概述列表 (Java 2 Platform SE 6)

JavaTM 2 Platform
Standard Ed. 6
所有类

软件包
java.applet
java.awt
java.awt.color
java.awt.datatransfer
java.awt.dnd
java.awt.event
java.awt.font
java.awt.geom
java.awt.im
java.awt.im.spi
java.awt.image
java.awt.image.renderable
java.awt.print
java.beans
java.beans.beancontext
java.io
java.lang
java.lang.annotation
java.lang.instrument
java.lang.management
java.lang.ref
java.lang.reflect
java.math
java.net
java.nio
java.nio.channels
java.nio.channels.spi
java.nio.charset
java.nio.charset.spi
java.rmi
java.rmi.activation
java.rmi.dgc
java.rmi.registry
java.rmi.server
java.security
java.security.acl
java.security.cert
java.security.interfaces
java.security.spec
java.sql
java.text
java.text.spi
java.util
java.util.concurrent
java.util.concurrent.atomic
java.util.concurrent.locks
java.util.jar
java.util.logging
java.util.prefs
java.util.regex
java.util.spi
java.util.zip
javax.accessibility
javax.activation
javax.activity
javax.annotation
javax.annotation.processing
javax.crypto
javax.crypto.interfaces
javax.crypto.spec
javax.imageio
javax.imageio.event
javax.imageio.metadata
javax.imageio.plugins.bmp
javax.imageio.plugins.jpeg
javax.imageio.spi
javax.imageio.stream
javax.jws
javax.jws.soap
javax.lang.model
javax.lang.model.element
javax.lang.model.type
javax.lang.model.util
javax.management
javax.management.loading
javax.management.modelmbean
javax.management.monitor
javax.management.openmbean
javax.management.relation
javax.management.remote
javax.management.remote.rmi
javax.management.timer
javax.naming
javax.naming.directory
javax.naming.event
javax.naming.ldap
javax.naming.spi
javax.net
javax.net.ssl
javax.print
javax.print.attribute
javax.print.attribute.standard
javax.print.event
javax.rmi
javax.rmi.CORBA
javax.rmi.ssl
javax.script
javax.security.auth
javax.security.auth.callback
javax.security.auth.kerberos
javax.security.auth.login
javax.security.auth.spi
javax.security.auth.x500
javax.security.cert
javax.security.sasl
javax.sound.midi
javax.sound.midi.spi
javax.sound.sampled
javax.sound.sampled.spi
javax.sql
javax.sql.rowset
javax.sql.rowset.serial
javax.sql.rowset.spi
javax.swing
javax.swing.border
javax.swing.colorchooser
javax.swing.event
javax.swing.filechooser
javax.swing.plaf
javax.swing.plaf.basic
javax.swing.plaf.metal
javax.swing.plaf.multi
javax.swing.plaf.synth
javax.swing.table
javax.swing.text
javax.swing.text.html
javax.swing.text.html.parser
javax.swing.text.rtf
javax.swing.tree
javax.swing.undo
javax.tools
javax.transaction
javax.transaction.xa
javax.xml
javax.xml.bind
javax.xml.bind.annotation
javax.xml.bind.annotation.adapters
javax.xml.bind.attachment
javax.xml.bind.helpers
javax.xml.bind.util
javax.xml.crypto
javax.xml.crypto.dom
javax.xml.crypto.dsig
javax.xml.crypto.dsig.dom
javax.xml.crypto.dsig.keyinfo
javax.xml.crypto.dsig.spec
javax.xml.datatype
javax.xml.namespace
javax.xml.parsers
javax.xml.soap
javax.xml.stream
javax.xml.stream.events
javax.xml.stream.util
javax.xml.transform
javax.xml.transform.dom
javax.xml.transform.sax
javax.xml.transform.stax
javax.xml.transform.stream
javax.xml.validation
javax.xml.ws
javax.xml.ws.handler
javax.xml.ws.handler.soap
javax.xml.ws.http
javax.xml.ws.soap
javax.xml.ws.spi
javax.xml.xpath
org.ietf.jgss
org.omg.CORBA
org.omg.CORBA_2_3
org.omg.CORBA_2_3.portable
org.omg.CORBA.DynAnyPackage
org.omg.CORBA.ORBPackage
org.omg.CORBA.portable
org.omg.CORBA.TypeCodePackage
org.omg.CosNaming
org.omg.CosNaming.NamingContextExtPackage
org.omg.CosNaming.NamingContextPackage
org.omg.Dynamic
org.omg.DynamicAny
org.omg.DynamicAny.DynAnyFactoryPackage
org.omg.DynamicAny.DynAnyPackage
org.omg.IOP
org.omg.IOP.CodecFactoryPackage
org.omg.IOP.CodecPackage
org.omg.Messaging
org.omg.PortableInterceptor
org.omg.PortableInterceptor.ORBInitInfoPackage
org.omg.PortableServer
org.omg.PortableServer.CurrentPackage
org.omg.PortableServer.POAManagerPackage
org.omg.PortableServer.POAPackage
org.omg.PortableServer.portable
org.omg.PortableServer.ServantLocatorPackage
org.omg.SendingContext
org.omg.stub.java.rmi
org.w3c.dom
org.w3c.dom.bootstrap
org.w3c.dom.events
org.w3c.dom.ls
org.xml.sax
org.xml.sax.ext
org.xml.sax.helpers


常量字段值 (Java 2 Platform SE 6)

概述 软件包 类 使用 树 已过时 索引 帮助
上一个 下一个 框架 无框架

常量字段值

目录
  • java.awt.*
  • java.beans.*
  • java.io.*
  • java.lang.*
  • java.math.*
  • java.net.*
  • java.nio.*
  • java.rmi.*
  • java.security.*
  • java.sql.*
  • java.text.*
  • java.util.*
  • javax.accessibility.*
  • javax.crypto.*
  • javax.imageio.*
  • javax.management.*
  • javax.naming.*
  • javax.print.*
  • javax.script.*
  • javax.security.*
  • javax.sound.*
  • javax.sql.*
  • javax.swing.*
  • javax.tools.*
  • javax.transaction.*
  • javax.xml.*
  • org.ietf.*
  • org.omg.*
  • org.w3c.*
  • org.xml.*
java.awt.*

java.awt.Adjustable
public static final int | HORIZONTAL | 0
public static final int | NO_ORIENTATION | 2
public static final int | VERTICAL | 1

java.awt.AlphaComposite
public static final int | CLEAR | 1
public static final int | DST | 9
public static final int | DST_ATOP | 11
public static final int | DST_IN | 6
public static final int | DST_OUT | 8
public static final int | DST_OVER | 4
public static final int | SRC | 2
public static final int | SRC_ATOP | 10
public static final int | SRC_IN | 5
public static final int | SRC_OUT | 7
public static final int | SRC_OVER | 3
public static final int | XOR | 12

java.awt.AWTEvent
public static final long | ACTION_EVENT_MASK | 128L
public static final long | ADJUSTMENT_EVENT_MASK | 256L
public static final long | COMPONENT_EVENT_MASK | 1L
public static final long | CONTAINER_EVENT_MASK | 2L
public static final long | FOCUS_EVENT_MASK | 4L
public static final long | HIERARCHY_BOUNDS_EVENT_MASK | 65536L
public static final long | HIERARCHY_EVENT_MASK | 32768L
public static final long | INPUT_METHOD_EVENT_MASK | 2048L
public static final long | INVOCATION_EVENT_MASK | 16384L
public static final long | ITEM_EVENT_MASK | 512L
public static final long | KEY_EVENT_MASK | 8L
public static final long | MOUSE_EVENT_MASK | 16L
public static final long | MOUSE_MOTION_EVENT_MASK | 32L
public static final long | MOUSE_WHEEL_EVENT_MASK | 131072L
public static final long | PAINT_EVENT_MASK | 8192L
public static final int | RESERVED_ID_MAX | 1999
public static final long | TEXT_EVENT_MASK | 1024L
public static final long | WINDOW_EVENT_MASK | 64L
public static final long | WINDOW_FOCUS_EVENT_MASK | 524288L
public static final long | WINDOW_STATE_EVENT_MASK | 262144L

java.awt.BasicStroke
public static final int | CAP_BUTT | 0
public static final int | CAP_ROUND | 1
public static final int | CAP_SQUARE | 2
public static final int | JOIN_BEVEL | 2
public static final int | JOIN_MITER | 0
public static final int | JOIN_ROUND | 1

java.awt.BorderLayout
public static final String | AFTER_LAST_LINE | "Last"
public static final String | AFTER_LINE_ENDS | "After"
public static final String | BEFORE_FIRST_LINE | "First"
public static final String | BEFORE_LINE_BEGINS | "Before"
public static final String | CENTER | "Center"
public static final String | EAST | "East"
public static final String | LINE_END | "After"
public static final String | LINE_START | "Before"
public static final String | NORTH | "North"
public static final String | PAGE_END | "Last"
public static final String | PAGE_START | "First"
public static final String | SOUTH | "South"
public static final String | WEST | "West"

java.awt.Component
public static final float | BOTTOM_ALIGNMENT | 1.0f
public static final float | CENTER_ALIGNMENT | 0.5f
public static final float | LEFT_ALIGNMENT | 0.0f
public static final float | RIGHT_ALIGNMENT | 1.0f
public static final float | TOP_ALIGNMENT | 0.0f

java.awt.Cursor
public static final int | CROSSHAIR_CURSOR | 1
public static final int | CUSTOM_CURSOR | -1
public static final int | DEFAULT_CURSOR | 0
public static final int | E_RESIZE_CURSOR | 11
public static final int | HAND_CURSOR | 12
public static final int | MOVE_CURSOR | 13
public static final int | N_RESIZE_CURSOR | 8
public static final int | NE_RESIZE_CURSOR | 7
public static final int | NW_RESIZE_CURSOR | 6
public static final int | S_RESIZE_CURSOR | 9
public static final int | SE_RESIZE_CURSOR | 5
public static final int | SW_RESIZE_CURSOR | 4
public static final int | TEXT_CURSOR | 2
public static final int | W_RESIZE_CURSOR | 10
public static final int | WAIT_CURSOR | 3

java.awt.DisplayMode
public static final int | BIT_DEPTH_MULTI | -1
public static final int | REFRESH_RATE_UNKNOWN | 0

java.awt.Event
public static final int | ACTION_EVENT | 1001
public static final int | ALT_MASK | 8
public static final int | BACK_SPACE | 8
public static final int | CAPS_LOCK | 1022
public static final int | CTRL_MASK | 2
public static final int | DELETE | 127
public static final int | DOWN | 1005
public static final int | END | 1001
public static final int | ENTER | 10
public static final int | ESCAPE | 27
public static final int | F1 | 1008
public static final int | F10 | 1017
public static final int | F11 | 1018
public static final int | F12 | 1019
public static final int | F2 | 1009
public static final int | F3 | 1010
public static final int | F4 | 1011
public static final int | F5 | 1012
public static final int | F6 | 1013
public static final int | F7 | 1014
public static final int | F8 | 1015
public static final int | F9 | 1016
public static final int | GOT_FOCUS | 1004
public static final int | HOME | 1000
public static final int | INSERT | 1025
public static final int | KEY_ACTION | 403
public static final int | KEY_ACTION_RELEASE | 404
public static final int | KEY_PRESS | 401
public static final int | KEY_RELEASE | 402
public static final int | LEFT | 1006
public static final int | LIST_DESELECT | 702
public static final int | LIST_SELECT | 701
public static final int | LOAD_FILE | 1002
public static final int | LOST_FOCUS | 1005
public static final int | META_MASK | 4
public static final int | MOUSE_DOWN | 501
public static final int | MOUSE_DRAG | 506
public static final int | MOUSE_ENTER | 504
public static final int | MOUSE_EXIT | 505
public static final int | MOUSE_MOVE | 503
public static final int | MOUSE_UP | 502
public static final int | NUM_LOCK | 1023
public static final int | PAUSE | 1024
public static final int | PGDN | 1003
public static final int | PGUP | 1002
public static final int | PRINT_SCREEN | 1020
public static final int | RIGHT | 1007
public static final int | SAVE_FILE | 1003
public static final int | SCROLL_ABSOLUTE | 605
public static final int | SCROLL_BEGIN | 606
public static final int | SCROLL_END | 607
public static final int | SCROLL_LINE_DOWN | 602
public static final int | SCROLL_LINE_UP | 601
public static final int | SCROLL_LOCK | 1021
public static final int | SCROLL_PAGE_DOWN | 604
public static final int | SCROLL_PAGE_UP | 603
public static final int | SHIFT_MASK | 1
public static final int | TAB | 9
public static final int | UP | 1004
public static final int | WINDOW_DEICONIFY | 204
public static final int | WINDOW_DESTROY | 201
public static final int | WINDOW_EXPOSE | 202
public static final int | WINDOW_ICONIFY | 203
public static final int | WINDOW_MOVED | 205

java.awt.FileDialog
public static final int | LOAD | 0
public static final int | SAVE | 1

java.awt.FlowLayout
public static final int | CENTER | 1
public static final int | LEADING | 3
public static final int | LEFT | 0
public static final int | RIGHT | 2
public static final int | TRAILING | 4

java.awt.Font
public static final int | BOLD | 1
public static final int | CENTER_BASELINE | 1
public static final String | DIALOG | "Dialog"
public static final String | DIALOG_INPUT | "DialogInput"
public static final int | HANGING_BASELINE | 2
public static final int | ITALIC | 2
public static final int | LAYOUT_LEFT_TO_RIGHT | 0
public static final int | LAYOUT_NO_LIMIT_CONTEXT | 4
public static final int | LAYOUT_NO_START_CONTEXT | 2
public static final int | LAYOUT_RIGHT_TO_LEFT | 1
public static final String | MONOSPACED | "Monospaced"
public static final int | PLAIN | 0
public static final int | ROMAN_BASELINE | 0
public static final String | SANS_SERIF | "SansSerif"
public static final String | SERIF | "Serif"
public static final int | TRUETYPE_FONT | 0
public static final int | TYPE1_FONT | 1

java.awt.Frame
public static final int | CROSSHAIR_CURSOR | 1
public static final int | DEFAULT_CURSOR | 0
public static final int | E_RESIZE_CURSOR | 11
public static final int | HAND_CURSOR | 12
public static final int | ICONIFIED | 1
public static final int | MAXIMIZED_BOTH | 6
public static final int | MAXIMIZED_HORIZ | 2
public static final int | MAXIMIZED_VERT | 4
public static final int | MOVE_CURSOR | 13
public static final int | N_RESIZE_CURSOR | 8
public static final int | NE_RESIZE_CURSOR | 7
public static final int | NORMAL | 0
public static final int | NW_RESIZE_CURSOR | 6
public static final int | S_RESIZE_CURSOR | 9
public static final int | SE_RESIZE_CURSOR | 5
public static final int | SW_RESIZE_CURSOR | 4
public static final int | TEXT_CURSOR | 2
public static final int | W_RESIZE_CURSOR | 10
public static final int | WAIT_CURSOR | 3

java.awt.GraphicsConfigTemplate
public static final int | PREFERRED | 2
public static final int | REQUIRED | 1
public static final int | UNNECESSARY | 3

java.awt.GraphicsDevice
public static final int | TYPE_IMAGE_BUFFER | 2
public static final int | TYPE_PRINTER | 1
public static final int | TYPE_RASTER_SCREEN | 0

java.awt.GridBagConstraints
public static final int | ABOVE_BASELINE | 1024
public static final int | ABOVE_BASELINE_LEADING | 1280
public static final int | ABOVE_BASELINE_TRAILING | 1536
public static final int | BASELINE | 256
public static final int | BASELINE_LEADING | 512
public static final int | BASELINE_TRAILING | 768
public static final int | BELOW_BASELINE | 1792
public static final int | BELOW_BASELINE_LEADING | 2048
public static final int | BELOW_BASELINE_TRAILING | 2304
public static final int | BOTH | 1
public static final int | CENTER | 10
public static final int | EAST | 13
public static final int | FIRST_LINE_END | 24
public static final int | FIRST_LINE_START | 23
public static final int | HORIZONTAL | 2
public static final int | LAST_LINE_END | 26
public static final int | LAST_LINE_START | 25
public static final int | LINE_END | 22
public static final int | LINE_START | 21
public static final int | NONE | 0
public static final int | NORTH | 11
public static final int | NORTHEAST | 12
public static final int | NORTHWEST | 18
public static final int | PAGE_END | 20
public static final int | PAGE_START | 19
public static final int | RELATIVE | -1
public static final int | REMAINDER | 0
public static final int | SOUTH | 15
public static final int | SOUTHEAST | 14
public static final int | SOUTHWEST | 16
public static final int | VERTICAL | 3
public static final int | WEST | 17

java.awt.GridBagLayout
protected static final int | MAXGRIDSIZE | 512
protected static final int | MINSIZE | 1
protected static final int | PREFERREDSIZE | 2

java.awt.Image
public static final int | SCALE_AREA_AVERAGING | 16
public static final int | SCALE_DEFAULT | 1
public static final int | SCALE_FAST | 2
public static final int | SCALE_REPLICATE | 8
public static final int | SCALE_SMOOTH | 4

java.awt.KeyboardFocusManager
public static final int | BACKWARD_TRAVERSAL_KEYS | 1
public static final int | DOWN_CYCLE_TRAVERSAL_KEYS | 3
public static final int | FORWARD_TRAVERSAL_KEYS | 0
public static final int | UP_CYCLE_TRAVERSAL_KEYS | 2

java.awt.Label
public static final int | CENTER | 1
public static final int | LEFT | 0
public static final int | RIGHT | 2

java.awt.MediaTracker
public static final int | ABORTED | 2
public static final int | COMPLETE | 8
public static final int | ERRORED | 4
public static final int | LOADING | 1

java.awt.Scrollbar
public static final int | HORIZONTAL | 0
public static final int | VERTICAL | 1

java.awt.ScrollPane
public static final int | SCROLLBARS_ALWAYS | 1
public static final int | SCROLLBARS_AS_NEEDED | 0
public static final int | SCROLLBARS_NEVER | 2

java.awt.SystemColor
public static final int | ACTIVE_CAPTION | 1
public static final int | ACTIVE_CAPTION_BORDER | 3
public static final int | ACTIVE_CAPTION_TEXT | 2
public static final int | CONTROL | 17
public static final int | CONTROL_DK_SHADOW | 22
public static final int | CONTROL_HIGHLIGHT | 19
public static final int | CONTROL_LT_HIGHLIGHT | 20
public static final int | CONTROL_SHADOW | 21
public static final int | CONTROL_TEXT | 18
public static final int | DESKTOP | 0
public static final int | INACTIVE_CAPTION | 4
public static final int | INACTIVE_CAPTION_BORDER | 6
public static final int | INACTIVE_CAPTION_TEXT | 5
public static final int | INFO | 24
public static final int | INFO_TEXT | 25
public static final int | MENU | 10
public static final int | MENU_TEXT | 11
public static final int | NUM_COLORS | 26
public static final int | SCROLLBAR | 23
public static final int | TEXT | 12
public static final int | TEXT_HIGHLIGHT | 14
public static final int | TEXT_HIGHLIGHT_TEXT | 15
public static final int | TEXT_INACTIVE_TEXT | 16
public static final int | TEXT_TEXT | 13
public static final int | WINDOW | 7
public static final int | WINDOW_BORDER | 8
public static final int | WINDOW_TEXT | 9

java.awt.TextArea
public static final int | SCROLLBARS_BOTH | 0
public static final int | SCROLLBARS_HORIZONTAL_ONLY | 2
public static final int | SCROLLBARS_NONE | 3
public static final int | SCROLLBARS_VERTICAL_ONLY | 1

java.awt.Transparency
public static final int | BITMASK | 2
public static final int | OPAQUE | 1
public static final int | TRANSLUCENT | 3

java.awt.color.ColorSpace
public static final int | CS_CIEXYZ | 1001
public static final int | CS_GRAY | 1003
public static final int | CS_LINEAR_RGB | 1004
public static final int | CS_PYCC | 1002
public static final int | CS_sRGB | 1000
public static final int | TYPE_2CLR | 12
public static final int | TYPE_3CLR | 13
public static final int | TYPE_4CLR | 14
public static final int | TYPE_5CLR | 15
public static final int | TYPE_6CLR | 16
public static final int | TYPE_7CLR | 17
public static final int | TYPE_8CLR | 18
public static final int | TYPE_9CLR | 19
public static final int | TYPE_ACLR | 20
public static final int | TYPE_BCLR | 21
public static final int | TYPE_CCLR | 22
public static final int | TYPE_CMY | 11
public static final int | TYPE_CMYK | 9
public static final int | TYPE_DCLR | 23
public static final int | TYPE_ECLR | 24
public static final int | TYPE_FCLR | 25
public static final int | TYPE_GRAY | 6
public static final int | TYPE_HLS | 8
public static final int | TYPE_HSV | 7
public static final int | TYPE_Lab | 1
public static final int | TYPE_Luv | 2
public static final int | TYPE_RGB | 5
public static final int | TYPE_XYZ | 0
public static final int | TYPE_YCbCr | 3
public static final int | TYPE_Yxy | 4

java.awt.color.ICC_Profile
public static final int | CLASS_ABSTRACT | 5
public static final int | CLASS_COLORSPACECONVERSION | 4
public static final int | CLASS_DEVICELINK | 3
public static final int | CLASS_DISPLAY | 1
public static final int | CLASS_INPUT | 0
public static final int | CLASS_NAMEDCOLOR | 6
public static final int | CLASS_OUTPUT | 2
public static final int | icAbsoluteColorimetric | 3
public static final int | icCurveCount | 8
public static final int | icCurveData | 12
public static final int | icHdrAttributes | 56
public static final int | icHdrCmmId | 4
public static final int | icHdrColorSpace | 16
public static final int | icHdrCreator | 80
public static final int | icHdrDate | 24
public static final int | icHdrDeviceClass | 12
public static final int | icHdrFlags | 44
public static final int | icHdrIlluminant | 68
public static final int | icHdrMagic | 36
public static final int | icHdrManufacturer | 48
public static final int | icHdrModel | 52
public static final int | icHdrPcs | 20
public static final int | icHdrPlatform | 40
public static final int | icHdrProfileID | 84
public static final int | icHdrRenderingIntent | 64
public static final int | icHdrSize | 0
public static final int | icHdrVersion | 8
public static final int | icICCAbsoluteColorimetric | 3
public static final int | icMediaRelativeColorimetric | 1
public static final int | icPerceptual | 0
public static final int | icRelativeColorimetric | 1
public static final int | icSaturation | 2
public static final int | icSigAbstractClass | 1633842036
public static final int | icSigAToB0Tag | 1093812784
public static final int | icSigAToB1Tag | 1093812785
public static final int | icSigAToB2Tag | 1093812786
public static final int | icSigBlueColorantTag | 1649957210
public static final int | icSigBlueMatrixColumnTag | 1649957210
public static final int | icSigBlueTRCTag | 1649693251
public static final int | icSigBToA0Tag | 1110589744
public static final int | icSigBToA1Tag | 1110589745
public static final int | icSigBToA2Tag | 1110589746
public static final int | icSigCalibrationDateTimeTag | 1667329140
public static final int | icSigCharTargetTag | 1952543335
public static final int | icSigChromaticAdaptationTag | 1667785060
public static final int | icSigChromaticityTag | 1667789421
public static final int | icSigCmyData | 1129142560
public static final int | icSigCmykData | 1129142603
public static final int | icSigColorantOrderTag | 1668051567
public static final int | icSigColorantTableTag | 1668051572
public static final int | icSigColorSpaceClass | 1936744803
public static final int | icSigCopyrightTag | 1668313716
public static final int | icSigCrdInfoTag | 1668441193
public static final int | icSigDeviceMfgDescTag | 1684893284
public static final int | icSigDeviceModelDescTag | 1684890724
public static final int | icSigDeviceSettingsTag | 1684371059
public static final int | icSigDisplayClass | 1835955314
public static final int | icSigGamutTag | 1734438260
public static final int | icSigGrayData | 1196573017
public static final int | icSigGrayTRCTag | 1800688195
public static final int | icSigGreenColorantTag | 1733843290
public static final int | icSigGreenMatrixColumnTag | 1733843290
public static final int | icSigGreenTRCTag | 1733579331
public static final int | icSigHead | 1751474532
public static final int | icSigHlsData | 1212961568
public static final int | icSigHsvData | 1213421088
public static final int | icSigInputClass | 1935896178
public static final int | icSigLabData | 1281450528
public static final int | icSigLinkClass | 1818848875
public static final int | icSigLuminanceTag | 1819635049
public static final int | icSigLuvData | 1282766368
public static final int | icSigMeasurementTag | 1835360627
public static final int | icSigMediaBlackPointTag | 1651208308
public static final int | icSigMediaWhitePointTag | 2004119668
public static final int | icSigNamedColor2Tag | 1852009522
public static final int | icSigNamedColorClass | 1852662636
public static final int | icSigOutputClass | 1886549106
public static final int | icSigOutputResponseTag | 1919251312
public static final int | icSigPreview0Tag | 1886545200
public static final int | icSigPreview1Tag | 1886545201
public static final int | icSigPreview2Tag | 1886545202
public static final int | icSigProfileDescriptionTag | 1684370275
public static final int | icSigProfileSequenceDescTag | 1886610801
public static final int | icSigPs2CRD0Tag | 1886610480
public static final int | icSigPs2CRD1Tag | 1886610481
public static final int | icSigPs2CRD2Tag | 1886610482
public static final int | icSigPs2CRD3Tag | 1886610483
public static final int | icSigPs2CSATag | 1886597747
public static final int | icSigPs2RenderingIntentTag | 1886597737
public static final int | icSigRedColorantTag | 1918392666
public static final int | icSigRedMatrixColumnTag | 1918392666
public static final int | icSigRedTRCTag | 1918128707
public static final int | icSigRgbData | 1380401696
public static final int | icSigScreeningDescTag | 1935897188
public static final int | icSigScreeningTag | 1935897198
public static final int | icSigSpace2CLR | 843271250
public static final int | icSigSpace3CLR | 860048466
public static final int | icSigSpace4CLR | 876825682
public static final int | icSigSpace5CLR | 893602898
public static final int | icSigSpace6CLR | 910380114
public static final int | icSigSpace7CLR | 927157330
public static final int | icSigSpace8CLR | 943934546
public static final int | icSigSpace9CLR | 960711762
public static final int | icSigSpaceACLR | 1094929490
public static final int | icSigSpaceBCLR | 1111706706
public static final int | icSigSpaceCCLR | 1128483922
public static final int | icSigSpaceDCLR | 1145261138
public static final int | icSigSpaceECLR | 1162038354
public static final int | icSigSpaceFCLR | 1178815570
public static final int | icSigTechnologyTag | 1952801640
public static final int | icSigUcrBgTag | 1650877472
public static final int | icSigViewingCondDescTag | 1987405156
public static final int | icSigViewingConditionsTag | 1986618743
public static final int | icSigXYZData | 1482250784
public static final int | icSigYCbCrData | 1497588338
public static final int | icSigYxyData | 1501067552
public static final int | icTagReserved | 4
public static final int | icTagType | 0
public static final int | icXYZNumberX | 8

java.awt.color.ICC_ProfileRGB
public static final int | BLUECOMPONENT | 2
public static final int | GREENCOMPONENT | 1
public static final int | REDCOMPONENT | 0

java.awt.datatransfer.DataFlavor
public static final String | javaJVMLocalObjectMimeType | "application/x-java-jvm-local-objectref"
public static final String | javaRemoteObjectMimeType | "application/x-java-remote-object"
public static final String | javaSerializedObjectMimeType | "application/x-java-serialized-object"

java.awt.dnd.DnDConstants
public static final int | ACTION_COPY | 1
public static final int | ACTION_COPY_OR_MOVE | 3
public static final int | ACTION_LINK | 1073741824
public static final int | ACTION_MOVE | 2
public static final int | ACTION_NONE | 0
public static final int | ACTION_REFERENCE | 1073741824

java.awt.dnd.DragSourceContext
protected static final int | CHANGED | 3
protected static final int | DEFAULT | 0
protected static final int | ENTER | 1
protected static final int | OVER | 2

java.awt.event.ActionEvent
public static final int | ACTION_FIRST | 1001
public static final int | ACTION_LAST | 1001
public static final int | ACTION_PERFORMED | 1001
public static final int | ALT_MASK | 8
public static final int | CTRL_MASK | 2
public static final int | META_MASK | 4
public static final int | SHIFT_MASK | 1

java.awt.event.AdjustmentEvent
public static final int | ADJUSTMENT_FIRST | 601
public static final int | ADJUSTMENT_LAST | 601
public static final int | ADJUSTMENT_VALUE_CHANGED | 601
public static final int | BLOCK_DECREMENT | 3
public static final int | BLOCK_INCREMENT | 4
public static final int | TRACK | 5
public static final int | UNIT_DECREMENT | 2
public static final int | UNIT_INCREMENT | 1

java.awt.event.ComponentEvent
public static final int | COMPONENT_FIRST | 100
public static final int | COMPONENT_HIDDEN | 103
public static final int | COMPONENT_LAST | 103
public static final int | COMPONENT_MOVED | 100
public static final int | COMPONENT_RESIZED | 101
public static final int | COMPONENT_SHOWN | 102

java.awt.event.ContainerEvent
public static final int | COMPONENT_ADDED | 300
public static final int | COMPONENT_REMOVED | 301
public static final int | CONTAINER_FIRST | 300
public static final int | CONTAINER_LAST | 301

java.awt.event.FocusEvent
public static final int | FOCUS_FIRST | 1004
public static final int | FOCUS_GAINED | 1004
public static final int | FOCUS_LAST | 1005
public static final int | FOCUS_LOST | 1005

java.awt.event.HierarchyEvent
public static final int | ANCESTOR_MOVED | 1401
public static final int | ANCESTOR_RESIZED | 1402
public static final int | DISPLAYABILITY_CHANGED | 2
public static final int | HIERARCHY_CHANGED | 1400
public static final int | HIERARCHY_FIRST | 1400
public static final int | HIERARCHY_LAST | 1402
public static final int | PARENT_CHANGED | 1
public static final int | SHOWING_CHANGED | 4

java.awt.event.InputEvent
public static final int | ALT_DOWN_MASK | 512
public static final int | ALT_GRAPH_DOWN_MASK | 8192
public static final int | ALT_GRAPH_MASK | 32
public static final int | ALT_MASK | 8
public static final int | BUTTON1_DOWN_MASK | 1024
public static final int | BUTTON1_MASK | 16
public static final int | BUTTON2_DOWN_MASK | 2048
public static final int | BUTTON2_MASK | 8
public static final int | BUTTON3_DOWN_MASK | 4096
public static final int | BUTTON3_MASK | 4
public static final int | CTRL_DOWN_MASK | 128
public static final int | CTRL_MASK | 2
public static final int | META_DOWN_MASK | 256
public static final int | META_MASK | 4
public static final int | SHIFT_DOWN_MASK | 64
public static final int | SHIFT_MASK | 1

java.awt.event.InputMethodEvent
public static final int | CARET_POSITION_CHANGED | 1101
public static final int | INPUT_METHOD_FIRST | 1100
public static final int | INPUT_METHOD_LAST | 1101
public static final int | INPUT_METHOD_TEXT_CHANGED | 1100

java.awt.event.InvocationEvent
public static final int | INVOCATION_DEFAULT | 1200
public static final int | INVOCATION_FIRST | 1200
public static final int | INVOCATION_LAST | 1200

java.awt.event.ItemEvent
public static final int | DESELECTED | 2
public static final int | ITEM_FIRST | 701
public static final int | ITEM_LAST | 701
public static final int | ITEM_STATE_CHANGED | 701
public static final int | SELECTED | 1

java.awt.event.KeyEvent
public static final char | CHAR_UNDEFINED | 65535
public static final int | KEY_FIRST | 400
public static final int | KEY_LAST | 402
public static final int | KEY_LOCATION_LEFT | 2
public static final int | KEY_LOCATION_NUMPAD | 4
public static final int | KEY_LOCATION_RIGHT | 3
public static final int | KEY_LOCATION_STANDARD | 1
public static final int | KEY_LOCATION_UNKNOWN | 0
public static final int | KEY_PRESSED | 401
public static final int | KEY_RELEASED | 402
public static final int | KEY_TYPED | 400
public static final int | VK_0 | 48
public static final int | VK_1 | 49
public static final int | VK_2 | 50
public static final int | VK_3 | 51
public static final int | VK_4 | 52
public static final int | VK_5 | 53
public static final int | VK_6 | 54
public static final int | VK_7 | 55
public static final int | VK_8 | 56
public static final int | VK_9 | 57
public static final int | VK_A | 65
public static final int | VK_ACCEPT | 30
public static final int | VK_ADD | 107
public static final int | VK_AGAIN | 65481
public static final int | VK_ALL_CANDIDATES | 256
public static final int | VK_ALPHANUMERIC | 240
public static final int | VK_ALT | 18
public static final int | VK_ALT_GRAPH | 65406
public static final int | VK_AMPERSAND | 150
public static final int | VK_ASTERISK | 151
public static final int | VK_AT | 512
public static final int | VK_B | 66
public static final int | VK_BACK_QUOTE | 192
public static final int | VK_BACK_SLASH | 92
public static final int | VK_BACK_SPACE | 8
public static final int | VK_BEGIN | 65368
public static final int | VK_BRACELEFT | 161
public static final int | VK_BRACERIGHT | 162
public static final int | VK_C | 67
public static final int | VK_CANCEL | 3
public static final int | VK_CAPS_LOCK | 20
public static final int | VK_CIRCUMFLEX | 514
public static final int | VK_CLEAR | 12
public static final int | VK_CLOSE_BRACKET | 93
public static final int | VK_CODE_INPUT | 258
public static final int | VK_COLON | 513
public static final int | VK_COMMA | 44
public static final int | VK_COMPOSE | 65312
public static final int | VK_CONTEXT_MENU | 525
public static final int | VK_CONTROL | 17
public static final int | VK_CONVERT | 28
public static final int | VK_COPY | 65485
public static final int | VK_CUT | 65489
public static final int | VK_D | 68
public static final int | VK_DEAD_ABOVEDOT | 134
public static final int | VK_DEAD_ABOVERING | 136
public static final int | VK_DEAD_ACUTE | 129
public static final int | VK_DEAD_BREVE | 133
public static final int | VK_DEAD_CARON | 138
public static final int | VK_DEAD_CEDILLA | 139
public static final int | VK_DEAD_CIRCUMFLEX | 130
public static final int | VK_DEAD_DIAERESIS | 135
public static final int | VK_DEAD_DOUBLEACUTE | 137
public static final int | VK_DEAD_GRAVE | 128
public static final int | VK_DEAD_IOTA | 141
public static final int | VK_DEAD_MACRON | 132
public static final int | VK_DEAD_OGONEK | 140
public static final int | VK_DEAD_SEMIVOICED_SOUND | 143
public static final int | VK_DEAD_TILDE | 131
public static final int | VK_DEAD_VOICED_SOUND | 142
public static final int | VK_DECIMAL | 110
public static final int | VK_DELETE | 127
public static final int | VK_DIVIDE | 111
public static final int | VK_DOLLAR | 515
public static final int | VK_DOWN | 40
public static final int | VK_E | 69
public static final int | VK_END | 35
public static final int | VK_ENTER | 10
public static final int | VK_EQUALS | 61
public static final int | VK_ESCAPE | 27
public static final int | VK_EURO_SIGN | 516
public static final int | VK_EXCLAMATION_MARK | 517
public static final int | VK_F | 70
public static final int | VK_F1 | 112
public static final int | VK_F10 | 121
public static final int | VK_F11 | 122
public static final int | VK_F12 | 123
public static final int | VK_F13 | 61440
public static final int | VK_F14 | 61441
public static final int | VK_F15 | 61442
public static final int | VK_F16 | 61443
public static final int | VK_F17 | 61444
public static final int | VK_F18 | 61445
public static final int | VK_F19 | 61446
public static final int | VK_F2 | 113
public static final int | VK_F20 | 61447
public static final int | VK_F21 | 61448
public static final int | VK_F22 | 61449
public static final int | VK_F23 | 61450
public static final int | VK_F24 | 61451
public static final int | VK_F3 | 114
public static final int | VK_F4 | 115
public static final int | VK_F5 | 116
public static final int | VK_F6 | 117
public static final int | VK_F7 | 118
public static final int | VK_F8 | 119
public static final int | VK_F9 | 120
public static final int | VK_FINAL | 24
public static final int | VK_FIND | 65488
public static final int | VK_FULL_WIDTH | 243
public static final int | VK_G | 71
public static final int | VK_GREATER | 160
public static final int | VK_H | 72
public static final int | VK_HALF_WIDTH | 244
public static final int | VK_HELP | 156
public static final int | VK_HIRAGANA | 242
public static final int | VK_HOME | 36
public static final int | VK_I | 73
public static final int | VK_INPUT_METHOD_ON_OFF | 263
public static final int | VK_INSERT | 155
public static final int | VK_INVERTED_EXCLAMATION_MARK | 518
public static final int | VK_J | 74
public static final int | VK_JAPANESE_HIRAGANA | 260
public static final int | VK_JAPANESE_KATAKANA | 259
public static final int | VK_JAPANESE_ROMAN | 261
public static final int | VK_K | 75
public static final int | VK_KANA | 21
public static final int | VK_KANA_LOCK | 262
public static final int | VK_KANJI | 25
public static final int | VK_KATAKANA | 241
public static final int | VK_KP_DOWN | 225
public static final int | VK_KP_LEFT | 226
public static final int | VK_KP_RIGHT | 227
public static final int | VK_KP_UP | 224
public static final int | VK_L | 76
public static final int | VK_LEFT | 37
public static final int | VK_LEFT_PARENTHESIS | 519
public static final int | VK_LESS | 153
public static final int | VK_M | 77
public static final int | VK_META | 157
public static final int | VK_MINUS | 45
public static final int | VK_MODECHANGE | 31
public static final int | VK_MULTIPLY | 106
public static final int | VK_N | 78
public static final int | VK_NONCONVERT | 29
public static final int | VK_NUM_LOCK | 144
public static final int | VK_NUMBER_SIGN | 520
public static final int | VK_NUMPAD0 | 96
public static final int | VK_NUMPAD1 | 97
public static final int | VK_NUMPAD2 | 98
public static final int | VK_NUMPAD3 | 99
public static final int | VK_NUMPAD4 | 100
public static final int | VK_NUMPAD5 | 101
public static final int | VK_NUMPAD6 | 102
public static final int | VK_NUMPAD7 | 103
public static final int | VK_NUMPAD8 | 104
public static final int | VK_NUMPAD9 | 105
public static final int | VK_O | 79
public static final int | VK_OPEN_BRACKET | 91
public static final int | VK_P | 80
public static final int | VK_PAGE_DOWN | 34
public static final int | VK_PAGE_UP | 33
public static final int | VK_PASTE | 65487
public static final int | VK_PAUSE | 19
public static final int | VK_PERIOD | 46
public static final int | VK_PLUS | 521
public static final int | VK_PREVIOUS_CANDIDATE | 257
public static final int | VK_PRINTSCREEN | 154
public static final int | VK_PROPS | 65482
public static final int | VK_Q | 81
public static final int | VK_QUOTE | 222
public static final int | VK_QUOTEDBL | 152
public static final int | VK_R | 82
public static final int | VK_RIGHT | 39
public static final int | VK_RIGHT_PARENTHESIS | 522
public static final int | VK_ROMAN_CHARACTERS | 245
public static final int | VK_S | 83
public static final int | VK_SCROLL_LOCK | 145
public static final int | VK_SEMICOLON | 59
public static final int | VK_SEPARATER | 108
public static final int | VK_SEPARATOR | 108
public static final int | VK_SHIFT | 16
public static final int | VK_SLASH | 47
public static final int | VK_SPACE | 32
public static final int | VK_STOP | 65480
public static final int | VK_SUBTRACT | 109
public static final int | VK_T | 84
public static final int | VK_TAB | 9
public static final int | VK_U | 85
public static final int | VK_UNDEFINED | 0
public static final int | VK_UNDERSCORE | 523
public static final int | VK_UNDO | 65483
public static final int | VK_UP | 38
public static final int | VK_V | 86
public static final int | VK_W | 87
public static final int | VK_WINDOWS | 524
public static final int | VK_X | 88
public static final int | VK_Y | 89
public static final int | VK_Z | 90

java.awt.event.MouseEvent
public static final int | BUTTON1 | 1
public static final int | BUTTON2 | 2
public static final int | BUTTON3 | 3
public static final int | MOUSE_CLICKED | 500
public static final int | MOUSE_DRAGGED | 506
public static final int | MOUSE_ENTERED | 504
public static final int | MOUSE_EXITED | 505
public static final int | MOUSE_FIRST | 500
public static final int | MOUSE_LAST | 507
public static final int | MOUSE_MOVED | 503
public static final int | MOUSE_PRESSED | 501
public static final int | MOUSE_RELEASED | 502
public static final int | MOUSE_WHEEL | 507
public static final int | NOBUTTON | 0

java.awt.event.MouseWheelEvent
public static final int | WHEEL_BLOCK_SCROLL | 1
public static final int | WHEEL_UNIT_SCROLL | 0

java.awt.event.PaintEvent
public static final int | PAINT | 800
public static final int | PAINT_FIRST | 800
public static final int | PAINT_LAST | 801
public static final int | UPDATE | 801

java.awt.event.TextEvent
public static final int | TEXT_FIRST | 900
public static final int | TEXT_LAST | 900
public static final int | TEXT_VALUE_CHANGED | 900

java.awt.event.WindowEvent
public static final int | WINDOW_ACTIVATED | 205
public static final int | WINDOW_CLOSED | 202
public static final int | WINDOW_CLOSING | 201
public static final int | WINDOW_DEACTIVATED | 206
public static final int | WINDOW_DEICONIFIED | 204
public static final int | WINDOW_FIRST | 200
public static final int | WINDOW_GAINED_FOCUS | 207
public static final int | WINDOW_ICONIFIED | 203
public static final int | WINDOW_LAST | 209
public static final int | WINDOW_LOST_FOCUS | 208
public static final int | WINDOW_OPENED | 200
public static final int | WINDOW_STATE_CHANGED | 209

java.awt.font.GlyphJustificationInfo
public static final int | PRIORITY_INTERCHAR | 2
public static final int | PRIORITY_KASHIDA | 0
public static final int | PRIORITY_NONE | 3
public static final int | PRIORITY_WHITESPACE | 1

java.awt.font.GlyphMetrics
public static final byte | COMBINING | 2
public static final byte | COMPONENT | 3
public static final byte | LIGATURE | 1
public static final byte | STANDARD | 0
public static final byte | WHITESPACE | 4

java.awt.font.GlyphVector
public static final int | FLAG_COMPLEX_GLYPHS | 8
public static final int | FLAG_HAS_POSITION_ADJUSTMENTS | 2
public static final int | FLAG_HAS_TRANSFORMS | 1
public static final int | FLAG_MASK | 15
public static final int | FLAG_RUN_RTL | 4

java.awt.font.GraphicAttribute
public static final int | BOTTOM_ALIGNMENT | -2
public static final int | CENTER_BASELINE | 1
public static final int | HANGING_BASELINE | 2
public static final int | ROMAN_BASELINE | 0
public static final int | TOP_ALIGNMENT | -1

java.awt.font.NumericShaper
public static final int | ALL_RANGES | 524287
public static final int | ARABIC | 2
public static final int | BENGALI | 16
public static final int | DEVANAGARI | 8
public static final int | EASTERN_ARABIC | 4
public static final int | ETHIOPIC | 65536
public static final int | EUROPEAN | 1
public static final int | GUJARATI | 64
public static final int | GURMUKHI | 32
public static final int | KANNADA | 1024
public static final int | KHMER | 131072
public static final int | LAO | 8192
public static final int | MALAYALAM | 2048
public static final int | MONGOLIAN | 262144
public static final int | MYANMAR | 32768
public static final int | ORIYA | 128
public static final int | TAMIL | 256
public static final int | TELUGU | 512
public static final int | THAI | 4096
public static final int | TIBETAN | 16384

java.awt.font.OpenType
public static final int | TAG_ACNT | 1633906292
public static final int | TAG_AVAR | 1635148146
public static final int | TAG_BASE | 1111577413
public static final int | TAG_BDAT | 1650745716
public static final int | TAG_BLOC | 1651273571
public static final int | TAG_BSLN | 1651731566
public static final int | TAG_CFF | 1128678944
public static final int | TAG_CMAP | 1668112752
public static final int | TAG_CVAR | 1668702578
public static final int | TAG_CVT | 1668707360
public static final int | TAG_DSIG | 1146308935
public static final int | TAG_EBDT | 1161970772
public static final int | TAG_EBLC | 1161972803
public static final int | TAG_EBSC | 1161974595
public static final int | TAG_FDSC | 1717859171
public static final int | TAG_FEAT | 1717920116
public static final int | TAG_FMTX | 1718449272
public static final int | TAG_FPGM | 1718642541
public static final int | TAG_FVAR | 1719034226
public static final int | TAG_GASP | 1734439792
public static final int | TAG_GDEF | 1195656518
public static final int | TAG_GLYF | 1735162214
public static final int | TAG_GPOS | 1196445523
public static final int | TAG_GSUB | 1196643650
public static final int | TAG_GVAR | 1735811442
public static final int | TAG_HDMX | 1751412088
public static final int | TAG_HEAD | 1751474532
public static final int | TAG_HHEA | 1751672161
public static final int | TAG_HMTX | 1752003704
public static final int | TAG_JSTF | 1246975046
public static final int | TAG_JUST | 1786082164
public static final int | TAG_KERN | 1801810542
public static final int | TAG_LCAR | 1818452338
public static final int | TAG_LOCA | 1819239265
public static final int | TAG_LTSH | 1280594760
public static final int | TAG_MAXP | 1835104368
public static final int | TAG_MMFX | 1296909912
public static final int | TAG_MMSD | 1296913220
public static final int | TAG_MORT | 1836020340
public static final int | TAG_NAME | 1851878757
public static final int | TAG_OPBD | 1836020340
public static final int | TAG_OS2 | 1330851634
public static final int | TAG_PCLT | 1346587732
public static final int | TAG_POST | 1886352244
public static final int | TAG_PREP | 1886545264
public static final int | TAG_PROP | 1886547824
public static final int | TAG_TRAK | 1953653099
public static final int | TAG_TYP1 | 1954115633
public static final int | TAG_VDMX | 1447316824
public static final int | TAG_VHEA | 1986553185
public static final int | TAG_VMTX | 1986884728

java.awt.font.ShapeGraphicAttribute
public static final boolean | FILL | false
public static final boolean | STROKE | true

java.awt.geom.AffineTransform
public static final int | TYPE_FLIP | 64
public static final int | TYPE_GENERAL_ROTATION | 16
public static final int | TYPE_GENERAL_SCALE | 4
public static final int | TYPE_GENERAL_TRANSFORM | 32
public static final int | TYPE_IDENTITY | 0
public static final int | TYPE_MASK_ROTATION | 24
public static final int | TYPE_MASK_SCALE | 6
public static final int | TYPE_QUADRANT_ROTATION | 8
public static final int | TYPE_TRANSLATION | 1
public static final int | TYPE_UNIFORM_SCALE | 2

java.awt.geom.Arc2D
public static final int | CHORD | 1
public static final int | OPEN | 0
public static final int | PIE | 2

java.awt.geom.Path2D
public static final int | WIND_EVEN_ODD | 0
public static final int | WIND_NON_ZERO | 1

java.awt.geom.PathIterator
public static final int | SEG_CLOSE | 4
public static final int | SEG_CUBICTO | 3
public static final int | SEG_LINETO | 1
public static final int | SEG_MOVETO | 0
public static final int | SEG_QUADTO | 2
public static final int | WIND_EVEN_ODD | 0
public static final int | WIND_NON_ZERO | 1

java.awt.geom.Rectangle2D
public static final int | OUT_BOTTOM | 8
public static final int | OUT_LEFT | 1
public static final int | OUT_RIGHT | 4
public static final int | OUT_TOP | 2

java.awt.im.InputMethodHighlight
public static final int | CONVERTED_TEXT | 1
public static final int | RAW_TEXT | 0

java.awt.image.AffineTransformOp
public static final int | TYPE_BICUBIC | 3
public static final int | TYPE_BILINEAR | 2
public static final int | TYPE_NEAREST_NEIGHBOR | 1

java.awt.image.BufferedImage
public static final int | TYPE_3BYTE_BGR | 5
public static final int | TYPE_4BYTE_ABGR | 6
public static final int | TYPE_4BYTE_ABGR_PRE | 7
public static final int | TYPE_BYTE_BINARY | 12
public static final int | TYPE_BYTE_GRAY | 10
public static final int | TYPE_BYTE_INDEXED | 13
public static final int | TYPE_CUSTOM | 0
public static final int | TYPE_INT_ARGB | 2
public static final int | TYPE_INT_ARGB_PRE | 3
public static final int | TYPE_INT_BGR | 4
public static final int | TYPE_INT_RGB | 1
public static final int | TYPE_USHORT_555_RGB | 9
public static final int | TYPE_USHORT_565_RGB | 8
public static final int | TYPE_USHORT_GRAY | 11

java.awt.image.ConvolveOp
public static final int | EDGE_NO_OP | 1
public static final int | EDGE_ZERO_FILL | 0

java.awt.image.DataBuffer
public static final int | TYPE_BYTE | 0
public static final int | TYPE_DOUBLE | 5
public static final int | TYPE_FLOAT | 4
public static final int | TYPE_INT | 3
public static final int | TYPE_SHORT | 2
public static final int | TYPE_UNDEFINED | 32
public static final int | TYPE_USHORT | 1

java.awt.image.ImageConsumer
public static final int | COMPLETESCANLINES | 4
public static final int | IMAGEABORTED | 4
public static final int | IMAGEERROR | 1
public static final int | RANDOMPIXELORDER | 1
public static final int | SINGLEFRAME | 16
public static final int | SINGLEFRAMEDONE | 2
public static final int | SINGLEPASS | 8
public static final int | STATICIMAGEDONE | 3
public static final int | TOPDOWNLEFTRIGHT | 2

java.awt.image.ImageObserver
public static final int | ABORT | 128
public static final int | ALLBITS | 32
public static final int | ERROR | 64
public static final int | FRAMEBITS | 16
public static final int | HEIGHT | 2
public static final int | PROPERTIES | 4
public static final int | SOMEBITS | 8
public static final int | WIDTH | 1

java.awt.image.VolatileImage
public static final int | IMAGE_INCOMPATIBLE | 2
public static final int | IMAGE_OK | 0
public static final int | IMAGE_RESTORED | 1

java.awt.image.renderable.RenderableImage
public static final String HINTS_OBSERVED "HINTS_OBSERVED"

java.awt.print.Pageable
public static final int UNKNOWN_NUMBER_OF_PAGES -1

java.awt.print.PageFormat
public static final int | LANDSCAPE | 0
public static final int | PORTRAIT | 1
public static final int | REVERSE_LANDSCAPE | 2

java.awt.print.Printable
public static final int | NO_SUCH_PAGE | 1
public static final int | PAGE_EXISTS | 0

java.beans.*

java.beans.BeanInfo
public static final int | ICON_COLOR_16x16 | 1
public static final int | ICON_COLOR_32x32 | 2
public static final int | ICON_MONO_16x16 | 3
public static final int | ICON_MONO_32x32 | 4

java.beans.DesignMode
public static final String PROPERTYNAME "designTime"

java.beans.Introspector
public static final int | IGNORE_ALL_BEANINFO | 3
public static final int | IGNORE_IMMEDIATE_BEANINFO | 2
public static final int | USE_ALL_BEANINFO | 1

java.io.*

java.io.ObjectStreamConstants
public static final int | baseWireHandle | 8257536
public static final int | PROTOCOL_VERSION_1 | 1
public static final int | PROTOCOL_VERSION_2 | 2
public static final byte | SC_BLOCK_DATA | 8
public static final byte | SC_ENUM | 16
public static final byte | SC_EXTERNALIZABLE | 4
public static final byte | SC_SERIALIZABLE | 2
public static final byte | SC_WRITE_METHOD | 1
public static final short | STREAM_MAGIC | -21267
public static final short | STREAM_VERSION | 5
public static final byte | TC_ARRAY | 117
public static final byte | TC_BASE | 112
public static final byte | TC_BLOCKDATA | 119
public static final byte | TC_BLOCKDATALONG | 122
public static final byte | TC_CLASS | 118
public static final byte | TC_CLASSDESC | 114
public static final byte | TC_ENDBLOCKDATA | 120
public static final byte | TC_ENUM | 126
public static final byte | TC_EXCEPTION | 123
public static final byte | TC_LONGSTRING | 124
public static final byte | TC_MAX | 126
public static final byte | TC_NULL | 112
public static final byte | TC_OBJECT | 115
public static final byte | TC_PROXYCLASSDESC | 125
public static final byte | TC_REFERENCE | 113
public static final byte | TC_RESET | 121
public static final byte | TC_STRING | 116

java.io.PipedInputStream
protected static final int PIPE_SIZE 1024

java.io.StreamTokenizer
public static final int | TT_EOF | -1
public static final int | TT_EOL | 10
public static final int | TT_NUMBER | -2
public static final int | TT_WORD | -3

java.lang.*

java.lang.Byte
public static final byte | MAX_VALUE | 127
public static final byte | MIN_VALUE | -128
public static final int | SIZE | 8

java.lang.Character
public static final byte | COMBINING_SPACING_MARK | 8
public static final byte | CONNECTOR_PUNCTUATION | 23
public static final byte | CONTROL | 15
public static final byte | CURRENCY_SYMBOL | 26
public static final byte | DASH_PUNCTUATION | 20
public static final byte | DECIMAL_DIGIT_NUMBER | 9
public static final byte | DIRECTIONALITY_ARABIC_NUMBER | 6
public static final byte | DIRECTIONALITY_BOUNDARY_NEUTRAL | 9
public static final byte | DIRECTIONALITY_COMMON_NUMBER_SEPARATOR | 7
public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER | 3
public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR | 4
public static final byte | DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR | 5
public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT | 0
public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING | 14
public static final byte | DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE | 15
public static final byte | DIRECTIONALITY_NONSPACING_MARK | 8
public static final byte | DIRECTIONALITY_OTHER_NEUTRALS | 13
public static final byte | DIRECTIONALITY_PARAGRAPH_SEPARATOR | 10
public static final byte | DIRECTIONALITY_POP_DIRECTIONAL_FORMAT | 18
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT | 1
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC | 2
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING | 16
public static final byte | DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE | 17
public static final byte | DIRECTIONALITY_SEGMENT_SEPARATOR | 11
public static final byte | DIRECTIONALITY_UNDEFINED | -1
public static final byte | DIRECTIONALITY_WHITESPACE | 12
public static final byte | ENCLOSING_MARK | 7
public static final byte | END_PUNCTUATION | 22
public static final byte | FINAL_QUOTE_PUNCTUATION | 30
public static final byte | FORMAT | 16
public static final byte | INITIAL_QUOTE_PUNCTUATION | 29
public static final byte | LETTER_NUMBER | 10
public static final byte | LINE_SEPARATOR | 13
public static final byte | LOWERCASE_LETTER | 2
public static final byte | MATH_SYMBOL | 25
public static final int | MAX_CODE_POINT | 1114111
public static final char | MAX_HIGH_SURROGATE | 56319
public static final char | MAX_LOW_SURROGATE | 57343
public static final int | MAX_RADIX | 36
public static final char | MAX_SURROGATE | 57343
public static final char | MAX_VALUE | 65535
public static final int | MIN_CODE_POINT | 0
public static final char | MIN_HIGH_SURROGATE | 55296
public static final char | MIN_LOW_SURROGATE | 56320
public static final int | MIN_RADIX | 2
public static final int | MIN_SUPPLEMENTARY_CODE_POINT | 65536
public static final char | MIN_SURROGATE | 55296
public static final char | MIN_VALUE | 0
public static final byte | MODIFIER_LETTER | 4
public static final byte | MODIFIER_SYMBOL | 27
public static final byte | NON_SPACING_MARK | 6
public static final byte | OTHER_LETTER | 5
public static final byte | OTHER_NUMBER | 11
public static final byte | OTHER_PUNCTUATION | 24
public static final byte | OTHER_SYMBOL | 28
public static final byte | PARAGRAPH_SEPARATOR | 14
public static final byte | PRIVATE_USE | 18
public static final int | SIZE | 16
public static final byte | SPACE_SEPARATOR | 12
public static final byte | START_PUNCTUATION | 21
public static final byte | SURROGATE | 19
public static final byte | TITLECASE_LETTER | 3
public static final byte | UNASSIGNED | 0
public static final byte | UPPERCASE_LETTER | 1

java.lang.Double
public static final int | MAX_EXPONENT | 1023
public static final double | MAX_VALUE | 1.7976931348623157E308
public static final int | MIN_EXPONENT | -1022
public static final double | MIN_NORMAL | 2.2250738585072014E-308
public static final double | MIN_VALUE | 4.9E-324
public static final double | NaN | 0d/0d
public static final double | NEGATIVE_INFINITY | -1d/0d
public static final double | POSITIVE_INFINITY | 1d/0d
public static final int | SIZE | 64

java.lang.Float
public static final int | MAX_EXPONENT | 127
public static final float | MAX_VALUE | 3.4028234663852886E38f
public static final int | MIN_EXPONENT | -126
public static final float | MIN_NORMAL | 1.1754943508222875E-38f
public static final float | MIN_VALUE | 1.401298464324817E-45f
public static final float | NaN | 0f/0f
public static final float | NEGATIVE_INFINITY | -1f/0f
public static final float | POSITIVE_INFINITY | 1f/0f
public static final int | SIZE | 32

java.lang.Integer
public static final int | MAX_VALUE | 2147483647
public static final int | MIN_VALUE | -2147483648
public static final int | SIZE | 32

java.lang.Long
public static final long | MAX_VALUE | 9223372036854775807L
public static final long | MIN_VALUE | -9223372036854775808L
public static final int | SIZE | 64

java.lang.Math
public static final double | E | 2.718281828459045
public static final double | PI | 3.141592653589793

java.lang.Short
public static final short | MAX_VALUE | 32767
public static final short | MIN_VALUE | -32768
public static final int | SIZE | 16

java.lang.StrictMath
public static final double | E | 2.718281828459045
public static final double | PI | 3.141592653589793

java.lang.Thread
public static final int | MAX_PRIORITY | 10
public static final int | MIN_PRIORITY | 1
public static final int | NORM_PRIORITY | 5

java.lang.management.ManagementFactory
public static final String | CLASS_LOADING_MXBEAN_NAME | "java.lang:type=ClassLoading"
public static final String | COMPILATION_MXBEAN_NAME | "java.lang:type=Compilation"
public static final String | GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE | "java.lang:type=GarbageCollector"
public static final String | MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE | "java.lang:type=MemoryManager"
public static final String | MEMORY_MXBEAN_NAME | "java.lang:type=Memory"
public static final String | MEMORY_POOL_MXBEAN_DOMAIN_TYPE | "java.lang:type=MemoryPool"
public static final String | OPERATING_SYSTEM_MXBEAN_NAME | "java.lang:type=OperatingSystem"
public static final String | RUNTIME_MXBEAN_NAME | "java.lang:type=Runtime"
public static final String | THREAD_MXBEAN_NAME | "java.lang:type=Threading"

java.lang.management.MemoryNotificationInfo
public static final String | MEMORY_COLLECTION_THRESHOLD_EXCEEDED | "java.management.memory.collection.threshold.exceeded"
public static final String | MEMORY_THRESHOLD_EXCEEDED | "java.management.memory.threshold.exceeded"

java.lang.reflect.Member
public static final int | DECLARED | 1
public static final int | PUBLIC | 0

java.lang.reflect.Modifier
public static final int | ABSTRACT | 1024
public static final int | FINAL | 16
public static final int | INTERFACE | 512
public static final int | NATIVE | 256
public static final int | PRIVATE | 2
public static final int | PROTECTED | 4
public static final int | PUBLIC | 1
public static final int | STATIC | 8
public static final int | STRICT | 2048
public static final int | SYNCHRONIZED | 32
public static final int | TRANSIENT | 128
public static final int | VOLATILE | 64

java.math.*

java.math.BigDecimal
public static final int | ROUND_CEILING | 2
public static final int | ROUND_DOWN | 1
public static final int | ROUND_FLOOR | 3
public static final int | ROUND_HALF_DOWN | 5
public static final int | ROUND_HALF_EVEN | 6
public static final int | ROUND_HALF_UP | 4
public static final int | ROUND_UNNECESSARY | 7
public static final int | ROUND_UP | 0

java.net.*

java.net.HttpURLConnection
public static final int | HTTP_ACCEPTED | 202
public static final int | HTTP_BAD_GATEWAY | 502
public static final int | HTTP_BAD_METHOD | 405
public static final int | HTTP_BAD_REQUEST | 400
public static final int | HTTP_CLIENT_TIMEOUT | 408
public static final int | HTTP_CONFLICT | 409
public static final int | HTTP_CREATED | 201
public static final int | HTTP_ENTITY_TOO_LARGE | 413
public static final int | HTTP_FORBIDDEN | 403
public static final int | HTTP_GATEWAY_TIMEOUT | 504
public static final int | HTTP_GONE | 410
public static final int | HTTP_INTERNAL_ERROR | 500
public static final int | HTTP_LENGTH_REQUIRED | 411
public static final int | HTTP_MOVED_PERM | 301
public static final int | HTTP_MOVED_TEMP | 302
public static final int | HTTP_MULT_CHOICE | 300
public static final int | HTTP_NO_CONTENT | 204
public static final int | HTTP_NOT_ACCEPTABLE | 406
public static final int | HTTP_NOT_AUTHORITATIVE | 203
public static final int | HTTP_NOT_FOUND | 404
public static final int | HTTP_NOT_IMPLEMENTED | 501
public static final int | HTTP_NOT_MODIFIED | 304
public static final int | HTTP_OK | 200
public static final int | HTTP_PARTIAL | 206
public static final int | HTTP_PAYMENT_REQUIRED | 402
public static final int | HTTP_PRECON_FAILED | 412
public static final int | HTTP_PROXY_AUTH | 407
public static final int | HTTP_REQ_TOO_LONG | 414
public static final int | HTTP_RESET | 205
public static final int | HTTP_SEE_OTHER | 303
public static final int | HTTP_SERVER_ERROR | 500
public static final int | HTTP_UNAUTHORIZED | 401
public static final int | HTTP_UNAVAILABLE | 503
public static final int | HTTP_UNSUPPORTED_TYPE | 415
public static final int | HTTP_USE_PROXY | 305
public static final int | HTTP_VERSION | 505

java.net.IDN
public static final int | ALLOW_UNASSIGNED | 1
public static final int | USE_STD3_ASCII_RULES | 2

java.net.SocketOptions
public static final int | IP_MULTICAST_IF | 16
public static final int | IP_MULTICAST_IF2 | 31
public static final int | IP_MULTICAST_LOOP | 18
public static final int | IP_TOS | 3
public static final int | SO_BINDADDR | 15
public static final int | SO_BROADCAST | 32
public static final int | SO_KEEPALIVE | 8
public static final int | SO_LINGER | 128
public static final int | SO_OOBINLINE | 4099
public static final int | SO_RCVBUF | 4098
public static final int | SO_REUSEADDR | 4
public static final int | SO_SNDBUF | 4097
public static final int | SO_TIMEOUT | 4102
public static final int | TCP_NODELAY | 1

java.nio.*

java.nio.channels.SelectionKey
public static final int | OP_ACCEPT | 16
public static final int | OP_CONNECT | 8
public static final int | OP_READ | 1
public static final int | OP_WRITE | 4

java.rmi.*

java.rmi.activation.ActivationSystem
public static final int SYSTEM_PORT 1098

java.rmi.registry.Registry
public static final int REGISTRY_PORT 1099

java.rmi.server.LoaderHandler
public static final String packagePrefix "sun.rmi.server"

java.rmi.server.LogStream
public static final int | BRIEF | 10
public static final int | SILENT | 0
public static final int | VERBOSE | 20

java.rmi.server.ObjID
public static final int | ACTIVATOR_ID | 1
public static final int | DGC_ID | 2
public static final int | REGISTRY_ID | 0

java.rmi.server.RemoteRef
public static final String | packagePrefix | "sun.rmi.server"
public static final long | serialVersionUID | 3632638527362204081L

java.rmi.server.ServerRef
public static final long serialVersionUID -4557750989390278438L

java.security.*

java.security.Key
public static final long serialVersionUID 6603384152749567654L

java.security.PrivateKey
public static final long serialVersionUID 6034044314589513430L

java.security.PublicKey
public static final long serialVersionUID 7187392471159151072L

java.security.Signature
protected static final int | SIGN | 2
protected static final int | UNINITIALIZED | 0
protected static final int | VERIFY | 3

java.security.interfaces.DSAPrivateKey
public static final long serialVersionUID 7776497482533790279L

java.security.interfaces.DSAPublicKey
public static final long serialVersionUID 1234526332779022332L

java.security.interfaces.ECPrivateKey
public static final long serialVersionUID -7896394956925609184L

java.security.interfaces.ECPublicKey
public static final long serialVersionUID -3314988629879632826L

java.security.interfaces.RSAMultiPrimePrivateCrtKey
public static final long serialVersionUID 618058533534628008L

java.security.interfaces.RSAPrivateCrtKey
public static final long serialVersionUID -5682214253527700368L

java.security.interfaces.RSAPrivateKey
public static final long serialVersionUID 5187144804936595022L

java.security.interfaces.RSAPublicKey
public static final long serialVersionUID -8727434096241101194L

java.sql.*

java.sql.Connection
public static final int | TRANSACTION_NONE | 0
public static final int | TRANSACTION_READ_COMMITTED | 2
public static final int | TRANSACTION_READ_UNCOMMITTED | 1
public static final int | TRANSACTION_REPEATABLE_READ | 4
public static final int | TRANSACTION_SERIALIZABLE | 8

java.sql.DatabaseMetaData
public static final short | attributeNoNulls | 0
public static final short | attributeNullable | 1
public static final short | attributeNullableUnknown | 2
public static final int | bestRowNotPseudo | 1
public static final int | bestRowPseudo | 2
public static final int | bestRowSession | 2
public static final int | bestRowTemporary | 0
public static final int | bestRowTransaction | 1
public static final int | bestRowUnknown | 0
public static final int | columnNoNulls | 0
public static final int | columnNullable | 1
public static final int | columnNullableUnknown | 2
public static final int | functionColumnIn | 1
public static final int | functionColumnInOut | 2
public static final int | functionColumnOut | 3
public static final int | functionColumnResult | 5
public static final int | functionColumnUnknown | 0
public static final int | functionNoNulls | 0
public static final int | functionNoTable | 1
public static final int | functionNullable | 1
public static final int | functionNullableUnknown | 2
public static final int | functionResultUnknown | 0
public static final int | functionReturn | 4
public static final int | functionReturnsTable | 2
public static final int | importedKeyCascade | 0
public static final int | importedKeyInitiallyDeferred | 5
public static final int | importedKeyInitiallyImmediate | 6
public static final int | importedKeyNoAction | 3
public static final int | importedKeyNotDeferrable | 7
public static final int | importedKeyRestrict | 1
public static final int | importedKeySetDefault | 4
public static final int | importedKeySetNull | 2
public static final int | procedureColumnIn | 1
public static final int | procedureColumnInOut | 2
public static final int | procedureColumnOut | 4
public static final int | procedureColumnResult | 3
public static final int | procedureColumnReturn | 5
public static final int | procedureColumnUnknown | 0
public static final int | procedureNoNulls | 0
public static final int | procedureNoResult | 1
public static final int | procedureNullable | 1
public static final int | procedureNullableUnknown | 2
public static final int | procedureResultUnknown | 0
public static final int | procedureReturnsResult | 2
public static final int | sqlStateSQL | 2
public static final int | sqlStateSQL99 | 2
public static final int | sqlStateXOpen | 1
public static final short | tableIndexClustered | 1
public static final short | tableIndexHashed | 2
public static final short | tableIndexOther | 3
public static final short | tableIndexStatistic | 0
public static final int | typeNoNulls | 0
public static final int | typeNullable | 1
public static final int | typeNullableUnknown | 2
public static final int | typePredBasic | 2
public static final int | typePredChar | 1
public static final int | typePredNone | 0
public static final int | typeSearchable | 3
public static final int | versionColumnNotPseudo | 1
public static final int | versionColumnPseudo | 2
public static final int | versionColumnUnknown | 0

java.sql.ParameterMetaData
public static final int | parameterModeIn | 1
public static final int | parameterModeInOut | 2
public static final int | parameterModeOut | 4
public static final int | parameterModeUnknown | 0
public static final int | parameterNoNulls | 0
public static final int | parameterNullable | 1
public static final int | parameterNullableUnknown | 2

java.sql.ResultSet
public static final int | CLOSE_CURSORS_AT_COMMIT | 2
public static final int | CONCUR_READ_ONLY | 1007
public static final int | CONCUR_UPDATABLE | 1008
public static final int | FETCH_FORWARD | 1000
public static final int | FETCH_REVERSE | 1001
public static final int | FETCH_UNKNOWN | 1002
public static final int | HOLD_CURSORS_OVER_COMMIT | 1
public static final int | TYPE_FORWARD_ONLY | 1003
public static final int | TYPE_SCROLL_INSENSITIVE | 1004
public static final int | TYPE_SCROLL_SENSITIVE | 1005

java.sql.ResultSetMetaData
public static final int | columnNoNulls | 0
public static final int | columnNullable | 1
public static final int | columnNullableUnknown | 2

java.sql.Statement
public static final int | CLOSE_ALL_RESULTS | 3
public static final int | CLOSE_CURRENT_RESULT | 1
public static final int | EXECUTE_FAILED | -3
public static final int | KEEP_CURRENT_RESULT | 2
public static final int | NO_GENERATED_KEYS | 2
public static final int | RETURN_GENERATED_KEYS | 1
public static final int | SUCCESS_NO_INFO | -2

java.sql.Types
public static final int | ARRAY | 2003
public static final int | BIGINT | -5
public static final int | BINARY | -2
public static final int | BIT | -7
public static final int | BLOB | 2004
public static final int | BOOLEAN | 16
public static final int | CHAR | 1
public static final int | CLOB | 2005
public static final int | DATALINK | 70
public static final int | DATE | 91
public static final int | DECIMAL | 3
public static final int | DISTINCT | 2001
public static final int | DOUBLE | 8
public static final int | FLOAT | 6
public static final int | INTEGER | 4
public static final int | JAVA_OBJECT | 2000
public static final int | LONGNVARCHAR | -16
public static final int | LONGVARBINARY | -4
public static final int | LONGVARCHAR | -1
public static final int | NCHAR | -15
public static final int | NCLOB | 2011
public static final int | NULL | 0
public static final int | NUMERIC | 2
public static final int | NVARCHAR | -9
public static final int | OTHER | 1111
public static final int | REAL | 7
public static final int | REF | 2006
public static final int | ROWID | -8
public static final int | SMALLINT | 5
public static final int | SQLXML | 2009
public static final int | STRUCT | 2002
public static final int | TIME | 92
public static final int | TIMESTAMP | 93
public static final int | TINYINT | -6
public static final int | VARBINARY | -3
public static final int | VARCHAR | 12

java.text.*

java.text.Bidi
public static final int | DIRECTION_DEFAULT_LEFT_TO_RIGHT | -2
public static final int | DIRECTION_DEFAULT_RIGHT_TO_LEFT | -1
public static final int | DIRECTION_LEFT_TO_RIGHT | 0
public static final int | DIRECTION_RIGHT_TO_LEFT | 1

java.text.BreakIterator
public static final int DONE -1

java.text.CharacterIterator
public static final char DONE 65535

java.text.CollationElementIterator
public static final int NULLORDER -1

java.text.Collator
public static final int | CANONICAL_DECOMPOSITION | 1
public static final int | FULL_DECOMPOSITION | 2
public static final int | IDENTICAL | 3
public static final int | NO_DECOMPOSITION | 0
public static final int | PRIMARY | 0
public static final int | SECONDARY | 1
public static final int | TERTIARY | 2

java.text.DateFormat
public static final int | AM_PM_FIELD | 14
public static final int | DATE_FIELD | 3
public static final int | DAY_OF_WEEK_FIELD | 9
public static final int | DAY_OF_WEEK_IN_MONTH_FIELD | 11
public static final int | DAY_OF_YEAR_FIELD | 10
public static final int | DEFAULT | 2
public static final int | ERA_FIELD | 0
public static final int | FULL | 0
public static final int | HOUR_OF_DAY0_FIELD | 5
public static final int | HOUR_OF_DAY1_FIELD | 4
public static final int | HOUR0_FIELD | 16
public static final int | HOUR1_FIELD | 15
public static final int | LONG | 1
public static final int | MEDIUM | 2
public static final int | MILLISECOND_FIELD | 8
public static final int | MINUTE_FIELD | 6
public static final int | MONTH_FIELD | 2
public static final int | SECOND_FIELD | 7
public static final int | SHORT | 3
public static final int | TIMEZONE_FIELD | 17
public static final int | WEEK_OF_MONTH_FIELD | 13
public static final int | WEEK_OF_YEAR_FIELD | 12
public static final int | YEAR_FIELD | 1

java.text.NumberFormat
public static final int | FRACTION_FIELD | 1
public static final int | INTEGER_FIELD | 0

java.util.*

java.util.Calendar
public static final int | ALL_STYLES | 0
public static final int | AM | 0
public static final int | AM_PM | 9
public static final int | APRIL | 3
public static final int | AUGUST | 7
public static final int | DATE | 5
public static final int | DAY_OF_MONTH | 5
public static final int | DAY_OF_WEEK | 7
public static final int | DAY_OF_WEEK_IN_MONTH | 8
public static final int | DAY_OF_YEAR | 6
public static final int | DECEMBER | 11
public static final int | DST_OFFSET | 16
public static final int | ERA | 0
public static final int | FEBRUARY | 1
public static final int | FIELD_COUNT | 17
public static final int | FRIDAY | 6
public static final int | HOUR | 10
public static final int | HOUR_OF_DAY | 11
public static final int | JANUARY | 0
public static final int | JULY | 6
public static final int | JUNE | 5
public static final int | LONG | 2
public static final int | MARCH | 2
public static final int | MAY | 4
public static final int | MILLISECOND | 14
public static final int | MINUTE | 12
public static final int | MONDAY | 2
public static final int | MONTH | 2
public static final int | NOVEMBER | 10
public static final int | OCTOBER | 9
public static final int | PM | 1
public static final int | SATURDAY | 7
public static final int | SECOND | 13
public static final int | SEPTEMBER | 8
public static final int | SHORT | 1
public static final int | SUNDAY | 1
public static final int | THURSDAY | 5
public static final int | TUESDAY | 3
public static final int | UNDECIMBER | 12
public static final int | WEDNESDAY | 4
public static final int | WEEK_OF_MONTH | 4
public static final int | WEEK_OF_YEAR | 3
public static final int | YEAR | 1
public static final int | ZONE_OFFSET | 15

java.util.FormattableFlags
public static final int | ALTERNATE | 4
public static final int | LEFT_JUSTIFY | 1
public static final int | UPPERCASE | 2

java.util.GregorianCalendar
public static final int | AD | 1
public static final int | BC | 0

java.util.ResourceBundle.Control
public static final long | TTL_DONT_CACHE | -1L
public static final long | TTL_NO_EXPIRATION_CONTROL | -2L

java.util.SimpleTimeZone
public static final int | STANDARD_TIME | 1
public static final int | UTC_TIME | 2
public static final int | WALL_TIME | 0

java.util.TimeZone
public static final int | LONG | 1
public static final int | SHORT | 0

java.util.jar.JarEntry
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.jar.JarFile
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final String | MANIFEST_NAME | "META-INF/MANIFEST.MF"

java.util.jar.JarInputStream
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.jar.JarOutputStream
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.jar.Pack200.Packer
public static final String | CLASS_ATTRIBUTE_PFX | "pack.class.attribute."
public static final String | CODE_ATTRIBUTE_PFX | "pack.code.attribute."
public static final String | DEFLATE_HINT | "pack.deflate.hint"
public static final String | EFFORT | "pack.effort"
public static final String | ERROR | "error"
public static final String | FALSE | "false"
public static final String | FIELD_ATTRIBUTE_PFX | "pack.field.attribute."
public static final String | KEEP | "keep"
public static final String | KEEP_FILE_ORDER | "pack.keep.file.order"
public static final String | LATEST | "latest"
public static final String | METHOD_ATTRIBUTE_PFX | "pack.method.attribute."
public static final String | MODIFICATION_TIME | "pack.modification.time"
public static final String | PASS | "pass"
public static final String | PASS_FILE_PFX | "pack.pass.file."
public static final String | PROGRESS | "pack.progress"
public static final String | SEGMENT_LIMIT | "pack.segment.limit"
public static final String | STRIP | "strip"
public static final String | TRUE | "true"
public static final String | UNKNOWN_ATTRIBUTE | "pack.unknown.attribute"

java.util.jar.Pack200.Unpacker
public static final String | DEFLATE_HINT | "unpack.deflate.hint"
public static final String | FALSE | "false"
public static final String | KEEP | "keep"
public static final String | PROGRESS | "unpack.progress"
public static final String | TRUE | "true"

java.util.logging.ErrorManager
public static final int | CLOSE_FAILURE | 3
public static final int | FLUSH_FAILURE | 2
public static final int | FORMAT_FAILURE | 5
public static final int | GENERIC_FAILURE | 0
public static final int | OPEN_FAILURE | 4
public static final int | WRITE_FAILURE | 1

java.util.logging.Logger
public static final String GLOBAL_LOGGER_NAME "global"

java.util.logging.LogManager
public static final String LOGGING_MXBEAN_NAME "java.util.logging:type=Logging"

java.util.prefs.Preferences
public static final int | MAX_KEY_LENGTH | 80
public static final int | MAX_NAME_LENGTH | 80
public static final int | MAX_VALUE_LENGTH | 8192

java.util.regex.Pattern
public static final int | CANON_EQ | 128
public static final int | CASE_INSENSITIVE | 2
public static final int | COMMENTS | 4
public static final int | DOTALL | 32
public static final int | LITERAL | 16
public static final int | MULTILINE | 8
public static final int | UNICODE_CASE | 64
public static final int | UNIX_LINES | 1

java.util.zip.Deflater
public static final int | BEST_COMPRESSION | 9
public static final int | BEST_SPEED | 1
public static final int | DEFAULT_COMPRESSION | -1
public static final int | DEFAULT_STRATEGY | 0
public static final int | DEFLATED | 8
public static final int | FILTERED | 1
public static final int | HUFFMAN_ONLY | 2
public static final int | NO_COMPRESSION | 0

java.util.zip.GZIPInputStream
public static final int GZIP_MAGIC 35615

java.util.zip.ZipEntry
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | DEFLATED | 8
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | STORED | 0

java.util.zip.ZipFile
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | OPEN_DELETE | 4
public static final int | OPEN_READ | 1

java.util.zip.ZipInputStream
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4

java.util.zip.ZipOutputStream
public static final int | CENATT | 36
public static final int | CENATX | 38
public static final int | CENCOM | 32
public static final int | CENCRC | 16
public static final int | CENDSK | 34
public static final int | CENEXT | 30
public static final int | CENFLG | 8
public static final int | CENHDR | 46
public static final int | CENHOW | 10
public static final int | CENLEN | 24
public static final int | CENNAM | 28
public static final int | CENOFF | 42
public static final long | CENSIG | 33639248L
public static final int | CENSIZ | 20
public static final int | CENTIM | 12
public static final int | CENVEM | 4
public static final int | CENVER | 6
public static final int | DEFLATED | 8
public static final int | ENDCOM | 20
public static final int | ENDHDR | 22
public static final int | ENDOFF | 16
public static final long | ENDSIG | 101010256L
public static final int | ENDSIZ | 12
public static final int | ENDSUB | 8
public static final int | ENDTOT | 10
public static final int | EXTCRC | 4
public static final int | EXTHDR | 16
public static final int | EXTLEN | 12
public static final long | EXTSIG | 134695760L
public static final int | EXTSIZ | 8
public static final int | LOCCRC | 14
public static final int | LOCEXT | 28
public static final int | LOCFLG | 6
public static final int | LOCHDR | 30
public static final int | LOCHOW | 8
public static final int | LOCLEN | 22
public static final int | LOCNAM | 26
public static final long | LOCSIG | 67324752L
public static final int | LOCSIZ | 18
public static final int | LOCTIM | 10
public static final int | LOCVER | 4
public static final int | STORED | 0

javax.accessibility.*

javax.accessibility.AccessibleContext
public static final String | ACCESSIBLE_ACTION_PROPERTY | "accessibleActionProperty"
public static final String | ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY | "AccessibleActiveDescendant"
public static final String | ACCESSIBLE_CARET_PROPERTY | "AccessibleCaret"
public static final String | ACCESSIBLE_CHILD_PROPERTY | "AccessibleChild"
public static final String | ACCESSIBLE_COMPONENT_BOUNDS_CHANGED | "accessibleComponentBoundsChanged"
public static final String | ACCESSIBLE_DESCRIPTION_PROPERTY | "AccessibleDescription"
public static final String | ACCESSIBLE_HYPERTEXT_OFFSET | "AccessibleHypertextOffset"
public static final String | ACCESSIBLE_INVALIDATE_CHILDREN | "accessibleInvalidateChildren"
public static final String | ACCESSIBLE_NAME_PROPERTY | "AccessibleName"
public static final String | ACCESSIBLE_SELECTION_PROPERTY | "AccessibleSelection"
public static final String | ACCESSIBLE_STATE_PROPERTY | "AccessibleState"
public static final String | ACCESSIBLE_TABLE_CAPTION_CHANGED | "accessibleTableCaptionChanged"
public static final String | ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED | "accessibleTableColumnDescriptionChanged"
public static final String | ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED | "accessibleTableColumnHeaderChanged"
public static final String | ACCESSIBLE_TABLE_MODEL_CHANGED | "accessibleTableModelChanged"
public static final String | ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED | "accessibleTableRowDescriptionChanged"
public static final String | ACCESSIBLE_TABLE_ROW_HEADER_CHANGED | "accessibleTableRowHeaderChanged"
public static final String | ACCESSIBLE_TABLE_SUMMARY_CHANGED | "accessibleTableSummaryChanged"
public static final String | ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED | "accessibleTextAttributesChanged"
public static final String | ACCESSIBLE_TEXT_PROPERTY | "AccessibleText"
public static final String | ACCESSIBLE_VALUE_PROPERTY | "AccessibleValue"
public static final String | ACCESSIBLE_VISIBLE_DATA_PROPERTY | "AccessibleVisibleData"

javax.accessibility.AccessibleExtendedText
public static final int | ATTRIBUTE_RUN | 5
public static final int | LINE | 4

javax.accessibility.AccessibleRelation
public static final String | CHILD_NODE_OF | "childNodeOf"
public static final String | CHILD_NODE_OF_PROPERTY | "childNodeOfProperty"
public static final String | CONTROLLED_BY_PROPERTY | "controlledByProperty"
public static final String | CONTROLLER_FOR_PROPERTY | "controllerForProperty"
public static final String | EMBEDDED_BY | "embeddedBy"
public static final String | EMBEDDED_BY_PROPERTY | "embeddedByProperty"
public static final String | EMBEDS | "embeds"
public static final String | EMBEDS_PROPERTY | "embedsProperty"
public static final String | FLOWS_FROM | "flowsFrom"
public static final String | FLOWS_FROM_PROPERTY | "flowsFromProperty"
public static final String | FLOWS_TO | "flowsTo"
public static final String | FLOWS_TO_PROPERTY | "flowsToProperty"
public static final String | LABEL_FOR_PROPERTY | "labelForProperty"
public static final String | LABELED_BY_PROPERTY | "labeledByProperty"
public static final String | MEMBER_OF_PROPERTY | "memberOfProperty"
public static final String | PARENT_WINDOW_OF | "parentWindowOf"
public static final String | PARENT_WINDOW_OF_PROPERTY | "parentWindowOfProperty"
public static final String | SUBWINDOW_OF | "subwindowOf"
public static final String | SUBWINDOW_OF_PROPERTY | "subwindowOfProperty"

javax.accessibility.AccessibleTableModelChange
public static final int | DELETE | -1
public static final int | INSERT | 1
public static final int | UPDATE | 0

javax.accessibility.AccessibleText
public static final int | CHARACTER | 1
public static final int | SENTENCE | 3
public static final int | WORD | 2

javax.crypto.*

javax.crypto.Cipher
public static final int | DECRYPT_MODE | 2
public static final int | ENCRYPT_MODE | 1
public static final int | PRIVATE_KEY | 2
public static final int | PUBLIC_KEY | 1
public static final int | SECRET_KEY | 3
public static final int | UNWRAP_MODE | 4
public static final int | WRAP_MODE | 3

javax.crypto.SecretKey
public static final long serialVersionUID -4795878709595146952L

javax.crypto.interfaces.DHPrivateKey
public static final long serialVersionUID 2211791113380396553L

javax.crypto.interfaces.DHPublicKey
public static final long serialVersionUID -6628103563352519193L

javax.crypto.interfaces.PBEKey
public static final long serialVersionUID -1430015993304333921L

javax.crypto.spec.DESedeKeySpec
public static final int DES_EDE_KEY_LEN 24

javax.crypto.spec.DESKeySpec
public static final int DES_KEY_LEN 8

javax.imageio.*

javax.imageio.ImageWriteParam
public static final int | MODE_COPY_FROM_METADATA | 3
public static final int | MODE_DEFAULT | 1
public static final int | MODE_DISABLED | 0
public static final int | MODE_EXPLICIT | 2

javax.imageio.metadata.IIOMetadataFormat
public static final int | CHILD_POLICY_ALL | 1
public static final int | CHILD_POLICY_CHOICE | 3
public static final int | CHILD_POLICY_EMPTY | 0
public static final int | CHILD_POLICY_MAX | 5
public static final int | CHILD_POLICY_REPEAT | 5
public static final int | CHILD_POLICY_SEQUENCE | 4
public static final int | CHILD_POLICY_SOME | 2
public static final int | DATATYPE_BOOLEAN | 1
public static final int | DATATYPE_DOUBLE | 4
public static final int | DATATYPE_FLOAT | 3
public static final int | DATATYPE_INTEGER | 2
public static final int | DATATYPE_STRING | 0
public static final int | VALUE_ARBITRARY | 1
public static final int | VALUE_ENUMERATION | 16
public static final int | VALUE_LIST | 32
public static final int | VALUE_NONE | 0
public static final int | VALUE_RANGE | 2
public static final int | VALUE_RANGE_MAX_INCLUSIVE | 10
public static final int | VALUE_RANGE_MAX_INCLUSIVE_MASK | 8
public static final int | VALUE_RANGE_MIN_INCLUSIVE | 6
public static final int | VALUE_RANGE_MIN_INCLUSIVE_MASK | 4
public static final int | VALUE_RANGE_MIN_MAX_INCLUSIVE | 14

javax.imageio.metadata.IIOMetadataFormatImpl
public static final String standardMetadataFormatName "javax_imageio_1.0"

javax.management.*

javax.management.AttributeChangeNotification
public static final String ATTRIBUTE_CHANGE "jmx.attribute.change"

javax.management.JMX
public static final String | DEFAULT_VALUE_FIELD | "defaultValue"
public static final String | IMMUTABLE_INFO_FIELD | "immutableInfo"
public static final String | INTERFACE_CLASS_NAME_FIELD | "interfaceClassName"
public static final String | LEGAL_VALUES_FIELD | "legalValues"
public static final String | MAX_VALUE_FIELD | "maxValue"
public static final String | MIN_VALUE_FIELD | "minValue"
public static final String | MXBEAN_FIELD | "mxbean"
public static final String | OPEN_TYPE_FIELD | "openType"
public static final String | ORIGINAL_TYPE_FIELD | "originalType"

javax.management.MBeanOperationInfo
public static final int | ACTION | 1
public static final int | ACTION_INFO | 2
public static final int | INFO | 0
public static final int | UNKNOWN | 3

javax.management.MBeanServerNotification
public static final String | REGISTRATION_NOTIFICATION | "JMX.mbean.registered"
public static final String | UNREGISTRATION_NOTIFICATION | "JMX.mbean.unregistered"

javax.management.Query
public static final int | DIV | 3
public static final int | EQ | 4
public static final int | GE | 2
public static final int | GT | 0
public static final int | LE | 3
public static final int | LT | 1
public static final int | MINUS | 1
public static final int | PLUS | 0
public static final int | TIMES | 2

javax.management.monitor.Monitor
protected static final int | capacityIncrement | 16
protected static final int | OBSERVED_ATTRIBUTE_ERROR_NOTIFIED | 2
protected static final int | OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED | 4
protected static final int | OBSERVED_OBJECT_ERROR_NOTIFIED | 1
protected static final int | RESET_FLAGS_ALREADY_NOTIFIED | 0
protected static final int | RUNTIME_ERROR_NOTIFIED | 8

javax.management.monitor.MonitorNotification
public static final String | OBSERVED_ATTRIBUTE_ERROR | "jmx.monitor.error.attribute"
public static final String | OBSERVED_ATTRIBUTE_TYPE_ERROR | "jmx.monitor.error.type"
public static final String | OBSERVED_OBJECT_ERROR | "jmx.monitor.error.mbean"
public static final String | RUNTIME_ERROR | "jmx.monitor.error.runtime"
public static final String | STRING_TO_COMPARE_VALUE_DIFFERED | "jmx.monitor.string.differs"
public static final String | STRING_TO_COMPARE_VALUE_MATCHED | "jmx.monitor.string.matches"
public static final String | THRESHOLD_ERROR | "jmx.monitor.error.threshold"
public static final String | THRESHOLD_HIGH_VALUE_EXCEEDED | "jmx.monitor.gauge.high"
public static final String | THRESHOLD_LOW_VALUE_EXCEEDED | "jmx.monitor.gauge.low"
public static final String | THRESHOLD_VALUE_EXCEEDED | "jmx.monitor.counter.threshold"

javax.management.relation.RelationNotification
public static final String | RELATION_BASIC_CREATION | "jmx.relation.creation.basic"
public static final String | RELATION_BASIC_REMOVAL | "jmx.relation.removal.basic"
public static final String | RELATION_BASIC_UPDATE | "jmx.relation.update.basic"
public static final String | RELATION_MBEAN_CREATION | "jmx.relation.creation.mbean"
public static final String | RELATION_MBEAN_REMOVAL | "jmx.relation.removal.mbean"
public static final String | RELATION_MBEAN_UPDATE | "jmx.relation.update.mbean"

javax.management.relation.RoleInfo
public static final int ROLE_CARDINALITY_INFINITY -1

javax.management.relation.RoleStatus
public static final int | LESS_THAN_MIN_ROLE_DEGREE | 4
public static final int | MORE_THAN_MAX_ROLE_DEGREE | 5
public static final int | NO_ROLE_WITH_NAME | 1
public static final int | REF_MBEAN_NOT_REGISTERED | 7
public static final int | REF_MBEAN_OF_INCORRECT_CLASS | 6
public static final int | ROLE_NOT_READABLE | 2
public static final int | ROLE_NOT_WRITABLE | 3

javax.management.remote.JMXConnectionNotification
public static final String | CLOSED | "jmx.remote.connection.closed"
public static final String | FAILED | "jmx.remote.connection.failed"
public static final String | NOTIFS_LOST | "jmx.remote.connection.notifs.lost"
public static final String | OPENED | "jmx.remote.connection.opened"

javax.management.remote.JMXConnector
public static final String CREDENTIALS "jmx.remote.credentials"

javax.management.remote.JMXConnectorFactory
public static final String | DEFAULT_CLASS_LOADER | "jmx.remote.default.class.loader"
public static final String | PROTOCOL_PROVIDER_CLASS_LOADER | "jmx.remote.protocol.provider.class.loader"
public static final String | PROTOCOL_PROVIDER_PACKAGES | "jmx.remote.protocol.provider.pkgs"

javax.management.remote.JMXConnectorServer
public static final String AUTHENTICATOR "jmx.remote.authenticator"

javax.management.remote.JMXConnectorServerFactory
public static final String | DEFAULT_CLASS_LOADER | "jmx.remote.default.class.loader"
public static final String | DEFAULT_CLASS_LOADER_NAME | "jmx.remote.default.class.loader.name"
public static final String | PROTOCOL_PROVIDER_CLASS_LOADER | "jmx.remote.protocol.provider.class.loader"
public static final String | PROTOCOL_PROVIDER_PACKAGES | "jmx.remote.protocol.provider.pkgs"

javax.management.remote.rmi.RMIConnectorServer
public static final String | JNDI_REBIND_ATTRIBUTE | "jmx.remote.jndi.rebind"
public static final String | RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE | "jmx.remote.rmi.client.socket.factory"
public static final String | RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE | "jmx.remote.rmi.server.socket.factory"

javax.management.timer.Timer
public static final long | ONE_DAY | 86400000L
public static final long | ONE_HOUR | 3600000L
public static final long | ONE_MINUTE | 60000L
public static final long | ONE_SECOND | 1000L
public static final long | ONE_WEEK | 604800000L

javax.naming.*

javax.naming.Context
public static final String | APPLET | "java.naming.applet"
public static final String | AUTHORITATIVE | "java.naming.authoritative"
public static final String | BATCHSIZE | "java.naming.batchsize"
public static final String | DNS_URL | "java.naming.dns.url"
public static final String | INITIAL_CONTEXT_FACTORY | "java.naming.factory.initial"
public static final String | LANGUAGE | "java.naming.language"
public static final String | OBJECT_FACTORIES | "java.naming.factory.object"
public static final String | PROVIDER_URL | "java.naming.provider.url"
public static final String | REFERRAL | "java.naming.referral"
public static final String | SECURITY_AUTHENTICATION | "java.naming.security.authentication"
public static final String | SECURITY_CREDENTIALS | "java.naming.security.credentials"
public static final String | SECURITY_PRINCIPAL | "java.naming.security.principal"
public static final String | SECURITY_PROTOCOL | "java.naming.security.protocol"
public static final String | STATE_FACTORIES | "java.naming.factory.state"
public static final String | URL_PKG_PREFIXES | "java.naming.factory.url.pkgs"

javax.naming.Name
public static final long serialVersionUID -3617482732056931635L

javax.naming.directory.Attribute
public static final long serialVersionUID 8707690322213556804L

javax.naming.directory.DirContext
public static final int | ADD_ATTRIBUTE | 1
public static final int | REMOVE_ATTRIBUTE | 3
public static final int | REPLACE_ATTRIBUTE | 2

javax.naming.directory.SearchControls
public static final int | OBJECT_SCOPE | 0
public static final int | ONELEVEL_SCOPE | 1
public static final int | SUBTREE_SCOPE | 2

javax.naming.event.EventContext
public static final int | OBJECT_SCOPE | 0
public static final int | ONELEVEL_SCOPE | 1
public static final int | SUBTREE_SCOPE | 2

javax.naming.event.NamingEvent
public static final int | OBJECT_ADDED | 0
public static final int | OBJECT_CHANGED | 3
public static final int | OBJECT_REMOVED | 1
public static final int | OBJECT_RENAMED | 2

javax.naming.ldap.Control
public static final boolean | CRITICAL | true
public static final boolean | NONCRITICAL | false

javax.naming.ldap.LdapContext
public static final String CONTROL_FACTORIES "java.naming.factory.control"

javax.naming.ldap.ManageReferralControl
public static final String OID "2.16.840.1.113730.3.4.2"

javax.naming.ldap.PagedResultsControl
public static final String OID "1.2.840.113556.1.4.319"

javax.naming.ldap.PagedResultsResponseControl
public static final String OID "1.2.840.113556.1.4.319"

javax.naming.ldap.SortControl
public static final String OID "1.2.840.113556.1.4.473"

javax.naming.ldap.SortResponseControl
public static final String OID "1.2.840.113556.1.4.474"

javax.naming.ldap.StartTlsRequest
public static final String OID "1.3.6.1.4.1.1466.20037"

javax.naming.ldap.StartTlsResponse
public static final String OID "1.3.6.1.4.1.1466.20037"

javax.naming.spi.NamingManager
public static final String CPE "java.naming.spi.CannotProceedException"

javax.print.*

javax.print.ServiceUIFactory
public static final int | ABOUT_UIROLE | 1
public static final int | ADMIN_UIROLE | 2
public static final String | DIALOG_UI | "java.awt.Dialog"
public static final String | JCOMPONENT_UI | "javax.swing.JComponent"
public static final String | JDIALOG_UI | "javax.swing.JDialog"
public static final int | MAIN_UIROLE | 3
public static final String | PANEL_UI | "java.awt.Panel"
public static final int | RESERVED_UIROLE | 99

javax.print.URIException
public static final int | URIInaccessible | 1
public static final int | URIOtherProblem | -1
public static final int | URISchemeNotSupported | 2

javax.print.attribute.ResolutionSyntax
public static final int | DPCM | 254
public static final int | DPI | 100

javax.print.attribute.Size2DSyntax
public static final int | INCH | 25400
public static final int | MM | 1000

javax.print.attribute.standard.MediaPrintableArea
public static final int | INCH | 25400
public static final int | MM | 1000

javax.print.event.PrintJobEvent
public static final int | DATA_TRANSFER_COMPLETE | 106
public static final int | JOB_CANCELED | 101
public static final int | JOB_COMPLETE | 102
public static final int | JOB_FAILED | 103
public static final int | NO_MORE_EVENTS | 105
public static final int | REQUIRES_ATTENTION | 104

javax.script.*

javax.script.ScriptContext
public static final int | ENGINE_SCOPE | 100
public static final int | GLOBAL_SCOPE | 200

javax.script.ScriptEngine
public static final String | ARGV | "javax.script.argv"
public static final String | ENGINE | "javax.script.engine"
public static final String | ENGINE_VERSION | "javax.script.engine_version"
public static final String | FILENAME | "javax.script.filename"
public static final String | LANGUAGE | "javax.script.language"
public static final String | LANGUAGE_VERSION | "javax.script.language_version"
public static final String | NAME | "javax.script.name"

javax.security.*

javax.security.auth.callback.ConfirmationCallback
public static final int | CANCEL | 2
public static final int | ERROR | 2
public static final int | INFORMATION | 0
public static final int | NO | 1
public static final int | OK | 3
public static final int | OK_CANCEL_OPTION | 2
public static final int | UNSPECIFIED_OPTION | -1
public static final int | WARNING | 1
public static final int | YES | 0
public static final int | YES_NO_CANCEL_OPTION | 1
public static final int | YES_NO_OPTION | 0

javax.security.auth.callback.TextOutputCallback
public static final int | ERROR | 2
public static final int | INFORMATION | 0
public static final int | WARNING | 1

javax.security.auth.kerberos.KerberosPrincipal
public static final int | KRB_NT_PRINCIPAL | 1
public static final int | KRB_NT_SRV_HST | 3
public static final int | KRB_NT_SRV_INST | 2
public static final int | KRB_NT_SRV_XHST | 4
public static final int | KRB_NT_UID | 5
public static final int | KRB_NT_UNKNOWN | 0

javax.security.auth.x500.X500Principal
public static final String | CANONICAL | "CANONICAL"
public static final String | RFC1779 | "RFC1779"
public static final String | RFC2253 | "RFC2253"

javax.security.sasl.Sasl
public static final String | CREDENTIALS | "javax.security.sasl.credentials"
public static final String | MAX_BUFFER | "javax.security.sasl.maxbuffer"
public static final String | POLICY_FORWARD_SECRECY | "javax.security.sasl.policy.forward"
public static final String | POLICY_NOACTIVE | "javax.security.sasl.policy.noactive"
public static final String | POLICY_NOANONYMOUS | "javax.security.sasl.policy.noanonymous"
public static final String | POLICY_NODICTIONARY | "javax.security.sasl.policy.nodictionary"
public static final String | POLICY_NOPLAINTEXT | "javax.security.sasl.policy.noplaintext"
public static final String | POLICY_PASS_CREDENTIALS | "javax.security.sasl.policy.credentials"
public static final String | QOP | "javax.security.sasl.qop"
public static final String | RAW_SEND_SIZE | "javax.security.sasl.rawsendsize"
public static final String | REUSE | "javax.security.sasl.reuse"
public static final String | SERVER_AUTH | "javax.security.sasl.server.authentication"
public static final String | STRENGTH | "javax.security.sasl.strength"

javax.sound.*

javax.sound.midi.MetaMessage
public static final int META 255

javax.sound.midi.MidiFileFormat
public static final int UNKNOWN_LENGTH -1

javax.sound.midi.Sequence
public static final float | PPQ | 0.0f
public static final float | SMPTE_24 | 24.0f
public static final float | SMPTE_25 | 25.0f
public static final float | SMPTE_30 | 30.0f
public static final float | SMPTE_30DROP | 29.969999313354492f

javax.sound.midi.Sequencer
public static final int LOOP_CONTINUOUSLY -1

javax.sound.midi.ShortMessage
public static final int | ACTIVE_SENSING | 254
public static final int | CHANNEL_PRESSURE | 208
public static final int | CONTINUE | 251
public static final int | CONTROL_CHANGE | 176
public static final int | END_OF_EXCLUSIVE | 247
public static final int | MIDI_TIME_CODE | 241
public static final int | NOTE_OFF | 128
public static final int | NOTE_ON | 144
public static final int | PITCH_BEND | 224
public static final int | POLY_PRESSURE | 160
public static final int | PROGRAM_CHANGE | 192
public static final int | SONG_POSITION_POINTER | 242
public static final int | SONG_SELECT | 243
public static final int | START | 250
public static final int | STOP | 252
public static final int | SYSTEM_RESET | 255
public static final int | TIMING_CLOCK | 248
public static final int | TUNE_REQUEST | 246

javax.sound.midi.SysexMessage
public static final int | SPECIAL_SYSTEM_EXCLUSIVE | 247
public static final int | SYSTEM_EXCLUSIVE | 240

javax.sound.sampled.AudioSystem
public static final int NOT_SPECIFIED -1

javax.sound.sampled.Clip
public static final int LOOP_CONTINUOUSLY -1

javax.sql.*

javax.sql.rowset.BaseRowSet
public static final int | ASCII_STREAM_PARAM | 2
public static final int | BINARY_STREAM_PARAM | 1
public static final int | UNICODE_STREAM_PARAM | 0

javax.sql.rowset.CachedRowSet
public static final boolean COMMIT_ON_ACCEPT_CHANGES true

javax.sql.rowset.JoinRowSet
public static final int | CROSS_JOIN | 0
public static final int | FULL_JOIN | 4
public static final int | INNER_JOIN | 1
public static final int | LEFT_OUTER_JOIN | 2
public static final int | RIGHT_OUTER_JOIN | 3

javax.sql.rowset.WebRowSet
public static final String | PUBLIC_XML_SCHEMA | "--//Sun Microsystems, Inc.//XSD Schema//EN"
public static final String | SCHEMA_SYSTEM_ID | "http://java.sun.com/xml/ns/jdbc/webrowset.xsd"

javax.sql.rowset.spi.SyncResolver
public static final int | DELETE_ROW_CONFLICT | 1
public static final int | INSERT_ROW_CONFLICT | 2
public static final int | NO_ROW_CONFLICT | 3
public static final int | UPDATE_ROW_CONFLICT | 0

javax.swing.*

javax.swing.AbstractButton
public static final String | BORDER_PAINTED_CHANGED_PROPERTY | "borderPainted"
public static final String | CONTENT_AREA_FILLED_CHANGED_PROPERTY | "contentAreaFilled"
public static final String | DISABLED_ICON_CHANGED_PROPERTY | "disabledIcon"
public static final String | DISABLED_SELECTED_ICON_CHANGED_PROPERTY | "disabledSelectedIcon"
public static final String | FOCUS_PAINTED_CHANGED_PROPERTY | "focusPainted"
public static final String | HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY | "horizontalAlignment"
public static final String | HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY | "horizontalTextPosition"
public static final String | ICON_CHANGED_PROPERTY | "icon"
public static final String | MARGIN_CHANGED_PROPERTY | "margin"
public static final String | MNEMONIC_CHANGED_PROPERTY | "mnemonic"
public static final String | MODEL_CHANGED_PROPERTY | "model"
public static final String | PRESSED_ICON_CHANGED_PROPERTY | "pressedIcon"
public static final String | ROLLOVER_ENABLED_CHANGED_PROPERTY | "rolloverEnabled"
public static final String | ROLLOVER_ICON_CHANGED_PROPERTY | "rolloverIcon"
public static final String | ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY | "rolloverSelectedIcon"
public static final String | SELECTED_ICON_CHANGED_PROPERTY | "selectedIcon"
public static final String | TEXT_CHANGED_PROPERTY | "text"
public static final String | VERTICAL_ALIGNMENT_CHANGED_PROPERTY | "verticalAlignment"
public static final String | VERTICAL_TEXT_POSITION_CHANGED_PROPERTY | "verticalTextPosition"

javax.swing.Action
public static final String | ACCELERATOR_KEY | "AcceleratorKey"
public static final String | ACTION_COMMAND_KEY | "ActionCommandKey"
public static final String | DEFAULT | "Default"
public static final String | DISPLAYED_MNEMONIC_INDEX_KEY | "SwingDisplayedMnemonicIndexKey"
public static final String | LARGE_ICON_KEY | "SwingLargeIconKey"
public static final String | LONG_DESCRIPTION | "LongDescription"
public static final String | MNEMONIC_KEY | "MnemonicKey"
public static final String | NAME | "Name"
public static final String | SELECTED_KEY | "SwingSelectedKey"
public static final String | SHORT_DESCRIPTION | "ShortDescription"
public static final String | SMALL_ICON | "SmallIcon"

javax.swing.BoxLayout
public static final int | LINE_AXIS | 2
public static final int | PAGE_AXIS | 3
public static final int | X_AXIS | 0
public static final int | Y_AXIS | 1

javax.swing.DebugGraphics
public static final int | BUFFERED_OPTION | 4
public static final int | FLASH_OPTION | 2
public static final int | LOG_OPTION | 1
public static final int | NONE_OPTION | -1

javax.swing.DefaultButtonModel
public static final int | ARMED | 1
public static final int | ENABLED | 8
public static final int | PRESSED | 4
public static final int | ROLLOVER | 16
public static final int | SELECTED | 2

javax.swing.FocusManager
public static final String FOCUS_MANAGER_CLASS_PROPERTY "FocusManagerClassName"

javax.swing.GroupLayout
public static final int | DEFAULT_SIZE | -1
public static final int | PREFERRED_SIZE | -2

javax.swing.JCheckBox
public static final String BORDER_PAINTED_FLAT_CHANGED_PROPERTY "borderPaintedFlat"

javax.swing.JColorChooser
public static final String | CHOOSER_PANELS_PROPERTY | "chooserPanels"
public static final String | PREVIEW_PANEL_PROPERTY | "previewPanel"
public static final String | SELECTION_MODEL_PROPERTY | "selectionModel"

javax.swing.JComponent
public static final String | TOOL_TIP_TEXT_KEY | "ToolTipText"
public static final int | UNDEFINED_CONDITION | -1
public static final int | WHEN_ANCESTOR_OF_FOCUSED_COMPONENT | 1
public static final int | WHEN_FOCUSED | 0
public static final int | WHEN_IN_FOCUSED_WINDOW | 2

javax.swing.JDesktopPane
public static final int | LIVE_DRAG_MODE | 0
public static final int | OUTLINE_DRAG_MODE | 1

javax.swing.JEditorPane
public static final String | HONOR_DISPLAY_PROPERTIES | "JEditorPane.honorDisplayProperties"
public static final String | W3C_LENGTH_UNITS | "JEditorPane.w3cLengthUnits"

javax.swing.JFileChooser
public static final String | ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY | "acceptAllFileFilterUsedChanged"
public static final String | ACCESSORY_CHANGED_PROPERTY | "AccessoryChangedProperty"
public static final String | APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY | "ApproveButtonMnemonicChangedProperty"
public static final String | APPROVE_BUTTON_TEXT_CHANGED_PROPERTY | "ApproveButtonTextChangedProperty"
public static final String | APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY | "ApproveButtonToolTipTextChangedProperty"
public static final int | APPROVE_OPTION | 0
public static final String | APPROVE_SELECTION | "ApproveSelection"
public static final int | CANCEL_OPTION | 1
public static final String | CANCEL_SELECTION | "CancelSelection"
public static final String | CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY | "ChoosableFileFilterChangedProperty"
public static final String | CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY | "ControlButtonsAreShownChangedProperty"
public static final int | CUSTOM_DIALOG | 2
public static final String | DIALOG_TITLE_CHANGED_PROPERTY | "DialogTitleChangedProperty"
public static final String | DIALOG_TYPE_CHANGED_PROPERTY | "DialogTypeChangedProperty"
public static final int | DIRECTORIES_ONLY | 1
public static final String | DIRECTORY_CHANGED_PROPERTY | "directoryChanged"
public static final int | ERROR_OPTION | -1
public static final String | FILE_FILTER_CHANGED_PROPERTY | "fileFilterChanged"
public static final String | FILE_HIDING_CHANGED_PROPERTY | "FileHidingChanged"
public static final String | FILE_SELECTION_MODE_CHANGED_PROPERTY | "fileSelectionChanged"
public static final String | FILE_SYSTEM_VIEW_CHANGED_PROPERTY | "FileSystemViewChanged"
public static final String | FILE_VIEW_CHANGED_PROPERTY | "fileViewChanged"
public static final int | FILES_AND_DIRECTORIES | 2
public static final int | FILES_ONLY | 0
public static final String | MULTI_SELECTION_ENABLED_CHANGED_PROPERTY | "MultiSelectionEnabledChangedProperty"
public static final int | OPEN_DIALOG | 0
public static final int | SAVE_DIALOG | 1
public static final String | SELECTED_FILE_CHANGED_PROPERTY | "SelectedFileChangedProperty"
public static final String | SELECTED_FILES_CHANGED_PROPERTY | "SelectedFilesChangedProperty"

javax.swing.JFormattedTextField
public static final int | COMMIT | 0
public static final int | COMMIT_OR_REVERT | 1
public static final int | PERSIST | 3
public static final int | REVERT | 2

javax.swing.JFrame
public static final int EXIT_ON_CLOSE 3

javax.swing.JInternalFrame
public static final String | CONTENT_PANE_PROPERTY | "contentPane"
public static final String | FRAME_ICON_PROPERTY | "frameIcon"
public static final String | GLASS_PANE_PROPERTY | "glassPane"
public static final String | IS_CLOSED_PROPERTY | "closed"
public static final String | IS_ICON_PROPERTY | "icon"
public static final String | IS_MAXIMUM_PROPERTY | "maximum"
public static final String | IS_SELECTED_PROPERTY | "selected"
public static final String | LAYERED_PANE_PROPERTY | "layeredPane"
public static final String | MENU_BAR_PROPERTY | "JMenuBar"
public static final String | ROOT_PANE_PROPERTY | "rootPane"
public static final String | TITLE_PROPERTY | "title"

javax.swing.JLayeredPane
public static final String LAYER_PROPERTY "layeredContainerLayer"

javax.swing.JList
public static final int | HORIZONTAL_WRAP | 2
public static final int | VERTICAL | 0
public static final int | VERTICAL_WRAP | 1

javax.swing.JOptionPane
public static final int | CANCEL_OPTION | 2
public static final int | CLOSED_OPTION | -1
public static final int | DEFAULT_OPTION | -1
public static final int | ERROR_MESSAGE | 0
public static final String | ICON_PROPERTY | "icon"
public static final int | INFORMATION_MESSAGE | 1
public static final String | INITIAL_SELECTION_VALUE_PROPERTY | "initialSelectionValue"
public static final String | INITIAL_VALUE_PROPERTY | "initialValue"
public static final String | INPUT_VALUE_PROPERTY | "inputValue"
public static final String | MESSAGE_PROPERTY | "message"
public static final String | MESSAGE_TYPE_PROPERTY | "messageType"
public static final int | NO_OPTION | 1
public static final int | OK_CANCEL_OPTION | 2
public static final int | OK_OPTION | 0
public static final String | OPTION_TYPE_PROPERTY | "optionType"
public static final String | OPTIONS_PROPERTY | "options"
public static final int | PLAIN_MESSAGE | -1
public static final int | QUESTION_MESSAGE | 3
public static final String | SELECTION_VALUES_PROPERTY | "selectionValues"
public static final String | VALUE_PROPERTY | "value"
public static final String | WANTS_INPUT_PROPERTY | "wantsInput"
public static final int | WARNING_MESSAGE | 2
public static final int | YES_NO_CANCEL_OPTION | 1
public static final int | YES_NO_OPTION | 0
public static final int | YES_OPTION | 0

javax.swing.JRootPane
public static final int | COLOR_CHOOSER_DIALOG | 5
public static final int | ERROR_DIALOG | 4
public static final int | FILE_CHOOSER_DIALOG | 6
public static final int | FRAME | 1
public static final int | INFORMATION_DIALOG | 3
public static final int | NONE | 0
public static final int | PLAIN_DIALOG | 2
public static final int | QUESTION_DIALOG | 7
public static final int | WARNING_DIALOG | 8

javax.swing.JSplitPane
public static final String | BOTTOM | "bottom"
public static final String | CONTINUOUS_LAYOUT_PROPERTY | "continuousLayout"
public static final String | DIVIDER | "divider"
public static final String | DIVIDER_LOCATION_PROPERTY | "dividerLocation"
public static final String | DIVIDER_SIZE_PROPERTY | "dividerSize"
public static final int | HORIZONTAL_SPLIT | 1
public static final String | LAST_DIVIDER_LOCATION_PROPERTY | "lastDividerLocation"
public static final String | LEFT | "left"
public static final String | ONE_TOUCH_EXPANDABLE_PROPERTY | "oneTouchExpandable"
public static final String | ORIENTATION_PROPERTY | "orientation"
public static final String | RESIZE_WEIGHT_PROPERTY | "resizeWeight"
public static final String | RIGHT | "right"
public static final String | TOP | "top"
public static final int | VERTICAL_SPLIT | 0

javax.swing.JTabbedPane
public static final int | SCROLL_TAB_LAYOUT | 1
public static final int | WRAP_TAB_LAYOUT | 0

javax.swing.JTable
public static final int | AUTO_RESIZE_ALL_COLUMNS | 4
public static final int | AUTO_RESIZE_LAST_COLUMN | 3
public static final int | AUTO_RESIZE_NEXT_COLUMN | 1
public static final int | AUTO_RESIZE_OFF | 0
public static final int | AUTO_RESIZE_SUBSEQUENT_COLUMNS | 2

javax.swing.JTextField
public static final String notifyAction "notify-field-accept"

javax.swing.JTree
public static final String | ANCHOR_SELECTION_PATH_PROPERTY | "anchorSelectionPath"
public static final String | CELL_EDITOR_PROPERTY | "cellEditor"
public static final String | CELL_RENDERER_PROPERTY | "cellRenderer"
public static final String | EDITABLE_PROPERTY | "editable"
public static final String | EXPANDS_SELECTED_PATHS_PROPERTY | "expandsSelectedPaths"
public static final String | INVOKES_STOP_CELL_EDITING_PROPERTY | "invokesStopCellEditing"
public static final String | LARGE_MODEL_PROPERTY | "largeModel"
public static final String | LEAD_SELECTION_PATH_PROPERTY | "leadSelectionPath"
public static final String | ROOT_VISIBLE_PROPERTY | "rootVisible"
public static final String | ROW_HEIGHT_PROPERTY | "rowHeight"
public static final String | SCROLLS_ON_EXPAND_PROPERTY | "scrollsOnExpand"
public static final String | SELECTION_MODEL_PROPERTY | "selectionModel"
public static final String | SHOWS_ROOT_HANDLES_PROPERTY | "showsRootHandles"
public static final String | TOGGLE_CLICK_COUNT_PROPERTY | "toggleClickCount"
public static final String | TREE_MODEL_PROPERTY | "model"
public static final String | VISIBLE_ROW_COUNT_PROPERTY | "visibleRowCount"

javax.swing.JViewport
public static final int | BACKINGSTORE_SCROLL_MODE | 2
public static final int | BLIT_SCROLL_MODE | 1
public static final int | SIMPLE_SCROLL_MODE | 0

javax.swing.ListSelectionModel
public static final int | MULTIPLE_INTERVAL_SELECTION | 2
public static final int | SINGLE_INTERVAL_SELECTION | 1
public static final int | SINGLE_SELECTION | 0

javax.swing.ScrollPaneConstants
public static final String | COLUMN_HEADER | "COLUMN_HEADER"
public static final String | HORIZONTAL_SCROLLBAR | "HORIZONTAL_SCROLLBAR"
public static final int | HORIZONTAL_SCROLLBAR_ALWAYS | 32
public static final int | HORIZONTAL_SCROLLBAR_AS_NEEDED | 30
public static final int | HORIZONTAL_SCROLLBAR_NEVER | 31
public static final String | HORIZONTAL_SCROLLBAR_POLICY | "HORIZONTAL_SCROLLBAR_POLICY"
public static final String | LOWER_LEADING_CORNER | "LOWER_LEADING_CORNER"
public static final String | LOWER_LEFT_CORNER | "LOWER_LEFT_CORNER"
public static final String | LOWER_RIGHT_CORNER | "LOWER_RIGHT_CORNER"
public static final String | LOWER_TRAILING_CORNER | "LOWER_TRAILING_CORNER"
public static final String | ROW_HEADER | "ROW_HEADER"
public static final String | UPPER_LEADING_CORNER | "UPPER_LEADING_CORNER"
public static final String | UPPER_LEFT_CORNER | "UPPER_LEFT_CORNER"
public static final String | UPPER_RIGHT_CORNER | "UPPER_RIGHT_CORNER"
public static final String | UPPER_TRAILING_CORNER | "UPPER_TRAILING_CORNER"
public static final String | VERTICAL_SCROLLBAR | "VERTICAL_SCROLLBAR"
public static final int | VERTICAL_SCROLLBAR_ALWAYS | 22
public static final int | VERTICAL_SCROLLBAR_AS_NEEDED | 20
public static final int | VERTICAL_SCROLLBAR_NEVER | 21
public static final String | VERTICAL_SCROLLBAR_POLICY | "VERTICAL_SCROLLBAR_POLICY"
public static final String | VIEWPORT | "VIEWPORT"

javax.swing.Spring
public static final int UNSET -2147483648

javax.swing.SpringLayout
public static final String | BASELINE | "Baseline"
public static final String | EAST | "East"
public static final String | HEIGHT | "Height"
public static final String | HORIZONTAL_CENTER | "HorizontalCenter"
public static final String | NORTH | "North"
public static final String | SOUTH | "South"
public static final String | VERTICAL_CENTER | "VerticalCenter"
public static final String | WEST | "West"
public static final String | WIDTH | "Width"

javax.swing.SwingConstants
public static final int | BOTTOM | 3
public static final int | CENTER | 0
public static final int | EAST | 3
public static final int | HORIZONTAL | 0
public static final int | LEADING | 10
public static final int | LEFT | 2
public static final int | NEXT | 12
public static final int | NORTH | 1
public static final int | NORTH_EAST | 2
public static final int | NORTH_WEST | 8
public static final int | PREVIOUS | 13
public static final int | RIGHT | 4
public static final int | SOUTH | 5
public static final int | SOUTH_EAST | 4
public static final int | SOUTH_WEST | 6
public static final int | TOP | 1
public static final int | TRAILING | 11
public static final int | VERTICAL | 1
public static final int | WEST | 7

javax.swing.TransferHandler
public static final int | COPY | 1
public static final int | COPY_OR_MOVE | 3
public static final int | LINK | 1073741824
public static final int | MOVE | 2
public static final int | NONE | 0

javax.swing.WindowConstants
public static final int | DISPOSE_ON_CLOSE | 2
public static final int | DO_NOTHING_ON_CLOSE | 0
public static final int | EXIT_ON_CLOSE | 3
public static final int | HIDE_ON_CLOSE | 1

javax.swing.border.BevelBorder
public static final int | LOWERED | 1
public static final int | RAISED | 0

javax.swing.border.EtchedBorder
public static final int | LOWERED | 1
public static final int | RAISED | 0

javax.swing.border.TitledBorder
public static final int | ABOVE_BOTTOM | 4
public static final int | ABOVE_TOP | 1
public static final int | BELOW_BOTTOM | 6
public static final int | BELOW_TOP | 3
public static final int | BOTTOM | 5
public static final int | CENTER | 2
public static final int | DEFAULT_JUSTIFICATION | 0
public static final int | DEFAULT_POSITION | 0
protected static final int | EDGE_SPACING | 2
public static final int | LEADING | 4
public static final int | LEFT | 1
public static final int | RIGHT | 3
protected static final int | TEXT_INSET_H | 5
protected static final int | TEXT_SPACING | 2
public static final int | TOP | 2
public static final int | TRAILING | 5

javax.swing.event.AncestorEvent
public static final int | ANCESTOR_ADDED | 1
public static final int | ANCESTOR_MOVED | 3
public static final int | ANCESTOR_REMOVED | 2

javax.swing.event.InternalFrameEvent
public static final int | INTERNAL_FRAME_ACTIVATED | 25554
public static final int | INTERNAL_FRAME_CLOSED | 25551
public static final int | INTERNAL_FRAME_CLOSING | 25550
public static final int | INTERNAL_FRAME_DEACTIVATED | 25555
public static final int | INTERNAL_FRAME_DEICONIFIED | 25553
public static final int | INTERNAL_FRAME_FIRST | 25549
public static final int | INTERNAL_FRAME_ICONIFIED | 25552
public static final int | INTERNAL_FRAME_LAST | 25555
public static final int | INTERNAL_FRAME_OPENED | 25549

javax.swing.event.ListDataEvent
public static final int | CONTENTS_CHANGED | 0
public static final int | INTERVAL_ADDED | 1
public static final int | INTERVAL_REMOVED | 2

javax.swing.event.TableModelEvent
public static final int | ALL_COLUMNS | -1
public static final int | DELETE | -1
public static final int | HEADER_ROW | -1
public static final int | INSERT | 1
public static final int | UPDATE | 0

javax.swing.plaf.basic.BasicComboPopup
protected static final int | SCROLL_DOWN | 1
protected static final int | SCROLL_UP | 0

javax.swing.plaf.basic.BasicHTML
public static final String | documentBaseKey | "html.base"
public static final String | propertyKey | "html"

javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener
protected final int RESIZE_NONE 0

javax.swing.plaf.basic.BasicListUI
protected static final int | cellRendererChanged | 64
protected static final int | fixedCellHeightChanged | 16
protected static final int | fixedCellWidthChanged | 8
protected static final int | fontChanged | 4
protected static final int | modelChanged | 1
protected static final int | prototypeCellValueChanged | 32
protected static final int | selectionModelChanged | 2

javax.swing.plaf.basic.BasicOptionPaneUI
public static final int | MinimumHeight | 90
public static final int | MinimumWidth | 262

javax.swing.plaf.basic.BasicScrollBarUI
protected static final int | DECREASE_HIGHLIGHT | 1
protected static final int | INCREASE_HIGHLIGHT | 2
protected static final int | NO_HIGHLIGHT | 0

javax.swing.plaf.basic.BasicSliderUI
public static final int | MAX_SCROLL | 2
public static final int | MIN_SCROLL | -2
public static final int | NEGATIVE_SCROLL | -1
public static final int | POSITIVE_SCROLL | 1

javax.swing.plaf.basic.BasicSplitPaneDivider
protected static final int | ONE_TOUCH_OFFSET | 2
protected static final int | ONE_TOUCH_SIZE | 6

javax.swing.plaf.basic.BasicSplitPaneUI
protected static final String NON_CONTINUOUS_DIVIDER "nonContinuousDivider"

javax.swing.plaf.metal.MetalIconFactory
public static final boolean | DARK | false
public static final boolean | LIGHT | true

javax.swing.plaf.metal.MetalScrollBarUI
public static final String FREE_STANDING_PROP "JScrollBar.isFreeStanding"

javax.swing.plaf.metal.MetalSliderUI
protected final String | SLIDER_FILL | "JSlider.isFilled"
protected final int | TICK_BUFFER | 4

javax.swing.plaf.metal.MetalToolTipUI
public static final int padSpaceBetweenStrings 12

javax.swing.plaf.synth.SynthConstants
public static final int | DEFAULT | 1024
public static final int | DISABLED | 8
public static final int | ENABLED | 1
public static final int | FOCUSED | 256
public static final int | MOUSE_OVER | 2
public static final int | PRESSED | 4
public static final int | SELECTED | 512

javax.swing.table.TableColumn
public static final String | CELL_RENDERER_PROPERTY | "cellRenderer"
public static final String | COLUMN_WIDTH_PROPERTY | "columWidth"
public static final String | HEADER_RENDERER_PROPERTY | "headerRenderer"
public static final String | HEADER_VALUE_PROPERTY | "headerValue"

javax.swing.text.AbstractDocument
protected static final String | BAD_LOCATION | "document location failure"
public static final String | BidiElementName | "bidi level"
public static final String | ContentElementName | "content"
public static final String | ElementNameAttribute | "$ename"
public static final String | ParagraphElementName | "paragraph"
public static final String | SectionElementName | "section"

javax.swing.text.AbstractWriter
protected static final char NEWLINE 10

javax.swing.text.DefaultCaret
public static final int | ALWAYS_UPDATE | 2
public static final int | NEVER_UPDATE | 1
public static final int | UPDATE_WHEN_ON_EDT | 0

javax.swing.text.DefaultEditorKit
public static final String | backwardAction | "caret-backward"
public static final String | beepAction | "beep"
public static final String | beginAction | "caret-begin"
public static final String | beginLineAction | "caret-begin-line"
public static final String | beginParagraphAction | "caret-begin-paragraph"
public static final String | beginWordAction | "caret-begin-word"
public static final String | copyAction | "copy-to-clipboard"
public static final String | cutAction | "cut-to-clipboard"
public static final String | defaultKeyTypedAction | "default-typed"
public static final String | deleteNextCharAction | "delete-next"
public static final String | deleteNextWordAction | "delete-next-word"
public static final String | deletePrevCharAction | "delete-previous"
public static final String | deletePrevWordAction | "delete-previous-word"
public static final String | downAction | "caret-down"
public static final String | endAction | "caret-end"
public static final String | endLineAction | "caret-end-line"
public static final String | EndOfLineStringProperty | "__EndOfLine__"
public static final String | endParagraphAction | "caret-end-paragraph"
public static final String | endWordAction | "caret-end-word"
public static final String | forwardAction | "caret-forward"
public static final String | insertBreakAction | "insert-break"
public static final String | insertContentAction | "insert-content"
public static final String | insertTabAction | "insert-tab"
public static final String | nextWordAction | "caret-next-word"
public static final String | pageDownAction | "page-down"
public static final String | pageUpAction | "page-up"
public static final String | pasteAction | "paste-from-clipboard"
public static final String | previousWordAction | "caret-previous-word"
public static final String | readOnlyAction | "set-read-only"
public static final String | selectAllAction | "select-all"
public static final String | selectionBackwardAction | "selection-backward"
public static final String | selectionBeginAction | "selection-begin"
public static final String | selectionBeginLineAction | "selection-begin-line"
public static final String | selectionBeginParagraphAction | "selection-begin-paragraph"
public static final String | selectionBeginWordAction | "selection-begin-word"
public static final String | selectionDownAction | "selection-down"
public static final String | selectionEndAction | "selection-end"
public static final String | selectionEndLineAction | "selection-end-line"
public static final String | selectionEndParagraphAction | "selection-end-paragraph"
public static final String | selectionEndWordAction | "selection-end-word"
public static final String | selectionForwardAction | "selection-forward"
public static final String | selectionNextWordAction | "selection-next-word"
public static final String | selectionPreviousWordAction | "selection-previous-word"
public static final String | selectionUpAction | "selection-up"
public static final String | selectLineAction | "select-line"
public static final String | selectParagraphAction | "select-paragraph"
public static final String | selectWordAction | "select-word"
public static final String | upAction | "caret-up"
public static final String | writableAction | "set-writable"

javax.swing.text.DefaultStyledDocument
public static final int BUFFER_SIZE_DEFAULT 4096

javax.swing.text.DefaultStyledDocument.ElementSpec
public static final short | ContentType | 3
public static final short | EndTagType | 2
public static final short | JoinFractureDirection | 7
public static final short | JoinNextDirection | 5
public static final short | JoinPreviousDirection | 4
public static final short | OriginateDirection | 6
public static final short | StartTagType | 1

javax.swing.text.Document
public static final String | StreamDescriptionProperty | "stream"
public static final String | TitleProperty | "title"

javax.swing.text.JTextComponent
public static final String | DEFAULT_KEYMAP | "default"
public static final String | FOCUS_ACCELERATOR_KEY | "focusAcceleratorKey"

javax.swing.text.PlainDocument
public static final String | lineLimitAttribute | "lineLimit"
public static final String | tabSizeAttribute | "tabSize"

javax.swing.text.StyleConstants
public static final int | ALIGN_CENTER | 1
public static final int | ALIGN_JUSTIFIED | 3
public static final int | ALIGN_LEFT | 0
public static final int | ALIGN_RIGHT | 2
public static final String | ComponentElementName | "component"
public static final String | IconElementName | "icon"

javax.swing.text.StyleContext
public static final String DEFAULT_STYLE "default"

javax.swing.text.TabStop
public static final int | ALIGN_BAR | 5
public static final int | ALIGN_CENTER | 2
public static final int | ALIGN_DECIMAL | 4
public static final int | ALIGN_LEFT | 0
public static final int | ALIGN_RIGHT | 1
public static final int | LEAD_DOTS | 1
public static final int | LEAD_EQUALS | 5
public static final int | LEAD_HYPHENS | 2
public static final int | LEAD_NONE | 0
public static final int | LEAD_THICKLINE | 4
public static final int | LEAD_UNDERLINE | 3

javax.swing.text.View
public static final int | BadBreakWeight | 0
public static final int | ExcellentBreakWeight | 2000
public static final int | ForcedBreakWeight | 3000
public static final int | GoodBreakWeight | 1000
public static final int | X_AXIS | 0
public static final int | Y_AXIS | 1

javax.swing.text.html.HTML
public static final String NULL_ATTRIBUTE_VALUE "#DEFAULT"

javax.swing.text.html.HTMLDocument
public static final String AdditionalComments "AdditionalComments"

javax.swing.text.html.HTMLEditorKit
public static final String | BOLD_ACTION | "html-bold-action"
public static final String | COLOR_ACTION | "html-color-action"
public static final String | DEFAULT_CSS | "default.css"
public static final String | FONT_CHANGE_BIGGER | "html-font-bigger"
public static final String | FONT_CHANGE_SMALLER | "html-font-smaller"
public static final String | IMG_ALIGN_BOTTOM | "html-image-align-bottom"
public static final String | IMG_ALIGN_MIDDLE | "html-image-align-middle"
public static final String | IMG_ALIGN_TOP | "html-image-align-top"
public static final String | IMG_BORDER | "html-image-border"
public static final String | ITALIC_ACTION | "html-italic-action"
public static final String | LOGICAL_STYLE_ACTION | "html-logical-style-action"
public static final String | PARA_INDENT_LEFT | "html-para-indent-left"
public static final String | PARA_INDENT_RIGHT | "html-para-indent-right"

javax.swing.text.html.parser.DTD
public static final int FILE_VERSION 1

javax.swing.text.html.parser.DTDConstants
public static final int | ANY | 19
public static final int | CDATA | 1
public static final int | CONREF | 4
public static final int | CURRENT | 3
public static final int | DEFAULT | 131072
public static final int | EMPTY | 17
public static final int | ENDTAG | 14
public static final int | ENTITIES | 3
public static final int | ENTITY | 2
public static final int | FIXED | 1
public static final int | GENERAL | 65536
public static final int | ID | 4
public static final int | IDREF | 5
public static final int | IDREFS | 6
public static final int | IMPLIED | 5
public static final int | MD | 16
public static final int | MODEL | 18
public static final int | MS | 15
public static final int | NAME | 7
public static final int | NAMES | 8
public static final int | NMTOKEN | 9
public static final int | NMTOKENS | 10
public static final int | NOTATION | 11
public static final int | NUMBER | 12
public static final int | NUMBERS | 13
public static final int | NUTOKEN | 14
public static final int | NUTOKENS | 15
public static final int | PARAMETER | 262144
public static final int | PI | 12
public static final int | PUBLIC | 10
public static final int | RCDATA | 16
public static final int | REQUIRED | 2
public static final int | SDATA | 11
public static final int | STARTTAG | 13
public static final int | SYSTEM | 17

javax.swing.tree.DefaultTreeSelectionModel
public static final String SELECTION_MODE_PROPERTY "selectionMode"

javax.swing.tree.TreeSelectionModel
public static final int | CONTIGUOUS_TREE_SELECTION | 2
public static final int | DISCONTIGUOUS_TREE_SELECTION | 4
public static final int | SINGLE_TREE_SELECTION | 1

javax.swing.undo.AbstractUndoableEdit
protected static final String | RedoName | "Redo"
protected static final String | UndoName | "Undo"

javax.swing.undo.StateEdit
protected static final String RCSID "$Id: StateEdit.java,v 1.6 1997/10/01 20:05:51 sandipc Exp $"

javax.swing.undo.StateEditable
public static final String RCSID "$Id: StateEditable.java,v 1.2 1997/09/08 19:39:08 marklin Exp $"

javax.tools.*

javax.tools.Diagnostic<S>
public static final long NOPOS -1L

javax.transaction.*

javax.transaction.xa.XAException
public static final int | XA_HEURCOM | 7
public static final int | XA_HEURHAZ | 8
public static final int | XA_HEURMIX | 5
public static final int | XA_HEURRB | 6
public static final int | XA_NOMIGRATE | 9
public static final int | XA_RBBASE | 100
public static final int | XA_RBCOMMFAIL | 101
public static final int | XA_RBDEADLOCK | 102
public static final int | XA_RBEND | 107
public static final int | XA_RBINTEGRITY | 103
public static final int | XA_RBOTHER | 104
public static final int | XA_RBPROTO | 105
public static final int | XA_RBROLLBACK | 100
public static final int | XA_RBTIMEOUT | 106
public static final int | XA_RBTRANSIENT | 107
public static final int | XA_RDONLY | 3
public static final int | XA_RETRY | 4
public static final int | XAER_ASYNC | -2
public static final int | XAER_DUPID | -8
public static final int | XAER_INVAL | -5
public static final int | XAER_NOTA | -4
public static final int | XAER_OUTSIDE | -9
public static final int | XAER_PROTO | -6
public static final int | XAER_RMERR | -3
public static final int | XAER_RMFAIL | -7

javax.transaction.xa.XAResource
public static final int | TMENDRSCAN | 8388608
public static final int | TMFAIL | 536870912
public static final int | TMJOIN | 2097152
public static final int | TMNOFLAGS | 0
public static final int | TMONEPHASE | 1073741824
public static final int | TMRESUME | 134217728
public static final int | TMSTARTRSCAN | 16777216
public static final int | TMSUCCESS | 67108864
public static final int | TMSUSPEND | 33554432
public static final int | XA_OK | 0
public static final int | XA_RDONLY | 3

javax.transaction.xa.Xid
public static final int | MAXBQUALSIZE | 64
public static final int | MAXGTRIDSIZE | 64

javax.xml.*

javax.xml.XMLConstants
public static final String | DEFAULT_NS_PREFIX | ""
public static final String | FEATURE_SECURE_PROCESSING | "http://javax.xml.XMLConstants/feature/secure-processing"
public static final String | NULL_NS_URI | ""
public static final String | RELAXNG_NS_URI | "http://relaxng.org/ns/structure/1.0"
public static final String | W3C_XML_SCHEMA_INSTANCE_NS_URI | "http://www.w3.org/2001/XMLSchema-instance"
public static final String | W3C_XML_SCHEMA_NS_URI | "http://www.w3.org/2001/XMLSchema"
public static final String | W3C_XPATH_DATATYPE_NS_URI | "http://www.w3.org/2003/11/xpath-datatypes"
public static final String | XML_DTD_NS_URI | "http://www.w3.org/TR/REC-xml"
public static final String | XML_NS_PREFIX | "xml"
public static final String | XML_NS_URI | "http://www.w3.org/XML/1998/namespace"
public static final String | XMLNS_ATTRIBUTE | "xmlns"
public static final String | XMLNS_ATTRIBUTE_NS_URI | "http://www.w3.org/2000/xmlns/"

javax.xml.bind.JAXBContext
public static final String JAXB_CONTEXT_FACTORY "javax.xml.bind.context.factory"

javax.xml.bind.Marshaller
public static final String | JAXB_ENCODING | "jaxb.encoding"
public static final String | JAXB_FORMATTED_OUTPUT | "jaxb.formatted.output"
public static final String | JAXB_FRAGMENT | "jaxb.fragment"
public static final String | JAXB_NO_NAMESPACE_SCHEMA_LOCATION | "jaxb.noNamespaceSchemaLocation"
public static final String | JAXB_SCHEMA_LOCATION | "jaxb.schemaLocation"

javax.xml.bind.ValidationEvent
public static final int | ERROR | 1
public static final int | FATAL_ERROR | 2
public static final int | WARNING | 0

javax.xml.crypto.dsig.CanonicalizationMethod
public static final String | EXCLUSIVE | "http://www.w3.org/2001/10/xml-exc-c14n#"
public static final String | EXCLUSIVE_WITH_COMMENTS | "http://www.w3.org/2001/10/xml-exc-c14n#WithComments"
public static final String | INCLUSIVE | "http://www.w3.org/TR/2001/REC-xml-c14n-20010315"
public static final String | INCLUSIVE_WITH_COMMENTS | "http://www.w3.org/TR/2001/REC-xml-c14n-20010315#WithComments"

javax.xml.crypto.dsig.DigestMethod
public static final String | RIPEMD160 | "http://www.w3.org/2001/04/xmlenc#ripemd160"
public static final String | SHA1 | "http://www.w3.org/2000/09/xmldsig#sha1"
public static final String | SHA256 | "http://www.w3.org/2001/04/xmlenc#sha256"
public static final String | SHA512 | "http://www.w3.org/2001/04/xmlenc#sha512"

javax.xml.crypto.dsig.Manifest
public static final String TYPE "http://www.w3.org/2000/09/xmldsig#Manifest"

javax.xml.crypto.dsig.SignatureMethod
public static final String | DSA_SHA1 | "http://www.w3.org/2000/09/xmldsig#dsa-sha1"
public static final String | HMAC_SHA1 | "http://www.w3.org/2000/09/xmldsig#hmac-sha1"
public static final String | RSA_SHA1 | "http://www.w3.org/2000/09/xmldsig#rsa-sha1"

javax.xml.crypto.dsig.SignatureProperties
public static final String TYPE "http://www.w3.org/2000/09/xmldsig#SignatureProperties"

javax.xml.crypto.dsig.Transform
public static final String | BASE64 | "http://www.w3.org/2000/09/xmldsig#base64"
public static final String | ENVELOPED | "http://www.w3.org/2000/09/xmldsig#enveloped-signature"
public static final String | XPATH | "http://www.w3.org/TR/1999/REC-xpath-19991116"
public static final String | XPATH2 | "http://www.w3.org/2002/06/xmldsig-filter2"
public static final String | XSLT | "http://www.w3.org/TR/1999/REC-xslt-19991116"

javax.xml.crypto.dsig.XMLObject
public static final String TYPE "http://www.w3.org/2000/09/xmldsig#Object"

javax.xml.crypto.dsig.XMLSignature
public static final String XMLNS "http://www.w3.org/2000/09/xmldsig#"

javax.xml.crypto.dsig.keyinfo.KeyValue
public static final String | DSA_TYPE | "http://www.w3.org/2000/09/xmldsig#DSAKeyValue"
public static final String | RSA_TYPE | "http://www.w3.org/2000/09/xmldsig#RSAKeyValue"

javax.xml.crypto.dsig.keyinfo.PGPData
public static final String TYPE "http://www.w3.org/2000/09/xmldsig#PGPData"

javax.xml.crypto.dsig.keyinfo.X509Data
public static final String | RAW_X509_CERTIFICATE_TYPE | "http://www.w3.org/2000/09/xmldsig#rawX509Certificate"
public static final String | TYPE | "http://www.w3.org/2000/09/xmldsig#X509Data"

javax.xml.crypto.dsig.spec.ExcC14NParameterSpec
public static final String DEFAULT "#default"

javax.xml.datatype.DatatypeConstants
public static final int | APRIL | 4
public static final int | AUGUST | 8
public static final int | DECEMBER | 12
public static final int | EQUAL | 0
public static final int | FEBRUARY | 2
public static final int | FIELD_UNDEFINED | -2147483648
public static final int | GREATER | 1
public static final int | INDETERMINATE | 2
public static final int | JANUARY | 1
public static final int | JULY | 7
public static final int | JUNE | 6
public static final int | LESSER | -1
public static final int | MARCH | 3
public static final int | MAX_TIMEZONE_OFFSET | -840
public static final int | MAY | 5
public static final int | MIN_TIMEZONE_OFFSET | 840
public static final int | NOVEMBER | 11
public static final int | OCTOBER | 10
public static final int | SEPTEMBER | 9

javax.xml.datatype.DatatypeFactory
public static final String DATATYPEFACTORY_PROPERTY "javax.xml.datatype.DatatypeFactory"

javax.xml.soap.SOAPConstants
public static final String | DEFAULT_SOAP_PROTOCOL | "SOAP 1.1 Protocol"
public static final String | DYNAMIC_SOAP_PROTOCOL | "Dynamic Protocol"
public static final String | SOAP_1_1_CONTENT_TYPE | "text/xml"
public static final String | SOAP_1_1_PROTOCOL | "SOAP 1.1 Protocol"
public static final String | SOAP_1_2_CONTENT_TYPE | "application/soap+xml"
public static final String | SOAP_1_2_PROTOCOL | "SOAP 1.2 Protocol"
public static final String | SOAP_ENV_PREFIX | "env"
public static final String | URI_NS_SOAP_1_1_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | URI_NS_SOAP_1_2_ENCODING | "http://www.w3.org/2003/05/soap-encoding"
public static final String | URI_NS_SOAP_1_2_ENVELOPE | "http://www.w3.org/2003/05/soap-envelope"
public static final String | URI_NS_SOAP_ENCODING | "http://schemas.xmlsoap.org/soap/encoding/"
public static final String | URI_NS_SOAP_ENVELOPE | "http://schemas.xmlsoap.org/soap/envelope/"
public static final String | URI_SOAP_1_2_ROLE_NEXT | "http://www.w3.org/2003/05/soap-envelope/role/next"
public static final String | URI_SOAP_1_2_ROLE_NONE | "http://www.w3.org/2003/05/soap-envelope/role/none"
public static final String | URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER | "http://www.w3.org/2003/05/soap-envelope/role/ultimateReceiver"
public static final String | URI_SOAP_ACTOR_NEXT | "http://schemas.xmlsoap.org/soap/actor/next"

javax.xml.soap.SOAPMessage
public static final String | CHARACTER_SET_ENCODING | "javax.xml.soap.character-set-encoding"
public static final String | WRITE_XML_DECLARATION | "javax.xml.soap.write-xml-declaration"

javax.xml.stream.XMLInputFactory
public static final String | ALLOCATOR | "javax.xml.stream.allocator"
public static final String | IS_COALESCING | "javax.xml.stream.isCoalescing"
public static final String | IS_NAMESPACE_AWARE | "javax.xml.stream.isNamespaceAware"
public static final String | IS_REPLACING_ENTITY_REFERENCES | "javax.xml.stream.isReplacingEntityReferences"
public static final String | IS_SUPPORTING_EXTERNAL_ENTITIES | "javax.xml.stream.isSupportingExternalEntities"
public static final String | IS_VALIDATING | "javax.xml.stream.isValidating"
public static final String | REPORTER | "javax.xml.stream.reporter"
public static final String | RESOLVER | "javax.xml.stream.resolver"
public static final String | SUPPORT_DTD | "javax.xml.stream.supportDTD"

javax.xml.stream.XMLOutputFactory
public static final String IS_REPAIRING_NAMESPACES "javax.xml.stream.isRepairingNamespaces"

javax.xml.stream.XMLStreamConstants
public static final int | ATTRIBUTE | 10
public static final int | CDATA | 12
public static final int | CHARACTERS | 4
public static final int | COMMENT | 5
public static final int | DTD | 11
public static final int | END_DOCUMENT | 8
public static final int | END_ELEMENT | 2
public static final int | ENTITY_DECLARATION | 15
public static final int | ENTITY_REFERENCE | 9
public static final int | NAMESPACE | 13
public static final int | NOTATION_DECLARATION | 14
public static final int | PROCESSING_INSTRUCTION | 3
public static final int | SPACE | 6
public static final int | START_DOCUMENT | 7
public static final int | START_ELEMENT | 1

javax.xml.transform.OutputKeys
public static final String | CDATA_SECTION_ELEMENTS | "cdata-section-elements"
public static final String | DOCTYPE_PUBLIC | "doctype-public"
public static final String | DOCTYPE_SYSTEM | "doctype-system"
public static final String | ENCODING | "encoding"
public static final String | INDENT | "indent"
public static final String | MEDIA_TYPE | "media-type"
public static final String | METHOD | "method"
public static final String | OMIT_XML_DECLARATION | "omit-xml-declaration"
public static final String | STANDALONE | "standalone"
public static final String | VERSION | "version"

javax.xml.transform.Result
public static final String | PI_DISABLE_OUTPUT_ESCAPING | "javax.xml.transform.disable-output-escaping"
public static final String | PI_ENABLE_OUTPUT_ESCAPING | "javax.xml.transform.enable-output-escaping"

javax.xml.transform.dom.DOMResult
public static final String FEATURE "http://javax.xml.transform.dom.DOMResult/feature"

javax.xml.transform.dom.DOMSource
public static final String FEATURE "http://javax.xml.transform.dom.DOMSource/feature"

javax.xml.transform.sax.SAXResult
public static final String FEATURE "http://javax.xml.transform.sax.SAXResult/feature"

javax.xml.transform.sax.SAXSource
public static final String FEATURE "http://javax.xml.transform.sax.SAXSource/feature"

javax.xml.transform.sax.SAXTransformerFactory
public static final String | FEATURE | "http://javax.xml.transform.sax.SAXTransformerFactory/feature"
public static final String | FEATURE_XMLFILTER | "http://javax.xml.transform.sax.SAXTransformerFactory/feature/xmlfilter"

javax.xml.transform.stax.StAXResult
public static final String FEATURE "http://javax.xml.transform.stax.StAXResult/feature"

javax.xml.transform.stax.StAXSource
public static final String FEATURE "http://javax.xml.transform.stax.StAXSource/feature"

javax.xml.transform.stream.StreamResult
public static final String FEATURE "http://javax.xml.transform.stream.StreamResult/feature"

javax.xml.transform.stream.StreamSource
public static final String FEATURE "http://javax.xml.transform.stream.StreamSource/feature"

javax.xml.ws.BindingProvider
public static final String | ENDPOINT_ADDRESS_PROPERTY | "javax.xml.ws.service.endpoint.address"
public static final String | PASSWORD_PROPERTY | "javax.xml.ws.security.auth.password"
public static final String | SESSION_MAINTAIN_PROPERTY | "javax.xml.ws.session.maintain"
public static final String | SOAPACTION_URI_PROPERTY | "javax.xml.ws.soap.http.soapaction.uri"
public static final String | SOAPACTION_USE_PROPERTY | "javax.xml.ws.soap.http.soapaction.use"
public static final String | USERNAME_PROPERTY | "javax.xml.ws.security.auth.username"

javax.xml.ws.Endpoint
public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"

javax.xml.ws.handler.MessageContext
public static final String | HTTP_REQUEST_HEADERS | "javax.xml.ws.http.request.headers"
public static final String | HTTP_REQUEST_METHOD | "javax.xml.ws.http.request.method"
public static final String | HTTP_RESPONSE_CODE | "javax.xml.ws.http.response.code"
public static final String | HTTP_RESPONSE_HEADERS | "javax.xml.ws.http.response.headers"
public static final String | INBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.inbound"
public static final String | MESSAGE_OUTBOUND_PROPERTY | "javax.xml.ws.handler.message.outbound"
public static final String | OUTBOUND_MESSAGE_ATTACHMENTS | "javax.xml.ws.binding.attachments.outbound"
public static final String | PATH_INFO | "javax.xml.ws.http.request.pathinfo"
public static final String | QUERY_STRING | "javax.xml.ws.http.request.querystring"
public static final String | SERVLET_CONTEXT | "javax.xml.ws.servlet.context"
public static final String | SERVLET_REQUEST | "javax.xml.ws.servlet.request"
public static final String | SERVLET_RESPONSE | "javax.xml.ws.servlet.response"
public static final String | WSDL_DESCRIPTION | "javax.xml.ws.wsdl.description"
public static final String | WSDL_INTERFACE | "javax.xml.ws.wsdl.interface"
public static final String | WSDL_OPERATION | "javax.xml.ws.wsdl.operation"
public static final String | WSDL_PORT | "javax.xml.ws.wsdl.port"
public static final String | WSDL_SERVICE | "javax.xml.ws.wsdl.service"

javax.xml.ws.http.HTTPBinding
public static final String HTTP_BINDING "http://www.w3.org/2004/08/wsdl/http"

javax.xml.ws.soap.SOAPBinding
public static final String | SOAP11HTTP_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http"
public static final String | SOAP11HTTP_MTOM_BINDING | "http://schemas.xmlsoap.org/wsdl/soap/http?mtom=true"
public static final String | SOAP12HTTP_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/"
public static final String | SOAP12HTTP_MTOM_BINDING | "http://www.w3.org/2003/05/soap/bindings/HTTP/?mtom=true"

javax.xml.ws.spi.Provider
public static final String JAXWSPROVIDER_PROPERTY "javax.xml.ws.spi.Provider"

javax.xml.xpath.XPathConstants
public static final String DOM_OBJECT_MODEL "http://java.sun.com/jaxp/xpath/dom"

javax.xml.xpath.XPathFactory
public static final String | DEFAULT_OBJECT_MODEL_URI | "http://java.sun.com/jaxp/xpath/dom"
public static final String | DEFAULT_PROPERTY_NAME | "javax.xml.xpath.XPathFactory"

org.ietf.*

org.ietf.jgss.GSSContext
public static final int | DEFAULT_LIFETIME | 0
public static final int | INDEFINITE_LIFETIME | 2147483647

org.ietf.jgss.GSSCredential
public static final int | ACCEPT_ONLY | 2
public static final int | DEFAULT_LIFETIME | 0
public static final int | INDEFINITE_LIFETIME | 2147483647
public static final int | INITIATE_AND_ACCEPT | 0
public static final int | INITIATE_ONLY | 1

org.ietf.jgss.GSSException
public static final int | BAD_BINDINGS | 1
public static final int | BAD_MECH | 2
public static final int | BAD_MIC | 6
public static final int | BAD_NAME | 3
public static final int | BAD_NAMETYPE | 4
public static final int | BAD_QOP | 14
public static final int | BAD_STATUS | 5
public static final int | CONTEXT_EXPIRED | 7
public static final int | CREDENTIALS_EXPIRED | 8
public static final int | DEFECTIVE_CREDENTIAL | 9
public static final int | DEFECTIVE_TOKEN | 10
public static final int | DUPLICATE_ELEMENT | 17
public static final int | DUPLICATE_TOKEN | 19
public static final int | FAILURE | 11
public static final int | GAP_TOKEN | 22
public static final int | NAME_NOT_MN | 18
public static final int | NO_CONTEXT | 12
public static final int | NO_CRED | 13
public static final int | OLD_TOKEN | 20
public static final int | UNAUTHORIZED | 15
public static final int | UNAVAILABLE | 16
public static final int | UNSEQ_TOKEN | 21

org.omg.*

org.omg.CORBA.ARG_IN
public static final int value 1

org.omg.CORBA.ARG_INOUT
public static final int value 3

org.omg.CORBA.ARG_OUT
public static final int value 2

org.omg.CORBA.BAD_POLICY
public static final short value 0

org.omg.CORBA.BAD_POLICY_TYPE
public static final short value 2

org.omg.CORBA.BAD_POLICY_VALUE
public static final short value 3

org.omg.CORBA.CompletionStatus
public static final int | _COMPLETED_MAYBE | 2
public static final int | _COMPLETED_NO | 1
public static final int | _COMPLETED_YES | 0

org.omg.CORBA.CTX_RESTRICT_SCOPE
public static final int value 15

org.omg.CORBA.DefinitionKind
public static final int | _dk_AbstractInterface | 24
public static final int | _dk_Alias | 9
public static final int | _dk_all | 1
public static final int | _dk_Array | 16
public static final int | _dk_Attribute | 2
public static final int | _dk_Constant | 3
public static final int | _dk_Enum | 12
public static final int | _dk_Exception | 4
public static final int | _dk_Fixed | 19
public static final int | _dk_Interface | 5
public static final int | _dk_Module | 6
public static final int | _dk_Native | 23
public static final int | _dk_none | 0
public static final int | _dk_Operation | 7
public static final int | _dk_Primitive | 13
public static final int | _dk_Repository | 17
public static final int | _dk_Sequence | 15
public static final int | _dk_String | 14
public static final int | _dk_Struct | 10
public static final int | _dk_Typedef | 8
public static final int | _dk_Union | 11
public static final int | _dk_Value | 20
public static final int | _dk_ValueBox | 21
public static final int | _dk_ValueMember | 22
public static final int | _dk_Wstring | 18

org.omg.CORBA.OMGVMCID
public static final int value 1330446336

org.omg.CORBA.ParameterMode
public static final int | _PARAM_IN | 0
public static final int | _PARAM_INOUT | 2
public static final int | _PARAM_OUT | 1

org.omg.CORBA.PRIVATE_MEMBER
public static final short value 0

org.omg.CORBA.PUBLIC_MEMBER
public static final short value 1

org.omg.CORBA.SetOverrideType
public static final int | _ADD_OVERRIDE | 1
public static final int | _SET_OVERRIDE | 0

org.omg.CORBA.TCKind
public static final int | _tk_abstract_interface | 32
public static final int | _tk_alias | 21
public static final int | _tk_any | 11
public static final int | _tk_array | 20
public static final int | _tk_boolean | 8
public static final int | _tk_char | 9
public static final int | _tk_double | 7
public static final int | _tk_enum | 17
public static final int | _tk_except | 22
public static final int | _tk_fixed | 28
public static final int | _tk_float | 6
public static final int | _tk_long | 3
public static final int | _tk_longdouble | 25
public static final int | _tk_longlong | 23
public static final int | _tk_native | 31
public static final int | _tk_null | 0
public static final int | _tk_objref | 14
public static final int | _tk_octet | 10
public static final int | _tk_Principal | 13
public static final int | _tk_sequence | 19
public static final int | _tk_short | 2
public static final int | _tk_string | 18
public static final int | _tk_struct | 15
public static final int | _tk_TypeCode | 12
public static final int | _tk_ulong | 5
public static final int | _tk_ulonglong | 24
public static final int | _tk_union | 16
public static final int | _tk_ushort | 4
public static final int | _tk_value | 29
public static final int | _tk_value_box | 30
public static final int | _tk_void | 1
public static final int | _tk_wchar | 26
public static final int | _tk_wstring | 27

org.omg.CORBA.UNSUPPORTED_POLICY
public static final short value 1

org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
public static final short value 4

org.omg.CORBA.VM_ABSTRACT
public static final short value 2

org.omg.CORBA.VM_CUSTOM
public static final short value 1

org.omg.CORBA.VM_NONE
public static final short value 0

org.omg.CORBA.VM_TRUNCATABLE
public static final short value 3

org.omg.CosNaming.BindingType
public static final int | _ncontext | 1
public static final int | _nobject | 0

org.omg.CosNaming.NamingContextPackage.NotFoundReason
public static final int | _missing_node | 0
public static final int | _not_context | 1
public static final int | _not_object | 2

org.omg.IOP.CodeSets
public static final int value 1

org.omg.IOP.ENCODING_CDR_ENCAPS
public static final short value 0

org.omg.IOP.ExceptionDetailMessage
public static final int value 14

org.omg.IOP.RMICustomMaxStreamFormat
public static final int value 17

org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
public static final int value 3

org.omg.IOP.TAG_CODE_SETS
public static final int value 1

org.omg.IOP.TAG_INTERNET_IOP
public static final int value 0

org.omg.IOP.TAG_JAVA_CODEBASE
public static final int value 25

org.omg.IOP.TAG_MULTIPLE_COMPONENTS
public static final int value 1

org.omg.IOP.TAG_ORB_TYPE
public static final int value 0

org.omg.IOP.TAG_POLICIES
public static final int value 2

org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
public static final int value 38

org.omg.IOP.TransactionService
public static final int value 0

org.omg.Messaging.SYNC_WITH_TRANSPORT
public static final short value 1

org.omg.PortableInterceptor.ACTIVE
public static final short value 1

org.omg.PortableInterceptor.DISCARDING
public static final short value 2

org.omg.PortableInterceptor.HOLDING
public static final short value 0

org.omg.PortableInterceptor.INACTIVE
public static final short value 3

org.omg.PortableInterceptor.LOCATION_FORWARD
public static final short value 3

org.omg.PortableInterceptor.NON_EXISTENT
public static final short value 4

org.omg.PortableInterceptor.SUCCESSFUL
public static final short value 0

org.omg.PortableInterceptor.SYSTEM_EXCEPTION
public static final short value 1

org.omg.PortableInterceptor.TRANSPORT_RETRY
public static final short value 4

org.omg.PortableInterceptor.UNKNOWN
public static final short value 5

org.omg.PortableInterceptor.USER_EXCEPTION
public static final short value 2

org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
public static final int value 19

org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
public static final int value 18

org.omg.PortableServer.IdAssignmentPolicyValue
public static final int | _SYSTEM_ID | 1
public static final int | _USER_ID | 0

org.omg.PortableServer.IdUniquenessPolicyValue
public static final int | _MULTIPLE_ID | 1
public static final int | _UNIQUE_ID | 0

org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
public static final int value 20

org.omg.PortableServer.ImplicitActivationPolicyValue
public static final int | _IMPLICIT_ACTIVATION | 0
public static final int | _NO_IMPLICIT_ACTIVATION | 1

org.omg.PortableServer.LIFESPAN_POLICY_ID
public static final int value 17

org.omg.PortableServer.LifespanPolicyValue
public static final int | _PERSISTENT | 1
public static final int | _TRANSIENT | 0

org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
public static final int value 22

org.omg.PortableServer.RequestProcessingPolicyValue
public static final int | _USE_ACTIVE_OBJECT_MAP_ONLY | 0
public static final int | _USE_DEFAULT_SERVANT | 1
public static final int | _USE_SERVANT_MANAGER | 2

org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
public static final int value 21

org.omg.PortableServer.ServantRetentionPolicyValue
public static final int | _NON_RETAIN | 1
public static final int | _RETAIN | 0

org.omg.PortableServer.THREAD_POLICY_ID
public static final int value 16

org.omg.PortableServer.ThreadPolicyValue
public static final int | _ORB_CTRL_MODEL | 0
public static final int | _SINGLE_THREAD_MODEL | 1

org.omg.PortableServer.POAManagerPackage.State
public static final int | _ACTIVE | 1
public static final int | _DISCARDING | 2
public static final int | _HOLDING | 0
public static final int | _INACTIVE | 3

org.w3c.*

org.w3c.dom.DOMError
public static final short | SEVERITY_ERROR | 2
public static final short | SEVERITY_FATAL_ERROR | 3
public static final short | SEVERITY_WARNING | 1

org.w3c.dom.DOMException
public static final short | DOMSTRING_SIZE_ERR | 2
public static final short | HIERARCHY_REQUEST_ERR | 3
public static final short | INDEX_SIZE_ERR | 1
public static final short | INUSE_ATTRIBUTE_ERR | 10
public static final short | INVALID_ACCESS_ERR | 15
public static final short | INVALID_CHARACTER_ERR | 5
public static final short | INVALID_MODIFICATION_ERR | 13
public static final short | INVALID_STATE_ERR | 11
public static final short | NAMESPACE_ERR | 14
public static final short | NO_DATA_ALLOWED_ERR | 6
public static final short | NO_MODIFICATION_ALLOWED_ERR | 7
public static final short | NOT_FOUND_ERR | 8
public static final short | NOT_SUPPORTED_ERR | 9
public static final short | SYNTAX_ERR | 12
public static final short | TYPE_MISMATCH_ERR | 17
public static final short | VALIDATION_ERR | 16
public static final short | WRONG_DOCUMENT_ERR | 4

org.w3c.dom.Node
public static final short | ATTRIBUTE_NODE | 2
public static final short | CDATA_SECTION_NODE | 4
public static final short | COMMENT_NODE | 8
public static final short | DOCUMENT_FRAGMENT_NODE | 11
public static final short | DOCUMENT_NODE | 9
public static final short | DOCUMENT_POSITION_CONTAINED_BY | 16
public static final short | DOCUMENT_POSITION_CONTAINS | 8
public static final short | DOCUMENT_POSITION_DISCONNECTED | 1
public static final short | DOCUMENT_POSITION_FOLLOWING | 4
public static final short | DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC | 32
public static final short | DOCUMENT_POSITION_PRECEDING | 2
public static final short | DOCUMENT_TYPE_NODE | 10
public static final short | ELEMENT_NODE | 1
public static final short | ENTITY_NODE | 6
public static final short | ENTITY_REFERENCE_NODE | 5
public static final short | NOTATION_NODE | 12
public static final short | PROCESSING_INSTRUCTION_NODE | 7
public static final short | TEXT_NODE | 3

org.w3c.dom.TypeInfo
public static final int | DERIVATION_EXTENSION | 2
public static final int | DERIVATION_LIST | 8
public static final int | DERIVATION_RESTRICTION | 1
public static final int | DERIVATION_UNION | 4

org.w3c.dom.UserDataHandler
public static final short | NODE_ADOPTED | 5
public static final short | NODE_CLONED | 1
public static final short | NODE_DELETED | 3
public static final short | NODE_IMPORTED | 2
public static final short | NODE_RENAMED | 4

org.w3c.dom.bootstrap.DOMImplementationRegistry
public static final String PROPERTY "org.w3c.dom.DOMImplementationSourceList"

org.w3c.dom.events.Event
public static final short | AT_TARGET | 2
public static final short | BUBBLING_PHASE | 3
public static final short | CAPTURING_PHASE | 1

org.w3c.dom.events.EventException
public static final short UNSPECIFIED_EVENT_TYPE_ERR 0

org.w3c.dom.events.MutationEvent
public static final short | ADDITION | 2
public static final short | MODIFICATION | 1
public static final short | REMOVAL | 3

org.w3c.dom.ls.DOMImplementationLS
public static final short | MODE_ASYNCHRONOUS | 2
public static final short | MODE_SYNCHRONOUS | 1

org.w3c.dom.ls.LSException
public static final short | PARSE_ERR | 81
public static final short | SERIALIZE_ERR | 82

org.w3c.dom.ls.LSParser
public static final short | ACTION_APPEND_AS_CHILDREN | 1
public static final short | ACTION_INSERT_AFTER | 4
public static final short | ACTION_INSERT_BEFORE | 3
public static final short | ACTION_REPLACE | 5
public static final short | ACTION_REPLACE_CHILDREN | 2

org.w3c.dom.ls.LSParserFilter
public static final short | FILTER_ACCEPT | 1
public static final short | FILTER_INTERRUPT | 4
public static final short | FILTER_REJECT | 2
public static final short | FILTER_SKIP | 3

org.xml.*

org.xml.sax.helpers.NamespaceSupport
public static final String | NSDECL | "http://www.w3.org/xmlns/2000/"
public static final String | XMLNS | "http://www.w3.org/XML/1998/namespace"

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架
提交错误或意见
有关更多的 API 参考资料和开发人员文档，请参阅 Java 2 SDK SE 开发人员文档。该文档包含更详细的、面向开发人员的描述，以及总体概述、术语定义、使用技巧和工作代码示例。

版权所有 2004 Sun Microsystems, Inc. 保留所有权利。 请遵守许可证条款。另请参阅文档重新分发政策。


序列化表格 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

序列化表格

软件包 java.applet

类 java.applet.Applet 继承 Panel 实现 Serializable

serialVersionUID: -5836846270535785031L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
从对象输入流读取 applet。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

accessibleContext

AccessibleContext accessibleContext

类 java.applet.Applet.AccessibleApplet 继承 Panel.AccessibleAWTPanel 实现 Serializable

serialVersionUID: 8127374778187708896L

软件包 java.awt

类 java.awt.AWTError 继承 Error 实现 Serializable

serialVersionUID: -1819846354050686206L

类 java.awt.AWTEvent 继承 EventObject 实现 Serializable

serialVersionUID: -1825314779160409405L

序列化字段

bdata

byte[] bdata

id

int id
事件的 id。

另请参见：
AWTEvent.getID(), AWTEvent.AWTEvent(java.lang.Object, int)

consumed

boolean consumed
在源处理了事件之后，控制是否将事件发送回同位体，false 表示将事件发送给同位体；true 则不发送。语义事件始终具有 'true' 值，因为它们由响应低级别事件的同位体生成。

另请参见：
AWTEvent.consume(), AWTEvent.isConsumed()

类 java.awt.AWTException 继承 Exception 实现 Serializable

serialVersionUID: -1900414231151323879L

类 java.awt.AWTKeyStroke 继承 Object 实现 Serializable

serialVersionUID: -6430539691155161871L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。

抛出：
ObjectStreamException
序列化字段

keyChar

char keyChar

keyCode

int keyCode

modifiers

int modifiers

onKeyRelease

boolean onKeyRelease

类 java.awt.AWTPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 8890392402588814465L

类 java.awt.BorderLayout 继承 Object 实现 Serializable

serialVersionUID: -8658291919501921765L

序列化字段

hgap

int hgap
Constructs a border layout with the horizontal gaps between components. The horizontal gap is specified by hgap.

另请参见：
BorderLayout.getHgap(), BorderLayout.setHgap(int)

vgap

int vgap
Constructs a border layout with the vertical gaps between components. The vertical gap is specified by vgap.

另请参见：
BorderLayout.getVgap(), BorderLayout.setVgap(int)

north

Component north
Constant to specify components location to be the north portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

west

Component west
Constant to specify components location to be the west portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

east

Component east
Constant to specify components location to be the east portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

south

Component south
Constant to specify components location to be the south portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

center

Component center
Constant to specify components location to be the center portion of the border layout.

另请参见：
BorderLayout.getChild(String, boolean),
BorderLayout.addLayoutComponent(java.awt.Component, java.lang.Object),
BorderLayout.getLayoutAlignmentX(java.awt.Container),
BorderLayout.getLayoutAlignmentY(java.awt.Container),
BorderLayout.removeLayoutComponent(java.awt.Component)

firstLine

Component firstLine
A relative positioning constant, that can be used instead of north, south, east, west or center. mixing the two types of constants can lead to unpredicable results. If you use both types, the relative constants will take precedence. For example, if you add components using both the NORTH and BEFORE_FIRST_LINE constants in a container whose orientation is LEFT_TO_RIGHT, only the BEFORE_FIRST_LINE will be layed out. This will be the same for lastLine, firstItem, lastItem.

lastLine

Component lastLine
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

firstItem

Component firstItem
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

lastItem

Component lastItem
A relative positioning constant, that can be used instead of north, south, east, west or center. Please read Description for firstLine.

类 java.awt.Button 继承 Component 实现 Serializable

serialVersionUID: -8774683716313001058L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收按钮激发的动作事件。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
Button.removeActionListener(ActionListener),
Button.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless(),
Button.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流。写入可序列化 ActionListeners 的一个列表作为可选数据。检测不可序列化的 ActionListeners，不会试图对它们进行序列化。

序列数据：
以 null 终止的 0 或多对序列：该对由一个 String 和一个 Object 组成；String 指示对象的类型，它是以下类型之一：指示 ActionListener 对象的 actionListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK, Button.readObject(ObjectInputStream)
序列化字段

label

String label
The button's label. This value may be null.

另请参见：
Button.getLabel(), Button.setLabel(String)

actionCommand

String actionCommand
The action to be performed once a button has been pressed. This value may be null.

另请参见：
Button.getActionCommand(), Button.setActionCommand(String)

buttonSerializedDataVersion

int buttonSerializedDataVersion

类 java.awt.Button.AccessibleAWTButton 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -5932203980244017102L

类 java.awt.Canvas 继承 Component 实现 Serializable

serialVersionUID: -2284879212465893870L

类 java.awt.Canvas.AccessibleAWTCanvas 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -6325592262103146699L

类 java.awt.CardLayout 继承 Object 实现 Serializable

serialVersionUID: -4328196481005934313L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从流中读取可序列化的字段。

抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
向流中写入可序列化的字段。

抛出：
IOException
序列化字段

currentCard

int currentCard

hgap

int hgap

tab

Hashtable<K,V> tab
已过时，仅用于向前兼容

vector

Vector<E> vector

vgap

int vgap

类 java.awt.Checkbox 继承 Component 实现 Serializable

serialVersionUID: 7270714317450821763L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 Checkbox 触发的项事件。忽略未被识别的键或值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
Checkbox.removeItemListener(ItemListener),
Checkbox.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Checkbox.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。写入可序列化 ItemListeners 的一个列表作为可选数据。检测不可序列化的 ItemListeners，不要尝试对它们进行序列化。

序列数据：
null 表示终止 0 或多个对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：itemListenerK 指示一个 ItemListener 对象
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Checkbox.readObject(ObjectInputStream)
序列化字段

label

String label
The label of the Checkbox. This field can be null.

另请参见：
Checkbox.getLabel(), Checkbox.setLabel(String)

state

boolean state
The state of the Checkbox.

另请参见：
Checkbox.getState(), Checkbox.setState(boolean)

group

CheckboxGroup group
The check box group. This field can be null indicating that the checkbox is not a group checkbox.

另请参见：
Checkbox.getCheckboxGroup(), Checkbox.setCheckboxGroup(CheckboxGroup)

checkboxSerializedDataVersion

int checkboxSerializedDataVersion

类 java.awt.Checkbox.AccessibleAWTCheckbox 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 7881579233144754107L

类 java.awt.CheckboxGroup 继承 Object 实现 Serializable

serialVersionUID: 3729780091441768983L

序列化字段

selectedCheckbox

Checkbox selectedCheckbox
The current choice.

另请参见：
CheckboxGroup.getCurrent(), CheckboxGroup.setCurrent(Checkbox)

类 java.awt.CheckboxMenuItem 继承 MenuItem 实现 Serializable

serialVersionUID: 6190621106981774043L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流。写入可序列化 ItemListeners 的一个列表作为可选数据。检测不可序列化的 ItemListeners，不要尝试对它们进行序列化。

序列数据：
以 null 终止的 0 或多对序列；该对由一个 String 和一个 Object 组成；String 指示对象的类型，它是以下类型之一：指示 ItemListener 对象的 itemListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, CheckboxMenuItem.readObject(ObjectInputStream)
序列化字段

state

boolean state
The state of a checkbox menu item

另请参见：
CheckboxMenuItem.getState(), CheckboxMenuItem.setState(boolean)

checkboxMenuItemSerializedDataVersion

int checkboxMenuItemSerializedDataVersion

类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 继承 MenuItem.AccessibleAWTMenuItem 实现 Serializable

serialVersionUID: -1122642964303476L

类 java.awt.Choice 继承 Component 实现 Serializable

serialVersionUID: -4075310674757313071L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 Choice 项触发的项事件。忽略未被识别的键或值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
Choice.removeItemListener(ItemListener),
Choice.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
Choice.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。写入可序列化 ItemListeners 的一个列表作为可选数据。检测不可序列化的 ItemListeners，不要尝试对它们进行序列化。

序列数据：
null 表示终止 0 或多个对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：itemListenerK 指示一个 ItemListener 对象
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Choice.readObject(ObjectInputStream)
序列化字段

pItems

Vector<E> pItems
The items for the Choice. This can be a null value.

另请参见：
Choice.add(String),
Choice.addItem(String),
Choice.getItem(int),
Choice.getItemCount(),
Choice.insert(String, int),
Choice.remove(String)

selectedIndex

int selectedIndex
The index of the current choice for this Choice or -1 if nothing is selected.

另请参见：
Choice.getSelectedItem(), Choice.select(int)

choiceSerializedDataVersion

int choiceSerializedDataVersion

类 java.awt.Choice.AccessibleAWTChoice 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 7175603582428509322L

类 java.awt.Color 继承 Object 实现 Serializable

serialVersionUID: 118526816881161077L

序列化字段

value

int value
The color value.

另请参见：
Color.getRGB()

frgbvalue

float[] frgbvalue
默认 sRGB ColorSpace 中的颜色值可看作是 float 分量（不带 alpha 值）。如果在构造对象之后颜色值为 null，则此颜色必须是用 8 位精度构造的一种 sRGB 颜色，因此要从 int 颜色值开始计算。

另请参见：
Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

fvalue

float[] fvalue
本机 sRGB ColorSpace 中的颜色值可看作是 float 分量（不带 alpha 值）。如果在构造对象之后颜色值为 null，则此颜色必须是用 8 位精度构造的一种 sRGB 颜色，因此要从 int 颜色值开始计算。

另请参见：
Color.getRGBColorComponents(float[]), Color.getRGBComponents(float[])

falpha

float falpha
alpha 值可看作是一个 float 分量。如果 frgbvalue 为 null，那么这是一个无效数据，因此要从 int 颜色值开始计算。

另请参见：
Color.getRGBComponents(float[]), Color.getComponents(float[])

cs

ColorSpace cs
ColorSpace。如果 ColorSpace 为 null，那么其默认值为 sRGB。

另请参见：
Color.getColor(java.lang.String),
Color.getColorSpace(),
Color.getColorComponents(float[])

类 java.awt.Component 继承 Object 实现 Serializable

serialVersionUID: -7644114512714619750L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
读取 ObjectInputStream 并且如果它不为 null，则添加一个侦听器，以便接收由组件所激发的各种事件。忽略未识别的键或值。

抛出：
ClassNotFoundException
IOException
另请参见：
Component.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。将各种可序列化侦听器作为可选数据写入。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
以 null 终止的 0 或多对序列；该对由一个 String 和一个 Object 组成；String 表示对象的类型并为下列类型之一（1.4 中）：componentListenerK 表示 ComponentListener 对象；focusListenerK 表示 FocusListener 对象；keyListenerK 表示 KeyListener 对象；mouseListenerK 表示 MouseListener 对象；mouseMotionListenerK 表示 MouseMotionListener 对象；InputMethodListener 表示 InputMethodListener 对象；hierarchyListenerK 表示 HierarchyListener 对象；hierarchyBoundsListenerK 表示 HierarchyBoundsListener 对象；mouseWheelListenerK 表示 MouseWheelListener 对象, 一个可选的 ComponentOrientation（在 1.2 中位于 inputMethodListener 之后）
抛出：
IOException
另请参见：
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.componentListenerK, Component.focusListenerK, Component.keyListenerK, Component.mouseListenerK, Component.mouseMotionListenerK, Component.inputMethodListenerK, Component.hierarchyListenerK, Component.hierarchyBoundsListenerK, Component.mouseWheelListenerK, Component.readObject(ObjectInputStream)
序列化字段

x

int x
The x position of the component in the parent's coordinate system.

另请参见：
Component.getLocation()

y

int y
The y position of the component in the parent's coordinate system.

另请参见：
Component.getLocation()

width

int width
The width of the component.

另请参见：
Component.getSize()

height

int height
The height of the component.

另请参见：
Component.getSize()

foreground

Color foreground
The foreground color for this component. foreground can be null.

另请参见：
Component.getForeground(), Component.setForeground(java.awt.Color)

background

Color background
The background color for this component. background can be null.

另请参见：
Component.getBackground(), Component.setBackground(java.awt.Color)

font

Font font
The font used by this component. The font can be null.

另请参见：
Component.getFont(), Component.setFont(java.awt.Font)

peerFont

Font peerFont
The font which the peer is currently using. (null if no peer exists.)

cursor

Cursor cursor
The cursor displayed when pointer is over this component. This value can be null.

另请参见：
Component.getCursor(), Component.setCursor(java.awt.Cursor)

locale

Locale locale
The locale for the component.

另请参见：
Component.getLocale(), Component.setLocale(java.util.Locale)

ignoreRepaint

boolean ignoreRepaint
True when the object should ignore all repaint events.

从以下版本开始：
1.4
另请参见：
Component.setIgnoreRepaint(boolean), Component.getIgnoreRepaint()

visible

boolean visible
True when the object is visible. An object that is not visible is not drawn on the screen.

另请参见：
Component.isVisible(), Component.setVisible(boolean)

enabled

boolean enabled
True when the object is enabled. An object that is not enabled does not interact with the user.

另请参见：
Component.isEnabled(), Component.setEnabled(boolean)

valid

boolean valid
True when the object is valid. An invalid object needs to be layed out. This flag is set to false when the object size is changed.

另请参见：
Component.isValid(),
Component.validate(),
Component.invalidate()

dropTarget

DropTarget dropTarget
The DropTarget associated with this component.

从以下版本开始：
1.2
另请参见：
Component.setDropTarget(java.awt.dnd.DropTarget), Component.getDropTarget()

popups

Vector<E> popups
另请参见：
Component.add(java.awt.PopupMenu)

name

String name
组件名称。该字段可以为 null。

另请参见：
Component.getName(), Component.setName(String)

nameExplicitlySet

boolean nameExplicitlySet
确定是否已显示地设置了名称的布尔值。如果尚未设置名称，则 nameExplicitlySet 为 false；否则为 true。

另请参见：
Component.getName(), Component.setName(String)

focusable

boolean focusable
表示此 Component 是否可以获得焦点。

从以下版本开始：
1.4
另请参见：
Component.setFocusable(boolean), Component.isFocusable()

isFocusTraversableOverridden

int isFocusTraversableOverridden
跟踪此 Component 是否依赖于默认的焦点可遍历性。

从以下版本开始：
1.4

focusTraversalKeys

Set<E>[] focusTraversalKeys
The focus traversal keys. These keys will generate focus traversal behavior for Components for which focus traversal keys are enabled. If a value of null is specified for a traversal key, this Component inherits that traversal key from its parent. If all ancestors of this Component have null specified for that traversal key, then the current KeyboardFocusManager's default traversal key is used.

从以下版本开始：
1.4
另请参见：
Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int)

focusTraversalKeysEnabled

boolean focusTraversalKeysEnabled
表示是否为此 Component 启用了焦点遍历键。其焦点遍历键已禁用的 Component 接收这些焦点遍历键的按键事件。其焦点遍历键已启用的 Component 不会看到这些事件；相反，会将该事件自动转换为遍历操作。

从以下版本开始：
1.4
另请参见：
Component.setFocusTraversalKeysEnabled(boolean), Component.getFocusTraversalKeysEnabled()

minSize

Dimension minSize
Minimum size. (This field perhaps should have been transient).

minSizeSet

boolean minSizeSet
Whether or not setMinimumSize has been invoked with a non-null value.

prefSize

Dimension prefSize
Preferred size. (This field perhaps should have been transient).

prefSizeSet

boolean prefSizeSet
Whether or not setPreferredSize has been invoked with a non-null value.

maxSize

Dimension maxSize
Maximum size

maxSizeSet

boolean maxSizeSet
Whether or not setMaximumSize has been invoked with a non-null value.

newEventsOnly

boolean newEventsOnly
newEventsOnly will be true if the event is one of the event types enabled for the component. It will then allow for normal processing to continue. If it is false the event is passed to the component's parent and up the ancestor tree until the event has been consumed.

另请参见：
Component.dispatchEvent(java.awt.AWTEvent)

eventMask

long eventMask
The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them. One bit is used to indicate whether input methods are enabled; this bit is set by enableInputMethods and is on by default.

另请参见：
Component.enableInputMethods(boolean), AWTEvent

changeSupport

PropertyChangeSupport changeSupport
如果已注册了任意 PropertyChangeListener，则 changeSupport 字段负责描述它们。

从以下版本开始：
1.2
另请参见：
Component.addPropertyChangeListener(java.beans.PropertyChangeListener),
Component.removePropertyChangeListener(java.beans.PropertyChangeListener),
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

isPacked

boolean isPacked

boundsOp

int boundsOp
直接用于几何学 API（setLocation、setBounds、setSize）的伪参数，通知 setBounds 发生了什么改变。应该在 TreeLock 下使用。需要它的唯一原因是无法改变公共和否决方法的交叉调用顺序。

componentSerializedDataVersion

int componentSerializedDataVersion
序列化的 Component 数据版本。

accessibleContext

AccessibleContext accessibleContext

类 java.awt.Component.AccessibleAWTComponent 继承 AccessibleContext 实现 Serializable

serialVersionUID: 642321655757800191L

序列化字段

accessibleAWTComponentHandler

ComponentListener accessibleAWTComponentHandler

accessibleAWTFocusHandler

FocusListener accessibleAWTFocusHandler

类 java.awt.ComponentOrientation 继承 Object 实现 Serializable

serialVersionUID: -4113291392143563828L

序列化字段

orientation

int orientation

类 java.awt.Container 继承 Component 实现 Serializable

serialVersionUID: 4613797578919906343L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化来自指定 ObjectInputStream 的 Container。
  • 从流中读取默认可序列化字段。
  • 读取可序列化 ContainerListener(s) 的一个列表作为可选数据。如果列表为 null，则不安装任何 Listener。
  • 读取此 Container 的 FocusTraversalPolicy 作为可选数据，它可以为 null。

抛出：
ClassNotFoundException
IOException
另请参见：
Container.addContainerListener(java.awt.event.ContainerListener), Container.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此 Container 序列化到指定的 ObjectOutputStream 中。
  • 将默认可序列化字段写入流中。
  • 写入可序列化 ContainerListener(s) 的一个列表作为可选数据。检测不可序列化的 ContainerListner(s)，不要试图对它们进行序列化。
  • 当且仅当此 Container 的 FocusTraversalPolicy 是可序列化的时候，才写入它；否则写入 null。

序列数据：
null 表示终止 0 或多个对的序列；这种对是由 String 和 Object 组成的；String 指示了对象类型，它为以下类型之一：指示 ContainerListener 对象的 containerListenerK、Container 的 FocusTraversalPolicy 或 null
抛出：
IOException
另请参见：
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.containerListenerK, Container.readObject(ObjectInputStream)
序列化字段

component

Component[] component
容器中的组件。

containerSerializedDataVersion

int containerSerializedDataVersion
Container Serial Data Version。

dispatcher

java.awt.LightweightDispatcher dispatcher
轻量级组件的事件路由器。如果容器是本机的，则此调度程序会小心转发这些事件，将它们的目标重新指向所包含的轻量级组件（如果有）。

focusCycleRoot

boolean focusCycleRoot
指示此 Component 是否是某个焦点遍历循环的根。一旦焦点进入某个遍历循环，它通常无法通过焦点遍历离开，除非按下向上键或向下键之一。普通遍历被限定于此 Container，该 Container 的所有子代并不是下级焦点循环根的子代。

focusTraversalPolicyProvider

boolean focusTraversalPolicyProvider
存储 focusTraversalPolicyProvider 属性的值。

layoutMgr

LayoutManager layoutMgr
此容器的布局管理器。

maxSize

Dimension maxSize
此 Container 的最大大小。

ncomponents

int ncomponents
容器中组件的数量。该值可以为 null。

类 java.awt.Container.AccessibleAWTContainer 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 5081320404842566097L

序列化字段

accessibleContainerHandler

ContainerListener accessibleContainerHandler

类 java.awt.ContainerOrderFocusTraversalPolicy 继承 FocusTraversalPolicy 实现 Serializable

serialVersionUID: 486933713763926351L

序列化字段

implicitDownCycleTraversal

boolean implicitDownCycleTraversal

类 java.awt.Cursor 继承 Object 实现 Serializable

serialVersionUID: 8028237497568985504L

序列化字段

type

int type
The chosen cursor type initially set to the DEFAULT_CURSOR.

另请参见：
Cursor.getType()

name

String name
光标的用户可视名称。

另请参见：
Cursor.getName()

类 java.awt.DefaultFocusTraversalPolicy 继承 ContainerOrderFocusTraversalPolicy 实现 Serializable

serialVersionUID: 8876966522510157497L

类 java.awt.Dialog 继承 Window 实现 Serializable

serialVersionUID: 5920926903803293709L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
抛出：
ClassNotFoundException
IOException
HeadlessException
序列化字段

resizable

boolean resizable
A dialog's resizable property. Will be true if the Dialog is to be resizable, otherwise it will be false.

另请参见：
Dialog.setResizable(boolean)

undecorated

boolean undecorated
This field indicates whether the dialog is undecorated. This property can only be changed while the dialog is not displayable. undecorated will be true if the dialog is undecorated, otherwise it will be false.

从以下版本开始：
1.4
另请参见：
Dialog.setUndecorated(boolean),
Dialog.isUndecorated(),
Component.isDisplayable()

modal

boolean modal
True if this dialog is modal, false is the dialog is modeless. A modal dialog blocks user input to some application top-level windows. This field is kept only for backwards compatibility. Use the ModalityType enum instead.

另请参见：
Dialog.isModal(), Dialog.setModal(boolean), Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType), Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE

modalityType

Dialog.ModalityType modalityType
Modality type of this dialog. If the dialog's modality type is not ModalityType.MODELESS, it blocks all user input to some application top-level windows.

从以下版本开始：
1.6
另请参见：
Dialog.ModalityType, Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType)

title

String title
Specifies the title of the Dialog. This field can be null.

另请参见：
Dialog.getTitle(), Dialog.setTitle(String)

类 java.awt.Dialog.AccessibleAWTDialog 继承 Window.AccessibleAWTWindow 实现 Serializable

serialVersionUID: 4837230331833941201L

类 java.awt.Dimension 继承 Dimension2D 实现 Serializable

serialVersionUID: 4723952579491349524L

序列化字段

width

int width
dimension 的宽度，可以使用负值。

从以下版本开始：
1.0
另请参见：
Dimension.getSize(), Dimension.setSize(double, double)

height

int height
dimension 的高度，可以使用负值。

从以下版本开始：
1.0
另请参见：
Dimension.getSize(), Dimension.setSize(double, double)

类 java.awt.Event 继承 Object 实现 Serializable

serialVersionUID: 5488922509400504703L

序列化字段

target

Object target
目标组件。这指示事件针对该组件发生，或事件与该组件关联。此对象已经由 AWTEvent.getSource() 取代。

另请参见：
EventObject.getSource()

when

long when
时间戳。由 InputEvent.getWhen() 取代。

另请参见：
InputEvent.getWhen()

id

int id
指示事件是什么类型的事件，其他哪个 Event 变量与该事件有关。它已经由 AWTEvent.getID() 取代。

另请参见：
AWTEvent.getID()

x

int x
事件的 x 坐标。由 MouseEvent.getX() 取代。

另请参见：
MouseEvent.getX()

y

int y
事件的 y 坐标。由 MouseEvent.getY() 取代。

另请参见：
MouseEvent.getY()

key

int key
在键盘事件中被按下的键的键代码。这已经由 KeyEvent.getKeyCode() 取代。

另请参见：
KeyEvent.getKeyCode()

modifiers

int modifiers
修饰符键的状态。这已经由 InputEvent.getModifiers() 取代。在 java 1.1 中，MouseEvent 和 KeyEvent 是 InputEvent 的子类。

另请参见：
InputEvent.getModifiers()

clickCount

int clickCount
对于 MOUSE_DOWN 事件来说，此字段指示连续点击的次数。对于其他事件，其值为 0。此字段由 MouseEvent.getClickCount() 取代。

另请参见：
MouseEvent.getClickCount().

arg

Object arg
事件的任意参数。此字段的值取决于事件的类型。arg 已经由事件指定的属性取代。

evt

Event evt
下一事件。将事件放入到链接列表时设置此字段。这已经由 EventQueue 取代。

另请参见：
EventQueue

consumed

boolean consumed
此字段控制当目标处理完事件时，该事件是否发送回同位体——如果为 false，则发送回同位体，如果为 true，则不发送。

另请参见：
Event.isConsumed()

类 java.awt.FileDialog 继承 Dialog 实现 Serializable

serialVersionUID: 5035145889651310422L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
读取 ObjectInputStream，并执行向后兼容检查，将 dir 或等于空字符串的 file 转换为 null。

抛出：
ClassNotFoundException
IOException
序列化字段

mode

int mode

dir

String dir

file

String file

filter

FilenameFilter filter

类 java.awt.FlowLayout 继承 Object 实现 Serializable

serialVersionUID: -7262534875583282631L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从序列化流读取此对象，处理由类的较旧版本写入的对象，该版本不包含我们现在使用的所有字段。

抛出：
IOException
ClassNotFoundException
序列化字段

align

int align
align is the property that determines how each row distributes empty space. It can be one of the following values:
    LEFT RIGHT CENTER LEADING TRAILING

另请参见：
FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

newAlign

int newAlign
newAlign is the property that determines how each row distributes empty space for the Java 2 platform, v1.2 and greater. It can be one of the following three values:
    LEFT RIGHT CENTER LEADING TRAILING

从以下版本开始：
1.2
另请参见：
FlowLayout.getAlignment(), FlowLayout.setAlignment(int)

hgap

int hgap
The flow layout manager allows a seperation of components with gaps. The horizontal gap will specify the space between components and between the components and the borders of the Container.

另请参见：
FlowLayout.getHgap(), FlowLayout.setHgap(int)

vgap

int vgap
The flow layout manager allows a seperation of components with gaps. The vertical gap will specify the space between rows and between the the rows and the borders of the Container.

另请参见：
FlowLayout.getHgap(), FlowLayout.setHgap(int)

alignOnBaseline

boolean alignOnBaseline
如果组件将沿着其基线对齐，则返回 true。

serialVersionOnStream

int serialVersionOnStream
表示正被使用的 currentSerialVersion。它将是以下两个值之一：0，Java 2 平台 v1.2 之前的版本1，Java 2 平台 v1.2 之后的版本

从以下版本开始：
1.2

类 java.awt.Font 继承 Object 实现 Serializable

serialVersionUID: -4206021311591459213L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
读取 ObjectInputStream。未识别的密钥或值将被忽略。

抛出：
ClassNotFoundException
IOException
另请参见：
Font.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
将默认的可序列化字段写入流中。

抛出：
ClassNotFoundException
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Font.readObject(java.io.ObjectInputStream)
序列化字段

fRequestedAttributes

Hashtable<K,V> fRequestedAttributes
此方法现在只在序列化期间使用。它通常为 null。

另请参见：
Font.getAttributes()

name

String name
Font 的逻辑名称，它被传递到构造方法中。

从以下版本开始：
JDK1.0
另请参见：
Font.getName()

style

int style
Font 的样式，它被传递到构造方法中。此样式可以为 PLAIN、BOLD、ITALIC 或 BOLD+ITALIC。

从以下版本开始：
JDK1.0
另请参见：
Font.getStyle()

size

int size
Font 的磅值大小，舍入为整数。

从以下版本开始：
JDK1.0
另请参见：
Font.getSize()

pointSize

float pointSize
以 float 形式表示的 Font 的磅值大小。

另请参见：
Font.getSize(), Font.getSize2D()

fontSerializedDataVersion

int fontSerializedDataVersion
Font 的可序列化数据形式。

类 java.awt.FontFormatException 继承 Exception 实现 Serializable

serialVersionUID: -4481290147811361272L

类 java.awt.FontMetrics 继承 Object 实现 Serializable

serialVersionUID: 1681126225205050147L

序列化字段

font

Font font
实际的 Font，字体规格是由此创建的。它不能为 null。

另请参见：
FontMetrics.getFont()

类 java.awt.Frame 继承 Window 实现 Serializable

serialVersionUID: 2673458971256075116L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream。尝试读取一个 Image 图标，它是从 1.4 版本开始可用的可选数据。如果有一个 Image 图标不可用，但是已经检测了除 EOF 之外的所有数据，则抛出 OptionalDataException。未识别的键或值将被忽略。

抛出：
OptionalDataException - 如果某个 Image 图标不可用，但是已经检测了除 EOF 之外的所有数据
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(),
Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可选的序列化 Image 图标，从 1.4 版本开始，该图标是可用的。

序列数据：
可选的 Image 图标
抛出：
IOException
另请参见：
Image,
Frame.getIconImage(),
Frame.setIconImage(Image),
Frame.readObject(ObjectInputStream)
序列化字段

maximizedBounds

Rectangle maximizedBounds
Maximized bounds for this frame.

从以下版本开始：
1.4
另请参见：
Frame.setMaximizedBounds(Rectangle), Frame.getMaximizedBounds()

title

String title
This is the title of the frame. It can be changed at any time. title can be null and if this is the case the title = "".

另请参见：
Frame.getTitle(), Frame.setTitle(String)

menuBar

MenuBar menuBar
The frames menubar. If menuBar = null the frame will not have a menubar.

另请参见：
Frame.getMenuBar(), Frame.setMenuBar(MenuBar)

resizable

boolean resizable
This field indicates whether the frame is resizable. This property can be changed at any time. resizable will be true if the frame is resizable, otherwise it will be false.

另请参见：
Frame.isResizable()

undecorated

boolean undecorated
This field indicates whether the frame is undecorated. This property can only be changed while the frame is not displayable. undecorated will be true if the frame is undecorated, otherwise it will be false.

从以下版本开始：
1.4
另请参见：
Frame.setUndecorated(boolean),
Frame.isUndecorated(),
Component.isDisplayable()

mbManagement

boolean mbManagement
mbManagement is only used by the Motif implementation.

state

int state

ownedWindows

Vector<E> ownedWindows

frameSerializedDataVersion

int frameSerializedDataVersion
Frame 的序列化数据版本。

类 java.awt.Frame.AccessibleAWTFrame 继承 Window.AccessibleAWTWindow 实现 Serializable

serialVersionUID: -6172960752956030250L

类 java.awt.GraphicsConfigTemplate 继承 Object 实现 Serializable

serialVersionUID: -8061369279557787079L

类 java.awt.GridBagConstraints 继承 Object 实现 Serializable

serialVersionUID: -1000070633030801713L

序列化字段

gridx

int gridx
指定包含组件的显示区域开始边的单元格，其中行的第一个单元格为 gridx=0。组件显示区域的开始边指的是水平的、从左到右的容器的左边缘，以及水平的、从右到左的容器的右边缘。值 RELATIVE 指定将组件放置在添加此组件之前刚刚添加到容器中的组件的后面。

默认值为 RELATIVE。gridx 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridy, ComponentOrientation

gridy

int gridy
指定位于组件显示区域的顶部的单元格，其中最上边的单元格为 gridy=0。值 RELATIVE 指定将组件放置在添加此组件之前刚刚添加到容器中的组件的下面。

默认值为 RELATIVE。gridy 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridx

gridwidth

int gridwidth
指定组件显示区域的某一行中的单元格数。

使用 REMAINDER 指定组件的显示区域，该区域的范围是从 gridx 到该行的最后一个单元格。使用 RELATIVE 指定组件的显示区域，该区域的范围是从 gridx 到它所在行的倒数第二个单元格。

gridwidth 应为非负，默认值为 1。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridheight

gridheight

int gridheight
指定在组件显示区域的一列中的单元格数。

使用 REMAINDER 指定组件的显示区域，该区域的范围是从 gridy 到该列的最后一个单元格。使用 RELATIVE 指定组件的显示区域，该区域的范围是从 gridy 到它所在列的倒数第二个单元格。

gridheight 应为非负，默认值为 1。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.gridwidth

weightx

double weightx
指定如何分布额外的水平空间。

网格包布局管理器计算出列的权重将是列的所有组件中最大的 weightx。如果得到的布局在水平方向上比需要填充的区域小，那么系统会将额外的空间按照其权重比例分布到每一列。权重为零的列不会得到额外的空间。

如果所有的权重都为零，则所有的额外空间都将出现在单元格的网格之间和左右边缘之间。

此字段的默认值为 0。weightx 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.weighty

weighty

double weighty
指定如何分布额外的垂直空间。

网格包布局管理器计算出行的权重将是行的所有组件中最大的 weighty。如果得到的布局在垂直方向上比需要填充的区域小，则系统会将额外的空间按照其权重比例分布到每一行。权重为零的行不会得到额外的空间。

如果所有的权重都为零，则所有的额外空间都将出现在单元格的网格之间和上下边缘之间。

此字段的默认值为 0。weighty 应为非负值。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.weightx

anchor

int anchor
当组件小于其显示区域时使用此字段。它可以确定在显示区域中放置组件的位置。

可能的值有三种：相对于方向的值、相对于基线的值和绝对值。相对于方向的值是相对于容器的组件方向属性进行解释的，相对于基线值是相对于基线进行解释的，绝对值则不然。绝对值有：CENTER、NORTH、NORTHEAST、EAST、SOUTHEAST、SOUTH、SOUTHWEST、WEST 和 NORTHWEST。方向相对值有：PAGE_START、PAGE_END、LINE_START、LINE_END、FIRST_LINE_START、FIRST_LINE_END、LAST_LINE_START 和 LAST_LINE_END。相对于基线的值有：BASELINE、BASELINE_LEADING、BASELINE_TRAILING、ABOVE_BASELINE、ABOVE_BASELINE_LEADING、ABOVE_BASELINE_TRAILING、BELOW_BASELINE、BELOW_BASELINE_LEADING 和 BELOW_BASELINE_TRAILING。默认值为 CENTER。

另请参见：
GridBagConstraints.clone(), ComponentOrientation

fill

int fill
当组件的显示区域大于它所请求的显示区域的大小时使用此字段。它可以确定是否调整组件大小，以及在需要的时候如何进行调整。

以下值适用于 fill：

  • NONE：不调整组件大小。
  • HORIZONTAL：加宽组件，使它在水平方向上填满其显示区域，但是不改变高度。
  • VERTICAL：加高组件，使它在垂直方向上填满其显示区域，但是不改变宽度。
  • BOTH：使组件完全填满其显示区域。

默认值为 NONE。

另请参见：
GridBagConstraints.clone()

insets

Insets insets
此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。

默认值为 new Insets(0, 0, 0, 0)。

另请参见：
GridBagConstraints.clone()

ipadx

int ipadx
此字段指定组件的内部填充，即给组件的最小宽度添加多大的空间。组件的宽度至少为其最小宽度加上 ipadx 像素。

默认值为 0。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.ipady

ipady

int ipady
此字段指定内部填充，即给组件的最小高度添加多大的空间。组件的高度至少为其最小高度加上 ipady 像素。

默认值为 0。

另请参见：
GridBagConstraints.clone(), GridBagConstraints.ipadx

tempX

int tempX
Temporary place holder for the x coordinate.

tempY

int tempY
Temporary place holder for the y coordinate.

tempWidth

int tempWidth
Temporary place holder for the Width of the component.

tempHeight

int tempHeight
Temporary place holder for the Height of the component.

minWidth

int minWidth
The minimum width of the component. It is used to calculate ipady, where the default will be 0.

另请参见：
GridBagConstraints.ipady

minHeight

int minHeight
The minimum height of the component. It is used to calculate ipadx, where the default will be 0.

另请参见：
GridBagConstraints.ipadx

类 java.awt.GridBagLayout 继承 Object 实现 Serializable

serialVersionUID: 8838754796412211005L

序列化字段

comptable

Hashtable<K,V> comptable
此哈希表维持组件与其网格包约束之间的关联。comptable 中的键是组件，值是 GridBagConstraints 的实例。

另请参见：
GridBagConstraints

defaultConstraints

GridBagConstraints defaultConstraints
此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。

另请参见：
GridBagLayout.getConstraints(Component),
GridBagLayout.setConstraints(Component, GridBagConstraints),
GridBagLayout.lookupConstraints(Component)

layoutInfo

GridBagLayoutInfo layoutInfo
此字段保持网格包的布局信息。此字段中的信息基于最近验证的网格包。如果 layoutInfo 为 null，这指示网格包中不存在组件，或者即使存在，也是尚未经过验证的组件。

另请参见：
GridBagLayout.getLayoutInfo(Container, int)

columnWidths

int[] columnWidths
此字段保持对列最小宽度的重写。如果此字段为非 null，则在计算全部最小列宽度之后将这些值应用到网格包。如果 columnWidths 的元素数多于列数，则在网格包中添加列以匹配 columnWidth 中的元素数。

另请参见：
GridBagLayout.getLayoutDimensions()

rowHeights

int[] rowHeights
此字段保持对行最小高度的重写。如果此字段为非 null，则在计算全部最小行高度之后将这些值应用到网格包。如果 rowHeights 的元素数多于行数，则在网格包中添加行以匹配 rowHeights 中的元素数。

另请参见：
GridBagLayout.getLayoutDimensions()

columnWeights

double[] columnWeights
此字段保持对列权重的重写。如果此字段为非 null，则在计算全部列权重之后将这些值应用到网格包。如果 columnWeights[i] 大于列 i 的权重，则将 columnWeights[i] 中的权重分配给列 i。如果 columnWeights 的元素数多于列数，则多余的元素将被忽略——而不会相应地创建更多列。

rowWeights

double[] rowWeights
此字段保持对行权重的重写。如果此字段为非 null，则在计算全部行权重之后将这些值应用到网格包。如果 rowWeights[i] 大于行 i 的权重，则将 rowWeights[i] 中的权重分配给行 i。如果 rowWeights 的元素多于行数，则多余的元素将被忽略——它们不会导致更多行的创建。

componentAdjusting

Component componentAdjusting
正放置的组件。这是在调用 adjustForGravity 之前设置的。

类 java.awt.GridBagLayoutInfo 继承 Object 实现 Serializable

serialVersionUID: -4899416460737170217L

序列化字段

width

int width

height

int height

startx

int startx

starty

int starty

minWidth

int[] minWidth

minHeight

int[] minHeight

weightX

double[] weightX

weightY

double[] weightY

hasBaseline

boolean hasBaseline

baselineType

short[] baselineType

maxAscent

int[] maxAscent

maxDescent

int[] maxDescent

类 java.awt.GridLayout 继承 Object 实现 Serializable

serialVersionUID: -7411804673224730901L

序列化字段

hgap

int hgap
This is the horizontal gap (in pixels) which specifies the space between columns. They can be changed at any time. This should be a non-negative integer.

另请参见：
GridLayout.getHgap(), GridLayout.setHgap(int)

vgap

int vgap
This is the vertical gap (in pixels) which specifies the space between rows. They can be changed at any time. This should be a non negative integer.

另请参见：
GridLayout.getVgap(), GridLayout.setVgap(int)

rows

int rows
This is the number of rows specified for the grid. The number of rows can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Rows in that dimension depends on the other dimension.

另请参见：
GridLayout.getRows(), GridLayout.setRows(int)

cols

int cols
This is the number of columns specified for the grid. The number of columns can be changed at any time. This should be a non negative integer, where '0' means 'any number' meaning that the number of Columns in that dimension depends on the other dimension.

另请参见：
GridLayout.getColumns(), GridLayout.setColumns(int)

类 java.awt.HeadlessException 继承 UnsupportedOperationException 实现 Serializable

serialVersionUID: 167183644944358563L

类 java.awt.IllegalComponentStateException 继承 IllegalStateException 实现 Serializable

serialVersionUID: -1889339587208144238L

类 java.awt.Insets 继承 Object 实现 Serializable

serialVersionUID: -2272572637695466749L

序列化字段

top

int top
顶部的 inset。将此值添加到长方形的 Top，以产生一个新的 Top 位置。

另请参见：
Insets.clone()

left

int left
左边的 inset。将此值添加到长方形的 Left，以产生一个新的 Left 边缘位置。

另请参见：
Insets.clone()

bottom

int bottom
底部的 inset。从长方形的 Bottom 减去此值，以产生一个新的 Bottom 位置。

另请参见：
Insets.clone()

right

int right
右边的 inset。从长方形的 Right 减去此值，以产生一个新的 Right 边缘位置。

另请参见：
Insets.clone()

类 java.awt.Label 继承 Component 实现 Serializable

serialVersionUID: 3094126758329070636L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
从对象输入流读取标签。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

text

String text
The text of this label. This text can be modified by the program but never by the user.

另请参见：
Label.getText(), Label.setText(String)

alignment

int alignment
The label's alignment. The default alignment is set to be left justified.

另请参见：
Label.getAlignment(), Label.setAlignment(int)

类 java.awt.Label.AccessibleAWTLabel 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -3568967560160480438L

类 java.awt.List 继承 Component 实现 Serializable

serialVersionUID: -3304312411574666869L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加侦听器以接收由 List 激活的项事件和动作事件（由存储在流中的键指定）。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果为 GraphicsEnvironment.isHeadless，则返回 true
ClassNotFoundException
IOException
另请参见：
List.removeItemListener(ItemListener),
List.addItemListener(ItemListener),
GraphicsEnvironment.isHeadless(),
List.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可序列化的 ItemListeners 和 ActionListeners 的列表作为可选数据。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
null 终止 0 或更多对的序列；这些对由一个 String 和一个 Object 组成；String 指示对象类型，为以下任意一种：itemListenerK 指示一个 ItemListener 对象；actionListenerK 指示一个 ActionListener 对象。
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.itemListenerK, Component.actionListenerK, List.readObject(ObjectInputStream)
序列化字段

items

Vector<E> items
A vector created to contain items which will become part of the List Component.

另请参见：
List.addItem(String), List.getItem(int)

rows

int rows
This field will represent the number of visible rows in the List Component. It is specified only once, and that is when the list component is actually created. It will never change.

另请参见：
List.getRows()

multipleMode

boolean multipleMode
multipleMode is a variable that will be set to true if a list component is to be set to multiple selection mode, that is where the user can select more than one item in a list at one time. multipleMode will be set to false if the list component is set to single selection, that is where the user can only select one item on the list at any one time.

另请参见：
List.isMultipleMode(), List.setMultipleMode(boolean)

selected

int[] selected
selected is an array that will contain the indices of items that have been selected.

另请参见：
List.getSelectedIndexes(), List.getSelectedIndex()

visibleIndex

int visibleIndex
This variable contains the value that will be used when trying to make a particular list item visible.

另请参见：
List.makeVisible(int)

listSerializedDataVersion

int listSerializedDataVersion
List 组件的序列化数据版本 (Serialized Data Version)。

类 java.awt.List.AccessibleAWTList 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 7924617370136012829L

类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 4412022926028300317L

序列化字段

parent

List parent

indexInParent

int indexInParent

类 java.awt.MediaTracker 继承 Object 实现 Serializable

serialVersionUID: -483174189758638095L

序列化字段

target

Component target
A given Component that will be tracked by a media tracker where the image will eventually be drawn.

另请参见：
MediaTracker.MediaTracker(Component)

head

java.awt.MediaEntry head
The head of the list of Images that is being tracked by the MediaTracker.

另请参见：
MediaTracker.addImage(Image, int), MediaTracker.removeImage(Image)

类 java.awt.Menu 继承 MenuItem 实现 Serializable

serialVersionUID: -8809584163345499784L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException,
                        HeadlessException
读取 ObjectInputStream。未识别的密钥或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
IOException
ClassNotFoundException
另请参见：
GraphicsEnvironment.isHeadless(), Menu.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。

抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Menu.readObject(ObjectInputStream)
序列化字段

items

Vector<E> items
A vector of the items that will be part of the Menu.

另请参见：
Menu.countItems()

tearOff

boolean tearOff
This field indicates whether the menu has the tear of property or not. It will be set to true if the menu has the tear off property and it will be set to false if it does not. A torn off menu can be deleted by a user when it is no longer needed.

另请参见：
Menu.isTearOff()

isHelpMenu

boolean isHelpMenu
This field will be set to true if the Menu in question is actually a help menu. Otherwise it will be set to false.

menuSerializedDataVersion

int menuSerializedDataVersion
菜单序列化的数据版本。

类 java.awt.Menu.AccessibleAWTMenu 继承 MenuItem.AccessibleAWTMenuItem 实现 Serializable

serialVersionUID: 5228160894980069094L

类 java.awt.MenuBar 继承 MenuComponent 实现 Serializable

serialVersionUID: -4930327919388951260L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(), MenuBar.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
将默认的可序列化字段写入流中。

抛出：
ClassNotFoundException
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuBar.readObject(java.io.ObjectInputStream)
序列化字段

menus

Vector<E> menus
This field represents a vector of the actual menus that will be part of the MenuBar.

另请参见：
MenuBar.countMenus()

helpMenu

Menu helpMenu
This menu is a special menu dedicated to help. The one thing to note about this menu is that on some platforms it appears at the right edge of the menubar.

另请参见：
MenuBar.getHelpMenu(), MenuBar.setHelpMenu(Menu)

menuBarSerializedDataVersion

int menuBarSerializedDataVersion
MenuBar 的序列化数据版本。

类 java.awt.MenuBar.AccessibleAWTMenuBar 继承 MenuComponent.AccessibleAWTMenuComponent 实现 Serializable

serialVersionUID: -8577604491830083815L

类 java.awt.MenuComponent 继承 Object 实现 Serializable

serialVersionUID: -4536902356223894379L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
从对象输入流读取该菜单组件。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

font

Font font
The menu component's font. This value can be null at which point a default will be used. This defaults to null.

另请参见：
MenuComponent.setFont(Font), MenuComponent.getFont()

name

String name
该菜单组件的名称，默认为 null。

另请参见：
MenuComponent.getName(), MenuComponent.setName(String)

nameExplicitlySet

boolean nameExplicitlySet
指示是否显式设置名称的变量。如果为 true，将以显式方式设置该名称。此变量默认为 false。

另请参见：
MenuComponent.setName(String)

newEventsOnly

boolean newEventsOnly
Defaults to false.

另请参见：
MenuComponent.dispatchEvent(AWTEvent)

accessibleContext

AccessibleContext accessibleContext

类 java.awt.MenuComponent.AccessibleAWTMenuComponent 继承 AccessibleContext 实现 Serializable

serialVersionUID: -4269533416223798698L

类 java.awt.MenuItem 继承 MenuComponent 实现 Serializable

serialVersionUID: -21757335363267194L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收由 Menu 项引发的动作事件。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
MenuItem.removeActionListener(ActionListener),
MenuItem.addActionListener(ActionListener),
MenuItem.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。将一个可序列化的 ActionListeners 列表作为可选数据写入。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
null 表示终止 0 或更多对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：指示 ActionListener 对象的 actionListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), MenuItem.readObject(ObjectInputStream)
序列化字段

enabled

boolean enabled
A value to indicate whether a menu item is enabled or not. If it is enabled, enabled will be set to true. Else enabled will be set to false.

另请参见：
MenuItem.isEnabled(), MenuItem.setEnabled(boolean)

label

String label
label is the label of a menu item. It can be any string.

另请参见：
MenuItem.getLabel(), MenuItem.setLabel(String)

actionCommand

String actionCommand
This field indicates the command tha has been issued by a particular menu item. By default the actionCommand is the label of the menu item, unless it has been set using setActionCommand.

另请参见：
MenuItem.setActionCommand(String), MenuItem.getActionCommand()

eventMask

long eventMask
The eventMask is ONLY set by subclasses via enableEvents. The mask should NOT be set when listeners are registered so that we can distinguish the difference between when listeners request events and subclasses request them.

shortcut

MenuShortcut shortcut
与菜单项关联的关键字序列。注意，在 1.1.2 中，必须使用菜单项上的 setActionCommand()，才可以以快捷方式工作。

另请参见：
MenuItem.getShortcut(),
MenuItem.setShortcut(MenuShortcut),
MenuItem.deleteShortcut()

menuItemSerializedDataVersion

int menuItemSerializedDataVersion
菜单项的序列化数据版本。

类 java.awt.MenuItem.AccessibleAWTMenuItem 继承 MenuComponent.AccessibleAWTMenuComponent 实现 Serializable

serialVersionUID: -217847831945965825L

类 java.awt.MenuShortcut 继承 Object 实现 Serializable

serialVersionUID: 143448358473180225L

序列化字段

key

int key
The virtual keycode for the menu shortcut. This is the keycode with which the menu shortcut will be created. Note that it is a virtual keycode, not a character, e.g. KeyEvent.VK_A, not 'a'. Note: in 1.1.x you must use setActionCommand() on a menu item in order for its shortcut to work, otherwise it will fire a null action command.

从以下版本开始：
JDK1.1
另请参见：
MenuShortcut.getKey(), MenuShortcut.usesShiftModifier(), KeyEvent

usesShift

boolean usesShift
Indicates whether the shft key was pressed. If true, the shift key was pressed. If false, the shift key was not pressed

从以下版本开始：
JDK1.1
另请参见：
MenuShortcut.usesShiftModifier()

类 java.awt.Panel 继承 Container 实现 Serializable

serialVersionUID: -2728009084054400034L

类 java.awt.Panel.AccessibleAWTPanel 继承 Container.AccessibleAWTContainer 实现 Serializable

serialVersionUID: -6409552226660031050L

类 java.awt.Point 继承 Point2D 实现 Serializable

serialVersionUID: -5276940640259749850L

序列化字段

x

int x
此 Point 的 X 坐标。如果未设置 X 坐标，则默认为 0。

从以下版本开始：
1.0
另请参见：
Point.getLocation(), Point.move(int, int)

y

int y
此 Point 的 Y 坐标。如果未设置 Y 坐标，则默认为 0。

从以下版本开始：
1.0
另请参见：
Point.getLocation(), Point.move(int, int)

类 java.awt.Polygon 继承 Object 实现 Serializable

serialVersionUID: -6460061437900069969L

序列化字段

npoints

int npoints
点的总数。npoints 的值表示在此 Polygon 中有效的点的数量，该值可以小于 xpoints 或 ypoints 中元素的个数。此值可以为 NULL。

从以下版本开始：
1.0
另请参见：
Polygon.addPoint(int, int)

xpoints

int[] xpoints
X 坐标的数组。此数组中元素的个数可以大于此 Polygon 中 X 坐标的个数。额外的元素允许新的点添加到此 Polygon 中，而无需重新创建此数组。npoints 的值等于此 Polygon 中有效点的个数。

从以下版本开始：
1.0
另请参见：
Polygon.addPoint(int, int)

ypoints

int[] ypoints
Y 坐标的数组。此数组中元素的个数可以大于此 Polygon 中 Y 坐标的个数。额外的元素允许新的点添加到 Polygon 中，而无需重新创建此数组。npoints 的值等于此 Polygon 中有效点的个数。

从以下版本开始：
1.0
另请参见：
Polygon.addPoint(int, int)

bounds

Rectangle bounds
此 Polygon 的边界。此值可以为 null。

从以下版本开始：
1.0
另请参见：
Polygon.getBoundingBox(), Polygon.getBounds()

类 java.awt.PopupMenu 继承 Menu 实现 Serializable

serialVersionUID: -4620452533522760060L

类 java.awt.PopupMenu.AccessibleAWTPopupMenu 继承 Menu.AccessibleAWTMenu 实现 Serializable

serialVersionUID: -4282044795947239955L

类 java.awt.Rectangle 继承 Rectangle2D 实现 Serializable

serialVersionUID: -4345857070255674764L

序列化字段

x

int x
Rectangle 左上角的 X 坐标。

从以下版本开始：
1.0
另请参见：
Rectangle.setLocation(int, int), Rectangle.getLocation()

y

int y
Rectangle 左上角的 Y 坐标。

从以下版本开始：
1.0
另请参见：
Rectangle.setLocation(int, int), Rectangle.getLocation()

width

int width
Rectangle 的宽度。

从以下版本开始：
1.0
另请参见：
Rectangle.setSize(int, int), Rectangle.getSize()

height

int height
Rectangle 的高度。

从以下版本开始：
1.0
另请参见：
Rectangle.setSize(int, int), Rectangle.getSize()

类 java.awt.Scrollbar 继承 Component 实现 Serializable

serialVersionUID: 8451667562882310543L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 Scrollbar 触发的调整事件。忽略未被识别的键或值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(), Scrollbar.writeObject(ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。写入可序列化 AdjustmentListeners 的一个列表作为可选数据。检测不可序列化的侦听器并且不尝试对其进行序列化。

序列数据：
null 表示终止 0 或更多对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：指示 AdjustmentListener 对象的 adjustmentListenerK
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.adjustmentListenerK, Scrollbar.readObject(ObjectInputStream)
序列化字段

value

int value
The value of the Scrollbar. This property must be greater than or equal to minimum and less than or equal to maximum - visibleAmount

另请参见：
Scrollbar.getValue(), Scrollbar.setValue(int)

maximum

int maximum
The maximum value of the Scrollbar. This value must be greater than the minimum value.

另请参见：
Scrollbar.getMaximum(), Scrollbar.setMaximum(int)

minimum

int minimum
The minimum value of the Scrollbar. This value must be less than the maximum value.

另请参见：
Scrollbar.getMinimum(), Scrollbar.setMinimum(int)

visibleAmount

int visibleAmount
The size of the Scrollbar's bubble. When a scroll bar is used to select a range of values, the visibleAmount represents the size of this range. This is visually indicated by the size of the bubble.

另请参见：
Scrollbar.getVisibleAmount(), Scrollbar.setVisibleAmount(int)

orientation

int orientation
The Scrollbar's orientation--being either horizontal or vertical. This value should be specified when the scrollbar is created.
orientation can be either : VERTICAL or HORIZONTAL only.

另请参见：
Scrollbar.getOrientation(), Scrollbar.setOrientation(int)

lineIncrement

int lineIncrement
The amount by which the scrollbar value will change when going up or down by a line. This value must be greater than zero.

另请参见：
Scrollbar.getLineIncrement(), Scrollbar.setLineIncrement(int)

pageIncrement

int pageIncrement
The amount by which the scrollbar value will change when going up or down by a page. This value must be greater than zero.

另请参见：
Scrollbar.getPageIncrement(), Scrollbar.setPageIncrement(int)

scrollbarSerializedDataVersion

int scrollbarSerializedDataVersion
滚动条的序列化 Data Version。

类 java.awt.Scrollbar.AccessibleAWTScrollBar 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: -344337268523697807L

类 java.awt.ScrollPane 继承 Container 实现 Serializable

serialVersionUID: 7956609840827222915L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
将默认可序列化字段读入流中。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入流中。

抛出：
IOException
序列化字段

scrollbarDisplayPolicy

int scrollbarDisplayPolicy
有三种显示滚动条的方法。此整数将显示三种显示方法之一——（SCROLLBARS_ALWAYS、SCROLLBARS_AS_NEEDED 和 SCROLLBARS_NEVER）

另请参见：
ScrollPane.getScrollbarDisplayPolicy()

vAdjustable

ScrollPaneAdjustable vAdjustable
一个可调整的垂直滚动条。注意到不必 调用三种 Adjustable 方法非常重要，这三种方法是：setMinimum()、setMaximum() 和 setVisibleAmount()。

另请参见：
ScrollPane.getVAdjustable()

hAdjustable

ScrollPaneAdjustable hAdjustable
一个可调整的水平滚动条。注意到不必 调用三种 Adjustable 方法非常重要，这三种方法是：setMinimum()、setMaximum() 和 setVisibleAmount()。

另请参见：
ScrollPane.getHAdjustable()

wheelScrollingEnabled

boolean wheelScrollingEnabled
指示是否应该在接收 MouseWheelEvent 时进行滚动。

从以下版本开始：
1.4

类 java.awt.ScrollPane.AccessibleAWTScrollPane 继承 Container.AccessibleAWTContainer 实现 Serializable

serialVersionUID: 6100703663886637L

类 java.awt.ScrollPaneAdjustable 继承 Object 实现 Serializable

serialVersionUID: -3359745691033257079L

序列化字段

sp

ScrollPane sp
此对象是其滚动条的 ScrollPane。

orientation

int orientation
此滚动条的方向。

另请参见：
ScrollPaneAdjustable.getOrientation(), Adjustable.HORIZONTAL, Adjustable.VERTICAL

value

int value
此滚动条的值。value 应该大于 minimum 且小于 maximum

另请参见：
ScrollPaneAdjustable.getValue(), ScrollPaneAdjustable.setValue(int)

minimum

int minimum
此滚动条的最小值。只能通过 ScrollPane 设置此值。

ATTN： 在当前实现中，minimum 总是为 0。只能通过 setSpan 方法更改此字段，并且 ScrollPane 总是调用 minimum 为 0 的此方法。getMinimum 方法总是返回 0 而不检查此字段。

另请参见：
ScrollPaneAdjustable.getMinimum(), ScrollPaneAdjustable.setSpan(int, int, int)

maximum

int maximum
此滚动条的最大值。只能通过 ScrollPane 设置此值。

另请参见：
ScrollPaneAdjustable.getMaximum(), ScrollPaneAdjustable.setSpan(int, int, int)

visibleAmount

int visibleAmount
此滚动条可视部分的大小。只能通过 ScrollPane 设置此值。

另请参见：
ScrollPaneAdjustable.getVisibleAmount(), ScrollPaneAdjustable.setSpan(int, int, int)

unitIncrement

int unitIncrement
当滚动条向上或向下移动一行时，滚动条值更改的量。该值应该是一个非负整数。

另请参见：
ScrollPaneAdjustable.getUnitIncrement(), ScrollPaneAdjustable.setUnitIncrement(int)

blockIncrement

int blockIncrement
当滚动条向上或向下移动一页时，滚动条值更改的量。该值应该是一个非负整数。

另请参见：
ScrollPaneAdjustable.getBlockIncrement(), ScrollPaneAdjustable.setBlockIncrement(int)

adjustmentListener

AdjustmentListener adjustmentListener

类 java.awt.SystemColor 继承 Color 实现 Serializable

serialVersionUID: 4503142729533789064L

类 java.awt.TextArea 继承 TextComponent 实现 Serializable

serialVersionUID: 3692302836626095722L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless()
序列化字段

rows

int rows
The number of rows in the TextArea. This parameter will determine the text area's height. Guaranteed to be non-negative.

另请参见：
TextArea.getRows(), TextArea.setRows(int)

columns

int columns
The number of columns in the TextArea. A column is an approximate average character width that is platform-dependent. This parameter will determine the text area's width. Guaranteed to be non-negative.

另请参见：
TextArea.setColumns(int), TextArea.getColumns()

scrollbarVisibility

int scrollbarVisibility
确定为文本区创建哪种滚动条。它可以是以下四个值之一：SCROLLBARS_BOTH = 两种滚动条都创建。
SCROLLBARS_HORIZONTAL_ONLY = 只创建水平滚动条。
SCROLLBARS_VERTICAL_ONLY = 只创建垂直滚动条。
SCROLLBARS_NONE = 不创建滚动条。

另请参见：
TextArea.getScrollbarVisibility()

textAreaSerializedDataVersion

int textAreaSerializedDataVersion
The textArea Serialized Data Version.

类 java.awt.TextArea.AccessibleAWTTextArea 继承 TextComponent.AccessibleAWTTextComponent 实现 Serializable

serialVersionUID: 3472827823632144419L

类 java.awt.TextComponent 继承 Component 实现 Serializable

serialVersionUID: -2214773872412987419L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 TextComponent 触发的文本事件。未识别的密钥或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
TextComponent.removeTextListener(java.awt.event.TextListener),
TextComponent.addTextListener(java.awt.event.TextListener),
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可序列化 TextListener 的一个列表作为可选数据。检测不可序列化的 TextListener，并且不尝试对其进行序列化。

序列数据：
以 null 终止的 0 或多对序列。由 String 和 Object 组成的一对序列。String 指示对象类型，它是以下之一： textListenerK 指示 TextListener 对象。
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.textListenerK
序列化字段

text

String text
The value of the text. A null value is the same as "".

另请参见：
TextComponent.setText(String), TextComponent.getText()

editable

boolean editable
A boolean indicating whether or not this TextComponent is editable. It will be true if the text component is editable and false if not.

另请参见：
TextComponent.isEditable()

selectionStart

int selectionStart
The selection refers to the selected text, and the selectionStart is the start position of the selected text.

另请参见：
TextComponent.getSelectionStart(), TextComponent.setSelectionStart(int)

selectionEnd

int selectionEnd
The selection refers to the selected text, and the selectionEnd is the end position of the selected text.

另请参见：
TextComponent.getSelectionEnd(), TextComponent.setSelectionEnd(int)

backgroundSetByClientCode

boolean backgroundSetByClientCode

textComponentSerializedDataVersion

int textComponentSerializedDataVersion
textComponent 的 SerializedDataVersion。

checkForEnableIM

boolean checkForEnableIM

类 java.awt.TextComponent.AccessibleAWTTextComponent 继承 Component.AccessibleAWTComponent 实现 Serializable

serialVersionUID: 3631432373506317811L

类 java.awt.TextField 继承 TextComponent 实现 Serializable

serialVersionUID: -2966288784432217853L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream，如果它不为 null，则添加一个侦听器，以接收 TextField 触发的操作事件。未识别的密钥或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
ClassNotFoundException
IOException
另请参见：
TextField.removeActionListener(ActionListener),
TextField.addActionListener(ActionListener),
GraphicsEnvironment.isHeadless()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。写入可序列化 ActionListener 的一个列表作为可选数据。检测不可序列化的 ActionListener，并且不尝试对其进行序列化。

序列数据：
以 null 终止的 0 或多对序列。由 String 和 Object 组成的一对序列。String 指示对象类型，它是以下类型之一：指示 ActionListener 对象的 ActionListenerK。
抛出：
IOException
另请参见：
AWTEventMulticaster.save(ObjectOutputStream, String, EventListener), Component.actionListenerK
序列化字段

columns

int columns
The number of columns in the text field. A column is an approximate average character width that is platform-dependent. Guaranteed to be non-negative.

另请参见：
TextField.setColumns(int), TextField.getColumns()

echoChar

char echoChar
The echo character, which is used when the user wishes to disguise the characters typed into the text field. The disguises are removed if echoChar = 0.

另请参见：
TextField.getEchoChar(),
TextField.setEchoChar(char),
TextField.echoCharIsSet()

textFieldSerializedDataVersion

int textFieldSerializedDataVersion
textField 的 Serialized Data Version。

类 java.awt.TextField.AccessibleAWTTextField 继承 TextComponent.AccessibleAWTTextComponent 实现 Serializable

serialVersionUID: 6219164359235943158L

类 java.awt.Window 继承 Container 实现 Serializable

serialVersionUID: 4497834738069338734L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException,
                        HeadlessException
读取 ObjectInputStream 和侦听器的可选列表，以接收由该组件引发的各种事件；并且读取子窗口（可能为 null）的列表。未识别的键或值将被忽略。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
ClassNotFoundException
IOException
另请参见：
GraphicsEnvironment.isHeadless(), Window.writeObject(java.io.ObjectOutputStream)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流中。将可序列化的 WindowListener 和 WindowFocusListener 的列表作为可选数据写入。将子窗口的列表作为可选数据写入。将图标图像的列表作为可选数据写入。

序列数据：
null 表示终止 0 或更多对的序列；这种对是由 String 和 Object 组成的；String 指示对象类型，它为以下类型之一：windowListenerK 指示 WindowListener 对象；windowFocusWindowK 指示 WindowFocusListener 对象；ownedWindowK 指示 Window 子对象
抛出：
IOException
另请参见：
AWTEventMulticaster.save(java.io.ObjectOutputStream, java.lang.String, java.util.EventListener), Component.windowListenerK, Component.windowFocusListenerK, Component.ownedWindowK, Window.readObject(ObjectInputStream)
序列化字段

warningString

String warningString
This represents the warning message that is to be displayed in a non secure window. ie : a window that has a security manager installed for which calling SecurityManager.checkTopLevelWindow() is false. This message can be displayed anywhere in the window.

另请参见：
Window.getWarningString()

syncLWRequests

boolean syncLWRequests

state

int state
An Integer value representing the Window State.

从以下版本开始：
1.2
另请参见：
Window.show()

alwaysOnTop

boolean alwaysOnTop
表示窗口 always-on-top 状态的布尔值

从以下版本开始：
1.5
另请参见：
Window.setAlwaysOnTop(boolean), Window.isAlwaysOnTop()

modalExclusionType

Dialog.ModalExclusionType modalExclusionType
从以下版本开始：
1.6
另请参见：
Dialog.ModalExclusionType, Window.getModalExclusionType(), Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType)

focusMgr

java.awt.FocusManager focusMgr
未使用。为序列化向后兼容性而维护。

从以下版本开始：
1.2

focusableWindowState

boolean focusableWindowState
指示此窗口是否可以成为聚焦窗口。

从以下版本开始：
1.4
另请参见：
Window.getFocusableWindowState(), Window.setFocusableWindowState(boolean)

windowSerializedDataVersion

int windowSerializedDataVersion
窗口序列化的数据版本。

locationByPlatform

boolean locationByPlatform

类 java.awt.Window.AccessibleAWTWindow 继承 Container.AccessibleAWTContainer 实现 Serializable

serialVersionUID: 4215068635060671780L

软件包 java.awt.color

类 java.awt.color.CMMException 继承 RuntimeException 实现 Serializable

类 java.awt.color.ColorSpace 继承 Object 实现 Serializable

serialVersionUID: -409452704308689724L

序列化字段

type

int type

numComponents

int numComponents

类 java.awt.color.ICC_ColorSpace 继承 ColorSpace 实现 Serializable

serialVersionUID: 3455889114070431483L

序列化字段

thisProfile

ICC_Profile thisProfile

minVal

float[] minVal

maxVal

float[] maxVal

diffMinMax

float[] diffMinMax

invDiffMinMax

float[] invDiffMinMax

needScaleInit

boolean needScaleInit

类 java.awt.color.ICC_Profile 继承 Object 实现 Serializable

serialVersionUID: -3938515861990936766L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中读取默认的可序列化字段。从流中读取 string 和 byte 数组作为额外的数据。

序列数据：
如果 profile 对象是预定义颜色空间（如 "CS_sRGB"）的某个配置文件，则 String 是 ColorSpace 类中所定义的 CS_* 常量之一。否则 string 为 null。

byte[] 数组是该配置文件的配置文件数据。对于预定义的配置文件而言，它通常为 null。

如果将该 string 识别为预定义颜色空间的常量名，则将对象解析为使用 getInstance(int cspace) 所获得的配置文件，并且忽略配置文件数据。否则将对象解析为使用 getInstance(byte[] data) 所获得的配置文件。

抛出：
IOException - 由 ObjectInputStream 抛出。
ClassNotFoundException - 由 ObjectInputStream 抛出。
另请参见：
ICC_Profile.readResolve(),
ICC_Profile.getInstance(int),
ICC_Profile.getInstance(byte[])

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入流。向流中写入 string 和 byte 数组作为额外的数据。

序列数据：
如果 profile 对象是预定义颜色空间（如 "CS_sRGB"）的某个配置文件，则 String 是 ColorSpace 类中所定义的 CS_* 常量之一。否则 string 为 null。

byte[] 数组是该配置文件的配置文件数据。对于预定义的颜色空间，写入的是 null 而不是配置文件数据。如果在以后的 Java API 版本中添加了新的预定义颜色空间，则此类的以后版本中可能会选择这条道：不但写入新预定义颜色空间的颜色空间名称，而且还要写入配置文件数据，以使旧版本仍能反序列化对象。

抛出：
IOException - 由 ObjectInputStream 抛出。

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析将被反序列化为用 CMM 注册的实例的实例。

抛出：
ObjectStreamException - 不会抛出，但是要受序列化规范的限制。
从以下版本开始：
1.3
序列化字段

iccProfileSerializedDataVersion

int iccProfileSerializedDataVersion
流中其他序列化数据的格式版本。版本 1 对应于 Java 2 平台，1.3 版

从以下版本开始：
1.3

类 java.awt.color.ICC_ProfileGray 继承 ICC_Profile 实现 Serializable

类 java.awt.color.ICC_ProfileRGB 继承 ICC_Profile 实现 Serializable

类 java.awt.color.ProfileDataException 继承 RuntimeException 实现 Serializable

软件包 java.awt.datatransfer

类 java.awt.datatransfer.DataFlavor 继承 Object 实现 Serializable

serialVersionUID: 8367026044764648243L

序列化方法

readExternal

public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
根据 Serialized 状态还原此 DataFlavor。

抛出：
IOException - 如果发生 I/O 错误
ClassNotFoundException - 如果无法找到需要恢复的某个对象的类。

writeExternal

public void writeExternal(ObjectOutput os)
                   throws IOException
序列化此 DataFlavor。

抛出：
IOException - 包含可能发生的所有 I/O 异常

类 java.awt.datatransfer.FlavorEvent 继承 EventObject 实现 Serializable

类 java.awt.datatransfer.UnsupportedFlavorException 继承 Exception 实现 Serializable

serialVersionUID: 5383814944251665601L

软件包 java.awt.dnd

类 java.awt.dnd.DragGestureEvent 继承 EventObject 实现 Serializable

serialVersionUID: 9080172649166731306L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragGestureEvent。此方法首先为所有的非 transient 字段执行默认的反序列化。然后还要尝试反序列化此对象动作事件的 List。通过反序列化字段 events 来进行首次尝试，因为在发布版本 1.4 之前，此名称的非 transient 字段存储动作事件的 List。如果此尝试失败，则使用流中的下一个对象。如果结果 List 为 null，则设置此对象的动作事件 List 为空 List。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragGestureEvent。当且仅当可以序列化此对象的动作事件 List 时才执行默认的序列化，然后写出该 List。如果无法序列化，则写出 null。在这种情况下，从得到的反序列化流中创建的 DragGestureEvent 将包含一个空的动作事件 List。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 List 实例或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

dragSource

DragSource dragSource
与此 DragGestureEvent 关联的 DragSource。

component

Component component
与此 DragGestureEvent 关联的 Component。

origin

Point origin
拖动的原点。

action

int action
用户的首选操作。

类 java.awt.dnd.DragGestureRecognizer 继承 Object 实现 Serializable

serialVersionUID: 8996673345831063337L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragGestureRecognizer。此方法首先为所有的非 transient 字段执行默认的反序列化。然后通过使用流中的下一个对象，还要反序列化此对象的 DragGestureListener。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragGestureRecognizer。此方法首先执行默认的序列化。然后当且仅当可以序列化此对象的 DragGestureListener 时将其写出。如果无法序列化，则写出 null。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 DragGestureListener 或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

dragSource

DragSource dragSource
与此 DragGestureRecognizer 关联的 DragSource。

component

Component component
与此 DragGestureRecognizer 关联的 Component。

sourceActions

int sourceActions
此 Drag 和 Drop 操作中所用动作类型的 int 表示形式。

events

ArrayList<E> events
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。

类 java.awt.dnd.DragSource 继承 Object 实现 Serializable

serialVersionUID: 6236096958971414066L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragSource。此方法首先执行默认的反序列化。然后使用流中的下一个对象反序列化此对象的 FlavorMap。如果得到的 FlavorMap 为 null，则将此对象的 FlavorMap 设置为此线程的 ClassLoader 的默认 FlavorMap。然后反序列化此对象的侦听器，方法是从流中读取以 null 终止的 0 序列或者更多的键/值对：
  • 如果键对象是等于 dragSourceListenerK 的 String，则使用相应的值对象反序列化一个 DragSourceListener 并添加到此 DragSource 中。
  • 如果键对象是等于 dragSourceMotionListenerK 的 String，则使用相应的值对象反序列化一个 DragSourceMotionListener 并添加到此 DragSource 中。
  • 否则跳过该键/值对。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4
另请参见：
SystemFlavorMap.getDefaultFlavorMap()

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragSource。此方法首先执行默认的序列化。然后当且仅当可以序列化此对象的 FlavorMap 时写出该 FlavorMap。如果无法序列化，则写出 null。然后写出向此对象注册的 Serializable 侦听器。使用以 null 终止的 0 序列或更多数据对的形式写出这些侦听器。该数据对由 String 和 Object 组成；String 指示该 Object 的类型，为以下某个值：
  • dragSourceListenerK 表示 DragSourceListener 对象；
  • dragSourceMotionListenerK 表示 DragSourceMotionListener 对象。

序列数据：
FlavorMap 实例或 null，后跟以 null 终止的 0 序列或更多数据对；该数据对由 String 和 Object 组成；String 指示该 Object 的类型，为以下某个值：
  • dragSourceListenerK 表示 DragSourceListener 对象；
  • dragSourceMotionListenerK 表示 DragSourceMotionListener 对象。
抛出：
IOException
从以下版本开始：
1.4

类 java.awt.dnd.DragSourceContext 继承 Object 实现 Serializable

serialVersionUID: -115407898692194719L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DragSourceContext 此方法首先为所有的非 transient 字段执行默认的反序列化。然后通过使用流中的下两个对象，还要反序列化此对象的 Transferable 和 DragSourceListener 如果得到的 Transferable 为 null，则将此对象的 Transferable 设置为支持无 DataFlavor 的虚拟 Transferable。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DragSourceContext 此方法首先执行默认的序列化。然后当且仅当可以序列化此对象的 Transferable 时将其写出。如果无法序列化，则写出 null 在这种情况下，从得到的反序列化流中创建的 DragSourceContext 将包含一个支持无 DataFlavor 的虚拟 Transferable。最后，当且仅当可以序列化此对象的 DragSourceListener 时将其写出。如果无法序列化，则写出 null。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 Transferable 实例或 null，然后是 DragSourceListener 实例或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

trigger

DragGestureEvent trigger
触发拖动开始的事件。

cursor

Cursor cursor
当前的拖动光标。

useCustomCursor

boolean useCustomCursor
如果使用了自定义的拖动光标，而不是默认的拖动光标，则为 true。

sourceActions

int sourceActions
DnDConstants 的位掩码，表示拖动源针对与此 DragSourceContext 关联的拖动操作所支持的放置动作集合。

类 java.awt.dnd.DragSourceDragEvent 继承 DragSourceEvent 实现 Serializable

serialVersionUID: 481346297933902471L

序列化字段

targetActions

int targetActions
目标放置动作。

dropAction

int dropAction
用户放置动作。

gestureModifiers

int gestureModifiers
与用户动作关联的输入设备修饰符状态。

invalidModifiers

boolean invalidModifiers
指示 gestureModifiers 是否无效。

类 java.awt.dnd.DragSourceDropEvent 继承 DragSourceEvent 实现 Serializable

serialVersionUID: -5571321229470821891L

序列化字段

dropSuccess

boolean dropSuccess
如果放置成功，则为 true。

dropAction

int dropAction
放置操作。

类 java.awt.dnd.DragSourceEvent 继承 EventObject 实现 Serializable

serialVersionUID: -763287114604032641L

序列化字段

locationSpecified

boolean locationSpecified
指示是否为此事件指定了光标位置的 boolean 值。

x

int x
如果为此事件指定了光标位置，则为事件发生时该光标位置的水平坐标；否则为零。

y

int y
如果为此事件指定了光标位置，则为事件发生时该光标位置的垂直坐标；否则为零。

类 java.awt.dnd.DropTarget 继承 Object 实现 Serializable

serialVersionUID: -6283860791671019047L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
反序列化此 DropTarget 此方法首先为所有的非 transient 字段执行默认的反序列化。然后还要尝试反序列化此对象的 DropTargetListener 通过反序列化字段 dtListener 来进行首次尝试，因为在发布版本 1.4 之前，此名称的非 transient 字段存储 DropTargetListener 如果此尝试失败，则使用流中的下一个对象。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.4

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列化此 DropTarget 当且仅当可以执行序列化时才执行默认的序列化，然后写出此对象的 DropTargetListener 如果无法序列化，则写出 null。

序列数据：
按字母顺序排列的默认可序列化字段，后跟 DropTargetListener 实例或 null。
抛出：
IOException
从以下版本开始：
1.4
序列化字段

dropTargetContext

DropTargetContext dropTargetContext
与此 DropTarget 关联的 DropTargetContext。

component

Component component
与此 DropTarget 关联的 Component。

actions

int actions
Default permissible actions supported by this DropTarget.

另请参见：
DropTarget.setDefaultActions(int), DropTarget.getDefaultActions()

active

boolean active
true if the DropTarget is accepting Drag & Drop operations.

类 java.awt.dnd.DropTargetContext 继承 Object 实现 Serializable

serialVersionUID: -634158968993743371L

序列化字段

dropTarget

DropTarget dropTarget
与此 DropTargetContext 相关的 DropTarget。

类 java.awt.dnd.DropTargetDragEvent 继承 DropTargetEvent 实现 Serializable

serialVersionUID: -8422265619058953682L

序列化字段

location

Point location
Component 坐标中 drag 光标的热点位置。

actions

int actions
源 drop 操作。

dropAction

int dropAction
用户 drop 操作。

类 java.awt.dnd.DropTargetDropEvent 继承 DropTargetEvent 实现 Serializable

serialVersionUID: -1721911170440459322L

序列化字段

location

Point location
Component 坐标中 drag 光标的热点位置。

actions

int actions
源 drop 操作。

dropAction

int dropAction
用户 drop 操作。

isLocalTx

boolean isLocalTx
如果源对象与目标对象处于相同的 JVM 中，则为 true。

类 java.awt.dnd.DropTargetEvent 继承 EventObject 实现 Serializable

serialVersionUID: 2821229066521922993L

序列化字段

context

DropTargetContext context
与此 DropTargetEvent 相关的 DropTargetContext。

类 java.awt.dnd.InvalidDnDOperationException 继承 IllegalStateException 实现 Serializable

类 java.awt.dnd.MouseDragGestureRecognizer 继承 DragGestureRecognizer 实现 Serializable

serialVersionUID: 6220099344182281120L

软件包 java.awt.event

类 java.awt.event.ActionEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: -7671078796273832149L

序列化字段

actionCommand

String actionCommand
The nonlocalized string that gives more details of what actually caused the event. This information is very specific to the component that fired it.

另请参见：
ActionEvent.getActionCommand()

when

long when
Timestamp of when this event occurred. Because an ActionEvent is a high- level, semantic event, the timestamp is typically the same as an underlying InputEvent.

另请参见：
ActionEvent.getWhen()

modifiers

int modifiers
This represents the key modifier that was selected, and is used to determine the state of the selected key. If no modifier has been selected it will default to zero.

另请参见：
ActionEvent.getModifiers()

类 java.awt.event.AdjustmentEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 5700290645205279921L

序列化字段

adjustable

Adjustable adjustable
The adjustable object that fired the event.

另请参见：
AdjustmentEvent.getAdjustable()

value

int value
value will contain the new value of the adjustable object. This value will always be in a range associated adjustable object.

另请参见：
AdjustmentEvent.getValue()

adjustmentType

int adjustmentType
The adjustmentType describes how the adjustable object value has changed. This value can be increased/decreased by a block or unit amount where the block is associated with page increments/decrements, and a unit is associated with line increments/decrements.

另请参见：
AdjustmentEvent.getAdjustmentType()

isAdjusting

boolean isAdjusting
The isAdjusting is true if the event is one of the series of multiple adjustment events.

从以下版本开始：
1.4
另请参见：
AdjustmentEvent.getValueIsAdjusting()

类 java.awt.event.ComponentEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 8101406823902992965L

类 java.awt.event.ContainerEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: -4114942250539772041L

序列化字段

child

Component child
The non-null component that is being added or removed from the Container.

另请参见：
ContainerEvent.getChild()

类 java.awt.event.FocusEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: 523753786457416396L

序列化字段

temporary

boolean temporary
A focus event can have two different levels, permanent and temporary. It will be set to true if some operation takes away the focus temporarily and intends on getting it back once the event is completed. Otherwise it will be set to false.

另请参见：
FocusEvent.isTemporary()

类 java.awt.event.HierarchyEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: -5337576970038043990L

序列化字段

changed

Component changed

changedParent

Container changedParent

changeFlags

long changeFlags

类 java.awt.event.InputEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: -2482525981698309786L

序列化字段

when

long when
The input event's Time stamp in UTC format. The time stamp indicates when the input event was created.

另请参见：
InputEvent.getWhen()

modifiers

int modifiers
The state of the modifier mask at the time the input event was fired.

另请参见：
InputEvent.getModifiers(), InputEvent.getModifiersEx(), KeyEvent, MouseEvent

类 java.awt.event.InputMethodEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 4727190874778922661L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
如果 when 字段未出现在对象输入流中，则初始化它。在这种情况下，将通过调用 EventQueue.getMostRecentEventTime() 来初始化该字段。

抛出：
ClassNotFoundException
IOException
序列化字段

when

long when
The time stamp that indicates when the event was created.

从以下版本开始：
1.4
另请参见：
InputMethodEvent.getWhen()

类 java.awt.event.InvocationEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 436056344909459450L

序列化字段

runnable

Runnable runnable
调用其 run() 方法的 Runnable。

notifier

Object notifier
在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。

catchExceptions

boolean catchExceptions
如果 dispatch() 捕获了 Throwable 并将其存储在异常实例变量中，则设置为 true。如果设置为 false，则会将 Throwable 传播到 EventDispatchThread 的调度循环中。

exception

Exception exception
在执行 Runnable.run() 方法期间抛出的 Exception（可能为 null）。如果特定实例没有捕获异常，则此变量也为 null。

throwable

Throwable throwable
在执行 Runnable.run() 方法期间抛出的 Throwable（可能为 null）。如果特定实例没有捕获异常，则此变量也为 null。

when

long when
此事件发生时的时间戳。

另请参见：
InvocationEvent.getWhen()

类 java.awt.event.ItemEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: -608708132447206933L

序列化字段

item

Object item
The item whose selection state has changed.

另请参见：
ItemEvent.getItem()

stateChange

int stateChange
stateChange indicates whether the item was selected or deselected.

另请参见：
ItemEvent.getStateChange()

类 java.awt.event.KeyEvent 继承 InputEvent 实现 Serializable

serialVersionUID: -2352130953028126954L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
根据旧的修饰符来设置新的修饰符。键修饰符可重写与鼠标修饰符重合的部分。

抛出：
IOException
ClassNotFoundException
序列化字段

isProxyActive

boolean isProxyActive
存储本机事件调度系统的状态。如果创建事件时事件代理机制是活动的，则为 true；如果是非活动的，则为 false。该状态用于 Component.dispatchEventImpl 中，以在代理是活动的情况下正确地调度事件。

keyCode

int keyCode
The unique value assigned to each of the keys on the keyboard. There is a common set of key codes that can be fired by most keyboards. The symbolic name for a key code should be used rather than the code value itself.

另请参见：
KeyEvent.getKeyCode(), KeyEvent.setKeyCode(int)

keyChar

char keyChar
keyChar is a valid unicode character that is fired by a key or a key combination on a keyboard.

另请参见：
KeyEvent.getKeyChar(), KeyEvent.setKeyChar(char)

keyLocation

int keyLocation
The location of the key on the keyboard. Some keys occur more than once on a keyboard, e.g. the left and right shift keys. Additionally, some keys occur on the numeric keypad. This variable is used to distinguish such keys. The only legal values are KEY_LOCATION_UNKNOWN, KEY_LOCATION_STANDARD, KEY_LOCATION_LEFT, KEY_LOCATION_RIGHT, and KEY_LOCATION_NUMPAD.

另请参见：
KeyEvent.getKeyLocation()

类 java.awt.event.MouseEvent 继承 InputEvent 实现 Serializable

serialVersionUID: -991214153494842848L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
根据旧的修饰符来设置新的修饰符。

抛出：
IOException
ClassNotFoundException
序列化字段

x

int x
The mouse event's x coordinate. The x value is relative to the component that fired the event.

另请参见：
MouseEvent.getX()

y

int y
The mouse event's y coordinate. The y value is relative to the component that fired the event.

另请参见：
MouseEvent.getY()

xAbs

int xAbs
鼠标事件的 x 绝对坐标。在虚拟设备多屏幕环境中，桌面区域可以跨越多个物理屏幕设备，此坐标相对于虚拟坐标系。否则，此坐标相对于与 Component 的 GraphicsConfiguration 关联的坐标系。

yAbs

int yAbs
鼠标事件的 y 绝对坐标。在虚拟设备多屏幕环境中，桌面区域可以跨越多个物理屏幕设备，此坐标相对于虚拟坐标系。否则，此坐标相对于与 Component 的 GraphicsConfiguration 关联的坐标系。

clickCount

int clickCount
Indicates the number of quick consecutive clicks of a mouse button. clickCount will be valid for only three mouse events :
MOUSE_CLICKED, MOUSE_PRESSED and MOUSE_RELEASED. For the above, the clickCount will be at least 1. For all other events the count will be 0.

另请参见：
MouseEvent.getClickCount().

button

int button
Indicates which, if any, of the mouse buttons has changed state. The only legal values are the following constants: NOBUTTON, BUTTON1, BUTTON2 or BUTTON3.

另请参见：
MouseEvent.getButton().

popupTrigger

boolean popupTrigger
A property used to indicate whether a Popup Menu should appear with a certain gestures. If popupTrigger = false, no popup menu should appear. If it is true then a popup menu should appear.

另请参见：
PopupMenu, MouseEvent.isPopupTrigger()

类 java.awt.event.MouseWheelEvent 继承 MouseEvent 实现 Serializable

serialVersionUID: 6459879390515399677L

序列化字段

scrollType

int scrollType
Indicates what sort of scrolling should take place in response to this event, based on platform settings. Legal values are:
  • WHEEL_UNIT_SCROLL
  • WHEEL_BLOCK_SCROLL

另请参见：
MouseWheelEvent.getScrollType()

scrollAmount

int scrollAmount
Only valid for scrollType WHEEL_UNIT_SCROLL. Indicates number of units that should be scrolled per click of mouse wheel rotation, based on platform settings.

另请参见：
MouseWheelEvent.getScrollAmount(), MouseWheelEvent.getScrollType()

wheelRotation

int wheelRotation
Indicates how far the mouse wheel was rotated.

另请参见：
MouseWheelEvent.getWheelRotation()

类 java.awt.event.PaintEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: 1267492026433337593L

序列化字段

updateRect

Rectangle updateRect
This is the rectangle that represents the area on the source component that requires a repaint. This rectangle should be non null.

另请参见：
Rectangle, PaintEvent.setUpdateRect(Rectangle), PaintEvent.getUpdateRect()

类 java.awt.event.TextEvent 继承 AWTEvent 实现 Serializable

serialVersionUID: 6269902291250941179L

类 java.awt.event.WindowEvent 继承 ComponentEvent 实现 Serializable

serialVersionUID: -1567959133147912127L

序列化字段

oldState

int oldState
TBS

newState

int newState
软件包 java.awt.font

类 java.awt.font.NumericShaper 继承 Object 实现 Serializable

序列化字段

key

int key
针对上下文成形的上下文索引，值的范围是 0 到 18

mask

int mask
此标志指示是否以上下文方式成形（高位），以及要成形哪些数字范围（0-18 位）

类 java.awt.font.TextAttribute 继承 AttributedCharacterIterator.Attribute 实现 Serializable

serialVersionUID: 7744112784117861702L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将反序列化的实例解析为预定义常量。

抛出：
InvalidObjectException

类 java.awt.font.TransformAttribute 继承 Object 实现 Serializable

serialVersionUID: 3356247357827709530L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
抛出：
ClassNotFoundException
IOException

readResolve

private Object readResolve()
                    throws ObjectStreamException
抛出：
ObjectStreamException
序列化字段

transform

AffineTransform transform
此 TransformAttribute 的 AffineTransform；如果 AffineTransform 为恒等变换，则为 null。

软件包 java.awt.geom

类 java.awt.geom.AffineTransform 继承 Object 实现 Serializable

serialVersionUID: 1330973210523860834L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws ClassNotFoundException,
                         IOException
抛出：
ClassNotFoundException
IOException
序列化字段

m00

double m00
The X coordinate scaling element of the 3x3 affine transformation matrix.

m10

double m10
The Y coordinate shearing element of the 3x3 affine transformation matrix.

m01

double m01
The X coordinate shearing element of the 3x3 affine transformation matrix.

m11

double m11
The Y coordinate scaling element of the 3x3 affine transformation matrix.

m02

double m02
The X coordinate of the translation element of the 3x3 affine transformation matrix.

m12

double m12
The Y coordinate of the translation element of the 3x3 affine transformation matrix.

类 java.awt.geom.Arc2D.Double 继承 Arc2D 实现 Serializable

serialVersionUID: 728264085846882001L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectInputStream 中读取默认可序列化字段。

序列数据：
  1. 默认可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectOutputStream 中。

序列数据：
  1. 默认的可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
IOException
序列化字段

x

double x
弧的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

double y
弧的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

double width
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

height

double height
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

start

double start
弧的起始角度（以度数表示）。

从以下版本开始：
1.2

extent

double extent
弧的角跨越（以度数表示）。

从以下版本开始：
1.2

类 java.awt.geom.Arc2D.Float 继承 Arc2D 实现 Serializable

serialVersionUID: 9130893014586380278L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectInputStream 中读取默认可序列化字段。

序列数据：
  1. 默认可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认可序列化字段写入后跟一个指示此 Arc2D 实例类型的 byte 值的 ObjectOutputStream 中。

序列数据：
  1. 默认可序列化字段。
  2. 后跟一个指示类型 Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE 的 byte。
抛出：
IOException
序列化字段

x

float x
弧的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

float y
弧的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

float width
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

height

float height
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

start

float start
弧的起始角度（以度数表示）。

从以下版本开始：
1.2

extent

float extent
弧的角跨越（以度数表示）。

从以下版本开始：
1.2

类 java.awt.geom.CubicCurve2D.Double 继承 CubicCurve2D 实现 Serializable

serialVersionUID: -4202960122839707295L

序列化字段

x1

double x1
三次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

double y1
三次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx1

double ctrlx1
三次曲线段第一个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly1

double ctrly1
三次曲线段第一个控制点的 Y 坐标。

从以下版本开始：
1.2

ctrlx2

double ctrlx2
三次曲线段第二个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly2

double ctrly2
三次曲线段第二个控制点的 Y 坐标。

从以下版本开始：
1.2

x2

double x2
三次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

double y2
三次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.CubicCurve2D.Float 继承 CubicCurve2D 实现 Serializable

serialVersionUID: -1272015596714244385L

序列化字段

x1

float x1
三次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

float y1
三次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx1

float ctrlx1
三次曲线段第一个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly1

float ctrly1
三次曲线段第一个控制点的 Y 坐标。

从以下版本开始：
1.2

ctrlx2

float ctrlx2
三次曲线段第二个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly2

float ctrly2
三次曲线段第二个控制点的 Y 坐标。

从以下版本开始：
1.2

x2

float x2
三次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

float y2
三次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Ellipse2D.Double 继承 Ellipse2D 实现 Serializable

serialVersionUID: 5555464816372320683L

序列化字段

x

double x
此 Ellipse2D 的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

double y
此 Ellipse2D 的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

double width
此 Ellipse2D 的总宽度。

从以下版本开始：
1.2

height

double height
此 Ellipse2D 的总高度。

从以下版本开始：
1.2

类 java.awt.geom.Ellipse2D.Float 继承 Ellipse2D 实现 Serializable

serialVersionUID: -6633761252372475977L

序列化字段

x

float x
此 Ellipse2D 窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

float y
此 Ellipse2D 窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

float width
此 Ellipse2D 的总宽度。

从以下版本开始：
1.2

height

float height
此 Ellipse2D 的总高度。

从以下版本开始：
1.2

类 java.awt.geom.GeneralPath 继承 Path2D.Float 实现 Serializable

serialVersionUID: -8327096662768731142L

类 java.awt.geom.IllegalPathStateException 继承 RuntimeException 实现 Serializable

类 java.awt.geom.Line2D.Double 继承 Line2D 实现 Serializable

serialVersionUID: 7979627399746467499L

序列化字段

x1

double x1
线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

double y1
线段起始点的 Y 坐标。

从以下版本开始：
1.2

x2

double x2
线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

double y2
线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Line2D.Float 继承 Line2D 实现 Serializable

serialVersionUID: 6161772511649436349L

序列化字段

x1

float x1
线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

float y1
线段起始点的 Y 坐标。

从以下版本开始：
1.2

x2

float x2
线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

float y2
线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.NoninvertibleTransformException 继承 Exception 实现 Serializable

类 java.awt.geom.Path2D.Double 继承 Path2D 实现 Serializable

serialVersionUID: 1826762518450014216L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从 ObjectInputStream 中读取默认的可序列化字段，然后显式序列化此路径中存储的路径段。

从 1.6 开始，没有默认的可序列化字段。

此对象的序列数据是用 writeObject 方法描述的。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入 ObjectOutputStream，然后显式序列化此路径中存储的路径段。

序列数据：
  1. 默认的可序列化字段。从 1.6 开始，没有默认的可序列化字段。
  2. 后跟一个字节，指示将初始对象的存储类型作为提示 (SERIAL_STORAGE_DBL_ARRAY)。
  3. 接着是一个整数，指示应该遵循的路径段数量 (NP)，或者为 -1 ，指示遵循未知数量的路径段。
  4. 接着又是一个整数，指示应该遵循的坐标总数 (NC)，或者为 -1，指示遵循未知的坐标数（NC 应该始终是偶数，因为坐标始终以成对的 x,y 形式出现）。
  5. 再接着是一个指示旋绕规则（WIND_EVEN_ODD 或 WIND_NON_ZERO）的字节。
  6. 再接着是由指示路径段类型的单个字节组成的值的 NP 集合（如果 NP < 0，则值是无限的），后跟表示路径段坐标的一对或多对 float 或 double 值。
  7. 最后是指示路径结尾的字节 (SERIAL_PATH_END) 。

以下字节值常量用于 Path2D 对象的序列化形式中：

常量名 | 字节值 | 后跟 | 描述
SERIAL_STORAGE_FLT_ARRAY | 0x30 | 一个提示，原始 Path2D 对象以 Java 的 float 数组形式存储于坐标中。
SERIAL_STORAGE_DBL_ARRAY | 0x31 | 一个提示，原始 Path2D 对象以 Java 的 double 数组形式存储于坐标中。
SERIAL_SEG_FLT_MOVETO | 0x40 | 2 浮点型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_FLT_LINETO | 0x41 | 2 浮点型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_FLT_QUADTO | 0x42 | 4 浮点型 | 后跟一个 quadTo 路径段。
SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 浮点型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_MOVETO | 0x50 | 2 双精度型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_DBL_LINETO | 0x51 | 2 双精度型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_DBL_QUADTO | 0x52 | 4 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_CLOSE | 0x60 | 一个 closePath 路径段。
SERIAL_PATH_END | 0x61 | 不再有路径段跟在后面。
抛出：
IOException
从以下版本开始：
1.6

类 java.awt.geom.Path2D.Float 继承 Path2D 实现 Serializable

serialVersionUID: 6990832515060788886L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从 ObjectInputStream 中读取默认的可序列化字段，然后显式序列化此路径中存储的路径段。

从 1.6 开始，没有默认的可序列化字段。

此对象的序列数据是用 writeObject 方法描述的。

抛出：
ClassNotFoundException
IOException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将默认的可序列化字段写入 ObjectOutputStream，然后显式序列化此路径中存储的路径段。

序列数据：
  1. 默认的可序列化字段。从 1.6 开始，没有默认的可序列化字段。
  2. 后跟一个字节，指示将初始对象的存储类型作为提示 (SERIAL_STORAGE_FLT_ARRAY)。
  3. 接着是一个整数，指示应该遵循的路径段数量 (NP)，或者为 -1 ，指示遵循未知数量的路径段。
  4. 接着又是一个整数，指示应该遵循的坐标总数 (NC)，或者为 -1，指示遵循未知的坐标数（NC 应该始终是偶数，因为坐标始终以成对的 x,y 形式出现）。
  5. 再接着是一个指示旋绕规则（WIND_EVEN_ODD 或 WIND_NON_ZERO）的字节。
  6. 再接着是由指示路径段类型的单个字节组成的值的 NP 集合（如果 NP < 0，则值是无限的），后跟表示路径段坐标的一对或多对 float 或 double 值。
  7. 最后是指示路径结尾的字节 (SERIAL_PATH_END) 。

以下字节值常量用于 Path2D 对象的序列化形式中：

常量名 | 字节值 | 后跟 | 描述
SERIAL_STORAGE_FLT_ARRAY | 0x30 | 一个提示，原始 Path2D 对象以 Java 的 float 数组形式存储于坐标中。
SERIAL_STORAGE_DBL_ARRAY | 0x31 | 一个提示，原始 Path2D 对象以 Java 的 double 数组形式存储于坐标中。
SERIAL_SEG_FLT_MOVETO | 0x40 | 2 浮点型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_FLT_LINETO | 0x41 | 2 浮点型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_FLT_QUADTO | 0x42 | 4 浮点型 | 后跟一个 quadTo 路径段。
SERIAL_SEG_FLT_CUBICTO | 0x43 | 6 浮点型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_MOVETO | 0x50 | 2 双精度型 | 后跟一个 moveTo 路径段。
SERIAL_SEG_DBL_LINETO | 0x51 | 2 双精度型 | 后跟一个 lineTo 路径段。
SERIAL_SEG_DBL_QUADTO | 0x52 | 4 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_DBL_CUBICTO | 0x53 | 6 双精度型 | 后跟一个 curveTo 路径段。
SERIAL_SEG_CLOSE | 0x60 | 一个 closePath 路径段。
SERIAL_PATH_END | 0x61 | 不再有路径段跟在后面。
抛出：
IOException
从以下版本开始：
1.6

类 java.awt.geom.Point2D.Double 继承 Point2D 实现 Serializable

serialVersionUID: 6150783262733311327L

序列化字段

x

double x
此 Point2D 的 X 坐标。

从以下版本开始：
1.2

y

double y
此 Point2D 的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Point2D.Float 继承 Point2D 实现 Serializable

serialVersionUID: -2870572449815403710L

序列化字段

x

float x
此 Point2D 的 X 坐标。

从以下版本开始：
1.2

y

float y
此 Point2D 的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.QuadCurve2D.Double 继承 QuadCurve2D 实现 Serializable

serialVersionUID: 4217149928428559721L

序列化字段

x1

double x1
二次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

double y1
二次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx

double ctrlx
二次曲线段控制点的 X 坐标。

从以下版本开始：
1.2

ctrly

double ctrly
二次曲线段控制点的 Y 坐标。

从以下版本开始：
1.2

x2

double x2
二次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

double y2
二次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.QuadCurve2D.Float 继承 QuadCurve2D 实现 Serializable

serialVersionUID: -8511188402130719609L

序列化字段

x1

float x1
二次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

float y1
二次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx

float ctrlx
二次曲线段控制点的 X 坐标。

从以下版本开始：
1.2

ctrly

float ctrly
二次曲线段控制点的 Y 坐标。

从以下版本开始：
1.2

x2

float x2
二次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

float y2
二次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2

类 java.awt.geom.Rectangle2D.Double 继承 Rectangle2D 实现 Serializable

serialVersionUID: 7771313791441850493L

序列化字段

x

double x
此 Rectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

double y
此 Rectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

double width
此 Rectangle2D 的宽度。

从以下版本开始：
1.2

height

double height
此 Rectangle2D 的高度。

从以下版本开始：
1.2

类 java.awt.geom.Rectangle2D.Float 继承 Rectangle2D 实现 Serializable

serialVersionUID: 3798716824173675777L

序列化字段

x

float x
此 Rectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

float y
此 Rectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

float width
此 Rectangle2D 的宽度。

从以下版本开始：
1.2

height

float height
此 Rectangle2D 的高度。

从以下版本开始：
1.2

类 java.awt.geom.RoundRectangle2D.Double 继承 RoundRectangle2D 实现 Serializable

serialVersionUID: 1048939333485206117L

序列化字段

x

double x
此 RoundRectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

double y
此 RoundRectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

double width
此 RoundRectangle2D 的宽度。

从以下版本开始：
1.2

height

double height
此 RoundRectangle2D 的高度。

从以下版本开始：
1.2

arcwidth

double arcwidth
圆角弧的宽度。

从以下版本开始：
1.2

archeight

double archeight
圆角弧的高度。

从以下版本开始：
1.2

类 java.awt.geom.RoundRectangle2D.Float 继承 RoundRectangle2D 实现 Serializable

serialVersionUID: -3423150618393866922L

序列化字段

x

float x
此 RoundRectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

float y
此 RoundRectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

float width
此 RoundRectangle2D 的宽度。

从以下版本开始：
1.2

height

float height
此 RoundRectangle2D 的高度。

从以下版本开始：
1.2

arcwidth

float arcwidth
圆角弧的宽度。

从以下版本开始：
1.2

archeight

float archeight
圆角弧的高度。

从以下版本开始：
1.2
软件包 java.awt.image

类 java.awt.image.ImagingOpException 继承 RuntimeException 实现 Serializable

类 java.awt.image.RasterFormatException 继承 RuntimeException 实现 Serializable

软件包 java.awt.image.renderable

类 java.awt.image.renderable.ParameterBlock 继承 Object 实现 Serializable

序列化字段

sources

Vector<E> sources
源的 Vector，存储为任意 Objects。

parameters

Vector<E> parameters
一个非源参数的 Vector，存储为任意 Object。

软件包 java.awt.print

类 java.awt.print.PrinterAbortException 继承 PrinterException 实现 Serializable

类 java.awt.print.PrinterException 继承 Exception 实现 Serializable

类 java.awt.print.PrinterIOException 继承 PrinterException 实现 Serializable

serialVersionUID: 5850870712125932846L

序列化字段

mException

IOException mException
终止打印作业的 IO 错误。

软件包 java.beans

类 java.beans.IndexedPropertyChangeEvent 继承 PropertyChangeEvent 实现 Serializable

序列化字段

index

int index

类 java.beans.IntrospectionException 继承 Exception 实现 Serializable

类 java.beans.PropertyChangeEvent 继承 EventObject 实现 Serializable

序列化字段

propertyName

String propertyName
已更改属性的名称。如果该名称未知，则为 null。

newValue

Object newValue
属性的新值。如果该值未知，则为 null。

oldValue

Object oldValue
属性以前的值。如果该值未知，则为 null。

propagationId

Object propagationId
传播 ID。可能为 null。

另请参见：
#getPropagationId.

类 java.beans.PropertyChangeSupport 继承 Object 实现 Serializable

serialVersionUID: 6401253773779951803L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列数据：
Null terminated list of PropertyChangeListeners。

在进行序列化时，跳过不可序列化的侦听器，只序列化可序列化的侦听器。

抛出：
IOException
序列化字段

children

Hashtable<K,V> children
管理特定属性的侦听器的哈希表。将属性名称映射到 PropertyChangeSupport 对象。

从以下版本开始：
1.2

source

Object source
将作为所有已生成事件的“源”提供的对象。

propertyChangeSupportSerializedDataVersion

int propertyChangeSupportSerializedDataVersion
内部版本号

从以下版本开始：

类 java.beans.PropertyVetoException 继承 Exception 实现 Serializable

序列化字段

evt

PropertyChangeEvent evt
描述所禁止的更改的 PropertyChangeEvent。

类 java.beans.VetoableChangeSupport 继承 Object 实现 Serializable

serialVersionUID: -5090210921595982017L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
序列数据：
Null terminated list of VetoableChangeListeners.

在进行序列化时，跳过不可序列化的侦听器，只序列化可序列化的侦听器。

抛出：
IOException
序列化字段

children

Hashtable<K,V> children
管理特定属性的侦听器的哈希表。将属性名称映射到 VetoableChangeSupport 对象。

从以下版本开始：
1.2

source

Object source
将作为所有已生成事件的“源”而提供的对象。

vetoableChangeSupportSerializedDataVersion

int vetoableChangeSupportSerializedDataVersion
内部版本号

软件包 java.beans.beancontext

类 java.beans.beancontext.BeanContextChildSupport 继承 Object 实现 Serializable

serialVersionUID: 6328947014421475877L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
恢复一个持久对象，必须等待后续 setBeanContext() 完全恢复从新的嵌套 BeanContext 中获得的所有资源

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
写入对象的持久状态。

抛出：
IOException
序列化字段

beanContextChildPeer

BeanContextChild beanContextChildPeer
在其中嵌套此 BeanContextChild 的 BeanContext。

pcSupport

PropertyChangeSupport pcSupport
与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。

vcSupport

VetoableChangeSupport vcSupport
与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。

类 java.beans.beancontext.BeanContextEvent 继承 EventObject 实现 Serializable

序列化字段

propagatedFrom

BeanContext propagatedFrom
作为此事件传播源的 BeanContext

类 java.beans.beancontext.BeanContextMembershipEvent 继承 BeanContextEvent 实现 Serializable

序列化字段

children

Collection<E> children
受此事件通知影响的子级的列表。

类 java.beans.beancontext.BeanContextServiceAvailableEvent 继承 BeanContextEvent 实现 Serializable

序列化字段

serviceClass

Class<T> serviceClass
新近可用服务的 Class 引用

类 java.beans.beancontext.BeanContextServiceRevokedEvent 继承 BeanContextEvent 实现 Serializable

序列化字段

serviceClass

Class<T> serviceClass
将被取消服务的 Class 引用。

invalidateRefs

boolean invalidateRefs

类 java.beans.beancontext.BeanContextServicesSupport 继承 BeanContextSupport 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
反序列化实例。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
序列化实例。

抛出：
IOException

类 java.beans.beancontext.BeanContextServicesSupport.BCSSChild 继承 BeanContextSupport.BCSChild 实现 Serializable

serialVersionUID: -3263851306889194873L

类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 继承 Object 实现 Serializable

序列化字段

serviceProvider

BeanContextServiceProvider serviceProvider

类 java.beans.beancontext.BeanContextSupport 继承 BeanContextChildSupport 实现 Serializable

serialVersionUID: -4879613978649577204L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
反序列化内容。如果此实例有截然不同的同位体，则子级在这里“不”被序列化，同位体的 readObject() 必须在反序列化此实例之后调用 readChildren()。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException,
                         ClassNotFoundException
序列化 BeanContextSupport，如果此实例有一个截然不同的同位体（即此对象正充当另一个对象的代理），则此实例的子级在这里不被序列化，因为在序列化此实例的同时反序列化其子级会产生“先有鸡还是先有蛋”的问题。 所以，在具有此实例的截然不同同位体的情况下，应该总是在调用 writeObject() 之后调用 writeChildren()，并在调用 readObject() 之后调用 readChildren()。

抛出：
IOException
ClassNotFoundException
序列化字段

serializable

int serializable

locale

Locale locale
此 BeanContext 的当前语言环境。

okToUseGui

boolean okToUseGui
指示此实例现在能否呈现 GUI 的 boolean 值。

designTime

boolean designTime
指示此对象目前是否处于设计时间模式下的 boolean 值。

类 java.beans.beancontext.BeanContextSupport.BCSChild 继承 Object 实现 Serializable

serialVersionUID: -5815286101609939109L

序列化字段

child

Object child

proxyPeer

Object proxyPeer
软件包 java.io

类 java.io.CharConversionException 继承 IOException 实现 Serializable

类 java.io.EOFException 继承 IOException 实现 Serializable

类 java.io.File 继承 Object 实现 Serializable

serialVersionUID: 301077366599181567L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject 来恢复此文件名。读取原有的分隔符字符。如果它于此系统上的分隔符字符不同，则使用本地分隔符替换原有的分隔符。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject 保存此文件名。还要保存分隔符字符，以便用不同主机类型重构该路径时可以对它进行替换。

序列数据：
Default fields followed by separator character.
抛出：
IOException
序列化字段

path

String path
此抽象路径名的规范化路径名字符串。规范化路径名字符串使用默认名称分隔符，并且不包含任何重复或多余的分隔符。

类 java.io.FileNotFoundException 继承 IOException 实现 Serializable

类 java.io.FilePermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 2202956749081564585L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
"permissions" field (a Vector containing the FilePermissions).
抛出：
IOException
序列化字段

permissions

Vector<E> permissions
A list of FilePermission objects.

类 java.io.InterruptedIOException 继承 IOException 实现 Serializable

序列化字段

bytesTransferred

int bytesTransferred
报告 I/O 操作中断之前传输了其中多少字节。

类 java.io.InvalidClassException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -4333316296251054416L

序列化字段

classname

String classname
无效类的名称。

无效类的名称。

类 java.io.InvalidObjectException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: 3233174318281839583L

类 java.io.IOError 继承 Error 实现 Serializable

serialVersionUID: 67100927991680413L

类 java.io.IOException 继承 Exception 实现 Serializable

serialVersionUID: 7818375828146090155L

类 java.io.NotActiveException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -3893467273049808895L

类 java.io.NotSerializableException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: 2906642554793891381L

类 java.io.ObjectStreamClass 继承 Object 实现 Serializable

serialVersionUID: -6120832682080437368L

序列化字段

类 java.io.ObjectStreamException 继承 IOException 实现 Serializable

serialVersionUID: 7260898174833392607L

类 java.io.OptionalDataException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -8011121865681257820L

序列化字段

length

int length
当前缓冲区中可读取的基本数据的字节数。

eof

boolean eof
如果流的缓冲部分不再有数据，则为 True。

类 java.io.SerializablePermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 8537212141160296410L

序列化字段

actions

String actions

类 java.io.StreamCorruptedException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: 8983558202217591746L

类 java.io.SyncFailedException 继承 IOException 实现 Serializable

类 java.io.UnsupportedEncodingException 继承 IOException 实现 Serializable

类 java.io.UTFDataFormatException 继承 IOException 实现 Serializable

类 java.io.WriteAbortedException 继承 ObjectStreamException 实现 Serializable

serialVersionUID: -3326426625597282442L

序列化字段

detail

Exception detail
在写入 ObjectStream 时捕获的异常。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获得此信息的首选方法。

软件包 java.lang

类 java.lang.AbstractMethodError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.ArithmeticException 继承 RuntimeException 实现 Serializable

类 java.lang.ArrayIndexOutOfBoundsException 继承 IndexOutOfBoundsException 实现 Serializable

类 java.lang.ArrayStoreException 继承 RuntimeException 实现 Serializable

类 java.lang.AssertionError 继承 Error 实现 Serializable

类 java.lang.Boolean 继承 Object 实现 Serializable

serialVersionUID: -3665804199014368530L

序列化字段

value

boolean value
布尔值。

类 java.lang.Byte 继承 Number 实现 Serializable

serialVersionUID: -7183698231559129828L

序列化字段

value

byte value
Byte 的值。

类 java.lang.Character 继承 Object 实现 Serializable

serialVersionUID: 3786198910865385080L

序列化字段

value

char value
Character 的值。

类 java.lang.Class 继承 Object 实现 Serializable

serialVersionUID: 3206093459760846163L

序列化概述
Class 类是 Serialization Stream Protocol 中的一个特例。 Class 实例最初是以下列格式写入 ObjectOutputStream 的：
      TC_CLASS ClassDescriptor
      ClassDescriptor 是 java.io.ObjectStreamClass 实例的一个特殊序列化。
类描述符写入该流的初始时刻会生成一个新的句柄。未来对该类描述符的引用写作对此初始类描述符实例的引用。

另请参见：
ObjectStreamClass
序列化字段

类 java.lang.ClassCastException 继承 RuntimeException 实现 Serializable

类 java.lang.ClassCircularityError 继承 LinkageError 实现 Serializable

类 java.lang.ClassFormatError 继承 LinkageError 实现 Serializable

类 java.lang.ClassNotFoundException 继承 Exception 实现 Serializable

serialVersionUID: 9176873029745254542L

序列化字段

ex

Throwable ex
如果使用 ClassNotFoundException(String s, Throwable ex) 构造方法来实例化对象，则此字段保持异常 ex。

从以下版本开始：
1.2

类 java.lang.CloneNotSupportedException 继承 Exception 实现 Serializable

类 java.lang.Double 继承 Number 实现 Serializable

serialVersionUID: -9172774392245257468L

序列化字段

value

double value
Double 的值。

类 java.lang.Enum 继承 Object 实现 Serializable

序列化字段

name

String name
此枚举常量的名称，在枚举声明中声明。大多数程序员应该使用 Enum.toString() 方法，而不是访问此字段。

ordinal

int ordinal
此枚举常量的序数（它在枚举声明中的位置，其中初始常量序数为零）。 大多数程序员不会使用此字段。它被设计用于复杂的基于枚举的数据结构，比如 EnumSet 和 EnumMap。

类 java.lang.EnumConstantNotPresentException 继承 RuntimeException 实现 Serializable

序列化字段

enumType

Class<T> enumType
缺少的枚举常量的类型。

constantName

String constantName
缺少的枚举常量的名称。

类 java.lang.Error 继承 Throwable 实现 Serializable

serialVersionUID: 4980196508277280342L

类 java.lang.Exception 继承 Throwable 实现 Serializable

serialVersionUID: -3387516993124229948L

类 java.lang.ExceptionInInitializerError 继承 LinkageError 实现 Serializable

serialVersionUID: 1521711792217232256L

序列化字段

exception

Throwable exception
如果使用 ExceptionInInitializerError(Throwable thrown) 构造方法来实例化此对象，则该字段将保持异常

类 java.lang.Float 继承 Number 实现 Serializable

serialVersionUID: -2671257302660747028L

序列化字段

value

float value
Float 的值。

类 java.lang.IllegalAccessError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.IllegalAccessException 继承 Exception 实现 Serializable

类 java.lang.IllegalArgumentException 继承 RuntimeException 实现 Serializable

serialVersionUID: -5365630128856068164L

类 java.lang.IllegalMonitorStateException 继承 RuntimeException 实现 Serializable

类 java.lang.IllegalStateException 继承 RuntimeException 实现 Serializable

serialVersionUID: -1848914673093119416L

类 java.lang.IllegalThreadStateException 继承 IllegalArgumentException 实现 Serializable

类 java.lang.IncompatibleClassChangeError 继承 LinkageError 实现 Serializable

类 java.lang.IndexOutOfBoundsException 继承 RuntimeException 实现 Serializable

类 java.lang.InstantiationError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.InstantiationException 继承 Exception 实现 Serializable

类 java.lang.Integer 继承 Number 实现 Serializable

serialVersionUID: 1360826667806852920L

序列化字段

value

int value
Integer 的值。

类 java.lang.InternalError 继承 VirtualMachineError 实现 Serializable

类 java.lang.InterruptedException 继承 Exception 实现 Serializable

类 java.lang.LinkageError 继承 Error 实现 Serializable

类 java.lang.Long 继承 Number 实现 Serializable

serialVersionUID: 4290774380558885855L

序列化字段

value

long value
Long 的值。

类 java.lang.NegativeArraySizeException 继承 RuntimeException 实现 Serializable

类 java.lang.NoClassDefFoundError 继承 LinkageError 实现 Serializable

类 java.lang.NoSuchFieldError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.NoSuchFieldException 继承 Exception 实现 Serializable

类 java.lang.NoSuchMethodError 继承 IncompatibleClassChangeError 实现 Serializable

类 java.lang.NoSuchMethodException 继承 Exception 实现 Serializable

类 java.lang.NullPointerException 继承 RuntimeException 实现 Serializable

类 java.lang.Number 继承 Object 实现 Serializable

serialVersionUID: -8742448824652078965L

类 java.lang.NumberFormatException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: -2848938806368998894L

类 java.lang.OutOfMemoryError 继承 VirtualMachineError 实现 Serializable

类 java.lang.RuntimeException 继承 Exception 实现 Serializable

serialVersionUID: -7034897190745766939L

类 java.lang.RuntimePermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 7399184964622342223L

类 java.lang.SecurityException 继承 RuntimeException 实现 Serializable

serialVersionUID: 6878364983674394167L

类 java.lang.Short 继承 Number 实现 Serializable

serialVersionUID: 7515723908773894738L

序列化字段

value

short value
Short 值。

类 java.lang.StackOverflowError 继承 VirtualMachineError 实现 Serializable

类 java.lang.StackTraceElement 继承 Object 实现 Serializable

serialVersionUID: 6992337162326171013L

序列化字段

declaringClass

String declaringClass

methodName

String methodName

fileName

String fileName

lineNumber

int lineNumber

类 java.lang.String 继承 Object 实现 Serializable

serialVersionUID: -6849794470754667710L

序列化概述
String 类被专门放入 Serialization Stream Protocol。 String 实例最初以如下格式被写入 ObjectOutputStream：
      TC_STRING (utf String)
该 String 由方法 DataOutput.writeUTF 写入。生成一个新句柄以访问流中对此字符串实例的所有将来引用。

序列化字段

类 java.lang.StringBuffer 继承 java.lang.AbstractStringBuilder 实现 Serializable

serialVersionUID: 3388685877147921107L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 StringBuffer 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 readObject，从流中恢复 StringBuffer 的状态。

抛出：
IOException
序列化概述
StringBuffer 的可序列化字段。

序列化字段

count

int count
该 StringBuffer 中的字符数。

shared

boolean shared
指示是否共享底层数组的标志。在反序列化时忽略该值。

value

char[] value
该 StringBuffer 的底层字符数组。

类 java.lang.StringBuilder 继承 java.lang.AbstractStringBuilder 实现 Serializable

serialVersionUID: 4383685877147921099L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 StringBuffer 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 StringBuilder 实例的状态保存到流中（也就是将其序列化）。

序列数据：
当前存储在字符串生成器中的字符数（int），后跟字符串生成器中的字符（char[]）。char 数组的长度可能大于当前存储在字符串生成器中的字符数，在这种情况下，将忽略多出的字符。
抛出：
IOException

类 java.lang.StringIndexOutOfBoundsException 继承 IndexOutOfBoundsException 实现 Serializable

类 java.lang.ThreadDeath 继承 Error 实现 Serializable

类 java.lang.Throwable 继承 Object 实现 Serializable

serialVersionUID: -3042686055658047285L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException
序列化字段

detailMessage

String detailMessage
有关 Throwable 的详细信息。例如，对于 FileNotFoundException，这包含了无法找到的文件名称。

cause

Throwable cause
由此 throwable 引起的 throwable 被抛出，如果 throwable 未由其他 throwable 引起，或作为 cause 的 throwable 未知，则为空。如果此字段等于该 throwable 本身，它表示该 throwable 的 cause 尚未初始化。

从以下版本开始：
1.4

stackTrace

StackTraceElement[] stackTrace
堆栈跟踪，由 Throwable.getStackTrace() 返回。

从以下版本开始：
1.4

类 java.lang.TypeNotPresentException 继承 RuntimeException 实现 Serializable

序列化字段

typeName

String typeName

类 java.lang.UnknownError 继承 VirtualMachineError 实现 Serializable

类 java.lang.UnsatisfiedLinkError 继承 LinkageError 实现 Serializable

类 java.lang.UnsupportedClassVersionError 继承 ClassFormatError 实现 Serializable

类 java.lang.UnsupportedOperationException 继承 RuntimeException 实现 Serializable

serialVersionUID: -1242599979055084673L

类 java.lang.VerifyError 继承 LinkageError 实现 Serializable

类 java.lang.VirtualMachineError 继承 Error 实现 Serializable

软件包 java.lang.annotation

类 java.lang.annotation.AnnotationFormatError 继承 Error 实现 Serializable

类 java.lang.annotation.AnnotationTypeMismatchException 继承 RuntimeException 实现 Serializable

序列化字段

element

Method element
注释元素的 Method 对象。

foundType

String foundType
在注释中找到的数据（错误）类型。该字符串可以，但不一定包含该值。字符串的确切格式没有指定。

类 java.lang.annotation.IncompleteAnnotationException 继承 RuntimeException 实现 Serializable

序列化字段

annotationType

Class<T> annotationType

elementName

String elementName
软件包 java.lang.instrument

类 java.lang.instrument.IllegalClassFormatException 继承 Exception 实现 Serializable

类 java.lang.instrument.UnmodifiableClassException 继承 Exception 实现 Serializable

软件包 java.lang.management

类 java.lang.management.ManagementPermission 继承 BasicPermission 实现 Serializable

软件包 java.lang.reflect

类 java.lang.reflect.GenericSignatureFormatError 继承 ClassFormatError 实现 Serializable

类 java.lang.reflect.InvocationTargetException 继承 Exception 实现 Serializable

serialVersionUID: 4085088731926701167L

序列化字段

target

Throwable target
如果使用 InvocationTargetException(Throwable target) 构造方法来实例化该对象，则此字段将保持目标

类 java.lang.reflect.MalformedParameterizedTypeException 继承 RuntimeException 实现 Serializable

类 java.lang.reflect.Proxy 继承 Object 实现 Serializable

serialVersionUID: -2222568056686623797L

序列化字段

h

InvocationHandler h
此代理实例的调用处理程序。

类 java.lang.reflect.ReflectPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 7412737110241507485L

类 java.lang.reflect.UndeclaredThrowableException 继承 RuntimeException 实现 Serializable

serialVersionUID: 330127114055056639L

序列化字段

undeclaredThrowable

Throwable undeclaredThrowable
抛出的经过检查的未声明异常

软件包 java.math

类 java.math.BigDecimal 继承 Number 实现 Serializable

serialVersionUID: 6108874887143696463L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 BigDecimal 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此 BigDecimal 序列化到请求的流

抛出：
IOException
序列化字段

intVal

BigInteger intVal
此 BigDecimal 的非标度值，由 BigDecimal.unscaledValue() 返回。

另请参见：
BigDecimal.unscaledValue()

scale

int scale
此 BigDecimal 的标度，由 BigDecimal.scale 返回。

另请参见：
BigDecimal.scale

类 java.math.BigInteger 继承 Number 实现 Serializable

serialVersionUID: -8287574255936472291L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 BigInteger 实例（也就是将其反序列化）。由于历史原因，该大小作为一个 byte 数组读入，但它被转换为一个 int 数组，并丢弃 byte 数组。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 BigInteger 实例保存到流。由于历史原因，BigInteger 的大小被序列化为一个 byte 数组。

序列数据：
将写入两个必需字段和一些过时字段，以便与较旧版本兼容。
抛出：
IOException
序列化概述
BigInteger 的可序列化字段。

序列化字段

bitCount

int bitCount
此 BigInteger 中的位数

bitLength

int bitLength
此 BigInteger 最小的二进制补码表示形式的位数

lowestSetBit

int lowestSetBit
二进制补码表示形式的最低设置位

magnitude

int[] magnitude
此 BigInteger 的大小数组。

signum

int signum
此 BigInteger 的正负号。

类 java.math.MathContext 继承 Object 实现 Serializable

serialVersionUID: 5579720004786848255L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 MathContext 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException
序列化字段

precision

int precision
某个操作使用的数位。值为 0 指示将使用无限精度（需要多少位就用多少位）。注意，前导零（在某个数的系数中）不是有效数字。

precision 始终为非负数。

roundingMode

RoundingMode roundingMode
某个操作使用的舍入算法。

另请参见：
RoundingMode
软件包 java.net

类 java.net.BindException 继承 SocketException 实现 Serializable

类 java.net.ConnectException 继承 SocketException 实现 Serializable

类 java.net.HttpRetryException 继承 IOException 实现 Serializable

序列化字段

responseCode

int responseCode

location

String location

类 java.net.Inet4Address 继承 InetAddress 实现 Serializable

serialVersionUID: 3286316764910316507L

序列化方法

writeReplace

private Object writeReplace()
                     throws ObjectStreamException
用 InetAddress 对象取代要序列化的对象。

抛出：
ObjectStreamException - 如果无法创建取代此对象的新对象

类 java.net.Inet6Address 继承 InetAddress 实现 Serializable

serialVersionUID: 6880410070516793377L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
仅当范围接口名称在此系统上有效时，从包括范围信息的流还原此对象的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写默认行为以便以 String 的形式，而不是以不可序列化的 NetworkInterface 的形式写入 scope_ifname 字段。

抛出：
IOException
序列化字段

ipaddress

byte[] ipaddress
Holds a 128-bit (16 bytes) IPv6 address.

scope_id

int scope_id
scope_id。创建对象时指定的范围。如果对象是使用接口名称创建的，则到需要时才确定 scope_id。

scope_id_set

boolean scope_id_set
当 scope_id 字段包含有效的整数 scope_id 时，将其设置为 true。

scope_ifname_set

boolean scope_ifname_set
在使用范围接口而不是数字范围 id 构造对象时设置。

ifname

String ifname
仅在序列化/反序列化期间才使用后跟字段

类 java.net.InetAddress 继承 Object 实现 Serializable

serialVersionUID: 3286316764910316507L

序列化方法

readResolve

private Object readResolve()
                    throws ObjectStreamException
用 Inet4Address 对象取代反序列化对象。

抛出：
ObjectStreamException - 如果无法创建取代此对象的新对象
序列化字段

hostName

String hostName

address

int address
Holds a 32-bit IPv4 address.

family

int family
Specifies the address family type, for instance, '1' for IPv4 addresses, and '2' for IPv6 addresses.

类 java.net.InetSocketAddress 继承 SocketAddress 实现 Serializable

serialVersionUID: 5076001401234631237L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException
序列化字段

hostname

String hostname

addr

InetAddress addr

port

int port

类 java.net.MalformedURLException 继承 IOException 实现 Serializable

类 java.net.NetPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -8343910153355041693L

类 java.net.NoRouteToHostException 继承 SocketException 实现 Serializable

类 java.net.PortUnreachableException 继承 SocketException 实现 Serializable

类 java.net.ProtocolException 继承 IOException 实现 Serializable

类 java.net.SocketAddress 继承 Object 实现 Serializable

类 java.net.SocketException 继承 IOException 实现 Serializable

类 java.net.SocketPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 2787186408602843674L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
"permissions" field (a Vector containing the SocketPermissions).
抛出：
IOException
序列化字段

permissions

Vector<E> permissions
A list of the SocketPermissions for this set.

类 java.net.SocketTimeoutException 继承 InterruptedIOException 实现 Serializable

类 java.net.UnknownHostException 继承 IOException 实现 Serializable

类 java.net.UnknownServiceException 继承 IOException 实现 Serializable

类 java.net.URI 继承 Object 实现 Serializable

serialVersionUID: -6052424284110960213L

序列化方法

readObject

private void readObject(ObjectInputStream is)
                 throws ClassNotFoundException,
                        IOException
从给定的串行流重构 URI。

调用 ObjectInputStream.defaultReadObject() 方法以读取 string 字段的值。然后按通常方式对结果进行解析。

抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream os)
                  throws IOException
将此 URI 的内容保存到给定的串行流中。

URI 实例的惟一可序列化字段是 string 字段。如果该字段原来没有值，则给定一个值，然后调用给定对象输出流的 ObjectOutputStream.defaultWriteObject() 方法。

抛出：
IOException
序列化字段

string

String string
此 URI 的字符串表示形式。

类 java.net.URISyntaxException 继承 Exception 实现 Serializable

序列化字段

input

String input

index

int index

类 java.net.URL 继承 Object 实现 Serializable

serialVersionUID: -7627629688361524110L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，以便从流中恢复 URL 的状态。它读取 URL 的各个组成部分并查找本地流处理程序。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject，将 URL 的状态保存到 ObjectOutputStream 中。不保存该处理程序，因为它特定于此系统。

序列数据：
默认的写入对象的值。当读取返回时，reader 必须确保调用的具有协议变量的 getURLStreamHandler 返回有效的 URLStreamHandler，如果返回无效的 URLStreamHandler，则抛出 IOException 异常。
抛出：
IOException
序列化字段

protocol

String protocol
要使用的协议（ftp、http、nntp，...等）。

host

String host
要连接的主机名。

port

int port
要连接的协议端口。

file

String file
相应主机上的指定文件名。file 定义的格式为 path[?query]

authority

String authority
此 URL 的授权部分。

ref

String ref
# 引用。

hashCode

int hashCode
软件包 java.nio

类 java.nio.BufferOverflowException 继承 RuntimeException 实现 Serializable

类 java.nio.BufferUnderflowException 继承 RuntimeException 实现 Serializable

类 java.nio.InvalidMarkException 继承 IllegalStateException 实现 Serializable

类 java.nio.ReadOnlyBufferException 继承 UnsupportedOperationException 实现 Serializable

软件包 java.nio.channels

类 java.nio.channels.AlreadyConnectedException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.AsynchronousCloseException 继承 ClosedChannelException 实现 Serializable

类 java.nio.channels.CancelledKeyException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.ClosedByInterruptException 继承 AsynchronousCloseException 实现 Serializable

类 java.nio.channels.ClosedChannelException 继承 IOException 实现 Serializable

类 java.nio.channels.ClosedSelectorException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.ConnectionPendingException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.FileLockInterruptionException 继承 IOException 实现 Serializable

类 java.nio.channels.IllegalBlockingModeException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.IllegalSelectorException 继承 IllegalArgumentException 实现 Serializable

类 java.nio.channels.NoConnectionPendingException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NonReadableChannelException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NonWritableChannelException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NotYetBoundException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.NotYetConnectedException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.OverlappingFileLockException 继承 IllegalStateException 实现 Serializable

类 java.nio.channels.UnresolvedAddressException 继承 IllegalArgumentException 实现 Serializable

类 java.nio.channels.UnsupportedAddressTypeException 继承 IllegalArgumentException 实现 Serializable

软件包 java.nio.charset

类 java.nio.charset.CharacterCodingException 继承 IOException 实现 Serializable

类 java.nio.charset.CoderMalfunctionError 继承 Error 实现 Serializable

类 java.nio.charset.IllegalCharsetNameException 继承 IllegalArgumentException 实现 Serializable

序列化字段

charsetName

String charsetName

类 java.nio.charset.MalformedInputException 继承 CharacterCodingException 实现 Serializable

序列化字段

inputLength

int inputLength

类 java.nio.charset.UnmappableCharacterException 继承 CharacterCodingException 实现 Serializable

序列化字段

inputLength

int inputLength

类 java.nio.charset.UnsupportedCharsetException 继承 IllegalArgumentException 实现 Serializable

序列化字段

charsetName

String charsetName
软件包 java.rmi

类 java.rmi.AccessException 继承 RemoteException 实现 Serializable

serialVersionUID: 6314925228044966088L

类 java.rmi.AlreadyBoundException 继承 Exception 实现 Serializable

serialVersionUID: 9218657361741657110L

类 java.rmi.ConnectException 继承 RemoteException 实现 Serializable

serialVersionUID: 4863550261346652506L

类 java.rmi.ConnectIOException 继承 RemoteException 实现 Serializable

serialVersionUID: -8087809532704668744L

类 java.rmi.MarshalException 继承 RemoteException 实现 Serializable

serialVersionUID: 6223554758134037936L

类 java.rmi.MarshalledObject 继承 Object 实现 Serializable

serialVersionUID: 8988374069173025854L

序列化字段

objBytes

byte[] objBytes
字节的序列化表示形式。如果 objBytes 为 null，则已编组的对象为 null 引用。

locBytes

byte[] locBytes
由 equals 忽略的字节位置注释。如果 locBytes 为 null，则在编组过程中存在非 null 注释。

hash

int hash
所包含对象存储的哈希码。
另请参见：
MarshalledObject.hashCode()

类 java.rmi.NoSuchObjectException 继承 RemoteException 实现 Serializable

serialVersionUID: 6619395951570472985L

类 java.rmi.NotBoundException 继承 Exception 实现 Serializable

serialVersionUID: -1857741824849069317L

类 java.rmi.RemoteException 继承 IOException 实现 Serializable

serialVersionUID: -5148567311918794206L

序列化字段

detail

Throwable detail
远程异常的原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

类 java.rmi.RMISecurityException 继承 SecurityException 实现 Serializable

serialVersionUID: -8433406075740433514L

类 java.rmi.ServerError 继承 RemoteException 实现 Serializable

serialVersionUID: 8455284893909696482L

类 java.rmi.ServerException 继承 RemoteException 实现 Serializable

serialVersionUID: -4775845313121906682L

类 java.rmi.ServerRuntimeException 继承 RemoteException 实现 Serializable

serialVersionUID: 7054464920481467219L

类 java.rmi.StubNotFoundException 继承 RemoteException 实现 Serializable

serialVersionUID: -7088199405468872373L

类 java.rmi.UnexpectedException 继承 RemoteException 实现 Serializable

serialVersionUID: 1800467484195073863L

类 java.rmi.UnknownHostException 继承 RemoteException 实现 Serializable

serialVersionUID: -8152710247442114228L

类 java.rmi.UnmarshalException 继承 RemoteException 实现 Serializable

serialVersionUID: 594380845140740218L

软件包 java.rmi.activation

类 java.rmi.activation.ActivateFailedException 继承 RemoteException 实现 Serializable

serialVersionUID: 4863550261346652506L

类 java.rmi.activation.ActivationDesc 继承 Object 实现 Serializable

serialVersionUID: 7455834104417690957L

序列化字段

groupID

ActivationGroupID groupID
组标识符

className

String className
对象的类名

location

String location
对象的代码基

data

MarshalledObject<T> data
对象的初始化数据

restart

boolean restart
表示对象是否应当被重新启动。

类 java.rmi.activation.ActivationException 继承 Exception 实现 Serializable

serialVersionUID: -4320118837291406071L

序列化字段

detail

Throwable detail
激活异常的原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

类 java.rmi.activation.ActivationGroup 继承 UnicastRemoteObject 实现 Serializable

serialVersionUID: -7696947875314805420L

序列化字段

groupID

ActivationGroupID groupID
组标识符

monitor

ActivationMonitor monitor
组监视器

incarnation

long incarnation
组的代号

类 java.rmi.activation.ActivationGroup_Stub 继承 RemoteStub 实现 Serializable

类 java.rmi.activation.ActivationGroupDesc 继承 Object 实现 Serializable

serialVersionUID: -4936225423168276595L

序列化字段

className

String className
组的完全限定包的类名。

location

String location
要加载组类的位置。

data

MarshalledObject<T> data
组的初始化数据。

env

ActivationGroupDesc.CommandEnvironment env
在另一个进程中执行 VM 的控制选项。

props

Properties props
一个将重写子进程环境中默认设置的属性映射表。

类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 继承 Object 实现 Serializable

serialVersionUID: 6165754737887770191L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
针对自定义序列化的 readObject。

此方法按以下方式读取该类的此对象的序列化形式：

此方法首先调用指定对象输入流上的 defaultReadObject，如果 options 为 null，则 options 被设置为零长度的 String 数组。

抛出：
IOException
ClassNotFoundException
序列化字段

command

String command

options

String[] options

类 java.rmi.activation.ActivationGroupID 继承 Object 实现 Serializable

serialVersionUID: -1648432278909740833L

序列化字段

system

ActivationSystem system
组的激活系统。

uid

UID uid
组的唯一 id。

类 java.rmi.activation.ActivationID 继承 Object 实现 Serializable

serialVersionUID: -4608673054848209235L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
针对自定义序列化的 readObject。

此方法为此类读取此对象的序列化形式，方式如下：

readObject 方法在 in 被调用，以读取此对象的惟一标识符（一个 UID 实例）。

接下来，readUTF 方法在 in 上被调用，以读取此对象的激活器的 RemoteRef 实例的外部引用类型名称。然后，对应于外部引用类型名称（由 readUTF 返回），RemoteRef 实例由一个特定于实现的类创建，并且 readExternal 方法在该 RemoteRef 实例上被调用，以读取对应于外部引用类型名称的外部形式。

注：如果外部引用类型名称为 "UnicastRef"、"UnicastServerRef"、"UnicastRef2"、"UnicastServerRef2" 或 "ActivatableRef"，则必须找到对应的特定于实现的类，并且其 readExternal 方法必须为外部类型名称读取序列数据，正如指定将此类写入 serialData 文档一样。如果外部引用类型名称是任何其他字符串（长度不为零），则将抛出 ClassNotFoundException，除非该实现提供了对应于外部引用类型名称的特定于实现的类，在这种情况下，RemoteRef 将是特定于实现的类的一个实例。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
针对自定义序列化的 writeObject。

此方法为此类写入此对象的序列化形式，方式如下：

传入此对象的惟一标识符（一个 UID 实例）作为参数，writeObject 方法在 out 上被调用。

接下来，getRefClass 方法在激活器的 RemoteRef 实例上被调用，以获得其外部引用类型名称。然后，writeUTF 方法使用 getRefClass 返回的值在 out 上被调用，接着 writeExternal 方法传递 out 作为参数在 RemoteRef 实例上被调用。

序列数据：
此类的序列化数据组成一个 java.rmi.server.UID（用 ObjectOutput.writeObject 方法写入），后面紧跟激活器 RemoteRef 实例（用 ObjectOutput.writeUTF 写入的一个字符串）的外部类型名称，后面紧跟由其 writeExternal 方法写入的 RemoteRef 实例的外部形式。

使用在 RemoteObject 的 writeObject 方法 serialData 规范中指定的外部引用类型名称的定义来确定 RemoteRef 实例的外部引用类型名称。类似地，通过 RemoteRef 实现类的 writeExternal 方法写入和通过 readExternal 方法读取的数据对应于在 RemoteObject writeObject 方法 serialData 规范中指定的每一个已定义外部引用类型名称。

抛出：
IOException
ClassNotFoundException

类 java.rmi.activation.UnknownGroupException 继承 ActivationException 实现 Serializable

serialVersionUID: 7056094974750002460L

类 java.rmi.activation.UnknownObjectException 继承 ActivationException 实现 Serializable

serialVersionUID: 3425547551622251430L

软件包 java.rmi.dgc

类 java.rmi.dgc.Lease 继承 Object 实现 Serializable

serialVersionUID: -5713411624328831948L

序列化字段

vmid

VMID vmid
与此 Lease 关联的虚拟机 ID。
另请参见：
Lease.getVMID()

value

long value
此 lease 的期限。
另请参见：
Lease.getValue()

类 java.rmi.dgc.VMID 继承 Object 实现 Serializable

serialVersionUID: -538642295484486218L

序列化字段

addr

byte[] addr
唯一地标识创建于其上的主机的 byte 数组

uid

UID uid
有关创建于其上的主机的唯一标识符
软件包 java.rmi.server

类 java.rmi.server.ExportException 继承 RemoteException 实现 Serializable

serialVersionUID: -9155485338494060170L

类 java.rmi.server.ObjID 继承 Object 实现 Serializable

serialVersionUID: -6386392263968365220L

序列化字段

objNum

long objNum
object number
另请参见：
ObjID.hashCode()

space

UID space
address space identifier (unique to host over time)

类 java.rmi.server.RemoteObject 继承 Object 实现 Serializable

serialVersionUID: -3215090123894869218L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
用于自定义序列化的 readObject。

此方法按以下方式读取该类的此对象的序列化形式：

在 in 上调用 readUTF 方法来读取 RemoteRef 实例的外部 ref 类型名称，以将其填充到此对象的 ref 字段。如果 readUTF 返回的字符串长度为 0，则在 in 上调用 readObject 方法，然后将 readObject 返回的值转换为 RemoteRef，并将此对象的 ref 字段设置为该值。否则，此对象的 ref 字段将设置为从与 readUTF 返回的外部 ref 类型名称相对应的特定于实现的类创建的 RemoteRef 实例，然后在此对象的 ref 字段上调用 readExternal 方法。

如果外部 ref 类型名称为 "UnicastRef"、"UnicastServerRef"、"UnicastRef2"、"UnicastServerRef2" 或 "ActivatableRef"，则必须找到一个相应的特定于实现的类，并且其 readExternal 方法在指定要写入此类的 serialData 文档时必须读取外部 ref 类型名称的序列数据。如果外部 ref 类型名称是任何其他字符串（长度不是 0），则将抛出 ClassNotFoundException，除非该实现提供相对于该外部 ref 类型名称的特定于实现的类，在这种情况下，将把此对象的 ref 字段设置为一个该特定于实现的类的实例。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException,
                         ClassNotFoundException
用于自定义序列化的 writeObject。

此方法按以下方式写入该类的此对象的序列化形式：

在此对象的 ref 字段上调用 getRefClass 方法，以获得其外部 ref 类型名称。如果 getRefClass 返回的值是长度大于 0 的非 null 字符串，则在具有 getRefClass 返回的值的 out 上调用 writeUTF 方法，然后在作为参数传递 out 的此对象的 ref 字段上调用 writeExternal 方法；否则，在具有 0 长度字符串 ("") 的 out 上调用 writeUTF 方法，然后在作为参数传递此对象的 ref 字段的 out 上调用 writeObject 方法。

序列数据：
此类的序列化数据包含一个字符串（用 ObjectOutput.writeUTF 写入），该字符串可以是包含的 RemoteRef 实例（ref 字段）的外部 ref 类型名称，也可以是一个 0 长度字符串，如果该字符串的长度不是 0，则后跟 writeExternal 方法写入的 ref 字段的外部形式；如果该字符串的长度为 0，则后跟将其传递到序列化流的 writeObject 时写入的 ref 字段的序列化形式。

如果此对象是一个从任何 UnicastRemoteObject.exportObject 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，且未使用自定义套接字工厂，则外部 ref 类型名称为 "UnicastRef"。 如果此对象是一个从任何 UnicastRemoteObject.exportObject 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，且使用自定义套接字工厂，则外部 ref 类型名称为 "UnicastRef2"。 如果此对象是一个从任何 java.rmi.activation.Activatable.exportObject 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，则外部 ref 类型名称为 "ActivatableRef"。 如果此对象是一个从 RemoteObject.toStub 方法返回的 RemoteStub 或 RemoteObjectInvocationHandler 的实例（并且传入 toStub 的参数本身不是 RemoteStub），则外部 ref 类型名称是一个传入 toStub 的远程对象的导出方式的函数，如上所述。 如果此对象是一个最初通过反序列化创建的 RemoteStub 或 RemoteObjectInvocationHandler 的实例，则外部 ref 类型名称与此对象进行反序列化时读取的类型名称相同。

如果此对象是一个未使用自定义套接字工厂的 java.rmi.server.UnicastRemoteObject 的实例，则外部 ref 类型名称为 "UnicastServerRef"。 如果此对象是一个使用自定义套接字工厂的 UnicastRemoteObject 实例，则外部 ref 类型名称为 "UnicastServerRef2"。

下面是必须由 writeExternal 方法写入且由 RemoteRef 实现类的 readExternal 方法读取的数据，该实现类对应于每个定义的外部 ref 类型名称：

对于 "UnicastRef"：

  • 引用的远程对象的主机名，由 DataOutput.writeUTF(String) 写入
  • 引用的远程对象的端口，由 DataOutput.writeInt(int) 写入
  • 作为引用中包含的 ObjID 实例上调用 {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} 的结果写入的数据
  • boolean 值 false，由 DataOutput.writeBoolean(boolean) 写入

对于具有 null 客户机套接字工厂的 "UnicastRef2"：

  • 字节值 0x00（指示 null 客户机套接字工厂），由 DataOutput.writeByte(int) 写入
  • 引用的远程对象的主机名，由 DataOutput.writeUTF(String) 写入
  • 引用的远程对象的端口，由 DataOutput.writeInt(int) 写入
  • 作为引用中包含的 ObjID 实例上调用 {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} 的结果写入的数据
  • boolean 值 false，由 DataOutput.writeBoolean(boolean) 写入

对于具有非 null 客户机套接字工厂的 "UnicastRef2"：

  • 字节值 0x01（指示非 null 客户机套接字工厂），由 DataOutput.writeByte(int) 写入
  • 引用的远程对象的主机名，由 DataOutput.writeUTF(String) 写入
  • 引用的远程对象的端口，由 DataOutput.writeInt(int) 写入
  • 客户机套接字工厂（类型 java.rmi.server.RMIClientSocketFactory 的对象），通过将其传递到流实例上的 writeObject 的调用写入
  • 作为引用中包含的 ObjID 实例上调用 {link java.rmi.server.ObjID#write(java.io.ObjectOutput)} 的结果写入的数据
  • boolean 值 false，由 DataOutput.writeBoolean(boolean) 写入

对于具有 null 嵌入远程引用的 "ActivatableRef"：

  • java.rmi.activation.ActivationID 的实例，通过将其传递到流实例上的 writeObject 的调用写入
  • 0 长度字符串 ("")，由 DataOutput.writeUTF(String) 写入

对于具有非 null 嵌入远程引用的 "ActivatableRef"：

  • java.rmi.activation.ActivationID 的实例，通过将其传递到流实例上的 writeObject 的调用写入
  • 嵌入的远程引用的外部 ref 类型名称（必须是 "UnicastRef2"），由 DataOutput.writeUTF(String) 写入
  • 嵌入的远程引用的外部形式，通过调用其具有流实例的 writeExternal 方法写入（请参阅上述 "UnicastRef2" 的外部形式的描述）

对于 "UnicastServerRef" 和 "UnicastServerRef2"，不能通过 writeExternal 方法写入数据，也不能通过 readExternal 方法读取数据。

抛出：
IOException
ClassNotFoundException

类 java.rmi.server.RemoteObjectInvocationHandler 继承 RemoteObject 实现 Serializable

serialVersionUID: 2L

序列化方法

readObjectNoData

private void readObjectNoData()
                       throws InvalidObjectException
抛出：
InvalidObjectException - 无条件抛出

类 java.rmi.server.RemoteServer 继承 RemoteObject 实现 Serializable

serialVersionUID: -4100238210092549637L

类 java.rmi.server.RemoteStub 继承 RemoteObject 实现 Serializable

serialVersionUID: -1585587260594494182L

类 java.rmi.server.ServerCloneException 继承 CloneNotSupportedException 实现 Serializable

serialVersionUID: 6617456357664815945L

序列化字段

detail

Exception detail
异常原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

类 java.rmi.server.ServerNotActiveException 继承 Exception 实现 Serializable

serialVersionUID: 4687940720827538231L

类 java.rmi.server.SkeletonMismatchException 继承 RemoteException 实现 Serializable

serialVersionUID: -7780460454818859281L

类 java.rmi.server.SkeletonNotFoundException 继承 RemoteException 实现 Serializable

serialVersionUID: -7860299673822761231L

类 java.rmi.server.SocketSecurityException 继承 ExportException 实现 Serializable

serialVersionUID: -7622072999407781979L

类 java.rmi.server.UID 继承 Object 实现 Serializable

serialVersionUID: 1086053664494604050L

序列化字段

unique

int unique
唯一标识此 UID 在其中生成的 VM 的数字，该数字和主机和给定的时间有关

time

long time
此 UID 在其中生成的 VM 处于活动状态时的时间（由 System.currentTimeMillis() 返回）

count

short count
用来区分按同一时间在同一 VM 中创建的 UID 实例的 16 位数字

类 java.rmi.server.UnicastRemoteObject 继承 RemoteServer 实现 Serializable

serialVersionUID: 4974527148936298033L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
将远程对象进行反序列化时重新将其导出。

抛出：
IOException
ClassNotFoundException
序列化字段

port

int port
要在其上导出对象的端口号

csf

RMIClientSocketFactory csf
客户端套接字工厂（如果有）

ssf

RMIServerSocketFactory ssf
导出对象时使用的服务器端套接字工厂（如果有）
软件包 java.security

类 java.security.AccessControlException 继承 SecurityException 实现 Serializable

serialVersionUID: 5138225684096988535L

序列化字段

perm

Permission perm

类 java.security.AllPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: -4023755556366636806L

序列化字段

all_allowed

boolean all_allowed

类 java.security.AuthProvider 继承 Provider 实现 Serializable

类 java.security.BasicPermission 继承 Permission 实现 Serializable

serialVersionUID: 6279438298436773498L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 BasicPermission 的状态。

抛出：
IOException
ClassNotFoundException

类 java.security.BasicPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 739301742472979399L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
readObject is called to restore the state of the BasicPermissionCollection from a stream.

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default fields.
抛出：
IOException
序列化字段

all_allowed

boolean all_allowed
This is set to true if this BasicPermissionCollection contains a BasicPermission with '*' as its permission name.

permClass

Class<T> permClass
The class to which all BasicPermissions in this BasicPermissionCollection belongs.

permissions

Hashtable<K,V> permissions
The BasicPermissions in this BasicPermissionCollection. All BasicPermissions in the collection must belong to the same class. The Hashtable is indexed by the BasicPermission name; the value of the Hashtable entry is the permission.

类 java.security.CodeSigner 继承 Object 实现 Serializable

serialVersionUID: 6819288105193937581L

序列化字段

signerCertPath

CertPath signerCertPath
签名者的证书路径。

timestamp

Timestamp timestamp

类 java.security.CodeSource 继承 Object 实现 Serializable

serialVersionUID: 4977541819976013951L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
从流还原此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写出到流中（也就是将其序列化）。

序列数据：
初始 URL 后跟一个 int，指示要遵守的证书数（值“零”表示不存在与此对象关联的证书）。所有证书的撰写都以表示证书类型的 String 开头，后跟一个指定证书编码长度的 int，再后跟作为 byte 数组写出的证书编码本身。最后，如果出现代码签名者，则同时序列化和写出代码签名者的数组。
抛出：
IOException
序列化字段

location

URL location
代码位置。

类 java.security.DigestException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 5821450303093652515L

类 java.security.GeneralSecurityException 继承 Exception 实现 Serializable

serialVersionUID: 894798122053539237L

类 java.security.GuardedObject 继承 Object 实现 Serializable

serialVersionUID: -5240450096227834308L

序列化方法

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写出到流中（即将其序列化）。如果存在 guard，则检查它。

抛出：
IOException
序列化字段

object

Object object

guard

Guard guard

类 java.security.Identity 继承 Object 实现 Serializable

serialVersionUID: 3609922007826600659L

序列化字段

name

String name
已过时。
此 Identity 的名称。

publicKey

PublicKey publicKey
已过时。
此 Identity 的公钥。

info

String info
已过时。
Generic, descriptive information about the identity.

scope

IdentityScope scope
已过时。
The scope of the identity.

certificates

Vector<E> certificates
已过时。
The certificates for this identity.

类 java.security.IdentityScope 继承 Identity 实现 Serializable

serialVersionUID: -2337346281189773310L

类 java.security.InvalidAlgorithmParameterException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 2864672297499471472L

类 java.security.InvalidKeyException 继承 KeyException 实现 Serializable

serialVersionUID: 5698479920593359816L

类 java.security.InvalidParameterException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: -857968536935667808L

类 java.security.KeyException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -7483676942812432108L

类 java.security.KeyManagementException 继承 KeyException 实现 Serializable

serialVersionUID: 947674216157062695L

类 java.security.KeyPair 继承 Object 实现 Serializable

serialVersionUID: -7565189502268009837L

序列化字段

privateKey

PrivateKey privateKey

publicKey

PublicKey publicKey

类 java.security.KeyRep 继承 Object 实现 Serializable

serialVersionUID: -4757683898830641853L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析 Key 对象。

此方法支持三种 Type/format 组合：

  • Type.SECRET/"RAW" - 返回使用编码的密钥字节和算法构建的 SecretKeySpec 对象
  • Type.PUBLIC/"X.509" - 获取该密钥算法的 KeyFactory 实例，用编码的密钥字节构建 X509EncodedKeySpec，根据 spec 生成公钥
  • Type.PRIVATE/"PKCS#8" - 获取该密钥算法的 KeyFactory 实例，用编码的密钥字节构造 PKCS8EncodedKeySpec，根据 spec 生成私钥

抛出：
ObjectStreamException - 如果 Type/format 组合是不能识别的；如果算法、密钥格式或编码的密钥字节是不能识别的/无效的；如果由于任何原因密钥解析失败。
序列化字段

type

KeyRep.Type type
Type.SECRET、Type.PUBLIC 或 Type.PRIVATE 之一。

algorithm

String algorithm
Key 算法

format

String format
Key 编码格式

encoded

byte[] encoded
编码的 Key 的字节

类 java.security.KeyStoreException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -1119353179322377262L

类 java.security.NoSuchAlgorithmException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -7443947487218346562L

类 java.security.NoSuchProviderException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 8488111756688534474L

类 java.security.Permission 继承 Object 实现 Serializable

serialVersionUID: -5636570222231596674L

序列化字段

name

String name

类 java.security.PermissionCollection 继承 Object 实现 Serializable

serialVersionUID: -6727011328946861783L

序列化字段

readOnly

boolean readOnly

类 java.security.PermissionsHash 继承 PermissionCollection 实现 Serializable

serialVersionUID: -8491988220802933440L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default fields.
抛出：
IOException
序列化字段

perms

Hashtable<K,V> perms
A table of the Permissions (both key and value are same).

类 java.security.PrivilegedActionException 继承 Exception 实现 Serializable

serialVersionUID: 4724086851538908602L

序列化字段

exception

Exception exception

类 java.security.Provider 继承 Properties 实现 Serializable

serialVersionUID: -4298000515446427739L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException
序列化字段

name

String name
provider 名称

info

String info
provider 及其服务的描述。

version

double version
provider 版本号。

类 java.security.ProviderException 继承 RuntimeException 实现 Serializable

serialVersionUID: 5256023526693665674L

类 java.security.SecureRandom 继承 Random 实现 Serializable

serialVersionUID: 4940670005562187L

序列化字段

provider

Provider provider
提供者。

从以下版本开始：
1.2

secureRandomSpi

SecureRandomSpi secureRandomSpi
提供者实现。

从以下版本开始：
1.2

algorithm

String algorithm

state

byte[] state

digest

MessageDigest digest

randomBytes

byte[] randomBytes
我们知道，MessageDigest 类不实现 java.io.Serializable。但由于不再使用此字段，所以它始终为 NULL，不会影响 SecureRandom 类本身的序列化。

randomBytesUsed

int randomBytesUsed

counter

long counter

类 java.security.SecureRandomSpi 继承 Object 实现 Serializable

serialVersionUID: -2991854161009191830L

类 java.security.SecurityPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 5236109936224050470L

类 java.security.SignatureException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 7509989324975124438L

类 java.security.SignedObject 继承 Object 实现 Serializable

serialVersionUID: 720502720485447167L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject，从流中恢复 SignedObject 的状态。

抛出：
IOException
ClassNotFoundException
序列化字段

content

byte[] content

signature

byte[] signature

thealgorithm

String thealgorithm

类 java.security.Signer 继承 Identity 实现 Serializable

serialVersionUID: -1763464102261361480L

序列化字段

privateKey

PrivateKey privateKey
已过时。
signer 的私钥。

类 java.security.Timestamp 继承 Object 实现 Serializable

serialVersionUID: -5502683707821851294L

序列化字段

timestamp

Date timestamp
时间戳的日期和时间

signerCertPath

CertPath signerCertPath
TSA 的证书路径。

类 java.security.UnrecoverableEntryException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -4527142945246286535L

类 java.security.UnrecoverableKeyException 继承 UnrecoverableEntryException 实现 Serializable

serialVersionUID: 7275063078190151277L

类 java.security.UnresolvedPermission 继承 Permission 实现 Serializable

serialVersionUID: -4821973115467008846L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
从流还原此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写入流中（也就是将其序列化）。

序列数据：
初始 String（表示 type）后跟一个 String（表示 name），其后又跟一个 String（表示 actions），它后面又跟一个 int，指示要使用的证书数量；如果该值为“零”，则表示没有与此对象相关的证书。每个证书的编写都从一个表示证书类型的 String 开始，其后是 int，用来指定证书编码的长度，再向后是以 byte 数组形式写出的证书编码本身。
抛出：
IOException
序列化字段

type

String type
解析此未解析的权限时将创建 Permission 类的类名称。

name

String name
权限名称。

actions

String actions
对权限的操作。

类 java.security.UnresolvedPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: -7176153071733132400L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default field.
抛出：
IOException
序列化字段

permissions

Hashtable<K,V> permissions
A table of the UnresolvedPermissions keyed on type, value is Vector of permissions
软件包 java.security.acl

类 java.security.acl.AclNotFoundException 继承 Exception 实现 Serializable

serialVersionUID: 5684295034092681791L

类 java.security.acl.LastOwnerException 继承 Exception 实现 Serializable

serialVersionUID: -5141997548211140359L

类 java.security.acl.NotOwnerException 继承 Exception 实现 Serializable

serialVersionUID: -5555597911163362399L

软件包 java.security.cert

类 java.security.cert.Certificate 继承 Object 实现 Serializable

serialVersionUID: -3585440601605666277L

序列化方法

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
替换要被序列化的 Certificate。

抛出：
ObjectStreamException - 如果新对象表示无法创建此 Certificate
从以下版本开始：
1.3
序列化字段

type

String type

类 java.security.cert.Certificate.CertificateRep 继承 Object 实现 Serializable

serialVersionUID: -8563758940495660020L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析该 Certificate 对象。

抛出：
ObjectStreamException - 如果无法解析该 Certificate
序列化字段

type

String type

data

byte[] data

类 java.security.cert.CertificateEncodingException 继承 CertificateException 实现 Serializable

serialVersionUID: 6219492851589449162L

类 java.security.cert.CertificateException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 3192535253797119798L

类 java.security.cert.CertificateExpiredException 继承 CertificateException 实现 Serializable

serialVersionUID: 9071001339691533771L

类 java.security.cert.CertificateNotYetValidException 继承 CertificateException 实现 Serializable

serialVersionUID: 4355919900041064702L

类 java.security.cert.CertificateParsingException 继承 CertificateException 实现 Serializable

serialVersionUID: -7989222416793322029L

类 java.security.cert.CertPath 继承 Object 实现 Serializable

serialVersionUID: 6068470306649138683L

序列化方法

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
使用 CertPathRep 对象替换要被序列化的 CertPath。

抛出：
ObjectStreamException - 如果不能创建表示此证书路径的 CertPathRep 对象
序列化字段

type

String type

类 java.security.cert.CertPath.CertPathRep 继承 Object 实现 Serializable

serialVersionUID: 3015633072427920915L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
返回根据类型和数据所构造的 CertPath。

抛出：
ObjectStreamException - 如果无法构造 CertPath
序列化字段

type

String type
Certificate 类型。

data

byte[] data
CertPath 的编码形式。

类 java.security.cert.CertPathBuilderException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 5316471420178794402L

类 java.security.cert.CertPathValidatorException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -3083180014971893139L

序列化字段

index

int index
导致该异常抛出的证书在证书路径中的索引

certPath

CertPath certPath
异常抛出时所验证的 CertPath

类 java.security.cert.CertStoreException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 2395296107471573245L

类 java.security.cert.CRLException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -6694728944094197147L

类 java.security.cert.X509Certificate 继承 Certificate 实现 Serializable

serialVersionUID: -2491127588187038216L

软件包 java.security.interfaces
软件包 java.security.spec

类 java.security.spec.InvalidKeySpecException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: 3546139293998810778L

类 java.security.spec.InvalidParameterSpecException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -970468769593399342L

软件包 java.sql

类 java.sql.BatchUpdateException 继承 SQLException 实现 Serializable

serialVersionUID: 5977529877145521757L

序列化字段

updateCounts

int[] updateCounts
描述批处理执行结果的数组。

从以下版本开始：
1.2

类 java.sql.ClientInfoException 继承 SQLException 实现 Serializable

序列化字段

failedProperties

Properties failedProperties

类 java.sql.DataTruncation 继承 SQLWarning 实现 Serializable

serialVersionUID: 6464298989504059473L

序列化字段

index

int index

parameter

boolean parameter

read

boolean read

dataSize

int dataSize

transferSize

int transferSize

类 java.sql.Date 继承 Date 实现 Serializable

serialVersionUID: 1511598038487230103L

类 java.sql.SQLClientInfoException 继承 SQLException 实现 Serializable

serialVersionUID: -4319604256824655880L

序列化字段

failedProperties

Map<K,V> failedProperties

类 java.sql.SQLDataException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -6889123282670549800L

类 java.sql.SQLDataSetSyncException 继承 java.sql.SQLRuntimeException 实现 Serializable

序列化字段

ds

java.sql.DataSetResolver<T> ds

类 java.sql.SQLException 继承 Exception 实现 Serializable

serialVersionUID: 2135244094396331484L

序列化字段

SQLState

String SQLState

vendorCode

int vendorCode

next

SQLException next

类 java.sql.SQLFeatureNotSupportedException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -1026510870282316051L

类 java.sql.SQLIntegrityConstraintViolationException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: 8033405298774849169L

类 java.sql.SQLInvalidAuthorizationSpecException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -64105250450891498L

类 java.sql.SQLNonTransientConnectionException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -5852318857474782892L

类 java.sql.SQLNonTransientException 继承 SQLException 实现 Serializable

serialVersionUID: -9104382843534716547L

类 java.sql.SQLPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -1439323187199563495L

类 java.sql.SQLRecoverableException 继承 SQLException 实现 Serializable

serialVersionUID: -4144386502923131579L

类 java.sql.SQLRuntimeException 继承 RuntimeException 实现 Serializable

类 java.sql.SQLSyntaxErrorException 继承 SQLNonTransientException 实现 Serializable

serialVersionUID: -1843832610477496053L

类 java.sql.SQLTimeoutException 继承 SQLTransientException 实现 Serializable

serialVersionUID: -4487171280562520262L

类 java.sql.SQLTransactionRollbackException 继承 SQLTransientException 实现 Serializable

serialVersionUID: 5246680841170837229L

类 java.sql.SQLTransientConnectionException 继承 SQLTransientException 实现 Serializable

serialVersionUID: -2520155553543391200L

类 java.sql.SQLTransientException 继承 SQLException 实现 Serializable

serialVersionUID: -9042733978262274539L

类 java.sql.SQLWarning 继承 SQLException 实现 Serializable

serialVersionUID: 3917336774604784856L

类 java.sql.Time 继承 Date 实现 Serializable

serialVersionUID: 8397324403548013681L

类 java.sql.Timestamp 继承 Date 实现 Serializable

serialVersionUID: 2745179027874758501L

序列化字段

nanos

int nanos
软件包 java.text

类 java.text.AttributedCharacterIterator.Attribute 继承 Object 实现 Serializable

serialVersionUID: -9142742483513960612L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
解析将被反序列化为预定义常量的实例。

抛出：
InvalidObjectException
序列化字段

name

String name
属性的名称。名称主要由 readResolve 方法在反序列化一个实例时用于查找相应的预定义实例。

类 java.text.ChoiceFormat 继承 NumberFormat 实现 Serializable

serialVersionUID: 1795184449645032964L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从输入流读取一个对象后，进行简单的验证，以维护类的不变量。

抛出：
InvalidObjectException - 如果从该流读取的对象无效。
IOException
ClassNotFoundException
序列化字段

choiceLimits

double[] choiceLimits
choice 的较低边界的列表。如果正在格式化的数大于等于 choiceLimits[i] 且小于 choiceLimits[i+1]，则该格式器将返回 choiceFormats[i]。

choiceFormats

String[] choiceFormats
choice 字符串列表。如果正在格式化的数大于等于 choiceLimits[i] 且小于 choiceLimits[i+1]，则该格式器将返回 choiceFormats[i]。

类 java.text.DateFormat 继承 Format 实现 Serializable

serialVersionUID: 7218322306649953788L

序列化字段

calendar

Calendar calendar
DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。子类应将此 calendar 初始化为适合于与此 DateFormat 关联的语言环境的日历。

numberFormat

NumberFormat numberFormat
数字格式器，DateFormat 用其来格式化日期和时间中的数字。子类应将此数字格式器初始化为适合于与此 DateFormat 关联的语言环境的数字格式。

类 java.text.DateFormat.Field 继承 Format.Field 实现 Serializable

serialVersionUID: 7441350119349544720L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将反序列化的实例解析成预定义的常量。

抛出：
InvalidObjectException - 如果无法解析该常量。
序列化字段

calendarField

int calendarField
Calendar 字段。

类 java.text.DateFormatSymbols 继承 Object 实现 Serializable

serialVersionUID: -5987973545549424702L

序列化方法

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
为了确保向后兼容性，在确保 zoneStrings 字段被初始化之后写出默认可序列化数据。

抛出：
IOException
从以下版本开始：
1.6
序列化字段

eras

String[] eras
Era strings. For example: "AD" and "BC". An array of 2 strings, indexed by Calendar.BC and Calendar.AD.

months

String[] months
Month strings. For example: "January", "February", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

shortMonths

String[] shortMonths
Short month strings. For example: "Jan", "Feb", etc. An array of 13 strings (some calendars have 13 months), indexed by Calendar.JANUARY, Calendar.FEBRUARY, etc.

weekdays

String[] weekdays
Weekday strings. For example: "Sunday", "Monday", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element weekdays[0] is ignored.

shortWeekdays

String[] shortWeekdays
Short weekday strings. For example: "Sun", "Mon", etc. An array of 8 strings, indexed by Calendar.SUNDAY, Calendar.MONDAY, etc. The element shortWeekdays[0] is ignored.

ampms

String[] ampms
AM and PM strings. For example: "AM" and "PM". An array of 2 strings, indexed by Calendar.AM and Calendar.PM.

zoneStrings

String[][] zoneStrings
Localized names of time zones in this locale. This is a two-dimensional array of strings of size n by m, where m is at least 5. Each of the n rows is an entry containing the localized names for a single TimeZone. Each such row contains (with i ranging from 0..n-1):
  • zoneStrings[i][0] - time zone ID
  • zoneStrings[i][1] - long name of zone in standard time
  • zoneStrings[i][2] - short name of zone in standard time
  • zoneStrings[i][3] - long name of zone in daylight saving time
  • zoneStrings[i][4] - short name of zone in daylight saving time
The zone ID is not localized; it's one of the valid IDs of the TimeZone class that are not custom IDs. All other entries are localized names.

另请参见：
TimeZone

localPatternChars

String localPatternChars
Localized date-time pattern characters. For example, a locale may wish to use 'u' rather than 'y' to represent years in its date format pattern strings. This string must be exactly 18 characters long, with the index of the characters described by DateFormat.ERA_FIELD, DateFormat.YEAR_FIELD, etc. Thus, if the string were "Xz...", then localized patterns would use 'X' for era and 'z' for year.

locale

Locale locale
The locale which is used for initializing this DateFormatSymbols object.

从以下版本开始：
1.6

类 java.text.DecimalFormat 继承 NumberFormat 实现 Serializable

serialVersionUID: 864413376551465018L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从流中读取默认的可序列化字段，并对较旧的序列化版本执行验证和调整。该验证和调整有：
  1. 验证超类的位数计数字段是否正确地反映了在除 BigInteger 和 BigDecimal 对象之外的格式化数字上所施加的限制。这些限制存储在与较旧版本序列化兼容的超类中，而 BigInteger 和 BigDecimal 对象的限制也保存在此类中。在该超类中，如果最小或最大整数位数计数大于 DOUBLE_INTEGER_DIGITS，或者最小或最大小数位数计数大于 DOUBLE_FRACTION_DIGITS，则流数据无效并且此方法抛出 InvalidObjectException。
  2. 如果 serialVersionOnStream 小于 4，则将 roundingMode 初始化为 RoundingMode.HALF_EVEN。此字段是版本 4 的新字段。
  3. 如果 serialVersionOnStream 小于 3，则为最小和最大整数和小数位数调用具有相应超类 getter 值的 setter，以初始化此类中的各个字段。此类中的各个字段是版本 3 的新字段。
  4. 如果 serialVersionOnStream 小于 1，则指示该流是用 JDK 1.1 所编写的，初始化 useExponentialNotation 会得到 false，因为在 JDK 1.1 中没有它。
  5. 如果再次流出此对象，则可将 serialVersionOnStream 设置为最大的允许值，以使默认的序列化可以正常工作。

版本早于 2 的流没有前后缀模式变量 posPrefixPattern 等。所以将其初始化为 null，这意味着前后缀字符串将采用字面量值。这正是我们想要的，因为这对应于早于版本 2 的版本行为。

抛出：
IOException
ClassNotFoundException
序列化字段

positivePrefix

String positivePrefix
格式化正数时用作前缀的符号，例如 "+"。

另请参见：
DecimalFormat.getPositivePrefix()

positiveSuffix

String positiveSuffix
格式化正数时用作后缀的符号。这通常是一个空字符串。

另请参见：
DecimalFormat.getPositiveSuffix()

negativePrefix

String negativePrefix
格式化负数时用作前缀的符号，例如 "-"。

另请参见：
DecimalFormat.getNegativePrefix()

negativeSuffix

String negativeSuffix
格式化负数时用作后缀的符号。这通常是一个空字符串。

另请参见：
DecimalFormat.getNegativeSuffix()

posPrefixPattern

String posPrefixPattern
非负数的前缀模式。此变量对应于 positivePrefix。

此模式由方法 expandAffix() 对 positivePrefix 进行扩展得到，以更新后者从而反映 symbols 中的改变。如果此变量为 null，则将 positivePrefix 用作字面量值，在 symbols 改变时不改变该值。对于从早于流版本 2 的流中恢复的 DecimalFormat 对象而言，此变量始终为 null。

从以下版本开始：
1.3

posSuffixPattern

String posSuffixPattern
非负数的后缀模式。此变量对应于 positiveSuffix。此变量类似于 posPrefixPattern；有关进一步的内容，请参见该变量。

从以下版本开始：
1.3

negPrefixPattern

String negPrefixPattern
负数的前缀模式。此变量对应于 negativePrefix。此变量类似于 posPrefixPattern；有关进一步的内容，请参见该变量。

从以下版本开始：
1.3

negSuffixPattern

String negSuffixPattern
负数的后缀模式。此变量对应于 negativeSuffix。此变量类似于 posPrefixPattern；有关进一步的内容，请参见该变量。

从以下版本开始：
1.3

multiplier

int multiplier
百分数、千分数等使用的乘数。

另请参见：
DecimalFormat.getMultiplier()

groupingSize

byte groupingSize
数的整数部分中分组分隔符之间的数字位数。如果 NumberFormat.groupingUsed 为 true，则该值必须大于 0。

另请参见：
DecimalFormat.getGroupingSize(), NumberFormat.isGroupingUsed()

decimalSeparatorAlwaysShown

boolean decimalSeparatorAlwaysShown
如果为 true，则强制小数分隔符总是出现在已格式化的数中，即使数的小数部分为零也是如此。

另请参见：
DecimalFormat.isDecimalSeparatorAlwaysShown()

parseBigDecimal

boolean parseBigDecimal
如果为 true，则只要有可能，解析就返回 BigDecimal。

从以下版本开始：
1.5
另请参见：
DecimalFormat.isParseBigDecimal()

symbols

DecimalFormatSymbols symbols
此格式使用的 DecimalFormatSymbols 对象。它包含用于格式化数的符号，例如分组分隔符、小数分隔符等等。

另请参见：
DecimalFormat.setDecimalFormatSymbols(java.text.DecimalFormatSymbols), DecimalFormatSymbols

useExponentialNotation

boolean useExponentialNotation
如果为 True，则在格式化数时强制使用指数（也就是科学）计数法。

从以下版本开始：
1.2

minExponentDigits

byte minExponentDigits
以科学计数法格式化数时，用于显示指数的最小数字位数。如果 useExponentialNotation 不为 true，则忽略此字段。

从以下版本开始：
1.2

maximumIntegerDigits

int maximumIntegerDigits
BigInteger 或 BigDecimal 的整数部分中所允许的最大数字位数。maximumIntegerDigits 必须大于等于 minimumIntegerDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMaximumIntegerDigits()

minimumIntegerDigits

int minimumIntegerDigits
BigInteger 或 BigDecimal 的整数部分中所允许的最小数字位数。minimumIntegerDigits 必须小于等于 maximumIntegerDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMinimumIntegerDigits()

maximumFractionDigits

int maximumFractionDigits
BigInteger 或 BigDecimal 的小数部分中所允许的最大数字位数。maximumFractionDigits 必须大于等于 minimumFractionDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMaximumFractionDigits()

minimumFractionDigits

int minimumFractionDigits
BigInteger 或 BigDecimal 的小数部分中所允许的最小数字位数。minimumFractionDigits 必须小于等于 maximumFractionDigits。

从以下版本开始：
1.5
另请参见：
DecimalFormat.getMinimumFractionDigits()

roundingMode

RoundingMode roundingMode
在此 DecimalFormat 中使用的 RoundingMode。

从以下版本开始：
1.6

serialVersionOnStream

int serialVersionOnStream
声明写入何种版本的内部系列版本。可能的值为：
  • 0（默认值）：Java 2 平台 v1.2 之前的版本
  • 1：1.2 版本，包括两个新字段 useExponentialNotation 和 minExponentDigits。
  • 2：1.3 和以后版本，添加了四个新字段：posPrefixPattern、posSuffixPattern、negPrefixPattern 和 negSuffixPattern。
  • 3：1.5 和以后版本，添加了五个新字段：maximumIntegerDigits、minimumIntegerDigits、maximumFractionDigits、minimumFractionDigits 和 parseBigDecimal。
  • 4：1.6 和以后版本，添加了一个新字段：roundingMode。

从以下版本开始：
1.2

类 java.text.DecimalFormatSymbols 继承 Object 实现 Serializable

serialVersionUID: 5772796243397350300L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
读取默认的可序列化字段、为较旧系列版本的对象提供默认值，并对不可序列化的字段进行初始化。如果 serialVersionOnStream 小于 1，则将 monetarySeparator 初始化为与 decimalSeparator 相同，并将 exponential 初始化为 'E'。如果 serialVersionOnStream 小于 2，则将 locale 初始化为根语言环境。如果 serialVersionOnStream 小于 3，则它使用 exponential 初始化 exponentialSeparator。如果再次流出此对象，则可将 serialVersionOnStream 设置回最大的允许值，以使默认的序列化可以正常工作。根据 intlCurrencySymbol 字段来初始化货币。

抛出：
IOException
ClassNotFoundException
从以下版本开始：
JDK 1.1.6
序列化字段

zeroDigit

char zeroDigit
用于零的字符。

另请参见：
DecimalFormatSymbols.getZeroDigit()

groupingSeparator

char groupingSeparator
用于千位分隔符的字符。

另请参见：
DecimalFormatSymbols.getGroupingSeparator()

decimalSeparator

char decimalSeparator
用于十进制符号的字符。

另请参见：
DecimalFormatSymbols.getDecimalSeparator()

perMill

char perMill
用于千分数符号的字符。

另请参见：
DecimalFormatSymbols.getPerMill()

percent

char percent
用于百分数符号的字符。

另请参见：
DecimalFormatSymbols.getPercent()

digit

char digit
用于某种模式中数字的字符。

另请参见：
DecimalFormatSymbols.getDigit()

patternSeparator

char patternSeparator
用于在模式中分隔正数和负数子模式的字符。

另请参见：
DecimalFormatSymbols.getPatternSeparator()

infinity

String infinity
用于表示无穷大的字符串。

另请参见：
DecimalFormatSymbols.getInfinity()

NaN

String NaN
用于表示“非数字”的字符串。

另请参见：
DecimalFormatSymbols.getNaN()

minusSign

char minusSign
用于表示减号的字符。

另请参见：
DecimalFormatSymbols.getMinusSign()

currencySymbol

String currencySymbol
表示本地货币的字符串，如 "$"。

另请参见：
DecimalFormatSymbols.getCurrencySymbol()

intlCurrencySymbol

String intlCurrencySymbol
表示本地货币的 ISO 4217 货币代码，如 "USD"。

另请参见：
DecimalFormatSymbols.getInternationalCurrencySymbol()

monetarySeparator

char monetarySeparator
格式化货币值时使用的小数点。

从以下版本开始：
JDK 1.1.6
另请参见：
DecimalFormatSymbols.getMonetaryDecimalSeparator()

exponential

char exponential
用于以指数计数法格式化数字时，区分数字中指数的字符，例如像数字 "1.23E45" 中的 'E'。

注意，公共的 API 没有提供设置此字段的方法，即使实现和流格式支持该设置也是如此。在以后会将该功能添加到 API 中。

从以下版本开始：
JDK 1.1.6

exponentialSeparator

String exponentialSeparator
用于分隔尾数和指数的字符串。示例：1.23x10^4 中的 "x10^"，1.23E4 中的 "E"。

如果 exponential 和 exponentialSeparator 都存在，则优先使用此 exponentialSeparator。

从以下版本开始：
1.6

locale

Locale locale
这些货币格式符号的语言环境。

从以下版本开始：
1.4

serialVersionOnStream

int serialVersionOnStream
描述流中存在的 DecimalFormatSymbols 的版本。可能的值为：
  • 0（或未初始化的）：JDK 1.1.6 之前的版本。
  • 1：使用 JDK 1.1.6 或更高版本所编写，包括两个新字段：monetarySeparator 和 exponential。
  • 2：使用 J2SE 1.4 或更高版本所编写，包括新的 locale 字段。
  • 3: 使用 J2SE 1.6 或更高版本所编写，包括新的 exponentialSeparator 字段。
流出 DecimalFormatSymbols 时，总是写入最新的格式（对应于允许的最高 serialVersionOnStream）。

从以下版本开始：
JDK 1.1.6

类 java.text.Format 继承 Object 实现 Serializable

serialVersionUID: -299282585814624189L

类 java.text.Format.Field 继承 AttributedCharacterIterator.Attribute 实现 Serializable

serialVersionUID: 276966692217360283L

类 java.text.MessageFormat 继承 Format 实现 Serializable

serialVersionUID: 6479157306784022952L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从输入流中读取一个对象后，进行简单的验证以维护类常量。

抛出：
InvalidObjectException - 如果从流读入的对象无效。
IOException
ClassNotFoundException
序列化字段

locale

Locale locale
用于格式化数字和日期的语言环境。

pattern

String pattern
要插入格式化后的值的字符串。换句话说，这是对所有取出的 {} 表达式进行构造所提供的方法。

formats

Format[] formats
格式器数组，它们用于对参数进行格式化。

offsets

int[] offsets
每个参数格式化结果要插入到模式中的位置。

argumentNumbers

int[] argumentNumbers
对应于每个格式器的参数个数。（格式器按照它们在模式中出现的顺序进行存储，而不是按照参数被指定的顺序）。

maxOffset

int maxOffset
比 offsets 中的条目数少 1。也可以看作正被使用的 offsets 中的最高数字的元素的索引。所有这些数组必须具有与 offsets 相同个数的元素，因此该变量能够告知我们数组中有多少个条目。

类 java.text.MessageFormat.Field 继承 Format.Field 实现 Serializable

serialVersionUID: 7899943957617360810L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
把正被反序列化的实例解析为预定义的常量。

抛出：
InvalidObjectException - 如果常量无法解析。

类 java.text.NumberFormat 继承 Format 实现 Serializable

serialVersionUID: -2308460125733713944L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
首先，读取默认的序列化数据。 然后，如果 serialVersionOnStream 小于 1，指示流是用 JDK 1.1 编写的，则设置 int 字段（例如 maximumIntegerDigits）等于 byte 字段（例如 maxIntegerDigits），因为 int 字段在 JDK 1.1 中不存在。最后，将 serialVersionOnStream 重新设置为允许的最大值，这样如果此对象再次流出时，默认的序列化可以正常工作。

如果 minimumIntegerDigits 大于 maximumIntegerDigits，或者 minimumFractionDigits 大于 maximumFractionDigits，则流数据无效且此方法抛出 InvalidObjectException。此外，如果这些值中的任何一个是负数，则此方法抛出 InvalidObjectException。

抛出：
IOException
ClassNotFoundException
从以下版本开始：
1.2

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
为了与流格式的 JDK 1.1 版本保持兼容，首先设置 byte 字段（例如 maxIntegerDigits）等于 int 字段（例如 maximumIntegerDigits）（或者等于 Byte.MAX_VALUE，取决于二者中那个值更小），然后写出默认的序列化数据。

抛出：
IOException
从以下版本开始：
1.2
序列化字段

groupingUsed

boolean groupingUsed
如果格式化和解析数值时使用了组（即千位）分隔符，则返回 true。

另请参见：
NumberFormat.isGroupingUsed()

maxIntegerDigits

byte maxIntegerDigits
数值的整数部分允许的最大位数。maxIntegerDigits 必须大于等于 minIntegerDigits。

注：此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用 int 字段 maximumIntegerDigits 来替代。当写入一个流时，maxIntegerDigits 被设置为 maximumIntegerDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMaximumIntegerDigits()

minIntegerDigits

byte minIntegerDigits
数的整数部分允许的最小位数，minimumIntegerDigits 必须小于等于 maximumIntegerDigits。

注：此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用新的 int 字段 minimumIntegerDigits 来替代。当写入一个流时，minIntegerDigits 被设置为 minimumIntegerDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMinimumIntegerDigits()

maxFractionDigits

byte maxFractionDigits
数的小数部分允许的最大位数，maximumFractionDigits 必须大于等于 minimumFractionDigits。

注： 此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用新的 int 字段 maximumFractionDigits 来替代。当写入一个流时，maxFractionDigits 被设置为 maximumFractionDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMaximumFractionDigits()

minFractionDigits

byte minFractionDigits
数的小数部分允许的最小位数。minimumFractionDigits 必须小于等于 maximumFractionDigits。

注：此字段仅在与 JDK 1.1 兼容的序列化中存在。在 Java 2 平台 的 v1.2 和更高版本中，用新的 int field minimumFractionDigits 来替代。当写入一个流时，minFractionDigits 被设置为 minimumFractionDigits 或 Byte.MAX_VALUE 中较小的一个。当从一个流读取时，仅当 serialVersionOnStream 小于 1 时使用此字段。

另请参见：
NumberFormat.getMinimumFractionDigits()

parseIntegerOnly

boolean parseIntegerOnly
如果此格式仅将数作为整数解析，则返回 true。

另请参见：
NumberFormat.isParseIntegerOnly()

maximumIntegerDigits

int maximumIntegerDigits
数的整数部分允许的最大位数。maximumIntegerDigits 必须大于等于 minimumIntegerDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMaximumIntegerDigits()

minimumIntegerDigits

int minimumIntegerDigits
数的整数部分允许的最小位数。minimumIntegerDigits 必须小于等于 maximumIntegerDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMinimumIntegerDigits()

maximumFractionDigits

int maximumFractionDigits
数的小数部分允许的最大位数。maximumFractionDigits 必须大于等于 minimumFractionDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMaximumFractionDigits()

minimumFractionDigits

int minimumFractionDigits
数的小数部分允许的最小位数。minimumFractionDigits 必须小于等于 maximumFractionDigits。

从以下版本开始：
1.2
另请参见：
NumberFormat.getMinimumFractionDigits()

serialVersionOnStream

int serialVersionOnStream
描述了流上存在的 NumberFormat 的版本。可能的值为：
  • 0（或未初始化）：流格式的 JDK 1.1 版本。在此版本中，诸如 maximumIntegerDigits 之类的 int 字段不存在，而使用如 maxIntegerDigits 这样的 byte 字段来替代。
  • 1：流格式的 1.2 版本。诸如 maxIntegerDigits 之类的 byte 字段的值被忽略，而使用如 maximumIntegerDigits 这样的 int 字段来替代。
当流出 NumberFormat 时，总是写入最近的格式（对应于允许的最高 serialVersionOnStream）。

从以下版本开始：
1.2

类 java.text.NumberFormat.Field 继承 Format.Field 实现 Serializable

serialVersionUID: 7494728892700160890L

序列化方法

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将正被反序列化的实例解析为预定义的常量。

抛出：
InvalidObjectException - 如果无法解析常量。

类 java.text.ParseException 继承 Exception 实现 Serializable

序列化字段

errorOffset

int errorOffset
从零开始的字符偏移量，在解析过程中，在字符串中的此处发现错误。

类 java.text.SimpleDateFormat 继承 DateFormat 实现 Serializable

serialVersionUID: 4774881970558875024L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
在从输入流中读取对象后，验证对象中的格式模式。

抛出：
InvalidObjectException - 如果模式无效
IOException
ClassNotFoundException
序列化字段

serialVersionOnStream

int serialVersionOnStream
流上序列化数据的版本。可能的值：
  • 0 或者不出现在流上：JDK 1.1.3。此版本在流上没有 defaultCenturyStart。
  • 1 JDK 1.1.4 或更高版本。此版本增加了 defaultCenturyStart。
在流出此类时，编写最新格式和所允许的最高 serialVersionOnStream。

从以下版本开始：
JDK1.1.4

pattern

String pattern
此格式器的模式字符串。这始终是一个非本地化的模式。不能为 null。有关详细信息，请参阅类文档。

formatData

DateFormatSymbols formatData
此格式器为周名称、月名称等使用的符号。不能为 null。

另请参见：
DateFormatSymbols

defaultCenturyStart

Date defaultCenturyStart
我们将两位数字的年份日期映射到从 defaultCenturyStart 开始的世纪（可以为任何日期）。不能为 null。

从以下版本开始：
JDK1.1.4

locale

Locale locale
用于实例化此 SimpleDateFormat 的 Locale。如果此对象已由旧的 SimpleDateFormat 创建并且进行了反序列化，则值可以为 null。

从以下版本开始：
1.6
软件包 java.util

类 java.util.AbstractMap.SimpleEntry 继承 Object 实现 Serializable

serialVersionUID: -8499721149061103585L

序列化字段

key

Object key

value

Object value

类 java.util.AbstractMap.SimpleImmutableEntry 继承 Object 实现 Serializable

serialVersionUID: 7138329143949025153L

序列化字段

key

Object key

value

Object value

类 java.util.ArrayDeque 继承 AbstractCollection<E> 实现 Serializable

serialVersionUID: 2340985798034038923L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
将此双端队列反序列化。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此双端队列序列化。

序列数据：
双端队列的当前大小 (int)，按从前到后的顺序紧跟其所有元素（一个对象引用一个）。
抛出：
IOException

类 java.util.ArrayList 继承 AbstractList<E> 实现 Serializable

serialVersionUID: 8683452581122892189L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 ArrayList 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 ArrayList 实例的状态保存到流中（也就是将其序列化）。

序列数据：
支持发出 ArrayList 实例的数组的长度 (int)，后面是按适当顺序排列的所有元素（每个元素都是一个 Object）。
抛出：
IOException
序列化字段

size

int size
ArrayList 的大小（它包含的元素数）。

类 java.util.Arrays.ArrayList 继承 AbstractList<E> 实现 Serializable

serialVersionUID: -2764017481108945198L

序列化字段

a

Object[] a

类 java.util.BitSet 继承 Object 实现 Serializable

serialVersionUID: 7997698588986878753L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重建 BitSet 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 BitSet 实例保存到流中（也就是将其序列化）。

抛出：
IOException
序列化字段

bits

long[] bits
此 BitSet 中的位。第 i 个位存储在数位位置为 i % 64 的 bits[i/64]中（其中数位位置 0 表示最低有效位，数位位置 63 表示最高有效位）。

类 java.util.Calendar 继承 Object 实现 Serializable

serialVersionUID: -1807547505821590642L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从流重构此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
将此对象的状态保存到流中（也就是将其序列化）。 理想情况下，Calendar 将只写出其状态数据和当前时间，并且不会写出任何字段数据，比如 fields[]、isTimeSet、areFieldsSet 和 isSet[]。nextStamp 不应该是持久存储状态的一部分。不幸的是，在发行 JDK 1.1 之前，事情并非如此。为了与 JDK 1.1 兼容，必须总是写出字段值和状态标志。不过，可以从序列化流中移除 nextStamp；可能在以后会实现。

抛出：
IOException
序列化字段

fields

int[] fields
此日历当前设置时间的日历字段值。这是一个 FIELD_COUNT 整数数组，索引值为 ERA 到 DST_OFFSET。

isSet

boolean[] isSet
通知是否设置了该日历某一指定日历字段的标志。新的对象没有设置任何字段。在第一次调用生成该字段的某一方法后，这些字段都将保留调用之后的设置。这是一个 FIELD_COUNT 布尔值数组，索引值为 ERA 到 DST_OFFSET。

time

long time
日历的当前设置时间，以毫秒为单位，表示自格林威治标准时间 1970 年 1月 1 日 0:00:00 后经过的时间。

另请参见：
Calendar.isTimeSet

isTimeSet

boolean isTimeSet
如果 time 值是一个有效值，则返回 true。通过更改 field[] 的项，可以使时间无效。

另请参见：
Calendar.time

areFieldsSet

boolean areFieldsSet
如果 fields[] 与当前的设置时间同步，则返回 true。如果返回 false，则在下一次试图获得某一字段的值时，将强行重新计算 time 当前值中的所有字段。

lenient

boolean lenient
如果此日历允许在计算 fields[] 中的 time 时使用超出范围的字段值，则返回 True。

另请参见：
Calendar.setLenient(boolean), Calendar.isLenient()

zone

TimeZone zone
此日历使用的 TimeZone。Calendar 使用时区数据来实现语言环境与 GMT 时间的转换。

firstDayOfWeek

int firstDayOfWeek
一星期中的第一天，可能的值是 SUNDAY、MONDAY，等等。这是一个同语言环境有关的值。

minimalDaysInFirstWeek

int minimalDaysInFirstWeek
一月或一年中第一个星期所需的天数，可能的值是从 1 到 7。这是一个同语言环境有关的值。

nextStamp

int nextStamp
stamp[]（一个内部数组）的下一个可用值。实际上不应该将该方法写出到流中，在以后，可能从流中将其移除。同时，应该使用 MINIMUM_USER_STAMP 值。

serialVersionOnStream

int serialVersionOnStream
流中序列化数据的版本。可能的值是：
0 或流中不存在该数据
JDK 1.1.5 或更早的版本。
1
JDK 1.1.6 或更高的版本。为其他字段编写一个正确的 'time' 值以及兼容的值。这是一种过渡格式。
在流出此类时，编写最新格式和所允许的最高 serialVersionOnStream。

从以下版本开始：
JDK1.1.6

类 java.util.Collections.CheckedCollection 继承 Object 实现 Serializable

serialVersionUID: 1578914078182001775L

序列化字段

c

Collection<E> c

type

Class<T> type

zeroLengthElementArray

Object[] zeroLengthElementArray

类 java.util.Collections.CheckedList 继承 java.util.Collections.CheckedCollection<E> 实现 Serializable

serialVersionUID: 65247728283967356L

序列化字段

list

List<E> list

类 java.util.Collections.CheckedMap 继承 Object 实现 Serializable

serialVersionUID: 5742860141034234728L

序列化字段

m

Map<K,V> m

keyType

Class<T> keyType

valueType

Class<T> valueType

zeroLengthKeyArray

Object[] zeroLengthKeyArray

zeroLengthValueArray

Object[] zeroLengthValueArray

类 java.util.Collections.CheckedRandomAccessList 继承 java.util.Collections.CheckedList<E> 实现 Serializable

serialVersionUID: 1638200125423088369L

类 java.util.Collections.CheckedSet 继承 java.util.Collections.CheckedCollection<E> 实现 Serializable

serialVersionUID: 4694047833775013803L

类 java.util.Collections.CheckedSortedMap 继承 java.util.Collections.CheckedMap<K,V> 实现 Serializable

serialVersionUID: 1599671320688067438L

序列化字段

sm

SortedMap<K,V> sm

类 java.util.Collections.CheckedSortedSet 继承 java.util.Collections.CheckedSet<E> 实现 Serializable

serialVersionUID: 1599911165492914959L

序列化字段

ss

SortedSet<E> ss

类 java.util.Collections.CopiesList 继承 AbstractList<E> 实现 Serializable

serialVersionUID: 2739099268398711800L

序列化字段

n

int n

element

Object element

类 java.util.Collections.EmptyList 继承 AbstractList<Object> 实现 Serializable

serialVersionUID: 8842843931221139166L

序列化方法

readResolve

private Object readResolve()

类 java.util.Collections.EmptySet 继承 AbstractSet<Object> 实现 Serializable

serialVersionUID: 1582296315990362920L

序列化方法

readResolve

private Object readResolve()

类 java.util.Collections.ReverseComparator 继承 Object 实现 Serializable

serialVersionUID: 7207038068494060240L

序列化方法

readResolve

private Object readResolve()

类 java.util.Collections.ReverseComparator2 继承 Object 实现 Serializable

serialVersionUID: 4374092139857L

序列化字段

cmp

Comparator<T> cmp
The comparator specified in the static factory. This will never be null, as the static factory returns a ReverseComparator instance if its argument is null.

类 java.util.Collections.SingletonSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: 3193687207550431679L

序列化字段

element

Object element

类 java.util.Collections.SynchronizedCollection 继承 Object 实现 Serializable

serialVersionUID: 3053995032091335093L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException
序列化字段

c

Collection<E> c

mutex

Object mutex

类 java.util.Collections.SynchronizedList 继承 java.util.Collections.SynchronizedCollection<E> 实现 Serializable

serialVersionUID: -7754090372962971524L

序列化方法

readResolve

private Object readResolve()
SynchronizedRandomAccessList instances are serialized as SynchronizedList instances to allow them to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto SynchronizedList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, SynchronizedRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become SynchronizedList instances, as this method was missing in 1.4.

序列化字段

list

List<E> list

类 java.util.Collections.SynchronizedMap 继承 Object 实现 Serializable

serialVersionUID: 1978198479659022715L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException
序列化字段

m

Map<K,V> m

mutex

Object mutex

类 java.util.Collections.SynchronizedRandomAccessList 继承 java.util.Collections.SynchronizedList<E> 实现 Serializable

serialVersionUID: 1530674583602358482L

序列化方法

writeReplace

private Object writeReplace()
Allows instances to be deserialized in pre-1.4 JREs (which do not have SynchronizedRandomAccessList). SynchronizedList has a readResolve method that inverts this transformation upon deserialization.

类 java.util.Collections.SynchronizedSet 继承 java.util.Collections.SynchronizedCollection<E> 实现 Serializable

serialVersionUID: 487447009682186044L

类 java.util.Collections.SynchronizedSortedMap 继承 java.util.Collections.SynchronizedMap<K,V> 实现 Serializable

serialVersionUID: -8798146769416483793L

序列化字段

sm

SortedMap<K,V> sm

类 java.util.Collections.SynchronizedSortedSet 继承 java.util.Collections.SynchronizedSet<E> 实现 Serializable

serialVersionUID: 8695801310862127406L

序列化字段

ss

SortedSet<E> ss

类 java.util.Collections.UnmodifiableCollection 继承 Object 实现 Serializable

serialVersionUID: 1820017752578914078L

序列化字段

c

Collection<E> c

类 java.util.Collections.UnmodifiableList 继承 java.util.Collections.UnmodifiableCollection<E> 实现 Serializable

serialVersionUID: -283967356065247728L

序列化方法

readResolve

private Object readResolve()
UnmodifiableRandomAccessList instances are serialized as UnmodifiableList instances to allow them to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). This method inverts the transformation. As a beneficial side-effect, it also grafts the RandomAccess marker onto UnmodifiableList instances that were serialized in pre-1.4 JREs. Note: Unfortunately, UnmodifiableRandomAccessList instances serialized in 1.4.1 and deserialized in 1.4 will become UnmodifiableList instances, as this method was missing in 1.4.

序列化字段

list

List<E> list

类 java.util.Collections.UnmodifiableMap 继承 Object 实现 Serializable

serialVersionUID: -1034234728574286014L

序列化字段

m

Map<K,V> m

类 java.util.Collections.UnmodifiableMap.UnmodifiableEntrySet 继承 java.util.Collections.UnmodifiableSet<Map.Entry<K,V>> 实现 Serializable

serialVersionUID: 7854390611657943733L

类 java.util.Collections.UnmodifiableRandomAccessList 继承 java.util.Collections.UnmodifiableList<E> 实现 Serializable

serialVersionUID: -2542308836966382001L

序列化方法

writeReplace

private Object writeReplace()
Allows instances to be deserialized in pre-1.4 JREs (which do not have UnmodifiableRandomAccessList). UnmodifiableList has a readResolve method that inverts this transformation upon deserialization.

类 java.util.Collections.UnmodifiableSet 继承 java.util.Collections.UnmodifiableCollection<E> 实现 Serializable

serialVersionUID: -9215047833775013803L

类 java.util.Collections.UnmodifiableSortedMap 继承 java.util.Collections.UnmodifiableMap<K,V> 实现 Serializable

serialVersionUID: -8806743815996713206L

序列化字段

sm

SortedMap<K,V> sm

类 java.util.Collections.UnmodifiableSortedSet 继承 java.util.Collections.UnmodifiableSet<E> 实现 Serializable

serialVersionUID: -4929149591599911165L

序列化字段

ss

SortedSet<E> ss

类 java.util.ConcurrentModificationException 继承 RuntimeException 实现 Serializable

类 java.util.Currency 继承 Object 实现 Serializable

serialVersionUID: -158308464356906721L

序列化方法

readResolve

private Object readResolve()
把正被反序列化的实例解析为每种货币的单个实例。

序列化字段

currencyCode

String currencyCode
此货币的 ISO 4217 货币代码。

类 java.util.Date 继承 Object 实现 Serializable

serialVersionUID: 7523967970034938905L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此对象的状态保存到流中（也就是将其序列化）。

序列数据：
发出由 getTime() 返回的值 (long)。它表示自 1970 年 1 月 1 日 00:00:00 GMT 的偏移量（以毫秒为单位）。
抛出：
IOException

类 java.util.DuplicateFormatFlagsException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 18890531L

序列化字段

flags

String flags

类 java.util.EmptyStackException 继承 RuntimeException 实现 Serializable

类 java.util.EnumMap 继承 AbstractMap<K extends Enum<K>,V> 实现 Serializable

serialVersionUID: 458661240069192865L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重新构造来自流的 EnumMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 EnumMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出枚举映射的 size（键-值映射关系数），后跟由枚举映射表示的每个键-值映射关系的键 (Object) 和值 (Object)。
抛出：
IOException
序列化字段

keyType

Class<T> keyType
此映射所有键的枚举类型的 Class 对象。

类 java.util.EnumSet.SerializationProxy 继承 Object 实现 Serializable

serialVersionUID: 362491234563181265L

序列化方法

readResolve

private Object readResolve()
序列化字段

elementType

Class<T> elementType
The element type of this enum set.

elements

Enum<E extends Enum<E>>[] elements
The elements contained in this enum set.

类 java.util.EventObject 继承 Object 实现 Serializable

serialVersionUID: 5516075349620653480L

类 java.util.FormatFlagsConversionMismatchException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19120414L

序列化字段

f

String f

c

char c

类 java.util.FormatterClosedException 继承 IllegalStateException 实现 Serializable

serialVersionUID: 18111216L

类 java.util.GregorianCalendar 继承 Calendar 实现 Serializable

serialVersionUID: -8125100834729963327L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
更新内部状态。

抛出：
IOException
ClassNotFoundException
序列化字段

gregorianCutover

long gregorianCutover
格里高利历规则的使用点，从标准新纪元开始以毫秒为单位来测量。默认时间 1582 年 10 月 15 日（格里高利历）00:00:00 UTC 或 -12219292800000L。对此默认值，1582 年 10 月 4 日（儒略历）之后是 1582 年 10 月 15 日（格里高利历）。这对应于儒略历日期号 2299161。

类 java.util.HashMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 362498820763181265L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 HashMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 HashMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出 HashMap 的容量（桶数组的长度，为 int 值），后跟 size（一个 int 值，键-值映射关系数），后跟每个键-值映射关系的键 (Object) 和值 (Object)。发出的键-值映射关系没有特定顺序。
抛出：
IOException
序列化字段

threshold

int threshold
The next size value at which to resize (capacity * load factor).

loadFactor

float loadFactor
哈希表的加载因子。

类 java.util.HashSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: -5024744406713321676L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 HashSet 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 HashSet 实例的状态保存到流中（也就是将它序列化）。

序列数据：
发出底层 HashMap 实例的容量（int）及其加载因子（float），后跟 set 的大小（所包含元素的数量（int）），再后跟着它的所有元素（每个元素都是一个对象），这些元素没有按特定顺序排列。
抛出：
IOException

类 java.util.Hashtable 继承 Dictionary<K,V> 实现 Serializable

serialVersionUID: 1421746759512286392L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 Hashtable（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 Hashtable 的状态保存到流中（也就是将其序列化）。

序列数据：
发出 Hashtable 的容量（桶数组的长度（为 int）），后跟 Hashtable 的大小（键-值映射关系的数量），再后面是由 Hashtable 表示的每个键-值映射关系的键（Object）和值（Object），发出这些键-值映射关系没有按照任何特定顺序。
抛出：
IOException
序列化字段

threshold

int threshold
如果表的大小超出此阈值，则要对其执行 rehash 操作。（阈值是一个 int 值，等于容量与加载因子的乘积。）

loadFactor

float loadFactor
哈希表的加载因子。

类 java.util.IdentityHashMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 8188218128353913216L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 IdentityHashMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 IdentityHashMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
HashMap（键-值映射关系数）的大小 (int)，然后是 IdentityHashMap 所表示的每个键-值映射关系的键（对象）和值（对象）。发出的键-值映射关系没有特定顺序。
抛出：
IOException
序列化字段

size

int size
返回此标识哈希映射中的键-值映射关系数。

类 java.util.IllegalFormatCodePointException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19080630L

序列化字段

c

int c

类 java.util.IllegalFormatConversionException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 17000126L

序列化字段

c

char c

arg

Class<T> arg

类 java.util.IllegalFormatException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: 18830826L

类 java.util.IllegalFormatFlagsException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 790824L

序列化字段

flags

String flags

类 java.util.IllegalFormatPrecisionException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 18711008L

序列化字段

p

int p

类 java.util.IllegalFormatWidthException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 16660902L

序列化字段

w

int w

类 java.util.InputMismatchException 继承 NoSuchElementException 实现 Serializable

类 java.util.LinkedHashMap 继承 HashMap<K,V> 实现 Serializable

serialVersionUID: 3801124242820219131L

序列化字段

accessOrder

boolean accessOrder
此链接哈希映射的迭代排序方法：访问顺序为 true；插入顺序为 false。

类 java.util.LinkedHashSet 继承 HashSet<E> 实现 Serializable

serialVersionUID: -2851667679971038690L

类 java.util.LinkedList 继承 AbstractSequentialList<E> 实现 Serializable

serialVersionUID: 876323262645176354L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构此 LinkedList 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此 LinkedList 实例的状态保存到流中（也就是将其序列化）。

序列数据：
列表的大小（它所包含的元素数）(int)，然后是其按恰当顺序排列的所有元素（每个对象）。
抛出：
IOException

类 java.util.Locale 继承 Object 实现 Serializable

serialVersionUID: 9149081749638150636L

序列化方法

readResolve

private Object readResolve()
                    throws ObjectStreamException
用新创建的对象替换已反序列化的 Locale 对象。用较旧的 ISO 代码替换较新的语言代码。用内部 String 副本替换国家/地区和变量代码。

抛出：
ObjectStreamException
序列化字段

language

String language
另请参见：
Locale.getLanguage()

country

String country
另请参见：
Locale.getCountry()

variant

String variant
另请参见：
Locale.getVariant()

hashcode

int hashcode
对象的哈希码的占位符。总为 -1。

类 java.util.MissingFormatArgumentException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19190115L

序列化字段

s

String s

类 java.util.MissingFormatWidthException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 15560123L

序列化字段

s

String s

类 java.util.MissingResourceException 继承 RuntimeException 实现 Serializable

serialVersionUID: -4876345176062000401L

序列化字段

className

String className
用户所请求的资源包的类名。

key

String key
用户所请求的特定资源名。

类 java.util.NoSuchElementException 继承 RuntimeException 实现 Serializable

类 java.util.PriorityQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -7720805057305804111L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构 PriorityQueue 实例（即将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将实例的状态保存到流中（即将其序列化）。

序列数据：
底层实例数组的长度 (int)，然后是其按恰当顺序排列的所有元素（每个 Object）。
抛出：
IOException
序列化字段

size

int size
优先级队列中的元素数目。

comparator

Comparator<T> comparator
比较器，如果优先级队列使用元素的自然顺序，则为 null。

类 java.util.Properties 继承 Hashtable<Object,Object> 实现 Serializable

serialVersionUID: 4112578634029874840L

序列化字段

defaults

Properties defaults
一个属性列表，包含属性列表中所有未找到值的键的默认值。

类 java.util.PropertyPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: 7015263904581634791L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
Default fields.
抛出：
IOException
序列化字段

all_allowed

boolean all_allowed
boolean saying if "*" is in the collection.

permissions

Hashtable<K,V> permissions
A table of the PropertyPermissions.

类 java.util.Random 继承 Object 实现 Serializable

serialVersionUID: 3905348978240129619L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 Random 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 Random 实例保存到流中。

抛出：
IOException
序列化概述
Random 的可序列化字段。

序列化字段

haveNextNextGaussian

boolean haveNextNextGaussian
nextNextGaussian 是有效的

nextNextGaussian

double；要返回的下一个 nextNextGaussian
Gaussian

seed

long； seed
随机计算的种子

类 java.util.ServiceConfigurationError 继承 Error 实现 Serializable

serialVersionUID: 74132770414881L

类 java.util.SimpleTimeZone 继承 TimeZone 实现 Serializable

serialVersionUID: -403250971215465050L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
从流重构此对象（也就是将其反序列化）。 我们同时处理 JDK 1.1 二进制格式和具有打包字节数组的完全格式。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
将此对象的状态保存到流中（也就是将其序列化）。

序列数据：
我们编写了两种格式，JDK 1.1 兼容格式，它使用 DOW_IN_MONTH_MODE 规则，在必需部分中后跟完全规则，在可选部分中则使用打包格式。在流入时 JDK 1.1 代码将忽略可选部分。

可选部分的内容：发出字节数组的长度 (int)；对于此版本为 4。发出给定长度的字节数组。字节数组的内容是字段 startDay、startDayOfWeek、endDay 和 endDayOfWeek 的 true 值。在必需部分中这些字段的值是适合于规则模式 DOW_IN_MONTH_MODE 的近似值，它是 JDK 1.1 唯一可识别的模式。

抛出：
IOException
序列化字段

startMonth

int startMonth
夏令时开始的月份。此值必须介于 Calendar.JANUARY 和 Calendar.DECEMBER（包含）之间。此值必须不能等于 endMonth。

如果 useDaylight 为 false，则忽略此值。

startDay

int startDay
此字段有两种可能的解释：
startMode == DOW_IN_MONTH
startDay 指示夏令时是在 startMonth 月份中的哪个日期开始的，该日期可以是从 1 到 28、30 或 31，具体取决于 startMonth。
startMode != DOW_IN_MONTH
startDay 指示夏令时是在 startMonth 月份中的哪个 startDayOfWeek 开始。例如，一个 +1 值和一个 Calendar.SUNDAY 的 startDayOfWeek 指示 startMonth 的第一个星期日。同样，+2 则指示第二个星期日，-1 指示最后一个星期日。0 值是非法的。

如果 useDaylight 为 false，则忽略此值。

startDayOfWeek

int startDayOfWeek
夏令时开始时是一周的星期几。此值必须介于 Calendar.SUNDAY 和 Calendar.SATURDAY（包括）之间。

如果 useDaylight 为 false 或 startMode == DAY_OF_MONTH，则忽略此值。

startTime

int startTime
夏令时开始日的子夜之后以毫秒表示的时间。此值表示为挂钟时间、标准时间或 UTC 时间，具体取决于 startTimeMode 的设置。

如果 useDaylight 为 false，则忽略此值。

startTimeMode

int startTimeMode
startTime 的格式，可为 WALL_TIME、STANDARD_TIME 或 UTC_TIME。

从以下版本开始：
1.3

endMonth

int endMonth
夏令时结束的月份。此值必须介于 Calendar.JANUARY 和 Calendar.UNDECIMBER 之间。此值必须不能等于 startMonth。

如果 useDaylight 为 false，则忽略此值。

endDay

int endDay
此字段有两种可能的解释：
endMode == DOW_IN_MONTH
endDay 指示夏令时是在 endMonth 月份中的哪个日期结束的，该日期可以是从 1 到 28、30 或 31，具体取决于 endMonth。
endMode != DOW_IN_MONTH
endDay 指示夏令时是在 endMonth 月份中哪个 endDayOfWeek 结束。例如，一个 +1 值和一个 Calendar.SUNDAY 的 endDayOfWeek 指示 endMonth 的第一个星期日。同样，+2 则指示第二个星期日，-1 指示最后一个星期日。0 值是非法的。

如果 useDaylight 为 false，则忽略此值。

endDayOfWeek

int endDayOfWeek
夏令时结束时，一周的星期几。此值必须介于 Calendar.SUNDAY 和 Calendar.SATURDAY（包括）之间。

如果 useDaylight 为 false 或 endMode == DAY_OF_MONTH，则忽略此值。

endTime

int endTime
夏令时结束日的子夜之后以毫秒表示的时间。此值表示为挂钟时间、标准时间或 UTC 时间，具体取决于 endTimeMode 的设置。

如果 useDaylight 为 false，则忽略此值。

endTimeMode

int endTimeMode
endTime 的格式，可为 WALL_TIME、STANDARD_TIME 或 UTC_TIME。

从以下版本开始：
1.3

startYear

int startYear
夏令时首次实施的年份。它是一个 AD 值。如果此值小于 1，则在所有的 AD 年份中都实施夏令时。

如果 useDaylight 为 false，则忽略此值。

rawOffset

int rawOffset
此时区与 GMT 之间以毫秒为单位的偏移量。负偏移表示西时区。要获得本地标准 时间，可用偏移量加上 GMT 时间。要获取本地挂钟时间，则还须加上 dstSavings。

useDaylight

boolean useDaylight
一个布尔值，当且仅当此时区使用夏令时时才为 true。如果此值为 false，则忽略其他几个字段。

monthLength

byte[] monthLength
此字段在 JDK 1.1 中是序列化的，因此，我们必须保持该顺序，以维护序列化的兼容性。不过，无需在每次创建新时区时都重新创建此数组。

包含值 {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31} 的字节数组。从 Java 2 平台 v1.2 开始忽略了此顺序，但为了保持与 JDK 1.1 的兼容性，还必须保持它的有序性。

startMode

int startMode
指定开始规则模式的变量。采用下面的值：
DOM_MODE
具体日期；例如，3 月 1 日。
DOW_IN_MONTH_MODE
一个月中的星期几；例如，3 月的最后一个星期日。
DOW_GE_DOM_MODE
一个月的某一天之后的星期几；例如，3 月 15 日或之后的星期日。
DOW_LE_DOM_MODE
一个月的某一天之前的星期几；例如，3 月 15 日或之前的星期日。
此字段的设置影响 startDay 字段的解释。

如果 useDaylight 为 false，则忽略此值。

从以下版本开始：
1.1.4

endMode

int endMode
指定结束规则模式的变量。采用下面的值：
DOM_MODE
具体日期；例如，3 月 1 日。
DOW_IN_MONTH_MODE
一个月中的星期几；例如，3 月的最后一个星期日。
DOW_GE_DOM_MODE
一个月的某一天之后的星期几；例如，3 月 15 日或之后的星期日。
DOW_LE_DOM_MODE
一个月的某一天之前的星期几；例如，3 月 15 日或之前的星期日。
此字段的设置影响 endDay 字段的解释。

如果 useDaylight 为 false，则忽略此值。

从以下版本开始：
1.1.4

dstSavings

int dstSavings
正值指示在 DST 期间节省的时间量（以毫秒为单位）。一般为 1 小时 (3600000)，有时为 30 分钟 (1800000)。

如果 useDaylight 为 false，则忽略此值。

从以下版本开始：
1.1.4

serialVersionOnStream

int serialVersionOnStream
流上序列化数据的版本。可能的值：
0 或者在流上不出现
JDK 1.1.3 或较早版本。
1
JDK 1.1.4 或更高版本。包括三个新字段：startMode、endMode 和 dstSavings。
2
JDK 1.3 或更高版本。包括两个新字段：startTimeMode 和 endTimeMode。
在流出此类时，编写最新格式和所允许的最高 serialVersionOnStream。

从以下版本开始：
1.1.4

类 java.util.Stack 继承 Vector<E> 实现 Serializable

serialVersionUID: 1224463164541339165L

类 java.util.TimeZone 继承 Object 实现 Serializable

serialVersionUID: 3581463369166924961L

序列化字段

ID

String ID
此 TimeZone 的字符串标识符。这是一个编程标识符，供内部用于从系统表中查询 TimeZone 对象，也用于把它们映射到它们的本地化显示名称。ID 值在系统表中是唯一的，但可能不是针对动态创建的区域。

类 java.util.TooManyListenersException 继承 Exception 实现 Serializable

类 java.util.TreeMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 919286545866124006L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
在某一流中重新构造 TreeMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 TreeMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出 TreeMap 的大小（健值映射关系数，用一个 int 值表示），后跟 TreeMap 表示的每个键-值映射关系的键（Object）和值（Object）。键-值映射关系是按照键的顺序发出的（由 TreeMap 的 Comparator 确定，如果 TreeMap 没有 Comparator，则该顺序由键的自然顺序确定）。
抛出：
IOException
序列化字段

comparator

Comparator<T> comparator
用来保持此树映射（tree map）中的顺序的比较器，如果此树映射使用它的键的自然顺序，则返回 null。

类 java.util.TreeMap.AscendingSubMap 继承 java.util.TreeMap.NavigableSubMap<K,V> 实现 Serializable

serialVersionUID: 912986545866124060L

类 java.util.TreeMap.DescendingSubMap 继承 java.util.TreeMap.NavigableSubMap<K,V> 实现 Serializable

serialVersionUID: 912986545866120460L

序列化字段

reverseComparator

Comparator<T> reverseComparator

类 java.util.TreeMap.NavigableSubMap 继承 AbstractMap<K,V> 实现 Serializable

序列化字段

m

TreeMap<K,V> m
The backing map.

lo

Object lo
Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

hi

Object hi
Endpoints are represented as triples (fromStart, lo, loInclusive) and (toEnd, hi, hiInclusive). If fromStart is true, then the low (absolute) bound is the start of the backing map, and the other values are ignored. Otherwise, if loInclusive is true, lo is the inclusive bound, else lo is the exclusive bound. Similarly for the upper bound.

fromStart

boolean fromStart

toEnd

boolean toEnd

loInclusive

boolean loInclusive

hiInclusive

boolean hiInclusive

类 java.util.TreeMap.SubMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: -6520786458950516097L

序列化方法

readResolve

private Object readResolve()
序列化字段

fromStart

boolean fromStart

toEnd

boolean toEnd

fromKey

Object fromKey

toKey

Object toKey

类 java.util.TreeMap$SubMap$DescendingEntrySetView 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingEntryIterator 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingEntrySet 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingKeySet 继承 Object 实现 Serializable

类 java.util.TreeMap$DescendingSubMapEntryIterator 继承 Object 实现 Serializable

类 java.util.TreeMap$SubMapEntryIterator 继承 Object 实现 Serializable

类 java.util.TreeSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: -2479143000061671589L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
在某一流中重新构造 TreeSet 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 TreeSet 实例的状态保存到流中（也就是将其序列化）。

序列数据：
发出用于对此 set 进行排序的比较器，如果其元素遵循自然顺序（Object），则发出 null，后跟该 set 的大小（它包含的元素数，用一个 int 值表示），再后面是其按顺序排列的所有元素（每个元素是一个 Object）（该顺序由 set 的 Comparator 确定；如果 set 没有 Comparator，则该顺序由元素的自然顺序确定）。
抛出：
IOException

类 java.util.UnknownFormatConversionException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19060418L

序列化字段

s

String s

类 java.util.UnknownFormatFlagsException 继承 IllegalFormatException 实现 Serializable

serialVersionUID: 19370506L

序列化字段

flags

String flags

类 java.util.UUID 继承 Object 实现 Serializable

serialVersionUID: -4856846361193249489L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据流重构 UUID 实例（也就是将其反序列化）。这对于将各个 transient 字段设置为其正确的未初始化的值以便按需重新计算很有必要。

抛出：
IOException
ClassNotFoundException
序列化字段

mostSigBits

long mostSigBits

leastSigBits

long leastSigBits

类 java.util.Vector 继承 AbstractList<E> 实现 Serializable

serialVersionUID: -2767605614048989439L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 Vector 实例的状态保存到流中（也就是将其序列化）。此方法只在同步时使用。它仅调用默认的 writeObject 方法。

抛出：
IOException
序列化字段

elementData

Object[] elementData
存储向量组件的数组缓冲区。vector 的容量就是此数据缓冲区的长度，该长度至少要足以包含向量的所有元素。

Vector 中的最后一个元素后的任何数组元素都为 null。

elementCount

int elementCount
Vector 对象中的有效组件数。从 elementData[0] 到 elementData[elementCount-1] 的组件均为实际项。

capacityIncrement

int capacityIncrement
向量的大小大于其容量时，容量自动增加的量。如果容量的增量小于等于零，则每次需要增大容量时，向量的容量将增大一倍。

软件包 java.util.concurrent

类 java.util.concurrent.ArrayBlockingQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -817911632652898426L

序列化字段

items

Object[] items
已加入队列的项

takeIndex

int takeIndex
下次提取、轮询或移除的项索引

putIndex

int putIndex
下次放入、提供或添加的项索引

count

int count
队列中的项的数量

lock

ReentrantLock lock
保护所有访问的主锁

notEmpty

Condition notEmpty
等待取出的条件

notFull

Condition notFull
等待放入的条件

类 java.util.concurrent.BrokenBarrierException 继承 Exception 实现 Serializable

serialVersionUID: 7117394618823254244L

类 java.util.concurrent.CancellationException 继承 IllegalStateException 实现 Serializable

serialVersionUID: -9202173006928992231L

类 java.util.concurrent.ConcurrentHashMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: 7249069246763182397L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构 ConcurrentHashMap 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 ConcurrentHashMap 实例的状态保存到流中（也就是将其序列化）。

序列数据：
每个键-值映射关系的键 (Object) 和值 (Object)，后跟一个 null 对。键-值映射关系的发出没有任何特定顺序。
抛出：
IOException
序列化字段

segmentMask

int segmentMask
用来对段进行索引的掩码值。哈希表的键的高位被用来选择段。

segmentShift

int segmentShift
用来在段中进行索引的移位值。

segments

java.util.concurrent.ConcurrentHashMap.Segment<K,V>[] segments
每个段都是一个专门的哈希表。

类 java.util.concurrent.ConcurrentLinkedQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: 196745693267521676L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
在某一流中重构 Queue 实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将状态保存到流中（也就是将其序列化）。

序列数据：
以恰当顺序排列的所有元素（每个元素是一个 E），后跟一个 null
抛出：
IOException

类 java.util.concurrent.ConcurrentSkipListMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: -8627078645895051609L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构映射。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此映射的状态保存到流中。

序列数据：
映射表示的每个键-值映射关系的键 (Object) 和值 (Object)，后跟 null。按照键顺序（由 Comparator 确定，如果没有 Comparator，则由键的自然顺序确定）发出键-值映射关系。
抛出：
IOException
序列化字段

comparator

Comparator<T> comparator
用于维护此映射中顺序的比较器；如果使用自然顺序，则为 null。

类 java.util.concurrent.ConcurrentSkipListMap$DescendingEntryIterator 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap$DescendingEntrySet 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap$DescendingKeyIterator 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap$DescendingKeySet 继承 Object 实现 Serializable

类 java.util.concurrent.ConcurrentSkipListMap.SubMap 继承 AbstractMap<K,V> 实现 Serializable

serialVersionUID: -7647078645895051609L

序列化字段

m

ConcurrentSkipListMap<K,V> m
Underlying map

lo

Object lo
lower bound key, or null if from start

hi

Object hi
upper bound key, or null if to end

loInclusive

boolean loInclusive
inclusion flag for lo

hiInclusive

boolean hiInclusive
inclusion flag for hi

isDescending

boolean isDescending
direction

类 java.util.concurrent.ConcurrentSkipListSet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: -2479143111061671589L

序列化字段

m

ConcurrentNavigableMap<K,V> m
底层映射。将 Boolean.TRUE 用作每个元素的值。为了线程安全将此字段声明为 final，这会在 clone() 中带来一些丑陋的外观。

类 java.util.concurrent.CopyOnWriteArrayList 继承 Object 实现 Serializable

serialVersionUID: 8673264195747942595L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构列表（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将列表状态保存到流中（也就是将其序列化）。

序列数据：
发出支持列表的数组的长度（一个 int 值），后跟以适当顺序排列的所有数组元素（均为对象）。
抛出：
IOException

类 java.util.concurrent.CopyOnWriteArraySet 继承 AbstractSet<E> 实现 Serializable

serialVersionUID: 5457747651344034263L

序列化字段

al

CopyOnWriteArrayList<E> al

类 java.util.concurrent.ExecutionException 继承 Exception 实现 Serializable

serialVersionUID: 7830266012832686185L

类 java.util.concurrent.LinkedBlockingDeque 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -387911632671998426L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重构此双端队列（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将此双端队列的状态保存到流中（也就是将其序列化）。

序列数据：
容量 (int)，后跟以恰当顺序排列的元素（每个都是 Object），然后是 null
抛出：
IOException
序列化字段

capacity

int capacity
双端队列中的最大条目数

lock

ReentrantLock lock
保护所有访问的主锁

notEmpty

Condition notEmpty
等待 take 的条件

notFull

Condition notFull
等待 put 的条件

类 java.util.concurrent.LinkedBlockingQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -6903933977591709194L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流重构此队列实例（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将状态保存到流中（也就是将其序列化）。

序列数据：
发出容量 (int)，后跟按适当顺序排列的所有元素（每个都是顺序正确的 Object），后跟 null。
抛出：
IOException
序列化字段

capacity

int capacity
容量上限，如果没有则为 Integer.MAX_VALUE。

count

AtomicInteger count
当前的元素数。

takeLock

ReentrantLock takeLock
由 take、poll 等所保持的锁。

notEmpty

Condition notEmpty
等待 take 的等待队列。

putLock

ReentrantLock putLock
由 put、offer 等所保持的锁。

notFull

Condition notFull
等待 put 的等待队列。

类 java.util.concurrent.PriorityBlockingQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: 5595510919245408276L

序列化方法

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将状态保存到流中（也就是将其序列化）。这只包装锁内的默认序列化内容。该内容的序列化策略留给底层 Queue 负责。注意，在反序列化时不需要锁，所以并未定义 readObject，使用默认值即可。

抛出：
IOException
序列化字段

q

PriorityQueue<E> q

lock

ReentrantLock lock

notEmpty

Condition notEmpty

类 java.util.concurrent.RejectedExecutionException 继承 RuntimeException 实现 Serializable

serialVersionUID: -375805702767069545L

类 java.util.concurrent.Semaphore 继承 Object 实现 Serializable

serialVersionUID: -3222578661600680210L

序列化字段

sync

java.util.concurrent.Semaphore.Sync sync
通过 AbstractQueuedSynchronizer 子类实现的所有机制。

类 java.util.concurrent.SynchronousQueue 继承 AbstractQueue<E> 实现 Serializable

serialVersionUID: -3223113410248163686L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将该状态保存到流中（也就是将其序列化）。

抛出：
IOException
序列化字段

qlock

ReentrantLock qlock

waitingProducers

java.util.concurrent.SynchronousQueue.WaitQueue waitingProducers

waitingConsumers

java.util.concurrent.SynchronousQueue.WaitQueue waitingConsumers

类 java.util.concurrent.TimeoutException 继承 Exception 实现 Serializable

serialVersionUID: 1900926677490660714L

软件包 java.util.concurrent.atomic

类 java.util.concurrent.atomic.AtomicBoolean 继承 Object 实现 Serializable

serialVersionUID: 4654671469794556979L

序列化字段

value

int value

类 java.util.concurrent.atomic.AtomicInteger 继承 Number 实现 Serializable

serialVersionUID: 6214790243416807050L

序列化字段

value

int value

类 java.util.concurrent.atomic.AtomicIntegerArray 继承 Object 实现 Serializable

serialVersionUID: 2862133569453604235L

序列化字段

array

int[] array

类 java.util.concurrent.atomic.AtomicLong 继承 Number 实现 Serializable

serialVersionUID: 1927816293512124184L

序列化字段

value

long value

类 java.util.concurrent.atomic.AtomicLongArray 继承 Object 实现 Serializable

serialVersionUID: -2308431214976778248L

序列化字段

array

long[] array

类 java.util.concurrent.atomic.AtomicReference 继承 Object 实现 Serializable

serialVersionUID: -1848883965231344442L

序列化字段

value

Object value

类 java.util.concurrent.atomic.AtomicReferenceArray 继承 Object 实现 Serializable

serialVersionUID: -6209656149925076980L

序列化字段

array

Object[] array
软件包 java.util.concurrent.locks

类 java.util.concurrent.locks.AbstractOwnableSynchronizer 继承 Object 实现 Serializable

serialVersionUID: 3737899427754241961L

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 继承 AbstractOwnableSynchronizer 实现 Serializable

serialVersionUID: 7373984972572414692L

序列化字段

state

long state
同步状态。

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 继承 Object 实现 Serializable

serialVersionUID: 1173984872572414699L

类 java.util.concurrent.locks.AbstractQueuedSynchronizer 继承 AbstractOwnableSynchronizer 实现 Serializable

serialVersionUID: 7373984972572414691L

序列化字段

state

int state
同步状态。

类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 继承 Object 实现 Serializable

serialVersionUID: 1173984872572414699L

类 java.util.concurrent.locks.ReentrantLock 继承 Object 实现 Serializable

serialVersionUID: 7373984872572414699L

序列化字段

sync

java.util.concurrent.locks.ReentrantLock.Sync sync
提供所有实现机制的同步器

类 java.util.concurrent.locks.ReentrantReadWriteLock 继承 Object 实现 Serializable

serialVersionUID: -6992448646407690164L

序列化字段

readerLock

ReentrantReadWriteLock.ReadLock readerLock
提供读取锁的内部类

writerLock

ReentrantReadWriteLock.WriteLock writerLock
提供写入锁的内部类

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync
执行所有同步机制

类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 继承 Object 实现 Serializable

serialVersionUID: -5992448646407690164L

序列化字段

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync

类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 继承 Object 实现 Serializable

serialVersionUID: -4992448646407690164L

序列化字段

sync

java.util.concurrent.locks.ReentrantReadWriteLock.Sync sync
软件包 java.util.jar

类 java.util.jar.JarException 继承 ZipException 实现 Serializable

软件包 java.util.logging

类 java.util.logging.Level 继承 Object 实现 Serializable

serialVersionUID: -8176160795706313070L

序列化方法

readResolve

private Object readResolve()
序列化字段

name

String name
级别的非本地化名称。

value

int value
级别的整数值。

resourceBundleName

String resourceBundleName
本地化级别名称时使用的资源包名称。

类 java.util.logging.LoggingPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 63564341580231582L

类 java.util.logging.LogRecord 继承 Object 实现 Serializable

serialVersionUID: 5372048053134512534L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
序列数据：
默认字段，后跟两个字节的版本号（前面是主字节，后面是次字节），后跟关于日志记录参数数组的信息。如果不存在参数数组，则写入 -1。如果存在参数数组（可能长度为零），则作为整数写入数组长度，后跟每个参数的 String 值。如果参数为 null，则写入 null String。否则，写入 Object.toString() 的输出。
抛出：
IOException
序列化字段

level

Level level
日志消息级别

sequenceNumber

long sequenceNumber
序列号

sourceClassName

String sourceClassName
发出日志调用的类

sourceMethodName

String sourceMethodName
发出日志调用的方法

message

String message
非本地化的原始消息文本

threadID

int threadID
发出日志调用的线程的线程 ID。

millis

long millis
自从 1970 年以毫秒为单位的事件时间

thrown

Throwable thrown
与日志消息相关联的 Throwable（如果有）

loggerName

String loggerName
源 Logger 的名称。

resourceBundleName

String resourceBundleName
本地化日志消息的资源包名称。
软件包 java.util.prefs

类 java.util.prefs.BackingStoreException 继承 Exception 实现 Serializable

serialVersionUID: 859796500401108469L

类 java.util.prefs.InvalidPreferencesFormatException 继承 Exception 实现 Serializable

serialVersionUID: -791715184232119669L

软件包 java.util.regex

类 java.util.regex.Pattern 继承 Object 实现 Serializable

serialVersionUID: 5073258162644648461L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中重新编译 Pattern 实例。读入初始模式字符串并从中重新编译对象树。

抛出：
IOException
ClassNotFoundException
序列化字段

pattern

String pattern
初始正则表达式模式字符串。

flags

int flags
初始模式标志。

类 java.util.regex.PatternSyntaxException 继承 IllegalArgumentException 实现 Serializable

序列化字段

desc

String desc

pattern

String pattern

index

int index
软件包 java.util.zip

类 java.util.zip.DataFormatException 继承 Exception 实现 Serializable

类 java.util.zip.ZipError 继承 InternalError 实现 Serializable

serialVersionUID: 853973422266861979L

类 java.util.zip.ZipException 继承 IOException 实现 Serializable

软件包 javax.activation

类 javax.activation.ActivationDataFlavor 继承 DataFlavor 实现 Serializable

序列化方法

readExternal

public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
根据 Serialized 状态还原此 DataFlavor。

抛出：
IOException - 如果发生 I/O 错误
ClassNotFoundException - 如果无法找到需要恢复的某个对象的类。

writeExternal

public void writeExternal(ObjectOutput os)
                   throws IOException
序列化此 DataFlavor。

抛出：
IOException - 包含可能发生的所有 I/O 异常

类 javax.activation.MimeType 继承 Object 实现 Serializable

序列化方法

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。readExternal 方法必须按照与 writeExternal 写入值时使用的相同顺序和类型来读取这些值。

抛出：
ClassNotFoundException - 如果找不到要恢复的对象的类。I
IOException - 如果发生 I/O 错误

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。

抛出：
IOException - 包括可能发生的所有 I/O 异常

类 javax.activation.MimeTypeParseException 继承 Exception 实现 Serializable

类 javax.activation.UnsupportedDataTypeException 继承 IOException 实现 Serializable

软件包 javax.activity

类 javax.activity.ActivityCompletedException 继承 RemoteException 实现 Serializable

类 javax.activity.ActivityRequiredException 继承 RemoteException 实现 Serializable

类 javax.activity.InvalidActivityException 继承 RemoteException 实现 Serializable

软件包 javax.annotation.processing

类 javax.annotation.processing.FilerException 继承 IOException 实现 Serializable

serialVersionUID: 8426423106453163293L

软件包 javax.crypto

类 javax.crypto.BadPaddingException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.ExemptionMechanismException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.IllegalBlockSizeException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.NoSuchPaddingException 继承 GeneralSecurityException 实现 Serializable

类 javax.crypto.SealedObject 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流中还原 SealedObject 的状态。

抛出：
NullPointerException - 如果 s 为 null。
IOException
ClassNotFoundException
序列化字段

encodedParams

byte[] encodedParams
由密封 Cipher 使用的加密参数，以默认格式进行编码。

即 cipher.getParameters().getEncoded()。

encryptedContent

byte[] encryptedContent
以加密格式存在的序列化对象内容。

sealAlg

String sealAlg
用于密封此对象的算法。

paramsAlg

String paramsAlg
所用的参数算法。

类 javax.crypto.ShortBufferException 继承 GeneralSecurityException 实现 Serializable

软件包 javax.crypto.interfaces
软件包 javax.crypto.spec

类 javax.crypto.spec.SecretKeySpec 继承 Object 实现 Serializable

序列化字段

key

byte[] key
密钥。

algorithm

String algorithm
与此密钥关联的算法名称。

软件包 javax.imageio

类 javax.imageio.IIOException 继承 IOException 实现 Serializable

软件包 javax.imageio.metadata

类 javax.imageio.metadata.IIOInvalidTreeException 继承 IIOException 实现 Serializable

序列化字段

offendingNode

Node offendingNode
导致解析错误的 Node，或 null。

软件包 javax.lang.model.element

类 javax.lang.model.element.UnknownAnnotationValueException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

类 javax.lang.model.element.UnknownElementException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

软件包 javax.lang.model.type

类 javax.lang.model.type.MirroredTypeException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

类 javax.lang.model.type.MirroredTypesException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

类 javax.lang.model.type.UnknownTypeException 继承 RuntimeException 实现 Serializable

serialVersionUID: 269L

软件包 javax.management

类 javax.management.AndQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -1081892073854801359L

序列化字段

exp1

QueryExp exp1
The first QueryExp of the conjunction

exp2

QueryExp exp2
The second QueryExp of the conjunction

类 javax.management.Attribute 继承 Object 实现 Serializable

serialVersionUID: 2484220110589082382L

序列化字段

name

String name
Attribute 名称。

value

Object value
Attribute 值。

类 javax.management.AttributeChangeNotification 继承 Notification 实现 Serializable

serialVersionUID: 535176054565814134L

序列化字段

attributeName

String attributeName
MBean 属性名称。

attributeType

String attributeType
MBean 属性类型。

oldValue

Object oldValue
MBean 属性的旧值。

newValue

Object newValue
MBean 属性的新值。

类 javax.management.AttributeChangeNotificationFilter 继承 Object 实现 Serializable

serialVersionUID: -6347317584796410029L

序列化字段

enabledAttributes

Vector<E> enabledAttributes
包含已启用属性名称的 Vector。默认值是一个空向量。

类 javax.management.AttributeList 继承 ArrayList<Object> 实现 Serializable

serialVersionUID: -4077085769279709076L

类 javax.management.AttributeNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: 6511584241791106926L

类 javax.management.AttributeValueExp 继承 Object 实现 Serializable

serialVersionUID: -7768025046539163385L

序列化字段

attr

String attr

类 javax.management.BadAttributeValueExpException 继承 Exception 实现 Serializable

serialVersionUID: -3105272988410493376L

序列化字段

val

Object val
产生此异常的属性值

类 javax.management.BadBinaryOpValueExpException 继承 Exception 实现 Serializable

serialVersionUID: 5068475589449021227L

序列化字段

exp

ValueExp exp
产生此异常的 ValueExp

类 javax.management.BadStringOperationException 继承 Exception 实现 Serializable

serialVersionUID: 7802201238441662100L

序列化字段

op

String op
对产生此异常的操作的描述

类 javax.management.BetweenQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -2933597532866307444L

序列化字段

exp1

ValueExp exp1
The checked value

exp2

ValueExp exp2
The lower bound value

exp3

ValueExp exp3
The upper bound value

类 javax.management.BinaryOpValueExp 继承 QueryEval 实现 Serializable

serialVersionUID: 1216286847881456786L

序列化字段

op

int op
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

类 javax.management.BinaryRelQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -5690656271650491000L

序列化字段

relOp

int relOp
The operator

exp1

ValueExp exp1
The first value

exp2

ValueExp exp2
The second value

类 javax.management.BooleanValueExp 继承 QueryEval 实现 Serializable

serialVersionUID: 7754922052666594581L

序列化字段

val

boolean val
The boolean value

类 javax.management.ClassAttributeValueExp 继承 AttributeValueExp 实现 Serializable

序列化字段

attr

String attr
The name of the attribute

The serialVersionUID of this class is -1081892073854801359L.

类 javax.management.ImmutableDescriptor 继承 Object 实现 Serializable

serialVersionUID: 8853308591080540165L

序列化方法

readResolve

private Object readResolve()
                    throws InvalidObjectException
此方法可以使用另一个实例替换此类的反序列化实例。例如，它可以使用 ImmutableDescriptor.EMPTY_DESCRIPTOR 替换反序列化的空 ImmutableDescriptor。

抛出：
InvalidObjectException - 如果读取的对象包含无效字段。
序列化字段

names

String[] names
此 ImmutableDescriptor 中具有其原始大小写的字段名称。名称必须按 String.CASE_INSENSITIVE_ORDER 确定的方式以字母顺序排列。

values

Object[] values
此 ImmutableDescriptor 中字段的值。此数组中的元素与 names 数组中的相应元素匹配。

类 javax.management.InQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -5801329450358952434L

序列化字段

val

ValueExp val
The ValueExp to be found

valueList

ValueExp[] valueList
The array of ValueExp to be searched

类 javax.management.InstanceAlreadyExistsException 继承 OperationsException 实现 Serializable

serialVersionUID: 8893743928912733931L

类 javax.management.InstanceNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: -882579438394773049L

类 javax.management.InstanceOfQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -1081892073854801359L

序列化字段

classNameValue

StringValueExp classNameValue
The StringValueExp returning the name of the class of which selected MBeans should be instances.

类 javax.management.IntrospectionException 继承 OperationsException 实现 Serializable

serialVersionUID: 1054516935875481725L

类 javax.management.InvalidApplicationException 继承 Exception 实现 Serializable

serialVersionUID: -3048022274675537269L

序列化字段

val

Object val
表示 MBean 的类的对象

类 javax.management.InvalidAttributeValueException 继承 OperationsException 实现 Serializable

serialVersionUID: 2164571879317142449L

类 javax.management.JMException 继承 Exception 实现 Serializable

serialVersionUID: 350520924977331825L

类 javax.management.JMRuntimeException 继承 RuntimeException 实现 Serializable

serialVersionUID: 6573344628407841861L

类 javax.management.ListenerNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: -7242605822448519061L

类 javax.management.MalformedObjectNameException 继承 OperationsException 实现 Serializable

serialVersionUID: -572689714442915824L

类 javax.management.MatchQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: -7156603696948215014L

序列化字段

exp

AttributeValueExp exp
The attribute value to be matched

pattern

String pattern
The pattern to be matched

类 javax.management.MBeanAttributeInfo 继承 MBeanFeatureInfo 实现 Serializable

序列化字段

attributeType

String attributeType
The actual attribute type.

isWrite

boolean isWrite
The attribute write right.

isRead

boolean isRead
The attribute read right.

is

boolean is
Indicates if this method is a "is"

类 javax.management.MBeanConstructorInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: 4433990064191844427L

序列化字段

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

类 javax.management.MBeanException 继承 JMException 实现 Serializable

serialVersionUID: 4066342430588744142L

序列化字段

exception

Exception exception
Encapsulated Exception

类 javax.management.MBeanFeatureInfo 继承 Object 实现 Serializable

serialVersionUID: 3952882688968447265L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据 ObjectInputStream 反序列化 MBeanFeatureInfo。

序列数据：
For compatibility reasons, an object of this class is deserialized as follows.
    The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:
    • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
    • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
    • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR
    • Any other value. A StreamCorruptedException is thrown.
抛出：
IOException
ClassNotFoundException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 MBeanFeatureInfo 序列化为 ObjectOutputStream。

序列数据：
For compatibility reasons, an object of this class is serialized as follows.
    The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:
    • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
    • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize directly the field descriptor.
抛出：
IOException
从以下版本开始：
1.6
序列化字段

name

String name
该功能的名称。推荐子类调用 MBeanFeatureInfo.getName() 方法，而不是读取此字段，并且子类不能更改该字段。

该功能的名称。

description

String description
该功能的可读描述。推荐子类调用 MBeanFeatureInfo.getDescription() 方法，而不是读取此字段，并且子类不能更改该字段。

该功能的可读描述。

类 javax.management.MBeanInfo 继承 Object 实现 Serializable

serialVersionUID: -6451021435135161911L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 MBeanInfo。

序列数据：
For compatibility reasons, an object of this class is deserialized as follows.
    The method defaultReadObject() is called first to deserialize the object except the field descriptor, which is not serialized in the default way. Then the method read() is called to read a byte, the field descriptor is deserialized according to the value of the byte value:
    • 1. The method readObject() is called twice to obtain the field names (a String[]) and the field values (a Object[]) of the descriptor. The two obtained values then are used to construct an ImmutableDescriptor instance for the field descriptor;
    • 0. The value for the field descriptor is obtained directly by calling the method readObject(). If the obtained value is null, the field descriptor is set to EMPTY_DESCRIPTOR;
    • -1. This means that there is no byte to read and that the object is from an earlier version of the JMX API. The field descriptor is set to EMPTY_DESCRIPTOR.
    • Any other value. A StreamCorruptedException is thrown.
抛出：
IOException
ClassNotFoundException
从以下版本开始：
1.6

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 MBeanInfo 序列化为 ObjectOutputStream。

序列数据：
For compatibility reasons, an object of this class is serialized as follows.
    The method defaultWriteObject() is called first to serialize the object except the field descriptor which is declared as transient. The field descriptor is serialized as follows:
    • If descriptor is an instance of the class ImmutableDescriptor, the method write(int val) is called to write a byte with the value 1, then the method writeObject(Object obj) is called twice to serialize the field names and the field values of the descriptor, respectively as a String[] and an Object[];
    • Otherwise, the method write(int val) is called to write a byte with the value 0, then the method writeObject(Object obj) is called to serialize the field descriptor directly.
抛出：
IOException
从以下版本开始：
1.6
序列化字段

description

String description
The human readable description of the class.

className

String className
The MBean qualified name.

attributes

MBeanAttributeInfo[] attributes
The MBean attribute descriptors.

operations

MBeanOperationInfo[] operations
The MBean operation descriptors.

constructors

MBeanConstructorInfo[] constructors
The MBean constructor descriptors.

notifications

MBeanNotificationInfo[] notifications
The MBean notification descriptors.

类 javax.management.MBeanNotificationInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: -3888371564530107064L

序列化字段

types

String[] types
The different types of the notification.

类 javax.management.MBeanOperationInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: -6178860474881375330L

序列化字段

type

String type
The method's return value.

signature

MBeanParameterInfo[] signature
The signature of the method, that is, the class names of the arguments.

impact

int impact
返回该方法的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。

类 javax.management.MBeanParameterInfo 继承 MBeanFeatureInfo 实现 Serializable

serialVersionUID: 7432616882776782338L

序列化字段

type

String type
The type or class name of the data.

类 javax.management.MBeanPermission 继承 Permission 实现 Serializable

serialVersionUID: -2416928705275160661L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据此对象的名称和操作反序列化它。

抛出：
IOException
ClassNotFoundException
序列化字段

actions

String actions
操作字符串。

类 javax.management.MBeanRegistrationException 继承 MBeanException 实现 Serializable

serialVersionUID: 4482382455277067805L

类 javax.management.MBeanServerNotification 继承 Notification 实现 Serializable

serialVersionUID: 2876477500475969677L

序列化字段

objectName

ObjectName objectName
与此通知有关的 MBean 的对象名

类 javax.management.MBeanServerPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -5661980843569388590L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

类 javax.management.MBeanServerPermissionCollection 继承 PermissionCollection 实现 Serializable

serialVersionUID: -5661980843569388590L

序列化字段

collectionPermission

MBeanServerPermission collectionPermission
Null if no permissions in collection, otherwise a single permission that is the union of all permissions that have been added.

类 javax.management.MBeanTrustPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -2952178077029018140L

类 javax.management.NotCompliantMBeanException 继承 OperationsException 实现 Serializable

serialVersionUID: 5175579583207963577L

类 javax.management.Notification 继承 EventObject 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 中反序列化 Notification。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 Notification 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

message

String message
通知消息。

sequenceNumber

long sequenceNumber
通知序列号。序列号在通知源的上下文中标识特定的通知实例。

source

Object source
最初发生通知的对象。

timeStamp

long timeStamp
通知时间戳。指示通知的生成时间

type

String type
通知类型。用和 Java 属性类似的点标注法表示的 string。通知类型的示例：network.alarm.router

userData

Object userData
通知的用户数据。用于通知源希望与其使用者所交流的所有其他数据

类 javax.management.NotificationFilterSupport 继承 Object 实现 Serializable

serialVersionUID: 6579080007561786969L

序列化字段

enabledTypes

List<E> enabledTypes
包含已启用通知类型的 Vector。默认值是一个空向量。

类 javax.management.NotQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: 5269643775896723397L

序列化字段

exp

QueryExp exp
The negated QueryExp

类 javax.management.NumericValueExp 继承 QueryEval 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
Deserializes a NumericValueExp from an ObjectInputStream.

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
Serializes a NumericValueExp to an ObjectOutputStream.

抛出：
IOException
序列化字段

val

Number val
The numeric value

The serialVersionUID of this class is -4679739485102359104L.

类 javax.management.ObjectInstance 继承 Object 实现 Serializable

serialVersionUID: -4099952623687795850L

序列化字段

name

ObjectName name
Object name.

className

String className
Class name.

类 javax.management.ObjectName 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
根据 ObjectInputStream 反序列化 ObjectName。

序列数据：
  • 在目前的序列形式中（属性 jmx.serial.form 的值不是 1.0）：字符串 "<域>:<属性><通配符>"，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性> 表示属性列表，由 ObjectName.getKeyPropertyListString() 所返回
    • 如果 isPropertyPattern 返回 false，则 <通配符> 为空；如果 isPropertyPattern 和 <属性> 为空，则 <通配符> 为字符 "*"；如果 isPropertyPattern 和 <属性> 不为空，则 <通配符> 为 ",*"。
    目的是可将此字符串提供给 ObjectName.ObjectName(String) 构造方法，以生成等效的 ObjectName。
  • 在旧的序列形式中（属性 jmx.serial.form 的值是 1.0）：<域> <属性列表> <属性列表 String> <规范名> <模式> <属性模式>，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性列表> 是包含此 ObjectName 所有键值对的 Hashtable
    • <属性列表 String> 是以任意顺序出现的属性列表的 String 表示形式（并不强制使用规范的表示形式）
    • <规范名> 是包含此 ObjectName 的规范名称的 String
    • <模式> 是一个 boolean 值，如果此 ObjectName 包含模式，则为 true
    • <属性模式> 是一个 boolean 值，如果此 ObjectName 在属性列表中包含模式，则为 true
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ObjectName 序列化为 ObjectOutputStream。

序列数据：
  • 在目前的序列形式中（属性 jmx.serial.form 的值不是 1.0）：字符串 "<域>:<属性><通配符>"，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性> 表示属性列表，由 ObjectName.getKeyPropertyListString() 所返回
    • 如果 isPropertyPattern 返回 false，则 <通配符> 为空；如果此 isPropertyPattern 和 <属性> 为空，则 <通配符> 为字符 "*"；如果 isPropertyPattern 和 <属性> 不为空，则 <通配符> 为 ",*"。
    目的是可将此字符串提供给 ObjectName.ObjectName(String) 构造方法，以生成等效的 ObjectName。
  • 在旧的序列形式中（属性 jmx.serial.form 的值是 1.0）：<域> <属性列表> <属性列表 String> <规范名> <模式> <属性模式>，其中：
    • <域> 表示 ObjectName 的域部分
    • <属性列表> 是包含此 ObjectName 所有键值对的 Hashtable
    • <属性列表 String> 是以任意顺序出现的属性列表的 String 表示形式（并不强制使用规范的表示形式）
    • <规范名> 是包含此 ObjectName 的规范名称的 String
    • <模式> 是一个 boolean 值，如果此 ObjectName 包含模式，则为 true
    • <属性模式> 是一个 boolean 值，如果此 ObjectName 在属性列表中包含模式，则为 true
抛出：
IOException
序列化字段

类 javax.management.OperationsException 继承 JMException 实现 Serializable

serialVersionUID: -4967597595580536216L

类 javax.management.OrQueryExp 继承 QueryEval 实现 Serializable

serialVersionUID: 2962973084421716523L

序列化字段

exp1

QueryExp exp1
The left query expression

exp2

QueryExp exp2
The right query expression

类 javax.management.QualifiedAttributeValueExp 继承 AttributeValueExp 实现 Serializable

serialVersionUID: 8832517277410933254L

序列化字段

className

String className
The attribute class name

类 javax.management.QueryEval 继承 Object 实现 Serializable

serialVersionUID: 2675899265640874796L

类 javax.management.ReflectionException 继承 JMException 实现 Serializable

serialVersionUID: 9170809325636915553L

序列化字段

exception

Exception exception
包装的 Exception

类 javax.management.RuntimeErrorException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: 704338937753949796L

序列化字段

error

Error error
封装的 Error

类 javax.management.RuntimeMBeanException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: 5274912751982730171L

序列化字段

runtimeException

RuntimeException runtimeException
封装的 RuntimeException

类 javax.management.RuntimeOperationsException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: -8408923047489133588L

序列化字段

runtimeException

RuntimeException runtimeException
封装的 RuntimeException

类 javax.management.ServiceNotFoundException 继承 OperationsException 实现 Serializable

serialVersionUID: -3990675661956646827L

类 javax.management.StringValueExp 继承 Object 实现 Serializable

serialVersionUID: -3256390509806284044L

序列化字段

val

String val
字符串文本
软件包 javax.management.loading

类 javax.management.loading.MLet 继承 URLClassLoader 实现 Serializable

serialVersionUID: 3636148327800330130L

序列化方法

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

从给定的 ObjectInput 恢复此 MLet 的内容。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改读取数据的格式。

读取数据的格式是未指定的，但如果某个实现支持 MLet.readExternal(java.io.ObjectInput)，则它必须也支持 MLet.writeExternal(java.io.ObjectOutput)，以便前者可以读取后者所写入的内容。

抛出：
IOException - 如果在读取时出现问题。
ClassNotFoundException - 如果找不到要恢复的对象的类。
UnsupportedOperationException - 如果此实现不支持此操作。

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

将此 MLet 的内容保存到给定的 ObjectOutput。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改写入数据的格式。

写入数据的格式是未指定的，但如果某个实现支持 MLet.writeExternal(java.io.ObjectOutput)，则它必须也支持 MLet.readExternal(java.io.ObjectInput)，以便后者可以读取前者所写入的内容。

抛出：
IOException - 如果在写入时发生问题。
UnsupportedOperationException - 如果此实现不支持此操作。

类 javax.management.loading.PrivateMLet 继承 MLet 实现 Serializable

serialVersionUID: 2503458973393711979L

序列化方法

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

从给定的 ObjectInput 恢复此 MLet 的内容。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改读取数据的格式。

读取数据的格式是未指定的，但如果某个实现支持 MLet.readExternal(java.io.ObjectInput)，则它必须也支持 MLet.writeExternal(java.io.ObjectOutput)，以便前者可以读取后者所写入的内容。

抛出：
IOException - 如果在读取时出现问题。
ClassNotFoundException - 如果找不到要恢复的对象的类。
UnsupportedOperationException - 如果此实现不支持此操作。

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

将此 MLet 的内容保存到给定的 ObjectOutput。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改写入数据的格式。

写入数据的格式是未指定的，但如果某个实现支持 MLet.writeExternal(java.io.ObjectOutput)，则它必须也支持 MLet.readExternal(java.io.ObjectInput)，以便后者可以读取前者所写入的内容。

抛出：
IOException - 如果在写入时发生问题。
UnsupportedOperationException - 如果此实现不支持此操作。
软件包 javax.management.modelmbean

类 javax.management.modelmbean.DescriptorSupport 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 DescriptorSupport。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 DescriptorSupport 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

descriptor

HashMap<K,V> descriptor
表示此描述符的字段的集合

类 javax.management.modelmbean.InvalidTargetObjectTypeException 继承 Exception 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 InvalidTargetObjectTypeException。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 InvalidTargetObjectTypeException 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

exception

Exception exception
封装的 {@link Exception}

类 javax.management.modelmbean.ModelMBeanAttributeInfo 继承 MBeanAttributeInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanAttributeInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanAttributeInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

attrDescriptor

Descriptor attrDescriptor
包含对应于此属性的元数据的 {@link Descriptor}

类 javax.management.modelmbean.ModelMBeanConstructorInfo 继承 MBeanConstructorInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanConstructorInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanConstructorInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

consDescriptor

Descriptor consDescriptor
包含此实例的元数据的 {@link Descriptor}

类 javax.management.modelmbean.ModelMBeanInfoSupport 继承 MBeanInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanInfoSupport。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanInfoSupport 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

modelMBeanAttributes

ModelMBeanAttributeInfo[] modelMBeanAttributes
带有描述符的 {@link ModelMBeanAttributeInfo} 对象数组

modelMBeanConstructors

MBeanConstructorInfo[] modelMBeanConstructors
带有描述符的 {@link ModelMBeanConstructorInfo} 对象数组

modelMBeanDescriptor

Descriptor modelMBeanDescriptor
包含 MBean 级策略的描述符

modelMBeanNotifications

MBeanNotificationInfo[] modelMBeanNotifications
带有描述符的 {@link ModelMBeanNotificationInfo} 对象数组

modelMBeanOperations

MBeanOperationInfo[] modelMBeanOperations
带有描述符的 {@link ModelMBeanOperationInfo} 对象数组

类 javax.management.modelmbean.ModelMBeanNotificationInfo 继承 MBeanNotificationInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanNotificationInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanNotificationInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

notificationDescriptor

Descriptor notificationDescriptor
包含此实例的适当元数据的描述符

类 javax.management.modelmbean.ModelMBeanOperationInfo 继承 MBeanOperationInfo 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 ModelMBeanOperationInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 ModelMBeanOperationInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

operationDescriptor

Descriptor operationDescriptor
包含此实例的适当元数据的描述符

类 javax.management.modelmbean.XMLParseException 继承 Exception 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 XMLParseException。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 XMLParseException 序列化为ObjectOutputStream。

抛出：
IOException
序列化字段
软件包 javax.management.monitor

类 javax.management.monitor.MonitorNotification 继承 Notification 实现 Serializable

serialVersionUID: -4608189663661929204L

序列化字段

observedObject

ObjectName observedObject
Monitor notification observed object.

observedAttribute

String observedAttribute
Monitor notification observed attribute.

derivedGauge

Object derivedGauge
Monitor notification derived gauge.

trigger

Object trigger
Monitor notification release mechanism.此值用来保留触发此通知的阈值/字符串（取决于监视器类型）。

类 javax.management.monitor.MonitorSettingException 继承 JMRuntimeException 实现 Serializable

serialVersionUID: -8807913418190202007L

软件包 javax.management.openmbean

类 javax.management.openmbean.ArrayType 继承 OpenType<T> 实现 Serializable

serialVersionUID: 720504429830309770L

序列化方法

readResolve

private Object readResolve()
                    throws ObjectStreamException
在从流中读取的对象返回到调用者之前对其进行替换和解析。

序列数据：
The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into primitive types before the deserialized ArrayType instance is return to the caller. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

Therefore the following serializable fields are deserialized as follows:

  • if primitiveArray is true the className field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
  • if primitiveArray is true the typeName field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "[[Ljava.lang.Integer;" will be deserialized as "[[I".
  • if primitiveArray is true the description field is deserialized by replacing the array's component primitive wrapper type by the corresponding array's component primitive type, e.g. "2-dimension array of java.lang.Integer" will be deserialized as "2-dimension array of int".
抛出：
ObjectStreamException
从以下版本开始：
1.6

writeReplace

private Object writeReplace()
                     throws ObjectStreamException
在流中的此对象被写入前制定一个替换对象。

序列数据：
The new serial form of this class defines a new serializable boolean field primitiveArray. In order to guarantee the interoperability with previous versions of this class the new serial form must continue to refer to primitive wrapper types even when the ArrayType instance describes a primitive type array. So when primitiveArray is true the className, typeName and description serializable fields are converted into wrapper types before the serialized ArrayType instance is written to the stream. The elementType field always returns the SimpleType corresponding to the primitive wrapper type of the array's primitive type.

Therefore the following serializable fields are serialized as follows:

  • if primitiveArray is true the className field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
  • if primitiveArray is true the typeName field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "[[I" will be serialized as "[[Ljava.lang.Integer;".
  • if primitiveArray is true the description field is serialized by replacing the array's component primitive type by the corresponding array's component primitive wrapper type, e.g. "2-dimension array of int" will be serialized as "2-dimension array of java.lang.Integer".
抛出：
ObjectStreamException
从以下版本开始：
1.6
序列化字段

dimension

int dimension
此 ArrayType 实例描述的数组的维度。

elementType

OpenType<T> elementType
此 ArrayType 实例描述的数组中包含的元素值的开放类型。

primitiveArray

boolean primitiveArray
This flag indicates whether this ArrayType describes a primitive array.
从以下版本开始：
1.6

类 javax.management.openmbean.CompositeDataSupport 继承 Object 实现 Serializable

serialVersionUID: 8003518976613702244L

序列化字段

contents

SortedMap<K,V> contents
它们各自值的项名称的映射关系的内部表示形式。SortedMap 用于较快速的元素检索。

compositeType

CompositeType compositeType
此复合数据 实例的复合类型。

类 javax.management.openmbean.CompositeType 继承 OpenType<CompositeData> 实现 Serializable

serialVersionUID: -5366242454346948798L

序列化字段

nameToDescription

TreeMap<K,V> nameToDescription
项名称到其描述的有序映射

nameToType

TreeMap<K,V> nameToType
项名称到其开放类型的有序映射

类 javax.management.openmbean.InvalidKeyException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: 4224269443946322062L

类 javax.management.openmbean.InvalidOpenTypeException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: -2837312755412327534L

类 javax.management.openmbean.KeyAlreadyExistsException 继承 IllegalArgumentException 实现 Serializable

serialVersionUID: 1845183636745282866L

类 javax.management.openmbean.OpenDataException 继承 JMException 实现 Serializable

serialVersionUID: 8346311255433349870L

类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 继承 MBeanAttributeInfo 实现 Serializable

serialVersionUID: -4867215622149721849L

序列化方法

readResolve

private Object readResolve()
在 Descriptor 被添加到此类之前，用此版本的 API 进行序列化的对象的 Descriptor 将为空或 null。 为了与此版本的操作保持一致，必须使用另一个对象取代该对象，用来取代的那个对象的 Descriptor 应该反映 openType、defaultValue 等等的值。

序列化字段

openType

OpenType<T> openType
open mbean 属性的开放类型

defaultValue

Object defaultValue
open mbean 属性的默认值

legalValues

Set<E> legalValues
open mbean 属性的合法值。此 Set 是不可修改的。

minValue

Comparable<T> minValue
open mbean 属性的最小值

maxValue

Comparable<T> maxValue
open mbean 属性的最大值

类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 继承 MBeanConstructorInfo 实现 Serializable

serialVersionUID: -4400441579007477003L

类 javax.management.openmbean.OpenMBeanInfoSupport 继承 MBeanInfo 实现 Serializable

serialVersionUID: 4349395935420511492L

类 javax.management.openmbean.OpenMBeanOperationInfoSupport 继承 MBeanOperationInfo 实现 Serializable

serialVersionUID: 4996859732565369366L

序列化方法

readResolve

private Object readResolve()
An object serialized in a version of the API before Descriptors were added to this class will have an empty or null Descriptor. For consistency with our behavior in this version, we must replace the object with one where the Descriptors reflect the same value of returned openType.

序列化字段

returnOpenType

OpenType<T> returnOpenType
此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。

类 javax.management.openmbean.OpenMBeanParameterInfoSupport 继承 MBeanParameterInfo 实现 Serializable

serialVersionUID: -7235016873758443122L

序列化方法

readResolve

private Object readResolve()
在 Descriptor 被添加到此类之前，用此版本的 API 进行序列化的对象的 Descriptor 将为空或 null。为了与此版本的操作保持一致，必须使用另一个对象取代该对象，用来取代的那个对象的 Descriptor 应该反映 openType、defaultValue 等等的值。

序列化字段

openType

OpenType<T> openType
open mbean 参数的开放类型

defaultValue

Object defaultValue
open mbean 参数的默认值

legalValues

Set<E> legalValues
open mbean 参数的合法值。此 Set 是不可修改的。

minValue

Comparable<T> minValue
open mbean 参数的最小值

maxValue

Comparable<T> maxValue
open mbean 参数的最大值

类 javax.management.openmbean.OpenType 继承 Object 实现 Serializable

serialVersionUID: -9195195325186646468L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 java.io.OpenType。

抛出：
IOException
ClassNotFoundException
序列化字段

className

String className
此类型描述的开放数据值的完全限定的 Java 类名。

description

String description
类型描述（不应为 null 或空）。

typeName

String typeName
为此类型提供的名称（不应为 null 或空）。

类 javax.management.openmbean.SimpleType 继承 OpenType<T> 实现 Serializable

serialVersionUID: 2215577471957694503L

序列化方法

readResolve

public Object readResolve()
                   throws ObjectStreamException
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。

抛出：
ObjectStreamException - 如果读取对象不能被解析。

类 javax.management.openmbean.TabularDataSupport 继承 Object 实现 Serializable

serialVersionUID: 5720150593236309827L

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 TabularDataSupport。

抛出：
IOException
ClassNotFoundException
序列化字段

dataMap

Map<K,V> dataMap
此表格数据实例的内容：一个 HashMap

tabularType

TabularType tabularType
此表格数据实例的表格类型

类 javax.management.openmbean.TabularType 继承 OpenType<TabularData> 实现 Serializable

serialVersionUID: 6554071860220659261L

序列化字段

rowType

CompositeType rowType
行的复合类型

indexNames

List<E> indexNames
用于索引每个行元素的项，它保持用户给定的顺序。这是一个不可修改的 ArrayList
软件包 javax.management.relation

类 javax.management.relation.InvalidRelationIdException 继承 RelationException 实现 Serializable

serialVersionUID: -7115040321202754171L

类 javax.management.relation.InvalidRelationServiceException 继承 RelationException 实现 Serializable

serialVersionUID: 3400722103759507559L

类 javax.management.relation.InvalidRelationTypeException 继承 RelationException 实现 Serializable

serialVersionUID: 3007446608299169961L

类 javax.management.relation.InvalidRoleInfoException 继承 RelationException 实现 Serializable

serialVersionUID: 7517834705158932074L

类 javax.management.relation.InvalidRoleValueException 继承 RelationException 实现 Serializable

serialVersionUID: -2066091747301983721L

类 javax.management.relation.MBeanServerNotificationFilter 继承 NotificationFilterSupport 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 MBeanServerNotificationFilter。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 MBeanServerNotificationFilter 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

deselectedNames

List<E> deselectedNames
List of {@link ObjectName}s with no interest
  • null 意味着隐式地取消选中所有 {@link ObjectName}（复选表示显式选择）
  • 空向量意味着没有任何 {@link ObjectName} 被显式取消选中。

selectedNames

List<E> selectedNames
List of {@link ObjectName}s of interest
  • null 意味着隐式选中所有 {@link ObjectName}（复选表示显式取消选择）
  • 空向量意味着没有任何 {@link ObjectName} 被显式选中。

类 javax.management.relation.RelationException 继承 JMException 实现 Serializable

serialVersionUID: 5434016005679159613L

类 javax.management.relation.RelationNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: -3793951411158559116L

类 javax.management.relation.RelationNotification 继承 Notification 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RelationNotification。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RelationNotification 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

newRoleValue

List<E> newRoleValue
New role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

oldRoleValue

List<E> oldRoleValue
Old role value ({@link ArrayList} of {@link ObjectName}s) (only for role update)

relationId

String relationId
Relation identifier of created/removed/updated relation

relationObjName

ObjectName relationObjName
{@link ObjectName} of the relation MBean of created/removed/updated relation (only if the relation is represented by an MBean)

relationTypeName

String relationTypeName
Relation type name of created/removed/updated relation

roleName

String roleName
Name of updated role (only for role update)

unregisterMBeanList

List<E> unregisterMBeanList
List of {@link ObjectName}s of referenced MBeans to be unregistered due to relation removal

类 javax.management.relation.RelationServiceNotRegisteredException 继承 RelationException 实现 Serializable

serialVersionUID: 8454744887157122910L

类 javax.management.relation.RelationTypeNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: 1274155316284300752L

类 javax.management.relation.RelationTypeSupport 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RelationTypeSupport。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RelationTypeSupport 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

isInRelationService

boolean isInRelationService
Flag specifying whether the relation type has been declared in the Relation Service (so can no longer be updated)

roleName2InfoMap

Map<K,V> roleName2InfoMap
{@link Map} holding the mapping: <role name ({@link String})> -> <role info ({@link RoleInfo} object)>

typeName

String typeName
Relation type name

类 javax.management.relation.Role 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 Role。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 Role 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

name

String name
Role name

objectNameList

List<E> objectNameList
{@link List} of {@link ObjectName}s of referenced MBeans

类 javax.management.relation.RoleInfo 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RoleInfo。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RoleInfo 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

description

String description
Role description

isReadable

boolean isReadable
Read access mode: true if role is readable

isWritable

boolean isWritable
Write access mode: true if role is writable

maxDegree

int maxDegree
Maximum degree (i.e. maximum number of referenced MBeans in corresponding role)

minDegree

int minDegree
Minimum degree (i.e. minimum number of referenced MBeans in corresponding role)

name

String name
Role name

referencedMBeanClassName

String referencedMBeanClassName
Name of class of MBean(s) expected to be referenced in corresponding role

类 javax.management.relation.RoleInfoNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: 4394092234999959939L

类 javax.management.relation.RoleList 继承 ArrayList<Object> 实现 Serializable

serialVersionUID: 5568344346499649313L

类 javax.management.relation.RoleNotFoundException 继承 RelationException 实现 Serializable

serialVersionUID: -2986406101364031481L

类 javax.management.relation.RoleResult 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RoleResult。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RoleResult 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

roleList

RoleList roleList
List of roles successfully accessed

unresolvedRoleList

RoleUnresolvedList unresolvedRoleList
List of roles unsuccessfully accessed

类 javax.management.relation.RoleUnresolved 继承 Object 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream in)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 反序列化 RoleUnresolved。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream out)
                  throws IOException
将 RoleUnresolved 序列化为 ObjectOutputStream。

抛出：
IOException
序列化字段

problemType

int problemType
Problem type

roleName

String roleName
Role name

roleValue

List<E> roleValue
Role value ({@link List} of {@link ObjectName} objects)

类 javax.management.relation.RoleUnresolvedList 继承 ArrayList<Object> 实现 Serializable

serialVersionUID: 4054902803091433324L

软件包 javax.management.remote

类 javax.management.remote.JMXConnectionNotification 继承 Notification 实现 Serializable

serialVersionUID: -2331308725952627538L

序列化字段

connectionId

String connectionId
The connection ID to which this notification pertains.
另请参见：
JMXConnectionNotification.getConnectionId()

类 javax.management.remote.JMXPrincipal 继承 Object 实现 Serializable

serialVersionUID: -4184480100214577411L

序列化字段

name

String name
The JMX Remote API name for the identity represented by this JMXPrincipal object.
另请参见：
JMXPrincipal.getName()

类 javax.management.remote.JMXProviderException 继承 IOException 实现 Serializable

serialVersionUID: -3166703627550447198L

序列化字段

cause

Throwable cause
An exception that caused this exception to be thrown.此字段可以为 null。
另请参见：
JMXProviderException.getCause()

类 javax.management.remote.JMXServerErrorException 继承 IOException 实现 Serializable

serialVersionUID: 3996732239558744666L

序列化字段

cause

Error cause
An Error that caused this exception to be thrown.
另请参见：
JMXServerErrorException.getCause()

类 javax.management.remote.JMXServiceURL 继承 Object 实现 Serializable

serialVersionUID: 8173364409860779292L

序列化字段

protocol

String protocol
由 JMXServiceURL.getProtocol() 返回的值。

host

String host
由 JMXServiceURL.getHost() 返回的值。

port

int port
由 JMXServiceURL.getPort() 返回的值。

urlPath

String urlPath
由 JMXServiceURL.getURLPath() 返回的值。

类 javax.management.remote.NotificationResult 继承 Object 实现 Serializable

serialVersionUID: 1191800228721395279L

序列化字段

earliestSequenceNumber

long earliestSequenceNumber

nextSequenceNumber

long nextSequenceNumber

targetedNotifications

TargetedNotification[] targetedNotifications

类 javax.management.remote.SubjectDelegationPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 1481618113008682343L

类 javax.management.remote.TargetedNotification 继承 Object 实现 Serializable

serialVersionUID: 7676132089779300926L

序列化字段

notif

Notification notif
A notification to transmit to the other side.
另请参见：
TargetedNotification.getNotification()

id

Integer id
The ID of the listener to which the notification is targeted.
另请参见：
TargetedNotification.getListenerID()
软件包 javax.management.remote.rmi

类 javax.management.remote.rmi._RMIConnection_Stub 继承 Stub 实现 Serializable

类 javax.management.remote.rmi._RMIServer_Stub 继承 Stub 实现 Serializable

类 javax.management.remote.rmi.RMIConnectionImpl_Stub 继承 RemoteStub 实现 Serializable

serialVersionUID: 2L

类 javax.management.remote.rmi.RMIConnectionImpl$6 继承 Object 实现 Serializable

类 javax.management.remote.rmi.RMIConnectionImpl$7 继承 Object 实现 Serializable

类 javax.management.remote.rmi.RMIConnector 继承 Object 实现 Serializable

serialVersionUID: 817323035842634473L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从 ObjectInputStream 读入 RMIConnector 字段。调用 s.defaultReadObject() 并接着初始化所有需要初始化的中间变量。

抛出：
InvalidObjectException - 如果 rmiServer stub 或 jmxServiceURL 均未设置。
IOException
ClassNotFoundException
另请参见：
RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 RMIConnector 字段写入到 ObjectOutputStream。

如果需要的话，在初始化之前，将基础 RMIServer stub 连接到一个 ORB。通过使用为构造方法提供的环境映射（如果有）来完成此连接，如在 javax.management.remote.rmi 中描述的那样。

然后此方法调用 s.defaultWriteObject()。通常，如果此对象是使用 JMXServiceURL 构造的，则 rmiServer 为 null，如果此对象是使用 RMIServer stub 构造的，则 jmxServiceURL 为 null。

注意，环境 Map 并未序列化，因为假定它包含的对象只对于本地环境（类加载器、ORB，等等）而言是上下文相关的。

对 RMIConnector 反序列化后，假定用户将调用 RMIConnector.connect(Map)，则它提供了一个包含与新本地环境上下文相关的值的 Map。

由于在序列化之前需要连接到 ORB，并且要连接到的 ORB 为上下文相关的参数之一，不建议对刚刚序列化过的对象重新序列化，因为反序列化的对象不具有映射。因此，需要将一个 RMIConnector 对象序列化或传输到一个远程应用程序时，建议通过调用 RMIConnectorServer.toJMXConnector(Map) 获得新的 RMIConnector stub。

抛出：
InvalidObjectException - 如果 rmiServer stub 或 jmxServiceURL 均未设置。
IOException
另请参见：
RMIConnector.RMIConnector(JMXServiceURL,Map), RMIConnector.RMIConnector(RMIServer,Map)
序列化字段

rmiServer

RMIServer rmiServer
The RMIServer stub of the RMI JMX Connector server to which this client connector is (or will be) connected.当 jmxServiceURL 不为 null 时，此字段可以为 null。这包括了 jmxServiceURL 包含序列化的 RMIServer stub 的情况。如果 rmiServer 和 jmxServiceURL 都为 null，则序列化将失败。
另请参见：
RMIConnector.RMIConnector(RMIServer,Map)

jmxServiceURL

JMXServiceURL jmxServiceURL
The JMXServiceURL of the RMI JMX Connector server to which this client connector will be connected.当 rmiServer 不为 null 时，此字段可以为 null。如果 rmiServer 和 jmxServiceURL 都为 null，则序列化将失败。
另请参见：
RMIConnector.RMIConnector(JMXServiceURL,Map)

类 javax.management.remote.rmi.RMIServerImpl_Stub 继承 RemoteStub 实现 Serializable

serialVersionUID: 2L

软件包 javax.management.timer

类 javax.management.timer.TimerNotification 继承 Notification 实现 Serializable

serialVersionUID: 1798492029603825750L

序列化字段

notificationID

Integer notificationID
Timer notification identifier.此标识符用来从通知的计时器列表中检索计时器通知。
软件包 javax.naming

类 javax.naming.AuthenticationException 继承 NamingSecurityException 实现 Serializable

serialVersionUID: 3678497619904568096L

类 javax.naming.AuthenticationNotSupportedException 继承 NamingSecurityException 实现 Serializable

serialVersionUID: -7149033933259492300L

类 javax.naming.BinaryRefAddr 继承 RefAddr 实现 Serializable

serialVersionUID: -3415254970957330361L

序列化字段

buf

byte[] buf
包含地址字节。此字段由构造方法初始化，并使用 getAddressBytes() 和 getAddressContents() 返回。

类 javax.naming.Binding 继承 NameClassPair 实现 Serializable

serialVersionUID: 8839217842691845890L

序列化字段

boundObj

Object boundObj
包含此绑定的对象。它由构造方法初始化，可以使用 setObject 更新。

另请参见：
Binding.getObject(), Binding.setObject(java.lang.Object)

类 javax.naming.CannotProceedException 继承 NamingException 实现 Serializable

serialVersionUID: 1219724816191576813L

序列化字段

remainingNewName

Name remainingNewName
包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。此信息对于继续 Context.rename() 操作是必需的。

此字段被初始化为 null。不应该直接操作它：应该使用 getRemainingName() 和 setRemainingName() 访问和更新。

另请参见：
CannotProceedException.getRemainingNewName(), CannotProceedException.setRemainingNewName(javax.naming.Name)

environment

Hashtable<K,V> environment
包含与无法继续进行的 Context 或 DirContext 方法有关的环境。

此字段被初始化为 null。不应该直接操作它：应该使用 getEnvironment() 和 setEnvironment() 访问和更新。

另请参见：
CannotProceedException.getEnvironment(), CannotProceedException.setEnvironment(java.util.Hashtable)

altName

Name altName
包含已解析对象的名称，该名称相对于上下文 altNameCtx。该名称是一个复合名称。如果为 null，则不指定任何名称。有关如何使用此方法的详细信息，请参见 javax.naming.spi.ObjectFactory.getObjectInstance 方法。

此字段被初始化为 null。不应该直接操作它：应该使用 getAltName() 和 setAltName() 访问和更新。

另请参见：
CannotProceedException.getAltName(), CannotProceedException.setAltName(javax.naming.Name), CannotProceedException.altNameCtx, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

altNameCtx

Context altNameCtx
包含上下文，altName 是相对于该上下文指定的。如果为 null，则暗指默认初始上下文。有关如何使用此方法的详细信息，请参见 javax.naming.spi.ObjectFactory.getObjectInstance 方法。

此字段被初始化为 null。不应该直接操作它：应该使用 getAltNameCtx() 和 setAltNameCtx() 访问和更新。

另请参见：
CannotProceedException.getAltNameCtx(), CannotProceedException.setAltNameCtx(javax.naming.Context), CannotProceedException.altName, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

类 javax.naming.CommunicationException 继承 NamingException 实现 Serializable

serialVersionUID: 3618507780299986611L

类 javax.naming.CompositeName 继承 Object 实现 Serializable

serialVersionUID: 1667768148915813118L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免存在实现依赖关系。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免存在实现依赖关系。

序列数据：
个别组件后跟着的组件数（一个 int），每个组件都是一个 String。
抛出：
IOException

类 javax.naming.CompoundName 继承 Object 实现 Serializable

serialVersionUID: 3513100557083972036L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免存在实现依赖关系。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免存在实现依赖关系。

序列数据：
语法 Properties，后跟组件数（一个 int），以及个别组件，每个组件都是一个 String。
抛出：
IOException

类 javax.naming.ConfigurationException 继承 NamingException 实现 Serializable

serialVersionUID: -2535156726228855704L

类 javax.naming.ContextNotEmptyException 继承 NamingException 实现 Serializable

serialVersionUID: 1090963683348219877L

类 javax.naming.InsufficientResourcesException 继承 NamingException 实现 Serializable

serialVersionUID: 6227672693037844532L

类 javax.naming.InterruptedNamingException 继承 NamingException 实现 Serializable

serialVersionUID: 6404516648893194728L

类 javax.naming.InvalidNameException 继承 NamingException 实现 Serializable

serialVersionUID: -8370672380823801105L

类 javax.naming.LimitExceededException 继承 NamingException 实现 Serializable

serialVersionUID: -776898738660207856L

类 javax.naming.LinkException 继承 NamingException 实现 Serializable

serialVersionUID: -7967662604076777712L

序列化字段

linkResolvedName

Name linkResolvedName
包含已成功解析的链接部分。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkResolvedName(), LinkException.setLinkResolvedName(javax.naming.Name)

linkResolvedObj

Object linkResolvedObj
包含一个对象，已成功解析的链接部分一直到达该对象。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkResolvedObj(), LinkException.setLinkResolvedObj(java.lang.Object)

linkRemainingName

Name linkRemainingName
包含尚未解析的剩余链接名称。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkRemainingName(), LinkException.setLinkRemainingName(javax.naming.Name)

linkExplanation

String linkExplanation
包含链接解析失败原因的异常。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
LinkException.getLinkExplanation(), LinkException.setLinkExplanation(java.lang.String)

类 javax.naming.LinkLoopException 继承 LinkException 实现 Serializable

serialVersionUID: -3119189944325198009L

类 javax.naming.LinkRef 继承 Reference 实现 Serializable

serialVersionUID: -5386290613498931298L

类 javax.naming.MalformedLinkException 继承 LinkException 实现 Serializable

serialVersionUID: -3066740437737830242L

类 javax.naming.NameAlreadyBoundException 继承 NamingException 实现 Serializable

serialVersionUID: -8491441000356780586L

类 javax.naming.NameClassPair 继承 Object 实现 Serializable

serialVersionUID: 5620776610160863339L

序列化字段

name

String name
包含此 NameClassPair 的名称。它由构造方法初始化，可以使用 setName() 更新。

另请参见：
NameClassPair.getName(), NameClassPair.setName(java.lang.String)

className

String className
包含此 NameClassPair 中包含的类名称。它由构造方法初始化，可以使用 setClassName() 更新。

另请参见：
NameClassPair.getClassName(), NameClassPair.setClassName(java.lang.String)

fullName

String fullName
包含其自己的名称空间中此 NameClassPair 的完全名称。它使用 setNameInNamespace() 初始化

另请参见：
NameClassPair.getNameInNamespace(), NameClassPair.setNameInNamespace(java.lang.String)

isRel

boolean isRel
记录此 NameClassPair 的名称是否相对于目标上下文。它由构造方法初始化，可以使用 setRelative() 更新。

另请参见：
NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.getName(),
NameClassPair.setName(java.lang.String)

类 javax.naming.NameNotFoundException 继承 NamingException 实现 Serializable

serialVersionUID: -8007156725367842053L

类 javax.naming.NamingException 继承 Exception 实现 Serializable

serialVersionUID: -1299181962103167177L

序列化字段

resolvedName

Name resolvedName
包含已成功解析的名称部分。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
NamingException.getResolvedName(), NamingException.setResolvedName(javax.naming.Name)

resolvedObj

Object resolvedObj
包含一个对象，已成功解析的名称部分进行到该对象。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
NamingException.getResolvedObj(), NamingException.setResolvedObj(java.lang.Object)

remainingName

Name remainingName
包含尚未解析的剩余名称。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get、set 和 "append" 方法访问和操作此字段。

另请参见：
NamingException.getRemainingName(),
NamingException.setRemainingName(javax.naming.Name),
NamingException.appendRemainingName(javax.naming.Name),
NamingException.appendRemainingComponent(java.lang.String)

rootException

Throwable rootException
包含导致抛出此 NamingException 的原始异常。如果存在可以从原始异常中获得的附加信息，或者无法将原始异常映射到 NamingException 的子类，则设置此字段。可以为 null。

此字段早于通用异常链设施。NamingException.initCause(Throwable) 和 NamingException.getCause() 方法现在是访问此信息的首选方法。

另请参见：
NamingException.getRootCause(),
NamingException.setRootCause(Throwable),
NamingException.initCause(Throwable),
NamingException.getCause()

类 javax.naming.NamingSecurityException 继承 NamingException 实现 Serializable

serialVersionUID: 5855287647294685775L

类 javax.naming.NoInitialContextException 继承 NamingException 实现 Serializable

serialVersionUID: -3413733186901258623L

类 javax.naming.NoPermissionException 继承 NamingSecurityException 实现 Serializable

serialVersionUID: 8395332708699751775L

类 javax.naming.NotContextException 继承 NamingException 实现 Serializable

serialVersionUID: 849752551644540417L

类 javax.naming.OperationNotSupportedException 继承 NamingException 实现 Serializable

serialVersionUID: 5493232822427682064L

类 javax.naming.PartialResultException 继承 NamingException 实现 Serializable

serialVersionUID: 2572144970049426786L

类 javax.naming.RefAddr 继承 Object 实现 Serializable

serialVersionUID: -1468165120479154358L

序列化字段

addrType

String addrType
包含此地址的类型。

类 javax.naming.Reference 继承 Object 实现 Serializable

serialVersionUID: -1673475790065791735L

序列化字段

className

String className
包含此 Reference 所引用的对象类的完全限定名称。

另请参见：
Class.getName()

addrs

Vector<E> addrs
包含此 Reference 中所包含的地址。由构造方法初始化。

classFactory

String classFactory
包含用来创建此 Reference 所引用的对象实例的工厂类名称。被初始化为 null。

classFactoryLocation

String classFactoryLocation
包含工厂类的位置。被初始化为 null。

类 javax.naming.ReferralException 继承 NamingException 实现 Serializable

serialVersionUID: -2881363844695698876L

类 javax.naming.ServiceUnavailableException 继承 NamingException 实现 Serializable

serialVersionUID: -4996964726566773444L

类 javax.naming.SizeLimitExceededException 继承 LimitExceededException 实现 Serializable

serialVersionUID: 7129289564879168579L

类 javax.naming.StringRefAddr 继承 RefAddr 实现 Serializable

serialVersionUID: -8913762495138505527L

序列化字段

contents

String contents
包含此地址的内容。可以为 null。

类 javax.naming.TimeLimitExceededException 继承 LimitExceededException 实现 Serializable

serialVersionUID: -3597009011385034696L

软件包 javax.naming.directory

类 javax.naming.directory.AttributeInUseException 继承 NamingException 实现 Serializable

serialVersionUID: 4437710305529322564L

类 javax.naming.directory.AttributeModificationException 继承 NamingException 实现 Serializable

serialVersionUID: 8060676069678710186L

序列化字段

unexecs

ModificationItem[] unexecs
包含未执行修改的可能为 null 的列表。

类 javax.naming.directory.BasicAttribute 继承 Object 实现 Serializable

serialVersionUID: 6743528196119291326L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免公开实现细节。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免公开实现细节

序列数据：
Default field (the attribute ID -- a String), followed by the number of values (an int), and the individual values.
抛出：
IOException
序列化字段

attrID

String attrID
保存属性的 id。其由公共构造方法初始化且不能为 null，除非已经重写 BasicAttribute 中使用 attrID 的方法。

ordered

boolean ordered
记录此属性的值是否有序的标志。

类 javax.naming.directory.BasicAttributes 继承 Object 实现 Serializable

serialVersionUID: 4980164073184639448L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
重写以避免公开实现细节。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
重写以避免公开实现细节。

序列数据：
Default field (ignoreCase flag -- a boolean), followed by the number of attributes in the set (an int), and then the individual Attribute objects.
抛出：
IOException
序列化字段

ignoreCase

boolean ignoreCase
指示是否忽略属性 id 的大小写。

类 javax.naming.directory.InvalidAttributeIdentifierException 继承 NamingException 实现 Serializable

serialVersionUID: -9036920266322999923L

类 javax.naming.directory.InvalidAttributesException 继承 NamingException 实现 Serializable

serialVersionUID: 2607612850539889765L

类 javax.naming.directory.InvalidAttributeValueException 继承 NamingException 实现 Serializable

serialVersionUID: 8720050295499275011L

类 javax.naming.directory.InvalidSearchControlsException 继承 NamingException 实现 Serializable

serialVersionUID: -5124108943352665777L

类 javax.naming.directory.InvalidSearchFilterException 继承 NamingException 实现 Serializable

serialVersionUID: 2902700940682875441L

类 javax.naming.directory.ModificationItem 继承 Object 实现 Serializable

serialVersionUID: 7573258562534746850L

序列化字段

mod_op

int mod_op
包含标识要执行的修改的整数。

attr

Attribute attr
包含标识要应用于修改的属性和/或其值的属性。

类 javax.naming.directory.NoSuchAttributeException 继承 NamingException 实现 Serializable

serialVersionUID: 4836415647935888137L

类 javax.naming.directory.SchemaViolationException 继承 NamingException 实现 Serializable

serialVersionUID: -3041762429525049663L

类 javax.naming.directory.SearchControls 继承 Object 实现 Serializable

serialVersionUID: -2480540967773454797L

序列化字段

searchScope

int searchScope
包含应用搜索的范围。ONELEVEL_SCOPE、OBJECT_SCOPE 或 SUBTREE_SCOPE 之一。

timeLimit

int timeLimit
包含从搜索返回前要等待的毫秒数。

derefLink

boolean derefLink
指示在搜索期间是否取消对 JNDI 链接的引用。

returnObj

boolean returnObj
指示是否在 SearchResult 中返回对象。

countLimit

long countLimit
包含要返回的最大 SearchResults 数。

attributesToReturn

String[] attributesToReturn
包含要为搜索的每个匹配项在 SearchResult 中返回的属性所组成的列表。null 指示要返回所有属性。

类 javax.naming.directory.SearchResult 继承 Binding 实现 Serializable

serialVersionUID: -9158063327699723172L

序列化字段

attrs

Attributes attrs
包含与对象一起返回的属性。

软件包 javax.naming.event

类 javax.naming.event.NamingEvent 继承 EventObject 实现 Serializable

serialVersionUID: -7126752885365133499L

序列化字段

changeInfo

Object changeInfo
包含关于生成此事件的更改的信息。

type

int type
包含此事件的类型。

另请参见：
NamingEvent.OBJECT_ADDED, NamingEvent.OBJECT_REMOVED, NamingEvent.OBJECT_RENAMED, NamingEvent.OBJECT_CHANGED

oldBinding

Binding oldBinding
包含关于更改前对象的信息。

newBinding

Binding newBinding
包含关于更改后对象的信息。

类 javax.naming.event.NamingExceptionEvent 继承 EventObject 实现 Serializable

serialVersionUID: -4877678086134736336L

序列化字段

exception

NamingException exception
包含抛出过的异常

软件包 javax.naming.ldap

类 javax.naming.ldap.BasicControl 继承 Object 实现 Serializable

serialVersionUID: -4233907508771791687L

序列化字段

id

String id
控件的对象标识符字符串。

criticality

boolean criticality
控件的关键性。

value

byte[] value
控件的 ASN.1 BER 编码值。

类 javax.naming.ldap.LdapName 继承 Object 实现 Serializable

serialVersionUID: -1595520034788997356L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
仅序列化未解析的 DN，以更紧密并避免任何实现依赖关系。

序列数据：
The DN string
抛出：
IOException

类 javax.naming.ldap.LdapReferralException 继承 ReferralException 实现 Serializable

serialVersionUID: -1668992791764950804L

类 javax.naming.ldap.ManageReferralControl 继承 BasicControl 实现 Serializable

serialVersionUID: 3017756160149982566L

类 javax.naming.ldap.PagedResultsControl 继承 BasicControl 实现 Serializable

serialVersionUID: 6684806685736844298L

类 javax.naming.ldap.PagedResultsResponseControl 继承 BasicControl 实现 Serializable

serialVersionUID: -8819778744844514666L

序列化字段

resultSize

int resultSize
搜索结果中的项数的估计值。

cookie

byte[] cookie
服务器生成的 cookie。

类 javax.naming.ldap.Rdn 继承 Object 实现 Serializable

serialVersionUID: -5994465067210009656L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
仅序列化未解析的 RDN，以更紧密并避免任何实现依赖关系。

序列数据：
The RDN string
抛出：
IOException

类 javax.naming.ldap.SortControl 继承 BasicControl 实现 Serializable

serialVersionUID: -1965961680233330744L

类 javax.naming.ldap.SortResponseControl 继承 BasicControl 实现 Serializable

serialVersionUID: 5142939176006310877L

序列化字段

resultCode

int resultCode
排序结果代码。

badAttrId

String badAttrId
导致排序失败的属性的 ID。

类 javax.naming.ldap.StartTlsRequest 继承 Object 实现 Serializable

serialVersionUID: 4441679576360753397L

类 javax.naming.ldap.StartTlsResponse 继承 Object 实现 Serializable

serialVersionUID: 8372842182579276418L

类 javax.naming.ldap.UnsolicitedNotificationEvent 继承 EventObject 实现 Serializable

serialVersionUID: -2382603380799883705L

序列化字段

notice

UnsolicitedNotification notice
导致触发此事件的通知。

软件包 javax.naming.spi

类 javax.naming.spi.ResolveResult 继承 Object 实现 Serializable

serialVersionUID: -4552108072002407559L

序列化字段

resolvedObj

Object resolvedObj
该字段包含已成功解析成的 Object。它只在使用子类构造时可以为 null。构造方法应该总是初始化此字段。

remainingName

Name remainingName
该字段包含要解析的剩余名称。它只在使用子类构造时可以为 null。构造方法应该总是初始化此字段。

软件包 javax.net.ssl

类 javax.net.ssl.HandshakeCompletedEvent 继承 EventObject 实现 Serializable

类 javax.net.ssl.SSLException 继承 IOException 实现 Serializable

类 javax.net.ssl.SSLHandshakeException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLKeyException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLPeerUnverifiedException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLPermission 继承 BasicPermission 实现 Serializable

类 javax.net.ssl.SSLProtocolException 继承 SSLException 实现 Serializable

类 javax.net.ssl.SSLSessionBindingEvent 继承 EventObject 实现 Serializable

序列化字段

name

String name
将对象绑定到的或从其解除绑定的名称

类 javax.net.ssl.SSLSocketFactory$1 继承 Object 实现 Serializable

软件包 javax.print

类 javax.print.DocFlavor 继承 Object 实现 Serializable

serialVersionUID: -4512080796965449721L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
根据流重构实例（也就是将其反序列化）。

序列数据：
DocFlavor 的序列化形式是名称为表示形式类的 String，后跟表示 MIME 类型规范形式的 String。
抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将实例写入流中（也就是序列化该对象）。

抛出：
IOException
序列化字段

myClassName

String myClassName
表示形式类名。

类 javax.print.DocFlavor.BYTE_ARRAY 继承 DocFlavor 实现 Serializable

serialVersionUID: -9065578006593857475L

类 javax.print.DocFlavor.CHAR_ARRAY 继承 DocFlavor 实现 Serializable

serialVersionUID: -8720590903724405128L

类 javax.print.DocFlavor.INPUT_STREAM 继承 DocFlavor 实现 Serializable

serialVersionUID: -7045842700749194127L

类 javax.print.DocFlavor.READER 继承 DocFlavor 实现 Serializable

serialVersionUID: 7100295812579351567L

类 javax.print.DocFlavor.SERVICE_FORMATTED 继承 DocFlavor 实现 Serializable

serialVersionUID: 6181337766266637256L

类 javax.print.DocFlavor.STRING 继承 DocFlavor 实现 Serializable

serialVersionUID: 4414407504887034035L

类 javax.print.DocFlavor.URL 继承 DocFlavor 实现 Serializable

类 javax.print.PrintException 继承 Exception 实现 Serializable

软件包 javax.print.attribute

类 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 继承 Object 实现 Serializable

序列化字段

attrset

AttributeSet attrset

类 javax.print.attribute.AttributeSetUtilities.SynchronizedDocAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.SynchronizedPrintJobAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.SynchronizedPrintRequestAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.SynchronizedPrintServiceAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.SynchronizedAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 继承 Object 实现 Serializable

序列化字段

attrset

AttributeSet attrset

类 javax.print.attribute.AttributeSetUtilities.UnmodifiableDocAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintJobAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintRequestAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.AttributeSetUtilities.UnmodifiablePrintServiceAttributeSet 继承 javax.print.attribute.AttributeSetUtilities.UnmodifiableAttributeSet 实现 Serializable

类 javax.print.attribute.DateTimeSyntax 继承 Object 实现 Serializable

serialVersionUID: -1400819079791208582L

序列化字段

value

Date value
此日期-时间属性的 java.util.Date 值。

类 javax.print.attribute.EnumSyntax 继承 Object 实现 Serializable

serialVersionUID: -2739521845085831642L

序列化方法

readResolve

protected Object readResolve()
                      throws ObjectStreamException
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。

抛出：
ObjectStreamException - 如果无法对流反序列化
InvalidObjectException - 如果枚举值表为 null，此枚举值的整数值与枚举值表中的元素不对应，或枚举值表中的对应元素为 null，则抛出该异常。（注：InvalidObjectException 是 ObjectStreamException 的一个子类，ObjectStreamException 由 readResolve() 声明抛出。
序列化字段

value

int value
此枚举值的整数值。

类 javax.print.attribute.HashAttributeSet 继承 Object 实现 Serializable

serialVersionUID: 5311560590283707917L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws ClassNotFoundException,
                        IOException
从流重构一个实例（也就是将其反序列化）。

抛出：
ClassNotFoundException
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将该实例写入到流（即：将该对象序列化）

序列数据：
属性集的序列化形式显式写入该集合中的属性的数量和每个属性。这不保证序列化形式的相等性，因为未定义写入属性的顺序。
抛出：
IOException
序列化字段

myInterface

Class<T> myInterface
此属性集的所有成员必须是其实例的接口。假设是接口 Attribute 或其子接口。

类 javax.print.attribute.HashDocAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: -1128534486061432528L

类 javax.print.attribute.HashPrintJobAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: -4204473656070350348L

类 javax.print.attribute.HashPrintRequestAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: 2364756266107751933L

类 javax.print.attribute.HashPrintServiceAttributeSet 继承 HashAttributeSet 实现 Serializable

serialVersionUID: 6642904616179203070L

类 javax.print.attribute.IntegerSyntax 继承 Object 实现 Serializable

serialVersionUID: 3644574816328081943L

序列化字段

value

int value
此整数属性的整数值。

类 javax.print.attribute.ResolutionSyntax 继承 Object 实现 Serializable

serialVersionUID: 2706743076526672017L

序列化字段

crossFeedResolution

int crossFeedResolution
以每 100 英寸点数 (dphi) 为单位的反向进纸分辨率。

feedResolution

int feedResolution
以每 100 英寸点数 (dphi) 为单位的进纸分辨率。

类 javax.print.attribute.SetOfIntegerSyntax 继承 Object 实现 Serializable

serialVersionUID: 3666874174847632203L

序列化字段

members

int[][] members
规范数组形式表示的此集合的成员。

类 javax.print.attribute.Size2DSyntax 继承 Object 实现 Serializable

serialVersionUID: 5584439964938660530L

序列化字段

x

int x
以微米 (µm) 为单位的 X 维度。

y

int y
以微米 (µm) 为单位的 Y 维度。

类 javax.print.attribute.TextSyntax 继承 Object 实现 Serializable

serialVersionUID: -8130648736378144102L

序列化字段

value

String value
此文本属性的字符串值。

locale

Locale locale
此文本属性的语言环境。

类 javax.print.attribute.UnmodifiableSetException 继承 RuntimeException 实现 Serializable

类 javax.print.attribute.URISyntax 继承 Object 实现 Serializable

serialVersionUID: -7842661210486401678L

序列化字段

uri

URI uri
此 URI 属性的 URI 值。

软件包 javax.print.attribute.standard

类 javax.print.attribute.standard.Chromaticity 继承 EnumSyntax 实现 Serializable

serialVersionUID: 4660543931355214012L

类 javax.print.attribute.standard.ColorSupported 继承 EnumSyntax 实现 Serializable

serialVersionUID: -2700555589688535545L

类 javax.print.attribute.standard.Compression 继承 EnumSyntax 实现 Serializable

serialVersionUID: -5716748913324997674L

类 javax.print.attribute.standard.Copies 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -6426631521680023833L

类 javax.print.attribute.standard.CopiesSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: 6927711687034846001L

类 javax.print.attribute.standard.DateTimeAtCompleted 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: 6497399708058490000L

类 javax.print.attribute.standard.DateTimeAtCreation 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: -2923732231056647903L

类 javax.print.attribute.standard.DateTimeAtProcessing 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: -3710068197278263244L

类 javax.print.attribute.standard.Destination 继承 URISyntax 实现 Serializable

serialVersionUID: 6776739171700415321L

类 javax.print.attribute.standard.DocumentName 继承 TextSyntax 实现 Serializable

serialVersionUID: 7883105848533280430L

类 javax.print.attribute.standard.Fidelity 继承 EnumSyntax 实现 Serializable

serialVersionUID: 6320827847329172308L

类 javax.print.attribute.standard.Finishings 继承 EnumSyntax 实现 Serializable

serialVersionUID: -627840419548391754L

类 javax.print.attribute.standard.JobHoldUntil 继承 DateTimeSyntax 实现 Serializable

serialVersionUID: -1664471048860415024L

类 javax.print.attribute.standard.JobImpressions 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 8225537206784322464L

类 javax.print.attribute.standard.JobImpressionsCompleted 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 6722648442432393294L

类 javax.print.attribute.standard.JobImpressionsSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: -4887354803843173692L

类 javax.print.attribute.standard.JobKOctets 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -8959710146498202869L

类 javax.print.attribute.standard.JobKOctetsProcessed 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -6265238509657881806L

类 javax.print.attribute.standard.JobKOctetsSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: -2867871140549897443L

类 javax.print.attribute.standard.JobMediaSheets 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 408871131531979741L

类 javax.print.attribute.standard.JobMediaSheetsCompleted 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 1739595973810840475L

类 javax.print.attribute.standard.JobMediaSheetsSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: 2953685470388672940L

类 javax.print.attribute.standard.JobMessageFromOperator 继承 TextSyntax 实现 Serializable

serialVersionUID: -4620751846003142047L

类 javax.print.attribute.standard.JobName 继承 TextSyntax 实现 Serializable

serialVersionUID: 4660359192078689545L

类 javax.print.attribute.standard.JobOriginatingUserName 继承 TextSyntax 实现 Serializable

serialVersionUID: -8052537926362933477L

类 javax.print.attribute.standard.JobPriority 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -4599900369040602769L

类 javax.print.attribute.standard.JobPrioritySupported 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 2564840378013555894L

类 javax.print.attribute.standard.JobSheets 继承 EnumSyntax 实现 Serializable

serialVersionUID: -4735258056132519759L

类 javax.print.attribute.standard.JobState 继承 EnumSyntax 实现 Serializable

serialVersionUID: 400465010094018920L

类 javax.print.attribute.standard.JobStateReason 继承 EnumSyntax 实现 Serializable

serialVersionUID: -8765894420449009168L

类 javax.print.attribute.standard.JobStateReasons 继承 HashSet<JobStateReason> 实现 Serializable

serialVersionUID: 8849088261264331812L

类 javax.print.attribute.standard.Media 继承 EnumSyntax 实现 Serializable

serialVersionUID: -2823970704630722439L

类 javax.print.attribute.standard.MediaName 继承 Media 实现 Serializable

serialVersionUID: 4653117714524155448L

类 javax.print.attribute.standard.MediaPrintableArea 继承 Object 实现 Serializable

serialVersionUID: -1597171464050795793L

序列化字段

x

int x

y

int y

w

int w

h

int h

units

int units

类 javax.print.attribute.standard.MediaSize 继承 Size2DSyntax 实现 Serializable

serialVersionUID: -1967958664615414771L

序列化字段

mediaName

MediaSizeName mediaName

类 javax.print.attribute.standard.MediaSizeName 继承 Media 实现 Serializable

serialVersionUID: 2778798329756942747L

类 javax.print.attribute.standard.MediaTray 继承 Media 实现 Serializable

serialVersionUID: -982503611095214703L

类 javax.print.attribute.standard.MultipleDocumentHandling 继承 EnumSyntax 实现 Serializable

serialVersionUID: 8098326460746413466L

类 javax.print.attribute.standard.NumberOfDocuments 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 7891881310684461097L

类 javax.print.attribute.standard.NumberOfInterveningJobs 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 2568141124844982746L

类 javax.print.attribute.standard.NumberUp 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -3040436486786527811L

类 javax.print.attribute.standard.NumberUpSupported 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: -1041573395759141805L

类 javax.print.attribute.standard.OrientationRequested 继承 EnumSyntax 实现 Serializable

serialVersionUID: -4447437289862822276L

类 javax.print.attribute.standard.OutputDeviceAssigned 继承 TextSyntax 实现 Serializable

serialVersionUID: 5486733778854271081L

类 javax.print.attribute.standard.PageRanges 继承 SetOfIntegerSyntax 实现 Serializable

serialVersionUID: 8639895197656148392L

类 javax.print.attribute.standard.PagesPerMinute 继承 IntegerSyntax 实现 Serializable

serialVersionUID: -6366403993072862015L

类 javax.print.attribute.standard.PagesPerMinuteColor 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 1684993151687470944L

类 javax.print.attribute.standard.PDLOverrideSupported 继承 EnumSyntax 实现 Serializable

serialVersionUID: -4393264467928463934L

类 javax.print.attribute.standard.PresentationDirection 继承 EnumSyntax 实现 Serializable

serialVersionUID: 8294728067230931780L

类 javax.print.attribute.standard.PrinterInfo 继承 TextSyntax 实现 Serializable

serialVersionUID: 7765280618777599727L

类 javax.print.attribute.standard.PrinterIsAcceptingJobs 继承 EnumSyntax 实现 Serializable

serialVersionUID: -5052010680537678061L

类 javax.print.attribute.standard.PrinterLocation 继承 TextSyntax 实现 Serializable

serialVersionUID: -1598610039865566337L

类 javax.print.attribute.standard.PrinterMakeAndModel 继承 TextSyntax 实现 Serializable

serialVersionUID: 4580461489499351411L

类 javax.print.attribute.standard.PrinterMessageFromOperator 继承 TextSyntax 实现 Serializable

serialVersionUID: -4486871203218629318L

类 javax.print.attribute.standard.PrinterMoreInfo 继承 URISyntax 实现 Serializable

serialVersionUID: 4555850007675338574L

类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 继承 URISyntax 实现 Serializable

serialVersionUID: 3323271346485076608L

类 javax.print.attribute.standard.PrinterName 继承 TextSyntax 实现 Serializable

serialVersionUID: 299740639137803127L

类 javax.print.attribute.standard.PrinterResolution 继承 ResolutionSyntax 实现 Serializable

serialVersionUID: 13090306561090558L

类 javax.print.attribute.standard.PrinterState 继承 EnumSyntax 实现 Serializable

serialVersionUID: -649578618346507718L

类 javax.print.attribute.standard.PrinterStateReason 继承 EnumSyntax 实现 Serializable

serialVersionUID: -1623720656201472593L

类 javax.print.attribute.standard.PrinterStateReasons 继承 HashMap<PrinterStateReason,Severity> 实现 Serializable

serialVersionUID: -3731791085163619457L

类 javax.print.attribute.standard.PrinterURI 继承 URISyntax 实现 Serializable

serialVersionUID: 7923912792485606497L

类 javax.print.attribute.standard.PrintQuality 继承 EnumSyntax 实现 Serializable

serialVersionUID: -3072341285225858365L

类 javax.print.attribute.standard.QueuedJobCount 继承 IntegerSyntax 实现 Serializable

serialVersionUID: 7499723077864047742L

类 javax.print.attribute.standard.ReferenceUriSchemesSupported 继承 EnumSyntax 实现 Serializable

serialVersionUID: -8989076942813442805L

类 javax.print.attribute.standard.RequestingUserName 继承 TextSyntax 实现 Serializable

serialVersionUID: -2683049894310331454L

类 javax.print.attribute.standard.Severity 继承 EnumSyntax 实现 Serializable

serialVersionUID: 8781881462717925380L

类 javax.print.attribute.standard.SheetCollate 继承 EnumSyntax 实现 Serializable

serialVersionUID: 7080587914259873003L

类 javax.print.attribute.standard.Sides 继承 EnumSyntax 实现 Serializable

serialVersionUID: -6890309414893262822L

软件包 javax.print.event

类 javax.print.event.PrintEvent 继承 EventObject 实现 Serializable

serialVersionUID: 2286914924430763847L

类 javax.print.event.PrintJobAttributeEvent 继承 PrintEvent 实现 Serializable

serialVersionUID: -6534469883874742101L

序列化字段

attributes

PrintJobAttributeSet attributes

类 javax.print.event.PrintJobEvent 继承 PrintEvent 实现 Serializable

serialVersionUID: -1711656903622072997L

序列化字段

reason

int reason

类 javax.print.event.PrintServiceAttributeEvent 继承 PrintEvent 实现 Serializable

serialVersionUID: -7565987018140326600L

序列化字段

attributes

PrintServiceAttributeSet attributes
软件包 javax.rmi.CORBA

类 javax.rmi.CORBA.ClassDesc 继承 Object 实现 Serializable

序列化字段

repid

String repid
该类的 RepositoryId。

codebase

String codebase
代码基 URL 的空格分隔的列表。

类 javax.rmi.CORBA.Stub 继承 ObjectImpl 实现 Serializable

serialVersionUID: 1087775603798577179L

序列化方法

readObject

private void readObject(ObjectInputStream stream)
                 throws IOException,
                        ClassNotFoundException
恢复 IOR 状态的序列化方法。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream stream)
                  throws IOException
保存 IOR 状态的序列化方法。

序列数据：
IOR 类型 ID (int) 的长度，后跟 IOR 类型 ID（使用 ISO8859-1 编码的字节数组），后跟 IOR 配置文件数 (int)，后跟 IOR 配置文件。每个 IOR 配置文件作为配置文件标签 (int) 写入，后跟配置文件数据 (int) 的长度，后跟配置文件数据（字节数组）。
抛出：
IOException
软件包 javax.rmi.ssl

类 javax.rmi.ssl.SslRMIClientSocketFactory 继承 Object 实现 Serializable

serialVersionUID: -8310631444933958385L

软件包 javax.script

类 javax.script.ScriptException 继承 Exception 实现 Serializable

序列化字段

fileName

String fileName

lineNumber

int lineNumber

columnNumber

int columnNumber
软件包 javax.security.auth

类 javax.security.auth.AuthPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 5806031445061587174L

类 javax.security.auth.DestroyFailedException 继承 Exception 实现 Serializable

serialVersionUID: -7790152857282749162L

类 javax.security.auth.PrivateCredentialPermission 继承 Permission 实现 Serializable

serialVersionUID: 5284372143517237068L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流读取此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException
序列化字段

credentialClass

String credentialClass

principals

Set<E> principals
与此 permission 相关联的 Principals 。该集合包含 PrivateCredentialPermission.CredOwner 类型的元素。

testing

boolean testing

类 javax.security.auth.PrivateCredentialPermission.CredOwner 继承 Object 实现 Serializable

serialVersionUID: -5607449830436408266L

序列化字段

principalClass

String principalClass

principalName

String principalName

类 javax.security.auth.RefreshFailedException 继承 Exception 实现 Serializable

serialVersionUID: 5058444488565265840L

类 javax.security.auth.Subject 继承 Object 实现 Serializable

serialVersionUID: -8308522755600156056L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
从流读取此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将此对象写入到流中（也就是将其序列化）。

抛出：
IOException
序列化字段

principals

Set<E> principals
A Set that provides a view of all of this Subject's Principals

Each element in this set is a java.security.Principal. The set is a Subject.SecureSet.

readOnly

boolean readOnly
此 Subject 是否为只读的

类 javax.security.auth.Subject.SecureSet 继承 AbstractSet 实现 Serializable

serialVersionUID: 7911754171111800359L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
Writes this object out to a stream (i.e., serializes it).

序列数据：
If this is a private credential set, a security check is performed to ensure that the caller has permission to access each credential in the set. If the security check passes, the set is serialized.
抛出：
IOException
序列化字段

elements

LinkedList<E> elements
The elements in this set.

this$0

Subject this$0
The outer Subject instance.
软件包 javax.security.auth.callback

类 javax.security.auth.callback.ChoiceCallback 继承 Object 实现 Serializable

serialVersionUID: -3975664071579892167L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

choices

String[] choices
选项列表
从以下版本开始：
1.4

defaultChoice

int defaultChoice
用作默认选项的选项
从以下版本开始：
1.4

multipleSelectionsAllowed

boolean multipleSelectionsAllowed
选项列表中是否允许进行多重选择
从以下版本开始：
1.4

selections

int[] selections
选中的选项，表示为 choices 列表中的索引。
从以下版本开始：
1.4

类 javax.security.auth.callback.ConfirmationCallback 继承 Object 实现 Serializable

serialVersionUID: -9095656433782481624L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

messageType

int messageType
从以下版本开始：
1.4

optionType

int optionType
从以下版本开始：
1.4

defaultOption

int defaultOption
从以下版本开始：
1.4

options

String[] options
从以下版本开始：
1.4

selection

int selection
从以下版本开始：
1.4

类 javax.security.auth.callback.LanguageCallback 继承 Object 实现 Serializable

serialVersionUID: 2019050433478903213L

序列化字段

locale

Locale locale
从以下版本开始：
1.4

类 javax.security.auth.callback.NameCallback 继承 Object 实现 Serializable

serialVersionUID: 3770938795909392253L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

defaultName

String defaultName
从以下版本开始：
1.4

inputName

String inputName
从以下版本开始：
1.4

类 javax.security.auth.callback.PasswordCallback 继承 Object 实现 Serializable

serialVersionUID: 2267422647454909926L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

echoOn

boolean echoOn
从以下版本开始：
1.4

inputPassword

char[] inputPassword
从以下版本开始：
1.4

类 javax.security.auth.callback.TextInputCallback 继承 Object 实现 Serializable

serialVersionUID: -8064222478852811804L

序列化字段

prompt

String prompt
从以下版本开始：
1.4

defaultText

String defaultText
从以下版本开始：
1.4

inputText

String inputText
从以下版本开始：
1.4

类 javax.security.auth.callback.TextOutputCallback 继承 Object 实现 Serializable

serialVersionUID: 1689502495511663102L

序列化字段

messageType

int messageType
从以下版本开始：
1.4

message

String message
从以下版本开始：
1.4

类 javax.security.auth.callback.UnsupportedCallbackException 继承 Exception 实现 Serializable

serialVersionUID: -6873556327655666839L

序列化字段

callback

Callback callback
软件包 javax.security.auth.kerberos

类 javax.security.auth.kerberos.DelegationPermission 继承 BasicPermission 实现 Serializable

serialVersionUID: 883133252142523922L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject 从流中恢复 DelegationPermission 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject 将 DelegationPermission 的状态保存到流中。操作已被序列化，超类负责管理名称。

抛出：
IOException

类 javax.security.auth.kerberos.KerberosKey 继承 Object 实现 Serializable

serialVersionUID: -4625402278148246993L

序列化字段

principal

KerberosPrincipal principal
此秘密密钥所属的主体。

versionNum

int versionNum
此秘密密钥的版本号。

key

javax.security.auth.kerberos.KeyImpl key
通过写出加密密钥的 ASN1 Encoded 字节来序列化 KeyImpl。ASN1 编码在 RFC1510 中得到定义，如下所示：
                        EncryptionKey ::=   SEQUENCE {
                                keytype[0]    INTEGER,
                                keyvalue[1]   OCTET STRING
                                }

类 javax.security.auth.kerberos.KerberosPrincipal 继承 Object 实现 Serializable

serialVersionUID: -7374788026156829911L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
从流读取此对象（也就是将其反序列化）。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream oos)
                  throws IOException
将 KerberosPrincipal 对象保存到流中。

序列数据：
通过以 DER-encoded 形式（在 RFC1510 的 5.2 小节中指定）写出 PrincipalName 和域来序列化 KerberosPrincipal。
抛出：
IOException

类 javax.security.auth.kerberos.KerberosTicket 继承 Object 实现 Serializable

serialVersionUID: 7395334370157380539L

序列化字段

asn1Encoding

byte[] asn1Encoding
定义在 Kerberos Protocol Specification RFC1510 中的 Ticket ASN.1 DER Encoding。

sessionKey

javax.security.auth.kerberos.KeyImpl sessionKey
通过写出加密密钥的 ASN1 Encoded 字节来序列化 KeyImpl。ASN1 编码在 RFC1510 中定义如下：

                        EncryptionKey ::=   SEQUENCE {
                                keytype[0]    INTEGER,
                                keyvalue[1]   OCTET STRING
                                }

flags

boolean[] flags
Kerberos Protocol Specification RFC1510 中定义了票据标志。

authTime

Date authTime
初始的验证时间。

startTime

Date startTime
经过这段时间后票据开始生效。

endTime

Date endTime
经过这段时间后将不再支持此票据。（其过期时间）。

renewTill

Date renewTill
对于可更新的 Ticket，它指示包含在某一更新中的最长终止时间。可以认为它是票据的绝对过期时间，其中包括所有的更新。对于不可更新的票据，此字段可以为 null。

client

KerberosPrincipal client
拥有服务票据的客户端。

server

KerberosPrincipal server
一项服务，已将票据发送给它。

clientAddresses

InetAddress[] clientAddresses
客户端可以从其所在位置使用票据的地址。如果票据在任何地址都是可用的，则此字段可以为 null。

类 javax.security.auth.kerberos.KeyImpl 继承 Object 实现 Serializable

serialVersionUID: -7889313790214321193L

序列化方法

readObject

private void readObject(ObjectInputStream ois)
                 throws IOException,
                        ClassNotFoundException
抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream ois)
                  throws IOException
序列数据：
this KeyImpl is serialized by writing out the ASN1 Encoded bytes of the encryption key. The ASN1 encoding is defined in RFC1510 and as follows: EncryptionKey ::= SEQUENCE { keytype[0] INTEGER, keyvalue[1] OCTET STRING }
抛出：
IOException

类 javax.security.auth.kerberos.ServicePermission 继承 Permission 实现 Serializable

serialVersionUID: -1227585031618624935L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        ClassNotFoundException
调用 readObject 从流中恢复 ServicePermission 的状态。

抛出：
IOException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
调用 WriteObject 将 ServicePermission 的状态保存到流中。操作已被序列化，超类负责管理名称。

抛出：
IOException
序列化字段

actions

String actions
动作字符串。

软件包 javax.security.auth.login

类 javax.security.auth.login.AccountException 继承 LoginException 实现 Serializable

serialVersionUID: -2112878680072211787L

类 javax.security.auth.login.AccountExpiredException 继承 AccountException 实现 Serializable

serialVersionUID: -6064064890162661560L

类 javax.security.auth.login.AccountLockedException 继承 AccountException 实现 Serializable

serialVersionUID: 8280345554014066334L

类 javax.security.auth.login.AccountNotFoundException 继承 AccountException 实现 Serializable

serialVersionUID: 1498349563916294614L

类 javax.security.auth.login.CredentialException 继承 LoginException 实现 Serializable

serialVersionUID: -4772893876810601859L

类 javax.security.auth.login.CredentialExpiredException 继承 CredentialException 实现 Serializable

serialVersionUID: -5344739593859737937L

类 javax.security.auth.login.CredentialNotFoundException 继承 CredentialException 实现 Serializable

serialVersionUID: -7779934467214319475L

类 javax.security.auth.login.FailedLoginException 继承 LoginException 实现 Serializable

serialVersionUID: 802556922354616286L

类 javax.security.auth.login.LoginException 继承 GeneralSecurityException 实现 Serializable

serialVersionUID: -4679091624035232488L

软件包 javax.security.auth.x500

类 javax.security.auth.x500.X500Principal 继承 Object 实现 Serializable

serialVersionUID: -500463348111345721L

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException,
                        NotActiveException,
                        ClassNotFoundException
从流读取此对象（即将其反序列化）。

抛出：
IOException
NotActiveException
ClassNotFoundException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
将 X500Principal 对象保存到流中。

序列数据：
此 X500Principal 通过写出它的 DER 编码格式（getEncoded 的值被序列化）来获得序列化。
抛出：
IOException
软件包 javax.security.cert

类 javax.security.cert.CertificateEncodingException 继承 CertificateException 实现 Serializable

类 javax.security.cert.CertificateException 继承 Exception 实现 Serializable

类 javax.security.cert.CertificateExpiredException 继承 CertificateException 实现 Serializable

类 javax.security.cert.CertificateNotYetValidException 继承 CertificateException 实现 Serializable

类 javax.security.cert.CertificateParsingException 继承 CertificateException 实现 Serializable

软件包 javax.security.sasl

类 javax.security.sasl.AuthenticationException 继承 SaslException 实现 Serializable

serialVersionUID: -3579708765071815007L

类 javax.security.sasl.AuthorizeCallback 继承 Object 实现 Serializable

serialVersionUID: -2353344186490470805L

序列化字段

authenticationID

String authenticationID
要检查的（已验证的）验证 id。

authorizationID

String authorizationID
要检查的授权 id。

authorizedID

String authorizedID
已授权实体的 id。如果为 null，则已授权实体的 id 是 authorizationID。

authorized

boolean authorized
一个标志，指示是否允许用验证 id 代表授权 id。

类 javax.security.sasl.RealmCallback 继承 TextInputCallback 实现 Serializable

serialVersionUID: -4342673378785456908L

类 javax.security.sasl.RealmChoiceCallback 继承 ChoiceCallback 实现 Serializable

serialVersionUID: -8588141348846281332L

类 javax.security.sasl.SaslException 继承 IOException 实现 Serializable

serialVersionUID: 4579784287983423626L

序列化字段

_exception

Throwable _exception
根本原因异常，可能为 null。

软件包 javax.sound.midi

类 javax.sound.midi.InvalidMidiDataException 继承 Exception 实现 Serializable

类 javax.sound.midi.MidiUnavailableException 继承 Exception 实现 Serializable

软件包 javax.sound.sampled

类 javax.sound.sampled.AudioPermission 继承 BasicPermission 实现 Serializable

类 javax.sound.sampled.LineUnavailableException 继承 Exception 实现 Serializable

类 javax.sound.sampled.UnsupportedAudioFileException 继承 Exception 实现 Serializable

软件包 javax.sql

类 javax.sql.ConnectionEvent 继承 EventObject 实现 Serializable

serialVersionUID: -4843217645290030002L

序列化字段

ex

SQLException ex
发生错误且入池连接不再可用时驱动程序将向应用程序抛出的 SQLException。

类 javax.sql.RowSetEvent 继承 EventObject 实现 Serializable

serialVersionUID: -1875450876546332005L

类 javax.sql.StatementEvent 继承 EventObject 实现 Serializable

序列化字段

exception

SQLException exception

statement

PreparedStatement statement
软件包 javax.sql.rowset

类 javax.sql.rowset.BaseRowSet 继承 Object 实现 Serializable

serialVersionUID: 4886719666485113312L

序列化字段

binaryStream

InputStream binaryStream
将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

unicodeStream

InputStream unicodeStream
将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

asciiStream

InputStream asciiStream
将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

charStream

Reader charStream
将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。

command

String command
发送到 DBMS 的查询，调用方法 execute 时执行该查询。

URL

String URL
当使用 DriverManager 获得连接时，reader、writer 或二者提供给方法 DriverManager.getConnection 的 JDBC URL。

该 JDBC URL 标识用于建立连接的驱动程序。可在驱动程序供应商提供的文档中找到此 URL。

dataSource

String dataSource
为了从 Java Directory and Naming Interface (JNDI) 命名服务中获取 DataSource 对象，reader/writer 应该使用的数据源逻辑名。

rowSetType

int rowSetType
指示此 JDBC RowSet 对象类型的常量。它必须是以下 ResultSet 常量之一：TYPE_FORWARD_ONLY、TYPE_SCROLL_INSENSITIVE 或 TYPE_SCROLL_SENSITIVE。

showDeleted

boolean showDeleted
指示已删除行在此 JDBC RowSet 对象中是否可见的 boolean 值。

queryTimeout

int queryTimeout
驱动程序等待执行命令的最大秒数。当此 JDBC RowSet 对象连接到其数据源时应用此限制，也就是用数据填充该对象和该对象将数据写回数据源时。

maxRows

int maxRows
reader 应该读取的最大行数。

maxFieldSize

int maxFieldSize
reader 应该读取的最大字段大小。

concurrency

int concurrency
指示此 JDBC RowSet 对象并发性的常量。它必须是以下 ResultSet 常量之一：CONCUR_READ_ONLY 或 CONCUR_UPDATABLE。

readOnly

boolean readOnly
指示此 JDBC RowSet 对象是否为只读的 boolean 值。true 指示它是只读的；false 指示它是可写入的。

escapeProcessing

boolean escapeProcessing
指示此 JDBC RowSet 对象的 reader 是否应该执行转义处理的 boolean 值。true 表示开启转义处理；false 表示关闭。默认值为 true。

isolation

int isolation
指示此 JDBC RowSet 对象连接的隔离级别的常量。它必须是以下 Connection 常量之一：TRANSACTION_NONE、TRANSACTION_READ_UNCOMMITTED、TRANSACTION_READ_COMMITTED、TRANSACTION_REPEATABLE_READ 或 TRANSACTION_SERIALIZABLE。

fetchDir

int fetchDir
用作驱动程序提示的常量，指示要从此 JDBC RowSet 对象获取数据时所用的方向。可能的 ResultSet 常量值如下：FETCH_FORWARD、FETCH_REVERSE、FETCH_UNKNOWN。

目前未使用。

fetchSize

int fetchSize
为驱动程序提供的提示，指示此 JDBC RowSet 对象中的预期行数。

目前未使用。

map

Map<K,V> map
一个 java.util.Map 对象，其中包含的项提供了 SQL 类型名称到 Java 编程语言中类的映射，以用于用户定义类型的自定义映射。

listeners

Vector<E> listeners
一个 Vector 对象，保存已向此 RowSet 对象注册的侦听器所组成的列表。

params

Hashtable<K,V> params
一个 Vector 对象，保存此 RowSet 对象的当前命令的参数集。

类 javax.sql.rowset.RowSetMetaDataImpl 继承 Object 实现 Serializable

serialVersionUID: 6893806403181801867L

序列化字段

colCount

int colCount
创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。

colInfo

javax.sql.rowset.RowSetMetaDataImpl.ColInfo[] colInfo
ColInfo 对象数组，这些对象用于存储关于 RowSet 对象（此 RowSetMetaDataImpl 对象为其创建）中每个列的信息。此数组中的第一个 ColInfo 对象包含关于 RowSet 对象中第一个列的信息，第二个元素包含关于第二列的信息，依此类推。

类 javax.sql.rowset.RowSetWarning 继承 SQLException 实现 Serializable

serialVersionUID: 6678332766434564774L

序列化字段

rwarning

RowSetWarning rwarning
RowSetWarning 对象句柄。

软件包 javax.sql.rowset.serial

类 javax.sql.rowset.serial.SerialArray 继承 Object 实现 Serializable

serialVersionUID: -8466174297270688520L

序列化字段

elements

Object[] elements
序列化数组，每个数组元素都是一个 Java 编程语言中表示 SQL ARRAY 值的 Object。

baseType

int baseType
此 SerialArray 对象中 SQL 类型的元素。该类型表示为 java.sql.Types 类中的一个常量。

baseTypeName

String baseTypeName
DBMS 将该类型名称用于此 SerialArray 对象所表示的 SQL ARRAY 值中的元素。

len

int len
此 SerialArray 对象中的元素数，同时还是此 SerialArray 对象所表示的 SQL ARRAY 值中的元素数。

类 javax.sql.rowset.serial.SerialBlob 继承 Object 实现 Serializable

serialVersionUID: -8144641928112860441L

序列化字段

buf

byte[] buf
表示此 SerialBlob 对象值的序列化未解释字节数组。

blob

Blob blob
Blob 对象的内部表示形式，此 SerialBlob 对象以该对象为基础。

len

long len
此 SerialBlob 对象的字节数组中的字节数。

origLen

long origLen
刚建立时此 SerialBlob 对象的字节数组中的原始字节数。

类 javax.sql.rowset.serial.SerialClob 继承 Object 实现 Serializable

serialVersionUID: -1662519690087375313L

序列化字段

buf

char[] buf
一个序列化字符数组，包含此 SerialClob 对象所表示的 SQL CLOB 值的数据。

clob

Clob clob
使用 Clob 初始化 SerialClob 时内部 Clob 表示形式

len

long len
此 SerialClob 对象内部字符数组的长度（以字符为单位）。

origLen

long origLen
此 SerialClob 对象内部字符数组的原始长度（以字符为单位）。

类 javax.sql.rowset.serial.SerialDatalink 继承 Object 实现 Serializable

serialVersionUID: 2826907821828733626L

序列化字段

url

URL url
提取的 URL 字段，该字段是从 DATALINK 字段获取的。

baseType

int baseType
此 SerialDatalink 对象中 SQL 类型的元素。该类型表示为 java.sql.Types 类中的常量之一。

baseTypeName

String baseTypeName
DBMS 将该类型名称用于此 SerialDatalink 对象所表示的 SQL DATALINK 值中的元素。

类 javax.sql.rowset.serial.SerialException 继承 SQLException 实现 Serializable

serialVersionUID: -489794565168592690L

类 javax.sql.rowset.serial.SerialJavaObject 继承 Object 实现 Serializable

serialVersionUID: -1465795139032831023L

序列化字段

obj

Object obj
要序列化的对象的占位符。

chain

Vector<E> chain
A container for the warnings issued on this SerialJavaObject object. When there are multiple warnings, each warning is chained to the previous warning.

类 javax.sql.rowset.serial.SerialRef 继承 Object 实现 Serializable

serialVersionUID: -4727123500609662274L

序列化字段

baseTypeName

String baseTypeName
包含基本类型名称的字符串。

object

Object object
此类将类型 Ref 存储为 Object。

reference

Ref reference
Ref 引用的私有副本。

类 javax.sql.rowset.serial.SerialStruct 继承 Object 实现 Serializable

serialVersionUID: -8322445504027483372L

序列化字段

SQLTypeName

String SQLTypeName
此 SerialStruct 对象所表示的结构类型的 SQL 类型名称。此为在 SQL 结构类型的 SQL 定义中使用的名称。

attribs

Object[] attribs
Object 实例数组，每个数组元素都是此 SerialStruct 对象所表示的 SQL 结构类型的属性。这些属性按照它们在 SQL 结构类型定义中的顺序排列。

软件包 javax.sql.rowset.spi

类 javax.sql.rowset.spi.SyncFactoryException 继承 SQLException 实现 Serializable

serialVersionUID: -4354595476433200352L

类 javax.sql.rowset.spi.SyncProviderException 继承 SQLException 实现 Serializable

serialVersionUID: -939908523620640692L

序列化字段

syncResolver

SyncResolver syncResolver
调用 getSyncResolver 方法时此 SyncProviderException 对象将返回的 javax.sql.rowset.spi.SyncResolver 实例。

软件包 javax.tools

类 javax.tools.ToolProvider$1 继承 Object 实现 Serializable

软件包 javax.transaction

类 javax.transaction.InvalidTransactionException 继承 RemoteException 实现 Serializable

类 javax.transaction.TransactionRequiredException 继承 RemoteException 实现 Serializable

类 javax.transaction.TransactionRolledbackException 继承 RemoteException 实现 Serializable

软件包 javax.transaction.xa

类 javax.transaction.xa.XAException 继承 Exception 实现 Serializable

序列化字段

errorCode

int errorCode
用其创建 SystemException 的错误代码。

该异常的错误代码
软件包 javax.xml.bind

类 javax.xml.bind.JAXBElement 继承 Object 实现 Serializable

serialVersionUID: 1L

序列化字段

name

QName name
xml 元素标记名称。

declaredType

Class<T> declaredType
xml 元素声明类型的 Java 数据类型绑定。

scope

Class<T> scope
表示此 xml 元素实例的 xml 元素声明的作用域。可以是以下值之一：全局 xml 元素声明的 JAXBElement.GlobalScope。局部元素声明有一个被设置为包含 xml 元素声明的复杂类型定义的 Java 类表示形式的作用域。

value

Object value
xml 元素值。表示 xml 元素实例的内容模式和属性。

nil

boolean nil
如果 xml 元素实例具有 xsi:nil="true" 属性，则 nil 为 true。

类 javax.xml.bind.JAXBException 继承 Exception 实现 Serializable

serialVersionUID: -5621384651494307979L

序列化字段

errorCode

String errorCode
特定于供应商的错误代码。

linkedException

Throwable linkedException
异常引用。

类 javax.xml.bind.MarshalException 继承 JAXBException 实现 Serializable

类 javax.xml.bind.PropertyException 继承 JAXBException 实现 Serializable

类 javax.xml.bind.TypeConstraintException 继承 RuntimeException 实现 Serializable

序列化字段

errorCode

String errorCode
特定于供应商的错误代码。

linkedException

Throwable linkedException
异常引用。

类 javax.xml.bind.UnmarshalException 继承 JAXBException 实现 Serializable

类 javax.xml.bind.ValidationException 继承 JAXBException 实现 Serializable

软件包 javax.xml.crypto

类 javax.xml.crypto.KeySelectorException 继承 Exception 实现 Serializable

serialVersionUID: -7480033639322531109L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

类 javax.xml.crypto.MarshalException 继承 Exception 实现 Serializable

serialVersionUID: -863185580332643547L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable；如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则该值为 null。

类 javax.xml.crypto.NoSuchMechanismException 继承 RuntimeException 实现 Serializable

serialVersionUID: 4189669069570660166L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable；如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

类 javax.xml.crypto.URIReferenceException 继承 Exception 实现 Serializable

serialVersionUID: 7173469703932561419L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由另一个 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

uriReference

URIReference uriReference
软件包 javax.xml.crypto.dsig

类 javax.xml.crypto.dsig.TransformException 继承 Exception 实现 Serializable

serialVersionUID: 5082634801360427800L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由其他 throwable 引起的；如果导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

类 javax.xml.crypto.dsig.XMLSignatureException 继承 Exception 实现 Serializable

serialVersionUID: -3438102491013869995L

序列化字段

cause

Throwable cause
导致抛出此异常的 throwable，如果此异常不是由其他 throwable 引起的，或者导致抛出异常的 throwable 对于此异常是未知的，则 cause 为 null。

软件包 javax.xml.datatype

类 javax.xml.datatype.DatatypeConfigurationException 继承 Exception 实现 Serializable

软件包 javax.xml.namespace

类 javax.xml.namespace.QName 继承 Object 实现 Serializable

序列化字段

namespaceURI

String namespaceURI

此 QName 的名称空间 URI。

localPart

String localPart

此 QName 的本地部分。

prefix

String prefix

此 QName 的前缀。

软件包 javax.xml.parsers

类 javax.xml.parsers.FactoryConfigurationError 继承 Error 实现 Serializable

序列化字段

exception

Exception exception
表示该错误的 Exception。

类 javax.xml.parsers.ParserConfigurationException 继承 Exception 实现 Serializable

软件包 javax.xml.soap

类 javax.xml.soap.SOAPException 继承 Exception 实现 Serializable

序列化字段

cause

Throwable cause
软件包 javax.xml.stream

类 javax.xml.stream.FactoryConfigurationError 继承 Error 实现 Serializable

序列化字段

nested

Exception nested

类 javax.xml.stream.XMLStreamException 继承 Exception 实现 Serializable

序列化字段

nested

Throwable nested

location

Location location
软件包 javax.xml.transform

类 javax.xml.transform.TransformerConfigurationException 继承 TransformerException 实现 Serializable

类 javax.xml.transform.TransformerException 继承 Exception 实现 Serializable

序列化字段

locator

SourceLocator locator
Field locator specifies where the error occured

containedException

Throwable containedException
Field containedException specifies a wrapped exception. May be null.

类 javax.xml.transform.TransformerFactoryConfigurationError 继承 Error 实现 Serializable

序列化字段

exception

Exception exception
TransformerFactoryConfigurationError 的 Exception。

软件包 javax.xml.ws

类 javax.xml.ws.ProtocolException 继承 WebServiceException 实现 Serializable

类 javax.xml.ws.WebServiceException 继承 RuntimeException 实现 Serializable

类 javax.xml.ws.WebServicePermission 继承 BasicPermission 实现 Serializable

serialVersionUID: -146474640053770988L

软件包 javax.xml.ws.http

类 javax.xml.ws.http.HTTPException 继承 ProtocolException 实现 Serializable

序列化字段

statusCode

int statusCode
软件包 javax.xml.ws.soap

类 javax.xml.ws.soap.SOAPFaultException 继承 ProtocolException 实现 Serializable

序列化字段

fault

SOAPFault fault
软件包 javax.xml.xpath

类 javax.xml.xpath.XPathException 继承 Exception 实现 Serializable

serialVersionUID: -1837080260374986980L

序列化字段

cause

Throwable cause

类 javax.xml.xpath.XPathExpressionException 继承 XPathException 实现 Serializable

serialVersionUID: -1837080260374986980L

类 javax.xml.xpath.XPathFactoryConfigurationException 继承 XPathException 实现 Serializable

serialVersionUID: -1837080260374986980L

类 javax.xml.xpath.XPathFunctionException 继承 XPathExpressionException 实现 Serializable

serialVersionUID: -1837080260374986980L

软件包 org.ietf.jgss

类 org.ietf.jgss.GSSException 继承 Exception 实现 Serializable

serialVersionUID: -2706218945227726672L

序列化字段

major

int major
此异常的主要代码。

minor

int minor
此异常的次要代码。

minorMessage

String minorMessage
次要代码的文本字符串

majorString

String majorString
主要代码的替换文本字符串

软件包 org.omg.CosNaming

类 org.omg.CosNaming._BindingIteratorImplBase 继承 DynamicImplementation 实现 Serializable

类 org.omg.CosNaming._BindingIteratorStub 继承 ObjectImpl 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
抛出：
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException

类 org.omg.CosNaming._NamingContextExtStub 继承 ObjectImpl 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
抛出：
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException

类 org.omg.CosNaming._NamingContextImplBase 继承 DynamicImplementation 实现 Serializable

类 org.omg.CosNaming._NamingContextStub 继承 ObjectImpl 实现 Serializable

序列化方法

readObject

private void readObject(ObjectInputStream s)
                 throws IOException
抛出：
IOException

writeObject

private void writeObject(ObjectOutputStream s)
                  throws IOException
抛出：
IOException

类 org.omg.CosNaming.Binding 继承 Object 实现 Serializable

序列化字段

binding_name

NameComponent[] binding_name

binding_type

BindingType binding_type

类 org.omg.CosNaming.BindingType 继承 Object 实现 Serializable

序列化字段

__value

int __value

类 org.omg.CosNaming.NameComponent 继承 Object 实现 Serializable

序列化字段

id

String id

kind

String kind
软件包 org.w3c.dom

类 org.w3c.dom.DOMException 继承 RuntimeException 实现 Serializable

serialVersionUID: 6627732366795969916L

序列化字段

code

short code
软件包 org.w3c.dom.events

类 org.w3c.dom.events.EventException 继承 RuntimeException 实现 Serializable

序列化字段

code

short code
软件包 org.w3c.dom.ls

类 org.w3c.dom.ls.LSException 继承 RuntimeException 实现 Serializable

序列化字段

code

short code
软件包 org.xml.sax

类 org.xml.sax.SAXException 继承 Exception 实现 Serializable

serialVersionUID: 583241635256073760L

序列化字段

exception

Exception exception
使用隧道时的嵌入异常，否则为 null。

类 org.xml.sax.SAXNotRecognizedException 继承 SAXException 实现 Serializable

serialVersionUID: 5440506620509557213L

类 org.xml.sax.SAXNotSupportedException 继承 SAXException 实现 Serializable

serialVersionUID: -1422818934641823846L

类 org.xml.sax.SAXParseException 继承 SAXException 实现 Serializable

serialVersionUID: -5651165872476709336L

序列化字段

publicId

String publicId
公共标识符或 null。
另请参见：
SAXParseException.getPublicId()

systemId

String systemId
系统标识符或 null。
另请参见：
SAXParseException.getSystemId()

lineNumber

int lineNumber
行号或 -1。
另请参见：
SAXParseException.getLineNumber()

columnNumber

int columnNumber
列号或 -1。
另请参见：
SAXParseException.getColumnNumber()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

所有软件包的分层结构

软件包分层结构：
java.applet, java.awt, java.awt.color, java.awt.datatransfer, java.awt.dnd, java.awt.event, java.awt.font, java.awt.geom, java.awt.im, java.awt.im.spi, java.awt.image, java.awt.image.renderable, java.awt.print, java.beans, java.beans.beancontext, java.io, java.lang, java.lang.annotation, java.lang.instrument, java.lang.management, java.lang.ref, java.lang.reflect, java.math, java.net, java.nio, java.nio.channels, java.nio.channels.spi, java.nio.charset, java.nio.charset.spi, java.rmi, java.rmi.activation, java.rmi.dgc, java.rmi.registry, java.rmi.server, java.security, java.security.acl, java.security.cert, java.security.interfaces, java.security.spec, java.sql, java.text, java.text.spi, java.util, java.util.concurrent, java.util.concurrent.atomic, java.util.concurrent.locks, java.util.jar, java.util.logging, java.util.prefs, java.util.regex, java.util.spi, java.util.zip, javax.accessibility, javax.activation, javax.activity, javax.annotation, javax.annotation.processing, javax.crypto, javax.crypto.interfaces, javax.crypto.spec, javax.imageio, javax.imageio.event, javax.imageio.metadata, javax.imageio.plugins.bmp, javax.imageio.plugins.jpeg, javax.imageio.spi, javax.imageio.stream, javax.jws, javax.jws.soap, javax.lang.model, javax.lang.model.element, javax.lang.model.type, javax.lang.model.util, javax.management, javax.management.loading, javax.management.modelmbean, javax.management.monitor, javax.management.openmbean, javax.management.relation, javax.management.remote, javax.management.remote.rmi, javax.management.timer, javax.naming, javax.naming.directory, javax.naming.event, javax.naming.ldap, javax.naming.spi, javax.net, javax.net.ssl, javax.print, javax.print.attribute, javax.print.attribute.standard, javax.print.event, javax.rmi, javax.rmi.CORBA, javax.rmi.ssl, javax.script, javax.security.auth, javax.security.auth.callback, javax.security.auth.kerberos, javax.security.auth.login, javax.security.auth.spi, javax.security.auth.x500, javax.security.cert, javax.security.sasl, javax.sound.midi, javax.sound.midi.spi, javax.sound.sampled, javax.sound.sampled.spi, javax.sql, javax.sql.rowset, javax.sql.rowset.serial, javax.sql.rowset.spi, javax.swing, javax.swing.border, javax.swing.colorchooser, javax.swing.event, javax.swing.filechooser, javax.swing.plaf, javax.swing.plaf.basic, javax.swing.plaf.metal, javax.swing.plaf.multi, javax.swing.plaf.synth, javax.swing.table, javax.swing.text, javax.swing.text.html, javax.swing.text.html.parser, javax.swing.text.rtf, javax.swing.tree, javax.swing.undo, javax.tools, javax.transaction, javax.transaction.xa, javax.xml, javax.xml.bind, javax.xml.bind.annotation, javax.xml.bind.annotation.adapters, javax.xml.bind.attachment, javax.xml.bind.helpers, javax.xml.bind.util, javax.xml.crypto, javax.xml.crypto.dom, javax.xml.crypto.dsig, javax.xml.crypto.dsig.dom, javax.xml.crypto.dsig.keyinfo, javax.xml.crypto.dsig.spec, javax.xml.datatype, javax.xml.namespace, javax.xml.parsers, javax.xml.soap, javax.xml.stream, javax.xml.stream.events, javax.xml.stream.util, javax.xml.transform, javax.xml.transform.dom, javax.xml.transform.sax, javax.xml.transform.stax, javax.xml.transform.stream, javax.xml.validation, javax.xml.ws, javax.xml.ws.handler, javax.xml.ws.handler.soap, javax.xml.ws.http, javax.xml.ws.soap, javax.xml.ws.spi, javax.xml.xpath, org.ietf.jgss, org.omg.CORBA, org.omg.CORBA_2_3, org.omg.CORBA_2_3.portable, org.omg.CORBA.DynAnyPackage, org.omg.CORBA.ORBPackage, org.omg.CORBA.portable, org.omg.CORBA.TypeCodePackage, org.omg.CosNaming, org.omg.CosNaming.NamingContextExtPackage, org.omg.CosNaming.NamingContextPackage, org.omg.Dynamic, org.omg.DynamicAny, org.omg.DynamicAny.DynAnyFactoryPackage, org.omg.DynamicAny.DynAnyPackage, org.omg.IOP, org.omg.IOP.CodecFactoryPackage, org.omg.IOP.CodecPackage, org.omg.Messaging, org.omg.PortableInterceptor, org.omg.PortableInterceptor.ORBInitInfoPackage, org.omg.PortableServer, org.omg.PortableServer.CurrentPackage, org.omg.PortableServer.POAManagerPackage, org.omg.PortableServer.POAPackage, org.omg.PortableServer.portable, org.omg.PortableServer.ServantLocatorPackage, org.omg.SendingContext, org.omg.stub.java.rmi, org.w3c.dom, org.w3c.dom.bootstrap, org.w3c.dom.events, org.w3c.dom.ls, org.xml.sax, org.xml.sax.ext, org.xml.sax.helpers

类分层结构

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDesktopPaneUI.CloseAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MaximizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.MinimizeAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.NavigateAction
      • javax.swing.plaf.basic.BasicDesktopPaneUI.OpenAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ApproveSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.CancelSelectionAction
      • javax.swing.plaf.basic.BasicFileChooserUI.ChangeToParentDirectoryAction
      • javax.swing.plaf.basic.BasicFileChooserUI.GoHomeAction
      • javax.swing.plaf.basic.BasicFileChooserUI.NewFolderAction
      • javax.swing.plaf.basic.BasicFileChooserUI.UpdateAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.CloseAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.IconifyAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MaximizeAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.MoveAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.RestoreAction
      • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SizeAction
      • javax.swing.plaf.basic.BasicSliderUI.ActionScroller
      • javax.swing.plaf.basic.BasicTreeUI.TreeCancelEditingAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeHomeAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeIncrementAction
      • javax.swing.plaf.basic.BasicTreeUI.TreePageAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeToggleAction
      • javax.swing.plaf.basic.BasicTreeUI.TreeTraverseAction
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxAction
      • javax.swing.text.TextAction
        • javax.swing.text.DefaultEditorKit.BeepAction
        • javax.swing.text.DefaultEditorKit.CopyAction
        • javax.swing.text.DefaultEditorKit.CutAction
        • javax.swing.text.DefaultEditorKit.DefaultKeyTypedAction
        • javax.swing.text.DefaultEditorKit.InsertBreakAction
        • javax.swing.text.DefaultEditorKit.InsertContentAction
        • javax.swing.text.DefaultEditorKit.InsertTabAction
        • javax.swing.text.DefaultEditorKit.PasteAction
        • javax.swing.text.StyledEditorKit.StyledTextAction
          • javax.swing.text.html.HTMLEditorKit.HTMLTextAction
            • javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction
          • javax.swing.text.StyledEditorKit.AlignmentAction
          • javax.swing.text.StyledEditorKit.BoldAction
          • javax.swing.text.StyledEditorKit.FontFamilyAction
          • javax.swing.text.StyledEditorKit.FontSizeAction
          • javax.swing.text.StyledEditorKit.ForegroundAction
          • javax.swing.text.StyledEditorKit.ItalicAction
          • javax.swing.text.StyledEditorKit.UnderlineAction
    • javax.lang.model.util.AbstractAnnotationValueVisitor6<R,P> (implements javax.lang.model.element.AnnotationValueVisitor<R,P>)
      • javax.lang.model.util.SimpleAnnotationValueVisitor6<R,P>
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.plaf.basic.BasicBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.basic.BasicBorders.RadioButtonBorder
        • javax.swing.plaf.basic.BasicBorders.RolloverButtonBorder
        • javax.swing.plaf.basic.BasicBorders.ToggleButtonBorder
      • javax.swing.plaf.basic.BasicBorders.FieldBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MarginBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.basic.BasicBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.border.BevelBorder
        • javax.swing.plaf.BorderUIResource.BevelBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.SoftBevelBorder
      • javax.swing.border.CompoundBorder
        • javax.swing.plaf.BorderUIResource.CompoundBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EmptyBorder (implements java.io.Serializable)
        • javax.swing.plaf.BorderUIResource.EmptyBorderUIResource (implements javax.swing.plaf.UIResource)
        • javax.swing.border.MatteBorder
          • javax.swing.plaf.BorderUIResource.MatteBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.EtchedBorder
        • javax.swing.plaf.BorderUIResource.EtchedBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.border.LineBorder
        • javax.swing.plaf.BorderUIResource.LineBorderUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ButtonBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.RolloverButtonBorder
        • javax.swing.plaf.metal.MetalBorders.ToggleButtonBorder
      • javax.swing.plaf.metal.MetalBorders.Flush3DBorder (implements javax.swing.plaf.UIResource)
        • javax.swing.plaf.metal.MetalBorders.TextFieldBorder
      • javax.swing.plaf.metal.MetalBorders.InternalFrameBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuBarBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.MenuItemBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.OptionDialogBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PaletteBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.PopupMenuBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.ScrollPaneBorder (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalBorders.TableHeaderBorder
      • javax.swing.plaf.metal.MetalBorders.ToolBarBorder (implements javax.swing.SwingConstants, javax.swing.plaf.UIResource)
      • javax.swing.border.TitledBorder
        • javax.swing.plaf.BorderUIResource.TitledBorderUIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.AbstractButton.ButtonChangeListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.AbstractCellEditor (implements javax.swing.CellEditor, java.io.Serializable)
      • javax.swing.DefaultCellEditor (implements javax.swing.table.TableCellEditor, javax.swing.tree.TreeCellEditor)
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.AbstractSequentialList<E>
          • java.util.LinkedList<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.util.List<E>, java.io.Serializable)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • javax.management.AttributeList
          • javax.management.relation.RoleList
          • javax.management.relation.RoleUnresolvedList
        • java.util.Vector<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • java.util.Stack<E>
      • java.util.AbstractQueue<E> (implements java.util.Queue<E>)
        • java.util.concurrent.ArrayBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.ConcurrentLinkedQueue<E> (implements java.util.Queue<E>, java.io.Serializable)
        • java.util.concurrent.DelayQueue<E> (implements java.util.concurrent.BlockingQueue<E>)
        • java.util.concurrent.LinkedBlockingDeque<E> (implements java.util.concurrent.BlockingDeque<E>, java.io.Serializable)
        • java.util.concurrent.LinkedBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.PriorityBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.PriorityQueue<E> (implements java.io.Serializable)
        • java.util.concurrent.SynchronousQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.concurrent.ConcurrentSkipListSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
        • java.util.concurrent.CopyOnWriteArraySet<E> (implements java.io.Serializable)
        • java.util.EnumSet<E> (implements java.lang.Cloneable, java.io.Serializable)
        • java.util.HashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
          • javax.print.attribute.standard.JobStateReasons (implements javax.print.attribute.PrintJobAttribute)
          • java.util.LinkedHashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
        • java.util.TreeSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
      • java.util.ArrayDeque<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.io.Serializable)
    • javax.swing.text.AbstractDocument (implements javax.swing.text.Document, java.io.Serializable)
      • javax.swing.text.DefaultStyledDocument (implements javax.swing.text.StyledDocument)
        • javax.swing.text.html.HTMLDocument
      • javax.swing.text.PlainDocument
    • javax.swing.text.AbstractDocument.AbstractElement (implements javax.swing.text.Element, javax.swing.text.MutableAttributeSet, java.io.Serializable, javax.swing.tree.TreeNode)
      • javax.swing.text.AbstractDocument.BranchElement
        • javax.swing.text.DefaultStyledDocument.SectionElement
        • javax.swing.text.html.HTMLDocument.BlockElement
      • javax.swing.text.AbstractDocument.LeafElement
        • javax.swing.text.html.HTMLDocument.RunElement
    • javax.lang.model.util.AbstractElementVisitor6<R,P> (implements javax.lang.model.element.ElementVisitor<R,P>)
      • javax.lang.model.util.ElementScanner6<R,P>
      • javax.lang.model.util.SimpleElementVisitor6<R,P>
        • javax.lang.model.util.ElementKindVisitor6<R,P>
    • java.util.concurrent.AbstractExecutorService (implements java.util.concurrent.ExecutorService)
      • java.util.concurrent.ThreadPoolExecutor
        • java.util.concurrent.ScheduledThreadPoolExecutor (implements java.util.concurrent.ScheduledExecutorService)
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.FileChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.DatagramChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.Pipe.SinkChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.WritableByteChannel)
          • java.nio.channels.Pipe.SourceChannel (implements java.nio.channels.ReadableByteChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.ServerSocketChannel
          • java.nio.channels.SocketChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel)
    • javax.swing.tree.AbstractLayoutCache (implements javax.swing.tree.RowMapper)
      • javax.swing.tree.FixedHeightLayoutCache
      • javax.swing.tree.VariableHeightLayoutCache
    • javax.swing.tree.AbstractLayoutCache.NodeDimensions
      • javax.swing.plaf.basic.BasicTreeUI.NodeDimensionsHandler
    • javax.swing.AbstractListModel (implements javax.swing.ListModel, java.io.Serializable)
      • javax.swing.plaf.basic.BasicDirectoryModel (implements java.beans.PropertyChangeListener)
      • javax.swing.DefaultComboBoxModel (implements javax.swing.MutableComboBoxModel, java.io.Serializable)
      • javax.swing.DefaultListModel
      • javax.swing.plaf.metal.MetalFileChooserUI.DirectoryComboBoxModel (implements javax.swing.ComboBoxModel)
      • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxModel (implements javax.swing.ComboBoxModel, java.beans.PropertyChangeListener)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.concurrent.ConcurrentHashMap<K,V> (implements java.util.concurrent.ConcurrentMap<K,V>, java.io.Serializable)
      • java.util.concurrent.ConcurrentSkipListMap<K,V> (implements java.lang.Cloneable, java.util.concurrent.ConcurrentNavigableMap<K,V>, java.io.Serializable)
      • java.util.EnumMap<K,V> (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.LinkedHashMap<K,V> (implements java.util.Map<K,V>)
        • javax.print.attribute.standard.PrinterStateReasons (implements javax.print.attribute.PrintServiceAttribute)
      • java.util.IdentityHashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
      • java.util.TreeMap<K,V> (implements java.lang.Cloneable, java.util.NavigableMap<K,V>, java.io.Serializable)
      • java.util.WeakHashMap<K,V> (implements java.util.Map<K,V>)
    • java.util.AbstractMap.SimpleEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • java.util.AbstractMap.SimpleImmutableEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • javax.xml.bind.helpers.AbstractMarshallerImpl (implements javax.xml.bind.Marshaller)
    • java.util.concurrent.locks.AbstractOwnableSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedLongSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedSynchronizer (implements java.io.Serializable)
    • javax.annotation.processing.AbstractProcessor (implements javax.annotation.processing.Processor)
    • java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • javax.script.AbstractScriptEngine (implements javax.script.ScriptEngine)
    • javax.swing.AbstractSpinnerModel (implements javax.swing.SpinnerModel)
      • javax.swing.SpinnerDateModel (implements java.io.Serializable)
      • javax.swing.SpinnerListModel (implements java.io.Serializable)
      • javax.swing.SpinnerNumberModel (implements java.io.Serializable)
    • javax.swing.table.AbstractTableModel (implements java.io.Serializable, javax.swing.table.TableModel)
      • javax.swing.table.DefaultTableModel (implements java.io.Serializable)
    • javax.lang.model.util.AbstractTypeVisitor6<R,P> (implements javax.lang.model.type.TypeVisitor<R,P>)
      • javax.lang.model.util.SimpleTypeVisitor6<R,P>
        • javax.lang.model.util.TypeKindVisitor6<R,P>
    • javax.swing.undo.AbstractUndoableEdit (implements java.io.Serializable, javax.swing.undo.UndoableEdit)
      • javax.swing.text.AbstractDocument.ElementEdit (implements javax.swing.event.DocumentEvent.ElementChange)
      • javax.swing.undo.CompoundEdit
        • javax.swing.text.AbstractDocument.DefaultDocumentEvent (implements javax.swing.event.DocumentEvent)
        • javax.swing.undo.UndoManager (implements javax.swing.event.UndoableEditListener)
      • javax.swing.text.DefaultStyledDocument.AttributeUndoableEdit
      • javax.swing.undo.StateEdit
    • javax.xml.bind.helpers.AbstractUnmarshallerImpl (implements javax.xml.bind.Unmarshaller)
    • javax.swing.text.AbstractWriter
      • javax.swing.text.html.HTMLWriter
      • javax.swing.text.html.MinimalHTMLWriter
    • java.security.AccessControlContext
    • java.security.AccessController
    • javax.accessibility.AccessibleAttributeSequence
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleRelation
      • javax.accessibility.AccessibleRole
      • javax.accessibility.AccessibleState
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • javax.swing.Box.Filler.AccessibleBoxFiller
        • java.awt.Button.AccessibleAWTButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
        • java.awt.Canvas.AccessibleAWTCanvas
        • java.awt.Checkbox.AccessibleAWTCheckbox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue, java.awt.event.ItemListener)
        • java.awt.Choice.AccessibleAWTChoice (implements javax.accessibility.AccessibleAction)
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.Box.AccessibleBox
          • javax.swing.CellRendererPane.AccessibleCellRendererPane
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.AbstractButton.AccessibleAbstractButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue)
              • javax.swing.JButton.AccessibleJButton
              • javax.swing.JMenuItem.AccessibleJMenuItem (implements javax.swing.event.ChangeListener)
                • javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
                • javax.swing.JMenu.AccessibleJMenu (implements javax.accessibility.AccessibleSelection)
                • javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
              • javax.swing.JToggleButton.AccessibleJToggleButton (implements java.awt.event.ItemListener)
                • javax.swing.JCheckBox.AccessibleJCheckBox
                • javax.swing.JRadioButton.AccessibleJRadioButton
            • javax.swing.JColorChooser.AccessibleJColorChooser
            • javax.swing.JComboBox.AccessibleJComboBox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleSelection)
            • javax.swing.JDesktopPane.AccessibleJDesktopPane
            • javax.swing.JFileChooser.AccessibleJFileChooser
            • javax.swing.JInternalFrame.AccessibleJInternalFrame (implements javax.accessibility.AccessibleValue)
            • javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon (implements javax.accessibility.AccessibleValue)
            • javax.swing.JLabel.AccessibleJLabel (implements javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText)
            • javax.swing.JLayeredPane.AccessibleJLayeredPane
            • javax.swing.JList.AccessibleJList (implements javax.accessibility.AccessibleSelection, javax.swing.event.ListDataListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener)
            • javax.swing.JMenuBar.AccessibleJMenuBar (implements javax.accessibility.AccessibleSelection)
            • javax.swing.JOptionPane.AccessibleJOptionPane
            • javax.swing.JPanel.AccessibleJPanel
            • javax.swing.JPopupMenu.AccessibleJPopupMenu (implements java.beans.PropertyChangeListener)
            • javax.swing.JProgressBar.AccessibleJProgressBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JRootPane.AccessibleJRootPane
            • javax.swing.JScrollBar.AccessibleJScrollBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JScrollPane.AccessibleJScrollPane (implements javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
            • javax.swing.JSeparator.AccessibleJSeparator
            • javax.swing.JSlider.AccessibleJSlider (implements javax.accessibility.AccessibleValue)
            • javax.swing.JSpinner.AccessibleJSpinner (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue, javax.swing.event.ChangeListener)
            • javax.swing.JSplitPane.AccessibleJSplitPane (implements javax.accessibility.AccessibleValue)
            • javax.swing.JTabbedPane.AccessibleJTabbedPane (implements javax.accessibility.AccessibleSelection, javax.swing.event.ChangeListener)
            • javax.swing.JTable.AccessibleJTable (implements javax.accessibility.AccessibleExtendedTable, javax.accessibility.AccessibleSelection, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
            • javax.swing.table.JTableHeader.AccessibleJTableHeader
            • javax.swing.text.JTextComponent.AccessibleJTextComponent (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleExtendedText, javax.accessibility.AccessibleText, javax.swing.event.CaretListener, javax.swing.event.DocumentListener)
              • javax.swing.JEditorPane.AccessibleJEditorPane
                • javax.swing.JEditorPane.AccessibleJEditorPaneHTML
                • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport (implements javax.accessibility.AccessibleHypertext)
              • javax.swing.JTextArea.AccessibleJTextArea
              • javax.swing.JTextField.AccessibleJTextField
                • javax.swing.JPasswordField.AccessibleJPasswordField
            • javax.swing.JToolBar.AccessibleJToolBar
            • javax.swing.JToolTip.AccessibleJToolTip
            • javax.swing.JTree.AccessibleJTree (implements javax.accessibility.AccessibleSelection, javax.swing.event.TreeExpansionListener, javax.swing.event.TreeModelListener, javax.swing.event.TreeSelectionListener)
            • javax.swing.JViewport.AccessibleJViewport
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
              • javax.swing.JApplet.AccessibleJApplet
          • java.awt.ScrollPane.AccessibleAWTScrollPane
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
              • javax.swing.JDialog.AccessibleJDialog
            • java.awt.Frame.AccessibleAWTFrame
              • javax.swing.JFrame.AccessibleJFrame
            • javax.swing.JWindow.AccessibleJWindow
        • java.awt.Label.AccessibleAWTLabel
        • java.awt.List.AccessibleAWTList (implements javax.accessibility.AccessibleSelection, java.awt.event.ActionListener, java.awt.event.ItemListener)
        • java.awt.List.AccessibleAWTList.AccessibleAWTListChild (implements javax.accessibility.Accessible)
        • java.awt.Scrollbar.AccessibleAWTScrollBar (implements javax.accessibility.AccessibleValue)
        • java.awt.TextComponent.AccessibleAWTTextComponent (implements javax.accessibility.AccessibleText, java.awt.event.TextListener)
          • java.awt.TextArea.AccessibleAWTTextArea
          • java.awt.TextField.AccessibleAWTTextField
      • javax.swing.ImageIcon.AccessibleImageIcon (implements javax.accessibility.AccessibleIcon, java.io.Serializable)
      • javax.swing.JList.AccessibleJList.AccessibleJListChild (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTable.AccessibleJTable.AccessibleJTableCell (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.table.JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode (implements javax.accessibility.Accessible, javax.accessibility.AccessibleAction, javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection)
      • java.awt.MenuComponent.AccessibleAWTMenuComponent (implements javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection, java.io.Serializable)
        • java.awt.MenuBar.AccessibleAWTMenuBar
        • java.awt.MenuItem.AccessibleAWTMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.Menu.AccessibleAWTMenu
            • java.awt.PopupMenu.AccessibleAWTPopupMenu
      • javax.swing.ProgressMonitor.AccessibleProgressMonitor (implements javax.accessibility.AccessibleText, javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
    • javax.accessibility.AccessibleHyperlink (implements javax.accessibility.AccessibleAction)
      • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
    • java.lang.reflect.AccessibleObject (implements java.lang.reflect.AnnotatedElement)
      • java.lang.reflect.Constructor<T> (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
      • java.lang.reflect.Field (implements java.lang.reflect.Member)
      • java.lang.reflect.Method (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
    • javax.accessibility.AccessibleRelationSet
    • javax.accessibility.AccessibleStateSet
    • javax.accessibility.AccessibleTextSequence
    • javax.swing.ActionMap (implements java.io.Serializable)
      • javax.swing.plaf.ActionMapUIResource (implements javax.swing.plaf.UIResource)
    • java.rmi.activation.ActivationDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc.CommandEnvironment (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupID (implements java.io.Serializable)
    • java.rmi.activation.ActivationID (implements java.io.Serializable)
    • org.omg.PortableServer.POAPackage.AdapterAlreadyExistsHelper
    • org.omg.PortableServer.POAManagerPackage.AdapterInactiveHelper
    • org.omg.PortableInterceptor.AdapterManagerIdHelper
    • org.omg.PortableInterceptor.AdapterNameHelper
    • org.omg.PortableServer.POAPackage.AdapterNonExistentHelper
    • org.omg.PortableInterceptor.AdapterStateHelper
    • org.omg.CosNaming.NamingContextExtPackage.AddressHelper
    • java.util.zip.Adler32 (implements java.util.zip.Checksum)
    • java.awt.geom.AffineTransform (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.image.AffineTransformOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.security.AlgorithmParameterGenerator
    • java.security.AlgorithmParameterGeneratorSpi
    • java.security.AlgorithmParameters
    • java.security.AlgorithmParametersSpi
    • java.awt.AlphaComposite (implements java.awt.Composite)
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHelper
    • org.omg.CosNaming.NamingContextPackage.AlreadyBoundHolder (implements org.omg.CORBA.portable.Streamable)
    • java.text.Annotation
    • org.omg.CORBA.Any (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.AnyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.AnySeqHelper
    • org.omg.DynamicAny.AnySeqHelper
    • org.omg.CORBA.AnySeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.security.auth.login.AppConfigurationEntry
    • javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
    • java.awt.geom.Area (implements java.lang.Cloneable, java.awt.Shape)
    • java.lang.reflect.Array
    • java.util.Arrays
    • javax.swing.text.AsyncBoxView.ChildLocator
    • javax.swing.text.AsyncBoxView.ChildState (implements java.lang.Runnable)
    • java.util.concurrent.atomic.AtomicBoolean (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicLongArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicLongFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicMarkableReference<V>
    • java.util.concurrent.atomic.AtomicReference<V> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceArray<E> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceFieldUpdater<T,V>
    • java.util.concurrent.atomic.AtomicStampedReference<V>
    • javax.xml.bind.attachment.AttachmentMarshaller
    • javax.xml.soap.AttachmentPart
    • javax.xml.bind.attachment.AttachmentUnmarshaller
    • javax.management.Attribute (implements java.io.Serializable)
    • javax.management.AttributeChangeNotificationFilter (implements javax.management.NotificationFilter)
    • java.text.AttributedCharacterIterator.Attribute (implements java.io.Serializable)
      • java.text.Format.Field
        • java.text.DateFormat.Field
        • java.text.MessageFormat.Field
        • java.text.NumberFormat.Field
      • java.awt.font.TextAttribute
    • java.text.AttributedString
    • javax.swing.text.html.parser.AttributeList (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • org.xml.sax.helpers.AttributeListImpl (implements org.xml.sax.AttributeList)
    • java.util.jar.Attributes (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.util.jar.Attributes.Name
    • javax.print.attribute.AttributeSetUtilities
    • org.xml.sax.helpers.AttributesImpl (implements org.xml.sax.Attributes)
      • org.xml.sax.ext.Attributes2Impl (implements org.xml.sax.ext.Attributes2)
    • javax.management.AttributeValueExp (implements javax.management.ValueExp)
    • javax.sound.sampled.AudioFileFormat
    • javax.sound.sampled.AudioFileFormat.Type
    • javax.sound.sampled.spi.AudioFileReader
    • javax.sound.sampled.spi.AudioFileWriter
    • javax.sound.sampled.AudioFormat
    • javax.sound.sampled.AudioFormat.Encoding
    • javax.sound.sampled.AudioSystem
    • java.net.Authenticator
    • javax.security.sasl.AuthorizeCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.awt.AWTEventMulticaster (implements java.awt.event.ActionListener, java.awt.event.AdjustmentListener, java.awt.event.ComponentListener, java.awt.event.ContainerListener, java.awt.event.FocusListener, java.awt.event.HierarchyBoundsListener, java.awt.event.HierarchyListener, java.awt.event.InputMethodListener, java.awt.event.ItemListener, java.awt.event.KeyListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener, java.awt.event.TextListener, java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
    • java.awt.AWTKeyStroke (implements java.io.Serializable)
      • javax.swing.KeyStroke
    • java.awt.image.BandCombineOp (implements java.awt.image.RasterOp)
    • javax.sql.rowset.BaseRowSet (implements java.lang.Cloneable, java.io.Serializable)
    • javax.naming.directory.BasicAttribute (implements javax.naming.directory.Attribute)
    • javax.naming.directory.BasicAttributes (implements javax.naming.directory.Attributes)
    • javax.swing.plaf.basic.BasicBorders
    • javax.swing.plaf.basic.BasicBorders.SplitPaneBorder (implements javax.swing.border.Border, javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicButtonListener (implements javax.swing.event.ChangeListener, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicColorChooserUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicComboBoxEditor (implements javax.swing.ComboBoxEditor, java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.metal.MetalComboBoxEditor
        • javax.swing.plaf.metal.MetalComboBoxEditor.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.plaf.basic.BasicComboBoxUI.ComboBoxLayoutManager (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboBoxLayoutManager
    • javax.swing.plaf.basic.BasicComboBoxUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboBoxUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalComboBoxUI.MetalPropertyChangeListener
    • javax.swing.plaf.basic.BasicComboPopup.ItemHandler (implements java.awt.event.ItemListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicComboPopup.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicComboPopup.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.naming.ldap.BasicControl (implements javax.naming.ldap.Control)
      • javax.naming.ldap.ManageReferralControl
      • javax.naming.ldap.PagedResultsControl
      • javax.naming.ldap.PagedResultsResponseControl
      • javax.naming.ldap.SortControl
      • javax.naming.ldap.SortResponseControl
    • javax.swing.plaf.basic.BasicFileChooserUI.SelectionListener (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicGraphicsUtils
    • javax.swing.plaf.basic.BasicHTML
    • javax.swing.plaf.basic.BasicIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicInternalFrameTitlePane.TitlePaneLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.BasicInternalFrameListener (implements javax.swing.event.InternalFrameListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.ComponentHandler (implements java.awt.event.ComponentListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.GlassPaneDispatcher (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFrameLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicInternalFrameUI.InternalFramePropertyChangeListener (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicListUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicListUI.ListDataHandler (implements javax.swing.event.ListDataListener)
    • javax.swing.plaf.basic.BasicListUI.ListSelectionHandler (implements javax.swing.event.ListSelectionListener)
    • javax.swing.plaf.basic.BasicListUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicListUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicMenuItemUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicMenuUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicMenuUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonActionListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicOptionPaneUI.ButtonAreaLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicOptionPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicProgressBarUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ModelListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollBarUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.HSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.MouseWheelHandler (implements java.awt.event.MouseWheelListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.ViewportChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicScrollPaneUI.VSBChangeListener (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.ChangeHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicSliderUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicSliderUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalSliderUI.MetalPropertyListener
    • javax.swing.plaf.basic.BasicSliderUI.ScrollListener (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DividerLayout (implements java.awt.LayoutManager)
    • javax.swing.plaf.basic.BasicSplitPaneDivider.DragController
      • javax.swing.plaf.basic.BasicSplitPaneDivider.VerticalDragController
    • javax.swing.plaf.basic.BasicSplitPaneUI.BasicHorizontalLayoutManager (implements java.awt.LayoutManager2)
      • javax.swing.plaf.basic.BasicSplitPaneUI.BasicVerticalLayoutManager
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardDownRightHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardEndHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardHomeHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardResizeToggleHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.KeyboardUpLeftHandler (implements java.awt.event.ActionListener)
    • javax.swing.plaf.basic.BasicSplitPaneUI.PropertyHandler (implements java.beans.PropertyChangeListener)
    • java.awt.BasicStroke (implements java.awt.Stroke)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabbedPaneLayout (implements java.awt.LayoutManager)
      • javax.swing.plaf.metal.MetalTabbedPaneUI.TabbedPaneLayout
    • javax.swing.plaf.basic.BasicTabbedPaneUI.TabSelectionHandler (implements javax.swing.event.ChangeListener)
    • javax.swing.plaf.basic.BasicTableHeaderUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTableUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTableUI.KeyHandler (implements java.awt.event.KeyListener)
    • javax.swing.plaf.basic.BasicTableUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicToolBarUI.DockingListener (implements javax.swing.event.MouseInputListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalDockingListener
    • javax.swing.plaf.basic.BasicToolBarUI.PropertyListener (implements java.beans.PropertyChangeListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalRolloverListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarContListener (implements java.awt.event.ContainerListener)
      • javax.swing.plaf.metal.MetalToolBarUI.MetalContainerListener
    • javax.swing.plaf.basic.BasicToolBarUI.ToolBarFocusListener (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.CellEditorHandler (implements javax.swing.event.CellEditorListener)
    • javax.swing.plaf.basic.BasicTreeUI.FocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.plaf.basic.BasicTreeUI.MouseInputHandler (implements javax.swing.event.MouseInputListener)
    • javax.swing.plaf.basic.BasicTreeUI.PropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.SelectionModelPropertyChangeHandler (implements java.beans.PropertyChangeListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeExpansionHandler (implements javax.swing.event.TreeExpansionListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.plaf.basic.BasicTreeUI.TreeSelectionHandler (implements javax.swing.event.TreeSelectionListener)
    • java.beans.beancontext.BeanContextChildSupport (implements java.beans.beancontext.BeanContextChild, java.beans.beancontext.BeanContextServicesListener, java.io.Serializable)
      • java.beans.beancontext.BeanContextSupport (implements java.beans.beancontext.BeanContext, java.beans.PropertyChangeListener, java.io.Serializable, java.beans.VetoableChangeListener)
        • java.beans.beancontext.BeanContextServicesSupport (implements java.beans.beancontext.BeanContextServices)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider (implements java.beans.beancontext.BeanContextServiceProvider, java.beans.beancontext.BeanContextServiceRevokedListener)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider (implements java.io.Serializable)
    • java.beans.beancontext.BeanContextSupport.BCSChild (implements java.io.Serializable)
      • java.beans.beancontext.BeanContextServicesSupport.BCSSChild
    • java.beans.beancontext.BeanContextSupport.BCSIterator (implements java.util.Iterator<E>)
    • java.beans.Beans
    • java.text.Bidi
    • javax.xml.bind.Binder<XmlNode>
    • org.omg.CosNaming.Binding (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingHelper
    • org.omg.CosNaming.BindingHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingIteratorHelper
    • org.omg.CosNaming.BindingIteratorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingListHelper
    • org.omg.CosNaming.BindingListHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.BindingType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingTypeHelper
    • org.omg.CosNaming.BindingTypeHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.BitSet (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.print.Book (implements java.awt.print.Pageable)
    • java.lang.Boolean (implements java.lang.Comparable<T>, java.io.Serializable)
    • org.omg.CORBA.BooleanHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.BooleanSeqHelper
    • org.omg.CORBA.BooleanSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.BorderFactory
    • java.awt.BorderLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.plaf.BorderUIResource (implements javax.swing.border.Border, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.BoxLayout (implements java.awt.LayoutManager2, java.io.Serializable)
      • javax.swing.plaf.basic.DefaultMenuLayout (implements javax.swing.plaf.UIResource)
    • java.text.BreakIterator (implements java.lang.Cloneable)
    • java.nio.Buffer
      • java.nio.ByteBuffer (implements java.lang.Comparable<T>)
        • java.nio.MappedByteBuffer
      • java.nio.CharBuffer (implements java.lang.Appendable, java.lang.CharSequence, java.lang.Comparable<T>, java.lang.Readable)
      • java.nio.DoubleBuffer (implements java.lang.Comparable<T>)
      • java.nio.FloatBuffer (implements java.lang.Comparable<T>)
      • java.nio.IntBuffer (implements java.lang.Comparable<T>)
      • java.nio.LongBuffer (implements java.lang.Comparable<T>)
      • java.nio.ShortBuffer (implements java.lang.Comparable<T>)
    • java.awt.BufferCapabilities (implements java.lang.Cloneable)
    • java.awt.BufferCapabilities.FlipContents
    • java.awt.image.BufferStrategy
      • java.awt.Component.BltBufferStrategy
      • java.awt.Component.FlipBufferStrategy
    • javax.swing.ButtonGroup (implements java.io.Serializable)
    • org.omg.CORBA.ByteHolder (implements org.omg.CORBA.portable.Streamable)
    • java.nio.ByteOrder
    • java.net.CacheRequest
    • java.net.CacheResponse
      • java.net.SecureCacheResponse
    • java.util.Calendar (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.util.GregorianCalendar
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHelper
    • org.omg.CosNaming.NamingContextPackage.CannotProceedHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.CardLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.security.cert.Certificate (implements java.io.Serializable)
      • java.security.cert.X509Certificate (implements java.security.cert.X509Extension)
    • javax.security.cert.Certificate
      • javax.security.cert.X509Certificate
    • java.security.cert.Certificate.CertificateRep (implements java.io.Serializable)
    • java.security.cert.CertificateFactory
    • java.security.cert.CertificateFactorySpi
    • java.security.cert.CertPath (implements java.io.Serializable)
    • java.security.cert.CertPath.CertPathRep (implements java.io.Serializable)
    • java.security.cert.CertPathBuilder
    • java.security.cert.CertPathBuilderSpi
    • javax.net.ssl.CertPathTrustManagerParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.cert.CertPathValidator
    • java.security.cert.CertPathValidatorSpi
    • java.security.cert.CertStore
    • java.security.cert.CertStoreSpi
    • org.ietf.jgss.ChannelBinding
    • java.nio.channels.Channels
    • java.lang.Character (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Character.Subset
      • java.lang.Character.UnicodeBlock
      • java.awt.im.InputSubset
    • org.omg.CORBA.CharHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.CharSeqHelper
    • org.omg.CORBA.CharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.nio.charset.Charset (implements java.lang.Comparable<T>)
    • java.nio.charset.CharsetDecoder
    • java.nio.charset.CharsetEncoder
    • java.nio.charset.spi.CharsetProvider
    • java.awt.CheckboxGroup (implements java.io.Serializable)
    • javax.security.auth.callback.ChoiceCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmChoiceCallback
    • javax.crypto.Cipher
      • javax.crypto.NullCipher
    • javax.crypto.CipherSpi
    • java.lang.Class<T> (implements java.lang.reflect.AnnotatedElement, java.lang.reflect.GenericDeclaration, java.io.Serializable, java.lang.reflect.Type)
    • java.lang.instrument.ClassDefinition
    • javax.rmi.CORBA.ClassDesc (implements java.io.Serializable)
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader
          • javax.management.loading.MLet (implements java.io.Externalizable, javax.management.MBeanRegistration, javax.management.loading.MLetMBean)
            • javax.management.loading.PrivateMLet (implements javax.management.loading.PrivateClassLoader)
    • java.awt.datatransfer.Clipboard
    • org.omg.IOP.CodecFactoryHelper
    • java.nio.charset.CoderResult
    • java.security.CodeSigner (implements java.io.Serializable)
    • java.security.CodeSource (implements java.io.Serializable)
    • java.nio.charset.CodingErrorAction
    • java.text.CollationElementIterator
    • java.text.CollationKey (implements java.lang.Comparable<T>)
    • java.text.Collator (implements java.lang.Cloneable, java.util.Comparator<T>)
      • java.text.RuleBasedCollator
    • java.security.cert.CollectionCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.util.Collections
    • java.awt.Color (implements java.awt.Paint, java.io.Serializable)
      • javax.swing.plaf.ColorUIResource (implements javax.swing.plaf.UIResource)
      • java.awt.SystemColor (implements java.io.Serializable)
    • javax.swing.colorchooser.ColorChooserComponentFactory
    • java.awt.image.ColorConvertOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.ColorModel (implements java.awt.Transparency)
      • java.awt.image.ComponentColorModel
      • java.awt.image.IndexColorModel
      • java.awt.image.PackedColorModel
        • java.awt.image.DirectColorModel
    • java.awt.color.ColorSpace (implements java.io.Serializable)
      • java.awt.color.ICC_ColorSpace
    • javax.swing.plaf.synth.ColorType
    • javax.activation.CommandInfo
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap
    • javax.script.CompiledScript
    • java.lang.Compiler
    • javax.annotation.processing.Completions
    • org.omg.CORBA.CompletionStatus (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.CompletionStatusHelper
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Button (implements javax.accessibility.Accessible)
      • java.awt.Canvas (implements javax.accessibility.Accessible)
      • java.awt.Checkbox (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Choice (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Container
        • javax.swing.plaf.basic.BasicSplitPaneDivider (implements java.beans.PropertyChangeListener)
        • javax.swing.CellRendererPane (implements javax.accessibility.Accessible)
        • javax.swing.tree.DefaultTreeCellEditor.EditorContainer
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
              • javax.swing.plaf.basic.BasicArrowButton (implements javax.swing.SwingConstants)
                • javax.swing.plaf.metal.MetalScrollButton
              • javax.swing.plaf.metal.MetalComboBoxButton
            • javax.swing.JMenuItem (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JCheckBoxMenuItem (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
              • javax.swing.JMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JRadioButtonMenuItem (implements javax.accessibility.Accessible)
            • javax.swing.JToggleButton (implements javax.accessibility.Accessible)
              • javax.swing.JCheckBox (implements javax.accessibility.Accessible)
              • javax.swing.JRadioButton (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicInternalFrameTitlePane
            • javax.swing.plaf.metal.MetalInternalFrameTitlePane
          • javax.swing.Box (implements javax.accessibility.Accessible)
          • javax.swing.Box.Filler (implements javax.accessibility.Accessible)
          • javax.swing.JColorChooser (implements javax.accessibility.Accessible)
          • javax.swing.JComboBox (implements javax.accessibility.Accessible, java.awt.event.ActionListener, java.awt.ItemSelectable, javax.swing.event.ListDataListener)
          • javax.swing.JFileChooser (implements javax.accessibility.Accessible)
          • javax.swing.JInternalFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JInternalFrame.JDesktopIcon (implements javax.accessibility.Accessible)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.plaf.basic.BasicComboBoxRenderer (implements javax.swing.ListCellRenderer, java.io.Serializable)
              • javax.swing.plaf.basic.BasicComboBoxRenderer.UIResource (implements javax.swing.plaf.UIResource)
            • javax.swing.DefaultListCellRenderer (implements javax.swing.ListCellRenderer, java.io.Serializable)
              • javax.swing.DefaultListCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
              • javax.swing.plaf.metal.MetalFileChooserUI.FileRenderer
              • javax.swing.plaf.metal.MetalFileChooserUI.FilterComboBoxRenderer
            • javax.swing.table.DefaultTableCellRenderer (implements java.io.Serializable, javax.swing.table.TableCellRenderer)
              • javax.swing.table.DefaultTableCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
            • javax.swing.tree.DefaultTreeCellRenderer (implements javax.swing.tree.TreeCellRenderer)
          • javax.swing.JLayeredPane (implements javax.accessibility.Accessible)
            • javax.swing.JDesktopPane (implements javax.accessibility.Accessible)
          • javax.swing.JList (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JMenuBar (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicInternalFrameTitlePane.SystemMenuBar
          • javax.swing.JOptionPane (implements javax.accessibility.Accessible)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • javax.swing.colorchooser.AbstractColorChooserPanel
            • javax.swing.JSpinner.DefaultEditor (implements javax.swing.event.ChangeListener, java.awt.LayoutManager, java.beans.PropertyChangeListener)
              • javax.swing.JSpinner.DateEditor
              • javax.swing.JSpinner.ListEditor
              • javax.swing.JSpinner.NumberEditor
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
            • javax.swing.plaf.basic.BasicComboPopup (implements javax.swing.plaf.basic.ComboPopup)
              • javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
          • javax.swing.JProgressBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JRootPane (implements javax.accessibility.Accessible)
          • javax.swing.JScrollBar (implements javax.accessibility.Accessible, java.awt.Adjustable)
            • javax.swing.JScrollPane.ScrollBar (implements javax.swing.plaf.UIResource)
          • javax.swing.JScrollPane (implements javax.accessibility.Accessible, javax.swing.ScrollPaneConstants)
          • javax.swing.JSeparator (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.JPopupMenu.Separator
            • javax.swing.JToolBar.Separator
          • javax.swing.JSlider (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JSpinner (implements javax.accessibility.Accessible)
          • javax.swing.JSplitPane (implements javax.accessibility.Accessible)
          • javax.swing.JTabbedPane (implements javax.accessibility.Accessible, java.io.Serializable, javax.swing.SwingConstants)
          • javax.swing.JTable (implements javax.accessibility.Accessible, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, javax.swing.event.RowSorterListener, javax.swing.Scrollable, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
          • javax.swing.table.JTableHeader (implements javax.accessibility.Accessible, javax.swing.event.TableColumnModelListener)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JEditorPane
              • javax.swing.JTextPane
            • javax.swing.JTextArea
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.tree.DefaultTreeCellEditor.DefaultTextField
              • javax.swing.JFormattedTextField
              • javax.swing.JPasswordField
          • javax.swing.JToolBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JToolTip (implements javax.accessibility.Accessible)
          • javax.swing.JTree (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JViewport (implements javax.accessibility.Accessible)
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • javax.swing.JApplet (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
        • java.awt.ScrollPane (implements javax.accessibility.Accessible)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • javax.swing.plaf.basic.BasicToolBarUI.DragWindow
          • java.awt.Dialog
            • java.awt.FileDialog
            • javax.swing.JDialog (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • java.awt.Frame (implements java.awt.MenuContainer)
            • javax.swing.JFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JWindow (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
      • java.awt.Label (implements javax.accessibility.Accessible)
      • java.awt.List (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Scrollbar (implements javax.accessibility.Accessible, java.awt.Adjustable)
      • java.awt.TextComponent (implements javax.accessibility.Accessible)
        • java.awt.TextArea
        • java.awt.TextField
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (implements java.awt.event.ComponentListener)
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (implements java.awt.event.FocusListener)
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
      • javax.swing.plaf.basic.BasicSliderUI.ComponentHandler
      • javax.swing.plaf.basic.BasicTreeUI.ComponentHandler (implements java.awt.event.ActionListener)
      • javax.swing.JViewport.ViewListener (implements java.io.Serializable)
    • org.omg.IOP.ComponentIdHelper
    • java.awt.ComponentOrientation (implements java.io.Serializable)
    • javax.swing.plaf.ComponentUI
      • javax.swing.plaf.ButtonUI
        • javax.swing.plaf.basic.BasicButtonUI
          • javax.swing.plaf.basic.BasicToggleButtonUI
            • javax.swing.plaf.basic.BasicRadioButtonUI
              • javax.swing.plaf.basic.BasicCheckBoxUI
              • javax.swing.plaf.metal.MetalRadioButtonUI
                • javax.swing.plaf.metal.MetalCheckBoxUI
            • javax.swing.plaf.metal.MetalToggleButtonUI
          • javax.swing.plaf.metal.MetalButtonUI
        • javax.swing.plaf.MenuItemUI
          • javax.swing.plaf.basic.BasicMenuItemUI
            • javax.swing.plaf.basic.BasicCheckBoxMenuItemUI
            • javax.swing.plaf.basic.BasicMenuUI
            • javax.swing.plaf.basic.BasicRadioButtonMenuItemUI
          • javax.swing.plaf.multi.MultiMenuItemUI
        • javax.swing.plaf.multi.MultiButtonUI
      • javax.swing.plaf.ColorChooserUI
        • javax.swing.plaf.basic.BasicColorChooserUI
        • javax.swing.plaf.multi.MultiColorChooserUI
      • javax.swing.plaf.ComboBoxUI
        • javax.swing.plaf.basic.BasicComboBoxUI
          • javax.swing.plaf.metal.MetalComboBoxUI
        • javax.swing.plaf.multi.MultiComboBoxUI
      • javax.swing.plaf.DesktopIconUI
        • javax.swing.plaf.basic.BasicDesktopIconUI
          • javax.swing.plaf.metal.MetalDesktopIconUI
        • javax.swing.plaf.multi.MultiDesktopIconUI
      • javax.swing.plaf.DesktopPaneUI
        • javax.swing.plaf.basic.BasicDesktopPaneUI
        • javax.swing.plaf.multi.MultiDesktopPaneUI
      • javax.swing.plaf.FileChooserUI
        • javax.swing.plaf.basic.BasicFileChooserUI
          • javax.swing.plaf.metal.MetalFileChooserUI
        • javax.swing.plaf.multi.MultiFileChooserUI
      • javax.swing.plaf.InternalFrameUI
        • javax.swing.plaf.basic.BasicInternalFrameUI
          • javax.swing.plaf.metal.MetalInternalFrameUI
        • javax.swing.plaf.multi.MultiInternalFrameUI
      • javax.swing.plaf.LabelUI
        • javax.swing.plaf.basic.BasicLabelUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalLabelUI
        • javax.swing.plaf.multi.MultiLabelUI
      • javax.swing.plaf.ListUI
        • javax.swing.plaf.basic.BasicListUI
        • javax.swing.plaf.multi.MultiListUI
      • javax.swing.plaf.MenuBarUI
        • javax.swing.plaf.basic.BasicMenuBarUI
          • javax.swing.plaf.metal.MetalMenuBarUI
        • javax.swing.plaf.multi.MultiMenuBarUI
      • javax.swing.plaf.OptionPaneUI
        • javax.swing.plaf.basic.BasicOptionPaneUI
        • javax.swing.plaf.multi.MultiOptionPaneUI
      • javax.swing.plaf.PanelUI
        • javax.swing.plaf.basic.BasicPanelUI
        • javax.swing.plaf.multi.MultiPanelUI
      • javax.swing.plaf.PopupMenuUI
        • javax.swing.plaf.basic.BasicPopupMenuUI
        • javax.swing.plaf.multi.MultiPopupMenuUI
      • javax.swing.plaf.ProgressBarUI
        • javax.swing.plaf.basic.BasicProgressBarUI
          • javax.swing.plaf.metal.MetalProgressBarUI
        • javax.swing.plaf.multi.MultiProgressBarUI
      • javax.swing.plaf.RootPaneUI
        • javax.swing.plaf.basic.BasicRootPaneUI (implements java.beans.PropertyChangeListener)
          • javax.swing.plaf.metal.MetalRootPaneUI
        • javax.swing.plaf.multi.MultiRootPaneUI
      • javax.swing.plaf.ScrollBarUI
        • javax.swing.plaf.basic.BasicScrollBarUI (implements java.awt.LayoutManager, javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalScrollBarUI
        • javax.swing.plaf.multi.MultiScrollBarUI
      • javax.swing.plaf.ScrollPaneUI
        • javax.swing.plaf.basic.BasicScrollPaneUI (implements javax.swing.ScrollPaneConstants)
          • javax.swing.plaf.metal.MetalScrollPaneUI
        • javax.swing.plaf.multi.MultiScrollPaneUI
      • javax.swing.plaf.SeparatorUI
        • javax.swing.plaf.basic.BasicSeparatorUI
          • javax.swing.plaf.basic.BasicPopupMenuSeparatorUI
          • javax.swing.plaf.basic.BasicToolBarSeparatorUI
          • javax.swing.plaf.metal.MetalSeparatorUI
            • javax.swing.plaf.metal.MetalPopupMenuSeparatorUI
        • javax.swing.plaf.multi.MultiSeparatorUI
      • javax.swing.plaf.SliderUI
        • javax.swing.plaf.basic.BasicSliderUI
          • javax.swing.plaf.metal.MetalSliderUI
        • javax.swing.plaf.multi.MultiSliderUI
      • javax.swing.plaf.SpinnerUI
        • javax.swing.plaf.basic.BasicSpinnerUI
        • javax.swing.plaf.multi.MultiSpinnerUI
      • javax.swing.plaf.SplitPaneUI
        • javax.swing.plaf.basic.BasicSplitPaneUI
          • javax.swing.plaf.metal.MetalSplitPaneUI
        • javax.swing.plaf.multi.MultiSplitPaneUI
      • javax.swing.plaf.TabbedPaneUI
        • javax.swing.plaf.basic.BasicTabbedPaneUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalTabbedPaneUI
        • javax.swing.plaf.multi.MultiTabbedPaneUI
      • javax.swing.plaf.TableHeaderUI
        • javax.swing.plaf.basic.BasicTableHeaderUI
        • javax.swing.plaf.multi.MultiTableHeaderUI
      • javax.swing.plaf.TableUI
        • javax.swing.plaf.basic.BasicTableUI
        • javax.swing.plaf.multi.MultiTableUI
      • javax.swing.plaf.TextUI
        • javax.swing.plaf.basic.BasicTextUI (implements javax.swing.text.ViewFactory)
          • javax.swing.plaf.basic.BasicEditorPaneUI
            • javax.swing.plaf.basic.BasicTextPaneUI
          • javax.swing.plaf.basic.BasicTextAreaUI
          • javax.swing.plaf.basic.BasicTextFieldUI
            • javax.swing.plaf.basic.BasicFormattedTextFieldUI
            • javax.swing.plaf.basic.BasicPasswordFieldUI
            • javax.swing.plaf.metal.MetalTextFieldUI
          • javax.swing.text.DefaultTextUI
        • javax.swing.plaf.multi.MultiTextUI
      • javax.swing.plaf.ToolBarUI
        • javax.swing.plaf.basic.BasicToolBarUI (implements javax.swing.SwingConstants)
          • javax.swing.plaf.metal.MetalToolBarUI
        • javax.swing.plaf.multi.MultiToolBarUI
      • javax.swing.plaf.ToolTipUI
        • javax.swing.plaf.basic.BasicToolTipUI
          • javax.swing.plaf.metal.MetalToolTipUI
        • javax.swing.plaf.multi.MultiToolTipUI
      • javax.swing.plaf.TreeUI
        • javax.swing.plaf.basic.BasicTreeUI
          • javax.swing.plaf.metal.MetalTreeUI
        • javax.swing.plaf.multi.MultiTreeUI
      • javax.swing.plaf.ViewportUI
        • javax.swing.plaf.basic.BasicViewportUI
        • javax.swing.plaf.multi.MultiViewportUI
    • javax.management.openmbean.CompositeDataInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.management.openmbean.CompositeDataSupport (implements javax.management.openmbean.CompositeData, java.io.Serializable)
    • javax.naming.CompositeName (implements javax.naming.Name)
    • javax.naming.CompoundName (implements javax.naming.Name)
    • javax.security.auth.login.Configuration
    • javax.security.auth.login.ConfigurationSpi
    • javax.security.auth.callback.ConfirmationCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.io.Console (implements java.io.Flushable)
    • java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • java.awt.event.ContainerAdapter (implements java.awt.event.ContainerListener)
    • java.net.ContentHandler
    • javax.swing.text.html.parser.ContentModel (implements java.io.Serializable)
    • org.omg.CORBA.Context
    • org.omg.CORBA.ContextList
    • javax.sound.sampled.Control
      • javax.sound.sampled.BooleanControl
      • javax.sound.sampled.CompoundControl
      • javax.sound.sampled.EnumControl
      • javax.sound.sampled.FloatControl
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.BooleanControl.Type
      • javax.sound.sampled.CompoundControl.Type
      • javax.sound.sampled.EnumControl.Type
      • javax.sound.sampled.FloatControl.Type
    • javax.naming.ldap.ControlFactory
    • java.awt.image.ConvolveOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.net.CookieHandler
      • java.net.CookieManager
    • org.omg.PortableServer.ServantLocatorPackage.CookieHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.concurrent.CopyOnWriteArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
    • java.util.concurrent.CountDownLatch
    • java.util.zip.CRC32 (implements java.util.zip.Checksum)
    • java.security.cert.CRL
      • java.security.cert.X509CRL (implements java.security.cert.X509Extension)
    • javax.swing.text.html.CSS (implements java.io.Serializable)
    • javax.swing.text.html.CSS.Attribute
    • java.awt.geom.CubicCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.CubicCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.CubicCurve2D.Float (implements java.io.Serializable)
    • java.util.Currency (implements java.io.Serializable)
    • org.omg.CORBA.CurrentHelper
    • org.omg.PortableServer.CurrentHelper
    • org.omg.PortableInterceptor.CurrentHelper
    • org.omg.CORBA.CurrentHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.Cursor (implements java.io.Serializable)
    • java.util.concurrent.CyclicBarrier
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferByte
      • java.awt.image.DataBufferDouble
      • java.awt.image.DataBufferFloat
      • java.awt.image.DataBufferInt
      • java.awt.image.DataBufferShort
      • java.awt.image.DataBufferUShort
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • javax.activation.ActivationDataFlavor
    • java.net.DatagramPacket
    • java.net.DatagramSocket
      • java.net.MulticastSocket
    • java.net.DatagramSocketImpl (implements java.net.SocketOptions)
    • javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • javax.xml.datatype.DatatypeConstants
    • javax.xml.datatype.DatatypeConstants.Field
    • javax.xml.bind.DatatypeConverter
    • javax.xml.datatype.DatatypeFactory
    • java.util.Date (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.sql.Date
      • java.sql.Time
      • java.sql.Timestamp
    • java.text.DateFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.DateTimeSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DateTimeAtCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtCreation (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtProcessing (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobHoldUntil (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • java.text.DecimalFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • javax.swing.DefaultBoundedRangeModel (implements javax.swing.BoundedRangeModel, java.io.Serializable)
    • javax.swing.DefaultButtonModel (implements javax.swing.ButtonModel, java.io.Serializable)
      • javax.swing.JToggleButton.ToggleButtonModel
    • javax.swing.DefaultCellEditor.EditorDelegate (implements java.awt.event.ActionListener, java.awt.event.ItemListener, java.io.Serializable)
    • javax.swing.colorchooser.DefaultColorSelectionModel (implements javax.swing.colorchooser.ColorSelectionModel, java.io.Serializable)
    • javax.swing.DefaultDesktopManager (implements javax.swing.DesktopManager, java.io.Serializable)
    • org.xml.sax.helpers.DefaultHandler (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
      • org.xml.sax.ext.DefaultHandler2 (implements org.xml.sax.ext.DeclHandler, org.xml.sax.ext.EntityResolver2, org.xml.sax.ext.LexicalHandler)
    • javax.swing.DefaultListSelectionModel (implements java.lang.Cloneable, javax.swing.ListSelectionModel, java.io.Serializable)
    • javax.management.DefaultLoaderRepository
    • javax.management.loading.DefaultLoaderRepository
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
      • javax.swing.JTree.DynamicUtilTreeNode
    • javax.swing.DefaultRowSorter.ModelWrapper<M,I>
    • javax.swing.DefaultSingleSelectionModel (implements java.io.Serializable, javax.swing.SingleSelectionModel)
    • javax.swing.text.DefaultStyledDocument.ElementBuffer (implements java.io.Serializable)
    • javax.swing.text.DefaultStyledDocument.ElementSpec
    • javax.swing.table.DefaultTableColumnModel (implements javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, java.io.Serializable, javax.swing.table.TableColumnModel)
    • javax.swing.tree.DefaultTreeCellEditor (implements java.awt.event.ActionListener, javax.swing.tree.TreeCellEditor, javax.swing.event.TreeSelectionListener)
    • javax.swing.tree.DefaultTreeModel (implements java.io.Serializable, javax.swing.tree.TreeModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
      • javax.swing.JTree.EmptySelectionModel
    • javax.xml.bind.helpers.DefaultValidationEventHandler (implements javax.xml.bind.ValidationEventHandler)
    • org.omg.CORBA.DefinitionKind (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DefinitionKindHelper
    • java.util.zip.Deflater
    • org.omg.CORBA.portable.Delegate
      • org.omg.CORBA_2_3.portable.Delegate
    • javax.management.modelmbean.DescriptorSupport (implements javax.management.Descriptor)
    • javax.crypto.spec.DESedeKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DESKeySpec (implements java.security.spec.KeySpec)
    • java.awt.Desktop
    • javax.crypto.spec.DHGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHPrivateKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DHPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.tools.DiagnosticCollector<S> (implements javax.tools.DiagnosticListener<S>)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • java.security.Provider
            • java.security.AuthProvider
        • javax.swing.UIDefaults
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
      • java.awt.Dimension (implements java.io.Serializable)
        • javax.swing.plaf.DimensionUIResource (implements javax.swing.plaf.UIResource)
    • javax.naming.spi.DirStateFactory.Result
    • java.awt.DisplayMode
    • java.awt.dnd.DnDConstants
    • javax.print.DocFlavor (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.DocFlavor.BYTE_ARRAY
      • javax.print.DocFlavor.CHAR_ARRAY
      • javax.print.DocFlavor.INPUT_STREAM
      • javax.print.DocFlavor.READER
      • javax.print.DocFlavor.SERVICE_FORMATTED
      • javax.print.DocFlavor.STRING
      • javax.print.DocFlavor.URL
    • javax.xml.parsers.DocumentBuilder
    • javax.xml.parsers.DocumentBuilderFactory
    • javax.swing.event.DocumentEvent.EventType
    • javax.swing.text.DocumentFilter
    • javax.swing.text.DocumentFilter.FilterBypass
    • javax.xml.crypto.dom.DOMCryptoContext (implements javax.xml.crypto.XMLCryptoContext)
      • javax.xml.crypto.dsig.dom.DOMSignContext (implements javax.xml.crypto.dsig.XMLSignContext)
      • javax.xml.crypto.dsig.dom.DOMValidateContext (implements javax.xml.crypto.dsig.XMLValidateContext)
    • org.w3c.dom.bootstrap.DOMImplementationRegistry
    • javax.xml.transform.dom.DOMResult (implements javax.xml.transform.Result)
      • javax.xml.soap.SAAJResult
    • javax.xml.transform.dom.DOMSource (implements javax.xml.transform.Source)
    • javax.xml.crypto.dom.DOMStructure (implements javax.xml.crypto.XMLStructure)
    • org.omg.CORBA.DoubleHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.DoubleSeqHelper
    • org.omg.CORBA.DoubleSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.dnd.DragGestureRecognizer (implements java.io.Serializable)
      • java.awt.dnd.MouseDragGestureRecognizer (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.dnd.DragSource (implements java.io.Serializable)
    • java.awt.dnd.DragSourceAdapter (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener)
    • java.awt.dnd.DragSourceContext (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener, java.io.Serializable)
    • java.sql.DriverManager
    • java.sql.DriverPropertyInfo
    • java.awt.dnd.DropTarget (implements java.awt.dnd.DropTargetListener, java.io.Serializable)
    • java.awt.dnd.DropTarget.DropTargetAutoScroller (implements java.awt.event.ActionListener)
    • java.awt.dnd.DropTargetAdapter (implements java.awt.dnd.DropTargetListener)
    • java.awt.dnd.DropTargetContext (implements java.io.Serializable)
    • java.awt.dnd.DropTargetContext.TransferableProxy (implements java.awt.datatransfer.Transferable)
    • java.security.spec.DSAParameterSpec (implements java.security.spec.AlgorithmParameterSpec, java.security.interfaces.DSAParams)
    • java.security.spec.DSAPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.DSAPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.swing.text.html.parser.DTD (implements javax.swing.text.html.parser.DTDConstants)
    • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateNameHelper
    • javax.xml.datatype.Duration
    • org.omg.DynamicAny.DynAnyFactoryHelper
    • org.omg.DynamicAny.DynAnyHelper
    • org.omg.DynamicAny.DynAnySeqHelper
    • org.omg.DynamicAny.DynArrayHelper
    • org.omg.DynamicAny.DynEnumHelper
    • org.omg.DynamicAny.DynFixedHelper
    • org.omg.DynamicAny.DynSequenceHelper
    • org.omg.DynamicAny.DynStructHelper
    • org.omg.DynamicAny.DynUnionHelper
    • org.omg.DynamicAny.DynValueHelper
    • java.security.spec.ECFieldF2m (implements java.security.spec.ECField)
    • java.security.spec.ECFieldFp (implements java.security.spec.ECField)
    • java.security.spec.ECGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECPoint
    • java.security.spec.ECPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.ECPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.swing.text.EditorKit (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.text.DefaultEditorKit
        • javax.swing.text.StyledEditorKit
          • javax.swing.text.html.HTMLEditorKit (implements javax.accessibility.Accessible)
          • javax.swing.text.rtf.RTFEditorKit
    • javax.swing.text.html.parser.Element (implements javax.swing.text.html.parser.DTDConstants, java.io.Serializable)
    • javax.lang.model.util.ElementFilter
    • javax.swing.text.ElementIterator (implements java.lang.Cloneable)
    • java.security.spec.EllipticCurve
    • java.security.spec.EncodedKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.PKCS8EncodedKeySpec
      • java.security.spec.X509EncodedKeySpec
    • java.beans.Encoder
      • java.beans.XMLEncoder
    • org.omg.IOP.Encoding (implements org.omg.CORBA.portable.IDLEntity)
    • javax.crypto.EncryptedPrivateKeyInfo
    • javax.xml.ws.Endpoint
    • javax.swing.text.html.parser.Entity (implements javax.swing.text.html.parser.DTDConstants)
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.print.attribute.EnumSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Chromaticity (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ColorSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.Compression (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.Fidelity (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Finishings (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobState (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Media (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
        • javax.print.attribute.standard.MediaName (implements javax.print.attribute.Attribute)
        • javax.print.attribute.standard.MediaSizeName
        • javax.print.attribute.standard.MediaTray (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.MultipleDocumentHandling (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.OrientationRequested (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PDLOverrideSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PresentationDirection (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterIsAcceptingJobs (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterState (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.PrintQuality (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ReferenceUriSchemesSupported (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Severity (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.SheetCollate (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Sides (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • org.omg.CORBA.Environment
    • java.util.logging.ErrorManager
    • java.awt.Event (implements java.io.Serializable)
    • java.beans.EventHandler (implements java.lang.reflect.InvocationHandler)
    • javax.swing.event.EventListenerList (implements java.io.Serializable)
    • java.util.EventListenerProxy (implements java.util.EventListener)
      • java.awt.event.AWTEventListenerProxy (implements java.awt.event.AWTEventListener)
      • java.beans.PropertyChangeListenerProxy (implements java.beans.PropertyChangeListener)
      • java.beans.VetoableChangeListenerProxy (implements java.beans.VetoableChangeListener)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
        • java.awt.event.ActionEvent
        • java.awt.event.AdjustmentEvent
        • javax.swing.event.AncestorEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.ContainerEvent
          • java.awt.event.FocusEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
              • javax.swing.event.MenuKeyEvent
            • java.awt.event.MouseEvent
              • javax.swing.event.MenuDragMouseEvent
              • java.awt.event.MouseWheelEvent
          • java.awt.event.PaintEvent
          • java.awt.event.WindowEvent
        • java.awt.event.HierarchyEvent
        • java.awt.event.InputMethodEvent
        • javax.swing.event.InternalFrameEvent
        • java.awt.event.InvocationEvent (implements java.awt.ActiveEvent)
        • java.awt.event.ItemEvent
        • java.awt.event.TextEvent
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextMembershipEvent
        • java.beans.beancontext.BeanContextServiceAvailableEvent
        • java.beans.beancontext.BeanContextServiceRevokedEvent
      • javax.swing.event.CaretEvent
      • javax.swing.event.ChangeEvent
      • javax.sql.ConnectionEvent
      • java.awt.dnd.DragGestureEvent
      • java.awt.dnd.DragSourceEvent
        • java.awt.dnd.DragSourceDragEvent
        • java.awt.dnd.DragSourceDropEvent
      • java.awt.dnd.DropTargetEvent
        • java.awt.dnd.DropTargetDragEvent
        • java.awt.dnd.DropTargetDropEvent
      • java.awt.datatransfer.FlavorEvent
      • javax.net.ssl.HandshakeCompletedEvent
      • javax.swing.event.HyperlinkEvent
        • javax.swing.text.html.HTMLFrameHyperlinkEvent
          • javax.swing.text.html.FormSubmitEvent
      • javax.sound.sampled.LineEvent
      • javax.swing.event.ListDataEvent
      • javax.swing.event.ListSelectionEvent
      • javax.swing.event.MenuEvent
      • javax.naming.event.NamingEvent
      • javax.naming.event.NamingExceptionEvent
      • java.util.prefs.NodeChangeEvent
      • javax.management.Notification
        • javax.management.AttributeChangeNotification
        • javax.management.remote.JMXConnectionNotification
        • javax.management.MBeanServerNotification
        • javax.management.monitor.MonitorNotification
        • javax.management.relation.RelationNotification
        • javax.management.timer.TimerNotification
      • javax.swing.event.PopupMenuEvent
      • java.util.prefs.PreferenceChangeEvent
      • javax.print.event.PrintEvent
        • javax.print.event.PrintJobAttributeEvent
        • javax.print.event.PrintJobEvent
        • javax.print.event.PrintServiceAttributeEvent
      • java.beans.PropertyChangeEvent
        • java.beans.IndexedPropertyChangeEvent
      • javax.sql.RowSetEvent
      • javax.swing.event.RowSorterEvent
      • javax.net.ssl.SSLSessionBindingEvent
      • javax.sql.StatementEvent
      • javax.swing.event.TableColumnModelEvent
      • javax.swing.event.TableModelEvent
      • javax.swing.event.TreeExpansionEvent
      • javax.swing.event.TreeModelEvent
      • javax.swing.event.TreeSelectionEvent
      • javax.swing.event.UndoableEditEvent
      • javax.naming.ldap.UnsolicitedNotificationEvent
    • java.awt.EventQueue
    • javax.xml.stream.util.EventReaderDelegate (implements javax.xml.stream.XMLEventReader)
    • javax.xml.crypto.dsig.spec.ExcC14NParameterSpec (implements javax.xml.crypto.dsig.spec.C14NMethodParameterSpec)
    • org.omg.CORBA.ExceptionList
    • java.util.concurrent.Exchanger<V>
    • java.util.concurrent.ExecutorCompletionService<V> (implements java.util.concurrent.CompletionService<V>)
    • java.util.concurrent.Executors
    • javax.crypto.ExemptionMechanism
    • javax.crypto.ExemptionMechanismSpi
    • java.beans.FeatureDescriptor
      • java.beans.BeanDescriptor
      • java.beans.EventSetDescriptor
      • java.beans.MethodDescriptor
      • java.beans.ParameterDescriptor
      • java.beans.PropertyDescriptor
        • java.beans.IndexedPropertyDescriptor
    • org.omg.CORBA.FieldNameHelper
    • org.omg.DynamicAny.FieldNameHelper
    • java.text.FieldPosition
    • java.io.File (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.nio.channels.FileChannel.MapMode
    • javax.activation.FileDataSource (implements javax.activation.DataSource)
    • java.io.FileDescriptor
    • javax.swing.filechooser.FileFilter
      • javax.swing.plaf.basic.BasicFileChooserUI.AcceptAllFileFilter
      • javax.swing.filechooser.FileNameExtensionFilter
    • java.nio.channels.FileLock
    • javax.swing.filechooser.FileSystemView
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap
    • javax.swing.filechooser.FileView
      • javax.swing.plaf.basic.BasicFileChooserUI.BasicFileView
    • java.awt.image.FilteredImageSource (implements java.awt.image.ImageProducer)
    • org.omg.CORBA.FixedHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.geom.FlatteningPathIterator (implements java.awt.geom.PathIterator)
    • org.omg.CORBA.FloatHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.FloatSeqHelper
    • org.omg.CORBA.FloatSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.FlowLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • javax.swing.text.FlowView.FlowStrategy
    • java.awt.event.FocusAdapter (implements java.awt.event.FocusListener)
      • javax.swing.plaf.basic.BasicSplitPaneUI.FocusHandler
      • javax.swing.plaf.basic.BasicTabbedPaneUI.FocusHandler
    • java.awt.FocusTraversalPolicy
      • java.awt.ContainerOrderFocusTraversalPolicy (implements java.io.Serializable)
        • java.awt.DefaultFocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
        • javax.swing.SortingFocusTraversalPolicy
          • javax.swing.LayoutFocusTraversalPolicy (implements java.io.Serializable)
    • java.awt.Font (implements java.io.Serializable)
      • javax.swing.plaf.FontUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.FontMetrics (implements java.io.Serializable)
    • java.awt.font.FontRenderContext
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
      • java.text.MessageFormat
      • java.text.NumberFormat
        • java.text.ChoiceFormat
        • java.text.DecimalFormat
    • javax.sound.sampled.spi.FormatConversionProvider
    • org.omg.IOP.CodecPackage.FormatMismatchHelper
    • java.util.FormattableFlags
    • java.util.Formatter (implements java.io.Closeable, java.io.Flushable)
    • java.util.logging.Formatter
      • java.util.logging.SimpleFormatter
      • java.util.logging.XMLFormatter
    • javax.tools.ForwardingFileObject<F> (implements javax.tools.FileObject)
      • javax.tools.ForwardingJavaFileObject<F> (implements javax.tools.JavaFileObject)
    • javax.tools.ForwardingJavaFileManager<M> (implements javax.tools.JavaFileManager)
    • org.omg.PortableServer.ForwardRequestHelper
    • org.omg.PortableInterceptor.ForwardRequestHelper
    • java.util.concurrent.FutureTask<V> (implements java.util.concurrent.RunnableFuture<V>)
    • javax.swing.text.GapContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • java.awt.font.GlyphJustificationInfo
    • java.awt.font.GlyphMetrics
    • java.awt.font.GlyphVector (implements java.lang.Cloneable)
    • javax.swing.text.GlyphView.GlyphPainter
    • java.awt.GradientPaint (implements java.awt.Paint)
    • java.awt.font.GraphicAttribute
      • java.awt.font.ImageGraphicAttribute
      • java.awt.font.ShapeGraphicAttribute
    • java.awt.Graphics
      • javax.swing.DebugGraphics
      • java.awt.Graphics2D
    • java.awt.GraphicsConfigTemplate (implements java.io.Serializable)
    • java.awt.GraphicsConfiguration
    • java.awt.GraphicsDevice
    • java.awt.GraphicsEnvironment
    • java.awt.GridBagConstraints (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.GridBagLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.GridBagLayoutInfo (implements java.io.Serializable)
    • java.awt.GridLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • javax.swing.GroupLayout (implements java.awt.LayoutManager2)
    • javax.swing.GroupLayout.Group
      • javax.swing.GroupLayout.ParallelGroup
      • javax.swing.GroupLayout.SequentialGroup
    • org.ietf.jgss.GSSManager
    • java.security.GuardedObject (implements java.io.Serializable)
    • java.util.logging.Handler
      • java.util.logging.MemoryHandler
      • java.util.logging.StreamHandler
        • java.util.logging.ConsoleHandler
        • java.util.logging.FileHandler
        • java.util.logging.SocketHandler
    • org.xml.sax.HandlerBase (implements org.xml.sax.DocumentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler)
    • javax.print.attribute.HashAttributeSet (implements javax.print.attribute.AttributeSet, java.io.Serializable)
      • javax.print.attribute.HashDocAttributeSet (implements javax.print.attribute.DocAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintJobAttributeSet (implements javax.print.attribute.PrintJobAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintRequestAttributeSet (implements javax.print.attribute.PrintRequestAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintServiceAttributeSet (implements javax.print.attribute.PrintServiceAttributeSet, java.io.Serializable)
    • java.awt.event.HierarchyBoundsAdapter (implements java.awt.event.HierarchyBoundsListener)
    • javax.xml.crypto.dsig.spec.HMACParameterSpec (implements javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec)
    • javax.xml.ws.Holder<T>
    • javax.swing.text.html.HTML
    • javax.swing.text.html.HTML.Attribute
    • javax.swing.text.html.HTML.Tag
      • javax.swing.text.html.HTML.UnknownTag (implements java.io.Serializable)
    • javax.swing.text.html.HTMLDocument.HTMLReader.TagAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.BlockAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.ParagraphAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.PreAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.CharacterAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.HiddenAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.IsindexAction
      • javax.swing.text.html.HTMLDocument.HTMLReader.SpecialAction
        • javax.swing.text.html.HTMLDocument.HTMLReader.FormAction
    • javax.swing.text.html.HTMLDocument.Iterator
    • javax.swing.text.html.HTMLEditorKit.HTMLFactory (implements javax.swing.text.ViewFactory)
    • javax.swing.text.html.HTMLEditorKit.Parser
      • javax.swing.text.html.parser.ParserDelegator (implements java.io.Serializable)
    • javax.swing.text.html.HTMLEditorKit.ParserCallback
      • javax.swing.text.html.HTMLDocument.HTMLReader
    • java.net.HttpCookie (implements java.lang.Cloneable)
    • javax.swing.event.HyperlinkEvent.EventType
    • java.awt.color.ICC_Profile (implements java.io.Serializable)
      • java.awt.color.ICC_ProfileGray
      • java.awt.color.ICC_ProfileRGB
    • javax.swing.plaf.IconUIResource (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • org.omg.PortableServer.IdAssignmentPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.IdentifierHelper
    • java.security.Identity (implements java.security.Principal, java.io.Serializable)
      • java.security.IdentityScope
      • java.security.Signer
    • org.omg.CORBA.IDLTypeHelper
    • java.net.IDN
    • org.omg.PortableServer.IdUniquenessPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.imageio.stream.IIOByteBuffer
    • javax.imageio.IIOImage
    • javax.imageio.metadata.IIOMetadata
    • javax.imageio.metadata.IIOMetadataFormatImpl (implements javax.imageio.metadata.IIOMetadataFormat)
    • javax.imageio.metadata.IIOMetadataNode (implements org.w3c.dom.Element, org.w3c.dom.NodeList)
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.jpeg.JPEGImageReadParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.bmp.BMPImageWriteParam
        • javax.imageio.plugins.jpeg.JPEGImageWriteParam
    • javax.imageio.spi.IIOServiceProvider (implements javax.imageio.spi.RegisterableService)
      • javax.imageio.spi.ImageInputStreamSpi
      • javax.imageio.spi.ImageOutputStreamSpi
      • javax.imageio.spi.ImageReaderWriterSpi
        • javax.imageio.spi.ImageReaderSpi
        • javax.imageio.spi.ImageWriterSpi
      • javax.imageio.spi.ImageTranscoderSpi
    • java.awt.Image
      • java.awt.image.BufferedImage (implements java.awt.Transparency, java.awt.image.WritableRenderedImage)
      • java.awt.image.VolatileImage (implements java.awt.Transparency)
    • java.awt.ImageCapabilities (implements java.lang.Cloneable)
    • java.awt.image.ImageFilter (implements java.lang.Cloneable, java.awt.image.ImageConsumer)
      • java.awt.image.BufferedImageFilter (implements java.lang.Cloneable)
      • java.awt.image.CropImageFilter
      • java.awt.image.ReplicateScaleFilter
        • java.awt.image.AreaAveragingScaleFilter
      • java.awt.image.RGBImageFilter
        • javax.swing.GrayFilter
    • javax.swing.ImageIcon (implements javax.accessibility.Accessible, javax.swing.Icon, java.io.Serializable)
    • javax.imageio.stream.ImageInputStreamImpl (implements javax.imageio.stream.ImageInputStream)
      • javax.imageio.stream.FileCacheImageInputStream
      • javax.imageio.stream.FileImageInputStream
      • javax.imageio.stream.ImageOutputStreamImpl (implements javax.imageio.stream.ImageOutputStream)
        • javax.imageio.stream.FileCacheImageOutputStream
        • javax.imageio.stream.FileImageOutputStream
        • javax.imageio.stream.MemoryCacheImageOutputStream
      • javax.imageio.stream.MemoryCacheImageInputStream
    • javax.imageio.ImageIO
    • javax.imageio.ImageReader
    • javax.imageio.ImageTypeSpecifier
    • javax.imageio.ImageWriter (implements javax.imageio.ImageTranscoder)
    • javax.management.ImmutableDescriptor (implements javax.management.Descriptor)
    • org.omg.PortableServer.ImplicitActivationPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCodeHelper
    • java.net.InetAddress (implements java.io.Serializable)
      • java.net.Inet4Address
      • java.net.Inet6Address
    • java.util.zip.Inflater
    • javax.naming.InitialContext (implements javax.naming.Context)
      • javax.naming.directory.InitialDirContext (implements javax.naming.directory.DirContext)
        • javax.naming.ldap.InitialLdapContext (implements javax.naming.ldap.LdapContext)
    • java.awt.im.InputContext
    • javax.swing.InputMap (implements java.io.Serializable)
      • javax.swing.ComponentInputMap
        • javax.swing.plaf.ComponentInputMapUIResource (implements javax.swing.plaf.UIResource)
      • javax.swing.plaf.InputMapUIResource (implements javax.swing.plaf.UIResource)
    • java.awt.im.InputMethodHighlight
    • org.xml.sax.InputSource
    • java.io.InputStream (implements java.io.Closeable)
      • javax.sound.sampled.AudioInputStream
      • java.io.ByteArrayInputStream
      • java.io.FileInputStream
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
        • java.util.zip.CheckedInputStream
        • javax.crypto.CipherInputStream
        • java.io.DataInputStream (implements java.io.DataInput)
        • java.util.zip.DeflaterInputStream
        • java.security.DigestInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.GZIPInputStream
          • java.util.zip.ZipInputStream
            • java.util.jar.JarInputStream
        • java.io.LineNumberInputStream
        • javax.swing.ProgressMonitorInputStream
        • java.io.PushbackInputStream
      • org.omg.CORBA.portable.InputStream
        • org.omg.CORBA_2_3.portable.InputStream
      • java.io.ObjectInputStream (implements java.io.ObjectInput, java.io.ObjectStreamConstants)
      • java.io.PipedInputStream
      • java.io.SequenceInputStream
      • java.io.StringBufferInputStream
    • javax.swing.InputVerifier
    • java.awt.Insets (implements java.lang.Cloneable, java.io.Serializable)
      • javax.swing.plaf.InsetsUIResource (implements javax.swing.plaf.UIResource)
    • javax.print.attribute.IntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Copies (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressions (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressionsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobKOctets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobKOctetsProcessed (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobMediaSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobMediaSheetsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobPriority (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobPrioritySupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberOfDocuments (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberOfInterveningJobs (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberUp (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PagesPerMinute (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PagesPerMinuteColor (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.QueuedJobCount (implements javax.print.attribute.PrintServiceAttribute)
    • java.net.InterfaceAddress
    • javax.swing.event.InternalFrameAdapter (implements javax.swing.event.InternalFrameListener)
    • org.omg.CORBA.IntHolder (implements org.omg.CORBA.portable.Streamable)
    • java.beans.Introspector
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHelper
    • org.omg.CosNaming.NamingContextExtPackage.InvalidAddressHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidNameHelper
    • org.omg.CosNaming.NamingContextPackage.InvalidNameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableServer.POAPackage.InvalidPolicyHelper
    • org.omg.PortableInterceptor.InvalidSlotHelper
    • org.omg.IOP.CodecPackage.InvalidTypeForEncodingHelper
    • org.omg.DynamicAny.DynAnyPackage.InvalidValueHelper
    • org.omg.IOP.IOR (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.IORHelper
    • org.omg.IOP.IORHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.IORInterceptor_3_0Helper
    • org.omg.PortableInterceptor.IORInterceptor_3_0Holder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.IstringHelper
    • javax.crypto.spec.IvParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.xml.bind.JAXBContext
    • javax.xml.bind.JAXBElement<T> (implements java.io.Serializable)
    • javax.xml.bind.JAXBElement.GlobalScope
    • javax.xml.bind.JAXBIntrospector
    • javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.JFormattedTextField.AbstractFormatter (implements java.io.Serializable)
      • javax.swing.text.DefaultFormatter (implements java.lang.Cloneable, java.io.Serializable)
        • javax.swing.text.InternationalFormatter
          • javax.swing.text.DateFormatter
          • javax.swing.text.NumberFormatter
        • javax.swing.text.MaskFormatter
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
      • javax.swing.text.DefaultFormatterFactory (implements java.io.Serializable)
    • javax.management.JMX
    • javax.management.remote.JMXConnectorFactory
    • javax.management.remote.JMXConnectorServerFactory
    • javax.management.remote.JMXPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.management.remote.JMXServiceURL (implements java.io.Serializable)
    • java.awt.JobAttributes (implements java.lang.Cloneable)
    • java.awt.JobAttributes.DefaultSelectionType
    • java.awt.JobAttributes.DestinationType
    • java.awt.JobAttributes.DialogType
    • java.awt.JobAttributes.MultipleDocumentHandlingType
    • java.awt.JobAttributes.SidesType
    • javax.imageio.plugins.jpeg.JPEGHuffmanTable
    • javax.imageio.plugins.jpeg.JPEGQTable
    • javax.swing.JRootPane.RootLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.JTabbedPane.ModelListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange (implements javax.accessibility.AccessibleTableModelChange)
    • javax.swing.text.JTextComponent.KeyBinding
    • javax.swing.JTree.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.JTree.TreeSelectionRedirector (implements java.io.Serializable, javax.swing.event.TreeSelectionListener)
    • javax.security.auth.kerberos.KerberosKey (implements javax.security.auth.Destroyable, javax.crypto.SecretKey)
    • javax.security.auth.kerberos.KerberosPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.kerberos.KerberosTicket (implements javax.security.auth.Destroyable, javax.security.auth.Refreshable, java.io.Serializable)
    • java.awt.image.Kernel (implements java.lang.Cloneable)
    • java.awt.event.KeyAdapter (implements java.awt.event.KeyListener)
      • javax.swing.plaf.basic.BasicComboBoxUI.KeyHandler
      • javax.swing.plaf.basic.BasicComboPopup.InvocationKeyHandler
      • javax.swing.plaf.basic.BasicTreeUI.KeyHandler
    • javax.crypto.KeyAgreement
    • javax.crypto.KeyAgreementSpi
    • java.awt.KeyboardFocusManager (implements java.awt.KeyEventDispatcher, java.awt.KeyEventPostProcessor)
      • java.awt.DefaultKeyboardFocusManager
        • javax.swing.FocusManager
          • javax.swing.DefaultFocusManager
    • java.security.KeyFactory
    • java.security.KeyFactorySpi
    • javax.crypto.KeyGenerator
    • javax.crypto.KeyGeneratorSpi
    • javax.xml.crypto.dsig.keyinfo.KeyInfoFactory
    • javax.net.ssl.KeyManagerFactory
    • javax.net.ssl.KeyManagerFactorySpi
    • java.security.KeyPair (implements java.io.Serializable)
    • java.security.KeyPairGeneratorSpi
      • java.security.KeyPairGenerator
    • java.security.KeyRep (implements java.io.Serializable)
    • javax.xml.crypto.KeySelector
    • javax.xml.crypto.KeySelector.Purpose
    • java.security.KeyStore
    • java.security.KeyStore.Builder
    • java.security.KeyStore.CallbackHandlerProtection (implements java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PasswordProtection (implements javax.security.auth.Destroyable, java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PrivateKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.SecretKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.TrustedCertificateEntry (implements java.security.KeyStore.Entry)
    • javax.net.ssl.KeyStoreBuilderParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.KeyStoreSpi
    • javax.security.auth.callback.LanguageCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.swing.text.LayeredHighlighter (implements javax.swing.text.Highlighter)
      • javax.swing.text.DefaultHighlighter
        • javax.swing.plaf.basic.BasicTextUI.BasicHighlighter (implements javax.swing.plaf.UIResource)
    • javax.swing.text.LayeredHighlighter.LayerPainter (implements javax.swing.text.Highlighter.HighlightPainter)
      • javax.swing.text.DefaultHighlighter.DefaultHighlightPainter
    • java.awt.font.LayoutPath
    • javax.swing.text.LayoutQueue
    • javax.swing.LayoutStyle
    • java.security.cert.LDAPCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • javax.naming.ldap.LdapName (implements javax.naming.Name)
    • java.rmi.dgc.Lease (implements java.io.Serializable)
    • java.util.logging.Level (implements java.io.Serializable)
    • org.omg.PortableServer.LifespanPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.sound.sampled.Line.Info
      • javax.sound.sampled.DataLine.Info
      • javax.sound.sampled.Port.Info
    • java.awt.geom.Line2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Line2D.Double (implements java.io.Serializable)
      • java.awt.geom.Line2D.Float (implements java.io.Serializable)
    • java.awt.font.LineBreakMeasurer
    • javax.sound.sampled.LineEvent.Type
    • java.awt.font.LineMetrics
    • java.util.Locale (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.BreakIteratorProvider
      • java.text.spi.CollatorProvider
      • java.util.spi.CurrencyNameProvider
      • java.text.spi.DateFormatProvider
      • java.text.spi.DateFormatSymbolsProvider
      • java.text.spi.DecimalFormatSymbolsProvider
      • java.util.spi.LocaleNameProvider
      • java.text.spi.NumberFormatProvider
      • java.util.spi.TimeZoneNameProvider
    • org.omg.CORBA.LocalObject (implements org.omg.CORBA.Object)
    • java.rmi.registry.LocateRegistry
    • org.xml.sax.helpers.LocatorImpl (implements org.xml.sax.Locator)
      • org.xml.sax.ext.Locator2Impl (implements org.xml.sax.ext.Locator2)
    • java.lang.management.LockInfo
      • java.lang.management.MonitorInfo
    • java.util.concurrent.locks.LockSupport
    • java.util.logging.Logger
    • javax.security.auth.login.LoginContext
    • java.util.logging.LogManager
    • java.util.logging.LogRecord (implements java.io.Serializable)
    • org.omg.CORBA.LongHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongLongSeqHelper
    • org.omg.CORBA.LongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.LongSeqHelper
    • org.omg.CORBA.LongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.LookAndFeel
      • javax.swing.plaf.basic.BasicLookAndFeel (implements java.io.Serializable)
        • javax.swing.plaf.metal.MetalLookAndFeel
        • javax.swing.plaf.synth.SynthLookAndFeel
      • javax.swing.plaf.multi.MultiLookAndFeel
    • java.awt.image.LookupOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.LookupTable
      • java.awt.image.ByteLookupTable
      • java.awt.image.ShortLookupTable
    • javax.crypto.Mac (implements java.lang.Cloneable)
    • javax.crypto.MacSpi
    • java.lang.management.ManagementFactory
    • java.util.jar.Manifest (implements java.lang.Cloneable)
    • java.rmi.MarshalledObject<T> (implements java.io.Serializable)
    • javax.xml.bind.Marshaller.Listener
    • java.util.regex.Matcher (implements java.util.regex.MatchResult)
    • java.lang.Math
    • java.math.MathContext (implements java.io.Serializable)
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanAttributeInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanAttributeInfoSupport (implements javax.management.openmbean.OpenMBeanAttributeInfo)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanConstructorInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanConstructorInfoSupport (implements javax.management.openmbean.OpenMBeanConstructorInfo)
      • javax.management.MBeanNotificationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanNotificationInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanOperationInfo (implements javax.management.DescriptorAccess)
        • javax.management.openmbean.OpenMBeanOperationInfoSupport (implements javax.management.openmbean.OpenMBeanOperationInfo)
      • javax.management.MBeanParameterInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanParameterInfoSupport (implements javax.management.openmbean.OpenMBeanParameterInfo)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.modelmbean.ModelMBeanInfoSupport (implements javax.management.modelmbean.ModelMBeanInfo)
      • javax.management.openmbean.OpenMBeanInfoSupport (implements javax.management.openmbean.OpenMBeanInfo)
    • javax.management.MBeanServerBuilder
    • javax.management.MBeanServerDelegate (implements javax.management.MBeanServerDelegateMBean, javax.management.NotificationEmitter)
    • javax.management.MBeanServerFactory
    • javax.management.MBeanServerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.print.attribute.standard.MediaPrintableArea (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.standard.MediaSize.Engineering
    • javax.print.attribute.standard.MediaSize.ISO
    • javax.print.attribute.standard.MediaSize.JIS
    • javax.print.attribute.standard.MediaSize.NA
    • javax.print.attribute.standard.MediaSize.Other
    • java.awt.MediaTracker (implements java.io.Serializable)
    • java.awt.image.MemoryImageSource (implements java.awt.image.ImageProducer)
    • java.lang.management.MemoryNotificationInfo
    • java.lang.management.MemoryUsage
    • java.awt.MenuComponent (implements java.io.Serializable)
      • java.awt.MenuBar (implements javax.accessibility.Accessible, java.awt.MenuContainer)
      • java.awt.MenuItem (implements javax.accessibility.Accessible)
        • java.awt.CheckboxMenuItem (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
        • java.awt.Menu (implements javax.accessibility.Accessible, java.awt.MenuContainer)
          • java.awt.PopupMenu
    • javax.swing.MenuSelectionManager
    • java.awt.MenuShortcut (implements java.io.Serializable)
    • java.security.MessageDigestSpi
      • java.security.MessageDigest
    • javax.xml.soap.MessageFactory
    • org.ietf.jgss.MessageProp
    • javax.swing.plaf.metal.MetalBorders
    • javax.swing.plaf.metal.MetalCheckBoxIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalComboBoxIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory (implements java.io.Serializable)
    • javax.swing.plaf.metal.MetalIconFactory.FileIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeLeafIcon
    • javax.swing.plaf.metal.MetalIconFactory.FolderIcon16 (implements javax.swing.Icon, java.io.Serializable)
      • javax.swing.plaf.metal.MetalIconFactory.TreeFolderIcon
    • javax.swing.plaf.metal.MetalIconFactory.PaletteCloseIcon (implements javax.swing.Icon, java.io.Serializable, javax.swing.plaf.UIResource)
    • javax.swing.plaf.metal.MetalIconFactory.TreeControlIcon (implements javax.swing.Icon, java.io.Serializable)
    • javax.swing.plaf.metal.MetalTheme
      • javax.swing.plaf.metal.DefaultMetalTheme
        • javax.swing.plaf.metal.OceanTheme
    • java.security.spec.MGF1ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.sound.midi.MidiDevice.Info
    • javax.sound.midi.spi.MidiDeviceProvider
    • javax.sound.midi.MidiEvent
    • javax.sound.midi.MidiFileFormat
    • javax.sound.midi.spi.MidiFileReader
    • javax.sound.midi.spi.MidiFileWriter
    • javax.sound.midi.MidiMessage (implements java.lang.Cloneable)
      • javax.sound.midi.MetaMessage
      • javax.sound.midi.ShortMessage
      • javax.sound.midi.SysexMessage
    • javax.sound.midi.MidiSystem
    • javax.xml.soap.MimeHeader
    • javax.xml.soap.MimeHeaders
    • javax.activation.MimeType (implements java.io.Externalizable)
    • javax.activation.MimeTypeParameterList
    • javax.sound.sampled.Mixer.Info
    • javax.sound.sampled.spi.MixerProvider
    • javax.management.loading.MLetContent
    • javax.naming.directory.ModificationItem (implements java.io.Serializable)
    • java.lang.reflect.Modifier
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseHandler
      • javax.swing.plaf.basic.BasicFileChooserUI.DoubleClickListener
      • javax.swing.plaf.basic.BasicScrollBarUI.ArrowButtonListener
      • javax.swing.plaf.basic.BasicScrollBarUI.TrackListener (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicSplitPaneDivider.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicTabbedPaneUI.MouseHandler
      • javax.swing.plaf.basic.BasicTreeUI.MouseHandler (implements java.awt.event.MouseMotionListener)
      • javax.swing.text.html.FormView.MouseEventListener
      • javax.swing.text.html.HTMLEditorKit.LinkController (implements java.awt.event.MouseMotionListener, java.io.Serializable)
      • javax.swing.plaf.metal.MetalFileChooserUI.SingleClickListener
      • javax.swing.event.MouseInputAdapter (implements javax.swing.event.MouseInputListener)
        • javax.swing.plaf.basic.BasicDesktopIconUI.MouseInputHandler
        • javax.swing.plaf.basic.BasicInternalFrameUI.BorderListener (implements javax.swing.SwingConstants)
        • javax.swing.plaf.basic.BasicSliderUI.TrackListener
      • javax.swing.ToolTipManager (implements java.awt.event.MouseMotionListener)
    • java.awt.MouseInfo
    • java.awt.event.MouseMotionAdapter (implements java.awt.event.MouseMotionListener)
      • javax.swing.plaf.basic.BasicComboPopup.InvocationMouseMotionHandler
      • javax.swing.plaf.basic.BasicComboPopup.ListMouseMotionHandler
    • org.omg.IOP.MultipleComponentProfileHelper
    • org.omg.IOP.MultipleComponentProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.MultipleGradientPaint (implements java.awt.Paint)
      • java.awt.LinearGradientPaint
      • java.awt.RadialGradientPaint
    • javax.security.auth.callback.NameCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.naming.NameClassPair (implements java.io.Serializable)
      • javax.naming.Binding
        • javax.naming.directory.SearchResult
    • org.omg.CosNaming.NameComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NameComponentHelper
    • org.omg.CosNaming.NameComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.NamedValue
    • org.omg.DynamicAny.NameDynAnyPair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameDynAnyPairHelper
    • org.omg.DynamicAny.NameDynAnyPairSeqHelper
    • org.omg.CosNaming.NameHelper
    • org.omg.CosNaming.NameHolder (implements org.omg.CORBA.portable.Streamable)
    • org.xml.sax.helpers.NamespaceSupport
    • org.omg.CORBA.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.NameValuePair (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairHelper
    • org.omg.DynamicAny.NameValuePairSeqHelper
    • java.rmi.Naming
    • org.omg.CosNaming.NamingContextExtHelper
    • org.omg.CosNaming.NamingContextExtHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextHelper
    • org.omg.CosNaming.NamingContextHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.naming.spi.NamingManager
      • javax.naming.spi.DirectoryManager
    • javax.swing.text.NavigationFilter
    • javax.swing.text.NavigationFilter.FilterBypass
    • java.net.NetworkInterface
    • org.omg.PortableServer.CurrentPackage.NoContextHelper
    • java.text.Normalizer
    • org.omg.PortableServer.POAPackage.NoServantHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHelper
    • org.omg.CosNaming.NamingContextPackage.NotEmptyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReason (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHelper
    • org.omg.CosNaming.NamingContextPackage.NotFoundReasonHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.remote.JMXConnectorServer (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnectorServerMBean, javax.management.MBeanRegistration)
        • javax.management.remote.rmi.RMIConnectorServer
      • javax.management.monitor.Monitor (implements javax.management.MBeanRegistration, javax.management.monitor.MonitorMBean)
        • javax.management.monitor.CounterMonitor (implements javax.management.monitor.CounterMonitorMBean)
        • javax.management.monitor.GaugeMonitor (implements javax.management.monitor.GaugeMonitorMBean)
        • javax.management.monitor.StringMonitor (implements javax.management.monitor.StringMonitorMBean)
      • javax.management.relation.RelationService (implements javax.management.MBeanRegistration, javax.management.NotificationListener, javax.management.relation.RelationServiceMBean)
      • javax.management.timer.Timer (implements javax.management.MBeanRegistration, javax.management.timer.TimerMBean)
    • javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter)
      • javax.management.relation.MBeanServerNotificationFilter
    • javax.management.remote.NotificationResult (implements java.io.Serializable)
    • java.lang.Number (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicInteger (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicLong (implements java.io.Serializable)
      • java.math.BigDecimal (implements java.lang.Comparable<T>)
      • java.math.BigInteger (implements java.lang.Comparable<T>)
      • java.lang.Byte (implements java.lang.Comparable<T>)
      • java.lang.Double (implements java.lang.Comparable<T>)
      • java.lang.Float (implements java.lang.Comparable<T>)
      • java.lang.Integer (implements java.lang.Comparable<T>)
      • java.lang.Long (implements java.lang.Comparable<T>)
      • java.lang.Short (implements java.lang.Comparable<T>)
    • java.awt.font.NumericShaper (implements java.io.Serializable)
    • org.omg.CORBA.NVList
    • javax.crypto.spec.OAEPParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • org.omg.PortableServer.POAPackage.ObjectAlreadyActiveHelper
    • org.omg.CORBA.ObjectHelper
    • org.omg.CORBA.ObjectHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectIdHelper
    • org.omg.PortableInterceptor.ORBInitInfoPackage.ObjectIdHelper
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CosNaming._BindingIteratorStub (implements org.omg.CosNaming.BindingIterator)
      • org.omg.DynamicAny._DynAnyFactoryStub (implements org.omg.DynamicAny.DynAnyFactory)
      • org.omg.DynamicAny._DynAnyStub (implements org.omg.DynamicAny.DynAny)
      • org.omg.DynamicAny._DynArrayStub (implements org.omg.DynamicAny.DynArray)
      • org.omg.DynamicAny._DynEnumStub (implements org.omg.DynamicAny.DynEnum)
      • org.omg.DynamicAny._DynFixedStub (implements org.omg.DynamicAny.DynFixed)
      • org.omg.DynamicAny._DynSequenceStub (implements org.omg.DynamicAny.DynSequence)
      • org.omg.DynamicAny._DynStructStub (implements org.omg.DynamicAny.DynStruct)
      • org.omg.DynamicAny._DynUnionStub (implements org.omg.DynamicAny.DynUnion)
      • org.omg.DynamicAny._DynValueStub (implements org.omg.DynamicAny.DynValue)
      • org.omg.CORBA._IDLTypeStub (implements org.omg.CORBA.IDLType)
      • org.omg.CosNaming._NamingContextExtStub (implements org.omg.CosNaming.NamingContextExt)
      • org.omg.CosNaming._NamingContextStub (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA._PolicyStub (implements org.omg.CORBA.Policy)
      • org.omg.PortableServer._ServantActivatorStub (implements org.omg.PortableServer.ServantActivator)
      • org.omg.PortableServer._ServantLocatorStub (implements org.omg.PortableServer.ServantLocator)
      • org.omg.CORBA.DynamicImplementation
        • org.omg.CosNaming._BindingIteratorImplBase (implements org.omg.CosNaming.BindingIterator)
        • org.omg.CosNaming._NamingContextImplBase (implements org.omg.CosNaming.NamingContext)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
          • org.omg.stub.java.rmi._Remote_Stub (implements java.rmi.Remote)
    • java.io.ObjectInputStream.GetField
    • javax.management.ObjectInstance (implements java.io.Serializable)
    • javax.management.ObjectName (implements java.lang.Comparable<T>, javax.management.QueryExp)
    • org.omg.PortableServer.POAPackage.ObjectNotActiveHelper
    • java.io.ObjectOutputStream.PutField
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHelper
    • org.omg.PortableInterceptor.ObjectReferenceFactoryHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHelper
    • org.omg.PortableInterceptor.ObjectReferenceTemplateSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.io.ObjectStreamClass (implements java.io.Serializable)
    • java.io.ObjectStreamField (implements java.lang.Comparable<T>)
    • java.rmi.server.ObjID (implements java.io.Serializable)
    • java.util.Observable
    • org.omg.CORBA.OctetSeqHelper
    • org.omg.CORBA.OctetSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.crypto.OctetStreamData (implements javax.xml.crypto.Data)
    • org.ietf.jgss.Oid
    • javax.management.openmbean.OpenType<T> (implements java.io.Serializable)
      • javax.management.openmbean.ArrayType<T>
      • javax.management.openmbean.CompositeType
      • javax.management.openmbean.SimpleType<T>
      • javax.management.openmbean.TabularType
    • java.rmi.server.Operation
    • javax.swing.text.html.Option (implements java.io.Serializable)
    • org.omg.CORBA.ORB
      • org.omg.CORBA_2_3.ORB
    • org.omg.PortableInterceptor.ORBIdHelper
    • javax.xml.transform.OutputKeys
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
      • java.io.FileOutputStream
      • java.io.FilterOutputStream
        • java.io.BufferedOutputStream
        • java.util.zip.CheckedOutputStream
        • javax.crypto.CipherOutputStream
        • java.io.DataOutputStream (implements java.io.DataOutput)
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.GZIPOutputStream
          • java.util.zip.ZipOutputStream
            • java.util.jar.JarOutputStream
        • java.security.DigestOutputStream
        • java.util.zip.InflaterOutputStream
        • java.io.PrintStream (implements java.lang.Appendable, java.io.Closeable)
          • java.rmi.server.LogStream
      • java.io.ObjectOutputStream (implements java.io.ObjectOutput, java.io.ObjectStreamConstants)
      • org.omg.CORBA.portable.OutputStream
        • org.omg.CORBA_2_3.portable.OutputStream
      • java.io.PipedOutputStream
    • javax.swing.OverlayLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.util.jar.Pack200
    • java.lang.Package (implements java.lang.reflect.AnnotatedElement)
    • java.awt.PageAttributes (implements java.lang.Cloneable)
    • java.awt.PageAttributes.ColorType
    • java.awt.PageAttributes.MediaType
    • java.awt.PageAttributes.OrientationRequestedType
    • java.awt.PageAttributes.OriginType
    • java.awt.PageAttributes.PrintQualityType
    • java.awt.print.PageFormat (implements java.lang.Cloneable)
    • java.awt.print.Paper (implements java.lang.Cloneable)
    • org.omg.Dynamic.Parameter (implements org.omg.CORBA.portable.IDLEntity)
    • java.awt.image.renderable.ParameterBlock (implements java.lang.Cloneable, java.io.Serializable)
    • org.omg.CORBA.ParameterMode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ParameterModeHelper
    • org.omg.CORBA.ParameterModeHolder (implements org.omg.CORBA.portable.Streamable)
    • java.text.ParsePosition
    • javax.swing.text.html.parser.Parser (implements javax.swing.text.html.parser.DTDConstants)
      • javax.swing.text.html.parser.DocumentParser
    • org.xml.sax.helpers.ParserAdapter (implements org.xml.sax.DocumentHandler, org.xml.sax.XMLReader)
    • org.xml.sax.helpers.ParserFactory
    • java.net.PasswordAuthentication
    • javax.security.auth.callback.PasswordCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.sound.midi.Patch
    • java.awt.geom.Path2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Path2D.Double (implements java.io.Serializable)
      • java.awt.geom.Path2D.Float (implements java.io.Serializable)
        • java.awt.geom.GeneralPath
    • java.util.regex.Pattern (implements java.io.Serializable)
    • javax.crypto.spec.PBEKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.PBEParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.AllPermission
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.sound.sampled.AudioPermission
        • javax.security.auth.AuthPermission
        • java.awt.AWTPermission
        • javax.security.auth.kerberos.DelegationPermission (implements java.io.Serializable)
        • java.util.logging.LoggingPermission
        • java.lang.management.ManagementPermission
        • javax.management.MBeanServerPermission
        • javax.management.MBeanTrustPermission
        • java.net.NetPermission
        • java.util.PropertyPermission
        • java.lang.reflect.ReflectPermission
        • java.lang.RuntimePermission
        • java.security.SecurityPermission
        • java.io.SerializablePermission
        • java.sql.SQLPermission
        • javax.net.ssl.SSLPermission
        • javax.management.remote.SubjectDelegationPermission
        • javax.xml.ws.WebServicePermission
      • java.io.FilePermission (implements java.io.Serializable)
      • javax.management.MBeanPermission
      • javax.security.auth.PrivateCredentialPermission
      • javax.security.auth.kerberos.ServicePermission (implements java.io.Serializable)
      • java.net.SocketPermission (implements java.io.Serializable)
      • java.security.UnresolvedPermission (implements java.io.Serializable)
    • java.security.PermissionCollection (implements java.io.Serializable)
      • java.security.Permissions (implements java.io.Serializable)
    • java.beans.PersistenceDelegate
      • java.beans.DefaultPersistenceDelegate
    • java.nio.channels.Pipe
    • java.awt.image.PixelGrabber (implements java.awt.image.ImageConsumer)
    • java.security.cert.PKIXCertPathChecker (implements java.lang.Cloneable)
    • java.security.cert.PKIXCertPathValidatorResult (implements java.security.cert.CertPathValidatorResult)
      • java.security.cert.PKIXCertPathBuilderResult (implements java.security.cert.CertPathBuilderResult)
    • java.security.cert.PKIXParameters (implements java.security.cert.CertPathParameters)
      • java.security.cert.PKIXBuilderParameters
    • org.omg.PortableServer.POAHelper
    • java.awt.geom.Point2D (implements java.lang.Cloneable)
      • java.awt.Point (implements java.io.Serializable)
      • java.awt.geom.Point2D.Double (implements java.io.Serializable)
      • java.awt.geom.Point2D.Float (implements java.io.Serializable)
    • java.awt.PointerInfo
    • java.security.Policy
    • javax.security.auth.Policy
    • org.omg.CORBA.PolicyErrorCodeHelper
    • org.omg.CORBA.PolicyErrorHelper
    • org.omg.CORBA.PolicyErrorHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyHelper
    • org.omg.CORBA.PolicyHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.PolicyListHelper
    • org.omg.CORBA.PolicyListHolder (implements org.omg.CORBA.portable.Streamable)
    • java.security.cert.PolicyQualifierInfo
    • java.security.PolicySpi
    • org.omg.CORBA.PolicyTypeHelper
    • java.awt.Polygon (implements java.io.Serializable, java.awt.Shape)
    • javax.swing.Popup
    • javax.swing.PopupFactory
    • javax.rmi.PortableRemoteObject
    • javax.swing.text.Position.Bias
    • java.util.prefs.Preferences
      • java.util.prefs.AbstractPreferences
    • org.omg.CORBA.Principal
    • org.omg.CORBA.PrincipalHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.print.PrinterJob
    • java.awt.PrintJob
    • javax.print.event.PrintJobAdapter (implements javax.print.event.PrintJobListener)
    • javax.print.PrintServiceLookup
    • java.lang.Process
    • java.lang.ProcessBuilder
    • org.omg.IOP.ProfileIdHelper
    • javax.swing.ProgressMonitor (implements javax.accessibility.Accessible)
    • java.beans.PropertyChangeSupport (implements java.io.Serializable)
      • javax.swing.event.SwingPropertyChangeSupport
    • java.beans.PropertyEditorManager
    • java.beans.PropertyEditorSupport (implements java.beans.PropertyEditor)
    • java.security.ProtectionDomain
    • javax.xml.ws.spi.Provider
    • java.security.Provider.Service
    • java.lang.reflect.Proxy (implements java.io.Serializable)
    • java.net.Proxy
    • java.net.ProxySelector
    • javax.crypto.spec.PSource
      • javax.crypto.spec.PSource.PSpecified
    • java.security.spec.PSSParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.xml.namespace.QName (implements java.io.Serializable)
    • java.awt.geom.QuadCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.QuadCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.QuadCurve2D.Float (implements java.io.Serializable)
    • javax.management.Query
    • javax.management.QueryEval (implements java.io.Serializable)
    • java.util.Random (implements java.io.Serializable)
      • java.security.SecureRandom
    • java.io.RandomAccessFile (implements java.io.Closeable, java.io.DataInput, java.io.DataOutput)
    • java.awt.image.Raster
      • java.awt.image.WritableRaster
    • javax.crypto.spec.RC2ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.RC5ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.naming.ldap.Rdn (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
      • java.io.CharArrayReader
      • java.io.FilterReader
        • java.io.PushbackReader
      • java.io.InputStreamReader
        • java.io.FileReader
      • java.io.PipedReader
      • java.io.StringReader
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Arc2D
        • java.awt.geom.Arc2D.Double (implements java.io.Serializable)
        • java.awt.geom.Arc2D.Float (implements java.io.Serializable)
      • java.awt.geom.Ellipse2D
        • java.awt.geom.Ellipse2D.Double (implements java.io.Serializable)
        • java.awt.geom.Ellipse2D.Float (implements java.io.Serializable)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
          • javax.swing.text.DefaultCaret (implements javax.swing.text.Caret, java.awt.event.FocusListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
            • javax.swing.plaf.basic.BasicTextUI.BasicCaret (implements javax.swing.plaf.UIResource)
        • java.awt.geom.Rectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.Rectangle2D.Float (implements java.io.Serializable)
      • java.awt.geom.RoundRectangle2D
        • java.awt.geom.RoundRectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.RoundRectangle2D.Float (implements java.io.Serializable)
    • java.util.concurrent.locks.ReentrantLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock (implements java.util.concurrent.locks.ReadWriteLock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • javax.naming.RefAddr (implements java.io.Serializable)
      • javax.naming.BinaryRefAddr
      • javax.naming.StringRefAddr
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
      • java.lang.ref.SoftReference<T>
      • java.lang.ref.WeakReference<T>
    • javax.naming.Reference (implements java.lang.Cloneable, java.io.Serializable)
      • javax.naming.LinkRef
    • java.lang.ref.ReferenceQueue<T>
    • javax.swing.plaf.synth.Region
    • javax.management.relation.RelationSupport (implements javax.management.MBeanRegistration, javax.management.relation.RelationSupportMBean)
    • javax.management.relation.RelationTypeSupport (implements javax.management.relation.RelationType)
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteObjectInvocationHandler (implements java.lang.reflect.InvocationHandler)
      • java.rmi.server.RemoteServer
        • java.rmi.activation.Activatable
        • java.rmi.server.UnicastRemoteObject
          • java.rmi.activation.ActivationGroup (implements java.rmi.activation.ActivationInstantiator)
      • java.rmi.server.RemoteStub
        • java.rmi.activation.ActivationGroup_Stub (implements java.rmi.activation.ActivationInstantiator, java.rmi.Remote)
        • javax.management.remote.rmi.RMIConnectionImpl_Stub (implements javax.management.remote.rmi.RMIConnection)
        • javax.management.remote.rmi.RMIServerImpl_Stub (implements javax.management.remote.rmi.RMIServer)
    • java.awt.image.renderable.RenderableImageOp (implements java.awt.image.renderable.RenderableImage)
    • java.awt.image.renderable.RenderableImageProducer (implements java.awt.image.ImageProducer, java.lang.Runnable)
    • java.awt.image.renderable.RenderContext (implements java.lang.Cloneable)
    • java.awt.RenderingHints (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.awt.RenderingHints.Key
    • javax.swing.RepaintManager
    • org.omg.CORBA.RepositoryIdHelper
    • org.omg.CORBA.Request
    • org.omg.PortableServer.RequestProcessingPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • javax.management.modelmbean.RequiredModelMBean (implements javax.management.MBeanRegistration, javax.management.modelmbean.ModelMBean, javax.management.NotificationEmitter)
    • java.awt.image.RescaleOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • javax.print.attribute.ResolutionSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.PrinterResolution (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.naming.spi.ResolveResult (implements java.io.Serializable)
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
        • javax.accessibility.AccessibleResourceBundle
      • java.util.PropertyResourceBundle
    • java.util.ResourceBundle.Control
    • java.net.ResponseCache
    • javax.sound.sampled.ReverbType
    • java.rmi.server.RMIClassLoader
    • java.rmi.server.RMIClassLoaderSpi
    • javax.management.remote.rmi.RMIConnectionImpl (implements javax.management.remote.rmi.RMIConnection, java.rmi.server.Unreferenced)
    • javax.management.remote.rmi.RMIConnector (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnector, java.io.Serializable)
    • javax.management.remote.rmi.RMIServerImpl (implements java.io.Closeable, javax.management.remote.rmi.RMIServer)
      • javax.management.remote.rmi.RMIIIOPServerImpl
      • javax.management.remote.rmi.RMIJRMPServerImpl
    • java.rmi.server.RMISocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.rmi.server.RMIServerSocketFactory)
    • java.awt.Robot
    • javax.management.relation.Role (implements java.io.Serializable)
    • javax.management.relation.RoleInfo (implements java.io.Serializable)
    • javax.management.relation.RoleResult (implements java.io.Serializable)
    • javax.management.relation.RoleStatus
    • javax.management.relation.RoleUnresolved (implements java.io.Serializable)
    • javax.swing.RowFilter<M,I>
    • javax.swing.RowFilter.Entry<M,I>
    • javax.sql.rowset.RowSetMetaDataImpl (implements javax.sql.RowSetMetaData, java.io.Serializable)
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
        • javax.swing.table.TableRowSorter<M>
    • javax.swing.RowSorter.SortKey
    • java.security.spec.RSAKeyGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.RSAOtherPrimeInfo
    • java.security.spec.RSAPrivateKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.RSAMultiPrimePrivateCrtKeySpec
      • java.security.spec.RSAPrivateCrtKeySpec
    • java.security.spec.RSAPublicKeySpec (implements java.security.spec.KeySpec)
    • java.lang.Runtime
    • javax.xml.soap.SAAJMetaFactory
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
        • java.awt.image.BandedSampleModel
        • java.awt.image.PixelInterleavedSampleModel
      • java.awt.image.MultiPixelPackedSampleModel
      • java.awt.image.SinglePixelPackedSampleModel
    • javax.security.sasl.Sasl
    • javax.xml.parsers.SAXParser
    • javax.xml.parsers.SAXParserFactory
    • javax.xml.transform.sax.SAXResult (implements javax.xml.transform.Result)
      • javax.xml.bind.util.JAXBResult
    • javax.xml.transform.sax.SAXSource (implements javax.xml.transform.Source)
      • javax.xml.bind.util.JAXBSource
    • java.util.Scanner (implements java.util.Iterator<E>)
    • javax.xml.validation.Schema
    • javax.xml.validation.SchemaFactory
    • javax.xml.validation.SchemaFactoryLoader
    • javax.xml.bind.SchemaOutputResolver
    • javax.script.ScriptEngineManager
    • java.awt.ScrollPaneAdjustable (implements java.awt.Adjustable, java.io.Serializable)
    • javax.swing.ScrollPaneLayout (implements java.awt.LayoutManager, javax.swing.ScrollPaneConstants, java.io.Serializable)
      • javax.swing.ScrollPaneLayout.UIResource (implements javax.swing.plaf.UIResource)
    • javax.crypto.SealedObject (implements java.io.Serializable)
    • javax.naming.directory.SearchControls (implements java.io.Serializable)
    • javax.crypto.SecretKeyFactory
    • javax.crypto.SecretKeyFactorySpi
    • javax.crypto.spec.SecretKeySpec (implements java.security.spec.KeySpec, javax.crypto.SecretKey)
    • java.security.SecureRandomSpi (implements java.io.Serializable)
    • java.security.Security
    • java.lang.SecurityManager
      • java.rmi.RMISecurityManager
    • javax.swing.text.Segment (implements java.text.CharacterIterator, java.lang.CharSequence, java.lang.Cloneable)
    • java.nio.channels.SelectionKey
      • java.nio.channels.spi.AbstractSelectionKey
    • java.nio.channels.Selector
      • java.nio.channels.spi.AbstractSelector
    • java.nio.channels.spi.SelectorProvider
    • java.util.concurrent.Semaphore (implements java.io.Serializable)
    • javax.sound.midi.Sequence
    • javax.sound.midi.Sequencer.SyncMode
    • javax.sql.rowset.serial.SerialArray (implements java.sql.Array, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialBlob (implements java.sql.Blob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialClob (implements java.sql.Clob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialDatalink (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialJavaObject (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialRef (implements java.lang.Cloneable, java.sql.Ref, java.io.Serializable)
    • javax.sql.rowset.serial.SerialStruct (implements java.lang.Cloneable, java.io.Serializable, java.sql.Struct)
    • org.omg.PortableServer.Servant
      • org.omg.CosNaming.BindingIteratorPOA (implements org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.InvokeHandler)
      • org.omg.PortableServer.DynamicImplementation
      • org.omg.CosNaming.NamingContextExtPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.CosNaming.NamingContextOperations)
      • org.omg.PortableServer.ServantActivatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocatorPOA (implements org.omg.CORBA.portable.InvokeHandler, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantActivatorHelper
    • org.omg.PortableServer.POAPackage.ServantAlreadyActiveHelper
    • org.omg.PortableServer.ServantLocatorHelper
    • org.omg.PortableServer.POAPackage.ServantNotActiveHelper
    • org.omg.CORBA.portable.ServantObject
    • org.omg.PortableServer.ServantRetentionPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.ServerIdHelper
    • org.omg.CORBA.ServerRequest
    • java.net.ServerSocket
      • javax.net.ssl.SSLServerSocket
    • javax.net.ServerSocketFactory
      • javax.net.ssl.SSLServerSocketFactory
    • javax.xml.ws.Service
    • org.omg.IOP.ServiceContext (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.ServiceContextHelper
    • org.omg.IOP.ServiceContextHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.ServiceContextListHelper
    • org.omg.IOP.ServiceContextListHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.ws.spi.ServiceDelegate
    • org.omg.CORBA.ServiceDetail (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceDetailHelper
    • org.omg.IOP.ServiceIdHelper
    • org.omg.CORBA.ServiceInformation (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ServiceInformationHelper
    • org.omg.CORBA.ServiceInformationHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.ServiceLoader<S> (implements java.lang.Iterable<T>)
    • javax.imageio.spi.ServiceRegistry
      • javax.imageio.spi.IIORegistry
    • javax.print.ServiceUI
    • javax.print.ServiceUIFactory
    • javax.print.attribute.SetOfIntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.CopiesSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobImpressionsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobKOctetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobMediaSheetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberUpSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.PageRanges (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • org.omg.CORBA.SetOverrideType (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.SetOverrideTypeHelper
    • org.omg.CORBA.ShortHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ShortSeqHelper
    • org.omg.CORBA.ShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.security.SignatureSpi
      • java.security.Signature
    • java.security.SignedObject (implements java.io.Serializable)
    • javax.swing.text.SimpleAttributeSet (implements java.lang.Cloneable, javax.swing.text.MutableAttributeSet, java.io.Serializable)
    • java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
    • javax.script.SimpleBindings (implements javax.script.Bindings)
    • javax.print.SimpleDoc (implements javax.print.Doc)
    • javax.tools.SimpleJavaFileObject (implements javax.tools.JavaFileObject)
    • javax.script.SimpleScriptContext (implements javax.script.ScriptContext)
    • javax.print.attribute.Size2DSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.MediaSize (implements javax.print.attribute.Attribute)
    • javax.swing.SizeRequirements (implements java.io.Serializable)
    • javax.swing.SizeSequence
    • javax.xml.soap.SOAPConnection
    • javax.xml.soap.SOAPConnectionFactory
    • javax.xml.soap.SOAPElementFactory
    • javax.xml.soap.SOAPFactory
    • javax.xml.soap.SOAPMessage
    • javax.xml.soap.SOAPPart (implements org.w3c.dom.Document, javax.xml.soap.Node)
    • java.net.Socket
      • javax.net.ssl.SSLSocket
    • java.net.SocketAddress (implements java.io.Serializable)
      • java.net.InetSocketAddress
    • javax.net.SocketFactory
      • javax.net.ssl.SSLSocketFactory
    • java.net.SocketImpl (implements java.net.SocketOptions)
    • javax.naming.ldap.SortKey
    • javax.sound.midi.spi.SoundbankReader
    • javax.sound.midi.SoundbankResource
      • javax.sound.midi.Instrument
    • java.awt.SplashScreen
    • javax.swing.Spring
    • javax.swing.SpringLayout (implements java.awt.LayoutManager2)
    • javax.swing.SpringLayout.Constraints
    • javax.sql.rowset.serial.SQLInputImpl (implements java.sql.SQLInput)
    • javax.sql.rowset.serial.SQLOutputImpl (implements java.sql.SQLOutput)
    • javax.net.ssl.SSLContext
    • javax.net.ssl.SSLContextSpi
    • javax.net.ssl.SSLEngine
    • javax.net.ssl.SSLEngineResult
    • javax.net.ssl.SSLParameters
    • javax.rmi.ssl.SslRMIClientSocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.io.Serializable)
    • javax.rmi.ssl.SslRMIServerSocketFactory (implements java.rmi.server.RMIServerSocketFactory)
    • java.lang.StackTraceElement (implements java.io.Serializable)
    • javax.management.StandardMBean (implements javax.management.DynamicMBean, javax.management.MBeanRegistration)
      • javax.management.StandardEmitterMBean (implements javax.management.NotificationEmitter)
    • javax.naming.ldap.StartTlsRequest (implements javax.naming.ldap.ExtendedRequest)
    • javax.naming.ldap.StartTlsResponse (implements javax.naming.ldap.ExtendedResponse)
    • org.omg.PortableServer.POAManagerPackage.State (implements org.omg.CORBA.portable.IDLEntity)
    • java.beans.Statement
      • java.beans.Expression
    • javax.xml.transform.stax.StAXResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stax.StAXSource (implements javax.xml.transform.Source)
    • javax.print.StreamPrintService (implements javax.print.PrintService)
    • javax.print.StreamPrintServiceFactory
    • javax.xml.stream.util.StreamReaderDelegate (implements javax.xml.stream.XMLStreamReader)
    • javax.xml.transform.stream.StreamResult (implements javax.xml.transform.Result)
    • javax.xml.transform.stream.StreamSource (implements javax.xml.transform.Source)
    • java.io.StreamTokenizer
    • java.lang.StrictMath
    • java.lang.String (implements java.lang.CharSequence, java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.StringBuffer (implements java.lang.CharSequence, java.io.Serializable)
    • java.lang.StringBuilder (implements java.lang.CharSequence, java.io.Serializable)
    • java.text.StringCharacterIterator (implements java.text.CharacterIterator)
    • javax.swing.text.StringContent (implements javax.swing.text.AbstractDocument.Content, java.io.Serializable)
    • org.omg.CORBA.StringHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CosNaming.NamingContextExtPackage.StringNameHelper
    • java.awt.datatransfer.StringSelection (implements java.awt.datatransfer.ClipboardOwner, java.awt.datatransfer.Transferable)
    • org.omg.CORBA.StringSeqHelper
    • org.omg.CORBA.StringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.util.StringTokenizer (implements java.util.Enumeration<E>)
    • javax.management.StringValueExp (implements javax.management.ValueExp)
    • org.omg.CORBA.StringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • org.omg.CORBA.StructMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.StructMemberHelper
    • javax.swing.text.StyleConstants
      • javax.swing.text.StyleConstants.CharacterConstants (implements javax.swing.text.AttributeSet.CharacterAttribute)
      • javax.swing.text.StyleConstants.ColorConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.ColorAttribute)
      • javax.swing.text.StyleConstants.FontConstants (implements javax.swing.text.AttributeSet.CharacterAttribute, javax.swing.text.AttributeSet.FontAttribute)
      • javax.swing.text.StyleConstants.ParagraphConstants (implements javax.swing.text.AttributeSet.ParagraphAttribute)
    • javax.swing.text.StyleContext (implements javax.swing.text.AbstractDocument.AttributeContext, java.io.Serializable)
      • javax.swing.text.html.StyleSheet
    • javax.swing.text.StyleContext.NamedStyle (implements java.io.Serializable, javax.swing.text.Style)
    • javax.swing.text.StyleContext.SmallAttributeSet (implements javax.swing.text.AttributeSet)
    • javax.swing.text.html.StyleSheet.BoxPainter (implements java.io.Serializable)
    • javax.swing.text.html.StyleSheet.ListPainter (implements java.io.Serializable)
    • javax.security.auth.Subject (implements java.io.Serializable)
    • javax.security.auth.SubjectDomainCombiner (implements java.security.DomainCombiner)
    • javax.swing.SwingUtilities (implements javax.swing.SwingConstants)
    • javax.swing.SwingWorker<T,V> (implements java.util.concurrent.RunnableFuture<V>)
    • javax.sql.rowset.spi.SyncFactory
    • javax.sql.rowset.spi.SyncProvider
    • org.omg.Messaging.SyncScopeHelper
    • javax.swing.plaf.synth.SynthContext
    • javax.swing.plaf.synth.SynthGraphicsUtils
    • javax.swing.plaf.synth.SynthPainter
    • javax.swing.plaf.synth.SynthStyle
    • javax.swing.plaf.synth.SynthStyleFactory
    • java.lang.System
    • java.awt.datatransfer.SystemFlavorMap (implements java.awt.datatransfer.FlavorMap, java.awt.datatransfer.FlavorTable)
    • java.awt.SystemTray
    • javax.swing.table.TableColumn (implements java.io.Serializable)
    • javax.swing.table.TableStringConverter
    • javax.swing.text.TabSet (implements java.io.Serializable)
    • javax.swing.text.TabStop (implements java.io.Serializable)
    • javax.management.openmbean.TabularDataSupport (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable, javax.management.openmbean.TabularData)
    • javax.swing.text.html.parser.TagElement
    • org.omg.IOP.TaggedComponent (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedComponentHelper
    • org.omg.IOP.TaggedComponentHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.IOP.TaggedProfile (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.TaggedProfileHelper
    • org.omg.IOP.TaggedProfileHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.management.remote.TargetedNotification (implements java.io.Serializable)
    • org.omg.CORBA.TCKind
    • java.awt.font.TextHitInfo
    • javax.security.auth.callback.TextInputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmCallback
    • java.awt.font.TextLayout (implements java.lang.Cloneable)
    • java.awt.font.TextLayout.CaretPolicy
    • java.awt.font.TextMeasurer (implements java.lang.Cloneable)
    • javax.security.auth.callback.TextOutputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.print.attribute.TextSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DocumentName (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.JobMessageFromOperator (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobName (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobOriginatingUserName (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.OutputDeviceAssigned (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.PrinterInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterLocation (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMakeAndModel (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMessageFromOperator (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterName (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.RequestingUserName (implements javax.print.attribute.PrintRequestAttribute)
    • java.awt.TexturePaint (implements java.awt.Paint)
    • java.lang.Thread (implements java.lang.Runnable)
    • java.lang.ThreadGroup (implements java.lang.Thread.UncaughtExceptionHandler)
    • java.lang.management.ThreadInfo
    • java.lang.ThreadLocal<T>
      • java.lang.InheritableThreadLocal<T>
    • org.omg.PortableServer.ThreadPolicyValue (implements org.omg.CORBA.portable.IDLEntity)
    • java.util.concurrent.ThreadPoolExecutor.AbortPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.annotation.AnnotationFormatError
        • java.lang.AssertionError
        • java.awt.AWTError
        • java.nio.charset.CoderMalfunctionError
        • javax.xml.parsers.FactoryConfigurationError
        • javax.xml.stream.FactoryConfigurationError
        • java.io.IOError
        • java.lang.LinkageError
          • java.lang.ClassCircularityError
          • java.lang.ClassFormatError
            • java.lang.reflect.GenericSignatureFormatError
            • java.lang.UnsupportedClassVersionError
          • java.lang.ExceptionInInitializerError
          • java.lang.IncompatibleClassChangeError
            • java.lang.AbstractMethodError
            • java.lang.IllegalAccessError
            • java.lang.InstantiationError
            • java.lang.NoSuchFieldError
            • java.lang.NoSuchMethodError
          • java.lang.NoClassDefFoundError
          • java.lang.UnsatisfiedLinkError
          • java.lang.VerifyError
        • java.util.ServiceConfigurationError
        • java.lang.ThreadDeath
        • javax.xml.transform.TransformerFactoryConfigurationError
        • java.lang.VirtualMachineError
          • java.lang.InternalError
            • java.util.zip.ZipError
          • java.lang.OutOfMemoryError
          • java.lang.StackOverflowError
          • java.lang.UnknownError
      • java.lang.Exception
        • java.security.acl.AclNotFoundException
        • java.rmi.activation.ActivationException
          • java.rmi.activation.UnknownGroupException
          • java.rmi.activation.UnknownObjectException
        • java.rmi.AlreadyBoundException
        • org.omg.CORBA.portable.ApplicationException
        • java.awt.AWTException
        • java.util.prefs.BackingStoreException
        • javax.management.BadAttributeValueExpException
        • javax.management.BadBinaryOpValueExpException
        • javax.swing.text.BadLocationException
        • javax.management.BadStringOperationException
        • java.util.concurrent.BrokenBarrierException
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateEncodingException
          • javax.security.cert.CertificateExpiredException
          • javax.security.cert.CertificateNotYetValidException
          • javax.security.cert.CertificateParsingException
        • java.lang.ClassNotFoundException
        • java.lang.CloneNotSupportedException
          • java.rmi.server.ServerCloneException
        • java.util.zip.DataFormatException
        • javax.xml.datatype.DatatypeConfigurationException
        • javax.security.auth.DestroyFailedException
        • java.util.concurrent.ExecutionException
        • javax.swing.tree.ExpandVetoException
        • java.awt.FontFormatException
        • java.security.GeneralSecurityException
          • javax.crypto.BadPaddingException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateEncodingException
            • java.security.cert.CertificateExpiredException
            • java.security.cert.CertificateNotYetValidException
            • java.security.cert.CertificateParsingException
          • java.security.cert.CertPathBuilderException
          • java.security.cert.CertPathValidatorException
          • java.security.cert.CertStoreException
          • java.security.cert.CRLException
          • java.security.DigestException
          • javax.crypto.ExemptionMechanismException
          • javax.crypto.IllegalBlockSizeException
          • java.security.InvalidAlgorithmParameterException
          • java.security.spec.InvalidKeySpecException
          • java.security.spec.InvalidParameterSpecException
          • java.security.KeyException
            • java.security.InvalidKeyException
            • java.security.KeyManagementException
          • java.security.KeyStoreException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountExpiredException
              • javax.security.auth.login.AccountLockedException
              • javax.security.auth.login.AccountNotFoundException
            • javax.security.auth.login.CredentialException
              • javax.security.auth.login.CredentialExpiredException
              • javax.security.auth.login.CredentialNotFoundException
            • javax.security.auth.login.FailedLoginException
          • java.security.NoSuchAlgorithmException
          • javax.crypto.NoSuchPaddingException
          • java.security.NoSuchProviderException
          • javax.crypto.ShortBufferException
          • java.security.SignatureException
          • java.security.UnrecoverableEntryException
            • java.security.UnrecoverableKeyException
        • org.ietf.jgss.GSSException
        • java.lang.IllegalAccessException
        • java.lang.instrument.IllegalClassFormatException
        • java.lang.InstantiationException
        • java.lang.InterruptedException
        • java.beans.IntrospectionException
        • javax.management.InvalidApplicationException
        • javax.sound.midi.InvalidMidiDataException
        • java.util.prefs.InvalidPreferencesFormatException
        • javax.management.modelmbean.InvalidTargetObjectTypeException
        • java.lang.reflect.InvocationTargetException
        • java.io.IOException
          • javax.swing.text.ChangedCharSetException
          • java.nio.charset.CharacterCodingException
            • java.nio.charset.MalformedInputException
            • java.nio.charset.UnmappableCharacterException
          • java.io.CharConversionException
          • java.nio.channels.ClosedChannelException
            • java.nio.channels.AsynchronousCloseException
              • java.nio.channels.ClosedByInterruptException
          • java.io.EOFException
          • java.nio.channels.FileLockInterruptionException
          • java.io.FileNotFoundException
          • javax.annotation.processing.FilerException
          • java.net.HttpRetryException
          • javax.imageio.IIOException
            • javax.imageio.metadata.IIOInvalidTreeException
          • java.io.InterruptedIOException
            • java.net.SocketTimeoutException
          • java.util.InvalidPropertiesFormatException
          • javax.management.remote.JMXProviderException
          • javax.management.remote.JMXServerErrorException
          • java.net.MalformedURLException
          • java.io.ObjectStreamException
            • java.io.InvalidClassException
            • java.io.InvalidObjectException
            • java.io.NotActiveException
            • java.io.NotSerializableException
            • java.io.OptionalDataException
            • java.io.StreamCorruptedException
            • java.io.WriteAbortedException
          • java.net.ProtocolException
          • java.rmi.RemoteException
            • java.rmi.AccessException
            • java.rmi.activation.ActivateFailedException
            • javax.activity.ActivityCompletedException
            • javax.activity.ActivityRequiredException
            • java.rmi.ConnectException
            • java.rmi.ConnectIOException
            • java.rmi.server.ExportException
              • java.rmi.server.SocketSecurityException
            • javax.activity.InvalidActivityException
            • javax.transaction.InvalidTransactionException
            • java.rmi.MarshalException
            • java.rmi.NoSuchObjectException
            • java.rmi.ServerError
            • java.rmi.ServerException
            • java.rmi.ServerRuntimeException
            • java.rmi.server.SkeletonMismatchException
            • java.rmi.server.SkeletonNotFoundException
            • java.rmi.StubNotFoundException
            • javax.transaction.TransactionRequiredException
            • javax.transaction.TransactionRolledbackException
            • java.rmi.UnexpectedException
            • java.rmi.UnknownHostException
            • java.rmi.UnmarshalException
          • javax.security.sasl.SaslException
            • javax.security.sasl.AuthenticationException
          • java.net.SocketException
            • java.net.BindException
            • java.net.ConnectException
            • java.net.NoRouteToHostException
            • java.net.PortUnreachableException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLHandshakeException
            • javax.net.ssl.SSLKeyException
            • javax.net.ssl.SSLPeerUnverifiedException
            • javax.net.ssl.SSLProtocolException
          • java.io.SyncFailedException
          • java.net.UnknownHostException
          • java.net.UnknownServiceException
          • javax.activation.UnsupportedDataTypeException
          • java.io.UnsupportedEncodingException
          • java.io.UTFDataFormatException
          • java.util.zip.ZipException
            • java.util.jar.JarException
        • javax.xml.bind.JAXBException
          • javax.xml.bind.MarshalException
          • javax.xml.bind.PropertyException
          • javax.xml.bind.UnmarshalException
          • javax.xml.bind.ValidationException
        • javax.management.JMException
          • javax.management.MBeanException
            • javax.management.MBeanRegistrationException
          • javax.management.openmbean.OpenDataException
          • javax.management.OperationsException
            • javax.management.AttributeNotFoundException
            • javax.management.InstanceAlreadyExistsException
            • javax.management.InstanceNotFoundException
            • javax.management.IntrospectionException
            • javax.management.InvalidAttributeValueException
            • javax.management.ListenerNotFoundException
            • javax.management.MalformedObjectNameException
            • javax.management.NotCompliantMBeanException
            • javax.management.ServiceNotFoundException
          • javax.management.ReflectionException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationIdException
            • javax.management.relation.InvalidRelationServiceException
            • javax.management.relation.InvalidRelationTypeException
            • javax.management.relation.InvalidRoleInfoException
            • javax.management.relation.InvalidRoleValueException
            • javax.management.relation.RelationNotFoundException
            • javax.management.relation.RelationServiceNotRegisteredException
            • javax.management.relation.RelationTypeNotFoundException
            • javax.management.relation.RoleInfoNotFoundException
            • javax.management.relation.RoleNotFoundException
        • javax.xml.crypto.KeySelectorException
        • java.security.acl.LastOwnerException
        • javax.sound.sampled.LineUnavailableException
        • javax.xml.crypto.MarshalException
        • javax.sound.midi.MidiUnavailableException
        • java.awt.datatransfer.MimeTypeParseException
        • javax.activation.MimeTypeParseException
        • javax.naming.NamingException
          • javax.naming.directory.AttributeInUseException
          • javax.naming.directory.AttributeModificationException
          • javax.naming.CannotProceedException
          • javax.naming.CommunicationException
          • javax.naming.ConfigurationException
          • javax.naming.ContextNotEmptyException
          • javax.naming.InsufficientResourcesException
          • javax.naming.InterruptedNamingException
          • javax.naming.directory.InvalidAttributeIdentifierException
          • javax.naming.directory.InvalidAttributesException
          • javax.naming.directory.InvalidAttributeValueException
          • javax.naming.InvalidNameException
          • javax.naming.directory.InvalidSearchControlsException
          • javax.naming.directory.InvalidSearchFilterException
          • javax.naming.LimitExceededException
            • javax.naming.SizeLimitExceededException
            • javax.naming.TimeLimitExceededException
          • javax.naming.LinkException
            • javax.naming.LinkLoopException
            • javax.naming.MalformedLinkException
          • javax.naming.NameAlreadyBoundException
          • javax.naming.NameNotFoundException
          • javax.naming.NamingSecurityException
            • javax.naming.AuthenticationException
            • javax.naming.AuthenticationNotSupportedException
            • javax.naming.NoPermissionException
          • javax.naming.NoInitialContextException
          • javax.naming.directory.NoSuchAttributeException
          • javax.naming.NotContextException
          • javax.naming.OperationNotSupportedException
          • javax.naming.PartialResultException
          • javax.naming.ReferralException
            • javax.naming.ldap.LdapReferralException
          • javax.naming.directory.SchemaViolationException
          • javax.naming.ServiceUnavailableException
        • java.awt.geom.NoninvertibleTransformException
        • java.lang.NoSuchFieldException
        • java.lang.NoSuchMethodException
        • java.rmi.NotBoundException
        • java.security.acl.NotOwnerException
        • java.text.ParseException
        • javax.xml.parsers.ParserConfigurationException
        • java.awt.print.PrinterException
          • java.awt.print.PrinterAbortException
          • java.awt.print.PrinterIOException
        • javax.print.PrintException
        • java.security.PrivilegedActionException
        • java.beans.PropertyVetoException
        • javax.security.auth.RefreshFailedException
        • org.omg.CORBA.portable.RemarshalException
        • java.lang.RuntimeException
          • java.lang.annotation.AnnotationTypeMismatchException
          • java.lang.ArithmeticException
          • java.lang.ArrayStoreException
          • java.nio.BufferOverflowException
          • java.nio.BufferUnderflowException
          • javax.swing.undo.CannotRedoException
          • javax.swing.undo.CannotUndoException
          • java.lang.ClassCastException
          • java.awt.color.CMMException
          • java.util.ConcurrentModificationException
          • org.w3c.dom.DOMException
          • java.util.EmptyStackException
          • java.lang.EnumConstantNotPresentException
          • org.w3c.dom.events.EventException
          • java.lang.IllegalArgumentException
            • java.nio.charset.IllegalCharsetNameException
            • java.util.IllegalFormatException
              • java.util.DuplicateFormatFlagsException
              • java.util.FormatFlagsConversionMismatchException
              • java.util.IllegalFormatCodePointException
              • java.util.IllegalFormatConversionException
              • java.util.IllegalFormatFlagsException
              • java.util.IllegalFormatPrecisionException
              • java.util.IllegalFormatWidthException
              • java.util.MissingFormatArgumentException
              • java.util.MissingFormatWidthException
              • java.util.UnknownFormatConversionException
              • java.util.UnknownFormatFlagsException
            • java.nio.channels.IllegalSelectorException
            • java.lang.IllegalThreadStateException
            • javax.management.openmbean.InvalidKeyException
            • javax.management.openmbean.InvalidOpenTypeException
            • java.security.InvalidParameterException
            • javax.management.openmbean.KeyAlreadyExistsException
            • java.lang.NumberFormatException
            • java.util.regex.PatternSyntaxException
            • java.nio.channels.UnresolvedAddressException
            • java.nio.channels.UnsupportedAddressTypeException
            • java.nio.charset.UnsupportedCharsetException
          • java.lang.IllegalMonitorStateException
          • java.awt.geom.IllegalPathStateException
          • java.lang.IllegalStateException
            • java.nio.channels.AlreadyConnectedException
            • java.util.concurrent.CancellationException
            • java.nio.channels.CancelledKeyException
            • java.nio.channels.ClosedSelectorException
            • java.nio.channels.ConnectionPendingException
            • java.util.FormatterClosedException
            • java.nio.channels.IllegalBlockingModeException
            • java.awt.IllegalComponentStateException
            • java.awt.dnd.InvalidDnDOperationException
            • java.nio.InvalidMarkException
            • java.nio.channels.NoConnectionPendingException
            • java.nio.channels.NonReadableChannelException
            • java.nio.channels.NonWritableChannelException
            • java.nio.channels.NotYetBoundException
            • java.nio.channels.NotYetConnectedException
            • java.nio.channels.OverlappingFileLockException
          • java.awt.image.ImagingOpException
          • java.lang.annotation.IncompleteAnnotationException
          • java.lang.IndexOutOfBoundsException
            • java.lang.ArrayIndexOutOfBoundsException
            • java.lang.StringIndexOutOfBoundsException
          • javax.management.JMRuntimeException
            • javax.management.monitor.MonitorSettingException
            • javax.management.RuntimeErrorException
            • javax.management.RuntimeMBeanException
            • javax.management.RuntimeOperationsException
          • org.w3c.dom.ls.LSException
          • java.lang.reflect.MalformedParameterizedTypeException
          • javax.lang.model.type.MirroredTypeException
          • javax.lang.model.type.MirroredTypesException
          • java.util.MissingResourceException
          • java.lang.NegativeArraySizeException
          • java.util.NoSuchElementException
            • java.util.InputMismatchException
          • javax.xml.crypto.NoSuchMechanismException
          • java.lang.NullPointerException
          • java.awt.color.ProfileDataException
          • java.security.ProviderException
          • java.awt.image.RasterFormatException
          • java.util.concurrent.RejectedExecutionException
          • java.lang.SecurityException
            • java.security.AccessControlException
            • java.rmi.RMISecurityException
          • org.omg.CORBA.SystemException
            • org.omg.CORBA.ACTIVITY_COMPLETED
            • org.omg.CORBA.ACTIVITY_REQUIRED
            • org.omg.CORBA.BAD_CONTEXT
            • org.omg.CORBA.BAD_INV_ORDER
            • org.omg.CORBA.BAD_OPERATION
            • org.omg.CORBA.BAD_PARAM
            • org.omg.CORBA.BAD_QOS
            • org.omg.CORBA.BAD_TYPECODE
            • org.omg.CORBA.CODESET_INCOMPATIBLE
            • org.omg.CORBA.COMM_FAILURE
            • org.omg.CORBA.DATA_CONVERSION
            • org.omg.CORBA.FREE_MEM
            • org.omg.CORBA.IMP_LIMIT
            • org.omg.CORBA.portable.IndirectionException
            • org.omg.CORBA.INITIALIZE
            • org.omg.CORBA.INTERNAL
            • org.omg.CORBA.INTF_REPOS
            • org.omg.CORBA.INV_FLAG
            • org.omg.CORBA.INV_IDENT
            • org.omg.CORBA.INV_OBJREF
            • org.omg.CORBA.INV_POLICY
            • org.omg.CORBA.INVALID_ACTIVITY
            • org.omg.CORBA.INVALID_TRANSACTION
            • org.omg.CORBA.MARSHAL
            • org.omg.CORBA.NO_IMPLEMENT
            • org.omg.CORBA.NO_MEMORY
            • org.omg.CORBA.NO_PERMISSION
            • org.omg.CORBA.NO_RESOURCES
            • org.omg.CORBA.NO_RESPONSE
            • org.omg.CORBA.OBJ_ADAPTER
            • org.omg.CORBA.OBJECT_NOT_EXIST
            • org.omg.CORBA.PERSIST_STORE
            • org.omg.CORBA.REBIND
            • org.omg.CORBA.TIMEOUT
            • org.omg.CORBA.TRANSACTION_MODE
            • org.omg.CORBA.TRANSACTION_REQUIRED
            • org.omg.CORBA.TRANSACTION_ROLLEDBACK
            • org.omg.CORBA.TRANSACTION_UNAVAILABLE
            • org.omg.CORBA.TRANSIENT
            • org.omg.CORBA.UNKNOWN
            • org.omg.CORBA.portable.UnknownException
          • javax.xml.bind.TypeConstraintException
          • java.lang.TypeNotPresentException
          • java.lang.reflect.UndeclaredThrowableException
          • javax.lang.model.element.UnknownAnnotationValueException
          • javax.lang.model.element.UnknownElementException
          • javax.lang.model.type.UnknownTypeException
          • javax.print.attribute.UnmodifiableSetException
          • java.lang.UnsupportedOperationException
            • java.awt.HeadlessException
            • java.nio.ReadOnlyBufferException
          • javax.xml.ws.WebServiceException
            • javax.xml.ws.ProtocolException
              • javax.xml.ws.http.HTTPException
              • javax.xml.ws.soap.SOAPFaultException
        • org.xml.sax.SAXException
          • org.xml.sax.SAXNotRecognizedException
          • org.xml.sax.SAXNotSupportedException
          • org.xml.sax.SAXParseException
        • javax.script.ScriptException
        • java.rmi.server.ServerNotActiveException
        • javax.xml.soap.SOAPException
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • java.sql.BatchUpdateException
          • javax.sql.rowset.RowSetWarning
          • javax.sql.rowset.serial.SerialException
          • java.sql.SQLClientInfoException
          • java.sql.SQLNonTransientException
            • java.sql.SQLDataException
            • java.sql.SQLFeatureNotSupportedException
            • java.sql.SQLIntegrityConstraintViolationException
            • java.sql.SQLInvalidAuthorizationSpecException
            • java.sql.SQLNonTransientConnectionException
            • java.sql.SQLSyntaxErrorException
          • java.sql.SQLRecoverableException
          • java.sql.SQLTransientException
            • java.sql.SQLTimeoutException
            • java.sql.SQLTransactionRollbackException
            • java.sql.SQLTransientConnectionException
          • java.sql.SQLWarning
            • java.sql.DataTruncation
          • javax.sql.rowset.spi.SyncFactoryException
          • javax.sql.rowset.spi.SyncProviderException
        • java.util.concurrent.TimeoutException
        • java.util.TooManyListenersException
        • javax.xml.transform.TransformerException
          • javax.xml.transform.TransformerConfigurationException
        • javax.xml.crypto.dsig.TransformException
        • java.lang.instrument.UnmodifiableClassException
        • javax.sound.sampled.UnsupportedAudioFileException
        • javax.security.auth.callback.UnsupportedCallbackException
        • java.awt.datatransfer.UnsupportedFlavorException
        • javax.swing.UnsupportedLookAndFeelException
        • javax.xml.crypto.URIReferenceException
        • java.net.URISyntaxException
        • org.omg.CORBA.UserException (implements org.omg.CORBA.portable.IDLEntity)
          • org.omg.PortableServer.POAPackage.AdapterAlreadyExists
          • org.omg.PortableServer.POAManagerPackage.AdapterInactive
          • org.omg.PortableServer.POAPackage.AdapterNonExistent
          • org.omg.CosNaming.NamingContextPackage.AlreadyBound
          • org.omg.CORBA.TypeCodePackage.BadKind
          • org.omg.CORBA.Bounds
          • org.omg.CORBA.TypeCodePackage.Bounds
          • org.omg.CosNaming.NamingContextPackage.CannotProceed
          • org.omg.PortableInterceptor.ORBInitInfoPackage.DuplicateName
          • org.omg.IOP.CodecPackage.FormatMismatch
          • org.omg.PortableServer.ForwardRequest
          • org.omg.PortableInterceptor.ForwardRequest
          • org.omg.CORBA.ORBPackage.InconsistentTypeCode
          • org.omg.DynamicAny.DynAnyFactoryPackage.InconsistentTypeCode
          • org.omg.CORBA.DynAnyPackage.Invalid
          • org.omg.CosNaming.NamingContextExtPackage.InvalidAddress
          • org.omg.CORBA.ORBPackage.InvalidName
          • org.omg.CosNaming.NamingContextPackage.InvalidName
          • org.omg.PortableInterceptor.ORBInitInfoPackage.InvalidName
          • org.omg.PortableServer.POAPackage.InvalidPolicy
          • org.omg.CORBA.DynAnyPackage.InvalidSeq
          • org.omg.PortableInterceptor.InvalidSlot
          • org.omg.IOP.CodecPackage.InvalidTypeForEncoding
          • org.omg.CORBA.DynAnyPackage.InvalidValue
          • org.omg.DynamicAny.DynAnyPackage.InvalidValue
          • org.omg.PortableServer.CurrentPackage.NoContext
          • org.omg.PortableServer.POAPackage.NoServant
          • org.omg.CosNaming.NamingContextPackage.NotEmpty
          • org.omg.CosNaming.NamingContextPackage.NotFound
          • org.omg.PortableServer.POAPackage.ObjectAlreadyActive
          • org.omg.PortableServer.POAPackage.ObjectNotActive
          • org.omg.CORBA.PolicyError
          • org.omg.PortableServer.POAPackage.ServantAlreadyActive
          • org.omg.PortableServer.POAPackage.ServantNotActive
          • org.omg.CORBA.DynAnyPackage.TypeMismatch
          • org.omg.IOP.CodecPackage.TypeMismatch
          • org.omg.DynamicAny.DynAnyPackage.TypeMismatch
          • org.omg.IOP.CodecFactoryPackage.UnknownEncoding
          • org.omg.CORBA.UnknownUserException
          • org.omg.PortableServer.POAPackage.WrongAdapter
          • org.omg.PortableServer.POAPackage.WrongPolicy
          • org.omg.CORBA.WrongTransaction
        • javax.transaction.xa.XAException
        • javax.management.modelmbean.XMLParseException
        • javax.xml.crypto.dsig.XMLSignatureException
        • javax.xml.stream.XMLStreamException
        • javax.xml.xpath.XPathException
          • javax.xml.xpath.XPathExpressionException
            • javax.xml.xpath.XPathFunctionException
          • javax.xml.xpath.XPathFactoryConfigurationException
    • java.util.Timer
    • javax.swing.Timer (implements java.io.Serializable)
    • java.util.TimerTask (implements java.lang.Runnable)
    • java.security.Timestamp (implements java.io.Serializable)
    • java.util.TimeZone (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.SimpleTimeZone
    • java.awt.Toolkit
    • javax.tools.ToolProvider
    • javax.swing.ToolTipManager.insideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.outsideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.stillInsideTimerAction (implements java.awt.event.ActionListener)
    • javax.sound.midi.Track
    • javax.swing.TransferHandler (implements java.io.Serializable)
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JList.DropLocation
      • javax.swing.JTable.DropLocation
      • javax.swing.text.JTextComponent.DropLocation
      • javax.swing.JTree.DropLocation
    • javax.swing.TransferHandler.TransferSupport
    • java.awt.font.TransformAttribute (implements java.io.Serializable)
    • javax.xml.transform.Transformer
    • javax.xml.transform.TransformerFactory
      • javax.xml.transform.sax.SAXTransformerFactory
    • javax.xml.crypto.dsig.TransformService (implements javax.xml.crypto.dsig.Transform)
    • java.awt.TrayIcon
    • javax.swing.tree.TreePath (implements java.io.Serializable)
    • java.security.cert.TrustAnchor
    • javax.net.ssl.TrustManagerFactory
    • javax.net.ssl.TrustManagerFactorySpi
    • org.omg.CORBA.TypeCode (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.TypeCodeHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.validation.TypeInfoProvider
    • org.omg.IOP.CodecPackage.TypeMismatchHelper
    • org.omg.DynamicAny.DynAnyPackage.TypeMismatchHelper
    • java.sql.Types
    • java.rmi.server.UID (implements java.io.Serializable)
    • javax.swing.UIDefaults.LazyInputMap (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIDefaults.ProxyLazyValue (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIManager (implements java.io.Serializable)
    • javax.swing.UIManager.LookAndFeelInfo
    • org.omg.CORBA.ULongLongSeqHelper
    • org.omg.CORBA.ULongLongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ULongSeqHelper
    • org.omg.CORBA.ULongSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.swing.undo.UndoableEditSupport
    • org.omg.CORBA.UnionMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.UnionMemberHelper
    • org.omg.IOP.CodecFactoryPackage.UnknownEncodingHelper
    • org.omg.CORBA.UnknownUserExceptionHelper
    • org.omg.CORBA.UnknownUserExceptionHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.xml.bind.Unmarshaller.Listener
    • java.net.URI (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.security.URIParameter (implements javax.security.auth.login.Configuration.Parameters, java.security.Policy.Parameters)
    • javax.print.attribute.URISyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Destination (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterMoreInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMoreInfoManufacturer (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterURI (implements javax.print.attribute.PrintServiceAttribute)
    • java.net.URL (implements java.io.Serializable)
    • java.net.URLConnection
      • java.net.HttpURLConnection
        • javax.net.ssl.HttpsURLConnection
      • java.net.JarURLConnection
    • javax.activation.URLDataSource (implements javax.activation.DataSource)
    • java.net.URLDecoder
    • java.net.URLEncoder
    • java.net.URLStreamHandler
    • org.omg.CosNaming.NamingContextExtPackage.URLStringHelper
    • org.omg.CORBA.UShortSeqHelper
    • org.omg.CORBA.UShortSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • javax.rmi.CORBA.Util
    • javax.swing.text.Utilities
    • java.util.UUID (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.xml.bind.util.ValidationEventCollector (implements javax.xml.bind.ValidationEventHandler)
    • javax.xml.bind.helpers.ValidationEventImpl (implements javax.xml.bind.ValidationEvent)
      • javax.xml.bind.helpers.NotIdentifiableEventImpl (implements javax.xml.bind.NotIdentifiableEvent)
      • javax.xml.bind.helpers.ParseConversionEventImpl (implements javax.xml.bind.ParseConversionEvent)
      • javax.xml.bind.helpers.PrintConversionEventImpl (implements javax.xml.bind.PrintConversionEvent)
    • javax.xml.bind.helpers.ValidationEventLocatorImpl (implements javax.xml.bind.ValidationEventLocator)
    • javax.xml.validation.Validator
    • javax.xml.validation.ValidatorHandler (implements org.xml.sax.ContentHandler)
    • org.omg.CORBA.ValueBaseHelper
    • org.omg.CORBA.ValueBaseHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.ValueMember (implements org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.ValueMemberHelper
    • org.omg.CORBA.VersionSpecHelper
    • java.beans.VetoableChangeSupport (implements java.io.Serializable)
    • javax.swing.text.View (implements javax.swing.SwingConstants)
      • javax.swing.text.AsyncBoxView
      • javax.swing.text.ComponentView
        • javax.swing.text.html.FormView (implements java.awt.event.ActionListener)
        • javax.swing.text.html.ObjectView
      • javax.swing.text.CompositeView
        • javax.swing.text.BoxView
          • javax.swing.text.html.BlockView
            • javax.swing.text.html.ListView
          • javax.swing.text.FlowView
            • javax.swing.text.ParagraphView (implements javax.swing.text.TabExpander)
              • javax.swing.text.html.ParagraphView
          • javax.swing.text.TableView
          • javax.swing.text.TableView.TableCell
          • javax.swing.text.TableView.TableRow
          • javax.swing.text.WrappedPlainView (implements javax.swing.text.TabExpander)
          • javax.swing.text.ZoneView
      • javax.swing.text.GlyphView (implements java.lang.Cloneable, javax.swing.text.TabableView)
        • javax.swing.text.LabelView (implements javax.swing.text.TabableView)
          • javax.swing.text.html.InlineView
      • javax.swing.text.IconView
      • javax.swing.text.html.ImageView
      • javax.swing.text.PlainView (implements javax.swing.text.TabExpander)
        • javax.swing.text.FieldView
          • javax.swing.text.PasswordView
    • javax.swing.ViewportLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • org.omg.CORBA.VisibilityHelper
    • java.rmi.dgc.VMID (implements java.io.Serializable)
    • javax.sound.midi.VoiceStatus
    • java.lang.Void
    • javax.xml.bind.annotation.W3CDomHandler (implements javax.xml.bind.annotation.DomHandler<ElementT,ResultT>)
    • org.omg.CORBA.WCharSeqHelper
    • org.omg.CORBA.WCharSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
      • javax.swing.plaf.basic.BasicToolBarUI.FrameListener
      • javax.swing.JMenu.WinListener (implements java.io.Serializable)
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • java.io.BufferedWriter
      • java.io.CharArrayWriter
      • java.io.FilterWriter
      • java.io.OutputStreamWriter
        • java.io.FileWriter
      • java.io.PipedWriter
      • java.io.PrintWriter
      • java.io.StringWriter
    • org.omg.PortableServer.POAPackage.WrongAdapterHelper
    • org.omg.PortableServer.POAPackage.WrongPolicyHelper
    • org.omg.CORBA.WrongTransactionHelper
    • org.omg.CORBA.WrongTransactionHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringSeqHelper
    • org.omg.CORBA.WStringSeqHolder (implements org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.WStringValueHelper (implements org.omg.CORBA.portable.BoxedValueHelper)
    • javax.security.auth.x500.X500Principal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.x500.X500PrivateCredential (implements javax.security.auth.Destroyable)
    • java.security.cert.X509CertSelector (implements java.security.cert.CertSelector)
    • java.security.cert.X509CRLEntry (implements java.security.cert.X509Extension)
    • java.security.cert.X509CRLSelector (implements java.security.cert.CRLSelector)
    • javax.net.ssl.X509ExtendedKeyManager (implements javax.net.ssl.X509KeyManager)
    • javax.xml.bind.annotation.adapters.XmlAdapter<ValueType,BoundType>
      • javax.xml.bind.annotation.adapters.CollapsedStringAdapter
      • javax.xml.bind.annotation.adapters.HexBinaryAdapter
      • javax.xml.bind.annotation.adapters.NormalizedStringAdapter
    • javax.xml.XMLConstants
    • java.beans.XMLDecoder
    • javax.xml.bind.annotation.XmlElement.DEFAULT
    • javax.xml.bind.annotation.XmlElementDecl.GLOBAL
    • javax.xml.bind.annotation.XmlElementRef.DEFAULT
    • javax.xml.stream.XMLEventFactory
    • org.xml.sax.helpers.XMLFilterImpl (implements org.xml.sax.ContentHandler, org.xml.sax.DTDHandler, org.xml.sax.EntityResolver, org.xml.sax.ErrorHandler, org.xml.sax.XMLFilter)
    • javax.xml.datatype.XMLGregorianCalendar (implements java.lang.Cloneable)
    • javax.xml.stream.XMLInputFactory
    • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter.DEFAULT
    • javax.xml.stream.XMLOutputFactory
    • org.xml.sax.helpers.XMLReaderAdapter (implements org.xml.sax.ContentHandler, org.xml.sax.Parser)
    • org.xml.sax.helpers.XMLReaderFactory
    • javax.xml.bind.annotation.XmlSchemaType.DEFAULT
    • javax.xml.crypto.dsig.XMLSignatureFactory
    • javax.xml.bind.annotation.XmlType.DEFAULT
    • javax.xml.xpath.XPathConstants
    • javax.xml.xpath.XPathFactory
    • javax.xml.crypto.dsig.spec.XPathFilter2ParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathFilterParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • javax.xml.crypto.dsig.spec.XPathType
    • javax.xml.crypto.dsig.spec.XPathType.Filter
    • javax.xml.crypto.dsig.spec.XSLTTransformParameterSpec (implements javax.xml.crypto.dsig.spec.TransformParameterSpec)
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
      • java.util.jar.JarEntry
    • java.util.zip.ZipFile
      • java.util.jar.JarFile

接口分层结构

  • javax.swing.text.AbstractDocument.AttributeContext
  • javax.swing.text.AbstractDocument.Content
  • javax.accessibility.Accessible
  • javax.accessibility.AccessibleAction
  • javax.accessibility.AccessibleComponent
    • javax.accessibility.AccessibleExtendedComponent
  • javax.accessibility.AccessibleExtendedText
  • javax.accessibility.AccessibleIcon
  • javax.accessibility.AccessibleKeyBinding
  • javax.accessibility.AccessibleSelection
  • javax.accessibility.AccessibleStreamable
  • javax.accessibility.AccessibleTable
    • javax.accessibility.AccessibleExtendedTable
  • javax.accessibility.AccessibleTableModelChange
  • javax.accessibility.AccessibleText
    • javax.accessibility.AccessibleEditableText
    • javax.accessibility.AccessibleHypertext
  • javax.accessibility.AccessibleValue
  • org.omg.PortableInterceptor.ACTIVE
  • java.awt.ActiveEvent
  • org.omg.PortableServer.AdapterActivatorOperations
    • org.omg.PortableServer.AdapterActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.awt.Adjustable
  • javax.xml.crypto.AlgorithmMethod
    • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.DigestMethod (并 extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.SignatureMethod (并 extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.Transform (并 extends javax.xml.crypto.XMLStructure)
      • javax.xml.crypto.dsig.CanonicalizationMethod
  • java.security.spec.AlgorithmParameterSpec
    • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
    • javax.xml.crypto.dsig.spec.DigestMethodParameterSpec
    • javax.xml.crypto.dsig.spec.SignatureMethodParameterSpec
    • javax.xml.crypto.dsig.spec.TransformParameterSpec
      • javax.xml.crypto.dsig.spec.C14NMethodParameterSpec
  • java.lang.reflect.AnnotatedElement
  • java.lang.annotation.Annotation
  • javax.lang.model.element.AnnotationMirror
  • javax.lang.model.element.AnnotationValue
  • javax.lang.model.element.AnnotationValueVisitor<R,P>
  • java.lang.Appendable
  • java.applet.AppletContext
  • java.beans.AppletInitializer
  • java.applet.AppletStub
  • org.omg.CORBA.ARG_IN
  • org.omg.CORBA.ARG_INOUT
  • org.omg.CORBA.ARG_OUT
  • java.sql.Array
  • javax.xml.ws.AsyncHandler<T>
  • javax.print.AttributeException
  • org.xml.sax.AttributeList
  • org.xml.sax.Attributes
    • org.xml.sax.ext.Attributes2
  • javax.print.attribute.AttributeSet
    • javax.print.attribute.DocAttributeSet
    • javax.print.attribute.PrintJobAttributeSet
    • javax.print.attribute.PrintRequestAttributeSet
    • javax.print.attribute.PrintServiceAttributeSet
  • javax.swing.text.AttributeSet
    • javax.swing.text.MutableAttributeSet
      • javax.swing.text.Style
    • javax.swing.text.Style
  • javax.swing.text.AttributeSet.CharacterAttribute
  • javax.swing.text.AttributeSet.ColorAttribute
  • javax.swing.text.AttributeSet.FontAttribute
  • javax.swing.text.AttributeSet.ParagraphAttribute
  • java.applet.AudioClip
  • java.awt.dnd.Autoscroll
  • org.omg.CORBA.BAD_POLICY
  • org.omg.CORBA.BAD_POLICY_TYPE
  • org.omg.CORBA.BAD_POLICY_VALUE
  • java.beans.beancontext.BeanContextChild
    • java.beans.beancontext.BeanContext (并 extends java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • java.beans.beancontext.BeanContextChildComponentProxy
  • java.beans.beancontext.BeanContextContainerProxy
  • java.beans.beancontext.BeanContextProxy
  • java.beans.beancontext.BeanContextServiceProvider
  • java.beans.BeanInfo
    • java.beans.beancontext.BeanContextServiceProviderBeanInfo
  • javax.xml.ws.Binding
    • javax.xml.ws.http.HTTPBinding
    • javax.xml.ws.soap.SOAPBinding
  • org.omg.CosNaming.BindingIteratorOperations
    • org.omg.CosNaming.BindingIterator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • javax.xml.ws.BindingProvider
    • javax.xml.ws.Dispatch<T>
  • java.sql.Blob
  • javax.swing.border.Border
  • javax.swing.BoundedRangeModel
  • org.omg.CORBA.portable.BoxedValueHelper
  • java.awt.image.BufferedImageOp
  • java.util.concurrent.Callable<V>
    • javax.tools.JavaCompiler.CompilationTask
  • javax.security.auth.callback.Callback
  • javax.security.auth.callback.CallbackHandler
  • javax.swing.text.Caret
  • javax.swing.CellEditor
    • javax.swing.table.TableCellEditor
    • javax.swing.tree.TreeCellEditor
  • java.security.Certificate
  • java.lang.CharSequence
    • javax.lang.model.element.Name
  • java.util.zip.Checksum
  • java.lang.instrument.ClassFileTransformer
  • javax.management.loading.ClassLoaderRepository
  • java.lang.management.ClassLoadingMXBean
  • java.awt.datatransfer.ClipboardOwner
  • java.sql.Clob
    • java.sql.NClob
  • java.lang.Cloneable
    • java.security.acl.AclEntry
    • javax.naming.directory.Attribute (并 extends java.io.Serializable)
    • java.text.AttributedCharacterIterator
    • javax.naming.directory.Attributes (并 extends java.io.Serializable)
    • java.security.cert.CertPathBuilderResult
    • java.security.cert.CertPathParameters
    • java.security.cert.CertPathValidatorResult
    • java.security.cert.CertSelector
    • java.security.cert.CertStoreParameters
    • java.text.CharacterIterator
      • java.text.AttributedCharacterIterator
    • java.security.cert.CRLSelector
    • javax.management.Descriptor (并 extends java.io.Serializable)
    • org.ietf.jgss.GSSCredential
    • javax.naming.Name (并 extends java.lang.Comparable<T>, java.io.Serializable)
  • java.io.Closeable
    • java.nio.channels.ByteChannel (并 extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
    • java.nio.channels.Channel
      • java.nio.channels.ByteChannel (并 extends java.nio.channels.ReadableByteChannel, java.nio.channels.WritableByteChannel)
      • java.nio.channels.GatheringByteChannel
      • java.nio.channels.InterruptibleChannel
      • java.nio.channels.ReadableByteChannel
        • java.nio.channels.ByteChannel (并 extends java.nio.channels.WritableByteChannel)
        • java.nio.channels.ScatteringByteChannel
      • java.nio.channels.ScatteringByteChannel
      • java.nio.channels.WritableByteChannel
        • java.nio.channels.ByteChannel (并 extends java.nio.channels.ReadableByteChannel)
        • java.nio.channels.GatheringByteChannel
    • java.nio.channels.GatheringByteChannel
    • java.nio.channels.InterruptibleChannel
    • javax.tools.JavaFileManager (并 extends java.io.Flushable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
    • javax.management.remote.JMXConnector
    • java.nio.channels.ReadableByteChannel
      • java.nio.channels.ByteChannel (并 extends java.nio.channels.WritableByteChannel)
      • java.nio.channels.ScatteringByteChannel
    • javax.management.remote.rmi.RMIConnection (并 extends java.rmi.Remote)
    • java.nio.channels.ScatteringByteChannel
    • javax.tools.StandardJavaFileManager
    • java.nio.channels.WritableByteChannel
      • java.nio.channels.ByteChannel (并 extends java.nio.channels.ReadableByteChannel)
      • java.nio.channels.GatheringByteChannel
  • org.omg.IOP.CodecFactoryOperations
    • org.omg.IOP.CodecFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodecOperations
    • org.omg.IOP.Codec (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.IOP.CodeSets
  • javax.swing.colorchooser.ColorSelectionModel
  • javax.swing.ComboBoxEditor
  • javax.swing.plaf.basic.ComboPopup
  • javax.activation.CommandObject
  • javax.sql.CommonDataSource
    • javax.sql.ConnectionPoolDataSource
    • javax.sql.DataSource (并 extends java.sql.Wrapper)
    • javax.sql.XADataSource
  • java.lang.Comparable<T>
    • java.util.concurrent.Delayed
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
      • java.util.concurrent.ScheduledFuture<V> (并 extends java.util.concurrent.Future<V>)
        • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>)
    • javax.naming.Name (并 extends java.lang.Cloneable, java.io.Serializable)
    • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (并 extends java.util.concurrent.Delayed, java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>)
  • java.util.Comparator<T>
  • javax.script.Compilable
  • java.lang.management.CompilationMXBean
  • javax.annotation.processing.Completion
  • java.util.concurrent.CompletionService<V>
  • java.awt.Composite
  • java.awt.CompositeContext
  • javax.management.openmbean.CompositeData
  • javax.management.openmbean.CompositeDataView
  • java.util.concurrent.locks.Condition
  • javax.security.auth.login.Configuration.Parameters
  • org.xml.sax.ContentHandler
    • javax.xml.transform.sax.TemplatesHandler
    • javax.xml.transform.sax.TransformerHandler (并 extends org.xml.sax.DTDHandler, org.xml.sax.ext.LexicalHandler)
    • javax.xml.bind.UnmarshallerHandler
  • java.net.ContentHandlerFactory
  • javax.naming.Context
    • javax.naming.directory.DirContext
      • javax.naming.event.EventDirContext (并 extends javax.naming.event.EventContext)
      • javax.naming.ldap.LdapContext
    • javax.naming.event.EventContext
      • javax.naming.event.EventDirContext (并 extends javax.naming.directory.DirContext)
    • javax.naming.event.EventDirContext (并 extends javax.naming.directory.DirContext, javax.naming.event.EventContext)
    • javax.naming.ldap.LdapContext
  • java.net.CookiePolicy
  • java.net.CookieStore
  • org.omg.CORBA.CTX_RESTRICT_SCOPE
  • org.omg.CORBA.CurrentOperations
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (并 extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (并 extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (并 extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (并 extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.CurrentOperations
      • org.omg.PortableServer.Current (并 extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.CurrentOperations
      • org.omg.PortableInterceptor.Current (并 extends org.omg.CORBA.Current, org.omg.CORBA.portable.IDLEntity)
  • java.beans.Customizer
  • org.omg.CORBA.CustomMarshal
    • org.omg.CORBA.portable.CustomValue (并 extends org.omg.CORBA.portable.ValueBase)
  • javax.xml.crypto.Data
    • javax.xml.crypto.NodeSetData
  • javax.activation.DataContentHandler
  • javax.activation.DataContentHandlerFactory
  • java.net.DatagramSocketImplFactory
  • java.io.DataInput
    • javax.imageio.stream.ImageInputStream
      • javax.imageio.stream.ImageOutputStream (并 extends java.io.DataOutput)
    • javax.imageio.stream.ImageOutputStream (并 extends java.io.DataOutput, javax.imageio.stream.ImageInputStream)
    • java.io.ObjectInput
  • java.io.DataOutput
    • javax.imageio.stream.ImageOutputStream (并 extends javax.imageio.stream.ImageInputStream)
    • java.io.ObjectOutput
  • javax.activation.DataSource
  • javax.xml.bind.DatatypeConverterInterface
  • org.xml.sax.ext.DeclHandler
  • org.omg.PortableServer.portable.Delegate
  • javax.management.DescriptorRead
    • javax.management.DescriptorAccess
  • java.beans.DesignMode
    • java.beans.beancontext.BeanContext (并 extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • javax.swing.DesktopManager
  • javax.security.auth.Destroyable
  • javax.crypto.interfaces.DHKey
    • javax.crypto.interfaces.DHPrivateKey (并 extends java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (并 extends java.security.PublicKey)
  • javax.tools.Diagnostic<S>
  • javax.tools.DiagnosticListener<S>
  • org.omg.PortableInterceptor.DISCARDING
  • javax.print.Doc
  • javax.print.DocPrintJob
    • javax.print.CancelablePrintJob
    • javax.print.MultiDocPrintJob
  • javax.swing.text.Document
    • javax.swing.text.StyledDocument
  • javax.swing.event.DocumentEvent
  • org.w3c.dom.events.DocumentEvent
  • javax.swing.event.DocumentEvent.ElementChange
  • org.xml.sax.DocumentHandler
  • java.security.DomainCombiner
  • org.omg.CORBA.DomainManagerOperations
    • org.omg.CORBA.DomainManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.w3c.dom.DOMConfiguration
  • org.w3c.dom.DOMError
  • org.w3c.dom.DOMErrorHandler
  • javax.xml.bind.annotation.DomHandler<ElementT,ResultT>
  • org.w3c.dom.DOMImplementation
  • org.w3c.dom.DOMImplementationList
  • org.w3c.dom.ls.DOMImplementationLS
  • org.w3c.dom.DOMImplementationSource
  • org.w3c.dom.DOMLocator
  • org.w3c.dom.DOMStringList
  • java.sql.Driver
  • java.security.interfaces.DSAKey
    • java.security.interfaces.DSAPrivateKey (并 extends java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (并 extends java.security.PublicKey)
  • java.security.interfaces.DSAKeyPairGenerator
  • java.security.interfaces.DSAParams
  • javax.swing.text.html.parser.DTDConstants
  • org.xml.sax.DTDHandler
    • javax.xml.transform.sax.TransformerHandler (并 extends org.xml.sax.ContentHandler, org.xml.sax.ext.LexicalHandler)
  • javax.management.DynamicMBean
    • javax.management.modelmbean.ModelMBean (并 extends javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
  • org.omg.DynamicAny.DynAnyFactoryOperations
    • org.omg.DynamicAny.DynAnyFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.DynamicAny.DynAnyOperations
    • org.omg.DynamicAny.DynAny (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynArrayOperations
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnumOperations
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixedOperations
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequenceOperations
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStructOperations
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnionOperations
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBoxOperations
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommonOperations
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBoxOperations
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynAny, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueOperations
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueOperations
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
  • java.security.spec.ECField
  • java.security.interfaces.ECKey
    • java.security.interfaces.ECPrivateKey (并 extends java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (并 extends java.security.PublicKey)
  • javax.lang.model.element.Element
    • javax.lang.model.element.ExecutableElement
    • javax.lang.model.element.PackageElement
    • javax.lang.model.element.TypeElement
    • javax.lang.model.element.TypeParameterElement
    • javax.lang.model.element.VariableElement
  • javax.swing.text.Element
  • javax.xml.bind.Element
  • javax.lang.model.util.Elements
  • javax.lang.model.element.ElementVisitor<R,P>
  • org.omg.IOP.ENCODING_CDR_ENCAPS
  • org.xml.sax.EntityResolver
    • org.xml.sax.ext.EntityResolver2
  • java.util.Enumeration<E>
    • javax.naming.NamingEnumeration<T>
  • org.xml.sax.ErrorHandler
  • javax.xml.transform.ErrorListener
  • org.w3c.dom.events.Event
    • org.w3c.dom.ls.LSLoadEvent
    • org.w3c.dom.ls.LSProgressEvent
    • org.w3c.dom.events.MouseEvent
    • org.w3c.dom.events.MutationEvent
    • org.w3c.dom.events.UIEvent
      • org.w3c.dom.events.MouseEvent
  • javax.xml.stream.EventFilter
  • java.util.EventListener
    • javax.swing.Action
    • java.awt.event.ActionListener
      • javax.swing.Action
    • java.awt.event.AdjustmentListener
    • javax.swing.event.AncestorListener
    • java.awt.event.AWTEventListener
    • java.beans.beancontext.BeanContextMembershipListener
    • java.beans.beancontext.BeanContextServiceRevokedListener
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
      • java.beans.beancontext.BeanContextServicesListener
        • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext)
    • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServicesListener
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext)
    • javax.swing.event.CaretListener
    • javax.swing.event.CellEditorListener
    • javax.swing.event.ChangeListener
    • java.awt.event.ComponentListener
    • javax.sql.ConnectionEventListener
    • java.awt.event.ContainerListener
    • javax.sound.midi.ControllerEventListener
    • javax.swing.event.DocumentListener
    • java.awt.dnd.DragGestureListener
    • java.awt.dnd.DragSourceListener
    • java.awt.dnd.DragSourceMotionListener
    • java.awt.dnd.DropTargetListener
    • java.awt.datatransfer.FlavorListener
    • java.awt.event.FocusListener
    • javax.net.ssl.HandshakeCompletedListener
    • java.awt.event.HierarchyBoundsListener
    • java.awt.event.HierarchyListener
    • javax.swing.event.HyperlinkListener
    • javax.imageio.event.IIOReadProgressListener
    • javax.imageio.event.IIOReadUpdateListener
    • javax.imageio.event.IIOReadWarningListener
    • javax.imageio.event.IIOWriteProgressListener
    • javax.imageio.event.IIOWriteWarningListener
    • java.awt.event.InputMethodListener
    • javax.swing.event.InternalFrameListener
    • java.awt.event.ItemListener
    • java.awt.event.KeyListener
    • javax.sound.sampled.LineListener
    • javax.swing.event.ListDataListener
    • javax.swing.event.ListSelectionListener
    • javax.swing.event.MenuDragMouseListener
    • javax.swing.event.MenuKeyListener
    • javax.swing.event.MenuListener
    • javax.sound.midi.MetaEventListener
    • javax.swing.event.MouseInputListener (并 extends java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.event.MouseListener
      • javax.swing.event.MouseInputListener (并 extends java.awt.event.MouseMotionListener)
    • java.awt.event.MouseMotionListener
      • javax.swing.event.MouseInputListener (并 extends java.awt.event.MouseListener)
    • java.awt.event.MouseWheelListener
    • javax.naming.event.NamespaceChangeListener
    • javax.naming.event.NamingListener
      • javax.naming.event.NamespaceChangeListener
      • javax.naming.event.ObjectChangeListener
      • javax.naming.ldap.UnsolicitedNotificationListener
    • java.util.prefs.NodeChangeListener
    • javax.management.NotificationListener
    • javax.naming.event.ObjectChangeListener
    • javax.swing.event.PopupMenuListener
    • java.util.prefs.PreferenceChangeListener
    • java.beans.PropertyChangeListener
    • javax.sql.RowSetListener
    • javax.swing.event.RowSorterListener
    • javax.net.ssl.SSLSessionBindingListener
    • javax.sql.StatementEventListener
    • javax.swing.event.TableColumnModelListener
    • javax.swing.event.TableModelListener
    • java.awt.event.TextListener
    • javax.swing.event.TreeExpansionListener
    • javax.swing.event.TreeModelListener
    • javax.swing.event.TreeSelectionListener
    • javax.swing.event.TreeWillExpandListener
    • javax.swing.event.UndoableEditListener
    • javax.naming.ldap.UnsolicitedNotificationListener
    • java.beans.VetoableChangeListener
    • java.awt.event.WindowFocusListener
    • java.awt.event.WindowListener
    • java.awt.event.WindowStateListener
  • org.w3c.dom.events.EventListener
  • org.w3c.dom.events.EventTarget
  • org.omg.IOP.ExceptionDetailMessage
  • java.beans.ExceptionListener
  • java.util.concurrent.Executor
    • java.util.concurrent.ExecutorService
      • java.util.concurrent.ScheduledExecutorService
    • java.util.concurrent.ScheduledExecutorService
  • java.io.FileFilter
  • java.io.FilenameFilter
  • java.net.FileNameMap
  • javax.tools.FileObject
    • javax.tools.JavaFileObject
  • javax.annotation.processing.Filer
  • java.util.logging.Filter
  • javax.print.FlavorException
  • java.awt.datatransfer.FlavorMap
    • java.awt.datatransfer.FlavorTable
  • java.io.Flushable
    • javax.tools.JavaFileManager (并 extends java.io.Closeable, javax.tools.OptionChecker)
      • javax.tools.StandardJavaFileManager
    • javax.tools.StandardJavaFileManager
  • java.util.Formattable
  • java.util.concurrent.Future<V>
    • javax.xml.ws.Response<T>
    • java.util.concurrent.RunnableFuture<V> (并 extends java.lang.Runnable)
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (并 extends java.util.concurrent.Delayed)
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>)
  • java.lang.reflect.GenericDeclaration
  • org.ietf.jgss.GSSContext
  • org.ietf.jgss.GSSName
  • java.security.Guard
  • javax.xml.ws.handler.Handler<C>
    • javax.xml.ws.handler.LogicalHandler<C>
    • javax.xml.ws.handler.soap.SOAPHandler<T>
  • javax.xml.ws.handler.HandlerResolver
  • javax.naming.ldap.HasControls
    • javax.naming.ldap.UnsolicitedNotification (并 extends javax.naming.ldap.ExtendedResponse)
  • javax.swing.text.Highlighter
  • javax.swing.text.Highlighter.Highlight
  • javax.swing.text.Highlighter.HighlightPainter
  • org.omg.PortableInterceptor.HOLDING
  • javax.net.ssl.HostnameVerifier
  • javax.swing.Icon
  • org.omg.PortableServer.ID_ASSIGNMENT_POLICY_ID
  • org.omg.PortableServer.ID_UNIQUENESS_POLICY_ID
  • javax.imageio.metadata.IIOMetadataController
  • javax.imageio.metadata.IIOMetadataFormat
  • javax.imageio.IIOParamController
  • java.awt.image.ImageConsumer
  • java.awt.image.ImageObserver
  • java.awt.image.ImageProducer
  • javax.imageio.ImageTranscoder
  • org.omg.PortableServer.IMPLICIT_ACTIVATION_POLICY_ID
  • org.omg.PortableInterceptor.INACTIVE
  • javax.naming.spi.InitialContextFactory
  • javax.naming.spi.InitialContextFactoryBuilder
  • java.awt.im.spi.InputMethod
  • java.awt.im.spi.InputMethodDescriptor
  • java.awt.im.InputMethodRequests
    • java.awt.im.spi.InputMethodContext
  • java.lang.instrument.Instrumentation
  • org.omg.PortableInterceptor.InterceptorOperations
    • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.ClientRequestInterceptorOperations
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.PortableInterceptor.Interceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.IORInterceptorOperations
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0Operations
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptorOperations
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
  • javax.script.Invocable
  • java.lang.reflect.InvocationHandler
  • org.omg.CORBA.portable.InvokeHandler
    • javax.rmi.CORBA.Tie
  • org.omg.PortableInterceptor.IORInfoOperations
    • org.omg.PortableInterceptor.IORInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.CORBA.IRObjectOperations
    • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IDLTypeOperations
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObject)
    • org.omg.CORBA.IRObject (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
  • java.awt.ItemSelectable
    • javax.swing.ButtonModel
  • java.lang.Iterable<T>
    • java.beans.beancontext.BeanContext (并 extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
    • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
    • java.util.concurrent.BlockingQueue<E>
      • java.util.concurrent.BlockingDeque<E> (并 extends java.util.Deque<E>)
    • java.util.Collection<E>
      • java.beans.beancontext.BeanContext (并 extends java.beans.beancontext.BeanContextChild, java.beans.DesignMode, java.beans.Visibility)
        • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
      • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
      • java.util.concurrent.BlockingQueue<E>
        • java.util.concurrent.BlockingDeque<E> (并 extends java.util.Deque<E>)
      • java.util.Deque<E>
        • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>)
      • java.util.List<E>
      • java.util.NavigableSet<E>
      • java.util.Queue<E>
        • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
        • java.util.concurrent.BlockingQueue<E>
          • java.util.concurrent.BlockingDeque<E> (并 extends java.util.Deque<E>)
        • java.util.Deque<E>
          • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>)
      • java.util.Set<E>
        • java.util.NavigableSet<E>
        • java.util.SortedSet<E>
          • java.util.NavigableSet<E>
      • java.util.SortedSet<E>
        • java.util.NavigableSet<E>
    • java.util.Deque<E>
      • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>)
    • java.util.List<E>
    • java.util.NavigableSet<E>
    • java.util.Queue<E>
      • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>, java.util.Deque<E>)
      • java.util.concurrent.BlockingQueue<E>
        • java.util.concurrent.BlockingDeque<E> (并 extends java.util.Deque<E>)
      • java.util.Deque<E>
        • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>)
    • java.util.Set<E>
      • java.util.NavigableSet<E>
      • java.util.SortedSet<E>
        • java.util.NavigableSet<E>
    • java.util.SortedSet<E>
      • java.util.NavigableSet<E>
  • java.util.Iterator<E>
    • java.util.ListIterator<E>
    • javax.xml.stream.XMLEventReader
  • javax.tools.JavaFileManager.Location
  • javax.swing.JComboBox.KeySelectionManager
  • javax.management.remote.JMXAddressable
  • javax.management.remote.JMXAuthenticator
  • javax.management.remote.JMXConnectorProvider
  • javax.management.remote.JMXConnectorServerMBean
  • javax.management.remote.JMXConnectorServerProvider
  • javax.sql.rowset.Joinable
    • javax.sql.rowset.CachedRowSet (并 extends javax.sql.RowSet)
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.FilteredRowSet
    • javax.sql.rowset.JdbcRowSet (并 extends javax.sql.RowSet)
    • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.WebRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
  • java.awt.KeyEventDispatcher
  • java.awt.KeyEventPostProcessor
  • javax.net.ssl.KeyManager
    • javax.net.ssl.X509KeyManager
  • javax.swing.text.Keymap
  • javax.xml.crypto.KeySelectorResult
  • java.security.spec.KeySpec
  • java.security.KeyStore.Entry
  • java.security.KeyStore.LoadStoreParameter
  • java.security.KeyStore.ProtectionParameter
  • java.awt.LayoutManager
    • java.awt.LayoutManager2
  • org.xml.sax.ext.LexicalHandler
    • javax.xml.transform.sax.TransformerHandler (并 extends org.xml.sax.ContentHandler, org.xml.sax.DTDHandler)
  • org.omg.PortableServer.LIFESPAN_POLICY_ID
  • javax.sound.sampled.Line
    • javax.sound.sampled.Clip
    • javax.sound.sampled.DataLine
      • javax.sound.sampled.Clip
      • javax.sound.sampled.SourceDataLine
      • javax.sound.sampled.TargetDataLine
    • javax.sound.sampled.Mixer
    • javax.sound.sampled.Port
    • javax.sound.sampled.SourceDataLine
    • javax.sound.sampled.TargetDataLine
  • javax.swing.ListCellRenderer
  • javax.swing.ListModel
    • javax.swing.ComboBoxModel
      • javax.swing.MutableComboBoxModel
    • javax.swing.MutableComboBoxModel
  • javax.swing.ListSelectionModel
  • java.rmi.server.LoaderHandler
  • javax.xml.stream.Location
  • org.omg.PortableInterceptor.LOCATION_FORWARD
  • org.xml.sax.Locator
    • org.xml.sax.ext.Locator2
  • java.util.concurrent.locks.Lock
  • java.util.logging.LoggingMXBean
  • javax.xml.ws.LogicalMessage
  • javax.security.auth.spi.LoginModule
  • org.w3c.dom.ls.LSInput
  • org.w3c.dom.ls.LSOutput
  • org.w3c.dom.ls.LSParser
  • org.w3c.dom.ls.LSParserFilter
  • org.w3c.dom.ls.LSResourceResolver
  • org.w3c.dom.ls.LSSerializer
  • javax.net.ssl.ManagerFactoryParameters
  • java.util.Map<K,V>
    • javax.script.Bindings
    • java.util.concurrent.ConcurrentMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (并 extends java.util.NavigableMap<K,V>)
    • java.util.concurrent.ConcurrentNavigableMap<K,V> (并 extends java.util.concurrent.ConcurrentMap<K,V>, java.util.NavigableMap<K,V>)
    • javax.xml.ws.handler.LogicalMessageContext
    • javax.xml.ws.handler.MessageContext
      • javax.xml.ws.handler.LogicalMessageContext
      • javax.xml.ws.handler.soap.SOAPMessageContext
    • java.util.NavigableMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (并 extends java.util.concurrent.ConcurrentMap<K,V>)
    • javax.xml.ws.handler.soap.SOAPMessageContext
    • java.util.SortedMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (并 extends java.util.concurrent.ConcurrentMap<K,V>, java.util.NavigableMap<K,V>)
      • java.util.NavigableMap<K,V>
        • java.util.concurrent.ConcurrentNavigableMap<K,V> (并 extends java.util.concurrent.ConcurrentMap<K,V>)
  • java.util.Map.Entry<K,V>
  • javax.xml.bind.Marshaller
  • java.util.regex.MatchResult
  • javax.management.MBeanRegistration
  • javax.management.MBeanServerConnection
    • javax.management.MBeanServer
      • javax.management.remote.MBeanServerForwarder
    • javax.management.remote.MBeanServerForwarder
  • javax.management.MBeanServerDelegateMBean
  • java.lang.reflect.Member
  • java.lang.management.MemoryManagerMXBean
    • java.lang.management.GarbageCollectorMXBean
  • java.lang.management.MemoryMXBean
  • java.lang.management.MemoryPoolMXBean
  • java.awt.MenuContainer
  • javax.swing.MenuElement
  • javax.annotation.processing.Messager
  • javax.sound.midi.MidiChannel
  • javax.sound.midi.MidiDevice
    • javax.sound.midi.Sequencer
    • javax.sound.midi.Synthesizer
  • javax.management.loading.MLetMBean
  • javax.management.modelmbean.ModelMBeanInfo
  • javax.management.monitor.MonitorMBean
    • javax.management.monitor.CounterMonitorMBean
    • javax.management.monitor.GaugeMonitorMBean
    • javax.management.monitor.StringMonitorMBean
  • javax.print.MultiDoc
  • java.awt.font.MultipleMaster
  • javax.xml.soap.Name
  • org.w3c.dom.NamedNodeMap
  • org.w3c.dom.NameList
  • javax.naming.NameParser
  • javax.xml.namespace.NamespaceContext
  • org.omg.CosNaming.NamingContextOperations
    • org.omg.CosNaming.NamingContext (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExtOperations
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext)
  • org.w3c.dom.Node
    • org.w3c.dom.Attr
    • org.w3c.dom.CDATASection
    • org.w3c.dom.CharacterData
      • org.w3c.dom.CDATASection
      • org.w3c.dom.Comment
      • org.w3c.dom.Text
        • org.w3c.dom.CDATASection
        • javax.xml.soap.Text (并 extends javax.xml.soap.Node)
      • javax.xml.soap.Text (并 extends javax.xml.soap.Node, org.w3c.dom.Text)
    • org.w3c.dom.Comment
    • javax.xml.soap.Detail
    • javax.xml.soap.DetailEntry
    • org.w3c.dom.Document
    • org.w3c.dom.DocumentFragment
    • org.w3c.dom.DocumentType
    • org.w3c.dom.Element
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (并 extends javax.xml.soap.Node)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • org.w3c.dom.Entity
    • org.w3c.dom.EntityReference
    • javax.xml.soap.Node
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPElement (并 extends org.w3c.dom.Element)
        • javax.xml.soap.Detail
        • javax.xml.soap.DetailEntry
        • javax.xml.soap.SOAPBody
        • javax.xml.soap.SOAPBodyElement
          • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPEnvelope
        • javax.xml.soap.SOAPFault
        • javax.xml.soap.SOAPFaultElement
          • javax.xml.soap.Detail
        • javax.xml.soap.SOAPHeader
        • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
      • javax.xml.soap.Text (并 extends org.w3c.dom.Text)
    • org.w3c.dom.Notation
    • org.w3c.dom.ProcessingInstruction
    • javax.xml.soap.SOAPBody
    • javax.xml.soap.SOAPBodyElement
      • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPElement (并 extends org.w3c.dom.Element, javax.xml.soap.Node)
      • javax.xml.soap.Detail
      • javax.xml.soap.DetailEntry
      • javax.xml.soap.SOAPBody
      • javax.xml.soap.SOAPBodyElement
        • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPEnvelope
      • javax.xml.soap.SOAPFault
      • javax.xml.soap.SOAPFaultElement
        • javax.xml.soap.Detail
      • javax.xml.soap.SOAPHeader
      • javax.xml.soap.SOAPHeaderElement
    • javax.xml.soap.SOAPEnvelope
    • javax.xml.soap.SOAPFault
    • javax.xml.soap.SOAPFaultElement
      • javax.xml.soap.Detail
    • javax.xml.soap.SOAPHeader
    • javax.xml.soap.SOAPHeaderElement
    • org.w3c.dom.Text
      • org.w3c.dom.CDATASection
      • javax.xml.soap.Text (并 extends javax.xml.soap.Node)
    • javax.xml.soap.Text (并 extends javax.xml.soap.Node, org.w3c.dom.Text)
  • org.w3c.dom.traversal.NodeFilter
    • org.w3c.dom.ls.LSSerializerFilter
  • org.w3c.dom.NodeList
  • org.omg.PortableInterceptor.NON_EXISTENT
  • javax.management.NotificationBroadcaster
    • javax.management.modelmbean.ModelMBean (并 extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
    • javax.management.modelmbean.ModelMBeanNotificationBroadcaster
      • javax.management.modelmbean.ModelMBean (并 extends javax.management.DynamicMBean, javax.management.PersistentMBean)
    • javax.management.NotificationEmitter
  • org.omg.CORBA.Object
    • org.omg.PortableServer.AdapterActivator (并 extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CosNaming.BindingIterator (并 extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.IOP.Codec (并 extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.IOP.CodecFactory (并 extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (并 extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (并 extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (并 extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (并 extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DomainManager (并 extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynAny
      • org.omg.CORBA.DynArray (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynEnum (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynFixed (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynSequence (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynStruct (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynUnion (并 extends org.omg.CORBA.Object)
      • org.omg.CORBA.DynValue (并 extends org.omg.CORBA.Object)
    • org.omg.DynamicAny.DynAny (并 extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (并 extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynArray (并 extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynEnum (并 extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynFixed (并 extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynSequence (并 extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynStruct (并 extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynUnion (并 extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.DynValue (并 extends org.omg.CORBA.DynAny)
    • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableInterceptor.Interceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations)
    • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.CORBA.IRObject (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations)
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.CosNaming.NamingContext (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations)
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.PortableInterceptor.ORBInitializer (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • org.omg.PortableServer.POA (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableInterceptor.PolicyFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • org.omg.PortableInterceptor.RequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • org.omg.SendingContext.RunTime (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.SendingContext.RunTimeOperations)
    • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
  • javax.naming.spi.ObjectFactory
    • javax.naming.spi.DirObjectFactory
  • javax.naming.spi.ObjectFactoryBuilder
  • java.io.ObjectInputValidation
  • java.io.ObjectStreamConstants
  • java.util.Observer
  • org.omg.CORBA.OMGVMCID
  • javax.management.openmbean.OpenMBeanConstructorInfo
  • javax.management.openmbean.OpenMBeanInfo
  • javax.management.openmbean.OpenMBeanOperationInfo
  • javax.management.openmbean.OpenMBeanParameterInfo
    • javax.management.openmbean.OpenMBeanAttributeInfo
  • java.awt.font.OpenType
  • java.lang.management.OperatingSystemMXBean
  • javax.tools.OptionChecker
    • javax.tools.JavaCompiler (并 extends javax.tools.Tool)
    • javax.tools.JavaFileManager (并 extends java.io.Closeable, java.io.Flushable)
      • javax.tools.StandardJavaFileManager
    • javax.tools.StandardJavaFileManager
  • org.omg.PortableInterceptor.ORBInitializerOperations
    • org.omg.PortableInterceptor.ORBInitializer (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableInterceptor.ORBInitInfoOperations
    • org.omg.PortableInterceptor.ORBInitInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.acl.Owner
    • java.security.acl.Acl
  • java.util.jar.Pack200.Packer
  • java.util.jar.Pack200.Unpacker
  • java.awt.print.Pageable
  • java.awt.PaintContext
  • org.xml.sax.Parser
  • java.awt.geom.PathIterator
  • java.security.acl.Permission
  • javax.management.PersistentMBean
    • javax.management.modelmbean.ModelMBean (并 extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster)
  • org.omg.PortableServer.POAManagerOperations
    • org.omg.PortableServer.POAManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • org.omg.PortableServer.POAOperations
    • org.omg.PortableServer.POA (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.Policy.Parameters
  • org.omg.PortableInterceptor.PolicyFactoryOperations
    • org.omg.PortableInterceptor.PolicyFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • java.security.cert.PolicyNode
  • org.omg.CORBA.PolicyOperations
    • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdAssignmentPolicyOperations
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.IdUniquenessPolicyOperations
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicyOperations
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.LifespanPolicyOperations
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.Policy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • org.omg.PortableServer.RequestProcessingPolicyOperations
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • org.omg.PortableServer.ServantRetentionPolicyOperations
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableServer.ThreadPolicyOperations
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
  • javax.sql.PooledConnection
    • javax.sql.XAConnection
  • javax.rmi.CORBA.PortableRemoteObjectDelegate
  • javax.xml.ws.handler.PortInfo
  • javax.swing.text.Position
  • javax.sql.rowset.Predicate
  • java.util.prefs.PreferencesFactory
  • java.security.Principal
    • java.security.acl.Group
  • java.awt.print.Printable
  • java.awt.print.PrinterGraphics
  • java.awt.PrintGraphics
  • javax.print.event.PrintJobAttributeListener
  • javax.print.event.PrintJobListener
  • javax.print.PrintService
    • javax.print.MultiDocPrintService
  • javax.print.event.PrintServiceAttributeListener
  • org.omg.CORBA.PRIVATE_MEMBER
  • javax.management.loading.PrivateClassLoader
  • java.security.PrivilegedAction<T>
  • java.security.PrivilegedExceptionAction<T>
  • javax.annotation.processing.ProcessingEnvironment
  • javax.annotation.processing.Processor
  • java.beans.PropertyEditor
  • javax.xml.ws.Provider<T>
  • org.omg.CORBA.PUBLIC_MEMBER
  • java.util.RandomAccess
  • java.awt.image.RasterOp
  • java.lang.Readable
  • java.util.concurrent.locks.ReadWriteLock
  • javax.sound.midi.Receiver
  • java.sql.Ref
  • javax.naming.Referenceable
  • javax.security.auth.Refreshable
  • javax.imageio.spi.RegisterableService
  • java.rmi.registry.RegistryHandler
  • java.util.concurrent.RejectedExecutionHandler
  • javax.management.relation.Relation
    • javax.management.relation.RelationSupportMBean
  • javax.management.relation.RelationServiceMBean
  • java.rmi.Remote
    • java.rmi.activation.ActivationInstantiator
    • java.rmi.activation.ActivationMonitor
    • java.rmi.activation.ActivationSystem
    • java.rmi.activation.Activator
    • java.rmi.dgc.DGC
    • java.rmi.registry.Registry
    • javax.management.remote.rmi.RMIConnection (并 extends java.io.Closeable)
    • javax.management.remote.rmi.RMIServer
  • java.rmi.server.RemoteCall
  • java.awt.image.renderable.RenderableImage
  • java.awt.image.RenderedImage
    • java.awt.image.WritableRenderedImage
  • java.awt.image.renderable.RenderedImageFactory
    • java.awt.image.renderable.ContextualRenderedImageFactory
  • javax.swing.Renderer
  • org.omg.PortableServer.REQUEST_PROCESSING_POLICY_ID
  • org.omg.PortableInterceptor.RequestInfoOperations
    • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInfoOperations
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.RequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInfoOperations
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
  • javax.naming.spi.Resolver
  • org.omg.CORBA.portable.ResponseHandler
  • javax.xml.transform.Result
  • java.rmi.server.RMIClientSocketFactory
  • org.omg.IOP.RMICustomMaxStreamFormat
  • java.rmi.server.RMIFailureHandler
  • java.rmi.server.RMIServerSocketFactory
  • javax.swing.RootPaneContainer
  • javax.annotation.processing.RoundEnvironment
  • java.sql.RowId
  • javax.swing.tree.RowMapper
  • javax.sql.RowSetInternal
  • javax.sql.RowSetReader
    • javax.sql.rowset.spi.XmlReader
  • javax.sql.RowSetWriter
    • javax.sql.rowset.spi.TransactionalWriter
    • javax.sql.rowset.spi.XmlWriter
  • java.security.interfaces.RSAKey
    • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPrivateKey (并 extends java.security.PrivateKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (并 extends java.security.PublicKey)
  • java.lang.Runnable
    • java.util.concurrent.RunnableFuture<V> (并 extends java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>, java.util.concurrent.ScheduledFuture<V>)
  • java.lang.management.RuntimeMXBean
  • org.omg.SendingContext.RunTimeOperations
    • org.omg.SendingContext.RunTime (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
  • javax.security.sasl.SaslClient
  • javax.security.sasl.SaslClientFactory
  • javax.security.sasl.SaslServer
  • javax.security.sasl.SaslServerFactory
  • java.sql.Savepoint
  • javax.script.ScriptContext
  • javax.script.ScriptEngine
  • javax.script.ScriptEngineFactory
  • javax.swing.Scrollable
  • javax.swing.ScrollPaneConstants
  • java.io.Serializable
    • org.omg.PortableServer.AdapterActivator (并 extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • javax.naming.directory.Attribute (并 extends java.lang.Cloneable)
    • javax.print.attribute.Attribute
      • javax.print.attribute.DocAttribute
      • javax.print.attribute.PrintJobAttribute
      • javax.print.attribute.PrintRequestAttribute
      • javax.print.attribute.PrintServiceAttribute
      • javax.print.attribute.SupportedValuesAttribute
    • javax.naming.directory.Attributes (并 extends java.lang.Cloneable)
    • org.omg.CosNaming.BindingIterator (并 extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo)
    • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor)
    • org.omg.IOP.Codec (并 extends org.omg.IOP.CodecOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • org.omg.IOP.CodecFactory (并 extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • javax.naming.ldap.Control
    • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.Current (并 extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.Current (并 extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableServer.Current (并 extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.PortableInterceptor.Current (并 extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.CORBA.portable.CustomValue (并 extends org.omg.CORBA.CustomMarshal, org.omg.CORBA.portable.ValueBase)
    • org.omg.CORBA.DataInputStream
    • org.omg.CORBA.DataOutputStream
    • javax.management.Descriptor (并 extends java.lang.Cloneable)
    • javax.crypto.interfaces.DHPrivateKey (并 extends javax.crypto.interfaces.DHKey, java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (并 extends javax.crypto.interfaces.DHKey, java.security.PublicKey)
    • javax.print.attribute.DocAttribute
    • org.omg.CORBA.DomainManager (并 extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • java.security.interfaces.DSAPrivateKey (并 extends java.security.interfaces.DSAKey, java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (并 extends java.security.interfaces.DSAKey, java.security.PublicKey)
    • org.omg.DynamicAny.DynAny (并 extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynAnyFactory (并 extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
    • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
    • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
    • java.security.interfaces.ECPrivateKey (并 extends java.security.interfaces.ECKey, java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (并 extends java.security.interfaces.ECKey, java.security.PublicKey)
    • javax.naming.ldap.ExtendedRequest
    • javax.naming.ldap.ExtendedResponse
      • javax.naming.ldap.UnsolicitedNotification (并 extends javax.naming.ldap.HasControls)
    • java.io.Externalizable
      • java.rmi.server.RemoteRef
        • java.rmi.server.ServerRef
      • java.rmi.server.ServerRef
    • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy)
    • org.omg.CORBA.portable.IDLEntity
      • org.omg.PortableServer.AdapterActivator (并 extends org.omg.PortableServer.AdapterActivatorOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.BindingIterator (并 extends org.omg.CosNaming.BindingIteratorOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.PortableInterceptor.RequestInfo)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.PortableInterceptor.Interceptor)
      • org.omg.IOP.Codec (并 extends org.omg.IOP.CodecOperations, org.omg.CORBA.Object)
      • org.omg.IOP.CodecFactory (并 extends org.omg.IOP.CodecFactoryOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.Current (并 extends org.omg.CORBA.CurrentOperations, org.omg.CORBA.Object)
        • org.omg.PortableServer.Current (并 extends org.omg.PortableServer.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.Current (并 extends org.omg.PortableInterceptor.CurrentOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.Current (并 extends org.omg.CORBA.Current, org.omg.PortableServer.CurrentOperations)
      • org.omg.PortableInterceptor.Current (并 extends org.omg.CORBA.Current, org.omg.PortableInterceptor.CurrentOperations)
      • org.omg.CORBA.portable.CustomValue (并 extends org.omg.CORBA.CustomMarshal, org.omg.CORBA.portable.ValueBase)
      • org.omg.CORBA.DataInputStream
      • org.omg.CORBA.DataOutputStream
      • org.omg.CORBA.DomainManager (并 extends org.omg.CORBA.DomainManagerOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynAny (并 extends org.omg.DynamicAny.DynAnyOperations, org.omg.CORBA.Object)
        • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynArrayOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynEnumOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynFixedOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynSequenceOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynStructOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynUnionOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynValueCommonOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
          • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.DynamicAny.DynAnyFactory (并 extends org.omg.DynamicAny.DynAnyFactoryOperations, org.omg.CORBA.Object)
      • org.omg.DynamicAny.DynArray (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynArrayOperations)
      • org.omg.DynamicAny.DynEnum (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynEnumOperations)
      • org.omg.DynamicAny.DynFixed (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynFixedOperations)
      • org.omg.DynamicAny.DynSequence (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynSequenceOperations)
      • org.omg.DynamicAny.DynStruct (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynStructOperations)
      • org.omg.DynamicAny.DynUnion (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynUnionOperations)
      • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueCommon, org.omg.DynamicAny.DynValueOperations)
      • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.DynamicAny.DynValueCommon)
      • org.omg.DynamicAny.DynValueCommon (并 extends org.omg.DynamicAny.DynAny, org.omg.DynamicAny.DynValueCommonOperations)
        • org.omg.DynamicAny.DynValue (并 extends org.omg.DynamicAny.DynValueOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.DynamicAny.DynValueBox (并 extends org.omg.DynamicAny.DynValueBoxOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.PortableInterceptor.Interceptor (并 extends org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
        • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
          • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
        • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.PortableInterceptor.IORInfo (并 extends org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.CORBA.IRObject (并 extends org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
        • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
      • org.omg.CosNaming.NamingContext (并 extends org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
        • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
      • org.omg.PortableInterceptor.ObjectReferenceFactory
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ORBInitializer (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
      • org.omg.PortableInterceptor.ORBInitInfo (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
      • org.omg.PortableServer.POA (并 extends org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
      • org.omg.PortableServer.POAManager (并 extends org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
      • org.omg.CORBA.Policy (并 extends org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
        • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
        • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
        • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
        • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
        • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
        • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.PortableInterceptor.PolicyFactory (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
      • org.omg.PortableInterceptor.RequestInfo (并 extends org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
        • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
        • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.SendingContext.RunTime (并 extends org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
      • org.omg.PortableServer.ServantManager (并 extends org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
        • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
        • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
      • org.omg.CORBA.portable.StreamableValue (并 extends org.omg.CORBA.portable.Streamable, org.omg.CORBA.portable.ValueBase)
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
      • org.omg.CORBA.portable.ValueBase
        • org.omg.CORBA.portable.CustomValue (并 extends org.omg.CORBA.CustomMarshal)
        • org.omg.CORBA.DataInputStream
        • org.omg.CORBA.DataOutputStream
        • org.omg.PortableInterceptor.ObjectReferenceFactory
          • org.omg.PortableInterceptor.ObjectReferenceTemplate
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
        • org.omg.CORBA.portable.StreamableValue (并 extends org.omg.CORBA.portable.Streamable)
    • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations, org.omg.CORBA.IRObject)
    • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations, org.omg.CORBA.Policy)
    • org.omg.PortableInterceptor.Interceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.InterceptorOperations, org.omg.CORBA.Object)
      • org.omg.PortableInterceptor.ClientRequestInterceptor (并 extends org.omg.PortableInterceptor.ClientRequestInterceptorOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptorOperations)
        • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
      • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.PortableInterceptor.IORInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInfoOperations, org.omg.CORBA.Object)
    • org.omg.PortableInterceptor.IORInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.IORInterceptorOperations)
      • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.PortableInterceptor.IORInterceptor_3_0 (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.IORInterceptor, org.omg.PortableInterceptor.IORInterceptor_3_0Operations)
    • org.omg.CORBA.IRObject (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IRObjectOperations, org.omg.CORBA.Object)
      • org.omg.CORBA.IDLType (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.IDLTypeOperations)
    • java.security.Key
      • javax.crypto.interfaces.DHPrivateKey (并 extends javax.crypto.interfaces.DHKey, java.security.PrivateKey)
      • javax.crypto.interfaces.DHPublicKey (并 extends javax.crypto.interfaces.DHKey, java.security.PublicKey)
      • java.security.interfaces.DSAPrivateKey (并 extends java.security.interfaces.DSAKey, java.security.PrivateKey)
      • java.security.interfaces.DSAPublicKey (并 extends java.security.interfaces.DSAKey, java.security.PublicKey)
      • java.security.interfaces.ECPrivateKey (并 extends java.security.interfaces.ECKey, java.security.PrivateKey)
      • java.security.interfaces.ECPublicKey (并 extends java.security.interfaces.ECKey, java.security.PublicKey)
      • javax.crypto.interfaces.PBEKey
      • java.security.PrivateKey
        • javax.crypto.interfaces.DHPrivateKey (并 extends javax.crypto.interfaces.DHKey)
        • java.security.interfaces.DSAPrivateKey (并 extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPrivateKey (并 extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
        • java.security.interfaces.RSAPrivateKey (并 extends java.security.interfaces.RSAKey)
          • java.security.interfaces.RSAMultiPrimePrivateCrtKey
          • java.security.interfaces.RSAPrivateCrtKey
      • java.security.PublicKey
        • javax.crypto.interfaces.DHPublicKey (并 extends javax.crypto.interfaces.DHKey)
        • java.security.interfaces.DSAPublicKey (并 extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPublicKey (并 extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAPublicKey (并 extends java.security.interfaces.RSAKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPrivateKey (并 extends java.security.PrivateKey, java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPublicKey (并 extends java.security.PublicKey, java.security.interfaces.RSAKey)
      • javax.crypto.SecretKey
        • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations, org.omg.CORBA.Policy)
    • javax.naming.Name (并 extends java.lang.Cloneable, java.lang.Comparable<T>)
    • org.omg.CosNaming.NamingContext (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextOperations, org.omg.CORBA.Object)
      • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContextExtOperations)
    • org.omg.CosNaming.NamingContextExt (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CosNaming.NamingContext, org.omg.CosNaming.NamingContextExtOperations)
    • javax.management.NotificationFilter
    • org.omg.PortableInterceptor.ObjectReferenceFactory
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
    • org.omg.PortableInterceptor.ObjectReferenceTemplate
    • org.omg.PortableInterceptor.ORBInitializer (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitializerOperations)
    • org.omg.PortableInterceptor.ORBInitInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.ORBInitInfoOperations)
    • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.POA (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.POAOperations)
    • org.omg.PortableServer.POAManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.POAManagerOperations)
    • org.omg.CORBA.Policy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.CORBA.PolicyOperations)
      • org.omg.PortableServer.IdAssignmentPolicy (并 extends org.omg.PortableServer.IdAssignmentPolicyOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableServer.IdUniquenessPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.IdUniquenessPolicyOperations)
      • org.omg.PortableServer.ImplicitActivationPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ImplicitActivationPolicyOperations)
      • org.omg.PortableServer.LifespanPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.LifespanPolicyOperations)
      • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.RequestProcessingPolicyOperations)
      • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantRetentionPolicyOperations)
      • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ThreadPolicyOperations)
    • org.omg.PortableInterceptor.PolicyFactory (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.PolicyFactoryOperations)
    • javax.print.attribute.PrintJobAttribute
    • javax.print.attribute.PrintRequestAttribute
    • javax.print.attribute.PrintServiceAttribute
    • java.security.PrivateKey
      • javax.crypto.interfaces.DHPrivateKey (并 extends javax.crypto.interfaces.DHKey)
      • java.security.interfaces.DSAPrivateKey (并 extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPrivateKey (并 extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
      • java.security.interfaces.RSAPrivateKey (并 extends java.security.interfaces.RSAKey)
        • java.security.interfaces.RSAMultiPrimePrivateCrtKey
        • java.security.interfaces.RSAPrivateCrtKey
    • java.security.PublicKey
      • javax.crypto.interfaces.DHPublicKey (并 extends javax.crypto.interfaces.DHKey)
      • java.security.interfaces.DSAPublicKey (并 extends java.security.interfaces.DSAKey)
      • java.security.interfaces.ECPublicKey (并 extends java.security.interfaces.ECKey)
      • java.security.interfaces.RSAPublicKey (并 extends java.security.interfaces.RSAKey)
    • javax.management.QueryExp
    • javax.management.relation.RelationType
    • java.rmi.server.RemoteRef
      • java.rmi.server.ServerRef
    • org.omg.PortableInterceptor.RequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableInterceptor.RequestInfoOperations)
      • org.omg.PortableInterceptor.ClientRequestInfo (并 extends org.omg.PortableInterceptor.ClientRequestInfoOperations, org.omg.CORBA.portable.IDLEntity)
      • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableServer.RequestProcessingPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.RequestProcessingPolicyOperations)
    • java.security.interfaces.RSAMultiPrimePrivateCrtKey
    • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPrivateKey (并 extends java.security.PrivateKey, java.security.interfaces.RSAKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (并 extends java.security.PublicKey, java.security.interfaces.RSAKey)
    • org.omg.SendingContext.RunTime (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.SendingContext.RunTimeOperations)
    • javax.crypto.SecretKey
      • javax.crypto.interfaces.PBEKey
    • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object, org.omg.PortableServer.ServantManagerOperations)
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
    • org.omg.PortableServer.ServantRetentionPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ServantRetentionPolicyOperations)
    • java.rmi.server.ServerRef
    • org.omg.PortableInterceptor.ServerRequestInfo (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.RequestInfo, org.omg.PortableInterceptor.ServerRequestInfoOperations)
    • org.omg.PortableInterceptor.ServerRequestInterceptor (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableInterceptor.Interceptor, org.omg.PortableInterceptor.ServerRequestInterceptorOperations)
    • org.omg.CORBA.portable.StreamableValue (并 extends org.omg.CORBA.portable.Streamable, org.omg.CORBA.portable.ValueBase)
    • javax.print.attribute.SupportedValuesAttribute
    • org.omg.PortableServer.ThreadPolicy (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Policy, org.omg.PortableServer.ThreadPolicyOperations)
    • javax.naming.ldap.UnsolicitedNotification (并 extends javax.naming.ldap.ExtendedResponse, javax.naming.ldap.HasControls)
    • org.omg.CORBA.portable.ValueBase
      • org.omg.CORBA.portable.CustomValue (并 extends org.omg.CORBA.CustomMarshal)
      • org.omg.CORBA.DataInputStream
      • org.omg.CORBA.DataOutputStream
      • org.omg.PortableInterceptor.ObjectReferenceFactory
        • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.PortableInterceptor.ObjectReferenceTemplate
      • org.omg.CORBA.portable.StreamableValue (并 extends org.omg.CORBA.portable.Streamable)
    • javax.management.ValueExp
  • org.omg.PortableServer.SERVANT_RETENTION_POLICY_ID
  • org.omg.PortableServer.ServantManagerOperations
    • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantActivatorOperations
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantLocatorOperations
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantManager)
    • org.omg.PortableServer.ServantManager (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.CORBA.Object)
      • org.omg.PortableServer.ServantActivator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantActivatorOperations)
      • org.omg.PortableServer.ServantLocator (并 extends org.omg.CORBA.portable.IDLEntity, org.omg.PortableServer.ServantLocatorOperations)
  • javax.imageio.spi.ServiceRegistry.Filter
  • java.awt.Shape
  • javax.swing.SingleSelectionModel
  • java.rmi.server.Skeleton
  • javax.xml.soap.SOAPConstants
  • java.net.SocketImplFactory
  • java.net.SocketOptions
  • javax.sound.midi.Soundbank
  • javax.xml.transform.Source
  • javax.xml.transform.SourceLocator
    • javax.xml.transform.dom.DOMLocator
  • javax.swing.SpinnerModel
  • java.sql.SQLData
  • java.sql.SQLInput
  • java.sql.SQLOutput
  • java.sql.SQLXML
  • javax.net.ssl.SSLSession
  • javax.net.ssl.SSLSessionContext
  • javax.swing.undo.StateEditable
  • javax.naming.spi.StateFactory
    • javax.naming.spi.DirStateFactory
  • org.omg.CORBA.portable.Streamable
    • org.omg.CORBA.portable.StreamableValue (并 extends org.omg.CORBA.portable.ValueBase)
  • javax.xml.stream.StreamFilter
  • java.awt.Stroke
  • java.sql.Struct
  • javax.rmi.CORBA.StubDelegate
  • org.omg.PortableInterceptor.SUCCESSFUL
  • javax.swing.SwingConstants
  • org.omg.Messaging.SYNC_WITH_TRANSPORT
  • javax.swing.plaf.synth.SynthConstants
  • org.omg.PortableInterceptor.SYSTEM_EXCEPTION
  • javax.swing.text.TabableView
  • javax.swing.text.TabExpander
  • javax.swing.table.TableCellRenderer
  • javax.swing.table.TableColumnModel
  • javax.swing.table.TableModel
  • javax.management.openmbean.TabularData
  • org.omg.IOP.TAG_ALTERNATE_IIOP_ADDRESS
  • org.omg.IOP.TAG_CODE_SETS
  • org.omg.IOP.TAG_INTERNET_IOP
  • org.omg.IOP.TAG_JAVA_CODEBASE
  • org.omg.IOP.TAG_MULTIPLE_COMPONENTS
  • org.omg.IOP.TAG_ORB_TYPE
  • org.omg.IOP.TAG_POLICIES
  • org.omg.IOP.TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
  • javax.xml.transform.Templates
  • org.omg.PortableServer.THREAD_POLICY_ID
  • java.lang.Thread.UncaughtExceptionHandler
  • java.util.concurrent.ThreadFactory
  • java.lang.management.ThreadMXBean
  • java.awt.image.TileObserver
  • javax.management.timer.TimerMBean
  • javax.tools.Tool
    • javax.tools.JavaCompiler (并 extends javax.tools.OptionChecker)
  • org.omg.IOP.TransactionService
  • java.awt.datatransfer.Transferable
  • javax.sound.midi.Transmitter
  • java.awt.Transparency
    • java.awt.Paint
  • org.omg.PortableInterceptor.TRANSPORT_RETRY
  • javax.swing.tree.TreeCellRenderer
  • javax.swing.tree.TreeModel
  • javax.swing.tree.TreeNode
    • javax.swing.tree.MutableTreeNode
  • javax.swing.tree.TreeSelectionModel
  • javax.net.ssl.TrustManager
    • javax.net.ssl.X509TrustManager
  • java.lang.reflect.Type
    • java.lang.reflect.GenericArrayType
    • java.lang.reflect.ParameterizedType
    • java.lang.reflect.TypeVariable<D>
    • java.lang.reflect.WildcardType
  • org.w3c.dom.TypeInfo
  • javax.lang.model.type.TypeMirror
    • javax.lang.model.type.ArrayType
    • javax.lang.model.type.DeclaredType
      • javax.lang.model.type.ErrorType
    • javax.lang.model.type.ErrorType
    • javax.lang.model.type.ExecutableType
    • javax.lang.model.type.NoType
    • javax.lang.model.type.NullType
    • javax.lang.model.type.PrimitiveType
    • javax.lang.model.type.ReferenceType
      • javax.lang.model.type.ArrayType
      • javax.lang.model.type.DeclaredType
        • javax.lang.model.type.ErrorType
      • javax.lang.model.type.ErrorType
      • javax.lang.model.type.NullType
      • javax.lang.model.type.TypeVariable
    • javax.lang.model.type.TypeVariable
    • javax.lang.model.type.WildcardType
  • javax.lang.model.util.Types
  • javax.lang.model.type.TypeVisitor<R,P>
  • javax.swing.UIDefaults.ActiveValue
  • javax.swing.UIDefaults.LazyValue
  • javax.swing.plaf.UIResource
  • javax.swing.undo.UndoableEdit
  • org.omg.PortableInterceptor.UNKNOWN
  • javax.xml.bind.Unmarshaller
  • java.rmi.server.Unreferenced
  • org.omg.CORBA.UNSUPPORTED_POLICY
  • org.omg.CORBA.UNSUPPORTED_POLICY_VALUE
  • javax.xml.crypto.URIDereferencer
  • javax.print.URIException
  • javax.xml.crypto.URIReference
    • javax.xml.crypto.dom.DOMURIReference
    • javax.xml.crypto.dsig.Reference (并 extends javax.xml.crypto.XMLStructure)
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (并 extends javax.xml.crypto.XMLStructure)
  • javax.xml.transform.URIResolver
  • java.net.URLStreamHandlerFactory
  • org.omg.PortableInterceptor.USER_EXCEPTION
  • org.w3c.dom.UserDataHandler
  • javax.rmi.CORBA.UtilDelegate
  • javax.xml.bind.ValidationEvent
    • javax.xml.bind.NotIdentifiableEvent
    • javax.xml.bind.ParseConversionEvent
    • javax.xml.bind.PrintConversionEvent
  • javax.xml.bind.ValidationEventHandler
  • javax.xml.bind.ValidationEventLocator
  • javax.xml.bind.Validator
  • org.omg.CORBA.portable.ValueFactory
  • javax.rmi.CORBA.ValueHandler
    • javax.rmi.CORBA.ValueHandlerMultiFormat
  • org.omg.CORBA.portable.ValueInputStream
  • org.omg.CORBA.portable.ValueOutputStream
  • javax.swing.text.ViewFactory
  • java.beans.Visibility
    • java.beans.beancontext.BeanContext (并 extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
    • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext, java.beans.beancontext.BeanContextServicesListener)
  • org.omg.CORBA.VM_ABSTRACT
  • org.omg.CORBA.VM_CUSTOM
  • org.omg.CORBA.VM_NONE
  • org.omg.CORBA.VM_TRUNCATABLE
  • javax.xml.ws.WebServiceContext
  • javax.swing.WindowConstants
  • java.sql.Wrapper
    • javax.sql.rowset.CachedRowSet (并 extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.sql.CallableStatement
    • java.sql.Connection
    • java.sql.DatabaseMetaData
    • javax.sql.DataSource (并 extends javax.sql.CommonDataSource)
    • javax.sql.rowset.FilteredRowSet
    • javax.sql.rowset.JdbcRowSet (并 extends javax.sql.rowset.Joinable, javax.sql.RowSet)
    • javax.sql.rowset.JoinRowSet
    • java.sql.ParameterMetaData
    • java.sql.PreparedStatement
      • java.sql.CallableStatement
    • java.sql.ResultSet
      • javax.sql.rowset.CachedRowSet (并 extends javax.sql.rowset.Joinable, javax.sql.RowSet)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (并 extends javax.sql.rowset.Joinable, javax.sql.RowSet)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.RowSet
        • javax.sql.rowset.CachedRowSet (并 extends javax.sql.rowset.Joinable)
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
          • javax.sql.rowset.WebRowSet
            • javax.sql.rowset.FilteredRowSet
            • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JdbcRowSet (并 extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.spi.SyncResolver
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • java.sql.ResultSetMetaData
      • javax.sql.RowSetMetaData
    • javax.sql.RowSet
      • javax.sql.rowset.CachedRowSet (并 extends javax.sql.rowset.Joinable)
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.WebRowSet
          • javax.sql.rowset.FilteredRowSet
          • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JdbcRowSet (并 extends javax.sql.rowset.Joinable)
      • javax.sql.rowset.JoinRowSet
      • javax.sql.rowset.spi.SyncResolver
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.RowSetMetaData
    • java.sql.Statement
      • java.sql.CallableStatement
      • java.sql.PreparedStatement
        • java.sql.CallableStatement
    • javax.sql.rowset.spi.SyncResolver
    • javax.sql.rowset.WebRowSet
      • javax.sql.rowset.FilteredRowSet
      • javax.sql.rowset.JoinRowSet
  • java.security.cert.X509Extension
  • javax.transaction.xa.XAResource
  • javax.transaction.xa.Xid
  • javax.xml.crypto.XMLCryptoContext
    • javax.xml.crypto.dsig.XMLSignContext
    • javax.xml.crypto.dsig.XMLValidateContext
  • javax.xml.stream.util.XMLEventAllocator
  • javax.xml.stream.util.XMLEventConsumer
    • javax.xml.stream.XMLEventWriter
  • org.xml.sax.XMLReader
    • org.xml.sax.XMLFilter
  • javax.xml.stream.XMLReporter
  • javax.xml.stream.XMLResolver
  • javax.xml.stream.XMLStreamConstants
    • javax.xml.stream.events.Attribute
      • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.Characters
    • javax.xml.stream.events.Comment
    • javax.xml.stream.events.DTD
    • javax.xml.stream.events.EndDocument
    • javax.xml.stream.events.EndElement
    • javax.xml.stream.events.EntityDeclaration
    • javax.xml.stream.events.EntityReference
    • javax.xml.stream.events.Namespace
    • javax.xml.stream.events.NotationDeclaration
    • javax.xml.stream.events.ProcessingInstruction
    • javax.xml.stream.events.StartDocument
    • javax.xml.stream.events.StartElement
    • javax.xml.stream.events.XMLEvent
      • javax.xml.stream.events.Attribute
        • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.Characters
      • javax.xml.stream.events.Comment
      • javax.xml.stream.events.DTD
      • javax.xml.stream.events.EndDocument
      • javax.xml.stream.events.EndElement
      • javax.xml.stream.events.EntityDeclaration
      • javax.xml.stream.events.EntityReference
      • javax.xml.stream.events.Namespace
      • javax.xml.stream.events.NotationDeclaration
      • javax.xml.stream.events.ProcessingInstruction
      • javax.xml.stream.events.StartDocument
      • javax.xml.stream.events.StartElement
    • javax.xml.stream.XMLStreamReader
  • javax.xml.stream.XMLStreamWriter
  • javax.xml.crypto.XMLStructure
    • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.DigestMethod (并 extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.keyinfo.KeyInfo
    • javax.xml.crypto.dsig.keyinfo.KeyName
    • javax.xml.crypto.dsig.keyinfo.KeyValue
    • javax.xml.crypto.dsig.Manifest
    • javax.xml.crypto.dsig.keyinfo.PGPData
    • javax.xml.crypto.dsig.Reference (并 extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.keyinfo.RetrievalMethod (并 extends javax.xml.crypto.URIReference)
    • javax.xml.crypto.dsig.SignatureMethod (并 extends javax.xml.crypto.AlgorithmMethod)
    • javax.xml.crypto.dsig.SignatureProperties
    • javax.xml.crypto.dsig.SignatureProperty
    • javax.xml.crypto.dsig.SignedInfo
    • javax.xml.crypto.dsig.Transform (并 extends javax.xml.crypto.AlgorithmMethod)
      • javax.xml.crypto.dsig.CanonicalizationMethod
    • javax.xml.crypto.dsig.keyinfo.X509Data
    • javax.xml.crypto.dsig.keyinfo.X509IssuerSerial
    • javax.xml.crypto.dsig.XMLObject
    • javax.xml.crypto.dsig.XMLSignature
    • javax.xml.crypto.dsig.XMLSignature.SignatureValue
  • javax.xml.xpath.XPath
  • javax.xml.xpath.XPathExpression
  • javax.xml.xpath.XPathFunction
  • javax.xml.xpath.XPathFunctionResolver
  • javax.xml.xpath.XPathVariableResolver

注释类型分层结构

  • java.beans.ConstructorProperties (implements java.lang.annotation.Annotation)
  • java.lang.Deprecated (implements java.lang.annotation.Annotation)
  • java.lang.Override (implements java.lang.annotation.Annotation)
  • java.lang.SuppressWarnings (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Documented (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Inherited (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Retention (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Target (implements java.lang.annotation.Annotation)
  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedAnnotationTypes (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedOptions (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedSourceVersion (implements java.lang.annotation.Annotation)
  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)
  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)
  • javax.management.DescriptorKey (implements java.lang.annotation.Annotation)
  • javax.management.MXBean (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorOrder (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAccessorType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAnyElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttachmentRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlAttribute (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementDecl (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRef (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementRefs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElementWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlElements (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnum (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlEnumValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlID (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlIDREF (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlInlineBinaryData (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlList (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMimeType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlMixed (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlNs (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRegistry (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlRootElement (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchema (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlSchemaTypes (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlTransient (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlType (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.XmlValue (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapter (implements java.lang.annotation.Annotation)
  • javax.xml.bind.annotation.adapters.XmlJavaTypeAdapters (implements java.lang.annotation.Annotation)
  • javax.xml.ws.BindingType (implements java.lang.annotation.Annotation)
  • javax.xml.ws.RequestWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ResponseWrapper (implements java.lang.annotation.Annotation)
  • javax.xml.ws.ServiceMode (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebEndpoint (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebFault (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceClient (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceProvider (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRef (implements java.lang.annotation.Annotation)
  • javax.xml.ws.WebServiceRefs (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.Desktop.Action
      • java.awt.MultipleGradientPaint.CycleMethod
      • java.awt.MultipleGradientPaint.ColorSpaceType
      • java.awt.TrayIcon.MessageType
      • java.awt.Dialog.ModalityType
      • java.awt.Dialog.ModalExclusionType
      • java.awt.Component.BaselineResizeBehavior
      • java.lang.Thread.State
      • java.lang.annotation.ElementType
      • java.lang.annotation.RetentionPolicy
      • java.lang.management.MemoryType
      • java.math.RoundingMode
      • java.net.Proxy.Type
      • java.net.Authenticator.RequestorType
      • java.security.KeyRep.Type
      • java.sql.ClientInfoStatus
      • java.sql.RowIdLifetime
      • java.text.Normalizer.Form
      • java.util.Formatter.BigDecimalLayoutForm
      • java.util.concurrent.TimeUnit
      • javax.annotation.Resource.AuthenticationType
      • javax.jws.WebParam.Mode
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
      • javax.lang.model.SourceVersion
      • javax.lang.model.element.ElementKind
      • javax.lang.model.element.Modifier
      • javax.lang.model.element.NestingKind
      • javax.lang.model.type.TypeKind
      • javax.net.ssl.SSLEngineResult.Status
      • javax.net.ssl.SSLEngineResult.HandshakeStatus
      • javax.swing.GroupLayout.Alignment
      • javax.swing.LayoutStyle.ComponentPlacement
      • javax.swing.RowFilter.ComparisonType
      • javax.swing.SortOrder
      • javax.swing.SwingWorker.StateValue
      • javax.swing.JTable.PrintMode
      • javax.swing.DropMode
      • javax.swing.event.RowSorterEvent.Type
      • javax.swing.text.html.FormSubmitEvent.MethodType
      • javax.tools.StandardLocation (implements javax.tools.JavaFileManager.Location)
      • javax.tools.Diagnostic.Kind
      • javax.tools.JavaFileObject.Kind
      • javax.xml.bind.annotation.XmlAccessOrder
      • javax.xml.bind.annotation.XmlAccessType
      • javax.xml.bind.annotation.XmlNsForm
      • javax.xml.ws.Service.Mode
      • javax.xml.ws.handler.MessageContext.Scope
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


已过时项目列表 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

已过时的 API

目录
  • 已过时的接口
  • 已过时的类
  • 已过时的异常
  • 已过时的注释类型
  • 已过时的字段
  • 已过时的方法
  • 已过时的构造方法
  • 已过时的注释类型元素
已过时的接口
org.xml.sax.AttributeList
此接口已经被 SAX2 Attributes 接口取代，后者包括名称空间支持。
java.security.Certificate
在 Java 平台中创建了新的证书处理包。此 Certificate 接口已完全废弃，其仍存在是为了能平稳地过渡到新包。
org.xml.sax.DocumentHandler
此接口已经被 SAX2 ContentHandler 接口取代，后者包括名称空间支持。
org.omg.CORBA.DynAny
使用新的 DynAny 替代
org.omg.CORBA.DynArray
使用新的 DynArray 替代
org.omg.CORBA.DynEnum
使用新的 DynEnum 替代
org.omg.CORBA.DynFixed
使用新的 DynFixed 替代
org.omg.CORBA.DynSequence
使用新的 DynSequence 替代
org.omg.CORBA.DynStruct
使用新的 DynStruct 替代
org.omg.CORBA.DynUnion
使用新的 DynUnion 替代
org.omg.CORBA.DynValue
使用新的 DynValue 替代
java.rmi.server.LoaderHandler
无替代版本
org.xml.sax.Parser
此接口已经被 SAX2 XMLReader 接口取代，后者包括名称空间支持。
java.rmi.registry.RegistryHandler
无替代版本
java.rmi.server.RemoteCall
无替代版本。
java.rmi.server.Skeleton
无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
javax.xml.bind.Validator
从 JAXB 2.0 开始

已过时的类
javax.accessibility.AccessibleResourceBundle
从 Java Platform 的 1.3 版开始，此类已废弃。
org.xml.sax.helpers.AttributeListImpl
此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。
javax.management.DefaultLoaderRepository
使用 MBeanServer.getClassLoaderRepository() 取代。
javax.management.loading.DefaultLoaderRepository
使用 MBeanServer.getClassLoaderRepository()} 替代。
javax.swing.text.DefaultTextUI
org.omg.CORBA.DynamicImplementation
org.omg.CORBA.DynamicImplementation
org.xml.sax.HandlerBase
此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。
java.security.Identity
不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
java.security.IdentityScope
此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
java.io.LineNumberInputStream
此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
java.rmi.server.LogStream
无替代版本
javax.swing.plaf.metal.MetalComboBoxUI.MetalComboPopup
从 Java 2 platform v1.4 开始。
java.rmi.server.Operation
无替代版本
org.xml.sax.helpers.ParserFactory
此类与不推荐使用的 Parser 接口一起使用。
javax.security.auth.Policy
从 JDK 1.4 版本开始，由 java.security.Policy 取代。java.security.Policy 有一个方法：
        public PermissionCollection getPermissions
            (java.security.ProtectionDomain pd)
ProtectionDomain 有一个构造方法：
        public ProtectionDomain
            (CodeSource cs,
             PermissionCollection permissions,
             ClassLoader loader,
             Principal[] principals)
这两个 API 为调用者提供向 Policy 查询基于 Principal 的 Permission 条目的方法。
org.omg.CORBA.Principal
已由 CORBA 2.2 取代。
org.omg.CORBA.PrincipalHolder
Deprecated by CORBA 2.2.
java.security.Signer
将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。
javax.xml.soap.SOAPElementFactory
- 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。
java.io.StringBufferInputStream
此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。
javax.swing.text.TableView.TableCell
表单元格如今可以是任何 View 实现。

已过时的异常
java.rmi.RMISecurityException
由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
java.rmi.ServerRuntimeException
无替换版本
java.rmi.server.SkeletonMismatchException
无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
java.rmi.server.SkeletonNotFoundException
无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

已过时的注释类型
javax.jws.soap.InitParam
从 JSR-181 2.0 开始，无替代版本。
javax.jws.soap.SOAPMessageHandler
从 JSR-181 2.0 开始，无替代版本。
javax.jws.soap.SOAPMessageHandlers
从 JSR-181 2.0 开始，无替代版本。

已过时的字段
javax.management.openmbean.OpenType.ALLOWED_CLASSNAMES
使用 ALLOWED_CLASSNAMES_LIST 取代。
javax.management.monitor.Monitor.alreadyNotified
等效于 Monitor.alreadyNotifieds[0]。
javax.swing.JViewport.backingStore
从 Java 2 平台 v1.3 开始
javax.swing.plaf.basic.BasicDesktopPaneUI.closeKey
从 1.3 开始。
java.awt.Frame.CROSSHAIR_CURSOR
由 Cursor.CROSSHAIR_CURSOR 取代。
javax.management.monitor.Monitor.dbgTag
无替代版本。
java.awt.Frame.DEFAULT_CURSOR
由 Cursor.DEFAULT_CURSOR 取代。
javax.swing.JRootPane.defaultPressAction
从 Java 2 platform v1.3 开始
javax.swing.JRootPane.defaultReleaseAction
从 Java 2 platform v1.3 开始
javax.swing.plaf.basic.BasicSplitPaneUI.dividerResizeToggleKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.downKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicTabbedPaneUI.downKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicToolBarUI.downKey
从 Java 2 平台 v1.3 开始。
java.awt.Frame.E_RESIZE_CURSOR
由 Cursor.E_RESIZE_CURSOR 取代。
javax.swing.plaf.basic.BasicSplitPaneUI.endKey
从 Java 2 platform v1.3 开始。
java.util.logging.Logger.global
此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。
java.awt.Frame.HAND_CURSOR
由 Cursor.HAND_CURSOR 取代。
javax.swing.plaf.basic.BasicSplitPaneUI.homeKey
从 Java 2 platform v1.3 开始。
java.net.HttpURLConnection.HTTP_SERVER_ERROR
放错了位置，它不应该存在。
java.lang.SecurityManager.inCheck
建议不使用该类型的安全检查。建议使用 checkPermission 调用。
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardDownRightListener
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardEndListener
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardHomeListener
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardResizeToggleListener
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.keyboardUpLeftListener
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.leftKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicTabbedPaneUI.leftKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicToolBarUI.leftKey
从 Java 2 平台 v1.3 开始。
javax.swing.plaf.basic.BasicDesktopPaneUI.maximizeKey
从 1.3 开始。
javax.swing.plaf.basic.BasicDesktopPaneUI.minimizeKey
从 1.3 开始。
java.awt.Frame.MOVE_CURSOR
由 Cursor.MOVE_CURSOR 取代。
java.awt.Frame.N_RESIZE_CURSOR
由 Cursor.N_RESIZE_CURSOR 取代。
javax.swing.plaf.basic.BasicDesktopPaneUI.navigateKey
从 1.3 开始。
javax.swing.plaf.basic.BasicDesktopPaneUI.navigateKey2
从 1.3 开始。
java.awt.Frame.NE_RESIZE_CURSOR
由 Cursor.NE_RESIZE_CURSOR 取代。
java.awt.Frame.NW_RESIZE_CURSOR
由 Cursor.NW_RESIZE_CURSOR 取代。
javax.swing.plaf.basic.BasicInternalFrameUI.openMenuKey
从 Java 2 platform v1.3 开始。
java.awt.datatransfer.DataFlavor.plainTextFlavor
从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。
javax.swing.text.html.FormView.RESET
从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值
javax.swing.table.TableColumn.resizedPostingDisableCount
从 Java 2 platform v1.3 开始
javax.swing.plaf.basic.BasicSplitPaneUI.rightKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicTabbedPaneUI.rightKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicToolBarUI.rightKey
从 Java 2 平台 v1.3 开始。
java.awt.Frame.S_RESIZE_CURSOR
由 Cursor.S_RESIZE_CURSOR 取代。
java.awt.Frame.SE_RESIZE_CURSOR
由 Cursor.SE_RESIZE_CURSOR 取代。
javax.swing.text.html.FormView.SUBMIT
从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值
java.lang.Character.UnicodeBlock.SURROGATES_AREA
从 J2SE 5 开始，使用 Character.UnicodeBlock.HIGH_SURROGATES、Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES 和 Character.UnicodeBlock.LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。Character.UnicodeBlock.of(char) 和 Character.UnicodeBlock.of(int) 方法返回新常量，而不是 SURROGATES_AREA。
java.awt.Frame.SW_RESIZE_CURSOR
由 Cursor.SW_RESIZE_CURSOR 取代。
java.awt.Frame.TEXT_CURSOR
由 Cursor.TEXT_CURSOR 取代。
javax.swing.plaf.basic.BasicSplitPaneUI.upKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicTabbedPaneUI.upKey
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicToolBarUI.upKey
从 Java 2 平台 v1.3 开始。
java.awt.Frame.W_RESIZE_CURSOR
由 Cursor.W_RESIZE_CURSOR 取代。
java.awt.Frame.WAIT_CURSOR
由 Cursor.WAIT_CURSOR 取代。

已过时的方法
java.awt.Component.action(Event, Object)
从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
java.awt.List.addItem(String)
由 add(String) 取代。
java.awt.List.addItem(String, int)
由 add(String, int) 取代。
java.awt.CardLayout.addLayoutComponent(String, Component)
由 addLayoutComponent(Component, Object) 取代。
java.awt.BorderLayout.addLayoutComponent(String, Component)
由 addLayoutComponent(Component, Object) 取代。
java.awt.List.allowsMultipleSelections()
从 JDK version 1.1 开始，由 isMultipleMode() 取代。
java.lang.ThreadGroup.allowThreadSuspension(boolean)
此调用的定义取决于 ThreadGroup.suspend()，它被废弃了。更进一步地说，此调用的行为从不被指定。
java.awt.TextArea.appendText(String)
从 JDK version 1.1 开始，由 append(String) 取代。
java.awt.Window.applyResourceBundle(ResourceBundle)
从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
java.awt.Window.applyResourceBundle(String)
从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
java.awt.Component.bounds()
从 JDK version 1.1 开始，由 getBounds() 取代。
java.lang.SecurityManager.checkMulticast(InetAddress, byte)
由 #checkPermission(java.security.Permission) 取代
java.lang.SecurityManager.classDepth(String)
建议不使用该类安全检查。建议使用 checkPermission 调用。
java.lang.SecurityManager.classLoaderDepth()
建议不使用该类安全检查。建议使用 checkPermission 调用。
java.awt.List.clear()
从 JDK version 1.1 开始，由 removeAll() 取代。
java.awt.image.renderable.RenderContext.concetenateTransform(AffineTransform)
由 concatenateTransform(AffineTransform) 所替代。
java.awt.Container.countComponents()
从 JDK version 1.1 开始，用 etComponentCount() 取代。
java.awt.Choice.countItems()
从 JDK version 1.1 开始，由 getItemCount() 取代。
java.awt.List.countItems()
从 JDK version 1.1 开始，由 getItemCount() 取代。
java.awt.Menu.countItems()
从 JDK version 1.1 开始，已由 getItemCount() 取代。
java.awt.MenuBar.countMenus()
从 JDK version 1.1 开始，由 getMenuCount() 取代。
java.lang.Thread.countStackFrames()
该调用的定义依赖于 Thread.suspend()，但它遭到了反对。此外，该调用的结果从来都不是意义明确的。
org.omg.CORBA.ORB.create_basic_dyn_any(TypeCode)
使用新的 DynAnyFactory API 代替
org.omg.CORBA.ORB.create_dyn_any(Any)
使用新的 DynAnyFactory API 代替
org.omg.CORBA.ORB.create_dyn_array(TypeCode)
使用新的 DynAnyFactory API 代替
org.omg.CORBA.ORB.create_dyn_enum(TypeCode)
使用新的 DynAnyFactory API 代替
org.omg.CORBA.ORB.create_dyn_sequence(TypeCode)
使用新的 DynAnyFactory API 代替
org.omg.CORBA.ORB.create_dyn_struct(TypeCode)
使用新的 DynAnyFactory API 代替
org.omg.CORBA.ORB.create_dyn_union(TypeCode)
使用新的 DynAnyFactory API 代替
org.omg.CORBA.ORB.create_recursive_sequence_tc(int, int)
使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
javax.xml.soap.SOAPElementFactory.create(Name)
使用 javax.xml.soap.SOAPFactory.createElement(javax.xml.soap.Name) 替换
javax.xml.soap.SOAPElementFactory.create(String)
使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换
javax.xml.soap.SOAPElementFactory.create(String, String, String)
使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardDownRightListener()
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardEndListener()
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardHomeListener()
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardResizeToggleListener()
从 Java 2 platform v1.3 开始。
javax.swing.plaf.basic.BasicSplitPaneUI.createKeyboardUpLeftListener()
从 Java 2 platform v1.3 开始。
javax.swing.JTable.createScrollPaneForTable(JTable)
从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
javax.swing.text.TableView.createTableCell(Element)
现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
javax.xml.bind.JAXBContext.createValidator()
从 JAXB 2.0 开始
java.lang.SecurityManager.currentClassLoader()
建议不使用该类安全检查。建议使用 checkPermission 调用。
java.lang.SecurityManager.currentLoadedClass()
建议不使用该类安全检查。建议使用 checkPermission 调用。
java.net.URLDecoder.decode(String)
结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。
java.lang.ClassLoader.defineClass(byte[], int, int)
由 defineClass(String, byte[], int, int) 取代
java.awt.List.delItem(int)
由 remove(String) 和 remove(int) 取代。
java.awt.List.delItems(int, int)
从 JDK version 1.1 开始，后来不再公开使用。只希望作为包私有方法时保留此方法。
java.awt.Container.deliverEvent(Event)
从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
java.awt.Component.deliverEvent(Event)
从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
javax.management.MBeanServer.deserialize(ObjectName, byte[])
使用 getClassLoaderFor 为反序列化获得合适的类加载器。
javax.management.MBeanServer.deserialize(String, byte[])
使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
javax.management.MBeanServer.deserialize(String, ObjectName, byte[])
使用 getClassLoader 为反序列化获得类加载器。
java.lang.Thread.destroy()
该方法最初用于破坏该线程，但不作任何清除。它所保持的任何监视器都会保持锁定状态。不过，该方法决不会被实现。即使要实现，它也极有可能以 Thread.suspend() 方式被死锁。如果目标线程被破坏时保持一个保护关键系统资源的锁，则任何线程在任何时候都无法再次访问该资源。如果另一个线程曾试图锁定该资源，则会出现死锁。这类死锁通常会证明它们自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
java.awt.MenuItem.disable()
从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
java.awt.Component.disable()
从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
javax.swing.JComponent.disable()
从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
javax.swing.table.TableColumn.disableResizedPosting()
从 Java 2 platform v1.3 开始
javax.swing.FocusManager.disableSwingFocusManager()
从 1.4 开始，由 KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy) 取代
java.rmi.server.Skeleton.dispatch(Remote, RemoteCall, int, long)
无替代版本
java.rmi.server.RemoteCall.done()
无替代版本
java.rmi.server.RemoteRef.done(RemoteCall)
1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
javax.swing.plaf.metal.MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent)
从 Java 2 platform v1.4 开始。
java.awt.MenuItem.enable()
从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
java.awt.Component.enable()
从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
javax.swing.JComponent.enable()
从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
java.awt.MenuItem.enable(boolean)
从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
java.awt.Component.enable(boolean)
从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
javax.swing.table.TableColumn.enableResizedPosting()
从 Java 2 platform v1.3 开始
java.net.URLEncoder.encode(String)
结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。
java.security.SignatureSpi.engineGetParameter(String)
java.security.SignatureSpi.engineSetParameter(String, Object)
由 engineSetParameter 取代。
java.awt.datatransfer.DataFlavor.equals(String)
与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。
org.omg.CORBA.ServerRequest.except(Any)
使用 set_exception()
java.rmi.server.RemoteCall.executeCall()
无替代版本
org.omg.CORBA.Any.extract_Principal()
由 CORBA 2.2 取代。
javax.swing.SwingUtilities.findFocusOwner(Component)
从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
org.omg.CORBA.ORB.get_current()
使用 resolve_initial_references。
java.security.Security.getAlgorithmProperty(String, String)
此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。
java.sql.CallableStatement.getBigDecimal(int, int)
使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
java.sql.ResultSet.getBigDecimal(int, int)
java.sql.ResultSet.getBigDecimal(String, int)
java.awt.Polygon.getBoundingBox()
从 JDK version 1.1 开始，由 getBounds() 取代。
java.lang.String.getBytes(int, int, byte[], int)
该方法无法将字符正确转换为字节。从 JDK 1.1 起，完成该转换的首选方法是通过 String.getBytes() 方法，该方法使用平台的默认字符集。
java.awt.Graphics.getClipRect()
从 JDK version 1.1 开始，由 getClipBounds() 取代。
javax.swing.JPopupMenu.getComponentAtIndex(int)
由 Container.getComponent(int) 取代
javax.swing.JMenuBar.getComponentAtIndex(int)
由 getComponent(int i) 取代
java.awt.CheckboxGroup.getCurrent()
从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
java.awt.Frame.getCursorType()
从 JDK version 1.1 开始，由 Component.getCursor() 取代。
java.sql.Time.getDate()
java.util.Date.getDate()
从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_MONTH) 取代。
java.sql.Time.getDay()
java.util.Date.getDay()
从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_WEEK) 取代。
java.net.URLConnection.getDefaultRequestProperty(String)
应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。
java.rmi.server.LogStream.getDefaultStream()
无替代版本
javax.management.monitor.CounterMonitor.getDerivedGauge()
从 JMX 1.2 开始，由 CounterMonitor.getDerivedGauge(ObjectName) 取代
javax.management.monitor.CounterMonitorMBean.getDerivedGauge()
从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGauge(ObjectName) 取代
javax.management.monitor.GaugeMonitor.getDerivedGauge()
从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGauge(ObjectName) 取代
javax.management.monitor.GaugeMonitorMBean.getDerivedGauge()
从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGauge(ObjectName) 取代
javax.management.monitor.StringMonitor.getDerivedGauge()
从 JMX 1.2 开始，由 StringMonitor.getDerivedGauge(ObjectName) 取代
javax.management.monitor.StringMonitorMBean.getDerivedGauge()
从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGauge(ObjectName) 取代
javax.management.monitor.CounterMonitor.getDerivedGaugeTimeStamp()
从 JMX 1.2 开始，由 CounterMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
javax.management.monitor.CounterMonitorMBean.getDerivedGaugeTimeStamp()
从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
javax.management.monitor.GaugeMonitor.getDerivedGaugeTimeStamp()
从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
javax.management.monitor.GaugeMonitorMBean.getDerivedGaugeTimeStamp()
从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
javax.management.monitor.StringMonitor.getDerivedGaugeTimeStamp()
从 JMX 1.2 开始，由 StringMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
javax.management.monitor.StringMonitorMBean.getDerivedGaugeTimeStamp()
从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
javax.swing.plaf.basic.BasicSplitPaneUI.getDividerBorderSize()
从 Java 2 平台 v1.3 开始，由在分隔符上设置边框取代。
javax.xml.bind.Validator.getEventHandler()
从 JAXB2.0 开始
java.awt.Toolkit.getFontList()
请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()
javax.swing.text.LabelView.getFontMetrics()
FontMetrics 不用于在 JDK 中运行时的字形呈现。
java.awt.Toolkit.getFontMetrics(Font)
从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
java.awt.Toolkit.getFontPeer(String, int)
请参阅 java.awt.GraphicsEnvironment#getAllFonts
java.sql.Date.getHours()
java.util.Date.getHours()
从 JDK 1.1 开始，由 Calendar.get(Calendar.HOUR_OF_DAY) 取代。
java.lang.SecurityManager.getInCheck()
建议不使用该类安全检查。建议使用 checkPermission 调用。
java.rmi.server.RemoteCall.getInputStream()
无替代版本
javax.swing.KeyStroke.getKeyStroke(char, boolean)
使用 getKeyStroke(char)
javax.swing.AbstractButton.getLabel()
- 由 getText 取代
java.awt.Scrollbar.getLineIncrement()
从 JDK version 1.1 开始，由 getUnitIncrement() 取代。
java.lang.Runtime.getLocalizedInputStream(InputStream)
从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
java.lang.Runtime.getLocalizedOutputStream(OutputStream)
从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
java.sql.DriverManager.getLogStream()
java.awt.FontMetrics.getMaxDecent()
从 JDK version 1.1.1 开始，由 getMaxDescent() 取代。
javax.swing.JInternalFrame.getMenuBar()
从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
javax.swing.JRootPane.getMenuBar()
从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。
java.sql.Date.getMinutes()
java.util.Date.getMinutes()
从 JDK 1.1 开始，由 Calendar.get(Calendar.MINUTE) 取代。
java.sql.Time.getMonth()
java.util.Date.getMonth()
从 JDK 1.1 开始，由 Calendar.get(Calendar.MONTH) 取代。
javax.swing.JComponent.getNextFocusableComponent()
从 1.4 版本开始，由 FocusTraversalPolicy 取代。
javax.management.monitor.Monitor.getObservedObject()
从 JMX 1.2 开始，由 Monitor.getObservedObjects() 取代
javax.management.monitor.MonitorMBean.getObservedObject()
从 JMX 1.2 开始，由 MonitorMBean.getObservedObjects() 取代
java.rmi.server.Operation.getOperation()
无替代版本
java.rmi.server.Skeleton.getOperations()
无替代版本
java.awt.ComponentOrientation.getOrientation(ResourceBundle)
在 J2SE 1.4 中，使用 ComponentOrientation.getOrientation(java.util.Locale)。
java.rmi.server.LogStream.getOutputStream()
无替代版本
java.rmi.server.RemoteCall.getOutputStream()
无替代版本
java.awt.Scrollbar.getPageIncrement()
从 JDK version 1.1 开始，由 getBlockIncrement() 取代。
java.security.Signature.getParameter(String)
java.awt.MenuComponent.getPeer()
从 JDK version 1.1 开始，程序不应直接操作同位体。
java.awt.Font.getPeer()
现在，字体呈现与平台无关。
java.awt.Component.getPeer()
从 JDK version 1.1 开始，程序不应直接操作同位体；由 boolean isDisplayable() 取代。
javax.xml.bind.Validator.getProperty(String)
从 JAXB2.0 开始
java.rmi.server.RemoteCall.getResultStream(boolean)
无替代版本
java.sql.Date.getSeconds()
java.util.Date.getSeconds()
从 JDK 1.1 开始，由 Calendar.get(Calendar.SECOND) 取代。
java.rmi.server.LoaderHandler.getSecurityContext(ClassLoader)
无替代版本
java.rmi.server.RMIClassLoader.getSecurityContext(ClassLoader)
无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
javax.swing.JPasswordField.getText()
从 Java 2 platform v1.2 开始，由 getPassword 来代替。
javax.swing.JPasswordField.getText(int, int)
从 Java 2 platform v1.2 开始，由 getPassword 来代替。
javax.management.monitor.CounterMonitor.getThreshold()
从 JMX 1.2 开始，由 CounterMonitor.getThreshold(ObjectName) 取代
javax.management.monitor.CounterMonitorMBean.getThreshold()
从 JMX 1.2 开始，由 CounterMonitorMBean.getThreshold(ObjectName) 取代
java.util.Date.getTimezoneOffset()
从 JDK 1.1 开始，由 -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 取代。
java.net.DatagramSocketImpl.getTTL()
使用 getTimeToLive 代替。
java.net.MulticastSocket.getTTL()
使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
java.sql.ResultSet.getUnicodeStream(int)
使用 getCharacterStream 取代 getUnicodeStream
java.sql.ResultSet.getUnicodeStream(String)
使用 getCharacterStream 代替
javax.swing.ScrollPaneLayout.getViewportBorderBounds(JScrollPane)
从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
java.awt.Scrollbar.getVisible()
从 JDK version 1.1 开始，由 getVisibleAmount() 取代。
java.sql.Time.getYear()
java.util.Date.getYear()
从 JDK 1.1 开始，由 Calendar.get(Calendar.YEAR) - 1900 取代。
java.awt.Component.gotFocus(Event, Object)
从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
java.awt.Component.handleEvent(Event)
从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
java.awt.Dialog.hide()
从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
java.awt.Window.hide()
从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
java.awt.Component.hide()
从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
java.lang.SecurityManager.inClass(String)
建议不使用该类安全检查。建议使用 checkPermission 调用。
java.lang.SecurityManager.inClassLoader()
建议不使用该类安全检查。建议使用 checkPermission 调用。
org.omg.CORBA.Any.insert_Principal(Principal)
由 CORBA 2.2 取代。
javax.swing.text.html.HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane, HTMLDocument, int, Element, String, HTML.Tag, HTML.Tag)
从 Java 2 平台 v1.3 开始，使用 insertAtBoundary
java.awt.TextArea.insertText(String, int)
从 JDK version 1.1 开始，由 insert(String, int) 取代。
java.awt.Container.insets()
从 JDK version 1.1 开始，用 getInsets() 取代。
java.awt.Polygon.inside(int, int)
从 JDK version 1.1 开始, 此函数为 contains(int, int)。
java.awt.Rectangle.inside(int, int)
从 JDK version 1.1 开始，由 contains(int, int) 取代。
java.awt.Component.inside(int, int)
从 JDK version 1.1 开始，由 contains(int, int) 取代。
java.rmi.server.RemoteRef.invoke(RemoteCall)
1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
org.omg.CORBA.DynamicImplementation.invoke(ServerRequest)
由 Portable Object Adapter 取代
javax.swing.JViewport.isBackingStoreEnabled()
从 Java 2 平台 1.3 版开始，由 getScrollMode() 取代。
javax.swing.FocusManager.isFocusManagerEnabled()
从 1.4 开始，由 KeyboardFocusManager.getDefaultFocusTraversalPolicy() 取代
java.awt.Component.isFocusTraversable()
从 1.4 开始，由 isFocusable() 取代。
java.lang.Character.isJavaLetter(char)
由 isJavaIdentifierStart(char) 取代。
java.lang.Character.isJavaLetterOrDigit(char)
由 isJavaIdentifierPart(char) 取代。
javax.swing.JComponent.isManagingFocus()
从 1.4 版本开始，由 Component.setFocusTraversalKeys(int, Set) 和 Container.setFocusCycleRoot(boolean) 取代。
java.awt.List.isSelected(int)
从 JDK version 1.1 开始，由 isIndexSelected(int) 取代。
java.lang.Character.isSpace(char)
由 isWhitespace(char) 取代。
java.rmi.dgc.VMID.isUnique()
javax.xml.bind.Unmarshaller.isValidating()
从 JAXB 2.0 开始，请参阅 Unmarshaller.getSchema()
java.awt.Component.keyDown(Event, int)
从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
java.awt.Component.keyUp(Event, int)
从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
java.awt.ScrollPane.layout()
从 JDK version 1.1 开始，由 doLayout() 取代。
java.awt.Container.layout()
从 JDK version 1.1，用 doLayout() 取代。
java.awt.Component.layout()
从 JDK version 1.1 开始，由 doLayout() 取代。
java.rmi.server.LoaderHandler.loadClass(String)
无替代版本
java.rmi.server.RMIClassLoader.loadClass(String)
由 loadClass(String,String) 方法取代
java.rmi.server.LoaderHandler.loadClass(URL, String)
无替代版本
java.awt.Container.locate(int, int)
从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
java.awt.Component.locate(int, int)
从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。
java.awt.Component.location()
从 JDK version 1.1 开始，由 getLocation() 取代。
java.rmi.server.LogStream.log(String)
无替代版本
java.awt.Component.lostFocus(Event, Object)
从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
java.awt.List.minimumSize()
从 JDK version 1.1 开始，由 getMinimumSize() 取代。
java.awt.TextArea.minimumSize()
从 JDK version 1.1 开始，由 getMinimumSize() 取代。
java.awt.TextField.minimumSize()
从 JDK version 1.1 开始，由 getMinimumSize() 取代。
java.awt.Container.minimumSize()
从 JDK version 1.1 开始，用 getMinimumSize() 取代。
java.awt.Component.minimumSize()
从 JDK version 1.1 开始，由 getMinimumSize() 取代。
java.awt.List.minimumSize(int)
从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
java.awt.TextField.minimumSize(int)
从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
java.awt.TextArea.minimumSize(int, int)
从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
javax.swing.text.View.modelToView(int, Shape)
java.awt.Component.mouseDown(Event, int, int)
从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
java.awt.Component.mouseDrag(Event, int, int)
从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
java.awt.Component.mouseEnter(Event, int, int)
从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
java.awt.Component.mouseExit(Event, int, int)
从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
java.awt.Component.mouseMove(Event, int, int)
从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
java.awt.Component.mouseUp(Event, int, int)
从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
java.awt.Rectangle.move(int, int)
从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
java.awt.Component.move(int, int)
从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
org.omg.CORBA.Principal.name()
已由 CORBA 2.2 取代。
org.omg.CORBA.Principal.name(byte[])
已由 CORBA 2.2 取代。
java.rmi.server.RemoteRef.newCall(RemoteObject, Operation[], int, long)
1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。
java.awt.Component.nextFocus()
从 JDK version 1.1 开始，由 transferFocus() 取代。
java.awt.datatransfer.DataFlavor.normalizeMimeType(String)
javax.activation.ActivationDataFlavor.normalizeMimeType(String)
java.awt.datatransfer.DataFlavor.normalizeMimeTypeParameter(String, String)
javax.activation.ActivationDataFlavor.normalizeMimeTypeParameter(String, String)
org.omg.CORBA.ServerRequest.op_name()
使用 operation()
org.omg.CORBA.ServerRequest.params(NVList)
使用方法 arguments
java.util.Date.parse(String)
从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
java.rmi.server.LogStream.parseLevel(String)
无替代版本
java.awt.MenuComponent.postEvent(Event)
从 JDK version 1.1 开始，已由 dispatchEvent 取代。
java.awt.Window.postEvent(Event)
从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
java.awt.Component.postEvent(Event)
从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
java.awt.MenuContainer.postEvent(Event)
从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
java.awt.image.renderable.RenderContext.preConcetenateTransform(AffineTransform)
由 preConcatenateTransform(AffineTransform) 所取代。
java.awt.List.preferredSize()
从 JDK version 1.1 开始，由 getPreferredSize() 取代。
java.awt.TextArea.preferredSize()
从 JDK version 1.1 开始，由 getPreferredSize() 取代。
java.awt.TextField.preferredSize()
从 JDK version 1.1 开始，由 getPreferredSize() 取代。
java.awt.Container.preferredSize()
从 JDK version 1.1 开始，用 getPreferredSize() 取代。
java.awt.Component.preferredSize()
从 JDK version 1.1 开始，由 getPreferredSize() 取代。
java.awt.List.preferredSize(int)
从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
java.awt.TextField.preferredSize(int)
从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
java.awt.TextArea.preferredSize(int, int)
从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
org.omg.CORBA.portable.InputStream.read_Principal()
已由 CORBA 2.2 取代。
java.io.ObjectInputStream.readLine()
此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
java.io.DataInputStream.readLine()
该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
java.rmi.registry.RegistryHandler.registryImpl(int)
无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
java.rmi.registry.RegistryHandler.registryStub(String, int)
无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。
java.rmi.server.RemoteCall.releaseInputStream()
无替代版本
java.rmi.server.RemoteCall.releaseOutputStream()
无替代版本
javax.swing.plaf.metal.MetalComboBoxUI.removeListeners()
从 Java 2 platform v1.4 开始。
java.awt.TextArea.replaceText(String, int, int)
从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。
javax.swing.JComponent.requestDefaultFocus()
从 1.4 版本开始，由 FocusTraversalPolicy.getDefaultComponent(Container).requestFocus() 取代
java.awt.Rectangle.reshape(int, int, int, int)
从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
java.awt.Window.reshape(int, int, int, int)
从 JDK 1.1 版开始，由 setBounds(int, int, int, int) 取代。
java.awt.Component.reshape(int, int, int, int)
从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
javax.swing.JComponent.reshape(int, int, int, int)
从 JDK 5 开始，由 Component.setBounds(int, int, int, int) 取代。

移动此组件并调整其大小。

java.awt.Component.resize(Dimension)
从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
java.awt.Rectangle.resize(int, int)
从 JDK version 1.1 开始，由 setSize(int, int) 取代。
java.awt.Component.resize(int, int)
从 JDK version 1.1 开始，由 setSize(int, int) 取代。
org.omg.CORBA.ServerRequest.result(Any)
使用方法 set_result
java.lang.ThreadGroup.resume()
此方法只用于联合 Thread.suspend 和 ThreadGroup.suspend 时，因为它们所固有的容易导致死锁的特性，所以两者都已废弃。有关详细信息，请参阅 Thread.suspend()。
java.lang.Thread.resume()
该方法只与 Thread.suspend() 一起使用，但 Thread.suspend() 已经遭到反对，因为它具有死锁倾向。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
java.lang.Runtime.runFinalizersOnExit(boolean)
此方法本身具有不安全性。它可能对正在使用的对象调用终结方法，而其他线程正在操作这些对象，从而导致不正确的行为或死锁。
java.lang.System.runFinalizersOnExit(boolean)
该方法具有固有的不安全性。它可能对正在使用的对象调用终结方法，而其他线程同时正在操作这些对象，从而导致不正确的行为或死锁。
java.util.Properties.save(OutputStream, String)
如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
java.net.MulticastSocket.send(DatagramPacket, byte)
使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
javax.swing.JViewport.setBackingStoreEnabled(boolean)
从 Java 2 平台 1.3 版开始，由 setScrollMode() 取代。
java.awt.CheckboxGroup.setCurrent(Checkbox)
从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
java.awt.Frame.setCursor(int)
从 JDK version 1.1 开始，由 Component.setCursor(Cursor) 取代。
java.sql.Time.setDate(int)
java.util.Date.setDate(int)
从 JDK 1.1 开始，由 Calendar.set(Calendar.DAY_OF_MONTH, int date) 取代。
java.net.URLConnection.setDefaultRequestProperty(String, String)
应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。
java.rmi.server.LogStream.setDefaultStream(PrintStream)
无替代版本
java.awt.TextField.setEchoCharacter(char)
从 JDK version 1.1 开始，由 setEchoChar(char) 取代。
javax.xml.bind.Validator.setEventHandler(ValidationEventHandler)
从 JAXB2.0 开始
java.sql.Date.setHours(int)
java.util.Date.setHours(int)
从 JDK 1.1 开始，由 Calendar.set(Calendar.HOUR_OF_DAY, int hours) 取代。
javax.swing.AbstractButton.setLabel(String)
- 由 setText(text) 取代
java.awt.Scrollbar.setLineIncrement(int)
从 JDK version 1.1 开始，由 setUnitIncrement(int) 取代。
java.sql.DriverManager.setLogStream(PrintStream)
javax.management.ValueExp.setMBeanServer(MBeanServer)
不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。
javax.swing.JInternalFrame.setMenuBar(JMenuBar)
从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
javax.swing.JRootPane.setMenuBar(JMenuBar)
从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。
java.sql.Date.setMinutes(int)
java.util.Date.setMinutes(int)
从 JDK 1.1 开始，由 Calendar.set(Calendar.MINUTE, int minutes) 取代。
java.awt.event.KeyEvent.setModifiers(int)
从 JDK1.1.4 开始
java.sql.Time.setMonth(int)
java.util.Date.setMonth(int)
从 JDK 1.1 开始，由 Calendar.set(Calendar.MONTH, int month) 取代。
java.awt.List.setMultipleSelections(boolean)
从 JDK version 1.1 开始，由 setMultipleMode(boolean) 取代。
javax.swing.JComponent.setNextFocusableComponent(Component)
从 1.4 版本开始，由 FocusTraversalPolicy 取代
javax.management.monitor.Monitor.setObservedObject(ObjectName)
从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
javax.management.monitor.MonitorMBean.setObservedObject(ObjectName)
从 JMX 1.2 开始，由 MonitorMBean.addObservedObject(javax.management.ObjectName) 取代
java.rmi.server.LogStream.setOutputStream(OutputStream)
无替代版本
java.awt.Scrollbar.setPageIncrement(int)
从 JDK version 1.1 开始，由 setBlockIncrement() 取代。
java.security.Signature.setParameter(String, Object)
使用 setParameter 取代。
javax.xml.bind.Validator.setProperty(String, Object)
从 JAXB2.0 开始
java.rmi.server.RemoteStub.setRef(RemoteStub, RemoteRef)
无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。
java.sql.Date.setSeconds(int)
java.util.Date.setSeconds(int)
从 JDK 1.1 开始，由 Calendar.set(Calendar.SECOND, int seconds) 取代。
javax.management.monitor.CounterMonitor.setThreshold(Number)
从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
javax.management.monitor.CounterMonitorMBean.setThreshold(Number)
从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代
java.net.DatagramSocketImpl.setTTL(byte)
使用 setTimeToLive 代替。
java.net.MulticastSocket.setTTL(byte)
使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
java.sql.PreparedStatement.setUnicodeStream(int, InputStream, int)
javax.sql.rowset.BaseRowSet.setUnicodeStream(int, InputStream, int)
应该使用 getCharacterStream 替代它
java.net.URLStreamHandler.setURL(URL, String, String, int, String, String)
使用 setURL(URL, String, String, int, String, String, String, String);
javax.xml.bind.Unmarshaller.setValidating(boolean)
从 JAXB2.0 开始，请参阅 Unmarshaller.setSchema(javax.xml.validation.Schema)
java.sql.Time.setYear(int)
java.util.Date.setYear(int)
从 JDK 1.1 开始，由 Calendar.set(Calendar.YEAR, year + 1900) 取代。
java.awt.Dialog.show()
从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
java.awt.Window.show()
从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
java.awt.Component.show()
从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
java.awt.Component.show(boolean)
从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
java.awt.Component.size()
从 JDK version 1.1 开始，由 getSize() 取代。
javax.swing.JTable.sizeColumnsToFit(boolean)
从 Swing version 1.0.3 开始，由 doLayout() 取代。
java.lang.ThreadGroup.stop()
此方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。
java.lang.Thread.stop()
该方法具有固有的不安全性。用 Thread.stop 来终止线程将释放它已经锁定的所有监视器（作为沿堆栈向上传播的未检查 ThreadDeath 异常的一个自然后果）。如果以前受这些监视器保护的任何对象都处于一种不一致的状态，则损坏的对象将对其他线程可见，这有可能导致任意的行为。stop 的许多使用都应由只修改某些变量以指示目标线程应该停止运行的代码来取代。目标线程应定期检查该变量，并且如果该变量指示它要停止运行，则从其运行方法依次返回。如果目标线程等待很长时间（例如基于一个条件变量），则应使用 interrupt 方法来中断该等待。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
java.lang.Thread.stop(Throwable)
该方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
java.lang.ThreadGroup.suspend()
此方法容易导致死锁。有关详细信息，请参阅 Thread.suspend()。
java.lang.Thread.suspend()
该方法已经遭到反对，因为它具有固有的死锁倾向。如果目标线程挂起时在保护关键系统资源的监视器上保持有锁，则在目标线程重新开始以前任何线程都不能访问该资源。如果重新开始目标线程的线程想在调用 resume 之前锁定该监视器，则会发生死锁。这类死锁通常会证明自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
java.util.Date.toGMTString()
从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。
java.util.Date.toLocaleString()
从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。
java.rmi.server.LogStream.toString()
无替代版本
java.rmi.server.Operation.toString()
无替代版本
java.io.ByteArrayOutputStream.toString(int)
此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。
java.io.File.toURL()
此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。
java.util.Date.UTC(int, int, int, int, int, int)
从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代，使用 UTC TimeZone，后跟 Calendar.getTime().getTime()。
javax.xml.bind.Validator.validate(Object)
从 JAXB2.0 开始
javax.xml.bind.Validator.validateRoot(Object)
从 JAXB2.0 开始
javax.swing.text.View.viewToModel(float, float, Shape)
org.omg.CORBA.portable.OutputStream.write_Principal(Principal)
已由 CORBA 2.2 取代。
java.rmi.server.LogStream.write(byte[], int, int)
无替代版本
java.rmi.server.LogStream.write(int)
无替代版本
java.io.ObjectOutputStream.PutField.write(ObjectOutput)
此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。

已过时的构造方法
javax.management.AttributeValueExp()
在查询中不能使用此构造方法所创建的实例。
java.sql.Date(int, int, int)
使用构造方法 Date(long date) 替代
java.util.Date(int, int, int)
从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date) 或 GregorianCalendar(year + 1900, month, date) 取代。
java.util.Date(int, int, int, int, int)
从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min) 或 GregorianCalendar(year + 1900, month, date, hrs, min) 取代。
java.util.Date(int, int, int, int, int, int)
从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代。
java.util.Date(String)
从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
java.awt.event.KeyEvent(Component, int, long, int, int)
从 JDK1.1 开始
java.rmi.server.Operation(String)
无替代版本
java.rmi.RMISecurityException(String)
无替换版本
java.rmi.RMISecurityException(String, String)
无替换版本
java.rmi.ServerRuntimeException(String, Exception)
无替换版本
java.rmi.server.SkeletonMismatchException(String)
无替代版本
java.net.Socket(InetAddress, int, boolean)
Use DatagramSocket instead for UDP transport.
java.net.Socket(String, int, boolean)
使用 DatagramSocket 取代 UDP 传输。
java.io.StreamTokenizer(InputStream)
从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
java.lang.String(byte[], int)
该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
java.lang.String(byte[], int, int, int)
该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
org.omg.CORBA.TCKind(int)
不要使用此构造方法，因为根据 OMG 规范，此方法应该是私有的。使用 TCKind.from_int(int) 代替。
java.sql.Time(int, int, int)
使用采用毫秒值的构造方法取代此构造方法
java.sql.Timestamp(int, int, int, int, int, int, int)
使用构造方法 Timestamp(long millis) 来代替

已过时的注释类型元素
javax.jws.HandlerChain.name
从 JSR-181 2.0 开始，无替代版本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


所有类 (Java 2 Platform SE 6)

 所有类
AbstractAction
AbstractAnnotationValueVisitor6
AbstractBorder
AbstractButton
AbstractCellEditor
AbstractCollection
AbstractColorChooserPanel
AbstractDocument
AbstractDocument.AttributeContext
AbstractDocument.Content
AbstractDocument.ElementEdit
AbstractElementVisitor6
AbstractExecutorService
AbstractInterruptibleChannel
AbstractLayoutCache
AbstractLayoutCache.NodeDimensions
AbstractList
AbstractListModel
AbstractMap
AbstractMap.SimpleEntry
AbstractMap.SimpleImmutableEntry
AbstractMarshallerImpl
AbstractMethodError
AbstractOwnableSynchronizer
AbstractPreferences
AbstractProcessor
AbstractQueue
AbstractQueuedLongSynchronizer
AbstractQueuedSynchronizer
AbstractScriptEngine
AbstractSelectableChannel
AbstractSelectionKey
AbstractSelector
AbstractSequentialList
AbstractSet
AbstractSpinnerModel
AbstractTableModel
AbstractTypeVisitor6
AbstractUndoableEdit
AbstractUnmarshallerImpl
AbstractWriter
AccessControlContext
AccessControlException
AccessController
AccessException
Accessible
AccessibleAction
AccessibleAttributeSequence
AccessibleBundle
AccessibleComponent
AccessibleContext
AccessibleEditableText
AccessibleExtendedComponent
AccessibleExtendedTable
AccessibleExtendedText
AccessibleHyperlink
AccessibleHypertext
AccessibleIcon
AccessibleKeyBinding
AccessibleObject
AccessibleRelation
AccessibleRelationSet
AccessibleResourceBundle
AccessibleRole
AccessibleSelection
AccessibleState
AccessibleStateSet
AccessibleStreamable
AccessibleTable
AccessibleTableModelChange
AccessibleText
AccessibleTextSequence
AccessibleValue
AccountException
AccountExpiredException
AccountLockedException
AccountNotFoundException
Acl
AclEntry
AclNotFoundException
Action
ActionEvent
ActionListener
ActionMap
ActionMapUIResource
Activatable
ActivateFailedException
ActivationDataFlavor
ActivationDesc
ActivationException
ActivationGroup
ActivationGroup_Stub
ActivationGroupDesc
ActivationGroupDesc.CommandEnvironment
ActivationGroupID
ActivationID
ActivationInstantiator
ActivationMonitor
ActivationSystem
Activator
ACTIVE
ActiveEvent
ACTIVITY_COMPLETED
ACTIVITY_REQUIRED
ActivityCompletedException
ActivityRequiredException
AdapterActivator
AdapterActivatorOperations
AdapterAlreadyExists
AdapterAlreadyExistsHelper
AdapterInactive
AdapterInactiveHelper
AdapterManagerIdHelper
AdapterNameHelper
AdapterNonExistent
AdapterNonExistentHelper
AdapterStateHelper
AddressHelper
Adjustable
AdjustmentEvent
AdjustmentListener
Adler32
AffineTransform
AffineTransformOp
AlgorithmMethod
AlgorithmParameterGenerator
AlgorithmParameterGeneratorSpi
AlgorithmParameters
AlgorithmParameterSpec
AlgorithmParametersSpi
AllPermission
AlphaComposite
AlreadyBound
AlreadyBoundException
AlreadyBoundHelper
AlreadyBoundHolder
AlreadyConnectedException
AncestorEvent
AncestorListener
AnnotatedElement
Annotation
Annotation
AnnotationFormatError
AnnotationMirror
AnnotationTypeMismatchException
AnnotationValue
AnnotationValueVisitor
Any
AnyHolder
AnySeqHelper
AnySeqHelper
AnySeqHolder
AppConfigurationEntry
AppConfigurationEntry.LoginModuleControlFlag
Appendable
Applet
AppletContext
AppletInitializer
AppletStub
ApplicationException
Arc2D
Arc2D.Double
Arc2D.Float
Area
AreaAveragingScaleFilter
ARG_IN
ARG_INOUT
ARG_OUT
ArithmeticException
Array
Array
ArrayBlockingQueue
ArrayDeque
ArrayIndexOutOfBoundsException
ArrayList
Arrays
ArrayStoreException
ArrayType
ArrayType
AssertionError
AsyncBoxView
AsyncHandler
AsynchronousCloseException
AtomicBoolean
AtomicInteger
AtomicIntegerArray
AtomicIntegerFieldUpdater
AtomicLong
AtomicLongArray
AtomicLongFieldUpdater
AtomicMarkableReference
AtomicReference
AtomicReferenceArray
AtomicReferenceFieldUpdater
AtomicStampedReference
AttachmentMarshaller
AttachmentPart
AttachmentUnmarshaller
Attr
Attribute
Attribute
Attribute
Attribute
AttributeChangeNotification
AttributeChangeNotificationFilter
AttributedCharacterIterator
AttributedCharacterIterator.Attribute
AttributedString
AttributeException
AttributeInUseException
AttributeList
AttributeList
AttributeList
AttributeListImpl
AttributeModificationException
AttributeNotFoundException
Attributes
Attributes
Attributes
Attributes.Name
Attributes2
Attributes2Impl
AttributeSet
AttributeSet
AttributeSet.CharacterAttribute
AttributeSet.ColorAttribute
AttributeSet.FontAttribute
AttributeSet.ParagraphAttribute
AttributeSetUtilities
AttributesImpl
AttributeValueExp
AudioClip
AudioFileFormat
AudioFileFormat.Type
AudioFileReader
AudioFileWriter
AudioFormat
AudioFormat.Encoding
AudioInputStream
AudioPermission
AudioSystem
AuthenticationException
AuthenticationException
AuthenticationNotSupportedException
Authenticator
Authenticator.RequestorType
AuthorizeCallback
AuthPermission
AuthProvider
Autoscroll
AWTError
AWTEvent
AWTEventListener
AWTEventListenerProxy
AWTEventMulticaster
AWTException
AWTKeyStroke
AWTPermission
BackingStoreException
BAD_CONTEXT
BAD_INV_ORDER
BAD_OPERATION
BAD_PARAM
BAD_POLICY
BAD_POLICY_TYPE
BAD_POLICY_VALUE
BAD_QOS
BAD_TYPECODE
BadAttributeValueExpException
BadBinaryOpValueExpException
BadKind
BadLocationException
BadPaddingException
BadStringOperationException
BandCombineOp
BandedSampleModel
BaseRowSet
BasicArrowButton
BasicAttribute
BasicAttributes
BasicBorders
BasicBorders.ButtonBorder
BasicBorders.FieldBorder
BasicBorders.MarginBorder
BasicBorders.MenuBarBorder
BasicBorders.RadioButtonBorder
BasicBorders.RolloverButtonBorder
BasicBorders.SplitPaneBorder
BasicBorders.ToggleButtonBorder
BasicButtonListener
BasicButtonUI
BasicCheckBoxMenuItemUI
BasicCheckBoxUI
BasicColorChooserUI
BasicComboBoxEditor
BasicComboBoxEditor.UIResource
BasicComboBoxRenderer
BasicComboBoxRenderer.UIResource
BasicComboBoxUI
BasicComboPopup
BasicControl
BasicDesktopIconUI
BasicDesktopPaneUI
BasicDirectoryModel
BasicEditorPaneUI
BasicFileChooserUI
BasicFormattedTextFieldUI
BasicGraphicsUtils
BasicHTML
BasicIconFactory
BasicInternalFrameTitlePane
BasicInternalFrameUI
BasicLabelUI
BasicListUI
BasicLookAndFeel
BasicMenuBarUI
BasicMenuItemUI
BasicMenuUI
BasicOptionPaneUI
BasicOptionPaneUI.ButtonAreaLayout
BasicPanelUI
BasicPasswordFieldUI
BasicPermission
BasicPopupMenuSeparatorUI
BasicPopupMenuUI
BasicProgressBarUI
BasicRadioButtonMenuItemUI
BasicRadioButtonUI
BasicRootPaneUI
BasicScrollBarUI
BasicScrollPaneUI
BasicSeparatorUI
BasicSliderUI
BasicSpinnerUI
BasicSplitPaneDivider
BasicSplitPaneUI
BasicStroke
BasicTabbedPaneUI
BasicTableHeaderUI
BasicTableUI
BasicTextAreaUI
BasicTextFieldUI
BasicTextPaneUI
BasicTextUI
BasicTextUI.BasicCaret
BasicTextUI.BasicHighlighter
BasicToggleButtonUI
BasicToolBarSeparatorUI
BasicToolBarUI
BasicToolTipUI
BasicTreeUI
BasicViewportUI
BatchUpdateException
BeanContext
BeanContextChild
BeanContextChildComponentProxy
BeanContextChildSupport
BeanContextContainerProxy
BeanContextEvent
BeanContextMembershipEvent
BeanContextMembershipListener
BeanContextProxy
BeanContextServiceAvailableEvent
BeanContextServiceProvider
BeanContextServiceProviderBeanInfo
BeanContextServiceRevokedEvent
BeanContextServiceRevokedListener
BeanContextServices
BeanContextServicesListener
BeanContextServicesSupport
BeanContextServicesSupport.BCSSServiceProvider
BeanContextSupport
BeanContextSupport.BCSIterator
BeanDescriptor
BeanInfo
Beans
BevelBorder
Bidi
BigDecimal
BigInteger
BinaryRefAddr
Binder
BindException
Binding
Binding
Binding
BindingHelper
BindingHolder
BindingIterator
BindingIteratorHelper
BindingIteratorHolder
BindingIteratorOperations
BindingIteratorPOA
BindingListHelper
BindingListHolder
BindingProvider
Bindings
BindingType
BindingType
BindingTypeHelper
BindingTypeHolder
BitSet
Blob
BlockingDeque
BlockingQueue
BlockView
BMPImageWriteParam
Book
Boolean
BooleanControl
BooleanControl.Type
BooleanHolder
BooleanSeqHelper
BooleanSeqHolder
Border
BorderFactory
BorderLayout
BorderUIResource
BorderUIResource.BevelBorderUIResource
BorderUIResource.CompoundBorderUIResource
BorderUIResource.EmptyBorderUIResource
BorderUIResource.EtchedBorderUIResource
BorderUIResource.LineBorderUIResource
BorderUIResource.MatteBorderUIResource
BorderUIResource.TitledBorderUIResource
BoundedRangeModel
Bounds
Bounds
Box
Box.Filler
BoxedValueHelper
BoxLayout
BoxView
BreakIterator
BreakIteratorProvider
BrokenBarrierException
Buffer
BufferCapabilities
BufferCapabilities.FlipContents
BufferedImage
BufferedImageFilter
BufferedImageOp
BufferedInputStream
BufferedOutputStream
BufferedReader
BufferedWriter
BufferOverflowException
BufferStrategy
BufferUnderflowException
Button
ButtonGroup
ButtonModel
ButtonUI
Byte
ByteArrayInputStream
ByteArrayOutputStream
ByteBuffer
ByteChannel
ByteHolder
ByteLookupTable
ByteOrder
C14NMethodParameterSpec
CachedRowSet
CacheRequest
CacheResponse
Calendar
Callable
CallableStatement
Callback
CallbackHandler
CancelablePrintJob
CancellationException
CancelledKeyException
CannotProceed
CannotProceedException
CannotProceedHelper
CannotProceedHolder
CannotRedoException
CannotUndoException
CanonicalizationMethod
Canvas
CardLayout
Caret
CaretEvent
CaretListener
CDATASection
CellEditor
CellEditorListener
CellRendererPane
Certificate
Certificate
Certificate
Certificate.CertificateRep
CertificateEncodingException
CertificateEncodingException
CertificateException
CertificateException
CertificateExpiredException
CertificateExpiredException
CertificateFactory
CertificateFactorySpi
CertificateNotYetValidException
CertificateNotYetValidException
CertificateParsingException
CertificateParsingException
CertPath
CertPath.CertPathRep
CertPathBuilder
CertPathBuilderException
CertPathBuilderResult
CertPathBuilderSpi
CertPathParameters
CertPathTrustManagerParameters
CertPathValidator
CertPathValidatorException
CertPathValidatorResult
CertPathValidatorSpi
CertSelector
CertStore
CertStoreException
CertStoreParameters
CertStoreSpi
ChangedCharSetException
ChangeEvent
ChangeListener
Channel
ChannelBinding
Channels
Character
Character.Subset
Character.UnicodeBlock
CharacterCodingException
CharacterData
CharacterIterator
Characters
CharArrayReader
CharArrayWriter
CharBuffer
CharConversionException
CharHolder
CharSeqHelper
CharSeqHolder
CharSequence
Charset
CharsetDecoder
CharsetEncoder
CharsetProvider
Checkbox
CheckboxGroup
CheckboxMenuItem
CheckedInputStream
CheckedOutputStream
Checksum
Choice
ChoiceCallback
ChoiceFormat
Chromaticity
Cipher
CipherInputStream
CipherOutputStream
CipherSpi
Class
ClassCastException
ClassCircularityError
ClassDefinition
ClassDesc
ClassFileTransformer
ClassFormatError
ClassLoader
ClassLoaderRepository
ClassLoadingMXBean
ClassNotFoundException
ClientInfoStatus
ClientRequestInfo
ClientRequestInfoOperations
ClientRequestInterceptor
ClientRequestInterceptorOperations
Clip
Clipboard
ClipboardOwner
Clob
Cloneable
CloneNotSupportedException
Closeable
ClosedByInterruptException
ClosedChannelException
ClosedSelectorException
CMMException
Codec
CodecFactory
CodecFactoryHelper
CodecFactoryOperations
CodecOperations
CoderMalfunctionError
CoderResult
CODESET_INCOMPATIBLE
CodeSets
CodeSigner
CodeSource
CodingErrorAction
CollapsedStringAdapter
CollationElementIterator
CollationKey
Collator
CollatorProvider
Collection
CollectionCertStoreParameters
Collections
Color
ColorChooserComponentFactory
ColorChooserUI
ColorConvertOp
ColorModel
ColorSelectionModel
ColorSpace
ColorSupported
ColorType
ColorUIResource
ComboBoxEditor
ComboBoxModel
ComboBoxUI
ComboPopup
COMM_FAILURE
CommandInfo
CommandMap
CommandObject
Comment
Comment
CommonDataSource
CommunicationException
Comparable
Comparator
Compilable
CompilationMXBean
CompiledScript
Compiler
Completion
Completions
CompletionService
CompletionStatus
CompletionStatusHelper
Component
Component.BaselineResizeBehavior
ComponentAdapter
ComponentColorModel
ComponentEvent
ComponentIdHelper
ComponentInputMap
ComponentInputMapUIResource
ComponentListener
ComponentOrientation
ComponentSampleModel
ComponentUI
ComponentView
Composite
CompositeContext
CompositeData
CompositeDataInvocationHandler
CompositeDataSupport
CompositeDataView
CompositeName
CompositeType
CompositeView
CompoundBorder
CompoundControl
CompoundControl.Type
CompoundEdit
CompoundName
Compression
ConcurrentHashMap
ConcurrentLinkedQueue
ConcurrentMap
ConcurrentModificationException
ConcurrentNavigableMap
ConcurrentSkipListMap
ConcurrentSkipListSet
Condition
Configuration
Configuration.Parameters
ConfigurationException
ConfigurationSpi
ConfirmationCallback
ConnectException
ConnectException
ConnectIOException
Connection
ConnectionEvent
ConnectionEventListener
ConnectionPendingException
ConnectionPoolDataSource
Console
ConsoleHandler
Constructor
ConstructorProperties
Container
ContainerAdapter
ContainerEvent
ContainerListener
ContainerOrderFocusTraversalPolicy
ContentHandler
ContentHandler
ContentHandlerFactory
ContentModel
Context
Context
ContextList
ContextNotEmptyException
ContextualRenderedImageFactory
Control
Control
Control.Type
ControlFactory
ControllerEventListener
ConvolveOp
CookieHandler
CookieHolder
CookieManager
CookiePolicy
CookieStore
Copies
CopiesSupported
CopyOnWriteArrayList
CopyOnWriteArraySet
CountDownLatch
CounterMonitor
CounterMonitorMBean
CRC32
CredentialException
CredentialExpiredException
CredentialNotFoundException
CRL
CRLException
CRLSelector
CropImageFilter
CSS
CSS.Attribute
CTX_RESTRICT_SCOPE
CubicCurve2D
CubicCurve2D.Double
CubicCurve2D.Float
Currency
CurrencyNameProvider
Current
Current
Current
CurrentHelper
CurrentHelper
CurrentHelper
CurrentHolder
CurrentOperations
CurrentOperations
CurrentOperations
Cursor
Customizer
CustomMarshal
CustomValue
CyclicBarrier
Data
DATA_CONVERSION
DatabaseMetaData
DataBuffer
DataBufferByte
DataBufferDouble
DataBufferFloat
DataBufferInt
DataBufferShort
DataBufferUShort
DataContentHandler
DataContentHandlerFactory
DataFlavor
DataFormatException
DatagramChannel
DatagramPacket
DatagramSocket
DatagramSocketImpl
DatagramSocketImplFactory
DataHandler
DataInput
DataInputStream
DataInputStream
DataLine
DataLine.Info
DataOutput
DataOutputStream
DataOutputStream
DataSource
DataSource
DataTruncation
DatatypeConfigurationException
DatatypeConstants
DatatypeConstants.Field
DatatypeConverter
DatatypeConverterInterface
DatatypeFactory
Date
Date
DateFormat
DateFormat.Field
DateFormatProvider
DateFormatSymbols
DateFormatSymbolsProvider
DateFormatter
DateTimeAtCompleted
DateTimeAtCreation
DateTimeAtProcessing
DateTimeSyntax
DebugGraphics
DecimalFormat
DecimalFormatSymbols
DecimalFormatSymbolsProvider
DeclaredType
DeclHandler
DefaultBoundedRangeModel
DefaultButtonModel
DefaultCaret
DefaultCellEditor
DefaultColorSelectionModel
DefaultComboBoxModel
DefaultDesktopManager
DefaultEditorKit
DefaultEditorKit.BeepAction
DefaultEditorKit.CopyAction
DefaultEditorKit.CutAction
DefaultEditorKit.DefaultKeyTypedAction
DefaultEditorKit.InsertBreakAction
DefaultEditorKit.InsertContentAction
DefaultEditorKit.InsertTabAction
DefaultEditorKit.PasteAction
DefaultFocusManager
DefaultFocusTraversalPolicy
DefaultFormatter
DefaultFormatterFactory
DefaultHandler
DefaultHandler2
DefaultHighlighter
DefaultHighlighter.DefaultHighlightPainter
DefaultKeyboardFocusManager
DefaultListCellRenderer
DefaultListCellRenderer.UIResource
DefaultListModel
DefaultListSelectionModel
DefaultLoaderRepository
DefaultLoaderRepository
DefaultMenuLayout
DefaultMetalTheme
DefaultMutableTreeNode
DefaultPersistenceDelegate
DefaultRowSorter
DefaultRowSorter.ModelWrapper
DefaultSingleSelectionModel
DefaultStyledDocument
DefaultStyledDocument.AttributeUndoableEdit
DefaultStyledDocument.ElementSpec
DefaultTableCellRenderer
DefaultTableCellRenderer.UIResource
DefaultTableColumnModel
DefaultTableModel
DefaultTextUI
DefaultTreeCellEditor
DefaultTreeCellRenderer
DefaultTreeModel
DefaultTreeSelectionModel
DefaultValidationEventHandler
DefinitionKind
DefinitionKindHelper
Deflater
DeflaterInputStream
DeflaterOutputStream
Delayed
DelayQueue
Delegate
Delegate
Delegate
DelegationPermission
Deprecated
Deque
Descriptor
DescriptorAccess
DescriptorKey
DescriptorRead
DescriptorSupport
DESedeKeySpec
DesignMode
DESKeySpec
Desktop
Desktop.Action
DesktopIconUI
DesktopManager
DesktopPaneUI
Destination
Destroyable
DestroyFailedException
Detail
DetailEntry
DGC
DHGenParameterSpec
DHKey
DHParameterSpec
DHPrivateKey
DHPrivateKeySpec
DHPublicKey
DHPublicKeySpec
Diagnostic
Diagnostic.Kind
DiagnosticCollector
DiagnosticListener
Dialog
Dialog.ModalExclusionType
Dialog.ModalityType
Dictionary
DigestException
DigestInputStream
DigestMethod
DigestMethodParameterSpec
DigestOutputStream
Dimension
Dimension2D
DimensionUIResource
DirContext
DirectColorModel
DirectoryManager
DirObjectFactory
DirStateFactory
DirStateFactory.Result
DISCARDING
Dispatch
DisplayMode
DnDConstants
Doc
DocAttribute
DocAttributeSet
DocFlavor
DocFlavor.BYTE_ARRAY
DocFlavor.CHAR_ARRAY
DocFlavor.INPUT_STREAM
DocFlavor.READER
DocFlavor.SERVICE_FORMATTED
DocFlavor.STRING
DocFlavor.URL
DocPrintJob
Document
Document
DocumentBuilder
DocumentBuilderFactory
Documented
DocumentEvent
DocumentEvent
DocumentEvent.ElementChange
DocumentEvent.EventType
DocumentFilter
DocumentFilter.FilterBypass
DocumentFragment
DocumentHandler
DocumentListener
DocumentName
DocumentParser
DocumentType
DomainCombiner
DomainManager
DomainManagerOperations
DOMConfiguration
DOMCryptoContext
DOMError
DOMErrorHandler
DOMException
DomHandler
DOMImplementation
DOMImplementationList
DOMImplementationLS
DOMImplementationRegistry
DOMImplementationSource
DOMLocator
DOMLocator
DOMResult
DOMSignContext
DOMSource
DOMStringList
DOMStructure
DOMURIReference
DOMValidateContext
Double
DoubleBuffer
DoubleHolder
DoubleSeqHelper
DoubleSeqHolder
DragGestureEvent
DragGestureListener
DragGestureRecognizer
DragSource
DragSourceAdapter
DragSourceContext
DragSourceDragEvent
DragSourceDropEvent
DragSourceEvent
DragSourceListener
DragSourceMotionListener
Driver
DriverManager
DriverPropertyInfo
DropMode
DropTarget
DropTarget.DropTargetAutoScroller
DropTargetAdapter
DropTargetContext
DropTargetDragEvent
DropTargetDropEvent
DropTargetEvent
DropTargetListener
DSAKey
DSAKeyPairGenerator
DSAParameterSpec
DSAParams
DSAPrivateKey
DSAPrivateKeySpec
DSAPublicKey
DSAPublicKeySpec
DTD
DTD
DTDConstants
DTDHandler
DuplicateFormatFlagsException
DuplicateName
DuplicateNameHelper
Duration
DynamicImplementation
DynamicImplementation
DynamicMBean
DynAny
DynAny
DynAnyFactory
DynAnyFactoryHelper
DynAnyFactoryOperations
DynAnyHelper
DynAnyOperations
DynAnySeqHelper
DynArray
DynArray
DynArrayHelper
DynArrayOperations
DynEnum
DynEnum
DynEnumHelper
DynEnumOperations
DynFixed
DynFixed
DynFixedHelper
DynFixedOperations
DynSequence
DynSequence
DynSequenceHelper
DynSequenceOperations
DynStruct
DynStruct
DynStructHelper
DynStructOperations
DynUnion
DynUnion
DynUnionHelper
DynUnionOperations
DynValue
DynValue
DynValueBox
DynValueBoxOperations
DynValueCommon
DynValueCommonOperations
DynValueHelper
DynValueOperations
ECField
ECFieldF2m
ECFieldFp
ECGenParameterSpec
ECKey
ECParameterSpec
ECPoint
ECPrivateKey
ECPrivateKeySpec
ECPublicKey
ECPublicKeySpec
EditorKit
Element
Element
Element
Element
Element
ElementFilter
ElementIterator
ElementKind
ElementKindVisitor6
Elements
ElementScanner6
ElementType
ElementVisitor
Ellipse2D
Ellipse2D.Double
Ellipse2D.Float
EllipticCurve
EmptyBorder
EmptyStackException
EncodedKeySpec
Encoder
Encoding
ENCODING_CDR_ENCAPS
EncryptedPrivateKeyInfo
EndDocument
EndElement
Endpoint
Entity
Entity
EntityDeclaration
EntityReference
EntityReference
EntityResolver
EntityResolver2
Enum
EnumConstantNotPresentException
EnumControl
EnumControl.Type
Enumeration
EnumMap
EnumSet
EnumSyntax
Environment
EOFException
Error
ErrorHandler
ErrorListener
ErrorManager
ErrorType
EtchedBorder
Event
Event
EventContext
EventDirContext
EventException
EventFilter
EventHandler
EventListener
EventListener
EventListenerList
EventListenerProxy
EventObject
EventQueue
EventReaderDelegate
EventSetDescriptor
EventTarget
ExcC14NParameterSpec
Exception
ExceptionDetailMessage
ExceptionInInitializerError
ExceptionList
ExceptionListener
Exchanger
ExecutableElement
ExecutableType
ExecutionException
Executor
ExecutorCompletionService
Executors
ExecutorService
ExemptionMechanism
ExemptionMechanismException
ExemptionMechanismSpi
ExpandVetoException
ExportException
Expression
ExtendedRequest
ExtendedResponse
Externalizable
FactoryConfigurationError
FactoryConfigurationError
FailedLoginException
FeatureDescriptor
Fidelity
Field
FieldNameHelper
FieldNameHelper
FieldPosition
FieldView
File
FileCacheImageInputStream
FileCacheImageOutputStream
FileChannel
FileChannel.MapMode
FileChooserUI
FileDataSource
FileDescriptor
FileDialog
FileFilter
FileFilter
FileHandler
FileImageInputStream
FileImageOutputStream
FileInputStream
FileLock
FileLockInterruptionException
FileNameExtensionFilter
FilenameFilter
FileNameMap
FileNotFoundException
FileObject
FileOutputStream
FilePermission
Filer
FileReader
FilerException
FileSystemView
FileTypeMap
FileView
FileWriter
Filter
FilteredImageSource
FilteredRowSet
FilterInputStream
FilterOutputStream
FilterReader
FilterWriter
Finishings
FixedHeightLayoutCache
FixedHolder
FlatteningPathIterator
FlavorEvent
FlavorException
FlavorListener
FlavorMap
FlavorTable
Float
FloatBuffer
FloatControl
FloatControl.Type
FloatHolder
FloatSeqHelper
FloatSeqHolder
FlowLayout
FlowView
FlowView.FlowStrategy
Flushable
FocusAdapter
FocusEvent
FocusListener
FocusManager
FocusTraversalPolicy
Font
FontFormatException
FontMetrics
FontRenderContext
FontUIResource
Format
Format.Field
FormatConversionProvider
FormatFlagsConversionMismatchException
FormatMismatch
FormatMismatchHelper
Formattable
FormattableFlags
Formatter
Formatter
Formatter.BigDecimalLayoutForm
FormatterClosedException
FormSubmitEvent
FormSubmitEvent.MethodType
FormView
ForwardingFileObject
ForwardingJavaFileManager
ForwardingJavaFileObject
ForwardRequest
ForwardRequest
ForwardRequestHelper
ForwardRequestHelper
Frame
FREE_MEM
Future
FutureTask
GapContent
GarbageCollectorMXBean
GatheringByteChannel
GaugeMonitor
GaugeMonitorMBean
GeneralPath
GeneralSecurityException
Generated
GenericArrayType
GenericDeclaration
GenericSignatureFormatError
GlyphJustificationInfo
GlyphMetrics
GlyphVector
GlyphView
GlyphView.GlyphPainter
GradientPaint
GraphicAttribute
Graphics
Graphics2D
GraphicsConfigTemplate
GraphicsConfiguration
GraphicsDevice
GraphicsEnvironment
GrayFilter
GregorianCalendar
GridBagConstraints
GridBagLayout
GridBagLayoutInfo
GridLayout
Group
GroupLayout
GroupLayout.Alignment
GSSContext
GSSCredential
GSSException
GSSManager
GSSName
Guard
GuardedObject
GZIPInputStream
GZIPOutputStream
Handler
Handler
HandlerBase
HandlerChain
HandlerResolver
HandshakeCompletedEvent
HandshakeCompletedListener
HasControls
HashAttributeSet
HashDocAttributeSet
HashMap
HashPrintJobAttributeSet
HashPrintRequestAttributeSet
HashPrintServiceAttributeSet
HashSet
Hashtable
HeadlessException
HexBinaryAdapter
HierarchyBoundsAdapter
HierarchyBoundsListener
HierarchyEvent
HierarchyListener
Highlighter
Highlighter.Highlight
Highlighter.HighlightPainter
HMACParameterSpec
Holder
HOLDING
HostnameVerifier
HTML
HTML.Attribute
HTML.Tag
HTML.UnknownTag
HTMLDocument
HTMLDocument.Iterator
HTMLEditorKit
HTMLEditorKit.HTMLFactory
HTMLEditorKit.HTMLTextAction
HTMLEditorKit.InsertHTMLTextAction
HTMLEditorKit.LinkController
HTMLEditorKit.Parser
HTMLEditorKit.ParserCallback
HTMLFrameHyperlinkEvent
HTMLWriter
HTTPBinding
HttpCookie
HTTPException
HttpRetryException
HttpsURLConnection
HttpURLConnection
HyperlinkEvent
HyperlinkEvent.EventType
HyperlinkListener
ICC_ColorSpace
ICC_Profile
ICC_ProfileGray
ICC_ProfileRGB
Icon
IconUIResource
IconView
ID_ASSIGNMENT_POLICY_ID
ID_UNIQUENESS_POLICY_ID
IdAssignmentPolicy
IdAssignmentPolicyOperations
IdAssignmentPolicyValue
IdentifierHelper
Identity
IdentityHashMap
IdentityScope
IDLEntity
IDLType
IDLTypeHelper
IDLTypeOperations
IDN
IdUniquenessPolicy
IdUniquenessPolicyOperations
IdUniquenessPolicyValue
IIOByteBuffer
IIOException
IIOImage
IIOInvalidTreeException
IIOMetadata
IIOMetadataController
IIOMetadataFormat
IIOMetadataFormatImpl
IIOMetadataNode
IIOParam
IIOParamController
IIOReadProgressListener
IIOReadUpdateListener
IIOReadWarningListener
IIORegistry
IIOServiceProvider
IIOWriteProgressListener
IIOWriteWarningListener
IllegalAccessError
IllegalAccessException
IllegalArgumentException
IllegalBlockingModeException
IllegalBlockSizeException
IllegalCharsetNameException
IllegalClassFormatException
IllegalComponentStateException
IllegalFormatCodePointException
IllegalFormatConversionException
IllegalFormatException
IllegalFormatFlagsException
IllegalFormatPrecisionException
IllegalFormatWidthException
IllegalMonitorStateException
IllegalPathStateException
IllegalSelectorException
IllegalStateException
IllegalThreadStateException
Image
ImageCapabilities
ImageConsumer
ImageFilter
ImageGraphicAttribute
ImageIcon
ImageInputStream
ImageInputStreamImpl
ImageInputStreamSpi
ImageIO
ImageObserver
ImageOutputStream
ImageOutputStreamImpl
ImageOutputStreamSpi
ImageProducer
ImageReader
ImageReaderSpi
ImageReaderWriterSpi
ImageReadParam
ImageTranscoder
ImageTranscoderSpi
ImageTypeSpecifier
ImageView
ImageWriteParam
ImageWriter
ImageWriterSpi
ImagingOpException
ImmutableDescriptor
IMP_LIMIT
IMPLICIT_ACTIVATION_POLICY_ID
ImplicitActivationPolicy
ImplicitActivationPolicyOperations
ImplicitActivationPolicyValue
INACTIVE
IncompatibleClassChangeError
IncompleteAnnotationException
InconsistentTypeCode
InconsistentTypeCode
InconsistentTypeCodeHelper
IndexColorModel
IndexedPropertyChangeEvent
IndexedPropertyDescriptor
IndexOutOfBoundsException
IndirectionException
Inet4Address
Inet6Address
InetAddress
InetSocketAddress
Inflater
InflaterInputStream
InflaterOutputStream
InheritableThreadLocal
Inherited
InitialContext
InitialContextFactory
InitialContextFactoryBuilder
InitialDirContext
INITIALIZE
InitialLdapContext
InitParam
InlineView
InputContext
InputEvent
InputMap
InputMapUIResource
InputMethod
InputMethodContext
InputMethodDescriptor
InputMethodEvent
InputMethodHighlight
InputMethodListener
InputMethodRequests
InputMismatchException
InputSource
InputStream
InputStream
InputStream
InputStreamReader
InputSubset
InputVerifier
Insets
InsetsUIResource
InstanceAlreadyExistsException
InstanceNotFoundException
InstantiationError
InstantiationException
Instrument
Instrumentation
InsufficientResourcesException
IntBuffer
Integer
IntegerSyntax
Interceptor
InterceptorOperations
InterfaceAddress
INTERNAL
InternalError
InternalFrameAdapter
InternalFrameEvent
InternalFrameFocusTraversalPolicy
InternalFrameListener
InternalFrameUI
InternationalFormatter
InterruptedException
InterruptedIOException
InterruptedNamingException
InterruptibleChannel
INTF_REPOS
IntHolder
IntrospectionException
IntrospectionException
Introspector
INV_FLAG
INV_IDENT
INV_OBJREF
INV_POLICY
Invalid
INVALID_ACTIVITY
INVALID_TRANSACTION
InvalidActivityException
InvalidAddress
InvalidAddressHelper
InvalidAddressHolder
InvalidAlgorithmParameterException
InvalidApplicationException
InvalidAttributeIdentifierException
InvalidAttributesException
InvalidAttributeValueException
InvalidAttributeValueException
InvalidClassException
InvalidDnDOperationException
InvalidKeyException
InvalidKeyException
InvalidKeySpecException
InvalidMarkException
InvalidMidiDataException
InvalidName
InvalidName
InvalidName
InvalidNameException
InvalidNameHelper
InvalidNameHelper
InvalidNameHolder
InvalidObjectException
InvalidOpenTypeException
InvalidParameterException
InvalidParameterSpecException
InvalidPolicy
InvalidPolicyHelper
InvalidPreferencesFormatException
InvalidPropertiesFormatException
InvalidRelationIdException
InvalidRelationServiceException
InvalidRelationTypeException
InvalidRoleInfoException
InvalidRoleValueException
InvalidSearchControlsException
InvalidSearchFilterException
InvalidSeq
InvalidSlot
InvalidSlotHelper
InvalidTargetObjectTypeException
InvalidTransactionException
InvalidTypeForEncoding
InvalidTypeForEncodingHelper
InvalidValue
InvalidValue
InvalidValueHelper
Invocable
InvocationEvent
InvocationHandler
InvocationTargetException
InvokeHandler
IOError
IOException
IOR
IORHelper
IORHolder
IORInfo
IORInfoOperations
IORInterceptor
IORInterceptor_3_0
IORInterceptor_3_0Helper
IORInterceptor_3_0Holder
IORInterceptor_3_0Operations
IORInterceptorOperations
IRObject
IRObjectOperations
IstringHelper
ItemEvent
ItemListener
ItemSelectable
Iterable
Iterator
IvParameterSpec
JApplet
JarEntry
JarException
JarFile
JarInputStream
JarOutputStream
JarURLConnection
JavaCompiler
JavaCompiler.CompilationTask
JavaFileManager
JavaFileManager.Location
JavaFileObject
JavaFileObject.Kind
JAXBContext
JAXBElement
JAXBElement.GlobalScope
JAXBException
JAXBIntrospector
JAXBResult
JAXBSource
JButton
JCheckBox
JCheckBoxMenuItem
JColorChooser
JComboBox
JComboBox.KeySelectionManager
JComponent
JdbcRowSet
JDesktopPane
JDialog
JEditorPane
JFileChooser
JFormattedTextField
JFormattedTextField.AbstractFormatter
JFormattedTextField.AbstractFormatterFactory
JFrame
JInternalFrame
JInternalFrame.JDesktopIcon
JLabel
JLayeredPane
JList
JList.DropLocation
JMenu
JMenuBar
JMenuItem
JMException
JMRuntimeException
JMX
JMXAddressable
JMXAuthenticator
JMXConnectionNotification
JMXConnector
JMXConnectorFactory
JMXConnectorProvider
JMXConnectorServer
JMXConnectorServerFactory
JMXConnectorServerMBean
JMXConnectorServerProvider
JMXPrincipal
JMXProviderException
JMXServerErrorException
JMXServiceURL
JobAttributes
JobAttributes.DefaultSelectionType
JobAttributes.DestinationType
JobAttributes.DialogType
JobAttributes.MultipleDocumentHandlingType
JobAttributes.SidesType
JobHoldUntil
JobImpressions
JobImpressionsCompleted
JobImpressionsSupported
JobKOctets
JobKOctetsProcessed
JobKOctetsSupported
JobMediaSheets
JobMediaSheetsCompleted
JobMediaSheetsSupported
JobMessageFromOperator
JobName
JobOriginatingUserName
JobPriority
JobPrioritySupported
JobSheets
JobState
JobStateReason
JobStateReasons
Joinable
JoinRowSet
JOptionPane
JPanel
JPasswordField
JPEGHuffmanTable
JPEGImageReadParam
JPEGImageWriteParam
JPEGQTable
JPopupMenu
JPopupMenu.Separator
JProgressBar
JRadioButton
JRadioButtonMenuItem
JRootPane
JScrollBar
JScrollPane
JSeparator
JSlider
JSpinner
JSpinner.DateEditor
JSpinner.DefaultEditor
JSpinner.ListEditor
JSpinner.NumberEditor
JSplitPane
JTabbedPane
JTable
JTable.DropLocation
JTable.PrintMode
JTableHeader
JTextArea
JTextComponent
JTextComponent.DropLocation
JTextComponent.KeyBinding
JTextField
JTextPane
JToggleButton
JToggleButton.ToggleButtonModel
JToolBar
JToolBar.Separator
JToolTip
JTree
JTree.DropLocation
JTree.DynamicUtilTreeNode
JTree.EmptySelectionModel
JViewport
JWindow
KerberosKey
KerberosPrincipal
KerberosTicket
Kernel
Key
KeyAdapter
KeyAgreement
KeyAgreementSpi
KeyAlreadyExistsException
KeyboardFocusManager
KeyEvent
KeyEventDispatcher
KeyEventPostProcessor
KeyException
KeyFactory
KeyFactorySpi
KeyGenerator
KeyGeneratorSpi
KeyInfo
KeyInfoFactory
KeyListener
KeyManagementException
KeyManager
KeyManagerFactory
KeyManagerFactorySpi
Keymap
KeyName
KeyPair
KeyPairGenerator
KeyPairGeneratorSpi
KeyRep
KeyRep.Type
KeySelector
KeySelector.Purpose
KeySelectorException
KeySelectorResult
KeySpec
KeyStore
KeyStore.Builder
KeyStore.CallbackHandlerProtection
KeyStore.Entry
KeyStore.LoadStoreParameter
KeyStore.PasswordProtection
KeyStore.PrivateKeyEntry
KeyStore.ProtectionParameter
KeyStore.SecretKeyEntry
KeyStore.TrustedCertificateEntry
KeyStoreBuilderParameters
KeyStoreException
KeyStoreSpi
KeyStroke
KeyValue
Label
LabelUI
LabelView
LanguageCallback
LastOwnerException
LayeredHighlighter
LayeredHighlighter.LayerPainter
LayoutFocusTraversalPolicy
LayoutManager
LayoutManager2
LayoutPath
LayoutQueue
LayoutStyle
LayoutStyle.ComponentPlacement
LDAPCertStoreParameters
LdapContext
LdapName
LdapReferralException
Lease
Level
LexicalHandler
LIFESPAN_POLICY_ID
LifespanPolicy
LifespanPolicyOperations
LifespanPolicyValue
LimitExceededException
Line
Line.Info
Line2D
Line2D.Double
Line2D.Float
LinearGradientPaint
LineBorder
LineBreakMeasurer
LineEvent
LineEvent.Type
LineListener
LineMetrics
LineNumberInputStream
LineNumberReader
LineUnavailableException
LinkageError
LinkedBlockingDeque
LinkedBlockingQueue
LinkedHashMap
LinkedHashSet
LinkedList
LinkException
LinkLoopException
LinkRef
List
List
ListCellRenderer
ListDataEvent
ListDataListener
ListenerNotFoundException
ListIterator
ListModel
ListResourceBundle
ListSelectionEvent
ListSelectionListener
ListSelectionModel
ListUI
ListView
LoaderHandler
Locale
LocaleNameProvider
LocaleServiceProvider
LocalObject
LocateRegistry
Location
LOCATION_FORWARD
Locator
Locator2
Locator2Impl
LocatorImpl
Lock
LockInfo
LockSupport
Logger
LoggingMXBean
LoggingPermission
LogicalHandler
LogicalMessage
LogicalMessageContext
LoginContext
LoginException
LoginModule
LogManager
LogRecord
LogStream
Long
LongBuffer
LongHolder
LongLongSeqHelper
LongLongSeqHolder
LongSeqHelper
LongSeqHolder
LookAndFeel
LookupOp
LookupTable
LSException
LSInput
LSLoadEvent
LSOutput
LSParser
LSParserFilter
LSProgressEvent
LSResourceResolver
LSSerializer
LSSerializerFilter
Mac
MacSpi
MailcapCommandMap
MalformedInputException
MalformedLinkException
MalformedObjectNameException
MalformedParameterizedTypeException
MalformedURLException
ManagementFactory
ManagementPermission
ManageReferralControl
ManagerFactoryParameters
Manifest
Manifest
Map
Map.Entry
MappedByteBuffer
MARSHAL
MarshalException
MarshalException
MarshalException
MarshalledObject
Marshaller
Marshaller.Listener
MaskFormatter
Matcher
MatchResult
Math
MathContext
MatteBorder
MBeanAttributeInfo
MBeanConstructorInfo
MBeanException
MBeanFeatureInfo
MBeanInfo
MBeanNotificationInfo
MBeanOperationInfo
MBeanParameterInfo
MBeanPermission
MBeanRegistration
MBeanRegistrationException
MBeanServer
MBeanServerBuilder
MBeanServerConnection
MBeanServerDelegate
MBeanServerDelegateMBean
MBeanServerFactory
MBeanServerForwarder
MBeanServerInvocationHandler
MBeanServerNotification
MBeanServerNotificationFilter
MBeanServerPermission
MBeanTrustPermission
Media
MediaName
MediaPrintableArea
MediaSize
MediaSize.Engineering
MediaSize.ISO
MediaSize.JIS
MediaSize.NA
MediaSize.Other
MediaSizeName
MediaTracker
MediaTray
Member
MemoryCacheImageInputStream
MemoryCacheImageOutputStream
MemoryHandler
MemoryImageSource
MemoryManagerMXBean
MemoryMXBean
MemoryNotificationInfo
MemoryPoolMXBean
MemoryType
MemoryUsage
Menu
MenuBar
MenuBarUI
MenuComponent
MenuContainer
MenuDragMouseEvent
MenuDragMouseListener
MenuElement
MenuEvent
MenuItem
MenuItemUI
MenuKeyEvent
MenuKeyListener
MenuListener
MenuSelectionManager
MenuShortcut
MessageContext
MessageContext.Scope
MessageDigest
MessageDigestSpi
MessageFactory
MessageFormat
MessageFormat.Field
MessageProp
Messager
MetaEventListener
MetalBorders
MetalBorders.ButtonBorder
MetalBorders.Flush3DBorder
MetalBorders.InternalFrameBorder
MetalBorders.MenuBarBorder
MetalBorders.MenuItemBorder
MetalBorders.OptionDialogBorder
MetalBorders.PaletteBorder
MetalBorders.PopupMenuBorder
MetalBorders.RolloverButtonBorder
MetalBorders.ScrollPaneBorder
MetalBorders.TableHeaderBorder
MetalBorders.TextFieldBorder
MetalBorders.ToggleButtonBorder
MetalBorders.ToolBarBorder
MetalButtonUI
MetalCheckBoxIcon
MetalCheckBoxUI
MetalComboBoxButton
MetalComboBoxEditor
MetalComboBoxEditor.UIResource
MetalComboBoxIcon
MetalComboBoxUI
MetalDesktopIconUI
MetalFileChooserUI
MetalIconFactory
MetalIconFactory.FileIcon16
MetalIconFactory.FolderIcon16
MetalIconFactory.PaletteCloseIcon
MetalIconFactory.TreeControlIcon
MetalIconFactory.TreeFolderIcon
MetalIconFactory.TreeLeafIcon
MetalInternalFrameTitlePane
MetalInternalFrameUI
MetalLabelUI
MetalLookAndFeel
MetalMenuBarUI
MetalPopupMenuSeparatorUI
MetalProgressBarUI
MetalRadioButtonUI
MetalRootPaneUI
MetalScrollBarUI
MetalScrollButton
MetalScrollPaneUI
MetalSeparatorUI
MetalSliderUI
MetalSplitPaneUI
MetalTabbedPaneUI
MetalTextFieldUI
MetalTheme
MetalToggleButtonUI
MetalToolBarUI
MetalToolTipUI
MetalTreeUI
MetaMessage
Method
MethodDescriptor
MGF1ParameterSpec
MidiChannel
MidiDevice
MidiDevice.Info
MidiDeviceProvider
MidiEvent
MidiFileFormat
MidiFileReader
MidiFileWriter
MidiMessage
MidiSystem
MidiUnavailableException
MimeHeader
MimeHeaders
MimeType
MimeTypeParameterList
MimeTypeParseException
MimeTypeParseException
MimetypesFileTypeMap
MinimalHTMLWriter
MirroredTypeException
MirroredTypesException
MissingFormatArgumentException
MissingFormatWidthException
MissingResourceException
Mixer
Mixer.Info
MixerProvider
MLet
MLetContent
MLetMBean
ModelMBean
ModelMBeanAttributeInfo
ModelMBeanConstructorInfo
ModelMBeanInfo
ModelMBeanInfoSupport
ModelMBeanNotificationBroadcaster
ModelMBeanNotificationInfo
ModelMBeanOperationInfo
ModificationItem
Modifier
Modifier
Monitor
MonitorInfo
MonitorMBean
MonitorNotification
MonitorSettingException
MouseAdapter
MouseDragGestureRecognizer
MouseEvent
MouseEvent
MouseInfo
MouseInputAdapter
MouseInputListener
MouseListener
MouseMotionAdapter
MouseMotionListener
MouseWheelEvent
MouseWheelListener
MultiButtonUI
MulticastSocket
MultiColorChooserUI
MultiComboBoxUI
MultiDesktopIconUI
MultiDesktopPaneUI
MultiDoc
MultiDocPrintJob
MultiDocPrintService
MultiFileChooserUI
MultiInternalFrameUI
MultiLabelUI
MultiListUI
MultiLookAndFeel
MultiMenuBarUI
MultiMenuItemUI
MultiOptionPaneUI
MultiPanelUI
MultiPixelPackedSampleModel
MultipleComponentProfileHelper
MultipleComponentProfileHolder
MultipleDocumentHandling
MultipleGradientPaint
MultipleGradientPaint.ColorSpaceType
MultipleGradientPaint.CycleMethod
MultipleMaster
MultiPopupMenuUI
MultiProgressBarUI
MultiRootPaneUI
MultiScrollBarUI
MultiScrollPaneUI
MultiSeparatorUI
MultiSliderUI
MultiSpinnerUI
MultiSplitPaneUI
MultiTabbedPaneUI
MultiTableHeaderUI
MultiTableUI
MultiTextUI
MultiToolBarUI
MultiToolTipUI
MultiTreeUI
MultiViewportUI
MutableAttributeSet
MutableComboBoxModel
MutableTreeNode
MutationEvent
MXBean
Name
Name
Name
NameAlreadyBoundException
NameCallback
NameClassPair
NameComponent
NameComponentHelper
NameComponentHolder
NamedNodeMap
NamedValue
NameDynAnyPair
NameDynAnyPairHelper
NameDynAnyPairSeqHelper
NameHelper
NameHolder
NameList
NameNotFoundException
NameParser
Namespace
NamespaceChangeListener
NamespaceContext
NamespaceSupport
NameValuePair
NameValuePair
NameValuePairHelper
NameValuePairHelper
NameValuePairSeqHelper
Naming
NamingContext
NamingContextExt
NamingContextExtHelper
NamingContextExtHolder
NamingContextExtOperations
NamingContextExtPOA
NamingContextHelper
NamingContextHolder
NamingContextOperations
NamingContextPOA
NamingEnumeration
NamingEvent
NamingException
NamingExceptionEvent
NamingListener
NamingManager
NamingSecurityException
NavigableMap
NavigableSet
NavigationFilter
NavigationFilter.FilterBypass
NClob
NegativeArraySizeException
NestingKind
NetPermission
NetworkInterface
NO_IMPLEMENT
NO_MEMORY
NO_PERMISSION
NO_RESOURCES
NO_RESPONSE
NoClassDefFoundError
NoConnectionPendingException
NoContext
NoContextHelper
Node
Node
NodeChangeEvent
NodeChangeListener
NodeList
NodeSetData
NoInitialContextException
NON_EXISTENT
NoninvertibleTransformException
NonReadableChannelException
NonWritableChannelException
NoPermissionException
NormalizedStringAdapter
Normalizer
Normalizer.Form
NoRouteToHostException
NoServant
NoServantHelper
NoSuchAlgorithmException
NoSuchAttributeException
NoSuchElementException
NoSuchFieldError
NoSuchFieldException
NoSuchMechanismException
NoSuchMethodError
NoSuchMethodException
NoSuchObjectException
NoSuchPaddingException
NoSuchProviderException
NotActiveException
Notation
NotationDeclaration
NotBoundException
NotCompliantMBeanException
NotContextException
NotEmpty
NotEmptyHelper
NotEmptyHolder
NotFound
NotFoundHelper
NotFoundHolder
NotFoundReason
NotFoundReasonHelper
NotFoundReasonHolder
NotIdentifiableEvent
NotIdentifiableEventImpl
Notification
NotificationBroadcaster
NotificationBroadcasterSupport
NotificationEmitter
NotificationFilter
NotificationFilterSupport
NotificationListener
NotificationResult
NotOwnerException
NotSerializableException
NotYetBoundException
NotYetConnectedException
NoType
NullCipher
NullPointerException
NullType
Number
NumberFormat
NumberFormat.Field
NumberFormatException
NumberFormatProvider
NumberFormatter
NumberOfDocuments
NumberOfInterveningJobs
NumberUp
NumberUpSupported
NumericShaper
NVList
OAEPParameterSpec
OBJ_ADAPTER
Object
Object
OBJECT_NOT_EXIST
ObjectAlreadyActive
ObjectAlreadyActiveHelper
ObjectChangeListener
ObjectFactory
ObjectFactoryBuilder
ObjectHelper
ObjectHolder
ObjectIdHelper
ObjectIdHelper
ObjectImpl
ObjectImpl
ObjectInput
ObjectInputStream
ObjectInputStream.GetField
ObjectInputValidation
ObjectInstance
ObjectName
ObjectNotActive
ObjectNotActiveHelper
ObjectOutput
ObjectOutputStream
ObjectOutputStream.PutField
ObjectReferenceFactory
ObjectReferenceFactoryHelper
ObjectReferenceFactoryHolder
ObjectReferenceTemplate
ObjectReferenceTemplateHelper
ObjectReferenceTemplateHolder
ObjectReferenceTemplateSeqHelper
ObjectReferenceTemplateSeqHolder
ObjectStreamClass
ObjectStreamConstants
ObjectStreamException
ObjectStreamField
ObjectView
ObjID
Observable
Observer
OceanTheme
OctetSeqHelper
OctetSeqHolder
OctetStreamData
Oid
OMGVMCID
Oneway
OpenDataException
OpenMBeanAttributeInfo
OpenMBeanAttributeInfoSupport
OpenMBeanConstructorInfo
OpenMBeanConstructorInfoSupport
OpenMBeanInfo
OpenMBeanInfoSupport
OpenMBeanOperationInfo
OpenMBeanOperationInfoSupport
OpenMBeanParameterInfo
OpenMBeanParameterInfoSupport
OpenType
OpenType
OperatingSystemMXBean
Operation
OperationNotSupportedException
OperationsException
Option
OptionalDataException
OptionChecker
OptionPaneUI
ORB
ORB
ORBIdHelper
ORBInitializer
ORBInitializerOperations
ORBInitInfo
ORBInitInfoOperations
OrientationRequested
OutOfMemoryError
OutputDeviceAssigned
OutputKeys
OutputStream
OutputStream
OutputStream
OutputStreamWriter
OverlappingFileLockException
OverlayLayout
Override
Owner
Pack200
Pack200.Packer
Pack200.Unpacker
Package
PackageElement
PackedColorModel
Pageable
PageAttributes
PageAttributes.ColorType
PageAttributes.MediaType
PageAttributes.OrientationRequestedType
PageAttributes.OriginType
PageAttributes.PrintQualityType
PagedResultsControl
PagedResultsResponseControl
PageFormat
PageRanges
PagesPerMinute
PagesPerMinuteColor
Paint
PaintContext
PaintEvent
Panel
PanelUI
Paper
ParagraphView
ParagraphView
Parameter
ParameterBlock
ParameterDescriptor
ParameterizedType
ParameterMetaData
ParameterMode
ParameterModeHelper
ParameterModeHolder
ParseConversionEvent
ParseConversionEventImpl
ParseException
ParsePosition
Parser
Parser
ParserAdapter
ParserConfigurationException
ParserDelegator
ParserFactory
PartialResultException
PasswordAuthentication
PasswordCallback
PasswordView
Patch
Path2D
Path2D.Double
Path2D.Float
PathIterator
Pattern
PatternSyntaxException
PBEKey
PBEKeySpec
PBEParameterSpec
PDLOverrideSupported
Permission
Permission
PermissionCollection
Permissions
PERSIST_STORE
PersistenceDelegate
PersistentMBean
PGPData
PhantomReference
Pipe
Pipe.SinkChannel
Pipe.SourceChannel
PipedInputStream
PipedOutputStream
PipedReader
PipedWriter
PixelGrabber
PixelInterleavedSampleModel
PKCS8EncodedKeySpec
PKIXBuilderParameters
PKIXCertPathBuilderResult
PKIXCertPathChecker
PKIXCertPathValidatorResult
PKIXParameters
PlainDocument
PlainView
POA
POAHelper
POAManager
POAManagerOperations
POAOperations
Point
Point2D
Point2D.Double
Point2D.Float
PointerInfo
Policy
Policy
Policy
Policy.Parameters
PolicyError
PolicyErrorCodeHelper
PolicyErrorHelper
PolicyErrorHolder
PolicyFactory
PolicyFactoryOperations
PolicyHelper
PolicyHolder
PolicyListHelper
PolicyListHolder
PolicyNode
PolicyOperations
PolicyQualifierInfo
PolicySpi
PolicyTypeHelper
Polygon
PooledConnection
Popup
PopupFactory
PopupMenu
PopupMenuEvent
PopupMenuListener
PopupMenuUI
Port
Port.Info
PortableRemoteObject
PortableRemoteObjectDelegate
PortInfo
PortUnreachableException
Position
Position.Bias
PostConstruct
PreDestroy
Predicate
PreferenceChangeEvent
PreferenceChangeListener
Preferences
PreferencesFactory
PreparedStatement
PresentationDirection
PrimitiveType
Principal
Principal
PrincipalHolder
Printable
PrintConversionEvent
PrintConversionEventImpl
PrinterAbortException
PrinterException
PrinterGraphics
PrinterInfo
PrinterIOException
PrinterIsAcceptingJobs
PrinterJob
PrinterLocation
PrinterMakeAndModel
PrinterMessageFromOperator
PrinterMoreInfo
PrinterMoreInfoManufacturer
PrinterName
PrinterResolution
PrinterState
PrinterStateReason
PrinterStateReasons
PrinterURI
PrintEvent
PrintException
PrintGraphics
PrintJob
PrintJobAdapter
PrintJobAttribute
PrintJobAttributeEvent
PrintJobAttributeListener
PrintJobAttributeSet
PrintJobEvent
PrintJobListener
PrintQuality
PrintRequestAttribute
PrintRequestAttributeSet
PrintService
PrintServiceAttribute
PrintServiceAttributeEvent
PrintServiceAttributeListener
PrintServiceAttributeSet
PrintServiceLookup
PrintStream
PrintWriter
PriorityBlockingQueue
PriorityQueue
PRIVATE_MEMBER
PrivateClassLoader
PrivateCredentialPermission
PrivateKey
PrivateMLet
PrivilegedAction
PrivilegedActionException
PrivilegedExceptionAction
Process
ProcessBuilder
ProcessingEnvironment
ProcessingInstruction
ProcessingInstruction
Processor
ProfileDataException
ProfileIdHelper
ProgressBarUI
ProgressMonitor
ProgressMonitorInputStream
Properties
PropertyChangeEvent
PropertyChangeListener
PropertyChangeListenerProxy
PropertyChangeSupport
PropertyDescriptor
PropertyEditor
PropertyEditorManager
PropertyEditorSupport
PropertyException
PropertyPermission
PropertyResourceBundle
PropertyVetoException
ProtectionDomain
ProtocolException
ProtocolException
Provider
Provider
Provider
Provider.Service
ProviderException
Proxy
Proxy
Proxy.Type
ProxySelector
PSource
PSource.PSpecified
PSSParameterSpec
PUBLIC_MEMBER
PublicKey
PushbackInputStream
PushbackReader
QName
QuadCurve2D
QuadCurve2D.Double
QuadCurve2D.Float
Query
QueryEval
QueryExp
Queue
QueuedJobCount
RadialGradientPaint
Random
RandomAccess
RandomAccessFile
Raster
RasterFormatException
RasterOp
RC2ParameterSpec
RC5ParameterSpec
Rdn
Readable
ReadableByteChannel
Reader
ReadOnlyBufferException
ReadWriteLock
RealmCallback
RealmChoiceCallback
REBIND
Receiver
Rectangle
Rectangle2D
Rectangle2D.Double
Rectangle2D.Float
RectangularShape
ReentrantLock
ReentrantReadWriteLock
ReentrantReadWriteLock.ReadLock
ReentrantReadWriteLock.WriteLock
Ref
RefAddr
Reference
Reference
Reference
Referenceable
ReferenceQueue
ReferenceType
ReferenceUriSchemesSupported
ReferralException
ReflectionException
ReflectPermission
Refreshable
RefreshFailedException
Region
RegisterableService
Registry
RegistryHandler
RejectedExecutionException
RejectedExecutionHandler
Relation
RelationException
RelationNotFoundException
RelationNotification
RelationService
RelationServiceMBean
RelationServiceNotRegisteredException
RelationSupport
RelationSupportMBean
RelationType
RelationTypeNotFoundException
RelationTypeSupport
RemarshalException
Remote
RemoteCall
RemoteException
RemoteObject
RemoteObjectInvocationHandler
RemoteRef
RemoteServer
RemoteStub
RenderableImage
RenderableImageOp
RenderableImageProducer
RenderContext
RenderedImage
RenderedImageFactory
Renderer
RenderingHints
RenderingHints.Key
RepaintManager
ReplicateScaleFilter
RepositoryIdHelper
Request
REQUEST_PROCESSING_POLICY_ID
RequestInfo
RequestInfoOperations
RequestingUserName
RequestProcessingPolicy
RequestProcessingPolicyOperations
RequestProcessingPolicyValue
RequestWrapper
RequiredModelMBean
RescaleOp
ResolutionSyntax
Resolver
ResolveResult
Resource
Resource.AuthenticationType
ResourceBundle
ResourceBundle.Control
Resources
Response
ResponseCache
ResponseHandler
ResponseWrapper
Result
ResultSet
ResultSetMetaData
Retention
RetentionPolicy
RetrievalMethod
ReverbType
RGBImageFilter
RMIClassLoader
RMIClassLoaderSpi
RMIClientSocketFactory
RMIConnection
RMIConnectionImpl
RMIConnectionImpl_Stub
RMIConnector
RMIConnectorServer
RMICustomMaxStreamFormat
RMIFailureHandler
RMIIIOPServerImpl
RMIJRMPServerImpl
RMISecurityException
RMISecurityManager
RMIServer
RMIServerImpl
RMIServerImpl_Stub
RMIServerSocketFactory
RMISocketFactory
Robot
Role
RoleInfo
RoleInfoNotFoundException
RoleList
RoleNotFoundException
RoleResult
RoleStatus
RoleUnresolved
RoleUnresolvedList
RootPaneContainer
RootPaneUI
RoundEnvironment
RoundingMode
RoundRectangle2D
RoundRectangle2D.Double
RoundRectangle2D.Float
RowFilter
RowFilter.ComparisonType
RowFilter.Entry
RowId
RowIdLifetime
RowMapper
RowSet
RowSetEvent
RowSetInternal
RowSetListener
RowSetMetaData
RowSetMetaDataImpl
RowSetReader
RowSetWarning
RowSetWriter
RowSorter
RowSorter.SortKey
RowSorterEvent
RowSorterEvent.Type
RowSorterListener
RSAKey
RSAKeyGenParameterSpec
RSAMultiPrimePrivateCrtKey
RSAMultiPrimePrivateCrtKeySpec
RSAOtherPrimeInfo
RSAPrivateCrtKey
RSAPrivateCrtKeySpec
RSAPrivateKey
RSAPrivateKeySpec
RSAPublicKey
RSAPublicKeySpec
RTFEditorKit
RuleBasedCollator
Runnable
RunnableFuture
RunnableScheduledFuture
Runtime
RunTime
RuntimeErrorException
RuntimeException
RuntimeMBeanException
RuntimeMXBean
RunTimeOperations
RuntimeOperationsException
RuntimePermission
SAAJMetaFactory
SAAJResult
SampleModel
Sasl
SaslClient
SaslClientFactory
SaslException
SaslServer
SaslServerFactory
Savepoint
SAXException
SAXNotRecognizedException
SAXNotSupportedException
SAXParseException
SAXParser
SAXParserFactory
SAXResult
SAXSource
SAXTransformerFactory
Scanner
ScatteringByteChannel
ScheduledExecutorService
ScheduledFuture
ScheduledThreadPoolExecutor
Schema
SchemaFactory
SchemaFactoryLoader
SchemaOutputResolver
SchemaViolationException
ScriptContext
ScriptEngine
ScriptEngineFactory
ScriptEngineManager
ScriptException
Scrollable
Scrollbar
ScrollBarUI
ScrollPane
ScrollPaneAdjustable
ScrollPaneConstants
ScrollPaneLayout
ScrollPaneLayout.UIResource
ScrollPaneUI
SealedObject
SearchControls
SearchResult
SecretKey
SecretKeyFactory
SecretKeyFactorySpi
SecretKeySpec
SecureCacheResponse
SecureClassLoader
SecureRandom
SecureRandomSpi
Security
SecurityException
SecurityManager
SecurityPermission
Segment
SelectableChannel
SelectionKey
Selector
SelectorProvider
Semaphore
SeparatorUI
Sequence
SequenceInputStream
Sequencer
Sequencer.SyncMode
SerialArray
SerialBlob
SerialClob
SerialDatalink
SerialException
Serializable
SerializablePermission
SerialJavaObject
SerialRef
SerialStruct
Servant
SERVANT_RETENTION_POLICY_ID
ServantActivator
ServantActivatorHelper
ServantActivatorOperations
ServantActivatorPOA
ServantAlreadyActive
ServantAlreadyActiveHelper
ServantLocator
ServantLocatorHelper
ServantLocatorOperations
ServantLocatorPOA
ServantManager
ServantManagerOperations
ServantNotActive
ServantNotActiveHelper
ServantObject
ServantRetentionPolicy
ServantRetentionPolicyOperations
ServantRetentionPolicyValue
ServerCloneException
ServerError
ServerException
ServerIdHelper
ServerNotActiveException
ServerRef
ServerRequest
ServerRequestInfo
ServerRequestInfoOperations
ServerRequestInterceptor
ServerRequestInterceptorOperations
ServerRuntimeException
ServerSocket
ServerSocketChannel
ServerSocketFactory
Service
Service.Mode
ServiceConfigurationError
ServiceContext
ServiceContextHelper
ServiceContextHolder
ServiceContextListHelper
ServiceContextListHolder
ServiceDelegate
ServiceDetail
ServiceDetailHelper
ServiceIdHelper
ServiceInformation
ServiceInformationHelper
ServiceInformationHolder
ServiceLoader
ServiceMode
ServiceNotFoundException
ServicePermission
ServiceRegistry
ServiceRegistry.Filter
ServiceUI
ServiceUIFactory
ServiceUnavailableException
Set
SetOfIntegerSyntax
SetOverrideType
SetOverrideTypeHelper
Severity
Shape
ShapeGraphicAttribute
SheetCollate
Short
ShortBuffer
ShortBufferException
ShortHolder
ShortLookupTable
ShortMessage
ShortSeqHelper
ShortSeqHolder
Sides
Signature
SignatureException
SignatureMethod
SignatureMethodParameterSpec
SignatureProperties
SignatureProperty
SignatureSpi
SignedInfo
SignedObject
Signer
SimpleAnnotationValueVisitor6
SimpleAttributeSet
SimpleBeanInfo
SimpleBindings
SimpleDateFormat
SimpleDoc
SimpleElementVisitor6
SimpleFormatter
SimpleJavaFileObject
SimpleScriptContext
SimpleTimeZone
SimpleType
SimpleTypeVisitor6
SinglePixelPackedSampleModel
SingleSelectionModel
Size2DSyntax
SizeLimitExceededException
SizeRequirements
SizeSequence
Skeleton
SkeletonMismatchException
SkeletonNotFoundException
SliderUI
SOAPBinding
SOAPBinding
SOAPBinding.ParameterStyle
SOAPBinding.Style
SOAPBinding.Use
SOAPBody
SOAPBodyElement
SOAPConnection
SOAPConnectionFactory
SOAPConstants
SOAPElement
SOAPElementFactory
SOAPEnvelope
SOAPException
SOAPFactory
SOAPFault
SOAPFaultElement
SOAPFaultException
SOAPHandler
SOAPHeader
SOAPHeaderElement
SOAPMessage
SOAPMessageContext
SOAPMessageHandler
SOAPMessageHandlers
SOAPPart
Socket
SocketAddress
SocketChannel
SocketException
SocketFactory
SocketHandler
SocketImpl
SocketImplFactory
SocketOptions
SocketPermission
SocketSecurityException
SocketTimeoutException
SoftBevelBorder
SoftReference
SortControl
SortedMap
SortedSet
SortingFocusTraversalPolicy
SortKey
SortOrder
SortResponseControl
Soundbank
SoundbankReader
SoundbankResource
Source
SourceDataLine
SourceLocator
SourceVersion
SpinnerDateModel
SpinnerListModel
SpinnerModel
SpinnerNumberModel
SpinnerUI
SplashScreen
SplitPaneUI
Spring
SpringLayout
SpringLayout.Constraints
SQLClientInfoException
SQLData
SQLDataException
SQLException
SQLFeatureNotSupportedException
SQLInput
SQLInputImpl
SQLIntegrityConstraintViolationException
SQLInvalidAuthorizationSpecException
SQLNonTransientConnectionException
SQLNonTransientException
SQLOutput
SQLOutputImpl
SQLPermission
SQLRecoverableException
SQLSyntaxErrorException
SQLTimeoutException
SQLTransactionRollbackException
SQLTransientConnectionException
SQLTransientException
SQLWarning
SQLXML
SSLContext
SSLContextSpi
SSLEngine
SSLEngineResult
SSLEngineResult.HandshakeStatus
SSLEngineResult.Status
SSLException
SSLHandshakeException
SSLKeyException
SSLParameters
SSLPeerUnverifiedException
SSLPermission
SSLProtocolException
SslRMIClientSocketFactory
SslRMIServerSocketFactory
SSLServerSocket
SSLServerSocketFactory
SSLSession
SSLSessionBindingEvent
SSLSessionBindingListener
SSLSessionContext
SSLSocket
SSLSocketFactory
Stack
StackOverflowError
StackTraceElement
StandardEmitterMBean
StandardJavaFileManager
StandardLocation
StandardMBean
StartDocument
StartElement
StartTlsRequest
StartTlsResponse
State
StateEdit
StateEditable
StateFactory
Statement
Statement
StatementEvent
StatementEventListener
StAXResult
StAXSource
Streamable
StreamableValue
StreamCorruptedException
StreamFilter
StreamHandler
StreamPrintService
StreamPrintServiceFactory
StreamReaderDelegate
StreamResult
StreamSource
StreamTokenizer
StrictMath
String
StringBuffer
StringBufferInputStream
StringBuilder
StringCharacterIterator
StringContent
StringHolder
StringIndexOutOfBoundsException
StringMonitor
StringMonitorMBean
StringNameHelper
StringReader
StringRefAddr
StringSelection
StringSeqHelper
StringSeqHolder
StringTokenizer
StringValueExp
StringValueHelper
StringWriter
Stroke
Struct
StructMember
StructMemberHelper
Stub
StubDelegate
StubNotFoundException
Style
StyleConstants
StyleConstants.CharacterConstants
StyleConstants.ColorConstants
StyleConstants.FontConstants
StyleConstants.ParagraphConstants
StyleContext
StyledDocument
StyledEditorKit
StyledEditorKit.AlignmentAction
StyledEditorKit.BoldAction
StyledEditorKit.FontFamilyAction
StyledEditorKit.FontSizeAction
StyledEditorKit.ForegroundAction
StyledEditorKit.ItalicAction
StyledEditorKit.StyledTextAction
StyledEditorKit.UnderlineAction
StyleSheet
StyleSheet.BoxPainter
StyleSheet.ListPainter
Subject
SubjectDelegationPermission
SubjectDomainCombiner
SUCCESSFUL
SupportedAnnotationTypes
SupportedOptions
SupportedSourceVersion
SupportedValuesAttribute
SuppressWarnings
SwingConstants
SwingPropertyChangeSupport
SwingUtilities
SwingWorker
SwingWorker.StateValue
SYNC_WITH_TRANSPORT
SyncFactory
SyncFactoryException
SyncFailedException
SynchronousQueue
SyncProvider
SyncProviderException
SyncResolver
SyncScopeHelper
SynthConstants
SynthContext
Synthesizer
SynthGraphicsUtils
SynthLookAndFeel
SynthPainter
SynthStyle
SynthStyleFactory
SysexMessage
System
SYSTEM_EXCEPTION
SystemColor
SystemException
SystemFlavorMap
SystemTray
TabableView
TabbedPaneUI
TabExpander
TableCellEditor
TableCellRenderer
TableColumn
TableColumnModel
TableColumnModelEvent
TableColumnModelListener
TableHeaderUI
TableModel
TableModelEvent
TableModelListener
TableRowSorter
TableStringConverter
TableUI
TableView
TabSet
TabStop
TabularData
TabularDataSupport
TabularType
TAG_ALTERNATE_IIOP_ADDRESS
TAG_CODE_SETS
TAG_INTERNET_IOP
TAG_JAVA_CODEBASE
TAG_MULTIPLE_COMPONENTS
TAG_ORB_TYPE
TAG_POLICIES
TAG_RMI_CUSTOM_MAX_STREAM_FORMAT
TagElement
TaggedComponent
TaggedComponentHelper
TaggedComponentHolder
TaggedProfile
TaggedProfileHelper
TaggedProfileHolder
Target
TargetDataLine
TargetedNotification
TCKind
Templates
TemplatesHandler
Text
Text
TextAction
TextArea
TextAttribute
TextComponent
TextEvent
TextField
TextHitInfo
TextInputCallback
TextLayout
TextLayout.CaretPolicy
TextListener
TextMeasurer
TextOutputCallback
TextSyntax
TextUI
TexturePaint
Thread
Thread.State
Thread.UncaughtExceptionHandler
THREAD_POLICY_ID
ThreadDeath
ThreadFactory
ThreadGroup
ThreadInfo
ThreadLocal
ThreadMXBean
ThreadPolicy
ThreadPolicyOperations
ThreadPolicyValue
ThreadPoolExecutor
ThreadPoolExecutor.AbortPolicy
ThreadPoolExecutor.CallerRunsPolicy
ThreadPoolExecutor.DiscardOldestPolicy
ThreadPoolExecutor.DiscardPolicy
Throwable
Tie
TileObserver
Time
TimeLimitExceededException
TIMEOUT
TimeoutException
Timer
Timer
Timer
TimerMBean
TimerNotification
TimerTask
Timestamp
Timestamp
TimeUnit
TimeZone
TimeZoneNameProvider
TitledBorder
Tool
ToolBarUI
Toolkit
ToolProvider
ToolTipManager
ToolTipUI
TooManyListenersException
Track
TRANSACTION_MODE
TRANSACTION_REQUIRED
TRANSACTION_ROLLEDBACK
TRANSACTION_UNAVAILABLE
TransactionalWriter
TransactionRequiredException
TransactionRolledbackException
TransactionService
Transferable
TransferHandler
TransferHandler.DropLocation
TransferHandler.TransferSupport
Transform
TransformAttribute
Transformer
TransformerConfigurationException
TransformerException
TransformerFactory
TransformerFactoryConfigurationError
TransformerHandler
TransformException
TransformParameterSpec
TransformService
TRANSIENT
Transmitter
Transparency
TRANSPORT_RETRY
TrayIcon
TrayIcon.MessageType
TreeCellEditor
TreeCellRenderer
TreeExpansionEvent
TreeExpansionListener
TreeMap
TreeModel
TreeModelEvent
TreeModelListener
TreeNode
TreePath
TreeSelectionEvent
TreeSelectionListener
TreeSelectionModel
TreeSet
TreeUI
TreeWillExpandListener
TrustAnchor
TrustManager
TrustManagerFactory
TrustManagerFactorySpi
Type
TypeCode
TypeCodeHolder
TypeConstraintException
TypeElement
TypeInfo
TypeInfoProvider
TypeKind
TypeKindVisitor6
TypeMirror
TypeMismatch
TypeMismatch
TypeMismatch
TypeMismatchHelper
TypeMismatchHelper
TypeNotPresentException
TypeParameterElement
Types
Types
TypeVariable
TypeVariable
TypeVisitor
UID
UIDefaults
UIDefaults.ActiveValue
UIDefaults.LazyInputMap
UIDefaults.LazyValue
UIDefaults.ProxyLazyValue
UIEvent
UIManager
UIManager.LookAndFeelInfo
UIResource
ULongLongSeqHelper
ULongLongSeqHolder
ULongSeqHelper
ULongSeqHolder
UndeclaredThrowableException
UndoableEdit
UndoableEditEvent
UndoableEditListener
UndoableEditSupport
UndoManager
UnexpectedException
UnicastRemoteObject
UnionMember
UnionMemberHelper
UNKNOWN
UNKNOWN
UnknownAnnotationValueException
UnknownElementException
UnknownEncoding
UnknownEncodingHelper
UnknownError
UnknownException
UnknownFormatConversionException
UnknownFormatFlagsException
UnknownGroupException
UnknownHostException
UnknownHostException
UnknownObjectException
UnknownServiceException
UnknownTypeException
UnknownUserException
UnknownUserExceptionHelper
UnknownUserExceptionHolder
UnmappableCharacterException
UnmarshalException
UnmarshalException
Unmarshaller
Unmarshaller.Listener
UnmarshallerHandler
UnmodifiableClassException
UnmodifiableSetException
UnrecoverableEntryException
UnrecoverableKeyException
Unreferenced
UnresolvedAddressException
UnresolvedPermission
UnsatisfiedLinkError
UnsolicitedNotification
UnsolicitedNotificationEvent
UnsolicitedNotificationListener
UNSUPPORTED_POLICY
UNSUPPORTED_POLICY_VALUE
UnsupportedAddressTypeException
UnsupportedAudioFileException
UnsupportedCallbackException
UnsupportedCharsetException
UnsupportedClassVersionError
UnsupportedDataTypeException
UnsupportedEncodingException
UnsupportedFlavorException
UnsupportedLookAndFeelException
UnsupportedOperationException
URI
URIDereferencer
URIException
URIParameter
URIReference
URIReferenceException
URIResolver
URISyntax
URISyntaxException
URL
URLClassLoader
URLConnection
URLDataSource
URLDecoder
URLEncoder
URLStreamHandler
URLStreamHandlerFactory
URLStringHelper
USER_EXCEPTION
UserDataHandler
UserException
UShortSeqHelper
UShortSeqHolder
UTFDataFormatException
Util
UtilDelegate
Utilities
UUID
ValidationEvent
ValidationEventCollector
ValidationEventHandler
ValidationEventImpl
ValidationEventLocator
ValidationEventLocatorImpl
ValidationException
Validator
Validator
ValidatorHandler
ValueBase
ValueBaseHelper
ValueBaseHolder
ValueExp
ValueFactory
ValueHandler
ValueHandlerMultiFormat
ValueInputStream
ValueMember
ValueMemberHelper
ValueOutputStream
VariableElement
VariableHeightLayoutCache
Vector
VerifyError
VersionSpecHelper
VetoableChangeListener
VetoableChangeListenerProxy
VetoableChangeSupport
View
ViewFactory
ViewportLayout
ViewportUI
VirtualMachineError
Visibility
VisibilityHelper
VM_ABSTRACT
VM_CUSTOM
VM_NONE
VM_TRUNCATABLE
VMID
VoiceStatus
Void
VolatileImage
W3CDomHandler
WCharSeqHelper
WCharSeqHolder
WeakHashMap
WeakReference
WebEndpoint
WebFault
WebMethod
WebParam
WebParam.Mode
WebResult
WebRowSet
WebService
WebServiceClient
WebServiceContext
WebServiceException
WebServicePermission
WebServiceProvider
WebServiceRef
WebServiceRefs
WildcardType
WildcardType
Window
WindowAdapter
WindowConstants
WindowEvent
WindowFocusListener
WindowListener
WindowStateListener
WrappedPlainView
Wrapper
WritableByteChannel
WritableRaster
WritableRenderedImage
WriteAbortedException
Writer
WrongAdapter
WrongAdapterHelper
WrongPolicy
WrongPolicyHelper
WrongTransaction
WrongTransactionHelper
WrongTransactionHolder
WStringSeqHelper
WStringSeqHolder
WStringValueHelper
X500Principal
X500PrivateCredential
X509Certificate
X509Certificate
X509CertSelector
X509CRL
X509CRLEntry
X509CRLSelector
X509Data
X509EncodedKeySpec
X509ExtendedKeyManager
X509Extension
X509IssuerSerial
X509KeyManager
X509TrustManager
XAConnection
XADataSource
XAException
XAResource
Xid
XmlAccessOrder
XmlAccessorOrder
XmlAccessorType
XmlAccessType
XmlAdapter
XmlAnyAttribute
XmlAnyElement
XmlAttachmentRef
XmlAttribute
XMLConstants
XMLCryptoContext
XMLDecoder
XmlElement
XmlElement.DEFAULT
XmlElementDecl
XmlElementDecl.GLOBAL
XmlElementRef
XmlElementRef.DEFAULT
XmlElementRefs
XmlElements
XmlElementWrapper
XMLEncoder
XmlEnum
XmlEnumValue
XMLEvent
XMLEventAllocator
XMLEventConsumer
XMLEventFactory
XMLEventReader
XMLEventWriter
XMLFilter
XMLFilterImpl
XMLFormatter
XMLGregorianCalendar
XmlID
XmlIDREF
XmlInlineBinaryData
XMLInputFactory
XmlJavaTypeAdapter
XmlJavaTypeAdapter.DEFAULT
XmlJavaTypeAdapters
XmlList
XmlMimeType
XmlMixed
XmlNs
XmlNsForm
XMLObject
XMLOutputFactory
XMLParseException
XmlReader
XMLReader
XMLReaderAdapter
XMLReaderFactory
XmlRegistry
XMLReporter
XMLResolver
XmlRootElement
XmlSchema
XmlSchemaType
XmlSchemaType.DEFAULT
XmlSchemaTypes
XMLSignature
XMLSignature.SignatureValue
XMLSignatureException
XMLSignatureFactory
XMLSignContext
XMLStreamConstants
XMLStreamException
XMLStreamReader
XMLStreamWriter
XMLStructure
XmlTransient
XmlType
XmlType.DEFAULT
XMLValidateContext
XmlValue
XmlWriter
XPath
XPathConstants
XPathException
XPathExpression
XPathExpressionException
XPathFactory
XPathFactoryConfigurationException
XPathFilter2ParameterSpec
XPathFilterParameterSpec
XPathFunction
XPathFunctionException
XPathFunctionResolver
XPathType
XPathType.Filter
XPathVariableResolver
XSLTTransformParameterSpec
ZipEntry
ZipError
ZipException
ZipFile
ZipInputStream
ZipOutputStream
ZoneView
_BindingIteratorImplBase
_BindingIteratorStub
_DynAnyFactoryStub
_DynAnyStub
_DynArrayStub
_DynEnumStub
_DynFixedStub
_DynSequenceStub
_DynStructStub
_DynUnionStub
_DynValueStub
_IDLTypeStub
_NamingContextExtStub
_NamingContextImplBase
_NamingContextStub
_PolicyStub
_Remote_Stub
_ServantActivatorStub
_ServantLocatorStub


Java 2 Platform SE 6

框架警报

请使用框架功能查看此文档。如果看到此消息，则表明您使用的是不支持框架的 Web 客户机。
链接到非框架版本。


概述 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

JavaTM 2 Platform Standard Edition 6
API 规范

本文档是 Java 2 Platform Standard Edition 6.0 的 API 规范。

请参见：
描述

Java 2 Platform 软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.ref | 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.spi | java.util 包中类的服务提供者类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert | 为公钥证书提供类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml | 根据 XML 规范定义核心 XML 常量和功能。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.bind.attachment | 此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3 | CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.portable | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap |
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

其他软件包
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

本文档是 Java 2 Platform Standard Edition 6.0 的 API 规范。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


API 帮助 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

此 API 文档的组织方式

此 API（应用程序编程接口）文档包含对应于导航栏中的项目的页面，如下所述。

概述

概述 页面是此 API 文档的首页，提供了所有软件包的列表及其摘要。此页面也可能包含这些软件包的总体描述。

软件包

每个软件包都有一个页面，其中包含它的类和接口的列表及其摘要。此页面可以包含四个类别：

  • 接口（斜体）
  • 类
  • 枚举
  • 异常
  • 错误
  • 注释类型

类/接口

每个类、接口、嵌套类和嵌套接口都有各自的页面。其中每个页面都由三部分（类/接口描述、摘要表，以及详细的成员描述）组成：

  • 类继承图
  • 直接子类
  • 所有已知子接口
  • 所有已知实现类
  • 类/接口声明
  • 类/接口描述

  • 嵌套类摘要
  • 字段摘要
  • 构造方法摘要
  • 方法摘要

  • 字段详细信息
  • 构造方法详细信息
  • 方法详细信息
每个摘要条目都包含该项目的详细描述的第一句。摘要条目按字母顺序排列，而详细描述则按其在源代码中出现的顺序排列。这样保持了程序员所建立的逻辑分组。

注释类型

每个注释类型都有各自的页面，其中包含以下部分：

  • 注释类型声明
  • 注释类型描述
  • 必需元素摘要
  • 可选元素摘要
  • 元素详细信息

枚举

每个枚举都有各自的页面，其中包含以下部分：

  • 枚举声明
  • 枚举描述
  • 枚举常量摘要
  • 枚举常量详细信息

使用

每个已文档化的软件包、类和接口都有各自的“使用”页面。此页面介绍了使用给定类或软件包的任何部分的软件包、类、方法、构造方法和字段。对于给定的类或接口 A，其“使用”页面包含 A 的子类、声明为 A 的字段、返回 A 的方法，以及带有类型为 A 的参数的方法和构造方法。访问此页面的方法是：首先转至软件包、类或接口，然后单击导航栏中的“使用”链接。

树（类分层结构）

对于所有软件包，有一个 类分层结构 页面，以及每个软件包的分层结构。每个分层结构页面都包含类的列表和接口的列表。从 java.lang.Object 开始，按继承结构对类进行排列。接口不从 java.lang.Object 继承。
  • 查看“概述”页面时，单击“树”将显示所有软件包的分层结构。
  • 查看特定软件包、类或接口页面时，单击“树”将仅显示该软件包的分层结构。

已过时的 API

已过时的 API 页面列出了所有已过时的 API。一般由于进行了改进并且通常提供了替代的 API，所以建议不要使用已过时的 API。在将来的实施过程中，可能会删除已过时的 API。

索引

索引 包含按字母顺序排列的所有类、接口、构造方法、方法和字段的列表。

上一个/下一个

这些链接使您可以转至下一个或上一个类、接口、软件包或相关页面。

框架/无框架

这些链接用于显示和隐藏 HTML 框架。所有页面均具有有框架和无框架两种显示方式。

序列化表格

每个可序列化或可外部化的类都有其序列化字段和方法的描述。此信息对重新实现者有用，而对使用 API 的开发者则没有什么用处。尽管导航栏中没有链接，但您可以通过下列方式获取此信息：转至任何序列化类，然后单击类描述的“另请参见”部分中的“序列化表格”。

常量字段值

常量字段值页面列出了静态最终字段及其值。

此帮助文件适用于使用标准 doclet 生成的 API 文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Applet (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.applet
类 Applet

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Panel
                继承者  java.applet.Applet
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
JApplet
public class Applet
extends Panel

applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

Applet 类必须是任何嵌入 Web 页或可用 Java Applet Viewer 查看的 applet 的超类。Applet 类提供了 applet 及其运行环境之间的标准接口。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

嵌套类摘要
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。
从类 java.awt.Panel 继承的嵌套类/接口
Panel.AccessibleAWTPanel
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Applet()
构造一个新 Applet。
方法摘要
void | destroy() 由浏览器或 applet viewer 调用，通知此 applet 它正在被回收，它应该销毁分配给它的任何资源。
AccessibleContext | getAccessibleContext() 获取与此 Applet 关联的 AccessibleContext。
AppletContext | getAppletContext() 确定此 applet 的上下文，上下文允许 applet 查询和影响它所运行的环境。
String | getAppletInfo() 返回有关此 applet 的信息。
AudioClip | getAudioClip(URL url) 返回 URL 参数指定的 AudioClip 对象。
AudioClip | getAudioClip(URL url, String name) 返回 URL 和 name 参数指定的 AudioClip 对象。
URL | getCodeBase() 获得基 URL。
URL | getDocumentBase() 获取嵌入此 applet 的文档的 URL。
Image | getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | getImage(URL url, String name) 返回能被绘制到屏幕上的 Image 对象。
Locale | getLocale() 获取 applet 的语言环境。
String | getParameter(String name) 返回 HTML 标记中指定参数的值。
String[][] | getParameterInfo() 返回此 applet 理解的关于参数的信息。
void | init() 由浏览器或 applet viewer 调用，通知此 applet 它已经被加载到系统中。
boolean | isActive() 确定 applet 是否处于活动状态。
static AudioClip | newAudioClip(URL url) 从给定 URL 处获取音频剪辑。
void | play(URL url) 播放指定绝对 URL 处的音频剪辑。
void | play(URL url, String name) 播放音频剪辑，给定了 URL 及与之相对的说明符。
void | resize(Dimension d) 请求调整此 applet 的大小。
void | resize(int width, int height) 请求调整此 applet 的大小。
void | setStub(AppletStub stub) 设置此 applet 的 stub。
void | showStatus(String msg) 请求将参数字符串显示在“状态窗口”中。
void | start() 由浏览器或 applet viewer 调用，通知此 applet 它应该开始执行。
void | stop() 由浏览器或 applet viewer 调用，通知此 applet 它应该终止执行。
从类 java.awt.Panel 继承的方法
addNotify
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Applet

public Applet()
       throws HeadlessException
构造一个新 Applet。

注：java.applet.Applet 中的许多方法只有在完全构造了 applet 之后才能由该 applet 调用；在构造方法中，applet 应该避免调用 java.applet.Applet 中的方法。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

setStub

public final void setStub(AppletStub stub)
设置此 applet 的 stub。此操作可以通过系统自动完成。

如果存在安全管理器并且设置了 stub，则通过 AWTPermission("setAppletStub") 权限调用它的 checkPermission 方法。

参数：
stub - 新 stub。
抛出：
SecurityException - 如果调用者不能设置 stub

isActive

public boolean isActive()
确定 applet 是否处于活动状态。在调用 applet 的 start 方法之前，applet 被标记为活动状态。在调用 applet 的 stop 方法之前，applet 被标记为非活动状态。

返回：
如果 applet 处于活动状态，则返回 true；否则返回 false。
另请参见：
start(), stop()

getDocumentBase

public URL getDocumentBase()
获取嵌入此 applet 的文档的 URL。例如，假定 applet 包含在以下文档中:
    http://java.sun.com/products/jdk/1.2/index.html
则文档基为:
    http://java.sun.com/products/jdk/1.2/index.html

返回：
包含此 applet 的文档的 URL。
另请参见：
getCodeBase()

getCodeBase

public URL getCodeBase()
获得基 URL。这是包含此 applet 的目录的 URL。

返回：
包含此 applet 的目录的基 URL。
另请参见：
getDocumentBase()

getParameter

public String getParameter(String name)
返回 HTML 标记中指定参数的值。例如，如果此 applet 被指定为:
 <applet code="Clock" width=50 height=50>
 <param name=Color value="blue">
 </applet>

那么调用 getParameter("Color") 将返回值 "blue"。

name 参数不区分大小写。

参数：
name - 参数名称。
返回：
指定参数的值；如果未设置，则返回 null。

getAppletContext

public AppletContext getAppletContext()
确定此 applet 的上下文，上下文允许 applet 查询和影响它所运行的环境。

applet 的环境指包含该 applet 的文档。

返回：
applet 的上下文。

resize

public void resize(int width,
                   int height)
请求调整此 applet 的大小。

覆盖：
类 Component 中的 resize
参数：
width - 为 applet 请求的新宽度。
height - 为 applet 请求的新高度。

resize

public void resize(Dimension d)
请求调整此 applet 的大小。

覆盖：
类 Component 中的 resize
参数：
d - 给出新宽度和高度的对象。

showStatus

public void showStatus(String msg)
请求将参数字符串显示在“状态窗口”中。很多浏览器和 applet viewer 提供这种窗口，应用程序可以通过该窗口将其当前状态通知给用户。

参数：
msg - 在状态窗口中显示的字符串。

getImage

public Image getImage(URL url)
返回能被绘制到屏幕上的 Image 对象。作为参数传递的 url 必须指定绝对 URL。

不管图像存在与否，此方法总是立刻返回。当此 applet 试图在屏幕上绘制图像时，数据将被加载。绘制图像的图形图元将逐渐绘制到屏幕上。

参数：
url - 给出图像位置的绝对 URL。
返回：
指定 URL 处的图像。
另请参见：
Image

getImage

public Image getImage(URL url,
                      String name)
返回能被绘制到屏幕上的 Image 对象。url 参数必须指定绝对 URL。name 参数是相对于 url 参数的说明符。

不管图像存在与否，此方法总是立刻返回。当此 applet 试图在屏幕上绘制图像时，数据将被加载。绘制图像的图形图元将逐渐绘制到屏幕上。

参数：
url - 给出图像基本位置的绝对 URL。
name - 相对于 url 参数的图象位置。
返回：
指定 URL 处的图像。
另请参见：
Image

newAudioClip

public static final AudioClip newAudioClip(URL url)
从给定 URL 处获取音频剪辑。

参数：
url - 指向音频剪辑
返回：
指定 URL 处的音频剪辑。
从以下版本开始：
1.2

getAudioClip

public AudioClip getAudioClip(URL url)
返回 URL 参数指定的 AudioClip 对象。

不管音频剪辑存在与否，此方法总是立即返回。当此 applet 试图播放音频剪辑时，数据将被加载。

参数：
url - 给出音频剪辑位置的绝对 URL。
返回：
指定 URL 处的音频剪辑。
另请参见：
AudioClip

getAudioClip

public AudioClip getAudioClip(URL url,
                              String name)
返回 URL 和 name 参数指定的 AudioClip 对象。

不管音频剪辑存在与否，此方法总是立即返回。当此 applet 试图播放音频剪辑时，数据将被加载。

参数：
url - 给定音频剪辑基本位置的绝对 URL。
name - 相对于 url 参数的音频剪辑位置。
返回：
指定 URL 处的音频剪辑。
另请参见：
AudioClip

getAppletInfo

public String getAppletInfo()
返回有关此 applet 的信息。applet 应该重写此方法，返回包含有关 applet 的作者、版本和版权信息的 String。

Applet 类提供的此方法实现返回 null。

返回：
包含有关 applet 的作者、版本和版权信息的字符串。

getLocale

public Locale getLocale()
获取 applet 的语言环境。该方法允许 applet 维护自己的语言环境，该环境与浏览器或 appletviewer 的语言环境是分离的。

覆盖：
类 Component 中的 getLocale
返回：
applet 的语言环境；如果尚未设置该语言环境，则返回默认语言环境。
从以下版本开始：
JDK1.1
另请参见：
Component.setLocale(java.util.Locale)

getParameterInfo

public String[][] getParameterInfo()
返回此 applet 理解的关于参数的信息。applet 应该重写此方法，返回描述这些参数的 String 数组。

数组的每个元素应该是三个 String 的集合，包括名称、类型和描述。例如：

 String pinfo[][] = {
         {"fps",    "1-10",    "frames per second"},
         {"repeat", "boolean", "repeat image loop"},
         {"imgs",   "url",     "images directory"}
 };

Applet 类提供的此方法实现返回 null。

返回：
描述此 applet 所寻找的参数的数组。

play

public void play(URL url)
播放指定绝对 URL 处的音频剪辑。如果未找到音频剪辑，则没有任何效果。

参数：
url - 给出音频剪辑位置的绝对 URL。

play

public void play(URL url,
                 String name)
播放音频剪辑，给定了 URL 及与之相对的说明符。如果未找到音频剪辑，则没有任何效果。

参数：
url - 给定音频剪辑基位置的绝对 URL。
name - 相对于 url 参数的音频剪辑位置。

init

public void init()
由浏览器或 applet viewer 调用，通知此 applet 它已经被加载到系统中。它经常在第一次调用 start 方法前被调用。

如果 Applet 的子类要执行初始化，则应该重写此方法。例如，使用线程的 applet 将用 init 方法创建线程，用 destroy 方法销毁它们。

Applet 类提供的此方法实现不执行任何操作。

另请参见：
destroy(),
start(),
stop()

start

public void start()
由浏览器或 applet viewer 调用，通知此 applet 它应该开始执行。它在 init 方法调用后以及在 Web 页中每次重新访问 applet 时调用。

如果 Applet 子类在包含它的 Web 页被访问时有想要执行的操作，则它应该重写此方法。例如，带有动画的 applet 可能想使用 start 方法再次播放动画，使用 stop 方法挂起动画。

注：某些方法（如 getLocationOnScreen）只有在如果 applet 正在显示时，才能提供有意义的结果。因为当 applet 的 start 方法第一次被调用时，isShowing 返回 false，所以需要 isShowing 返回 true 的方法应该从 ComponentListener 进行调用。

Applet 类提供的此方法实现不执行任何操作。

另请参见：
destroy(),
init(),
stop(),
Component.isShowing(),
ComponentListener.componentShown(java.awt.event.ComponentEvent)

stop

public void stop()
由浏览器或 applet viewer 调用，通知此 applet 它应该终止执行。当包含此 applet 的 Web 页已经被其他页替换时，在 applet 被销毁前调用此方法。

如果 Applet 子类在包含它的 Web 页每次不可见时有想要执行的操作，则它应该重写此方法。例如，带有动画的 applet 可能想使用 start 方法再次播放动画，使用 stop 方法挂起动画。

Applet 类提供的此方法实现不执行任何操作。

另请参见：
destroy(), init()

destroy

public void destroy()
由浏览器或 applet viewer 调用，通知此 applet 它正在被回收，它应该销毁分配给它的任何资源。stop 方法总是在 destroy 之前被调用。

如果 Applet 子类在被销毁前有想要执行的操作，则它应该重写此方法。例如，使用线程的 applet 将用 init 方法来创建线程，用 destroy 方法销毁它们。

Applet 类提供的此方法实现不执行任何操作。

另请参见：
init(),
start(),
stop()

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Applet 关联的 AccessibleContext。对于 applet，AccessibleContext 采用 AccessibleApplet 的形式。如有必要，可创建一个新的 AccessibleApplet 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Panel 中的 getAccessibleContext
返回：
一个 AccessibleApplet，它充当此 Applet 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Applet.AccessibleApplet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.applet
类 Applet.AccessibleApplet

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Panel.AccessibleAWTPanel
                    继承者  java.applet.Applet.AccessibleApplet
所有已实现的接口：
Serializable, AccessibleComponent
直接已知子类：
JApplet.AccessibleJApplet
正在封闭类：
Applet
protected class Applet.AccessibleApplet
extends Panel.AccessibleAWTPanel

此类实现对 Applet 类的可访问性支持。它提供适合 applet 用户界面元素的 Java Accessibility API 实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Applet.AccessibleApplet()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获得此对象的状态。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Applet.AccessibleApplet

protected Applet.AccessibleApplet()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Panel.AccessibleAWTPanel 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获得此对象的状态。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AppletContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.applet
接口 AppletContext

public interface AppletContext

此接口对应于 applet 的环境：包含 applet 的文档以及同一文档中的其他 applet。

applet 可以使用此接口中的方法获取有关其环境的信息。

从以下版本开始：
JDK1.0

方法摘要
Applet | getApplet(String name) 通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。
Enumeration<Applet> | getApplets() 找到此 applet 上下文表示的文档中的所有 applet。
AudioClip | getAudioClip(URL url) 创建音频剪辑。
Image | getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
InputStream | getStream(String key) 返回此 applet 上下文中指定键所关联的流。
Iterator<String> | getStreamKeys() 找到此 applet 上下文中所有流对应的键。
void | setStream(String key, InputStream stream) 在此 applet 上下文中用指定的键关联指定的流。
void | showDocument(URL url) 请求浏览器或 applet viewer 显示 url 参数指示的 Web 页面。
void | showDocument(URL url, String target) 请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。
void | showStatus(String status) 请求参数字符串显示在“状态窗口”中。

方法详细信息

getAudioClip

AudioClip getAudioClip(URL url)
创建音频剪辑。

参数：
url - 给出音频剪辑位置的绝对 URL。
返回：
指定 URL 处的音频剪辑。

getImage

Image getImage(URL url)
返回能被绘制到屏幕上的 Image 对象。作为参数传递的 url 必须指定绝对 URL。

不管图像存在与否，此方法总是立即返回。当此 applet 试图在屏幕上绘制图像时，数据将被加载。绘制图像的图形图元将逐渐绘制到屏幕上。

参数：
url - 给出图像位置的绝对 URL。
返回：
指定 URL 处的图像。
另请参见：
Image

getApplet

Applet getApplet(String name)
通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。名称可以在 HTML 标记中通过设置 name 属性来设置。

参数：
name - applet 名称。
返回：
具有给定名称的 applet；如果未找到，则返回 null。

getApplets

Enumeration<Applet> getApplets()
找到此 applet 上下文表示的文档中的所有 applet。

返回：
此 applet 上下文表示的文档中所有 applet 的枚举。

showDocument

void showDocument(URL url)
请求浏览器或 applet viewer 显示 url 参数指示的 Web 页面。浏览器或 applet viewer 确定使用哪个窗口或窗体来显示 Web 页面。非浏览器的 applet 上下文可以忽略此方法。

参数：
url - 给出文档位置的绝对 URL。

showDocument

void showDocument(URL url,
                  String target)
请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。target 参数指示在哪个 HTML 窗体中显示文档。target 参数的解释如下:

Target 参数 | 描述
"_self" | 在包含 applet 的窗口和窗体中显示。
"_parent" | 在 applet 的父窗体中显示。如果 applet 的窗体没有父窗体，执行与 "_self" 相同的动作。
"_top" | 在 applet 窗口的顶层窗体中显示。如果 applet 窗体是顶层窗体，执行与 "_self" 相同的动作。
"_blank" | 在一个新的、未命名的顶层窗口中显示。
name | 在名为 name 的窗体或窗口中显示。如果名为 name 的 target 尚未存在，将创建一个具有指定名称的新顶层窗口，文档将在该窗口中显示。

applet viewer 或浏览器可以随意地忽略 showDocument。

参数：
url - 给定文档位置的绝对 URL。
target - 指示在哪里显示页面的 String。

showStatus

void showStatus(String status)
请求参数字符串显示在“状态窗口”中。很多浏览器和 applet viewer 提供这种窗口，应用程序可以通过该窗口将其当前状态通知给用户。

参数：
status - 在状态窗口中显示的字符串。

setStream

void setStream(String key,
               InputStream stream)
               throws IOException
在此 applet 上下文中用指定的键关联指定的流。如果 applet 上下文以前包含了一个此键的映射关系，那么将替换旧值。

出于安全性考虑，每个代码基都存在流和键的映射。换句话说，一个代码基中的 applet 不能访问不同代码基中的 applet 创建的流。

参数：
key - 指定值要关联的键。
stream - 指定键要关联的流。如果此参数为 null，则在此 applet 上下文中将移除指定键。
抛出：
IOException - 如果流大小超过了一定大小限制。大小限制由此接口的实现者确定。
IOException
从以下版本开始：
JDK1.4

getStream

InputStream getStream(String key)
返回此 applet 上下文中指定键所关联的流。如果 applet 上下文中不包含此键对应的流，则返回 null。

由于安全性考虑，每个代码基都存在流和键的映射。换句话说，一个代码基中的 applet 不能访问不同代码基中的 applet 创建的流。

参数：
key - 要返回其关联流的键。
返回：
此 applet 上下文将键映射到的流
从以下版本开始：
JDK1.4

getStreamKeys

Iterator<String> getStreamKeys()
找到此 applet 上下文中所有流对应的键。

由于安全性考虑，每个代码基都存在流和键的映射。换句话说，一个代码基中的 applet 不能访问不同代码基中的 applet 创建的流。

返回：
返回此 applet 上下文中所有流名称的迭代器。
从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AppletStub (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.applet
接口 AppletStub

public interface AppletStub

当 applet 第一次被创建时，使用 applet 的 setStub 方法把 applet stub 连接到它。此 stub 充当 applet 和浏览器环境或 applet viewer 环境之间的接口，应用程序在此环境中运行。

从以下版本开始：
JDK1.0
另请参见：
Applet.setStub(java.applet.AppletStub)

方法摘要
void | appletResize(int width, int height) 当 applet 想要重新调整大小时调用。
AppletContext | getAppletContext() 返回 applet 的上下文。
URL | getCodeBase() 获取基 URL。
URL | getDocumentBase() 获取嵌入 applet 的文档的 URL。
String | getParameter(String name) 返回 HTML 标记中命名参数的值。
boolean | isActive() 确定 applet 是否处于激活状态。

方法详细信息

isActive

boolean isActive()
确定 applet 是否处于激活状态。仅在 applet 的 start 方法被调用前，applet 才处于激活状态。仅在 applet 的 stop 方法被调用前，applet 才变成非激活状态。

返回：
如果 applet 处于激活状态，则返回 true；否则返回 false。

getDocumentBase

URL getDocumentBase()
获取嵌入 applet 的文档的 URL。例如，假定 applet 包含在下面的文档中：
    http://java.sun.com/products/jdk/1.2/index.html
则该文档基于：
    http://java.sun.com/products/jdk/1.2/index.html

返回：
包含 applet 的文档的 URL。
另请参见：
getCodeBase()

getCodeBase

URL getCodeBase()
获取基 URL。这是包含 applet 的目录的 URL。

返回：
包含 applet 的目录的基 URL。
另请参见：
getDocumentBase()

getParameter

String getParameter(String name)
返回 HTML 标记中命名参数的值。例如，如果 applet 被指定为：
 <applet code="Clock" width=50 height=50>
 <param name=Color value="blue">
 </applet>

则对 getParameter("Color") 的调用将返回值 "blue"。

参数：
name - 参数名。
返回：
命名参数的值，如果没有设置，则为　null。

getAppletContext

AppletContext getAppletContext()
返回 applet 的上下文。

返回：
applet 上下文。

appletResize

void appletResize(int width,
                  int height)
当 applet 想要重新调整大小时调用。

参数：
width - 为 applet 新请求的宽度。
height - 为 applet 新请求的高度。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AudioClip (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.applet
接口 AudioClip

public interface AudioClip

AudioClip 接口是用于播放音频剪辑的简单抽象。多个 AudioClip 项能够同时播放，得到的声音混合在一起可产生合成声音。

从以下版本开始：
JDK1.0

方法摘要
void | loop() 以循环方式开始播放此音频剪辑。
void | play() 开始播放此音频剪辑。
void | stop() 停止播放此音频剪辑。

方法详细信息

play

void play()
开始播放此音频剪辑。每次调用此方法时，剪辑都从头开始重新播放。

loop

void loop()
以循环方式开始播放此音频剪辑。

stop

void stop()
停止播放此音频剪辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.applet (Java 2 Platform SE 6)

 java.applet
接口
AppletContext
AppletStub
AudioClip
类
Applet


java.applet (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.applet

提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

请参见：
描述

接口摘要
AppletContext | 此接口对应于 applet 的环境：包含 applet 的文档以及同一文档中的其他 applet。
AppletStub | 当 applet 第一次被创建时，使用 applet 的 setStub 方法把 applet stub 连接到它。
AudioClip | AudioClip 接口是用于播放音频剪辑的简单抽象。

类摘要
Applet applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

软件包 java.applet 的描述

提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

applet 框架包括两种实体：applet 和 applet 上下文。applet 是一种可嵌入的窗体（参见 Panel 类），它带有几个 applet 上下文用来初始化、启动和终止 applet 的额外方法。

applet 上下文是负责加载和运行 applet 的应用程序。例如，applet 上下文可能是 Web 浏览器或 applet 开发环境。

从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.applet 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.applet 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet

接口分层结构

  • java.applet.AppletContext
  • java.applet.AppletStub
  • java.applet.AudioClip
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.applet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.applet
的使用

使用 java.applet 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

java.applet 使用的 java.applet 中的类
Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。
AppletContext
此接口对应于 applet 的环境：包含 applet 的文档以及同一文档中的其他 applet。
AppletStub
当 applet 第一次被创建时，使用 applet 的 setStub 方法把 applet stub 连接到它。
AudioClip
AudioClip 接口是用于播放音频剪辑的简单抽象。

java.beans 使用的 java.applet 中的类
Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

javax.swing 使用的 java.applet 中的类
Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。
Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

org.omg.CORBA 使用的 java.applet 中的类
Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.applet.AudioClip 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.applet.AudioClip
的使用

使用 AudioClip 的软件包
java.applet 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.applet 中 AudioClip 的使用

返回 AudioClip 的 java.applet 中的方法
AudioClip | AppletContext.getAudioClip(URL url) 创建音频剪辑。
AudioClip | Applet.getAudioClip(URL url) 返回 URL 参数指定的 AudioClip 对象。
AudioClip | Applet.getAudioClip(URL url, String name) 返回 URL 和 name 参数指定的 AudioClip 对象。
static AudioClip | Applet.newAudioClip(URL url) 从给定 URL 处获取音频剪辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.applet.AppletStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.applet.AppletStub
的使用

使用 AppletStub 的软件包
java.applet 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.applet 中 AppletStub 的使用

参数类型为 AppletStub 的 java.applet 中的方法
 void Applet.setStub(AppletStub stub)
设置此 applet 的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.applet.AppletContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.applet.AppletContext
的使用

使用 AppletContext 的软件包
java.applet 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.applet 中 AppletContext 的使用

返回 AppletContext 的 java.applet 中的方法
AppletContext | AppletStub.getAppletContext() 返回 applet 的上下文。
AppletContext | Applet.getAppletContext() 确定此 applet 的上下文，上下文允许 applet 查询和影响它所运行的环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.applet.Applet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.applet.Applet
的使用

使用 Applet 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

java.applet 中 Applet 的使用

返回 Applet 的 java.applet 中的方法
 Applet AppletContext.getApplet(String name)
通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。

返回变量类型为 Applet 的类型的 java.applet 中的方法
 Enumeration<Applet> AppletContext.getApplets()
找到此 applet 上下文表示的文档中的所有 applet。

java.beans 中 Applet 的使用

参数类型为 Applet 的 java.beans 中的方法
void | AppletInitializer.activate(Applet newApplet) 激活和/或将 Applet 标记为激活。
void | AppletInitializer.initialize(Applet newAppletBean, BeanContext bCtxt) 如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。

javax.swing 中 Applet 的使用

javax.swing 中 Applet 的子类
 class JApplet
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。

参数类型为 Applet 的 javax.swing 中的方法
 void RepaintManager.addDirtyRegion(Applet applet, int x, int y, int w, int h)
将 applet 添加到需要重绘的 Component 列表。

org.omg.CORBA 中 Applet 的使用

参数类型为 Applet 的 org.omg.CORBA 中的方法
static ORB | ORB.init(Applet app, Properties props) 为 applet 创建一个新的 ORB 实例。
protected abstract void | ORB.set_parameters(Applet app, Properties props) 允许使用给定 applet 和参数初始化 ORB 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.applet.Applet.AccessibleApplet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.applet.Applet.AccessibleApplet
的使用

使用 Applet.AccessibleApplet 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Applet.AccessibleApplet 的使用

javax.swing 中 Applet.AccessibleApplet 的子类
protected  class JApplet.AccessibleJApplet
此类实现对 JApplet 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ActiveEvent (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 ActiveEvent

所有已知实现类：
InvocationEvent
public interface ActiveEvent

知道如何对自身进行指派的事件的接口。通过实现此接口，可以使用 EventDispatchThread 将一个事件放置到事件队列，并且指派该事件时将调用其 dispatch() 方法。

这是一种非常有用的避免死锁的机制。如果线程正在执行某个关键部分（即它已经进入了一个或多个监视器），调用其他同步代码可能导致死锁。为了避免潜在的死锁，可以创建一个 ActiveEvent，以便以后运行代码的第二部分。如果存在监视器争用，那么在第一个线程已经完成工作并退出监视器之前，第二个线程将一直处于阻塞状态。

出于安全性考虑，使用 ActiveEvent 来避免从一个关键线程中调用不受信任的代码通常是很值得的。例如，同位体实现可以使用此设施来避免从系统线程调用用户代码。这样做可以避免潜在的死锁和拒绝服务攻击。

从以下版本开始：
1.2

方法摘要
 void dispatch()
将事件指派给目标、事件源侦听器，或者做任何希望此事件去做的事情。

方法详细信息

dispatch

void dispatch()
将事件指派给目标、事件源侦听器，或者做任何希望此事件去做的事情。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Adjustable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 Adjustable

所有已知实现类：
JScrollBar, JScrollPane.ScrollBar, Scrollbar, ScrollPaneAdjustable
public interface Adjustable

此接口用于那些具有可调整数值的对象，数值应包含在有限范围的值之内。

字段摘要
static int | HORIZONTAL 指示 Adjustable 具有水平方向。
static int | NO_ORIENTATION 指示 Adjustable 不具有方向。
static int | VERTICAL 指示 Adjustable 具有垂直方向。
方法摘要
void | addAdjustmentListener(AdjustmentListener l) 添加侦听器，以便在可调整对象的值更改时接收调整事件。
int | getBlockIncrement() 获取可调整对象的块值增量。
int | getMaximum() 获取可调整对象的最大值。
int | getMinimum() 获取可调整对象的最小值。
int | getOrientation() 获取此可调整对象的方向。
int | getUnitIncrement() 获取可调整对象的单位值增量。
int | getValue() 获取可调整对象的当前值。
int | getVisibleAmount() 获取比例指示器的长度。
void | removeAdjustmentListener(AdjustmentListener l) 移除一个调整侦听器。
void | setBlockIncrement(int b) 设置可调整对象的块值增量。
void | setMaximum(int max) 设置可调整对象的最大值。
void | setMinimum(int min) 设置可调整对象的最小值。
void | setUnitIncrement(int u) 设置可调整对象的单位值增量。
void | setValue(int v) 设置可调整对象的当前值。
void | setVisibleAmount(int v) 设置可调整对象的比例指示器的长度。

字段详细信息

HORIZONTAL

static final int HORIZONTAL
指示 Adjustable 具有水平方向。

另请参见：
常量字段值

VERTICAL

static final int VERTICAL
指示 Adjustable 具有垂直方向。

另请参见：
常量字段值

NO_ORIENTATION

static final int NO_ORIENTATION
指示 Adjustable 不具有方向。

另请参见：
常量字段值
方法详细信息

getOrientation

int getOrientation()
获取此可调整对象的方向。

返回：
可调整对象的方向；可以是 HORIZONTAL、VERTICAL 或者 NO_ORIENTATION

setMinimum

void setMinimum(int min)
设置可调整对象的最小值。

参数：
min - 最小值

getMinimum

int getMinimum()
获取可调整对象的最小值。

返回：
可调整对象的最小值

setMaximum

void setMaximum(int max)
设置可调整对象的最大值。

参数：
max - 最大值

getMaximum

int getMaximum()
获取可调整对象的最大值。

返回：
可调整对象的最大值

setUnitIncrement

void setUnitIncrement(int u)
设置可调整对象的单位值增量。

参数：
u - 单位增量

getUnitIncrement

int getUnitIncrement()
获取可调整对象的单位值增量。

返回：
可调整对象的单位值增量

setBlockIncrement

void setBlockIncrement(int b)
设置可调整对象的块值增量。

参数：
b - 块值增量

getBlockIncrement

int getBlockIncrement()
获取可调整对象的块值增量。

返回：
可调整对象的块值增量

setVisibleAmount

void setVisibleAmount(int v)
设置可调整对象的比例指示器的长度。

参数：
v - 指示器的长度

getVisibleAmount

int getVisibleAmount()
获取比例指示器的长度。

返回：
比例指示器的长度

setValue

void setValue(int v)
设置可调整对象的当前值。如果提供的值小于 minimum 或者大于 maximum - visibleAmount，则适当地替换其中一个值。

调用此方法不会激发 AdjustmentEvent。

参数：
v - 当前值，它位于 minimum 和 maximum - visibleAmount 之间

getValue

int getValue()
获取可调整对象的当前值。

返回：
可调整对象的当前值

addAdjustmentListener

void addAdjustmentListener(AdjustmentListener l)
添加侦听器，以便在可调整对象的值更改时接收调整事件。

参数：
l - 接受事件的侦听器
另请参见：
AdjustmentEvent

removeAdjustmentListener

void removeAdjustmentListener(AdjustmentListener l)
移除一个调整侦听器。

参数：
l - 要移除的侦听器
另请参见：
AdjustmentEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AlphaComposite (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 AlphaComposite

java.lang.Object
    继承者  java.awt.AlphaComposite
所有已实现的接口：
Composite
public final class AlphaComposite
extends Object
implements Composite

AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。此类实现的特定规则是 T. Porter 和 T. Duff 合著的 "Compositing Digital Images", SIGGRAPH 84, 253-259 中描述的 12 条基本规则集。本文档的其余部分假定读者熟悉上述论文中概括的定义和概念。

此类扩展了 Porter 和 Duff 定义的方程，包含一个额外的因子。AlphaComposite 类的实例可以包含一个 alpha 值，在将该值用于混合方程之前，可以用它来修改不透明度和每个源像素的覆盖率。

要重点注意的是，Porter 和 Duff 的论文中定义的方程完全是为颜色分量方面的操作定义的，这些颜色分量都要用它们对应的 alpha 分量预乘。因为 ColorModel 和 Raster 类允许以预乘和非预乘的方式存储像素数据，所以在将所有输入数据应用到方程之前，必须将它们标准化为预乘形式，并且在存储像素值之前，可能需要将所有结果都调整回目标所需的形式。

还要注意的是，此类只定义了以纯数学方式组合颜色和 alpha 值的方程。方程的具体应用取决于从数据源中检索数据和将它们存储到其目标中的方式。有关更多信息，请参阅实现警告事项。

Porter 和 Duff 的论文在混合方程的描述中使用了以下因子：

因子 | 定义
As | 源像素的 alpha 分量
Cs | 源像素的预乘形式的颜色分量
Ad | 目标像素的 alpha 分量
Cd | 目标像素的预乘形式的颜色分量
Fs | 用于输出的源像素的分数值
Fd | 用于输出的目标像素的分数值
Ar | 结果 alpha 分量
Cr | 结果预乘形式的颜色分量

使用这些因子，Porter 和 Duff 定义了 12 种选择混合因子 Fs 和 Fd 的方法，从而产生了 12 种令人满意的可视效果。在对 12 个指定可视效果的静态字段的描述中，给出了具有确定 Fs 和 Fd 值的方程。例如，对 SRC_OVER 的描述指定了 Fs = 1 和 Fd = (1-As)。一旦已知一组确定混合因子的方程，就可以使用以下方程组将它们应用于每个像素以生成结果：

        Fs = f(Ad)
        Fd = f(As)
        Ar = As*Fs + Ad*Fd
        Cr = Cs*Fs + Cd*Fd

在我们对 Porter 和 Duff 论文混合方程的扩展中，用到了以下因子：

因子 | 定义
Csr | 源像素的原始颜色分量之一
Cdr | 目标像素的原始颜色分量之一
Aac | 取自 AlphaComposite 实例的“额外的”alpha 分量
Asr | 源像素的原始 alpha 分量
Adr | 目标像素的原始 alpha 分量
Adf | 目标中存储的最终 alpha 分量
Cdf | 目标中存储的最终原始颜色分量

准备输入

AlphaComposite 类定义一个应用于源 alpha 的额外 alpha 值。应用此值就好像首先将隐式的 SRC_IN 规则应用于源像素（通过将原始源 alpha 和原始源色乘以 AlphaComposite 中的 alpha 值获得），而不是应用于具有指定 alpha 值的像素。这产生了以下方程，该方程生成 Porter 和 Duff 的混合方程中使用的 alpha 值：

        As = Asr * Aac
所有这些原始源色分量都必须乘以 AlphaComposite 实例中的 alpha 值。此外，如果源色分量不是预乘形式的，那么还需要将颜色分量乘以源 alpha 值。因此，用来生成 Porter 和 Duff 方程源色分量的方程取决于源像素是否已经被预乘：
        Cs = Csr * Asr * Aac     （如果源像素没有被预乘）
        Cs = Csr * Aac           （如果源像素被预乘）
无需对目标 alpha 进行调整：
        Ad = Adr

仅当目标色分量不是预乘形式时，才需要对它们进行调整：

        Cd = Cdr * Ad    （如果目标色分量没有被预乘）
        Cd = Cdr         （如果目标色分量被预乘）

应用混合方程

调整后的 As、Ad、Cs 和 Cd 将用于标准的 Porter 和 Duff 方程，以计算混合因子 Fs 和 Fd，然后计算得到的预乘分量 Ar 和 Cr。

准备结果

仅当结果要存储回保存未预乘数据的目标缓冲区时，才需要使用以下方程调整结果：

        Adf = Ar
        Cdf = Cr                 （如果目标数据被预乘）
        Cdf = Cr / Ar            （如果目标数据没有被预乘）
注意，在所得 alpha 为零时除法是不明确的，所以在这种情况下会忽略除法以避免“除以零”的情况，此时颜色分量都将为零。

性能考虑事项

出于性能方面的原因，传递给 CompositeContext 对象（由 AlphaComposite 类创建） compose 方法的 Raster 对象最好有预乘数据。不过，如果源 Raster 或目标 Raster 没有被预乘，那么可以在合成操作之前或之后执行适当的转换。

实现警告事项

  • 许多源图像，比如 BufferedImage 类中列出的一些不透明图像类型，没有为它们的像素存储 alpha 值。这类源图像为它们所有的像素提供了值为 1.0 的 alpha 值。

  • 许多目标也没有地方存储 alpha 值（这些值是此类执行混合计算的结果）。这类目标会隐式丢弃此类产生的 alpha 值。建议这类目标将它们存储的颜色值作为未预乘的值对待，并在存储颜色值和丢弃 alpha 值之前，将得到的颜色值除以得到的 alpha 值。

  • 结果的精度取决于将像素存储到目标中的方式。对于一连串十二种合成操作中的少数操作，将为每种颜色和 alpha 分量提供至少 8 个存储位的图像格式作为目标无论如何都应该足够了。在舍入误差支配结果之前，为每个分量提供少于 8 个存储位的图像格式仅限用于一或两个合成操作。对于任何半透明混合的类型而言，不单独存储颜色分量的图像格式不是一个好的候选方式。例如，不应将 BufferedImage.TYPE_BYTE_INDEXED 用作混合操作的目标，因为需要从限定的调色板选择像素，以匹配混合方程的结果，所以每个操作都可能引入大量错误。

  • 几乎所有的格式都将像素存储为离散整数，而不是将它们存储为上述方程中使用的浮点值。该实现可以将整数像素值缩放成范围在 0.0 到 1.0 之间的浮点值，或者使用稍作修改的方程，完全在整数域内操作，从而生成与上述方程类似的结果。

    通常，整数值与浮点值存在某种相关性：整数 0 等于浮点值 0.0，整数 2^n-1（其中 n 是表示形式中的位数）等于 1.0。对于 8 位的表示形式，这意味着 0x00 表示 0.0，0xff 表示 1.0。

  • 内部实现可能近似于某些方程，它们也可以消除一些步骤，以避免不必要的操作。例如，可以考虑一个离散整数图像，它带有未预乘的 alpha 值，并为存储每个分量使用了 8 个位。接近透明的暗红色存储的值可能是：
        (A, R, G, B) = (0x01, 0xb0, 0x00, 0x00)

    如果正在使用整数运算，并且此值在 SRC 模式下没有与任何 alpha 值合成，则该运算将指示此运算的结果为（整数格式）：

        (A, R, G, B) = (0x01, 0x01, 0x00, 0x00)

    注意中间的值，它总是以已预乘的形式出现，并且只允许整数 red 分量为 0x00 或 0x01。当试图将此结果存储回未预乘的目标中时，用 alpha 值相除之后，对于未预乘的 red 值，可进行的选择很少。在这种情况下，在整数空间内执行运算（没有快捷方式）的实现最后可能提供以下最终像素值：

        (A, R, G, B) = (0x01, 0xff, 0x00, 0x00)

    （注意，0x01 除以 0x01 得到的是 1.0，等于 8 位存储格式的值 0xff。）

    另一方面，使用浮点运算的实现可以生成更精确的结果，并以返回原始像素值结束，该值有可能带有少量的舍入误差。或者，使用整数运算的实现可能决定是否可以将未涉及的像素传输给目标，完全避免所有运算。因为如果在浮点空间内执行运算，方程可简单归结为颜色值上的一个虚拟 NOP。

    这些实现都试图遵守相同的方程，但使用经过权衡的不同整数和浮点运算，并使用部分的或全部的方程。为了说明这些不同之处，可能最好只期望获得已预乘形式的结果，以在实现和图像格式之间进行匹配。在这种情况下，以预乘形式表示的两种答案将等同于：

        (A, R, G, B) = (0x01, 0x01, 0x00, 0x00)

    并且它们将是完全匹配的。

  • 因为那些通过简化方程使计算更有效的技术，在非预乘的目标上遇到值为 0.0 的结果 alpha 值时，一些实现的执行可能会有所不同。注意，如果分母 (alpha) 为 0，则在 SRC 规则下移除除以 alpha 这一简化操作技术上是不合法的。但是，因为在以预乘形式查看时只期望结果是精确的，所以，结果为 0 的 alpha 值呈现的实质上是所得到的不相关颜色分量，因此，在这种情况下，具体的行为应该是无法预料的。

另请参见：
Composite, CompositeContext

字段摘要
static AlphaComposite | Clear 实现不透明 CLEAR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static int | CLEAR 目标色和目标 alpha 值都被清除（Porter-Duff Clear 规则）。
static AlphaComposite | Dst 实现不透明 DST 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static int | DST 目标色不变（Porter-Duff Destination 规则）。
static int | DST_ATOP 在源色之上合成源色中的目标色部分，并将替换目标色（Porter-Duff Destination Atop Source 规则）。
static int | DST_IN 源色中的目标色部分将替换目标色（Porter-Duff Destination In Source 规则）。
static int | DST_OUT 源色以外的目标色部分将替换目标色（Porter-Duff Destination Held Out By Source 规则）。
static int | DST_OVER 在源色之上合成目标色，产生的结果将替代目标色（Porter-Duff Destination Over Source 规则）。
static AlphaComposite | DstAtop 实现不透明 DST_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | DstIn 实现不透明 DST_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | DstOut 实现不透明 DST_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | DstOver 实现不透明 DST_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | Src 实现不透明 SRC 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static int | SRC 将源色复制到目标色（Porter-Duff Source 规则）。
static int | SRC_ATOP 目标色中的源色部分将被合成到目标色中（Porter-Duff Source Atop Destination 规则）。
static int | SRC_IN 目标色中的源色部分将替换目标色（Porter-Duff Source In Destination 规则）。
static int | SRC_OUT 目标色以外的源色部分将替换目标色（Porter-Duff Source Held Out By Destination 规则）。
static int | SRC_OVER 在目标色之上合成源色（Porter-Duff Source Over Destination 规则）。
static AlphaComposite | SrcAtop 实现不透明 SRC_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | SrcIn 实现不透明 SRC_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | SrcOut 实现不透明 SRC_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | SrcOver 实现不透明 SRC_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | Xor 实现不透明 XOR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static int | XOR 将目标色之外的源色部分与源色之外的目标色部分结合到一起（Porter-Duff Source Xor Destination 规则）。
方法摘要
CompositeContext | createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 为合成操作创建一个上下文。
AlphaComposite | derive(float alpha) 返回一个类似的 AlphaComposite 对象，该对象使用指定的 alpha 值。
AlphaComposite | derive(int rule) 返回一个类似的 AlphaComposite 对象，该对象使用指定的复合规则。
boolean | equals(Object obj) 确定指定的对象是否等于此 AlphaComposite。
float | getAlpha() 返回此 AlphaComposite 的 alpha 值。
static AlphaComposite | getInstance(int rule) 创建一个具有指定规则的 AlphaComposite 对象。
static AlphaComposite | getInstance(int rule, float alpha) 创建一个 AlphaComposite 对象，它具有指定的规则和用来乘源色 alpha 值的常量 alpha 值。
int | getRule() 返回此 AlphaComposite 的合成规则。
int | hashCode() 返回此合成的哈希码。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CLEAR

public static final int CLEAR
目标色和目标 alpha 值都被清除（Porter-Duff Clear 规则）。源色和目标色都不被用作输入。

Fs = 0 和 Fd = 0，因此：

        Ar = 0
        Cr = 0

另请参见：
常量字段值

SRC

public static final int SRC
将源色复制到目标色（Porter-Duff Source 规则）。目标色不被用作输入。

Fs = 1 和 Fd = 0，因此：

        Ar = As
        Cr = Cs

另请参见：
常量字段值

DST

public static final int DST
目标色不变（Porter-Duff Destination 规则）。

Fs = 0 和 Fd = 1，因此：

        Ar = Ad
        Cr = Cd

从以下版本开始：
1.4
另请参见：
常量字段值

SRC_OVER

public static final int SRC_OVER
在目标色之上合成源色（Porter-Duff Source Over Destination 规则）。

Fs = 1 和 Fd = (1-As)，因此：

        Ar = As + Ad*(1-As)
        Cr = Cs + Cd*(1-As)

另请参见：
常量字段值

DST_OVER

public static final int DST_OVER
在源色之上合成目标色，产生的结果将替代目标色（Porter-Duff Destination Over Source 规则）。

Fs = (1-Ad) 和 Fd = 1，因此：

        Ar = As*(1-Ad) + Ad
        Cr = Cs*(1-Ad) + Cd

另请参见：
常量字段值

SRC_IN

public static final int SRC_IN
目标色中的源色部分将替换目标色（Porter-Duff Source In Destination 规则）。

Fs = Ad 和 Fd = 0，因此：

        Ar = As*Ad
        Cr = Cs*Ad

另请参见：
常量字段值

DST_IN

public static final int DST_IN
源色中的目标色部分将替换目标色（Porter-Duff Destination In Source 规则）。

Fs = 0 和 Fd = As，因此：

        Ar = Ad*As
        Cr = Cd*As

另请参见：
常量字段值

SRC_OUT

public static final int SRC_OUT
目标色以外的源色部分将替换目标色（Porter-Duff Source Held Out By Destination 规则）。

Fs = (1-Ad) 和 Fd = 0，因此：

        Ar = As*(1-Ad)
        Cr = Cs*(1-Ad)

另请参见：
常量字段值

DST_OUT

public static final int DST_OUT
源色以外的目标色部分将替换目标色（Porter-Duff Destination Held Out By Source 规则）。

Fs = 0 和 Fd = (1-As)，因此：

        Ar = Ad*(1-As)
        Cr = Cd*(1-As)

另请参见：
常量字段值

SRC_ATOP

public static final int SRC_ATOP
目标色中的源色部分将被合成到目标色中（Porter-Duff Source Atop Destination 规则）。

Fs = Ad 和 Fd = (1-As)，因此：

        Ar = As*Ad + Ad*(1-As) = Ad
        Cr = Cs*Ad + Cd*(1-As)

从以下版本开始：
1.4
另请参见：
常量字段值

DST_ATOP

public static final int DST_ATOP
在源色之上合成源色中的目标色部分，并将替换目标色（Porter-Duff Destination Atop Source 规则）。

Fs = (1-Ad) 和 Fd = As，因此：

        Ar = As*(1-Ad) + Ad*As = As
        Cr = Cs*(1-Ad) + Cd*As

从以下版本开始：
1.4
另请参见：
常量字段值

XOR

public static final int XOR
将目标色之外的源色部分与源色之外的目标色部分结合到一起（Porter-Duff Source Xor Destination 规则）。

Fs = (1-Ad) 和 Fd = (1-As)，因此：

        Ar = As*(1-Ad) + Ad*(1-As)
        Cr = Cs*(1-Ad) + Cd*(1-As)

从以下版本开始：
1.4
另请参见：
常量字段值

Clear

public static final AlphaComposite Clear
实现不透明 CLEAR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
CLEAR

Src

public static final AlphaComposite Src
实现不透明 SRC 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
SRC

Dst

public static final AlphaComposite Dst
实现不透明 DST 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

从以下版本开始：
1.4
另请参见：
DST

SrcOver

public static final AlphaComposite SrcOver
实现不透明 SRC_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
SRC_OVER

DstOver

public static final AlphaComposite DstOver
实现不透明 DST_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
DST_OVER

SrcIn

public static final AlphaComposite SrcIn
实现不透明 SRC_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
SRC_IN

DstIn

public static final AlphaComposite DstIn
实现不透明 DST_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
DST_IN

SrcOut

public static final AlphaComposite SrcOut
实现不透明 SRC_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
SRC_OUT

DstOut

public static final AlphaComposite DstOut
实现不透明 DST_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

另请参见：
DST_OUT

SrcAtop

public static final AlphaComposite SrcAtop
实现不透明 SRC_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

从以下版本开始：
1.4
另请参见：
SRC_ATOP

DstAtop

public static final AlphaComposite DstAtop
实现不透明 DST_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

从以下版本开始：
1.4
另请参见：
DST_ATOP

Xor

public static final AlphaComposite Xor
实现不透明 XOR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

从以下版本开始：
1.4
另请参见：
XOR
方法详细信息

getInstance

public static AlphaComposite getInstance(int rule)
创建一个具有指定规则的 AlphaComposite 对象。

参数：
rule - 合成规则
抛出：
IllegalArgumentException - 如果 rule 不是以下规则之一：CLEAR、SRC、DST、SRC_OVER、DST_OVER、SRC_IN、DST_IN、SRC_OUT、DST_OUT、SRC_ATOP、DST_ATOP 或 XOR

getInstance

public static AlphaComposite getInstance(int rule,
                                         float alpha)
创建一个 AlphaComposite 对象，它具有指定的规则和用来乘源色 alpha 值的常量 alpha 值。在将源色与目标色合成前，要将源色乘以指定的 alpha 值。

参数：
rule - 合成规则
alpha - 将乘源色的 alpha 值的常量 alpha 值。alpha 必须是范围 [0.0, 1.0] 之内（包含边界值）的一个浮点数字。
抛出：
IllegalArgumentException - 如果 alpha 小于 0.0 或大于 1.0，或者 rule 是以下规则之一：CLEAR、SRC、DST、SRC_OVER、DST_OVER、SRC_IN、DST_IN、SRC_OUT、DST_OUT、SRC_ATOP、DST_ATOP 或 XOR

createContext

public CompositeContext createContext(ColorModel srcColorModel,
                                      ColorModel dstColorModel,
                                      RenderingHints hints)
为合成操作创建一个上下文。上下文中包括执行合成操作过程中使用的状态。

指定者：
接口 Composite 中的 createContext
参数：
srcColorModel - 源色的 ColorModel
dstColorModel - 目标色的 ColorModel
hints - 上下文对象用于选择呈现方法的提示
返回：
用来执行合成操作的 CompositeContext 对象。

getAlpha

public float getAlpha()
返回此 AlphaComposite 的 alpha 值。如果此 AlphaComposite 没有 alpha 值，则返回 1.0。

返回：
此 AlphaComposite 的 alpha 值。

getRule

public int getRule()
返回此 AlphaComposite 的合成规则。

返回：
此 AlphaComposite 的合成规则。

derive

public AlphaComposite derive(int rule)
返回一个类似的 AlphaComposite 对象，该对象使用指定的复合规则。如果此对象已经使用指定的复合规则，则返回此对象。

参数：
rule - 复合规则
返回：
派生于使用指定复合规则的对象的 AlphaComposite 对象。
抛出：
IllegalArgumentException - 如果 rule 不是以下规则之一： CLEAR、SRC、DST、SRC_OVER、DST_OVER、SRC_IN、DST_IN、SRC_OUT、DST_OUT、SRC_ATOP、DST_ATOP 或 XOR
从以下版本开始：
1.6

derive

public AlphaComposite derive(float alpha)
返回一个类似的 AlphaComposite 对象，该对象使用指定的 alpha 值。如果此对象已经具有指定的 alpha 值，则返回此对象。

参数：
alpha - 常量 alpha，将乘以源的 alpha 值。alpha 必须是闭区间 [0.0, 1.0] 中的一个浮点数字。
返回：
派生于使用指定 alpha 值的对象的 AlphaComposite 对象。
抛出：
IllegalArgumentException - 如果 alpha 小于 0.0 或大于 1.0
从以下版本开始：
1.6

hashCode

public int hashCode()
返回此合成的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此合成的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
确定指定的对象是否等于此 AlphaComposite。

当且仅当参数不为 null，并且是一个与此对象具有相同组合规则和 alpha 值的 AlphaComposite 对象时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要测试相等性的 Object
返回：
如果 obj 等于此 AlphaComposite，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 AWTError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.awt.AWTError
所有已实现的接口：
Serializable
public class AWTError
extends Error

当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。

另请参见：
序列化表格

构造方法摘要
AWTError(String msg)
构造带指定详细消息的 AWTError 的实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AWTError

public AWTError(String msg)
构造带指定详细消息的 AWTError 的实例。

参数：
msg - 详细消息。
从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 AWTEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
所有已实现的接口：
Serializable
直接已知子类：
ActionEvent, AdjustmentEvent, AncestorEvent, ComponentEvent, HierarchyEvent, InputMethodEvent, InternalFrameEvent, InvocationEvent, ItemEvent, TextEvent
public abstract class AWTEvent
extends EventObject

所有 AWT 事件的根事件类。此类及其子类取代了原来的 java.awt.Event 类。此根 AWTEvent 类（在 java.awt.event 包的外部定义）的子类定义的事件 ID 值应该大于 RESERVED_ID_MAX 定义的值。

Component 子类需要此子类中定义的事件掩码，它使用 Component.enableEvents() 来选择未被已注册侦听器选择的事件类型。如果在一个组件上注册了侦听器，则该组件已经在内部设置了适当的事件掩码。

也使用该掩码来指定 AWTEventListener 应该侦听的事件类型。用按位或运算将该掩码集中起来，并传递给 Toolkit.addAWTEventListener。

从以下版本开始：
1.1
另请参见：
Component.enableEvents(long), Toolkit.addAWTEventListener(java.awt.event.AWTEventListener, long), ActionEvent, AdjustmentEvent, ComponentEvent, ContainerEvent, FocusEvent, InputMethodEvent, InvocationEvent, ItemEvent, HierarchyEvent, KeyEvent, MouseEvent, MouseWheelEvent, PaintEvent, TextEvent, WindowEvent, 序列化表格

字段摘要
static long | ACTION_EVENT_MASK 用于选择操作事件的事件掩码。
static long | ADJUSTMENT_EVENT_MASK 用于选择调整事件的事件掩码。
static long | COMPONENT_EVENT_MASK 用于选择组件事件的事件掩码。
protected boolean | consumed 在源处理了事件之后，控制是否将事件发送回同位体，false 表示将事件发送给同位体；true 则不发送。
static long | CONTAINER_EVENT_MASK 用于选择容器事件的事件掩码。
static long | FOCUS_EVENT_MASK 用于选择焦点事件的事件掩码。
static long | HIERARCHY_BOUNDS_EVENT_MASK 用于选择层次结构边界事件的事件掩码。
static long | HIERARCHY_EVENT_MASK 用于选择层次结构事件的事件掩码。
protected int | id 事件的 id。
static long | INPUT_METHOD_EVENT_MASK 用于选择输入方法事件的事件掩码。
static long | INVOCATION_EVENT_MASK 用于选择调用事件的事件掩码。
static long | ITEM_EVENT_MASK 用于选择项事件的事件掩码。
static long | KEY_EVENT_MASK 用于选择键事件的事件掩码。
static long | MOUSE_EVENT_MASK 用于选择鼠标事件的事件掩码。
static long | MOUSE_MOTION_EVENT_MASK 用于选择鼠标动作事件的事件掩码。
static long | MOUSE_WHEEL_EVENT_MASK 用于选择鼠标滚轮事件的事件掩码。
static long | PAINT_EVENT_MASK 用于选择绘制事件的事件掩码。
static int | RESERVED_ID_MAX 保留的 AWT 事件 ID 的最大值。
static long | TEXT_EVENT_MASK 用于选择文本事件的事件掩码。
static long | WINDOW_EVENT_MASK 用于选择窗口事件的事件掩码。
static long | WINDOW_FOCUS_EVENT_MASK 用于选择窗口焦点事件的事件掩码。
static long | WINDOW_STATE_EVENT_MASK 用于选择窗口状态事件的事件掩码。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
AWTEvent(Event event)
从 1.0 样式的事件参数构造一个 AWTEvent 对象。
AWTEvent(Object source, int id)
使用指定的源对象和类型构造一个 AWTEvent 对象。
方法摘要
protected void | consume() 如果能够使用此事件，则使用此事件。
int | getID() 返回事件类型。
protected boolean | isConsumed() 返回是否已经使用了此事件。
String | paramString() 返回表示此 Event 状态的字符串。
void | setSource(Object newSource) 将事件的目标更改为新的源。
String | toString() 返回此对象的字符串表示形式。
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

id

protected int id
事件的 id。

另请参见：
getID(), AWTEvent(java.lang.Object, int)

consumed

protected boolean consumed
在源处理了事件之后，控制是否将事件发送回同位体，false 表示将事件发送给同位体；true 则不发送。语义事件始终具有 'true' 值，因为它们由响应低级别事件的同位体生成。

另请参见：
consume(), isConsumed()

COMPONENT_EVENT_MASK

public static final long COMPONENT_EVENT_MASK
用于选择组件事件的事件掩码。

另请参见：
常量字段值

CONTAINER_EVENT_MASK

public static final long CONTAINER_EVENT_MASK
用于选择容器事件的事件掩码。

另请参见：
常量字段值

FOCUS_EVENT_MASK

public static final long FOCUS_EVENT_MASK
用于选择焦点事件的事件掩码。

另请参见：
常量字段值

KEY_EVENT_MASK

public static final long KEY_EVENT_MASK
用于选择键事件的事件掩码。

另请参见：
常量字段值

MOUSE_EVENT_MASK

public static final long MOUSE_EVENT_MASK
用于选择鼠标事件的事件掩码。

另请参见：
常量字段值

MOUSE_MOTION_EVENT_MASK

public static final long MOUSE_MOTION_EVENT_MASK
用于选择鼠标动作事件的事件掩码。

另请参见：
常量字段值

WINDOW_EVENT_MASK

public static final long WINDOW_EVENT_MASK
用于选择窗口事件的事件掩码。

另请参见：
常量字段值

ACTION_EVENT_MASK

public static final long ACTION_EVENT_MASK
用于选择操作事件的事件掩码。

另请参见：
常量字段值

ADJUSTMENT_EVENT_MASK

public static final long ADJUSTMENT_EVENT_MASK
用于选择调整事件的事件掩码。

另请参见：
常量字段值

ITEM_EVENT_MASK

public static final long ITEM_EVENT_MASK
用于选择项事件的事件掩码。

另请参见：
常量字段值

TEXT_EVENT_MASK

public static final long TEXT_EVENT_MASK
用于选择文本事件的事件掩码。

另请参见：
常量字段值

INPUT_METHOD_EVENT_MASK

public static final long INPUT_METHOD_EVENT_MASK
用于选择输入方法事件的事件掩码。

另请参见：
常量字段值

PAINT_EVENT_MASK

public static final long PAINT_EVENT_MASK
用于选择绘制事件的事件掩码。

另请参见：
常量字段值

INVOCATION_EVENT_MASK

public static final long INVOCATION_EVENT_MASK
用于选择调用事件的事件掩码。

另请参见：
常量字段值

HIERARCHY_EVENT_MASK

public static final long HIERARCHY_EVENT_MASK
用于选择层次结构事件的事件掩码。

另请参见：
常量字段值

HIERARCHY_BOUNDS_EVENT_MASK

public static final long HIERARCHY_BOUNDS_EVENT_MASK
用于选择层次结构边界事件的事件掩码。

另请参见：
常量字段值

MOUSE_WHEEL_EVENT_MASK

public static final long MOUSE_WHEEL_EVENT_MASK
用于选择鼠标滚轮事件的事件掩码。

从以下版本开始：
1.4
另请参见：
常量字段值

WINDOW_STATE_EVENT_MASK

public static final long WINDOW_STATE_EVENT_MASK
用于选择窗口状态事件的事件掩码。

从以下版本开始：
1.4
另请参见：
常量字段值

WINDOW_FOCUS_EVENT_MASK

public static final long WINDOW_FOCUS_EVENT_MASK
用于选择窗口焦点事件的事件掩码。

从以下版本开始：
1.4
另请参见：
常量字段值

RESERVED_ID_MAX

public static final int RESERVED_ID_MAX
保留的 AWT 事件 ID 的最大值。定义自己的事件 ID 的程序应该使用大于此值的 ID。

另请参见：
常量字段值
构造方法详细信息

AWTEvent

public AWTEvent(Event event)
从 1.0 样式的事件参数构造一个 AWTEvent 对象。

参数：
event - 旧式的事件

AWTEvent

public AWTEvent(Object source,
                int id)
使用指定的源对象和类型构造一个 AWTEvent 对象。

参数：
source - 产生该事件的对象
方法详细信息

setSource

public void setSource(Object newSource)
将事件的目标更改为新的源。此方法通常用于将事件的目标更改为最初的重量级源的轻量级子组件。

只有事件目标子系统才能使用此方法，如客户机定义的 KeyboardFocusManager。一般的客户机不能使用。

参数：
newSource - 指派事件的新对象
从以下版本开始：
1.4

getID

public int getID()
返回事件类型。

toString

public String toString()
返回此对象的字符串表示形式。

覆盖：
类 EventObject 中的 toString
返回：
该 EventObject 的 String 表示形式。

paramString

public String paramString()
返回表示此 Event 状态的字符串。此方法仅在进行调试的时候使用，返回的字符串的内容和格式也根据不同的实现而不同。返回的字符串可以为空，但不可以为 null。

返回：
此事件的字符串表示形式

consume

protected void consume()
如果能够使用此事件，则使用此事件。只能使用低级别的系统事件。

isConsumed

protected boolean isConsumed()
返回是否已经使用了此事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTEventMulticaster (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 AWTEventMulticaster

java.lang.Object
    继承者  java.awt.AWTEventMulticaster
所有已实现的接口：
ActionListener, AdjustmentListener, ComponentListener, ContainerListener, FocusListener, HierarchyBoundsListener, HierarchyListener, InputMethodListener, ItemListener, KeyListener, MouseListener, MouseMotionListener, MouseWheelListener, TextListener, WindowFocusListener, WindowListener, WindowStateListener, EventListener
public class AWTEventMulticaster
extends Object
implements ComponentListener, ContainerListener, FocusListener, KeyListener, MouseListener, MouseMotionListener, WindowListener, WindowFocusListener, WindowStateListener, ActionListener, ItemListener, AdjustmentListener, TextListener, InputMethodListener, HierarchyListener, HierarchyBoundsListener, MouseWheelListener

AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

以下实例阐释了如何使用此类：

 public myComponent extends Component {
     ActionListener actionListener = null;

     public synchronized void addActionListener(ActionListener l) {
           actionListener = AWTEventMulticaster.add(actionListener, l);
     }
     public synchronized void removeActionListener(ActionListener l) {
           actionListener = AWTEventMulticaster.remove(actionListener, l);
     }
     public void processEvent(AWTEvent e) {
         // when event occurs which causes "action" semantic
         ActionListener listener = actionListener;
         if (listener != null) {
             listener.actionPerformed(new ActionEvent());
         }
     }
 }
需要重点注意的是 add 和 remove 方法的第一个参数，它是维护侦听器的字段。此外，必须将 add 和 remove 方法的结果分配给维护侦听器的字段。

AWTEventMulticaster 是作为一对 EventListeners 实现的，它们在构造时被设置。AWTEventMulticaster 是不可变的。add 和 remove 方法不得以任何方式改变 AWTEventMulticaster。如有必要，可以创建一个新的 AWTEventMulticaster。以这种方式在指派事件的过程中添加和移除侦听器是安全的。但是，不会向目前正指派的事件通知事件指派操作过程中添加的事件侦听器。

允许所有 add 方法使用 null 参数。如果第一个参数是 null，则返回第二个参数。如果第一个参数不是 null，而第二个参数是 null，则返回第一个参数。如果两个参数都是 non-null，则使用这两个参数创建一个新的 AWTEventMulticaster 并返回它。

对于使用两个参数的 remove 方法，返回以下内容：

  • null，如果第一个参数是 null，或者参数相等（==）。
  • 第一个参数，如果第一个参数不是一个 AWTEventMulticaster 实例。
  • 在将第二个参数提供给 remove(EventListener) 方法的情况下，对第一个参数调用 remove(EventListener) 的结果。

Swing 基于类似的逻辑使用 EventListenerList。有关细节，请参见 EventListenerList。

从以下版本开始：
1.1
另请参见：
EventListenerList

字段摘要
protected EventListener | a
protected EventListener | b
构造方法摘要
protected AWTEventMulticaster(EventListener a, EventListener b)
创建一个将侦听器 a 和侦听器 b 链接起来的事件多路广播器实例。
方法摘要
 void actionPerformed(ActionEvent e)
通过在侦听器 a 和侦听器 b 上调用 actionPerformed 方法处理 actionPerformed 事件。
static ActionListener add(ActionListener a, ActionListener b)
添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。
static AdjustmentListener add(AdjustmentListener a, AdjustmentListener b)
添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。
static ComponentListener add(ComponentListener a, ComponentListener b)
添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。
static ContainerListener add(ContainerListener a, ContainerListener b)
添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。
static FocusListener add(FocusListener a, FocusListener b)
添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。
static HierarchyBoundsListener add(HierarchyBoundsListener a, HierarchyBoundsListener b)
添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。
static HierarchyListener add(HierarchyListener a, HierarchyListener b)
添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。
static InputMethodListener add(InputMethodListener a, InputMethodListener b)
添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。
static ItemListener add(ItemListener a, ItemListener b)
添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。
static KeyListener add(KeyListener a, KeyListener b)
添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。
static MouseListener add(MouseListener a, MouseListener b)
添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。
static MouseMotionListener add(MouseMotionListener a, MouseMotionListener b)
添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。
static MouseWheelListener add(MouseWheelListener a, MouseWheelListener b)
添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。
static TextListener add(TextListener a, TextListener b)
static WindowFocusListener add(WindowFocusListener a, WindowFocusListener b)
添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。
static WindowListener add(WindowListener a, WindowListener b)
添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。
static WindowStateListener add(WindowStateListener a, WindowStateListener b)
添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。
protected static EventListener addInternal(EventListener a, EventListener b)
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。
 void adjustmentValueChanged(AdjustmentEvent e)
通过在侦听器 a 和侦听器 b 上调用 adjustmentValueChanged 方法处理 adjustmentValueChanged 事件。
 void ancestorMoved(HierarchyEvent e)
通过在侦听器 a 和侦听器 b 上调用 ancestorMoved 方法处理 ancestorMoved 事件。
 void ancestorResized(HierarchyEvent e)
通过在侦听器 a 和侦听器 b 上调用 ancestorResized 方法处理 ancestorResized 事件。
 void caretPositionChanged(InputMethodEvent e)
通过在侦听器 a 和侦听器 b 上调用 caretPositionChanged 方法处理 caretPositionChanged 事件。
 void componentAdded(ContainerEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentAdded 方法处理 componentAdded 容器事件。
 void componentHidden(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentHidden 方法处理 componentHidden 事件。
 void componentMoved(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentMoved 方法处理 componentMoved 事件。
 void componentRemoved(ContainerEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentRemoved 方法处理 componentRemoved 容器事件。
 void componentResized(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentResized 方法处理 componentResized 事件。
 void componentShown(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentShown 方法处理 componentShown 事件。
 void focusGained(FocusEvent e)
通过在侦听器 a 和侦听器 b 上调用 focusGained 方法处理 focusGained 事件。
 void focusLost(FocusEvent e)
通过在侦听器 a 和侦听器 b 上调用 focusLost 方法处理 focusLost 事件。
static
<T extends EventListener>
T[]
getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
 void hierarchyChanged(HierarchyEvent e)
通过在侦听器 a 和侦听器 b 上调用 hierarchyChanged 方法处理 hierarchyChanged 事件。
 void inputMethodTextChanged(InputMethodEvent e)
通过在侦听器 a 和侦听器 b 上调用 inputMethodTextChanged 方法处理 inputMethodTextChanged 事件。
 void itemStateChanged(ItemEvent e)
通过在侦听器 a 和侦听器 b 上调用 itemStateChanged 方法处理 itemStateChanged 事件。
 void keyPressed(KeyEvent e)
通过在侦听器 a 和侦听器 b 上调用 keyPressed 方法处理 keyPressed 事件。
 void keyReleased(KeyEvent e)
通过在侦听器 a 和侦听器 b 上调用 keyReleased 方法处理 keyReleased 事件。
 void keyTyped(KeyEvent e)
通过在侦听器 a 和侦听器 b 上调用 keyTyped 方法处理 keyTyped 事件。
 void mouseClicked(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseClicked 方法处理 mouseClicked 事件。
 void mouseDragged(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseDragged 方法处理 mouseDragged 事件。
 void mouseEntered(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseEntered 方法处理 mouseEntered 事件。
 void mouseExited(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseExited 方法处理 mouseExited 事件。
 void mouseMoved(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseMoved 方法处理 mouseMoved 事件。
 void mousePressed(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mousePressed 方法处理 mousePressed 事件。
 void mouseReleased(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseReleased 方法处理 mouseReleased 事件。
 void mouseWheelMoved(MouseWheelEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseWheelMoved 方法处理 mouseWheelMoved 事件。
static ActionListener remove(ActionListener l, ActionListener oldl)
从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。
static AdjustmentListener remove(AdjustmentListener l, AdjustmentListener oldl)
从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。
static ComponentListener remove(ComponentListener l, ComponentListener oldl)
从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。
static ContainerListener remove(ContainerListener l, ContainerListener oldl)
从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。
protected  EventListener remove(EventListener oldl)
从此多路广播器中移除一个侦听器。
static FocusListener remove(FocusListener l, FocusListener oldl)
从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。
static HierarchyBoundsListener remove(HierarchyBoundsListener l, HierarchyBoundsListener oldl)
从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。
static HierarchyListener remove(HierarchyListener l, HierarchyListener oldl)
从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。
static InputMethodListener remove(InputMethodListener l, InputMethodListener oldl)
从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。
static ItemListener remove(ItemListener l, ItemListener oldl)
从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。
static KeyListener remove(KeyListener l, KeyListener oldl)
从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。
static MouseListener remove(MouseListener l, MouseListener oldl)
从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。
static MouseMotionListener remove(MouseMotionListener l, MouseMotionListener oldl)
从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。
static MouseWheelListener remove(MouseWheelListener l, MouseWheelListener oldl)
从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。
static TextListener remove(TextListener l, TextListener oldl)
static WindowFocusListener remove(WindowFocusListener l, WindowFocusListener oldl)
从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。
static WindowListener remove(WindowListener l, WindowListener oldl)
从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。
static WindowStateListener remove(WindowStateListener l, WindowStateListener oldl)
从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。
protected static EventListener removeInternal(EventListener l, EventListener oldl)
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。
protected static void save(ObjectOutputStream s, String k, EventListener l)
protected  void saveInternal(ObjectOutputStream s, String k)
 void textValueChanged(TextEvent e)
文本的值已改变时调用。
 void windowActivated(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowActivated 方法处理 windowActivated 事件。
 void windowClosed(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowClosed 方法处理 windowClosed 事件。
 void windowClosing(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowClosing 方法处理 windowClosing 事件。
 void windowDeactivated(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowDeactivated 方法处理 windowDeactivated 事件。
 void windowDeiconified(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowDeiconified 方法处理 windowDeiconified 事件。
 void windowGainedFocus(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowGainedFocus 方法处理 windowGainedFocus 事件。
 void windowIconified(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowIconified 方法处理 windowIconified 事件。
 void windowLostFocus(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowLostFocus 方法处理 windowLostFocus 事件。
 void windowOpened(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowOpened 方法处理 windowOpened 事件。
 void windowStateChanged(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowStateChanged 方法处理 windowStateChanged 事件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

a

protected final EventListener a

b

protected final EventListener b
构造方法详细信息

AWTEventMulticaster

protected AWTEventMulticaster(EventListener a,
                              EventListener b)
创建一个将侦听器 a 和侦听器 b 链接起来的事件多路广播器实例。输入参数 a 和 b 不应为 null，对于是否选择在这种情况下抛出 NullPointerException，因实现不同而各不相同。

参数：
a - 侦听器 a
b - 侦听器 b
方法详细信息

remove

protected EventListener remove(EventListener oldl)
从此多路广播器中移除一个侦听器。

除了所有出现的 oldl 之外，返回的多路广播器包含此多路广播器中的所有侦听器。如果得到的多路广播器只包含可能返回的常规侦听器。如果得到的多路广播器为空，则可能返回 null。

如果 oldl 为 null，不会有异常抛出。

参数：
oldl - 要移除的侦听器
返回：
得到的侦听器

componentResized

public void componentResized(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentResized 方法处理 componentResized 事件。

指定者：
接口 ComponentListener 中的 componentResized
参数：
e - 组件事件

componentMoved

public void componentMoved(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentMoved 方法处理 componentMoved 事件。

指定者：
接口 ComponentListener 中的 componentMoved
参数：
e - 组件事件

componentShown

public void componentShown(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentShown 方法处理 componentShown 事件。

指定者：
接口 ComponentListener 中的 componentShown
参数：
e - 组件事件

componentHidden

public void componentHidden(ComponentEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentHidden 方法处理 componentHidden 事件。

指定者：
接口 ComponentListener 中的 componentHidden
参数：
e - 组件事件

componentAdded

public void componentAdded(ContainerEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentAdded 方法处理 componentAdded 容器事件。

指定者：
接口 ContainerListener 中的 componentAdded
参数：
e - 组件事件

componentRemoved

public void componentRemoved(ContainerEvent e)
通过在侦听器 a 和侦听器 b 上调用 componentRemoved 方法处理 componentRemoved 容器事件。

指定者：
接口 ContainerListener 中的 componentRemoved
参数：
e - 组件事件

focusGained

public void focusGained(FocusEvent e)
通过在侦听器 a 和侦听器 b 上调用 focusGained 方法处理 focusGained 事件。

指定者：
接口 FocusListener 中的 focusGained
参数：
e - 焦点事件

focusLost

public void focusLost(FocusEvent e)
通过在侦听器 a 和侦听器 b 上调用 focusLost 方法处理 focusLost 事件。

指定者：
接口 FocusListener 中的 focusLost
参数：
e - 焦点事件

keyTyped

public void keyTyped(KeyEvent e)
通过在侦听器 a 和侦听器 b 上调用 keyTyped 方法处理 keyTyped 事件。

指定者：
接口 KeyListener 中的 keyTyped
参数：
e - 键事件

keyPressed

public void keyPressed(KeyEvent e)
通过在侦听器 a 和侦听器 b 上调用 keyPressed 方法处理 keyPressed 事件。

指定者：
接口 KeyListener 中的 keyPressed
参数：
e - 键事件

keyReleased

public void keyReleased(KeyEvent e)
通过在侦听器 a 和侦听器 b 上调用 keyReleased 方法处理 keyReleased 事件。

指定者：
接口 KeyListener 中的 keyReleased
参数：
e - 键事件

mouseClicked

public void mouseClicked(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseClicked 方法处理 mouseClicked 事件。

指定者：
接口 MouseListener 中的 mouseClicked
参数：
e - 鼠标事件

mousePressed

public void mousePressed(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mousePressed 方法处理 mousePressed 事件。

指定者：
接口 MouseListener 中的 mousePressed
参数：
e - 鼠标事件

mouseReleased

public void mouseReleased(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseReleased 方法处理 mouseReleased 事件。

指定者：
接口 MouseListener 中的 mouseReleased
参数：
e - 鼠标事件

mouseEntered

public void mouseEntered(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseEntered 方法处理 mouseEntered 事件。

指定者：
接口 MouseListener 中的 mouseEntered
参数：
e - 鼠标事件

mouseExited

public void mouseExited(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseExited 方法处理 mouseExited 事件。

指定者：
接口 MouseListener 中的 mouseExited
参数：
e - 鼠标事件

mouseDragged

public void mouseDragged(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseDragged 方法处理 mouseDragged 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
参数：
e - 鼠标事件

mouseMoved

public void mouseMoved(MouseEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseMoved 方法处理 mouseMoved 事件。

指定者：
接口 MouseMotionListener 中的 mouseMoved
参数：
e - 鼠标事件

windowOpened

public void windowOpened(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowOpened 方法处理 windowOpened 事件。

指定者：
接口 WindowListener 中的 windowOpened
参数：
e - 窗口事件

windowClosing

public void windowClosing(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowClosing 方法处理 windowClosing 事件。

指定者：
接口 WindowListener 中的 windowClosing
参数：
e - 窗口事件

windowClosed

public void windowClosed(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowClosed 方法处理 windowClosed 事件。

指定者：
接口 WindowListener 中的 windowClosed
参数：
e - 窗口事件

windowIconified

public void windowIconified(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowIconified 方法处理 windowIconified 事件。

指定者：
接口 WindowListener 中的 windowIconified
参数：
e - 窗口事件
另请参见：
Frame.setIconImage(java.awt.Image)

windowDeiconified

public void windowDeiconified(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowDeiconified 方法处理 windowDeiconified 事件。

指定者：
接口 WindowListener 中的 windowDeiconified
参数：
e - 窗口事件

windowActivated

public void windowActivated(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowActivated 方法处理 windowActivated 事件。

指定者：
接口 WindowListener 中的 windowActivated
参数：
e - 窗口事件

windowDeactivated

public void windowDeactivated(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowDeactivated 方法处理 windowDeactivated 事件。

指定者：
接口 WindowListener 中的 windowDeactivated
参数：
e - 窗口事件

windowStateChanged

public void windowStateChanged(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowStateChanged 方法处理 windowStateChanged 事件。

指定者：
接口 WindowStateListener 中的 windowStateChanged
参数：
e - 窗口事件
从以下版本开始：
1.4

windowGainedFocus

public void windowGainedFocus(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowGainedFocus 方法处理 windowGainedFocus 事件。

指定者：
接口 WindowFocusListener 中的 windowGainedFocus
参数：
e - 窗口事件
从以下版本开始：
1.4

windowLostFocus

public void windowLostFocus(WindowEvent e)
通过在侦听器 a 和侦听器 b 上调用 windowLostFocus 方法处理 windowLostFocus 事件。

指定者：
接口 WindowFocusListener 中的 windowLostFocus
参数：
e - 窗口事件
从以下版本开始：
1.4

actionPerformed

public void actionPerformed(ActionEvent e)
通过在侦听器 a 和侦听器 b 上调用 actionPerformed 方法处理 actionPerformed 事件。

指定者：
接口 ActionListener 中的 actionPerformed
参数：
e - 操作事件

itemStateChanged

public void itemStateChanged(ItemEvent e)
通过在侦听器 a 和侦听器 b 上调用 itemStateChanged 方法处理 itemStateChanged 事件。

指定者：
接口 ItemListener 中的 itemStateChanged
参数：
e - 项事件

adjustmentValueChanged

public void adjustmentValueChanged(AdjustmentEvent e)
通过在侦听器 a 和侦听器 b 上调用 adjustmentValueChanged 方法处理 adjustmentValueChanged 事件。

指定者：
接口 AdjustmentListener 中的 adjustmentValueChanged
参数：
e - 调整事件

textValueChanged

public void textValueChanged(TextEvent e)
从接口 TextListener 复制的描述
文本的值已改变时调用。为此方法所编写的代码在文本改变时执行所需的操作。

指定者：
接口 TextListener 中的 textValueChanged

inputMethodTextChanged

public void inputMethodTextChanged(InputMethodEvent e)
通过在侦听器 a 和侦听器 b 上调用 inputMethodTextChanged 方法处理 inputMethodTextChanged 事件。

指定者：
接口 InputMethodListener 中的 inputMethodTextChanged
参数：
e - 项事件

caretPositionChanged

public void caretPositionChanged(InputMethodEvent e)
通过在侦听器 a 和侦听器 b 上调用 caretPositionChanged 方法处理 caretPositionChanged 事件。

指定者：
接口 InputMethodListener 中的 caretPositionChanged
参数：
e - 项事件

hierarchyChanged

public void hierarchyChanged(HierarchyEvent e)
通过在侦听器 a 和侦听器 b 上调用 hierarchyChanged 方法处理 hierarchyChanged 事件。

指定者：
接口 HierarchyListener 中的 hierarchyChanged
参数：
e - 项事件
从以下版本开始：
1.3
另请参见：
HierarchyEvent.getChangeFlags()

ancestorMoved

public void ancestorMoved(HierarchyEvent e)
通过在侦听器 a 和侦听器 b 上调用 ancestorMoved 方法处理 ancestorMoved 事件。

指定者：
接口 HierarchyBoundsListener 中的 ancestorMoved
参数：
e - 项事件
从以下版本开始：
1.3

ancestorResized

public void ancestorResized(HierarchyEvent e)
通过在侦听器 a 和侦听器 b 上调用 ancestorResized 方法处理 ancestorResized 事件。

指定者：
接口 HierarchyBoundsListener 中的 ancestorResized
参数：
e - 项事件
从以下版本开始：
1.3

mouseWheelMoved

public void mouseWheelMoved(MouseWheelEvent e)
通过在侦听器 a 和侦听器 b 上调用 mouseWheelMoved 方法处理 mouseWheelMoved 事件。

指定者：
接口 MouseWheelListener 中的 mouseWheelMoved
参数：
e - 鼠标事件
从以下版本开始：
1.4
另请参见：
MouseWheelEvent

add

public static ComponentListener add(ComponentListener a,
                                    ComponentListener b)
添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 组件侦听器 a
b - 组件侦听器 b

add

public static ContainerListener add(ContainerListener a,
                                    ContainerListener b)
添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 容器侦听器 a
b - 容器侦听器 b

add

public static FocusListener add(FocusListener a,
                                FocusListener b)
添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 焦点侦听器 a
b - 焦点侦听器 b

add

public static KeyListener add(KeyListener a,
                              KeyListener b)
添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 键侦听器 a
b - 键侦听器 b

add

public static MouseListener add(MouseListener a,
                                MouseListener b)
添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 鼠标侦听器 a
b - 鼠标侦听器 b

add

public static MouseMotionListener add(MouseMotionListener a,
                                      MouseMotionListener b)
添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 鼠标移动侦听器 a
b - 鼠标移动侦听器 b

add

public static WindowListener add(WindowListener a,
                                 WindowListener b)
添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 窗口侦听器 a
b - 窗口侦听器 b

add

public static WindowStateListener add(WindowStateListener a,
                                      WindowStateListener b)
添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 窗口状态侦听器 a
b - 窗口状态侦听器 b
从以下版本开始：
1.4

add

public static WindowFocusListener add(WindowFocusListener a,
                                      WindowFocusListener b)
添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 窗口焦点侦听器 a
b - 窗口焦点侦听器 b
从以下版本开始：
1.4

add

public static ActionListener add(ActionListener a,
                                 ActionListener b)
添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 操作侦听器 a
b - 操作侦听器 b

add

public static ItemListener add(ItemListener a,
                               ItemListener b)
添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 项侦听器 a
b - 项侦听器 b

add

public static AdjustmentListener add(AdjustmentListener a,
                                     AdjustmentListener b)
添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 调整侦听器 a
b - 调整侦听器 b

add

public static TextListener add(TextListener a,
                               TextListener b)

add

public static InputMethodListener add(InputMethodListener a,
                                      InputMethodListener b)
添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 输入方法侦听器 a
b - 输入方法侦听器 b

add

public static HierarchyListener add(HierarchyListener a,
                                    HierarchyListener b)
添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 层次结构侦听器 a
b - 层次结构侦听器 b
从以下版本开始：
1.3

add

public static HierarchyBoundsListener add(HierarchyBoundsListener a,
                                          HierarchyBoundsListener b)
添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 层次结构边界侦听器 a
b - 层次结构边界侦听器 b
从以下版本开始：
1.3

add

public static MouseWheelListener add(MouseWheelListener a,
                                     MouseWheelListener b)
添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。

参数：
a - 鼠标滚轮侦听器 a
b - 鼠标滚轮侦听器 b

remove

public static ComponentListener remove(ComponentListener l,
                                       ComponentListener oldl)
从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。

参数：
l - 组件侦听器 l
oldl - 正移除的组件侦听器

remove

public static ContainerListener remove(ContainerListener l,
                                       ContainerListener oldl)
从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。

参数：
l - 容器侦听器 l
oldl - 正移除的容器侦听器

remove

public static FocusListener remove(FocusListener l,
                                   FocusListener oldl)
从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。

参数：
l - 焦点侦听器 l
oldl - 正移除的焦点侦听器

remove

public static KeyListener remove(KeyListener l,
                                 KeyListener oldl)
从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。

参数：
l - 键侦听器 l
oldl - 正移除的键侦听器

remove

public static MouseListener remove(MouseListener l,
                                   MouseListener oldl)
从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。

参数：
l - 鼠标侦听器 l
oldl - 正移除的鼠标侦听器

remove

public static MouseMotionListener remove(MouseMotionListener l,
                                         MouseMotionListener oldl)
从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。

参数：
l - 鼠标移动侦听器 l
oldl - 正移除的鼠标移动侦听器

remove

public static WindowListener remove(WindowListener l,
                                    WindowListener oldl)
从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。

参数：
l - 窗口侦听器 l
oldl - 正移除的窗口侦听器

remove

public static WindowStateListener remove(WindowStateListener l,
                                         WindowStateListener oldl)
从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。

参数：
l - 窗口状态侦听器 l
oldl - 正移除的窗口状态侦听器
从以下版本开始：
1.4

remove

public static WindowFocusListener remove(WindowFocusListener l,
                                         WindowFocusListener oldl)
从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。

参数：
l - 窗口焦点侦听器 l
oldl - 正移除的窗口焦点侦听器
从以下版本开始：
1.4

remove

public static ActionListener remove(ActionListener l,
                                    ActionListener oldl)
从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。

参数：
l - 操作侦听器 l
oldl - 正移除的操作侦听器

remove

public static ItemListener remove(ItemListener l,
                                  ItemListener oldl)
从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。

参数：
l - 项侦听器 l
oldl - 正移除的项侦听器

remove

public static AdjustmentListener remove(AdjustmentListener l,
                                        AdjustmentListener oldl)
从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。

参数：
l - 调整侦听器 l
oldl - 正移除的调整侦听器

remove

public static TextListener remove(TextListener l,
                                  TextListener oldl)

remove

public static InputMethodListener remove(InputMethodListener l,
                                         InputMethodListener oldl)
从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。

参数：
l - 输入方法侦听器 l
oldl - 正移除的输入方法侦听器

remove

public static HierarchyListener remove(HierarchyListener l,
                                       HierarchyListener oldl)
从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。

参数：
l - 层次结构侦听器 l
oldl - 正移除的层次结构侦听器
从以下版本开始：
1.3

remove

public static HierarchyBoundsListener remove(HierarchyBoundsListener l,
                                             HierarchyBoundsListener oldl)
从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。

参数：
l - 层次结构边界侦听器 l
oldl - 正移除的层次结构边界侦听器
从以下版本开始：
1.3

remove

public static MouseWheelListener remove(MouseWheelListener l,
                                        MouseWheelListener oldl)
从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。

参数：
l - 鼠标滚轮侦听器 l
oldl - 正移除的鼠标滚轮侦听器

addInternal

protected static EventListener addInternal(EventListener a,
                                           EventListener b)
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。如果侦听器 a 为 null，则此方法将返回侦听器 b；如果侦听器 b 为 null，则此方法将返回侦听器 a；如果侦听器 a 和侦听器 b 都不为 null，则返回一个将 a 和 b 链接的新 AWTEventMulticaster 实例。

参数：
a - 事件侦听器 a
b - 事件侦听器 b

removeInternal

protected static EventListener removeInternal(EventListener l,
                                              EventListener oldl)
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。如果侦听器 l 与旧的侦听器相同，或者侦听器 l 为 null，则返回 null。否则，如果侦听器 l 是 AWTEventMulticaster 的一个实例，则从中移除旧的侦听器。其他情况则返回侦听器 l。

参数：
l - 正在其中执行移除操作的侦听器
oldl - 正移除的侦听器

saveInternal

protected void saveInternal(ObjectOutputStream s,
                            String k)
                     throws IOException
抛出：
IOException

save

protected static void save(ObjectOutputStream s,
                           String k,
                           EventListener l)
                    throws IOException
抛出：
IOException

getListeners

public static <T extends EventListener> T[] getListeners(EventListener l,
                                                         Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。FooListener 是使用 addFooListener 方法、通过 AWTEventMulticaster 链接的。如果已指定一个 null 侦听器，则此方法将返回一个空数组。如果指定的侦听器不是 AWTEventMulticaster 的一个实例，则此方法将返回一个只包含指定侦听器的数组。如果没有链接这样的侦听器，则此方法将返回一个空数组。

参数：
l - 指定的 java.util.EventListener
listenerType - 所需的侦听器类型；该参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
通过指定的多路广播侦听器链接为 FooListener 的所有对象的数组，如果没有通过指定的多路广播侦听器链接这样的侦听器，则返回一个空数组
抛出：
NullPointerException - 如果指定的 listenertype 参数为 null
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 AWTException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.AWTException
所有已实现的接口：
Serializable
public class AWTException
extends Exception

表示发生了 Absract Window Toolkit 异常。

另请参见：
序列化表格

构造方法摘要
AWTException(String msg)
构造带指定详细消息的 AWTException 实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AWTException

public AWTException(String msg)
构造带指定详细消息的 AWTException 实例。详细消息是描述此特定异常的 String 的一个实例。

参数：
msg - 详细消息
从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTKeyStroke (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 AWTKeyStroke

java.lang.Object
    继承者  java.awt.AWTKeyStroke
所有已实现的接口：
Serializable
直接已知子类：
KeyStroke
public class AWTKeyStroke
extends Object
implements Serializable

AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。正如 KEY_PRESSED 和 KEY_RELEASED KeyEvent 一样，AWTKeyStroke 仅对应于一个特定键的按下或释放；另一方面，它们与 KEY_TYPED KeyEvent 事件一样，对应于键入一个特定 Java 字符的操作。在所有情况下，AWTKeyStroke 都可以指定修改键（alt、shift、control、meta、altGraph 或它们的组合），在针对精确匹配的操作中，这些修改键必须存在。

AWTKeyStrokes 是不可变的，并且应该是唯一的。客户机代码绝对不能自己创建 AWTKeyStroke，而应该使用 getAWTKeyStroke 的一个变体代替。使用这些工厂方法的客户机允许 AWTKeyStroke 实现有效地缓存和共享实例。

从以下版本开始：
1.4
另请参见：
getAWTKeyStroke(char), 序列化表格

构造方法摘要
protected | AWTKeyStroke() 使用默认值构造 AWTKeyStroke。
protected | AWTKeyStroke(char keyChar, int keyCode, int modifiers, boolean onKeyRelease) 使用指定值构造 AWTKeyStroke。
方法摘要
boolean | equals(Object anObject) 如果此对象与指定对象相同，则返回 true。
static AWTKeyStroke | getAWTKeyStroke(char keyChar) 返回表示指定字符的 KEY_TYPED 事件的 AWTKeyStroke 的一个共享实例。
static AWTKeyStroke | getAWTKeyStroke(Character keyChar, int modifiers) 返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。
static AWTKeyStroke | getAWTKeyStroke(int keyCode, int modifiers) 在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例。
static AWTKeyStroke | getAWTKeyStroke(int keyCode, int modifiers, boolean onKeyRelease) 在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例，指定该键在按下或释放时是否是被激活。
static AWTKeyStroke | getAWTKeyStroke(String s) 分析字符串并返回一个 AWTKeyStroke。
static AWTKeyStroke | getAWTKeyStrokeForEvent(KeyEvent anEvent) 返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。
char | getKeyChar() 返回此 AWTKeyStroke 的字符。
int | getKeyCode() 返回此 AWTKeyStroke 的数字键代码。
int | getKeyEventType() 返回 KeyEvent 的类型，它对应于此 AWTKeyStroke。
int | getModifiers() 返回此 AWTKeyStroke 的修饰符键。
int | hashCode() 返回此对象的数值，它可能是唯一的，将它用作哈希表中的索引值是一个好选择。
boolean | isOnKeyRelease() 返回此 AWTKeyStroke 是否表示一个键释放操作。
protected Object | readResolve() 返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。
protected static void | registerSubclass(Class<?> subclass) 注册一个新类，AWTKeyStroke 中的工厂方法在生成 AWTKeyStroke 的新实例时将使用它。
String | toString() 返回一个显示并标识此对象属性的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AWTKeyStroke

protected AWTKeyStroke()
使用默认值构造 AWTKeyStroke。使用的默认值如下：
属性 | 默认值
Key Char | KeyEvent.CHAR_UNDEFINED
Key Code | KeyEvent.VK_UNDEFINED
Modifiers | none
On key release? | false
不应该通过客户机代码构造 AWTKeyStroke。应该使用 getAWTKeyStroke 的一个变体代替。

另请参见：
getAWTKeyStroke(char)

AWTKeyStroke

protected AWTKeyStroke(char keyChar,
                       int keyCode,
                       int modifiers,
                       boolean onKeyRelease)
使用指定值构造 AWTKeyStroke。不应该通过客户机代码构造 AWTKeyStroke。应该使用 getAWTKeyStroke 的一个变体代替。

参数：
keyChar - 键盘上某个键的字符值
keyCode - 此 AWTKeyStroke 的键代码
modifiers - 任意修饰符的按位或组合
onKeyRelease - 如果此 AWTKeyStroke 对应一个键释放，则该参数为 true；否则为 false
另请参见：
getAWTKeyStroke(char)
方法详细信息

registerSubclass

protected static void registerSubclass(Class<?> subclass)
注册一个新类，AWTKeyStroke 中的工厂方法在生成 AWTKeyStroke 的新实例时将使用它。调用此方法后，工厂方法将返回指定类的实例。指定的类必须是 AWTKeyStroke 或者从 AWTKeyStroke 派生的类，并且它必须有一个无参数构造方法。此构造方法可以具有任意的可访问性，其中包括 private。此操作刷新当前的 AWTKeyStroke 缓存。

参数：
subclass - 工厂方法应该创建其实例的新类
抛出：
IllegalArgumentException - 如果 subclass 为 null，或者 subclass 没有无参数构造方法
ClassCastException - 如果 subclass 不是 AWTKeyStroke 或者从 AWTKeyStroke 派生的类

getAWTKeyStroke

public static AWTKeyStroke getAWTKeyStroke(char keyChar)
返回表示指定字符的 KEY_TYPED 事件的 AWTKeyStroke 的一个共享实例。

参数：
keyChar - 键盘上某个键的字符值
返回：
该键的 AWTKeyStroke 对象

getAWTKeyStroke

public static AWTKeyStroke getAWTKeyStroke(Character keyChar,
                                           int modifiers)
返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。注意，第一个参数是 Character 类型而不是 char 类型。这是为了避免在调用 getAWTKeyStroke(int keyCode, int modifiers) 时发生无意的冲突。修饰符由以下任意组合组成：
  • java.awt.event.InputEvent.SHIFT_DOWN_MASK
  • java.awt.event.InputEvent.CTRL_DOWN_MASK
  • java.awt.event.InputEvent.META_DOWN_MASK
  • java.awt.event.InputEvent.ALT_DOWN_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
也可以使用下面列出的旧的修改键，但它们被映射到 _DOWN_ 修饰符。
  • java.awt.event.InputEvent.SHIFT_MASK
  • java.awt.event.InputEvent.CTRL_MASK
  • java.awt.event.InputEvent.META_MASK
  • java.awt.event.InputEvent.ALT_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_MASK
也可以使用，但它们被映射到 _DOWN_ 修饰符。因为这些数字都是 2 的不同次幂，所以它们的任意组合是一个整数，该整数的每个位都表示一个不同的修饰符键。可以使用 0 指定无修饰符。

参数：
keyChar - 键盘字符的 Character 对象
modifiers - 任意修饰符的按位或组合
返回：
该键的 AWTKeyStroke 对象
抛出：
IllegalArgumentException - 如果 keyChar 为 null
另请参见：
InputEvent

getAWTKeyStroke

public static AWTKeyStroke getAWTKeyStroke(int keyCode,
                                           int modifiers,
                                           boolean onKeyRelease)
在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例，指定该键在按下或释放时是否是被激活。

可以使用在 java.awt.event.KeyEvent 中定义的“虚拟键”常量来指定键代码。例如：

  • java.awt.event.KeyEvent.VK_ENTER
  • java.awt.event.KeyEvent.VK_TAB
  • java.awt.event.KeyEvent.VK_SPACE
修饰符由以下任意组合组成：
  • java.awt.event.InputEvent.SHIFT_DOWN_MASK
  • java.awt.event.InputEvent.CTRL_DOWN_MASK
  • java.awt.event.InputEvent.META_DOWN_MASK
  • java.awt.event.InputEvent.ALT_DOWN_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
旧的修饰符
  • java.awt.event.InputEvent.SHIFT_MASK
  • java.awt.event.InputEvent.CTRL_MASK
  • java.awt.event.InputEvent.META_MASK
  • java.awt.event.InputEvent.ALT_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_MASK
也可以使用，但它们被映射到 _DOWN_ 修饰符。因为这些数字都是 2 的不同次幂，所以它们的任意组合是一个整数，该整数的每个位都表示一个不同的修饰符键。可以使用 0 指定无修饰符。

参数：
keyCode - 一个 int，指定键盘上某个键的数字代码
modifiers - 任意修饰符的按位或组合
onKeyRelease - 如果 AWTKeyStroke 应该表示一个键释放，则该参数为 true；否则为 false
返回：
该键的 AWTKeyStroke 对象
另请参见：
KeyEvent, InputEvent

getAWTKeyStroke

public static AWTKeyStroke getAWTKeyStroke(int keyCode,
                                           int modifiers)
在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例。返回的 AWTKeyStroke 将对应于一个按键操作。

可以使用在 java.awt.event.KeyEvent 中定义的“虚拟键”常量来指定键代码。例如：

  • java.awt.event.KeyEvent.VK_ENTER
  • java.awt.event.KeyEvent.VK_TAB
  • java.awt.event.KeyEvent.VK_SPACE
修饰符由以下任意组合组成：
  • java.awt.event.InputEvent.SHIFT_DOWN_MASK
  • java.awt.event.InputEvent.CTRL_DOWN_MASK
  • java.awt.event.InputEvent.META_DOWN_MASK
  • java.awt.event.InputEvent.ALT_DOWN_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
旧的修饰符
  • java.awt.event.InputEvent.SHIFT_MASK
  • java.awt.event.InputEvent.CTRL_MASK
  • java.awt.event.InputEvent.META_MASK
  • java.awt.event.InputEvent.ALT_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_MASK
也可以使用，但它们被映射到 _DOWN_ 修饰符。 因为这些数字都是 2 的不同次幂，所以它们的任意组合是一个整数，该整数的每个位都表示一个不同的修饰符键。可以使用 0 指定无修饰符。

参数：
keyCode - 一个 int，指定键盘上某个键的数字代码
modifiers - 任意修饰符的按位或组合
返回：
该键的 AWTKeyStroke 对象
另请参见：
KeyEvent, InputEvent

getAWTKeyStrokeForEvent

public static AWTKeyStroke getAWTKeyStrokeForEvent(KeyEvent anEvent)
返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。

此方法获得来自 KeyTyped 事件的 keyChar，以及来自 KeyPressed 或 KeyReleased 事件的 keyCode。为所有三种类型的 KeyEvent 获取 KeyEvent 修饰符。

参数：
anEvent - 从中获取 AWTKeyStroke 的 KeyEvent
返回：
促使该事件发生的 AWTKeyStroke
抛出：
NullPointerException - 如果 anEvent 为 null

getAWTKeyStroke

public static AWTKeyStroke getAWTKeyStroke(String s)
分析字符串并返回一个 AWTKeyStroke。该字符串必须具有以下语法：
    <modifiers>* (<typedID> | <pressedReleasedID>)

    modifiers := shift | control | ctrl | meta | alt | altGraph
    typedID := typed <typedKey>
    typedKey := string of length 1 giving Unicode character.
    pressedReleasedID := (pressed | released) key
    key := KeyEvent key code name, i.e. the name following "VK_".
如果没有指定是键入、按下还是释放，则假定为按下。以下是一些示例：
     "INSERT" => getAWTKeyStroke(KeyEvent.VK_INSERT, 0);
     "control DELETE" => getAWTKeyStroke(KeyEvent.VK_DELETE, InputEvent.CTRL_MASK);
     "alt shift X" => getAWTKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK);
     "alt shift released X" => getAWTKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK, true);
     "typed a" => getAWTKeyStroke('a');

参数：
s - 用上述方法格式化的一个字符串
返回：
该字符串的一个 AWTKeyStroke 对象
抛出：
IllegalArgumentException - 如果 s 为 null，或者没有被正确地格式化

getKeyChar

public final char getKeyChar()
返回此 AWTKeyStroke 的字符。

返回：
一个 char 值
另请参见：
getAWTKeyStroke(char), KeyEvent.getKeyChar()

getKeyCode

public final int getKeyCode()
返回此 AWTKeyStroke 的数字键代码。

返回：
一个 int，它包含键代码值
另请参见：
getAWTKeyStroke(int,int), KeyEvent.getKeyCode()

getModifiers

public final int getModifiers()
返回此 AWTKeyStroke 的修饰符键。

返回：
一个 int，它包含修饰符
另请参见：
getAWTKeyStroke(int,int)

isOnKeyRelease

public final boolean isOnKeyRelease()
返回此 AWTKeyStroke 是否表示一个键释放操作。

返回：
如果此 AWTKeyStroke 表示一个键释放操作，则返回 true；否则返回 false
另请参见：
getAWTKeyStroke(int,int,boolean)

getKeyEventType

public final int getKeyEventType()
返回 KeyEvent 的类型，它对应于此 AWTKeyStroke。

返回：
KeyEvent.KEY_PRESSED、KeyEvent.KEY_TYPED 或 KeyEvent.KEY_RELEASED
另请参见：
KeyEvent

hashCode

public int hashCode()
返回此对象的数值，它可能是唯一的，将它用作哈希表中的索引值是一个好选择。

覆盖：
类 Object 中的 hashCode
返回：
表示此对象的一个 int
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public final boolean equals(Object anObject)
如果此对象与指定对象相同，则返回 true。

覆盖：
类 Object 中的 equals
参数：
anObject - 将与此对象进行比较的对象
返回：
如果两个对象相同，则返回 true
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回一个显示并标识此对象属性的字符串。可以将此方法返回的 String 作为参数传递给 getAWTKeyStroke(String)，以生成一个与此键击等效的键击。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式
另请参见：
getAWTKeyStroke(String)

readResolve

protected Object readResolve()
                      throws ObjectStreamException
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。

返回：
一个与此实例相等的缓存实例
抛出：
ObjectStreamException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 AWTPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.awt.AWTPermission
所有已实现的接口：
Serializable, Guard
public final class AWTPermission
extends BasicPermission

此类用于 AWT 权限。AWTPermission 包含一个目标名称，但是不包括操作列表；您可以有指定的权限，也可以没有。

目标名称是 AWT 权限的名称（参见下面内容）。命名约定遵守层次结构属性命名约定。另外，可以用星号来表示所有的 AWT 权限。

下表列出了所有可能的 AWTPermission 目标名称，并描述了每个名称允许何种权限，还讨论了授权代码权限的风险。

权限目标名称 | 权限允许的操作 | 允许权限所带来的风险
accessClipboard | 向 AWT 剪贴板发送信息，以及获取来自 AWT 剪贴板的信息 | 这将允许非法代码共享潜在的敏感（或机密）信息。
accessEventQueue | 访问 AWT 事件队列 | 检索 AWT 事件队列之后，恶意代码可能窥视甚至从其事件队列中移除现有的事件，也可能蓄意发出虚假事件，这些虚假事件可能以不安全的方式导致应用程序或 applet 行为异常。
accessSystemTray | 访问 AWT SystemTray 实例 | 这将允许使用恶意代码将托盘图标 (tray icon) 添加到系统托盘。首先，这样的图标看起来可能类似于某些已知应用程序的图标（比如防火墙或杀毒软件），它会命令用户做一些不安全的事（帮助发布大量虚假消息）。其次，系统托盘可能被托盘图标所充斥，从而无法再添加托盘图标。
createRobot | 创建 java.awt.Robot 对象 | java.awt.Robot 对象允许代码生成本机级别的鼠标和键盘事件，还允许读取屏幕内容。它可能允许恶意代码控制系统、运行其他程序、读取显示内容，以及拒绝用户访问鼠标和键盘。
fullScreenExclusive | 进入全屏独占模式 | 进入全屏独占模式允许直接访问低层的显卡内存。这可能欺骗系统，因为程序直接控制了显示。
listenToAllAWTEvents | 在系统范围内侦听所有 AWT 事件 | 添加 AWT 事件侦听器后，恶意代码可能扫描系统中指派的所有 AWT 事件，从而允许它读取所有用户输入（如密码）。每个 AWT 事件侦听器都是从该事件队列的 EventDispatchThread 上下文中调用的，因此，如果同时启用了 accessEventQueue 权限，那么恶意代码就能在系统范围内修改 AWT 事件队列的上下文，从而以不安全的方式导致应用程序或 applet 行为异常。
readDisplayPixels | 从显示器屏幕读回像素 | 接口（如 java.awt.Composite 接口）或 java.awt.Robot 类允许任意代码检查显示器上的像素，这使得恶意代码能窥探用户的活动。
replaceKeyboardFocusManager | 设置特定线程的 KeyboardFocusManager。 | 当安装 SecurityManager 时，必须将此权限授权给调用线程，以便替代当前的 KeyboardFocusManager。如果没有授权，则抛出 SecurityException。
setAppletStub | 设置实现 Applet 容器服务的 stub | 恶意代码可能设置 applet 的 stub，这将导致不可预料的行为或拒绝对 applet 服务。
setWindowAlwaysOnTop | 设置窗口的 always-on-top 属性： | 恶意窗口可能会伪装成一个真实完整的桌面，于是，对此毫不怀疑的用户输入的信息将会被捕获，随后被滥用。
showWindowWithoutWarningBanner | 显示窗口，但不显示 applet 创建窗口的标志警告 | 没有此警告，可能突然弹出 applet 窗口，而用户却不知道它们属于 applet。因为用户可以基于窗口是否属于 applet 做出安全敏感的决策（例如，在对话框中输入用户名和密码），所以禁用此警告标志可能允许 applet 欺骗用户去输入这些信息。
toolkitModality | 创建 TOOLKIT_MODAL 对话框并设置 TOOLKIT_EXCLUDE 窗口属性。 | 当从某一个 applet 显示工具包模式的对话框时，浏览器中的其他所有 applet 都将受阻塞。当从 Java Web Start 启动应用程序时，它的窗口（比如安全对话框）也可能被此工具包模式对话框阻塞，并从这些应用程序显示。
watchMousePointer | 获取任意时间鼠标指针位置的信息 | 通过对鼠标指针的持续观察，applet 可以猜出用户正在做的事情，也就是说，将鼠标移动到屏幕左下角很可能意味着用户将要启动某个应用程序。如果使用了虚拟键区，从而可以用鼠标模拟键盘，applet 可以猜出正在键入的文字。

另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
AWTPermission(String name)
创建具有指定名称的新 AWTPermission。
AWTPermission(String name, String actions)
创建具有指定名称的新 AWTPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AWTPermission

public AWTPermission(String name)
创建具有指定名称的新 AWTPermission。参数 name 是 AWTPermission 的符号名，如 "topLevelWindow"、"systemClipboard" 等等。可以使用星号来指示所有的 AWT 权限。

参数：
name - AWTPermission 的名称
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

AWTPermission

public AWTPermission(String name,
                     String actions)
创建具有指定名称的新 AWTPermission 对象。参数 name 是 AWTPermission 的符号名，actions 字符串目前未被使用，应该为 null。

参数：
name - AWTPermission 的名称
actions - 应该为 null
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicStroke (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 BasicStroke

java.lang.Object
    继承者  java.awt.BasicStroke
所有已实现的接口：
Stroke
public class BasicStroke
extends Object
implements Stroke

BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。由 BasicStroke 定义的呈现属性描述了用画笔沿 Shape 的轮廓绘制的某个标记的形状，以及应用在 Shape 路径线段的末端和连接处的装饰。 这些呈现属性包括：

width
画笔的宽度，是垂直于画笔轨迹的测量值。
end caps
在未封闭子路径和虚线线段的末端应用的一些装饰。如果子路径没有 CLOSE 段，则在同一点上开始和结束的子路径仍被认为是未封闭的。关于 CLOSE 段的更多信息，请参阅 SEG_CLOSE。三个不同的装饰是：CAP_BUTT、CAP_ROUND 和 CAP_SQUARE。
line joins
在两个路径线段的交汇处，以及使用 SEG_CLOSE 封闭的子路径端点的交汇处应用的装饰。三个不同的装饰是：JOIN_BEVEL、JOIN_MITER 和 JOIN_ROUND。
miter limit
对剪裁具有 JOIN_MITER 装饰的线接合点的限制。当斜接长度与笔划宽度的比大于 miterlimit 值时，需要剪裁线接合点。斜接长度是斜接的对角线长度，即交汇处的内棱角和外棱角之间的距离。两条线段形成的角度越小，斜接长度就越长，交汇处的角度就越尖锐。默认 miterlimit 值为 10.0f，它会使所有小于 11 度的角都被剪裁。剪裁斜接会使线接合点的装饰变成斜角。
dash attributes
关于如何通过在不透明和透明部分之间交替形成一个虚线模式的定义。
一些属性指定了控制返回轮廓形状的测量和距离，所有这些属性都是在与最初未绘制轮廓的 Shape 参数相同的坐标系中测量的。当 Graphics2D 对象在执行其 draw 方法之一期间使用 Stroke 对象重定义一条路径时，在应用 Graphics2D 转换属性之前，要提供原始形式的几何形状。所以，诸如画笔宽度之类的属性是在 Graphics2D 对象的用户空间坐标系中解释的，并受制于特定 Graphics2D 中用户空间到设备空间转换的缩放和剪切效果。例如，呈现形状的轮廓宽度不仅由此 BasicStroke 的 width 属性确定，还由 Graphics2D 对象的 transform 属性确定。请考虑以下代码：
// sets the Graphics2D object's Tranform attribute g2d.scale(10, 10); // sets the Graphics2D object's Stroke attribute g2d.setStroke(new BasicStroke(1.5f));
假定不对 Graphics2D 对象添加其他任何缩放转换，那么所得到的线条宽度大约是 15 个像素宽。如示例代码所述，浮点线提供了更好的精度，特别是在对 Graphics2D 对象使用大型转换时。当一条线是斜线时，具体的宽度取决于在追踪理论上已加宽的轮廓时，呈现管线选择填充哪些像素。选择开启哪些像素受到 antialiasing 属性的影响，因为抗锯齿呈现管线可以选择给部分覆盖的像素着色。

关于用户空间坐标和呈现过程的更多信息，请参阅 Graphics2D 类的注释。

另请参见：
Graphics2D

字段摘要
static int | CAP_BUTT 无装饰地结束未封闭的子路径和虚线线段。
static int | CAP_ROUND 使用半径等于画笔宽度一半的圆形装饰结束未封闭的子路径和虚线线段。
static int | CAP_SQUARE 使用正方形结束未封闭的子路径和虚线线段，正方形越过线段端点，并延长等于线条宽度一半的距离。
static int | JOIN_BEVEL 通过直线连接宽体轮廓的外角，将路径线段连接在一起。
static int | JOIN_MITER 扩展路径线段的外边缘，直到它们连接在一起。
static int | JOIN_ROUND 通过舍去半径为线长的一半的圆角，将路径线段连接在一起。
构造方法摘要
BasicStroke()
构造一个具有所有属性的默认值的新 BasicStroke。
BasicStroke(float width)
构造一个具有指定线条宽度以及 cap 和 join 风格的默认值的实心 BasicStroke。
BasicStroke(float width, int cap, int join)
构造一个具有指定属性的实心的 BasicStroke。
BasicStroke(float width, int cap, int join, float miterlimit)
构造一个具有指定属性的实心的 BasicStroke。
BasicStroke(float width, int cap, int join, float miterlimit, float[] dash, float dash_phase)
构造一个具有指定属性的新 BasicStroke。
方法摘要
Shape | createStrokedShape(Shape s) 返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。
boolean | equals(Object obj) 测试指定对象与此 BasicStroke 是否相等，首先测试指定对象是否是一个 BasicStroke，然后将其宽度、连接、cap、斜接限制、虚线和虚线相位属性与 BasicStroke 的那些属性进行比较。
float[] | getDashArray() 返回表示虚线线段长度的数组。
float | getDashPhase() 返回当前虚线相位。
int | getEndCap() 返回端点的 cap 样式。
int | getLineJoin() 返回线条连接样式。
float | getLineWidth() 返回线条的宽度。
float | getMiterLimit() 返回斜接的限制。
int | hashCode() 返回此笔划的哈希码。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

JOIN_MITER

public static final int JOIN_MITER
扩展路径线段的外边缘，直到它们连接在一起。

另请参见：
常量字段值

JOIN_ROUND

public static final int JOIN_ROUND
通过舍去半径为线长的一半的圆角，将路径线段连接在一起。

另请参见：
常量字段值

JOIN_BEVEL

public static final int JOIN_BEVEL
通过直线连接宽体轮廓的外角，将路径线段连接在一起。

另请参见：
常量字段值

CAP_BUTT

public static final int CAP_BUTT
无装饰地结束未封闭的子路径和虚线线段。

另请参见：
常量字段值

CAP_ROUND

public static final int CAP_ROUND
使用半径等于画笔宽度一半的圆形装饰结束未封闭的子路径和虚线线段。

另请参见：
常量字段值

CAP_SQUARE

public static final int CAP_SQUARE
使用正方形结束未封闭的子路径和虚线线段，正方形越过线段端点，并延长等于线条宽度一半的距离。

另请参见：
常量字段值
构造方法详细信息

BasicStroke

public BasicStroke(float width,
                   int cap,
                   int join,
                   float miterlimit,
                   float[] dash,
                   float dash_phase)
构造一个具有指定属性的新 BasicStroke。

参数：
width - 此 BasicStroke 的宽度。此宽度必须大于或等于 0.0f。如果将宽度设置为 0.0f，则将笔划呈现为可用于目标设备和抗锯齿提示设置的最细线条。
cap - BasicStroke 端点的装饰
join - 应用在路径线段交汇处的装饰
miterlimit - 斜接处的剪裁限制。miterlimit 必须大于或等于 1.0f。
dash - 表示虚线模式的数组
dash_phase - 开始虚线模式的偏移量
抛出：
IllegalArgumentException - 如果 width 为负
IllegalArgumentException - 如果 cap 既不是 CAP_BUTT，也不是 CAP_ROUND 或 CAP_SQUARE
IllegalArgumentException - 如果 miterlimit 小于 1 并且 join 为 JOIN_MITER
IllegalArgumentException - 如果 join 既不是 JOIN_ROUND，也不是 JOIN_BEVEL 或 JOIN_MITER
IllegalArgumentException - 如果 dash_phase 为负并且 dash 不为 null
IllegalArgumentException - 如果 dash 的长度为零
IllegalArgumentException - 如果所有 dash 的长度都为零。

BasicStroke

public BasicStroke(float width,
                   int cap,
                   int join,
                   float miterlimit)
构造一个具有指定属性的实心的 BasicStroke。

参数：
width - BasicStroke 的宽度
cap - BasicStroke 端点的装饰
join - 应用在路径线段交汇处的装饰
miterlimit - 斜接处的剪裁限制
抛出：
IllegalArgumentException - 如果 width 为负
IllegalArgumentException - 如果 cap 既不是 CAP_BUTT，也不是 CAP_ROUND 或 CAP_SQUARE
IllegalArgumentException - 如果 miterlimit 小于 1 并且 join 为 JOIN_MITER
IllegalArgumentException - 如果 join 既不是 JOIN_ROUND，也不是 JOIN_BEVEL 或 JOIN_MITER

BasicStroke

public BasicStroke(float width,
                   int cap,
                   int join)
构造一个具有指定属性的实心的 BasicStroke。在允许使用默认值或线连接点未指定为 JOIN_MITER 的情况下，不需要 miterlimit 参数。

参数：
width - BasicStroke 的宽度
cap - BasicStroke 端点的装饰
join - 应用在路径线段交汇处的装饰
抛出：
IllegalArgumentException - 如果 width 为负
IllegalArgumentException - 如果 cap 既不是 CAP_BUTT，也不是 CAP_ROUND 或 CAP_SQUARE
IllegalArgumentException - 如果 join 既不是 JOIN_ROUND，也不是 JOIN_BEVEL 或 JOIN_MITER

BasicStroke

public BasicStroke(float width)
构造一个具有指定线条宽度以及 cap 和 join 风格的默认值的实心 BasicStroke。

参数：
width - BasicStroke 的宽度
抛出：
IllegalArgumentException - 如果 width 为负

BasicStroke

public BasicStroke()
构造一个具有所有属性的默认值的新 BasicStroke。默认属性是宽度为 1.0 的实线、CAP_SQUARE、JOIN_MITER 和 10.0 的斜接限制。

方法详细信息

createStrokedShape

public Shape createStrokedShape(Shape s)
返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。

指定者：
接口 Stroke 中的 createStrokedShape
参数：
s - 要勾画的 Shape 边界
返回：
勾画了轮廓的 Shape。

getLineWidth

public float getLineWidth()
返回线条的宽度。线条的宽度是在用户空间中表示的，此空间是 Java 2D 使用的默认坐标空间。关于用户空间坐标系的更多信息，请参阅 Graphics2D 类的注释。

返回：
此 BasicStroke 的线条宽度。
另请参见：
Graphics2D

getEndCap

public int getEndCap()
返回端点的 cap 样式。

返回：
此 BasicStroke 端点的 cap 样式，它是定义可能的端点 cap 样式的静态 int 值之一。

getLineJoin

public int getLineJoin()
返回线条连接样式。

返回：
BasicStroke 的线条连接样式，它是定义可能的线条连接样式的静态 int 值之一。

getMiterLimit

public float getMiterLimit()
返回斜接的限制。

返回：
BasicStroke 的斜接限制。

getDashArray

public float[] getDashArray()
返回表示虚线线段长度的数组。数组中其他条目表示了不透明和透明虚线线段的用户空间长度。当勾画将被绘制的 Shape 的轮廓时，勾画的用户空间距离将被累积。距离值被用来在虚线数组中建立索引。当画笔的当前累积距离映射到虚线数组的某一个元素时，画笔是不透明的，否则是透明的。

返回：
虚线数组。

getDashPhase

public float getDashPhase()
返回当前虚线相位。虚线相位是在用户坐标中指定的一个距离，它表示虚线模式中的偏移量。换句话说，虚线相位定义了虚线模式中的点，该点将相应于笔划的起始点。

返回：
返回 float 值形式的虚线相位。

hashCode

public int hashCode()
返回此笔划的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此笔划的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
测试指定对象与此 BasicStroke 是否相等，首先测试指定对象是否是一个 BasicStroke，然后将其宽度、连接、cap、斜接限制、虚线和虚线相位属性与 BasicStroke 的那些属性进行比较。

覆盖：
类 Object 中的 equals
参数：
obj - 与此 BasicStroke 进行比较的指定对象
返回：
如果两个对象的宽度、连接、cap、斜接限制、虚线和虚线相位相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 BorderLayout

java.lang.Object
    继承者  java.awt.BorderLayout
所有已实现的接口：
LayoutManager, LayoutManager2, Serializable
public class BorderLayout
extends Object
implements LayoutManager2, Serializable

这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。每个区域最多只能包含一个组件，并通过相应的常量进行标识：NORTH、SOUTH、EAST、WEST、CENTER。当使用边框布局将一个组件添加到容器中时，要使用这五个常量之一，例如：

    Panel p = new Panel();
    p.setLayout(new BorderLayout());
    p.add(new Button("Okay"), BorderLayout.SOUTH);
为了方便起见，BorderLayout 将缺少字符串说明的情况解释为常量 CENTER：
    Panel p2 = new Panel();
    p2.setLayout(new BorderLayout());
    p2.add(new TextArea());  // Same as p.add(new TextArea(), BorderLayout.CENTER);

此外，BorderLayout 支持相对定位常量 PAGE_START、PAGE_END、LINE_START 和 LINE_END。在 ComponentOrientation 设置为 ComponentOrientation.LEFT_TO_RIGHT 的容器中，这些常量分别映射到 NORTH、SOUTH、WEST 和 EAST。

为了与以前的版本兼容，BorderLayout 还包括相对定位常量 BEFORE_FIRST_LINE、AFTER_LAST_LINE、BEFORE_LINE_BEGINS 和 AFTER_LINE_ENDS。这些常量分别等同于 PAGE_START、PAGE_END、LINE_START 和 LINE_END。为了与其他组件使用的相对定位常量一致，应优先使用后一组常量。

将绝对定位常量与相对定位常量混合会产生无法预料的结果。如果两种类型的常量都使用，则优先采用相对常量。例如，如果同时使用 NORTH 和 PAGE_START 常量在方向性为 LEFT_TO_RIGHT 的容器中添加组件，则只体现 PAGE_START 布局。

注：目前，在 Java 2 Platform v1.2 中，BorderLayout 不支持垂直方向。不考虑容器的 ComponentOrientation 上 isVertical 设置。

根据其首选大小和容器大小的约束 (constraints) 对组件进行布局。NORTH 和 SOUTH 组件可以在水平方向上拉伸；而 EAST 和 WEST 组件可以在垂直方向上拉伸；CENTER 组件可同时在水平和垂直方向上拉伸，从而填充所有剩余空间。

以下是一个使用 BorderLayout 布局管理器的例子，它对一个 applet 中的五个按钮进行布局：

描述 BorderLayout 的 applet 的图表。 BorderLayout 的每个部分都包含一个对应于它在布局中位置的 Button，它为以下五个常量之一： North、West、Center、East 或 South。

此 applet 的代码如下：

 import java.awt.*;
 import java.applet.Applet;

 public class buttonDir extends Applet {
   public void init() {
     setLayout(new BorderLayout());
     add(new Button("North"), BorderLayout.NORTH);
     add(new Button("South"), BorderLayout.SOUTH);
     add(new Button("East"), BorderLayout.EAST);
     add(new Button("West"), BorderLayout.WEST);
     add(new Button("Center"), BorderLayout.CENTER);
   }
 }

从以下版本开始：
JDK1.0
另请参见：
Container.add(String, Component), ComponentOrientation, 序列化表格

字段摘要
static String | AFTER_LAST_LINE 与 PAGE_END 同义。
static String | AFTER_LINE_ENDS 与 LINE_END 同义。
static String | BEFORE_FIRST_LINE 与 PAGE_START 同义。
static String | BEFORE_LINE_BEGINS 与 LINE_START 同义。
static String | CENTER 中间区域的布局约束（容器中央）。
static String | EAST 东区域的布局约束（容器右边）。
static String | LINE_END 组件出现在布局的行方向的结尾处。
static String | LINE_START 组件出现在布局的行方向的开始处。
static String | NORTH 北区域的布局约束（容器顶部）。
static String | PAGE_END 组件出现在最后一行布局内容之后。
static String | PAGE_START 组件出现在第一行布局内容之前。
static String | SOUTH 南区域的布局约束（容器底部）。
static String | WEST 西区域的布局约束（容器左边）。
构造方法摘要
BorderLayout()
构造一个组件之间没有间距的新边框布局。
BorderLayout(int hgap, int vgap)
构造一个具有指定组件间距的边框布局。
方法摘要
 void addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。
 void addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 Object getConstraints(Component comp)
获取指定组件的约束
 int getHgap()
返回组件之间的水平间距。
 float getLayoutAlignmentX(Container parent)
返回沿 x 轴的对齐方式。
 float getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。
 Component getLayoutComponent(Container target, Object constraints)
基于目标 Container 的组件方向，返回给定约束位置对应的组件。
 Component getLayoutComponent(Object constraints)
获取使用给定约束添加的组件。
 int getVgap()
返回组件之间的垂直间距。
 void invalidateLayout(Container target)
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
 void layoutContainer(Container target)
使用此边框布局对容器参数进行布局。
 Dimension maximumLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。
 Dimension minimumLayoutSize(Container target)
使用此布局管理器确定 target 容器的最小大小。
 Dimension preferredLayoutSize(Container target)
基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。
 void removeLayoutComponent(Component comp)
从此边框布局中移除指定组件。
 void setHgap(int hgap)
设置组件之间的水平间距。
 void setVgap(int vgap)
设置组件之间的垂直间距。
 String toString()
返回此边框布局的状态的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

NORTH

public static final String NORTH
北区域的布局约束（容器顶部）。

另请参见：
常量字段值

SOUTH

public static final String SOUTH
南区域的布局约束（容器底部）。

另请参见：
常量字段值

EAST

public static final String EAST
东区域的布局约束（容器右边）。

另请参见：
常量字段值

WEST

public static final String WEST
西区域的布局约束（容器左边）。

另请参见：
常量字段值

CENTER

public static final String CENTER
中间区域的布局约束（容器中央）。

另请参见：
常量字段值

BEFORE_FIRST_LINE

public static final String BEFORE_FIRST_LINE
与 PAGE_START 同义。为了与以前版本兼容而存在。首选 PAGE_START。

从以下版本开始：
1.2
另请参见：
PAGE_START, 常量字段值

AFTER_LAST_LINE

public static final String AFTER_LAST_LINE
与 PAGE_END 同义。为了与以前版本兼容而存在。首选 PAGE_END。

从以下版本开始：
1.2
另请参见：
PAGE_END, 常量字段值

BEFORE_LINE_BEGINS

public static final String BEFORE_LINE_BEGINS
与 LINE_START 同义。为了与以前版本兼容而存在。首选 LINE_START。

从以下版本开始：
1.2
另请参见：
LINE_START, 常量字段值

AFTER_LINE_ENDS

public static final String AFTER_LINE_ENDS
与 LINE_END 同义。为了与以前版本兼容而存在。首选 LINE_END。

从以下版本开始：
1.2
另请参见：
LINE_END, 常量字段值

PAGE_START

public static final String PAGE_START
组件出现在第一行布局内容之前。对于 Western，方向是从左到右、从上到下，等同于 NORTH。

从以下版本开始：
1.4
另请参见：
Component.getComponentOrientation(), 常量字段值

PAGE_END

public static final String PAGE_END
组件出现在最后一行布局内容之后。对于 Western，方向是从左到右、从上到下，等同于 SOUTH。

从以下版本开始：
1.4
另请参见：
Component.getComponentOrientation(), 常量字段值

LINE_START

public static final String LINE_START
组件出现在布局的行方向的开始处。对于 Western，方向是从左到右、从上到下，等同于 WEST。

从以下版本开始：
1.4
另请参见：
Component.getComponentOrientation(), 常量字段值

LINE_END

public static final String LINE_END
组件出现在布局的行方向的结尾处。对于 Western，方向是从左到右、从上到下，等同于 EAST。

从以下版本开始：
1.4
另请参见：
Component.getComponentOrientation(), 常量字段值
构造方法详细信息

BorderLayout

public BorderLayout()
构造一个组件之间没有间距的新边框布局。

BorderLayout

public BorderLayout(int hgap,
                    int vgap)
构造一个具有指定组件间距的边框布局。水平间距由 hgap 指定，垂直间距由 vgap 指定。

参数：
hgap - 水平间距。
vgap - 垂直间距。
方法详细信息

getHgap

public int getHgap()
返回组件之间的水平间距。

从以下版本开始：
JDK1.1

setHgap

public void setHgap(int hgap)
设置组件之间的水平间距。

参数：
hgap - 组件之间的水平间距
从以下版本开始：
JDK1.1

getVgap

public int getVgap()
返回组件之间的垂直间距。

从以下版本开始：
JDK1.1

setVgap

public void setVgap(int vgap)
设置组件之间的垂直间距。

参数：
vgap - 组件之间的垂直间距
从以下版本开始：
JDK1.1

addLayoutComponent

public void addLayoutComponent(Component comp,
                               Object constraints)
使用指定的约束对象将指定组件添加到布局中。对于边框布局，约束必须是以下约束之一：NORTH、SOUTH、EAST、WEST 或 CENTER。

大多数应用程序并不直接调用此方法。当使用 Container.add 方法将组件添加到容器中时，可以使用相同的参数类型调用此方法。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
comp - 要添加的组件。
constraints - 指定将组件添加到布局中的方式和位置的对象。
抛出：
IllegalArgumentException - 如果约束对象不是一个字符串，或者它不是五种指定约束之一。
从以下版本开始：
JDK1.1
另请参见：
Container.add(java.awt.Component, java.lang.Object)

addLayoutComponent

@Deprecated
public void addLayoutComponent(String name,
                                          Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。

从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从此边框布局中移除指定组件。当容器调用其 remove 或 removeAll 方法时，可调用此方法。大多数应用程序并不直接调用此方法。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件。
另请参见：
Container.remove(java.awt.Component), Container.removeAll()

getLayoutComponent

public Component getLayoutComponent(Object constraints)
获取使用给定约束添加的组件。

参数：
constraints - 所需的约束，它是 CENTER、NORTH、SOUTH、WEST、EAST、PAGE_START、PAGE_END、LINE_START、LINE_END 之一
返回：
给定位置上的组件；如果此位置为空，则返回 null
抛出：
IllegalArgumentException - 如果约束对象不是九个指定约束之一
从以下版本开始：
1.5
另请参见：
addLayoutComponent(java.awt.Component, java.lang.Object)

getLayoutComponent

public Component getLayoutComponent(Container target,
                                    Object constraints)
基于目标 Container 的组件方向，返回给定约束位置对应的组件。利用相对约束 PAGE_START、PAGE_END、LINE_START 和 LINE_END 添加的组件优先于利用显式约束 NORTH、SOUTH、WEST 和 EAST 添加的组件。Container 的组件方向用于确定利用 LINE_START 和 LINE_END 添加的组件的位置。

参数：
constraints - 所需的绝对位置，CENTER、NORTH、SOUTH、EAST 和 WEST 之一
target - Container，用来获取基于目标 Container 组件方向的约束位置。
返回：
指定位置上的组件；如果此位置为空，则返回 null
抛出：
IllegalArgumentException - 如果约束对象不是五个指定约束之一
NullPointerException - 如果目标参数为 null
从以下版本开始：
1.5
另请参见：
addLayoutComponent(java.awt.Component, java.lang.Object)

getConstraints

public Object getConstraints(Component comp)
获取指定组件的约束

参数：
comp - 要查询的组件
返回：
指定组件的约束；如果组件为 null 或不在此布局中，则返回 null
从以下版本开始：
1.5
另请参见：
addLayoutComponent(java.awt.Component, java.lang.Object)

minimumLayoutSize

public Dimension minimumLayoutSize(Container target)
使用此布局管理器确定 target 容器的最小大小。

当容器调用其 getMinimumSize 方法时，可以调用此方法。大多数应用程序并不直接调用此方法。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
target - 在其中进行布局的容器。
返回：
对指定容器的子组件进行布局所需的最小尺寸。
另请参见：
Container, preferredLayoutSize(java.awt.Container), Container.getMinimumSize()

preferredLayoutSize

public Dimension preferredLayoutSize(Container target)
基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。

大多数应用程序并不直接调用此方法。容器调用其 getPreferredSize 方法时将调用此方法。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
target - 在其中进行布局的容器。
返回：
对指定容器的子组件进行布局所需的首选尺寸。
另请参见：
Container, minimumLayoutSize(java.awt.Container), Container.getPreferredSize()

maximumLayoutSize

public Dimension maximumLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
参数：
target - 需要对其进行布局的组件
另请参见：
Container, minimumLayoutSize(java.awt.Container), preferredLayoutSize(java.awt.Container)

getLayoutAlignmentX

public float getLayoutAlignmentX(Container parent)
返回沿 x 轴的对齐方式。这指出了相对于其他组件将如何排列该组件。该值应该在 0 到 1 之间，其中 0 表示根据原点进行对齐，1 表示根据距原点最远的点对齐，0.5 表示居中对齐等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX

getLayoutAlignmentY

public float getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。这指出了相对于其他组件将如何排列该组件。该值应该在 0 到 1 之间，其中 0 表示根据原点进行对齐，1 表示根据距原点最远的点对齐，0.5 表示居中对齐等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY

invalidateLayout

public void invalidateLayout(Container target)
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。

指定者：
接口 LayoutManager2 中的 invalidateLayout

layoutContainer

public void layoutContainer(Container target)
使用此边框布局对容器参数进行布局。

为了满足此 BorderLayout 对象的约束条件，此方法实际上会重塑指定容器中的组件。NORTH 和 SOUTH 组件（如果有）分别放置在容器的顶部和底部。WEST 和 EAST 组件分别放置在容器的左边和右边。最后，CENTER 对象放置在中间的任何剩余空间内。

大多数应用程序并不直接调用此方法。容器调用其 doLayout 方法时将调用此方法。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
target - 在其中进行布局的容器。
另请参见：
Container, Container.doLayout()

toString

public String toString()
返回此边框布局的状态的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此边框布局的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferCapabilities (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 BufferCapabilities

java.lang.Object
    继承者  java.awt.BufferCapabilities
所有已实现的接口：
Cloneable
public class BufferCapabilities
extends Object
implements Cloneable

缓冲区的能力和属性。

从以下版本开始：
1.4
另请参见：
BufferStrategy.getCapabilities(), GraphicsConfiguration.getBufferCapabilities()

嵌套类摘要
static class BufferCapabilities.FlipContents
页面翻转后可能的后台缓冲区内容的一个类型安全的枚举
构造方法摘要
BufferCapabilities(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
创建一个指定缓冲区能力的新对象
方法摘要
Object | clone() 创建并返回此对象的一个副本。
ImageCapabilities | getBackBufferCapabilities()
BufferCapabilities.FlipContents | getFlipContents()
ImageCapabilities | getFrontBufferCapabilities()
boolean | isFullScreenRequired()
boolean | isMultiBufferAvailable()
boolean | isPageFlipping()
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BufferCapabilities

public BufferCapabilities(ImageCapabilities frontCaps,
                          ImageCapabilities backCaps,
                          BufferCapabilities.FlipContents flipContents)
创建一个指定缓冲区能力的新对象

参数：
frontCaps - 前台缓冲区的能力，不能为 null
backCaps - 后台缓冲区和中间缓冲区的能力，不能为 null
flipContents - 页面翻转后后台缓冲区的内容，如果未使用页面翻转（意味着使用了位图传输 (blitting)），则为 null
抛出：
IllegalArgumentException - 如果 frontCaps 或 backCaps 为 null
方法详细信息

getFrontBufferCapabilities

public ImageCapabilities getFrontBufferCapabilities()
返回：
前台（显示）缓冲区的图像能力

getBackBufferCapabilities

public ImageCapabilities getBackBufferCapabilities()
返回：
所有后台缓冲区（中间缓冲区可看作后台缓冲区）的图像能力

isPageFlipping

public boolean isPageFlipping()
返回：
缓冲区策略是否使用了页面翻转；通过切换视频指针（或者通过内部内存复制），一个使用页面翻转的缓冲区集合可以在前台缓冲区与一个或多个后台缓冲区之间进行内容的内部交换。一个非翻转的缓冲区集合使用位图传输将一个缓冲区的内容复制到另一个缓冲区；如果是这种情况，则 getFlipContents 返回 null

getFlipContents

public BufferCapabilities.FlipContents getFlipContents()
返回：
页面翻转后得到的后台缓冲区的内容。当 isPageFlipping 返回 false 时，此值为 null，意味着使用位图传输。它可以是 FlipContents.UNDEFINED（假定的默认值）、FlipContents.BACKGROUND、FlipContents.PRIOR 或 FlipContents.COPIED 中的一个。
另请参见：
isPageFlipping(), BufferCapabilities.FlipContents.UNDEFINED, BufferCapabilities.FlipContents.BACKGROUND, BufferCapabilities.FlipContents.PRIOR, BufferCapabilities.FlipContents.COPIED

isFullScreenRequired

public boolean isFullScreenRequired()
返回：
是否页面翻转只在全屏模式下可用。如果它为 true，则页面翻转需要全屏独占模式。
另请参见：
isPageFlipping(), GraphicsDevice.setFullScreenWindow(java.awt.Window)

isMultiBufferAvailable

public boolean isMultiBufferAvailable()
返回：
是否使用多于两个缓冲区（一个或更多中间缓冲区、前台缓冲区或后台缓冲区）执行页面翻转操作。
另请参见：
isPageFlipping()

clone

public Object clone()
从类 Object 复制的描述
创建并返回此对象的一个副本。“副本”的准确含义可能依赖于对象的类。这样做的目的是，对于任何对象 x，表达式：
x.clone() != x
为 true，表达式：
x.clone().getClass() == x.getClass()
也为 true，但这些并非必须要满足的要求。一般情况下：
x.clone().equals(x)
为 true，但这并非必须要满足的要求。

按照惯例，返回的对象应该通过调用 super.clone 获得。如果一个类及其所有的超类（Object 除外）都遵守此约定，则 x.clone().getClass() == x.getClass()。

按照惯例，此方法返回的对象应该独立于该对象（正被复制的对象）。要获得此独立性，在 super.clone 返回对象之前，有必要对该对象的一个或多个字段进行修改。这通常意味着要复制包含正在被复制对象的内部“深层结构”的所有可变对象，并使用对副本的引用替换对这些对象的引用。如果一个类只包含基本字段或对不变对象的引用，那么通常不需要修改 super.clone 返回的对象中的字段。

Object 类的 clone 方法执行特定的复制操作。首先，如果此对象的类不能实现接口 Cloneable，则会抛出 CloneNotSupportedException。注意，所有的数组都被视为实现接口 Cloneable。否则，此方法会创建此对象的类的一个新实例，并像通过分配那样，严格使用此对象相应字段的内容初始化该对象的所有字段；这些字段的内容没有被自我复制。所以，此方法执行的是该对象的“浅表复制”，而不“深层复制”操作。

Object 类本身不实现接口 Cloneable，所以在类为 Object 的对象上调用 clone 方法将会导致在运行时抛出异常。

覆盖：
类 Object 中的 clone
返回：
此 BufferCapabilities 对象的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferCapabilities.FlipContents (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 BufferCapabilities.FlipContents

java.lang.Object
    继承者  java.awt.BufferCapabilities.FlipContents
正在封闭类：
BufferCapabilities
public static final class BufferCapabilities.FlipContents
extends Object

页面翻转后可能的后台缓冲区内容的一个类型安全的枚举

从以下版本开始：
1.4

字段摘要
static BufferCapabilities.FlipContents | BACKGROUND 当翻转内容为 BACKGROUND 时，后台缓冲区的内容在翻转后使用背景颜色清除。
static BufferCapabilities.FlipContents | COPIED 当翻转内容为 COPIED 时，翻转时将后台缓冲区的内容复制到前台缓冲区。
static BufferCapabilities.FlipContents | PRIOR 当翻转内容为 PRIOR 时，后台缓冲区的内容为前台缓冲区的先前内容（真实的页面翻转）。
static BufferCapabilities.FlipContents | UNDEFINED 当翻转内容为 UNDEFINED 时，后台缓冲区的内容在翻转后是不明确的。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

UNDEFINED

public static final BufferCapabilities.FlipContents UNDEFINED
当翻转内容为 UNDEFINED 时，后台缓冲区的内容在翻转后是不明确的。

另请参见：
BufferCapabilities.isPageFlipping(), BufferCapabilities.getFlipContents(), BACKGROUND, PRIOR, COPIED

BACKGROUND

public static final BufferCapabilities.FlipContents BACKGROUND
当翻转内容为 BACKGROUND 时，后台缓冲区的内容在翻转后使用背景颜色清除。

另请参见：
BufferCapabilities.isPageFlipping(), BufferCapabilities.getFlipContents(), UNDEFINED, PRIOR, COPIED

PRIOR

public static final BufferCapabilities.FlipContents PRIOR
当翻转内容为 PRIOR 时，后台缓冲区的内容为前台缓冲区的先前内容（真实的页面翻转）。

另请参见：
BufferCapabilities.isPageFlipping(), BufferCapabilities.getFlipContents(), UNDEFINED, BACKGROUND, COPIED

COPIED

public static final BufferCapabilities.FlipContents COPIED
当翻转内容为 COPIED 时，翻转时将后台缓冲区的内容复制到前台缓冲区。

另请参见：
BufferCapabilities.isPageFlipping(), BufferCapabilities.getFlipContents(), UNDEFINED, BACKGROUND, PRIOR
方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Button (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Button

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Button
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class Button
extends Component
implements Accessible

此类创建一个标签按钮。当按下该按钮时，应用程序能执行某项动作。以下图像描绘了在 Solaris 操作系统下，"Quit" 按钮所表现的三种视图：

第一幅视图展示该按钮在一般情况下的外观。第二幅视图展示该按钮成为输入焦点时的外观。其边框变黑，让用户知道它是一个活动对象。第三幅视图展示用户在该按钮上单击鼠标，从而请求执行某个动作时该按钮的外观。

用鼠标单击按钮这一动作与 ActionEvent 的一个实例相关，在按下鼠标和释放按钮的时候都会用到该类。如果应用程序希望知道何时按钮作为一个单独动作被按下但未释放，它可以特殊化 processMouseEvent，或者通过调用 addMouseListener 将自身注册为鼠标事件的侦听器。这两种方法都是由所有组件的抽象超类 Component 定义的。

当按下按钮并释放时，AWT 通过调用按钮的 processEvent，将 ActionEvent 的一个实例发送给按钮。按钮的 processEvent 方法接收按钮的所有事件；同时，它通过调用自身的 processActionEvent 方法传递一个动作事件。后一种方法将动作事件传递给为关注此按钮生成的动作事件而注册的任何动作侦听器。

如果应用程序想要执行基于按下并释放按钮的某个动作，则它应该实现 ActionListener 并注册新的侦听器，以便通过调用按钮的 addActionListener 方法来接收发自此按钮的事件。应用程序可以按消息传递协议使用按钮的动作命令。

从以下版本开始：
JDK1.0
另请参见：
ActionEvent, ActionListener, Component.processMouseEvent(java.awt.event.MouseEvent), Component.addMouseListener(java.awt.event.MouseListener), 序列化表格

嵌套类摘要
protected  class Button.AccessibleAWTButton
此类实现对 Button 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Button()
构造一个标签字符串为空的按钮。
Button(String label)
构造一个带指定标签的按钮。
方法摘要
 void addActionListener(ActionListener l)
添加指定的动作侦听器，以接收发自此按钮的动作事件。
 void addNotify()
创建按钮的同位体。
 AccessibleContext getAccessibleContext()
获取与此 Button 相关的 AccessibleContext。
 String getActionCommand()
返回此按钮激发的动作事件的命令名称。
 ActionListener[] getActionListeners()
返回在此按钮上注册的所有动作侦听器的一个数组。
 String getLabel()
获取此按钮的标签。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
protected  String paramString()
返回此 Button 状态的字符串表示形式。
protected  void processActionEvent(ActionEvent e)
处理发生在此按钮上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
protected  void processEvent(AWTEvent e)
处理此按钮上的事件。
 void removeActionListener(ActionListener l)
移除指定的动作侦听器，以便它不再接收发自此按钮的动作事件。
 void setActionCommand(String command)
设置此按钮激发的动作事件的命令名称。
 void setLabel(String label)
将按钮的标签设置为指定的字符串。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Button

public Button()
       throws HeadlessException
构造一个标签字符串为空的按钮。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

Button

public Button(String label)
       throws HeadlessException
构造一个带指定标签的按钮。

参数：
label - 按钮的字符串标签，如果没有标签，则为 null
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建按钮的同位体。按钮的同位体允许应用程序更改按钮的外观。而不更改其功能。

覆盖：
类 Component 中的 addNotify
另请参见：
Toolkit.createButton(java.awt.Button), Component.getToolkit()

getLabel

public String getLabel()
获取此按钮的标签。

返回：
按钮的标签，如果按钮没有标签，则返回 null。
另请参见：
setLabel(java.lang.String)

setLabel

public void setLabel(String label)
将按钮的标签设置为指定的字符串。

参数：
label - 新的标签，如果按钮没有标签，则为 null。
另请参见：
getLabel()

setActionCommand

public void setActionCommand(String command)
设置此按钮激发的动作事件的命令名称。在默认情况下，此动作命令设置为与按钮标签相匹配。

参数：
command - 用于设置按钮动作命令的字符串。如果字符串为 null，则动作命令设置为与按钮标签相匹配。
从以下版本开始：
JDK1.1
另请参见：
ActionEvent

getActionCommand

public String getActionCommand()
返回此按钮激发的动作事件的命令名称。如果命令名称为 null（默认），则此方法返回按钮的标签。

addActionListener

public void addActionListener(ActionListener l)
添加指定的动作侦听器，以接收发自此按钮的动作事件。当用户在此按钮上按下或释放鼠标时，发生动作事件。如果 l 为 null，则不抛出任何异常，也不执行任何动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 动作侦听器
从以下版本开始：
JDK1.1
另请参见：
removeActionListener(java.awt.event.ActionListener), getActionListeners(), ActionListener

removeActionListener

public void removeActionListener(ActionListener l)
移除指定的动作侦听器，以便它不再接收发自此按钮的动作事件。当用户在此按钮上按下或释放鼠标时，发生动作事件。如果 l 为 null，则不抛出任何异常，也不执行任何动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 动作侦听器
从以下版本开始：
JDK1.1
另请参见：
addActionListener(java.awt.event.ActionListener), getActionListeners(), ActionListener

getActionListeners

public ActionListener[] getActionListeners()
返回在此按钮上注册的所有动作侦听器的一个数组。

返回：
此按钮的所有 ActionListener；如果当前没有注册任何动作侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener), ActionListener

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值（如 FooListener.class）来指定 listenerType 参数。例如，可以使用以下代码来查询 Button b 的动作侦听器：

ActionListener[] als = (ActionListener[])(b.getListeners(ActionListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 Component 中的 getListeners
参数：
listenerType - 请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此按钮上作为 FooListener 注册的所有对象的数组；如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getActionListeners()

processEvent

protected void processEvent(AWTEvent e)
处理此按钮上的事件。如果事件是 ActionEvent 的一个实例，则此方法将调用 processActionEvent 方法。否则，它调用超类的 processEvent 方法。

注意，如果事件参数为 null，则行为未指定，并可能导致一个异常。

覆盖：
类 Component 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
ActionEvent, processActionEvent(java.awt.event.ActionEvent)

processActionEvent

protected void processActionEvent(ActionEvent e)
处理发生在此按钮上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。

只有启用了此按钮的动作事件，此方法才有可能被调用。当发生以下事件之一时会激活动作事件：

  • 通过 addActionListener 注册了 ActionListener 对象。
  • 通过 enableEvents 激活了动作事件。

注意，如果事件参数为 null，则行为未指定，并可能导致一个异常。

参数：
e - 动作事件
从以下版本开始：
JDK1.1
另请参见：
ActionListener, addActionListener(java.awt.event.ActionListener), Component.enableEvents(long)

paramString

protected String paramString()
返回此 Button 状态的字符串表示形式。此方法仅在进行调试的时候使用，对于这两个实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Component 中的 paramString
返回：
此按钮的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Button 相关的 AccessibleContext。对于按钮，AccessibleContext 采用 AccessibleAWTButton 的形式。如果有必要，创建一个新的 AccessibleAWTButton 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
一个 AccessibleAWTButton，它将充当此 Button 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Button.AccessibleAWTButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Button.AccessibleAWTButton

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Button.AccessibleAWTButton
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleValue
正在封闭类：
Button
protected class Button.AccessibleAWTButton
extends Component.AccessibleAWTComponent
implements AccessibleAction, AccessibleValue

此类实现对 Button 类的可访问性支持。它提供适合于按钮用户界面元素的 Java Accessibility API 的一个实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
protected Button.AccessibleAWTButton()
方法摘要
boolean | doAccessibleAction(int i) 在对象上执行指定的操作
AccessibleAction | getAccessibleAction() 获取与此对象相关的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用的 Action 的数目。
String | getAccessibleActionDescription(int i) 返回对象指定操作的描述。
String | getAccessibleName() 获取此对象的可访问名称。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleValue | getAccessibleValue() 获取与此对象相关的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Button.AccessibleAWTButton

protected Button.AccessibleAWTButton()
方法详细信息

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleName
返回：
对象的固定名称，如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象相关的 AccessibleAction。在此类的 Java Accessibility API 的实现中，返回此对象，它本身负责实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象相关的 AccessibleValue。在此类的 Java Accessibility API 的实现中，返回此对象，它本身负责实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用的 Action 的数目。按钮的默认行为是执行一个操作：切换按钮。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中 Action 的数目，即 1。

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回对象指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 操作的从 0 开始的索引
返回：
动作的 String 描述
另请参见：
AccessibleAction.getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
在对象上执行指定的操作

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从 0 开始的索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的值，它是一个 Number。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
如果没有选定此对象，则返回整数 0；如果选定了此对象，则返回整数 1。
另请参见：
AbstractButton.isSelected()

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置了该值，则返回 True。
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小值，它是一个 Number。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
整数 0。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大值，它是一个 Number。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
整数 0。
另请参见：
AccessibleValue.getMinimumAccessibleValue()

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的一个实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Canvas (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Canvas

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Canvas
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class Canvas
extends Component
implements Accessible

Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。

应用程序必须为 Canvas 类创建子类，以获得有用的功能（如创建自定义组件）。必须重写 paint 方法，以便在 canvas 上执行自定义图形。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

嵌套类摘要
protected  class Canvas.AccessibleAWTCanvas
此类实现对 Canvas 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Canvas()
构造一个新的 Canvas。
Canvas(GraphicsConfiguration config)
根据给定 GraphicsConfiguration 对象构造一个新的 Canvas。
方法摘要
void | addNotify() 创建 canvas 的同位体。
void | createBufferStrategy(int numBuffers) 创建一个新的策略，用于对此组件的多次缓冲。
void | createBufferStrategy(int numBuffers, BufferCapabilities caps) 创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。
AccessibleContext | getAccessibleContext() 获取与此 Canvas 相关的 AccessibleContext。
BufferStrategy | getBufferStrategy() 返回由此组件使用的 BufferStrategy。
void | paint(Graphics g) 绘制此 canvas。
void | update(Graphics g) 更新此 canvas。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, paramString, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Canvas

public Canvas()
构造一个新的 Canvas。

Canvas

public Canvas(GraphicsConfiguration config)
根据给定 GraphicsConfiguration 对象构造一个新的 Canvas。

参数：
config - 对 GraphicsConfiguration 对象的引用。
另请参见：
GraphicsConfiguration
方法详细信息

addNotify

public void addNotify()
创建 canvas 的同位体。此同位体允许您更改 canvas 的用户界面，而不更改其功能。

覆盖：
类 Component 中的 addNotify
另请参见：
Toolkit.createCanvas(java.awt.Canvas), Component.getToolkit()

paint

public void paint(Graphics g)
绘制此 canvas。

为 Canvas 创建子类的大多数应用程序应该重写此方法，以便执行某个有用的操作（通常是 canvas 的自定义绘制操作）。默认操作是清理 canvas。重写此方法的应用程序不需要调用 super.paint(g)。

覆盖：
类 Component 中的 paint
参数：
g - 指定的 Graphics 上下文
另请参见：
update(Graphics), Component.paint(Graphics)

update

public void update(Graphics g)
更新此 canvas。

调用此方法响应对 repaint 的调用。首先通过使用背景色填充 canvas 来清理它，然后通过调用此 canvas 的 paint 方法重绘它。注：重写此方法的应用程序应该调用 super.update(g)，或者将上述功能合并到其自身的代码中。

覆盖：
类 Component 中的 update
参数：
g - 指定的 Graphics 上下文
另请参见：
paint(Graphics), Component.update(Graphics)

createBufferStrategy

public void createBufferStrategy(int numBuffers)
创建一个新的策略，用于对此组件的多次缓冲。多次缓冲对于提高呈现性能很有用。此方法试图使用提供的缓冲区数创建最佳可用策略。它始终创建一个使用该数量缓冲区的 BufferStrategy。首先尝试页面翻转策略，然后尝试使用加速缓冲区的位图传输策略。最后，使用非加速的位图传输策略。

每次调用此方法时，都会丢弃此组件现有的缓冲区策略。

参数：
numBuffers - 要创建的缓冲区数，包括前台缓冲区
抛出：
IllegalArgumentException - 如果 numBuffers 小于 1。
IllegalStateException - 如果组件不是可显示的
从以下版本开始：
1.4
另请参见：
Component.isDisplayable(), getBufferStrategy()

createBufferStrategy

public void createBufferStrategy(int numBuffers,
                                 BufferCapabilities caps)
                          throws AWTException
创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。例如，如果只需加速内存或页面翻转（由缓冲区能力指定），则这种策略很有用。

每次调用此方法时，都会丢弃此组件现有的缓冲区策略。

参数：
numBuffers - 要创建的缓冲区数量
caps - 创建缓冲区策略所要求的能力；不能为 null
抛出：
AWTException - 如果提供的能力不受支持或不能满足要求；例如，如果当前可用的加速内存不够，或者不能进行指定的页面翻转时，可能出现这种情况。
IllegalArgumentException - 如果 numBuffers 小于 1，或者 caps 为 null
从以下版本开始：
1.4
另请参见：
getBufferStrategy()

getBufferStrategy

public BufferStrategy getBufferStrategy()
返回由此组件使用的 BufferStrategy。如果尚未创建 BufferStrategy 或者已经用完了内存，则此方法返回 null。

返回：
此组件使用的缓冲区策略
从以下版本开始：
1.4
另请参见：
createBufferStrategy(int)

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Canvas 相关的 AccessibleContext。对于 canvas 来说，AccessibleContext 采用 AccessibleAWTCanvas 的形式。如果必要，创建一个新的 AccessibleAWTCanvas 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
一个 AccessibleAWTCanvas，它充当此 Canvas 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CardLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 CardLayout

java.lang.Object
    继承者  java.awt.CardLayout
所有已实现的接口：
LayoutManager, LayoutManager2, Serializable
public class CardLayout
extends Object
implements LayoutManager2, Serializable

CardLayout 对象是容器的布局管理器。它将容器中的每个组件看作一张卡片。一次只能看到一张卡片，容器则充当卡片的堆栈。当容器第一次显示时，第一个添加到 CardLayout 对象的组件为可见组件。

卡片的顺序由组件对象本身在容器内部的顺序决定。CardLayout 定义了一组方法，这些方法允许应用程序按顺序地浏览这些卡片，或者显示指定的卡片。addLayoutComponent(java.awt.Component, java.lang.Object) 方法可用于将一个字符串标识符与给定卡片关联，以便进行快速随机访问。

从以下版本开始：
JDK1.0
另请参见：
Container, 序列化表格

构造方法摘要
CardLayout()
创建一个间距大小为 0 的新卡片布局。
CardLayout(int hgap, int vgap)
创建一个具有指定水平间距和垂直间距的新卡片布局。
方法摘要
 void addLayoutComponent(Component comp, Object constraints)
将指定的组件添加到此卡片布局的内部名称表。
 void addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 void first(Container parent)
翻转到容器的第一张卡片。
 int getHgap()
获取组件之间的水平间距。
 float getLayoutAlignmentX(Container parent)
返回沿 x 轴的对齐方式。
 float getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。
 int getVgap()
获取组件之间的垂直间距。
 void invalidateLayout(Container target)
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
 void last(Container parent)
翻转到容器的最后一张卡片。
 void layoutContainer(Container parent)
使用此卡片布局布置指定的容器。
 Dimension maximumLayoutSize(Container target)
给出指定目标容器中的组件，返回此布局的最大尺寸。
 Dimension minimumLayoutSize(Container parent)
计算指定面板大小的最小值。
 void next(Container parent)
翻转到指定容器的下一张卡片。
 Dimension preferredLayoutSize(Container parent)
使用此卡片布局确定容器参数的首选大小。
 void previous(Container parent)
翻转到指定容器的前一张卡片。
 void removeLayoutComponent(Component comp)
从布局中移除指定的组件。
 void setHgap(int hgap)
设置组件之间的水平间距。
 void setVgap(int vgap)
设置组件之间的垂直间距。
 void show(Container parent, String name)
翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。
 String toString()
返回此卡片布局状态的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CardLayout

public CardLayout()
创建一个间距大小为 0 的新卡片布局。

CardLayout

public CardLayout(int hgap,
                  int vgap)
创建一个具有指定水平间距和垂直间距的新卡片布局。水平间距置于左右边缘。垂直间距置于上下边缘。

参数：
hgap - 水平间距。
vgap - 垂直间距。
方法详细信息

getHgap

public int getHgap()
获取组件之间的水平间距。

返回：
组件之间的水平间距。
从以下版本开始：
JDK1.1
另请参见：
setHgap(int), getVgap()

setHgap

public void setHgap(int hgap)
设置组件之间的水平间距。

参数：
hgap - 组件之间的水平间距。
从以下版本开始：
JDK1.1
另请参见：
getHgap(), setVgap(int)

getVgap

public int getVgap()
获取组件之间的垂直间距。

返回：
组件之间的垂直间距。
另请参见：
setVgap(int), getHgap()

setVgap

public void setVgap(int vgap)
设置组件之间的垂直间距。

参数：
vgap - 组件之间的垂直间距。
从以下版本开始：
JDK1.1
另请参见：
getVgap(), setHgap(int)

addLayoutComponent

public void addLayoutComponent(Component comp,
                               Object constraints)
将指定的组件添加到此卡片布局的内部名称表。constraints 指定的对象必须是一个字符串。卡片布局将此字符串作为一个键-值对存储起来，该键-值对可用于对特定卡片的随机访问。通过调用 show 方法，应用程序可以显示具有指定名称的组件。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
comp - 要添加的组件。
constraints - 标识布局中特定卡片的标记。
抛出：
IllegalArgumentException - 如果 constraint 不是一个字符串。
另请参见：
show(java.awt.Container, java.lang.String)

addLayoutComponent

@Deprecated
public void addLayoutComponent(String name,
                                          Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。

从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从布局中移除指定的组件。如果顶部的卡片可见，则紧挨其下方的下一张卡片也将显示。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件。
另请参见：
Container.remove(java.awt.Component), Container.removeAll()

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
使用此卡片布局确定容器参数的首选大小。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 要在其中进行布局的父容器
返回：
布置指定容器子组件的首选尺寸
另请参见：
Container.getPreferredSize(), minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
计算指定面板大小的最小值。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 要在其中进行布局的父容器
返回：
布置指定容器子组件所需的最小尺寸
另请参见：
Container.doLayout(), preferredLayoutSize(java.awt.Container)

maximumLayoutSize

public Dimension maximumLayoutSize(Container target)
给出指定目标容器中的组件，返回此布局的最大尺寸。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
参数：
target - 需要布局的组件
另请参见：
Container, minimumLayoutSize(java.awt.Container), preferredLayoutSize(java.awt.Container)

getLayoutAlignmentX

public float getLayoutAlignmentX(Container parent)
返回沿 x 轴的对齐方式。这指定了如何相对于其他组件来对齐该组件。返回值应该在 0 和 1 之间，其中 0 表示根据原点进行对齐，1 表示根据距离原点最远的点对齐，0.5 表示居中对齐等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX

getLayoutAlignmentY

public float getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。这指定了如何相对于其他组件来对齐该组件。返回值应该在 0 和 1 之间，其中 0 表示根据原点进行对齐，1 表示根据距离原点最远的点对齐，0.5 表示居中对齐等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY

invalidateLayout

public void invalidateLayout(Container target)
使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。

指定者：
接口 LayoutManager2 中的 invalidateLayout

layoutContainer

public void layoutContainer(Container parent)
使用此卡片布局布置指定的容器。

parent 容器中每个组件的尺寸要变为容器尺寸减去组件四周 insets 的空间，再减去水平间距和垂直间距。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要在其中进行布局的父容器
另请参见：
Container.doLayout()

first

public void first(Container parent)
翻转到容器的第一张卡片。

参数：
parent - 要在其中进行布局的父容器
另请参见：
last(java.awt.Container)

next

public void next(Container parent)
翻转到指定容器的下一张卡片。如果当前的可见卡片是最后一个，则此方法翻转到布局的第一张卡片。

参数：
parent - 要在其中进行布局的父容器
另请参见：
jjava.awt.CardLayout#previous

previous

public void previous(Container parent)
翻转到指定容器的前一张卡片。如果当前的可见卡片是第一个，则此方法翻转到布局的最后一张卡片。

参数：
parent - 要在其中进行布局的父容器
另请参见：
next(java.awt.Container)

last

public void last(Container parent)
翻转到容器的最后一张卡片。

参数：
parent - 要在其中进行布局的父容器
另请参见：
first(java.awt.Container)

show

public void show(Container parent,
                 String name)
翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。如果不存在这样的组件，则不发生任何操作。

参数：
parent - 要在其中进行布局的父容器
name - 组件名称
另请参见：
addLayoutComponent(java.awt.Component, java.lang.Object)

toString

public String toString()
返回此卡片布局状态的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此卡片布局的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Canvas.AccessibleAWTCanvas (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Canvas.AccessibleAWTCanvas

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Canvas.AccessibleAWTCanvas
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
Canvas
protected class Canvas.AccessibleAWTCanvas
extends Component.AccessibleAWTComponent

此类实现对 Canvas 类的可访问性支持。它提供适合 canvas 用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Canvas.AccessibleAWTCanvas()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Canvas.AccessibleAWTCanvas

protected Canvas.AccessibleAWTCanvas()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的一个实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Checkbox (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Checkbox

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Checkbox
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible
public class Checkbox
extends Component
implements ItemSelectable, Accessible

复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。单击复选框可将其状态从“开”更改为“关”，或从“关”更改为“开”。

下列代码示例在网格布局中创建了一组复选框：

 setLayout(new GridLayout(3, 1));
 add(new Checkbox("one", null, true));
 add(new Checkbox("two"));
 add(new Checkbox("three"));

该图像描述了由这个代码示例创建的复选框和网格布局：

标记为 one 的按钮处于“开”状态，其他两个按钮处于“关”状态。在这个例子中，使用了 GridLayout 类，三个复选框的状态是分别设置的。

作为选择，可使用 CheckboxGroup 类将一些复选框组成一组，作为单个对象来控制。在一个复选框组中，在任何给定时间，最多只能有一个按钮处于“开”状态。单击并打开一个复选框会强迫同组中其他原来处于打开状态的复选框变为“关”状态。

从以下版本开始：
JDK1.0
另请参见：
GridLayout, CheckboxGroup, 序列化表格

嵌套类摘要
protected  class Checkbox.AccessibleAWTCheckbox
此类实现对 Checkbox 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Checkbox()
使用空字符串标签创建一个复选框。
Checkbox(String label)
使用指定标签创建一个复选框。
Checkbox(String label, boolean state)
使用指定标签创建一个复选框，并将它设置为指定状态。
Checkbox(String label, boolean state, CheckboxGroup group)
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。
Checkbox(String label, CheckboxGroup group, boolean state)
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。
方法摘要
 void addItemListener(ItemListener l)
添加指定的项侦听器，以接收来自此复选框的项事件。
 void addNotify()
创建 Checkbox 的同位体。
 AccessibleContext getAccessibleContext()
获取与此 Checkbox 相关的 AccessibleContext。
 CheckboxGroup getCheckboxGroup()
确定此复选框的组。
 ItemListener[] getItemListeners()
返回已在此复选框上注册的所有项侦听器所组成的数组。
 String getLabel()
获取此复选框的标签。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
 Object[] getSelectedObjects()
返回包含复选框标签的数组 (length 1)，如果没有选定复选框，则返回 null。
 boolean getState()
确定此复选框是处于“开”状态，还是处于“关”状态。
protected  String paramString()
返回表示此 Checkbox 的状态的字符串。
protected  void processEvent(AWTEvent e)
处理关于此复选框的事件。
protected  void processItemEvent(ItemEvent e)
处理发生在此复选框上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
 void removeItemListener(ItemListener l)
移除此项侦听器，这样项侦听器将不再接收发自此复选框的项事件。
 void setCheckboxGroup(CheckboxGroup g)
将此复选框的组设置为指定复选框组。
 void setLabel(String label)
将此复选框的标签设置为字符串参数。
 void setState(boolean state)
将此复选框的状态设置为指定状态。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Checkbox

public Checkbox()
         throws HeadlessException
使用空字符串标签创建一个复选框。此复选框的状态被设置为“关”，并且它不属于任何复选框组。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

Checkbox

public Checkbox(String label)
         throws HeadlessException
使用指定标签创建一个复选框。此复选框的状态被设置为“关”，并且它不属于任何复选框组。

参数：
label - 此复选框的字符串标签，如果没有标签，则该参数为 null。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

Checkbox

public Checkbox(String label,
                boolean state)
         throws HeadlessException
使用指定标签创建一个复选框，并将它设置为指定状态。该复选框不属于任何复选框组。

参数：
label - 此复选框的字符串标签，如果没有标签，则该参数为 null
state - 此复选框的初始状态
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

Checkbox

public Checkbox(String label,
                boolean state,
                CheckboxGroup group)
         throws HeadlessException
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。

参数：
label - 此复选框的字符串标签，如果没有标签，则该参数为 null。
state - 此复选框的初始状态。
group - 此复选框的复选框组，如果没有这样的复选框组，则该参数为 null。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()

Checkbox

public Checkbox(String label,
                CheckboxGroup group,
                boolean state)
         throws HeadlessException
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。

参数：
label - 此复选框的字符串标签，如果没有标签，则该参数为 null。
group - 此复选框的复选框组，如果没有这样的复选框组，则该参数为 null。
state - 此复选框的初始状态。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建 Checkbox 的同位体。该同位体允许更改 Checkbox 的外观，而不更改其功能。

覆盖：
类 Component 中的 addNotify
另请参见：
Toolkit.createCheckbox(java.awt.Checkbox), Component.getToolkit()

getLabel

public String getLabel()
获取此复选框的标签。

返回：
此复选框的标签，如果此复选框没有标签，则返回 null。
另请参见：
setLabel(String)

setLabel

public void setLabel(String label)
将此复选框的标签设置为字符串参数。

参数：
label - 设置为新标签的字符串，如果没有标签，则该参数为 null。
另请参见：
getLabel()

getState

public boolean getState()
确定此复选框是处于“开”状态，还是处于“关”状态。boolean 值 true 指示此复选框处于“开”状态，false 指示此复选框处于“关”状态。

返回：
以 boolean 值形式表示的此复选框的状态
另请参见：
setState(boolean)

setState

public void setState(boolean state)
将此复选框的状态设置为指定状态。boolean 值 true 指示此复选框处于“开”状态，false 指示此复选框处于“关”状态。

注意，此方法应主要用于初始化复选框的状态。以编程方式设置复选框的状态，这不 会触发 ItemEvent。触发 ItemEvent 的唯一方式是用户交互。

参数：
state - 以 boolean 值形式表示的复选框的状态
另请参见：
getState()

getSelectedObjects

public Object[] getSelectedObjects()
返回包含复选框标签的数组 (length 1)，如果没有选定复选框，则返回 null。

指定者：
接口 ItemSelectable 中的 getSelectedObjects
另请参见：
ItemSelectable

getCheckboxGroup

public CheckboxGroup getCheckboxGroup()
确定此复选框的组。

返回：
此复选框的组，如果该复选框不属于任何复选框组，则返回 null。
另请参见：
setCheckboxGroup(CheckboxGroup)

setCheckboxGroup

public void setCheckboxGroup(CheckboxGroup g)
将此复选框的组设置为指定复选框组。如果此复选框已经在另一个复选框组中，则首先从这个复选框组中提取该复选框。

如果此复选框的状态为 true 并且新组已经有一个选定的复选框，则将此复选框的状态更改为 false。如果此复选框的状态为 true，并且新组中没有选定的复选框，则此复选框将成为新组的选定复选框，并且其状态为 true。

参数：
g - 新复选框组，如果该参数为 null，则从所有复选框组中移除此复选框
另请参见：
getCheckboxGroup()

addItemListener

public void addItemListener(ItemListener l)
添加指定的项侦听器，以接收来自此复选框的项事件。将项事件发送到侦听器，以响应用户输入，但不响应对 setState() 的调用。如果 l 为 null，则不会抛出异常，并且不执行任何操作。有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 addItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
removeItemListener(java.awt.event.ItemListener), getItemListeners(), setState(boolean), ItemEvent, ItemListener

removeItemListener

public void removeItemListener(ItemListener l)
移除此项侦听器，这样项侦听器将不再接收发自此复选框的项事件。如果 l 为 null，则不会抛出异常，并且不执行任何操作。有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 removeItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
addItemListener(java.awt.event.ItemListener), getItemListeners(), ItemEvent, ItemListener

getItemListeners

public ItemListener[] getItemListeners()
返回已在此复选框上注册的所有项侦听器所组成的数组。

返回：
此复选框的所有 ItemListener，如果没有当前已注册的项侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addItemListener(java.awt.event.ItemListener), removeItemListener(java.awt.event.ItemListener), ItemEvent, ItemListener

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。FooListener 是使用 addFooListener 方法注册的。

可以用一个 class 字面值（比如 FooListener.class）指定 listenerType 参数。例如，可以使用以下代码查询 Checkbox c，以获得它的项侦听器：

ItemListener[] ils = (ItemListener[])(c.getListeners(ItemListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 Component 中的 getListeners
参数：
listenerType - 所请求侦听器的类型；该参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
在此复选框上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getItemListeners()

processEvent

protected void processEvent(AWTEvent e)
处理关于此复选框的事件。如果事件是 ItemEvent 的一个实例，则此方法将调用 processItemEvent 方法。否则，它将调用其超类的 processEvent 方法。

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

覆盖：
类 Component 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, processItemEvent(java.awt.event.ItemEvent)

processItemEvent

protected void processItemEvent(ItemEvent e)
处理发生在此复选框上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。

只有启用组件的项事件之后，才会调用此方法。当下列事件之一发生时，项事件将被启用：

  • 通过 addItemListener 注册了一个 ItemListener 对象。
  • 通过 enableEvents 启用了项事件。

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

参数：
e - 项事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, ItemListener, addItemListener(java.awt.event.ItemListener), Component.enableEvents(long)

paramString

protected String paramString()
返回表示此 Checkbox 的状态的字符串。此方法仅在进行调试的时候使用，对于这两个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Component 中的 paramString
返回：
此复选框的参数字符串。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Checkbox 相关的 AccessibleContext。对于复选框，AccessibleContext 采用的是 AccessibleAWTCheckbox 的形式。如有必要，可以创建一个新的 AccessibleAWTCheckbox。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
充当此 Checkbox 的 AccessibleContext 的 AccessibleAWTCheckbox
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Checkbox.AccessibleAWTCheckbox (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Checkbox.AccessibleAWTCheckbox

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Checkbox.AccessibleAWTCheckbox
所有已实现的接口：
ItemListener, Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleValue
正在封闭类：
Checkbox
protected class Checkbox.AccessibleAWTCheckbox
extends Component.AccessibleAWTComponent
implements ItemListener, AccessibleAction, AccessibleValue

此类实现对 Checkbox 类的可访问性支持。它提供适合复选框用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
Checkbox.AccessibleAWTCheckbox()
方法摘要
boolean | doAccessibleAction(int i) 在对象上执行指定的操作
AccessibleAction | getAccessibleAction() 获取与此对象相关的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用的 Action 的数目。
String | getAccessibleActionDescription(int i) 返回对象指定操作的描述。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleValue | getAccessibleValue() 获取与此对象相关的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
void | itemStateChanged(ItemEvent e) 当切换按钮的状态变化时，激发可访问的属性更改事件。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Checkbox.AccessibleAWTCheckbox

public Checkbox.AccessibleAWTCheckbox()
方法详细信息

itemStateChanged

public void itemStateChanged(ItemEvent e)
当切换按钮的状态变化时，激发可访问的属性更改事件。

指定者：
接口 ItemListener 中的 itemStateChanged

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象相关的 AccessibleAction。在此类的 Java Accessibility API 的实现中，返回此对象，它本身负责实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象相关的 AccessibleValue。在此类的 Java Accessibility API 的实现中，返回此对象，它本身负责实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用的 Action 的数目。如果大于 1，则第一个为“默认”操作。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中 Action 的数目

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回对象指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 操作的从 0 开始的索引
返回：
动作的 String 描述
另请参见：
AccessibleAction.getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
在对象上执行指定的操作

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从 0 开始的索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的值，它是一个 Number。如果没有设置值，则返回值为 null。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
对象的值
另请参见：
setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置了值，则返回 True，否则返回 False
另请参见：
getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小值，它是一个 Number。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
对象的最小值，如果此对象没有最小值，则返回 null
另请参见：
getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大值，它是一个 Number。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
对象的最大值，如果此对象没有最大值，则返回 null
另请参见：
getMinimumAccessibleValue()

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的一个实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的一个实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CheckboxGroup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 CheckboxGroup

java.lang.Object
    继承者  java.awt.CheckboxGroup
所有已实现的接口：
Serializable
public class CheckboxGroup
extends Object
implements Serializable

CheckboxGroup 类用于集合 Checkbox 按钮集。

准确地说，CheckboxGroup 中的复选框按钮可以在任意给定的时间处于 "on" 状态。按下任何按钮，可将按钮状态设置为 "on"，并且强制将任何其他 "on" 状态的按钮更改为 "off" 状态。

以下代码示例生成了一个新的复选框组，其中有三个复选框：

 setLayout(new GridLayout(3, 1));
 CheckboxGroup cbg = new CheckboxGroup();
 add(new Checkbox("one", cbg, true));
 add(new Checkbox("two", cbg, false));
 add(new Checkbox("three", cbg, false));

下面的图像描绘了此示例创建的复选框组：

按垂直排列方式显示三个复选框，其标签分别为 one、two、three。复选框 one 处于 on 状态。

从以下版本开始：
JDK1.0
另请参见：
Checkbox, 序列化表格

构造方法摘要
CheckboxGroup()
创建 CheckboxGroup 的一个新实例。
方法摘要
 Checkbox getCurrent()
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
 Checkbox getSelectedCheckbox()
从此复选框组中获取当前选择。
 void setCurrent(Checkbox box)
已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
 void setSelectedCheckbox(Checkbox box)
将此组中当前选中的复选框设置为指定的复选框。
 String toString()
返回此复选框组的字符串表示形式，包含当前选中复选框的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CheckboxGroup

public CheckboxGroup()
创建 CheckboxGroup 的一个新实例。

方法详细信息

getSelectedCheckbox

public Checkbox getSelectedCheckbox()
从此复选框组中获取当前选择。当前选择就是此组中当前处于 "on" 状态的复选框，如果组中所有复选框都处于 off 状态，则返回 null。

返回：
当前处于 "on" 状态的复选框，或者返回 null。
从以下版本开始：
JDK1.1
另请参见：
Checkbox, setSelectedCheckbox(java.awt.Checkbox)

getCurrent

@Deprecated
public Checkbox getCurrent()
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。

setSelectedCheckbox

public void setSelectedCheckbox(Checkbox box)
将此组中当前选中的复选框设置为指定的复选框。此方法将该复选框的状态设置为 "on"，并将组中所有其他复选框设置为 off。

如果复选框参数为 null，则此复选框组中的所有复选框都会被取消选中。如果复选框参数属于一个不同的复选框组，则此方法不执行任何操作。

参数：
box - 要设置为当前选中复选框的 Checkbox。
从以下版本开始：
JDK1.1
另请参见：
Checkbox, getSelectedCheckbox()

setCurrent

@Deprecated
public void setCurrent(Checkbox box)
已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。

toString

public String toString()
返回此复选框组的字符串表示形式，包含当前选中复选框的值。

覆盖：
类 Object 中的 toString
返回：
此复选框组的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CheckboxMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 CheckboxMenuItem

java.lang.Object
    继承者  java.awt.MenuComponent
        继承者  java.awt.MenuItem
            继承者  java.awt.CheckboxMenuItem
所有已实现的接口：
ItemSelectable, Serializable, Accessible
public class CheckboxMenuItem
extends MenuItem
implements ItemSelectable, Accessible

此类表示一个可包括在菜单中的复选框。选择菜单中的复选框可以将其状态从 "开" 更改为 "关" 或者从 "关" 更改为 "开"。

下图描绘了一个包含 CheckBoxMenuItem 实例的菜单：

Examples 菜单，包含 Basic、Simple、Check 和 More Examples 项。Check 项是一个 CheckBoxMenuItem 实例，处于关闭状态。

Check 项显示了一个处于 "关" 状态的复选框菜单项。

当选定一个复选框菜单项时，AWT 将一个项事件发送到该项。因为该事件是 ItemEvent 的一个实例，所以 processEvent 方法检查该事件，同时将它传递给 processItemEvent。后一种方法将该事件重定向到任何为关注此菜单项生成的项事件而注册的 ItemListener 对象。

从以下版本开始：
JDK1.0
另请参见：
ItemEvent, ItemListener, 序列化表格

嵌套类摘要
protected  class CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
从类 java.awt.MenuItem 继承的嵌套类/接口
MenuItem.AccessibleAWTMenuItem
从类 java.awt.MenuComponent 继承的嵌套类/接口
MenuComponent.AccessibleAWTMenuComponent
构造方法摘要
CheckboxMenuItem()
创建具有空标签的复选框菜单项。
CheckboxMenuItem(String label)
创建具有指定标签的复选框菜单项。
CheckboxMenuItem(String label, boolean state)
创建 具有指定标签和状态的复选框菜单项。
方法摘要
 void addItemListener(ItemListener l)
添加指定的项侦听器，以接收发自此复选框菜单项的项事件。
 void addNotify()
创建复选框项的同位体。
 AccessibleContext getAccessibleContext()
获取与此 CheckboxMenuItem 相关的 AccessibleContext。
 ItemListener[] getItemListeners()
返回在此复选框菜单项上注册的所有项侦听器组成的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
 Object[] getSelectedObjects()
返回一个数组（长度为 1)，它包含复选框菜单项的标签，如果没有选中复选框，则返回 null。
 boolean getState()
确定此复选框菜单项的状态是 "开" 还是 "关"。
 String paramString()
返回表示此 CheckBoxMenuItem 状态的字符串。
protected  void processEvent(AWTEvent e)
处理此复选框菜单项上的事件。
protected  void processItemEvent(ItemEvent e)
处理发生在此复选框菜单项上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
 void removeItemListener(ItemListener l)
移除指定的项侦听器，以便它不再接收发自此复选框菜单项的项事件。
 void setState(boolean b)
将此复选框菜单项设置为指定的状态。
从类 java.awt.MenuItem 继承的方法
addActionListener, deleteShortcut, disable, disableEvents, enable, enable, enableEvents, getActionCommand, getActionListeners, getLabel, getShortcut, isEnabled, processActionEvent, removeActionListener, setActionCommand, setEnabled, setLabel, setShortcut
从类 java.awt.MenuComponent 继承的方法
dispatchEvent, getFont, getName, getParent, getPeer, getTreeLock, postEvent, removeNotify, setFont, setName, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CheckboxMenuItem

public CheckboxMenuItem()
                 throws HeadlessException
创建具有空标签的复选框菜单项。菜单项的状态初始设置为 "关"。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()

CheckboxMenuItem

public CheckboxMenuItem(String label)
                 throws HeadlessException
创建具有指定标签的复选框菜单项。菜单项的状态初始设置为 "关"。

参数：
label - 复选框菜单项的字符串标签，对于没有标签的菜单项，该参数为 null。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

CheckboxMenuItem

public CheckboxMenuItem(String label,
                        boolean state)
                 throws HeadlessException
创建 具有指定标签和状态的复选框菜单项。

参数：
label - 复选框菜单项的字符串标签，对于没有标签的菜单项，该参数为 null。
state - 菜单项的最初状态，其中 true 指示 "开"，false 指示 "关"。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建复选框项的同位体。此同位体允许更改复选框外观，而不更改其功能。大多数应用程序并不直接调用此方法。

覆盖：
类 MenuItem 中的 addNotify
另请参见：
Toolkit.createCheckboxMenuItem(java.awt.CheckboxMenuItem), Component.getToolkit()

getState

public boolean getState()
确定此复选框菜单项的状态是 "开" 还是 "关"。

返回：
复选框菜单项的状态，其中 true 指示 "开"，false 指示 "关"
另请参见：
setState(boolean)

setState

public void setState(boolean b)
将此复选框菜单项设置为指定的状态。boolean 值 true 指示 "开"，而 false 指示 "关"。

注意，此方法应主要用于初始化复选框菜单项的状态。以编程方式设置复选框菜单项的状态不会 触发 ItemEvent。触发 ItemEvent 的唯一方式是通过用户交互。

参数：
b - 如果复选框菜单项处于打开状态，则该参数为 true，否则为 false
另请参见：
getState()

getSelectedObjects

public Object[] getSelectedObjects()
返回一个数组（长度为 1)，它包含复选框菜单项的标签，如果没有选中复选框，则返回 null。

指定者：
接口 ItemSelectable 中的 getSelectedObjects
另请参见：
ItemSelectable

addItemListener

public void addItemListener(ItemListener l)
添加指定的项侦听器，以接收发自此复选框菜单项的项事件。发送项事件，以响应用户动作，但不响应对 setState() 的调用。如果 l 为 null，则不抛出任何异常，也不执行任何动作。有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 addItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
removeItemListener(java.awt.event.ItemListener), getItemListeners(), setState(boolean), ItemEvent, ItemListener

removeItemListener

public void removeItemListener(ItemListener l)
移除指定的项侦听器，以便它不再接收发自此复选框菜单项的项事件。如果 l 为 null，则不抛出任何异常，也不执行任何动作。有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 removeItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
addItemListener(java.awt.event.ItemListener), getItemListeners(), ItemEvent, ItemListener

getItemListeners

public ItemListener[] getItemListeners()
返回在此复选框菜单项上注册的所有项侦听器组成的数组。

返回：
此复选框菜单的所有 ItemListener；如果当前没有已注册的项侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addItemListener(java.awt.event.ItemListener), removeItemListener(java.awt.event.ItemListener), ItemEvent, ItemListener

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值（如 FooListener.class）来指定 listenerType 参数。例如，可以通过以下代码查询 CheckboxMenuItem c，以获得它的项侦听器：

ItemListener[] ils = (ItemListener[])(c.getListeners(ItemListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 MenuItem 中的 getListeners
参数：
listenerType - 请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此复选框菜单上作为 FooListener 注册的所有对象组成的数组；如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getItemListeners()

processEvent

protected void processEvent(AWTEvent e)
处理此复选框菜单项上的事件。如果事件是 ItemEvent 的一个实例，则此方法将调用 processItemEvent 方法。如果事件不是一个项事件，则它将调用超类的 processEvent。

复选框菜单项目前只支持项事件。

注意，如果事件参数为 null，则行为是不确定的，并可能导致一个异常。

覆盖：
类 MenuItem 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, processItemEvent(java.awt.event.ItemEvent)

processItemEvent

protected void processItemEvent(ItemEvent e)
处理发生在此复选框菜单项上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。

只有此菜单项启用了项事件，才会调用此方法。当出现以下情况时，将启用项事件：

  • 通过 addItemListener 注册了 ItemListener 对象。
  • 通过 enableEvents 启用了项事件。

注意，如果事件参数为 null，则行为是不确定的，并可能导致异常。

参数：
e - 项事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, ItemListener, addItemListener(java.awt.event.ItemListener), MenuItem.enableEvents(long)

paramString

public String paramString()
返回表示此 CheckBoxMenuItem 状态的字符串。此方法仅在进行调试的时候使用，对于这两个实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 MenuItem 中的 paramString
返回：
此复选框菜单项的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 CheckboxMenuItem 相关的 AccessibleContext。对于复选框菜单来说，AccessibleContext 采用 AccessibleAWTCheckboxMenuItem 的形式。如果必要，可以创建一个新的 AccessibleAWTCheckboxMenuItem。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 MenuItem 中的 getAccessibleContext
返回：
一个 AccessibleAWTCheckboxMenuItem，它充当此 CheckboxMenuItem 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.MenuComponent.AccessibleAWTMenuComponent
            继承者  java.awt.MenuItem.AccessibleAWTMenuItem
                继承者  java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleSelection, AccessibleValue
正在封闭类：
CheckboxMenuItem
protected class CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
extends MenuItem.AccessibleAWTMenuItem
implements AccessibleAction, AccessibleValue

用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。此类并非旨在由应用程序开发人员直接使用，而只能由菜单组件开发人员为其创建子类。

此类实现对 CheckboxMenuItem 类的可访问性支持。它提供适合复选框菜单项用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
protected CheckboxMenuItem.AccessibleAWTCheckboxMenuItem()
方法摘要
boolean | doAccessibleAction(int i) 在对象上执行指定的操作
AccessibleAction | getAccessibleAction() 获取与此对象相关的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用的 Actions 的数目。
String | getAccessibleActionDescription(int i) 返回对象指定操作的描述。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleValue | getAccessibleValue() 获取与此对象相关的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 java.awt.MenuItem.AccessibleAWTMenuItem 继承的方法
getAccessibleName
从类 java.awt.MenuComponent.AccessibleAWTMenuComponent 继承的方法
addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem

protected CheckboxMenuItem.AccessibleAWTCheckboxMenuItem()
方法详细信息

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象相关的 AccessibleAction。在此类的 Java Accessibility API 的实现中，返回此对象，它本身负责实现 AccessibleAction 接口。

覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象相关的 AccessibleValue。在此类的 Java Accessibility API 的实现中，返回此对象，它本身负责实现 AccessibleValue 接口。

覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用的 Actions 的数目。如果大于 1，则第一个为“默认”操作。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getAccessibleActionCount
返回：
此对象中 Action 的数目。

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回对象指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getAccessibleActionDescription
参数：
i - 操作的从 0 开始的索引
返回：
动作的 String 描述
另请参见：
AccessibleAction.getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
在对象上执行指定的操作

指定者：
接口 AccessibleAction 中的 doAccessibleAction
覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 doAccessibleAction
参数：
i - 操作的从 0 开始的索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的值，它是一个 Number。如果没有设置值，则返回值为 null。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getCurrentAccessibleValue
返回：
对象的值
另请参见：
setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 setCurrentAccessibleValue
返回：
如果设置了值，则返回 true，否则返回 false
另请参见：
getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小值，它是一个 Number。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getMinimumAccessibleValue
返回：
对象的最小值，如果此对象没有最小值，则返回 null
另请参见：
getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大值，它是一个 Number。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getMaximumAccessibleValue
返回：
对象的最大值，如果此对象没有最大值，则返回 null
另请参见：
getMinimumAccessibleValue()

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的一个实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Choice (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Choice

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Choice
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible
public class Choice
extends Component
implements ItemSelectable, Accessible

Choice 类表示一个弹出式选择菜单。当前的选择显示为菜单的标题。

下列代码示例产生了一个弹出式菜单：

Choice ColorChooser = new Choice();
ColorChooser.add("Green");
ColorChooser.add("Red");
ColorChooser.add("Blue");

在将此选择菜单添加到一个面板中后，它显示为以下正常状态：

在这个图像中，"Green" 为当前选择。在对象上按下鼠标按键，这将显示一个菜单，菜单的当前选择被高亮显示。

一些本机平台不支持任意调整 Choice 组件的大小，setSize()/getSize() 的行为受到这类限制的约束。本机 GUI Choice 组件的大小常受到一些属性的限制，比如字体大小和 Choice 中包含的项的长度。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

嵌套类摘要
protected  class Choice.AccessibleAWTChoice
此类实现对 Choice 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Choice()
创建一个新的选择菜单。
方法摘要
 void add(String item)
将一个项添加到此 Choice 菜单中。
 void addItem(String item)
如果对于 Java 2 platform v1.1 已过时，请使用 add 方法替换。
 void addItemListener(ItemListener l)
添加指定的项侦听器，以接收发自此 Choice 菜单的项事件。
 void addNotify()
创建 Choice 的同位体。
 int countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
 AccessibleContext getAccessibleContext()
获取与此 Choice 相关的 AccessibleContext。
 String getItem(int index)
获取此 Choice 菜单中指定索引上的字符串。
 int getItemCount()
返回此 Choice 菜单中项的数量。
 ItemListener[] getItemListeners()
返回已在此选择上注册的所有项侦听器组成的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
 int getSelectedIndex()
返回当前选定项的索引。
 String getSelectedItem()
获取当前选择的字符串表示形式。
 Object[] getSelectedObjects()
返回包含当前选定项的数组（长度为 1）。
 void insert(String item, int index)
将菜单项插入此选择的指定位置上。
protected  String paramString()
返回表示此 Choice 菜单的状态的字符串。
protected  void processEvent(AWTEvent e)
处理关于此选择的事件。
protected  void processItemEvent(ItemEvent e)
处理发生在此 Choice 菜单上的项事件，实现方式是将这些事件指派给所有已注册的 ItemListener 对象。
 void remove(int position)
从选择菜单的指定位置上移除一个项。
 void remove(String item)
移除 Choice 菜单中第一个出现的 item。
 void removeAll()
从选择菜单中移除所有的项。
 void removeItemListener(ItemListener l)
移除指定的项侦听器，以便它不再接收发自此 Choice 菜单的项事件。
 void select(int pos)
将此 Choice 菜单中的选定项设置为指定位置上的项。
 void select(String str)
将此 Choice 菜单中的选定项设置为其名称等于指定字符串的项。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Choice

public Choice()
       throws HeadlessException
创建一个新的选择菜单。最初，此菜单中没有任何项。

默认情况下，在用户通过调用 select 方法之一进行不同的选择之前，给选择菜单添加的第一个项将成为选定项。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), select(int), select(java.lang.String)
方法详细信息

addNotify

public void addNotify()
创建 Choice 的同位体。此同位体允许更改 Choice 的外观，而不更改其功能。

覆盖：
类 Component 中的 addNotify
另请参见：
Toolkit.createChoice(java.awt.Choice), Component.getToolkit()

getItemCount

public int getItemCount()
返回此 Choice 菜单中项的数量。

返回：
此 Choice 菜单中项的数量
从以下版本开始：
JDK1.1
另请参见：
getItem(int)

countItems

@Deprecated
public int countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。

getItem

public String getItem(int index)
获取此 Choice 菜单中指定索引上的字符串。

参数：
index - 起始索引
另请参见：
getItemCount()

add

public void add(String item)
将一个项添加到此 Choice 菜单中。

参数：
item - 要添加的项
抛出：
NullPointerException - 如果这个项的值为 null
从以下版本开始：
JDK1.1

addItem

public void addItem(String item)
如果对于 Java 2 platform v1.1 已过时，请使用 add 方法替换。

将一个项添加到此 Choice 菜单中。

参数：
item - 要添加的菜单项
抛出：
NullPointerException - 如果这个项的值等于 null

insert

public void insert(String item,
                   int index)
将菜单项插入此选择的指定位置上。如果某个索引上存在的项大于等于 index，则将它上移一位，以容纳新的项。如果 index 大于等于此选择中项的数目，则将 item 添加到此选择的结尾处。

如果此项是第一个添加到该选择中的项，则这个项将成为选定项。否则，如果选定项是上移项中的一个，则该选择中的第一个项将成为选定项。如果选定项不在这些上移项中，则它仍然是选定项。

参数：
item - 将插入的非 null 项
index - 应该插入项的位置
抛出：
IllegalArgumentException - 如果索引小于 0

remove

public void remove(String item)
移除 Choice 菜单中第一个出现的 item。如果正被移除的项是目前选定的项，则该选择中的第一个项将成为选定项。否则，当前选定项仍然是选定项（并且选定的索引被相应地更新）。

参数：
item - 将从此 Choice 菜单中移除的项
抛出：
IllegalArgumentException - 如果该项不在此选择菜单中
从以下版本开始：
JDK1.1

remove

public void remove(int position)
从选择菜单的指定位置上移除一个项。如果正被移除的项是目前选定的项，则该选择中的第一个项将成为选定项。否则，当前选定项将仍然是选定项（并且选定的索引被相应地更新）。

参数：
position - 项的位置
抛出：
IndexOutOfBoundsException - 如果指定位置超出边界
从以下版本开始：
JDK1.1

removeAll

public void removeAll()
从选择菜单中移除所有的项。

从以下版本开始：
JDK1.1
另请参见：
remove(java.lang.String)

getSelectedItem

public String getSelectedItem()
获取当前选择的字符串表示形式。

返回：
此选择菜单中当前选定项的字符串表示形式
另请参见：
getSelectedIndex()

getSelectedObjects

public Object[] getSelectedObjects()
返回包含当前选定项的数组（长度为 1）。如果此选择菜单中没项，则返回 null。

指定者：
接口 ItemSelectable 中的 getSelectedObjects
另请参见：
ItemSelectable

getSelectedIndex

public int getSelectedIndex()
返回当前选定项的索引。如果没有选定任何内容，则返回 -1。

返回：
当前选定项的索引，如果目前没有选定任何内容，则返回 -1
另请参见：
getSelectedItem()

select

public void select(int pos)
将此 Choice 菜单中的选定项设置为指定位置上的项。

注意，此方法主要应该用于对此组件中某个项的选择的初始化。以编程方式调用此方法不 会触发 ItemEvent。触发 ItemEvent 的唯一方式是通过用户交互。

参数：
pos - 指定项的位置
抛出：
IllegalArgumentException - 如果指定位置大于项的数量或小于零
另请参见：
getSelectedItem(), getSelectedIndex()

select

public void select(String str)
将此 Choice 菜单中的选定项设置为其名称等于指定字符串的项。如果有多个项与指定的字符串匹配（相等），则选择具有最小索引的那一个项。

注意，此方法主要应该用于初始化对此组件中某个项的选择。以编程方式调用此方法不 会触发 ItemEvent。触发 ItemEvent 的唯一方式是通过用户交互。

参数：
str - 指定的字符串
另请参见：
getSelectedItem(), getSelectedIndex()

addItemListener

public void addItemListener(ItemListener l)
添加指定的项侦听器，以接收发自此 Choice 菜单的项事件。通过发送项事件来响应用户输入，但不响应对 select 的调用。如果 l 为 null，则不会抛出异常，并且不执行任何动作。有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 addItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
removeItemListener(java.awt.event.ItemListener), getItemListeners(), select(int), ItemEvent, ItemListener

removeItemListener

public void removeItemListener(ItemListener l)
移除指定的项侦听器，以便它不再接收发自此 Choice 菜单的项事件。如果 l 为 null，则不会抛出异常，并且不执行任何动作。有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 removeItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
addItemListener(java.awt.event.ItemListener), getItemListeners(), ItemEvent, ItemListener

getItemListeners

public ItemListener[] getItemListeners()
返回已在此选择上注册的所有项侦听器组成的数组。

返回：
此选择的所有 ItemListener，如果没有当前已注册的项侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addItemListener(java.awt.event.ItemListener), removeItemListener(java.awt.event.ItemListener), ItemEvent, ItemListener

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。FooListener 是使用 addFooListener 方法注册的。

可以用一个 class 字面值（比如 FooListener.class）指定 listenerType 参数。例如，可以使用以下代码查询 Choice c，以获得它的项侦听器：

ItemListener[] ils = (ItemListener[])(c.getListeners(ItemListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 Component 中的 getListeners
参数：
listenerType - 所请求侦听器的类型；该参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
在此选择上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getItemListeners()

processEvent

protected void processEvent(AWTEvent e)
处理关于此选择的事件。如果事件是 ItemEvent 的一个实例，则此方法将调用 processItemEvent 方法。否则，它将调用其超类的 processEvent 方法。

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

覆盖：
类 Component 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, processItemEvent(java.awt.event.ItemEvent)

processItemEvent

protected void processItemEvent(ItemEvent e)
处理发生在此 Choice 菜单上的项事件，实现方式是将这些事件指派给所有已注册的 ItemListener 对象。

只有为此组件启用项事件之后，才调用此方法。项事件是在出现以下情况之一时启用：

  • ItemListener 对象是通过 addItemListener 注册的。
  • 可以通过 enableEvents 启用项事件。

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

参数：
e - 项事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, ItemListener, addItemListener(ItemListener), Component.enableEvents(long)

paramString

protected String paramString()
返回表示此 Choice 菜单的状态的字符串。此方法仅在进行调试的时候使用，对于这两个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Component 中的 paramString
返回：
此 Choice 菜单的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Choice 相关的 AccessibleContext。对于 Choice 组件，AccessibleContext 采用的是 AccessibleAWTChoice 的形式。如有必要，可以创建一个新的 AccessibleAWTChoice 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
充当此 Choice 的 AccessibleContext 的 AccessibleAWTChoice
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Choice.AccessibleAWTChoice (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Choice.AccessibleAWTChoice

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Choice.AccessibleAWTChoice
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent
正在封闭类：
Choice
protected class Choice.AccessibleAWTChoice
extends Component.AccessibleAWTComponent
implements AccessibleAction

此类实现对 Choice 类的可访问性支持。它提供适合 choice 用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
Choice.AccessibleAWTChoice()
方法摘要
boolean | doAccessibleAction(int i) 在对象上执行指定的操作
AccessibleAction | getAccessibleAction() 获取与此对象相关的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用的可访问操作的数目，如果大于 1，则第一个作为该对象的“默认”操作。
String | getAccessibleActionDescription(int i) 返回对象指定操作的描述。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Choice.AccessibleAWTChoice

public Choice.AccessibleAWTChoice()
方法详细信息

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象相关的 AccessibleAction。在此类的 Java Accessibility API 的实现中，返回此对象，它本身负责实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的一个实例
另请参见：
AccessibleRole

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用的可访问操作的数目，如果大于 1，则第一个作为该对象的“默认”操作。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中 Action 的数目，从 0 开始索引

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回对象指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 操作的从 0 开始的索引
返回：
操作的字符串描述
另请参见：
getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
在对象上执行指定的操作

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从 0 开始的索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
getAccessibleActionCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Color (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Color

java.lang.Object
    继承者  java.awt.Color
所有已实现的接口：
Paint, Transparency, Serializable
直接已知子类：
ColorUIResource, SystemColor
public class Color
extends Object
implements Paint, Serializable

Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。每种颜色都有一个隐式的 alpha 值 1.0，或者有一个在构造方法中提供的显式的 alpha 值。alpha 值定义了颜色的透明度，可用一个在 0.0 - 1.0 或 0 - 255 范围内的浮点值表示它。alpha 值为 1.0 或 255 则意味着颜色完全是不透明的，alpha 值为 0 或 0.0 则意味着颜色是完全透明的。在使用显式的 alpha 值构造 Color 时，或者在获取某个 Color 的颜色/alpha 分量时，从不将颜色分量预乘 alpha 分量。

Java 2D(tm) API 的默认颜色空间是 sRGB，这是一个被推荐使用的标准 RGB 颜色空间。有关 sRGB 的更多信息，请参阅 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html。

另请参见：
ColorSpace, AlphaComposite, 序列化表格

字段摘要
static Color | black 黑色。
static Color | BLACK 黑色。
static Color | blue 蓝色。
static Color | BLUE 蓝色。
static Color | cyan 青色。
static Color | CYAN 青色。
static Color | DARK_GRAY 深灰色。
static Color | darkGray 深灰色。
static Color | gray 灰色。
static Color | GRAY 灰色。
static Color | green 绿色。
static Color | GREEN 绿色。
static Color | LIGHT_GRAY 浅灰色。
static Color | lightGray 浅灰色。
static Color | magenta 洋红色。
static Color | MAGENTA 洋红色。
static Color | orange 桔黄色。
static Color | ORANGE 桔黄色。
static Color | pink 粉红色。
static Color | PINK 粉红色。
static Color | red 红色。
static Color | RED 红色。
static Color | white 白色。
static Color | WHITE 白色。
static Color | yellow 黄色。
static Color | YELLOW 黄色。
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
Color(ColorSpace cspace, float[] components, float alpha)
创建具有 float 数组中指定的颜色分量和指定的 alpha 值的指定 ColorSpace 中的颜色。
Color(float r, float g, float b)
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这三个颜色值都在 (0.0 - 1.0) 的范围内。
Color(float r, float g, float b, float a)
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0.0 - 1.0) 的范围内。
Color(int rgb)
创建具有指定组合的 RGB 值的不透明的 sRGB 颜色，此 sRGB 值的 16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。
Color(int rgba, boolean hasalpha)
创建具有指定组合的 RGBA 值的 sRGB 颜色，此 RGBA 值的 24-31 位表示 alpha 分量，16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。
Color(int r, int g, int b)
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。
Color(int r, int g, int b, int a)
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。
方法摘要
Color | brighter() 创建一个新 Color，它具有比此 Color 更亮的颜色。
PaintContext | createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
Color | darker() 创建一个新 Color，它具有比此 Color 更暗的颜色。
static Color | decode(String nm) 将 String 转换成整数，并返回指定的不透明 Color。
boolean | equals(Object obj) 确定另一个对象是否与此 Color 相同。
int | getAlpha() 返回位于范围 0-255 中的 alpha 分量。
int | getBlue() 返回默认 sRGB 空间中位于范围 0-255 中的蓝色分量。
static Color | getColor(String nm) 查找系统属性中的一种颜色。
static Color | getColor(String nm, Color v) 查找系统属性中的一种颜色。
static Color | getColor(String nm, int v) 查找系统属性中的一种颜色。
float[] | getColorComponents(ColorSpace cspace, float[] compArray) 根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
float[] | getColorComponents(float[] compArray) 根据 Color 的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
ColorSpace | getColorSpace() 返回此 Color 的 ColorSpace。
float[] | getComponents(ColorSpace cspace, float[] compArray) 根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的 alpha 分量。
float[] | getComponents(float[] compArray) 根据 Color 的 ColorSpace，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。
int | getGreen() 返回默认 sRGB 空间中位于范围 0-255 中的绿色分量。
static Color | getHSBColor(float h, float s, float b) 根据所指定的数值，创建一个基于 HSB 颜色模型的 Color 对象。
int | getRed() 返回默认 sRGB 空间中位于范围 0-255 中的红色分量。
int | getRGB() 返回默认 sRGB ColorModel 中表示颜色的 RGB 值。
float[] | getRGBColorComponents(float[] compArray) 根据默认的 sRGB color space，返回一个 float 数组，该数组只包含 Color 的颜色分量。
float[] | getRGBComponents(float[] compArray) 根据默认的 sRGB color space，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。
int | getTransparency() 返回此 Color 的透明模式。
int | hashCode() 计算此 Color 的哈希码。
static int | HSBtoRGB(float hue, float saturation, float brightness) 将由 HSB 模型指定的颜色分量转换为等价的默认 RGB 模型的值的集合。
static float[] | RGBtoHSB(int r, int g, int b, float[] hsbvals) 将默认 RGB 模式指定的颜色分量转换为等价的色调、饱和度和亮度值的集合，这三个值是 HSB 模型的三个分量。
String | toString() 返回此 Color 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

white

public static final Color white
白色。在默认 sRGB 空间中。

WHITE

public static final Color WHITE
白色。在默认 sRGB 空间中。

从以下版本开始：
1.4

lightGray

public static final Color lightGray
浅灰色。在默认 sRGB 空间中。

LIGHT_GRAY

public static final Color LIGHT_GRAY
浅灰色。在默认 sRGB 空间中。

从以下版本开始：
1.4

gray

public static final Color gray
灰色。在默认 sRGB 空间中。

从以下版本开始：
1.4

GRAY

public static final Color GRAY
灰色。在默认 sRGB 空间中。

darkGray

public static final Color darkGray
深灰色。在默认 sRGB 空间中。

DARK_GRAY

public static final Color DARK_GRAY
深灰色。在默认 sRGB 空间中。

从以下版本开始：
1.4

black

public static final Color black
黑色。在默认 sRGB 空间中。

BLACK

public static final Color BLACK
黑色。在默认 sRGB 空间中。

从以下版本开始：
1.4

red

public static final Color red
红色。在默认 sRGB 空间中。

RED

public static final Color RED
红色。在默认 sRGB 空间中。

从以下版本开始：
1.4

pink

public static final Color pink
粉红色。在默认 sRGB 空间中。

PINK

public static final Color PINK
粉红色。在默认 sRGB 空间中。

从以下版本开始：
1.4

orange

public static final Color orange
桔黄色。在默认 sRGB 空间中。

ORANGE

public static final Color ORANGE
桔黄色。在默认 sRGB 空间中。

从以下版本开始：
1.4

yellow

public static final Color yellow
黄色。在默认 sRGB 空间中。

YELLOW

public static final Color YELLOW
黄色。在默认 sRGB 空间中。

从以下版本开始：
1.4

green

public static final Color green
绿色。在默认 sRGB 空间中。

GREEN

public static final Color GREEN
绿色。在默认 sRGB 空间中。

从以下版本开始：
1.4

magenta

public static final Color magenta
洋红色。在默认 sRGB 空间中。

MAGENTA

public static final Color MAGENTA
洋红色。在默认 sRGB 空间中。

从以下版本开始：
1.4

cyan

public static final Color cyan
青色。在默认 sRGB 空间中。

CYAN

public static final Color CYAN
青色。在默认 sRGB 空间中。

从以下版本开始：
1.4

blue

public static final Color blue
蓝色。在默认 sRGB 空间中。

BLUE

public static final Color BLUE
蓝色。在默认 sRGB 空间中。

从以下版本开始：
1.4
构造方法详细信息

Color

public Color(int r,
             int g,
             int b)
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。绘制时实际使用的颜色取决于从给出的可用于给定输出设备的颜色空间中找到的最匹配颜色。alpha 值的默认值为 255。

参数：
r - 红色分量
g - 绿色分量
b - 蓝色分量
抛出：
IllegalArgumentException - 如果 r、g 或 b 超出 0 到 255（包括）的范围
另请参见：
getRed(),
getGreen(),
getBlue(),
getRGB()

Color

public Color(int r,
             int g,
             int b,
             int a)
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0 - 255) 的范围内。

参数：
r - 红色分量
g - 绿色分量
b - 蓝色分量
a - alpha 分量
抛出：
IllegalArgumentException - 如果 r、g、b 或 a 超出 0 到 255（包括）的范围
另请参见：
getRed(),
getGreen(),
getBlue(),
getAlpha(),
getRGB()

Color

public Color(int rgb)
创建具有指定组合的 RGB 值的不透明的 sRGB 颜色，此 sRGB 值的 16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。绘制时实际使用的颜色取决于从给出的可用于特定输出设备的颜色空间中找到的最匹配颜色。alpha 值的默认值为 255。

参数：
rgb - 组合的 RGB 分量
另请参见：
ColorModel.getRGBdefault(),
getRed(),
getGreen(),
getBlue(),
getRGB()

Color

public Color(int rgba,
             boolean hasalpha)
创建具有指定组合的 RGBA 值的 sRGB 颜色，此 RGBA 值的 24-31 位表示 alpha 分量，16-23 位表示红色分量，8-15 位表示绿色分量，0-7 位表示蓝色分量。如果 hasalpha 参数为 false，则 alpha 值为默认值 255。

参数：
rgba - 组合的 RGBA 分量
hasalpha - 如果 alpha 的位有效，则该参数为 true；否则为 false
另请参见：
ColorModel.getRGBdefault(),
getRed(),
getGreen(),
getBlue(),
getAlpha(),
getRGB()

Color

public Color(float r,
             float g,
             float b)
创建具有指定红色、绿色和蓝色值的不透明的 sRGB 颜色，这三个颜色值都在 (0.0 - 1.0) 的范围内。alpha 值的默认值为 1.0。绘制时实际使用的颜色取决于从给出的可用于特定输出设备的颜色空间中找到的最匹配颜色。

参数：
r - 红色分量
g - 绿色分量
b - 蓝色分量
抛出：
IllegalArgumentException - 如果 r、g 或 b 超出 0.0 到 1.0（包括）的范围
另请参见：
getRed(),
getGreen(),
getBlue(),
getRGB()

Color

public Color(float r,
             float g,
             float b,
             float a)
创建具有指定红色、绿色、蓝色和 alpha 值的 sRGB 颜色，这些值都在 (0.0 - 1.0) 的范围内。绘制时实际使用的颜色取决于从给出的可用于特定输出设备的颜色空间中找到的最匹配的颜色。

参数：
r - 红色分量
g - 绿色分量
b - 蓝色分量
a - alpha 分量
抛出：
IllegalArgumentException - 如果 r、g、b 或 a 超出 0.0 到 1.0（包括）的范围
另请参见：
getRed(),
getGreen(),
getBlue(),
getAlpha(),
getRGB()

Color

public Color(ColorSpace cspace,
             float[] components,
             float alpha)
创建具有 float 数组中指定的颜色分量和指定的 alpha 值的指定 ColorSpace 中的颜色。分量的数量由 ColorSpace 的类型确定。例如，RGB 需要 3 个分量，但 CMYK 需要 4 个分量。

参数：
cspace - 用来解释分量的 ColorSpace
components - 与 ColorSpace 兼容的任意数量的颜色分量
alpha - alpha 值
抛出：
IllegalArgumentException - 如果 components 数组中的任意某个值或 alpha 值超出 0.0 到 1.0 的范围
另请参见：
getComponents(float[]), getColorComponents(float[])
方法详细信息

getRed

public int getRed()
返回默认 sRGB 空间中位于范围 0-255 中的红色分量。

返回：
红色分量。
另请参见：
getRGB()

getGreen

public int getGreen()
返回默认 sRGB 空间中位于范围 0-255 中的绿色分量。

返回：
绿色分量。
另请参见：
getRGB()

getBlue

public int getBlue()
返回默认 sRGB 空间中位于范围 0-255 中的蓝色分量。

返回：
蓝色分量。
另请参见：
getRGB()

getAlpha

public int getAlpha()
返回位于范围 0-255 中的 alpha 分量。

返回：
alpha 分量。
另请参见：
getRGB()

getRGB

public int getRGB()
返回默认 sRGB ColorModel 中表示颜色的 RGB 值。（24-31 位表示 alpha，16-23 位表示红色，8-15 位表示绿色，0-7 位表示蓝色）。

返回：
默认 sRGB ColorModel 中表示颜色的 RGB 值。
从以下版本开始：
JDK1.0
另请参见：
ColorModel.getRGBdefault(),
getRed(),
getGreen(),
getBlue()

brighter

public Color brighter()
创建一个新 Color，它具有比此 Color 更亮的颜色。

此方法对这个 Color 的三个 RGB 分量都使用了一个任意缩放因子，以创建具有更亮颜色的 Color。brighter 和 darker 是相反的操作，因为舍入误差，所以连续多次调用这两个方法所产生的结果可能是不一致的。

返回：
一个新 Color，它具有比此 Color 更亮的颜色。
从以下版本开始：
JDK1.0
另请参见：
darker()

darker

public Color darker()
创建一个新 Color，它具有比此 Color 更暗的颜色。

此方法对这个 Color 的三个 RGB 分量都使用了一个任意缩放因子，以创建具有更暗颜色的 Color。brighter 和 darker 是相反的操作，因为舍入误差，所以连续多次调用这两个方法所产生的结果可能是不一致的。

返回：
一个新 Color，它具有比此 Color 更暗的颜色。
从以下版本开始：
JDK1.0
另请参见：
brighter()

hashCode

public int hashCode()
计算此 Color 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
从以下版本开始：
JDK1.0
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
确定另一个对象是否与此 Color 相同。

当且仅当此参数不为 null，并且是一个与此对象具有相同红色、绿色、蓝色和 alpha 值的 Color 对象时，结果才是 true。

覆盖：
类 Object 中的 equals
参数：
obj - 用来与此 Color 进行等同性测试的对象
返回：
如果对象相同，则返回 true；否则返回 false
从以下版本开始：
JDK1.0
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回此 Color 的字符串表示形式。此方法只适用于调试。返回的字符串的内容和格式在各种实现间可能各不相同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Object 中的 toString
返回：
此 Color 的字符串表示形式。

decode

public static Color decode(String nm)
                    throws NumberFormatException
将 String 转换成整数，并返回指定的不透明 Color。此方法处理用来表示八进制和十六进制数字的字符串格式。

参数：
nm - 将某种不透明颜色表示为 24 位整数的 String
返回：
新的 Color 对象。
抛出：
NumberFormatException - 如果不能将指定的字符串解释为十进制、八进制或十六进制的整数。
从以下版本开始：
JDK1.1
另请参见：
Integer.decode(java.lang.String)

getColor

public static Color getColor(String nm)
查找系统属性中的一种颜色。

该参数被视为要获得的系统属性的名称。然后，将此属性的字符串值解释为一个整数值，该整数随后被转换为一个 Color 对象。

如果没有找到指定的属性，或者无法将它当作一个整数来分析，则返回 null。

参数：
nm - 颜色属性的名称
返回：
系统属性所转换的 Color
从以下版本开始：
JDK1.0
另请参见：
System.getProperty(java.lang.String),
Integer.getInteger(java.lang.String),
Color(int)

getColor

public static Color getColor(String nm,
                             Color v)
查找系统属性中的一种颜色。

第一个参数被视为要获得的系统属性的名称。然后，将此属性的字符串值解释为一个整数值，该整数随后被转换为一个 Color 对象。

如果没有找到指定的属性，或者不能将该属性当作一个整数来分析，则返回由第二个参数指定的 Color。

参数：
nm - 颜色属性的名称
v - 默认的 Color
返回：
系统属性所转换的 Color，或者指定的 Color
从以下版本开始：
JDK1.0
另请参见：
System.getProperty(java.lang.String),
Integer.getInteger(java.lang.String),
Color(int)

getColor

public static Color getColor(String nm,
                             int v)
查找系统属性中的一种颜色。

第一个参数被视为要获得的系统属性的名称。然后，将此属性的字符串值解释为一个整数值，该整数随后被转换为一个 Color 对象。

如果没有找到指定的属性，或者不能将该属性当作一个整数来分析，则使用整数值 v 来替代，并将它转换为一个 Color 对象。

参数：
nm - 颜色属性的名称
v - 默认的整数形式的颜色值
返回：
系统属性所转换的 Color 或者指定整数所转换的 Color
从以下版本开始：
JDK1.0
另请参见：
System.getProperty(java.lang.String),
Integer.getInteger(java.lang.String),
Color(int)

HSBtoRGB

public static int HSBtoRGB(float hue,
                           float saturation,
                           float brightness)
将由 HSB 模型指定的颜色分量转换为等价的默认 RGB 模型的值的集合。

saturation 和 brightness 分量应该是 0 到 1 之间的浮点值（范围在 0.0-1.0 之间的数字）。hue 分量可以是任意浮点数字。从这个数字中减去该数字的基数，便可以创建 0 和 1 之间的小数部分。然后，将这个数字乘以 360 就可以得到 HSB 颜色模式中的色彩角度。

HSBtoRGB 返回的整数在整数值 0-23 的位中对颜色值进行了编码，该整数值的格式与 getRGB 使用的格式相同。可以将这个整数作为一个参数提供给 Color 构造方法，此构造方法仅带有一个参数。

参数：
hue - 颜色的灰度分量
saturation - 颜色的饱和度
brightness - 颜色的亮度
返回：
具有指示色调、饱和度和亮度的颜色的 RGB 值。
从以下版本开始：
JDK1.0
另请参见：
getRGB(), Color(int), ColorModel.getRGBdefault()

RGBtoHSB

public static float[] RGBtoHSB(int r,
                               int g,
                               int b,
                               float[] hsbvals)
将默认 RGB 模式指定的颜色分量转换为等价的色调、饱和度和亮度值的集合，这三个值是 HSB 模型的三个分量。

如果 hsbvals 参数为 null，则分配一个新的数组来返回结果。否则。该方法将返回 hsbvals 数组，以及存放在数组中的值。

参数：
r - 该颜色的红色分量
g - 该颜色的绿色分量
b - 该颜色的蓝色分量
hsbvals - 用来返回三个 HSB 值的数组，或者为 null
返回：
包含颜色的色调、饱和度和亮度（按此排序）的三个元素的数组，此颜色具有指示的红色、绿色和蓝色分量。
从以下版本开始：
JDK1.0
另请参见：
getRGB(), Color(int), ColorModel.getRGBdefault()

getHSBColor

public static Color getHSBColor(float h,
                                float s,
                                float b)
根据所指定的数值，创建一个基于 HSB 颜色模型的 Color 对象。

s 和 b 分量应该是 0 到 1 之间的浮点值（范围在 0.0-1.0 之间的数字）。h 分量可以是任意浮点数字。从这个数字中减去该数字的基数，便可以创建 0 和 1 之间的小数部分。然后，将这个数字乘以 360 就可以得到 HSB 颜色模式中的色彩角度。

参数：
h - hue 分量
s - 颜色的饱和度
b - 颜色的亮度
返回：
一个具有指定色调、饱和度和亮度的 Color 对象。
从以下版本开始：
JDK1.0

getRGBComponents

public float[] getRGBComponents(float[] compArray)
根据默认的 sRGB color space，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。如果 compArray 为 null，则将为返回值创建一个长度为 4 的数组。否则，compArray 的长度必须是 4 或大于 4，并被上述分量和返回的值填充。

参数：
compArray - 此方法用颜色分量、alpha 分量和返回的值填充的数组
返回：
float 数组中的 RGBA 分量。

getRGBColorComponents

public float[] getRGBColorComponents(float[] compArray)
根据默认的 sRGB color space，返回一个 float 数组，该数组只包含 Color 的颜色分量。如果 compArray 为 null，则将为返回值创建一个长度为 3 的数组。否则，compArray 的长度必须是 3 或大于 4，并被上述分量和返回的值填充。

参数：
compArray - 此方法用颜色分量和返回的值填充的数组
返回：
float 数组中的 RGB 分量。

getComponents

public float[] getComponents(float[] compArray)
根据 Color 的 ColorSpace，返回一个 float 数组，该数组包含 Color 的颜色分量和 alpha 分量。如果 compArray 为 null，则将为返回值创建一个数组，该数组的长度等于相关 ColorSpace 中的分量数加 1。否则，compArray 的长度至少必须为该长度，并被上述分量和返回的值填充。

参数：
compArray - 此方法用 ColorSpace 中此 Color 的颜色分量和 alpha 分量填充并返回的数组
返回：
float 数组中的颜色分量和 alpha 分量。

getColorComponents

public float[] getColorComponents(float[] compArray)
根据 Color 的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。如果 compArray 为 null，则将为返回值创建一个数组，该数组的长度等于相关 ColorSpace 中的分量数。否则，compArray 的长度至少必须为该长度，并被上述分量和返回的值填充。

参数：
compArray - 此方法用 ColorSpace 中此 Color 的颜色分量填充并返回的数组
返回：
float 数组中的颜色分量。

getComponents

public float[] getComponents(ColorSpace cspace,
                             float[] compArray)
根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的 alpha 分量。如果 compArray 为 null，则将为返回值创建一个数组，该数组的长度等于 cspace 中的分量数加 1。否则，compArray 的长度至少必须为该长度，并被上述分量和返回的值填充。

参数：
cspace - 一个指定的 ColorSpace
compArray - 此方法用指定 ColorSpace 中此 Color 的颜色分量和 alpha 分量填充并返回的数组
返回：
float 数组中的颜色分量和 alpha 分量。

getColorComponents

public float[] getColorComponents(ColorSpace cspace,
                                  float[] compArray)
根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。如果 compArray 为 null，则将为返回值创建一个数组，该数组的长度等于 cspace 中的分量数。否则，compArray 的长度至少必须为该长度，并被上述分量和返回的值填充。

参数：
cspace - 一个指定的 ColorSpace
compArray - 此方法用指定 ColorSpace 中此 Color 的颜色分量填充的数组
返回：
float 数组中的颜色分量。

getColorSpace

public ColorSpace getColorSpace()
返回此 Color 的 ColorSpace。

返回：
此 Color 对象的 ColorSpace。

createContext

public PaintContext createContext(ColorModel cm,
                                  Rectangle r,
                                  Rectangle2D r2d,
                                  AffineTransform xform,
                                  RenderingHints hints)
创建并返回用来生成固定颜色模式的 PaintContext。这使得任何一个需要以一个实现了 Paint 接口的对象为参数的方法，都可以用 Color 对象做该参数。不管 r、r2d、xform 或 hints 是否为 null，返回的都是相同的 PaintContext。

指定者：
接口 Paint 中的 createContext
参数：
cm - 指定的 ColorModel
r - 指定的 Rectangle
r2d - 指定的 Rectangle2D
xform - 指定的 AffineTransform
hints - 指定的 RenderingHints
返回：
一个用来生成固定颜色模式的 PaintContext
另请参见：
Paint, PaintContext, Graphics2D.setPaint(java.awt.Paint)

getTransparency

public int getTransparency()
返回此 Color 的透明模式。当实现 Paint 接口时需要用到此方法。

指定者：
接口 Transparency 中的 getTransparency
返回：
此 Color 对象的透明模式。
另请参见：
Paint, Transparency, createContext(java.awt.image.ColorModel, java.awt.Rectangle, java.awt.geom.Rectangle2D, java.awt.geom.AffineTransform, java.awt.RenderingHints)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Component (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component

java.lang.Object
    继承者  java.awt.Component
所有已实现的接口：
ImageObserver, MenuContainer, Serializable
直接已知子类：
Button, Canvas, Checkbox, Choice, Container, Label, List, Scrollbar, TextComponent
public abstract class Component
extends Object
implements ImageObserver, MenuContainer, Serializable

component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。典型图形用户界面中的按钮、复选框和滚动条都是组件示例。

Component 类是与菜单不相关的 Abstract Window Toolkit 组件的抽象超类。还可以直接扩展类 Component 来创建一个轻量级组件。轻量级组件是与本机不透明窗口不相关的组件。

序列化

存储对象时，仅保存那些符合 Serializable 协议的 AWT 侦听器，注意这一点很重要。如果具有侦听器的 AWT 对象未标记为可序列化，则在 writeObject 时将会被丢弃。开发人员始终需要考虑序列化对象的意义。需要注意的一种情形是：
    import java.awt.*;
    import java.awt.event.*;
    import java.io.Serializable;

    class MyApp implements ActionListener, Serializable
    {
        BigObjectThatShouldNotBeSerializedWithAButton bigOne;
        Button aButton = new Button();

        MyApp()
        {
            // Oops, now aButton has a listener with a reference
            // to bigOne!
            aButton.addActionListener(this);
        }

        public void actionPerformed(ActionEvent e)
        {
            System.out.println("Hello There");
        }
    }
在此示例中，通过 aButton 自身进行序列化会使得 MyApp 及其引用的所有内容也都被序列化。问题是，原本没打算序列化的侦听器也被同时序列化了。为分别判断 MyApp 和 ActionListener 是否可序列化，可使用一个嵌套类，如下面示例所示：
    import java.awt.*;
    import java.awt.event.*;
    import java.io.Serializable;

    class MyApp java.io.Serializable
    {
         BigObjectThatShouldNotBeSerializedWithAButton bigOne;
         Button aButton = new Button();

         static class MyActionListener implements ActionListener
         {
             public void actionPerformed(ActionEvent e)
             {
                 System.out.println("Hello There");
             }
         }

         MyApp()
         {
             aButton.addActionListener(new MyActionListener());
         }
    }

注：有关 AWT 和 Swing 所用绘制机制的更多信息，包括如何编写最高效的绘制代码的信息，请参阅 Painting in AWT and Swing。

有关焦点子系统的详情，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 部分，以及 Focus Specification 了解更多信息。

另请参见：
序列化表格

嵌套类摘要
protected class | Component.AccessibleAWTComponent 用来为可访问性提供默认支持的 Component 的内部类。
static class | Component.BaselineResizeBehavior 常见方式的枚举，指示组件的基线可以随大小的更改而更改。
protected class | Component.BltBufferStrategy 用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。
protected class | Component.FlipBufferStrategy 在组件上翻转缓冲区的内部类。
字段摘要
static float | BOTTOM_ALIGNMENT getAlignmentY 的易于使用的常量。
static float | CENTER_ALIGNMENT getAlignmentY 和 getAlignmentX 的易于使用的常量。
static float | LEFT_ALIGNMENT getAlignmentX 的易于使用的常量。
static float | RIGHT_ALIGNMENT getAlignmentX 的易于使用的常量。
static float | TOP_ALIGNMENT getAlignmentY() 的易于使用的常量。
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
protected Component()
构造一个新组件。
方法摘要
 boolean action(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
 void add(PopupMenu popup)
向组件添加指定的弹出菜单。
 void addComponentListener(ComponentListener l)
添加指定的组件侦听器，以接收发自此组件的组件事件。
 void addFocusListener(FocusListener l)
添加指定的焦点侦听器，以便当此组件获得输入焦点时能够接收发自此组件的焦点事件。
 void addHierarchyBoundsListener(HierarchyBoundsListener l)
添加指定的层次结构边界侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构边界事件。
 void addHierarchyListener(HierarchyListener l)
添加指定的层次结构侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构变化事件。
 void addInputMethodListener(InputMethodListener l)
添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。
 void addKeyListener(KeyListener l)
添加指定的按键侦听器，以接收发自此组件的按键事件。
 void addMouseListener(MouseListener l)
添加指定的鼠标侦听器，以接收发自此组件的鼠标事件。
 void addMouseMotionListener(MouseMotionListener l)
添加指定的鼠标移动侦听器，以接收发自此组件的鼠标移动事件。
 void addMouseWheelListener(MouseWheelListener l)
添加指定的鼠标滚轮侦听器，以接收发自此组件的鼠标滚轮事件。
 void addNotify()
通过将此 Component 连接到一个本机屏幕资源使其成为可显示的。
 void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。
 void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
向指定属性的侦听器列表添加一个 PropertyChangeListener。
 void applyComponentOrientation(ComponentOrientation orientation)
设置此组件及其包含的所有组件的 ComponentOrientation 属性。
 boolean areFocusTraversalKeysSet(int id)
返回是否为此 Component 显式定义了给定焦点遍历操作的焦点遍历键 Set。
 Rectangle bounds()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 int checkImage(Image image, ImageObserver observer)
返回指定图像屏幕表示的构造状态。
 int checkImage(Image image, int width, int height, ImageObserver observer)
返回指定图像屏幕表示的构造状态。
protected  AWTEvent coalesceEvents(AWTEvent existingEvent, AWTEvent newEvent)
将正发送的事件与现有事件组合在一起。
 boolean contains(int x, int y)
检查组件是否“包含”指定的点，其中 x 和 y 是相对于此组件的坐标系定义的。
 boolean contains(Point p)
检查组件是否“包含”指定的点，其中该点的 x 和 y 坐标是相对于此组件的坐标系定义的。
 Image createImage(ImageProducer producer)
根据指定的图像生成器创建一幅图像。
 Image createImage(int width, int height)
创建一幅用于双缓冲的、可在屏幕外绘制的图像。
 VolatileImage createVolatileImage(int width, int height)
创建一幅用于双缓冲的、可变的、可在屏幕外绘制的图像。
 VolatileImage createVolatileImage(int width, int height, ImageCapabilities caps)
创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。
 void deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
 void disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
protected  void disableEvents(long eventsToDisable)
禁用由传递给此组件的指定事件掩码参数所定义的事件。
 void dispatchEvent(AWTEvent e)
为组件或其子组件之一指派事件。
 void doLayout()
提示布局管理器布局此组件。
 void enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
protected  void enableEvents(long eventsToEnable)
启用由传递给此组件的指定事件掩码参数所定义的事件。
 void enableInputMethods(boolean enable)
启用或禁用此组件的输入方法支持。
protected  void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
支持报告布尔属性的绑定属性改变。
 void firePropertyChange(String propertyName, byte oldValue, byte newValue)
报告绑定属性的改变。
 void firePropertyChange(String propertyName, char oldValue, char newValue)
报告绑定属性的改变。
 void firePropertyChange(String propertyName, double oldValue, double newValue)
报告绑定属性的改变。
 void firePropertyChange(String propertyName, float oldValue, float newValue)
报告绑定属性的改变。
protected  void firePropertyChange(String propertyName, int oldValue, int newValue)
支持报告整数属性的绑定属性改变。
 void firePropertyChange(String propertyName, long oldValue, long newValue)
报告绑定属性的改变。
protected  void firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 Object 属性的绑定属性改变。
 void firePropertyChange(String propertyName, short oldValue, short newValue)
报告绑定属性的改变。
 AccessibleContext getAccessibleContext()
获取与此 Component 相关的 AccessibleContext。
 float getAlignmentX()
返回 x 轴的对齐方式。
 float getAlignmentY()
返回 y 轴的对齐方式。
 Color getBackground()
获取组件的背景色。
 int getBaseline(int width, int height)
返回基线。
 Component.BaselineResizeBehavior getBaselineResizeBehavior()
返回一个指示组件的基线如何随大小发生更改的枚举。
 Rectangle getBounds()
以 Rectangle 对象的形式获取组件的边界。
 Rectangle getBounds(Rectangle rv)
将组件的边界存储到“返回值”rv 中并返回 rv。
 ColorModel getColorModel()
获取用于在输出设备上显示组件的 ColorModel 实例。
 Component getComponentAt(int x, int y)
确定此组件或其直接子组件之一是否包含（x，y）位置，并且如果是，则返回包含该位置的组件。
 Component getComponentAt(Point p)
返回包含指定点的组件或子组件。
 ComponentListener[] getComponentListeners()
返回在此组件上所有已注册的组件侦听器的数组。
 ComponentOrientation getComponentOrientation()
检索将用于排序此组件内的元素或文本的语言敏感的方向。
 Cursor getCursor()
获取组件中的光标集合。
 DropTarget getDropTarget()
获取与此 Component 相关的 DropTarget。
 Container getFocusCycleRootAncestor()
返回作为此 Component 焦点遍历循环的焦点循环根的 Container。
 FocusListener[] getFocusListeners()
返回在此组件上所有已注册的焦点侦听器的数组。
 Set<AWTKeyStroke> getFocusTraversalKeys(int id)
返回此 Component 的给定遍历操作的焦点遍历键 Set。
 boolean getFocusTraversalKeysEnabled()
返回是否已为此 Component 启用了焦点遍历键。
 Font getFont()
获取组件的字体。
 FontMetrics getFontMetrics(Font font)
获取指定字体的字体规格。
 Color getForeground()
获取组件的前景色。
 Graphics getGraphics()
为组件创建一个图形上下文。
 GraphicsConfiguration getGraphicsConfiguration()
获取与此 Component 相关的 GraphicsConfiguration。
 int getHeight()
返回组件的当前高度。
 HierarchyBoundsListener[] getHierarchyBoundsListeners()
返回在此组件上所有已注册的层次结构边界侦听器的数组。
 HierarchyListener[] getHierarchyListeners()
返回在此组件上所有已注册的层次结构侦听器的数组。
 boolean getIgnoreRepaint()
 InputContext getInputContext()
获取此组件使用的输入上下文，用于处理在此组件中输入文本时与输入方法的通信。
 InputMethodListener[] getInputMethodListeners()
返回在此组件上所有已注册的输入方法侦听器的数组。
 InputMethodRequests getInputMethodRequests()
获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。
 KeyListener[] getKeyListeners()
返回在此组件上所有已注册的按键侦听器的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
 Locale getLocale()
获取组件的语言环境。
 Point getLocation()
获取组件的位置，形式是指定组件左上角的一个点。
 Point getLocation(Point rv)
将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。
 Point getLocationOnScreen()
获取组件的位置，形式是一个指定屏幕坐标空间中组件左上角的一个点。
 Dimension getMaximumSize()
获取组件的最大大小。
 Dimension getMinimumSize()
获取组件的最小大小。
 MouseListener[] getMouseListeners()
返回在此组件上所有已注册的鼠标侦听器的数组。
 MouseMotionListener[] getMouseMotionListeners()
返回在此组件上所有已注册的鼠标移动侦听器的数组。
 Point getMousePosition()
如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。
 MouseWheelListener[] getMouseWheelListeners()
返回在此组件上所有已注册的鼠标滚轮侦听器的数组。
 String getName()
获取组件的名称。
 Container getParent()
获取此组件的父级。
 java.awt.peer.ComponentPeer getPeer()
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体；由 boolean isDisplayable() 取代。
 Dimension getPreferredSize()
获取组件的首选大小。
 PropertyChangeListener[] getPropertyChangeListeners()
返回在此组件上所有已注册的属性更改侦听器的数组。
 PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的数组。
 Dimension getSize()
以 Dimension 对象的形式返回组件的大小。
 Dimension getSize(Dimension rv)
将组件的宽度/高度存储到“返回值”rv 中并返回 rv。
 Toolkit getToolkit()
获取此组件的工具包。
 Object getTreeLock()
获取此组件用于 AWT 组件树和布局操作的锁定对象（拥有线程同步监视器的对象）。
 int getWidth()
返回组件的当前宽度。
 int getX()
返回组件原点的当前 x 坐标。
 int getY()
返回组件原点的当前 y 坐标。
 boolean gotFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
 boolean handleEvent(Event evt)
已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
 boolean hasFocus()
如果此 Component 是焦点所有者，则返回 true。
 void hide()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 boolean imageUpdate(Image img, int infoflags, int x, int y, int w, int h)
图像已改变时重绘组件。
 boolean inside(int x, int y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
 void invalidate()
使此组件无效。
 boolean isBackgroundSet()
返回是否已为此组件显示地设置了背景色。
 boolean isCursorSet()
返回是否已为此组件显示地设置了光标。
 boolean isDisplayable()
确定此组件是否可以显示。
 boolean isDoubleBuffered()
如果将此组件绘制到一个随后复制到屏幕上的屏幕外图像（“缓冲区”），则返回 true。
 boolean isEnabled()
确定此组件是否已启用。
 boolean isFocusable()
返回此 Component 是否可以获得焦点。
 boolean isFocusCycleRoot(Container container)
返回指定的 Container 是否为此 Component 焦点遍历循环的焦点循环根。
 boolean isFocusOwner()
如果此 Component 是焦点所有者，则返回 true。
 boolean isFocusTraversable()
已过时。 从 1.4 开始，由 isFocusable() 取代。
 boolean isFontSet()
返回是否已为此组件显示地设置了字体。
 boolean isForegroundSet()
返回是否已为此组件显式地设置了前景色。
 boolean isLightweight()
轻量级组件没有本机工具包同位体。
 boolean isMaximumSizeSet()
如果已将最大大小设置为非 null 值，则返回 true，否则返回 false。
 boolean isMinimumSizeSet()
返回是否已用非 null 值调用了 setMinimumSize。
 boolean isOpaque()
如果组件是完全不透明的，则返回 true，默认返回 false。
 boolean isPreferredSizeSet()
如果已将首选大小设置为非 null 值，则返回 true，否则返回 false。
 boolean isShowing()
确定此组件是否在屏幕上显示。
 boolean isValid()
确定组件是否有效。
 boolean isVisible()
确定此组件在其父容器可见时是否应该可见。
 boolean keyDown(Event evt, int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
 boolean keyUp(Event evt, int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
 void layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
 void list()
将组件列表打印到标准系统输出流 System.out。
 void list(PrintStream out)
将组件列表打印到指定的输出流。
 void list(PrintStream out, int indent)
将列表从指定的缩排开始打印到指定的打印流。
 void list(PrintWriter out)
将列表打印到指定的打印编写器。
 void list(PrintWriter out, int indent)
将列表从指定的缩排开始打印到指定的打印编写器。
 Component locate(int x, int y)
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。
 Point location()
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。
 boolean lostFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
 Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 boolean mouseDown(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean mouseDrag(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
 boolean mouseEnter(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean mouseExit(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean mouseMove(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
 boolean mouseUp(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 void move(int x, int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
 void nextFocus()
已过时。 从 JDK version 1.1 开始，由 transferFocus() 取代。
 void paint(Graphics g)
绘制此组件。
 void paintAll(Graphics g)
绘制此组件及其所有子组件。
protected  String paramString()
返回此组件状态的字符串表示形式。
 boolean postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
 Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 boolean prepareImage(Image image, ImageObserver observer)
准备一幅在此组件上呈现的图像。
 boolean prepareImage(Image image, int width, int height, ImageObserver observer)
以指定的宽度和高度准备一幅在此组件上呈现的图像。
 void print(Graphics g)
打印此组件。
 void printAll(Graphics g)
打印此组件及其所有子组件。
protected  void processComponentEvent(ComponentEvent e)
处理组件上发生的组件事件，方法是将其指派到任意已注册的 ComponentListener 对象。
protected  void processEvent(AWTEvent e)
处理组件上发生的事件。
protected  void processFocusEvent(FocusEvent e)
处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。
protected  void processHierarchyBoundsEvent(HierarchyEvent e)
处理组件上发生的层次结构边界事件，方法是将其指派到任意已注册的 HierarchyBoundsListener 对象。
protected  void processHierarchyEvent(HierarchyEvent e)
处理组件上发生的层次结构事件，方法是将其指派到任意已注册的 HierarchyListener 对象。
protected  void processInputMethodEvent(InputMethodEvent e)
处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。
protected  void processKeyEvent(KeyEvent e)
处理组件上发生的按键事件，方法是将其指派到任意已注册的 KeyListener 对象。
protected  void processMouseEvent(MouseEvent e)
处理组件上发生的鼠标事件，方法是将其指派到任意已注册的 MouseListener 对象。
protected  void processMouseMotionEvent(MouseEvent e)
处理组件上发生的鼠标移动事件，方法是将其指派到任意已注册的 MouseMotionListener 事件。
protected  void processMouseWheelEvent(MouseWheelEvent e)
处理组件上发生的鼠标滚轮事件，方法是将其指派到任意已注册的 MouseWheelListener 对象。
 void remove(MenuComponent popup)
从组件移除指定的弹出菜单。
 void removeComponentListener(ComponentListener l)
移除指定的组件侦听器，以便它不再接收发自此组件的组件事件。
 void removeFocusListener(FocusListener l)
移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
 void removeHierarchyBoundsListener(HierarchyBoundsListener l)
移除指定的层次结构边界侦听器，以便它不再接收发自此组件的层次结构边界事件。
 void removeHierarchyListener(HierarchyListener l)
移除指定的层次结构侦听器，以便它不再接收发自此组件的层次结构变化事件。
 void removeInputMethodListener(InputMethodListener l)
移除指定的输入方法侦听器，以便它不再接收发自此组件的输入方法事件。
 void removeKeyListener(KeyListener l)
移除指定的按键侦听器，以便它不再接收发自此组件的按键事件。
 void removeMouseListener(MouseListener l)
移除指定的鼠标侦听器，以便它不再接收发自此组件的鼠标事件。
 void removeMouseMotionListener(MouseMotionListener l)
移除指定的鼠标移动侦听器，以便它不再接收发自此组件的鼠标移动事件。
 void removeMouseWheelListener(MouseWheelListener l)
移除指定的鼠标滚轮侦听器，以便它不再接收发自此组件的鼠标滚轮事件。
 void removeNotify()
通过销毁此 Component 的本机屏幕资源使其成为不可显示的。
 void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。
 void removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
从指定属性的侦听器列表中移除一个 PropertyChangeListener。
 void repaint()
重绘此组件。
 void repaint(int x, int y, int width, int height)
重绘组件的指定矩形区域。
 void repaint(long tm)
重绘组件。
 void repaint(long tm, int x, int y, int width, int height)
在 tm 毫秒内重绘组件的指定矩形区域。
 void requestFocus()
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。
protected  boolean requestFocus(boolean temporary)
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。
 boolean requestFocusInWindow()
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。
protected  boolean requestFocusInWindow(boolean temporary)
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。
 void reshape(int x, int y, int width, int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
 void resize(Dimension d)
已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
 void resize(int width, int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
 void setBackground(Color c)
设置组件的背景色。
 void setBounds(int x, int y, int width, int height)
移动组件并调整其大小。
 void setBounds(Rectangle r)
移动组件并调整其大小，使其符合新的有界矩形 r。
 void setComponentOrientation(ComponentOrientation o)
设置语言敏感的方向，用于排序此组件内的元素或文本。
 void setCursor(Cursor cursor)
为指定的光标设置光标图像。
 void setDropTarget(DropTarget dt)
将组件与 DropTarget 相关联。
 void setEnabled(boolean b)
根据参数 b 的值启用或禁用此组件。
 void setFocusable(boolean focusable)
将此 Component 的焦点状态设置为指定值。
 void setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
为此 Component 的给定遍历操作设置焦点遍历键。
 void setFocusTraversalKeysEnabled(boolean focusTraversalKeysEnabled)
设置是否为此 Component 启用焦点遍历键。
 void setFont(Font f)
设置组件的字体。
 void setForeground(Color c)
设置组件的前景色。
 void setIgnoreRepaint(boolean ignoreRepaint)
设置是否应该忽略从操作系统接受的绘制消息。
 void setLocale(Locale l)
设置组件的语言环境。
 void setLocation(int x, int y)
将组件移到新位置。
 void setLocation(Point p)
将组件移到新位置。
 void setMaximumSize(Dimension maximumSize)
将组件的最大大小设置为常量值。
 void setMinimumSize(Dimension minimumSize)
将组件的最小大小设置为常量值。
 void setName(String name)
将组件的名称设置为指定的字符串。
 void setPreferredSize(Dimension preferredSize)
将组件的首选大小设置为常量值。
 void setSize(Dimension d)
调整组件的大小，使其宽度为 d.width，高度为 d.height。
 void setSize(int width, int height)
调整组件的大小，使其宽度为 width，高度为 height。
 void setVisible(boolean b)
根据参数 b 的值显示或隐藏此组件。
 void show()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 void show(boolean b)
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 Dimension size()
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。
 String toString()
返回此组件及其值的字符串表示形式。
 void transferFocus()
将焦点转移到下一个组件，就好像此 Component 曾是焦点所有者。
 void transferFocusBackward()
将焦点转移到前一个组件，就好像此 Component 曾是焦点所有者。
 void transferFocusUpCycle()
将焦点向上转移一个焦点遍历循环。
 void update(Graphics g)
更新组件。
 void validate()
确保组件具有有效的布局。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

TOP_ALIGNMENT

public static final float TOP_ALIGNMENT
getAlignmentY() 的易于使用的常量。指定组件顶部对齐方式。

另请参见：
getAlignmentY(), 常量字段值

CENTER_ALIGNMENT

public static final float CENTER_ALIGNMENT
getAlignmentY 和 getAlignmentX 的易于使用的常量。指定组件居中对齐方式。

另请参见：
getAlignmentX(), getAlignmentY(), 常量字段值

BOTTOM_ALIGNMENT

public static final float BOTTOM_ALIGNMENT
getAlignmentY 的易于使用的常量。指定组件底部对齐方式。

另请参见：
getAlignmentY(), 常量字段值

LEFT_ALIGNMENT

public static final float LEFT_ALIGNMENT
getAlignmentX 的易于使用的常量。指定组件左对齐方式。

另请参见：
getAlignmentX(), 常量字段值

RIGHT_ALIGNMENT

public static final float RIGHT_ALIGNMENT
getAlignmentX 的易于使用的常量。指定组件右对齐方式。

另请参见：
getAlignmentX(), 常量字段值
构造方法详细信息

Component

protected Component()
构造一个新组件。可以直接扩展 Component 类，以便创建不利用本机不透明窗口的轻量级组件。轻量级组件必须由组件树中较高处的本机容器所承载（例如由 Frame 对象承载）。

方法详细信息

getName

public String getName()
获取组件的名称。

返回：
组件的名称
从以下版本开始：
JDK1.1
另请参见：
setName(java.lang.String)

setName

public void setName(String name)
将组件的名称设置为指定的字符串。

参数：
name - 要成为组件名称的字符串。
从以下版本开始：
JDK1.1
另请参见：
getName()

getParent

public Container getParent()
获取此组件的父级。

返回：
此组件的父级容器
从以下版本开始：
JDK1.0

getPeer

@Deprecated
public java.awt.peer.ComponentPeer getPeer()
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体；由 boolean isDisplayable() 取代。

setDropTarget

public void setDropTarget(DropTarget dt)
将组件与 DropTarget 相关联。仅在已启用 Component 时才接收放置。

参数：
dt - DropTarget
另请参见：
isEnabled()

getDropTarget

public DropTarget getDropTarget()
获取与此 Component 相关的 DropTarget。

getGraphicsConfiguration

public GraphicsConfiguration getGraphicsConfiguration()
获取与此 Component 相关的 GraphicsConfiguration。如果尚未给 Component 分配指定的 GraphicsConfiguration，则返回该 Component 对象顶层容器的 GraphicsConfiguration。如果已经创建了 Component 但尚未添加到 Container 中，则此方法返回 null。

返回：
此 Component 使用的 GraphicsConfiguration，或者返回 null
从以下版本开始：
1.3

getTreeLock

public final Object getTreeLock()
获取此组件用于 AWT 组件树和布局操作的锁定对象（拥有线程同步监视器的对象）。

返回：
此组件的锁定对象

getToolkit

public Toolkit getToolkit()
获取此组件的工具包。注意，包含组件的框架控制该组件使用哪个工具包。因此，如果组件从一个框架移到另一个框架中，那么它所使用的工具包可能改变。

返回：
此组件的工具包
从以下版本开始：
JDK1.0

isValid

public boolean isValid()
确定组件是否有效。当组件在其父级容器内正确确定了大小和位置，并且其所有子组件也是有效的，则该组件是有效的。为了确定同位体的大小要求，组件首次显示在屏幕上时是无效的。 完全实现父级容器时，其所有组件将是有效的。

返回：
如果组件有效，则返回 true；否则返回 false
从以下版本开始：
JDK1.0
另请参见：
validate(), invalidate()

isDisplayable

public boolean isDisplayable()
确定此组件是否可以显示。当组件连接到一个本机屏幕资源时是可以显示的。

将组件添加到一个可显示的包含层次结构时，或者其包含层次结构变成可显示时，该组件才成为可显示的组件。当包含层次结构的祖先窗口被打包或变为可见时，它才成为可显示的。

从可显示的包含层次结构中移除某个组件，或者该组件的包含层次结构变成不可显示时，该组件就成为不可显示的组件。当包含层次结构的祖先窗口被移除时，它才变成不可显示的。

返回：
如果组件是可显示的，则返回 true；否则返回 false
从以下版本开始：
1.2
另请参见：
Container.add(Component),
Window.pack(),
Window.show(),
Container.remove(Component),
Window.dispose()

isVisible

public boolean isVisible()
确定此组件在其父容器可见时是否应该可见。组件初始是可见的，诸如 Frame 对象等顶层组件除外。

返回：
如果组件是可见的，则返回 true；否则返回 false
从以下版本开始：
JDK1.0
另请参见：
setVisible(boolean)

getMousePosition

public Point getMousePosition()
                       throws HeadlessException
如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。如果屏幕上未显示 Component，那么即使鼠标指针位于将显示 Component 的区域之上，此方法也只是返回 null。如果 Component 被其他 Component 或本机窗口所部分或完全遮掩，则仅在鼠标指针位于 Component 未被遮掩的部分之上时，此方法才返回非 null 值。

对于 Container，如果鼠标位于 Container 本身之上或位于其后代之上时，则此方法返回非 null 值。如果需要将子容器排除在外，请使用 Container.getMousePosition(boolean)。

有时鼠标的准确坐标并不重要，唯一重要的是指定的 Component 是否位于鼠标指针下。如果此方法的返回值为 null，则鼠标指针不位于 Component 的上边。

返回：
鼠标相对与此 Component 的坐标，或者返回 null。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.5
另请参见：
isShowing(), Container.getMousePosition(boolean)

isShowing

public boolean isShowing()
确定此组件是否在屏幕上显示。这意味着组件必须是可见的，并且必须位于一个可见并且正在显示的容器中。

注：有时无法检测用户是否可以实际看见 Component。这可能发生在以下情况时：

  • 该组件已被添加到一个可见的 ScrollPane 中，但 Component 目前不在滚动窗格的视区中。
  • 该 Component 被另一个 Component 或 Container 遮掩。

返回：
如果正在显示组件，则返回 true；否则返回 false
从以下版本开始：
JDK1.0
另请参见：
setVisible(boolean)

isEnabled

public boolean isEnabled()
确定此组件是否已启用。已启用的组件可以响应用户输入并生成事件。默认情况下，组件最初是启用的。调用组件的 setEnabled 方法可以启用或禁用组件。

返回：
如果组件已启用，则返回 true；否则返回 false
从以下版本开始：
JDK1.0
另请参见：
setEnabled(boolean)

setEnabled

public void setEnabled(boolean b)
根据参数 b 的值启用或禁用此组件。已启用的组件可以响应用户输入并生成事件。默认情况下，组件最初是启用的。

注：禁用轻量级组件不会阻止其接收 MouseEvents。

注：禁用重量级容器可以阻止此容器中的所有组件接收任何输入事件。但是禁用重量级容器只影响此容器。

参数：
b - 如果为 true，则启用此组件；否则禁用此组件
从以下版本开始：
JDK1.1
另请参见：
isEnabled(), isLightweight()

enable

@Deprecated
public void enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。

enable

@Deprecated
public void enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。

disable

@Deprecated
public void disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。

isDoubleBuffered

public boolean isDoubleBuffered()
如果将此组件绘制到一个随后复制到屏幕上的屏幕外图像（“缓冲区”），则返回 true。支持双缓冲的组件子类应该重写此方法，以便在启用双缓冲时返回 true。

返回：
默认返回 false

enableInputMethods

public void enableInputMethods(boolean enable)
启用或禁用此组件的输入方法支持。如果启用输入方法支持并且组件也处理按键事件，则将传入的事件提供给当前的输入方法，并且如果输入方法没有使用它们，则仅由组件处理或指派给其侦听器。默认情况下启用输入方法支持。

参数：
enable - true 表示启用，false 表示禁用
从以下版本开始：
1.2
另请参见：
processKeyEvent(java.awt.event.KeyEvent)

setVisible

public void setVisible(boolean b)
根据参数 b 的值显示或隐藏此组件。

参数：
b - 如果为 true，则显示此组件；否则隐藏此组件
从以下版本开始：
JDK1.1
另请参见：
isVisible()

show

@Deprecated
public void show()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。

show

@Deprecated
public void show(boolean b)
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。

hide

@Deprecated
public void hide()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。

getForeground

public Color getForeground()
获取组件的前景色。

返回：
组件的前景色；如果此组件没有前景色，则返回其父级的前景色
从以下版本开始：
JDK1.0
另请参见：
setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
设置组件的前景色。

参数：
c - 要成为此组件前景色的颜色；如果此参数为 null，则此组件继承其父级的前景色
从以下版本开始：
JDK1.0
另请参见：
getForeground()

isForegroundSet

public boolean isForegroundSet()
返回是否已为此组件显式地设置了前景色。如果此方法返回 false，则此组件继承了其祖先的前景色。

返回：
如果已为此组件显示地设置了前景色，则返回 true；否则返回 false。
从以下版本开始：
1.4

getBackground

public Color getBackground()
获取组件的背景色。

返回：
组件的背景色；如果此组件没有背景色，则返回其父级的背景色
从以下版本开始：
JDK1.0
另请参见：
setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置组件的背景色。

背景色对每个组件的影响各不相同，并且部分受背景色影响的组件在不同的操作系统之间可能有所不同。

参数：
c - 要成为此组件背景色的颜色；如果此参数为 null，则此组件继承其父级的背景色
从以下版本开始：
JDK1.0
另请参见：
getBackground()

isBackgroundSet

public boolean isBackgroundSet()
返回是否已为此组件显示地设置了背景色。如果此方法返回 false，则此组件继承了其祖先的背景色。

返回：
如果已为此组件显示地设置了背景色，则返回 true；否则返回 false。
从以下版本开始：
1.4

getFont

public Font getFont()
获取组件的字体。

指定者：
接口 MenuContainer 中的 getFont
返回：
组件的字体；如果此组件未设置字体，则返回其父级的字体
从以下版本开始：
JDK1.0
另请参见：
setFont(java.awt.Font)

setFont

public void setFont(Font f)
设置组件的字体。

参数：
f - 要成为此组件字体的字体；如果此参数为 null，则此组件继承其父级的字体
从以下版本开始：
JDK1.0
另请参见：
getFont()

isFontSet

public boolean isFontSet()
返回是否已为此组件显示地设置了字体。如果此方法返回 false，则此组件继承了其祖先的字体。

返回：
如果已为此组件显示地设置了字体，则返回 true；否则返回 false。
从以下版本开始：
1.4

getLocale

public Locale getLocale()
获取组件的语言环境。

返回：
组件的语言环境；如果此组件没有语言环境，则返回其父级的语言环境
抛出：
IllegalComponentStateException - 如果 Component 没有其自己的语言环境，并且尚未添加到包含层次结构中（如果添加到包含层次结构中就可以从其包含父级确定语言环境）
从以下版本开始：
JDK1.1
另请参见：
setLocale(java.util.Locale)

setLocale

public void setLocale(Locale l)
设置组件的语言环境。这是一个绑定 (bound) 属性。

参数：
l - 要成为此组件语言环境的语言环境
从以下版本开始：
JDK1.1
另请参见：
getLocale()

getColorModel

public ColorModel getColorModel()
获取用于在输出设备上显示组件的 ColorModel 实例。

返回：
组件使用的颜色模型
从以下版本开始：
JDK1.0
另请参见：
ColorModel, ComponentPeer.getColorModel(), Toolkit.getColorModel()

getLocation

public Point getLocation()
获取组件的位置，形式是指定组件左上角的一个点。该位置是相对于父级坐标空间的。

由于本机事件处理的异步特性，所以此方法可能返回过时的值（例如，在快速连续调用 setLocation() 后）。为此，推荐获得组件位置的方法是在 java.awt.event.ComponentListener.componentMoved() 内，在操作系统结束组件移动后调用它。

返回：
一个 Point 实例，表示在组件父级坐标空间中组件边界的左上角
从以下版本开始：
JDK1.1
另请参见：
setLocation(int, int), getLocationOnScreen()

getLocationOnScreen

public Point getLocationOnScreen()
获取组件的位置，形式是一个指定屏幕坐标空间中组件左上角的一个点。

返回：
一个 Point 实例，表示在屏幕坐标空间中组件边界的左上角
抛出：
IllegalComponentStateException - 如果屏幕上未显示该组件
另请参见：
setLocation(int, int), getLocation()

location

@Deprecated
public Point location()
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。

setLocation

public void setLocation(int x,
                        int y)
将组件移到新位置。通过此组件父级坐标空间中的 x 和 y 参数来指定新位置的左上角。

参数：
x - 父级坐标空间中新位置左上角的 x 坐标
y - 父级坐标空间中新位置左上角的 y 坐标
从以下版本开始：
JDK1.1
另请参见：
getLocation(), setBounds(int, int, int, int)

move

@Deprecated
public void move(int x,
                            int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。

setLocation

public void setLocation(Point p)
将组件移到新位置。通过点 p 来指定新位置的左上角。在父级坐标空间中给出点 p。

参数：
p - 定义新位置左上角的点，在此组件的父级坐标空间中给出
从以下版本开始：
JDK1.1
另请参见：
getLocation(), setBounds(int, int, int, int)

getSize

public Dimension getSize()
以 Dimension 对象的形式返回组件的大小。Dimension 对象的 height 字段包含此组件的高度，而 Dimension 对象的 width 字段则包含此组件的宽度。

返回：
表示组件大小的 Dimension 对象
从以下版本开始：
JDK1.1
另请参见：
setSize(int, int)

size

@Deprecated
public Dimension size()
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。

setSize

public void setSize(int width,
                    int height)
调整组件的大小，使其宽度为 width，高度为 height。

参数：
width - 组件的新宽度，单位是像素
height - 组件的新高度，单位是像素
从以下版本开始：
JDK1.1
另请参见：
getSize(), setBounds(int, int, int, int)

resize

@Deprecated
public void resize(int width,
                              int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。

setSize

public void setSize(Dimension d)
调整组件的大小，使其宽度为 d.width，高度为 d.height。

参数：
d - 指定组件新大小的尺寸
从以下版本开始：
JDK1.1
另请参见：
setSize(int, int), setBounds(int, int, int, int)

resize

@Deprecated
public void resize(Dimension d)
已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。

getBounds

public Rectangle getBounds()
以 Rectangle 对象的形式获取组件的边界。边界指定此组件的宽度、高度和相对于其父级的位置。

返回：
表示组件边界的矩形
另请参见：
setBounds(int, int, int, int),
getLocation(),
getSize()

bounds

@Deprecated
public Rectangle bounds()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。

setBounds

public void setBounds(int x,
                      int y,
                      int width,
                      int height)
移动组件并调整其大小。由 x 和 y 指定左上角的新位置，由 width 和 height 指定新的大小。

参数：
x - 组件的新 x 坐标
y - 组件的新 y 坐标
width - 组件的新 width
height - 组件的新 height
从以下版本开始：
JDK1.1
另请参见：
getBounds(), setLocation(int, int), setLocation(Point), setSize(int, int), setSize(Dimension)

reshape

@Deprecated
public void reshape(int x,
                               int y,
                               int width,
                               int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。

setBounds

public void setBounds(Rectangle r)
移动组件并调整其大小，使其符合新的有界矩形 r。由 r.x 和 r.y 指定组件的新位置，由 r.width 和 r.height 指定组件的新大小

参数：
r - 此组件的新的有界矩形
从以下版本开始：
JDK1.1
另请参见：
getBounds(), setLocation(int, int), setLocation(Point), setSize(int, int), setSize(Dimension)

getX

public int getX()
返回组件原点的当前 x 坐标。此方法优于 component.getBounds().x 或 component.getLocation().x 方法，因为它不会导致任何的堆分配。

返回：
组件原点的当前 x 坐标
从以下版本开始：
1.2

getY

public int getY()
返回组件原点的当前 y 坐标。此方法优于 component.getBounds().y 或 component.getLocation().y 方法，因为它不会导致任何的堆分配。

返回：
组件原点的当前 y 坐标
从以下版本开始：
1.2

getWidth

public int getWidth()
返回组件的当前宽度。此方法优于 component.getBounds().width 或 component.getLocation().width 方法，因为它不会导致任何的堆分配。

返回：
组件的当前宽度
从以下版本开始：
1.2

getHeight

public int getHeight()
返回组件的当前高度。此方法优于 component.getBounds().height 或 component.getSize().height 方法，因为它不会导致任何的堆分配。

返回：
组件的当前高度
从以下版本开始：
1.2

getBounds

public Rectangle getBounds(Rectangle rv)
将组件的边界存储到“返回值”rv 中并返回 rv。如果 rv 为 null，则分配一个新的 Rectangle。如果调用者想要避免在堆上分配一个新的 Rectangle 对象，则此版本的 getBounds 是很有用的。

参数：
rv - 返回值，被修改为组件的边界
返回：
rv

getSize

public Dimension getSize(Dimension rv)
将组件的宽度/高度存储到“返回值”rv 中并返回 rv。如果 rv 为 null，则分配一个新的 Dimension 对象。如果调用者想要避免在堆上分配一个新的 Dimension 对象，则此版本的 getSize 是很有用的。

参数：
rv - 返回值，被修改为组件的大小
返回：
rv

getLocation

public Point getLocation(Point rv)
将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。如果 rv 为 null，则分配一个新的 Point。如果调用者想要避免在堆上分配一个新的 Point 对象，则此版本的 getLocation 是很有用的。

参数：
rv - 返回值，被修改为组件的位置
返回：
rv

isOpaque

public boolean isOpaque()
如果组件是完全不透明的，则返回 true，默认返回 false。

不透明组件将每个像素绘制在其矩形区域内。透明的组件则仅绘制其某些像素，允许其下面的像素“透视出来”。因此，没有完全绘制其像素的组件则提供了一定程度的透明度。只有轻量级组件可以是透明的。

保证总是完全绘制其内容的子类应该重写此方法并返回 true。所有“重量级”AWT 组件都是不透明的。

返回：
如果组件是完全不透明的，则返回 true
从以下版本开始：
1.2
另请参见：
isLightweight()

isLightweight

public boolean isLightweight()
轻量级组件没有本机工具包同位体。除了在此包中定义的、像 Button 或 Scrollbar 那些组件以外，Component 和 Container 的子类都是轻量级组件。所有 Swing 组件是轻量级组件。

如果组件是不可显示的，那么由于无法确定不可显示的组件是轻量级还是重量级的，所以此方法总是返回 false。

返回：
如果组件有一个轻量级同位体，则返回 true；如果有一个本机同位体或没有同位体，则返回 false
从以下版本开始：
1.2
另请参见：
isDisplayable()

setPreferredSize

public void setPreferredSize(Dimension preferredSize)
将组件的首选大小设置为常量值。对 getPreferredSize 的后续调用总是返回此值。将首选大小设置为 null 可还原默认的行为。

参数：
preferredSize - 新的首选大小，或者为 null
从以下版本开始：
1.5
另请参见：
getPreferredSize(), isPreferredSizeSet()

isPreferredSizeSet

public boolean isPreferredSizeSet()
如果已将首选大小设置为非 null 值，则返回 true，否则返回 false。

返回：
如果已经用非 null 值调用了 setPreferredSize，则返回 true。
从以下版本开始：
1.5

getPreferredSize

public Dimension getPreferredSize()
获取组件的首选大小。

返回：
一个表示组件首选大小的 dimension 对象
另请参见：
getMinimumSize(), LayoutManager

preferredSize

@Deprecated
public Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。

setMinimumSize

public void setMinimumSize(Dimension minimumSize)
将组件的最小大小设置为常量值。对 getMinimumSize 的后续调用总是返回此值。将最小大小设置为 null 可还原默认的行为。

参数：
minimumSize - 组件新的最小大小
从以下版本开始：
1.5
另请参见：
getMinimumSize(), isMinimumSizeSet()

isMinimumSizeSet

public boolean isMinimumSizeSet()
返回是否已用非 null 值调用了 setMinimumSize。

返回：
如果已经用非 null 值调用了 setMinimumSize，则返回 true。
从以下版本开始：
1.5

getMinimumSize

public Dimension getMinimumSize()
获取组件的最小大小。

返回：
一个表示组件最小大小的 dimension 对象
另请参见：
getPreferredSize(), LayoutManager

minimumSize

@Deprecated
public Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。

setMaximumSize

public void setMaximumSize(Dimension maximumSize)
将组件的最大大小设置为常量值。对 getMaximumSize 的后续调用总是返回此值。将最大大小设置为 null 可还原默认的行为。

参数：
maximumSize - 一个包含所需最大允许大小的 Dimension
从以下版本开始：
1.5
另请参见：
getMaximumSize(), isMaximumSizeSet()

isMaximumSizeSet

public boolean isMaximumSizeSet()
如果已将最大大小设置为非 null 值，则返回 true，否则返回 false。

返回：
如果 maximumSize 是非 null 值，则返回 true，否则返回 false
从以下版本开始：
1.5

getMaximumSize

public Dimension getMaximumSize()
获取组件的最大大小。

返回：
一个表示组件最大大小的 dimension 对象
另请参见：
getMinimumSize(), getPreferredSize(), LayoutManager

getAlignmentX

public float getAlignmentX()
返回 x 轴的对齐方式。指定组件相对于其他组件的对齐方式。值应该是 0 到 1 之间的数，其中 0 代表与原点对齐，1 代表距离原点最远处对齐，0.5 代表居中等。

getAlignmentY

public float getAlignmentY()
返回 y 轴的对齐方式。指定组件相对于其他组件的对齐方式。值应该是 0 到 1 之间的数，其中 0 代表与原点对齐，1 代表距离原点最远处对齐，0.5 代表居中等。

getBaseline

public int getBaseline(int width,
                       int height)
返回基线。基线是从组件的顶部测量的。此方法主要用于 LayoutManager，以便沿组件的基线对齐组件。返回值小于 0 表示此组件没有合理的基线，LayoutManager 不应该根据该组件的基线来对齐此组件。

默认实现返回 -1。支持基线的子类应该适当重写。如果返回值 >= 0，则该组件有一个对于 >= 最小大小的任何大小有效的基线，并且可以使用 getBaselineResizeBehavior 确定基线如何随大小发生更改。

参数：
width - 适合基线的宽度
height - 适合基线的高度
返回：
基线，如果基线 < 0，则表示没有合理的基线
抛出：
IllegalArgumentException - 如果 width 或 height < 0
从以下版本开始：
1.6
另请参见：
getBaselineResizeBehavior(), FontMetrics

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior()
返回一个指示组件的基线如何随大小发生更改的枚举。此方法主要适用于布局管理器和 GUI 生成器。

默认实现返回 BaselineResizeBehavior.OTHER。拥有基线的子类应该适当重写。子类永远不应该返回 null；如果无法计算基线，则返回 BaselineResizeBehavior.OTHER。调用者应该首先查询使用 getBaseline 的基线，如果返回值 >= 0，则使用此方法。如果此方法返回一个不同于 BaselineResizeBehavior.OTHER 的值，即使 getBaseline 返回一个小于 0 的值，也是可接受的。

返回：
一个指示基线如何随组件大小的更改发生变化的枚举
从以下版本开始：
1.6
另请参见：
getBaseline(int, int)

doLayout

public void doLayout()
提示布局管理器布局此组件。通常在验证组件（更明确地说是容器）时调用。

另请参见：
validate(), LayoutManager

layout

@Deprecated
public void layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。

validate

public void validate()
确保组件具有有效的布局。此类主要适用于在 Container 实例上进行操作。

从以下版本开始：
JDK1.0
另请参见：
invalidate(), doLayout(), LayoutManager, Container.validate()

invalidate

public void invalidate()
使此组件无效。此组件及其上所有父组件都标记为需要进行布局。此方法经常被调用，所以需要其快速执行。

从以下版本开始：
JDK1.0
另请参见：
validate(), doLayout(), LayoutManager

getGraphics

public Graphics getGraphics()
为组件创建一个图形上下文。如果组件当前是不可显示的，则此方法返回 null。

返回：
组件的图形上下文，如果其没有，则返回 null
从以下版本开始：
JDK1.0
另请参见：
paint(java.awt.Graphics)

getFontMetrics

public FontMetrics getFontMetrics(Font font)
获取指定字体的字体规格。警告：因为 Font 规格受 FontRenderContext 影响，并且此方法不返回任何字体规格，所以可以只返回适用于默认呈现上下文的规格，该规格可能与呈现在 Component 上时使用的规格不匹配（如果使用 Graphics2D 功能）。相反，可以在呈现时通过调用 Graphics.getFontMetrics() 或 Font 类上的文本测量 API 获得规格。

参数：
font - 要获得其字体规格的字体
返回：
font 的字体规格
从以下版本开始：
JDK1.0
另请参见：
getFont(),
getPeer(),
ComponentPeer.getFontMetrics(Font),
Toolkit.getFontMetrics(Font)

setCursor

public void setCursor(Cursor cursor)
为指定的光标设置光标图像。当此组件的 contains 方法为当前的光标位置返回 ture，并且此组件是可见的、可显示的并且已启用的，则显示此光标图像。设置 Container 的光标会导致在该容器的所有子组件内显示该光标，那些具有非 null 的光标除外。

如果 Java 平台实现和/或本机系统不支持更改鼠标光标形状，则该方法可能不会产生任何视觉效果。

参数：
cursor - Cursor 类定义的常量之一；如果此参数为 null，则此组件继承其父级的光标
从以下版本开始：
JDK1.1
另请参见：
isEnabled(),
isShowing(),
getCursor(),
contains(int, int),
Toolkit.createCustomCursor(java.awt.Image, java.awt.Point, java.lang.String),
Cursor

getCursor

public Cursor getCursor()
获取组件中的光标集合。如果组件没有光标集合，则返回其父级的光标。如果整个层次结构中都没有设置光标，则返回 Cursor.DEFAULT_CURSOR。

从以下版本开始：
JDK1.1
另请参见：
setCursor(java.awt.Cursor)

isCursorSet

public boolean isCursorSet()
返回是否已为此组件显示地设置了光标。如果此方法返回 false，则此组件继承了其祖先的光标。

返回：
如果已为此组件显示地设置了光标，则返回 true；否则返回 false。
从以下版本开始：
1.4

paint

public void paint(Graphics g)
绘制此组件。

应该绘制组件的内容时调用此方法；例如首次显示组件或者组件已损坏并需要修复时。Graphics 参数中的剪贴区矩形设置为需要绘制的区域。重写此方法的 Component 子类不需要调用 super.paint(g)。

出于性能的考虑，首次显示宽度或高度为 0 的 Component 时认为它不需要进行绘制，并且也不需要修复。

注：有关 AWT 和 Swing 所用绘制机制的更多信息，包括如何编写最高效的绘制代码的信息，请参阅 Painting in AWT and Swing。

参数：
g - 用于绘制的图像上下文
从以下版本开始：
JDK1.0
另请参见：
update(java.awt.Graphics)

update

public void update(Graphics g)
更新组件。

如果此组件不是轻量级组件，则为了响应对 repaint 的调用，AWT 调用 update 方法。可以假定未清除背景。

Component 的 update 方法调用此组件的 paint 方法来重绘此组件。为响应对 repaint 的调用而需要其他工作的子类通常重写此方法。重写此方法的 Component 子类应该调用 super.update(g)，或者直接从其 update 方法中调用 paint(g)。

图形上下文的原点，即它的（0，0）坐标点是此组件的左上角。图形上下文的剪贴区域是此组件的边界矩形。

注：有关 AWT 和 Swing 所用绘制机制的更多信息，包括如何编写最高效的绘制代码的信息，请参阅 Painting in AWT and Swing。

参数：
g - 用于更新的指定上下文
从以下版本开始：
JDK1.0
另请参见：
paint(java.awt.Graphics), repaint()

paintAll

public void paintAll(Graphics g)
绘制此组件及其所有子组件。

图形上下文的原点，即它的（0，0）坐标点是此组件的左上角。图形上下文的剪贴区域是此组件的边界矩形。

参数：
g - 用于绘制的图形上下文
从以下版本开始：
JDK1.0
另请参见：
paint(java.awt.Graphics)

repaint

public void repaint()
重绘此组件。

如果此组件是轻量级组件，则此方法会尽快调用此组件的 paint 方法。否则此方法会尽快调用此组件的 update 方法。

注：有关 AWT 和 Swing 所用绘制机制的更多信息，包括如何编写最高效的绘制代码的信息，请参阅 Painting in AWT and Swing。

从以下版本开始：
JDK1.0
另请参见：
update(Graphics)

repaint

public void repaint(long tm)
重绘组件。如果此组件是轻量级组件，则会导致在 tm 毫秒内调用 paint。

注：有关 AWT 和 Swing 所用绘制机制的更多信息，包括如何编写最高效的绘制代码的信息，请参阅 Painting in AWT and Swing。

参数：
tm - 更新前等待的最长时间（以毫秒为单位）
从以下版本开始：
JDK1.0
另请参见：
paint(java.awt.Graphics), update(Graphics)

repaint

public void repaint(int x,
                    int y,
                    int width,
                    int height)
重绘组件的指定矩形区域。

如果此组件是轻量级组件，则此方法会尽快调用此组件的 paint 方法。否则此方法会尽快调用此组件的 update 方法。

注：有关 AWT 和 Swing 所用绘制机制的更多信息，包括如何编写最高效的绘制代码的信息，请参阅 Painting in AWT and Swing。

参数：
x - x 坐标
y - y 坐标
width - 宽度
height - 高度
从以下版本开始：
JDK1.0
另请参见：
update(Graphics)

repaint

public void repaint(long tm,
                    int x,
                    int y,
                    int width,
                    int height)
在 tm 毫秒内重绘组件的指定矩形区域。

如果此组件是轻量级组件，则此方法调用此组件的 paint 方法。否则此方法调用此组件的 update 方法。

注：有关 AWT 和 Swing 所用绘制机制的更多信息，包括如何编写最高效的绘制代码的信息，请参阅 Painting in AWT and Swing。

参数：
tm - 更新前等待的最长时间（以毫秒为单位）
x - x 坐标
y - y 坐标
width - 宽度
height - 高度
从以下版本开始：
JDK1.0
另请参见：
update(Graphics)

print

public void print(Graphics g)
打印此组件。对于打印前必须进行特殊处理或打印内容不同于绘制内容的组件，应用程序应该重写此方法。

此方法的默认实现调用 paint 方法。

图形上下文的原点，即它的（0，0）坐标点是此组件的左上角。图形上下文的剪贴区域是此组件的边界矩形。

参数：
g - 用于绘制的图形上下文
从以下版本开始：
JDK1.0
另请参见：
paint(Graphics)

printAll

public void printAll(Graphics g)
打印此组件及其所有子组件。

图形上下文的原点，即它的（0，0）坐标点是此组件的左上角。图形上下文的剪贴区域是此组件的边界矩形。

参数：
g - 用于打印的图形上下文
从以下版本开始：
JDK1.0
另请参见：
print(Graphics)

imageUpdate

public boolean imageUpdate(Image img,
                           int infoflags,
                           int x,
                           int y,
                           int w,
                           int h)
图像已改变时重绘组件。当有关图像的更多信息可用时调用 ImageObserver 的 imageUpdate 方法，该图像是以前使用诸如 Graphics 的 drawImage 方法等此类异步例程请求的。有关此方法及其参数的更多信息，请参阅 imageUpdate 的定义。

随着有更多的可用图像位，Component 的 imageUpdate 方法在组件上逐渐绘制图像。

如果系统属性 awt.image.incrementaldraw 丢失或其值为 true，则逐渐绘制图像。如果该系统属性为其他值，则在完全加载图像后才绘制它。

另外，如果是逐渐绘制图像，则将系统属性 awt.image.redrawrate 的值解释为一个整数，得到一个最快的重绘速率，单位是毫秒。如果该系统属性丢失或无法解释为一个整数，则重绘速率是每 100ms 一次。

x、y、width 和 height 参数的解释取决于 infoflags 参数值。

指定者：
接口 ImageObserver 中的 imageUpdate
参数：
img - 正观察的图像
infoflags - 有关更多信息，请参阅 imageUpdate
x - x 坐标
y - y 坐标
w - 宽度
h - 高度
返回：
如果 infoflags 表明已完全加载了图像，则返回 false；否则返回 true。
从以下版本开始：
JDK1.0
另请参见：
ImageObserver, Graphics.drawImage(Image, int, int, Color, java.awt.image.ImageObserver), Graphics.drawImage(Image, int, int, java.awt.image.ImageObserver), Graphics.drawImage(Image, int, int, int, int, Color, java.awt.image.ImageObserver), Graphics.drawImage(Image, int, int, int, int, java.awt.image.ImageObserver), ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

createImage

public Image createImage(ImageProducer producer)
根据指定的图像生成器创建一幅图像。

参数：
producer - 图像生成器
返回：
生成的图像
从以下版本开始：
JDK1.0

createImage

public Image createImage(int width,
                         int height)
创建一幅用于双缓冲的、可在屏幕外绘制的图像。

参数：
width - 指定的宽度
height - 指定的高度
返回：
一幅屏幕外可绘制的图像，可用于双缓冲。如果组件是不可显示的，则返回值可能为 null。如果 GraphicsEnvironment.isHeadless() 返回 true，则始终发生这种情况。
从以下版本开始：
JDK1.0
另请参见：
isDisplayable(), GraphicsEnvironment.isHeadless()

createVolatileImage

public VolatileImage createVolatileImage(int width,
                                         int height)
创建一幅用于双缓冲的、可变的、可在屏幕外绘制的图像。

参数：
width - 指定的宽度。
height - 指定的高度。
返回：
一幅屏幕外可绘制的图像，可用于双缓冲。如果组件是不可显示的，则返回值可能为 null。如果 GraphicsEnvironment.isHeadless() 返回 true，则始终发生这种情况。
从以下版本开始：
1.4
另请参见：
VolatileImage, isDisplayable(), GraphicsEnvironment.isHeadless()

createVolatileImage

public VolatileImage createVolatileImage(int width,
                                         int height,
                                         ImageCapabilities caps)
                                  throws AWTException
创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。由于操作系统的问题，此图像的内容可在任意时间丢失，所以必须通过 VolatileImage 接口管理该图像。

参数：
width - 指定的宽度。
height - 指定的高度。
caps - 图像的能力
返回：
一个 VolatileImage 对象，可用于管理图面内容丢失和能力。
抛出：
AWTException - 如果无法创建具有指定能力的图像
从以下版本开始：
1.4
另请参见：
VolatileImage

prepareImage

public boolean prepareImage(Image image,
                            ImageObserver observer)
准备一幅在此组件上呈现的图像。图像数据由另一个线程异步下载并生成适当的图像屏幕表示。

参数：
image - 准备进行屏幕表示的 Image
observer - 图像准备就绪时所要通知的 ImageObserver 对象
返回：
如果图像已经完全准备好，则返回 true；否则返回 false
从以下版本开始：
JDK1.0

prepareImage

public boolean prepareImage(Image image,
                            int width,
                            int height,
                            ImageObserver observer)
以指定的宽度和高度准备一幅在此组件上呈现的图像。

图像数据由另一个线程异步下载并生成适当缩放的图像屏幕表示。

参数：
image - 准备进行屏幕表示的 Image 实例
width - 所需屏幕表示的宽度
height - 所需屏幕表示的高度
observer - 图像准备就绪时所要通知的 ImageObserver 对象
返回：
如果图像已经完全准备好，则返回 true；否则返回 false
从以下版本开始：
JDK1.0
另请参见：
ImageObserver

checkImage

public int checkImage(Image image,
                      ImageObserver observer)
返回指定图像屏幕表示的构造状态。

此方法不会使图像开始加载。应用程序必须使用 prepareImage 方法强制加载图像。

可在 ImageObserver 接口的讨论中找到有关此方法返回的标志的信息。

参数：
image - 正检查其状态的 Image 对象
observer - 图像准备就绪时所要通知的 ImageObserver 对象
返回：
对 ImageObserver 的标志按位进行 OR 运算后的结果，指示图像的哪些信息是当前可用的
从以下版本开始：
JDK1.0
另请参见：
prepareImage(Image, int, int, java.awt.image.ImageObserver), Toolkit.checkImage(Image, int, int, java.awt.image.ImageObserver), ImageObserver

checkImage

public int checkImage(Image image,
                      int width,
                      int height,
                      ImageObserver observer)
返回指定图像屏幕表示的构造状态。

此方法不会使图像开始加载。应用程序必须使用 prepareImage 方法强制加载图像。

Component 的 checkImage 方法调用其同位体的 checkImage 方法来计算标志。如果此组件还没有同位体，则调用组件工具包的 checkImage 方法。

可在 ImageObserver 接口的讨论中找到有关此方法返回的标志的信息。

参数：
image - 正检查其状态的 Image
width - 要检查其状态的缩放图像的宽度
height - 要检查其状态的缩放图像的高度
observer - 图像准备就绪时所要通知的 ImageObserver 对象
返回：
对 ImageObserver 的标志按位进行 OR 运算后的结果，指示图像的哪些信息是当前可用的
从以下版本开始：
JDK1.0
另请参见：
prepareImage(Image, int, int, java.awt.image.ImageObserver), Toolkit.checkImage(Image, int, int, java.awt.image.ImageObserver), ImageObserver

setIgnoreRepaint

public void setIgnoreRepaint(boolean ignoreRepaint)
设置是否应该忽略从操作系统接受的绘制消息。这不会影响 AWT 在软件中生成的绘制事件，除非它们是对操作系统级别绘制消息的直接响应。

这是很有用的，例如正在全屏模式中运行并且需要更佳的性能，或者使用页面翻转作为缓冲策略时。

从以下版本开始：
1.4
另请参见：
getIgnoreRepaint(),
Canvas.createBufferStrategy(int),
Window.createBufferStrategy(int),
BufferStrategy,
GraphicsDevice.setFullScreenWindow(java.awt.Window)

getIgnoreRepaint

public boolean getIgnoreRepaint()
返回：
是否应该忽略接收操作系统发出的绘制消息。
从以下版本开始：
1.4
另请参见：
setIgnoreRepaint(boolean)

contains

public boolean contains(int x,
                        int y)
检查组件是否“包含”指定的点，其中 x 和 y 是相对于此组件的坐标系定义的。

参数：
x - 该点的 x 坐标
y - 该点的 y 坐标
从以下版本开始：
JDK1.1
另请参见：
getComponentAt(int, int)

inside

@Deprecated
public boolean inside(int x,
                                 int y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。

contains

public boolean contains(Point p)
检查组件是否“包含”指定的点，其中该点的 x 和 y 坐标是相对于此组件的坐标系定义的。

参数：
p - 点
从以下版本开始：
JDK1.1
另请参见：
getComponentAt(Point)

getComponentAt

public Component getComponentAt(int x,
                                int y)
确定此组件或其直接子组件之一是否包含（x，y）位置，并且如果是，则返回包含该位置的组件。此方法仅查找一层子组件。如果点（x，y）处于某个子组件内部，而该子组件本身也有子组件，则此方法不向下查找子组件树。

如果（x，y）坐标位置处于组件边界框的内部，则 Component 的 locate 方法只是简单地返回组件本身；否则返回 null。

参数：
x - x 坐标
y - y 坐标
返回：
包含（x，y）位置的组件或子组件；如果该位置位于此组件外部，则返回 null
从以下版本开始：
JDK1.0
另请参见：
contains(int, int)

locate

@Deprecated
public Component locate(int x,
                                   int y)
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。

getComponentAt

public Component getComponentAt(Point p)
返回包含指定点的组件或子组件。

参数：
p - 点
从以下版本开始：
JDK1.1
另请参见：
contains(int, int)

deliverEvent

@Deprecated
public void deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。

dispatchEvent

public final void dispatchEvent(AWTEvent e)
为组件或其子组件之一指派事件。对于已为 Component 启用的 1.1 类型的事件，在返回前要调用 processEvent。

参数：
e - 事件

postEvent

@Deprecated
public boolean postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。

指定者：
接口 MenuContainer 中的 postEvent

addComponentListener

public void addComponentListener(ComponentListener l)
添加指定的组件侦听器，以接收发自此组件的组件事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 组件侦听器
从以下版本开始：
JDK1.1
另请参见：
ComponentEvent, ComponentListener, removeComponentListener(java.awt.event.ComponentListener), getComponentListeners()

removeComponentListener

public void removeComponentListener(ComponentListener l)
移除指定的组件侦听器，以便它不再接收发自此组件的组件事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 组件侦听器
从以下版本开始：
JDK1.1
另请参见：
ComponentEvent, ComponentListener, addComponentListener(java.awt.event.ComponentListener), getComponentListeners()

getComponentListeners

public ComponentListener[] getComponentListeners()
返回在此组件上所有已注册的组件侦听器的数组。

返回：
组件的所有 ComponentListener，如果当前没有注册的组件侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addComponentListener(java.awt.event.ComponentListener), removeComponentListener(java.awt.event.ComponentListener)

addFocusListener

public void addFocusListener(FocusListener l)
添加指定的焦点侦听器，以便当此组件获得输入焦点时能够接收发自此组件的焦点事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 焦点侦听器
从以下版本开始：
JDK1.1
另请参见：
FocusEvent, FocusListener, removeFocusListener(java.awt.event.FocusListener), getFocusListeners()

removeFocusListener

public void removeFocusListener(FocusListener l)
移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。如果参数所指定的侦听器尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 焦点侦听器
从以下版本开始：
JDK1.1
另请参见：
FocusEvent, FocusListener, addFocusListener(java.awt.event.FocusListener), getFocusListeners()

getFocusListeners

public FocusListener[] getFocusListeners()
返回在此组件上所有已注册的焦点侦听器的数组。

返回：
组件的所有 FocusListener，如果当前没有注册的焦点侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addFocusListener(java.awt.event.FocusListener), removeFocusListener(java.awt.event.FocusListener)

addHierarchyListener

public void addHierarchyListener(HierarchyListener l)
添加指定的层次结构侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构变化事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 层次结构侦听器
从以下版本开始：
1.3
另请参见：
HierarchyEvent, HierarchyListener, removeHierarchyListener(java.awt.event.HierarchyListener), getHierarchyListeners()

removeHierarchyListener

public void removeHierarchyListener(HierarchyListener l)
移除指定的层次结构侦听器，以便它不再接收发自此组件的层次结构变化事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 层次结构侦听器
从以下版本开始：
1.3
另请参见：
HierarchyEvent, HierarchyListener, addHierarchyListener(java.awt.event.HierarchyListener), getHierarchyListeners()

getHierarchyListeners

public HierarchyListener[] getHierarchyListeners()
返回在此组件上所有已注册的层次结构侦听器的数组。

返回：
组件的所有 HierarchyListener，如果当前没有注册的层次结构侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addHierarchyListener(java.awt.event.HierarchyListener), removeHierarchyListener(java.awt.event.HierarchyListener)

addHierarchyBoundsListener

public void addHierarchyBoundsListener(HierarchyBoundsListener l)
添加指定的层次结构边界侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构边界事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 层次结构边界侦听器
从以下版本开始：
1.3
另请参见：
HierarchyEvent, HierarchyBoundsListener, removeHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener), getHierarchyBoundsListeners()

removeHierarchyBoundsListener

public void removeHierarchyBoundsListener(HierarchyBoundsListener l)
移除指定的层次结构边界侦听器，以便它不再接收发自此组件的层次结构边界事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 层次结构边界侦听器
从以下版本开始：
1.3
另请参见：
HierarchyEvent, HierarchyBoundsListener, addHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener), getHierarchyBoundsListeners()

getHierarchyBoundsListeners

public HierarchyBoundsListener[] getHierarchyBoundsListeners()
返回在此组件上所有已注册的层次结构边界侦听器的数组。

返回：
组件的所有 HierarchyBoundsListener，如果当前没有注册的层次结构边界侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener), removeHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener)

addKeyListener

public void addKeyListener(KeyListener l)
添加指定的按键侦听器，以接收发自此组件的按键事件。如果 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 按键侦听器。
从以下版本开始：
JDK1.1
另请参见：
KeyEvent, KeyListener, removeKeyListener(java.awt.event.KeyListener), getKeyListeners()

removeKeyListener

public void removeKeyListener(KeyListener l)
移除指定的按键侦听器，以便它不再接收发自此组件的按键事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 按键侦听器
从以下版本开始：
JDK1.1
另请参见：
KeyEvent, KeyListener, addKeyListener(java.awt.event.KeyListener), getKeyListeners()

getKeyListeners

public KeyListener[] getKeyListeners()
返回在此组件上所有已注册的按键侦听器的数组。

返回：
组件的所有 KeyListener，如果当前没有注册的按键侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addKeyListener(java.awt.event.KeyListener), removeKeyListener(java.awt.event.KeyListener)

addMouseListener

public void addMouseListener(MouseListener l)
添加指定的鼠标侦听器，以接收发自此组件的鼠标事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 鼠标侦听器
从以下版本开始：
JDK1.1
另请参见：
MouseEvent, MouseListener, removeMouseListener(java.awt.event.MouseListener), getMouseListeners()

removeMouseListener

public void removeMouseListener(MouseListener l)
移除指定的鼠标侦听器，以便它不再接收发自此组件的鼠标事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 鼠标侦听器
从以下版本开始：
JDK1.1
另请参见：
MouseEvent, MouseListener, addMouseListener(java.awt.event.MouseListener), getMouseListeners()

getMouseListeners

public MouseListener[] getMouseListeners()
返回在此组件上所有已注册的鼠标侦听器的数组。

返回：
组件的所有 MouseListener，如果当前没有注册的鼠标侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addMouseListener(java.awt.event.MouseListener), removeMouseListener(java.awt.event.MouseListener)

addMouseMotionListener

public void addMouseMotionListener(MouseMotionListener l)
添加指定的鼠标移动侦听器，以接收发自此组件的鼠标移动事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 鼠标移动侦听器
从以下版本开始：
JDK1.1
另请参见：
MouseEvent, MouseMotionListener, removeMouseMotionListener(java.awt.event.MouseMotionListener), getMouseMotionListeners()

removeMouseMotionListener

public void removeMouseMotionListener(MouseMotionListener l)
移除指定的鼠标移动侦听器，以便它不再接收发自此组件的鼠标移动事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 鼠标移动侦听器
从以下版本开始：
JDK1.1
另请参见：
MouseEvent, MouseMotionListener, addMouseMotionListener(java.awt.event.MouseMotionListener), getMouseMotionListeners()

getMouseMotionListeners

public MouseMotionListener[] getMouseMotionListeners()
返回在此组件上所有已注册的鼠标移动侦听器的数组。

返回：
组件的所有 MouseMotionListener，如果当前没有注册的鼠标移动侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addMouseMotionListener(java.awt.event.MouseMotionListener), removeMouseMotionListener(java.awt.event.MouseMotionListener)

addMouseWheelListener

public void addMouseWheelListener(MouseWheelListener l)
添加指定的鼠标滚轮侦听器，以接收发自此组件的鼠标滚轮事件。容器还接收发自子组件的鼠标滚轮事件。

有关如何指派鼠标滚轮事件的信息，请参阅 MouseWheelEvent 的类描述。

如果 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 鼠标滚轮侦听器
从以下版本开始：
1.4
另请参见：
MouseWheelEvent, MouseWheelListener, removeMouseWheelListener(java.awt.event.MouseWheelListener), getMouseWheelListeners()

removeMouseWheelListener

public void removeMouseWheelListener(MouseWheelListener l)
移除指定的鼠标滚轮侦听器，以便它不再接收发自此组件的鼠标滚轮事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 鼠标滚轮侦听器。
从以下版本开始：
1.4
另请参见：
MouseWheelEvent, MouseWheelListener, addMouseWheelListener(java.awt.event.MouseWheelListener), getMouseWheelListeners()

getMouseWheelListeners

public MouseWheelListener[] getMouseWheelListeners()
返回在此组件上所有已注册的鼠标滚轮侦听器的数组。

返回：
组件的所有 MouseWheelListener，如果当前没有注册的鼠标滚轮侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addMouseWheelListener(java.awt.event.MouseWheelListener), removeMouseWheelListener(java.awt.event.MouseWheelListener)

addInputMethodListener

public void addInputMethodListener(InputMethodListener l)
添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。如果组件还重写了 getInputMethodRequests 并返回一个 InputMethodRequests 实例，则该组件只接收发自输入方法的输入方法事件。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 输入方法侦听器
从以下版本开始：
1.2
另请参见：
InputMethodEvent,
InputMethodListener,
removeInputMethodListener(java.awt.event.InputMethodListener),
getInputMethodListeners(),
getInputMethodRequests()

removeInputMethodListener

public void removeInputMethodListener(InputMethodListener l)
移除指定的输入方法侦听器，以便它不再接收发自此组件的输入方法事件。如果参数所指定的侦听器先前尚未添加到此组件，则此方法不起作用，也不抛出异常。如果侦听器 l 为 null，则不会抛出异常并且不执行动作。

有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 输入方法侦听器
从以下版本开始：
1.2
另请参见：
InputMethodEvent, InputMethodListener, addInputMethodListener(java.awt.event.InputMethodListener), getInputMethodListeners()

getInputMethodListeners

public InputMethodListener[] getInputMethodListeners()
返回在此组件上所有已注册的输入方法侦听器的数组。

返回：
组件的所有 InputMethodListener，如果当前没有注册的输入方法侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addInputMethodListener(java.awt.event.InputMethodListener), removeInputMethodListener(java.awt.event.InputMethodListener)

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。FooListener 是使用 addFooListener 方法注册的。

可以使用 class 字面值（如 FooListener.class）来指定 listenerType 参数。例如，可以使用以下代码来查询 Component c 的鼠标侦听器：

MouseListener[] mls = (MouseListener[])(c.getListeners(MouseListener.class));
如果不存在这样的侦听器，则此方法返回一个空数组。

参数：
listenerType - 所请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
返回一个在此组件上作为 FooListener 注册的所有对象的数组，如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getComponentListeners(),
getFocusListeners(),
getHierarchyListeners(),
getHierarchyBoundsListeners(),
getKeyListeners(),
getMouseListeners(),
getMouseMotionListeners(),
getMouseWheelListeners(),
getInputMethodListeners(),
#getPropertyChangeListener

getInputMethodRequests

public InputMethodRequests getInputMethodRequests()
获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。支持当场文本输入的组件必须重写此方法，以便返回一个 InputMethodRequests 实例。同时，还必须处理输入方法事件。

返回：
组件的输入方法请求处理程序，默认为 null
从以下版本开始：
1.2
另请参见：
addInputMethodListener(java.awt.event.InputMethodListener)

getInputContext

public InputContext getInputContext()
获取此组件使用的输入上下文，用于处理在此组件中输入文本时与输入方法的通信。默认情况下，返回父组件使用的输入上下文。组件可能重写此方法，以便返回一个私有的输入上下文。

返回：
组件使用的输入上下文，如果可以确定没有上下文，则返回 null
从以下版本开始：
1.2

enableEvents

protected final void enableEvents(long eventsToEnable)
启用由传递给此组件的指定事件掩码参数所定义的事件。

将某个事件类型的侦听器添加到该组件时，自动启用该事件类型。

此方法只能由 Component 的子类调用，该子类需要将指定的事件类型传递给 processEvent，而不管是否已注册了侦听器。

参数：
eventsToEnable - 定义事件类型的事件掩码
从以下版本开始：
JDK1.1
另请参见：
processEvent(java.awt.AWTEvent), disableEvents(long), AWTEvent

disableEvents

protected final void disableEvents(long eventsToDisable)
禁用由传递给此组件的指定事件掩码参数所定义的事件。

参数：
eventsToDisable - 定义事件类型的事件掩码
从以下版本开始：
JDK1.1
另请参见：
enableEvents(long)

coalesceEvents

protected AWTEvent coalesceEvents(AWTEvent existingEvent,
                                  AWTEvent newEvent)
将正发送的事件与现有事件组合在一起。如果队列中的事件与要发送的事件有相同的 ID（两个事件都将此组件作为其源组件）时，则由 EventQueue.postEvent 调用此方法。此方法返回一个已组合的事件并用该事件取代现有事件（然后丢弃新事件），或者返回 null，表示没有进行组合（将第二个事件添加到队列的末尾）。如果未返回 null，则可以修改并返回任一事件参数，同时丢弃另一个参数。

此 coalesceEvents 实现可组合两种事件类型：鼠标移动（和拖动）事件，以及绘制（和更新）事件。对于鼠标移动事件，总是返回最后一个事件，导致丢弃中间的移动。对于绘制事件，将新事件组合到同位体中的复杂 RepaintArea。总是返回新的 AWTEvent。

参数：
existingEvent - 已在 EventQueue 中的事件
newEvent - 正发送到 EventQueue 中的事件
返回：
一个已组合的事件，或者返回 null 表明没有进行组合

processEvent

protected void processEvent(AWTEvent e)
处理组件上发生的事件。默认情况下，此方法调用给定事件类的适当 process<event type>Event 方法。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
processComponentEvent(java.awt.event.ComponentEvent),
processFocusEvent(java.awt.event.FocusEvent),
processKeyEvent(java.awt.event.KeyEvent),
processMouseEvent(java.awt.event.MouseEvent),
processMouseMotionEvent(java.awt.event.MouseEvent),
processInputMethodEvent(java.awt.event.InputMethodEvent),
processHierarchyEvent(java.awt.event.HierarchyEvent),
processMouseWheelEvent(java.awt.event.MouseWheelEvent)

processComponentEvent

protected void processComponentEvent(ComponentEvent e)
处理组件上发生的组件事件，方法是将其指派到任意已注册的 ComponentListener 对象。

如果组件上没有启用组件事件，则不调用此方法。发生下列之一时启用组件事件：

  • 通过 addComponentListener 注册了一个 ComponentListener 对象。
  • 通过 enableEvents 启用了组件事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 组件事件
从以下版本开始：
JDK1.1
另请参见：
ComponentEvent, ComponentListener, addComponentListener(java.awt.event.ComponentListener), enableEvents(long)

processFocusEvent

protected void processFocusEvent(FocusEvent e)
处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。

如果组件上没有启用焦点事件，则不调用此方法。发生下列之一时启用焦点事件：

  • 通过 addFocusListener 注册了一个 FocusListener 对象。
  • 通过 enableEvents 启用了焦点事件。

如果为某个 Component 启用了焦点事件，则当前的 KeyboardFocusManager 确定是否应该将焦点事件指派到已注册的 FocusListener 对象。如果未指派事件，则 KeyboardFocusManager 调用 Component 的 dispatchEvent 方法，此方法又调用 Component 的 processFocusEvent 方法。

如果为 Component 启用了焦点事件，则用 FocusEvent 作为参数来调用 Component 的 dispatchEvent 方法将导致调用 Component 的 processFocusEvent 方法，而不管当前的 KeyboardFocusManager 如何。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 焦点事件
从以下版本开始：
JDK1.1
另请参见：
FocusEvent, FocusListener, KeyboardFocusManager, addFocusListener(java.awt.event.FocusListener), enableEvents(long), dispatchEvent(java.awt.AWTEvent)

processKeyEvent

protected void processKeyEvent(KeyEvent e)
处理组件上发生的按键事件，方法是将其指派到任意已注册的 KeyListener 对象。

如果组件上没有启用按键事件，则不调用此方法。发生下列之一时启用按键事件：

  • 通过 addKeyListener 注册了一个 KeyListener 对象。
  • 通过 enableEvents 启用了按键事件。

如果为某个 Component 启用了按键事件，则当前的 KeyboardFocusManager 确定是否应该将按键事件指派到已注册的 KeyListener 对象。DefaultKeyboardFocusManager 不会为非焦点所有者或未显示的 Component 指派按键事件。

从 J2SE 1.4 开始，已将 KeyEvent 重定向到焦点所有者。有关更多信息，请参阅 Focus Specification。

只要组件正在显示、已定焦、已启用并且其上的按键事件已启用，那么使用 KeyEvent 作为参数来调用 Component 的 dispatchEvent 方法将导致调用 Component 的 processKeyEvent 方法，而不管当前的 KeyboardFocusManager 如何。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 按键事件
从以下版本开始：
JDK1.1
另请参见：
KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, processEvent(java.awt.AWTEvent), dispatchEvent(java.awt.AWTEvent), addKeyListener(java.awt.event.KeyListener), enableEvents(long), isShowing()

processMouseEvent

protected void processMouseEvent(MouseEvent e)
处理组件上发生的鼠标事件，方法是将其指派到任意已注册的 MouseListener 对象。

如果组件上没有启用鼠标事件，则不调用此方法。发生下列之一时启用鼠标事件：

  • 通过 addMouseListener 注册了一个 MouseListener 对象。
  • 通过 enableEvents 启用了鼠标事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 鼠标事件
从以下版本开始：
JDK1.1
另请参见：
MouseEvent, MouseListener, addMouseListener(java.awt.event.MouseListener), enableEvents(long)

processMouseMotionEvent

protected void processMouseMotionEvent(MouseEvent e)
处理组件上发生的鼠标移动事件，方法是将其指派到任意已注册的 MouseMotionListener 事件。

如果组件上没有启用鼠标移动事件，则不调用此方法。发生下列之一时启用鼠标移动事件：

  • 通过 addMouseMotionListener 注册了一个 MouseMotionListener 对象。
  • 通过 enableEvents 启用了鼠标移动事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 鼠标移动事件
从以下版本开始：
JDK1.1
另请参见：
MouseEvent, MouseMotionListener, addMouseMotionListener(java.awt.event.MouseMotionListener), enableEvents(long)

processMouseWheelEvent

protected void processMouseWheelEvent(MouseWheelEvent e)
处理组件上发生的鼠标滚轮事件，方法是将其指派到任意已注册的 MouseWheelListener 对象。

如果组件上没有启用鼠标滚轮事件，则不调用此方法。发生下列之一时启用鼠标滚轮事件：

  • 通过 addMouseWheelListener 注册了一个 MouseWheelListener 对象。
  • 通过 enableEvents 启用了鼠标滚轮事件。

有关如何指派鼠标滚轮事件的信息，请参阅 MouseWheelEvent 的类描述。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 鼠标滚轮事件
从以下版本开始：
1.4
另请参见：
MouseWheelEvent, MouseWheelListener, addMouseWheelListener(java.awt.event.MouseWheelListener), enableEvents(long)

processInputMethodEvent

protected void processInputMethodEvent(InputMethodEvent e)
处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。

如果组件上没有启用输入方法事件，则不调用此方法。发生下列之一时启用输入方法事件：

  • 通过 addInputMethodListener 注册了一个 InputMethodListener 对象。
  • 通过 enableEvents 启用了输入方法事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 输入方法事件
从以下版本开始：
1.2
另请参见：
InputMethodEvent, InputMethodListener, addInputMethodListener(java.awt.event.InputMethodListener), enableEvents(long)

processHierarchyEvent

protected void processHierarchyEvent(HierarchyEvent e)
处理组件上发生的层次结构事件，方法是将其指派到任意已注册的 HierarchyListener 对象。

如果组件上没有启用层次结构事件，则不调用此方法。发生下列之一时启用层次结构事件：

  • 通过 addHierarchyListener 注册了一个 HierarchyListener 对象。
  • 通过 enableEvents 启用了层次结构事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 层次结构事件
从以下版本开始：
1.3
另请参见：
HierarchyEvent, HierarchyListener, addHierarchyListener(java.awt.event.HierarchyListener), enableEvents(long)

processHierarchyBoundsEvent

protected void processHierarchyBoundsEvent(HierarchyEvent e)
处理组件上发生的层次结构边界事件，方法是将其指派到任意已注册的 HierarchyBoundsListener 对象。

如果组件上没有启用层次结构边界事件，则不调用此方法。发生下列之一时启用层次结构边界事件：

  • 通过 addHierarchyBoundsListener 注册了一个 HierarchyBoundsListener 对象。
  • 通过 enableEvents 启用了层次结构边界事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

参数：
e - 层次结构事件
从以下版本开始：
1.3
另请参见：
HierarchyEvent, HierarchyBoundsListener, addHierarchyBoundsListener(java.awt.event.HierarchyBoundsListener), enableEvents(long)

handleEvent

@Deprecated
public boolean handleEvent(Event evt)
已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。

mouseDown

@Deprecated
public boolean mouseDown(Event evt,
                                    int x,
                                    int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。

mouseDrag

@Deprecated
public boolean mouseDrag(Event evt,
                                    int x,
                                    int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。

mouseUp

@Deprecated
public boolean mouseUp(Event evt,
                                  int x,
                                  int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。

mouseMove

@Deprecated
public boolean mouseMove(Event evt,
                                    int x,
                                    int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。

mouseEnter

@Deprecated
public boolean mouseEnter(Event evt,
                                     int x,
                                     int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。

mouseExit

@Deprecated
public boolean mouseExit(Event evt,
                                    int x,
                                    int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。

keyDown

@Deprecated
public boolean keyDown(Event evt,
                                  int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。

keyUp

@Deprecated
public boolean keyUp(Event evt,
                                int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。

action

@Deprecated
public boolean action(Event evt,
                                 Object what)
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。

addNotify

public void addNotify()
通过将此 Component 连接到一个本机屏幕资源使其成为可显示的。此方法由工具包内部调用，不应直接由程序调用。

从以下版本开始：
JDK1.0
另请参见：
isDisplayable(), removeNotify()

removeNotify

public void removeNotify()
通过销毁此 Component 的本机屏幕资源使其成为不可显示的。

此方法由工具包内部调用，不应直接由程序调用。重写此方法的代码应该在重写方法的首行调用 super.removeNotify。

从以下版本开始：
JDK1.0
另请参见：
isDisplayable(), addNotify()

gotFocus

@Deprecated
public boolean gotFocus(Event evt,
                                   Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。

lostFocus

@Deprecated
public boolean lostFocus(Event evt,
                                    Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。

isFocusTraversable

@Deprecated
public boolean isFocusTraversable()
已过时。 从 1.4 开始，由 isFocusable() 取代。

返回此 Component 是否可以成为焦点所有者。

返回：
如果此 Component 是可以获得焦点的，则返回 true；否则返回 false
从以下版本开始：
JDK1.1
另请参见：
setFocusable(boolean)

isFocusable

public boolean isFocusable()
返回此 Component 是否可以获得焦点。

返回：
如果此 Component 可以获得焦点，则返回 true；否则返回 false。
从以下版本开始：
1.4
另请参见：
setFocusable(boolean)

setFocusable

public void setFocusable(boolean focusable)
将此 Component 的焦点状态设置为指定值。此值覆盖 Component 的默认焦点状态。

参数：
focusable - 表明此 Component 是否可以获得焦点
从以下版本开始：
1.4
另请参见：
isFocusable()

setFocusTraversalKeys

public void setFocusTraversalKeys(int id,
                                  Set<? extends AWTKeyStroke> keystrokes)
为此 Component 的给定遍历操作设置焦点遍历键。

Component 的焦点遍历键的默认值与实现有关。Sun 建议为特定本机平台的所有实现使用相同的默认值。下面列出了 Windows 和 Unix 的建议值。在 Sun AWT 实现中使用了这些建议值。

标识符 | 含义 | 默认值
KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS | 正常的前向键盘遍历 | KEY_PRESSED 上的 TAB，KEY_PRESSED 上的 CTRL-TAB
KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS | 正常的反向键盘遍历 | KEY_PRESSED 上的 SHIFT-TAB，KEY_PRESSED 上的 CTRL-SHIFT-TAB
KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS | 到上一个焦点遍历循环 | 无
使用空的 Set 来禁用遍历键；建议使用 Collections.EMPTY_SET。

客户机代码使用 AWTKeyStroke API 可以指定根据哪种特定的 KeyEvents（KEY_PRESSED 或 KEY_RELEASED）将会发生焦点遍历操作。然而，无论指定了哪种 KeyEvent，都将使用与焦点遍历键相关的所有 KeyEvents（包括相关联的 KEY_TYPED 事件），并且不会指派到任意 Component。将 KEY_TYPED 事件指定为焦点遍历操作的映射，或者将相同的事件映射到多个默认焦点遍历操作会生成运行时错误。

如果为 Set 指定了 null 值，则此 Component 会继承其父级的 Set。如果此 Component 的所有祖先都为 Set 指定了 null，则使用当前 KeyboardFocusManager 的默认 Set。

参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一。
keystrokes - 指定操作的 AWTKeyStroke 的 Set。
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一、或者 keystroke 包含 null、或者 keystroke 中的 Object 不是 AWTKeyStroke、或者任意 keystroke 表示一个 KEY_TYPED 事件，或者任意 keystroke 已经映射到此 Component 的另一个焦点遍历操作
从以下版本开始：
1.4
另请参见：
getFocusTraversalKeys(int), KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS

getFocusTraversalKeys

public Set<AWTKeyStroke> getFocusTraversalKeys(int id)
返回此 Component 的给定遍历操作的焦点遍历键 Set。（有关每个键的完整描述，请参阅 setFocusTraversalKeys）。

如果没有为此 Component 显式定义遍历键 Set，则返回此 Component 的父级 Set。如果没有为此 Component 的所有父级显式定义 Set，则返回当前 KeyboardFocusManager 的默认 Set。

参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一。
返回：
指定操作的 AWTKeyStrokes 的 Set。Set 是不可修改的，但可为空。此方法永远不会返回 null。
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一
从以下版本开始：
1.4
另请参见：
setFocusTraversalKeys(int, java.util.Set), KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS

areFocusTraversalKeysSet

public boolean areFocusTraversalKeysSet(int id)
返回是否为此 Component 显式定义了给定焦点遍历操作的焦点遍历键 Set。如果此方法返回 false，则此 Component 继承了其祖先或当前 KeyboardFocusManager 的 Set。

参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一
返回：
如果已为此 Component 显式定义了给定焦点遍历操作的焦点遍历键 Set，则返回 true；否则返回 false。
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一
从以下版本开始：
1.4

setFocusTraversalKeysEnabled

public void setFocusTraversalKeysEnabled(boolean focusTraversalKeysEnabled)
设置是否为此 Component 启用焦点遍历键。其焦点遍历键已禁用的 Component 接收焦点遍历键的按键事件。其焦点遍历键已启用的 Component 不会看到这些事件；相反，会自动将这些事件转换为遍历操作。

参数：
focusTraversalKeysEnabled - 是否为此 Component 启用焦点遍历键
从以下版本开始：
1.4
另请参见：
getFocusTraversalKeysEnabled(),
setFocusTraversalKeys(int, java.util.Set),
getFocusTraversalKeys(int)

getFocusTraversalKeysEnabled

public boolean getFocusTraversalKeysEnabled()
返回是否已为此 Component 启用了焦点遍历键。其焦点遍历键已禁用的 Component 接收焦点遍历键的按键事件。其焦点遍历键已启用的 Component 不会看到这些事件；相反，会自动将这些事件转换为遍历操作。

返回：
是否已为此 Component 启用焦点遍历键
从以下版本开始：
1.4
另请参见：
setFocusTraversalKeysEnabled(boolean), setFocusTraversalKeys(int, java.util.Set), getFocusTraversalKeys(int)

requestFocus

public void requestFocus()
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。此 Component 对于所要许可的请求而言必须是不可显示的、可聚焦的和可见的并且其所有祖先（除了顶层 Window 以外）必须是可见的。此方法会尽力完成该请求；但是在某些情况下可能无法完成。在此 Component 接收 FOCUS_GAINED 事件前，开发人员永远不能假定此 Component 是焦点所有者。如果由于此 Component 的顶层 Window 没有成为获得焦点的窗口而拒绝了此请求，则记住此请求，并在后来用户使窗口成为获得焦点的窗口时许可此请求。

此方法不能用于为根本不是 Component 的内容设置焦点所有者，应该使用 KeyboardFocusManager.clearGlobalFocusOwner()。

因为此方法的焦点行为与平台有关，所以强烈建议开发人员在可能时使用 requestFocusInWindow。

注：并不是所有的焦点传输都将导致防止调用此方法。同样地，组件可以在没有调用此方法或 Component 的其他任何方法的情况下接收焦点。

从以下版本开始：
JDK1.0
另请参见：
requestFocusInWindow(),
FocusEvent,
addFocusListener(java.awt.event.FocusListener),
isFocusable(),
isDisplayable(),
KeyboardFocusManager.clearGlobalFocusOwner()

requestFocus

protected boolean requestFocus(boolean temporary)
请求此 Component 获取输入焦点，并且此 Component 的顶层祖先成为获得焦点的 Window。此 Component 对于所要许可的请求而言必须是不可显示的、可聚焦的和可见的并且其所有祖先（除了顶层 Window 以外）必须是可见的。此方法会尽力完成该请求；但是在某些情况下可能无法完成。在此 Component 接收 FOCUS_GAINED 事件前，开发人员必须永远不能假定此 Component 是焦点所有者。如果由于此 Component 的顶层窗口没有成为获得焦点的窗口而拒绝了此请求，则记住此请求，并在后来用户使窗口成为获得焦点的窗口时许可此请求。

此方法返回布尔值。如果返回 false，则请求注定要失败。如果返回 true，并且在本机窗口系统允许请求前不禁止该请求或不发生特别的事件（如处理该组件的同位体），则请求成功。此外，虽然返回 true 表示请求可能成功了，但是在此组件接收 FOCUS_GAINED 事件前，开发人员必须永远不能假定此 Component 是焦点所有者。

此方法不能用于为根本不是 component 的内容设置焦点所有者，应该使用 KeyboardFocusManager.clearGlobalFocusOwner。

因为此方法的焦点行为与平台有关，所以强烈建议开发人员在可能时使用 requestFocusInWindow。

此方法会尽力完成该请求，确保作为此请求结果所产生的 FocusEvent 具有指定的临时值。但是，因为在所有本机窗口系统上指定一个任意的临时状态是不可能实现的，所以只有轻量级 Component 可以保证此方法的行为正确。此方法并非用于一般用途，而是作为轻量级组件库（如 Swing）的钩子 (hook) 而存在的。

注：并不是所有的焦点传输都将导致防止调用此方法。同样地，组件可以在没有调用此方法或 Component 的其他任何方法的情况下接收焦点。

参数：
temporary - 如果焦点改变是临时的（如在窗口丢失焦点时），则为 true；有关临时焦点改变的更多信息，请参阅 Focus Specification
返回：
如果焦点改变请求注定要失败，则返回 false；如果可能成功，则返回 true
从以下版本开始：
1.4
另请参见：
FocusEvent,
addFocusListener(java.awt.event.FocusListener),
isFocusable(),
isDisplayable(),
KeyboardFocusManager.clearGlobalFocusOwner()

requestFocusInWindow

public boolean requestFocusInWindow()
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。此 Component 对于所要许可的请求而言必须是不可显示的、可聚焦的和可见的并且其所有祖先（除了顶层 Window 以外）必须是可见的。此方法会尽力完成该请求；但是在某些情况下可能无法完成。在此 Component 接收 FOCUS_GAINED 事件前，开发人员永远不能假定此 Component 是焦点所有者。

此方法返回布尔值。如果返回 false，则请求注定要失败。如果返回 true，并且在本机窗口系统允许请求前不禁止该请求或不发生特别的事件（如处理该组件的同位体），则请求成功。此外，虽然返回 true 表示请求可能成功了，但是在此组件接收 FOCUS_GAINED 事件前，开发人员必须永远不能假定此 Component 是焦点所有者。

此方法不能用于为根本不是 Component 的内容设置焦点所有者，应该使用 KeyboardFocusManager.clearGlobalFocusOwner()。

可在各种平台之间一致地实现此方法的焦点行为，所以强烈建议开发人员在可能时使用此方法，而不是 requestFocus。依赖 requestFocus 的代码可能在不同平台上表现出不同的焦点行为。

注：并不是所有的焦点传输都将导致防止调用此方法。同样地，组件可以在没有调用此方法或 Component 的其他任何方法的情况下接收焦点。

返回：
如果焦点改变请求注定要失败，则返回 false；如果可能成功，则返回 true
从以下版本开始：
1.4
另请参见：
requestFocus(),
FocusEvent,
addFocusListener(java.awt.event.FocusListener),
isFocusable(),
isDisplayable(),
KeyboardFocusManager.clearGlobalFocusOwner()

requestFocusInWindow

protected boolean requestFocusInWindow(boolean temporary)
如果此 Component 的顶层祖先已经是获得焦点的 Window，则请求此 Component 获取输入焦点。此 Component 对于所要许可的请求而言必须是不可显示的、可聚焦的和可见的并且其所有祖先（除了顶层 Window 以外）必须是可见的。此方法会尽力完成该请求；但是在某些情况下可能无法完成。在此 Component 接收 FOCUS_GAINED 事件前，开发人员必须永远不能假定此 Component 是焦点所有者。

此方法返回布尔值。如果返回 false，则请求注定要失败。如果返回 true，并且在本机窗口系统允许请求前不禁止该请求或不发生特别的事件（如处理该组件的同位体），则请求成功。此外，虽然返回 true 表示请求可能成功了，但是在此组件接收 FOCUS_GAINED 事件前，开发人员必须永远不能假定此 Component 是焦点所有者。

此方法不能用于为根本不是 Component 的内容设置焦点所有者。应该使用 KeyboardFocusManager.clearGlobalFocusOwner。

可在各种平台之间一致地实现此方法的焦点行为，所以强烈建议开发人员在可能时使用此方法，而不是 requestFocus。依赖 requestFocus 的代码可能在不同平台上表现出不同的焦点行为。

此方法会尽力完成该请求，确保作为此请求结果所产生的 FocusEvent 具有指定的临时值。但是，因为在所有本机窗口系统上指定一个任意的临时状态是不可能实现的，所以只有轻量级组件可以保证此方法的行为正确。此方法并非用于一般用途，而是作为轻量级组件库（如 Swing）的钩子 (hook) 而存在的。

注：并不是所有的焦点传输都将导致防止调用此方法。同样地，组件可以在没有调用此方法或 Component 的其他任何方法的情况下接收焦点。

参数：
temporary - 如果焦点改变是临时的（如在窗口丢失焦点时），则为 true；有关临时焦点改变的更多信息，请参阅 Focus Specification
返回：
如果焦点改变请求注定要失败，则返回 false；如果可能成功，则返回 true
从以下版本开始：
1.4
另请参见：
requestFocus(),
FocusEvent,
addFocusListener(java.awt.event.FocusListener),
isFocusable(),
isDisplayable(),
KeyboardFocusManager.clearGlobalFocusOwner()

transferFocus

public void transferFocus()
将焦点转移到下一个组件，就好像此 Component 曾是焦点所有者。

从以下版本开始：
JDK1.1
另请参见：
requestFocus()

getFocusCycleRootAncestor

public Container getFocusCycleRootAncestor()
返回作为此 Component 焦点遍历循环的焦点循环根的 Container。每个焦点遍历循环只有一个焦点遍历循环根，每个不是 Container 的 Component 只属于一个焦点遍历循环。是焦点循环根的 Container 属于两个循环：一个起始于 Container 本身的循环，以及一个起始于 Container 的最近焦点循环根祖先的循环。对于这些 Container，此方法返回 Container 的最近焦点循环根祖先。

返回：
此 Component 的最近焦点循环根祖先
从以下版本开始：
1.4
另请参见：
Container.isFocusCycleRoot()

isFocusCycleRoot

public boolean isFocusCycleRoot(Container container)
返回指定的 Container 是否为此 Component 焦点遍历循环的焦点循环根。每个焦点遍历循环只有一个焦点遍历循环根，每个不是 Container 的 Component 只属于一个焦点遍历循环。

参数：
container - 要测试的 Container
返回：
如果指定的 Container 是此 Component 的焦点循环根，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
Container.isFocusCycleRoot()

nextFocus

@Deprecated
public void nextFocus()
已过时。 从 JDK version 1.1 开始，由 transferFocus() 取代。

transferFocusBackward

public void transferFocusBackward()
将焦点转移到前一个组件，就好像此 Component 曾是焦点所有者。

从以下版本开始：
1.4
另请参见：
requestFocus()

transferFocusUpCycle

public void transferFocusUpCycle()
将焦点向上转移一个焦点遍历循环。通常将焦点所有者设置为此 Component 的焦点循环根，将当前的焦点循环根设置为新焦点所有者的焦点循环根。但是如果此 Component 的焦点循环根是一个 Window，则将焦点所有者设置为焦点循环根的默认 Component，以便获得焦点，并且不改变当前的焦点循环根。

从以下版本开始：
1.4
另请参见：
requestFocus(),
Container.isFocusCycleRoot(),
Container.setFocusCycleRoot(boolean)

hasFocus

public boolean hasFocus()
如果此 Component 是焦点所有者，则返回 true。此方法已过时，并且已经由 isFocusOwner() 取代。

返回：
如果此 Component 是焦点所有者，则返回 true；否则返回 false
从以下版本开始：
1.2

isFocusOwner

public boolean isFocusOwner()
如果此 Component 是焦点所有者，则返回 true。

返回：
如果此 Component 是焦点所有者，则返回 true；否则返回 false
从以下版本开始：
1.4

add

public void add(PopupMenu popup)
向组件添加指定的弹出菜单。

参数：
popup - 要添加给组件的弹出菜单。
抛出：
NullPointerException - 如果 popup 为 null
从以下版本开始：
JDK1.1
另请参见：
remove(MenuComponent)

remove

public void remove(MenuComponent popup)
从组件移除指定的弹出菜单。

指定者：
接口 MenuContainer 中的 remove
参数：
popup - 要移除的弹出菜单
从以下版本开始：
JDK1.1
另请参见：
add(PopupMenu)

paramString

protected String paramString()
返回此组件状态的字符串表示形式。此方法仅在进行调试的时候使用，对于这两个实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

返回：
组件状态的字符串表示形式
从以下版本开始：
JDK1.0

toString

public String toString()
返回此组件及其值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
组件的字符串表示形式。
从以下版本开始：
JDK1.0

list

public void list()
将组件列表打印到标准系统输出流 System.out。

从以下版本开始：
JDK1.0
另请参见：
System.out

list

public void list(PrintStream out)
将组件列表打印到指定的输出流。

参数：
out - 打印流
从以下版本开始：
JDK1.0

list

public void list(PrintStream out,
                 int indent)
将列表从指定的缩排开始打印到指定的打印流。

参数：
out - 打印流
indent - 缩排的空格数
从以下版本开始：
JDK1.0
另请参见：
PrintStream.println(java.lang.Object)

list

public void list(PrintWriter out)
将列表打印到指定的打印编写器。

参数：
out - 打印到的打印编写器
从以下版本开始：
JDK1.1

list

public void list(PrintWriter out,
                 int indent)
将列表从指定的缩排开始打印到指定的打印编写器。

参数：
out - 打印到的打印编写器
indent - 缩排的空格数
从以下版本开始：
JDK1.1
另请参见：
PrintStream.println(java.lang.Object)

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。侦听器是为此类的所有绑定属性注册的，这些属性包括：
  • 此 Component 的字体 ("font")
  • 此 Component 的背景色 ("background")
  • 此 Component 的前景色 ("foreground")
  • 此 Component 的可拥有焦点性 ("focusable")
  • 此 Component 的焦点遍历键启用状态 ("focusTraversalKeysEnabled")
  • 此 Component 的 FORWARD_TRAVERSAL_KEYS 的 Set ("forwardFocusTraversalKeys")
  • 此 Component 的 BACKWARD_TRAVERSAL_KEYS 的 Set ("backwardFocusTraversalKeys")
  • 此 Component 的 UP_CYCLE_TRAVERSAL_KEYS 的 Set ("upCycleFocusTraversalKeys")
  • 此 Component 的首选大小 ("preferredSize")
  • 此 Component 的最小大小 ("minimumSize")
  • 此 Component 的最大大小 ("maximumSize")
  • 此 Component 的名称 ("name")
注意，如果此 Component 继承了一个绑定属性，则不会激发事件来响应继承属性的改变。

如果 listener 为 null，则不会抛出异常并且不执行动作。

参数：
listener - 要添加的属性更改侦听器
另请参见：
removePropertyChangeListener(java.beans.PropertyChangeListener), #getPropertyChangeListener, addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener)

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。应该使用此方法移除为此类的所有绑定属性所注册的 PropertyChangeListener。

如果 listener 为 null，则不会抛出异常并且不执行动作。

参数：
listener - 要移除的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), #getPropertyChangeListener, removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回在此组件上所有已注册的属性更改侦听器的数组。

返回：
组件的所有 PropertyChangeListener，如果当前没有注册的属性更改侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener),
removePropertyChangeListener(java.beans.PropertyChangeListener),
#getPropertyChangeListener(java.lang.String),
java.beans.PropertyChangeSupport#getPropertyChangeListener

addPropertyChangeListener

public void addPropertyChangeListener(String propertyName,
                                      PropertyChangeListener listener)
向指定属性的侦听器列表添加一个 PropertyChangeListener。指定的属性可能是用户定义的，或者是下列之一：
  • 此 Component 的字体 ("font")
  • 此 Component 的背景色 ("background")
  • 此 Component 的前景色 ("foreground")
  • 此 Component 的可拥有焦点性 ("focusable")
  • 此 Component 的焦点遍历键启用状态 ("focusTraversalKeysEnabled")
  • 此 Component 的 FORWARD_TRAVERSAL_KEYS 的 Set ("forwardFocusTraversalKeys")
  • 此 Component 的 BACKWARD_TRAVERSAL_KEYS 的 Set ("backwardFocusTraversalKeys")
  • 此 Component 的 UP_CYCLE_TRAVERSAL_KEYS 的 Set ("upCycleFocusTraversalKeys")
注意，如果此 Component 继承了一个绑定属性，则不会激发事件来响应继承属性的改变。

如果 propertyName 或 listener 为 null，则不会抛出异常并且不执行动作。

参数：
propertyName - 上面所列的属性名之一
listener - 要添加的 PropertyChangeListener
另请参见：
removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener),
#getPropertyChangeListener(java.lang.String),
addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener)

removePropertyChangeListener

public void removePropertyChangeListener(String propertyName,
                                         PropertyChangeListener listener)
从指定属性的侦听器列表中移除一个 PropertyChangeListener。应该使用此方法移除为指定绑定属性所注册的 PropertyChangeListener。

如果 propertyName 或 listener 为 null，则不会抛出异常并且不执行动作。

参数：
propertyName - 有效的属性名
listener - 要移除的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener),
#getPropertyChangeListener(java.lang.String),
removePropertyChangeListener(java.beans.PropertyChangeListener)

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的数组。

返回：
与指定属性相关联的所有 PropertyChangeListener；如果尚未添加这样的侦听器，或者 propertyName 为 null，则返回空数组
从以下版本开始：
1.4
另请参见：
addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener), removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener), #getPropertyChangeListener

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
支持报告 Object 属性的绑定属性改变。当改变了绑定属性并且向所有已注册的 PropertyChangeListener 发送相应的 PropertyChangeEvent 时可以调用此方法。

参数：
propertyName - 其值已改变的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  boolean oldValue,
                                  boolean newValue)
支持报告布尔属性的绑定属性改变。当改变了绑定属性并且向所有已注册的 PropertyChangeListener 发送相应的 PropertyChangeEvent 时可以调用此方法。

参数：
propertyName - 其值已改变的属性
oldValue - 该属性以前的值
newValue - 该属性的新值
从以下版本开始：
1.4

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  int oldValue,
                                  int newValue)
支持报告整数属性的绑定属性改变。当改变了绑定属性并且向所有已注册的 PropertyChangeListener 发送相应的 PropertyChangeEvent 时可以调用此方法。

参数：
propertyName - 其值已改变的属性
oldValue - 该属性以前的值
newValue - 该属性的新值
从以下版本开始：
1.4

firePropertyChange

public void firePropertyChange(String propertyName,
                               byte oldValue,
                               byte newValue)
报告绑定属性的改变。

参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（byte 类型）
newValue - 该属性的新值（byte 类型）
从以下版本开始：
1.5
另请参见：
firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               char oldValue,
                               char newValue)
报告绑定属性的改变。

参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（char 类型）
newValue - 该属性的新值（char 类型）
从以下版本开始：
1.5
另请参见：
firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               short oldValue,
                               short newValue)
报告绑定属性的改变。

参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（short 类型）
newValue - 该属性的新值（short 类型）
从以下版本开始：
1.5
另请参见：
firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               long oldValue,
                               long newValue)
报告绑定属性的改变。

参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（long 类型）
newValue - 该属性的新值（long 类型）
从以下版本开始：
1.5
另请参见：
firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               float oldValue,
                               float newValue)
报告绑定属性的改变。

参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（float 类型）
newValue - 该属性的新值（float 类型）
从以下版本开始：
1.5
另请参见：
firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               double oldValue,
                               double newValue)
报告绑定属性的改变。

参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（double 类型）
newValue - 该属性的新值（double 类型）
从以下版本开始：
1.5
另请参见：
firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

setComponentOrientation

public void setComponentOrientation(ComponentOrientation o)
设置语言敏感的方向，用于排序此组件内的元素或文本。语言敏感的 LayoutManager 和 Component 子类使用此属性来确定如何布局并绘制组件。

在构造时，组件的方向设置为 ComponentOrientation.UNKNOWN，表示尚未显式地指定它。UNKNOWN 方向的行为与 ComponentOrientation.LEFT_TO_RIGHT 相同。

要设置单个组件的方向，请使用此方法。要设置整个组件层次结构的方向，请使用 applyComponentOrientation。

另请参见：
ComponentOrientation

getComponentOrientation

public ComponentOrientation getComponentOrientation()
检索将用于排序此组件内的元素或文本的语言敏感的方向。需要考虑方向的 LayoutManager 和 Component 子类在执行布局或绘制前应该调用此方法来获取组件的方向。

另请参见：
ComponentOrientation

applyComponentOrientation

public void applyComponentOrientation(ComponentOrientation orientation)
设置此组件及其包含的所有组件的 ComponentOrientation 属性。

参数：
orientation - 此组件及其包含的所有组件的新组件方向。
抛出：
NullPointerException - 如果 orientation 为 null。
从以下版本开始：
1.4
另请参见：
setComponentOrientation(java.awt.ComponentOrientation), getComponentOrientation()

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Component 相关的 AccessibleContext。此基类所实现的方法返回 null。扩展 Component 的类应该实现此方法，以便返回与该子类相关的 AccessibleContext。

返回：
此 Component 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Component.AccessibleAWTComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component.AccessibleAWTComponent

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
所有已实现的接口：
Serializable, AccessibleComponent
直接已知子类：
Box.Filler.AccessibleBoxFiller, Button.AccessibleAWTButton, Canvas.AccessibleAWTCanvas, Checkbox.AccessibleAWTCheckbox, Choice.AccessibleAWTChoice, Container.AccessibleAWTContainer, Label.AccessibleAWTLabel, List.AccessibleAWTList, List.AccessibleAWTList.AccessibleAWTListChild, Scrollbar.AccessibleAWTScrollBar, TextComponent.AccessibleAWTTextComponent
正在封闭类：
Component
protected abstract class Component.AccessibleAWTComponent
extends AccessibleContext
implements Serializable, AccessibleComponent

用来为可访问性提供默认支持的 Component 的内部类。此类不是专门供应用程序开发人员直接使用的，而是供组件开发人员创建子类的。

可以使用该类来获得此对象的可访问功能。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
protected class | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）
protected class | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）
字段摘要
protected ComponentListener | accessibleAWTComponentHandler
protected FocusListener | accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Component.AccessibleAWTComponent()
虽然该类是抽象的，但其所有子类都应该能够调用此方法。
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收发自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表中。
boolean | contains(Point p) 检查指定的点是否在此对象的边界内，该点的 x 坐标和 y 坐标是相对于该对象的坐标系来定义的。
Accessible | getAccessibleAt(Point p) 返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。
Accessible | getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
int | getAccessibleChildrenCount() 返回此对象中可访问的子对象数。
AccessibleComponent | getAccessibleComponent() 获取与此对象相关的 AccessibleComponent（如果存在一个这样的组件）。
String | getAccessibleDescription() 获取此对象的可访问描述。
int | getAccessibleIndexInParent() 获取此对象在其可访问父对象中的索引。
String | getAccessibleName() 获取此对象的可访问名称。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取此对象的边界，用 Rectangle 对象的形式表示它。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 返回此对象的区域。
Point | getLocation() 通过用一个点指定该对象的左上角在屏幕坐标空间中的位置的形式，获取此对象相对于父对象的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 返回此对象的大小，用 Dimension 对象的形式表示它。
boolean | isEnabled() 确定是否启用了此对象。
boolean | isFocusTraversable() 返回对此对象是否可以接受焦点的判断。
boolean | isShowing() 确定是否正在显示该对象。
boolean | isVisible() 确定对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 从侦听器列表中移除。
void | requestFocus() 请求使此对象拥有焦点。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置此对象的边界，用 Rectangle 对象的形式表示它。
void | setCursor(Cursor cursor) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置此对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对父对象的位置。
void | setSize(Dimension d) 调整此对象的大小，使它具有宽度和高度。
void | setVisible(boolean b) 设置此对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

accessibleAWTComponentHandler

protected ComponentListener accessibleAWTComponentHandler

accessibleAWTFocusHandler

protected FocusListener accessibleAWTFocusHandler
构造方法详细信息

Component.AccessibleAWTComponent

protected Component.AccessibleAWTComponent()
虽然该类是抽象的，但其所有子类都应该能够调用此方法。

方法详细信息

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表中。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
listener - 要添加的属性更改侦听器
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 从侦听器列表中移除。此方法移除了一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
listener - 要移除的 PropertyChangeListener

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。此方法几乎从不返回 java.awt.Component.getName() 获取的名称，因为该名称通常不是一个本地化名称，并且对用户没有任何意义。如果对象根本就是一个文本对象（例如，一个菜单项），则可访问名称应该是该对象的文本（例如 "save"）。如果对象有一个工具提示，则工具提示文本还可以是要返回的适当 String。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称——如果此对象没有名称，则可以返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问描述。此描述应该是一个关于此对象是什么（即此对象对用户的意义）的简单本地化描述。如果对象有一个工具提示，则工具提示文本还可以是要返回的适当字符串，假定它包含对该对象的简单描述（而不仅仅只包含对象的名称，例如，工具栏上用 "save" 作为工具提示文本的 "Save" 图标不能将其工具提示文本作为描述返回，但像 "Saves the current text document" 之类的文本则可以作为描述返回）。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
对象的本地化描述——如果此对象没有描述，则可以返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 的一个实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象当前状态设置的 AccessibleStateSet 的一个实例
另请参见：
AccessibleState

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。如果此对象的父对象实现 Accessible，则此方法应该仅返回 getParent。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
此对象的 Accessible 父对象——如果此对象没有 Accessible 父对象，则可以返回 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
此对象在其可访问父对象中的索引；如果此对象没有可访问的父对象，则返回 -1
另请参见：
getAccessibleParent()

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回此对象中可访问的子对象数。如果此对象的所有子对象都实现了 Accessible，那么此方法应该返回该对象的子对象数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
返回此对象中可访问的子对象数

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回该对象的第 n 个 Accessible 子对象。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 子对象的基于 0 的索引
返回：
对象的第 n 个 Accessible 子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
返回此对象的区域。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此对象的区域

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象相关的 AccessibleComponent（如果存在一个这样的组件）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
组件
另请参见：
AccessibleComponent

getBackground

public Color getBackground()
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
该对象的背景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景色。（有关透明度的信息，请参阅 isOpaque。）

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 新的背景 Color
另请参见：
Component.isOpaque()

getForeground

public Color getForeground()
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
该对象的前景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 新的前景 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
对象的 Cursor（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor cursor)
设置此对象的 Cursor。

如果 Java 平台实现和/或本机系统不支持更改鼠标光标形状，则该方法可能不会产生任何视觉效果。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
对象的 Font（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
对象的 FontMetrics（如果受支持）；否则返回 null
另请参见：
getFont()

isEnabled

public boolean isEnabled()
确定是否启用了此对象。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果启用了此对象，则返回 ture；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
设置此对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果此参数为 ture，则启用此对象；否则将禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
确定对象是否可见。注：这意味该对象应该是可见的；但事实上，可能因为包含此对象的对象之一是不可见的，所以此对象无法在屏幕上显示出来。使用 isShowing 来确定某个对象是否正显示在屏幕上。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象是可见的，则返回 ture；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
设置此对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果此参数为 ture，则显示对象；否则将隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
确定是否正在显示该对象。这是通过检查该对象的可见性及其祖先来确定的。注：即使另一个对象掩藏了该对象（例如，它碰巧在一个下拉的菜单下面），此方法也将返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果正在显示该对象，则返回 ture；否则返回 false

contains

public boolean contains(Point p)
检查指定的点是否在此对象的边界内，该点的 x 坐标和 y 坐标是相对于该对象的坐标系来定义的。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 相对于该对象的坐标系的 Point
返回：
如果该对象包含 Point，则返回 ture；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
对象在屏幕上的位置——如果此对象不在屏幕上，则可以返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
通过用一个点指定该对象的左上角在屏幕坐标空间中的位置的形式，获取此对象相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
Point 的一个实例，这个 Point 表示了对象边界的左上角在屏幕坐标空间中的位置；如果此对象或其父对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
设置对象相对父对象的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 对象的坐标
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
获取此对象的边界，用 Rectangle 对象的形式表示它。这些边界了指定此对象的宽度、高度和相对其父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
指示该组件的边界的一个矩形；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
设置此对象的边界，用 Rectangle 对象的形式表示它。这些边界了指定此对象的宽度、高度和相对其父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示该组件的边界的一个矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
返回此对象的大小，用 Dimension 对象的形式表示它。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
指示此组件大小的一个 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
调整此对象的大小，使它具有宽度和高度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的尺寸
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。否则返回 null。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 定义 Accessible 左上角的点，在该对象的父对象的坐标空间内给定此点
返回：
如果存在 Accessible，则在指定的位置上返回这个点；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
返回对此对象是否可以接受焦点的判断。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 ture；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
请求使此对象拥有焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
添加指定的焦点侦听器，以接收发自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

java.lang.Object
    继承者  java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
所有已实现的接口：
ComponentListener, EventListener
正在封闭类：
Component.AccessibleAWTComponent
protected class Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
extends Object
implements ComponentListener

当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）

从以下版本开始：
1.3

构造方法摘要
protected Component.AccessibleAWTComponent.AccessibleAWTComponentHandler()
方法摘要
void | componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | componentMoved(ComponentEvent e) 组件位置更改时调用。
void | componentResized(ComponentEvent e) 组件大小更改时调用。
void | componentShown(ComponentEvent e) 组件变得可见时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Component.AccessibleAWTComponent.AccessibleAWTComponentHandler

protected Component.AccessibleAWTComponent.AccessibleAWTComponentHandler()
方法详细信息

componentHidden

public void componentHidden(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件变得不可见时调用。

指定者：
接口 ComponentListener 中的 componentHidden

componentShown

public void componentShown(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件变得可见时调用。

指定者：
接口 ComponentListener 中的 componentShown

componentMoved

public void componentMoved(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件位置更改时调用。

指定者：
接口 ComponentListener 中的 componentMoved

componentResized

public void componentResized(ComponentEvent e)
从接口 ComponentListener 复制的描述
组件大小更改时调用。

指定者：
接口 ComponentListener 中的 componentResized
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Component.BaselineResizeBehavior (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.awt
枚举 Component.BaselineResizeBehavior

java.lang.Object
    继承者  java.lang.Enum<Component.BaselineResizeBehavior>
        继承者  java.awt.Component.BaselineResizeBehavior
所有已实现的接口：
Serializable, Comparable<Component.BaselineResizeBehavior>
正在封闭类：
Component
public static enum Component.BaselineResizeBehavior
extends Enum<Component.BaselineResizeBehavior>

常见方式的枚举，指示组件的基线可以随大小的更改而更改。基线调整行为主要用于布局管理器，在组件大小发生更改时，布局管理器需要知道基线位置的更改方式。通常，在组件大小大于等于最小大小（实际最小大小；不是开发人员指定的最小大小）时，基线调整行为才是有效的。在组件大小小于最小大小的情况下，基线可能以基线调整行为所指示方式之外的某种方式发生更改。类似地，如果大小接近 Integer.MAX_VALUE 和/或 Short.MAX_VALUE，基线可能以基线调整行为所指示方式之外的某种方式发生更改。

从以下版本开始：
1.6
另请参见：
Component.getBaselineResizeBehavior(), Component.getBaseline(int,int)

枚举常量摘要
CENTER_OFFSET
指示基线与组件的中心保持固定的距离。
CONSTANT_ASCENT
指示基线相对于 y 原点保持不变。
CONSTANT_DESCENT
指示基线相对于高度保持不变，且不会随着宽度不同而发生更改。
OTHER
指示基线调整行为无法使用其他任何常量表示。
方法摘要
static Component.BaselineResizeBehavior | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Component.BaselineResizeBehavior[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

CONSTANT_ASCENT

public static final Component.BaselineResizeBehavior CONSTANT_ASCENT
指示基线相对于 y 原点保持不变。也就是说，无论高度或宽度如何，getBaseline 均返回相同的值。例如，包含使用 TOP 垂直对齐方式的非空文本的 JLabel 应该具有 CONSTANT_ASCENT 基线类型。

CONSTANT_DESCENT

public static final Component.BaselineResizeBehavior CONSTANT_DESCENT
指示基线相对于高度保持不变，且不会随着宽度不同而发生更改。也就是说，对于任意高度 H，H 和 getBaseline(w, H) 之间的差值是相同的。例如，包含使用 BOTTOM 垂直对齐方式的非空文本的 JLabel 应该具有 CONSTANT_DESCENT 基线类型。

CENTER_OFFSET

public static final Component.BaselineResizeBehavior CENTER_OFFSET
指示基线与组件的中心保持固定的距离。也就是说，对于任意高度 H，getBaseline(w, H) 和 H / 2 之间的差值是相同的（根据舍入误差加上或减去 1）。

因为可能存在舍入误差，所以建议通过两个连续高度请求（计算）基线，并使用返回值来确定计算结果是否需要值为 1 的 pad。以下显示了如何计算任意高度的基线：

Dimension preferredSize = component.getPreferredSize();
int baseline = getBaseline(preferredSize.width,
preferredSize.height);
int nextBaseline = getBaseline(preferredSize.width,
preferredSize.height + 1);
// Amount to add to height when calculating where baseline
// lands for a particular height:
int padding = 0;
// Where the baseline is relative to the mid point
int baselineOffset = baseline - height / 2;
if (preferredSize.height % 2 == 0 &&
baseline != nextBaseline) {
padding = 1;
   }
else if (preferredSize.height % 2 == 1 &&
baseline == nextBaseline) {
baselineOffset--;
padding = 1;
   }
// The following calculates where the baseline lands for
// the height z:
int calculatedBaseline = (z + padding) / 2 + baselineOffset;

OTHER

public static final Component.BaselineResizeBehavior OTHER
指示基线调整行为无法使用其他任何常量表示。它也可能指示基线随组件宽度的不同而不同。没有基线的组件也会返回它。

方法详细信息

values

public static final Component.BaselineResizeBehavior[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Component.BaselineResizeBehavior c : Component.BaselineResizeBehavior.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Component.BaselineResizeBehavior valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

java.lang.Object
    继承者  java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
Component.AccessibleAWTComponent
protected class Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
extends Object
implements FocusListener

当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）

从以下版本开始：
1.3

构造方法摘要
protected Component.AccessibleAWTComponent.AccessibleAWTFocusHandler()
方法摘要
void | focusGained(FocusEvent event) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent event) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Component.AccessibleAWTComponent.AccessibleAWTFocusHandler

protected Component.AccessibleAWTComponent.AccessibleAWTFocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent event)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent event)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Component.BltBufferStrategy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component.BltBufferStrategy

java.lang.Object
    继承者  java.awt.image.BufferStrategy
        继承者  java.awt.Component.BltBufferStrategy
正在封闭类：
Component
protected class Component.BltBufferStrategy
extends BufferStrategy

用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。

从以下版本开始：
1.4

字段摘要
protected VolatileImage[] | backBuffers 后台缓冲区
protected BufferCapabilities | caps 缓冲区能力
protected int | height
protected boolean | validatedContents 绘制缓冲区最近是否已经从丢失状态中恢复。
protected int | width 后台缓冲区的大小
构造方法摘要
protected Component.BltBufferStrategy(int numBuffers, BufferCapabilities caps)
围绕组件创建一个新的 blt 缓冲区策略
方法摘要
boolean | contentsLost() 返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。
boolean | contentsRestored() 返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。
protected void | createBackBuffers(int numBuffers) 创建后台缓冲区
void | dispose() 释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
BufferCapabilities | getCapabilities() 返回此 BufferStrategy 的 BufferCapabilities。
Graphics | getDrawGraphics() 创建用于绘制缓冲区的图形上下文。
protected void | revalidate() 如果绘制缓冲区已经丢失，则恢复它
void | show() 使下一个有效缓冲区可见。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

caps

protected BufferCapabilities caps
缓冲区能力

backBuffers

protected VolatileImage[] backBuffers
后台缓冲区

validatedContents

protected boolean validatedContents
绘制缓冲区最近是否已经从丢失状态中恢复。

width

protected int width
后台缓冲区的大小

height

protected int height
构造方法详细信息

Component.BltBufferStrategy

protected Component.BltBufferStrategy(int numBuffers,
                                      BufferCapabilities caps)
围绕组件创建一个新的 blt 缓冲区策略

参数：
numBuffers - 要创建的缓冲区数，包括前台缓冲区
caps - 缓冲区能力
方法详细信息

dispose

public void dispose()
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。在调用此方法之后，getBufferStrategy 将返回 null。试图在释放 BufferStrategy 后使用它将导致不确定的行为。

覆盖：
类 BufferStrategy 中的 dispose
从以下版本开始：
1.6
另请参见：
Component.createBufferStrategy(int), Component.getBufferStrategy()

createBackBuffers

protected void createBackBuffers(int numBuffers)
创建后台缓冲区

getCapabilities

public BufferCapabilities getCapabilities()
从类 BufferStrategy 复制的描述
返回此 BufferStrategy 的 BufferCapabilities。

指定者：
类 BufferStrategy 中的 getCapabilities
返回：
此策略的缓冲区能力

getDrawGraphics

public Graphics getDrawGraphics()
从类 BufferStrategy 复制的描述
创建用于绘制缓冲区的图形上下文。由于性能的原因，此方法可能不是同步的；多个线程使用此方法时，应该在应用层对其进行处理。对所得到的图形对象的释放必须由应用程序来处理。

指定者：
类 BufferStrategy 中的 getDrawGraphics
返回：
绘制的图形

show

public void show()
使下一个有效缓冲区可见。

指定者：
类 BufferStrategy 中的 show

revalidate

protected void revalidate()
如果绘制缓冲区已经丢失，则恢复它

contentsLost

public boolean contentsLost()
从类 BufferStrategy 复制的描述
返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。由于使用缓冲区策略的缓冲区通常是 VolatileImage 类型的，因此它们有可能丢失。有关对丢失缓冲区的讨论，请参阅 VolatileImage。

指定者：
类 BufferStrategy 中的 contentsLost
返回：
最后一次调用 getDrawGraphics 之后，绘制缓冲区是否丢失
另请参见：
VolatileImage

contentsRestored

public boolean contentsRestored()
从类 BufferStrategy 复制的描述
返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。由于使用缓冲区策略的缓冲区通常是 VolatileImage 类型的，因此它们有可能丢失。如果上次调用 getDrawGraphics 后，缓冲区最近已从丢失状态恢复，则缓冲区可能要求重新绘制。有关对丢失缓冲区的讨论，请参阅 VolatileImage。

指定者：
类 BufferStrategy 中的 contentsRestored
返回：
绘制缓冲区最近是否从丢失状态中恢复，并且重新初始化为默认的背景色（白色）
另请参见：
VolatileImage
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Component.FlipBufferStrategy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Component.FlipBufferStrategy

java.lang.Object
    继承者  java.awt.image.BufferStrategy
        继承者  java.awt.Component.FlipBufferStrategy
正在封闭类：
Component
protected class Component.FlipBufferStrategy
extends BufferStrategy

在组件上翻转缓冲区的内部类。该组件必须是 Canvas 或 Window。

从以下版本开始：
1.4
另请参见：
Canvas, Window, BufferStrategy

字段摘要
protected BufferCapabilities | caps 缓冲能力。
protected Image | drawBuffer 绘制缓冲区。
protected VolatileImage | drawVBuffer 作为可变图像的绘制缓冲区。
protected int | numBuffers 缓冲区的数目。
protected boolean | validatedContents 绘制缓冲区是否已从最近的丢失状态还原。
构造方法摘要
protected Component.FlipBufferStrategy(int numBuffers, BufferCapabilities caps)
为此组件创建新的翻转缓冲区策略。
方法摘要
boolean | contentsLost() 返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。
boolean | contentsRestored() 返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。
protected void | createBuffers(int numBuffers, BufferCapabilities caps) 创建一个或多个具有给定能力的、复杂的翻转缓冲区。
protected void | destroyBuffers() 销毁通过此对象所创建的缓冲区。
void | dispose() 释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
protected void | flip(BufferCapabilities.FlipContents flipAction) 将底层缓冲区的内容翻转移动到前台缓冲区，可通过复制或移动视频指针来执行。
protected Image | getBackBuffer()
BufferCapabilities | getCapabilities() 返回此 BufferStrategy 的 BufferCapabilities。
Graphics | getDrawGraphics() 创建用于绘制缓冲区的图形上下文。
protected void | revalidate() 如果绘制缓冲区已丢失，则将其还原。
void | show() 通过位图传送或翻转，使下一个可用的缓冲区可见。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

numBuffers

protected int numBuffers
缓冲区的数目。

caps

protected BufferCapabilities caps
缓冲能力。

drawBuffer

protected Image drawBuffer
绘制缓冲区。

drawVBuffer

protected VolatileImage drawVBuffer
作为可变图像的绘制缓冲区。

validatedContents

protected boolean validatedContents
绘制缓冲区是否已从最近的丢失状态还原。

构造方法详细信息

Component.FlipBufferStrategy

protected Component.FlipBufferStrategy(int numBuffers,
                                       BufferCapabilities caps)
                                throws AWTException
为此组件创建新的翻转缓冲区策略。该组件必须是 Canvas 或 Window。

参数：
numBuffers - 缓冲区的数目
caps - 缓冲区的能力
抛出：
AWTException - 如果不支持或无法满足所提供的能力
ClassCastException - 如果该组件不是 canvas 或 window。
另请参见：
Canvas, Window
方法详细信息

createBuffers

protected void createBuffers(int numBuffers,
                             BufferCapabilities caps)
                      throws AWTException
创建一个或多个具有给定能力的、复杂的翻转缓冲区。

参数：
numBuffers - 要创建的缓冲区数；必须大于 1
caps - 缓冲区的能力。BufferCapabilities.isPageFlipping 必须为 true。
抛出：
AWTException - 如果不支持或无法满足所提供的能力
IllegalStateException - 如果组件没有同位体
IllegalArgumentException - 如果 numBuffers 小于 2，或者 BufferCapabilities.isPageFlipping 不为 true。
另请参见：
BufferCapabilities.isPageFlipping()

getBackBuffer

protected Image getBackBuffer()
返回：
直接访问作为图像的底层缓冲区。
抛出：
IllegalStateException - 如果尚未创建该缓冲区

flip

protected void flip(BufferCapabilities.FlipContents flipAction)
将底层缓冲区的内容翻转移动到前台缓冲区，可通过复制或移动视频指针来执行。

参数：
flipAction - 一个整数值，用于描述底层缓冲区内容的翻转操作。这应该是 BufferCapabilities.FlipContents 属性值之一。
抛出：
IllegalStateException - 如果尚未创建该缓冲区
另请参见：
BufferCapabilities.getFlipContents()

destroyBuffers

protected void destroyBuffers()
销毁通过此对象所创建的缓冲区。

getCapabilities

public BufferCapabilities getCapabilities()
从类 BufferStrategy 复制的描述
返回此 BufferStrategy 的 BufferCapabilities。

指定者：
类 BufferStrategy 中的 getCapabilities
返回：
此策略的缓冲能力。

getDrawGraphics

public Graphics getDrawGraphics()
从类 BufferStrategy 复制的描述
创建用于绘制缓冲区的图形上下文。由于性能的原因，此方法可能不是同步的；多个线程使用此方法时，应该在应用层对其进行处理。对所得到的图形对象的释放必须由应用程序来处理。

指定者：
类 BufferStrategy 中的 getDrawGraphics
返回：
绘制缓冲区中的图形。由于性能的原因，此方法可能不是同步的；多个线程使用此方法时，应该在相应的层对其进行处理。图形对象的移除必须由应用程序来处理。

revalidate

protected void revalidate()
如果绘制缓冲区已丢失，则将其还原。

contentsLost

public boolean contentsLost()
从类 BufferStrategy 复制的描述
返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。由于使用缓冲区策略的缓冲区通常是 VolatileImage 类型的，因此它们有可能丢失。有关对丢失缓冲区的讨论，请参阅 VolatileImage。

指定者：
类 BufferStrategy 中的 contentsLost
返回：
自从最后一次调用 getDrawGraphics 后是否丢失了绘制缓冲区。
另请参见：
VolatileImage

contentsRestored

public boolean contentsRestored()
从类 BufferStrategy 复制的描述
返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。由于使用缓冲区策略的缓冲区通常是 VolatileImage 类型的，因此它们有可能丢失。如果上次调用 getDrawGraphics 后，缓冲区最近已从丢失状态恢复，则缓冲区可能要求重新绘制。有关对丢失缓冲区的讨论，请参阅 VolatileImage。

指定者：
类 BufferStrategy 中的 contentsRestored
返回：
最近是否从丢失中还原了绘制缓冲区并且将其重新初始化为默认的背景色（白色）。
另请参见：
VolatileImage

show

public void show()
通过位图传送或翻转，使下一个可用的缓冲区可见。

指定者：
类 BufferStrategy 中的 show

dispose

public void dispose()
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。在调用此方法之后，getBufferStrategy 将返回 null。试图在释放 BufferStrategy 后使用它将导致不确定的行为。

覆盖：
类 BufferStrategy 中的 dispose
从以下版本开始：
1.6
另请参见：
Component.createBufferStrategy(int), Component.getBufferStrategy()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentOrientation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 ComponentOrientation

java.lang.Object
    继承者  java.awt.ComponentOrientation
所有已实现的接口：
Serializable
public final class ComponentOrientation
extends Object
implements Serializable

ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。使用它可反映西方字母表、中东字母表（如希伯来语）和远东字母表（如日语）之间此种排序的差别。

从根本上讲，此类管理在行中布局的各项（如字符），以及各行在块中的布局。这也适用于小部件中的各项：例如在一个复选框中，相对于文本而言该框的定位。

现代语言中使用了 4 种不同的方向，如下表所示。

 LT          RT          TL          TR
 A B C       C B A       A D G       G D A
 D E F       F E D       B E H       H E B
 G H I       I H G       C F I       I F C

（在标题中，两字母缩写中的首个字母表示项的方向，第二个字母表示行的方向。例如，LT 意味着“项从左到右，行从上到下”，TL 则意味着“项从上到下，行从左到右”，依此类推。）

方向有：

  • LT - 西欧（可选用于日语、汉语、韩语）
  • RT - 中东（阿拉伯语、希伯来语）
  • TR - 日语、汉语、韩语
  • TL - 蒙古语
其视图和控制器代码依靠方向的组件应该使用 isLeftToRight() 和 isHorizontal() 方法来确定其行为。这些组件不应包括类似于开关的代码来切换常量，如：
 if (orientation == LEFT_TO_RIGHT) {
   ...
 } else if (orientation == RIGHT_TO_LEFT) {
   ...
 } else {
   // Oops
 }
因为以后可能添加更多的常量，以及无法保证方向对象是惟一的，所以这是不安全的。

另请参见：
序列化表格

字段摘要
static ComponentOrientation | LEFT_TO_RIGHT 各项从左到右布局，各行从上到下，示例：英语、法语。
static ComponentOrientation | RIGHT_TO_LEFT 各项从右到左布局，各行从上到下，示例：阿拉伯语、希伯来语。
static ComponentOrientation | UNKNOWN 表示尚未设置组件的方向。
方法摘要
static ComponentOrientation | getOrientation(Locale locale) 返回适合于给定区域的方向。
static ComponentOrientation | getOrientation(ResourceBundle bdl) 已过时。 在 J2SE 1.4 中，使用 getOrientation(java.util.Locale)。
boolean | isHorizontal() 各行是水平的？这将为水平的、从左到右的书写系统（如罗马语）返回 true。
boolean | isLeftToRight() 水平行：各项从左到右布局？ 垂直行：各行从左到右布局？ 这将为水平的、从左到右的书写系统（如罗马语）返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LEFT_TO_RIGHT

public static final ComponentOrientation LEFT_TO_RIGHT
各项从左到右布局，各行从上到下，示例：英语、法语。

RIGHT_TO_LEFT

public static final ComponentOrientation RIGHT_TO_LEFT
各项从右到左布局，各行从上到下，示例：阿拉伯语、希伯来语。

UNKNOWN

public static final ComponentOrientation UNKNOWN
表示尚未设置组件的方向。要保持现有应用程序的行为，isLeftToRight 将为此值返回 true。

方法详细信息

isHorizontal

public boolean isHorizontal()
各行是水平的？这将为水平的、从左到右的书写系统（如罗马语）返回 true。

isLeftToRight

public boolean isLeftToRight()
水平行：各项从左到右布局？
垂直行：各行从左到右布局？
这将为水平的、从左到右的书写系统（如罗马语）返回 true。

getOrientation

public static ComponentOrientation getOrientation(Locale locale)
返回适合于给定区域的方向。

参数：
locale - 指定的区域

getOrientation

@Deprecated
public static ComponentOrientation getOrientation(ResourceBundle bdl)
已过时。 在 J2SE 1.4 中，使用 getOrientation(java.util.Locale)。

返回适合于给定 ResourceBundle 的本地化的方向。按下列顺序尝试三种方法：
  1. 使用字符串 "Orientation" 作为关键字从 ResourceBundle 中检索 ComponentOrientation 对象。
  2. 使用 ResourceBundle.getLocale 确定资源包的区域，然后返回该区域的方向。
  3. 返回默认区域的方向。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Composite (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 Composite

所有已知实现类：
AlphaComposite
public interface Composite

Composite 接口和 CompositeContext 一起定义了用基础图形区域组合绘图基本元素的方法。在 Graphics2D 上下文中设置 Composite 后，此接口组合形状、文本或图像，这些内容已经用根据预定义的规则所呈现的颜色进行了呈现。实现此接口的类提供规则和方法来创建特定操作的上下文。CompositeContext 是复合操作所使用的环境，由 Graphics2D 在操作开始前创建。CompositeContext 包含复合操作所需的私有信息和资源。当不再需要 CompositeContext 时，Graphics2D 对象会移除它，以便回收为操作所分配的资源。

实现 Composite 的类实例必须是不可变的，因为将这些对象作为 setComposite 方法的属性来设置时，或者 Graphics2D 对象被复制时，Graphics2D 并不复制这些对象。这是为了避免 Graphics2D 未定义的呈现行为，这种行为是在 Graphics2D 上下文中设置 Composite 对象后再对其进行修改所导致的。

由于此接口必须向可能的任意代码公开目标设备或图像上的像素内容，所以在直接向屏幕设备呈现内容时，由 readDisplayPixels AWTPermission 负责管理那些实现此接口的自定义对象的使用。将这样的自定义对象传递给 Graphics2D（从 Component 检索）的 setComposite 方法时会进行权限检查。

另请参见：
AlphaComposite, CompositeContext, Graphics2D.setComposite(java.awt.Composite)

方法摘要
 CompositeContext createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints)
创建一个上下文，其中包含用于执行复合操作的状态。

方法详细信息

createContext

CompositeContext createContext(ColorModel srcColorModel,
                               ColorModel dstColorModel,
                               RenderingHints hints)
创建一个上下文，其中包含用于执行复合操作的状态。在多线程环境中，单个 Composite 对象可同时有多个上下文。

参数：
srcColorModel - 源的 ColorModel
dstColorModel - 目标的 ColorModel
hints - 上下文对象用于选择呈现方法的提示
返回：
用于执行复合操作的 CompositeContext 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompositeContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 CompositeContext

public interface CompositeContext

CompositeContext 接口为复合操作定义了已封装和已优化的环境。CompositeContext 对象维护复合操作的状态。在多线程环境中，单个 Composite 对象可同时有多个上下文。

另请参见：
Composite

方法摘要
void | compose(Raster src, Raster dstIn, WritableRaster dstOut) 组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。
void | dispose() 释放分配给上下文的资源。

方法详细信息

dispose

void dispose()
释放分配给上下文的资源。

compose

void compose(Raster src,
             Raster dstIn,
             WritableRaster dstOut)
组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。注意，目标可以是第一个或第二个源对象。注意，dstIn 和 dstOut 必须与传递给 Composite 接口的 (java.awt.image.ColorModel、java.awt.image.ColorModel、java.awt.RenderingHints) createContext 方法的 dstColorModel 兼容。

参数：
src - 复合操作的第一个源
dstIn - 复合操作的第二个源
dstOut - 存储操作结果的 WritableRaster
另请参见：
Composite
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Container (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Container

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
所有已实现的接口：
ImageObserver, MenuContainer, Serializable
直接已知子类：
BasicSplitPaneDivider, CellRendererPane, DefaultTreeCellEditor.EditorContainer, JComponent, Panel, ScrollPane, Window
public class Container
extends Component

一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。

添加到容器中的组件放在一个列表中。列表的顺序将定义组件在容器内的正向堆栈顺序。如果将组件添加到容器中时未指定索引，则该索引将被添加到列表尾部（此后它位于堆栈顺序的底部）。

注：有关焦点子系统的详细信息，请参阅 The Java Tutorial 中 How to Use the Focus Subsystem 一节，要获得更多的信息，请参阅 Focus Specification。

从以下版本开始：
JDK1.0
另请参见：
add(java.awt.Component, int), getComponent(int), LayoutManager, 序列化表格

嵌套类摘要
protected  class Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Container()
构造一个新的 Container。
方法摘要
 Component add(Component comp)
将指定组件追加到此容器的尾部。
 Component add(Component comp, int index)
将指定组件添加到此容器的给定位置上。
 void add(Component comp, Object constraints)
将指定的组件添加到此容器的尾部。
 void add(Component comp, Object constraints, int index)
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。
 Component add(String name, Component comp)
将指定组件添加到此容器中。
 void addContainerListener(ContainerListener l)
添加指定容器的侦听器，以接收来自此容器的容器事件。
protected  void addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。
 void addNotify()
通过将这个 Container 连接到本机屏幕资源，使其可以显示。
 void addPropertyChangeListener(PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到侦听器列表中。
 void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。
 void applyComponentOrientation(ComponentOrientation o)
设置此容器和其中包含的所有组件的 ComponentOrientation 属性。
 boolean areFocusTraversalKeysSet(int id)
返回是否已经为此 Container 明确定义了用于给定焦点遍历操作的焦点遍历键的 Set。
 int countComponents()
已过时。 从 JDK version 1.1 开始，用 etComponentCount() 取代。
 void deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
 void doLayout()
使此容器布置其组件。
 Component findComponentAt(int x, int y)
对包含指定位置的可视子组件进行定位。
 Component findComponentAt(Point p)
对包含指定点的可视子组件进行定位。
 float getAlignmentX()
返回沿 x 轴的对齐方式。
 float getAlignmentY()
返回沿 y 轴的对齐方式。
 Component getComponent(int n)
获取此容器中的第 n 个组件。
 Component getComponentAt(int x, int y)
对包含 x，y 位置的组件进行定位。
 Component getComponentAt(Point p)
获取包含指定点的组件。
 int getComponentCount()
获取此面板中的组件数。
 Component[] getComponents()
获取此容器中的所有组件。
 int getComponentZOrder(Component comp)
返回容器内组件的 z 顺序索引。
 ContainerListener[] getContainerListeners()
返回已在此容器上注册的所有容器侦听器的数组。
 Set<AWTKeyStroke> getFocusTraversalKeys(int id)
为此 Container 的给定遍历操作返回焦点遍历键的 Set。
 FocusTraversalPolicy getFocusTraversalPolicy()
返回焦点遍历策略，用于管理此 Container 子组件的键盘遍历；如果此 Container 不是一个焦点循环根，则返回 null。
 Insets getInsets()
确定此容器的 insets，它指示容器边框的大小。
 LayoutManager getLayout()
获取此容器的布局管理器。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
 Dimension getMaximumSize()
返回此容器的最大大小。
 Dimension getMinimumSize()
返回此容器的最小大小。
 Point getMousePosition(boolean allowChildren)
如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。
 Dimension getPreferredSize()
返回此容器的首选大小。
 Insets insets()
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。
 void invalidate()
使容器失效。
 boolean isAncestorOf(Component c)
检查该组件是否包含在此容器的组件层次结构中。
 boolean isFocusCycleRoot()
返回此 Container 是否是某个焦点遍历循环的根。
 boolean isFocusCycleRoot(Container container)
返回指定的 Container 是否是此 Container 的焦点遍历循环的焦点循环根。
 boolean isFocusTraversalPolicyProvider()
返回此容器是否提供焦点遍历策略。
 boolean isFocusTraversalPolicySet()
返回是否为此 Container 明确设置焦点遍历策略。
 void layout()
已过时。 从 JDK version 1.1，用 doLayout() 取代。
 void list(PrintStream out, int indent)
将此容器的清单打印到指定输出流。
 void list(PrintWriter out, int indent)
将一个列表打印到指定打印编写器，从指定缩排位置开始。
 Component locate(int x, int y)
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
 Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。
 void paint(Graphics g)
绘制容器。
 void paintComponents(Graphics g)
绘制此容器中的每个组件。
protected  String paramString()
返回表示此 Container 的状态的字符串。
 Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。
 void print(Graphics g)
打印容器。
 void printComponents(Graphics g)
打印此容器中的每个组件。
protected  void processContainerEvent(ContainerEvent e)
通过将发生在此容器上的容器事件指派给所有已注册的 ContainerListener 对象来处理这些事件。
protected  void processEvent(AWTEvent e)
处理关于此容器的事件。
 void remove(Component comp)
从此容器中移除指定组件。
 void remove(int index)
从此容器中移除 index 指定的组件。
 void removeAll()
从此容器中移除所有组件。
 void removeContainerListener(ContainerListener l)
移除指定容器的侦听器，从而不再接收来自此容器的容器事件。
 void removeNotify()
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。
 void setComponentZOrder(Component comp, int index)
将指定组件移动到容器中指定的 z 顺序索引。
 void setFocusCycleRoot(boolean focusCycleRoot)
设置此 Container 是否是某个焦点遍历循环的根。
 void setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
为此 Container 的给定遍历操作设置焦点遍历键。
 void setFocusTraversalPolicy(FocusTraversalPolicy policy)
如果此 Container 是一个焦点循环根，则设置将管理此 Container 的子代的键盘遍历的焦点遍历策略。
 void setFocusTraversalPolicyProvider(boolean provider)
设置是否将用此容器提供焦点遍历策略。
 void setFont(Font f)
设置此容器的字体。
 void setLayout(LayoutManager mgr)
设置此容器的布局管理器。
 void transferFocusBackward()
将焦点转移到前一个组件，就好像此 Component 曾是焦点所有者。
 void transferFocusDownCycle()
将焦点向下传输一个焦点遍历循环。
 void update(Graphics g)
更新容器。
 void validate()
验证此容器及其所有子组件。
protected  void validateTree()
递归继承容器树，对于所有被标记为需要重新计算布局的子树（标记为无效的那些子树）重新计算布局。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAccessibleContext, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Container

public Container()
构造一个新的 Container。可以直接扩展 Container，但在这种情况下是轻量级的，并且它必须被位于本机组件树中更高处的某一个父容器包含。（比如说 Frame）。

方法详细信息

getComponentCount

public int getComponentCount()
获取此面板中的组件数。

返回：
此面板中的组件数。
从以下版本开始：
JDK1.1
另请参见：
getComponent(int)

countComponents

@Deprecated
public int countComponents()
已过时。 从 JDK version 1.1 开始，用 etComponentCount() 取代。

getComponent

public Component getComponent(int n)
获取此容器中的第 n 个组件。

参数：
n - 要获取的组件的索引。
返回：
此容器中的 nth 组件。
抛出：
ArrayIndexOutOfBoundsException - 如果 nth 值不存在。

getComponents

public Component[] getComponents()
获取此容器中的所有组件。

返回：
此容器中的所有组件的数组。

getInsets

public Insets getInsets()
确定此容器的 insets，它指示容器边框的大小。

例如，Frame 对象有一个顶端 inset，它对应于窗体的标题栏的高度。

返回：
此容器的 inset。
从以下版本开始：
JDK1.1
另请参见：
Insets, LayoutManager

insets

@Deprecated
public Insets insets()
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。

add

public Component add(Component comp)
将指定组件追加到此容器的尾部。这是一个适用于 addImpl(java.awt.Component, java.lang.Object, int) 的便捷方法。

注：如果已经将某个组件添加到显示的容器中，则必须在此容器上调用 validate，以显示新的组件。如果添加多个组件，那么可以在添加所有组件之后，通过只调用一次 validate 来提高效率。

参数：
comp - 要添加的组件
返回：
component 参数
抛出：
NullPointerException - 如果 comp 为 null
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
validate(),
JComponent.revalidate()

add

public Component add(String name,
                     Component comp)
将指定组件添加到此容器中。这是一个适用于 addImpl(java.awt.Component, java.lang.Object, int) 的便捷方法。

从 JDK version 1.1 开始，此方法已过时。请使用 add(Component, Object) 方法代替。

抛出：
NullPointerException - 如果 comp 为 null
另请参见：
add(Component, Object)

add

public Component add(Component comp,
                     int index)
将指定组件添加到此容器的给定位置上。这是一个适用于 addImpl(java.awt.Component, java.lang.Object, int) 的便捷方法。

注：如果已经将某个组件添加到显示的容器中，则必须在此容器上调用 validate，以显示新的组件。如果添加多个组件，那么可以在添加所有组件之后，通过只调用一次 validate 来提高效率。

参数：
comp - 要添加的组件
index - 插入组件的位置，-1 表示将组件追加到尾部
返回：
组件 comp
抛出：
NullPointerException - 如果 comp 为 null
IllegalArgumentException - 如果 index 无效（有关细节请参阅 addImpl(java.awt.Component, java.lang.Object, int)）
另请参见：
addImpl(java.awt.Component, java.lang.Object, int), remove(int), validate(), JComponent.revalidate()

setComponentZOrder

public void setComponentZOrder(Component comp,
                               int index)
将指定组件移动到容器中指定的 z 顺序索引。z 顺序确定了绘制组件的顺序；具有最高 z 顺序的组件将第一个绘制，而具有最低 z 顺序的组件将最后一个绘制。在组件重叠的地方，具有较低 z 顺序的组件将覆盖具有较高 z 顺序的组件。

如果组件是其他某个 container 的子组件，则在将它添加到此容器之前，从该容器中移除它。此方法与 java.awt.Container.add(Component, int) 之间的重要不同是，在将组件从其以前的容器中移除时，此方法不对该组件调用 removeNotify，除非有此必要，并且基础本机窗口系统允许这样做。因此，如果组件拥有键盘焦点，那么在移动到新的位置上时，它会维持该焦点。

要保证此属性只应用于轻量级的非 Container 组件。

注：并不是所有的平台都支持在不调用 removeNotify 的情况下，将重量级组件的 z 顺序从一个容器更改到另一个容器中。无法检测某个平台是否支持这一点，因此开发人员不应该作出任何假设。

参数：
comp - 要移动的组件
index - 在容器的列表中插入组件的位置，其中 getComponentCount() 指追加到尾部
抛出：
NullPointerException - 如果 comp 为 null
IllegalArgumentException - 如果 comp 是该容器的父容器之一
IllegalArgumentException - 如果在容器间移动的 index 不在 [0, getComponentCount()] 范围内，或者在容器内移动的 index 不在 [0, getComponentCount()-1] 范围内
IllegalArgumentException - 如果将一个容器添加给其自身
IllegalArgumentException - 如果将 Window 添加到容器中
从以下版本开始：
1.5
另请参见：
getComponentZOrder(java.awt.Component)

getComponentZOrder

public int getComponentZOrder(Component comp)
返回容器内组件的 z 顺序索引。组件在 z 顺序层次结构中所处的位置越高，它的索引就越低。具有最低 z 顺序索引的组件最后一个被绘制，而它在层次结构中高于其他所有子组件。

参数：
comp - 正查询的组件
返回：
组件的 z 顺序索引；如果 component 为 null 或者不属于该容器，则返回 -1
从以下版本开始：
1.5
另请参见：
setComponentZOrder(java.awt.Component, int)

add

public void add(Component comp,
                Object constraints)
将指定的组件添加到此容器的尾部。同时通知布局管理器使用指定的 constraints 对象将组件添加到此容器的布局中。这是一个适用于 addImpl(java.awt.Component, java.lang.Object, int) 的便捷方法。

注：如果已经将某个组件添加到显示的容器中，则必须在此容器上调用 validate，以显示新的组件。如果添加多个组件，那么可以在添加所有组件之后，通过只调用一次 validate 来提高效率。

参数：
comp - 要添加的组件
constraints - 表示此组件的布局约束的对象
抛出：
NullPointerException - 如果 comp 为 null
从以下版本开始：
JDK1.1
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
validate(),
JComponent.revalidate(),
LayoutManager

add

public void add(Component comp,
                Object constraints,
                int index)
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。还要通知布局管理器，使用指定的约束对象将组件添加到此容器的布局中。这是一个适用于 addImpl(java.awt.Component, java.lang.Object, int) 的便捷方法。

注：如果已经将某个组件添加到显示的容器中，则必须在此容器上调用 validate，以显示新的组件。如果添加多个组件，那么可以在添加所有组件之后，通过只调用一次 validate 来提高效率。

参数：
comp - 要添加的组件
constraints - 表示此组件的布局约束的对象
index - 容器列表中插入组件的位置；-1 表示将组件插入尾部
抛出：
NullPointerException - 如果 comp 为 null
IllegalArgumentException - 如果 index 无效（有关细节请参阅 addImpl(java.awt.Component, java.lang.Object, int)）
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
validate(),
JComponent.revalidate(),
remove(int),
LayoutManager

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
将指定组件添加到此容器的指定索引所在的位置上。此方法还通知布局管理器，通过 addLayoutComponent 方法，使用指定的约束对象将组件添加到此容器的布局中。

这些约束是由正使用的特定布局管理器定义的。例如，BorderLayout 类定义了五个约束：BorderLayout.NORTH、BorderLayout.SOUTH、BorderLayout.EAST、BorderLayout.WEST 和 BorderLayout.CENTER。

GridBagLayout 类需要一个 GridBagConstraints 对象。如果传递正确的约束对象类型时失败，则会导致 IllegalArgumentException。

如果当前布局管理器实现了 LayoutManager2，则在其上调用 LayoutManager2.addLayoutComponent(Component,Object)。如果当前布局管理器没有实现 LayoutManager2，并且约束是一个 String，则在其上调用 LayoutManager.addLayoutComponent(String,Component)。

如果该组件不是此容器的祖先容器，并且有一个非 null 父组件，则在将该组件添加到此容器之前，从其当前父组件中移除它。

在其他所有添加方法引用此方法时，如果某个程序需要追踪每个添加到容器的请求，那么这就是要重写的方法。被重写的方法通常应该包括一个对该方法的超类版本的调用：

super.addImpl(comp, constraints, index)

参数：
comp - 要添加的组件
constraints - 表示此组件的布局约束的对象
容器列表中插入组件的位置；其中 - -1 表示将组件追加到尾部
抛出：
IllegalArgumentException - 如果 index 无效；如果 comp 是此容器的子容器，则有效范围是 [-1, getComponentCount()-1]；如果组件不是此容器的子容器，则有效范围是 [-1, getComponentCount()]
IllegalArgumentException - 如果 comp 是此容器的祖先容器
IllegalArgumentException - 如果向容器添加一个窗口
NullPointerException - 如果 comp 为 null
从以下版本开始：
JDK1.1
另请参见：
add(Component), add(Component, int), add(Component, java.lang.Object), LayoutManager, LayoutManager2

remove

public void remove(int index)
从此容器中移除 index 指定的组件。此方法还通知布局管理器，通过 removeLayoutComponent 方法从此容器的布局中移除该组件。

注：如果已经从已显示的容器中移除一个组件，则必须在该容器上调用 validate() 来反映更改。如果移除多个组件，那么可以在移除所有组件之后，通过只调用一次 validate() 来提高效率。

参数：
index - 要移除的组件的索引
抛出：
ArrayIndexOutOfBoundsException - 如果 index 不在范围 [0, getComponentCount()-1] 内
从以下版本开始：
JDK1.1
另请参见：
add(java.awt.Component),
validate(),
getComponentCount()

remove

public void remove(Component comp)
从此容器中移除指定组件。此方法还通知布局管理器，通过 removeLayoutComponent 方法从此容器的布局中移除该组件。

注：如果已经从已显示的容器中移除一个组件，则必须在该容器上调用 validate() 来反映更改。如果移除多个组件，那么可以在移除所有组件之后，通过只调用一次 validate() 来提高效率。

参数：
comp - 要移除的组件
另请参见：
add(java.awt.Component),
validate(),
remove(int)

removeAll

public void removeAll()
从此容器中移除所有组件。此方法还通知布局管理器，通过 removeLayoutComponent 方法从此容器的布局中移除这些组件。

另请参见：
add(java.awt.Component), remove(int)

getLayout

public LayoutManager getLayout()
获取此容器的布局管理器。

另请参见：
doLayout(), setLayout(java.awt.LayoutManager)

setLayout

public void setLayout(LayoutManager mgr)
设置此容器的布局管理器。

参数：
mgr - 指定的布局管理器
另请参见：
doLayout(), getLayout()

doLayout

public void doLayout()
使此容器布置其组件。大部分程序不应该直接调用此方法，而是应该调用 validate 方法。

覆盖：
类 Component 中的 doLayout
从以下版本开始：
JDK1.1
另请参见：
LayoutManager.layoutContainer(java.awt.Container),
setLayout(java.awt.LayoutManager),
validate()

layout

@Deprecated
public void layout()
已过时。 从 JDK version 1.1，用 doLayout() 取代。

覆盖：
类 Component 中的 layout

invalidate

public void invalidate()
使容器失效。该容器及其之上的所有父容器被标记为需要重新布置。此方法经常被调用，所以必须快速执行它。

如果在此容器上安装的 LayoutManager 是一个 LayoutManager2 实例，则在该实例上调用 LayoutManager2.invalidateLayout(Container)，并提供此 Container 作为参数。

覆盖：
类 Component 中的 invalidate
另请参见：
validate(), layout(), LayoutManager, LayoutManager2.invalidateLayout(Container)

validate

public void validate()
验证此容器及其所有子组件。

使用 validate 方法会使容器再次布置其子组件。已经显示容器后，在修改此容器的子组件的时候（在容器中添加或移除组件，或者更改与布局相关的信息），应该调用上述方法。

如果此 Container 无效，则此方法将调用 validateTree 方法，并将此 Container 标记为有效。否则不执行任何动作。

覆盖：
类 Component 中的 validate
另请参见：
add(java.awt.Component),
Component.invalidate(),
JComponent.revalidate(),
validateTree()

validateTree

protected void validateTree()
递归继承容器树，对于所有被标记为需要重新计算布局的子树（标记为无效的那些子树）重新计算布局。同步应该由调用本方法的方法 (validate) 提供。

另请参见：
doLayout(), validate()

setFont

public void setFont(Font f)
设置此容器的字体。

覆盖：
类 Component 中的 setFont
参数：
f - 将成为此容器的字体的字体。
从以下版本开始：
JDK1.0
另请参见：
Component.getFont()

getPreferredSize

public Dimension getPreferredSize()
返回此容器的首选大小。如果尚未通过 Component.setPreferredSize(Dimension) 显式设置首选大小，并且此 Container 有一个 non-null LayoutManager，则使用 LayoutManager.preferredLayoutSize(Container) 来计算首选大小。

注：一些实现可能缓存从 LayoutManager 返回的值。每次调用此方法时，这些缓存实现不需要在 LayoutManager 上调用 preferredLayoutSize，而是只在 Container 变得无效之后查询 LayoutManager。

覆盖：
类 Component 中的 getPreferredSize
返回：
表示此容器的首选大小的 Dimension 实例。
另请参见：
getMinimumSize(),
getMaximumSize(),
getLayout(),
LayoutManager.preferredLayoutSize(Container),
Component.getPreferredSize()

preferredSize

@Deprecated
public Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。

覆盖：
类 Component 中的 preferredSize

getMinimumSize

public Dimension getMinimumSize()
返回此容器的最小大小。如果尚未通过 Component.setMinimumSize(Dimension) 显式设置最小大小，并且此 Container 有一个 non-null LayoutManager，则使用 LayoutManager.minimumLayoutSize(Container) 来计算最小大小。

注：一些实现可能缓存从 LayoutManager 返回的值。每次调用此方法时，这些缓存实现不需要在 LayoutManager 上调用 minimumLayoutSize，而是只在 Container 变得无效之后查询 LayoutManager。

覆盖：
类 Component 中的 getMinimumSize
返回：
表示此容器的最小大小的 Dimension 实例。
从以下版本开始：
JDK1.1
另请参见：
getPreferredSize(),
getMaximumSize(),
getLayout(),
LayoutManager.minimumLayoutSize(Container),
Component.getMinimumSize()

minimumSize

@Deprecated
public Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。

覆盖：
类 Component 中的 minimumSize

getMaximumSize

public Dimension getMaximumSize()
返回此容器的最大大小。如果尚未通过 Component.setMaximumSize(Dimension) 显式设置最大大小，并且在此 Container 上安装的 LayoutManager 是一个 LayoutManager2 实例，则使用 LayoutManager2.maximumLayoutSize(Container) 来计算最大大小。

注：一些实现可能缓存从 LayoutManager2 返回的值。每次调用此方法时，这些缓存实现不需要在 LayoutManager2 上调用 maximumLayoutSize，而是只在 Container 变得无效之后查询 LayoutManager2。

覆盖：
类 Component 中的 getMaximumSize
返回：
表示此容器最大大小的 Dimension 实例。
另请参见：
getPreferredSize(),
getMinimumSize(),
getLayout(),
LayoutManager2.maximumLayoutSize(Container),
Component.getMaximumSize()

getAlignmentX

public float getAlignmentX()
返回沿 x 轴的对齐方式。这指出了相对于其他组件将如何对齐该组件。该值应该在 0 到 1 之间，其中，0 表示根据原点进行对齐，1 表示根据距原点最远的地方对齐，0.5 表示从中间对齐等等。

覆盖：
类 Component 中的 getAlignmentX

getAlignmentY

public float getAlignmentY()
返回沿 y 轴的对齐方式。这指出相对于其他组件将如何排列该组件。该值应该在 0 到 1 之间，其中，0 表示根据原点进行对齐，1 表示根据距原点最远的地方对齐，0.5 表示从中间对齐等等。

覆盖：
类 Component 中的 getAlignmentY

paint

public void paint(Graphics g)
绘制容器。该方法将 paint 转发给任意一个此容器子组件的轻量级组件。如果重新实现此方法，那么应该调用 super.paint(g) 方法，从而可以正确地呈现轻量级组件。如果通过 g 中的当前剪切设置完全剪切某个子组件，则不会将 paint() 转发给这个子组件。

覆盖：
类 Component 中的 paint
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

update

public void update(Graphics g)
更新容器。该方法将 update 方法转发给任意一个此容器子组件的轻量级组件。如果重新实现此方法，那么应该调用 super.update(g) 方法，从而可以正确地呈现轻量级组件。如果通过 g 中的当前剪切设置完全剪切某个子组件，则不会将 update() 转发给这个子组件。

覆盖：
类 Component 中的 update
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

print

public void print(Graphics g)
打印容器。该方法将 print 方法转发给任意一个此容器子组件的轻量级组件。如果重新实现此方法，那么应该调用 super.print(g) 方法，从而可以正确地呈现轻量级组件。如果通过 g 中的当前剪切设置完全剪切某个子组件，则不会将 print() 转发给这个子组件。

覆盖：
类 Component 中的 print
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

paintComponents

public void paintComponents(Graphics g)
绘制此容器中的每个组件。

参数：
g - 图形上下文。
另请参见：
Component.paint(java.awt.Graphics), Component.paintAll(java.awt.Graphics)

printComponents

public void printComponents(Graphics g)
打印此容器中的每个组件。

参数：
g - 图形上下文。
另请参见：
Component.print(java.awt.Graphics), Component.printAll(java.awt.Graphics)

addContainerListener

public void addContainerListener(ContainerListener l)
添加指定容器的侦听器，以接收来自此容器的容器事件。如果 l 为 null，则不会抛出异常，并且不执行任何动作。 有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 容器侦听器
另请参见：
removeContainerListener(java.awt.event.ContainerListener), getContainerListeners()

removeContainerListener

public void removeContainerListener(ContainerListener l)
移除指定容器的侦听器，从而不再接收来自此容器的容器事件。如果 l 为 null，则不会抛出异常，并且不执行任何动作。 有关 AWT 的线程模型的细节信息，请参阅 AWT 线程问题。

参数：
l - 容器侦听器
另请参见：
addContainerListener(java.awt.event.ContainerListener), getContainerListeners()

getContainerListeners

public ContainerListener[] getContainerListeners()
返回已在此容器上注册的所有容器侦听器的数组。

返回：
此容器的所有 ContainerListener，如果没有当前已注册的容器侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addContainerListener(java.awt.event.ContainerListener), removeContainerListener(java.awt.event.ContainerListener)

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。FooListener 是使用 addFooListener 方法注册的。

可以用一个类字面值（比如 FooListener.class）指定 listenerType 参数。例如，可以使用以下代码查询 Container c，以获得该容器的侦听器：

ContainerListener[] cls = (ContainerListener[])(c.getListeners(ContainerListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 Component 中的 getListeners
参数：
listenerType - 所请求侦听器的类型；该参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此容器上注册为 FooListener 的所有对象的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getContainerListeners()

processEvent

protected void processEvent(AWTEvent e)
处理关于此容器的事件。如果事件是一个 ContainerEvent，那么将调用 processContainerEvent 方法，否则将调用其超类的 processEvent 方法。

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

覆盖：
类 Component 中的 processEvent
参数：
e - 事件
另请参见：
Component.processComponentEvent(java.awt.event.ComponentEvent),
Component.processFocusEvent(java.awt.event.FocusEvent),
Component.processKeyEvent(java.awt.event.KeyEvent),
Component.processMouseEvent(java.awt.event.MouseEvent),
Component.processMouseMotionEvent(java.awt.event.MouseEvent),
Component.processInputMethodEvent(java.awt.event.InputMethodEvent),
Component.processHierarchyEvent(java.awt.event.HierarchyEvent),
Component.processMouseWheelEvent(java.awt.event.MouseWheelEvent)

processContainerEvent

protected void processContainerEvent(ContainerEvent e)
通过将发生在此容器上的容器事件指派给所有已注册的 ContainerListener 对象来处理这些事件。注：直到为此组件启用容器事件，才调用此方法；这发生在出现以下情况之一时：
  • 通过 addContainerListener 注册 ContainerListener 对象
  • 通过 enableEvents 启用容器事件

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

参数：
e - 容器事件
另请参见：
Component.enableEvents(long)

deliverEvent

@Deprecated
public void deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代

覆盖：
类 Component 中的 deliverEvent

getComponentAt

public Component getComponentAt(int x,
                                int y)
对包含 x，y 位置的组件进行定位。在组件中出现重叠的情况下，返回位于最顶端的子组件。这是通过查找最接近于索引 0 并且通过 Component.contains() 要求包含给定点的组件来确定的，但拥有本机同位体的组件优先于那些没有同位体的组件（也就是轻量级组件）。

覆盖：
类 Component 中的 getComponentAt
参数：
x - x 坐标
y - y 坐标
返回：
如果组件不包含该位置上，则返回 null。如果所请求的点上没有子组件，并且这个点在容器的边界内，则返回容器自身；否则返回最顶端的子组件。
从以下版本开始：
JDK1.1
另请参见：
Component.contains(int, int)

locate

@Deprecated
public Component locate(int x,
                                   int y)
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。

覆盖：
类 Component 中的 locate

getComponentAt

public Component getComponentAt(Point p)
获取包含指定点的组件。

覆盖：
类 Component 中的 getComponentAt
参数：
p - 点。
返回：
包含这个点的组件，如果组件不包含这个点，则返回 null。
从以下版本开始：
JDK1.1
另请参见：
Component.contains(int, int)

getMousePosition

public Point getMousePosition(boolean allowChildren)
                       throws HeadlessException
如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。此方法类似于 Component.getMousePosition()，不过它可能还要考虑 Container 的子组件。如果 allowChildren 为 false，则仅当鼠标指针直接位于 Container 上方，而不是位于被 Container 的子组件掩盖的那部分上方时，此方法才返回一个非 null 值。如果 allowChildren 为 true，且鼠标指针位于 Container 或其任意子代的上方时，此方法才返回一个非 null 值。

参数：
allowChildren - 如果将子组件也考虑进去，则此参数为 true
返回：
相对于 Component 的鼠标坐标，或者 null
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.5
另请参见：
Component.getMousePosition()

findComponentAt

public Component findComponentAt(int x,
                                 int y)
对包含指定位置的可视子组件进行定位。在组件中出现重叠的情况下，返回位于最顶端的子组件。如果包含的子组件是一个 Container，则此方法将继续搜索，以找到嵌套最深的子组件。在搜索期间忽略不可见的组件。

findComponentAt 方法不同于 getComponentAt 方法，getComponentAt 方法只搜索 Container 的直接子组件；如果包含的组件是一个 Container，则 findComponentAt 方法将搜索子容器，以找到嵌套的组件。

参数：
x - x 坐标
y - y 坐标
返回：
如果组件不包含这个位置上，则返回 null。如果所请求的点上没有子组件，并且这个点在容器的边界内，则返回容器自身。
从以下版本开始：
1.2
另请参见：
Component.contains(int, int), getComponentAt(int, int)

findComponentAt

public Component findComponentAt(Point p)
对包含指定点的可视子组件进行定位。在组件中出现重叠的情况下，返回位于最顶端的子组件。如果包含的子组件是一个 Container，则此方法将继续搜索，以找到嵌套最深的子组件。在搜索期间忽略不可见的组件。

findComponentAt 方法不同于 getComponentAt 方法，getComponentAt 方法只搜索 Container 的直接子组件；如果包含的组件是一个 Container，则 findComponentAt 方法将搜索子容器，以找到嵌套的组件。

参数：
p - 点。
返回：
如果组件没有包含该位置，则返回 null。如果所请求的点上没有子组件，并且这个点在容器的边界内，则返回容器自身。
从以下版本开始：
1.2
另请参见：
Component.contains(int, int), getComponentAt(int, int)

addNotify

public void addNotify()
通过将这个 Container 连接到本机屏幕资源，使其可以显示。使容器变得可以显示会使其所有子容器都变得可以显示。此方法是通过工具包内部调用的，不应该通过程序直接调用它。

覆盖：
类 Component 中的 addNotify
另请参见：
Component.isDisplayable(), removeNotify()

removeNotify

public void removeNotify()
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。使容器变得不可显示会使其所有子容器都变得不可显示。此方法是通过工具包内部调用的，不应该通过程序直接调用它。

覆盖：
类 Component 中的 removeNotify
另请参见：
Component.isDisplayable(), addNotify()

isAncestorOf

public boolean isAncestorOf(Component c)
检查该组件是否包含在此容器的组件层次结构中。

参数：
c - 组件
返回：
如果它是一个祖先级组件，则返回 true；否则返回 false。
从以下版本开始：
JDK1.1

paramString

protected String paramString()
返回表示此 Container 的状态的字符串。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Component 中的 paramString
返回：
此容器的参数字符串

list

public void list(PrintStream out,
                 int indent)
将此容器的清单打印到指定输出流。该清单起始于指定缩排位置。

使用 indent+1 的缩排来打印容器的直接子组件。这些子组件的子组件是在 indent+2 上打印的，依此类推。

覆盖：
类 Component 中的 list
参数：
out - 打印流
indent - 缩排的空格数
从以下版本开始：
JDK1.0
另请参见：
Component.list(java.io.PrintStream, int)

list

public void list(PrintWriter out,
                 int indent)
将一个列表打印到指定打印编写器，从指定缩排位置开始。

使用 indent+1 的缩排来打印容器的直接子组件。这些子组件的子组件是在 indent+2 上打印的，依此类推。

覆盖：
类 Component 中的 list
参数：
out - 打印编写器
indent - 缩排的空格数
从以下版本开始：
JDK1.1
另请参见：
Component.list(java.io.PrintWriter, int)

setFocusTraversalKeys

public void setFocusTraversalKeys(int id,
                                  Set<? extends AWTKeyStroke> keystrokes)
为此 Container 的给定遍历操作设置焦点遍历键。

Container 的焦点遍历键的默认值与实现相关。Sun 建议特定本机平台的所有实现都使用相同的默认值。对 Windows 和 Unix 的建议列出如下。这些建议用于 Sun AWT 实现中。

标识符 | 含义 | 默认值
KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS | 普通的转发键盘遍历 | KEY_PRESSED 上的 TAB，KEY_PRESSED 上的 CTRL-TAB
KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS | 普通的反向键盘遍历 | KEY_PRESSED 上的 SHIFT-TAB，KEY_PRESSED 上的 CTRL-SHIFT-TAB
KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS | 向上移动一个焦点遍历循环 | 无
KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS | 向下移动一个焦点遍历循环 | 无
要禁用一个遍历键，可以使用空 Set；建议使用 Collections.EMPTY_SET。

使用 AWTKeyStroke API，客户机代码可以指定在两个特定 KeyEvents（KEY_PRESSED 或 KEY_RELEASED）中的哪一个上进行焦点遍历操作。不管指定的是哪一个 KeyEvent，所有与焦点遍历键相关的 KeyEvent（包括相关 KEY_TYPED 事件）都将被使用，并且不将它们指派给任何 Container。在将事件映射到焦点遍历操作，或者将同一事件映射到多个默认焦点遍历操作时，指定 KEY_TYPED 事件是一个运行时错误。

如果为 Set 指定 null 值，则此 Container 将继承其父辈的 Set。如果此 Container 的所有祖先都为 Set 指定了 null 值，则使用当前 KeyboardFocusManager 的默认 Set。

覆盖：
类 Component 中的 setFocusTraversalKeys
参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一
keystrokes - 用于指定操作的 AWTKeyStroke 的 Set
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一；或者 keystroke 中包含 null；或者 keystroke 中的任何 Object 都不是 AWTKeyStroke；或者任何 keystroke 都表示一个 KEY_TYPED 事件；或者任何 keystroke 总是映射到此 Container 的另一个焦点遍历操作
从以下版本开始：
1.4
另请参见：
getFocusTraversalKeys(int), KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS, KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS

getFocusTraversalKeys

public Set<AWTKeyStroke> getFocusTraversalKeys(int id)
为此 Container 的给定遍历操作返回焦点遍历键的 Set。（有关每个键的完整描述，请参阅 setFocusTraversalKeys。）

如果没有为此 Container 明确定义了遍历键的 Set，则返回此 Container 的父 Set。如果没有为此 Container 的任何祖先明确定义 Set，则返回当前 KeyboardFocusManager 的默认 Set。

覆盖：
类 Component 中的 getFocusTraversalKeys
参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一
返回：
用于指定操作的 AWTKeyStrokes 的 Set。此 Set 将是不可修改的，并且可能是空的。从不返回 null。
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一
从以下版本开始：
1.4
另请参见：
setFocusTraversalKeys(int, java.util.Set), KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS, KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS

areFocusTraversalKeysSet

public boolean areFocusTraversalKeysSet(int id)
返回是否已经为此 Container 明确定义了用于给定焦点遍历操作的焦点遍历键的 Set。如果此方法返回 false，则此 Container 从一个祖先或当前 KeyboardFocusManager 那里继承 Set。

覆盖：
类 Component 中的 areFocusTraversalKeysSet
参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一
返回：
如果已经为此 Component 明确定义了用于给定焦点遍历操作的焦点遍历键的 Set，则返回 true；否则返回 false。
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一
从以下版本开始：
1.4

isFocusCycleRoot

public boolean isFocusCycleRoot(Container container)
返回指定的 Container 是否是此 Container 的焦点遍历循环的焦点循环根。每个焦点遍历循环只有一个焦点循环根，并且不是焦点循环根的每个 Container 只属于一个焦点遍历循环。那些是焦点循环根的容器属于两个循环：一个根植于 Container 自身中，另一个根植于此 Container 的最近的焦点循环根祖先中。在这种情况下，对于这两种 Container，此方法都将返回 true。

覆盖：
类 Component 中的 isFocusCycleRoot
参数：
container - 要测试的 Container
返回：
如果指定 Container 是此 Container 的一个焦点循环根，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
isFocusCycleRoot()

transferFocusBackward

public void transferFocusBackward()
从类 Component 复制的描述
将焦点转移到前一个组件，就好像此 Component 曾是焦点所有者。

覆盖：
类 Component 中的 transferFocusBackward
另请参见：
Component.requestFocus()

setFocusTraversalPolicy

public void setFocusTraversalPolicy(FocusTraversalPolicy policy)
如果此 Container 是一个焦点循环根，则设置将管理此 Container 的子代的键盘遍历的焦点遍历策略。如果参数为 null，则此 Container 将继承其焦点循环根祖先的策略。如果参数为非 null 值，则此策略将由所有焦点循环根的子组件继承，这些子组件没有自己的键盘遍历策略（它们将以递归方式管理其焦点循环根的子组件）。

如果此 Container 不是一个焦点循环根，要记得该策略，但直到此 Container 成为焦点循环根，此 Container 或其他任何 Container 才可以使用或继承此策略。

参数：
policy - 此 Container 的新的焦点遍历策略
从以下版本开始：
1.4
另请参见：
getFocusTraversalPolicy(), setFocusCycleRoot(boolean), isFocusCycleRoot(java.awt.Container)

getFocusTraversalPolicy

public FocusTraversalPolicy getFocusTraversalPolicy()
返回焦点遍历策略，用于管理此 Container 子组件的键盘遍历；如果此 Container 不是一个焦点循环根，则返回 null。如果没有明确为此 Container 设置遍历策略，则返回此 Container 的焦点循环根祖先的策略。

返回：
此 Container 的焦点遍历策略，如果此 Container 不是一个焦点循环根，则返回 null。
从以下版本开始：
1.4
另请参见：
setFocusTraversalPolicy(java.awt.FocusTraversalPolicy), setFocusCycleRoot(boolean), isFocusCycleRoot(java.awt.Container)

isFocusTraversalPolicySet

public boolean isFocusTraversalPolicySet()
返回是否为此 Container 明确设置焦点遍历策略。如果此方法返回 false，则此 Container 将从一个祖先那里继承其焦点遍历策略。

返回：
如果已经明确为此 Container 设置焦点遍历策略，则返回 true；否则返回 false。
从以下版本开始：
1.4

setFocusCycleRoot

public void setFocusCycleRoot(boolean focusCycleRoot)
设置此 Container 是否是某个焦点遍历循环的根。一旦焦点进入某个遍历循环，它通常无法通过焦点遍历离开，除非按下向上循环键或向下循环键之一。普通遍历被限定于此 Container，该 Container 的所有子代并不是下级焦点循环根的子代。注意，FocusTraversalPolicy 可能屈服于这些约束。例如，ContainerOrderFocusTraversalPolicy 支持隐式的向下循环遍历。

指定此 Container 子代的遍历顺序的替代方法是焦点遍历策略提供者。

参数：
focusCycleRoot - 指示此 Container 是否是某个焦点遍历循环的根
从以下版本开始：
1.4
另请参见：
isFocusCycleRoot(),
setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
getFocusTraversalPolicy(),
ContainerOrderFocusTraversalPolicy,
setFocusTraversalPolicyProvider(boolean)

isFocusCycleRoot

public boolean isFocusCycleRoot()
返回此 Container 是否是某个焦点遍历循环的根。一旦焦点进入某个遍历循环，它通常无法通过焦点遍历离开，除非按下向上循环键或向下循环键之一。普通遍历被限定于此 Container，该 Container 的所有子代并不是下级焦点循环根的子代。注意，FocusTraversalPolicy 可能屈服于这些约束。例如，ContainerOrderFocusTraversalPolicy 支持隐式的向下循环遍历。

返回：
此 Container 是否是某个焦点遍历循环的根
从以下版本开始：
1.4
另请参见：
setFocusCycleRoot(boolean), setFocusTraversalPolicy(java.awt.FocusTraversalPolicy), getFocusTraversalPolicy(), ContainerOrderFocusTraversalPolicy

setFocusTraversalPolicyProvider

public final void setFocusTraversalPolicyProvider(boolean provider)
设置是否将用此容器提供焦点遍历策略。将使用把该属性设置为 true 的容器来获取焦点遍历策略，而不是获取最近的焦点循环根的祖先。

参数：
provider - 指示是否将用此容器提供焦点遍历策略
从以下版本开始：
1.5
另请参见：
setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
getFocusTraversalPolicy(),
isFocusTraversalPolicyProvider()

isFocusTraversalPolicyProvider

public final boolean isFocusTraversalPolicyProvider()
返回此容器是否提供焦点遍历策略。如果将此属性设置为 true，那么在键盘焦点管理器搜索容器层次结构来查找焦点遍历策略，且在其他任何将此属性设置为 true 的容器之前遇到此容器或焦点循环根的时候，将使用其焦点遍历策略，而不是使用焦点循环根的策略。

返回：
如果此容器提供焦点遍历策略，则返回 true，否则返回 false
从以下版本开始：
1.5
另请参见：
setFocusTraversalPolicy(java.awt.FocusTraversalPolicy), getFocusTraversalPolicy(), setFocusCycleRoot(boolean), setFocusTraversalPolicyProvider(boolean)

transferFocusDownCycle

public void transferFocusDownCycle()
将焦点向下传输一个焦点遍历循环。如果此 Container 是一个焦点循环根，则将焦点的所有者设置为此 Container 的将成为焦点的默认 Component，并将当前焦点循环根设置为此 Container。如果此 Container 不是一个焦点循环根，则不会发生焦点遍历操作。

从以下版本开始：
1.4
另请参见：
Component.requestFocus(),
isFocusCycleRoot(java.awt.Container),
setFocusCycleRoot(boolean)

applyComponentOrientation

public void applyComponentOrientation(ComponentOrientation o)
设置此容器和其中包含的所有组件的 ComponentOrientation 属性。

覆盖：
类 Component 中的 applyComponentOrientation
参数：
o - 此容器的新组件的方向性和其中包含组件的方向性。
抛出：
NullPointerException - 如果 orientation 为 null。
从以下版本开始：
1.4
另请参见：
Component.setComponentOrientation(java.awt.ComponentOrientation), Component.getComponentOrientation()

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到侦听器列表中。该侦听器是为此类的所有边界属性注册的，其中包括以下属性：
  • 此 Container 的字体 ("font")
  • 此 Container 的背景色 ("background")
  • 此 Container 的前景色 ("foreground")
  • 此 Container 的可聚焦性 ("focusable")
  • 此 Container 的焦点遍历键支持的状态 ("focusTraversalKeysEnabled")
  • 此 Container 的 FORWARD_TRAVERSAL_KEYS 的 Set ("forwardFocusTraversalKeys")
  • 此 Container 的 BACKWARD_TRAVERSAL_KEYS 的 Set ("backwardFocusTraversalKeys")
  • 此 Container 的 UP_CYCLE_TRAVERSAL_KEYS 的 Set ("upCycleFocusTraversalKeys")
  • 此 Container 的 DOWN_CYCLE_TRAVERSAL_KEYS 的 Set ("downCycleFocusTraversalKeys")
  • 此 Container 的焦点遍历策略 ("focusTraversalPolicy")
  • 此 Container 的焦点循环根的状态 ("focusCycleRoot")
注意，如果此 Container 正继承某个边界属性，那么不会为响应所继承属性中的更改而触发任何事件。

如果侦听器为 null，则不会抛出异常，并且不执行任何动作。

覆盖：
类 Component 中的 addPropertyChangeListener
参数：
listener - 要添加的 PropertyChangeListener
另请参见：
Component.removePropertyChangeListener(java.beans.PropertyChangeListener), addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

addPropertyChangeListener

public void addPropertyChangeListener(String propertyName,
                                      PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。指定的属性可以是用户定义的，或者是以下默认属性之一：
  • 此 Container 的字体 ("font")
  • 此 Container 的背景色 ("background")
  • 此 Container 的前景色 ("foreground")
  • 此 Container 的可聚焦性 ("focusable")
  • 此 Container 的焦点遍历键支持的状态 ("focusTraversalKeysEnabled")
  • 此 Container 的 FORWARD_TRAVERSAL_KEYS 的 Set ("forwardFocusTraversalKeys")
  • 此 Container 的 BACKWARD_TRAVERSAL_KEYS 的 Set ("backwardFocusTraversalKeys")
  • 此 Container 的 UP_CYCLE_TRAVERSAL_KEYS 的 Set ("upCycleFocusTraversalKeys")
  • 此 Container 的 DOWN_CYCLE_TRAVERSAL_KEYS 的 Set ("downCycleFocusTraversalKeys")
  • 此 Container 的焦点遍历策略 ("focusTraversalPolicy")
  • 此 Container 的焦点循环根的状态 ("focusCycleRoot")
  • 此 Container 的焦点遍历策略提供者的状态 ("focusTraversalPolicyProvider")
  • 此 Container 的焦点遍历策略提供者的状态 ("focusTraversalPolicyProvider")
注意，如果此 Container 正继承某个边界属性，那么不会为响应所继承属性中的更改而触发任何事件。

如果侦听器为 null，则不会抛出异常，并且不执行任何动作。

覆盖：
类 Component 中的 addPropertyChangeListener
参数：
propertyName - 上面列出的属性名称之一
listener - 要添加的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), Component.removePropertyChangeListener(java.beans.PropertyChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Container.AccessibleAWTContainer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Container.AccessibleAWTContainer

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
所有已实现的接口：
Serializable, AccessibleComponent
直接已知子类：
Box.AccessibleBox, CellRendererPane.AccessibleCellRendererPane, JComponent.AccessibleJComponent, Panel.AccessibleAWTPanel, ScrollPane.AccessibleAWTScrollPane, Window.AccessibleAWTWindow
正在封闭类：
Container
protected class Container.AccessibleAWTContainer
extends Component.AccessibleAWTComponent

用于对可访问性提供默认支持的 Container 内部类。此类并非旨在由应用程序开发人员直接使用，而只能由容器开发人员为其创建子类。

该类用于获得此对象的访问职责，以及实现 AccessibleContainer 接口中的很多方法。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
protected  class Container.AccessibleAWTContainer.AccessibleContainerHandler
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
protected  ContainerListener accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Container.AccessibleAWTContainer()
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
Accessible | getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子容器。
int | getAccessibleChildrenCount() 返回对象中可访问的子容器数。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleRole, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

accessibleContainerHandler

protected ContainerListener accessibleContainerHandler
构造方法详细信息

Container.AccessibleAWTContainer

protected Container.AccessibleAWTContainer()
方法详细信息

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中可访问的子容器数。如果此对象的所有子容器都实现了 Accessible，则此方法应该返回此对象的子容器数。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChildrenCount
返回：
对象中可访问的子容器数

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个 Accessible 子容器。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChild
参数：
i - 基于 0 的子容器索引
返回：
对象的第 n 个 Accessible 子容器
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleAt
参数：
p - 定义 Accessible 左上角的点，在对象父代的坐标空间中给出
返回：
位于指定位置的 Accessible（如果存在）；否则返回 null

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。

覆盖：
类 Component.AccessibleAWTComponent 中的 addPropertyChangeListener
参数：
listener - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Container.AccessibleAWTContainer.AccessibleContainerHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Container.AccessibleAWTContainer.AccessibleContainerHandler

java.lang.Object
    继承者  java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
所有已实现的接口：
ContainerListener, EventListener
正在封闭类：
Container.AccessibleAWTContainer
protected class Container.AccessibleAWTContainer.AccessibleContainerHandler
extends Object
implements ContainerListener

添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

从以下版本开始：
1.3

构造方法摘要
protected Container.AccessibleAWTContainer.AccessibleContainerHandler()
方法摘要
void | componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Container.AccessibleAWTContainer.AccessibleContainerHandler

protected Container.AccessibleAWTContainer.AccessibleContainerHandler()
方法详细信息

componentAdded

public void componentAdded(ContainerEvent e)
从接口 ContainerListener 复制的描述
已将组件添加到容器中时调用。

指定者：
接口 ContainerListener 中的 componentAdded

componentRemoved

public void componentRemoved(ContainerEvent e)
从接口 ContainerListener 复制的描述
已从容器中移除组件时调用。

指定者：
接口 ContainerListener 中的 componentRemoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContainerOrderFocusTraversalPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 ContainerOrderFocusTraversalPolicy

java.lang.Object
    继承者  java.awt.FocusTraversalPolicy
        继承者  java.awt.ContainerOrderFocusTraversalPolicy
所有已实现的接口：
Serializable
直接已知子类：
DefaultFocusTraversalPolicy
public class ContainerOrderFocusTraversalPolicy
extends FocusTraversalPolicy
implements Serializable

根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。该策略将从特定焦点循环根对 Component 层次结构进行前序遍历，并根据 Container.getComponents() 返回的数组顺序遍历 Container 的子容器。不可视和不可显示的部分层次结构将不被搜索。

默认情况下，ContainerOrderFocusTraversalPolicy 会隐式将焦点传递给下一个循环。也就是说，在进行普通正向焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。可以使用 setImplicitDownCycleTraversal 方法禁用此行为。

默认情况下，只有 Component 是可视的、可显示的、被启用的和可聚焦的时候，此类的方法才返回此 Component。子类可以通过重写 accept 方法修改此行为。

此策略需要考虑焦点遍历策略提供者。在搜索第一个/最后一个/下一个/前一个 Component 时，如果遇到一个焦点遍历策略提供者，则使用其焦点遍历策略来执行搜索操作。

从以下版本开始：
1.4
另请参见：
Container.getComponents(), 序列化表格

构造方法摘要
ContainerOrderFocusTraversalPolicy()
方法摘要
protected boolean | accept(Component aComponent) 确定是否可以接受选择某个 Component 作为新的焦点拥有者。
Component | getComponentAfter(Container aContainer, Component aComponent) 返回应该接收 aComponent 后面的焦点的 Component。
Component | getComponentBefore(Container aContainer, Component aComponent) 返回应该接收 aComponent 前面的焦点的 Component。
Component | getDefaultComponent(Container aContainer) 返回默认拥有焦点的 Component。
Component | getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
boolean | getImplicitDownCycleTraversal() 返回对此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环的判断。
Component | getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
void | setImplicitDownCycleTraversal(boolean implicitDownCycleTraversal) 设置此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环。
从类 java.awt.FocusTraversalPolicy 继承的方法
getInitialComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContainerOrderFocusTraversalPolicy

public ContainerOrderFocusTraversalPolicy()
方法详细信息

getComponentAfter

public Component getComponentAfter(Container aContainer,
                                   Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。aContainer 必须是 aComponent 的焦点循环根，或者是一个焦点遍历策略提供者。

默认情况下，ContainerOrderFocusTraversalPolicy 会隐式将焦点传递给下一个循环。也就是说，在进行普通正向焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。可以使用 setImplicitDownCycleTraversal 方法禁用此行为。

如果 aContainer 是焦点遍历策略提供者，则总是将焦点传递到下一个循环。

指定者：
类 FocusTraversalPolicy 中的 getComponentAfter
参数：
aContainer - aComponent 的一个焦点循环根或者一个焦点遍历策略提供者
aComponent - aContainer 的一个（可能间接的）子代，或者 aContainer 自身
返回：
应该接受 aComponent 后面的焦点的 Component，如果没有找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或者焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getComponentBefore

public Component getComponentBefore(Container aContainer,
                                    Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。aContainer 必须是 aComponent 的焦点循环根，或者是一个焦点遍历策略提供者。

指定者：
类 FocusTraversalPolicy 中的 getComponentBefore
参数：
aContainer - aComponent 的一个焦点循环根或者一个焦点遍历策略提供者
aComponent - aContainer 的一个（可能间接的）子代，或者 aContainer 自身
返回：
应该接受 aComponent 前面的焦点的 Component，如果没有找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或者焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getFirstComponent

public Component getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。在进行正向遍历时，可用此方法确定拥有焦点的下一个 Component。

指定者：
类 FocusTraversalPolicy 中的 getFirstComponent
参数：
aContainer - 将返回其第一个 Component 的焦点循环根或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的第一个 Component，如果没有找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getLastComponent

public Component getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。在进行反向遍历时，可用此方法确定拥有焦点的下一个 Component。

指定者：
类 FocusTraversalPolicy 中的 getLastComponent
参数：
aContainer - 将返回其最后一个 Component 的焦点循环根或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的最后一个 Component，如果没有找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getDefaultComponent

public Component getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。在向下遍历到以 aContainer 为根的新焦点遍历循环时，此 Component 将是第一个接受焦点的 Component。此方法的默认实现将返回与 getFirstComponent 相同的 Component。

指定者：
类 FocusTraversalPolicy 中的 getDefaultComponent
参数：
aContainer - 将返回其默认 Component 的焦点循环根或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的默认 Component，如果没有找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null
另请参见：
getFirstComponent(java.awt.Container)

setImplicitDownCycleTraversal

public void setImplicitDownCycleTraversal(boolean implicitDownCycleTraversal)
设置此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环。如果设置为 true，则在进行普通正向焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。如果设置为 false，则将遍历根植在指定焦点循环根的焦点遍历循环中的下一个 Component。此属性的默认值为 true。

参数：
implicitDownCycleTraversal - 此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环
另请参见：
getImplicitDownCycleTraversal(), getFirstComponent(java.awt.Container)

getImplicitDownCycleTraversal

public boolean getImplicitDownCycleTraversal()
返回对此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环的判断。如果返回 true，则在进行普通正向焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。如果返回 false，则将遍历根植在指定焦点循环根上的焦点遍历循环中的下一个 Component。

返回：
此 ContainerOrderFocusTraversalPolicy 是否隐式将焦点传递给下一个循环
另请参见：
setImplicitDownCycleTraversal(boolean), getFirstComponent(java.awt.Container)

accept

protected boolean accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点拥有者。默认情况下，当且仅当 Component 是可视的、可显示的、被启用的和可聚焦的时候，此方法才接受此 Component。

参数：
aComponent - 将测试其是否适合作为焦点所有者的 Component
返回：
如果 aComponent 是可视的、可显示的、被启用的和可聚焦的，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Cursor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Cursor

java.lang.Object
    继承者  java.awt.Cursor
所有已实现的接口：
Serializable
public class Cursor
extends Object
implements Serializable

封装鼠标光标的位图表示形式的类。

另请参见：
Component.setCursor(java.awt.Cursor), 序列化表格

字段摘要
static int | CROSSHAIR_CURSOR 十字光标类型。
static int | CUSTOM_CURSOR 与所有定制光标有关的类型。
static int | DEFAULT_CURSOR 默认光标类型（如果没有定义光标，则获取该设置）。
static int | E_RESIZE_CURSOR 调整窗口右边框大小的光标类型。
static int | HAND_CURSOR 手状光标类型。
static int | MOVE_CURSOR 移动光标类型。
static int | N_RESIZE_CURSOR 调整窗口上边框大小的光标类型。
protected String | name 光标的用户可视名称。
static int | NE_RESIZE_CURSOR 调整窗口右上角大小的光标类型。
static int | NW_RESIZE_CURSOR 调整窗口左上角大小的光标类型。
protected static Cursor[] | predefined
static int | S_RESIZE_CURSOR 调整窗口下边框大小的光标类型。
static int | SE_RESIZE_CURSOR 调整窗口右下角大小的光标类型。
static int | SW_RESIZE_CURSOR 调整窗口左下角大小的光标类型。
static int | TEXT_CURSOR 文字光标类型。
static int | W_RESIZE_CURSOR 调整窗口左边框大小的光标类型。
static int | WAIT_CURSOR 等待光标类型。
构造方法摘要
 | Cursor(int type) 用指定类型创建一个新的光标对象。
protected | Cursor(String name) 用指定名称创建一个新的定制光标对象。
方法摘要
static Cursor | getDefaultCursor() 返回系统默认光标。
String | getName() 返回此光标的名称。
static Cursor | getPredefinedCursor(int type) 返回一个具有指定预定义类型的光标对象。
static Cursor | getSystemCustomCursor(String name) 返回与指定名称匹配的特定于系统的定制光标对象。
int | getType() 返回此光标的类型。
String | toString() 返回此光标的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_CURSOR

public static final int DEFAULT_CURSOR
默认光标类型（如果没有定义光标，则获取该设置）。

另请参见：
常量字段值

CROSSHAIR_CURSOR

public static final int CROSSHAIR_CURSOR
十字光标类型。

另请参见：
常量字段值

TEXT_CURSOR

public static final int TEXT_CURSOR
文字光标类型。

另请参见：
常量字段值

WAIT_CURSOR

public static final int WAIT_CURSOR
等待光标类型。

另请参见：
常量字段值

SW_RESIZE_CURSOR

public static final int SW_RESIZE_CURSOR
调整窗口左下角大小的光标类型。

另请参见：
常量字段值

SE_RESIZE_CURSOR

public static final int SE_RESIZE_CURSOR
调整窗口右下角大小的光标类型。

另请参见：
常量字段值

NW_RESIZE_CURSOR

public static final int NW_RESIZE_CURSOR
调整窗口左上角大小的光标类型。

另请参见：
常量字段值

NE_RESIZE_CURSOR

public static final int NE_RESIZE_CURSOR
调整窗口右上角大小的光标类型。

另请参见：
常量字段值

N_RESIZE_CURSOR

public static final int N_RESIZE_CURSOR
调整窗口上边框大小的光标类型。

另请参见：
常量字段值

S_RESIZE_CURSOR

public static final int S_RESIZE_CURSOR
调整窗口下边框大小的光标类型。

另请参见：
常量字段值

W_RESIZE_CURSOR

public static final int W_RESIZE_CURSOR
调整窗口左边框大小的光标类型。

另请参见：
常量字段值

E_RESIZE_CURSOR

public static final int E_RESIZE_CURSOR
调整窗口右边框大小的光标类型。

另请参见：
常量字段值

HAND_CURSOR

public static final int HAND_CURSOR
手状光标类型。

另请参见：
常量字段值

MOVE_CURSOR

public static final int MOVE_CURSOR
移动光标类型。

另请参见：
常量字段值

predefined

protected static Cursor[] predefined

CUSTOM_CURSOR

public static final int CUSTOM_CURSOR
与所有定制光标有关的类型。

另请参见：
常量字段值

name

protected String name
光标的用户可视名称。

另请参见：
getName()
构造方法详细信息

Cursor

public Cursor(int type)
用指定类型创建一个新的光标对象。

参数：
type - 光标的类型
抛出：
IllegalArgumentException - 如果指定的光标类型无效

Cursor

protected Cursor(String name)
用指定名称创建一个新的定制光标对象。

注：此构造方法应该只由 AWT 实现使用，用作它们支持定制光标的一部分。应用程序应该使用 Toolkit.createCustomCursor()。

参数：
name - 光标的用户可视名称。
另请参见：
Toolkit.createCustomCursor(java.awt.Image, java.awt.Point, java.lang.String)
方法详细信息

getPredefinedCursor

public static Cursor getPredefinedCursor(int type)
返回一个具有指定预定义类型的光标对象。

参数：
type - 指定光标的类型
返回：
指定的预定义光标
抛出：
IllegalArgumentException - 如果指定的光标类型无效

getSystemCustomCursor

public static Cursor getSystemCustomCursor(String name)
                                    throws AWTException,
                                           HeadlessException
返回与指定名称匹配的特定于系统的定制光标对象。例如，光标名称为："Invalid.16x16"

参数：
name - 描述所需的特定于系统的定制光标的字符串
返回：
与指定名称匹配的特定于系统的定制光标
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
AWTException

getDefaultCursor

public static Cursor getDefaultCursor()
返回系统默认光标。

getType

public int getType()
返回此光标的类型。

getName

public String getName()
返回此光标的名称。

返回：
此光标的本地化描述。
从以下版本开始：
1.2

toString

public String toString()
返回此光标的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此光标的字符串表示形式。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultFocusTraversalPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 DefaultFocusTraversalPolicy

java.lang.Object
    继承者  java.awt.FocusTraversalPolicy
        继承者  java.awt.ContainerOrderFocusTraversalPolicy
            继承者  java.awt.DefaultFocusTraversalPolicy
所有已实现的接口：
Serializable
public class DefaultFocusTraversalPolicy
extends ContainerOrderFocusTraversalPolicy

根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。该策略将从特定焦点循环根对 Component 层次结构进行前序遍历，并根据 Container.getComponents() 返回的数组顺序遍历 Container 的子容器。不可视和不可显示的部分层次结构将不被搜索。

如果通过重写 Component.isFocusTraversable() 或 Component.isFocusable()，或者通过调用 Component.setFocusable()，客户机代码已经明确设置了 Component 的可聚焦性，则 DefaultFocusTraversalPolicy 的行为完全类似于 ContainerOrderFocusTraversalPolicy。不过，如果 Component 依赖于默认的可聚焦性，则 DefaultFocusTraversalPolicy 将拒绝具有不可聚焦同位体的所有 Component。这是所有 AWT Container 的默认 FocusTraversalPolicy。

同位体的可聚焦性与实现有关。Sun 建议特定本机平台的所有实现都构造具有相同可聚焦性的同位体。对 Windows 和 Unix 的建议是：Canvases、Labels、Panels、Scrollbars、ScrollPanes、Windows 和轻量级 Component 都有不可聚焦的同位体，而其他所有 Component 都有可聚焦的同位体。这些建议被用于 Sun AWT 实现中。注意，Component 的同位体的可聚焦性不同于（并且不会影响）其自身的可聚焦性。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节以及 Focus Specification。

从以下版本开始：
1.4
另请参见：
Container.getComponents(),
Component.isFocusable(),
Component.setFocusable(boolean),
序列化表格

构造方法摘要
DefaultFocusTraversalPolicy()
方法摘要
protected  boolean accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点所有者。
从类 java.awt.ContainerOrderFocusTraversalPolicy 继承的方法
getComponentAfter, getComponentBefore, getDefaultComponent, getFirstComponent, getImplicitDownCycleTraversal, getLastComponent, setImplicitDownCycleTraversal
从类 java.awt.FocusTraversalPolicy 继承的方法
getInitialComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultFocusTraversalPolicy

public DefaultFocusTraversalPolicy()
方法详细信息

accept

protected boolean accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点所有者。该 Component 必须是可视的、可显示的和能够接受的。如果通过重写 Component.isFocusTraversable() 或 Component.isFocusable()，或者通过调用 Component.setFocusable()，客户机代码已经明确设置 Component 的可聚焦性，则只在 Component 是可聚焦的组件时，才会接受它。不过，如果 Component 依赖于默认可聚焦性，那么所有的 Canvases、Labels、Panels、Scrollbars、ScrollPanes、Windows 和轻量级 Component 都将遭到拒绝。

覆盖：
类 ContainerOrderFocusTraversalPolicy 中的 accept
参数：
aComponent - 将测试其是否适合作为焦点所有者的 Component
返回：
如果 aComponent 满足上述要求，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultKeyboardFocusManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 DefaultKeyboardFocusManager

java.lang.Object
    继承者  java.awt.KeyboardFocusManager
        继承者  java.awt.DefaultKeyboardFocusManager
所有已实现的接口：
KeyEventDispatcher, KeyEventPostProcessor
直接已知子类：
FocusManager
public class DefaultKeyboardFocusManager
extends KeyboardFocusManager

AWT 应用程序的默认 KeyboardFocusManager。通过进行焦点遍历来响应 Component 的焦点遍历键，并使用 Container 的 FocusTraversalPolicy。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节以及 Focus Specification。

从以下版本开始：
1.4
另请参见：
FocusTraversalPolicy, Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int)

字段摘要
从类 java.awt.KeyboardFocusManager 继承的字段
BACKWARD_TRAVERSAL_KEYS, DOWN_CYCLE_TRAVERSAL_KEYS, FORWARD_TRAVERSAL_KEYS, UP_CYCLE_TRAVERSAL_KEYS
构造方法摘要
DefaultKeyboardFocusManager()
方法摘要
protected void | dequeueKeyEvents(long after, Component untilFocused) 释放正常指派到当前焦点所有者的所有 KeyEvent，这些 KeyEvent 因为调用了具有相同时间戳和 Component 的 enqueueKeyEvents 而被加入队列。
protected void | discardKeyEvents(Component comp) 放弃因为一次或多次调用具有指定 Component 或其子代之一的 enqueueKeyEvents 而加入队列的所有 KeyEvent。
boolean | dispatchEvent(AWTEvent e) 此方法由 AWT 事件调度程序调用，该调度程序请求当前的 KeyboardFocusManager 以它的名义指派指定的事件。
boolean | dispatchKeyEvent(KeyEvent e) 如果调度程序链中其他 KeyEventDispatcher 都没有调度 KeyEvent，或者没有注册其他 KeyEventDispatcher，则由 dispatchEvent 调用此方法。
void | downFocusCycle(Container aContainer) 将焦点下移一个焦点遍历循环。
protected void | enqueueKeyEvents(long after, Component untilFocused) 延迟对 KeyEvent 的指派，直到指定的 Component 成为焦点所有者。
void | focusNextComponent(Component aComponent) 使 aComponent 后面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
void | focusPreviousComponent(Component aComponent) 使 aComponent 前面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
boolean | postProcessKeyEvent(KeyEvent e) 由 dispatchKeyEvent 调用此方法。
void | processKeyEvent(Component focusedComponent, KeyEvent e) 当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。
void | upFocusCycle(Component aComponent) 将焦点上移一个焦点遍历循环。
从类 java.awt.KeyboardFocusManager 继承的方法
addKeyEventDispatcher, addKeyEventPostProcessor, addPropertyChangeListener, addPropertyChangeListener, addVetoableChangeListener, addVetoableChangeListener, clearGlobalFocusOwner, downFocusCycle, firePropertyChange, fireVetoableChange, focusNextComponent, focusPreviousComponent, getActiveWindow, getCurrentFocusCycleRoot, getCurrentKeyboardFocusManager, getDefaultFocusTraversalKeys, getDefaultFocusTraversalPolicy, getFocusedWindow, getFocusOwner, getGlobalActiveWindow, getGlobalCurrentFocusCycleRoot, getGlobalFocusedWindow, getGlobalFocusOwner, getGlobalPermanentFocusOwner, getKeyEventDispatchers, getKeyEventPostProcessors, getPermanentFocusOwner, getPropertyChangeListeners, getPropertyChangeListeners, getVetoableChangeListeners, getVetoableChangeListeners, redispatchEvent, removeKeyEventDispatcher, removeKeyEventPostProcessor, removePropertyChangeListener, removePropertyChangeListener, removeVetoableChangeListener, removeVetoableChangeListener, setCurrentKeyboardFocusManager, setDefaultFocusTraversalKeys, setDefaultFocusTraversalPolicy, setGlobalActiveWindow, setGlobalCurrentFocusCycleRoot, setGlobalFocusedWindow, setGlobalFocusOwner, setGlobalPermanentFocusOwner, upFocusCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultKeyboardFocusManager

public DefaultKeyboardFocusManager()
方法详细信息

dispatchEvent

public boolean dispatchEvent(AWTEvent e)
此方法由 AWT 事件调度程序调用，该调度程序请求当前的 KeyboardFocusManager 以它的名义指派指定的事件。DefaultKeyboardFocusManagers 指派所有 FocusEvents、所有与焦点有关的 WindowEvents 和所有 KeyEvents。根据 KeyboardFocusManager 的焦点所有者、聚焦的窗口和活动窗口的概念来指派这些事件，有时需要重写指定 AWTEvent 的源代码。如果此方法返回 false，则 AWT 事件调度程序会试着指派事件本身。

指定者：
类 KeyboardFocusManager 中的 dispatchEvent
参数：
e - 要指派的 AWTEvent
返回：
如果此方法指派了事件，则返回 true；否则返回 false
另请参见：
KeyboardFocusManager.redispatchEvent(java.awt.Component, java.awt.AWTEvent), KeyboardFocusManager.dispatchKeyEvent(java.awt.event.KeyEvent)

dispatchKeyEvent

public boolean dispatchKeyEvent(KeyEvent e)
如果调度程序链中其他 KeyEventDispatcher 都没有调度 KeyEvent，或者没有注册其他 KeyEventDispatcher，则由 dispatchEvent 调用此方法。如果没有使用该事件，而是启用了它的目标，且焦点所有者不为 null，则此方法会将该事件指派到它的目标。此方法随后会将该事件指派到所有已注册的 KeyEventPostProcessor。完成所有这些操作之后，会将该事件传递给 KeyEventPostProcessor 的同位体进行处理。

在所有情况下，此方法都将返回 true，这是因为设计了 DefaultKeyboardFocusManager，因此，在任何情况下，dispatchEvent 和 AWT 事件调度程序都不应该对该事件执行进一步的操作。

指定者：
接口 KeyEventDispatcher 中的 dispatchKeyEvent
指定者：
类 KeyboardFocusManager 中的 dispatchKeyEvent
参数：
e - 要指派的 KeyEvent
返回：
true
另请参见：
Component.dispatchEvent(java.awt.AWTEvent)

postProcessKeyEvent

public boolean postProcessKeyEvent(KeyEvent e)
由 dispatchKeyEvent 调用此方法。它将处理所有未使用的、映射到 AWT MenuShortcut 的 KeyEvent，这是通过使用该事件并激活快捷方式来实现的。

指定者：
接口 KeyEventPostProcessor 中的 postProcessKeyEvent
指定者：
类 KeyboardFocusManager 中的 postProcessKeyEvent
参数：
e - 要进行后处理的 KeyEvent
返回：
true
另请参见：
dispatchKeyEvent(java.awt.event.KeyEvent), MenuShortcut

processKeyEvent

public void processKeyEvent(Component focusedComponent,
                            KeyEvent e)
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。期望 focusedComponent 就是当前的焦点所有者，虽然事实不必如此。如果事实并非如此，则仍然要进行焦点遍历，就像 focusedComponent 是焦点所有者一样。

指定者：
类 KeyboardFocusManager 中的 processKeyEvent
参数：
focusedComponent - 作为焦点遍历操作的基础的 Component，如果指定事件表示 Component 的焦点遍历键，则执行焦点遍历操作
e - 可以表示焦点遍历键的事件

enqueueKeyEvents

protected void enqueueKeyEvents(long after,
                                Component untilFocused)
延迟对 KeyEvent 的指派，直到指定的 Component 成为焦点所有者。将时间戳迟于指定时间戳的 KeyEvent 加入队列，直到指定的 Component 接收一个 FOCUS_GAINED 事件，或者 AWT 通过调用 dequeueKeyEvents 或 discardKeyEvents 取消延迟请求。

指定者：
类 KeyboardFocusManager 中的 enqueueKeyEvents
参数：
after - 当前事件的时间戳，如果当前事件没有时间戳，或 AWT 无法确定当前正在处理哪个事件，则此参数为当前系统时间
untilFocused - 将接收任何挂起 KeyEvent 之前的 FOCUS_GAINED 事件的 Component
另请参见：
dequeueKeyEvents(long, java.awt.Component), discardKeyEvents(java.awt.Component)

dequeueKeyEvents

protected void dequeueKeyEvents(long after,
                                Component untilFocused)
释放正常指派到当前焦点所有者的所有 KeyEvent，这些 KeyEvent 因为调用了具有相同时间戳和 Component 的 enqueueKeyEvents 而被加入队列。如果给定的时间戳小于零，那么对于具有最早的时间戳（如果有）的给定 Component，应该取消未完成的入队请求。

指定者：
类 KeyboardFocusManager 中的 dequeueKeyEvents
参数：
after - 调用 enqueueKeyEvents 期间指定的时间戳，或为小于零的任意值
untilFocused - 调用 enqueueKeyEvents 期间指定的 Component
另请参见：
enqueueKeyEvents(long, java.awt.Component), discardKeyEvents(java.awt.Component)

discardKeyEvents

protected void discardKeyEvents(Component comp)
放弃因为一次或多次调用具有指定 Component 或其子代之一的 enqueueKeyEvents 而加入队列的所有 KeyEvent。

指定者：
类 KeyboardFocusManager 中的 discardKeyEvents
参数：
comp - 一次或多次调用 enqueueKeyEvents 期间指定的 Component，或这样一个 Component 的父组件
另请参见：
enqueueKeyEvents(long, java.awt.Component), dequeueKeyEvents(long, java.awt.Component)

focusPreviousComponent

public void focusPreviousComponent(Component aComponent)
使 aComponent 前面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。

指定者：
类 KeyboardFocusManager 中的 focusPreviousComponent
参数：
aComponent - 作为焦点遍历操作的基础的 Component
另请参见：
FocusTraversalPolicy, Component.transferFocusBackward()

focusNextComponent

public void focusNextComponent(Component aComponent)
使 aComponent 后面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。

指定者：
类 KeyboardFocusManager 中的 focusNextComponent
参数：
aComponent - 作为焦点遍历操作的基础的 Component
另请参见：
FocusTraversalPolicy, Component.transferFocus()

upFocusCycle

public void upFocusCycle(Component aComponent)
将焦点上移一个焦点遍历循环。通常，将焦点所有者设置为 aComponent 的焦点循环根，将当前的焦点循环根设置为新焦点所有者的焦点循环根。但是，如果 aComponent 的焦点循环根是一个 Window，则将焦点所有者设置为焦点循环根默认拥有焦点的 Component，当前的焦点循环根不变。

指定者：
类 KeyboardFocusManager 中的 upFocusCycle
参数：
aComponent - 作为焦点遍历操作的基础的 Component
另请参见：
Component.transferFocusUpCycle()

downFocusCycle

public void downFocusCycle(Container aContainer)
将焦点下移一个焦点遍历循环。如果 aContainer 是一个焦点循环根，则将焦点所有者设置为 aContainer 默认拥有焦点的 Component，并将当前的焦点循环根设置为 aContainer。如果 aContainer 不是一个焦点循环根，则不发生焦点遍历操作。

指定者：
类 KeyboardFocusManager 中的 downFocusCycle
参数：
aContainer - 作为焦点遍历操作的基础的 Component
另请参见：
Container.transferFocusDownCycle()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Desktop (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Desktop

java.lang.Object
    继承者  java.awt.Desktop

public class Desktop
extends Object

Desktop 类允许 Java 应用程序启动已在本机桌面上注册的关联应用程序，以处理 URI 或文件。

支持的操作包括：

  • 启动用户默认浏览器来显示指定的 URI；
  • 启动带有可选 mailto URI 的用户默认邮件客户端；
  • 启动已注册的应用程序，以打开、编辑或打印指定的文件。

此类提供与这些操作对应的方法。这些方法查找在当前平台上注册的关联应用程序，并启动该应用程序来处理 URI 或文件。如果没有关联应用程序或关联应用程序无法启动，则抛出异常。

应用程序被注册为 URI 或文件类型；例如，&quot;sxi&quot; 文件扩展名通常注册为 StarOffice。注册、访问和启动关联应用程序的机制与平台有关。

每个操作都是由 Desktop.Action 类表示的一种动作类型。

注：当调用一些动作和执行关联应用程序时，将在与启动 Java 应用程序相同的系统上执行它们。

从以下版本开始：
1.6

嵌套类摘要
static class Desktop.Action
表示动作类型。
方法摘要
void | browse(URI uri) 启动默认浏览器来显示 URI。
void | edit(File file) 启动关联编辑器应用程序并打开用于编辑的文件。
static Desktop | getDesktop() 返回当前浏览器上下文的 Desktop 实例。
static boolean | isDesktopSupported() 测试当前平台是否支持此类。
boolean | isSupported(Desktop.Action action) 测试当前平台是否支持某一动作。
void | mail() 启动用户默认邮件客户端的邮件组合窗口。
void | mail(URI mailtoURI) 启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。
void | open(File file) 启动关联应用程序来打开文件。
void | print(File file) 使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getDesktop

public static Desktop getDesktop()
返回当前浏览器上下文的 Desktop 实例。一些平台不支持 Desktop API；可以使用 isDesktopSupported() 方法来确定是否支持当前桌面。

返回：
当前浏览器上下文的 Desktop 实例
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
UnsupportedOperationException - 如果当前平台不支持此类
另请参见：
isDesktopSupported(), GraphicsEnvironment.isHeadless()

isDesktopSupported

public static boolean isDesktopSupported()
测试当前平台是否支持此类。如果不受支持，则使用 getDesktop() 获得实例。

返回：
如果当前平台支持此类，则返回 true；否则返回 false
另请参见：
getDesktop()

isSupported

public boolean isSupported(Desktop.Action action)
测试当前平台是否支持某一动作。

即使平台支持某一动作、文件或 URI，也可能没有针对该动作的注册应用程序。例如，大多数平台支持 Desktop.Action.OPEN 动作。但对于特定文件，可能没有用来打开它的注册应用程序。在这种情况下，isSupported(java.awt.Desktop.Action) 可能返回 true，但相应的动作方法将抛出 IOException。

参数：
action - 指定的 Desktop.Action
返回：
如果当前平台支持指定的动作，则返回 true；否则返回 false
另请参见：
Desktop.Action

open

public void open(File file)
          throws IOException
启动关联应用程序来打开文件。

如果指定的文件是一个目录，则启动当前平台的文件管理器打开它。

参数：
file - 要用关联应用程序打开的文件
抛出：
NullPointerException - 如果 file 为 null
IllegalArgumentException - 如果指定文件不存在
UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.OPEN 动作
IOException - 如果指定文件没有关联应用程序，或者关联应用程序无法启动
SecurityException - 如果安全管理器存在且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读取访问；或者它拒绝 AWTPermission("showWindowWithoutWarningBanner") 权限；或者不允许调用线程创建子进程
另请参见：
AWTPermission

edit

public void edit(File file)
          throws IOException
启动关联编辑器应用程序并打开用于编辑的文件。

参数：
file - 要打开用于编辑的文件
抛出：
NullPointerException - 如果指定文件为 null
IllegalArgumentException - 如果指定文件不存在
UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.EDIT 动作
IOException - 如果指定文件没有关联编辑器，或者关联应用程序无法启动
SecurityException - 如果安全管理器存在且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读取访问；或者 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写入访问；或者它拒绝 AWTPermission("showWindowWithoutWarningBanner") 权限；或者不允许调用线程创建子进程
另请参见：
AWTPermission

print

public void print(File file)
           throws IOException
使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。

参数：
file - 要打印的文件
抛出：
NullPointerException - 如果指定文件为 null
IllegalArgumentException - 如果指定文件不存在
UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.PRINT 动作
IOException - 如果指定文件没有可用于打印它的关联应用程序
SecurityException - 如果安全管理器存在且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读取访问；或者其 SecurityManager.checkPrintJobAccess() 方法拒绝打印文件的权限；或者不允许调用线程创建子进程

browse

public void browse(URI uri)
            throws IOException
启动默认浏览器来显示 URI。如果默认浏览器无法处理指定的 URI，则调用用于处理指定类型的 URI 的注册应用程序。正如 URI 类定义的一样，根据协议和 URI 的路径确定应用程序。

如果调用线程没有必需的权限，且它是从 applet 中调用的，则使用 AppletContext.showDocument()。类似地，如果调用线程没有必需的权限，且它是从 Java Web Started 应用程序中调用的，则使用 BasicService.showDocument()。

参数：
uri - 将显示在用户默认浏览器中的 URI
抛出：
NullPointerException - 如果 uri 为 null
UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.BROWSE 动作
IOException - 如果未找到用户默认浏览器或无法启动它，或者默认处理器应用程序无法启动
SecurityException - 如果安全管理器存在且它拒绝 AWTPermission("showWindowWithoutWarningBanner") 权限；或者它不允许调用线程创建子进程，且不是从 applet 或 Java Web Started 应用程序中调用的
IllegalArgumentException - 如果必需权限不可用且 URI 无法转换为 URL
另请参见：
URI, AWTPermission, AppletContext

mail

public void mail()
          throws IOException
启动用户默认邮件客户端的邮件组合窗口。

抛出：
UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.MAIL 动作
IOException - 如果未找到默认邮件客户端，或者无法启动它
SecurityException - 如果安全管理器存在且它拒绝 AWTPermission("showWindowWithoutWarningBanner") 权限，或者它不允许调用线程创建子进程
另请参见：
AWTPermission

mail

public void mail(URI mailtoURI)
          throws IOException
启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。

mailto:URI 可以指定包含 "to"、"cc"、"subject"、"body" 等内容的消息字段。有关 mailto: URI 规范的详细信息，请参阅 mailto URL scheme (RFC 2368)。

参数：
mailtoURI - 指定的 mailto:URI
抛出：
NullPointerException - 如果指定的 URI 为 null
IllegalArgumentException - 如果 URI 方案不是 "mailto"
UnsupportedOperationException - 如果当前平台不支持 Desktop.Action.MAIL 动作
IOException - 如果未找到用户默认邮件客户端或无法启动它
SecurityException - 如果安全管理器存在且它拒绝 AWTPermission("showWindowWithoutWarningBanner") 权限，或者它不允许调用线程创建子进程
另请参见：
URI, AWTPermission
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Desktop.Action (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.awt
枚举 Desktop.Action

java.lang.Object
    继承者  java.lang.Enum<Desktop.Action>
        继承者  java.awt.Desktop.Action
所有已实现的接口：
Serializable, Comparable<Desktop.Action>
正在封闭类：
Desktop
public static enum Desktop.Action
extends Enum<Desktop.Action>

表示动作类型。每个平台都支持不同的动作集。可以使用 Desktop.isSupported(java.awt.Desktop.Action) 方法确定当前平台是否支持给定动作。

从以下版本开始：
1.6
另请参见：
Desktop.isSupported(java.awt.Desktop.Action)

枚举常量摘要
BROWSE
表示“浏览”动作。
EDIT
表示“编辑”动作。
MAIL
表示“邮寄”动作。
OPEN
表示“打开”动作。
PRINT
表示“打印”动作。
方法摘要
static Desktop.Action | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Desktop.Action[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

OPEN

public static final Desktop.Action OPEN
表示“打开”动作。

另请参见：
Desktop.open(java.io.File)

EDIT

public static final Desktop.Action EDIT
表示“编辑”动作。

另请参见：
Desktop.edit(java.io.File)

PRINT

public static final Desktop.Action PRINT
表示“打印”动作。

另请参见：
Desktop.print(java.io.File)

MAIL

public static final Desktop.Action MAIL
表示“邮寄”动作。

另请参见：
Desktop.mail(), Desktop.mail(java.net.URI)

BROWSE

public static final Desktop.Action BROWSE
表示“浏览”动作。

另请参见：
Desktop.browse(java.net.URI)
方法详细信息

values

public static final Desktop.Action[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Desktop.Action c : Desktop.Action.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Desktop.Action valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Dialog (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Dialog

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
                继承者  java.awt.Dialog
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
FileDialog, JDialog
public class Dialog
extends Window

Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。Dialog 的大小包括边界所指定的任何区域。边界区的维度可以使用 getInsets 方法获得，但是，由于这些维度是依赖于平台的，因此只有通过调用 pack 或 show 将 dialog 设置为可显示的，才能获得有效的 insets 值。由于 dialog 的总大小包括了边界区，因此边界有效地模糊了 dialog 的部分区域，约束了可用于在矩形中呈现或显示子部件的区域，矩形左上角的位置为 (insets.left, insets.top)，宽度为 width - (insets.left + insets.right)，长度为 height - (insets.top + insets.bottom)。

Dialog 的默认布局为 BorderLayout。

Dialog 可以使用 setUndecorated 关闭本机装饰（例如 Frame & Titlebar）。只有在 dialog 不是 displayable 时才能完成此操作。

在构造 dialog 时，dialog 可以拥有另一个窗口作为它自己的窗口。当可见的 dialog 的所有者窗口被最小化时，dialog 会自动隐藏为对用户不可见。当所有者窗口被还原时，dialog 重新又变为用户可见的。

在多屏幕环境中，可以在不同于其所有者的屏幕设备上创建 Dialog。有关更多信息，请参阅 Frame。

dialog 可以是无模式的（默认情况下）或有模式的。有模式的 dialog 会阻止将内容输入到应用程序中的其他一些顶层窗口中（将此 dialog 创建为其所有者的所有窗口除外）。有关细节，请参阅 AWT Modality 规范。

Dialog 能够产生以下 WindowEvents：WindowOpened、WindowClosing、WindowClosed、WindowActivated、WindowDeactivated、WindowGainedFocus、WindowLostFocus。

从以下版本开始：
JDK1.0
另请参见：
WindowEvent, Window.addWindowListener(java.awt.event.WindowListener), 序列化表格

嵌套类摘要
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
static class | Dialog.ModalExclusionType 任何顶层窗口都可以标记为不受模式对话框阻塞。
static class | Dialog.ModalityType 模式对话框阻塞对某些顶层窗口的所有输入。
从类 java.awt.Window 继承的嵌套类/接口
Window.AccessibleAWTWindow
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static Dialog.ModalityType DEFAULT_MODALITY_TYPE
有模式 dialog 的默认模式类型。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Dialog(Dialog owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Dialog 和一个空标题。
Dialog(Dialog owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。
Dialog(Dialog owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。
Dialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。
Dialog(Frame owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Frame 和一个空标题。
Dialog(Frame owner, boolean modal)
构造一个最初不可见的 Dialog，它带有指定所有者 Frame、模式和一个空标题。
Dialog(Frame owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。
Dialog(Frame owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。
Dialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。
Dialog(Window owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Window 和一个空标题。
Dialog(Window owner, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。
Dialog(Window owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。
Dialog(Window owner, String title, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。
Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。
方法摘要
void | addNotify() 通过将此 Dialog 连接到本机屏幕资源，从而使其成为可显示的。
AccessibleContext | getAccessibleContext() 获取与此 Dialog 有关的 AccessibleContext。
Dialog.ModalityType | getModalityType() 返回此 dialog 的模式类型。
String | getTitle() 获取 dialog 的标题。
void | hide() 已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
boolean | isModal() 指出 dialog 是否为有模式的。
boolean | isResizable() 指出此 dialog 是否可以由用户调整大小。
boolean | isUndecorated() 指出此 dialog 是否未装饰。
protected String | paramString() 返回表示此 dialog 状态的字符串。
void | setModal(boolean modal) 指定此 dialog 是否应该是有模式的。
void | setModalityType(Dialog.ModalityType type) 设置此 dialog 的模式类型。
void | setResizable(boolean resizable) 设置此 dialog 是否可以由用户调整大小。
void | setTitle(String title) 设置 Dialog 的标题。
void | setUndecorated(boolean undecorated) 禁用或启用此 dialog 的装饰。
void | setVisible(boolean b) 根据参数 b 的值显示或隐藏此 Dialog。
void | show() 已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
void | toBack() 如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。
从类 java.awt.Window 继承的方法
addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getGraphicsConfiguration, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOwnedWindows, getOwner, getOwnerlessWindows, getToolkit, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isShowing, pack, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, toFront
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_MODALITY_TYPE

public static final Dialog.ModalityType DEFAULT_MODALITY_TYPE
有模式 dialog 的默认模式类型。默认模式类型是 APPLICATION_MODAL。调用旧式 setModal(true) 等效于调用 setModalityType(DEFAULT_MODALITY_TYPE)。

从以下版本开始：
1.6
另请参见：
Dialog.ModalityType, setModal(boolean)
构造方法详细信息

Dialog

public Dialog(Frame owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Frame 和一个空标题。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
另请参见：
GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean)

Dialog

public Dialog(Frame owner,
              boolean modal)
构造一个最初不可见的 Dialog，它带有指定所有者 Frame、模式和一个空标题。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
modal - 指定在显示的时候是否阻止用户将内容输入到其他顶级窗口中。如果该参数为 false，则 dialog 是 MODELESS；如果该参数为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, DEFAULT_MODALITY_TYPE, setModal(boolean), setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless()

Dialog

public Dialog(Frame owner,
              String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
另请参见：
GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean)

Dialog

public Dialog(Frame owner,
              String title,
              boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
modal - 指定在显示的时候是否阻止用户将内容输入到其他顶级窗口中。如果该参数为 false，则 dialog 是 MODELESS；如果该参数为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, DEFAULT_MODALITY_TYPE, setModal(boolean), setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), Component.setSize(int, int), Component.setVisible(boolean)

Dialog

public Dialog(Frame owner,
              String title,
              boolean modal,
              GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
modal - 指定在显示的时候是否阻止用户将内容输入到其他顶级窗口中。如果该参数为 false，则 dialog 是 MODELESS；如果该参数为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE
gc - 目标屏幕设备的 GraphicsConfiguration；如果该参数为 null，则假定默认系统为 GraphicsConfiguration
抛出：
IllegalArgumentException - 如果 gc 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.4
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, DEFAULT_MODALITY_TYPE, setModal(boolean), setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), Component.setSize(int, int), Component.setVisible(boolean)

Dialog

public Dialog(Dialog owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Dialog 和一个空标题。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.2
另请参见：
GraphicsEnvironment.isHeadless()

Dialog

public Dialog(Dialog owner,
              String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.2
另请参见：
GraphicsEnvironment.isHeadless()

Dialog

public Dialog(Dialog owner,
              String title,
              boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
modal - 指定在显示的时候是否阻止用户将内容输入到其他顶级窗口中。如果该参数为 false，则 dialog 是 MODELESS；如果该参数为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.2
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, DEFAULT_MODALITY_TYPE, setModal(boolean), setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless()

Dialog

public Dialog(Dialog owner,
              String title,
              boolean modal,
              GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。

参数：
owner - dialog 的所有者，如果此 dialog 没有所有者，则该参数为 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
modal - 指定在显示的时候是否阻止用户将内容输入到其他顶级窗口中。如果该参数为 false，则 dialog 是 MODELESS；如果该参数为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE
gc - 目标屏幕设备的 GraphicsConfiguration；如果该参数为 null，则假定默认系统为 GraphicsConfiguration
抛出：
IllegalArgumentException - 如果 gc 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.4
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, DEFAULT_MODALITY_TYPE, setModal(boolean), setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), Component.setSize(int, int), Component.setVisible(boolean)

Dialog

public Dialog(Window owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Window 和一个空标题。

参数：
owner - dialog 的所有者。该所有者必须是 Dialog、Frame 以及它们的任何后代的实例，或者是 null
抛出：
IllegalArgumentException - 如果 owner 不是 Dialog 或 Frame 实例
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.6
另请参见：
GraphicsEnvironment.isHeadless()

Dialog

public Dialog(Window owner,
              String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。

参数：
owner - dialog 的所有者。该所有者必须是 Dialog、Frame 以及它们的任何后代的实例，或者是 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
抛出：
IllegalArgumentException - 如果 owner 不是 Dialog 或 Frame 实例
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.6
另请参见：
GraphicsEnvironment.isHeadless()

Dialog

public Dialog(Window owner,
              Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。

参数：
owner - dialog 的所有者。该所有者必须是 Dialog、Frame 以及它们的任何后代的实例，或者是 null
modalityType - 指定 dialog 是否阻止用户在显示的时候将内容输入其他窗口。null 值和不受支持的模式类型等效于 MODELESS
抛出：
IllegalArgumentException - 如果 owner 不是 Dialog 或 Frame 实例
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某个屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
SecurityException - 如果调用线程没有使用给定 modalityType 创建有模式 dialog 的权限
从以下版本开始：
1.6
另请参见：
Dialog.ModalityType,
setModal(boolean),
setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

Dialog

public Dialog(Window owner,
              String title,
              Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。

参数：
owner - dialog 的所有者。该所有者必须是 Dialog、Frame 以及它们的任何后代的实例，或者是 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
modalityType - 指定 dialog 是否阻止用户在显示的时候将内容输入其他窗口中。null 值和不受支持的模式类型等效于 MODELESS
抛出：
IllegalArgumentException - 如果 owner 不是 Dialog 或 Frame 实例
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自某个屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
SecurityException - 如果调用线程没有使用给定 modalityType 创建有模式 dialog 的权限
从以下版本开始：
1.6
另请参见：
Dialog.ModalityType,
setModal(boolean),
setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

Dialog

public Dialog(Window owner,
              String title,
              Dialog.ModalityType modalityType,
              GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。

参数：
owner - dialog 的所有者。该所有者必须是 Dialog、Frame 以及它们的任何后代的实例，或者是 null
title - dialog 的标题，如果此 dialog 没有标题，则该参数为 null
modalityType - 指定 dialog 是否阻止用户在显示的时候将内容输入其他窗口。null 值和不受支持的模式类型等效于 MODELESS
gc - 目标屏幕设备的 GraphicsConfiguration；如果该参数为 null，则假定默认系统为 GraphicsConfiguration
抛出：
IllegalArgumentException - 如果 owner 不是 Dialog 或 Frame 实例
IllegalArgumentException - 如果 gc 不是来自某一屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
SecurityException - 如果调用线程没有使用给定 modalityType 创建有模式 dialog 的权限
从以下版本开始：
1.6
另请参见：
Dialog.ModalityType,
setModal(boolean),
setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)
方法详细信息

addNotify

public void addNotify()
通过将此 Dialog 连接到本机屏幕资源，从而使其成为可显示的。如果 dialog 是可显示的，则其所有子级也将成为可显示的。由工具包在内部调用此方法，而不应该直接由程序调用。

覆盖：
类 Window 中的 addNotify
另请参见：
Component.isDisplayable(), Window.removeNotify()

isModal

public boolean isModal()
指出 dialog 是否为有模式的。

此方法已过时，保留它只是为了后向兼容。可以使用 getModalityType() 代替。

返回：
如果此 dialog 窗口是有模式的，则返回 true；否则返回 false
另请参见：
DEFAULT_MODALITY_TYPE, Dialog.ModalityType.MODELESS, setModal(boolean), getModalityType(), setModalityType(java.awt.Dialog.ModalityType)

setModal

public void setModal(boolean modal)
指定此 dialog 是否应该是有模式的。

此方法已过时，保留它只是为了后向兼容。可以使用 setModalityType() 代替。

注：更改可见 dialog 的模式只在隐藏该 dialog 并再次显示它时产生效果。

参数：
modal - 指定 dialog 是否阻止在显示的时候将内容输入其他窗口；调用 setModal(true) 等效于 setModalityType(Dialog.DEFAULT_MODALITY_TYPE)，而调用 setModal(false) 等效于 setModalityType(Dialog.ModalityType.MODELESS)
从以下版本开始：
1.1
另请参见：
DEFAULT_MODALITY_TYPE,
Dialog.ModalityType.MODELESS,
isModal(),
getModalityType(),
setModalityType(java.awt.Dialog.ModalityType)

getModalityType

public Dialog.ModalityType getModalityType()
返回此 dialog 的模式类型。

返回：
此 dialog 的模式类型
从以下版本开始：
1.6
另请参见：
setModalityType(java.awt.Dialog.ModalityType)

setModalityType

public void setModalityType(Dialog.ModalityType type)
设置此 dialog 的模式类型。有关可能的模式类型，请参阅 ModalityType。

如果给定模式类型不受支持，则使用 MODELESS。您可能想在调用此方法之后调用 getModalityType()，以确保模式类型已被设置。

注：更改可见 dialog 的模式只在隐藏该 dialog 并再次显示它时产生效果。

参数：
type - 指定 dialog 是否阻止在显示的时候将内容输入其他窗口。null 值和不受支持的模式类型等效于 MODELESS
抛出：
SecurityException - 如果调用线程没有使用给定 modalityType 创建有模式 dialog 的权限
从以下版本开始：
1.6
另请参见：
getModalityType(), Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

getTitle

public String getTitle()
获取 dialog 的标题。标题显示在 dialog 的边界中。

返回：
此 dialog 窗口的标题。标题可以为 null。
另请参见：
setTitle(java.lang.String)

setTitle

public void setTitle(String title)
设置 Dialog 的标题。

参数：
title - 显示在 dialog 的边界中的标题；null 值会导致一个空标题
另请参见：
getTitle()

setVisible

public void setVisible(boolean b)
根据参数 b 的值显示或隐藏此 Dialog。

覆盖：
类 Window 中的 setVisible
参数：
b - 如果该参数为 true，则使 Dialog 可见，否则隐藏 Dialog。如果 dialog 和/或其所有者尚不可显示，则使它们都变成可显示的。在使 dialog 可见之前，将验证该 dialog。如果该参数为 false，则隐藏 Dialog，并且随后导致返回 setVisible(true)（如果它目前受阻塞）。

对有模式 dialog 的注释。

  • setVisible(true)：如果 dialog 尚不可见，则在通过调用 setVisible(false) 或 dispose 隐藏 dialog 之前，此调用不会返回。
  • setVisible(false)：隐藏 dialog，然后返回 setVisible(true)（如果它目前受阻塞）。
  • 从事件指派线程调用此方法是受允许的，因为在此方法受阻塞时，工具包会确保其他事件不受阻塞。
另请参见：
Window.setVisible(boolean),
Window.dispose(),
Component.isDisplayable(),
Component.validate(),
isModal()

show

@Deprecated
public void show()
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。

使 Dialog 可见。如果 dialog 和/或其所有者尚不可显示，则使它们都变成可显示的。在使 dialog 可见之前，将验证该 dialog。如果 dialog 已经可见，则此方法会使 dialog 显示在前面。

如果 dialog 是有模式的并且尚不可见，则在通过调用 hide 或 dispose 方法隐藏 dialog 之前，此调用不会返回。从事件指派线程显示有模式 dialog 是受允许的，因为调用此方法的线程受阻塞时，工具包会确保另一个事件队列的运行。

覆盖：
类 Window 中的 show
另请参见：
Component.hide(),
Component.isDisplayable(),
Component.validate(),
isModal(),
Window.setVisible(boolean)

hide

@Deprecated
public void hide()
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。

隐藏 Dialog 并随后导致返回 show（如果它目前受阻塞）。

覆盖：
类 Window 中的 hide
另请参见：
Window.show(),
Window.dispose(),
Window.setVisible(boolean)

toBack

public void toBack()
如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。

在此虚拟机中，将此窗口放在堆栈顺序的底部，并在其他所有窗口之后显示此窗口。如果此窗口不可见，则不发生任何操作。有些平台不允许其他窗口拥有的窗口出现在其所有者下方。将进行所有尝试来移动此窗口，使其位于堆栈顺序中尽可能靠后的位置；不过，开发人员不应假定此方法在所有情况下都可以将此窗口移到所有其他窗口之下。

由于本机窗口系统多种多样，因此无法保证对焦点窗口和活动窗口的更改能够实现。在此窗口接收 WINDOW_LOST_FOCUS 或 WINDOW_DEACTIVATED 事件之前，开发人员不得假定此窗口不再是焦点窗口或活动窗口。在顶层窗口为焦点窗口的平台上，此方法可能导致此窗口不再是焦点状态。在此情况下，此虚拟机中紧跟其后的可作为焦点的窗口将成为焦点窗口。在堆栈顺序通常不影响焦点窗口的平台上，此方法可能维持焦点窗口和活动窗口不变。

如果此 dialog 是有模式的并且阻止某些窗口，则所有 dialog 都被发送回来，使它们位于正受阻塞的 dialog 下。

覆盖：
类 Window 中的 toBack
另请参见：
Window.toBack()

isResizable

public boolean isResizable()
指出此 dialog 是否可以由用户调整大小。默认情况下，所有 dialog 最初都是可调整的。

返回：
如果用户可以调整 dialog 的大小，则返回 true；否则返回 false。
另请参见：
setResizable(boolean)

setResizable

public void setResizable(boolean resizable)
设置此 dialog 是否可以由用户调整大小。

参数：
resizable - 如果用户可以调整 dialog 的大小，则返回 true；否则返回 false。
另请参见：
isResizable()

setUndecorated

public void setUndecorated(boolean undecorated)
禁用或启用此 dialog 的装饰。只有在 dialog 不可显示时才调用此方法。

参数：
undecorated - 如果没有启用 dialog 装饰，则为 true；如果启用了 dialog 装饰，则为 false。
抛出：
IllegalComponentStateException - 如果 dialog 是可显示的。
从以下版本开始：
1.4
另请参见：
isUndecorated(), Component.isDisplayable()

isUndecorated

public boolean isUndecorated()
指出此 dialog 是否未装饰。在默认情况下，所有 dialog 最初都是已装饰的。

返回：
如果 dialog 为未装饰，则为 true；否则为 false。
从以下版本开始：
1.4
另请参见：
setUndecorated(boolean)

paramString

protected String paramString()
返回表示此 dialog 状态的字符串。此方法仅用于调试目的，对于这两种实现，返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Container 中的 paramString
返回：
此 dialog 窗口的参数字符串。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Dialog 有关的 AccessibleContext。对于 dialog 来说，AccessibleContext 采用 AccessibleAWTDialog 的某种形式。必要时创建一个新的 AccessibleAWTDialog 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Window 中的 getAccessibleContext
返回：
AccessibleAWTDialog，用作此 Dialog 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Dialog.AccessibleAWTDialog (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Dialog.AccessibleAWTDialog

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Window.AccessibleAWTWindow
                    继承者  java.awt.Dialog.AccessibleAWTDialog
所有已实现的接口：
Serializable, AccessibleComponent
直接已知子类：
JDialog.AccessibleJDialog
正在封闭类：
Dialog
protected class Dialog.AccessibleAWTDialog
extends Window.AccessibleAWTWindow

此类实现对 Dialog 类的可访问性支持。它实现适合于 dialog 用户界面元素的 Java Accessibility API。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Dialog.AccessibleAWTDialog()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Dialog.AccessibleAWTDialog

protected Dialog.AccessibleAWTDialog()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Window.AccessibleAWTWindow 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

覆盖：
类 Window.AccessibleAWTWindow 中的 getAccessibleStateSet
返回：
包含对象的当前状态集合的 AccessibleStateSet 实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Dialog.ModalExclusionType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.awt
枚举 Dialog.ModalExclusionType

java.lang.Object
    继承者  java.lang.Enum<Dialog.ModalExclusionType>
        继承者  java.awt.Dialog.ModalExclusionType
所有已实现的接口：
Serializable, Comparable<Dialog.ModalExclusionType>
正在封闭类：
Dialog
public static enum Dialog.ModalExclusionType
extends Enum<Dialog.ModalExclusionType>

任何顶层窗口都可以标记为不受模式对话框阻塞。这称为“模式排斥”。此枚举指定可能的模式排斥类型。

从以下版本开始：
1.6
另请参见：
Window.getModalExclusionType(),
Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType),
Toolkit.isModalExclusionTypeSupported(java.awt.Dialog.ModalExclusionType)

枚举常量摘要
APPLICATION_EXCLUDE
APPLICATION_EXCLUDE 指示顶层窗口不会被任何应用程序模式对话框阻塞。
NO_EXCLUDE
无模式排斥。
TOOLKIT_EXCLUDE
TOOLKIT_EXCLUDE 指示顶层窗口不会被应用程序模式对话框或工具包模式对话框阻塞。
方法摘要
static Dialog.ModalExclusionType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Dialog.ModalExclusionType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

NO_EXCLUDE

public static final Dialog.ModalExclusionType NO_EXCLUDE
无模式排斥。

APPLICATION_EXCLUDE

public static final Dialog.ModalExclusionType APPLICATION_EXCLUDE
APPLICATION_EXCLUDE 指示顶层窗口不会被任何应用程序模式对话框阻塞。此外，它不会被其子层次结构范围之外的文档模式对话框阻塞。

TOOLKIT_EXCLUDE

public static final Dialog.ModalExclusionType TOOLKIT_EXCLUDE
TOOLKIT_EXCLUDE 指示顶层窗口不会被应用程序模式对话框或工具包模式对话框阻塞。此外，它不会被其子层次结构范围之外的文档模式对话框阻塞。必须为这种排斥授予 "toolkitModality" AWTPermission。如果将排斥属性更改为 TOOLKIT_EXCLUDE 且不授予此权限，则将抛出 SecurityEcxeption，排斥属性将保持不变。

方法详细信息

values

public static final Dialog.ModalExclusionType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Dialog.ModalExclusionType c : Dialog.ModalExclusionType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Dialog.ModalExclusionType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Dialog.ModalityType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.awt
枚举 Dialog.ModalityType

java.lang.Object
    继承者  java.lang.Enum<Dialog.ModalityType>
        继承者  java.awt.Dialog.ModalityType
所有已实现的接口：
Serializable, Comparable<Dialog.ModalityType>
正在封闭类：
Dialog
public static enum Dialog.ModalityType
extends Enum<Dialog.ModalityType>

模式对话框阻塞对某些顶层窗口的所有输入。是否阻塞某一特定窗口取决于对话框的模式类型；这被称为“阻塞范围”。ModalityType 枚举指定模式类型及其相关范围。

从以下版本开始：
1.6
另请参见：
Dialog.getModalityType(),
Dialog.setModalityType(java.awt.Dialog.ModalityType),
Toolkit.isModalityTypeSupported(java.awt.Dialog.ModalityType)

枚举常量摘要
APPLICATION_MODAL
APPLICATION_MODAL 对话框阻塞同一 Java 应用程序中的所有顶层窗口（它自己的子层次结构中的顶层窗口除外）。
DOCUMENT_MODAL
DOCUMENT_MODAL 对话框阻塞对同一文档中所有顶层窗口的输入（它自己的子层次结构中的顶层窗口除外）。
MODELESS
MODELESS 对话框不阻塞任何顶层窗口。
TOOLKIT_MODAL
TOOLKIT_MODAL 对话框阻塞从同一工具包运行所有顶层窗口（它自己的子层次结构中的顶层窗口除外）。
方法摘要
static Dialog.ModalityType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Dialog.ModalityType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

MODELESS

public static final Dialog.ModalityType MODELESS
MODELESS 对话框不阻塞任何顶层窗口。

DOCUMENT_MODAL

public static final Dialog.ModalityType DOCUMENT_MODAL
DOCUMENT_MODAL 对话框阻塞对同一文档中所有顶层窗口的输入（它自己的子层次结构中的顶层窗口除外）。文档是无所有者的顶层窗口。它可以包含子窗口，子窗口与顶层窗口一起被看作单个实体文档。因为每个顶层窗口必须隶属于某个文档，所以其根可以作为无所有者的最接近顶层的窗口找到。

APPLICATION_MODAL

public static final Dialog.ModalityType APPLICATION_MODAL
APPLICATION_MODAL 对话框阻塞同一 Java 应用程序中的所有顶层窗口（它自己的子层次结构中的顶层窗口除外）。如果浏览器中有几个已启动的 applet，那么可以将它们看作独立的应用程序或单个应用程序。此行为是依赖于实现的。

TOOLKIT_MODAL

public static final Dialog.ModalityType TOOLKIT_MODAL
TOOLKIT_MODAL 对话框阻塞从同一工具包运行所有顶层窗口（它自己的子层次结构中的顶层窗口除外）。如果浏览器中有几个已启动的 applet，则它们都将使用同一工具包运行；因此，通过 applet 显示的工具包模式对话框可能影响其他 applet，以及嵌入了此工具包 Java 运行时环境的浏览器实例的所有窗口。要使用工具包模式对话框，则必须授予特殊的 AWTPermission "toolkitModality"。如果正在创建 TOOLKIT_MODAL 对话框且没有授予此权限，则将抛出 SecurityException，且不创建任何对话框。如果将模式类型更改为 TOOLKIT_MODAL 且不授予此权限，则将抛出 SecurityException，模式类型保持不变。

方法详细信息

values

public static final Dialog.ModalityType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Dialog.ModalityType c : Dialog.ModalityType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Dialog.ModalityType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Dimension (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Dimension

java.lang.Object
    继承者  java.awt.geom.Dimension2D
        继承者  java.awt.Dimension
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
DimensionUIResource
public class Dimension
extends Dimension2D
implements Serializable

Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。该类与组件的某个属性关联。由 Component 类和 LayoutManager 接口定义的一些方法将返回 Dimension 对象。

通常，width 和 height 的值是非负整数。允许创建 dimension 的构造方法不会阻止您为这些属性设置负值。如果 width 或 height 的值为负，则由其他对象定义的一些方法的行为是不明确的。

从以下版本开始：
1.0
另请参见：
Component, LayoutManager, 序列化表格

字段摘要
int | height dimension 的高度，可以使用负值。
int | width dimension 的宽度，可以使用负值。
构造方法摘要
Dimension()
创建 Dimension 的一个实例（宽度为零，高度为零）。
Dimension(Dimension d)
创建 Dimension 的一个实例（宽度和高度与指定的 dimension 相同）。
Dimension(int width, int height)
构造一个 Dimension，并将其初始化为指定宽度和高度。
方法摘要
boolean | equals(Object obj) 检查两个 dimension 对象是否具有相同的值。
double | getHeight() 返回此 Dimension 的高度（以 double 精度表示）。
Dimension | getSize() 获取此 Dimension 对象的大小。
double | getWidth() 返回此 Dimension 的宽度（以 double 精度表示）。
int | hashCode() 返回此 Dimension 的哈希码。
void | setSize(Dimension d) 将 Dimension 对象的大小设置为指定大小。
void | setSize(double width, double height) 将此 Dimension 对象的大小设置为指定的宽度和高度（以双精度表示）。
void | setSize(int width, int height) 将此 Dimension 对象的大小设置为指定的宽度和高度。
String | toString() 返回此 Dimension 对象的 height 和 width 字段的字符串表示形式。
从类 java.awt.geom.Dimension2D 继承的方法
clone, setSize
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

width

public int width
dimension 的宽度，可以使用负值。

从以下版本开始：
1.0
另请参见：
getSize(), setSize(double, double)

height

public int height
dimension 的高度，可以使用负值。

从以下版本开始：
1.0
另请参见：
getSize(), setSize(double, double)
构造方法详细信息

Dimension

public Dimension()
创建 Dimension 的一个实例（宽度为零，高度为零）。

Dimension

public Dimension(Dimension d)
创建 Dimension 的一个实例（宽度和高度与指定的 dimension 相同）。

参数：
d - 带有 width 和 height 值的指定 dimension

Dimension

public Dimension(int width,
                 int height)
构造一个 Dimension，并将其初始化为指定宽度和高度。

参数：
width - 指定宽度
height - 指定高度
方法详细信息

getWidth

public double getWidth()
返回此 Dimension 的宽度（以 double 精度表示）。

指定者：
类 Dimension2D 中的 getWidth
返回：
此 Dimension 的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
返回此 Dimension 的高度（以 double 精度表示）。

指定者：
类 Dimension2D 中的 getHeight
返回：
此 Dimension 的高度。
从以下版本开始：
1.2

setSize

public void setSize(double width,
                    double height)
将此 Dimension 对象的大小设置为指定的宽度和高度（以双精度表示）。注意，如果 width 或 height 大于 Integer.MAX_VALUE，则将其重新设置为 Integer.MAX_VALUE。

指定者：
类 Dimension2D 中的 setSize
参数：
width - Dimension 对象的新宽度
height - Dimension 对象的新高度
从以下版本开始：
1.2

getSize

public Dimension getSize()
获取此 Dimension 对象的大小。包含此方法是出于完整性考虑，它与 Component 定义的 getSize 方法相似。

返回：
此 dimension 的大小，一个具有相同宽度和高度的 Dimension 的新实例
从以下版本开始：
1.1
另请参见：
setSize(double, double), Component.getSize()

setSize

public void setSize(Dimension d)
将 Dimension 对象的大小设置为指定大小。包含此方法是出于完整性考虑，它与 Component 定义的 setSize 方法相似。

参数：
d - Dimension 对象的新大小
从以下版本开始：
1.1
另请参见：
getSize(), Component.setSize(int, int)

setSize

public void setSize(int width,
                    int height)
将此 Dimension 对象的大小设置为指定的宽度和高度。包含此方法是出于完整性考虑，它与 Component 定义的 setSize 方法相似。

参数：
width - Dimension 对象的新宽度
height - Dimension 对象的新高度
从以下版本开始：
1.1
另请参见：
getSize(), Component.setSize(int, int)

equals

public boolean equals(Object obj)
检查两个 dimension 对象是否具有相同的值。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 Dimension 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Dimension 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 Dimension 对象的 height 和 width 字段的字符串表示形式。此方法仅用于调试目的，对于这两种实现，返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Object 中的 toString
返回：
该 Dimension 对象的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DisplayMode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 DisplayMode

java.lang.Object
    继承者  java.awt.DisplayMode

public final class DisplayMode
extends Object

DisplayMode 类封装 GraphicsDevice 的位深、高度、宽度和刷新率。更改图形设备的显示模式的能力是与平台和配置有关的，可能并不总是可用的（请参见 GraphicsDevice.isDisplayChangeSupported()）。

有关全屏独占模式的更多信息，请参阅全屏独占模式 API 教程。

从以下版本开始：
1.4
另请参见：
GraphicsDevice,
GraphicsDevice.isDisplayChangeSupported(),
GraphicsDevice.getDisplayModes(),
GraphicsDevice.setDisplayMode(java.awt.DisplayMode)

字段摘要
static int | BIT_DEPTH_MULTI 位深的值（如果此显示模式支持多个位深）。
static int | REFRESH_RATE_UNKNOWN 刷新率的值（如果未知）。
构造方法摘要
DisplayMode(int width, int height, int bitDepth, int refreshRate)
使用提供的参数创建一个新的显示模式对象。
方法摘要
boolean | equals(DisplayMode dm) 返回对两个显示模式是否相同的判断。
boolean | equals(Object dm) 指示其他某个对象是否与此对象“相等”。
int | getBitDepth() 返回显示的位深（以位/像素表示）。
int | getHeight() 返回显示的高度（以像素表示）。
int | getRefreshRate() 返回显示的刷新率（以赫兹表示）如果信息不可用，则它可以是 REFRESH_RATE_UNKNOWN。
int | getWidth() 返回显示的宽度（以像素表示）。
int | hashCode() 返回该对象的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BIT_DEPTH_MULTI

public static final int BIT_DEPTH_MULTI
位深的值（如果此显示模式支持多个位深）。

另请参见：
getBitDepth(), 常量字段值

REFRESH_RATE_UNKNOWN

public static final int REFRESH_RATE_UNKNOWN
刷新率的值（如果未知）。

另请参见：
getRefreshRate(), 常量字段值
构造方法详细信息

DisplayMode

public DisplayMode(int width,
                   int height,
                   int bitDepth,
                   int refreshRate)
使用提供的参数创建一个新的显示模式对象。

参数：
width - 显示的宽度（用像素表示）
height - 显示的高度（用像素表示）
bitDepth - 显示的位深（用位/像素表示）。如果有多个位深可用，它可以是 BIT_DEPTH_MULTI。
refreshRate - 显示的刷新率（以赫兹表示）。如果信息不可用，则它可以是 REFRESH_RATE_UNKNOWN。
另请参见：
BIT_DEPTH_MULTI, REFRESH_RATE_UNKNOWN
方法详细信息

getHeight

public int getHeight()
返回显示的高度（以像素表示）。

返回：
显示的高度（以像素表示）

getWidth

public int getWidth()
返回显示的宽度（以像素表示）。

返回：
显示的宽度（以像素表示）

getBitDepth

public int getBitDepth()
返回显示的位深（以位/像素表示）。如果此显示模式支持多个位深，则它可以是 BIT_DEPTH_MULTI。

返回：
显示的刷新率（以赫兹表示）。
另请参见：
BIT_DEPTH_MULTI

getRefreshRate

public int getRefreshRate()
返回显示的刷新率（以赫兹表示）如果信息不可用，则它可以是 REFRESH_RATE_UNKNOWN。 返回显示的刷新率（以赫兹表示）。

另请参见：
REFRESH_RATE_UNKNOWN

equals

public boolean equals(DisplayMode dm)
返回对两个显示模式是否相同的判断。

返回：
两个显示模式是否相同

equals

public boolean equals(Object dm)
指示其他某个对象是否与此对象“相等”。

equals 方法在非空对象引用上实现相等关系：

  • 自反性：对于任何非空引用值 x，x.equals(x) 都应返回 true。
  • 对称性：对于任何非空引用值 x 和 y，当且仅当 y.equals(x) 返回 true 时，x.equals(y) 才应返回 true。
  • 传递性：对于任何非空引用值 x、y 和 z，如果 x.equals(y) 返回 true，并且 y.equals(z) 返回 true，那么 x.equals(z) 应返回 true。
  • 一致性：对于任何非空引用值 x 和 y，多次调用 x.equals(y) 始终返回 true 或始终返回 false，前提是对象上 equals 比较中所用的信息没有被修改。
  • 对于任何非空引用值 x，x.equals(null) 都应返回 false。

Object 类的 equals 方法实现对象上差别可能性最大的相等关系；即，对于任何非空引用值 x 和 y，当且仅当 x 和 y 引用同一个对象时，此方法才返回 true（x == y 具有值 true）。

注意：当此方法被重写时，通常有必要重写 hashCode 方法，以维护 hashCode 方法的常规协定，该协定声明相等对象必须具有相等的哈希码。

覆盖：
类 Object 中的 equals
参数：
dm - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Event (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Event

java.lang.Object
    继承者  java.awt.Event
所有已实现的接口：
Serializable
public class Event
extends Object
implements Serializable

注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类及其子类所取代。

Event 是一个与平台无关的类，它封装了 Java 1.0 事件模型中来自平台图形用户界面的事件。在 Java 1.1 和以后的版本中，Event 类只针对向后兼容进行维护。此类描述中的信息可以协助程序员将 Java 1.0 程序转换成新的事件模型。

在 Java 1.0 事件模型中，包含 id 字段的事件指出它是什么类型的事件，以及与该事件有关的其他 Event 变量。

对于键盘事件来说，key 所包含的值指出要激活哪个键，modifiers 包含该事件的修饰符。对于 KEY_PRESS 和 KEY_RELEASE 事件的 id，key 的值是该键的 unicode 字符代码。对于 KEY_ACTION 和 KEY_ACTION_RELEASE，key 的值是 Event 类（PGUP、PGDN、F1、F2 等）中所定义的某个动作-键标识符。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static int | ACTION_EVENT 此事件指示用户想要某个事件发生。
static int | ALT_MASK 此标志指示当事件发生时按下 Alt 键。
Object | arg 事件的任意参数。
static int | BACK_SPACE BackSpace 键。
static int | CAPS_LOCK Caps Lock 键，一个非 ASCII 操作键。
int | clickCount 对于 MOUSE_DOWN 事件来说，此字段指示连续点击的次数。
static int | CTRL_MASK 此标志指示当事件发生时按下 Control 键。
static int | DELETE Delete 键。
static int | DOWN Down Arrow 键，一个非 ASCII 操作键。
static int | END End 键，一个非 ASCII 操作键。
static int | ENTER Enter 键。
static int | ESCAPE Escape 键。
Event | evt 下一事件。
static int | F1 F1 功能键，一个非 ASCII 操作键。
static int | F10 F10 功能键，一个非 ASCII 操作键。
static int | F11 F11 功能键，一个非 ASCII 操作键。
static int | F12 F12 功能键，一个非 ASCII 操作键。
static int | F2 F2 功能键，一个非 ASCII 操作键。
static int | F3 F3 功能键，一个非 ASCII 操作键。
static int | F4 F4 功能键，一个非 ASCII 操作键。
static int | F5 F5 功能键，一个非 ASCII 操作键。
static int | F6 F6 功能键，一个非 ASCII 操作键。
static int | F7 F7 功能键，一个非 ASCII 操作键。
static int | F8 F8 功能键，一个非 ASCII 操作键。
static int | F9 F9 功能键，一个非 ASCII 操作键。
static int | GOT_FOCUS 组件获得焦点。
static int | HOME Home 键，一个非 ASCII 操作键。
int | id 指示事件是什么类型的事件，其他哪个 Event 变量与该事件有关。
static int | INSERT Insert 键，一个非 ASCII 操作键。
int | key 在键盘事件中被按下的键的键代码。
static int | KEY_ACTION 用户已经按下一个非 ASCII action 键。
static int | KEY_ACTION_RELEASE 用户已经释放一个非 ASCII action 键。
static int | KEY_PRESS 用户已经按下一个常规键。
static int | KEY_RELEASE 用户已经释放一个常规键。
static int | LEFT Left Arrow 键，一个非 ASCII 操作键。
static int | LIST_DESELECT 已经取消选择列表中的一项。
static int | LIST_SELECT 已经选择了列表中的一项。
static int | LOAD_FILE 文件加载事件。
static int | LOST_FOCUS 组件失去焦点。
static int | META_MASK 此标志指示当事件发生时按下 Meta 键。
int | modifiers 修饰符键的状态。
static int | MOUSE_DOWN 用户已经按下鼠标按钮。
static int | MOUSE_DRAG 鼠标已经移动，同时按钮被按下。
static int | MOUSE_ENTER 鼠标已经进入了一个组件。
static int | MOUSE_EXIT 鼠标已经退出了一个组件。
static int | MOUSE_MOVE 鼠标已经移动，没有按钮被按下。
static int | MOUSE_UP 用户已经释放鼠标按钮。
static int | NUM_LOCK Num Lock 键，一个非 ASCII 操作键。
static int | PAUSE Pause 键，一个非 ASCII 操作键。
static int | PGDN Page Down 键，一个非 ASCII 操作键。
static int | PGUP Page Up 键，一个非 ASCII 操作键。
static int | PRINT_SCREEN Print Screen 键，一个非 ASCII 操作键。
static int | RIGHT Right Arrow 键，一个非 ASCII 操作键。
static int | SAVE_FILE 文件保存事件。
static int | SCROLL_ABSOLUTE 用户已经将滚动条中的“气泡”（即翻阅标志）移到一个“绝对的”位置，而不是相对最后位置的偏移量。
static int | SCROLL_BEGIN 滚动开始事件。
static int | SCROLL_END 滚动结束事件。
static int | SCROLL_LINE_DOWN 用户已经激活了滚动条的 line down 区域。
static int | SCROLL_LINE_UP 用户已经激活了滚动条的 line up 区域。
static int | SCROLL_LOCK Scroll Lock 键，一个非 ASCII 操作键。
static int | SCROLL_PAGE_DOWN 用户已经激活了滚动条的 page down 区域。
static int | SCROLL_PAGE_UP 用户已经激活了滚动条的 page up 区域。
static int | SHIFT_MASK 此标志指示当事件发生时按下 Shift 键。
static int | TAB Tab 键。
Object | target 目标组件。
static int | UP Up Arrow 键，一个非 ASCII 操作键。
long | when 时间戳。
static int | WINDOW_DEICONIFY 用户要求窗口管理程序取消窗口图标化。
static int | WINDOW_DESTROY 用户要求窗口管理程序关掉窗口。
static int | WINDOW_EXPOSE 用户要求窗口管理程序公开窗口。
static int | WINDOW_ICONIFY 用户要求窗口管理程序图标化窗口。
static int | WINDOW_MOVED 用户要求窗口管理程序移动窗口。
int | x 事件的 x 坐标。
int | y 事件的 y 坐标。
构造方法摘要
Event(Object target, int id, Object arg)
注：Event 类已废弃，只可用于向后兼容。
Event(Object target, long when, int id, int x, int y, int key, int modifiers)
注：Event 类已废弃，只可用于向后兼容。
Event(Object target, long when, int id, int x, int y, int key, int modifiers, Object arg)
注：Event 类已废弃，只可用于向后兼容。
方法摘要
boolean | controlDown() 注：Event 类已废弃，只可用于向后兼容。
boolean | metaDown() 注：Event 类已废弃，只可用于向后兼容。
protected String | paramString() 注：Event 类已废弃，只可用于向后兼容。
boolean | shiftDown() 注：Event 类已废弃，只可用于向后兼容。
String | toString() 注：Event 类已废弃，只可用于向后兼容。
void | translate(int dx, int dy) 注：Event 类已废弃，只可用于向后兼容。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SHIFT_MASK

public static final int SHIFT_MASK
此标志指示当事件发生时按下 Shift 键。

另请参见：
常量字段值

CTRL_MASK

public static final int CTRL_MASK
此标志指示当事件发生时按下 Control 键。

另请参见：
常量字段值

META_MASK

public static final int META_MASK
此标志指示当事件发生时按下 Meta 键。对于鼠标事件，此标志指示按下或释放右边按钮。

另请参见：
常量字段值

ALT_MASK

public static final int ALT_MASK
此标志指示当事件发生时按下 Alt 键。对于鼠标事件，此标志指示按下或释放中间鼠标按钮。

另请参见：
常量字段值

HOME

public static final int HOME
Home 键，一个非 ASCII 操作键。

另请参见：
常量字段值

END

public static final int END
End 键，一个非 ASCII 操作键。

另请参见：
常量字段值

PGUP

public static final int PGUP
Page Up 键，一个非 ASCII 操作键。

另请参见：
常量字段值

PGDN

public static final int PGDN
Page Down 键，一个非 ASCII 操作键。

另请参见：
常量字段值

UP

public static final int UP
Up Arrow 键，一个非 ASCII 操作键。

另请参见：
常量字段值

DOWN

public static final int DOWN
Down Arrow 键，一个非 ASCII 操作键。

另请参见：
常量字段值

LEFT

public static final int LEFT
Left Arrow 键，一个非 ASCII 操作键。

另请参见：
常量字段值

RIGHT

public static final int RIGHT
Right Arrow 键，一个非 ASCII 操作键。

另请参见：
常量字段值

F1

public static final int F1
F1 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F2

public static final int F2
F2 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F3

public static final int F3
F3 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F4

public static final int F4
F4 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F5

public static final int F5
F5 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F6

public static final int F6
F6 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F7

public static final int F7
F7 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F8

public static final int F8
F8 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F9

public static final int F9
F9 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F10

public static final int F10
F10 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F11

public static final int F11
F11 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

F12

public static final int F12
F12 功能键，一个非 ASCII 操作键。

另请参见：
常量字段值

PRINT_SCREEN

public static final int PRINT_SCREEN
Print Screen 键，一个非 ASCII 操作键。

另请参见：
常量字段值

SCROLL_LOCK

public static final int SCROLL_LOCK
Scroll Lock 键，一个非 ASCII 操作键。

另请参见：
常量字段值

CAPS_LOCK

public static final int CAPS_LOCK
Caps Lock 键，一个非 ASCII 操作键。

另请参见：
常量字段值

NUM_LOCK

public static final int NUM_LOCK
Num Lock 键，一个非 ASCII 操作键。

另请参见：
常量字段值

PAUSE

public static final int PAUSE
Pause 键，一个非 ASCII 操作键。

另请参见：
常量字段值

INSERT

public static final int INSERT
Insert 键，一个非 ASCII 操作键。

另请参见：
常量字段值

ENTER

public static final int ENTER
Enter 键。

另请参见：
常量字段值

BACK_SPACE

public static final int BACK_SPACE
BackSpace 键。

另请参见：
常量字段值

TAB

public static final int TAB
Tab 键。

另请参见：
常量字段值

ESCAPE

public static final int ESCAPE
Escape 键。

另请参见：
常量字段值

DELETE

public static final int DELETE
Delete 键。

另请参见：
常量字段值

WINDOW_DESTROY

public static final int WINDOW_DESTROY
用户要求窗口管理程序关掉窗口。

另请参见：
常量字段值

WINDOW_EXPOSE

public static final int WINDOW_EXPOSE
用户要求窗口管理程序公开窗口。

另请参见：
常量字段值

WINDOW_ICONIFY

public static final int WINDOW_ICONIFY
用户要求窗口管理程序图标化窗口。

另请参见：
常量字段值

WINDOW_DEICONIFY

public static final int WINDOW_DEICONIFY
用户要求窗口管理程序取消窗口图标化。

另请参见：
常量字段值

WINDOW_MOVED

public static final int WINDOW_MOVED
用户要求窗口管理程序移动窗口。

另请参见：
常量字段值

KEY_PRESS

public static final int KEY_PRESS
用户已经按下一个常规键。

另请参见：
常量字段值

KEY_RELEASE

public static final int KEY_RELEASE
用户已经释放一个常规键。

另请参见：
常量字段值

KEY_ACTION

public static final int KEY_ACTION
用户已经按下一个非 ASCII action 键。key 字段包含一个值，指示发生在某个操作键上的事件，操作键包括 12 个功能键、箭头（光标）键、Page Up、Page Down、Home、End、Print Screen、Scroll Lock、Caps Lock、Num Lock、Pause 和 Insert。

另请参见：
常量字段值

KEY_ACTION_RELEASE

public static final int KEY_ACTION_RELEASE
用户已经释放一个非 ASCII action 键。key 字段包含一个值，指示发生在某个操作键中的事件，操作键包括 12 个功能键、箭头（光标）键、Page Up、Page Down、Home、End、Print Screen、Scroll Lock、Caps Lock、Num Lock、Pause 和 Insert。

另请参见：
常量字段值

MOUSE_DOWN

public static final int MOUSE_DOWN
用户已经按下鼠标按钮。ALT_MASK 标志指示中间按钮已经被按下。META_MASK 标志指示右按钮已经被按下。

另请参见：
ALT_MASK, META_MASK, 常量字段值

MOUSE_UP

public static final int MOUSE_UP
用户已经释放鼠标按钮。ALT_MASK 标志指示中间按钮已经被释放。META_MASK 标志指示右边按钮已经被释放。

另请参见：
ALT_MASK, META_MASK, 常量字段值

MOUSE_MOVE

public static final int MOUSE_MOVE
鼠标已经移动，没有按钮被按下。

另请参见：
常量字段值

MOUSE_ENTER

public static final int MOUSE_ENTER
鼠标已经进入了一个组件。

另请参见：
常量字段值

MOUSE_EXIT

public static final int MOUSE_EXIT
鼠标已经退出了一个组件。

另请参见：
常量字段值

MOUSE_DRAG

public static final int MOUSE_DRAG
鼠标已经移动，同时按钮被按下。ALT_MASK 标志指示中间按钮正在被按下。META_MASK 标志指示右边按钮正在被按下。

另请参见：
ALT_MASK, META_MASK, 常量字段值

SCROLL_LINE_UP

public static final int SCROLL_LINE_UP
用户已经激活了滚动条的 line up 区域。

另请参见：
常量字段值

SCROLL_LINE_DOWN

public static final int SCROLL_LINE_DOWN
用户已经激活了滚动条的 line down 区域。

另请参见：
常量字段值

SCROLL_PAGE_UP

public static final int SCROLL_PAGE_UP
用户已经激活了滚动条的 page up 区域。

另请参见：
常量字段值

SCROLL_PAGE_DOWN

public static final int SCROLL_PAGE_DOWN
用户已经激活了滚动条的 page down 区域。

另请参见：
常量字段值

SCROLL_ABSOLUTE

public static final int SCROLL_ABSOLUTE
用户已经将滚动条中的“气泡”（即翻阅标志）移到一个“绝对的”位置，而不是相对最后位置的偏移量。

另请参见：
常量字段值

SCROLL_BEGIN

public static final int SCROLL_BEGIN
滚动开始事件。

另请参见：
常量字段值

SCROLL_END

public static final int SCROLL_END
滚动结束事件。

另请参见：
常量字段值

LIST_SELECT

public static final int LIST_SELECT
已经选择了列表中的一项。

另请参见：
常量字段值

LIST_DESELECT

public static final int LIST_DESELECT
已经取消选择列表中的一项。

另请参见：
常量字段值

ACTION_EVENT

public static final int ACTION_EVENT
此事件指示用户想要某个事件发生。

另请参见：
常量字段值

LOAD_FILE

public static final int LOAD_FILE
文件加载事件。

另请参见：
常量字段值

SAVE_FILE

public static final int SAVE_FILE
文件保存事件。

另请参见：
常量字段值

GOT_FOCUS

public static final int GOT_FOCUS
组件获得焦点。

另请参见：
常量字段值

LOST_FOCUS

public static final int LOST_FOCUS
组件失去焦点。

另请参见：
常量字段值

target

public Object target
目标组件。这指示事件针对该组件发生，或事件与该组件关联。此对象已经由 AWTEvent.getSource() 取代。

另请参见：
EventObject.getSource()

when

public long when
时间戳。由 InputEvent.getWhen() 取代。

另请参见：
InputEvent.getWhen()

id

public int id
指示事件是什么类型的事件，其他哪个 Event 变量与该事件有关。它已经由 AWTEvent.getID() 取代。

另请参见：
AWTEvent.getID()

x

public int x
事件的 x 坐标。由 MouseEvent.getX() 取代。

另请参见：
MouseEvent.getX()

y

public int y
事件的 y 坐标。由 MouseEvent.getY() 取代。

另请参见：
MouseEvent.getY()

key

public int key
在键盘事件中被按下的键的键代码。这已经由 KeyEvent.getKeyCode() 取代。

另请参见：
KeyEvent.getKeyCode()

modifiers

public int modifiers
修饰符键的状态。这已经由 InputEvent.getModifiers() 取代。在 java 1.1 中，MouseEvent 和 KeyEvent 是 InputEvent 的子类。

另请参见：
InputEvent.getModifiers()

clickCount

public int clickCount
对于 MOUSE_DOWN 事件来说，此字段指示连续点击的次数。对于其他事件，其值为 0。此字段由 MouseEvent.getClickCount() 取代。

另请参见：
MouseEvent.getClickCount().

arg

public Object arg
事件的任意参数。此字段的值取决于事件的类型。arg 已经由事件指定的属性取代。

evt

public Event evt
下一事件。将事件放入到链接列表时设置此字段。这已经由 EventQueue 取代。

另请参见：
EventQueue
构造方法详细信息

Event

public Event(Object target,
             long when,
             int id,
             int x,
             int y,
             int key,
             int modifiers,
             Object arg)
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类及其子类所取代。

创建 Event 的一个实例，具有指定的目标组件、时间戳、事件类型、x 和 y 坐标、键盘键、修饰符键的状态、参数。

参数：
target - 目标组件。
when - 时间戳。
id - 事件类型。
x - x 坐标。
y - y 坐标。
key - 在键盘事件中按下的键。
modifiers - 修饰符键的状态。
arg - 指定参数。

Event

public Event(Object target,
             long when,
             int id,
             int x,
             int y,
             int key,
             int modifiers)
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

创建 Event 的一个实例，具有指定的目标组件、时间戳、事件类型、x 和 y 坐标、键盘键、修饰符键的状态、一个设置为 null 的参数。

参数：
target - 目标组件。
when - 时间戳。
id - 事件类型。
x - x 坐标。
y - y 坐标。
key - 在键盘事件中按下的键。
modifiers - 修饰符键的状态。

Event

public Event(Object target,
             int id,
             Object arg)
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

使用指定的目标组件、事件类型和参数创建 Event 的一个实例。

参数：
target - 目标组件。
id - 事件类型。
arg - 指定参数。
方法详细信息

translate

public void translate(int dx,
                      int dy)
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

转换此事件，使其 x 和 y 坐标分别以 dx 和 dy 递增。

此方法转换与给定组件相关的事件。这至少涉及到将坐标转换成给定组件的本地坐标系。它还可能涉及到在公开事件中转换一个区域

参数：
dx - 要转换 x 坐标的距离。
dy - 要转换 y 坐标的距离。

shiftDown

public boolean shiftDown()
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

检查 Shift 键是否被按下。

返回：
如果该键被按下，则返回 true；否则返回 false。
另请参见：
modifiers, controlDown(), metaDown()

controlDown

public boolean controlDown()
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

检查 Control 键是否被按下。

返回：
如果该键被按下，则返回 true；否则返回 false。
另请参见：
modifiers, shiftDown(), metaDown()

metaDown

public boolean metaDown()
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

检查 Meta 键是否被按下。

返回：
如果该键被按下，则返回 true；否则返回 false。
另请参见：
modifiers, shiftDown(), controlDown()

paramString

protected String paramString()
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

返回此 Event 状态的字符串表示形式。此方法仅用于调试目的，对于这两种实现，返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

返回：
此事件的参数字符串

toString

public String toString()
注：Event 类已废弃，只可用于向后兼容。它已经由 AWTEvent 类和其子类所取代。

返回此事件的值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
字符串，表示事件及其成员字段的值。
从以下版本开始：
JDK1.1
另请参见：
paramString()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 EventQueue

java.lang.Object
    继承者  java.awt.EventQueue

public class EventQueue
extends Object

EventQueue 是一个与平台无关的类，它将来自于底层同位体类和受信任的应用程序类的事件列入队列。

它封装了异步事件指派机制，该机制从队列中提取事件，然后通过对此 EventQueue 调用 dispatchEvent(AWTEvent) 方法来指派这些事件（事件作为参数被指派）。该机制的特殊行为是与实现有关的。指派实际排入到该队列中的事件（注意，正在发送到 EventQueue 中的事件可以被合并）的唯一要求是：

按顺序指派。
也就是说，不允许同时从该队列中指派多个事件。
指派顺序与它们排队的顺序相同。
也就是说，如果 AWTEvent A 比 AWTEvent B 先排入到 EventQueue 中，那么事件 B 不能在事件 A 之前被指派。

一些浏览器将不同代码基中的 applet 分成独立的上下文，并在这些上下文之间建立一道道墙。在这样的场景中，每个上下文将会有一个 EventQueue。其他浏览器将所有的 applet 放入到同一个上下文中，这意味着所有 applet 只有一个全局 EventQueue。该行为是与实现有关的。有关更多信息，请参照浏览器的文档。

有关事件指派机制的线程问题，请参阅 AWT 线程问题。

从以下版本开始：
1.1

构造方法摘要
EventQueue()
方法摘要
protected void | dispatchEvent(AWTEvent event) 指派一个事件。
static AWTEvent | getCurrentEvent() 返回当前正在被 EventQueue（它与正在调用的线程相关）指派的事件。
static long | getMostRecentEventTime() 返回最近事件的时间戳（如果有），该事件从 EventQueue（它与正在调用的线程相关）进行指派。
AWTEvent | getNextEvent() 从 EventQueue 中移除一个事件，并返回该事件。
static void | invokeAndWait(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
static void | invokeLater(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
static boolean | isDispatchThread() 如果正在调用的线程是当前 AWT EventQueue 的指派线程，则返回 true。
AWTEvent | peekEvent() 返回 EventQueue 上的第一个事件，而不移除它。
AWTEvent | peekEvent(int id) 返回指定 id（如果有） 的第一个事件。
protected void | pop() 停止使用此 EventQueue 指派事件。
void | postEvent(AWTEvent theEvent) 将一个 1.1 样式的事件发送到 EventQueue 中。
void | push(EventQueue newEventQueue) 用指定的事件队列替换现有的 EventQueue。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventQueue

public EventQueue()
方法详细信息

postEvent

public void postEvent(AWTEvent theEvent)
将一个 1.1 样式的事件发送到 EventQueue 中。如果在队列中存在具有相同 ID 和事件源的事件，则调用源 Component 的 coalesceEvents 方法。

参数：
theEvent - java.awt.AWTEvent 的实例，或者是它的子类
抛出：
NullPointerException - 如果 theEvent 为 null

getNextEvent

public AWTEvent getNextEvent()
                      throws InterruptedException
从 EventQueue 中移除一个事件，并返回该事件。在另一个线程发送事件之前该方法被阻塞。

返回：
下一个 AWTEvent
抛出：
InterruptedException - 如果任何线程中断了此线程

peekEvent

public AWTEvent peekEvent()
返回 EventQueue 上的第一个事件，而不移除它。

返回：
第一个事件

peekEvent

public AWTEvent peekEvent(int id)
返回指定 id（如果有） 的第一个事件。

参数：
id - 所需事件类型的 id
返回：
指定 id 的第一个事件，如果没有这样的事件，则返回 null

dispatchEvent

protected void dispatchEvent(AWTEvent event)
指派一个事件。指派事件的方式取决于事件的类型和事件的源对象的类型：

事件类型 | 源类型 | 指派
ActiveEvent | 所有 | event.dispatch()
其他 | Component | source.dispatchEvent(AWTEvent)
其他 | MenuComponent | source.dispatchEvent(AWTEvent)
其他 | 其他 | 无动作（忽略）

参数：
event - java.awt.AWTEvent 的实例或者是它的子类
抛出：
NullPointerException - 如果 event 为 null
从以下版本开始：
1.2

getMostRecentEventTime

public static long getMostRecentEventTime()
返回最近事件的时间戳（如果有），该事件从 EventQueue（它与正在调用的线程相关）进行指派。如果具有时间戳的事件目前正被指派，则返回它的时间戳。如果没有事件被指派，则返回 EventQueue 的初始化时间。在 JDK 的当前版本中，只有 InputEvent、ActionEvent 和 InvocationEvent 有时间戳；但是，JDK 的未来版本可能将时间戳添加到其他事件类型中。注意，该方法只应该从应用程序事件的指派线程进行调用。如果从另一个线程调用该方法，则返回当前系统的时间（由 System.currentTimeMillis() 报告）。

返回：
最后一次 InputEvent 的时间戳，要指派的 ActionEvent 或 InvocationEvent，如果在不同于事件指派线程的线程上调用该方法，则返回 System.currentTimeMillis()
从以下版本开始：
1.4
另请参见：
InputEvent.getWhen(),
ActionEvent.getWhen(),
InvocationEvent.getWhen()

getCurrentEvent

public static AWTEvent getCurrentEvent()
返回当前正在被 EventQueue（它与正在调用的线程相关）指派的事件。只有某个方法需要访问事件时，但是并没有被设计为可以将事件作为参数来接受，则此方法很有用。注意，该方法应该只从应用程序的事件指派线程进行调用。如果从另一个线程调用该方法，则返回 null。

返回：
当前正被指派的事件；如果调用该方法的线程不是事件指派线程，则返回 null
从以下版本开始：
1.4

push

public void push(EventQueue newEventQueue)
用指定的事件队列替换现有的 EventQueue。任何挂起的事件都被传输到 EventQueue 以备处理。

参数：
newEventQueue - 要使用的 EventQueue（或其子类的）的实例
抛出：
NullPointerException - 如果 newEventQueue 为 null
从以下版本开始：
1.2
另请参见：
pop()

pop

protected void pop()
            throws EmptyStackException
停止使用此 EventQueue 指派事件。任何挂起的事件都被传输到以前的 EventQueue 以备处理。

警告：为了避免死锁，不要在子类中将该方法声明为 synchronized。

抛出：
EmptyStackException - 如果以前没有对该 EventQueue 执行 push 操作
从以下版本开始：
1.2
另请参见：
push(java.awt.EventQueue)

isDispatchThread

public static boolean isDispatchThread()
如果正在调用的线程是当前 AWT EventQueue 的指派线程，则返回 true。使用此调用确保给定的任务正在当前 AWT EventDispatchThread 上执行（或没有执行）。

返回：
如果给定的任务正在当前 AWT EventQueue 的指派线程上运行，则返回 true。
从以下版本开始：
1.2

invokeLater

public static void invokeLater(Runnable runnable)
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。

参数：
runnable - Runnable 对象，其 run 方法应该在 EventQueue 上同步执行
从以下版本开始：
1.2
另请参见：
invokeAndWait(java.lang.Runnable)

invokeAndWait

public static void invokeAndWait(Runnable runnable)
                          throws InterruptedException,
                                 InvocationTargetException
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。在所有挂起事件被处理后才发生。在这发生之前调用被阻塞。如果从事件指派线程进行调用，则该方法将抛出 Error。

参数：
runnable - Runnable 对象，其 run 方法应该在 EventQueue 上同步执行
抛出：
InterruptedException - 如果任何线程中断了该线程
InvocationTargetException - 如果运行 runnable 时抛出一个 throwable
从以下版本开始：
1.2
另请参见：
invokeLater(java.lang.Runnable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDialog (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 FileDialog

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
                继承者  java.awt.Dialog
                    继承者  java.awt.FileDialog
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class FileDialog
extends Dialog

FileDialog 类显示一个对话框窗口，用户可以从中选择文件。

由于它是一个模式对话框，当应用程序调用其 show 方法来显示对话框时，它将阻塞其余应用程序，直到用户选择一个文件。

从以下版本开始：
JDK1.0
另请参见：
Window.show(), 序列化表格

嵌套类摘要
从类 java.awt.Dialog 继承的嵌套类/接口
Dialog.AccessibleAWTDialog, Dialog.ModalExclusionType, Dialog.ModalityType
从类 java.awt.Window 继承的嵌套类/接口
Window.AccessibleAWTWindow
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | LOAD 此常量值指示文件对话框窗口的作用是查找要读取的文件。
static int | SAVE 此常量值指示文件对话框窗口的作用是查找要写入的文件。
从类 java.awt.Dialog 继承的字段
DEFAULT_MODALITY_TYPE
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
FileDialog(Dialog parent)
创建一个文件对话框，用于加载文件。
FileDialog(Dialog parent, String title)
创建一个具有指定标题的文件对话框，用于加载文件。
FileDialog(Dialog parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
FileDialog(Frame parent)
创建一个文件对话框，用于加载文件。
FileDialog(Frame parent, String title)
创建一个具有指定标题的文件对话框窗口，用于加载文件。
FileDialog(Frame parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
方法摘要
void | addNotify() 创建文件对话框的同位体。
String | getDirectory() 获取此文件对话框的目录。
String | getFile() 获取此文件对话框的选定文件。
FilenameFilter | getFilenameFilter() 确定此文件对话框的文件名过滤器。
int | getMode() 指示此文件对话框是用于从文件加载内容还是将内容保存到文件。
protected String | paramString() 返回表示此 FileDialog 窗口状态的字符串。
void | setDirectory(String dir) 将此文件对话框窗口的目录设置为指定目录。
void | setFile(String file) 将此文件对话框窗口的选定文件设置为指定文件。
void | setFilenameFilter(FilenameFilter filter) 将此文件对话框窗口的文件名过滤器设置为指定的过滤器。
void | setMode(int mode) 设置文件对话框的模式。
从类 java.awt.Dialog 继承的方法
getAccessibleContext, getModalityType, getTitle, hide, isModal, isResizable, isUndecorated, setModal, setModalityType, setResizable, setTitle, setUndecorated, setVisible, show, toBack
从类 java.awt.Window 继承的方法
addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getGraphicsConfiguration, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOwnedWindows, getOwner, getOwnerlessWindows, getToolkit, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isShowing, pack, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, toFront
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

LOAD

public static final int LOAD
此常量值指示文件对话框窗口的作用是查找要读取的文件。

另请参见：
常量字段值

SAVE

public static final int SAVE
此常量值指示文件对话框窗口的作用是查找要写入的文件。

另请参见：
常量字段值
构造方法详细信息

FileDialog

public FileDialog(Frame parent)
创建一个文件对话框，用于加载文件。文件对话框的标题最初是空的。这是 FileDialog(parent, "", LOAD) 的一个便捷方法。

参数：
parent - 对话框的所有者
从以下版本开始：
JDK1.1

FileDialog

public FileDialog(Frame parent,
                  String title)
创建一个具有指定标题的文件对话框窗口，用于加载文件。显示的文件是当前目录中的文件。这是 FileDialog(parent, title, LOAD) 的一个便捷方法。

参数：
parent - 对话框的所有者
title - 对话框的标题

FileDialog

public FileDialog(Frame parent,
                  String title,
                  int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

如果 mode 的值为 LOAD，那么文件对话框将查找要读取的文件，所显示的文件是当前目录中的文件。如果 mode 的值为 SAVE，则文件对话框将查找要写入文件的位置。

参数：
parent - 对话框的所有者
title - 对话框的标题
mode - 对话框的模式，可以是 FileDialog.LOAD 或 FileDialog.SAVE
抛出：
IllegalArgumentException - 如果提供了非法的文件对话框模式
另请参见：
LOAD, SAVE

FileDialog

public FileDialog(Dialog parent)
创建一个文件对话框，用于加载文件。文件对话框的标题最初是空的。这是 FileDialog(parent, "", LOAD) 的一个便捷方法。

参数：
parent - 对话框的所有者
抛出：
IllegalArgumentException - 如果 parent 的 GraphicsConfiguration 不是来自屏幕设备；
IllegalArgumentException - 如果 parent 为 null；当 GraphicsEnvironment.isHeadless 返回 true 时始终抛出此异常
从以下版本开始：
1.5
另请参见：
GraphicsEnvironment.isHeadless()

FileDialog

public FileDialog(Dialog parent,
                  String title)
创建一个具有指定标题的文件对话框，用于加载文件。显示的文件是当前目录中的文件。这是 FileDialog(parent, title, LOAD) 的一个便捷方法。

参数：
parent - 对话框的所有者
title - 对话框的标题；接受 null 值时不会抛出 NullPointerException
抛出：
IllegalArgumentException - 如果 parent 的 GraphicsConfiguration 不是来自屏幕设备；
IllegalArgumentException - 如果 parent 为 null；当 GraphicsEnvironment.isHeadless 返回 true 时始终抛出此异常
从以下版本开始：
1.5
另请参见：
GraphicsEnvironment.isHeadless()

FileDialog

public FileDialog(Dialog parent,
                  String title,
                  int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

如果 mode 的值为 LOAD，那么文件对话框将查找要读取的文件，所显示的文件是当前目录中的文件。如果 mode 的值为 SAVE，则文件对话框将查找要写入文件的位置。

参数：
parent - 对话框的所有者
title - 对话框的标题；接受 null 值时不会抛出 NullPointerException
mode - 对话框的模式，FileDialog.LOAD 或 FileDialog.SAVE
抛出：
IllegalArgumentException - 如果提供了非法的文件对话框模式；
IllegalArgumentException - 如果 parent 的 GraphicsConfiguration 不是来自屏幕设备；
IllegalArgumentException - 如果 parent 为 null；当 GraphicsEnvironment.isHeadless 返回 true 时始终抛出此异常
从以下版本开始：
1.5
另请参见：
GraphicsEnvironment.isHeadless(), LOAD, SAVE
方法详细信息

addNotify

public void addNotify()
创建文件对话框的同位体。同位体允许我们更改文件对话框的外观而不更改其功能。

覆盖：
类 Dialog 中的 addNotify
另请参见：
Component.isDisplayable(), Window.removeNotify()

getMode

public int getMode()
指示此文件对话框是用于从文件加载内容还是将内容保存到文件。

返回：
文件对话框窗口的模式，可以是 FileDialog.LOAD 或 FileDialog.SAVE
另请参见：
LOAD, SAVE, setMode(int)

setMode

public void setMode(int mode)
设置文件对话框的模式。如果 mode 不是一个合法值，则抛出一个异常，并且不设置 mode。

参数：
mode - 文件对话框的模式，可以是 FileDialog.LOAD 或 FileDialog.SAVE
抛出：
IllegalArgumentException - 如果提供了非法的文件对话框模式
从以下版本开始：
JDK1.1
另请参见：
LOAD, SAVE, getMode()

getDirectory

public String getDirectory()
获取此文件对话框的目录。

返回：
此 FileDialog 的目录（可能为 null 或无效）
另请参见：
setDirectory(java.lang.String)

setDirectory

public void setDirectory(String dir)
将此文件对话框窗口的目录设置为指定目录。指定 null 或无效目录意味着指定由实现所定义的默认值。但是，在用户选择一个文件之前，此默认值不会被实现。在此之前，getDirectory() 将返回传递到此方法的值。

指定 "" 作为目录，完全等同于指定 null 作为目录。

参数：
dir - 指定的目录
另请参见：
getDirectory()

getFile

public String getFile()
获取此文件对话框的选定文件。如果用户选择 CANCEL，则返回文件为 null。

返回：
此文件对话框窗口当前所选择的文件；如果没有文件被选择，则返回 null
另请参见：
setFile(java.lang.String)

setFile

public void setFile(String file)
将此文件对话框窗口的选定文件设置为指定文件。如果这么设置，那么在文件对话框窗口第一次显示之前，此文件就成为默认文件。

指定 "" 作为文件，完全等同于指定 null 作为文件。

参数：
file - 正被设置的文件 set
另请参见：
getFile()

getFilenameFilter

public FilenameFilter getFilenameFilter()
确定此文件对话框的文件名过滤器。文件名过滤器允许用户指定哪个文件出现在文件对话框窗口。Microsoft Windows 的文件名过滤器在 Sun 的参考实现中不起作用。

返回：
此文件对话框的文件名过滤器
另请参见：
FilenameFilter, setFilenameFilter(java.io.FilenameFilter)

setFilenameFilter

public void setFilenameFilter(FilenameFilter filter)
将此文件对话框窗口的文件名过滤器设置为指定的过滤器。Microsoft Windows 的文件名过滤器在 Sun 的参考实现中不起作用。

参数：
filter - 指定的过滤器
另请参见：
FilenameFilter, getFilenameFilter()

paramString

protected String paramString()
返回表示此 FileDialog 窗口状态的字符串。此方法仅在进行调试的时候使用，对于不同的实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Dialog 中的 paramString
返回：
此文件对话框窗口的参数字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlowLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 FlowLayout

java.lang.Object
    继承者  java.awt.FlowLayout
所有已实现的接口：
LayoutManager, Serializable
public class FlowLayout
extends Object
implements LayoutManager, Serializable

流布局用于安排有向流中的组件，这非常类似于段落中的文本行。流的方向取决于容器的 componentOrientation 属性，它可能是以下两个值中的一个：

  • ComponentOrientation.LEFT_TO_RIGHT
  • ComponentOrientation.RIGHT_TO_LEFT
流布局一般用来安排面板中的按钮。它使得按钮呈水平放置，直到同一条线上再也没有适合的按钮。线的对齐方式由 align 属性确定。可能的值为：
  • LEFT
  • RIGHT
  • CENTER
  • LEADING
  • TRAILING

例如，以下图片显示了使用流布局管理器（它的默认布局管理器）来定位三个按钮的 applet：

以下是此 applet 的代码：

 import java.awt.*;
 import java.applet.Applet;

 public class myButtons extends Applet {
     Button button1, button2, button3;
     public void init() {
         button1 = new Button("Ok");
         button2 = new Button("Open");
         button3 = new Button("Close");
         add(button1);
         add(button2);
         add(button3);
     }
 }

流布局把每个组件都假定为它的自然（首选）大小。

从以下版本开始：
JDK1.0
另请参见：
ComponentOrientation, 序列化表格

字段摘要
static int | CENTER 此值指示每一行组件都应该是居中的。
static int | LEADING 此值指示每一行组件都应该与容器方向的开始边对齐，例如，对于从左到右的方向，则与左边对齐。
static int | LEFT 此值指示每一行组件都应该是左对齐的。
static int | RIGHT 此值指示每一行组件都应该是右对齐的。
static int | TRAILING 此值指示每行组件都应该与容器方向的结束边对齐，例如，对于从左到右的方向，则与右边对齐。
构造方法摘要
FlowLayout()
构造一个新的 FlowLayout，它是居中对齐的，默认的水平和垂直间隙是 5 个单位。
FlowLayout(int align)
构造一个新的 FlowLayout，它具有指定的对齐方式，默认的水平和垂直间隙是 5 个单位。
FlowLayout(int align, int hgap, int vgap)
创建一个新的流布局管理器，它具有指定的对齐方式以及指定的水平和垂直间隙。
方法摘要
void | addLayoutComponent(String name, Component comp) 将指定的组件添加到布局中。
int | getAlignment() 获取此布局的对齐方式。
boolean | getAlignOnBaseline() 如果组件将沿其基线垂直对齐，则返回 true。
int | getHgap() 获取组件之间以及组件与 Container 的边之间的水平间隙。
int | getVgap() 获取组件之间以及组件与 Container 的边之间的垂直间隙。
void | layoutContainer(Container target) 布置该容器。
Dimension | minimumLayoutSize(Container target) 返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。
Dimension | preferredLayoutSize(Container target) 给出指定目标容器中的 visible 组件，返回此布局的首选维数。
void | removeLayoutComponent(Component comp) 从布局中移除指定的组件。
void | setAlignment(int align) 设置此布局的对齐方式。
void | setAlignOnBaseline(boolean alignOnBaseline) 设置组件是否应该沿着其基线垂直对齐。
void | setHgap(int hgap) 设置组件之间以及组件与 Container 的边之间的水平间隙。
void | setVgap(int vgap) 设置组件之间以及组件与 Container 的边之间的垂直间隙。
String | toString() 返回此 FlowLayout 对象及其值的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

LEFT

public static final int LEFT
此值指示每一行组件都应该是左对齐的。

另请参见：
常量字段值

CENTER

public static final int CENTER
此值指示每一行组件都应该是居中的。

另请参见：
常量字段值

RIGHT

public static final int RIGHT
此值指示每一行组件都应该是右对齐的。

另请参见：
常量字段值

LEADING

public static final int LEADING
此值指示每一行组件都应该与容器方向的开始边对齐，例如，对于从左到右的方向，则与左边对齐。

从以下版本开始：
1.2
另请参见：
Component.getComponentOrientation(), ComponentOrientation, 常量字段值

TRAILING

public static final int TRAILING
此值指示每行组件都应该与容器方向的结束边对齐，例如，对于从左到右的方向，则与右边对齐。

从以下版本开始：
1.2
另请参见：
Component.getComponentOrientation(), ComponentOrientation, 常量字段值
构造方法详细信息

FlowLayout

public FlowLayout()
构造一个新的 FlowLayout，它是居中对齐的，默认的水平和垂直间隙是 5 个单位。

FlowLayout

public FlowLayout(int align)
构造一个新的 FlowLayout，它具有指定的对齐方式，默认的水平和垂直间隙是 5 个单位。align 参数的值必须是以下值之一：FlowLayout.LEFT、FlowLayout.RIGHT、FlowLayout.CENTER、FlowLayout.LEADING 或 FlowLayout.TRAILING。

参数：
align - 对齐值

FlowLayout

public FlowLayout(int align,
                  int hgap,
                  int vgap)
创建一个新的流布局管理器，它具有指定的对齐方式以及指定的水平和垂直间隙。

align 参数的值必须是以下值之一：FlowLayout.LEFT、FlowLayout.RIGHT、FlowLayout.CENTER、FlowLayout.LEADING 或 FlowLayout.TRAILING。

参数：
align - 对齐值
hgap - 组件之间以及组件与 Container 的边之间的水平间隙
vgap - 组件之间以及组件与 Container 的边之间的垂直间隙
方法详细信息

getAlignment

public int getAlignment()
获取此布局的对齐方式。可能的值是 FlowLayout.LEFT、FlowLayout.RIGHT、FlowLayout.CENTER、FlowLayout.LEADING 或 FlowLayout.TRAILING。

返回：
此布局的对齐值
从以下版本开始：
JDK1.1
另请参见：
setAlignment(int)

setAlignment

public void setAlignment(int align)
设置此布局的对齐方式。可能的值是
  • FlowLayout.LEFT
  • FlowLayout.RIGHT
  • FlowLayout.CENTER
  • FlowLayout.LEADING
  • FlowLayout.TRAILING

参数：
align - 上面显示的对齐值之一
从以下版本开始：
JDK1.1
另请参见：
getAlignment()

getHgap

public int getHgap()
获取组件之间以及组件与 Container 的边之间的水平间隙。

返回：
组件之间以及组件与 Container 的边之间的水平间隙
从以下版本开始：
JDK1.1
另请参见：
setHgap(int)

setHgap

public void setHgap(int hgap)
设置组件之间以及组件与 Container 的边之间的水平间隙。

参数：
hgap - 组件之间以及组件与 Container 的边之间的水平间隙
从以下版本开始：
JDK1.1
另请参见：
getHgap()

getVgap

public int getVgap()
获取组件之间以及组件与 Container 的边之间的垂直间隙。

返回：
组件之间以及组件与 Container 的边之间的垂直间隙
从以下版本开始：
JDK1.1
另请参见：
setVgap(int)

setVgap

public void setVgap(int vgap)
设置组件之间以及组件与 Container 的边之间的垂直间隙。

参数：
vgap - 组件之间以及组件与 Container 的边之间的垂直间隙
从以下版本开始：
JDK1.1
另请参见：
getVgap()

setAlignOnBaseline

public void setAlignOnBaseline(boolean alignOnBaseline)
设置组件是否应该沿着其基线垂直对齐。没有基线的组件将中心对齐。默认值为 false。

参数：
alignOnBaseline - 组件是否应该沿着其基线垂直对齐
从以下版本开始：
1.6

getAlignOnBaseline

public boolean getAlignOnBaseline()
如果组件将沿其基线垂直对齐，则返回 true。默认值为 false。

返回：
true 如果组件将沿其基线垂直对齐
从以下版本开始：
1.6

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
将指定的组件添加到布局中。不能被此类使用。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 组件的名称
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从布局中移除指定的组件。不能被此类使用。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件
另请参见：
Container.removeAll()

preferredLayoutSize

public Dimension preferredLayoutSize(Container target)
给出指定目标容器中的 visible 组件，返回此布局的首选维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
target - 需要布置的容器
返回：
布置指定容器的子组件的首选维数
另请参见：
Container, minimumLayoutSize(java.awt.Container), Container.getPreferredSize()

minimumLayoutSize

public Dimension minimumLayoutSize(Container target)
返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
target - 需要布置的容器
返回：
布置指定容器的子组件的最小维数
另请参见：
preferredLayoutSize(java.awt.Container), Container, Container.doLayout()

layoutContainer

public void layoutContainer(Container target)
布置该容器。此方法让每个 visible 组件都采用它的首选大小，这通过对目标容器中的组件进行整形得以实现，以满足此 FlowLayout 对象的对齐方式。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
target - 正被布置的指定组件
另请参见：
Container, Container.doLayout()

toString

public String toString()
返回此 FlowLayout 对象及其值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此布局的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FocusTraversalPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 FocusTraversalPolicy

java.lang.Object
    继承者  java.awt.FocusTraversalPolicy
直接已知子类：
ContainerOrderFocusTraversalPolicy, InternalFrameFocusTraversalPolicy
public abstract class FocusTraversalPolicy
extends Object

FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。实例可以将此策略应用于任意焦点循环根，允许它们在整个 Container 共享。当焦点循环根的组件层次结构更改时，不必重新初始化它们。

FocusTraversalPolicy 的核心职责是提供算法，在 UI 中进行向前或向后遍历时确定下一个和上一个要聚焦的 Component。每个 FocusTraversalPolicy 还必须提供算法，确定遍历循环中第一个、最后一个，以及默认的组件。进行正常的正向和反向遍历时，分别使用第一个和最后一个 Component。默认的 Component 是向下遍历到一个新的焦点遍历循环时接收焦点的第一个 Component。FocusTraversalPolicy 可以随意提供确定窗口初始 Component 的算法。初始 Component 是首次将窗口设置为可见时接收焦点的第一个 Component。

FocusTraversalPolicy 会考虑焦点遍历策略提供者。当搜索第一个/最后一个/下一个/上一个 Component 时，如果遇到焦点遍历策略提供者，则使用该焦点遍历策略来执行搜索操作。

有关更多信息，请参阅 The Java Tutorial 中 How to Use the Focus Subsystem 一节和 Focus Specification。

从以下版本开始：
1.4
另请参见：
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
Container.getFocusTraversalPolicy(),
Container.setFocusCycleRoot(boolean),
Container.isFocusCycleRoot(java.awt.Container),
Container.setFocusTraversalPolicyProvider(boolean),
Container.isFocusTraversalPolicyProvider(),
KeyboardFocusManager.setDefaultFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
KeyboardFocusManager.getDefaultFocusTraversalPolicy()

构造方法摘要
FocusTraversalPolicy()
方法摘要
abstract Component | getComponentAfter(Container aContainer, Component aComponent) 返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
abstract Component | getComponentBefore(Container aContainer, Component aComponent) 返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
abstract Component | getDefaultComponent(Container aContainer) 返回要聚焦的默认 Component。
abstract Component | getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
Component | getInitialComponent(Window window) 返回第一次将窗口设置为可见时，应该接收焦点的 Component。
abstract Component | getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FocusTraversalPolicy

public FocusTraversalPolicy()
方法详细信息

getComponentAfter

public abstract Component getComponentAfter(Container aContainer,
                                            Component aComponent)
返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。

参数：
aContainer - aComponent 的焦点循环根，或焦点遍历策略提供者
aComponent - aContainer 的子级（可能是间接的），或 aContainer 自身
返回：
应该接收 aComponent 之后的焦点的 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getComponentBefore

public abstract Component getComponentBefore(Container aContainer,
                                             Component aComponent)
返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。

参数：
aContainer - aComponent 的焦点循环根，或焦点遍历策略提供者
aComponent - aContainer 的子级（可能是间接的），或 aContainer 自身
返回：
应该接收 aComponent 之前的焦点的 Componentor，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getFirstComponent

public abstract Component getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。在进行正向遍历时，可用此方法确定拥有焦点的下一个 Component。

参数：
aContainer - 焦点循环根，或要返回第一个 Component 的焦点遍历策略提供者
返回：
aContainer 的遍历循环中的第一个 Componentor，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getLastComponent

public abstract Component getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。在进行反向遍历时，可用此方法确定拥有焦点的下一个 Component。

参数：
aContainer - 焦点循环根，或要返回最后一个 Component 的焦点遍历策略提供者
返回：
aContainer 的遍历循环中的最后一个 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getDefaultComponent

public abstract Component getDefaultComponent(Container aContainer)
返回要聚焦的默认 Component。在向下遍历到以 aContainer 为根的新焦点遍历循环时，此 Component 将是第一个接受焦点的 Component。

参数：
aContainer - 焦点循环根，或要返回其默认 Component 的焦点遍历策略提供者
返回：
aContainer 的遍历循环中的默认 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getInitialComponent

public Component getInitialComponent(Window window)
返回第一次将窗口设置为可见时，应该接收焦点的 Component。一旦通过调用 show() 或 setVisible(true) 将窗口设置为可见的，将不再使用初始 Component。相反，如果窗口失去焦点、随后又重获焦点，或者设置为不可见或不可显示、随后又设置为可见或可显示，则窗口最近聚焦的 Component 将成为焦点所有者。此方法的默认实现返回默认 Component。

参数：
window - 要返回其初始组件的 Window
返回：
第一次将窗口设置为可见时，应该接收焦点的 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 window 为 null
另请参见：
getDefaultComponent(java.awt.Container), Window.getMostRecentFocusOwner()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Font (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Font

java.lang.Object
    继承者  java.awt.Font
所有已实现的接口：
Serializable
直接已知子类：
FontUIResource
public class Font
extends Object
implements Serializable

Font 类表示字体，可以使用它以可见方式呈现文本。字体提供将字符 序列映射到字形 序列所需要的信息，以便在 Graphics 对象和 Component 对象上呈现字形序列。

字符和字形

字符 是表示项的符号（如字母、数字或具有抽象意义的标点）。例如，'g'（G 的拉丁小写字母）是一个字符。

字形 是用来呈现字符或字符序列的一种形状。在简单的书写系统（如拉丁文）中，通常一个字形就表示一个字符。但在一般情况下，字符和字形并没有一对一的对应关系。例如，字符 'á' A 的带重音符号的拉丁小写字母 可以由两个字形表示：一个是 'a'，一个是 '´'。另一方面，两字符的字符串 "fi" 可以由单个字形 "fi" 连字表示。在复杂的书写系统（如阿拉伯语或南亚和东南亚语言）中，字符与字形之间的关系可能更复杂，涉及到依赖于上下文的字形选择以及字形重排序。字体封装了呈现所选择的字符集所需的字形集，还封装了将字符序列映射到相应的字形序列所需的表。

物理字体和逻辑字体

Java Platform 可以区分两种字体：物理 字体和逻辑 字体。

物理 字体是实际的字体库，包含字形数据和表，这些数据和表使用字体技术（如 TrueType 或 PostScript Type 1）将字符序列映射到字形序列。Java Platform 的所有实现都支持 TrueType 字体；对其他字体技术的支持是与实现相关的。物理字体可以使用字体名称，如 Helvetica、Palatino、HonMincho 或任意数量的其他字体名称。通常，每种物理字体只支持有限的书写系统集合，例如，只支持拉丁文字符，或者只支持日文和基本拉丁文。可用的物理字体集合随配置的不同而有所不同。要求特定字体的应用程序可以使用 createFont 方法来捆绑这些字体，并对其进行实例化。

逻辑 字体是由必须受所有 Java 运行时环境支持的 Java 平台所定义的五种字体系列：Serif、SansSerif、Monospaced、Dialog 和 DialogInput。这些逻辑字体不是实际的字体库。此外，由 Java 运行时环境将逻辑字体名称映射到物理字体。映射关系与实现和通常语言环境相关，因此它们提供的外观和规格各不相同。通常，为了覆盖庞大的字符范围，每种逻辑字体名称都映射到几种物理字体。

同级的 AWT 组件（如 Label 和 TextField）只可以使用逻辑字体。

有关使用物理字体或逻辑字体的相对优势和劣势的讨论，请参阅 Internationalization FAQ 文档。

字体外观和名称

Font 可以有多个外观，如 heavy、medium、oblique、gothic 和 regular。所有这些外观都有相似的排字设计。

可以从 Font 对象获得三种不同的名称。逻辑字体名称 只是用来构造字体的名称。字体外观名称，或外观名称 是特定字体外观的名称，如 Helvetica Bold。系列名称 是字体系列的名称，用来确定多种外观（如 Helvetica）的排字设计。

Font 类表示字体外观集合中字体外观的实例，字体外观集合位于主机系统的系统资源中。例如，Arial Bold 和 Courier Bold Italic 是字体外观。有几个 Font 对象与字体外观相关，每个对象在大小、样式、变换和字体特征上都有所不同。

GraphicsEnvironment 类的 getAllFonts 方法返回系统中所有可用字体外观组成的数组。这些字体外观被作为 Font 对象返回，对象的大小为 1，具有恒等变换和默认字体特征。这些基本字体可以用来派生新的 Font 对象，使之具有变化的大小、样式、变换和字体特征，这些可以通过此类中的 deriveFont 方法实现。

Font 和 TextAttribute

Font 支持大多数 TextAttribute。这使得一些操作（如呈现带下划线的文本）变得更方便，因为没必要再显式构造一个 TextLayout 对象。通过使用 TextAttribute 值的 Map 来构造或派生属性，可以在 Font 上设置属性。

一些 TextAttributes 值是不可序列化的，因此尝试序列化具有这样的值的 Font 实例不会使它们获得序列化。这意味着从这样一个流实现序列化的 Font 不会等同于包含不可序列化属性的原始 Font。这应该是很少出现的一个问题，因为这些属性通常只使用在特殊情况下并且不可能被序列化。

  • FOREGROUND 和 BACKGROUND 使用 Paint 值。子类 Color 是可序列化的，而 GradientPaint 和 TexturePaint 是不可序列化的。
  • CHAR_REPLACEMENT 使用 GraphicAttribute 值。子类 ShapeGraphicAttribute 和 ImageGraphicAttribute 是不可序列化的。
  • INPUT_METHOD_HIGHLIGHT 使用 InputMethodHighlight 值，它是不可序列化的。请参阅 InputMethodHighlight。
创建 Paint 和 GraphicAttribute 的自定义子类的客户机可以使它们可序列化并避免此问题。使用输入方法高亮显示的客户机可以将这些转换为特定于平台的属性，以便在当前平台上高亮显示它们并在 Font 上设置它们，以此作为解决方法。

基于 Map 的构造方法和 deriveFont API 忽略了 FONT 属性，并且没有通过 Font 保留它；如果 FONT 属性可能存在，则应该使用 static getFont(java.util.Map) 方法。有关更多信息，请参阅 TextAttribute.FONT。

一些属性会带来额外的呈现开销，并且可能调用布局。如果某一 Font 具有这样的属性，那么 hasLayoutAttributes 方法将返回 true。

注：字体旋转可能导致文本基线也跟着旋转。为了应对这种（很少见的）可能性，可以指定字体 API 返回字体规格，并使参数“位于相对于基线的坐标中”。这将 'x' 坐标映射到沿基线的某段距离处（正 x 表示沿基线的正方向），将 'y' 坐标映射到位于 'x' 坐标的基线垂直方向的某段距离处（正 y 表示从基线向量顺时针旋转 90 度）。用于实现这些的 API 特别重要，它们被调出，就像具有“相对于基线的坐标”一样。

另请参见：
序列化表格

字段摘要
static int | BOLD 粗体样式常量。
static int | CENTER_BASELINE 布置文本时，在表意文字的脚本（如中文、日文和韩文）中使用的基线。
static String | DIALOG 逻辑字体 "Dialog" 的规范系列名称的 String 常量。
static String | DIALOG_INPUT 逻辑字体 "DialogInput" 的规范系列名称的 String 常量。
static int | HANGING_BASELINE 布置文本时，在 Devanigiri 和类似脚本中使用的基线。
static int | ITALIC 斜体样式常量。
static int | LAYOUT_LEFT_TO_RIGHT layoutGlyphVector 的标志，指示文本是从左到右的，这由 Bidi 分析确定。
static int | LAYOUT_NO_LIMIT_CONTEXT layoutGlyphVector 的标志，指示不应该检查指定 limit 之后的 char 数组中的文本。
static int | LAYOUT_NO_START_CONTEXT layoutGlyphVector 的标志，指示不应该检查指定 start 之前的 char 数组中的文本。
static int | LAYOUT_RIGHT_TO_LEFT layoutGlyphVector 的标志，指示文本是从右到左的，这由 Bidi 分析确定。
static String | MONOSPACED 逻辑字体 "Monospaced" 的规范系列名称的 String 常量。
protected String | name Font 的逻辑名称，它被传递到构造方法中。
static int | PLAIN 普通样式常量。
protected float | pointSize 以 float 形式表示的 Font 的磅值大小。
static int | ROMAN_BASELINE 布置文本时，在大多数 Roman 脚本中使用的基线。
static String | SANS_SERIF 逻辑字体 "SansSerif" 的规范系列名称的 String 常量。
static String | SERIF 逻辑字体 "Serif" 的规范系列名称的 String 常量。
protected int | size Font 的磅值大小，舍入为整数。
protected int | style Font 的样式，它被传递到构造方法中。
static int | TRUETYPE_FONT 标识 TRUETYPE 类型的字体资源。
static int | TYPE1_FONT 标识 TYPE1 类型的字体资源。
构造方法摘要
protected | Font(Font font) 根据指定 font 创建一个新 Font。
 | Font(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 创建一个具有指定属性的新 Font。
 | Font(String name, int style, int size) 根据指定名称、样式和磅值大小，创建一个新 Font。
方法摘要
boolean | canDisplay(char c) 检查此 Font 是否具有指定字符的字形。
boolean | canDisplay(int codePoint) 检查此 Font 是否具有指定字符的字形。
int | canDisplayUpTo(char[] text, int start, int limit) 指示此 Font 是否可以显示指定 text 中从 start 开始至 limit 结束的所有字符。
int | canDisplayUpTo(CharacterIterator iter, int start, int limit) 指示此 Font 是否可以显示由 iter 指定的文本（从 start 开始至 limit 结束）。
int | canDisplayUpTo(String str) 指示此 Font 是否可以显示指定的 String。
static Font | createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
static Font | createFont(int fontFormat, InputStream fontStream) 返回一个使用指定字体类型和输入数据的新 Font。
GlyphVector | createGlyphVector(FontRenderContext frc, char[] chars) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | createGlyphVector(FontRenderContext frc, CharacterIterator ci) 根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | createGlyphVector(FontRenderContext frc, int[] glyphCodes) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | createGlyphVector(FontRenderContext frc, String str) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
static Font | decode(String str) 返回 str 参数所描述的 Font。
Font | deriveFont(AffineTransform trans) 通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。
Font | deriveFont(float size) 通过复制当前 Font 对象并应用新的大小，创建一个新 Font 对象。
Font | deriveFont(int style) 通过复制当前的 Font 对象，并应用新的样式，创建一个新 Font 对象。
Font | deriveFont(int style, AffineTransform trans) 通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。
Font | deriveFont(int style, float size) 通过复制此 Font 对象并应用新样式和大小，创建一个新 Font 对象。
Font | deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
boolean | equals(Object obj) 将此 Font 对象与指定 Object 进行比较。
protected void | finalize() 移除本机 Font 对象。
Map<TextAttribute,?> | getAttributes() 返回此 Font 中可用的字体属性的映射。
AttributedCharacterIterator.Attribute[] | getAvailableAttributes() 返回由此 Font 支持的所有属性的键。
byte | getBaselineFor(char c) 返回适合用来显示此字符的基线。
String | getFamily() 返回此 Font 的系列名称。
String | getFamily(Locale l) 返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。
static Font | getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 返回适合于这些属性的 Font。
static Font | getFont(String nm) 从系统属性列表返回一个 Font 对象。
static Font | getFont(String nm, Font font) 从系统属性列表获取指定的 Font。
String | getFontName() 返回此 Font 的字体外观名称。
String | getFontName(Locale l) 返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。
float | getItalicAngle() 返回此 Font 的斜角。
LineMetrics | getLineMetrics(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | getLineMetrics(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | getLineMetrics(String str, FontRenderContext frc) 返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。
LineMetrics | getLineMetrics(String str, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
Rectangle2D | getMaxCharBounds(FontRenderContext frc) 返回最大边界定义在 FontRenderContext 中的字符的边界。
int | getMissingGlyphCode() 返回此 Font 不具有指定的 unicode 字形时所使用的 glyphCode 代码点。
String | getName() 返回此 Font 的逻辑名称。
int | getNumGlyphs() 返回此 Font 中的字形数量。
java.awt.peer.FontPeer | getPeer() 已过时。 现在，字体呈现与平台无关。
String | getPSName() 返回此 Font 的 postscript 名称。
int | getSize() 返回此 Font 的磅值大小，舍入为整数。
float | getSize2D() 返回此 Font 的磅值大小（以 float 值表示）。
Rectangle2D | getStringBounds(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 指定字符数组的逻辑边界。
Rectangle2D | getStringBounds(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
Rectangle2D | getStringBounds(String str, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
Rectangle2D | getStringBounds(String str, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
int | getStyle() 返回此 Font 的样式。
AffineTransform | getTransform() 返回与此 Font 相关的变换的副本。
int | hashCode() 返回此 Font 的哈希码。
boolean | hasLayoutAttributes() 如果此 Font 包含需要额外布局处理的属性，则返回 true。
boolean | hasUniformLineMetrics() 检查此 Font 是否具有统一的行规格。
boolean | isBold() 指示此 Font 对象的样式是否为 BOLD。
boolean | isItalic() 指示此 Font 对象的样式是否为 ITALIC。
boolean | isPlain() 指示此 Font 对象的样式是否为 PLAIN。
boolean | isTransformed() 指示此 Font 对象是否具有影响其大小以及 Size 属性的变换。
GlyphVector | layoutGlyphVector(FontRenderContext frc, char[] text, int start, int limit, int flags) 返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。
String | toString() 将此 Font 对象转换为 String 表示形式。
从类 java.lang.Object 继承的方法
clone, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

DIALOG

public static final String DIALOG
逻辑字体 "Dialog" 的规范系列名称的 String 常量。它在 Font 构造中很有用，可提供该名称的编译时验证。

从以下版本开始：
1.6
另请参见：
常量字段值

DIALOG_INPUT

public static final String DIALOG_INPUT
逻辑字体 "DialogInput" 的规范系列名称的 String 常量。它在 Font 构造中很有用，可提供该名称的编译时验证。

从以下版本开始：
1.6
另请参见：
常量字段值

SANS_SERIF

public static final String SANS_SERIF
逻辑字体 "SansSerif" 的规范系列名称的 String 常量。它在 Font 构造中很有用，可提供该名称的编译时验证。

从以下版本开始：
1.6
另请参见：
常量字段值

SERIF

public static final String SERIF
逻辑字体 "Serif" 的规范系列名称的 String 常量。它在 Font 构造中很有用，可提供该名称的编译时验证。

从以下版本开始：
1.6
另请参见：
常量字段值

MONOSPACED

public static final String MONOSPACED
逻辑字体 "Monospaced" 的规范系列名称的 String 常量。它在 Font 构造中很有用，可提供该名称的编译时验证。

从以下版本开始：
1.6
另请参见：
常量字段值

PLAIN

public static final int PLAIN
普通样式常量。

另请参见：
常量字段值

BOLD

public static final int BOLD
粗体样式常量。可与其他样式常量（PLAIN 除外）进行组合，从而得到混合样式。

另请参见：
常量字段值

ITALIC

public static final int ITALIC
斜体样式常量。可与其他样式常量（PLAIN 除外）进行组合，从而得到混合样式。

另请参见：
常量字段值

ROMAN_BASELINE

public static final int ROMAN_BASELINE
布置文本时，在大多数 Roman 脚本中使用的基线。

另请参见：
常量字段值

CENTER_BASELINE

public static final int CENTER_BASELINE
布置文本时，在表意文字的脚本（如中文、日文和韩文）中使用的基线。

另请参见：
常量字段值

HANGING_BASELINE

public static final int HANGING_BASELINE
布置文本时，在 Devanigiri 和类似脚本中使用的基线。

另请参见：
常量字段值

TRUETYPE_FONT

public static final int TRUETYPE_FONT
标识 TRUETYPE 类型的字体资源。可用它为 createFont(int, java.io.InputStream) 方法指定一个 TrueType 字体资源。

从以下版本开始：
1.3
另请参见：
常量字段值

TYPE1_FONT

public static final int TYPE1_FONT
标识 TYPE1 类型的字体资源。可用它为 createFont(int, java.io.InputStream) 方法指定一个 Type1 字体资源。

从以下版本开始：
1.5
另请参见：
常量字段值

name

protected String name
Font 的逻辑名称，它被传递到构造方法中。

从以下版本开始：
JDK1.0
另请参见：
getName()

style

protected int style
Font 的样式，它被传递到构造方法中。此样式可以为 PLAIN、BOLD、ITALIC 或 BOLD+ITALIC。

从以下版本开始：
JDK1.0
另请参见：
getStyle()

size

protected int size
Font 的磅值大小，舍入为整数。

从以下版本开始：
JDK1.0
另请参见：
getSize()

pointSize

protected float pointSize
以 float 形式表示的 Font 的磅值大小。

另请参见：
getSize(), getSize2D()

LAYOUT_LEFT_TO_RIGHT

public static final int LAYOUT_LEFT_TO_RIGHT
layoutGlyphVector 的标志，指示文本是从左到右的，这由 Bidi 分析确定。

另请参见：
常量字段值

LAYOUT_RIGHT_TO_LEFT

public static final int LAYOUT_RIGHT_TO_LEFT
layoutGlyphVector 的标志，指示文本是从右到左的，这由 Bidi 分析确定。

另请参见：
常量字段值

LAYOUT_NO_START_CONTEXT

public static final int LAYOUT_NO_START_CONTEXT
layoutGlyphVector 的标志，指示不应该检查指定 start 之前的 char 数组中的文本。

另请参见：
常量字段值

LAYOUT_NO_LIMIT_CONTEXT

public static final int LAYOUT_NO_LIMIT_CONTEXT
layoutGlyphVector 的标志，指示不应该检查指定 limit 之后的 char 数组中的文本。

另请参见：
常量字段值
构造方法详细信息

Font

public Font(String name,
            int style,
            int size)
根据指定名称、样式和磅值大小，创建一个新 Font。

字体名称可以是字体外观名称或字体系列名称。它与样式一起使用，以查找合适的字体外观。如果指定了字体系列名称，则使用样式参数从系列中选择最合适的外观。如果指定了字体外观名称，则合并外观的样式和样式参数，以便从同一个系列查找最匹配的字体。例如，如果指定外观名称 "Arial Bold" 及样式 Font.ITALIC，则字体系统在 "Arial" 系列中寻找既是粗体又是斜体的外观，可以将字体实例与物理字体外观 "Arial Bold Italic" 相关联。将样式参数与指定外观的样式合并，而不是执行添加或减去操作。这意味着，指定粗体外观和粗体样式并不会双倍加粗字体，而指定粗体外观和普通样式也不会变细字体。

如果无法找到所要求样式的外观，则字体系统可以应用样式设计算法来获得所需的样式。例如，如果要求 ITALIC，但是没有可用的斜体外观，则可以通过算法使普通外观倾斜。

字体名称查找是区分大小写的，可以使用 US 语言环境的大小写转换规则。

如果 name 参数表示逻辑字体以外的事物，例如表示为物理字体外观或系列名称，并且无法通过实现物理字体或可兼容的替代物映射它，则字体系统会将 Font 实例映射到 "Dialog"，因此，通过 getFamily 报告的字体系列名称将是 "Dialog"。

参数：
name - 字体名称。可以是字体外观名称或字体系列名称，并且可表示此 GraphicsEnvironment 中找到的逻辑字体或物理字体。逻辑字体的系列名称有：Dialog、DialogInput、Monospaced、Serif 或 SansSerif。预定义 String 常量是为所有这些名称（如 DIALOG）而存在。如果 name 为 null，则将新 Font 的逻辑字体名称（由 getName() 返回）设置为 "Default"。
style - Font 的样式常量。样式参数是整数位掩码，可以为 PLAIN，或 BOLD 和 ITALIC 的按位或（例如，ITALIC 或 BOLD|ITALIC）。如果样式参数不符合任何一个期望的整数位掩码，则将样式设置为 PLAIN。
size - Font 的磅值大小
从以下版本开始：
JDK1.0
另请参见：
GraphicsEnvironment.getAllFonts(), GraphicsEnvironment.getAvailableFontFamilyNames()

Font

public Font(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
创建一个具有指定属性的新 Font。只有 TextAttribute 中定义的键被识别。此外，FONT 属性也没有被此构造方法识别（请参阅 getAvailableAttributes()）。只有具有有效类型值的属性会影响新的 Font。

如果 attributes 为 null，则使用默认值初始化新 Font。

参数：
attributes - 分配给新 Font 的属性，或 null
另请参见：
TextAttribute

Font

protected Font(Font font)
根据指定 font 创建一个新 Font。此构造方法由子类使用。

参数：
font - 用来创建此 Font 的字体。
抛出：
NullPointerException - 如果 font 为 null
从以下版本开始：
1.6
方法详细信息

getPeer

@Deprecated
public java.awt.peer.FontPeer getPeer()
已过时。 现在，字体呈现与平台无关。

获取此 Font 的同位体。

返回：
Font 的同位体。
从以下版本开始：
JDK1.1

getFont

public static Font getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
返回适合于这些属性的 Font。如果 attributes 包含一个使用有效 Font 作为其值的 FONT 属性，那么它将与其余所有属性合并。有关更多信息，请参阅 TextAttribute.FONT。

参数：
attributes - 分配给新 Font 的属性
返回：
使用指定属性创建的新 Font
抛出：
NullPointerException - 如果 attributes 为 null。
从以下版本开始：
1.2
另请参见：
TextAttribute

createFont

public static Font createFont(int fontFormat,
                              InputStream fontStream)
                       throws FontFormatException,
                              IOException
返回一个使用指定字体类型和输入数据的新 Font。创建的新 Font 的磅值大小为 1，样式为 PLAIN。然后，基本字体可以与此类中的 deriveFont 方法一起使用，从而派生出新的 Font 对象，这些对象具有变化的大小、样式、变换和字体特征。此方法不会关闭 InputStream。

为了使 Font 可用于 Font 构造方法，必须通过调用 registerFont(Font) 在 GraphicsEnviroment 中注册返回的 Font。

参数：
fontFormat - Font 的类型，如果指定了 TrueType 资源，则类型为 TRUETYPE_FONT，如果指定了 Type 1 资源，则类型为 TYPE1_FONT。
fontStream - InputStream 对象，表示字体的输入数据。
返回：
使用指定字体类型创建的新 Font。
抛出：
IllegalArgumentException - 如果 fontFormat 不为 TRUETYPE_FONT 或 TYPE1_FONT。
FontFormatException - 如果 fontStream 数据不包含指定格式所需的字体表。
IOException - 如果无法完全读取 fontStream。
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.registerFont(Font)

createFont

public static Font createFont(int fontFormat,
                              File fontFile)
                       throws FontFormatException,
                              IOException
返回一个使用指定字体类型和指定字体文件的新 Font。创建的新 Font 的磅值大小为 1，样式为 PLAIN。基本字体可以与此类中的 deriveFont 方法一起使用，从而派生出新的 Font 对象，这些对象具有变化的大小、样式、变换和字体特征。

参数：
fontFormat - Font 的类型，如果指定了 TrueType 资源，则类型为 TRUETYPE_FONT，如果指定了 Type 1 资源，则类型为 TYPE1_FONT。只要引用了返回的字体，或它派生的字体，实现就可以继续访问 fontFile 以检索字体数据。因此，如果文件被更改，或变成不可访问的，其结果是不确定的。

为了使 Font 可用于 Font 构造方法，必须通过调用 registerFont(Font) 在 GraphicsEnviroment 中注册返回的 Font。

fontFile - File 对象，表示字体的输入数据。
返回：
使用指定字体类型创建的新 Font。
抛出：
IllegalArgumentException - 如果 fontFormat 不为 TRUETYPE_FONTorTYPE1_FONT。
NullPointerException - 如果 fontFile 为 null。
IOException - 如果无法读取 fontFile。
FontFormatException - 如果 fontFile 不包含指定格式所需的字体表。
SecurityException - 如果正在执行的代码没有从文件中读取的权限。
从以下版本开始：
1.5
另请参见：
GraphicsEnvironment.registerFont(Font)

getTransform

public AffineTransform getTransform()
返回与此 Font 相关的变换的副本。此转换对于用于构造字体的方法而言是没必要的。如果字体具有算法上标（algorithmic superscripting）或宽度调整，那么这将合并到返回的 AffineTransform 中。

通常不会转换字体。客户机通常应该先调用 isTransformed()，如果 isTransformed 返回 true，则只调用此方法。

返回：
AffineTransform 对象，表示此 Font 对象的变换属性。

getFamily

public String getFamily()
返回此 Font 的系列名称。

字体的系列名称是特定于字体的。两个字体 Helvetica Italic 和 Helvetica Bold 具有相同的系列名称 Helvetica，但它们的字体外观名称是 Helvetica Bold 和 Helvetica Italic。可用的系列名称列表可以通过使用 GraphicsEnvironment.getAvailableFontFamilyNames() 方法得到。

使用 getName 可以获取字体的逻辑名称。使用 getFontName 可以获取字体的字体外观名称。

返回：
一个 String，此 Font 的系列名称。
从以下版本开始：
JDK1.1
另请参见：
getName(), getFontName()

getFamily

public String getFamily(Locale l)
返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。

字体的系列名称是特定于字体的。两个字体 Helvetica Italic 和 Helvetica Bold 具有相同的系列名称 Helvetica，但它们的字体外观名称是 Helvetica Bold 和 Helvetica Italic。可用的系列名称列表可以通过使用 GraphicsEnvironment.getAvailableFontFamilyNames() 方法得到。

使用 getFontName 可以获取字体的字体外观名称。

参数：
l - 语言环境，要获得该语言环境的系列名称
返回：
一个 String，表示字体的系列名称（已经针对指定语言环境进行了本地化）。
从以下版本开始：
1.2
另请参见：
getFontName(), Locale

getPSName

public String getPSName()
返回此 Font 的 postscript 名称。使用 getFamily 可以获取字体的系列名称。使用 getFontName 可以获取字体的字体外观名称。

返回：
一个 String，表示此 Font 的 postscript 名称。
从以下版本开始：
1.2

getName

public String getName()
返回此 Font 的逻辑名称。使用 getFamily 可以获取字体的系列名称。使用 getFontName 可以获取字体的字体外观名称。

返回：
一个 String，表示此 Font 的逻辑名称。
从以下版本开始：
JDK1.0
另请参见：
getFamily(), getFontName()

getFontName

public String getFontName()
返回此 Font 的字体外观名称。例如，Helvetica Bold 可以作为字体外观名称返回。使用 getFamily 可以获取字体的系列名称。使用 getName 可以获取字体的逻辑名称。

返回：
一个 String，表示此 Font 的字体外观名称。
从以下版本开始：
1.2
另请参见：
getFamily(), getName()

getFontName

public String getFontName(Locale l)
返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。例如，Helvetica Fett 可以作为字体外观名称返回。使用 getFamily 可以获取字体的系列名称。

参数：
l - 语言环境，要获得该语言环境的字体外观名称
返回：
一个 String，表示字体外观名称（已经针对指定语言环境进行了本地化）。
另请参见：
getFamily(), Locale

getStyle

public int getStyle()
返回此 Font 的样式。样式可以为 PLAIN、BOLD、ITALIC 或 BOLD+ITALIC。

返回：
此 Font 的样式
从以下版本开始：
JDK1.0
另请参见：
isPlain(),
isBold(),
isItalic()

getSize

public int getSize()
返回此 Font 的磅值大小，舍入为整数。大多数用户都熟悉使用磅值大小 的概念，它用于指定字体中字形的大小。磅值大小定义了单间距文本文档中某行的基线到下一行的基线之间的测量。磅值大小是基于排字磅值 的，大约为 1/72 英寸。

Java(tm)2D API 规定：1 磅等于用户坐标中的 1 个单位。当使用规范化变换将用户空间坐标转换为设备空间坐标时，72 个用户空间单位等于设备空间中的 1 英寸。在这种情况下，1 磅就是 1/72 英寸。

返回：
Font 的磅值大小（以 1/72 英寸为单位）。
从以下版本开始：
JDK1.0
另请参见：
getSize2D(),
GraphicsConfiguration.getDefaultTransform(),
GraphicsConfiguration.getNormalizingTransform()

getSize2D

public float getSize2D()
返回此 Font 的磅值大小（以 float 值表示）。

返回：
Font 的磅值大小（以 float 值表示）。
从以下版本开始：
1.2
另请参见：
getSize()

isPlain

public boolean isPlain()
指示此 Font 对象的样式是否为 PLAIN。

返回：
如果此 Font 样式为 PLAIN，则返回 true；否则返回 false。
从以下版本开始：
JDK1.0
另请参见：
getStyle()

isBold

public boolean isBold()
指示此 Font 对象的样式是否为 BOLD。

返回：
如果此 Font 对象的样式为 BOLD，则返回 true；否则返回 false。
从以下版本开始：
JDK1.0
另请参见：
getStyle()

isItalic

public boolean isItalic()
指示此 Font 对象的样式是否为 ITALIC。

返回：
如果此 Font 对象的样式为 ITALIC，则返回 true；否则返回 false。
从以下版本开始：
JDK1.0
另请参见：
getStyle()

isTransformed

public boolean isTransformed()
指示此 Font 对象是否具有影响其大小以及 Size 属性的变换。

返回：
如果此 Font 对象具有无标识的 AffineTransform 属性，则返回 true；否则返回 false。
从以下版本开始：
1.4
另请参见：
getTransform()

hasLayoutAttributes

public boolean hasLayoutAttributes()
如果此 Font 包含需要额外布局处理的属性，则返回 true。

返回：
如果该字体已经具有布局属性，则返回 true
从以下版本开始：
1.6

getFont

public static Font getFont(String nm)
从系统属性列表返回一个 Font 对象。nm 被视为要获得的系统属性的名称。然后，根据 Font.decode(String) 规范，将此属性的 String 值解释为一个 Font 对象。如果无法找到指定属性，或者执行代码没有读取该属性的权限，则返回 null。

参数：
nm - 属性名称
返回：
属性名称描述的 Font 对象，如果没有这样的属性存在，则返回 null。
抛出：
NullPointerException - 如果 nm 为 null。
从以下版本开始：
1.2
另请参见：
decode(String)

decode

public static Font decode(String str)
返回 str 参数所描述的 Font。为了确保此方法返回所需的 Font，可以使用以下方式之一格式化 str 参数。

  • fontname-style-pointsize
  • fontname-pointsize
  • fontname-style
  • fontname
  • fontname style pointsize
  • fontname pointsize
  • fontname style
  • fontname
其中，style 是以下四个区分大小写的字符串之一："PLAIN"、"BOLD"、"BOLDITALIC" 和 "ITALIC"，pointsize 是磅值大小的正十进制整数表示形式。例如，如果想要的字体是 Arial、粗体、磅值大小为 18，则按以下方式调用此方法："Arial-BOLD-18"。这等同于调用以下 Font 构造方法：new Font("Arial", Font.BOLD, 18);，值被解释为构造方法所指定的形式。

有效的尾部十进制字段总是被解释为 pointsize。因此，后跟十进制值的 fontname 不应该在只在 fontname 的格式中使用。

如果样式名称字段不是有效的样式字符串，则它被解释为样式名称的一部分，并且使用默认样式。

只有 ' ' 或 '-' 可以用来分隔输入中的字段。所标识的分隔符是最接近字符串末尾的字符，它将有效的 pointsize 或有效的样式名称与字符串的其余部分分隔开来。Null（空）pointsize 和样式字段被视为有效字段，具有该字段的默认值。

有些字体名称可以包括分隔符 ' ' 或 '-'。如果 str 不是由三部分构成，例如，style 或 pointsize 字段不出现在 str 中，并且 fontname 还包含确定为分隔符的字符，则这些打算作为 fontname 一部分出现的字符也可以解释为分隔符，因此字体名称无法正确识别。

默认大小为 12，默认样式为 PLAIN。如果 str 没有指定有效大小，则返回的 Font 大小为 12。如果 str 没有指定有效样式，则返回的 Font 样式为 PLAIN。如果没有在 str 参数中指定有效的字体名称，则此方法将返回系列名称为 "Dialog" 的字体。要确定系统上可以使用哪些字体系列名称，可以使用 GraphicsEnvironment.getAvailableFontFamilyNames() 方法。如果 str 为 null，则返回的新 Font 的系列名称为 "Dialog"，大小为 12，样式为 PLAIN。

参数：
str - 字体名称，或 null
返回：
str 描述的 Font 对象，如果 str 为 null，则返回新的默认 Font。
从以下版本开始：
JDK1.1
另请参见：
getFamily()

getFont

public static Font getFont(String nm,
                           Font font)
从系统属性列表获取指定的 Font。在 System 的 getProperty 方法中，第一个参数被视为要获取的系统属性的名称。接着将此属性的 String 值解释为 Font 对象。

属性值应该是 Font.decode(String) 所接受的形式之一。如果无法找到指定属性，或者执行代码没有读取该属性的权限，则返回 font 参数。

参数：
nm - 不区分大小写的属性名称
font - 如果没有定义属性 nm，则为要返回的默认 Font
返回：
属性的 Font 值。
抛出：
NullPointerException - 如果 nm 为 null。
另请参见：
decode(String)

hashCode

public int hashCode()
返回此 Font 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Font 的哈希码值。
从以下版本开始：
JDK1.0
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此 Font 对象与指定 Object 进行比较。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的 Object
返回：
如果对象相同，或参数是 Font 对象，且描述的字体与此对象相同，则返回 true；否则，返回 false。
从以下版本开始：
JDK1.0
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
将此 Font 对象转换为 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
此 Font 对象的 String 表示形式。
从以下版本开始：
JDK1.0

getNumGlyphs

public int getNumGlyphs()
返回此 Font 中的字形数量。此 Font 的字形代码，范围从 0 到 getNumGlyphs() - 1。

返回：
此 Font 的字形数量。
从以下版本开始：
1.2

getMissingGlyphCode

public int getMissingGlyphCode()
返回此 Font 不具有指定的 unicode 字形时所使用的 glyphCode 代码点。

返回：
此 Font 的 glyphCode。
从以下版本开始：
1.2

getBaselineFor

public byte getBaselineFor(char c)
返回适合用来显示此字符的基线。

大字体可以支持不同的书写系统，并且每个系统都可以使用不同的基线。字符参数确定要使用的书写系统。客户不应该假定所有字符都使用相同的基线。

参数：
c - 用来标识书写系统的字符
返回：
适合于指定字符的基线。
从以下版本开始：
1.2
另请参见：
LineMetrics.getBaselineOffsets(), ROMAN_BASELINE, CENTER_BASELINE, HANGING_BASELINE

getAttributes

public Map<TextAttribute,?> getAttributes()
返回此 Font 中可用的字体属性的映射。属性包括诸如连字和字形替换之类的事情。

返回：
此 Font 的属性映射。

getAvailableAttributes

public AttributedCharacterIterator.Attribute[] getAvailableAttributes()
返回由此 Font 支持的所有属性的键。这些属性可以用来派生其他字体。

返回：
一个数组，包含受此 Font 支持的所有属性的键。
从以下版本开始：
1.2

deriveFont

public Font deriveFont(int style,
                       float size)
通过复制此 Font 对象并应用新样式和大小，创建一个新 Font 对象。

参数：
style - 新 Font 的样式
size - 新 Font 的大小
返回：
新 Font 对象。
从以下版本开始：
1.2

deriveFont

public Font deriveFont(int style,
                       AffineTransform trans)
通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。

参数：
style - 新 Font 的样式
trans - 与新 Font 相关的 AffineTransform
返回：
一个新 Font 对象。
抛出：
IllegalArgumentException - 如果 trans 为 null
从以下版本开始：
1.2

deriveFont

public Font deriveFont(float size)
通过复制当前 Font 对象并应用新的大小，创建一个新 Font 对象。

参数：
size - 新 Font 的大小。
返回：
新 Font 对象。
从以下版本开始：
1.2

deriveFont

public Font deriveFont(AffineTransform trans)
通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。

参数：
trans - 与新 Font 相关的 AffineTransform
返回：
一个新的 Font 对象。
抛出：
IllegalArgumentException - 如果 trans 为 null
从以下版本开始：
1.2

deriveFont

public Font deriveFont(int style)
通过复制当前的 Font 对象，并应用新的样式，创建一个新 Font 对象。

参数：
style - 新 Font 的样式
返回：
新 Font 对象。
从以下版本开始：
1.2

deriveFont

public Font deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。

参数：
attributes - 为新 Font 所启用的属性映射
返回：
新 Font 对象。
从以下版本开始：
1.2

canDisplay

public boolean canDisplay(char c)
检查此 Font 是否具有指定字符的字形。

注：此方法无法处理增补字符。要支持所有 Unicode 字符，包括增补字符，可以使用 canDisplay(int) 方法或 canDisplayUpTo 方法。

参数：
c - 需要字形的字符
返回：
如果此 Font 具有该字符的字形，则返回 true；否则返回 false。
从以下版本开始：
1.2

canDisplay

public boolean canDisplay(int codePoint)
检查此 Font 是否具有指定字符的字形。

参数：
codePoint - 需要字形的字符（Unicode 代码点）。
返回：
如果此 Font 具有该字符的字形，则返回 true；否则返回 false。
抛出：
IllegalArgumentException - 如果代码点不是一个有效的 Unicode 代码点。
从以下版本开始：
1.5
另请参见：
Character.isValidCodePoint(int)

canDisplayUpTo

public int canDisplayUpTo(String str)
指示此 Font 是否可以显示指定的 String。对于使用 Unicode 编码的字符串，知道特定字体是否可以显示该字符串是很重要的。此方法返回 String str 中的一个偏移量，这是此 Font 不使用缺少的字形代码就无法显示的第一个字符。如果 Font 可以显示所有字符，则返回 -1。

参数：
str - 一个 String 对象
返回：
str 中的一个偏移量，指向 str 中此 Font 无法显示的第一个字符；如果此 Font 可以显示 str 中的所有字符，则返回 -1。
从以下版本开始：
1.2

canDisplayUpTo

public int canDisplayUpTo(char[] text,
                          int start,
                          int limit)
指示此 Font 是否可以显示指定 text 中从 start 开始至 limit 结束的所有字符。此方法是一次方便的重载。

参数：
text - 指定 char 值的数组
start - 指定 char 值数组中的指定起始偏移量 (in char)
limit - 指定 char 值数组中的指定结束偏移量 (in char)
返回：
text 中的偏移量，指向此 Font 无法显示的 text 中的第一个字符；如果此 Font 可以显示 text 中的所有字符，则返回 -1。
从以下版本开始：
1.2

canDisplayUpTo

public int canDisplayUpTo(CharacterIterator iter,
                          int start,
                          int limit)
指示此 Font 是否可以显示由 iter 指定的文本（从 start 开始至 limit 结束）。

参数：
iter - CharacterIterator 对象
start - 指定 CharacterIterator 中的指定起始偏移量。
limit - 指定 CharacterIterator 中的指定结束偏移量。
返回：
iter 中的偏移量，它指向 iter 中此 Font 无法显示的第一个字符；如果此 Font 可以显示 iter 中的所有字符，则返回 -1。
从以下版本开始：
1.2

getItalicAngle

public float getItalicAngle()
返回此 Font 的斜角。斜角是与此 Font 的动作最匹配的 caret 的反斜面。

返回：
此 Font 的 ITALIC 样式的角度
另请参见：
TextAttribute.POSTURE

hasUniformLineMetrics

public boolean hasUniformLineMetrics()
检查此 Font 是否具有统一的行规格。逻辑 Font 可以是复合字体，这意味着它由不同的物理字体组成，可以覆盖不同的代码范围。其中每一种字体都可能有不同的 LineMetrics。如果逻辑 Font 是单一字体，则规格将是统一的。

返回：
如果此 Font 具有统一的行规格，则返回 true；否则返回 false。

getLineMetrics

public LineMetrics getLineMetrics(String str,
                                  FontRenderContext frc)
返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。

参数：
str - 指定的 String
frc - 指定的 FontRenderContext
返回：
使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。

getLineMetrics

public LineMetrics getLineMetrics(String str,
                                  int beginIndex,
                                  int limit,
                                  FontRenderContext frc)
返回使用指定参数创建的 LineMetrics 对象。

参数：
str - 指定的 String
beginIndex - str 的初始偏移量
limit - str 的结束偏移量
frc - 指定的 FontRenderContext
返回：
使用指定参数创建的 LineMetrics 对象。

getLineMetrics

public LineMetrics getLineMetrics(char[] chars,
                                  int beginIndex,
                                  int limit,
                                  FontRenderContext frc)
返回使用指定参数创建的 LineMetrics 对象。

参数：
chars - 字符数组
beginIndex - chars 的初始偏移量
limit - chars 的结束偏移量
frc - 指定的 FontRenderContext
返回：
使用指定参数创建的 LineMetrics 对象。

getLineMetrics

public LineMetrics getLineMetrics(CharacterIterator ci,
                                  int beginIndex,
                                  int limit,
                                  FontRenderContext frc)
返回使用指定参数创建的 LineMetrics 对象。

参数：
ci - 指定的 CharacterIterator
beginIndex - ci 中的初始偏移量
limit - ci 的结束偏移量
frc - 指定的 FontRenderContext
返回：
使用指定参数创建的 LineMetrics 对象。

getStringBounds

public Rectangle2D getStringBounds(String str,
                                   FontRenderContext frc)
返回指定 FontRenderContext 中指定 String 的逻辑边界。逻辑边界包含 origin、ascent、advance 和 height，其中包括了 leading。逻辑边界并不总是包围所有文本。例如，在某些语言和字体中，accent 标记可以位于 ascent 之上，或 descent 之下。要得到可视的边界框（它包围了所有文本），可以使用 TextLayout 的 getBounds 方法。

注：返回的边界在相对于基线的坐标中（请参阅 class notes）。

参数：
str - 指定的 String
frc - 指定的 FontRenderContext
返回：
一个 Rectangle2D，它是指定 FontRenderContext 中指定 String 的边界框。
从以下版本开始：
1.2
另请参见：
FontRenderContext, createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

getStringBounds

public Rectangle2D getStringBounds(String str,
                                   int beginIndex,
                                   int limit,
                                   FontRenderContext frc)
返回指定 FontRenderContext 中指定 String 的逻辑边界。逻辑边界包含 origin、ascent、advance 和 height，其中包括了 leading。逻辑边界并不总是包围所有文本。例如，在某些语言和字体中，accent 标记可以位于 ascent 之上，或 descent 之下。要得到可视的边界框（它包围了所有文本），可以使用 TextLayout 的 getBounds 方法。

注：返回的边界在相对于基线的坐标中（请参阅 class notes）。

参数：
str - 指定的 String
beginIndex - str 的初始偏移量
limit - str 的结束偏移量
frc - 指定的 FontRenderContext
返回：
一个 Rectangle2D，它是指定 FontRenderContext 中指定 String 的边界框。
抛出：
IndexOutOfBoundsException - 如果 beginIndex 小于零，或 limit 大于 str 的长度，或 beginIndex 大于 limit。
从以下版本开始：
1.2
另请参见：
FontRenderContext, createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

getStringBounds

public Rectangle2D getStringBounds(char[] chars,
                                   int beginIndex,
                                   int limit,
                                   FontRenderContext frc)
返回指定 FontRenderContext 指定字符数组的逻辑边界。逻辑边界包含 origin、ascent、advance 和 height，其中包括了 leading。逻辑边界并不总是包围所有文本。例如，在某些语言和字体中，accent 标记可以位于 ascent 之上，或 descent 之下。要得到可视的边界框（它包围了所有文本），可以使用 TextLayout 的 getBounds 方法。

注：返回的边界在相对于基线的坐标中（请参阅 class notes）。

参数：
chars - 字符数组
beginIndex - 字符数组的初始偏移量
limit - 字符数组的结束偏移量
frc - 指定的 FontRenderContext
返回：
一个 Rectangle2D，它是指定 FontRenderContext 中指定字符数组的边界框。
抛出：
IndexOutOfBoundsException - 如果 beginIndex 小于零，或 limit 大于 chars 的长度，或 beginIndex 大于 limit。
从以下版本开始：
1.2
另请参见：
FontRenderContext, createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

getStringBounds

public Rectangle2D getStringBounds(CharacterIterator ci,
                                   int beginIndex,
                                   int limit,
                                   FontRenderContext frc)
返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。逻辑边界包含 origin、ascent、advance 和 height，其中包括了 leading。逻辑边界并不总是包围所有文本。例如，在某些语言和字体中，accent 标记可以位于 ascent 之上，或 descent 之下。要得到可视的边界框（它包围了所有文本），可以使用 TextLayout 的 getBounds 方法。

注：返回的边界在相对于基线的坐标中（请参阅 class notes）。

参数：
ci - 指定的 CharacterIterator
beginIndex - ci 中的初始偏移量
limit - ci 中的结束偏移量
frc - 指定的 FontRenderContext
返回：
一个 Rectangle2D，它是指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的边界框。
抛出：
IndexOutOfBoundsException - 如果 beginIndex 小于 ci 的起始索引，或 limit 大于 ci 的结束索引，或 beginIndex 大于 limit
从以下版本开始：
1.2
另请参见：
FontRenderContext, createGlyphVector(java.awt.font.FontRenderContext, java.lang.String)

getMaxCharBounds

public Rectangle2D getMaxCharBounds(FontRenderContext frc)
返回最大边界定义在 FontRenderContext 中的字符的边界。

注：返回的边界在相对于基线的坐标中（请参阅 class notes）。

参数：
frc - 指定的 FontRenderContext
返回：
一个 Rectangle2D，它是具有最大边界的字符的边界框。

createGlyphVector

public GlyphVector createGlyphVector(FontRenderContext frc,
                                     String str)
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。除了字形到字符的映射之外，此方法不做任何其他处理。这意味着，此方法对于某些脚本是无用的，如 Arabic、Hebrew、Thai 和 Indic，它们要求进行重排序、整形或连字替换。

参数：
frc - 指定的 FontRenderContext
str - 指定的 String
返回：
使用指定 String 和指定 FontRenderContext 创建的新 GlyphVector。

createGlyphVector

public GlyphVector createGlyphVector(FontRenderContext frc,
                                     char[] chars)
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。除了字形到字符的映射之外，此方法不做任何其他处理。这意味着，此方法对于某些脚本是无用的，如 Arabic、Hebrew、Thai 和 Indic，它们要求进行重排序、整形或连字替换。

参数：
frc - 指定的 FontRenderContext
chars - 指定的字符数组
返回：
使用指定字符数组和指定 FontRenderContext 创建的 GlyphVector。

createGlyphVector

public GlyphVector createGlyphVector(FontRenderContext frc,
                                     CharacterIterator ci)
根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。除了字形到字符的映射之外，此方法不做任何其他处理。这意味着，此方法对于某些脚本是无用的，如 Arabic、Hebrew、Thai 和 Indic，它们要求进行重排序、整形或连字替换。

参数：
frc - 指定的 FontRenderContext
ci - 指定的 CharacterIterator
返回：
使用指定 CharacterIterator 和指定 FontRenderContext 创建的 GlyphVector。

createGlyphVector

public GlyphVector createGlyphVector(FontRenderContext frc,
                                     int[] glyphCodes)
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。除了字形到字符的映射之外，此方法不做任何其他处理。这意味着，此方法对于某些脚本是无用的，如 Arabic、Hebrew、Thai 和 Indic，它们要求进行重排序、整形或连字替换。

参数：
frc - 指定的 FontRenderContext
glyphCodes - 指定的整数数组
返回：
使用指定整数数组和指定 FontRenderContext 创建的 GlyphVector。

layoutGlyphVector

public GlyphVector layoutGlyphVector(FontRenderContext frc,
                                     char[] text,
                                     int start,
                                     int limit,
                                     int flags)
返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。复杂文本要求有完整布局，如 Arabic 或 Hindi。对不同脚本的支持取决于字体和实现。

Layout requires bidi analysis, as performed by Bidi 只应该在具有统一方向的文本上执行。用 flags 参数来指示方向，通过使用 LAYOUT_RIGHT_TO_LEFT 来指示从右到左（Arabic 和 Hebrew）的运行方向，或通过使用 LAYOUT_LEFT_TO_RIGHT 来指示从左到右 (English) 的运行方向。

此外，有些操作（比如 Arabic 整形）需要上下文，这样在开始和结束处的字符才会有合适的形状。有时，在所提供范围之外的缓冲区中的数据并不是有效数据。可以将值 LAYOUT_NO_START_CONTEXT 和 LAYOUT_NO_LIMIT_CONTEXT 添加到 flags 参数中，分别指示在 start 之前或 limit 之后的文本不应该作为上下文进行检查。

flags 参数的所有其他值均被保留。

参数：
frc - 指定的 FontRenderContext
text - 要布局的文本
start - GlyphVector 所要使用的文本的起始处
limit - GlyphVector 所要使用的文本的结束处
flags - 如上所述的控制标志
返回：
一个新 GlyphVector，表示 start 和 limit 之间的文本，具有经过选择和定位的字形，以便以最佳方式表示文本
抛出：
ArrayIndexOutOfBoundsException - 如果 start 或 limit 超出了边界
从以下版本开始：
1.4
另请参见：
Bidi, LAYOUT_LEFT_TO_RIGHT, LAYOUT_RIGHT_TO_LEFT, LAYOUT_NO_START_CONTEXT, LAYOUT_NO_LIMIT_CONTEXT

finalize

protected void finalize()
                 throws Throwable
移除本机 Font 对象。

覆盖：
类 Object 中的 finalize
抛出：
Throwable - 此方法抛出的 Exception
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FontFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 FontFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.FontFormatException
所有已实现的接口：
Serializable
public class FontFormatException
extends Exception

此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。

从以下版本开始：
1.3
另请参见：
Font, 序列化表格

构造方法摘要
FontFormatException(String reason)
报告一个指定了原因的 FontFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FontFormatException

public FontFormatException(String reason)
报告一个指定了原因的 FontFormatException。

参数：
reason - String 消息，指示为什么该字体未被接受。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FontMetrics (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 FontMetrics

java.lang.Object
    继承者  java.awt.FontMetrics
所有已实现的接口：
Serializable
public abstract class FontMetrics
extends Object
implements Serializable

FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。

子类注意事项：由于当中很多方法都形成关闭的、相互递归的循环，所以必须注意，在每个这样的循环中至少要实现其中一个方法，以防止在使用子类时产生无穷递归。特别建议，至少要重写以下方法集合以确保正确性，并防止无穷递归（虽然其他子集也可以）。

  • getAscent()
  • getLeading()
  • getMaxAdvance()
  • charWidth(char)
  • charsWidth(char[], int, int)

字母 'p' 显示其“引用点” 注意，这些方法的实现效率低下，因此通常利用更高效的特定于工具包的实现重写它们。

当应用程序要求将字符放置在 (x, y) 位置时，放置字符的方式是使其引用点（附图中显示的点）放置在该位置。引用点指定一条水平线，称为字符的基线 (baseline)。在正常的打印中，字符的基线应该对齐。

此外，字体中的每个字符都具有 ascent、descent 和 advance width 属性。ascent 是字符超出基线之上的距离。descent 是字符超出基线以下的距离。advance width 指示 AWT 应该放置下一个字符的位置。

字符数组或字符串也可以具有 ascent、descent 和 advance width 属性。数组的 ascent 是数组中所有字符的最大 ascent。descent 是数组中所有字符的最大 descent。advance width 是字符数组中每个字符的 advance width 之和。String 的 advance 是 String 沿基线的距离。此距离是 String 居中或右对齐应该使用的 width。

注意，String 的 advance 不一定是每个字符单独测量的 advance 之和，因为字符的 width 可随上下文变动。例如，在 Arabic 文本中，可以更改一个字符的形状，以连接到其他字符。而在有些脚本中，某些字符序列可以由单个形状（称为连字）表示。单独测量的字符并不能说明这些转换。

字体规格是基线相关的，意味着它们通常是独立应用于该字体的循环（模可能的网格提示作用）。请参阅 Font。

从以下版本开始：
JDK1.0
另请参见：
Font, 序列化表格

字段摘要
protected  Font font
实际的 Font，字体规格是由此创建的。
构造方法摘要
protected FontMetrics(Font font)
创建一个新 FontMetrics 对象，用于查找该 Font 中关于指定 Font 和特定字符字形的 height 和 width 信息。
方法摘要
 int bytesWidth(byte[] data, int off, int len)
返回显示此 Font 中指定字节数组的总 advance width。
 int charsWidth(char[] data, int off, int len)
返回显示此 Font 中指定字符数组的总 advance width。
 int charWidth(char ch)
返回此 Font 中指定字符的 advance width。
 int charWidth(int codePoint)
返回此 Font 中指定字符的 advance width。
 int getAscent()
确定此 FontMetrics 对象所描述的 Font 的 font ascent。
 int getDescent()
确定此 FontMetrics 对象所描述的 Font 的 font descent。
 Font getFont()
获取此 FontMetrics 对象所描述的 Font。
 FontRenderContext getFontRenderContext()
获取此 FontMetrics 对象用来测量文本的 FontRenderContext。
 int getHeight()
获取此 Font 中文本行的标准 height。
 int getLeading()
确定此 FontMetrics 对象所描述的 Font 的标准行间距。
 LineMetrics getLineMetrics(char[] chars, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。
 LineMetrics getLineMetrics(CharacterIterator ci, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
 LineMetrics getLineMetrics(String str, Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
 LineMetrics getLineMetrics(String str, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
 int getMaxAdvance()
获取此 Font 中所有字符的最大 advance width。
 int getMaxAscent()
确定此 FontMetrics 对象所描述的 Font 的最大 ascent。
 Rectangle2D getMaxCharBounds(Graphics context)
返回指定 Graphics 上下文中具有最大边界的字符的边界。
 int getMaxDecent()
已过时。 从 JDK version 1.1.1 开始，由 getMaxDescent() 取代。
 int getMaxDescent()
确定此 FontMetrics 对象所描述的 Font 的最大 descent。
 Rectangle2D getStringBounds(char[] chars, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定字符数组的边界。
 Rectangle2D getStringBounds(CharacterIterator ci, int beginIndex, int limit, Graphics context)
返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。
 Rectangle2D getStringBounds(String str, Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。
 Rectangle2D getStringBounds(String str, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。
 int[] getWidths()
获取此 Font 中前 256 个字符的 advance width。
 boolean hasUniformLineMetrics()
检查 Font 是否具有统一的行规格。
 int stringWidth(String str)
返回此 Font 中指定 String 的总 advance width。
 String toString()
返回此 FontMetrics 对象的值的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

font

protected Font font
实际的 Font，字体规格是由此创建的。它不能为 null。

另请参见：
getFont()
构造方法详细信息

FontMetrics

protected FontMetrics(Font font)
创建一个新 FontMetrics 对象，用于查找该 Font 中关于指定 Font 和特定字符字形的 height 和 width 信息。

参数：
font - Font
另请参见：
Font
方法详细信息

getFont

public Font getFont()
获取此 FontMetrics 对象所描述的 Font。

返回：
此 FontMetrics 对象所描述的 Font。

getFontRenderContext

public FontRenderContext getFontRenderContext()
获取此 FontMetrics 对象用来测量文本的 FontRenderContext。

注意，此类中带有 Graphics 参数的方法测量使用该 Graphics 对象的 FontRenderContext 文本，而非此 FontRenderContext。

返回：
此 FontMetrics 对象使用的 FontRenderContext。
从以下版本开始：
1.6

getLeading

public int getLeading()
确定此 FontMetrics 对象所描述的 Font 的标准行间距。标准行间距（或行间间隔）是保留在一个文本行的 descent 和下一个文本行的 ascent 之间的逻辑间隔量。计算 height 规格时要包括这一额外间隔。

返回：
Font 的标准行间距。
另请参见：
getHeight(),
getAscent(),
getDescent()

getAscent

public int getAscent()
确定此 FontMetrics 对象所描述的 Font 的 font ascent。font ascent 是字体基线到大多数字母数字字符顶部的距离。在 Font 中，有些字符可能扩展超过 font ascent 线。

返回：
Font 的 font ascent。
另请参见：
getMaxAscent()

getDescent

public int getDescent()
确定此 FontMetrics 对象所描述的 Font 的 font descent。font descent 是字体基线到大多数字母数字字符底部的距离。在 Font 中，有些字符可能扩展到 font descent 线之下。

返回：
Font 的 font descent。
另请参见：
getMaxDescent()

getHeight

public int getHeight()
获取此 Font 中文本行的标准 height。它是相邻文本行基线之间的距离。它是 leading、ascent、descent 的总和。由于采用了舍入方法，它可能不同于 getAscent()、getDescent()、getLeading() 的总和。不保证以此距离间隔的文本行是不相交的；如果有些字符超出了标准 ascent 或标准 descent，则这些文本行可能会重叠。

返回：
Font 的标准 height。
另请参见：
getLeading(),
getAscent(),
getDescent()

getMaxAscent

public int getMaxAscent()
确定此 FontMetrics 对象所描述的 Font 的最大 ascent。字符超出字体基线的距离不会大于此 height。

返回：
Font 中所有字符的最大 ascent。
另请参见：
getAscent()

getMaxDescent

public int getMaxDescent()
确定此 FontMetrics 对象所描述的 Font 的最大 descent。字符低于字体基线的距离不会大于此 height。

返回：
Font 中所有字符的最大 descent。
另请参见：
getDescent()

getMaxDecent

@Deprecated
public int getMaxDecent()
已过时。 从 JDK version 1.1.1 开始，由 getMaxDescent() 取代。

只用于向后兼容性。

返回：
Font 中所有字符的最大 descent。
另请参见：
getMaxDescent()

getMaxAdvance

public int getMaxAdvance()
获取此 Font 中所有字符的最大 advance width。advance 是字符串基线上最左边的点到最右边的点之间的距离。String 的 advance 不一定是它所有字符的 advance 之和。

返回：
Font 中所有字符的最大 advance width；如果最大 advance width 未知，则返回 -1。

charWidth

public int charWidth(int codePoint)
返回此 Font 中指定字符的 advance width。advance 是字符基线上最左边的点到最右边的点之间的距离。注意，String 的 advance 不一定是它所有字符的 advance 之和。

此方法没有验证指定的字符是否为一个有效的 Unicode 代码点。如有必要，调用者必须使用 Character.isValidCodePoint 验证字符值。

参数：
codePoint - 要测量的字符（Unicode 代码点）
返回：
此 FontMetrics 对象所描述的 Font 中指定字符的 advance width。
另请参见：
charsWidth(char[], int, int), stringWidth(String)

charWidth

public int charWidth(char ch)
返回此 Font 中指定字符的 advance width。advance 是字符基线上最左边的点到最右边的点之间的距离。注意，String 的 advance 不一定是它所有字符的 advance 之和。

注： 此方法无法处理增补字符。要支持包括增补字符在内的所有 Unicode 字符，请使用 charWidth(int) 方法。

参数：
ch - 要测量的字符
返回：
此 FontMetrics 对象所描述的 Font 中指定字符的 advance width。
另请参见：
charsWidth(char[], int, int), stringWidth(String)

stringWidth

public int stringWidth(String str)
返回此 Font 中指定 String 的总 advance width。advance 是字符串基线上最左边的点到最右边的点之间的距离。

注意，code>String 的 advance 不一定是它所有字符的 advance 之和。

参数：
str - 要测量的 String
返回：
此 FontMetrics 描述的 Font 中指定 String 的 advance width。
抛出：
NullPointerException - 如果 str 为 null。
另请参见：
bytesWidth(byte[], int, int),
charsWidth(char[], int, int),
getStringBounds(String, Graphics)

charsWidth

public int charsWidth(char[] data,
                      int off,
                      int len)
返回显示此 Font 中指定字符数组的总 advance width。advance 是字符串基线上最左边的点到最右边的点之间的距离。String 的 advance 不一定是它所有字符的 advance 之和。这等同于测量 String 指定范围内的字符。

参数：
data - 要测量的字符数组
off - 数组中字符的起始偏移量
len - 数组中要测量的字符数
返回：
此 FontMetrics 对象所描述的字体中指定 char 数组子数组的 advance width。
抛出：
NullPointerException - 如果 data 为 null。
IndexOutOfBoundsException - 如果 off 和 len 参数索引字符超出 data 数组范围。
另请参见：
charWidth(int), charWidth(char), bytesWidth(byte[], int, int), stringWidth(String)

bytesWidth

public int bytesWidth(byte[] data,
                      int off,
                      int len)
返回显示此 Font 中指定字节数组的总 advance width。advance 是字符串基线上最左边的点到最右边的点之间的距离。String 的 advance 不一定是它所有字符的 advance 之和。这等同于测量 String 指定范围内的字符。

参数：
data - 要测量的字节数组
off - 数组中字节的起始偏移量
len - 数组中要测量的字节数
返回：
此 FontMetrics 对象所描述的 Font 中指定 byte 数组的子数组的 advance width。
抛出：
NullPointerException - 如果 data 为 null。
IndexOutOfBoundsException - 如果 off 和 len 参数索引字节超出 data 数组范围。
另请参见：
charsWidth(char[], int, int), stringWidth(String)

getWidths

public int[] getWidths()
获取此 Font 中前 256 个字符的 advance width。advance 是字符基线上最左边的点到最右边的点之间的距离。注意，String 的 advance 不一定是它所有字符的 advance 之和。

返回：
一个数组，它存储此 FontMetrics 对象所描述的 Font 中字符的 advance width。

hasUniformLineMetrics

public boolean hasUniformLineMetrics()
检查 Font 是否具有统一的行规格。复合字体可能由几种不同的字体组成，涉及到各种字符集。在此情况下，FontLineMetrics 对象是不统一的。不同的字体可能有不同的 ascent、descent、metrics 等等。对于行测量和行断开来说，此信息有时是必需的。

返回：
如果字体具有统一的行规格，则返回 true；否则返回 false。
另请参见：
Font.hasUniformLineMetrics()

getLineMetrics

public LineMetrics getLineMetrics(String str,
                                  Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

参数：
str - 指定的 String
context - 指定的 Graphics 上下文
返回：
使用指定 String 和 Graphics 上下文创建的 LineMetrics 对象。
另请参见：
Font.getLineMetrics(String, FontRenderContext)

getLineMetrics

public LineMetrics getLineMetrics(String str,
                                  int beginIndex,
                                  int limit,
                                  Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

参数：
str - 指定的 String
beginIndex - str 的初始偏移量
limit - str 的结束偏移量
context - 指定的 Graphics 上下文
返回：
使用指定 String 和 Graphics 上下文创建的 LineMetrics 对象。
另请参见：
Font.getLineMetrics(String, int, int, FontRenderContext)

getLineMetrics

public LineMetrics getLineMetrics(char[] chars,
                                  int beginIndex,
                                  int limit,
                                  Graphics context)
返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。

参数：
chars - 指定的字符数组
beginIndex - chars 的初始偏移量
limit - chars 的结束偏移量
context - 指定的 Graphics 上下文
返回：
使用指定字符数组和 Graphics 上下文创建的 LineMetrics 对象。
另请参见：
Font.getLineMetrics(char[], int, int, FontRenderContext)

getLineMetrics

public LineMetrics getLineMetrics(CharacterIterator ci,
                                  int beginIndex,
                                  int limit,
                                  Graphics context)
返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。

参数：
ci - 指定的 CharacterIterator
beginIndex - ci 中的初始偏移量
limit - ci 的结束索引
context - 指定的 Graphics 上下文
返回：
使用指定参数创建的 LineMetrics 对象。
另请参见：
Font.getLineMetrics(CharacterIterator, int, int, FontRenderContext)

getStringBounds

public Rectangle2D getStringBounds(String str,
                                   Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。边界用来对 String 进行布局。

注意：返回的边界在基线相关的坐标内 （请参阅类注释）。

参数：
str - 指定的 String
context - 指定的 Graphics 上下文
返回：
一个 Rectangle2D，它是指定 Graphics 上下文中指定 String 的边界框。
另请参见：
Font.getStringBounds(String, FontRenderContext)

getStringBounds

public Rectangle2D getStringBounds(String str,
                                   int beginIndex,
                                   int limit,
                                   Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。边界用来对 String 进行布局。

注意：返回的边界在基线相关的坐标内 （请参阅类注释）。

参数：
str - 指定的 String
beginIndex - str 的起始偏移量
limit - str 的结束偏移量
context - 指定的 Graphics 上下文
返回：
一个 Rectangle2D，它是指定 String 上下文中指定 Graphics 的边界框。
另请参见：
Font.getStringBounds(String, int, int, FontRenderContext)

getStringBounds

public Rectangle2D getStringBounds(char[] chars,
                                   int beginIndex,
                                   int limit,
                                   Graphics context)
返回指定 Graphics 上下文中指定字符数组的边界。边界用来对 String 进行布局，String 是使用指定的字符数组、beginIndex 和 limit 创建的。

注意：返回的边界在基线相关的坐标内 （请参阅类注释）。

参数：
chars - 字符数组
beginIndex - 字符数组的初始偏移量
limit - 字符数组的结束偏移量
context - 指定的 Graphics 上下文
返回：
一个 Rectangle2D，它是指定 Graphics 上下文中指定字符数组的边界框。
另请参见：
Font.getStringBounds(char[], int, int, FontRenderContext)

getStringBounds

public Rectangle2D getStringBounds(CharacterIterator ci,
                                   int beginIndex,
                                   int limit,
                                   Graphics context)
返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。

注意：返回的边界在基线相关的坐标内（请参阅类注释）。

参数：
ci - 指定的 CharacterIterator
beginIndex - ci 中的初始偏移量
limit - ci 的结束索引
context - 指定的 Graphics 上下文
返回：
一个 Rectangle2D，它是用指定 Graphics 上下文中的指定 CharacterIterator 进行索引的字符的边界框。
另请参见：
Font.getStringBounds(CharacterIterator, int, int, FontRenderContext)

getMaxCharBounds

public Rectangle2D getMaxCharBounds(Graphics context)
返回指定 Graphics 上下文中具有最大边界的字符的边界。

参数：
context - 指定的 Graphics 上下文
返回：
一个 Rectangle2D，它是具有最大边界的字符的边界框。
另请参见：
Font.getMaxCharBounds(FontRenderContext)

toString

public String toString()
返回此 FontMetrics 对象的值的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
此 FontMetrics 对象的 String 表示形式。
从以下版本开始：
JDK1.0.
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Frame (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Frame

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
                继承者  java.awt.Frame
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
JFrame
public class Frame
extends Window
implements MenuContainer

Frame 是带有标题和边框的顶层窗口。

窗体的大小包括为边框指定的所有区域。边框区域的尺寸可以使用 getInsets 方法获得，但是，由于这些尺寸与平台相关，因此在通过调用 pack 或 show 将窗体设置为可显示之前，将无法获得有效的 insets 值。由于窗体的总大小包括了边框区，因此边框实际上遮掩了窗体的部分区域，并将可用于在矩形中呈现和/或显示子部件的区域限制在一个矩形内，该矩形左上角的位置为 (insets.left, insets.top)，宽度为 width - (insets.left + insets.right)，长度为 height - (insets.top + insets.bottom)。

窗体的默认布局为 BorderLayout。

使用 setUndecorated，窗体可以关闭本机装饰（即 Frame 和 Titlebar）。但只有在窗体不是 displayable 时才能这样做。

在多屏幕环境中，通过使用 Frame(GraphicsConfiguration) 或 Frame(String title, GraphicsConfiguration) 构造 Frame，可以在不同的屏幕设备上创建 Frame。GraphicsConfiguration 对象是目标屏幕设备的 GraphicsConfiguration 对象之一。

在虚拟设备多屏幕环境中（其中桌面区域可以跨越多物理屏幕设备），所有配置的边界都是相对于虚拟坐标系的。虚拟坐标系的原点位于主物理屏幕的左上角。是否使用负坐标取决于主物理屏幕在虚拟设备中的位置，如下图所示。

包括三个物理屏幕和一个主物理屏幕的虚拟设备。主物理屏幕 显示坐标为 (0,0)，而另一个物理屏幕显示坐标为 (-80,-100)。

在此环境中调用 setLocation 时，必须传递一个虚拟坐标到此方法中。类似地，对 Frame 调用 getLocationOnScreen 将返回虚拟设备坐标。调用 GraphicsConfiguration 的 getBounds 方法可查找它在虚拟坐标系中的原点。

以下代码将 Frame 的位置设置为 (10, 10)（相对于相应 GraphicsConfiguration 的物理屏幕的原点）。如果不考虑 GraphicsConfiguration 的边界，则 Frame 的位置将被设置为 (10, 10)（相对于虚拟坐标系），并出现在主物理屏幕上，主物理屏幕不同于指定的 GraphicsConfiguration 的物理屏幕。

      Frame f = new Frame(GraphicsConfiguration gc);
      Rectangle bounds = gc.getBounds();
      f.setLocation(10 + bounds.x, 10 + bounds.y);

窗体能够生成以下类型的 WindowEvent：

  • WINDOW_OPENED
  • WINDOW_CLOSING:
    在处理此事件时，如果程序没有显式地隐藏或释放窗口，则取消窗口关闭操作。
  • WINDOW_CLOSED
  • WINDOW_ICONIFIED
  • WINDOW_DEICONIFIED
  • WINDOW_ACTIVATED
  • WINDOW_DEACTIVATED
  • WINDOW_GAINED_FOCUS
  • WINDOW_LOST_FOCUS
  • WINDOW_STATE_CHANGED

从以下版本开始：
JDK1.0
另请参见：
WindowEvent, Window.addWindowListener(java.awt.event.WindowListener), 序列化表格

嵌套类摘要
protected  class Frame.AccessibleAWTFrame
此类实现对 Frame 类的可访问性支持。
从类 java.awt.Window 继承的嵌套类/接口
Window.AccessibleAWTWindow
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | CROSSHAIR_CURSOR 已过时。 由 Cursor.CROSSHAIR_CURSOR 取代。
static int | DEFAULT_CURSOR 已过时。 由 Cursor.DEFAULT_CURSOR 取代。
static int | E_RESIZE_CURSOR 已过时。 由 Cursor.E_RESIZE_CURSOR 取代。
static int | HAND_CURSOR 已过时。 由 Cursor.HAND_CURSOR 取代。
static int | ICONIFIED 此状态位指示将窗体图标化。
static int | MAXIMIZED_BOTH 此状态位掩码指示将窗体完全最大化（水平和垂直方向）。
static int | MAXIMIZED_HORIZ 此状态位指示在水平方向将窗体最大化。
static int | MAXIMIZED_VERT 此状态位指示在垂直方向将窗体最大化。
static int | MOVE_CURSOR 已过时。 由 Cursor.MOVE_CURSOR 取代。
static int | N_RESIZE_CURSOR 已过时。 由 Cursor.N_RESIZE_CURSOR 取代。
static int | NE_RESIZE_CURSOR 已过时。 由 Cursor.NE_RESIZE_CURSOR 取代。
static int | NORMAL 窗体处于 "normal" 状态。
static int | NW_RESIZE_CURSOR 已过时。 由 Cursor.NW_RESIZE_CURSOR 取代。
static int | S_RESIZE_CURSOR 已过时。 由 Cursor.S_RESIZE_CURSOR 取代。
static int | SE_RESIZE_CURSOR 已过时。 由 Cursor.SE_RESIZE_CURSOR 取代。
static int | SW_RESIZE_CURSOR 已过时。 由 Cursor.SW_RESIZE_CURSOR 取代。
static int | TEXT_CURSOR 已过时。 由 Cursor.TEXT_CURSOR 取代。
static int | W_RESIZE_CURSOR 已过时。 由 Cursor.W_RESIZE_CURSOR 取代。
static int | WAIT_CURSOR 已过时。 由 Cursor.WAIT_CURSOR 取代。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Frame()
构造一个最初不可见的 Frame 新实例（）。
Frame(GraphicsConfiguration gc)
使用指定的 GraphicsConfiguration 构造一个最初不可见的新 Frame。
Frame(String title)
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。
Frame(String title, GraphicsConfiguration gc)
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。
方法摘要
 void addNotify()
通过将此窗体连接到本机屏幕资源，使其成为可显示的。
 AccessibleContext getAccessibleContext()
获取与此窗体有关的 AccessibleContext。
 int getCursorType()
已过时。 从 JDK version 1.1 开始，由 Component.getCursor() 取代。
 int getExtendedState()
获取此窗体的状态。
static Frame[] getFrames()
返回一个此应用程序创建的所有 Frame 所组成的数组。
 Image getIconImage()
返回要作为此窗体图标显示的图像。
 Rectangle getMaximizedBounds()
获取此窗体的最大化边界。
 MenuBar getMenuBar()
获取此窗体的菜单栏。
 int getState()
获取此窗体的状态（已废弃）。
 String getTitle()
获得窗体的标题。
 boolean isResizable()
指示此窗体是否可由用户调整大小。
 boolean isUndecorated()
指示此窗体是否未装饰。
protected  String paramString()
返回表示此 Frame 状态的字符串。
 void remove(MenuComponent m)
从此窗体移除指定的菜单栏。
 void removeNotify()
通过移除与本机屏幕资源的连接，将此窗体设置为不可显示的。
 void setCursor(int cursorType)
已过时。 从 JDK version 1.1 开始，由 Component.setCursor(Cursor) 取代。
 void setExtendedState(int state)
设置此窗体的状态。
 void setIconImage(Image image)
设置要作为此窗口图标显示的图像。
 void setMaximizedBounds(Rectangle bounds)
设置此窗体的最大化边界。
 void setMenuBar(MenuBar mb)
将此窗体的菜单栏设置为指定的菜单栏。
 void setResizable(boolean resizable)
设置此窗体是否可由用户调整大小。
 void setState(int state)
设置此窗体的状态（已废弃）。
 void setTitle(String title)
将此窗体的标题设置为指定的字符串。
 void setUndecorated(boolean undecorated)
禁用或启用此窗体的装饰。
从类 java.awt.Window 继承的方法
addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getGraphicsConfiguration, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOwnedWindows, getOwner, getOwnerlessWindows, getToolkit, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isShowing, pack, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setVisible, show, toBack, toFront
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.awt.MenuContainer 继承的方法
getFont, postEvent

字段详细信息

DEFAULT_CURSOR

@Deprecated
public static final int DEFAULT_CURSOR
已过时。 由 Cursor.DEFAULT_CURSOR 取代。
另请参见：
常量字段值

CROSSHAIR_CURSOR

@Deprecated
public static final int CROSSHAIR_CURSOR
已过时。 由 Cursor.CROSSHAIR_CURSOR 取代。
另请参见：
常量字段值

TEXT_CURSOR

@Deprecated
public static final int TEXT_CURSOR
已过时。 由 Cursor.TEXT_CURSOR 取代。
另请参见：
常量字段值

WAIT_CURSOR

@Deprecated
public static final int WAIT_CURSOR
已过时。 由 Cursor.WAIT_CURSOR 取代。
另请参见：
常量字段值

SW_RESIZE_CURSOR

@Deprecated
public static final int SW_RESIZE_CURSOR
已过时。 由 Cursor.SW_RESIZE_CURSOR 取代。
另请参见：
常量字段值

SE_RESIZE_CURSOR

@Deprecated
public static final int SE_RESIZE_CURSOR
已过时。 由 Cursor.SE_RESIZE_CURSOR 取代。
另请参见：
常量字段值

NW_RESIZE_CURSOR

@Deprecated
public static final int NW_RESIZE_CURSOR
已过时。 由 Cursor.NW_RESIZE_CURSOR 取代。
另请参见：
常量字段值

NE_RESIZE_CURSOR

@Deprecated
public static final int NE_RESIZE_CURSOR
已过时。 由 Cursor.NE_RESIZE_CURSOR 取代。
另请参见：
常量字段值

N_RESIZE_CURSOR

@Deprecated
public static final int N_RESIZE_CURSOR
已过时。 由 Cursor.N_RESIZE_CURSOR 取代。
另请参见：
常量字段值

S_RESIZE_CURSOR

@Deprecated
public static final int S_RESIZE_CURSOR
已过时。 由 Cursor.S_RESIZE_CURSOR 取代。
另请参见：
常量字段值

W_RESIZE_CURSOR

@Deprecated
public static final int W_RESIZE_CURSOR
已过时。 由 Cursor.W_RESIZE_CURSOR 取代。
另请参见：
常量字段值

E_RESIZE_CURSOR

@Deprecated
public static final int E_RESIZE_CURSOR
已过时。 由 Cursor.E_RESIZE_CURSOR 取代。
另请参见：
常量字段值

HAND_CURSOR

@Deprecated
public static final int HAND_CURSOR
已过时。 由 Cursor.HAND_CURSOR 取代。
另请参见：
常量字段值

MOVE_CURSOR

@Deprecated
public static final int MOVE_CURSOR
已过时。 由 Cursor.MOVE_CURSOR 取代。
另请参见：
常量字段值

NORMAL

public static final int NORMAL
窗体处于 "normal" 状态。此符号常量指定所有状态位均被清除的窗体状态。

另请参见：
setExtendedState(int), getExtendedState(), 常量字段值

ICONIFIED

public static final int ICONIFIED
此状态位指示将窗体图标化。

另请参见：
setExtendedState(int), getExtendedState(), 常量字段值

MAXIMIZED_HORIZ

public static final int MAXIMIZED_HORIZ
此状态位指示在水平方向将窗体最大化。

从以下版本开始：
1.4
另请参见：
setExtendedState(int), getExtendedState(), 常量字段值

MAXIMIZED_VERT

public static final int MAXIMIZED_VERT
此状态位指示在垂直方向将窗体最大化。

从以下版本开始：
1.4
另请参见：
setExtendedState(int), getExtendedState(), 常量字段值

MAXIMIZED_BOTH

public static final int MAXIMIZED_BOTH
此状态位掩码指示将窗体完全最大化（水平和垂直方向）。它只是 MAXIMIZED_VERT | MAXIMIZED_HORIZ 的一种便捷别名。

注意，要正确测试窗体是否完全最大化，使用以下方法：

     (state & Frame.MAXIMIZED_BOTH) == Frame.MAXIMIZED_BOTH

要测试窗体是否在某个 方向最大化，使用：

     (state & Frame.MAXIMIZED_BOTH) != 0

从以下版本开始：
1.4
另请参见：
setExtendedState(int), getExtendedState(), 常量字段值
构造方法详细信息

Frame

public Frame()
      throws HeadlessException
构造一个最初不可见的 Frame 新实例（）。Frame 的标题为空。

抛出：
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
另请参见：
GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean)

Frame

public Frame(GraphicsConfiguration gc)
使用指定的 GraphicsConfiguration 构造一个最初不可见的新 Frame。

参数：
gc - 目标屏幕设备的 GraphicsConfiguration。如果 gc 为 null，则假定它为系统默认的 GraphicsConfiguration。
抛出：
IllegalArgumentException - 如果 gc 不是来自屏幕设备。
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless()

Frame

public Frame(String title)
      throws HeadlessException
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。

参数：
title - 要显示在窗体边框中的标题。null 值视为空字符串 ""。
抛出：
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
另请参见：
GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean),
GraphicsConfiguration.getBounds()

Frame

public Frame(String title,
             GraphicsConfiguration gc)
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。

参数：
title - 要显示在窗体边框中的标题。null 值视为空字符串 ""。
gc - 目标屏幕设备的 GraphicsConfiguration。如果 gc 为 null，则假定它为系统默认的 GraphicsConfiguration。
抛出：
IllegalArgumentException - 如果 gc 不是来自屏幕设备。
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean),
GraphicsConfiguration.getBounds()
方法详细信息

addNotify

public void addNotify()
通过将此窗体连接到本机屏幕资源，使其成为可显示的。如果窗体是可显示的，则其所有子级也将成为可显示的。此方法由工具包内部调用，不应直接由程序调用。

覆盖：
类 Window 中的 addNotify
另请参见：
Component.isDisplayable(), removeNotify()

getTitle

public String getTitle()
获得窗体的标题。标题显示在窗体的边框中。

返回：
此窗体的标题，如果此窗体没有标题，则返回一个空字符串 ("") 。
另请参见：
setTitle(String)

setTitle

public void setTitle(String title)
将此窗体的标题设置为指定的字符串。

参数：
title - 要显示在窗体边框中的标题。null 值视为空字符串 ""。
另请参见：
getTitle()

getIconImage

public Image getIconImage()
返回要作为此窗体图标显示的图像。

此方法已废弃，保留它只是为了向后兼容性。使用 Window.getIconImages() 代替。

如果将几个图像的列表指定为 Window 的图标，则此方法返回列表的第一项。

返回：
此窗体的图标图像；如果此窗体没有图标图像，则返回 null。
另请参见：
setIconImage(Image), Window.getIconImages(), Window.setIconImages(java.util.List)

setIconImage

public void setIconImage(Image image)
设置要作为此窗口图标显示的图像。

将单个图像指定为窗口的图标时，可以使用此方法代替 setIconImages()。

以下语句：

     setIconImage(image);
等价于：
     ArrayList   imageList = new ArrayList  ();
     imageList.add(image);
     setIconImages(imageList);

注：根据上下文的不同（例如，窗口装饰、窗口列表、任务栏等），本机窗口系统可以使用不同尺寸的不同图像表示一个窗口。也可以对所有上下文使用一个图像，或者根本不用图像。

覆盖：
类 Window 中的 setIconImage
参数：
image - 要显示的图标图像。
另请参见：
Window.setIconImages(java.util.List), Window.getIconImages()

getMenuBar

public MenuBar getMenuBar()
获取此窗体的菜单栏。

返回：
此窗体的菜单栏；如果此窗体没有菜单栏，则返回 null。
另请参见：
setMenuBar(MenuBar)

setMenuBar

public void setMenuBar(MenuBar mb)
将此窗体的菜单栏设置为指定的菜单栏。

参数：
mb - 正被设置的菜单栏。如果此参数为 null，则移除此窗体上现有的所有菜单栏。
另请参见：
getMenuBar()

isResizable

public boolean isResizable()
指示此窗体是否可由用户调整大小。在默认情况下，所有窗体最初都可以调整大小。

返回：
如果用户可以调整窗体的大小，则返回 true；否则返回 false。
另请参见：
setResizable(boolean)

setResizable

public void setResizable(boolean resizable)
设置此窗体是否可由用户调整大小。

参数：
resizable - 如果此窗体是可调整大小的，则为 true；否则为 false。
另请参见：
isResizable()

setState

public void setState(int state)
设置此窗体的状态（已废弃）。

在较早的 JDK 版本中，窗体的状态只能为 NORMAL 或 ICONIFIED。自从 JDK 1.4 以来，受支持的窗体状态集合扩大了，窗体状态表示为逐位掩码。

为了与原有的程序兼容，此方法仍然接受 Frame.NORMAL 和 Frame.ICONIFIED，但它只改变窗体的图标状态，而不影响窗体其他方面的状态。

参数：
state - Frame.NORMAL 或 Frame.ICONIFIED。
另请参见：
getState(), setExtendedState(int)

setExtendedState

public void setExtendedState(int state)
设置此窗体的状态。该状态表示为逐位掩码。
  • NORMAL
    指示不设置任何状态位。
  • ICONIFIED
  • MAXIMIZED_HORIZ
  • MAXIMIZED_VERT
  • MAXIMIZED_BOTH
    串连 MAXIMIZED_HORIZ 和 MAXIMIZED_VERT。

注意，如果该状态在给定平台上不受支持，则什么也不会发生。应用程序可以通过 java.awt.Toolkit#isFrameStateSupported(int state) 方法确定特定的状态是否可用。

参数：
state - 窗体状态常量的逐位掩码
从以下版本开始：
1.4
另请参见：
getExtendedState(), Toolkit.isFrameStateSupported(int)

getState

public int getState()
获取此窗体的状态（已废弃）。

在较早的 JDK 版本中，窗体的状态只能为 NORMAL 或 ICONIFIED。自从 JDK 1.4 以来，受支持的窗体状态集合扩大了，窗体状态表示为逐位掩码。

为了与原有的程序兼容，此方法仍然返回 Frame.NORMAL 和 Frame.ICONIFIED，但它只报告窗体的图标状态，而不报告窗体其他方面的状态。

返回：
Frame.NORMAL 或 Frame.ICONIFIED。
另请参见：
setState(int), getExtendedState()

getExtendedState

public int getExtendedState()
获取此窗体的状态。该状态表示为逐位掩码。
  • NORMAL
    指示不设置任何状态位。
  • ICONIFIED
  • MAXIMIZED_HORIZ
  • MAXIMIZED_VERT
  • MAXIMIZED_BOTH
    串连 MAXIMIZED_HORIZ 和 MAXIMIZED_VERT。

返回：
窗体状态常量的逐位掩码
从以下版本开始：
1.4
另请参见：
setExtendedState(int)

setMaximizedBounds

public void setMaximizedBounds(Rectangle bounds)
设置此窗体的最大化边界。

当窗体处于最大化状态时，系统提供默认边界。此方法允许重写系统提供的部分或全部值。

如果 bounds 为 null，则接受系统提供的边界。如果 bound 不为 null，则可以重写系统提供的某些值而接受其他值，这通过将希望从系统接受的那些字段设置为 Integer.MAX_VALUE 来完成。

在某些系统中，只考虑部分边界的大小。

参数：
bounds - 最大化状态的边界
从以下版本开始：
1.4
另请参见：
getMaximizedBounds()

getMaximizedBounds

public Rectangle getMaximizedBounds()
获取此窗体的最大化边界。有些字段可能包含 Integer.MAX_VALUE，指示必须使用系统为该字段提供的值。

返回：
此窗体的最大化边界；可以为 null
从以下版本开始：
1.4
另请参见：
setMaximizedBounds(Rectangle)

setUndecorated

public void setUndecorated(boolean undecorated)
禁用或启用此窗体的装饰。只有在窗体不可显示时才调用此方法。

参数：
undecorated - 如果没有启用窗体装饰，则为 true；如果启用了窗体装饰，则为 false。
抛出：
IllegalComponentStateException - 如果窗体是可显示的。
从以下版本开始：
1.4
另请参见：
isUndecorated(),
Component.isDisplayable(),
JFrame.setDefaultLookAndFeelDecorated(boolean)

isUndecorated

public boolean isUndecorated()
指示此窗体是否未装饰。在默认情况下，所有窗体初始时都是已装饰的。

返回：
如果窗体未装饰，则返回 true；否则返回 false。
从以下版本开始：
1.4
另请参见：
setUndecorated(boolean)

remove

public void remove(MenuComponent m)
从此窗体移除指定的菜单栏。

指定者：
接口 MenuContainer 中的 remove
覆盖：
类 Component 中的 remove
参数：
m - 要移除的菜单组件。如果 m 为 null，则不执行任何操作。
另请参见：
Component.add(PopupMenu)

removeNotify

public void removeNotify()
通过移除与本机屏幕资源的连接，将此窗体设置为不可显示的。如果窗体是不可显示的，则其所有子级也将成为不可显示的。此方法由工具包内部调用，不应直接由程序调用。

覆盖：
类 Window 中的 removeNotify
另请参见：
Component.isDisplayable(), addNotify()

paramString

protected String paramString()
返回表示此 Frame 状态的字符串。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Container 中的 paramString
返回：
此窗体的参数字符串

setCursor

@Deprecated
public void setCursor(int cursorType)
已过时。 从 JDK version 1.1 开始，由 Component.setCursor(Cursor) 取代。

getCursorType

@Deprecated
public int getCursorType()
已过时。 从 JDK version 1.1 开始，由 Component.getCursor() 取代。

getFrames

public static Frame[] getFrames()
返回一个此应用程序创建的所有 Frame 所组成的数组。如果从 applet 调用，则数组只包括该 applet 可访问的 Frame。

警告： 此方法可能返回系统创建的窗体，如 Swing 使用的共享的、隐藏的窗体。应用程序不应该假定这些窗口存在，也不应该假定与这些窗体有关的任何内容（如组件位置、LayoutManager 或序列化）存在。

注：若要获得没有所有者的窗口列表，包括没有所有者的 Dialog（在版本 1.6 中引入），请使用 Window.getOwnerlessWindows。

从以下版本开始：
1.2
另请参见：
Window.getWindows(sun.awt.AppContext), Window.getOwnerlessWindows()

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此窗体有关的 AccessibleContext。对于 frame，AccessibleContext 采用 AccessibleAWTFrame 的形式。如有必要，创建一个新的 AccessibleAWTFrame 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Window 中的 getAccessibleContext
返回：
用作此窗体 AccessibleContext 的 AccessibleAWTFrame。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Frame.AccessibleAWTFrame (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Frame.AccessibleAWTFrame

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Window.AccessibleAWTWindow
                    继承者  java.awt.Frame.AccessibleAWTFrame
所有已实现的接口：
Serializable, AccessibleComponent
直接已知子类：
JFrame.AccessibleJFrame
正在封闭类：
Frame
protected class Frame.AccessibleAWTFrame
extends Window.AccessibleAWTWindow

此类实现对 Frame 类的可访问性支持。它提供了适合 frame 用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Frame.AccessibleAWTFrame()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Frame.AccessibleAWTFrame

protected Frame.AccessibleAWTFrame()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Window.AccessibleAWTWindow 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

覆盖：
类 Window.AccessibleAWTWindow 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GradientPaint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GradientPaint

java.lang.Object
    继承者  java.awt.GradientPaint
所有已实现的接口：
Paint, Transparency
public class GradientPaint
extends Object
implements Paint

GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。如果在用户空间指定了 Point P1 的 Color 为 C1，Point P2 的 Color 为 C2，则 P1、P2 连接线上的 Color 是逐渐地从 C1 变化到 C2 的。任何不在 P1、P2 延长线上的点 P 都具有点 P' 的颜色，P' 是 P1、P2 延长线上点 P 的垂直投影。P1、P2 段以外的延长线上的点可以按以下两种方式之一进行着色。

  • 如果渐变是周期性的，那么 P1、P2 延长线上的点在颜色 C1 和 C2 之间来回循环。
  • 如果渐变是非周期性的，那么 P1 一边的点有固定的 Color C1，而 P2 一边的点有固定的 Color C2。

另请参见：
Paint, Graphics2D.setPaint(java.awt.Paint)

字段摘要
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
GradientPaint(float x1, float y1, Color color1, float x2, float y2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(float x1, float y1, Color color1, float x2, float y2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
方法摘要
PaintContext | createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
Color | getColor1() 返回点 P1 的颜色 C1。
Color | getColor2() 返回点 P2 的颜色 C2。
Point2D | getPoint1() 返回着第一种颜色的点 P1 的副本。
Point2D | getPoint2() 返回着第二种颜色的点 P2 的副本。
int | getTransparency() 返回此 GradientPaint 的透明度模式。
boolean | isCyclic() 如果渐变在两种颜色 C1 和 C2 之间重复循环，则返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GradientPaint

public GradientPaint(float x1,
                     float y1,
                     Color color1,
                     float x2,
                     float y2,
                     Color color2)
构造一个简单的非周期性 GradientPaint 对象。

参数：
x1 - 用户空间中第一个指定 Point 的 x 坐标
y1 - 用户空间中第一个指定 Point 的 y 坐标
color1 - 第一个指定 Point 处的 Color
x2 - 用户空间中第二个指定 Point 的 x 坐标
y2 - 用户空间中第二个指定 Point 的 y 坐标
color2 - 第二个指定 Point 处的 Color
抛出：
NullPointerException - 如果任何一个 color 为 null

GradientPaint

public GradientPaint(Point2D pt1,
                     Color color1,
                     Point2D pt2,
                     Color color2)
构造一个简单的非周期性 GradientPaint 对象。

参数：
pt1 - 用户空间中第一个指定的 Point
color1 - 第一个指定 Point 处的 Color
pt2 - 用户空间中第二个指定的 Point
color2 - 第二个指定 Point 处的 Color
抛出：
NullPointerException - 如果任何一个 color 或 point 为 null

GradientPaint

public GradientPaint(float x1,
                     float y1,
                     Color color1,
                     float x2,
                     float y2,
                     Color color2,
                     boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。

参数：
x1 - 用户空间中第一个指定 Point 的 x 坐标
y1 - 用户空间中第一个指定 Point 的 y 坐标
color1 - 第一个指定 Point 处的 Color
x2 - 用户空间中第二个指定 Point 的 x 坐标
y2 - 用户空间中第二个指定 Point 的 y 坐标
color2 - 第二个指定 Point 处的 Color
cyclic - 如果渐变模式在两种颜色之间重复循环，则为 true；否则为 false。

GradientPaint

public GradientPaint(Point2D pt1,
                     Color color1,
                     Point2D pt2,
                     Color color2,
                     boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。

参数：
pt1 - 用户空间中第一个指定的 Point
color1 - 第一个指定 Point 处的 Color
pt2 - 用户空间中第二个指定的 Point
color2 - 第二个指定 Point 处的 Color
cyclic - 如果渐变模式在两种颜色之间重复循环，则为 true；否则为 false。
方法详细信息

getPoint1

public Point2D getPoint1()
返回着第一种颜色的点 P1 的副本。

返回：
Point2D 对象，它是着 GradientPaint 的第一种颜色的点的副本。

getColor1

public Color getColor1()
返回点 P1 的颜色 C1。

返回：
Color 对象，P1 的颜色。

getPoint2

public Point2D getPoint2()
返回着第二种颜色的点 P2 的副本。

返回：
Point2D 对象，它是着 GradientPaint 的第二种颜色的点的副本。

getColor2

public Color getColor2()
返回点 P2 的颜色 C2。

返回：
Color 对象，P2 的颜色。

isCyclic

public boolean isCyclic()
如果渐变在两种颜色 C1 和 C2 之间重复循环，则返回 true。

返回：
如果渐变在两种颜色之间重复循环，则返回 true；否则返回 false。

createContext

public PaintContext createContext(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform xform,
                                  RenderingHints hints)
创建并返回用来生成颜色模式的上下文。

指定者：
接口 Paint 中的 createContext
参数：
cm - 接收 Paint 数据的 ColorModel。这仅作为提示使用。
deviceBounds - 正在呈现的图形图元的设备空间边界框
userBounds - 正在呈现的图形图元的用户空间边界框
xform - 从用户空间到设备空间的 AffineTransform
hints - context 对象用于选择所呈现内容的提示
返回：
生成颜色模式的 PaintContext。
另请参见：
PaintContext

getTransparency

public int getTransparency()
返回此 GradientPaint 的透明度模式。

指定者：
接口 Transparency 中的 getTransparency
返回：
一个整数值，表示此 GradientPaint 对象的透明度模式。
另请参见：
Transparency
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Graphics (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Graphics

java.lang.Object
    继承者  java.awt.Graphics
直接已知子类：
DebugGraphics, Graphics2D
public abstract class Graphics
extends Object

Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。

Graphics 对象封装了 Java 支持的基本呈现操作所需的状态信息。此状态信息包括以下属性：

  • 要在其上绘制的 Component 对象。
  • 呈现和剪贴坐标的转换原点。
  • 当前剪贴区。
  • 当前颜色。
  • 当前字体。
  • 当前逻辑像素操作函数（XOR 或 Paint）。
  • 当前 XOR 交替颜色（参见 setXORMode(java.awt.Color)）。

坐标是无限细分的，并且位于输出设备的像素之间。绘制图形轮廓的操作是通过使用像素大小的画笔遍历像素间无限细分路径的操作，画笔从路径上的锚点向下和向右绘制。填充图形的操作是填充图形内部区域无限细分路径操作。呈现水平文本的操作是呈现字符字形完全位于基线坐标之上的上升部分。

图形画笔从要遍历的路径向下和向右绘制。其含义如下：

  • 如果绘制一个覆盖给定矩形的图形，那么该图形与填充被相同矩形所限定的图形相比，在右侧和底边多占用一行像素。
  • 如果沿着与一行文本基线相同的 y 坐标绘制一条水平线，那么除了文字的所有下降部分外，该线完全画在文本的下面。

所有作为此 Graphics 对象方法的参数而出现的坐标，都是相对于调用该方法前的此 Graphics 对象转换原点的。

所有呈现操作仅修改当前剪贴区所限定区域内的像素，此剪贴区是由用户空间中的 Shape 指定的，并通过使用 Graphics 对象的程序来控制。此用户剪贴区 被转换到设备空间中，并与设备剪贴区 组合，后者是通过窗口可见性和设备范围定义的。用户剪贴区和设备剪贴区的组合定义复合剪贴区，复合剪贴区确定最终的剪贴区域。用户剪贴区不能由呈现系统修改，以反映得到的复合剪贴区。用户剪贴区只能通过 setClip 或 clipRect 方法更改。所有的绘制或写入都以当前的颜色、当前绘图模式和当前字体完成。

从以下版本开始：
JDK1.0
另请参见：
Component,
clipRect(int, int, int, int),
setColor(java.awt.Color),
setPaintMode(),
setXORMode(java.awt.Color),
setFont(java.awt.Font)

构造方法摘要
protected Graphics()
构造一个新的 Graphics 对象。
方法摘要
abstract  void clearRect(int x, int y, int width, int height)
通过使用当前绘图表面的背景色进行填充来清除指定的矩形。
abstract  void clipRect(int x, int y, int width, int height)
将当前剪贴区与指定的矩形相交。
abstract  void copyArea(int x, int y, int width, int height, int dx, int dy)
将组件的区域复制到由 dx 和 dy 指定的距离处。
abstract  Graphics create()
创建一个新的 Graphics 对象，它是此 Graphics 对象的副本。
 Graphics create(int x, int y, int width, int height)
基于此 Graphics 对象创建一个新的 Graphics 对象，但是使用新的转换和剪贴区域。
abstract  void dispose()
释放此图形的上下文以及它使用的所有系统资源。
 void draw3DRect(int x, int y, int width, int height, boolean raised)
绘制指定矩形的 3-D 高亮显示边框。
abstract  void drawArc(int x, int y, int width, int height, int startAngle, int arcAngle)
绘制一个覆盖指定矩形的圆弧或椭圆弧边框。
 void drawBytes(byte[] data, int offset, int length, int x, int y)
使用此图形上下文的当前字体和颜色绘制由指定 byte 数组给定的文本。
 void drawChars(char[] data, int offset, int length, int x, int y)
使用此图形上下文的当前字体和颜色绘制由指定字符数组给定的文本。
abstract  boolean drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer)
绘制指定图像中当前可用的图像。
abstract  boolean drawImage(Image img, int x, int y, ImageObserver observer)
绘制指定图像中当前可用的图像。
abstract  boolean drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer)
绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract  boolean drawImage(Image img, int x, int y, int width, int height, ImageObserver observer)
绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract  boolean drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer)
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract  boolean drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer)
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract  void drawLine(int x1, int y1, int x2, int y2)
在此图形上下文的坐标系中，使用当前颜色在点 (x1, y1) 和 (x2, y2) 之间画一条线。
abstract  void drawOval(int x, int y, int width, int height)
绘制椭圆的边框。
abstract  void drawPolygon(int[] xPoints, int[] yPoints, int nPoints)
绘制一个由 x 和 y 坐标数组定义的闭合多边形。
 void drawPolygon(Polygon p)
绘制由指定的 Polygon 对象定义的多边形边框。
abstract  void drawPolyline(int[] xPoints, int[] yPoints, int nPoints)
绘制由 x 和 y 坐标数组定义的一系列连接线。
 void drawRect(int x, int y, int width, int height)
绘制指定矩形的边框。
abstract  void drawRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
用此图形上下文的当前颜色绘制圆角矩形的边框。
abstract  void drawString(AttributedCharacterIterator iterator, int x, int y)
依据 TextAttribute 类的规范应用指定迭代器的属性，呈现迭代器的文本。
abstract  void drawString(String str, int x, int y)
使用此图形上下文的当前字体和颜色绘制由指定 string 给定的文本。
 void fill3DRect(int x, int y, int width, int height, boolean raised)
绘制一个用当前颜色填充的 3-D 高亮显示矩形。
abstract  void fillArc(int x, int y, int width, int height, int startAngle, int arcAngle)
填充覆盖指定矩形的圆弧或椭圆弧。
abstract  void fillOval(int x, int y, int width, int height)
使用当前颜色填充外接指定矩形框的椭圆。
abstract  void fillPolygon(int[] xPoints, int[] yPoints, int nPoints)
填充由 x 和 y 坐标数组定义的闭合多边形。
 void fillPolygon(Polygon p)
用图形上下文的当前颜色填充指定 Polygon 对象定义的多边形。
abstract  void fillRect(int x, int y, int width, int height)
填充指定的矩形。
abstract  void fillRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight)
用当前颜色填充指定的圆角矩形。
 void finalize()
一旦不再引用此图形上下文就释放它。
abstract  Shape getClip()
获取当前剪贴区域。
abstract  Rectangle getClipBounds()
返回当前剪贴区域的边界矩形。
 Rectangle getClipBounds(Rectangle r)
返回当前剪贴区域的边界矩形。
 Rectangle getClipRect()
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。
abstract  Color getColor()
获取此图形上下文的当前颜色。
abstract  Font getFont()
获取当前字体。
 FontMetrics getFontMetrics()
获取当前字体的字体规格。
abstract  FontMetrics getFontMetrics(Font f)
获取指定字体的字体规格。
 boolean hitClip(int x, int y, int width, int height)
如果指定的矩形区域与当前的剪贴区域相交，则返回 true。
abstract  void setClip(int x, int y, int width, int height)
将当前剪贴区设置为由给定坐标指定的矩形。
abstract  void setClip(Shape clip)
将当前剪贴区域设置为任意的剪贴形状。
abstract  void setColor(Color c)
将此图形上下文的当前颜色设置为指定颜色。
abstract  void setFont(Font font)
将此图形上下文的字体设置为指定字体。
abstract  void setPaintMode()
设置将此图形上下文的绘图模式，以便通过此图形上下文中的当前颜色来覆盖目标。
abstract  void setXORMode(Color c1)
将此图形上下文的绘图模式设置为在此图形上下文的当前颜色和新的指定颜色之间交替。
 String toString()
返回表示此 Graphics 对象值的 String 对象。
abstract  void translate(int x, int y)
将图形上下文的原点平移到当前坐标系中的点 (x, y)。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Graphics

protected Graphics()
构造一个新的 Graphics 对象。此构造方法是用于图形上下文的默认构造方法。

因为 Graphics 是一个抽象类，所以应用程序不能直接调用此构造方法。图形上下文从其他图形上下文获取，或者通过在组件上调用 getGraphics 来创建。

另请参见：
create(), Component.getGraphics()
方法详细信息

create

public abstract Graphics create()
创建一个新的 Graphics 对象，它是此 Graphics 对象的副本。

返回：
新的图形上下文，它是此图形上下文的副本。

create

public Graphics create(int x,
                       int y,
                       int width,
                       int height)
基于此 Graphics 对象创建一个新的 Graphics 对象，但是使用新的转换和剪贴区域。新 Graphics 对象的原点平移到指定点 (x, y)。其剪贴区域由原始剪贴区域和指定矩形的交集确定。各个参数均在原始 Graphics 对象的坐标系内进行解释。新图形上下文除以下两方面之外，其他与原始图形上下文相同：

  • 新的图形上下文平移了 (x, y)。也就是说，新图形上下文中的点 (0, 0) 与原图形上下文中的点 (x, y) 相同。
  • 新图形上下文除了具有一个从原始图形上下文继承的（平移的）剪贴矩形之外，还有一个额外的剪贴矩形，新剪贴矩形的原点为 (0, 0)，其大小由 width 和 height 参数指定。

参数：
x - x 坐标。
y - y 坐标。
width - 剪贴矩形的宽度。
height - 剪贴矩形的高度。
返回：
新的图形上下文。
另请参见：
translate(int, int), clipRect(int, int, int, int)

translate

public abstract void translate(int x,
                               int y)
将图形上下文的原点平移到当前坐标系中的点 (x, y)。修改此图形上下文，使其新的原点对应于此图形上下文原坐标系中的点 (x, y)。在此图形上下文上执行的后续呈现操作所用的所有坐标均相对于这个新原点。

参数：
x - x 坐标。
y - y 坐标。

getColor

public abstract Color getColor()
获取此图形上下文的当前颜色。

返回：
此图形上下文的当前颜色。
另请参见：
Color, setColor(Color)

setColor

public abstract void setColor(Color c)
将此图形上下文的当前颜色设置为指定颜色。使用此图形上下文的所有后续图形操作均使用这个指定的颜色。

参数：
c - 新的呈现颜色。
另请参见：
Color, getColor()

setPaintMode

public abstract void setPaintMode()
设置将此图形上下文的绘图模式，以便通过此图形上下文中的当前颜色来覆盖目标。此方法将逻辑像素操作函数设置为绘图模式或覆盖模式。所有后续呈现操作将使用当前颜色覆盖目标。

setXORMode

public abstract void setXORMode(Color c1)
将此图形上下文的绘图模式设置为在此图形上下文的当前颜色和新的指定颜色之间交替。这指定了逻辑像素操作以 XOR 模式执行，在此模式中像素在当前颜色和指定的 XOR 颜色之间进行交替。

当执行绘制操作时，当前颜色的像素更改为指定的颜色，反之亦然。

这两种颜色以外的像素以不可预测但可逆的方式更改；如果相同的图形被绘制两次，则所有像素恢复到原始值。

参数：
c1 - XOR 交替颜色

getFont

public abstract Font getFont()
获取当前字体。

返回：
此图形上下文的当前字体。
另请参见：
Font, setFont(Font)

setFont

public abstract void setFont(Font font)
将此图形上下文的字体设置为指定字体。使用此图形上下文的所有后续文本操作均使用此字体。忽略 null 参数。

参数：
font - 字体。
另请参见：
getFont(),
drawString(java.lang.String, int, int),
drawBytes(byte[], int, int, int, int),
drawChars(char[], int, int, int, int)

getFontMetrics

public FontMetrics getFontMetrics()
获取当前字体的字体规格。

返回：
此图形上下文当前字体的字体规格。
另请参见：
getFont(), FontMetrics, getFontMetrics(Font)

getFontMetrics

public abstract FontMetrics getFontMetrics(Font f)
获取指定字体的字体规格。

参数：
f - 指定的字体
返回：
指定字体的字体规格。
另请参见：
getFont(), FontMetrics, getFontMetrics()

getClipBounds

public abstract Rectangle getClipBounds()
返回当前剪贴区域的边界矩形。此方法引用用户剪贴区，用户剪贴区与设备边界和窗口可见性关联的剪贴区无关。如果以前未设置剪贴区，或者已使用 setClip(null) 清除了剪贴区，则此方法返回 null。该矩形内的坐标相对于此图形上下文的坐标系原点。

返回：
当前剪贴区域的边界矩形；如果未设置剪贴区，则返回 null。
从以下版本开始：
JDK1.1
另请参见：
getClip(),
clipRect(int, int, int, int),
setClip(int, int, int, int),
setClip(Shape)

clipRect

public abstract void clipRect(int x,
                              int y,
                              int width,
                              int height)
将当前剪贴区与指定的矩形相交。得到的剪贴区域是当前剪贴区域和指定矩形的交集。如果因为从未设置过剪贴区，或者已使用 setClip(null) 清除了剪贴区而导致没有当前剪贴区域，那么指定的矩形将成为新的剪贴区。此方法设置用户剪贴区，用户剪贴区与设备边界和窗口可见性所关联的剪贴区无关。此方法只能用来缩小当前剪贴区。要扩大当前剪贴区，请使用 setClip 方法。呈现操作对剪贴区域的外部没有影响。

参数：
x - 要与剪贴区相交的矩形的 x 坐标
y - 要与剪贴区相交的矩形的 y 坐标
width - 要与剪贴区相交的矩形的宽度
height - 要与剪贴区相交的矩形的高度
另请参见：
setClip(int, int, int, int), setClip(Shape)

setClip

public abstract void setClip(int x,
                             int y,
                             int width,
                             int height)
将当前剪贴区设置为由给定坐标指定的矩形。此方法设置用户剪贴区，用户剪贴区与设备边界和窗口可见性关联的剪贴区无关。呈现操作对剪贴区域的外部没有影响。

参数：
x - 新剪贴区矩形的 x 坐标。
y - 新剪贴区矩形的 y 坐标。
width - 新剪贴区矩形的宽度。
height - 新剪贴区矩形的高度。
从以下版本开始：
JDK1.1
另请参见：
clipRect(int, int, int, int), setClip(Shape), getClip()

getClip

public abstract Shape getClip()
获取当前剪贴区域。此方法返回用户剪贴区，用户剪贴区与设备边界和窗口可见性关联的剪贴区无关。如果以前未设置剪贴区，或者已使用 setClip(null) 清除了剪贴区，那么此方法返回 null。

返回：
表示当前剪贴区域的 Shape 对象；如果未设置剪贴区，则返回 null。
从以下版本开始：
JDK1.1
另请参见：
getClipBounds(),
clipRect(int, int, int, int),
setClip(int, int, int, int),
setClip(Shape)

setClip

public abstract void setClip(Shape clip)
将当前剪贴区域设置为任意的剪贴形状。并非所有实现 Shape 接口的对象都能用于设置剪贴区。只保证支持通过 getClip 方法和 Rectangle 对象获取的 Shape 对象。此方法设置用户剪贴区，用户剪贴区与设备边界和窗口可见性关联的剪贴区无关。

参数：
clip - 用来设置剪贴形状的 Shape
从以下版本开始：
JDK1.1
另请参见：
getClip(),
clipRect(int, int, int, int),
setClip(int, int, int, int)

copyArea

public abstract void copyArea(int x,
                              int y,
                              int width,
                              int height,
                              int dx,
                              int dy)
将组件的区域复制到由 dx 和 dy 指定的距离处。此方法从 x 和 y 指定的点向下和向右复制。要将组件的区域向左或向上复制，请指定负的 dx 或 dy 值。如果源矩形的一部分位于组件边界的外部，或者被另一个窗口或组件遮掩，那么 copyArea 将无法复制相关的像素。通过调用组件的 paint 方法可刷新被忽略的区域。

参数：
x - 源矩形的 x 坐标。
y - 源矩形的 y 坐标。
width - 源矩形的宽度。
height - 源矩形的高度。
dx - 复制像素的水平距离。
dy - 复制像素的垂直距离。

drawLine

public abstract void drawLine(int x1,
                              int y1,
                              int x2,
                              int y2)
在此图形上下文的坐标系中，使用当前颜色在点 (x1, y1) 和 (x2, y2) 之间画一条线。

参数：
x1 - 第一个点的 x 坐标。
y1 - 第一个点的 y 坐标。
x2 - 第二个点的 x 坐标。
y2 - 第二个点的 y 坐标。

fillRect

public abstract void fillRect(int x,
                              int y,
                              int width,
                              int height)
填充指定的矩形。该矩形左边缘和右边缘分别位于 x 和 x + width - 1。上边缘和下边缘分别位于 y 和 y + height - 1。得到的矩形覆盖 width 像素宽乘以 height 像素高的区域。使用图形上下文的当前颜色填充该矩形。

参数：
x - 要填充矩形的 x 坐标。
y - 要填充矩形的 y 坐标。
width - 要填充矩形的宽度。
height - 要填充矩形的高度。
另请参见：
clearRect(int, int, int, int), drawRect(int, int, int, int)

drawRect

public void drawRect(int x,
                     int y,
                     int width,
                     int height)
绘制指定矩形的边框。矩形的左边缘和右边缘分别位于 x 和 x + width。上边缘和下边缘分别位于 y 和 y + height。使用图形上下文的当前颜色绘制该矩形。

参数：
x - 要绘制矩形的 x 坐标。
y - 要绘制矩形的 y 坐标。
width - 要绘制矩形的宽度。
height - 要绘制矩形的高度。
另请参见：
fillRect(int, int, int, int), clearRect(int, int, int, int)

clearRect

public abstract void clearRect(int x,
                               int y,
                               int width,
                               int height)
通过使用当前绘图表面的背景色进行填充来清除指定的矩形。此操作不使用当前绘图模式。

从 Java 1.1 开始，离屏图像的背景色可能与系统相关。应用程序应该使用 setColor，然后使用 fillRect，以确保离屏图像被清除为指定颜色。

参数：
x - 要清除矩形的 x 坐标。
y - 要清除矩形的 y 坐标。
width - 要清除矩形的宽度。
height - 要清除矩形的高度。
另请参见：
fillRect(int, int, int, int),
drawRect(int, int, int, int),
setColor(java.awt.Color),
setPaintMode(),
setXORMode(java.awt.Color)

drawRoundRect

public abstract void drawRoundRect(int x,
                                   int y,
                                   int width,
                                   int height,
                                   int arcWidth,
                                   int arcHeight)
用此图形上下文的当前颜色绘制圆角矩形的边框。矩形的左边缘和右边缘分别位于 x 和 x + width。矩形的上边缘和下边缘分别位于 y 和 y + height。

参数：
x - 要绘制矩形的 x 坐标。
y - 要绘制矩形的 y 坐标。
width - 要绘制矩形的宽度。
height - 要绘制矩形的高度。
arcWidth - 4 个角弧度的水平直径。
arcHeight - 4 个角弧度的垂直直径。
另请参见：
fillRoundRect(int, int, int, int, int, int)

fillRoundRect

public abstract void fillRoundRect(int x,
                                   int y,
                                   int width,
                                   int height,
                                   int arcWidth,
                                   int arcHeight)
用当前颜色填充指定的圆角矩形。矩形的左边缘和右边缘分别位于 x 和 x + width - 1。矩形的上边缘和下边缘分别位于 y 和 y + height - 1。

参数：
x - 要填充矩形的 x 坐标。
y - 要填充矩形的 y 坐标。
width - 要填充矩形的宽度。
height - 要填充矩形的高度。
arcWidth - 4 个角弧度的水平直径。
arcHeight - 4 个角弧度的垂直直径。
另请参见：
drawRoundRect(int, int, int, int, int, int)

draw3DRect

public void draw3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
绘制指定矩形的 3-D 高亮显示边框。矩形的边是高亮显示的，以至于从左上角看呈斜面并加亮。

高亮显示效果所用的颜色根据当前颜色确定。得到的矩形覆盖 width + 1 像素宽乘以 height + 1 像素高的区域。

参数：
x - 要绘制矩形的 x 坐标。
y - 要绘制矩形的 y 坐标。
width - 要绘制矩形的宽度。
height - 要绘制矩形的高度。
raised - 一个用于确定矩形是凸出平面显示还是凹入平面显示的 boolean 值。
另请参见：
fill3DRect(int, int, int, int, boolean)

fill3DRect

public void fill3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
绘制一个用当前颜色填充的 3-D 高亮显示矩形。矩形的边是高亮显示的，以至于从左上角看呈斜面并加亮。高亮显示效果所用的颜色根据当前颜色确定。

参数：
x - 要填充矩形的 x 坐标。
y - 要填充矩形的 y 坐标。
width - 要填充矩形的宽度。
height - 要填充矩形的高度。
raised - 一个用于确定矩形是凸出平面显示还是凹入平面显示的 boolean 值。
另请参见：
draw3DRect(int, int, int, int, boolean)

drawOval

public abstract void drawOval(int x,
                              int y,
                              int width,
                              int height)
绘制椭圆的边框。得到一个圆或椭圆，它刚好能放入由 x、y、width 和 height 参数指定的矩形中。

椭圆覆盖区域的宽度为 width + 1 像素，高度为 height + 1 像素。

参数：
x - 要绘制椭圆的左上角的 x 坐标。
y - 要绘制椭圆的左上角的 y 坐标。
width - 要绘制椭圆的宽度。
height - 要绘制椭圆的高度。
另请参见：
fillOval(int, int, int, int)

fillOval

public abstract void fillOval(int x,
                              int y,
                              int width,
                              int height)
使用当前颜色填充外接指定矩形框的椭圆。

参数：
x - 要填充椭圆的左上角的 x 坐标。
y - 要填充椭圆的左上角的 y 坐标。
width - 要填充椭圆的宽度。
height - 要填充椭圆的高度。
另请参见：
drawOval(int, int, int, int)

drawArc

public abstract void drawArc(int x,
                             int y,
                             int width,
                             int height,
                             int startAngle,
                             int arcAngle)
绘制一个覆盖指定矩形的圆弧或椭圆弧边框。

得到的弧从 startAngle 开始跨越 arcAngle 度，并使用当前颜色。对角度的解释如下：0 度角位于 3 点钟位置。正值指示逆时针旋转，负值指示顺时针旋转。

弧的中心是矩形的中心，此矩形的原点为 (x, y)，大小由 width 和 height 参数指定。

得到的弧覆盖 width + 1 像素宽乘以 height + 1 像素高的区域。

角度是相对于外接矩形的非正方形区域指定的，45 度角始终落在从椭圆中心到外接矩形右上角的连线上。因此，如果外接矩形在一个轴上远远长于另一个轴，则弧段的起点和结束点的角度将沿边框长轴发生更大的偏斜。

参数：
x - 要绘制弧的左上角的 x 坐标。
y - 要绘制弧的左上角的 y 坐标。
width - 要绘制弧的宽度。
height - 要绘制弧的高度。
startAngle - 开始角度。
arcAngle - 相对于开始角度而言，弧跨越的角度。
另请参见：
fillArc(int, int, int, int, int, int)

fillArc

public abstract void fillArc(int x,
                             int y,
                             int width,
                             int height,
                             int startAngle,
                             int arcAngle)
填充覆盖指定矩形的圆弧或椭圆弧。

得到的弧从 startAngle 开始跨越 arcAngle 度。对角度的解释如下：0 度角位于 3 点钟位置。正值指示逆时针旋转，负值指示顺时针旋转。

弧的中心是矩形的中心，此矩形的原点为 (x, y)，大小由 width 和 height 参数指定。

得到的弧覆盖 width + 1 像素宽乘以 height + 1 像素高的区域。

角度是相对于外接矩形的非正方形区域指定的，45 度角始终落在从椭圆中心到外接矩形右上角的连线上。因此，如果外接矩形在一个轴上远远长于另一个轴，则弧段的起点和结束点的角度将沿边框长轴发生更大的偏斜。

参数：
x - 要填充弧的左上角的 x 坐标。
y - 要填充弧的左上角的 y 坐标。
width - 要填充弧的宽度。
height - 要填充弧的高度。
startAngle - 开始角度。
arcAngle - 相对于开始角度而言，弧跨越的角度。
另请参见：
drawArc(int, int, int, int, int, int)

drawPolyline

public abstract void drawPolyline(int[] xPoints,
                                  int[] yPoints,
                                  int nPoints)
绘制由 x 和 y 坐标数组定义的一系列连接线。每对 (x, y) 坐标定义一个点。如果第一个点和最后一个点不同，则图形不是闭合的。

参数：
xPoints - x 点数组
yPoints - y 点数组
nPoints - 点的总数
从以下版本开始：
JDK1.1
另请参见：
drawPolygon(int[], int[], int)

drawPolygon

public abstract void drawPolygon(int[] xPoints,
                                 int[] yPoints,
                                 int nPoints)
绘制一个由 x 和 y 坐标数组定义的闭合多边形。每对 (x, y) 坐标定义一个点。

此方法绘制由 nPoint 个线段定义的多边形，其中前 nPoint - 1 个线段是 1 ≤ i ≤ nPoints 时从 (xPoints[i - 1], yPoints[i - 1]) 到 (xPoints[i], yPoints[i]) 的线段。如果最后一个点和第一个点不同，则图形将在这两点间绘制一条线段来自动闭合。

参数：
xPoints - x 坐标数组。
yPoints - y 坐标数组。
nPoints - 点的总数。
另请参见：
fillPolygon(int[], int[], int), drawPolyline(int[], int[], int)

drawPolygon

public void drawPolygon(Polygon p)
绘制由指定的 Polygon 对象定义的多边形边框。

参数：
p - 要绘制的多边形。
另请参见：
fillPolygon(int[], int[], int), drawPolyline(int[], int[], int)

fillPolygon

public abstract void fillPolygon(int[] xPoints,
                                 int[] yPoints,
                                 int nPoints)
填充由 x 和 y 坐标数组定义的闭合多边形。

此方法绘制由 nPoint 个线段定义的多边形，其中前 nPoint - 1 个线段是 1 ≤ i ≤ 时从 (xPoints[i - 1], yPoints[i - 1]) 到 (xPoints[i], yPoints[i]) 的线段。如果最后一个点和第一个点不同，则图形会通过在这两点间绘制一条线段来自动闭合。

多边形内部的区域使用奇偶填充规则定义，此规则也称为交替填充规则。

参数：
xPoints - x 坐标数组。
yPoints - y 坐标数组。
nPoints - 点的总数。
另请参见：
drawPolygon(int[], int[], int)

fillPolygon

public void fillPolygon(Polygon p)
用图形上下文的当前颜色填充指定 Polygon 对象定义的多边形。

多边形内部的区域使用奇偶填充规则定义，此规则也称为交替填充规则。

参数：
p - 要填充的多边形。
另请参见：
drawPolygon(int[], int[], int)

drawString

public abstract void drawString(String str,
                                int x,
                                int y)
使用此图形上下文的当前字体和颜色绘制由指定 string 给定的文本。最左侧字符的基线位于此图形上下文坐标系的 (x, y) 位置处。

参数：
str - 要绘制的 string。
x - x 坐标。
y - y 坐标。
抛出：
NullPointerException - 如果 str 为 null。
另请参见：
drawBytes(byte[], int, int, int, int), drawChars(char[], int, int, int, int)

drawString

public abstract void drawString(AttributedCharacterIterator iterator,
                                int x,
                                int y)
依据 TextAttribute 类的规范应用指定迭代器的属性，呈现迭代器的文本。

最左侧字符的基线位于此图形上下文坐标系的 (x, y) 位置处。

参数：
iterator - 要绘制其文本的迭代器
x - x 坐标。
y - y 坐标。
抛出：
NullPointerException - 如果 iterator 为 null。
另请参见：
drawBytes(byte[], int, int, int, int), drawChars(char[], int, int, int, int)

drawChars

public void drawChars(char[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
使用此图形上下文的当前字体和颜色绘制由指定字符数组给定的文本。首字符的基线位于此图形上下文坐标系的 (x, y) 位置处。

参数：
data - 要绘制的字符数组
offset - 数据的初始偏移量
length - 要绘制的字符数
x - 文本基线的 x 坐标
y - 文本基线的 y 坐标
抛出：
NullPointerException - 如果 data 为 null。
IndexOutOfBoundsException - 如果 offset 或 length 小于零，或者 offset+length 大于 data 数组的长度。
另请参见：
drawBytes(byte[], int, int, int, int), drawString(java.lang.String, int, int)

drawBytes

public void drawBytes(byte[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
使用此图形上下文的当前字体和颜色绘制由指定 byte 数组给定的文本。首字符的基线位于此图形上下文坐标系的 (x, y) 位置处。

不建议使用此方法，因为每个字节都被解释为 0 到 255 范围内的 Unicode 代码点，因此在该范围内只能用于绘制拉丁字符。

参数：
data - 要绘制的数据
offset - 数据的起始偏移量
length - 要绘制的字节数
x - 文本基线的 x 坐标
y - 文本基线的 y 坐标
抛出：
NullPointerException - 如果 data 为 null。
IndexOutOfBoundsException - 如果 offset 或 length 小于零，或者 offset+length 大于 data 数组的长度。
另请参见：
drawChars(char[], int, int, int, int), drawString(java.lang.String, int, int)

drawImage

public abstract boolean drawImage(Image img,
                                  int x,
                                  int y,
                                  ImageObserver observer)
绘制指定图像中当前可用的图像。图像的左上角位于该图形上下文坐标空间的 (x, y)。图像中的透明像素不影响该处已存在的像素。

此方法在任何情况下都立刻返回，甚至在图像尚未完整加载，并且还没有针对当前输出设备完成抖动和转换的情况下也是如此。

如果图像已经完整加载，并且其像素不再发生更改，则 drawImage 返回 true。否则，drawImage 返回 false，并且随着更多的图像可用或者到了绘制动画另一帧的时候，加载图像的进程将通知指定的图像观察者。

参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
observer - 转换了更多图像时要通知的对象。
返回：
如果图像像素仍在更改，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public abstract boolean drawImage(Image img,
                                  int x,
                                  int y,
                                  int width,
                                  int height,
                                  ImageObserver observer)
绘制指定图像中已缩放到适合指定矩形内部的图像。

图像绘制在此图形上下文坐标空间的指定矩形内部，如果需要，则进行缩放。透明像素不影响该处已存在的像素。

此方法在任何情况下都立刻返回，甚至在整个图像没有针对当前输出设备完成缩放、抖动或转换的情况下也是如此。如果当前输出表示形式尚未完成，则 drawImage 返回 false。随着更多的图像可用，加载图像的进程将通过调用图像观察者的 imageUpdate 方法来通知它。

缩放的图像不一定立刻可用，因为已经针对此输出设备构造了非缩放的图像。每种大小的图像可以被分别缓存，并由各自图像生产序列中的原始数据生成。

参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
width - 矩形的宽度。
height - 矩形的高度。
observer - 转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public abstract boolean drawImage(Image img,
                                  int x,
                                  int y,
                                  Color bgcolor,
                                  ImageObserver observer)
绘制指定图像中当前可用的图像。图像的左上角位于此图形上下文坐标空间的 (x, y)。以指定的背景色绘制透明像素。

此操作等同于用给定颜色填充指定图像宽度和高度的矩形，然后在其上绘制图像，但此操作效率更高。

此方法在任何情况下都立刻返回，甚至在整个图像尚未加载，并且还没有针对当前输出设备完成抖动和转换的情况下也是如此。

如果图像已经完全加载，并且其像素不再发生改变，则 drawImage 返回 true。否则 drawImage 返回 false，并且随着更多的图像可用或者到了绘制动画另一帧的时候，加载图像的进程将通知指定的图像观察者。

参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
bgcolor - 在图像非透明部分下绘制的背景色。
observer - 当转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public abstract boolean drawImage(Image img,
                                  int x,
                                  int y,
                                  int width,
                                  int height,
                                  Color bgcolor,
                                  ImageObserver observer)
绘制指定图像中已缩放到适合指定矩形内部的图像。

图像绘制在此图形上下文坐标空间的指定矩形内部，如果需要，则进行缩放。以指定的背景色绘制透明像素。此操作等同于用给定颜色填充指定图像宽度和高度的矩形，然后在其上绘制图像，但此操作效率更高。

此方法在任何情况下都立刻返回，甚至在整个图像没有针对当前输出设备完成缩放、抖动或转换的情况下也是如此。如果当前的输出表示形式尚未完成，则 drawImage 返回 false。随着更多的图像可用，加载图像的进程将通知指定的图像观察者。

缩放的图像不一定立刻是可用的，因为已经为此输出设备构造了非缩放的图像。每种大小的图像可以被分别缓存，并由各自图像生产序列中的原始数据生成。

参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
width - 矩形的宽度。
height - 矩形的高度。
bgcolor - 在图像非透明部分下绘制的背景色。
observer - 当转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public abstract boolean drawImage(Image img,
                                  int dx1,
                                  int dy1,
                                  int dx2,
                                  int dy2,
                                  int sx1,
                                  int sy1,
                                  int sx2,
                                  int sy2,
                                  ImageObserver observer)
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。透明像素不影响该处已存在的像素。

此方法在任何情况下都立刻返回，甚至在要绘制的图像区域没有针对当前输出设备完成缩放、抖动或转换的情况下也是如此。如果当前的输出表示形式尚未完成，则 drawImage 返回 false。随着更多的图像可用，加载图像的进程将通知指定的图像观察者。

此方法总是用非缩放的图像来呈现缩放的矩形，并且动态地执行所需的缩放。此操作不使用缓存的缩放图像。执行图像从源到目标的缩放：源矩形的第一个坐标被映射到目标矩形的第一个坐标，第二个源坐标被映射到第二个目标坐标。按需要缩放和翻转子图像以保持这些映射关系。

参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
dx1 - 目标矩形第一个角的 x 坐标。
dy1 - 目标矩形第一个角的 y 坐标。
dx2 - 目标矩形第二个角的 x 坐标。
dy2 - 目标矩形第二个角的 y 坐标。
sx1 - 源矩形第一个角的 x 坐标。
sy1 - 源矩形第一个角的 y 坐标。
sx2 - 源矩形第二个角的 x 坐标。
sy2 - 源矩形第二个角的 y 坐标。
observer - 当缩放并转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
从以下版本开始：
JDK1.1
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public abstract boolean drawImage(Image img,
                                  int dx1,
                                  int dy1,
                                  int dx2,
                                  int dy2,
                                  int sx1,
                                  int sy1,
                                  int sx2,
                                  int sy2,
                                  Color bgcolor,
                                  ImageObserver observer)
绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。

以指定的背景色绘制透明像素。此操作等同于用给定颜色填充指定图像宽度和高度的矩形，然后在其上绘制图像，但此操作效率更高。

此方法在任何情况下都立刻返回，甚至在要绘制的图像区域没有针对当前输出设备完成缩放、抖动或转换的情况下也是如此。如果当前的输出表示形式尚未完成，则 drawImage 返回 false。随着更多的图像可用，加载图像的进程将通知指定的图像观察者。

此方法总是用非缩放的图像来呈现缩放的矩形，并且动态地执行所需的缩放。此操作不使用缓存的缩放图像。执行图像从源到目标的缩放：源矩形的第一个坐标被映射到目标矩形的第一个坐标，第二个源坐标被映射到第二个目标坐标。按需要缩放和翻转子图像以保持这些映射关系。

参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
dx1 - 目标矩形第一个角的 x 坐标。
dy1 - 目标矩形第一个角的 y 坐标。
dx2 - 目标矩形第二个角的 x 坐标。
dy2 - 目标矩形第二个角的 y 坐标。
sx1 - 源矩形第一个角的 x 坐标。
sy1 - 源矩形第一个角的 y 坐标。
sx2 - 源矩形第二个角的 x 坐标。
sy2 - 源矩形第二个角的 y 坐标。
bgcolor - 在图像非透明部分下绘制的背景色。
observer - 当缩放并转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
从以下版本开始：
JDK1.1
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

dispose

public abstract void dispose()
释放此图形的上下文以及它使用的所有系统资源。调用 dispose 之后，就不能再使用 Graphics 对象。

Java 程序运行时，可以在一个短时间帧内创建大量的 Graphics 对象。尽管垃圾回收器的终止进程也能够进行相同的系统资源释放，但是最好通过调用此方法来手工释放相关资源，而不是依靠终止进程，因为终止进程需要很长时间才能结束运行。

作为组件 paint 和 update 方法的参数提供的 Graphics 对象，在这些方法返回时将被系统自动释放。为了提高效率，仅当所使用的 Graphics 对象是由组件或另一个 Graphics 对象直接创建时，程序员才应在使用完此 Graphics 后调用 dispose。

另请参见：
finalize(),
Component.paint(java.awt.Graphics),
Component.update(java.awt.Graphics),
Component.getGraphics(),
create()

finalize

public void finalize()
一旦不再引用此图形上下文就释放它。

覆盖：
类 Object 中的 finalize
另请参见：
dispose()

toString

public String toString()
返回表示此 Graphics 对象值的 String 对象。

覆盖：
类 Object 中的 toString
返回：
此图形上下文的字符串表示形式。

getClipRect

@Deprecated
public Rectangle getClipRect()
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。

返回当前剪贴区域的边界矩形。

返回：
当前剪贴区域的边界矩形；如果未设置剪贴区，则返回 null。

hitClip

public boolean hitClip(int x,
                       int y,
                       int width,
                       int height)
如果指定的矩形区域与当前的剪贴区域相交，则返回 true。指定矩形区域的坐标位于用户坐标空间中，并且相对于此图形上下文的坐标系原点。此方法可以使用快速计算出结果的算法，但此算法有时甚至在指定矩形区域与剪贴区域不相交时也返回 true。因此，所采用的指定算法可能牺牲准确性来换取速度，但是除非能够确保指定的矩形区域与当前剪贴区不相交，否则它不会返回 false。此方法使用的剪贴区域可以表示通过此图形上下文的 clip 方法指定的用户剪贴区的交集，也可以表示与设备或图像边界和窗口可见性关联的剪贴区。

参数：
x - 要与剪贴区测试的矩形的 x 坐标
y - 要与剪贴区测试的矩形的 y 坐标
width - 要与剪贴区测试的矩形的宽度
height - 要与剪贴区测试的矩形的高度
返回：
如果指定的矩形与当前剪贴区边界相交，则返回 true；否则返回 false。

getClipBounds

public Rectangle getClipBounds(Rectangle r)
返回当前剪贴区域的边界矩形。该矩形内的坐标相对于此图形上下文的坐标系原点。此方法与 getClipBounds 不同，后者使用现有的矩形而不是分配一个新矩形。此方法引用用户剪贴区，用户剪贴区与设备边界和窗口可见性关联的剪贴区无关。如果以前未设置剪贴区，或者已使用 setClip(null) 清除了剪贴区，则此方法返回指定的 Rectangle。

参数：
r - 要将当前剪贴区域复制到的矩形。此矩形的所有当前值均被覆盖。
返回：
当前剪贴区域的边界矩形。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Graphics2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Graphics2D

java.lang.Object
    继承者  java.awt.Graphics
        继承者  java.awt.Graphics2D

public abstract class Graphics2D
extends Graphics

此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。它是用于在 Java(tm) 平台上呈现二维形状、文本和图像的基础类。

坐标空间

所有传递到 Graphics2D 对象的坐标都在一个与设备无关并且名为用户空间的坐标系中指定，用户空间由应用程序使用。Graphics2D 对象包含一个 AffineTransform 对象作为其呈现状态的一部分，后者定义了如何将坐标从用户空间转换到设备空间中与设备有关的坐标。

设备空间中的坐标通常是指单个设备像素，并根据这些像素之间无限小的间距对齐。某些 Graphics2D 对象可用于捕获对存储器的呈现操作并存入图形元文件，以后可在未知物理分辨率的具体设备上重放。由于在捕获呈现操作时分辨率可能未知，所以 Graphics2D Transform 的设置可将用户坐标转换为虚拟设备空间，该设备空间与目标设备的预期分辨率接近。如果估计值不正确，则在重放时可能需要进一步转换。

某些由呈现属性对象执行的操作发生在设备空间中，但所有 Graphics2D 方法都采用用户空间坐标。

每个 Graphics2D 对象都与一个定义呈现位置的目标关联。GraphicsConfiguration 对象定义呈现目标的特征，如像素格式和分辨率。在 Graphics2D 对象的整个生命周期中都使用相同的呈现目标。

创建 Graphics2D 对象时，GraphicsConfiguration 将为 Graphics2D 的目标(Component 或 Image）指定默认转换，此默认转换将用户空间坐标系映射到屏幕和打印机设备坐标，使原点映射到设备目标区域的左上角，并将 X 坐标轴向右方延伸，将 Y 坐标轴向下方延伸。对于接近 72 dpi 的设备（例如屏幕设备），默认转换的缩放比例设置为 1:1。对于高分辨率设备（例如打印机），默认转换的缩放比例设置为每平方英寸大约 72 个用户空间坐标。对于图像缓冲区，默认转换为 Identity 转换。

呈现过程

呈现过程可以分为四个阶段，这四个阶段由 Graphics2D 呈现属性控制。呈现器可以优化当中的许多步骤：可以缓存结果以用于未来调用；可以将多个虚拟步骤合成一个操作；可以将多种属性识别为共用的简单情况（可以通过修改操作的其他部分来消除各种属性间的差别）。

呈现过程中的步骤有：

  1. 确定呈现内容。
  2. 将呈现操作限制在当前 Clip。 Clip 由用户空间中的 Shape 指定，由使用 Graphics 和 Graphics2D 中各种 clip 操作方法的程序控制。此用户剪贴区 由当前 Transform 转换到设备空间中，并与设备剪贴区 合并，后者是通过窗口可见性和设备范围定义的。用户剪贴区和设备剪贴区的组合定义复合剪贴区，复合剪贴区确定最终的剪贴区域。呈现系统不能修改用户剪贴区来反映得到的复合剪贴区。
  3. 确定呈现的颜色。
  4. 使用 Graphics2D 上下文中当前的 Composite 属性将颜色应用于目标绘图面。

三种类型的呈现操作，以及各自特殊呈现过程的细节如下：
  1. Shape 操作
    1. 如果该操作为 draw(Shape) 操作，则 Graphics2D 上下文中当前 Stroke 属性上的 createStrokedShape 方法将用于构造包含指定 Shape 轮廓的新 Shape 对象。
    2. 使用 Graphics2D 上下文中的当前 Transform 将 Shape 从用户空间转换到设备空间。
    3. Shape 的轮廓是通过使用 Shape 的 getPathIterator 方法提取的，该方法返回一个沿着 Shape 边界迭代得到的 PathIterator 对象。
    4. 如果 Graphics2D 对象无法处理 PathIterator 对象返回的曲线段，则可以调用 Shape 的 getPathIterator 替代方法，该方法可使 Shape 变得平滑。
    5. 对于 PaintContext，需要 Graphics2D 上下文中的当前 Paint，它指定了在设备空间中呈现的颜色。
  2. 文本操作
    1. 以下步骤用于确定呈现指定 String 所需的字形集：
      1. 如果参数是 String，则要求 Graphics2D 上下文中的当前 Font 将 String 中的 Unicode 字符转换为一个字形集，以表现 Font 实现的基本布局和成形算法。
      2. 如果参数是 AttributedCharacterIterator，则要求迭代器使用其内嵌的字体属性将其自身转换为 TextLayout。TextLayout 实现更为复杂的字形布局算法，用于为不同书写方向的多种字体自动执行 Unicode 双方向布局调整。
      3. 如果参数是 GlyphVector，则 GlyphVector 对象已经包含了特定于字体的合适字形代码和每个字形位置的显式坐标。
    2. 查询当前的 Font 以获取指定字形的轮廓。这些轮廓被视为用户空间中相对于步骤 1 中确定的每个字形位置的形状。
    3. 字符轮廓按上面 Shape 操作下指示的方式填充。
    4. 查询当前 PaintContext 以获取 Paint，Paint 指定了设备空间中呈现的颜色。
  3. Image 操作
    1. 感兴趣区域由源 Image 的边界框定义。此边界框在图像空间中指定，该空间即 Image 对象的本地坐标系。
    2. 如果 AffineTransform 被传递到 drawImage(Image, AffineTransform, ImageObserver)，则使用 AffineTransform 将边界框从图像空间转换到用户空间。如果未提供 AffineTransform，则认为边界框已存在于用户空间中。
    3. 使用当前 Transform 将 Image 的边界框从用户空间转换到设备空间。注意，转换边界框的结果不一定会得到设备空间中的矩形区域。
    4. Image 对象确定要呈现的颜色，并根据当前 Transform 和可选图像转换所指定的源到目标坐标映射关系进行采样。

默认呈现属性

Graphics2D 呈现属性的默认值有：
Paint
Component 的颜色。
Font
Component 的 Font。
Stroke
线宽为 1 的方形画笔，没有虚线、斜角线段接合和方形端点。
Transform
用于 Component 的 GraphicsConfiguration 的 getDefaultTransform。
Composite
AlphaComposite.SRC_OVER 规则。
Clip
不呈现 Clip，输出局限于 Component。

呈现兼容性问题

JDK(tm) 1.1 呈现模型是基于像素化的模型，该模型的坐标无限细分，且位于像素之间。使用一个一像素宽的画笔执行绘制操作，填充路径锚点向下和向右的像素。JDK 1.1 呈现模型与大多数现有平台呈现类的功能一致，需要将整数坐标解析为离散的画笔，使其完全落在指定的像素成员上。

Java 2D(tm)（Java(tm) 2 平台）API 支持抗锯齿呈现器。一像素宽的画笔不需要完全落在像素 N 或像素 N+1 上。该画笔可以部分落在这两个像素上。不需要为宽画笔选择一个偏离方向，因为沿画笔遍历边缘发生的混合可让画笔的子像素位置对用户可见。另一方面，如果通过将 KEY_ANTIALIASING 提示键设置为 VALUE_ANTIALIAS_OFF 提示值而关闭了抗锯齿，则当画笔跨在像素边界上时，呈现器可能需要应用偏离来确定要修改哪个像素，例如在设备空间中，当画笔沿着整数坐标绘制时。虽然抗锯齿呈现器的功能使之不再需要呈现模型为画笔指定一个偏离，但对于在屏幕上绘制一像素宽的水平线和垂直线这种常见情形，还是需要抗锯齿和非抗锯齿呈现器执行类似的操作。为了确保通过将 KEY_ANTIALIASING 提示键设置为 VALUE_ANTIALIAS_ON 而打开的抗锯齿不会导致这些线突然变为此宽度的二倍或一半不透明，需要让该模型为这些线指定一个路径，使它们完全覆盖特定的像素集，以帮助提高其平滑性。

Java 2D API 维持与 JDK 1.1 呈现行为的兼容性，遗留操作和现有呈现器行为在 Java 2D API 下没有改变。定义了映射到常规 draw 和 fill 方法的遗留方法，它明确指示 Graphics2D 根据 Stroke 和 Transform 属性以及呈现提示的设置扩展 Graphics 的方式。在默认属性设置下该定义的执行方式完全相同。例如，默认 Stroke 是一个宽度为 1 且没有虚线的 BasicStroke，屏幕绘制的默认 Transform 是 Identity 转换。

下面两个规则提供了可预见的呈现行为（无论是否使用了重叠还是抗锯齿）。

  • 将设备坐标定义为在设备像素之间，这避免了重叠呈现和抗锯齿呈现的结果不一致。如果将坐标定义为在像素的中心，则由矩形等形状覆盖的某些像素仅是半覆盖。通过重叠的呈现，半覆盖的像素可能呈现在形状内部，也可能呈现在形状外部。使用抗锯齿呈现，整个形状边缘上的像素都是半覆盖的。另一方面，由于坐标被定义在像素之间，所以无论是否使用抗锯齿进行呈现，像矩形这样的形状将不会有半覆盖像素。
  • 使用 BasicStroke 对象勾画的线和路径可以“标准化”，从而在不同的可绘制点上定位时，无论使用重叠还是抗锯齿呈现进行的绘制都能提供一致的轮廓呈现。此标准化过程通过 KEY_STROKE_CONTROL 提示控制。虽然未指定准确的标准化算法，但此标准化的目标是为了确保可以使用一致的可视外观呈现线条，而不考虑它们在像素网格上的位置；另一个目的是促进以抗锯齿模式呈现更连续的水平和垂直线，从而与没有抗锯齿的线更为相似。典型的标准化步骤可以将抗锯齿线端点提升到像素中心，以减少混合量；也可以调整无抗锯齿线的子像素位置，以便浮点线宽度舍入为近似相等的偶数或奇数像素计数。此过程可以将端点向上移动半个像素（通常沿两个坐标轴的正无穷大方向移动），以得到一致的结果。

在默认属性设置下，以下定义的常规遗留方法与以前指定行为的执行方式完全相同：

  • 对于 fill 操作，包括 fillRect、fillRoundRect、fillOval、fillArc、fillPolygon 和 clearRect，现在可以使用所需的 Shape 调用 fill。例如，在填充矩形时可调用：
    fill(new Rectangle(x, y, w, h));

  • 类似地，对于绘制操作，包括 drawLine、drawRect、drawRoundRect、drawOval、drawArc、drawPolyline 和 drawPolygon，现在可以使用所需的 Shape 调用 draw。例如，在绘制矩形时可调用：
    draw(new Rectangle(x, y, w, h));

  • draw3DRect 和 fill3DRect 方法是根据 Graphics 类中的 drawLine 和 fillRect 方法实现的，根据 Graphics2D 上下文中的当前 Stroke 和 Paint 对象可以预知其行为。此类重写了那些独占地使用当前 Color 的实现，重写当前 Paint 以及使用 fillRect 的 Paint，以描述与以前存在的方法完全相同的行为，而不考虑当前 Stroke 的设置。
Graphics 类仅定义了 setColor 方法来控制要绘制的颜色。由于 Java 2D API 扩展了 Color 对象来实现新的 Paint 接口，因此现有的 setColor 方法现在是将当前 Paint 属性设置为 Color 对象的便捷方法。setColor(c) 等同于 setPaint(c)。

Graphics 类定义了两种方法来控制如何将颜色应用到目标。

  1. setPaintMode 方法实现为设置默认 Composite 的便捷方法，它等同于 setComposite(new AlphaComposite.SrcOver)。
  2. setXORMode(Color xorcolor) 方法实现为设置特殊 Composite 对象的便捷方法，它忽略源颜色的 Alpha 分量，并将目标颜色设置为以下值：
    dstpixel = (PixelOf(srccolor) ^ PixelOf(xorcolor) ^ dstpixel);

另请参见：
RenderingHints

构造方法摘要
protected Graphics2D()
构建一个新的 Graphics2D 对象。
方法摘要
abstract void | addRenderingHints(Map<?,?> hints) 为呈现算法设置任意数量的首选项值。
abstract void | clip(Shape s) 将当前 Clip 与指定 Shape 的内部区域相交，并将 Clip 设置为所得的交集。
abstract void | draw(Shape s) 使用当前 Graphics2D 上下文的设置勾画 Shape 的轮廓。
void | draw3DRect(int x, int y, int width, int height, boolean raised) 绘制指定矩形的 3-D 高亮显示边框。
abstract void | drawGlyphVector(GlyphVector g, float x, float y) 使用 Graphics2D 上下文的呈现属性，呈现指定 GlyphVector 的文本。
abstract void | drawImage(BufferedImage img, BufferedImageOp op, int x, int y) 呈现使用 BufferedImageOp 过滤的 BufferedImage。
abstract boolean | drawImage(Image img, AffineTransform xform, ImageObserver obs) 呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
abstract void | drawRenderableImage(RenderableImage img, AffineTransform xform) 呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。
abstract void | drawRenderedImage(RenderedImage img, AffineTransform xform) 呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。
abstract void | drawString(AttributedCharacterIterator iterator, float x, float y) 依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
abstract void | drawString(AttributedCharacterIterator iterator, int x, int y) 依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
abstract void | drawString(String str, float x, float y) 使用 Graphics2D 上下文中当前文本属性状态呈现由指定 String 指定的文本。
abstract void | drawString(String str, int x, int y) 使用 Graphics2D 上下文中的当前文本属性状态呈现指定的 String 的文本。
abstract void | fill(Shape s) 使用 Graphics2D 上下文的设置，填充 Shape 的内部区域。
void | fill3DRect(int x, int y, int width, int height, boolean raised) 绘制一个用当前颜色填充的 3-D 高亮显示矩形。
abstract Color | getBackground() 返回用于清除区域的背景色。
abstract Composite | getComposite() 返回 Graphics2D 上下文中的当前 Composite
abstract GraphicsConfiguration | getDeviceConfiguration() 返回与此 Graphics2D 关联的设备配置。
abstract FontRenderContext | getFontRenderContext() 获取此 Graphics2D 上下文中 Font 的呈现上下文。
abstract Paint | getPaint() 返回 Graphics2D 上下文中的当前 Paint
abstract Object | getRenderingHint(RenderingHints.Key hintKey) 返回呈现算法的单个首选项的值。
abstract RenderingHints | getRenderingHints() 获取呈现算法的首选项。
abstract Stroke | getStroke() 返回 Graphics2D 上下文中的当前 Stroke
abstract AffineTransform | getTransform() 返回 Graphics2D 上下文中当前 Transform 的副本。
abstract boolean | hit(Rectangle rect, Shape s, boolean onStroke) 检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。
abstract void | rotate(double theta) 将当前的 Graphics2D Transform 与旋转转换连接。
abstract void | rotate(double theta, double x, double y) 将当前的 Graphics2D Transform 与平移后的旋转转换连接。
abstract void | scale(double sx, double sy) 将当前 Graphics2D Transform 与缩放转换连接。
abstract void | setBackground(Color color) 设置 Graphics2D 上下文的背景色。
abstract void | setComposite(Composite comp) 为 Graphics2D 上下文设置 Composite。
abstract void | setPaint(Paint paint) 为 Graphics2D 上下文设置 Paint 属性。
abstract void | setRenderingHint(RenderingHints.Key hintKey, Object hintValue) 为呈现算法设置单个首选项的值。
abstract void | setRenderingHints(Map<?,?> hints) 使用指定的 hints 替换用于所有呈现算法首选项的值。
abstract void | setStroke(Stroke s) 为 Graphics2D 上下文设置 Stroke
abstract void | setTransform(AffineTransform Tx) 重写 Graphics2D 上下文中的 Transform。
abstract void | shear(double shx, double shy) 将当前 Graphics2D Transform 与剪裁转换连接。
abstract void | transform(AffineTransform Tx) 根据“最后指定首先应用”规则，使用此 Graphics2D 中的 Transform 组合 AffineTransform 对象。
abstract void | translate(double tx, double ty) 将当前 Graphics2D Transform 与平移转换连接。
abstract void | translate(int x, int y) 将 Graphics2D 上下文的原点平移到当前坐标系中的点 (x, y)。
从类 java.awt.Graphics 继承的方法
clearRect, clipRect, copyArea, create, create, dispose, drawArc, drawBytes, drawChars, drawImage, drawImage, drawImage, drawImage, drawImage, drawImage, drawLine, drawOval, drawPolygon, drawPolygon, drawPolyline, drawRect, drawRoundRect, fillArc, fillOval, fillPolygon, fillPolygon, fillRect, fillRoundRect, finalize, getClip, getClipBounds, getClipBounds, getClipRect, getColor, getFont, getFontMetrics, getFontMetrics, hitClip, setClip, setClip, setColor, setFont, setPaintMode, setXORMode, toString
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Graphics2D

protected Graphics2D()
构建一个新的 Graphics2D 对象。由于 Graphics2D 是一个抽象类，而且它必须由不同输出设备的子类定制，所以无法直接创建 Graphics2D 对象。相反，Graphics2D 对象必须从另一个 Graphics2D 对象获得、由某个 Component 创建，或者从 BufferedImage 之类的图像对象获得。

另请参见：
Component.getGraphics(), Graphics.create()
方法详细信息

draw3DRect

public void draw3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
绘制指定矩形的 3-D 高亮显示边框。矩形的边是高亮显示的，以至于从左上角看呈斜面并加亮。

高亮显示效果所用的颜色根据当前颜色确定。得到的矩形覆盖的区域为 width + 1 像素宽乘以 height + 1 像素高。此方法独占使用当前 Color，并忽略当前 Paint

覆盖：
类 Graphics 中的 draw3DRect
参数：
x - 要绘制矩形的 x 坐标。
y - 要绘制矩形的 y 坐标。
width - 要绘制矩形的宽度。
height - 要绘制矩形的高度。
raised - 一个用于确定矩形是凸出平面显示还是凹入平面显示的 boolean 值。
另请参见：
Graphics.fill3DRect(int, int, int, int, boolean)

fill3DRect

public void fill3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
绘制一个用当前颜色填充的 3-D 高亮显示矩形。矩形的边是高亮显示的，以至于从左上角看呈斜面并加亮。高亮显示效果和填充所用的颜色根据当前 Color 确定。此方法独占使用当前 Color，并忽略当前 Paint

覆盖：
类 Graphics 中的 fill3DRect
参数：
x - 要填充矩形的 x 坐标。
y - 要填充矩形的 y 坐标。
width - 要填充矩形的宽度。
height - 要填充矩形的高度。
raised - 一个用于确定矩形是凸出平面显示还是凹入平面显示的 boolean 值。
另请参见：
Graphics.draw3DRect(int, int, int, int, boolean)

draw

public abstract void draw(Shape s)
使用当前 Graphics2D 上下文的设置勾画 Shape 的轮廓。应用的呈现属性包括 Clip、Transform、Paint、Composite 和 Stroke 属性。

参数：
s - 要呈现的 Shape
另请参见：
setStroke(java.awt.Stroke),
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
transform(java.awt.geom.AffineTransform),
setTransform(java.awt.geom.AffineTransform),
clip(java.awt.Shape),
Graphics.setClip(int, int, int, int),
setComposite(java.awt.Composite)

drawImage

public abstract boolean drawImage(Image img,
                                  AffineTransform xform,
                                  ImageObserver obs)
呈现一个图像，在绘制前进行从图像空间到用户空间的转换。从用户空间到设备空间的转换使用 Graphics2D 中的当前 Transform 完成。在应用 Graphics2D 上下文中的 transform 属性之前，指定的转换被应用到图像。应用的呈现属性包括 Clip、Transform 和 Composite 属性。注意，如果指定的转换不可逆，则不会完成呈现。

参数：
img - 要呈现的指定图像。如果 img 为 null，则此方法不执行任何动作。
xform - 从图像空间到用户空间的转换
obs - 转换了多个 Image 时要通知的 ImageObserver
返回：
如果 Image 被完全加载并完全呈现，则为 true，否则为 null；如果仍在加载 Image，则为 false
另请参见：
transform(java.awt.geom.AffineTransform),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
Graphics.setClip(int, int, int, int)

drawImage

public abstract void drawImage(BufferedImage img,
                               BufferedImageOp op,
                               int x,
                               int y)
呈现使用 BufferedImageOp 过滤的 BufferedImage。 应用的呈现属性包括 Clip、Transform 和 Composite 属性。这等价于：
 img1 = op.filter(img, null);
 drawImage(img1, new AffineTransform(1f,0f,0f,1f,x,y), null);

参数：
op - 在呈现之前要应用到图像的过滤器
img - 要呈现的指定 BufferedImage。 如果 img 为 null，则此方法不执行任何动作。
x - 用户空间中呈现该图像左上角位置的 x 坐标
y - 用户空间中呈现该图像左上角位置的 y 坐标
另请参见：
transform(java.awt.geom.AffineTransform),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
Graphics.setClip(int, int, int, int)

drawRenderedImage

public abstract void drawRenderedImage(RenderedImage img,
                                       AffineTransform xform)
呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。从用户空间到设备空间的转换使用 Graphics2D 中的当前 Transform 完成。在应用 Graphics2D 上下文中的 transform 属性之前，指定的转换被应用到图像。应用的呈现属性包括 Clip、Transform 和 Composite 属性。注意，如果指定的转换不可逆，则不会完成呈现。

参数：
img - 要呈现的图像。如果 img 为 null，则此方法不执行任何操作。
xform - 从图像空间到用户空间的转换
另请参见：
transform(java.awt.geom.AffineTransform),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
Graphics.setClip(int, int, int, int)

drawRenderableImage

public abstract void drawRenderableImage(RenderableImage img,
                                         AffineTransform xform)
呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。从用户空间到设备空间的转换使用 Graphics2D 中当前的 Transform 完成。在应用 Graphics2D 上下文中的 transform 属性之前，指定的转换被应用到图像。应用的呈现属性包括 Clip、Transform 和 Composite 属性。注意，如果指定的转换不可逆，则不会完成呈现。

呈现 RenderableImage 时，可以使用在 Graphics2D 对象上设置的呈现提示。如果由特定 RenderableImage 识别的特定提示需要显式控制，或者需要知道使用哪一个提示，则应直接从 RenderableImage 获取 RenderedImage，并使用 drawRenderedImage 呈现它。

参数：
img - 要呈现的图像。如果 img 为 null，则此方法不执行任何操作。
xform - 从图像空间到用户空间的转换
另请参见：
transform(java.awt.geom.AffineTransform),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
Graphics.setClip(int, int, int, int),
drawRenderedImage(java.awt.image.RenderedImage, java.awt.geom.AffineTransform)

drawString

public abstract void drawString(String str,
                                int x,
                                int y)
使用 Graphics2D 上下文中的当前文本属性状态呈现指定的 String 的文本。首字符的基线位于用户空间的 (x, y) 位置处。应用的呈现属性包括 Clip、Transform、Paint、Font 和 Composite 属性。对于脚本系统（如 Hebrew 和 Arabic）中的字符，在提供的坐标位于基线上最左边字符的情况下，可以从右到左呈现字形。

指定者：
类 Graphics 中的 drawString
参数：
str - 要呈现的字符串
x - 呈现 String 位置的 x 坐标
y - 呈现 String 位置的 y 坐标
抛出：
NullPointerException - 如果 str 为 null
从以下版本开始：
JDK1.0
另请参见：
Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawChars(char[], int, int, int, int)

drawString

public abstract void drawString(String str,
                                float x,
                                float y)
使用 Graphics2D 上下文中当前文本属性状态呈现由指定 String 指定的文本。首字符的基线位于用户空间中的 (x, y) 位置处。应用的呈现属性包括 Clip、Transform、Paint、Font 和 Composite 属性。对于脚本系统（如 Hebrew 和 Arabic）中的字符，在提供的坐标位于基线上最左边字符的情况下，可以从右到左呈现字形。

参数：
str - 要呈现的 String
x - 呈现 String 位置的 x 坐标
y - 呈现 String 位置的 y 坐标
抛出：
NullPointerException - 如果 str 为 null
另请参见：
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
Graphics.setFont(java.awt.Font),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
Graphics.setClip(int, int, int, int)

drawString

public abstract void drawString(AttributedCharacterIterator iterator,
                                int x,
                                int y)
依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。

首字符的基线位于用户空间中的 (x, y) 位置处。对于脚本系统（如 Hebrew 和 Arabic）中的字符，在提供的坐标位于基线上最左边字符的情况下，可以从右到左呈现字形。

指定者：
类 Graphics 中的 drawString
参数：
iterator - 要呈现其文本的迭代器
x - 要呈现迭代器文本处的 x 坐标
y - 要呈现迭代器文本处的 y 坐标
抛出：
NullPointerException - 如果 iterator 为 null
另请参见：
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
Graphics.setClip(int, int, int, int)

drawString

public abstract void drawString(AttributedCharacterIterator iterator,
                                float x,
                                float y)
依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。

首字符的基线位于用户空间中的 (x, y) 位置处。对于脚本系统（如 Hebrew 和 Arabic）中的字符，在提供的坐标位于基线上最左边字符的情况下，可以从右到左呈现字形。

参数：
iterator - 要呈现其文本的迭代器
x - 要呈现迭代器文本处的 x 坐标
y - 要呈现迭代器文本处的 y 坐标
抛出：
NullPointerException - 如果 iterator 为 null
另请参见：
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
Graphics.setClip(int, int, int, int)

drawGlyphVector

public abstract void drawGlyphVector(GlyphVector g,
                                     float x,
                                     float y)
使用 Graphics2D 上下文的呈现属性，呈现指定 GlyphVector 的文本。应用的呈现属性包括 Clip、Transform、Paint 和 Composite 属性。GlyphVector 指定来自一个 Font 的各个字形。GlyphVector 还可以包含字形位置。这是将一组字符呈现到屏幕的最快方式。

参数：
g - 要呈现的 GlyphVector
x - 字形呈现用户空间中的 x 位置
y - 字形呈现用户空间中的 y 位置
抛出：
NullPointerException - 如果 g 为 null。
另请参见：
Font.createGlyphVector(java.awt.font.FontRenderContext, java.lang.String),
GlyphVector,
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
Graphics.setClip(int, int, int, int)

fill

public abstract void fill(Shape s)
使用 Graphics2D 上下文的设置，填充 Shape 的内部区域。应用的呈现属性包括 Clip、Transform、Paint 和 Composite 属性。

参数：
s - 要填充的 Shape
另请参见：
setPaint(java.awt.Paint),
Graphics.setColor(java.awt.Color),
transform(java.awt.geom.AffineTransform),
setTransform(java.awt.geom.AffineTransform),
setComposite(java.awt.Composite),
clip(java.awt.Shape),
Graphics.setClip(int, int, int, int)

hit

public abstract boolean hit(Rectangle rect,
                            Shape s,
                            boolean onStroke)
检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。如果 onStroke 为 false，则此方法会检查指定 Shape 的内部区域是否与指定的 Rectangle 相交。如果 onStroke 为 true，则此方法会检查指定 Shape 轮廓的 Stroke 是否与指定的 Rectangle 相交。可应用的呈现属性包括 Clip、Transform 和 Stroke 属性。

参数：
rect - 检查设备空间中是否相交的区域
s - 检查是否相交的 Shape
onStroke - 用于在测试中选择笔划或填充图形的标志。如果该标志为 true，则测试 Stroke 轮廓。如果该标志为 false，则测试填充的 Shape。
返回：
如果存在相交，则返回 true；否则返回 false
另请参见：
setStroke(java.awt.Stroke),
fill(java.awt.Shape),
draw(java.awt.Shape),
transform(java.awt.geom.AffineTransform),
setTransform(java.awt.geom.AffineTransform),
clip(java.awt.Shape),
Graphics.setClip(int, int, int, int)

getDeviceConfiguration

public abstract GraphicsConfiguration getDeviceConfiguration()
返回与此 Graphics2D 关联的设备配置。

返回：
此 Graphics2D 的设备配置。

setComposite

public abstract void setComposite(Composite comp)
为 Graphics2D 上下文设置 Composite。 Composite 用于所有绘制方法中，如 drawImage、drawString、draw 和 fill。 它指定新的像素如何在呈现过程中与图形设备上的现有像素组合。

如果此 Graphics2D 上下文正在向显示屏幕绘制 Component，并且 Composite 是自定义对象，而不是 AlphaComposite 类的实例，那么如果有安全管理器，就可以使用 AWTPermission("readDisplayPixels") 权限调用其 checkPermission 方法。

参数：
comp - 用于呈现的 Composite 对象
抛出：
SecurityException - 如果自定义的 Composite 对象被用于呈现到屏幕，并设置了安全管理器，且其 checkPermission 方法不允许该操作。
另请参见：
Graphics.setXORMode(java.awt.Color),
Graphics.setPaintMode(),
getComposite(),
AlphaComposite,
SecurityManager.checkPermission(java.security.Permission),
AWTPermission

setPaint

public abstract void setPaint(Paint paint)
为 Graphics2D 上下文设置 Paint 属性。使用为 null 的 Paint 对象调用此方法对此 Graphics2D 的当前 Paint 属性没有任何影响。

参数：
paint - 呈现过程中用于生成颜色的 Paint 对象；或者为 null
另请参见：
Graphics.setColor(java.awt.Color), getPaint(), GradientPaint, TexturePaint

setStroke

public abstract void setStroke(Stroke s)
为 Graphics2D 上下文设置 Stroke

参数：
s - 呈现过程中用于勾画 Shape 的 Stroke 对象
另请参见：
BasicStroke, getStroke()

setRenderingHint

public abstract void setRenderingHint(RenderingHints.Key hintKey,
                                      Object hintValue)
为呈现算法设置单个首选项的值。提示类别包括对呈现过程中的呈现质量和总时间/质量折衷的控制。有关常用键和值的定义，请参考 RenderingHints 类。

参数：
hintKey - 要设置提示的键。
hintValue - 指示指定提示类别首选项的值。
另请参见：
getRenderingHint(RenderingHints.Key), RenderingHints

getRenderingHint

public abstract Object getRenderingHint(RenderingHints.Key hintKey)
返回呈现算法的单个首选项的值。提示类别包括对呈现过程中的呈现质量和总时间/质量折衷的控制。有关常用键和值的定义，请参考 RenderingHints 类。

参数：
hintKey - 与要获得的提示对应的键。
返回：
表示指定提示键的值的对象。一些键及其关联值在 RenderingHints 类中定义。
另请参见：
RenderingHints, setRenderingHint(RenderingHints.Key, Object)

setRenderingHints

public abstract void setRenderingHints(Map<?,?> hints)
使用指定的 hints 替换用于所有呈现算法首选项的值。丢弃所有呈现提示的现有值，并从指定的 Map 对象初始化一组新的已知提示和值。提示类别包括对呈现过程中的呈现质量和总时间/质量折衷的控制。有关常用键和值的定义，请参考 RenderingHints 类。

参数：
hints - 要设置的呈现提示
另请参见：
getRenderingHints(), RenderingHints

addRenderingHints

public abstract void addRenderingHints(Map<?,?> hints)
为呈现算法设置任意数量的首选项值。仅修改在指定 Map 对象中存在的呈现提示值。所有指定对象中不存在的其它首选项不做修改。提示类别包括对呈现过程中的呈现质量和总时间/质量折衷的控制。有关常用键和值的定义，请参考 RenderingHints 类。

参数：
hints - 要设置的呈现提示
另请参见：
RenderingHints

getRenderingHints

public abstract RenderingHints getRenderingHints()
获取呈现算法的首选项。提示类别包括对呈现过程中的呈现质量和总时间/质量折衷的控制。返回所有在一次操作中指定的提示键/值对。有关常用键和值的定义，请参考 RenderingHints 类。

返回：
包含对当前首选项的 RenderingHints 实例的引用。
另请参见：
RenderingHints, setRenderingHints(Map)

translate

public abstract void translate(int x,
                               int y)
将 Graphics2D 上下文的原点平移到当前坐标系中的点 (x, y)。修改 Graphics2D 上下文，使其新的原点对应于此 Graphics2D 上下文原坐标系中的点 (x, y)。在此图形上下文上执行的后续呈现操作使用的所有坐标均相对于这个新原点。

指定者：
类 Graphics 中的 translate
参数：
x - 指定的 x 坐标
y - 指定的 y 坐标
从以下版本开始：
JDK1.0

translate

public abstract void translate(double tx,
                               double ty)
将当前 Graphics2D Transform 与平移转换连接。后续呈现相对于前一位置平移指定的距离。这等同于调用 transform(T)，其中 T 为以下矩阵表示的 AffineTransform：
                [   1    0    tx  ]
                [   0    1    ty  ]
                [   0    0    1   ]

参数：
tx - 沿 x 轴平移的距离
ty - 沿 y 轴平移的距离

rotate

public abstract void rotate(double theta)
将当前的 Graphics2D Transform 与旋转转换连接。后续呈现相对于前一原点旋转指定弧度。这等同于调用 transform(R)，其中 R 为以下矩阵表示的 AffineTransform：
                [   cos(theta)    -sin(theta)    0   ]
                [   sin(theta)     cos(theta)    0   ]
                [       0              0         1   ]
使用正角度 theta 进行旋转，可将正 x 轴上的点转向正 y 轴。

参数：
theta - 旋转的角度，以弧度为单位

rotate

public abstract void rotate(double theta,
                            double x,
                            double y)
将当前的 Graphics2D Transform 与平移后的旋转转换连接。后续呈现的变换如下：平移到指定位置，旋转指定弧度，然后向回平移相同的距离。这等同于以下调用序列：
                translate(x, y);
                rotate(theta);
                translate(-x, -y);
使用正角度 theta 进行旋转，可将正 x 轴上的点转向正 y 轴。

参数：
theta - 旋转的角度，以弧度为单位
x - 旋转原点的 x 坐标
y - 旋转原点的 y 坐标

scale

public abstract void scale(double sx,
                           double sy)
将当前 Graphics2D Transform 与缩放转换连接。后续呈现相对于以前的缩放比例根据指定的缩放系数来重新调整大小。这等同于调用 transform(S)，其中 S 为以下矩阵表示的 AffineTransform：
                [   sx   0    0   ]
                [   0    sy   0   ]
                [   0    0    1   ]

参数：
sx - 相对于以前的呈现操作，后续呈现操作中的与 X 坐标相乘的量。
sy - 相对于以前的呈现操作，后续呈现操作中的与 Y 坐标相乘的量。

shear

public abstract void shear(double shx,
                           double shy)
将当前 Graphics2D Transform 与剪裁转换连接。后续呈现相对于以前的位置由指定的乘式剪裁。这等同于调用 transform(SH)，其中 SH 为以下矩阵表示的 AffineTransform：
                [   1   shx   0   ]
                [  shy   1    0   ]
                [   0    0    1   ]

参数：
shx - 在正 X 轴方向移动坐标的乘数，它可以作为其 Y 坐标的函数
shy - 在正 Y 轴方向移动坐标的乘数，它可以作为其 X 坐标的函数

transform

public abstract void transform(AffineTransform Tx)
根据“最后指定首先应用”规则，使用此 Graphics2D 中的 Transform 组合 AffineTransform 对象。如果当前 Transform 为 Cx，那么使用 Tx 进行组合的结果为新的 Transform Cx'。Cx' 成为此 Graphics2D 的当前 Transform。通过更新的 Transform Cx' 转换点 p 等同于首先通过 Tx 转换点 p，然后通过原来的 Transform Cx 转换所得结果。换句话说，Cx'(p) = Cx(Tx(p))。如有必要，可以生成 Tx 的副本，从而对 Tx 进行进一步修改时不会影响呈现。

参数：
Tx - 要与当前 Transform 组合的 AffineTransform 对象
另请参见：
setTransform(java.awt.geom.AffineTransform), AffineTransform

setTransform

public abstract void setTransform(AffineTransform Tx)
重写 Graphics2D 上下文中的 Transform。警告：切勿使用此方法在现有转换之上应用新的坐标转换，因为 Graphics2D 可能已经有用于其它用途（例如，呈现 Swing 组件或应用缩放转换以调整打印机的分辨率）的转换。

要添加坐标转换，请使用 transform、rotate、scale 或 shear 方法。setTransform 方法只用于呈现后恢复原始 Graphics2D 的转换，如以下示例所示：

 // Get the current transform
 AffineTransform saveAT = g2.getTransform();
 // Perform transformation
 g2d.transform(...);
 // Render
 g2d.draw(...);
 // Restore original transform
 g2d.setTransform(saveAT);

参数：
Tx - 从 getTransform 方法检索的 AffineTransform
另请参见：
transform(java.awt.geom.AffineTransform), getTransform(), AffineTransform

getTransform

public abstract AffineTransform getTransform()
返回 Graphics2D 上下文中当前 Transform 的副本。

返回：
Graphics2D 上下文中的当前 AffineTransform
另请参见：
transform(java.awt.geom.AffineTransform), setTransform(java.awt.geom.AffineTransform)

getPaint

public abstract Paint getPaint()
返回 Graphics2D 上下文中的当前 Paint

返回：
当前 Graphics2D Paint，它定义一种颜色或模式。
另请参见：
setPaint(java.awt.Paint), Graphics.setColor(java.awt.Color)

getComposite

public abstract Composite getComposite()
返回 Graphics2D 上下文中的当前 Composite

返回：
当前 Graphics2D Composite，它定义一种复合样式。
另请参见：
setComposite(java.awt.Composite)

setBackground

public abstract void setBackground(Color color)
设置 Graphics2D 上下文的背景色。背景色用于清除区域。当为 Component 构建 Graphics2D 时，可以从 Component 继承背景色。设置 Graphics2D 上下文中的背景色仅影响后续 clearRect 调用，不影响该 Component 的背景色。要更改 Component 的背景，请使用该 Component 的相应方法。

参数：
color - 在对 clearRect 的后续调用中所用的背景色
另请参见：
getBackground(), Graphics.clearRect(int, int, int, int)

getBackground

public abstract Color getBackground()
返回用于清除区域的背景色。

返回：
当前 Graphics2D Color，它定义背景色。
另请参见：
setBackground(java.awt.Color)

getStroke

public abstract Stroke getStroke()
返回 Graphics2D 上下文中的当前 Stroke

返回：
当前 Graphics2D Stroke，它定义线条样式。
另请参见：
setStroke(java.awt.Stroke)

clip

public abstract void clip(Shape s)
将当前 Clip 与指定 Shape 的内部区域相交，并将 Clip 设置为所得的交集。与当前 Clip 相交之前，使用当前 Graphics2D Transform 转换指定的 Shape。 此方法用于使当前 Clip 变小。要使 Clip 变大，请使用 setClip。 此方法修改的用户剪贴区 独立于与设备边界和可视性关联的剪切。如果以前没有设置任何剪贴区，或者已经使用带有 null 参数的 setClip 将剪贴区清除，那么指定的 Shape 将成为新的用户剪贴区。

参数：
s - 要与当前 Clip 相交的 Shape。如果 s 为 null，则此方法会清除当前 Clip。

getFontRenderContext

public abstract FontRenderContext getFontRenderContext()
获取此 Graphics2D 上下文中 Font 的呈现上下文。FontRenderContext 封装应用程序提示，如抗锯齿和小数规格，以及目标设备的特定信息（如每英寸的点数）。当使用 Font 和 TextLayout 等对象执行印刷格式编排时，应用程序应提供此信息。将各种呈现提示应用到文本呈现时，执行其自身布局并且需要对字形（如前距和线高）的各种特征进行精确测量的应用程序也应提供此信息。

返回：
对 FontRenderContext 实例的引用。
从以下版本开始：
1.2
另请参见：
FontRenderContext, Font.createGlyphVector(java.awt.font.FontRenderContext, java.lang.String), TextLayout
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GraphicsConfigTemplate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GraphicsConfigTemplate

java.lang.Object
    继承者  java.awt.GraphicsConfigTemplate
所有已实现的接口：
Serializable
public abstract class GraphicsConfigTemplate
extends Object
implements Serializable

GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。用户实例化其中的一个对象，然后根据需要设置所有非默认的属性。然后，使用此 GraphicsConfigTemplate 调用可在 GraphicsDevice 类中找到的 GraphicsDevice.getBestConfiguration(java.awt.GraphicsConfigTemplate) 方法。返回一个有效的 GraphicsConfiguration，它可满足或超过 GraphicsConfigTemplate 中的要求。

从以下版本开始：
1.2
另请参见：
GraphicsDevice, GraphicsConfiguration, 序列化表格

字段摘要
static int | PREFERRED 用于“枚举”（整数）类型的值。
static int | REQUIRED 用于“枚举”（整数）类型的值。
static int | UNNECESSARY 用于“枚举”（整数）类型的值。
构造方法摘要
GraphicsConfigTemplate()
此类是一个抽象类，因此只有子类才可以实例化。
方法摘要
abstract GraphicsConfiguration | getBestConfiguration(GraphicsConfiguration[] gc) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
abstract boolean | isGraphicsConfigSupported(GraphicsConfiguration gc) 返回一个 boolean，它指示指定的 GraphicsConfiguration 是否可用于创建支持指定功能的绘图面。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

REQUIRED

public static final int REQUIRED
用于“枚举”（整数）类型的值。声明此功能对于 GraphicsConfiguration 对象是必需的。如果此功能不可用，则不要选择 GraphicsConfiguration 对象。

另请参见：
常量字段值

PREFERRED

public static final int PREFERRED
用于“枚举”（整数）类型的值。声明此功能是 GraphicsConfiguration 对象所期望的。尽管这两个选项都被视为有效的匹配，但具有此功能的选项要优先于不包含此功能的选项。

另请参见：
常量字段值

UNNECESSARY

public static final int UNNECESSARY
用于“枚举”（整数）类型的值。声明此功能对于选择 GraphicsConfiguration 对象不是必需的。没有此功能的选项要优先于包含此功能的选项，因为没有使用该功能。

另请参见：
常量字段值
构造方法详细信息

GraphicsConfigTemplate

public GraphicsConfigTemplate()
此类是一个抽象类，因此只有子类才可以实例化。

方法详细信息

getBestConfiguration

public abstract GraphicsConfiguration getBestConfiguration(GraphicsConfiguration[] gc)
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。

参数：
gc - 要从其选择的 GraphicsConfiguration 对象的数组。
返回：
一个可能是最佳配置的 GraphicsConfiguration 对象。
另请参见：
GraphicsConfiguration

isGraphicsConfigSupported

public abstract boolean isGraphicsConfigSupported(GraphicsConfiguration gc)
返回一个 boolean，它指示指定的 GraphicsConfiguration 是否可用于创建支持指定功能的绘图面。

参数：
gc - 要测试的 GraphicsConfiguration 对象
返回：
如果此 GraphicsConfiguration 对象可用于创建支持指定功能的画面，则返回 true；如果 GraphicsConfiguration 不能用于创建此 Java(tm) API 可用的绘图面，则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GraphicsConfiguration (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GraphicsConfiguration

java.lang.Object
    继承者  java.awt.GraphicsConfiguration

public abstract class GraphicsConfiguration
extends Object

GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。有许多与单一图形设备关联的 GraphicsConfiguration 对象，表示不同的绘图模式或能力。相应的本机结构也将因平台而异。例如，在 X11 窗口系统上，每个可视组件都是一个不同的 GraphicsConfiguration。在 Microsoft Windows 系统上，GraphicsConfiguration 表示当前分辨率和颜色深度下可用的 PixelFormat。

在虚拟设备多屏幕环境中（其中桌面区域可以跨越多个物理屏幕设备），GraphicsConfiguration 对象的边界与虚拟坐标系相关。当设置组件的位置时，使用 getBounds 来获得所需 GraphicsConfiguration 的边界和 GraphicsConfiguration 坐标位置的偏移量，以下代码示例给出了说明：

      Frame f = new Frame(gc);  // where gc is a GraphicsConfiguration
      Rectangle bounds = gc.getBounds();
      f.setLocation(10 + bounds.x, 10 + bounds.y);

要确定环境是否为虚拟设备环境，可以对系统中的所有 GraphicsConfiguration 对象调用 getBounds。如果所有返回的边界原点都不是 (0, 0)，则环境为虚拟设备环境。

也可以使用 getBounds 来确定虚拟设备的边界。为此，首先要对系统中的所有 GraphicsConfiguration 对象调用 getBounds。然后计算调用 getBounds 返回的所有边界的并集。该并集就是虚拟设备的边界。以下代码示例可计算虚拟设备的边界。

      Rectangle virtualBounds = new Rectangle();
      GraphicsEnvironment ge = GraphicsEnvironment.
              getLocalGraphicsEnvironment();
      GraphicsDevice[] gs =
              ge.getScreenDevices();
      for (int j = 0; j < gs.length; j++) {
          GraphicsDevice gd = gs[j];
          GraphicsConfiguration[] gc =
              gd.getConfigurations();
          for (int i=0; i < gc.length; i++) {
              virtualBounds =
                  virtualBounds.union(gc[i].getBounds());
          }
      }

另请参见：
Window, Frame, GraphicsEnvironment, GraphicsDevice

构造方法摘要
protected GraphicsConfiguration()
这是一个不可直接实例化的抽象类。
方法摘要
abstract BufferedImage | createCompatibleImage(int width, int height) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
BufferedImage | createCompatibleImage(int width, int height, int transparency) 返回一个支持指定透明度，并且数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
VolatileImage | createCompatibleVolatileImage(int width, int height) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
VolatileImage | createCompatibleVolatileImage(int width, int height, ImageCapabilities caps) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
VolatileImage | createCompatibleVolatileImage(int width, int height, ImageCapabilities caps, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
VolatileImage | createCompatibleVolatileImage(int width, int height, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
abstract Rectangle | getBounds() 返回 GraphicsConfiguration 在设备坐标中的边界。
BufferCapabilities | getBufferCapabilities() 返回此 GraphicsConfiguration 的缓冲区能力。
abstract ColorModel | getColorModel() 返回与此 GraphicsConfiguration 关联的 ColorModel。
abstract ColorModel | getColorModel(int transparency) 返回与此 GraphicsConfiguration 关联并支持指定透明度的 ColorModel。
abstract AffineTransform | getDefaultTransform() 返回此 GraphicsConfiguration 的默认 AffineTransform。
abstract GraphicsDevice | getDevice() 返回与此 GraphicsConfiguration 关联的 GraphicsDevice。
ImageCapabilities | getImageCapabilities() 返回此 GraphicsConfiguration 的图像能力。
abstract AffineTransform | getNormalizingTransform() 返回可与 GraphicsConfiguration 的默认 AffineTransform 连接的 AffineTransform，从而用户空间的 72 单位等于设备空间的 1 英寸。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GraphicsConfiguration

protected GraphicsConfiguration()
这是一个不可直接实例化的抽象类。必须从合适的工厂或查询方法中获取实例。

另请参见：
GraphicsDevice.getConfigurations(),
GraphicsDevice.getDefaultConfiguration(),
GraphicsDevice.getBestConfiguration(java.awt.GraphicsConfigTemplate),
Graphics2D.getDeviceConfiguration()
方法详细信息

getDevice

public abstract GraphicsDevice getDevice()
返回与此 GraphicsConfiguration 关联的 GraphicsDevice。

返回：
一个与此 GraphicsConfiguration 关联的 GraphicsDevice 对象。

createCompatibleImage

public abstract BufferedImage createCompatibleImage(int width,
                                                    int height)
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。此方法与设备的内存映射无关。返回 BufferedImage 的数据布局和颜色模型与本机设备配置最接近，因此最适合于位图传输 (blitted) 到此设备上。

参数：
width - 返回的 BufferedImage 宽度
height - 返回的 BufferedImage 高度
返回：
一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。

createCompatibleImage

public BufferedImage createCompatibleImage(int width,
                                           int height,
                                           int transparency)
返回一个支持指定透明度，并且数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。此方法与设备的内存映射无关。返回 BufferedImage 的数据布局和颜色模型最适合于位图传输 (blitted) 到利用此 GraphicsConfiguration 的设备上。

参数：
width - 返回的 BufferedImage 宽度
height - 返回的 BufferedImage 高度
transparency - 指定的透明度模式
返回：
一个数据布局和颜色模型与此 GraphicsConfiguration 兼容且支持指定透明度的 BufferedImage。
抛出：
IllegalArgumentException - 如果透明度不是一个有效值
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT

createCompatibleVolatileImage

public VolatileImage createCompatibleVolatileImage(int width,
                                                   int height)
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。返回的 VolatileImage 可能有最适合于底层图形设备的存储数据，因此可能从特定于平台的呈现加速中受益。

参数：
width - 返回的 VolatileImage 宽度
height - 返回的 VolatileImage 高度
返回：
一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
从以下版本开始：
1.4
另请参见：
Component.createVolatileImage(int, int)

createCompatibleVolatileImage

public VolatileImage createCompatibleVolatileImage(int width,
                                                   int height,
                                                   int transparency)
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。返回的 VolatileImage 可能有最适合于底层图形设备的存储数据，因此可能从特定于平台的呈现加速中受益。

参数：
width - 返回的 VolatileImage 宽度
height - 返回的 VolatileImage 高度
transparency - 指定的透明度模式
返回：
一个数据和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
抛出：
IllegalArgumentException - 如果透明度不是一个有效值
从以下版本开始：
1.5
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT, Component.createVolatileImage(int, int)

createCompatibleVolatileImage

public VolatileImage createCompatibleVolatileImage(int width,
                                                   int height,
                                                   ImageCapabilities caps)
                                            throws AWTException
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。如果该 caps 参数为 null，则有效地忽略它，此方法还将创建一个 VolatileImage，而不考虑 ImageCapabilities 约束。 返回 VolatileImage 的数据布局和颜色模型与本机设备配置最接近，因此最适合于位图传输 (blitted) 到此设备上。

参数：
width - 返回的 VolatileImage 宽度
height - 返回的 VolatileImage 高度
caps - 图像能力
返回：
一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
抛出：
AWTException - 如果此图形配置无法满足提供的图像能力
从以下版本开始：
1.4

createCompatibleVolatileImage

public VolatileImage createCompatibleVolatileImage(int width,
                                                   int height,
                                                   ImageCapabilities caps,
                                                   int transparency)
                                            throws AWTException
返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。如果该 caps 参数为 null，则有效地忽略它，此方法还将创建一个 VolatileImage，而不考虑 ImageCapabilities 约束。 返回 VolatileImage 的数据布局和颜色模型与本机设备配置最接近，因此最适合于位图传输 (blitted) 到此设备上。

参数：
width - 返回的 VolatileImage 宽度
height - 返回的 VolatileImage 高度
caps - 图像能力
transparency - 指定的透明度模式
返回：
一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
抛出：
IllegalArgumentException - 如果透明度不是一个有效值
AWTException - 如果此图形配置无法满足提供的图像能力
从以下版本开始：
1.5
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT, Component.createVolatileImage(int, int)

getColorModel

public abstract ColorModel getColorModel()
返回与此 GraphicsConfiguration 关联的 ColorModel。

返回：
一个与此 GraphicsConfiguration 关联的 ColorModel 对象。

getColorModel

public abstract ColorModel getColorModel(int transparency)
返回与此 GraphicsConfiguration 关联并支持指定透明度的 ColorModel。

参数：
transparency - 指定的透明度模式
返回：
一个与此 GraphicsConfiguration 关联并支持指定透明度的 ColorModel 对象；如果透明度不是一个有效值，则返回 null。
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT

getDefaultTransform

public abstract AffineTransform getDefaultTransform()
返回此 GraphicsConfiguration 的默认 AffineTransform。此 AffineTransform 通常是大多数正常屏幕的 Identity 转换。默认的 AffineTransform 将坐标映射到设备上：72 用户空间坐标单位在尺度上近似于设备空间的 1 英寸。标准化的转换可使映射关系更准确。坐标空间中默认 AffineTransform 为屏幕和打印机设备定义的坐标如下：原点在设备目标区域的左上角，X 坐标方向向右，Y 坐标方向向下。对于与此设备无关的图像缓冲区，如那些非 createCompatibleImage 创建的缓冲区，此 AffineTransform 即为 Identity 转换。

返回：
此 GraphicsConfiguration 的默认 AffineTransform。

getNormalizingTransform

public abstract AffineTransform getNormalizingTransform()
返回可与 GraphicsConfiguration 的默认 AffineTransform 连接的 AffineTransform，从而用户空间的 72 单位等于设备空间的 1 英寸。

对于特定 Graphics2D g，可使用以下伪代码重新设置转换来创建这种映射关系：

      GraphicsConfiguration gc = g.getDeviceConfiguration();

      g.setTransform(gc.getDefaultTransform());
      g.transform(gc.getNormalizingTransform());
注意，有时此 AffineTransform 是诸如打印机或图元文件输出的标识，并且此 AffineTransform 只与底层系统提供的信息一样准确。对于与设备没有关联的图像缓冲区，如那些非 createCompatibleImage 创建的缓冲区，因为没有有效的距离尺度，此 AffineTransform 即为 Identity 转换。

返回：
一个连接默认 AffineTransform 的 AffineTransform，从而用户空间的 72 单位映射为设备空间的 1 英寸。

getBounds

public abstract Rectangle getBounds()
返回 GraphicsConfiguration 在设备坐标中的边界。在虚拟设备的多屏环境中，边界可以有负 X 或 Y 原点。

返回：
此 GraphicsConfiguration 覆盖的区域边界。
从以下版本开始：
1.3

getBufferCapabilities

public BufferCapabilities getBufferCapabilities()
返回此 GraphicsConfiguration 的缓冲区能力。

返回：
此图形配置对象的缓冲区能力
从以下版本开始：
1.4

getImageCapabilities

public ImageCapabilities getImageCapabilities()
返回此 GraphicsConfiguration 的图像能力。

返回：
此图形配置对象的图像能力
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GraphicsDevice (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GraphicsDevice

java.lang.Object
    继承者  java.awt.GraphicsDevice

public abstract class GraphicsDevice
extends Object

GraphicsDevice 类描述可以在特定图形环境中使用的图形设备。这些设备包括屏幕和打印机设备。注意，在 GraphicsEnvironment 实例中可以有许多屏幕和许多打印机。每个图形设备都有一个或多个与之关联的 GraphicsConfiguration 对象。这些对象指定可以使用 GraphicsDevice 的不同配置。

在多屏幕环境中，GraphicsConfiguration 对象可用于在多屏幕上呈现组件。以下代码示例演示了如何在 GraphicsEnvironment 中针对每个屏幕设备的每个 GraphicsConfiguration 创建 JFrame 对象。

   GraphicsEnvironment ge = GraphicsEnvironment.
   getLocalGraphicsEnvironment();
   GraphicsDevice[] gs = ge.getScreenDevices();
   for (int j = 0; j < gs.length; j++) {
      GraphicsDevice gd = gs[j];
      GraphicsConfiguration[] gc =
        gd.getConfigurations();
      for (int i=0; i < gc.length; i++) {
         JFrame f = new
         JFrame(gs[j].getDefaultConfiguration());
         Canvas c = new Canvas(gc[i]);
         Rectangle gcBounds = gc[i].getBounds();
         int xoffs = gcBounds.x;
         int yoffs = gcBounds.y;
           f.getContentPane().add(c);
           f.setLocation((i*50)+xoffs, (i*60)+yoffs);
         f.show();
      }
   }

有关全屏独占模式 API 的更多信息，请参阅 Full-Screen Exclusive Mode API Tutorial。

另请参见：
GraphicsEnvironment, GraphicsConfiguration

字段摘要
static int | TYPE_IMAGE_BUFFER 设备是图像缓冲区。
static int | TYPE_PRINTER 设备是打印机。
static int | TYPE_RASTER_SCREEN 设备是光栅屏幕。
构造方法摘要
protected GraphicsDevice()
这是一个无法直接实例化的抽象类。
方法摘要
int | getAvailableAcceleratedMemory() 此方法返回此设备上加速内存中可用的字节数。
GraphicsConfiguration | getBestConfiguration(GraphicsConfigTemplate gct) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
abstract GraphicsConfiguration[] | getConfigurations() 返回与此 GraphicsDevice 关联的所有 GraphicsConfiguration 对象。
abstract GraphicsConfiguration | getDefaultConfiguration() 返回与此 GraphicsDevice 关联的默认 GraphicsConfiguration。
DisplayMode | getDisplayMode() 返回此 GraphicsDevice 的当前显示模式。
DisplayMode[] | getDisplayModes() 返回可用于此 GraphicsDevice 的所有显示模式。
Window | getFullScreenWindow() 如果设备处于全屏模式，则返回表示全屏窗口的 Window 对象。
abstract String | getIDstring() 返回与此 GraphicsDevice 关联的标识字符串。
abstract int | getType() 返回此 GraphicsDevice 的类型。
boolean | isDisplayChangeSupported() 如果此 GraphicsDevice 支持低层显示更改，则返回 true。
boolean | isFullScreenSupported() 如果此 GraphicsDevice 支持全屏独占模式，则返回 true。
void | setDisplayMode(DisplayMode dm) 设置此图形设备的显示模式。
void | setFullScreenWindow(Window w) 进入全屏模式，或返回窗口化模式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_RASTER_SCREEN

public static final int TYPE_RASTER_SCREEN
设备是光栅屏幕。

另请参见：
常量字段值

TYPE_PRINTER

public static final int TYPE_PRINTER
设备是打印机。

另请参见：
常量字段值

TYPE_IMAGE_BUFFER

public static final int TYPE_IMAGE_BUFFER
设备是图像缓冲区。此缓冲区可驻留在设备或系统内存中，但用户无法实际看到它。

另请参见：
常量字段值
构造方法详细信息

GraphicsDevice

protected GraphicsDevice()
这是一个无法直接实例化的抽象类。必须从合适的工厂或查询方法中获取实例。

另请参见：
GraphicsEnvironment.getScreenDevices(),
GraphicsEnvironment.getDefaultScreenDevice(),
GraphicsConfiguration.getDevice()
方法详细信息

getType

public abstract int getType()
返回此 GraphicsDevice 的类型。

返回：
此 GraphicsDevice 的类型，可以是 TYPE_RASTER_SCREEN、TYPE_PRINTER 或 TYPE_IMAGE_BUFFER。
另请参见：
TYPE_RASTER_SCREEN, TYPE_PRINTER, TYPE_IMAGE_BUFFER

getIDstring

public abstract String getIDstring()
返回与此 GraphicsDevice 关联的标识字符串。

在 GraphicsEnvironment 中，某个特定程序可能使用多个 GraphicsDevice。此方法返回一个标识本地 GraphicsEnvironment 中特定 GraphicsDevice 的 String。尽管没有设置此 String 的公共方法，但程序员仍然可以在调试时使用此 String。JavaTM Runtime Environment 供应商可以格式化 String 的返回值。要确定如何解释 String 值，请与 Java Runtime 供应商联系。要查找谁是供应商，可以从程序中使用“java.vendor”调用 System 类的 getProperty 方法。

返回：
一个作为此 GraphicsDevice 标识的 String。

getConfigurations

public abstract GraphicsConfiguration[] getConfigurations()
返回与此 GraphicsDevice 关联的所有 GraphicsConfiguration 对象。

返回：
一个与此 GraphicsDevice 关联的 GraphicsConfiguration 对象的数组。

getDefaultConfiguration

public abstract GraphicsConfiguration getDefaultConfiguration()
返回与此 GraphicsDevice 关联的默认 GraphicsConfiguration。

返回：
此 GraphicsDevice 的默认 GraphicsConfiguration。

getBestConfiguration

public GraphicsConfiguration getBestConfiguration(GraphicsConfigTemplate gct)
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。

参数：
gct - 用于获取有效 GraphicsConfiguration 的 GraphicsConfigTemplate 对象
返回：
一个通过了指定 GraphicsConfigTemplate 中定义的标准的 GraphicsConfiguration。
另请参见：
GraphicsConfigTemplate

isFullScreenSupported

public boolean isFullScreenSupported()
如果此 GraphicsDevice 支持全屏独占模式，则返回 true。如果安装了 SecurityManager，则将使用 AWTPermission("fullScreenExclusive") 调用它的 checkPermission 方法。只有授权时 isFullScreenSupported 才会返回 true。

返回：
此图形设备是否可以使用全屏独占模式
从以下版本开始：
1.4
另请参见：
AWTPermission

setFullScreenWindow

public void setFullScreenWindow(Window w)
进入全屏模式，或返回窗口化模式。进入的全屏模式可以是独占的，也可以是模拟的。只有 isFullScreenSupported 返回 true 时，独占模式才可用。

独占模式意味着：

  • Windows 无法重叠全屏窗口。所有其他应用程序窗口总是以 Z-order 出现在全屏窗口后面。
  • 任何时候设备上都只能有一个全屏窗口，因此，当已存在全屏窗口时调用此方法将导致现有的全屏窗口返回为窗口化模式。
  • 禁用输入方法窗口。建议调用 Component.enableInputMethods(false)，使组件成为非客户端的输入方法框架。

模拟的全屏模式将窗口大小调整为屏幕大小，并将它置于 (0,0)。

当进入全屏模式时，如果看不到作为全屏窗口使用的窗口，此方法将会使其可见。当返回到窗口化模式时，窗口仍将保持可见。

当从独占全屏窗口模式返回到窗口化模式时，任何调用 setDisplayMode 做出的显示更改都将自动恢复原状。

参数：
w - 一个用作全屏窗口的窗口；如果返回到窗口化模式，则为 null。一些平台希望全屏窗口成为顶层组件（即 Frame）；因此这里最好使用 Frame，而不用 Window。
从以下版本开始：
1.4
另请参见：
isFullScreenSupported(),
getFullScreenWindow(),
setDisplayMode(java.awt.DisplayMode),
Component.enableInputMethods(boolean),
Component.setVisible(boolean)

getFullScreenWindow

public Window getFullScreenWindow()
如果设备处于全屏模式，则返回表示全屏窗口的 Window 对象。

返回：
全屏窗口；如果设备未在全屏模式，则返回 null。
从以下版本开始：
1.4
另请参见：
setFullScreenWindow(Window)

isDisplayChangeSupported

public boolean isDisplayChangeSupported()
如果此 GraphicsDevice 支持低层显示更改，则返回 true。某些平台可能只在全屏独占模式中允许低层显示更改（即如果 isFullScreenSupported() 返回 true，且应用程序已经使用 setFullScreenWindow(java.awt.Window) 进入全屏模式）。

返回：
此图形设备是否支持低层显示更改。
从以下版本开始：
1.4
另请参见：
setDisplayMode(java.awt.DisplayMode)

setDisplayMode

public void setDisplayMode(DisplayMode dm)
设置此图形设备的显示模式。只在 isDisplayChangeSupported() 返回 true 时才允许此方法，假如支持全屏独占模式的话（即 isFullScreenSupported() 返回 true），还可能要求首先使用 setFullScreenWindow(java.awt.Window) 进入全屏独占模式。

该显示模式必须是由 getDisplayModes() 返回的显示模式之一，只有一种情况例外：传递带有 DisplayMode.REFRESH_RATE_UNKNOWN 刷新率的显示模式时，将从带有匹配宽度、高度和位深的可用显示模式列表中选择一个显示模式。但是，只有在位深为 DisplayMode.BIT_DEPTH_MULTI 的显示模式存在于 getDisplayModes() 返回的列表中时，才能传递这种显示模式。

代码示例：

 Frame frame;
 DisplayMode newDisplayMode;
 GraphicsDevice gd;
 // create a Frame, select desired DisplayMode from the list of modes
 // returned by gd.getDisplayModes() ...

 if (gd.isFullScreenSupported()) {
     gd.setFullScreenWindow(frame);
 } else {
    // proceed in non-full-screen mode
    frame.setSize(...);
    frame.setLocation(...);
    frame.setVisible(true);
 }

 if (gd.isDisplayChangeSupported()) {
     gd.setDisplayMode(newDisplayMode);
 }

参数：
dm - 此图形设备的新显示模式。
抛出：
IllegalArgumentException - 如果提供的 DisplayMode 为 null，或者在 getDisplayModes 返回的数组中不可用
UnsupportedOperationException - 如果 isDisplayChangeSupported 返回 false
从以下版本开始：
1.4
另请参见：
getDisplayMode(),
getDisplayModes(),
isDisplayChangeSupported()

getDisplayMode

public DisplayMode getDisplayMode()
返回此 GraphicsDevice 的当前显示模式。如果返回的显示模式是不确定的，则允许它具有 DisplayMode.REFRESH_RATE_UNKNOWN 刷新率。同样，如果返回的显示模式是不确定的或者支持多个位深，则允许它具有 DisplayMode.BIT_DEPTH_MULTI 位深。

返回：
此图形设备的当前显示模式。
从以下版本开始：
1.4
另请参见：
setDisplayMode(DisplayMode)

getDisplayModes

public DisplayMode[] getDisplayModes()
返回可用于此 GraphicsDevice 的所有显示模式。如果返回的显示模式是不确定的，则允许它具有 DisplayMode.REFRESH_RATE_UNKNOWN 刷新率。同样，如果返回的显示模式是不确定的或者支持多个位深，则允许它具有 DisplayMode.BIT_DEPTH_MULTI 位深。

返回：
此图形设备可用的所有显示模式。
从以下版本开始：
1.4

getAvailableAcceleratedMemory

public int getAvailableAcceleratedMemory()
此方法返回此设备上加速内存中可用的字节数。某些图像在加速内存中是按先来先服务的方式创建或缓存的。在某些操作系统中，此内存是有限资源。调用此方法并慎重安排图像的创建和刷新能够使应用程序最有效地使用这些有限的资源。
注意，返回的数字是可用内存数量的快照；将某些图像分配到该内存中可能仍然存在问题。例如，根据操作系统、驱动程序、内存配置和线程情况的不同，给定的图像可能无法使用报告的全部内存空间。对于与 VolatileImage 关联的 ImageCapabilities 对象，还有更多的查询方法，可用于确定是否在加速内存中创建一个特殊的 VolatileImage。

返回：
加速内存中可用的字节数。返回值为负指示此 GraphicsDevice 上的加速内存量是不确定的。
从以下版本开始：
1.4
另请参见：
Image.flush(), ImageCapabilities.isAccelerated()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GraphicsEnvironment (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GraphicsEnvironment

java.lang.Object
    继承者  java.awt.GraphicsEnvironment

public abstract class GraphicsEnvironment
extends Object

GraphicsEnvironment 类描述了 Java(tm) 应用程序在特定平台上可用的 GraphicsDevice 对象和 Font 对象的集合。此 GraphicsEnvironment 中的资源可以是本地资源，也可以位于远程机器上。GraphicsDevice 对象可以是屏幕、打印机或图像缓冲区，并且都是 Graphics2D 绘图方法的目标。每个 GraphicsDevice 都有许多与之相关的 GraphicsConfiguration 对象。这些对象指定了使用 GraphicsDevice 所需的不同配置。

另请参见：
GraphicsDevice, GraphicsConfiguration

构造方法摘要
protected GraphicsEnvironment()
这是一个抽象类，不能直接将其实例化。
方法摘要
abstract  Graphics2D createGraphics(BufferedImage img)
返回一个呈现指定 BufferedImage 的 Graphics2D 对象。
abstract  Font[] getAllFonts()
返回一个数组，它包含此 GraphicsEnvironment 中所有可用字体的像素级实例。
abstract  String[] getAvailableFontFamilyNames()
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，它针对默认语言环境进行了本地化，由 Locale.getDefault() 返回。
abstract  String[] getAvailableFontFamilyNames(Locale l)
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。
 Point getCenterPoint()
返回 Windows 应居中的点。
abstract  GraphicsDevice getDefaultScreenDevice()
返回默认的屏幕 GraphicsDevice。
static GraphicsEnvironment getLocalGraphicsEnvironment()
返回本地 GraphicsEnvironment。
 Rectangle getMaximumWindowBounds()
返回居中 Windows 的最大边界。
abstract  GraphicsDevice[] getScreenDevices()
返回所有屏幕 GraphicsDevice 对象组成的数组。
static boolean isHeadless()
测试此环境是否支持显示器、键盘和鼠标。
 boolean isHeadlessInstance()
返回此图形环境是否支持显示器、键盘和鼠标。
 void preferLocaleFonts()
指示在逻辑字体到实际字体的映射关系中特定于语言环境的字体的首选项。
 void preferProportionalFonts()
指示在逻辑字体到实际字体的映射关系中用于均衡字体和非均衡字体（如双字节的中日韩字体）的首选项。
 boolean registerFont(Font font)
在此 GraphicsEnvironment 中注册一个/已创建的 Font。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GraphicsEnvironment

protected GraphicsEnvironment()
这是一个抽象类，不能直接将其实例化。必须从一个合适的工厂或查询方法获取实例。

方法详细信息

getLocalGraphicsEnvironment

public static GraphicsEnvironment getLocalGraphicsEnvironment()
返回本地 GraphicsEnvironment。

返回：
本地 GraphicsEnvironment

isHeadless

public static boolean isHeadless()
测试此环境是否支持显示器、键盘和鼠标。如果此方法返回 true，则从依赖于显示器、键盘或鼠标的 Toolkit 和 GraphicsEnvironment 区域抛出 HeadlessException。

返回：
如果此环境无法支持显示器、键盘和鼠标，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
HeadlessException

isHeadlessInstance

public boolean isHeadlessInstance()
返回此图形环境是否支持显示器、键盘和鼠标。如果返回 true，则将从依赖于显示器、键盘或鼠标的图形环境区域抛出 HeadlessException。

返回：
如果此环境支持显示器、键盘和鼠标，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
HeadlessException, isHeadless()

getScreenDevices

public abstract GraphicsDevice[] getScreenDevices()
                                           throws HeadlessException
返回所有屏幕 GraphicsDevice 对象组成的数组。

返回：
一个包含所有表示屏幕设备的 GraphicsDevice 对象的数组。
抛出：
HeadlessException - 如果 isHeadless() 返回 true
另请参见：
isHeadless()

getDefaultScreenDevice

public abstract GraphicsDevice getDefaultScreenDevice()
                                               throws HeadlessException
返回默认的屏幕 GraphicsDevice。

返回：
表示默认屏幕设备的 GraphicsDevice
抛出：
HeadlessException - 如果 isHeadless() 返回 true
另请参见：
isHeadless()

createGraphics

public abstract Graphics2D createGraphics(BufferedImage img)
返回一个呈现指定 BufferedImage 的 Graphics2D 对象。

参数：
img - 指定的 BufferedImage
返回：
一个用于呈现指定 BufferedImage 的 Graphics2D
抛出：
NullPointerException - 如果 img 为 null

getAllFonts

public abstract Font[] getAllFonts()
返回一个数组，它包含此 GraphicsEnvironment 中所有可用字体的像素级实例。典型用法就是允许用户选择特定的字体。然后，通过调用所选择实例中的 deriveFont 方法，应用程序可以调整字体大小和设置各种字体属性。

此方法使应用程序能够最精确地控制用于呈现文本的 Font 实例。如果此 GraphicsEnvironment 中的某种字体有多个可编程的变体，则仅在数组中返回该 Font 的一个实例，并且其他变体必须由应用程序派生。

如果此环境中的某种字体有多个可编程的变体，如 Multiple-Master 字体，则在 Font 数组中仅返回该字体的一个实例。其他变体必须由应用程序派生。

返回：
Font 对象的数组
从以下版本开始：
1.2
另请参见：
getAvailableFontFamilyNames(), Font, Font.deriveFont(int, float), Font.getFontName()

getAvailableFontFamilyNames

public abstract String[] getAvailableFontFamilyNames()
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，它针对默认语言环境进行了本地化，由 Locale.getDefault() 返回。

典型用法是向用户展示特定字体系列名称的选择。然后，应用程序可以在创建字体（包括样式，如粗体或斜体）时指定此名称，这为字体系统从同一字体系列的多种字体中选择与自身最匹配的字体提供了灵活性。

返回：
一个 String 数组，它包含针对默认语言环境进行了本地化的字体系列名称，如果不存在针对此语言环境的名称，则返回一个合适的替代名称。
从以下版本开始：
1.2
另请参见：
getAllFonts(), Font, Font.getFamily()

getAvailableFontFamilyNames

public abstract String[] getAvailableFontFamilyNames(Locale l)
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。

典型用法是向用户展示特定字体系列名称的选择。然后，应用程序可以在创建字体（包括样式，如粗体或斜体）时指定此名称，这为字体系统从同一字体系列的多种字体中选择与自身最匹配的字体提供了灵活性。

参数：
l - 一个表示特定地理、政治或文化领域的 Locale 对象。指定 null 等效于指定 Locale.getDefault()。
返回：
一个 String 数组，它包含针对指定 Locale 进行了本地化的字体系列名称，如果不存在用于指定语言环境的名称，则返回一个合适的替代名称。
从以下版本开始：
1.2
另请参见：
getAllFonts(), Font, Font.getFamily()

registerFont

public boolean registerFont(Font font)
在此 GraphicsEnvironment 中注册一个/已创建的 Font。已创建的字体是调用 Font.createFont(int, java.io.InputStream) 返回的字体，或者由调用 Font.deriveFont(int, float) 创建的字体派生的字体。对这种字体调用此方法之后，可在通过名称或系列名称构造新的 Font 的过程中使用它，并且可以通过此应用程序或 applet 的执行上下文中的 getAvailableFontFamilyNames() 和 getAllFonts() 对它进行枚举。这意味着 applet 无法以其他 applet 可以看见它的方式注册字体。

此方法无法注册字体并因此返回 false 的原因是：

  • 字体不是/已创建的 Font。
  • 字体与此 GraphicsEnvironment 中的非创建性 Font 冲突。例如，如果该名称是系统字体的名称，或者是 Font 类的文档中所描述的逻辑字体。如果它具有与系统字体相同的系列名称，则不管字体是否发生冲突，它都与实现有关。那些针对已创建字体的异常则意味着应用程序可以替代早先使用新字体创建的字体的注册。

返回：
如果已成功在此 GraphicsEnvironment 中注册 font，则返回 true。
从以下版本开始：
1.6

preferLocaleFonts

public void preferLocaleFonts()
指示在逻辑字体到实际字体的映射关系中特定于语言环境的字体的首选项。调用此方法指示字体呈现主要应该使用特定于主要书写系统（由默认编码和初始默认语言环境指示的书写系统）的字体。例如，如果主要书写系统是日文，那么应该使用日文字体呈现字符（如果可能）；只有当日文字体中没有某种形状的字符时，才使用其他字体。

调用此方法所导致的字体呈现行为的实际更改与实现有关；字体呈现行为可能根本不受影响，或者所请求行为与默认行为可能已经是匹配的。用轻量级组件呈现字体的行为与用同级组件呈现字体的行为可能有所不同。因为调用此方法需要不同的字体，所以客户端需要不同的规格，并且可能需要重新计算窗口的大小和布局。因此，应在初始化用户界面之前调用此方法。

从以下版本开始：
1.5

preferProportionalFonts

public void preferProportionalFonts()
指示在逻辑字体到实际字体的映射关系中用于均衡字体和非均衡字体（如双字节的中日韩字体）的首选项。如果默认映射关系包含均衡字体和非均衡字体，则调用此方法指示该映射关系应当使用均衡字体。

调用此方法所导致的字体呈现行为的实际更改与实现有关；字体呈现行为可能根本不受影响。用轻量级组件呈现字体的行为与用同级组件呈现字体的行为可能有所不同。因为调用此方法需要不同的字体，所以客户端需要不同的规格，并且可能需要重新计算窗口的大小和布局。因此，应在初始化用户界面之前调用此方法。

从以下版本开始：
1.5

getCenterPoint

public Point getCenterPoint()
                     throws HeadlessException
返回 Windows 应居中的点。建议使用 getMaximumWindowBounds() 检查居中的 Windows，以确保它们适合有效的显示区域。

返回：
Windows 应居中的点
抛出：
HeadlessException - 如果 isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
getMaximumWindowBounds()

getMaximumWindowBounds

public Rectangle getMaximumWindowBounds()
                                 throws HeadlessException
返回居中 Windows 的最大边界。这些边界决定了本机窗口系统中的对象，如任务栏和菜单栏。返回的边界将位于单个台显示器上，只有一种情况例外：在 Windows 横跨所有显示器居中的多屏幕系统中，此方法返回整个显示区域的边界。

要获取单个显示器的可用边界，请使用 GraphicsConfiguration.getBounds() 和 Toolkit.getScreenInsets()。

返回：
居中的 Windows 的最大边界
抛出：
HeadlessException - 如果 isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
getCenterPoint(),
GraphicsConfiguration.getBounds(),
Toolkit.getScreenInsets(java.awt.GraphicsConfiguration)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GridBagConstraints (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GridBagConstraints

java.lang.Object
    继承者  java.awt.GridBagConstraints
所有已实现的接口：
Serializable, Cloneable
public class GridBagConstraints
extends Object
implements Cloneable, Serializable

GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。

从以下版本开始：
JDK1.0
另请参见：
GridBagLayout, 序列化表格

字段摘要
static int | ABOVE_BASELINE anchor 字段的可能值。
static int | ABOVE_BASELINE_LEADING anchor 字段的可能值。
static int | ABOVE_BASELINE_TRAILING anchor 字段的可能值。
int | anchor 当组件小于其显示区域时使用此字段。
static int | BASELINE anchor 字段的可能值。
static int | BASELINE_LEADING anchor 字段的可能值。
static int | BASELINE_TRAILING anchor 字段的可能值。
static int | BELOW_BASELINE anchor 字段的可能值。
static int | BELOW_BASELINE_LEADING anchor 字段的可能值。
static int | BELOW_BASELINE_TRAILING anchor 字段的可能值。
static int | BOTH 在水平方向和垂直方向上同时调整组件大小。
static int | CENTER 将组件置于其显示区域的中心。
static int | EAST 将组件置于其显示区域的右部，并在垂直方向上居中。
int | fill 当组件的显示区域大于它所请求的显示区域的大小时使用此字段。
static int | FIRST_LINE_END 将组件置于显示区域的一角，在该区域中，当前 ComponentOrienation 的页面的第一个文本行正常结束。
static int | FIRST_LINE_START 将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。
int | gridheight 指定在组件显示区域的一列中的单元格数。
int | gridwidth 指定组件显示区域的某一行中的单元格数。
int | gridx 指定包含组件的显示区域开始边的单元格，其中行的第一个单元格为 gridx=0。
int | gridy 指定位于组件显示区域的顶部的单元格，其中最上边的单元格为 gridy=0。
static int | HORIZONTAL 在水平方向而不是垂直方向上调整组件大小。
Insets | insets 此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。
int | ipadx 此字段指定组件的内部填充，即给组件的最小宽度添加多大的空间。
int | ipady 此字段指定内部填充，即给组件的最小高度添加多大的空间。
static int | LAST_LINE_END 将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的结束位置。
static int | LAST_LINE_START 将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。
static int | LINE_END 沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常结束。
static int | LINE_START 沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常开始。
static int | NONE 不重新调整组件大小。
static int | NORTH 将组件置于其显示区域的顶部，并在水平方向上居中。
static int | NORTHEAST 将组件置于其显示区域的右上角。
static int | NORTHWEST 将组件置于其显示区域的左上角。
static int | PAGE_END 沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面结束部分相关。
static int | PAGE_START 沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面开始部分相关。
static int | RELATIVE 指定此组件为其行或列（gridwidth、gridheight）中的倒数第二个组件，或者让此组件紧跟在以前添加的组件（gridx、gridy）之后。
static int | REMAINDER 指定此组件是其行或列中的最后一个组件。
static int | SOUTH 将组件置于其显示区域的底部，并在水平方向上居中。
static int | SOUTHEAST 将组件置于其显示区域的右下角。
static int | SOUTHWEST 将组件置于其显示区域的左下角。
static int | VERTICAL 在垂直方向而不是水平方向上调整组件大小。
double | weightx 指定如何分布额外的水平空间。
double | weighty 指定如何分布额外的垂直空间。
static int | WEST 将组件置于其显示区域的左部，并在垂直方向上居中。
构造方法摘要
GridBagConstraints()
创建一个 GridBagConstraint 对象，将其所有字段都设置为默认值。
GridBagConstraints(int gridx, int gridy, int gridwidth, int gridheight, double weightx, double weighty, int anchor, int fill, Insets insets, int ipadx, int ipady)
创建一个 GridBagConstraints 对象，将其所有字段都设置为传入参数。
方法摘要
 Object clone()
创建此网格包约束（grid bag constraint）的副本。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RELATIVE

public static final int RELATIVE
指定此组件为其行或列（gridwidth、gridheight）中的倒数第二个组件，或者让此组件紧跟在以前添加的组件（gridx、gridy）之后。

另请参见：
gridwidth, gridheight, gridx, gridy, 常量字段值

REMAINDER

public static final int REMAINDER
指定此组件是其行或列中的最后一个组件。

另请参见：
常量字段值

NONE

public static final int NONE
不重新调整组件大小。

另请参见：
常量字段值

BOTH

public static final int BOTH
在水平方向和垂直方向上同时调整组件大小。

另请参见：
常量字段值

HORIZONTAL

public static final int HORIZONTAL
在水平方向而不是垂直方向上调整组件大小。

另请参见：
常量字段值

VERTICAL

public static final int VERTICAL
在垂直方向而不是水平方向上调整组件大小。

另请参见：
常量字段值

CENTER

public static final int CENTER
将组件置于其显示区域的中心。

另请参见：
常量字段值

NORTH

public static final int NORTH
将组件置于其显示区域的顶部，并在水平方向上居中。

另请参见：
常量字段值

NORTHEAST

public static final int NORTHEAST
将组件置于其显示区域的右上角。

另请参见：
常量字段值

EAST

public static final int EAST
将组件置于其显示区域的右部，并在垂直方向上居中。

另请参见：
常量字段值

SOUTHEAST

public static final int SOUTHEAST
将组件置于其显示区域的右下角。

另请参见：
常量字段值

SOUTH

public static final int SOUTH
将组件置于其显示区域的底部，并在水平方向上居中。

另请参见：
常量字段值

SOUTHWEST

public static final int SOUTHWEST
将组件置于其显示区域的左下角。

另请参见：
常量字段值

WEST

public static final int WEST
将组件置于其显示区域的左部，并在垂直方向上居中。

另请参见：
常量字段值

NORTHWEST

public static final int NORTHWEST
将组件置于其显示区域的左上角。

另请参见：
常量字段值

PAGE_START

public static final int PAGE_START
沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面开始部分相关。等同于水平方向的 NORTH。

另请参见：
常量字段值

PAGE_END

public static final int PAGE_END
沿显示区域的边缘居中放置组件，该显示区域与当前 ComponentOrienation 的页面结束部分相关。等同于水平方向的 SOUTH。

另请参见：
常量字段值

LINE_START

public static final int LINE_START
沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常开始。等同于水平的、从左到右方向的 WEST，以及水平的、从右到左方向的 EAST。

另请参见：
常量字段值

LINE_END

public static final int LINE_END
沿显示区域的边缘居中放置组件，在该区域中，当前 ComponentOrienation 的文本行正常结束。等同于水平的、从左到右方向的 EAST，以及水平的、从右到左方向的 WEST。

另请参见：
常量字段值

FIRST_LINE_START

public static final int FIRST_LINE_START
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。等同于水平的、从左到右方向的 NORTHWEST，以及水平的、从右到左方向的 NORTHEAST。

另请参见：
常量字段值

FIRST_LINE_END

public static final int FIRST_LINE_END
将组件置于显示区域的一角，在该区域中，当前 ComponentOrienation 的页面的第一个文本行正常结束。等同于水平的、从左到右方向的 NORTHEAST，以及水平的、从右到左方向的 NORTHWEST。

另请参见：
常量字段值

LAST_LINE_START

public static final int LAST_LINE_START
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的开始位置。等同于水平的、从左到右的 SOUTHWEST，以及水平的、从右到左方向的 SOUTHEAST。

另请参见：
常量字段值

LAST_LINE_END

public static final int LAST_LINE_END
将组件置于其显示区域的一角，这一角的位置是页面中最后一个文本行按照当前的 ComponentOrienation 在页面中的结束位置。等同于水平的、从左到右的 SOUTHEAST，以及水平的、从右到左方向的 SOUTHWEST。

另请参见：
常量字段值

BASELINE

public static final int BASELINE
anchor 字段的可能值。指定组件应该沿主要行的基线水平居中和垂直对齐。如果组件没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

BASELINE_LEADING

public static final int BASELINE_LEADING
anchor 字段的可能值。指定组件应沿开始边水平放置。对于从左到右方向的组件，开始边是左边。组件沿主要行的基线垂直对齐。如果组件没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

BASELINE_TRAILING

public static final int BASELINE_TRAILING
anchor 字段的可能值。指定组件应沿结尾边水平放置。对于从左到右方向的组件，结尾边是右边。组件沿主要行的基线垂直对齐。如果组件没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

ABOVE_BASELINE

public static final int ABOVE_BASELINE
anchor 字段的可能值。指定组件应该水平居中对齐。垂直放置组件，使它的底边接触到开始行的基线。如果开始行没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

ABOVE_BASELINE_LEADING

public static final int ABOVE_BASELINE_LEADING
anchor 字段的可能值。指定组件应沿开始边水平放置。对于从左到右方向的组件，开始边是左边。垂直放置组件，使它的底边接触到开始行的基线。如果开始行没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

ABOVE_BASELINE_TRAILING

public static final int ABOVE_BASELINE_TRAILING
anchor 字段的可能值。指定组件应沿结尾边水平放置。对于从左到右方向的组件，结尾边是右边。垂直放置组件，使它的底边接触到开始行的基线。如果开始行没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

BELOW_BASELINE

public static final int BELOW_BASELINE
anchor 字段的可能值。指定组件应该水平居中对齐。垂直放置组件，使它的底边接触到开始行的基线。如果开始行没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

BELOW_BASELINE_LEADING

public static final int BELOW_BASELINE_LEADING
anchor 字段的可能值。指定组件应沿开始边水平放置。对于从左到右方向的组件，开始边是左边。垂直放置组件，使它的底边接触到开始行的基线。如果开始行没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

BELOW_BASELINE_TRAILING

public static final int BELOW_BASELINE_TRAILING
anchor 字段的可能值。指定组件应沿结尾边水平放置。对于从左到右方向的组件，结尾边是右边。垂直放置组件，使它的底边接触到开始行的基线。如果开始行没有基线，那么它会垂直居中对齐。

从以下版本开始：
1.6
另请参见：
常量字段值

gridx

public int gridx
指定包含组件的显示区域开始边的单元格，其中行的第一个单元格为 gridx=0。组件显示区域的开始边指的是水平的、从左到右的容器的左边缘，以及水平的、从右到左的容器的右边缘。值 RELATIVE 指定将组件放置在添加此组件之前刚刚添加到容器中的组件的后面。

默认值为 RELATIVE。gridx 应为非负值。

另请参见：
clone(), gridy, ComponentOrientation

gridy

public int gridy
指定位于组件显示区域的顶部的单元格，其中最上边的单元格为 gridy=0。值 RELATIVE 指定将组件放置在添加此组件之前刚刚添加到容器中的组件的下面。

默认值为 RELATIVE。gridy 应为非负值。

另请参见：
clone(), gridx

gridwidth

public int gridwidth
指定组件显示区域的某一行中的单元格数。

使用 REMAINDER 指定组件的显示区域，该区域的范围是从 gridx 到该行的最后一个单元格。使用 RELATIVE 指定组件的显示区域，该区域的范围是从 gridx 到它所在行的倒数第二个单元格。

gridwidth 应为非负，默认值为 1。

另请参见：
clone(), gridheight

gridheight

public int gridheight
指定在组件显示区域的一列中的单元格数。

使用 REMAINDER 指定组件的显示区域，该区域的范围是从 gridy 到该列的最后一个单元格。使用 RELATIVE 指定组件的显示区域，该区域的范围是从 gridy 到它所在列的倒数第二个单元格。

gridheight 应为非负，默认值为 1。

另请参见：
clone(), gridwidth

weightx

public double weightx
指定如何分布额外的水平空间。

网格包布局管理器计算出列的权重将是列的所有组件中最大的 weightx。如果得到的布局在水平方向上比需要填充的区域小，那么系统会将额外的空间按照其权重比例分布到每一列。权重为零的列不会得到额外的空间。

如果所有的权重都为零，则所有的额外空间都将出现在单元格的网格之间和左右边缘之间。

此字段的默认值为 0。weightx 应为非负值。

另请参见：
clone(), weighty

weighty

public double weighty
指定如何分布额外的垂直空间。

网格包布局管理器计算出行的权重将是行的所有组件中最大的 weighty。如果得到的布局在垂直方向上比需要填充的区域小，则系统会将额外的空间按照其权重比例分布到每一行。权重为零的行不会得到额外的空间。

如果所有的权重都为零，则所有的额外空间都将出现在单元格的网格之间和上下边缘之间。

此字段的默认值为 0。weighty 应为非负值。

另请参见：
clone(), weightx

anchor

public int anchor
当组件小于其显示区域时使用此字段。它可以确定在显示区域中放置组件的位置。

可能的值有三种：相对于方向的值、相对于基线的值和绝对值。相对于方向的值是相对于容器的组件方向属性进行解释的，相对于基线值是相对于基线进行解释的，绝对值则不然。绝对值有：CENTER、NORTH、NORTHEAST、EAST、SOUTHEAST、SOUTH、SOUTHWEST、WEST 和 NORTHWEST。方向相对值有：PAGE_START、PAGE_END、LINE_START、LINE_END、FIRST_LINE_START、FIRST_LINE_END、LAST_LINE_START 和 LAST_LINE_END。相对于基线的值有：BASELINE、BASELINE_LEADING、BASELINE_TRAILING、ABOVE_BASELINE、ABOVE_BASELINE_LEADING、ABOVE_BASELINE_TRAILING、BELOW_BASELINE、BELOW_BASELINE_LEADING 和 BELOW_BASELINE_TRAILING。默认值为 CENTER。

另请参见：
clone(), ComponentOrientation

fill

public int fill
当组件的显示区域大于它所请求的显示区域的大小时使用此字段。它可以确定是否调整组件大小，以及在需要的时候如何进行调整。

以下值适用于 fill：

  • NONE：不调整组件大小。
  • HORIZONTAL：加宽组件，使它在水平方向上填满其显示区域，但是不改变高度。
  • VERTICAL：加高组件，使它在垂直方向上填满其显示区域，但是不改变宽度。
  • BOTH：使组件完全填满其显示区域。

默认值为 NONE。

另请参见：
clone()

insets

public Insets insets
此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。

默认值为 new Insets(0, 0, 0, 0)。

另请参见：
clone()

ipadx

public int ipadx
此字段指定组件的内部填充，即给组件的最小宽度添加多大的空间。组件的宽度至少为其最小宽度加上 ipadx 像素。

默认值为 0。

另请参见：
clone(), ipady

ipady

public int ipady
此字段指定内部填充，即给组件的最小高度添加多大的空间。组件的高度至少为其最小高度加上 ipady 像素。

默认值为 0。

另请参见：
clone(), ipadx
构造方法详细信息

GridBagConstraints

public GridBagConstraints()
创建一个 GridBagConstraint 对象，将其所有字段都设置为默认值。

GridBagConstraints

public GridBagConstraints(int gridx,
                          int gridy,
                          int gridwidth,
                          int gridheight,
                          double weightx,
                          double weighty,
                          int anchor,
                          int fill,
                          Insets insets,
                          int ipadx,
                          int ipady)
创建一个 GridBagConstraints 对象，将其所有字段都设置为传入参数。注：因为使用此构造方法会妨碍源代码的可读性，所以此构造方法仅供自动源代码生成工具使用。

参数：
gridx - 初始 gridx 值。
gridy - 初始 gridy 值。
gridwidth - 初始 gridwidth 值。
gridheight - 初始 gridheight 值。
weightx - 初始 weightx 值。
weighty - 初始 weighty 值。
anchor - 初始 anchor 值。
fill - 初始 fill 值。
insets - 初始 insets 值。
ipadx - 初始 ipadx 值。
ipady - 初始 ipady 值。
从以下版本开始：
1.2
另请参见：
gridx, gridy, gridwidth, gridheight, weightx, weighty, anchor, fill, insets, ipadx, ipady
方法详细信息

clone

public Object clone()
创建此网格包约束（grid bag constraint）的副本。

覆盖：
类 Object 中的 clone
返回：
此网格包约束的副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GridBagLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GridBagLayout

java.lang.Object
    继承者  java.awt.GridBagLayout
所有已实现的接口：
LayoutManager, LayoutManager2, Serializable
public class GridBagLayout
extends Object
implements LayoutManager2, Serializable

GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。每个 GridBagLayout 对象维持一个动态的矩形单元网格，每个组件占用一个或多个这样的单元，该单元被称为显示区域。

每个由 GridBagLayout 管理的组件都与 GridBagConstraints 的实例相关联。Constraints 对象指定组件的显示区域在网格中的具体放置位置，以及组件在其显示区域中的放置方式。除了 Constraints 对象之外，GridBagLayout 还考虑每个组件的最小大小和首选大小，以确定组件的大小。

网格的总体方向取决于容器的 ComponentOrientation 属性。对于水平的从左到右的方向，网格坐标 (0,0) 位于容器的左上角，其中 X 向右递增，Y 向下递增。对于水平的从右到左的方向，网格坐标 (0,0) 位于容器的右上角，其中 X 向左递增，Y 向下递增。

为了有效使用网格包布局，必须自定义与组件关联的一个或多个 GridBagConstraints 对象。可以通过设置一个或多个实例变量来自定义 GridBagConstraints 对象：

GridBagConstraints.gridx、GridBagConstraints.gridy
指定包含组件显示区域的前导角的单元，在此显示区域中，位于网格原点的单元地址是 gridx = 0, gridy = 0。对于水平的从左到右的布局，组件的前导角是其左上角。对于水平的从右到左的布局，组件的前导角是其右上角。使用 GridBagConstraints.RELATIVE（默认值），指定会将组件直接放置在之前刚添加到容器中的组件的后面（沿 X 轴向为 gridx 或 Y 轴向为 gridy）。
GridBagConstraints.gridwidth、GridBagConstraints.gridheight
指定组件的显示区域中行（针对 gridwidth）或列（针对 gridheight）中的单元数。默认值为 1。使用 GridBagConstraints.REMAINDER 指定组件的显示区域，该区域的范围是从 gridx 到该行（针对 gridwidth）中的最后一个单元，或者从 gridy 到该列（针对 gridheight）中的最后一个单元。 使用 GridBagConstraints.RELATIVE 指定组件的显示区域，该区域的范围是从 gridx 到其所在行（针对 gridwidth）的倒数第二个单元，或者从 gridy 到其所在列（针对 gridheight）的倒数第二个单元。
GridBagConstraints.fill
当组件的显示区域大于组件的所需大小时，用于确定是否（以及如何）调整组件。可能的值为 GridBagConstraints.NONE（默认值）、GridBagConstraints.HORIZONTAL（加宽组件直到它足以在水平方向上填满其显示区域，但不更改其高度）、GridBagConstraints.VERTICAL（加高组件直到它足以在垂直方向上填满其显示区域，但不更改其宽度）和 GridBagConstraints.BOTH（使组件完全填满其显示区域）。
GridBagConstraints.ipadx、GridBagConstraints.ipady
指定布局中组件的内部填充，即对组件最小大小的添加量。组件的宽度至少为其最小宽度加上 ipadx 像素。类似地，组件的高度至少为其最小高度加上 ipady 像素。
GridBagConstraints.insets
指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。
GridBagConstraints.anchor
指定组件应置于其显示区域中何处。可能的值有三种：绝对值、相对于方向的值和相对于基线的值。相对于方向的值是相对于容器的 ComponentOrientation 属性进行解释的，而绝对值则不然。相关于基线的值是相对于基线进行计算的。有效值包括：

绝对值 | 相对于方向的值 | 相对于基线的值
GridBagConstraints.NORTH GridBagConstraints.SOUTH GridBagConstraints.WEST GridBagConstraints.EAST GridBagConstraints.NORTHWEST GridBagConstraints.NORTHEAST GridBagConstraints.SOUTHWEST GridBagConstraints.SOUTHEAST GridBagConstraints.CENTER（默认值） | GridBagConstraints.PAGE_START GridBagConstraints.PAGE_END GridBagConstraints.LINE_START GridBagConstraints.LINE_END GridBagConstraints.FIRST_LINE_START GridBagConstraints.FIRST_LINE_END GridBagConstraints.LAST_LINE_START GridBagConstraints.LAST_LINE_END | GridBagConstraints.BASELINE GridBagConstraints.BASELINE_LEADING GridBagConstraints.BASELINE_TRAILING GridBagConstraints.ABOVE_BASELINE GridBagConstraints.ABOVE_BASELINE_LEADING GridBagConstraints.ABOVE_BASELINE_TRAILING GridBagConstraints.BELOW_BASELINE GridBagConstraints.BELOW_BASELINE_LEADING GridBagConstraints.BELOW_BASELINE_TRAILING

GridBagConstraints.weightx、GridBagConstraints.weighty
用于确定分布空间的方式，这对于指定调整行为至关重要。除非在行 (weightx) 和列 (weighty) 中至少指定一个组件的权重，否则所有组件都会聚集在其容器的中央。这是因为，当权重为零（默认值）时，GridBagLayout 对象会将所有额外空间置于其单元网格和容器边缘之间。

每行可以有一条基线，具体取决于该行中具有有效基线并沿此基线对齐的组件（组件的锚值是 BASELINE、BASELINE_LEADING 或 BASELINE_TRAILING 其中之一）。如果行中没有具有有效基线的组件，则该行没有基线。

如果组件跨多行，则它与起始行（如果基线调整行为是 CONSTANT_ASCENT）或结束行（如果基线调整行为是 CONSTANT_DESCENT）的基线对齐。用来对齐组件的行称为主导行。

下图显示了基线布局并包括横跨行的组件：

“对此图形的描述见下文（图
此布局由三个组件组成：
  • 起始于 0 行并结束于 1 行的面板。该面板有一个 CONSTANT_DESCENT 基线调整行为以及 BASELINE 的锚。因为基线调整行为是 CONSTANT_DESCENT，所以该面板的主要行是第 1 行。
  • 两个按钮，每个按钮都带有 CENTER_OFFSET 基线调整行为和 BASELINE 的锚。
因为第二个按钮和面板共享相同的主要行，所以它们都沿其基线对齐。

使用一个相对于基线的值定位的组件调整不同于使用绝对值或相对于方向的值。组件更改的方式由主要行的基线更改方式指示。如果基于相同主导行的所有组件具有 CONSTANT_DESCENT 基线调整行为，则基线定位到显示区域底部；否则，基线定位到显示区域顶部。下述规则指示调整大小的行为：

  • 位于基线上方的可调整大小的组件只能增长到与该基线一样高。例如，如果基线为 100 且位于顶部，则位于基线上方的可调整大小的组件的增长永远都不能超过 100 个单位。
  • 同样地，位于基线下方的可调整大小的组件只能增长到和显示高度与基线之间的差值一样高。
  • 仅当调整了大小的基线适应显示区域时，才能调整基线上具有 OTHER 基线调整行为的可调整大小组件。如果不能将基线放入显示区域，则该组件不能调整大小。
  • 位于该基线上没有 OTHER 基线调整行为的组件只能增长到和显示高度 - 基线 + 组件基线一样高。
如果沿基线放置一个组件，但该组件没有有效的基线，那么它将在其空间中垂直居中对齐。同样地，如果已放置一个相对于基线的组件且行中的所有组件都没有有效的基线，则该组件垂直居中对齐。

下图显示了由网格包布局管理的十个组件（均为按钮）。图 2 显示水平方向从左到右的容器的布局，图 3 显示水平方向从右到左的容器的布局。

对此图形的描述见前文（图 1）。 | 对此图形的描述见前文（图 2）。
图 2：水平方向，从左到右 | 图 3：水平方向，从右到左

十个组件的每一个组件都会将与之相关的 GridBagConstraints 对象的 fill 字段设置为 GridBagConstraints.BOTH。此外，这些组件还具有以下非默认值约束 (Constraints)：

  • Button1、Button2、Button3： weightx = 1.0
  • Button4：weightx = 1.0、gridwidth = GridBagConstraints.REMAINDER
  • Button5：gridwidth = GridBagConstraints.REMAINDER
  • Button6：gridwidth = GridBagConstraints.RELATIVE
  • Button7：gridwidth = GridBagConstraints.REMAINDER
  • Button8：gridheight = 2、weighty = 1.0
  • Button9、Button 10：gridwidth = GridBagConstraints.REMAINDER

下面是实现上述示例的代码：

 import java.awt.*;
 import java.util.*;
 import java.applet.Applet;

 public class GridBagEx1 extends Applet {

     protected void makebutton(String name,
                               GridBagLayout gridbag,
                               GridBagConstraints c) {
         Button button = new Button(name);
         gridbag.setConstraints(button, c);
         add(button);
     }

     public void init() {
         GridBagLayout gridbag = new GridBagLayout();
         GridBagConstraints c = new GridBagConstraints();

         setFont(new Font("SansSerif", Font.PLAIN, 14));
         setLayout(gridbag);

         c.fill = GridBagConstraints.BOTH;
         c.weightx = 1.0;
         makebutton("Button1", gridbag, c);
         makebutton("Button2", gridbag, c);
         makebutton("Button3", gridbag, c);

           c.gridwidth = GridBagConstraints.REMAINDER; //end row
         makebutton("Button4", gridbag, c);

         c.weightx = 0.0;                  //reset to the default
         makebutton("Button5", gridbag, c); //another row

           c.gridwidth = GridBagConstraints.RELATIVE; //next-to-last in row
         makebutton("Button6", gridbag, c);

           c.gridwidth = GridBagConstraints.REMAINDER; //end row
         makebutton("Button7", gridbag, c);

           c.gridwidth = 1;                //reset to the default
           c.gridheight = 2;
         c.weighty = 1.0;
         makebutton("Button8", gridbag, c);

         c.weighty = 0.0;                  //reset to the default
           c.gridwidth = GridBagConstraints.REMAINDER; //end row
           c.gridheight = 1;               //reset to the default
         makebutton("Button9", gridbag, c);
         makebutton("Button10", gridbag, c);

         setSize(300, 100);
     }

     public static void main(String args[]) {
           Frame f = new Frame("GridBag Layout Example");
           GridBagEx1 ex1 = new GridBagEx1();

           ex1.init();

           f.add("Center", ex1);
           f.pack();
           f.setSize(f.getPreferredSize());
           f.show();
     }
 }

从以下版本开始：
JDK1.0
另请参见：
GridBagConstraints, GridBagLayoutInfo, ComponentOrientation, 序列化表格

字段摘要
double[] | columnWeights 此字段保持对列权重的重写。
int[] | columnWidths 此字段保持对列最小宽度的重写。
protected Hashtable<Component,GridBagConstraints> | comptable 此哈希表维持组件与其网格包约束之间的关联。
protected GridBagConstraints | defaultConstraints 此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。
protected GridBagLayoutInfo | layoutInfo 此字段保持网格包的布局信息。
protected static int | MAXGRIDSIZE 此字段不再用于保留数组和保持向后兼容性。
protected static int | MINSIZE 网格包布局可以布置的最小网格。
protected static int | PREFERREDSIZE 网格包布局可以布置的首选网格大小。
int[] | rowHeights 此字段保持对行最小高度的重写。
double[] | rowWeights 此字段保持对行权重的重写。
构造方法摘要
GridBagLayout()
创建网格包布局管理器。
方法摘要
void | addLayoutComponent(Component comp, Object constraints) 使用指定 constraints 对象将指定组件添加到布局中。
void | addLayoutComponent(String name, Component comp) 无效，因为此布局管理器不使用每组件字符串。
protected void | adjustForGravity(GridBagConstraints constraints, Rectangle r) 根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。
protected void | AdjustForGravity(GridBagConstraints constraints, Rectangle r) 此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。
protected void | arrangeGrid(Container parent) 布置网格。
protected void | ArrangeGrid(Container parent) 此方法已过时，仅为提供向后兼容性；新代码应该调用 arrangeGrid 来代替。
GridBagConstraints | getConstraints(Component comp) 获取指定组件的约束。
float | getLayoutAlignmentX(Container parent) 返回沿 X 轴的对齐方式。
float | getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
int[][] | getLayoutDimensions() 确定布局网格的列宽度和行高度。
protected GridBagLayoutInfo | getLayoutInfo(Container parent, int sizeflag) 为当前受管子级的集合填充 GridBagLayoutInfo 的实例。
protected GridBagLayoutInfo | GetLayoutInfo(Container parent, int sizeflag) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。
Point | getLayoutOrigin() 在目标容器的图形坐标空间确定布局区域的原点。
double[][] | getLayoutWeights() 确定布局网格的行与列的权重。
protected Dimension | getMinSize(Container parent, GridBagLayoutInfo info) 基于 getLayoutInfo 中的信息计算其所有者的最小大小。
protected Dimension | GetMinSize(Container parent, GridBagLayoutInfo info) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。
void | invalidateLayout(Container target) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | layoutContainer(Container parent) 使用此网格包布局布置指定容器。
Point | location(int x, int y) 确定在布局网格中哪个单元包含由 (x, y) 指定的点。
protected GridBagConstraints | lookupConstraints(Component comp) 检索指定组件的约束。
Dimension | maximumLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的最大维数
Dimension | minimumLayoutSize(Container parent) 使用此网格包布局确定 parent 容器的最小大小。
Dimension | preferredLayoutSize(Container parent) 使用此网络包布局确定 parent 容器的首选大小。
void | removeLayoutComponent(Component comp) 从此布局移除指定组件。
void | setConstraints(Component comp, GridBagConstraints constraints) 设置此布局中指定组件的约束条件。
String | toString() 返回此网格包布局的值的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

MAXGRIDSIZE

protected static final int MAXGRIDSIZE
此字段不再用于保留数组和保持向后兼容性。以前，此是网格包布局布置的网格位置（既包括水平的位置，也包括垂直的位置）的最大数。当前实现不会对网格大小产生任何影响。

另请参见：
常量字段值

MINSIZE

protected static final int MINSIZE
网格包布局可以布置的最小网格。

另请参见：
常量字段值

PREFERREDSIZE

protected static final int PREFERREDSIZE
网格包布局可以布置的首选网格大小。

另请参见：
常量字段值

comptable

protected Hashtable<Component,GridBagConstraints> comptable
此哈希表维持组件与其网格包约束之间的关联。comptable 中的键是组件，值是 GridBagConstraints 的实例。

另请参见：
GridBagConstraints

defaultConstraints

protected GridBagConstraints defaultConstraints
此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。

另请参见：
getConstraints(Component), setConstraints(Component, GridBagConstraints), lookupConstraints(Component)

layoutInfo

protected GridBagLayoutInfo layoutInfo
此字段保持网格包的布局信息。此字段中的信息基于最近验证的网格包。如果 layoutInfo 为 null，这指示网格包中不存在组件，或者即使存在，也是尚未经过验证的组件。

另请参见：
getLayoutInfo(Container, int)

columnWidths

public int[] columnWidths
此字段保持对列最小宽度的重写。如果此字段为非 null，则在计算全部最小列宽度之后将这些值应用到网格包。如果 columnWidths 的元素数多于列数，则在网格包中添加列以匹配 columnWidth 中的元素数。

另请参见：
getLayoutDimensions()

rowHeights

public int[] rowHeights
此字段保持对行最小高度的重写。如果此字段为非 null，则在计算全部最小行高度之后将这些值应用到网格包。如果 rowHeights 的元素数多于行数，则在网格包中添加行以匹配 rowHeights 中的元素数。

另请参见：
getLayoutDimensions()

columnWeights

public double[] columnWeights
此字段保持对列权重的重写。如果此字段为非 null，则在计算全部列权重之后将这些值应用到网格包。如果 columnWeights[i] 大于列 i 的权重，则将 columnWeights[i] 中的权重分配给列 i。如果 columnWeights 的元素数多于列数，则多余的元素将被忽略——而不会相应地创建更多列。

rowWeights

public double[] rowWeights
此字段保持对行权重的重写。如果此字段为非 null，则在计算全部行权重之后将这些值应用到网格包。如果 rowWeights[i] 大于行 i 的权重，则将 rowWeights[i] 中的权重分配给行 i。如果 rowWeights 的元素多于行数，则多余的元素将被忽略——它们不会导致更多行的创建。

构造方法详细信息

GridBagLayout

public GridBagLayout()
创建网格包布局管理器。

方法详细信息

setConstraints

public void setConstraints(Component comp,
                           GridBagConstraints constraints)
设置此布局中指定组件的约束条件。

参数：
comp - 要修改的组件
constraints - 要应用的约束条件

getConstraints

public GridBagConstraints getConstraints(Component comp)
获取指定组件的约束。返回实际 GridBagConstraints 对象的副本。

参数：
comp - 要查询的组件
返回：
此网格包布局中指定组件的约束；返回实际约束对象的副本

lookupConstraints

protected GridBagConstraints lookupConstraints(Component comp)
检索指定组件的约束。返回值不是副本，而是布局机制使用的实际 GridBagConstraints 对象。

如果 comp 不在 GridBagLayout 中，则返回一组默认的 GridBagConstraints。值为 null 的 comp 值是无效的，返回 null。

参数：
comp - 要查询的组件
返回：
指定组件的约束

getLayoutOrigin

public Point getLayoutOrigin()
在目标容器的图形坐标空间确定布局区域的原点。此值表示布局区域的左上角的像素坐标，不管容器的 ComponentOrientation 值如何。这与单元坐标给定的网格原点 (0,0) 不同。大多数应用程序并不直接调用此方法。

返回：
布局网格左上角的单元的图形原点
从以下版本开始：
JDK1.1
另请参见：
ComponentOrientation

getLayoutDimensions

public int[][] getLayoutDimensions()
确定布局网格的列宽度和行高度。

大多数应用程序并不直接调用此方法。

返回：
一个二维数组，包含布局列的宽度和布局行的高度
从以下版本开始：
JDK1.1

getLayoutWeights

public double[][] getLayoutWeights()
确定布局网格的行与列的权重。如果布局具有额外空间来填充，则权重用于计算给定的行或列可以伸展得超过首选大小多少。

大多数应用程序不直接调用此方法。

返回：
一个二维数组，表示布局列的水平权重和布局行的垂直权重。
从以下版本开始：
JDK1.1

location

public Point location(int x,
                      int y)
确定在布局网格中哪个单元包含由 (x, y) 指定的点。每个单元由其列索引（范围从 0 到列数减 1）和其行索引（范围从 0 到行数减 1）来标识。

如果 (x, y) 点位于网格的外部，则使用以下规则。如果 x 位于从左到右容器布局的左边或位于从右到左容器布局的右边，则列索引的返回值为 0。如果 x 位于从左到右容器布局的右边或位于从右到左容器布局的左边，则列索引的返回值是列数。如果 y 位于布局的上边，则行索引的返回值为零；如果 y 位于布局的下边，则行索引的返回值为行数。容器的方向由其 ComponentOrientation 属性确定。

参数：
x - 点的 x 坐标
y - 点的 y 坐标
返回：
索引的有序对，指示布局网格中的哪个单元包含点 (x,y)。
从以下版本开始：
JDK1.1
另请参见：
ComponentOrientation

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
无效，因为此布局管理器不使用每组件字符串。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
comp - 要添加的组件

addLayoutComponent

public void addLayoutComponent(Component comp,
                               Object constraints)
使用指定 constraints 对象将指定组件添加到布局中。注意，约束条件是可变的，因此缓存时应该复制。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
comp - 要添加的组件
constraints - 确定如何将组件添加到布局的对象
抛出：
IllegalArgumentException - 如果 constraints 不是 GridBagConstraint

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从此布局移除指定组件。

大多数应用程序不直接调用此方法。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件。
另请参见：
Container.remove(java.awt.Component), Container.removeAll()

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
使用此网络包布局确定 parent 容器的首选大小。

大多数应用程序不直接调用此方法。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 在其中进行布局的容器
返回：
parent 容器的首选大小
另请参见：
Container.getPreferredSize()

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
使用此网格包布局确定 parent 容器的最小大小。

大多数应用程序不直接调用此方法。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 在其中进行布局的容器
返回：
parent 容器的最小大小
另请参见：
Container.doLayout()

maximumLayoutSize

public Dimension maximumLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的最大维数

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
参数：
target - 需要布置的容器
返回：
此布局的最大维数
另请参见：
Container, minimumLayoutSize(Container), preferredLayoutSize(Container)

getLayoutAlignmentX

public float getLayoutAlignmentX(Container parent)
返回沿 X 轴的对齐方式。它指定该组件相对于其他组件如何对齐。该值应该是一个介于 0 和 1 之间的数，其中 0 表示沿原点对齐，1 表示按距原点最远的点对齐，0.5 表示居中对齐等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX
返回：
指示居中对齐的值 0.5f

getLayoutAlignmentY

public float getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。它指定该组件相对于其他组件如何对齐。该值应该是一个介于 0 和 1 之间的数，其中 0 表示沿原点对齐，1 表示按距原点最远的点对齐，0.5 表示居中对齐等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY
返回：
指示居中对齐的值 0.5f

invalidateLayout

public void invalidateLayout(Container target)
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。

指定者：
接口 LayoutManager2 中的 invalidateLayout

layoutContainer

public void layoutContainer(Container parent)
使用此网格包布局布置指定容器。为了满足此 GridBagLayout 对象的约束条件，此方法会重塑指定容器中的组件。

大多数应用程序不直接调用此方法。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要在其中进行布局的容器
另请参见：
Container, Container.doLayout()

toString

public String toString()
返回此网格包布局的值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此网格包布局的字符串表示形式。

getLayoutInfo

protected GridBagLayoutInfo getLayoutInfo(Container parent,
                                          int sizeflag)
为当前受管子级的集合填充 GridBagLayoutInfo 的实例。这需要通过子级集合传递三次：
  1. 计算布局网格的维数。
  2. 确定组件占用的单元。
  3. 在行/列中分布权重和最小大小。
第一次遇到子级时，此操作还会将所有子级的最小大小缓存起来（因此后续循环不必再次请求）。

此方法仅供 GridBagLayout 内部使用。

参数：
parent - 布局容器
sizeflag - PREFERREDSIZE 或 MINSIZE
返回：
子级集合的 GridBagLayoutInfo
从以下版本开始：
1.4

GetLayoutInfo

protected GridBagLayoutInfo GetLayoutInfo(Container parent,
                                          int sizeflag)
此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。此方法与 getLayoutInfo 相同；请参阅 getLayoutInfo 以获取参数及返回值的详细信息。

adjustForGravity

protected void adjustForGravity(GridBagConstraints constraints,
                                Rectangle r)
根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。此方法仅供 GridBagLayout 内部使用。

参数：
constraints - 要应用的约束
r - 要调整的 Rectangle
从以下版本开始：
1.4

AdjustForGravity

protected void AdjustForGravity(GridBagConstraints constraints,
                                Rectangle r)
此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。此方法与 adjustForGravity 相同；请参阅 adjustForGravity 以获取参数及返回值的详细信息。

getMinSize

protected Dimension getMinSize(Container parent,
                               GridBagLayoutInfo info)
基于 getLayoutInfo 中的信息计算其所有者的最小大小。此方法仅供 GridBagLayout 内部使用。

参数：
parent - 布局容器
info - 此父级的布局信息
返回：
包含最小大小的 Dimension 对象
从以下版本开始：
1.4

GetMinSize

protected Dimension GetMinSize(Container parent,
                               GridBagLayoutInfo info)
此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。此方法与 getMinSize 相同；请参阅 getMinSize 以获取参数及返回值的详细信息。

arrangeGrid

protected void arrangeGrid(Container parent)
布置网格。此方法仅供 GridBagLayout 内部使用。

参数：
parent - 布局容器
从以下版本开始：
1.4

ArrangeGrid

protected void ArrangeGrid(Container parent)
此方法已过时，仅为提供向后兼容性；新代码应该调用 arrangeGrid 来代替。此方法与 arrangeGrid 相同；请参阅 arrangeGrid 以获取参数及返回值的详细信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GridBagLayoutInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GridBagLayoutInfo

java.lang.Object
    继承者  java.awt.GridBagLayoutInfo
所有已实现的接口：
Serializable
public class GridBagLayoutInfo
extends Object
implements Serializable

GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。它存储容器中每个组件的对齐、大小和基线参数。

从以下版本开始：
1.6
另请参见：
GridBagLayout, GridBagConstraints, 序列化表格

方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GridLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 GridLayout

java.lang.Object
    继承者  java.awt.GridLayout
所有已实现的接口：
LayoutManager, Serializable
public class GridLayout
extends Object
implements LayoutManager, Serializable

GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。容器被分成大小相等的矩形，一个矩形中放置一个组件。例如，下面是一个将六个按钮布置到三行两列中的 applet：

 import java.awt.*;
 import java.applet.Applet;
 public class ButtonGrid extends Applet {
     public void init() {
         setLayout(new GridLayout(3,2));
         add(new Button("1"));
         add(new Button("2"));
         add(new Button("3"));
         add(new Button("4"));
         add(new Button("5"));
         add(new Button("6"));
     }
 }

如果容器的 ComponentOrientation 属性是水平从左到右的，则上述示例生成图 1 中所示的输出。如果容器的 ComponentOrientation 属性是水平从右到左的，则该示例生成图 2 所示的输出。

在 3 行中显示 6 个按钮。第 1 行显示按钮 1 然后是按钮 2。 第 2 行显示按钮 3 然后是按钮 4。第 3 行显示按钮 5 然后是按钮 6。 | 在 3 行中显示 6 个按钮。第 1 行显示按钮 2 然后是按钮 1。 第 2 行显示按钮 4 然后是按钮 3。第 3 行显示按钮 6 然后是按钮 5。
图 1：水平，从左到右 | 图 2：水平，从右到左

通过构造方法或 setRows 和 setColumns 方法将行数和列数都设置为非零值时，指定的列数将被忽略。列数通过指定的行数和布局中的组件总数来确定。因此，例如，如果指定了三行和两列，在布局中添加了九个组件，则它们将显示为三行三列。仅当将行数设置为零时，指定列数才对布局有效。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
GridLayout()
创建具有默认值的网格布局，即每个组件占据一行一列。
GridLayout(int rows, int cols)
创建具有指定行数和列数的网格布局。
GridLayout(int rows, int cols, int hgap, int vgap)
创建具有指定行数和列数的网格布局。
方法摘要
void | addLayoutComponent(String name, Component comp) 将具有指定名称的指定组件添加到布局。
int | getColumns() 获取此布局中的列数。
int | getHgap() 获取组件之间的水平间距。
int | getRows() 获取此布局中的行数。
int | getVgap() 获取组件之间的垂直间距。
void | layoutContainer(Container parent) 使用此布局布置指定容器。
Dimension | minimumLayoutSize(Container parent) 使用此网络布局确定最小大小的容器参数。
Dimension | preferredLayoutSize(Container parent) 使用此网格布局确定容器参数的首选大小。
void | removeLayoutComponent(Component comp) 从布局移除指定组件。
void | setColumns(int cols) 将此布局中的列数设置为指定值。
void | setHgap(int hgap) 将组件之间的水平间距设置为指定值。
void | setRows(int rows) 将此布局中的行数设置为指定值。
void | setVgap(int vgap) 将组件之间的垂直间距设置为指定值。
String | toString() 返回此网格布局的值的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

GridLayout

public GridLayout()
创建具有默认值的网格布局，即每个组件占据一行一列。

从以下版本开始：
JDK1.1

GridLayout

public GridLayout(int rows,
                  int cols)
创建具有指定行数和列数的网格布局。给布局中的所有组件分配相等的大小。

rows 和 cols 中的一个可以为零（但不能两者同时为零），这表示可以将任何数目的对象置于行或列中。

参数：
rows - 该 rows 具有表示任意行数的值零。
cols - 该 cols 具有表示任意列数的值零。

GridLayout

public GridLayout(int rows,
                  int cols,
                  int hgap,
                  int vgap)
创建具有指定行数和列数的网格布局。给布局中的所有组件分配相等的大小。

此外，将水平和垂直间距设置为指定值。水平间距将置于列与列之间。将垂直间距将置于行与行之间。

rows 和 cols 中的一个可以为零（但不能两者同时为零），这表示可以将任何数目的对象置于行或列中。

所有 GridLayout 构造方法都服从这一规定。

参数：
rows - 该 rows 具有表示任意行数的值零
cols - 该 cols 具有表示任意列数的值零
hgap - 水平间距
vgap - 垂直间距
抛出：
IllegalArgumentException - 如果将 rows 和 cols 的值都设置为零
方法详细信息

getRows

public int getRows()
获取此布局中的行数。

返回：
此布局中的行数
从以下版本开始：
JDK1.1

setRows

public void setRows(int rows)
将此布局中的行数设置为指定值。

参数：
rows - 此布局中的行数
抛出：
IllegalArgumentException - 如果将 rows 和 cols 的值都设置为零
从以下版本开始：
JDK1.1

getColumns

public int getColumns()
获取此布局中的列数。

返回：
此布局中的列数
从以下版本开始：
JDK1.1

setColumns

public void setColumns(int cols)
将此布局中的列数设置为指定值。如果构造方法或 setRows 方法指定的行数为非零，则列数的设置对布局没有影响。在这种情况下，布局中显示的列数由组件的总数和指定的行数确定。

参数：
cols - 此布局中的列数
抛出：
IllegalArgumentException - 如果将 rows 和 cols 的值都设置为零
从以下版本开始：
JDK1.1

getHgap

public int getHgap()
获取组件之间的水平间距。

返回：
组件之间的水平间距
从以下版本开始：
JDK1.1

setHgap

public void setHgap(int hgap)
将组件之间的水平间距设置为指定值。

参数：
hgap - 组件之间的水平间距
从以下版本开始：
JDK1.1

getVgap

public int getVgap()
获取组件之间的垂直间距。

返回：
组件之间的垂直间距
从以下版本开始：
JDK1.1

setVgap

public void setVgap(int vgap)
将组件之间的垂直间距设置为指定值。

参数：
vgap - 组件之间的垂直间距
从以下版本开始：
JDK1.1

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
将具有指定名称的指定组件添加到布局。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 组件名
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
使用此网格布局确定容器参数的首选大小。

网络布局的首选宽度等于容器中所有组件的最大首选宽度乘以列数，加上水平填充乘以列数减去一，再加上目标容器的左右 insets。

网络布局的首选高度等于容器中所有组件的最大首选高度乘以行数，加上垂直填充乘以行数减去一，再加上目标容器的上下 insets。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 要在其中进行布局的容器
返回：
布置指定容器子组件的首选维数
另请参见：
minimumLayoutSize(java.awt.Container), Container.getPreferredSize()

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
使用此网络布局确定最小大小的容器参数。

网络布局的最小宽度等于容器中所有组件的最大最小宽度乘以列数，加上水平填充乘以列数减去一，再加上目标容器的左右 insets。

网络布局的最小高度等于容器中所有组件的最大最小高度乘以行数，加上垂直填充乘以行数减去一，再加上目标容器的上下 insets。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 要在其中进行布局的容器
返回：
布置指定容器的子组件所需的最小维数
另请参见：
preferredLayoutSize(java.awt.Container), Container.doLayout()

layoutContainer

public void layoutContainer(Container parent)
使用此布局布置指定容器。

为了满足 GridLayout 对象的约束条件，此方法会重塑指定目标中的组件。

网络布局管理器根据布局中的行数和列数，通过将容器中的自由空间分割成相等大小的部分来确定单个组件的大小。容器的自由空间等于容器的大小减去所有 insets 和所有指定的水平和垂直间距。给网络布局中的所有组件分配相同的大小。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要在其中进行布局的容器
另请参见：
Container, Container.doLayout()

toString

public String toString()
返回此网格布局的值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此网格布局的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HeadlessException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 HeadlessException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.UnsupportedOperationException
                    继承者  java.awt.HeadlessException
所有已实现的接口：
Serializable
public class HeadlessException
extends UnsupportedOperationException

在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
HeadlessException()
HeadlessException(String msg)
方法摘要
 String getMessage()
返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HeadlessException

public HeadlessException()

HeadlessException

public HeadlessException(String msg)
方法详细信息

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalComponentStateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 IllegalComponentStateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.awt.IllegalComponentStateException
所有已实现的接口：
Serializable
public class IllegalComponentStateException
extends IllegalStateException

当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

另请参见：
序列化表格

构造方法摘要
IllegalComponentStateException()
构造不带详细消息的 IllegalComponentStateException。
IllegalComponentStateException(String s)
构造带指定详细消息的 IllegalComponentStateException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalComponentStateException

public IllegalComponentStateException()
构造不带详细消息的 IllegalComponentStateException。详细消息是描述此特定异常的字符串。

IllegalComponentStateException

public IllegalComponentStateException(String s)
构造带指定详细消息的 IllegalComponentStateException。详细消息是描述此特定异常的字符串。

参数：
s - 包含详细消息的 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Image (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Image

java.lang.Object
    继承者  java.awt.Image
直接已知子类：
BufferedImage, VolatileImage
public abstract class Image
extends Object

抽象类 Image 是表示图形图像的所有类的超类。必须以特定于平台的方式获取图像。

从以下版本开始：
JDK1.0

字段摘要
protected float | accelerationPriority 用于加速此图像的优先级。
static int | SCALE_AREA_AVERAGING 使用 Area Averaging 图像缩放算法。
static int | SCALE_DEFAULT 使用默认的图像缩放算法。
static int | SCALE_FAST 选择一种图像缩放算法，在这种缩放算法中，缩放速度比缩放平滑度具有更高的优先级。
static int | SCALE_REPLICATE 使用 ReplicateScaleFilter 类中包含的图像缩放算法。
static int | SCALE_SMOOTH 选择图像平滑度比缩放速度具有更高优先级的图像缩放算法。
static Object | UndefinedProperty 每当获得某个不是为特定图像定义的属性时，应返回 UndefinedProperty 对象。
构造方法摘要
Image()
方法摘要
void | flush() 刷新此 Image 对象正在使用的所有可重构的资源。
float | getAccelerationPriority() 返回加速优先级提示的当前值。
ImageCapabilities | getCapabilities(GraphicsConfiguration gc) 返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。
abstract Graphics | getGraphics() 创建供绘制闭屏图像（off-screen image）使用的图形上下文。
abstract int | getHeight(ImageObserver observer) 确定图像的高度。
abstract Object | getProperty(String name, ImageObserver observer) 通过名称获取此图像的属性。
Image | getScaledInstance(int width, int height, int hints) 创建此图像的缩放版本。
abstract ImageProducer | getSource() 获取生成图像像素的对象。
abstract int | getWidth(ImageObserver observer) 确定图像的宽度。
void | setAccelerationPriority(float priority) 就加速的重要性设置此图像的提示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

accelerationPriority

protected float accelerationPriority
用于加速此图像的优先级。通过 setAccelerationPriority(float) 方法，子类可以随意设置不同的默认优先级，而应用程序可以随意设置特定图像的优先级。

从以下版本开始：
1.5

UndefinedProperty

public static final Object UndefinedProperty
每当获得某个不是为特定图像定义的属性时，应返回 UndefinedProperty 对象。

SCALE_DEFAULT

public static final int SCALE_DEFAULT
使用默认的图像缩放算法。

从以下版本开始：
JDK1.1
另请参见：
常量字段值

SCALE_FAST

public static final int SCALE_FAST
选择一种图像缩放算法，在这种缩放算法中，缩放速度比缩放平滑度具有更高的优先级。

从以下版本开始：
JDK1.1
另请参见：
常量字段值

SCALE_SMOOTH

public static final int SCALE_SMOOTH
选择图像平滑度比缩放速度具有更高优先级的图像缩放算法。

从以下版本开始：
JDK1.1
另请参见：
常量字段值

SCALE_REPLICATE

public static final int SCALE_REPLICATE
使用 ReplicateScaleFilter 类中包含的图像缩放算法。Image 对象可以随意替代不同的过滤器，以执行相同的算法，但它能更高效地集成工具包所提供的图像处理基础设施。

从以下版本开始：
JDK1.1
另请参见：
ReplicateScaleFilter, 常量字段值

SCALE_AREA_AVERAGING

public static final int SCALE_AREA_AVERAGING
使用 Area Averaging 图像缩放算法。图像对象可以随意替代不同的过滤器，以执行相同的算法，但它能更高效地集成工具包所提供的图像基础设施。

从以下版本开始：
JDK1.1
另请参见：
AreaAveragingScaleFilter, 常量字段值
构造方法详细信息

Image

public Image()
方法详细信息

getWidth

public abstract int getWidth(ImageObserver observer)
确定图像的宽度。如果宽度未知，则此方法返回 -1，然后通知指定的 ImageObserver 对象。

参数：
observer - 等待加载图像的对象。
返回：
此图像的宽度，如果宽度未知则返回 -1。
另请参见：
getHeight(java.awt.image.ImageObserver), ImageObserver

getHeight

public abstract int getHeight(ImageObserver observer)
确定图像的高度。如果高度未知，则此方法返回 -1，然后通知指定的 ImageObserver 对象。

参数：
observer - 等待加载图像的对象。
返回：
此图像的高度，如果高度未知则返回 -1。
另请参见：
getWidth(java.awt.image.ImageObserver), ImageObserver

getSource

public abstract ImageProducer getSource()
获取生成图像像素的对象。此方法由图像过滤类和执行图像转换及缩放的方法调用。

返回：
为此图像生成像素的图像生产者。
另请参见：
ImageProducer

getGraphics

public abstract Graphics getGraphics()
创建供绘制闭屏图像（off-screen image）使用的图形上下文。此方法仅供闭屏图像调用。

返回：
绘制闭屏图像的图形上下文。
抛出：
UnsupportedOperationException - 如果为非闭屏图像所调用。
另请参见：
Graphics, Component.createImage(int, int)

getProperty

public abstract Object getProperty(String name,
                                   ImageObserver observer)
通过名称获取此图像的属性。

各种图像格式都定义了自己的私人属性名。如果某属性不是为特定图像定义的，则此方法返回 UndefinedProperty 对象。

如果此图像的属性目前未知，则此方法返回 null，然后通知 ImageObserver 对象。

属性名 "comment" 应该用于存储可选注释，在应用程序中它显示为图像的描述、来源或作者。

参数：
name - 属性名。
observer - 等待加载此图像的对象。
返回：
指定属性的值。
抛出：
NullPointerException - 如果属性名为 null。
另请参见：
ImageObserver, UndefinedProperty

getScaledInstance

public Image getScaledInstance(int width,
                               int height,
                               int hints)
创建此图像的缩放版本。返回一个新的 Image 对象，默认情况下，该对象按指定的 width 和 height 呈现图像。即使已经完全加载了初始源图像，新的 Image 对象也可以被异步加载。

如果 width 或 height 为负数，则替换该值以维持初始图像尺寸的高宽比。如果 width 和 height 都为负，则使用初始图像尺寸。

参数：
width - 将图像缩放到的宽度。
height - 将图像缩放到的高度。
hints - 指示用于图像重新取样的算法类型的标志。
返回：
图像的缩放版本。
抛出：
IllegalArgumentException - 如果 width 或 height 为零。
从以下版本开始：
JDK1.1
另请参见：
SCALE_DEFAULT, SCALE_FAST, SCALE_SMOOTH, SCALE_REPLICATE, SCALE_AREA_AVERAGING

flush

public void flush()
刷新此 Image 对象正在使用的所有可重构的资源。这包括为呈现到屏幕而缓存的所有像素数据，以及用来存储图像数据或像素的所有系统资源（如果可以重新创建它们）。图像被重置为与初始创建时类似的状态，因此如果再次呈现图像，则必须重新创建图像数据或再次从源中获取这些数据。

此方法如何影响特定类型的 Image 对象的示例如下：

  • BufferedImage 对象不改动存储其像素的主要 Raster，但是刷新有关像素的缓存信息，比如上传到用于加速位图的显示硬件的副本。
  • Image 对象由带有 width 和 height 参数的 Component 方法创建，该方法不改动像素的主要缓冲区，但是释放所有缓存的信息，这与对 BufferedImage 对象的操作非常类似。
  • VolatileImage 对象释放其所有像素资源，这些资源包括通常存储在缺乏资源的显示硬件上的主要副本。这些对象稍后可以使用其 validate 方法还原。
  • 卸载从文件、URL 中加载或由 ImageProducer 生成的 Toolkit 和 Component 类创建的 Image 对象，并释放所有本地资源。稍后可在呈现这些对象时根据需要从初始源重新加载它们，就像第一次创建它们时那样。

getCapabilities

public ImageCapabilities getCapabilities(GraphicsConfiguration gc)
返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。这允许程序员查找关于他们已经创建的特定 Image 对象的更多运行时信息。例如，用户可能创建一个 BufferedImage，但是系统所剩显存可能不足以在使用给定 GraphicsConfiguration 时创建该大小的图像，因此尽管该对象一般而言是可加速的，但在使用 GraphicsConfiguration 时它确实不具有该功能。

参数：
gc - GraphicsConfiguration 对象。此参数值为 null 将导致获取默认 GraphicsConfiguration 的图像功能。
返回：
包含使用指定 GraphicsConfiguration 时此 Image 的功能的 ImageCapabilities 对象。
从以下版本开始：
1.5
另请参见：
VolatileImage#getCapabilities()

setAccelerationPriority

public void setAccelerationPriority(float priority)
就加速的重要性设置此图像的提示。此优先级提示用于在确定如何使用稀缺的加速资源（如显存）时与其他 Image 对象的优先级进行比较。如果可能加速此 Image，但在加速时进行该加速的可用资源不足，若可以通过取消加速具有较低优先级的其他图像来释放足够资源，则其他那些 Image 可能为了这一目的而被取消加速。具有相同优先级的图像利用资源的方式是先到先得。

参数：
priority - 介于 0 和 1 之间的值（包括 0 和 1），较大的值指示加速的重要性较高。值 0 意味着永远不应该加速此 Image。其他值用于确定相对于其他 Image 的加速优先级。
抛出：
IllegalArgumentException - 如果 priority 小于零或大于 1。
从以下版本开始：
1.5

getAccelerationPriority

public float getAccelerationPriority()
返回加速优先级提示的当前值。

返回：
介于 0 和 1 之间的值（包括 0 和 1），表示当前优先级值
从以下版本开始：
1.5
另请参见：
setAccelerationPriority
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Insets (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Insets

java.lang.Object
    继承者  java.awt.Insets
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
InsetsUIResource
public class Insets
extends Object
implements Cloneable, Serializable

Insets 对象是容器边界的表示形式。它指定容器必须在其各个边缘留出的空间。这个空间可以是边界、空白空间或标题。

从以下版本开始：
JDK1.0
另请参见：
LayoutManager, Container, 序列化表格

字段摘要
int | bottom 底部的 inset。
int | left 左边的 inset。
int | right 右边的 inset。
int | top 顶部的 inset。
构造方法摘要
Insets(int top, int left, int bottom, int right)
创建并初始化具有指定顶部、左边、底部、右边 inset 的新 Insets 对象。
方法摘要
Object | clone() 创建此对象的副本。
boolean | equals(Object obj) 检查两个 insets 对象是否等价。
int | hashCode() 返回此 Insets 的哈希码。
void | set(int top, int left, int bottom, int right) 将顶部、底部、左边和右边设置为指定值
String | toString() 返回此 Insets 对象的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

top

public int top
顶部的 inset。将此值添加到长方形的 Top，以产生一个新的 Top 位置。

另请参见：
clone()

left

public int left
左边的 inset。将此值添加到长方形的 Left，以产生一个新的 Left 边缘位置。

另请参见：
clone()

bottom

public int bottom
底部的 inset。从长方形的 Bottom 减去此值，以产生一个新的 Bottom 位置。

另请参见：
clone()

right

public int right
右边的 inset。从长方形的 Right 减去此值，以产生一个新的 Right 边缘位置。

另请参见：
clone()
构造方法详细信息

Insets

public Insets(int top,
              int left,
              int bottom,
              int right)
创建并初始化具有指定顶部、左边、底部、右边 inset 的新 Insets 对象。

参数：
top - 顶部的 inset。
left - 左边的 inset。
bottom - 底部的 inset。
right - 右边的 inset。
方法详细信息

set

public void set(int top,
                int left,
                int bottom,
                int right)
将顶部、底部、左边和右边设置为指定值

参数：
top - 顶部的 inset。
left - 左边的 inset。
bottom - 底部的 inset。
right - 右边的 inset。
从以下版本开始：
1.5

equals

public boolean equals(Object obj)
检查两个 insets 对象是否等价。如果两个 Insets 实例的字段 top、left、bottom 和 right 四个整数值都相等，则它们是等价的。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果两个 insets 等价，则返回 true；否则返回 false。
从以下版本开始：
JDK1.1
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 Insets 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Insets 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 Insets 对象的字符串表示形式。此方法仅在进行调试的时候使用，对于不同的实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Object 中的 toString
返回：
此 Insets 对象的字符串表示。

clone

public Object clone()
创建此对象的副本。

覆盖：
类 Object 中的 clone
返回：
此 Insets 对象的副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageCapabilities (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 ImageCapabilities

java.lang.Object
    继承者  java.awt.ImageCapabilities
所有已实现的接口：
Cloneable
public class ImageCapabilities
extends Object
implements Cloneable

图像的功能和属性。

从以下版本开始：
1.4

构造方法摘要
ImageCapabilities(boolean accelerated)
创建用于指定图像功能的新对象。
方法摘要
Object | clone() 创建并返回此对象的一个副本。
boolean | isAccelerated() 如果对象（它的功能封装在此 ImageCapabilities 中）可以被或者已经被 accelerated，则返回 true。
boolean | isTrueVolatile() 如果由此 ImageCapabilities 描述的 VolatileImage 可以丢失其图面，则返回 true。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageCapabilities

public ImageCapabilities(boolean accelerated)
创建用于指定图像功能的新对象。

参数：
accelerated - 是否需要一个 accelerated 图像
方法详细信息

isAccelerated

public boolean isAccelerated()
如果对象（它的功能封装在此 ImageCapabilities 中）可以被或者已经被 accelerated，则返回 true。

返回：
图像是否可以被或者已经被 accelerated。多种特定于平台的方式均可用于加速图像，包括 pixmaps、VRAM、AGP 等。此为常规加速方法（相对于驻留在系统内存中而言）。

isTrueVolatile

public boolean isTrueVolatile()
如果由此 ImageCapabilities 描述的 VolatileImage 可以丢失其图面，则返回 true。

返回：
可变图像是否可以在操作系统的控制下丢失其图面。

clone

public Object clone()
从类 Object 复制的描述
创建并返回此对象的一个副本。“副本”的准确含义可能依赖于对象的类。这样做的目的是，对于任何对象 x，表达式：
x.clone() != x
为 true，表达式：
x.clone().getClass() == x.getClass()
也为 true，但这些并非必须要满足的要求。一般情况下：
x.clone().equals(x)
为 true，但这并非必须要满足的要求。

按照惯例，返回的对象应该通过调用 super.clone 获得。如果一个类及其所有的超类（Object 除外）都遵守此约定，则 x.clone().getClass() == x.getClass()。

按照惯例，此方法返回的对象应该独立于该对象（正被复制的对象）。要获得此独立性，在 super.clone 返回对象之前，有必要对该对象的一个或多个字段进行修改。这通常意味着要复制包含正在被复制对象的内部“深层结构”的所有可变对象，并使用对副本的引用替换对这些对象的引用。如果一个类只包含基本字段或对不变对象的引用，那么通常不需要修改 super.clone 返回的对象中的字段。

Object 类的 clone 方法执行特定的复制操作。首先，如果此对象的类不能实现接口 Cloneable，则会抛出 CloneNotSupportedException。注意，所有的数组都被视为实现接口 Cloneable。否则，此方法会创建此对象的类的一个新实例，并像通过分配那样，严格使用此对象相应字段的内容初始化该对象的所有字段；这些字段的内容没有被自我复制。所以，此方法执行的是该对象的“浅表复制”，而不“深层复制”操作。

Object 类本身不实现接口 Cloneable，所以在类为 Object 的对象上调用 clone 方法将会导致在运行时抛出异常。

覆盖：
类 Object 中的 clone
返回：
此 ImageCapabilities 对象的副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ItemSelectable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 ItemSelectable

所有已知子接口：
ButtonModel
所有已知实现类：
AbstractButton, BasicArrowButton, Checkbox, CheckboxMenuItem, Choice, DefaultButtonModel, JButton, JCheckBox, JCheckBoxMenuItem, JComboBox, JMenu, JMenuItem, JRadioButton, JRadioButtonMenuItem, JToggleButton, JToggleButton.ToggleButtonModel, List, MetalComboBoxButton, MetalScrollButton
public interface ItemSelectable

包含零个或多个可选则项的集合的对象接口。

方法摘要
void | addItemListener(ItemListener l) 添加侦听器，以接收用户更改项状态时的项事件。
Object[] | getSelectedObjects() 返回选定项；如果没有选定的项，则返回 null。
void | removeItemListener(ItemListener l) 移除项侦听器。

方法详细信息

getSelectedObjects

Object[] getSelectedObjects()
返回选定项；如果没有选定的项，则返回 null。

addItemListener

void addItemListener(ItemListener l)
添加侦听器，以接收用户更改项状态时的项事件。以编程方式设置项状态时，不发送项事件。如果 l 为 null，则不抛出异常也不执行操作。

参数：
l - 接收事件的侦听器
另请参见：
ItemEvent

removeItemListener

void removeItemListener(ItemListener l)
移除项侦听器。如果 l 为 null，则不抛出异常也不执行操作。

参数：
l - 正在移除的侦听器
另请参见：
ItemEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobAttributes (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 JobAttributes

java.lang.Object
    继承者  java.awt.JobAttributes
所有已实现的接口：
Cloneable
public final class JobAttributes
extends Object
implements Cloneable

控制打印作业的属性集合。

此类的实例控制份数、默认选择、目标、打印对话框、文件和打印机名称、页面范围、多文档处理（包括整理）和使用此实例的每个打印作业的多页整版（如双面）。在可能的地方属性名遵守 Internet Printing Protocol (IPP) 1.1。在可能的地方属性值部分地遵守 Internet Printing Protocol (IPP) 1.1。

要使用采用内部类类型的方法，需要将引用传递给内部类的常量字段之一。客户端代码无法创建内部类类型的新实例，因为这些类都不具有公共构造方法。例如，将打印对话框类型设置为跨平台的纯 Java 打印对话框，使用以下代码：

 import java.awt.JobAttributes;

 public class PureJavaPrintDialogExample {
     public void setPureJavaPrintDialog(JobAttributes jobAttributes) {
         jobAttributes.setDialog(JobAttributes.DialogType.COMMON);
     }
 }

每个支持 attributeName（默认值）的 IPP 属性都具有相应的 setattributeNameToDefault 方法。未提供默认值字段。

从以下版本开始：
1.3

嵌套类摘要
static class | JobAttributes.DefaultSelectionType 可能的默认选择状态的类型安全的枚举。
static class | JobAttributes.DestinationType 可能的作业目标的类型安全枚举。
static class | JobAttributes.DialogType 显示给用户的可能对话框的类型安全枚举。
static class | JobAttributes.MultipleDocumentHandlingType 可能的多副本处理状态的类型安全枚举。
static class | JobAttributes.SidesType 可能的多页整版的类型安全枚举。
构造方法摘要
JobAttributes()
构造一个具有每个属性的默认值的 JobAttributes 实例。
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。
JobAttributes(JobAttributes obj)
构造一个 JobAttributes 实例，作为所提供的 JobAttributes 的副本。
方法摘要
Object | clone() 创建并返回此 JobAttributes 的一个副本。
boolean | equals(Object obj) 确定两个 JobAttributes 是否相等。
int | getCopies() 返回应用程序应该使用这些属性呈现作业的份数。
JobAttributes.DefaultSelectionType | getDefaultSelection() 指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。
JobAttributes.DestinationType | getDestination() 指定将输出到打印机还是使用这些属性的作业文件。
JobAttributes.DialogType | getDialog() 返回对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。
String | getFileName() 指定使用这些属性的作业的输出文件的文件名。
int | getFromPage() 对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的第一页。
int | getMaxPage() 指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。
int | getMinPage() 指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。
JobAttributes.MultipleDocumentHandlingType | getMultipleDocumentHandling() 为使用这些属性的作业指定多份处理，包括整理。
int[][] | getPageRanges() 对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。
String | getPrinter() 为使用这些属性的作业返回目标打印机。
JobAttributes.SidesType | getSides() 返回对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。
int | getToPage() 对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的最后一页（包括该页）。
int | hashCode() 返回此 JobAttributes 的哈希码值。
void | set(JobAttributes obj) 将此 JobAttributes 的所有属性设置为与 obj 的属性相同的值。
void | setCopies(int copies) 指定应用程序应该使用这些属性呈现作业的份数。
void | setCopiesToDefault() 将应用程序应该使用这些属性呈现作业的份数设置为默认值。
void | setDefaultSelection(JobAttributes.DefaultSelectionType defaultSelection) 指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。
void | setDestination(JobAttributes.DestinationType destination) 指定将输出到打印机还是使用这些属性的作业文件。
void | setDialog(JobAttributes.DialogType dialog) 指定对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。
void | setFileName(String fileName) 指定使用这些属性的作业的输出文件的文件名。
void | setFromPage(int fromPage) 对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的第一页。
void | setMaxPage(int maxPage) 指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。
void | setMinPage(int minPage) 指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。
void | setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling) 为使用这些属性的作业指定多份处理，包括整理。
void | setMultipleDocumentHandlingToDefault() 对于使用这些属性的作业，将多份处理（包括整理）设置为默认值。
void | setPageRanges(int[][] pageRanges) 对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。
void | setPrinter(String printer) 为使用这些属性的作业指定目标打印机。
void | setSides(JobAttributes.SidesType sides) 指定对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。
void | setSidesToDefault() 对于使用这些属性的作业，将如何在打印介质的面上强制应用连续页设置为默认值。
void | setToPage(int toPage) 对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的最后一页（包括该页）。
String | toString() 返回此 JobAttributes 的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobAttributes

public JobAttributes()
构造一个具有每个属性的默认值的 JobAttributes 实例。对话框默认为 DialogType.NATIVE。最小页默认为 1。最大页默认为 Integer.MAX_VALUE。目标默认为 DestinationType.PRINTER。选择默认为 DefaultSelectionType.ALL。份数默认为 1。多文档处理默认为 MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。面默认为 SidesType.ONE_SIDED。文件名默认为 null。

JobAttributes

public JobAttributes(JobAttributes obj)
构造一个 JobAttributes 实例，作为所提供的 JobAttributes 的副本。

参数：
obj - 要复制的 JobAttributes

JobAttributes

public JobAttributes(int copies,
                     JobAttributes.DefaultSelectionType defaultSelection,
                     JobAttributes.DestinationType destination,
                     JobAttributes.DialogType dialog,
                     String fileName,
                     int maxPage,
                     int minPage,
                     JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling,
                     int[][] pageRanges,
                     String printer,
                     JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

参数：
copies - 复制一个大于 0 的整数
defaultSelection - DefaultSelectionType.ALL、DefaultSelectionType.RANGE 和 DefaultSelectionType.SELECTION
destination - DesintationType.FILE 或 DesintationType.PRINTER
dialog - DialogType.COMMON、DialogType.NATIVE 或 DialogType.NONE
fileName - 可能为 null 文件名
maxPage - 大于零且大于或等于 minPage 的整数
minPage - 大于零且小于或等于 maxPage 的整数
multipleDocumentHandling - MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES 或 MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
pageRanges - 两个元素的整数数组的数组；数组的范围被解释为包括两个指定页面以及它们之间的所有页面；范围必须为升序并且一定不能重叠；指定的页码既不能小于 minPage 也不能大于 maxPage；例如：
                (new int[][] { new int[] { 1, 3 }, new int[] { 5, 5 },
                               new int[] { 15, 19 } }),
指定页面 1、2、3、5、15、16、17、18 和 19。注意，(new int[][] { new int[] { 1, 1 }, new int[] { 1, 2 } }) 是一种无效的页面范围设置，因为两个范围重叠
printer - 可能为 null 打印机名称
sides - SidesType.ONE_SIDED、SidesType.TWO_SIDED_LONG_EDGE 或 SidesType.TWO_SIDED_SHORT_EDGE
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件
方法详细信息

clone

public Object clone()
创建并返回此 JobAttributes 的一个副本。

覆盖：
类 Object 中的 clone
返回：
新创建的副本；可以安全地将此 Object 强制转换为 JobAttributes
另请参见：
Cloneable

set

public void set(JobAttributes obj)
将此 JobAttributes 的所有属性设置为与 obj 的属性相同的值。

参数：
obj - 要复制的 JobAttributes

getCopies

public int getCopies()
返回应用程序应该使用这些属性呈现作业的份数。将此属性更新为用户选择的值。

返回：
大于 0 的整数。

setCopies

public void setCopies(int copies)
指定应用程序应该使用这些属性呈现作业的份数。不指定此属性等效于指定 1。

参数：
copies - 复制一个大于 0 的整数
抛出：
IllegalArgumentException - 如果 copies 小于或等于 0

setCopiesToDefault

public void setCopiesToDefault()
将应用程序应该使用这些属性呈现作业的份数设置为默认值。默认份数为 1。

getDefaultSelection

public JobAttributes.DefaultSelectionType getDefaultSelection()
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。将此属性更新为用户选择的值。

返回：
DefaultSelectionType.ALL、DefaultSelectionType.RANGE 或 DefaultSelectionType.SELECTION

setDefaultSelection

public void setDefaultSelection(JobAttributes.DefaultSelectionType defaultSelection)
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。不指定此属性等效于指定 DefaultSelectionType.ALL。

参数：
defaultSelection - DefaultSelectionType.ALL、DefaultSelectionType.RANGE 或 DefaultSelectionType.SELECTION。
抛出：
IllegalArgumentException - 如果 defaultSelection 为 null

getDestination

public JobAttributes.DestinationType getDestination()
指定将输出到打印机还是使用这些属性的作业文件。将此属性更新为用户选择的值。

返回：
DesintationType.FILE 或 DesintationType.PRINTER

setDestination

public void setDestination(JobAttributes.DestinationType destination)
指定将输出到打印机还是使用这些属性的作业文件。不指定此属性等效于指定 DesintationType.PRINTER。

参数：
destination - DesintationType.FILE 或 DesintationType.PRINTER。
抛出：
IllegalArgumentException - 如果目标为 null。

getDialog

public JobAttributes.DialogType getDialog()
返回对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。DialogType.COMMON 表示跨平台的纯 Java 打印对话框。DialogType.NATIVE 表示平台的本机打印对话框。如果平台不支持本机打印对话框，则显示纯 Java 打印对话框。DialogType.NONE 指定无打印对话框（即后台打印）。任何实现或目标打印机都不能修改此属性，也不能对其加以限制。

返回：
DialogType.COMMON、DialogType.NATIVE 或 DialogType.NONE

setDialog

public void setDialog(JobAttributes.DialogType dialog)
指定对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。DialogType.COMMON 表示跨平台的纯 Java 打印对话框。DialogType.NATIVE 表示平台的本机打印对话框。如果平台不支持本机打印对话框，则显示纯 Java 打印对话框。DialogType.NONE 指定无打印对话框（即后台打印）。不指定此属性等效于指定 DialogType.NATIVE。

参数：
dialog - DialogType.COMMON、DialogType.NATIVE 或 DialogType.NONE。
抛出：
IllegalArgumentException - 如果对话框为 null。

getFileName

public String getFileName()
指定使用这些属性的作业的输出文件的文件名。将此属性更新为用户选择的值。

返回：
可能为 null 文件名

setFileName

public void setFileName(String fileName)
指定使用这些属性的作业的输出文件的文件名。默认为依赖于平台并且随实现而定。

参数：
fileName - 可能为 null 文件名。

getFromPage

public int getFromPage()
对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的第一页。将此属性更新为用户选择的值。应用程序应该忽略此输出属性，除非 getDefaultSelection 方法的返回值为 DefaultSelectionType.RANGE。如有可能，应用程序应该优先使用 getPageRanges 的返回值而不是此方法的返回值。

返回：
大于零且小于或等于 toPage 并且大于或等于 minPage 且小于或等于 maxPage 的整数。

setFromPage

public void setFromPage(int fromPage)
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的第一页。如果未指定此属性，则使用 pageRanges 属性的值。如果指定 pageRanges，同时指定 fromPage 和 toPage 的其中之一或两者，则优先使用 pageRanges。如果不指定 pageRanges、fromPage 或 toPage 中的任何一个，则等效于调用 setPageRanges(new int[][] { new int[] { minPage } })；

参数：
fromPage - 大于零且小于或等于 toPage 并且大于或等于 minPage 且小于或等于 maxPage 的整数。
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件。

getMaxPage

public int getMaxPage()
指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。任何实现或目标打印机都不能修改此属性，也不能对其加以限制。

返回：
大于零且大于或等于 minPage 的整数。

setMaxPage

public void setMaxPage(int maxPage)
指定对于使用这些属性的作业，用户可以指定为要打印的最后一页的最大值。不指定此属性等效于指定 Integer.MAX_VALUE。

参数：
maxPage - 大于零且大于或等于 minPage 的整数
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件

getMinPage

public int getMinPage()
指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。任何实现或目标打印机都不能修改此属性，也不能对其加以限制。

返回：
大于零且小于或等于 maxPage 的整数。

setMinPage

public void setMinPage(int minPage)
指定对于使用这些属性的作业，用户可以指定为要打印的第一页的最小值。不指定此属性等效于指定 1。

参数：
minPage - 大于零且小于或等于 maxPage 的整数。
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件。

getMultipleDocumentHandling

public JobAttributes.MultipleDocumentHandlingType getMultipleDocumentHandling()
为使用这些属性的作业指定多份处理，包括整理。将此属性更新为用户选择的值。

返回：
MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES 或 MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。

setMultipleDocumentHandling

public void setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling)
为使用这些属性的作业指定多份处理，包括整理。不指定此属性等效于指定 MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。

参数：
multipleDocumentHandling - MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES 或 MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。
抛出：
IllegalArgumentException - 如果 multipleDocumentHandling 为 null。

setMultipleDocumentHandlingToDefault

public void setMultipleDocumentHandlingToDefault()
对于使用这些属性的作业，将多份处理（包括整理）设置为默认值。默认处理为 MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES。

getPageRanges

public int[][] getPageRanges()
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。范围中的所有数字都包括在内。将此属性更新为用户选择的值。应用程序应该忽略此输出属性，除非 getDefaultSelection 方法的返回值为 DefaultSelectionType.RANGE。

返回：
两个元素的整数数组的数组。数组的范围被解释为包括两个指定页面以及它们之间的所有页面。范围必须为升序并且一定不能重叠。指定的页码不能小于 minPage，也不能大于 maxPage。例如：(new int[][] { new int[] { 1, 3 }, new int[] { 5, 5 }, new int[] { 15, 19 } }) 指定页面 1、2、3、5、15、16、17、18 和 19。

setPageRanges

public void setPageRanges(int[][] pageRanges)
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的页面范围。范围中的所有数字都包括在内。如果未指定此属性，则使用 fromPage 和 toPages 属性的值。如果指定 pageRanges，同时指定 fromPage 和 toPage 的其中之一或两者，则优先使用 pageRanges。如果不指定 pageRanges、fromPage 和 toPage 中的任何一个，则等效于调用 setPageRanges(new int[][] { new int[] { minPage, minPage } })；

参数：
pageRanges - 两个元素的整数数组的数组。数组的范围被解释为包括两个指定页面以及它们之间的所有页面。范围必须为升序并且一定不能重叠。指定的页码不能小于 minPage，也不能大于 maxPage。例如：(new int[][] { new int[] { 1, 3 }, new int[] { 5, 5 }, new int[] { 15, 19 } }) 指定页面 1、2、3、5、15、16、17、18 和 19。注意，(new int[][] { new int[] { 1, 1 }, new int[] { 1, 2 } }) 是一种页面范围的无效设置，因为两个范围重叠。
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件。

getPrinter

public String getPrinter()
为使用这些属性的作业返回目标打印机。将此属性更新为用户选择的值。

返回：
可能为 null 打印机名称。

setPrinter

public void setPrinter(String printer)
为使用这些属性的作业指定目标打印机。默认为依赖于平台并且随实现而定。

参数：
printer - 可能为 null 打印机名称。

getSides

public JobAttributes.SidesType getSides()
返回对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。SidesType.ONE_SIDED 将每个连续页强制应用于连续介质纸张的同一面。这种整版有时称为 simplex。SidesType.TWO_SIDED_LONG_EDGE 将每个连续页对应用于连续介质纸张的前后两面，以便介质上的每个页对方向正对着读者，就好像绑定在长边上一样。这种整版有时称为 duplex。SidesType.TWO_SIDED_SHORT_EDGE 将每个连续页对应用于连续介质纸张的前后两面，以便介质上的每个页对方向正对着读者，就好像绑定在短边上一样。这种整版有时称为 tumble。将此属性更新为用户选择的值。

返回：
SidesType.ONE_SIDED、SidesType.TWO_SIDED_LONG_EDGE 或 SidesType.TWO_SIDED_SHORT_EDGE。

setSides

public void setSides(JobAttributes.SidesType sides)
指定对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。SidesType.ONE_SIDED 将每个连续页强制应用于连续介质表的同一面。这种整版有时称为 simplex。SidesType.TWO_SIDED_LONG_EDGE 将每个连续页对应用于连续介质纸张的前后两面，以便介质上的每个页对方向正对着读者，就好像绑定在长边上一样。这种整版有时称为 duplex。SidesType.TWO_SIDED_SHORT_EDGE 将每个连续页对应用于连续介质纸张的前后两面，以便介质上的每个页对方向正对着读者，就好像绑定在短边上一样。这种整版有时称为 tumble。不指定此属性等效于指定 SidesType.ONE_SIDED。

参数：
sides - SidesType.ONE_SIDED、SidesType.TWO_SIDED_LONG_EDGE 或 SidesType.TWO_SIDED_SHORT_EDGE。
抛出：
IllegalArgumentException - 如果面为 null。

setSidesToDefault

public void setSidesToDefault()
对于使用这些属性的作业，将如何在打印介质的面上强制应用连续页设置为默认值。默认的整版为 SidesType.ONE_SIDED。

getToPage

public int getToPage()
对于使用这些属性的作业，如果要打印某个范围的页面，则返回要打印的最后一页（包括该页）。将此属性更新为用户选择的值。应用程序应该忽略此输出属性，除非 getDefaultSelection 方法的返回值是 DefaultSelectionType.RANGE。如果可能，应用程序应该优先使用 getPageRanges 的返回值而不用此方法的返回值。

返回：
大于零且大于或等于 toPage 并且大于或等于 minPage 且小于或等于 maxPage 的整数。

setToPage

public void setToPage(int toPage)
对于使用这些属性的作业，如果要打印某个范围的页面，则指定要打印的最后一页（包括该页）。如果未指定此属性，则使用 pageRanges 属性的值。如果指定 pageRanges，同时指定 fromPage 和 toPage 的其中之一或两者，则优先使用 pageRanges。如果不指定 pageRanges、fromPage 和 toPage 中的任何一个，则等效于调用 setPageRanges(new int[][] { new int[] { minPage } })；

参数：
toPage - 大于零且大于或等于 fromPage 并且大于或等于 minPage 且小于或等于 maxPage 的整数。
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件。

equals

public boolean equals(Object obj)
确定两个 JobAttributes 是否相等。

当且仅当两个 JobAttributes 的每个属性都相等时，这两个 JobAttributes 才相等。当且仅当字段都引用同一个惟一枚举对象时，枚举类型的属性才相等。当且仅当范围集合长度相等，每个范围枚举相同的页面并且这些范围顺序都相同时，页面范围的集合才相等。

覆盖：
类 Object 中的 equals
参数：
obj - 将检查其相等性的对象。
返回：
obj 是否等于此 JobAttribute，遵循上述标准。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 JobAttributes 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 JobAttributes 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobAttributes.DefaultSelectionType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 JobAttributes.DefaultSelectionType

java.lang.Object
    继承者  java.awt.JobAttributes.DefaultSelectionType
正在封闭类：
JobAttributes
public static final class JobAttributes.DefaultSelectionType
extends Object

可能的默认选择状态的类型安全的枚举。

从以下版本开始：
1.3

字段摘要
static JobAttributes.DefaultSelectionType | ALL 用于指定应该打印全部作业页面的 DefaultSelectionType 实例。
static JobAttributes.DefaultSelectionType | RANGE 用于指定应该打印一定范围的作业页面的 DefaultSelectionType 实例。
static JobAttributes.DefaultSelectionType | SELECTION 用于指定应该打印当前选择作业页面的 DefaultSelectionType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ALL

public static final JobAttributes.DefaultSelectionType ALL
用于指定应该打印全部作业页面的 DefaultSelectionType 实例。

RANGE

public static final JobAttributes.DefaultSelectionType RANGE
用于指定应该打印一定范围的作业页面的 DefaultSelectionType 实例。

SELECTION

public static final JobAttributes.DefaultSelectionType SELECTION
用于指定应该打印当前选择作业页面的 DefaultSelectionType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobAttributes.DestinationType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 JobAttributes.DestinationType

java.lang.Object
    继承者  java.awt.JobAttributes.DestinationType
正在封闭类：
JobAttributes
public static final class JobAttributes.DestinationType
extends Object

可能的作业目标的类型安全枚举。

从以下版本开始：
1.3

字段摘要
static JobAttributes.DestinationType | FILE 用于指定打印到文件的 DestinationType 实例。
static JobAttributes.DestinationType | PRINTER 用于指定打印到打印机的 DestinationType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

FILE

public static final JobAttributes.DestinationType FILE
用于指定打印到文件的 DestinationType 实例。

PRINTER

public static final JobAttributes.DestinationType PRINTER
用于指定打印到打印机的 DestinationType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobAttributes.DialogType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 JobAttributes.DialogType

java.lang.Object
    继承者  java.awt.JobAttributes.DialogType
正在封闭类：
JobAttributes
public static final class JobAttributes.DialogType
extends Object

显示给用户的可能对话框的类型安全枚举。

从以下版本开始：
1.3

字段摘要
static JobAttributes.DialogType | COMMON 用于指定跨平台的纯 Java 打印对话框的 DialogType 实例。
static JobAttributes.DialogType | NATIVE 用于指定平台的本机打印对话框的 DialogType 实例。
static JobAttributes.DialogType | NONE 用于指定无打印对话框的 DialogType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

COMMON

public static final JobAttributes.DialogType COMMON
用于指定跨平台的纯 Java 打印对话框的 DialogType 实例。

NATIVE

public static final JobAttributes.DialogType NATIVE
用于指定平台的本机打印对话框的 DialogType 实例。

NONE

public static final JobAttributes.DialogType NONE
用于指定无打印对话框的 DialogType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobAttributes.MultipleDocumentHandlingType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 JobAttributes.MultipleDocumentHandlingType

java.lang.Object
    继承者  java.awt.JobAttributes.MultipleDocumentHandlingType
正在封闭类：
JobAttributes
public static final class JobAttributes.MultipleDocumentHandlingType
extends Object

可能的多副本处理状态的类型安全枚举。使用它可以控制单个文档的多副本表格的整理方式。

从以下版本开始：
1.3

字段摘要
static JobAttributes.MultipleDocumentHandlingType | SEPARATE_DOCUMENTS_COLLATED_COPIES 用于指定应该将作业分成单独的、已整理的副本的 MultipleDocumentHandlingType 实例。
static JobAttributes.MultipleDocumentHandlingType | SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 用于指定应该将作业分成单独的、未整理的副本的 MultipleDocumentHandlingType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

SEPARATE_DOCUMENTS_COLLATED_COPIES

public static final JobAttributes.MultipleDocumentHandlingType SEPARATE_DOCUMENTS_COLLATED_COPIES
用于指定应该将作业分成单独的、已整理的副本的 MultipleDocumentHandlingType 实例。

SEPARATE_DOCUMENTS_UNCOLLATED_COPIES

public static final JobAttributes.MultipleDocumentHandlingType SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
用于指定应该将作业分成单独的、未整理的副本的 MultipleDocumentHandlingType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobAttributes.SidesType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 JobAttributes.SidesType

java.lang.Object
    继承者  java.awt.JobAttributes.SidesType
正在封闭类：
JobAttributes
public static final class JobAttributes.SidesType
extends Object

可能的多页整版的类型安全枚举。这些整版符合 IPP 1.1。

从以下版本开始：
1.3

字段摘要
static JobAttributes.SidesType | ONE_SIDED SidesType 实例用于指定应该在连续介质纸张的同一面打印连续作业页面。
static JobAttributes.SidesType | TWO_SIDED_LONG_EDGE SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在长边上一样。
static JobAttributes.SidesType | TWO_SIDED_SHORT_EDGE SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在短边上一样。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ONE_SIDED

public static final JobAttributes.SidesType ONE_SIDED
SidesType 实例用于指定应该在连续介质纸张的同一面打印连续作业页面。

TWO_SIDED_LONG_EDGE

public static final JobAttributes.SidesType TWO_SIDED_LONG_EDGE
SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在长边上一样。

TWO_SIDED_SHORT_EDGE

public static final JobAttributes.SidesType TWO_SIDED_SHORT_EDGE
SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在短边上一样。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyboardFocusManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 KeyboardFocusManager

java.lang.Object
    继承者  java.awt.KeyboardFocusManager
所有已实现的接口：
KeyEventDispatcher, KeyEventPostProcessor
直接已知子类：
DefaultKeyboardFocusManager
public abstract class KeyboardFocusManager
extends Object
implements KeyEventDispatcher, KeyEventPostProcessor

KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。焦点所有者的定义是：应用程序中的 Component，通常接收用户生成的所有 KeyEvent。聚焦 Window 指本身就是（或者包含）焦点所有者的 Window。只有 Frame 或 Dialog 才能成为活动 Window。本机的窗口操作系统可能使用特殊装饰（如高亮显示标题栏）来表示活动 Window 或其子窗口。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

KeyboardFocusManager 既是一个用于查询焦点所有者并启动焦点更改的客户端代码的集中位置，同时又是一个用于所有 FocusEvent、与焦点相关的 WindowEvent 和 KeyEvent 的调度程序。

有些浏览器将使用不同代码基数的 applet 划分为单独的上下文，并在这些上下文之间建墙分隔。在此方案中，每个上下文都将具有一个 KeyboardFocusManager。其他浏览器将所有 applet 置于同一个上下文中，这意味着仅存在一个用于所有 applet 的全局 KeyboardFocusManager。此行为是依赖于实现的。请参考浏览器文档以获取更多信息。然而，不管可能有多少上下文，每个 ClassLoader 的焦点所有者、聚焦 Window 或活动 Window 只能有一个。

请参见 How to Use the Focus Subsystem（The Java Tutorial 的一节）和 Focus Specification 以获取更多信息。

从以下版本开始：
1.4
另请参见：
Window, Frame, Dialog, FocusEvent, WindowEvent, KeyEvent

字段摘要
static int | BACKWARD_TRAVERSAL_KEYS Backward 焦点遍历键的标识符。
static int | DOWN_CYCLE_TRAVERSAL_KEYS Down Cycle 焦点遍历键的标识符。
static int | FORWARD_TRAVERSAL_KEYS Forward 焦点遍历键的标识符。
static int | UP_CYCLE_TRAVERSAL_KEYS Up Cycle 焦点遍历键的标识符。
构造方法摘要
KeyboardFocusManager()
初始化 KeyboardFocusManager。
方法摘要
void | addKeyEventDispatcher(KeyEventDispatcher dispatcher) 将 KeyEventDispatcher 添加到此 KeyboardFocusManager 的调度程序链中。
void | addKeyEventPostProcessor(KeyEventPostProcessor processor) 将 KeyEventPostProcessor 添加到此 KeyboardFocusManager 的后处理器链中。
void | addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到特定属性的侦听器列表。
void | addVetoableChangeListener(String propertyName, VetoableChangeListener listener) 将 VetoableChangeListener 添加到特定属性的侦听器列表。
void | addVetoableChangeListener(VetoableChangeListener listener) 将 VetoableChangeListener 添加到侦听器列表。
void | clearGlobalFocusOwner() 在 Java 和本机级别清除全局焦点所有者。
protected abstract void | dequeueKeyEvents(long after, Component untilFocused) 由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
protected abstract void | discardKeyEvents(Component comp) 由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
abstract boolean | dispatchEvent(AWTEvent e) AWT 事件调度程序可以调用此方法，请求当前的 KeyboardFocusManager 为其指派指定的事件。
abstract boolean | dispatchKeyEvent(KeyEvent e) 通常情况下，如果该指派程序链中的其他 KeyEventDispatcher 没有指派 KeyEvent 或者没有注册其他 KeyEventDispatcher，则 dispatchEvent 将调用此方法。
void | downFocusCycle() 当且仅当当前焦点所有者是一个作为焦点循环根的 Container 时，从当前焦点所有者将焦点下移一个焦点遍历循环。
abstract void | downFocusCycle(Container aContainer) 将焦点下移一个焦点遍历循环。
protected abstract void | enqueueKeyEvents(long after, Component untilFocused) 在指定的 Component 成为焦点所有者以前由 AWT 调用，以通知 KeyboardFocusManager 延迟指派 KeyEvent。
protected void | firePropertyChange(String propertyName, Object oldValue, Object newValue) 激发 PropertyChangeEvent 以响应绑定属性中的更改。
protected void | fireVetoableChange(String propertyName, Object oldValue, Object newValue) 激发 PropertyChangeEvent 以响应可否决属性中的更改。
void | focusNextComponent() 聚焦当前焦点所有者之后的 Component。
abstract void | focusNextComponent(Component aComponent) 聚焦 aComponent 之后的 Component，通常基于 FocusTraversalPolicy。
void | focusPreviousComponent() 聚焦当前焦点所有者之前的 Component。
abstract void | focusPreviousComponent(Component aComponent) 聚焦 aComponent 之前的 Component，通常基于 FocusTraversalPolicy。
Window | getActiveWindow() 如果活动 Window 与调用线程位于同一个上下文中，则返回活动 Window。
Container | getCurrentFocusCycleRoot() 如果当前焦点循环根与调用线程位于相同的上下文中，则返回当前焦点循环根。
static KeyboardFocusManager | getCurrentKeyboardFocusManager() 返回调用线程上下文的当前 KeyboardFocusManager 实例。
Set<AWTKeyStroke> | getDefaultFocusTraversalKeys(int id) 返回给定遍历操作的默认焦点遍历键的 Set。
FocusTraversalPolicy | getDefaultFocusTraversalPolicy() 返回默认 FocusTraversalPolicy。
Window | getFocusedWindow() 如果聚焦窗口与调用线程位于同一个上下文中，则返回聚焦窗口。
Component | getFocusOwner() 如果焦点所有者与调用线程位于同一个上下文中，则返回该焦点所有者。
protected Window | getGlobalActiveWindow() 返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。
protected Container | getGlobalCurrentFocusCycleRoot() 返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。
protected Window | getGlobalFocusedWindow() 返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。
protected Component | getGlobalFocusOwner() 返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。
protected Component | getGlobalPermanentFocusOwner() 返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。
protected List<KeyEventDispatcher> | getKeyEventDispatchers() 作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。
protected List<KeyEventPostProcessor> | getKeyEventPostProcessors() 作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。
Component | getPermanentFocusOwner() 如果持久焦点所有者与调用线程位于同一个上下文中，则返回持久焦点所有者。
PropertyChangeListener[] | getPropertyChangeListeners() 返回在此键盘焦点管理器上注册的所有属性更改侦听器组成的数组。
PropertyChangeListener[] | getPropertyChangeListeners(String propertyName) 返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。
VetoableChangeListener[] | getVetoableChangeListeners() 返回在此键盘焦点管理器上注册的所有可否决更改侦听器组成的数组。
VetoableChangeListener[] | getVetoableChangeListeners(String propertyName) 返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。
abstract boolean | postProcessKeyEvent(KeyEvent e) dispatchKeyEvent 将调用此方法。
abstract void | processKeyEvent(Component focusedComponent, KeyEvent e) 当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。
void | redispatchEvent(Component target, AWTEvent e) 重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。
void | removeKeyEventDispatcher(KeyEventDispatcher dispatcher) 移除以前添加到此 KeyboardFocusManager 调度程序链中的 KeyEventDispatcher。
void | removeKeyEventPostProcessor(KeyEventPostProcessor processor) 从此 KeyboardFocusManager 的后处理器链中移除以前添加的 KeyEventPostProcessor。
void | removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从特定属性的侦听器列表移除 PropertyChangeListener。
void | removeVetoableChangeListener(String propertyName, VetoableChangeListener listener) 从特定属性的侦听器列表移除 VetoableChangeListener。
void | removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除 VetoableChangeListener。
static void | setCurrentKeyboardFocusManager(KeyboardFocusManager newManager) 设置调用线程上下文的当前 KeyboardFocusManager 实例。
void | setDefaultFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 设置给定遍历操作的默认焦点遍历键。
void | setDefaultFocusTraversalPolicy(FocusTraversalPolicy defaultPolicy) 设置默认 FocusTraversalPolicy。
protected void | setGlobalActiveWindow(Window activeWindow) 设置活动 Window。
void | setGlobalCurrentFocusCycleRoot(Container newFocusCycleRoot) 设置当前焦点循环根。
protected void | setGlobalFocusedWindow(Window focusedWindow) 设置聚焦 Window。
protected void | setGlobalFocusOwner(Component focusOwner) 设置焦点所有者。
protected void | setGlobalPermanentFocusOwner(Component permanentFocusOwner) 设置持久焦点所有者。
void | upFocusCycle() 从当前焦点所有者将焦点上移一个焦点遍历循环。
abstract void | upFocusCycle(Component aComponent) 将焦点上移一个焦点遍历循环。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FORWARD_TRAVERSAL_KEYS

public static final int FORWARD_TRAVERSAL_KEYS
Forward 焦点遍历键的标识符。

另请参见：
setDefaultFocusTraversalKeys(int, java.util.Set), getDefaultFocusTraversalKeys(int), Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int), 常量字段值

BACKWARD_TRAVERSAL_KEYS

public static final int BACKWARD_TRAVERSAL_KEYS
Backward 焦点遍历键的标识符。

另请参见：
setDefaultFocusTraversalKeys(int, java.util.Set), getDefaultFocusTraversalKeys(int), Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int), 常量字段值

UP_CYCLE_TRAVERSAL_KEYS

public static final int UP_CYCLE_TRAVERSAL_KEYS
Up Cycle 焦点遍历键的标识符。

另请参见：
setDefaultFocusTraversalKeys(int, java.util.Set), getDefaultFocusTraversalKeys(int), Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int), 常量字段值

DOWN_CYCLE_TRAVERSAL_KEYS

public static final int DOWN_CYCLE_TRAVERSAL_KEYS
Down Cycle 焦点遍历键的标识符。

另请参见：
setDefaultFocusTraversalKeys(int, java.util.Set), getDefaultFocusTraversalKeys(int), Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int), 常量字段值
构造方法详细信息

KeyboardFocusManager

public KeyboardFocusManager()
初始化 KeyboardFocusManager。

方法详细信息

getCurrentKeyboardFocusManager

public static KeyboardFocusManager getCurrentKeyboardFocusManager()
返回调用线程上下文的当前 KeyboardFocusManager 实例。

返回：
此线程上下文的 KeyboardFocusManager
另请参见：
setCurrentKeyboardFocusManager(java.awt.KeyboardFocusManager)

setCurrentKeyboardFocusManager

public static void setCurrentKeyboardFocusManager(KeyboardFocusManager newManager)
                                           throws SecurityException
设置调用线程上下文的当前 KeyboardFocusManager 实例。如果指定了 null，则使用 DefaultKeyboardFocusManager 的新实例替换当前 KeyboardFocusManager。

如果安装了 SecurityManager，则必须授予调用线程 AWTPermission "replaceKeyboardFocusManager" 才能替换当前 KeyboardFocusManager。如果未授予该权限，则此方法将抛出 SecurityException，而当前的 KeyboardFocusManager 不会改变。

参数：
newManager - 此线程上下文的新 KeyboardFocusManager
抛出：
SecurityException - 如果调用线程不具有替换当前 KeyboardFocusManager 的权限
另请参见：
getCurrentKeyboardFocusManager(), DefaultKeyboardFocusManager

getFocusOwner

public Component getFocusOwner()
如果焦点所有者与调用线程位于同一个上下文中，则返回该焦点所有者。焦点所有者的定义是：应用程序中的 Component，通常用户生成的所有 KeyEvent 都被接收。如果为焦点所有者启用了焦点遍历键，则不会传递映射到焦点所有者的焦点遍历键的 KeyEvent。此外，KeyEventDispatcher 在到达焦点所有者之前可能重定向或使用 KeyEvent。

返回：
焦点所有者；如果焦点所有者调用的不是线程上下文的成员，则返回 null
另请参见：
getGlobalFocusOwner(), setGlobalFocusOwner(java.awt.Component)

getGlobalFocusOwner

protected Component getGlobalFocusOwner()
                                 throws SecurityException
返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。焦点所有者的定义是：应用程序中的 Component，通常接收用户生成的所有 KeyEvent。如果为焦点所有者启用了焦点遍历键，则不会传递映射到焦点所有者的焦点遍历键的 KeyEvent。此外，KeyEventDispatcher 在到达焦点所有者之前可能重定向或使用 KeyEvent。

如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager，则此方法将抛出 SecurityException。

返回：
焦点所有者
抛出：
SecurityException - 如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager
另请参见：
getFocusOwner(), setGlobalFocusOwner(java.awt.Component)

setGlobalFocusOwner

protected void setGlobalFocusOwner(Component focusOwner)
设置焦点所有者。如果该 Component 不可以作为焦点，则取消操作。焦点所有者的定义是：应用程序中的 Component，通常接收用户生成的所有 KeyEvent。如果为焦点所有者启用了焦点遍历键，则不会传递映射到焦点所有者的焦点遍历键的 KeyEvent。此外，KeyEventDispatcher 在到达焦点所有者之前可能重定向或使用 KeyEvent。

此方法实际上没有将焦点设置为指定的 Component。它只存储该值，以便以后由 getFocusOwner() 返回它。更改焦点所有者需要使用 Component.requestFocus() 或 Component.requestFocusInWindow()，具体的使用因平台而异。

参数：
focusOwner - 焦点所有者
另请参见：
getFocusOwner(),
getGlobalFocusOwner(),
Component.requestFocus(),
Component.requestFocusInWindow(),
Component.isFocusable()

clearGlobalFocusOwner

public void clearGlobalFocusOwner()
在 Java 和本机级别清除全局焦点所有者。如果存在焦点所有者，则该 Component 将接收持久 FOCUS_LOST 事件。完成此操作后，在用户选择接收焦点的新 Component 或通过调用 requestFocus() 为 Component 显式分配焦点之前，本机窗口操作系统将放弃所有用户生成的 KeyEvent。此操作不改变聚焦或激活状态的 Window。

另请参见：
Component.requestFocus(), FocusEvent.FOCUS_LOST

getPermanentFocusOwner

public Component getPermanentFocusOwner()
如果持久焦点所有者与调用线程位于同一个上下文中，则返回持久焦点所有者。持久焦点所有者的定义是：应用程序中的最后一个 Component，它可以接收持久 FOCUS_GAINED 事件。如果不发生临时焦点更改，则焦点所有者和持久焦点所有者是等效的。在发生临时焦点更改的情形下，临时焦点更改结束后，持久焦点所有者又会变成焦点所有者。

返回：
持久焦点所有者；如果持久焦点所有者调用的不是线程上下文的成员，则返回 null
另请参见：
getGlobalPermanentFocusOwner(), setGlobalPermanentFocusOwner(java.awt.Component)

getGlobalPermanentFocusOwner

protected Component getGlobalPermanentFocusOwner()
                                          throws SecurityException
返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。持久焦点所有者的定义是：应用程序中的最后一个 Component，它可以接收持久 FOCUS_GAINED 事件。如果不发生临时焦点更改，则焦点所有者和持久焦点所有者是等效的。在发生临时焦点更改的情形下，临时焦点更改结束后，持久焦点所有者又会变成焦点所有者。

如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager，则此方法将抛出 SecurityException。

返回：
持久焦点所有者
抛出：
SecurityException - 如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager
另请参见：
getPermanentFocusOwner(), setGlobalPermanentFocusOwner(java.awt.Component)

setGlobalPermanentFocusOwner

protected void setGlobalPermanentFocusOwner(Component permanentFocusOwner)
设置持久焦点所有者。如果该 Component 不可以作为焦点，则取消该操作。持久焦点所有者的定义是：应用程序中的最后一个 Component，它可以接收持久 FOCUS_GAINED 事件。如果不发生临时焦点更改，则焦点所有者和持久焦点所有者是等效的。在发生临时焦点更改的情形下，临时焦点更改结束后，持久焦点所有者又会变成焦点所有者。

此方法实际上没有将焦点设置为指定的 Component。它只存储该值，以便以后由 getPermanentFocusOwner() 返回它。更改焦点所有者需要使用 Component.requestFocus() 或 Component.requestFocusInWindow()，因平台而异。

参数：
permanentFocusOwner - 持久焦点所有者
另请参见：
getPermanentFocusOwner(),
getGlobalPermanentFocusOwner(),
Component.requestFocus(),
Component.requestFocusInWindow(),
Component.isFocusable()

getFocusedWindow

public Window getFocusedWindow()
如果聚焦窗口与调用线程位于同一个上下文中，则返回聚焦窗口。聚焦 Window 指本身就是（或者包含）焦点所有者的 Window。

返回：
聚焦 Window；如果聚焦 Window 调用的不是线程上下文的成员，则返回 null
另请参见：
getGlobalFocusedWindow(), setGlobalFocusedWindow(java.awt.Window)

getGlobalFocusedWindow

protected Window getGlobalFocusedWindow()
                                 throws SecurityException
返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。聚焦 Window 指本身就是（或者包含）焦点所有者的 Window。

如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager，则此方法将抛出 SecurityException。

返回：
聚焦 Window
抛出：
SecurityException - 如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager
另请参见：
getFocusedWindow(), setGlobalFocusedWindow(java.awt.Window)

setGlobalFocusedWindow

protected void setGlobalFocusedWindow(Window focusedWindow)
设置聚焦 Window。聚焦 Window 指本身就是（或者包含）焦点所有者的 Window。如果要聚焦的指定 Window 不是可以作为焦点的 Window，则取消该操作。

此方法不能实际更改与本机窗口操作系统相关的聚焦 Window。它只存储该值，以便以后由 getFocusedWindow() 返回它。更改聚焦 Window 需要使用 Component.requestFocus() 或 Component.requestFocusInWindow()，因平台而异。

参数：
focusedWindow - 聚焦 Window
另请参见：
getFocusedWindow(),
getGlobalFocusedWindow(),
Component.requestFocus(),
Component.requestFocusInWindow(),
Window.isFocusableWindow()

getActiveWindow

public Window getActiveWindow()
如果活动 Window 与调用线程位于同一个上下文中，则返回活动 Window。只有 Frame 或 Dialog 才能成为活动 Window。本机的窗口操作系统可能使用特殊装饰（如高亮显示标题栏）来表示活动 Window 或其子窗口。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

返回：
活动 Window；如果活动 Window 调用的不是线程上下文的成员，则返回 null
另请参见：
getGlobalActiveWindow(), setGlobalActiveWindow(java.awt.Window)

getGlobalActiveWindow

protected Window getGlobalActiveWindow()
                                throws SecurityException
返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。只有 Frame 或 Dialog 才能成为活动 Window。本机的窗口操作系统可能使用特殊装饰（如高亮显示标题栏）来表示活动 Window。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager，则此方法将抛出 SecurityException。

返回：
活动 Window
抛出：
SecurityException - 如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager
另请参见：
getActiveWindow(), setGlobalActiveWindow(java.awt.Window)

setGlobalActiveWindow

protected void setGlobalActiveWindow(Window activeWindow)
设置活动 Window。只有 Frame 或 Dialog 才能成为活动 Window。本机的窗口操作系统可能使用特殊装饰（如高亮显示标题栏）来表示活动 Window 或其子窗口。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

此方法不能实际更改与本机窗口操作系统相关的活动 Window。它只存储该值，以便以后由 getActiveWindow() 返回它。更改活动 Window 需要使用 Component.requestFocus() 或 Component.requestFocusInWindow()，因平台而异。

参数：
activeWindow - 活动 Window
另请参见：
getActiveWindow(),
getGlobalActiveWindow(),
Component.requestFocus(),
Component.requestFocusInWindow()

getDefaultFocusTraversalPolicy

public FocusTraversalPolicy getDefaultFocusTraversalPolicy()
返回默认 FocusTraversalPolicy。通过显式调用 Container.setFocusTraversalPolicy 初始化自己的焦点遍历策略时，顶层组件会使用该值。

返回：
默认 FocusTraversalPolicy。永远不会返回 null。
另请参见：
setDefaultFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
Container.getFocusTraversalPolicy()

setDefaultFocusTraversalPolicy

public void setDefaultFocusTraversalPolicy(FocusTraversalPolicy defaultPolicy)
设置默认 FocusTraversalPolicy。通过显式调用 Container.setFocusTraversalPolicy 初始化自己的焦点遍历策略时，顶层组件会使用此值。注：此调用不影响已经创建的组件，因为它们的策略已经初始化了。只有新组件才会将此策略用作默认策略。

参数：
defaultPolicy - 新的默认 FocusTraversalPolicy
抛出：
IllegalArgumentException - 如果 defaultPolicy 为 null
另请参见：
getDefaultFocusTraversalPolicy(),
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
Container.getFocusTraversalPolicy()

setDefaultFocusTraversalKeys

public void setDefaultFocusTraversalKeys(int id,
                                         Set<? extends AWTKeyStroke> keystrokes)
设置给定遍历操作的默认焦点遍历键。此遍历键 Set 对没有显式定义自己的这种 Set 的所有 Window 均有效。对于没有显式定义自己的这种 Set 的 Windows 而言，此 Set 还可以由其子 Component 递归式继承。

默认焦点遍历键的默认值是依赖于实现的。Sun 建议特定本机平台的所有实现都使用相同的默认值。下面列出了对 Windows 和 Unix 的建议。这些建议用于 Sun AWT 实现中。

标识符 | 意义 | 默认值
KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS | 正常向前键盘遍历 | TAB on KEY_PRESSED, CTRL-TAB on KEY_PRESSED
KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS | 正常反向键盘遍历 | SHIFT-TAB on KEY_PRESSED, CTRL-SHIFT-TAB on KEY_PRESSED
KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS | 向上一个焦点遍历循环 | none
KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS | 向下一个焦点遍历循环 | none
要禁用遍历键，需要使用空 Set；建议使用 Collections.EMPTY_SET。

使用 AWTKeyStroke API，客户端代码可以指定在两个特定 KeyEvent 的哪一个上进行焦点遍历，KEY_PRESSED 还是 KEY_RELEASED。不管指定哪一个 KeyEvent，所有与焦点遍历键相关的 KeyEvent（包括关联的 KEY_TYPED 事件）都将被使用，不会将其指派给任何 Component。将 KEY_TYPED 事件指定为映射为焦点遍历操作或将同一事件映射为多个默认焦点遍历操作都是运行时错误。

参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 和 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 其中之一
keystrokes - 指定操作的 AWTKeyStroke Set
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 和 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 其中之一，或者击键为 null，或者击键包含 null，或者击键中的任何 Object 不是 AWTKeyStroke，或者击键表示 KEY_TYPED 事件，或者击键已映射为别的默认焦点遍历操作
另请参见：
getDefaultFocusTraversalKeys(int), Component.setFocusTraversalKeys(int, java.util.Set), Component.getFocusTraversalKeys(int)

getDefaultFocusTraversalKeys

public Set<AWTKeyStroke> getDefaultFocusTraversalKeys(int id)
返回给定遍历操作的默认焦点遍历键的 Set。此遍历键 Set 对没有显式定义自己的这种 Set 的所有 Window 均有效。对于没有显式定义自己的这种 Set 的 Window 而言，此 Set 还可以由其子 Component 递归式继承。（请参见 setDefaultFocusTraversalKeys 以获取每个操作的完整描述。）

参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 和 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 其中之一
返回：
指定操作的 AWTKeyStroke Set；该 Set 不可修改，并且可以为空；永远不会返回 null
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 和 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 其中之一
另请参见：
setDefaultFocusTraversalKeys(int, java.util.Set),
Component.setFocusTraversalKeys(int, java.util.Set),
Component.getFocusTraversalKeys(int)

getCurrentFocusCycleRoot

public Container getCurrentFocusCycleRoot()
如果当前焦点循环根与调用线程位于相同的上下文中，则返回当前焦点循环根。如果焦点所有者本身是一个焦点循环根，则在正常焦点遍历期间，哪些 Component 表示焦点的上一个和下一个 Component 可能不明确。在这种情况下，需要使用当前焦点循环根来区分各种可能性。

此方法仅供 KeyboardFocusManager 和焦点实现使用。一般客户端不能使用。

返回：
当前焦点循环根；如果当前焦点循环根调用的不是线程上下文的成员，则返回 null
另请参见：
getGlobalCurrentFocusCycleRoot(), setGlobalCurrentFocusCycleRoot(java.awt.Container)

getGlobalCurrentFocusCycleRoot

protected Container getGlobalCurrentFocusCycleRoot()
                                            throws SecurityException
返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。如果焦点所有者本身是一个焦点循环根，则在正常焦点遍历期间，哪些 Component 表示焦点的上一个和下一个 Component 可能不明确。在这种情况下，需要使用当前焦点循环根来区分各种可能性。

如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager，则此方法将抛出 SecurityException。

返回：
当前焦点循环根；如果当前焦点循环根调用的不是线程上下文的成员，则返回 null
抛出：
SecurityException - 如果此 KeyboardFocusManager 调用的不是线程上下文的当前 KeyboardFocusManager
另请参见：
getCurrentFocusCycleRoot(), setGlobalCurrentFocusCycleRoot(java.awt.Container)

setGlobalCurrentFocusCycleRoot

public void setGlobalCurrentFocusCycleRoot(Container newFocusCycleRoot)
设置当前焦点循环根。如果焦点所有者本身是一个焦点循环根，则在正常焦点遍历期间，哪些 Component 表示焦点的上一个和下一个 Component 可能不明确。在这种情况下，需要使用当前焦点循环根来区分各种可能性。

此方法仅供 KeyboardFocusManager 和焦点实现使用。一般客户端不能使用。

参数：
newFocusCycleRoot - 新焦点循环根
另请参见：
getCurrentFocusCycleRoot(), getGlobalCurrentFocusCycleRoot()

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。为此类的所有绑定属性注册侦听器，这些属性包括：
  • KeyboardFocusManager 目前是否管理此应用程序或 applet 浏览器上下文的焦点 ("managingFocus")
  • 焦点所有者 ("focusOwner")
  • 持久焦点所有者 ("permanentFocusOwner")
  • 聚焦 Window ("focusedWindow")
  • 活动 Window ("activeWindow")
  • 默认焦点遍历策略 ("defaultFocusTraversalPolicy")
  • 默认 FORWARD_TRAVERSAL_KEYS 的 Set ("forwardDefaultFocusTraversalKeys")
  • 默认 BACKWARD_TRAVERSAL_KEYS 的 Set ("backwardDefaultFocusTraversalKeys")
  • 默认 UP_CYCLE_TRAVERSAL_KEYS 的 Set ("upCycleDefaultFocusTraversalKeys")
  • 默认 DOWN_CYCLE_TRAVERSAL_KEYS 的 Set ("downCycleDefaultFocusTraversalKeys")
  • 当前焦点循环根 ("currentFocusCycleRoot")
如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
listener - 要添加的 PropertyChangeListener
另请参见：
removePropertyChangeListener(java.beans.PropertyChangeListener),
getPropertyChangeListeners(),
addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除 PropertyChangeListener。可以使用此方法移除曾为此类的所有绑定属性注册的 PropertyChangeListener。

如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
listener - 要移除的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener),
getPropertyChangeListeners(),
removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回在此键盘焦点管理器上注册的所有属性更改侦听器组成的数组。

返回：
返回此键盘焦点管理器的所有 PropertyChangeListener；如果目前没有注册任何属性更改侦听器，则返回空数组
从以下版本开始：
1.4
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener),
removePropertyChangeListener(java.beans.PropertyChangeListener),
getPropertyChangeListeners(java.lang.String)

addPropertyChangeListener

public void addPropertyChangeListener(String propertyName,
                                      PropertyChangeListener listener)
将 PropertyChangeListener 添加到特定属性的侦听器列表。指定属性可能是用户定义的，也可能是以下属性之一：
  • KeyboardFocusManager 目前是否管理此应用程序或 applet 浏览器上下文的焦点 ("managingFocus")
  • 焦点所有者 ("focusOwner")
  • 持久焦点所有者 ("permanentFocusOwner")
  • 聚焦 Window ("focusedWindow")
  • 活动 Window ("activeWindow")
  • 默认焦点遍历策略 ("defaultFocusTraversalPolicy")
  • 默认 FORWARD_TRAVERSAL_KEYS 的 Set ("forwardDefaultFocusTraversalKeys")
  • 默认 BACKWARD_TRAVERSAL_KEYS 的 Set ("backwardDefaultFocusTraversalKeys")
  • 默认 UP_CYCLE_TRAVERSAL_KEYS 的 Set ("upCycleDefaultFocusTraversalKeys")
  • 默认 DOWN_CYCLE_TRAVERSAL_KEYS 的 Set ("downCycleDefaultFocusTraversalKeys")
  • 当前焦点循环根 ("currentFocusCycleRoot")
如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
propertyName - 上面列出的属性名之一
listener - 要添加的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener),
removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener),
getPropertyChangeListeners(java.lang.String)

removePropertyChangeListener

public void removePropertyChangeListener(String propertyName,
                                         PropertyChangeListener listener)
从特定属性的侦听器列表移除 PropertyChangeListener。可以使用此方法移除为特定绑定属性注册的 PropertyChangeListener。

如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
propertyName - 有效属性名
listener - 要移除的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener),
getPropertyChangeListeners(java.lang.String),
removePropertyChangeListener(java.beans.PropertyChangeListener)

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。

返回：
与指定属性相关联的所有 PropertyChangeListener；如果没有添加过这样的侦听器，则返回空数组。
从以下版本开始：
1.4
另请参见：
addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener), removePropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
激发 PropertyChangeEvent 以响应绑定属性中的更改。该事件将被传递到所有已注册的 PropertyChangeListener 中。如果 oldValue 和 newValue 相同，则不会传递事件。

参数：
propertyName - 已更改的属性名
oldValue - 属性的上一个值
newValue - 属性的新值

addVetoableChangeListener

public void addVetoableChangeListener(VetoableChangeListener listener)
将 VetoableChangeListener 添加到侦听器列表。为此类的所有可否决属性注册侦听器，这些属性包括：
  • 焦点所有者 ("focusOwner")
  • 持久焦点所有者 ("permanentFocusOwner")
  • 聚焦 Window ("focusedWindow")
  • 活动 Window ("activeWindow")
如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
listener - 要添加的 VetoableChangeListener
另请参见：
removeVetoableChangeListener(java.beans.VetoableChangeListener),
getVetoableChangeListeners(),
addVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener)

removeVetoableChangeListener

public void removeVetoableChangeListener(VetoableChangeListener listener)
从侦听器列表移除 VetoableChangeListener。使用此方法可以移除曾为此类的所有可否决属性注册的 VetoableChangeListener。

如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
listener - 要移除的 VetoableChangeListener
另请参见：
addVetoableChangeListener(java.beans.VetoableChangeListener),
getVetoableChangeListeners(),
removeVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener)

getVetoableChangeListeners

public VetoableChangeListener[] getVetoableChangeListeners()
返回在此键盘焦点管理器上注册的所有可否决更改侦听器组成的数组。

返回：
此键盘焦点管理器的所有 VetoableChangeListener；如果目前没有注册任何可否决更改侦听器，则返回空数组
从以下版本开始：
1.4
另请参见：
addVetoableChangeListener(java.beans.VetoableChangeListener),
removeVetoableChangeListener(java.beans.VetoableChangeListener),
getVetoableChangeListeners(java.lang.String)

addVetoableChangeListener

public void addVetoableChangeListener(String propertyName,
                                      VetoableChangeListener listener)
将 VetoableChangeListener 添加到特定属性的侦听器列表。指定属性可能是用户定义的，也可能是以下属性之一：
  • 焦点所有者 ("focusOwner")
  • 持久焦点所有者 ("permanentFocusOwner")
  • 聚焦 Window ("focusedWindow")
  • 活动 Window ("activeWindow")
如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
propertyName - 上面列出的属性名之一
listener - 要添加的 VetoableChangeListener
另请参见：
addVetoableChangeListener(java.beans.VetoableChangeListener),
removeVetoableChangeListener(java.beans.VetoableChangeListener),
getVetoableChangeListeners()

removeVetoableChangeListener

public void removeVetoableChangeListener(String propertyName,
                                         VetoableChangeListener listener)
从特定属性的侦听器列表移除 VetoableChangeListener。可以使用此方法移除为特定绑定属性注册的 VetoableChangeListener。

如果侦听器为 null，则不抛出异常，也不执行任何动作。

参数：
propertyName - 有效属性名
listener - 要移除的 VetoableChangeListener
另请参见：
addVetoableChangeListener(java.beans.VetoableChangeListener),
getVetoableChangeListeners(),
removeVetoableChangeListener(java.beans.VetoableChangeListener)

getVetoableChangeListeners

public VetoableChangeListener[] getVetoableChangeListeners(String propertyName)
返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。

返回：
与指定属性相关联的所有 VetoableChangeListener；如果没有添加过这样的侦听器，则返回空数组。
从以下版本开始：
1.4
另请参见：
addVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener),
removeVetoableChangeListener(java.lang.String,java.beans.VetoableChangeListener),
getVetoableChangeListeners()

fireVetoableChange

protected void fireVetoableChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
                           throws PropertyVetoException
激发 PropertyChangeEvent 以响应可否决属性中的更改。该事件将被传递到所有已注册的 VetoableChangeListener 中。如果 VetoableChangeListener 抛出 PropertyVetoException，则激发将所有 VetoableChangeListener 还原为旧值的新事件，并再次抛出异常。如果 oldValue 和 newValue 相同，则不会传递事件。

参数：
propertyName - 已更改的属性名
oldValue - 属性以前的值
newValue - 属性的新值
抛出：
PropertyVetoException - 如果 VetoableChangeListener 抛出了 PropertyVetoException

addKeyEventDispatcher

public void addKeyEventDispatcher(KeyEventDispatcher dispatcher)
将 KeyEventDispatcher 添加到此 KeyboardFocusManager 的调度程序链中。此 KeyboardFocusManager 将请求每个 KeyEventDispatcher 在最终指派 KeyEvent 本身之前，首先指派由用户生成的 KeyEvent。KeyEventDispatcher 将按其添加顺序得到通知。一旦一个 KeyEventDispatcher 从其 dispatchKeyEvent 方法返回 true，通知就会暂停。可以添加的 KeyEventDispatcher 的总数没有限制，添加特定 KeyEventDispatcher 实例的次数也没有限制。

如果指定了 null 指派程序，则不执行动作也不抛出异常。

在多线程应用程序中，KeyEventDispatcher 的行为与其他 AWT 侦听器相同。有关更多详细信息，请参阅 AWT 线程问题。

参数：
dispatcher - 要添加到指派程序链的 KeyEventDispatcher
另请参见：
removeKeyEventDispatcher(java.awt.KeyEventDispatcher)

removeKeyEventDispatcher

public void removeKeyEventDispatcher(KeyEventDispatcher dispatcher)
移除以前添加到此 KeyboardFocusManager 调度程序链中的 KeyEventDispatcher。此 KeyboardFocusManager 本身不能被移除，除非它是通过调用 addKeyEventDispatcher 显式重新注册的。

如果指定了 null 调度程序，指定的调度程序没有位于调度程序链中，或者此 KeyboardFocusManager 不是通过显式重新注册指定的，则不执行动作也不抛出异常。

在多线程应用程序中，KeyEventDispatcher 的行为与其他 AWT 侦听器相同。有关更多详细信息，请参阅 AWT 线程问题。

参数：
dispatcher - 要从调度程序链中移除的 KeyEventDispatcher
另请参见：
addKeyEventDispatcher(java.awt.KeyEventDispatcher)

getKeyEventDispatchers

protected List<KeyEventDispatcher> getKeyEventDispatchers()
作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。该 List 不包括此 KeyboardFocusManager，除非它是通过调用 addKeyEventDispatcher 显式重新注册的。如果没有注册其他 KeyEventDispatcher，则实现随意返回 null 或长度为 0 的 List。客户端代码不应假定某种行为多于其他行为，也不应假定建立行为后不能更改。

返回：
可能返回 null，也可能返回 KeyEventDispatcher 的空 List
另请参见：
addKeyEventDispatcher(java.awt.KeyEventDispatcher), removeKeyEventDispatcher(java.awt.KeyEventDispatcher)

addKeyEventPostProcessor

public void addKeyEventPostProcessor(KeyEventPostProcessor processor)
将 KeyEventPostProcessor 添加到此 KeyboardFocusManager 的后处理器链中。将 KeyEvent 指派给目标并由目标处理后，KeyboardFocusManager 将请求每个 KeyEventPostProcessor 作为 KeyEvent 的最终解析的一部分执行所有必要的后处理操作。KeyEventPostProcessor 将按其添加顺序得到通知；当前 KeyboardFocusManager 将排在最后。一旦一个 KeyEventPostProcessor 从其 postProcessKeyEvent 方法返回 true，通知就会暂停。可以添加的 KeyEventPostProcessors 的总数没有限制，添加特定 KeyEventPostProcessor 实例的次数也没有限制。

如果指定了 null 后处理器，则不执行动作也不抛出异常。

在多线程应用程序中，KeyEventPostProcessor 的行为与其他 AWT 侦听器相同。有关更多详细信息，请参阅 AWT 线程问题。

参数：
processor - 要添加到后处理器链的 KeyEventPostProcessor
另请参见：
removeKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

removeKeyEventPostProcessor

public void removeKeyEventPostProcessor(KeyEventPostProcessor processor)
从此 KeyboardFocusManager 的后处理器链中移除以前添加的 KeyEventPostProcessor。从该链中无法将 KeyboardFocusManager 本身完全移除。只能移除通过 addKeyEventPostProcessor 添加的其他引用。

如果指定了 null 后处理器，指定的后处理器没有位于后处理器链中，或者此 KeyboardFocusManager 不是通过显式添加指定的，则不执行动作也不抛出异常。

在多线程应用程序中，KeyEventPostProcessor 的行为与其他 AWT 侦听器相同。有关更多详细信息，请参阅 AWT 线程问题。

参数：
processor - 要从后处理器链中移除的 KeyEventPostProcessor
另请参见：
addKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

getKeyEventPostProcessors

protected List<KeyEventPostProcessor> getKeyEventPostProcessors()
作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。该 List 不包括此 KeyboardFocusManager，除非它是通过调用 addKeyEventPostProcessor 显式添加的。如果没有注册任何 KeyEventDispatcher，则实现随意返回 null 或长度为 0 的 List。客户端代码不应假定某种行为多于其他行为，也不应假定建立行为后不能更改。

返回：
可能返回 null 也可能返回 KeyEventPostProcessor 的空 List
另请参见：
addKeyEventPostProcessor(java.awt.KeyEventPostProcessor), removeKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

dispatchEvent

public abstract boolean dispatchEvent(AWTEvent e)
AWT 事件调度程序可以调用此方法，请求当前的 KeyboardFocusManager 为其指派指定的事件。所有 KeyboardFocusManager 需要指派所有 FocusEvent、所有与焦点相关的 WindowEvent 和所有 KeyEvent。这些事件应该基于 KeyboardFocusManager 的焦点所有者和聚焦及活动 Window 概念指派，有时会重写指定的 AWTEvent 的源代码。必须使用 redispatchEvent 完成指派操作，以防 AWT 事件调度程序递归式请求 KeyboardFocusManager 再次指派该事件。如果此方法返回 false，则 AWT 事件调度程序将尝试指派该事件本身。

参数：
e - 要指派的 AWTEvent
返回：
如果此方法指派了该事件，则返回 true；否则返回 false
另请参见：
redispatchEvent(java.awt.Component, java.awt.AWTEvent), dispatchKeyEvent(java.awt.event.KeyEvent)

redispatchEvent

public final void redispatchEvent(Component target,
                                  AWTEvent e)
重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。dispatchEvent 的客户端实现和客户端定义的 KeyEventDispatcher 必须调用 redispatchEvent(target, e) 而不是调用 target.dispatchEvent(e) 来指派事件。

此方法仅供 KeyboardFocusManager 和 KeyEventDispatcher 使用。一般客户端不能使用。

参数：
target - 应将事件指派到的 Component
e - 要指派的事件
另请参见：
dispatchEvent(java.awt.AWTEvent), KeyEventDispatcher

dispatchKeyEvent

public abstract boolean dispatchKeyEvent(KeyEvent e)
通常情况下，如果该指派程序链中的其他 KeyEventDispatcher 没有指派 KeyEvent 或者没有注册其他 KeyEventDispatcher，则 dispatchEvent 将调用此方法。如果此方法的实现返回 false，则 dispatchEvent 可能试图指派 KeyEvent 本身，或者可能简单地返回 false。如果返回 true，则 dispatchEvent 也应该返回 true。

指定者：
接口 KeyEventDispatcher 中的 dispatchKeyEvent
参数：
e - 当前 KeyboardFocusManager 已经请求此 KeyEventDispatcher 指派的 KeyEvent
返回：
如果指派了 KeyEvent，则返回 true；否则，返回 false
另请参见：
dispatchEvent(java.awt.AWTEvent)

postProcessKeyEvent

public abstract boolean postProcessKeyEvent(KeyEvent e)
dispatchKeyEvent 将调用此方法。默认情况下，此方法将通过使用该事件并激活快捷方式来处理映射到 AWT MenuShortcut 的所有未使用的 KeyEvent。

指定者：
接口 KeyEventPostProcessor 中的 postProcessKeyEvent
参数：
e - 要后处理的 KeyEvent
返回：
true，指示任何其他 KeyEventPostProcessor 都将得不到该 KeyEvent 的通知。
另请参见：
dispatchKeyEvent(java.awt.event.KeyEvent), MenuShortcut

processKeyEvent

public abstract void processKeyEvent(Component focusedComponent,
                                     KeyEvent e)
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。focusedComponent 应该是当前的焦点所有者，尽管这一点不是必需的。如果它不是，焦点遍历仍把 focusedComponent 当作是当前焦点所有者而继续执行操作。

参数：
focusedComponent - 指定的事件表示其焦点遍历键时，将成为焦点遍历操作基础的 Component
e - 可能表示焦点遍历键的事件

enqueueKeyEvents

protected abstract void enqueueKeyEvents(long after,
                                         Component untilFocused)
在指定的 Component 成为焦点所有者以前由 AWT 调用，以通知 KeyboardFocusManager 延迟指派 KeyEvent。如果客户端代码请求焦点更改，则 AWT 将确定本机窗口操作系统是否批准此请求，然后由 AWT 调用此方法。在指定的 Component 接收 FOCUS_GAINED 事件或 AWT 通过调用 dequeueKeyEvents 或 discardKeyEvents 取消延迟请求以前，KeyboardFocusManager 负责延迟指派时间戳晚于指定时间戳的 KeyEvent。

参数：
after - 当前事件的时间戳，如果当前事件没有时间戳或者 AWT 无法确定目前正在处理哪个事件，则为当前系统时间
untilFocused - 挂起 KeyEvent 之前应该接收 FOCUS_GAINED 事件的 Component
另请参见：
dequeueKeyEvents(long, java.awt.Component), discardKeyEvents(java.awt.Component)

dequeueKeyEvents

protected abstract void dequeueKeyEvents(long after,
                                         Component untilFocused)
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。应该释放由于使用相同时间戳和 Component 调用 enqueueKeyEvents 而加入队列的 KeyEvent，以将它们正常指派给当前焦点所有者。如果给定的时间戳小于零，则应该取消具有 oldest 时间戳的给定 Component 的未处理排队请求（如果有）。

参数：
after - 在对 enqueueKeyEvents 的调用中指定的时间戳，或者任何小于 0 的值
untilFocused - 在对 enqueueKeyEvents 的调用中指定的 Component
另请参见：
enqueueKeyEvents(long, java.awt.Component), discardKeyEvents(java.awt.Component)

discardKeyEvents

protected abstract void discardKeyEvents(Component comp)
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。应该丢弃由于使用相同 Component 一次或多次调用 enqueueKeyEvents 而加入队列 KeyEvent。

参数：
comp - 对 enqueueKeyEvents 的一次或多次调用中指定的 Component
另请参见：
enqueueKeyEvents(long, java.awt.Component), dequeueKeyEvents(long, java.awt.Component)

focusNextComponent

public abstract void focusNextComponent(Component aComponent)
聚焦 aComponent 之后的 Component，通常基于 FocusTraversalPolicy。

参数：
aComponent - 作为焦点遍历操作基础的 Component
另请参见：
FocusTraversalPolicy

focusPreviousComponent

public abstract void focusPreviousComponent(Component aComponent)
聚焦 aComponent 之前的 Component，通常基于 FocusTraversalPolicy。

参数：
aComponent - 作为焦点遍历操作基础的 Component
另请参见：
FocusTraversalPolicy

upFocusCycle

public abstract void upFocusCycle(Component aComponent)
将焦点上移一个焦点遍历循环。通常情况下，将焦点所有者设置为 aComponent 的焦点循环根，而将当前焦点循环根设置为新的焦点所有者的焦点循环根。但是，如果 aComponent 的焦点循环根是一个 Window，则通常将焦点所有者设置为要聚焦的 Window 的默认 Component，当前焦点循环根保持不变。

参数：
aComponent - 作为焦点遍历操作基础的 Component

downFocusCycle

public abstract void downFocusCycle(Container aContainer)
将焦点下移一个焦点遍历循环。通常情况下，如果 aContainer 是焦点循环根，则将焦点所有者设置为要聚焦的 aContainer 的默认 Component，而将当前焦点循环根设置为 aContainer。如果 aContainer 不是焦点循环根，则不进行焦点遍历操作。

参数：
aContainer - 作为焦点遍历操作基础的 Container

focusNextComponent

public final void focusNextComponent()
聚焦当前焦点所有者之后的 Component。

focusPreviousComponent

public final void focusPreviousComponent()
聚焦当前焦点所有者之前的 Component。

upFocusCycle

public final void upFocusCycle()
从当前焦点所有者将焦点上移一个焦点遍历循环。通常情况下，将新焦点所有者设置为当前焦点所有者的焦点循环根，而将当前焦点循环根设置为新焦点所有者的焦点循环根。但是，如果当前焦点所有者的焦点循环根是一个 Window，则通常将焦点所有者设置为要聚焦的焦点循环根的默认 Component，而当前焦点循环根保持不变。

downFocusCycle

public final void downFocusCycle()
当且仅当当前焦点所有者是一个作为焦点循环根的 Container 时，从当前焦点所有者将焦点下移一个焦点遍历循环。通常情况下，将焦点所有者设置为要聚焦的当前焦点所有者的默认 Component，而将当前焦点循环根设置为当前焦点所有者。如果当前焦点所有者不是作为焦点循环根的 Container，则不进行任何焦点遍历操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyEventDispatcher (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 KeyEventDispatcher

所有已知实现类：
DefaultFocusManager, DefaultKeyboardFocusManager, FocusManager, KeyboardFocusManager
public interface KeyEventDispatcher

在指派所有 KeyEvent 和为其确定目标时，KeyEventDispatcher 和当前 KeyboardFocusManager 一起使用。在当前 KeyboardFocusManager 中注册的 KeyEventDispatcher 在 KeyEvent 被指派到目标前接收它们，允许每个 KeyEventDispatcher 重定向事件，使用它，指派事件本身，或者进行其他更改。

注意，KeyboardFocusManager 本身即可实现 KeyEventDispatcher。默认情况下，当前 KeyboardFocusManager 是已注册 KeyEventDispatcher 未指派的所有 KeyEvent 的接受器。无法将当前 KeyboardFocusManager 作为 KeyEventDispatcher 完全注销。但是，如果 KeyEventDispatcher 报告指派了 KeyEvent，则不管是否实际指派了，KeyboardFocusManager 都将不对 KeyEvent 进行进一步的操作。（尽管客户端代码将当前的 KeyboardFocusManager 一次或多次注册为 KeyEventDispatcher 是可能的，但通常不必要也不建议这样做。）

从以下版本开始：
1.4
另请参见：
KeyboardFocusManager.addKeyEventDispatcher(java.awt.KeyEventDispatcher), KeyboardFocusManager.removeKeyEventDispatcher(java.awt.KeyEventDispatcher)

方法摘要
 boolean dispatchKeyEvent(KeyEvent e)
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventDispatcher 为其指派指定的事件。

方法详细信息

dispatchKeyEvent

boolean dispatchKeyEvent(KeyEvent e)
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventDispatcher 为其指派指定的事件。此 KeyEventDispatcher 可以随意重定向事件，使用它，指派它本身，或者进行其他更改。通常使用此功能将 KeyEvent 传递给 Component 而不是焦点所有者。例如，可以使用此功能在可访问环境中导航不可聚焦 Window 的子级。注意，如果 KeyEventDispatcher 指派 KeyEvent 本身，则其必须使用 redispatchEvent 来防止当前 KeyboardFocusManager 递归式请求此 KeyEventDispatcher 再次指派事件。

如果此方法的实现返回 false，则将 KeyEvent 传入链中的下一个 KeyEventDispatcher，以当前的 KeyboardFocusManager 结尾。如果实现返回 true，则假定已经指派了该 KeyEvent（尽管事实不一定如此），当前 KeyboardFocusManager 将不对该 KeyEvent 进行任何进一步的操作。在此情况下，KeyboardFocusManager.dispatchEvent 也应该返回 true。如果实现使用 KeyEvent，但是返回 false，则仍将所使用的事件传入链中的下一个 KeyEventDispatcher。开发人员在将 KeyEvent 指派到目标前首先检查它是否已使用至关重要。默认情况下，当前 KeyboardFocusManager 不指派使用的 KeyEvent。

参数：
e - 要指派的 KeyEvent
返回：
如果 KeyboardFocusManager 不应对该 KeyEvent 进行进一步操作，则返回 true；否则，返回 false
另请参见：
KeyboardFocusManager.redispatchEvent(java.awt.Component, java.awt.AWTEvent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyEventPostProcessor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 KeyEventPostProcessor

所有已知实现类：
DefaultFocusManager, DefaultKeyboardFocusManager, FocusManager, KeyboardFocusManager
public interface KeyEventPostProcessor

在最终解析所有未使用的 KeyEvent 时，需要将 KeyEventPostProcessor 和当前的 KeyboardFocusManager 一起使用。在当前 KeyboardFocusManager 中注册的 KeyEventPostProcessor 在 KeyEvent 被指派到目标并由目标处理后接收它们。因为目前应用程序中不存在拥有该焦点的 Component，所以也可以将这些 KeyEvent 转发到已注册的 KeyEventPostProcessor 中，否则它们将被丢弃。这允许应用程序实现需要全局 KeyEvent 后处理的功能，如菜单快捷键。

注意，KeyboardFocusManager 本身实现了 KeyEventPostProcessor。默认情况下，当前的 KeyboardFocusManager 将是链中的最终 KeyEventPostProcessor。无法将当前 KeyboardFocusManager 作为 KeyEventPostProcessor 完全注销。但是，如果 KeyEventPostProcessor 报告不应进一步后处理 KeyEvent，则 AWT 将认为已完全处理了该事件，不再对它执行任何其他操作。（尽管客户端代码将当前的 KeyboardFocusManager 一次或多次注册为 KeyEventPostProcessor 是可能的，但通常不必要也不建议这样做。）

从以下版本开始：
1.4
另请参见：
KeyboardFocusManager.addKeyEventPostProcessor(java.awt.KeyEventPostProcessor), KeyboardFocusManager.removeKeyEventPostProcessor(java.awt.KeyEventPostProcessor)

方法摘要
 boolean postProcessKeyEvent(KeyEvent e)
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventPostProcessor 执行应该作为 KeyEvent 最终解析的一部分的所需后处理。

方法详细信息

postProcessKeyEvent

boolean postProcessKeyEvent(KeyEvent e)
当前 KeyboardFocusManager 调用此方法，请求此 KeyEventPostProcessor 执行应该作为 KeyEvent 最终解析的一部分的所需后处理。在调用此方法时，通常已经将该 KeyEvent 指派到其目标并由其目标进行了处理。但是，如果目前应用程序中任何 Component 均不拥有该焦点，则表示尚未将该 KeyEvent 指派给任何 Component。通常情况下，KeyEvent 后处理用于实现需要全局 KeyEvent 后处理的功能，如菜单快捷键。注意，如果 KeyEventPostProcessor 希望指派 KeyEvent，则其必须使用 redispatchEvent 来防止 AWT 递归式请求此 KeyEventPostProcessor 再次后处理该事件。

如果此方法的实现返回 false，则将 KeyEvent 传入链中的下一个 KeyEventPostProcessor，以当前的 KeyboardFocusManager 结尾。如果实现返回 true，则假定已经完全处理了该 KeyEvent（尽管事实不一定如此），AWT 将不对该 KeyEvent 进行任何进一步的操作。如果实现使用了 KeyEvent，但是返回 false，则仍将所使用的事件传入链中的下一个 KeyEventPostProcessor。开发人员在后处理 KeyEvent 之前检查是否已经使用了该 KeyEvent 至关重要。默认情况下，当前 KeyboardFocusManager 不执行任何响应已使用 KeyEvent 的后处理操作。

参数：
e - 要后处理的 KeyEvent
返回：
如果 AWT 不应该对该 KeyEvent 执行进一步操作，则返回 true；否则返回 false
另请参见：
KeyboardFocusManager.redispatchEvent(java.awt.Component, java.awt.AWTEvent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Label (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Label

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Label
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class Label
extends Component
implements Accessible

Label 对象是一个可在容器中放置文本的组件。一个标签只显示一行只读文本。文本可由应用程序更改，但是用户不能直接对其进行编辑。

例如，代码……

 setLayout(new FlowLayout(FlowLayout.CENTER, 10, 10));
 add(new Label("Hi There!"));
 add(new Label("Another Label"));

生成以下标签：

两个标签：'Hi There!' 和 'Another label'

从以下版本开始：
JDK1.0
另请参见：
序列化表格

嵌套类摘要
protected  class Label.AccessibleAWTLabel
此类实现对 Label 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | CENTER 指示标签文本应居中。
static int | LEFT 指示标签文本应左对齐。
static int | RIGHT 指示标签文本应右对齐。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Label()
构造一个空标签。
Label(String text)
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。
Label(String text, int alignment)
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。
方法摘要
void | addNotify() 创建此标签的同位体。
AccessibleContext | getAccessibleContext() 获取与此标签相关的 AccessibleContext。
int | getAlignment() 获取此标签的当前对齐方式。
String | getText() 获取此标签的文本。
protected String | paramString() 返回一个表示此 Label 状态的字符串。
void | setAlignment(int alignment) 将此标签的对齐方式设置为指定的方式。
void | setText(String text) 将此标签的文本设置为指定的文本。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

LEFT

public static final int LEFT
指示标签文本应左对齐。

另请参见：
常量字段值

CENTER

public static final int CENTER
指示标签文本应居中。

另请参见：
常量字段值

RIGHT

public static final int RIGHT
指示标签文本应右对齐。

从以下版本开始：
JDK1.0t.
另请参见：
常量字段值
构造方法详细信息

Label

public Label()
      throws HeadlessException
构造一个空标签。此标签的文本为空字符串 ""。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

Label

public Label(String text)
      throws HeadlessException
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。

参数：
text - 此标签显示的字符串。将接受 null 值，而不不会导致抛出 NullPointerException。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

Label

public Label(String text,
             int alignment)
      throws HeadlessException
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。可能的 alignment 值有 Label.LEFT、Label.RIGHT 和 Label.CENTER。

参数：
text - 标签显示的字符串。将接受 null 值，并且不会导致抛出 NullPointerException。
alignment - 对齐方式的值。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建此标签的同位体。此同位体可在不更改标签功能的情况下修改其外观。

覆盖：
类 Component 中的 addNotify
另请参见：
Component.isDisplayable(), Component.removeNotify()

getAlignment

public int getAlignment()
获取此标签的当前对齐方式。可能的值有 Label.LEFT、Label.RIGHT 和 Label.CENTER。

另请参见：
setAlignment(int)

setAlignment

public void setAlignment(int alignment)
将此标签的对齐方式设置为指定的方式。可能的值有 Label.LEFT、Label.RIGHT 和 Label.CENTER。

参数：
alignment - 要设置的对齐方式。
抛出：
IllegalArgumentException - 如果 alignment 赋值不正确。
另请参见：
getAlignment()

getText

public String getText()
获取此标签的文本。

返回：
此标签的文本，如果此文本已设置为 null，则返回 null。
另请参见：
setText(java.lang.String)

setText

public void setText(String text)
将此标签的文本设置为指定的文本。

参数：
text - 此标签显示的文本。如果 text 为 null，则将其作为一个空字符串 "" 显示。
另请参见：
getText()

paramString

protected String paramString()
返回一个表示此 Label 状态的字符串。此方法仅在进行调试的时候使用，对于这两个实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Component 中的 paramString
返回：
此标签的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此标签相关的 AccessibleContext。对于标签，AccessibleContext 采用 AccessibleAWTLabel 的形式。如有必要，则会创建一个新的 AccessibleAWTLabel 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
一个 AccessibleAWTLabel，该 AccessibleAWTLabel 将用作此标签的 AccessibleContext。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Label.AccessibleAWTLabel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Label.AccessibleAWTLabel

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Label.AccessibleAWTLabel
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
Label
protected class Label.AccessibleAWTLabel
extends Component.AccessibleAWTComponent

此类实现对 Label 类的可访问性支持。它提供适合于标记用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
Label.AccessibleAWTLabel()
方法摘要
String | getAccessibleName() 获取此对象的可访问名称。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Label.AccessibleAWTLabel

public Label.AccessibleAWTLabel()
方法详细信息

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleName
返回：
对象的本地化名称——如果此对象不具有名称，则可以为 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 LayoutManager

所有已知子接口：
LayoutManager2
所有已知实现类：
BasicComboBoxUI.ComboBoxLayoutManager, BasicInternalFrameTitlePane.TitlePaneLayout, BasicInternalFrameUI.InternalFrameLayout, BasicOptionPaneUI.ButtonAreaLayout, BasicScrollBarUI, BasicSplitPaneDivider.DividerLayout, BasicSplitPaneUI.BasicHorizontalLayoutManager, BasicSplitPaneUI.BasicVerticalLayoutManager, BasicTabbedPaneUI.TabbedPaneLayout, BorderLayout, BoxLayout, CardLayout, DefaultMenuLayout, FlowLayout, GridBagLayout, GridLayout, GroupLayout, JRootPane.RootLayout, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, MetalComboBoxUI.MetalComboBoxLayoutManager, MetalScrollBarUI, MetalTabbedPaneUI.TabbedPaneLayout, OverlayLayout, ScrollPaneLayout, ScrollPaneLayout.UIResource, SpringLayout, ViewportLayout
public interface LayoutManager

定义知道如何布置 Container 类的接口。

Swing 的绘制架构假定 JComponent 的子组件不发生重叠。如果 JComponent 的 LayoutManager 允许子组件重叠，则 JComponent 必须重写 isOptimizedDrawingEnabled 以返回 false。

另请参见：
Container, JComponent.isOptimizedDrawingEnabled()

方法摘要
void | addLayoutComponent(String name, Component comp) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
void | layoutContainer(Container parent) 布置指定容器。
Dimension | minimumLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的最小大小维数。
Dimension | preferredLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | removeLayoutComponent(Component comp) 从布局移除指定组件。

方法详细信息

addLayoutComponent

void addLayoutComponent(String name,
                        Component comp)
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

参数：
name - 要与组件关联的字符串
comp - 要添加的组件

removeLayoutComponent

void removeLayoutComponent(Component comp)
从布局移除指定组件。

参数：
comp - 要移除的组件

preferredLayoutSize

Dimension preferredLayoutSize(Container parent)
给定指定容器所包含的组件，计算该容器的首选大小维数。

参数：
parent - 要布置的容器
另请参见：
minimumLayoutSize(java.awt.Container)

minimumLayoutSize

Dimension minimumLayoutSize(Container parent)
给定指定容器所包含的组件，计算该容器的最小大小维数。

参数：
parent - 要布置的组件

layoutContainer

void layoutContainer(Container parent)
布置指定容器。

参数：
parent - 要布置的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutManager2 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 LayoutManager2

所有超级接口：
LayoutManager
所有已知实现类：
BasicSplitPaneUI.BasicHorizontalLayoutManager, BasicSplitPaneUI.BasicVerticalLayoutManager, BorderLayout, BoxLayout, CardLayout, DefaultMenuLayout, GridBagLayout, GroupLayout, JRootPane.RootLayout, OverlayLayout, SpringLayout
public interface LayoutManager2
extends LayoutManager

为类定义接口，该类知道如何根据布局约束对象来布置 Container。 此接口扩展了 LayoutManager 接口，以根据约束对象显式地处理布局，该约束对象指定应该如何以及在何处将组件添加到布局。

LayoutManager 的这一最小扩展可供想要创建基于约束的布局的工具提供者使用。但是，它不对基于约束的自定义布局管理器提供完整的通用支持。

另请参见：
LayoutManager, Container

方法摘要
void | addLayoutComponent(Component comp, Object constraints) 使用指定约束对象，将指定组件添加到布局。
float | getLayoutAlignmentX(Container target) 返回沿 X 轴的对齐方式。
float | getLayoutAlignmentY(Container target) 返回沿 Y 轴的对齐方式。
void | invalidateLayout(Container target) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
Dimension | maximumLayoutSize(Container target) 给定指定容器的组件，计算该容器的最大大小维数。
从接口 java.awt.LayoutManager 继承的方法
addLayoutComponent, layoutContainer, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent

方法详细信息

addLayoutComponent

void addLayoutComponent(Component comp,
                        Object constraints)
使用指定约束对象，将指定组件添加到布局。

参数：
comp - 要添加的组件
constraints - 如何以及在何处将组件添加到布局。

maximumLayoutSize

Dimension maximumLayoutSize(Container target)
给定指定容器的组件，计算该容器的最大大小维数。

另请参见：
Component.getMaximumSize(), LayoutManager

getLayoutAlignmentX

float getLayoutAlignmentX(Container target)
返回沿 X 轴的对齐方式。它指定如何相对于其他组件对齐该组件。值应该是一个介于 0 和 1 之间的数，其中 0 表示顶部对齐，1 表示底部对齐，0.5 表示居中对齐等。

getLayoutAlignmentY

float getLayoutAlignmentY(Container target)
返回沿 Y 轴的对齐方式。它指定如何相对于其他组件对齐该组件。值应该是一个介于 0 和 1 之间的数，其中 0 表示顶部对齐，1 表示底部对齐，0.5 表示居中对齐等。

invalidateLayout

void invalidateLayout(Container target)
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinearGradientPaint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 LinearGradientPaint

java.lang.Object
    继承者  java.awt.MultipleGradientPaint
        继承者  java.awt.LinearGradientPaint
所有已实现的接口：
Paint, Transparency
public final class LinearGradientPaint
extends MultipleGradientPaint

LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。用户可以指定两种或多种渐变颜色，并且此绘制将在颜色与颜色之间提供一个插值。用户还可以指定起始点和结束点，它们定义了颜色渐变在用户空间中的开始和结束位置。

用户必须提供一个 float 数组，指定如何沿渐变分布颜色。这些值的范围从 0.0 到 1.0，其作用与沿着渐变的关键帧类似（它们标记了渐变应完全变为某种特定颜色的位置）。

在用户没有将第一个关键帧值设置为等于 0 和/或将最后一个关键帧值设置为等于 1 的情况下，将在这些位置创建关键帧，并且第一种颜色和最后一种颜色将在这些位置处复制。因此，如果用户指定以下数组来构造渐变：

{Color.BLUE, Color.RED}, {.3f, .7f}
那么此渐变将转换为一个带有以下关键帧的渐变：
{Color.BLUE, Color.BLUE, Color.RED, Color.RED}, {0f, .3f, .7f, 1f}

在填充起始点和结束点以外的颜色时，用户也可以选择 LinearGradientPaint 应执行的动作。如果没有指定循环方法，则将默认选择 NO_CYCLE，这意味着将使用端点颜色填充剩余的区域。

colorSpace 参数允许用户指定应在哪一种颜色空间（默认 sRGB 或线性 RGB）中执行插值操作。

以下代码演示了 LinearGradientPaint 的典型用法：

Point2D start = new Point2D.Float(0, 0);
Point2D end = new Point2D.Float(50, 50);
float[] dist = {0.0f, 0.2f, 1.0f};
Color[] colors = {Color.RED, Color.WHITE, Color.BLUE};
LinearGradientPaint p =
new LinearGradientPaint(start, end, dist, colors);

此代码将创建一个 LinearGradientPaint，它插入到渐变前 20% 的红色和白色之间，以及渐变剩余 80% 的白色和蓝色之间。

此图像演示了对以上示例代码使用三种循环方法时的情形：

从以下版本开始：
1.6
另请参见：
Paint, Graphics2D.setPaint(java.awt.Paint)

嵌套类摘要
从类 java.awt.MultipleGradientPaint 继承的嵌套类/接口
MultipleGradientPaint.ColorSpaceType, MultipleGradientPaint.CycleMethod
字段摘要
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
方法摘要
PaintContext | createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
Point2D | getEndPoint() 返回渐变轴结束点的副本。
Point2D | getStartPoint() 返回渐变轴起始点的副本。
从类 java.awt.MultipleGradientPaint 继承的方法
getColors, getColorSpace, getCycleMethod, getFractions, getTransform, getTransparency
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LinearGradientPaint

public LinearGradientPaint(float startX,
                           float startY,
                           float endX,
                           float endY,
                           float[] fractions,
                           Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。

参数：
startX - 用户空间中渐变轴起始点的 X 坐标
startY - 用户空间中渐变轴起始点的 Y 坐标
endX - 用户空间中渐变轴结束点的 X 坐标
endY - 用户空间中渐变轴结束点的 Y 坐标
fractions - 范围从 0.0 到 1.0 之间的数字，用于指定沿渐变的颜色分布
colors - 与每个小数值相对应的颜色数组
抛出：
NullPointerException - 如果 fractions 数组为 null，或 colors 数组为 null
IllegalArgumentException - 如果起始点和结束点是同一个点；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

LinearGradientPaint

public LinearGradientPaint(float startX,
                           float startY,
                           float endX,
                           float endY,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。

参数：
startX - 用户空间中渐变轴起始点的 X 坐标
startY - 用户空间中渐变轴起始点的 Y 坐标
endX - 用户空间中渐变轴结束点的 X 坐标
endY - 用户空间中渐变轴结束点的 Y 坐标
fractions - 范围从 0.0 到 1.0 之间的数字，用于指定沿渐变的颜色分布
colors - 与每个小数值相对应的颜色数组
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
抛出：
NullPointerException - 如果 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null
IllegalArgumentException - 如果起始点和结束点是同一个点；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按照升序提供 fractions

LinearGradientPaint

public LinearGradientPaint(Point2D start,
                           Point2D end,
                           float[] fractions,
                           Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。

参数：
start - 用户空间中渐变轴的起始 Point2D
end - 用户空间中渐变轴的结束 Point2D
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 与每个小数值相对应的颜色数组
抛出：
NullPointerException - 如果有一个点为 null；或者 fractions 数组为 null；或者 colors 数组为 null
IllegalArgumentException - 如果起始点和结束点是同一个点；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

LinearGradientPaint

public LinearGradientPaint(Point2D start,
                           Point2D end,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。

参数：
start - 用户空间中渐变轴的起始 Point2D
end - 用户空间中渐变轴的结束 Point2D
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 与每个小数值相对应的颜色数组
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
抛出：
NullPointerException - 如果有一个点为 null；或者 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null
IllegalArgumentException - 如果起始点和结束点为同一个点；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

LinearGradientPaint

public LinearGradientPaint(Point2D start,
                           Point2D end,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod,
                           MultipleGradientPaint.ColorSpaceType colorSpace,
                           AffineTransform gradientTransform)
构造一个 LinearGradientPaint。

参数：
start - 用户空间中渐变轴的起始 Point2D
end - 用户空间中渐变轴的结束 Point2D
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 与每个小数值相对应的颜色数组
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
colorSpace - 用于插值操作的颜色空间，该参数为 SRGB 或 LINEAR_RGB
gradientTransform - 将应用到渐变的转换
抛出：
NullPointerException - 如果有一个点为 null；或者 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null；或者 colorSpace 为 null；或者 gradientTransform 为 null
IllegalArgumentException - 如果起始点和结束点为同一个点；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions
方法详细信息

createContext

public PaintContext createContext(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform transform,
                                  RenderingHints hints)
创建并返回用来生成颜色模式的 PaintContext。因为传递给 createContext 的 ColorModel 参数只是一个提示，所以 Paint 的实现应该接受 ColorModel 的 null 参数。注意，如果应用程序没有首选的特定 ColorModel，则为 null 的 ColorModel 参数将给予 Paint 实现完全的选择余地，使其在光栅处理中使用其首选最高效的 ColorModel。

因为 API 文档在 1.4 版本之前没有关于此项的具体描述，因此可能有一些 Paint 实现不能接受 null ColorModel 参数。如果开发人员正在编写代码将 null ColorModel 参数从任意源传递给 Paint 对象的 createContext 方法，则为了实现安全的编码，应该为这些对象构造一个非 null ColorModel，使其抛出 NullPointerException。

参数：
cm - 接收 Paint 数据的 ColorModel。这只用作一个提示。
deviceBounds - 正在呈现的图形图元的设备空间边界框
userBounds - 正在呈现的图形图元的用户空间边界框
transform - 从用户空间到设备空间的 AffineTransform
hints - 上下文对象用于选择所呈现内容的提示
返回：
生成颜色模式的 PaintContext
另请参见：
PaintContext

getStartPoint

public Point2D getStartPoint()
返回渐变轴起始点的副本。

返回：
Point2D 对象，它是此 LinearGradientPaint 第一种颜色着色点的副本。

getEndPoint

public Point2D getEndPoint()
返回渐变轴结束点的副本。

返回：
Point2D 对象，它是此 LinearGradientPaint 最后一种颜色着色点的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


List (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 List

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.List
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible
public class List
extends Component
implements ItemSelectable, Accessible

List 组件为用户提供了一个可滚动的文本项列表。可设置此 list，使其允许用户进行单项或多项选择。

例如以下代码：

 List lst = new List(4, false);
 lst.add("Mercury");
 lst.add("Venus");
 lst.add("Earth");
 lst.add("JavaSoft");
 lst.add("Mars");
 lst.add("Jupiter");
 lst.add("Saturn");
 lst.add("Uranus");
 lst.add("Neptune");
 lst.add("Pluto");
 cnt.add(lst);

当 cnt 为容器时，将生成以下滚动列表：

显示一个包含这些项的列表：Venus、Earth、JavaSoft 和 Mars。Javasoft 为选中状态。

如果 List 允许进行多项选择，则单击已选中的项时，将取消选中该项。在上面的示例中，一次只能从滚动列表中选择一项，因为创建新的滚动列表时，第二个参数为 false。如果 List 不允许进行多项选择，则选择某一项会导致其他选中的项取消选中。

注意，本示例中显示的列表是用四个可视行创建的。创建该列表之后，不可更改可视行的数量。默认的 List 是用四行创建的，所以 lst = new List() 与 list = new List(4, false) 等效。

从 Java 1.1 开始，AWT（Abstract Window Toolkit，抽象窗口工具包）会把列表上发生的所有鼠标、键盘和焦点事件发送给 List 对象。（维护旧的 AWT 事件模型的目的是为了向后兼容，不推荐使用它。）

当用户选中或取消选中某项时，AWT 将向列表发送一个 ItemEvent 实例。当用户双击滚动列表中的某一项时，AWT 会在紧随项事件后向列表发送一个 ActionEvent 实例。当用户选中列表中的某项，按下 return 键时，AWT 也会生成一个动作事件。

如果应用程序需要基于此列表中用户选中或激活的项执行某个动作，则应该相应地实现 ItemListener 或 ActionListener，并注册新的侦听器，以便在此列表中接收事件。

对于多项选择滚动列表，使用外部动作（如单击按钮）来触发动作被认为是一种更好的用户界面。

从以下版本开始：
JDK1.0
另请参见：
ItemEvent, ItemListener, ActionEvent, ActionListener, 序列化表格

嵌套类摘要
protected  class List.AccessibleAWTList
此类实现 List 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
List()
创建新的滚动列表。
List(int rows)
创建一个用指定可视行数初始化的新滚动列表。
List(int rows, boolean multipleMode)
创建一个初始化为显示指定行数的新滚动列表。
方法摘要
 void add(String item)
向滚动列表的末尾添加指定的项。
 void add(String item, int index)
向滚动列表中索引指示的位置添加指定的项。
 void addActionListener(ActionListener l)
添加指定的动作侦听器以从此列表接收动作事件。
 void addItem(String item)
已过时。 由 add(String) 取代。
 void addItem(String item, int index)
已过时。 由 add(String, int) 取代。
 void addItemListener(ItemListener l)
添加指定的项侦听器以接收此列表的项事件。
 void addNotify()
创建列表的同位体。
 boolean allowsMultipleSelections()
已过时。 从 JDK version 1.1 开始，由 isMultipleMode() 取代。
 void clear()
已过时。 从 JDK version 1.1 开始，由 removeAll() 取代。
 int countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
 void delItem(int position)
已过时。 由 remove(String) 和 remove(int) 取代。
 void delItems(int start, int end)
已过时。 从 JDK version 1.1 开始，后来不再公开使用。只希望作为包私有方法时保留此方法。
 void deselect(int index)
取消选择指定索引处的项。
 AccessibleContext getAccessibleContext()
获取与此 List 关联的 AccessibleContext。
 ActionListener[] getActionListeners()
返回已在此列表上注册的所有动作侦听器的数组。
 String getItem(int index)
获取与指定索引关联的项。
 int getItemCount()
获取列表中的项数。
 ItemListener[] getItemListeners()
返回已在此列表上注册的所有项侦听器的数组。
 String[] getItems()
获取列表中的项。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
 Dimension getMinimumSize()
确定此滚动列表的最小大小。
 Dimension getMinimumSize(int rows)
获取具有指定行数的列表的最少维数。
 Dimension getPreferredSize()
获取此滚动列表的首选大小。
 Dimension getPreferredSize(int rows)
获取具有指定行数的列表的首选维数。
 int getRows()
获取此列表中的可视行数。
 int getSelectedIndex()
获取列表中选中项的索引。
 int[] getSelectedIndexes()
获取列表中选中的索引。
 String getSelectedItem()
获取此滚动列表中选中的项。
 String[] getSelectedItems()
获取此滚动列表中选中的项。
 Object[] getSelectedObjects()
获取对象数组中此滚动列表的选中项。
 int getVisibleIndex()
获取上次由 makeVisible 方法使其可视的项的索引。
 boolean isIndexSelected(int index)
确定是否已选中此滚动列表中的指定项。
 boolean isMultipleMode()
确定此列表是否允许进行多项选择。
 boolean isSelected(int index)
已过时。 从 JDK version 1.1 开始，由 isIndexSelected(int) 取代。
 void makeVisible(int index)
使指定索引处的项可视。
 Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension minimumSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
protected  String paramString()
返回表示此滚动列表状态的参数字符串。
 Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension preferredSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
protected  void processActionEvent(ActionEvent e)
处理发生在此列表上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
protected  void processEvent(AWTEvent e)
此滚动列表的进程事件。
protected  void processItemEvent(ItemEvent e)
处理发生在此列表上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
 void remove(int position)
从此滚动列表中移除指定位置处的项。
 void remove(String item)
从列表中移除项的第一次出现。
 void removeActionListener(ActionListener l)
移除指定的动作侦听器，以便不再从此列表接收动作事件。
 void removeAll()
从此列表中移除所有项。
 void removeItemListener(ItemListener l)
移除指定的项侦听器，以便不再从此列表接收项事件。
 void removeNotify()
移除此列表的同位体。
 void replaceItem(String newValue, int index)
使用新字符串替换滚动列表中指定索引处的项。
 void select(int index)
选择滚动列表中指定索引处的项。
 void setMultipleMode(boolean b)
设置确定此列表是否允许进行多项选择的标志。
 void setMultipleSelections(boolean b)
已过时。 从 JDK version 1.1 开始，由 setMultipleMode(boolean) 取代。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

List

public List()
     throws HeadlessException
创建新的滚动列表。默认情况下，有四个可视行，并且不允许进行多项选择。注意，这是 List(0, false) 的一种便捷方法。还要注意，列表中的可视行数一旦创建就不能更改。

抛出：
HeadlessException - 如果为 GraphicsEnvironment.isHeadless()，则返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

List

public List(int rows)
     throws HeadlessException
创建一个用指定可视行数初始化的新滚动列表。默认情况下，不允许进行多项选择。注意，这是 List(rows, false) 的一种便捷方法。还要注意，列表中的可视行数一旦创建就不能更改。

参数：
rows - 要显示的项数。
抛出：
HeadlessException - 如果为 GraphicsEnvironment.isHeadless()，则返回 true。
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()

List

public List(int rows,
            boolean multipleMode)
     throws HeadlessException
创建一个初始化为显示指定行数的新滚动列表。注意，如果指定了零行，则会按默认的四行创建列表。还要注意，列表中的可视行数一旦创建就不能更改。如果 multipleMode 的值为 true，则用户可从列表中选择多项。如果为 false，则一次只能选择一项。

参数：
rows - 要显示的项数。
multipleMode - 如果为 true，则允许进行多项选择；否则，一次只能选择一项。
抛出：
HeadlessException - 如果为 GraphicsEnvironment.isHeadless()，则返回 true。
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建列表的同位体。同位体允许我们在不更改列表功能的情况下修改其外观。

覆盖：
类 Component 中的 addNotify
另请参见：
Component.isDisplayable(), Component.removeNotify()

removeNotify

public void removeNotify()
移除此列表的同位体。同位体允许我们在不更改列表功能的情况下修改其外观。

覆盖：
类 Component 中的 removeNotify
另请参见：
Component.isDisplayable(), Component.addNotify()

getItemCount

public int getItemCount()
获取列表中的项数。

返回：
列表中的项数
从以下版本开始：
JDK1.1
另请参见：
getItem(int)

countItems

@Deprecated
public int countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。

getItem

public String getItem(int index)
获取与指定索引关联的项。

参数：
index - 项的位置
返回：
一个与指定索引关联的项
另请参见：
getItemCount()

getItems

public String[] getItems()
获取列表中的项。

返回：
一个包含列表中项的字符串数组
从以下版本开始：
JDK1.1
另请参见：
select(int), deselect(int), isIndexSelected(int)

add

public void add(String item)
向滚动列表的末尾添加指定的项。

参数：
item - 要添加的项
从以下版本开始：
JDK1.1

addItem

@Deprecated
public void addItem(String item)
已过时。 由 add(String) 取代。

add

public void add(String item,
                int index)
向滚动列表中索引指示的位置添加指定的项。索引是从零开始的。如果索引值小于零，或者索引值大于或等于列表中的项数，则将该项添加到列表的末尾。

参数：
item - 要添加的项；如果此参数为 null，则该项被视为空字符串 ""
index - 添加项的位置
从以下版本开始：
JDK1.1

addItem

@Deprecated
public void addItem(String item,
                               int index)
已过时。 由 add(String, int) 取代。

replaceItem

public void replaceItem(String newValue,
                        int index)
使用新字符串替换滚动列表中指定索引处的项。

参数：
newValue - 一个替换现有项的新字符串
index - 要替换项的位置
抛出：
ArrayIndexOutOfBoundsException - 如果 index 超出范围。

removeAll

public void removeAll()
从此列表中移除所有项。

从以下版本开始：
JDK1.1
另请参见：
remove(java.lang.String), delItems(int, int)

clear

@Deprecated
public void clear()
已过时。 从 JDK version 1.1 开始，由 removeAll() 取代。

remove

public void remove(String item)
从列表中移除项的第一次出现。如果选中了指定的项，并且该项是列表中唯一选中的项，则列表将被设置为无选择。

参数：
item - 从列表中移除的项
抛出：
IllegalArgumentException - 如果列表中不存在该项
从以下版本开始：
JDK1.1

remove

public void remove(int position)
从此滚动列表中移除指定位置处的项。如果选中了指定位置的项，并且该项是列表中惟一选中的项，则列表将被设置为无选择。

参数：
position - 要删除项的索引
抛出：
ArrayIndexOutOfBoundsException - 如果 position 小于零或大于 getItemCount()-1
从以下版本开始：
JDK1.1
另请参见：
add(String, int)

delItem

@Deprecated
public void delItem(int position)
已过时。 由 remove(String) 和 remove(int) 取代。

getSelectedIndex

public int getSelectedIndex()
获取列表中选中项的索引。

返回：
选中项的索引；如果没有选中的项，或者选中了多项，则返回 -1。
另请参见：
select(int), deselect(int), isIndexSelected(int)

getSelectedIndexes

public int[] getSelectedIndexes()
获取列表中选中的索引。

返回：
此滚动列表中选中索引的一个数组；如果没有选中的项，则返回一个零长度的数组。
另请参见：
select(int), deselect(int), isIndexSelected(int)

getSelectedItem

public String getSelectedItem()
获取此滚动列表中选中的项。

返回：
列表中选中的项；如果没有选中的项，或者选中了多项，则返回 null。
另请参见：
select(int), deselect(int), isIndexSelected(int)

getSelectedItems

public String[] getSelectedItems()
获取此滚动列表中选中的项。

返回：
此滚动列表中选中项的数组；如果没有选中的项，则返回一个零长度的数组。
另请参见：
select(int), deselect(int), isIndexSelected(int)

getSelectedObjects

public Object[] getSelectedObjects()
获取对象数组中此滚动列表的选中项。

指定者：
接口 ItemSelectable 中的 getSelectedObjects
返回：
表示此滚动列表中选中项的 Object 数组；如果没有选中的项，则会返回一个零长度的数组。
另请参见：
getSelectedItems(), ItemSelectable

select

public void select(int index)
选择滚动列表中指定索引处的项。

注意，超出参数范围是无效的，并且将导致未指定的行为。

注意，此方法应主要用于初始选择此组件中的项。以编程方式调用此方法不 会触发 ItemEvent。触发 ItemEvent 的唯一方式是通过用户交互。

参数：
index - 要选择的项位置
另请参见：
getSelectedItem(), deselect(int), isIndexSelected(int)

deselect

public void deselect(int index)
取消选择指定索引处的项。

注意，超出参数范围是无效的，并且将导致未指定的行为。

如果指定索引处的项未选中，则忽略操作。

参数：
index - 要取消选择项的位置
另请参见：
select(int), getSelectedItem(), isIndexSelected(int)

isIndexSelected

public boolean isIndexSelected(int index)
确定是否已选中此滚动列表中的指定项。

参数：
index - 要检查的项
返回：
如果已选中指定的项，则返回 true；否则返回 false
从以下版本开始：
JDK1.1
另请参见：
select(int), deselect(int)

isSelected

@Deprecated
public boolean isSelected(int index)
已过时。 从 JDK version 1.1 开始，由 isIndexSelected(int) 取代。

getRows

public int getRows()
获取此列表中的可视行数。注意，一旦完成 List 创建，行数将永远不变。

返回：
此滚动列表的可视行数

isMultipleMode

public boolean isMultipleMode()
确定此列表是否允许进行多项选择。

返回：
如果此列表允许进行多项选择，则返回 true；否则返回 false
从以下版本开始：
JDK1.1
另请参见：
setMultipleMode(boolean)

allowsMultipleSelections

@Deprecated
public boolean allowsMultipleSelections()
已过时。 从 JDK version 1.1 开始，由 isMultipleMode() 取代。

setMultipleMode

public void setMultipleMode(boolean b)
设置确定此列表是否允许进行多项选择的标志。当选择模式从多项选择更改为单项选择时，选中的项将会发生以下变化：如果选中的项具有位置光标，则只有该项仍保持选中。如果无选中项具有位置光标，则所有项都将取消选中。

参数：
b - 如果为 true，则允许进行多项选择；否则，只能一次从列表中选择一项。
从以下版本开始：
JDK1.1
另请参见：
isMultipleMode()

setMultipleSelections

@Deprecated
public void setMultipleSelections(boolean b)
已过时。 从 JDK version 1.1 开始，由 setMultipleMode(boolean) 取代。

getVisibleIndex

public int getVisibleIndex()
获取上次由 makeVisible 方法使其可视的项的索引。

返回：
上次变得可视的项的索引
另请参见：
makeVisible(int)

makeVisible

public void makeVisible(int index)
使指定索引处的项可视。

参数：
index - 项的位置
另请参见：
getVisibleIndex()

getPreferredSize

public Dimension getPreferredSize(int rows)
获取具有指定行数的列表的首选维数。

参数：
rows - 列表的行数
返回：
给出此滚动列表必须可视的指定行数，返回用于显示滚动列表的首选维数
从以下版本开始：
JDK1.1
另请参见：
Component.getPreferredSize()

preferredSize

@Deprecated
public Dimension preferredSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。

getPreferredSize

public Dimension getPreferredSize()
获取此滚动列表的首选大小。

覆盖：
类 Component 中的 getPreferredSize
返回：
用于显示此滚动列表的首选维数
从以下版本开始：
JDK1.1
另请参见：
Component.getPreferredSize()

preferredSize

@Deprecated
public Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。

覆盖：
类 Component 中的 preferredSize

getMinimumSize

public Dimension getMinimumSize(int rows)
获取具有指定行数的列表的最少维数。

参数：
rows - 列表的行数
返回：
给出此滚动列表必须可视的指定行数，返回用于显示滚动列表的最少维数
从以下版本开始：
JDK1.1
另请参见：
Component.getMinimumSize()

minimumSize

@Deprecated
public Dimension minimumSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。

getMinimumSize

public Dimension getMinimumSize()
确定此滚动列表的最小大小。

覆盖：
类 Component 中的 getMinimumSize
返回：
显示此滚动列表所需的最少维数
从以下版本开始：
JDK1.1
另请参见：
Component.getMinimumSize()

minimumSize

@Deprecated
public Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。

覆盖：
类 Component 中的 minimumSize

addItemListener

public void addItemListener(ItemListener l)
添加指定的项侦听器以接收此列表的项事件。发送项事件以响应用户输入，但不响应对 select 或 deselect 的调用。如果侦听器 l 为 null，则不会抛出异常，并且不执行动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 addItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
removeItemListener(java.awt.event.ItemListener), getItemListeners(), select(int), deselect(int), ItemEvent, ItemListener

removeItemListener

public void removeItemListener(ItemListener l)
移除指定的项侦听器，以便不再从此列表接收项事件。如果侦听器 l 为 null，则不会抛出异常，并且不执行动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

指定者：
接口 ItemSelectable 中的 removeItemListener
参数：
l - 项侦听器
从以下版本开始：
JDK1.1
另请参见：
addItemListener(java.awt.event.ItemListener), getItemListeners(), ItemEvent, ItemListener

getItemListeners

public ItemListener[] getItemListeners()
返回已在此列表上注册的所有项侦听器的数组。

返回：
此列表的所有 ItemListener，如果当前没有已注册的项侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addItemListener(java.awt.event.ItemListener), removeItemListener(java.awt.event.ItemListener), ItemEvent, ItemListener

addActionListener

public void addActionListener(ActionListener l)
添加指定的动作侦听器以从此列表接收动作事件。当用户双击列表项时或者在此列表具有键盘焦点时按 Enter 键，将发生动作事件。

如果侦听器 l 为 null，则不会抛出异常，并且不执行动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

参数：
l - 动作侦听器
从以下版本开始：
JDK1.1
另请参见：
removeActionListener(java.awt.event.ActionListener), getActionListeners(), ActionEvent, ActionListener

removeActionListener

public void removeActionListener(ActionListener l)
移除指定的动作侦听器，以便不再从此列表接收动作事件。当用户双击列表项时，将发生动作事件。如果侦听器 l 为 null，则不会抛出异常，并且不执行动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

参数：
l - 动作侦听器
从以下版本开始：
JDK1.1
另请参见：
addActionListener(java.awt.event.ActionListener), getActionListeners(), ActionEvent, ActionListener

getActionListeners

public ActionListener[] getActionListeners()
返回已在此列表上注册的所有动作侦听器的数组。

返回：
此列表的所有 ActionListener，如果当前没有已注册的动作侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener), ActionEvent, ActionListener

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以查询其项侦听器具有以下代码的 List l：

ItemListener[] ils = (ItemListener[])(l.getListeners(ItemListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 Component 中的 getListeners
参数：
listenerType - 请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
在此列表上注册为 FooListener 的所有对象的数组
抛出：
ClassCastException - 如果 listenerType 未指定实现 java.util.EventListener 的类或接口。
从以下版本开始：
1.3
另请参见：
getItemListeners()

processEvent

protected void processEvent(AWTEvent e)
此滚动列表的进程事件。如果事件是 ItemEvent 的一个实例，则该事件将调用 processItemEvent 方法。另外，如果事件是 ActionEvent 的一个实例，则它将调用 processActionEvent。如果事件不是一个项事件或动作事件，则它将调用超类的 processEvent。

注意，如果事件参数为 null，则行为未指定，并可能抛出异常。

覆盖：
类 Component 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
ActionEvent, ItemEvent, processActionEvent(java.awt.event.ActionEvent), processItemEvent(java.awt.event.ItemEvent)

processItemEvent

protected void processItemEvent(ItemEvent e)
处理发生在此列表上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。

除非此组件启用了项事件，才会调用此方法。当出现以下情况时，将启用项事件：

  • ItemListener 对象通过 addItemListener 注册。
  • 项事件通过 enableEvents 启用。

注意，如果事件参数为 null，则行为未指定，并可能抛出异常。

参数：
e - 项事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, ItemListener, addItemListener(java.awt.event.ItemListener), Component.enableEvents(long)

processActionEvent

protected void processActionEvent(ActionEvent e)
处理发生在此列表上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。

除非此组件启用了动作事件，才会调用此方法。当出现以下情况时，将启用动作事件：

  • ActionListener 对象通过 addActionListener 注册。
  • 动作事件通过 enableEvents 启用。

注意，如果事件参数为 null，则行为未指定，并可能导致一个异常。

参数：
e - 动作事件
从以下版本开始：
JDK1.1
另请参见：
ActionEvent, ActionListener, addActionListener(java.awt.event.ActionListener), Component.enableEvents(long)

paramString

protected String paramString()
返回表示此滚动列表状态的参数字符串。此字符串对调试很有用。

覆盖：
类 Component 中的 paramString
返回：
此滚动列表的参数字符串

delItems

@Deprecated
public void delItems(int start,
                                int end)
已过时。 从 JDK version 1.1 开始，后来不再公开使用。只希望作为包私有方法时保留此方法。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 List 关联的 AccessibleContext。对于列表，AccessibleContext 采用 AccessibleAWTList 的形式。如有必要，可以创建一个新的 AccessibleAWTList 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
一个 AccessibleAWTList，它将充当此 List 的 AccessibleContext。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


List.AccessibleAWTList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 List.AccessibleAWTList

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.List.AccessibleAWTList
所有已实现的接口：
ActionListener, ItemListener, Serializable, EventListener, AccessibleComponent, AccessibleSelection
正在封闭类：
List
protected class List.AccessibleAWTList
extends Component.AccessibleAWTComponent
implements AccessibleSelection, ItemListener, ActionListener

此类实现 List 类的可访问性支持。它提供适合列表用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
protected  class List.AccessibleAWTList.AccessibleAWTListChild
此类实现 List 子级的可访问性支持。
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
List.AccessibleAWTList()
方法摘要
void | actionPerformed(ActionEvent event) 发生操作时调用。
void | addAccessibleSelection(int i) 将对象中的指定选项添加到对象选择中。
void | clearAccessibleSelection() 清除对象中的选择，从而对象中没有选择任何项。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
int | getAccessibleChildrenCount() 返回对象的可访问子级数。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回表示对象中指定选项的 Accessible。
int | getAccessibleSelectionCount() 返回当前选择的项数。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
boolean | isAccessibleChildSelected(int i) 如果选择了此对象的当前子级，则返回 true。
void | itemStateChanged(ItemEvent event) 在用户已选定或取消选定某项时调用。
void | removeAccessibleSelection(int i) 从对象选择中移除对象中的指定选项。
void | selectAllAccessibleSelection() 如果对象支持多种选择，则导致选择对象中的所有已选择项。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

List.AccessibleAWTList

public List.AccessibleAWTList()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent event)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed

itemStateChanged

public void itemStateChanged(ItemEvent event)
从接口 ItemListener 复制的描述
在用户已选定或取消选定某项时调用。为此方法编写的代码将执行需要在已选定（或已取消选定）项时发生的操作。

指定者：
接口 ItemListener 中的 itemStateChanged

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleAt
参数：
p - 定义 Accessible 左上角的点，在该对象的父对象的坐标空间内给定此点
返回：
指定位置的 Accessible（如果存在）

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象的可访问子级数。如果此对象的所有子级都实现 Accessible，则此方法应该返回该对象的子级数。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个可访问子级。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChild
参数：
i - 子级基于零的索引
返回：
对象的第 n 个 Accessible 子级
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象相关联的 AccessibleSelection。在此类的 Java Accessibility API 的实现中，返回的是此对象，它负责为其本身实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选择的项数。如果未选择项，则返回值 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选择的项数。

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回表示对象中指定选项的 Accessible。如果没有作出选择，或者所选项数少于传入的整数，则返回值为 null。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选项的基于零的索引
返回：
包含所选项的 Accessible
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
如果选择了此对象的当前子级，则返回 true。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子级的基于零的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将对象中的指定选项添加到对象选择中。如果对象支持多种选择，则将指定项添加到所有现有选择中，否则它将替换对象中的所有现有选择。如果已经选择了指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 可选择项的基于零的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从对象选择中移除对象中的指定选项。如果目前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 可选择项的基于零的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，从而对象中没有选择任何项。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
如果对象支持多种选择，则导致选择对象中的所有已选择项。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


List.AccessibleAWTList.AccessibleAWTListChild (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 List.AccessibleAWTList.AccessibleAWTListChild

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.List.AccessibleAWTList.AccessibleAWTListChild
所有已实现的接口：
Serializable, Accessible, AccessibleComponent
正在封闭类：
List.AccessibleAWTList
protected class List.AccessibleAWTList.AccessibleAWTListChild
extends Component.AccessibleAWTComponent
implements Accessible

此类实现 List 子级的可访问性支持。它提供适合列表子级用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
List.AccessibleAWTList.AccessibleAWTListChild(List parent, int indexInParent)
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以从此组件接收焦点事件。
boolean | contains(Point p) 检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。
Accessible | getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回对象的可访问子级数。
AccessibleContext | getAccessibleContext() 获取此对象的 AccessibleContext。
int | getAccessibleIndexInParent() 获取此对象的可访问父级中基于 0 的索引。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
Color | getBackground() 获取此对象的背景颜色。
Rectangle | getBounds() 以 Rectangle 对象的形式获取此对象的界限。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 设置此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景颜色。
Locale | getLocale() 获取组件的区域设置。
Point | getLocation() 获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否已启用对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再从此组件接收焦点事件。
void | requestFocus() 请求聚焦此对象。
void | setBackground(Color c) 设置此对象的背景颜色。
void | setBounds(Rectangle r) 以 Rectangle 对象的形式设置此对象的界限。
void | setCursor(Cursor cursor) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景颜色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addPropertyChangeListener, getAccessibleComponent, getAccessibleDescription, getAccessibleName, getAccessibleParent, removePropertyChangeListener
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

List.AccessibleAWTList.AccessibleAWTListChild

public List.AccessibleAWTList.AccessibleAWTListChild(List parent,
                                                     int indexInParent)
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取此对象的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它是其自身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。对象的 AccessibleStateSet 是由唯一的 AccessibleState 的集合组成的。对象的 AccessibleStateSet 中的更改将导致为 ACCESSIBLE_STATE_PROPERTY 属性激发 PropertyChangeEvent。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象的当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, Component.AccessibleAWTComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

getLocale

public Locale getLocale()
获取组件的区域设置。如果该组件没有区域，则返回其父级的区域。

覆盖：
类 Component.AccessibleAWTComponent 中的 getLocale
返回：
此组件的区域。如果此组件没有区域，则返回其父级的区域。
抛出：
IllegalComponentStateException - 如果该 Component 没有它自己的区域，并且尚未被添加到包含层次结构（那样可以从包含父级确定其区域）。

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象的可访问父级中基于 0 的索引。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleIndexInParent
返回：
返回此对象父级中基于 0 的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
Component.AccessibleAWTComponent.getAccessibleParent(),
getAccessibleChildrenCount(),
getAccessibleChild(int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象的可访问子级数。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是基于零的，因此 Accessible 第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleChild
参数：
i - 子级基于零的索引
返回：
对象的 Accessible 子级
另请参见：
getAccessibleChildrenCount()

getBackground

public Color getBackground()
获取此对象的背景颜色。

指定者：
接口 AccessibleComponent 中的 getBackground
覆盖：
类 Component.AccessibleAWTComponent 中的 getBackground
返回：
对象的背景颜色，如果支持的话；否则返回 null
另请参见：
setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景颜色。

指定者：
接口 AccessibleComponent 中的 setBackground
覆盖：
类 Component.AccessibleAWTComponent 中的 setBackground
参数：
c - 背景的新 Color
另请参见：
setBackground(java.awt.Color)

getForeground

public Color getForeground()
获取此对象的前景颜色。

指定者：
接口 AccessibleComponent 中的 getForeground
覆盖：
类 Component.AccessibleAWTComponent 中的 getForeground
返回：
对象的前景颜色，如果支持的话；否则返回 null
另请参见：
setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
设置此对象的前景颜色。

指定者：
接口 AccessibleComponent 中的 setForeground
覆盖：
类 Component.AccessibleAWTComponent 中的 setForeground
参数：
c - 前景的新 Color
另请参见：
getForeground()

getCursor

public Cursor getCursor()
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
覆盖：
类 Component.AccessibleAWTComponent 中的 getCursor
返回：
对象的 Cursor，如果支持的话；否则返回 null
另请参见：
setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor cursor)
设置此对象的 Cursor。

如果 Java 平台实现和/或本机系统不支持更改鼠标光标形状，则该方法可能不会产生任何视觉效果。

指定者：
接口 AccessibleComponent 中的 setCursor
覆盖：
类 Component.AccessibleAWTComponent 中的 setCursor
参数：
cursor - 对象的新 Cursor
另请参见：
getCursor()

getFont

public Font getFont()
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
覆盖：
类 Component.AccessibleAWTComponent 中的 getFont
返回：
对象的 Font，如果支持的话；否则返回 null
另请参见：
setFont(java.awt.Font)

setFont

public void setFont(Font f)
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
覆盖：
类 Component.AccessibleAWTComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
设置此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
覆盖：
类 Component.AccessibleAWTComponent 中的 getFontMetrics
参数：
f - Font
返回：
对象的 FontMetrics，如果支持的话；否则返回 null
另请参见：
getFont()

isEnabled

public boolean isEnabled()
确定是否已启用对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
覆盖：
类 Component.AccessibleAWTComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
覆盖：
类 Component.AccessibleAWTComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
isEnabled()

isVisible

public boolean isVisible()
确定对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
覆盖：
类 Component.AccessibleAWTComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
覆盖：
类 Component.AccessibleAWTComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
isVisible()

isShowing

public boolean isShowing()
确定是否正显示对象。通过检查对象的可见性及其祖先的可见性可以确定这一点。注：即使该对象被另一对象屏蔽（例如，该对象为下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
覆盖：
类 Component.AccessibleAWTComponent 中的 isShowing
返回：
如果正显示对象，则返回 true；否则返回 false

contains

public boolean contains(Point p)
检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。

指定者：
接口 AccessibleComponent 中的 contains
覆盖：
类 Component.AccessibleAWTComponent 中的 contains
参数：
p - 相对于对象的的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
覆盖：
类 Component.AccessibleAWTComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
getBounds(), getLocation()

getLocation

public Point getLocation()
获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
覆盖：
类 Component.AccessibleAWTComponent 中的 getLocation
返回：
表示对象界限左上角在屏幕坐标空间中的 Point 的实例；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
getBounds(), getLocationOnScreen()

setLocation

public void setLocation(Point p)
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
覆盖：
类 Component.AccessibleAWTComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
getLocation()

getBounds

public Rectangle getBounds()
以 Rectangle 对象的形式获取此对象的界限。这些界限指定此对象的宽度、高度和相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
覆盖：
类 Component.AccessibleAWTComponent 中的 getBounds
返回：
返回指示此组件的界限的长方形；如果此对象不在屏幕上，则返回 null。
另请参见：
contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
以 Rectangle 对象的形式设置此对象的界限。这些界限指定此对象的宽度、高度和相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
覆盖：
类 Component.AccessibleAWTComponent 中的 setBounds
参数：
r - 指示此组件界限的长方形
另请参见：
getBounds()

getSize

public Dimension getSize()
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的高度字段包含此对象的高度，Dimension 对象的宽度字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
覆盖：
类 Component.AccessibleAWTComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
覆盖：
类 Component.AccessibleAWTComponent 中的 setSize
参数：
d - - 指定对象新大小的维数。
另请参见：
getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleAt
参数：
p - 相对于此对象的的点
返回：
如果 Accessible 存在，并且位于指定位置，则返回它；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
返回此对象是否可以接受焦点。可以接受焦点的对象在其 AccessibleStateSet 中也将具有 AccessibleState.FOCUSABLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
覆盖：
类 Component.AccessibleAWTComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
请求聚焦此对象。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
覆盖：
类 Component.AccessibleAWTComponent 中的 requestFocus
另请参见：
isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
添加指定的焦点侦听器，以从此组件接收焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
覆盖：
类 Component.AccessibleAWTComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
移除指定的焦点侦听器，使其不再从此组件接收焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
覆盖：
类 Component.AccessibleAWTComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaTracker (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MediaTracker

java.lang.Object
    继承者  java.awt.MediaTracker
所有已实现的接口：
Serializable
public class MediaTracker
extends Object
implements Serializable

MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。媒体对象可以包括音频剪辑和图像，但目前仅支持图像。

要使用媒体跟踪器，需要创建一个 MediaTracker 实例，然后对每个要跟踪的图像调用其 addImage 方法。另外，还可以为每个图像分配一个唯一的标识符。此标识符可控制获取图像的优先级顺序。它还可用于标识可单独等待的唯一图像子集。具有较低 ID 的图像比具有较高 ID 的图像优先加载。

由于动画图像加载和绘制的多部分特性（multi-part nature），跟踪动画图像可能不是始终有用，但这一功能的确受支持。在完成动画图像的第一帧的加载之后，MediaTracker 会认为动画图像已经加载完毕。这时，MediaTracker 会向所有等待者发出图像已完全加载的信号。如果在第一帧加载完之后没有 ImageObserver 查看此图像，则该图像可能会自我刷新来保存资源（请参见 Image.flush()）。

下面是一个使用 MediaTracker 的示例：

 import java.applet.Applet;
 import java.awt.Color;
 import java.awt.Image;
 import java.awt.Graphics;
 import java.awt.MediaTracker;

 public class ImageBlaster extends Applet implements Runnable {
        MediaTracker tracker;
        Image bg;
        Image anim[] = new Image[5];
        int index;
        Thread animator;

        // Get the images for the background (id == 0)
        // and the animation frames (id == 1)
        // and add them to the MediaTracker
        public void init() {
            tracker = new MediaTracker(this);
            bg = getImage(getDocumentBase(),
                  "images/background.gif");
            tracker.addImage(bg, 0);
            for (int i = 0; i < 5; i++) {
                anim[i] = getImage(getDocumentBase(),
                      "images/anim"+i+".gif");
                tracker.addImage(anim[i], 1);
            }
        }

        // Start the animation thread.
        public void start() {
            animator = new Thread(this);
            animator.start();
        }

        // Stop the animation thread.
        public void stop() {
            animator = null;
        }

        // Run the animation thread.
        // First wait for the background image to fully load
        // and paint.  Then wait for all of the animation
        // frames to finish loading. Finally, loop and
        // increment the animation frame index.
        public void run() {
            try {
                tracker.waitForID(0);
                tracker.waitForID(1);
            } catch (InterruptedException e) {
                return;
            }
            Thread me = Thread.currentThread();
            while (animator == me) {
                try {
                    Thread.sleep(100);
                } catch (InterruptedException e) {
                    break;
                }
                synchronized (this) {
                    index++;
                    if (index >= anim.length) {
                        index = 0;
                    }
                }
                repaint();
            }
        }

        // The background image fills the frame so we
        // don't need to clear the applet on repaints.
        // Just call the paint method.
        public void update(Graphics g) {
            paint(g);
        }

        // Paint a large red rectangle if there are any errors
        // loading the images.  Otherwise always paint the
        // background so that it appears incrementally as it
        // is loading.  Finally, only paint the current animation
        // frame if all of the frames (id == 1) are done loading,
        // so that we don't get partial animations.
        public void paint(Graphics g) {
            if ((tracker.statusAll(false) & MediaTracker.ERRORED) != 0) {
                g.setColor(Color.red);
                g.fillRect(0, 0, size().width, size().height);
                return;
            }
            g.drawImage(bg, 0, 0, this);
            if (tracker.statusID(1, false) == MediaTracker.COMPLETE) {
                g.drawImage(anim[index], 10, 10, this);
            }
        }
 }

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static int | ABORTED 指示媒体下载已中止的标志。
static int | COMPLETE 指示媒体下载已成功完成的标志。
static int | ERRORED 指示媒体下载出错的标志。
static int | LOADING 指示当前正在加载媒体的标志。
构造方法摘要
MediaTracker(Component comp)
创建媒体跟踪器以跟踪给定组件的图像。
方法摘要
void | addImage(Image image, int id) 向此媒体跟踪器正在跟踪的图像列表添加一个图像。
void | addImage(Image image, int id, int w, int h) 向此媒体跟踪器正在跟踪的图像列表添加一个经过缩放的图像。
boolean | checkAll() 查看此媒体跟踪器正在跟踪的所有图像是否已完成加载。
boolean | checkAll(boolean load) 检查此媒体跟踪器正在跟踪的所有图像是否都已完成加载。
boolean | checkID(int id) 检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。
boolean | checkID(int id, boolean load) 检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。
Object[] | getErrorsAny() 返回所有出错媒体的列表。
Object[] | getErrorsID(int id) 返回具有出错的指定 ID 的媒体列表。
boolean | isErrorAny() 检查所有图像的错误状态。
boolean | isErrorID(int id) 检查由此媒体跟踪器跟踪且具有指定标识符的所有图像的错误状态。
void | removeImage(Image image) 从此媒体跟踪器移除指定的图像。
void | removeImage(Image image, int id) 从此媒体跟踪器的指定跟踪 ID 中移除指定的图像。
void | removeImage(Image image, int id, int width, int height) 从此媒体跟踪器移除具有指定宽度、高度和 ID 的指定图像。
int | statusAll(boolean load) 计算并返回此媒体跟踪器跟踪的所有媒体状态的按位或。
int | statusID(int id, boolean load) 计算或返回由此媒体跟踪器跟踪且具有指定标识符的所有媒体状态的按位或。
void | waitForAll() 开始加载由此媒体跟踪器跟踪的所有图像。
boolean | waitForAll(long ms) 开始加载由此媒体跟踪器跟踪的所有图像。
void | waitForID(int id) 开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
boolean | waitForID(int id, long ms) 开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LOADING

public static final int LOADING
指示当前正在加载媒体的标志。

另请参见：
statusAll(boolean), statusID(int, boolean), 常量字段值

ABORTED

public static final int ABORTED
指示媒体下载已中止的标志。

另请参见：
statusAll(boolean), statusID(int, boolean), 常量字段值

ERRORED

public static final int ERRORED
指示媒体下载出错的标志。

另请参见：
statusAll(boolean), statusID(int, boolean), 常量字段值

COMPLETE

public static final int COMPLETE
指示媒体下载已成功完成的标志。

另请参见：
statusAll(boolean), statusID(int, boolean), 常量字段值
构造方法详细信息

MediaTracker

public MediaTracker(Component comp)
创建媒体跟踪器以跟踪给定组件的图像。

参数：
comp - 最终将在其上绘制图像的组件。
方法详细信息

addImage

public void addImage(Image image,
                     int id)
向此媒体跟踪器正在跟踪的图像列表添加一个图像。该图像最终将以它默认的大小（未缩放）呈现。

参数：
image - 要跟踪的图像
id - 用于跟踪此图像的标识符

addImage

public void addImage(Image image,
                     int id,
                     int w,
                     int h)
向此媒体跟踪器正在跟踪的图像列表添加一个经过缩放的图像。该图像最终将以指示的宽度和高度呈现。

参数：
image - 要跟踪的图像
id - 一个可用于跟踪此图像的标识符
w - 用来呈现图像的宽度
h - 用来呈现图像的高度

checkAll

public boolean checkAll()
查看此媒体跟踪器正在跟踪的所有图像是否已完成加载。

如果图像尚未完成加载，则此方法不能开始加载图像。

如果在加载或缩放图像时出错，则该图像被视为已完成加载。使用 isErrorAny 或 isErrorID 方法检查错误。

返回：
如果所有图像都已完成加载、发生中止或出错，则返回 true；否则返回 false
另请参见：
checkAll(boolean), checkID(int), isErrorAny(), isErrorID(int)

checkAll

public boolean checkAll(boolean load)
检查此媒体跟踪器正在跟踪的所有图像是否都已完成加载。

如果此 load 标志的值为 true，则此方法将开始加载任何尚未加载的图像。

如果在加载或缩放图像时出错，则该图像被视为已完成加载。使用 isErrorAny 和 isErrorID 方法检查错误。

参数：
load - 如果为 true，则开始加载任何尚未加载的图像
返回：
如果所有图像都已完成加载、发生中止或出错，则返回 true；否则返回 false
另请参见：
checkID(int),
checkAll(),
isErrorAny(),
isErrorID(int)

isErrorAny

public boolean isErrorAny()
检查所有图像的错误状态。

返回：
如果此媒体跟踪器跟踪的任何图像在加载期间出错，则返回 true；否则返回 false
另请参见：
isErrorID(int), getErrorsAny()

getErrorsAny

public Object[] getErrorsAny()
返回所有出错媒体的列表。

返回：
如果此媒体跟踪器在跟踪媒体对象时出错，则返回一个媒体对象数组；如果不出错，则返回 null
另请参见：
isErrorAny(), getErrorsID(int)

waitForAll

public void waitForAll()
                throws InterruptedException
开始加载由此媒体跟踪器跟踪的所有图像。在完成加载正在跟踪的全部图像之前，此方法一直等待。

如果在加载或缩放图像时出错，则该图像被视为已完成加载。使用 isErrorAny 或 isErrorID 方法检查错误。

抛出：
InterruptedException - 如果任何线程中断了此线程
另请参见：
waitForID(int), waitForAll(long), isErrorAny(), isErrorID(int)

waitForAll

public boolean waitForAll(long ms)
                   throws InterruptedException
开始加载由此媒体跟踪器跟踪的所有图像。在完成加载正在跟踪的所有图像之前，或在 ms 参数（以毫秒为单位）指定的时间到期之前，此方法将一直等待。

如果在加载或缩放图像时出错，则认为该图像已完成加载。使用 isErrorAny 或 isErrorID 方法检查错误。

参数：
ms - 等待加载完成的毫秒数
返回：
如果所有图像都成功加载，则返回 true；否则返回 false
抛出：
InterruptedException - 如果任何线程中断了此线程
另请参见：
waitForID(int), waitForAll(long), isErrorAny(), isErrorID(int)

statusAll

public int statusAll(boolean load)
计算并返回此媒体跟踪器跟踪的所有媒体状态的按位或。

由 MediaTracker 类定义的可能标志有 LOADING、ABORTED、ERRORED 和 COMPLETE。对于尚未开始加载的图像，其状态值为零。

如果 load 值为 true，则此方法开始加载任何尚未加载的图像。

参数：
load - 如果为 true，则开始加载任何尚未加载的图像
返回：
所有正在跟踪媒体状态的按位或
另请参见：
statusID(int, boolean), LOADING, ABORTED, ERRORED, COMPLETE

checkID

public boolean checkID(int id)
检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。

如果图像尚未完成加载，则此方法不能开始加载图像。

如果在加载或缩放图像时出错，则认为该图像已完成加载。使用 isErrorAny 或 isErrorID 方法检查错误。

参数：
id - 要检查的图像标识符
返回：
如果所有图像都已完成加载、发生中止或出错，则返回 true；否则返回 false
另请参见：
checkID(int, boolean),
checkAll(),
isErrorAny(),
isErrorID(int)

checkID

public boolean checkID(int id,
                       boolean load)
检查由此媒体跟踪器跟踪且使用指定标识符标记的所有图像是否已完成加载。

如果此 load 标志的值为 true，则此方法将开始加载任何尚未加载的图像。

如果在加载或缩放图像时出错，则该图像被视为已完成加载。使用 isErrorAny 或 isErrorID 方法检查错误。

参数：
id - 要检查的图像标识符
load - 如果为 true，则开始加载任何尚未加载的图像。
返回：
如果所有图像都已完成加载、发生中止或出错，则返回 true；否则返回 false
另请参见：
checkID(int, boolean),
checkAll(),
isErrorAny(),
isErrorID(int)

isErrorID

public boolean isErrorID(int id)
检查由此媒体跟踪器跟踪且具有指定标识符的所有图像的错误状态。

参数：
id - 要检查图像的标识符
返回：
如果具有指定标识符的任何图像在加载期间出错。则返回 true；否则返回 false
另请参见：
isErrorAny(), getErrorsID(int)

getErrorsID

public Object[] getErrorsID(int id)
返回具有出错的指定 ID 的媒体列表。

参数：
id - 要检查图像的标识符
返回：
如果指定的标识符出错，则返回此媒体跟踪器所跟踪媒体对象的数组；如果没有出错，则返回 null
另请参见：
isErrorID(int), isErrorAny(), getErrorsAny()

waitForID

public void waitForID(int id)
               throws InterruptedException
开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。在完成加载具有指定标识符的全部图像之前，此方法一直等待。

如果在加载或缩放图像时出错，则该图像被视为已完成加载。使用 isErrorAny 和 isErrorID 方法检查错误。

参数：
id - 要检查图像的标识符
抛出：
InterruptedException - 如果任何线程中止了此线程。
另请参见：
waitForAll(),
isErrorAny(),
isErrorID(int)

waitForID

public boolean waitForID(int id,
                         long ms)
                  throws InterruptedException
开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。在完成加载具有指定标识符的全部图像之前，或在 ms 参数（以毫秒为单位）指定的时间到期之前，此方法一直等待。

如果在加载或缩放图像时出错，则该图像被视为已完成加载。使用 statusID、isErrorID 和 isErrorAny 方法检查错误。

参数：
id - 要检查图像的标识符
ms - 等待加载完成的时间长度（以毫秒为单位）
抛出：
InterruptedException - 如果任何线程中断了此线程
另请参见：
waitForAll(),
waitForID(int),
statusID(int, boolean),
isErrorAny(),
isErrorID(int)

statusID

public int statusID(int id,
                    boolean load)
计算或返回由此媒体跟踪器跟踪且具有指定标识符的所有媒体状态的按位或。

由 MediaTracker 类定义的可能标志有 LOADING、ABORTED、ERRORED 和 COMPLETE。尚未开始加载的图像，其状态值为零。

如果 load 值为 true，则此方法开始加载任何尚未加载的图像。

参数：
id - 要检查图像的标识符
load - 如果为 true，则开始加载任何尚未加载的图像
返回：
正在跟踪且具有指定标识符的所有媒体状态的按位或
另请参见：
statusAll(boolean), LOADING, ABORTED, ERRORED, COMPLETE

removeImage

public void removeImage(Image image)
从此媒体跟踪器移除指定的图像。不管缩放比例和 ID 如何，所有指定图像的实例都将被移除。

参数：
image - 要移除的图像
从以下版本开始：
JDK1.1
另请参见：
removeImage(java.awt.Image, int), removeImage(java.awt.Image, int, int, int)

removeImage

public void removeImage(Image image,
                        int id)
从此媒体跟踪器的指定跟踪 ID 中移除指定的图像。不管缩放比例如何，指定 ID 下的所有正在跟踪的 Image 实例都将被移除。

参数：
image - 要移除的图像
id - 从其移除图像的跟踪 ID
从以下版本开始：
JDK1.1
另请参见：
removeImage(java.awt.Image), removeImage(java.awt.Image, int, int, int)

removeImage

public void removeImage(Image image,
                        int id,
                        int width,
                        int height)
从此媒体跟踪器移除具有指定宽度、高度和 ID 的指定图像。仅移除指定的实例（以及任何重复实例）。

参数：
image - 要移除的图像
id - 从其移除图像的跟踪 ID
width - 要移除的宽度（-1 为未缩放）
height - 要移除的高度（-1 为未缩放）
从以下版本开始：
JDK1.1
另请参见：
removeImage(java.awt.Image), removeImage(java.awt.Image, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Menu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Menu

java.lang.Object
    继承者  java.awt.MenuComponent
        继承者  java.awt.MenuItem
            继承者  java.awt.Menu
所有已实现的接口：
MenuContainer, Serializable, Accessible
直接已知子类：
PopupMenu
public class Menu
extends MenuItem
implements MenuContainer, Accessible

Menu 对象是从菜单栏部署的下拉式菜单组件。

菜单可以是任意分离式 菜单。可以打开分离式菜单，并从其父菜单栏或菜单中拖开。释放鼠标按钮之后，它仍然在屏幕上。分离菜单的机制与平台有关，因为分离式菜单的外观由其同位体确定。对于不支持分离式菜单的平台，分离属性会被忽略。

菜单中的每一项都必须属于 MenuItem 类。它可以是 MenuItem 的一个实例、子菜单（Menu 的一个实例）、或复选框（CheckboxMenuItem 的一个实例）。

从以下版本开始：
JDK1.0
另请参见：
MenuItem, CheckboxMenuItem, 序列化表格

嵌套类摘要
protected  class Menu.AccessibleAWTMenu
菜单的内部类，用于为可访问性提供默认支持。
从类 java.awt.MenuItem 继承的嵌套类/接口
MenuItem.AccessibleAWTMenuItem
从类 java.awt.MenuComponent 继承的嵌套类/接口
MenuComponent.AccessibleAWTMenuComponent
构造方法摘要
Menu()
构造具有空标签的新菜单。
Menu(String label)
构造具有指定标签的新菜单。
Menu(String label, boolean tearOff)
构造具有指定标签的新菜单，指示该菜单是否可以分离。
方法摘要
 MenuItem add(MenuItem mi)
将指定的菜单项添加到此菜单。
 void add(String label)
将带有指定标签的项添加到此菜单。
 void addNotify()
创建该菜单的同位体。
 void addSeparator()
将一个分隔线或连字符添加到菜单的当前位置。
 int countItems()
已过时。 从 JDK version 1.1 开始，已由 getItemCount() 取代。
 AccessibleContext getAccessibleContext()
获取与此菜单关联的 AccessibleContext。
 MenuItem getItem(int index)
获取此菜单的指定索引处的项。
 int getItemCount()
获取此菜单中的项数。
 void insert(MenuItem menuitem, int index)
将菜单项插入到此菜单的指定位置。
 void insert(String label, int index)
将带有指定标签的菜单项插入到此菜单的指定位置。
 void insertSeparator(int index)
在指定的位置插入分隔符。
 boolean isTearOff()
指示此菜单是否为分离式菜单。
 String paramString()
返回表示此 Menu 状态的字符串。
 void remove(int index)
从此菜单移除指定索引处的菜单项。
 void remove(MenuComponent item)
从此菜单移除指定的菜单项。
 void removeAll()
从此菜单移除所有项。
 void removeNotify()
移除该菜单的同位体。
从类 java.awt.MenuItem 继承的方法
addActionListener, deleteShortcut, disable, disableEvents, enable, enable, enableEvents, getActionCommand, getActionListeners, getLabel, getListeners, getShortcut, isEnabled, processActionEvent, processEvent, removeActionListener, setActionCommand, setEnabled, setLabel, setShortcut
从类 java.awt.MenuComponent 继承的方法
dispatchEvent, getFont, getName, getParent, getPeer, getTreeLock, postEvent, setFont, setName, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.awt.MenuContainer 继承的方法
getFont, postEvent

构造方法详细信息

Menu

public Menu()
     throws HeadlessException
构造具有空标签的新菜单。此菜单不是分离式菜单。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()

Menu

public Menu(String label)
     throws HeadlessException
构造具有指定标签的新菜单。此菜单不是分离式菜单。

参数：
label - 菜单栏或其他菜单（此菜单是其子菜单）中菜单的标签。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

Menu

public Menu(String label,
            boolean tearOff)
     throws HeadlessException
构造具有指定标签的新菜单，指示该菜单是否可以分离。

可能并非 AWT 的所有实现都支持分离功能。如果特定的实现不支持分离式菜单，则此值会被默认忽略。

参数：
label - 菜单栏或其他菜单（此菜单是其子菜单）中菜单的标签。
tearOff - 如果为 true，则该菜单为分离式菜单。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
JDK1.0.
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建该菜单的同位体。该同位体允许我们修改该菜单的外观，而不更改其功能。

覆盖：
类 MenuItem 中的 addNotify

removeNotify

public void removeNotify()
移除该菜单的同位体。该同位体允许我们修改该菜单的外观，而不更改其功能。

覆盖：
类 MenuComponent 中的 removeNotify

isTearOff

public boolean isTearOff()
指示此菜单是否为分离式菜单。

AWT 的所有实现都不支持分离功能。如果特定的实现不支持分离式菜单，则此值会被默认忽略。

返回：
如果这是一个分离式菜单，则返回 true；否则返回 false。

getItemCount

public int getItemCount()
获取此菜单中的项数。

返回：
此菜单中的项数。
从以下版本开始：
JDK1.1

countItems

@Deprecated
public int countItems()
已过时。 从 JDK version 1.1 开始，已由 getItemCount() 取代。

getItem

public MenuItem getItem(int index)
获取此菜单的指定索引处的项。

参数：
index - 要返回的项的位置。
返回：
指定索引处的项。

add

public MenuItem add(MenuItem mi)
将指定的菜单项添加到此菜单。如果该菜单项为另一个菜单的一部分，则从该菜单移除它。

参数：
mi - 要添加的菜单项
返回：
已添加的菜单项
另请参见：
insert(java.lang.String, int), insert(java.awt.MenuItem, int)

add

public void add(String label)
将带有指定标签的项添加到此菜单。

参数：
label - 该项上的文本
另请参见：
insert(java.lang.String, int), insert(java.awt.MenuItem, int)

insert

public void insert(MenuItem menuitem,
                   int index)
将菜单项插入到此菜单的指定位置。

参数：
menuitem - 要插入的菜单项。
index - 菜单项应插入的位置。
抛出：
IllegalArgumentException - 如果 index 的值小于零
从以下版本开始：
JDK1.1
另请参见：
add(java.lang.String), add(java.awt.MenuItem)

insert

public void insert(String label,
                   int index)
将带有指定标签的菜单项插入到此菜单的指定位置。这是 insert(menuItem, index) 的一个便捷方法。

参数：
label - 项的文本
index - 菜单项应插入的位置
抛出：
IllegalArgumentException - 如果 index 的值小于零
从以下版本开始：
JDK1.1
另请参见：
add(java.lang.String), add(java.awt.MenuItem)

addSeparator

public void addSeparator()
将一个分隔线或连字符添加到菜单的当前位置。

另请参见：
insertSeparator(int)

insertSeparator

public void insertSeparator(int index)
在指定的位置插入分隔符。

参数：
index - 菜单分隔符应插入的位置。
抛出：
IllegalArgumentException - 如果 index 的值小于 0。
从以下版本开始：
JDK1.1
另请参见：
addSeparator()

remove

public void remove(int index)
从此菜单移除指定索引处的菜单项。

参数：
index - 要移除的项的位置。

remove

public void remove(MenuComponent item)
从此菜单移除指定的菜单项。

指定者：
接口 MenuContainer 中的 remove
参数：
item - 要从该菜单移除的项。如果 item 为 null，或不在此菜单中，则此方法不执行任何操作。

removeAll

public void removeAll()
从此菜单移除所有项。

从以下版本开始：
JDK1.0.

paramString

public String paramString()
返回表示此 Menu 状态的字符串。此方法仅用于调试目的，对于这两个实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 MenuItem 中的 paramString
返回：
此菜单的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此菜单关联的 AccessibleContext。对于菜单，AccessibleContext 会采用 AccessibleAWTMenu 的窗体。必要时创建一个新的 AccessibleAWTDialog 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 MenuItem 中的 getAccessibleContext
返回：
用作此菜单的 AccessibleContext 的 AccessibleAWTMenu
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Menu.AccessibleAWTMenu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Menu.AccessibleAWTMenu

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.MenuComponent.AccessibleAWTMenuComponent
            继承者  java.awt.MenuItem.AccessibleAWTMenuItem
                继承者  java.awt.Menu.AccessibleAWTMenu
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleSelection, AccessibleValue
直接已知子类：
PopupMenu.AccessibleAWTPopupMenu
正在封闭类：
Menu
protected class Menu.AccessibleAWTMenu
extends MenuItem.AccessibleAWTMenuItem

菜单的内部类，用于为可访问性提供默认支持。此类并非旨在由应用程序开发人员直接使用，而只能由菜单组件开发人员为其创建子类。

此类实现对 Menu 类的可访问性支持。它提供适合菜单用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
protected Menu.AccessibleAWTMenu()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.MenuItem.AccessibleAWTMenuItem 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleName, getAccessibleValue, getCurrentAccessibleValue, getMaximumAccessibleValue, getMinimumAccessibleValue, setCurrentAccessibleValue
从类 java.awt.MenuComponent.AccessibleAWTMenuComponent 继承的方法
addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Menu.AccessibleAWTMenu

protected Menu.AccessibleAWTMenu()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 MenuItem.AccessibleAWTMenuItem 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MenuBar

java.lang.Object
    继承者  java.awt.MenuComponent
        继承者  java.awt.MenuBar
所有已实现的接口：
MenuContainer, Serializable, Accessible
public class MenuBar
extends MenuComponent
implements MenuContainer, Accessible

MenuBar 类封装绑定到框架的菜单栏的平台概念。为了将该菜单栏与 Frame 对象关联，可以调用该框架的 setMenuBar 方法。

下面是菜单栏的外观：

菜单栏处理菜单项的键盘快捷方式，并将它们传递到其子菜单。（键盘快捷方式是可选的，它为用户提供鼠标的替代方法，可以使用快捷方式调用菜单项并执行与鼠标关联的操作。）每个菜单项都可以维护 MenuShortcut 的一个实例。MenuBar 类定义了多个方法，其中 shortcuts() 和 getShortcutMenuItem(java.awt.MenuShortcut) 用于检索有关给定的菜单栏正在管理的快捷方式的信息。

从以下版本开始：
JDK1.0
另请参见：
Frame, Frame.setMenuBar(java.awt.MenuBar), Menu, MenuItem, MenuShortcut, 序列化表格

嵌套类摘要
protected  class MenuBar.AccessibleAWTMenuBar
菜单栏的内部类，用于为可访问性提供默认支持。
从类 java.awt.MenuComponent 继承的嵌套类/接口
MenuComponent.AccessibleAWTMenuComponent
构造方法摘要
MenuBar()
创建新的菜单栏。
方法摘要
 Menu add(Menu m)
将指定的菜单添加到菜单栏。
 void addNotify()
创建该菜单栏的同位体。
 int countMenus()
已过时。 从 JDK version 1.1 开始，由 getMenuCount() 取代。
 void deleteShortcut(MenuShortcut s)
删除指定的菜单快捷方式。
 AccessibleContext getAccessibleContext()
获取与此菜单栏关联的 AccessibleContext。
 Menu getHelpMenu()
获取该菜单栏上的帮助菜单。
 Menu getMenu(int i)
获取指定的菜单。
 int getMenuCount()
获取该菜单栏上的菜单数。
 MenuItem getShortcutMenuItem(MenuShortcut s)
获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。
 void remove(int index)
从此菜单栏移除指定索引处的菜单。
 void remove(MenuComponent m)
从此菜单栏移除指定的菜单组件。
 void removeNotify()
移除该菜单栏的同位体。
 void setHelpMenu(Menu m)
将指定的菜单设置为此菜单栏的帮助菜单。
 Enumeration<MenuShortcut> shortcuts()
获取此菜单栏正在管理的所有菜单快捷方式的枚举。
从类 java.awt.MenuComponent 继承的方法
dispatchEvent, getFont, getName, getParent, getPeer, getTreeLock, paramString, postEvent, processEvent, setFont, setName, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.awt.MenuContainer 继承的方法
getFont, postEvent

构造方法详细信息

MenuBar

public MenuBar()
        throws HeadlessException
创建新的菜单栏。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建该菜单栏的同位体。该同位体允许我们更改该菜单栏的外观，而不改变菜单栏的任何功能。

removeNotify

public void removeNotify()
移除该菜单栏的同位体。该同位体允许我们更改该菜单栏的外观，而不改变菜单栏的任何功能。

覆盖：
类 MenuComponent 中的 removeNotify

getHelpMenu

public Menu getHelpMenu()
获取该菜单栏上的帮助菜单。

返回：
此菜单栏上的帮助菜单。

setHelpMenu

public void setHelpMenu(Menu m)
将指定的菜单设置为此菜单栏的帮助菜单。如果此菜单栏已有帮助菜单，则从该菜单栏移除旧的帮助菜单，并替换为指定的菜单。

参数：
m - 要设置为帮助菜单的菜单

add

public Menu add(Menu m)
将指定的菜单添加到菜单栏。如果该菜单已经是另一个菜单栏的一部分，则从该菜单栏移除它。

参数：
m - 要添加的菜单
返回：
已添加的菜单
另请参见：
remove(int), remove(java.awt.MenuComponent)

remove

public void remove(int index)
从此菜单栏移除指定索引处的菜单。

参数：
index - 要移除的菜单的位置。
另请参见：
add(java.awt.Menu)

remove

public void remove(MenuComponent m)
从此菜单栏移除指定的菜单组件。

指定者：
接口 MenuContainer 中的 remove
参数：
m - 要移除的菜单组件。
另请参见：
add(java.awt.Menu)

getMenuCount

public int getMenuCount()
获取该菜单栏上的菜单数。

返回：
该菜单栏上的菜单数。
从以下版本开始：
JDK1.1

countMenus

@Deprecated
public int countMenus()
已过时。 从 JDK version 1.1 开始，由 getMenuCount() 取代。

getMenu

public Menu getMenu(int i)
获取指定的菜单。

参数：
i - 要返回的菜单的索引位置。
返回：
此菜单栏的指定索引处的菜单。

shortcuts

public Enumeration<MenuShortcut> shortcuts()
获取此菜单栏正在管理的所有菜单快捷方式的枚举。

返回：
此菜单栏正在管理的菜单快捷方式的枚举。
从以下版本开始：
JDK1.1
另请参见：
MenuShortcut

getShortcutMenuItem

public MenuItem getShortcutMenuItem(MenuShortcut s)
获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。

参数：
s - the specified menu shortcut.
从以下版本开始：
JDK1.1
另请参见：
MenuItem, MenuShortcut

deleteShortcut

public void deleteShortcut(MenuShortcut s)
删除指定的菜单快捷方式。

参数：
s - 要删除的菜单快捷方式。
从以下版本开始：
JDK1.1

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此菜单栏关联的 AccessibleContext。对于菜单栏，AccessibleContext 采用 AccessibleAWTMenuBar 的窗体。必要时会创建新的 AccessibleAWTMenuBar 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 MenuComponent 中的 getAccessibleContext
返回：
用作此菜单栏的 AccessibleContext 的 AccessibleAWTMenuBar。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuBar.AccessibleAWTMenuBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MenuBar.AccessibleAWTMenuBar

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.MenuComponent.AccessibleAWTMenuComponent
            继承者  java.awt.MenuBar.AccessibleAWTMenuBar
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleSelection
正在封闭类：
MenuBar
protected class MenuBar.AccessibleAWTMenuBar
extends MenuComponent.AccessibleAWTMenuComponent

菜单栏的内部类，用于为可访问性提供默认支持。此类并非旨在由应用程序开发人员直接使用，而只能由菜单组件开发人员为其创建子类。

此类实现对 MenuBar 类的可访问性支持。它提供适合菜单用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected MenuBar.AccessibleAWTMenuBar()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.MenuComponent.AccessibleAWTMenuComponent 继承的方法
addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MenuBar.AccessibleAWTMenuBar

protected MenuBar.AccessibleAWTMenuBar()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 MenuComponent.AccessibleAWTMenuComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例
从以下版本开始：
1.4
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MenuComponent

java.lang.Object
    继承者  java.awt.MenuComponent
所有已实现的接口：
Serializable
直接已知子类：
MenuBar, MenuItem
public abstract class MenuComponent
extends Object
implements Serializable

抽象类 MenuComponent 是所有与菜单相关的组件的超类。在这一方面，类 MenuComponent 与 AWT 组件的抽象超类 Component 相似。

菜单组件接收并处理 AWT 事件，就像组件通过方法 processEvent 执行的操作一样。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

嵌套类摘要
protected  class MenuComponent.AccessibleAWTMenuComponent
用于为可访问性提供默认支持的 MenuComponent 的内部类。
构造方法摘要
MenuComponent()
创建 MenuComponent。
方法摘要
void | dispatchEvent(AWTEvent e) 将事件传递给此组件或其子组件之一。
AccessibleContext | getAccessibleContext() 获取与此 MenuComponent 关联的 AccessibleContext。
Font | getFont() 获取用于此菜单组件的字体。
String | getName() 获取该菜单组件的名称。
MenuContainer | getParent() 返回此菜单组件的父容器。
java.awt.peer.MenuComponentPeer | getPeer() 已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体。
protected Object | getTreeLock() 获取此组件的锁定对象（拥有该线程同步监视器的对象），该对象可用于 AWT 组件树和布局操作。
protected String | paramString() 返回表示此 MenuComponent 状态的字符串。
boolean | postEvent(Event evt) 已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。
protected void | processEvent(AWTEvent e) 处理发生在此菜单组件上的事件。
void | removeNotify() 移除该菜单组件的同位体。
void | setFont(Font f) 将用于此菜单组件的字体设置为指定字体。
void | setName(String name) 将该组件的名称设置为指定字符串。
String | toString() 返回此菜单组件的表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuComponent

public MenuComponent()
              throws HeadlessException
创建 MenuComponent。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

getName

public String getName()
获取该菜单组件的名称。

返回：
该菜单组件的名称
从以下版本开始：
JDK1.1
另请参见：
setName(java.lang.String)

setName

public void setName(String name)
将该组件的名称设置为指定字符串。

参数：
name - 菜单组件的名称
从以下版本开始：
JDK1.1
另请参见：
getName()

getParent

public MenuContainer getParent()
返回此菜单组件的父容器。

返回：
包含此菜单组件的菜单组件，如果此菜单组件就是最外部组件，即该菜单栏本身，则返回 null

getPeer

@Deprecated
public java.awt.peer.MenuComponentPeer getPeer()
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体。

getFont

public Font getFont()
获取用于此菜单组件的字体。

返回：
在此菜单组件中使用的字体（如果存在）；否则返回 null
另请参见：
setFont(java.awt.Font)

setFont

public void setFont(Font f)
将用于此菜单组件的字体设置为指定字体。除非此菜单组件的所有子组件指定其他字体，否则它们也使用此字体。

有些平台可能不支持对菜件组件的所有字体属性的设置；在这种情况下，调用 setFont 对此菜单组件不支持的字体属性不会产生任何效果。除非此菜单组件的子菜单组件指定其他字体，否则，如果底层平台支持此字体，则这些子组件将使用该字体。

参数：
f - 要设置的字体
另请参见：
getFont(), Font.getAttributes(), TextAttribute

removeNotify

public void removeNotify()
移除该菜单组件的同位体。该同位体允许我们修改该菜单组件的外观，而不改变该菜单组件的功能。

postEvent

@Deprecated
public boolean postEvent(Event evt)
已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。

将指定的事件发布到该菜单。此方法是 Java 1.0 事件系统的一部分，维持它只是为了获得向后兼容。不鼓励使用它，它将来可能不受支持。

参数：
evt - 将要发生的事件

dispatchEvent

public final void dispatchEvent(AWTEvent e)
将事件传递给此组件或其子组件之一。

参数：
e - 事件

processEvent

protected void processEvent(AWTEvent e)
处理发生在此菜单组件上的事件。

注意，如果此事件参数为 null，则此行为是不确定的，而且可能导致异常。

参数：
e - 事件
从以下版本开始：
JDK1.1

paramString

protected String paramString()
返回表示此 MenuComponent 状态的字符串。此方法仅用于调试目的，对于这两个实现，返回的字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

返回：
此菜单组件的参数字符串

toString

public String toString()
返回此菜单组件的表示形式。

覆盖：
类 Object 中的 toString
返回：
此菜单组件的字符串表示形式

getTreeLock

protected final Object getTreeLock()
获取此组件的锁定对象（拥有该线程同步监视器的对象），该对象可用于 AWT 组件树和布局操作。

返回：
此组件的锁定对象

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 MenuComponent 关联的 AccessibleContext。由此基类实现的方法返回 null。扩展 MenuComponent 的类应实现此方法，以返回与该子类关联的 AccessibleContext。

返回：
此 MenuComponent 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuComponent.AccessibleAWTMenuComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MenuComponent.AccessibleAWTMenuComponent

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.MenuComponent.AccessibleAWTMenuComponent
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleSelection
直接已知子类：
MenuBar.AccessibleAWTMenuBar, MenuItem.AccessibleAWTMenuItem
正在封闭类：
MenuComponent
protected abstract class MenuComponent.AccessibleAWTMenuComponent
extends AccessibleContext
implements Serializable, AccessibleComponent, AccessibleSelection

用于为可访问性提供默认支持的 MenuComponent 的内部类。此类不能由应用程序开发人员直接使用，只能由菜单组件开发人员为其创建子类。

可以使用该类来获得此对象的可访问功能。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected MenuComponent.AccessibleAWTMenuComponent()
尽管该类是抽象的，但是应该可以通过所有子类调用它。
方法摘要
void | addAccessibleSelection(int i) 将该对象的指定 Accessible 子对象添加到该对象的选择中。
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以从此组件接收焦点事件。
void | clearAccessibleSelection() 清除该对象中的选择，使该对象中没有子对象被选择。
boolean | contains(Point p) 检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系相关。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。
Accessible | getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
int | getAccessibleChildrenCount() 返回该对象中可访问的子对象数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent（如果存在）。
String | getAccessibleDescription() 获取此对象的可访问的描述。
int | getAccessibleIndexInParent() 获取此对象在其可访问的父对象中的索引。
String | getAccessibleName() 获取此对象的可访问的名称。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子对象。
Accessible | getAccessibleSelection(int i) 返回 Accessible，它表示该对象中指定的已选择的子对象。
int | getAccessibleSelectionCount() 返回当前选择的 Accessible 子对象数。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 以 Rectangle 对象的形式获取此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 返回此对象的区域。
Point | getLocation() 以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isAccessibleChildSelected(int i) 确定是否选择此对象的当前子对象。
boolean | isEnabled() 确定是否启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定该对象是否正在显示。
boolean | isVisible() 确定该对象是否可见。
void | removeAccessibleSelection(int i) 从对象的选择中移除该对象的指定子对象。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使之不再从此组件接收焦点事件。
void | requestFocus() 请求此对象的焦点。
void | selectAllAccessibleSelection() 如果该对象支持多个选择，则会导致该对象的每个子对象都被选择。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 以 Rectangle 对象的形式设置此对象的边界。
void | setCursor(Cursor cursor) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置该对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置该对象相对于父对象的位置。
void | setSize(Dimension d) 调整此对象的大小。
void | setVisible(boolean b) 设置该对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MenuComponent.AccessibleAWTMenuComponent

protected MenuComponent.AccessibleAWTMenuComponent()
尽管该类是抽象的，但是应该可以通过所有子类调用它。

方法详细信息

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子对象。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
如果受对象支持，则返回 AccessibleSelection；否则返回 null
另请参见：
AccessibleSelection

getAccessibleName

public String getAccessibleName()
获取此对象的可访问的名称。几乎永远不应返回 java.awt.MenuComponent.getName，因为它通常不是一个本地化的名称，对用户来说，该名称没有任何意义。如果该对象从根本上说是一个文本对象（例如，菜单项），那么可访问的名称应是该对象的文本（例如，“保存”）。如果该对象有工具提示，则工具提示文本还可以是要返回的适当的 String。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
如果此对象没有名称，则返回该对象的本地化名称——可以为 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问的描述。这应该是一个简明的本地化描述，描述此对象是什么——对用户来说有何意义。如果该对象有一个工具提示，该工具提示文本可以是要返回的适当的字符串，假设该字符串包含对该对象的简明描述（而不仅仅是该对象的名称——例如，将“保存”作为工具提示文本的工具栏上的“保存”图标不应返回工具提示文本作为描述，而应为“保存当前文本文档”）。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
如果此对象没有描述，则返回该对象的本地化描述——可以为 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含该对象当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。如果此对象的父对象实现 Accessible，那么此方法应该只返回 getParent。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
如果此对象没有 Accessible 父对象，则返回此对象的 Accessible 父对象——可能为 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问的父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
此对象在其父对象中的索引；如果此对象没有可访问的父对象，则返回 -1
另请参见：
getAccessibleParent()

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回该对象中可访问的子对象数。如果此对象的所有子对象都实现 Accessible，那么此方法应返回此对象的子对象数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
该对象中可访问的子对象数

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回该对象的第 n 个 Accessible 子对象。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
该对象的第 n 个可访问子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
返回此对象的区域。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此对象的区域

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent（如果存在）。否则，返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
组件
另请参见：
AccessibleComponent

getBackground

public Color getBackground()
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
该对象的背景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景色。（有关透明的信息，请参阅 isOpaque。）

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 该背景的新 Color
另请参见：
Component.isOpaque()

getForeground

public Color getForeground()
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
该对象的前景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 该前景的新 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
该对象的 Curso（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor cursor)
设置此对象的 Cursor。

如果 Java 平台实现和/或本机系统不支持更改鼠标光标形状，则该方法可能不会产生任何视觉效果。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
cursor - 该对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
该对象的 Font（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 该对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
该对象的 FontMetrics（如果受支持）；否则返回 null
另请参见：
getFont()

isEnabled

public boolean isEnabled()
确定是否启用该对象。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果启用了该对象，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
设置该对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
确定该对象是否可见。注：这意味着该对象是可见的；但是，它实际上不显示在屏幕上，因为包含此对象的对象中的一个对象不可见。要确定某一对象是否在屏幕上显示，请使用 isShowing。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
设置该对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
确定该对象是否正在显示。通过检查该对象的可见性和祖先可确定这一点。注：这将返回 true，即使该对象被另一个对象遮掩（例如，该对象碰巧在下拉菜单的下面）。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果对象正在显示，则返回 true；否则返回 false

contains

public boolean contains(Point p)
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系相关。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 与该对象的坐标系相关的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
如果此对象不在屏幕上，则返回屏幕上对象的位置为 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
表示该屏幕坐标空间中对象边界的左上角的 Point的实例；如果此对象或其父对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
设置该对象相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
以 Rectangle 对象的形式获取此对象的边界。该边界可以指定此对象的宽和高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
指示此组件边界的矩形；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
以 Rectangle 对象的形式设置此对象的边界。该边界可以指定此对象的宽和高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的高度字段包含此对象的高度，Dimension 对象的宽度字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
调整此对象的大小。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - - 指定该对象新的大小的 Dimension
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。如果没有 Accessible 子对象，则返回 null。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 定义该对象的父对象的坐标空间中给出的 Accessible 的左上角的点
返回：
如果 Accessible 在指定的位置存在，则返回它；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
返回此对象是否可以接受焦点。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
请求此对象的焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
添加指定的焦点侦听器，以从此组件接收焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
移除指定的焦点侦听器，使之不再从此组件接收焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选择的 Accessible 子对象数。如果不选择子对象，那么返回的值将为 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选择的项数

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回 Accessible，它表示该对象中指定的已选择的子对象。如果没有选择，或选择的子对象数小于传入的整数，那么返回的值将为 null。

注意，该索引表示第 i 个已选择的子对象，它不同于第 i 个子对象。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选子对象的基于零的索引
返回：
第 i 个已选择的子对象
另请参见：
getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
确定是否选择此对象的当前子对象。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象中子对象的基于零的索引
返回：
如果选择此对象的当前子对象，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将该对象的指定 Accessible 子对象添加到该对象的选择中。如果该对象支持多个选择，则将指定的子对象添加到任何现有选择中，否则，它会替换该对象中的任何现有选择。如果指定的子对象已被选择，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 子对象的基于零的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从对象的选择中移除该对象的指定子对象。如果当前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 子对象的基于零的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除该对象中的选择，使该对象中没有子对象被选择。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
如果该对象支持多个选择，则会导致该对象的每个子对象都被选择。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuContainer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 MenuContainer

所有已知实现类：
AbstractButton, AbstractColorChooserPanel, Applet, BasicArrowButton, BasicComboBoxRenderer, BasicComboBoxRenderer.UIResource, BasicComboPopup, BasicInternalFrameTitlePane, BasicInternalFrameTitlePane.SystemMenuBar, BasicSplitPaneDivider, BasicToolBarUI.DragWindow, Box, Box.Filler, Button, Canvas, CellRendererPane, Checkbox, Choice, Component, Container, DefaultListCellRenderer, DefaultListCellRenderer.UIResource, DefaultTableCellRenderer, DefaultTableCellRenderer.UIResource, DefaultTreeCellEditor.DefaultTextField, DefaultTreeCellEditor.EditorContainer, DefaultTreeCellRenderer, Dialog, FileDialog, Frame, JApplet, JButton, JCheckBox, JCheckBoxMenuItem, JColorChooser, JComboBox, JComponent, JDesktopPane, JDialog, JEditorPane, JFileChooser, JFormattedTextField, JFrame, JInternalFrame, JInternalFrame.JDesktopIcon, JLabel, JLayeredPane, JList, JMenu, JMenuBar, JMenuItem, JOptionPane, JPanel, JPasswordField, JPopupMenu, JPopupMenu.Separator, JProgressBar, JRadioButton, JRadioButtonMenuItem, JRootPane, JScrollBar, JScrollPane, JScrollPane.ScrollBar, JSeparator, JSlider, JSpinner, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, JSplitPane, JTabbedPane, JTable, JTableHeader, JTextArea, JTextComponent, JTextField, JTextPane, JToggleButton, JToolBar, JToolBar.Separator, JToolTip, JTree, JViewport, JWindow, Label, List, Menu, MenuBar, MetalComboBoxButton, MetalComboBoxUI.MetalComboPopup, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer, MetalInternalFrameTitlePane, MetalScrollButton, Panel, PopupMenu, Scrollbar, ScrollPane, TextArea, TextComponent, TextField, Window
public interface MenuContainer

所有菜单相关容器的超类。

方法摘要
Font | getFont()
boolean | postEvent(Event evt) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
void | remove(MenuComponent comp)

方法详细信息

getFont

Font getFont()

remove

void remove(MenuComponent comp)

postEvent

@Deprecated
boolean postEvent(Event evt)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MenuItem

java.lang.Object
    继承者  java.awt.MenuComponent
        继承者  java.awt.MenuItem
所有已实现的接口：
Serializable, Accessible
直接已知子类：
CheckboxMenuItem, Menu
public class MenuItem
extends MenuComponent
implements Accessible

菜单中的所有项必须属于类 MenuItem 或其子类之一。

默认的 MenuItem 对象包含一个简单的加标签的菜单项。

此菜单栏的图像显示五个菜单项： 以下文本是对此图像的描述。
前两项是较简单的菜单项，加有标签 "Basic" 和 "Simple"。跟在这两项后面的是一个分隔符，它本身是一个使用标签 "-" 创建的菜单项。接下来是加有 "Check" 标签的 CheckboxMenuItem 的实例。最后一个菜单项是加有 "More Examples" 标签的子菜单，此子菜单是 Menu 的一个实例。

选择菜单项时，AWT 发送一个动作事件到该菜单项。由于该事件是一个 ActionEvent 实例，processEvent 方法会检查该事件，并将它传递到 processActionEvent。后一方法将该事件重定向到任何 ActionListener 对象，该对象已在由此菜单项生成的动作事件中注册权益。

注意，子类 Menu 重写此行为，且在选择其中一个子项前不向该框架发送任何事件。

另请参见：
序列化表格

嵌套类摘要
protected  class MenuItem.AccessibleAWTMenuItem
用于为可访问性提供默认支持的 MenuItem 的内部类。
从类 java.awt.MenuComponent 继承的嵌套类/接口
MenuComponent.AccessibleAWTMenuComponent
构造方法摘要
MenuItem()
构造具有空标签且没有键盘快捷方式的新菜单项。
MenuItem(String label)
构造具有指定的标签且没有键盘快捷方式的新菜单项。
MenuItem(String label, MenuShortcut s)
创建具有关联的键盘快捷方式的菜单项。
方法摘要
 void addActionListener(ActionListener l)
添加指定的动作侦听器，以从此菜单项接收动作事件。
 void addNotify()
创建该菜单项的同位体。
 void deleteShortcut()
删除与此菜单项关联的任何 MenuShortcut 对象。
 void disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
protected  void disableEvents(long eventsToDisable)
禁止将事件提交到将由指定事件掩码参数定义的事件的菜单项。
 void enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
protected  void enableEvents(long eventsToEnable)
允许将事件提交到将由指定事件掩码参数定义的事件的菜单项。
 AccessibleContext getAccessibleContext()
获取与此菜单项关联的 AccessibleContext。
 String getActionCommand()
获取由此菜单项引发的动作事件的命令名。
 ActionListener[] getActionListeners()
返回在此菜单项上注册的所有动作侦听器组成的数组。
 String getLabel()
获取此菜单项的标签。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
 MenuShortcut getShortcut()
获取与此菜单项关联的 MenuShortcut 对象。
 boolean isEnabled()
检查是否启用了此菜单项。
 String paramString()
返回表示此 MenuItem 状态的字符串。
protected  void processActionEvent(ActionEvent e)
处理此菜单项上发生的动作事件，方法是将其指派给任何已注册的 ActionListener 对象。
protected  void processEvent(AWTEvent e)
处理此菜单项上的事件。
 void removeActionListener(ActionListener l)
移除指定的动作侦听器，使其不再从此菜单项中接收动作事件。
 void setActionCommand(String command)
设置由此菜单项引发的动作事件的命令名。
 void setEnabled(boolean b)
设置是否可以选择此菜单项。
 void setLabel(String label)
将此菜单项的标签设置为指定标签。
 void setShortcut(MenuShortcut s)
设置与此菜单项关联的 MenuShortcut 对象。
从类 java.awt.MenuComponent 继承的方法
dispatchEvent, getFont, getName, getParent, getPeer, getTreeLock, postEvent, removeNotify, setFont, setName, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuItem

public MenuItem()
         throws HeadlessException
构造具有空标签且没有键盘快捷方式的新菜单项。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()

MenuItem

public MenuItem(String label)
         throws HeadlessException
构造具有指定的标签且没有键盘快捷方式的新菜单项。注意，保留标签中的“-”，用它来指示菜单项之间的分隔符。默认情况下，启用除分隔符之外的所有菜单项。

参数：
label - 此菜单项的标签。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
JDK1.0
另请参见：
GraphicsEnvironment.isHeadless()

MenuItem

public MenuItem(String label,
                MenuShortcut s)
         throws HeadlessException
创建具有关联的键盘快捷方式的菜单项。注意，保留标签中的“-”，用它来指示菜单项之间的分隔符。默认情况下，启用除分隔符之外的所有菜单项。

参数：
label - 此菜单项的标签。
s - 与此菜单项关联的 MenuShortcut 的实例。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建该菜单项的同位体。该同位体允许我们修改该菜单项的外观，而不改变其功能。

getLabel

public String getLabel()
获取此菜单项的标签。

返回：
此菜单项的标签，如果此菜单项没有标签，则返回 null。
从以下版本开始：
JDK1.0
另请参见：
setLabel(java.lang.String)

setLabel

public void setLabel(String label)
将此菜单项的标签设置为指定标签。

参数：
label - 新标签，如果无标签，则该参数为 null。
从以下版本开始：
JDK1.0
另请参见：
getLabel()

isEnabled

public boolean isEnabled()
检查是否启用了此菜单项。

从以下版本开始：
JDK1.0
另请参见：
setEnabled(boolean)

setEnabled

public void setEnabled(boolean b)
设置是否可以选择此菜单项。

参数：
b - 如果该参数为 true，则启用此菜单项；如果该参数为 false，则禁用它。
从以下版本开始：
JDK1.1
另请参见：
isEnabled()

enable

@Deprecated
public void enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。

enable

@Deprecated
public void enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。

disable

@Deprecated
public void disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。

getShortcut

public MenuShortcut getShortcut()
获取与此菜单项关联的 MenuShortcut 对象。

返回：
与此菜单项关联的菜单快捷方式，如果没有指定菜单快捷方式，则返回 null。
从以下版本开始：
JDK1.1
另请参见：
setShortcut(java.awt.MenuShortcut)

setShortcut

public void setShortcut(MenuShortcut s)
设置与此菜单项关联的 MenuShortcut 对象。如果某一菜单快捷方式已经与此菜单项关联，则取代它。

参数：
s - 与此菜单项关联的菜单快捷方式。
从以下版本开始：
JDK1.1
另请参见：
getShortcut()

deleteShortcut

public void deleteShortcut()
删除与此菜单项关联的任何 MenuShortcut 对象。

从以下版本开始：
JDK1.1

enableEvents

protected final void enableEvents(long eventsToEnable)
允许将事件提交到将由指定事件掩码参数定义的事件的菜单项。

由于在将事件类型的侦听器添加到菜单项时，会自动启用该事件类型，所以只需通过 MenuItem 的子类调用此方法即可，该子类要具有提交到 processEvent 的指定事件类型，不管侦听器是否注册。

参数：
eventsToEnable - 定义事件类型的事件掩码
从以下版本开始：
JDK1.1
另请参见：
processEvent(java.awt.AWTEvent), disableEvents(long), Component.enableEvents(long)

disableEvents

protected final void disableEvents(long eventsToDisable)
禁止将事件提交到将由指定事件掩码参数定义的事件的菜单项。

参数：
eventsToDisable - 定义事件类型的事件掩码
从以下版本开始：
JDK1.1
另请参见：
processEvent(java.awt.AWTEvent), enableEvents(long), Component.disableEvents(long)

setActionCommand

public void setActionCommand(String command)
设置由此菜单项引发的动作事件的命令名。

默认情况下，动作命令设置为菜单项的标签。

参数：
command - 要为此菜单项设置的动作命令。
从以下版本开始：
JDK1.1
另请参见：
getActionCommand()

getActionCommand

public String getActionCommand()
获取由此菜单项引发的动作事件的命令名。

从以下版本开始：
JDK1.1
另请参见：
setActionCommand(java.lang.String)

addActionListener

public void addActionListener(ActionListener l)
添加指定的动作侦听器，以从此菜单项接收动作事件。如果 l 为 null，则不抛出异常，也不执行任何动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

参数：
l - 动作侦听器。
从以下版本开始：
JDK1.1
另请参见：
removeActionListener(java.awt.event.ActionListener), getActionListeners(), ActionEvent, ActionListener

removeActionListener

public void removeActionListener(ActionListener l)
移除指定的动作侦听器，使其不再从此菜单项中接收动作事件。如果 l 为 null，则不抛出异常，也不执行任何动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

参数：
l - 动作侦听器。
从以下版本开始：
JDK1.1
另请参见：
addActionListener(java.awt.event.ActionListener), getActionListeners(), ActionEvent, ActionListener

getActionListeners

public ActionListener[] getActionListeners()
返回在此菜单项上注册的所有动作侦听器组成的数组。

返回：
此菜单项的所有 ActionListener，如果当前未注册动作侦听器，则返回空数组。
从以下版本开始：
1.4
另请参见：
addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener), ActionEvent, ActionListener

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。FooListener 使用 addFooListener 方法注册。

可以使用类文本（如 FooListener.class）指定 listenerType 参数。例如，可以使用下面的代码查询 MenuItem m 的动作侦听器：

ActionListener[] als = (ActionListener[])(m.getListeners(ActionListener.class));
如果不存在此类侦听器，则此方法返回一个空数组。

参数：
listenerType - 请求的侦听器的类型；此参数应指定一个从 java.util.EventListener 继承的接口
返回：
在此菜单项上注册为 FooListener 的所有对象组成的数组，如果未添加此侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个类或者实现 java.util.EventListener 的接口。
从以下版本开始：
1.3
另请参见：
getActionListeners()

processEvent

protected void processEvent(AWTEvent e)
处理此菜单项上的事件。如果事件是 ActionEvent 的一个实例，则调用 processActionEvent（通过 MenuItem 定义的另一个方法）。

当前，菜单项仅支持动作事件。

注意，如果事件参数为 null，则行为是不确定的，而且可能导致异常。

覆盖：
类 MenuComponent 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
ItemEvent, #processItemEvent

processActionEvent

protected void processActionEvent(ActionEvent e)
处理此菜单项上发生的动作事件，方法是将其指派给任何已注册的 ActionListener 对象。不调用此方法，除非为此组件启用了动作事件。在发生以下情况之一时启用动作事件：

  • 通过 addActionListener 注册 ActionListener 对象。
  • 通过 enableEvents 启用动作事件。

注意，如果事件参数为 null，则行为是不确定的，而且可能导致异常。

参数：
e - 动作事件
从以下版本开始：
JDK1.1
另请参见：
ActionEvent, ActionListener, enableEvents(long)

paramString

public String paramString()
返回表示此 MenuItem 状态的字符串。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 MenuComponent 中的 paramString
返回：
此菜单项的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此菜单项关联的 AccessibleContext。对于菜单项，AccessibleContext 采用 AccessibleAWTMenuItem 的形式。必要时要创建新的 AccessibleAWTMenuItem 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 MenuComponent 中的 getAccessibleContext
返回：
用作此菜单项的 AccessibleContext 的 AccessibleAWTMenuItem
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuItem.AccessibleAWTMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MenuItem.AccessibleAWTMenuItem

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.MenuComponent.AccessibleAWTMenuComponent
            继承者  java.awt.MenuItem.AccessibleAWTMenuItem
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleSelection, AccessibleValue
直接已知子类：
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem, Menu.AccessibleAWTMenu
正在封闭类：
MenuItem
protected class MenuItem.AccessibleAWTMenuItem
extends MenuComponent.AccessibleAWTMenuComponent
implements AccessibleAction, AccessibleValue

用于为可访问性提供默认支持的 MenuItem 的内部类。此类并非旨在由应用程序开发人员直接使用，而只能由菜单组件开发人员为其创建子类。

此类实现对 MenuItem 类的可访问性支持。它提供适合菜单项用户界面元素的 Java Accessibility API 实现。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
protected MenuItem.AccessibleAWTMenuItem()
方法摘要
boolean | doAccessibleAction(int i) 对该对象执行指定的操作
AccessibleAction | getAccessibleAction() 获取与此对象关联的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用的操作数。
String | getAccessibleActionDescription(int i) 返回对该对象指定操作的描述。
String | getAccessibleName() 获取此对象的可访问名称。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 以数字形式获取此对象的值。
Number | getMaximumAccessibleValue() 以数字形式获取此对象的最大值。
Number | getMinimumAccessibleValue() 以数字形式获取此对象的最小值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为数字。
从类 java.awt.MenuComponent.AccessibleAWTMenuComponent 继承的方法
addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MenuItem.AccessibleAWTMenuItem

protected MenuItem.AccessibleAWTMenuItem()
方法详细信息

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 MenuComponent.AccessibleAWTMenuComponent 中的 getAccessibleName
返回：
如果此对象没有名称，则返回该对象的本地化名称——可以为 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 MenuComponent.AccessibleAWTMenuComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的 AccessibleAction。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用的操作数。菜单项的默认行为是进行一次操作。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
1，此对象中的 Action 数

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回对该对象指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 该操作的从零开始的索引
返回：
动作的 String 描述
另请参见：
AccessibleAction.getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
对该对象执行指定的操作

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从零开始的索引
返回：
如果执行了该操作，则返回 true；否则，返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
以数字形式获取此对象的值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
如果不选择此对象，则返回整数 0，如果选择此对象，则返回整数 1。
另请参见：
AbstractButton.isSelected()

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为数字。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 True。
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
以数字形式获取此对象的最小值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
整数 0。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
以数字形式获取此对象的最大值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
整数 0。
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuShortcut (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MenuShortcut

java.lang.Object
    继承者  java.awt.MenuShortcut
所有已实现的接口：
Serializable
public class MenuShortcut
extends Object
implements Serializable

表示 MenuItem 键盘加速器的 MenuShortcut 类。

菜单快捷方式是使用虚拟键代码（而不是字符）创建的。例如，Ctrl-a（假设 Control 是加速键）的菜单快捷方式将通过类似以下的代码创建：

MenuShortcut ms = new MenuShortcut(KeyEvent.VK_A, false);

此加速键是与平台有关的，可通过 Toolkit.getMenuShortcutKeyMask() 得到。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
MenuShortcut(int key)
为指定的虚拟键代码构造一个新的 MenuShortcut。
MenuShortcut(int key, boolean useShiftModifier)
为指定的虚拟键代码构造一个新的菜单快捷方式。
方法摘要
boolean | equals(MenuShortcut s) 返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
boolean | equals(Object obj) 返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
int | getKey() 返回此菜单快捷方式的原键代码。
int | hashCode() 返回此菜单快捷方式的哈希码。
protected String | paramString() 返回表示此 MenuShortcut 状态的参数字符串。
String | toString() 返回此菜单快捷方式的国际化描述。
boolean | usesShiftModifier() 返回是否此菜单快捷方式必须使用 SHIFT 键调用。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuShortcut

public MenuShortcut(int key)
为指定的虚拟键代码构造一个新的 MenuShortcut。

参数：
key - 此菜单快捷方式的原键代码，如果按下此键，它将在 KeyEvent 的键代码字段中返回。
另请参见：
KeyEvent

MenuShortcut

public MenuShortcut(int key,
                    boolean useShiftModifier)
为指定的虚拟键代码构造一个新的菜单快捷方式。

参数：
key - 此菜单快捷方式的原键代码，如果按下此键，它将在 KeyEvent 的键代码字段中返回。
useShiftModifier - 指示按下 SHIFT 键是否调用此菜单快捷方式。
另请参见：
KeyEvent
方法详细信息

getKey

public int getKey()
返回此菜单快捷方式的原键代码。

返回：
此菜单快捷方式的原键代码。
从以下版本开始：
JDK1.1
另请参见：
KeyEvent

usesShiftModifier

public boolean usesShiftModifier()
返回是否此菜单快捷方式必须使用 SHIFT 键调用。

返回：
如果此菜单快捷方式必须使用 SHIFT 键调用，则返回 true；否则返回 false。
从以下版本开始：
JDK1.1

equals

public boolean equals(MenuShortcut s)
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。

参数：
s - 要与该菜单快捷方式比较的菜单快捷方式。
返回：
如果此 MenuShortcut 与另一个相同，则返回 true；否则返回 false。
从以下版本开始：
JDK1.1

equals

public boolean equals(Object obj)
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象比较的对象。
返回：
如果此 MenuShortcut 与另一个相同，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此菜单快捷方式的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此菜单快捷方式的哈希码。
从以下版本开始：
1.2
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此菜单快捷方式的国际化描述。

覆盖：
类 Object 中的 toString
返回：
此 MenuShortcut 的字符串表示形式。
从以下版本开始：
JDK1.1

paramString

protected String paramString()
返回表示此 MenuShortcut 状态的参数字符串。此字符串对调试很有用。

返回：
此菜单快捷方式的参数字符串。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MouseInfo

java.lang.Object
    继承者  java.awt.MouseInfo

public class MouseInfo
extends Object

MouseInfo 提供获取有关鼠标信息的方法，如鼠标指针位置和鼠标按钮数。

从以下版本开始：
1.5

方法摘要
static int | getNumberOfButtons() 返回鼠标上的按钮数。
static PointerInfo | getPointerInfo() 返回表示鼠标指针当前位置的 PointerInfo 实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getPointerInfo

public static PointerInfo getPointerInfo()
                                  throws HeadlessException
返回表示鼠标指针当前位置的 PointerInfo 实例。存储在此 PointerInfo 中的 GraphicsDevice 包含该鼠标指针。用于鼠标位置的坐标系取决于 GraphicsDevice 是否为虚拟屏幕设备的一部分。对于虚拟屏幕设备，坐标在虚拟坐标系中给出，否则，它们将在 GraphicsDevice 的坐标系中返回。有关虚拟屏幕设备的更多信息，请参阅 GraphicsConfiguration。在没有鼠标的系统上，返回 null。

如果存在安全管理器，则在创建和返回 PointerInfo 对象之前，将使用 AWTPermission("watchMousePointer") 权限调用其 checkPermission 方法。这可能导致一个 SecurityException 异常。

返回：
鼠标指针的位置
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
SecurityException - 如果存在安全管理器，而且其 checkPermission 方法不允许此操作
从以下版本开始：
1.5
另请参见：
GraphicsConfiguration, SecurityManager.checkPermission(java.security.Permission), AWTPermission

getNumberOfButtons

public static int getNumberOfButtons()
                              throws HeadlessException
返回鼠标上的按钮数。在没有鼠标的系统上，返回 -1。

返回：
鼠标上的按钮数
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultipleGradientPaint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 MultipleGradientPaint

java.lang.Object
    继承者  java.awt.MultipleGradientPaint
所有已实现的接口：
Paint, Transparency
直接已知子类：
LinearGradientPaint, RadialGradientPaint
public abstract class MultipleGradientPaint
extends Object
implements Paint

这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。它存储 LinearGradientPaint 和 RadialGradientPaint 共用的变量和枚举值。

从以下版本开始：
1.6

嵌套类摘要
static class | MultipleGradientPaint.ColorSpaceType 在其中执行渐变插值操作的颜色空间。
static class | MultipleGradientPaint.CycleMethod 在渐变边界以外进行绘制时使用的方法。
字段摘要
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
方法摘要
Color[] | getColors() 返回此渐变所使用的颜色数组的副本。
MultipleGradientPaint.ColorSpaceType | getColorSpace() 返回指定用于插值的颜色空间的枚举类型。
MultipleGradientPaint.CycleMethod | getCycleMethod() 返回指定循环行为的枚举类型。
float[] | getFractions() 返回此渐变所使用的 float 数组的副本，以计算颜色分布。
AffineTransform | getTransform() 返回应用于渐变的变换的副本。
int | getTransparency() 返回此 Paint 对象的透明度模式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Paint 继承的方法
createContext

方法详细信息

getFractions

public final float[] getFractions()
返回此渐变所使用的 float 数组的副本，以计算颜色分布。返回的数组始终以 0 作为其第一个值，1 作为最后一个值，中间的值在二者之间递增。

返回：
此渐变所使用的 float 数组的副本，用于计算颜色分布

getColors

public final Color[] getColors()
返回此渐变所使用的颜色数组的副本。第一种颜色映射到小数数组中的第一个值，最后一种颜色映射到小数数组中的最后一个值。

返回：
此渐变所使用的颜色数组的副本

getCycleMethod

public final MultipleGradientPaint.CycleMethod getCycleMethod()
返回指定循环行为的枚举类型。

返回：
指定循环行为的枚举类型

getColorSpace

public final MultipleGradientPaint.ColorSpaceType getColorSpace()
返回指定用于插值的颜色空间的枚举类型。

返回：
指定用于插作的颜色空间的枚举类型

getTransform

public final AffineTransform getTransform()
返回应用于渐变的变换的副本。

返回：
应用于渐变的变换的副本

getTransparency

public final int getTransparency()
返回此 Paint 对象的透明度模式。

指定者：
接口 Transparency 中的 getTransparency
返回：
一个整数值，表示此 Paint 对象的透明度模式
另请参见：
Transparency
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultipleGradientPaint.ColorSpaceType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.awt
枚举 MultipleGradientPaint.ColorSpaceType

java.lang.Object
    继承者  java.lang.Enum<MultipleGradientPaint.ColorSpaceType>
        继承者  java.awt.MultipleGradientPaint.ColorSpaceType
所有已实现的接口：
Serializable, Comparable<MultipleGradientPaint.ColorSpaceType>
正在封闭类：
MultipleGradientPaint
public static enum MultipleGradientPaint.ColorSpaceType
extends Enum<MultipleGradientPaint.ColorSpaceType>

在其中执行渐变插值操作的颜色空间。

从以下版本开始：
1.6

枚举常量摘要
LINEAR_RGB
指示颜色插值应出现在线性化 RGB 空间。
SRGB
指示颜色插值应出现在 sRGB 空间。
方法摘要
static MultipleGradientPaint.ColorSpaceType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MultipleGradientPaint.ColorSpaceType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

SRGB

public static final MultipleGradientPaint.ColorSpaceType SRGB
指示颜色插值应出现在 sRGB 空间。

LINEAR_RGB

public static final MultipleGradientPaint.ColorSpaceType LINEAR_RGB
指示颜色插值应出现在线性化 RGB 空间。

方法详细信息

values

public static final MultipleGradientPaint.ColorSpaceType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(MultipleGradientPaint.ColorSpaceType c : MultipleGradientPaint.ColorSpaceType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static MultipleGradientPaint.ColorSpaceType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


MultipleGradientPaint.CycleMethod (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.awt
枚举 MultipleGradientPaint.CycleMethod

java.lang.Object
    继承者  java.lang.Enum<MultipleGradientPaint.CycleMethod>
        继承者  java.awt.MultipleGradientPaint.CycleMethod
所有已实现的接口：
Serializable, Comparable<MultipleGradientPaint.CycleMethod>
正在封闭类：
MultipleGradientPaint
public static enum MultipleGradientPaint.CycleMethod
extends Enum<MultipleGradientPaint.CycleMethod>

在渐变边界以外进行绘制时使用的方法。

从以下版本开始：
1.6

枚举常量摘要
NO_CYCLE
使用最终颜色填充剩余的区域。
REFLECT
按照从头到尾、从尾到头的顺序循环渐变颜色，填充剩余区域。
REPEAT
按照从头到尾、从头到尾的顺序循环渐变颜色，填充剩余区域。
方法摘要
static MultipleGradientPaint.CycleMethod | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MultipleGradientPaint.CycleMethod[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

NO_CYCLE

public static final MultipleGradientPaint.CycleMethod NO_CYCLE
使用最终颜色填充剩余的区域。

REFLECT

public static final MultipleGradientPaint.CycleMethod REFLECT
按照从头到尾、从尾到头的顺序循环渐变颜色，填充剩余区域。

REPEAT

public static final MultipleGradientPaint.CycleMethod REPEAT
按照从头到尾、从头到尾的顺序循环渐变颜色，填充剩余区域。

方法详细信息

values

public static final MultipleGradientPaint.CycleMethod[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(MultipleGradientPaint.CycleMethod c : MultipleGradientPaint.CycleMethod.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static MultipleGradientPaint.CycleMethod valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


PageAttributes (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PageAttributes

java.lang.Object
    继承者  java.awt.PageAttributes
所有已实现的接口：
Cloneable
public final class PageAttributes
extends Object
implements Cloneable

用来控制打印页面输出的属性集。

此类的实例控制颜色状态、纸张尺寸（介质类型）、打印方向、逻辑原点、打印质量，以及使用实例的每个页面的分辨率。属性名尽可能遵守 Internet Printing Protocol (IPP) 1.1。属性值要尽可能部分地遵守该协议。

要使用采用内部类类型的方法，需要将引用传递给内部类的常量字段之一。客户端代码无法创建内部类类型的新实例，因为这些类都不具有公共构造方法。例如，为了将颜色状态设置为单色，需要使用以下代码：

 import java.awt.PageAttributes;

 public class MonochromeExample {
     public void setMonochrome(PageAttributes pageAttributes) {
         pageAttributes.setColor(PageAttributes.ColorType.MONOCHROME);
     }
 }

每个支持 attributeName（默认值）的 IPP 属性均有一个对应的 setattributeNameToDefault 方法。未提供默认值字段。

从以下版本开始：
1.3

嵌套类摘要
static class | PageAttributes.ColorType 可能颜色状态的类型安全的枚举。
static class | PageAttributes.MediaType 可能的纸张大小的类型安全的枚举。
static class | PageAttributes.OrientationRequestedType 可能打印方向的类型安全的枚举。
static class | PageAttributes.OriginType 可能原点的类型安全的枚举。
static class | PageAttributes.PrintQualityType 可能的打印质量的类型安全的枚举。
构造方法摘要
PageAttributes()
构造一个具有每个属性的默认值的 PageAttributes 实例。
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。
PageAttributes(PageAttributes obj)
构造一个 PageAttributes 实例，它是所提供的 PageAttributes 的副本。
方法摘要
Object | clone() 创建并返回此 PageAttributes 的一个副本。
boolean | equals(Object obj) 确定两个 PageAttributes 是否相等。
PageAttributes.ColorType | getColor() 返回使用这些属性的页面是以彩色呈现，还是以单色呈现。
PageAttributes.MediaType | getMedia() 返回使用这些属性的页面的纸张尺寸。
PageAttributes.OrientationRequestedType | getOrientationRequested() 返回使用这些属性的页面的打印方向。
PageAttributes.OriginType | getOrigin() 返回在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。
int[] | getPrinterResolution() 返回使用这些属性的页面的打印分辨率。
PageAttributes.PrintQualityType | getPrintQuality() 返回使用这些属性的页面的打印质量。
int | hashCode() 返回此 PageAttributes 的哈希码值。
void | set(PageAttributes obj) 将此 PageAttributes 的所有属性设置为与 obj 的属性相同的值。
void | setColor(PageAttributes.ColorType color) 指定使用这些属性的页面以彩色呈现，还是以单色呈现。
void | setMedia(PageAttributes.MediaType media) 指定使用这些属性的页面所需的纸张尺寸。
void | setMediaToDefault() 将使用这些属性的页面的纸张尺寸设置为默认地区的默认尺寸。
void | setOrientationRequested(int orientationRequested) 指定使用这些属性的页面的打印方向。
void | setOrientationRequested(PageAttributes.OrientationRequestedType orientationRequested) 指定使用这些属性的页面的打印方向。
void | setOrientationRequestedToDefault() 将使用这些属性的页面的打印方向设置为默认值。
void | setOrigin(PageAttributes.OriginType origin) 指定在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。
void | setPrinterResolution(int printerResolution) 指定使用这些属性的页面所需的反向进纸和进纸的打印分辨率，分辨率以每英寸的点数为单位。
void | setPrinterResolution(int[] printerResolution) 指定使用这些属性的页面所需的打印分辨率。
void | setPrinterResolutionToDefault() 将使用这些属性的页面的打印机分辨率设置为默认值。
void | setPrintQuality(int printQuality) 指定使用这些属性的页面的打印质量。
void | setPrintQuality(PageAttributes.PrintQualityType printQuality) 指定使用这些属性的页面的打印质量。
void | setPrintQualityToDefault() 将使用这些属性的页面的打印质量设置为默认值。
String | toString() 返回此 PageAttributes 的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PageAttributes

public PageAttributes()
构造一个具有每个属性的默认值的 PageAttributes 实例。

PageAttributes

public PageAttributes(PageAttributes obj)
构造一个 PageAttributes 实例，它是所提供的 PageAttributes 的副本。

参数：
obj - 要复制的 PageAttributes。

PageAttributes

public PageAttributes(PageAttributes.ColorType color,
                      PageAttributes.MediaType media,
                      PageAttributes.OrientationRequestedType orientationRequested,
                      PageAttributes.OriginType origin,
                      PageAttributes.PrintQualityType printQuality,
                      int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

参数：
color - ColorType.COLOR 或 ColorType.MONOCHROME。
media - MediaType 类的常数字段之一。
orientationRequested - OrientationRequestedType.PORTRAIT 或 OrientationRequestedType.LANDSCAPE。
origin - OriginType.PHYSICAL 或 OriginType.PRINTABLE
printQuality - PrintQualityType.DRAFT、PrintQualityType.NORMAL 或 PrintQualityType.HIGH
printerResolution - 3 个元素的整数数组。第一、二个元素必须大于 0，第三个元素必须为 3 或 4。
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件。
方法详细信息

clone

public Object clone()
创建并返回此 PageAttributes 的一个副本。

覆盖：
类 Object 中的 clone
返回：
新创建的副本。可以安全地将此 Object 强制转换为 PageAttributes。
另请参见：
Cloneable

set

public void set(PageAttributes obj)
将此 PageAttributes 的所有属性设置为与 obj 的属性相同的值。

参数：
obj - 要复制的 PageAttributes。

getColor

public PageAttributes.ColorType getColor()
返回使用这些属性的页面是以彩色呈现，还是以单色呈现。此属性更新为用户选择的值。

返回：
ColorType.COLOR 或 ColorType.MONOCHROME。

setColor

public void setColor(PageAttributes.ColorType color)
指定使用这些属性的页面以彩色呈现，还是以单色呈现。如果不指定此属性，则默认指定 ColorType.MONOCHROME。

参数：
color - ColorType.COLOR 或 ColorType.MONOCHROME。
抛出：
IllegalArgumentException - 如果 color 为 null。

getMedia

public PageAttributes.MediaType getMedia()
返回使用这些属性的页面的纸张尺寸。此属性更新为用户选择的值。

返回：
MediaType 类的常数字段之一。

setMedia

public void setMedia(PageAttributes.MediaType media)
指定使用这些属性的页面所需的纸张尺寸。实际的纸张尺寸取决于目标打印机的限制。如果无法找到精确的匹配，则选择尽可能相近的匹配来实现。如果不指定此属性，则采用默认地区的默认尺寸。美国和加拿大地区的默认尺寸为 MediaType.NA_LETTER。所有其他地区的默认尺寸为 MediaType.ISO_A4。

参数：
media - MediaType 类的常数字段之一。
抛出：
IllegalArgumentException - 如果 media 为 null。

setMediaToDefault

public void setMediaToDefault()
将使用这些属性的页面的纸张尺寸设置为默认地区的默认尺寸。美国和加拿大地区的默认尺寸为 MediaType.NA_LETTER。所有其他地区的默认尺寸为 MediaType.ISO_A4。

getOrientationRequested

public PageAttributes.OrientationRequestedType getOrientationRequested()
返回使用这些属性的页面的打印方向。此属性更新为用户选择的值。

返回：
OrientationRequestedType.PORTRAIT 或 OrientationRequestedType.LANDSCAPE。

setOrientationRequested

public void setOrientationRequested(PageAttributes.OrientationRequestedType orientationRequested)
指定使用这些属性的页面的打印方向。如果不指定此属性，则默认指定 OrientationRequestedType.PORTRAIT。

参数：
orientationRequested - OrientationRequestedType.PORTRAIT 或 OrientationRequestedType.LANDSCAPE。
抛出：
IllegalArgumentException - 如果 orientationRequested 为 null。

setOrientationRequested

public void setOrientationRequested(int orientationRequested)
指定使用这些属性的页面的打印方向。指定 3 表示纵向打印。指定 4 表示横向打印。指定任何其他值将生成 IllegalArgumentException。如果不指定此属性，则默认调用 setOrientationRequested(OrientationRequestedType.PORTRAIT)。

参数：
orientationRequested - 3 或 4
抛出：
IllegalArgumentException - 如果 orientationRequested 不为 3 或 4

setOrientationRequestedToDefault

public void setOrientationRequestedToDefault()
将使用这些属性的页面的打印方向设置为默认值。默认的打印方向为纵向。

getOrigin

public PageAttributes.OriginType getOrigin()
返回在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。（注意，这些位置可能是等效的）。任何实现或目标打印机都不能修改此属性，也不能对其加以限制。

返回：
OriginType.PHYSICAL 或 OriginType.PRINTABLE

setOrigin

public void setOrigin(PageAttributes.OriginType origin)
指定在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。（注意，这些位置可能是等效的）。如果不指定此属性，则默认指定 OriginType.PHYSICAL。

参数：
origin - OriginType.PHYSICAL 或 OriginType.PRINTABLE
抛出：
IllegalArgumentException - 如果 origin 为 null。

getPrintQuality

public PageAttributes.PrintQualityType getPrintQuality()
返回使用这些属性的页面的打印质量。此属性更新为用户选择的值。

返回：
PrintQualityType.DRAFT、PrintQualityType.NORMAL 或 PrintQualityType.HIGH

setPrintQuality

public void setPrintQuality(PageAttributes.PrintQualityType printQuality)
指定使用这些属性的页面的打印质量。如果不指定此属性，则默认指定 PrintQualityType.NORMAL。

参数：
printQuality - PrintQualityType.DRAFT、PrintQualityType.NORMAL 或 PrintQualityType.HIGH
抛出：
IllegalArgumentException - 如果 printQuality 为 null。

setPrintQuality

public void setPrintQuality(int printQuality)
指定使用这些属性的页面的打印质量。指定 3 表示草稿质量。指定 4 表示标准质量。指定 5 表示高质量。指定任何其他值都将会生成 IllegalArgumentException。如果不指定此属性，则调用 setPrintQuality(PrintQualityType.NORMAL)。

参数：
printQuality - 3、4 或 5
抛出：
IllegalArgumentException - 如果 printQuality 不为 3、4 或 5

setPrintQualityToDefault

public void setPrintQualityToDefault()
将使用这些属性的页面的打印质量设置为默认值。默认的打印质量为标准质量。

getPrinterResolution

public int[] getPrinterResolution()
返回使用这些属性的页面的打印分辨率。数组的索引 0 指定反向进纸的分辨率（通常为水平分辨率）。数组的索引 1 指定进纸的分辨率（通常为垂直分辨率）。数组的索引 2 指定分辨率是以每英寸的点数为单位，还是以每厘米的点数为单位。3 表示以每英寸的点数为单位。4 表示以每厘米的点数为单位。

返回：
3 个元素的整数数组。第一、二个元素必须大于 0，第三个元素必须为 3 或 4。

setPrinterResolution

public void setPrinterResolution(int[] printerResolution)
指定使用这些属性的页面所需的打印分辨率。实际的分辨率取决于实现和目标打印机的限制。数组的索引 0 指定反向进纸的分辨率（通常为水平分辨率）。数组的索引 1 指定进纸的分辨率（通常为垂直分辨率）。数组的索引 2 指定分辨率是以每英寸的点数为单位，还是以每厘米的点数为单位。3 表示以每英寸的点数为单位。4 表示以每厘米的点数为单位。注意，1.1 打印实现 (Toolkit.getPrintJob) 要求进纸和反向进纸具有相同的分辨率。如果不指定此属性，则调用 setPrinterResolution(72)。

参数：
printerResolution - 3 个元素的整数数组。第一、二个元素必须大于 0，第三个元素必须为 3 或 4。
抛出：
IllegalArgumentException - 如果违反了一个或多个上述条件。

setPrinterResolution

public void setPrinterResolution(int printerResolution)
指定使用这些属性的页面所需的反向进纸和进纸的打印分辨率，分辨率以每英寸的点数为单位。相同的值同时用于这两种分辨率。实际的分辨率取决于实现和目标打印机的限制。如果不指定此属性，则默认指定 72。

参数：
printerResolution - 大于 0 的整数。
抛出：
IllegalArgumentException - 如果 printerResolution 小于或等于 0。

setPrinterResolutionToDefault

public void setPrinterResolutionToDefault()
将使用这些属性的页面的打印机分辨率设置为默认值。进纸和反向进纸的默认分辨率均为 72 dpi。

equals

public boolean equals(Object obj)
确定两个 PageAttributes 是否相等。

当且仅当两个 PageAttributes 的每个属性均相等时，它们才是相等的。当且仅当字段的引用指向相同的唯一枚举对象时，枚举类型的属性才是相等的。这意味着一个有别名的 media 等效于基础的唯一 media。当且仅当进纸分辨率、反向进纸分辨率和单位相等时，打印机分辨率才是相等的。

覆盖：
类 Object 中的 equals
参数：
obj - 将检查其相等性的对象。
返回：
根据以上标准，obj 是否等于此 PageAttribute。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 PageAttributes 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 PageAttributes 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageAttributes.ColorType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PageAttributes.ColorType

java.lang.Object
    继承者  java.awt.PageAttributes.ColorType
正在封闭类：
PageAttributes
public static final class PageAttributes.ColorType
extends Object

可能颜色状态的类型安全的枚举。

从以下版本开始：
1.3

字段摘要
static PageAttributes.ColorType | COLOR 用来指定颜色打印的 ColorType 实例。
static PageAttributes.ColorType | MONOCHROME 用来指定单色打印的 ColorType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

COLOR

public static final PageAttributes.ColorType COLOR
用来指定颜色打印的 ColorType 实例。

MONOCHROME

public static final PageAttributes.ColorType MONOCHROME
用来指定单色打印的 ColorType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageAttributes.MediaType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PageAttributes.MediaType

java.lang.Object
    继承者  java.awt.PageAttributes.MediaType
正在封闭类：
PageAttributes
public static final class PageAttributes.MediaType
extends Object

可能的纸张大小的类型安全的枚举。这些纸张大小符合 IPP 1.1。

从以下版本开始：
1.3

字段摘要
static PageAttributes.MediaType | A Engineering A (8 1/2 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | A0 ISO_A0 的别名。
static PageAttributes.MediaType | A1 ISO_A1 的别名。
static PageAttributes.MediaType | A10 ISO_A10 的别名。
static PageAttributes.MediaType | A2 ISO_A2 的别名。
static PageAttributes.MediaType | A3 ISO_A3 的别名。
static PageAttributes.MediaType | A4 ISO_A4 的别名。
static PageAttributes.MediaType | A5 ISO_A5 的别名。
static PageAttributes.MediaType | A6 ISO_A6 的别名。
static PageAttributes.MediaType | A7 ISO_A7 的别名。
static PageAttributes.MediaType | A8 ISO_A8 的别名。
static PageAttributes.MediaType | A9 ISO_A9 的别名。
static PageAttributes.MediaType | B Engineering B (11 x 17 in) 的 MediaType 实例。
static PageAttributes.MediaType | B0 ISO_B0 的别名。
static PageAttributes.MediaType | B1 ISO_B1 的别名。
static PageAttributes.MediaType | B10 ISO_B10 的别名。
static PageAttributes.MediaType | B2 ISO_B2 的别名。
static PageAttributes.MediaType | B3 ISO_B3 的别名。
static PageAttributes.MediaType | B4 ISO_B4 的别名。
static PageAttributes.MediaType | B5 ISO_B5 的别名。
static PageAttributes.MediaType | B6 ISO_B6 的别名。
static PageAttributes.MediaType | B7 ISO_B7 的别名。
static PageAttributes.MediaType | B8 ISO_B8 的别名。
static PageAttributes.MediaType | B9 ISO_B9 的别名。
static PageAttributes.MediaType | C Engineering C (17 x 22 in) 的 MediaType 实例。
static PageAttributes.MediaType | C0 ISO_C0 的别名。
static PageAttributes.MediaType | C1 ISO_C1 的别名。
static PageAttributes.MediaType | C10 ISO_C10 的别名。
static PageAttributes.MediaType | C2 ISO_C2 的别名。
static PageAttributes.MediaType | C3 ISO_C3 的别名。
static PageAttributes.MediaType | C4 ISO_C4 的别名。
static PageAttributes.MediaType | C5 ISO_C5 的别名。
static PageAttributes.MediaType | C6 ISO_C6 的别名。
static PageAttributes.MediaType | C7 ISO_C7 的别名。
static PageAttributes.MediaType | C8 ISO_C8 的别名。
static PageAttributes.MediaType | C9 ISO_C9 的别名。
static PageAttributes.MediaType | D Engineering D (22 x 34 in) 的 MediaType 实例。
static PageAttributes.MediaType | E Engineering E (34 x 44 in) 的 MediaType 实例。
static PageAttributes.MediaType | ENV_10 NA_NUMBER_10_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_10X13 NA_10X13_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_10X14 NA_10X14_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_10X15 NA_10X15_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_11 NA_NUMBER_11_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_12 NA_NUMBER_12_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_14 NA_NUMBER_14_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_6X9 NA_6X9_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_7X9 NA_7X9_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_9 NA_NUMBER_9_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_9X11 NA_9X11_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_9X12 NA_9X12_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_INVITE INVITE_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_ITALY ITALY_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_MONARCH MONARCH_ENVELOPE 的别名。
static PageAttributes.MediaType | ENV_PERSONAL PERSONAL_ENVELOPE 的别名。
static PageAttributes.MediaType | EXECUTIVE Executive (7 1/4 x 10 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | FOLIO Folio (8 1/2 x 13 in) 的 MediaType 实例。
static PageAttributes.MediaType | INVITE INVITE_ENVELOPE 的别名。
static PageAttributes.MediaType | INVITE_ENVELOPE Invitation Envelope (220 x 220 mm) 的 MediaType 实例。
static PageAttributes.MediaType | INVOICE Invoice (5 1/2 x 8 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_2A0 ISO/DIN & JIS 2A0 (1189 x 1682 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_4A0 ISO/DIN & JIS 4A0 ( 1682 x 2378 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A0 ISO/DIN & JIS A0 (841 x 1189 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A1 ISO/DIN & JIS A1 (594 x 841 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A10 ISO/DIN & JIS A10 (26 x 37 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A2 ISO/DIN & JIS A2 (420 x 594 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A3 ISO/DIN & JIS A3 (297 x 420 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A4 ISO/DIN & JIS A4 (210 x 297 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A5 ISO/DIN & JIS A5 (148 x 210 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A6 ISO/DIN & JIS A6 (105 x 148 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A7 ISO/DIN & JIS A7 (74 x 105 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A8 ISO/DIN & JIS A8 (52 x 74 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_A9 ISO/DIN & JIS A9 (37 x 52 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B0 ISO/DIN B0 (1000 x 1414 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B1 ISO/DIN B1 ( 707 x 1000 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B10 ISO/DIN B10 (31 x 44 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B2 ISO/DIN B2 (500 x 707 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B3 ISO/DIN B3 (353 x 500 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B4 ISO/DIN B4 (250 x 353 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B4_ENVELOPE ISO_B4 的别名。
static PageAttributes.MediaType | ISO_B5 ISO/DIN B5 (176 x 250 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B5_ENVELOPE ISO_B5 的别名。
static PageAttributes.MediaType | ISO_B6 ISO/DIN B6 (125 x 176 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B7 ISO/DIN B7 (88 x 125 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B8 ISO/DIN B8 (62 x 88 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_B9 ISO/DIN B9 (44 x 62 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C0 ISO/DIN C0 (917 x 1297 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C0_ENVELOPE ISO_C0 的别名。
static PageAttributes.MediaType | ISO_C1 ISO/DIN C1 (648 x 917 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C1_ENVELOPE ISO_C1 的别名。
static PageAttributes.MediaType | ISO_C10 ISO/DIN C10 (28 x 40 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C10_ENVELOPE ISO_C10 的别名。
static PageAttributes.MediaType | ISO_C2 ISO/DIN C2 (458 x 648 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C2_ENVELOPE ISO_C2 的别名。
static PageAttributes.MediaType | ISO_C3 ISO/DIN C3 (324 x 458 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C3_ENVELOPE ISO_C3 的别名。
static PageAttributes.MediaType | ISO_C4 ISO/DIN C4 (229 x 324 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C4_ENVELOPE ISO_C4 的别名。
static PageAttributes.MediaType | ISO_C5 ISO/DIN C5 (162 x 229 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C5_ENVELOPE ISO_C5 的别名。
static PageAttributes.MediaType | ISO_C6 ISO/DIN C6 (114 x 162 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C6_ENVELOPE ISO_C6 的别名。
static PageAttributes.MediaType | ISO_C7 ISO/DIN C7 (81 x 114 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C7_ENVELOPE ISO_C7 的别名。
static PageAttributes.MediaType | ISO_C8 ISO/DIN C8 (57 x 81 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C8_ENVELOPE ISO_C8 的别名。
static PageAttributes.MediaType | ISO_C9 ISO/DIN C9 (40 x 57 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_C9_ENVELOPE ISO_C9 的别名。
static PageAttributes.MediaType | ISO_DESIGNATED_LONG ISO Designated Long (110 x 220 mm) 的 MediaType 实例。
static PageAttributes.MediaType | ISO_DESIGNATED_LONG_ENVELOPE ISO_DESIGNATED_LONG 的别名。
static PageAttributes.MediaType | ITALY ITALY_ENVELOPE 的别名。
static PageAttributes.MediaType | ITALY_ENVELOPE Italy Envelope (110 x 230 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B0 JIS B0 (1030 x 1456 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B1 JIS B1 (728 x 1030 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B10 JIS B10 (32 x 45 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B2 JIS B2 (515 x 728 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B3 JIS B3 (364 x 515 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B4 JIS B4 (257 x 364 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B5 JIS B5 (182 x 257 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B6 JIS B6 (128 x 182 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B7 JIS B7 (91 x 128 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B8 JIS B8 (64 x 91 mm) 的 MediaType 实例。
static PageAttributes.MediaType | JIS_B9 JIS B9 (45 x 64 mm) 的 MediaType 实例。
static PageAttributes.MediaType | LEDGER Ledger (11 x 17 in) 的 MediaType 实例。
static PageAttributes.MediaType | LEGAL NA_LEGAL 的别名。
static PageAttributes.MediaType | LETTER NA_LETTER 的别名。
static PageAttributes.MediaType | MONARCH MONARCH_ENVELOPE 的别名。
static PageAttributes.MediaType | MONARCH_ENVELOPE Monarch Envelope (3 7/8 x 7 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_10X13_ENVELOPE North American (10 x 13 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_10X14_ENVELOPE North American (10 x 14 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_10X15_ENVELOPE North American (10 x 15 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_6X9_ENVELOPE North American (6 x 9 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_7X9_ENVELOPE North American (7 x 9 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_9X11_ENVELOPE North American (9 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_9X12_ENVELOPE North American (9 x 12 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_LEGAL North American Legal (8 1/2 x 14 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_LETTER North American Letter (8 1/2 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_NUMBER_10_ENVELOPE North American #10 Business Envelope (4 1/8 x 9 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_NUMBER_11_ENVELOPE North American #11 Business Envelope (4 1/2 x 10 3/8 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_NUMBER_12_ENVELOPE North American #12 Business Envelope (4 3/4 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_NUMBER_14_ENVELOPE North American #14 Business Envelope (5 x 11 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | NA_NUMBER_9_ENVELOPE North American #9 Business Envelope (3 7/8 x 8 7/8 in) 的 MediaType 实例。
static PageAttributes.MediaType | NOTE NA_LETTER 的别名。
static PageAttributes.MediaType | PERSONAL PERSONAL_ENVELOPE 的别名。
static PageAttributes.MediaType | PERSONAL_ENVELOPE 6 3/4 envelope (3 5/8 x 6 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | QUARTO Quarto (215 x 275 mm) 的 MediaType 实例。
static PageAttributes.MediaType | STATEMENT INVOICE 的别名。
static PageAttributes.MediaType | TABLOID LEDGER 的别名。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ISO_4A0

public static final PageAttributes.MediaType ISO_4A0
ISO/DIN & JIS 4A0 ( 1682 x 2378 mm) 的 MediaType 实例。

ISO_2A0

public static final PageAttributes.MediaType ISO_2A0
ISO/DIN & JIS 2A0 (1189 x 1682 mm) 的 MediaType 实例。

ISO_A0

public static final PageAttributes.MediaType ISO_A0
ISO/DIN & JIS A0 (841 x 1189 mm) 的 MediaType 实例。

ISO_A1

public static final PageAttributes.MediaType ISO_A1
ISO/DIN & JIS A1 (594 x 841 mm) 的 MediaType 实例。

ISO_A2

public static final PageAttributes.MediaType ISO_A2
ISO/DIN & JIS A2 (420 x 594 mm) 的 MediaType 实例。

ISO_A3

public static final PageAttributes.MediaType ISO_A3
ISO/DIN & JIS A3 (297 x 420 mm) 的 MediaType 实例。

ISO_A4

public static final PageAttributes.MediaType ISO_A4
ISO/DIN & JIS A4 (210 x 297 mm) 的 MediaType 实例。

ISO_A5

public static final PageAttributes.MediaType ISO_A5
ISO/DIN & JIS A5 (148 x 210 mm) 的 MediaType 实例。

ISO_A6

public static final PageAttributes.MediaType ISO_A6
ISO/DIN & JIS A6 (105 x 148 mm) 的 MediaType 实例。

ISO_A7

public static final PageAttributes.MediaType ISO_A7
ISO/DIN & JIS A7 (74 x 105 mm) 的 MediaType 实例。

ISO_A8

public static final PageAttributes.MediaType ISO_A8
ISO/DIN & JIS A8 (52 x 74 mm) 的 MediaType 实例。

ISO_A9

public static final PageAttributes.MediaType ISO_A9
ISO/DIN & JIS A9 (37 x 52 mm) 的 MediaType 实例。

ISO_A10

public static final PageAttributes.MediaType ISO_A10
ISO/DIN & JIS A10 (26 x 37 mm) 的 MediaType 实例。

ISO_B0

public static final PageAttributes.MediaType ISO_B0
ISO/DIN B0 (1000 x 1414 mm) 的 MediaType 实例。

ISO_B1

public static final PageAttributes.MediaType ISO_B1
ISO/DIN B1 ( 707 x 1000 mm) 的 MediaType 实例。

ISO_B2

public static final PageAttributes.MediaType ISO_B2
ISO/DIN B2 (500 x 707 mm) 的 MediaType 实例。

ISO_B3

public static final PageAttributes.MediaType ISO_B3
ISO/DIN B3 (353 x 500 mm) 的 MediaType 实例。

ISO_B4

public static final PageAttributes.MediaType ISO_B4
ISO/DIN B4 (250 x 353 mm) 的 MediaType 实例。

ISO_B5

public static final PageAttributes.MediaType ISO_B5
ISO/DIN B5 (176 x 250 mm) 的 MediaType 实例。

ISO_B6

public static final PageAttributes.MediaType ISO_B6
ISO/DIN B6 (125 x 176 mm) 的 MediaType 实例。

ISO_B7

public static final PageAttributes.MediaType ISO_B7
ISO/DIN B7 (88 x 125 mm) 的 MediaType 实例。

ISO_B8

public static final PageAttributes.MediaType ISO_B8
ISO/DIN B8 (62 x 88 mm) 的 MediaType 实例。

ISO_B9

public static final PageAttributes.MediaType ISO_B9
ISO/DIN B9 (44 x 62 mm) 的 MediaType 实例。

ISO_B10

public static final PageAttributes.MediaType ISO_B10
ISO/DIN B10 (31 x 44 mm) 的 MediaType 实例。

JIS_B0

public static final PageAttributes.MediaType JIS_B0
JIS B0 (1030 x 1456 mm) 的 MediaType 实例。

JIS_B1

public static final PageAttributes.MediaType JIS_B1
JIS B1 (728 x 1030 mm) 的 MediaType 实例。

JIS_B2

public static final PageAttributes.MediaType JIS_B2
JIS B2 (515 x 728 mm) 的 MediaType 实例。

JIS_B3

public static final PageAttributes.MediaType JIS_B3
JIS B3 (364 x 515 mm) 的 MediaType 实例。

JIS_B4

public static final PageAttributes.MediaType JIS_B4
JIS B4 (257 x 364 mm) 的 MediaType 实例。

JIS_B5

public static final PageAttributes.MediaType JIS_B5
JIS B5 (182 x 257 mm) 的 MediaType 实例。

JIS_B6

public static final PageAttributes.MediaType JIS_B6
JIS B6 (128 x 182 mm) 的 MediaType 实例。

JIS_B7

public static final PageAttributes.MediaType JIS_B7
JIS B7 (91 x 128 mm) 的 MediaType 实例。

JIS_B8

public static final PageAttributes.MediaType JIS_B8
JIS B8 (64 x 91 mm) 的 MediaType 实例。

JIS_B9

public static final PageAttributes.MediaType JIS_B9
JIS B9 (45 x 64 mm) 的 MediaType 实例。

JIS_B10

public static final PageAttributes.MediaType JIS_B10
JIS B10 (32 x 45 mm) 的 MediaType 实例。

ISO_C0

public static final PageAttributes.MediaType ISO_C0
ISO/DIN C0 (917 x 1297 mm) 的 MediaType 实例。

ISO_C1

public static final PageAttributes.MediaType ISO_C1
ISO/DIN C1 (648 x 917 mm) 的 MediaType 实例。

ISO_C2

public static final PageAttributes.MediaType ISO_C2
ISO/DIN C2 (458 x 648 mm) 的 MediaType 实例。

ISO_C3

public static final PageAttributes.MediaType ISO_C3
ISO/DIN C3 (324 x 458 mm) 的 MediaType 实例。

ISO_C4

public static final PageAttributes.MediaType ISO_C4
ISO/DIN C4 (229 x 324 mm) 的 MediaType 实例。

ISO_C5

public static final PageAttributes.MediaType ISO_C5
ISO/DIN C5 (162 x 229 mm) 的 MediaType 实例。

ISO_C6

public static final PageAttributes.MediaType ISO_C6
ISO/DIN C6 (114 x 162 mm) 的 MediaType 实例。

ISO_C7

public static final PageAttributes.MediaType ISO_C7
ISO/DIN C7 (81 x 114 mm) 的 MediaType 实例。

ISO_C8

public static final PageAttributes.MediaType ISO_C8
ISO/DIN C8 (57 x 81 mm) 的 MediaType 实例。

ISO_C9

public static final PageAttributes.MediaType ISO_C9
ISO/DIN C9 (40 x 57 mm) 的 MediaType 实例。

ISO_C10

public static final PageAttributes.MediaType ISO_C10
ISO/DIN C10 (28 x 40 mm) 的 MediaType 实例。

ISO_DESIGNATED_LONG

public static final PageAttributes.MediaType ISO_DESIGNATED_LONG
ISO Designated Long (110 x 220 mm) 的 MediaType 实例。

EXECUTIVE

public static final PageAttributes.MediaType EXECUTIVE
Executive (7 1/4 x 10 1/2 in) 的 MediaType 实例。

FOLIO

public static final PageAttributes.MediaType FOLIO
Folio (8 1/2 x 13 in) 的 MediaType 实例。

INVOICE

public static final PageAttributes.MediaType INVOICE
Invoice (5 1/2 x 8 1/2 in) 的 MediaType 实例。

LEDGER

public static final PageAttributes.MediaType LEDGER
Ledger (11 x 17 in) 的 MediaType 实例。

NA_LETTER

public static final PageAttributes.MediaType NA_LETTER
North American Letter (8 1/2 x 11 in) 的 MediaType 实例。

NA_LEGAL

public static final PageAttributes.MediaType NA_LEGAL
North American Legal (8 1/2 x 14 in) 的 MediaType 实例。

QUARTO

public static final PageAttributes.MediaType QUARTO
Quarto (215 x 275 mm) 的 MediaType 实例。

A

public static final PageAttributes.MediaType A
Engineering A (8 1/2 x 11 in) 的 MediaType 实例。

B

public static final PageAttributes.MediaType B
Engineering B (11 x 17 in) 的 MediaType 实例。

C

public static final PageAttributes.MediaType C
Engineering C (17 x 22 in) 的 MediaType 实例。

D

public static final PageAttributes.MediaType D
Engineering D (22 x 34 in) 的 MediaType 实例。

E

public static final PageAttributes.MediaType E
Engineering E (34 x 44 in) 的 MediaType 实例。

NA_10X15_ENVELOPE

public static final PageAttributes.MediaType NA_10X15_ENVELOPE
North American (10 x 15 in) 的 MediaType 实例。

NA_10X14_ENVELOPE

public static final PageAttributes.MediaType NA_10X14_ENVELOPE
North American (10 x 14 in) 的 MediaType 实例。

NA_10X13_ENVELOPE

public static final PageAttributes.MediaType NA_10X13_ENVELOPE
North American (10 x 13 in) 的 MediaType 实例。

NA_9X12_ENVELOPE

public static final PageAttributes.MediaType NA_9X12_ENVELOPE
North American (9 x 12 in) 的 MediaType 实例。

NA_9X11_ENVELOPE

public static final PageAttributes.MediaType NA_9X11_ENVELOPE
North American (9 x 11 in) 的 MediaType 实例。

NA_7X9_ENVELOPE

public static final PageAttributes.MediaType NA_7X9_ENVELOPE
North American (7 x 9 in) 的 MediaType 实例。

NA_6X9_ENVELOPE

public static final PageAttributes.MediaType NA_6X9_ENVELOPE
North American (6 x 9 in) 的 MediaType 实例。

NA_NUMBER_9_ENVELOPE

public static final PageAttributes.MediaType NA_NUMBER_9_ENVELOPE
North American #9 Business Envelope (3 7/8 x 8 7/8 in) 的 MediaType 实例。

NA_NUMBER_10_ENVELOPE

public static final PageAttributes.MediaType NA_NUMBER_10_ENVELOPE
North American #10 Business Envelope (4 1/8 x 9 1/2 in) 的 MediaType 实例。

NA_NUMBER_11_ENVELOPE

public static final PageAttributes.MediaType NA_NUMBER_11_ENVELOPE
North American #11 Business Envelope (4 1/2 x 10 3/8 in) 的 MediaType 实例。

NA_NUMBER_12_ENVELOPE

public static final PageAttributes.MediaType NA_NUMBER_12_ENVELOPE
North American #12 Business Envelope (4 3/4 x 11 in) 的 MediaType 实例。

NA_NUMBER_14_ENVELOPE

public static final PageAttributes.MediaType NA_NUMBER_14_ENVELOPE
North American #14 Business Envelope (5 x 11 1/2 in) 的 MediaType 实例。

INVITE_ENVELOPE

public static final PageAttributes.MediaType INVITE_ENVELOPE
Invitation Envelope (220 x 220 mm) 的 MediaType 实例。

ITALY_ENVELOPE

public static final PageAttributes.MediaType ITALY_ENVELOPE
Italy Envelope (110 x 230 mm) 的 MediaType 实例。

MONARCH_ENVELOPE

public static final PageAttributes.MediaType MONARCH_ENVELOPE
Monarch Envelope (3 7/8 x 7 1/2 in) 的 MediaType 实例。

PERSONAL_ENVELOPE

public static final PageAttributes.MediaType PERSONAL_ENVELOPE
6 3/4 envelope (3 5/8 x 6 1/2 in) 的 MediaType 实例。

A0

public static final PageAttributes.MediaType A0
ISO_A0 的别名。

A1

public static final PageAttributes.MediaType A1
ISO_A1 的别名。

A2

public static final PageAttributes.MediaType A2
ISO_A2 的别名。

A3

public static final PageAttributes.MediaType A3
ISO_A3 的别名。

A4

public static final PageAttributes.MediaType A4
ISO_A4 的别名。

A5

public static final PageAttributes.MediaType A5
ISO_A5 的别名。

A6

public static final PageAttributes.MediaType A6
ISO_A6 的别名。

A7

public static final PageAttributes.MediaType A7
ISO_A7 的别名。

A8

public static final PageAttributes.MediaType A8
ISO_A8 的别名。

A9

public static final PageAttributes.MediaType A9
ISO_A9 的别名。

A10

public static final PageAttributes.MediaType A10
ISO_A10 的别名。

B0

public static final PageAttributes.MediaType B0
ISO_B0 的别名。

B1

public static final PageAttributes.MediaType B1
ISO_B1 的别名。

B2

public static final PageAttributes.MediaType B2
ISO_B2 的别名。

B3

public static final PageAttributes.MediaType B3
ISO_B3 的别名。

B4

public static final PageAttributes.MediaType B4
ISO_B4 的别名。

ISO_B4_ENVELOPE

public static final PageAttributes.MediaType ISO_B4_ENVELOPE
ISO_B4 的别名。

B5

public static final PageAttributes.MediaType B5
ISO_B5 的别名。

ISO_B5_ENVELOPE

public static final PageAttributes.MediaType ISO_B5_ENVELOPE
ISO_B5 的别名。

B6

public static final PageAttributes.MediaType B6
ISO_B6 的别名。

B7

public static final PageAttributes.MediaType B7
ISO_B7 的别名。

B8

public static final PageAttributes.MediaType B8
ISO_B8 的别名。

B9

public static final PageAttributes.MediaType B9
ISO_B9 的别名。

B10

public static final PageAttributes.MediaType B10
ISO_B10 的别名。

C0

public static final PageAttributes.MediaType C0
ISO_C0 的别名。

ISO_C0_ENVELOPE

public static final PageAttributes.MediaType ISO_C0_ENVELOPE
ISO_C0 的别名。

C1

public static final PageAttributes.MediaType C1
ISO_C1 的别名。

ISO_C1_ENVELOPE

public static final PageAttributes.MediaType ISO_C1_ENVELOPE
ISO_C1 的别名。

C2

public static final PageAttributes.MediaType C2
ISO_C2 的别名。

ISO_C2_ENVELOPE

public static final PageAttributes.MediaType ISO_C2_ENVELOPE
ISO_C2 的别名。

C3

public static final PageAttributes.MediaType C3
ISO_C3 的别名。

ISO_C3_ENVELOPE

public static final PageAttributes.MediaType ISO_C3_ENVELOPE
ISO_C3 的别名。

C4

public static final PageAttributes.MediaType C4
ISO_C4 的别名。

ISO_C4_ENVELOPE

public static final PageAttributes.MediaType ISO_C4_ENVELOPE
ISO_C4 的别名。

C5

public static final PageAttributes.MediaType C5
ISO_C5 的别名。

ISO_C5_ENVELOPE

public static final PageAttributes.MediaType ISO_C5_ENVELOPE
ISO_C5 的别名。

C6

public static final PageAttributes.MediaType C6
ISO_C6 的别名。

ISO_C6_ENVELOPE

public static final PageAttributes.MediaType ISO_C6_ENVELOPE
ISO_C6 的别名。

C7

public static final PageAttributes.MediaType C7
ISO_C7 的别名。

ISO_C7_ENVELOPE

public static final PageAttributes.MediaType ISO_C7_ENVELOPE
ISO_C7 的别名。

C8

public static final PageAttributes.MediaType C8
ISO_C8 的别名。

ISO_C8_ENVELOPE

public static final PageAttributes.MediaType ISO_C8_ENVELOPE
ISO_C8 的别名。

C9

public static final PageAttributes.MediaType C9
ISO_C9 的别名。

ISO_C9_ENVELOPE

public static final PageAttributes.MediaType ISO_C9_ENVELOPE
ISO_C9 的别名。

C10

public static final PageAttributes.MediaType C10
ISO_C10 的别名。

ISO_C10_ENVELOPE

public static final PageAttributes.MediaType ISO_C10_ENVELOPE
ISO_C10 的别名。

ISO_DESIGNATED_LONG_ENVELOPE

public static final PageAttributes.MediaType ISO_DESIGNATED_LONG_ENVELOPE
ISO_DESIGNATED_LONG 的别名。

STATEMENT

public static final PageAttributes.MediaType STATEMENT
INVOICE 的别名。

TABLOID

public static final PageAttributes.MediaType TABLOID
LEDGER 的别名。

LETTER

public static final PageAttributes.MediaType LETTER
NA_LETTER 的别名。

NOTE

public static final PageAttributes.MediaType NOTE
NA_LETTER 的别名。

LEGAL

public static final PageAttributes.MediaType LEGAL
NA_LEGAL 的别名。

ENV_10X15

public static final PageAttributes.MediaType ENV_10X15
NA_10X15_ENVELOPE 的别名。

ENV_10X14

public static final PageAttributes.MediaType ENV_10X14
NA_10X14_ENVELOPE 的别名。

ENV_10X13

public static final PageAttributes.MediaType ENV_10X13
NA_10X13_ENVELOPE 的别名。

ENV_9X12

public static final PageAttributes.MediaType ENV_9X12
NA_9X12_ENVELOPE 的别名。

ENV_9X11

public static final PageAttributes.MediaType ENV_9X11
NA_9X11_ENVELOPE 的别名。

ENV_7X9

public static final PageAttributes.MediaType ENV_7X9
NA_7X9_ENVELOPE 的别名。

ENV_6X9

public static final PageAttributes.MediaType ENV_6X9
NA_6X9_ENVELOPE 的别名。

ENV_9

public static final PageAttributes.MediaType ENV_9
NA_NUMBER_9_ENVELOPE 的别名。

ENV_10

public static final PageAttributes.MediaType ENV_10
NA_NUMBER_10_ENVELOPE 的别名。

ENV_11

public static final PageAttributes.MediaType ENV_11
NA_NUMBER_11_ENVELOPE 的别名。

ENV_12

public static final PageAttributes.MediaType ENV_12
NA_NUMBER_12_ENVELOPE 的别名。

ENV_14

public static final PageAttributes.MediaType ENV_14
NA_NUMBER_14_ENVELOPE 的别名。

ENV_INVITE

public static final PageAttributes.MediaType ENV_INVITE
INVITE_ENVELOPE 的别名。

ENV_ITALY

public static final PageAttributes.MediaType ENV_ITALY
ITALY_ENVELOPE 的别名。

ENV_MONARCH

public static final PageAttributes.MediaType ENV_MONARCH
MONARCH_ENVELOPE 的别名。

ENV_PERSONAL

public static final PageAttributes.MediaType ENV_PERSONAL
PERSONAL_ENVELOPE 的别名。

INVITE

public static final PageAttributes.MediaType INVITE
INVITE_ENVELOPE 的别名。

ITALY

public static final PageAttributes.MediaType ITALY
ITALY_ENVELOPE 的别名。

MONARCH

public static final PageAttributes.MediaType MONARCH
MONARCH_ENVELOPE 的别名。

PERSONAL

public static final PageAttributes.MediaType PERSONAL
PERSONAL_ENVELOPE 的别名。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageAttributes.OrientationRequestedType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PageAttributes.OrientationRequestedType

java.lang.Object
    继承者  java.awt.PageAttributes.OrientationRequestedType
正在封闭类：
PageAttributes
public static final class PageAttributes.OrientationRequestedType
extends Object

可能打印方向的类型安全的枚举。这些方向部分地遵守 IPP 1.1。

从以下版本开始：
1.3

字段摘要
static PageAttributes.OrientationRequestedType | LANDSCAPE 用于指定横向方向的 OrientationRequestedType 实例。
static PageAttributes.OrientationRequestedType | PORTRAIT 用于指定纵向方向的 OrientationRequestedType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

PORTRAIT

public static final PageAttributes.OrientationRequestedType PORTRAIT
用于指定纵向方向的 OrientationRequestedType 实例。

LANDSCAPE

public static final PageAttributes.OrientationRequestedType LANDSCAPE
用于指定横向方向的 OrientationRequestedType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageAttributes.OriginType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PageAttributes.OriginType

java.lang.Object
    继承者  java.awt.PageAttributes.OriginType
正在封闭类：
PageAttributes
public static final class PageAttributes.OriginType
extends Object

可能原点的类型安全的枚举。

从以下版本开始：
1.3

字段摘要
static PageAttributes.OriginType | PHYSICAL 用于指定物理原点的 OriginType 实例。
static PageAttributes.OriginType | PRINTABLE 用于指定可打印原点的 OriginType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

PHYSICAL

public static final PageAttributes.OriginType PHYSICAL
用于指定物理原点的 OriginType 实例。

PRINTABLE

public static final PageAttributes.OriginType PRINTABLE
用于指定可打印原点的 OriginType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageAttributes.PrintQualityType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PageAttributes.PrintQualityType

java.lang.Object
    继承者  java.awt.PageAttributes.PrintQualityType
正在封闭类：
PageAttributes
public static final class PageAttributes.PrintQualityType
extends Object

可能的打印质量的类型安全的枚举。这些打印质量遵守 IPP 1.1。

从以下版本开始：
1.3

字段摘要
static PageAttributes.PrintQualityType | DRAFT 用于指定草稿打印质量的 PrintQualityType 实例。
static PageAttributes.PrintQualityType | HIGH 用于指定高打印质量的 PrintQualityType 实例。
static PageAttributes.PrintQualityType | NORMAL 用于指定标准打印质量的 PrintQualityType 实例。
方法摘要
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

HIGH

public static final PageAttributes.PrintQualityType HIGH
用于指定高打印质量的 PrintQualityType 实例。

NORMAL

public static final PageAttributes.PrintQualityType NORMAL
用于指定标准打印质量的 PrintQualityType 实例。

DRAFT

public static final PageAttributes.PrintQualityType DRAFT
用于指定草稿打印质量的 PrintQualityType 实例。

方法详细信息

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Paint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 Paint

所有超级接口：
Transparency
所有已知实现类：
Color, ColorUIResource, GradientPaint, LinearGradientPaint, MultipleGradientPaint, RadialGradientPaint, SystemColor, TexturePaint
public interface Paint
extends Transparency

此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。将实现 Paint 接口的类添加到 Graphics2D 上下文中，以便定义 draw 和 fill 方法所使用的颜色模式。

实现 Paint 的类的实例必须是只读的，因为将这些对象作为 setPaint 方法的属性来设置时，或者 Graphics2D 对象本身被复制时，Graphics2D 并不复制这些对象。

另请参见：
PaintContext, Color, GradientPaint, TexturePaint, Graphics2D.setPaint(java.awt.Paint)

字段摘要
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
方法摘要
 PaintContext createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints)
创建并返回用来生成颜色模式的 PaintContext。
从接口 java.awt.Transparency 继承的方法
getTransparency

方法详细信息

createContext

PaintContext createContext(ColorModel cm,
                           Rectangle deviceBounds,
                           Rectangle2D userBounds,
                           AffineTransform xform,
                           RenderingHints hints)
创建并返回用来生成颜色模式的 PaintContext。因为传递给 createContext 的 ColorModel 参数只是一个提示，所以 Paint 的实现应该接受 ColorModel 的 null 参数。注意，如果应用程序没有首选的特定 ColorModel，则为 null 的 ColorModel 参数将给予 Paint 实现完全的选择余地，使其在光栅处理中使用其首选最高效的 ColorModel。

因为 API 文档在 1.4 版本之前没有关于此项的具体描述，因此可能有一些 Paint 实现不能接受 null ColorModel 参数。如果开发人员正在编写代码将 null ColorModel 参数从任意源传递给 Paint 对象的 createContext 方法，则为了实现安全的编码，应该为这些对象构造一个非 null ColorModel，使其抛出 NullPointerException。

参数：
cm - 接收 Paint 数据的 ColorModel。这只用作一个提示。
deviceBounds - 正在呈现的图形图元的设备空间边界框
userBounds - 正在呈现的图形图元的用户空间边界框
xform - 从用户空间到设备空间的 AffineTransform
hints - 上下文对象用于选择所呈现内容的提示
返回：
生成颜色模式的 PaintContext
另请参见：
PaintContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PaintContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 PaintContext

public interface PaintContext

PaintContext 接口定义了经过封装和优化的环境，使用此环境可以生成设备空间中的颜色模式，此模式用于在 Graphics2D 上进行填充操作或笔划操作。PaintContext 采用与 ColorModel 相关联的 Raster 的方式提供 Graphics2D 操作所必需的颜色。PaintContext 保持着进行特殊着色操作的状态。在多线程环境中，针对单个 Paint 对象可同时有多个上下文。

另请参见：
Paint

方法摘要
void | dispose() 释放为操作分配的资源。
ColorModel | getColorModel() 返回输出的 ColorModel。
Raster | getRaster(int x, int y, int w, int h) 返回包含为图形操作生成的颜色的 Raster。

方法详细信息

dispose

void dispose()
释放为操作分配的资源。

getColorModel

ColorModel getColorModel()
返回输出的 ColorModel。注意，此 ColorModel 可能与在 Paint 的 createContext 方法中指定的提示是不同的。不是所有的 PaintContext 对象都能够生成任意 ColorModel 的颜色模式。

返回：
输出的 ColorModel。

getRaster

Raster getRaster(int x,
                 int y,
                 int w,
                 int h)
返回包含为图形操作生成的颜色的 Raster。

参数：
x - 为其生成颜色的设备空间区域的 x 坐标。
y - 为其生成颜色的设备空间区域的 y 坐标。
w - 设备空间区域的宽度
h - 设备空间区域的高度
返回：
一个 Raster，它表示指定的矩形区域，该区域包含为图形操作生成的颜色。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Panel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Panel

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Panel
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
Applet
public class Panel
extends Container
implements Accessible

Panel 是最简单的容器类。应用程序可以将其他组件放在面板提供的空间内，这些组件包括其他面板。

面板的默认布局管理器是 FlowLayout 布局管理器。

从以下版本开始：
JDK1.0
另请参见：
FlowLayout, 序列化表格

嵌套类摘要
protected  class Panel.AccessibleAWTPanel
此类实现 Panel 类的可访问性支持。
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Panel()
使用默认的布局管理器创建新面板。
Panel(LayoutManager layout)
创建具有指定布局管理器的新面板。
方法摘要
void | addNotify() 创建 Panel 的同位体。
AccessibleContext | getAccessibleContext() 获取与 Panel 相关的 AccessibleContext。
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Panel

public Panel()
使用默认的布局管理器创建新面板。所有面板的默认布局管理器都是 FlowLayout 类。

Panel

public Panel(LayoutManager layout)
创建具有指定布局管理器的新面板。

参数：
layout - 此面板的布局管理器。
从以下版本开始：
JDK1.1
方法详细信息

addNotify

public void addNotify()
创建 Panel 的同位体。此同位体允许修改面板的外观而不会更改其功能。

覆盖：
类 Container 中的 addNotify
另请参见：
Component.isDisplayable(), Container.removeNotify()

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与 Panel 相关的 AccessibleContext。对于面板，AccessibleContext 采用 AccessibleAWTPanel 的形式。如有必要，则创建一个新的 AccessibleAWTPanel 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
一个 AccessibleAWTPanel，它作为此 Panel 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Panel.AccessibleAWTPanel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Panel.AccessibleAWTPanel

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Panel.AccessibleAWTPanel
所有已实现的接口：
Serializable, AccessibleComponent
直接已知子类：
Applet.AccessibleApplet
正在封闭类：
Panel
protected class Panel.AccessibleAWTPanel
extends Container.AccessibleAWTContainer

此类实现 Panel 类的可访问性支持。它提供适合面板用户界面元素的 Java Accessibility API 实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Panel.AccessibleAWTPanel()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Panel.AccessibleAWTPanel

protected Panel.AccessibleAWTPanel()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Point (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Point

java.lang.Object
    继承者  java.awt.geom.Point2D
        继承者  java.awt.Point
所有已实现的接口：
Serializable, Cloneable
public class Point
extends Point2D
implements Serializable

表示 (x,y) 坐标空间中的位置的点，以整数精度指定。

从以下版本开始：
1.0
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Point2D 继承的嵌套类/接口
Point2D.Double, Point2D.Float
字段摘要
int | x 此 Point 的 X 坐标。
int | y 此 Point 的 Y 坐标。
构造方法摘要
Point()
在坐标空间的原点 (0,0) 构造并初始化一个点。
Point(int x, int y)
在坐标空间中指定的 (x,y) 位置构造并初始化一个点。
Point(Point p)
构造并初始化一个与指定的 Point 对象具有相同位置的点。
方法摘要
boolean | equals(Object obj) 确定两个点是否相等。
Point | getLocation() 返回此点的位置。
double | getX() 以 double 精度返回此 Point2D 的 X 坐标。
double | getY() 以 double 精度返回此 Point2D 的 Y 坐标。
void | move(int x, int y) 将此点移动到 (x,y) 坐标平面中的指定位置。
void | setLocation(double x, double y) 将此点的位置设为指定的双精度坐标。
void | setLocation(int x, int y) 将此点更改为具有指定位置。
void | setLocation(Point p) 将点的位置设为指定位置。
String | toString() 返回此点的字符串表示形式及其在 (x,y) 坐标空间中的位置。
void | translate(int dx, int dy) 平移 (x,y) 位置的点，沿 x 轴平移 dx，沿 y 轴平移 dy，移动后得到点 (x+dx,y+dy)。
从类 java.awt.geom.Point2D 继承的方法
clone, distance, distance, distance, distanceSq, distanceSq, distanceSq, hashCode, setLocation
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

x

public int x
此 Point 的 X 坐标。如果未设置 X 坐标，则默认为 0。

从以下版本开始：
1.0
另请参见：
getLocation(), move(int, int)

y

public int y
此 Point 的 Y 坐标。如果未设置 Y 坐标，则默认为 0。

从以下版本开始：
1.0
另请参见：
getLocation(), move(int, int)
构造方法详细信息

Point

public Point()
在坐标空间的原点 (0,0) 构造并初始化一个点。

从以下版本开始：
1.1

Point

public Point(Point p)
构造并初始化一个与指定的 Point 对象具有相同位置的点。

参数：
p - 点
从以下版本开始：
1.1

Point

public Point(int x,
             int y)
在坐标空间中指定的 (x,y) 位置构造并初始化一个点。

参数：
x - 新构造的 Point 的 X 坐标
y - 新构造的 Point 的 Y 坐标
从以下版本开始：
1.0
方法详细信息

getX

public double getX()
以 double 精度返回此 Point2D 的 X 坐标。

指定者：
类 Point2D 中的 getX
返回：
此 Point2D 的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回此 Point2D 的 Y 坐标。

指定者：
类 Point2D 中的 getY
返回：
此 Point2D 的 Y 坐标。
从以下版本开始：
1.2

getLocation

public Point getLocation()
返回此点的位置。包含此方法是出于完整性考虑，它与 Component 的 getLocation 方法相似。

返回：
此点在相同位置的一个副本
从以下版本开始：
1.1
另请参见：
Component.getLocation(),
setLocation(java.awt.Point),
setLocation(int, int)

setLocation

public void setLocation(Point p)
将点的位置设为指定位置。包含此方法是出于完整性考虑，它与 Component 的 setLocation 方法相似。

参数：
p - 点，此点的新位置
从以下版本开始：
1.1
另请参见：
Component.setLocation(java.awt.Point), getLocation()

setLocation

public void setLocation(int x,
                        int y)
将此点更改为具有指定位置。

包含此方法是出于完整性考虑，它与 Component 的 setLocation 方法相似。其行为与 move(int, int) 相同。

参数：
x - 新位置的 X 坐标
y - 新位置的 Y 坐标
从以下版本开始：
1.1
另请参见：
Component.setLocation(int, int),
getLocation(),
move(int, int)

setLocation

public void setLocation(double x,
                        double y)
将此点的位置设为指定的双精度坐标。双精度的值将被舍入为整数值。任何小于 Integer.MIN_VALUE 的数都将被重置为 MIN_VALUE，任何大于 Integer.MAX_VALUE 的数都将被重置为 MAX_VALUE。

指定者：
类 Point2D 中的 setLocation
参数：
x - 新位置的 X 坐标
y - 新位置的 Y 坐标
另请参见：
getLocation()

move

public void move(int x,
                 int y)
将此点移动到 (x,y) 坐标平面中的指定位置。此方法与 setLocation(int, int) 相同。

参数：
x - 新位置的 X 坐标
y - 新位置的 Y 坐标
另请参见：
Component.setLocation(int, int)

translate

public void translate(int dx,
                      int dy)
平移 (x,y) 位置的点，沿 x 轴平移 dx，沿 y 轴平移 dy，移动后得到点 (x+dx,y+dy)。

参数：
dx - 沿 X 轴平移此点的距离
dy - 沿 Y 轴平移此点的距离

equals

public boolean equals(Object obj)
确定两个点是否相等。如果 Point2D 的两个实例的 x 和 y 成员字段的值相同，则它们是相等的，其中成员字段的值表示实例在坐标空间中的位置。

覆盖：
类 Point2D 中的 equals
参数：
obj - 将与此 Point2D 的实例进行比较的对象
返回：
如果要比较的对象是 Point2D 的实例且有相同的值，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回此点的字符串表示形式及其在 (x,y) 坐标空间中的位置。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Object 中的 toString
返回：
此点的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PointerInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PointerInfo

java.lang.Object
    继承者  java.awt.PointerInfo

public class PointerInfo
extends Object

描述指针位置的类。它提供指针所在的 GraphicsDevice，以及表示指针坐标的 Point。

此类的实例应该通过 MouseInfo.getPointerInfo() 来获得。PointerInfo 实例不随鼠标的移动而动态更新。为了获取更新后的位置，必须再次调用 MouseInfo.getPointerInfo()。

从以下版本开始：
1.5
另请参见：
MouseInfo.getPointerInfo()

方法摘要
GraphicsDevice | getDevice() 返回在创建此 PointerInfo 时鼠标指针所在的 GraphicsDevice。
Point | getLocation() 返回在屏幕上表示指针坐标的 Point。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getDevice

public GraphicsDevice getDevice()
返回在创建此 PointerInfo 时鼠标指针所在的 GraphicsDevice。

返回：
与指针对应的 GraphicsDevice
从以下版本开始：
1.5

getLocation

public Point getLocation()
返回在屏幕上表示指针坐标的 Point。有关多屏幕系统坐标计算的更多信息，请参见 MouseInfo.getPointerInfo()。

返回：
鼠标指针的坐标
从以下版本开始：
1.5
另请参见：
MouseInfo, MouseInfo.getPointerInfo()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Polygon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Polygon

java.lang.Object
    继承者  java.awt.Polygon
所有已实现的接口：
Shape, Serializable
public class Polygon
extends Object
implements Shape, Serializable

Polygon 类封装了坐标空间中封闭的二维区域的描述。此区域以任意条线段为边界，每条线段都是多边形的一条边。在内部，一个多边形包含一列 (x,y) 坐标对，其中每个坐标对（coordinate pair）定义多边形的一个顶点，且两个连续的坐标对是多边形一条边的端点。第一个和最后一个 (x,y) 坐标对通过一条线段相连，形成一个封闭的多边形。此 Polygon 是按奇-偶性旋绕规则来定义的。有关奇-偶性旋绕规则的定义，请参见 WIND_EVEN_ODD。此类的目标测试方法使用 Shape 类注释中描述的 insideness 定义，目标测试方法包括 contains、intersects 和 inside 方法。

从以下版本开始：
1.0
另请参见：
Shape, 序列化表格

字段摘要
protected Rectangle | bounds 此 Polygon 的边界。
int | npoints 点的总数。
int[] | xpoints X 坐标的数组。
int[] | ypoints Y 坐标的数组。
构造方法摘要
Polygon()
创建空的多边形。
Polygon(int[] xpoints, int[] ypoints, int npoints)
根据指定的参数构造并初始化新的 Polygon。
方法摘要
 void addPoint(int x, int y)
将指定的坐标追加到此 Polygon。
 boolean contains(double x, double y)
测试指定坐标是否在 Shape 的边界内。
 boolean contains(double x, double y, double w, double h)
测试 Shape 内部是否完全包含指定矩形区域。
 boolean contains(int x, int y)
确定指定的坐标是否位于此 Polygon 的内部。
 boolean contains(Point p)
确定指定的 Point 是否位于此 Polygon 的内部。
 boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。
 boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。
 Rectangle getBoundingBox()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 Rectangle getBounds()
获取此 Polygon 的边界框。
 Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
 PathIterator getPathIterator(AffineTransform at)
返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。
 PathIterator getPathIterator(AffineTransform at, double flatness)
返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。
 boolean inside(int x, int y)
已过时。 从 JDK version 1.1 开始, 此函数为 contains(int, int)。
 boolean intersects(double x, double y, double w, double h)
测试 Shape 内部是否与指定矩形区域的内部相交。
 boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。
 void invalidate()
所有内部缓冲数据的失效或刷新都依赖于此 Polygon 的顶点坐标。
 void reset()
将此 Polygon 对象重置为一个空多边形。
 void translate(int deltaX, int deltaY)
对 Polygon 的顶点进行平移，沿 x 轴移动 deltaX，沿 y 移动 deltaY。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

npoints

public int npoints
点的总数。npoints 的值表示在此 Polygon 中有效的点的数量，该值可以小于 xpoints 或 ypoints 中元素的个数。此值可以为 NULL。

从以下版本开始：
1.0
另请参见：
addPoint(int, int)

xpoints

public int[] xpoints
X 坐标的数组。此数组中元素的个数可以大于此 Polygon 中 X 坐标的个数。额外的元素允许新的点添加到此 Polygon 中，而无需重新创建此数组。npoints 的值等于此 Polygon 中有效点的个数。

从以下版本开始：
1.0
另请参见：
addPoint(int, int)

ypoints

public int[] ypoints
Y 坐标的数组。此数组中元素的个数可以大于此 Polygon 中 Y 坐标的个数。额外的元素允许新的点添加到 Polygon 中，而无需重新创建此数组。npoints 的值等于此 Polygon 中有效点的个数。

从以下版本开始：
1.0
另请参见：
addPoint(int, int)

bounds

protected Rectangle bounds
此 Polygon 的边界。此值可以为 null。

从以下版本开始：
1.0
另请参见：
getBoundingBox(), getBounds()
构造方法详细信息

Polygon

public Polygon()
创建空的多边形。

从以下版本开始：
1.0

Polygon

public Polygon(int[] xpoints,
               int[] ypoints,
               int npoints)
根据指定的参数构造并初始化新的 Polygon。

参数：
xpoints - X 坐标的数组
ypoints - Y 坐标的数组
npoints - 此 Polygon 中点的总数
抛出：
NegativeArraySizeException - 如果 npoints 为负值。
IndexOutOfBoundsException - 如果 npoints 大于 xpoints 或 ypoints 的长度。
NullPointerException - 如果 xpoints 或 ypoints 为 null。
从以下版本开始：
1.0
方法详细信息

reset

public void reset()
将此 Polygon 对象重置为一个空多边形。坐标数组及其中的数据不发生改变，但点的个数被重置为零，以便将旧的顶点数据标记为无效，并且开始从头累积新的顶点数据。与旧顶点相关的所有内部缓冲的数据都将被丢弃。注意，由于重用了重置之前的坐标数组，因此在将创建一个新的空 Polygon 与重置当前多边形相比时，如果新多边形数据的顶点数远远少于重置之前的数据的顶点数，则重新创建将会提高内存的效率。

从以下版本开始：
1.4
另请参见：
invalidate()

invalidate

public void invalidate()
所有内部缓冲数据的失效或刷新都依赖于此 Polygon 的顶点坐标。此方法应该在完成对 xpoints 或 ypoints 数组中坐标的直接操作之后被调用，以避免产生与 getBounds 或 contains 这样的方法不一致的结果，后者这些方法可能从与顶点坐标相关联的更早的计算中缓冲数据。

从以下版本开始：
1.4
另请参见：
getBounds()

translate

public void translate(int deltaX,
                      int deltaY)
对 Polygon 的顶点进行平移，沿 x 轴移动 deltaX，沿 y 移动 deltaY。

参数：
deltaX - 沿 X 轴移动的量
deltaY - 沿 Y 轴移动的量
从以下版本开始：
1.1

addPoint

public void addPoint(int x,
                     int y)
将指定的坐标追加到此 Polygon。

如果已经执行了计算此 Polygon 的边界框的操作，例如 getBounds 或 contains，则此方法将更新边界框。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.0
另请参见：
getBounds(), contains(java.awt.Point)

getBounds

public Rectangle getBounds()
获取此 Polygon 的边界框。边界框是最小的 Rectangle，其边平行于坐标空间的 x 轴和 y 轴，且能够完全包含 Polygon。

指定者：
接口 Shape 中的 getBounds
返回：
返回定义此 Polygon 边界的 Rectangle。
从以下版本开始：
1.1
另请参见：
Shape.getBounds2D()

getBoundingBox

@Deprecated
public Rectangle getBoundingBox()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。

返回此 Polygon 的边界。

返回：
返回此 Polygon 的边界。
从以下版本开始：
1.0

contains

public boolean contains(Point p)
确定指定的 Point 是否位于此 Polygon 的内部。

参数：
p - 要测试的指定的 Point
返回：
如果 Polygon 包含 Point，则返回 true；否则返回 false。
从以下版本开始：
1.0
另请参见：
contains(double, double)

contains

public boolean contains(int x,
                        int y)
确定指定的坐标是否位于此 Polygon 的内部。

参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果此 Polygon 包含指定的坐标 (x,y)，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
contains(double, double)

inside

@Deprecated
public boolean inside(int x,
                                 int y)
已过时。 从 JDK version 1.1 开始, 此函数为 contains(int, int)。

确定此 Polygon 是否包含指定的坐标。

参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果此 Polygon 包含指定的坐标 (x,y)，则返回 true；否则返回 false。
从以下版本开始：
1.0
另请参见：
contains(double, double)

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

contains

public boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
p - 要测试的指定的 Point2D
返回：
如果指定的 Point2D 在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

intersects

public boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.intersects(double, double, double, double)

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

contains

public boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：
  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含 Rectangle2D 的代价太高。
这意味着对于某些 Shape，即使 Shape 包含 Rectangle2D，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部完全包含 Rectangle2D，则返回 true；否则，如果 Shape 包含 Rectangle2D、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.contains(double, double, double, double)

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。可以指定一个可选的 AffineTransform，以便对迭代中返回的坐标进行相应的转换。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 坐标在迭代中返回时，要应用于这些坐标的可选的 AffineTransform，或者需要撤消转换时为 null
返回：
PathIterator 对象，该对象提供对此 Polygon 的几何形状的访问。
从以下版本开始：
1.2

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。迭代器只返回 SEG_MOVETO、SEG_LINETO 和 SEG_CLOSE 点类型。由于多边形是平面的，因此可以忽略 flatness 参数。可以指定可选的 AffineTransform，在这种情况下相应地转换在迭代返回的坐标。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 坐标在迭代中返回时，要应用于这些坐标的可选的 AffineTransform，或者需要撤消转换时为 null
flatness - 在使用连接端点的直线取代细分的曲线之前，给定曲线的控制点可以从共线变化的最大量。由于多平形是平面的，因此可以忽略 flatness 参数。
返回：
返回 PathIterator 对象，此对象提供对 Shape 对象的几何形状的访问。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PopupMenu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PopupMenu

java.lang.Object
    继承者  java.awt.MenuComponent
        继承者  java.awt.MenuItem
            继承者  java.awt.Menu
                继承者  java.awt.PopupMenu
所有已实现的接口：
MenuContainer, Serializable, Accessible
public class PopupMenu
extends Menu

此类实现能够在组件中的指定位置上动态弹出的菜单。

正如继承层次关系所暗示的那样，任何可以使用 Menu 的地方都可以使用 PopupMenu。但是，如果使用像 Menu 这样的 PopupMenu（例如，将其添加到 MenuBar），则不能调用该 PopupMenu 的 show。

另请参见：
序列化表格

嵌套类摘要
protected  class PopupMenu.AccessibleAWTPopupMenu
用于为可访问性提供默认支持的 PopupMenu 的内部类。
从类 java.awt.Menu 继承的嵌套类/接口
Menu.AccessibleAWTMenu
从类 java.awt.MenuItem 继承的嵌套类/接口
MenuItem.AccessibleAWTMenuItem
从类 java.awt.MenuComponent 继承的嵌套类/接口
MenuComponent.AccessibleAWTMenuComponent
构造方法摘要
PopupMenu()
创建具有空名称的新弹出式菜单。
PopupMenu(String label)
创建具有指定名称的新弹出式菜单。
方法摘要
void | addNotify() 创建弹出式菜单的同位体。
AccessibleContext | getAccessibleContext() 获取与此 PopupMenu 关联的 AccessibleContext。
MenuContainer | getParent() 返回此菜单组件的父容器。
void | show(Component origin, int x, int y) 在相对于初始组件的 x、y 位置上显示弹出式菜单。
从类 java.awt.Menu 继承的方法
add, add, addSeparator, countItems, getItem, getItemCount, insert, insert, insertSeparator, isTearOff, paramString, remove, remove, removeAll, removeNotify
从类 java.awt.MenuItem 继承的方法
addActionListener, deleteShortcut, disable, disableEvents, enable, enable, enableEvents, getActionCommand, getActionListeners, getLabel, getListeners, getShortcut, isEnabled, processActionEvent, processEvent, removeActionListener, setActionCommand, setEnabled, setLabel, setShortcut
从类 java.awt.MenuComponent 继承的方法
dispatchEvent, getFont, getName, getPeer, getTreeLock, postEvent, setFont, setName, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.awt.MenuContainer 继承的方法
getFont, postEvent

构造方法详细信息

PopupMenu

public PopupMenu()
          throws HeadlessException
创建具有空名称的新弹出式菜单。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

PopupMenu

public PopupMenu(String label)
          throws HeadlessException
创建具有指定名称的新弹出式菜单。

参数：
label - 用于指定弹出式菜单标签的非 null 字符串
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

getParent

public MenuContainer getParent()
返回此菜单组件的父容器。

覆盖：
类 MenuComponent 中的 getParent
返回：
包含此菜单组件的菜单组件，如果此菜单组件就是最外部组件，即该菜单栏本身，则返回 null

addNotify

public void addNotify()
创建弹出式菜单的同位体。同位体允许更改弹出式菜单的外观，而不更改其任何功能。

覆盖：
类 Menu 中的 addNotify

show

public void show(Component origin,
                 int x,
                 int y)
在相对于初始组件的 x、y 位置上显示弹出式菜单。初始组件必须包含在弹出式菜单的父菜单的组件层次结构中。初始组件和父菜单必须显示在对此方法有效的屏幕中。

如果此 PopupMenu 正被作为 Menu 使用（即它有一个非 Component 父菜单），则不能对 PopupMenu 调用此方法。

参数：
origin - 定义坐标空间的组件
x - 弹出菜单的 x 坐标位置
y - 弹出菜单的 y 坐标位置
抛出：
NullPointerException - 如果父菜单为 null
IllegalArgumentException - 如果此 PopupMenu 有非 Component 父菜单
IllegalArgumentException - 如果初始组件不在父菜单的继承关系中
RuntimeException - 如果父菜单没有显示在屏幕中

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 PopupMenu 关联的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Menu 中的 getAccessibleContext
返回：
此 PopupMenu 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PopupMenu.AccessibleAWTPopupMenu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PopupMenu.AccessibleAWTPopupMenu

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.MenuComponent.AccessibleAWTMenuComponent
            继承者  java.awt.MenuItem.AccessibleAWTMenuItem
                继承者  java.awt.Menu.AccessibleAWTMenu
                    继承者  java.awt.PopupMenu.AccessibleAWTPopupMenu
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleSelection, AccessibleValue
正在封闭类：
PopupMenu
protected class PopupMenu.AccessibleAWTPopupMenu
extends Menu.AccessibleAWTMenu

用于为可访问性提供默认支持的 PopupMenu 的内部类。此类并非旨在由应用程序开发人员直接使用，而只能由菜单组件开发人员为其创建子类。

可以使用该类来获得此对象的可访问功能。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
protected PopupMenu.AccessibleAWTPopupMenu()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.MenuItem.AccessibleAWTMenuItem 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleName, getAccessibleValue, getCurrentAccessibleValue, getMaximumAccessibleValue, getMinimumAccessibleValue, setCurrentAccessibleValue
从类 java.awt.MenuComponent.AccessibleAWTMenuComponent 继承的方法
addAccessibleSelection, addFocusListener, clearAccessibleSelection, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getAccessibleSelection, getAccessibleSelection, getAccessibleSelectionCount, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isAccessibleChildSelected, isEnabled, isFocusTraversable, isShowing, isVisible, removeAccessibleSelection, removeFocusListener, requestFocus, selectAllAccessibleSelection, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PopupMenu.AccessibleAWTPopupMenu

protected PopupMenu.AccessibleAWTPopupMenu()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Menu.AccessibleAWTMenu 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintGraphics (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 PrintGraphics

public interface PrintGraphics

提供页面的打印图形上下文的抽象类。

方法摘要
 PrintJob getPrintJob()
返回从其产生 PrintGraphics 对象的 PrintJob 对象。

方法详细信息

getPrintJob

PrintJob getPrintJob()
返回从其产生 PrintGraphics 对象的 PrintJob 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintJob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 PrintJob

java.lang.Object
    继承者  java.awt.PrintJob

public abstract class PrintJob
extends Object

启动并执行打印作业的抽象类。它提供呈现到适当打印设备的打印图形对象的访问权限。

另请参见：
Toolkit.getPrintJob(java.awt.Frame, java.lang.String, java.util.Properties)

构造方法摘要
PrintJob()
方法摘要
abstract void | end() 终止打印作业并进行必要的清除操作。
void | finalize() 一旦不再引用此打印作业，即可终止它。
abstract Graphics | getGraphics() 获取将绘制到下一页的 Graphics 对象。
abstract Dimension | getPageDimension() 返回页面的维数，以像素为单位。
abstract int | getPageResolution() 返回页面的分辨率，以每英寸的像素为单位。
abstract boolean | lastPageFirst() 如果首先打印最后一页，则返回 true。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PrintJob

public PrintJob()
方法详细信息

getGraphics

public abstract Graphics getGraphics()
获取将绘制到下一页的 Graphics 对象。移除图形对象时，页面被发送到打印机。此图形对象还将实现 PrintGraphics 接口。

另请参见：
PrintGraphics

getPageDimension

public abstract Dimension getPageDimension()
返回页面的维数，以像素为单位。选择页面的分辨率，使它类似于屏幕分辨率。

getPageResolution

public abstract int getPageResolution()
返回页面的分辨率，以每英寸的像素为单位。注意，此分辨率不一定对应于打印机的物理分辨率。

lastPageFirst

public abstract boolean lastPageFirst()
如果首先打印最后一页，则返回 true。

end

public abstract void end()
终止打印作业并进行必要的清除操作。

finalize

public void finalize()
一旦不再引用此打印作业，即可终止它。

覆盖：
类 Object 中的 finalize
另请参见：
end()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RadialGradientPaint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 RadialGradientPaint

java.lang.Object
    继承者  java.awt.MultipleGradientPaint
        继承者  java.awt.RadialGradientPaint
所有已实现的接口：
Paint, Transparency
public final class RadialGradientPaint
extends MultipleGradientPaint

RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。用户可以指定两种或多种渐变颜色，此绘制将在颜色与颜色之间提供一个插值。

用户必须指定用于控制渐变模式的圆，可用中心点和半径对该圆进行描述。用户也可以在该圆内部指定一个独立焦点，由它控制渐变的第一种颜色的位置。默认情况下，该焦点被设置为圆心。

此绘制将渐变的第一种颜色映射到焦点，将渐变的最后一种颜色映射到圆周，在两者之间平滑地插入用户指定的任意中间颜色。因此，从焦点到圆周之间绘制的任何直线都将跨越所有渐变颜色。

在圆的半径外部指定焦点将导致焦点被设置为焦点-中心线与圆周的交点。

用户必须提供一个 float 数组，用于指定如何沿渐变分布颜色。这些值的范围从 0.0 到 1.0，其作用与沿渐变的关键帧类似（它们标记渐变应完全变为某种特定颜色的位置）。

在用户没有将第一个关键帧值设置为等于 0 和/或将最后一个关键帧值设置为等于 1 的情况下，将在这些位置创建关键帧，并且第一种颜色和最后一种颜色将在这些位置处重复。因此，如果用户指定以下数组来构造渐变：

{Color.BLUE, Color.RED}, {.3f, .7f}
那么此渐变将转换为一个带有以下关键帧的渐变：
{Color.BLUE, Color.BLUE, Color.RED, Color.RED}, {0f, .3f, .7f, 1f}

在填充圆的半径边界以外的颜色时，用户也可以选择 RadialGradientPaint 应执行的动作。如果没有指定循环方法，则将默认选择 NO_CYCLE，这意味着将使用最后一个关键帧的颜色来填充剩余的区域。

colorSpace 参数允许用户指定应在哪一种颜色空间（默认 sRGB 或线性 RGB）中执行插值操作。

以下代码演示了 RadialGradientPaint 的典型用法，其中中心点和焦点是同一个点：

Point2D center = new Point2D.Float(50, 50);
float radius = 25;
float[] dist = {0.0f, 0.2f, 1.0f};
Color[] colors = {Color.RED, Color.WHITE, Color.BLUE};
RadialGradientPaint p =
new RadialGradientPaint(center, radius, dist, colors);

此图像用默认（居中）焦点演示了对以上示例代码使用三种循环方法时的情形：

它也可以使用以下代码指定一个非居中的焦点：

Point2D center = new Point2D.Float(50, 50);
float radius = 25;
Point2D focus = new Point2D.Float(40, 40);
float[] dist = {0.0f, 0.2f, 1.0f};
Color[] colors = {Color.RED, Color.WHITE, Color.BLUE};
RadialGradientPaint p =
new RadialGradientPaint(center, radius, focus,
dist, colors,
CycleMethod.NO_CYCLE);

此图像演示了对上述示例代码（使用了非居中焦点）使用三种循环方法时的情形：

从以下版本开始：
1.6
另请参见：
Paint, Graphics2D.setPaint(java.awt.Paint)

嵌套类摘要
从类 java.awt.MultipleGradientPaint 继承的嵌套类/接口
MultipleGradientPaint.ColorSpaceType, MultipleGradientPaint.CycleMethod
字段摘要
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。
RadialGradientPaint(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
方法摘要
PaintContext | createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
Point2D | getCenterPoint() 返回辐射状渐变中心点的副本。
Point2D | getFocusPoint() 返回渐变轴结束点的副本。
float | getRadius() 返回定义辐射状渐变的圆的半径。
从类 java.awt.MultipleGradientPaint 继承的方法
getColors, getColorSpace, getCycleMethod, getFractions, getTransform, getTransparency
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RadialGradientPaint

public RadialGradientPaint(float cx,
                           float cy,
                           float radius,
                           float[] fractions,
                           Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。

参数：
cx - 定义渐变的圆的中心点在用户空间中的 X 坐标。渐变的最后一种颜色被映射到圆周上。
cy - 定义渐变的圆的中心点在用户空间中的 Y 坐标。渐变的最后一种颜色被映射到圆周上。
radius - 定义颜色渐变范围的圆的半径
fractions - 范围从 0.0 到 1.0 之间的数字，用于指定沿渐变的颜色分布
colors - 在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。
抛出：
NullPointerException - 如果 fractions 数组为 null；或者 colors 数组为 null
IllegalArgumentException - 如果 radius 非正；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

RadialGradientPaint

public RadialGradientPaint(Point2D center,
                           float radius,
                           float[] fractions,
                           Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。

参数：
center - 用户空间中定义渐变的圆的中心点
radius - 圆的半径，用于定义颜色渐变的范围
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。
抛出：
NullPointerException - 如果 center 点为 null；或者 fractions 数组为 null；或者 colors 数组为 null
IllegalArgumentException - 如果 radius 非正；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

RadialGradientPaint

public RadialGradientPaint(float cx,
                           float cy,
                           float radius,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

参数：
cx - 定义渐变的圆的中心点在用户空间中的 X 坐标。渐变的最后一种颜色被映射到圆周上。
cy - 定义渐变的圆的中心点在用户空间中的 Y 坐标。渐变的最后一种颜色被映射到圆周上。
radius - 定义颜色渐变范围的圆的半径
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
抛出：
NullPointerException - 如果 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null
IllegalArgumentException - 如果 radius 非正；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

RadialGradientPaint

public RadialGradientPaint(Point2D center,
                           float radius,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

参数：
center - 用户空间中定义渐变的圆的中心点
radius - 圆的半径，用于定义颜色渐变的范围
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
抛出：
NullPointerException - 如果 center 点为 null；或者 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null
IllegalArgumentException - 如果 radius 非正；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

RadialGradientPaint

public RadialGradientPaint(float cx,
                           float cy,
                           float radius,
                           float fx,
                           float fy,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

参数：
cx - 定义渐变的圆的中心点在用户空间中的 X 坐标。渐变的最后一种颜色被映射到圆周上。
cy - 定义渐变的圆的中心点在用户空间中的 Y 坐标。渐变的最后一种颜色被映射到圆周上。
radius - 圆的半径，用于定义颜色渐变的范围
fx - 第一种颜色所映射的点在用户空间中的 X 坐标
fy - 第一种颜色所映射的点在用户空间中的 Y 坐标
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
抛出：
NullPointerException - 如果 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null
IllegalArgumentException - 如果 radius 非正；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

RadialGradientPaint

public RadialGradientPaint(Point2D center,
                           float radius,
                           Point2D focus,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

参数：
center - 用户空间中定义渐变的圆的中心点。渐变的最后一种颜色被映射到圆周上。
radius - 圆的半径，用于定义颜色渐变的范围
focus - 用户空间中第一种颜色映射到的点
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。 -
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
抛出：
NullPointerException - 如果有一个点为 null；或者 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null
IllegalArgumentException - 如果 radius 非正；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

RadialGradientPaint

public RadialGradientPaint(Point2D center,
                           float radius,
                           Point2D focus,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod,
                           MultipleGradientPaint.ColorSpaceType colorSpace,
                           AffineTransform gradientTransform)
构造一个 RadialGradientPaint。

参数：
center - 用户空间中定义渐变的圆的中心点。渐变的最后一种颜色被映射到圆周上。
radius - 圆的半径，用于定义颜色渐变的范围
focus - 用户空间中第一种颜色映射到的点
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。 -
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
colorSpace - 用于插值操作的颜色空间，该参数为 SRGB 或 LINEAR_RGB
gradientTransform - 要应用于渐变的变换
抛出：
NullPointerException - 如果有一个点为 null；或者 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null；或者 colorSpace 为 null；或者 gradientTransform 为 null
IllegalArgumentException - 如果 radius 非正；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions

RadialGradientPaint

public RadialGradientPaint(Rectangle2D gradientBounds,
                           float[] fractions,
                           Color[] colors,
                           MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。RadialGradientPaint 的渐变圆是由给定的边界框定义的。

此构造方法是表达以下（等效）代码的一种简便方式：

double gw = gradientBounds.getWidth();
double gh = gradientBounds.getHeight();
double cx = gradientBounds.getCenterX();
double cy = gradientBounds.getCenterY();
Point2D center = new Point2D.Double(cx, cy);

AffineTransform gradientTransform = new AffineTransform();
gradientTransform.translate(cx, cy);
gradientTransform.scale(gw / 2, gh / 2);
gradientTransform.translate(-cx, -cy);

RadialGradientPaint gp =
new RadialGradientPaint(center, 1.0f, center,
fractions, colors,
cycleMethod,
ColorSpaceType.SRGB,
gradientTransform);

参数：
gradientBounds - 用户空间中定义渐变最外层范围的边界框
fractions - 0.0 到 1.0 范围内的数字，用于指定沿渐变的颜色分布
colors - 在渐变中使用的颜色数组。第一种颜色用于焦点处，最后一种颜色环绕在圆周上。
cycleMethod - NO_CYCLE、REFLECT 或 REPEAT
抛出：
NullPointerException - 如果 gradientBounds 为 null；或者 fractions 数组为 null；或者 colors 数组为 null；或者 cycleMethod 为 null
IllegalArgumentException - 如果 gradientBounds 为空；或者 fractions.length != colors.length；或者 colors 大小小于 2；或者 fractions 值小于 0.0 或大于 1.0；或者没有严格按升序提供 fractions
方法详细信息

createContext

public PaintContext createContext(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform transform,
                                  RenderingHints hints)
创建并返回用来生成颜色模式的 PaintContext。因为传递给 createContext 的 ColorModel 参数只是一个提示，所以 Paint 的实现应该接受 ColorModel 的 null 参数。注意，如果应用程序没有首选的特定 ColorModel，则为 null 的 ColorModel 参数将给予 Paint 实现完全的选择余地，使其在光栅处理中使用其首选最高效的 ColorModel。

因为 API 文档在 1.4 版本之前没有关于此项的具体描述，因此可能有一些 Paint 实现不能接受 null ColorModel 参数。如果开发人员正在编写代码将 null ColorModel 参数从任意源传递给 Paint 对象的 createContext 方法，则为了实现安全的编码，应该为这些对象构造一个非 null ColorModel，使其抛出 NullPointerException。

参数：
cm - 接收 Paint 数据的 ColorModel。这只用作一个提示。
deviceBounds - 正在呈现的图形图元的设备空间边界框
userBounds - 正在呈现的图形图元的用户空间边界框
transform - 从用户空间到设备空间的 AffineTransform
hints - 上下文对象用于选择所呈现内容的提示
返回：
生成颜色模式的 PaintContext
另请参见：
PaintContext

getCenterPoint

public Point2D getCenterPoint()
返回辐射状渐变中心点的副本。

返回：
Point2D 对象，它是中心点的副本

getFocusPoint

public Point2D getFocusPoint()
返回渐变轴结束点的副本。

返回：
Point2D 对象，它是焦点的副本

getRadius

public float getRadius()
返回定义辐射状渐变的圆的半径。

返回：
定义辐射状渐变的圆的半径
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Rectangle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Rectangle

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Rectangle2D
            继承者  java.awt.Rectangle
所有已实现的接口：
Shape, Serializable, Cloneable
直接已知子类：
DefaultCaret
public class Rectangle
extends Rectangle2D
implements Shape, Serializable

Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

Rectangle 对象的 width 和 height 是 public 字段。创建 Rectangle 的构造方法，以及可以修改该对象的方法，都允许将 width 和 height 设置为负值。

对于 width 或 height 正好为 0 的 Rectangle，它在相应轴上存在维数为 0 的位置，但在这种情况下，也可将其视为空的 Rectangle。对于这种 Rectangle，isEmpty() 方法将返回 ture。 如果两个维数中任一维数为 0，则测试空 Rectangle 是否包含某个点或是否与某个矩形相交的方法将始终返回 false。用点或矩形合并这种 Rectangle 的方法将在结果中包含 Rectangle 在该轴上的位置，正如调用 add(Point) 方法一样。

对于 width 或 height 为负值的 Rectangle，它在相应轴上并不存在维数为负的位置或维数。这种 Rectangle 将被视为不存在相应的轴上。对于包含计算，这种 Rectangle 也为空，测试它是否包含某个点或是否与某个矩形相交的方法将始终返回 false。用点或矩形合并这种 Rectangle 的方法将在生成结果时完全忽略 Rectangle。如果合并了两个 Rectangle 对象，且每个对象都具有一个负维数，则结果中至少有一个负维数。

对于仅影响 Rectangle 位置的方法，无论 Rectangle 是否沿任一轴具有负维数或 0 维数，都将在其位置上进行操作。

注意，用默认不带参数的构造方法构造的 Rectangle 将具有 0x0 维数，因此为空。Rectangle 仍然具有 (0,0) 的位置，且将该位置用于合并和添加操作。因此，尝试累积点集合范围的代码最初应使用具体的负 width 和负 height 来构造 Rectangle，或者应使用该集合中的第一个点构造 Rectangle。例如：

Rectangle bounds = new Rectangle(0, 0, -1, -1);
for (int i = 0; i < points.length; i++) {
bounds.add(points[i]);
     }
如果知道点数组中至少包含了一个点，那么也可以：
Rectangle bounds = new Rectangle(points[0]);
for (int i = 1; i < points.length; i++) {
bounds.add(points[i]);
     }

此类用 32 位整数存储其位置和维数。通常情况下，这些操作可能生成超过 32 位整数范围的结果。这些方法将以某种方式计算它们的结果，该方式可以避免任何针对中间结果的 32 位溢出，然后将选择最佳的表示方式，将最终结果存储回保存位置和维数的 32 位字段中。通过将真实结果修改为最接近的 32 位值，将得到的位置存储到 x 和 y 字段中。存储到 width 和 height 维数字段中的值将被作为 32 位值选择，这些值尽可能包含真实结果的最大部分。通常情况下，这意味着维数将被独立地修改为 32 位整数范围内，但以下情况除外：如果必须移动位置才能将其存储到 32 位字段对中，则将相对于位置的“最佳表示形式”对维数进行调整；如果真实结果有一个负维数，并因此沿一个或两个轴不存在，则存储的维数在这些轴中将为负数；如果真实结果有一个位置可以在 32 位整数范围内表示，但沿一个或两个轴维数为 0，则存储的维数在这些轴中将为 0。

从以下版本开始：
1.0
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Rectangle2D 继承的嵌套类/接口
Rectangle2D.Double, Rectangle2D.Float
字段摘要
int | height Rectangle 的高度。
int | width Rectangle 的宽度。
int | x Rectangle 左上角的 X 坐标。
int | y Rectangle 左上角的 Y 坐标。
从类 java.awt.geom.Rectangle2D 继承的字段
OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP
构造方法摘要
Rectangle()
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，宽度和高度均为 0。
Rectangle(Dimension d)
构造一个新的 Rectangle，其左上角为 (0,0)，其宽度和高度由 Dimension 参数指定。
Rectangle(int width, int height)
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，其宽度和高度由同名的参数指定。
Rectangle(int x, int y, int width, int height)
构造一个新的 Rectangle，其左上角被指定为 (x,y)，其宽度和高度由同名的参数指定。
Rectangle(Point p)
构造一个新的 Rectangle，其左上角是指定的 Point，其宽度和高度均为 0。
Rectangle(Point p, Dimension d)
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。
Rectangle(Rectangle r)
构造一个新的 Rectangle，并将其初始化，以与指定 Rectangle 的值匹配。
方法摘要
 void add(int newx, int newy)
将一个由整数参数 newx,newy 指定的点添加到此 Rectangle 的边界。
 void add(Point pt)
将指定的 Point 添加到此 Rectangle 的边界。
 void add(Rectangle r)
将一个 Rectangle 添加到此 Rectangle 中。
 boolean contains(int x, int y)
检查此 Rectangle 是否包含位于指定位置 (x,y) 的点。
 boolean contains(int X, int Y, int W, int H)
检查此 Rectangle 是否完全包含位于指定位置 (X,Y) 且具有指定维数 (W,H) 的 Rectangle。
 boolean contains(Point p)
检查此 Rectangle 是否包含指定的 Point。
 boolean contains(Rectangle r)
检查此 Rectangle 是否完全包含指定的 Rectangle。
 Rectangle2D createIntersection(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
 Rectangle2D createUnion(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
 boolean equals(Object obj)
检查两个矩形是否相等。
 Rectangle getBounds()
获取此 Rectangle 的边界 Rectangle。
 Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
 double getHeight()
以 double 精度返回边界 Rectangle 的高度。
 Point getLocation()
返回此 Rectangle 的位置。
 Dimension getSize()
获取此 Rectangle 的大小，用返回的 Dimension 表示。
 double getWidth()
以 double 精度返回边界 Rectangle 的宽度。
 double getX()
以 double 精度返回边界 Rectangle 的 X 坐标。
 double getY()
以 double 精度返回边界 Rectangle 的 Y 坐标。
 void grow(int h, int v)
在水平方向和垂直方向上同时调整 Rectangle 的大小。
 boolean inside(int X, int Y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
 Rectangle intersection(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的交集。
 boolean intersects(Rectangle r)
确定此 Rectangle 是否与指定的 Rectangle 相交。
 boolean isEmpty()
确定 RectangularShape 是否为空。
 void move(int x, int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
 int outcode(double x, double y)
确定指定坐标相对于此 Rectangle2D 的位置。
 void reshape(int x, int y, int width, int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
 void resize(int width, int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
 void setBounds(int x, int y, int width, int height)
将此 Rectangle 的边界 Rectangle 设置为指定的 x、y、width 和 height。
 void setBounds(Rectangle r)
设置此 Rectangle 的边界 Rectangle，以匹配指定的 Rectangle。
 void setLocation(int x, int y)
将此 Rectangle 移动到指定位置。
 void setLocation(Point p)
将此 Rectangle 移动到指定位置。
 void setRect(double x, double y, double width, double height)
将此 Rectangle 的边界设置为整数边界，它包含指定的 x、y、width 和 height。
 void setSize(Dimension d)
设置此 Rectangle 的大小，以匹配指定的 Dimension。
 void setSize(int width, int height)
将此 Rectangle 的大小设置为指定的宽度和高度。
 String toString()
返回表示此 Rectangle 及其值的 String。
 void translate(int dx, int dy)
将此 Rectangle 沿 X 坐标轴向右，沿 Y 坐标轴向下平移指定距离。
 Rectangle union(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的并集。
从类 java.awt.geom.Rectangle2D 继承的方法
add, add, add, contains, contains, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, setRect, union
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.awt.Shape 继承的方法
contains, contains, contains, contains, getPathIterator, getPathIterator, intersects, intersects

字段详细信息

x

public int x
Rectangle 左上角的 X 坐标。

从以下版本开始：
1.0
另请参见：
setLocation(int, int), getLocation()

y

public int y
Rectangle 左上角的 Y 坐标。

从以下版本开始：
1.0
另请参见：
setLocation(int, int), getLocation()

width

public int width
Rectangle 的宽度。

从以下版本开始：
1.0
另请参见：
setSize(int, int), getSize()

height

public int height
Rectangle 的高度。

从以下版本开始：
1.0
另请参见：
setSize(int, int), getSize()
构造方法详细信息

Rectangle

public Rectangle()
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，宽度和高度均为 0。

Rectangle

public Rectangle(Rectangle r)
构造一个新的 Rectangle，并将其初始化，以与指定 Rectangle 的值匹配。

参数：
r - Rectangle，要从中将初始值复制到新构造的 Rectangle
从以下版本开始：
1.1

Rectangle

public Rectangle(int x,
                 int y,
                 int width,
                 int height)
构造一个新的 Rectangle，其左上角被指定为 (x,y)，其宽度和高度由同名的参数指定。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
width - Rectangle 的宽度
height - Rectangle 的高度
从以下版本开始：
1.0

Rectangle

public Rectangle(int width,
                 int height)
构造一个新的 Rectangle，其左上角的坐标为 (0,0)，其宽度和高度由同名的参数指定。

参数：
width - Rectangle 的宽度
height - Rectangle 的高度

Rectangle

public Rectangle(Point p,
                 Dimension d)
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。

参数：
p - 一个 Point，它是 Rectangle 的左上角
d - 一个 Dimension，表示 Rectangle 的宽度和高度

Rectangle

public Rectangle(Point p)
构造一个新的 Rectangle，其左上角是指定的 Point，其宽度和高度均为 0。

参数：
p - 一个 Point，它是 Rectangle 左上角的顶点

Rectangle

public Rectangle(Dimension d)
构造一个新的 Rectangle，其左上角为 (0,0)，其宽度和高度由 Dimension 参数指定。

参数：
d - 一个 Dimension，用于指定宽度和高度
方法详细信息

getX

public double getX()
以 double 精度返回边界 Rectangle 的 X 坐标。

指定者：
类 RectangularShape 中的 getX
返回：
边界 Rectangle 的 X 坐标。

getY

public double getY()
以 double 精度返回边界 Rectangle 的 Y 坐标。

指定者：
类 RectangularShape 中的 getY
返回：
边界 Rectangle 的 Y 坐标。

getWidth

public double getWidth()
以 double 精度返回边界 Rectangle 的宽度。

指定者：
类 RectangularShape 中的 getWidth
返回：
边界 Rectangle 的宽度。

getHeight

public double getHeight()
以 double 精度返回边界 Rectangle 的高度。

指定者：
类 RectangularShape 中的 getHeight
返回：
边界 Rectangle 的高度。

getBounds

public Rectangle getBounds()
获取此 Rectangle 的边界 Rectangle。

包含此方法是出于完整性考虑，以对应 Component 的 getBounds 方法。

指定者：
接口 Shape 中的 getBounds
覆盖：
类 RectangularShape 中的 getBounds
返回：
一个新 Rectangle，它等同于此 Rectangle 的边界 Rectangle。
从以下版本开始：
1.1
另请参见：
Component.getBounds(), setBounds(Rectangle), setBounds(int, int, int, int)

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
覆盖：
类 Rectangle2D 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()

setBounds

public void setBounds(Rectangle r)
设置此 Rectangle 的边界 Rectangle，以匹配指定的 Rectangle。

包含此方法是出于完整性考虑，以对应 Component 的 setBounds 方法。

参数：
r - 指定的 Rectangle
从以下版本开始：
1.1
另请参见：
getBounds(), Component.setBounds(java.awt.Rectangle)

setBounds

public void setBounds(int x,
                      int y,
                      int width,
                      int height)
将此 Rectangle 的边界 Rectangle 设置为指定的 x、y、width 和 height。

包含此方法是出于完整性考虑，以对应 Component 的 setBounds 方法。

参数：
x - 此 Rectangle 左上角的新 X 坐标
y - 此 Rectangle 左上角的新 Y 坐标
width - 此 Rectangle 的新宽度
height - 此 Rectangle 的新高度
从以下版本开始：
1.1
另请参见：
getBounds(), Component.setBounds(int, int, int, int)

setRect

public void setRect(double x,
                    double y,
                    double width,
                    double height)
将此 Rectangle 的边界设置为整数边界，它包含指定的 x、y、width 和 height。如果这些参数指定的 Rectangle 超出整数的最大范围，则结果将为与最大整数边界相交的指定 Rectangle 的最佳表示形式。

指定者：
类 Rectangle2D 中的 setRect
参数：
x - 指定矩形左上角的 X 坐标
y - 指定矩形左上角的 Y 坐标
width - 指定矩形的宽度
height - 指定矩形的新高度

reshape

@Deprecated
public void reshape(int x,
                               int y,
                               int width,
                               int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。

将此 Rectangle 的边界 Rectangle 设置为指定的 x、y、width 和 height。

参数：
x - 此 Rectangle 左上角的新 X 坐标
此 - Rectangle 左上角的新 Y 坐标
width - 此 Rectangle 的新宽度
height - 此 Rectangle 的新高度

getLocation

public Point getLocation()
返回此 Rectangle 的位置。

包含此方法是出于完整性考虑，以对应 Component 的 getLocation 方法。

返回：
一个 Point，它是此 Rectangle 左上角的顶点。
从以下版本开始：
1.1
另请参见：
Component.getLocation(), setLocation(Point), setLocation(int, int)

setLocation

public void setLocation(Point p)
将此 Rectangle 移动到指定位置。

包含此方法是出于完整性考虑，以对应 Component 的 setLocation 方法。

参数：
p - 指定此 Rectangle 新位置的 Point
从以下版本开始：
1.1
另请参见：
Component.setLocation(java.awt.Point), getLocation()

setLocation

public void setLocation(int x,
                        int y)
将此 Rectangle 移动到指定位置。

包含此方法是出于完整性考虑，以对应 Component 的 setLocation 方法。

参数：
x - 新位置的 X 坐标
y - 新位置的 Y 坐标
从以下版本开始：
1.1
另请参见：
getLocation(), Component.setLocation(int, int)

move

@Deprecated
public void move(int x,
                            int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。

将此 Rectangle 移动到指定位置。

参数：
x - 新位置的 X 坐标
新位置的 - Y 坐标

translate

public void translate(int dx,
                      int dy)
将此 Rectangle 沿 X 坐标轴向右，沿 Y 坐标轴向下平移指定距离。

参数：
dx - 沿 X 轴移动此 Rectangle 的距离
dy - 沿 Y 轴移动此 Rectangle 的距离
另请参见：
setLocation(int, int), setLocation(java.awt.Point)

getSize

public Dimension getSize()
获取此 Rectangle 的大小，用返回的 Dimension 表示。

包含此方法是出于完整性考虑，以对应 Component 的 getSize 方法。

返回：
一个 Dimension，表示此 Rectangle 的大小。
从以下版本开始：
1.1
另请参见：
Component.getSize(), setSize(Dimension), setSize(int, int)

setSize

public void setSize(Dimension d)
设置此 Rectangle 的大小，以匹配指定的 Dimension。

包含此方法是出于完整性考虑，以对应 Component 的 setSize 方法。

参数：
d - Dimension 对象的新大小
从以下版本开始：
1.1
另请参见：
Component.setSize(java.awt.Dimension), getSize()

setSize

public void setSize(int width,
                    int height)
将此 Rectangle 的大小设置为指定的宽度和高度。

包含此方法是出于完整性考虑，以对应 Component 的 setSize 方法。

参数：
width - 此 Rectangle 的新宽度
height - 此 Rectangle 的新高度
从以下版本开始：
1.1
另请参见：
Component.setSize(int, int), getSize()

resize

@Deprecated
public void resize(int width,
                              int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。

将此 Rectangle 的大小设置为指定的宽度和高度。

参数：
width - 此 Rectangle 的新宽度
height - 此 Rectangle 的新高度

contains

public boolean contains(Point p)
检查此 Rectangle 是否包含指定的 Point。

参数：
p - 要测试的 Point
返回：
如果指定的 Point 位于此 Rectangle 中，则返回 true；否则返回 false。
从以下版本开始：
1.1

contains

public boolean contains(int x,
                        int y)
检查此 Rectangle 是否包含位于指定位置 (x,y) 的点。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
返回：
如果点 (x,y) 位于此 Rectangle 中，则返回 true；否则返回 false。
从以下版本开始：
1.1

contains

public boolean contains(Rectangle r)
检查此 Rectangle 是否完全包含指定的 Rectangle。

参数：
r - 指定的 Rectangle
返回：
如果 Rectangle 完全包含在此 Rectangle 中，则返回 true；否则返回 false
从以下版本开始：
1.2

contains

public boolean contains(int X,
                        int Y,
                        int W,
                        int H)
检查此 Rectangle 是否完全包含位于指定位置 (X,Y) 且具有指定维数 (W,H) 的 Rectangle。

参数：
X - 指定的 X 坐标
Y - 指定的 Y 坐标
W - Rectangle 的宽度
H - Rectangle 的高度
返回：
如果由 (X, Y, W, H) 指定的 Rectangle 完全包含在此 Rectangle 中，则返回 true；否则返回 false。
从以下版本开始：
1.1

inside

@Deprecated
public boolean inside(int X,
                                 int Y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。

检查此 Rectangle 是否包含位于指定位置 (X,Y) 的点。

参数：
X - 指定的 X 坐标
Y - 指定的 Y 坐标
返回：
如果点 (X,Y) 位于此 Rectangle 中，则返回 true；否则返回 false。

intersects

public boolean intersects(Rectangle r)
确定此 Rectangle 是否与指定的 Rectangle 相交。如果两个矩形的交集为非空，则它们是相交的。

参数：
r - 指定的 Rectangle
返回：
如果指定的 Rectangle 与此 Rectangle 相交，则返回 true；否则返回 false。

intersection

public Rectangle intersection(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的交集。返回一个新的 Rectangle，它表示两个矩形的交集。如果两个矩形没有相交，则结果将是一个空矩形。

参数：
r - 指定的 Rectangle
返回：
同时包含在指定 Rectangle 和此 Rectangle 中的最大 Rectangle；如果这些矩形没有相交，则返回一个空矩形。

union

public Rectangle union(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的并集。返回一个新的 Rectangle，它表示两个矩形的并集。

如果两个 Rectangle 的任何维数小于 0，则应用针对不存在矩形的规则。如果只有一个维数小于 0，那么结果将是另一个 Rectangle 的副本。如果两个维数都小于 0，则结果中将至少有一个维数小于 0。

如果得到的 Rectangle 维数太大而无法表示为 int，则结果中将沿该维数有一个为 Integer.MAX_VALUE 的维数。

参数：
r - 指定的 Rectangle
返回：
同时包含指定 Rectangle 和此 Rectangle 的最小 Rectangle。

add

public void add(int newx,
                int newy)
将一个由整数参数 newx,newy 指定的点添加到此 Rectangle 的边界。

如果此 Rectangle 的任何维数小于 0，则应用针对不存在矩形的规则。在这种情况下，此 Rectangle 的新边界的位置将等于指定的坐标，且宽度和高度等于 0。

在添加一个点后，调用将添加的点作为参数的 contains 方法不一定返回 true。对于 Rectangl 右边和底部边界线上的点，econtains 方法不返回 true。所以，如果添加的点落在放大的 Rectangle 右边和底部边界线上，则 contains 将针对该点返回 false。如果指定的点必须包含在新 Rectangle 中，则应添加 1x1 矩形：

r.add(newx, newy, 1, 1);

参数：
newx - 新点的 X 坐标
newy - 新点的 Y 坐标

add

public void add(Point pt)
将指定的 Point 添加到此 Rectangle 的边界。

如果此 Rectangle 的任何维数小于 0，则应用针对不存在矩形的规则。在这种情况下，此 Rectangle 新边界的位置将等于指定 Point 的坐标，且宽度和高度等于 0。

在添加一个 Point 后，调用将添加的 Point 作为参数的 contains 方法不一定返回 true。对于 Rectangl 右边和底部边界线上的点，econtains 方法不返回 true。所以，如果添加的 Point 落在放大的 Rectangle 右边和底部边界线上，则 contains 将针对该 Point 返回 false。如果指定的点必须包含在新 Rectangle 中，则应添加 1x1 矩形：

r.add(pt.x, pt.y, 1, 1);

参数：
pt - 添加到此 Rectangle 中的新 Point

add

public void add(Rectangle r)
将一个 Rectangle 添加到此 Rectangle 中。得到的 Rectangle 是两个矩形的并集。

如果任何一个 Rectangle 任何维数小于 0，则结果将是另一个 Rectangle 的维数。如果两个 Rectangle 都至少有一个维数小于 0，则结果中至少有一个维数小于 0。

如果任何一个 Rectangle 中有一个或两个维数等于 0，则沿那些轴具有 0 维数的结果将等同于通过将相应原坐标添加到沿该轴的结果矩形中所获得的结果，这类似于 add(Point) 方法的操作，但没有超过该坐标的维数。

如果得到的 Rectangle 维数太大而无法表示为 int，则结果中将沿该维数有一个为 Integer.MAX_VALUE 的维数。

参数：
r - 指定的 Rectangle

grow

public void grow(int h,
                 int v)
在水平方向和垂直方向上同时调整 Rectangle 的大小。

此方法修改 Rectangle，使它左边和右边都增加 h 个单位，顶部和底部都增加 v 个单位。

新的 Rectangle 的左上角是 (x - h, y - v)，宽度是 (width + 2h)，高度是 (height + 2v)。

如果为 h 和 v 提供的是负值，则 Rectangle 的大小也相应地缩小。grow 方法检查整数溢出或下溢，但不检查得到的 width 和 height 值是否从负值增大到非负值或从非负值减小到负值。

参数：
h - 水平扩展
v - 垂直扩展

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

outcode

public int outcode(double x,
                   double y)
确定指定坐标相对于此 Rectangle2D 的位置。此方法计算适当掩码值的二进制或 (OR)，这些掩码值针对此 Rectangle2D 的每个边指示指定坐标是否在此 Rectangle2D 其余边缘的同一侧。

指定者：
类 Rectangle2D 中的 outcode
参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
返回：
所有适当外码的逻辑或。
从以下版本开始：
1.2
另请参见：
Rectangle2D.OUT_LEFT, Rectangle2D.OUT_TOP, Rectangle2D.OUT_RIGHT, Rectangle2D.OUT_BOTTOM

createIntersection

public Rectangle2D createIntersection(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。

指定者：
类 Rectangle2D 中的 createIntersection
参数：
r - 与此 Rectangle2D 相交的 Rectangle2D
返回：
同时被指定 Rectangle2D 和此 Rectangle2D 包含的最大 Rectangle2D。
从以下版本开始：
1.2

createUnion

public Rectangle2D createUnion(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。

指定者：
类 Rectangle2D 中的 createUnion
参数：
r - 与此 Rectangle2D 合并的 Rectangle2D
返回：
包含指定 Rectangle2D 和此 Rectangle2D 的最小 Rectangle2D。
从以下版本开始：
1.2

equals

public boolean equals(Object obj)
检查两个矩形是否相等。

当且仅当参数不是 null，而是一个与此 Rectangle 具有相同左上角、宽度和高度的 Rectangle 对象时，结果才为 true。

覆盖：
类 Rectangle2D 中的 equals
参数：
obj - 要与此 Rectangle 进行比较的 Object
返回：
如果对象相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回表示此 Rectangle 及其值的 String。

覆盖：
类 Object 中的 toString
返回：
表示此 Rectangle 对象的坐标和大小值的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderingHints (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 RenderingHints

java.lang.Object
    继承者  java.awt.RenderingHints
所有已实现的接口：
Cloneable, Map<Object,Object>
public class RenderingHints
extends Object
implements Map<Object,Object>, Cloneable

RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。Graphics2D 类以及实现 BufferedImageOp 和 RasterOp 的类都提供了一些方法，用于获取并可能设置单个 RenderingHints 键（或键组）及其关联值。当这些实现执行任何呈现或图像处理操作时，它们应当检查调用者所请求的任何 RenderingHints 的值，并相应地修改所使用的算法，以发挥它们的最佳功能。

注意，因为这些键和值是一些提示，所以不要求某一给定实现支持下面指示的所有可能选择，或者可以响应请求修改其算法选择。不同提示键的值也可以交互，从而在一种情况下可支持给定键的所有变体。当修改与其他键关联的值时，实现可能会受更多限制。例如，某些实现在抗锯齿提示关闭时可以提供几种抖动类型，但在抗锯齿开启时几乎不能控制抖动。受支持的键和提示的完整集合也因目标而有所不同，因为运行时在呈现到屏幕、呈现到 BufferedImage 对象或在打印时可能使用不同的底层模块。

实现可以随意地完全忽略提示，但应当尝试使用尽可能接近请求的实现算法。如果在将任意值用于关联提示键时某一实现支持给定的算法，那么它至少必须在此键的值正好是指定算法的值时才执行此操作。

用于控制提示的键都是为关联 RenderingHints.Key 类创建子类的特殊值。此类中许多常见提示在下文表示为静态常量，但列表并没有包含所有这类提示。通过定义子类化 Key 的新对象并定义关联值，其他包可以创建其他提示。

嵌套类摘要
static class RenderingHints.Key
定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
字段摘要
static RenderingHints.Key | KEY_ALPHA_INTERPOLATION Alpha 插值提示键。
static RenderingHints.Key | KEY_ANTIALIASING 抗锯齿提示键。
static RenderingHints.Key | KEY_COLOR_RENDERING 颜色呈现提示键。
static RenderingHints.Key | KEY_DITHERING 抖动提示键。
static RenderingHints.Key | KEY_FRACTIONALMETRICS 字体小数规格提示键。
static RenderingHints.Key | KEY_INTERPOLATION 插值提示键。
static RenderingHints.Key | KEY_RENDERING 呈现提示键。
static RenderingHints.Key | KEY_STROKE_CONTROL 笔划规范化控制提示键。
static RenderingHints.Key | KEY_TEXT_ANTIALIASING 文本抗锯齿提示键。
static RenderingHints.Key | KEY_TEXT_LCD_CONTRAST LCD 文本对比呈现提示键。
static Object | VALUE_ALPHA_INTERPOLATION_DEFAULT Alpha 插值提示值——由实现选择对性能和质量进行良好权衡的 alpha 混合算法
static Object | VALUE_ALPHA_INTERPOLATION_QUALITY Alpha 插值提示值——选择偏重于精确度和视觉质量的 alpha 混合算法。
static Object | VALUE_ALPHA_INTERPOLATION_SPEED Alpha 插值提示值——选择偏重于计算速度的 alpha 混合算法。
static Object | VALUE_ANTIALIAS_DEFAULT 抗锯齿提示值——使用由实现选择的默认抗锯齿模式完成呈现。
static Object | VALUE_ANTIALIAS_OFF 抗锯齿提示值——在不使用抗锯齿模式的情况下完成呈现。
static Object | VALUE_ANTIALIAS_ON 抗锯齿提示值——使用抗锯齿模式完成呈现。
static Object | VALUE_COLOR_RENDER_DEFAULT 颜色呈现提示值——根据实现的选择执行颜色转换计算，以表示可用的性能和精确度之间的最佳权衡。
static Object | VALUE_COLOR_RENDER_QUALITY 颜色呈现提示值——用最高的精确度和视觉质量执行颜色转换计算。
static Object | VALUE_COLOR_RENDER_SPEED 颜色呈现提示值——最快地执行输出设备格式的颜色转换。
static Object | VALUE_DITHER_DEFAULT 抖动提示值——对该实现选择的抖动使用默认值。
static Object | VALUE_DITHER_DISABLE 抖动提示值——呈现几何形状时不抖动。
static Object | VALUE_DITHER_ENABLE 抖动提示值——如果需要，在呈现几何形状时抖动。
static Object | VALUE_FRACTIONALMETRICS_DEFAULT 字体小数规格提示值——用实现选择的精度定位字符字形。
static Object | VALUE_FRACTIONALMETRICS_OFF 字体小数规格提示值——用舍入为像素边界的 advance width 定位字符字形。
static Object | VALUE_FRACTIONALMETRICS_ON 字体小数规格提示值——用子像素精确度定位字符字形。
static Object | VALUE_INTERPOLATION_BICUBIC 插值提示值—— 使用 X 和 Y 中的立方函数插入图像中整数坐标附近的 9 个样本，以生成一个颜色样本。
static Object | VALUE_INTERPOLATION_BILINEAR 插值提示值——图像中最接近整数坐标样本的 4 种颜色样本被线性地插入，以生成一个颜色样本。
static Object | VALUE_INTERPOLATION_NEAREST_NEIGHBOR 插值提示值——使用图像中最接近整数坐标样本的颜色样本。
static Object | VALUE_RENDER_DEFAULT 呈现提示值——由实现选择对性能和质量进行良好权衡的呈现算法。
static Object | VALUE_RENDER_QUALITY 呈现提示值——选择偏重输出质量的呈现算法。
static Object | VALUE_RENDER_SPEED 呈现提示值——选择偏重输出速度的呈现算法。
static Object | VALUE_STROKE_DEFAULT 笔划规范化控制提示值——根据给定实现的权衡，可以修改几何形状或保留原来的几何形状。
static Object | VALUE_STROKE_NORMALIZE 笔划规范化控制提示值——几何形状应当规范化，以提高均匀性或直线间隔和整体美观。
static Object | VALUE_STROKE_PURE 笔划规范化控制提示值——几何形状应该保持不变并使用子像素精确度呈现。
static Object | VALUE_TEXT_ANTIALIAS_DEFAULT 文本抗锯齿提示值——根据 KEY_ANTIALIASING 提示或由实现选择的默认值完成文本呈现。
static Object | VALUE_TEXT_ANTIALIAS_GASP 文本抗锯齿提示值——文本呈现需要使用字体资源中的信息，这些信息指定了每个点大小是否适合应用 VALUE_TEXT_ANTIALIAS_ON 或 VALUE_TEXT_ANTIALIAS_OFF。
static Object | VALUE_TEXT_ANTIALIAS_LCD_HBGR 文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素按从左到右为 B、G、R 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HBGR) 的三倍。
static Object | VALUE_TEXT_ANTIALIAS_LCD_HRGB 文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，该 LCD 显示器子像素按从左到右为 R、G、B 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HRGB) 的三倍。
static Object | VALUE_TEXT_ANTIALIAS_LCD_VBGR 文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VBGR) 的三倍。
static Object | VALUE_TEXT_ANTIALIAS_LCD_VRGB 文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VRGB) 的三倍。
static Object | VALUE_TEXT_ANTIALIAS_OFF 文本抗锯齿提示值——不使用任何抗锯齿形式完成文本呈现。
static Object | VALUE_TEXT_ANTIALIAS_ON 文本抗锯齿提示值——使用某种抗锯齿形式完成文本呈现。
构造方法摘要
RenderingHints(Map<RenderingHints.Key,?> init)
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。
RenderingHints(RenderingHints.Key key, Object value)
构造一个具有指定键/值对的新对象。
方法摘要
void | add(RenderingHints hints) 将指定 RenderingHints 对象中的所有键和相应的值添加到此 RenderingHints 对象中。
void | clear() 清除所有键/值对的 RenderingHints 对象。
Object | clone() 创建此 RenderingHints 对象的一个副本，它与此 RenderingHints 对象具有相同的内容。
boolean | containsKey(Object key) 如果此 RenderingHints 包含指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此 RenderingHints 将一个或多个键映射到指定值，则返回 true。
Set<Map.Entry<Object,Object>> | entrySet() 返回此 RenderingHints 中所包含映射关系的 Set 视图。
boolean | equals(Object o) 对指定的 Object 与此 RenderingHints 进行相等性比较。
Object | get(Object key) 返回指定键所映射的值。
int | hashCode() 返回此 RenderingHints 中的哈希码值。
boolean | isEmpty() 如果此 RenderingHints 未包含键-值映射关系，则返回 true。
Set<Object> | keySet() 返回此 RenderingHints 中所包含键的 Set 视图。
Object | put(Object key, Object value) 将指定 key 映射到此 RenderingHints 对象中指定的 value。
void | putAll(Map<?,?> m) 将指定 Map 中所有映射关系复制到此 RenderingHints 中。
Object | remove(Object key) 从此 RenderingHints 对象中移除键和它所对应的值。
int | size() 返回此 RenderingHints 中的键-值映射关系数。
String | toString() 返回 hashmap 的一个相当长的字符串表示形式，该 hashmap 包含此 RenderingHints 对象的键或值的映射关系。
Collection<Object> | values() 返回此 RenderinHints 中所包含键的 Collection 视图。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

KEY_ANTIALIASING

public static final RenderingHints.Key KEY_ANTIALIASING
抗锯齿提示键。ANTIALIASING 提示控制 Graphics2D 对象的几何形状呈现方法是否将尝试沿形状的边缘减少锯齿现象。

典型抗锯齿算法的工作方式如下：根据估计的部分形状像素覆盖率，沿形状的边界将像素的现有颜色与所请求的填充绘制 (fill paint) 混合在一起。

此提示允许的值有

  • VALUE_ANTIALIAS_ON
  • VALUE_ANTIALIAS_OFF
  • VALUE_ANTIALIAS_DEFAULT

VALUE_ANTIALIAS_ON

public static final Object VALUE_ANTIALIAS_ON
抗锯齿提示值——使用抗锯齿模式完成呈现。

另请参见：
KEY_ANTIALIASING

VALUE_ANTIALIAS_OFF

public static final Object VALUE_ANTIALIAS_OFF
抗锯齿提示值——在不使用抗锯齿模式的情况下完成呈现。

另请参见：
KEY_ANTIALIASING

VALUE_ANTIALIAS_DEFAULT

public static final Object VALUE_ANTIALIAS_DEFAULT
抗锯齿提示值——使用由实现选择的默认抗锯齿模式完成呈现。

另请参见：
KEY_ANTIALIASING

KEY_RENDERING

public static final RenderingHints.Key KEY_RENDERING
呈现提示键。RENDERING 提示是一个提供高级建议的常规提示，目的是在进行评估权衡时提示是应该选择更偏重于速度，还是选择更偏重于质量的算法。任何呈现或图像处理操作都可以参考此提示，但是决定通常会遵照其他优先于此提示的更明确的提示。

此提示允许的值有

  • VALUE_RENDER_SPEED
  • VALUE_RENDER_QUALITY
  • VALUE_RENDER_DEFAULT

VALUE_RENDER_SPEED

public static final Object VALUE_RENDER_SPEED
呈现提示值——选择偏重输出速度的呈现算法。

另请参见：
KEY_RENDERING

VALUE_RENDER_QUALITY

public static final Object VALUE_RENDER_QUALITY
呈现提示值——选择偏重输出质量的呈现算法。

另请参见：
KEY_RENDERING

VALUE_RENDER_DEFAULT

public static final Object VALUE_RENDER_DEFAULT
呈现提示值——由实现选择对性能和质量进行良好权衡的呈现算法。

另请参见：
KEY_RENDERING

KEY_DITHERING

public static final RenderingHints.Key KEY_DITHERING
抖动提示键。DITHERING 提示控制着在将颜色存储到颜色分辨率受限制的目标中时，所选颜色的近似程度。

一些呈现目标支持的颜色选择数可能受到限制，它也许无法准确地表示在呈现操作过程中产生的颜色的完整色谱。对于这类目标，DITHERING 提示控制着是否使用最接近于所请求的受支持颜色的单个像素值的普通固定填充方式来完成呈现，或者是否使用组合的颜色模式来填充形状，以便更好地接近于该颜色。

此提示允许的值有

  • VALUE_DITHER_DISABLE
  • VALUE_DITHER_ENABLE
  • VALUE_DITHER_DEFAULT

VALUE_DITHER_DISABLE

public static final Object VALUE_DITHER_DISABLE
抖动提示值——呈现几何形状时不抖动。

另请参见：
KEY_DITHERING

VALUE_DITHER_ENABLE

public static final Object VALUE_DITHER_ENABLE
抖动提示值——如果需要，在呈现几何形状时抖动。

另请参见：
KEY_DITHERING

VALUE_DITHER_DEFAULT

public static final Object VALUE_DITHER_DEFAULT
抖动提示值——对该实现选择的抖动使用默认值。

另请参见：
KEY_DITHERING

KEY_TEXT_ANTIALIASING

public static final RenderingHints.Key KEY_TEXT_ANTIALIASING
文本抗锯齿提示键。TEXT_ANTIALIASING 提示可以控制文本抗锯齿算法的使用，这与形状呈现的选择无关。通常，应用程序只希望对文本而不是其他形状使用抗锯齿。此外，用于减少文本锯齿现象的算法通常比那些为常规呈现而开发的算法更复杂，所以，此提示键提供了其他一些值，这些值可以控制某些特定于文本的算法的选择。如果保持在 DEFAULT 状态下，此提示通常遵从常规 KEY_ANTIALIASING 提示键的值。

此提示允许的值有

  • VALUE_TEXT_ANTIALIAS_ON
  • VALUE_TEXT_ANTIALIAS_OFF
  • VALUE_TEXT_ANTIALIAS_DEFAULT
  • VALUE_TEXT_ANTIALIAS_GASP
  • VALUE_TEXT_ANTIALIAS_LCD_HRGB
  • VALUE_TEXT_ANTIALIAS_LCD_HBGR
  • VALUE_TEXT_ANTIALIAS_LCD_VRGB
  • VALUE_TEXT_ANTIALIAS_LCD_VBGR

VALUE_TEXT_ANTIALIAS_ON

public static final Object VALUE_TEXT_ANTIALIAS_ON
文本抗锯齿提示值——使用某种抗锯齿形式完成文本呈现。

另请参见：
KEY_TEXT_ANTIALIASING

VALUE_TEXT_ANTIALIAS_OFF

public static final Object VALUE_TEXT_ANTIALIAS_OFF
文本抗锯齿提示值——不使用任何抗锯齿形式完成文本呈现。

另请参见：
KEY_TEXT_ANTIALIASING

VALUE_TEXT_ANTIALIAS_DEFAULT

public static final Object VALUE_TEXT_ANTIALIAS_DEFAULT
文本抗锯齿提示值——根据 KEY_ANTIALIASING 提示或由实现选择的默认值完成文本呈现。

另请参见：
KEY_TEXT_ANTIALIASING

VALUE_TEXT_ANTIALIAS_GASP

public static final Object VALUE_TEXT_ANTIALIAS_GASP
文本抗锯齿提示值——文本呈现需要使用字体资源中的信息，这些信息指定了每个点大小是否适合应用 VALUE_TEXT_ANTIALIAS_ON 或 VALUE_TEXT_ANTIALIAS_OFF。

TrueType 字体通常在 'gasp' 表中提供此信息。在没有此信息的情况下，特定字体和大小的行为由实现默认值确定。

注：字体设计者通常慎重地针对大多数普通用户界面的点大小提示某一种字体。因此，'gasp' 表有可能指定只针对这些大小而不是所有大小使用提示。所以，在许多情况下，得到的文本显示等效于 VALUE_TEXT_ANTIALIAS_OFF。这可能无法预料，但它是正确的。

出于一致性目的，由多种物理字体组成的逻辑字体将使用最适合于总体复合字体的设置。

从以下版本开始：
1.6
另请参见：
KEY_TEXT_ANTIALIASING

VALUE_TEXT_ANTIALIAS_LCD_HRGB

public static final Object VALUE_TEXT_ANTIALIAS_LCD_HRGB
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，该 LCD 显示器子像素按从左到右为 R、G、B 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HRGB) 的三倍。这是最常用的配置。为具有其他 LCD 子像素配置的显示器选择此提示将可能导致没有焦点的文本。

注：
在选择是否应用任何 LCD 文本提示值时，实现可能考虑多种因素，这些因素包括要求目标的颜色深度至少要为每像素 15 位（即每个颜色分量为 5 位）；字体特征（如内嵌位图是否可以产生更好的结果）；在显示到非本地网络显示设备时，是否只在有合适的协议可用时才启用它；如果执行非常高的分辨率呈现或目标设备不合适时（如打印时），是否忽略提示。

这些提示在呈现到软件图像时同样可以应用，但这些图像可能不适合于常规导出，因为文本将针对特定子像素组织进行适当地呈现。此外，有损失的图像和图像格式（如颜色受到限制的 GIF）不是一个好选择。所以，除非图像注定要在具有相同配置的显示设备上呈现，否则，其他一些文本抗锯齿提示（如 VALUE_TEXT_ANTIALIAS_ON）也许是更好的选择。

在使用时选择与 LCD 显示器不匹配的值可能导致文本质量的下降。在不具备与 LCD 显示器相同特征的显示设备（即 CRT）上，整体效果可能类似于标准文本抗锯齿，但质量可能因颜色失真而降低。模拟连接的 LCD 显示器也没有表现出比标准文本抗锯齿更好的地方，类似于 CRT。

换句话说，为了得到最好的结果，需使用带有数字显示连接器的 LCD 显示器并指定合适的子像素配置。

从以下版本开始：
1.6
另请参见：
KEY_TEXT_ANTIALIASING

VALUE_TEXT_ANTIALIAS_LCD_HBGR

public static final Object VALUE_TEXT_ANTIALIAS_LCD_HBGR
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素按从左到右为 B、G、R 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HBGR) 的三倍。与 HRGB 相比，这种配置不常见。为具有其他 LCD 子像素配置的显示器选择此提示将可能导致没有焦点的文本。有关何时应用此提示的更多信息，请参阅 VALUE_TEXT_ANTIALIAS_LCD_HRGB。

从以下版本开始：
1.6
另请参见：
KEY_TEXT_ANTIALIASING

VALUE_TEXT_ANTIALIAS_LCD_VRGB

public static final Object VALUE_TEXT_ANTIALIAS_LCD_VRGB
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VRGB) 的三倍。垂直方向比较少见，可能主要对物理旋转的显示器有用。为具有其他 LCD 子像素配置的显示器选择此提示将可能导致没有焦点的文本。有关何时应用此提示的更多信息，请参阅 VALUE_TEXT_ANTIALIAS_LCD_HRGB。

从以下版本开始：
1.6
另请参见：
KEY_TEXT_ANTIALIASING

VALUE_TEXT_ANTIALIAS_LCD_VBGR

public static final Object VALUE_TEXT_ANTIALIAS_LCD_VBGR
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VBGR) 的三倍。垂直方向比较少见，可能主要对物理地旋转显示有用。为具有其他 LCD 子像素配置的显示选择此提示将可能导致没有焦点的文本。有关何时应用此提示的更多信息，请参阅 VALUE_TEXT_ANTIALIAS_LCD_HRGB。

从以下版本开始：
1.6
另请参见：
KEY_TEXT_ANTIALIASING

KEY_TEXT_LCD_CONTRAST

public static final RenderingHints.Key KEY_TEXT_LCD_CONTRAST
LCD 文本对比呈现提示键。此值是一个 Integer 对象，在与 LCD 文本抗锯齿提示（如 VALUE_TEXT_ANTIALIAS_LCD_HRGB）一起使用时，它被用于文本对比度调整。
  • 这些值应该是 100 到 250 之间的正整数。
  • 当在浅色背景上显示深色文本时，较低的值（如 100）对应于较高对比度的文本。
  • 当在浅色背景上显示深色文本时，较高的值（如 200）对应于较低对比度的文本。
  • 通常，有用值的范围缩小到 140-180。
  • 如果未指定任何值，则应用系统或实现的默认值。
默认值可以满足大多数目的，所以客户端几乎都不需要指定此提示值，除非它们有关于某一合适值的具体信息。较高的值并不意味着较高的对比度，实际上正好相反。校正以一种类似方式应用于显示系统的非线性感知亮度响应（perceptual luminance response）的 gamma 调整，但不指示对它进行完全校正。

从以下版本开始：
1.6
另请参见：
KEY_TEXT_ANTIALIASING

KEY_FRACTIONALMETRICS

public static final RenderingHints.Key KEY_FRACTIONALMETRICS
字体小数规格提示键。FRACTIONALMETRICS 提示控制单个字符字形的定位是否考虑字体的缩放字符 advance 子像素的精确度，或者这类 advance 向量是否舍入为整个设备像素的一个整数数字。此提示只建议定位字形应该使用的精度，而不指定或建议是否应为了匹配而修改实际光栅化或字形的像素边界。

将文本呈现到低分辩率的设备（如屏幕）时没必要包括大量的舍入操作，因为字符字形的形状与规格的高质量和非常精确的定义必须与离散设备像素相匹配。理想情况下，文本布局过程中字形的定位将根据点的大小通过缩放字体的设计规格进行计算，但缩放的 advance with 不必是像素的一个整数数字。如果根据这些缩放的设计规格使用子像素精确度对字形进行定位，则在理想情况下，光栅化需要针对每个可能的子像素原点进行调整。

不幸的是，在文本布局过程中将每个自定义字形缩放到其实际子像素原点的代价太高，所以基于整数设备定位的简化系统通常用于布局文本。字形的光栅化和缩放的 advance with 在设备分辨率上都被调整，以生成看起来很好的文本，在字形之间具有一致的整数像素距离，有助于使字形看起来均匀，有一致性的距离且可读性好。

这种将光栅化字形的 advance with 舍入为整数距离的处理意味着：由于在每个字形调整宽度中一系列小差异的累加，使得字符密度和文本字符串的整体长度不同于理论上设计的测量值。特定差异将针对每种字形而有所不同，与它们的理论设计测量值相比，一些字形比较宽，而另一些字形较窄。因此，字符密度和长度中的整体差异将因许多因素的不同而有所不同，这些因素包括字体、作为目标的特定设备分辨率以及为表示要呈现的字符串而选择的字形。因此，对整个字符串而言，在多个设备分辨率中呈现同一个字符串可能出现很多不同的规格。

当启用 FRACTIONALMETRICS 时，实际字体设计规格按照点大小缩放，并用于具有子像素精确度的布局。因此，字符的字形平均密度和长字符串总长度将更接近于与字体的理论设计相匹配，但是可读性可能受影响，因为单独的字符对可能并不是始终显示为一致的间隔距离，这取决于字形原点子像素的累加与设备像素网格的协调方式。当正在执行必须一致地跨越多种不同输出分辨率的文本布局时，启用此提示可能很合适。需要特别说明的是，在文本布局正在低分辩率设备（如输出屏幕）上预览，但最终在高分辩率打印机或排版设备上呈现的情况下，此提示可能也很合适。

当禁用此提示时，缩放的设计规格针对布局舍入或调整为整数距离。任意特定字形对之间的距离在设备上将更加统一，但是长字符串的密度和总长度可能不再与字体设计人员的理论想法相匹配。在低分辩率设备（如计算机监视器）上禁用此提示通常产生更可读的结果。

此键允许的值有

  • VALUE_FRACTIONALMETRICS_OFF
  • VALUE_FRACTIONALMETRICS_ON
  • VALUE_FRACTIONALMETRICS_DEFAULT

VALUE_FRACTIONALMETRICS_OFF

public static final Object VALUE_FRACTIONALMETRICS_OFF
字体小数规格提示值——用舍入为像素边界的 advance width 定位字符字形。

另请参见：
KEY_FRACTIONALMETRICS

VALUE_FRACTIONALMETRICS_ON

public static final Object VALUE_FRACTIONALMETRICS_ON
字体小数规格提示值——用子像素精确度定位字符字形。

另请参见：
KEY_FRACTIONALMETRICS

VALUE_FRACTIONALMETRICS_DEFAULT

public static final Object VALUE_FRACTIONALMETRICS_DEFAULT
字体小数规格提示值——用实现选择的精度定位字符字形。

另请参见：
KEY_FRACTIONALMETRICS

KEY_INTERPOLATION

public static final RenderingHints.Key KEY_INTERPOLATION
插值提示键。INTERPOLATION 提示控制在图像呈现操作过程中如何过滤图像像素或重新对其取样。

图像被隐式地定义为在整数坐标位置上提供颜色样本。当图像没有缩放到目标而垂直呈现时，其图像像素映射到其设备像素的选择是显而易见的，且图像中整数坐标位置的样本一个对一个地被转换到设备像素网格上的相应整数位置。当图像在缩放、旋转或其他转换坐标系中呈现时，图像后面设备像素坐标的映射关系可能引起问题：所提供的图像样本整数位置之间的连续坐标处使用什么颜色样本。插值算法定义了一些函数，它们根据整数坐标周围的颜色样本为图像中的任何连续坐标提供颜色样本。

此提示允许的值有

  • VALUE_INTERPOLATION_NEAREST_NEIGHBOR
  • VALUE_INTERPOLATION_BILINEAR
  • VALUE_INTERPOLATION_BICUBIC

VALUE_INTERPOLATION_NEAREST_NEIGHBOR

public static final Object VALUE_INTERPOLATION_NEAREST_NEIGHBOR
插值提示值——使用图像中最接近整数坐标样本的颜色样本。从概念上讲，图像被视为单位大小的方形颜色区域的网格，该颜色以每个图像像素的中心为中心。

在放大图像时，图像看起来会相应地有些斑驳模糊。在缩小图像时，在输出表示中，源像素的颜色被不作修改地使用，或者完全被跳过。

另请参见：
KEY_INTERPOLATION

VALUE_INTERPOLATION_BILINEAR

public static final Object VALUE_INTERPOLATION_BILINEAR
插值提示值——图像中最接近整数坐标样本的 4 种颜色样本被线性地插入，以生成一个颜色样本。从概念上讲，图像被视为一组无穷小的点颜色样本，其值只位于整数坐标像素的中心，而且这些像素中心之间的空间是用线性延伸的颜色填充的，并用直线连接相邻的离散样本。

当放大图像时，因为有 NEAREST_NEIGHBOR，在图像中的颜色之间没有斑驳模糊边缘，但是混合可能沿样本排列的水平和垂直边缘显示一些微小的间断，这是由于插值斜面从样本的一侧到另一侧的突然更改造成的。当缩小图像时，更多图像像素具有它们自己的以结果输出表示的颜色样本，因为每个输出像素都从多达 4 个图像像素中接收颜色信息。

另请参见：
KEY_INTERPOLATION

VALUE_INTERPOLATION_BICUBIC

public static final Object VALUE_INTERPOLATION_BICUBIC
插值提示值—— 使用 X 和 Y 中的立方函数插入图像中整数坐标附近的 9 个样本，以生成一个颜色样本。从概念上讲，图像视图非常类似于 BILINEAR 算法中使用的视图，区别在于连接样本和曲线之间的颜色延伸，且当它们跨越样本边界时具有较好的斜面连续性。

放大图像时，没有斑驳模糊的边缘，与 BILINEAR 相比，插值显示得更光滑且原始图像中的所有边界都具有更好的描绘。当缩小图像时，甚至有更多的原始图像中的原始颜色样本将带有并表示它们的颜色信息。

另请参见：
KEY_INTERPOLATION

KEY_ALPHA_INTERPOLATION

public static final RenderingHints.Key KEY_ALPHA_INTERPOLATION
Alpha 插值提示键。ALPHA_INTERPOLATION 提示是一个提供高级建议的常规提示，目的是在评估权衡时提示应选择更偏重于速度或更偏重于质量的 alpha 混合算法。

此提示可以控制 alpha 混合算法的选择，它提供了使用快速查找表或较低精度 SIMD 指令的一些精确度。在计算其他每像素成本时，此提示还控制是否在多个线性可视效果计算过程中将颜色和 alpha 值转换到线性颜色空间。

此提示允许的值有

  • VALUE_ALPHA_INTERPOLATION_SPEED
  • VALUE_ALPHA_INTERPOLATION_QUALITY
  • VALUE_ALPHA_INTERPOLATION_DEFAULT

VALUE_ALPHA_INTERPOLATION_SPEED

public static final Object VALUE_ALPHA_INTERPOLATION_SPEED
Alpha 插值提示值——选择偏重于计算速度的 alpha 混合算法。

另请参见：
KEY_ALPHA_INTERPOLATION

VALUE_ALPHA_INTERPOLATION_QUALITY

public static final Object VALUE_ALPHA_INTERPOLATION_QUALITY
Alpha 插值提示值——选择偏重于精确度和视觉质量的 alpha 混合算法。

另请参见：
KEY_ALPHA_INTERPOLATION

VALUE_ALPHA_INTERPOLATION_DEFAULT

public static final Object VALUE_ALPHA_INTERPOLATION_DEFAULT
Alpha 插值提示值——由实现选择对性能和质量进行良好权衡的 alpha 混合算法

另请参见：
KEY_ALPHA_INTERPOLATION

KEY_COLOR_RENDERING

public static final RenderingHints.Key KEY_COLOR_RENDERING
颜色呈现提示键。COLOR_RENDERING 提示控制将颜色存储到目标图像或表面时近似值或转换的精确度。

当必须将呈现或图像处理操作生成的颜色值存储到目标中时，首先必须将该颜色转换为适合存储到目标图像或表面中的形式。必须至少将颜色分量转换为位表示形式并以正确的顺序排序，或者必须首先选择颜色查找表的索引，这样数据才可以存储到目标内存中。没有这种最少的转换，目标数据有可能表示为随机、不正确或甚至可能不受支持的值。快速将呈现操作的结果转换为最常见目标颜色格式的算法已众所周知，且执行得相当理想。

仅执行最基本的颜色格式转换，将颜色存储到目标，这样做可能潜在地忽略源和目标的 ColorSpace 校准或其他因素（如 gamma 校正的直线性）的差异。除非源和目标 ColorSpace 相同，从而在正确执行呈现操作的同时最大限度地维护被表示颜色的精确度，否则应该将源颜色转换为设备无关的 ColorSpace，然后转换回目标 ColorSpace。此外，如果要在呈现操作过程中执行计算（如多种源颜色的混合），通过选择与中间设备无关的 ColorSpace，使被计算的值与人眼的感知之间具有某种线性关系，以响应输出设备曲线，那么可以实现更加清晰的视觉。

此提示允许的值有

  • VALUE_COLOR_RENDER_SPEED
  • VALUE_COLOR_RENDER_QUALITY
  • VALUE_COLOR_RENDER_DEFAULT

VALUE_COLOR_RENDER_SPEED

public static final Object VALUE_COLOR_RENDER_SPEED
颜色呈现提示值——最快地执行输出设备格式的颜色转换。

另请参见：
KEY_COLOR_RENDERING

VALUE_COLOR_RENDER_QUALITY

public static final Object VALUE_COLOR_RENDER_QUALITY
颜色呈现提示值——用最高的精确度和视觉质量执行颜色转换计算。

另请参见：
KEY_COLOR_RENDERING

VALUE_COLOR_RENDER_DEFAULT

public static final Object VALUE_COLOR_RENDER_DEFAULT
颜色呈现提示值——根据实现的选择执行颜色转换计算，以表示可用的性能和精确度之间的最佳权衡。

另请参见：
KEY_COLOR_RENDERING

KEY_STROKE_CONTROL

public static final RenderingHints.Key KEY_STROKE_CONTROL
笔划规范化控制提示键。STROKE_CONTROL 提示键控制呈现实现是否应该或允许出于各种目的而修改所呈现轮廓的几何形状。

一些实现可以使用优化的平台呈现库，在给定平台上，它们比传统软件呈现算法更快，但它们也可能不支持浮点坐标。一些实现也可以具有复杂的算法，它们打乱路径的坐标，以便在宽度和间距上使宽线看起来更统一。

如果实现执行任意类型的修改或路径的“规范化”，则应当不在任何方向用半个以上像素来移动坐标。

此提示允许的值有

  • VALUE_STROKE_NORMALIZE
  • VALUE_STROKE_PURE
  • VALUE_STROKE_DEFAULT

从以下版本开始：
1.3

VALUE_STROKE_DEFAULT

public static final Object VALUE_STROKE_DEFAULT
笔划规范化控制提示值——根据给定实现的权衡，可以修改几何形状或保留原来的几何形状。通常情况下，此设置允许实现使用基于平台呈现库的快速整数坐标，但不特别要求均匀性或审美上的规范化。

从以下版本开始：
1.3
另请参见：
KEY_STROKE_CONTROL

VALUE_STROKE_NORMALIZE

public static final Object VALUE_STROKE_NORMALIZE
笔划规范化控制提示值——几何形状应当规范化，以提高均匀性或直线间隔和整体美观。注意，对于给定的输入路径，不同的规范化算法可能比其他算法更成功。

从以下版本开始：
1.3
另请参见：
KEY_STROKE_CONTROL

VALUE_STROKE_PURE

public static final Object VALUE_STROKE_PURE
笔划规范化控制提示值——几何形状应该保持不变并使用子像素精确度呈现。

从以下版本开始：
1.3
另请参见：
KEY_STROKE_CONTROL
构造方法详细信息

RenderingHints

public RenderingHints(Map<RenderingHints.Key,?> init)
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。

参数：
init - 初始化提示的键/值对映射；如果对象为空，则该参数为 null

RenderingHints

public RenderingHints(RenderingHints.Key key,
                      Object value)
构造一个具有指定键/值对的新对象。

参数：
key - 特定提示属性的键
value - 用 key 指定的提示属性的值
方法详细信息

size

public int size()
返回此 RenderingHints 中的键-值映射关系数。

指定者：
接口 Map<Object,Object> 中的 size
返回：
此 RenderingHints 中的键-值映射关系数。

isEmpty

public boolean isEmpty()
如果此 RenderingHints 未包含键-值映射关系，则返回 true。

指定者：
接口 Map<Object,Object> 中的 isEmpty
返回：
如果此 RenderingHints 未包含键-值映射关系，则返回 true。

containsKey

public boolean containsKey(Object key)
如果此 RenderingHints 包含指定键的映射关系，则返回 true。

指定者：
接口 Map<Object,Object> 中的 containsKey
参数：
key - 要测试其是否存在于此 RenderingHints 中的键。
返回：
如果此 RenderingHints 包含指定键的映射关系，则返回 true。
抛出：
ClassCastException - 如果无法将键强制转换为 RenderingHints.Key

containsValue

public boolean containsValue(Object value)
如果此 RenderingHints 将一个或多个键映射到指定值，则返回 true。更正式地说，当且仅当此 RenderingHints 至少包含一个与满足以下条件的值 v 的映射关系时，才返回 true：
(value==null ? v==null :value.equals(v))
. 对于大部分 RenderingHints 实现而言，此操作需要的时间可能会与 RenderingHints 的大小呈线性关系。

指定者：
接口 Map<Object,Object> 中的 containsValue
参数：
value - 要测试是否存在于此 RenderingHints 中的值。
返回：
如果此 RenderingHints 将一个或多个键映射到指定值，则返回 true。

get

public Object get(Object key)
返回指定键所映射的值。

指定者：
接口 Map<Object,Object> 中的 get
参数：
key - 呈现提示键
返回：
该键在此对象中所映射的值；如果该键没有映射到此对象中的任何值，则返回 null。
抛出：
ClassCastException - 如果无法将键强制转换为 RenderingHints.Key
另请参见：
put(Object, Object)

put

public Object put(Object key,
                  Object value)
将指定 key 映射到此 RenderingHints 对象中指定的 value。key 和 value 都不能为 null。通过使用与原来的键相同的键调用 get 方法，可以得到该值。

指定者：
接口 Map<Object,Object> 中的 put
参数：
key - 呈现提示键。
key - 呈现提示值。
value - 与指定键关联的值
返回：
此对象中指定键的以前的值；如果不存在该值，则返回 null。
抛出：
NullPointerException - 如果该键为 null。
ClassCastException - 如果无法将该键强制转换为 RenderingHints.Key
IllegalArgumentException - 对于指定值，如果指定键的 Key.isCompatibleValue() 方法返回 false
另请参见：
get(Object)

add

public void add(RenderingHints hints)
将指定 RenderingHints 对象中的所有键和相应的值添加到此 RenderingHints 对象中。位于此 RenderingHints 对象中，但不在指定的 RenderingHints 对象中的键不受影响。

参数：
hints - 要添加到此 RenderingHints 对象中的键/值对的集合

clear

public void clear()
清除所有键/值对的 RenderingHints 对象。

指定者：
接口 Map<Object,Object> 中的 clear

remove

public Object remove(Object key)
从此 RenderingHints 对象中移除键和它所对应的值。如果该键不在此 RenderingHints 对象中，则此方法不执行任何操作。

指定者：
接口 Map<Object,Object> 中的 remove
参数：
key - 要移除的呈现提示键
返回：
以前在此 RenderingHints 对象中映射的键的值；如果键没有映射关系，则返回 null。
抛出：
ClassCastException - 如果无法将键强制转换为 RenderingHints.Key

putAll

public void putAll(Map<?,?> m)
将指定 Map 中所有映射关系复制到此 RenderingHints 中。这些映射关系将替换此 RenderingHints 中针对指定 Map 中的当前所有键的所有映射关系。

指定者：
接口 Map<Object,Object> 中的 putAll
参数：
m - 指定的 Map
抛出：
ClassCastException - 指定 Map 中的键或值的类不允许将其存储在此 RenderingHints 中。
IllegalArgumentException - 如果指定 Map 中的键或值的某个方面不允许将其存储在此 RenderingHints 中。

keySet

public Set<Object> keySet()
返回此 RenderingHints 中所包含键的 Set 视图。Set 受 RenderingHints 的支持，所以对 RenderingHints 的更改反映在 Set 中，反之亦然。如果在对 Set 进行迭代的同时修改了 RenderingHints，则迭代的结果是不确定的。该 Set 支持元素移除，它可以通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从 RenderingHints 中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<Object,Object> 中的 keySet
返回：
此 RenderingHints 所包含键的 Set 视图。

values

public Collection<Object> values()
返回此 RenderinHints 中所包含键的 Collection 视图。Collection 受 RenderingHints 的支持，所以 RenderingHints 的更改反映在 Collection 中，反之亦然。如果在对 Collection 进行迭代的同时修改了 RenderingHints，则迭代的结果是不确定的。此 Collection 支持元素移除，它可以通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作从 RenderingHints 中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<Object,Object> 中的 values
返回：
此 RenderingHints 所包含值的 Collection 视图。

entrySet

public Set<Map.Entry<Object,Object>> entrySet()
返回此 RenderingHints 中所包含映射关系的 Set 视图。在返回的 Set 中，每个元素都是一个 Map.Entry。Set 受 RenderingHints 的支持，所以对 RenderingHints 的更改反映在 Set 中，反之亦然。如果在对 Set 进行迭代的同时修改了 RenderingHints，则迭代的结果是不确定的。

从 RenderingHints 对象中返回的 entrySet 是不可修改的。

指定者：
接口 Map<Object,Object> 中的 entrySet
返回：
此 RenderingHints 所包含映射关系的 Set 视图。

equals

public boolean equals(Object o)
对指定的 Object 与此 RenderingHints 进行相等性比较。如果指定对象也是一个 Map，并且这两个 Map 对象表示相同的映射关系，则返回 true。更正式地说，如果 t1.keySet().equals(t2.keySet())，并且对于 t1.keySet() 中的每个键 k，都满足以下条件，则 t1 和 t2 这两个 Map 对象表示相同的映射关系：
(t1.get(k)==null ? t2.get(k)==null :t1.get(k).equals(t2.get(k)))
. 这确保了 equals 方法在 Map 接口的不同实现中能够正常工作。

指定者：
接口 Map<Object,Object> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与此 RenderingHints 进行相等性比较的 Object。
返回：
如果指定的 Object 等于此 RenderingHints，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 RenderingHints 中的哈希码值。RenderingHints 的哈希码被定义为此 RenderingHints 对象的 entrySet 视图中每个 Entry 的 hashCode 之和。这确保 t1.equals(t2) 意味着对于任何两个 Map 对象 t1 和 t2，都存在 t1.hashCode()==t2.hashCode()，这正是 Object.hashCode 的常规协定所要求的。

指定者：
接口 Map<Object,Object> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 RenderingHints 的哈希码值。
另请参见：
Map.Entry.hashCode(),
Object.hashCode(),
Object.equals(Object),
equals(Object)

clone

public Object clone()
创建此 RenderingHints 对象的一个副本，它与此 RenderingHints 对象具有相同的内容。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

toString

public String toString()
返回 hashmap 的一个相当长的字符串表示形式，该 hashmap 包含此 RenderingHints 对象的键或值的映射关系。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderingHints.Key (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 RenderingHints.Key

java.lang.Object
    继承者  java.awt.RenderingHints.Key
正在封闭类：
RenderingHints
public abstract static class RenderingHints.Key
extends Object

定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。此类的实例是不变且唯一的，这意味着可以使用 == 运算符代替开销更大的 equals() 方法进行匹配测试。

构造方法摘要
protected RenderingHints.Key(int privatekey)
使用指示的私有键构造一个键。
方法摘要
 boolean equals(Object o)
用于所有 Key 对象的 equals 方法将返回与等号运算符 '==' 相同的结果。
 int hashCode()
所有 Key 对象的哈希码将与 System.identityHashCode() 方法定义的对象的系统识别码相同。
protected  int intKey()
返回子类用来实例化此 Key 的私有整数键。
abstract  boolean isCompatibleValue(Object val)
如果指定对象是此 Key 的有效值，则返回 true。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RenderingHints.Key

protected RenderingHints.Key(int privatekey)
使用指示的私有键构造一个键。Key 的每个子类都会维护自己唯一的整数键域。无法构造出两个具有相同整数键和相同指定子类的对象。如果试图用与 Key 子类的已有实例相同的整数键构造给定类的另一个对象，则将抛出一个异常。

参数：
privatekey - 指定键
方法详细信息

isCompatibleValue

public abstract boolean isCompatibleValue(Object val)
如果指定对象是此 Key 的有效值，则返回 true。

参数：
val - 要测试有效性的 Object
返回：
如果 val 有效，则返回 true；否则返回 false。

intKey

protected final int intKey()
返回子类用来实例化此 Key 的私有整数键。

返回：
子类用来实例化此 Key 的私有整数键。

hashCode

public final int hashCode()
所有 Key 对象的哈希码将与 System.identityHashCode() 方法定义的对象的系统识别码相同。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public final boolean equals(Object o)
用于所有 Key 对象的 equals 方法将返回与等号运算符 '==' 相同的结果。

覆盖：
类 Object 中的 equals
参数：
o - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Robot (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Robot

java.lang.Object
    继承者  java.awt.Robot

public class Robot
extends Object

此类用于为测试自动化、自运行演示程序和其他需要控制鼠标和键盘的应用程序生成本机系统输入事件。Robot 的主要目的是便于 Java 平台实现自动测试。

使用该类生成输入事件与将事件发送到 AWT 事件队列或 AWT 组件的区别在于：事件是在平台的本机输入队列中生成的。例如，Robot.mouseMove 将实际移动鼠标光标，而不是只生成鼠标移动事件。

注意，某些平台需要特定权限或扩展来访问低级输入控件。如果当前平台配置不允许使用输入控件，那么试图构造 Robot 对象时将抛出 AWTException。例如，如果 X 服务器不支持（或没有启用）XTEST 2.2 标准扩展，则 X-Window 系统会抛出异常。

出于自测试之外的目的而使用 Robot 的应用程序应妥善处理这些错误条件。

从以下版本开始：
1.3

构造方法摘要
Robot()
在基本屏幕坐标系中构造一个 Robot 对象。
Robot(GraphicsDevice screen)
为给定屏幕设备创建一个 Robot 。
方法摘要
BufferedImage | createScreenCapture(Rectangle screenRect) 创建包含从屏幕中读取的像素的图像。
void | delay(int ms) 睡眠指定的时间。
int | getAutoDelay() 返回此 Robot 在生成一个事件后睡眠的毫秒数。
Color | getPixelColor(int x, int y) 返回给定屏幕坐标处的像素颜色。
boolean | isAutoWaitForIdle() 返回此 Robot 在生成一个事件后是否自动调用 waitForIdle。
void | keyPress(int keycode) 按下给定的键。
void | keyRelease(int keycode) 释放给定的键。
void | mouseMove(int x, int y) 将鼠标指针移动到给定屏幕坐标。
void | mousePress(int buttons) 按下一个或多个鼠标按钮。
void | mouseRelease(int buttons) 释放一个或多个鼠标按钮。
void | mouseWheel(int wheelAmt) 在配有滚轮的鼠标上旋转滚轮。
void | setAutoDelay(int ms) 设置此 Robot 在生成一个事件后睡眠的毫秒数。
void | setAutoWaitForIdle(boolean isOn) 设置此 Robot 在生成一个事件后是否自动调用 waitForIdle。
String | toString() 返回此 Robot 的字符串表示形式。
void | waitForIdle() 在处理完当前事件队列中的所有事件之前，一直等待。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Robot

public Robot()
      throws AWTException
在基本屏幕坐标系中构造一个 Robot 对象。

抛出：
AWTException - 如果平台配置不允许使用低级输入控件。GraphicsEnvironment.isHeadless() 返回 true 时总是抛出此异常
SecurityException - 如果没有授予 createRobot 权限
另请参见：
GraphicsEnvironment.isHeadless(), SecurityManager.checkPermission(java.security.Permission), AWTPermission

Robot

public Robot(GraphicsDevice screen)
      throws AWTException
为给定屏幕设备创建一个 Robot 。传递给 Robot 方法调用（如 mouseMove 和 createScreenCapture）的坐标将在与指定屏幕相同的坐标系中解释。注意，根据平台配置，多个屏幕可以：
  • 共享相同坐标系，以形成一个合成虚拟屏幕
  • 使用不同坐标系作为单独的屏幕
此构造方法指后一种情况。

如果因配置屏幕设备而影响了坐标系，则现有 Robot 对象的行为是不确定的。

参数：
screen - 一个屏幕 GraphicsDevice，指示 Robot 将在该坐标系中进行操作。
抛出：
AWTException - 如果平台配置不允许使用低级输入控件。GraphicsEnvironment.isHeadless() 返回 true 时总是抛出此异常。
IllegalArgumentException - 如果 screen 不是一个屏幕 GraphicsDevice。
SecurityException - 如果没有授予 createRobot 权限
另请参见：
GraphicsEnvironment.isHeadless(), GraphicsDevice, SecurityManager.checkPermission(java.security.Permission), AWTPermission
方法详细信息

mouseMove

public void mouseMove(int x,
                      int y)
将鼠标指针移动到给定屏幕坐标。

参数：
x - X 坐标
y - Y 坐标

mousePress

public void mousePress(int buttons)
按下一个或多个鼠标按钮。应该使用 mouseRelease 方法释放鼠标按钮。

参数：
buttons - Button 掩码；一个或多个以下标志的组合：
  • InputEvent.BUTTON1_MASK
  • InputEvent.BUTTON2_MASK
  • InputEvent.BUTTON3_MASK
抛出：
IllegalArgumentException - 如果按钮掩码是无效组合
另请参见：
mouseRelease(int)

mouseRelease

public void mouseRelease(int buttons)
释放一个或多个鼠标按钮。

参数：
buttons - Button 掩码；一个或多个以下标志的组合：
  • InputEvent.BUTTON1_MASK
  • InputEvent.BUTTON2_MASK
  • InputEvent.BUTTON3_MASK
抛出：
IllegalArgumentException - 如果按钮掩码是无效组合
另请参见：
mousePress(int)

mouseWheel

public void mouseWheel(int wheelAmt)
在配有滚轮的鼠标上旋转滚轮。

参数：
wheelAmt - 移动鼠标滚轮的“刻痕 (notch)”数，负值表示向上/远离用户的运动，正值表示向下/接近用户的运动。
从以下版本开始：
1.4

keyPress

public void keyPress(int keycode)
按下给定的键。应该使用 keyRelease 方法释放该键。

拥有一个以上与之相关的物理键（例如，KeyEvent.VK_SHIFT 可能指左 shift 键或右 shift 键）的键代码可能映射到左键。

参数：
keycode - 要按下的键（例如，KeyEvent.VK_A）
抛出：
IllegalArgumentException - 如果 keycode 是一个无效的键
另请参见：
keyRelease(int), KeyEvent

keyRelease

public void keyRelease(int keycode)
释放给定的键。

拥有一个以上与之相关的物理键（例如，KeyEvent.VK_SHIFT 可能指左 shift 键或右 shift 键）的键代码可能映射到左键。

参数：
keycode - 要释放的键（例如，KeyEvent.VK_A）
抛出：
IllegalArgumentException - 如果 keycode 是一个无效的键
另请参见：
keyPress(int), KeyEvent

getPixelColor

public Color getPixelColor(int x,
                           int y)
返回给定屏幕坐标处的像素颜色。

参数：
x - 像素的 X 位置
y - 像素的 Y 位置
返回：
像素的颜色

createScreenCapture

public BufferedImage createScreenCapture(Rectangle screenRect)
创建包含从屏幕中读取的像素的图像。该图像不包括鼠标光标。

参数：
screenRect - 将在屏幕坐标中捕获的 Rect
返回：
捕获的图像
抛出：
IllegalArgumentException - 如果 screenRect 的宽度和高度不大于零
SecurityException - 如果没有授予 readDisplayPixels 权限
另请参见：
SecurityManager.checkPermission(java.security.Permission), AWTPermission

isAutoWaitForIdle

public boolean isAutoWaitForIdle()
返回此 Robot 在生成一个事件后是否自动调用 waitForIdle。

返回：
是否自动调用 waitForIdle

setAutoWaitForIdle

public void setAutoWaitForIdle(boolean isOn)
设置此 Robot 在生成一个事件后是否自动调用 waitForIdle。

参数：
isOn - 是否自动调用 waitForIdle

getAutoDelay

public int getAutoDelay()
返回此 Robot 在生成一个事件后睡眠的毫秒数。

setAutoDelay

public void setAutoDelay(int ms)
设置此 Robot 在生成一个事件后睡眠的毫秒数。

抛出：
IllegalArgumentException - 如果 ms 不在 0 到 60,000 毫秒的范围内

delay

public void delay(int ms)
睡眠指定的时间。为了捕获发生的所有 InterruptedException，可以使用 Thread.sleep() 替代。

参数：
ms - 睡眠的时间，以毫秒为单位
抛出：
IllegalArgumentException - 如果 ms 不在 0 到 60,000 毫秒的范围内
另请参见：
Thread.sleep(long)

waitForIdle

public void waitForIdle()
在处理完当前事件队列中的所有事件之前，一直等待。

抛出：
IllegalThreadStateException - 如果调用 AWT 事件指派线程

toString

public String toString()
返回此 Robot 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Scrollbar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Scrollbar

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Scrollbar
所有已实现的接口：
Adjustable, ImageObserver, MenuContainer, Serializable, Accessible
public class Scrollbar
extends Component
implements Adjustable, Accessible

Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。滚动条提供了一个允许用户在一定范围的值中进行选择的便捷方式。可以将以下三个垂直滚动条用作滑动块控件，以选择红、绿和蓝三种颜色的分量：

在此例中，每个滚动条都是使用类似于下面的代码创建的：

 redSlider=new Scrollbar(Scrollbar.VERTICAL, 0, 1, 0, 255);
 add(redSlider);

此外，滚动条还可以表示某一范围的值。例如，如果滚动条用于滚动文本，则可以使用“滑动块（bubble）”（也称为 "thumb" 或“滚动框”）的宽度来表示可视的文本数。下面是表示某一范围的滚动条：

图像显示了水平滑动块，其初始范围为 0，终止范围为 300。滑动块被标记为 60。

在这个例子中，滑动块表示的值范围是可见量。此例中的水平滚动条可以用以下代码来创建：

 ranger = new Scrollbar(Scrollbar.HORIZONTAL, 0, 60, 0, 300);
 add(ranger);

注意，滚动条的实际最大值是 maximum 减去 visible amount。在前面的例子中，因为 maximum 是 300，visible amount 是 60，所以实际最大值是 240。滚动条轨道的范围是 0 - 300。滑动块的左侧指示了滚动条的值。

通常，用户通过使用鼠标来改变滚动条的值。例如，用户可以上下拖动滚动条的滑动块，或单击滚动条的单位增量或块增量区域。键盘动作也能映射到滚动条。按照惯例，Page Up 和 Page Down 键等同于单击滚动条的块增量和块减量区域。

当用户改变滚动条的值时，滚动条接收一个 AdjustmentEvent 实例。滚动条处理此事件，将它传递给所有已注册的侦听器。

任何希望滚动条值发生变化时被通知的对象都应该实现包 java.awt.event 中定义的 AdjustmentListener 接口。调用 addAdjustmentListener 和 removeAdjustmentListener 方法能动态地添加或删除侦听器。

AdjustmentEvent 类定义了五种调整事件，如下所示：

  • 当用户拖动滚动条的滑动块时，发送 AdjustmentEvent.TRACK。
  • 当用户单击水平滚动条的左箭头或垂直滚动条的上箭头，或从键盘做出等效动作时，发送 AdjustmentEvent.UNIT_INCREMENT。
  • 当用户单击水平滚动条的右箭头或垂直滚动条的下箭头，或从键盘做出等效动作时，发送 AdjustmentEvent.UNIT_DECREMENT。
  • 当用户单击水平滚动条滑动块左边的轨道，或垂直滚动条滑动块上边的轨道时，发送 AdjustmentEvent.BLOCK_INCREMENT。按照惯例，如果用户使用定义了 Page Up 键的键盘，则 Page Up 键是等效的。
  • 当用户单击水平滚动条滑动块右边的轨道，或垂直滚动条滑动块下边的轨道时，发送 AdjustmentEvent.BLOCK_DECREMENT。按照惯例，如果用户使用定义了 Page Down 键的键盘，则 Page Down 键是等效的。

为了获得向后兼容，JDK 1.0 事件系统也受到支持，但是该平台的新版本不鼓励使用它。JDK 1.1 中介绍的五种调整事件与以前该平台版本中的有关滚动条的五种事件对应。下面列表给出了调整事件类型和它对应的 JDK 1.0 中的替换事件类型。

  • AdjustmentEvent.TRACK 替换 Event.SCROLL_ABSOLUTE
  • AdjustmentEvent.UNIT_INCREMENT 替换 Event.SCROLL_LINE_UP
  • AdjustmentEvent.UNIT_DECREMENT 替换 Event.SCROLL_LINE_DOWN
  • AdjustmentEvent.BLOCK_INCREMENT 替换 Event.SCROLL_PAGE_UP
  • AdjustmentEvent.BLOCK_DECREMENT 替换 Event.SCROLL_PAGE_DOWN

注：我们建议只对值的选择使用 Scrollbar。如果想在容器中实现一个可滚动的组件，那么建议您使用 ScrollPane。如果使用 Scrollbar 来实现这一目的，那么可能会遇到绘制、键处理、大小调整和定位问题。

从以下版本开始：
JDK1.0
另请参见：
AdjustmentEvent, AdjustmentListener, 序列化表格

嵌套类摘要
protected  class Scrollbar.AccessibleAWTScrollBar
此类实现 Scrollbar 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | HORIZONTAL 指示一个水平滚动条的常量。
static int | VERTICAL 指示一个垂直滚动条的常量。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.Adjustable 继承的字段
NO_ORIENTATION
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Scrollbar()
构造一个新的垂直滚动条。
Scrollbar(int orientation)
构造一个具有指定方向的新滚动条。
Scrollbar(int orientation, int value, int visible, int minimum, int maximum)
构造一个新的滚动条，它具有指定的方向、初始值、可见量、最小值和最大值。
方法摘要
 void addAdjustmentListener(AdjustmentListener l)
添加指定的调整侦听器，以接收发自此滚动条的 AdjustmentEvent 实例。
 void addNotify()
创建 Scrollbar 的同位体。
 AccessibleContext getAccessibleContext()
获取与此 Scrollbar 相关的 AccessibleContext。
 AdjustmentListener[] getAdjustmentListeners()
返回在此滚动条上所有已注册调整侦听器组成的数组。
 int getBlockIncrement()
获取此滚动条的块增量。
 int getLineIncrement()
已过时。 从 JDK version 1.1 开始，由 getUnitIncrement() 取代。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
 int getMaximum()
获取此滚动条的最大值。
 int getMinimum()
获取此滚动条的最小值。
 int getOrientation()
返回此滚动条的方向。
 int getPageIncrement()
已过时。 从 JDK version 1.1 开始，由 getBlockIncrement() 取代。
 int getUnitIncrement()
获取此滚动条的单位增量。
 int getValue()
获取此滚动条的当前值。
 boolean getValueIsAdjusting()
如果该值作为用户执行动作的结果正处于更改过程中，则返回 true。
 int getVisible()
已过时。 从 JDK version 1.1 开始，由 getVisibleAmount() 取代。
 int getVisibleAmount()
获取此滚动条的可见量。
protected  String paramString()
返回表示此 Scrollbar 当前状态的字符串表示形式。
protected  void processAdjustmentEvent(AdjustmentEvent e)
处理此滚动条上发生的调整事件，方法是将其指派到任意已注册的 AdjustmentListener 对象。
protected  void processEvent(AWTEvent e)
处理在滚动条上发生的事件。
 void removeAdjustmentListener(AdjustmentListener l)
移除指定的调整侦听器，不再接收发自此滚动条的 AdjustmentEvent 实例。
 void setBlockIncrement(int v)
设置此滚动条的块增量。
 void setLineIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setUnitIncrement(int) 取代。
 void setMaximum(int newMaximum)
设置此滚动条的最大值。
 void setMinimum(int newMinimum)
设置此滚动条的最小值。
 void setOrientation(int orientation)
设置此滚动条的方向。
 void setPageIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setBlockIncrement() 取代。
 void setUnitIncrement(int v)
设置此滚动条的单位增量。
 void setValue(int newValue)
将此滚动条的值设置为指定值。
 void setValueIsAdjusting(boolean b)
设置 valueIsAdjusting 属性。
 void setValues(int value, int visible, int minimum, int maximum)
设置此滚动条的四个属性值：value、visibleAmount、minimum 和 maximum。
 void setVisibleAmount(int newAmount)
设置此滚动条的可见量。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removeNotify, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

HORIZONTAL

public static final int HORIZONTAL
指示一个水平滚动条的常量。

另请参见：
常量字段值

VERTICAL

public static final int VERTICAL
指示一个垂直滚动条的常量。

另请参见：
常量字段值
构造方法详细信息

Scrollbar

public Scrollbar()
          throws HeadlessException
构造一个新的垂直滚动条。滚动条的默认属性列在下表中：

属性 | 描述 | 默认值
方向 指示滚动条是垂直的
或水平的 		Scrollbar.VERTICAL
值 控制滚动条的滑动块
位置的值 		0
可见量 滚动条范围的可见量，
通常由滚动条的滑动块
的大小表示 		10
最小值 | 滚动条的最小值 | 0
最大值 | 滚动条的最大值 | 100
单元增量 在按下 Line Up 或 Line Down 键时，
或者单击滚动条
的末端箭头时，
值更改的量 		1
块增量 在按下 Page Up 或 Page Down 键时，
或在滑动块的两侧
单击滚动条轨道时，
值更改的量 		10

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

Scrollbar

public Scrollbar(int orientation)
          throws HeadlessException
构造一个具有指定方向的新滚动条。

orientation 参数必须是 Scrollbar.HORIZONTAL 或 Scrollbar.VERTICAL 这两个值之一，它们分别指示滚动条是水平滚动条，还是垂直滚动条。

参数：
orientation - 指示滚动条的方向
抛出：
IllegalArgumentException - 在提供不合法的 orientation 参数值时
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

Scrollbar

public Scrollbar(int orientation,
                 int value,
                 int visible,
                 int minimum,
                 int maximum)
          throws HeadlessException
构造一个新的滚动条，它具有指定的方向、初始值、可见量、最小值和最大值。

orientation 参数必须是 Scrollbar.HORIZONTAL 或 Scrollbar.VERTICAL 这两个值之一，分别指示滚动条是水平滚动条，还是垂直滚动条。

为此构造方法提供的参数受到 setValues(int, int, int, int) 中描述的约束 (Constraints) 的限制。

参数：
orientation - 指示滚动条的方向。
value - 滚动条的初始值
visible - 滚动条的可见量，通常由滑动块的大小表示
minimum - 滚动条的最小值
maximum - 滚动条的最大值
抛出：
IllegalArgumentException - 当提供不合法的 orientation 参数值时
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
setValues(int, int, int, int), GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建 Scrollbar 的同位体。此同位体允许在不更改 Scrollbar 功能的情况下修改其外观。

覆盖：
类 Component 中的 addNotify
另请参见：
Component.isDisplayable(), Component.removeNotify()

getOrientation

public int getOrientation()
返回此滚动条的方向。

指定者：
接口 Adjustable 中的 getOrientation
返回：
此滚动条的方向，可以是 Scrollbar.HORIZONTAL 或 Scrollbar.VERTICAL
另请参见：
setOrientation(int)

setOrientation

public void setOrientation(int orientation)
设置此滚动条的方向。

参数：
orientation - 此滚动条的方向，可以是 Scrollbar.HORIZONTAL 或 Scrollbar.VERTICAL
抛出：
IllegalArgumentException - 如果为 orientation 提供的值是非法值
从以下版本开始：
JDK1.1
另请参见：
getOrientation()

getValue

public int getValue()
获取此滚动条的当前值。

指定者：
接口 Adjustable 中的 getValue
返回：
此滚动条的当前值
另请参见：
getMinimum(), getMaximum()

setValue

public void setValue(int newValue)
将此滚动条的值设置为指定值。

如果指定的值小于当前 minimum 或大于当前 maximum - visibleAmount，则对 minimum 或 maximum - visibleAmount 进行适当的替换。

通常，程序应该只通过调用 setValues 更改滚动条的值。setValues 方法同时且同步地设置滚动条的最小值、最大值、可见量和值属性，因此它们是一致的。

调用此方法不会触发 AdjustmentEvent。

指定者：
接口 Adjustable 中的 setValue
参数：
newValue - 滚动条的新值
另请参见：
setValues(int, int, int, int),
getValue(),
getMinimum(),
getMaximum()

getMinimum

public int getMinimum()
获取此滚动条的最小值。

指定者：
接口 Adjustable 中的 getMinimum
返回：
此滚动条的最小值
另请参见：
getValue(), getMaximum()

setMinimum

public void setMinimum(int newMinimum)
设置此滚动条的最小值。

在调用 setMinimum 时，最小值会发生更改，并且其他值（包括最大值、可视量和滚动条的当前值）都会随新的最小值发生一致的更改。

通常，程序应该只通过调用 setValues 更改滚动条的最小值。setValues 方法同时且同步地设置滚动条的最小值、最大值、可见量和值属性，因此它们是相互一致的。

注意，将最小值设置为 Integer.MAX_VALUE 将导致新的最小值被设置为 Integer.MAX_VALUE - 1。

指定者：
接口 Adjustable 中的 setMinimum
参数：
newMinimum - 此滚动条的新的最小值
从以下版本开始：
JDK1.1
另请参见：
setValues(int, int, int, int), setMaximum(int)

getMaximum

public int getMaximum()
获取此滚动条的最大值。

指定者：
接口 Adjustable 中的 getMaximum
返回：
此滚动条的最大值
另请参见：
getValue(), getMinimum()

setMaximum

public void setMaximum(int newMaximum)
设置此滚动条的最大值。

在调用 setMaximum 时，最大值会发生更改，并且其他值（包括最小值、可见量和滚动条的当前值）都会随新的最大值发生一致的更改。

通常，程序应该只通过调用 setValues 更改滚动条的最大值。setValues 方法同时且同步地设置滚动条的最小值、最大值、可见量和值属性，因此它们是相互一致的。

注意，将最大值设置为 Integer.MIN_VALUE 将导致新的最大值被设置为 Integer.MIN_VALUE + 1。

指定者：
接口 Adjustable 中的 setMaximum
参数：
newMaximum - 此滚动条的新的最大值
从以下版本开始：
JDK1.1
另请参见：
setValues(int, int, int, int), setMinimum(int)

getVisibleAmount

public int getVisibleAmount()
获取此滚动条的可见量。

当使用滚动条来选择某一范围的值时，可以使用可见量来表示当前可视值的范围。滚动条的滑动块（也称为 thumb 或滚动框）的大小通常给出了滚动条范围与可见量之间关系的直观表示。

在滚动条的滑动块不可移动时（例如，当它充斥滚动条轨道的整个长度时，或者当禁用滚动条时），它可能不被显示。是否显示滑动块不会影响 getVisibleAmount 返回的值。

指定者：
接口 Adjustable 中的 getVisibleAmount
返回：
此滚动条的可见量
从以下版本开始：
JDK1.1
另请参见：
setVisibleAmount(int)

getVisible

@Deprecated
public int getVisible()
已过时。 从 JDK version 1.1 开始，由 getVisibleAmount() 取代。

setVisibleAmount

public void setVisibleAmount(int newAmount)
设置此滚动条的可见量。

当使用滚动条来选择某一范围的值时，可以使用可见量来表示当前可视值的范围。滚动条的滑动块（也称为 thumb 或滚动框）的大小通常给出了滚动条范围与可见量之间关系的直观表示。

在滚动条的滑动块不可移动时（例如，当它充斥滚动条轨道的整个长度时，或者当禁用滚动条时），它可能不被显示。是否显示滑动块不会影响 getVisibleAmount 返回的值。

如果提供的可见量小于 one 或大于当前 maximum - minimum，则对 one 或 maximum - minimum 进行适当的替换。

通常，程序应该只通过调用 setValues 更改滚动条的值。setValues 方法同时且同步地设置滚动条的最小值、最大值、可见量和值属性，因此它们是一致的。

指定者：
接口 Adjustable 中的 setVisibleAmount
参数：
newAmount - 新的可见量
从以下版本开始：
JDK1.1
另请参见：
getVisibleAmount(), setValues(int, int, int, int)

setUnitIncrement

public void setUnitIncrement(int v)
设置此滚动条的单位增量。

单位增量是用户激活滚动条的单位增量区域时增加或减少的值，通常通过鼠标或键盘来实现，滚动条将该动作作为一个调整事件来接收。单位增量必须大于零。试图将单位增量设置为小于 1 的值将使该值被设置为 1。

指定者：
接口 Adjustable 中的 setUnitIncrement
参数：
v - 滚动条值增加或减少的量
从以下版本开始：
JDK1.1
另请参见：
getUnitIncrement()

setLineIncrement

@Deprecated
public void setLineIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setUnitIncrement(int) 取代。

getUnitIncrement

public int getUnitIncrement()
获取此滚动条的单位增量。

单位增量是用户激活滚动条的单位增量区域时增加或减少的值，通常通过鼠标或键盘来实现，滚动条将该动作作为一个调整事件来接收。单位增量必须大于零。

指定者：
接口 Adjustable 中的 getUnitIncrement
返回：
此滚动条的单位增量
从以下版本开始：
JDK1.1
另请参见：
setUnitIncrement(int)

getLineIncrement

@Deprecated
public int getLineIncrement()
已过时。 从 JDK version 1.1 开始，由 getUnitIncrement() 取代。

setBlockIncrement

public void setBlockIncrement(int v)
设置此滚动条的块增量。

块增量是用户激活滚动条的块增量区域时增加或减少的值，通常通过鼠标或键盘来实现，滚动条将该动作作为一个调整事件来接收。块增量必须大于零。试图将块增量设置为小于 1 的值将使该值被设置为 1。

指定者：
接口 Adjustable 中的 setBlockIncrement
参数：
v - 滚动条值增加或减少的量
从以下版本开始：
JDK1.1
另请参见：
getBlockIncrement()

setPageIncrement

@Deprecated
public void setPageIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setBlockIncrement() 取代。

getBlockIncrement

public int getBlockIncrement()
获取此滚动条的块增量。

块增量是用户激活滚动条的块增量区域时增加或减少的值，通常通过鼠标或键盘来实现，滚动条将该动作作为一个调整事件来接收。块增量必须大于零。

指定者：
接口 Adjustable 中的 getBlockIncrement
返回：
此滚动条的块增量
从以下版本开始：
JDK1.1
另请参见：
setBlockIncrement(int)

getPageIncrement

@Deprecated
public int getPageIncrement()
已过时。 从 JDK version 1.1 开始，由 getBlockIncrement() 取代。

setValues

public void setValues(int value,
                      int visible,
                      int minimum,
                      int maximum)
设置此滚动条的四个属性值：value、visibleAmount、minimum 和 maximum。如果为这些属性提供的值是不一致或不正确的，则将更改它们，确保它们一致。

此方法同时且同步地设置滚动条的四个属性值，以确保它们相互一致。它强制执行了以下约束：maximum 必须大于 minimum，maximum - minimum 不能大于 Integer.MAX_VALUE，visibleAmount 必须大于零。visibleAmount 不能大于 maximum - minimum，value 不能小于 minimum，并且 value 不能大于 maximum - visibleAmount

调用此方法不会触发 AdjustmentEvent。

参数：
value - 当前窗口的位置
visible - 滚动条的可见量
minimum - 滚动条的最小值
maximum - 滚动条的最大值
另请参见：
setMinimum(int), setMaximum(int), setVisibleAmount(int), setValue(int)

getValueIsAdjusting

public boolean getValueIsAdjusting()
如果该值作为用户执行动作的结果正处于更改过程中，则返回 true。

返回：
valueIsAdjusting 属性的值
从以下版本开始：
1.4
另请参见：
setValueIsAdjusting(boolean)

setValueIsAdjusting

public void setValueIsAdjusting(boolean b)
设置 valueIsAdjusting 属性。

参数：
b - 新的调整正处于进行 (adjustment-in-progress) 状态
从以下版本开始：
1.4
另请参见：
getValueIsAdjusting()

addAdjustmentListener

public void addAdjustmentListener(AdjustmentListener l)
添加指定的调整侦听器，以接收发自此滚动条的 AdjustmentEvent 实例。如果 l 为 null，则不会抛出异常并且不执行任何动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

指定者：
接口 Adjustable 中的 addAdjustmentListener
参数：
l - 调整侦听器
从以下版本开始：
JDK1.1
另请参见：
removeAdjustmentListener(java.awt.event.AdjustmentListener), getAdjustmentListeners(), AdjustmentEvent, AdjustmentListener

removeAdjustmentListener

public void removeAdjustmentListener(AdjustmentListener l)
移除指定的调整侦听器，不再接收发自此滚动条的 AdjustmentEvent 实例。如果 l 为 null，则不会抛出异常并且不执行任何动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

指定者：
接口 Adjustable 中的 removeAdjustmentListener
参数：
l - 调整侦听器
从以下版本开始：
JDK1.1
另请参见：
addAdjustmentListener(java.awt.event.AdjustmentListener), getAdjustmentListeners(), AdjustmentEvent, AdjustmentListener

getAdjustmentListeners

public AdjustmentListener[] getAdjustmentListeners()
返回在此滚动条上所有已注册调整侦听器组成的数组。

返回：
此滚动条的所有 AdjustmentListener，如果当前没有已注册的调整侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addAdjustmentListener(java.awt.event.AdjustmentListener), removeAdjustmentListener(java.awt.event.AdjustmentListener), AdjustmentEvent, AdjustmentListener

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用以下代码来查询 Scrollbar c 的鼠标侦听器：

MouseListener[] mls = (MouseListener[])(c.getListeners(MouseListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 Component 中的 getListeners
参数：
listenerType - 所请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
一个在此组件上作为 FooListener 注册的所有对象组成的数组，如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
Component.getComponentListeners(),
Component.getFocusListeners(),
Component.getHierarchyListeners(),
Component.getHierarchyBoundsListeners(),
Component.getKeyListeners(),
Component.getMouseListeners(),
Component.getMouseMotionListeners(),
Component.getMouseWheelListeners(),
Component.getInputMethodListeners(),
#getPropertyChangeListener

processEvent

protected void processEvent(AWTEvent e)
处理在滚动条上发生的事件。如果事件是一个 AdjustmentEvent 实例，则此方法将调用 processAdjustmentEvent 方法。否则，它将调用其超类的 processEvent 方法。

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

覆盖：
类 Component 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
AdjustmentEvent, processAdjustmentEvent(java.awt.event.AdjustmentEvent)

processAdjustmentEvent

protected void processAdjustmentEvent(AdjustmentEvent e)
处理此滚动条上发生的调整事件，方法是将其指派到任意已注册的 AdjustmentListener 对象。

如果没有在组件上启用调整事件，则不调用此方法。出现以下情况之一时启用调整事件：

  • 通过 addAdjustmentListener 注册 AdjustmentListener 对象。
  • 通过 enableEvents 启用调整事件。

注意，如果事件参数为 null，则行为是不确定的，并且可能导致异常。

参数：
e - 调整事件
从以下版本开始：
JDK1.1
另请参见：
AdjustmentEvent, AdjustmentListener, addAdjustmentListener(java.awt.event.AdjustmentListener), Component.enableEvents(long)

paramString

protected String paramString()
返回表示此 Scrollbar 当前状态的字符串表示形式。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Component 中的 paramString
返回：
此滚动条的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Scrollbar 相关的 AccessibleContext。对于滚动条，AccessibleContext 采用的是 AccessibleAWTScrollBar 的形式。如有必要，可以创建一个新的 AccessibleAWTScrollBar 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
充当此 ScrollBar 的 AccessibleContext 的 AccessibleAWTScrollBar
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Scrollbar.AccessibleAWTScrollBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Scrollbar.AccessibleAWTScrollBar

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Scrollbar.AccessibleAWTScrollBar
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleValue
正在封闭类：
Scrollbar
protected class Scrollbar.AccessibleAWTScrollBar
extends Component.AccessibleAWTComponent
implements AccessibleValue

此类实现 Scrollbar 类的可访问性支持。它提供适合于滚动条用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Scrollbar.AccessibleAWTScrollBar()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleValue | getAccessibleValue() 获得与此对象相关的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的可访问值。
Number | getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | getMinimumAccessibleValue() 获取此对象的最小可访问值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Scrollbar.AccessibleAWTScrollBar

protected Scrollbar.AccessibleAWTScrollBar()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleValue

public AccessibleValue getAccessibleValue()
获得与此对象相关的 AccessibleValue。在实现此对象的 Java Accessibility API 时，返回此对象，它负责代表它自己实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的可访问值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
此对象的当前值。
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果已设置该值，则返回 true。
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小可访问值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
此对象的最小值。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大可访问值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
此对象的最大值。
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 ScrollPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.ScrollPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class ScrollPane
extends Container
implements Accessible

实现用于单个子组件的自动水平和/或垂直滚动的容器类。滚动条的显示策略可以设置如下：

  1. as needed: 创建滚动条，且只在滚动窗格需要时显示
  2. always: 创建滚动条，且滚动窗格总是显示滚动条
  3. never: 滚动窗格永远不创建或显示滚动条

水平和垂直滚动条的状态由两个实现 Adjustable 接口的 ScrollPaneAdjustable 对象描述（每个对象对应各自的尺寸）。API 提供了访问这些对象的方法，以便能够对 Adjustable 对象的属性（如 unitIncrement 和 value 等）进行操作。

某些可调整属性（minimum、maximum、blockIncrement 和 visibleAmount）是由滚动窗格根据自身的几何形状及其子组件在内部进行设置的，不应由使用滚动窗格的程序设置。

如果滚动条显示策略被定义为 "never"，那么滚动窗格可以使用 setScrollPosition() 方法按程序滚动，并且滚动窗格将适当移动和裁剪子组件的内容。如果程序需要创建和管理自己的可调整控件，那么这个策略很有用。

滚动条的放置由程序之外的用户通过特定于平台的属性集控制。

此容器的初始大小被设置为 100x100，可以使用 setSize() 重新设置它。

默认情况下，使用配有滚轮的鼠标上的滚轮进行滚动。可以使用 setWheelScrollingEnabled 禁用此功能。通过设置水平和垂直 Adjustable 的块增量和单位增量，可以自定义滚轮滚动。有关如何指派鼠标滚轮事件的信息，请参阅 MouseWheelEvent 的类描述。

Insets 用于定义滚动条使用的所有空间和滚动窗格创建的所有边框，可以使用 getInsets() 获取当前 insets 的值。如果 scrollbarsAlwaysVisible 值为 false，则 insets 的值将根据滚动条当前是否可见而发生更改。

另请参见：
序列化表格

嵌套类摘要
protected  class ScrollPane.AccessibleAWTScrollPane
此类实现 ScrollPane 类的可访问性支持。
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | SCROLLBARS_ALWAYS 指定无论滚动窗格和子组件各自大小如何，总是显示水平/垂直滚动条。
static int | SCROLLBARS_AS_NEEDED 指定只在子组件的大小超过了滚动窗格水平/垂直尺寸时显示水平/垂直滚动条。
static int | SCROLLBARS_NEVER 指定无论滚动窗格和子组件各自大小如何，永不显示水平/垂直滚动条。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
ScrollPane()
创建一个具有滚动条策略 "as needed" 的新滚动窗格容器。
ScrollPane(int scrollbarDisplayPolicy)
创建新的滚动窗格容器。
方法摘要
protected  void addImpl(Component comp, Object constraints, int index)
将指定的组件添加到此滚动窗格容器。
 void addNotify()
创建滚动窗格的同位体。
 void doLayout()
通过将子组件的大小调整为其首选大小来布置此容器。
protected  boolean eventTypeEnabled(int type)
如果启用滚轮滚动，则对 MouseWheelEvents 返回 true
 AccessibleContext getAccessibleContext()
获取与此 ScrollPane 相关的 AccessibleContext。
 Adjustable getHAdjustable()
返回表示水平滚动条状态的 ScrollPaneAdjustable 对象。
 int getHScrollbarHeight()
返回水平滚动条占用的高度，它与当前是否由滚动窗格显示无关。
 int getScrollbarDisplayPolicy()
返回滚动条的显示策略。
 Point getScrollPosition()
返回子组件中的当前 x,y 位置，子组件显示在滚动窗格视口的 0,0 位置。
 Adjustable getVAdjustable()
返回表示垂直滚动条状态的 ScrollPaneAdjustable 对象。
 Dimension getViewportSize()
返回滚动条窗格视口的当前大小。
 int getVScrollbarWidth()
返回垂直滚动条占用的宽度，它与当前是否由滚动窗格显示无关。
 boolean isWheelScrollingEnabled()
指示是否进行滚动来响应鼠标滚轮。
 void layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
 String paramString()
返回表示此 ScrollPane 的状态的字符串。
 void printComponents(Graphics g)
显示此滚动窗格中的组件。
protected  void processMouseWheelEvent(MouseWheelEvent e)
处理通过滚动适当量而传递给此 ScrollPane 的鼠标滚轮事件。
 void setLayout(LayoutManager mgr)
设置此容器的布局管理器。
 void setScrollPosition(int x, int y)
滚动到子组件中的指定位置。
 void setScrollPosition(Point p)
滚动到子组件中的指定位置。
 void setWheelScrollingEnabled(boolean handleWheel)
启用/禁用对鼠标滚轮滚动的移动响应。
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SCROLLBARS_AS_NEEDED

public static final int SCROLLBARS_AS_NEEDED
指定只在子组件的大小超过了滚动窗格水平/垂直尺寸时显示水平/垂直滚动条。

另请参见：
常量字段值

SCROLLBARS_ALWAYS

public static final int SCROLLBARS_ALWAYS
指定无论滚动窗格和子组件各自大小如何，总是显示水平/垂直滚动条。

另请参见：
常量字段值

SCROLLBARS_NEVER

public static final int SCROLLBARS_NEVER
指定无论滚动窗格和子组件各自大小如何，永不显示水平/垂直滚动条。

另请参见：
常量字段值
构造方法详细信息

ScrollPane

public ScrollPane()
           throws HeadlessException
创建一个具有滚动条策略 "as needed" 的新滚动窗格容器。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

ScrollPane

public ScrollPane(int scrollbarDisplayPolicy)
           throws HeadlessException
创建新的滚动窗格容器。

参数：
scrollbarDisplayPolicy - 显示滚动条时使用的策略
抛出：
IllegalArgumentException - 如果指定的滚动条显示策略无效
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addImpl

protected final void addImpl(Component comp,
                             Object constraints,
                             int index)
将指定的组件添加到此滚动窗格容器。如果滚动窗格有一个现有子组件，则移除该组件，并添加新的组件。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要添加的组件
constraints - 不适用
index - 子组件的位置（必须 <= 0）
另请参见：
Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
LayoutManager,
LayoutManager2

getScrollbarDisplayPolicy

public int getScrollbarDisplayPolicy()
返回滚动条的显示策略。

返回：
滚动条的显示策略

getViewportSize

public Dimension getViewportSize()
返回滚动条窗格视口的当前大小。

返回：
滚动条视口的大小，以像素为单位

getHScrollbarHeight

public int getHScrollbarHeight()
返回水平滚动条占用的高度，它与当前是否由滚动窗格显示无关。

返回：
水平滚动条的高度，以像素为单位

getVScrollbarWidth

public int getVScrollbarWidth()
返回垂直滚动条占用的宽度，它与当前是否由滚动窗格显示无关。

返回：
垂直滚动条的宽度，以像素为单位

getVAdjustable

public Adjustable getVAdjustable()
返回表示垂直滚动条状态的 ScrollPaneAdjustable 对象。为了维护向后兼容性，所声明的此方法的返回类型是 Adjustable。

另请参见：
ScrollPaneAdjustable

getHAdjustable

public Adjustable getHAdjustable()
返回表示水平滚动条状态的 ScrollPaneAdjustable 对象。为了维护向后兼容性，所声明的此方法的返回类型是 Adjustable。

另请参见：
ScrollPaneAdjustable

setScrollPosition

public void setScrollPosition(int x,
                              int y)
滚动到子组件中的指定位置。只在滚动窗格包含一个子组件时，调用此方法才有效。指定一个子组件合法滚动边界之外的位置将会滚动到最近的合法位置。定义的合法边界是矩形：x = 0、y = 0、width =（子组件 width - 视口 width），height =（子组件 height - 视口 height）。这是与表示滚动条状态的 Adjustable 对象进行连接的一个便捷方法。

参数：
x - 要滚动到的 x 位置
y - 要滚动到的 y 位置
抛出：
NullPointerException - 如果滚动窗格未包含子组件

setScrollPosition

public void setScrollPosition(Point p)
滚动到子组件中的指定位置。只在滚动窗格包含一个子组件，且指定位置在子组件的合法滚动边界内时，调用此方法才有效。指定一个子组件合法滚动边界之外的位置将会滚动到最近的合法位置。定义的合法边界是矩形：x = 0、y = 0、width =（子组件 width - 视口 width），height =（子组件 height - 视口 height）。这是与表示滚动条状态的 Adjustable 对象进行连接的一个便捷方法。

参数：
p - 表示滚动到的位置的 Point

getScrollPosition

public Point getScrollPosition()
返回子组件中的当前 x,y 位置，子组件显示在滚动窗格视口的 0,0 位置。这是与表示滚动条状态的可调整对象进行连接的一个便捷方法。

返回：
当前滚动位置的坐标位置
抛出：
NullPointerException - 如果滚动窗格未包含子组件

setLayout

public final void setLayout(LayoutManager mgr)
设置此容器的布局管理器。重写此方法可以防止设置布局管理器。

覆盖：
类 Container 中的 setLayout
参数：
mgr - 指定的布局管理器
另请参见：
Container.doLayout(), Container.getLayout()

doLayout

public void doLayout()
通过将子组件的大小调整为其首选大小来布置此容器。如果子组件的新首选大小使当前滚动位置无效，则将滚动位置设置为最接近的有效位置。

覆盖：
类 Container 中的 doLayout
另请参见：
Component.validate()

layout

@Deprecated
public void layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。

覆盖：
类 Container 中的 layout

printComponents

public void printComponents(Graphics g)
显示此滚动窗格中的组件。

覆盖：
类 Container 中的 printComponents
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.print(java.awt.Graphics), Component.printAll(java.awt.Graphics)

addNotify

public void addNotify()
创建滚动窗格的同位体。

覆盖：
类 Container 中的 addNotify
另请参见：
Component.isDisplayable(), Container.removeNotify()

paramString

public String paramString()
返回表示此 ScrollPane 的状态的字符串。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Container 中的 paramString
返回：
此滚动窗格的参数字符串

processMouseWheelEvent

protected void processMouseWheelEvent(MouseWheelEvent e)
处理通过滚动适当量而传递给此 ScrollPane 的鼠标滚轮事件。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

覆盖：
类 Component 中的 processMouseWheelEvent
参数：
e - 鼠标滚轮事件
从以下版本开始：
1.4
另请参见：
MouseWheelEvent, MouseWheelListener, Component.addMouseWheelListener(java.awt.event.MouseWheelListener), Component.enableEvents(long)

eventTypeEnabled

protected boolean eventTypeEnabled(int type)
如果启用滚轮滚动，则对 MouseWheelEvents 返回 true

从以下版本开始：
1.4

setWheelScrollingEnabled

public void setWheelScrollingEnabled(boolean handleWheel)
启用/禁用对鼠标滚轮滚动的移动响应。默认情况下启用滚轮滚动。

参数：
handleWheel - 如果为 MouseWheelEvent 自动完成滚动，则返回 true；否则返回 false。
从以下版本开始：
1.4
另请参见：
isWheelScrollingEnabled(), MouseWheelEvent, MouseWheelListener

isWheelScrollingEnabled

public boolean isWheelScrollingEnabled()
指示是否进行滚动来响应鼠标滚轮。默认情况下启用滚轮滚动。

从以下版本开始：
1.4
另请参见：
setWheelScrollingEnabled(boolean)

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 ScrollPane 相关的 AccessibleContext。对于滚动窗格，AccessibleContext 采用的是 AccessibleAWTScrollPane 的形式。如有必要，将创建一个新的 AccessibleAWTScrollPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
充当此 ScrollPane 的 AccessibleContext 的 AccessibleAWTScrollPane
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollPaneAdjustable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 ScrollPaneAdjustable

java.lang.Object
    继承者  java.awt.ScrollPaneAdjustable
所有已实现的接口：
Adjustable, Serializable
public class ScrollPaneAdjustable
extends Object
implements Adjustable, Serializable

此类表示 ScrollPane 的水平或垂直滚动条的状态。ScrollPane 方法返回此类的对象。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
从接口 java.awt.Adjustable 继承的字段
HORIZONTAL, NO_ORIENTATION, VERTICAL
方法摘要
void | addAdjustmentListener(AdjustmentListener l) 添加指定的调整侦听器，以接收发自此 ScrollPaneAdjustable 的调整事件。
AdjustmentListener[] | getAdjustmentListeners() 返回在此 ScrollPaneAdjustable 上所有已注册调整侦听器组成的数组。
int | getBlockIncrement() 获取可调整对象的块值增量。
int | getMaximum() 获取可调整对象的最大值。
int | getMinimum() 获取可调整对象的最小值。
int | getOrientation() 返回此滚动条的方向。
int | getUnitIncrement() 获取可调整对象的单位值增量。
int | getValue() 获取可调整对象的当前值。
boolean | getValueIsAdjusting() 当作为用户所采用操作的结果的值正处于更改过程中时，返回 true。
int | getVisibleAmount() 获取比例指示器的长度。
String | paramString() 返回表示此滚动条的状态的字符串。
void | removeAdjustmentListener(AdjustmentListener l) 移除指定的调整侦听器，不再接收发自此 ScrollPaneAdjustable 的调整事件。
void | setBlockIncrement(int b) 设置可调整对象的块值增量。
void | setMaximum(int max) 此方法不应由用户代码调用。
void | setMinimum(int min) 此方法不应由用户代码调用。
void | setUnitIncrement(int u) 设置可调整对象的单位值增量。
void | setValue(int v) 将此滚动条的值设置为指定值。
void | setValueIsAdjusting(boolean b) 设置 valueIsAdjusting 属性。
void | setVisibleAmount(int v) 此方法不应由用户代码调用。
String | toString() 返回此滚动条及其值的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getOrientation

public int getOrientation()
返回此滚动条的方向。

指定者：
接口 Adjustable 中的 getOrientation
返回：
此滚动条的方向，可以是 Adjustable.HORIZONTAL 或 Adjustable.VERTICAL

setMinimum

public void setMinimum(int min)
此方法不应由用户代码调用。此方法对于正确实现 Adjustable 接口的类是公用的。

指定者：
接口 Adjustable 中的 setMinimum
参数：
min - 最小值
抛出：
AWTError - 调用时总是抛出一个错误。

getMinimum

public int getMinimum()
从接口 Adjustable 复制的描述
获取可调整对象的最小值。

指定者：
接口 Adjustable 中的 getMinimum
返回：
可调整对象的最小值

setMaximum

public void setMaximum(int max)
此方法不应由用户代码调用。此方法对于正确实现 Adjustable 接口的类是公用的。

指定者：
接口 Adjustable 中的 setMaximum
参数：
max - 最大值
抛出：
AWTError - 调用时总是抛出一个错误。

getMaximum

public int getMaximum()
从接口 Adjustable 复制的描述
获取可调整对象的最大值。

指定者：
接口 Adjustable 中的 getMaximum
返回：
可调整对象的最大值

setUnitIncrement

public void setUnitIncrement(int u)
从接口 Adjustable 复制的描述
设置可调整对象的单位值增量。

指定者：
接口 Adjustable 中的 setUnitIncrement
参数：
u - 单位增量

getUnitIncrement

public int getUnitIncrement()
从接口 Adjustable 复制的描述
获取可调整对象的单位值增量。

指定者：
接口 Adjustable 中的 getUnitIncrement
返回：
可调整对象的单位值增量

setBlockIncrement

public void setBlockIncrement(int b)
从接口 Adjustable 复制的描述
设置可调整对象的块值增量。

指定者：
接口 Adjustable 中的 setBlockIncrement
参数：
b - 块值增量

getBlockIncrement

public int getBlockIncrement()
从接口 Adjustable 复制的描述
获取可调整对象的块值增量。

指定者：
接口 Adjustable 中的 getBlockIncrement
返回：
可调整对象的块值增量

setVisibleAmount

public void setVisibleAmount(int v)
此方法不应由用户代码调用。此方法对于正确实现 Adjustable 接口的类是公用的。

指定者：
接口 Adjustable 中的 setVisibleAmount
参数：
v - 指示器的长度
抛出：
AWTError - 调用时总是抛出一个错误。

getVisibleAmount

public int getVisibleAmount()
从接口 Adjustable 复制的描述
获取比例指示器的长度。

指定者：
接口 Adjustable 中的 getVisibleAmount
返回：
比例指示器的长度

setValueIsAdjusting

public void setValueIsAdjusting(boolean b)
设置 valueIsAdjusting 属性。

参数：
b - 新的调整正处于进行状态
从以下版本开始：
1.4
另请参见：
getValueIsAdjusting()

getValueIsAdjusting

public boolean getValueIsAdjusting()
当作为用户所采用操作的结果的值正处于更改过程中时，返回 true。

返回：
valueIsAdjusting 属性的值
另请参见：
setValueIsAdjusting(boolean)

setValue

public void setValue(int v)
将此滚动条的值设置为指定值。

如果提供的值小于当前最小值或大于当前最大值，则适当地替换其中的一个值。

指定者：
接口 Adjustable 中的 setValue
参数：
v - 滚动条的新值

getValue

public int getValue()
从接口 Adjustable 复制的描述
获取可调整对象的当前值。

指定者：
接口 Adjustable 中的 getValue
返回：
可调整对象的当前值

addAdjustmentListener

public void addAdjustmentListener(AdjustmentListener l)
添加指定的调整侦听器，以接收发自此 ScrollPaneAdjustable 的调整事件。如果 l 为 null，则不抛出异常，也不执行任何动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

指定者：
接口 Adjustable 中的 addAdjustmentListener
参数：
l - 调整侦听器。
另请参见：
removeAdjustmentListener(java.awt.event.AdjustmentListener), getAdjustmentListeners(), AdjustmentListener, AdjustmentEvent

removeAdjustmentListener

public void removeAdjustmentListener(AdjustmentListener l)
移除指定的调整侦听器，不再接收发自此 ScrollPaneAdjustable 的调整事件。如果 l 为 null，则不抛出异常，也不执行动作。

有关 AWT 的线程模型的详细信息，请参阅 AWT 线程问题。

指定者：
接口 Adjustable 中的 removeAdjustmentListener
参数：
l - 调整侦听器。
从以下版本开始：
JDK1.1
另请参见：
addAdjustmentListener(java.awt.event.AdjustmentListener), getAdjustmentListeners(), AdjustmentListener, AdjustmentEvent

getAdjustmentListeners

public AdjustmentListener[] getAdjustmentListeners()
返回在此 ScrollPaneAdjustable 上所有已注册调整侦听器组成的数组。

返回：
此 ScrollPaneAdjustable 的所有 AdjustmentListener，如果当前没有已注册的调整侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addAdjustmentListener(java.awt.event.AdjustmentListener), removeAdjustmentListener(java.awt.event.AdjustmentListener), AdjustmentListener, AdjustmentEvent

toString

public String toString()
返回此滚动条及其值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此滚动条的字符串表示形式。

paramString

public String paramString()
返回表示此滚动条的状态的字符串。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

返回：
此滚动条的参数字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollPane.AccessibleAWTScrollPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 ScrollPane.AccessibleAWTScrollPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.ScrollPane.AccessibleAWTScrollPane
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
ScrollPane
protected class ScrollPane.AccessibleAWTScrollPane
extends Container.AccessibleAWTContainer

此类实现 ScrollPane 类的可访问性支持。它提供适合于滚动窗格用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected ScrollPane.AccessibleAWTScrollPane()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScrollPane.AccessibleAWTScrollPane

protected ScrollPane.AccessibleAWTScrollPane()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Shape (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 Shape

所有已知实现类：
Arc2D, Arc2D.Double, Arc2D.Float, Area, BasicTextUI.BasicCaret, CubicCurve2D, CubicCurve2D.Double, CubicCurve2D.Float, DefaultCaret, Ellipse2D, Ellipse2D.Double, Ellipse2D.Float, GeneralPath, Line2D, Line2D.Double, Line2D.Float, Path2D, Path2D.Double, Path2D.Float, Polygon, QuadCurve2D, QuadCurve2D.Double, QuadCurve2D.Float, Rectangle, Rectangle2D, Rectangle2D.Double, Rectangle2D.Float, RectangularShape, RoundRectangle2D, RoundRectangle2D.Double, RoundRectangle2D.Float
public interface Shape

Shape 接口提供了表示一些几何形状的对象的定义。Shape 是由 PathIterator 对象描述的，它可以表示 Shape 的轮廓以及确定该轮廓如何将 2D 平面划分成内点和外点的规则。每个 Shape 对象都提供回调，以获取几何形状的边框，确定点或矩形是部分还是全部位于 Shape 内部，并检索一个描述 Shape 轮廓的轨迹路径的 PathIterator 对象。

内部定义：当且仅当以下条件成立时，才认为某个点位于 Shape 内：

  • 该点完全位于 Shape 边界内，或者
  • 该点恰好位于 Shape 边界上，并且 X 轴正方向上紧邻该点的空间完全处于边界之内，或者
  • 该点恰好在水平边界分段上，并且 Y 轴正方向上紧邻该点的空间完全处于边界之内。

contains 和 intersects 方法将 Shape 内部视为可以填充的封闭区域。这意味着为了确定某个 shape 是否包含矩形或与矩形相交，或者确定某个 shape 是否包含一个点，这些方法将隐式地认为未闭合的 shape 是闭合的。

从以下版本开始：
1.2
另请参见：
PathIterator, AffineTransform, FlatteningPathIterator, GeneralPath

方法摘要
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
boolean | contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
Rectangle | getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
PathIterator | getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
boolean | intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。

方法详细信息

getBounds

Rectangle getBounds()
返回一个完全包围 Shape 的整型 Rectangle。注意，不保证返回的 Rectangle 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle 中。如果 Shape 超出了整数数据类型的有效范围，则返回的 Rectangle 也可能不完全包围 Shape。getBounds2D 方法由于在表示形式上具有更大的灵活性，所以通常返回更紧密的边界框。

返回：
完全包围 Shape 的整型 Rectangle。
从以下版本开始：
1.2
另请参见：
getBounds2D()

getBounds2D

Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
getBounds()

contains

boolean contains(double x,
                 double y)
测试指定坐标是否在 Shape 的边界内。

参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

contains

boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。

参数：
p - 要测试的指定的 Point2D
返回：
如果指定的 Point2D 在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

boolean intersects(double x,
                   double y,
                   double w,
                   double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

intersects

boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
intersects(double, double, double, double)

contains

boolean contains(double x,
                 double y,
                 double w,
                 double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, intersects(double, double, double, double)

contains

boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：
  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含 Rectangle2D 的代价太高。
这意味着对于某些 Shape，即使 Shape 包含 Rectangle2D，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部完全包含 Rectangle2D，则返回 true；否则，如果 Shape 包含 Rectangle2D、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
contains(double, double, double, double)

getPathIterator

PathIterator getPathIterator(AffineTransform at)
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。如果指定一个可选 AffineTransform，则相应地转换迭代中返回的坐标。

每次调用此方法都会返回一个最新的、遍历 Shape 对象几何形状的 PathIterator 对象，该对象独立于其他所有同时使用的 PathIterator 对象。

建议但不保证实现 Shape 接口的对象将进行中的迭代与该迭代期间可能对原始对象几何形状所做的任何更改隔离开来。

参数：
at - 一个可选的 AffineTransform，用于在迭代中返回的坐标，如果需要未转换的坐标，则返回 null
返回：
一个新的、独立地遍历 Shape 的几何形状的 PathIterator 对象。
从以下版本开始：
1.2

getPathIterator

PathIterator getPathIterator(AffineTransform at,
                             double flatness)
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。

迭代器只返回 SEG_MOVETO、SEG_LINETO 和 SEG_CLOSE 点类型。

如果指定一个可选 AffineTransform，则相应地转换迭代中返回的坐标。

flatness 参数控制曲线段分段的数量，指定转换的不平曲线上任一点能够偏离返回的变平路径段的最大距离。注意，变平路径的精度限制可能稍微受到影响，使非常小的变平参数作为较大的值来处理。如果有这样的限制，那么该限制是由使用的特定实现定义的。

每次调用此方法都会返回一个最新的、遍历 Shape 对象几何形状的 PathIterator 对象，该对象独立于其他所有同时使用的 PathIterator 对象。

建议但不保证实现 Shape 接口的对象将进行中的迭代与该迭代期间可能对原始对象几何形状所做的任何更改隔离开来。

参数：
at - 一个可选 AffineTransform，用于在迭代中返回的坐标，如果需要未转换的坐标，则返回 null
flatness - 用来近似曲线段的直线段偏离原始曲线上任一点的最大距离
返回：
一个新的、独立地遍历 Shape 几何形状的平面视图的 PathIterator。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SplashScreen (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 SplashScreen

java.lang.Object
    继承者  java.awt.SplashScreen

public final class SplashScreen
extends Object

在 Java 虚拟机 (JVM) 启动之前，可以在应用程序启动时创建闪现屏幕。闪现屏幕显示为一个包含图像的未装饰窗口。可以使用 GIF、JPEG 和 PNG 文件作为图像。支持动画（用于 GIF）和透明度（用于 GIF、PNG 文件）。窗口位于屏幕的中心（在多监视器系统中的位置没有指定——它与平台和实现有关）。一旦 Swing/AWT 显示第一个窗口，此窗口就会自动关闭（也可以使用 Java API 手动关闭窗口，参见以下内容）。

显示本机闪现屏幕有两种方式：

  • 如果是用命令行或快捷方式运行应用程序，则使用 "-splash:"Java 应用程序启动器选项来显示闪现屏幕。
    例如：
    java -splash:filename.gif Test
  • 如果应用程序被打包在 jar 文件中，可以使用清单文件中的 "SplashScreen-Image" 选项来显示闪现屏幕。将图像放在 jar 归档文件中并用选项指定路径。路径不应以斜杠开头。
    例如，在 manifest.mf 文件中：
    Manifest-Version: 1.0
Main-Class:Test
SplashScreen-Image:filename.gif
    命令行接口的优先级高于清单设置。

SplashScreen 类提供用于控制闪现屏幕的 API。此类可用于关闭闪现屏幕、更改闪现屏幕图像、获取图像位置/大小以及在闪现屏幕中进行绘制。它不能用于创建闪现屏幕；应当使用命令行或清单文件选项来实现该操作。

此类无法被实例化。只能存在一个此类的实例，可以使用 getSplashScreen() 静态方法获得该实例。如果闪现屏幕不是通过命令行或清单文件选项在应用程序启动时创建的，那么 getSplashScreen 方法将返回 null。

从以下版本开始：
1.6

方法摘要
void | close() 隐藏闪现屏幕、关闭窗口并释放所有相关资源。
Graphics2D | createGraphics() 创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。
Rectangle | getBounds() 以 Rectangle 形式返回闪现屏幕窗口的边界。
URL | getImageURL() 返回当前闪现屏幕图像。
Dimension | getSize() 以 Dimension 形式返回闪现屏幕窗口的大小。
static SplashScreen | getSplashScreen() 返回用于 Java 启动闪现屏幕控制的 SplashScreen 对象。
boolean | isVisible() 确定闪现屏幕是否可见。
void | setImageURL(URL imageURL) 更改闪现屏幕图像。
void | update() 用当前叠加图像的上下文来更新闪现屏幕窗口。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getSplashScreen

public static SplashScreen getSplashScreen()
返回用于 Java 启动闪现屏幕控制的 SplashScreen 对象。

返回：
SplashScreen 实例；如果没有该实例或者已经关闭它，则返回 null。
抛出：
UnsupportedOperationException - 如果当前工具包不支持闪现屏幕功能
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true

setImageURL

public void setImageURL(URL imageURL)
                 throws NullPointerException,
                        IOException,
                        IllegalStateException
更改闪现屏幕图像。从指定的 URL 加载新图像；支持 GIF、JPEG 和 PNG 图像格式。此方法在图像完成加载且窗口更新之后返回。闪现屏幕窗口根据图像的大小进行调整且在屏幕上居中。

参数：
imageURL - 新闪现屏幕图像的非 null URL
抛出：
NullPointerException - 如果 imageURL 为 null
IOException - 如果加载图像时出现错误
IllegalStateException - 如果闪现屏幕已经关闭

getImageURL

public URL getImageURL()
                throws IllegalStateException
返回当前闪现屏幕图像。

返回：
当前闪现屏幕图像文件的 URL
抛出：
IllegalStateException - 如果闪现屏幕已经关闭

getBounds

public Rectangle getBounds()
                    throws IllegalStateException
以 Rectangle 形式返回闪现屏幕窗口的边界。例如，如果想在同一位置用窗口替换闪现屏幕，此方法将很有用。

无法控制闪现屏幕的大小或位置。图像更改时闪现屏幕的大小将自动调整。

返回：
包含闪现屏幕边界的 Rectangle
抛出：
IllegalStateException - 如果闪现屏幕已经关闭

getSize

public Dimension getSize()
                  throws IllegalStateException
以 Dimension 形式返回闪现屏幕窗口的大小。例如，如果想在闪现屏幕叠加表面上进行绘制，这将很有用。

无法控制闪现屏幕的大小或位置。图像更改时闪现屏幕的大小将自动调整。

返回：
Dimension 对象，用于指示闪现屏幕的大小
抛出：
IllegalStateException - 如果闪现屏幕已经关闭

createGraphics

public Graphics2D createGraphics()
                          throws IllegalStateException
创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。注意，不是在主图像上绘制，而是在使用 alpha 混合的主图像上显示的图像中进行绘制。 还要注意的是，在叠加图像上绘制不必更新闪现屏幕窗口的内容。当希望闪现屏幕立即获得更新时，应当在 SplashScreen 上调用 update()。

返回：
闪现屏幕叠加表面的图形上下文
抛出：
IllegalStateException - 如果闪现屏幕已经关闭

update

public void update()
            throws IllegalStateException
用当前叠加图像的上下文来更新闪现屏幕窗口。

抛出：
IllegalStateException - 如果叠加图像不存在；例如，如果从未调用 createGraphics，或闪现屏幕已经关闭

close

public void close()
           throws IllegalStateException
隐藏闪现屏幕、关闭窗口并释放所有相关资源。

抛出：
IllegalStateException - 如果闪现屏幕已经关闭

isVisible

public boolean isVisible()
确定闪现屏幕是否可见。可以使用 close() 隐藏闪现屏幕，当第一个 AWT/Swing 窗口变得可见时，闪现屏幕也将自动隐藏。

返回：
如果闪现屏幕可见（尚未关闭），则返回 true，否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Stroke (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 Stroke

所有已知实现类：
BasicStroke
public interface Stroke

Stroke 接口允许 Graphics2D 对象获得一个 Shape，该 Shape 是指定 Shape 的装饰轮廓，或该轮廓的风格表示形式。描绘一个 Shape 如同使用一支具有适当大小和形状的画笔描绘其轮廓。画笔着墨的区域是轮廓 Shape 封闭的区域。

Graphics2D 接口中使用由 Stroke 对象返回的轮廓 Shape 的方法包括：draw 和其他所有根据此方法实现的方法，比如 drawLine、drawRect、drawRoundRect、drawOval、drawArc、drawPolyline 和 drawPolygon。

实现 Stroke 的类的对象必须是只读的，因为在使用 setStroke 方法将这些对象设置为一个属性时，或者在 Graphics2D 对象没有复制自身时，Graphics2D 不会复制这些对象。如果在 Graphics2D 上下文中设置了一个 Stroke 对象后修改它，则后续呈现行为将是不确定的。

另请参见：
BasicStroke, Graphics2D.setStroke(java.awt.Stroke)

方法摘要
 Shape createStrokedShape(Shape p)
返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。

方法详细信息

createStrokedShape

Shape createStrokedShape(Shape p)
返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。

参数：
p - 要描绘的 Shape
返回：
描绘的轮廓 Shape。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemColor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 SystemColor

java.lang.Object
    继承者  java.awt.Color
        继承者  java.awt.SystemColor
所有已实现的接口：
Paint, Transparency, Serializable
public final class SystemColor
extends Color
implements Serializable

封装表示系统中本机 GUI 对象颜色的象征性颜色的类。对于支持系统颜色动态更新的系统而言（当用户更改颜色时），这些象征性颜色的实际 RGB 值也将发生动态更改。要比较 SystemColor 对象的“当前”RGB 值与非象征性 Color 对象，应该使用 getRGB，而不是 equals。

注意，因为 GUI 对象在每个平台上的呈现可能各不相同，所以从一个平台到另一个平台，这些系统颜色应用于 GUI 对象的方式可能也会稍有不同。

通过 java.awt.Toolkit 上的 getDesktopProperty 方法也可以使用系统颜色值。

另请参见：
Toolkit.getDesktopProperty(java.lang.String), 序列化表格

字段摘要
static int | ACTIVE_CAPTION activeCaption 系统颜色的数组索引。
static int | ACTIVE_CAPTION_BORDER activeCaptionBorder 系统颜色的数组索引。
static int | ACTIVE_CAPTION_TEXT activeCaptionText 系统颜色的数组索引。
static SystemColor | activeCaption 为当前活动窗口的窗口标题提供的背景色。
static SystemColor | activeCaptionBorder 为当前活动窗口的边框提供的颜色。
static SystemColor | activeCaptionText 为当前活动窗口的窗口标题文本提供的颜色。
static SystemColor | control 为控制面板和控制对象（比如按钮）提供的颜色。
static int | CONTROL control 系统颜色的数组索引。
static int | CONTROL_DK_SHADOW controlDkShadow 系统颜色的数组索引。
static int | CONTROL_HIGHLIGHT controlHighlight 系统颜色的数组索引。
static int | CONTROL_LT_HIGHLIGHT controlLtHighlight 系统颜色的数组索引。
static int | CONTROL_SHADOW controlShadow 系统颜色的数组索引。
static int | CONTROL_TEXT controlText 系统颜色的数组索引。
static SystemColor | controlDkShadow 为 3D 控制对象（比如按钮）的加黑阴影区域提供的颜色。
static SystemColor | controlHighlight 为 3D 控制对象（比如按钮）的亮区提供的颜色。
static SystemColor | controlLtHighlight 为 3D 控制对象（比如按钮）的高亮区域提供的颜色。
static SystemColor | controlShadow 为 3D 控制对象（比如按钮）的阴影区域提供的颜色。
static SystemColor | controlText 为控制面板和控制对象（比如按钮）的文本提供的颜色。
static SystemColor | desktop 为桌面背景提供的颜色。
static int | DESKTOP desktop 系统颜色的数组索引。
static int | INACTIVE_CAPTION inactiveCaption 系统颜色的数组索引。
static int | INACTIVE_CAPTION_BORDER inactiveCaptionBorder 系统颜色的数组索引。
static int | INACTIVE_CAPTION_TEXT inactiveCaptionText 系统颜色的数组索引。
static SystemColor | inactiveCaption 为非活动窗口的窗口标题提供的背景色。
static SystemColor | inactiveCaptionBorder 为非活动窗口的边框提供的颜色。
static SystemColor | inactiveCaptionText 为非活动窗口的窗口标题文本提供的颜色。
static SystemColor | info 为工具栏提示或定点帮助提供的背景色。
static int | INFO info 系统颜色的数组索引。
static int | INFO_TEXT infoText 系统颜色的数组索引。
static SystemColor | infoText 为工具栏提示或定点帮助的文本提供的颜色。
static SystemColor | menu 为菜单提供的背景色。
static int | MENU menu 系统颜色的数组索引。
static int | MENU_TEXT menuText 系统颜色的数组索引。
static SystemColor | menuText 为菜单文本提供的颜色。
static int | NUM_COLORS 数组中系统颜色的数量。
static SystemColor | scrollbar 为滚动条提供的背景色。
static int | SCROLLBAR scrollbar 系统颜色的数组索引。
static SystemColor | text 为文本控制对象（比如文本字段和组合框）提供的背景色。
static int | TEXT text 系统颜色的数组索引。
static int | TEXT_HIGHLIGHT textHighlight 系统颜色的数组索引。
static int | TEXT_HIGHLIGHT_TEXT textHighlightText 系统颜色的数组索引。
static int | TEXT_INACTIVE_TEXT textInactiveText 系统颜色的数组索引。
static int | TEXT_TEXT textText 系统颜色的数组索引。
static SystemColor | textHighlight 为选则项（比如菜单、组合框和文本）提供的背景色。
static SystemColor | textHighlightText 为选则项（比如菜单、组合框和文本）的文本提供的颜色。
static SystemColor | textInactiveText 为非活动项（比如菜单中的项）的文本提供的颜色。
static SystemColor | textText 为文本控制对象（比如文本字段和组合框）的文本提供的颜色。
static SystemColor | window 为窗口的内部区域提供的背景色。
static int | WINDOW window 系统颜色的数组索引。
static int | WINDOW_BORDER windowBorder 系统颜色的数组索引。
static int | WINDOW_TEXT windowText 系统颜色的数组索引。
static SystemColor | windowBorder 为窗口内部区域的边框提供的颜色。
static SystemColor | windowText 为窗口内部区域的文本提供的颜色。
从类 java.awt.Color 继承的字段
black, BLACK, blue, BLUE, cyan, CYAN, DARK_GRAY, darkGray, gray, GRAY, green, GREEN, LIGHT_GRAY, lightGray, magenta, MAGENTA, orange, ORANGE, pink, PINK, red, RED, white, WHITE, yellow, YELLOW
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
方法摘要
PaintContext | createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
int | getRGB() 获取表示象征性颜色的“当前”RGB 值。
String | toString() 返回此 Color 值的字符串表示形式。
从类 java.awt.Color 继承的方法
brighter, darker, decode, equals, getAlpha, getBlue, getColor, getColor, getColor, getColorComponents, getColorComponents, getColorSpace, getComponents, getComponents, getGreen, getHSBColor, getRed, getRGBColorComponents, getRGBComponents, getTransparency, hashCode, HSBtoRGB, RGBtoHSB
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

DESKTOP

public static final int DESKTOP
desktop 系统颜色的数组索引。

另请参见：
desktop, 常量字段值

ACTIVE_CAPTION

public static final int ACTIVE_CAPTION
activeCaption 系统颜色的数组索引。

另请参见：
activeCaption, 常量字段值

ACTIVE_CAPTION_TEXT

public static final int ACTIVE_CAPTION_TEXT
activeCaptionText 系统颜色的数组索引。

另请参见：
activeCaptionText, 常量字段值

ACTIVE_CAPTION_BORDER

public static final int ACTIVE_CAPTION_BORDER
activeCaptionBorder 系统颜色的数组索引。

另请参见：
activeCaptionBorder, 常量字段值

INACTIVE_CAPTION

public static final int INACTIVE_CAPTION
inactiveCaption 系统颜色的数组索引。

另请参见：
inactiveCaption, 常量字段值

INACTIVE_CAPTION_TEXT

public static final int INACTIVE_CAPTION_TEXT
inactiveCaptionText 系统颜色的数组索引。

另请参见：
inactiveCaptionText, 常量字段值

INACTIVE_CAPTION_BORDER

public static final int INACTIVE_CAPTION_BORDER
inactiveCaptionBorder 系统颜色的数组索引。

另请参见：
inactiveCaptionBorder, 常量字段值

WINDOW

public static final int WINDOW
window 系统颜色的数组索引。

另请参见：
window, 常量字段值

WINDOW_BORDER

public static final int WINDOW_BORDER
windowBorder 系统颜色的数组索引。

另请参见：
windowBorder, 常量字段值

WINDOW_TEXT

public static final int WINDOW_TEXT
windowText 系统颜色的数组索引。

另请参见：
windowText, 常量字段值

MENU

public static final int MENU
menu 系统颜色的数组索引。

另请参见：
menu, 常量字段值

MENU_TEXT

public static final int MENU_TEXT
menuText 系统颜色的数组索引。

另请参见：
menuText, 常量字段值

TEXT

public static final int TEXT
text 系统颜色的数组索引。

另请参见：
text, 常量字段值

TEXT_TEXT

public static final int TEXT_TEXT
textText 系统颜色的数组索引。

另请参见：
textText, 常量字段值

TEXT_HIGHLIGHT

public static final int TEXT_HIGHLIGHT
textHighlight 系统颜色的数组索引。

另请参见：
textHighlight, 常量字段值

TEXT_HIGHLIGHT_TEXT

public static final int TEXT_HIGHLIGHT_TEXT
textHighlightText 系统颜色的数组索引。

另请参见：
textHighlightText, 常量字段值

TEXT_INACTIVE_TEXT

public static final int TEXT_INACTIVE_TEXT
textInactiveText 系统颜色的数组索引。

另请参见：
textInactiveText, 常量字段值

CONTROL

public static final int CONTROL
control 系统颜色的数组索引。

另请参见：
control, 常量字段值

CONTROL_TEXT

public static final int CONTROL_TEXT
controlText 系统颜色的数组索引。

另请参见：
controlText, 常量字段值

CONTROL_HIGHLIGHT

public static final int CONTROL_HIGHLIGHT
controlHighlight 系统颜色的数组索引。

另请参见：
controlHighlight, 常量字段值

CONTROL_LT_HIGHLIGHT

public static final int CONTROL_LT_HIGHLIGHT
controlLtHighlight 系统颜色的数组索引。

另请参见：
controlLtHighlight, 常量字段值

CONTROL_SHADOW

public static final int CONTROL_SHADOW
controlShadow 系统颜色的数组索引。

另请参见：
controlShadow, 常量字段值

CONTROL_DK_SHADOW

public static final int CONTROL_DK_SHADOW
controlDkShadow 系统颜色的数组索引。

另请参见：
controlDkShadow, 常量字段值

SCROLLBAR

public static final int SCROLLBAR
scrollbar 系统颜色的数组索引。

另请参见：
scrollbar, 常量字段值

INFO

public static final int INFO
info 系统颜色的数组索引。

另请参见：
info, 常量字段值

INFO_TEXT

public static final int INFO_TEXT
infoText 系统颜色的数组索引。

另请参见：
infoText, 常量字段值

NUM_COLORS

public static final int NUM_COLORS
数组中系统颜色的数量。

另请参见：
常量字段值

desktop

public static final SystemColor desktop
为桌面背景提供的颜色。

activeCaption

public static final SystemColor activeCaption
为当前活动窗口的窗口标题提供的背景色。

activeCaptionText

public static final SystemColor activeCaptionText
为当前活动窗口的窗口标题文本提供的颜色。

activeCaptionBorder

public static final SystemColor activeCaptionBorder
为当前活动窗口的边框提供的颜色。

inactiveCaption

public static final SystemColor inactiveCaption
为非活动窗口的窗口标题提供的背景色。

inactiveCaptionText

public static final SystemColor inactiveCaptionText
为非活动窗口的窗口标题文本提供的颜色。

inactiveCaptionBorder

public static final SystemColor inactiveCaptionBorder
为非活动窗口的边框提供的颜色。

window

public static final SystemColor window
为窗口的内部区域提供的背景色。

windowBorder

public static final SystemColor windowBorder
为窗口内部区域的边框提供的颜色。

windowText

public static final SystemColor windowText
为窗口内部区域的文本提供的颜色。

menu

public static final SystemColor menu
为菜单提供的背景色。

menuText

public static final SystemColor menuText
为菜单文本提供的颜色。

text

public static final SystemColor text
为文本控制对象（比如文本字段和组合框）提供的背景色。

textText

public static final SystemColor textText
为文本控制对象（比如文本字段和组合框）的文本提供的颜色。

textHighlight

public static final SystemColor textHighlight
为选则项（比如菜单、组合框和文本）提供的背景色。

textHighlightText

public static final SystemColor textHighlightText
为选则项（比如菜单、组合框和文本）的文本提供的颜色。

textInactiveText

public static final SystemColor textInactiveText
为非活动项（比如菜单中的项）的文本提供的颜色。

control

public static final SystemColor control
为控制面板和控制对象（比如按钮）提供的颜色。

controlText

public static final SystemColor controlText
为控制面板和控制对象（比如按钮）的文本提供的颜色。

controlHighlight

public static final SystemColor controlHighlight
为 3D 控制对象（比如按钮）的亮区提供的颜色。此颜色通常是从提供 3D 效果的 control 背景色中得来的。

controlLtHighlight

public static final SystemColor controlLtHighlight
为 3D 控制对象（比如按钮）的高亮区域提供的颜色。此颜色通常是从提供 3D 效果的 control 背景色中得来的。

controlShadow

public static final SystemColor controlShadow
为 3D 控制对象（比如按钮）的阴影区域提供的颜色。此颜色通常是从提供 3D 效果的 control 背景色中得来的。

controlDkShadow

public static final SystemColor controlDkShadow
为 3D 控制对象（比如按钮）的加黑阴影区域提供的颜色。此颜色通常是从提供 3D 效果的 control 背景色中得来的。

scrollbar

public static final SystemColor scrollbar
为滚动条提供的背景色。

info

public static final SystemColor info
为工具栏提示或定点帮助提供的背景色。

infoText

public static final SystemColor infoText
为工具栏提示或定点帮助的文本提供的颜色。

方法详细信息

getRGB

public int getRGB()
获取表示象征性颜色的“当前”RGB 值。（24-31 位表示 0xff，16-23 位表示红色，8-15 位表示绿色，0-7 位表示蓝色）。

覆盖：
类 Color 中的 getRGB
返回：
默认 sRGB ColorModel 中表示颜色的 RGB 值。
另请参见：
ColorModel.getRGBdefault(),
Color.getBlue(),
Color.getGreen(),
Color.getRed()

createContext

public PaintContext createContext(ColorModel cm,
                                  Rectangle r,
                                  Rectangle2D r2d,
                                  AffineTransform xform,
                                  RenderingHints hints)
创建并返回用来生成纯色模式的 PaintContext。这允许将 Color 对象用作需要一个对象来实现 Paint 接口的任何方法的参数。

指定者：
接口 Paint 中的 createContext
覆盖：
类 Color 中的 createContext
参数：
cm - 指定的 ColorModel
r - 指定的 Rectangle
r2d - 指定的 Rectangle2D
xform - 指定的 AffineTransform
hints - 指定的 RenderingHints
返回：
一个用来生成固定颜色模式的 PaintContext
另请参见：
Paint, PaintContext, Graphics2D.setPaint(java.awt.Paint)

toString

public String toString()
返回此 Color 值的字符串表示形式。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Color 中的 toString
返回：
此 Color 的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemTray (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 SystemTray

java.lang.Object
    继承者  java.awt.SystemTray

public class SystemTray
extends Object

SystemTray 类表示桌面的系统托盘。在 Microsoft Windows 上，它被称为“任务栏状态区域 (Taskbar Status Area)”，在 Gnome 上，它被称为“通知区域 (Notification Area)”，在 KDE 上，它被成为“系统托盘 (System Tray)”。系统托盘由运行在桌面上的所有应用程序共享。

在某些平台上，可能不存在或不支持系统托盘，在这种情况下，getSystemTray() 将抛出 UnsupportedOperationException。要检查系统托盘是否受支持，可以使用 isSupported()。

SystemTray 可以包含一个或多个 TrayIcon，可以使用 add(java.awt.TrayIcon) 方法将它们添加到托盘，当不再需要托盘时，使用 remove(java.awt.TrayIcon) 移除它。TrayIcon 由图像、弹出菜单和一组相关侦听器组成。有关详细信息，请参阅 TrayIcon 类。

每个 Java 应用程序都有一个 SystemTray 实例，在应用程序运行时，它允许应用程序与桌面系统托盘建立连接。SystemTray 实例可以通过 getSystemTray() 方法获得。应用程序不能创建自己的 SystemTray 实例。

以下代码片段演示了如何访问和自定义系统托盘：

TrayIcon trayIcon = null;
if (SystemTray.isSupported()) {
// get the SystemTray instance
SystemTray tray = SystemTray.getSystemTray();
// load an image
Image image = Toolkit.getDefaultToolkit.getImage(...);
// create a action listener to listen for default action executed on the tray icon
ActionListener listener = new ActionListener() {
public void actionPerformed(ActionEvent e) {
// execute default action of the application
                 // ...
             }
         };
// create a popup menu
PopupMenu popup = new PopupMenu();
// create menu item for the default action
MenuItem defaultItem = new MenuItem(...);
defaultItem.addActionListener(listener);
popup.add(defaultItem);
/// ... add other items
// construct a TrayIcon
trayIcon = new TrayIcon(image, "Tray Demo", popup);
// set the TrayIcon properties
trayIcon.addActionListener(listener);
         // ...
// add the tray image
try {
tray.add(trayIcon);
} catch (AWTException e) {
System.err.println(e);
         }
         // ...
} else {
// disable tray option in your application or
// perform other actions
         ...
     }
     // ...
// some time later
// the application state has changed - update the image
if (trayIcon != null) {
trayIcon.setImage(updatedImage);
     }
     // ...

从以下版本开始：
1.6
另请参见：
TrayIcon

方法摘要
void | add(TrayIcon trayIcon) 将 TrayIcon 添加到 SystemTray。
void | addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到特定属性的侦听器列表中。
PropertyChangeListener[] | getPropertyChangeListeners(String propertyName) 返回与指定属性关联的所有侦听器的数组。
static SystemTray | getSystemTray() 获取表示桌面托盘区的 SystemTray 实例。
TrayIcon[] | getTrayIcons() 返回由此应用程序添加到托盘中的所有图标的数组。
Dimension | getTrayIconSize() 返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
static boolean | isSupported() 返回当前平台是否支持系统托盘。
void | remove(TrayIcon trayIcon) 从 SystemTray 中移除指定的 TrayIcon。
void | removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从特定属性的侦听器列表中移除 PropertyChangeListener。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getSystemTray

public static SystemTray getSystemTray()
获取表示桌面托盘区的 SystemTray 实例。它总是对每个应用程序返回相同的实例。在一些平台上，可能不支持系统托盘。可以使用 isSupported() 方法检查系统托盘是否受支持。

如果安装了 SecurityManager，则必须授予 AWTPermission accessSystemTray 才能获取 SystemTray 实例。否则，此方法将抛出 SecurityException。

返回：
表示桌面托盘区的 SystemTray 实例
抛出：
UnsupportedOperationException - 如果当前平台不支持系统托盘
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
SecurityException - 如果未授予 accessSystemTray 权限
另请参见：
add(TrayIcon), TrayIcon, isSupported(), SecurityManager.checkPermission(java.security.Permission), AWTPermission

isSupported

public static boolean isSupported()
返回当前平台是否支持系统托盘。除了显示托盘图标之外，最小系统托盘支持还包括弹出菜单（请参阅 TrayIcon.setPopupMenu(PopupMenu)）或操作事件（请参阅 TrayIcon.addActionListener(ActionListener)）。

开发人员不应假定所有系统托盘功能都是受支持的。要保证始终可以访问托盘图标的默认动作，则应将默认动作同时添加到动作侦听器和弹出菜单。有关如何执行此操作的示例，请参阅 example。

注：在实现 SystemTray 和 TrayIcon 时，强烈建议 为弹出菜单和动作事件分配不同的动作。为两种目的重载一个动作时会产生混淆，并可能阻止用户访问它们其中的一个或另一个。

返回：
如果不支持系统托盘访问，则返回 false；如果当前平台支持最小系统托盘访问，但不保证支持所有系统托盘功能，则此方法返回 true
另请参见：
getSystemTray()

add

public void add(TrayIcon trayIcon)
         throws AWTException
将 TrayIcon 添加到 SystemTray。一旦添加了托盘图标，就可以在系统托盘中看到它。图标在托盘中的显示顺序未指定——它与平台和实现有关。

在应用程序退出时，应用程序添加的所有图标都将自动从 SystemTray 移除，在桌面系统托盘不可用时也一样。

参数：
trayIcon - 要添加的 TrayIcon
抛出：
NullPointerException - 如果 trayIcon 为 null
IllegalArgumentException - 如果多次添加 TrayIcon 的同一实例
AWTException - 如果桌面系统托盘不可用
另请参见：
remove(TrayIcon), getSystemTray(), TrayIcon, Image

remove

public void remove(TrayIcon trayIcon)
从 SystemTray 中移除指定的 TrayIcon。

在应用程序退出时，应用程序添加的所有图标都将自动从 SystemTray 移除，在桌面系统托盘不可用时也一样。

如果 trayIcon 为 null 或未添加到系统托盘，则不抛出任何异常且不执行任何动作。

参数：
trayIcon - 要移除的 TrayIcon
另请参见：
add(TrayIcon), TrayIcon

getTrayIcons

public TrayIcon[] getTrayIcons()
返回由此应用程序添加到托盘中的所有图标的数组。用户无法访问由另一个应用程序添加的图标。有些浏览器将使用不同代码基的 applet 划分为单独的上下文，并在这些上下文之间建墙分隔。在这种情形下，只返回从此上下文中添加的托盘图标。

返回的数组是实际数组的副本，可以以任意方式修改它，而不会影响系统托盘。要从 SystemTray 中移除 TrayIcon，可以使用 remove(TrayIcon) 方法。

返回：
添加到此托盘的所有托盘图标的数组；如果未添加托盘图标，则返回空数组
另请参见：
add(TrayIcon), TrayIcon

getTrayIconSize

public Dimension getTrayIconSize()
返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。开发人员可以使用这种方法在创建托盘图标之前获取图像属性的首选大小。为方便起见，在 TrayIcon 类中有一个类似的方法 TrayIcon.getSize()。

返回：
托盘图标的默认大小（以像素为单位）
另请参见：
TrayIcon.setImageAutoSize(boolean), Image, TrayIcon.getSize()

addPropertyChangeListener

public void addPropertyChangeListener(String propertyName,
                                      PropertyChangeListener listener)
将 PropertyChangeListener 添加到特定属性的侦听器列表中。当前支持的属性：
  • trayIcons

    此 SystemTray 的 TrayIcon 数组。通过 getTrayIcons() 可以访问该数组。
    在将 TrayIcon 添加到 SystemTray（或从中移除 TrayIcon）时，此属性将发生更改。
    例如，当本机 SystemTray 在桌面上不可用时，此属性将被更改
    且自动移除 TrayIcon。

listener 仅在此上下文中侦听属性更改。

如果 listener 为 null，则不抛出任何异常且不执行任何动作。

参数：
propertyName - 指定的属性
listener - 要添加的属性更改侦听器
另请参见：
removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener), getPropertyChangeListeners(java.lang.String)

removePropertyChangeListener

public void removePropertyChangeListener(String propertyName,
                                         PropertyChangeListener listener)
从特定属性的侦听器列表中移除 PropertyChangeListener。

PropertyChangeListener 必须来自于此上下文。

如果 propertyName 或 listener 为 null 或无效，则不抛出任何异常且不执行任何动作。

参数：
propertyName - 指定的属性
listener - 要移除的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener), getPropertyChangeListeners(java.lang.String)

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性关联的所有侦听器的数组。

只返回此上下文中的侦听器。

参数：
propertyName - 指定的属性
返回：
与指定属性关联的所有 PropertyChangeListener；如果未添加此类侦听器或者 propertyName 为 null 或无效，则返回空数组
另请参见：
addPropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener), removePropertyChangeListener(java.lang.String, java.beans.PropertyChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextArea (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TextArea

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.TextComponent
            继承者  java.awt.TextArea
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class TextArea
extends TextComponent

TextArea 对象是显示文本的多行区域。可以将它设置为允许编辑或只读。

下图显示了文本区的外观：

显示单词 'Hello!' 的 TextArea

此文本区可以使用以下代码行来创建：

 new TextArea("Hello", 5, 40);

从以下版本开始：
JDK1.0
另请参见：
序列化表格

嵌套类摘要
protected  class TextArea.AccessibleAWTTextArea
此类实现 TextArea 类的可访问性支持。
从类 java.awt.TextComponent 继承的嵌套类/接口
TextComponent.AccessibleAWTTextComponent
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | SCROLLBARS_BOTH 创建并显示垂直和水平滚动条。
static int | SCROLLBARS_HORIZONTAL_ONLY 只创建并显示水平滚动条。
static int | SCROLLBARS_NONE 不为文本区创建或显示任何滚动条。
static int | SCROLLBARS_VERTICAL_ONLY 只创建并显示垂直滚动条。
从类 java.awt.TextComponent 继承的字段
textListener
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
TextArea()
构造一个将空字符串作为文本的新文本区。
TextArea(int rows, int columns)
构造一个新文本区，该文本区具有指定的行数和列数，并将空字符串作为文本。
TextArea(String text)
构造具有指定文本的新文本区。
TextArea(String text, int rows, int columns)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。
TextArea(String text, int rows, int columns, int scrollbars)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。
方法摘要
 void addNotify()
创建 TextArea 的同位体。
 void append(String str)
将给定文本追加到文本区的当前文本。
 void appendText(String str)
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。
 AccessibleContext getAccessibleContext()
返回与此 TextArea 相关的 AccessibleContext。
 int getColumns()
返回此文本区中的列数。
 Dimension getMinimumSize()
确定此文本区的最小大小。
 Dimension getMinimumSize(int rows, int columns)
确定具有指定行数和列数的文本区的最小大小。
 Dimension getPreferredSize()
确定此文本区的首选大小。
 Dimension getPreferredSize(int rows, int columns)
确定具有指定行数和列数的文本区的首选大小。
 int getRows()
返回此文本区的行数。
 int getScrollbarVisibility()
返回指示文本区使用何种滚动条的枚举值。
 void insert(String str, int pos)
在此文本区的指定位置插入指定文本。
 void insertText(String str, int pos)
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。
 Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension minimumSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
protected  String paramString()
返回表示此 TextArea 状态的字符串。
 Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension preferredSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
 void replaceRange(String str, int start, int end)
用指定替换文本替换指定开始位置与结束位置之间的文本。
 void replaceText(String str, int start, int end)
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。
 void setColumns(int columns)
设置此文本区的列数。
 void setRows(int rows)
设置此文本区的行数。
从类 java.awt.TextComponent 继承的方法
addTextListener, enableInputMethods, getBackground, getCaretPosition, getInputMethodRequests, getListeners, getSelectedText, getSelectionEnd, getSelectionStart, getText, getTextListeners, isEditable, processEvent, processTextEvent, removeNotify, removeTextListener, select, selectAll, setBackground, setCaretPosition, setEditable, setSelectionEnd, setSelectionStart, setText
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SCROLLBARS_BOTH

public static final int SCROLLBARS_BOTH
创建并显示垂直和水平滚动条。

从以下版本开始：
JDK1.1
另请参见：
常量字段值

SCROLLBARS_VERTICAL_ONLY

public static final int SCROLLBARS_VERTICAL_ONLY
只创建并显示垂直滚动条。

从以下版本开始：
JDK1.1
另请参见：
常量字段值

SCROLLBARS_HORIZONTAL_ONLY

public static final int SCROLLBARS_HORIZONTAL_ONLY
只创建并显示水平滚动条。

从以下版本开始：
JDK1.1
另请参见：
常量字段值

SCROLLBARS_NONE

public static final int SCROLLBARS_NONE
不为文本区创建或显示任何滚动条。

从以下版本开始：
JDK1.1
另请参见：
常量字段值
构造方法详细信息

TextArea

public TextArea()
         throws HeadlessException
构造一个将空字符串作为文本的新文本区。此文本区是在滚动条可见性等于 SCROLLBARS_BOTH 的情况下创建的，所以垂直滚动条和水平滚动条对于文本区都将是可视的。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

TextArea

public TextArea(String text)
         throws HeadlessException
构造具有指定文本的新文本区。文本区是在滚动条可见性等于 SCROLLBARS_BOTH 的情况下创建的，所以垂直滚动条和水平滚动条对于文本区都将是可视的。

参数：
text - 要显示的文本；如果 text 为 null，则显示空字符串 ""
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

TextArea

public TextArea(int rows,
                int columns)
         throws HeadlessException
构造一个新文本区，该文本区具有指定的行数和列数，并将空字符串作为文本。列是近似平均字符宽度，它与平台有关。文本区是在滚动条可见性等于 SCROLLBARS_BOTH 的情况下创建的，所以垂直滚动条和水平滚动条对于文本区都将是可视的。

参数：
rows - 行数
columns - 列数
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

TextArea

public TextArea(String text,
                int rows,
                int columns)
         throws HeadlessException
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。列是近似平均字符宽度，它与平台有关。文本区是在滚动条可见性等于 SCROLLBARS_BOTH 的情况下创建的，所以垂直滚动条和水平滚动条对于文本区都将是可视的。

参数：
text - 要显示的文本；如果 text 为 null，则显示空字符串 ""
rows - 行数
columns - 列数
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

TextArea

public TextArea(String text,
                int rows,
                int columns,
                int scrollbars)
         throws HeadlessException
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。所有 TextArea 构造方法都服从这一规定。

TextArea 类定义一些可以作为 scrollbars 参数值提供的常量：

  • SCROLLBARS_BOTH,
  • SCROLLBARS_VERTICAL_ONLY,
  • SCROLLBARS_HORIZONTAL_ONLY,
  • SCROLLBARS_NONE.
其他所有用于 scrollbars 参数的值都是无效的，并会使创建此文本区时使用的滚动条可见性等于 SCROLLBARS_BOTH 的默认值。

参数：
text - 要显示的文本；如果 text 为 null，则显示空字符串 ""
rows - 行数；如果 rows 小于 0，则将 rows 设置为 0
columns - 列数；如果 columns 小于 0，则将 columns 设置为 0
scrollbars - 确定为查看文本区创建的滚动条类型的常量
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建 TextArea 的同位体。该同位体允许修改 TextArea 的外观，而不更改其功能。

覆盖：
类 TextComponent 中的 addNotify
另请参见：
TextComponent.removeNotify()

insert

public void insert(String str,
                   int pos)
在此文本区的指定位置插入指定文本。

注意，传递 null 或不一致的参数是无效的，并且将导致不确定的行为。

参数：
str - 要插入的非 null 文本
pos - 插入的位置
从以下版本开始：
JDK1.1
另请参见：
TextComponent.setText(java.lang.String),
replaceRange(java.lang.String, int, int),
append(java.lang.String)

insertText

@Deprecated
public void insertText(String str,
                                  int pos)
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。

append

public void append(String str)
将给定文本追加到文本区的当前文本。

注意，传递 null 或不一致的参数是无效的，并且将导致不确定的行为。

参数：
str - 要追加的非 null 文本
从以下版本开始：
JDK1.1
另请参见：
insert(java.lang.String, int)

appendText

@Deprecated
public void appendText(String str)
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。

replaceRange

public void replaceRange(String str,
                         int start,
                         int end)
用指定替换文本替换指定开始位置与结束位置之间的文本。结束处的文本不会被替换。开始位置处的文本会被替换（除非开始位置与结束位置相同）。文本位置是从零开始的。插入子字符串的长度可以与所替换文本的长度不同。

注意，传递 null 或不一致的参数是无效的，并且将导致不确定的行为。

参数：
str - 用于替换的非 null 文本
start - 开始位置
end - 结束位置
从以下版本开始：
JDK1.1
另请参见：
insert(java.lang.String, int)

replaceText

@Deprecated
public void replaceText(String str,
                                   int start,
                                   int end)
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。

getRows

public int getRows()
返回此文本区的行数。

返回：
此文本区中的行数
从以下版本开始：
JDK1
另请参见：
setRows(int), getColumns()

setRows

public void setRows(int rows)
设置此文本区的行数。

参数：
rows - 行数
抛出：
IllegalArgumentException - 如果为 rows 提供的值小于 0
从以下版本开始：
JDK1.1
另请参见：
getRows(), setColumns(int)

getColumns

public int getColumns()
返回此文本区中的列数。

返回：
此文本区中的列数
另请参见：
setColumns(int), getRows()

setColumns

public void setColumns(int columns)
设置此文本区的列数。

参数：
columns - 列数
抛出：
IllegalArgumentException - 如果为 columns 提供的值小于 0
从以下版本开始：
JDK1.1
另请参见：
getColumns(), setRows(int)

getScrollbarVisibility

public int getScrollbarVisibility()
返回指示文本区使用何种滚动条的枚举值。

TextArea 类定义了四个整数常量，用来指定哪些滚动条是可用的。TextArea 有一个给出滚动条上的应用方向的构造方法。

返回：
指示使用哪种滚动条的整数
从以下版本开始：
JDK1.1
另请参见：
SCROLLBARS_BOTH, SCROLLBARS_VERTICAL_ONLY, SCROLLBARS_HORIZONTAL_ONLY, SCROLLBARS_NONE, TextArea(java.lang.String, int, int, int)

getPreferredSize

public Dimension getPreferredSize(int rows,
                                  int columns)
确定具有指定行数和列数的文本区的首选大小。

参数：
rows - 行数
columns - 列数
返回：
显示具有指定行数和列数的文本区所需的首选尺寸
从以下版本开始：
JDK1.1
另请参见：
Component.getPreferredSize()

preferredSize

@Deprecated
public Dimension preferredSize(int rows,
                                          int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。

getPreferredSize

public Dimension getPreferredSize()
确定此文本区的首选大小。

覆盖：
类 Component 中的 getPreferredSize
返回：
此文本区所需的首选尺寸
从以下版本开始：
JDK1.1
另请参见：
Component.getPreferredSize()

preferredSize

@Deprecated
public Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。

覆盖：
类 Component 中的 preferredSize

getMinimumSize

public Dimension getMinimumSize(int rows,
                                int columns)
确定具有指定行数和列数的文本区的最小大小。

参数：
rows - 行数
columns - 列数
返回：
显示具有指定行数和列数的文本区所需的最小尺寸
从以下版本开始：
JDK1.1
另请参见：
Component.getMinimumSize()

minimumSize

@Deprecated
public Dimension minimumSize(int rows,
                                        int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。

getMinimumSize

public Dimension getMinimumSize()
确定此文本区的最小大小。

覆盖：
类 Component 中的 getMinimumSize
返回：
此文本区所需的首选尺寸
从以下版本开始：
JDK1.1
另请参见：
Component.getPreferredSize()

minimumSize

@Deprecated
public Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。

覆盖：
类 Component 中的 minimumSize

paramString

protected String paramString()
返回表示此 TextArea 状态的字符串。此方法仅用于调试目的，对于各个实现，返回的字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 TextComponent 中的 paramString
返回：
此文本区的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
返回与此 TextArea 相关的 AccessibleContext。对于文本区，AccessibleContext 采用 AccessibleAWTTextArea 的形式。如有必要，可创建一个新的 AccessibleAWTTextArea 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 TextComponent 中的 getAccessibleContext
返回：
用作此 TextArea 的 AccessibleContext 的 AccessibleAWTTextArea
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextArea.AccessibleAWTTextArea (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TextArea.AccessibleAWTTextArea

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.TextComponent.AccessibleAWTTextComponent
                继承者  java.awt.TextArea.AccessibleAWTTextArea
所有已实现的接口：
TextListener, Serializable, EventListener, AccessibleComponent, AccessibleText
正在封闭类：
TextArea
protected class TextArea.AccessibleAWTTextArea
extends TextComponent.AccessibleAWTTextComponent

此类实现 TextArea 类的可访问性支持。它提供适合于文本区域用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected TextArea.AccessibleAWTTextArea()
方法摘要
 AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。
从类 java.awt.TextComponent.AccessibleAWTTextComponent 继承的方法
getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, textValueChanged
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TextArea.AccessibleAWTTextArea

protected TextArea.AccessibleAWTTextArea()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 TextComponent.AccessibleAWTTextComponent 中的 getAccessibleStateSet
返回：
描述对象状态的 AccessibleStateSet 实例
另请参见：
AccessibleStateSet
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TextComponent

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.TextComponent
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
TextArea, TextField
public class TextComponent
extends Component
implements Accessible

TextComponent 类是所有允许编辑文本的组件的超类。

文本组件具体化文本字符串。TextComponent 类定义了一组判断此文本是否可编辑的方法。如果组件是可编辑的，则该类还定义了另一组支持文件插入符的方法。

此外，该类定义了用于维护文本当前选择 的方法。文本选择是组件文本的子字符串，是编辑操作的目标。它也被称为选定文本。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

嵌套类摘要
protected  class TextComponent.AccessibleAWTTextComponent
此类实现对 TextComponent 类的可访问性支持。
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected  TextListener textListener
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
方法摘要
 void addNotify()
通过将此 Component 连接到一个本机屏幕资源，使其成为可显示的。
 void addTextListener(TextListener l)
添加指定的文本事件侦听器，以接收此文本组件发出的文本事件。
 void enableInputMethods(boolean enable)
启用或禁用此文本组件的输入法支持。
 AccessibleContext getAccessibleContext()
获取与此 TextComponent 关联的 AccessibleContext。
 Color getBackground()
获得此文本组件的背景色。
 int getCaretPosition()
返回文本插入符的位置。
 InputMethodRequests getInputMethodRequests()
获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
 String getSelectedText()
返回此文本组件所表示文本的选定文本。
 int getSelectionEnd()
获取此文本组件中选定文本的结束位置。
 int getSelectionStart()
获取此文本组件中选定文本的开始位置。
 String getText()
返回此文本组件表示的文本。
 TextListener[] getTextListeners()
返回在此文本组件上所有已注册文本侦听器的数组。
 boolean isEditable()
指示此文本组件是否可编辑。
protected  String paramString()
返回表示此 TextComponent 状态的字符串。
protected  void processEvent(AWTEvent e)
处理此文本组件上发生的事件。
protected  void processTextEvent(TextEvent e)
处理发生在此文本组件上的文本事件：将这些事件指派给所有已注册的 TextListener 对象。
 void removeNotify()
移除 TextComponent 的同位体。
 void removeTextListener(TextListener l)
移除指定的文本事件侦听器，不再接收此文本组件发出的文本事件。
 void select(int selectionStart, int selectionEnd)
选择指定开始位置和结束位置之间的文本。
 void selectAll()
选择此文本组件中的所有文本。
 void setBackground(Color c)
设置此文本组件的背景色。
 void setCaretPosition(int position)
设置文本插入符的位置。
 void setEditable(boolean b)
设置判断此文本组件是否可编辑的标志。
 void setSelectionEnd(int selectionEnd)
将此文本组件的选定结束位置设置为指定位置。
 void setSelectionStart(int selectionStart)
将此文本组件的选定开始位置设置为指定位置。
 void setText(String t)
将此文本组件显示的文本设置为指定文本。
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMinimumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPreferredSize, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, minimumSize, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, preferredSize, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

textListener

protected transient TextListener textListener
方法详细信息

enableInputMethods

public void enableInputMethods(boolean enable)
启用或禁用此文本组件的输入法支持。如果启用输入法支持并且文本组件也能处理按键事件，则将传入事件提供给当前输入法；如果输入法没有使用它们，则它们只能由组件处理或被指派给它们的侦听器。默认情况下，启用还是禁用，以及如何启用或禁用此文本组建的输入法支持与实现有关。

覆盖：
类 Component 中的 enableInputMethods
参数：
enable - 为 true 表示启用；为 false 表示禁用
从以下版本开始：
1.2
另请参见：
Component.processKeyEvent(java.awt.event.KeyEvent)

getInputMethodRequests

public InputMethodRequests getInputMethodRequests()
从类 Component 复制的描述
获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。支持当场文本输入的组件必须重写此方法，以便返回一个 InputMethodRequests 实例。同时，还必须处理输入方法事件。

覆盖：
类 Component 中的 getInputMethodRequests
返回：
组件的输入方法请求处理程序，默认为 null
另请参见：
Component.addInputMethodListener(java.awt.event.InputMethodListener)

addNotify

public void addNotify()
通过将此 Component 连接到一个本机屏幕资源，使其成为可显示的。此方法由工具包内部调用，不应直接由程序调用。

覆盖：
类 Component 中的 addNotify
另请参见：
removeNotify()

removeNotify

public void removeNotify()
移除 TextComponent 的同位体。该同位体允许我们修改 TextComponent 的外观，而不更改其功能。

覆盖：
类 Component 中的 removeNotify
另请参见：
Component.isDisplayable(), Component.addNotify()

setText

public void setText(String t)
将此文本组件显示的文本设置为指定文本。

参数：
t - 新文本；如果此参数为 null，则将文本设置为空字符串 ""
另请参见：
getText()

getText

public String getText()
返回此文本组件表示的文本。默认情况下，此文本是一个空字符串。

返回：
此 TextComponent 的值
另请参见：
setText(java.lang.String)

getSelectedText

public String getSelectedText()
返回此文本组件所表示文本的选定文本。

返回：
此文本组件的选定文本
另请参见：
select(int, int)

isEditable

public boolean isEditable()
指示此文本组件是否可编辑。

返回：
如果此文本组件是可编辑的，则返回 true；否则返回 false。
从以下版本开始：
JDK1.0
另请参见：
setEditable(boolean)

setEditable

public void setEditable(boolean b)
设置判断此文本组件是否可编辑的标志。

如果将该标志设置为 true，则此文本组件变成用户可编辑的。如果将该标志设置为 false，则用户无法更改此文本组件的文本。默认情况下，不可编辑的文本组件的背景色为 SystemColor.control。通过调用 setBackground 可以重写此默认值。

参数：
b - 指示此文本组件是否是用户可编辑的标志。
从以下版本开始：
JDK1.0
另请参见：
isEditable()

getBackground

public Color getBackground()
获得此文本组件的背景色。默认情况下，不可编辑的文本组件的背景色为 SystemColor.control。通过调用 setBackground 可以重写此默认值。

覆盖：
类 Component 中的 getBackground
返回：
此文本组件的背景色。如果此文本组件没有背景色，则返回其父组件的背景色。
从以下版本开始：
JDK1.0
另请参见：
setBackground(Color)

setBackground

public void setBackground(Color c)
设置此文本组件的背景色。

覆盖：
类 Component 中的 setBackground
参数：
c - 成为此文本组件颜色的颜色。如果此参数为 null，则此文本组件将继承其父组件的背景色。
从以下版本开始：
JDK1.0
另请参见：
getBackground()

getSelectionStart

public int getSelectionStart()
获取此文本组件中选定文本的开始位置。

返回：
选定文本的开始位置
另请参见：
setSelectionStart(int), getSelectionEnd()

setSelectionStart

public void setSelectionStart(int selectionStart)
将此文本组件的选定开始位置设置为指定位置。新的起始点限制在当前选定结束位置处或之前。并且不能将它设置为小于零，即小于组件文本的开始处。如果调用者提供的 selectionStart 值超出限度，则该方法暗中执行这些限制，操作不会失败。

参数：
selectionStart - 选定文本的开始位置
从以下版本开始：
JDK1.1
另请参见：
getSelectionStart(), setSelectionEnd(int)

getSelectionEnd

public int getSelectionEnd()
获取此文本组件中选定文本的结束位置。

返回：
选定文本的结束位置
另请参见：
setSelectionEnd(int), getSelectionStart()

setSelectionEnd

public void setSelectionEnd(int selectionEnd)
将此文本组件的选定结束位置设置为指定位置。新的结束点限制在当前选定开始位置处或之后。并且不能将它设置为超出组件文本末端。如果调用者提供的 selectionEnd 值超出限度，则该方法暗中执行这些限制，操作不会失败。

参数：
selectionEnd - 选定文本的结束位置
从以下版本开始：
JDK1.1
另请参见：
getSelectionEnd(), setSelectionStart(int)

select

public void select(int selectionStart,
                   int selectionEnd)
选择指定开始位置和结束位置之间的文本。

此方法设置选定文本的开始位置和结束位置，并强行限制开始位置必须大于等于零。结束位置必须大于等于开始位置，并小于等于文本组件的文本长度。字符位置的索引从零开始。选择文本的长度是 endPosition - startPosition，因此没有选定 endPosition 处的字符。如果选定文本的开始位置和结束位置是相等的，则取消对所有文本的选择。

如果调用者提供不一致或超出限度的值，则该方法暗中执行这些限制，操作不会失败。具体来说，如果开始位置或结束位置大于文本长度，则将它重置为等于文本长度。如果开始位置小于零，则将它重置为零，如果结束位置小于开始位置，则将它重置为开始位置。

参数：
selectionStart - 要选定的首字符（char 值）从零开始的索引
selectionEnd - 要选定的文本从零开始的结束位置；selectionEnd 处的字符（char 值）未被选定
另请参见：
setSelectionStart(int), setSelectionEnd(int), selectAll()

selectAll

public void selectAll()
选择此文本组件中的所有文本。

另请参见：
select(int, int)

setCaretPosition

public void setCaretPosition(int position)
设置文本插入符的位置。插入符的位置被限制在 0 和文本最后一个字符（包括）之间。如果传入值大于此范围，则将该值设置为最后一个字符（如果 TextComponent 不包含文本，则将该值设置为 0），并且不返回任何错误。如果传入值小于 0，则抛出 IllegalArgumentException。

参数：
position - 文本插入符的位置
抛出：
IllegalArgumentException - 如果 position 小于零
从以下版本开始：
JDK1.1

getCaretPosition

public int getCaretPosition()
返回文本插入符的位置。插入符的位置被限制在 0 和文本最后一个字符（包括）之间。如果没有设置文本或插入符，则默认插入符的位置为 0。

返回：
文本插入符的位置
从以下版本开始：
JDK1.1
另请参见：
setCaretPosition(int)

addTextListener

public void addTextListener(TextListener l)
添加指定的文本事件侦听器，以接收此文本组件发出的文本事件。如果 l 为 null，则不抛出任何异常，也不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 文本事件侦听器
另请参见：
removeTextListener(java.awt.event.TextListener), getTextListeners(), TextListener

removeTextListener

public void removeTextListener(TextListener l)
移除指定的文本事件侦听器，不再接收此文本组件发出的文本事件。如果 l 为 null，则不抛出任何异常，也不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 文本侦听器
从以下版本开始：
JDK1.1
另请参见：
addTextListener(java.awt.event.TextListener), getTextListeners(), TextListener

getTextListeners

public TextListener[] getTextListeners()
返回在此文本组件上所有已注册文本侦听器的数组。

返回：
此文本组件的所有 TextListener；如果当前没有已注册的文本侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addTextListener(java.awt.event.TextListener), removeTextListener(java.awt.event.TextListener)

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用以下代码来查询 TextComponent t 的文本侦听器：

TextListener[] tls = (TextListener[])(t.getListeners(TextListener.class));
如果不存在这样的侦听器，则此方法返回一个空数组。

覆盖：
类 Component 中的 getListeners
参数：
listenerType - 请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此文本组件上作为 FooListener 注册的所有对象的数组；如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getTextListeners()

processEvent

protected void processEvent(AWTEvent e)
处理此文本组件上发生的事件。如果事件是 TextEvent，那么它将调用 processTextEvent 方法，否则它将调用其超类的 processEvent。

注意，如果事件参数为 null，则行为是不明确的，并可能导致异常。

覆盖：
类 Component 中的 processEvent
参数：
e - 事件
另请参见：
Component.processComponentEvent(java.awt.event.ComponentEvent),
Component.processFocusEvent(java.awt.event.FocusEvent),
Component.processKeyEvent(java.awt.event.KeyEvent),
Component.processMouseEvent(java.awt.event.MouseEvent),
Component.processMouseMotionEvent(java.awt.event.MouseEvent),
Component.processInputMethodEvent(java.awt.event.InputMethodEvent),
Component.processHierarchyEvent(java.awt.event.HierarchyEvent),
Component.processMouseWheelEvent(java.awt.event.MouseWheelEvent)

processTextEvent

protected void processTextEvent(TextEvent e)
处理发生在此文本组件上的文本事件：将这些事件指派给所有已注册的 TextListener 对象。

注：如果没有对此组件启用文本事件，则不调用此方法。这发生在出现以下情况之一时：

  • 通过 addTextListener 注册一个 TextListener 对象。
  • 通过 enableEvents 启用文本事件

注意，如果事件参数为 null，则行为是不明确的，并可能导致异常。

参数：
e - 文本事件
另请参见：
Component.enableEvents(long)

paramString

protected String paramString()
返回表示此 TextComponent 状态的字符串。此方法仅用于调试目的，对于各个实现，返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Component 中的 paramString
返回：
此文本组件的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 TextComponent 关联的 AccessibleContext。对于文本组件，AccessibleContext 采用 AccessibleAWTTextComponent 的形式。如有必要，可创建一个新的 AccessibleAWTTextComponent 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
一个 AccessibleAWTTextComponent，它充当此 TextComponent 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextComponent.AccessibleAWTTextComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TextComponent.AccessibleAWTTextComponent

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.TextComponent.AccessibleAWTTextComponent
所有已实现的接口：
TextListener, Serializable, EventListener, AccessibleComponent, AccessibleText
直接已知子类：
TextArea.AccessibleAWTTextArea, TextField.AccessibleAWTTextField
正在封闭类：
TextComponent
protected class TextComponent.AccessibleAWTTextComponent
extends Component.AccessibleAWTComponent
implements AccessibleText, TextListener

此类实现对 TextComponent 类的可访问性支持。它提供适合于文本组件用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
TextComponent.AccessibleAWTTextComponent()
构造 AccessibleAWTTextComponent。
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取 TextComponent 的状态设置。
AccessibleText | getAccessibleText() 获取与此对象相关的 AccessibleText。
String | getAfterIndex(int part, int index) 返回给定索引后面的 String。
String | getAtIndex(int part, int index) 返回给定索引处的 String。
String | getBeforeIndex(int part, int index) 返回给定索引前面的 String。
int | getCaretPosition() 返回插入记号的从零开始的偏移量。
AttributeSet | getCharacterAttribute(int i) 返回给定字符（位于给定索引处）的 AttributeSet。
Rectangle | getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
int | getCharCount() 返回字符（有效索引）的数量
int | getIndexAtPoint(Point p) 给出本地坐标中的一个点，返回该 Point 下的、从零开始的字符索引。
String | getSelectedText() 返回选定文本的一部分。
int | getSelectionEnd() 返回选定文本中的终止偏移量。
int | getSelectionStart() 返回选定文本中的起始偏移量。
void | textValueChanged(TextEvent textEvent) 文本值更改的 TextListener 通知。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TextComponent.AccessibleAWTTextComponent

public TextComponent.AccessibleAWTTextComponent()
构造 AccessibleAWTTextComponent。添加跟踪插入记号更改的侦听器。

方法详细信息

textValueChanged

public void textValueChanged(TextEvent textEvent)
文本值更改的 TextListener 通知。

指定者：
接口 TextListener 中的 textValueChanged

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取 TextComponent 的状态设置。对象的 AccessibleStateSet 由惟一的 AccessibleStates 集合组成。对象的 AccessibleStateSet 中的更改将导致对 AccessibleContext.ACCESSIBLE_STATE_PROPERTY 属性触发 PropertyChangeEvent。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态设置的 AccessibleStateSet 实例
另请参见：
AccessibleStateSet, AccessibleState, Component.AccessibleAWTComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象 (AccessibleRole.TEXT) 职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleText

public AccessibleText getAccessibleText()
获取与此对象相关的 AccessibleText。在此类的 Java Accessibility API 实现中，返回此对象，它负责代表它自己实现 AccessibleText 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
此对象
另请参见：
AccessibleText

getIndexAtPoint

public int getIndexAtPoint(Point p)
给出本地坐标中的一个点，返回该 Point 下的、从零开始的字符索引。如果该点无效，则此方法返回 -1。

指定者：
接口 AccessibleText 中的 getIndexAtPoint
参数：
p - 本地坐标中的 Point
返回：
Point p 下的、从零开始的字符索引。

getCharacterBounds

public Rectangle getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。边界以本地坐标返回。如果索引无效，则返回一个 null 矩形。

指定者：
接口 AccessibleText 中的 getCharacterBounds
参数：
i - String 中的索引，该索引 >= 0
返回：
字符边界框的屏幕坐标

getCharCount

public int getCharCount()
返回字符（有效索引）的数量

指定者：
接口 AccessibleText 中的 getCharCount
返回：
字符数量，该值 >= 0

getCaretPosition

public int getCaretPosition()
返回插入记号的从零开始的偏移量。 注： 插入记号右边的字符将拥有与偏移量相同的索引值（插入记号在两个字符之间）。

指定者：
接口 AccessibleText 中的 getCaretPosition
返回：
插入记号的从零开始的偏移量。

getCharacterAttribute

public AttributeSet getCharacterAttribute(int i)
返回给定字符（位于给定索引处）的 AttributeSet。

指定者：
接口 AccessibleText 中的 getCharacterAttribute
参数：
i - 文本中从零开始的索引
返回：
字符的 AttributeSet

getSelectionStart

public int getSelectionStart()
返回选定文本中的起始偏移量。如果没有选择文本，但有一个插入记号，则起始偏移量和终止偏移量是相同的。如果文本为空，则返回 0，如果没有选择文本，则返回插入记号的位置。

指定者：
接口 AccessibleText 中的 getSelectionStart
返回：
选择文本中起始处的索引，该索引 >= 0

getSelectionEnd

public int getSelectionEnd()
返回选定文本中的终止偏移量。如果没有选择文本，但有一个插入记号，则起始偏移量和终止偏移量是相同的。如果文本为空，则返回 0，如果没有选择文本，则返回插入记号的位置。

指定者：
接口 AccessibleText 中的 getSelectionEnd
返回：
选择文本中终止处的索引，该索引 >= 0

getSelectedText

public String getSelectedText()
返回选定文本的一部分。

指定者：
接口 AccessibleText 中的 getSelectedText
返回：
文本，如果没有选择文本，则返回 null

getAtIndex

public String getAtIndex(int part,
                         int index)
返回给定索引处的 String。

指定者：
接口 AccessibleText 中的 getAtIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该索引 >= 0
返回：
字母、单词或句子，对于无效索引或无效部分，则返回 null

getAfterIndex

public String getAfterIndex(int part,
                            int index)
返回给定索引后面的 String。

指定者：
接口 AccessibleText 中的 getAfterIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该索引 >= 0
返回：
字母、单词或句子，对于无效索引或无效部分，则返回 null

getBeforeIndex

public String getBeforeIndex(int part,
                             int index)
返回给定索引前面的 String。

指定者：
接口 AccessibleText 中的 getBeforeIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该索引 >= 0
返回：
字母、单词或句子，对于无效索引或无效部分，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TextField

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.TextComponent
            继承者  java.awt.TextField
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class TextField
extends TextComponent

TextField 对象是允许编辑单行文本的文本组件。

例如，下图描绘了带有四个宽度各异的文本字段的窗体。其中两个文本字段显示预定义文本 "Hello"。

以下是产生四个文本字段的代码：

TextField tf1, tf2, tf3, tf4;
// a blank text field
tf1 = new TextField();
// blank field of 20 columns
tf2 = new TextField("", 20);
// predefined text displayed
tf3 = new TextField("Hello!");
// predefined text in 30 columns
tf4 = new TextField("Hello", 30);

每次用户在文本字段中键入一个键时，就有一个或更多键事件被发送到该文本字段。KeyEvent 是以下三种类型之一：keyPressed、keyReleased 或 keyTyped。键事件的属性指示事件是哪一种类型，以及关于事件的其他信息，比如对键事件应用哪种修饰符和事件发生的时间。

键事件被传递给每一个 KeyListener 或 KeyAdapter 对象，这些对象使用组件的 addKeyListener 方法注册，以接收这类事件。（KeyAdapter 对象实现 KeyListener 接口。）

TextField 还可能触发 ActionEvent。如果对文本字段启用操作事件，则可以通过按下 Return 键触发它们。

TextField 类的 processEvent 方法检查操作事件，并将它们传递给 processActionEvent。后一种方法将该事件重定向到为接收此文本字段生成的操作事件而注册的所有 ActionListener 对象。

从以下版本开始：
JDK1.0
另请参见：
KeyEvent, KeyAdapter, KeyListener, ActionEvent, Component.addKeyListener(java.awt.event.KeyListener), processEvent(java.awt.AWTEvent), processActionEvent(java.awt.event.ActionEvent), addActionListener(java.awt.event.ActionListener), 序列化表格

嵌套类摘要
protected  class TextField.AccessibleAWTTextField
此类实现 TextField 类的可访问性支持。
从类 java.awt.TextComponent 继承的嵌套类/接口
TextComponent.AccessibleAWTTextComponent
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.TextComponent 继承的字段
textListener
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
TextField()
构造新文本字段。
TextField(int columns)
构造具有指定列数的新空文本字段。
TextField(String text)
构造使用指定文本初始化的新文本字段。
TextField(String text, int columns)
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。
方法摘要
 void addActionListener(ActionListener l)
添加指定的操作侦听器，以从此文本字段接收操作事件。
 void addNotify()
创建 TextField 的同位体。
 boolean echoCharIsSet()
指示此文本字段是否有一个回显字符集。
 AccessibleContext getAccessibleContext()
获取与此 TextField 关联的 AccessibleContext。
 ActionListener[] getActionListeners()
返回此文本字段上已注册的所有操作侦听器的数组。
 int getColumns()
获取此文本字段中的列数。
 char getEchoChar()
获取用于回显的字符。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
 Dimension getMinimumSize()
获取此文本字段的最小尺寸。
 Dimension getMinimumSize(int columns)
获取具有指定列数的文本字段的最小尺寸。
 Dimension getPreferredSize()
获取此文本字段的首选大小。
 Dimension getPreferredSize(int columns)
获取具有指定列数的文本字段的首选大小。
 Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension minimumSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
protected  String paramString()
返回表示此 TextField 状态的字符串。
 Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension preferredSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
protected  void processActionEvent(ActionEvent e)
处理发生在此文本字段上的操作事件：将这些事件指派给所有已注册的 ActionListener 对象。
protected  void processEvent(AWTEvent e)
处理此文本字段上的事件。
 void removeActionListener(ActionListener l)
移除指定的操作侦听器，不再从此文本字段接收操作事件。
 void setColumns(int columns)
设置此文本字段中的列数。
 void setEchoChar(char c)
设置此文本字段的回显字符。
 void setEchoCharacter(char c)
已过时。 从 JDK version 1.1 开始，由 setEchoChar(char) 取代。
 void setText(String t)
将此文本组件显示的文本设置为指定文本。
从类 java.awt.TextComponent 继承的方法
addTextListener, enableInputMethods, getBackground, getCaretPosition, getInputMethodRequests, getSelectedText, getSelectionEnd, getSelectionStart, getText, getTextListeners, isEditable, processTextEvent, removeNotify, removeTextListener, select, selectAll, setBackground, setCaretPosition, setEditable, setSelectionEnd, setSelectionStart
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, deliverEvent, disable, disableEvents, dispatchEvent, doLayout, enable, enable, enableEvents, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getAlignmentX, getAlignmentY, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentAt, getComponentAt, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeys, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMaximumSize, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, invalidate, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusCycleRoot, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, layout, list, list, list, list, list, locate, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paint, paintAll, postEvent, prepareImage, prepareImage, print, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeys, setFocusTraversalKeysEnabled, setFont, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusBackward, transferFocusUpCycle, update, validate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TextField

public TextField()
          throws HeadlessException
构造新文本字段。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

TextField

public TextField(String text)
          throws HeadlessException
构造使用指定文本初始化的新文本字段。

参数：
text - 要显示的文本。如果 text 为 null，则显示空字符串 ""。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

TextField

public TextField(int columns)
          throws HeadlessException
构造具有指定列数的新空文本字段。列是近似平均字符宽度，它与平台有关。

参数：
columns - 列数。如果 columns 小于 0，则将 columns 设置为 0。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

TextField

public TextField(String text,
                 int columns)
          throws HeadlessException
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。列是近似平均字符宽度，它与平台有关。

参数：
text - 要显示的文本。如果 text 为 null，则显示空字符串 ""。
columns - 列数。如果 columns 小于 0，则将 columns 设置为 0。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

addNotify

public void addNotify()
创建 TextField 的同位体。此同位体允许修改 TextField 的外观，并且不更改其功能。

覆盖：
类 TextComponent 中的 addNotify
另请参见：
TextComponent.removeNotify()

getEchoChar

public char getEchoChar()
获取用于回显的字符。

回显字符对于不应将用户输入回显到屏幕上的文本字段有用，例如输入密码的文本字段。如果 echoChar = 0，则将用户输入不作更改地回显到屏幕。

Java 平台实现只能支持有限的、非空回显字符集。此函数返回 setEchoChar() 最初请求的回显字符。TextField 实现实际使用的回显字符可能不同。

返回：
此文本字段的回显字符。
另请参见：
echoCharIsSet(), setEchoChar(char)

setEchoChar

public void setEchoChar(char c)
设置此文本字段的回显字符。

回显字符对于不应将用户输入回显到屏幕上的文本字段很有用，例如输入密码的文本字段。设置 echoChar = 0 允许将用户输入再次回显到屏幕。

Java 平台实现只能支持有限的、非空回显字符集。试图设置不受支持的回显字符将导致使用默认回显字符。对 getEchoChar() 的后续调用将返回最初请求的回显字符。返回的回显字符有可能与 TextField 实现实际使用的相同，也有可能不同。

参数：
c - 此文本字段的回显字符。
从以下版本开始：
JDK1.1
另请参见：
echoCharIsSet(), getEchoChar()

setEchoCharacter

@Deprecated
public void setEchoCharacter(char c)
已过时。 从 JDK version 1.1 开始，由 setEchoChar(char) 取代。

setText

public void setText(String t)
将此文本组件显示的文本设置为指定文本。

覆盖：
类 TextComponent 中的 setText
参数：
t - 新文本。
另请参见：
TextComponent.getText()

echoCharIsSet

public boolean echoCharIsSet()
指示此文本字段是否有一个回显字符集。

回显字符对于不应将用户输入回显到屏幕上的文本字段有用，例如输入密码的文本字段。

返回：
如果此文本字段有一个回显字符集，则返回 true；否则返回 false。
另请参见：
setEchoChar(char), getEchoChar()

getColumns

public int getColumns()
获取此文本字段中的列数。列是近似平均字符宽度，它与平台有关。

返回：
列数。
从以下版本开始：
JDK1.1
另请参见：
setColumns(int)

setColumns

public void setColumns(int columns)
设置此文本字段中的列数。列是近似平均字符宽度，它与平台有关。

参数：
columns - 列数。
抛出：
IllegalArgumentException - 如果为 columns 提供的值小于 0。
从以下版本开始：
JDK1.1
另请参见：
getColumns()

getPreferredSize

public Dimension getPreferredSize(int columns)
获取具有指定列数的文本字段的首选大小。

参数：
columns - 此文本字段中的列数。
返回：
显示此文本字段的首选尺寸。
从以下版本开始：
JDK1.1

preferredSize

@Deprecated
public Dimension preferredSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。

getPreferredSize

public Dimension getPreferredSize()
获取此文本字段的首选大小。

覆盖：
类 Component 中的 getPreferredSize
返回：
显示此文本字段的首选尺寸。
从以下版本开始：
JDK1.1
另请参见：
Component.getMinimumSize(), LayoutManager

preferredSize

@Deprecated
public Dimension preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。

覆盖：
类 Component 中的 preferredSize

getMinimumSize

public Dimension getMinimumSize(int columns)
获取具有指定列数的文本字段的最小尺寸。

参数：
columns - 此文本字段中的列数。
从以下版本开始：
JDK1.1

minimumSize

@Deprecated
public Dimension minimumSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。

getMinimumSize

public Dimension getMinimumSize()
获取此文本字段的最小尺寸。

覆盖：
类 Component 中的 getMinimumSize
返回：
显示此文本字段的最小尺寸。
从以下版本开始：
JDK1.1
另请参见：
Component.getPreferredSize(), LayoutManager

minimumSize

@Deprecated
public Dimension minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。

覆盖：
类 Component 中的 minimumSize

addActionListener

public void addActionListener(ActionListener l)
添加指定的操作侦听器，以从此文本字段接收操作事件。如果 l 为 null，则不抛出任何异常，也不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 操作侦听器。
从以下版本开始：
JDK1.1
另请参见：
removeActionListener(java.awt.event.ActionListener), getActionListeners(), ActionListener

removeActionListener

public void removeActionListener(ActionListener l)
移除指定的操作侦听器，不再从此文本字段接收操作事件。如果 l 为 null，则不抛出任何异常，也不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 操作侦听器。
从以下版本开始：
JDK1.1
另请参见：
addActionListener(java.awt.event.ActionListener), getActionListeners(), ActionListener

getActionListeners

public ActionListener[] getActionListeners()
返回此文本字段上已注册的所有操作侦听器的数组。

返回：
此文本字段的所有 ActionListener；如果当前没有注册任何操作侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener), java.awt.event

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值（如 FooListener.class）来指定 listenerType 参数。例如，可以使用以下代码来查询 TextField t 的操作侦听器：

ActionListener[] als = (ActionListener[])(t.getListeners(ActionListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 TextComponent 中的 getListeners
参数：
listenerType - 所请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此文本字段上作为 FooListener 注册的所有对象的数组；如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getActionListeners()

processEvent

protected void processEvent(AWTEvent e)
处理此文本字段上的事件。如果事件是 ActionEvent 的一个实例，则此方法将调用 processActionEvent 方法。否则，它将调用超类的 processEvent 方法。

注意，如果事件参数为 null，则行为是不明确的，并可能导致异常。

覆盖：
类 TextComponent 中的 processEvent
参数：
e - 事件
从以下版本开始：
JDK1.1
另请参见：
ActionEvent, processActionEvent(java.awt.event.ActionEvent)

processActionEvent

protected void processActionEvent(ActionEvent e)
处理发生在此文本字段上的操作事件：将这些事件指派给所有已注册的 ActionListener 对象。

只有此组件启用了操作事件时，才调用此方法。发生以下事件之一时将启用操作事件：

  • ActionListener 对象通过 addActionListener 注册。
  • 操作事件通过 enableEvents 启用。

注意，如果事件参数为 null，则行为是不明确的，并可能导致异常。

参数：
e - 操作事件
从以下版本开始：
JDK1.1
另请参见：
ActionListener, addActionListener(java.awt.event.ActionListener), Component.enableEvents(long)

paramString

protected String paramString()
返回表示此 TextField 状态的字符串。此方法仅用于调试目的，对于各个实现，返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 TextComponent 中的 paramString
返回：
此文本字段的参数字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 TextField 关联的 AccessibleContext。对于文本字段，AccessibleContext 采用 AccessibleAWTTextField 的形式。如有必要，可创建一个新的 AccessibleAWTTextField 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 TextComponent 中的 getAccessibleContext
返回：
一个 AccessibleAWTTextField，它充当此 TextField 的 AccessibleContext。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextField.AccessibleAWTTextField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TextField.AccessibleAWTTextField

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.TextComponent.AccessibleAWTTextComponent
                继承者  java.awt.TextField.AccessibleAWTTextField
所有已实现的接口：
TextListener, Serializable, EventListener, AccessibleComponent, AccessibleText
正在封闭类：
TextField
protected class TextField.AccessibleAWTTextField
extends TextComponent.AccessibleAWTTextComponent

此类实现 TextField 类的可访问性支持。它提供适合于文本字段用户界面元素的 Java Accessibility API 的实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected TextField.AccessibleAWTTextField()
方法摘要
 AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。
从类 java.awt.TextComponent.AccessibleAWTTextComponent 继承的方法
getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, textValueChanged
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TextField.AccessibleAWTTextField

protected TextField.AccessibleAWTTextField()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 TextComponent.AccessibleAWTTextComponent 中的 getAccessibleStateSet
返回：
描述对象状态的 AccessibleStateSet 实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TexturePaint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TexturePaint

java.lang.Object
    继承者  java.awt.TexturePaint
所有已实现的接口：
Paint, Transparency
public class TexturePaint
extends Object
implements Paint

TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。因为 BufferedImage 数据由 TexturePaint 对象复制，所以 BufferedImage 对象的大小应该小一些。在构造时，纹理定位在用户空间中指定的 Rectangle2D 的左上角。在理论上，计算纹理在设备空间中的位置的方式是，在用户空间中的所有方向上无限制地复制指定 Rectangle2D，然后将 BufferedImage 映射到各个复制的 Rectangle2D。

另请参见：
Paint, Graphics2D.setPaint(java.awt.Paint)

字段摘要
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
TexturePaint(BufferedImage txtr, Rectangle2D anchor)
构造 TexturePaint 对象。
方法摘要
PaintContext | createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
Rectangle2D | getAnchorRect() 返回定位纹理图像并设置其大小的固定矩形的副本。
BufferedImage | getImage() 返回用于填充形状的 BufferedImage 纹理。
int | getTransparency() 返回此 TexturePaint 的透明模式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TexturePaint

public TexturePaint(BufferedImage txtr,
                    Rectangle2D anchor)
构造 TexturePaint 对象。

参数：
txtr - 具有用于绘制的纹理的 BufferedImage 对象
anchor - 用户空间中用于定位和复制纹理的 Rectangle2D
方法详细信息

getImage

public BufferedImage getImage()
返回用于填充形状的 BufferedImage 纹理。

返回：
一个 BufferedImage。

getAnchorRect

public Rectangle2D getAnchorRect()
返回定位纹理图像并设置其大小的固定矩形的副本。

返回：
用来将此 TexturePaint 固定并设置其大小的 Rectangle2D。

createContext

public PaintContext createContext(ColorModel cm,
                                  Rectangle deviceBounds,
                                  Rectangle2D userBounds,
                                  AffineTransform xform,
                                  RenderingHints hints)
创建并返回用于生成颜色模式的上下文。

指定者：
接口 Paint 中的 createContext
参数：
cm - 接收 Paint 数据的 ColorModel。此参数只用作一个提示。
deviceBounds - 要呈现的图形原语的设备空间边界框
userBounds - 要呈现的图形原语的用户空间边界框
xform - 从用户空间到设备空间的 AffineTransform
hints - 可用于指定模式的最终呈现方式的 RenderingHints 对象
返回：
用于生成颜色模式的 PaintContext。
另请参见：
PaintContext

getTransparency

public int getTransparency()
返回此 TexturePaint 的透明模式。

指定者：
接口 Transparency 中的 getTransparency
返回：
整数值形式的此 TexturePaint 的透明模式。
另请参见：
Transparency
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Toolkit (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Toolkit

java.lang.Object
    继承者  java.awt.Toolkit

public abstract class Toolkit
extends Object

此类是所有 Abstract Window Toolkit 实际实现的抽象超类。Toolkit 的子类被用于将各种组件绑定到特定本机工具包实现。

许多 GUI 操作可以异步执行。这意味着如果设置某一组件的状态，随后立刻查询该状态，则返回的值可能并没有反映所请求的更改。这包括但不局限于以下操作：

  • 滚动到指定位置。
    例如，如果原始请求没有被处理，那么调用 ScrollPane.setScrollPosition 并随后调用 getScrollPosition 可能返回一个不正确的值。

  • 将焦点从一个组件移动到另一个组件。
    有关更多信息，请参阅 The Swing Tutorial 的 Timing Focus Transfers 一节。

  • 使顶层容器可见。
    对 Window、Frame 或 Dialog 调用 setVisible(true) 可能异步发生。

  • 设置顶层容器的大小或位置。
    对 Window、Frame 或 Dialog 调用 setSize、setBounds 或 setLocation 将被转发到底层窗口管理系统，并可能被忽略或修改。有关更多信息，请参阅 Window。

大多数应用程序不应直接调用该类中的任何方法。Toolkit 定义的方法是一种“胶水”，将 java.awt 包中与平台无关的类与 java.awt.peer 中的对应物连接起来。Toolkit 定义的一些方法能直接查询本机操作系统。

从以下版本开始：
JDK1.0

字段摘要
protected Map<String,Object> | desktopProperties
protected PropertyChangeSupport | desktopPropsSupport
构造方法摘要
Toolkit()
方法摘要
 void addAWTEventListener(AWTEventListener listener, long eventMask)
添加一个 AWTEventListener，以接收与给定 eventMask 一致的系统范围内指派的所有 AWTEvent。
 void addPropertyChangeListener(String name, PropertyChangeListener pcl)
为指定的桌面属性添加指定的属性更改侦听器。
abstract  void beep()
发出一个音频嘟嘟声。
abstract  int checkImage(Image image, int width, int height, ImageObserver observer)
指示正准备显示的指定图像的构造状态。
protected abstract  java.awt.peer.ButtonPeer createButton(Button target)
使用指定同位体接口创建此工具包的 Button 实现。
protected abstract  java.awt.peer.CanvasPeer createCanvas(Canvas target)
使用指定同位体接口创建此工具包的 Canvas 实现。
protected abstract  java.awt.peer.CheckboxPeer createCheckbox(Checkbox target)
使用指定同位体接口创建此工具包的 Checkbox 实现。
protected abstract  java.awt.peer.CheckboxMenuItemPeer createCheckboxMenuItem(CheckboxMenuItem target)
使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。
protected abstract  java.awt.peer.ChoicePeer createChoice(Choice target)
使用指定同位体接口创建此工具包的 Choice 实现。
protected  java.awt.peer.LightweightPeer createComponent(Component target)
创建组件或容器的同位体。
 Cursor createCustomCursor(Image cursor, Point hotSpot, String name)
创建一个新的自定义光标对象。
protected abstract  java.awt.peer.DesktopPeer createDesktopPeer(Desktop target)
使用指定的同位体接口创建此工具包的 Desktop 实现。
protected abstract  java.awt.peer.DialogPeer createDialog(Dialog target)
使用指定同位体接口创建此工具包的 Dialog 实现。
<T extends DragGestureRecognizer>
T
createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。
abstract  java.awt.dnd.peer.DragSourceContextPeer createDragSourceContextPeer(DragGestureEvent dge)
创建 DragSourceContext 的同位体。
protected abstract  java.awt.peer.FileDialogPeer createFileDialog(FileDialog target)
使用指定同位体接口创建此工具包的 FileDialog 实现。
protected abstract  java.awt.peer.FramePeer createFrame(Frame target)
使用指定同位体接口创建此工具包的 Frame 实现。
 Image createImage(byte[] imagedata)
创建一幅图像，该图像对存储在指定字节数组中的图像进行解码。
abstract  Image createImage(byte[] imagedata, int imageoffset, int imagelength)
创建一幅图像，该图像对存储在指定字节数组中指定偏移量和长度处的图像进行解码。
abstract  Image createImage(ImageProducer producer)
使用指定的图像生成器创建一幅图像。
abstract  Image createImage(String filename)
返回从指定文件获取像素数据的图像。
abstract  Image createImage(URL url)
返回一幅图像，该图像从指定 URL 获取像素数据。
protected abstract  java.awt.peer.LabelPeer createLabel(Label target)
使用指定同位体接口创建此工具包的 Label 实现。
protected abstract  java.awt.peer.ListPeer createList(List target)
使用指定同位体接口创建此工具包的 List 实现。
protected abstract  java.awt.peer.MenuPeer createMenu(Menu target)
使用指定同位体接口创建此工具包的 Menu 实现。
protected abstract  java.awt.peer.MenuBarPeer createMenuBar(MenuBar target)
使用指定同位体接口创建此工具包的 MenuBar 实现。
protected abstract  java.awt.peer.MenuItemPeer createMenuItem(MenuItem target)
使用指定同位体接口创建此工具包的 MenuItem 实现。
protected abstract  java.awt.peer.PanelPeer createPanel(Panel target)
使用指定同位体接口创建此工具包的 Panel 实现。
protected abstract  java.awt.peer.PopupMenuPeer createPopupMenu(PopupMenu target)
使用指定同位体接口创建此工具包的 PopupMenu 实现。
protected abstract  java.awt.peer.ScrollbarPeer createScrollbar(Scrollbar target)
使用指定同位体接口创建此工具包的 Scrollbar 实现。
protected abstract  java.awt.peer.ScrollPanePeer createScrollPane(ScrollPane target)
使用指定同位体接口创建此工具包的 ScrollPane 实现。
protected abstract  java.awt.peer.TextAreaPeer createTextArea(TextArea target)
使用指定同位体接口创建此工具包的 TextArea 实现。
protected abstract  java.awt.peer.TextFieldPeer createTextField(TextField target)
使用指定同位体接口创建此工具包的 TextField 实现。
protected abstract  java.awt.peer.WindowPeer createWindow(Window target)
使用指定同位体接口创建此工具包的 Window 实现。
 AWTEventListener[] getAWTEventListeners()
返回在此工具包上所有已注册 AWTEventListener 所组成的数组。
 AWTEventListener[] getAWTEventListeners(long eventMask)
返回已在此工具包上注册的所有 AWTEventListener 所组成的数组，这些侦听器侦听用 eventMask 参数指定的所有事件类型。
 Dimension getBestCursorSize(int preferredWidth, int preferredHeight)
返回最接近所需大小的受支持光标尺寸。
abstract  ColorModel getColorModel()
确定此工具包屏幕的颜色模型。
static Toolkit getDefaultToolkit()
获取默认工具包。
 Object getDesktopProperty(String propertyName)
获取指定桌面属性的值。
abstract  String[] getFontList()
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()
abstract  FontMetrics getFontMetrics(Font font)
已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
protected abstract  java.awt.peer.FontPeer getFontPeer(String name, int style)
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts
abstract  Image getImage(String filename)
返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。
abstract  Image getImage(URL url)
返回一幅图像，该图像从指定 URL 获取像素数据。
 boolean getLockingKeyState(int keyCode)
返回键盘上给定锁定键是否处于 "on" 状态。
 int getMaximumCursorColors()
返回自定义光标调色板中 Toolkit 支持的最大颜色数。
 int getMenuShortcutKeyMask()
确定哪一个修改键是菜单快捷方式的适当加速键。
protected  java.awt.peer.MouseInfoPeer getMouseInfoPeer()
使用指定同位体接口创建此工具包的 MouseInfo 实现。
protected static Container getNativeContainer(Component c)
使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。
 PrintJob getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
abstract  PrintJob getPrintJob(Frame frame, String jobtitle, Properties props)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
static String getProperty(String key, String defaultValue)
获取具有指定键和默认值的属性。
 PropertyChangeListener[] getPropertyChangeListeners()
返回在此工具包上所有已注册的属性更改侦听器所组成的数组。
 PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。
 Insets getScreenInsets(GraphicsConfiguration gc)
获得屏幕的 insets。
abstract  int getScreenResolution()
返回屏幕分辨率，以每英寸的点数为单位。
abstract  Dimension getScreenSize()
获取屏幕的大小。
abstract  Clipboard getSystemClipboard()
获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。
 EventQueue getSystemEventQueue()
获取应用程序或 applet 的 EventQueue 实例。
protected abstract  EventQueue getSystemEventQueueImpl()
获取应用程序或 applet 的 EventQueue 实例，不检查访问权。
 Clipboard getSystemSelection()
以 Clipboard 对象的形式获取系统选择的一个实例。
protected  void initializeDesktopProperties()
initializeDesktopProperties
 boolean isAlwaysOnTopSupported()
返回此工具包是否支持 always-on-top 模式。
 boolean isDynamicLayoutActive()
返回当前是否激活了调整大小时的动态布局（以编程方式设置，并受底层操作系统和/或窗口管理器支持）。
protected  boolean isDynamicLayoutSet()
返回 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
 boolean isFrameStateSupported(int state)
返回 Toolkit 是否支持 Frame 状态。
abstract  boolean isModalExclusionTypeSupported(Dialog.ModalExclusionType modalExclusionType)
返回此工具包是否支持给定的模式排斥类型。
abstract  boolean isModalityTypeSupported(Dialog.ModalityType modalityType)
返回此工具包是否支持给定的模式类型。
protected  Object lazilyLoadDesktopProperty(String name)
一个对桌面属性值延迟计算的机会。
protected  void loadSystemColors(int[] systemColors)
使用当前系统颜色值填充作为参数提供的整数数组。
abstract  Map<TextAttribute,?> mapInputMethodHighlight(InputMethodHighlight highlight)
返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。
abstract  boolean prepareImage(Image image, int width, int height, ImageObserver observer)
准备一个用于呈现的图像。
 void removeAWTEventListener(AWTEventListener listener)
从正接收的指派 AWTEvent 中移除一个 AWTEventListener。
 void removePropertyChangeListener(String name, PropertyChangeListener pcl)
为指定的桌面属性移除指定的属性更改侦听器。
protected  void setDesktopProperty(String name, Object newValue)
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。
 void setDynamicLayout(boolean dynamic)
控制 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
 void setLockingKeyState(int keyCode, boolean on)
设置键盘上给定锁定键的状态。
abstract  void sync()
同步此工具包的图形状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

desktopProperties

protected final Map<String,Object> desktopProperties

desktopPropsSupport

protected final PropertyChangeSupport desktopPropsSupport
构造方法详细信息

Toolkit

public Toolkit()
方法详细信息

createDesktopPeer

protected abstract java.awt.peer.DesktopPeer createDesktopPeer(Desktop target)
                                                        throws HeadlessException
使用指定的同位体接口创建此工具包的 Desktop 实现。

参数：
target - 要实现的 Desktop
返回：
此工具包的 Desktop 实现
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.6
另请参见：
GraphicsEnvironment.isHeadless(), Desktop, DesktopPeer

createButton

protected abstract java.awt.peer.ButtonPeer createButton(Button target)
                                                  throws HeadlessException
使用指定同位体接口创建此工具包的 Button 实现。

参数：
target - 要实现的按钮。
返回：
此工具包的 Button 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Button, ButtonPeer

createTextField

protected abstract java.awt.peer.TextFieldPeer createTextField(TextField target)
                                                        throws HeadlessException
使用指定同位体接口创建此工具包的 TextField 实现。

参数：
target - 要实现的文本字段。
返回：
此工具包的 TextField 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), TextField, TextFieldPeer

createLabel

protected abstract java.awt.peer.LabelPeer createLabel(Label target)
                                                throws HeadlessException
使用指定同位体接口创建此工具包的 Label 实现。

参数：
target - 要实现的标签。
返回：
此工具包的 Label 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Label, LabelPeer

createList

protected abstract java.awt.peer.ListPeer createList(List target)
                                              throws HeadlessException
使用指定同位体接口创建此工具包的 List 实现。

参数：
target - 要实现的列表。
返回：
此工具包的 List 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), List, ListPeer

createCheckbox

protected abstract java.awt.peer.CheckboxPeer createCheckbox(Checkbox target)
                                                      throws HeadlessException
使用指定同位体接口创建此工具包的 Checkbox 实现。

参数：
target - 要实现的复选框。
返回：
此工具包的 Checkbox 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Checkbox, CheckboxPeer

createScrollbar

protected abstract java.awt.peer.ScrollbarPeer createScrollbar(Scrollbar target)
                                                        throws HeadlessException
使用指定同位体接口创建此工具包的 Scrollbar 实现。

参数：
target - 要实现的滚动条。
返回：
此工具包的 Scrollbar 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Scrollbar, ScrollbarPeer

createScrollPane

protected abstract java.awt.peer.ScrollPanePeer createScrollPane(ScrollPane target)
                                                          throws HeadlessException
使用指定同位体接口创建此工具包的 ScrollPane 实现。

参数：
target - 要实现的滚动窗格。
返回：
此工具包的 ScrollPane 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless(), ScrollPane, ScrollPanePeer

createTextArea

protected abstract java.awt.peer.TextAreaPeer createTextArea(TextArea target)
                                                      throws HeadlessException
使用指定同位体接口创建此工具包的 TextArea 实现。

参数：
target - 要实现的文本字区域。
返回：
此工具包的 TextArea 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), TextArea, TextAreaPeer

createChoice

protected abstract java.awt.peer.ChoicePeer createChoice(Choice target)
                                                  throws HeadlessException
使用指定同位体接口创建此工具包的 Choice 实现。

参数：
target - 要实现的选择。
返回：
此工具包的 Choice 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Choice, ChoicePeer

createFrame

protected abstract java.awt.peer.FramePeer createFrame(Frame target)
                                                throws HeadlessException
使用指定同位体接口创建此工具包的 Frame 实现。

参数：
target - 要实现的窗体。
返回：
此工具包的 Frame 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Frame, FramePeer

createCanvas

protected abstract java.awt.peer.CanvasPeer createCanvas(Canvas target)
使用指定同位体接口创建此工具包的 Canvas 实现。

参数：
target - 要实现的画布。
返回：
此工具包的 Canvas 实现。
另请参见：
Canvas, CanvasPeer

createPanel

protected abstract java.awt.peer.PanelPeer createPanel(Panel target)
使用指定同位体接口创建此工具包的 Panel 实现。

参数：
target - 要实现的面板。
返回：
此工具包的 Panel 实现。
另请参见：
Panel, PanelPeer

createWindow

protected abstract java.awt.peer.WindowPeer createWindow(Window target)
                                                  throws HeadlessException
使用指定同位体接口创建此工具包的 Window 实现。

参数：
target - 要实现的窗口。
返回：
此工具包的 Window 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Window, WindowPeer

createDialog

protected abstract java.awt.peer.DialogPeer createDialog(Dialog target)
                                                  throws HeadlessException
使用指定同位体接口创建此工具包的 Dialog 实现。

参数：
target - 要实现的对话框。
返回：
此工具包的 Dialog 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Dialog, DialogPeer

createMenuBar

protected abstract java.awt.peer.MenuBarPeer createMenuBar(MenuBar target)
                                                    throws HeadlessException
使用指定同位体接口创建此工具包的 MenuBar 实现。

参数：
target - 要实现的菜单栏。
返回：
此工具包的 MenuBar 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), MenuBar, MenuBarPeer

createMenu

protected abstract java.awt.peer.MenuPeer createMenu(Menu target)
                                              throws HeadlessException
使用指定同位体接口创建此工具包的 Menu 实现。

参数：
target - 要实现的菜单。
返回：
此工具包的 Menu 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), Menu, MenuPeer

createPopupMenu

protected abstract java.awt.peer.PopupMenuPeer createPopupMenu(PopupMenu target)
                                                        throws HeadlessException
使用指定同位体接口创建此工具包的 PopupMenu 实现。

参数：
target - 要实现的弹出菜单。
返回：
此工具包的 PopupMenu 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless(), PopupMenu, PopupMenuPeer

createMenuItem

protected abstract java.awt.peer.MenuItemPeer createMenuItem(MenuItem target)
                                                      throws HeadlessException
使用指定同位体接口创建此工具包的 MenuItem 实现。

参数：
target - 要实现的菜单项。
返回：
此工具包的 MenuItem 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), MenuItem, MenuItemPeer

createFileDialog

protected abstract java.awt.peer.FileDialogPeer createFileDialog(FileDialog target)
                                                          throws HeadlessException
使用指定同位体接口创建此工具包的 FileDialog 实现。

参数：
target - 要实现的文件对话框。
返回：
此工具包的 FileDialog 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), FileDialog, FileDialogPeer

createCheckboxMenuItem

protected abstract java.awt.peer.CheckboxMenuItemPeer createCheckboxMenuItem(CheckboxMenuItem target)
                                                                      throws HeadlessException
使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。

参数：
target - 要实现的复选菜单项。
返回：
此工具包的 CheckboxMenuItem 实现。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), CheckboxMenuItem, CheckboxMenuItemPeer

getMouseInfoPeer

protected java.awt.peer.MouseInfoPeer getMouseInfoPeer()
使用指定同位体接口创建此工具包的 MouseInfo 实现。

返回：
此工具包的 MouseInfo 的帮助器实现
抛出：
UnsupportedOperationException - 如果没有实现此操作
从以下版本开始：
1.5
另请参见：
MouseInfoPeer, MouseInfo

createComponent

protected java.awt.peer.LightweightPeer createComponent(Component target)
创建组件或容器的同位体。此同位体是无窗口的，允许直接扩展 Component 和 Container 类，以创建完全在 Java 中定义的无窗口组件。

参数：
target - 要创建的 Component。

getFontPeer

@Deprecated
protected abstract java.awt.peer.FontPeer getFontPeer(String name,
                                                                 int style)
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts

使用指定同位体接口创建此工具包的 Font 实现。

参数：
name - 要实现的字体
style - 字体样式，比如 PLAIN、BOLD、ITALIC 或它们的组合
返回：
此工具包的 Font 实现
另请参见：
Font, FontPeer, GraphicsEnvironment.getAllFonts()

loadSystemColors

protected void loadSystemColors(int[] systemColors)
                         throws HeadlessException
使用当前系统颜色值填充作为参数提供的整数数组。

参数：
systemColors - 一个整数数组。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless()

setDynamicLayout

public void setDynamicLayout(boolean dynamic)
                      throws HeadlessException
控制 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。注意，并非所有平台都支持此功能，反之，在某些平台上不能关闭此功能。在不支持（或总是支持）调整大小期间动态布局的平台上设置此属性无效。注意，在某些平台上，此功能可以作为操作系统或窗口管理器的一个属性来设置或取消设置。在这种平台上，在此方法生效前，必须在操作系统或窗口管理器级别上设置动态调整大小的属性。此方法不能改变底层操作系统或窗口管理器的支持或设置。使用 getDesktopProperty("awt.dynamicLayoutSupported") 可以查询 OS/WM 支持。

参数：
dynamic - 如果该参数为 true，则在调整 Container 大小时重新布置其组件。如果该参数为 false，则布局将在重新调整大小后生效。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
isDynamicLayoutSet(), isDynamicLayoutActive(), getDesktopProperty(String propertyName), GraphicsEnvironment.isHeadless()

isDynamicLayoutSet

protected boolean isDynamicLayoutSet()
                              throws HeadlessException
返回 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。注：此方法返回的值是以编程方式设置的，不会影响调整大小时对动态布局的操作系统或窗口管理器级的支持，也不会影响当前操作系统或窗口管理器设置。使用 getDesktopProperty("awt.dynamicLayoutSupported") 可以查询 OS/WM 支持。

返回：
如果动态地使 Container 有效，则返回 true，如果在结束对大小的调整后使 Containers 有效，则返回 false。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
setDynamicLayout(boolean dynamic), isDynamicLayoutActive(), getDesktopProperty(String propertyName), GraphicsEnvironment.isHeadless()

isDynamicLayoutActive

public boolean isDynamicLayoutActive()
                              throws HeadlessException
返回当前是否激活了调整大小时的动态布局（以编程方式设置，并受底层操作系统和/或窗口管理器支持）。使用 getDesktopProperty("awt.dynamicLayoutSupported") 可以查询 OS/WM 支持。

返回：
如果当前激活了调整大小时的动态布局，则返回 true；否则返回 false。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
setDynamicLayout(boolean dynamic), isDynamicLayoutSet(), getDesktopProperty(String propertyName), GraphicsEnvironment.isHeadless()

getScreenSize

public abstract Dimension getScreenSize()
                                 throws HeadlessException
获取屏幕的大小。在具有多个显示屏的系统上，使用主显示屏。从 GraphicsConfiguration 和 GraphicsDevice 可以获得多屏幕感知显示尺寸。

返回：
此工具包的屏幕大小，以像素为单位。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsConfiguration.getBounds(),
GraphicsDevice.getDisplayMode(),
GraphicsEnvironment.isHeadless()

getScreenResolution

public abstract int getScreenResolution()
                                 throws HeadlessException
返回屏幕分辨率，以每英寸的点数为单位。

返回：
此工具包的屏幕分辨率，以每英寸的点数为单位。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

getScreenInsets

public Insets getScreenInsets(GraphicsConfiguration gc)
                       throws HeadlessException
获得屏幕的 insets。

参数：
gc - 一个 GraphicsConfiguration
返回：
此工具包屏幕的 insets，以像素为单位。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()

getColorModel

public abstract ColorModel getColorModel()
                                  throws HeadlessException
确定此工具包屏幕的颜色模型。

ColorModel 是一个抽象类，封装了图像的像素值及其红色、绿色、蓝色和 alpha 组件之间的转换能力。

此工具包方法由 Component 类的 getColorModel 方法调用。

返回：
此工具包屏幕的颜色模型。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless(), ColorModel, Component.getColorModel()

getFontList

@Deprecated
public abstract String[] getFontList()
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()

返回此工具包中可用字体的名称。

在 1.1 中，以下字体名称已经过时，括号内是替代名称：

  • TimesRoman（使用 Serif 替代）
  • Helvetica（使用 SansSerif 替代）
  • Courier（使用 Monospaced 替代）

在 1.1 中字体名称 ZapfDingbats 也已经过时，但 Unicode 中定义的字符从 0x2700 开始。从 1.1 开始，Java 支持这些字符。

返回：
此工具包中可用字体的名称。
另请参见：
GraphicsEnvironment.getAvailableFontFamilyNames()

getFontMetrics

@Deprecated
public abstract FontMetrics getFontMetrics(Font font)
已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。

获取呈现字体的屏幕设备规格。

参数：
font - 字体
返回：
此工具包中指定字体的屏幕规格
另请参见：
LineMetrics, Font.getLineMetrics(java.lang.String, java.awt.font.FontRenderContext), GraphicsEnvironment.getScreenDevices()

sync

public abstract void sync()
同步此工具包的图形状态。某些窗口系统可能会缓存图形事件。

此方法确保显示是最新的。这在动画制作时很有用。

getDefaultToolkit

public static Toolkit getDefaultToolkit()
获取默认工具包。

如果名为 "java.awt.headless" 的系统属性被设置为 true，则使用 Toolkit 的 headless 实现。

如果不存在 "java.awt.headless" 或 "java.awt.headless" 被设置为 false，且存在名为 "awt.toolkit" 的系统属性，则该属性将被视为 Toolkit 子类的名称；否则将使用特定于平台的默认 Toolkit 实现。

还可以使用 Sun 引用实现中指定的属性 'assistive_technologies' 将其他类加载到 VM 中，该属性是在 'accessibility.properties' 文件的一个行中指定的。形式是 "assistive_technologies=..."，其中 "..." 是以逗号分隔的、要加载的辅助技术类的列表。每个类都以给定的顺序加载，并且要使用 Class.forName(class).newInstance() 创建每个类的单独实例。此操作在创建 AWT 工具包之后进行。所有错误都通过 AWTError 异常来处理。

返回：
默认工具包。
抛出：
AWTError - 如果不能找到工具包，或者不能访问或实例化工具包。

getImage

public abstract Image getImage(String filename)
返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。底层工具包试图对具有相同文件名的多个请求返回相同的 Image。

因为便利 Image 对象共享所需的机制可能在一段不明确的时间内继续保存不再使用的图像，所以鼓励开发者在所有可能的地方使用 createImage 变体实现自己的图像缓存。 如果包含在指定文件中的图像数据发生了更改，则此方法返回的 Image 对象仍然包含前一个调用之后从该文件加载的旧信息。 通过对返回的 Image 调用 flush 方法，可以手动丢弃以前加载的信息。

此方法首先检查是否安装了安全管理器。 如果安装了安全管理器，则该方法使用指定的文件调用安全管理器的 checkRead 方法，以确保允许访问该图像。

参数：
filename - 以可识别文件格式包含像素数据的文件名。
返回：
从指定文件中获取像素数据的图像。
抛出：
SecurityException - 如果存在安全管理器且其 checkListen 方法不允许该操作。
另请参见：
createImage(java.lang.String)

getImage

public abstract Image getImage(URL url)
返回一幅图像，该图像从指定 URL 获取像素数据。通过指定 URL 引用的像素数据必须使用以下格式之一：GIF、JPEG 或 PNG。底层工具包试图对具有相同 URL 的多个请求返回相同的 Image。

因为便利 Image 对象共享所需的机制可能在一段不明确的时间内继续保存不再使用的图像，所以鼓励开发者在所有可能的地方使用 createImage 变体实现自己的图像缓存。 如果包含在指定 URL 中的图像数据发生了更改，则此方法返回的 Image 对象仍然包含前一个调用之后从该 URL 加载的旧信息。 通过对返回的 Image 调用 flush 方法，可以手动丢弃以前加载的信息。

此方法首先检查是否安装了安全管理器。 如果安装了安全管理器，则该方法通过 url.openConnection().getPermission() 权限调用安全管理器的 checkRead 方法，以确保允许访问该图像。为了与 1.2 以前的安全管理器兼容，如果通过 FilePermission 或 SocketPermission 的访问被拒绝，而对应的 1.1 样式的 SecurityManager.checkXXX 也拒绝访问，则该方法抛出 SecurityException。

参数：
url - 用来获取像素数据的 URL。
返回：
从指定 URL 获取像素数据的图像。
抛出：
SecurityException - 如果存在安全管理器且其 checkPermission 方法不允许该操作。
另请参见：
createImage(java.net.URL)

createImage

public abstract Image createImage(String filename)
返回从指定文件获取像素数据的图像。返回的 Image 是一个新对象，该对象不再由此方法的其他任何调用者或其 getImage 变体共享。

此方法首先检查是否安装了安全管理器。如果安装了安全管理器，则该方法使用指定的文件调用安全管理器的 checkRead 方法，以确保允许创建该图像。

参数：
filename - 以可识别文件格式包含像素数据的文件名。
返回：
从指定文件获取像素数据的图像。
抛出：
SecurityException - 如果存在安全管理器且其 checkRead 方法不允许该操作。
另请参见：
getImage(java.lang.String)

createImage

public abstract Image createImage(URL url)
返回一幅图像，该图像从指定 URL 获取像素数据。返回的 Image 是一个新对象，该对象不再由此方法的其他任何调用者或其 getImage 变体共享。

此方法首先检查是否安装了安全管理器。如果安装了安全管理器，则该方法通过 url.openConnection().getPermission() 权限调用安全管理器的 checkPermission 方法，以确保允许创建图像。为了与 1.2 以前的安全管理器兼容，如果通过 FilePermission 或 SocketPermission 的访问被拒绝，而对应的 1.1 样式的 SecurityManager.checkXXX 也拒绝访问，则该方法抛出 SecurityException。

参数：
url - 用来获取像素数据的 URL。
返回：
从指定 URL 获取像素数据的图像。
抛出：
SecurityException - 如果存在安全管理器且其 checkPermission 方法不允许该操作。
另请参见：
getImage(java.net.URL)

prepareImage

public abstract boolean prepareImage(Image image,
                                     int width,
                                     int height,
                                     ImageObserver observer)
准备一个用于呈现的图像。

如果 width 和 height 参数的值均为 -1，则此方法在默认屏幕上准备一个用于呈现的图像；否则此方法在默认屏幕上以指定宽度和高度准备一个用于呈现的图像。

图像数据由另一个线程异步下载，并将生成适当缩放的图像屏幕表示形式。

此方法由组件的 prepareImage 方法调用。

可在 ImageObserver 接口的定义中找到有关此方法返回的标志的信息。

参数：
image - 准备屏幕显示的图像。
width - 需要的屏幕显示宽度，或为 -1。
height - 需要的屏幕显示高度，或为 -1。
observer - 在准备图像时要通知的 ImageObserver 对象。
返回：
如果已完全准备好了图像，则返回 true；否则返回 false。
另请参见：
Component.prepareImage(java.awt.Image, java.awt.image.ImageObserver), Component.prepareImage(java.awt.Image, int, int, java.awt.image.ImageObserver), ImageObserver

checkImage

public abstract int checkImage(Image image,
                               int width,
                               int height,
                               ImageObserver observer)
指示正准备显示的指定图像的构造状态。

如果 width 和 height 参数的值均为 -1，则此方法返回此工具包中指定图像屏幕表示形式的构造状态。否则，此方法以指定宽度和高度返回图像缩放表示形式的构造状态。

此方法不会导致开始加载图像。应用程序必须调用 prepareImage 来强制加载图像。

此方法由组件的 checkImage 方法调用。

可在 ImageObserver 接口的定义中找到有关此方法返回的标志的信息。

参数：
image - 要检查状态的图像。
width - 要检查状态的图像的缩放宽度，或为 -1。
height - 要检查状态的图像的缩放高度，或为 -1。
observer - 在准备图像时要通知的 ImageObserver 对象。
返回：
当前可用图像数据的 ImageObserver 标志的逐位 OR。
另请参见：
prepareImage(java.awt.Image, int, int, java.awt.image.ImageObserver),
Component.checkImage(java.awt.Image, java.awt.image.ImageObserver),
Component.checkImage(java.awt.Image, int, int, java.awt.image.ImageObserver),
ImageObserver

createImage

public abstract Image createImage(ImageProducer producer)
使用指定的图像生成器创建一幅图像。

参数：
producer - 要使用的图像生成器。
返回：
使用指定图像生成器创建的图像。
另请参见：
Image, ImageProducer, Component.createImage(java.awt.image.ImageProducer)

createImage

public Image createImage(byte[] imagedata)
创建一幅图像，该图像对存储在指定字节数组中的图像进行解码。

数据必须使用此工具包支持的图像格式存储，比如 GIF 或 JPEG。

参数：
imagedata - 字节数组，表示用受支持图像格式存储的图像数据。
返回：
一幅图像。
从以下版本开始：
JDK1.1

createImage

public abstract Image createImage(byte[] imagedata,
                                  int imageoffset,
                                  int imagelength)
创建一幅图像，该图像对存储在指定字节数组中指定偏移量和长度处的图像进行解码。数据必须用受此工具包支持的图像格式存储，比如 GIF 或 JPEG。

参数：
imagedata - 字节数组，表示用受支持图像格式存储的图像。
imageoffset - 数组中数据开始的偏移量。
imagelength - 数组中数据的长度。
返回：
一幅图像。
从以下版本开始：
JDK1.1

getPrintJob

public abstract PrintJob getPrintJob(Frame frame,
                                     String jobtitle,
                                     Properties props)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

此方法的每个实际实现都应该先检查是否安装了安全管理器。如果安装了安全管理器，则该方法应该调用安全管理器的 checkPrintJobAccess 方法，以确保允许初始化打印操作。如果使用 checkPrintJobAccess 的默认实现（即未重写该方法），则将导致使用 RuntimePermission("queuePrintJob") 权限调用安全管理器的 checkPermission 方法。

参数：
frame - 打印对话框的父容器。不能为 null。
jobtitle - PrintJob 的标题。null 标题等同于 ""。
props - 包含零个或更多属性的 Properties 对象。这些属性没有被标准化，并且在各个实现之间不一致。因此，要求作业和页面控制的 PrintJob 应该使用此方法带有 JobAttributes 和 PageAttributes 对象的版本。可以更新此对象来反映用户离开时的作业选择。可以为 null。
返回：
一个 PrintJob 对象；如果用户取消打印作业，则返回 null。
抛出：
NullPointerException - 如果 frame 为 null。GraphicsEnvironment.isHeadless() 返回 true 时总是抛出此异常。
SecurityException - 如果此线程不允许初始化打印作业请求
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless(), PrintJob, RuntimePermission

getPrintJob

public PrintJob getPrintJob(Frame frame,
                            String jobtitle,
                            JobAttributes jobAttributes,
                            PageAttributes pageAttributes)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

此方法的每个实际实现都应该先检查是否安装了安全管理器。如果安装了安全管理器，则该方法应该调用安全管理器的 checkPrintJobAccess 方法，以确保允许初始化打印操作。如果使用 checkPrintJobAccess 的默认实现（即未重写该方法），则将导致使用 RuntimePermission("queuePrintJob") 权限调用安全管理器的 checkPermission 方法。

参数：
frame - 打印对话框的父级。当且仅当 jobAttributes 不为 null 且 jobAttributes.getDialog() 返回 JobAttributes.DialogType.NONE 或 JobAttributes.DialogType.COMMON 时，该参数可为 null。
jobtitle - PrintJob 的标题。null 标题等同于 ""。
jobAttributes - 控制 PrintJob 的作业属性集合。这些属性将被更新，以反映用户的选择，这概括在 JobAttributes 文档中。可以为 null。
pageAttributes - 控制 PrintJob 的页面属性集合。这些属性将应用于作业中的每个页面。这些属性将被更新，以反映用户的选择，这概括在 PageAttributes 文档中。可以为 null。
返回：
一个 PrintJob 对象；如果用户取消打印作业，则返回 null。
抛出：
NullPointerException - 如果 frame 为 null，并且 jobAttributes 为 null 或者 jobAttributes.getDialog() 返回 JobAttributes.DialogType.NATIVE。
IllegalArgumentException - 如果 pageAttributes 通过馈送然后解析馈送这一过程来指定不同之处。如果此线程可访问文件系统且 jobAttributes 指定打印到文件，则出现以下情况时也将抛出该异常：指定目标文件存在但它是一个目录而不是常规文件；指定目标文件不存在但不能创建；指定目标文件由于某些其他原因无法打开。但是，在指定打印到文件的情况下，如果同时请求了显示对话框，那么用户将有机会选择一个文件并继续打印。在从此方法返回前，该对话框将保证选择的输出文件有效。

GraphicsEnvironment.isHeadless() 返回 true 时总是抛出此异常。

SecurityException - 如果此线程不允许初始化打印作业请求，或者 jobAttributes 指定打印到文件，并且此线程不允许访问该文件系统
从以下版本开始：
1.3
另请参见：
PrintJob, GraphicsEnvironment.isHeadless(), RuntimePermission, JobAttributes, PageAttributes

beep

public abstract void beep()
发出一个音频嘟嘟声。

从以下版本开始：
JDK1.1

getSystemClipboard

public abstract Clipboard getSystemClipboard()
                                      throws HeadlessException
获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。该剪贴板使数据能够在 Java 应用程序和使用本机剪贴板工具的本机应用程序之间传输。

除了 flavormap.properties 文件（或 AWT.DnD.flavorMapFileURL Toolkit 属性指定的其他文件）中指定的所有格式之外，系统 Clipboard 的 getTransferData() 方法返回的文本在以下 flavor 中是可用的：

  • DataFlavor.stringFlavor
  • DataFlavor.plainTextFlavor（已过时）
在使用 java.awt.datatransfer.StringSelection 时，如果要求的 flavor 是 DataFlavor.plainTextFlavor 或等价 flavor，则返回一个 Reader。注：系统 Clipboard 针对 DataFlavor.plainTextFlavor 和等价 DataFlavor 的 getTransferData() 方法的行为与 DataFlavor.plainTextFlavor 的定义是不一致的。因此，对 DataFlavor.plainTextFlavor 和等价 flavor 的支持已过时。

此方法的每个实际实现都应该先检查是否安装了安全管理器。如果安装了安全管理器，则此方法应该调用安全管理器的 checkSystemClipboardAccess 方法，以确保可以访问系统剪贴板。如果使用 checkSystemClipboardAccess 的默认实现（即未重写该方法），则将导致使用 AWTPermission("accessClipboard") 权限调用安全管理器的 checkPermission 方法。

返回：
系统 Clipboard
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless(), Clipboard, StringSelection, DataFlavor.stringFlavor, DataFlavor.plainTextFlavor, Reader, AWTPermission

getSystemSelection

public Clipboard getSystemSelection()
                             throws HeadlessException
以 Clipboard 对象的形式获取系统选择的一个实例。这使应用程序能够读取和修改当前系统范围内的选择。

无论用户在何时使用鼠标或键盘选择了文本，应用程序都要负责更新系统选择。通常，实现方式是在所有支持文本选择的 Component 上，以及传递给该 Component 的 FOCUS_GAINED 和 FOCUS_LOST 事件之间安装一个 FocusListener，并在 Component 内的选择发生更改时更新系统选择 Clipboard。恰当地更新系统选择确保了 Java 应用程序与本机应用程序和同时运行在系统上的其他 Java 应用程序正确交互。注意，java.awt.TextComponent 和 javax.swing.text.JTextComponent 已支持此策略。在使用这些类及其子类时，开发人员不需要编写任何额外的代码。

一些平台不支持系统选择 Clipboard。在这些平台上，此方法将返回 null。在这种情况下，应用程序不再有责任更新系统选择 Clipboard（如上所述）。

此方法的每个实际实现都应该先检查是否安装了 SecurityManager。如果是安装了 SecurityManager，则应调用 SecurityManager 的 checkSystemClipboardAccess 方法，以确保可以访问系统剪贴板。如果使用 checkSystemClipboardAccess 的默认实现（即如果未重写该方法），则将导致使用 AWTPermission("accessClipboard") 权限调用 SecurityManager 的 checkPermission 方法。

返回：
以 Clipboard 形式返回系统选择，如果本机平台不支持系统选择 Clipboard，则返回 null
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
Clipboard, FocusListener, FocusEvent.FOCUS_GAINED, FocusEvent.FOCUS_LOST, TextComponent, JTextComponent, AWTPermission, GraphicsEnvironment.isHeadless()

getMenuShortcutKeyMask

public int getMenuShortcutKeyMask()
                           throws HeadlessException
确定哪一个修改键是菜单快捷方式的适当加速键。

菜单快捷方式嵌入在 MenuShortcut 类中，由 MenuBar 类处理。

默认情况下，此方法返回 Event.CTRL_MASK。如果 Control 键不是正确的加速键，则工具包实现应该重写此方法。

返回：
此工具包中用于菜单快捷方式的 Event 类的修饰符掩码。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
JDK1.1
另请参见：
GraphicsEnvironment.isHeadless(), MenuBar, MenuShortcut

getLockingKeyState

public boolean getLockingKeyState(int keyCode)
                           throws UnsupportedOperationException
返回键盘上给定锁定键是否处于 "on" 状态。有效键代码是 VK_CAPS_LOCK、VK_NUM_LOCK、VK_SCROLL_LOCK 和 VK_KANA_LOCK。

抛出：
IllegalArgumentException - 如果 keyCode 不是有效键代码之一
UnsupportedOperationException - 如果主机系统不允许以编程方式获取此键的状态，或者键盘没有此键
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless()

setLockingKeyState

public void setLockingKeyState(int keyCode,
                               boolean on)
                        throws UnsupportedOperationException
设置键盘上给定锁定键的状态。有效键代码是 VK_CAPS_LOCK、VK_NUM_LOCK、VK_SCROLL_LOCK 和 VK_KANA_LOCK。

根据不同的平台，设置锁定键的状态可能涉及事件处理，因此不能立即通过 getLockingKeyState 观察到。

抛出：
IllegalArgumentException - 如果 keyCode 不是有效键代码之一
UnsupportedOperationException - 如果主机系统不允许以编程方式设置此键的状态，或者键盘没有此键
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless()

getNativeContainer

protected static Container getNativeContainer(Component c)
使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。

createCustomCursor

public Cursor createCustomCursor(Image cursor,
                                 Point hotSpot,
                                 String name)
                          throws IndexOutOfBoundsException,
                                 HeadlessException
创建一个新的自定义光标对象。如果要显示的图像无效，则隐藏光标（使其完全透明），并将热点 (hotspot) 设置为（0，0）。

注意，多帧图像是无效的，可能造成此方法被挂起。

参数：
cursor - 激活光标时要显示的图像
hotSpot - 大光标热点的 X 和 Y 坐标；hotSpot 值必须小于 getBestCursorSize 返回的 Dimension
name - 光标的本地化描述，用于 Java Accessibility
抛出：
IndexOutOfBoundsException - 如果 hotSpot 值超出光标边界
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.2
另请参见：
GraphicsEnvironment.isHeadless()

getBestCursorSize

public Dimension getBestCursorSize(int preferredWidth,
                                   int preferredHeight)
                            throws HeadlessException
返回最接近所需大小的受支持光标尺寸。无论所需的大小如何，只支持单个光标大小的系统将返回该大小。不支持自定义光标的系统返回的尺寸将是 0, 0。

注：如果使用的图像尺寸不符合受支持的大小（由此方法返回的尺寸），则 Toolkit 实现会试着将图像的大小调整为受支持的大小。因为转换低分辨率图像存在一些困难，所以不保证不受支持大小的光标图像的质量。因此建议调用此方法并使用合适的图像，从而不需要转换图像。

参数：
preferredWidth - 组件将使用的首选光标宽度。
preferredHeight - 组件将使用的首选光标高度。
返回：
最接近的受支持光标大小；如果 Toolkit 实现不支持自定义光标，则返回的尺寸为 0,0。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.2
另请参见：
GraphicsEnvironment.isHeadless()

getMaximumCursorColors

public int getMaximumCursorColors()
                           throws HeadlessException
返回自定义光标调色板中 Toolkit 支持的最大颜色数。

注：如果图像调色板中使用的颜色超过所支持的最大颜色数，则 Toolkit 实现会试图将调色板所用颜色调整为最大颜色数。因为转换低分辨率图像存在一些困难，所以不保证颜色多于系统支持颜色的那些图像的质量。因此建议调用此方法并使用合适的图像，从而不需要转换图像。

返回：
最大颜色数；如果 Toolkit 实现不支持自定义光标，则返回零。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.2
另请参见：
GraphicsEnvironment.isHeadless()

isFrameStateSupported

public boolean isFrameStateSupported(int state)
                              throws HeadlessException
返回 Toolkit 是否支持 Frame 状态。此方法判断是否支持最大化或图标化的 UI。对于 Frame.ICONIFIED|Frame.MAXIMIZED_VERT 之类的“复合”状态，该方法总是返回 false。换句话说，根据经验只有使用单窗体状态常量作为参数的查询才是有意义的。

参数：
state - 指定的窗体状态常量之一。
返回：
如果此 Toolkit 实现支持窗体状态，则返回 true；否则返回 false。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
1.4
另请参见：
Frame.setExtendedState(int)

getProperty

public static String getProperty(String key,
                                 String defaultValue)
获取具有指定键和默认值的属性。如果未找到属性，此方法将返回 defaultValue。

getSystemEventQueue

public final EventQueue getSystemEventQueue()
获取应用程序或 applet 的 EventQueue 实例。根据 Toolkit 实现，对于不同的 applet，可能返回不同的 EventQueue。所以 applet 不能假设此方法返回的 EventQueue 实例将由其他 applet 或系统共享。

如果存在安全管理器，则首先调用其 checkAwtEventQueueAccess 方法。如果使用 checkAwtEventQueueAccess 的默认实现（即未重写该方法），则将导致使用 AWTPermission("accessEventQueue") 权限调用安全管理器的 checkPermission 方法。

返回：
EventQueue 对象
抛出：
SecurityException - 如果存在安全管理器且其 SecurityManager.checkAwtEventQueueAccess() 方法拒绝访问 EventQueue
另请参见：
AWTPermission

getSystemEventQueueImpl

protected abstract EventQueue getSystemEventQueueImpl()
获取应用程序或 applet 的 EventQueue 实例，不检查访问权。出于安全原因，只能从 Toolkit 子类调用此方法。

返回：
EventQueue 对象

createDragSourceContextPeer

public abstract java.awt.dnd.peer.DragSourceContextPeer createDragSourceContextPeer(DragGestureEvent dge)
                                                                             throws InvalidDnDOperationException
创建 DragSourceContext 的同位体。如果 GraphicsEnvironment.isHeadless() 返回 true，则总是抛出 InvalidDndOperationException。

抛出：
InvalidDnDOperationException
另请参见：
GraphicsEnvironment.isHeadless()

createDragGestureRecognizer

public <T extends DragGestureRecognizer> T createDragGestureRecognizer(Class<T> abstractRecognizerClass,
                                                                       DragSource ds,
                                                                       Component c,
                                                                       int srcActions,
                                                                       DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。子类应该重写此方法，以提供自己的实现。

参数：
abstractRecognizerClass - 所需识别器的抽象类
ds - DragSource
c - DragGestureRecognizer 的 Component 目标
srcActions - 允许用于该动作的操作
dgl - DragGestureListener
返回：
新的对象或 null。如果 GraphicsEnvironment.isHeadless() 返回 true，则总是返回 null。
另请参见：
GraphicsEnvironment.isHeadless()

getDesktopProperty

public final Object getDesktopProperty(String propertyName)
获取指定桌面属性的值。桌面属性是作为 Toolkit 全局变量资源的惟一指定值。通常它也是与底层平台有关的桌面设置的抽象表示形式。 有关 AWT 支持的桌面属性的更多信息，请参阅 AWT Desktop Properties。

setDesktopProperty

protected final void setDesktopProperty(String name,
                                        Object newValue)
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。

lazilyLoadDesktopProperty

protected Object lazilyLoadDesktopProperty(String name)
一个对桌面属性值延迟计算的机会。

initializeDesktopProperties

protected void initializeDesktopProperties()
initializeDesktopProperties

addPropertyChangeListener

public void addPropertyChangeListener(String name,
                                      PropertyChangeListener pcl)
为指定的桌面属性添加指定的属性更改侦听器。如果 pcl 为 null，则不抛出任何异常，且不执行任何操作。

参数：
name - 要监听的属性的名称
pcl - 属性更改侦听器
从以下版本开始：
1.2

removePropertyChangeListener

public void removePropertyChangeListener(String name,
                                         PropertyChangeListener pcl)
为指定的桌面属性移除指定的属性更改侦听器。如果 pcl 为 null，则不抛出任何异常，且不执行任何操作。

参数：
name - 要移除的属性的名称
pcl - 属性更改侦听器
从以下版本开始：
1.2

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回在此工具包上所有已注册的属性更改侦听器所组成的数组。

返回：
此工具包的所有 PropertyChangeListener；如果当前没有注册的属性更改侦听器，则返回一个空数组
从以下版本开始：
1.4

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。

参数：
propertyName - 指定的属性
返回：
与指定属性关联的所有 PropertyChangeListener；如果没有添加这样的侦听器，则返回一个空数组
从以下版本开始：
1.4

isAlwaysOnTopSupported

public boolean isAlwaysOnTopSupported()
返回此工具包是否支持 always-on-top 模式。要检测特定窗口是否支持 always-on-top 模式，请使用 Window.isAlwaysOnTopSupported()。

返回：
如果当前工具包支持 always-on-top 模式，则返回 true；否则返回 false
从以下版本开始：
1.6
另请参见：
Window.isAlwaysOnTopSupported(), Window.setAlwaysOnTop(boolean)

isModalityTypeSupported

public abstract boolean isModalityTypeSupported(Dialog.ModalityType modalityType)
返回此工具包是否支持给定的模式类型。如果创建了带有不受支持的模式类型的对话框，则使用 Dialog.ModalityType.MODELESS。

参数：
modalityType - 要检测是否受此工具包支持的模式类型
返回：
如果当前工具包支持给定模式类型，则返回 true；否则返回 false
从以下版本开始：
1.6
另请参见：
Dialog.ModalityType, Dialog.getModalityType(), Dialog.setModalityType(java.awt.Dialog.ModalityType)

isModalExclusionTypeSupported

public abstract boolean isModalExclusionTypeSupported(Dialog.ModalExclusionType modalExclusionType)
返回此工具包是否支持给定的模式排斥类型。如果在窗口上设置了不受支持的模式排斥类型，则使用 Dialog.ModalExclusionType.NO_EXCLUDE。

参数：
modalExclusionType - 要检测是否受此工具包支持的模式排斥类型
返回：
如果当前工具包支持给定模式排斥类型，则返回 true；否则返回 false
从以下版本开始：
1.6
另请参见：
Dialog.ModalExclusionType, Window.getModalExclusionType(), Window.setModalExclusionType(java.awt.Dialog.ModalExclusionType)

addAWTEventListener

public void addAWTEventListener(AWTEventListener listener,
                                long eventMask)
添加一个 AWTEventListener，以接收与给定 eventMask 一致的系统范围内指派的所有 AWTEvent。

首先，如果存在安全管理器，则使用 AWTPermission("listenToAllAWTEvents") 权限调用 checkPermission 方法。这可能导致 SecurityException 异常。

eventMask 是要接收的事件类型的位掩码。它是通过对 AWTEvent 中定义的事件掩码进行逐位 OR 得到的。

注：对于一般的应用程序，不推荐使用事件侦听器，它只用于支持特定目的工具，包括支持可访问性、事件记录/回放和诊断跟踪。如果 listener 为 null，则不抛出任何异常，且不执行任何操作。

参数：
listener - 事件侦听器。
eventMask - 要接收的事件类型的位掩码
抛出：
SecurityException - 如果存在安全管理器且其 checkPermission 方法不允许进行此操作。
从以下版本开始：
1.2
另请参见：
removeAWTEventListener(java.awt.event.AWTEventListener), getAWTEventListeners(), SecurityManager.checkPermission(java.security.Permission), AWTEvent, AWTPermission, AWTEventListener, AWTEventListenerProxy

removeAWTEventListener

public void removeAWTEventListener(AWTEventListener listener)
从正接收的指派 AWTEvent 中移除一个 AWTEventListener。

首先，如果存在安全管理器，则使用 AWTPermission("listenToAllAWTEvents") 权限调用 checkPermission 方法。这可能导致 SecurityException 异常。

注：对于一般的应用程序，不推荐使用事件侦听器，它只用于支持特定目的工具，包括支持可访问性、事件记录/回放和诊断跟踪。如果 listener 为 null，则不抛出任何异常，且不执行任何操作。

参数：
listener - 事件侦听器。
抛出：
SecurityException - 如果存在安全管理器且其 checkPermission 方法不允许进行此操作。
从以下版本开始：
1.2
另请参见：
addAWTEventListener(java.awt.event.AWTEventListener, long), getAWTEventListeners(), SecurityManager.checkPermission(java.security.Permission), AWTEvent, AWTPermission, AWTEventListener, AWTEventListenerProxy

getAWTEventListeners

public AWTEventListener[] getAWTEventListeners()
返回在此工具包上所有已注册 AWTEventListener 所组成的数组。如果存在安全管理器，则使用 AWTPermission("listenToAllAWTEvents") 权限调用它的 checkPermission 方法。这可能导致 SecurityException 异常。侦听器可以在 AWTEventListenerProxy 对象中返回，该对象还包含给定侦听器的事件掩码。注意，多次添加的侦听器对象在返回数组中只出现一次。

返回：
所有 AWTEventListener；如果当前没有已注册侦听器，则返回一个空数组
抛出：
SecurityException - 如果存在安全管理器且其 checkPermission 方法不允许进行此操作。
从以下版本开始：
1.4
另请参见：
addAWTEventListener(java.awt.event.AWTEventListener, long), removeAWTEventListener(java.awt.event.AWTEventListener), SecurityManager.checkPermission(java.security.Permission), AWTEvent, AWTPermission, AWTEventListener, AWTEventListenerProxy

getAWTEventListeners

public AWTEventListener[] getAWTEventListeners(long eventMask)
返回已在此工具包上注册的所有 AWTEventListener 所组成的数组，这些侦听器侦听用 eventMask 参数指定的所有事件类型。如果存在安全管理器，则使用 AWTPermission("listenToAllAWTEvents") 权限调用它的 checkPermission 方法。这可能导致 SecurityException 异常。侦听器可以在 AWTEventListenerProxy 对象中返回，该对象还包含给定侦听器的事件掩码。注意，多次添加的侦听器对象在返回数组中只出现一次。

参数：
eventMask - 要监听的事件类型的位掩码
返回：
已在此工具包上为指定事件类型注册的所有 AWTEventListener；如果当前没有这样的已注册侦听器，则返回一个空数组
抛出：
SecurityException - 如果存在安全管理器且其 checkPermission 方法不允许该操作。
从以下版本开始：
1.4
另请参见：
addAWTEventListener(java.awt.event.AWTEventListener, long), removeAWTEventListener(java.awt.event.AWTEventListener), SecurityManager.checkPermission(java.security.Permission), AWTEvent, AWTPermission, AWTEventListener, AWTEventListenerProxy

mapInputMethodHighlight

public abstract Map<TextAttribute,?> mapInputMethodHighlight(InputMethodHighlight highlight)
                                                      throws HeadlessException
返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。输入方法高亮区的样式字段被忽略。返回的映射是不可修改的。

参数：
highlight - 输入方法高亮区
返回：
样式属性映射，或者返回 null
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Transparency (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
接口 Transparency

所有已知子接口：
Paint
所有已知实现类：
BufferedImage, Color, ColorModel, ColorUIResource, ComponentColorModel, DirectColorModel, GradientPaint, IndexColorModel, LinearGradientPaint, MultipleGradientPaint, PackedColorModel, RadialGradientPaint, SystemColor, TexturePaint, VolatileImage
public interface Transparency

Transparency 接口定义用于实现类的通用透明模式。

字段摘要
static int | BITMASK 表示保证完全不透明的图像数据（alpha 值为 1.0）或完全透明的图像数据（alpha 值为 0.0）。
static int | OPAQUE 表示保证完全不透明的图像数据，意味着所有像素 alpha 值都为 1.0。
static int | TRANSLUCENT 表示包含或可能包含位于 0.0 和 1.0（含两者）之间的任意 alpha 值的图像数据。
方法摘要
 int getTransparency()
返回此 Transparency 的类型。

字段详细信息

OPAQUE

static final int OPAQUE
表示保证完全不透明的图像数据，意味着所有像素 alpha 值都为 1.0。

另请参见：
常量字段值

BITMASK

static final int BITMASK
表示保证完全不透明的图像数据（alpha 值为 1.0）或完全透明的图像数据（alpha 值为 0.0）。

另请参见：
常量字段值

TRANSLUCENT

static final int TRANSLUCENT
表示包含或可能包含位于 0.0 和 1.0（含两者）之间的任意 alpha 值的图像数据。

另请参见：
常量字段值
方法详细信息

getTransparency

int getTransparency()
返回此 Transparency 的类型。

返回：
此 Transparency 的字段类型，具体为 OPAQUE、BITMASK 或 TRANSLUCENT。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrayIcon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 TrayIcon

java.lang.Object
    继承者  java.awt.TrayIcon

public class TrayIcon
extends Object

TrayIcon 对象表示可以添加到系统托盘的托盘图标。TrayIcon 可以包含工具提示（文本）、图像、弹出菜单和一组与之关联的侦听器。

TrayIcon 可以生成各种 MouseEvent，并支持添加相应的侦听器，以接收这些事件的通知。TrayIcon 可以自己处理一些事件。例如，默认情况下，在 TrayIcon 上单击鼠标右键时，它将显示指定的弹出菜单。当鼠标悬停到 TrayIcon 上时，它将显示工具提示。

注：在将 MouseEvent 指派给它的注册侦听器时，其 component 属性将被设置为 null。（请参阅 ComponentEvent.getComponent()）；source 属性将被设置为此 TrayIcon（请参阅 EventObject.getSource()）。

注： 行为良好的 TrayIcon 实现将分配不同的动作来显示弹出菜单并选择托盘图标。

TrayIcon 可以生成一个 ActionEvent。在某些平台上，当用户使用鼠标或键盘选择托盘图标时，会出现这种情况。

如果已经安装了 SecurityManager，则必须授予 AWTPermission accessSystemTray 才能创建 TrayIcon。否则，构造方法将抛出 SecurityException。

有关如何使用 TrayIcon API 的示例，请参阅 SystemTray 类概述。

从以下版本开始：
1.6
另请参见：
SystemTray.add(java.awt.TrayIcon),
ComponentEvent.getComponent(),
EventObject.getSource()

嵌套类摘要
static class TrayIcon.MessageType
MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。
构造方法摘要
TrayIcon(Image image)
创建带有指定图像的 TrayIcon。
TrayIcon(Image image, String tooltip)
创建带有指定图像和工具提示文本的 TrayIcon。
TrayIcon(Image image, String tooltip, PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。
方法摘要
void | addActionListener(ActionListener listener) 添加指定的动作侦听器，以接收发自此 TrayIcon 的 ActionEvent。
void | addMouseListener(MouseListener listener) 添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标事件。
void | addMouseMotionListener(MouseMotionListener listener) 添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标移动事件。
void | displayMessage(String caption, String text, TrayIcon.MessageType messageType) 在托盘图标附近显示弹出消息。
String | getActionCommand() 返回由此托盘图标触发的动作事件的命令名。
ActionListener[] | getActionListeners() 返回在已此 TrayIcon 上注册的所有动作侦听器的数组。
Image | getImage() 返回用于此 TrayIcon 的当前图像。
MouseListener[] | getMouseListeners() 返回已在此 TrayIcon 上注册的所有鼠标侦听器的数组。
MouseMotionListener[] | getMouseMotionListeners() 返回已在此 TrayIcon 上注册的所有鼠标移动侦听器的数组。
PopupMenu | getPopupMenu() 返回与此 TrayIcon 关联的弹出菜单。
Dimension | getSize() 返回托盘图标在系统托盘上占用的空间大小（以像素为单位）。
String | getToolTip() 返回与此 TrayIcon 关联的工具提示字符串。
boolean | isImageAutoSize() 返回自动调整大小属性的值。
void | removeActionListener(ActionListener listener) 移除指定的动作侦听器。
void | removeMouseListener(MouseListener listener) 移除指定的鼠标侦听器。
void | removeMouseMotionListener(MouseMotionListener listener) 移除指定的鼠标移动侦听器。
void | setActionCommand(String command) 设置由此托盘图标触发的动作事件的命令名。
void | setImage(Image image) 设置此 TrayIcon 的图像。
void | setImageAutoSize(boolean autosize) 设置自动调整大小的属性。
void | setPopupMenu(PopupMenu popup) 设置此 TrayIcon 的弹出菜单。
void | setToolTip(String tooltip) 设置此 TrayIcon 的工具提示字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TrayIcon

public TrayIcon(Image image)
创建带有指定图像的 TrayIcon。

参数：
image - 要使用的 Image
抛出：
IllegalArgumentException - 如果 image 为 null
UnsupportedOperationException - 如果当前平台不支持系统托盘
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
SecurityException - 如果未授予 accessSystemTray 权限
另请参见：
SystemTray.add(TrayIcon),
TrayIcon(Image, String, PopupMenu),
TrayIcon(Image, String),
SecurityManager.checkPermission(java.security.Permission),
AWTPermission

TrayIcon

public TrayIcon(Image image,
                String tooltip)
创建带有指定图像和工具提示文本的 TrayIcon。

参数：
image - 要使用的 Image
tooltip - 将用作工具提示文本的字符串；如果值为 null，则不显示工具提示
抛出：
IllegalArgumentException - 如果 image 为 null
UnsupportedOperationException - 如果当前平台不支持系统托盘
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
SecurityException - 如果未授予 accessSystemTray 权限
另请参见：
SystemTray.add(TrayIcon), TrayIcon(Image), TrayIcon(Image, String, PopupMenu), SecurityManager.checkPermission(java.security.Permission), AWTPermission

TrayIcon

public TrayIcon(Image image,
                String tooltip,
                PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。

参数：
image - 要使用的 Image
tooltip - 将用作工具提示文本的字符串；如果值为 null ，则不显示工具提示
popup - 将用于托盘图标的弹出菜单的菜单；如果值为 null，则不显示弹出菜单
抛出：
IllegalArgumentException - 如果 image 为 null
UnsupportedOperationException - 如果当前平台不支持系统托盘
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
SecurityException - 如果未授予 accessSystemTray 权限
另请参见：
SystemTray.add(TrayIcon), TrayIcon(Image, String), TrayIcon(Image), PopupMenu, MouseListener, addMouseListener(MouseListener), SecurityManager.checkPermission(java.security.Permission), AWTPermission
方法详细信息

setImage

public void setImage(Image image)
设置此 TrayIcon 的图像。若想在不调用 Image.flush() 方法的情况下舍弃以前的托盘图标图像，则需要手动调用它。

如果该图像表示一幅动画图像，则将自动显示动画。

有关显示图像大小的详细信息，请参阅 setImageAutoSize(boolean) 属性。

用与当前正在使用的图像相同的图像调用此方法无效。

参数：
image - 要使用的非 null Image
抛出：
NullPointerException - 如果 image 为 null
另请参见：
getImage(), Image, SystemTray.add(TrayIcon), TrayIcon(Image, String)

getImage

public Image getImage()
返回用于此 TrayIcon 的当前图像。

返回：
图像
另请参见：
setImage(Image), Image

setPopupMenu

public void setPopupMenu(PopupMenu popup)
设置此 TrayIcon 的弹出菜单。如果 popup 为 null，则没有任何弹出菜单与此 TrayIcon 关联。

注意，在托盘图标上设置此 popup 之前或之后，都不得将它添加到任何父级弹出菜单。如果将它添加到某个父级弹出菜单，则可能从该父级弹出菜单中移除 popup。

popup 只能设置在一个 TrayIcon 上。在多个 TrayIcon 上设置同一个 popup 将导致 IllegalArgumentException。

注： 一些平台可能不支持在用户右键单击托盘图标时显示用户指定的弹出菜单组件。在这种情况下，可能不显示任何菜单，在某些系统中，也可能显示菜单的本地版本。

参数：
popup - 一个 PopupMenu，如果该参数为 null，则移除所有弹出菜单
抛出：
IllegalArgumentException - 如果已经为另一个 TrayIcon 设置 popup
另请参见：
getPopupMenu()

getPopupMenu

public PopupMenu getPopupMenu()
返回与此 TrayIcon 关联的弹出菜单。

返回：
弹出菜单；如果不存在弹出菜单，则返回 null
另请参见：
setPopupMenu(PopupMenu)

setToolTip

public void setToolTip(String tooltip)
设置此 TrayIcon 的工具提示字符串。当鼠标悬停在图标上时，自动显示工具提示。将工具提示设置为 null 将移除所有工具提示文本。 在某些平台上显示时，工具提示字符串可能被截断；可以显示的字符数与平台有关。

参数：
tooltip - 工具提示的字符串；如果值为 null，则不显示任何工具提示
另请参见：
getToolTip()

getToolTip

public String getToolTip()
返回与此 TrayIcon 关联的工具提示字符串。

返回：
工具提示字符串；如果不存在，则返回 null
另请参见：
setToolTip(String)

setImageAutoSize

public void setImageAutoSize(boolean autosize)
设置自动调整大小的属性。自动调整大小属性将确定托盘图像是否能自动调整大小以适合托盘上为图像分配的空间。默认情况下，自动调整大小属性被设置为 false。

如果自动调整大小属性为 false，且图像大小与托盘图标空间不匹配，则图像将按照原样绘制在该空间中，如果图像大小大于分配的空间，那么它将被裁剪。

如果自动调整大小属性为 true，则将拉伸或缩小图像以适合托盘图标空间。

参数：
autosize - 如果自动调整图像大小，则为 true；否则为 false
另请参见：
isImageAutoSize()

isImageAutoSize

public boolean isImageAutoSize()
返回自动调整大小属性的值。

返回：
如果自动调整图像大小，则返回 true；否则返回 false
另请参见：
setImageAutoSize(boolean)

addMouseListener

public void addMouseListener(MouseListener listener)
添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标事件。用 null 值调用此方法无效。

注：MouseEvent 的坐标（从 TrayIcon 接收）是相对于屏幕的，而不是相对于 TrayIcon 的。

注： 不支持 MOUSE_ENTERED 和 MOUSE_EXITED 鼠标事件。

有关 AWT 线程模型的详细信息，请参阅 AWT 线程问题。

参数：
listener - 鼠标侦听器
另请参见：
MouseEvent, MouseListener, removeMouseListener(MouseListener), getMouseListeners()

removeMouseListener

public void removeMouseListener(MouseListener listener)
移除指定的鼠标侦听器。用 null 或无效值调用此方法无效。

有关 AWT 线程模型的详细信息，请参阅 AWT 线程问题。

参数：
listener - 鼠标侦听器
另请参见：
MouseEvent, MouseListener, addMouseListener(MouseListener), getMouseListeners()

getMouseListeners

public MouseListener[] getMouseListeners()
返回已在此 TrayIcon 上注册的所有鼠标侦听器的数组。

返回：
所有已在此 TrayIcon 上注册的 MouseListeners；如果当前没有已注册的鼠标侦听器，则返回空数组
另请参见：
addMouseListener(MouseListener), removeMouseListener(MouseListener), MouseListener

addMouseMotionListener

public void addMouseMotionListener(MouseMotionListener listener)
添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标移动事件。用 null 值调用此方法无效。

注：MouseEvent 的坐标（从 TrayIcon 接收）是相对于屏幕的，而不是相对于 TrayIcon 的。

注： 不支持 MOUSE_DRAGGED 鼠标事件。

有关 AWT 线程模型的详细信息，请参阅 AWT 线程问题。

参数：
listener - 鼠标侦听器
另请参见：
MouseEvent, MouseMotionListener, removeMouseMotionListener(MouseMotionListener), getMouseMotionListeners()

removeMouseMotionListener

public void removeMouseMotionListener(MouseMotionListener listener)
移除指定的鼠标移动侦听器。用 null 或无效值调用此方法无效。

有关 AWT 线程模型的详细信息，请参阅 AWT 线程问题。

参数：
listener - 鼠标侦听器
另请参见：
MouseEvent, MouseMotionListener, addMouseMotionListener(MouseMotionListener), getMouseMotionListeners()

getMouseMotionListeners

public MouseMotionListener[] getMouseMotionListeners()
返回已在此 TrayIcon 上注册的所有鼠标移动侦听器的数组。

返回：
所有已在此 TrayIcon 上注册的 MouseInputListeners；如果当前没有注册的鼠标侦听器，则返回空数组
另请参见：
addMouseMotionListener(MouseMotionListener), removeMouseMotionListener(MouseMotionListener), MouseMotionListener

getActionCommand

public String getActionCommand()
返回由此托盘图标触发的动作事件的命令名。

返回：
动作命令名；如果不存在，则返回 null
另请参见：
addActionListener(ActionListener), setActionCommand(String)

setActionCommand

public void setActionCommand(String command)
设置由此托盘图标触发的动作事件的命令名。默认情况下，此动作命令被设置为 null。

参数：
command - 用于设置托盘图标动作命令的字符串。
另请参见：
ActionEvent, addActionListener(ActionListener), getActionCommand()

addActionListener

public void addActionListener(ActionListener listener)
添加指定的动作侦听器，以接收发自此 TrayIcon 的 ActionEvent。当用户使用鼠标或键盘选择托盘图标时，通常会发生动作事件。动作事件生成的条件与平台有关。

用 null 值调用此方法无效。

有关 AWT 线程模型的详细信息，请参阅 AWT 线程问题。

参数：
listener - 动作侦听器
另请参见：
removeActionListener(java.awt.event.ActionListener), getActionListeners(), ActionListener, setActionCommand(String)

removeActionListener

public void removeActionListener(ActionListener listener)
移除指定的动作侦听器。用 null 或无效值调用此方法无效。

有关 AWT 线程模型的详细信息，请参阅 AWT 线程问题。

参数：
listener - 动作侦听器
另请参见：
ActionEvent, ActionListener, addActionListener(ActionListener), getActionListeners(), setActionCommand(String)

getActionListeners

public ActionListener[] getActionListeners()
返回在已此 TrayIcon 上注册的所有动作侦听器的数组。

返回：
所有已在此 TrayIcon 上注册的 ActionListeners；如果当前没有注册的动作侦听器，则返回空数组
另请参见：
addActionListener(ActionListener), removeActionListener(ActionListener), ActionListener

displayMessage

public void displayMessage(String caption,
                           String text,
                           TrayIcon.MessageType messageType)
在托盘图标附近显示弹出消息。消息将在一段时间之后或用户在消息上单击时消失。单击消息可能触发 ActionEvent。

标题或文本可以为 null，但如果两者都为 null，则抛出 NullPointerException。 在某些平台上显示时，标题或文本字符串可能被截取；可以显示的字符数与平台有关。

注： 一些平台可能不支持显示消息。

参数：
caption - 显示在文本上面的标题，通常为粗体；可以为 null
text - 显示特定消息的文本；可以为 null
messageType - 指示消息类型的枚举
抛出：
NullPointerException - 如果 caption 和 text 都为 null

getSize

public Dimension getSize()
返回托盘图标在系统托盘上占用的空间大小（以像素为单位）。对于尚未添加到系统托盘上的托盘图标，返回的大小等于 SystemTray.getTrayIconSize() 的结果。

返回：
托盘图标的大小（以像素为单位）
另请参见：
setImageAutoSize(boolean), Image, getSize()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrayIcon.MessageType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.awt
枚举 TrayIcon.MessageType

java.lang.Object
    继承者  java.lang.Enum<TrayIcon.MessageType>
        继承者  java.awt.TrayIcon.MessageType
所有已实现的接口：
Serializable, Comparable<TrayIcon.MessageType>
正在封闭类：
TrayIcon
public static enum TrayIcon.MessageType
extends Enum<TrayIcon.MessageType>

MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。

从以下版本开始：
1.6
另请参见：
TrayIcon, TrayIcon.displayMessage(String, String, MessageType)

枚举常量摘要
ERROR
错误消息
INFO
信息消息
NONE
简单消息
WARNING
警告消息
方法摘要
static TrayIcon.MessageType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TrayIcon.MessageType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

ERROR

public static final TrayIcon.MessageType ERROR
错误消息

WARNING

public static final TrayIcon.MessageType WARNING
警告消息

INFO

public static final TrayIcon.MessageType INFO
信息消息

NONE

public static final TrayIcon.MessageType NONE
简单消息

方法详细信息

values

public static final TrayIcon.MessageType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(TrayIcon.MessageType c : TrayIcon.MessageType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TrayIcon.MessageType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Window (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Window

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
BasicToolBarUI.DragWindow, Dialog, Frame, JWindow
public class Window
extends Container
implements Accessible

Window 对象是一个没有边界和菜单栏的顶层窗口。窗口的默认布局是 BorderLayout。

构造窗口时，它必须拥有窗体、对话框或其他作为其所有者定义的窗口。

在多屏幕环境中，通过使用 Window(Window, GraphicsConfiguration) 构造 Window，可以在不同的屏幕设备上创建 Window。GraphicsConfiguration 对象是目标屏幕设备的 GraphicsConfiguration 对象之一。

在虚拟设备多屏幕环境中（其中桌面区域可以跨越多物理屏幕设备），所有配置的边界都是相对于虚拟设备坐标系的。虚拟坐标系的原点位于主物理屏幕的左上角。是否使用负坐标取决于主物理屏幕在虚拟设备中的位置，如下图所示。

图表显示的虚拟设备包含 4 个物理屏幕。主物理屏幕显示坐标 (0,0)，其他屏幕显示 (-80,-100)。

在此环境中，调用 setLocation 时，必须传递一个虚拟坐标到此方法中。类似地，对 Frame 调用 getLocationOnScreen 将返回虚拟设备坐标。调用 GraphicsConfiguration 的 getBounds 方法，以查找它在虚拟坐标系中的原点。

以下代码将 Window 的位置设置在 (10, 10)（相对于相应 GraphicsConfiguration 物理屏幕的原点）。如果不考虑 GraphicsConfiguration 的边界，则 Window 位置应设置在 (10, 10)（相对于虚拟坐标系），并显示在主物理屏幕上，该屏幕可能不同于指定 GraphicsConfiguration 的物理屏幕。

        Window w = new Window(Window owner, GraphicsConfiguration gc);
        Rectangle bounds = gc.getBounds();
        w.setLocation(10 + bounds.x, 10 + bounds.y);

注：顶层窗口（包括 Window、Frame 和 Dialog）的位置和大小受桌面窗口管理系统的控制。对 setLocation、setSize 和 setBounds 的调用是转发到窗口管理系统的请求（不是指令）。将尽所有努力响应这样的请求。但是，在某些情况下，窗口管理系统可以忽略这样的请求，或修改请求的几何结构，以放置和调整 Window 的大小，使之更好地与桌面设置匹配。

由于本机事件处理的异步特性，在处理完最后一个请求前，getBounds、getLocation、getLocationOnScreen 和 getSize 返回的结果可能不反映屏幕上窗口的实际几何结构。在处理后续请求的过程中，窗口管理系统满足这些请求时，这些值可能会相应地改变。

应用程序可以随意设置不可见 Window 的大小和位置，但是当 Window 可见时，窗口管理系统可以随后更改它的大小和/或位置。将生成一个或多个 ComponentEvent 来表示新的几何结构。

窗口能够生成以下 WindowEvents：WindowOpened、WindowClosed、indowGainedFocus、indowLostFocus。

从以下版本开始：
JDK1.0
另请参见：
WindowEvent, addWindowListener(java.awt.event.WindowListener), BorderLayout, 序列化表格

嵌套类摘要
protected  class Window.AccessibleAWTWindow
此类实现对 Window 类的可访问性支持。
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Window(Frame owner)
构造一个新的、最初不可见的窗口，使用指定的 Frame 作为其所有者。
Window(Window owner)
构造一个新的、最初不可见的窗口，使用指定 Window 作为其所有者。
Window(Window owner, GraphicsConfiguration gc)
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。
方法摘要
 void addNotify()
通过创建到本机屏幕资源的连接，使此窗口变得可显示。
 void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。
 void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 添加到某个特定属性的侦听器列表。
 void addWindowFocusListener(WindowFocusListener l)
添加指定的窗口焦点侦听器，以从此窗口接收窗口事件。
 void addWindowListener(WindowListener l)
添加指定的窗口侦听器，以从此窗口接收窗口事件。
 void addWindowStateListener(WindowStateListener l)
添加指定的窗口状态侦听器，以从此窗口接收窗口事件。
 void applyResourceBundle(ResourceBundle rb)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
 void applyResourceBundle(String rbName)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
 void createBufferStrategy(int numBuffers)
为此组件上的多缓冲创建一个新策略。
 void createBufferStrategy(int numBuffers, BufferCapabilities caps)
根据所需缓冲区能力为此组件上的多缓冲创建新策略。
 void dispose()
释放由此 Window、其子组件及其拥有的所有子组件所使用的所有本机屏幕资源。
 AccessibleContext getAccessibleContext()
获取与此窗口关联的 AccessibleContext。
 BufferStrategy getBufferStrategy()
返回此组件使用的 BufferStrategy。
 boolean getFocusableWindowState()
返回如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。
 Container getFocusCycleRootAncestor()
始终返回 null，因为窗口没有祖先；它们表示组件层次结构的顶层。
 Component getFocusOwner()
如果此窗口为焦点窗口，则返回是焦点窗口的子组件；否则返回 null。
 Set<AWTKeyStroke> getFocusTraversalKeys(int id)
获取此窗口的焦点遍历键。
 GraphicsConfiguration getGraphicsConfiguration()
此方法返回由此窗口使用的 GraphicsConfiguration。
 List<Image> getIconImages()
返回要作为此窗口的图标显示的图像序列。
 InputContext getInputContext()
获取此窗口的输入上下文。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
 Locale getLocale()
如果设置了区域，则获取与此窗口关联的 Locale 对象。
 Dialog.ModalExclusionType getModalExclusionType()
返回此窗口的模式排斥类型。
 Component getMostRecentFocusOwner()
返回此窗口的子组件，该子组件在此窗口为焦点窗口时将接收焦点。
 Window[] getOwnedWindows()
返回包含此窗口当前拥有的所有窗口的数组。
 Window getOwner()
返回此窗口的所有者。
static Window[] getOwnerlessWindows()
返回一个数组，该数组由此应用程序创建的所有没有所有者的 Window 组成。
 Toolkit getToolkit()
返回此窗体的工具包。
 String getWarningString()
获取此窗口中显示的警告字符串。
 WindowFocusListener[] getWindowFocusListeners()
返回在此窗口注册的所有窗口焦点侦听器所组成的数组。
 WindowListener[] getWindowListeners()
返回在此窗口注册的所有窗口侦听器所组成的数组。
static Window[] getWindows()
返回一个数组，该数组由此应用程序创建的所有 Window（包括被拥有的和不被拥有的）组成。
 WindowStateListener[] getWindowStateListeners()
返回在此窗口注册的所有窗口状态侦听器所组成的数组。
 void hide()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
 boolean isActive()
返回此窗口是否为活动窗口。
 boolean isAlwaysOnTop()
返回此窗口是否为 always-on-top 窗口。
 boolean isAlwaysOnTopSupported()
返回此窗口是否支持 always-on-top 模式。
 boolean isFocusableWindow()
返回此窗口是否可以成为焦点窗口，也就是说，此窗口或其任何子组件是否可以成为焦点所有者。
 boolean isFocusCycleRoot()
始终返回 true，因为所有窗口必须是焦点遍历循环的根。
 boolean isFocused()
返回此窗口是否为焦点窗口。
 boolean isLocationByPlatform()
如果此窗口下次可见时，出现在本机窗口操作系统的默认位置，则返回 true。
 boolean isShowing()
检查此窗口是否显示在屏幕上。
 void pack()
调整此窗口的大小，以适合其子组件的首选大小和布局。
 boolean postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
protected  void processEvent(AWTEvent e)
处理此窗口上的事件。
protected  void processWindowEvent(WindowEvent e)
处理此窗口上发生的窗口事件：将它们指派到任何注册的 WindowListener 对象。
protected  void processWindowFocusEvent(WindowEvent e)
处理此窗口上发生的窗口焦点事件：将它们指派到任何注册的 WindowFocusListener 对象。
protected  void processWindowStateEvent(WindowEvent e)
处理此窗口上发生的窗口状态事件：将它们指派到任何注册的 WindowStateListener 对象。
 void removeNotify()
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。
 void removeWindowFocusListener(WindowFocusListener l)
移除指定的窗口焦点侦听器，以便不再从此窗口接收窗口事件。
 void removeWindowListener(WindowListener l)
移除指定的窗口侦听器，以便不再从此窗口接收窗口事件。
 void removeWindowStateListener(WindowStateListener l)
移除指定的窗口状态侦听器，以便不再从此窗口接收窗口事件。
 void reshape(int x, int y, int width, int height)
已过时。 从 JDK 1.1 版开始，由 setBounds(int, int, int, int) 取代。
 void setAlwaysOnTop(boolean alwaysOnTop)
设置此窗口是否应该始终位于其他窗口上方。
 void setBounds(int x, int y, int width, int height)
移动组件并调整其大小。
 void setBounds(Rectangle r)
移动组件并调整其大小，使其符合新的有界矩形 r。
 void setCursor(Cursor cursor)
设置指定光标的光标图像。
 void setFocusableWindowState(boolean focusableWindowState)
设置如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。
 void setFocusCycleRoot(boolean focusCycleRoot)
不执行任何操作，因为窗口必须始终是焦点遍历循环的根。
 void setIconImage(Image image)
设置要作为此窗口图标显示的图像。
 void setIconImages(List<? extends Image> icons)
设置要作为此窗口的图标显示的图像序列。
 void setLocationByPlatform(boolean locationByPlatform)
设置窗口下次可见时应该出现的位置：本机窗口系统的默认位置，还是当前位置（由 getLocation 返回）。
 void setLocationRelativeTo(Component c)
设置窗口相对于指定组件的位置。
 void setMinimumSize(Dimension minimumSize)
将此窗口的最小大小设置为一个常量值。
 void setModalExclusionType(Dialog.ModalExclusionType exclusionType)
指定此窗口的模式排斥类型。
 void setSize(Dimension d)
调整组件的大小，使其宽度为 d.width，高度为 d.height。
 void setSize(int width, int height)
调整组件的大小，使其宽度为 width，高度为 height。
 void setVisible(boolean b)
根据参数 b 的值显示或隐藏此 Window。
 void show()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
 void toBack()
如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。
 void toFront()
如果此窗口是可见的，则将此窗口置于前端，并可以将其设为焦点 Window。
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, update, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Window

public Window(Frame owner)
构造一个新的、最初不可见的窗口，使用指定的 Frame 作为其所有者。该窗口将不可聚焦，除非其所有者正显示在屏幕上。

如果存在安全管理器，则此方法首先调用安全管理器的 checkTopLevelWindow 方法（this 作为其参数），以确定是否必须使用警告标志显示该窗口。

参数：
owner - 要充当所有者的 Frame；如果此窗口没有所有者，则该参数为 null
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless 返回 true 时
另请参见：
GraphicsEnvironment.isHeadless(),
SecurityManager.checkTopLevelWindow(java.lang.Object),
isShowing()

Window

public Window(Window owner)
构造一个新的、最初不可见的窗口，使用指定 Window 作为其所有者。此窗口将不可聚焦，除非其最近拥有的 Frame 或 Dialog 正显示在屏幕上。

如果存在安全管理器，则此方法首先调用安全管理器的 checkTopLevelWindow 方法（this 作为其参数），以确定是否必须使用警告标志显示该窗口。

参数：
owner - 要充当所有者的 Window；如果此窗口没有所有者，则该参数为 null
抛出：
IllegalArgumentException - 如果 owner 的 GraphicsConfiguration 不是来自屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless 返回 true 时
从以下版本开始：
1.2
另请参见：
GraphicsEnvironment.isHeadless(),
SecurityManager.checkTopLevelWindow(java.lang.Object),
isShowing()

Window

public Window(Window owner,
              GraphicsConfiguration gc)
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。该窗口将不可聚焦，除非其最近拥有的 Frame 或 Dialog 正显示在屏幕上。

如果存在安全管理器，则此方法首先调用安全管理器的 checkTopLevelWindow 方法（this 作为其参数），以确定是否必须使用警告标志显示该窗口。

参数：
owner - 要作为所有者的窗口；如果此窗口没有所有者，则该参数为 null
gc - 目标屏幕设备的 GraphicsConfiguration；如果 gc 为 null，则使用系统默认的 GraphicsConfiguration
抛出：
IllegalArgumentException - 如果 gc 不是来自屏幕设备
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless(),
SecurityManager.checkTopLevelWindow(java.lang.Object),
GraphicsConfiguration.getBounds(),
isShowing()
方法详细信息

getIconImages

public List<Image> getIconImages()
返回要作为此窗口的图标显示的图像序列。

此方法返回内部存储列表的一个副本，所以对返回对象的任何操作都不会影响窗口的行为。

返回：
此窗口的图标图像列表的副本；如果此窗口没有图标图像，则返回空列表。
从以下版本开始：
1.6
另请参见：
setIconImages(java.util.List), setIconImage(Image)

setIconImages

public void setIconImages(List<? extends Image> icons)
设置要作为此窗口的图标显示的图像序列。随后调用 getIconImages 将总是返回 icons 列表的一个副本。

各平台根据自身能力的不同，使用不同数量和尺寸的图像作为窗口的图标。

一开始便扫描 icons 列表，寻找最佳尺寸的图像。如果列表包含几个大小相同的图像，则使用第一个图像。

未指定图标的、没有所有者的窗口将使用平台默认的图标。如果没有显示重写，被拥有的窗口的图标可以从其所有者继承。将图标设置为 null 或空列表将恢复默认行为。

注：根据上下文的不同（例如，窗口装饰、窗口列表、任务栏等），本机窗口系统可以使用不同尺寸的不同图像表示一个窗口。也可以对所有上下文使用一个图像，或者根本不用图像。

参数：
icons - 要显示的图标图像列表。
从以下版本开始：
1.6
另请参见：
getIconImages(), setIconImage(Image)

setIconImage

public void setIconImage(Image image)
设置要作为此窗口图标显示的图像。

将单个图像指定为窗口的图标时，可以使用此方法代替 setIconImages()。

以下语句：

     setIconImage(image);
等价于：
     ArrayList   imageList = new ArrayList  ();
     imageList.add(image);
     setIconImages(imageList);

注：根据上下文的不同（例如，窗口装饰、窗口列表、任务栏等），本机窗口系统可以使用不同尺寸的不同图像表示一个窗口。也可以对所有上下文使用一个图像，或者根本不用图像。

参数：
image - 要显示的图标图像。
从以下版本开始：
1.6
另请参见：
setIconImages(java.util.List), getIconImages()

addNotify

public void addNotify()
通过创建到本机屏幕资源的连接，使此窗口变得可显示。此方法由工具包在内部进行调用，并且不应由程序直接调用。

覆盖：
类 Container 中的 addNotify
从以下版本开始：
JDK1.0
另请参见：
Component.isDisplayable(), Container.removeNotify()

removeNotify

public void removeNotify()
通过移除此 Container 到其本机屏幕资源的连接，使其不可显示。使容器变得不可显示会使其所有子容器都变得不可显示。此方法是通过工具包内部调用的，不应该通过程序直接调用它。

覆盖：
类 Container 中的 removeNotify
另请参见：
Component.isDisplayable(), Container.addNotify()

pack

public void pack()
调整此窗口的大小，以适合其子组件的首选大小和布局。如果该窗口和/或其所有者还不可显示，则在计算首选大小之前都将变得可显示。在计算首选大小之后，将会验证该窗口。

另请参见：
Component.isDisplayable()

setMinimumSize

public void setMinimumSize(Dimension minimumSize)
将此窗口的最小大小设置为一个常量值。随后调用 getMinimumSize 将总是返回此值。如果当前窗口的大小小于 minimumSize，则窗口的大小将自动增大到最小大小。

如果随后调用 setSize 或 setBounds 方法，且调用时使用的宽度或高度小于 setMinimumSize 指定的宽度或高度，则窗口将自动增大到 minimumSize 值。将最小大小设置为 null 将还原默认行为。

如果用户试图将窗口大小调整到 minimumSize 值以下，则该调整操作将受到限制。 此行为与平台有关。

覆盖：
类 Component 中的 setMinimumSize
参数：
minimumSize - 此窗口新的最小大小
从以下版本开始：
1.6
另请参见：
Component.setMinimumSize(java.awt.Dimension),
Container.getMinimumSize(),
Component.isMinimumSizeSet(),
setSize(Dimension)

setSize

public void setSize(Dimension d)
调整组件的大小，使其宽度为 d.width，高度为 d.height。

如果 d.width 值或 d.height 值小于之前调用 setMinimumSize 指定的最小大小，则它将自动增大。

覆盖：
类 Component 中的 setSize
参数：
d - 指定组件新大小的尺寸
从以下版本开始：
1.6
另请参见：
Component.getSize(),
setBounds(int, int, int, int),
setMinimumSize(java.awt.Dimension)

setSize

public void setSize(int width,
                    int height)
调整组件的大小，使其宽度为 width，高度为 height。

如果 width 值或 height 值小于之前调用 setMinimumSize 指定的最小大小，则它将自动增大。

覆盖：
类 Component 中的 setSize
参数：
width - 组件的新宽度，单位是像素
height - 组件的新高度，单位是像素
从以下版本开始：
1.6
另请参见：
Component.getSize(),
setBounds(int, int, int, int),
setMinimumSize(java.awt.Dimension)

reshape

@Deprecated
public void reshape(int x,
                               int y,
                               int width,
                               int height)
已过时。 从 JDK 1.1 版开始，由 setBounds(int, int, int, int) 取代。

覆盖：
类 Component 中的 reshape

setVisible

public void setVisible(boolean b)
根据参数 b 的值显示或隐藏此 Window。

覆盖：
类 Component 中的 setVisible
参数：
b - 如为 true，则使 Window 可见，否则隐藏 Window。 如果 Window 和/或其所有者还不能显示，则都不显示。在使 Window 可见之前将验证它。 如果 Window 已经可见，则此方法将 Window 带到最前面。

如为 false，则隐藏此 Window、此 Window 的子组件，以及它拥有的所有子级。 调用 #setVisible(true) 可以重新使 Window 及其子组件可见。

另请参见：
Component.isDisplayable(),
Component.setVisible(boolean),
toFront(),
dispose()

show

@Deprecated
public void show()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。

使窗口可见。如果窗口和/或其所有者还不能显示，则都不显示。在使窗口可见之前将验证它。如果窗口已经可见，则此方法将窗口带到最前面。

覆盖：
类 Component 中的 show
另请参见：
Component.isDisplayable(), toFront()

hide

@Deprecated
public void hide()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。

隐藏此窗口、此窗口的子组件，以及它拥有的所有子级。调用 show 可以重新使窗口及其子组件可见。

覆盖：
类 Component 中的 hide
另请参见：
show(), dispose()

dispose

public void dispose()
释放由此 Window、其子组件及其拥有的所有子组件所使用的所有本机屏幕资源。即这些 Component 的资源将被破坏，它们使用的所有内存都将返回到操作系统，并将它们标记为不可显示。

通过随后调用 pack 或 show 重新构造本机资源，可以再次显示 Window 及其子组件。重新创建的 Window 及其子组件的状态与释放 Window 时这些对象的状态一致（不考虑这些操作之间的其他更改）。

注：当 Java 虚拟机 (VM) 中最后的可显示窗口被释放后，虚拟机可能会终止。有关更多信息，请参阅 AWT Threading Issues。

另请参见：
Component.isDisplayable(),
pack(),
show()

toFront

public void toFront()
如果此窗口是可见的，则将此窗口置于前端，并可以将其设为焦点 Window。

将此窗口放在堆栈顺序的顶层，并在此虚拟机中显示在所有其他窗口的上面。如果此窗口不可见，则不会发生任何操作。有些平台不允许拥有其他窗口的窗口显示在它所拥有的窗口之上。有些平台可能不允许此虚拟机将其窗口放在本机应用程序窗口或其他虚拟机窗口之上。此权限可能取决于此虚拟机中的窗口是否已被设为焦点窗口。将进行所有尝试来移动此窗口，使其位于堆栈顺序中尽可能靠前的位置；但是，开发人员不应假定此方法在所有情况下都可以将此窗口移到所有其他窗口之上。

由于本机窗口系统多种多样，因此无法保证对焦点窗口和活动窗口的更改能够实现。在此窗口接收 WINDOW_GAINED_FOCUS 或 WINDOW_ACTIVATED 事件之前，开发人员不得假定此窗口是焦点窗口或活动窗口。在顶层窗口是焦点窗口的平台上，此方法可能使此窗口成为焦点窗口（如果它还不是焦点窗口）。在堆栈顺序通常不影响焦点窗口的平台上，此方法可能维持焦点窗口和活动窗口不变。

如果此方法导致此窗口成为焦点窗口，而且此窗口是一个 Frame 或 Dialog，则它也将被激活。如果此窗口是焦点窗口，但它不是一个 Frame 或 Dialog，则拥有此窗口的第一个 Frame 或 Dialog 将被激活。

如果此窗口被模式对话框 (modal dialog) 阻塞，则阻塞对话框将置于最前端，仍然处于被阻塞窗口的前方。

另请参见：
toBack()

toBack

public void toBack()
如果此窗口是可视的，则将此窗口置于后方，如果它是焦点窗口或活动窗口，则会导致丢失焦点或活动状态。

在此虚拟机中，将此窗口放在堆栈顺序的底部，并在其他所有窗口之后显示此窗口。如果此窗口不可见，则不发生任何操作。有些平台不允许其他窗口拥有的窗口出现在其所有者下方。将进行所有尝试来移动此窗口，使其位于堆栈顺序中尽可能靠后的位置；不过，开发人员不应假定此方法在所有情况下都可以将此窗口移到所有其他窗口之下。

由于本机窗口系统多种多样，因此无法保证对焦点窗口和活动窗口的更改能够实现。在此窗口接收 WINDOW_LOST_FOCUS 或 WINDOW_DEACTIVATED 事件之前，开发人员不得假定此窗口不再是焦点窗口或活动窗口。在顶层窗口为焦点窗口的平台上，此方法可能导致此窗口不再是焦点状态。在此情况下，此虚拟机中紧跟其后的可作为焦点的窗口将成为焦点窗口。在堆栈顺序通常不影响焦点窗口的平台上，此方法可能维持焦点窗口和活动窗口不变。

另请参见：
toFront()

getToolkit

public Toolkit getToolkit()
返回此窗体的工具包。

覆盖：
类 Component 中的 getToolkit
返回：
此窗口的工具包。
另请参见：
Toolkit, Toolkit.getDefaultToolkit(), Component.getToolkit()

getWarningString

public final String getWarningString()
获取此窗口中显示的警告字符串。如果此窗口不安全，则警告字符串将在此窗口的可视区域内显示。如果存在安全管理器，并且在窗口作为一个参数传递到安全管理器的 checkTopLevelWindow 方法时，该方法返回 false，那么窗口是不安全的。

如果此窗口是安全的，则 getWarningString 返回 null。如果此窗口是不安全的，则此方法检查系统属性 awt.appletWarning，并返回此属性的字符串值。

返回：
此窗口的警告字符串。
另请参见：
SecurityManager.checkTopLevelWindow(java.lang.Object)

getLocale

public Locale getLocale()
如果设置了区域，则获取与此窗口关联的 Locale 对象。如果未设置区域，则返回默认的区域。

覆盖：
类 Component 中的 getLocale
返回：
为此窗口设置的区域。
从以下版本开始：
JDK1.1
另请参见：
Locale

getInputContext

public InputContext getInputContext()
获取此窗口的输入上下文。窗口始终具有一个输入上下文，如果子组件没有创建并设置自己的输入上下文，则可以共享该输入上下文。

覆盖：
类 Component 中的 getInputContext
返回：
组件使用的输入上下文，如果可以确定没有上下文，则返回 null
从以下版本开始：
1.2
另请参见：
Component.getInputContext()

setCursor

public void setCursor(Cursor cursor)
设置指定光标的光标图像。

如果 Java 平台实现和/或本机系统不支持更改鼠标光标形状，那么此方法将没有任何视觉效果。

覆盖：
类 Component 中的 setCursor
参数：
cursor - 由 Cursor 类定义的常量之一。如果此参数为 null，则此窗口的光标将被设置为类型 Cursor.DEFAULT_CURSOR。
从以下版本开始：
JDK1.1
另请参见：
Component.getCursor(), Cursor

getOwner

public Window getOwner()
返回此窗口的所有者。

从以下版本开始：
1.2

getOwnedWindows

public Window[] getOwnedWindows()
返回包含此窗口当前拥有的所有窗口的数组。

从以下版本开始：
1.2

getWindows

public static Window[] getWindows()
返回一个数组，该数组由此应用程序创建的所有 Window（包括被拥有的和不被拥有的）组成。 如果从 applet 调用此方法，则返回数组只包括该 applet 可访问的 Window。

警告： 此方法可以返回系统创建的窗口，如打印对话框。应用程序不应该假定这些对话框存在，也不应该假定任何与这些对话框有关的内容（如组件位置、LayoutManager 或序列化）存在。

从以下版本开始：
1.6
另请参见：
Frame.getFrames(), getOwnerlessWindows()

getOwnerlessWindows

public static Window[] getOwnerlessWindows()
返回一个数组，该数组由此应用程序创建的所有没有所有者的 Window 组成。它们包括 Frame 以及没有所有者的 Dialog 和 Window。 如果从 applet 调用此方法，则返回数组只包括该 applet 可访问的 Window。

警告： 此方法可以返回系统创建的窗口，如打印对话框。应用程序不应该假定这些对话框存在，也不应该假定任何与这些对话框有关的内容（如组件位置、LayoutManager 或序列化）存在。

从以下版本开始：
1.6
另请参见：
Frame.getFrames(), getWindows(sun.awt.AppContext)

setModalExclusionType

public void setModalExclusionType(Dialog.ModalExclusionType exclusionType)
指定此窗口的模式排斥类型。如果一个窗口是模式排斥的，则该窗口不会被某些模式对话框阻塞。有关可能的模式排斥类型，请参阅 Dialog.ModalExclusionType。

如果不支持给定类型，则使用 NO_EXCLUDE。

注：如果将可见窗口更改为模式排斥类型，则只有在该窗口被隐藏然后再次出现后才有效。

参数：
exclusionType - 此窗口的模式排斥类型；null 值等价于 NO_EXCLUDE
抛出：
SecurityException - 如果调用线程没有权限使用给定 exclusionType 设置窗口的模式排斥属性
从以下版本开始：
1.6
另请参见：
Dialog.ModalExclusionType, getModalExclusionType(), Toolkit.isModalExclusionTypeSupported(java.awt.Dialog.ModalExclusionType)

getModalExclusionType

public Dialog.ModalExclusionType getModalExclusionType()
返回此窗口的模式排斥类型。

返回：
此窗口的模式排斥类型
从以下版本开始：
1.6
另请参见：
Dialog.ModalExclusionType, setModalExclusionType(java.awt.Dialog.ModalExclusionType)

addWindowListener

public void addWindowListener(WindowListener l)
添加指定的窗口侦听器，以从此窗口接收窗口事件。如果 l 为 null，则不抛出任何异常，且不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 窗口侦听器
另请参见：
removeWindowListener(java.awt.event.WindowListener), getWindowListeners()

addWindowStateListener

public void addWindowStateListener(WindowStateListener l)
添加指定的窗口状态侦听器，以从此窗口接收窗口事件。如果 l 为 null，则不抛出任何异常，且不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 窗口状态侦听器
从以下版本开始：
1.4
另请参见：
removeWindowStateListener(java.awt.event.WindowStateListener), getWindowStateListeners()

addWindowFocusListener

public void addWindowFocusListener(WindowFocusListener l)
添加指定的窗口焦点侦听器，以从此窗口接收窗口事件。如果 l 为 null，则不抛出任何异常，且不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 窗口焦点侦听器
从以下版本开始：
1.4
另请参见：
removeWindowFocusListener(java.awt.event.WindowFocusListener), getWindowFocusListeners()

removeWindowListener

public void removeWindowListener(WindowListener l)
移除指定的窗口侦听器，以便不再从此窗口接收窗口事件。如果 l 为 null，则不抛出任何异常，且不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 窗口侦听器
另请参见：
addWindowListener(java.awt.event.WindowListener), getWindowListeners()

removeWindowStateListener

public void removeWindowStateListener(WindowStateListener l)
移除指定的窗口状态侦听器，以便不再从此窗口接收窗口事件。如果 l 为 null，则不抛出任何异常，且不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 窗口状态侦听器
从以下版本开始：
1.4
另请参见：
addWindowStateListener(java.awt.event.WindowStateListener), getWindowStateListeners()

removeWindowFocusListener

public void removeWindowFocusListener(WindowFocusListener l)
移除指定的窗口焦点侦听器，以便不再从此窗口接收窗口事件。如果 l 为 null，则不抛出任何异常，且不执行任何操作。

有关 AWT 线程模式的详细信息，请参考 AWT Threading Issues。

参数：
l - 窗口焦点侦听器
从以下版本开始：
1.4
另请参见：
addWindowFocusListener(java.awt.event.WindowFocusListener), getWindowFocusListeners()

getWindowListeners

public WindowListener[] getWindowListeners()
返回在此窗口注册的所有窗口侦听器所组成的数组。

返回：
此窗口的所有 WindowListener；如果当前未注册窗口侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addWindowListener(java.awt.event.WindowListener), removeWindowListener(java.awt.event.WindowListener)

getWindowFocusListeners

public WindowFocusListener[] getWindowFocusListeners()
返回在此窗口注册的所有窗口焦点侦听器所组成的数组。

返回：
此窗口的所有 WindowFocusListener；如果当前未注册窗口焦点侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addWindowFocusListener(java.awt.event.WindowFocusListener), removeWindowFocusListener(java.awt.event.WindowFocusListener)

getWindowStateListeners

public WindowStateListener[] getWindowStateListeners()
返回在此窗口注册的所有窗口状态侦听器所组成的数组。

返回：
此窗口的所有 WindowStateListener；如果当前未注册窗口状态侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addWindowStateListener(java.awt.event.WindowStateListener), removeWindowStateListener(java.awt.event.WindowStateListener)

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。FooListener 是使用 addFooListener 方法注册的。

可以使用类文本指定 listenerType 参数，如 FooListener.class。例如，可以使用以下代码查询 Window w，获取其窗口侦听器：

WindowListener[] wls = (WindowListener[])(w.getListeners(WindowListener.class));
如果不存在此类侦听器，则此方法将返回一个空数组。

覆盖：
类 Container 中的 getListeners
参数：
listenerType - 请求的侦听器的类型；此参数应指定一个从 java.util.EventListener 继承的接口
返回：
在此窗口注册为 FooListener 的所有对象所组成的数组；如果未添加此类侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getWindowListeners()

processEvent

protected void processEvent(AWTEvent e)
处理此窗口上的事件。如果此事件为一个 WindowEvent，它将调用 processWindowEvent 方法，否则将调用其超类的 processEvent。

注意，如果此事件参数为 null，则此行为是不明确的，可能导致异常。

覆盖：
类 Container 中的 processEvent
参数：
e - 事件
另请参见：
Component.processComponentEvent(java.awt.event.ComponentEvent),
Component.processFocusEvent(java.awt.event.FocusEvent),
Component.processKeyEvent(java.awt.event.KeyEvent),
Component.processMouseEvent(java.awt.event.MouseEvent),
Component.processMouseMotionEvent(java.awt.event.MouseEvent),
Component.processInputMethodEvent(java.awt.event.InputMethodEvent),
Component.processHierarchyEvent(java.awt.event.HierarchyEvent),
Component.processMouseWheelEvent(java.awt.event.MouseWheelEvent)

processWindowEvent

protected void processWindowEvent(WindowEvent e)
处理此窗口上发生的窗口事件：将它们指派到任何注册的 WindowListener 对象。注：只有为此组件启用了窗口事件时，此方法才有可能被调用；这在存在以下条件之一时发生：
  • 通过 addWindowListener 注册 WindowListener 对象
  • 通过 enableEvents 启用窗口事件

注意，如果此事件参数为 null，则此行为是不明确的，可能导致异常。

参数：
e - 窗口事件
另请参见：
Component.enableEvents(long)

processWindowFocusEvent

protected void processWindowFocusEvent(WindowEvent e)
处理此窗口上发生的窗口焦点事件：将它们指派到任何注册的 WindowFocusListener 对象。注：只有为此组件启用了窗口事件时，此方法才有可能被调用。这在存在以下条件之一时发生：
  • 通过 addWindowFocusListener 注册 WindowFocusListener
  • 通过 enableEvents 启用窗口焦点事件

注意，如果此事件参数为 null，则此行为是不明确的，可能导致异常。

参数：
e - 窗口焦点事件
从以下版本开始：
1.4
另请参见：
Component.enableEvents(long)

processWindowStateEvent

protected void processWindowStateEvent(WindowEvent e)
处理此窗口上发生的窗口状态事件：将它们指派到任何注册的 WindowStateListener 对象。注：只有为此组件启用了窗口事件时，此方法才有可能被调用。这在存在以下条件之一时发生：
  • 通过 addWindowStateListener 注册 WindowStateListener
  • 通过 enableEvents 启用窗口状态事件

注意，如果此事件参数为 null，则此行为是不明确的，可能导致异常。

参数：
e - 窗口状态事件
从以下版本开始：
1.4
另请参见：
Component.enableEvents(long)

setAlwaysOnTop

public final void setAlwaysOnTop(boolean alwaysOnTop)
                          throws SecurityException
设置此窗口是否应该始终位于其他窗口上方。如果存在多个 always-on-top 窗口，则它们的相对顺序没有指定，该顺序与平台有关。

如果某个其他窗口已经是 always-on-top，则不指定这些窗口之间的相互顺序（与平台有关）。任何窗口都不会置于 always-on-top 窗口之上，除非它也是一个 always-on-top 窗口。

所有 always-on-top 窗口拥有的窗口将继承此状态，自动成为 always-on-top 窗口。如果某个窗口不再是 always-on-top 窗口，则它所拥有的窗口也不再是 always-on-top 窗口。当 always-on-top 窗口调用 toBack 时，其 always-on-top 状态将设置为 false。

如果对某个窗口调用此方法且参数值为 true，并且该窗口可见，平台也支持此窗口为 always-on-top，那么该窗口将立即向前，“锁定”在最顶层位置。如果窗口当前不可见，那么此方法将 always-on-top 状态设置为 true，但窗口不会向前。如果以后显示该窗口，那么它将 always-on-top。

如果 alwaysOnTop 为 true，则此方法可使窗口 always-on-top。如果窗口是可见的（这包括将窗口前置，即 toFront），则将其“锁定”在最顶层的位置。如果窗口不可见，则除了设置 always-on-top 的属性之外，不执行任何操作。如果以后窗口显示出来，则该窗口将 always-on-top。如果窗口已经位于顶层，则此调用不执行任何操作。

如果对某个窗口调用此方法且参数值为 false，则 always-on-top 状态被设置为常规。该窗口保持在最顶层，但对于任何其他窗口来说，其 z-order 可以更改。对已经是常规状态的窗口调用此方法且参数值为 false 将无效。如果没有其他 always-on-top 窗口，将 always-on-top 状态设置为 false 对窗口的相对 z-order 没有影响。

注：有些平台可能不支持 always-on-top 窗口。要检测当前平台是否支持 always-on-top 窗口，请使用 Toolkit.isAlwaysOnTopSupported() 和 isAlwaysOnTopSupported()。如果工具包或此窗口不支持 always-on-top 模式，则调用此方法无效。

如果安装了 SecurityManager，则必须授予调用线程 AWTPermission "setWindowAlwaysOnTop" 权限，才能设置此属性值。如果未授予此权限，则此方法将抛出 SecurityException，并且属性的当前值保持不变。

参数：
alwaysOnTop - 如果窗口应该始终位于其他窗口上方，则该参数为 true
抛出：
SecurityException - 如果调用线程无权设置 always-on-top 属性值。
从以下版本开始：
1.5
另请参见：
isAlwaysOnTop(),
toFront(),
toBack(),
AWTPermission,
isAlwaysOnTopSupported(),
Toolkit.isAlwaysOnTopSupported()

isAlwaysOnTopSupported

public boolean isAlwaysOnTopSupported()
返回此窗口是否支持 always-on-top 模式。某些平台不支持 always-on-top 窗口，而另一些只支持某种 top-level（顶层）窗口；例如，某个平台不支持 always-on-top 模式对话框。

返回：
如果工具包和此窗口支持 always-on-top 模式，则返回 true；如果此窗口不支持 always-on-top 模式，或者工具包不支持 always-on-top 窗口，则返回 false。
从以下版本开始：
1.6
另请参见：
setAlwaysOnTop(boolean), Toolkit.isAlwaysOnTopSupported()

isAlwaysOnTop

public final boolean isAlwaysOnTop()
返回此窗口是否为 always-on-top 窗口。

返回：
如果此窗口处于 always-on-top 状态，则返回 true，否则，返回 false
从以下版本开始：
1.5
另请参见：
setAlwaysOnTop(boolean)

getFocusOwner

public Component getFocusOwner()
如果此窗口为焦点窗口，则返回是焦点窗口的子组件；否则返回 null。

返回：
具有焦点的子组件；如果此窗口不是焦点窗口，则返回 null
另请参见：
getMostRecentFocusOwner(), isFocused()

getMostRecentFocusOwner

public Component getMostRecentFocusOwner()
返回此窗口的子组件，该子组件在此窗口为焦点窗口时将接收焦点。如果此窗口当前为焦点窗口，则此方法将返回与 getFocusOwner() 相同的组件。如果此窗口不是焦点窗口，则返回最近请求焦点的子组件。如果没有子组件请求过焦点，并且这是一个可成为焦点的窗口，则返回此窗口最初可成为焦点的组件。如果没有子组件请求过焦点，并且这是一个不能成为焦点的窗口，则返回 null。

返回：
在此窗口成为焦点窗口时，将接收焦点的子组件
从以下版本开始：
1.4
另请参见：
getFocusOwner(),
isFocused(),
isFocusableWindow()

isActive

public boolean isActive()
返回此窗口是否为活动窗口。仅有一个 Frame 或 Dialog 可以处于活动状态。本机窗口系统表示具有特殊修饰的活动窗口或其子窗口，如高亮的标题栏。活动窗口始终是焦点窗口，或者是拥有该焦点窗口的第一个 Frame 或 Dialog。

返回：
此窗口是否为活动窗口。
从以下版本开始：
1.4
另请参见：
isFocused()

isFocused

public boolean isFocused()
返回此窗口是否为焦点窗口。如果存在焦点所有者，则焦点窗口就是（或者包含）焦点所有者的窗口。如果不存在焦点所有者，则没有作为焦点的窗口。

如果焦点窗口是一个 Frame 或 Dialog，那么它同时也是一个活动窗口。否则，活动窗口将是拥有焦点窗口的第一个 Frame 或 Dialog。

返回：
此窗口是否为焦点窗口。
从以下版本开始：
1.4
另请参见：
isActive()

getFocusTraversalKeys

public Set<AWTKeyStroke> getFocusTraversalKeys(int id)
获取此窗口的焦点遍历键。（有关每个键的完整描述，请参阅 setFocusTraversalKeys。）

如果未为此窗口显式设置遍历键，则返回此窗口的父窗口的遍历键。如果未为此窗口的任何祖先显式设置遍历键，则返回当前 KeyboardFocusManager 的默认遍历键。

覆盖：
类 Container 中的 getFocusTraversalKeys
参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一
返回：
指定键的 AWTKeyStroke
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS、KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 或 KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS 之一
从以下版本开始：
1.4
另请参见：
Container.setFocusTraversalKeys(int, java.util.Set), KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS, KeyboardFocusManager.DOWN_CYCLE_TRAVERSAL_KEYS

setFocusCycleRoot

public final void setFocusCycleRoot(boolean focusCycleRoot)
不执行任何操作，因为窗口必须始终是焦点遍历循环的根。忽略传入的值。

覆盖：
类 Container 中的 setFocusCycleRoot
参数：
focusCycleRoot - 忽略此值
从以下版本开始：
1.4
另请参见：
isFocusCycleRoot(),
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
Container.getFocusTraversalPolicy()

isFocusCycleRoot

public final boolean isFocusCycleRoot()
始终返回 true，因为所有窗口必须是焦点遍历循环的根。

覆盖：
类 Container 中的 isFocusCycleRoot
返回：
true
从以下版本开始：
1.4
另请参见：
setFocusCycleRoot(boolean), Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy), Container.getFocusTraversalPolicy()

getFocusCycleRootAncestor

public final Container getFocusCycleRootAncestor()
始终返回 null，因为窗口没有祖先；它们表示组件层次结构的顶层。

覆盖：
类 Component 中的 getFocusCycleRootAncestor
返回：
null
从以下版本开始：
1.4
另请参见：
Container.isFocusCycleRoot()

isFocusableWindow

public final boolean isFocusableWindow()
返回此窗口是否可以成为焦点窗口，也就是说，此窗口或其任何子组件是否可以成为焦点所有者。对于可成为焦点的 Frame 或 Dialog，其可成为焦点的窗口状态必须设置为 true。对于不可成为焦点的 Frame 或 Dialog 的窗口，其可成为焦点的窗口状态必须设置为 true，其最近拥有的 Frame 或 Dialog 必须显示在屏幕上，而且它必须至少包含其焦点遍历循环中的一个组件。如果未满足这些条件中的任何一个条件，则此窗口及其任何子组件都不能成为焦点所有者。

返回：
如果此窗口可以成为焦点窗口，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
getFocusableWindowState(), setFocusableWindowState(boolean), isShowing(), Component.isFocusable()

getFocusableWindowState

public boolean getFocusableWindowState()
返回如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。如果此方法返回 false，则 isFocusableWindow 也将返回 false。如果此方法返回 true，则 isFocusableWindow 可能返回 true，也可能返回 false，具体取决于窗口要成为焦点窗口所必须满足的其他要求。

默认情况下，所有窗口都具有 focusable 的窗口状态 true。

返回：
此窗口是否可成为焦点窗口
从以下版本开始：
1.4
另请参见：
isFocusableWindow(), setFocusableWindowState(boolean), isShowing(), Component.setFocusable(boolean)

setFocusableWindowState

public void setFocusableWindowState(boolean focusableWindowState)
设置如果此窗口满足 isFocusableWindow 中列出的其他要求，其是否可以成为焦点窗口。如果此窗口可成为焦点窗口状态设置为 false，则 isFocusableWindow 将返回 false。如果此窗口的可成为焦点的窗口状态设置为 true，则 isFocusableWindow 可能返回 true，也可能返回 false，具体取决于要成为焦点的窗口所必须满足的其他要求。

将窗口的焦点状态设置为 false 是 AWT 标识应用程序的标准机制，AWT 是可用作浮动调色板或工具栏的窗口，因此应为是不可为焦点的窗口。在可见的 Window 上设置焦点状态，可能在某些平台上产生延迟的结果 — 只有在 Window 成为隐藏窗口，然后再可见后才发生实际的更改。为确保行为跨平台的一致性，当 Window 不可见时设置 Window 的焦点状态，然后再显示它。

参数：
focusableWindowState - 此窗口是否可以成为焦点窗口
从以下版本开始：
1.4
另请参见：
isFocusableWindow(),
getFocusableWindowState(),
isShowing(),
Component.setFocusable(boolean)

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。为此类的所有绑定 (bound) 属性注册侦听器，包括：
  • 此窗口的字体 ("font")
  • 此窗口的背景色 ("background")
  • 此窗口的前景色 ("foreground")
  • 此窗口的可聚焦性 ("focusable")
  • 此窗口的焦点遍历键启用状态 ("focusTraversalKeysEnabled")
  • 此窗口的 FORWARD_TRAVERSAL_KEYS 集 ("forwardFocusTraversalKeys")
  • 此窗口的 BACKWARD_TRAVERSAL_KEYS 集 ("backwardFocusTraversalKeys")
  • 此窗口的 UP_CYCLE_TRAVERSAL_KEYS 集 ("upCycleFocusTraversalKeys")
  • 此窗口的 DOWN_CYCLE_TRAVERSAL_KEYS 集 ("downCycleFocusTraversalKeys")
  • 此窗口的焦点遍历策略 ("focusTraversalPolicy")
  • 此窗口的可成为焦点的窗口状态 ("focusableWindowState")
  • 此窗口的 always-on-top 状态 ("alwaysOnTop")
注意，如果此窗口在继承一个绑定属性，则不触发任何事件来响应继承属性中的更改。

如果侦听器为 null，则不抛出任何异常，且不执行任何操作。

覆盖：
类 Container 中的 addPropertyChangeListener
参数：
listener - 要添加的 PropertyChangeListener
另请参见：
Component.removePropertyChangeListener(java.beans.PropertyChangeListener), addPropertyChangeListener(java.lang.String,java.beans.PropertyChangeListener)

addPropertyChangeListener

public void addPropertyChangeListener(String propertyName,
                                      PropertyChangeListener listener)
将 PropertyChangeListener 添加到某个特定属性的侦听器列表。指定的属性可以是用户定义的，也可以是下列属性之一：
  • 此窗口的字体 ("font")
  • 此窗口的背景色 ("background")
  • 此窗口的前景色 ("foreground")
  • 此窗口的可聚焦性 ("focusable")
  • 此窗口的焦点遍历键启用状态 ("focusTraversalKeysEnabled")
  • 此窗口的 FORWARD_TRAVERSAL_KEYS 集 ("forwardFocusTraversalKeys")
  • 此窗口的 BACKWARD_TRAVERSAL_KEYS 集 ("backwardFocusTraversalKeys")
  • 此窗口的 UP_CYCLE_TRAVERSAL_KEYS 集 ("upCycleFocusTraversalKeys")
  • 此窗口的 DOWN_CYCLE_TRAVERSAL_KEYS 集 ("downCycleFocusTraversalKeys")
  • 此窗口的焦点遍历策略 ("focusTraversalPolicy")
  • 此窗口的可成为焦点的窗口状态 ("focusableWindowState")
  • 此窗口的 always-on-top 状态 ("alwaysOnTop")
注意，如果此窗口在继承一个绑定属性，则不触发任何事件来响应继承属性中的更改。

如果侦听器为 null，则不抛出任何异常，且不执行任何操作。

覆盖：
类 Container 中的 addPropertyChangeListener
参数：
propertyName - 上文列出的属性名之一
listener - 要添加的 PropertyChangeListener
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), Component.removePropertyChangeListener(java.beans.PropertyChangeListener)

postEvent

@Deprecated
public boolean postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。

指定者：
接口 MenuContainer 中的 postEvent
覆盖：
类 Component 中的 postEvent

isShowing

public boolean isShowing()
检查此窗口是否显示在屏幕上。

覆盖：
类 Component 中的 isShowing
返回：
如果正在显示组件，则返回 true；否则返回 false
另请参见：
Component.setVisible(boolean)

applyResourceBundle

@Deprecated
public void applyResourceBundle(ResourceBundle rb)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。

applyResourceBundle

@Deprecated
public void applyResourceBundle(String rbName)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此窗口关联的 AccessibleContext。对于窗口，AccessibleContext 采取 AccessibleAWTWindow 的形式。如有必要，创建新的 AccessibleAWTWindow 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
充当此窗口的 AccessibleContext 的 AccessibleAWTWindow
从以下版本开始：
1.3

getGraphicsConfiguration

public GraphicsConfiguration getGraphicsConfiguration()
此方法返回由此窗口使用的 GraphicsConfiguration。

覆盖：
类 Component 中的 getGraphicsConfiguration
返回：
此 Component 使用的 GraphicsConfiguration，或者返回 null
从以下版本开始：
1.3

setLocationRelativeTo

public void setLocationRelativeTo(Component c)
设置窗口相对于指定组件的位置。

如果组件当前未显示，或者 c 为 null，则此窗口将置于屏幕的中央。中点可以使用 GraphicsEnvironment.getCenterPoint 确定。

如果该组件的底部在屏幕外，则将该窗口放置在 Component 最接近窗口中心的一侧。因此，如果 Component 在屏幕的右部，则 Window 将被放置在左部，反之亦然。

参数：
c - 确定窗口位置涉及的组件
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.getCenterPoint()

createBufferStrategy

public void createBufferStrategy(int numBuffers)
为此组件上的多缓冲创建一个新策略。多缓冲对于呈现性能非常有用。此方法试图根据提供的缓冲区数创建可用的最佳策略。它将始终根据该缓冲区数创建 BufferStrategy。首先尝试 page-flipping 策略，然后使用加速缓冲区尝试 blitting 策略。最后使用不加速的 blitting 策略。

每次调用此方法时，将丢弃此组件的现有缓冲策略。

参数：
numBuffers - 要创建的缓冲区数
抛出：
IllegalArgumentException - 如果 numBuffers 小于 1。
IllegalStateException - 如果组件不可显示
从以下版本开始：
1.4
另请参见：
Component.isDisplayable(), getBufferStrategy()

createBufferStrategy

public void createBufferStrategy(int numBuffers,
                                 BufferCapabilities caps)
                          throws AWTException
根据所需缓冲区能力为此组件上的多缓冲创建新策略。在只需要加速的内存或页面翻转（由缓冲区能力指定）时，这很有用。

每次调用此方法时，将丢弃此组件的现有缓冲策略。

参数：
numBuffers - 要创建的缓冲区数，包括前缓冲区
caps - 创建缓冲策略所需的能力；不能为 null
抛出：
AWTException - 如果提供的能力不受支持或未得到满足；这是有可能发生的，例如，如果当前无足够的可用加速内存，或者指定了页翻转，但不可能实现。
IllegalArgumentException - 如果 numBuffers 小于 1，或者 caps 为 null
从以下版本开始：
1.4
另请参见：
getBufferStrategy()

getBufferStrategy

public BufferStrategy getBufferStrategy()
返回此组件使用的 BufferStrategy。如果尚未创建或已经释放了 BufferStrategy，那么此方法将返回 null。

返回：
此组件使用的缓冲策略
从以下版本开始：
1.4
另请参见：
createBufferStrategy(int)

setLocationByPlatform

public void setLocationByPlatform(boolean locationByPlatform)
设置窗口下次可见时应该出现的位置：本机窗口系统的默认位置，还是当前位置（由 getLocation 返回）。此行为模拟显示的本机窗口，而不是以编程方式设置其位置。如果未显式设置窗口的位置，那么大多数窗口操作系统将重叠显示窗口。一旦窗口显示在屏幕上，其实际位置就被确定。

还可以通过将系统属性 "java.awt.Window.locationByPlatform" 设置为 "true" 来启用此行为，但应优先考虑调用此方法。

在调用 setLocationByPlatform 清除窗口的此属性之后，调用 setVisible、setLocation 和 setBounds。

例如，在执行以下代码后：

 setLocationByPlatform(true);
 setVisible(true);
 boolean flag = isLocationByPlatform();
窗口将显示在平台的默认位置，flag 将为 false。

在以下示例中：

 setLocationByPlatform(true);
 setLocation(10, 10);
 boolean flag = isLocationByPlatform();
 setVisible(true);
窗口将显示在 (10, 10) 的位置，flag 将为 false。

参数：
locationByPlatform - 如果此窗口应出现在默认位置，则为 true，如果应出现在当前位置，则为 false
抛出：
IllegalComponentStateException - 如果此窗口显示在屏幕上，且 locationByPlatform 为 true。
从以下版本开始：
1.5
另请参见：
Component.setLocation(int, int), isShowing(), setVisible(boolean), isLocationByPlatform(), System.getProperty(String)

isLocationByPlatform

public boolean isLocationByPlatform()
如果此窗口下次可见时，出现在本机窗口操作系统的默认位置，则返回 true。如果窗口显示在屏幕上，则此方法始终返回 false。

返回：
此窗口是否将出现在默认位置
从以下版本开始：
1.5
另请参见：
setLocationByPlatform(boolean), isShowing()

setBounds

public void setBounds(int x,
                      int y,
                      int width,
                      int height)
移动组件并调整其大小。由 x 和 y 指定左上角的新位置，由 width 和 height 指定新的大小。

如果 width 值或 height 值小于之前调用 setMinimumSize 指定的最小大小，则它的值将自动增加。

覆盖：
类 Component 中的 setBounds
参数：
x - 组件的新 x 坐标
y - 组件的新 y 坐标
width - 组件的新 width
height - 组件的新 height
从以下版本开始：
1.6
另请参见：
Component.getBounds(),
Component.setLocation(int, int),
Component.setLocation(Point),
setSize(int, int),
setSize(Dimension),
setMinimumSize(java.awt.Dimension),
setLocationByPlatform(boolean),
isLocationByPlatform()

setBounds

public void setBounds(Rectangle r)
移动组件并调整其大小，使其符合新的有界矩形 r。由 r.x 和 r.y 指定组件的新位置，由 r.width 和 r.height 指定组件的新大小

如果 r.width 值或 r.height 值小于之前调用 setMinimumSize 指定的最小大小，则它的值将自动增加。

覆盖：
类 Component 中的 setBounds
参数：
r - 此组件的新的有界矩形
从以下版本开始：
1.6
另请参见：
Component.getBounds(),
Component.setLocation(int, int),
Component.setLocation(Point),
setSize(int, int),
setSize(Dimension),
setMinimumSize(java.awt.Dimension),
setLocationByPlatform(boolean),
isLocationByPlatform()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Window.AccessibleAWTWindow (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt
类 Window.AccessibleAWTWindow

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Window.AccessibleAWTWindow
所有已实现的接口：
Serializable, AccessibleComponent
直接已知子类：
Dialog.AccessibleAWTDialog, Frame.AccessibleAWTFrame, JWindow.AccessibleJWindow
正在封闭类：
Window
protected class Window.AccessibleAWTWindow
extends Container.AccessibleAWTContainer

此类实现对 Window 类的可访问性支持。它提供适合窗口用户界面元素的 Java Accessibility API 实现。

从以下版本开始：
1.3
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Window.AccessibleAWTWindow()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Window.AccessibleAWTWindow

protected Window.AccessibleAWTWindow()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含此对象当前状态集的 AccessibleStateSet 实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt (Java 2 Platform SE 6)

 java.awt
接口
ActiveEvent
Adjustable
Composite
CompositeContext
ItemSelectable
KeyEventDispatcher
KeyEventPostProcessor
LayoutManager
LayoutManager2
MenuContainer
Paint
PaintContext
PrintGraphics
Shape
Stroke
Transparency
类
AlphaComposite
AWTEvent
AWTEventMulticaster
AWTKeyStroke
AWTPermission
BasicStroke
BorderLayout
BufferCapabilities
BufferCapabilities.FlipContents
Button
Canvas
CardLayout
Checkbox
CheckboxGroup
CheckboxMenuItem
Choice
Color
Component
ComponentOrientation
Container
ContainerOrderFocusTraversalPolicy
Cursor
DefaultFocusTraversalPolicy
DefaultKeyboardFocusManager
Desktop
Dialog
Dimension
DisplayMode
Event
EventQueue
FileDialog
FlowLayout
FocusTraversalPolicy
Font
FontMetrics
Frame
GradientPaint
Graphics
Graphics2D
GraphicsConfigTemplate
GraphicsConfiguration
GraphicsDevice
GraphicsEnvironment
GridBagConstraints
GridBagLayout
GridBagLayoutInfo
GridLayout
Image
ImageCapabilities
Insets
JobAttributes
JobAttributes.DefaultSelectionType
JobAttributes.DestinationType
JobAttributes.DialogType
JobAttributes.MultipleDocumentHandlingType
JobAttributes.SidesType
KeyboardFocusManager
Label
LinearGradientPaint
List
MediaTracker
Menu
MenuBar
MenuComponent
MenuItem
MenuShortcut
MouseInfo
MultipleGradientPaint
PageAttributes
PageAttributes.ColorType
PageAttributes.MediaType
PageAttributes.OrientationRequestedType
PageAttributes.OriginType
PageAttributes.PrintQualityType
Panel
Point
PointerInfo
Polygon
PopupMenu
PrintJob
RadialGradientPaint
Rectangle
RenderingHints
RenderingHints.Key
Robot
Scrollbar
ScrollPane
ScrollPaneAdjustable
SplashScreen
SystemColor
SystemTray
TextArea
TextComponent
TextField
TexturePaint
Toolkit
TrayIcon
Window
枚举
Component.BaselineResizeBehavior
Desktop.Action
Dialog.ModalExclusionType
Dialog.ModalityType
MultipleGradientPaint.ColorSpaceType
MultipleGradientPaint.CycleMethod
TrayIcon.MessageType
异常
AWTException
FontFormatException
HeadlessException
IllegalComponentStateException
错误
AWTError


java.awt (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt

包含用于创建用户界面和绘制图形图像的所有类。

请参见：
描述

接口摘要
ActiveEvent | 知道如何对自身进行指派的事件的接口。
Adjustable | 此接口用于那些具有可调整数值的对象，数值应包含在有限范围的值之内。
Composite | Composite 接口和 CompositeContext 一起定义了用基础图形区域组合绘图基本元素的方法。
CompositeContext | CompositeContext 接口为复合操作定义了已封装和已优化的环境。
ItemSelectable | 包含零个或多个可选则项的集合的对象接口。
KeyEventDispatcher | 在指派所有 KeyEvent 和为其确定目标时，KeyEventDispatcher 和当前 KeyboardFocusManager 一起使用。
KeyEventPostProcessor | 在最终解析所有未使用的 KeyEvent 时，需要将 KeyEventPostProcessor 和当前的 KeyboardFocusManager 一起使用。
LayoutManager | 定义知道如何布置 Container 类的接口。
LayoutManager2 | 为类定义接口，该类知道如何根据布局约束对象来布置 Container。
MenuContainer | 所有菜单相关容器的超类。
Paint | 此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。
PaintContext | PaintContext 接口定义了经过封装和优化的环境，使用此环境可以生成设备空间中的颜色模式，此模式用于在 Graphics2D 上进行填充操作或笔划操作。
PrintGraphics | 提供页面的打印图形上下文的抽象类。
Shape | Shape 接口提供了表示一些几何形状的对象的定义。
Stroke | Stroke 接口允许 Graphics2D 对象获得一个 Shape，该 Shape 是指定 Shape 的装饰轮廓，或该轮廓的风格表示形式。
Transparency | Transparency 接口定义用于实现类的通用透明模式。

类摘要
AlphaComposite | AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。
AWTEvent | 所有 AWT 事件的根事件类。
AWTEventMulticaster | AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
AWTKeyStroke | AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。
AWTPermission | 此类用于 AWT 权限。
BasicStroke | BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。
BorderLayout | 这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
BufferCapabilities | 缓冲区的能力和属性。
BufferCapabilities.FlipContents | 页面翻转后可能的后台缓冲区内容的一个类型安全的枚举
Button | 此类创建一个标签按钮。
Canvas | Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
CardLayout | CardLayout 对象是容器的布局管理器。
Checkbox | 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
CheckboxGroup | CheckboxGroup 类用于集合 Checkbox 按钮集。
CheckboxMenuItem | 此类表示一个可包括在菜单中的复选框。
Choice | Choice 类表示一个弹出式选择菜单。
Color | Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component | component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
ComponentOrientation | ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
Container | 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
ContainerOrderFocusTraversalPolicy | 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
Cursor | 封装鼠标光标的位图表示形式的类。
DefaultFocusTraversalPolicy | 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
DefaultKeyboardFocusManager | AWT 应用程序的默认 KeyboardFocusManager。
Desktop | Desktop 类允许 Java 应用程序启动已在本机桌面上注册的关联应用程序，以处理 URI 或文件。
Dialog | Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
Dimension | Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
DisplayMode | DisplayMode 类封装 GraphicsDevice 的位深、高度、宽度和刷新率。
Event | 注：Event 类已废弃，只可用于向后兼容。
EventQueue | EventQueue 是一个与平台无关的类，它将来自于底层同位体类和受信任的应用程序类的事件列入队列。
FileDialog | FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
FlowLayout | 流布局用于安排有向流中的组件，这非常类似于段落中的文本行。
FocusTraversalPolicy | FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。
Font | Font 类表示字体，可以使用它以可见方式呈现文本。
FontMetrics | FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
Frame | Frame 是带有标题和边框的顶层窗口。
GradientPaint | GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。
Graphics | Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Graphics2D | 此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。
GraphicsConfigTemplate | GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。
GraphicsConfiguration | GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。
GraphicsDevice | GraphicsDevice 类描述可以在特定图形环境中使用的图形设备。
GraphicsEnvironment | GraphicsEnvironment 类描述了 Java(tm) 应用程序在特定平台上可用的 GraphicsDevice 对象和 Font 对象的集合。
GridBagConstraints | GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
GridBagLayout | GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。
GridBagLayoutInfo | GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。
GridLayout | GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。
Image | 抽象类 Image 是表示图形图像的所有类的超类。
ImageCapabilities | 图像的功能和属性。
Insets | Insets 对象是容器边界的表示形式。
JobAttributes | 控制打印作业的属性集合。
JobAttributes.DefaultSelectionType | 可能的默认选择状态的类型安全的枚举。
JobAttributes.DestinationType | 可能的作业目标的类型安全枚举。
JobAttributes.DialogType | 显示给用户的可能对话框的类型安全枚举。
JobAttributes.MultipleDocumentHandlingType | 可能的多副本处理状态的类型安全枚举。
JobAttributes.SidesType | 可能的多页整版的类型安全枚举。
KeyboardFocusManager | KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。
Label | Label 对象是一个可在容器中放置文本的组件。
LinearGradientPaint | LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
List | List 组件为用户提供了一个可滚动的文本项列表。
MediaTracker | MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。
Menu | Menu 对象是从菜单栏部署的下拉式菜单组件。
MenuBar | MenuBar 类封装绑定到框架的菜单栏的平台概念。
MenuComponent | 抽象类 MenuComponent 是所有与菜单相关的组件的超类。
MenuItem | 菜单中的所有项必须属于类 MenuItem 或其子类之一。
MenuShortcut | 表示 MenuItem 键盘加速器的 MenuShortcut 类。
MouseInfo | MouseInfo 提供获取有关鼠标信息的方法，如鼠标指针位置和鼠标按钮数。
MultipleGradientPaint | 这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
PageAttributes | 用来控制打印页面输出的属性集。
PageAttributes.ColorType | 可能颜色状态的类型安全的枚举。
PageAttributes.MediaType | 可能的纸张大小的类型安全的枚举。
PageAttributes.OrientationRequestedType | 可能打印方向的类型安全的枚举。
PageAttributes.OriginType | 可能原点的类型安全的枚举。
PageAttributes.PrintQualityType | 可能的打印质量的类型安全的枚举。
Panel | Panel 是最简单的容器类。
Point | 表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
PointerInfo | 描述指针位置的类。
Polygon | Polygon 类封装了坐标空间中封闭的二维区域的描述。
PopupMenu | 此类实现能够在组件中的指定位置上动态弹出的菜单。
PrintJob | 启动并执行打印作业的抽象类。
RadialGradientPaint | RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。
Rectangle | Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
RenderingHints | RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。
RenderingHints.Key | 定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。
Robot | 此类用于为测试自动化、自运行演示程序和其他需要控制鼠标和键盘的应用程序生成本机系统输入事件。
Scrollbar | Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
ScrollPane | 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
ScrollPaneAdjustable | 此类表示 ScrollPane 的水平或垂直滚动条的状态。
SplashScreen | 在 Java 虚拟机 (JVM) 启动之前，可以在应用程序启动时创建闪现屏幕。
SystemColor | 封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
SystemTray | SystemTray 类表示桌面的系统托盘。
TextArea | TextArea 对象是显示文本的多行区域。
TextComponent | TextComponent 类是所有允许编辑文本的组件的超类。
TextField | TextField 对象是允许编辑单行文本的文本组件。
TexturePaint | TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。
Toolkit | 此类是所有 Abstract Window Toolkit 实际实现的抽象超类。
TrayIcon | TrayIcon 对象表示可以添加到系统托盘的托盘图标。
Window | Window 对象是一个没有边界和菜单栏的顶层窗口。

枚举摘要
Component.BaselineResizeBehavior | 常见方式的枚举，指示组件的基线可以随大小的更改而更改。
Desktop.Action | 表示动作类型。
Dialog.ModalExclusionType | 任何顶层窗口都可以标记为不受模式对话框阻塞。
Dialog.ModalityType | 模式对话框阻塞对某些顶层窗口的所有输入。
MultipleGradientPaint.ColorSpaceType | 在其中执行渐变插值操作的颜色空间。
MultipleGradientPaint.CycleMethod | 在渐变边界以外进行绘制时使用的方法。
TrayIcon.MessageType | MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。

异常摘要
AWTException | 表示发生了 Absract Window Toolkit 异常。
FontFormatException | 此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
HeadlessException | 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
IllegalComponentStateException | 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

错误摘要
AWTError 当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。

软件包 java.awt 的描述

包含用于创建用户界面和绘制图形图像的所有类。在 AWT 术语中，诸如按钮或滚动条之类的用户界面对象称为组件。Component 类是所有 AWT 组件的根。有关所有 AWT 组件的公共属性的详细描述，请参见 Component。

当用户与组件交互时，一些组件会激发事件。AWTEvent 类及其子类用于表示 AWT 组件能够激发的事件。有关 AWT 事件模型的描述，请参见 AWTEvent。

容器是一个可以包含组件和其他容器的组件。容器还可以具有布局管理器，用来控制容器中组件的可视化布局。AWT 包带有几个布局管理器类和一个接口，此接口可用于构建自己的布局管理器。有关更多信息，请参见 Container 和 LayoutManager。

补充说明

  • The AWT Focus Subsystem
  • The AWT Modality

从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • java.awt.Button.AccessibleAWTButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
        • java.awt.Canvas.AccessibleAWTCanvas
        • java.awt.Checkbox.AccessibleAWTCheckbox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue, java.awt.event.ItemListener)
        • java.awt.Choice.AccessibleAWTChoice (implements javax.accessibility.AccessibleAction)
        • java.awt.Container.AccessibleAWTContainer
          • java.awt.Panel.AccessibleAWTPanel
          • java.awt.ScrollPane.AccessibleAWTScrollPane
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
            • java.awt.Frame.AccessibleAWTFrame
        • java.awt.Label.AccessibleAWTLabel
        • java.awt.List.AccessibleAWTList (implements javax.accessibility.AccessibleSelection, java.awt.event.ActionListener, java.awt.event.ItemListener)
        • java.awt.List.AccessibleAWTList.AccessibleAWTListChild (implements javax.accessibility.Accessible)
        • java.awt.Scrollbar.AccessibleAWTScrollBar (implements javax.accessibility.AccessibleValue)
        • java.awt.TextComponent.AccessibleAWTTextComponent (implements javax.accessibility.AccessibleText, java.awt.event.TextListener)
          • java.awt.TextArea.AccessibleAWTTextArea
          • java.awt.TextField.AccessibleAWTTextField
      • java.awt.MenuComponent.AccessibleAWTMenuComponent (implements javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection, java.io.Serializable)
        • java.awt.MenuBar.AccessibleAWTMenuBar
        • java.awt.MenuItem.AccessibleAWTMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleValue)
          • java.awt.Menu.AccessibleAWTMenu
            • java.awt.PopupMenu.AccessibleAWTPopupMenu
    • java.awt.AlphaComposite (implements java.awt.Composite)
    • java.awt.AWTEventMulticaster (implements java.awt.event.ActionListener, java.awt.event.AdjustmentListener, java.awt.event.ComponentListener, java.awt.event.ContainerListener, java.awt.event.FocusListener, java.awt.event.HierarchyBoundsListener, java.awt.event.HierarchyListener, java.awt.event.InputMethodListener, java.awt.event.ItemListener, java.awt.event.KeyListener, java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener, java.awt.event.TextListener, java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
    • java.awt.AWTKeyStroke (implements java.io.Serializable)
    • java.awt.BasicStroke (implements java.awt.Stroke)
    • java.awt.BorderLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.BufferCapabilities (implements java.lang.Cloneable)
    • java.awt.BufferCapabilities.FlipContents
    • java.awt.image.BufferStrategy
      • java.awt.Component.BltBufferStrategy
      • java.awt.Component.FlipBufferStrategy
    • java.awt.CardLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.CheckboxGroup (implements java.io.Serializable)
    • java.awt.Color (implements java.awt.Paint, java.io.Serializable)
      • java.awt.SystemColor (implements java.io.Serializable)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Button (implements javax.accessibility.Accessible)
      • java.awt.Canvas (implements javax.accessibility.Accessible)
      • java.awt.Checkbox (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Choice (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Container
        • java.awt.Panel (implements javax.accessibility.Accessible)
        • java.awt.ScrollPane (implements javax.accessibility.Accessible)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • java.awt.Dialog
            • java.awt.FileDialog
          • java.awt.Frame (implements java.awt.MenuContainer)
      • java.awt.Label (implements javax.accessibility.Accessible)
      • java.awt.List (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
      • java.awt.Scrollbar (implements javax.accessibility.Accessible, java.awt.Adjustable)
      • java.awt.TextComponent (implements javax.accessibility.Accessible)
        • java.awt.TextArea
        • java.awt.TextField
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler (implements java.awt.event.ComponentListener)
    • java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler (implements java.awt.event.FocusListener)
    • java.awt.ComponentOrientation (implements java.io.Serializable)
    • java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • java.awt.Cursor (implements java.io.Serializable)
    • java.awt.Desktop
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
      • java.awt.Dimension (implements java.io.Serializable)
    • java.awt.DisplayMode
    • java.awt.Event (implements java.io.Serializable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
    • java.awt.EventQueue
    • java.awt.FlowLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • java.awt.FocusTraversalPolicy
      • java.awt.ContainerOrderFocusTraversalPolicy (implements java.io.Serializable)
        • java.awt.DefaultFocusTraversalPolicy
    • java.awt.Font (implements java.io.Serializable)
    • java.awt.FontMetrics (implements java.io.Serializable)
    • java.awt.GradientPaint (implements java.awt.Paint)
    • java.awt.Graphics
      • java.awt.Graphics2D
    • java.awt.GraphicsConfigTemplate (implements java.io.Serializable)
    • java.awt.GraphicsConfiguration
    • java.awt.GraphicsDevice
    • java.awt.GraphicsEnvironment
    • java.awt.GridBagConstraints (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.GridBagLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • java.awt.GridBagLayoutInfo (implements java.io.Serializable)
    • java.awt.GridLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • java.awt.Image
    • java.awt.ImageCapabilities (implements java.lang.Cloneable)
    • java.awt.Insets (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.JobAttributes (implements java.lang.Cloneable)
    • java.awt.JobAttributes.DefaultSelectionType
    • java.awt.JobAttributes.DestinationType
    • java.awt.JobAttributes.DialogType
    • java.awt.JobAttributes.MultipleDocumentHandlingType
    • java.awt.JobAttributes.SidesType
    • java.awt.KeyboardFocusManager (implements java.awt.KeyEventDispatcher, java.awt.KeyEventPostProcessor)
      • java.awt.DefaultKeyboardFocusManager
    • java.awt.MediaTracker (implements java.io.Serializable)
    • java.awt.MenuComponent (implements java.io.Serializable)
      • java.awt.MenuBar (implements javax.accessibility.Accessible, java.awt.MenuContainer)
      • java.awt.MenuItem (implements javax.accessibility.Accessible)
        • java.awt.CheckboxMenuItem (implements javax.accessibility.Accessible, java.awt.ItemSelectable)
        • java.awt.Menu (implements javax.accessibility.Accessible, java.awt.MenuContainer)
          • java.awt.PopupMenu
    • java.awt.MenuShortcut (implements java.io.Serializable)
    • java.awt.MouseInfo
    • java.awt.MultipleGradientPaint (implements java.awt.Paint)
      • java.awt.LinearGradientPaint
      • java.awt.RadialGradientPaint
    • java.awt.PageAttributes (implements java.lang.Cloneable)
    • java.awt.PageAttributes.ColorType
    • java.awt.PageAttributes.MediaType
    • java.awt.PageAttributes.OrientationRequestedType
    • java.awt.PageAttributes.OriginType
    • java.awt.PageAttributes.PrintQualityType
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.awt.AWTPermission
    • java.awt.geom.Point2D (implements java.lang.Cloneable)
      • java.awt.Point (implements java.io.Serializable)
    • java.awt.PointerInfo
    • java.awt.Polygon (implements java.io.Serializable, java.awt.Shape)
    • java.awt.PrintJob
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Rectangle2D
        • java.awt.Rectangle (implements java.io.Serializable, java.awt.Shape)
    • java.awt.RenderingHints (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.awt.RenderingHints.Key
    • java.awt.Robot
    • java.awt.ScrollPaneAdjustable (implements java.awt.Adjustable, java.io.Serializable)
    • java.awt.SplashScreen
    • java.awt.SystemTray
    • java.awt.TexturePaint (implements java.awt.Paint)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.awt.AWTError
      • java.lang.Exception
        • java.awt.AWTException
        • java.awt.FontFormatException
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.awt.IllegalComponentStateException
          • java.lang.UnsupportedOperationException
            • java.awt.HeadlessException
    • java.awt.Toolkit
    • java.awt.TrayIcon

接口分层结构

  • java.awt.ActiveEvent
  • java.awt.Adjustable
  • java.awt.Composite
  • java.awt.CompositeContext
  • java.awt.ItemSelectable
  • java.awt.KeyEventDispatcher
  • java.awt.KeyEventPostProcessor
  • java.awt.LayoutManager
    • java.awt.LayoutManager2
  • java.awt.MenuContainer
  • java.awt.PaintContext
  • java.awt.PrintGraphics
  • java.awt.Shape
  • java.awt.Stroke
  • java.awt.Transparency
    • java.awt.Paint

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.awt.Desktop.Action
      • java.awt.MultipleGradientPaint.CycleMethod
      • java.awt.MultipleGradientPaint.ColorSpaceType
      • java.awt.TrayIcon.MessageType
      • java.awt.Dialog.ModalityType
      • java.awt.Dialog.ModalExclusionType
      • java.awt.Component.BaselineResizeBehavior
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt
的使用

使用 java.awt 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.imageio | Java Image I/O API 的主要包。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 使用的 java.awt 中的类
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.AccessibleAWTComponent
用来为可访问性提供默认支持的 Component 的内部类。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
Image
抽象类 Image 是表示图形图像的所有类的超类。
MenuContainer
所有菜单相关容器的超类。
Panel
Panel 是最简单的容器类。
Panel.AccessibleAWTPanel
此类实现 Panel 类的可访问性支持。

java.awt 使用的 java.awt 中的类
Adjustable
此接口用于那些具有可调整数值的对象，数值应包含在有限范围的值之内。
AlphaComposite
AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。
AWTEvent
所有 AWT 事件的根事件类。
AWTException
表示发生了 Absract Window Toolkit 异常。
AWTKeyStroke
AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。
BufferCapabilities
缓冲区的能力和属性。
BufferCapabilities.FlipContents
页面翻转后可能的后台缓冲区内容的一个类型安全的枚举
Button
此类创建一个标签按钮。
Canvas
Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
Checkbox
复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
CheckboxGroup
CheckboxGroup 类用于集合 Checkbox 按钮集。
CheckboxMenuItem
此类表示一个可包括在菜单中的复选框。
Choice
Choice 类表示一个弹出式选择菜单。
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.AccessibleAWTComponent
用来为可访问性提供默认支持的 Component 的内部类。
Component.BaselineResizeBehavior
常见方式的枚举，指示组件的基线可以随大小的更改而更改。
ComponentOrientation
ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
Composite
Composite 接口和 CompositeContext 一起定义了用基础图形区域组合绘图基本元素的方法。
CompositeContext
CompositeContext 接口为复合操作定义了已封装和已优化的环境。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。
ContainerOrderFocusTraversalPolicy
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
Cursor
封装鼠标光标的位图表示形式的类。
Desktop
Desktop 类允许 Java 应用程序启动已在本机桌面上注册的关联应用程序，以处理 URI 或文件。
Desktop.Action
表示动作类型。
Dialog
Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
Dialog.ModalExclusionType
任何顶层窗口都可以标记为不受模式对话框阻塞。
Dialog.ModalityType
模式对话框阻塞对某些顶层窗口的所有输入。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
DisplayMode
DisplayMode 类封装 GraphicsDevice 的位深、高度、宽度和刷新率。
Event
注：Event 类已废弃，只可用于向后兼容。
EventQueue
EventQueue 是一个与平台无关的类，它将来自于底层同位体类和受信任的应用程序类的事件列入队列。
FileDialog
FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
FocusTraversalPolicy
FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
FontFormatException
此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
Frame
Frame 是带有标题和边框的顶层窗口。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Graphics2D
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。
GraphicsConfigTemplate
GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。
GraphicsConfiguration
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。
GraphicsDevice
GraphicsDevice 类描述可以在特定图形环境中使用的图形设备。
GraphicsEnvironment
GraphicsEnvironment 类描述了 Java(tm) 应用程序在特定平台上可用的 GraphicsDevice 对象和 Font 对象的集合。
GridBagConstraints
GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
GridBagLayoutInfo
GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。
HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
Image
抽象类 Image 是表示图形图像的所有类的超类。
ImageCapabilities
图像的功能和属性。
Insets
Insets 对象是容器边界的表示形式。
ItemSelectable
包含零个或多个可选则项的集合的对象接口。
JobAttributes
控制打印作业的属性集合。
JobAttributes.DefaultSelectionType
可能的默认选择状态的类型安全的枚举。
JobAttributes.DestinationType
可能的作业目标的类型安全枚举。
JobAttributes.DialogType
显示给用户的可能对话框的类型安全枚举。
JobAttributes.MultipleDocumentHandlingType
可能的多副本处理状态的类型安全枚举。
JobAttributes.SidesType
可能的多页整版的类型安全枚举。
KeyboardFocusManager
KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。
KeyEventDispatcher
在指派所有 KeyEvent 和为其确定目标时，KeyEventDispatcher 和当前 KeyboardFocusManager 一起使用。
KeyEventPostProcessor
在最终解析所有未使用的 KeyEvent 时，需要将 KeyEventPostProcessor 和当前的 KeyboardFocusManager 一起使用。
Label
Label 对象是一个可在容器中放置文本的组件。
LayoutManager
定义知道如何布置 Container 类的接口。
LayoutManager2
为类定义接口，该类知道如何根据布局约束对象来布置 Container。
List
List 组件为用户提供了一个可滚动的文本项列表。
Menu
Menu 对象是从菜单栏部署的下拉式菜单组件。
Menu.AccessibleAWTMenu
菜单的内部类，用于为可访问性提供默认支持。
MenuBar
MenuBar 类封装绑定到框架的菜单栏的平台概念。
MenuComponent
抽象类 MenuComponent 是所有与菜单相关的组件的超类。
MenuComponent.AccessibleAWTMenuComponent
用于为可访问性提供默认支持的 MenuComponent 的内部类。
MenuContainer
所有菜单相关容器的超类。
MenuItem
菜单中的所有项必须属于类 MenuItem 或其子类之一。
MenuItem.AccessibleAWTMenuItem
用于为可访问性提供默认支持的 MenuItem 的内部类。
MenuShortcut
表示 MenuItem 键盘加速器的 MenuShortcut 类。
MultipleGradientPaint
这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
MultipleGradientPaint.ColorSpaceType
在其中执行渐变插值操作的颜色空间。
MultipleGradientPaint.CycleMethod
在渐变边界以外进行绘制时使用的方法。
PageAttributes
用来控制打印页面输出的属性集。
PageAttributes.ColorType
可能颜色状态的类型安全的枚举。
PageAttributes.MediaType
可能的纸张大小的类型安全的枚举。
PageAttributes.OrientationRequestedType
可能打印方向的类型安全的枚举。
PageAttributes.OriginType
可能原点的类型安全的枚举。
PageAttributes.PrintQualityType
可能的打印质量的类型安全的枚举。
Paint
此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。
PaintContext
PaintContext 接口定义了经过封装和优化的环境，使用此环境可以生成设备空间中的颜色模式，此模式用于在 Graphics2D 上进行填充操作或笔划操作。
Panel
Panel 是最简单的容器类。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
PointerInfo
描述指针位置的类。
Polygon
Polygon 类封装了坐标空间中封闭的二维区域的描述。
PopupMenu
此类实现能够在组件中的指定位置上动态弹出的菜单。
PrintJob
启动并执行打印作业的抽象类。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
RenderingHints
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。
RenderingHints.Key
定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。
Scrollbar
Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
ScrollPane
实现用于单个子组件的自动水平和/或垂直滚动的容器类。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。
SplashScreen
在 Java 虚拟机 (JVM) 启动之前，可以在应用程序启动时创建闪现屏幕。
Stroke
Stroke 接口允许 Graphics2D 对象获得一个 Shape，该 Shape 是指定 Shape 的装饰轮廓，或该轮廓的风格表示形式。
SystemColor
封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
SystemTray
SystemTray 类表示桌面的系统托盘。
TextArea
TextArea 对象是显示文本的多行区域。
TextComponent
TextComponent 类是所有允许编辑文本的组件的超类。
TextComponent.AccessibleAWTTextComponent
此类实现对 TextComponent 类的可访问性支持。
TextField
TextField 对象是允许编辑单行文本的文本组件。
Toolkit
此类是所有 Abstract Window Toolkit 实际实现的抽象超类。
Transparency
Transparency 接口定义用于实现类的通用透明模式。
TrayIcon
TrayIcon 对象表示可以添加到系统托盘的托盘图标。
TrayIcon.MessageType
MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。
Window
Window 对象是一个没有边界和菜单栏的顶层窗口。
Window.AccessibleAWTWindow
此类实现对 Window 类的可访问性支持。

java.awt.dnd 使用的 java.awt 中的类
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Cursor
封装鼠标光标的位图表示形式的类。
HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
Image
抽象类 Image 是表示图形图像的所有类的超类。
Insets
Insets 对象是容器边界的表示形式。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。

java.awt.event 使用的 java.awt 中的类
ActiveEvent
知道如何对自身进行指派的事件的接口。
Adjustable
此接口用于那些具有可调整数值的对象，数值应包含在有限范围的值之内。
AWTEvent
所有 AWT 事件的根事件类。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
ItemSelectable
包含零个或多个可选则项的集合的对象接口。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Window
Window 对象是一个没有边界和菜单栏的顶层窗口。

java.awt.font 使用的 java.awt 中的类
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
Graphics2D
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。
Image
抽象类 Image 是表示图形图像的所有类的超类。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。

java.awt.geom 使用的 java.awt 中的类
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。

java.awt.im 使用的 java.awt 中的类
AWTEvent
所有 AWT 事件的根事件类。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

java.awt.im.spi 使用的 java.awt 中的类
AWTEvent
所有 AWT 事件的根事件类。
AWTException
表示发生了 Absract Window Toolkit 异常。
Image
抽象类 Image 是表示图形图像的所有类的超类。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Window
Window 对象是一个没有边界和菜单栏的顶层窗口。

java.awt.image 使用的 java.awt 中的类
BufferCapabilities
缓冲区的能力和属性。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Graphics2D
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。
GraphicsConfiguration
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。
Image
抽象类 Image 是表示图形图像的所有类的超类。
ImageCapabilities
图像的功能和属性。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
RenderingHints
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。
Transparency
Transparency 接口定义用于实现类的通用透明模式。

java.awt.image.renderable 使用的 java.awt 中的类
RenderingHints
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。

java.awt.print 使用的 java.awt 中的类
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。

java.beans 使用的 java.awt 中的类
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Image
抽象类 Image 是表示图形图像的所有类的超类。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

java.beans.beancontext 使用的 java.awt 中的类
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。

javax.accessibility 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Cursor
封装鼠标光标的位图表示形式的类。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
IllegalComponentStateException
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

javax.imageio 使用的 java.awt 中的类
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

javax.print 使用的 java.awt 中的类
GraphicsConfiguration
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。
HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。

javax.swing 使用的 java.awt 中的类
Adjustable
此接口用于那些具有可调整数值的对象，数值应包含在有限范围的值之内。
AWTKeyStroke
AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.AccessibleAWTComponent
用来为可访问性提供默认支持的 Component 的内部类。
Component.BaselineResizeBehavior
常见方式的枚举，指示组件的基线可以随大小的更改而更改。
ComponentOrientation
ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。
Cursor
封装鼠标光标的位图表示形式的类。
DefaultKeyboardFocusManager
AWT 应用程序的默认 KeyboardFocusManager。
Dialog
Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
Dialog.AccessibleAWTDialog
此类实现对 Dialog 类的可访问性支持。
Dialog.ModalityType
模式对话框阻塞对某些顶层窗口的所有输入。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
FocusTraversalPolicy
FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
Frame
Frame 是带有标题和边框的顶层窗口。
Frame.AccessibleAWTFrame
此类实现对 Frame 类的可访问性支持。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
GraphicsConfiguration
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。
HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
IllegalComponentStateException
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。
Image
抽象类 Image 是表示图形图像的所有类的超类。
Insets
Insets 对象是容器边界的表示形式。
ItemSelectable
包含零个或多个可选则项的集合的对象接口。
KeyboardFocusManager
KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。
KeyEventDispatcher
在指派所有 KeyEvent 和为其确定目标时，KeyEventDispatcher 和当前 KeyboardFocusManager 一起使用。
KeyEventPostProcessor
在最终解析所有未使用的 KeyEvent 时，需要将 KeyEventPostProcessor 和当前的 KeyboardFocusManager 一起使用。
LayoutManager
定义知道如何布置 Container 类的接口。
LayoutManager2
为类定义接口，该类知道如何根据布局约束对象来布置 Container。
MediaTracker
MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。
MenuContainer
所有菜单相关容器的超类。
Panel
Panel 是最简单的容器类。
Panel.AccessibleAWTPanel
此类实现 Panel 类的可访问性支持。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。
Window
Window 对象是一个没有边界和菜单栏的顶层窗口。
Window.AccessibleAWTWindow
此类实现对 Window 类的可访问性支持。

javax.swing.border 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.BaselineResizeBehavior
常见方式的枚举，指示组件的基线可以随大小的更改而更改。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Insets
Insets 对象是容器边界的表示形式。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

javax.swing.colorchooser 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
MenuContainer
所有菜单相关容器的超类。

javax.swing.event 使用的 java.awt 中的类
AWTEvent
所有 AWT 事件的根事件类。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。

javax.swing.plaf 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.BaselineResizeBehavior
常见方式的枚举，指示组件的基线可以随大小的更改而更改。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Insets
Insets 对象是容器边界的表示形式。
Paint
此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Transparency
Transparency 接口定义用于实现类的通用透明模式。

javax.swing.plaf.basic 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.BaselineResizeBehavior
常见方式的枚举，指示组件的基线可以随大小的更改而更改。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
GridBagConstraints
GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
Insets
Insets 对象是容器边界的表示形式。
ItemSelectable
包含零个或多个可选则项的集合的对象接口。
LayoutManager
定义知道如何布置 Container 类的接口。
LayoutManager2
为类定义接口，该类知道如何根据布局约束对象来布置 Container。
MenuContainer
所有菜单相关容器的超类。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。
Window
Window 对象是一个没有边界和菜单栏的顶层窗口。

javax.swing.plaf.metal 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Insets
Insets 对象是容器边界的表示形式。
ItemSelectable
包含零个或多个可选则项的集合的对象接口。
LayoutManager
定义知道如何布置 Container 类的接口。
MenuContainer
所有菜单相关容器的超类。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

javax.swing.plaf.multi 使用的 java.awt 中的类
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

javax.swing.plaf.synth 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Insets
Insets 对象是容器边界的表示形式。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

javax.swing.table 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.AccessibleAWTComponent
用来为可访问性提供默认支持的 Component 的内部类。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。
Cursor
封装鼠标光标的位图表示形式的类。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
MenuContainer
所有菜单相关容器的超类。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

javax.swing.text 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Component.AccessibleAWTComponent
用来为可访问性提供默认支持的 Component 的内部类。
ComponentOrientation
ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Insets
Insets 对象是容器边界的表示形式。
MenuContainer
所有菜单相关容器的超类。
Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。

javax.swing.text.html 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Cursor
封装鼠标光标的位图表示形式的类。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
Image
抽象类 Image 是表示图形图像的所有类的超类。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
Shape
Shape 接口提供了表示一些几何形状的对象的定义。

javax.swing.tree 使用的 java.awt 中的类
Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
Font
Font 类表示字体，可以使用它以可见方式呈现文本。
Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。
MenuContainer
所有菜单相关容器的超类。
Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


CMMException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.color
类 CMMException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.awt.color.CMMException
所有已实现的接口：
Serializable
public class CMMException
extends RuntimeException

如果本机 CMM 返回一个错误，则抛出此异常。

另请参见：
序列化表格

构造方法摘要
CMMException(String s)
构造带指定详细消息的 CMMException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CMMException

public CMMException(String s)
构造带指定详细消息的 CMMException。

参数：
s - 指定的详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ColorSpace (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.color
类 ColorSpace

java.lang.Object
    继承者  java.awt.color.ColorSpace
所有已实现的接口：
Serializable
直接已知子类：
ICC_ColorSpace
public abstract class ColorSpace
extends Object
implements Serializable

此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。此类包含了可将指定颜色空间中的颜色与 sRGB 和定义良好的 CIEXYZ 颜色空间中的颜色进行相互转换的方法。

对于此类中的各个方法，颜色以颜色分量数组表示，颜色分量则是以每个 ColorSpace 定义的标准化范围中的 float 数表示。对于多数 ColorSpace（例如 sRGB）而言，此范围是 0.0 到 1.0。但是某些 ColorSpace 的颜色分量具有不同的范围值。此类提供了查询每个分量最小和最大标准化值的方法。

定义了多个变量，用来表示颜色空间类型（如 TYPE_RGB、TYPE_XYZ 等等）和特定颜色空间（如 CS_sRGB 和 CS_CIEXYZ）。sRGB 指的是标准的 RGB 颜色空间。有关更多信息，请参阅 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html。

提供对定义良好的 CIEXYZ 颜色空间相互转换的方法是为了支持在任意两个颜色空间之间进行高精确度的变换。用户期望 ColorSpace（如 ICC_ColorSpace）的特定子类实现能支持基于基础平台颜色管理系统的高性能变换。

toCIEXYZ/fromCIEXYZ 方法使用的 CS_CIEXYZ 空间可以描述如下：

      CIEXYZ
      观看照度：200 勒克斯
      观看白色点：CIE D50
      介质白色点：“完全反射漫射面”-- D50
      介质黑色点：0 勒克斯或 0 反射率
      流光：1％
      环绕：介质白色点的 20％
      介质说明：反射输出（例如，RLAB，Hunt 观看介质）
      注：对于要为此变换空间创建 ICC 配置文件的开发人员，可采用下列方法。使用简单的 Von Kries 适用模式将白色点放入 3X3 的矩阵参数中；将流光和环绕效果放入三个一维检索表中（假定每个表都使用了监视器最低限度的模型）。

另请参见：
ICC_ColorSpace, 序列化表格

字段摘要
static int | CS_CIEXYZ 上面定义的 CIEXYZ 变换颜色空间。
static int | CS_GRAY 内置的线性灰度颜色空间。
static int | CS_LINEAR_RGB 内置的线性 RGB 颜色空间。
static int | CS_PYCC Photo YCC 变换颜色空间。
static int | CS_sRGB sRGB 颜色空间的定义位于 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html。
static int | TYPE_2CLR Generic 2 分量颜色空间。
static int | TYPE_3CLR Generic 3 分量颜色空间。
static int | TYPE_4CLR Generic 4 分量颜色空间。
static int | TYPE_5CLR Generic 5 分量颜色空间。
static int | TYPE_6CLR Generic 6 分量颜色空间。
static int | TYPE_7CLR Generic 7 分量颜色空间。
static int | TYPE_8CLR Generic 8 分量颜色空间。
static int | TYPE_9CLR Generic 9 分量颜色空间。
static int | TYPE_ACLR Generic 10 分量颜色空间。
static int | TYPE_BCLR Generic 11 分量颜色空间。
static int | TYPE_CCLR Generic 12 分量颜色空间。
static int | TYPE_CMY CMY 颜色空间的任意颜色系列。
static int | TYPE_CMYK CMYK 颜色空间的任意颜色系列。
static int | TYPE_DCLR Generic 13 分量颜色空间。
static int | TYPE_ECLR Generic 14 分量颜色空间。
static int | TYPE_FCLR Generic 15 分量颜色空间。
static int | TYPE_GRAY GRAY 颜色空间的任意颜色系列。
static int | TYPE_HLS HLS 颜色空间的任意颜色系列。
static int | TYPE_HSV HSV 颜色空间的任意颜色系列。
static int | TYPE_Lab Lab 颜色空间的任意颜色系列。
static int | TYPE_Luv Luv 颜色空间的任意颜色系列。
static int | TYPE_RGB RGB 颜色空间的任意颜色系列。
static int | TYPE_XYZ XYZ 颜色空间的任意颜色系列。
static int | TYPE_YCbCr YCbCr 颜色空间的任意颜色系列。
static int | TYPE_Yxy Yxy 颜色空间的任意颜色系列。
构造方法摘要
protected ColorSpace(int type, int numcomponents)
构造一个给定颜色空间类型和分量数的 ColorSpace。
方法摘要
abstract float[] | fromCIEXYZ(float[] colorvalue) 将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换成此 ColorSpace 中的值。
abstract float[] | fromRGB(float[] rgbvalue) 将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。
static ColorSpace | getInstance(int colorspace) 返回表示特定于预定义颜色空间之一的 ColorSpace。
float | getMaxValue(int component) 返回指定分量的最大标准化颜色分量值。
float | getMinValue(int component) 返回指定分量的最小标准化颜色分量值。
String | getName(int idx) 返回给定分量索引处的分量名称。
int | getNumComponents() 返回此 ColorSpace 的分量数。
int | getType() 返回此 ColorSpace 的颜色空间类型（例如 TYPE_RGB、TYPE_XYZ……）。
boolean | isCS_sRGB() 如果 ColorSpace 是 CS_sRGB，则返回 true。
abstract float[] | toCIEXYZ(float[] colorvalue) 将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。
abstract float[] | toRGB(float[] colorvalue) 将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_XYZ

public static final int TYPE_XYZ
XYZ 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_Lab

public static final int TYPE_Lab
Lab 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_Luv

public static final int TYPE_Luv
Luv 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_YCbCr

public static final int TYPE_YCbCr
YCbCr 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_Yxy

public static final int TYPE_Yxy
Yxy 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_RGB

public static final int TYPE_RGB
RGB 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_GRAY

public static final int TYPE_GRAY
GRAY 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_HSV

public static final int TYPE_HSV
HSV 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_HLS

public static final int TYPE_HLS
HLS 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_CMYK

public static final int TYPE_CMYK
CMYK 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_CMY

public static final int TYPE_CMY
CMY 颜色空间的任意颜色系列。

另请参见：
常量字段值

TYPE_2CLR

public static final int TYPE_2CLR
Generic 2 分量颜色空间。

另请参见：
常量字段值

TYPE_3CLR

public static final int TYPE_3CLR
Generic 3 分量颜色空间。

另请参见：
常量字段值

TYPE_4CLR

public static final int TYPE_4CLR
Generic 4 分量颜色空间。

另请参见：
常量字段值

TYPE_5CLR

public static final int TYPE_5CLR
Generic 5 分量颜色空间。

另请参见：
常量字段值

TYPE_6CLR

public static final int TYPE_6CLR
Generic 6 分量颜色空间。

另请参见：
常量字段值

TYPE_7CLR

public static final int TYPE_7CLR
Generic 7 分量颜色空间。

另请参见：
常量字段值

TYPE_8CLR

public static final int TYPE_8CLR
Generic 8 分量颜色空间。

另请参见：
常量字段值

TYPE_9CLR

public static final int TYPE_9CLR
Generic 9 分量颜色空间。

另请参见：
常量字段值

TYPE_ACLR

public static final int TYPE_ACLR
Generic 10 分量颜色空间。

另请参见：
常量字段值

TYPE_BCLR

public static final int TYPE_BCLR
Generic 11 分量颜色空间。

另请参见：
常量字段值

TYPE_CCLR

public static final int TYPE_CCLR
Generic 12 分量颜色空间。

另请参见：
常量字段值

TYPE_DCLR

public static final int TYPE_DCLR
Generic 13 分量颜色空间。

另请参见：
常量字段值

TYPE_ECLR

public static final int TYPE_ECLR
Generic 14 分量颜色空间。

另请参见：
常量字段值

TYPE_FCLR

public static final int TYPE_FCLR
Generic 15 分量颜色空间。

另请参见：
常量字段值

CS_sRGB

public static final int CS_sRGB
sRGB 颜色空间的定义位于 http://www.w3.org/pub/WWW/Graphics/Color/sRGB.html。

另请参见：
常量字段值

CS_LINEAR_RGB

public static final int CS_LINEAR_RGB
内置的线性 RGB 颜色空间。此空间基于与 CS_sRGB 相同的 RGB 原色，但是有一个线性色调再现曲线。

另请参见：
常量字段值

CS_CIEXYZ

public static final int CS_CIEXYZ
上面定义的 CIEXYZ 变换颜色空间。

另请参见：
常量字段值

CS_PYCC

public static final int CS_PYCC
Photo YCC 变换颜色空间。

另请参见：
常量字段值

CS_GRAY

public static final int CS_GRAY
内置的线性灰度颜色空间。

另请参见：
常量字段值
构造方法详细信息

ColorSpace

protected ColorSpace(int type,
                     int numcomponents)
构造一个给定颜色空间类型和分量数的 ColorSpace。

参数：
type - ColorSpace 类型常量之一
numcomponents - 颜色空间中的分量数
方法详细信息

getInstance

public static ColorSpace getInstance(int colorspace)
返回表示特定于预定义颜色空间之一的 ColorSpace。

参数：
colorspace - 由某个预定义的类常量标识的特定颜色空间（如 CS_sRGB、CS_LINEAR_RGB、CS_CIEXYZ、CS_GRAY 或 CS_PYCC）
返回：
请求的 ColorSpace 对象

isCS_sRGB

public boolean isCS_sRGB()
如果 ColorSpace 是 CS_sRGB，则返回 true。

返回：
如果这是一个 CS_sRGB 颜色空间，则返回 true；如果不是，则返回 false

toRGB

public abstract float[] toRGB(float[] colorvalue)
将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。

此方法使用可在输入和输出颜色之间生成最佳感知匹配的算法来转换颜色值。为了完成颜色值的色度变换，应该首先使用此颜色空间的 toCIEXYZ 方法将颜色值从输入颜色空间转换到 CS_CIEXYZ 颜色空间，然后使用 CS_sRGB 颜色空间的 fromCIEXYZ 方法将其从 CS_CIEXYZ 转换到输出颜色空间。有关更多信息，请参阅 toCIEXYZ 和 fromCIEXYZ。

参数：
colorvalue - 一个长度至少为此 ColorSpace 中分量数的 float 数组
返回：
一个长度为 3 的 float 数组
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于此 ColorSpace 中的分量数

fromRGB

public abstract float[] fromRGB(float[] rgbvalue)
将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。

此方法使用可在输入和输出颜色之间生成最佳感知匹配的算法来转换颜色值。为了完成颜色值的色度变换，应该首先使用 CS_sRGB 颜色空间的 toCIEXYZ 方法将颜色值从输入颜色空间变换到 CS_CIEXYZ 颜色空间，然后使用此颜色空间的 fromCIEXYZ 方法将其从 CS_CIEXYZ 变换到输出颜色空间。有关更多信息，请参阅 toCIEXYZ 和 fromCIEXYZ。

参数：
rgbvalue - 一个长度至少为 3 的 float 数组
返回：
一个长度等于 ColorSpace 中分量数的 float 数组
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于 3

toCIEXYZ

public abstract float[] toCIEXYZ(float[] colorvalue)
将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。

此方法使用相对色度来转换颜色值，由国际色彩联盟标准所定义。这意味着此方法所返回的 XYZ 值是用相对于 CS_CIEXYZ 颜色空间的 D50 白色点来表示的。这种表示方法在两步骤的颜色变换过程中是很有用的，即将输入颜色空间中的颜色转换为 CS_CIEXYZ，然后再转换为输出颜色空间中的颜色。此表示形式与使用色度计由给定颜色值所测量的 XYZ 值不同。计算使用当前 CIE 推荐的做法所测量的 XYZ 值还需要进一步的转换。有关更多信息，请参阅 ICC_ColorSpace 的 toCIEXYZ 方法。

参数：
colorvalue - 一个长度至少为此 ColorSpace 中分量数的 float 数组
返回：
一个长度为 3 的 float 数组
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于此 ColorSpace 中的分量数。

fromCIEXYZ

public abstract float[] fromCIEXYZ(float[] colorvalue)
将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换成此 ColorSpace 中的值。

此方法使用相对色度来转换颜色值，由国际色彩联盟标准所定义。这意味着此方法所返回的 XYZ 参数值是用相对于 CS_CIEXYZ 颜色空间的 D50 白色点来表示的。这种表示方法在两步骤的颜色变换过程中是很有用的，即将输入颜色空间中的颜色转换为 CS_CIEXYZ，然后再转换为输出颜色空间中的颜色。此方法返回的颜色值与色度计测量时生成并传递给方法的 XYZ 值不同。如果 XYZ 值对应于使用当前 CIE 推荐的做法所测量的值，则在将其传递给此方法前必须将其转换成 D50 的相对值。有关更多信息，请参阅 ICC_ColorSpace 的 fromCIEXYZ 方法。

参数：
colorvalue - 一个长度至少为 3 的 float 数组
返回：
一个长度等于 ColorSpace 中分量数的 float 数组
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于 3

getType

public int getType()
返回此 ColorSpace 的颜色空间类型（例如 TYPE_RGB、TYPE_XYZ……）。类型定义了颜色空间的分量数和对它的解释，例如，TYPE_RGB 表示具有三个分量的颜色空间：红色、绿色和蓝色。它并不定义空间的特定颜色特征（如，原色的色度）。

返回：
表示此 ColorSpace 类型的类型常量

getNumComponents

public int getNumComponents()
返回此 ColorSpace 的分量数。

返回：
此 ColorSpace 中的分量数。

getName

public String getName(int idx)
返回给定分量索引处的分量名称。

参数：
idx - 分量索引
返回：
指定索引处的分量名称
抛出：
IllegalArgumentException - 如果 idx 小于 0 或者大于 (numComponents) - 1

getMinValue

public float getMinValue(int component)
返回指定分量的最小标准化颜色分量值。此抽象类的默认实现为所有分量返回 0.0。如有必要，子类应该重写此方法。

参数：
component - 分量索引
返回：
最小标准化分量值
抛出：
IllegalArgumentException - 如果 component 小于 0 或者大于 (numComponents) - 1
从以下版本开始：
1.4

getMaxValue

public float getMaxValue(int component)
返回指定分量的最大标准化颜色分量值。此抽象类的默认实现为所有分量返回 1.0。如有必要，子类应该重写此方法。

参数：
component - 分量索引
返回：
最大标准化分量值
抛出：
IllegalArgumentException - 如果 component 小于 0 或者大于 numComponents - 1
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICC_ColorSpace (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.color
类 ICC_ColorSpace

java.lang.Object
    继承者  java.awt.color.ColorSpace
        继承者  java.awt.color.ICC_ColorSpace
所有已实现的接口：
Serializable
public class ICC_ColorSpace
extends ColorSpace

ICC_ColorSpace 类是抽象 ColorSpace 类的实现。这种与设备无关和设备相关的颜色空间表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。

通常，Color 或 ColorModel 与 ICC 配置文件相关联，该配置文件可以是输入、显示或输出配置文件（请参阅 ICC 规范）。还有其他类型的 ICC 配置文件，如抽象配置文件、设备链接配置文件和指定颜色配置文件，这些配置文件不包含适合表示颜色、图像或设备颜色空间的信息（请参阅 ICC_Profile）。试图从不适合的 ICC 配置文件创建 ICC_ColorSpace 对象会产生错误。

ICC 配置文件表示从配置文件（如监视器）的颜色空间到配置文件连接空间 (PCS) 的转换。用于标记图像或颜色的感兴趣配置文件有一个 PCS，它是 ICC 配置文件格式规范中定义的设备无关空间（一个 CIEXYZ 空间和两个 CIELab 空间）之一。大多数感兴趣的配置文件都具有可逆的转换或显式指定的双向转换。如果使用 ICC_ColorSpace 对象的方式需要从 PCS 到配置文件本机空间的变换，并且没有足够的数据来正确执行转换，则 ICC_ColorSpace 对象将在指定类型的颜色空间（如 TYPE_RGB、TYPE_CMYK 等等）中生成输出，但是输出数据的具体颜色值是不明确的。

此类的细节对于这样的简单 applet 是不重要的：在默认颜色空间中进行绘图，或者处理和显示具有已知颜色空间的导入图像。这种 applet 至多需要通过 ColorSpace.getInstance() 获取默认的颜色空间之一。

另请参见：
ColorSpace, ICC_Profile, 序列化表格

字段摘要
从类 java.awt.color.ColorSpace 继承的字段
CS_CIEXYZ, CS_GRAY, CS_LINEAR_RGB, CS_PYCC, CS_sRGB, TYPE_2CLR, TYPE_3CLR, TYPE_4CLR, TYPE_5CLR, TYPE_6CLR, TYPE_7CLR, TYPE_8CLR, TYPE_9CLR, TYPE_ACLR, TYPE_BCLR, TYPE_CCLR, TYPE_CMY, TYPE_CMYK, TYPE_DCLR, TYPE_ECLR, TYPE_FCLR, TYPE_GRAY, TYPE_HLS, TYPE_HSV, TYPE_Lab, TYPE_Luv, TYPE_RGB, TYPE_XYZ, TYPE_YCbCr, TYPE_Yxy
构造方法摘要
ICC_ColorSpace(ICC_Profile profile)
由 ICC_Profile 对象构造一个新的 ICC_ColorSpace。
方法摘要
float[] | fromCIEXYZ(float[] colorvalue) 将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换为此 ColorSpace 中的值。
float[] | fromRGB(float[] rgbvalue) 将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。
float | getMaxValue(int component) 返回指定分量的最大标准化颜色分量值。
float | getMinValue(int component) 返回指定分量的最小标准化颜色分量值。
ICC_Profile | getProfile() 返回此 ICC_ColorSpace 的 ICC_Profile。
float[] | toCIEXYZ(float[] colorvalue) 将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。
float[] | toRGB(float[] colorvalue) 将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。
从类 java.awt.color.ColorSpace 继承的方法
getInstance, getName, getNumComponents, getType, isCS_sRGB
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ICC_ColorSpace

public ICC_ColorSpace(ICC_Profile profile)
由 ICC_Profile 对象构造一个新的 ICC_ColorSpace。

参数：
profile - 指定的 ICC_Profile 对象
抛出：
IllegalArgumentException - 如果 profile 不适合表示 ColorSpace。
方法详细信息

getProfile

public ICC_Profile getProfile()
返回此 ICC_ColorSpace 的 ICC_Profile。

返回：
此 ICC_ColorSpace 的 ICC_Profile。

toRGB

public float[] toRGB(float[] colorvalue)
将假定为此 ColorSpace 中的颜色值转换成默认 CS_sRGB 颜色空间中的值。

此方法使用可在输入和输出颜色之间生成最佳感知匹配的算法来转换颜色值。为了完成颜色值的色度变换，应该首先使用此颜色空间的 toCIEXYZ 方法将颜色值从输入颜色空间变换到 CS_CIEXYZ 颜色空间，然后使用 CS_sRGB 颜色空间的 fromCIEXYZ 方法将其从 CS_CIEXYZ 变换到输出颜色空间。有关此内容的更多信息，请参阅 toCIEXYZ 和 fromCIEXYZ。

指定者：
类 ColorSpace 中的 toRGB
参数：
colorvalue - 一个长度至少等于此 ColorSpace 中的分量数的 float 数组。
返回：
一个长度为 3 的 float 数组。
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于此 ColorSpace 中的分量数。

fromRGB

public float[] fromRGB(float[] rgbvalue)
将假定为默认 CS_sRGB 颜色空间中的颜色值转换成此 ColorSpace 中的值。

此方法使用可在输入和输出颜色之间生成最佳感知匹配的算法来变换颜色值。为了完成颜色值的色度变换，应该首先使用 CS_sRGB 颜色空间的 toCIEXYZ 方法将颜色值从输入颜色空间变换到 CS_CIEXYZ 颜色空间，然后使用此颜色空间的 fromCIEXYZ 方法将其从 CS_CIEXYZ 变换到输出颜色空间。有关此内容的更多信息，请参阅 toCIEXYZ 和 fromCIEXYZ。

指定者：
类 ColorSpace 中的 fromRGB
参数：
rgbvalue - 长度至少为 3 的 float 数组。
返回：
一个长度等于 ColorSpace 中分量数的 float 数组。
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于 3。

toCIEXYZ

public float[] toCIEXYZ(float[] colorvalue)
将假定为此 ColorSpace 中的颜色值转换成 CS_CIEXYZ 变换颜色空间中的值。

此方法使用相对色度来转换颜色值，由 ICC 规范所定义。这意味着此方法所返回的 XYZ 值是相对于 CS_CIEXYZ 颜色空间的 D50 白色点来表示的。这种表示方法在两步骤的颜色变换过程中是很有用的，即将输入颜色空间中的颜色转换为 CS_CIEXYZ，然后再转换为输出颜色空间中的颜色。该表示形式和通过色度计提供的颜色值所测量的 XYZ 值不同。计算使用当前 CIE 推荐的做法所测量的 XYZ 值还需要进一步的转换。下面各段对此进行了详细解释。

ICC 标准使用设备无关的颜色空间 (DICS) 作为将颜色从一台设备变换到另一台设备的机制。在此架构中，将颜色从源设备的颜色空间变换到 ICC DICS，然后从 ICC DICS 变换到目标设备的颜色空间。ICC 标准定义了在设备的颜色空间和 ICC DICS 之间进行转换的设备配置文件。从源设备的颜色到目标设备的颜色的总体转换是通过这种方式完成的：把源设备的设备到 DICS 的配置文件转换连接到目标设备的 DICS 到设备的配置文件转换。因此，ICC DICS 通常也称为配置文件连接空间 (PCS)。在 toCIEXYZ 和 fromCIEXYZ 方法中使用的颜色空间是由 ICC 规范所定义的 CIEXYZ PCS。这也是 ColorSpace.CS_CIEXYZ 所表示的颜色空间。

颜色的 XYZ 值通常相对于某些白色点来表示，所以在 XYZ 值白色点未知的情况下，是无法知道这些值的实际含义的。这称为相对色度。PCS 使用 D50 的白色点，所以 PCS 的 XYZ 值是相对于 D50 的。例如，PCS 中白色具有 D50 的 XYZ 值，定义为 X=.9642、Y=1.000 和 Z=0.8249。此白色点通常用于制版印刷应用中，但其他应用中也经常使用其他白色点。

要量化打印机或监视器等设备的颜色特征，通常是测量特定设备的颜色 XYZ 值。为便于论述，设备 XYZ 值这一术语用来表示使用当前的 CIE 推荐做法测量设备颜色所得的 XYZ 值。

在设备 XYZ 值和此方法返回的 PCS XYZ 值之间的转换对应于设备颜色空间（由 CIE 色度值表示）和 PCS 之间的转换。此过程涉及了很多因素，其中有些因素相当微妙。但最重要的要算为解决设备白色点和 PCS 白色点之间的不同而进行的调整。有许多针对这种调整的技术，它是当前许多研究和争论的主题。一些常用的方法是 XYZ 缩放、von Kries 转换和 Bradford 转换。应根据每个特定的应用来使用正确的方法。

最简单的方法是 XYZ 缩放。在此方法中，可将每台设备的 XYZ 值变换成 PCS XYZ 值，方法是将每台设备的 XYZ 值乘以 PCS 白色点 (D50) 和设备白色点的比值。

Xd、Yd、Zd 是设备的 XYZ 值
Xdw、Ydw、Zdw 是设备的 XYZ 白色点值
Xp、Yp、Zp 是 PCS XYZ 值
Xd50、Yd50、Zd50 是 PCS XYZ 白色点值

 Xp = Xd * (Xd50 / Xdw)
 Yp = Yd * (Yd50 / Ydw)
 Zp = Zd * (Zd50 / Zdw)

对这些等式取倒数可得到 PCS 到设备的变换：

 Xd = Xp * (Xdw / Xd50)
 Yd = Yp * (Ydw / Yd50)
 Zd = Zp * (Zdw / Zd50)

注意，ICC 配置文件中的介质白色点标记与设备的白色点标记不同。介质白色点标记以 PCS 值的形式表示，并且用于表示设备光源的 XYZ 和在该光源下所测量的设备介质 XYZ 之间的差异。设备白色点以对应于设备上所显示的白色的设备 XYZ 值来表示。例如，在 sRGB 设备上显示 RGB 颜色（1.0、1.0、1.0）将得到被测设备的 D65 XYZ 值。这与 sRGB 设备的 ICC 配置文件中的介质白色点标记 XYZ 值不同。

指定者：
类 ColorSpace 中的 toCIEXYZ
参数：
colorvalue - 一个长度至少等于此 ColorSpace 中的分量数的 float 数组。
返回：
一个长度为 3 的 float 数组。
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于此 ColorSpace 中的分量数。

fromCIEXYZ

public float[] fromCIEXYZ(float[] colorvalue)
将假定为 CS_CIEXYZ 变换颜色空间中的颜色值转换为此 ColorSpace 中的值。

此方法使用相对色度来转换颜色值，由 ICC 规范所定义。这意味着此方法所返回的 XYZ 参数值是相对于 CS_CIEXYZ 颜色空间的 D50 白色点来表示的。这种表示方法在两步骤的颜色变换过程中是很有用的，即将输入颜色空间中的颜色转换为 CS_CIEXYZ，然后再转换为输出颜色空间中的颜色。此方法返回的颜色值与色度计测量时生成并传递给方法的 XYZ 值不同。如果 XYZ 值对应于使用当前 CIE 推荐的做法所测量的值，则在将其传递给此方法前必须转换成 D50 相对值。下面各段对此进行了详细解释。

ICC 标准使用设备无关的颜色空间 (DICS) 作为将颜色从一台设备变换到另一台设备的机制。在此架构中，将颜色从源设备的颜色空间变换到 ICC DICS，然后从 ICC DICS 变换到目标设备的颜色空间。ICC 标准定义了在设备的颜色空间和 ICC DICS 之间进行转换的设备配置文件。从源设备的颜色到目标设备的颜色的总体转换是通过这种方式完成的：把源设备的设备到 DICS 的配置文件转换连接到目标设备的 DICS 到设备的配置文件转换。因此，ICC DICS 通常也称为配置文件连接空间 (PCS)。在 toCIEXYZ 和 fromCIEXYZ 方法中使用的颜色空间是由 ICC 规范所定义的 CIEXYZ PCS。这也是 ColorSpace.CS_CIEXYZ 所表示的颜色空间。

颜色的 XYZ 值通常相对于某些白色点来表示，所以在 XYZ 值白色点未知的情况下，是无法知道这些值的实际含义的。这称为相对色度。PCS 使用 D50 的白色点，所以 PCS 的 XYZ 值是相对于 D50 的。例如，PCS 中白色具有 D50 的 XYZ 值，定义为 X=.9642、Y=1.000 和 Z=0.8249。此白色点通常用于制版印刷应用中，但其他应用中也经常使用其他白色点。

要量化打印机或监视器等设备的颜色特征，通常是测量特定设备颜色的 XYZ 值。为便于论述，设备 XYZ 值这一术语用来表示使用当前的 CIE 推荐做法测量设备颜色所得的 XYZ 值。

在设备 XYZ 值和此方法作为参数采用的 PCS XYZ 值之间的变换对应于设备颜色空间（由 CIE 色度值表示）和 PCS 之间的变换。此过程涉及了很多因素，其中有些因素相当微妙。但最重要的要算为解决设备白色点和 PCS 白色点之间的不同而进行的调整。有许多针对这种调整的技术，它是当前许多研究和争论的主题。一些常用的方法是 XYZ 缩放、von Kries 转换和 Bradford 转换。应根据每个特定的应用来使用正确的方法。

最简单的方法是 XYZ 缩放。在此方法中，可将每台设备的 XYZ 值变换成 PCS XYZ 值，方法是将每台设备的 XYZ 值乘以 PCS 白色点 (D50) 和设备白色点的比值。

Xd、Yd、Zd 是设备的 XYZ 值
Xdw、Ydw、Zdw 是设备的 XYZ 白色点值
Xp、Yp、Zp 是 PCS XYZ 值
Xd50、Yd50、Zd50 是 PCS XYZ 白色点值

 Xp = Xd * (Xd50 / Xdw)
 Yp = Yd * (Yd50 / Ydw)
 Zp = Zd * (Zd50 / Zdw)

对这些等式取倒数可得到 PCS 到设备的变换：

 Xd = Xp * (Xdw / Xd50)
 Yd = Yp * (Ydw / Yd50)
 Zd = Zp * (Zdw / Zd50)

注意，ICC 配置文件中的介质白色点标记与设备的白色点标记不同。介质白色点标记以 PCS 值的形式表示，并且用于表示设备光源的 XYZ 和在该光源下所测量的设备介质 XYZ 之间的差异。设备白色点以对应于设备上所显示的白色的设备 XYZ 值来表示。例如，在 sRGB 设备上显示 RGB 颜色（1.0、1.0、1.0）将得到被测设备的 D65 XYZ 值。这与 sRGB 设备的 ICC 配置文件中的介质白色点标记 XYZ 值不同。

指定者：
类 ColorSpace 中的 fromCIEXYZ
参数：
colorvalue - 长度至少为 3 的 float 数组。
返回：
一个长度等于 ColorSpace 中分量数的 float 数组。
抛出：
ArrayIndexOutOfBoundsException - 如果数组长度小于 3。

getMinValue

public float getMinValue(int component)
返回指定分量的最小标准化颜色分量值。对于 TYPE_XYZ 空间，此方法为所有分量返回最小值 0.0。对于 TYPE_Lab 空间，此方法为 L 分量返回 0.0，为 a 和 b 分量返回 -128.0。这与 ICC 规范中的 XYZ 和 Lab 配置文件连接空间的编码一致。对于所有其他类型，此方法为所有分量返回 0.0。使用具有要求不同最小分量值配置文件的 ICC_ColorSpace 时，需要为此类创建子类并重写此方法。

覆盖：
类 ColorSpace 中的 getMinValue
参数：
component - 分量索引。
返回：
最小标准化分量值。
抛出：
IllegalArgumentException - 如果 component 小于 0 或大于 numComponents - 1。
从以下版本开始：
1.4

getMaxValue

public float getMaxValue(int component)
返回指定分量的最大标准化颜色分量值。对于 TYPE_XYZ 空间，此方法为所有分量返回最大值 1.0 + (32767.0 / 32768.0)。对于 TYPE_Lab 空间，此方法为 L 分量返回 100.0，为 a 和 b 分量返回 127.0。这与 ICC 规范中的 XYZ 和 Lab 配置文件连接空间的编码一致。对于所有其他类型，此方法为所有分量返回 1.0。使用具有要求不同最大分量值的配置文件的 ICC_ColorSpace 时，需要为此类创建子类并重写此方法。

覆盖：
类 ColorSpace 中的 getMaxValue
参数：
component - 分量索引。
返回：
最大标准化分量值。
抛出：
IllegalArgumentException - 如果 component 小于 0 或大于 numComponents - 1。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICC_Profile (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.color
类 ICC_Profile

java.lang.Object
    继承者  java.awt.color.ICC_Profile
所有已实现的接口：
Serializable
直接已知子类：
ICC_ProfileGray, ICC_ProfileRGB
public class ICC_Profile
extends Object
implements Serializable

与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。

可从适当的 ICC_Profile 构造 ICC_ColorSpace 对象。通常，一个 ICC_ColorSpace 与一个 ICC 配置文件相关联，该配置文件可以是输入、显示或输出配置文件（请参阅 ICC 规范）。还有设备链接、抽象、颜色空间转换和指定的颜色配置文件。这些配置文件在标记颜色和图像方面用处不大，但在其他方面很有用（特别是设备链接配置文件能够提高从一台设备的颜色空间向另一台设备颜色空间进行转换的性能）。

ICC 配置文件表示从配置文件（如监视器）的颜色空间到配置文件连接空间 (PCS) 的转换。用于标记图像或颜色的相关配置文件有一个 PCS，该 PCS 是在 ICC 配置文件格式规范中定义的设备无关空间（一个 CIEXYZ 空间和一个 CIELab 空间）之一。大多数相关的配置文件都具有可逆的转换或显式指定的双向转换。

另请参见：
ICC_ColorSpace, 序列化表格

字段摘要
static int | CLASS_ABSTRACT Profile 类是抽象。
static int | CLASS_COLORSPACECONVERSION Profile 类是颜色空间变换。
static int | CLASS_DEVICELINK Profile 类是设备链接。
static int | CLASS_DISPLAY Profile 类是显示。
static int | CLASS_INPUT Profile 类是输入。
static int | CLASS_NAMEDCOLOR Profile 类是指定的颜色。
static int | CLASS_OUTPUT Profile 类是输出。
static int | icAbsoluteColorimetric ICC 配置文件呈现目的：AbsoluteColorimetric。
static int | icCurveCount ICC 配置文件常量：curveType 计数。
static int | icCurveData ICC 配置文件常量：curveType 数据。
static int | icHdrAttributes ICC 配置文件头位置：设备属性。
static int | icHdrCmmId ICC 配置文件头位置：此配置文件的 CMM。
static int | icHdrColorSpace ICC 配置文件头位置：数据的颜色空间。
static int | icHdrCreator ICC 配置文件头位置：配置文件创建者。
static int | icHdrDate ICC 配置文件头位置：创建的日期配置文件。
static int | icHdrDeviceClass ICC 配置文件头位置：配置文件类型。
static int | icHdrFlags ICC 配置文件头位置：各种位设置。
static int | icHdrIlluminant ICC 配置文件头位置：配置文件光源。
static int | icHdrMagic ICC 配置文件头位置：icMagicNumber。
static int | icHdrManufacturer ICC 配置文件头位置：设备制造商。
static int | icHdrModel ICC 配置文件头位置：设备型号。
static int | icHdrPcs ICC 配置文件头位置：PCS - XYZ 或 Lab。
static int | icHdrPlatform ICC 配置文件头位置：原始平台。
static int | icHdrProfileID ICC 配置文件头位置：配置文件的 ID。
static int | icHdrRenderingIntent ICC 配置文件头位置：呈现目的。
static int | icHdrSize ICC 配置文件头位置：以字节为单位的配置文件的大小。
static int | icHdrVersion ICC 配置文件头位置：格式版本号。
static int | icICCAbsoluteColorimetric ICC 配置文件呈现目的：ICC-AbsoluteColorimetric。
static int | icMediaRelativeColorimetric ICC 配置文件呈现目的：Media-RelativeColorimetric。
static int | icPerceptual ICC 配置文件呈现目的：Perceptual。
static int | icRelativeColorimetric ICC 配置文件呈现目的：RelativeColorimetric。
static int | icSaturation ICC 配置文件呈现目的：Saturation。
static int | icSigAbstractClass ICC Profile 类签名：'abst'。
static int | icSigAToB0Tag ICC 配置文件标记签名：'A2B0'。
static int | icSigAToB1Tag ICC 配置文件标记签名：'A2B1'。
static int | icSigAToB2Tag ICC 配置文件标记签名：'A2B2'。
static int | icSigBlueColorantTag ICC 配置文件标记签名：'bXYZ'。
static int | icSigBlueMatrixColumnTag ICC 配置文件标记签名：'bXYZ'。
static int | icSigBlueTRCTag ICC 配置文件标记签名：'bTRC'。
static int | icSigBToA0Tag ICC 配置文件标记签名：'B2A0'。
static int | icSigBToA1Tag ICC 配置文件标记签名：'B2A1'。
static int | icSigBToA2Tag ICC 配置文件标记签名：'B2A2'。
static int | icSigCalibrationDateTimeTag ICC 配置文件标记签名：'calt'。
static int | icSigCharTargetTag ICC 配置文件标记签名：'targ'。
static int | icSigChromaticAdaptationTag ICC 配置文件标记签名：'chad'。
static int | icSigChromaticityTag ICC 配置文件标记签名：'chrm'。
static int | icSigCmyData ICC 配置文件颜色空间类型签名：'CMY '。
static int | icSigCmykData ICC 配置文件颜色空间类型签名：'CMYK'。
static int | icSigColorantOrderTag ICC 配置文件标记签名：'clro'。
static int | icSigColorantTableTag ICC 配置文件标记签名：'clrt'。
static int | icSigColorSpaceClass ICC Profile 类签名：'spac'。
static int | icSigCopyrightTag ICC 配置文件标记签名：'cprt'。
static int | icSigCrdInfoTag ICC 配置文件标记签名：'crdi'。
static int | icSigDeviceMfgDescTag ICC 配置文件标记签名：'dmnd'。
static int | icSigDeviceModelDescTag ICC 配置文件标记签名：'dmdd'。
static int | icSigDeviceSettingsTag ICC 配置文件标记签名：'devs'。
static int | icSigDisplayClass ICC Profile 类签名：'mntr'。
static int | icSigGamutTag ICC 配置文件标记签名：'gamt'。
static int | icSigGrayData ICC 配置文件颜色空间类型签名：'GRAY'。
static int | icSigGrayTRCTag ICC 配置文件标记签名：'kTRC'。
static int | icSigGreenColorantTag ICC 配置文件标记签名：'gXYZ'。
static int | icSigGreenMatrixColumnTag ICC 配置文件标记签名：'gXYZ'。
static int | icSigGreenTRCTag ICC 配置文件标记签名：'gTRC'。
static int | icSigHead ICC 配置文件标记签名：'head' - 专用。
static int | icSigHlsData ICC 配置文件颜色空间类型签名：'HLS'。
static int | icSigHsvData ICC 配置文件颜色空间类型签名：'HSV'。
static int | icSigInputClass ICC Profile 类签名：'scnr'。
static int | icSigLabData ICC 配置文件颜色空间类型签名：'Lab '。
static int | icSigLinkClass ICC Profile 类签名：'link'。
static int | icSigLuminanceTag ICC 配置文件标记签名：'lumi'。
static int | icSigLuvData ICC 配置文件颜色空间类型签名：'Luv '。
static int | icSigMeasurementTag ICC 配置文件标记签名：'meas'。
static int | icSigMediaBlackPointTag ICC 配置文件标记签名：'bkpt'。
static int | icSigMediaWhitePointTag ICC 配置文件标记签名：'wtpt'。
static int | icSigNamedColor2Tag ICC 配置文件标记签名：'ncl2'。
static int | icSigNamedColorClass ICC Profile 类签名：'nmcl'。
static int | icSigOutputClass ICC Profile 类签名：'prtr'。
static int | icSigOutputResponseTag ICC 配置文件标记签名：'resp'。
static int | icSigPreview0Tag ICC 配置文件标记签名：'pre0'。
static int | icSigPreview1Tag ICC 配置文件标记签名：'pre1'。
static int | icSigPreview2Tag ICC 配置文件标记签名：'pre2'。
static int | icSigProfileDescriptionTag ICC 配置文件标记签名：'desc'。
static int | icSigProfileSequenceDescTag ICC 配置文件标记签名：'pseq'。
static int | icSigPs2CRD0Tag ICC 配置文件标记签名：'psd0'。
static int | icSigPs2CRD1Tag ICC 配置文件标记签名：'psd1'。
static int | icSigPs2CRD2Tag ICC 配置文件标记签名：'psd2'。
static int | icSigPs2CRD3Tag ICC 配置文件标记签名：'psd3'。
static int | icSigPs2CSATag ICC 配置文件标记签名：'ps2s'。
static int | icSigPs2RenderingIntentTag ICC 配置文件标记签名：'ps2i'。
static int | icSigRedColorantTag ICC 配置文件标记签名：'rXYZ'。
static int | icSigRedMatrixColumnTag ICC 配置文件标记签名：'rXYZ'。
static int | icSigRedTRCTag ICC 配置文件标记签名：'rTRC'。
static int | icSigRgbData ICC 配置文件颜色空间类型签名：'RGB '。
static int | icSigScreeningDescTag ICC 配置文件标记签名：'scrd'。
static int | icSigScreeningTag ICC 配置文件标记签名：'scrn'。
static int | icSigSpace2CLR ICC 配置文件颜色空间类型签名：'2CLR'。
static int | icSigSpace3CLR ICC 配置文件颜色空间类型签名：'3CLR'。
static int | icSigSpace4CLR ICC 配置文件颜色空间类型签名：'4CLR'。
static int | icSigSpace5CLR ICC 配置文件颜色空间类型签名：'5CLR'。
static int | icSigSpace6CLR ICC 配置文件颜色空间类型签名：'6CLR'。
static int | icSigSpace7CLR ICC 配置文件颜色空间类型签名：'7CLR'。
static int | icSigSpace8CLR ICC 配置文件颜色空间类型签名：'8CLR'。
static int | icSigSpace9CLR ICC 配置文件颜色空间类型签名：'9CLR'。
static int | icSigSpaceACLR ICC 配置文件颜色空间类型签名：'ACLR'。
static int | icSigSpaceBCLR ICC 配置文件颜色空间类型签名：'BCLR'。
static int | icSigSpaceCCLR ICC 配置文件颜色空间类型签名：'CCLR'。
static int | icSigSpaceDCLR ICC 配置文件颜色空间类型签名：'DCLR'。
static int | icSigSpaceECLR ICC 配置文件颜色空间类型签名：'ECLR'。
static int | icSigSpaceFCLR ICC 配置文件颜色空间类型签名：'FCLR'。
static int | icSigTechnologyTag ICC 配置文件标记签名：'tech'。
static int | icSigUcrBgTag ICC 配置文件标记签名：'bfd '。
static int | icSigViewingCondDescTag ICC 配置文件标记签名：'vued'。
static int | icSigViewingConditionsTag ICC 配置文件标记签名：'view'。
static int | icSigXYZData ICC 配置文件颜色空间类型签名：'XYZ '。
static int | icSigYCbCrData ICC 配置文件颜色空间类型签名：'YCbr'。
static int | icSigYxyData ICC 配置文件颜色空间类型签名：'Yxy '。
static int | icTagReserved ICC 配置文件常量：保留。
static int | icTagType ICC 配置文件常量：标记类型 signaturE。
static int | icXYZNumberX ICC 配置文件常量：XYZNumber X。
方法摘要
protected void | finalize() 释放与 ICC_Profile 对象关联的资源。
int | getColorSpaceType() 返回颜色空间类型。
byte[] | getData() 返回与 ICC_Profile 数据相对应的 byte 数组。
byte[] | getData(int tagSignature) 从配置文件中返回包含特定标记数据元素的 byte 数组。
static ICC_Profile | getInstance(byte[] data) 构造一个与 byte 数组中的数据相对应的 ICC_Profile 对象。
static ICC_Profile | getInstance(InputStream s) 构造一个与 InputStream 中的数据相对应的 ICC_Profile。
static ICC_Profile | getInstance(int cspace) 构造一个与 ColorSpace 类所定义的指定颜色空间之一（如 CS_sRGB）相对应的 ICC_Profile。
static ICC_Profile | getInstance(String fileName) 构造一个与文件中的数据相对应的 ICC_Profile。
int | getMajorVersion() 返回配置文件的主版本号。
int | getMinorVersion() 返回配置文件的次版本号。
int | getNumComponents() 返回配置文件的“输入”颜色空间中的颜色分量数。
int | getPCSType() 返回配置文件连接空间 (PCS) 的颜色空间类型。
int | getProfileClass() 返回配置文件类。
protected Object | readResolve() 解析将被反序列化为用 CMM 注册的实例的实例。
void | setData(int tagSignature, byte[] tagData) 从一个 byte 数组中设置配置文件中的特定标记数据元素。
void | write(OutputStream s) 将 ICC_Profile 写入一个 OutputStream。
void | write(String fileName) 将此 ICC_Profile 写入一个文件。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CLASS_INPUT

public static final int CLASS_INPUT
Profile 类是输入。

另请参见：
常量字段值

CLASS_DISPLAY

public static final int CLASS_DISPLAY
Profile 类是显示。

另请参见：
常量字段值

CLASS_OUTPUT

public static final int CLASS_OUTPUT
Profile 类是输出。

另请参见：
常量字段值

CLASS_DEVICELINK

public static final int CLASS_DEVICELINK
Profile 类是设备链接。

另请参见：
常量字段值

CLASS_COLORSPACECONVERSION

public static final int CLASS_COLORSPACECONVERSION
Profile 类是颜色空间变换。

另请参见：
常量字段值

CLASS_ABSTRACT

public static final int CLASS_ABSTRACT
Profile 类是抽象。

另请参见：
常量字段值

CLASS_NAMEDCOLOR

public static final int CLASS_NAMEDCOLOR
Profile 类是指定的颜色。

另请参见：
常量字段值

icSigXYZData

public static final int icSigXYZData
ICC 配置文件颜色空间类型签名：'XYZ '。

另请参见：
常量字段值

icSigLabData

public static final int icSigLabData
ICC 配置文件颜色空间类型签名：'Lab '。

另请参见：
常量字段值

icSigLuvData

public static final int icSigLuvData
ICC 配置文件颜色空间类型签名：'Luv '。

另请参见：
常量字段值

icSigYCbCrData

public static final int icSigYCbCrData
ICC 配置文件颜色空间类型签名：'YCbr'。

另请参见：
常量字段值

icSigYxyData

public static final int icSigYxyData
ICC 配置文件颜色空间类型签名：'Yxy '。

另请参见：
常量字段值

icSigRgbData

public static final int icSigRgbData
ICC 配置文件颜色空间类型签名：'RGB '。

另请参见：
常量字段值

icSigGrayData

public static final int icSigGrayData
ICC 配置文件颜色空间类型签名：'GRAY'。

另请参见：
常量字段值

icSigHsvData

public static final int icSigHsvData
ICC 配置文件颜色空间类型签名：'HSV'。

另请参见：
常量字段值

icSigHlsData

public static final int icSigHlsData
ICC 配置文件颜色空间类型签名：'HLS'。

另请参见：
常量字段值

icSigCmykData

public static final int icSigCmykData
ICC 配置文件颜色空间类型签名：'CMYK'。

另请参见：
常量字段值

icSigCmyData

public static final int icSigCmyData
ICC 配置文件颜色空间类型签名：'CMY '。

另请参见：
常量字段值

icSigSpace2CLR

public static final int icSigSpace2CLR
ICC 配置文件颜色空间类型签名：'2CLR'。

另请参见：
常量字段值

icSigSpace3CLR

public static final int icSigSpace3CLR
ICC 配置文件颜色空间类型签名：'3CLR'。

另请参见：
常量字段值

icSigSpace4CLR

public static final int icSigSpace4CLR
ICC 配置文件颜色空间类型签名：'4CLR'。

另请参见：
常量字段值

icSigSpace5CLR

public static final int icSigSpace5CLR
ICC 配置文件颜色空间类型签名：'5CLR'。

另请参见：
常量字段值

icSigSpace6CLR

public static final int icSigSpace6CLR
ICC 配置文件颜色空间类型签名：'6CLR'。

另请参见：
常量字段值

icSigSpace7CLR

public static final int icSigSpace7CLR
ICC 配置文件颜色空间类型签名：'7CLR'。

另请参见：
常量字段值

icSigSpace8CLR

public static final int icSigSpace8CLR
ICC 配置文件颜色空间类型签名：'8CLR'。

另请参见：
常量字段值

icSigSpace9CLR

public static final int icSigSpace9CLR
ICC 配置文件颜色空间类型签名：'9CLR'。

另请参见：
常量字段值

icSigSpaceACLR

public static final int icSigSpaceACLR
ICC 配置文件颜色空间类型签名：'ACLR'。

另请参见：
常量字段值

icSigSpaceBCLR

public static final int icSigSpaceBCLR
ICC 配置文件颜色空间类型签名：'BCLR'。

另请参见：
常量字段值

icSigSpaceCCLR

public static final int icSigSpaceCCLR
ICC 配置文件颜色空间类型签名：'CCLR'。

另请参见：
常量字段值

icSigSpaceDCLR

public static final int icSigSpaceDCLR
ICC 配置文件颜色空间类型签名：'DCLR'。

另请参见：
常量字段值

icSigSpaceECLR

public static final int icSigSpaceECLR
ICC 配置文件颜色空间类型签名：'ECLR'。

另请参见：
常量字段值

icSigSpaceFCLR

public static final int icSigSpaceFCLR
ICC 配置文件颜色空间类型签名：'FCLR'。

另请参见：
常量字段值

icSigInputClass

public static final int icSigInputClass
ICC Profile 类签名：'scnr'。

另请参见：
常量字段值

icSigDisplayClass

public static final int icSigDisplayClass
ICC Profile 类签名：'mntr'。

另请参见：
常量字段值

icSigOutputClass

public static final int icSigOutputClass
ICC Profile 类签名：'prtr'。

另请参见：
常量字段值

icSigLinkClass

public static final int icSigLinkClass
ICC Profile 类签名：'link'。

另请参见：
常量字段值

icSigAbstractClass

public static final int icSigAbstractClass
ICC Profile 类签名：'abst'。

另请参见：
常量字段值

icSigColorSpaceClass

public static final int icSigColorSpaceClass
ICC Profile 类签名：'spac'。

另请参见：
常量字段值

icSigNamedColorClass

public static final int icSigNamedColorClass
ICC Profile 类签名：'nmcl'。

另请参见：
常量字段值

icPerceptual

public static final int icPerceptual
ICC 配置文件呈现目的：Perceptual。

另请参见：
常量字段值

icRelativeColorimetric

public static final int icRelativeColorimetric
ICC 配置文件呈现目的：RelativeColorimetric。

另请参见：
常量字段值

icMediaRelativeColorimetric

public static final int icMediaRelativeColorimetric
ICC 配置文件呈现目的：Media-RelativeColorimetric。

从以下版本开始：
1.5
另请参见：
常量字段值

icSaturation

public static final int icSaturation
ICC 配置文件呈现目的：Saturation。

另请参见：
常量字段值

icAbsoluteColorimetric

public static final int icAbsoluteColorimetric
ICC 配置文件呈现目的：AbsoluteColorimetric。

另请参见：
常量字段值

icICCAbsoluteColorimetric

public static final int icICCAbsoluteColorimetric
ICC 配置文件呈现目的：ICC-AbsoluteColorimetric。

从以下版本开始：
1.5
另请参见：
常量字段值

icSigHead

public static final int icSigHead
ICC 配置文件标记签名：'head' - 专用。

另请参见：
常量字段值

icSigAToB0Tag

public static final int icSigAToB0Tag
ICC 配置文件标记签名：'A2B0'。

另请参见：
常量字段值

icSigAToB1Tag

public static final int icSigAToB1Tag
ICC 配置文件标记签名：'A2B1'。

另请参见：
常量字段值

icSigAToB2Tag

public static final int icSigAToB2Tag
ICC 配置文件标记签名：'A2B2'。

另请参见：
常量字段值

icSigBlueColorantTag

public static final int icSigBlueColorantTag
ICC 配置文件标记签名：'bXYZ'。

另请参见：
常量字段值

icSigBlueMatrixColumnTag

public static final int icSigBlueMatrixColumnTag
ICC 配置文件标记签名：'bXYZ'。

从以下版本开始：
1.5
另请参见：
常量字段值

icSigBlueTRCTag

public static final int icSigBlueTRCTag
ICC 配置文件标记签名：'bTRC'。

另请参见：
常量字段值

icSigBToA0Tag

public static final int icSigBToA0Tag
ICC 配置文件标记签名：'B2A0'。

另请参见：
常量字段值

icSigBToA1Tag

public static final int icSigBToA1Tag
ICC 配置文件标记签名：'B2A1'。

另请参见：
常量字段值

icSigBToA2Tag

public static final int icSigBToA2Tag
ICC 配置文件标记签名：'B2A2'。

另请参见：
常量字段值

icSigCalibrationDateTimeTag

public static final int icSigCalibrationDateTimeTag
ICC 配置文件标记签名：'calt'。

另请参见：
常量字段值

icSigCharTargetTag

public static final int icSigCharTargetTag
ICC 配置文件标记签名：'targ'。

另请参见：
常量字段值

icSigCopyrightTag

public static final int icSigCopyrightTag
ICC 配置文件标记签名：'cprt'。

另请参见：
常量字段值

icSigCrdInfoTag

public static final int icSigCrdInfoTag
ICC 配置文件标记签名：'crdi'。

另请参见：
常量字段值

icSigDeviceMfgDescTag

public static final int icSigDeviceMfgDescTag
ICC 配置文件标记签名：'dmnd'。

另请参见：
常量字段值

icSigDeviceModelDescTag

public static final int icSigDeviceModelDescTag
ICC 配置文件标记签名：'dmdd'。

另请参见：
常量字段值

icSigDeviceSettingsTag

public static final int icSigDeviceSettingsTag
ICC 配置文件标记签名：'devs'。

另请参见：
常量字段值

icSigGamutTag

public static final int icSigGamutTag
ICC 配置文件标记签名：'gamt'。

另请参见：
常量字段值

icSigGrayTRCTag

public static final int icSigGrayTRCTag
ICC 配置文件标记签名：'kTRC'。

另请参见：
常量字段值

icSigGreenColorantTag

public static final int icSigGreenColorantTag
ICC 配置文件标记签名：'gXYZ'。

另请参见：
常量字段值

icSigGreenMatrixColumnTag

public static final int icSigGreenMatrixColumnTag
ICC 配置文件标记签名：'gXYZ'。

从以下版本开始：
1.5
另请参见：
常量字段值

icSigGreenTRCTag

public static final int icSigGreenTRCTag
ICC 配置文件标记签名：'gTRC'。

另请参见：
常量字段值

icSigLuminanceTag

public static final int icSigLuminanceTag
ICC 配置文件标记签名：'lumi'。

另请参见：
常量字段值

icSigMeasurementTag

public static final int icSigMeasurementTag
ICC 配置文件标记签名：'meas'。

另请参见：
常量字段值

icSigMediaBlackPointTag

public static final int icSigMediaBlackPointTag
ICC 配置文件标记签名：'bkpt'。

另请参见：
常量字段值

icSigMediaWhitePointTag

public static final int icSigMediaWhitePointTag
ICC 配置文件标记签名：'wtpt'。

另请参见：
常量字段值

icSigNamedColor2Tag

public static final int icSigNamedColor2Tag
ICC 配置文件标记签名：'ncl2'。

另请参见：
常量字段值

icSigOutputResponseTag

public static final int icSigOutputResponseTag
ICC 配置文件标记签名：'resp'。

另请参见：
常量字段值

icSigPreview0Tag

public static final int icSigPreview0Tag
ICC 配置文件标记签名：'pre0'。

另请参见：
常量字段值

icSigPreview1Tag

public static final int icSigPreview1Tag
ICC 配置文件标记签名：'pre1'。

另请参见：
常量字段值

icSigPreview2Tag

public static final int icSigPreview2Tag
ICC 配置文件标记签名：'pre2'。

另请参见：
常量字段值

icSigProfileDescriptionTag

public static final int icSigProfileDescriptionTag
ICC 配置文件标记签名：'desc'。

另请参见：
常量字段值

icSigProfileSequenceDescTag

public static final int icSigProfileSequenceDescTag
ICC 配置文件标记签名：'pseq'。

另请参见：
常量字段值

icSigPs2CRD0Tag

public static final int icSigPs2CRD0Tag
ICC 配置文件标记签名：'psd0'。

另请参见：
常量字段值

icSigPs2CRD1Tag

public static final int icSigPs2CRD1Tag
ICC 配置文件标记签名：'psd1'。

另请参见：
常量字段值

icSigPs2CRD2Tag

public static final int icSigPs2CRD2Tag
ICC 配置文件标记签名：'psd2'。

另请参见：
常量字段值

icSigPs2CRD3Tag

public static final int icSigPs2CRD3Tag
ICC 配置文件标记签名：'psd3'。

另请参见：
常量字段值

icSigPs2CSATag

public static final int icSigPs2CSATag
ICC 配置文件标记签名：'ps2s'。

另请参见：
常量字段值

icSigPs2RenderingIntentTag

public static final int icSigPs2RenderingIntentTag
ICC 配置文件标记签名：'ps2i'。

另请参见：
常量字段值

icSigRedColorantTag

public static final int icSigRedColorantTag
ICC 配置文件标记签名：'rXYZ'。

另请参见：
常量字段值

icSigRedMatrixColumnTag

public static final int icSigRedMatrixColumnTag
ICC 配置文件标记签名：'rXYZ'。

从以下版本开始：
1.5
另请参见：
常量字段值

icSigRedTRCTag

public static final int icSigRedTRCTag
ICC 配置文件标记签名：'rTRC'。

另请参见：
常量字段值

icSigScreeningDescTag

public static final int icSigScreeningDescTag
ICC 配置文件标记签名：'scrd'。

另请参见：
常量字段值

icSigScreeningTag

public static final int icSigScreeningTag
ICC 配置文件标记签名：'scrn'。

另请参见：
常量字段值

icSigTechnologyTag

public static final int icSigTechnologyTag
ICC 配置文件标记签名：'tech'。

另请参见：
常量字段值

icSigUcrBgTag

public static final int icSigUcrBgTag
ICC 配置文件标记签名：'bfd '。

另请参见：
常量字段值

icSigViewingCondDescTag

public static final int icSigViewingCondDescTag
ICC 配置文件标记签名：'vued'。

另请参见：
常量字段值

icSigViewingConditionsTag

public static final int icSigViewingConditionsTag
ICC 配置文件标记签名：'view'。

另请参见：
常量字段值

icSigChromaticityTag

public static final int icSigChromaticityTag
ICC 配置文件标记签名：'chrm'。

另请参见：
常量字段值

icSigChromaticAdaptationTag

public static final int icSigChromaticAdaptationTag
ICC 配置文件标记签名：'chad'。

从以下版本开始：
1.5
另请参见：
常量字段值

icSigColorantOrderTag

public static final int icSigColorantOrderTag
ICC 配置文件标记签名：'clro'。

从以下版本开始：
1.5
另请参见：
常量字段值

icSigColorantTableTag

public static final int icSigColorantTableTag
ICC 配置文件标记签名：'clrt'。

从以下版本开始：
1.5
另请参见：
常量字段值

icHdrSize

public static final int icHdrSize
ICC 配置文件头位置：以字节为单位的配置文件的大小。

另请参见：
常量字段值

icHdrCmmId

public static final int icHdrCmmId
ICC 配置文件头位置：此配置文件的 CMM。

另请参见：
常量字段值

icHdrVersion

public static final int icHdrVersion
ICC 配置文件头位置：格式版本号。

另请参见：
常量字段值

icHdrDeviceClass

public static final int icHdrDeviceClass
ICC 配置文件头位置：配置文件类型。

另请参见：
常量字段值

icHdrColorSpace

public static final int icHdrColorSpace
ICC 配置文件头位置：数据的颜色空间。

另请参见：
常量字段值

icHdrPcs

public static final int icHdrPcs
ICC 配置文件头位置：PCS - XYZ 或 Lab。

另请参见：
常量字段值

icHdrDate

public static final int icHdrDate
ICC 配置文件头位置：创建的日期配置文件。

另请参见：
常量字段值

icHdrMagic

public static final int icHdrMagic
ICC 配置文件头位置：icMagicNumber。

另请参见：
常量字段值

icHdrPlatform

public static final int icHdrPlatform
ICC 配置文件头位置：原始平台。

另请参见：
常量字段值

icHdrFlags

public static final int icHdrFlags
ICC 配置文件头位置：各种位设置。

另请参见：
常量字段值

icHdrManufacturer

public static final int icHdrManufacturer
ICC 配置文件头位置：设备制造商。

另请参见：
常量字段值

icHdrModel

public static final int icHdrModel
ICC 配置文件头位置：设备型号。

另请参见：
常量字段值

icHdrAttributes

public static final int icHdrAttributes
ICC 配置文件头位置：设备属性。

另请参见：
常量字段值

icHdrRenderingIntent

public static final int icHdrRenderingIntent
ICC 配置文件头位置：呈现目的。

另请参见：
常量字段值

icHdrIlluminant

public static final int icHdrIlluminant
ICC 配置文件头位置：配置文件光源。

另请参见：
常量字段值

icHdrCreator

public static final int icHdrCreator
ICC 配置文件头位置：配置文件创建者。

另请参见：
常量字段值

icHdrProfileID

public static final int icHdrProfileID
ICC 配置文件头位置：配置文件的 ID。

从以下版本开始：
1.5
另请参见：
常量字段值

icTagType

public static final int icTagType
ICC 配置文件常量：标记类型 signaturE。

另请参见：
常量字段值

icTagReserved

public static final int icTagReserved
ICC 配置文件常量：保留。

另请参见：
常量字段值

icCurveCount

public static final int icCurveCount
ICC 配置文件常量：curveType 计数。

另请参见：
常量字段值

icCurveData

public static final int icCurveData
ICC 配置文件常量：curveType 数据。

另请参见：
常量字段值

icXYZNumberX

public static final int icXYZNumberX
ICC 配置文件常量：XYZNumber X。

另请参见：
常量字段值
方法详细信息

finalize

protected void finalize()
释放与 ICC_Profile 对象关联的资源。

覆盖：
类 Object 中的 finalize

getInstance

public static ICC_Profile getInstance(byte[] data)
构造一个与 byte 数组中的数据相对应的 ICC_Profile 对象。如果数据未对应一个有效的 ICC_Profile ，则抛出 IllegalArgumentException。

参数：
data - 指定的 ICC 配置文件数据
返回：
与指定 data 数组中的数据相对应的 ICC_Profile 对象。

getInstance

public static ICC_Profile getInstance(int cspace)
构造一个与 ColorSpace 类所定义的指定颜色空间之一（如 CS_sRGB）相对应的 ICC_Profile。如果 cspace 不是已定义的颜色空间之一，则抛出 IllegalArgumentException。

参数：
cspace - 为之创建配置文件的颜色空间类型。指定的类型是 ColorSpace 类中所定义的颜色空间常量之一。
返回：
与指定 ColorSpace 类型相对应的 ICC_Profile 对象。
抛出：
IllegalArgumentException - 如果 cspace 不是预定义的颜色空间类型之一。

getInstance

public static ICC_Profile getInstance(String fileName)
                               throws IOException
构造一个与文件中的数据相对应的 ICC_Profile。fileName 可能是绝对文件规范，也可能是相对文件规范。在多个位置中查找相对文件名：首先是 java.iccprofile.path 属性所指定的所有目录；其次是 java.class.path 属性指定的所有目录；最后是用来存储总是可用的配置文件（如 sRGB 的配置文件）的目录。内置的配置文件使用 .pf 作为配置文件的扩展名，如 sRGB.pf。如果无法打开指定的文件或者读取该文件时发生 I/O 错误，则此方法抛出 IOException。如果该文件不包含有效的 ICC 配置文件数据，则抛出 IllegalArgumentException。

参数：
fileName - 包含配置文件数据的文件。
返回：
与指定文件中的数据相对应的 ICC_Profile 对象。
抛出：
IOException - 如果无法打开指定的文件或者读取该文件时发生 I/O 错误。
IllegalArgumentException - 如果该文件不包含有效的 ICC 配置文件数据。
SecurityException - 如果已安装安全管理器并且它不允许对给定文件的读取访问。

getInstance

public static ICC_Profile getInstance(InputStream s)
                               throws IOException
构造一个与 InputStream 中的数据相对应的 ICC_Profile。如果该流不包含有效的 ICC 配置文件数据，则此方法抛出 IllegalArgumentException。如果读取该流时发生 I/O 错误，则抛出 IOException。

参数：
s - 从中读取配置文件数据的输入流。
返回：
与指定 InputStream 中的数据相对应的 ICC_Profile 对象。
抛出：
IOException - 如果读取该流时发生 I/O 错误。
IllegalArgumentException - 如果该文件不包含有效的 ICC 配置文件数据。

getMajorVersion

public int getMajorVersion()
返回配置文件的主版本号。

返回：
配置文件的主版本号。

getMinorVersion

public int getMinorVersion()
返回配置文件的次版本号。

返回：
配置文件的次版本号。

getProfileClass

public int getProfileClass()
返回配置文件类。

返回：
预定义的配置文件类常量之一。

getColorSpaceType

public int getColorSpaceType()
返回颜色空间类型。返回由 ColorSpace 类所定义的颜色空间类型常量之一。这是配置文件的“输入”颜色空间。类型定义了颜色空间的分量数，例如，TYPE_RGB 表示具有三个分量的颜色空间：红色、绿色和蓝色。它并不定义空间的特定颜色特征，例如原色的色度。

返回：
ColorSpace 类中所定义的颜色空间类型常量之一。

getPCSType

public int getPCSType()
返回配置文件连接空间 (PCS) 的颜色空间类型。返回由 ColorSpace 类所定义的颜色空间类型常量之一。这是配置文件的“输出”颜色空间。对于标记颜色或图像很有用的输入、显示或输出配置文件，这可以是 TYPE_XYZ 或 TYPE_Lab，并且应该解释为在 ICC 规范中定义的相应特定颜色空间。对于设备链接配置文件，则可以是任意颜色空间类型常量。

返回：
ColorSpace 类中所定义的颜色空间类型常量之一。

write

public void write(String fileName)
           throws IOException
将此 ICC_Profile 写入一个文件。

参数：
fileName - 配置文件数据所要写入的文件。
抛出：
IOException - 如果无法打开写入的文件或者写入该文件时发生了 I/O 错误。

write

public void write(OutputStream s)
           throws IOException
将 ICC_Profile 写入一个 OutputStream。

参数：
s - 配置文件数据所要写入的流。
抛出：
IOException - 如果写入该流时发生 I/O 错误。

getData

public byte[] getData()
返回与 ICC_Profile 数据相对应的 byte 数组。

返回：
包含配置文件数据的 byte 数组。
另请参见：
setData(int, byte[])

getData

public byte[] getData(int tagSignature)
从配置文件中返回包含特定标记数据元素的 byte 数组。依靠在 ICC 规范中所定义的签名来标识各个元素。可使用签名 icSigHead 获得头信息。此方法对于需要直接访问配置文件数据的高级 applet 或应用程序很有用。

参数：
tagSignature - 要获得的数据元素的 ICC 标记签名。
返回：
包含标记数据元素的 byte 数组。如果指定的标记不存在，则返回 null。
另请参见：
setData(int, byte[])

setData

public void setData(int tagSignature,
                    byte[] tagData)
从一个 byte 数组中设置配置文件中的特定标记数据元素。此方法对于需要直接访问配置文件数据的高级 applet 或应用程序很有用。

参数：
tagSignature - 要设置的数据元素的 ICC 标记签名。
tagData - 要为特定标记签名设置的数据
另请参见：
getData()

getNumComponents

public int getNumComponents()
返回配置文件的“输入”颜色空间中的颜色分量数。例如，如果此配置文件的颜色空间类型是 TYPE_RGB，则此方法将返回 3。

返回：
配置文件的输入颜色空间中的颜色分量数。
抛出：
ProfileDataException - 如果配置文件中的颜色空间无效

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析将被反序列化为用 CMM 注册的实例的实例。

返回：
用 CMM 注册的配置文件的 ICC_Profile 对象。
抛出：
ObjectStreamException - 不会抛出，但是要受序列化规范的限制。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICC_ProfileGray (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.color
类 ICC_ProfileGray

java.lang.Object
    继承者  java.awt.color.ICC_Profile
        继承者  java.awt.color.ICC_ProfileGray
所有已实现的接口：
Serializable
public class ICC_ProfileGray
extends ICC_Profile

ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。此类配置文件的示例有单色输入配置文件、单色显示配置文件和单色输出配置文件。满足上述条件时，ICC_Profile 类中的 getInstance 方法将返回一个 ICC_ProfileGray 对象。此类的优势在于它提供了一个查找表，Java 或本机方法在某些情况下可以直接使用这些表来优化颜色转换。

要从 GRAY 设备配置文件颜色空间转换成 CIEXYZ 配置文件连接空间，可使用查找表参考色调再现曲线 (TRC) 来变换设备的灰色分量。变换的结果作为 PCS 的非彩色分量。

                PCSY = grayTRC[deviceGray]
通过反向 grayTRC 将 PCS Y 分量变换为设备的 Gray 即可完成逆向转换。

另请参见：
序列化表格

字段摘要
从类 java.awt.color.ICC_Profile 继承的字段
CLASS_ABSTRACT, CLASS_COLORSPACECONVERSION, CLASS_DEVICELINK, CLASS_DISPLAY, CLASS_INPUT, CLASS_NAMEDCOLOR, CLASS_OUTPUT, icAbsoluteColorimetric, icCurveCount, icCurveData, icHdrAttributes, icHdrCmmId, icHdrColorSpace, icHdrCreator, icHdrDate, icHdrDeviceClass, icHdrFlags, icHdrIlluminant, icHdrMagic, icHdrManufacturer, icHdrModel, icHdrPcs, icHdrPlatform, icHdrProfileID, icHdrRenderingIntent, icHdrSize, icHdrVersion, icICCAbsoluteColorimetric, icMediaRelativeColorimetric, icPerceptual, icRelativeColorimetric, icSaturation, icSigAbstractClass, icSigAToB0Tag, icSigAToB1Tag, icSigAToB2Tag, icSigBlueColorantTag, icSigBlueMatrixColumnTag, icSigBlueTRCTag, icSigBToA0Tag, icSigBToA1Tag, icSigBToA2Tag, icSigCalibrationDateTimeTag, icSigCharTargetTag, icSigChromaticAdaptationTag, icSigChromaticityTag, icSigCmyData, icSigCmykData, icSigColorantOrderTag, icSigColorantTableTag, icSigColorSpaceClass, icSigCopyrightTag, icSigCrdInfoTag, icSigDeviceMfgDescTag, icSigDeviceModelDescTag, icSigDeviceSettingsTag, icSigDisplayClass, icSigGamutTag, icSigGrayData, icSigGrayTRCTag, icSigGreenColorantTag, icSigGreenMatrixColumnTag, icSigGreenTRCTag, icSigHead, icSigHlsData, icSigHsvData, icSigInputClass, icSigLabData, icSigLinkClass, icSigLuminanceTag, icSigLuvData, icSigMeasurementTag, icSigMediaBlackPointTag, icSigMediaWhitePointTag, icSigNamedColor2Tag, icSigNamedColorClass, icSigOutputClass, icSigOutputResponseTag, icSigPreview0Tag, icSigPreview1Tag, icSigPreview2Tag, icSigProfileDescriptionTag, icSigProfileSequenceDescTag, icSigPs2CRD0Tag, icSigPs2CRD1Tag, icSigPs2CRD2Tag, icSigPs2CRD3Tag, icSigPs2CSATag, icSigPs2RenderingIntentTag, icSigRedColorantTag, icSigRedMatrixColumnTag, icSigRedTRCTag, icSigRgbData, icSigScreeningDescTag, icSigScreeningTag, icSigSpace2CLR, icSigSpace3CLR, icSigSpace4CLR, icSigSpace5CLR, icSigSpace6CLR, icSigSpace7CLR, icSigSpace8CLR, icSigSpace9CLR, icSigSpaceACLR, icSigSpaceBCLR, icSigSpaceCCLR, icSigSpaceDCLR, icSigSpaceECLR, icSigSpaceFCLR, icSigTechnologyTag, icSigUcrBgTag, icSigViewingCondDescTag, icSigViewingConditionsTag, icSigXYZData, icSigYCbCrData, icSigYxyData, icTagReserved, icTagType, icXYZNumberX
方法摘要
float | getGamma() 返回一个表示色调再现曲线 (TRC) 的 gamma 值。
float[] | getMediaWhitePoint() 返回一个长度为 3 的 float 数组，在其 ICC 配置文件中包含 mediaWhitePointTag 的 X、Y 和 Z 分量。
short[] | getTRC() 以 short 数组的形式返回 TRC。
从类 java.awt.color.ICC_Profile 继承的方法
finalize, getColorSpaceType, getData, getData, getInstance, getInstance, getInstance, getInstance, getMajorVersion, getMinorVersion, getNumComponents, getPCSType, getProfileClass, readResolve, setData, write, write
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getMediaWhitePoint

public float[] getMediaWhitePoint()
返回一个长度为 3 的 float 数组，在其 ICC 配置文件中包含 mediaWhitePointTag 的 X、Y 和 Z 分量。

返回：
一个在其 ICC 配置文件中包含 mediaWhitePointTag 各分量的数组。

getGamma

public float getGamma()
返回一个表示色调再现曲线 (TRC) 的 gamma 值。如果配置文件将 TRC 表示成一个表，而不是一个单个 gamma 值，则抛出异常。在这种情况下，可通过 getTRC() 获得实际的表。使用 gamma 值时，PCS Y 分量按以下方式计算：

                          gamma
         PCSY = deviceGray

返回：
一个 float 类型的 gamma 值。
抛出：
ProfileDataException - 如果配置文件未将 TRC 指定为单个 gamma 值。

getTRC

public short[] getTRC()
以 short 数组的形式返回 TRC。如果配置文件已将 TRC 指定为线性（gamma＝1.0）或简单 gamma 值，则此方法将抛出异常，应该使用 getGamma() 方法来获取该 gamma 值。否则此处返回的 short 类型数组表示一个查找表，在理论上，其输入 Gray 值范围是 [0.0, 1.0]。值 0.0 对应数组索引 0，值 1.0 则对应数组索引 length-1。对于数组中无确切对应某个索引的输入值，可以使用插值法为其生成输出值。输出值也与范围 [0.0, 1.0] 呈线性对应。值 0.0 由数组值 0x0000 表示，值 1.0 则由数组值 0xFFFF 表示，也就是说尽管这些值是以 short 数组的形式返回的，但它们实际上是无符号的 short 值。

返回：
一个表示 TRC 的 short 数组。
抛出：
ProfileDataException - 如果配置文件没有将 TRC 指定为一个表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ICC_ProfileRGB (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.color
类 ICC_ProfileRGB

java.lang.Object
    继承者  java.awt.color.ICC_Profile
        继承者  java.awt.color.ICC_ProfileRGB
所有已实现的接口：
Serializable
public class ICC_ProfileRGB
extends ICC_Profile

ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件：

  • 配置文件的颜色空间类型是 RGB。
  • 配置文件包括 redColorantTag、greenColorantTag、blueColorantTag、redTRCTag、greenTRCTag、blueTRCTag 和 mediaWhitePointTag 标记。
当满足这些条件时，ICC_Profile 的 getInstance 方法将返回一个 ICC_ProfileRGB 对象。三个分量、基于矩阵输入的配置文件和 RGB 显示配置文件是这种类型的配置文件示例。

此配置文件类提供了颜色变换矩阵和查找表，Java 或本机方法在某些情况下可直接使用它们来优化颜色转换。

要从设备配置文件颜色空间转换到 CIEXYZ 配置文件连接空间，首先应该由查找表通过色调再现曲线 (TRC) 来线性化每种设备颜色分量。线性化之后的 RGB 分量通过一个由 RGB 颜料所构造的 3x3 矩阵转换为 CIEXYZ PCS。

                 linearR = redTRC[deviceR]

                 linearG = greenTRC[deviceG]

                 linearB = blueTRC[deviceB]

   _      _       _                                             _   _         _
  [  PCSX  ]     [  redColorantX  greenColorantX  blueColorantX  ] [  linearR  ]
  [        ]     [                                               ] [           ]
  [  PCSY  ]  =  [  redColorantY  greenColorantY  blueColorantY  ] [  linearG  ]
  [        ]     [                                               ] [           ]
  [_ PCSZ _]     [_ redColorantZ  greenColorantZ  blueColorantZ _] [_ linearB _]
可用以下方式执行逆向转换：通过上面 3x3 矩阵的逆矩阵可将 PCS XYZ 分量转换为线性 RGB 分量，然后通过逆 TRC 将线性 RGB 转换为设备 RGB。

另请参见：
序列化表格

字段摘要
static int | BLUECOMPONENT 用于获取蓝色分量的 gamma 值或 TRC。
static int | GREENCOMPONENT 用于获取绿色分量的 gamma 值或 TRC。
static int | REDCOMPONENT 用于获取红色分量的 gamma 值或 TRC。
从类 java.awt.color.ICC_Profile 继承的字段
CLASS_ABSTRACT, CLASS_COLORSPACECONVERSION, CLASS_DEVICELINK, CLASS_DISPLAY, CLASS_INPUT, CLASS_NAMEDCOLOR, CLASS_OUTPUT, icAbsoluteColorimetric, icCurveCount, icCurveData, icHdrAttributes, icHdrCmmId, icHdrColorSpace, icHdrCreator, icHdrDate, icHdrDeviceClass, icHdrFlags, icHdrIlluminant, icHdrMagic, icHdrManufacturer, icHdrModel, icHdrPcs, icHdrPlatform, icHdrProfileID, icHdrRenderingIntent, icHdrSize, icHdrVersion, icICCAbsoluteColorimetric, icMediaRelativeColorimetric, icPerceptual, icRelativeColorimetric, icSaturation, icSigAbstractClass, icSigAToB0Tag, icSigAToB1Tag, icSigAToB2Tag, icSigBlueColorantTag, icSigBlueMatrixColumnTag, icSigBlueTRCTag, icSigBToA0Tag, icSigBToA1Tag, icSigBToA2Tag, icSigCalibrationDateTimeTag, icSigCharTargetTag, icSigChromaticAdaptationTag, icSigChromaticityTag, icSigCmyData, icSigCmykData, icSigColorantOrderTag, icSigColorantTableTag, icSigColorSpaceClass, icSigCopyrightTag, icSigCrdInfoTag, icSigDeviceMfgDescTag, icSigDeviceModelDescTag, icSigDeviceSettingsTag, icSigDisplayClass, icSigGamutTag, icSigGrayData, icSigGrayTRCTag, icSigGreenColorantTag, icSigGreenMatrixColumnTag, icSigGreenTRCTag, icSigHead, icSigHlsData, icSigHsvData, icSigInputClass, icSigLabData, icSigLinkClass, icSigLuminanceTag, icSigLuvData, icSigMeasurementTag, icSigMediaBlackPointTag, icSigMediaWhitePointTag, icSigNamedColor2Tag, icSigNamedColorClass, icSigOutputClass, icSigOutputResponseTag, icSigPreview0Tag, icSigPreview1Tag, icSigPreview2Tag, icSigProfileDescriptionTag, icSigProfileSequenceDescTag, icSigPs2CRD0Tag, icSigPs2CRD1Tag, icSigPs2CRD2Tag, icSigPs2CRD3Tag, icSigPs2CSATag, icSigPs2RenderingIntentTag, icSigRedColorantTag, icSigRedMatrixColumnTag, icSigRedTRCTag, icSigRgbData, icSigScreeningDescTag, icSigScreeningTag, icSigSpace2CLR, icSigSpace3CLR, icSigSpace4CLR, icSigSpace5CLR, icSigSpace6CLR, icSigSpace7CLR, icSigSpace8CLR, icSigSpace9CLR, icSigSpaceACLR, icSigSpaceBCLR, icSigSpaceCCLR, icSigSpaceDCLR, icSigSpaceECLR, icSigSpaceFCLR, icSigTechnologyTag, icSigUcrBgTag, icSigViewingCondDescTag, icSigViewingConditionsTag, icSigXYZData, icSigYCbCrData, icSigYxyData, icTagReserved, icTagType, icXYZNumberX
方法摘要
float | getGamma(int component) 返回表示特定分量色调再现曲线 (TRC) 的 gamma 值。
float[][] | getMatrix() 返回一个由配置文件的 redColorantTag、greenColorantTag 和 blueColorantTag 的 X、Y 和 Z 分量构造的 3x3 float 矩阵。
float[] | getMediaWhitePoint() 返回包含配置文件的 mediaWhitePointTag 分量的数组。
short[] | getTRC(int component) 以数组形式返回特定分量的 TRC。
从类 java.awt.color.ICC_Profile 继承的方法
finalize, getColorSpaceType, getData, getData, getInstance, getInstance, getInstance, getInstance, getMajorVersion, getMinorVersion, getNumComponents, getPCSType, getProfileClass, readResolve, setData, write, write
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

REDCOMPONENT

public static final int REDCOMPONENT
用于获取红色分量的 gamma 值或 TRC。

另请参见：
常量字段值

GREENCOMPONENT

public static final int GREENCOMPONENT
用于获取绿色分量的 gamma 值或 TRC。

另请参见：
常量字段值

BLUECOMPONENT

public static final int BLUECOMPONENT
用于获取蓝色分量的 gamma 值或 TRC。

另请参见：
常量字段值
方法详细信息

getMediaWhitePoint

public float[] getMediaWhitePoint()
返回包含配置文件的 mediaWhitePointTag 分量的数组。

返回：
一个 3 元素的 float 数组，它包含配置文件的 mediaWhitePointTag 的 x、y 和 z 分量。

getMatrix

public float[][] getMatrix()
返回一个由配置文件的 redColorantTag、greenColorantTag 和 blueColorantTag 的 X、Y 和 Z 分量构造的 3x3 float 矩阵。

此矩阵可用于配置文件的正向颜色转换，即从配置文件颜色空间到 CIEXYZ PCS 的转变。

返回：
一个包含配置文件的 redColorantTag、greenColorantTag 和 blueColorantTag 的 X、Y 和 Z 分量的 3x3 float 数组。

getGamma

public float getGamma(int component)
返回表示特定分量色调再现曲线 (TRC) 的 gamma 值。component 参数必须是 REDCOMPONENT、GREENCOMPONENT 或 BLUECOMPONENT 三者之一。

如果配置文件将相应分量的 TRC 表示为表，而不是单个 gamma 值，则抛出异常。在这种情况下，可通过 getTRC(int) 方法获得实际的表。使用 gamma 值时，按如下方式计算线性分量（R、G 或 B）：

                                           gamma
          linearComponent = deviceComponent

参数：
component - ICC_ProfileRGB 常量，表示要检索其 TRC 的分量
返回：
float 类型的 gamma 值。
抛出：
ProfileDataException - 如果配置文件没有将相应的 TRC 指定为单个 gamma 值。

getTRC

public short[] getTRC(int component)
以数组形式返回特定分量的 TRC。Component 必须是 REDCOMPONENT、GREENCOMPONENT 或 BLUECOMPONENT 三者之一。否则该返回数组表示一个查找表，在理论上，其输入分量值范围是 [0.0, 1.0]。值 0.0 对应数组索引 0，值 1.0 则对应数组索引 length-1。对于数组中无确切对应某个索引的输入值，可以使用插值法为其生成输出值。输出值也与范围 [0.0, 1.0] 呈线性对应。数组值 0x0000 表示值 0.0，0xFFFF 则表示值 1.0。换句话说，尽管这些值是以 short 数组的形式返回的，但它们实际上是无符号的 short 值。 如果配置文件已经将相应的 TRC 指定为线性（gamma＝1.0）或一个简单的 gamma 值，则此方法抛出异常。在这种情况下，应该使用 getGamma(int) 方法获取 gamma 值。

参数：
component - ICC_ProfileRGB 常量，表示要检索其 TRC 的分量：REDCOMPONENT、GREENCOMPONENT 或 BLUECOMPONENT。
返回：
表示 TRC 的 short 数组。
抛出：
ProfileDataException - 如果配置文件没有将相应的 TRC 指定为一个表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProfileDataException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.color
类 ProfileDataException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.awt.color.ProfileDataException
所有已实现的接口：
Serializable
public class ProfileDataException
extends RuntimeException

当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

另请参见：
序列化表格

构造方法摘要
ProfileDataException(String s)
构造带指定详细消息的 ProfileDataException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ProfileDataException

public ProfileDataException(String s)
构造带指定详细消息的 ProfileDataException。

参数：
s - 指定的详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.color (Java 2 Platform SE 6)

 java.awt.color
类
ColorSpace
ICC_ColorSpace
ICC_Profile
ICC_ProfileGray
ICC_ProfileRGB
异常
CMMException
ProfileDataException


java.awt.color (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.color

提供用于颜色空间的类。

请参见：
描述

类摘要
ColorSpace | 此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。
ICC_ColorSpace | ICC_ColorSpace 类是抽象 ColorSpace 类的实现。
ICC_Profile | 与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。
ICC_ProfileGray | ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。
ICC_ProfileRGB | ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。

异常摘要
CMMException | 如果本机 CMM 返回一个错误，则抛出此异常。
ProfileDataException | 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

软件包 java.awt.color 的描述

提供用于颜色空间的类。它包含了基于国际色彩联盟 (ICC) 配置文件格式规范（版本 3.4，1997 年 8 月 15 日）的颜色空间实现。它还包含了基于 ICC 配置文件格式规范的颜色配置文件。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.color 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.color 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.color.ColorSpace (implements java.io.Serializable)
      • java.awt.color.ICC_ColorSpace
    • java.awt.color.ICC_Profile (implements java.io.Serializable)
      • java.awt.color.ICC_ProfileGray
      • java.awt.color.ICC_ProfileRGB
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.awt.color.CMMException
          • java.awt.color.ProfileDataException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.color 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.color
的使用

使用 java.awt.color 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt 使用的 java.awt.color 中的类
ColorSpace
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。

java.awt.color 使用的 java.awt.color 中的类
ColorSpace
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。
ICC_Profile
与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。

java.awt.image 使用的 java.awt.color 中的类
ColorSpace
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。
ICC_Profile
与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。

javax.imageio 使用的 java.awt.color 中的类
ColorSpace
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.color.CMMException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.CMMException
的使用

没有 java.awt.color.CMMException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.color.ICC_ProfileGray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_ProfileGray
的使用

没有 java.awt.color.ICC_ProfileGray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.color.ProfileDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ProfileDataException
的使用

没有 java.awt.color.ProfileDataException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.color.ICC_ColorSpace 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_ColorSpace
的使用

没有 java.awt.color.ICC_ColorSpace 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.color.ICC_ProfileRGB 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_ProfileRGB
的使用

没有 java.awt.color.ICC_ProfileRGB 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.color.ICC_Profile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ICC_Profile
的使用

使用 ICC_Profile 的软件包
java.awt.color | 提供用于颜色空间的类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt.color 中 ICC_Profile 的使用

java.awt.color 中 ICC_Profile 的子类
class | ICC_ProfileGray ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。
class | ICC_ProfileRGB ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。

返回 ICC_Profile 的 java.awt.color 中的方法
static ICC_Profile | ICC_Profile.getInstance(byte[] data) 构造一个与 byte 数组中的数据相对应的 ICC_Profile 对象。
static ICC_Profile | ICC_Profile.getInstance(InputStream s) 构造一个与 InputStream 中的数据相对应的 ICC_Profile。
static ICC_Profile | ICC_Profile.getInstance(int cspace) 构造一个与 ColorSpace 类所定义的指定颜色空间之一（如 CS_sRGB）相对应的 ICC_Profile。
static ICC_Profile | ICC_Profile.getInstance(String fileName) 构造一个与文件中的数据相对应的 ICC_Profile。
ICC_Profile | ICC_ColorSpace.getProfile() 返回此 ICC_ColorSpace 的 ICC_Profile。

参数类型为 ICC_Profile 的 java.awt.color 中的构造方法
ICC_ColorSpace(ICC_Profile profile)
由 ICC_Profile 对象构造一个新的 ICC_ColorSpace。

java.awt.image 中 ICC_Profile 的使用

返回 ICC_Profile 的 java.awt.image 中的方法
 ICC_Profile[] ColorConvertOp.getICC_Profiles()
返回用于构造此 ColorConvertOp 的 ICC_Profiles 的数组。

参数类型为 ICC_Profile 的 java.awt.image 中的构造方法
ColorConvertOp(ICC_Profile[] profiles, RenderingHints hints)
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.color.ColorSpace 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.color.ColorSpace
的使用

使用 ColorSpace 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt 中 ColorSpace 的使用

返回 ColorSpace 的 java.awt 中的方法
 ColorSpace Color.getColorSpace()
返回此 Color 的 ColorSpace。

参数类型为 ColorSpace 的 java.awt 中的方法
float[] | Color.getColorComponents(ColorSpace cspace, float[] compArray) 根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的颜色分量。
float[] | Color.getComponents(ColorSpace cspace, float[] compArray) 根据由 cspace 参数指定的 ColorSpace，返回一个 float 数组，该数组只包含 Color 的 alpha 分量。

参数类型为 ColorSpace 的 java.awt 中的构造方法
Color(ColorSpace cspace, float[] components, float alpha)
创建具有 float 数组中指定的颜色分量和指定的 alpha 值的指定 ColorSpace 中的颜色。

java.awt.color 中 ColorSpace 的使用

java.awt.color 中 ColorSpace 的子类
 class ICC_ColorSpace
ICC_ColorSpace 类是抽象 ColorSpace 类的实现。

返回 ColorSpace 的 java.awt.color 中的方法
static ColorSpace ColorSpace.getInstance(int colorspace)
返回表示特定于预定义颜色空间之一的 ColorSpace。

java.awt.image 中 ColorSpace 的使用

返回 ColorSpace 的 java.awt.image 中的方法
 ColorSpace ColorModel.getColorSpace()
返回与此 ColorModel 相关的 ColorSpace。

参数类型为 ColorSpace 的 java.awt.image 中的构造方法
ColorConvertOp(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
根据两个 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ColorSpace cspace, RenderingHints hints)
根据 ColorSpace 对象构造新的 ColorConvertOp。
ColorModel(int pixel_bits, int[] bits, ColorSpace cspace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
构造将像素值转换为颜色/alpha 分量的 ColorModel。
ComponentColorModel(ColorSpace colorSpace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
根据指定参数构造 ComponentColorModel。
ComponentColorModel(ColorSpace colorSpace, int[] bits, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
根据指定参数构造 ComponentColorModel。
DirectColorModel(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int transferType)
根据指定参数构造 DirectColorModel。
PackedColorModel(ColorSpace space, int bits, int[] colorMaskArray, int alphaMask, boolean isAlphaPremultiplied, int trans, int transferType)
根据颜色掩码数组（指定了 int 像素表示形式中哪些位包含每个颜色的采样）和 alpha 掩码来构造一个 PackedColorModel。
PackedColorModel(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int trans, int transferType)
根据指定的掩码构造一个 PackedColorModel，该掩码指示 int 像素表示形式中的哪些位包含 alpha、红色、绿色和蓝色采样。

javax.imageio 中 ColorSpace 的使用

参数类型为 ColorSpace 的 javax.imageio 中的方法
static ImageTypeSpecifier | ImageTypeSpecifier.createBanded(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。
static ImageTypeSpecifier | ImageTypeSpecifier.createInterleaved(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。
static ImageTypeSpecifier | ImageTypeSpecifier.createPacked(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied) 返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Autoscroll (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
接口 Autoscroll

public interface Autoscroll

在 DnD 操作期间，用户有可能希望将操作目标放入一个可滚动的 GUI 控件区域中，而该区域当前对用户是不可见的。

为了使不可见区域对用户可见，此时希望 GUI 控件检测到此操作并开始滚动操作。此功能称为自动滚动。

如果 GUI 控件既是一个活动 DropTarget，又是可滚动的，则可以接收用户从实现此接口的 DnD 系统发出的自动滚动动作通知。

用户将拖动光标在 Component 的边界区域（称为“自动滚动区域”）持续一段预定义的时间不动，即可发起自动滚动动作，这将导致向该 Component 重复发出滚动请求，直到拖动 Cursor 恢复其运动。

从以下版本开始：
1.2

方法摘要
void | autoscroll(Point cursorLocn) 通知 Component 自动滚动
Insets | getAutoscrollInsets() 此方法返回 Insets，用于描述相对于实现 Component 几何形状的自动滚动区域或边界。

方法详细信息

getAutoscrollInsets

Insets getAutoscrollInsets()
此方法返回 Insets，用于描述相对于实现 Component 几何形状的自动滚动区域或边界。

将 Cursor 拖入关联的 Component 时，DropTarget 读取此值一次。

返回：
Insets

autoscroll

void autoscroll(Point cursorLocn)
通知 Component 自动滚动

参数：
cursorLocn - 一个指示触发此操作的光标位置的 Point。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DnDConstants (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DnDConstants

java.lang.Object
    继承者  java.awt.dnd.DnDConstants

public final class DnDConstants
extends Object

此类包含了表示 Drag 和 Drop 操作所执行的操作类型的常量值。

从以下版本开始：
1.2

字段摘要
static int | ACTION_COPY 表示“复制”操作的 int 值。
static int | ACTION_COPY_OR_MOVE 表示“复制”或“移动”操作的 int 值。
static int | ACTION_LINK 表示“链接”操作的 int 值。
static int | ACTION_MOVE 表示“移动”操作的 int 值。
static int | ACTION_NONE 表示无操作的 int 值。
static int | ACTION_REFERENCE 表示“引用”操作的 int 值（等同于 ACTION_LINK）。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ACTION_NONE

public static final int ACTION_NONE
表示无操作的 int 值。

另请参见：
常量字段值

ACTION_COPY

public static final int ACTION_COPY
表示“复制”操作的 int 值。

另请参见：
常量字段值

ACTION_MOVE

public static final int ACTION_MOVE
表示“移动”操作的 int 值。

另请参见：
常量字段值

ACTION_COPY_OR_MOVE

public static final int ACTION_COPY_OR_MOVE
表示“复制”或“移动”操作的 int 值。

另请参见：
常量字段值

ACTION_LINK

public static final int ACTION_LINK
表示“链接”操作的 int 值。在很多平台（并非所有本机 DnD 平台）中都可找到动词链接，“链接”语义的实际解释是与平台和应用程序相关的。一般而言，该语义是“不复制或移动操作数，而是为其创建一个引用”。对“引用”含义的定义正是导致歧义的症结所在。出于完整性考虑才提供该动词，但是不建议将其用于逻辑上不同的应用程序之间的 DnD 操作，对操作语义的误解会导致用户混淆结果。

另请参见：
常量字段值

ACTION_REFERENCE

public static final int ACTION_REFERENCE
表示“引用”操作的 int 值（等同于 ACTION_LINK）。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragGestureEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragGestureEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.dnd.DragGestureEvent
所有已实现的接口：
Serializable
public class DragGestureEvent
extends EventObject

当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。

另请参见：
DragGestureRecognizer, DragGestureListener, DragSource, 序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。
方法摘要
Component | getComponent() 返回与此 DragGestureEvent 关联的 Component。
int | getDragAction() 返回用户所选操作的 int 表示形式。
Point | getDragOrigin() 返回 Component 坐标中开始拖动位置的 Point。
DragSource | getDragSource() 返回 DragSource。
DragGestureRecognizer | getSourceAsDragGestureRecognizer() 以 DragGestureRecognizer 的形式返回源。
InputEvent | getTriggerEvent() 返回触发动作的初始事件。
Iterator<InputEvent> | iterator() 返回组成动作的事件 Iterator。
void | startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | startDrag(Cursor dragCursor, Transferable transferable) 在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
void | startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
Object[] | toArray() 返回组成拖动动作的事件 Object 数组。
Object[] | toArray(Object[] array) 返回组成拖动动作的事件数组。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DragGestureEvent

public DragGestureEvent(DragGestureRecognizer dgr,
                        int act,
                        Point ori,
                        List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。

参数：
dgr - 激发此事件的 DragGestureRecognizer
act - 用户的首选操作
ori - 拖动的原点
evs - 组成该动作的事件 List

抛出：
IllegalArgumentException - 如果输入参数为 null
方法详细信息

getSourceAsDragGestureRecognizer

public DragGestureRecognizer getSourceAsDragGestureRecognizer()
以 DragGestureRecognizer 的形式返回源。

返回：
DragGestureRecognizer 形式的源。

getComponent

public Component getComponent()
返回与此 DragGestureEvent 关联的 Component。

返回：
Component

getDragSource

public DragSource getDragSource()
返回 DragSource。

返回：
DragSource

getDragOrigin

public Point getDragOrigin()
返回 Component 坐标中开始拖动位置的 Point。

返回：
Component 坐标中开始拖动位置的 Point。

iterator

public Iterator<InputEvent> iterator()
返回组成动作的事件 Iterator。

返回：
组成动作的事件 Iterator

toArray

public Object[] toArray()
返回组成拖动动作的事件 Object 数组。

返回：
组成动作的事件数组

toArray

public Object[] toArray(Object[] array)
返回组成拖动动作的事件数组。

参数：
array - EventObject 子（类型）数组

返回：
组成动作的事件数组

getDragAction

public int getDragAction()
返回用户所选操作的 int 表示形式。

返回：
用户选择的操作

getTriggerEvent

public InputEvent getTriggerEvent()
返回触发动作的初始事件。

返回：
操作序列中的首个“触发”事件

startDrag

public void startDrag(Cursor dragCursor,
                      Transferable transferable)
               throws InvalidDnDOperationException
在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
如果指定的 Cursor 为 null，则不抛出异常，而是使用默认的拖动光标。
如果指定的 Transferable 为 null，则抛出 NullPointerException。

参数：
dragCursor - 此拖动操作的 Cursor
transferable - 表示此拖动操作源数据的 Transferable。
抛出：
InvalidDnDOperationException - 如果 Drag 和 Drop 系统不能发起拖动操作，或者用户试图开始拖动的同时仍在执行现有的拖动操作。
NullPointerException - 如果 Transferable 为 null。
InvalidDnDOperationException
从以下版本开始：
1.4

startDrag

public void startDrag(Cursor dragCursor,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。

参数：
dragCursor - 初始的拖动 Cursor
transferable - 拖动源的 Transferable
dsl - 拖动源的 DragSourceListener

抛出：
InvalidDnDOperationException - 如果 Drag 和 Drop 系统不能发起拖动操作，或者用户试图开始拖动的同时仍在执行现有的拖动操作。
InvalidDnDOperationException

startDrag

public void startDrag(Cursor dragCursor,
                      Image dragImage,
                      Point imageOffset,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。

参数：
dragCursor - 初始的拖动 Cursor
dragImage - 拖动源的 dragImage
imageOffset - dragImage 的偏移量
transferable - 拖动源的 Transferable
dsl - 拖动源的 DragSourceListener

抛出：
InvalidDnDOperationException - 如果 Drag 和 Drop 系统不能发起拖动操作，或者用户试图开始拖动的同时仍在执行现有的拖动操作。
InvalidDnDOperationException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragGestureListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
接口 DragGestureListener

所有超级接口：
EventListener
public interface DragGestureListener
extends EventListener

此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。

接收到这种通知之后，此接口的实现者将负责启动拖动操作。

另请参见：
DragGestureRecognizer, DragGestureEvent, DragSource

方法摘要
 void dragGestureRecognized(DragGestureEvent dge)
DragGestureRecognizer 已经检测到与平台有关的拖动启动动作，并且正通知此侦听器，以便启动用户操作。

方法详细信息

dragGestureRecognized

void dragGestureRecognized(DragGestureEvent dge)
DragGestureRecognizer 已经检测到与平台有关的拖动启动动作，并且正通知此侦听器，以便启动用户操作。

参数：
dge - 描述刚才所发生动作的 DragGestureEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragGestureRecognizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragGestureRecognizer

java.lang.Object
    继承者  java.awt.dnd.DragGestureRecognizer
所有已实现的接口：
Serializable
直接已知子类：
MouseDragGestureRecognizer
public abstract class DragGestureRecognizer
extends Object
implements Serializable

DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。

可从与特定 Component 关联的 DragSource，或通过其 createDragGestureRecognizer() 方法从 Toolkit 对象获得合适的 DragGestureRecognizer 子类。

DragGestureRecognizer 一旦与特定的 Component 关联，就会在该 Component 上注册合适的侦听器接口，以跟踪传递给该 Component 的输入事件。

DragGestureRecognizer 一旦将该 Component 上的事件顺序标识为拖动开始动作，它就会通过调用其 gestureRecognized() 方法来通知其单播传递的 DragGestureListener。

当具体的 DragGestureRecognizer 实例在其关联的 Component 上检测到拖动开始动作时，它将激发一个 DragGestureEvent，并针对 DragGestureListener 事件将其传递给在其单播传递事件源上注册的 DragGestureListener。此 DragGestureListener 负责使关联的 DragSource 开始 Drag 和 Drop 操作（如果合适）。

另请参见：
DragGestureListener, DragGestureEvent, DragSource, 序列化表格

字段摘要
protected Component | component 与此 DragGestureRecognizer 关联的 Component。
protected DragGestureListener | dragGestureListener 与此 DragGestureRecognizer 关联的 DragGestureListener。
protected DragSource | dragSource 与此 DragGestureRecognizer 关联的 DragSource。
protected ArrayList<InputEvent> | events DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。
protected int | sourceActions 此 Drag 和 Drop 操作中所用动作类型的 int 表示形式。
构造方法摘要
protected | DragGestureRecognizer(DragSource ds) 构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource。
protected | DragGestureRecognizer(DragSource ds, Component c) 构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。
protected | DragGestureRecognizer(DragSource ds, Component c, int sa) 构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。
protected | DragGestureRecognizer(DragSource ds, Component c, int sa, DragGestureListener dgl) 构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
方法摘要
void | addDragGestureListener(DragGestureListener dgl) 注册一个新的 DragGestureListener。
protected void | appendEvent(InputEvent awtie) Recognizer 在 Component 上注册的侦听器将通过此 API 记录所有识别的 Event，识别的 Event 是组成 Drag 和 Drop 开始动作的系列 Event 的一部分。
protected void | fireDragGestureRecognized(int dragAction, Point p) 通知 DragGestureListener 已发生了 Drag 和 Drop 开始动作。
Component | getComponent() 此方法返回 DragGestureRecognizer 所“观察”的 Component，以便了解拖动开始动作。
DragSource | getDragSource() 此方法返回 DragSource，为了进行 Drag 和 Drop 操作，将使用此 DragGestureRecognizer。
int | getSourceActions() 此方法返回 Drag 和 Drop 操作所支持动作类型的 int 表示形式。
InputEvent | getTriggerEvent() 此方法返回发起 Drag 和 Drop 操作的系列事件中的首个事件。
protected abstract void | registerListeners() 向该 Component 注册此 DragGestureRecognizer 的 Listeners。
void | removeDragGestureListener(DragGestureListener dgl) 取消注册当前的 DragGestureListener
void | resetRecognizer() 重置 Recognizer，如果 Recognizer 当前正在识别一个动作，则忽略。
void | setComponent(Component c) 设置与该 DragGestureRecognizer 关联的 Component 使用此方法时还会调用 registerListeners() 和 unregisterListeners()。
void | setSourceActions(int actions) 此方法设置此 Drag 和 Drop 操作允许的源拖动动作。
protected abstract void | unregisterListeners() 向该 Component 取消注册此 DragGestureRecognizer 的 Listeners。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

dragSource

protected DragSource dragSource
与此 DragGestureRecognizer 关联的 DragSource。

component

protected Component component
与此 DragGestureRecognizer 关联的 Component。

dragGestureListener

protected transient DragGestureListener dragGestureListener
与此 DragGestureRecognizer 关联的 DragGestureListener。

sourceActions

protected int sourceActions
此 Drag 和 Drop 操作中所用动作类型的 int 表示形式。

events

protected ArrayList<InputEvent> events
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。

构造方法详细信息

DragGestureRecognizer

protected DragGestureRecognizer(DragSource ds,
                                Component c,
                                int sa,
                                DragGestureListener dgl)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。

参数：
ds - 此 DragGestureRecognizer 用于处理 Drag 和 Drop 操作的 DragSource
c - 为了检测拖动开始动作，此 DragGestureRecognizer 应该“观察”事件流去往的 Component。如果此值为 null，则 DragGestureRecognizer 未与任何 Component 关联。
sa - 此 Drag 和 Drop 操作支持的 DnDConstants 集合（逻辑“或”）
dgl - 检测到拖动动作时要通知的 DragGestureRecognizer

抛出：
IllegalArgumentException - 如果 ds 为 null。

DragGestureRecognizer

protected DragGestureRecognizer(DragSource ds,
                                Component c,
                                int sa)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。

参数：
ds - 此 DragGestureRecognizer 用于处理 Drag 和 Drop 操作的 DragSource
c - 为了检测拖动开始动作，此 DragGestureRecognizer 应该“观察”事件流去往的 Component。如果此值为 null，则 DragGestureRecognizer 未与任何 Component 关联。
sa - 此 Drag 和 Drop 操作支持的 DnDConstants 集合（逻辑“或”）

抛出：
IllegalArgumentException - 如果 ds 为 null。

DragGestureRecognizer

protected DragGestureRecognizer(DragSource ds,
                                Component c)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。

参数：
ds - 此 DragGestureRecognizer 用于处理 Drag 和 Drop 操作的 DragSource
c - 为了检测拖动开始动作，此 DragGestureRecognizer 应该“观察”事件流去往的 Component。如果此值为 null，则 DragGestureRecognizer 未与任何 Component 关联。

抛出：
IllegalArgumentException - 如果 ds 为 null。

DragGestureRecognizer

protected DragGestureRecognizer(DragSource ds)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource。

参数：
ds - 此 DragGestureRecognizer 用于处理 Drag 和 Drop 操作的 DragSource

抛出：
IllegalArgumentException - 如果 ds 为 null。
方法详细信息

registerListeners

protected abstract void registerListeners()
向该 Component 注册此 DragGestureRecognizer 的 Listeners。子类必须重写此方法

unregisterListeners

protected abstract void unregisterListeners()
向该 Component 取消注册此 DragGestureRecognizer 的 Listeners。子类必须重写此方法

getDragSource

public DragSource getDragSource()
此方法返回 DragSource，为了进行 Drag 和 Drop 操作，将使用此 DragGestureRecognizer。

返回：
DragSource

getComponent

public Component getComponent()
此方法返回 DragGestureRecognizer 所“观察”的 Component，以便了解拖动开始动作。

返回：
与此 DragGestureRecognizer 关联的 Component

setComponent

public void setComponent(Component c)
设置与该 DragGestureRecognizer 关联的 Component 使用此方法时还会调用 registerListeners() 和 unregisterListeners()。

参数：
c - Component 或 null

getSourceActions

public int getSourceActions()
此方法返回 Drag 和 Drop 操作所支持动作类型的 int 表示形式。

返回：
当前允许的源动作

setSourceActions

public void setSourceActions(int actions)
此方法设置此 Drag 和 Drop 操作允许的源拖动动作。

参数：
actions - 允许的源拖动动作

getTriggerEvent

public InputEvent getTriggerEvent()
此方法返回发起 Drag 和 Drop 操作的系列事件中的首个事件。

返回：
触发拖动动作的初始事件

resetRecognizer

public void resetRecognizer()
重置 Recognizer，如果 Recognizer 当前正在识别一个动作，则忽略。

addDragGestureListener

public void addDragGestureListener(DragGestureListener dgl)
                            throws TooManyListenersException
注册一个新的 DragGestureListener。

参数：
dgl - 使用此 DragGestureRecognizer 注册的 DragGestureListener。

抛出：
TooManyListenersException - 如果已经添加了 DragGestureListener。

removeDragGestureListener

public void removeDragGestureListener(DragGestureListener dgl)
取消注册当前的 DragGestureListener

参数：
dgl - 使用此 DragGestureRecognizer 取消注册的 DragGestureListener。

抛出：
IllegalArgumentException - 如果 dgl 不是（等于）当前已注册的 DragGestureListener。

fireDragGestureRecognized

protected void fireDragGestureRecognized(int dragAction,
                                         Point p)
通知 DragGestureListener 已发生了 Drag 和 Drop 开始动作。然后重置 Recognizer 的状态。

参数：
dragAction - 通过用户动作初始选中的动作
p - 该动作开始的 point（在 Component 坐标中）

appendEvent

protected void appendEvent(InputEvent awtie)
Recognizer 在 Component 上注册的侦听器将通过此 API 记录所有识别的 Event，识别的 Event 是组成 Drag 和 Drop 开始动作的系列 Event 的一部分。

DragGestureRecognizer 实现使用此方法将 InputEvent 子类（相信它是组成 Drag 和 Drop 操作的系列事件的一部分）添加到此 DragGestureRecognizer 内部维护的事件数组中。

参数：
awtie - 添加到此 DragGestureRecognizer 内部事件数组的 InputEvent。注意，null 不是有效值，将忽略该值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragSource

java.lang.Object
    继承者  java.awt.dnd.DragSource
所有已实现的接口：
Serializable
public class DragSource
extends Object
implements Serializable

DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中：

  • JVM 生命周期中每个 JVM 的一个默认实例。
  • 每个潜在 Drag 初始程序对象（例如 TextField）类的一个实例。[与实现相关]
  • 每个特定 Component 一个实例，或者每个与 GUI 中 Component 实例相关联的特定应用程序对象一个实例。[与实现相关]
  • 其他一些任意的关联。[与实现相关]
一旦获得 DragSource，还应获得一个 DragGestureRecognizer，以便将该 DragSource 与特定的 Component 关联。

通常是由 DragGestureRecognizer 来实现一个 implementing Component，而这个 implementing component 负责用户操作的初始解释和随后开始的拖动操作。

出现一个拖动操作时，应调用 DragSource 的 startDrag() 方法，以处理用户的浏览操作并传递 Drag 和 Drop 协议通知。DragSource 只允许在任一时刻执行一个 Drag 和 Drop 操作，并且在现存的操作完成前，通过抛出 IllegalDnDOperationException 来拒绝所有其他的 startDrag() 请求。

startDrag() 方法调用 createDragSourceContext() 方法来实例化合适的 DragSourceContext，并将 DragSourceContextPeer 与其关联。

如果 Drag 和 Drop 系统由于某些原因而无法开始拖动操作，则 startDrag() 方法抛出 java.awt.dnd.InvalidDnDOperationException 来通知该状况。通常在基础平台系统未处于可初始拖动的状态或者指定的参数无效时抛出此异常。

注意，在拖动期间，操作完成前不能改变拖动源在拖动操作开始时所公开的操作集合。操作持续期间该操作对于 DragSource 而言是持续的。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
static Cursor | DefaultCopyDrop 用于复制操作的默认 Cursor，指示当前允许放置。
static Cursor | DefaultCopyNoDrop 用于复制操作的默认 Cursor，指示当前不允许放置。
static Cursor | DefaultLinkDrop 用于链接操作的默认 Cursor，指示当前允许放置。
static Cursor | DefaultLinkNoDrop 用于链接操作的默认 Cursor，指示当前不允许放置。
static Cursor | DefaultMoveDrop 用于移动操作的默认 Cursor，指示当前允许放置。
static Cursor | DefaultMoveNoDrop 用于移动操作的默认 Cursor，指示当前不允许放置。
构造方法摘要
DragSource()
创建一个新的 DragSource。
方法摘要
 void addDragSourceListener(DragSourceListener dsl)
将指定的 DragSourceListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动源事件。
 void addDragSourceMotionListener(DragSourceMotionListener dsml)
将指定的 DragSourceMotionListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动移动事件。
 DragGestureRecognizer createDefaultDragGestureRecognizer(Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
<T extends DragGestureRecognizer>
T
createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
protected  DragSourceContext createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl)
创建处理此拖动的 DragSourceContext。
static DragSource getDefaultDragSource()
获取与基础平台关联的 DragSource 对象。
 DragSourceListener[] getDragSourceListeners()
获得向此 DragSource 注册的所有 DragSourceListener。
 DragSourceMotionListener[] getDragSourceMotionListeners()
获得向此 DragSource 注册的所有 DragSourceMotionListener。
static int getDragThreshold()
返回拖动操作移动阈值。
 FlavorMap getFlavorMap()
此方法返回此 DragSource 的 FlavorMap。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。
static boolean isDragImageSupported()
报告基础平台是否提供对拖动 Image 的支持。
 void removeDragSourceListener(DragSourceListener dsl)
从此 DragSource 移除指定的 DragSourceListener。
 void removeDragSourceMotionListener(DragSourceMotionListener dsml)
从此 DragSource 移除指定的 DragSourceMotionListener。
 void startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl)
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
 void startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
 void startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl)
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
 void startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap)
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DefaultCopyDrop

public static final Cursor DefaultCopyDrop
用于复制操作的默认 Cursor，指示当前允许放置。如果 GraphicsEnvironment.isHeadless() 返回 true，则为 null。

另请参见：
GraphicsEnvironment.isHeadless()

DefaultMoveDrop

public static final Cursor DefaultMoveDrop
用于移动操作的默认 Cursor，指示当前允许放置。如果 GraphicsEnvironment.isHeadless() 返回 true，则为 null。

另请参见：
GraphicsEnvironment.isHeadless()

DefaultLinkDrop

public static final Cursor DefaultLinkDrop
用于链接操作的默认 Cursor，指示当前允许放置。如果 GraphicsEnvironment.isHeadless() 返回 true，则为 null。

另请参见：
GraphicsEnvironment.isHeadless()

DefaultCopyNoDrop

public static final Cursor DefaultCopyNoDrop
用于复制操作的默认 Cursor，指示当前不允许放置。如果 GraphicsEnvironment.isHeadless() 返回 true，则为 null。

另请参见：
GraphicsEnvironment.isHeadless()

DefaultMoveNoDrop

public static final Cursor DefaultMoveNoDrop
用于移动操作的默认 Cursor，指示当前不允许放置。如果 GraphicsEnvironment.isHeadless() 返回 true，则为 null。

另请参见：
GraphicsEnvironment.isHeadless()

DefaultLinkNoDrop

public static final Cursor DefaultLinkNoDrop
用于链接操作的默认 Cursor，指示当前不允许放置。如果 GraphicsEnvironment.isHeadless() 返回 true，则为 null。

另请参见：
GraphicsEnvironment.isHeadless()
构造方法详细信息

DragSource

public DragSource()
           throws HeadlessException
创建一个新的 DragSource。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

getDefaultDragSource

public static DragSource getDefaultDragSource()
获取与基础平台关联的 DragSource 对象。

返回：
平台 DragSource
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

isDragImageSupported

public static boolean isDragImageSupported()
报告基础平台是否提供对拖动 Image 的支持。

返回：
此平台是否提供对拖动 Image 的支持

startDrag

public void startDrag(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Image dragImage,
                      Point imageOffset,
                      Transferable transferable,
                      DragSourceListener dsl,
                      FlavorMap flavorMap)
               throws InvalidDnDOperationException
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数：
trigger - 发起拖动的 DragGestureEvent
dragCursor - 初始 Cursor，默认为 null
dragImage - 要拖动的图像，或者为 null。
imageOffset - Image 原点距离触发时 Cursor 热点的偏移量
transferable - 该拖动的目标数据
dsl - DragSourceListener
flavorMap - 使用的 FlavorMap，或者为 null

抛出：
java.awt.dnd.InvalidDnDOperationException - 如果 Drag 和 Drop 系统不能发起拖动操作，或者用户试图在现有拖动操作仍在进行时开始拖动。
InvalidDnDOperationException

startDrag

public void startDrag(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Transferable transferable,
                      DragSourceListener dsl,
                      FlavorMap flavorMap)
               throws InvalidDnDOperationException
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数：
trigger - 发起拖动的 DragGestureEvent
dragCursor - 初始 Cursor，默认为 null
transferable - 拖动的目标数据
dsl - DragSourceListener
flavorMap - 使用的 FlavorMap，或者为 null

抛出：
java.awt.dnd.InvalidDnDOperationException - 如果 Drag 和 Drop 系统不能发起拖动操作，或者用户试图在现有拖动操作仍在进行时开始拖动。
InvalidDnDOperationException

startDrag

public void startDrag(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Image dragImage,
                      Point dragOffset,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。

参数：
trigger - 发起拖动的 DragGestureEvent
dragCursor - 初始 Cursor，或默认为 null
dragImage - 要拖动的 Image，或者为 null
dragOffset - Image 原点距离触发开始时 Cursor 热点的偏移量
transferable - 拖动的目标数据
dsl - DragSourceListener

抛出：
java.awt.dnd.InvalidDnDOperationException - 如果 Drag 和 Drop 系统不能发起拖动操作，或者用户试图在现有拖动操作仍在进行时开始拖动。
InvalidDnDOperationException

startDrag

public void startDrag(DragGestureEvent trigger,
                      Cursor dragCursor,
                      Transferable transferable,
                      DragSourceListener dsl)
               throws InvalidDnDOperationException
在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。

参数：
trigger - 发起拖动的 DragGestureEvent
dragCursor - 初始 Cursor，或默认为 null
transferable - 拖动的目标数据
dsl - DragSourceListener

抛出：
java.awt.dnd.InvalidDnDOperationException - 如果 Drag 和 Drop 系统不能发起拖动操作，或者用户试图在现有拖动操作仍在进行时开始拖动。
InvalidDnDOperationException

createDragSourceContext

protected DragSourceContext createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp,
                                                    DragGestureEvent dgl,
                                                    Cursor dragCursor,
                                                    Image dragImage,
                                                    Point imageOffset,
                                                    Transferable t,
                                                    DragSourceListener dsl)
创建处理此拖动的 DragSourceContext。

要合并一个新的 DragSourceContext 子类，可子类化 DragSource 并重写此方法。

如果 dragImage 为 null，则没有用于表示此拖动操作拖动完成的反馈图像，但不抛出 NullPointerException。

如果 dsl 为 null，则没有向已创建的 DragSourceContext 注册的拖动源侦听器，但不抛出 NullPointerException。

如果 dragCursor 为 null，则此拖动操作使用默认的拖动光标。不抛出 NullPointerException。

参数：
dscp - 此拖动的 DragSourceContextPeer
dgl - 触发拖动的 DragGestureEvent
dragCursor - 要显示的初始 Cursor
dragImage - 要拖动的 Image，或者为 null
imageOffset - Image 原点距离触发开始时 cursor 热点的偏移量
t - 拖动的目标数据
dsl - DragSourceListener
返回：
DragSourceContext
抛出：
NullPointerException - 如果 dscp 为 null
NullPointerException - 如果 dgl 为 null
NullPointerException - 如果 dragImage 不为 null，并且 imageOffset 为 null
NullPointerException - 如果 t 为 null
IllegalArgumentException - 如果与触发事件关联的 Component 为 null。
IllegalArgumentException - 如果触发事件的 DragSource 为 null。
IllegalArgumentException - 如果触发事件的拖动操作是 DnDConstants.ACTION_NONE。
IllegalArgumentException - 如果与触发事件关联的 DragGestureRecognizer 的拖动源操作是 DnDConstants.ACTION_NONE。

getFlavorMap

public FlavorMap getFlavorMap()
此方法返回此 DragSource 的 FlavorMap。

返回：
此 DragSource 的 FlavorMap

createDragGestureRecognizer

public <T extends DragGestureRecognizer> T createDragGestureRecognizer(Class<T> recognizerAbstractClass,
                                                                       Component c,
                                                                       int actions,
                                                                       DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。

参数：
recognizerAbstractClass - 所请求的抽象类型
actions - 允许的源拖动操作
c - Component 目标
dgl - 要通知的 DragGestureListener

返回：
新的 DragGestureRecognizer，如果 Toolkit.createDragGestureRecognizer 没有为所请求的 DragGestureRecognizer 子类提供实现并返回 null，则此方法返回 null

createDefaultDragGestureRecognizer

public DragGestureRecognizer createDefaultDragGestureRecognizer(Component c,
                                                                int actions,
                                                                DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。 对于此 DragSource，默认值是 MouseDragGestureRecognizer。

参数：
c - 该识别器的 Component 目标
actions - 允许的源操作
dgl - 要通知的 DragGestureListener

返回：
新的 DragGestureRecognizer，如果 Toolkit.createDragGestureRecognizer 没有为所请求的 DragGestureRecognizer 子类提供实现并返回 null，则此方法返回 null

addDragSourceListener

public void addDragSourceListener(DragSourceListener dsl)
将指定的 DragSourceListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动源事件。如果指定的侦听器为 null，则不采取任何操作并且不抛出任何异常。

参数：
dsl - 要添加的 DragSourceListener
从以下版本开始：
1.4
另请参见：
removeDragSourceListener(java.awt.dnd.DragSourceListener), getDragSourceListeners()

removeDragSourceListener

public void removeDragSourceListener(DragSourceListener dsl)
从此 DragSource 移除指定的 DragSourceListener。如果指定的侦听器为 null，则不采取操作并且不抛出异常。如果该参数所指定的侦听器不是以前添加到此 DragSource 的侦听器，则不采取任何操作并且不抛出任何异常。

参数：
dsl - 要移除的 DragSourceListener
从以下版本开始：
1.4
另请参见：
addDragSourceListener(java.awt.dnd.DragSourceListener), getDragSourceListeners()

getDragSourceListeners

public DragSourceListener[] getDragSourceListeners()
获得向此 DragSource 注册的所有 DragSourceListener。

返回：
此 DragSource 的所有 DragSourceListener，如果当前没有注册这样的侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addDragSourceListener(java.awt.dnd.DragSourceListener), removeDragSourceListener(java.awt.dnd.DragSourceListener)

addDragSourceMotionListener

public void addDragSourceMotionListener(DragSourceMotionListener dsml)
将指定的 DragSourceMotionListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动移动事件。如果指定的侦听器为 null，则不采取任何操作并且不抛出任何异常。

参数：
dsml - 要添加的 DragSourceMotionListener
从以下版本开始：
1.4
另请参见：
removeDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener), getDragSourceMotionListeners()

removeDragSourceMotionListener

public void removeDragSourceMotionListener(DragSourceMotionListener dsml)
从此 DragSource 移除指定的 DragSourceMotionListener。如果指定的侦听器为 null，则不采取任何操作并且不抛出任何异常。如果该参数所指定的侦听器不是以前添加到此 DragSource 的侦听器，则不采取任何操作并且不抛出任何异常。

参数：
dsml - 要移除的 DragSourceMotionListener
从以下版本开始：
1.4
另请参见：
addDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener), getDragSourceMotionListeners()

getDragSourceMotionListeners

public DragSourceMotionListener[] getDragSourceMotionListeners()
获得向此 DragSource 注册的所有 DragSourceMotionListener。

返回：
此 DragSource 的所有 DragSourceMotionListener，如果当前没有注册这样的侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener), removeDragSourceMotionListener(java.awt.dnd.DragSourceMotionListener)

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。FooListener 是用 addFooListener 方法注册的。

参数：
listenerType - 所请求侦听器的类型；此参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
在此 DragSource 上注册为 FooListener 的所有对象的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.4
另请参见：
getDragSourceListeners(), getDragSourceMotionListeners()

getDragThreshold

public static int getDragThreshold()
返回拖动操作移动阈值。拖动操作移动阈值定义了 MouseDragGestureRecognizer 的推荐行为。

如果将系统属性 awt.dnd.drag.threshold 设置为正整数，则此方法返回该系统属性值；否则如果有关的桌面属性可用并且 Java 平台实现支持该属性，则此方法返回该属性值；否则此方法返回某些默认值。可使用 java.awt.Toolkit.getDesktopProperty("DnD.gestureMotionThreshold") 查询有关的桌面属性。

返回：
拖动操作移动阈值
从以下版本开始：
1.5
另请参见：
MouseDragGestureRecognizer
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSourceAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragSourceAdapter

java.lang.Object
    继承者  java.awt.dnd.DragSourceAdapter
所有已实现的接口：
DragSourceListener, DragSourceMotionListener, EventListener
public abstract class DragSourceAdapter
extends Object
implements DragSourceListener, DragSourceMotionListener

用于接收拖动源事件的抽象适配器类。此类中的方法为空。此类存在的目的只是为了便于创建侦听器对象。

扩展此类即可创建 DragSourceEvent 侦听器并为感兴趣的事件重写该方法。（如果实现了 DragSourceListener 接口，则必须定义其中的所有方法。此抽象类为所有方法都定义了 null 方法，所以只需为关心的事件定义方法即可。）

使用扩展的类创建侦听器对象，然后向 DragSource 注册它。当拖动进入、移过或离开放置点时、放置操作改变时和拖动结束时，调用该侦听器对象中的相关方法，并将 DragSourceEvent 传递给该方法。

如果在此适配器类上最后一次调用 dragEnter() 是相对于该放置点的，并且后面没有接着在此适配器类上调用 dragExit()，则该放置点是与上一次 dragEnter() 调用相关联的。

从以下版本开始：
1.4
另请参见：
DragSourceEvent, DragSourceListener, DragSourceMotionListener

构造方法摘要
DragSourceAdapter()
方法摘要
void | dragDropEnd(DragSourceDropEvent dsde) 调用此方法来通知 Drag 和 Drop 操作已完成。
void | dragEnter(DragSourceDragEvent dsde) 光标的热点进入放置点（与平台相关）时调用该方法。
void | dragExit(DragSourceEvent dse) 光标的热点离开放置点（与平台相关）时调用该方法。
void | dragMouseMoved(DragSourceDragEvent dsde) 在拖动操作期间，只要移动了鼠标就调用该方法。
void | dragOver(DragSourceDragEvent dsde) 光标的热点在放置点（与平台相关）上移动时调用该方法。
void | dropActionChanged(DragSourceDragEvent dsde) 当用户修改放置操作时调用该方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DragSourceAdapter

public DragSourceAdapter()
方法详细信息

dragEnter

public void dragEnter(DragSourceDragEvent dsde)
光标的热点进入放置点（与平台相关）时调用该方法。满足以下所有条件时调用此方法：
  • 光标的热点进入与平台相关的放置点的可操作部分。
  • 放置点处于激活状态。
  • 放置点接受该拖动。

指定者：
接口 DragSourceListener 中的 dragEnter
参数：
dsde - DragSourceDragEvent

dragOver

public void dragOver(DragSourceDragEvent dsde)
光标的热点在放置点（与平台相关）上移动时调用该方法。满足以下所有条件时调用此方法：
  • 光标的热点已移动，但是仍旧处于和上一次调用 dragEnter() 相关联的放置点可操作部分内。
  • 放置点仍处于激活状态。
  • 放置点接受该拖动。

指定者：
接口 DragSourceListener 中的 dragOver
参数：
dsde - DragSourceDragEvent

dragMouseMoved

public void dragMouseMoved(DragSourceDragEvent dsde)
在拖动操作期间，只要移动了鼠标就调用该方法。

指定者：
接口 DragSourceMotionListener 中的 dragMouseMoved
参数：
dsde - DragSourceDragEvent

dropActionChanged

public void dropActionChanged(DragSourceDragEvent dsde)
当用户修改放置操作时调用该方法。当用户使用的输入设备状态改变时调用此方法。这种设备通常是与用户交互的鼠标按键或键盘修改键。

指定者：
接口 DragSourceListener 中的 dropActionChanged
参数：
dsde - DragSourceDragEvent

dragExit

public void dragExit(DragSourceEvent dse)
光标的热点离开放置点（与平台相关）时调用该方法。满足以下任一条件时调用此方法：
  • 光标的热点不再处于和上一次调用 dragEnter() 相关联的放置点可操作部分内。
或者
  • 与上一次调用 dragEnter() 相关联的放置点不再处于激活状态。
或者
  • 与上一次调用 dragEnter() 相关联的放置点拒绝该拖动。

指定者：
接口 DragSourceListener 中的 dragExit
参数：
dse - DragSourceEvent

dragDropEnd

public void dragDropEnd(DragSourceDropEvent dsde)
调用此方法来通知 Drag 和 Drop 操作已完成。可以使用 DragSourceDropEvent 的 getDropSuccess() 方法来确定终止状态。getDropAction() 方法返回选择放置点应用到 Drop 操作的操作。一旦此方法完成，则当前的 DragSourceContext 和关联的资源就变为无效。

指定者：
接口 DragSourceListener 中的 dragDropEnd
参数：
dsde - DragSourceDropEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSourceContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragSourceContext

java.lang.Object
    继承者  java.awt.dnd.DragSourceContext
所有已实现的接口：
DragSourceListener, DragSourceMotionListener, Serializable, EventListener
public class DragSourceContext
extends Object
implements DragSourceListener, DragSourceMotionListener, Serializable

DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。特别是负责管理对 DragSourceListener 和 DragSourceMotionListener 的拖动事件通知，并提供表示拖动操作源数据的 Transferable。

注意，DragSourceContext 自行实现 DragSourceListener 和 DragSourceMotionListener 接口。这就允许 DragSource 创建的平台同位体（DragSourceContextPeer 实例）能够在正在进行的操作中通知 DragSourceContext 状态改变。从而允许 DragSourceContext 介入平台和拖动操作起始端所提供的侦听器之间。

从以下版本开始：
1.2
另请参见：
DragSourceListener, DragSourceMotionListener, 序列化表格

字段摘要
protected static int | CHANGED updateCurrentCursor() 使用的 int 值，指示用户操作已改变。
protected static int | DEFAULT updateCurrentCursor() 使用的 int 值，指示应该将 Cursor 改为默认（未放置）的 Cursor。
protected static int | ENTER updateCurrentCursor() 使用的 int 值，指示 Cursor 已进入 DropTarget。
protected static int | OVER updateCurrentCursor() 使用的 int 值，指示 Cursor 处于 DropTarget 上。
构造方法摘要
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。
方法摘要
void | addDragSourceListener(DragSourceListener dsl) 如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。
void | dragDropEnd(DragSourceDropEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragDropEnd，并将指定的 DragSourceDropEvent 传递给它们。
void | dragEnter(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragEnter，并将指定的 DragSourceDragEvent 传递给它们。
void | dragExit(DragSourceEvent dse) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragExit，并将指定的 DragSourceEvent 传递给它们。
void | dragMouseMoved(DragSourceDragEvent dsde) 对向与此 DragSourceContext 关联的 DragSource 注册的 DragSourceMotionListener 调用 dragMouseMoved，并将指定的 DragSourceDragEvent 传递给它们。
void | dragOver(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceContext 调用 dragOver，并将指定的 DragSourceDragEvent 传递给它们。
void | dropActionChanged(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dropActionChanged，并将指定的 DragSourceDragEvent 传递给它们。
Component | getComponent() 返回与此 DragSourceContext 关联的 Component。
Cursor | getCursor() 返回当前的拖动 Cursor
DragSource | getDragSource() 返回实例化此 DragSourceContext 的 DragSource。
int | getSourceActions() 返回 DnDConstants 的位掩码，表示拖动源针对与此 DragSourceContext 关联的拖动操作所支持的放置动作集合。
Transferable | getTransferable() 返回与此 DragSourceContext 关联的 Transferable。
DragGestureEvent | getTrigger() 返回最初触发该拖动的 DragGestureEvent。
void | removeDragSourceListener(DragSourceListener dsl) 从此 DragSourceContext 移除指定的 DragSourceListener。
void | setCursor(Cursor c) 将此拖动操作的光标设置为指定的 Cursor。
void | transferablesFlavorsChanged() 通知同位体该 Transferable 的 DataFlavor 已改变。
protected void | updateCurrentCursor(int sourceAct, int targetAct, int status) 如果默认拖动光标行为处于活动状态，则此方法将为默认拖动光标设置受拖动源、放置目标动作和状态支持的指定动作，否则此方法不执行任何操作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT

protected static final int DEFAULT
updateCurrentCursor() 使用的 int 值，指示应该将 Cursor 改为默认（未放置）的 Cursor。

另请参见：
常量字段值

ENTER

protected static final int ENTER
updateCurrentCursor() 使用的 int 值，指示 Cursor 已进入 DropTarget。

另请参见：
常量字段值

OVER

protected static final int OVER
updateCurrentCursor() 使用的 int 值，指示 Cursor 处于 DropTarget 上。

另请参见：
常量字段值

CHANGED

protected static final int CHANGED
updateCurrentCursor() 使用的 int 值，指示用户操作已改变。

另请参见：
常量字段值
构造方法详细信息

DragSourceContext

public DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp,
                         DragGestureEvent trigger,
                         Cursor dragCursor,
                         Image dragImage,
                         Point offset,
                         Transferable t,
                         DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。
如果 DragSourceContextPeer 为 null，则抛出 NullPointerException。
如果 DragGestureEvent 为 null，则抛出 NullPointerException。
如果 Cursor 为 null，不抛出任何异常，并为此次拖动操作激活默认的拖动光标行为。
如果 Image 为 null，不抛出任何异常。
如果 Image 不为 null 且 offset 为 null，则抛出 NullPointerException。
如果 Transferable 为 null，则抛出 NullPointerException。
如果 DragSourceListener 为 null，不抛出任何异常。

参数：
dscp - 此 Drag 的 DragSourceContextPeer
trigger - 触发事件
dragCursor - 初始的 Cursor
dragImage - 要拖动的 Image（或者为 null）
offset - 图像原点与触发事件时距离热点的偏移量
t - Transferable
dsl - DragSourceListener
抛出：
IllegalArgumentException - 如果与触发事件关联的 Component 为 null
IllegalArgumentException - 如果触发事件的 DragSource 为 null
IllegalArgumentException - 如果该触发事件的拖动动作为 DnDConstants.ACTION_NONE
IllegalArgumentException - 如果与触发事件关联的 DragGestureRecognizer 的源动作等于 DnDConstants.ACTION_NONE
NullPointerException - 如果 dscp、trigger 或 t 为 null，或者 dragImage 为非 null 且 offset 为 null
方法详细信息

getDragSource

public DragSource getDragSource()
返回实例化此 DragSourceContext 的 DragSource。

返回：
实例化此 DragSourceContext 的 DragSource

getComponent

public Component getComponent()
返回与此 DragSourceContext 关联的 Component。

返回：
启动拖动的 Component

getTrigger

public DragGestureEvent getTrigger()
返回最初触发该拖动的 DragGestureEvent。

返回：
触发拖动的 Event

getSourceActions

public int getSourceActions()
返回 DnDConstants 的位掩码，表示拖动源针对与此 DragSourceContext 关联的拖动操作所支持的放置动作集合。

返回：
拖动源支持的放置动作

setCursor

public void setCursor(Cursor c)
将此拖动操作的光标设置为指定的 Cursor。 如果指定的 Cursor 为 null，则为此拖动操作激活默认的拖动光标行为，否则停用该默认行为。

参数：
c - 要显示的 Cursor，或者为 null，表示激活默认拖动光标行为

getCursor

public Cursor getCursor()
返回当前的拖动 Cursor

返回：
当前的拖动 Cursor。

addDragSourceListener

public void addDragSourceListener(DragSourceListener dsl)
                           throws TooManyListenersException
如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。如果 DragSourceListener 已存在，则此方法抛出 TooManyListenersException。

参数：
dsl - 要添加的 DragSourceListener。注意，虽然不禁止 null，但它作为参数是不可接受的值。

抛出：
TooManyListenersException - 如果已添加 DragSourceListener
TooManyListenersException

removeDragSourceListener

public void removeDragSourceListener(DragSourceListener dsl)
从此 DragSourceContext 移除指定的 DragSourceListener。

参数：
dsl - 要移除的 DragSourceListener；注意，虽然不禁止 null，但它作为参数是不可接受的值。

transferablesFlavorsChanged

public void transferablesFlavorsChanged()
通知同位体该 Transferable 的 DataFlavor 已改变。

dragEnter

public void dragEnter(DragSourceDragEvent dsde)
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragEnter，并将指定的 DragSourceDragEvent 传递给它们。

指定者：
接口 DragSourceListener 中的 dragEnter
参数：
dsde - DragSourceDragEvent

dragOver

public void dragOver(DragSourceDragEvent dsde)
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceContext 调用 dragOver，并将指定的 DragSourceDragEvent 传递给它们。

指定者：
接口 DragSourceListener 中的 dragOver
参数：
dsde - DragSourceDragEvent

dragExit

public void dragExit(DragSourceEvent dse)
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragExit，并将指定的 DragSourceEvent 传递给它们。

指定者：
接口 DragSourceListener 中的 dragExit
参数：
dse - DragSourceEvent

dropActionChanged

public void dropActionChanged(DragSourceDragEvent dsde)
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dropActionChanged，并将指定的 DragSourceDragEvent 传递给它们。

指定者：
接口 DragSourceListener 中的 dropActionChanged
参数：
dsde - DragSourceDragEvent

dragDropEnd

public void dragDropEnd(DragSourceDropEvent dsde)
对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragDropEnd，并将指定的 DragSourceDropEvent 传递给它们。

指定者：
接口 DragSourceListener 中的 dragDropEnd
参数：
dsde - DragSourceDropEvent

dragMouseMoved

public void dragMouseMoved(DragSourceDragEvent dsde)
对向与此 DragSourceContext 关联的 DragSource 注册的 DragSourceMotionListener 调用 dragMouseMoved，并将指定的 DragSourceDragEvent 传递给它们。

指定者：
接口 DragSourceMotionListener 中的 dragMouseMoved
参数：
dsde - DragSourceDragEvent
从以下版本开始：
1.4

getTransferable

public Transferable getTransferable()
返回与此 DragSourceContext 关联的 Transferable。

返回：
Transferable

updateCurrentCursor

protected void updateCurrentCursor(int sourceAct,
                                   int targetAct,
                                   int status)
如果默认拖动光标行为处于活动状态，则此方法将为默认拖动光标设置受拖动源、放置目标动作和状态支持的指定动作，否则此方法不执行任何操作。

参数：
sourceAct - 受拖动源支持的动作
targetAct - 放置目标动作
status - DEFAULT、ENTER、OVER 和 CHANGED 字段之一
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSourceDragEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragSourceDragEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.dnd.DragSourceEvent
            继承者  java.awt.dnd.DragSourceDragEvent
所有已实现的接口：
Serializable
public class DragSourceDragEvent
extends DragSourceEvent

通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。

DragSourceDragEvent 报告可反映当前拖动操作状态的目标放置动作 和用户放置动作。

目标放置动作 是 DnDConstants 之一：如果拖动源支持此放置动作，则为当前放置目标所选择的放置动作；如果拖动源不支持此放置动作，则为 DnDConstants.ACTION_NONE。

用户放置动作 则取决于拖动源所支持的放置动作和用户所选择的放置动作。用户可在拖动操作期间按下修改键来选择放置动作：

   Ctrl + Shift -> ACTION_LINK
   Ctrl         -> ACTION_COPY
   Shift        -> ACTION_MOVE
如果用户选择了某个放置动作，则用户放置动作 是 DnDConstants 之一：如果拖动源支持此放置动作，则为所选择的放置动作；如果拖动源不支持此放置动作，则为 DnDConstants.ACTION_NONE。

如果用户未选择某个放置动作，则在 DnDConstants 集合（表示拖动源支持的放置动作集合）中搜索 DnDConstants.ACTION_MOVE，然后是 DnDConstants.ACTION_COPY，最后是 DnDConstants.ACTION_LINK，找到的第一个常量就是用户放置动作。 如果未找到常量，则用户放置动作 为 DnDConstants.ACTION_NONE。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
DragSourceDragEvent(DragSourceContext dsc, int dropAction, int action, int modifiers)
构造一个 DragSourceDragEvent。
DragSourceDragEvent(DragSourceContext dsc, int dropAction, int action, int modifiers, int x, int y)
构造一个具有指定 DragSourceContext、用户放置动作、目标放置动作、修改键和坐标的 DragSourceDragEvent。
方法摘要
int | getDropAction() 此方法返回目标放置动作与拖动源支持的放置动作集合的逻辑交集。
int | getGestureModifiers() 此方法返回一个 int 值，表示与用户动作关联的输入设备修饰符的当前状态。
int | getGestureModifiersEx() 此方法返回一个 int 值，表示与用户动作关联的输入设备扩展修饰符的当前状态。
int | getTargetActions() 此方法返回目标放置动作。
int | getUserAction() 此方法返回用户放置动作。
从类 java.awt.dnd.DragSourceEvent 继承的方法
getDragSourceContext, getLocation, getX, getY
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DragSourceDragEvent

public DragSourceDragEvent(DragSourceContext dsc,
                           int dropAction,
                           int action,
                           int modifiers)
构造一个 DragSourceDragEvent。 此类通常由 DragSourceContextPeer 实例化，而不是直接由客户机代码实例化。未指定此 DragSourceDragEvent 的坐标，所以 getLocation 将对此事件返回 null。

参数 dropAction 和 action 应该是表示单个动作的 DnDConstants 之一。参数 modifiers 应该是旧 java.awt.event.InputEvent.*_MASK 常量的位掩码，或者是扩展 java.awt.event.InputEvent.*_DOWN_MASK 常量的位掩码。此构造方法对无效的 dropAction、action 和 modifiers 不抛出任何异常。

参数：
dsc - 用来管理此事件通知的 DragSourceContext。
dropAction - 用户放置动作。
action - 目标放置动作。
modifiers - 事件期间按下的修改键（shift、ctrl、alt、meta）。应该使用扩展的 _DOWN_MASK 修饰符或旧的 _MASK 修饰符，但是在一个事件中不应混用两种模型。首选扩展的修饰符。
抛出：
IllegalArgumentException - 如果 dsc 为 null。
另请参见：
InputEvent, DragSourceEvent.getLocation()

DragSourceDragEvent

public DragSourceDragEvent(DragSourceContext dsc,
                           int dropAction,
                           int action,
                           int modifiers,
                           int x,
                           int y)
构造一个具有指定 DragSourceContext、用户放置动作、目标放置动作、修改键和坐标的 DragSourceDragEvent。

参数 dropAction 和 action 应该是表示单个动作的 DnDConstants 之一。参数 modifiers 应该是旧 java.awt.event.InputEvent.*_MASK 常量的位掩码，或者是扩展 java.awt.event.InputEvent.*_DOWN_MASK 常量的位掩码。此构造方法对无效的 dropAction、action 和 modifiers 不抛出任何异常。

参数：
dsc - 与此事件关联的 DragSourceContext
dropAction - 用户放置动作。
action - 目标放置动作。
modifiers - 事件期间按下的修改键（shift、ctrl、alt、meta）。应该使用扩展的 _DOWN_MASK 修饰符或旧的 _MASK 修饰符，但是在一个事件中不应混用两种模型。首选扩展的修饰符。
x - 光标位置的水平坐标
y - 光标位置的垂直坐标
抛出：
IllegalArgumentException - 如果 dsc 为 null。
从以下版本开始：
1.4
另请参见：
InputEvent
方法详细信息

getTargetActions

public int getTargetActions()
此方法返回目标放置动作。

返回：
目标放置动作。

getGestureModifiers

public int getGestureModifiers()
此方法返回一个 int 值，表示与用户动作关联的输入设备修饰符的当前状态。通常是鼠标按键或键盘修饰符。

如果传递给构造方法的 modifiers 无效，则此方法按原样返回它们。

返回：
输入设备修饰符的当前状态

getGestureModifiersEx

public int getGestureModifiersEx()
此方法返回一个 int 值，表示与用户动作关联的输入设备扩展修饰符的当前状态。请参阅 InputEvent.getModifiersEx()

如果传递给构造方法的 modifiers 无效，则此方法按原样返回它们。

返回：
输入设备扩展修饰符的当前状态
从以下版本开始：
1.4

getUserAction

public int getUserAction()
此方法返回用户放置动作。

返回：
用户放置动作。

getDropAction

public int getDropAction()
此方法返回目标放置动作与拖动源支持的放置动作集合的逻辑交集。

返回：
目标放置动作与拖动源支持的放置动作集合的逻辑交集。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSourceDropEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragSourceDropEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.dnd.DragSourceEvent
            继承者  java.awt.dnd.DragSourceDropEvent
所有已实现的接口：
Serializable
public class DragSourceDropEvent
extends DragSourceEvent

通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。它包含足够的信息，允许操作的发起方在操作完成时向最终用户提供适当的反馈。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
DragSourceDropEvent(DragSourceContext dsc)
针对没有引起放置的拖动构造一个 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext dsc, int action, boolean success)
放置构造一个具有给定 DragSourceContext、放置操作和指示放置是否成功的 boolean 值的 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext dsc, int action, boolean success, int x, int y)
针对放置构造一个具有给定 DragSourceContext、放置操作、表示放置是否成功的 boolean 值和坐标的 DragSourceDropEvent。
方法摘要
int | getDropAction() 此方法返回一个 int 值，表示放置主题目标执行的操作。
boolean | getDropSuccess() 此方法返回表示放置是否成功的 boolean 值。
从类 java.awt.dnd.DragSourceEvent 继承的方法
getDragSourceContext, getLocation, getX, getY
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DragSourceDropEvent

public DragSourceDropEvent(DragSourceContext dsc,
                           int action,
                           boolean success)
放置构造一个具有给定 DragSourceContext、放置操作和指示放置是否成功的 boolean 值的 DragSourceDropEvent。未指定此 DragSourceDropEvent 的坐标，所以 getLocation 将在此事件中返回 null。

参数 action 应该是表示单个操作的 DnDConstants 之一。对于无效的 action，此构造方法不抛出任何异常。

参数：
dsc - 与此 DragSourceDropEvent 关联的 DragSourceContext
action - 放置操作
success - 指示放置是否成功的 boolean 值
抛出：
IllegalArgumentException - 如果 dsc 为 null。
另请参见：
DragSourceEvent.getLocation()

DragSourceDropEvent

public DragSourceDropEvent(DragSourceContext dsc,
                           int action,
                           boolean success,
                           int x,
                           int y)
针对放置构造一个具有给定 DragSourceContext、放置操作、表示放置是否成功的 boolean 值和坐标的 DragSourceDropEvent。

参数 action 应该是表示单个操作的 DnDConstants 之一。对于无效的 action，此构造方法不抛出任何异常。

参数：
dsc - 与此 DragSourceDropEvent 关联的 DragSourceContext
action - 放置操作
success - 表示放置是否成功的 boolean 值
x - 光标位置的水平坐标
y - 光标位置的垂直坐标
抛出：
IllegalArgumentException - 如果 dsc 为 null。
从以下版本开始：
1.4

DragSourceDropEvent

public DragSourceDropEvent(DragSourceContext dsc)
针对没有引起放置的拖动构造一个 DragSourceDropEvent。未指定此 DragSourceDropEvent 的坐标，所以 getLocation 将为此事件返回 null。

参数：
dsc - DragSourceContext
抛出：
IllegalArgumentException - 如果 dsc 为 null。
另请参见：
DragSourceEvent.getLocation()
方法详细信息

getDropSuccess

public boolean getDropSuccess()
此方法返回表示放置是否成功的 boolean 值。

返回：
如果放置目标接受了该放置并且成功地执行了放置操作，则返回 true；如果放置目标拒绝该放置或者放置目标接受了该放置，但是无法执行放置操作，则返回 false。

getDropAction

public int getDropAction()
此方法返回一个 int 值，表示放置主题目标执行的操作。

返回：
如果放置目标接受了该放置并且拖动源支持目标放置操作，则返回放置主题目标执行的操作；否则返回 DnDConstants.ACTION_NONE。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSourceEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DragSourceEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.dnd.DragSourceEvent
所有已实现的接口：
Serializable
直接已知子类：
DragSourceDragEvent, DragSourceDropEvent
public class DragSourceEvent
extends EventObject

此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。

只要拖动进入、移动或退出放置点、放置操作改变和拖动结束时就会生成 DragSourceEvent。此事件发生时生成 DragSourceEvent 的位置指定了鼠标光标在屏幕坐标中的位置。

在没有虚拟设备的多屏幕环境中，光标位置是在初始端 GraphicsConfiguration 的坐标系中指定的。初始端 GraphicsConfiguration 是在其上识别出当前拖动操作的 Component 的 GraphicsConfiguration。如果光标的位置位于初始端 GraphicsConfiguration 的边界之外，则对报告的坐标进行截取，使其处于该 GraphicsConfiguration 边界内。

在具有虚拟设备的多屏幕环境中，该位置是在相应的虚拟坐标系中指定的。如果光标的位置位于虚拟设备的边界之外，则对报告的坐标进行截取，使其处于虚拟设备的边界内。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
DragSourceEvent(DragSourceContext dsc)
根据一个指定的 DragSourceContext 来构造一个 DragSourceEvent。
DragSourceEvent(DragSourceContext dsc, int x, int y)
根据指定的 DragSourceContext 和光标位置坐标构造一个 DragSourceEvent。
方法摘要
DragSourceContext | getDragSourceContext() 此方法返回引起事件的 DragSourceContext。
Point | getLocation() 此方法返回一个 Point，指示事件发生时光标在屏幕坐标中的位置，如果没有为此事件指定光标位置，则返回 null。
int | getX() 此方法返回事件发生时在屏幕坐标中光标位置的水平坐标，如果没有为此事件指定光标位置，则返回零。
int | getY() 此方法返回事件发生时在屏幕坐标中光标位置的垂直坐标，如果没有为此事件指定光标位置，则返回零。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DragSourceEvent

public DragSourceEvent(DragSourceContext dsc)
根据一个指定的 DragSourceContext 来构造一个 DragSourceEvent。未指定此 DragSourceEvent 的坐标，所以 getLocation 将在此事件中返回 null。

参数：
dsc - DragSourceContext
抛出：
IllegalArgumentException - 如果 dsc 为 null。
另请参见：
getLocation()

DragSourceEvent

public DragSourceEvent(DragSourceContext dsc,
                       int x,
                       int y)
根据指定的 DragSourceContext 和光标位置坐标构造一个 DragSourceEvent。

参数：
dsc - DragSourceContext
x - 光标位置的水平坐标
y - 光标位置的垂直坐标
抛出：
IllegalArgumentException - 如果 dsc 为 null。
从以下版本开始：
1.4
方法详细信息

getDragSourceContext

public DragSourceContext getDragSourceContext()
此方法返回引起事件的 DragSourceContext。

返回：
引起事件的 DragSourceContext

getLocation

public Point getLocation()
此方法返回一个 Point，指示事件发生时光标在屏幕坐标中的位置，如果没有为此事件指定光标位置，则返回 null。

返回：
指示光标位置的 Point，如果没有指定光标位置，则返回 null
从以下版本开始：
1.4

getX

public int getX()
此方法返回事件发生时在屏幕坐标中光标位置的水平坐标，如果没有为此事件指定光标位置，则返回零。

返回：
一个指示光标位置水平坐标的整数值，如果没有指定光标位置，则返回零
从以下版本开始：
1.4

getY

public int getY()
此方法返回事件发生时在屏幕坐标中光标位置的垂直坐标，如果没有为此事件指定光标位置，则返回零。

返回：
一个指示光标位置垂直坐标的整数值，如果没有指定光标位置，则返回零
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSourceListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
接口 DragSourceListener

所有超级接口：
EventListener
所有已知实现类：
DragSourceAdapter, DragSourceContext
public interface DragSourceListener
extends EventListener

DragSourceListener 定义了事件接口，Drag 和 Drop 操作的始发端使用它来跟踪用户操作的状态，并通过 Drag 和 Drop 操作为用户提供合适的“拖动结束”反馈。

放置点是与上一次 dragEnter() 调用相关联 的，前提是在此侦听器上最后一次调用 dragEnter() 满足以下条件：

  • 对应于该放置点，并且
  • 随后没有在此侦听器上调用 dragExit()。

从以下版本开始：
1.2

方法摘要
void | dragDropEnd(DragSourceDropEvent dsde) 调用此方法来通知 Drag 和 Drop 操作已完成。
void | dragEnter(DragSourceDragEvent dsde) 光标的热点进入放置点（与平台相关）时调用该方法。
void | dragExit(DragSourceEvent dse) 光标的热点离开放置点（与平台相关）时调用该方法。
void | dragOver(DragSourceDragEvent dsde) 光标的热点在放置点（与平台相关）上移动时调用该方法。
void | dropActionChanged(DragSourceDragEvent dsde) 当用户修改放置操作时调用该方法。

方法详细信息

dragEnter

void dragEnter(DragSourceDragEvent dsde)
光标的热点进入放置点（与平台相关）时调用该方法。满足以下所有条件时调用此方法：
  • 光标的热点进入与平台相关的放置点的可操作部分。
  • 放置点处于激活状态。
  • 放置点接受该拖动。

参数：
dsde - DragSourceDragEvent

dragOver

void dragOver(DragSourceDragEvent dsde)
光标的热点在放置点（与平台相关）上移动时调用该方法。满足以下所有条件时调用此方法：
  • 光标的热点已移动，但是仍旧处于和上一次调用 dragEnter() 相关联的放置点可操作部分内。
  • 放置点仍处于激活状态。
  • 放置点接受该拖动。

参数：
dsde - DragSourceDragEvent

dropActionChanged

void dropActionChanged(DragSourceDragEvent dsde)
当用户修改放置操作时调用该方法。当用户使用的输入设备状态改变时调用此方法。这种设备通常是与用户交互的鼠标按键或键盘修改键。

参数：
dsde - DragSourceDragEvent

dragExit

void dragExit(DragSourceEvent dse)
光标的热点离开放置点（与平台相关）时调用该方法。满足以下任一条件时调用此方法：
  • 光标的热点不再处于和上一次调用 dragEnter() 相关联的放置点可操作部分内。
或者
  • 与上一次调用 dragEnter() 相关联的放置点不再处于激活状态。
或者
  • 与上一次调用 dragEnter() 相关联的放置点拒绝该拖动。

参数：
dse - DragSourceEvent

dragDropEnd

void dragDropEnd(DragSourceDropEvent dsde)
调用此方法来通知 Drag 和 Drop 操作已完成。可以使用 DragSourceDropEvent 的 getDropSuccess() 方法来确定终止状态。放置点所选择的操作由 getDropAction() 方法返回，并应用到 Drop 操作中。一旦此方法完成，则当前的 DragSourceContext 和关联的资源就变为无效。

参数：
dsde - DragSourceDropEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DragSourceMotionListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
接口 DragSourceMotionListener

所有超级接口：
EventListener
所有已知实现类：
DragSourceAdapter, DragSourceContext
public interface DragSourceMotionListener
extends EventListener

用于接收拖动操作期间鼠标移动事件的侦听器接口。

在拖动操作期间处理鼠标移动事件的类要么实现此接口，要么扩展抽象 DragSourceAdapter 类（仅重写有用的方法）。

使用该类创建一个侦听器对象，然后向某个 DragSource 注册该对象。只要在使用此 DragSource 发起的拖动操作期间出现了鼠标移动，就调用该对象的 dragMouseMoved 方法并将 DragSourceDragEvent 传递给它。

从以下版本开始：
1.4
另请参见：
DragSourceDragEvent, DragSource, DragSourceListener, DragSourceAdapter

方法摘要
 void dragMouseMoved(DragSourceDragEvent dsde)
只要在拖动操作期间鼠标移动了，就调用该方法。

方法详细信息

dragMouseMoved

void dragMouseMoved(DragSourceDragEvent dsde)
只要在拖动操作期间鼠标移动了，就调用该方法。

参数：
dsde - DragSourceDragEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTarget (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTarget

java.lang.Object
    继承者  java.awt.dnd.DropTarget
所有已实现的接口：
DropTargetListener, Serializable, EventListener
public class DropTarget
extends Object
implements DropTargetListener, Serializable

在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。

每个 DropTarget 都与一个 FlavorMap 关联。这之后默认的 FlavorMap 指定 SystemFlavorMap.getDefaultFlavorMap() 所返回的 FlavorMap。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
protected static class DropTarget.DropTargetAutoScroller
此受保护的嵌套类实现自动滚动
构造方法摘要
DropTarget()
创建一个 DropTarget
DropTarget(Component c, DropTargetListener dtl)
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。
方法摘要
void | addDropTargetListener(DropTargetListener dtl) 添加一个新的 DropTargetListener (UNICAST SOURCE)。
void | addNotify(java.awt.peer.ComponentPeer peer) 通知 DropTarget 它已经与某个 Component 关联。
protected void | clearAutoscroll() 清除自动滚动
protected DropTarget.DropTargetAutoScroller | createDropTargetAutoScroller(Component c, Point p) 创建一个嵌入式自动滚动条
protected DropTargetContext | createDropTargetContext() 创建与此 DropTarget 关联的 DropTargetContext。
void | dragEnter(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dragEnter，并将其传递给指定的 DropTargetDragEvent。
void | dragExit(DropTargetEvent dte) 在已注册的 DropTargetListener 上调用 dragExit，并将其传递给指定的 DropTargetEvent。
void | dragOver(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dragOver，并将其传递给指定的 DropTargetDragEvent。
void | drop(DropTargetDropEvent dtde) 如果此 DropTarget 处于激活状态，则在已注册的 DropTargetListener 上调用 drop，并将其传递给指定的 DropTargetDropEvent。
void | dropActionChanged(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dropActionChanged，并将其传递给指定的 DropTargetDragEvent。
Component | getComponent() 获取与此 DropTarget 关联的 Component。
int | getDefaultActions() 获取表示受此 DropTarget 支持的当前操作的 int 值。
DropTargetContext | getDropTargetContext() 获取与此 DropTarget 关联的 DropTargetContext。
FlavorMap | getFlavorMap() 获取与此 DropTarget 关联的 FlavorMap。
protected void | initializeAutoscrolling(Point p) 初始化自动滚动
boolean | isActive() 报告此 DropTarget 当前是否为激活状态（准备接受 drop）。
void | removeDropTargetListener(DropTargetListener dtl) 移除当前的 DropTargetListener (UNICAST SOURCE)。
void | removeNotify(java.awt.peer.ComponentPeer peer) 通知 DropTarget 它已经与某个 Component 解除关联。
void | setActive(boolean isActive) 如果为 true，则将 DropTarget 设置为激活状态；如果为 false，则将 DropTarget 设置为非激活状态。
void | setComponent(Component c) 注意：要求此接口允许 DropTarget 以下面两种方式之一与 Component 安全关联：component.setDropTarget(droptarget) 或 droptarget.setComponent(component)。
void | setDefaultActions(int ops) 为此 DropTarget 设置默认的可接受操作。
void | setFlavorMap(FlavorMap fm) 设置 FlavorMap 与此 DropTarget 关联。
protected void | updateAutoscroll(Point dragCursorLocn) 使用当前的光标位置更新自动滚动
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DropTarget

public DropTarget(Component c,
                  int ops,
                  DropTargetListener dtl,
                  boolean act,
                  FlavorMap fm)
           throws HeadlessException
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。

仅在已启用时 Component 才会接收 drop。

参数：
c - 与此 DropTarget 有关联的 Component
ops - 此 DropTarget 的默认可接受操作
dtl - 此 DropTarget 的 DropTargetListener
act - DropTarget 是否接收 drop。
fm - 要使用的 FlavorMap，使用默认 FlavorMap 时为 null
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

DropTarget

public DropTarget(Component c,
                  int ops,
                  DropTargetListener dtl,
                  boolean act)
           throws HeadlessException
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。

仅在已启用时 Component 才会接收 drop。

参数：
c - 与此 DropTarget 有关联的 Component
ops - 此 DropTarget 的默认可接受操作
dtl - 此 DropTarget 的 DropTargetListener
act - DropTarget 是否接收 drop。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

DropTarget

public DropTarget()
           throws HeadlessException
创建一个 DropTarget

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

DropTarget

public DropTarget(Component c,
                  DropTargetListener dtl)
           throws HeadlessException
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。

仅在已启用时 Component 才会接收 drop。

参数：
c - 与此 DropTarget 有关联的 Component
dtl - 此 DropTarget 的 DropTargetListener
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

DropTarget

public DropTarget(Component c,
                  int ops,
                  DropTargetListener dtl)
           throws HeadlessException
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。

仅在已启用时 Component 才会接收 drop。

参数：
c - 与此 DropTarget 有关联的 Component
ops - 此 DropTarget 的默认可接受操作
dtl - 此 DropTarget 的 DropTargetListener
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true
另请参见：
GraphicsEnvironment.isHeadless()
方法详细信息

setComponent

public void setComponent(Component c)
注意：要求此接口允许 DropTarget 以下面两种方式之一与 Component 安全关联：component.setDropTarget(droptarget) 或 droptarget.setComponent(component)。

仅在已启用时 Component 才会接收 drop。

参数：
c - 此 DropTarget 要关联的新 Component。

getComponent

public Component getComponent()
获取与此 DropTarget 关联的 Component。

返回：
当前的 Component

setDefaultActions

public void setDefaultActions(int ops)
为此 DropTarget 设置默认的可接受操作。

参数：
ops - 默认操作

另请参见：
DnDConstants

getDefaultActions

public int getDefaultActions()
获取表示受此 DropTarget 支持的当前操作的 int 值。

返回：
当前的默认操作

setActive

public void setActive(boolean isActive)
如果为 true，则将 DropTarget 设置为激活状态；如果为 false，则将 DropTarget 设置为非激活状态。

参数：
isActive - 将 DropTarget 设置为（非）激活状态。

isActive

public boolean isActive()
报告此 DropTarget 当前是否为激活状态（准备接受 drop）。

返回：
如果为激活状态，则返回 true；否则返回 false

addDropTargetListener

public void addDropTargetListener(DropTargetListener dtl)
                           throws TooManyListenersException
添加一个新的 DropTargetListener (UNICAST SOURCE)。

参数：
dtl - 新的 DropTargetListener

抛出：
TooManyListenersException - 如果已向此 DropTarget 添加 DropTargetListener。
TooManyListenersException

removeDropTargetListener

public void removeDropTargetListener(DropTargetListener dtl)
移除当前的 DropTargetListener (UNICAST SOURCE)。

参数：
dtl - 要取消注册的 DropTargetListener。

dragEnter

public void dragEnter(DropTargetDragEvent dtde)
在已注册的 DropTargetListener 上调用 dragEnter，并将其传递给指定的 DropTargetDragEvent。 如果此 DropTarget 是非激活状态，则此调用无效。

指定者：
接口 DropTargetListener 中的 dragEnter
参数：
dtde - DropTargetDragEvent
抛出：
NullPointerException - 如果此 DropTarget 处于激活状态并且 dtde 为 null
另请参见：
isActive()

dragOver

public void dragOver(DropTargetDragEvent dtde)
在已注册的 DropTargetListener 上调用 dragOver，并将其传递给指定的 DropTargetDragEvent。 如果此 DropTarget 是非激活状态，则该调用无效。

指定者：
接口 DropTargetListener 中的 dragOver
参数：
dtde - DropTargetDragEvent
抛出：
NullPointerException - 如果此 DropTarget 处于激活状态并且 dtde 为 null
另请参见：
isActive()

dropActionChanged

public void dropActionChanged(DropTargetDragEvent dtde)
在已注册的 DropTargetListener 上调用 dropActionChanged，并将其传递给指定的 DropTargetDragEvent。 如果此 DropTarget 是非激活状态，则此调用无效。

指定者：
接口 DropTargetListener 中的 dropActionChanged
参数：
dtde - DropTargetDragEvent
抛出：
NullPointerException - 如果此 DropTarget 处于激活状态并且 dtde 为 null
另请参见：
isActive()

dragExit

public void dragExit(DropTargetEvent dte)
在已注册的 DropTargetListener 上调用 dragExit，并将其传递给指定的 DropTargetEvent。 如果此 DropTarget 是非激活状态，则此调用无效。

对于 null 参数，此方法本身并不抛出任何异常，而是由相应的侦听器方法抛出异常。

指定者：
接口 DropTargetListener 中的 dragExit
参数：
dte - DropTargetEvent
另请参见：
isActive()

drop

public void drop(DropTargetDropEvent dtde)
如果此 DropTarget 处于激活状态，则在已注册的 DropTargetListener 上调用 drop，并将其传递给指定的 DropTargetDropEvent。

指定者：
接口 DropTargetListener 中的 drop
参数：
dtde - DropTargetDropEvent
抛出：
NullPointerException - 如果 dtde 为 null 并且以下条件中至少有一个为真：此 DropTarget 不处于激活状态，或者没有已注册的 DropTargetListener。
另请参见：
isActive()

getFlavorMap

public FlavorMap getFlavorMap()
获取与此 DropTarget 关联的 FlavorMap。 如果没有为此 DropTarget 设置 FlavorMap，则它与默认的 FlavorMap 关联。

返回：
此 DropTarget 的 FlavorMap

setFlavorMap

public void setFlavorMap(FlavorMap fm)
设置 FlavorMap 与此 DropTarget 关联。

参数：
fm - 新的 FlavorMap，如果将默认的 FlavorMap 与此 DropTarget 关联，则为 null。

addNotify

public void addNotify(java.awt.peer.ComponentPeer peer)
通知 DropTarget 它已经与某个 Component 关联。通常从与此 DropTarget 相关联 Component 的 java.awt.Component.addNotify() 调用此方法，以通知 DropTarget 一个 ComponentPeer 已经与该 Component 关联。调用此方法，而不是将 ComponentPeer 与 Component 的关联通知给此 DropTarget，这可能导致 DnD 系统故障。

参数：
peer - 与该 Component 关联的同位体

removeNotify

public void removeNotify(java.awt.peer.ComponentPeer peer)
通知 DropTarget 它已经与某个 Component 解除关联。通常从与此 DropTarget 相关联 Component 的 java.awt.Component.removeNotify() 调用此方法，以通知 DropTarget 一个 ComponentPeer 已经与该 Component 解除关联。调用此方法，而不是将 ComponentPeer 与 Component 的解除关联通知给此 DropTarget，这可能导致 DnD 系统故障。

参数：
peer - 与该 Component 解除关联的同位体

getDropTargetContext

public DropTargetContext getDropTargetContext()
获取与此 DropTarget 关联的 DropTargetContext。

返回：
与此 DropTarget 关联的 DropTargetContext。

createDropTargetContext

protected DropTargetContext createDropTargetContext()
创建与此 DropTarget 关联的 DropTargetContext。子类可能重写此方法，以实例化它们自己的 DropTargetContext 子类。 通常只在拖动操作遇到此 DropTarget 时才由平台的 DropTargetContextPeer 调用此方法。在当前没有 Drag 时访问 Context 的结果是不明确的。

createDropTargetAutoScroller

protected DropTarget.DropTargetAutoScroller createDropTargetAutoScroller(Component c,
                                                                         Point p)
创建一个嵌入式自动滚动条

参数：
c - Component
p - Point

initializeAutoscrolling

protected void initializeAutoscrolling(Point p)
初始化自动滚动

参数：
p - Point

updateAutoscroll

protected void updateAutoscroll(Point dragCursorLocn)
使用当前的光标位置更新自动滚动

参数：
dragCursorLocn - Point

clearAutoscroll

protected void clearAutoscroll()
清除自动滚动

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTargetAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTargetAdapter

java.lang.Object
    继承者  java.awt.dnd.DropTargetAdapter
所有已实现的接口：
DropTargetListener, EventListener
public abstract class DropTargetAdapter
extends Object
implements DropTargetListener

接收放置目标事件的抽象适配器类。此类中的方法为空。此类存在的目的只是为了便于创建侦听器对象。

扩展此类即可创建 DropTargetEvent 侦听器并为感兴趣的事件重写该方法。（如果实现了 DropTargetListener 接口，则必须定义该接口内的所有方法。此抽象类为除 drop(DropTargetDropEvent) 以外的所有方法都定义了 null 实现，所以只需为关心的事件定义方法即可。）用户必须至少为 drop(DropTargetDropEvent) 提供一个实现。因为此方法的规范要求接受或拒绝放置，并且如果接受的话，要指出放置是否成功，所以此方法不能是 null 实现。

使用扩展的类创建侦听器对象，然后向 DropTarget 注册它。当拖动进入、移动或离开该 DropTarget 放置点的可操作部分时，以及放置操作改变时和放置发生时，调用该侦听器对象中的相关方法，并将 DropTargetEvent 传递给它。

DropTarget 放置点的可操作部分是关联 Component 的几何形状的一部分，该部分未被顶层窗口或另一个与活动 DropTarget 关联并且在 Z-order（排顺）中更高的 Component 所覆盖。

在拖动期间，可检索与当前拖动操作相关联的数据，方法是调用传递给侦听器方法的 DropTargetDragEvent 实例上的 getTransferable()。

注意，应该只在各自侦听器方法内调用 DropTargetDragEvent 实例上的 getTransferable()，并且应该在该方法返回前从返回的 Transferable 检索所有所需的数据。

从以下版本开始：
1.4
另请参见：
DropTargetEvent, DropTargetListener

构造方法摘要
DropTargetAdapter()
方法摘要
void | dragEnter(DropTargetDragEvent dtde) 当鼠标指针进入向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行的同时调用该方法。
void | dragExit(DropTargetEvent dte) 当鼠标指针已经离开向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行时调用该方法。
void | dragOver(DropTargetDragEvent dtde) 当鼠标指针仍旧处于向此侦听器注册的 DropTarget 放置点可操作部分上时，则在拖动操作正在进行时调用该方法。
void | dropActionChanged(DropTargetDragEvent dtde) 如果用户已经修改了当前的放置操作，则调用该方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.dnd.DropTargetListener 继承的方法
drop

构造方法详细信息

DropTargetAdapter

public DropTargetAdapter()
方法详细信息

dragEnter

public void dragEnter(DropTargetDragEvent dtde)
当鼠标指针进入向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行的同时调用该方法。

指定者：
接口 DropTargetListener 中的 dragEnter
参数：
dtde - DropTargetDragEvent

dragOver

public void dragOver(DropTargetDragEvent dtde)
当鼠标指针仍旧处于向此侦听器注册的 DropTarget 放置点可操作部分上时，则在拖动操作正在进行时调用该方法。

指定者：
接口 DropTargetListener 中的 dragOver
参数：
dtde - DropTargetDragEvent

dropActionChanged

public void dropActionChanged(DropTargetDragEvent dtde)
如果用户已经修改了当前的放置操作，则调用该方法。

指定者：
接口 DropTargetListener 中的 dropActionChanged
参数：
dtde - DropTargetDragEvent

dragExit

public void dragExit(DropTargetEvent dte)
当鼠标指针已经离开向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行时调用该方法。

指定者：
接口 DropTargetListener 中的 dragExit
参数：
dte - DropTargetEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTarget.DropTargetAutoScroller (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTarget.DropTargetAutoScroller

java.lang.Object
    继承者  java.awt.dnd.DropTarget.DropTargetAutoScroller
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
DropTarget
protected static class DropTarget.DropTargetAutoScroller
extends Object
implements ActionListener

此受保护的嵌套类实现自动滚动

构造方法摘要
protected DropTarget.DropTargetAutoScroller(Component c, Point p)
构造一个 DropTargetAutoScroller
方法摘要
void | actionPerformed(ActionEvent e) 导致发生自动滚动
protected void | stop() 导致停止自动滚动
protected void | updateLocation(Point newLocn) 导致发生自动滚动
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DropTarget.DropTargetAutoScroller

protected DropTarget.DropTargetAutoScroller(Component c,
                                            Point p)
构造一个 DropTargetAutoScroller

参数：
c - Component
p - Point
方法详细信息

updateLocation

protected void updateLocation(Point newLocn)
导致发生自动滚动

参数：
newLocn - Point

stop

protected void stop()
导致停止自动滚动

actionPerformed

public void actionPerformed(ActionEvent e)
导致发生自动滚动

指定者：
接口 ActionListener 中的 actionPerformed
参数：
e - ActionEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTargetContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTargetContext

java.lang.Object
    继承者  java.awt.dnd.DropTargetContext
所有已实现的接口：
Serializable
public class DropTargetContext
extends Object
implements Serializable

每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。DropTargetContext 为放置操作的潜在接收者提供一种机制，该机制既为终端用户提供适当的拖动反馈，也影响适当的后续数据传输。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
protected  class DropTargetContext.TransferableProxy
TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。
方法摘要
protected void | acceptDrag(int dragOperation) 接受该 Drag。
protected void | acceptDrop(int dropOperation) 调用以指示放置操作是可接受的（使用指定的操作）。
void | addNotify(java.awt.dnd.peer.DropTargetContextPeer dtcp) 与 DropTargetContextPeer 关联时调用。
protected Transferable | createTransferableProxy(Transferable t, boolean local) 创建一个代理指定 Transferable 的 TransferableProxy。
void | dropComplete(boolean success) 此方法指示放置操作完成以及成功与否。
Component | getComponent() 此方法返回与此 DropTargetContext 相关的 Component。
protected DataFlavor[] | getCurrentDataFlavors() 获取此操作的 Transferable 操作数的可用 DataFlavor。
protected List<DataFlavor> | getCurrentDataFlavorsAsList() 此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。
DropTarget | getDropTarget() 此方法返回与此 DropTargetContext 相关的 DropTarget。
protected int | getTargetActions() 此方法返回一个 int，表示此 DropTarget 将接受的当前操作。
protected Transferable | getTransferable() 获取此操作的 Transferable（代理）操作数
protected boolean | isDataFlavorSupported(DataFlavor df) 此方法返回一个 boolean 值，指示给定的 DataFlavor 是否受此 DropTargetContext 支持。
protected void | rejectDrag() 拒绝该 Drag。
protected void | rejectDrop() 调用以指示放置操作是不可接受的。
void | removeNotify() 取消与 DropTargetContextPeer 的关联时调用。
protected void | setTargetActions(int actions) 此方法设置此 DropTarget 可接受的当前操作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getDropTarget

public DropTarget getDropTarget()
此方法返回与此 DropTargetContext 相关的 DropTarget。

返回：
与此 DropTargetContext 相关的 DropTarget

getComponent

public Component getComponent()
此方法返回与此 DropTargetContext 相关的 Component。

返回：
与此 Context 相关的 Component

addNotify

public void addNotify(java.awt.dnd.peer.DropTargetContextPeer dtcp)
与 DropTargetContextPeer 关联时调用。

参数：
dtcp - DropTargetContextPeer

removeNotify

public void removeNotify()
取消与 DropTargetContextPeer 的关联时调用。

setTargetActions

protected void setTargetActions(int actions)
此方法设置此 DropTarget 可接受的当前操作。

参数：
actions - 一个 int，表示受支持的操作

getTargetActions

protected int getTargetActions()
此方法返回一个 int，表示此 DropTarget 将接受的当前操作。

返回：
此 DropTarget 可接受的当前操作

dropComplete

public void dropComplete(boolean success)
                  throws InvalidDnDOperationException
此方法指示放置操作完成以及成功与否。

参数：
success - 如果成功，则为 true；否则为 false

抛出：
InvalidDnDOperationException - 如果放置操作未完成/成功

acceptDrag

protected void acceptDrag(int dragOperation)
接受该 Drag。

参数：
dragOperation - 受支持的操作

rejectDrag

protected void rejectDrag()
拒绝该 Drag。

acceptDrop

protected void acceptDrop(int dropOperation)
调用以指示放置操作是可接受的（使用指定的操作）。在 DropTargetListener.drop 方法调用期间必须被调用。

参数：
dropOperation - 受支持的操作

rejectDrop

protected void rejectDrop()
调用以指示放置操作是不可接受的。在 DropTargetListener.drop 方法调用期间必须被调用。

getCurrentDataFlavors

protected DataFlavor[] getCurrentDataFlavors()
获取此操作的 Transferable 操作数的可用 DataFlavor。

返回：
一个 DataFlavor[]，它包含受支持的 Transferable 操作数的 DataFlavor。

getCurrentDataFlavorsAsList

protected List<DataFlavor> getCurrentDataFlavorsAsList()
此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。

返回：
当前可用的 DataFlavor，作为一个 java.util.List

isDataFlavorSupported

protected boolean isDataFlavorSupported(DataFlavor df)
此方法返回一个 boolean 值，指示给定的 DataFlavor 是否受此 DropTargetContext 支持。

参数：
df - DataFlavor

返回：
指定的 DataFlavor 是否受支持

getTransferable

protected Transferable getTransferable()
                                throws InvalidDnDOperationException
获取此操作的 Transferable（代理）操作数

返回：
Transferable
抛出：
InvalidDnDOperationException - 如果放置操作未完成/成功

createTransferableProxy

protected Transferable createTransferableProxy(Transferable t,
                                               boolean local)
创建一个代理指定 Transferable 的 TransferableProxy。

参数：
t - 要被代理的 Transferable
local - 如果 t 表示本地 drag-n-drop 操作的结果，则为 true。
返回：
新的 TransferableProxy 实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTargetContext.TransferableProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTargetContext.TransferableProxy

java.lang.Object
    继承者  java.awt.dnd.DropTargetContext.TransferableProxy
所有已实现的接口：
Transferable
正在封闭类：
DropTargetContext
protected class DropTargetContext.TransferableProxy
extends Object
implements Transferable

TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。

该代理将所有请求转发给封装的 transferable，并在本地转换时自动对由封装的 transferable 返回的数据执行其他转换。

字段摘要
protected boolean | isLocal 一个 boolean 值，指示所封装的 Transferable 对象是否表示执行本地 drag-n-drop 操作的结果（在同一个 JVM 中）。
protected Transferable | transferable 封装的 Transferable 对象。
方法摘要
Object | getTransferData(DataFlavor df) 返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。
DataFlavor[] | getTransferDataFlavors() 返回一个 DataFlavor 对象数组，指示该数据的 flavor 是否可由封装的 transferable 提供。
boolean | isDataFlavorSupported(DataFlavor flavor) 返回指定的数据 flavor 是否受封装的 transferable 支持。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

transferable

protected Transferable transferable
封装的 Transferable 对象。

isLocal

protected boolean isLocal
一个 boolean 值，指示所封装的 Transferable 对象是否表示执行本地 drag-n-drop 操作的结果（在同一个 JVM 中）。

方法详细信息

getTransferDataFlavors

public DataFlavor[] getTransferDataFlavors()
返回一个 DataFlavor 对象数组，指示该数据的 flavor 是否可由封装的 transferable 提供。

指定者：
接口 Transferable 中的 getTransferDataFlavors
返回：
数据 flavor 的数组，在这个数组中数据是由封装的 transferable 提供的

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor flavor)
返回指定的数据 flavor 是否受封装的 transferable 支持。

指定者：
接口 Transferable 中的 isDataFlavorSupported
参数：
flavor - 数据所请求的 flavor
返回：
如果该数据 flavor 受支持，则返回 true；否则返回 false

getTransferData

public Object getTransferData(DataFlavor df)
                       throws UnsupportedFlavorException,
                              IOException
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。

进行本地转换时，如果在应用程序或 x-java-serialized-object 数据 flavor 中请求数据，则提供由封装的 transferable 返回的对象的序列化副本。

指定者：
接口 Transferable 中的 getTransferData
参数：
df - 请求的数据 flavor
抛出：
IOException - 如果该数据对请求的 flavor 不再可用。
UnsupportedFlavorException - 如果不支持请求的数据 flavor。
另请参见：
DataFlavor.getRepresentationClass()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTargetDragEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTargetDragEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.dnd.DropTargetEvent
            继承者  java.awt.dnd.DropTargetDragEvent
所有已实现的接口：
Serializable
public class DropTargetDragEvent
extends DropTargetEvent

通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。

DropTargetDragEvent 报告源 drop 操作 和用户 drop 操作，这些操作反映了 drag 操作的当前状态。

源 drop 操作 是 DnDConstants 的位掩码，DnDConstants 表示受此 drag 操作的 drag 源支持的 drop 操作集合。

用户 drop 操作 取决于受 drag 源支持的 drop 操作和用户选定的 drop 操作。在进行 drag 操作中，用户可以通过按下修正键选择一个 drop 操作。

   Ctrl + Shift -> ACTION_LINK
   Ctrl         -> ACTION_COPY
   Shift        -> ACTION_MOVE
当用户选择一个 drop 操作时，如果此 drop 操作受 drag 源支持，则用户 drop 操作 为 DnDConstants 之一，如果此 drop 操作不受 drag 源支持，则用户 drop 操作为 DnDConstants.ACTION_NONE。

如果用户没有选 drop 操作，则表示受 drag 源支持的 drop 操作集合的 DnDConstants 集合是先搜索 DnDConstants.ACTION_MOVE，然后搜索 DnDConstants.ACTION_COPY，最后搜索 DnDConstants.ACTION_LINK 而得到的，并且用户 drop 操作 是找到的第一个常量。如果找不到常量，则用户 drop 操作 为 DnDConstants.ACTION_NONE。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
从类 java.awt.dnd.DropTargetEvent 继承的字段
context
从类 java.util.EventObject 继承的字段
source
构造方法摘要
DropTargetDragEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。
方法摘要
void | acceptDrag(int dragOperation) 接受 drag。
DataFlavor[] | getCurrentDataFlavors() 此方法返回来自 DropTargetContext 的当前 DataFlavor。
List<DataFlavor> | getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前的 DataFlavor
int | getDropAction() 此方法返回用户 drop 操作。
Point | getLocation() 此方法返回一个指示 Component 坐标中 Cursor 当前位置的 Point。
int | getSourceActions() 此方法返回源 drop 操作。
Transferable | getTransferable() 此方法返回 Transferable 对象，该对象表示与当前的 drag 操作有关的数据。
boolean | isDataFlavorSupported(DataFlavor df) 此方法返回一个指示指定的 DataFlavor 是否受支持 boolean 值。
void | rejectDrag() 作为检查 dropAction 或可用的 DataFlavor 类型的结果，拒绝 drag。
从类 java.awt.dnd.DropTargetEvent 继承的方法
getDropTargetContext
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DropTargetDragEvent

public DropTargetDragEvent(DropTargetContext dtc,
                           Point cursorLocn,
                           int dropAction,
                           int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。

参数：
dtc - 此操作的 DropTargetContext
cursorLocn - Component 坐标中 "Drag" Cursor 热点的位置
dropAction - 用户 drop 操作
srcActions - 源 drop 操作
抛出：
NullPointerException - 如果 cursorLocn 为 null
IllegalArgumentException - 如果 dropAction 不是 DnDConstants 之一。
IllegalArgumentException - 如果 srcAction 不是 DnDConstants 的位掩码。
IllegalArgumentException - 如果 dtc 为 null。
方法详细信息

getLocation

public Point getLocation()
此方法返回一个指示 Component 坐标中 Cursor 当前位置的 Point。

返回：
Component 坐标中光标的当前位置。

getCurrentDataFlavors

public DataFlavor[] getCurrentDataFlavors()
此方法返回来自 DropTargetContext 的当前 DataFlavor。

返回：
来自 DropTargetContext 的当前 DataFlavor

getCurrentDataFlavorsAsList

public List<DataFlavor> getCurrentDataFlavorsAsList()
此方法以 java.util.List 形式返回当前的 DataFlavor

返回：
当前 DataFlavor 的 java.util.List

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor df)
此方法返回一个指示指定的 DataFlavor 是否受支持 boolean 值。

参数：
df - 要测试的 DataFlavor

返回：
特定 DataFlavor 是否受支持

getSourceActions

public int getSourceActions()
此方法返回源 drop 操作。

返回：
源 drop 操作

getDropAction

public int getDropAction()
此方法返回用户 drop 操作。

返回：
用户 drop 操作

getTransferable

public Transferable getTransferable()
此方法返回 Transferable 对象，该对象表示与当前的 drag 操作有关的数据。

返回：
与 drag 操作有关的 Transferable
抛出：
InvalidDnDOperationException - 如果与 drag 操作有关的数据不可用
从以下版本开始：
1.5

acceptDrag

public void acceptDrag(int dragOperation)
接受 drag。如果实现希望接受来自 srcAction 的操作，而不是接受用户选择的操作（表示为 dropAction），则应该从 DropTargetListener、dragEnter、dragOver 和 dropActionChanged 方法来调用此方法。

参数：
dragOperation - 目标所接受的操作

rejectDrag

public void rejectDrag()
作为检查 dropAction 或可用的 DataFlavor 类型的结果，拒绝 drag。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTargetDropEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTargetDropEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.dnd.DropTargetEvent
            继承者  java.awt.dnd.DropTargetDropEvent
所有已实现的接口：
Serializable
public class DropTargetDropEvent
extends DropTargetEvent

通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。

DropTargetDropEvent 报告源 drop 操作 和用户 drop 操作，这些操作反映了 drag-and-drop 操作的当前状态。

源 drop 操作 是 DnDConstants 的位掩码，DnDConstants 表示受 drag-and-drop 操作的 drag 源支持的 drop 操作集合。

用户 drop 操作 取决于受 drag 源支持的 drop 操作和用户选定的 drop 操作。在进行 drag 操作中，用户可以通过按下修正键选择一个 drop 操作。

   Ctrl + Shift -> ACTION_LINK
   Ctrl         -> ACTION_COPY
   Shift        -> ACTION_MOVE
当用户选择一个 drop 操作时，如果此 drop 操作受 drag 源支持，则用户 drop 操作 为表示选择的 drop 操作 DnDConstants 之一，如果此 drop 操作不受 drag 源支持，则用户 drop 操作为 DnDConstants.ACTION_NONE 之一。

如果用户没有选 drop 操作，则表示受 drag 源支持的 drop 操作集合的 DnDConstants 集合是先搜索 DnDConstants.ACTION_MOVE，然后搜索 DnDConstants.ACTION_COPY，最后搜索 DnDConstants.ACTION_LINK 而得到的，并且用户 drop 操作 是找到的第一个常量。如果找不到常量，则用户 drop 操作 为 DnDConstants.ACTION_NONE。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
从类 java.awt.dnd.DropTargetEvent 继承的字段
context
从类 java.util.EventObject 继承的字段
source
构造方法摘要
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。
方法摘要
void | acceptDrop(int dropAction) 使用指定的操作接受 drop。
void | dropComplete(boolean success) 此方法通知 DragSource drop 传输已完成。
DataFlavor[] | getCurrentDataFlavors() 此方法返回当前的 DataFlavor。
List<DataFlavor> | getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前可用的 DataFlavor。
int | getDropAction() 此方法返回用户 drop 操作。
Point | getLocation() 此方法返回一个 Point，指示 Component 坐标中 Cursor 的当前位置。
int | getSourceActions() 此方法返回源 drop 操作。
Transferable | getTransferable() 此方法返回与 drop 相关的 Transferable 对象。
boolean | isDataFlavorSupported(DataFlavor df) 此方法返回一个指示指定的 DataFlavor 是否可在源对象中使用的 boolean 值。
boolean | isLocalTransfer() 此方法返回一个指示源对象与目标对象是否在同一 JVM 中的 int。
void | rejectDrop() 拒绝 Drop。
从类 java.awt.dnd.DropTargetEvent 继承的方法
getDropTargetContext
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DropTargetDropEvent

public DropTargetDropEvent(DropTargetContext dtc,
                           Point cursorLocn,
                           int dropAction,
                           int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。默认情况下，此构造器假定目标对象与源对象不在同一虚拟机中；也就是说，isLocalTransfer() 将返回 false。

参数：
dtc - 此操作的 DropTargetContext
cursorLocn - Component 坐标中 "Drag" Cursor 的热点位置
dropAction - 用户 drop 操作。
srcActions - 源 drop 操作。
抛出：
NullPointerException - 如果 cursorLocn 为 null
IllegalArgumentException - 如果 dropAction 不是 DnDConstants 之一。
IllegalArgumentException - 如果 srcActions 不是 DnDConstants 的位掩码。
IllegalArgumentException - 如果 dtc 为 null。

DropTargetDropEvent

public DropTargetDropEvent(DropTargetContext dtc,
                           Point cursorLocn,
                           int dropAction,
                           int srcActions,
                           boolean isLocal)
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。

参数：
dtc - 此操作的 DropTargetContext
cursorLocn - Component 坐标中 "Drag" Cursor 的热点位置
dropAction - 用户 drop 操作。
srcActions - 源 drop 操作。
isLocal - 如果源对象与目标对象在同一 JVM 中，则为 true
抛出：
NullPointerException - 如果 cursorLocn 为 null
IllegalArgumentException - 如果 dropAction 不是 DnDConstants 之一。
IllegalArgumentException - 如果 srcAction 不是 DnDConstants 的位掩码。
IllegalArgumentException - 如果 dtc 为 null。
方法详细信息

getLocation

public Point getLocation()
此方法返回一个 Point，指示 Component 坐标中 Cursor 的当前位置。

返回：
Component 坐标中 Cursor 的当前位置。

getCurrentDataFlavors

public DataFlavor[] getCurrentDataFlavors()
此方法返回当前的 DataFlavor。

返回：
当前的 DataFlavor

getCurrentDataFlavorsAsList

public List<DataFlavor> getCurrentDataFlavorsAsList()
此方法以 java.util.List 形式返回当前可用的 DataFlavor。

返回：
java.util.List 形式的当前可用 DataFlavor

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor df)
此方法返回一个指示指定的 DataFlavor 是否可在源对象中使用的 boolean 值。

参数：
df - 要测试的 DataFlavor

返回：
是否指定的 DataFlavor 是否可在源对象中使用

getSourceActions

public int getSourceActions()
此方法返回源 drop 操作。

返回：
源 drop 操作。

getDropAction

public int getDropAction()
此方法返回用户 drop 操作。

返回：
用户 drop 操作。

getTransferable

public Transferable getTransferable()
此方法返回与 drop 相关的 Transferable 对象。

返回：
与 drop 相关的 Transferable

acceptDrop

public void acceptDrop(int dropAction)
使用指定的操作接受 drop。

参数：
dropAction - 指定的操作

rejectDrop

public void rejectDrop()
拒绝 Drop。

dropComplete

public void dropComplete(boolean success)
此方法通知 DragSource drop 传输已完成。

参数：
success - 指示 drop 传输已完成的 boolean 值。

isLocalTransfer

public boolean isLocalTransfer()
此方法返回一个指示源对象与目标对象是否在同一 JVM 中的 int。

返回：
Source 是否在同一 JVM 中
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTargetEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 DropTargetEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.dnd.DropTargetEvent
所有已实现的接口：
Serializable
直接已知子类：
DropTargetDragEvent, DropTargetDropEvent
public class DropTargetEvent
extends EventObject

DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。它封装了 Drag 和 Drop 操作的当前状态，特别是当前的 DropTargetContext。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
protected  DropTargetContext context
与此 DropTargetEvent 相关的 DropTargetContext。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
DropTargetEvent(DropTargetContext dtc)
构造一个具有指定 DropTargetContext 的 DropTargetEvent。
方法摘要
 DropTargetContext getDropTargetContext()
此方法返回与该 DropTargetEvent 相关的 DropTargetContext。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

context

protected DropTargetContext context
与此 DropTargetEvent 相关的 DropTargetContext。

构造方法详细信息

DropTargetEvent

public DropTargetEvent(DropTargetContext dtc)
构造一个具有指定 DropTargetContext 的 DropTargetEvent。

参数：
dtc - DropTargetContext
方法详细信息

getDropTargetContext

public DropTargetContext getDropTargetContext()
此方法返回与该 DropTargetEvent 相关的 DropTargetContext。

返回：
DropTargetContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropTargetListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
接口 DropTargetListener

所有超级接口：
EventListener
所有已知实现类：
DropTarget, DropTargetAdapter
public interface DropTargetListener
extends EventListener

DropTargetListener 接口是 DropTarget 类所使用的回调接口，用于提供所涉及的 DropTarget 的 DnD 操作的通知。在整个 Drag 和 Drop 操作中，可以实现此接口的方法，向用户提供 "drag under" 的可视化反馈。

通过实现该接口，并使用 DropTarget 注册该接口，可以创建一个 listener 对象。当 drag 进入、移上或退出该 DropTarget 的 drop 位置的可操作部分时，当 drop 操作改变时，以及当 drop 操作发生时，调用 listener 对象的相关方法，并将 DropTargetEvent 传递到该方法。

DropTarget 的 drop 位置的可操作部分是关联 Component 几何结构的一部分，该部分不会被重叠的顶层窗口或另一 Z-order（顺序）更高的并具有关联的活动 DropTarget 的 Component 遮掩。

在 drag 过程中，通过对 DropTargetDragEvent 实例（该实例被传递给 listener 的方法）调用 getTransferable()，可以检索与当前 drag 操作相关的数据。

注意，DropTargetDragEvent 实例上的 getTransferable() 应该只在各自 listener 的方法中调用，并且应该在该方法返回前从返回的 Transferable 检索所有必需的数据。

从以下版本开始：
1.2

方法摘要
void | dragEnter(DropTargetDragEvent dtde) 正在进行 drag 操作时调用，此时鼠标指针进入 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | dragExit(DropTargetEvent dte) 正在进行 drag 操作时调用，此时鼠标指针已退出 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | dragOver(DropTargetDragEvent dtde) 正在进行 drag 操作时调用，此时鼠标指针仍然处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | drop(DropTargetDropEvent dtde) 在 drag 操作已终止时调用，此时 drop 处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | dropActionChanged(DropTargetDragEvent dtde) 在用户已经修改了当前 drop 操作后调用。

方法详细信息

dragEnter

void dragEnter(DropTargetDragEvent dtde)
正在进行 drag 操作时调用，此时鼠标指针进入 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

参数：
dtde - DropTargetDragEvent

dragOver

void dragOver(DropTargetDragEvent dtde)
正在进行 drag 操作时调用，此时鼠标指针仍然处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

参数：
dtde - DropTargetDragEvent

dropActionChanged

void dropActionChanged(DropTargetDragEvent dtde)
在用户已经修改了当前 drop 操作后调用。

参数：
dtde - DropTargetDragEvent

dragExit

void dragExit(DropTargetEvent dte)
正在进行 drag 操作时调用，此时鼠标指针已退出 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

参数：
dte - DropTargetEvent

drop

void drop(DropTargetDropEvent dtde)
在 drag 操作已终止时调用，此时 drop 处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

此方法负责保证与操作相关的数据传输。DropTargetDropEvent 提供获得 Transferable 对象的手段，该对象表示要转换的数据对象。

利用此方法，DropTargetListener 将通过带 DropTargetDropEvent 参数的 acceptDrop(int dropAction) 或 rejectDrop() 方法来接受或拒绝 drop 操作。

在 acceptDrop() 之后（而不是之前），可以调用 DropTargetDropEvent 的 getTransferable() 方法，还可以通过返回的 Transferable 的 getTransferData() 方法执行数据传输。

完成 drop 之后，需要此方法实现指明 drop 成功还是失败，这通过传递合适的 boolean 给 DropTargetDropEvent 的 dropComplete(boolean success) 方法来完成。

注：应该在调用 DropTargetDropEvent 的 dropComplete(boolean success) 方法之前完成数据传输。在此之后，调用由 DropTargetDropEvent.getTransferable() 返回的 Transferable 的 getTransferData() 方法，确保只有在数据传输限于本地时才会成功；也就是说，只有 DropTargetDropEvent.isLocalTransfer() 返回 true 时才会成功。否则，调用的行为是与实现相关的。

参数：
dtde - DropTargetDropEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidDnDOperationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 InvalidDnDOperationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.awt.dnd.InvalidDnDOperationException
所有已实现的接口：
Serializable
public class InvalidDnDOperationException
extends IllegalStateException

java.awt.dnd 包中的各种方法都会抛出此异常。抛出此异常通常表示相关目标当前因基础 DnD 系统未处在合适的状态而无法承担所请求的操作。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
InvalidDnDOperationException()
创建一个默认的异常。
InvalidDnDOperationException(String msg)
创建一个带有其自身描述性消息的异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidDnDOperationException

public InvalidDnDOperationException()
创建一个默认的异常。

InvalidDnDOperationException

public InvalidDnDOperationException(String msg)
创建一个带有其自身描述性消息的异常。

参数：
msg - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseDragGestureRecognizer (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.dnd
类 MouseDragGestureRecognizer

java.lang.Object
    继承者  java.awt.dnd.DragGestureRecognizer
        继承者  java.awt.dnd.MouseDragGestureRecognizer
所有已实现的接口：
MouseListener, MouseMotionListener, Serializable, EventListener
public abstract class MouseDragGestureRecognizer
extends DragGestureRecognizer
implements MouseListener, MouseMotionListener

DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。通过 Toolkit.createDragGestureRecognizer() 方法，每个平台实现此类自身的具体子类，以封装与平台无关的鼠标动作（启动拖放操作）的识别功能。

鼠标拖动识别程序应该遵守拖动动作阈值，该阈值可以通过 DragSource.getDragThreshold() 获得。只有在上一次鼠标拖动事件时的位置和相应鼠标按键事件时的位置之间的水平或垂直方向的差值大于拖动动作阈值时，才应该识别为拖动动作。

利用 DragSource.createDefaultDragGestureRecognizer(java.awt.Component, int, java.awt.dnd.DragGestureListener) 创建的拖动识别程序遵守以下约定。

另请参见：
DragGestureListener, DragGestureEvent, DragSource, 序列化表格

字段摘要
从类 java.awt.dnd.DragGestureRecognizer 继承的字段
component, dragGestureListener, dragSource, events, sourceActions
构造方法摘要
protected | MouseDragGestureRecognizer(DragSource ds) 给出 Component 的 DragSource，构造一个新的 MouseDragGestureRecognizer。
protected | MouseDragGestureRecognizer(DragSource ds, Component c) 给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。
protected | MouseDragGestureRecognizer(DragSource ds, Component c, int act) 给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。
protected | MouseDragGestureRecognizer(DragSource ds, Component c, int act, DragGestureListener dgl) 给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。
方法摘要
void | mouseClicked(MouseEvent e) 鼠标在组件上单击时调用。
void | mouseDragged(MouseEvent e) 鼠标按钮在组件上按下时调用。
void | mouseEntered(MouseEvent e) 鼠标移动到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标按钮在组件上移动（无按钮按下）时调用。
void | mousePressed(MouseEvent e) 鼠标按钮在 Component 上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
protected void | registerListeners() 注册此 DragGestureRecognizer 的 Listener 和 Component
protected void | unregisterListeners() 取消注册此 DragGestureRecognizer 的 Listener 和 Component 子类必须重写此方法：
从类 java.awt.dnd.DragGestureRecognizer 继承的方法
addDragGestureListener, appendEvent, fireDragGestureRecognized, getComponent, getDragSource, getSourceActions, getTriggerEvent, removeDragGestureListener, resetRecognizer, setComponent, setSourceActions
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MouseDragGestureRecognizer

protected MouseDragGestureRecognizer(DragSource ds,
                                     Component c,
                                     int act,
                                     DragGestureListener dgl)
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。

参数：
ds - Component c 的 DragSource
c - 要观察的 Component
act - 此拖动操作允许的操作
dgl - 检测到拖动时发出通知的 DragGestureListener

MouseDragGestureRecognizer

protected MouseDragGestureRecognizer(DragSource ds,
                                     Component c,
                                     int act)
给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。

参数：
ds - Component c 的 DragSource
c - 要观察的 Component
act - 此拖动操作允许的操作

MouseDragGestureRecognizer

protected MouseDragGestureRecognizer(DragSource ds,
                                     Component c)
给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。

参数：
ds - Component c 的 DragSource
c - 要观察的 Component

MouseDragGestureRecognizer

protected MouseDragGestureRecognizer(DragSource ds)
给出 Component 的 DragSource，构造一个新的 MouseDragGestureRecognizer。

参数：
ds - Component 的 DragSource
方法详细信息

registerListeners

protected void registerListeners()
注册此 DragGestureRecognizer 的 Listener 和 Component

指定者：
类 DragGestureRecognizer 中的 registerListeners

unregisterListeners

protected void unregisterListeners()
取消注册此 DragGestureRecognizer 的 Listener 和 Component 子类必须重写此方法：

指定者：
类 DragGestureRecognizer 中的 unregisterListeners

mouseClicked

public void mouseClicked(MouseEvent e)
鼠标在组件上单击时调用。

指定者：
接口 MouseListener 中的 mouseClicked
参数：
e - MouseEvent

mousePressed

public void mousePressed(MouseEvent e)
鼠标按钮在 Component 上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed
参数：
e - MouseEvent

mouseReleased

public void mouseReleased(MouseEvent e)
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased
参数：
e - MouseEvent

mouseEntered

public void mouseEntered(MouseEvent e)
鼠标移动到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered
参数：
e - MouseEvent

mouseExited

public void mouseExited(MouseEvent e)
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited
参数：
e - MouseEvent

mouseDragged

public void mouseDragged(MouseEvent e)
鼠标按钮在组件上按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseDragged
参数：
e - MouseEvent

mouseMoved

public void mouseMoved(MouseEvent e)
鼠标按钮在组件上移动（无按钮按下）时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
参数：
e - MouseEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.dnd (Java 2 Platform SE 6)

 java.awt.dnd
接口
Autoscroll
DragGestureListener
DragSourceListener
DragSourceMotionListener
DropTargetListener
类
DnDConstants
DragGestureEvent
DragGestureRecognizer
DragSource
DragSourceAdapter
DragSourceContext
DragSourceDragEvent
DragSourceDropEvent
DragSourceEvent
DropTarget
DropTarget.DropTargetAutoScroller
DropTargetAdapter
DropTargetContext
DropTargetDragEvent
DropTargetDropEvent
DropTargetEvent
MouseDragGestureRecognizer
异常
InvalidDnDOperationException


java.awt.dnd (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.dnd

Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

请参见：
描述

接口摘要
Autoscroll | 在 DnD 操作期间，用户有可能希望将操作目标放入一个可滚动的 GUI 控件区域中，而该区域当前对用户是不可见的。
DragGestureListener | 此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。
DragSourceListener | DragSourceListener 定义了事件接口，Drag 和 Drop 操作的始发端使用它来跟踪用户操作的状态，并通过 Drag 和 Drop 操作为用户提供合适的“拖动结束”反馈。
DragSourceMotionListener | 用于接收拖动操作期间鼠标移动事件的侦听器接口。
DropTargetListener | DropTargetListener 接口是 DropTarget 类所使用的回调接口，用于提供所涉及的 DropTarget 的 DnD 操作的通知。

类摘要
DnDConstants | 此类包含了表示 Drag 和 Drop 操作所执行的操作类型的常量值。
DragGestureEvent | 当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
DragGestureRecognizer | DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。
DragSource | DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。
DragSourceAdapter | 用于接收拖动源事件的抽象适配器类。
DragSourceContext | DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
DragSourceDragEvent | 通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
DragSourceDropEvent | 通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
DragSourceEvent | 此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
DropTarget | 在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
DropTarget.DropTargetAutoScroller | 此受保护的嵌套类实现自动滚动
DropTargetAdapter | 接收放置目标事件的抽象适配器类。
DropTargetContext | 每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。
DropTargetDragEvent | 通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
DropTargetDropEvent | 通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
DropTargetEvent | DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。
MouseDragGestureRecognizer | DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

异常摘要
InvalidDnDOperationException java.awt.dnd 包中的各种方法都会抛出此异常。

软件包 java.awt.dnd 的描述

Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。Drag 和 Drop 通常由使用适当输入设备的用户的实际操作所驱动，它既提供在对 GUI 显示元素导航期间启用连续反馈（关于传输给用户的任何后续数据的可能结果）的机制，又提供支持任何后续数据协商和传输的设施。

此包定义了在 Java 中执行 Drag 和 Drop 操作所需的类和接口。它定义了用于拖动源和放置目标的类，以及用于传输正被拖动的数据的事件。此包还在整个 Drag 和 Drop 操作期间提供一种向用户提供可视反馈的方法。

典型的 Drag 和 Drop 操作可以分解为以下几种状态（未完全按顺序）：

  • 存在与 GUI 中某个显示元素 (Component) 相关的 DragSource，以启动对某个潜在 Transferable 数据的 Drag 和 Drop 操作。

  • 进入/离开一个或多个与 GUI 中显示元素（组件）相关的 DropTarget，很可能要使用 Transferable 数据类型。

  • 为了跟踪和识别任何由用户在 Component 上启动的 Drag 操作，可以从 DragSource 获取 DragGestureRecognizer，并让它与一个 Component 相关联。

  • 用户在 Component 上发起 Drag 操作，已注册的 DragGestureRecognizer 检测到该操作，并通知 DragGestureListener。

    注：尽管此 API 一直认为拖放操作是由用户的实际操作激发的，但这并不排除由适当的 DragSource 实现发出的以编程方式驱动的 DnD 操作。此包包含用于识别鼠标设备操作的抽象类 MouseDragGestureRecognizer。平台可以提供其他抽象子类，以支持其他输入设备或特定的 Component 类语义。

  • DragGestureListener 使得 DragSource 按用户的行为启动 Drag 和 Drop 操作，或者激活 GUI 光标，或呈现此操作主题项的 Image。

  • 当用户对 GUI 中带相关 DropTarget 的 Component 进行定位时，根据受支持的操作和所涉及的数据类型，DragSource 接收通知以提供 "Drag Over" 反馈效果，而 "DropTarget" 接收通知以提供 "Drag Under" 反馈效果。

该操作本身可以在整个 GUI 层次结构中移动逻辑光标，交叉 GUI 组件的几何形状，并可能导致逻辑“Drag”光标进入、跨越、随后离开 Component 及相关的 DropTarget。

DragSource 对象向用户显示“Drag Over”反馈，一般情况下是通过激活与逻辑光标相关的 GUI Cursor 来实现的。

DropTarget 对象向用户显示“Drag Under”反馈，一般情况下是通过在 GUI Cursor 下将动画呈现到相关 GUI Component 来实现的。

反馈结果的确认、数据转换的最终成败（只发生一种）是按如下方式参数化的：

  • 由用户选择的传输“操作”，并受 DragSource 和 DropTarget 支持：复制、移动或引用（链接）。

  • 通过 DragSource 所提供的数据类型集合和 DropTarget 可理解的数据类型集合的交集来实现。

  • 当用户终止 drag 操作时，一般会导致 Drop 操作成功，DragSource 和 DropTarget 都会接收到通知，该通知包含与 DragSource 相关的信息，并且通过 Transferable 对象导致信息的流通和信息类型的转换。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.dnd 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.dnd 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.dnd.DnDConstants
    • java.awt.dnd.DragGestureRecognizer (implements java.io.Serializable)
      • java.awt.dnd.MouseDragGestureRecognizer (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener)
    • java.awt.dnd.DragSource (implements java.io.Serializable)
    • java.awt.dnd.DragSourceAdapter (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener)
    • java.awt.dnd.DragSourceContext (implements java.awt.dnd.DragSourceListener, java.awt.dnd.DragSourceMotionListener, java.io.Serializable)
    • java.awt.dnd.DropTarget (implements java.awt.dnd.DropTargetListener, java.io.Serializable)
    • java.awt.dnd.DropTarget.DropTargetAutoScroller (implements java.awt.event.ActionListener)
    • java.awt.dnd.DropTargetAdapter (implements java.awt.dnd.DropTargetListener)
    • java.awt.dnd.DropTargetContext (implements java.io.Serializable)
    • java.awt.dnd.DropTargetContext.TransferableProxy (implements java.awt.datatransfer.Transferable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.dnd.DragGestureEvent
      • java.awt.dnd.DragSourceEvent
        • java.awt.dnd.DragSourceDragEvent
        • java.awt.dnd.DragSourceDropEvent
      • java.awt.dnd.DropTargetEvent
        • java.awt.dnd.DropTargetDragEvent
        • java.awt.dnd.DropTargetDropEvent
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.awt.dnd.InvalidDnDOperationException

接口分层结构

  • java.awt.dnd.Autoscroll
  • java.util.EventListener
    • java.awt.dnd.DragGestureListener
    • java.awt.dnd.DragSourceListener
    • java.awt.dnd.DragSourceMotionListener
    • java.awt.dnd.DropTargetListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.dnd 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.dnd
的使用

使用 java.awt.dnd 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 使用的 java.awt.dnd 中的类
DragGestureEvent
当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
DragGestureListener
此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。
DragGestureRecognizer
DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。
DragSource
DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。
DropTarget
在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.awt.dnd 使用的 java.awt.dnd 中的类
DragGestureEvent
当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
DragGestureListener
此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。
DragGestureRecognizer
DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。
DragSource
DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。
DragSourceContext
DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
DragSourceDragEvent
通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
DragSourceDropEvent
通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
DragSourceEvent
此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
DragSourceListener
DragSourceListener 定义了事件接口，Drag 和 Drop 操作的始发端使用它来跟踪用户操作的状态，并通过 Drag 和 Drop 操作为用户提供合适的“拖动结束”反馈。
DragSourceMotionListener
用于接收拖动操作期间鼠标移动事件的侦听器接口。
DropTarget
在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
DropTarget.DropTargetAutoScroller
此受保护的嵌套类实现自动滚动
DropTargetContext
每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。
DropTargetDragEvent
通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
DropTargetDropEvent
通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
DropTargetEvent
DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。
DropTargetListener
DropTargetListener 接口是 DropTarget 类所使用的回调接口，用于提供所涉及的 DropTarget 的 DnD 操作的通知。
InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.dnd.Autoscroll 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.Autoscroll
的使用

没有 java.awt.dnd.Autoscroll 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DnDConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DnDConstants
的使用

没有 java.awt.dnd.DnDConstants 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragGestureEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragGestureEvent
的使用

使用 DragGestureEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragGestureEvent 的使用

参数类型为 DragGestureEvent 的 java.awt 中的方法
abstract  java.awt.dnd.peer.DragSourceContextPeer Toolkit.createDragSourceContextPeer(DragGestureEvent dge)
创建 DragSourceContext 的同位体。

java.awt.dnd 中 DragGestureEvent 的使用

返回 DragGestureEvent 的 java.awt.dnd 中的方法
 DragGestureEvent DragSourceContext.getTrigger()
返回最初触发该拖动的 DragGestureEvent。

参数类型为 DragGestureEvent 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragGestureListener.dragGestureRecognized(DragGestureEvent dge) DragGestureRecognizer 已经检测到与平台有关的拖动启动动作，并且正通知此侦听器，以便启动用户操作。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 DragGestureEvent 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.dnd.DragGestureListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DragGestureListener
的使用

使用 DragGestureListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragGestureListener 的使用

参数类型为 DragGestureListener 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。

java.awt.dnd 中 DragGestureListener 的使用

声明为 DragGestureListener 的 java.awt.dnd 中的字段
protected  DragGestureListener DragGestureRecognizer.dragGestureListener
与此 DragGestureRecognizer 关联的 DragGestureListener。

参数类型为 DragGestureListener 的 java.awt.dnd 中的方法
 void DragGestureRecognizer.addDragGestureListener(DragGestureListener dgl)
注册一个新的 DragGestureListener。
 DragGestureRecognizer DragSource.createDefaultDragGestureRecognizer(Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
 void DragGestureRecognizer.removeDragGestureListener(DragGestureListener dgl)
取消注册当前的 DragGestureListener

参数类型为 DragGestureListener 的 java.awt.dnd 中的构造方法
DragGestureRecognizer(DragSource ds, Component c, int sa, DragGestureListener dgl)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
MouseDragGestureRecognizer(DragSource ds, Component c, int act, DragGestureListener dgl)
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragGestureRecognizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragGestureRecognizer
的使用

使用 DragGestureRecognizer 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragGestureRecognizer 的使用

类型参数类型为 DragGestureRecognizer 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。

java.awt.dnd 中 DragGestureRecognizer 的使用

java.awt.dnd 中 DragGestureRecognizer 的子类
 class MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

类型参数类型为 DragGestureRecognizer 的 java.awt.dnd 中的方法
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。

返回 DragGestureRecognizer 的 java.awt.dnd 中的方法
DragGestureRecognizer | DragSource.createDefaultDragGestureRecognizer(Component c, int actions, DragGestureListener dgl) 创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
DragGestureRecognizer | DragGestureEvent.getSourceAsDragGestureRecognizer() 以 DragGestureRecognizer 的形式返回源。

参数类型为 DragGestureRecognizer 的 java.awt.dnd 中的构造方法
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSource
的使用

使用 DragSource 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DragSource 的使用

参数类型为 DragSource 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。

java.awt.dnd 中 DragSource 的使用

声明为 DragSource 的 java.awt.dnd 中的字段
protected  DragSource DragGestureRecognizer.dragSource
与此 DragGestureRecognizer 关联的 DragSource。

返回 DragSource 的 java.awt.dnd 中的方法
static DragSource | DragSource.getDefaultDragSource() 获取与基础平台关联的 DragSource 对象。
DragSource | DragGestureEvent.getDragSource() 返回 DragSource。
DragSource | DragGestureRecognizer.getDragSource() 此方法返回 DragSource，为了进行 Drag 和 Drop 操作，将使用此 DragGestureRecognizer。
DragSource | DragSourceContext.getDragSource() 返回实例化此 DragSourceContext 的 DragSource。

参数类型为 DragSource 的 java.awt.dnd 中的构造方法
DragGestureRecognizer(DragSource ds)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource。
DragGestureRecognizer(DragSource ds, Component c)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。
DragGestureRecognizer(DragSource ds, Component c, int sa)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。
DragGestureRecognizer(DragSource ds, Component c, int sa, DragGestureListener dgl)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
MouseDragGestureRecognizer(DragSource ds)
给出 Component 的 DragSource，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c)
给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act)
给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act, DragGestureListener dgl)
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragSourceAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceAdapter
的使用

没有 java.awt.dnd.DragSourceAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragSourceContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceContext
的使用

使用 DragSourceContext 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceContext 的使用

返回 DragSourceContext 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
DragSourceContext | DragSourceEvent.getDragSourceContext() 此方法返回引起事件的 DragSourceContext。

参数类型为 DragSourceContext 的 java.awt.dnd 中的构造方法
DragSourceDragEvent(DragSourceContext dsc, int dropAction, int action, int modifiers)
构造一个 DragSourceDragEvent。
DragSourceDragEvent(DragSourceContext dsc, int dropAction, int action, int modifiers, int x, int y)
构造一个具有指定 DragSourceContext、用户放置动作、目标放置动作、修改键和坐标的 DragSourceDragEvent。
DragSourceDropEvent(DragSourceContext dsc)
针对没有引起放置的拖动构造一个 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext dsc, int action, boolean success)
放置构造一个具有给定 DragSourceContext、放置操作和指示放置是否成功的 boolean 值的 DragSourceDropEvent。
DragSourceDropEvent(DragSourceContext dsc, int action, boolean success, int x, int y)
针对放置构造一个具有给定 DragSourceContext、放置操作、表示放置是否成功的 boolean 值和坐标的 DragSourceDropEvent。
DragSourceEvent(DragSourceContext dsc)
根据一个指定的 DragSourceContext 来构造一个 DragSourceEvent。
DragSourceEvent(DragSourceContext dsc, int x, int y)
根据指定的 DragSourceContext 和光标位置坐标构造一个 DragSourceEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragSourceDragEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceDragEvent
的使用

使用 DragSourceDragEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceDragEvent 的使用

参数类型为 DragSourceDragEvent 的 java.awt.dnd 中的方法
void | DragSourceAdapter.dragEnter(DragSourceDragEvent dsde) 光标的热点进入放置点（与平台相关）时调用该方法。
void | DragSourceContext.dragEnter(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragEnter，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceListener.dragEnter(DragSourceDragEvent dsde) 光标的热点进入放置点（与平台相关）时调用该方法。
void | DragSourceAdapter.dragMouseMoved(DragSourceDragEvent dsde) 在拖动操作期间，只要移动了鼠标就调用该方法。
void | DragSourceContext.dragMouseMoved(DragSourceDragEvent dsde) 对向与此 DragSourceContext 关联的 DragSource 注册的 DragSourceMotionListener 调用 dragMouseMoved，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceMotionListener.dragMouseMoved(DragSourceDragEvent dsde) 只要在拖动操作期间鼠标移动了，就调用该方法。
void | DragSourceAdapter.dragOver(DragSourceDragEvent dsde) 光标的热点在放置点（与平台相关）上移动时调用该方法。
void | DragSourceContext.dragOver(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceContext 调用 dragOver，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceListener.dragOver(DragSourceDragEvent dsde) 光标的热点在放置点（与平台相关）上移动时调用该方法。
void | DragSourceAdapter.dropActionChanged(DragSourceDragEvent dsde) 当用户修改放置操作时调用该方法。
void | DragSourceContext.dropActionChanged(DragSourceDragEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dropActionChanged，并将指定的 DragSourceDragEvent 传递给它们。
void | DragSourceListener.dropActionChanged(DragSourceDragEvent dsde) 当用户修改放置操作时调用该方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragSourceDropEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceDropEvent
的使用

使用 DragSourceDropEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceDropEvent 的使用

参数类型为 DragSourceDropEvent 的 java.awt.dnd 中的方法
void | DragSourceAdapter.dragDropEnd(DragSourceDropEvent dsde) 调用此方法来通知 Drag 和 Drop 操作已完成。
void | DragSourceContext.dragDropEnd(DragSourceDropEvent dsde) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragDropEnd，并将指定的 DragSourceDropEvent 传递给它们。
void | DragSourceListener.dragDropEnd(DragSourceDropEvent dsde) 调用此方法来通知 Drag 和 Drop 操作已完成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DragSourceEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DragSourceEvent
的使用

使用 DragSourceEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceEvent 的使用

java.awt.dnd 中 DragSourceEvent 的子类
class | DragSourceDragEvent 通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
class | DragSourceDropEvent 通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。

参数类型为 DragSourceEvent 的 java.awt.dnd 中的方法
void | DragSourceAdapter.dragExit(DragSourceEvent dse) 光标的热点离开放置点（与平台相关）时调用该方法。
void | DragSourceContext.dragExit(DragSourceEvent dse) 对向此 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 调用 dragExit，并将指定的 DragSourceEvent 传递给它们。
void | DragSourceListener.dragExit(DragSourceEvent dse) 光标的热点离开放置点（与平台相关）时调用该方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.dnd.DragSourceListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DragSourceListener
的使用

使用 DragSourceListener 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceListener 的使用

实现 DragSourceListener 的 java.awt.dnd 中的类
class | DragSourceAdapter 用于接收拖动源事件的抽象适配器类。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。

返回 DragSourceListener 的 java.awt.dnd 中的方法
 DragSourceListener[] DragSource.getDragSourceListeners()
获得向此 DragSource 注册的所有 DragSourceListener。

参数类型为 DragSourceListener 的 java.awt.dnd 中的方法
void | DragSource.addDragSourceListener(DragSourceListener dsl) 将指定的 DragSourceListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动源事件。
void | DragSourceContext.addDragSourceListener(DragSourceListener dsl) 如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragSource.removeDragSourceListener(DragSourceListener dsl) 从此 DragSource 移除指定的 DragSourceListener。
void | DragSourceContext.removeDragSourceListener(DragSourceListener dsl) 从此 DragSourceContext 移除指定的 DragSourceListener。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 DragSourceListener 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.dnd.DragSourceMotionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DragSourceMotionListener
的使用

使用 DragSourceMotionListener 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DragSourceMotionListener 的使用

实现 DragSourceMotionListener 的 java.awt.dnd 中的类
class | DragSourceAdapter 用于接收拖动源事件的抽象适配器类。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。

返回 DragSourceMotionListener 的 java.awt.dnd 中的方法
 DragSourceMotionListener[] DragSource.getDragSourceMotionListeners()
获得向此 DragSource 注册的所有 DragSourceMotionListener。

参数类型为 DragSourceMotionListener 的 java.awt.dnd 中的方法
void | DragSource.addDragSourceMotionListener(DragSourceMotionListener dsml) 将指定的 DragSourceMotionListener 添加到此 DragSource，以接收在使用此 DragSource 所发起的拖动操作期间出现的拖动移动事件。
void | DragSource.removeDragSourceMotionListener(DragSourceMotionListener dsml) 从此 DragSource 移除指定的 DragSourceMotionListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTargetAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetAdapter
的使用

没有 java.awt.dnd.DropTargetAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTargetDragEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetDragEvent
的使用

使用 DropTargetDragEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetDragEvent 的使用

参数类型为 DropTargetDragEvent 的 java.awt.dnd 中的方法
void | DropTargetAdapter.dragEnter(DropTargetDragEvent dtde) 当鼠标指针进入向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行的同时调用该方法。
void | DropTarget.dragEnter(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dragEnter，并将其传递给指定的 DropTargetDragEvent。
void | DropTargetListener.dragEnter(DropTargetDragEvent dtde) 正在进行 drag 操作时调用，此时鼠标指针进入 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | DropTargetAdapter.dragOver(DropTargetDragEvent dtde) 当鼠标指针仍旧处于向此侦听器注册的 DropTarget 放置点可操作部分上时，则在拖动操作正在进行时调用该方法。
void | DropTarget.dragOver(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dragOver，并将其传递给指定的 DropTargetDragEvent。
void | DropTargetListener.dragOver(DropTargetDragEvent dtde) 正在进行 drag 操作时调用，此时鼠标指针仍然处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。
void | DropTargetAdapter.dropActionChanged(DropTargetDragEvent dtde) 如果用户已经修改了当前的放置操作，则调用该方法。
void | DropTarget.dropActionChanged(DropTargetDragEvent dtde) 在已注册的 DropTargetListener 上调用 dropActionChanged，并将其传递给指定的 DropTargetDragEvent。
void | DropTargetListener.dropActionChanged(DropTargetDragEvent dtde) 在用户已经修改了当前 drop 操作后调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTargetDropEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetDropEvent
的使用

使用 DropTargetDropEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetDropEvent 的使用

参数类型为 DropTargetDropEvent 的 java.awt.dnd 中的方法
void | DropTarget.drop(DropTargetDropEvent dtde) 如果此 DropTarget 处于激活状态，则在已注册的 DropTargetListener 上调用 drop，并将其传递给指定的 DropTargetDropEvent。
void | DropTargetListener.drop(DropTargetDropEvent dtde) 在 drag 操作已终止时调用，此时 drop 处于 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTargetEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetEvent
的使用

使用 DropTargetEvent 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetEvent 的使用

java.awt.dnd 中 DropTargetEvent 的子类
class | DropTargetDragEvent 通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
class | DropTargetDropEvent 通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。

参数类型为 DropTargetEvent 的 java.awt.dnd 中的方法
void | DropTargetAdapter.dragExit(DropTargetEvent dte) 当鼠标指针已经离开向此侦听器注册的 DropTarget 放置点可操作部分时，则在拖动操作正在进行时调用该方法。
void | DropTarget.dragExit(DropTargetEvent dte) 在已注册的 DropTargetListener 上调用 dragExit，并将其传递给指定的 DropTargetEvent。
void | DropTargetListener.dragExit(DropTargetEvent dte) 正在进行 drag 操作时调用，此时鼠标指针已退出 DropTarget（使用此 listener 注册）的 drop 位置的可操作部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.InvalidDnDOperationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.InvalidDnDOperationException
的使用

使用 InvalidDnDOperationException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 InvalidDnDOperationException 的使用

抛出 InvalidDnDOperationException 的 java.awt 中的方法
abstract  java.awt.dnd.peer.DragSourceContextPeer Toolkit.createDragSourceContextPeer(DragGestureEvent dge)
创建 DragSourceContext 的同位体。

java.awt.dnd 中 InvalidDnDOperationException 的使用

抛出 InvalidDnDOperationException 的 java.awt.dnd 中的方法
void | DropTargetContext.dropComplete(boolean success) 此方法指示放置操作完成以及成功与否。
protected Transferable | DropTargetContext.getTransferable() 获取此操作的 Transferable（代理）操作数
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable) 在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.MouseDragGestureRecognizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.MouseDragGestureRecognizer
的使用

没有 java.awt.dnd.MouseDragGestureRecognizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTargetContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetContext
的使用

使用 DropTargetContext 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetContext 的使用

声明为 DropTargetContext 的 java.awt.dnd 中的字段
protected  DropTargetContext DropTargetEvent.context
与此 DropTargetEvent 相关的 DropTargetContext。

返回 DropTargetContext 的 java.awt.dnd 中的方法
protected DropTargetContext | DropTarget.createDropTargetContext() 创建与此 DropTarget 关联的 DropTargetContext。
DropTargetContext | DropTargetEvent.getDropTargetContext() 此方法返回与该 DropTargetEvent 相关的 DropTargetContext。
DropTargetContext | DropTarget.getDropTargetContext() 获取与此 DropTarget 关联的 DropTargetContext。

参数类型为 DropTargetContext 的 java.awt.dnd 中的构造方法
DropTargetDragEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。
DropTargetEvent(DropTargetContext dtc)
构造一个具有指定 DropTargetContext 的 DropTargetEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTargetContext.TransferableProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTargetContext.TransferableProxy
的使用

没有 java.awt.dnd.DropTargetContext.TransferableProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTarget 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTarget
的使用

使用 DropTarget 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt 中 DropTarget 的使用

返回 DropTarget 的 java.awt 中的方法
 DropTarget Component.getDropTarget()
获取与此 Component 相关的 DropTarget。

参数类型为 DropTarget 的 java.awt 中的方法
 void Component.setDropTarget(DropTarget dt)
将组件与 DropTarget 相关联。

java.awt.dnd 中 DropTarget 的使用

返回 DropTarget 的 java.awt.dnd 中的方法
 DropTarget DropTargetContext.getDropTarget()
此方法返回与此 DropTargetContext 相关的 DropTarget。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.dnd.DropTarget.DropTargetAutoScroller 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.dnd.DropTarget.DropTargetAutoScroller
的使用

使用 DropTarget.DropTargetAutoScroller 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTarget.DropTargetAutoScroller 的使用

返回 DropTarget.DropTargetAutoScroller 的 java.awt.dnd 中的方法
protected  DropTarget.DropTargetAutoScroller DropTarget.createDropTargetAutoScroller(Component c, Point p)
创建一个嵌入式自动滚动条

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.dnd.DropTargetListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.dnd.DropTargetListener
的使用

使用 DropTargetListener 的软件包
java.awt.dnd Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.dnd 中 DropTargetListener 的使用

实现 DropTargetListener 的 java.awt.dnd 中的类
class | DropTarget 在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
class | DropTargetAdapter 接收放置目标事件的抽象适配器类。

参数类型为 DropTargetListener 的 java.awt.dnd 中的方法
void | DropTarget.addDropTargetListener(DropTargetListener dtl) 添加一个新的 DropTargetListener (UNICAST SOURCE)。
void | DropTarget.removeDropTargetListener(DropTargetListener dtl) 移除当前的 DropTargetListener (UNICAST SOURCE)。

参数类型为 DropTargetListener 的 java.awt.dnd 中的构造方法
DropTarget(Component c, DropTargetListener dtl)
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Clipboard (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
类 Clipboard

java.lang.Object
    继承者  java.awt.datatransfer.Clipboard

public class Clipboard
extends Object

此类实现一种使用剪切/复制/粘贴操作传输数据的机制。

FlavorListener 可以在 Clipboard 类的实例上注册，以接收对此剪贴板上可用的 DataFlavor 的集合更改的通知（参见 addFlavorListener(java.awt.datatransfer.FlavorListener)）。

另请参见：
Toolkit.getSystemClipboard(), Toolkit.getSystemSelection()

字段摘要
protected Transferable | contents
protected ClipboardOwner | owner
构造方法摘要
Clipboard(String name)
创建剪贴板对象。
方法摘要
void | addFlavorListener(FlavorListener listener) 注册指定的 FlavorListener，以从此剪贴板接收 FlavorEvent。
DataFlavor[] | getAvailableDataFlavors() 返回 DataFlavor 的数组，其中提供了此剪贴板的当前内容。
Transferable | getContents(Object requestor) 返回表示剪贴板当前内容的 transferable 对象。
Object | getData(DataFlavor flavor) 返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
FlavorListener[] | getFlavorListeners() 返回一组目前在此 Clipboard 上注册的所有 FlavorListener。
String | getName() 返回此剪贴板对象的名称。
boolean | isDataFlavorAvailable(DataFlavor flavor) 返回是否能够以指定的 DataFlavor 形式提供此剪贴板的当前内容。
void | removeFlavorListener(FlavorListener listener) 移除指定的 FlavorListener，使其不再从此 Clipboard 接收 FlavorEvent。
void | setContents(Transferable contents, ClipboardOwner owner) 将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

owner

protected ClipboardOwner owner

contents

protected Transferable contents
构造方法详细信息

Clipboard

public Clipboard(String name)
创建剪贴板对象。

另请参见：
Toolkit.getSystemClipboard()
方法详细信息

getName

public String getName()
返回此剪贴板对象的名称。

另请参见：
Toolkit.getSystemClipboard()

setContents

public void setContents(Transferable contents,
                        ClipboardOwner owner)
将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。

如果现有的所有者与参数 owner 不同，则该所有者将得到通知，它已不再保持剪贴板内容的所有关系，此操作是通过对该所有者调用 ClipboardOwner.lostOwnership() 完成的。setContents() 的实现可以不直接从此方法调用 lostOwnership()。例如，可以稍后在另一个线程上调用 lostOwnership()。在此剪贴板上注册的 FlavorListener 也是如此。

如果剪贴板当前不可用，则该方法抛出 IllegalStateException。例如，在某些平台上，系统剪贴板在被别的应用程序访问时是不可用的。

参数：
contents - 表示剪贴板内容的 transferable 对象
owner - 拥有剪贴板内容的对象
抛出：
IllegalStateException - 如果剪贴板当前不可用
另请参见：
Toolkit.getSystemClipboard()

getContents

public Transferable getContents(Object requestor)
返回表示剪贴板当前内容的 transferable 对象。如果剪贴板目前没有任何内容，则返回 null。目前没有使用参数 Object requestor。如果剪贴板当前不可用，则该方法抛出 IllegalStateException。例如，在某些平台上，系统剪贴板在被别的应用程序访问时是不可用的。

参数：
requestor - 请求剪切数据（不使用）的对象
返回：
剪贴板上的当前 transferable
抛出：
IllegalStateException - 如果剪贴板当前不可用
另请参见：
Toolkit.getSystemClipboard()

getAvailableDataFlavors

public DataFlavor[] getAvailableDataFlavors()
返回 DataFlavor 的数组，其中提供了此剪贴板的当前内容。如果不存在任何可用的 DataFlavor，则此方法返回一个长度为零的数组。

返回：
一组 DataFlavor，在其中可以提供此剪贴板的当前内容
抛出：
IllegalStateException - 如果此剪贴板当前不可用
从以下版本开始：
1.5

isDataFlavorAvailable

public boolean isDataFlavorAvailable(DataFlavor flavor)
返回是否能够以指定的 DataFlavor 形式提供此剪贴板的当前内容。

参数：
flavor - 为该内容请求的 DataFlavor
返回：
如果可以在指定的 DataFlavor 中提供此剪贴板的当前内容，则返回 true；否则返回 false
抛出：
NullPointerException - 如果 flavor 为 null
IllegalStateException - 如果此剪贴板当前不可用
从以下版本开始：
1.5

getData

public Object getData(DataFlavor flavor)
               throws UnsupportedFlavorException,
                      IOException
返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。返回对象的类是由 flavor 的表示形式类定义的。

参数：
flavor - 为该内容请求的 DataFlavor
返回：
一个对象，表示指定的 DataFlavor 中此剪贴板的当前内容
抛出：
NullPointerException - 如果 flavor 为 null
IllegalStateException - 如果此剪贴板目前不可用
UnsupportedFlavorException - 如果请求的 DataFlavor 不可用
IOException - 如果无法检索请求的 DataFlavor 中的数据
从以下版本开始：
1.5
另请参见：
DataFlavor.getRepresentationClass()

addFlavorListener

public void addFlavorListener(FlavorListener listener)
注册指定的 FlavorListener，以从此剪贴板接收 FlavorEvent。如果 listener 为 null，则不会抛出异常并且不执行操作。

参数：
listener - 要添加的侦听器
从以下版本开始：
1.5
另请参见：
removeFlavorListener(java.awt.datatransfer.FlavorListener), getFlavorListeners(), FlavorListener, FlavorEvent

removeFlavorListener

public void removeFlavorListener(FlavorListener listener)
移除指定的 FlavorListener，使其不再从此 Clipboard 接收 FlavorEvent。如果参数所指定的侦听器尚未添加到此 Clipboard，则此方法不起作用，也不抛出异常。如果 listener 为 null，则不会抛出异常并且不执行操作。

参数：
listener - 要移除的侦听器
从以下版本开始：
1.5
另请参见：
addFlavorListener(java.awt.datatransfer.FlavorListener), getFlavorListeners(), FlavorListener, FlavorEvent

getFlavorListeners

public FlavorListener[] getFlavorListeners()
返回一组目前在此 Clipboard 上注册的所有 FlavorListener。

返回：
此剪贴板的所有 FlavorListener，如果目前没有注册侦听器，则返回一个空数组
从以下版本开始：
1.5
另请参见：
addFlavorListener(java.awt.datatransfer.FlavorListener), removeFlavorListener(java.awt.datatransfer.FlavorListener), FlavorListener, FlavorEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClipboardOwner (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
接口 ClipboardOwner

所有已知实现类：
StringSelection
public interface ClipboardOwner

为提供数据到剪贴板的类所定义的接口。如果此接口的实例作为剪贴板的 Clipboard.setContents(java.awt.datatransfer.Transferable, java.awt.datatransfer.ClipboardOwner) 方法的参数传递,并且此方法成功返回，则该实例将变成剪贴板的内容的所有者（剪贴板所有者）。该实例保持为剪贴板所有者，直到其他应用程序或此应用程序中的其他对象维护此剪贴板的所有权。

另请参见：
Clipboard

方法摘要
 void lostOwnership(Clipboard clipboard, Transferable contents)
通知此对象，它已不再是剪贴板所有者。

方法详细信息

lostOwnership

void lostOwnership(Clipboard clipboard,
                   Transferable contents)
通知此对象，它已不再是剪贴板所有者。当其他应用程序或此应用程序中的其他对象维护剪贴板的所有权时，调用此方法。

参数：
clipboard - 不再拥有的剪贴板
contents - 此所有者置于剪贴板上的内容
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataFlavor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
类 DataFlavor

java.lang.Object
    继承者  java.awt.datatransfer.DataFlavor
所有已实现的接口：
Externalizable, Serializable, Cloneable
直接已知子类：
ActivationDataFlavor
public class DataFlavor
extends Object
implements Externalizable, Cloneable

DataFlavor 提供有关数据的元信息。DataFlavor 通常用于访问剪切板上的数据，或者在执行拖放操作时使用。

DataFlavor 实例封装 RFC 2045 和 RFC 2046 中定义的内容类型。内容类型通常被称为 MIME 类型。

内容类型由媒体类型（被称为基本类型）、子类型和可选参数组成。关于 MIME 类型的语法的详细信息，请参阅 RFC 2045。

JRE 数据传输实现将 MIME 类型的参数 "class" 解释为一个表示形式类。表示形式类反映将被传输的对象的类。换句话说，表示形式类是由 Transferable.getTransferData(java.awt.datatransfer.DataFlavor) 返回的对象的类型。例如，imageFlavor 的 MIME 类型是 "image/x-java-image;class=java.awt.Image"，基本类型是 image，子类型是 x-java-image，表示形式类是 java.awt.Image。当调用 getTransferData，且 DataFlavor 为 imageFlavor 时，返回 java.awt.Image 的实例。要重点注意的是，DataFlavor 不会依据表示形式类进行任何错误检查。由 DataFlavor 的使用者（如 Transferable）决定是否遵守表示形式类。
注意，如果在创建 DataFlavor 时没有指定表示形式类，则使用默认表示形式类。有关 DataFlavor 的构造方法，请参阅适当的文档。

此外，具有 "text" 基本 MIME 类型的 DataFlavor 实例可能有一个 "charset" 参数。有关 "text" MIME 类型和 "charset" 参数的详细信息，请参阅 RFC 2046 和 selectBestTextFlavor(java.awt.datatransfer.DataFlavor[]) 。

DataFlavors 的相等性由基本类型、子类型和表示形式类决定。有关详细信息，请参阅 equals(DataFlavor)。在确定相等性时，所有可选参数都被忽略。例如，以下代码产生的两个 DataFlavors 被认为是相等的：

   DataFlavor flavor1 = new DataFlavor(Object.class, "X-test/test; class=<java.lang.Object>; foo=bar");
   DataFlavor flavor2 = new DataFlavor(Object.class, "X-test/test; class=<java.lang.Object>; x=y");
   // The following returns true.
   flavor1.equals(flavor2);
正如上面提到的那样，flavor1 和 flavor2 被认为是相等的。同样地，请求 Transferable 或 DataFlavor 将返回相同的结果。

有关在 Swing 中使用数据传输的更多信息，请参阅 Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

另请参见：
序列化表格

字段摘要
static DataFlavor | imageFlavor DataFlavor 表示 Java Image 类，其中：
static DataFlavor | javaFileListFlavor 要将文件列表传入 Java（及底层平台）或从中传出，需要使用此类型/子类型的 DataFlavor 和 java.util.List 的表示形式类。
static String | javaJVMLocalObjectMimeType 要将一个引用传输到不具有关联 MIME Content 类型的任意 Java 对象引用（跨越同一 JVM 中的 Transferable 接口），需要使用具有此类型/子类型的 DataFlavor，其中 representationClass 等于跨越 Transferable 传递的类/接口的类型。
static String | javaRemoteObjectMimeType 为了通过拖放 ACTION_LINK 操作将活动链接传递到 Remote 对象，应该使用 Mime Content 类型的 application/x-java-remote-object，其中 DataFlavor 的表示形式类表示要传输的 Remote 接口的类型。
static String | javaSerializedObjectMimeType MIME Content 类型的 application/x-java-serialized-object 表示已变得持久的 Java 对象的图形。
static DataFlavor | plainTextFlavor 已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。
static DataFlavor | stringFlavor DataFlavor 表示 Java Unicode String 类，其中：
构造方法摘要
DataFlavor()
构造一个新的 DataFlavor。
DataFlavor(Class<?> representationClass, String humanPresentableName)
构造一个表示 Java 类的 DataFlavor。
DataFlavor(String mimeType)
根据 mimeType 字符串构造 DataFlavor。
DataFlavor(String mimeType, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。
DataFlavor(String mimeType, String humanPresentableName, ClassLoader classLoader)
构造一个表示 MimeType 的 DataFlavor。
方法摘要
 Object clone()
返回此 DataFlavor 的副本。
 boolean equals(DataFlavor that)
测试 DataFlavor 与此 DataFlavor 的相等性。
 boolean equals(Object o)
测试任意 Object 与此 DataFlavor 的相等性。
 boolean equals(String s)
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。
 Class<?> getDefaultRepresentationClass()
 String getDefaultRepresentationClassAsString()
 String getHumanPresentableName()
返回此 DataFlavor 表示的数据格式的得体的名称。
 String getMimeType()
返回此 DataFlavor 的 MIME 类型字符串。
 String getParameter(String paramName)
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。
 String getPrimaryType()
返回此 DataFlavor 的基本 MIME 类型。
 Reader getReaderForText(Transferable transferable)
获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
 Class<?> getRepresentationClass()
返回请求此 DataFlavor 时，支持此 DataFlavor 的对象将返回的 Class。
 String getSubType()
返回此 DataFlavor 的子 MIME 类型。
static DataFlavor getTextPlainUnicodeFlavor()
返回表示具有 Unicode 编码的纯文本的 DataFlavor，其中： representationClass = java.io.InputStream mimeType = "text/plain; charset=<platform default Unicode encoding>" Sun 的 Microsoft Windows 实现使用编码 utf-16le。
 int hashCode()
返回此 DataFlavor 的哈希码。
 boolean isFlavorJavaFileListType()
如果指定的 DataFlavor 表示 File 对象列表，则返回 true。
 boolean isFlavorRemoteObjectType()
如果指定的 DataFlavor 表示远程对象，则返回 true。
 boolean isFlavorSerializedObjectType()
如果指定的 DataFlavor 表示序列化对象，则返回 true。
 boolean isFlavorTextType()
返回此 DataFlavor 是否是 Java 平台此实现的有效文本 flavor。
 boolean isMimeTypeEqual(DataFlavor dataFlavor)
比较两个 DataFlavor 对象的 mimeType。
 boolean isMimeTypeEqual(String mimeType)
返回传入的 MIME 类型的字符串表示形式是否等于此 DataFlavor 的 MIME 类型。
 boolean isMimeTypeSerializedObject()
DataFlavor 是否表示序列化对象？
 boolean isRepresentationClassByteBuffer()
返回此 DataFlavor 的表示形式类是 java.nio.ByteBuffer 还是其子类。
 boolean isRepresentationClassCharBuffer()
返回此 DataFlavor 的表示形式类是 java.nio.CharBuffer 还是其子类。
 boolean isRepresentationClassInputStream()
DataFlavor 是否表示 java.io.InputStream？
 boolean isRepresentationClassReader()
返回此 DataFlavor 的表示形式类是 java.io.Reader 还是其子类。
 boolean isRepresentationClassRemote()
如果表示形式类为 Remote，则返回 true。
 boolean isRepresentationClassSerializable()
如果表示形式类可序列化，则返回 true。
 boolean match(DataFlavor that)
测试 DataFlavor 与此 DataFlavor 的相等性。
protected  String normalizeMimeType(String mimeType)
已过时。
protected  String normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。
 void readExternal(ObjectInput is)
根据 Serialized 状态还原此 DataFlavor。
static DataFlavor selectBestTextFlavor(DataFlavor[] availableFlavors)
从 DataFlavor 数组中选择最佳文本 DataFlavor。
 void setHumanPresentableName(String humanPresentableName)
设置此 DataFlavor 表示的数据格式的得体的名称。
 String toString()
此 DataFlavor 及其参数的字符串表示形式。
protected static Class<?> tryToLoadClass(String className, ClassLoader fallback)
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。
 void writeExternal(ObjectOutput os)
序列化此 DataFlavor。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

stringFlavor

public static final DataFlavor stringFlavor
DataFlavor 表示 Java Unicode String 类，其中：
     representationClass = java.lang.String
     mimeType           = "application/x-java-serialized-object"

imageFlavor

public static final DataFlavor imageFlavor
DataFlavor 表示 Java Image 类，其中：
     representationClass = java.awt.Image
     mimeType            = "image/x-java-image"

plainTextFlavor

@Deprecated
public static final DataFlavor plainTextFlavor
已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。
DataFlavor 表示使用 Unicode 编码的纯文本，其中：
     representationClass = InputStream
     mimeType            = "text/plain; charset=unicode"
此 DataFlavor 已过时，因为 (1) 其表示形式为 InputStream，一个基于 8 位的表示形式，而 Unicode 是一个 16 位的字符集；(2) charset "unicode" 意义不明确。"unicode" 意味着特定平台的 Unicode 实现，而不是跨平台的实现。

javaSerializedObjectMimeType

public static final String javaSerializedObjectMimeType
MIME Content 类型的 application/x-java-serialized-object 表示已变得持久的 Java 对象的图形。与此 DataFlavor 关联的表示形式类可以标识对象的 Java 类型，这里的对象指调用 java.awt.datatransfer.getTransferData 时作为引用返回的对象。

另请参见：
常量字段值

javaFileListFlavor

public static final DataFlavor javaFileListFlavor
要将文件列表传入 Java（及底层平台）或从中传出，需要使用此类型/子类型的 DataFlavor 和 java.util.List 的表示形式类。要求/保证列表的每个元素都是 java.io.File 类型。

javaJVMLocalObjectMimeType

public static final String javaJVMLocalObjectMimeType
要将一个引用传输到不具有关联 MIME Content 类型的任意 Java 对象引用（跨越同一 JVM 中的 Transferable 接口），需要使用具有此类型/子类型的 DataFlavor，其中 representationClass 等于跨越 Transferable 传递的类/接口的类型。

对于具有此 MIME Content 类型的 DataFlavor，从 Transferable.getTransferData 返回的对象引用必须是 DataFlavor 的表示形式类的实例。

另请参见：
常量字段值

javaRemoteObjectMimeType

public static final String javaRemoteObjectMimeType
为了通过拖放 ACTION_LINK 操作将活动链接传递到 Remote 对象，应该使用 Mime Content 类型的 application/x-java-remote-object，其中 DataFlavor 的表示形式类表示要传输的 Remote 接口的类型。

另请参见：
常量字段值
构造方法详细信息

DataFlavor

public DataFlavor()
构造一个新的 DataFlavor。提供此构造方法的目的只是为了支持 Externalizable 接口。它不用于公共（客户端）用途。

从以下版本开始：
1.2

DataFlavor

public DataFlavor(Class<?> representationClass,
                  String humanPresentableName)
构造一个表示 Java 类的 DataFlavor。

返回的 DataFlavor 将具有以下特征：

    representationClass = representationClass
    mimeType            = application/x-java-serialized-object

参数：
representationClass - 用于在此 flavor 中传输数据的类
humanPresentableName - 用于标识此 flavor 的可读字符串；如果此参数为 null，则使用 MIME Content 类型的值
抛出：
NullPointerException - 如果 representationClass 为 null

DataFlavor

public DataFlavor(String mimeType,
                  String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

返回的 DataFlavor 将具有以下特征：

如果 mimeType 为 "application/x-java-serialized-object; class=<representation class>"，则结果与调用 new DataFlavor(Class:forName(<representation class>) 相同。

否则：

     representationClass = InputStream
     mimeType            = mimeType

参数：
mimeType - 用于标识此 flavor 的 MIME 类型的字符串；如果 mimeType 没有指定 "class=" 参数，或者没有成功地加载类，则抛出 IllegalArgumentException
humanPresentableName - 用于标识此 flavor 的可读字符串；如果此参数为 null，则使用 MIME Content 类型的值
抛出：
IllegalArgumentException - 如果 mimeType 无效或者没有成功加载类
NullPointerException - 如果 mimeType 为 null

DataFlavor

public DataFlavor(String mimeType,
                  String humanPresentableName,
                  ClassLoader classLoader)
           throws ClassNotFoundException
构造一个表示 MimeType 的 DataFlavor。

返回的 DataFlavor 将具有以下特征：

如果 mimeType 为 "application/x-java-serialized-object; class=<representation class>"，则结果与调用 new DataFlavor(Class:forName(<representation class>) 相同。

否则：

     representationClass = InputStream
     mimeType            = mimeType

参数：
mimeType - 用于标识此 flavor 的 MIME 类型的字符串
humanPresentableName - 用于标识此 flavor 的可读字符串
classLoader - 要使用的类加载器
抛出：
ClassNotFoundException - 如果没有加载类
IllegalArgumentException - 如果 mimeType 无效
NullPointerException - 如果 mimeType 为 null

DataFlavor

public DataFlavor(String mimeType)
           throws ClassNotFoundException
根据 mimeType 字符串构造 DataFlavor。该字符串可以指定 "class=" 参数，以创建具有所需表示形式类的 DataFlavor。如果字符串不包含 "class=" 参数，则使用 java.io.InputStream 作为默认值。

参数：
mimeType - 用于标识此 flavor 的 MIME 类型的字符串；如果没有成功加载 "class=" 参数指定的类，则抛出 ClassNotFoundException
抛出：
ClassNotFoundException - 如果没有加载类
IllegalArgumentException - 如果 mimeType 无效
NullPointerException - 如果 mimeType 为 null
方法详细信息

tryToLoadClass

protected static final Class<?> tryToLoadClass(String className,
                                               ClassLoader fallback)
                                        throws ClassNotFoundException
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

参数：
className - 要加载的类的名称
fallback - 回退加载器
返回：
加载的类
抛出：
ClassNotFoundException - 如果未找到类

toString

public String toString()
此 DataFlavor 及其参数的字符串表示形式。得到的 String 包含 DataFlavor 类的名称、此 flavor 的 MIME 类型及其表示形式类。如果此 flavor 具有 "text" 的基本 MIME 类型、支持 charset 参数并且具有编码的表示形式，则还包括 flavor 的 charset。有关支持 charset 参数的文本 flavor 列表，请参阅 selectBestTextFlavor。

覆盖：
类 Object 中的 toString
返回：
此 DataFlavor 的字符串表示形式
另请参见：
selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

getTextPlainUnicodeFlavor

public static final DataFlavor getTextPlainUnicodeFlavor()
返回表示具有 Unicode 编码的纯文本的 DataFlavor，其中：
     representationClass = java.io.InputStream
     mimeType            = "text/plain;
                            charset=<platform default Unicode encoding>"
Sun 的 Microsoft Windows 实现使用编码 utf-16le。Sun 的 Solaris 和 Linux 实现使用编码 iso-10646-ucs-2。

返回：
表示具有 Unicode 编码的纯文本的 DataFlavor
从以下版本开始：
1.3

selectBestTextFlavor

public static final DataFlavor selectBestTextFlavor(DataFlavor[] availableFlavors)
从 DataFlavor 数组中选择最佳文本 DataFlavor。只能选择 DataFlavor.stringFlavor、等效 flavor 和具有基本 MIME "text" 类型的 flavor。

首先 Flavor 按照其 MIME 类型排序，顺序如下所示：

  • "text/sgml"
  • "text/xml"
  • "text/html"
  • "text/rtf"
  • "text/enriched"
  • "text/richtext"
  • "text/uri-list"
  • "text/tab-separated-values"
  • "text/t140"
  • "text/rfc822-headers"
  • "text/parityfec"
  • "text/directory"
  • "text/css"
  • "text/calendar"
  • "application/x-java-serialized-object"
  • "text/plain"
  • "text/<other>"

例如，在 "text/html" 上选择 "text/sgml"，在 DataFlavor.plainTextFlavor 上选择 DataFlavor.stringFlavor。

如果两个或更多 flavor 共享数组中的最佳 MIME 类型，则需要检查 MIME 类型以查看它是否支持 charset 参数。

以下 MIME 类型支持（或被视为支持）charset 参数：

  • "text/sgml"
  • "text/xml"
  • "text/html"
  • "text/enriched"
  • "text/richtext"
  • "text/uri-list"
  • "text/directory"
  • "text/css"
  • "text/calendar"
  • "application/x-java-serialized-object"
  • "text/plain"
以下 MIME 类型不支持（或被视为不支持）charset 参数：
  • "text/rtf"
  • "text/tab-separated-values"
  • "text/t140"
  • "text/rfc822-headers"
  • "text/parityfec"
对于 "text/<other>" MIME 类型，首先 JRE 需要确定 MIME 类型是否支持 charset 参数，它将检查该参数是否显式列入任意选择的使用该 MIME 类型的 DataFlavor 中。如果是这样，则 JRE 将假定从该点开始，MIME 类型支持 charset 参数，并且不再进行检查。如果没有显式列入该参数，则 JRE 将假定从该点开始，MIME 类型不支持 charset 参数，并且不再进行检查。因为此检查是在任意选择的 DataFlavor 上执行的，所以如果 MIME 类型支持 charset 参数，开发人员就必须确保所有具有该 "text/<other>" MIME 类型的 DataFlavor 指定了该参数。开发人员不应该依赖 JRE 用平台的默认 charset 来替代 "text/<other>" DataFlavor。不遵守此限制将导致不确定的行为。

如果数组中的最佳 MIME 类型不支持 charset 参数，则共享 MIME 类型的 flavor 按照其表示形式类排序，顺序如下所示：java.io.InputStream、java.nio.ByteBuffer、[B、<其他>。

如果两个或多个 flavor 共享最佳表示形式类，或者任何 flavor 都不具有三个指定的表示形式中的一个，则随意地选择这些 flavor 中的一个。

如果数组中的最佳 MIME 类型支持 charset 参数，则共享 MIME 类型的 flavor 按照其表示形式类排序，顺序如下所示：java.io.Reader、java.lang.String、java.nio.CharBuffer、[C、<其他>。

如果两个或多个 flavor 共享最佳表示形式类，并且该表示形式是明确列出的四个表示形式中的一个，则非随意地选择这些 flavor 中的一个。但是，如果任何 flavor 都不是四个指定的表示形式中的一个，则通过其 charset 对 flavor 排序。Unicode charset，如 "UTF-16"、"UTF-8"、"UTF-16BE"、"UTF-16LE" 及其别名被认为是最佳的。其次选择平台默认的 charset 及其别名。"US-ASCII" 及其别名最差。所有其他 charset 都是按字母顺序选择的，但是只考虑 Java 平台的此实现所支持的 charset。

如果两个或更多 flavor 共享最佳 charset，则 flavor 再次按照其表示形式类排序，顺序如下所示：java.io.InputStream、java.nio.ByteBuffer、[B、<其他>。

如果两个或多个 flavor 共享最佳表示形式类，或者任何 flavor 都不具有三个指定的表示形式中的一个，则非随意地选择这些 flavor 中的一个。

参数：
availableFlavors - 可用 DataFlavor 的数组
返回：
按照以上指定规则的最佳（最高保真度）flavor；如果 availableFlavors 为 null、长度为零或包含非文本 flavor，则返回 null
从以下版本开始：
1.3

getReaderForText

public Reader getReaderForText(Transferable transferable)
                        throws UnsupportedFlavorException,
                               IOException
获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。受支持的表示形式类有：java.io.Reader、java.lang.String、java.nio.CharBuffer、[C、java.io.InputStream、java.nio.ByteBuffer 和 [B。

因为不支持 charset 参数的文本 flavor 是以非标准格式编码的，所以应为这种 flavor 调用此方法。但是，为了维护向后兼容性，如果为这样的 flavor 调用了此方法，那么此方法会将该 flavor 视为支持 charset 参数，并相应地尝试为其解码。有关不支持 charset 参数的文本 flavor 列表，请参阅 selectBestTextFlavor。

参数：
transferable - 将在此 flavor 中请求其数据的 Transferable
返回：
要读取 Transferable 数据的 Reader
抛出：
IllegalArgumentException - 如果表示形式类不是上文列出的七种之一
IllegalArgumentException - 如果 Transferable 包含 null 数据
NullPointerException - 如果 Transferable 为 null
UnsupportedEncodingException - 如果此 flavor 的表示形式为 java.io.InputStream、java.nio.ByteBuffer 或 [B，但 Java 平台的此实现不支持此 flavor 的编码
UnsupportedFlavorException - 如果 Transferable 不支持此 flavor
IOException - 如果因 I/O 错误而无法读取数据
从以下版本开始：
1.3
另请参见：
selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

getMimeType

public String getMimeType()
返回此 DataFlavor 的 MIME 类型字符串。

返回：
此 flavor 的 MIME 类型字符串

getRepresentationClass

public Class<?> getRepresentationClass()
返回请求此 DataFlavor 时，支持此 DataFlavor 的对象将返回的 Class。

返回：
请求此 DataFlavor 时，支持此 DataFlavor 的对象将返回的 Class。

getHumanPresentableName

public String getHumanPresentableName()
返回此 DataFlavor 表示的数据格式的得体的名称。此名称将由各个国家/地区来本地化。

返回：
此 DataFlavor 表示的数据格式的得体的名称

getPrimaryType

public String getPrimaryType()
返回此 DataFlavor 的基本 MIME 类型。

返回：
此 DataFlavor 的基本 MIME 类型

getSubType

public String getSubType()
返回此 DataFlavor 的子 MIME 类型。

返回：
此 DataFlavor 的子 MIME 类型

getParameter

public String getParameter(String paramName)
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。否则返回与 paramName 关联的 MIME 类型值。

参数：
paramName - 请求的参数名
返回：
name 参数的值；如果不存在关联值，则返回 null

setHumanPresentableName

public void setHumanPresentableName(String humanPresentableName)
设置此 DataFlavor 表示的数据格式的得体的名称。此名称将由各个国家/地区来本地化。

参数：
humanPresentableName - 新的得体的名称

equals

public boolean equals(Object o)
测试任意 Object 与此 DataFlavor 的相等性。当且仅当两个 DataFlavor 的 MIME 基本类型、子类型和表示形式类都相等时，才认为它们是相等的。此外，如果基本类型为 "text"，子类型表示支持 charset 参数的文本 flavor，而表示形式类不是 java.io.Reader、java.lang.String、java.nio.CharBuffer 或 [C，则 charset 参数也一定要相等。如果没有为一个或两个 DataFlavor 显式指定 charset，则假定使用平台默认的编码。有关支持 charset 参数的文本 flavor 列表，请参阅 selectBestTextFlavor。

覆盖：
类 Object 中的 equals
参数：
o - 要与 this 相比较的 Object
返回：
如果 that 等于此 DataFlavor，则返回 true；否则返回 false
另请参见：
selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

equals

public boolean equals(DataFlavor that)
测试 DataFlavor 与此 DataFlavor 的相等性。当且仅当两个 DataFlavor 的 MIME 基本类型、子类型和表示形式类都相等时，才认为它们是相等的。此外，如果基本类型为 "text"，子类型表示支持 charset 参数的文本 flavor，而表示形式类不是 java.io.Reader、java.lang.String、java.nio.CharBuffer 或 [C，则 charset 参数也一定要相等。如果没有为一个或两个 DataFlavor 显式指定 charset，则假定使用平台默认的编码。有关支持 charset 参数的文本 flavor 的列表，请参阅 selectBestTextFlavor。

参数：
that - 要与 this 相比较的 DataFlavor
返回：
如果 that 等于此 DataFlavor，则返回 true；否则返回 false
另请参见：
selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

equals

@Deprecated
public boolean equals(String s)
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。

只比较 mimeType 与传入的 String，在比较中不考虑 representationClass。如果需要比较 representationClass，则可以使用 equals(new DataFlavor(s))。

返回：
如果 String (MimeType) 相等，则返回 true。

hashCode

public int hashCode()
返回此 DataFlavor 的哈希码。对于两个相等的 DataFlavor，其哈希码也相等。对于与 DataFlavor.equals(String) 匹配的 String，不保证 DataFlavor 的哈希码等于 String 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 DataFlavor 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

match

public boolean match(DataFlavor that)
测试 DataFlavor 与此 DataFlavor 的相等性。当且仅当两个 DataFlavor 的 MIME 基本类型、子类型和表示形式类都相等时，才认为它们是相等的。此外，如果基本类型为 "text"，子类型表示支持 charset 参数的文本 flavor，而表示形式类不是 java.io.Reader、java.lang.String、java.nio.CharBuffer 或 [C，则 charset 参数也一定要相等。如果没有为一个或两个 DataFlavor 显式指定 charset，则假定使用平台默认的编码。有关支持 charset 参数的文本 flavor 的列表，请参阅 selectBestTextFlavor。

参数：
that - 要与 this 相比较的 DataFlavor
返回：
如果 that 等于此 DataFlavor，则返回 true；否则返回 false
从以下版本开始：
1.3
另请参见：
selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

isMimeTypeEqual

public boolean isMimeTypeEqual(String mimeType)
返回传入的 MIME 类型的字符串表示形式是否等于此 DataFlavor 的 MIME 类型。比较中不包括参数。

参数：
mimeType - MIME 类型的字符串表示形式
返回：
如果传入的 MIME 类型的字符串表示形式等于此 DataFlavor 的 MIME 类型，则返回 true；否则返回 false
抛出：
NullPointerException - 如果 mimeType 为 null

isMimeTypeEqual

public final boolean isMimeTypeEqual(DataFlavor dataFlavor)
比较两个 DataFlavor 对象的 mimeType。不考虑任何参数。

参数：
dataFlavor - 要比较的 DataFlavor
返回：
如果 MimeType 相等，则返回 true；否则返回 false

isMimeTypeSerializedObject

public boolean isMimeTypeSerializedObject()
DataFlavor 是否表示序列化对象？

getDefaultRepresentationClass

public final Class<?> getDefaultRepresentationClass()

getDefaultRepresentationClassAsString

public final String getDefaultRepresentationClassAsString()

isRepresentationClassInputStream

public boolean isRepresentationClassInputStream()
DataFlavor 是否表示 java.io.InputStream？

isRepresentationClassReader

public boolean isRepresentationClassReader()
返回此 DataFlavor 的表示形式类是 java.io.Reader 还是其子类。

从以下版本开始：
1.4

isRepresentationClassCharBuffer

public boolean isRepresentationClassCharBuffer()
返回此 DataFlavor 的表示形式类是 java.nio.CharBuffer 还是其子类。

从以下版本开始：
1.4

isRepresentationClassByteBuffer

public boolean isRepresentationClassByteBuffer()
返回此 DataFlavor 的表示形式类是 java.nio.ByteBuffer 还是其子类。

从以下版本开始：
1.4

isRepresentationClassSerializable

public boolean isRepresentationClassSerializable()
如果表示形式类可序列化，则返回 true。

返回：
如果表示形式类可序列化，则返回 true。

isRepresentationClassRemote

public boolean isRepresentationClassRemote()
如果表示形式类为 Remote，则返回 true。

返回：
如果表示形式类为 Remote，则返回 true。

isFlavorSerializedObjectType

public boolean isFlavorSerializedObjectType()
如果指定的 DataFlavor 表示序列化对象，则返回 true。

返回：
如果指定的 DataFlavor 表示序列化对象，则返回 true。

isFlavorRemoteObjectType

public boolean isFlavorRemoteObjectType()
如果指定的 DataFlavor 表示远程对象，则返回 true。

返回：
如果指定的 DataFlavor 表示远程对象，则返回 true。

isFlavorJavaFileListType

public boolean isFlavorJavaFileListType()
如果指定的 DataFlavor 表示 File 对象列表，则返回 true。

返回：
如果指定的 DataFlavor 表示 File 对象列表，则返回 true。

isFlavorTextType

public boolean isFlavorTextType()
返回此 DataFlavor 是否是 Java 平台此实现的有效文本 flavor。只有等于 DataFlavor.stringFlavor 和 DataFlavor，并且其基本 MIME 类型为 "text" 的 flavor 才是有效的文本 flavor。

如果此 flavor 支持 charset 参数，则它必须等于 DataFlavor.stringFlavor，或者其表示形式必须为 java.io.Reader、java.lang.String、java.nio.CharBuffer、[C、java.io.InputStream、java.nio.ByteBuffer 或 [B。如果表示形式为 java.io.InputStream、java.nio.ByteBuffer 或 [B，则此 flavor 的 charset 参数必须受 Java 平台此实现的支持。如果未指定 charset，则假定使用始终受支持的平台默认 charset。

如果此 flavor 不支持 charset 参数，则其表示形式必须为 java.io.InputStream、java.nio.ByteBuffer 或 [B。

有关支持 charset 参数的文本 flavor 的列表，请参阅 selectBestTextFlavor。

返回：
如果此 DataFlavor 为上述有效文本 flavor，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

writeExternal

public void writeExternal(ObjectOutput os)
                   throws IOException
序列化此 DataFlavor。

指定者：
接口 Externalizable 中的 writeExternal
参数：
os - 要写入对象的流
抛出：
IOException - 包含可能发生的所有 I/O 异常

readExternal

public void readExternal(ObjectInput is)
                  throws IOException,
                         ClassNotFoundException
根据 Serialized 状态还原此 DataFlavor。

指定者：
接口 Externalizable 中的 readExternal
参数：
is - 为了恢复对象而从中读取数据的流
抛出：
IOException - 如果发生 I/O 错误
ClassNotFoundException - 如果无法找到需要恢复的某个对象的类。

clone

public Object clone()
             throws CloneNotSupportedException
返回此 DataFlavor 的副本。

覆盖：
类 Object 中的 clone
返回：
此 DataFlavor 的副本
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable

normalizeMimeTypeParameter

@Deprecated
protected String normalizeMimeTypeParameter(String parameterName,
                                                       String parameterValue)
已过时。

为每个 MIME 类型参数对 DataFlavor 调用此方法可以使 DataFlavor 的子类处理特定参数，如文本/纯文本 charset 参数，其值是区分大小写的。（假定 MIME 类型参数值区分大小写。）

为每个参数名/值对调用此方法，应该返回 parameterValue 的标准化表示形式。 从 1.1 版本开始，此实现不再调用此方法。

normalizeMimeType

@Deprecated
protected String normalizeMimeType(String mimeType)
已过时。

为每个 MIME 类型字符串调用此方法可以使 DataFlavor 子类型有机会更改实现 MIME 类型标准化的方式。一种可能的使用情况是添加默认的参数/值对，以防传入的 MIME 类型字符串中参数/值对不存在的情况。 从 1.1 版本开始，此实现不再调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlavorEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
类 FlavorEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.datatransfer.FlavorEvent
所有已实现的接口：
Serializable
public class FlavorEvent
extends EventObject

FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。

从以下版本开始：
1.5
另请参见：
FlavorListener, 序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
FlavorEvent(Clipboard source)
构造一个 FlavorEvent 对象。
方法摘要
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FlavorEvent

public FlavorEvent(Clipboard source)
构造一个 FlavorEvent 对象。

参数：
source - 作为事件源的 Clipboard
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlavorListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
接口 FlavorListener

所有超级接口：
EventListener
public interface FlavorListener
extends EventListener

定义侦听 FlavorEvent 的对象。

从以下版本开始：
1.5

方法摘要
 void flavorsChanged(FlavorEvent e)
当侦听器的目标 Clipboard 已更改其可用的 DataFlavor 时调用。

方法详细信息

flavorsChanged

void flavorsChanged(FlavorEvent e)
当侦听器的目标 Clipboard 已更改其可用的 DataFlavor 时调用。

有些通知可能是多余的——它们不是由剪贴板上可用的 DataFlavor 集合的变化引起的。例如，如果剪贴板子系统假定系统剪贴板的内容已更改，但是无法断定其 DataFlavor 是否会在访问剪贴板时因某个异常条件而更改，则发送通知以确保不漏掉重要通知。一般来说，这些多余的通知都应该是偶然的。

参数：
e - FlavorEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlavorMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
接口 FlavorMap

所有已知子接口：
FlavorTable
所有已知实现类：
SystemFlavorMap
public interface FlavorMap

"native" (String)（对应于特定平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的双向 Map。FlavorMap 不必对称，但通常是对称的。

从以下版本开始：
1.2

方法摘要
Map<String,DataFlavor> | getFlavorsForNatives(String[] natives) 返回指定 String native 到其相应 DataFlavor 的 Map。
Map<DataFlavor,String> | getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其对应的 String native 的 Map。

方法详细信息

getNativesForFlavors

Map<DataFlavor,String> getNativesForFlavors(DataFlavor[] flavors)
返回指定 DataFlavor 到其对应的 String native 的 Map。返回的 Map 是此 FlavorMap 内部数据的可修改副本。客户端代码可以随意修改该 Map，而不会影响此对象。

参数：
flavors - 一组 DataFlavor，它们是返回 Map 的键集。如果指定了 null，则返回此 FlavorMap 当前所知的所有 DataFlavor 到对应 String native 的映射关系。
返回：
DataFlavor 到 String native 的 java.util.Map

getFlavorsForNatives

Map<String,DataFlavor> getFlavorsForNatives(String[] natives)
返回指定 String native 到其相应 DataFlavor 的 Map。返回的 Map 是此 FlavorMap 内部数据的可修改副本。客户端代码可以随意修改该 Map，而不会影响此对象。

参数：
native - 一组 String，它们是返回 Map 的键集。如果指定了 null，则返回此 FlavorMap 当前所知的所有 String native 到对应 DataFlavor 的映射关系。
返回：
String native 到 DataFlavor 的 java.util.Map
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlavorTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
接口 FlavorTable

所有超级接口：
FlavorMap
所有已知实现类：
SystemFlavorMap
public interface FlavorTable
extends FlavorMap

放宽传统一对一 Map 限制的 FlavorMap。允许将一种 flavor 映射到任意数量的 native，同样地，也允许将一种 native 映射到任何数量的 flavor。FlavorTable 不必对称，但通常是对称的。

从以下版本开始：
1.4

方法摘要
List<DataFlavor> | getFlavorsForNative(String nat) 返回与指定 String 对应的 DataFlavor 的 List。
List<String> | getNativesForFlavor(DataFlavor flav) 返回与指定 DataFlavor 对应的 String native 的 List。
从接口 java.awt.datatransfer.FlavorMap 继承的方法
getFlavorsForNatives, getNativesForFlavors

方法详细信息

getNativesForFlavor

List<String> getNativesForFlavor(DataFlavor flav)
返回与指定 DataFlavor 对应的 String native 的 List。该 List 的排序方式是从最好的 native 到最差的 native。即第一个 native 最能将指定 flavor 的数据反映到底层的本机平台。返回的 List 是此 FlavorTable 内部数据的可修改副本。客户端代码可以随意修改该 List，而不会影响此对象。

参数：
flav - 应该返回相应的 native 的 DataFlavor。如果指定了 null，则此 FlavorTable 当前已知的所有 native 都将以不确定的顺序返回。
返回：
java.lang.String 对象的 java.util.List，这些对象是特定于平台的数据格式的特定于平台的表示形式

getFlavorsForNative

List<DataFlavor> getFlavorsForNative(String nat)
返回与指定 String 对应的 DataFlavor 的 List。该 List 的排序方式是从最好的 DataFlavor 到最差的 DataFlavor。即第一个 DataFlavor 最能将指定 native 中的数据反映到 Java 应用程序。返回的 List 是此 FlavorTable 内部数据的可修改副本。客户端代码可以随意修改该 List，而不会影响此对象。

参数：
nat - 应该返回其对应 DataFlavor 的 native。如果指定了 null，则此 FlavorTable 当前已知的所有 DataFlavor 都将以不确定的顺序返回。
返回：
DataFlavor 对象的 java.util.List，可以将指定的特定于平台的 native 中特定于平台的数据转换为这些对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MimeTypeParseException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
类 MimeTypeParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.datatransfer.MimeTypeParseException
所有已实现的接口：
Serializable
public class MimeTypeParseException
extends Exception

对分析相关异常的 MimeType 进行封装的类

从以下版本开始：
1.3

构造方法摘要
MimeTypeParseException()
构造不带指定详细消息的 MimeTypeParseException。
MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MimeTypeParseException

public MimeTypeParseException()
构造不带指定详细消息的 MimeTypeParseException。

MimeTypeParseException

public MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringSelection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
类 StringSelection

java.lang.Object
    继承者  java.awt.datatransfer.StringSelection
所有已实现的接口：
ClipboardOwner, Transferable
public class StringSelection
extends Object
implements Transferable, ClipboardOwner

实现传输 String 所需能力的 Transferable。此 Transferable 可以正确支持 DataFlavor.stringFlavor 及所有等效 flavor。对 DataFlavor.plainTextFlavor 及所有等效 flavor 的支持已被废弃。不支持其他 DataFlavor。

另请参见：
DataFlavor.stringFlavor, DataFlavor.plainTextFlavor

构造方法摘要
StringSelection(String data)
创建能传输指定 String 的 Transferable。
方法摘要
Object | getTransferData(DataFlavor flavor) 如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
DataFlavor[] | getTransferDataFlavors() 返回 flavor 的数组，Transferable 可用该 flavor 提供数据。
boolean | isDataFlavorSupported(DataFlavor flavor) 返回所请求的 flavor 是否受此 Transferable 支持。
void | lostOwnership(Clipboard clipboard, Transferable contents) 通知此对象，它已不再是剪贴板所有者。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringSelection

public StringSelection(String data)
创建能传输指定 String 的 Transferable。

方法详细信息

getTransferDataFlavors

public DataFlavor[] getTransferDataFlavors()
返回 flavor 的数组，Transferable 可用该 flavor 提供数据。正确支持 DataFlavor.stringFlavor。对 DataFlavor.plainTextFlavor 的支持已被废弃。

指定者：
接口 Transferable 中的 getTransferDataFlavors
返回：
长度为 2 的数组，其元素为 DataFlavor. stringFlavor 和 DataFlavor.plainTextFlavor

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor flavor)
返回所请求的 flavor 是否受此 Transferable 支持。

指定者：
接口 Transferable 中的 isDataFlavorSupported
参数：
flavor - 所请求的数据 flavor
返回：
如果 flavor 等于 DataFlavor.stringFlavor 或 DataFlavor.plainTextFlavor，则为 true；如果 flavor 不是上述两种 flavor 之一，则为 false
抛出：
NullPointerException - 如果 flavor 为 null

getTransferData

public Object getTransferData(DataFlavor flavor)
                       throws UnsupportedFlavorException,
                              IOException
如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。如果需要的 flavor 是 DataFlavor.stringFlavor 或其等效 flavor，则返回表示这一选择的 String。如果需要的 flavor 是 DataFlavor.plainTextFlavor 或其等效 flavor，则返回 Reader。注：针对 DataFlavor.plainTextFlavor 及其等效的 DataFlavor 的此方法的行为与 DataFlavor.plainTextFlavor 的定义不一致。

指定者：
接口 Transferable 中的 getTransferData
参数：
flavor - 请求的数据 flavor
返回：
按照上面的描述使用请求的 flavor 返回数据
抛出：
UnsupportedFlavorException - 如果请求的数据 flavor 既不等效于 DataFlavor.stringFlavor 也不等效于 DataFlavor.plainTextFlavor
IOException - 如果检索数据时发生 IOException。默认情况下，StringSelection 不会抛出此异常，但是其子类可以。
NullPointerException - 如果 flavor 为 null
另请参见：
Reader

lostOwnership

public void lostOwnership(Clipboard clipboard,
                          Transferable contents)
从接口 ClipboardOwner 复制的描述
通知此对象，它已不再是剪贴板所有者。当其他应用程序或此应用程序中的其他对象维护剪贴板的所有权时，调用此方法。

指定者：
接口 ClipboardOwner 中的 lostOwnership
参数：
clipboard - 不再拥有的剪贴板
contents - 此所有者置于剪贴板上的内容
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SystemFlavorMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
类 SystemFlavorMap

java.lang.Object
    继承者  java.awt.datatransfer.SystemFlavorMap
所有已实现的接口：
FlavorMap, FlavorTable
public final class SystemFlavorMap
extends Object
implements FlavorMap, FlavorTable

SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。数据传输子系统使用此映射在 Java 和本机应用程序之间传输数据，以及在独立的 VM 中的 Java 应用程序之间传输数据。

在 Sun 参考实现中，默认的 SystemFlavorMap 是通过文件 jre/lib/flavormap.properties 和 AWT 属性 AWT.DnD.flavorMapFileURL 所引用的 URL 的内容初始化的。有关详细信息，请参阅 flavormap.properties。

从以下版本开始：
1.2

方法摘要
void | addFlavorForUnencodedNative(String nat, DataFlavor flav) 添加从单个 String native 到单个 DataFlavor 的映射。
void | addUnencodedNativeForFlavor(DataFlavor flav, String nat) 添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。
static DataFlavor | decodeDataFlavor(String nat) 解码 String native 以用作 DataFlavor。
static String | decodeJavaMIMEType(String nat) 解码 String native 以用作 Java MIME 类型。
static String | encodeDataFlavor(DataFlavor flav) 编码 DataFlavor 以用作 String native。
static String | encodeJavaMIMEType(String mimeType) 编码 MIME 类型以用作 String native。
static FlavorMap | getDefaultFlavorMap() 返回此线程的 ClassLoader 的默认 FlavorMap。
List<DataFlavor> | getFlavorsForNative(String nat) 返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。
Map<String,DataFlavor> | getFlavorsForNatives(String[] natives) 返回指定 String native 到其大多数首选 DataFlavor 的 Map。
List<String> | getNativesForFlavor(DataFlavor flav) 返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。
Map<DataFlavor,String> | getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
static boolean | isJavaMIMEType(String str) 返回指定的 String 是否为编码的 Java MIME 类型。
void | setFlavorsForNative(String nat, DataFlavor[] flavors) 放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。
void | setNativesForFlavor(DataFlavor flav, String[] natives) 放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getDefaultFlavorMap

public static FlavorMap getDefaultFlavorMap()
返回此线程的 ClassLoader 的默认 FlavorMap。

getNativesForFlavor

public List<String> getNativesForFlavor(DataFlavor flav)
返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。该 List 的排序方式是从最好的 native 到最差的 native。即第一个 native 最能将指定 flavor 的数据反映到底层的本机平台。

如果指定的 DataFlavor 以前对于数据传输子系统而言是未知的，并且数据传输子系统未能将此 DataFlavor 转换为任何现有的 native，则调用此方法将在指定的 DataFlavor 和其 MIME 类型的编码版本之间建立一个双向映射，作为其 native。

指定者：
接口 FlavorTable 中的 getNativesForFlavor
参数：
flav - 应该返回其对应 native 的 DataFlavor。如果指定 null，则数据传输子系统当前已知的所有 native 都将以不确定的顺序返回。
返回：
java.lang.String 对象的 java.util.List，这些对象是特定于平台的数据格式的特定于平台的表示形式
从以下版本开始：
1.4
另请参见：
encodeDataFlavor(java.awt.datatransfer.DataFlavor)

getFlavorsForNative

public List<DataFlavor> getFlavorsForNative(String nat)
返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。该 List 的排序方式是从最好的 DataFlavor 到最差的 DataFlavor。即第一个 DataFlavor 最能将指定 native 中的数据反映到 Java 应用程序。

如果指定的 native 以前对于数据传输子系统而言是未知的，并且该 native 编码正确，则调用此方法将在指定的 native 和 DataFlavor（其 MIME 类型为 native 的解码版本）之间建立一个双向映射。

如果指定的 native 不是正确编码的 native，并且此 native 的映射关系没有使用 setFlavorsForNative 进行修改，则 List 的内容是与平台有关的，但是并不能返回 null。

指定者：
接口 FlavorTable 中的 getFlavorsForNative
参数：
nat - 应该返回其对应 DataFlavor 的 native。如果指定 null，则数据传输子系统当前已知的所有 DataFlavor 都将以不确定的顺序返回。
返回：
DataFlavor 对象的 java.util.List，可以将特定于平台的指定 native 中特定于平台的数据转换为这些对象。
从以下版本开始：
1.4
另请参见：
encodeJavaMIMEType(java.lang.String)

getNativesForFlavors

public Map<DataFlavor,String> getNativesForFlavors(DataFlavor[] flavors)
返回指定 DataFlavor 到其大多数首选的 String native 的 Map。每一个 native 值都将与指定 flavor 的 getNativesForFlavor 所返回 List 中的第一个 native 相同。

如果指定的 DataFlavor 以前对于数据传输子系统是未知的，那么调用此方法将在指定的 DataFlavor 和其 MIME 类型的编码版本之间建立一个双向映射，作为其 native。

指定者：
接口 FlavorMap 中的 getNativesForFlavors
参数：
flavors - 一组 DataFlavor，它们是返回 Map 的键集。如果指定了 null，则返回对数据传输子系统已知的所有 DataFlavor 到其大多数首选 String native 的映射。
返回：
DataFlavor 到 String native 的 java.util.Map
另请参见：
getNativesForFlavor(java.awt.datatransfer.DataFlavor), encodeDataFlavor(java.awt.datatransfer.DataFlavor)

getFlavorsForNatives

public Map<String,DataFlavor> getFlavorsForNatives(String[] natives)
返回指定 String native 到其大多数首选 DataFlavor 的 Map。每一个 DataFlavor 值都将与指定 native 的 getFlavorsForNative 所返回 List 中的第一个 DataFlavor 相同。

如果指定的 native 以前对于数据传输子系统而言是未知的，并且该 native 编码正确，则调用此方法将在指定的 native 和 DataFlavor（其 MIME 类型为 native 的解码版本）之间建立一个双向映射。

指定者：
接口 FlavorMap 中的 getFlavorsForNatives
参数：
native - 一组 String，它们是返回 Map 的键集。如果指定了 null，则返回所有受支持 String native 到其大多数首选 DataFlavor 的映射。
返回：
String native 到 DataFlavor 的 java.util.Map
另请参见：
getFlavorsForNative(java.lang.String), encodeJavaMIMEType(java.lang.String)

addUnencodedNativeForFlavor

public void addUnencodedNativeForFlavor(DataFlavor flav,
                                        String nat)
添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。与 getNativesForFlavor 不同，该映射仅是单向建立的，并且不对 native 进行编码。要建立双向映射，请同时调用 addFlavorForUnencodedNative。新的映射优先级低于现有映射。如果从指定或相等 DataFlavor 到指定 String native 的映射已经存在，则此方法无效。

参数：
flav - 该映射的 DataFlavor 键
nat - 该映射的 String native 值
抛出：
NullPointerException - 如果 flav 或 nat 为 null
从以下版本开始：
1.4
另请参见：
addFlavorForUnencodedNative(java.lang.String, java.awt.datatransfer.DataFlavor)

setNativesForFlavor

public void setNativesForFlavor(DataFlavor flav,
                                String[] natives)
放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。与 getNativesForFlavor 不同，这些映射仅是单向建立的，并且不对 native 进行编码。要建立双向映射，请同时调用 setFlavorsForNative。数组中的第一个 native 表示最高优先级的映射。后续 native 所表示的映射的优先级是递减的。

如果数组包含多个引用相等 String native 的元素，则此方法将为其中第一个元素建立新映射，而忽略其余的元素。

建议客户机代码不要重置数据传输子系统建立的映射。此方法仅用于应用程序级的映射。

参数：
flav - 该映射的 DataFlavor 键
natives - 该映射的 String native 值
抛出：
NullPointerException - 如果 flav 或 native 为 null 或者 native 包含 null 元素
从以下版本开始：
1.4
另请参见：
setFlavorsForNative(java.lang.String, java.awt.datatransfer.DataFlavor[])

addFlavorForUnencodedNative

public void addFlavorForUnencodedNative(String nat,
                                        DataFlavor flav)
添加从单个 String native 到单个 DataFlavor 的映射。与 getFlavorsForNative 不同，该映射仅是单向建立的，并且不对 native 进行编码。要建立双向映射，请同时调用 addUnencodedNativeForFlavor。新的映射优先级低于现有映射。如果从指定 String native 到指定或相等 DataFlavor 的映射已经存在，则此方法无效。

参数：
nat - 该映射的 String native 键
flav - 该映射的 DataFlavor 值
抛出：
NullPointerException - 如果 nat 或 flav 为 null
从以下版本开始：
1.4
另请参见：
addUnencodedNativeForFlavor(java.awt.datatransfer.DataFlavor, java.lang.String)

setFlavorsForNative

public void setFlavorsForNative(String nat,
                                DataFlavor[] flavors)
放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。与 getFlavorsForNative 不同，这些映射将仅是单向建立的，并且不需要对 native 进行编码。要建立双向映射，请同时调用 setNativesForFlavor。数组中的第一个 DataFlavor 表示最高优先级的映射。后续 DataFlavor 所表示的映射的优先级是递减的。

如果数组包含多个引用相等 DataFlavor 的元素，则为其中的第一个元素建立新映射，而忽略其余的元素。

建议客户机代码不要重置数据传输子系统建立的映射。此方法仅用于应用程序级的映射。

参数：
nat - 映射的 String native 键
flavor - 映射的 DataFlavor 值
抛出：
NullPointerException - 如果 nat 或 flavor 为 null 或者 flavor 包含 null 元素
从以下版本开始：
1.4
另请参见：
setNativesForFlavor(java.awt.datatransfer.DataFlavor, java.lang.String[])

encodeJavaMIMEType

public static String encodeJavaMIMEType(String mimeType)
编码 MIME 类型以用作 String native。MIME 类型的编码表示形式的格式是与实现有关的。仅有的限制是：
  • 当且仅当 MIME 类型 String 为 null 时，编码表示形式为 null。
  • 两个非 null MIME 类型 String 的编码表示形式相等的条件是，当且仅当根据 String.equals(Object) 这些 String 相等。

Sun 对此方法的参考实现返回指定 MIME 类型 String，前缀为 JAVA_DATAFLAVOR:。

参数：
mimeType - 要编码的 MIME 类型
返回：
编码的 String，如果 mimeType 为 null，则返回 null

encodeDataFlavor

public static String encodeDataFlavor(DataFlavor flav)
编码 DataFlavor 以用作 String native。编码的 DataFlavor 的格式是与实现有关的。仅有的限制是：
  • 当且仅当指定 DataFlavor 为 null 或者其 MIME 类型 String 为 null 时，编码表示形式为 null。
  • 具有非 null MIME 类型 String 的两个非 null DataFlavor 的编码表示形式相等的条件是，根据 String.equals(Object) 当且仅当这些 DataFlavor 的 MIME 类型 String 相等。

Sun 对此方法的参考实现返回前缀为 JAVA_DATAFLAVOR: 的指定 DataFlavor 的 MIME 类型 String。

参数：
flav - 要编码的 DataFlavor
返回：
编码的 String，如果 flav 为 null 或者具有 null MIME 类型，则返回 null

isJavaMIMEType

public static boolean isJavaMIMEType(String str)
返回指定的 String 是否为编码的 Java MIME 类型。

参数：
str - 要测试的 String
返回：
如果对 String 进行了编码，则返回 true；否则返回 false

decodeJavaMIMEType

public static String decodeJavaMIMEType(String nat)
解码 String native 以用作 Java MIME 类型。

参数：
nat - 要解码的 String
返回：
解码的 Java MIME 类型，如果 nat 不是编码的 String native，则返回 null

decodeDataFlavor

public static DataFlavor decodeDataFlavor(String nat)
                                   throws ClassNotFoundException
解码 String native 以用作 DataFlavor。

参数：
nat - 要解码的 String
返回：
解码的 DataFlavor，如果 nat 不是编码的 String native，则返回 null
抛出：
ClassNotFoundException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Transferable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
接口 Transferable

所有已知实现类：
DataHandler, DropTargetContext.TransferableProxy, StringSelection
public interface Transferable

定义为传输操作提供数据所使用的类的接口。

有关如何使用 Swing 进行数据传输的信息，请参阅 The Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

方法摘要
Object | getTransferData(DataFlavor flavor) 返回一个对象，该对象表示将要被传输的数据。
DataFlavor[] | getTransferDataFlavors() 返回 DataFlavor 对象的数组，指示可用于提供数据的 flavor。
boolean | isDataFlavorSupported(DataFlavor flavor) 返回此对象是否支持指定的数据 flavor。

方法详细信息

getTransferDataFlavors

DataFlavor[] getTransferDataFlavors()
返回 DataFlavor 对象的数组，指示可用于提供数据的 flavor。该数组应该根据提供数据的偏好来排序（从描述最多的到描述最少的）。

返回：
数据 flavor 的数组，使用它来传输此数据

isDataFlavorSupported

boolean isDataFlavorSupported(DataFlavor flavor)
返回此对象是否支持指定的数据 flavor。

参数：
flavor - 请求的数据 flavor
返回：
boolean 指示是否支持该数据 flavor

getTransferData

Object getTransferData(DataFlavor flavor)
                       throws UnsupportedFlavorException,
                              IOException
返回一个对象，该对象表示将要被传输的数据。返回对象的类是由该 flavor 的表示类定义的。

参数：
flavor - 请求的数据 flavor
抛出：
IOException - 如果使用请求的 flavor 时数据不再可用。
UnsupportedFlavorException - 如果不支持请求的数据 flavor。
另请参见：
DataFlavor.getRepresentationClass()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedFlavorException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.datatransfer
类 UnsupportedFlavorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.datatransfer.UnsupportedFlavorException
所有已实现的接口：
Serializable
public class UnsupportedFlavorException
extends Exception

在此 flavor 中不支持所请求的数据的信号。

另请参见：
Transferable.getTransferData(java.awt.datatransfer.DataFlavor), 序列化表格

构造方法摘要
UnsupportedFlavorException(DataFlavor flavor)
构造一个 UnsupportedFlavorException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedFlavorException

public UnsupportedFlavorException(DataFlavor flavor)
构造一个 UnsupportedFlavorException。

参数：
flavor - 导致异常的 flavor 对象。可能为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.datatransfer (Java 2 Platform SE 6)

 java.awt.datatransfer
接口
ClipboardOwner
FlavorListener
FlavorMap
FlavorTable
Transferable
类
Clipboard
DataFlavor
FlavorEvent
StringSelection
SystemFlavorMap
异常
MimeTypeParseException
UnsupportedFlavorException


java.awt.datatransfer (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.datatransfer

提供在应用程序之间和在应用程序内部传输数据的接口和类。

请参见：
描述

接口摘要
ClipboardOwner | 为提供数据到剪贴板的类所定义的接口。
FlavorListener | 定义侦听 FlavorEvent 的对象。
FlavorMap | "native" (String)（对应于特定平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的双向 Map。
FlavorTable | 放宽传统一对一 Map 限制的 FlavorMap。
Transferable | 定义为传输操作提供数据所使用的类的接口。

类摘要
Clipboard | 此类实现一种使用剪切/复制/粘贴操作传输数据的机制。
DataFlavor | DataFlavor 提供有关数据的元信息。
FlavorEvent | FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。
StringSelection | 实现传输 String 所需能力的 Transferable。
SystemFlavorMap | SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。

异常摘要
MimeTypeParseException | 对分析相关异常的 MimeType 进行封装的类
UnsupportedFlavorException | 在此 flavor 中不支持所请求的数据的信号。

软件包 java.awt.datatransfer 的描述

提供在应用程序之间和在应用程序内部传输数据的接口和类。它定义了 "transferable" 对象的概念，该对象可以在应用程序之间或应用程序内部传输。它是一种通过实现 Transferable 接口标识自身为可传输的对象。

此外，它还提供一种剪贴板机制，剪贴板机制是一个对象，它临时保持可以在应用程序之间或应用程序内部传输的对象。剪贴板通常用于进行复制和粘贴操作。尽管可以创建在应用程序内部使用的剪贴板，但大多数应用程序还是会使用系统剪贴板，以确保数据可以在该平台上运行的多个应用程序之间传输。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.datatransfer 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.datatransfer 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.datatransfer.Clipboard
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.datatransfer.FlavorEvent
    • java.awt.datatransfer.StringSelection (implements java.awt.datatransfer.ClipboardOwner, java.awt.datatransfer.Transferable)
    • java.awt.datatransfer.SystemFlavorMap (implements java.awt.datatransfer.FlavorMap, java.awt.datatransfer.FlavorTable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.awt.datatransfer.MimeTypeParseException
        • java.awt.datatransfer.UnsupportedFlavorException

接口分层结构

  • java.awt.datatransfer.ClipboardOwner
  • java.util.EventListener
    • java.awt.datatransfer.FlavorListener
  • java.awt.datatransfer.FlavorMap
    • java.awt.datatransfer.FlavorTable
  • java.awt.datatransfer.Transferable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.datatransfer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.datatransfer
的使用

使用 java.awt.datatransfer 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 使用的 java.awt.datatransfer 中的类
Clipboard
此类实现一种使用剪切/复制/粘贴操作传输数据的机制。

java.awt.datatransfer 使用的 java.awt.datatransfer 中的类
Clipboard
此类实现一种使用剪切/复制/粘贴操作传输数据的机制。
ClipboardOwner
为提供数据到剪贴板的类所定义的接口。
DataFlavor
DataFlavor 提供有关数据的元信息。
FlavorEvent
FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。
FlavorListener
定义侦听 FlavorEvent 的对象。
FlavorMap
"native" (String)（对应于特定平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的双向 Map。
FlavorTable
放宽传统一对一 Map 限制的 FlavorMap。
Transferable
定义为传输操作提供数据所使用的类的接口。
UnsupportedFlavorException
在此 flavor 中不支持所请求的数据的信号。

java.awt.dnd 使用的 java.awt.datatransfer 中的类
DataFlavor
DataFlavor 提供有关数据的元信息。
FlavorMap
"native" (String)（对应于特定平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的双向 Map。
Transferable
定义为传输操作提供数据所使用的类的接口。
UnsupportedFlavorException
在此 flavor 中不支持所请求的数据的信号。

javax.accessibility 使用的 java.awt.datatransfer 中的类
DataFlavor
DataFlavor 提供有关数据的元信息。

javax.activation 使用的 java.awt.datatransfer 中的类
DataFlavor
DataFlavor 提供有关数据的元信息。
Transferable
定义为传输操作提供数据所使用的类的接口。
UnsupportedFlavorException
在此 flavor 中不支持所请求的数据的信号。

javax.swing 使用的 java.awt.datatransfer 中的类
Clipboard
此类实现一种使用剪切/复制/粘贴操作传输数据的机制。
DataFlavor
DataFlavor 提供有关数据的元信息。
Transferable
定义为传输操作提供数据所使用的类的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.datatransfer.FlavorEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.FlavorEvent
的使用

使用 FlavorEvent 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 FlavorEvent 的使用

参数类型为 FlavorEvent 的 java.awt.datatransfer 中的方法
 void FlavorListener.flavorsChanged(FlavorEvent e)
当侦听器的目标 Clipboard 已更改其可用的 DataFlavor 时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.datatransfer.FlavorListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.FlavorListener
的使用

使用 FlavorListener 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 FlavorListener 的使用

返回 FlavorListener 的 java.awt.datatransfer 中的方法
 FlavorListener[] Clipboard.getFlavorListeners()
返回一组目前在此 Clipboard 上注册的所有 FlavorListener。

参数类型为 FlavorListener 的 java.awt.datatransfer 中的方法
void | Clipboard.addFlavorListener(FlavorListener listener) 注册指定的 FlavorListener，以从此剪贴板接收 FlavorEvent。
void | Clipboard.removeFlavorListener(FlavorListener listener) 移除指定的 FlavorListener，使其不再从此 Clipboard 接收 FlavorEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.datatransfer.MimeTypeParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.MimeTypeParseException
的使用

没有 java.awt.datatransfer.MimeTypeParseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.datatransfer.StringSelection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.StringSelection
的使用

没有 java.awt.datatransfer.StringSelection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.datatransfer.UnsupportedFlavorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.UnsupportedFlavorException
的使用

使用 UnsupportedFlavorException 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.activation |

java.awt.datatransfer 中 UnsupportedFlavorException 的使用

抛出 UnsupportedFlavorException 的 java.awt.datatransfer 中的方法
Object | Clipboard.getData(DataFlavor flavor) 返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
Reader | DataFlavor.getReaderForText(Transferable transferable) 获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
Object | StringSelection.getTransferData(DataFlavor flavor) 如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
Object | Transferable.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示将要被传输的数据。

java.awt.dnd 中 UnsupportedFlavorException 的使用

抛出 UnsupportedFlavorException 的 java.awt.dnd 中的方法
 Object DropTargetContext.TransferableProxy.getTransferData(DataFlavor df)
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。

javax.activation 中 UnsupportedFlavorException 的使用

抛出 UnsupportedFlavorException 的 javax.activation 中的方法
Object | DataHandler.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示要传输的数据。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.datatransfer.ClipboardOwner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.ClipboardOwner
的使用

使用 ClipboardOwner 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 ClipboardOwner 的使用

实现 ClipboardOwner 的 java.awt.datatransfer 中的类
 class StringSelection
实现传输 String 所需能力的 Transferable。

声明为 ClipboardOwner 的 java.awt.datatransfer 中的字段
protected  ClipboardOwner Clipboard.owner

参数类型为 ClipboardOwner 的 java.awt.datatransfer 中的方法
 void Clipboard.setContents(Transferable contents, ClipboardOwner owner)
将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.datatransfer.Transferable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.Transferable
的使用

使用 Transferable 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.activation |
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.datatransfer 中 Transferable 的使用

实现 Transferable 的 java.awt.datatransfer 中的类
 class StringSelection
实现传输 String 所需能力的 Transferable。

声明为 Transferable 的 java.awt.datatransfer 中的字段
protected  Transferable Clipboard.contents

返回 Transferable 的 java.awt.datatransfer 中的方法
 Transferable Clipboard.getContents(Object requestor)
返回表示剪贴板当前内容的 transferable 对象。

参数类型为 Transferable 的 java.awt.datatransfer 中的方法
Reader | DataFlavor.getReaderForText(Transferable transferable) 获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
void | StringSelection.lostOwnership(Clipboard clipboard, Transferable contents)
void | ClipboardOwner.lostOwnership(Clipboard clipboard, Transferable contents) 通知此对象，它已不再是剪贴板所有者。
void | Clipboard.setContents(Transferable contents, ClipboardOwner owner) 将剪贴板的当前内容设置到指定的 transferable 对象，并将指定的剪贴板所有者作为新内容的所有者注册。

java.awt.dnd 中 Transferable 的使用

实现 Transferable 的 java.awt.dnd 中的类
protected  class DropTargetContext.TransferableProxy
TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。

声明为 Transferable 的 java.awt.dnd 中的字段
protected  Transferable DropTargetContext.TransferableProxy.transferable
封装的 Transferable 对象。

返回 Transferable 的 java.awt.dnd 中的方法
protected Transferable | DropTargetContext.createTransferableProxy(Transferable t, boolean local) 创建一个代理指定 Transferable 的 TransferableProxy。
Transferable | DragSourceContext.getTransferable() 返回与此 DragSourceContext 关联的 Transferable。
Transferable | DropTargetDragEvent.getTransferable() 此方法返回 Transferable 对象，该对象表示与当前的 drag 操作有关的数据。
Transferable | DropTargetDropEvent.getTransferable() 此方法返回与 drop 相关的 Transferable 对象。
protected Transferable | DropTargetContext.getTransferable() 获取此操作的 Transferable（代理）操作数

参数类型为 Transferable 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
protected Transferable | DropTargetContext.createTransferableProxy(Transferable t, boolean local) 创建一个代理指定 Transferable 的 TransferableProxy。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable) 在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 Transferable 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

javax.activation 中 Transferable 的使用

实现 Transferable 的 javax.activation 中的类
 class DataHandler
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。

javax.swing 中 Transferable 的使用

返回 Transferable 的 javax.swing 中的方法
protected Transferable | TransferHandler.createTransferable(JComponent c) 创建一个要用作数据传输源的 Transferable。
Transferable | TransferHandler.TransferSupport.getTransferable() 返回与此传输关联的 Transferable。

参数类型为 Transferable 的 javax.swing 中的方法
protected void | TransferHandler.exportDone(JComponent source, Transferable data, int action) 在导出数据之后调用。
Icon | TransferHandler.getVisualRepresentation(Transferable t) 返回一个建立传输外观的对象。
boolean | TransferHandler.importData(JComponent comp, Transferable t) 导致从剪贴板或 DND 放置操作向组件的传输。

参数类型为 Transferable 的 javax.swing 中的构造方法
TransferHandler.TransferSupport(Component component, Transferable transferable)
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.datatransfer.DataFlavor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.DataFlavor
的使用

使用 DataFlavor 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.datatransfer 中 DataFlavor 的使用

声明为 DataFlavor 的 java.awt.datatransfer 中的字段
static DataFlavor | DataFlavor.imageFlavor DataFlavor 表示 Java Image 类，其中：
static DataFlavor | DataFlavor.javaFileListFlavor 要将文件列表传入 Java（及底层平台）或从中传出，需要使用此类型/子类型的 DataFlavor 和 java.util.List 的表示形式类。
static DataFlavor | DataFlavor.plainTextFlavor 已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。
static DataFlavor | DataFlavor.stringFlavor DataFlavor 表示 Java Unicode String 类，其中：

返回 DataFlavor 的 java.awt.datatransfer 中的方法
static DataFlavor SystemFlavorMap.decodeDataFlavor(String nat)
解码 String native 以用作 DataFlavor。
 DataFlavor[] Clipboard.getAvailableDataFlavors()
返回 DataFlavor 的数组，其中提供了此剪贴板的当前内容。
static DataFlavor DataFlavor.getTextPlainUnicodeFlavor()
返回表示具有 Unicode 编码的纯文本的 DataFlavor，其中： representationClass = java.io.InputStream mimeType = "text/plain; charset=<platform default Unicode encoding>" Sun 的 Microsoft Windows 实现使用编码 utf-16le。
 DataFlavor[] StringSelection.getTransferDataFlavors()
返回 flavor 的数组，Transferable 可用该 flavor 提供数据。
 DataFlavor[] Transferable.getTransferDataFlavors()
返回 DataFlavor 对象的数组，指示可用于提供数据的 flavor。
static DataFlavor DataFlavor.selectBestTextFlavor(DataFlavor[] availableFlavors)
从 DataFlavor 数组中选择最佳文本 DataFlavor。

返回变量类型为 DataFlavor 的类型的 java.awt.datatransfer 中的方法
List<DataFlavor> | SystemFlavorMap.getFlavorsForNative(String nat) 返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。
List<DataFlavor> | FlavorTable.getFlavorsForNative(String nat) 返回与指定 String 对应的 DataFlavor 的 List。
Map<String,DataFlavor> | SystemFlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其大多数首选 DataFlavor 的 Map。
Map<String,DataFlavor> | FlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其相应 DataFlavor 的 Map。
Map<DataFlavor,String> | SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
Map<DataFlavor,String> | FlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其对应的 String native 的 Map。

参数类型为 DataFlavor 的 java.awt.datatransfer 中的方法
void | SystemFlavorMap.addFlavorForUnencodedNative(String nat, DataFlavor flav) 添加从单个 String native 到单个 DataFlavor 的映射。
void | SystemFlavorMap.addUnencodedNativeForFlavor(DataFlavor flav, String nat) 添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。
static String | SystemFlavorMap.encodeDataFlavor(DataFlavor flav) 编码 DataFlavor 以用作 String native。
boolean | DataFlavor.equals(DataFlavor that) 测试 DataFlavor 与此 DataFlavor 的相等性。
Object | Clipboard.getData(DataFlavor flavor) 返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
List<String> | SystemFlavorMap.getNativesForFlavor(DataFlavor flav) 返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。
List<String> | FlavorTable.getNativesForFlavor(DataFlavor flav) 返回与指定 DataFlavor 对应的 String native 的 List。
Map<DataFlavor,String> | SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
Map<DataFlavor,String> | FlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其对应的 String native 的 Map。
Object | StringSelection.getTransferData(DataFlavor flavor) 如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
Object | Transferable.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示将要被传输的数据。
boolean | Clipboard.isDataFlavorAvailable(DataFlavor flavor) 返回是否能够以指定的 DataFlavor 形式提供此剪贴板的当前内容。
boolean | StringSelection.isDataFlavorSupported(DataFlavor flavor) 返回所请求的 flavor 是否受此 Transferable 支持。
boolean | Transferable.isDataFlavorSupported(DataFlavor flavor) 返回此对象是否支持指定的数据 flavor。
boolean | DataFlavor.isMimeTypeEqual(DataFlavor dataFlavor) 比较两个 DataFlavor 对象的 mimeType。
boolean | DataFlavor.match(DataFlavor that) 测试 DataFlavor 与此 DataFlavor 的相等性。
static DataFlavor | DataFlavor.selectBestTextFlavor(DataFlavor[] availableFlavors) 从 DataFlavor 数组中选择最佳文本 DataFlavor。
void | SystemFlavorMap.setFlavorsForNative(String nat, DataFlavor[] flavors) 放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。
void | SystemFlavorMap.setNativesForFlavor(DataFlavor flav, String[] natives) 放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。

参数类型为 DataFlavor 的 java.awt.datatransfer 中的构造方法
UnsupportedFlavorException(DataFlavor flavor)
构造一个 UnsupportedFlavorException。

java.awt.dnd 中 DataFlavor 的使用

返回 DataFlavor 的 java.awt.dnd 中的方法
DataFlavor[] | DropTargetDragEvent.getCurrentDataFlavors() 此方法返回来自 DropTargetContext 的当前 DataFlavor。
DataFlavor[] | DropTargetDropEvent.getCurrentDataFlavors() 此方法返回当前的 DataFlavor。
protected DataFlavor[] | DropTargetContext.getCurrentDataFlavors() 获取此操作的 Transferable 操作数的可用 DataFlavor。
DataFlavor[] | DropTargetContext.TransferableProxy.getTransferDataFlavors() 返回一个 DataFlavor 对象数组，指示该数据的 flavor 是否可由封装的 transferable 提供。

返回变量类型为 DataFlavor 的类型的 java.awt.dnd 中的方法
List<DataFlavor> | DropTargetDragEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前的 DataFlavor
List<DataFlavor> | DropTargetDropEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前可用的 DataFlavor。
protected List<DataFlavor> | DropTargetContext.getCurrentDataFlavorsAsList() 此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。

参数类型为 DataFlavor 的 java.awt.dnd 中的方法
Object | DropTargetContext.TransferableProxy.getTransferData(DataFlavor df) 返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。
boolean | DropTargetDragEvent.isDataFlavorSupported(DataFlavor df) 此方法返回一个指示指定的 DataFlavor 是否受支持 boolean 值。
boolean | DropTargetDropEvent.isDataFlavorSupported(DataFlavor df) 此方法返回一个指示指定的 DataFlavor 是否可在源对象中使用的 boolean 值。
protected boolean | DropTargetContext.isDataFlavorSupported(DataFlavor df) 此方法返回一个 boolean 值，指示给定的 DataFlavor 是否受此 DropTargetContext 支持。
boolean | DropTargetContext.TransferableProxy.isDataFlavorSupported(DataFlavor flavor) 返回指定的数据 flavor 是否受封装的 transferable 支持。

javax.accessibility 中 DataFlavor 的使用

返回 DataFlavor 的 javax.accessibility 中的方法
 DataFlavor[] AccessibleStreamable.getMimeTypes()
返回此对象所支持的 MIME 类型的 DataFlavor 对象数组。

参数类型为 DataFlavor 的 javax.accessibility 中的方法
 InputStream AccessibleStreamable.getStream(DataFlavor flavor)
返回 DataFlavor 的 InputStream

javax.activation 中 DataFlavor 的使用

javax.activation 中 DataFlavor 的子类
 class ActivationDataFlavor
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。

返回 DataFlavor 的 javax.activation 中的方法
DataFlavor[] | DataContentHandler.getTransferDataFlavors() 返回一个 DataFlavor 对象数组，这些对象指示可用于提供数据的 flavor。
DataFlavor[] | DataHandler.getTransferDataFlavors() 返回此数据在其中可用的 DataFlavor。

参数类型为 DataFlavor 的 javax.activation 中的方法
boolean | ActivationDataFlavor.equals(DataFlavor dataFlavor) 将传入的 DataFlavor 与此 DataFlavor 进行比较；调用 isMimeTypeEqual 方法。
Object | DataHandler.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示要传输的数据。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。
boolean | DataHandler.isDataFlavorSupported(DataFlavor flavor) 返回此对象是否支持指定的数据 flavor。

javax.swing 中 DataFlavor 的使用

返回 DataFlavor 的 javax.swing 中的方法
 DataFlavor[] TransferHandler.TransferSupport.getDataFlavors()
返回此传输的数据 flavor。

参数类型为 DataFlavor 的 javax.swing 中的方法
boolean | TransferHandler.canImport(JComponent comp, DataFlavor[] transferFlavors) 指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。
boolean | TransferHandler.TransferSupport.isDataFlavorSupported(DataFlavor df) 返回是否支持给定的数据 flavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.datatransfer.SystemFlavorMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.SystemFlavorMap
的使用

没有 java.awt.datatransfer.SystemFlavorMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.datatransfer.FlavorTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.FlavorTable
的使用

使用 FlavorTable 的软件包
java.awt.datatransfer 提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.datatransfer 中 FlavorTable 的使用

实现 FlavorTable 的 java.awt.datatransfer 中的类
 class SystemFlavorMap
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.datatransfer.FlavorMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.datatransfer.FlavorMap
的使用

使用 FlavorMap 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.datatransfer 中 FlavorMap 的使用

java.awt.datatransfer 中 FlavorMap 的子接口
 interface FlavorTable
放宽传统一对一 Map 限制的 FlavorMap。

实现 FlavorMap 的 java.awt.datatransfer 中的类
 class SystemFlavorMap
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。

返回 FlavorMap 的 java.awt.datatransfer 中的方法
static FlavorMap SystemFlavorMap.getDefaultFlavorMap()
返回此线程的 ClassLoader 的默认 FlavorMap。

java.awt.dnd 中 FlavorMap 的使用

返回 FlavorMap 的 java.awt.dnd 中的方法
FlavorMap | DragSource.getFlavorMap() 此方法返回此 DragSource 的 FlavorMap。
FlavorMap | DropTarget.getFlavorMap() 获取与此 DropTarget 关联的 FlavorMap。

参数类型为 FlavorMap 的 java.awt.dnd 中的方法
void | DropTarget.setFlavorMap(FlavorMap fm) 设置 FlavorMap 与此 DropTarget 关联。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 FlavorMap 的 java.awt.dnd 中的构造方法
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.datatransfer.Clipboard 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.datatransfer.Clipboard
的使用

使用 Clipboard 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Clipboard 的使用

返回 Clipboard 的 java.awt 中的方法
abstract Clipboard | Toolkit.getSystemClipboard() 获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。
Clipboard | Toolkit.getSystemSelection() 以 Clipboard 对象的形式获取系统选择的一个实例。

java.awt.datatransfer 中 Clipboard 的使用

参数类型为 Clipboard 的 java.awt.datatransfer 中的方法
void | StringSelection.lostOwnership(Clipboard clipboard, Transferable contents)
void | ClipboardOwner.lostOwnership(Clipboard clipboard, Transferable contents) 通知此对象，它已不再是剪贴板所有者。

参数类型为 Clipboard 的 java.awt.datatransfer 中的构造方法
FlavorEvent(Clipboard source)
构造一个 FlavorEvent 对象。

javax.swing 中 Clipboard 的使用

参数类型为 Clipboard 的 javax.swing 中的方法
 void TransferHandler.exportToClipboard(JComponent comp, Clipboard clip, int action)
导致从给定组件到给定剪贴板的传输。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ActionEvent (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 ActionEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ActionEvent
所有已实现的接口：
Serializable
public class ActionEvent
extends AWTEvent

指示发生了组件定义的动作的语义事件。当特定于组件的动作（比如被按下）发生时，由组件（比如 Button）生成此高级别事件。事件被传递给每一个 ActionListener 对象，这些对象是使用组件的 addActionListener 方法注册的，用以接收这类事件。

注：要使用键盘在 Button 上触发 ActionEvent，请使用空格键。

实现 ActionListener 接口的对象在发生事件时获取此 ActionEvent。因此，侦听器不必处理个别鼠标移动和鼠标单击的细节，而是可以处理像“按下按钮”这样的“有意义”（语义）事件。

从以下版本开始：
1.1
另请参见：
ActionListener, Tutorial: Java 1.1 Event Model, 序列化表格

字段摘要
static int | ACTION_FIRST 用于标识动作事件的 ID 序列的起始编号。
static int | ACTION_LAST 用于标识动作事件的 ID 序列的结束编号。
static int | ACTION_PERFORMED 此事件 id 指示发生了有意义的动作。
static int | ALT_MASK alt 修饰符。
static int | CTRL_MASK Ctrl 修饰符。
static int | META_MASK meta 修饰符。
static int | SHIFT_MASK shift 修饰符。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ActionEvent(Object source, int id, String command)
构造一个 ActionEvent 对象。
ActionEvent(Object source, int id, String command, int modifiers)
使用修改键构造一个 ActionEvent 对象。
ActionEvent(Object source, int id, String command, long when, int modifiers)
使用指定修改键和时间戳构造一个 ActionEvent 对象。
方法摘要
String | getActionCommand() 返回与此动作相关的命令字符串。
int | getModifiers() 返回发生此动作事件期间按下的修改键。
long | getWhen() 返回发生此事件时的时间戳。
String | paramString() 返回标识此动作事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SHIFT_MASK

public static final int SHIFT_MASK
shift 修饰符。指示 shift 键在发生事件期间是否被按下的指示器。

另请参见：
常量字段值

CTRL_MASK

public static final int CTRL_MASK
Ctrl 修饰符。指示 Ctrl 键在发生事件期间是否被按下的指示器。

另请参见：
常量字段值

META_MASK

public static final int META_MASK
meta 修饰符。指示 meta 键在发生事件期间是否被按下的指示器。

另请参见：
常量字段值

ALT_MASK

public static final int ALT_MASK
alt 修饰符。指示 alt 键在发生事件期间是否被按下的指示器。

另请参见：
常量字段值

ACTION_FIRST

public static final int ACTION_FIRST
用于标识动作事件的 ID 序列的起始编号。

另请参见：
常量字段值

ACTION_LAST

public static final int ACTION_LAST
用于标识动作事件的 ID 序列的结束编号。

另请参见：
常量字段值

ACTION_PERFORMED

public static final int ACTION_PERFORMED
此事件 id 指示发生了有意义的动作。

另请参见：
常量字段值
构造方法详细信息

ActionEvent

public ActionEvent(Object source,
                   int id,
                   String command)
构造一个 ActionEvent 对象。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。为 null 的 command 字符串是合法的，但不建议使用。

参数：
source - 发起事件的对象
id - 标识事件的整数
command - 一个字符串，它可以用来指定与事件所相关的一条命令（可能是几个中的一个）
抛出：
IllegalArgumentException - 如果 source 为 null

ActionEvent

public ActionEvent(Object source,
                   int id,
                   String command,
                   int modifiers)
使用修改键构造一个 ActionEvent 对象。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。为 null 的 command 字符串是合法的，但不建议使用。

参数：
source - 发起事件的对象
id - 标识事件的整数
command - 一个字符串，它可以用来指定与事件所相关的一条命令（可能是几个中的一个）
modifiers - 进行此动作期间按下的修改键
抛出：
IllegalArgumentException - 如果 source 为 null

ActionEvent

public ActionEvent(Object source,
                   int id,
                   String command,
                   long when,
                   int modifiers)
使用指定修改键和时间戳构造一个 ActionEvent 对象。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。为 null 的 command 字符串是合法的，但不建议使用。

参数：
source - 发起事件的对象
id - 标识事件的整数
command - 一个字符串，它可以用来指定与事件所相关的一条命令（可能是几个中的一个）
when - 发生事件的时间
modifiers - 进行此动作期间按下的修改键
抛出：
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.4
方法详细信息

getActionCommand

public String getActionCommand()
返回与此动作相关的命令字符串。这使得 "modal" 组件可以由其当前的状态，通过此字符串来得到它能够产生的几个命令之一。例如，单个按钮可以在“显示详细信息”和“隐藏详细信息”之间切换。在所有情况下，源对象和事件都将是相同的，但命令字符串将会标识出实际对应的动作。

注意，如果将 null 命令字符串传递给此 ActionEvent 的构造方法，则此方法返回 null。

返回：
标识此事件命令的字符串

getWhen

public long getWhen()
返回发生此事件时的时间戳。因为 ActionEvent 是一个高级别语义事件，所以时间戳通常与基础 InputEvent 相同。

返回：
此事件的时间戳
从以下版本开始：
1.4

getModifiers

public int getModifiers()
返回发生此动作事件期间按下的修改键。

返回：
修饰符常量的按位或

paramString

public String paramString()
返回标识此动作事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其相关命令的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ActionListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 ActionListener

所有超级接口：
EventListener
所有已知子接口：
Action
所有已知实现类：
AbstractAction, AWTEventMulticaster, BasicDesktopPaneUI.CloseAction, BasicDesktopPaneUI.MaximizeAction, BasicDesktopPaneUI.MinimizeAction, BasicDesktopPaneUI.NavigateAction, BasicDesktopPaneUI.OpenAction, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.UpdateAction, BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicOptionPaneUI.ButtonActionListener, BasicScrollBarUI.ScrollListener, BasicSliderUI.ActionScroller, BasicSliderUI.ScrollListener, BasicSplitPaneUI.KeyboardDownRightHandler, BasicSplitPaneUI.KeyboardEndHandler, BasicSplitPaneUI.KeyboardHomeHandler, BasicSplitPaneUI.KeyboardResizeToggleHandler, BasicSplitPaneUI.KeyboardUpLeftHandler, BasicTreeUI.ComponentHandler, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreePageAction, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction, DefaultCellEditor.EditorDelegate, DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction, DefaultTreeCellEditor, DropTarget.DropTargetAutoScroller, FormView, HTMLEditorKit.HTMLTextAction, HTMLEditorKit.InsertHTMLTextAction, JComboBox, List.AccessibleAWTList, MetalFileChooserUI.DirectoryComboBoxAction, StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction, TextAction, ToolTipManager.insideTimerAction, ToolTipManager.outsideTimerAction, ToolTipManager.stillInsideTimerAction
public interface ActionListener
extends EventListener

用于接收操作事件的侦听器接口。对处理操作事件感兴趣的类可以实现此接口，而使用该类创建的对象可使用组件的 addActionListener 方法向该组件注册。在发生操作事件时，调用该对象的 actionPerformed 方法。

从以下版本开始：
1.1
另请参见：
ActionEvent, Tutorial: Java 1.1 Event Model

方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。

方法详细信息

actionPerformed

void actionPerformed(ActionEvent e)
发生操作时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdjustmentEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 AdjustmentEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.AdjustmentEvent
所有已实现的接口：
Serializable
public class AdjustmentEvent
extends AWTEvent

由 Adjustable 对象所发出的调整事件。

从以下版本开始：
1.1
另请参见：
Adjustable, AdjustmentListener, 序列化表格

字段摘要
static int | ADJUSTMENT_FIRST 标记调整事件 id 范围的第一个整数 id。
static int | ADJUSTMENT_LAST 标记调整事件 id 范围的最后一个整数 id。
static int | ADJUSTMENT_VALUE_CHANGED 调整值更改事件。
static int | BLOCK_DECREMENT 块减量调整类型。
static int | BLOCK_INCREMENT 块增量调整类型。
static int | TRACK 绝对跟踪调整类型。
static int | UNIT_DECREMENT 单位减量调整类型。
static int | UNIT_INCREMENT 单位增量调整类型。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
AdjustmentEvent(Adjustable source, int id, int type, int value)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
AdjustmentEvent(Adjustable source, int id, int type, int value, boolean isAdjusting)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
方法摘要
Adjustable | getAdjustable() 返回发起此事件的 Adjustable 对象。
int | getAdjustmentType() 返回导致值更改事件的调整类型。
int | getValue() 返回调整事件中的当前值。
boolean | getValueIsAdjusting() 如果此事件是多个调整事件之一，则返回 true。
String | paramString() 返回表示此 Event 状态的字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ADJUSTMENT_FIRST

public static final int ADJUSTMENT_FIRST
标记调整事件 id 范围的第一个整数 id。

另请参见：
常量字段值

ADJUSTMENT_LAST

public static final int ADJUSTMENT_LAST
标记调整事件 id 范围的最后一个整数 id。

另请参见：
常量字段值

ADJUSTMENT_VALUE_CHANGED

public static final int ADJUSTMENT_VALUE_CHANGED
调整值更改事件。

另请参见：
常量字段值

UNIT_INCREMENT

public static final int UNIT_INCREMENT
单位增量调整类型。

另请参见：
常量字段值

UNIT_DECREMENT

public static final int UNIT_DECREMENT
单位减量调整类型。

另请参见：
常量字段值

BLOCK_DECREMENT

public static final int BLOCK_DECREMENT
块减量调整类型。

另请参见：
常量字段值

BLOCK_INCREMENT

public static final int BLOCK_INCREMENT
块增量调整类型。

另请参见：
常量字段值

TRACK

public static final int TRACK
绝对跟踪调整类型。

另请参见：
常量字段值
构造方法详细信息

AdjustmentEvent

public AdjustmentEvent(Adjustable source,
                       int id,
                       int type,
                       int value)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Adjustable 对象
id - 事件类型
type - 调整类型
value - 当前调整值
抛出：
IllegalArgumentException - 如果 source 为 null

AdjustmentEvent

public AdjustmentEvent(Adjustable source,
                       int id,
                       int type,
                       int value,
                       boolean isAdjusting)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Adjustable 对象
id - 事件类型
type - 调整类型
value - 当前调整值
isAdjusting - 如果事件是连续多个调整事件之一，则该参数为 true，否则为 false
抛出：
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.4
方法详细信息

getAdjustable

public Adjustable getAdjustable()
返回发起此事件的 Adjustable 对象。

返回：
发起此事件的 Adjustable 对象

getValue

public int getValue()
返回调整事件中的当前值。

返回：
调整事件中的当前值

getAdjustmentType

public int getAdjustmentType()
返回导致值更改事件的调整类型。它将是以下值之一：
  • UNIT_INCREMENT
  • UNIT_DECREMENT
  • BLOCK_INCREMENT
  • BLOCK_DECREMENT
  • TRACK

返回：
上面列出的调整值之一

getValueIsAdjusting

public boolean getValueIsAdjusting()
如果此事件是多个调整事件之一，则返回 true。

返回：
如果此事件是多个调整事件之一，则返回 true；否则返回 false
从以下版本开始：
1.4

paramString

public String paramString()
从类 AWTEvent 复制的描述
返回表示此 Event 状态的字符串。此方法仅在进行调试的时候使用，返回的字符串的内容和格式也根据不同的实现而不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 AWTEvent 中的 paramString
返回：
此事件的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AdjustmentListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 AdjustmentListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster
public interface AdjustmentListener
extends EventListener

用于接收调整事件的侦听器接口。

从以下版本开始：
1.1

方法摘要
 void adjustmentValueChanged(AdjustmentEvent e)
在可调整的值发生更改时调用该方法。

方法详细信息

adjustmentValueChanged

void adjustmentValueChanged(AdjustmentEvent e)
在可调整的值发生更改时调用该方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTEventListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 AWTEventListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventListenerProxy
public interface AWTEventListener
extends EventListener

该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。与此包中的其他 EventListener 不同，AWTEventListener 被动地在 AWT （系统范围）内观察正被指派的事件。大多数应用程序从不使用此类；可以使用 AWTEventListener 的应用程序包含用于自动测试的事件记录器，以及诸如 Java Accessibility 包之类的设施。

对监视 AWT 事件感兴趣的类实现此接口，而使用该类创建的对象可使用 Toolkit 的 addAWTEventListener 方法向该 Toolkit 注册。当在 AWT 中的任意某个地方指派事件时，都会调用该对象的 eventDispatched 方法。

从以下版本开始：
1.2
另请参见：
AWTEvent, Toolkit.addAWTEventListener(java.awt.event.AWTEventListener, long), Toolkit.removeAWTEventListener(java.awt.event.AWTEventListener)

方法摘要
 void eventDispatched(AWTEvent event)
在 AWT 中指派事件时调用。

方法详细信息

eventDispatched

void eventDispatched(AWTEvent event)
在 AWT 中指派事件时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AWTEventListenerProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 AWTEventListenerProxy

java.lang.Object
    继承者  java.util.EventListenerProxy
        继承者  java.awt.event.AWTEventListenerProxy
所有已实现的接口：
AWTEventListener, EventListener
public class AWTEventListenerProxy
extends EventListenerProxy
implements AWTEventListener

扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。可以将此类的实例作为 AWTEventListener 添加到 Toolkit 对象。

Toolkit 的 getAWTEventListeners 方法可以返回 AWTEventListener 和 AWTEventListenerProxy 对象的混合物。

从以下版本开始：
1.4
另请参见：
Toolkit, EventListenerProxy

构造方法摘要
AWTEventListenerProxy(long eventMask, AWTEventListener listener)
将 AWTEventListener 绑定到特定事件掩码的构造方法。
方法摘要
void | eventDispatched(AWTEvent evt) 将属性更改事件转发给侦听器代理。
long | getEventMask() 返回与侦听器有关的事件掩码。
从类 java.util.EventListenerProxy 继承的方法
getListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AWTEventListenerProxy

public AWTEventListenerProxy(long eventMask,
                             AWTEventListener listener)
将 AWTEventListener 绑定到特定事件掩码的构造方法。

参数：
listener - 侦听器对象
eventMask - 要接收的事件类型的位图
方法详细信息

eventDispatched

public void eventDispatched(AWTEvent evt)
将属性更改事件转发给侦听器代理。

指定者：
接口 AWTEventListener 中的 eventDispatched
参数：
evt - 属性更改事件

getEventMask

public long getEventMask()
返回与侦听器有关的事件掩码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 ComponentAdapter

java.lang.Object
    继承者  java.awt.event.ComponentAdapter
所有已实现的接口：
ComponentListener, EventListener
直接已知子类：
BasicSliderUI.ComponentHandler, BasicTreeUI.ComponentHandler, JViewport.ViewListener
public abstract class ComponentAdapter
extends Object
implements ComponentListener

用于接收组件事件的抽象适配器类。此类中的方法为空。此类存在的目的是方便创建侦听器对象。

扩展此类来创建 ComponentEvent 侦听器并针对感兴趣的事件重写方法。（如果实现 ComponentListener 接口，则必须定义该接口中的所有方法。此抽象类将所有这些方法都定义为 null，所以您只需针对所关心的事件重写方法。）

使用类创建一个侦听器对象，然后使用组件的 addComponentListener 方法向组件注册。当组件的大小、位置或可见性发生更改时，可调用侦听器对象中的相关方法，并将 ComponentEvent 传递给它。

从以下版本开始：
1.1
另请参见：
ComponentEvent, ComponentListener, Tutorial: Writing a Component Listener

构造方法摘要
ComponentAdapter()
方法摘要
void | componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | componentMoved(ComponentEvent e) 组件位置更改时调用。
void | componentResized(ComponentEvent e) 组件大小更改时调用。
void | componentShown(ComponentEvent e) 组件变得可见时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComponentAdapter

public ComponentAdapter()
方法详细信息

componentResized

public void componentResized(ComponentEvent e)
组件大小更改时调用。

指定者：
接口 ComponentListener 中的 componentResized

componentMoved

public void componentMoved(ComponentEvent e)
组件位置更改时调用。

指定者：
接口 ComponentListener 中的 componentMoved

componentShown

public void componentShown(ComponentEvent e)
组件变得可见时调用。

指定者：
接口 ComponentListener 中的 componentShown

componentHidden

public void componentHidden(ComponentEvent e)
组件变得不可见时调用。

指定者：
接口 ComponentListener 中的 componentHidden
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 ComponentEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
所有已实现的接口：
Serializable
直接已知子类：
ContainerEvent, FocusEvent, InputEvent, PaintEvent, WindowEvent
public class ComponentEvent
extends AWTEvent

指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。

这些组件事件“仅”为通知目的而提供；AWT 将自动内部处理组件移动和调整大小，使 GUI 布局正常工作，而不管程序是否正接收这些事件。

除了充当其他组件相关事件（InputEvent、FocusEvent、WindowEvent 和 ContainerEvent）的基类之外，此类还定义了指示组件大小、位置或可见性方面的更改的事件。

当组件被移动、调整大小、呈现为不可见或再次可见时，此低级别事件由组件对象（比如 List）生成。事件被传递给每一个 ComponentListener 或 ComponentAdapter 对象，这些对象已使用组件的 addComponentListener 方法注册，以接收这类事件。（ComponentAdapter 对象实现 ComponentListener 接口。）当发生该事件时，所有这类侦听器对象都获得此 ComponentEvent。

从以下版本开始：
1.1
另请参见：
ComponentAdapter, ComponentListener, Tutorial: Writing a Component Listener, 序列化表格

字段摘要
static int | COMPONENT_FIRST 用于组件事件的 id 范围的起始编号。
static int | COMPONENT_HIDDEN 此事件指示组件呈现为不可见。
static int | COMPONENT_LAST 用于组件事件的 id 范围的结束编号。
static int | COMPONENT_MOVED 此事件指示组件位置已更改。
static int | COMPONENT_RESIZED 此事件指示组件大小已更改。
static int | COMPONENT_SHOWN 此事件指示组件已变得可见。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ComponentEvent(Component source, int id)
构造一个 ComponentEvent 对象。
方法摘要
Component | getComponent() 返回事件的始发者。
String | paramString() 返回标识此事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

COMPONENT_FIRST

public static final int COMPONENT_FIRST
用于组件事件的 id 范围的起始编号。

另请参见：
常量字段值

COMPONENT_LAST

public static final int COMPONENT_LAST
用于组件事件的 id 范围的结束编号。

另请参见：
常量字段值

COMPONENT_MOVED

public static final int COMPONENT_MOVED
此事件指示组件位置已更改。

另请参见：
常量字段值

COMPONENT_RESIZED

public static final int COMPONENT_RESIZED
此事件指示组件大小已更改。

另请参见：
常量字段值

COMPONENT_SHOWN

public static final int COMPONENT_SHOWN
此事件指示组件已变得可见。

另请参见：
常量字段值

COMPONENT_HIDDEN

public static final int COMPONENT_HIDDEN
此事件指示组件呈现为不可见。

另请参见：
常量字段值
构造方法详细信息

ComponentEvent

public ComponentEvent(Component source,
                      int id)
构造一个 ComponentEvent 对象。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Component
id - 指示事件类型的整数
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

getComponent

public Component getComponent()
返回事件的始发者。

返回：
发起事件的 Component 对象，如果该对象不是一个 Component，则返回 null。

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 ComponentListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicInternalFrameUI.ComponentHandler, BasicSliderUI.ComponentHandler, BasicTreeUI.ComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, ComponentAdapter, JViewport.ViewListener
public interface ComponentListener
extends EventListener

用于接收组件事件的侦听器接口。对处理组件事件感兴趣的类要么实现此接口（以及它包含的所有方法），要么扩展抽象 ComponentAdapter 类（只重写感兴趣的方法）。然后，根据该类创建的侦听器对象使用组件的 addComponentListener 方法向该组件注册。当组件的大小、位置或可见性发生更改时，可调用侦听器对象中的相关方法，并将 ComponentEvent 传递给它。

这些组件事件“仅”为通知目的而提供；AWT 将自动内部处理组件移动和调整大小，使 GUI 布局正常工作，而不管程序是否注册了一个 ComponentListener。

从以下版本开始：
1.1
另请参见：
ComponentAdapter, ComponentEvent, Tutorial: Writing a Component Listener

方法摘要
void | componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | componentMoved(ComponentEvent e) 组件位置更改时调用。
void | componentResized(ComponentEvent e) 组件大小更改时调用。
void | componentShown(ComponentEvent e) 组件变得可见时调用。

方法详细信息

componentResized

void componentResized(ComponentEvent e)
组件大小更改时调用。

componentMoved

void componentMoved(ComponentEvent e)
组件位置更改时调用。

componentShown

void componentShown(ComponentEvent e)
组件变得可见时调用。

componentHidden

void componentHidden(ComponentEvent e)
组件变得不可见时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContainerAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 ContainerAdapter

java.lang.Object
    继承者  java.awt.event.ContainerAdapter
所有已实现的接口：
ContainerListener, EventListener
public abstract class ContainerAdapter
extends Object
implements ContainerListener

用于接收容器事件的抽象适配器类。此类中的方法为空。此类存在的目的只是为了便于创建侦听器对象。

扩展此类可创建 ContainerEvent 侦听器并针对感兴趣的事件重写方法。（如果实现 ContainerListener 接口，则必须定义该接口中的所有方法。此抽象类将所有这些方法都定义为 null，所以您只需针对所关心的事件重写方法。）

使用扩展的类创建一个侦听器对象，然后使用组件的 addContainerListener 方法向组件注册。当容器的内容因为添加和移除组件而更改时，可调用侦听器对象中的相关方法，并将 ContainerEvent 传递给它。

从以下版本开始：
1.1
另请参见：
ContainerEvent, ContainerListener, Tutorial: Writing a Container Listener

构造方法摘要
ContainerAdapter()
方法摘要
void | componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContainerAdapter

public ContainerAdapter()
方法详细信息

componentAdded

public void componentAdded(ContainerEvent e)
已将组件添加到容器中时调用。

指定者：
接口 ContainerListener 中的 componentAdded

componentRemoved

public void componentRemoved(ContainerEvent e)
已从容器中移除组件时调用。

指定者：
接口 ContainerListener 中的 componentRemoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContainerEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 ContainerEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.ContainerEvent
所有已实现的接口：
Serializable
public class ContainerEvent
extends ComponentEvent

指示容器内容因为添加或移除组件而更改的低级别事件。

这些容器事件“仅”为通知目的而提供；AWT 将自动处理内部容器内容的更改，使程序正常工作，而不管该程序是否接收这些事件。

在向容器对象（比如 Panel）添加组件或从中移除组件时，容器对象将生成此低级别事件。事件被传递给每一个 ContainerListener 或 ContainerAdapter 对象，这些对象使用组件的 addContainerListener 方法注册，以接收这类事件。（ContainerAdapter 对象实现 ContainerListener 接口。）当发生该事件时，所有这类侦听器对象都获得此 ContainerEvent。

从以下版本开始：
1.1
另请参见：
ContainerAdapter, ContainerListener, Tutorial: Writing a Container Listener, 序列化表格

字段摘要
static int | COMPONENT_ADDED 此事件指示组件已被添加到容器中。
static int | COMPONENT_REMOVED 此事件指示已从容器中移除组件。
static int | CONTAINER_FIRST 用于容器事件的 id 范围的起始编号。
static int | CONTAINER_LAST 用于容器事件的 id 范围的结束编号。
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ContainerEvent(Component source, int id, Component child)
构造一个 ContainerEvent 对象。
方法摘要
Component | getChild() 返回受事件影响的组件。
Container | getContainer() 返回事件的始发者。
String | paramString() 返回标识此事件的参数字符串。
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

CONTAINER_FIRST

public static final int CONTAINER_FIRST
用于容器事件的 id 范围的起始编号。

另请参见：
常量字段值

CONTAINER_LAST

public static final int CONTAINER_LAST
用于容器事件的 id 范围的结束编号。

另请参见：
常量字段值

COMPONENT_ADDED

public static final int COMPONENT_ADDED
此事件指示组件已被添加到容器中。

另请参见：
常量字段值

COMPONENT_REMOVED

public static final int COMPONENT_REMOVED
此事件指示已从容器中移除组件。

另请参见：
常量字段值
构造方法详细信息

ContainerEvent

public ContainerEvent(Component source,
                      int id,
                      Component child)
构造一个 ContainerEvent 对象。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Component 对象（容器）
id - 指示事件类型的整数
child - 被添加或移除的组件
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

getContainer

public Container getContainer()
返回事件的始发者。

返回：
发起事件的 Container 对象，如果该对象不是一个 Container，则返回 null。

getChild

public Component getChild()
返回受事件影响的组件。

返回：
被添加或移除的 Component 对象

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 ComponentEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContainerListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 ContainerListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicToolBarUI.ToolBarContListener, Container.AccessibleAWTContainer.AccessibleContainerHandler, ContainerAdapter, JComponent.AccessibleJComponent.AccessibleContainerHandler, MetalToolBarUI.MetalContainerListener
public interface ContainerListener
extends EventListener

用于接收容器事件的侦听器接口。对处理容器事件感兴趣的类要么实现此接口（以及它包含的所有方法），要么扩展抽象 ContainerAdapter 类（只重写感兴趣的方法）。然后，根据该类创建的侦听器对象使用组件的 addContainerListener 方法向该组件注册。当容器的内容因为添加和移除组件而更改时，可调用侦听器对象中的相关方法，并将 ContainerEvent 传递给它。

这些容器事件“仅”为通知目的而提供；AWT 将自动内部处理添加和移除操作，使程序正常工作，而不管该程序是否注册了一个 ComponentListener。

从以下版本开始：
1.1
另请参见：
ContainerAdapter, ContainerEvent, Tutorial: Writing a Container Listener

方法摘要
void | componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。

方法详细信息

componentAdded

void componentAdded(ContainerEvent e)
已将组件添加到容器中时调用。

componentRemoved

void componentRemoved(ContainerEvent e)
已从容器中移除组件时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FocusAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 FocusAdapter

java.lang.Object
    继承者  java.awt.event.FocusAdapter
所有已实现的接口：
FocusListener, EventListener
直接已知子类：
BasicSplitPaneUI.FocusHandler, BasicTabbedPaneUI.FocusHandler
public abstract class FocusAdapter
extends Object
implements FocusListener

用于接收键盘焦点事件的抽象适配器类。此类中的方法为空。此类存在的目的是方便创建侦听器对象。

扩展此类来创建 FocusEvent 侦听器，并针对感兴趣的事件重写方法。（如果实现 FocusListener 接口，则必须定义该接口中的所有方法。此抽象类将所有这些方法都定义为 null，所以您只需针对所关心的事件重写方法。）

使用扩展的类创建一个侦听器对象，然后使用组件的 addFocusListener 方法向组件注册。当组件获得或失去键盘焦点时，可调用侦听器对象中的相关方法，并将 FocusEvent 传递给它。

从以下版本开始：
1.1
另请参见：
FocusEvent, FocusListener, Tutorial: Writing a Focus Listener

构造方法摘要
FocusAdapter()
方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FocusAdapter

public FocusAdapter()
方法详细信息

focusGained

public void focusGained(FocusEvent e)
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent e)
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FocusEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 FocusEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.FocusEvent
所有已实现的接口：
Serializable
public class FocusEvent
extends ComponentEvent

指示 Component 已获得或失去输入焦点的低级别事件。此低级别事件由 Component（比如 TextField）生成。事件被传递给每一个 FocusListener 或 FocusAdapter 对象，这些对象使用 Component 的 addFocusListener 方法注册，以接收这类事件。（FocusAdapter 对象实现 FocusListener 接口。）当发生该事件时，所有这类侦听器对象都将获得此 FocusEvent。

有两个焦点事件级别：持久性的和暂时性的。当焦点直接从一个 Component 移动到另一个 Component 时（比如通过调用 requestFocus()，或者用户使用 TAB 键遍历 Component 时），发生持久性焦点更改事件。当由于另一个操作（比如释放 Window 或拖动 Scrollbar）间接引起 Component 暂时失去焦点时，发生暂时性焦点更改事件。在这种情况下，一旦该操作结束，将自动恢复原始焦点状态，对于释放 Window 的情况来说，重新激活 Window 就能恢复原始焦点状态。持久性焦点事件和暂时性焦点事件使用 FOCUS_GAINED 和 FOCUS_LOST 事件 id 传递；可以使用 isTemporary() 方法区分事件的级别。

从以下版本开始：
1.1
另请参见：
FocusAdapter, FocusListener, Tutorial: Writing a Focus Listener, 序列化表格

字段摘要
static int | FOCUS_FIRST 用于焦点事件的 id 范围的起始编号。
static int | FOCUS_GAINED 此事件指示 Component 现在是焦点所有者。
static int | FOCUS_LAST 用于焦点事件的 id 范围的结束编号。
static int | FOCUS_LOST 此事件指示 Component 不再是焦点所有者。
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
FocusEvent(Component source, int id)
构造一个 FocusEvent 对象，并将它标识为一个持久性焦点更改。
FocusEvent(Component source, int id, boolean temporary)
构造一个 FocusEvent 对象，并将标识更改是否为暂时的。
FocusEvent(Component source, int id, boolean temporary, Component opposite)
构造一个 FocusEvent 对象，它具有指定的暂时状态和对立 Component。
方法摘要
Component | getOppositeComponent() 返回此焦点更改中涉及的另一个 Component。
boolean | isTemporary() 将焦点更改事件标识为暂时性的或持久性的。
String | paramString() 返回标识此事件的参数字符串。
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

FOCUS_FIRST

public static final int FOCUS_FIRST
用于焦点事件的 id 范围的起始编号。

另请参见：
常量字段值

FOCUS_LAST

public static final int FOCUS_LAST
用于焦点事件的 id 范围的结束编号。

另请参见：
常量字段值

FOCUS_GAINED

public static final int FOCUS_GAINED
此事件指示 Component 现在是焦点所有者。

另请参见：
常量字段值

FOCUS_LOST

public static final int FOCUS_LOST
此事件指示 Component 不再是焦点所有者。

另请参见：
常量字段值
构造方法详细信息

FocusEvent

public FocusEvent(Component source,
                  int id,
                  boolean temporary,
                  Component opposite)
构造一个 FocusEvent 对象，它具有指定的暂时状态和对立 Component。对立 Component 是在此焦点更改中涉及的另一个 Component。对于 FOCUS_GAINED 事件，该组件是失去焦点的 Component。对于 FOCUS_LOST 事件，该组件是获得焦点的 Component。如果此焦点更改发生在本机应用程序、不同 VM 中的 Java 应用程序或没有其他 Component 的情况下，则对立 Component 为 null。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Component
id - FOCUS_GAINED 或 FOCUS_LOST
temporary - 如果焦点更改是暂时的，则为 true；否则为 false
opposite - 焦点更改中涉及的另一个 Component，或者为 null
抛出：
IllegalArgumentException - 如果 source 为 null

FocusEvent

public FocusEvent(Component source,
                  int id,
                  boolean temporary)
构造一个 FocusEvent 对象，并将标识更改是否为暂时的。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Component
id - 指示事件类型的整数
temporary - 如果焦点更改是暂时的，则为 true；否则为 false
抛出：
IllegalArgumentException - 如果 source 为 null

FocusEvent

public FocusEvent(Component source,
                  int id)
构造一个 FocusEvent 对象，并将它标识为一个持久性焦点更改。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Component
id - 指示事件类型的整数
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

isTemporary

public boolean isTemporary()
将焦点更改事件标识为暂时性的或持久性的。

返回：
如果焦点更改是暂时性的，则返回 true；否则返回 false

getOppositeComponent

public Component getOppositeComponent()
返回此焦点更改中涉及的另一个 Component。对于 FOCUS_GAINED 事件，该组件是失去焦点的 Component。对于 FOCUS_LOST 事件，该组件是获得焦点的 Component。如果此焦点更改发生在本机应用程序、不同 VM 或上下文中的 Java 应用程序或没有其他 Component 的情况下，则返回 null。

返回：
焦点更改中涉及的另一个 Component，或返回 null
从以下版本开始：
1.4

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 ComponentEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FocusListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 FocusListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicButtonListener, BasicComboBoxEditor, BasicComboBoxEditor.UIResource, BasicComboBoxUI.FocusHandler, BasicListUI.FocusHandler, BasicSliderUI.FocusHandler, BasicSplitPaneUI.FocusHandler, BasicTabbedPaneUI.FocusHandler, BasicTableUI.FocusHandler, BasicTextUI.BasicCaret, BasicToolBarUI.ToolBarFocusListener, BasicTreeUI.FocusHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler, DefaultCaret, FocusAdapter, JComponent.AccessibleJComponent.AccessibleFocusHandler, MetalComboBoxEditor, MetalComboBoxEditor.UIResource
public interface FocusListener
extends EventListener

用于接收组件上的键盘焦点事件的侦听器接口。对处理焦点事件感兴趣的类要么实现此接口（以及它包含的所有方法），要么扩展抽象 FocusAdapter 类（只重写感兴趣的方法）。然后，根据该类创建的侦听器对象使用组件的 addFocusListener 方法向该组件注册。当组件获得或失去键盘焦点时，可调用侦听器对象中的相关方法，并将 FocusEvent 传递给它。

从以下版本开始：
1.1
另请参见：
FocusAdapter, FocusEvent, Tutorial: Writing a Focus Listener

方法摘要
void | focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent e) 组件失去键盘焦点时调用。

方法详细信息

focusGained

void focusGained(FocusEvent e)
组件获得键盘焦点时调用。

focusLost

void focusLost(FocusEvent e)
组件失去键盘焦点时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HierarchyBoundsAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 HierarchyBoundsAdapter

java.lang.Object
    继承者  java.awt.event.HierarchyBoundsAdapter
所有已实现的接口：
HierarchyBoundsListener, EventListener
public abstract class HierarchyBoundsAdapter
extends Object
implements HierarchyBoundsListener

用于接收祖先的移动和大小重调事件的抽象适配器类。此类中的方法为空。此类存在的目的是方便创建侦听器对象。

扩展此类并针对感兴趣的事件重写方法。（如果实现 HierarchyBoundsListener 接口，则必须同时定义该接口中的两个方法。此抽象类将两个方法都定义为 null，所以只需针对关心的事件定义方法。）

使用类创建一个侦听器对象，然后使用 Component 的 addHierarchyBoundsListener 方法向该 Component 注册。当 Component 所属的层次结构因为祖先组件的大小调整或移动而更改时，可调用侦听器对象中的相关方法，并将 HierarchyEvent 传递给它。

从以下版本开始：
1.3
另请参见：
HierarchyBoundsListener, HierarchyEvent

构造方法摘要
HierarchyBoundsAdapter()
方法摘要
void | ancestorMoved(HierarchyEvent e) 移动源的祖先时调用。
void | ancestorResized(HierarchyEvent e) 调整源的祖先的大小时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HierarchyBoundsAdapter

public HierarchyBoundsAdapter()
方法详细信息

ancestorMoved

public void ancestorMoved(HierarchyEvent e)
移动源的祖先时调用。

指定者：
接口 HierarchyBoundsListener 中的 ancestorMoved

ancestorResized

public void ancestorResized(HierarchyEvent e)
调整源的祖先的大小时调用。

指定者：
接口 HierarchyBoundsListener 中的 ancestorResized
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HierarchyBoundsListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 HierarchyBoundsListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, HierarchyBoundsAdapter
public interface HierarchyBoundsListener
extends EventListener

用于接收祖先的移动和大小调整事件的侦听器接口。对处理这些事件感兴趣的类要么实现此接口（以及它包含的所有方法），要么扩展抽象 HierarchyBoundsAdapter 类（只重写感兴趣的方法）。然后，根据该类创建的侦听器对象使用 Component 的 addHierarchyBoundsListener 方法向该 Component 注册。当 Component 所属的层次结构因为祖先组件的大小调整或移动而更改时，可调用侦听器对象中的相关方法，并将 HierarchyEvent 传递给它。

这些层次结构事件“仅”为通知目的而提供；AWT 将自动内部处理层次结构更改，使 GUI 布局正常工作，而不管程序是否注册了一个 HierarchyBoundsListener。

从以下版本开始：
1.3
另请参见：
HierarchyBoundsAdapter, HierarchyEvent

方法摘要
void | ancestorMoved(HierarchyEvent e) 移动源的祖先时调用。
void | ancestorResized(HierarchyEvent e) 调整源的祖先的大小时调用。

方法详细信息

ancestorMoved

void ancestorMoved(HierarchyEvent e)
移动源的祖先时调用。

ancestorResized

void ancestorResized(HierarchyEvent e)
调整源的祖先的大小时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HierarchyEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 HierarchyEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.HierarchyEvent
所有已实现的接口：
Serializable
public class HierarchyEvent
extends AWTEvent

指示 Component 所属的 Component 层次结构发生更改的事件。

  • 层次结构更改事件 (HierarchyListener)
    • 添加一个祖先
    • 移除一个祖先
    • 层次结构变得可以显示
    • 层次结构变得不可显示
    • 显示在屏幕上的层次结构（既包括可见的，也包括不可见的）
    • 屏幕上隐藏的层次结构（可见的或不可见的）
  • 祖先重塑事件 (HierarchyBoundsListener)
    • 重新调整祖先的大小
    • 移动一个祖先

层次结构事件“仅”为通知目的而提供。AWT 将自动内部处理层次结构的更改，使 GUI 布局和可显示性正常工作，而不管该程序是否接收这些事件。

此事件由 Container 对象（比如 Panel）在 Container 被添加、移除、移动或调整大小时生成，并顺着层次结构向下传递。Component 对象在调用其 addNotify、removeNotify、show 或 hide 方法时，也生成此事件。ANCESTOR_MOVED 和 ANCESTOR_RESIZED 事件被指派到每个 HierarchyBoundsListener 或 HierarchyBoundsAdapter 对象，这些对象已使用 Component 的 addHierarchyBoundsListener 方法注册，以接收这类事件。（HierarchyBoundsAdapter 对象实现 HierarchyBoundsListener 接口。）HIERARCHY_CHANGED 事件被指派到每个 HierarchyListener，这些对象已使用 Component 的 addHierarchyListener 方法注册，以接收这类事件。当发生该事件时，所有这类侦听器对象都获取此 HierarchyEvent。

从以下版本开始：
1.3
另请参见：
HierarchyListener, HierarchyBoundsAdapter, HierarchyBoundsListener, 序列化表格

字段摘要
static int | ANCESTOR_MOVED 指示祖先 Container 被移动的事件 id。
static int | ANCESTOR_RESIZED 指示祖先 Container 大小被调整的事件 id。
static int | DISPLAYABILITY_CHANGED 指示 HIERARCHY_CHANGED 事件是因为层次结构的可显示性发生更改而生成的。
static int | HIERARCHY_CHANGED 指示对整个层次结构树进行修改的事件 id。
static int | HIERARCHY_FIRST 标记层次结构事件 id 范围的第一个整数 id。
static int | HIERARCHY_LAST 标记祖先事件 id 范围的最后一个整数 id。
static int | PARENT_CHANGED 指示 HIERARCHY_CHANGED 事件是通过 reparenting 操作生成的。
static int | SHOWING_CHANGED 指示 HIERARCHY_CHANGED 事件是因为层次结构的显示状态发生更改而生成的。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
HierarchyEvent(Component source, int id, Component changed, Container changedParent)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyEvent(Component source, int id, Component changed, Container changedParent, long changeFlags)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
方法摘要
 Component getChanged()
返回位于被更改层次结构顶部的 Component。
 Container getChangedParent()
返回由 getChanged() 返回的 Component 的父级。
 long getChangeFlags()
返回指示此事件对象中表示的 HIERARCHY_CHANGED 事件类型的位掩码。
 Component getComponent()
返回事件的始发者。
 String paramString()
返回标识此事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

HIERARCHY_FIRST

public static final int HIERARCHY_FIRST
标记层次结构事件 id 范围的第一个整数 id。

另请参见：
常量字段值

HIERARCHY_CHANGED

public static final int HIERARCHY_CHANGED
指示对整个层次结构树进行修改的事件 id。

另请参见：
常量字段值

ANCESTOR_MOVED

public static final int ANCESTOR_MOVED
指示祖先 Container 被移动的事件 id。

另请参见：
常量字段值

ANCESTOR_RESIZED

public static final int ANCESTOR_RESIZED
指示祖先 Container 大小被调整的事件 id。

另请参见：
常量字段值

HIERARCHY_LAST

public static final int HIERARCHY_LAST
标记祖先事件 id 范围的最后一个整数 id。

另请参见：
常量字段值

PARENT_CHANGED

public static final int PARENT_CHANGED
指示 HIERARCHY_CHANGED 事件是通过 reparenting 操作生成的。

另请参见：
常量字段值

DISPLAYABILITY_CHANGED

public static final int DISPLAYABILITY_CHANGED
指示 HIERARCHY_CHANGED 事件是因为层次结构的可显示性发生更改而生成的。要了解层次结构的当前可显示性，调用 Component.isDisplayable。可显示性更改发生在响应对 Component.addNotify 和 Component.removeNotify 的显式或隐式调用时。

另请参见：
Component.isDisplayable(),
Component.addNotify(),
Component.removeNotify(),
常量字段值

SHOWING_CHANGED

public static final int SHOWING_CHANGED
指示 HIERARCHY_CHANGED 事件是因为层次结构的显示状态发生更改而生成的。要了解层次结构的当前显示状态，请调用 Component.isShowing。显示状态更改发生在层次结构可显示或可见时。可见性更改发生在响应对 Component.show 和 Component.hide 的显式或隐式调用时。

另请参见：
Component.isShowing(),
Component.addNotify(),
Component.removeNotify(),
Component.show(),
Component.hide(),
常量字段值
构造方法详细信息

HierarchyEvent

public HierarchyEvent(Component source,
                      int id,
                      Component changed,
                      Container changedParent)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。

注意，传入无效 id 会导致未指定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Component 对象
id - 指示事件类型的整数
changed - 位于被更改层次结构顶部的 Component
changedParent - changed 的父级；它可以是该更改之前或之后的父级，这取决于更改的类型
抛出：
IllegalArgumentException - 如果 source 为 null

HierarchyEvent

public HierarchyEvent(Component source,
                      int id,
                      Component changed,
                      Container changedParent,
                      long changeFlags)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 发起事件的 Component 对象
id - 指示事件类型的整数
changed - 位于被更改层次结构顶部的 Component
changedParent - changed 的父级；它可以是该更改之前或之后的父级，这取决于更改的类型
changeFlags - 指示此事件对象中表示的 HIERARCHY_CHANGED 事件类型的位掩码
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

getComponent

public Component getComponent()
返回事件的始发者。

返回：
发起事件的 Component 对象，如果该对象不是一个 Component，则返回 null。

getChanged

public Component getChanged()
返回位于被更改层次结构顶部的 Component。

返回：
更改的 Component

getChangedParent

public Container getChangedParent()
返回由 getChanged() 返回的 Component 的父级。对于更改类型为 PARENT_CHANGED 并通过调用 Container.add 实现的 HIERARCHY_CHANGED 事件，返回的父级是添加操作之后的父级。对于更改类型为 PARENT_CHANGED 并通过调用 Container.remove 实现的 HIERARCHY_CHANGED 事件，返回的父级是移除操作之前的父级。对于其他所有事件和类型，返回的父级是操作期间的父级。

返回：
所更改 Component 的父级

getChangeFlags

public long getChangeFlags()
返回指示此事件对象中表示的 HIERARCHY_CHANGED 事件类型的位掩码。这些位一起被执行了按位或运算。

返回：
位掩码，如果此事件不是 HIERARCHY_CHANGED 事件，则返回 0

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HierarchyListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 HierarchyListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster
public interface HierarchyListener
extends EventListener

用于接收层次结构更改事件的侦听器接口。对处理层次结构更改事件感兴趣的类应该实现此接口。然后，根据该类创建的侦听器对象使用 Component 的 addHierarchyListener 方法向该 Component 注册。当 Component 所属的层次结构发生变化时，可调用侦听器对象中的 hierarchyChanged 方法，并将 HierarchyEvent 传递给它。

层次结构事件“仅”为通知目的而提供；AWT 将自动内部处理层次结构更改，使 GUI 布局、可显示性和可见性正常工作，而不管程序是否注册了一个 HierarchyListener。

从以下版本开始：
1.3
另请参见：
HierarchyEvent

方法摘要
 void hierarchyChanged(HierarchyEvent e)
层次结构已更改时调用。

方法详细信息

hierarchyChanged

void hierarchyChanged(HierarchyEvent e)
层次结构已更改时调用。要了解更改的实际类型，调用 HierarchyEvent.getChangeFlags()。

另请参见：
HierarchyEvent.getChangeFlags()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 InputEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.InputEvent
所有已实现的接口：
Serializable
直接已知子类：
KeyEvent, MouseEvent
public abstract class InputEvent
extends ComponentEvent

所有组件级别输入事件的根事件类。 输入事件通常由产生输入事件的源代码进行处理，而在此之前，将他们提交到侦听器中。这样就允许侦听器和组件子类“使用”事件，以便源代码不会以默认方式处理事件。例如，在 Button 组件上使用 mousePressed 事件将阻止 Button 被激活。

从以下版本开始：
1.1
另请参见：
KeyEvent, KeyAdapter, MouseEvent, MouseAdapter, MouseMotionAdapter, 序列化表格

字段摘要
static int | ALT_DOWN_MASK Alt 键的扩展修饰符常量。
static int | ALT_GRAPH_DOWN_MASK AltGraph 键的扩展修饰符常量。
static int | ALT_GRAPH_MASK AltGraph 键修饰符常量。
static int | ALT_MASK Alt 键修饰符常量。
static int | BUTTON1_DOWN_MASK Mouse Button1 的扩展修饰符常量。
static int | BUTTON1_MASK Mouse Button1 修饰符常量。
static int | BUTTON2_DOWN_MASK Mouse Button2 的扩展修饰符常量。
static int | BUTTON2_MASK Mouse Button2 修饰符常量。
static int | BUTTON3_DOWN_MASK Mouse Button3 的扩展修饰符常量。
static int | BUTTON3_MASK Mouse Button3 修饰符常量。
static int | CTRL_DOWN_MASK Control 键的扩展修饰符常量。
static int | CTRL_MASK Ctrl 键修饰符常量。
static int | META_DOWN_MASK Meta 键的扩展修饰符常量。
static int | META_MASK Meta 键修饰符常量。
static int | SHIFT_DOWN_MASK Shift 键的扩展修饰符常量。
static int | SHIFT_MASK Shift 键修饰符常量。
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
方法摘要
void | consume() 使用此事件，以便不会按照默认的方式由产生此事件的源代码来处理此事件。
int | getModifiers() 返回此事件的修饰符掩码。
int | getModifiersEx() 返回此事件的扩展修饰符掩码。
static String | getModifiersExText(int modifiers) 返回描述扩展修改键和鼠标按钮（例如 "Shift"、"Button1" 或 "Ctrl+Shift"）的 String。
long | getWhen() 返回此事件发生时的时间戳。
boolean | isAltDown() 返回 Alt 修饰符在此事件上是否为 down。
boolean | isAltGraphDown() 返回 AltGraph 修饰符在此事件上是否为 down。
boolean | isConsumed() 返回是否已经使用此事件。
boolean | isControlDown() 返回 Control 修饰符在此事件上是为 down。
boolean | isMetaDown() 返回 Meta 修饰符在此事件上是否为 down。
boolean | isShiftDown() 返回 Shift 修饰符在此事件上是否为 down。
从类 java.awt.event.ComponentEvent 继承的方法
getComponent, paramString
从类 java.awt.AWTEvent 继承的方法
getID, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SHIFT_MASK

public static final int SHIFT_MASK
Shift 键修饰符常量。建议使用 SHIFT_DOWN_MASK。

另请参见：
常量字段值

CTRL_MASK

public static final int CTRL_MASK
Ctrl 键修饰符常量。建议使用 CTRL_DOWN_MASK。

另请参见：
常量字段值

META_MASK

public static final int META_MASK
Meta 键修饰符常量。建议使用 META_DOWN_MASK。

另请参见：
常量字段值

ALT_MASK

public static final int ALT_MASK
Alt 键修饰符常量。建议使用 ALT_DOWN_MASK。

另请参见：
常量字段值

ALT_GRAPH_MASK

public static final int ALT_GRAPH_MASK
AltGraph 键修饰符常量。

另请参见：
常量字段值

BUTTON1_MASK

public static final int BUTTON1_MASK
Mouse Button1 修饰符常量。建议使用 BUTTON1_DOWN_MASK。

另请参见：
常量字段值

BUTTON2_MASK

public static final int BUTTON2_MASK
Mouse Button2 修饰符常量。建议使用 BUTTON2_DOWN_MASK。注意，BUTTON2_MASK 和 ALT_MASK 具有相同的值。

另请参见：
常量字段值

BUTTON3_MASK

public static final int BUTTON3_MASK
Mouse Button3 修饰符常量。建议使用 BUTTON3_DOWN_MASK。注意：BUTTON3_MASK 和 META_MASK 具有相同的值。

另请参见：
常量字段值

SHIFT_DOWN_MASK

public static final int SHIFT_DOWN_MASK
Shift 键的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值

CTRL_DOWN_MASK

public static final int CTRL_DOWN_MASK
Control 键的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值

META_DOWN_MASK

public static final int META_DOWN_MASK
Meta 键的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值

ALT_DOWN_MASK

public static final int ALT_DOWN_MASK
Alt 键的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值

BUTTON1_DOWN_MASK

public static final int BUTTON1_DOWN_MASK
Mouse Button1 的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值

BUTTON2_DOWN_MASK

public static final int BUTTON2_DOWN_MASK
Mouse Button2 的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值

BUTTON3_DOWN_MASK

public static final int BUTTON3_DOWN_MASK
Mouse Button3 的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值

ALT_GRAPH_DOWN_MASK

public static final int ALT_GRAPH_DOWN_MASK
AltGraph 键的扩展修饰符常量。

从以下版本开始：
1.4
另请参见：
常量字段值
方法详细信息

isShiftDown

public boolean isShiftDown()
返回 Shift 修饰符在此事件上是否为 down。

isControlDown

public boolean isControlDown()
返回 Control 修饰符在此事件上是为 down。

isMetaDown

public boolean isMetaDown()
返回 Meta 修饰符在此事件上是否为 down。

isAltDown

public boolean isAltDown()
返回 Alt 修饰符在此事件上是否为 down。

isAltGraphDown

public boolean isAltGraphDown()
返回 AltGraph 修饰符在此事件上是否为 down。

getWhen

public long getWhen()
返回此事件发生时的时间戳。

getModifiers

public int getModifiers()
返回此事件的修饰符掩码。

getModifiersEx

public int getModifiersEx()
返回此事件的扩展修饰符掩码。扩展修饰符表示所有模式键的状态，例如 ALT、CTRL、META 和事件发生后那一刻的鼠标按钮

例如，如果用户在按下 button 1 后又按下 button 2，然后以相同的顺序释放这两个按钮，则会生成以下事件序列：

    MOUSE_PRESSED: BUTTON1_DOWN_MASK
    MOUSE_PRESSED: BUTTON1_DOWN_MASK | BUTTON2_DOWN_MASK
    MOUSE_RELEASED: BUTTON2_DOWN_MASK
    MOUSE_CLICKED: BUTTON2_DOWN_MASK
    MOUSE_RELEASED:
    MOUSE_CLICKED:

建议不使用 == 来比较此方法的返回值，因为在以后会增加新的修饰符。例如，检查 SHIFT 和 BUTTON1 已经按下而 CTRL 未按下的正确方法可以通过以下代码来演示：

    int onmask = SHIFT_DOWN_MASK | BUTTON1_DOWN_MASK;
    int offmask = CTRL_DOWN_MASK;
    if (event.getModifiersEx() & (onmask | offmask) == onmask) {
        ...
    }
即使添加了新的修饰符，上述代码仍然有效。

从以下版本开始：
1.4

consume

public void consume()
使用此事件，以便不会按照默认的方式由产生此事件的源代码来处理此事件。

覆盖：
类 AWTEvent 中的 consume

isConsumed

public boolean isConsumed()
返回是否已经使用此事件。

覆盖：
类 AWTEvent 中的 isConsumed
另请参见：
consume()

getModifiersExText

public static String getModifiersExText(int modifiers)
返回描述扩展修改键和鼠标按钮（例如 "Shift"、"Button1" 或 "Ctrl+Shift"）的 String。这些字符串的本地化可以通过修改 awt.properties 文件来完成。

参数：
modifiers - 描述事件的扩展修饰符和鼠标按钮的修饰符掩码
返回：
事件期间保存按下的扩展修改键和鼠标按钮集合的文本描述。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputMethodEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 InputMethodEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.InputMethodEvent
所有已实现的接口：
Serializable
public class InputMethodEvent
extends AWTEvent

输入方法事件包含有关使用输入方法进行撰写的文本的信息。只要文本发生变化，输入方法就会发送一个事件。如果当前正在使用输入方法的文本组件是活动的客户端，则将事件指派给该组件。否则，将事件指派给单独的组合窗口。

涉及输入方法事件的文本由两部分组成：已提交文本和撰写文本。任何一个部分都可以为空。两部分一起替代了前一事件中发送的未提交的撰写文本，或当前选定的已提交文本。已提交文本应该整合到文本组件的持久数据中，它将不会再次发送。撰写的文本可能会反复修改和发送，以反映用户的编辑操作。已提交文本始终在撰写文本之前。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
static int | CARET_POSITION_CHANGED 事件类型，它指示输入方法文本中修改的插入点。
static int | INPUT_METHOD_FIRST 标记输入方法事件 id 范围内的第一个整数 id。
static int | INPUT_METHOD_LAST 标记输入方法事件 id 范围内最后一个整数 id。
static int | INPUT_METHOD_TEXT_CHANGED 事件类型，它指示修改的输入方法文本。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
InputMethodEvent(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。
方法摘要
void | consume() 使用此事件，以便不会按默认方式由产生此事件的源代码来处理此事件。
TextHitInfo | getCaret() 获取插入符。
int | getCommittedCharacterCount() 获取文本中已提交字符的数量。
AttributedCharacterIterator | getText() 获取已提交文本和撰写文本的组合。
TextHitInfo | getVisiblePosition() 获取对于可见性至关重要的位置。
long | getWhen() 返回此事件发生时的时间戳。
boolean | isConsumed() 返回是否已经使用此事件。
String | paramString() 返回标识此事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
getID, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

INPUT_METHOD_FIRST

public static final int INPUT_METHOD_FIRST
标记输入方法事件 id 范围内的第一个整数 id。

另请参见：
常量字段值

INPUT_METHOD_TEXT_CHANGED

public static final int INPUT_METHOD_TEXT_CHANGED
事件类型，它指示修改的输入方法文本。此事件由输入方法在处理输入时生成。

另请参见：
常量字段值

CARET_POSITION_CHANGED

public static final int CARET_POSITION_CHANGED
事件类型，它指示输入方法文本中修改的插入点。此事件由输入方法在处理仅有插入符修改的输入时生成。

另请参见：
常量字段值

INPUT_METHOD_LAST

public static final int INPUT_METHOD_LAST
标记输入方法事件 id 范围内最后一个整数 id。

另请参见：
常量字段值
构造方法详细信息

InputMethodEvent

public InputMethodEvent(Component source,
                        int id,
                        long when,
                        AttributedCharacterIterator text,
                        int committedCharacterCount,
                        TextHitInfo caret,
                        TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。

插入符和 visiblePosition 的偏移量与当前撰写的文本有关；也就是说，如果是 INPUT_METHOD_TEXT_CHANGED 事件，则为 text 中的撰写文本；否则为前面 INPUT_METHOD_TEXT_CHANGED 事件的 text 中的撰写文本。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的对象
id - 事件类型
when - 指定事件发生时间的 long 整数
text - 已提交文本和撰写文本的组合，已提交文本在前；如果事件类型为 CARET_POSITION_CHANGED，则必须为 null；对于 INPUT_METHOD_TEXT_CHANGED 事件来说，如果无任何已提交文本或撰写文本，则可能为 null
committedCharacterCount - 文本中已提交的字符数
caret - 插入符（也叫插入点）；如果当前撰写文本中无任何插入符，则为 null
visiblePosition - 对于可见性至关重要的位置；如果当前撰写文本中对于可见位置无任何建议，则为 null
抛出：
IllegalArgumentException - 如果 id 不在 INPUT_METHOD_FIRST 到 INPUT_METHOD_LAST 范围内；或者 id 为 CARET_POSITION_CHANGED 而 text 不为 null；或者 committedCharacterCount 不在 0 到 (text.getEndIndex() - text.getBeginIndex()) 范围内
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.4

InputMethodEvent

public InputMethodEvent(Component source,
                        int id,
                        AttributedCharacterIterator text,
                        int committedCharacterCount,
                        TextHitInfo caret,
                        TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。

插入符和 visiblePosition 的偏移量与当前撰写的文本有关；也就是说，如果是 INPUT_METHOD_TEXT_CHANGED 事件，则为 text 中的撰写文本；否则为前面 INPUT_METHOD_TEXT_CHANGED 事件的 text 中的撰写文本。通过调用 EventQueue.getMostRecentEventTime() 初始化此事件的时间戳。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的对象
id - 事件类型
text - 已提交文本和撰写文本的组合，已提交文本在前；如果事件类型为 CARET_POSITION_CHANGED，则必须为 null；对于 INPUT_METHOD_TEXT_CHANGED 事件来说，如果无任何已提交文本或撰写文本，则可能为 null
committedCharacterCount - 文本中已提交的字符数
caret - 插入符（也叫插入点）；如果当前撰写文本中无任何插入符，则为 null
visiblePosition - 对于可见性至关重要的位置；如果当前撰写文本中对于可见位置无任何建议，则为 null
抛出：
IllegalArgumentException - 如果 id 不在 INPUT_METHOD_FIRST 到 INPUT_METHOD_LAST 范围内；或者 id 为 CARET_POSITION_CHANGED 而 text 不为 null；或者 committedCharacterCount 不在 0 到 (text.getEndIndex() - text.getBeginIndex()) 范围内
IllegalArgumentException - 如果 source 为 null

InputMethodEvent

public InputMethodEvent(Component source,
                        int id,
                        TextHitInfo caret,
                        TextHitInfo visiblePosition)
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。文本设置为 null，committedCharacterCount 设置为 0。

Caret 和 visiblePosition 的偏移量与当前撰写文本有关；也就是说，如果将事件构造为 CARET_POSITION_CHANGED 事件，则为前面 INPUT_METHOD_TEXT_CHANGED 事件的 text 中的撰写文本。对于没有文本的 INPUT_METHOD_TEXT_CHANGED 事件，caret 和 visiblePosition 必须为 null。通过调用 EventQueue.getMostRecentEventTime() 初始化此事件的时间戳。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的对象
id - 事件类型
caret - 插入符（也叫插入点）；如果当前撰写文本中无任何插入符，则为 null
visiblePosition - 对于可见性至关重要的位置；如果当前撰写文本中对于可见位置无任何建议，则为 null
抛出：
IllegalArgumentException - 如果 id 不在 INPUT_METHOD_FIRST 到 INPUT_METHOD_LAST 范围内
IllegalArgumentException - 如果 source 为 null
方法详细信息

getText

public AttributedCharacterIterator getText()
获取已提交文本和撰写文本的组合。从索引 0 到索引 getCommittedCharacterCount() - 1 的字符为已提交文本，其余字符为撰写文本。

返回：
文本。对于 CARET_POSITION_CHANGED 始终为 null；如果没有任何撰写文本或已提交文本，则对于 INPUT_METHOD_TEXT_CHANGED 可能为 null。

getCommittedCharacterCount

public int getCommittedCharacterCount()
获取文本中已提交字符的数量。

getCaret

public TextHitInfo getCaret()
获取插入符。

插入符的偏移量与当前撰写文本有关；也就是说，如果是 INPUT_METHOD_TEXT_CHANGED 事件，则为 getText() 中的撰写文本；否则为前面 INPUT_METHOD_TEXT_CHANGED 事件的 getText() 中的撰写文本。

返回：
插入符（也叫插入点）。如果当前撰写文本中没有任何插入符，则为 null。

getVisiblePosition

public TextHitInfo getVisiblePosition()
获取对于可见性至关重要的位置。

可见位置的偏移量与当前撰写文本有关；也就是说，如果是 INPUT_METHOD_TEXT_CHANGED 事件，则为 getText() 中的撰写文本；否则为前面 INPUT_METHOD_TEXT_CHANGED 事件的 getText() 中的撰写文本。

返回：
对于可见性至关重要的位置。如果当前撰写文本中对于可见位置没有任何建议，则为 null。

consume

public void consume()
使用此事件，以便不会按默认方式由产生此事件的源代码来处理此事件。

覆盖：
类 AWTEvent 中的 consume

isConsumed

public boolean isConsumed()
返回是否已经使用此事件。

覆盖：
类 AWTEvent 中的 isConsumed
另请参见：
consume()

getWhen

public long getWhen()
返回此事件发生时的时间戳。

返回：
此事件的时间戳
从以下版本开始：
1.4

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。它包含文本形式的事件 ID、用 "+" 分隔的已提交文本和撰写文本的字符、已提交字符的数量、插入符和可见位置。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputMethodListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 InputMethodListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster
public interface InputMethodListener
extends EventListener

接收输入方法事件的侦听器接口。文本编辑组件必须安装输入方法事件侦听器，以使用输入方法。

文本编辑组件还必须提供 InputMethodRequests 实例。

从以下版本开始：
1.2
另请参见：
InputMethodEvent, InputMethodRequests

方法摘要
void | caretPositionChanged(InputMethodEvent event) 当撰写文本中的 caret 发生变化时调用。
void | inputMethodTextChanged(InputMethodEvent event) 当通过输入方法输入的文本发生变化时调用。

方法详细信息

inputMethodTextChanged

void inputMethodTextChanged(InputMethodEvent event)
当通过输入方法输入的文本发生变化时调用。

caretPositionChanged

void caretPositionChanged(InputMethodEvent event)
当撰写文本中的 caret 发生变化时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvocationEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 InvocationEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.InvocationEvent
所有已实现的接口：
ActiveEvent, Serializable
public class InvocationEvent
extends AWTEvent
implements ActiveEvent

当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。此类可以用作 ActiveEvent 的参考实现，而不用于声明新类和定义 dispatch()。

通过调用 invokeLater 和 invokeAndWait，可以将此类的实例置于 EventQueue 上。客户端代码可以使用这一事实来编写 invokeLater 和 invokeAndWait 的替代函数，无需在任何 AWTEventListener 对象中编写特殊代码。

从以下版本开始：
1.2
另请参见：
ActiveEvent, EventQueue.invokeLater(java.lang.Runnable), EventQueue.invokeAndWait(java.lang.Runnable), AWTEventListener, 序列化表格

字段摘要
protected boolean | catchExceptions 如果 dispatch() 捕获了 Throwable 并将其存储在异常实例变量中，则设置为 true。
static int | INVOCATION_DEFAULT 所有 InvocationEvent 的默认 id。
static int | INVOCATION_FIRST 标记调用事件 id 范围内的第一个整数 id。
static int | INVOCATION_LAST 标记调用事件 id 范围内的最后一个整数 id。
protected Object | notifier 在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。
protected Runnable | runnable 调用其 run() 方法的 Runnable。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
protected | InvocationEvent(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables) 构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。
 | InvocationEvent(Object source, Runnable runnable) 构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
 | InvocationEvent(Object source, Runnable runnable, Object notifier, boolean catchThrowables) 构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
方法摘要
 void dispatch()
执行 Runnable 的 run() 方法并在 run() 返回时通知 notifier（如果有）。
 Exception getException()
返回在执行 Runnable 的 run() 方法时捕获的任何 Exception。
 Throwable getThrowable()
返回在执行 Runnable 的 run() 方法时捕获的任何 Throwable。
 long getWhen()
返回此事件发生时的时间戳。
 String paramString()
返回标识此事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

INVOCATION_FIRST

public static final int INVOCATION_FIRST
标记调用事件 id 范围内的第一个整数 id。

另请参见：
常量字段值

INVOCATION_DEFAULT

public static final int INVOCATION_DEFAULT
所有 InvocationEvent 的默认 id。

另请参见：
常量字段值

INVOCATION_LAST

public static final int INVOCATION_LAST
标记调用事件 id 范围内的最后一个整数 id。

另请参见：
常量字段值

runnable

protected Runnable runnable
调用其 run() 方法的 Runnable。

notifier

protected Object notifier
在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。

catchExceptions

protected boolean catchExceptions
如果 dispatch() 捕获了 Throwable 并将其存储在异常实例变量中，则设置为 true。如果设置为 false，则会将 Throwable 传播到 EventDispatchThread 的调度循环中。

构造方法详细信息

InvocationEvent

public InvocationEvent(Object source,
                       Runnable runnable)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。

这是一个很有用的构造方法。对于 InvocationEvent(source, runnable) 形式的调用而言，其行为与调用 InvocationEvent(source, runnable, null, false) 完全相同。

如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的 Object
runnable - 执行其 run 方法的 Runnable
抛出：
IllegalArgumentException - 如果 source 为 null
另请参见：
InvocationEvent(Object, Runnable, Object, boolean)

InvocationEvent

public InvocationEvent(Object source,
                       Runnable runnable,
                       Object notifier,
                       boolean catchThrowables)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。如果 notifier 为非 null，则会在 run 返回之后立即对它调用 notifyAll()。

对于 InvocationEvent(source, runnable, notifier, catchThrowables) 形式的调用而言，其行为与调用 InvocationEvent(source, InvocationEvent.INVOCATION_DEFAULT, runnable, notifier, catchThrowables) 完全相同。

如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的 Object
runnable - 执行其 run 方法的 Runnable
notifier - 在 Runnable.run 返回之后调用其 notifyAll 方法的对象
catchThrowables - 指定 dispatch 是否应该在执行 Runnable 的 run 方法时捕获 Throwable，或者应该将那些 Throwable 传播到 EventDispatchThread 的调度循环中
抛出：
IllegalArgumentException - 如果 source 为 null
另请参见：
InvocationEvent(Object, int, Runnable, Object, boolean)

InvocationEvent

protected InvocationEvent(Object source,
                          int id,
                          Runnable runnable,
                          Object notifier,
                          boolean catchThrowables)
构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。如果 notifier 为非 null，则将在 run 返回之后立即对它调用 notifyAll。

注意，传递无效 id 会导致不确定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的 Object
id - 事件的 ID
runnable - 执行其 run 方法的 Runnable
notifier - 在 Runnable.run 返回之后调用其 notifyAll 方法的 Object
catchThrowables - 指定 dispatch 是否应该在执行 Runnable 的 run 方法时捕获 Throwable，或者应该将那些 Throwable 传播到 EventDispatchThread 的调度循环中
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

dispatch

public void dispatch()
执行 Runnable 的 run() 方法并在 run() 返回时通知 notifier（如果有）。

指定者：
接口 ActiveEvent 中的 dispatch

getException

public Exception getException()
返回在执行 Runnable 的 run() 方法时捕获的任何 Exception。

返回：
如果抛出 Exception，则返回对 Exception 的引用；如果没有抛出 Exception 或者此 InvocationEvent 没有捕获异常，则返回 null

getThrowable

public Throwable getThrowable()
返回在执行 Runnable 的 run() 方法时捕获的任何 Throwable。

返回：
如果抛出 Throwable，则返回对 Throwable 的引用；如果没有抛出 Throwable 或者此 InvocationEvent 没有捕获 Throwable，则返回 null
从以下版本开始：
1.5

getWhen

public long getWhen()
返回此事件发生时的时间戳。

返回：
此事件的时间戳
从以下版本开始：
1.4

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对事件日志记录和调试很有用。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ItemEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 ItemEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ItemEvent
所有已实现的接口：
Serializable
public class ItemEvent
extends AWTEvent

指示项被选定或取消选定的语义事件。此高级事件是在用户已选定项或取消选定项时由 ItemSelectable 对象（如 List）生成的。该事件被传递到每个 ItemListener 对象，这些对象都已使用组件的 addItemListener 方法注册接收此类事件。

实现 ItemListener 接口的对象将在事件发生时获取此 ItemEvent。侦听器避开处理具体鼠标移动和鼠标单击的细节问题，转而处理诸如“已选定项”或“已取消选定项”之类的“有意义的”（语义）事件。

从以下版本开始：
1.1
另请参见：
ItemSelectable, ItemListener, Tutorial: Writing an Item Listener, 序列化表格

字段摘要
static int | DESELECTED 此状态更改值指示已选定的项被取消选定。
static int | ITEM_FIRST 项事件使用的 id 范围内的起始编号。
static int | ITEM_LAST 项事件使用的 id 范围内的结束编号。
static int | ITEM_STATE_CHANGED 此事件 id 指示项状态已更改。
static int | SELECTED 此状态更改值指示项被选定。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ItemEvent(ItemSelectable source, int id, Object item, int stateChange)
构造一个 ItemEvent 对象。
方法摘要
Object | getItem() 返回受事件影响的项。
ItemSelectable | getItemSelectable() 返回事件的产生程序。
int | getStateChange() 返回状态更改的类型（已选定或已取消选定）。
String | paramString() 返回标识此项事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ITEM_FIRST

public static final int ITEM_FIRST
项事件使用的 id 范围内的起始编号。

另请参见：
常量字段值

ITEM_LAST

public static final int ITEM_LAST
项事件使用的 id 范围内的结束编号。

另请参见：
常量字段值

ITEM_STATE_CHANGED

public static final int ITEM_STATE_CHANGED
此事件 id 指示项状态已更改。

另请参见：
常量字段值

SELECTED

public static final int SELECTED
此状态更改值指示项被选定。

另请参见：
常量字段值

DESELECTED

public static final int DESELECTED
此状态更改值指示已选定的项被取消选定。

另请参见：
常量字段值
构造方法详细信息

ItemEvent

public ItemEvent(ItemSelectable source,
                 int id,
                 Object item,
                 int stateChange)
构造一个 ItemEvent 对象。

注意，传递无效 id 会导致不确定的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的 ItemSelectable 对象
id - 标识事件类型的整数
item - 一个对象，即受事件影响的项
stateChange - 指示已选定还是已取消选定项的整数
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

getItemSelectable

public ItemSelectable getItemSelectable()
返回事件的产生程序。

返回：
产生事件的 ItemSelectable 对象。

getItem

public Object getItem()
返回受事件影响的项。

返回：
受事件影响的项（对象）

getStateChange

public int getStateChange()
返回状态更改的类型（已选定或已取消选定）。

返回：
指示已选定还是已取消选定项的整数
另请参见：
SELECTED, DESELECTED

paramString

public String paramString()
返回标识此项事件的参数字符串。此方法对事件日志记录和调试很有用。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ItemListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 ItemListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicComboBoxUI.ItemHandler, BasicComboPopup.ItemHandler, Checkbox.AccessibleAWTCheckbox, DefaultCellEditor.EditorDelegate, JCheckBox.AccessibleJCheckBox, JRadioButton.AccessibleJRadioButton, JToggleButton.AccessibleJToggleButton, List.AccessibleAWTList
public interface ItemListener
extends EventListener

接收项事件的侦听器接口。特别适于处理项事件的类实现此接口。然后，使用组件的 addItemListener 方法向该组件注册由此类创建的对象。选定项事件发生时，调用侦听器对象的 itemStateChanged 方法。

从以下版本开始：
1.1
另请参见：
ItemSelectable, ItemEvent, Tutorial: Writing an Item Listener

方法摘要
 void itemStateChanged(ItemEvent e)
在用户已选定或取消选定某项时调用。

方法详细信息

itemStateChanged

void itemStateChanged(ItemEvent e)
在用户已选定或取消选定某项时调用。为此方法编写的代码将执行需要在已选定（或已取消选定）项时发生的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 KeyAdapter

java.lang.Object
    继承者  java.awt.event.KeyAdapter
所有已实现的接口：
KeyListener, EventListener
直接已知子类：
BasicComboBoxUI.KeyHandler, BasicComboPopup.InvocationKeyHandler, BasicTreeUI.KeyHandler
public abstract class KeyAdapter
extends Object
implements KeyListener

接收键盘事件的抽象适配器类。此类中的方法为空。此类存在的目的是方便创建侦听器对象。

扩展此类即可创建 KeyEvent 侦听器并重写所需事件的方法。（如果要实现 KeyListener 接口，则必须定义该接口内的所有方法。此抽象类将所有方法都定义为 null，所以只需针对关心的事件定义方法。）

使用扩展的类可创建侦听器对象，然后使用组件的 addKeyListener 方法向该组件注册此侦听器对象。当按下、释放或键入某个键时，将调用该侦听器对象中的相应方法，并将 KeyEvent 传递给相应的方法。

从以下版本开始：
1.1
另请参见：
KeyEvent, KeyListener, Tutorial: Writing a Key Listener

构造方法摘要
KeyAdapter()
方法摘要
void | keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | keyTyped(KeyEvent e) 键入某个键时调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyAdapter

public KeyAdapter()
方法详细信息

keyTyped

public void keyTyped(KeyEvent e)
键入某个键时调用此方法。当按下键然后又释放该键时发生此事件。

指定者：
接口 KeyListener 中的 keyTyped

keyPressed

public void keyPressed(KeyEvent e)
按下某个键时调用此方法。

指定者：
接口 KeyListener 中的 keyPressed

keyReleased

public void keyReleased(KeyEvent e)
释放某个键时调用此方法。

指定者：
接口 KeyListener 中的 keyReleased
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 KeyEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.InputEvent
                    继承者  java.awt.event.KeyEvent
所有已实现的接口：
Serializable
直接已知子类：
MenuKeyEvent
public class KeyEvent
extends InputEvent

表示组件中发生键击的事件。

当按下、释放或键入某个键时，组件对象（如文本字段）将生成此低级别事件。该事件被传递给每一个 KeyListener 或 KeyAdapter 对象，这些对象使用组件的 addKeyListener 方法注册，以接收此类事件。（KeyAdapter 对象实现 KeyListener 接口。）发生事件时，所有此类侦听器对象都将获得此 KeyEvent。

“键入键”事件 是高级别事件，通常不依赖于平台或键盘布局。输入 Unicode 字符时生成此类事件，它们被认为是发现字符输入的最佳方式。最简单的情况是，按下单个键（如 "a"）将产生键入键事件。但是，字符经常是通过一系列按键（如‘shift’＋‘a’）产生的，按下键事件和键入键事件的映射关系可能是多对一或多对多的。键释放通常不需要生成键入键事件，但在某些情况下，只有释放了某个键后才能生成键入键事件（如在 Windows 中通过 Alt-Numpad 方法来输入 ASCII 序列）。对于不生成 Unicode 字符的键是不会生成键入键事件的（如动作键、修改键等等）。

getKeyChar 方法总是返回有效的 Unicode 字符或 CHAR_UNDEFINED。KEY_TYPED 事件报告字符输入：KEY_PRESSED 和 KEY_RELEASED 事件不必与字符输入关联。因此，可以保证 getKeyChar 方法的结果只对 KEY_TYPED 事件有意义。

对于按下键和释放键事件，getKeyCode 方法返回该事件的 keyCode。对于键入键事件，getKeyCode 方法总是返回 VK_UNDEFINED。

“按下键”和“释放键”事件 是低级别事件，依赖于平台和键盘布局。只要按下或释放键就生成这些事件，它们是发现不生成字符输入的键（如动作键、修改键等等）的惟一方式。通过 getKeyCode 方法可指出按下或释放的键，该方法返回一个虚拟键码。

虚拟键码 用于报告按下了键盘上的哪个键，而不是一次或多次键击组合生成的字符（如 "A" 是由 shift ＋ "a" 生成的）。

例如，按下 Shift 键会生成 keyCode 为 VK_SHIFT 的 KEY_PRESSED 事件，而按下 'a' 键将生成 keyCode 为 VK_A 的 KEY_PRESSED 事件。释放 'a' 键后，会激发 keyCode 为 VK_A 的 KEY_RELEASED 事件。另外，还会生成一个 keyChar 值为 'A' 的 KEY_TYPED 事件。

按下和释放键盘上的键会导致（依次）生成以下键事件：

    KEY_PRESSED
    KEY_TYPED（只在可生成有效 Unicode 字符时产生。）
    KEY_RELEASED
但在某些情况下（例如，在激活自动重复或输入方法时），该顺序可能会有所不同（并且与平台有关）。

注：

  • 不产生 Unicode 字符的键组合（如 F1 和 HELP 键等动作键）不会生成 KEY_TYPED 事件。
  • 并非所有键盘和系统都能够生成所有的虚拟键码。在 Java 中不会尝试人为地生成这些键。
  • 虚拟键码不标识物理键：它们取决于平台和键盘布局。例如，使用美国键盘布局时生成 VK_Q 的键在使用法国键盘布局时将生成 VK_A。
  • 并非所有的字符都有与之关联的 keycode。例如，没有用于问号的 keycode，因为没有在主层上显示问号的键盘。
  • 为了支持平台无关的动作键处理，Java 平台为某些功能使用少量附加虚拟键常量，否则必须通过解释虚拟键码和修饰符来识别这些功能。例如，对于日文 Windows 键盘，返回 VK_ALL_CANDIDATES 而不是 VK_CONVERT 加 ALT 修饰符。
  • 正如 Focus Specification 中指定的那样，默认情况下键事件被指派给焦点拥有者。

警告：除了 Java 语言定义的这些键之外（VK_ENTER、VK_BACK_SPACE 和 VK_TAB），不要依赖 VK_ 常量值。Sun 保留将来根据需要更改这些值的权利，以适应更大范围的键盘。

从以下版本开始：
1.1
另请参见：
KeyAdapter, KeyListener, Tutorial: Writing a Key Listener, 序列化表格

字段摘要
static char | CHAR_UNDEFINED KEY_PRESSED 和 KEY_RELEASED 事件没有映射到一个有效的 Unicode 字符时使用此值作为 keyChar 值。
static int | KEY_FIRST 用于键事件的 id 范围的起始编号。
static int | KEY_LAST 用于键事件的 id 范围的结束编号。
static int | KEY_LOCATION_LEFT 该常量指示按下或释放的键位于左侧（此键的位置有多种可能性）。
static int | KEY_LOCATION_NUMPAD 该常量指示按键事件发自于数字键盘或对应于数字键盘的虚拟键。
static int | KEY_LOCATION_RIGHT 该常量指示按下或释放的键位于右侧（此键的位置有多种可能性）。
static int | KEY_LOCATION_STANDARD 该常量指示按下或释放的键不区分左右，并且不是发自数字键盘（或者不是发自对应于数字键盘的虚拟键）。
static int | KEY_LOCATION_UNKNOWN 指示 keyLocation 为不确定或不相关的常量。
static int | KEY_PRESSED “按下键”事件。
static int | KEY_RELEASED “释放键”事件。
static int | KEY_TYPED “键入键”事件。
static int | VK_0 VK_0 到 VK_9 与 ASCII 的‘0’到‘9’(0x30 - 0x39) 相同
static int | VK_1
static int | VK_2
static int | VK_3
static int | VK_4
static int | VK_5
static int | VK_6
static int | VK_7
static int | VK_8
static int | VK_9
static int | VK_A VK_A 到 VK_Z 与 ASCII 的‘A’到‘Z’(0x41 - 0x5A) 相同
static int | VK_ACCEPT 用于 Accept 或 Commit 功能键的常量。
static int | VK_ADD
static int | VK_AGAIN
static int | VK_ALL_CANDIDATES 用于 All Candidates 功能键的常量。
static int | VK_ALPHANUMERIC 用于 Alphanumeric 功能键的常量。
static int | VK_ALT
static int | VK_ALT_GRAPH 用于 AltGraph 功能键的常量。
static int | VK_AMPERSAND
static int | VK_ASTERISK
static int | VK_AT 用于 "@" 键的常量。
static int | VK_B
static int | VK_BACK_QUOTE
static int | VK_BACK_SLASH 用于反斜杠键 "\" 的常量。
static int | VK_BACK_SPACE
static int | VK_BEGIN 用于 Begin 键的常量。
static int | VK_BRACELEFT
static int | VK_BRACERIGHT
static int | VK_C
static int | VK_CANCEL
static int | VK_CAPS_LOCK
static int | VK_CIRCUMFLEX 用于 "^" 键的常量。
static int | VK_CLEAR
static int | VK_CLOSE_BRACKET 用于右方括号键 "]" 的常量。
static int | VK_CODE_INPUT 用于 Code Input 功能键的常量。
static int | VK_COLON 用于 ":" 键的常量。
static int | VK_COMMA 用于逗号键 "," 的常量。
static int | VK_COMPOSE 用于 Compose 功能键的常量。
static int | VK_CONTEXT_MENU 用于 Microsoft Windows 上下文菜单键的常量。
static int | VK_CONTROL
static int | VK_CONVERT 用于 Convert 功能键的常量。
static int | VK_COPY
static int | VK_CUT
static int | VK_D
static int | VK_DEAD_ABOVEDOT
static int | VK_DEAD_ABOVERING
static int | VK_DEAD_ACUTE
static int | VK_DEAD_BREVE
static int | VK_DEAD_CARON
static int | VK_DEAD_CEDILLA
static int | VK_DEAD_CIRCUMFLEX
static int | VK_DEAD_DIAERESIS
static int | VK_DEAD_DOUBLEACUTE
static int | VK_DEAD_GRAVE
static int | VK_DEAD_IOTA
static int | VK_DEAD_MACRON
static int | VK_DEAD_OGONEK
static int | VK_DEAD_SEMIVOICED_SOUND
static int | VK_DEAD_TILDE
static int | VK_DEAD_VOICED_SOUND
static int | VK_DECIMAL
static int | VK_DELETE
static int | VK_DIVIDE
static int | VK_DOLLAR 用于 "$" 键的常量。
static int | VK_DOWN 用于非数字键盘向下方向键的常量。
static int | VK_E
static int | VK_END
static int | VK_ENTER
static int | VK_EQUALS 用于等号键 "=" 的常量。
static int | VK_ESCAPE
static int | VK_EURO_SIGN 用于欧洲货币符号键的常量。
static int | VK_EXCLAMATION_MARK 用于 "!" 键的常量。
static int | VK_F
static int | VK_F1 用于 F1 功能键的常量。
static int | VK_F10 用于 F10 功能键的常量。
static int | VK_F11 用于 F11 功能键的常量。
static int | VK_F12 用于 F12 功能键的常量。
static int | VK_F13 用于 F13 功能键的常量。
static int | VK_F14 用于 F14 功能键的常量。
static int | VK_F15 用于 F15 功能键的常量。
static int | VK_F16 用于 F16 功能键的常量。
static int | VK_F17 用于 F17 功能键的常量。
static int | VK_F18 用于 F18 功能键的常量。
static int | VK_F19 用于 F19 功能键的常量。
static int | VK_F2 用于 F2 功能键的常量。
static int | VK_F20 用于 F20 功能键的常量。
static int | VK_F21 用于 F21 功能键的常量。
static int | VK_F22 用于 F22 功能键的常量。
static int | VK_F23 用于 F23 功能键的常量。
static int | VK_F24 用于 F24 功能键的常量。
static int | VK_F3 用于 F3 功能键的常量。
static int | VK_F4 用于 F4 功能键的常量。
static int | VK_F5 用于 F5 功能键的常量。
static int | VK_F6 用于 F6 功能键的常量。
static int | VK_F7 用于 F7 功能键的常量。
static int | VK_F8 用于 F8 功能键的常量。
static int | VK_F9 用于 F9 功能键的常量。
static int | VK_FINAL
static int | VK_FIND
static int | VK_FULL_WIDTH 用于 Full-Width Characters 功能键的常量。
static int | VK_G
static int | VK_GREATER
static int | VK_H
static int | VK_HALF_WIDTH 用于 Half-Width Characters 功能键的常量。
static int | VK_HELP
static int | VK_HIRAGANA 用于 Hiragana 功能键的常量。
static int | VK_HOME
static int | VK_I
static int | VK_INPUT_METHOD_ON_OFF 用于输入法开/关键的常量。
static int | VK_INSERT
static int | VK_INVERTED_EXCLAMATION_MARK 用于反向感叹号键的常量。
static int | VK_J
static int | VK_JAPANESE_HIRAGANA 用于 Japanese-Hiragana 功能键的常量。
static int | VK_JAPANESE_KATAKANA 用于 Japanese-Katakana 功能键的常量。
static int | VK_JAPANESE_ROMAN 用于 Japanese-Roman 功能键的常量。
static int | VK_K
static int | VK_KANA
static int | VK_KANA_LOCK 用于锁定 Kana 功能键的常量。
static int | VK_KANJI
static int | VK_KATAKANA 用于 Katakana 功能键的常量。
static int | VK_KP_DOWN 用于数字键盘向下方向键的常量。
static int | VK_KP_LEFT 用于数字键盘向左方向键的常量。
static int | VK_KP_RIGHT 用于数字键盘向右方向键的常量。
static int | VK_KP_UP 用于数字键盘向上方向键的常量。
static int | VK_L
static int | VK_LEFT 用于非数字键盘向左方向键的常量。
static int | VK_LEFT_PARENTHESIS 用于 "(" 键的常量。
static int | VK_LESS
static int | VK_M
static int | VK_META
static int | VK_MINUS 用于减号键 "-" 的常量
static int | VK_MODECHANGE
static int | VK_MULTIPLY
static int | VK_N
static int | VK_NONCONVERT 用于 Don't Convert 功能键的常量。
static int | VK_NUM_LOCK
static int | VK_NUMBER_SIGN 用于 "#" 键的常量。
static int | VK_NUMPAD0
static int | VK_NUMPAD1
static int | VK_NUMPAD2
static int | VK_NUMPAD3
static int | VK_NUMPAD4
static int | VK_NUMPAD5
static int | VK_NUMPAD6
static int | VK_NUMPAD7
static int | VK_NUMPAD8
static int | VK_NUMPAD9
static int | VK_O
static int | VK_OPEN_BRACKET 用于左方括号键 "[" 的常量。
static int | VK_P
static int | VK_PAGE_DOWN
static int | VK_PAGE_UP
static int | VK_PASTE
static int | VK_PAUSE
static int | VK_PERIOD 用于句点键 "." 的常量。
static int | VK_PLUS 用于 "+" 键的常量。
static int | VK_PREVIOUS_CANDIDATE 用于 Previous Candidate 功能键的常量。
static int | VK_PRINTSCREEN
static int | VK_PROPS
static int | VK_Q
static int | VK_QUOTE
static int | VK_QUOTEDBL
static int | VK_R
static int | VK_RIGHT 用于非数字键盘向右方向键的常量。
static int | VK_RIGHT_PARENTHESIS 用于 ")" 键的常量。
static int | VK_ROMAN_CHARACTERS 用于 Roman Characters 功能键的常量。
static int | VK_S
static int | VK_SCROLL_LOCK
static int | VK_SEMICOLON 用于分号键 ";" 的常量。
static int | VK_SEPARATER 此常量已废弃，包括它仅为了向后兼容。
static int | VK_SEPARATOR 用于数字键盘分隔符键的常量。
static int | VK_SHIFT
static int | VK_SLASH 用于正斜杠键 "/" 的常量。
static int | VK_SPACE
static int | VK_STOP
static int | VK_SUBTRACT
static int | VK_T
static int | VK_TAB
static int | VK_U
static int | VK_UNDEFINED 此值用于指出 keyCode 是未知的。
static int | VK_UNDERSCORE 用于 "_" 键的常量。
static int | VK_UNDO
static int | VK_UP 用于非数字键盘向上方向键的常量。
static int | VK_V
static int | VK_W
static int | VK_WINDOWS 用于 Microsoft Windows 的 "Windows" 键的常量。
static int | VK_X
static int | VK_Y
static int | VK_Z
从类 java.awt.event.InputEvent 继承的字段
ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
KeyEvent(Component source, int id, long when, int modifiers, int keyCode)
已过时。 从 JDK1.1 开始
KeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar)
构造一个 KeyEvent 对象。
KeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, int keyLocation)
方法摘要
char | getKeyChar() 返回与此事件中的键关联的字符。
int | getKeyCode() 返回与此事件中的键关联的整数 keyCode。
int | getKeyLocation() 返回产生此按键事件的键位置。
static String | getKeyModifiersText(int modifiers) 返回描述修改键的 String，如 "Shift" 或 "Ctrl+Shift"。
static String | getKeyText(int keyCode) 返回描述 keyCode 的 String，如 "HOME"、"F1" 或 "A"。
boolean | isActionKey() 返回此事件中的键是否为“动作”键。
String | paramString() 返回标识此事件的参数字符串。
void | setKeyChar(char keyChar) 设置 keyCode 值，以表示某个逻辑字符。
void | setKeyCode(int keyCode) 设置 keyCode 值，以表示某个物理键。
void | setModifiers(int modifiers) 已过时。 从 JDK1.1.4 开始
从类 java.awt.event.InputEvent 继承的方法
consume, getModifiers, getModifiersEx, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
getID, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

KEY_FIRST

public static final int KEY_FIRST
用于键事件的 id 范围的起始编号。

另请参见：
常量字段值

KEY_LAST

public static final int KEY_LAST
用于键事件的 id 范围的结束编号。

另请参见：
常量字段值

KEY_TYPED

public static final int KEY_TYPED
“键入键”事件。输入字符时生成此事件。最简单的情况是，按下单个键产生该事件。但是，经常是通过一系列按键来产生字符，按下键事件和键入键事件的映射关系可能是多对一或多对多的。

另请参见：
常量字段值

KEY_PRESSED

public static final int KEY_PRESSED
“按下键”事件。键被按下时生成此事件。

另请参见：
常量字段值

KEY_RELEASED

public static final int KEY_RELEASED
“释放键”事件。松开键时生成此事件。

另请参见：
常量字段值

VK_ENTER

public static final int VK_ENTER
另请参见：
常量字段值

VK_BACK_SPACE

public static final int VK_BACK_SPACE
另请参见：
常量字段值

VK_TAB

public static final int VK_TAB
另请参见：
常量字段值

VK_CANCEL

public static final int VK_CANCEL
另请参见：
常量字段值

VK_CLEAR

public static final int VK_CLEAR
另请参见：
常量字段值

VK_SHIFT

public static final int VK_SHIFT
另请参见：
常量字段值

VK_CONTROL

public static final int VK_CONTROL
另请参见：
常量字段值

VK_ALT

public static final int VK_ALT
另请参见：
常量字段值

VK_PAUSE

public static final int VK_PAUSE
另请参见：
常量字段值

VK_CAPS_LOCK

public static final int VK_CAPS_LOCK
另请参见：
常量字段值

VK_ESCAPE

public static final int VK_ESCAPE
另请参见：
常量字段值

VK_SPACE

public static final int VK_SPACE
另请参见：
常量字段值

VK_PAGE_UP

public static final int VK_PAGE_UP
另请参见：
常量字段值

VK_PAGE_DOWN

public static final int VK_PAGE_DOWN
另请参见：
常量字段值

VK_END

public static final int VK_END
另请参见：
常量字段值

VK_HOME

public static final int VK_HOME
另请参见：
常量字段值

VK_LEFT

public static final int VK_LEFT
用于非数字键盘向左方向键的常量。

另请参见：
VK_KP_LEFT, 常量字段值

VK_UP

public static final int VK_UP
用于非数字键盘向上方向键的常量。

另请参见：
VK_KP_UP, 常量字段值

VK_RIGHT

public static final int VK_RIGHT
用于非数字键盘向右方向键的常量。

另请参见：
VK_KP_RIGHT, 常量字段值

VK_DOWN

public static final int VK_DOWN
用于非数字键盘向下方向键的常量。

另请参见：
VK_KP_DOWN, 常量字段值

VK_COMMA

public static final int VK_COMMA
用于逗号键 "," 的常量。

另请参见：
常量字段值

VK_MINUS

public static final int VK_MINUS
用于减号键 "-" 的常量

从以下版本开始：
1.2
另请参见：
常量字段值

VK_PERIOD

public static final int VK_PERIOD
用于句点键 "." 的常量。

另请参见：
常量字段值

VK_SLASH

public static final int VK_SLASH
用于正斜杠键 "/" 的常量。

另请参见：
常量字段值

VK_0

public static final int VK_0
VK_0 到 VK_9 与 ASCII 的‘0’到‘9’(0x30 - 0x39) 相同

另请参见：
常量字段值

VK_1

public static final int VK_1
另请参见：
常量字段值

VK_2

public static final int VK_2
另请参见：
常量字段值

VK_3

public static final int VK_3
另请参见：
常量字段值

VK_4

public static final int VK_4
另请参见：
常量字段值

VK_5

public static final int VK_5
另请参见：
常量字段值

VK_6

public static final int VK_6
另请参见：
常量字段值

VK_7

public static final int VK_7
另请参见：
常量字段值

VK_8

public static final int VK_8
另请参见：
常量字段值

VK_9

public static final int VK_9
另请参见：
常量字段值

VK_SEMICOLON

public static final int VK_SEMICOLON
用于分号键 ";" 的常量。

另请参见：
常量字段值

VK_EQUALS

public static final int VK_EQUALS
用于等号键 "=" 的常量。

另请参见：
常量字段值

VK_A

public static final int VK_A
VK_A 到 VK_Z 与 ASCII 的‘A’到‘Z’(0x41 - 0x5A) 相同

另请参见：
常量字段值

VK_B

public static final int VK_B
另请参见：
常量字段值

VK_C

public static final int VK_C
另请参见：
常量字段值

VK_D

public static final int VK_D
另请参见：
常量字段值

VK_E

public static final int VK_E
另请参见：
常量字段值

VK_F

public static final int VK_F
另请参见：
常量字段值

VK_G

public static final int VK_G
另请参见：
常量字段值

VK_H

public static final int VK_H
另请参见：
常量字段值

VK_I

public static final int VK_I
另请参见：
常量字段值

VK_J

public static final int VK_J
另请参见：
常量字段值

VK_K

public static final int VK_K
另请参见：
常量字段值

VK_L

public static final int VK_L
另请参见：
常量字段值

VK_M

public static final int VK_M
另请参见：
常量字段值

VK_N

public static final int VK_N
另请参见：
常量字段值

VK_O

public static final int VK_O
另请参见：
常量字段值

VK_P

public static final int VK_P
另请参见：
常量字段值

VK_Q

public static final int VK_Q
另请参见：
常量字段值

VK_R

public static final int VK_R
另请参见：
常量字段值

VK_S

public static final int VK_S
另请参见：
常量字段值

VK_T

public static final int VK_T
另请参见：
常量字段值

VK_U

public static final int VK_U
另请参见：
常量字段值

VK_V

public static final int VK_V
另请参见：
常量字段值

VK_W

public static final int VK_W
另请参见：
常量字段值

VK_X

public static final int VK_X
另请参见：
常量字段值

VK_Y

public static final int VK_Y
另请参见：
常量字段值

VK_Z

public static final int VK_Z
另请参见：
常量字段值

VK_OPEN_BRACKET

public static final int VK_OPEN_BRACKET
用于左方括号键 "[" 的常量。

另请参见：
常量字段值

VK_BACK_SLASH

public static final int VK_BACK_SLASH
用于反斜杠键 "\" 的常量。

另请参见：
常量字段值

VK_CLOSE_BRACKET

public static final int VK_CLOSE_BRACKET
用于右方括号键 "]" 的常量。

另请参见：
常量字段值

VK_NUMPAD0

public static final int VK_NUMPAD0
另请参见：
常量字段值

VK_NUMPAD1

public static final int VK_NUMPAD1
另请参见：
常量字段值

VK_NUMPAD2

public static final int VK_NUMPAD2
另请参见：
常量字段值

VK_NUMPAD3

public static final int VK_NUMPAD3
另请参见：
常量字段值

VK_NUMPAD4

public static final int VK_NUMPAD4
另请参见：
常量字段值

VK_NUMPAD5

public static final int VK_NUMPAD5
另请参见：
常量字段值

VK_NUMPAD6

public static final int VK_NUMPAD6
另请参见：
常量字段值

VK_NUMPAD7

public static final int VK_NUMPAD7
另请参见：
常量字段值

VK_NUMPAD8

public static final int VK_NUMPAD8
另请参见：
常量字段值

VK_NUMPAD9

public static final int VK_NUMPAD9
另请参见：
常量字段值

VK_MULTIPLY

public static final int VK_MULTIPLY
另请参见：
常量字段值

VK_ADD

public static final int VK_ADD
另请参见：
常量字段值

VK_SEPARATER

public static final int VK_SEPARATER
此常量已废弃，包括它仅为了向后兼容。

另请参见：
VK_SEPARATOR, 常量字段值

VK_SEPARATOR

public static final int VK_SEPARATOR
用于数字键盘分隔符键的常量。

从以下版本开始：
1.4
另请参见：
常量字段值

VK_SUBTRACT

public static final int VK_SUBTRACT
另请参见：
常量字段值

VK_DECIMAL

public static final int VK_DECIMAL
另请参见：
常量字段值

VK_DIVIDE

public static final int VK_DIVIDE
另请参见：
常量字段值

VK_DELETE

public static final int VK_DELETE
另请参见：
常量字段值

VK_NUM_LOCK

public static final int VK_NUM_LOCK
另请参见：
常量字段值

VK_SCROLL_LOCK

public static final int VK_SCROLL_LOCK
另请参见：
常量字段值

VK_F1

public static final int VK_F1
用于 F1 功能键的常量。

另请参见：
常量字段值

VK_F2

public static final int VK_F2
用于 F2 功能键的常量。

另请参见：
常量字段值

VK_F3

public static final int VK_F3
用于 F3 功能键的常量。

另请参见：
常量字段值

VK_F4

public static final int VK_F4
用于 F4 功能键的常量。

另请参见：
常量字段值

VK_F5

public static final int VK_F5
用于 F5 功能键的常量。

另请参见：
常量字段值

VK_F6

public static final int VK_F6
用于 F6 功能键的常量。

另请参见：
常量字段值

VK_F7

public static final int VK_F7
用于 F7 功能键的常量。

另请参见：
常量字段值

VK_F8

public static final int VK_F8
用于 F8 功能键的常量。

另请参见：
常量字段值

VK_F9

public static final int VK_F9
用于 F9 功能键的常量。

另请参见：
常量字段值

VK_F10

public static final int VK_F10
用于 F10 功能键的常量。

另请参见：
常量字段值

VK_F11

public static final int VK_F11
用于 F11 功能键的常量。

另请参见：
常量字段值

VK_F12

public static final int VK_F12
用于 F12 功能键的常量。

另请参见：
常量字段值

VK_F13

public static final int VK_F13
用于 F13 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F14

public static final int VK_F14
用于 F14 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F15

public static final int VK_F15
用于 F15 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F16

public static final int VK_F16
用于 F16 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F17

public static final int VK_F17
用于 F17 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F18

public static final int VK_F18
用于 F18 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F19

public static final int VK_F19
用于 F19 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F20

public static final int VK_F20
用于 F20 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F21

public static final int VK_F21
用于 F21 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F22

public static final int VK_F22
用于 F22 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F23

public static final int VK_F23
用于 F23 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_F24

public static final int VK_F24
用于 F24 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_PRINTSCREEN

public static final int VK_PRINTSCREEN
另请参见：
常量字段值

VK_INSERT

public static final int VK_INSERT
另请参见：
常量字段值

VK_HELP

public static final int VK_HELP
另请参见：
常量字段值

VK_META

public static final int VK_META
另请参见：
常量字段值

VK_BACK_QUOTE

public static final int VK_BACK_QUOTE
另请参见：
常量字段值

VK_QUOTE

public static final int VK_QUOTE
另请参见：
常量字段值

VK_KP_UP

public static final int VK_KP_UP
用于数字键盘向上方向键的常量。

从以下版本开始：
1.2
另请参见：
VK_UP, 常量字段值

VK_KP_DOWN

public static final int VK_KP_DOWN
用于数字键盘向下方向键的常量。

从以下版本开始：
1.2
另请参见：
VK_DOWN, 常量字段值

VK_KP_LEFT

public static final int VK_KP_LEFT
用于数字键盘向左方向键的常量。

从以下版本开始：
1.2
另请参见：
VK_LEFT, 常量字段值

VK_KP_RIGHT

public static final int VK_KP_RIGHT
用于数字键盘向右方向键的常量。

从以下版本开始：
1.2
另请参见：
VK_RIGHT, 常量字段值

VK_DEAD_GRAVE

public static final int VK_DEAD_GRAVE
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_ACUTE

public static final int VK_DEAD_ACUTE
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_CIRCUMFLEX

public static final int VK_DEAD_CIRCUMFLEX
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_TILDE

public static final int VK_DEAD_TILDE
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_MACRON

public static final int VK_DEAD_MACRON
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_BREVE

public static final int VK_DEAD_BREVE
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_ABOVEDOT

public static final int VK_DEAD_ABOVEDOT
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_DIAERESIS

public static final int VK_DEAD_DIAERESIS
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_ABOVERING

public static final int VK_DEAD_ABOVERING
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_DOUBLEACUTE

public static final int VK_DEAD_DOUBLEACUTE
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_CARON

public static final int VK_DEAD_CARON
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_CEDILLA

public static final int VK_DEAD_CEDILLA
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_OGONEK

public static final int VK_DEAD_OGONEK
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_IOTA

public static final int VK_DEAD_IOTA
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_VOICED_SOUND

public static final int VK_DEAD_VOICED_SOUND
从以下版本开始：
1.2
另请参见：
常量字段值

VK_DEAD_SEMIVOICED_SOUND

public static final int VK_DEAD_SEMIVOICED_SOUND
从以下版本开始：
1.2
另请参见：
常量字段值

VK_AMPERSAND

public static final int VK_AMPERSAND
从以下版本开始：
1.2
另请参见：
常量字段值

VK_ASTERISK

public static final int VK_ASTERISK
从以下版本开始：
1.2
另请参见：
常量字段值

VK_QUOTEDBL

public static final int VK_QUOTEDBL
从以下版本开始：
1.2
另请参见：
常量字段值

VK_LESS

public static final int VK_LESS
从以下版本开始：
1.2
另请参见：
常量字段值

VK_GREATER

public static final int VK_GREATER
从以下版本开始：
1.2
另请参见：
常量字段值

VK_BRACELEFT

public static final int VK_BRACELEFT
从以下版本开始：
1.2
另请参见：
常量字段值

VK_BRACERIGHT

public static final int VK_BRACERIGHT
从以下版本开始：
1.2
另请参见：
常量字段值

VK_AT

public static final int VK_AT
用于 "@" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_COLON

public static final int VK_COLON
用于 ":" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_CIRCUMFLEX

public static final int VK_CIRCUMFLEX
用于 "^" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_DOLLAR

public static final int VK_DOLLAR
用于 "$" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_EURO_SIGN

public static final int VK_EURO_SIGN
用于欧洲货币符号键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_EXCLAMATION_MARK

public static final int VK_EXCLAMATION_MARK
用于 "!" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_INVERTED_EXCLAMATION_MARK

public static final int VK_INVERTED_EXCLAMATION_MARK
用于反向感叹号键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_LEFT_PARENTHESIS

public static final int VK_LEFT_PARENTHESIS
用于 "(" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_NUMBER_SIGN

public static final int VK_NUMBER_SIGN
用于 "#" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_PLUS

public static final int VK_PLUS
用于 "+" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_RIGHT_PARENTHESIS

public static final int VK_RIGHT_PARENTHESIS
用于 ")" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_UNDERSCORE

public static final int VK_UNDERSCORE
用于 "_" 键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_WINDOWS

public static final int VK_WINDOWS
用于 Microsoft Windows 的 "Windows" 键的常量。此常量同时用于左右两个这种键。

从以下版本开始：
1.5
另请参见：
getKeyLocation(), 常量字段值

VK_CONTEXT_MENU

public static final int VK_CONTEXT_MENU
用于 Microsoft Windows 上下文菜单键的常量。

从以下版本开始：
1.5
另请参见：
常量字段值

VK_FINAL

public static final int VK_FINAL
另请参见：
常量字段值

VK_CONVERT

public static final int VK_CONVERT
用于 Convert 功能键的常量。

另请参见：
常量字段值

VK_NONCONVERT

public static final int VK_NONCONVERT
用于 Don't Convert 功能键的常量。

另请参见：
常量字段值

VK_ACCEPT

public static final int VK_ACCEPT
用于 Accept 或 Commit 功能键的常量。

另请参见：
常量字段值

VK_MODECHANGE

public static final int VK_MODECHANGE
另请参见：
常量字段值

VK_KANA

public static final int VK_KANA
另请参见：
常量字段值

VK_KANJI

public static final int VK_KANJI
另请参见：
常量字段值

VK_ALPHANUMERIC

public static final int VK_ALPHANUMERIC
用于 Alphanumeric 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_KATAKANA

public static final int VK_KATAKANA
用于 Katakana 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_HIRAGANA

public static final int VK_HIRAGANA
用于 Hiragana 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_FULL_WIDTH

public static final int VK_FULL_WIDTH
用于 Full-Width Characters 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_HALF_WIDTH

public static final int VK_HALF_WIDTH
用于 Half-Width Characters 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_ROMAN_CHARACTERS

public static final int VK_ROMAN_CHARACTERS
用于 Roman Characters 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_ALL_CANDIDATES

public static final int VK_ALL_CANDIDATES
用于 All Candidates 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_PREVIOUS_CANDIDATE

public static final int VK_PREVIOUS_CANDIDATE
用于 Previous Candidate 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_CODE_INPUT

public static final int VK_CODE_INPUT
用于 Code Input 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_JAPANESE_KATAKANA

public static final int VK_JAPANESE_KATAKANA
用于 Japanese-Katakana 功能键的常量。此键可切换到日文输入法并选择其 Katakana 输入模式。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_JAPANESE_HIRAGANA

public static final int VK_JAPANESE_HIRAGANA
用于 Japanese-Hiragana 功能键的常量。此键可切换到日文输入法并选择其 Hiragana 输入模式。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_JAPANESE_ROMAN

public static final int VK_JAPANESE_ROMAN
用于 Japanese-Roman 功能键的常量。此键可切换到日文输入法并选择其 Roman-Direct 输入模式。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_KANA_LOCK

public static final int VK_KANA_LOCK
用于锁定 Kana 功能键的常量。这将把键盘锁定在 Kana 布局。

从以下版本开始：
1.3
另请参见：
常量字段值

VK_INPUT_METHOD_ON_OFF

public static final int VK_INPUT_METHOD_ON_OFF
用于输入法开/关键的常量。

从以下版本开始：
1.3
另请参见：
常量字段值

VK_CUT

public static final int VK_CUT
从以下版本开始：
1.2
另请参见：
常量字段值

VK_COPY

public static final int VK_COPY
从以下版本开始：
1.2
另请参见：
常量字段值

VK_PASTE

public static final int VK_PASTE
从以下版本开始：
1.2
另请参见：
常量字段值

VK_UNDO

public static final int VK_UNDO
从以下版本开始：
1.2
另请参见：
常量字段值

VK_AGAIN

public static final int VK_AGAIN
从以下版本开始：
1.2
另请参见：
常量字段值

VK_FIND

public static final int VK_FIND
从以下版本开始：
1.2
另请参见：
常量字段值

VK_PROPS

public static final int VK_PROPS
从以下版本开始：
1.2
另请参见：
常量字段值

VK_STOP

public static final int VK_STOP
从以下版本开始：
1.2
另请参见：
常量字段值

VK_COMPOSE

public static final int VK_COMPOSE
用于 Compose 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_ALT_GRAPH

public static final int VK_ALT_GRAPH
用于 AltGraph 功能键的常量。

从以下版本开始：
1.2
另请参见：
常量字段值

VK_BEGIN

public static final int VK_BEGIN
用于 Begin 键的常量。

从以下版本开始：
1.5
另请参见：
常量字段值

VK_UNDEFINED

public static final int VK_UNDEFINED
此值用于指出 keyCode 是未知的。KEY_TYPED 事件没有 keyCode 值，用此值代替。

另请参见：
常量字段值

CHAR_UNDEFINED

public static final char CHAR_UNDEFINED
KEY_PRESSED 和 KEY_RELEASED 事件没有映射到一个有效的 Unicode 字符时使用此值作为 keyChar 值。

另请参见：
常量字段值

KEY_LOCATION_UNKNOWN

public static final int KEY_LOCATION_UNKNOWN
指示 keyLocation 为不确定或不相关的常量。KEY_TYPED 事件没有 keyLocation，使用此值代替。

从以下版本开始：
1.4
另请参见：
常量字段值

KEY_LOCATION_STANDARD

public static final int KEY_LOCATION_STANDARD
该常量指示按下或释放的键不区分左右，并且不是发自数字键盘（或者不是发自对应于数字键盘的虚拟键）。

从以下版本开始：
1.4
另请参见：
常量字段值

KEY_LOCATION_LEFT

public static final int KEY_LOCATION_LEFT
该常量指示按下或释放的键位于左侧（此键的位置有多种可能性）。示例：左侧的 shift 键。

从以下版本开始：
1.4
另请参见：
常量字段值

KEY_LOCATION_RIGHT

public static final int KEY_LOCATION_RIGHT
该常量指示按下或释放的键位于右侧（此键的位置有多种可能性）。示例：右侧的 shift 键。

从以下版本开始：
1.4
另请参见：
常量字段值

KEY_LOCATION_NUMPAD

public static final int KEY_LOCATION_NUMPAD
该常量指示按键事件发自于数字键盘或对应于数字键盘的虚拟键。

从以下版本开始：
1.4
另请参见：
常量字段值
构造方法详细信息

KeyEvent

public KeyEvent(Component source,
                int id,
                long when,
                int modifiers,
                int keyCode,
                char keyChar,
                int keyLocation)

KeyEvent

public KeyEvent(Component source,
                int id,
                long when,
                int modifiers,
                int keyCode,
                char keyChar)
构造一个 KeyEvent 对象。

注意，传入无效的 id 将导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生事件的 Component
id - 标识事件类型的整数
when - 指定事件发生时间的 long 型整数
modifiers - 事件期间按下的修改键（shift、ctrl、alt、meta）。应该使用扩展的 _DOWN_MASK 修饰符或旧的 _MASK 修饰符，但是在一个事件中不应混用两种模型。首选扩展的修饰符。
keyCode - 实际键的整数代码，或者为 VK_UNDEFINED（对于键入键事件）
keyChar - 此事件所生成的 Unicode 字符，或者为 CHAR_UNDEFINED（对于未映射到有效 Unicode 字符的按下键和释放键事件)
抛出：
IllegalArgumentException - 如果 id 为 KEY_TYPED 且 keyChar 为 CHAR_UNDEFINED；或者 id 为 KEY_TYPED 且 keyCode 不为 VK_UNDEFINED
IllegalArgumentException - 如果 source 为 null

KeyEvent

@Deprecated
public KeyEvent(Component source,
                           int id,
                           long when,
                           int modifiers,
                           int keyCode)
已过时。 从 JDK1.1 开始

方法详细信息

getKeyCode

public int getKeyCode()
返回与此事件中的键关联的整数 keyCode。

返回：
键盘上实际键的整数代码。（对于 KEY_TYPED 事件，该 keyCode 为 VK_UNDEFINED。）

setKeyCode

public void setKeyCode(int keyCode)
设置 keyCode 值，以表示某个物理键。

参数：
keyCode - 与键盘上实际键相对应的一个整数。

getKeyChar

public char getKeyChar()
返回与此事件中的键关联的字符。例如，shift + "a" 的 KEY_TYPED 事件返回值 "A"。

KEY_PRESSED 和 KEY_RELEASED 事件不用于报告字符输入。因此，可以保证此方法返回的值只对 KEY_TYPED 事件有意义。

返回：
为此按键事件定义的 Unicode 字符。如果对于此按键事件没有有效的 Unicode 字符，则返回 CHAR_UNDEFINED。

setKeyChar

public void setKeyChar(char keyChar)
设置 keyCode 值，以表示某个逻辑字符。

参数：
keyChar - 与构成此事件的键击组合相对应的 char 值。

setModifiers

@Deprecated
public void setModifiers(int modifiers)
已过时。 从 JDK1.1.4 开始

设置修饰符，以指出所按住的修改键（例如 shift、ctrl、alt、meta），该动作被定义为 InputEvent 的一部分。

注：因为很多 AWT 实现不识别修饰符的改变，所以不推荐使用此方法。对于其中更改了 shift 修饰符的 KEY_TYPED 事件更是如此。

参数：
modifiers - 修饰符常量的整数组合。
另请参见：
InputEvent

getKeyLocation

public int getKeyLocation()
返回产生此按键事件的键位置。 某些键在键盘上出现多次，如左右 shift 键。另外，某些键则出现在数字键盘上。此方法提供了一种区分这些键的方式。

返回：
被按下或释放的键的位置。总是为 KEY_TYPED 事件返回 KEY_LOCATION_UNKNOWN。
从以下版本开始：
1.4

getKeyText

public static String getKeyText(int keyCode)
返回描述 keyCode 的 String，如 "HOME"、"F1" 或 "A"。通过更改 awt.properties 文件可以本地化这些字符串。

返回：
包含物理键文本描述的字符串，物理键通过其 keyCode 标识。

getKeyModifiersText

public static String getKeyModifiersText(int modifiers)
返回描述修改键的 String，如 "Shift" 或 "Ctrl+Shift"。通过更改 awt.properties 文件可以本地化这些字符串。

注意，InputEvent.ALT_MASK 和 InputEvent.BUTTON2_MASK 具有相同的值，所以对这两个修饰符返回字符串 "Alt"。同样，InputEvent.META_MASK 和 InputEvent.BUTTON3_MASK 具有相同的值，所以对这两个修饰符返回字符串 "Meta"。

返回：
一个字符串，它是在事件期间所按住的修改键组合的文本描述
另请参见：
InputEvent.getModifiersExText(int)

isActionKey

public boolean isActionKey()
返回此事件中的键是否为“动作”键。通常动作键不会激发 unicode 字符并且不是修改键。

返回：
如果该键是“动作”键，则返回 true；否则返回 false

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 ComponentEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 KeyListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicComboBoxUI.KeyHandler, BasicComboPopup.InvocationKeyHandler, BasicTableUI.KeyHandler, BasicTreeUI.KeyHandler, KeyAdapter
public interface KeyListener
extends EventListener

用于接收键盘事件（击键）的侦听器接口。旨在处理键盘事件的类要么实现此接口（及其包含的所有方法），要么扩展抽象 KeyAdapter 类（仅重写有用的方法）。

然后使用组件的 addKeyListener 方法将从该类所创建的侦听器对象向该组件注册。按下、释放或键入键时生成键盘事件。然后调用侦听器对象中的相关方法并将该 KeyEvent 传递给它。

从以下版本开始：
1.1
另请参见：
KeyAdapter, KeyEvent, Tutorial: Writing a Key Listener

方法摘要
void | keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | keyTyped(KeyEvent e) 键入某个键时调用此方法。

方法详细信息

keyTyped

void keyTyped(KeyEvent e)
键入某个键时调用此方法。有关键入键事件的定义，请参见 KeyEvent 的类描述。

keyPressed

void keyPressed(KeyEvent e)
按下某个键时调用此方法。有关按下键事件的定义，请参见 KeyEvent 的类描述。

keyReleased

void keyReleased(KeyEvent e)
释放某个键时调用此方法。有关释放键事件的定义，请参见 KeyEvent 的类描述。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 MouseAdapter

java.lang.Object
    继承者  java.awt.event.MouseAdapter
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
直接已知子类：
BasicComboPopup.InvocationMouseHandler, BasicComboPopup.ListMouseHandler, BasicFileChooserUI.DoubleClickListener, BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.TrackListener, BasicSplitPaneDivider.MouseHandler, BasicTabbedPaneUI.MouseHandler, BasicTreeUI.MouseHandler, FormView.MouseEventListener, HTMLEditorKit.LinkController, MetalFileChooserUI.SingleClickListener, MouseInputAdapter, ToolTipManager
public abstract class MouseAdapter
extends Object
implements MouseListener, MouseWheelListener, MouseMotionListener

接收鼠标事件的抽象适配器类。此类中的方法为空。此类存在的目的是方便创建侦听器对象。

鼠标事件使用户能够跟踪鼠标何时被按下、释放、单击、移动、拖动、何时进入一个组件、何时退出、何时滚动鼠标滚轮。

扩展此类可创建 MouseEvent（包括拖动和移动事件）或/和 MouseWheelEvent 侦听器，并针对所需事件重写方法。（如果要实现 MouseListener 和 MouseMotionListener 接口，则必须定义该接口中的所有方法。此抽象类将所有方法都定义为 null，所以只需针对关心的事件定义方法。）

使用扩展的类创建一个侦听器对象，然后使用组件的 addMouseListener、addMouseMotionListener 和 addMouseWheelListener 方法向该组件注册此侦听器对象。侦听器对象中的相关方法被调用，MouseEvent 或 MouseWheelEvent 在以下情况下被传递给该对象：

  • 当鼠标键被按下、释放或单击（按下并释放）时
  • 当鼠标光标进入或退出某个组件时
  • 当鼠标滚轮滚动，或者鼠标被移动或拖动时

从以下版本开始：
1.1
另请参见：
MouseEvent, MouseWheelEvent, MouseListener, MouseMotionListener, MouseWheelListener, Tutorial: Writing a Mouse Listener

构造方法摘要
MouseAdapter()
方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
void | mouseWheelMoved(MouseWheelEvent e) 鼠标滚轮旋转时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MouseAdapter

public MouseAdapter()
方法详细信息

mouseClicked

public void mouseClicked(MouseEvent e)
鼠标按键在组件上单击（按下并释放）时调用。

指定者：
接口 MouseListener 中的 mouseClicked

mousePressed

public void mousePressed(MouseEvent e)
鼠标按键在组件上按下时调用。

指定者：
接口 MouseListener 中的 mousePressed

mouseReleased

public void mouseReleased(MouseEvent e)
鼠标按钮在组件上释放时调用。

指定者：
接口 MouseListener 中的 mouseReleased

mouseEntered

public void mouseEntered(MouseEvent e)
鼠标进入到组件上时调用。

指定者：
接口 MouseListener 中的 mouseEntered

mouseExited

public void mouseExited(MouseEvent e)
鼠标离开组件时调用。

指定者：
接口 MouseListener 中的 mouseExited

mouseWheelMoved

public void mouseWheelMoved(MouseWheelEvent e)
鼠标滚轮旋转时调用。

指定者：
接口 MouseWheelListener 中的 mouseWheelMoved
从以下版本开始：
1.6
另请参见：
MouseWheelEvent

mouseDragged

public void mouseDragged(MouseEvent e)
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

指定者：
接口 MouseMotionListener 中的 mouseDragged
从以下版本开始：
1.6

mouseMoved

public void mouseMoved(MouseEvent e)
鼠标光标移动到组件上但无按键按下时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 MouseEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.InputEvent
                    继承者  java.awt.event.MouseEvent
所有已实现的接口：
Serializable
直接已知子类：
MenuDragMouseEvent, MouseWheelEvent
public class MouseEvent
extends InputEvent

指示组件中发生鼠标动作的事件。当且仅当动作发生时鼠标光标处于特定组件边界未被遮掩的部分上，才认为在该组件上发生了鼠标动作。对于轻量级组件，比如 Swing 的组件，当在某个组件上启用某个鼠标事件类型之后，此类鼠标事件仅被指派给该组件。通过将适当的基于鼠标的 EventListener 添加到组件（MouseListener 或 MouseMotionListener），或者通过调用带有适当掩码参数（AWTEvent.MOUSE_EVENT_MASK 或 AWTEvent.MOUSE_MOTION_EVENT_MASK）的 Component.enableEvents(long)，可以启用鼠标事件类型。如果没有对组件启用鼠标事件类型，则相应的鼠标事件将被指派给启用了鼠标事件类型的第一个祖先组件。

例如，如果已经将 MouseListener 添加到某一组件，或者已经调用 enableEvents(AWTEvent.MOUSE_EVENT_MASK)，则由 MouseListener 定义的所有事件都将指派给该组件。另一方面，如果没有添加 MouseMotionListener 并且没有调用带 AWTEvent.MOUSE_MOTION_EVENT_MASK 参数的 enableEvents，则鼠标移动事件不会被指派到该组件。这些鼠标移动事件将被指派给启用了鼠标移动事件的第一个祖先组件。

对于以下动作，组件对象将生成此低级别事件：

  • 鼠标事件
    • 按下鼠标按键
    • 释放鼠标按键
    • 单击鼠标按键（按下并释放）
    • 鼠标光标进入组件几何形状的未遮掩部分
    • 鼠标光标离开组件几何形状的未遮掩部分
  • 鼠标移动事件
    • 移动鼠标
    • 拖动鼠标

MouseEvent 对象被传递给每一个 MouseListener 或 MouseAdapter 对象，这些对象使用组件的 addMouseListener 方法注册，以接收“感兴趣的”鼠标事件。（MouseAdapter 对象实现 MouseListener 接口。）每个此类侦听器对象都获得包含鼠标事件的 MouseEvent。

MouseEvent 对象还传递给每一个 MouseMotionListener 或 MouseMotionAdapter 对象，这些对象使用组件的 addMouseMotionListener 方法注册，以接收鼠标移动事件。（MouseMotionAdapter 对象实现 MouseMotionListener 接口。）每个此类侦听器对象都获得包含鼠标移动事件的 MouseEvent。

当单击鼠标按键时，将生成事件并发送给已注册的 MouseListener。可以使用 InputEvent.getModifiers() 和 InputEvent.getModifiersEx() 方法检索模式键的状态。InputEvent.getModifiers() 返回的按键掩码只反映改变了状态的按键，没有反映所有按键的当前状态。（注：由于 ALT_MASK/BUTTON2_MASK 和 META_MASK/BUTTON3_MASK 的值是重叠的，所以对于涉及修改键的鼠标事件并不总是正确的。）要获得所有按键和修改键的状态，请使用 InputEvent.getModifiersEx()。getButton() 返回改变了状态的鼠标按键。

例如，如果按下了第一个鼠标按键，则以下列顺序发送事件：

    id             修饰符       按键
    MOUSE_PRESSED: BUTTON1_MASK BUTTON1
    MOUSE_RELEASED: BUTTON1_MASK BUTTON1
    MOUSE_CLICKED: BUTTON1_MASK BUTTON1
按下多个鼠标按键时，每次按下、释放和单击按键都会生成一个独立的事件。

例如，如果用户按下按键 1 后按下按键 2，然后以相同的顺序释放它们，则将生成下列事件序列：

    id             修饰符       按键
    MOUSE_PRESSED: BUTTON1_MASK BUTTON1
    MOUSE_PRESSED: BUTTON2_MASK BUTTON2
    MOUSE_RELEASED: BUTTON1_MASK BUTTON1
    MOUSE_CLICKED: BUTTON1_MASK BUTTON1
    MOUSE_RELEASED: BUTTON2_MASK BUTTON2
    MOUSE_CLICKED: BUTTON2_MASK BUTTON2
如果先释放按键 2，则先出现 BUTTON2_MASK 的 MOUSE_RELEASED/MOUSE_CLICKED 对，然后是 BUTTON1_MASK 对。

在释放鼠标按键前，MOUSE_DRAGGED 事件将被传递到鼠标按键按下时所在的 Component（无论鼠标位置当前是否处于 Component 的边界内）。由于拖放实现与平台有关，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。在多屏幕环境中，即使鼠标位置在与 Component 关联的 GraphicsConfiguration 边界之外，也会将鼠标拖动事件传递给该 Component。但是，在这种情况下报告的鼠标拖动事件位置可能与实际的鼠标位置不同：

  • 在没有虚拟设备的多屏幕环境中：
    报告的鼠标拖动事件坐标被限制在与 Component 关联的 GraphicsConfiguration 边界内。
  • 在具有虚拟设备的多屏幕环境中：
    报告的鼠标拖动事件坐标被限制在与 Component 关联的虚拟设备边界内。

从以下版本开始：
1.1
另请参见：
MouseAdapter, MouseListener, MouseMotionAdapter, MouseMotionListener, MouseWheelListener, Tutorial: Writing a Mouse Listener, Tutorial: Writing a Mouse Motion Listener, 序列化表格

字段摘要
static int | BUTTON1 指示鼠标按键 #1；由 getButton() 使用。
static int | BUTTON2 指示鼠标按键 #2；由 getButton() 使用。
static int | BUTTON3 指示鼠标按键 #3；由 getButton() 使用。
static int | MOUSE_CLICKED “鼠标单击”事件。
static int | MOUSE_DRAGGED “鼠标拖动”事件。
static int | MOUSE_ENTERED “鼠标进入”事件。
static int | MOUSE_EXITED “鼠标离开”事件。
static int | MOUSE_FIRST 用于鼠标事件的 id 范围的起始编号。
static int | MOUSE_LAST 用于鼠标事件的 id 范围的结束编号。
static int | MOUSE_MOVED “鼠标移动”事件。
static int | MOUSE_PRESSED “鼠标按下”事件。
static int | MOUSE_RELEASED “鼠标释放”事件。
static int | MOUSE_WHEEL “鼠标滚轮”事件。
static int | NOBUTTON 指示没有鼠标按键，由 getButton() 使用。
从类 java.awt.event.InputEvent 继承的字段
ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int button)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int button)
构造一个具有指定源组件、类型、修饰符、相对坐标、绝对坐标和单击计数的 MouseEvent 对象。
方法摘要
int | getButton() 返回更改了状态的鼠标按键（如果有）。
int | getClickCount() 返回与此事件关联的鼠标单击次数。
Point | getLocationOnScreen() 返回事件的绝对 x, y 坐标。
static String | getMouseModifiersText(int modifiers) 返回一个描述事件期间所按下的修改键和鼠标按键（如“Shift”或“Ctrl+Shift”）的 String。
Point | getPoint() 返回事件相对于源组件的 x, y 坐标。
int | getX() 返回事件相对于源组件的水平 x 坐标。
int | getXOnScreen() 返回事件的绝对水平 x 坐标。
int | getY() 返回事件相对于源组件的垂直 y 坐标。
int | getYOnScreen() 返回事件的绝对垂直 y 坐标。
boolean | isPopupTrigger() 返回此鼠标事件是否为该平台的弹出菜单触发事件。
String | paramString() 返回标识此事件的参数字符串。
void | translatePoint(int x, int y) 通过将事件坐标加上指定的 x（水平）和 y（垂直）偏移量，将事件的坐标平移到新位置。
从类 java.awt.event.InputEvent 继承的方法
consume, getModifiers, getModifiersEx, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
getID, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

MOUSE_FIRST

public static final int MOUSE_FIRST
用于鼠标事件的 id 范围的起始编号。

另请参见：
常量字段值

MOUSE_LAST

public static final int MOUSE_LAST
用于鼠标事件的 id 范围的结束编号。

另请参见：
常量字段值

MOUSE_CLICKED

public static final int MOUSE_CLICKED
“鼠标单击”事件。按下并释放鼠标按键时产生此 MouseEvent。

另请参见：
常量字段值

MOUSE_PRESSED

public static final int MOUSE_PRESSED
“鼠标按下”事件。按下鼠标按键时产生此 MouseEvent。

另请参见：
常量字段值

MOUSE_RELEASED

public static final int MOUSE_RELEASED
“鼠标释放”事件。松开鼠标按键时产生此 MouseEvent。

另请参见：
常量字段值

MOUSE_MOVED

public static final int MOUSE_MOVED
“鼠标移动”事件。鼠标位置改变时产生此 MouseEvent。

另请参见：
常量字段值

MOUSE_ENTERED

public static final int MOUSE_ENTERED
“鼠标进入”事件。鼠标光标进入组件几何形状的未遮掩部分时产生此 MouseEvent。

另请参见：
常量字段值

MOUSE_EXITED

public static final int MOUSE_EXITED
“鼠标离开”事件。鼠标光标离开组件几何形状的未遮掩部分时产生此 MouseEvent。

另请参见：
常量字段值

MOUSE_DRAGGED

public static final int MOUSE_DRAGGED
“鼠标拖动”事件。鼠标按键处于被按下状态中更改鼠标位置时产生此 MouseEvent。

另请参见：
常量字段值

MOUSE_WHEEL

public static final int MOUSE_WHEEL
“鼠标滚轮”事件。这是惟一的 MouseWheelEvent。带有滚轮的鼠标在滚轮旋转时产生此事件。

从以下版本开始：
1.4
另请参见：
常量字段值

NOBUTTON

public static final int NOBUTTON
指示没有鼠标按键，由 getButton() 使用。

从以下版本开始：
1.4
另请参见：
常量字段值

BUTTON1

public static final int BUTTON1
指示鼠标按键 #1；由 getButton() 使用。

从以下版本开始：
1.4
另请参见：
常量字段值

BUTTON2

public static final int BUTTON2
指示鼠标按键 #2；由 getButton() 使用。

从以下版本开始：
1.4
另请参见：
常量字段值

BUTTON3

public static final int BUTTON3
指示鼠标按键 #3；由 getButton() 使用。

从以下版本开始：
1.4
另请参见：
常量字段值
构造方法详细信息

MouseEvent

public MouseEvent(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int clickCount,
                  boolean popupTrigger,
                  int button)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。

注意，传入无效 id 将导致不确定的行为。创建无效事件（例如使用多个旧的 _MASK，或者使用不匹配的修饰符/按键值）将导致不确定的行为。调用形式为 MouseEvent(source, id, when, modifiers, x, y, clickCount, popupTrigger, button) 的方法与调用 MouseEvent(source, id, when, modifiers, x, y, xAbs, yAbs, clickCount, popupTrigger, button) 完全相同，其中 xAbs 和 yAbs 定义为屏幕上源组件的位置加上相对坐标 x 和 y。如果没有显示源组件，则 xAbs 和 yAbs 被设置为 0。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Component
id - 标识事件的整数
when - 给出事件发生时间的 long int 值
modifiers - 事件期间按下的修改键（如 shift、ctrl、alt、meta）。应该使用扩展的 _DOWN_MASK 修饰符或旧的 _MASK 修饰符，但是在一个事件中不应混用两种模型。首选扩展的修饰符。
x - 鼠标位置的水平 x 坐标
y - 鼠标位置的垂直 y 坐标
clickCount - 与事件关联的鼠标单击次数
popupTrigger - 一个 boolean 值，如果此事件是某个弹出菜单的触发器，则为 true
button - 改变了状态的鼠标按键。为 NOBUTTON、BUTTON1、BUTTON2 或 BUTTON3。
抛出：
IllegalArgumentException - 如果传入无效的 button 值
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.4

MouseEvent

public MouseEvent(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int clickCount,
                  boolean popupTrigger)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。

注意，传入无效 id 将导致不确定的行为。调用形式为 MouseEvent(source, id, when, modifiers, x, y, clickCount, popupTrigger) 的方法所产生的效果与调用 MouseEvent(source, id, when, modifiers, x, y, xAbs, yAbs, clickCount, popupTrigger, MouseEvent.NOBUTTON) 完全相同，其中 xAbs 和 yAbs 定义为屏幕上原点的位置加上相对坐标 x 和 y。如果没有显示原点，则 xAbs 和 yAbs 被设置为零。如果 source 为 null，则此方法将抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Component
id - 标识事件的整数
when - 给出事件发生时间的 long int 值
modifiers - 发生事件期间按下的修改键（例如 shift、ctrl、alt 和 meta)，应该使用扩展的 _DOWN_MASK 修饰符或旧的 _MASK 修饰符，但是在一个事件中不应混用两种模型。首选扩展的修饰符。
x - 鼠标位置的水平 x 坐标
y - 鼠标位置的垂直 y 坐标
clickCount - 与该事件有关的鼠标单击次数
popupTrigger - 一个 boolean 值，如此事件是某个弹出菜单的触发器，则该参数为 true
抛出：
IllegalArgumentException - 如果 source 为 null

MouseEvent

public MouseEvent(Component source,
                  int id,
                  long when,
                  int modifiers,
                  int x,
                  int y,
                  int xAbs,
                  int yAbs,
                  int clickCount,
                  boolean popupTrigger,
                  int button)
构造一个具有指定源组件、类型、修饰符、相对坐标、绝对坐标和单击计数的 MouseEvent 对象。

注意，传入无效 id 将导致不确定的行为。创建无效事件（比如使用多个旧的 _MASK，或者使用不匹配的修饰符/按钮值）将导致不确定的行为。即使将不一致的相对坐标值和绝对坐标值传递给构造方法，仍然会创建鼠标事件实例，并且不抛出任何异常。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Component
id - 标识事件的整数
when - 给出事件发生时间的 long int 值
modifiers - 事件期间按下的修改键（如 shift、ctrl、alt、meta）。应该使用扩展的 _DOWN_MASK 修饰符或旧的 _MASK 修饰符，但是在一个事件中不应混用两种模型。首选扩展的修饰符。
x - 鼠标位置的水平 x 坐标
y - 鼠标位置的垂直 y 坐标
xAbs - 鼠标位置的绝对水平 x 坐标
yAbs - 鼠标位置的绝对垂直 y 坐标
clickCount - 与事件关联的鼠标单击次数
popupTrigger - 一个 boolean 值，如果此事件是某个弹出菜单的触发器，则为 true
button - 更改了状态的鼠标按键。该参数为 NOBUTTON、BUTTON1、BUTTON2 或 BUTTON3。
抛出：
IllegalArgumentException - 如果传入无效的 button 值
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.6
方法详细信息

getLocationOnScreen

public Point getLocationOnScreen()
返回事件的绝对 x, y 坐标。在虚拟设备多屏幕环境中，桌面区域可以跨越多个物理屏幕设备，这些坐标相对于虚拟坐标系。否则，这些坐标相对于与 Component 的 GraphicsConfiguration 关联的坐标系。

返回：
包含绝对 x 坐标和绝对 y 坐标的 Point 对象。
从以下版本开始：
1.6
另请参见：
GraphicsConfiguration

getXOnScreen

public int getXOnScreen()
返回事件的绝对水平 x 坐标。在虚拟设备多屏幕环境中，桌面区域可以跨越多个物理屏幕设备，这些坐标相对于虚拟坐标系。否则，这些坐标相对于与 Component 的 GraphicsConfiguration 关联的坐标系。

返回：
x 表示绝对水平位置的整数。
从以下版本开始：
1.6
另请参见：
GraphicsConfiguration

getYOnScreen

public int getYOnScreen()
返回事件的绝对垂直 y 坐标。在虚拟设备多屏幕环境中，桌面区域可以跨越多个物理屏幕设备，这些坐标相对于虚拟坐标系。否则，这些坐标相对于与 Component 的 GraphicsConfiguration 关联的坐标系。

返回：
y 表示绝对垂直位置的整数。
从以下版本开始：
1.6
另请参见：
GraphicsConfiguration

getX

public int getX()
返回事件相对于源组件的水平 x 坐标。

返回：
一个整数 x，指示相对于组件的水平位置

getY

public int getY()
返回事件相对于源组件的垂直 y 坐标。

返回：
一个整数 y，指示相对于组件的垂直位置

getPoint

public Point getPoint()
返回事件相对于源组件的 x, y 坐标。

返回：
一个 Point 对象，包含相对于源组件的 x 和 y 坐标

translatePoint

public void translatePoint(int x,
                           int y)
通过将事件坐标加上指定的 x（水平）和 y（垂直）偏移量，将事件的坐标平移到新位置。

参数：
x - 与当前 x 坐标位置相加的水平 x 值
y - 与当前 y 坐标位置相加的垂直 y 值

getClickCount

public int getClickCount()
返回与此事件关联的鼠标单击次数。

返回：
单击次数的整数值

getButton

public int getButton()
返回更改了状态的鼠标按键（如果有）。

返回：
以下常量之一：NOBUTTON、BUTTON1、BUTTON2 或 BUTTON3。
从以下版本开始：
1.4

isPopupTrigger

public boolean isPopupTrigger()
返回此鼠标事件是否为该平台的弹出菜单触发事件。

注：在不同系统上弹出菜单的触发方式不同。因此，为了正确实现跨平台功能，在 mouseReleased 和 mousePressed 中都应检查 isPopupTrigger。

返回：
一个 boolean 值，如果此事件是此平台的弹出菜单触发器，则为 true

getMouseModifiersText

public static String getMouseModifiersText(int modifiers)
返回一个描述事件期间所按下的修改键和鼠标按键（如“Shift”或“Ctrl+Shift”）的 String。通过更改 awt.properties 文件可以本地化这些字符串。

注意，InputEvent.ALT_MASK 和 InputEvent.BUTTON2_MASK 具有相同的值，所以这两个修饰符都返回字符串“Alt”。同样，InputEvent.META_MASK 和 InputEvent.BUTTON3_MASK 具有相同的值，所以这两个修饰符都返回字符串“Meta”。

参数：
modifiers - 描述事件期间所按下的修改键和鼠标按键的修饰符掩码
返回：
一个 string，描述事件期间所按下的修改键和鼠标按钮的文本描述
从以下版本开始：
1.4
另请参见：
InputEvent.getModifiersExText(int)

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 ComponentEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 MouseListener

所有超级接口：
EventListener
所有已知子接口：
MouseInputListener
所有已知实现类：
AWTEventMulticaster, BasicButtonListener, BasicComboPopup.InvocationMouseHandler, BasicComboPopup.ListMouseHandler, BasicDesktopIconUI.MouseInputHandler, BasicFileChooserUI.DoubleClickListener, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.GlassPaneDispatcher, BasicListUI.MouseInputHandler, BasicMenuItemUI.MouseInputHandler, BasicMenuUI.MouseInputHandler, BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.TrackListener, BasicSliderUI.TrackListener, BasicSplitPaneDivider.MouseHandler, BasicTabbedPaneUI.MouseHandler, BasicTableHeaderUI.MouseInputHandler, BasicTableUI.MouseInputHandler, BasicTextUI.BasicCaret, BasicToolBarUI.DockingListener, BasicTreeUI.MouseHandler, BasicTreeUI.MouseInputHandler, DefaultCaret, FormView.MouseEventListener, HTMLEditorKit.LinkController, MetalFileChooserUI.SingleClickListener, MetalToolBarUI.MetalDockingListener, MouseAdapter, MouseDragGestureRecognizer, MouseInputAdapter, ToolTipManager
public interface MouseListener
extends EventListener

用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。（要跟踪鼠标移动和鼠标拖动，请使用 MouseMotionListener。）

旨在处理鼠标事件的类要么实现此接口（及其包含的所有方法），要么扩展抽象类 MouseAdapter（仅重写所需的方法）。

然后使用组件的 addMouseListener 方法将从该类所创建的侦听器对象向该组件注册。当按下、释放或单击（按下并释放）鼠标时会生成鼠标事件。鼠标光标进入或离开组件时也会生成鼠标事件。发生鼠标事件时，将调用该侦听器对象中的相应方法，并将 MouseEvent 传递给该方法。

从以下版本开始：
1.1
另请参见：
MouseAdapter, MouseEvent, Tutorial: Writing a Mouse Listener

方法摘要
void | mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。

方法详细信息

mouseClicked

void mouseClicked(MouseEvent e)
鼠标按键在组件上单击（按下并释放）时调用。

mousePressed

void mousePressed(MouseEvent e)
鼠标按键在组件上按下时调用。

mouseReleased

void mouseReleased(MouseEvent e)
鼠标按钮在组件上释放时调用。

mouseEntered

void mouseEntered(MouseEvent e)
鼠标进入到组件上时调用。

mouseExited

void mouseExited(MouseEvent e)
鼠标离开组件时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseMotionAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 MouseMotionAdapter

java.lang.Object
    继承者  java.awt.event.MouseMotionAdapter
所有已实现的接口：
MouseMotionListener, EventListener
直接已知子类：
BasicComboPopup.InvocationMouseMotionHandler, BasicComboPopup.ListMouseMotionHandler
public abstract class MouseMotionAdapter
extends Object
implements MouseMotionListener

接收鼠标移动事件的抽象适配器类。此类中的方法为空。此类存在的目的是方便创建侦听器对象。

移动或拖动鼠标时会发生鼠标移动事件。（在正常程序中会生成很多此类事件。要跟踪单击和其他鼠标事件，请使用 MouseAdapter。）

扩展此类可创建 MouseEvent 侦听器并重写所需事件的方法。（如果要实现 MouseMotionListener 接口，则必须定义该接口内的所有方法。此抽象类将所有方法都定义为 null，所以只需针对关心的事件定义方法。）

使用扩展的类可以创建侦听器对象，然后使用组件的 addMouseMotionListener 方法向该组件注册此侦听器对象。移动或拖动鼠标时，将调用该侦听器对象中的相应方法，并将 MouseEvent 传递给该方法。

从以下版本开始：
1.1
另请参见：
MouseEvent, MouseMotionListener, Tutorial: Writing a Mouse Motion Listener

构造方法摘要
MouseMotionAdapter()
方法摘要
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseMoved(MouseEvent e) 鼠标按键在组件上移动（无按键按下）时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MouseMotionAdapter

public MouseMotionAdapter()
方法详细信息

mouseDragged

public void mouseDragged(MouseEvent e)
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，鼠标拖动事件被连续地传递到首先发起该事件的组件（而不管鼠标位置是否处于该组件的边界内）。

指定者：
接口 MouseMotionListener 中的 mouseDragged

mouseMoved

public void mouseMoved(MouseEvent e)
鼠标按键在组件上移动（无按键按下）时调用。

指定者：
接口 MouseMotionListener 中的 mouseMoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseMotionListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 MouseMotionListener

所有超级接口：
EventListener
所有已知子接口：
MouseInputListener
所有已知实现类：
AWTEventMulticaster, BasicButtonListener, BasicComboPopup.InvocationMouseHandler, BasicComboPopup.InvocationMouseMotionHandler, BasicComboPopup.ListMouseHandler, BasicComboPopup.ListMouseMotionHandler, BasicDesktopIconUI.MouseInputHandler, BasicFileChooserUI.DoubleClickListener, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.GlassPaneDispatcher, BasicListUI.MouseInputHandler, BasicMenuItemUI.MouseInputHandler, BasicMenuUI.MouseInputHandler, BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.TrackListener, BasicSliderUI.TrackListener, BasicSplitPaneDivider.MouseHandler, BasicTabbedPaneUI.MouseHandler, BasicTableHeaderUI.MouseInputHandler, BasicTableUI.MouseInputHandler, BasicTextUI.BasicCaret, BasicToolBarUI.DockingListener, BasicTreeUI.MouseHandler, BasicTreeUI.MouseInputHandler, DefaultCaret, FormView.MouseEventListener, HTMLEditorKit.LinkController, MetalFileChooserUI.SingleClickListener, MetalToolBarUI.MetalDockingListener, MouseAdapter, MouseDragGestureRecognizer, MouseInputAdapter, MouseMotionAdapter, ToolTipManager
public interface MouseMotionListener
extends EventListener

用于接收组件上的鼠标移动事件的侦听器接口。（对于单击和其他鼠标事件，请使用 MouseListener。）

旨在处理鼠标移动事件的类要么实现此接口（及其包含的所有方法），要么扩展抽象 MouseMotionAdapter 类（仅重写有用的方法）。

然后使用组件的 addMouseMotionListener 方法将从该类所创建的侦听器对象向该组件注册。移动或拖动鼠标时会生成鼠标移动事件。（将生成很多此类事件）。发生鼠标移动事件时，将调用该侦听器对象中的相应方法，并将 MouseEvent 传递给该方法。

从以下版本开始：
1.1
另请参见：
MouseMotionAdapter, MouseEvent, Tutorial: Writing a Mouse Motion Listener

方法摘要
void | mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。

方法详细信息

mouseDragged

void mouseDragged(MouseEvent e)
鼠标按键在组件上按下并拖动时调用。在释放鼠标按键前，MOUSE_DRAGGED 事件被连续地传递到发起该拖动的组件（而不管鼠标位置是否处于该组件的边界内）。

由于拖放实现是与平台相关的，所以在本机拖放操作期间可能不传递 MOUSE_DRAGGED 事件。

mouseMoved

void mouseMoved(MouseEvent e)
鼠标光标移动到组件上但无按键按下时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseWheelEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 MouseWheelEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.InputEvent
                    继承者  java.awt.event.MouseEvent
                        继承者  java.awt.event.MouseWheelEvent
所有已实现的接口：
Serializable
public class MouseWheelEvent
extends MouseEvent

表示鼠标滚轮在组件中滚动的事件。

滚轮鼠标是一种用滚轮代替中间按键的鼠标。可朝向用户或背离用户旋转此滚轮。尽管鼠标滚轮也有其他用途，但最主要的是用于滚动。

MouseWheelEvent 对象传递给每一个 MouseWheelListener 对象，该对象使用组件的 addMouseWheelListener 方法注册，以接收“感兴趣”鼠标事件。所有此类侦听器对象都获得包含鼠标事件的 MouseEvent。

由于鼠标滚轮与滚动 Component 的特殊关系，传递 MouseWheelEvent 与传递其他 MouseEvent 稍有不同。这是因为，其他 MouseEvent 通常影响鼠标光标正下方 Component 的更改（如单击某个按钮时），而 MouseWheelEvent 常会在远离鼠标光标处产生影响（位于 ScrollPane 中的某个 Component 上时，滚动滚轮就能滚动 ScrollPane 上的某个 Scrollbar）。

MouseWheelEvent 从鼠标光标下的 Component 开始传递。如果在该 Component 上没有启用 MouseWheelEvent，则把事件传递到启用 MouseWheelEvent 的第一个祖先 Container。这通常是启用了滚轮滚动的 ScrollPane。源 Component 和 x、y 坐标都是相对于该事件的最终目标 (ScrollPane)。这就允许将复杂的 GUI 不加修改地安装到 ScrollPane 中，并让传递到 ScrollPane 的所有 MouseWheelEvent 能够滚动。

某些 AWT Component 是用本机小部件实现的，这些小部件显示它们自己的滚动条，并能自行处理滚动。这种特殊的 Component 因平台而异。当在这些 Component 上移动鼠标滚轮时，事件将直接传递到本机小部件而不会传播到其祖先。

各种平台提供在移动鼠标滚轮时应该发生的自定义滚动量。两个最常见的设置是滚动一定的“单位”数（通常是基于文本的组件中的文本行），或者整个“块”（类似于 page-up/page-down）。MouseWheelEvent 提供了符合底层平台设置的各种方法。用户可在任何时间改变这些平台设置。MouseWheelEvent 反映最新的设置。

从以下版本开始：
1.4
另请参见：
MouseWheelListener, ScrollPane, ScrollPane.setWheelScrollingEnabled(boolean), JScrollPane, JScrollPane.setWheelScrollingEnabled(boolean), 序列化表格

字段摘要
static int | WHEEL_BLOCK_SCROLL 表示按“块”进行滚动的常量（如使用 page-up、page-down 键进行滚动）
static int | WHEEL_UNIT_SCROLL 表示按“单位”进行滚动的常量（如使用方向键进行滚动）
从类 java.awt.event.MouseEvent 继承的字段
BUTTON1, BUTTON2, BUTTON3, MOUSE_CLICKED, MOUSE_DRAGGED, MOUSE_ENTERED, MOUSE_EXITED, MOUSE_FIRST, MOUSE_LAST, MOUSE_MOVED, MOUSE_PRESSED, MOUSE_RELEASED, MOUSE_WHEEL, NOBUTTON
从类 java.awt.event.InputEvent 继承的字段
ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
MouseWheelEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、滚动类型、滚动量和滚轮旋转的 MouseWheelEvent。
MouseWheelEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、绝对坐标、滚动类型、滚动量和滚轮滚动的 MouseWheelEvent 对象。
方法摘要
int | getScrollAmount() 返回每转动一下鼠标滚轮应该滚动的单位数。
int | getScrollType() 返回响应此事件时应该发生的滚动类型。
int | getUnitsToScroll() 这是帮助实现常用 MouseWheelListener 的便捷方法，以使 ScrollPane 或 JScrollPane 的滚动量符合平台的设置。
int | getWheelRotation() 返回鼠标滚轮旋转的“喀哒声”的次数。
String | paramString() 返回标识此事件的参数字符串。
从类 java.awt.event.MouseEvent 继承的方法
getButton, getClickCount, getLocationOnScreen, getMouseModifiersText, getPoint, getX, getXOnScreen, getY, getYOnScreen, isPopupTrigger, translatePoint
从类 java.awt.event.InputEvent 继承的方法
consume, getModifiers, getModifiersEx, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
getID, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

WHEEL_UNIT_SCROLL

public static final int WHEEL_UNIT_SCROLL
表示按“单位”进行滚动的常量（如使用方向键进行滚动）

另请参见：
getScrollType(), 常量字段值

WHEEL_BLOCK_SCROLL

public static final int WHEEL_BLOCK_SCROLL
表示按“块”进行滚动的常量（如使用 page-up、page-down 键进行滚动）

另请参见：
getScrollType(), 常量字段值
构造方法详细信息

MouseWheelEvent

public MouseWheelEvent(Component source,
                       int id,
                       long when,
                       int modifiers,
                       int x,
                       int y,
                       int clickCount,
                       boolean popupTrigger,
                       int scrollType,
                       int scrollAmount,
                       int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、滚动类型、滚动量和滚轮旋转的 MouseWheelEvent。

绝对坐标 xAbs 和 yAbs 被设置为屏幕上的原点位置加上相对坐标 x 和 y。如果不显示原点，则 xAbs 和 yAbs 被设置为零。

注意，传递无效的 id 将导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Component
id - 标识事件的整数
when - 给出事件发生时间的 long 值
modifiers - 事件期间按下的修改键（如 shift、ctrl、alt、meta）
x - 鼠标位置的水平 x 坐标
y - 鼠标位置的垂直 y 坐标
clickCount - 与事件关联的鼠标单击数
popupTrigger - 一个 boolean 值，如果此事件是弹出菜单的触发器，则为 true
scrollType - 响应此事件时应该发生的滚动类型；有效值有 WHEEL_UNIT_SCROLL 和 WHEEL_BLOCK_SCROLL
scrollAmount - 对于 scrollType WHEEL_UNIT_SCROLL，该参数表示要滚动的单位数
wheelRotation - 鼠标滚轮的旋转量（“喀哒声”的次数）
抛出：
IllegalArgumentException - 如果 source 为 null
另请参见：
MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, boolean), MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)

MouseWheelEvent

public MouseWheelEvent(Component source,
                       int id,
                       long when,
                       int modifiers,
                       int x,
                       int y,
                       int xAbs,
                       int yAbs,
                       int clickCount,
                       boolean popupTrigger,
                       int scrollType,
                       int scrollAmount,
                       int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、绝对坐标、滚动类型、滚动量和滚轮滚动的 MouseWheelEvent 对象。

注意，传入无效 id 将导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

即使将不一致的相对坐标值和绝对坐标值传递给构造方法，MouseWheelEvent 实例也能被创建，并且不抛出任何异常。

参数：
source - 产生该事件的 Component
id - 标识事件的整数
when - 给出事件发生时间的 long 值
modifiers - 发生事件期间按下的修改键（shift、ctrl、alt 和 meta）
x - 鼠标位置的水平 x 坐标
y - 鼠标位置的垂直 y 坐标
xAbs - 鼠标位置的绝对水平 x 坐标
yAbs - 鼠标位置的绝对垂直 y 坐标
clickCount - 与该事件有关的鼠标单击次数
popupTrigger - 一个 boolean 值，如果此事件是弹出菜单的触发器，则为 true
scrollType - 响应此事件时应该发生的滚动类型；有效值有 WHEEL_UNIT_SCROLL 和 WHEEL_BLOCK_SCROLL
scrollAmount - 对于 scrollType WHEEL_UNIT_SCROLL，是要滚动的单位数
wheelRotation - 鼠标滚轮的旋转量（“喀哒声”的次数）
抛出：
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.6
另请参见：
MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, boolean), MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)
方法详细信息

getScrollType

public int getScrollType()
返回响应此事件时应该发生的滚动类型。这由本机平台所决定。合法的值有：
  • MouseWheelEvent.WHEEL_UNIT_SCROLL
  • MouseWheelEvent.WHEEL_BLOCK_SCROLL

返回：
根据本机平台的配置，返回 MouseWheelEvent.WHEEL_UNIT_SCROLL 或 MouseWheelEvent.WHEEL_BLOCK_SCROLL。
另请参见：
Adjustable.getUnitIncrement(),
Adjustable.getBlockIncrement(),
Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int),
Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

getScrollAmount

public int getScrollAmount()
返回每转动一下鼠标滚轮应该滚动的单位数。仅在 getScrollType 返回 MouseWheelEvent.WHEEL_UNIT_SCROLL 时有效。

返回：
要滚动的单位数；如果 getScrollType 返回 MouseWheelEvent.WHEEL_BLOCK_SCROLL，则为不明确的值
另请参见：
getScrollType()

getWheelRotation

public int getWheelRotation()
返回鼠标滚轮旋转的“喀哒声”的次数。

返回：
如果鼠标滚轮向上/远离用户方向旋转，则为负值；如果鼠标滚轮向下/朝向用户方向旋转，则为正值

getUnitsToScroll

public int getUnitsToScroll()
这是帮助实现常用 MouseWheelListener 的便捷方法，以使 ScrollPane 或 JScrollPane 的滚动量符合平台的设置。（注意，ScrollPane 和 JScrollPane 已内置了此功能。）

当滚动类型是 MouseWheelEvent.WHEEL_UNIT_SCROLL 时，此方法返回要滚动的单位数，只有在 getScrollType 返回 MouseWheelEvent.WHEEL_UNIT_SCROLL 时才应该调用此方法。

滚动方向、滚轮移动量和滚轮滚动的平台设置都要考虑在内。此方法没有也不能考虑 Adjustable/Scrollable 单位增量值，因为该值随滚动组件的不同而不同。

以下简化的示例说明了在侦听器中如何使用此方法：

  mouseWheelMoved(MouseWheelEvent event) {
      ScrollPane sp = getScrollPaneFromSomewhere();
      Adjustable adj = sp.getVAdjustable()
      if (MouseWheelEvent.getScrollType() == WHEEL_UNIT_SCROLL) {
          int totalScrollAmount =
              event.getUnitsToScroll() *
              adj.getUnitIncrement();
          adj.setValue(adj.getValue() + totalScrollAmount);
      }
  }

返回：
根据鼠标滚轮旋转的方向和旋转量，以及本机平台的滚轮滚动设置所得出的滚动单位数
另请参见：
getScrollType(), getScrollAmount(), MouseWheelListener, Adjustable, Adjustable.getUnitIncrement(), Scrollable, Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int), ScrollPane, ScrollPane.setWheelScrollingEnabled(boolean), JScrollPane, JScrollPane.setWheelScrollingEnabled(boolean)

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 MouseEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseWheelListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 MouseWheelListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicComboPopup.InvocationMouseHandler, BasicComboPopup.ListMouseHandler, BasicDesktopIconUI.MouseInputHandler, BasicFileChooserUI.DoubleClickListener, BasicInternalFrameUI.BorderListener, BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.TrackListener, BasicScrollPaneUI.MouseWheelHandler, BasicSliderUI.TrackListener, BasicSplitPaneDivider.MouseHandler, BasicTabbedPaneUI.MouseHandler, BasicTreeUI.MouseHandler, FormView.MouseEventListener, HTMLEditorKit.LinkController, MetalFileChooserUI.SingleClickListener, MouseAdapter, MouseInputAdapter, ToolTipManager
public interface MouseWheelListener
extends EventListener

用于接收组件上的鼠标滚轮事件的侦听器接口。（对于单击和其他鼠标事件，请使用 MouseListener。对于鼠标移动和拖动，请使用 MouseMotionListener。）

旨在处理鼠标滚轮事件的类实现此接口（及其包含的所有方法）。

然后使用组件的 addMouseWheelListener 方法将从该类所创建的侦听器对象向该组件注册。旋转鼠标滚轮时生成鼠标滚轮事件。发生鼠标滚轮事件时，将调用对象的 mouseWheelMoved 方法。

有关如何指派鼠标滚轮事件的信息，请参阅 MouseWheelEvent 的类描述。

从以下版本开始：
1.4
另请参见：
MouseWheelEvent

方法摘要
 void mouseWheelMoved(MouseWheelEvent e)
鼠标滚轮旋转时调用。

方法详细信息

mouseWheelMoved

void mouseWheelMoved(MouseWheelEvent e)
鼠标滚轮旋转时调用。

另请参见：
MouseWheelEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PaintEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 PaintEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.PaintEvent
所有已实现的接口：
Serializable
public class PaintEvent
extends ComponentEvent

组件级绘制事件。此事件是一个特殊事件类型，用于确保 paint/update 方法的调用连同从事件队列传递过来的其他事件一起序列化。此事件并非专用于事件侦听器模型；程序应该连续重写 paint/update 方法以便正确呈现自身。

从以下版本开始：
1.1
另请参见：
序列化表格

字段摘要
static int | PAINT 绘制事件类型。
static int | PAINT_FIRST 标记绘制事件 id 范围中的首个整数 id。
static int | PAINT_LAST 标记绘制事件 id 范围中的最后一个整数 id。
static int | UPDATE 更新事件类型。
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PaintEvent(Component source, int id, Rectangle updateRect)
构造一个具有指定源组件和类型的 PaintEvent 对象。
方法摘要
Rectangle | getUpdateRect() 返回表示需要重绘区域以响应此事件的矩形。
String | paramString() 返回标识此事件的参数字符串。
void | setUpdateRect(Rectangle updateRect) 设置表示需要进行重绘区域以响应此事件的矩形。
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

PAINT_FIRST

public static final int PAINT_FIRST
标记绘制事件 id 范围中的首个整数 id。

另请参见：
常量字段值

PAINT_LAST

public static final int PAINT_LAST
标记绘制事件 id 范围中的最后一个整数 id。

另请参见：
常量字段值

PAINT

public static final int PAINT
绘制事件类型。

另请参见：
常量字段值

UPDATE

public static final int UPDATE
更新事件类型。

另请参见：
常量字段值
构造方法详细信息

PaintEvent

public PaintEvent(Component source,
                  int id,
                  Rectangle updateRect)
构造一个具有指定源组件和类型的 PaintEvent 对象。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的对象
id - 事件类型
updateRect - 需要重绘的矩形区域
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

getUpdateRect

public Rectangle getUpdateRect()
返回表示需要重绘区域以响应此事件的矩形。

setUpdateRect

public void setUpdateRect(Rectangle updateRect)
设置表示需要进行重绘区域以响应此事件的矩形。

参数：
updateRect - 需要重绘的矩形区域

paramString

public String paramString()
从类 ComponentEvent 复制的描述
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 ComponentEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 TextEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.TextEvent
所有已实现的接口：
Serializable
public class TextEvent
extends AWTEvent

指示对象文本已改变的语义事件。当某个对象（如 TextComponent）的文本改变时，该对象将生成此高级别事件。该事件被传递给每一个使用组件的 addTextListener 方法注册以接收这种事件的 TextListener 对象。

事件发生时，实现 TextListener 接口的对象获得此 TextEvent。侦听器不必考虑个别鼠标移动和击键的细节，而是可以处理像“文本改变”这样的“有意义”（语义）事件。

从以下版本开始：
1.1
另请参见：
TextComponent, TextListener, Tutorial: Writing a Text Listener, 序列化表格

字段摘要
static int | TEXT_FIRST 用于文本事件的 id 范围的起始编号。
static int | TEXT_LAST 用于文本事件的 id 范围的结束编号。
static int | TEXT_VALUE_CHANGED 此事件 id 指示对象的文本已改变。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
TextEvent(Object source, int id)
构造一个 TextEvent 对象。
方法摘要
 String paramString()
返回标识此文本事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

TEXT_FIRST

public static final int TEXT_FIRST
用于文本事件的 id 范围的起始编号。

另请参见：
常量字段值

TEXT_LAST

public static final int TEXT_LAST
用于文本事件的 id 范围的结束编号。

另请参见：
常量字段值

TEXT_VALUE_CHANGED

public static final int TEXT_VALUE_CHANGED
此事件 id 指示对象的文本已改变。

另请参见：
常量字段值
构造方法详细信息

TextEvent

public TextEvent(Object source,
                 int id)
构造一个 TextEvent 对象。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的（TextComponent）对象
id - 标识事件类型的整数
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

paramString

public String paramString()
返回标识此文本事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 TextListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, TextArea.AccessibleAWTTextArea, TextComponent.AccessibleAWTTextComponent, TextField.AccessibleAWTTextField
public interface TextListener
extends EventListener

用于接收文本事件的侦听器接口。 旨在处理文本事件的类实现此接口。然后使用组件的 addTextListener 方法将从该类所创建的对象向该组件注册。当组件的文本改变时，将调用侦听器对象的 textValueChanged 方法。

从以下版本开始：
1.1
另请参见：
TextEvent, Tutorial: Writing a Text Listener

方法摘要
 void textValueChanged(TextEvent e)
文本的值已改变时调用。

方法详细信息

textValueChanged

void textValueChanged(TextEvent e)
文本的值已改变时调用。为此方法所编写的代码在文本改变时执行所需的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WindowAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 WindowAdapter

java.lang.Object
    继承者  java.awt.event.WindowAdapter
所有已实现的接口：
WindowFocusListener, WindowListener, WindowStateListener, EventListener
直接已知子类：
BasicToolBarUI.FrameListener, JMenu.WinListener
public abstract class WindowAdapter
extends Object
implements WindowListener, WindowStateListener, WindowFocusListener

接收窗口事件的抽象适配器类。此类中的方法为空。此类存在的目的是方便创建侦听器对象。

扩展此类可创建 WindowEvent 侦听器并为所需事件重写该方法。（如果要实现 WindowListener 接口，则必须定义该接口内的所有方法。此抽象类将所有方法都定义为 null，所以只需针对关心的事件定义方法。）

使用扩展的类可以创建侦听器对象，然后使用窗口的 addWindowListener 方法向该窗口注册侦听器。当通过打开、关闭、激活或停用、图标化或取消图标化而改变了窗口状态时，将调用该侦听器对象中的相关方法，并将 WindowEvent 传递给该方法。

从以下版本开始：
1.1
另请参见：
WindowEvent, WindowListener, Tutorial: Writing a Window Listener

构造方法摘要
WindowAdapter()
方法摘要
void | windowActivated(WindowEvent e) 激活窗口时调用。
void | windowClosed(WindowEvent e) 当窗口已被关闭时调用。
void | windowClosing(WindowEvent e) 窗口正处在关闭过程中时调用。
void | windowDeactivated(WindowEvent e) 停用窗口时调用。
void | windowDeiconified(WindowEvent e) 取消图标化窗口时调用。
void | windowGainedFocus(WindowEvent e) 该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
void | windowIconified(WindowEvent e) 图标化窗口时调用。
void | windowLostFocus(WindowEvent e) 该 Window 不再为聚焦 Window 时调用，不再为聚焦 Window 意味着键盘事件不再传递到该 Window 或其任意子组件。
void | windowOpened(WindowEvent e) 已打开窗口时调用。
void | windowStateChanged(WindowEvent e) 窗口状态改变时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WindowAdapter

public WindowAdapter()
方法详细信息

windowOpened

public void windowOpened(WindowEvent e)
已打开窗口时调用。

指定者：
接口 WindowListener 中的 windowOpened

windowClosing

public void windowClosing(WindowEvent e)
窗口正处在关闭过程中时调用。此时可重写关闭操作。

指定者：
接口 WindowListener 中的 windowClosing

windowClosed

public void windowClosed(WindowEvent e)
当窗口已被关闭时调用。

指定者：
接口 WindowListener 中的 windowClosed

windowIconified

public void windowIconified(WindowEvent e)
图标化窗口时调用。

指定者：
接口 WindowListener 中的 windowIconified
另请参见：
Frame.setIconImage(java.awt.Image)

windowDeiconified

public void windowDeiconified(WindowEvent e)
取消图标化窗口时调用。

指定者：
接口 WindowListener 中的 windowDeiconified

windowActivated

public void windowActivated(WindowEvent e)
激活窗口时调用。

指定者：
接口 WindowListener 中的 windowActivated

windowDeactivated

public void windowDeactivated(WindowEvent e)
停用窗口时调用。

指定者：
接口 WindowListener 中的 windowDeactivated

windowStateChanged

public void windowStateChanged(WindowEvent e)
窗口状态改变时调用。

指定者：
接口 WindowStateListener 中的 windowStateChanged
从以下版本开始：
1.4

windowGainedFocus

public void windowGainedFocus(WindowEvent e)
该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。

指定者：
接口 WindowFocusListener 中的 windowGainedFocus
从以下版本开始：
1.4

windowLostFocus

public void windowLostFocus(WindowEvent e)
该 Window 不再为聚焦 Window 时调用，不再为聚焦 Window 意味着键盘事件不再传递到该 Window 或其任意子组件。

指定者：
接口 WindowFocusListener 中的 windowLostFocus
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WindowEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
类 WindowEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.WindowEvent
所有已实现的接口：
Serializable
public class WindowEvent
extends ComponentEvent

指示窗口状态改变的低级别事件。当打开、关闭、激活、停用、图标化或取消图标化 Window 对象时，或者焦点转移到 Window 内或移出 Window 时，由 Window 对象生成此低级别事件。

该事件被传递给每一个使用窗口的 addWindowListener 方法注册以接收这种事件的 WindowListener 或 WindowAdapter 对象。（WindowAdapter 对象实现 WindowListener 接口。）发生事件时，所有此类侦听器对象都将获取此 WindowEvent。

从以下版本开始：
JDK1.1
另请参见：
WindowAdapter, WindowListener, Tutorial: Writing a Window Listener, 序列化表格

字段摘要
static int | WINDOW_ACTIVATED 窗口激活事件类型。
static int | WINDOW_CLOSED 窗口关闭事件。
static int | WINDOW_CLOSING “窗口正在关闭”事件。
static int | WINDOW_DEACTIVATED 窗口停用事件类型。
static int | WINDOW_DEICONIFIED 窗口取消图标化事件类型。
static int | WINDOW_FIRST 用于窗口事件的 id 范围的起始编号。
static int | WINDOW_GAINED_FOCUS 窗口获得焦点事件类型。
static int | WINDOW_ICONIFIED 窗口图标化事件。
static int | WINDOW_LAST 用于窗口事件的 id 范围的结束编号。
static int | WINDOW_LOST_FOCUS 窗口失去焦点事件类型。
static int | WINDOW_OPENED 窗口打开事件。
static int | WINDOW_STATE_CHANGED 窗口状态改变事件类型。
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
WindowEvent(Window source, int id)
构造一个 WindowEvent 对象。
WindowEvent(Window source, int id, int oldState, int newState)
构造一个具有指定的以前和新窗口状态的 WindowEvent 对象。
WindowEvent(Window source, int id, Window opposite)
构造一个具有指定对应 Window 的 WindowEvent 对象。
WindowEvent(Window source, int id, Window opposite, int oldState, int newState)
构造一个 WindowEvent 对象。
方法摘要
int | getNewState() 对于 WINDOW_STATE_CHANGED 事件，返回新的窗口状态。
int | getOldState() 对于 WINDOW_STATE_CHANGED 事件，返回以前的窗口状态。
Window | getOppositeWindow() 返回在此焦点或活动性变化中所涉及的其他 Window。
Window | getWindow() 返回事件的发起方。
String | paramString() 返回标识此事件的参数字符串。
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

WINDOW_FIRST

public static final int WINDOW_FIRST
用于窗口事件的 id 范围的起始编号。

另请参见：
常量字段值

WINDOW_OPENED

public static final int WINDOW_OPENED
窗口打开事件。仅在第一次使窗口可见时才传递此事件。

另请参见：
常量字段值

WINDOW_CLOSING

public static final int WINDOW_CLOSING
“窗口正在关闭”事件。当用户试图从窗口的系统菜单中关闭该窗口时传递此事件。在处理此事件时，如果程序没有显式地隐藏或释放窗口，则取消窗口关闭操作。

另请参见：
常量字段值

WINDOW_CLOSED

public static final int WINDOW_CLOSED
窗口关闭事件。调用 dispose 使窗口关闭后传递此事件。

另请参见：
常量字段值

WINDOW_ICONIFIED

public static final int WINDOW_ICONIFIED
窗口图标化事件。窗口从正常状态变为最小化状态时传递此事件。对于很多平台而言，已最小化的窗口将显示为窗口 iconImage 属性中所指定的图标。

另请参见：
Frame.setIconImage(java.awt.Image), 常量字段值

WINDOW_DEICONIFIED

public static final int WINDOW_DEICONIFIED
窗口取消图标化事件类型。窗口从最小化状态变为正常状态时传递此事件。

另请参见：
常量字段值

WINDOW_ACTIVATED

public static final int WINDOW_ACTIVATED
窗口激活事件类型。Window 成为活动 Window 时传递此事件。只有框架或对话框可以成为活动 Window。本机的窗口操作系统可能使用特殊装饰表示活动 Window 或其子窗口，如高亮显示标题栏。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

另请参见：
常量字段值

WINDOW_DEACTIVATED

public static final int WINDOW_DEACTIVATED
窗口停用事件类型。Window 不再是活动 Window 时传递此事件。只有框架或对话框可以成为活动 Window。本机的窗口操作系统可能使用特殊装饰表示活动 Window 或其子窗口，如高亮显示标题栏。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

另请参见：
常量字段值

WINDOW_GAINED_FOCUS

public static final int WINDOW_GAINED_FOCUS
窗口获得焦点事件类型。Window 成为聚焦 Window，即该 Window 或其某个子组件接收键盘事件时传递此事件。

另请参见：
常量字段值

WINDOW_LOST_FOCUS

public static final int WINDOW_LOST_FOCUS
窗口失去焦点事件类型。Window 不再是聚焦 Window，即该 Window 或其某个子组件不再接收键盘事件时传递此事件。

另请参见：
常量字段值

WINDOW_STATE_CHANGED

public static final int WINDOW_STATE_CHANGED
窗口状态改变事件类型。Window 的状态因为图标化、最大化等原因而发生改变时传递此事件。

从以下版本开始：
1.4
另请参见：
常量字段值

WINDOW_LAST

public static final int WINDOW_LAST
用于窗口事件的 id 范围的结束编号。

另请参见：
常量字段值
构造方法详细信息

WindowEvent

public WindowEvent(Window source,
                   int id,
                   Window opposite,
                   int oldState,
                   int newState)
构造一个 WindowEvent 对象。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Window 对象
id - 指示事件类型的整数。
opposite - 焦点或活动性变化中涉及的其他窗口，或者为 null
oldState - 窗口以前的状态，用于窗口状态改变事件
newState - 窗口的新状态，用于窗口状态改变事件
抛出：
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.4

WindowEvent

public WindowEvent(Window source,
                   int id,
                   Window opposite)
构造一个具有指定对应 Window 的 WindowEvent 对象。对应 Window 是此焦点或活动性变化中所涉及的其他 Window。对于 WINDOW_ACTIVATED 或 WINDOW_GAINED_FOCUS 事件，这是失去活动性或焦点的 Window。对于 WINDOW_DEACTIVATED 或 WINDOW_LOST_FOCUS 事件，这是获得活动性或焦点的 Window。如果本机应用程序、不同 VM 中的 Java 应用程序或没有其他 Window 的窗口发生了这种焦点改变，则对应 Window 为 null。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Window 对象
id - WINDOW_ACTIVATED、WINDOW_DEACTIVATED、WINDOW_GAINED_FOCUS 或 WINDOW_LOST_FOCUS。因为其他 WindowEvent 类型事件的对应 Window 总是为 null，所以不希望将此构造方法用于这种类型的事件
opposite - 焦点或活动性变化中涉及的其他 Window，或者为 null
抛出：
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.4

WindowEvent

public WindowEvent(Window source,
                   int id,
                   int oldState,
                   int newState)
构造一个具有指定的以前和新窗口状态的 WindowEvent 对象。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Window 对象
id - WINDOW_STATE_CHANGED 事件类型。因为对于其他 WindowEvent 事件类型而言，以前和新的窗口状态是无意义的，所以不希望将此构造方法用于其他事件类型。
oldState - 表示以前窗口状态的整数
newState - 表示新窗口状态的整数
抛出：
IllegalArgumentException - 如果 source 为 null
从以下版本开始：
1.4

WindowEvent

public WindowEvent(Window source,
                   int id)
构造一个 WindowEvent 对象。

注意，传递无效的 id 会导致不明确的行为。如果 source 为 null，则此方法抛出 IllegalArgumentException。

参数：
source - 产生该事件的 Window 对象
id - 指示事件类型的整数
抛出：
IllegalArgumentException - 如果 source 为 null
方法详细信息

getWindow

public Window getWindow()
返回事件的发起方。

返回：
引起该事件的 Window 对象

getOppositeWindow

public Window getOppositeWindow()
返回在此焦点或活动性变化中所涉及的其他 Window。对于 WINDOW_ACTIVATED 或 WINDOW_GAINED_FOCUS 事件，这是失去活动性或焦点的 Window。对于 WINDOW_DEACTIVATED 或 WINDOW_LOST_FOCUS 事件，这是获得活动性或焦点的 Window。对于所有其他 WindowEvent 类型，或者本机应用程序、不同 VM 或上下文中的 Java 应用程序或没有其他 Window 的窗口发生了焦点或活动性变化，则返回 null。

返回：
焦点或活动性变化中所涉及的其他 Window，或者为 null
从以下版本开始：
1.4

getOldState

public int getOldState()
对于 WINDOW_STATE_CHANGED 事件，返回以前的窗口状态。该状态表示为逐位掩码。
  • NORMAL
    指示不设置状态位。
  • ICONIFIED
  • MAXIMIZED_HORIZ
  • MAXIMIZED_VERT
  • MAXIMIZED_BOTH
    连接 MAXIMIZED_HORIZ 和 MAXIMIZED_VERT。

返回：
以前窗口状态的逐位掩码
从以下版本开始：
1.4
另请参见：
Frame.getExtendedState()

getNewState

public int getNewState()
对于 WINDOW_STATE_CHANGED 事件，返回新的窗口状态。该状态表示为逐位掩码。
  • NORMAL
    指示不设置状态位。
  • ICONIFIED
  • MAXIMIZED_HORIZ
  • MAXIMIZED_VERT
  • MAXIMIZED_BOTH
    连接 MAXIMIZED_HORIZ 和 MAXIMIZED_VERT。

返回：
新窗口状态的逐位掩码
从以下版本开始：
1.4
另请参见：
Frame.getExtendedState()

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 ComponentEvent 中的 paramString
返回：
标识事件及其属性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WindowFocusListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 WindowFocusListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicToolBarUI.FrameListener, JMenu.WinListener, WindowAdapter
public interface WindowFocusListener
extends EventListener

用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。旨在处理 WindowEvent 的类要么实现此接口（及其包含的所有方法），要么扩展抽象 WindowAdapter 类（仅重写所需的方法）。然后使用 Window 的 addWindowFocusListener 方法将从该类所创建的侦听器对象向该 Window 注册。当通过打开、关闭、激活、停用、图标化或取消图标化，或者通过将焦点移入或移出 Window 而使该 Window 的状态改变时，将调用侦听器对象中的相关方法，并将 WindowEvent 传递给该方法。

从以下版本开始：
1.4
另请参见：
WindowAdapter, WindowEvent, Tutorial: Writing a Window Listener

方法摘要
void | windowGainedFocus(WindowEvent e) 该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
void | windowLostFocus(WindowEvent e) 该 Window 不再是聚焦 Window 时调用，不再是聚焦 Window 意味着不再传递键盘事件到该 Window 或其任意子组件。

方法详细信息

windowGainedFocus

void windowGainedFocus(WindowEvent e)
该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。

windowLostFocus

void windowLostFocus(WindowEvent e)
该 Window 不再是聚焦 Window 时调用，不再是聚焦 Window 意味着不再传递键盘事件到该 Window 或其任意子组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WindowListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 WindowListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicToolBarUI.FrameListener, JMenu.WinListener, WindowAdapter
public interface WindowListener
extends EventListener

用于接收窗口事件的侦听器接口。旨在处理窗口事件的类要么实现此接口（及其包含的所有方法），要么扩展抽象类 WindowAdapter（仅重写所需的方法）。然后使用窗口的 addWindowListener 方法将从该类所创建的侦听器对象向该 Window 注册。当通过打开、关闭、激活或停用、图标化或取消图标化而改变了窗口状态时，将调用该侦听器对象中的相关方法，并将 WindowEvent 传递给该方法。

从以下版本开始：
1.1
另请参见：
WindowAdapter, WindowEvent, Tutorial: How to Write Window Listeners

方法摘要
void | windowActivated(WindowEvent e) 将 Window 设置为活动 Window 时调用。
void | windowClosed(WindowEvent e) 因对窗口调用 dispose 而将其关闭时调用。
void | windowClosing(WindowEvent e) 用户试图从窗口的系统菜单中关闭窗口时调用。
void | windowDeactivated(WindowEvent e) 当 Window 不再是活动 Window 时调用。
void | windowDeiconified(WindowEvent e) 窗口从最小化状态变为正常状态时调用。
void | windowIconified(WindowEvent e) 窗口从正常状态变为最小化状态时调用。
void | windowOpened(WindowEvent e) 窗口首次变为可见时调用。

方法详细信息

windowOpened

void windowOpened(WindowEvent e)
窗口首次变为可见时调用。

windowClosing

void windowClosing(WindowEvent e)
用户试图从窗口的系统菜单中关闭窗口时调用。

windowClosed

void windowClosed(WindowEvent e)
因对窗口调用 dispose 而将其关闭时调用。

windowIconified

void windowIconified(WindowEvent e)
窗口从正常状态变为最小化状态时调用。对于很多平台而言，已最小化的窗口将显示为窗口 iconImage 属性中所指定的图标。

另请参见：
Frame.setIconImage(java.awt.Image)

windowDeiconified

void windowDeiconified(WindowEvent e)
窗口从最小化状态变为正常状态时调用。

windowActivated

void windowActivated(WindowEvent e)
将 Window 设置为活动 Window 时调用。只有框架或对话框可以成为活动 Window。本机的窗口系统可能使用特殊装饰表示活动 Window 或其子窗口，如高亮显示标题栏。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

windowDeactivated

void windowDeactivated(WindowEvent e)
当 Window 不再是活动 Window 时调用。只有框架或对话框可以成为活动 Window。本机的窗口操作系统可能使用特殊装饰表示活动 Window 或其子窗口，如高亮显示标题栏。活动 Window 要么是聚焦 Window，要么是作为聚焦 Window 所有者的第一个 Frame 或 Dialog。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WindowStateListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.event
接口 WindowStateListener

所有超级接口：
EventListener
所有已知实现类：
AWTEventMulticaster, BasicToolBarUI.FrameListener, JMenu.WinListener, WindowAdapter
public interface WindowStateListener
extends EventListener

用于接收窗口状态事件的侦听器接口。

旨在处理窗口状态事件的类要么实现此接口（及其包含的所有方法），要么扩展抽象 WindowAdapter 类（仅重写所需的方法）。

然后使用 Window 的 addWindowStateListener 方法将从该类所创建的侦听器对象向该 Window 注册。当通过图标化、最大化等改变窗口状态时，就调用侦听器对象中的 windowStateChanged 方法，并将 WindowEvent 传递给该方法。

从以下版本开始：
1.4
另请参见：
WindowAdapter, WindowEvent

方法摘要
 void windowStateChanged(WindowEvent e)
窗口状态改变时调用。

方法详细信息

windowStateChanged

void windowStateChanged(WindowEvent e)
窗口状态改变时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.event (Java 2 Platform SE 6)

 java.awt.event
接口
ActionListener
AdjustmentListener
AWTEventListener
ComponentListener
ContainerListener
FocusListener
HierarchyBoundsListener
HierarchyListener
InputMethodListener
ItemListener
KeyListener
MouseListener
MouseMotionListener
MouseWheelListener
TextListener
WindowFocusListener
WindowListener
WindowStateListener
类
ActionEvent
AdjustmentEvent
AWTEventListenerProxy
ComponentAdapter
ComponentEvent
ContainerAdapter
ContainerEvent
FocusAdapter
FocusEvent
HierarchyBoundsAdapter
HierarchyEvent
InputEvent
InputMethodEvent
InvocationEvent
ItemEvent
KeyAdapter
KeyEvent
MouseAdapter
MouseEvent
MouseMotionAdapter
MouseWheelEvent
PaintEvent
TextEvent
WindowAdapter
WindowEvent


java.awt.event (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.event

提供处理由 AWT 组件所激发的各类事件的接口和类。

请参见：
描述

接口摘要
ActionListener | 用于接收操作事件的侦听器接口。
AdjustmentListener | 用于接收调整事件的侦听器接口。
AWTEventListener | 该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。
ComponentListener | 用于接收组件事件的侦听器接口。
ContainerListener | 用于接收容器事件的侦听器接口。
FocusListener | 用于接收组件上的键盘焦点事件的侦听器接口。
HierarchyBoundsListener | 用于接收祖先的移动和大小调整事件的侦听器接口。
HierarchyListener | 用于接收层次结构更改事件的侦听器接口。
InputMethodListener | 接收输入方法事件的侦听器接口。
ItemListener | 接收项事件的侦听器接口。
KeyListener | 用于接收键盘事件（击键）的侦听器接口。
MouseListener | 用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener | 用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelListener | 用于接收组件上的鼠标滚轮事件的侦听器接口。
TextListener | 用于接收文本事件的侦听器接口。
WindowFocusListener | 用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
WindowListener | 用于接收窗口事件的侦听器接口。
WindowStateListener | 用于接收窗口状态事件的侦听器接口。

类摘要
ActionEvent | 指示发生了组件定义的动作的语义事件。
AdjustmentEvent | 由 Adjustable 对象所发出的调整事件。
AWTEventListenerProxy | 扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。
ComponentAdapter | 用于接收组件事件的抽象适配器类。
ComponentEvent | 指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
ContainerAdapter | 用于接收容器事件的抽象适配器类。
ContainerEvent | 指示容器内容因为添加或移除组件而更改的低级别事件。
FocusAdapter | 用于接收键盘焦点事件的抽象适配器类。
FocusEvent | 指示 Component 已获得或失去输入焦点的低级别事件。
HierarchyBoundsAdapter | 用于接收祖先的移动和大小重调事件的抽象适配器类。
HierarchyEvent | 指示 Component 所属的 Component 层次结构发生更改的事件。
InputEvent | 所有组件级别输入事件的根事件类。
InputMethodEvent | 输入方法事件包含有关使用输入方法进行撰写的文本的信息。
InvocationEvent | 当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
ItemEvent | 指示项被选定或取消选定的语义事件。
KeyAdapter | 接收键盘事件的抽象适配器类。
KeyEvent | 表示组件中发生键击的事件。
MouseAdapter | 接收鼠标事件的抽象适配器类。
MouseEvent | 指示组件中发生鼠标动作的事件。
MouseMotionAdapter | 接收鼠标移动事件的抽象适配器类。
MouseWheelEvent | 表示鼠标滚轮在组件中滚动的事件。
PaintEvent | 组件级绘制事件。
TextEvent | 指示对象文本已改变的语义事件。
WindowAdapter | 接收窗口事件的抽象适配器类。
WindowEvent | 指示窗口状态改变的低级别事件。

软件包 java.awt.event 的描述

提供处理由 AWT 组件所激发的各类事件的接口和类。有关 AWT 事件模型的细节，请参见 java.awt.AWTEvent 类。事件由事件源所激发。向事件源注册的事件侦听器可接收有关特定事件类型的通知。此包定义了事件和事件侦听器，以及事件侦听器适配器，它是让事件侦听器的编写过程更为轻松的便捷类。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.event 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.event 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
    • java.awt.event.ContainerAdapter (implements java.awt.event.ContainerListener)
    • java.util.EventListenerProxy (implements java.util.EventListener)
      • java.awt.event.AWTEventListenerProxy (implements java.awt.event.AWTEventListener)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
        • java.awt.event.ActionEvent
        • java.awt.event.AdjustmentEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.ContainerEvent
          • java.awt.event.FocusEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
            • java.awt.event.MouseEvent
              • java.awt.event.MouseWheelEvent
          • java.awt.event.PaintEvent
          • java.awt.event.WindowEvent
        • java.awt.event.HierarchyEvent
        • java.awt.event.InputMethodEvent
        • java.awt.event.InvocationEvent (implements java.awt.ActiveEvent)
        • java.awt.event.ItemEvent
        • java.awt.event.TextEvent
    • java.awt.event.FocusAdapter (implements java.awt.event.FocusListener)
    • java.awt.event.HierarchyBoundsAdapter (implements java.awt.event.HierarchyBoundsListener)
    • java.awt.event.KeyAdapter (implements java.awt.event.KeyListener)
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
    • java.awt.event.MouseMotionAdapter (implements java.awt.event.MouseMotionListener)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)

接口分层结构

  • java.util.EventListener
    • java.awt.event.ActionListener
    • java.awt.event.AdjustmentListener
    • java.awt.event.AWTEventListener
    • java.awt.event.ComponentListener
    • java.awt.event.ContainerListener
    • java.awt.event.FocusListener
    • java.awt.event.HierarchyBoundsListener
    • java.awt.event.HierarchyListener
    • java.awt.event.InputMethodListener
    • java.awt.event.ItemListener
    • java.awt.event.KeyListener
    • java.awt.event.MouseListener
    • java.awt.event.MouseMotionListener
    • java.awt.event.MouseWheelListener
    • java.awt.event.TextListener
    • java.awt.event.WindowFocusListener
    • java.awt.event.WindowListener
    • java.awt.event.WindowStateListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.event
的使用

使用 java.awt.event 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。
AdjustmentEvent
由 Adjustable 对象所发出的调整事件。
AdjustmentListener
用于接收调整事件的侦听器接口。
AWTEventListener
该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。
ComponentEvent
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
ComponentListener
用于接收组件事件的侦听器接口。
ContainerEvent
指示容器内容因为添加或移除组件而更改的低级别事件。
ContainerListener
用于接收容器事件的侦听器接口。
FocusEvent
指示 Component 已获得或失去输入焦点的低级别事件。
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。
HierarchyBoundsListener
用于接收祖先的移动和大小调整事件的侦听器接口。
HierarchyEvent
指示 Component 所属的 Component 层次结构发生更改的事件。
HierarchyListener
用于接收层次结构更改事件的侦听器接口。
InputMethodEvent
输入方法事件包含有关使用输入方法进行撰写的文本的信息。
InputMethodListener
接收输入方法事件的侦听器接口。
ItemEvent
指示项被选定或取消选定的语义事件。
ItemListener
接收项事件的侦听器接口。
KeyEvent
表示组件中发生键击的事件。
KeyListener
用于接收键盘事件（击键）的侦听器接口。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelEvent
表示鼠标滚轮在组件中滚动的事件。
MouseWheelListener
用于接收组件上的鼠标滚轮事件的侦听器接口。
TextEvent
指示对象文本已改变的语义事件。
TextListener
用于接收文本事件的侦听器接口。
WindowEvent
指示窗口状态改变的低级别事件。
WindowFocusListener
用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
WindowListener
用于接收窗口事件的侦听器接口。
WindowStateListener
用于接收窗口状态事件的侦听器接口。

java.awt.dnd 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。
InputEvent
所有组件级别输入事件的根事件类。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。

java.awt.event 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
AdjustmentEvent
由 Adjustable 对象所发出的调整事件。
AWTEventListener
该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。
ComponentEvent
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
ComponentListener
用于接收组件事件的侦听器接口。
ContainerEvent
指示容器内容因为添加或移除组件而更改的低级别事件。
ContainerListener
用于接收容器事件的侦听器接口。
FocusEvent
指示 Component 已获得或失去输入焦点的低级别事件。
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。
HierarchyBoundsListener
用于接收祖先的移动和大小调整事件的侦听器接口。
HierarchyEvent
指示 Component 所属的 Component 层次结构发生更改的事件。
InputEvent
所有组件级别输入事件的根事件类。
InputMethodEvent
输入方法事件包含有关使用输入方法进行撰写的文本的信息。
ItemEvent
指示项被选定或取消选定的语义事件。
KeyEvent
表示组件中发生键击的事件。
KeyListener
用于接收键盘事件（击键）的侦听器接口。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelEvent
表示鼠标滚轮在组件中滚动的事件。
MouseWheelListener
用于接收组件上的鼠标滚轮事件的侦听器接口。
TextEvent
指示对象文本已改变的语义事件。
WindowEvent
指示窗口状态改变的低级别事件。
WindowFocusListener
用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
WindowListener
用于接收窗口事件的侦听器接口。
WindowStateListener
用于接收窗口状态事件的侦听器接口。

javax.accessibility 使用的 java.awt.event 中的类
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。

javax.swing 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。
AdjustmentListener
用于接收调整事件的侦听器接口。
ComponentAdapter
用于接收组件事件的抽象适配器类。
ComponentEvent
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
ComponentListener
用于接收组件事件的侦听器接口。
ContainerEvent
指示容器内容因为添加或移除组件而更改的低级别事件。
ContainerListener
用于接收容器事件的侦听器接口。
FocusEvent
指示 Component 已获得或失去输入焦点的低级别事件。
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。
InputEvent
所有组件级别输入事件的根事件类。
InputMethodEvent
输入方法事件包含有关使用输入方法进行撰写的文本的信息。
ItemEvent
指示项被选定或取消选定的语义事件。
ItemListener
接收项事件的侦听器接口。
KeyEvent
表示组件中发生键击的事件。
MouseAdapter
接收鼠标事件的抽象适配器类。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelListener
用于接收组件上的鼠标滚轮事件的侦听器接口。
WindowAdapter
接收窗口事件的抽象适配器类。
WindowEvent
指示窗口状态改变的低级别事件。
WindowFocusListener
用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
WindowListener
用于接收窗口事件的侦听器接口。
WindowStateListener
用于接收窗口状态事件的侦听器接口。

javax.swing.event 使用的 java.awt.event 中的类
ComponentEvent
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
InputEvent
所有组件级别输入事件的根事件类。
KeyEvent
表示组件中发生键击的事件。
MouseAdapter
接收鼠标事件的抽象适配器类。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelListener
用于接收组件上的鼠标滚轮事件的侦听器接口。

javax.swing.plaf 使用的 java.awt.event 中的类
MouseEvent
指示组件中发生鼠标动作的事件。

javax.swing.plaf.basic 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。
ComponentAdapter
用于接收组件事件的抽象适配器类。
ComponentEvent
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
ComponentListener
用于接收组件事件的侦听器接口。
ContainerEvent
指示容器内容因为添加或移除组件而更改的低级别事件。
ContainerListener
用于接收容器事件的侦听器接口。
FocusAdapter
用于接收键盘焦点事件的抽象适配器类。
FocusEvent
指示 Component 已获得或失去输入焦点的低级别事件。
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。
ItemEvent
指示项被选定或取消选定的语义事件。
ItemListener
接收项事件的侦听器接口。
KeyAdapter
接收键盘事件的抽象适配器类。
KeyEvent
表示组件中发生键击的事件。
KeyListener
用于接收键盘事件（击键）的侦听器接口。
MouseAdapter
接收鼠标事件的抽象适配器类。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionAdapter
接收鼠标移动事件的抽象适配器类。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelEvent
表示鼠标滚轮在组件中滚动的事件。
MouseWheelListener
用于接收组件上的鼠标滚轮事件的侦听器接口。
WindowAdapter
接收窗口事件的抽象适配器类。
WindowEvent
指示窗口状态改变的低级别事件。
WindowFocusListener
用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
WindowListener
用于接收窗口事件的侦听器接口。
WindowStateListener
用于接收窗口状态事件的侦听器接口。

javax.swing.plaf.metal 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。
ContainerListener
用于接收容器事件的侦听器接口。
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。
MouseAdapter
接收鼠标事件的抽象适配器类。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelListener
用于接收组件上的鼠标滚轮事件的侦听器接口。

javax.swing.plaf.multi 使用的 java.awt.event 中的类
MouseEvent
指示组件中发生鼠标动作的事件。

javax.swing.table 使用的 java.awt.event 中的类
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。
MouseEvent
指示组件中发生鼠标动作的事件。

javax.swing.text 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。
FocusEvent
指示 Component 已获得或失去输入焦点的低级别事件。
FocusListener
用于接收组件上的键盘焦点事件的侦听器接口。
InputMethodEvent
输入方法事件包含有关使用输入方法进行撰写的文本的信息。
InputMethodListener
接收输入方法事件的侦听器接口。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。

javax.swing.text.html 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。
MouseAdapter
接收鼠标事件的抽象适配器类。
MouseEvent
指示组件中发生鼠标动作的事件。
MouseListener
用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
MouseMotionListener
用于接收组件上的鼠标移动事件的侦听器接口。
MouseWheelListener
用于接收组件上的鼠标滚轮事件的侦听器接口。

javax.swing.tree 使用的 java.awt.event 中的类
ActionEvent
指示发生了组件定义的动作的语义事件。
ActionListener
用于接收操作事件的侦听器接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.ContainerAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ContainerAdapter
的使用

没有 java.awt.event.ContainerAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.HierarchyBoundsAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.HierarchyBoundsAdapter
的使用

没有 java.awt.event.HierarchyBoundsAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.TextEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.TextEvent
的使用

使用 TextEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 TextEvent 的使用

参数类型为 TextEvent 的 java.awt 中的方法
protected void | TextComponent.processTextEvent(TextEvent e) 处理发生在此文本组件上的文本事件：将这些事件指派给所有已注册的 TextListener 对象。
void | TextComponent.AccessibleAWTTextComponent.textValueChanged(TextEvent textEvent) 文本值更改的 TextListener 通知。
void | AWTEventMulticaster.textValueChanged(TextEvent e)

java.awt.event 中 TextEvent 的使用

参数类型为 TextEvent 的 java.awt.event 中的方法
 void TextListener.textValueChanged(TextEvent e)
文本的值已改变时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.ItemEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ItemEvent
的使用

使用 ItemEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ItemEvent 的使用

参数类型为 ItemEvent 的 java.awt 中的方法
void | Checkbox.AccessibleAWTCheckbox.itemStateChanged(ItemEvent e) 当切换按钮的状态变化时，激发可访问的属性更改事件。
void | List.AccessibleAWTList.itemStateChanged(ItemEvent event)
void | AWTEventMulticaster.itemStateChanged(ItemEvent e) 通过在侦听器 a 和侦听器 b 上调用 itemStateChanged 方法处理 itemStateChanged 事件。
protected void | Checkbox.processItemEvent(ItemEvent e) 处理发生在此复选框上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
protected void | CheckboxMenuItem.processItemEvent(ItemEvent e) 处理发生在此复选框菜单项上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。
protected void | Choice.processItemEvent(ItemEvent e) 处理发生在此 Choice 菜单上的项事件，实现方式是将这些事件指派给所有已注册的 ItemListener 对象。
protected void | List.processItemEvent(ItemEvent e) 处理发生在此列表上的项事件，方法是将这些事件指派给所有已注册的 ItemListener 对象。

java.awt.event 中 ItemEvent 的使用

参数类型为 ItemEvent 的 java.awt.event 中的方法
 void ItemListener.itemStateChanged(ItemEvent e)
在用户已选定或取消选定某项时调用。

javax.swing 中 ItemEvent 的使用

参数类型为 ItemEvent 的 javax.swing 中的方法
protected void | JComboBox.fireItemStateChanged(ItemEvent e) 通知所有需要此事件类型的通知的已注册侦听器。
protected void | DefaultButtonModel.fireItemStateChanged(ItemEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected void | AbstractButton.fireItemStateChanged(ItemEvent event) 通知所有需要此事件类型的通知的已注册侦听器。
void | DefaultCellEditor.EditorDelegate.itemStateChanged(ItemEvent e) 在项的状态发生更改时，编辑被终止。
void | JToggleButton.AccessibleJToggleButton.itemStateChanged(ItemEvent e) 当切换按钮的状态变化时，激发可访问的属性变更事件。

javax.swing.plaf.basic 中 ItemEvent 的使用

参数类型为 ItemEvent 的 javax.swing.plaf.basic 中的方法
void | BasicComboPopup.ItemHandler.itemStateChanged(ItemEvent e)
void | BasicComboBoxUI.ItemHandler.itemStateChanged(ItemEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.AdjustmentEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.AdjustmentEvent
的使用

使用 AdjustmentEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 AdjustmentEvent 的使用

参数类型为 AdjustmentEvent 的 java.awt 中的方法
void | AWTEventMulticaster.adjustmentValueChanged(AdjustmentEvent e) 通过在侦听器 a 和侦听器 b 上调用 adjustmentValueChanged 方法处理 adjustmentValueChanged 事件。
protected void | Scrollbar.processAdjustmentEvent(AdjustmentEvent e) 处理此滚动条上发生的调整事件，方法是将其指派到任意已注册的 AdjustmentListener 对象。

java.awt.event 中 AdjustmentEvent 的使用

参数类型为 AdjustmentEvent 的 java.awt.event 中的方法
 void AdjustmentListener.adjustmentValueChanged(AdjustmentEvent e)
在可调整的值发生更改时调用该方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.ComponentAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ComponentAdapter
的使用

使用 ComponentAdapter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 ComponentAdapter 的使用

javax.swing 中 ComponentAdapter 的子类
protected  class JViewport.ViewListener
视图的侦听器。

javax.swing.plaf.basic 中 ComponentAdapter 的使用

javax.swing.plaf.basic 中 ComponentAdapter 的子类
class | BasicSliderUI.ComponentHandler 调整事件大小的侦听器。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.WindowAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.WindowAdapter
的使用

使用 WindowAdapter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 WindowAdapter 的使用

javax.swing 中 WindowAdapter 的子类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowAdapter 的使用

javax.swing.plaf.basic 中 WindowAdapter 的子类
protected  class BasicToolBarUI.FrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.FocusAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.FocusAdapter
的使用

使用 FocusAdapter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 FocusAdapter 的使用

javax.swing.plaf.basic 中 FocusAdapter 的子类
class | BasicSplitPaneUI.FocusHandler JSplitPane UI 使用的 FocusListener 的实现。
class | BasicTabbedPaneUI.FocusHandler 此类应视为“受保护”内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.AWTEventListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.AWTEventListenerProxy
的使用

没有 java.awt.event.AWTEventListenerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.ContainerEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ContainerEvent
的使用

使用 ContainerEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 java.awt 中的方法
void | AWTEventMulticaster.componentAdded(ContainerEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentAdded 方法处理 componentAdded 容器事件。
void | Container.AccessibleAWTContainer.AccessibleContainerHandler.componentAdded(ContainerEvent e)
void | AWTEventMulticaster.componentRemoved(ContainerEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentRemoved 方法处理 componentRemoved 容器事件。
void | Container.AccessibleAWTContainer.AccessibleContainerHandler.componentRemoved(ContainerEvent e)
protected void | Container.processContainerEvent(ContainerEvent e) 通过将发生在此容器上的容器事件指派给所有已注册的 ContainerListener 对象来处理这些事件。

java.awt.event 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 java.awt.event 中的方法
void | ContainerAdapter.componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | ContainerListener.componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | ContainerAdapter.componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
void | ContainerListener.componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。

javax.swing 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 javax.swing 中的方法
void | JComponent.AccessibleJComponent.AccessibleContainerHandler.componentAdded(ContainerEvent e)
void | JComponent.AccessibleJComponent.AccessibleContainerHandler.componentRemoved(ContainerEvent e)

javax.swing.plaf.basic 中 ContainerEvent 的使用

参数类型为 ContainerEvent 的 javax.swing.plaf.basic 中的方法
void | BasicToolBarUI.ToolBarContListener.componentAdded(ContainerEvent e)
void | BasicToolBarUI.ToolBarContListener.componentRemoved(ContainerEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.TextListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.TextListener
的使用

使用 TextListener 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextListener 的使用

实现 TextListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

声明为 TextListener 的 java.awt 中的字段
protected  TextListener TextComponent.textListener

返回 TextListener 的 java.awt 中的方法
static TextListener | AWTEventMulticaster.add(TextListener a, TextListener b)
TextListener[] | TextComponent.getTextListeners() 返回在此文本组件上所有已注册文本侦听器的数组。
static TextListener | AWTEventMulticaster.remove(TextListener l, TextListener oldl)

参数类型为 TextListener 的 java.awt 中的方法
static TextListener | AWTEventMulticaster.add(TextListener a, TextListener b)
void | TextComponent.addTextListener(TextListener l) 添加指定的文本事件侦听器，以接收此文本组件发出的文本事件。
static TextListener | AWTEventMulticaster.remove(TextListener l, TextListener oldl)
void | TextComponent.removeTextListener(TextListener l) 移除指定的文本事件侦听器，不再接收此文本组件发出的文本事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.AdjustmentListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.AdjustmentListener
的使用

使用 AdjustmentListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 AdjustmentListener 的使用

实现 AdjustmentListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 AdjustmentListener 的 java.awt 中的方法
static AdjustmentListener | AWTEventMulticaster.add(AdjustmentListener a, AdjustmentListener b) 添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。
AdjustmentListener[] | ScrollPaneAdjustable.getAdjustmentListeners() 返回在此 ScrollPaneAdjustable 上所有已注册调整侦听器组成的数组。
AdjustmentListener[] | Scrollbar.getAdjustmentListeners() 返回在此滚动条上所有已注册调整侦听器组成的数组。
static AdjustmentListener | AWTEventMulticaster.remove(AdjustmentListener l, AdjustmentListener oldl) 从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。

参数类型为 AdjustmentListener 的 java.awt 中的方法
static AdjustmentListener | AWTEventMulticaster.add(AdjustmentListener a, AdjustmentListener b) 添加调整侦听器 a 和调整侦听器 b，并返回得到的多路广播侦听器。
void | ScrollPaneAdjustable.addAdjustmentListener(AdjustmentListener l) 添加指定的调整侦听器，以接收发自此 ScrollPaneAdjustable 的调整事件。
void | Scrollbar.addAdjustmentListener(AdjustmentListener l) 添加指定的调整侦听器，以接收发自此滚动条的 AdjustmentEvent 实例。
void | Adjustable.addAdjustmentListener(AdjustmentListener l) 添加侦听器，以便在可调整对象的值更改时接收调整事件。
static AdjustmentListener | AWTEventMulticaster.remove(AdjustmentListener l, AdjustmentListener oldl) 从调整侦听器 l 中移除旧的调整侦听器，并返回得到的多路广播侦听器。
void | ScrollPaneAdjustable.removeAdjustmentListener(AdjustmentListener l) 移除指定的调整侦听器，不再接收发自此 ScrollPaneAdjustable 的调整事件。
void | Scrollbar.removeAdjustmentListener(AdjustmentListener l) 移除指定的调整侦听器，不再接收发自此滚动条的 AdjustmentEvent 实例。
void | Adjustable.removeAdjustmentListener(AdjustmentListener l) 移除一个调整侦听器。

javax.swing 中 AdjustmentListener 的使用

返回 AdjustmentListener 的 javax.swing 中的方法
 AdjustmentListener[] JScrollBar.getAdjustmentListeners()
返回使用 addAdjustmentListener() 添加到此 JScrollBar 中的 AdjustmentListener 组成的数组。

参数类型为 AdjustmentListener 的 javax.swing 中的方法
void | JScrollBar.addAdjustmentListener(AdjustmentListener l) 添加一个 AdjustmentListener。
void | JScrollBar.removeAdjustmentListener(AdjustmentListener l) 移除一个 AdjustmentEvent 侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.WindowStateListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.WindowStateListener
的使用

使用 WindowStateListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowStateListener 的使用

实现 WindowStateListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 WindowStateListener 的 java.awt 中的方法
static WindowStateListener | AWTEventMulticaster.add(WindowStateListener a, WindowStateListener b) 添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。
WindowStateListener[] | Window.getWindowStateListeners() 返回在此窗口注册的所有窗口状态侦听器所组成的数组。
static WindowStateListener | AWTEventMulticaster.remove(WindowStateListener l, WindowStateListener oldl) 从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。

参数类型为 WindowStateListener 的 java.awt 中的方法
static WindowStateListener | AWTEventMulticaster.add(WindowStateListener a, WindowStateListener b) 添加窗口状态侦听器 a 和窗口状态侦听器 b，并返回得到的多路广播侦听器。
void | Window.addWindowStateListener(WindowStateListener l) 添加指定的窗口状态侦听器，以从此窗口接收窗口事件。
static WindowStateListener | AWTEventMulticaster.remove(WindowStateListener l, WindowStateListener oldl) 从窗口状态侦听器 l 中移除旧的窗口状态侦听器，并返回得到的多路广播侦听器。
void | Window.removeWindowStateListener(WindowStateListener l) 移除指定的窗口状态侦听器，以便不再从此窗口接收窗口事件。

java.awt.event 中 WindowStateListener 的使用

实现 WindowStateListener 的 java.awt.event 中的类
 class WindowAdapter
接收窗口事件的抽象适配器类。

javax.swing 中 WindowStateListener 的使用

实现 WindowStateListener 的 javax.swing 中的类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowStateListener 的使用

实现 WindowStateListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.FrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.WindowFocusListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.WindowFocusListener
的使用

使用 WindowFocusListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 WindowFocusListener 的 java.awt 中的方法
static WindowFocusListener | AWTEventMulticaster.add(WindowFocusListener a, WindowFocusListener b) 添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。
WindowFocusListener[] | Window.getWindowFocusListeners() 返回在此窗口注册的所有窗口焦点侦听器所组成的数组。
static WindowFocusListener | AWTEventMulticaster.remove(WindowFocusListener l, WindowFocusListener oldl) 从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。

参数类型为 WindowFocusListener 的 java.awt 中的方法
static WindowFocusListener | AWTEventMulticaster.add(WindowFocusListener a, WindowFocusListener b) 添加窗口焦点侦听器 a 和窗口焦点侦听器 b，并返回得到的多路广播侦听器。
void | Window.addWindowFocusListener(WindowFocusListener l) 添加指定的窗口焦点侦听器，以从此窗口接收窗口事件。
static WindowFocusListener | AWTEventMulticaster.remove(WindowFocusListener l, WindowFocusListener oldl) 从窗口焦点侦听器 l 中移除旧的窗口焦点侦听器，并返回得到的多路广播侦听器。
void | Window.removeWindowFocusListener(WindowFocusListener l) 移除指定的窗口焦点侦听器，以便不再从此窗口接收窗口事件。

java.awt.event 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 java.awt.event 中的类
 class WindowAdapter
接收窗口事件的抽象适配器类。

javax.swing 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 javax.swing 中的类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowFocusListener 的使用

实现 WindowFocusListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.FrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.ItemListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ItemListener
的使用

使用 ItemListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ItemListener 的使用

实现 ItemListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。

返回 ItemListener 的 java.awt 中的方法
static ItemListener | AWTEventMulticaster.add(ItemListener a, ItemListener b) 添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。
ItemListener[] | Checkbox.getItemListeners() 返回已在此复选框上注册的所有项侦听器所组成的数组。
ItemListener[] | CheckboxMenuItem.getItemListeners() 返回在此复选框菜单项上注册的所有项侦听器组成的数组。
ItemListener[] | Choice.getItemListeners() 返回已在此选择上注册的所有项侦听器组成的数组。
ItemListener[] | List.getItemListeners() 返回已在此列表上注册的所有项侦听器的数组。
static ItemListener | AWTEventMulticaster.remove(ItemListener l, ItemListener oldl) 从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。

参数类型为 ItemListener 的 java.awt 中的方法
static ItemListener | AWTEventMulticaster.add(ItemListener a, ItemListener b) 添加项侦听器 a 和项侦听器 b，并返回得到的多路广播侦听器。
void | Checkbox.addItemListener(ItemListener l) 添加指定的项侦听器，以接收来自此复选框的项事件。
void | CheckboxMenuItem.addItemListener(ItemListener l) 添加指定的项侦听器，以接收发自此复选框菜单项的项事件。
void | Choice.addItemListener(ItemListener l) 添加指定的项侦听器，以接收发自此 Choice 菜单的项事件。
void | List.addItemListener(ItemListener l) 添加指定的项侦听器以接收此列表的项事件。
void | ItemSelectable.addItemListener(ItemListener l) 添加侦听器，以接收用户更改项状态时的项事件。
static ItemListener | AWTEventMulticaster.remove(ItemListener l, ItemListener oldl) 从项侦听器 l 中移除旧的项侦听器，并返回得到的多路广播侦听器。
void | Checkbox.removeItemListener(ItemListener l) 移除此项侦听器，这样项侦听器将不再接收发自此复选框的项事件。
void | CheckboxMenuItem.removeItemListener(ItemListener l) 移除指定的项侦听器，以便它不再接收发自此复选框菜单项的项事件。
void | Choice.removeItemListener(ItemListener l) 移除指定的项侦听器，以便它不再接收发自此 Choice 菜单的项事件。
void | List.removeItemListener(ItemListener l) 移除指定的项侦听器，以便不再从此列表接收项事件。
void | ItemSelectable.removeItemListener(ItemListener l) 移除项侦听器。

javax.swing 中 ItemListener 的使用

实现 ItemListener 的 javax.swing 中的类
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。

声明为 ItemListener 的 javax.swing 中的字段
protected  ItemListener AbstractButton.itemListener
按钮模型的 ItemListener。

返回 ItemListener 的 javax.swing 中的方法
protected  ItemListener AbstractButton.createItemListener()
 ItemListener[] JComboBox.getItemListeners()
返回使用 addItemListener() 添加到此 JComboBox 中的所有 ItemListener 组成的数组。
 ItemListener[] DefaultButtonModel.getItemListeners()
返回此 DefaultButtonModel 上所有已注册的项侦听器组成的数组。
 ItemListener[] AbstractButton.getItemListeners()
返回使用 addItemListener() 添加到此 AbstractButton 中的所有 ItemListener 组成的数组。

参数类型为 ItemListener 的 javax.swing 中的方法
void | JComboBox.addItemListener(ItemListener aListener) 添加 ItemListener。
void | DefaultButtonModel.addItemListener(ItemListener l) 向模型添加一个 ItemListener。
void | ButtonModel.addItemListener(ItemListener l) 向模型添加一个 ItemListener。
void | AbstractButton.addItemListener(ItemListener l) 将一个 ItemListener 添加到 checkbox 中。
void | JComboBox.removeItemListener(ItemListener aListener) 移除 ItemListener。
void | DefaultButtonModel.removeItemListener(ItemListener l) 从模型中移除一个 ItemListener。
void | ButtonModel.removeItemListener(ItemListener l) 从模型中移除一个 ItemListener。
void | AbstractButton.removeItemListener(ItemListener l) 从按钮中移除一个 ItemListener。

javax.swing.plaf.basic 中 ItemListener 的使用

实现 ItemListener 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.ItemHandler 此侦听器观察组合框中选择的更改。
protected class | BasicComboPopup.ItemHandler 此侦听器观察组合框中选择的更改。

声明为 ItemListener 的 javax.swing.plaf.basic 中的字段
protected ItemListener | BasicComboPopup.itemListener 此受保护字段是特定于实现的。
protected ItemListener | BasicComboBoxUI.itemListener 此受保护字段是特定于实现的。

返回 ItemListener 的 javax.swing.plaf.basic 中的方法
protected ItemListener | BasicComboPopup.createItemListener() 创建将添加到组合框的 ItemListener。
protected ItemListener | BasicComboBoxUI.createItemListener() 创建将添加到组合框的 ItemListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.MouseAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseAdapter
的使用

使用 MouseAdapter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 MouseAdapter 的使用

javax.swing 中 MouseAdapter 的子类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseAdapter 的使用

javax.swing.event 中 MouseAdapter 的子类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseAdapter 的使用

javax.swing.plaf.basic 中 MouseAdapter 的子类
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。

javax.swing.plaf.metal 中 MouseAdapter 的使用

javax.swing.plaf.metal 中 MouseAdapter 的子类
protected  class MetalFileChooserUI.SingleClickListener

javax.swing.text.html 中 MouseAdapter 的使用

javax.swing.text.html 中 MouseAdapter 的子类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.MouseMotionAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseMotionAdapter
的使用

使用 MouseMotionAdapter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 MouseMotionAdapter 的使用

javax.swing.plaf.basic 中 MouseMotionAdapter 的子类
protected class | BasicComboPopup.InvocationMouseMotionHandler 此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
protected class | BasicComboPopup.ListMouseMotionHandler 在列表上移动鼠标时，此侦听器更改所选项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.ActionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ActionListener
的使用

使用 ActionListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 ActionListener 的使用

实现 ActionListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。

返回 ActionListener 的 java.awt 中的方法
static ActionListener | AWTEventMulticaster.add(ActionListener a, ActionListener b) 添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。
ActionListener[] | Button.getActionListeners() 返回在此按钮上注册的所有动作侦听器的一个数组。
ActionListener[] | List.getActionListeners() 返回已在此列表上注册的所有动作侦听器的数组。
ActionListener[] | TextField.getActionListeners() 返回此文本字段上已注册的所有操作侦听器的数组。
ActionListener[] | TrayIcon.getActionListeners() 返回在已此 TrayIcon 上注册的所有动作侦听器的数组。
ActionListener[] | MenuItem.getActionListeners() 返回在此菜单项上注册的所有动作侦听器组成的数组。
static ActionListener | AWTEventMulticaster.remove(ActionListener l, ActionListener oldl) 从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。

参数类型为 ActionListener 的 java.awt 中的方法
static ActionListener | AWTEventMulticaster.add(ActionListener a, ActionListener b) 添加操作侦听器 a 和操作侦听器 b，并返回得到的多路广播侦听器。
void | Button.addActionListener(ActionListener l) 添加指定的动作侦听器，以接收发自此按钮的动作事件。
void | List.addActionListener(ActionListener l) 添加指定的动作侦听器以从此列表接收动作事件。
void | TextField.addActionListener(ActionListener l) 添加指定的操作侦听器，以从此文本字段接收操作事件。
void | TrayIcon.addActionListener(ActionListener listener) 添加指定的动作侦听器，以接收发自此 TrayIcon 的 ActionEvent。
void | MenuItem.addActionListener(ActionListener l) 添加指定的动作侦听器，以从此菜单项接收动作事件。
static ActionListener | AWTEventMulticaster.remove(ActionListener l, ActionListener oldl) 从操作侦听器 l 中移除旧的操作侦听器，并返回得到的多路广播侦听器。
void | Button.removeActionListener(ActionListener l) 移除指定的动作侦听器，以便它不再接收发自此按钮的动作事件。
void | List.removeActionListener(ActionListener l) 移除指定的动作侦听器，以便不再从此列表接收动作事件。
void | TextField.removeActionListener(ActionListener l) 移除指定的操作侦听器，不再从此文本字段接收操作事件。
void | TrayIcon.removeActionListener(ActionListener listener) 移除指定的动作侦听器。
void | MenuItem.removeActionListener(ActionListener l) 移除指定的动作侦听器，使其不再从此菜单项中接收动作事件。

java.awt.dnd 中 ActionListener 的使用

实现 ActionListener 的 java.awt.dnd 中的类
protected static class DropTarget.DropTargetAutoScroller
此受保护的嵌套类实现自动滚动

javax.swing 中 ActionListener 的使用

javax.swing 中 ActionListener 的子接口
 interface Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。

实现 ActionListener 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | ToolTipManager.insideTimerAction
protected class | ToolTipManager.outsideTimerAction
protected class | ToolTipManager.stillInsideTimerAction

声明为 ActionListener 的 javax.swing 中的字段
protected  ActionListener AbstractButton.actionListener
按钮模型的 ActionListener。

返回 ActionListener 的 javax.swing 中的方法
protected  ActionListener AbstractButton.createActionListener()
 ActionListener JComponent.getActionForKeyStroke(KeyStroke aKeyStroke)
返回执行针对给定键击而注册的操作的对象。
 ActionListener[] JFileChooser.getActionListeners()
返回在此文件选择器上注册的所有操作侦听器的数组。
 ActionListener[] JTextField.getActionListeners()
返回通过 addActionListener() 添加到此 JTextField 中的所有 ActionListener 的数组。
 ActionListener[] JComboBox.getActionListeners()
返回使用 addActionListener() 添加到此 JComboBox 的所有 ActionListener 组成的数组。
 ActionListener[] DefaultButtonModel.getActionListeners()
返回此 DefaultButtonModel 上所有已注册的操作侦听器组成的数组。
 ActionListener[] Timer.getActionListeners()
返回已在此计时器上注册的所有动作侦听器所组成的数组。
 ActionListener[] AbstractButton.getActionListeners()
返回使用 addActionListener() 添加到此 AbstractButton 的所有 ActionListener 组成的数组。

参数类型为 ActionListener 的 javax.swing 中的方法
 void JFileChooser.addActionListener(ActionListener l)
向文件选择器添加一个 ActionListener。
 void JTextField.addActionListener(ActionListener l)
添加指定的操作侦听器以从此文本字段接收操作事件。
 void ComboBoxEditor.addActionListener(ActionListener l)
添加一个 ActionListener。
 void JComboBox.addActionListener(ActionListener l)
添加 ActionListener。
 void DefaultButtonModel.addActionListener(ActionListener l)
向模型添加一个 ActionListener。
 void ButtonModel.addActionListener(ActionListener l)
向模型添加一个 ActionListener。
 void Timer.addActionListener(ActionListener listener)
将一个动作侦听器添加到 Timer。
 void AbstractButton.addActionListener(ActionListener l)
将一个 ActionListener 添加到按钮中。
static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
 void JComponent.registerKeyboardAction(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void JComponent.registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void JFileChooser.removeActionListener(ActionListener l)
从文件选择器中移除一个 ActionListener。
 void JTextField.removeActionListener(ActionListener l)
移除指定的操作侦听器，以便不再从此文本字段接收操作事件。
 void ComboBoxEditor.removeActionListener(ActionListener l)
移除一个 ActionListener
 void JComboBox.removeActionListener(ActionListener l)
移除 ActionListener。
 void DefaultButtonModel.removeActionListener(ActionListener l)
从模型中移除一个 ActionListener。
 void ButtonModel.removeActionListener(ActionListener l)
从模型中移除一个 ActionListener。
 void Timer.removeActionListener(ActionListener listener)
从 Timer 移除指定的动作侦听器。
 void AbstractButton.removeActionListener(ActionListener l)
从按钮中移除一个 ActionListener。

参数类型为 ActionListener 的 javax.swing 中的构造方法
Timer(int delay, ActionListener listener)
创建一个 Timer 并将初始延迟和事件间延迟初始化为 delay 毫秒。

javax.swing.plaf.basic 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.plaf.basic 中的类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicOptionPaneUI.ButtonActionListener 此内部类因编译器故障而被标记为“公开”。
protected class | BasicScrollBarUI.ScrollListener 在 ScrollPane 中发起的滚动事件的侦听器。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicSliderUI.ScrollListener 滚动事件侦听器。
class | BasicSplitPaneUI.KeyboardDownRightHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardEndHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardHomeHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardResizeToggleHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardUpLeftHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

声明为 ActionListener 的 javax.swing.plaf.basic 中的字段
protected ActionListener | BasicSplitPaneUI.keyboardDownRightListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardEndListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardHomeListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardResizeToggleListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardUpLeftListener 已过时。 从 Java 2 platform v1.3 开始。

返回 ActionListener 的 javax.swing.plaf.basic 中的方法
protected ActionListener | BasicOptionPaneUI.createButtonActionListener(int buttonIndex)
protected ActionListener | BasicSplitPaneUI.createKeyboardDownRightListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardEndListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardHomeListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardResizeToggleListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardUpLeftListener() 已过时。 从 Java 2 platform v1.3 开始。

参数类型为 ActionListener 的 javax.swing.plaf.basic 中的方法
void | BasicComboBoxEditor.addActionListener(ActionListener l)
void | BasicComboBoxEditor.removeActionListener(ActionListener l)

javax.swing.plaf.metal 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.text 中的类
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.text.html 中的类
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

javax.swing.tree 中 ActionListener 的使用

实现 ActionListener 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.WindowListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.WindowListener
的使用

使用 WindowListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowListener 的使用

实现 WindowListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 WindowListener 的 java.awt 中的方法
static WindowListener | AWTEventMulticaster.add(WindowListener a, WindowListener b) 添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。
WindowListener[] | Window.getWindowListeners() 返回在此窗口注册的所有窗口侦听器所组成的数组。
static WindowListener | AWTEventMulticaster.remove(WindowListener l, WindowListener oldl) 从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。

参数类型为 WindowListener 的 java.awt 中的方法
static WindowListener | AWTEventMulticaster.add(WindowListener a, WindowListener b) 添加窗口侦听器 a 和窗口侦听器 b，并返回得到的多路广播侦听器。
void | Window.addWindowListener(WindowListener l) 添加指定的窗口侦听器，以从此窗口接收窗口事件。
static WindowListener | AWTEventMulticaster.remove(WindowListener l, WindowListener oldl) 从窗口侦听器 l 中移除旧的窗口侦听器，并返回得到的多路广播侦听器。
void | Window.removeWindowListener(WindowListener l) 移除指定的窗口侦听器，以便不再从此窗口接收窗口事件。

java.awt.event 中 WindowListener 的使用

实现 WindowListener 的 java.awt.event 中的类
 class WindowAdapter
接收窗口事件的抽象适配器类。

javax.swing 中 WindowListener 的使用

实现 WindowListener 的 javax.swing 中的类
protected  class JMenu.WinListener
观察弹出窗口关闭的侦听器类。

javax.swing.plaf.basic 中 WindowListener 的使用

实现 WindowListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.FrameListener

返回 WindowListener 的 javax.swing.plaf.basic 中的方法
protected  WindowListener BasicToolBarUI.createFrameListener()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.KeyAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.KeyAdapter
的使用

使用 KeyAdapter 的软件包
javax.swing.plaf.basic 提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.basic 中 KeyAdapter 的使用

javax.swing.plaf.basic 中 KeyAdapter 的子类
class | BasicComboBoxUI.KeyHandler 此侦听器检查键事件是否不是导航键。
class | BasicComboPopup.InvocationKeyHandler 从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
class | BasicTreeUI.KeyHandler 用于获取多个按键事件以适当生成事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.ActionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ActionEvent
的使用

使用 ActionEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 ActionEvent 的使用

参数类型为 ActionEvent 的 java.awt 中的方法
void | List.AccessibleAWTList.actionPerformed(ActionEvent event)
void | AWTEventMulticaster.actionPerformed(ActionEvent e) 通过在侦听器 a 和侦听器 b 上调用 actionPerformed 方法处理 actionPerformed 事件。
protected void | Button.processActionEvent(ActionEvent e) 处理发生在此按钮上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
protected void | List.processActionEvent(ActionEvent e) 处理发生在此列表上的动作事件，方法是将这些事件指派给所有已注册的 ActionListener 对象。
protected void | TextField.processActionEvent(ActionEvent e) 处理发生在此文本字段上的操作事件：将这些事件指派给所有已注册的 ActionListener 对象。
protected void | MenuItem.processActionEvent(ActionEvent e) 处理此菜单项上发生的动作事件，方法是将其指派给任何已注册的 ActionListener 对象。

java.awt.dnd 中 ActionEvent 的使用

参数类型为 ActionEvent 的 java.awt.dnd 中的方法
 void DropTarget.DropTargetAutoScroller.actionPerformed(ActionEvent e)
导致发生自动滚动

java.awt.event 中 ActionEvent 的使用

参数类型为 ActionEvent 的 java.awt.event 中的方法
 void ActionListener.actionPerformed(ActionEvent e)
发生操作时调用。

javax.swing 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing 中的方法
void | DefaultCellEditor.EditorDelegate.actionPerformed(ActionEvent e) 在执行操作时，编辑被终止。
void | JComboBox.actionPerformed(ActionEvent e) 此方法由于实现的副作用而存在的公共方法。
void | ToolTipManager.insideTimerAction.actionPerformed(ActionEvent e)
void | ToolTipManager.outsideTimerAction.actionPerformed(ActionEvent e)
void | ToolTipManager.stillInsideTimerAction.actionPerformed(ActionEvent e)
protected void | DefaultButtonModel.fireActionPerformed(ActionEvent e) 通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected void | Timer.fireActionPerformed(ActionEvent e) 通知为此事件类型的通知而注册的所有侦听器。
protected void | AbstractButton.fireActionPerformed(ActionEvent event) 通知所有需要此事件类型的通知的已注册侦听器。

javax.swing.plaf.basic 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.plaf.basic 中的方法
void | BasicDesktopPaneUI.OpenAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.CloseAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.MinimizeAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.MaximizeAction.actionPerformed(ActionEvent evt)
void | BasicDesktopPaneUI.NavigateAction.actionPerformed(ActionEvent evt)
void | BasicFileChooserUI.NewFolderAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.GoHomeAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.ChangeToParentDirectoryAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.ApproveSelectionAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.CancelSelectionAction.actionPerformed(ActionEvent e)
void | BasicFileChooserUI.UpdateAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.CloseAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.MaximizeAction.actionPerformed(ActionEvent evt)
void | BasicInternalFrameTitlePane.IconifyAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.RestoreAction.actionPerformed(ActionEvent evt)
void | BasicInternalFrameTitlePane.MoveAction.actionPerformed(ActionEvent e)
void | BasicInternalFrameTitlePane.SizeAction.actionPerformed(ActionEvent e)
void | BasicOptionPaneUI.ButtonActionListener.actionPerformed(ActionEvent e)
void | BasicSliderUI.ScrollListener.actionPerformed(ActionEvent e)
void | BasicSliderUI.ActionScroller.actionPerformed(ActionEvent e)
void | BasicSplitPaneUI.KeyboardUpLeftHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardDownRightHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardHomeHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardEndHandler.actionPerformed(ActionEvent ev)
void | BasicSplitPaneUI.KeyboardResizeToggleHandler.actionPerformed(ActionEvent ev)
void | BasicTreeUI.ComponentHandler.actionPerformed(ActionEvent ae) 因 Timer 而将此方法作为公共方法。
void | BasicTreeUI.TreeTraverseAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreePageAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeIncrementAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeHomeAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeToggleAction.actionPerformed(ActionEvent e)
void | BasicTreeUI.TreeCancelEditingAction.actionPerformed(ActionEvent e)
void | BasicScrollBarUI.ScrollListener.actionPerformed(ActionEvent e)

javax.swing.plaf.metal 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.plaf.metal 中的方法
 void MetalFileChooserUI.DirectoryComboBoxAction.actionPerformed(ActionEvent e)

javax.swing.text 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.text 中的方法
void | StyledEditorKit.FontFamilyAction.actionPerformed(ActionEvent e) 设置字体系列。
void | StyledEditorKit.FontSizeAction.actionPerformed(ActionEvent e) 设置字体大小。
void | StyledEditorKit.ForegroundAction.actionPerformed(ActionEvent e) 设置前景色。
void | StyledEditorKit.AlignmentAction.actionPerformed(ActionEvent e) 设置对齐方式。
void | StyledEditorKit.BoldAction.actionPerformed(ActionEvent e) 切换粗体属性。
void | StyledEditorKit.ItalicAction.actionPerformed(ActionEvent e) 切换斜体属性。
void | StyledEditorKit.UnderlineAction.actionPerformed(ActionEvent e) 切换下划线属性。
void | DefaultEditorKit.DefaultKeyTypedAction.actionPerformed(ActionEvent e) 动作触发时执行的操作。
void | DefaultEditorKit.InsertContentAction.actionPerformed(ActionEvent e) 此动作触发时执行的操作。
void | DefaultEditorKit.InsertBreakAction.actionPerformed(ActionEvent e) 触发此动作时执行该操作。
void | DefaultEditorKit.InsertTabAction.actionPerformed(ActionEvent e) 此动作触发时执行的操作。
void | DefaultEditorKit.CutAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
void | DefaultEditorKit.CopyAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
void | DefaultEditorKit.PasteAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
void | DefaultEditorKit.BeepAction.actionPerformed(ActionEvent e) 触发此动作时执行的操作。
protected JEditorPane | StyledEditorKit.StyledTextAction.getEditor(ActionEvent e) 获得操作的目标编辑器。
protected JTextComponent | TextAction.getTextComponent(ActionEvent e) 确定动作所使用的组件。

javax.swing.text.html 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.text.html 中的方法
void | FormView.actionPerformed(ActionEvent evt) 负责处理 ActionEvent。
void | HTMLEditorKit.InsertHTMLTextAction.actionPerformed(ActionEvent ae) 将 HTML 插入文档。

javax.swing.tree 中 ActionEvent 的使用

参数类型为 ActionEvent 的 javax.swing.tree 中的方法
 void DefaultTreeCellEditor.actionPerformed(ActionEvent e)
计时器被激发时传递消息，这将启动编辑会话。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.WindowEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.WindowEvent
的使用

使用 WindowEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 WindowEvent 的使用

参数类型为 WindowEvent 的 java.awt 中的方法
protected void | Window.processWindowEvent(WindowEvent e) 处理此窗口上发生的窗口事件：将它们指派到任何注册的 WindowListener 对象。
protected void | Window.processWindowFocusEvent(WindowEvent e) 处理此窗口上发生的窗口焦点事件：将它们指派到任何注册的 WindowFocusListener 对象。
protected void | Window.processWindowStateEvent(WindowEvent e) 处理此窗口上发生的窗口状态事件：将它们指派到任何注册的 WindowStateListener 对象。
void | AWTEventMulticaster.windowActivated(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowActivated 方法处理 windowActivated 事件。
void | AWTEventMulticaster.windowClosed(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowClosed 方法处理 windowClosed 事件。
void | AWTEventMulticaster.windowClosing(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowClosing 方法处理 windowClosing 事件。
void | AWTEventMulticaster.windowDeactivated(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowDeactivated 方法处理 windowDeactivated 事件。
void | AWTEventMulticaster.windowDeiconified(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowDeiconified 方法处理 windowDeiconified 事件。
void | AWTEventMulticaster.windowGainedFocus(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowGainedFocus 方法处理 windowGainedFocus 事件。
void | AWTEventMulticaster.windowIconified(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowIconified 方法处理 windowIconified 事件。
void | AWTEventMulticaster.windowLostFocus(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowLostFocus 方法处理 windowLostFocus 事件。
void | AWTEventMulticaster.windowOpened(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowOpened 方法处理 windowOpened 事件。
void | AWTEventMulticaster.windowStateChanged(WindowEvent e) 通过在侦听器 a 和侦听器 b 上调用 windowStateChanged 方法处理 windowStateChanged 事件。

java.awt.event 中 WindowEvent 的使用

参数类型为 WindowEvent 的 java.awt.event 中的方法
void | WindowAdapter.windowActivated(WindowEvent e) 激活窗口时调用。
void | WindowListener.windowActivated(WindowEvent e) 将 Window 设置为活动 Window 时调用。
void | WindowAdapter.windowClosed(WindowEvent e) 当窗口已被关闭时调用。
void | WindowListener.windowClosed(WindowEvent e) 因对窗口调用 dispose 而将其关闭时调用。
void | WindowAdapter.windowClosing(WindowEvent e) 窗口正处在关闭过程中时调用。
void | WindowListener.windowClosing(WindowEvent e) 用户试图从窗口的系统菜单中关闭窗口时调用。
void | WindowAdapter.windowDeactivated(WindowEvent e) 停用窗口时调用。
void | WindowListener.windowDeactivated(WindowEvent e) 当 Window 不再是活动 Window 时调用。
void | WindowAdapter.windowDeiconified(WindowEvent e) 取消图标化窗口时调用。
void | WindowListener.windowDeiconified(WindowEvent e) 窗口从最小化状态变为正常状态时调用。
void | WindowAdapter.windowGainedFocus(WindowEvent e) 该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
void | WindowFocusListener.windowGainedFocus(WindowEvent e) 该 Window 被设置为聚焦 Window 时调用，聚焦 Window 意味着该 Window 或其某个子组件将接收键盘事件。
void | WindowAdapter.windowIconified(WindowEvent e) 图标化窗口时调用。
void | WindowListener.windowIconified(WindowEvent e) 窗口从正常状态变为最小化状态时调用。
void | WindowAdapter.windowLostFocus(WindowEvent e) 该 Window 不再为聚焦 Window 时调用，不再为聚焦 Window 意味着键盘事件不再传递到该 Window 或其任意子组件。
void | WindowFocusListener.windowLostFocus(WindowEvent e) 该 Window 不再是聚焦 Window 时调用，不再是聚焦 Window 意味着不再传递键盘事件到该 Window 或其任意子组件。
void | WindowAdapter.windowOpened(WindowEvent e) 已打开窗口时调用。
void | WindowListener.windowOpened(WindowEvent e) 窗口首次变为可见时调用。
void | WindowAdapter.windowStateChanged(WindowEvent e) 窗口状态改变时调用。
void | WindowStateListener.windowStateChanged(WindowEvent e) 窗口状态改变时调用。

javax.swing 中 WindowEvent 的使用

参数类型为 WindowEvent 的 javax.swing 中的方法
protected void | JDialog.processWindowEvent(WindowEvent e) 根据 defaultCloseOperation 属性的状态处理窗口事件。
protected void | JFrame.processWindowEvent(WindowEvent e) 处理此组件上发生的窗口事件。
void | JMenu.WinListener.windowClosing(WindowEvent e) 从外部关闭弹出菜单时取消选择该菜单。

javax.swing.plaf.basic 中 WindowEvent 的使用

参数类型为 WindowEvent 的 javax.swing.plaf.basic 中的方法
 void BasicToolBarUI.FrameListener.windowClosing(WindowEvent w)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.InputMethodEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.InputMethodEvent
的使用

使用 InputMethodEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 java.awt 中的方法
void | AWTEventMulticaster.caretPositionChanged(InputMethodEvent e) 通过在侦听器 a 和侦听器 b 上调用 caretPositionChanged 方法处理 caretPositionChanged 事件。
void | AWTEventMulticaster.inputMethodTextChanged(InputMethodEvent e) 通过在侦听器 a 和侦听器 b 上调用 inputMethodTextChanged 方法处理 inputMethodTextChanged 事件。
protected void | Component.processInputMethodEvent(InputMethodEvent e) 处理组件上发生的输入方法事件，方法是将其指派到任意已注册的 InputMethodListener 对象。

java.awt.event 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 java.awt.event 中的方法
void | InputMethodListener.caretPositionChanged(InputMethodEvent event) 当撰写文本中的 caret 发生变化时调用。
void | InputMethodListener.inputMethodTextChanged(InputMethodEvent event) 当通过输入方法输入的文本发生变化时调用。

javax.swing 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 javax.swing 中的方法
protected  void JFormattedTextField.processInputMethodEvent(InputMethodEvent e)
处理所有的输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED 或 InputMethodEvent.CARET_POSITION_CHANGED。

javax.swing.text 中 InputMethodEvent 的使用

参数类型为 InputMethodEvent 的 javax.swing.text 中的方法
protected  void JTextComponent.processInputMethodEvent(InputMethodEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.HierarchyEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.HierarchyEvent
的使用

使用 HierarchyEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 HierarchyEvent 的使用

参数类型为 HierarchyEvent 的 java.awt 中的方法
void | AWTEventMulticaster.ancestorMoved(HierarchyEvent e) 通过在侦听器 a 和侦听器 b 上调用 ancestorMoved 方法处理 ancestorMoved 事件。
void | AWTEventMulticaster.ancestorResized(HierarchyEvent e) 通过在侦听器 a 和侦听器 b 上调用 ancestorResized 方法处理 ancestorResized 事件。
void | AWTEventMulticaster.hierarchyChanged(HierarchyEvent e) 通过在侦听器 a 和侦听器 b 上调用 hierarchyChanged 方法处理 hierarchyChanged 事件。
protected void | Component.processHierarchyBoundsEvent(HierarchyEvent e) 处理组件上发生的层次结构边界事件，方法是将其指派到任意已注册的 HierarchyBoundsListener 对象。
protected void | Component.processHierarchyEvent(HierarchyEvent e) 处理组件上发生的层次结构事件，方法是将其指派到任意已注册的 HierarchyListener 对象。

java.awt.event 中 HierarchyEvent 的使用

参数类型为 HierarchyEvent 的 java.awt.event 中的方法
void | HierarchyBoundsAdapter.ancestorMoved(HierarchyEvent e) 移动源的祖先时调用。
void | HierarchyBoundsListener.ancestorMoved(HierarchyEvent e) 移动源的祖先时调用。
void | HierarchyBoundsAdapter.ancestorResized(HierarchyEvent e) 调整源的祖先的大小时调用。
void | HierarchyBoundsListener.ancestorResized(HierarchyEvent e) 调整源的祖先的大小时调用。
void | HierarchyListener.hierarchyChanged(HierarchyEvent e) 层次结构已更改时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.FocusEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.FocusEvent
的使用

使用 FocusEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 FocusEvent 的使用

参数类型为 FocusEvent 的 java.awt 中的方法
void | AWTEventMulticaster.focusGained(FocusEvent e) 通过在侦听器 a 和侦听器 b 上调用 focusGained 方法处理 focusGained 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusGained(FocusEvent event)
void | AWTEventMulticaster.focusLost(FocusEvent e) 通过在侦听器 a 和侦听器 b 上调用 focusLost 方法处理 focusLost 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler.focusLost(FocusEvent event)
protected void | Component.processFocusEvent(FocusEvent e) 处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。

java.awt.event 中 FocusEvent 的使用

参数类型为 FocusEvent 的 java.awt.event 中的方法
void | FocusAdapter.focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | FocusListener.focusGained(FocusEvent e) 组件获得键盘焦点时调用。
void | FocusAdapter.focusLost(FocusEvent e) 组件失去键盘焦点时调用。
void | FocusListener.focusLost(FocusEvent e) 组件失去键盘焦点时调用。

javax.swing 中 FocusEvent 的使用

参数类型为 FocusEvent 的 javax.swing 中的方法
void | JComponent.AccessibleJComponent.AccessibleFocusHandler.focusGained(FocusEvent event)
void | JComponent.AccessibleJComponent.AccessibleFocusHandler.focusLost(FocusEvent event)
protected void | JFormattedTextField.processFocusEvent(FocusEvent e) 处理所有的焦点事件，如 FocusEvent.FOCUS_GAINED 或 FocusEvent.FOCUS_LOST。
protected void | JPopupMenu.processFocusEvent(FocusEvent evt)

javax.swing.plaf.basic 中 FocusEvent 的使用

参数类型为 FocusEvent 的 javax.swing.plaf.basic 中的方法
void | BasicSliderUI.FocusHandler.focusGained(FocusEvent e)
void | BasicSplitPaneUI.FocusHandler.focusGained(FocusEvent ev)
void | BasicTreeUI.FocusHandler.focusGained(FocusEvent e) 在当前树上激活焦点、重绘前导行时调用。
void | BasicTableUI.FocusHandler.focusGained(FocusEvent e)
void | BasicTabbedPaneUI.FocusHandler.focusGained(FocusEvent e)
void | BasicComboBoxEditor.focusGained(FocusEvent e)
void | BasicListUI.FocusHandler.focusGained(FocusEvent e)
void | BasicComboBoxUI.FocusHandler.focusGained(FocusEvent e)
void | BasicToolBarUI.ToolBarFocusListener.focusGained(FocusEvent e)
void | BasicButtonListener.focusGained(FocusEvent e)
void | BasicSliderUI.FocusHandler.focusLost(FocusEvent e)
void | BasicSplitPaneUI.FocusHandler.focusLost(FocusEvent ev)
void | BasicTreeUI.FocusHandler.focusLost(FocusEvent e) 在当前树上激活焦点、重绘前导行时调用。
void | BasicTableUI.FocusHandler.focusLost(FocusEvent e)
void | BasicTabbedPaneUI.FocusHandler.focusLost(FocusEvent e)
void | BasicComboBoxEditor.focusLost(FocusEvent e)
void | BasicListUI.FocusHandler.focusLost(FocusEvent e)
void | BasicComboBoxUI.FocusHandler.focusLost(FocusEvent e)
void | BasicToolBarUI.ToolBarFocusListener.focusLost(FocusEvent e)
void | BasicButtonListener.focusLost(FocusEvent e)

javax.swing.text 中 FocusEvent 的使用

参数类型为 FocusEvent 的 javax.swing.text 中的方法
void | DefaultCaret.focusGained(FocusEvent e) 在包含插入符的组件获得焦点时调用。
void | DefaultCaret.focusLost(FocusEvent e) 在包含插入符的组件失去焦点时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.MouseWheelEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseWheelEvent
的使用

使用 MouseWheelEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 MouseWheelEvent 的使用

参数类型为 MouseWheelEvent 的 java.awt 中的方法
void | AWTEventMulticaster.mouseWheelMoved(MouseWheelEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseWheelMoved 方法处理 mouseWheelMoved 事件。
protected void | ScrollPane.processMouseWheelEvent(MouseWheelEvent e) 处理通过滚动适当量而传递给此 ScrollPane 的鼠标滚轮事件。
protected void | Component.processMouseWheelEvent(MouseWheelEvent e) 处理组件上发生的鼠标滚轮事件，方法是将其指派到任意已注册的 MouseWheelListener 对象。

java.awt.event 中 MouseWheelEvent 的使用

参数类型为 MouseWheelEvent 的 java.awt.event 中的方法
void | MouseAdapter.mouseWheelMoved(MouseWheelEvent e) 鼠标滚轮旋转时调用。
void | MouseWheelListener.mouseWheelMoved(MouseWheelEvent e) 鼠标滚轮旋转时调用。

javax.swing.plaf.basic 中 MouseWheelEvent 的使用

参数类型为 MouseWheelEvent 的 javax.swing.plaf.basic 中的方法
 void BasicScrollPaneUI.MouseWheelHandler.mouseWheelMoved(MouseWheelEvent e)
当鼠标滚轮在 JScrollPane 上转动时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.ContainerListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ContainerListener
的使用

使用 ContainerListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

java.awt 中 ContainerListener 的使用

实现 ContainerListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Container.AccessibleAWTContainer.AccessibleContainerHandler 添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

声明为 ContainerListener 的 java.awt 中的字段
protected  ContainerListener Container.AccessibleAWTContainer.accessibleContainerHandler

返回 ContainerListener 的 java.awt 中的方法
static ContainerListener | AWTEventMulticaster.add(ContainerListener a, ContainerListener b) 添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。
ContainerListener[] | Container.getContainerListeners() 返回已在此容器上注册的所有容器侦听器的数组。
static ContainerListener | AWTEventMulticaster.remove(ContainerListener l, ContainerListener oldl) 从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。

参数类型为 ContainerListener 的 java.awt 中的方法
static ContainerListener | AWTEventMulticaster.add(ContainerListener a, ContainerListener b) 添加容器侦听器 a 和容器侦听器 b，并返回得到的多路广播侦听器。
void | Container.addContainerListener(ContainerListener l) 添加指定容器的侦听器，以接收来自此容器的容器事件。
static ContainerListener | AWTEventMulticaster.remove(ContainerListener l, ContainerListener oldl) 从容器侦听器 l 中移除旧的容器侦听器，并返回得到的多路广播侦听器。
void | Container.removeContainerListener(ContainerListener l) 移除指定容器的侦听器，从而不再接收来自此容器的容器事件。

java.awt.event 中 ContainerListener 的使用

实现 ContainerListener 的 java.awt.event 中的类
 class ContainerAdapter
用于接收容器事件的抽象适配器类。

javax.swing 中 ContainerListener 的使用

实现 ContainerListener 的 javax.swing 中的类
protected  class JComponent.AccessibleJComponent.AccessibleContainerHandler
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

声明为 ContainerListener 的 javax.swing 中的字段
protected  ContainerListener JComponent.AccessibleJComponent.accessibleContainerHandler

javax.swing.plaf.basic 中 ContainerListener 的使用

实现 ContainerListener 的 javax.swing.plaf.basic 中的类
protected  class BasicToolBarUI.ToolBarContListener

声明为 ContainerListener 的 javax.swing.plaf.basic 中的字段
protected ContainerListener | BasicMenuBarUI.containerListener
protected ContainerListener | BasicToolBarUI.toolBarContListener

返回 ContainerListener 的 javax.swing.plaf.basic 中的方法
protected ContainerListener | BasicMenuBarUI.createContainerListener()
protected ContainerListener | BasicToolBarUI.createToolBarContListener()

javax.swing.plaf.metal 中 ContainerListener 的使用

实现 ContainerListener 的 javax.swing.plaf.metal 中的类
protected  class MetalToolBarUI.MetalContainerListener

声明为 ContainerListener 的 javax.swing.plaf.metal 中的字段
protected  ContainerListener MetalToolBarUI.contListener
此受保护的字段是特定于实现的。

返回 ContainerListener 的 javax.swing.plaf.metal 中的方法
protected  ContainerListener MetalToolBarUI.createContainerListener()
创建一个将添加到 JToolBar 中的容器侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.InputMethodListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.InputMethodListener
的使用

使用 InputMethodListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 InputMethodListener 的使用

实现 InputMethodListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 InputMethodListener 的 java.awt 中的方法
static InputMethodListener | AWTEventMulticaster.add(InputMethodListener a, InputMethodListener b) 添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。
InputMethodListener[] | Component.getInputMethodListeners() 返回在此组件上所有已注册的输入方法侦听器的数组。
static InputMethodListener | AWTEventMulticaster.remove(InputMethodListener l, InputMethodListener oldl) 从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。

参数类型为 InputMethodListener 的 java.awt 中的方法
static InputMethodListener | AWTEventMulticaster.add(InputMethodListener a, InputMethodListener b) 添加输入方法侦听器 a 和输入方法侦听器 b，并返回得到的多路广播侦听器。
void | Component.addInputMethodListener(InputMethodListener l) 添加指定的输入方法侦听器，以接收发自此组件的输入方法事件。
static InputMethodListener | AWTEventMulticaster.remove(InputMethodListener l, InputMethodListener oldl) 从输入方法侦听器 l 中移除旧的输入方法侦听器，并返回得到的多路广播侦听器。
void | Component.removeInputMethodListener(InputMethodListener l) 移除指定的输入方法侦听器，以便它不再接收发自此组件的输入方法事件。

javax.swing.text 中 InputMethodListener 的使用

参数类型为 InputMethodListener 的 javax.swing.text 中的方法
 void JTextComponent.addInputMethodListener(InputMethodListener l)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.MouseWheelListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.MouseWheelListener
的使用

使用 MouseWheelListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 MouseWheelListener 的 java.awt 中的方法
static MouseWheelListener | AWTEventMulticaster.add(MouseWheelListener a, MouseWheelListener b) 添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。
MouseWheelListener[] | Component.getMouseWheelListeners() 返回在此组件上所有已注册的鼠标滚轮侦听器的数组。
static MouseWheelListener | AWTEventMulticaster.remove(MouseWheelListener l, MouseWheelListener oldl) 从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。

参数类型为 MouseWheelListener 的 java.awt 中的方法
static MouseWheelListener | AWTEventMulticaster.add(MouseWheelListener a, MouseWheelListener b) 添加鼠标滚轮侦听器 a 和鼠标滚轮侦听器 b，并返回得到的多路广播侦听器。
void | Component.addMouseWheelListener(MouseWheelListener l) 添加指定的鼠标滚轮侦听器，以接收发自此组件的鼠标滚轮事件。
static MouseWheelListener | AWTEventMulticaster.remove(MouseWheelListener l, MouseWheelListener oldl) 从鼠标滚轮侦听器 l 中移除旧的鼠标滚轮侦听器，并返回得到的多路广播侦听器。
void | Component.removeMouseWheelListener(MouseWheelListener l) 移除指定的鼠标滚轮侦听器，以便它不再接收发自此组件的鼠标滚轮事件。

java.awt.event 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 java.awt.event 中的类
 class MouseAdapter
接收鼠标事件的抽象适配器类。

javax.swing 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing 中的类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.plaf.basic 中的类
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
protected class | BasicScrollPaneUI.MouseWheelHandler MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。

返回 MouseWheelListener 的 javax.swing.plaf.basic 中的方法
protected  MouseWheelListener BasicScrollPaneUI.createMouseWheelListener()
创建一个 MouseWheelListener 的实例，该实例由 installUI() 添加到 JScrollPane。

javax.swing.plaf.metal 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.SingleClickListener

javax.swing.text.html 中 MouseWheelListener 的使用

实现 MouseWheelListener 的 javax.swing.text.html 中的类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.MouseMotionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.MouseMotionListener
的使用

使用 MouseMotionListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 MouseMotionListener 的 java.awt 中的方法
static MouseMotionListener | AWTEventMulticaster.add(MouseMotionListener a, MouseMotionListener b) 添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。
MouseMotionListener[] | TrayIcon.getMouseMotionListeners() 返回已在此 TrayIcon 上注册的所有鼠标移动侦听器的数组。
MouseMotionListener[] | Component.getMouseMotionListeners() 返回在此组件上所有已注册的鼠标移动侦听器的数组。
static MouseMotionListener | AWTEventMulticaster.remove(MouseMotionListener l, MouseMotionListener oldl) 从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。

参数类型为 MouseMotionListener 的 java.awt 中的方法
static MouseMotionListener | AWTEventMulticaster.add(MouseMotionListener a, MouseMotionListener b) 添加鼠标移动侦听器 a 和鼠标移动侦听器 b，并返回得到的多路广播侦听器。
void | TrayIcon.addMouseMotionListener(MouseMotionListener listener) 添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标移动事件。
void | Component.addMouseMotionListener(MouseMotionListener l) 添加指定的鼠标移动侦听器，以接收发自此组件的鼠标移动事件。
static MouseMotionListener | AWTEventMulticaster.remove(MouseMotionListener l, MouseMotionListener oldl) 从鼠标移动侦听器 l 中移除旧的鼠标移动侦听器，并返回得到的多路广播侦听器。
void | TrayIcon.removeMouseMotionListener(MouseMotionListener listener) 移除指定的鼠标移动侦听器。
void | Component.removeMouseMotionListener(MouseMotionListener l) 移除指定的鼠标移动侦听器，以便它不再接收发自此组件的鼠标移动事件。

java.awt.dnd 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 java.awt.dnd 中的类
 class MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

java.awt.event 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 java.awt.event 中的类
class | MouseAdapter 接收鼠标事件的抽象适配器类。
class | MouseMotionAdapter 接收鼠标移动事件的抽象适配器类。

javax.swing 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing 中的类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseMotionListener 的使用

javax.swing.event 中 MouseMotionListener 的子接口
 interface MouseInputListener
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。

实现 MouseMotionListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.InvocationMouseMotionHandler 此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
protected class | BasicComboPopup.ListMouseMotionHandler 在列表上移动鼠标时，此侦听器更改所选项。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
protected class | BasicMenuItemUI.MouseInputHandler
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

声明为 MouseMotionListener 的 javax.swing.plaf.basic 中的字段
protected MouseMotionListener | BasicComboPopup.listMouseMotionListener 此受保护字段是特定于实现的。
protected MouseMotionListener | BasicComboPopup.mouseMotionListener 此受保护字段是特定于实现的。
protected MouseMotionListener | BasicComboBoxUI.popupMouseMotionListener

返回 MouseMotionListener 的 javax.swing.plaf.basic 中的方法
protected  MouseMotionListener BasicComboPopup.createListMouseMotionListener()
创建观察弹出列表中的鼠标移动事件的鼠标移动侦听器。
protected  MouseMotionListener BasicComboPopup.createMouseMotionListener()
创建将添加到组合框的鼠标移动侦听器。
 MouseMotionListener BasicComboPopup.getMouseMotionListener()
ComboPopup.getMouseMotionListener() 的实现。
 MouseMotionListener ComboPopup.getMouseMotionListener()
返回将添加到组合框的鼠标移动侦听器或 null。

javax.swing.plaf.metal 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.SingleClickListener
protected class | MetalToolBarUI.MetalDockingListener

javax.swing.text 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

javax.swing.text.html 中 MouseMotionListener 的使用

实现 MouseMotionListener 的 javax.swing.text.html 中的类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.MouseListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.MouseListener
的使用

使用 MouseListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseListener 的使用

实现 MouseListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 MouseListener 的 java.awt 中的方法
static MouseListener | AWTEventMulticaster.add(MouseListener a, MouseListener b) 添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。
MouseListener[] | TrayIcon.getMouseListeners() 返回已在此 TrayIcon 上注册的所有鼠标侦听器的数组。
MouseListener[] | Component.getMouseListeners() 返回在此组件上所有已注册的鼠标侦听器的数组。
static MouseListener | AWTEventMulticaster.remove(MouseListener l, MouseListener oldl) 从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。

参数类型为 MouseListener 的 java.awt 中的方法
static MouseListener | AWTEventMulticaster.add(MouseListener a, MouseListener b) 添加鼠标侦听器 a 和鼠标侦听器 b，并返回得到的多路广播侦听器。
void | TrayIcon.addMouseListener(MouseListener listener) 添加指定的鼠标侦听器，以接收发自此 TrayIcon 的鼠标事件。
void | Component.addMouseListener(MouseListener l) 添加指定的鼠标侦听器，以接收发自此组件的鼠标事件。
static MouseListener | AWTEventMulticaster.remove(MouseListener l, MouseListener oldl) 从鼠标侦听器 l 中移除旧的鼠标侦听器，并返回得到的多路广播侦听器。
void | TrayIcon.removeMouseListener(MouseListener listener) 移除指定的鼠标侦听器。
void | Component.removeMouseListener(MouseListener l) 移除指定的鼠标侦听器，以便它不再接收发自此组件的鼠标事件。

java.awt.dnd 中 MouseListener 的使用

实现 MouseListener 的 java.awt.dnd 中的类
 class MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

java.awt.event 中 MouseListener 的使用

实现 MouseListener 的 java.awt.event 中的类
 class MouseAdapter
接收鼠标事件的抽象适配器类。

javax.swing 中 MouseListener 的使用

实现 MouseListener 的 javax.swing 中的类
 class ToolTipManager
管理系统中的所有 ToolTips。

javax.swing.event 中 MouseListener 的使用

javax.swing.event 中 MouseListener 的子接口
 interface MouseInputListener
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。

实现 MouseListener 的 javax.swing.event 中的类
 class MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

javax.swing.plaf.basic 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
protected class | BasicMenuItemUI.MouseInputHandler
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

声明为 MouseListener 的 javax.swing.plaf.basic 中的字段
protected MouseListener | BasicComboPopup.listMouseListener 此受保护字段是特定于实现的。
protected MouseListener | BasicTabbedPaneUI.mouseListener
protected MouseListener | BasicComboPopup.mouseListener 此受保护字段是特定于实现的。
protected MouseListener | BasicComboBoxUI.popupMouseListener

返回 MouseListener 的 javax.swing.plaf.basic 中的方法
protected  MouseListener BasicFileChooserUI.createDoubleClickListener(JFileChooser fc, JList list)
protected  MouseListener BasicComboPopup.createListMouseListener()
创建观察弹出列表中的鼠标事件的鼠标侦听器。
protected  MouseListener BasicTreeUI.createMouseListener()
创建负责基于鼠标事件更新选择的侦听器。
protected  MouseListener BasicTabbedPaneUI.createMouseListener()
protected  MouseListener BasicComboPopup.createMouseListener()
创建将观察组合框上的鼠标按下和释放事件的侦听器。
 MouseListener BasicComboPopup.getMouseListener()
ComboPopup.getMouseListener() 的实现。
 MouseListener ComboPopup.getMouseListener()
返回将添加到组合框的鼠标侦听器或 null。

javax.swing.plaf.metal 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.plaf.metal 中的类
protected class | MetalFileChooserUI.SingleClickListener
protected class | MetalToolBarUI.MetalDockingListener

javax.swing.text 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

javax.swing.text.html 中 MouseListener 的使用

实现 MouseListener 的 javax.swing.text.html 中的类
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.KeyListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.KeyListener
的使用

使用 KeyListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 KeyListener 的使用

实现 KeyListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 KeyListener 的 java.awt 中的方法
static KeyListener | AWTEventMulticaster.add(KeyListener a, KeyListener b) 添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。
KeyListener[] | Component.getKeyListeners() 返回在此组件上所有已注册的按键侦听器的数组。
static KeyListener | AWTEventMulticaster.remove(KeyListener l, KeyListener oldl) 从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。

参数类型为 KeyListener 的 java.awt 中的方法
static KeyListener | AWTEventMulticaster.add(KeyListener a, KeyListener b) 添加键侦听器 a 和键侦听器 b，并返回得到的多路广播侦听器。
void | Component.addKeyListener(KeyListener l) 添加指定的按键侦听器，以接收发自此组件的按键事件。
static KeyListener | AWTEventMulticaster.remove(KeyListener l, KeyListener oldl) 从键侦听器 l 中移除旧的键侦听器，并返回得到的多路广播侦听器。
void | Component.removeKeyListener(KeyListener l) 移除指定的按键侦听器，以便它不再接收发自此组件的按键事件。

java.awt.event 中 KeyListener 的使用

实现 KeyListener 的 java.awt.event 中的类
 class KeyAdapter
接收键盘事件的抽象适配器类。

javax.swing.plaf.basic 中 KeyListener 的使用

实现 KeyListener 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.KeyHandler 此侦听器检查键事件是否不是导航键。
class | BasicComboPopup.InvocationKeyHandler 从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
class | BasicTableUI.KeyHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTreeUI.KeyHandler 用于获取多个按键事件以适当生成事件。

声明为 KeyListener 的 javax.swing.plaf.basic 中的字段
protected KeyListener | BasicTableUI.keyListener
protected KeyListener | BasicComboPopup.keyListener 此受保护字段是特定于实现的。
protected KeyListener | BasicComboBoxUI.keyListener 此受保护字段是特定于实现的。
protected KeyListener | BasicComboBoxUI.popupKeyListener

返回 KeyListener 的 javax.swing.plaf.basic 中的方法
protected  KeyListener BasicTreeUI.createKeyListener()
创建负责从树获取键事件的侦听器。
protected  KeyListener BasicTableUI.createKeyListener()
创建在 JTable 中处理键盘导航的键侦听器。
protected  KeyListener BasicComboPopup.createKeyListener()
创建将添加到组合框的键侦听器。
protected  KeyListener BasicComboBoxUI.createKeyListener()
创建将添加到组合框的 KeyListener。
 KeyListener BasicComboPopup.getKeyListener()
ComboPopup.getKeyListener() 的实现。
 KeyListener ComboPopup.getKeyListener()
返回将添加到组合框的键侦听器或 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.HierarchyListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.HierarchyListener
的使用

使用 HierarchyListener 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 HierarchyListener 的使用

实现 HierarchyListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 HierarchyListener 的 java.awt 中的方法
static HierarchyListener | AWTEventMulticaster.add(HierarchyListener a, HierarchyListener b) 添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。
HierarchyListener[] | Component.getHierarchyListeners() 返回在此组件上所有已注册的层次结构侦听器的数组。
static HierarchyListener | AWTEventMulticaster.remove(HierarchyListener l, HierarchyListener oldl) 从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。

参数类型为 HierarchyListener 的 java.awt 中的方法
static HierarchyListener | AWTEventMulticaster.add(HierarchyListener a, HierarchyListener b) 添加层次结构侦听器 a 和层次结构侦听器 b，并返回得到的多路广播侦听器。
void | Component.addHierarchyListener(HierarchyListener l) 添加指定的层次结构侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构变化事件。
static HierarchyListener | AWTEventMulticaster.remove(HierarchyListener l, HierarchyListener oldl) 从层次结构侦听器 l 中移除旧的层次结构侦听器，并返回得到的多路广播侦听器。
void | Component.removeHierarchyListener(HierarchyListener l) 移除指定的层次结构侦听器，以便它不再接收发自此组件的层次结构变化事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.HierarchyBoundsListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.HierarchyBoundsListener
的使用

使用 HierarchyBoundsListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 HierarchyBoundsListener 的使用

实现 HierarchyBoundsListener 的 java.awt 中的类
 class AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

返回 HierarchyBoundsListener 的 java.awt 中的方法
static HierarchyBoundsListener | AWTEventMulticaster.add(HierarchyBoundsListener a, HierarchyBoundsListener b) 添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。
HierarchyBoundsListener[] | Component.getHierarchyBoundsListeners() 返回在此组件上所有已注册的层次结构边界侦听器的数组。
static HierarchyBoundsListener | AWTEventMulticaster.remove(HierarchyBoundsListener l, HierarchyBoundsListener oldl) 从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。

参数类型为 HierarchyBoundsListener 的 java.awt 中的方法
static HierarchyBoundsListener | AWTEventMulticaster.add(HierarchyBoundsListener a, HierarchyBoundsListener b) 添加层次结构边界侦听器 a 和层次结构边界侦听器 b，并返回得到的多路广播侦听器。
void | Component.addHierarchyBoundsListener(HierarchyBoundsListener l) 添加指定的层次结构边界侦听器，以便当此容器所属的层次结构发生变化时接收发自此组件的层次结构边界事件。
static HierarchyBoundsListener | AWTEventMulticaster.remove(HierarchyBoundsListener l, HierarchyBoundsListener oldl) 从层次结构边界侦听器 l 中移除旧的层次结构边界侦听器，并返回得到的多路广播侦听器。
void | Component.removeHierarchyBoundsListener(HierarchyBoundsListener l) 移除指定的层次结构边界侦听器，以便它不再接收发自此组件的层次结构边界事件。

java.awt.event 中 HierarchyBoundsListener 的使用

实现 HierarchyBoundsListener 的 java.awt.event 中的类
 class HierarchyBoundsAdapter
用于接收祖先的移动和大小重调事件的抽象适配器类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.FocusListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.FocusListener
的使用

使用 FocusListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 FocusListener 的使用

实现 FocusListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）

声明为 FocusListener 的 java.awt 中的字段
protected  FocusListener Component.AccessibleAWTComponent.accessibleAWTFocusHandler

返回 FocusListener 的 java.awt 中的方法
static FocusListener | AWTEventMulticaster.add(FocusListener a, FocusListener b) 添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。
FocusListener[] | Component.getFocusListeners() 返回在此组件上所有已注册的焦点侦听器的数组。
static FocusListener | AWTEventMulticaster.remove(FocusListener l, FocusListener oldl) 从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。

参数类型为 FocusListener 的 java.awt 中的方法
static FocusListener | AWTEventMulticaster.add(FocusListener a, FocusListener b) 添加焦点侦听器 a 和焦点侦听器 b，并返回得到的多路广播侦听器。
void | List.AccessibleAWTList.AccessibleAWTListChild.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以从此组件接收焦点事件。
void | MenuComponent.AccessibleAWTMenuComponent.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以从此组件接收焦点事件。
void | Component.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以便当此组件获得输入焦点时能够接收发自此组件的焦点事件。
void | Component.AccessibleAWTComponent.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收发自此组件的焦点事件。
static FocusListener | AWTEventMulticaster.remove(FocusListener l, FocusListener oldl) 从焦点侦听器 l 中移除旧的焦点侦听器，并返回得到的多路广播侦听器。
void | List.AccessibleAWTList.AccessibleAWTListChild.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再从此组件接收焦点事件。
void | MenuComponent.AccessibleAWTMenuComponent.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使之不再从此组件接收焦点事件。
void | Component.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。
void | Component.AccessibleAWTComponent.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，以便它不再接收发自此组件的焦点事件。

java.awt.event 中 FocusListener 的使用

实现 FocusListener 的 java.awt.event 中的类
 class FocusAdapter
用于接收键盘焦点事件的抽象适配器类。

javax.accessibility 中 FocusListener 的使用

参数类型为 FocusListener 的 javax.accessibility 中的方法
void | AccessibleComponent.addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | AccessibleComponent.removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

javax.swing 中 FocusListener 的使用

实现 FocusListener 的 javax.swing 中的类
protected  class JComponent.AccessibleJComponent.AccessibleFocusHandler
发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

声明为 FocusListener 的 javax.swing 中的字段
protected  FocusListener JComponent.AccessibleJComponent.accessibleFocusHandler

参数类型为 FocusListener 的 javax.swing 中的方法
void | JTree.AccessibleJTree.AccessibleJTreeNode.addFocusListener(FocusListener l)
void | JTable.AccessibleJTable.AccessibleJTableCell.addFocusListener(FocusListener l)
void | JList.AccessibleJList.AccessibleJListChild.addFocusListener(FocusListener l)
void | JTree.AccessibleJTree.AccessibleJTreeNode.removeFocusListener(FocusListener l)
void | JTable.AccessibleJTable.AccessibleJTableCell.removeFocusListener(FocusListener l)
void | JList.AccessibleJList.AccessibleJListChild.removeFocusListener(FocusListener l)

javax.swing.plaf.basic 中 FocusListener 的使用

实现 FocusListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicComboBoxEditor 用于可编辑组合框的默认编辑器。
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。
class | BasicComboBoxUI.FocusHandler 失去焦点时，此侦听器将隐藏弹出部分。
class | BasicListUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicSliderUI.FocusHandler 焦点更改侦听器。
class | BasicSplitPaneUI.FocusHandler JSplitPane UI 使用的 FocusListener 的实现。
class | BasicTabbedPaneUI.FocusHandler 此类应视为“受保护”内部类。
class | BasicTableUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
protected class | BasicToolBarUI.ToolBarFocusListener
class | BasicTreeUI.FocusHandler 失去/获得焦点时重绘前导选择行。

声明为 FocusListener 的 javax.swing.plaf.basic 中的字段
protected FocusListener | BasicSliderUI.focusListener
protected FocusListener | BasicSplitPaneUI.focusListener 此 JSplitPane 的 FocusListener 的实例。
protected FocusListener | BasicTableUI.focusListener
protected FocusListener | BasicTabbedPaneUI.focusListener
protected FocusListener | BasicListUI.focusListener
protected FocusListener | BasicComboBoxUI.focusListener 此受保护字段是特定于实现的。
protected FocusListener | BasicToolBarUI.toolBarFocusListener

返回 FocusListener 的 javax.swing.plaf.basic 中的方法
protected FocusListener | BasicSplitPaneUI.createFocusListener() 创建 JSplitPane UI 的 FocusListener。
protected FocusListener | BasicTreeUI.createFocusListener() 创建失去/获取焦点时负责更新显示的侦听器。
protected FocusListener | BasicTableUI.createFocusListener() 创建在 JTable 中处理键盘导航的焦点侦听器。
protected FocusListener | BasicTabbedPaneUI.createFocusListener()
protected FocusListener | BasicListUI.createFocusListener()
protected FocusListener | BasicComboBoxUI.createFocusListener() 创建将添加到组合框的 FocusListener。
protected FocusListener | BasicSliderUI.createFocusListener(JSlider slider)
protected FocusListener | BasicToolBarUI.createToolBarFocusListener()

javax.swing.plaf.metal 中 FocusListener 的使用

实现 FocusListener 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。

javax.swing.table 中 FocusListener 的使用

参数类型为 FocusListener 的 javax.swing.table 中的方法
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addFocusListener(FocusListener l)
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.removeFocusListener(FocusListener l)

javax.swing.text 中 FocusListener 的使用

实现 FocusListener 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.ComponentListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.ComponentListener
的使用

使用 ComponentListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ComponentListener 的使用

实现 ComponentListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）

声明为 ComponentListener 的 java.awt 中的字段
protected  ComponentListener Component.AccessibleAWTComponent.accessibleAWTComponentHandler

返回 ComponentListener 的 java.awt 中的方法
static ComponentListener | AWTEventMulticaster.add(ComponentListener a, ComponentListener b) 添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。
ComponentListener[] | Component.getComponentListeners() 返回在此组件上所有已注册的组件侦听器的数组。
static ComponentListener | AWTEventMulticaster.remove(ComponentListener l, ComponentListener oldl) 从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。

参数类型为 ComponentListener 的 java.awt 中的方法
static ComponentListener | AWTEventMulticaster.add(ComponentListener a, ComponentListener b) 添加组件侦听器 a 和组件侦听器 b，并返回得到的多路广播侦听器。
void | Component.addComponentListener(ComponentListener l) 添加指定的组件侦听器，以接收发自此组件的组件事件。
static ComponentListener | AWTEventMulticaster.remove(ComponentListener l, ComponentListener oldl) 从组件侦听器 l 中移除旧的组件侦听器，并返回得到的多路广播侦听器。
void | Component.removeComponentListener(ComponentListener l) 移除指定的组件侦听器，以便它不再接收发自此组件的组件事件。

java.awt.event 中 ComponentListener 的使用

实现 ComponentListener 的 java.awt.event 中的类
 class ComponentAdapter
用于接收组件事件的抽象适配器类。

javax.swing 中 ComponentListener 的使用

实现 ComponentListener 的 javax.swing 中的类
protected  class JViewport.ViewListener
视图的侦听器。

javax.swing.plaf.basic 中 ComponentListener 的使用

实现 ComponentListener 的 javax.swing.plaf.basic 中的类
protected class | BasicInternalFrameUI.ComponentHandler
class | BasicSliderUI.ComponentHandler 调整事件大小的侦听器。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。

声明为 ComponentListener 的 javax.swing.plaf.basic 中的字段
protected ComponentListener | BasicInternalFrameUI.componentListener
protected ComponentListener | BasicSliderUI.componentListener

返回 ComponentListener 的 javax.swing.plaf.basic 中的方法
protected ComponentListener | BasicInternalFrameUI.createComponentListener()
protected ComponentListener | BasicTreeUI.createComponentListener() 创建并返回新的 ComponentHandler。
protected ComponentListener | BasicSliderUI.createComponentListener(JSlider slider)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.InvocationEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.InvocationEvent
的使用

没有 java.awt.event.InvocationEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.PaintEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.PaintEvent
的使用

没有 java.awt.event.PaintEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.MouseEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.MouseEvent
的使用

使用 MouseEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 MouseEvent 的使用

参数类型为 MouseEvent 的 java.awt 中的方法
void | AWTEventMulticaster.mouseClicked(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseClicked 方法处理 mouseClicked 事件。
void | AWTEventMulticaster.mouseDragged(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseDragged 方法处理 mouseDragged 事件。
void | AWTEventMulticaster.mouseEntered(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseEntered 方法处理 mouseEntered 事件。
void | AWTEventMulticaster.mouseExited(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseExited 方法处理 mouseExited 事件。
void | AWTEventMulticaster.mouseMoved(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseMoved 方法处理 mouseMoved 事件。
void | AWTEventMulticaster.mousePressed(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mousePressed 方法处理 mousePressed 事件。
void | AWTEventMulticaster.mouseReleased(MouseEvent e) 通过在侦听器 a 和侦听器 b 上调用 mouseReleased 方法处理 mouseReleased 事件。
protected void | Component.processMouseEvent(MouseEvent e) 处理组件上发生的鼠标事件，方法是将其指派到任意已注册的 MouseListener 对象。
protected void | Component.processMouseMotionEvent(MouseEvent e) 处理组件上发生的鼠标移动事件，方法是将其指派到任意已注册的 MouseMotionListener 事件。

java.awt.dnd 中 MouseEvent 的使用

参数类型为 MouseEvent 的 java.awt.dnd 中的方法
void | MouseDragGestureRecognizer.mouseClicked(MouseEvent e) 鼠标在组件上单击时调用。
void | MouseDragGestureRecognizer.mouseDragged(MouseEvent e) 鼠标按钮在组件上按下时调用。
void | MouseDragGestureRecognizer.mouseEntered(MouseEvent e) 鼠标移动到组件上时调用。
void | MouseDragGestureRecognizer.mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | MouseDragGestureRecognizer.mouseMoved(MouseEvent e) 鼠标按钮在组件上移动（无按钮按下）时调用。
void | MouseDragGestureRecognizer.mousePressed(MouseEvent e) 鼠标按钮在 Component 上按下时调用。
void | MouseDragGestureRecognizer.mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。

java.awt.event 中 MouseEvent 的使用

java.awt.event 中 MouseEvent 的子类
 class MouseWheelEvent
表示鼠标滚轮在组件中滚动的事件。

参数类型为 MouseEvent 的 java.awt.event 中的方法
void | MouseAdapter.mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | MouseListener.mouseClicked(MouseEvent e) 鼠标按键在组件上单击（按下并释放）时调用。
void | MouseMotionAdapter.mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | MouseAdapter.mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | MouseMotionListener.mouseDragged(MouseEvent e) 鼠标按键在组件上按下并拖动时调用。
void | MouseAdapter.mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | MouseListener.mouseEntered(MouseEvent e) 鼠标进入到组件上时调用。
void | MouseAdapter.mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | MouseListener.mouseExited(MouseEvent e) 鼠标离开组件时调用。
void | MouseMotionAdapter.mouseMoved(MouseEvent e) 鼠标按键在组件上移动（无按键按下）时调用。
void | MouseAdapter.mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | MouseMotionListener.mouseMoved(MouseEvent e) 鼠标光标移动到组件上但无按键按下时调用。
void | MouseAdapter.mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | MouseListener.mousePressed(MouseEvent e) 鼠标按键在组件上按下时调用。
void | MouseAdapter.mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。
void | MouseListener.mouseReleased(MouseEvent e) 鼠标按钮在组件上释放时调用。

javax.swing 中 MouseEvent 的使用

返回 MouseEvent 的 javax.swing 中的方法
static MouseEvent SwingUtilities.convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination)
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。

参数类型为 MouseEvent 的 javax.swing 中的方法
static MouseEvent SwingUtilities.convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination)
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。
 Point JComponent.getPopupLocation(MouseEvent event)
返回在此组件坐标系统中显示弹出式菜单的首选位置。
 Point JComponent.getToolTipLocation(MouseEvent event)
返回工具提示在此组件坐标系统中的位置。
 String JTree.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。
 String JTable.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。
 String JTabbedPane.getToolTipText(MouseEvent event)
返回由鼠标事件位置确定的组件的工具提示文本。
 String JList.getToolTipText(MouseEvent event)
返回用于给定事件的工具提示文本。
 String JComponent.getToolTipText(MouseEvent event)
返回用作 event 工具提示的字符串。
static boolean SwingUtilities.isLeftMouseButton(MouseEvent anEvent)
如果鼠标事件指定左边鼠标按键，则返回 true。
static boolean SwingUtilities.isMiddleMouseButton(MouseEvent anEvent)
如果鼠标事件指定中间鼠标按键，则返回 true。
 boolean JPopupMenu.isPopupTrigger(MouseEvent e)
如果 JPopupMenu 的当前安装 UI 将 MouseEvent 视为弹出菜单触发器，则返回 true。
static boolean SwingUtilities.isRightMouseButton(MouseEvent anEvent)
如果鼠标事件指定右边鼠标按键，则返回 true。
 void ToolTipManager.mouseDragged(MouseEvent event)
按下和拖动鼠标时调用。
 void ToolTipManager.mouseEntered(MouseEvent event)
鼠标进入组件区域时调用。
 void ToolTipManager.mouseExited(MouseEvent event)
鼠标退出组件区域时调用。
 void ToolTipManager.mouseMoved(MouseEvent event)
移动鼠标时调用。
 void ToolTipManager.mousePressed(MouseEvent event)
当按下鼠标时调用。
 void MenuSelectionManager.processMouseEvent(MouseEvent event)
当 MenuElement 从 MouseListener 接收事件时，它决不应直接处理该事件。
protected  void JComponent.processMouseEvent(MouseEvent e)
处理此组件上发生的鼠标事件，通过将其指派到任意已注册的 MouseListener 对象来完成，有关此方法的完整描述，请参阅 Component.processMouseEvent(MouseEvent)。
 void JPopupMenu.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
要求此方法遵守 MenuElement 接口，但它没有被实现。
 void JMenuBar.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
实现为 MenuElement（不执行任何操作）。
 void JMenuItem.processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
 void MenuElement.processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
处理鼠标事件。
protected  void JComponent.processMouseMotionEvent(MouseEvent e)
处理鼠标移动事件，如 MouseEvent.MOUSE_DRAGGED。

javax.swing.event 中 MouseEvent 的使用

javax.swing.event 中 MouseEvent 的子类
 class MenuDragMouseEvent
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。

javax.swing.plaf 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.plaf 中的方法
 boolean PopupMenuUI.isPopupTrigger(MouseEvent e)

javax.swing.plaf.basic 中 MouseEvent 的使用

返回 MouseEvent 的 javax.swing.plaf.basic 中的方法
protected  MouseEvent BasicComboPopup.convertMouseEvent(MouseEvent e)

参数类型为 MouseEvent 的 javax.swing.plaf.basic 中的方法
protected void | BasicSplitPaneDivider.DragController.completeDrag(MouseEvent e) 用鼠标事件的新位置传递 finishDraggingTo 的消息。
protected void | BasicSplitPaneDivider.DragController.continueDrag(MouseEvent e) 用鼠标事件的新位置传递 dragDividerTo 的消息。
protected MouseEvent | BasicComboPopup.convertMouseEvent(MouseEvent e)
protected void | BasicComboPopup.delegateFocus(MouseEvent e) 此为一种实用程序方法，用于帮助事件处理程序计算出在调出弹出控件时将焦点发送到的位置。
protected boolean | BasicTreeUI.isMultiSelectEvent(MouseEvent event) 返回 true 表示节点上的鼠标事件应该根据锚点作出选择。
boolean | BasicPopupMenuUI.isPopupTrigger(MouseEvent e)
protected boolean | BasicTreeUI.isToggleEvent(MouseEvent event) 返回 true 指示应该基于事件切换鼠标下的行。
protected boolean | BasicTreeUI.isToggleSelectionEvent(MouseEvent event) 返回 true 表示节点上的鼠标事件应该仅切换鼠标下的行的选择。
void | BasicFileChooserUI.DoubleClickListener.mouseClicked(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseClicked(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseClicked(MouseEvent e)
void | BasicTreeUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicMenuItemUI.MouseInputHandler.mouseClicked(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseClicked(MouseEvent e)
void | BasicButtonListener.mouseClicked(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseDragged(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseDragged(MouseEvent e)
void | BasicSliderUI.TrackListener.mouseDragged(MouseEvent e) 将模型值设置为相对于滑道原点的 thumb 顶部/左部位置。
void | BasicSplitPaneDivider.MouseHandler.mouseDragged(MouseEvent e) 如果拖动器不为 null，则此方法利用 continueDrag 传递消息。
void | BasicTreeUI.MouseHandler.mouseDragged(MouseEvent e)
void | BasicTreeUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicComboPopup.InvocationMouseMotionHandler.mouseDragged(MouseEvent e)
void | BasicScrollBarUI.TrackListener.mouseDragged(MouseEvent e) 将模型值设置为 thumb 的 Vertical 滚动条顶部的位置，或者相对于滑道原点的从左到右/从右到左滚动条中 Horizontal 滚动条的左部/右部位置。
void | BasicMenuUI.MouseInputHandler.mouseDragged(MouseEvent e) 在菜单上按下鼠标按键并随后拖动鼠标时调用。
void | BasicMenuItemUI.MouseInputHandler.mouseDragged(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseDragged(MouseEvent e)
void | BasicButtonListener.mouseDragged(MouseEvent e)
void | BasicFileChooserUI.DoubleClickListener.mouseEntered(MouseEvent e) 用于表示文件的 JList 由子类创建，但是在此类中监视选择。
void | BasicInternalFrameUI.BorderListener.mouseEntered(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseEntered(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseEntered(MouseEvent e) 鼠标进入组件时调用。
void | BasicTreeUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseEntered(MouseEvent e) 在指针进入菜单时调用。
void | BasicMenuItemUI.MouseInputHandler.mouseEntered(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseEntered(MouseEvent e)
void | BasicButtonListener.mouseEntered(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseExited(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseExited(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseExited(MouseEvent e) 鼠标退出组件时调用。
void | BasicTreeUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicScrollBarUI.TrackListener.mouseExited(MouseEvent e) 当鼠标退出滚动条时调用。
void | BasicMenuUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicMenuItemUI.MouseInputHandler.mouseExited(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseExited(MouseEvent e)
void | BasicButtonListener.mouseExited(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseMoved(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseMoved(MouseEvent e)
void | BasicSliderUI.TrackListener.mouseMoved(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseMoved(MouseEvent e) 基于方向重置光标。
void | BasicTreeUI.MouseHandler.mouseMoved(MouseEvent e) 已将鼠标按键移动到组件上（但没有按下任何一个按键）时调用。
void | BasicTreeUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicComboPopup.ListMouseMotionHandler.mouseMoved(MouseEvent anEvent)
void | BasicScrollBarUI.TrackListener.mouseMoved(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicMenuItemUI.MouseInputHandler.mouseMoved(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseMoved(MouseEvent e)
void | BasicButtonListener.mouseMoved(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mousePressed(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mousePressed(MouseEvent e)
void | BasicSliderUI.TrackListener.mousePressed(MouseEvent e) 如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按鼠标则将滚动条值增加一页。
void | BasicSplitPaneDivider.MouseHandler.mousePressed(MouseEvent e) 通过创建 DragController 的适当实例启动拖动会话。
void | BasicTreeUI.MouseHandler.mousePressed(MouseEvent e) 在组件上按下鼠标按键时调用。
void | BasicTreeUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicTabbedPaneUI.MouseHandler.mousePressed(MouseEvent e)
void | BasicListUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicComboPopup.InvocationMouseHandler.mousePressed(MouseEvent e) 响应组合框上的鼠标按下事件。
void | BasicComboPopup.ListMouseHandler.mousePressed(MouseEvent e)
void | BasicScrollBarUI.TrackListener.mousePressed(MouseEvent e) 如果在 "thumb" 组件上方按下鼠标，则可以将滚动条值减少一页（“向上翻页”），在下方按下鼠标则将滚动条值增加一页。
void | BasicScrollBarUI.ArrowButtonListener.mousePressed(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mousePressed(MouseEvent e) 在菜单上单击鼠标时调用。
void | BasicMenuItemUI.MouseInputHandler.mousePressed(MouseEvent e)
void | BasicToolBarUI.DockingListener.mousePressed(MouseEvent e)
void | BasicButtonListener.mousePressed(MouseEvent e)
void | BasicDesktopIconUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicInternalFrameUI.BorderListener.mouseReleased(MouseEvent e)
void | BasicInternalFrameUI.GlassPaneDispatcher.mouseReleased(MouseEvent e)
void | BasicSliderUI.TrackListener.mouseReleased(MouseEvent e)
void | BasicSplitPaneDivider.MouseHandler.mouseReleased(MouseEvent e) 如果拖动器不为 null，则此方法利用 completeDrag 传递消息。
void | BasicTreeUI.MouseHandler.mouseReleased(MouseEvent e)
void | BasicTreeUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicTableUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicTableHeaderUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicListUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicComboPopup.InvocationMouseHandler.mouseReleased(MouseEvent e) 响应用户终止从组合框开始的单击或拖动操作。
void | BasicComboPopup.ListMouseHandler.mouseReleased(MouseEvent anEvent)
void | BasicScrollBarUI.TrackListener.mouseReleased(MouseEvent e)
void | BasicScrollBarUI.ArrowButtonListener.mouseReleased(MouseEvent e)
void | BasicMenuUI.MouseInputHandler.mouseReleased(MouseEvent e) 在菜单上释放鼠标时调用。
void | BasicMenuItemUI.MouseInputHandler.mouseReleased(MouseEvent e)
void | BasicToolBarUI.DockingListener.mouseReleased(MouseEvent e)
void | BasicButtonListener.mouseReleased(MouseEvent e)
protected int | BasicSplitPaneDivider.DragController.positionForMouseEvent(MouseEvent e) 返回基于传入的 MouseEvent 放置分隔器的新位置。
protected int | BasicSplitPaneDivider.VerticalDragController.positionForMouseEvent(MouseEvent e) 返回基于传入的 MouseEvent 放置分隔器的新位置。
void | BasicRadioButtonMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
void | BasicCheckBoxMenuItemUI.processMouseEvent(JMenuItem item, MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
protected void | BasicTreeUI.selectPathForEvent(TreePath path, MouseEvent event) 传递消息以基于特定行上的 MouseEvent 更新选择。
protected boolean | BasicTreeUI.startEditing(TreePath path, MouseEvent event) 如果存在 cellEditor 并且 shouldSelectCell 返回 true，则启动节点的编辑操作。
protected void | BasicComboPopup.updateListBoxSelectionForEvent(MouseEvent anEvent, boolean shouldScroll) 供事件侦听器使用的实用程序方法。

参数类型为 MouseEvent 的 javax.swing.plaf.basic 中的构造方法
BasicSplitPaneDivider.DragController(MouseEvent e)
BasicSplitPaneDivider.VerticalDragController(MouseEvent e)
BasicTreeUI.MouseInputHandler(Component source, Component destination, MouseEvent event)

javax.swing.plaf.metal 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.plaf.metal 中的方法
void | MetalComboBoxUI.MetalComboPopup.delegateFocus(MouseEvent e) 已过时。
void | MetalToolBarUI.MetalDockingListener.mouseDragged(MouseEvent e)
void | MetalToolBarUI.MetalDockingListener.mousePressed(MouseEvent e)

javax.swing.plaf.multi 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.plaf.multi 中的方法
 boolean MultiPopupMenuUI.isPopupTrigger(MouseEvent a)
在由此对象处理的每个 UI 上调用 isPopupTrigger 方法。

javax.swing.table 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.table 中的方法
 String JTableHeader.getToolTipText(MouseEvent event)
如果设置了提示文本，则允许使用渲染器的提示。

javax.swing.text 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.text 中的方法
 String JTextComponent.getToolTipText(MouseEvent event)
返回用作 event 的工具提示的字符串。
 void DefaultCaret.mouseClicked(MouseEvent e)
单击鼠标时调用。
 void DefaultCaret.mouseDragged(MouseEvent e)
根据鼠标指针当前位置移动插入符位置。
 void DefaultCaret.mouseEntered(MouseEvent e)
鼠标进入某个区域时调用。
 void DefaultCaret.mouseExited(MouseEvent e)
鼠标退出某个区域时调用。
 void DefaultCaret.mouseMoved(MouseEvent e)
移动鼠标时调用。
 void DefaultCaret.mousePressed(MouseEvent e)
如果按下 button 1，实现它可请求将焦点置于关联的文本组件上，并设置插入符位置。
 void DefaultCaret.mouseReleased(MouseEvent e)
释放鼠标时调用。
protected  void DefaultCaret.moveCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标移动插入符的位置。
protected  void DefaultCaret.positionCaret(MouseEvent e)
试图使用 viewToModel() 从鼠标事件的坐标设置插入符的位置。

javax.swing.text.html 中 MouseEvent 的使用

参数类型为 MouseEvent 的 javax.swing.text.html 中的方法
void | HTMLEditorKit.LinkController.mouseClicked(MouseEvent e) 鼠标单击事件时调用。
void | HTMLEditorKit.LinkController.mouseDragged(MouseEvent e)
void | HTMLEditorKit.LinkController.mouseMoved(MouseEvent e)
void | FormView.MouseEventListener.mouseReleased(MouseEvent evt)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.event.AWTEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.event.AWTEventListener
的使用

使用 AWTEventListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt 中 AWTEventListener 的使用

返回 AWTEventListener 的 java.awt 中的方法
AWTEventListener[] | Toolkit.getAWTEventListeners() 返回在此工具包上所有已注册 AWTEventListener 所组成的数组。
AWTEventListener[] | Toolkit.getAWTEventListeners(long eventMask) 返回已在此工具包上注册的所有 AWTEventListener 所组成的数组，这些侦听器侦听用 eventMask 参数指定的所有事件类型。

参数类型为 AWTEventListener 的 java.awt 中的方法
void | Toolkit.addAWTEventListener(AWTEventListener listener, long eventMask) 添加一个 AWTEventListener，以接收与给定 eventMask 一致的系统范围内指派的所有 AWTEvent。
void | Toolkit.removeAWTEventListener(AWTEventListener listener) 从正接收的指派 AWTEvent 中移除一个 AWTEventListener。

java.awt.event 中 AWTEventListener 的使用

实现 AWTEventListener 的 java.awt.event 中的类
 class AWTEventListenerProxy
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。

参数类型为 AWTEventListener 的 java.awt.event 中的构造方法
AWTEventListenerProxy(long eventMask, AWTEventListener listener)
将 AWTEventListener 绑定到特定事件掩码的构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.KeyEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.KeyEvent
的使用

使用 KeyEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 KeyEvent 的使用

参数类型为 KeyEvent 的 java.awt 中的方法
boolean | DefaultKeyboardFocusManager.dispatchKeyEvent(KeyEvent e) 如果调度程序链中其他 KeyEventDispatcher 都没有调度 KeyEvent，或者没有注册其他 KeyEventDispatcher，则由 dispatchEvent 调用此方法。
abstract boolean | KeyboardFocusManager.dispatchKeyEvent(KeyEvent e) 通常情况下，如果该指派程序链中的其他 KeyEventDispatcher 没有指派 KeyEvent 或者没有注册其他 KeyEventDispatcher，则 dispatchEvent 将调用此方法。
boolean | KeyEventDispatcher.dispatchKeyEvent(KeyEvent e) 当前 KeyboardFocusManager 调用此方法，请求此 KeyEventDispatcher 为其指派指定的事件。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStrokeForEvent(KeyEvent anEvent) 返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。
void | AWTEventMulticaster.keyPressed(KeyEvent e) 通过在侦听器 a 和侦听器 b 上调用 keyPressed 方法处理 keyPressed 事件。
void | AWTEventMulticaster.keyReleased(KeyEvent e) 通过在侦听器 a 和侦听器 b 上调用 keyReleased 方法处理 keyReleased 事件。
void | AWTEventMulticaster.keyTyped(KeyEvent e) 通过在侦听器 a 和侦听器 b 上调用 keyTyped 方法处理 keyTyped 事件。
boolean | DefaultKeyboardFocusManager.postProcessKeyEvent(KeyEvent e) 由 dispatchKeyEvent 调用此方法。
abstract boolean | KeyboardFocusManager.postProcessKeyEvent(KeyEvent e) dispatchKeyEvent 将调用此方法。
boolean | KeyEventPostProcessor.postProcessKeyEvent(KeyEvent e) 当前 KeyboardFocusManager 调用此方法，请求此 KeyEventPostProcessor 执行应该作为 KeyEvent 最终解析的一部分的所需后处理。
void | DefaultKeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e) 当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。
abstract void | KeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e) 当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。
protected void | Component.processKeyEvent(KeyEvent e) 处理组件上发生的按键事件，方法是将其指派到任意已注册的 KeyListener 对象。

java.awt.event 中 KeyEvent 的使用

参数类型为 KeyEvent 的 java.awt.event 中的方法
void | KeyAdapter.keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | KeyListener.keyPressed(KeyEvent e) 按下某个键时调用此方法。
void | KeyAdapter.keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | KeyListener.keyReleased(KeyEvent e) 释放某个键时调用此方法。
void | KeyAdapter.keyTyped(KeyEvent e) 键入某个键时调用此方法。
void | KeyListener.keyTyped(KeyEvent e) 键入某个键时调用此方法。

javax.swing 中 KeyEvent 的使用

参数类型为 KeyEvent 的 javax.swing 中的方法
static KeyStroke | KeyStroke.getKeyStrokeForEvent(KeyEvent anEvent) 返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。
static boolean | SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers) 如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
protected void | JComponent.processComponentKeyEvent(KeyEvent e) 处理该组件本身可识别的所有键事件。
protected boolean | JTable.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
protected boolean | JMenuBar.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed) 子类化以检查所有子菜单。
protected boolean | JComponent.processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed) 由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
static boolean | SwingUtilities.processKeyBindings(KeyEvent event) 处理与 event 关联的 Component 的键绑定。
void | JComboBox.processKeyEvent(KeyEvent e) 处理 KeyEvent，查找 Tab 键。
void | MenuSelectionManager.processKeyEvent(KeyEvent e) 当 MenuElement 从 KeyListener 接收事件时，它决不应直接处理该事件。
protected void | JPopupMenu.processKeyEvent(KeyEvent evt) 处理快捷键事件，如助记符和加速器。
protected void | JMenu.processKeyEvent(KeyEvent evt) 处理键击事件，如助记符和加速器。
protected void | JComponent.processKeyEvent(KeyEvent e) 重写 processKeyEvent 以处理事件。
void | JPopupMenu.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | JMenuBar.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | JMenuItem.processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
void | MenuElement.processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager) 处理键事件。

javax.swing.event 中 KeyEvent 的使用

javax.swing.event 中 KeyEvent 的子类
 class MenuKeyEvent
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

javax.swing.plaf.basic 中 KeyEvent 的使用

参数类型为 KeyEvent 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.KeyHandler.keyPressed(KeyEvent e)
void | BasicTableUI.KeyHandler.keyPressed(KeyEvent e)
void | BasicComboBoxUI.KeyHandler.keyPressed(KeyEvent e)
void | BasicTreeUI.KeyHandler.keyReleased(KeyEvent e)
void | BasicTableUI.KeyHandler.keyReleased(KeyEvent e)
void | BasicComboPopup.InvocationKeyHandler.keyReleased(KeyEvent e)
void | BasicTreeUI.KeyHandler.keyTyped(KeyEvent e) 键入键时调用。
void | BasicTableUI.KeyHandler.keyTyped(KeyEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.InputEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.InputEvent
的使用

使用 InputEvent 的软件包
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

java.awt.dnd 中 InputEvent 的使用

类型参数类型为 InputEvent 的 java.awt.dnd 中的字段
protected  ArrayList<InputEvent> DragGestureRecognizer.events
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。

返回 InputEvent 的 java.awt.dnd 中的方法
InputEvent | DragGestureEvent.getTriggerEvent() 返回触发动作的初始事件。
InputEvent | DragGestureRecognizer.getTriggerEvent() 此方法返回发起 Drag 和 Drop 操作的系列事件中的首个事件。

返回变量类型为 InputEvent 的类型的 java.awt.dnd 中的方法
 Iterator<InputEvent> DragGestureEvent.iterator()
返回组成动作的事件 Iterator。

参数类型为 InputEvent 的 java.awt.dnd 中的方法
protected  void DragGestureRecognizer.appendEvent(InputEvent awtie)
Recognizer 在 Component 上注册的侦听器将通过此 API 记录所有识别的 Event，识别的 Event 是组成 Drag 和 Drop 开始动作的系列 Event 的一部分。

类型变量类型为 InputEvent 的 java.awt.dnd 中的构造方法参数
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。

java.awt.event 中 InputEvent 的使用

java.awt.event 中 InputEvent 的子类
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。

javax.swing 中 InputEvent 的使用

参数类型为 InputEvent 的 javax.swing 中的方法
 void TransferHandler.exportAsDrag(JComponent comp, InputEvent e, int action)
导致 Swing 拖动支持的启用。

javax.swing.event 中 InputEvent 的使用

javax.swing.event 中 InputEvent 的子类
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.event.ComponentEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.event.ComponentEvent
的使用

使用 ComponentEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 ComponentEvent 的使用

参数类型为 ComponentEvent 的 java.awt 中的方法
void | AWTEventMulticaster.componentHidden(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentHidden 方法处理 componentHidden 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentHidden(ComponentEvent e)
void | AWTEventMulticaster.componentMoved(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentMoved 方法处理 componentMoved 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentMoved(ComponentEvent e)
void | AWTEventMulticaster.componentResized(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentResized 方法处理 componentResized 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentResized(ComponentEvent e)
void | AWTEventMulticaster.componentShown(ComponentEvent e) 通过在侦听器 a 和侦听器 b 上调用 componentShown 方法处理 componentShown 事件。
void | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler.componentShown(ComponentEvent e)
protected void | Component.processComponentEvent(ComponentEvent e) 处理组件上发生的组件事件，方法是将其指派到任意已注册的 ComponentListener 对象。

java.awt.event 中 ComponentEvent 的使用

java.awt.event 中 ComponentEvent 的子类
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

参数类型为 ComponentEvent 的 java.awt.event 中的方法
void | ComponentAdapter.componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | ComponentListener.componentHidden(ComponentEvent e) 组件变得不可见时调用。
void | ComponentAdapter.componentMoved(ComponentEvent e) 组件位置更改时调用。
void | ComponentListener.componentMoved(ComponentEvent e) 组件位置更改时调用。
void | ComponentAdapter.componentResized(ComponentEvent e) 组件大小更改时调用。
void | ComponentListener.componentResized(ComponentEvent e) 组件大小更改时调用。
void | ComponentAdapter.componentShown(ComponentEvent e) 组件变得可见时调用。
void | ComponentListener.componentShown(ComponentEvent e) 组件变得可见时调用。

javax.swing 中 ComponentEvent 的使用

参数类型为 ComponentEvent 的 javax.swing 中的方法
 void JViewport.ViewListener.componentResized(ComponentEvent e)

javax.swing.event 中 ComponentEvent 的使用

javax.swing.event 中 ComponentEvent 的子类
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

javax.swing.plaf.basic 中 ComponentEvent 的使用

参数类型为 ComponentEvent 的 javax.swing.plaf.basic 中的方法
void | BasicInternalFrameUI.ComponentHandler.componentHidden(ComponentEvent e)
void | BasicInternalFrameUI.ComponentHandler.componentMoved(ComponentEvent e)
void | BasicTreeUI.ComponentHandler.componentMoved(ComponentEvent e)
void | BasicInternalFrameUI.ComponentHandler.componentResized(ComponentEvent e) 当 JInternalFrame 的父级大小更改时调用。
void | BasicSliderUI.ComponentHandler.componentResized(ComponentEvent e)
void | BasicInternalFrameUI.ComponentHandler.componentShown(ComponentEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


FontRenderContext (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 FontRenderContext

java.lang.Object
    继承者  java.awt.font.FontRenderContext

public class FontRenderContext
extends Object

FontRenderContext 类是正确测量文本所需的信息容器。因为将轮廓映射到像素的规则不同，而且应用程序提供的呈现提示不同，所以文本的测量也有所不同。

其中一条信息是将印刷点缩放成像素的转换信息。（一个点被定义成恰好是一英寸的 1/72，这与点的传统机械测量稍有不同。）由于舍入到像素边界和字体设计者已指定的提示等因素，在 600dpi 设备上以 12pt 呈现的字符可能与在 72dpi 设备上以 12pt 呈现的同一个字符大小不同。

应用程序指定的 Anti-aliasing 和 Fractional-metrics 也可能因为舍入到像素边界而影响字符的大小。

通常，从 Graphics2D 对象获取 FontRenderContext 实例。直接构造的 FontRenderContext 很可能不表示任何实际的图形设备，并可能导致不可预料的或不正确的结果。

另请参见：
RenderingHints.KEY_TEXT_ANTIALIASING, RenderingHints.KEY_FRACTIONALMETRICS, Graphics2D.getFontRenderContext(), LineMetrics

构造方法摘要
protected | FontRenderContext() 构造一个新 FontRenderContext 对象。
 | FontRenderContext(AffineTransform tx, boolean isAntiAliased, boolean usesFractionalMetrics) 根据可选的 AffineTransform 和两个 boolean 值构造一个 FontRenderContext 对象，这两个 boolean 值确定新构造的对象是否具有 anti-aliasing 或 fractional metrics 属性。
 | FontRenderContext(AffineTransform tx, Object aaHint, Object fmHint) 根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。
方法摘要
 boolean equals(FontRenderContext rhs)
如果 rhs 具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
 boolean equals(Object obj)
如果 obj 是 FontRenderContext 的一个实例，并且具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
 Object getAntiAliasingHint()
返回此 FontRenderContext 中使用的文本 anti-aliasing 呈现模式提示。
 Object getFractionalMetricsHint()
返回此 FontRenderContext 中使用的文本 fractional metrics 呈现模式提示。
 AffineTransform getTransform()
获取用于在此 FontRenderContext 中将印刷点缩放为像素的转换。
 int getTransformType()
返回此 FontRenderContext 的仿射转换的整数类型，该类型由 AffineTransform.getType() 指定。
 int hashCode()
返回此 FontRenderContext 的哈希码。
 boolean isAntiAliased()
返回一个 boolean 值，指示是否某些形式的抗锯齿由此 FontRenderContext 指定。
 boolean isTransformed()
指示此 FontRenderContext 对象是否需要考虑已转换的呈现上下文中的文本。
 boolean usesFractionalMetrics()
返回一个 boolean 值，指示是否在此 FontRenderContext 中使用文本 fractional metrics 模式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FontRenderContext

protected FontRenderContext()
构造一个新 FontRenderContext 对象。

FontRenderContext

public FontRenderContext(AffineTransform tx,
                         boolean isAntiAliased,
                         boolean usesFractionalMetrics)
根据可选的 AffineTransform 和两个 boolean 值构造一个 FontRenderContext 对象，这两个 boolean 值确定新构造的对象是否具有 anti-aliasing 或 fractional metrics 属性。在任何情况下，boolean 值 true 和 false 分别对应于呈现提示值 ON 和 OFF。

要指定其他提示值，请使用将呈现提示值指定为参数的构造方法： FontRenderContext(AffineTransform, Object, Object)。

参数：
tx - 用于在此 FontRenderContext 中将印刷点缩放为像素的转换。如果该参数为 null，则使用恒等转换。
isAntiAliased - 确定新构造的对象是否具有 anti-aliasing 属性。
usesFractionalMetrics - 确定新构造的对象是否具有 fractional metrics 属性。

FontRenderContext

public FontRenderContext(AffineTransform tx,
                         Object aaHint,
                         Object fmHint)
根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。

参数：
tx - 用于在此 FontRenderContext 中将印刷点缩放为像素的转换。如果该参数为 null，则使用恒等转换。
aaHint - - java.awt.RenderingHints 中定义的文本抗锯齿呈现提示值之一。其他任何值都将抛出 IllegalArgumentException。可以指定 VALUE_TEXT_ANTIALIAS_DEFAULT，在这种情况下，使用的模式与实现有关。
fmHint - - java.awt.RenderingHints 中定义的文本碎片 (text fractional) 呈现提示值之一。可以指定 VALUE_FRACTIONALMETRICS_DEFAULT，在这种情况下，使用的默认与实现有关。其他任何值都将抛出 IllegalArgumentException
抛出：
IllegalArgumentException - 如果提示不是一个合法值。
从以下版本开始：
1.6
方法详细信息

isTransformed

public boolean isTransformed()
指示此 FontRenderContext 对象是否需要考虑已转换的呈现上下文中的文本。

返回：
如果此 FontRenderContext 对象具有非等同 AffineTransform 属性，则返回 true。否则返回 false。
从以下版本开始：
1.6
另请参见：
getTransform()

getTransformType

public int getTransformType()
返回此 FontRenderContext 的仿射转换的整数类型，该类型由 AffineTransform.getType() 指定。

返回：
转换的类型。
从以下版本开始：
1.6
另请参见：
AffineTransform

getTransform

public AffineTransform getTransform()
获取用于在此 FontRenderContext 中将印刷点缩放为像素的转换。

返回：
此 FontRenderContext 的 AffineTransform
另请参见：
AffineTransform

isAntiAliased

public boolean isAntiAliased()
返回一个 boolean 值，指示是否某些形式的抗锯齿由此 FontRenderContext 指定。对于特定呈现提示值，可以调用 getAntiAliasingHint()。

返回：
如果此 FontRenderContext 中的文本是抗锯齿的，则返回 true；否则返回 false。
另请参见：
RenderingHints.KEY_TEXT_ANTIALIASING, FontRenderContext(AffineTransform,boolean,boolean), FontRenderContext(AffineTransform,Object,Object)

usesFractionalMetrics

public boolean usesFractionalMetrics()
返回一个 boolean 值，指示是否在此 FontRenderContext 中使用文本 fractional metrics 模式。可以调用 getFractionalMetricsHint() 来获得对应的呈现提示值。

返回：
如果在此 FontRenderContext 中的布局应使用 fractional metrics 来执行，则返回 true；否则返回 false。
另请参见：
RenderingHints.KEY_FRACTIONALMETRICS, FontRenderContext(AffineTransform,boolean,boolean), FontRenderContext(AffineTransform,Object,Object)

getAntiAliasingHint

public Object getAntiAliasingHint()
返回此 FontRenderContext 中使用的文本 anti-aliasing 呈现模式提示。该值将是 java.awt.RenderingHints 中定义的文本抗锯齿呈现提示值之一。

返回：
此 FontRenderContext 中使用的文本 anti-aliasing 呈现模式提示。
从以下版本开始：
1.6

getFractionalMetricsHint

public Object getFractionalMetricsHint()
返回此 FontRenderContext 中使用的文本 fractional metrics 呈现模式提示。该值将是 java.awt.RenderingHints 中定义的文本 fractional metrics 呈现提示值之一。

返回：
此 FontRenderContext 中使用的文本 fractional metrics 呈现模式提示。
从以下版本开始：
1.6

equals

public boolean equals(Object obj)
如果 obj 是 FontRenderContext 的一个实例，并且具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要测试其相等性的对象
返回：
如果指定的对象与此 FontRenderContext 相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

equals

public boolean equals(FontRenderContext rhs)
如果 rhs 具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。

参数：
rhs - 要测试其相等性的 FontRenderContext
返回：
如果 rhs 与此 FontRenderContext 相等，则返回 true；否则返回 false。
从以下版本开始：
1.4

hashCode

public int hashCode()
返回此 FontRenderContext 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


GlyphJustificationInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 GlyphJustificationInfo

java.lang.Object
    继承者  java.awt.font.GlyphJustificationInfo

public final class GlyphJustificationInfo
extends Object

GlyphJustificationInfo 类表示关于字形调整属性的信息。字形是一个或多个字符的视觉表示形式。可以使用多个不同的字形来表示单个字符或字符组合。GlyphJustificationInfo 表示的四个调整属性为 weight、priority、absorb 和 limit。

Weight 是行中字形的总“权重”。通常它与字体的大小成正比。较大 weight 的字形相应分配较大的空间改变量。

Priority 确定此字形使用的调整阶段。检查下一 priority 的字形前先检查同一 priority 的所有字形。如果可以将所有的空间更改都分配给这些字形而不超出该字形的界限，则不检查具有下一个 priority 的字形。有四种 priority 属性：kashida、whitespace、interchar 和 none。KASHIDA 是第一个被检查的 priority。NONE 是最后一个被检查的 priority。

Absorb 确定字形是否占有所有的空间更改。在给定的 priority 内，某些字形可能占有所有的空间更改。如果存在这些字形，则不检查具有较低 priority 的字形。

Limit 确定该字形可以更改的最大量或最小量。该字形的左边和右边可以具有不同的 limit。

每个 GlyphJustificationInfo 表示两组规格，它们是增大 和缩小。当行上的字形要散开，以放入较大的宽度时，请使用增大规格。当这些字形要向集中移动，以适合较小的宽度时，请使用缩小规格。

字段摘要
boolean | growAbsorb 如果为 true，那么当此字形增大时，它会占有此 priority 和更低 priority 的所有额外空间。
float | growLeftLimit 此字形左边可以增大的最大量。
int | growPriority 此字形增大时的 priority 级别。
float | growRightLimit 此字形右边可以增大的最大量。
static int | PRIORITY_INTERCHAR 次低调整 priority。
static int | PRIORITY_KASHIDA 最高调整 priority。
static int | PRIORITY_NONE 最低调整 priority。
static int | PRIORITY_WHITESPACE 次高调整 priority。
boolean | shrinkAbsorb 如果为 true，那么当此字形缩小时，它会占有此 priority 和更低 priority 的所有剩余收缩量。
float | shrinkLeftLimit 此字形左边可以收缩的最大量（一个正数）。
int | shrinkPriority 此字形缩小时的 priority 级别。
float | shrinkRightLimit 此字形右边可以收缩的最大量（一个正数）。
float | weight 此字形的 weight。
构造方法摘要
GlyphJustificationInfo(float weight, boolean growAbsorb, int growPriority, float growLeftLimit, float growRightLimit, boolean shrinkAbsorb, int shrinkPriority, float shrinkLeftLimit, float shrinkRightLimit)
构造有关字形调整属性的信息。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PRIORITY_KASHIDA

public static final int PRIORITY_KASHIDA
最高调整 priority。

另请参见：
常量字段值

PRIORITY_WHITESPACE

public static final int PRIORITY_WHITESPACE
次高调整 priority。

另请参见：
常量字段值

PRIORITY_INTERCHAR

public static final int PRIORITY_INTERCHAR
次低调整 priority。

另请参见：
常量字段值

PRIORITY_NONE

public static final int PRIORITY_NONE
最低调整 priority。

另请参见：
常量字段值

weight

public final float weight
此字形的 weight。

growPriority

public final int growPriority
此字形增大时的 priority 级别。

growAbsorb

public final boolean growAbsorb
如果为 true，那么当此字形增大时，它会占有此 priority 和更低 priority 的所有额外空间。

growLeftLimit

public final float growLeftLimit
此字形左边可以增大的最大量。

growRightLimit

public final float growRightLimit
此字形右边可以增大的最大量。

shrinkPriority

public final int shrinkPriority
此字形缩小时的 priority 级别。

shrinkAbsorb

public final boolean shrinkAbsorb
如果为 true，那么当此字形缩小时，它会占有此 priority 和更低 priority 的所有剩余收缩量。

shrinkLeftLimit

public final float shrinkLeftLimit
此字形左边可以收缩的最大量（一个正数）。

shrinkRightLimit

public final float shrinkRightLimit
此字形右边可以收缩的最大量（一个正数）。

构造方法详细信息

GlyphJustificationInfo

public GlyphJustificationInfo(float weight,
                              boolean growAbsorb,
                              int growPriority,
                              float growLeftLimit,
                              float growRightLimit,
                              boolean shrinkAbsorb,
                              int shrinkPriority,
                              float shrinkLeftLimit,
                              float shrinkRightLimit)
构造有关字形调整属性的信息。

参数：
weight - 分配空间时，此字形的权重。必须为非负数。
growAbsorb - 如果为 true，那么当此字形增大时，它会占有此 priority 和较低 priority 的所有额外空间
growPriority - 此字形增大时的 priority 级别
growLeftLimit - 此字形左边可以增大的最大量。必须为非负数。
growRightLimit - 此字形右边可以增大的最大量。必须为非负数。
shrinkAbsorb - 如果为 true，那么当此字形缩小时，它会占有此 priority 和较低 priority 的所有剩余缩小量
shrinkPriority - 此字形缩小时的 priority 级别
shrinkLeftLimit - 此字形左边可以缩小的最大量。必须为非负数。
shrinkRightLimit - 此字形右边可以缩小的最大量。必须为非负数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GlyphMetrics (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 GlyphMetrics

java.lang.Object
    继承者  java.awt.font.GlyphMetrics

public final class GlyphMetrics
extends Object

GlyphMetrics 类表示单个字形的信息。字形是一个或多个字符的可视化表示形式。可以使用多个不同的字形来表示单个字符或字符组合。GlyphMetrics 实例由 Font 生成，并可应用于特定 Font 中的具体字形。

字形可以是 STANDARD、LIGATURE、COMBINING 或 COMPONENT。

  • STANDARD 字形通常用于表示单个字符。
  • LIGATURE 字形用于表示字符序列。
  • GlyphVector 中的 COMPONENT 字形不对应文本模型中的特定字符。取而代之的是，由于印刷原因（如阿拉伯语调整）添加 COMPONENT 字形。
  • COMBINING 字形修饰 STANDARD 或 LIGATURE 字形，例如，重音符号。插入符 (caret) 不会出现在 COMBINING 字形的前面。

通过 GlyphMetrics 可使用的其他规格是 advance、可视边界以及左跨距和右跨距分量。

对于旋转字体的字形或从已对字形应用旋转的 GlyphVector 获得的字形，可以具有包含 X 和 Y 分量的 advance。advance 通常仅有一个分量。

字形的 advance 是从该字形原点沿基线（可以是垂直的，也可以是水平的）到下一个字形原点的距离。注意，在 GlyphVector 中，由于字距调整和其他位置调整，所以从一个字形到其下一个字形之间的距离可能不是该字形的 advance。

边界是完全包含该字形轮廓的最小矩形。边界矩形是相对于该字形原点的。左跨距是从字形原点到其边界矩形左边的距离。如果左跨距为负，则将该字形的一部分绘制到其原点的左边。右跨距是从该边界矩形的右边到下一个字形原点的距离（原点加上 advance）。如果为负，则将该字形的一部分绘制到下一个字形原点的右边。注意，当呈现该字形时，由于光栅化和像素调整效果，该边界不一定包括受到影响的所有像素。

虽然可以直接构造 GlyphMetrics 的实例，但是几乎总是从 GlyphVector 获得它们。一旦构造 GlyphMetrics 对象之后，它就是不可变的。

示例：

查询 Font，了解字形信息

 Font font = ...;
 int glyphIndex = ...;
 GlyphMetrics metrics = GlyphVector.getGlyphMetrics(glyphIndex);
 int isStandard = metrics.isStandard();
 float glyphAdvance = metrics.getAdvance();

另请参见：
Font, GlyphVector

字段摘要
static byte | COMBINING 指示表示组合字符的字形，例如元音变音。
static byte | COMPONENT 指示在内部存储中没有相应字符的字形。
static byte | LIGATURE 指示将多个字符表示成连字（例如，'fi' 或 'ffi'）的字形。
static byte | STANDARD 指示表示单个标准字符的字形。
static byte | WHITESPACE 指示一个无可视化表示形式的字形。
构造方法摘要
GlyphMetrics(boolean horizontal, float advanceX, float advanceY, Rectangle2D bounds, byte glyphType)
构造一个 GlyphMetrics 对象。
GlyphMetrics(float advance, Rectangle2D bounds, byte glyphType)
构造一个 GlyphMetrics 对象。
方法摘要
float | getAdvance() 返回沿基线（水平基线或垂直基线）的字形 advance。
float | getAdvanceX() 返回字形 advance 的 x 分量。
float | getAdvanceY() 返回字形 advance 的 y 分量。
Rectangle2D | getBounds2D() 返回该字形的边界。
float | getLSB() 返回该字形的左（上）跨距。
float | getRSB() 返回该字形的右（底）跨距。
int | getType() 返回原始字形类型代码。
boolean | isCombining() 如果这是一个组合字形，则返回 true。
boolean | isComponent() 如果这是一个分量字形，则返回 true。
boolean | isLigature() 如果这是一个连字字形，则返回 true。
boolean | isStandard() 如果这是一个标准字形，则返回 true。
boolean | isWhitespace() 如果这是一个空白字形，则返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STANDARD

public static final byte STANDARD
指示表示单个标准字符的字形。

另请参见：
常量字段值

LIGATURE

public static final byte LIGATURE
指示将多个字符表示成连字（例如，'fi' 或 'ffi'）的字形。它后跟用于剩余字符的填充字形。可以将填充字形和组合字形混合，以控制重音符号逻辑上在前置连字上的位置。

另请参见：
常量字段值

COMBINING

public static final byte COMBINING
指示表示组合字符的字形，例如元音变音。在此字形和前置字形之间没有插入符的位置。

另请参见：
常量字段值

COMPONENT

public static final byte COMPONENT
指示在内部存储中没有相应字符的字形。该字形与逻辑前置无分量字形表示的字符关联。这用于 kashida 调整或其他现有字形的可视修改。在此字形和前置字形之间没有插入符的位置。

另请参见：
常量字段值

WHITESPACE

public static final byte WHITESPACE
指示一个无可视化表示形式的字形。可将其添加到其他代码值，以指示可见字形。

另请参见：
常量字段值
构造方法详细信息

GlyphMetrics

public GlyphMetrics(float advance,
                    Rectangle2D bounds,
                    byte glyphType)
构造一个 GlyphMetrics 对象。

参数：
advance - 该字形的 advance 宽度
bounds - 该字形的黑框边界
glyphType - 该字形的类型

GlyphMetrics

public GlyphMetrics(boolean horizontal,
                    float advanceX,
                    float advanceY,
                    Rectangle2D bounds,
                    byte glyphType)
构造一个 GlyphMetrics 对象。

参数：
horizontal - 如果为 true，则规格用于水平基线；否则用于垂直基线
advanceX - 该字形的 advance 的 X 分量
advanceY - 该字形的 advance 的 Y 分量
bounds - 该字形的可视化边界
glyphType - 该字形的类型
从以下版本开始：
1.4
方法详细信息

getAdvance

public float getAdvance()
返回沿基线（水平基线或垂直基线）的字形 advance。

返回：
该字形的 advance

getAdvanceX

public float getAdvanceX()
返回字形 advance 的 x 分量。

返回：
字形 advance 的 x 分量
从以下版本开始：
1.4

getAdvanceY

public float getAdvanceY()
返回字形 advance 的 y 分量。

返回：
字形 advance 的 y 分量
从以下版本开始：
1.4

getBounds2D

public Rectangle2D getBounds2D()
返回该字形的边界。这是该字形轮廓的边界框。因为光栅化和像素对齐的影响，在呈现字形时，它不一定包括受影响的像素。

返回：
该字形边界的 Rectangle2D。

getLSB

public float getLSB()
返回该字形的左（上）跨距。

这是从 0, 0 到该字形边界的左（上）边的距离。如果该字形的边界在原点的左（上）边，则 LSB 为负。

返回：
该字形的左跨距。

getRSB

public float getRSB()
返回该字形的右（底）跨距。

这是从该字形边界的右（底）边到该 advance 的距离。如果该字形的边界在 advance 的右（下）边，则 RSB 为负。

返回：
该字形的右跨距。

getType

public int getType()
返回原始字形类型代码。

返回：
原始字形类型代码。

isStandard

public boolean isStandard()
如果这是一个标准字形，则返回 true。

返回：
如果这是一个标准字形，则返回 true；否则返回 false。

isLigature

public boolean isLigature()
如果这是一个连字字形，则返回 true。

返回：
如果这是一个连字字形；则返回 true；否则返回 false。

isCombining

public boolean isCombining()
如果这是一个组合字形，则返回 true。

返回：
如果这是一个组合字形，则返回 true；否则返回 false。

isComponent

public boolean isComponent()
如果这是一个分量字形，则返回 true。

返回：
如果这是一个分量字形，则返回 true；否则返回 false。

isWhitespace

public boolean isWhitespace()
如果这是一个空白字形，则返回 true。

返回：
如果这是一个空白字形，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GlyphVector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 GlyphVector

java.lang.Object
    继承者  java.awt.font.GlyphVector
所有已实现的接口：
Cloneable
public abstract class GlyphVector
extends Object
implements Cloneable

GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。

GlyphVector 不尝试对它包含的字形序列进行任何解释。序列中相邻字形之间的关系只用于确定在可视坐标空间中的字形放置。

GlyphVector 的实例由 Font 创建。

在一个可以对文本的中间表示形式进行缓存的文本处理应用程序中，将字符的可视化表示形式呈现给用户最快的方法是，创建并随后缓存在呈现期间使用的 GlyphVector。

GlyphVector 只与一个 Font 关联，可以提供仅与此 Font 相关的有用数据。另外，从 GlyphVector 获得的规格通常不是几何上可缩放的，因为像素化和间隔与 Font 中的网格适应算法相关。为了便于精确测量 GlyphVector 及其分量字形，在创建 GlyphVector 时必须指定缩放转换、anti-alias 模式和 fractional metrics 模式。这些特性可以从目标设备派生得到。

对于 GlyphVector 中的每个字形，您可以获得：

  • 该字形的位置
  • 与该字形关联的转换
  • GlyphVector 上下文中的字形规格。在不同的转换、具有指定呈现提示的应用程序和 GlyphVector 内字形的具体实例情况下，字形的规格可能也不相同。

改变创建 GlyphVector 所使用的数据不会改变 GlyphVector 的状态。

该类提供了一些方法来调整 GlyphVector 内字形位置。这些方法最适合为显示字形而正在执行调整操作的应用程序。

该类提供了一些方法来转换 GlyphVector 中各个字形。这些方法主要用于特殊效果。

该类提供了一些方法来返回整个 GlyphVector 或 GlyphVector 中各个字形的可视的、逻辑的和像素的边界。

该类还提供了一些方法来返回 GlyphVector 和 GlyphVector 中各个字形的 Shape。

另请参见：
Font, GlyphMetrics, TextLayout

字段摘要
static int | FLAG_COMPLEX_GLYPHS 与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从字形到字符的复杂映射关系（此映射并非严格按照与排列方向匹配的升序或降序顺序将字形一一映射到字符）。
static int | FLAG_HAS_POSITION_ADJUSTMENTS 与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 调整了位置。
static int | FLAG_HAS_TRANSFORMS 与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 的每个字形都有转换。
static int | FLAG_MASK getLayoutFlags 支持标志的掩码。
static int | FLAG_RUN_RTL 与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从右到左的排列方向。
构造方法摘要
GlyphVector()
方法摘要
abstract boolean | equals(GlyphVector set) 测试指定的 GlyphVector 是否恰好等于此 GlyphVector。
abstract Font | getFont() 返回与此 GlyphVector 关联的 Font。
abstract FontRenderContext | getFontRenderContext() 返回与此 GlyphVector 关联的 FontRenderContext。
int | getGlyphCharIndex(int glyphIndex) 返回指定字形的字符索引。
int[] | getGlyphCharIndices(int beginGlyphIndex, int numEntries, int[] codeReturn) 返回指定字形的字符索引。
abstract int | getGlyphCode(int glyphIndex) 返回指定字形的 glyphcode。
abstract int[] | getGlyphCodes(int beginGlyphIndex, int numEntries, int[] codeReturn) 返回指定字形的 glyphcode 数组。
abstract GlyphJustificationInfo | getGlyphJustificationInfo(int glyphIndex) 返回此 GlyphVector 中指定索引处的字形调整信息。
abstract Shape | getGlyphLogicalBounds(int glyphIndex) 返回此 GlyphVector 中指定字形的逻辑边界。
abstract GlyphMetrics | getGlyphMetrics(int glyphIndex) 返回此 GlyphVector 中指定索引处的字形规格。
abstract Shape | getGlyphOutline(int glyphIndex) 返回其内部区域与此 GlyphVector 中指定字形的可视表示形式对应的 Shape。
Shape | getGlyphOutline(int glyphIndex, float x, float y) 返回一个 Shape，其内部区域与此 GlyphVector 中指定字形的可视表示形式对应，并偏移到 x、y。
Rectangle | getGlyphPixelBounds(int index, FontRenderContext renderFRC, float x, float y) 返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。
abstract Point2D | getGlyphPosition(int glyphIndex) 返回与此 GlyphVector 原点对应的指定字形的位置。
abstract float[] | getGlyphPositions(int beginGlyphIndex, int numEntries, float[] positionReturn) 返回包含指定字形位置的数组。
abstract AffineTransform | getGlyphTransform(int glyphIndex) 返回此 GlyphVector 中指定字形的转换。
abstract Shape | getGlyphVisualBounds(int glyphIndex) 返回 GlyphVector 中指定字形的可视边界。
int | getLayoutFlags() 返回描述该 GlyphVector 全局状态的标志。
abstract Rectangle2D | getLogicalBounds() 返回此 GlyphVector 的逻辑边界。
abstract int | getNumGlyphs() 返回此 GlyphVector 中的字形数。
abstract Shape | getOutline() 返回其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
abstract Shape | getOutline(float x, float y) 返回在 x、y 处呈现时，其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
Rectangle | getPixelBounds(FontRenderContext renderFRC, float x, float y) 返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。
abstract Rectangle2D | getVisualBounds() 返回此 GlyphVector 的可视边界，可视边界是此 GlyphVector 轮廓的边界框。
abstract void | performDefaultLayout() 为此 GlyphVector 中的每个字形分配默认位置。
abstract void | setGlyphPosition(int glyphIndex, Point2D newPos) 设置此 GlyphVector 中的指定字形位置。
abstract void | setGlyphTransform(int glyphIndex, AffineTransform newTX) 设置此 GlyphVector 中指定字形的转换。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FLAG_HAS_TRANSFORMS

public static final int FLAG_HAS_TRANSFORMS
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 的每个字形都有转换。

从以下版本开始：
1.4
另请参见：
常量字段值

FLAG_HAS_POSITION_ADJUSTMENTS

public static final int FLAG_HAS_POSITION_ADJUSTMENTS
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 调整了位置。该标志为 true 时，字形位置与该字形累加的默认 advance 不匹配（例如，已完成字距调整）。

从以下版本开始：
1.4
另请参见：
常量字段值

FLAG_RUN_RTL

public static final int FLAG_RUN_RTL
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从右到左的排列方向。这是指字形到字符的映射关系，并不意味着该字形的可视位置一定要按此顺序，但通常如此。

从以下版本开始：
1.4
另请参见：
常量字段值

FLAG_COMPLEX_GLYPHS

public static final int FLAG_COMPLEX_GLYPHS
与 getLayoutFlags 一起使用的标志，指示此 GlyphVector 具有从字形到字符的复杂映射关系（此映射并非严格按照与排列方向匹配的升序或降序顺序将字形一一映射到字符）。

从以下版本开始：
1.4
另请参见：
常量字段值

FLAG_MASK

public static final int FLAG_MASK
getLayoutFlags 支持标志的掩码。只应测试该掩码包含的位。

从以下版本开始：
1.4
另请参见：
常量字段值
构造方法详细信息

GlyphVector

public GlyphVector()
方法详细信息

getFont

public abstract Font getFont()
返回与此 GlyphVector 关联的 Font。

返回：
用于创建此 GlyphVector 的 Font。
另请参见：
Font

getFontRenderContext

public abstract FontRenderContext getFontRenderContext()
返回与此 GlyphVector 关联的 FontRenderContext。

返回：
用于创建此 GlyphVector 的 FontRenderContext。
另请参见：
FontRenderContext, Font

performDefaultLayout

public abstract void performDefaultLayout()
为此 GlyphVector 中的每个字形分配默认位置。这会破坏此 GlyphVector 初始布局期间所生成的信息。

getNumGlyphs

public abstract int getNumGlyphs()
返回此 GlyphVector 中的字形数。

返回：
此 GlyphVector 中的字形数。

getGlyphCode

public abstract int getGlyphCode(int glyphIndex)
返回指定字形的 glyphcode。除创建此 GlyphVector 的 Font 对象之外，此返回值对其他对象均无意义。

参数：
glyphIndex - 此 GlyphVector 中的索引，它与从中检索 glyphcode 的字形对应。
返回：
指定 glyphIndex 处字形的 glyphcode。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数

getGlyphCodes

public abstract int[] getGlyphCodes(int beginGlyphIndex,
                                    int numEntries,
                                    int[] codeReturn)
返回指定字形的 glyphcode 数组。除用来创建此 GlyphVector 的 Font 之外，此返回值的内容对其他对象均无意义。处理 glyphcode 时，此方法使用便捷，性能优越。如果没有数组传入，则创建新的数组。

参数：
beginGlyphIndex - 此 GlyphVector 中的索引，从此处开始检索 glyphcode
numEntries - 要检索的 glyphcode 数
codeReturn - 接收 glyphcode 然后返回的数组
返回：
指定字形的 glyphcode 数组。
抛出：
IllegalArgumentException - 如果 numEntries 小于 0
IndexOutOfBoundsException - 如果 beginGlyphIndex 小于 0
IndexOutOfBoundsException - 如果 beginGlyphIndex 与 numEntries 的和大于此 GlyphVector 中的字形数

getGlyphCharIndex

public int getGlyphCharIndex(int glyphIndex)
返回指定字形的字符索引。字符索引是该字形表示的第一个逻辑字符的索引。默认实现假定字形和字符是从左到右一一对应的映射关系。

参数：
glyphIndex - 该字形的索引
返回：
该字形表示的第一个字符索引
从以下版本开始：
1.4

getGlyphCharIndices

public int[] getGlyphCharIndices(int beginGlyphIndex,
                                 int numEntries,
                                 int[] codeReturn)
返回指定字形的字符索引。字符索引是该字形表示的第一个逻辑字符的索引。按字形顺序返回索引。默认实现为每个字形调用 getGlyphCharIndex，出于性能的考虑，子类可能要重写此实现。在处理 glyphcode 时，此方法使用便捷，性能优越。如果没有数组传入，则创建新的数组。

参数：
beginGlyphIndex - 第一个字形的索引
numEntries - 字形索引数
codeReturn - 接收返回字符索引的数组
返回：
字符索引的数组，每个字形一个字符索引。
从以下版本开始：
1.4

getLogicalBounds

public abstract Rectangle2D getLogicalBounds()
返回此 GlyphVector 的逻辑边界。相对于视觉相邻的 GlyphVector 对象定位此 GlyphVector 时使用此方法。

返回：
一个 Rectangle2D，它是此 GlyphVector 的逻辑边界。

getVisualBounds

public abstract Rectangle2D getVisualBounds()
返回此 GlyphVector 的可视边界，可视边界是此 GlyphVector 轮廓的边界框。由于像素的光栅化和对齐方式，此框可能没有包围受呈现此 GlyphVector 影响的所有像素。

返回：
一个 Rectangle2D，它是此 GlyphVector 的边界框。

getPixelBounds

public Rectangle getPixelBounds(FontRenderContext renderFRC,
                                float x,
                                float y)
返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。renderFRC 无需与此 GlyphVector 的 FontRenderContext 相同，可以为 null。如果为 null，则使用此 GlyphVector 的 FontRenderContext。默认实现返回可视边界、x 和 y 的偏移量，并舍入为下一个整数值（即返回包含可视边界的整数矩形），并忽略 FRC。子类应重写此方法。

参数：
renderFRC - Graphics 的 FontRenderContext。
x - 呈现此 GlyphVector 处的 x 坐标。
y - 呈现此 GlyphVector 处的 y 坐标。
返回：
包围受影响像素的 Rectangle。
从以下版本开始：
1.4

getOutline

public abstract Shape getOutline()
返回其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。

返回：
此 GlyphVector 轮廓的 Shape。

getOutline

public abstract Shape getOutline(float x,
                                 float y)
返回在 x、y 处呈现时，其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。

参数：
x - 此 GlyphVector 的 X 坐标。
y - 此 GlyphVector 的 Y 坐标。
返回：
在指定坐标位置呈现时，此 GlyphVector 轮廓的 Shape。

getGlyphOutline

public abstract Shape getGlyphOutline(int glyphIndex)
返回其内部区域与此 GlyphVector 中指定字形的可视表示形式对应的 Shape。此方法返回的轮廓位于各个字形的原点周围。

参数：
glyphIndex - 此 GlyphVector 的索引
返回：
一个 Shape，它是该 GlyphVector 中指定 glyphIndex 处的字形轮廓。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数

getGlyphOutline

public Shape getGlyphOutline(int glyphIndex,
                             float x,
                             float y)
返回一个 Shape，其内部区域与此 GlyphVector 中指定字形的可视表示形式对应，并偏移到 x、y。此方法返回的轮廓位于各个字形的原点周围。

参数：
glyphIndex - 此 GlyphVector 的索引
x - 此 GlyphVector 的坐标的 X 坐标
y - 此 GlyphVector 的坐标的 Y 坐标
返回：
一个 Shape，它是在指定的坐标处呈现时，此 GlyphVector 中指定 glyphIndex 处的字形轮廓。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数
从以下版本开始：
1.4

getGlyphPosition

public abstract Point2D getGlyphPosition(int glyphIndex)
返回与此 GlyphVector 原点对应的指定字形的位置。如果 glyphIndex 等于此 GlyphVector 中的字形数，则此方法返回最后一个字形后的位置。此位置用于定义整个 GlyphVector 的 advance。

参数：
glyphIndex - 此 GlyphVector 的索引
返回：
表示指定 glyphIndex 处字形位置的 Point2D 对象。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于此 GlyphVector 中的字形数
另请参见：
setGlyphPosition(int, java.awt.geom.Point2D)

setGlyphPosition

public abstract void setGlyphPosition(int glyphIndex,
                                      Point2D newPos)
设置此 GlyphVector 中的指定字形位置。如果 glyphIndex 等于此 GlyphVector 中的字形数，则此方法设置最后一个字形后的位置。此位置用于定义整个 GlyphVector 的 advance。

参数：
glyphIndex - 此 GlyphVector 的索引
newPos - 定位指定 glyphIndex 处字形的 Point2D
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或大于此 GlyphVector 中的字形数
另请参见：
getGlyphPosition(int)

getGlyphTransform

public abstract AffineTransform getGlyphTransform(int glyphIndex)
返回此 GlyphVector 中指定字形的转换。该转换与字形位置相关。如果未应用特殊转换，则返回 null。返回 null 指示恒等转换。

参数：
glyphIndex - 此 GlyphVector 的索引
返回：
转换指定 glyphIndex 处字形的 AffineTransform。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数
另请参见：
setGlyphTransform(int, java.awt.geom.AffineTransform)

setGlyphTransform

public abstract void setGlyphTransform(int glyphIndex,
                                       AffineTransform newTX)
设置此 GlyphVector 中指定字形的转换。该转换与字形位置相关。newTX 参数为 null 表示对指定字形没有应用特殊转换。此方法可以用于旋转、镜像、平移和缩放字形。添加转换可以明显地影响性能。

参数：
glyphIndex - 此 GlyphVector 的索引
newTX - glyphIndex 处的字形的新转换
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数
另请参见：
getGlyphTransform(int)

getLayoutFlags

public int getLayoutFlags()
返回描述该 GlyphVector 全局状态的标志。下文没有描述的标志是保留的。对于位置调整、转换、rtl 和复杂标志，默认实现返回 0（意味着 false）。子类应重写此方法，并确保它正确地描述 GlyphVector 并与相关调用的结果对应。

返回：
一个 int 值，包含描述该状态的标志
从以下版本开始：
1.4
另请参见：
FLAG_HAS_POSITION_ADJUSTMENTS, FLAG_HAS_TRANSFORMS, FLAG_RUN_RTL, FLAG_COMPLEX_GLYPHS, FLAG_MASK

getGlyphPositions

public abstract float[] getGlyphPositions(int beginGlyphIndex,
                                          int numEntries,
                                          float[] positionReturn)
返回包含指定字形位置的数组。处理字形位置时，此方法使用便捷，性能优越。如果没有数组传入，则创建新的数组。从位置 0 开始的偶数数组项是编号为 beginGlyphIndex + position/2 的字形 X 坐标。从位置 1 开始的奇数数组项是编号为 beginGlyphIndex + (position-1)/2 的字形 Y 坐标。如果 beginGlyphIndex 等于此 GlyphVector 中的字形数，则此方法会获取最后一个字形后的位置，此位置用于定义整个 GlyphVector 的 advance。

参数：
beginGlyphIndex - 开始检索字形位置的索引
numEntries - 要检索的字形数
positionReturn - 接收字形位置然后返回的数组。
返回：
由 beginGlyphIndex 和 numEntries 指定的字形位置的数组。
抛出：
IllegalArgumentException - 如果 numEntries 小于 0
IndexOutOfBoundsException - 如果 beginGlyphIndex 小于 0
IndexOutOfBoundsException - 如果 beginGlyphIndex 与 numEntries 的和大于此 GlyphVector 中的字形数加 1

getGlyphLogicalBounds

public abstract Shape getGlyphLogicalBounds(int glyphIndex)
返回此 GlyphVector 中指定字形的逻辑边界。这些逻辑边界总共有四个边，两个边平行于该字形转换的基线，另外两个边与相邻字形（如果存在）共用。此方法常用于指定字形的命中测试、插入符在开始边和尾边的定位，以及在指定字形周围绘制一个高亮显示区域。

参数：
glyphIndex - 此 GlyphVector 的索引，它与从中检索其逻辑边界的字形对应
返回：
一个 Shape，表示指定 glyphIndex 处的字形逻辑边界。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数
另请参见：
getGlyphVisualBounds(int)

getGlyphVisualBounds

public abstract Shape getGlyphVisualBounds(int glyphIndex)
返回 GlyphVector 中指定字形的可视边界。此方法返回的边界位于各个字形的原点周围。

参数：
glyphIndex - 此 GlyphVector 的索引，它与从中检索其可视边界的字形对应
返回：
一个 Shape，表示指定 GlyphVector 处的字形可视边界。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数
另请参见：
getGlyphLogicalBounds(int)

getGlyphPixelBounds

public Rectangle getGlyphPixelBounds(int index,
                                     FontRenderContext renderFRC,
                                     float x,
                                     float y)
返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。 renderFRC 无需与此 GlyphVector 的 FontRenderContext 相同，可以为 null。如果为 null，则使用此 GlyphVector 的 FontRenderContext。默认的实现会返回该字形的可视边界、x 和 y 的偏移量，以及舍入到下一个整数值，并忽略 FRC。子类应重写此方法。

参数：
index - 该字形的索引。
renderFRC - Graphics 的 FontRenderContext。
x - 呈现此 GlyphVector 的 X 坐标。
y - 呈现此 GlyphVector 的 Y 坐标。
返回：
包围受影响像素的 Rectangle。
从以下版本开始：
1.4

getGlyphMetrics

public abstract GlyphMetrics getGlyphMetrics(int glyphIndex)
返回此 GlyphVector 中指定索引处的字形规格。

参数：
glyphIndex - 此 GlyphVector 的索引，它与从中检索其规格的字形对应
返回：
一个 GlyphMetrics 对象，表示此 GlyphVector 中指定 glyphIndex 处的字形规格。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数

getGlyphJustificationInfo

public abstract GlyphJustificationInfo getGlyphJustificationInfo(int glyphIndex)
返回此 GlyphVector 中指定索引处的字形调整信息。

参数：
glyphIndex - 此 GlyphVector 的索引，它与从中检索其调整属性的字形对应
返回：
一个 GlyphJustificationInfo 对象，表示此 GlyphVector 中指定 glyphIndex 处的字形调整属性。
抛出：
IndexOutOfBoundsException - 如果 glyphIndex 小于 0，或者大于等于此 GlyphVector 中的字形数

equals

public abstract boolean equals(GlyphVector set)
测试指定的 GlyphVector 是否恰好等于此 GlyphVector。

参数：
set - 要测试的指定 GlyphVector
返回：
如果指定的 GlyphVector 等于此 GlyphVector，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GraphicAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 GraphicAttribute

java.lang.Object
    继承者  java.awt.font.GraphicAttribute
直接已知子类：
ImageGraphicAttribute, ShapeGraphicAttribute
public abstract class GraphicAttribute
extends Object

此类与 CHAR_REPLACEMENT 属性一起使用。

GraphicAttribute 类表示文本中内嵌的图形。客户端创建此类的子类，以实现其自身的 char 替换图形。要在文本中嵌入形状和图像的客户端不必创建此类的子类。相反，客户端可以使用 ShapeGraphicAttribute 和 ImageGraphicAttribute 类。

子类必须确保对象一经构造就不可修改。该变 TextLayout 中使用的 GraphicAttribute 会导致 TextLayout 的不确定行为。

字段摘要
static int | BOTTOM_ALIGNMENT 将图形底部与行的底部对齐。
static int | CENTER_BASELINE 将图形的原点与行的中心基线对齐。
static int | HANGING_BASELINE 将图形的原点与行的悬挂基线对齐。
static int | ROMAN_BASELINE 将图形的原点与行的罗马字体基线对齐。
static int | TOP_ALIGNMENT 将图形顶端与行的顶端对齐。
构造方法摘要
protected GraphicAttribute(int alignment)
构造一个 GraphicAttribute。
方法摘要
abstract void | draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
abstract float | getAdvance() 返回此 GraphicAttribute 的 advance。
int | getAlignment() 返回此 GraphicAttribute 的对齐方式。
abstract float | getAscent() 返回此 GraphicAttribute 的 ascent。
Rectangle2D | getBounds() 返回包括所有位的 Rectangle2D，这些位由与呈现位置相关的 GraphicAttribute 绘制。
abstract float | getDescent() 返回此 GraphicAttribute 的 descent。
GlyphJustificationInfo | getJustificationInfo() 返回此 GraphicAttribute 的调整信息。
Shape | getOutline(AffineTransform tx) 返回表示此 GraphicAttribute 呈现区域的 Shape。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TOP_ALIGNMENT

public static final int TOP_ALIGNMENT
将图形顶端与行的顶端对齐。

另请参见：
常量字段值

BOTTOM_ALIGNMENT

public static final int BOTTOM_ALIGNMENT
将图形底部与行的底部对齐。

另请参见：
常量字段值

ROMAN_BASELINE

public static final int ROMAN_BASELINE
将图形的原点与行的罗马字体基线对齐。

另请参见：
常量字段值

CENTER_BASELINE

public static final int CENTER_BASELINE
将图形的原点与行的中心基线对齐。

另请参见：
常量字段值

HANGING_BASELINE

public static final int HANGING_BASELINE
将图形的原点与行的悬挂基线对齐。

另请参见：
常量字段值
构造方法详细信息

GraphicAttribute

protected GraphicAttribute(int alignment)
构造一个 GraphicAttribute。子类使用此构造方法来定义图形的对齐方式。

参数：
alignment - 表示某个 GraphicAttribute 对齐字段的 int 值。
方法详细信息

getAscent

public abstract float getAscent()
返回此 GraphicAttribute 的 ascent。图形可以在其 ascent 之上呈现。

返回：
此 GraphicAttribute 的 ascent。
另请参见：
getBounds()

getDescent

public abstract float getDescent()
返回此 GraphicAttribute 的 descent。图形可以在其 descent 之下呈现。

返回：
此 GraphicAttribute 的 descent。
另请参见：
getBounds()

getAdvance

public abstract float getAdvance()
返回此 GraphicAttribute 的 advance。GraphicAttribute 对象的 advance 是呈现该图形的点与呈现下一个字符或图形的点之间的距离。图形可以呈现在其 advance 之外。

返回：
此 GraphicAttribute 的 advance。
另请参见：
getBounds()

getBounds

public Rectangle2D getBounds()
返回包括所有位的 Rectangle2D，这些位由与呈现位置相关的 GraphicAttribute 绘制。图形可以在其原点、ascent、descent 和 advance 之外呈现；但是如果这样的话，此方法的实现必须指示呈现该图形的位置。默认的边界是矩形 (0, -ascent, advance, ascent+descent)。

返回：
包括由此 GraphicAttribute 呈现的所有位的 Rectangle2D。

getOutline

public Shape getOutline(AffineTransform tx)
返回表示此 GraphicAttribute 呈现区域的 Shape。当请求 TextLayout 返回文本轮廓时，将使用此方法。（未变换的）Shape 不得超出 getBounds 返回的矩形边界。 默认实现将返回由 getBounds() 返回，并通过提供的 AffineTransform（如果有）变换得到的矩形。

参数：
tx - 要应用到此 GraphicAttribute 轮廓的可选 AffineTransform。此参数可以为 null。
返回：
.表示此图形属性的 Shape，适用于勾画或填充。
从以下版本开始：
1.6

draw

public abstract void draw(Graphics2D graphics,
                          float x,
                          float y)
在指定的位置呈现此 GraphicAttribute。

参数：
graphics - 将该图形呈现到的 Graphics2D
x, y - 呈现该图形的用户空间坐标

getAlignment

public final int getAlignment()
返回此 GraphicAttribute 的对齐方式。可与特定的基线对齐，或与行的绝对顶端或底端对齐。

返回：
此 GraphicAttribute 的对齐方式。

getJustificationInfo

public GlyphJustificationInfo getJustificationInfo()
返回此 GraphicAttribute 的调整信息。子类可以重写此方法，以提供不同的调整信息。

返回：
包含此 GraphicAttribute 调整信息的 GlyphJustificationInfo 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageGraphicAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 ImageGraphicAttribute

java.lang.Object
    继承者  java.awt.font.GraphicAttribute
        继承者  java.awt.font.ImageGraphicAttribute

public final class ImageGraphicAttribute
extends GraphicAttribute

ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。

另请参见：
GraphicAttribute

字段摘要
从类 java.awt.font.GraphicAttribute 继承的字段
BOTTOM_ALIGNMENT, CENTER_BASELINE, HANGING_BASELINE, ROMAN_BASELINE, TOP_ALIGNMENT
构造方法摘要
ImageGraphicAttribute(Image image, int alignment)
根据指定的 Image 构造一个 ImageGraphicAttribute。
ImageGraphicAttribute(Image image, int alignment, float originX, float originY)
根据指定的 Image 构造一个 ImageGraphicAttribute。
方法摘要
void | draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
boolean | equals(ImageGraphicAttribute rhs) 比较此 ImageGraphicAttribute 与指定的 ImageGraphicAttribute。
boolean | equals(Object rhs) 比较此 ImageGraphicAttribute 与指定的 Object。
float | getAdvance() 返回此 ImageGraphicAttribute 的 advance。
float | getAscent() 返回此 ImageGraphicAttribute 的 ascent。
Rectangle2D | getBounds() 返回一个 Rectangle2D，它封装此 ImageGraphicAttribute 相对于呈现位置呈现的所有位。
float | getDescent() 返回此 ImageGraphicAttribute 的 descent。
int | hashCode() 返回此 ImageGraphicAttribute 的哈希码。
从类 java.awt.font.GraphicAttribute 继承的方法
getAlignment, getJustificationInfo, getOutline
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageGraphicAttribute

public ImageGraphicAttribute(Image image,
                             int alignment)
根据指定的 Image 构造一个 ImageGraphicAttribute。原点位于 (0, 0)。

参数：
image - 此 ImageGraphicAttribute 呈现的 Image。此对象保持对 image 的引用。
alignment - 此 ImageGraphicAttribute 的一种对齐方式。

ImageGraphicAttribute

public ImageGraphicAttribute(Image image,
                             int alignment,
                             float originX,
                             float originY)
根据指定的 Image 构造一个 ImageGraphicAttribute。Image 中的点 (originX, originY) 出现在文本中 ImageGraphicAttribute 的原点。

参数：
image - 此 ImageGraphicAttribute 呈现的 Image。此对象保持对 image 的引用。
alignment - 此 ImageGraphicAttribute 的一种对齐方式
originX - Image 中点的 X 坐标，该点显示在文本行中 ImageGraphicAttribute 的原点位置上。
originY - Image 中点的 Y 坐标，该点显示在文本行中 ImageGraphicAttribute 的原点位置上。
方法详细信息

getAscent

public float getAscent()
返回此 ImageGraphicAttribute 的 ascent。ImageGraphicAttribute 的 ascent 是从该图像的顶端到原点的距离。

指定者：
类 GraphicAttribute 中的 getAscent
返回：
此 ImageGraphicAttribute 的 ascent。
另请参见：
GraphicAttribute.getBounds()

getDescent

public float getDescent()
返回此 ImageGraphicAttribute 的 descent。ImageGraphicAttribute 的 descent 是从原点到该图像底部的距离。

指定者：
类 GraphicAttribute 中的 getDescent
返回：
此 ImageGraphicAttribute 的 descent。
另请参见：
GraphicAttribute.getBounds()

getAdvance

public float getAdvance()
返回此 ImageGraphicAttribute 的 advance。ImageGraphicAttribute 的 advance 是从原点到该图像右边缘的距离。

指定者：
类 GraphicAttribute 中的 getAdvance
返回：
此 ImageGraphicAttribute 的 advance。
另请参见：
GraphicAttribute.getBounds()

getBounds

public Rectangle2D getBounds()
返回一个 Rectangle2D，它封装此 ImageGraphicAttribute 相对于呈现位置呈现的所有位。图形可以在其原点、ascent、descent 和 advance 之外呈现；但如果这样做,此方法的实现必须指示呈现该图形的位置。

覆盖：
类 GraphicAttribute 中的 getBounds
返回：
封装此 ImageGraphicAttribute 呈现的所有位的 Rectangle2D。

draw

public void draw(Graphics2D graphics,
                 float x,
                 float y)
在指定的位置呈现此 GraphicAttribute。

指定者：
类 GraphicAttribute 中的 draw
参数：
graphics - 将该图形呈现到的 Graphics2D

hashCode

public int hashCode()
返回此 ImageGraphicAttribute 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object rhs)
比较此 ImageGraphicAttribute 与指定的 Object。

覆盖：
类 Object 中的 equals
参数：
rhs - 要测试相等性的 Object
返回：
如果此 ImageGraphicAttribute 与 rhs 相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

equals

public boolean equals(ImageGraphicAttribute rhs)
比较此 ImageGraphicAttribute 与指定的 ImageGraphicAttribute。

参数：
rhs - 要测试相等性的 ImageGraphicAttribute
返回：
如果此 ImageGraphicAttribute 与 rhs 相等，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutPath (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 LayoutPath

java.lang.Object
    继承者  java.awt.font.LayoutPath

public abstract class LayoutPath
extends Object

LayoutPath 提供相对于基线的位置与用户空间中的点之间的映射。位置由沿基线的 advance 以及垂直于该 advance 处基线的偏移量组成。沿垂线的正值的方向是从基线向量顺时针旋转 90 度的方向。位置表示为 Point2D，其中 x 为 advance，y 为偏移量。

从以下版本开始：
1.6

构造方法摘要
LayoutPath()
方法摘要
abstract void | pathToPoint(Point2D location, boolean preceding, Point2D point) 将相对于路径的位置转换为用户坐标中的点。
abstract boolean | pointToPath(Point2D point, Point2D location) 将用户空间中的点转换为相对于路径的位置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LayoutPath

public LayoutPath()
方法详细信息

pointToPath

public abstract boolean pointToPath(Point2D point,
                                    Point2D location)
将用户空间中的点转换为相对于路径的位置。选择的位置要最小化点到路径的距离（例如，偏移量的数量级将是最小值）。如果存在多个这样的位置，则选择具有最小 advance 的位置。

参数：
point - 要转换的点。如果它不是与 location 相同的对象，则此调用将不会修改该点。
location - 用于保存返回位置的 Point2D。它可以是与 point 相同的对象。
返回：
如果点与位置前面的路径部分关联，则返回 true；如果它与后面部分关联，则返回 false。默认情况下，如果该位置不在路径中的中断处或尖锐拐弯处，则返回 true。
抛出：
NullPointerException - 如果 point 或 location 为 null
从以下版本开始：
1.6

pathToPoint

public abstract void pathToPoint(Point2D location,
                                 boolean preceding,
                                 Point2D point)
将相对于路径的位置转换为用户坐标中的点。路径可能突然拐弯或者在此位置的 advance 处不相交。如果是这样，则 'preceding' 的值用于确定路径部分，路径的位置和斜面将用于解释偏移量。

参数：
location - 一个 Point2D，表示相对于路径的某一位置的 advance（用 x 表示）和 offset（用 y 表示）。如果 location 与 point 不是相同的对象，则此调用不会修改该位置。
preceding - 如果为 true，则应该使用 advance 之前的部分；如果为 false，则应该使用之后的部分。如果路径在 advance 处没有中断或突然拐弯，则此方法无效。
point - 用于保存返回点的 Point2D。它可以是与 location 相同的对象。
抛出：
NullPointerException - 如果 location 或 point 为 null
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineBreakMeasurer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 LineBreakMeasurer

java.lang.Object
    继承者  java.awt.font.LineBreakMeasurer

public final class LineBreakMeasurer
extends Object

LineBreakMeasurer 类允许将样式化的文本断为行（或段），以符合特定的可视 advance。这对希望显示适合指定宽度（称为环绕宽度）文本段落的客户端很有用。

LineBreakMeasurer 通过样式化文本上的迭代器构造。该迭代器的范围应该是文本中的单个段落。LineBreakMeasurer 保存文本中用于开始下一个文本段的位置。最初，此位置是文本的开始点。根据双向格式规则，为段落分配了总体方向（从左到右或从右到左）。从段落获得的所有段具有与该段落相同的方向。

通过调用方法 nextLayout 可获得文本的段，该方法会返回表示符合该环绕宽度的文本的 TextLayout。nextLayout 方法将当前位置移动到从 nextLayout 返回的布局末尾。

LineBreakMeasurer 实现最常用的换行策略：在该行上放置符合环绕宽度的每一个词。如果第一个词不符合，那么适合环绕宽度的所有字符将放置在该行上。每行至少放置一个字符。

由 LineBreakMeasurer 返回的 TextLayout 实例将 TAB 视为 0 宽度的空格。为了定位而希望获得以 TAB 分界的段的客户端应该重载 nextLayout，它可以在文本实行限制偏移量。限制偏移量应该是 TAB 后的第一个字符。从此方法返回的 TextLayout 对象在提供的界限处（或者界限之前，条件是当前位置和该界限之间的文本没有完全位于环绕宽度之内）结束。

在行上放置首段之后，正在布局 TAB 分隔文本的客户端需要稍微不同的换行策略。新策略不是将部分词放入剩余空间，而是应该将无法完全放入剩余空间的词放在下一行。带有 boolean 参数的 nextLayout 重载中可能请求这种策略更改。如果此参数为 true，且第一个词无法放入给定的空间，则 nextLayout 返回 null。请参见下面的 TAB 示例。

通常，如果用于构造 LineBreakMeasurer 的文本发生更改，则必须构造新的 LineBreakMeasurer 以反映此更改。（原来的 LineBreakMeasurer 可继续正常工作，但文本的更改对于它是未知的。）但是如果该文本更改是插入或删除单个字符，则可通过调用 insertChar 或 deleteChar 来“更新”现有的 LineBreakMeasurer。更新现有的 LineBreakMeasurer 比创建一个新 LineBreakMeasurer 要快得多。根据用户键入内容来修改文本的客户端应利用这些方法。

示例：

在组件中呈现段落

 public void paint(Graphics graphics) {

     Point2D pen = new Point2D(10, 20);
     Graphics2D g2d = (Graphics2D)graphics;
     FontRenderContext frc = g2d.getFontRenderContext();

     // let styledText be an AttributedCharacterIterator containing at least
     // one character

     LineBreakMeasurer measurer = new LineBreakMeasurer(styledText, frc);
     float wrappingWidth = getSize().width - 15;

     while (measurer.getPosition() < fStyledText.length()) {

         TextLayout layout = measurer.nextLayout(wrappingWidth);

         pen.y += (layout.getAscent());
         float dx = layout.isLeftToRight() ?
             0 : (wrappingWidth - layout.getAdvance());

         layout.draw(graphics, pen.x + dx, pen.y);
         pen.y += layout.getDescent() + layout.getLeading();
     }
 }

使用 TAB 呈现文本。为简单起见，假定总体的文本方向为从左到右

 public void paint(Graphics graphics) {

     float leftMargin = 10, rightMargin = 310;
     float[] tabStops = { 100, 250 };

     // assume styledText is an AttributedCharacterIterator, and the number
     // of tabs in styledText is tabCount

     int[] tabLocations = new int[tabCount+1];

     int i = 0;
     for (char c = styledText.first(); c != styledText.DONE; c = styledText.next()) {
         if (c == '\t') {
             tabLocations[i++] = styledText.getIndex();
         }
     }
     tabLocations[tabCount] = styledText.getEndIndex() - 1;

     // Now tabLocations has an entry for every tab's offset in
     // the text.  For convenience, the last entry is tabLocations
     // is the offset of the last character in the text.

     LineBreakMeasurer measurer = new LineBreakMeasurer(styledText);
     int currentTab = 0;
     float verticalPos = 20;

     while (measurer.getPosition() < styledText.getEndIndex()) {

         // Lay out and draw each line.  All segments on a line
         // must be computed before any drawing can occur, since
         // we must know the largest ascent on the line.
         // TextLayouts are computed and stored in a Vector;
         // their horizontal positions are stored in a parallel
         // Vector.

         // lineContainsText is true after first segment is drawn
         boolean lineContainsText = false;
         boolean lineComplete = false;
         float maxAscent = 0, maxDescent = 0;
         float horizontalPos = leftMargin;
         Vector layouts = new Vector(1);
         Vector penPositions = new Vector(1);

         while (!lineComplete) {
             float wrappingWidth = rightMargin - horizontalPos;
             TextLayout layout =
                     measurer.nextLayout(wrappingWidth,
                                         tabLocations[currentTab]+1,
                                         lineContainsText);

             // layout can be null if lineContainsText is true
             if (layout != null) {
                 layouts.addElement(layout);
                 penPositions.addElement(new Float(horizontalPos));
                 horizontalPos += layout.getAdvance();
                 maxAscent = Math.max(maxAscent, layout.getAscent());
                 maxDescent = Math.max(maxDescent,
                     layout.getDescent() + layout.getLeading());
             } else {
                 lineComplete = true;
             }

             lineContainsText = true;

             if (measurer.getPosition() == tabLocations[currentTab]+1) {
                 currentTab++;
             }

             if (measurer.getPosition() == styledText.getEndIndex())
                 lineComplete = true;
             else if (horizontalPos >= tabStops[tabStops.length-1])
                 lineComplete = true;

             if (!lineComplete) {
                 // move to next tab stop
                 int j;
                 for (j=0; horizontalPos >= tabStops[j]; j++) {}
                 horizontalPos = tabStops[j];
             }
         }

         verticalPos += maxAscent;

         Enumeration layoutEnum = layouts.elements();
         Enumeration positionEnum = penPositions.elements();

         // now iterate through layouts and draw them
         while (layoutEnum.hasMoreElements()) {
             TextLayout nextLayout = (TextLayout) layoutEnum.nextElement();
             Float nextPosition = (Float) positionEnum.nextElement();
             nextLayout.draw(graphics, nextPosition.floatValue(), verticalPos);
         }

         verticalPos += maxDescent;
     }
 }

另请参见：
TextLayout

构造方法摘要
LineBreakMeasurer(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
LineBreakMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
方法摘要
void | deleteChar(AttributedCharacterIterator newParagraph, int deletePos) 从文本删除单个字符之后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
int | getPosition() 返回此 LineBreakMeasurer 的当前位置。
void | insertChar(AttributedCharacterIterator newParagraph, int insertPos) 将单个字符插入文本后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
TextLayout | nextLayout(float wrappingWidth) 返回下一个布局，并更新当前位置。
TextLayout | nextLayout(float wrappingWidth, int offsetLimit, boolean requireNextWord) 返回下一个布局，并更新当前位置。
int | nextOffset(float wrappingWidth) 返回下一个布局结尾处的位置。
int | nextOffset(float wrappingWidth, int offsetLimit, boolean requireNextWord) 返回下一个布局结尾处的位置。
void | setPosition(int newPosition) 设置此 LineBreakMeasurer 的当前位置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LineBreakMeasurer

public LineBreakMeasurer(AttributedCharacterIterator text,
                         FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。

参数：
text - 此 LineBreakMeasurer 为其生成 TextLayout 对象的文本；该文本必须至少包含一个字符；如果通过 iter 提供的文本发生更改，则再次调用此 LineBreakMeasurer 实例是不明确的（后来调用 insertChar 或 deleteChar 等某些情况除外 - 参见下面内容）
frc - 包含关于正确测量文本所需的图形设备的信息；由于设备分辨率和属性（抗锯齿）的不同，文本测量可能稍有变化；此参数不指定 LineBreakMeasurer 和用户空间之间的转换
另请参见：
insertChar(java.text.AttributedCharacterIterator, int), deleteChar(java.text.AttributedCharacterIterator, int)

LineBreakMeasurer

public LineBreakMeasurer(AttributedCharacterIterator text,
                         BreakIterator breakIter,
                         FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。

参数：
text - 此 LineBreakMeasurer 为其生成 TextLayout 对象的文本；该文本必须至少包含一个字符；如果通过 iter 提供的文本发生更改，则再次调用此 LineBreakMeasurer 实例是不明确的（后来调用 insertChar 或 deleteChar 等某些情况除外 - 参见下面内容）
breakIter - 定义换行的 BreakIterator
frc - 包含关于正确测量文本所需的图形设备的信息；由于设备分辨率和属性（抗锯齿）的不同，文本测量可能稍有变化；此参数不指定 LineBreakMeasurer 和用户空间之间的转换
抛出：
IllegalArgumentException - 如果文本少于一个字符
另请参见：
insertChar(java.text.AttributedCharacterIterator, int), deleteChar(java.text.AttributedCharacterIterator, int)
方法详细信息

nextOffset

public int nextOffset(float wrappingWidth)
返回下一个布局结尾处的位置。不更新此 LineBreakMeasurer 的当前位置。

参数：
wrappingWidth - 下一布局中文本所允许的最大可视 advance
返回：
文本中表示下一个 TextLayout 限制的偏移量。

nextOffset

public int nextOffset(float wrappingWidth,
                      int offsetLimit,
                      boolean requireNextWord)
返回下一个布局结尾处的位置。不更新此 LineBreakMeasurer 的当前位置。

参数：
wrappingWidth - 下一布局中文本所允许的最大可视 advance
offsetLimit - 即使限制后的文本适合该环绕宽度，下一个布局中也无法包括的第一个字符；offsetLimit 必须大于当前位置
requireNextWord - 如果为 true，且下一个词的全部不适合 wrappingWidth，则为返回的当前位置；如果为 false，则返回的偏移量至少比当前位置大一
返回：
文本中表示下一个 TextLayout 限制的偏移量。

nextLayout

public TextLayout nextLayout(float wrappingWidth)
返回下一个布局，并更新当前位置。

参数：
wrappingWidth - 下一布局中文本所允许的最大可视 advance
返回：
从当前位置开始的 TextLayout，它表示适合 wrappingWidth 的下一行。

nextLayout

public TextLayout nextLayout(float wrappingWidth,
                             int offsetLimit,
                             boolean requireNextWord)
返回下一个布局，并更新当前位置。

参数：
wrappingWidth - 下一个布局中文本所允许的最大可视 advance
offsetLimit - 即使限制后的文本适合环绕宽度，下一个布局中也无法包括的第一个字符；offsetLimit 必须大于当前位置
requireNextWord - 如果为 true，并且当前位置的整个词不适合环绕宽度，则返回 null。如果为 false，则返回有效的布局，该布局至少包括当前位置的字符
返回：
从当前位置开始的 TextLayout，它表示适合 wrappingWidth 的下一行。如果当前位置位于由此 LineBreakMeasurer 使用的文本末尾处，则返回 null

getPosition

public int getPosition()
返回此 LineBreakMeasurer 的当前位置。

返回：
此 LineBreakMeasurer 的当前位置
另请参见：
setPosition(int)

setPosition

public void setPosition(int newPosition)
设置此 LineBreakMeasurer 的当前位置。

参数：
newPosition - 此 LineBreakMeasurer 的当前位置；该位置应位于构造此 LineBreakMeasurer 所使用的文本内（或位于最近传递给 insertChar 或 deleteChar 的文本内）
另请参见：
getPosition()

insertChar

public void insertChar(AttributedCharacterIterator newParagraph,
                       int insertPos)
将单个字符插入文本后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。

参数：
newParagraph - 插入后的文本
insertPos - 文本中插入字符的位置
抛出：
IndexOutOfBoundsException - 如果 insertPos 小于 newParagraph 的开始，或者大于或等于 newParagraph 的末尾
NullPointerException - 如果 newParagraph 为 null
另请参见：
deleteChar(java.text.AttributedCharacterIterator, int)

deleteChar

public void deleteChar(AttributedCharacterIterator newParagraph,
                       int deletePos)
从文本删除单个字符之后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。

参数：
newParagraph - 删除之后的文本
deletePos - 文本中删除字符的位置
抛出：
IndexOutOfBoundsException - 如果 deletePos 小于 newParagraph 的开始，或大于 newParagraph 的末尾
NullPointerException - 如果 newParagraph 为 null
另请参见：
insertChar(java.text.AttributedCharacterIterator, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineMetrics (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 LineMetrics

java.lang.Object
    继承者  java.awt.font.LineMetrics

public abstract class LineMetrics
extends Object

LineMetrics 类允许访问沿着一行布局字符和多行布局所需要的规格。LineMetrics 对象封装了与文本排列相关的测量信息。

对于不同的字符范围，Font 可以有不同的规格。Font 的 getLineMetrics 方法将某一文本作为参数，并返回一个 LineMetrics 对象，该对象描述该文本中初始字符数量（由 getNumChars() 返回）的规格。

构造方法摘要
LineMetrics()
方法摘要
abstract float | getAscent() 返回该文本的 ascent。
abstract int | getBaselineIndex() 返回该文本的基线索引。
abstract float[] | getBaselineOffsets() 返回文本的基线偏移量（相对于文本的基线）。
abstract float | getDescent() 返回该文本的 descent。
abstract float | getHeight() 返回该文本的高度。
abstract float | getLeading() 返回该文本的 leading。
abstract int | getNumChars() 返回文本中的字符数量（char 值），该文本的规格由此 LineMetrics 对象封装。
abstract float | getStrikethroughOffset() 返回删除线相对于基线的位置。
abstract float | getStrikethroughThickness() 返回删除线的宽度。
abstract float | getUnderlineOffset() 返回下划线相对于基线的位置。
abstract float | getUnderlineThickness() 返回下划线的宽度。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LineMetrics

public LineMetrics()
方法详细信息

getNumChars

public abstract int getNumChars()
返回文本中的字符数量（char 值），该文本的规格由此 LineMetrics 对象封装。

返回：
文本中的字符数量（char 值），根据该数量可以创建此 LineMetrics。

getAscent

public abstract float getAscent()
返回该文本的 ascent。ascent 是从基线到 ascender 线的距离。ascent 通常表示文本中大写字母的高度。某些字符可以超过 ascender 线。

返回：
该文本的 ascent。

getDescent

public abstract float getDescent()
返回该文本的 descent。descent 是从基线到下降线的距离。descent 通常表示到小写字母（如 'p'）底部的距离。某些字符可以延伸到下降线以下。

返回：
该文本的 descent。

getLeading

public abstract float getLeading()
返回该文本的 leading。leading 是从下降线的底部到下一行顶部的建议距离。

返回：
该文本的 leading。

getHeight

public abstract float getHeight()
返回该文本的高度。文本高度等于 ascent、descent 和 leading 的总和。

返回：
该文本的高度。

getBaselineIndex

public abstract int getBaselineIndex()
返回该文本的基线索引。该索引是 ROMAN_BASELINE、CENTER_BASELINE、HANGING_BASELINE 之一。

返回：
该文本的基线。

getBaselineOffsets

public abstract float[] getBaselineOffsets()
返回文本的基线偏移量（相对于文本的基线）。基线索引用来索引该偏移量。例如，如果基线索引为 CENTER_BASELINE，则 offsets[HANGING_BASELINE] 通常为负，offsets[CENTER_BASELINE] 为 0，offsets[ROMAN_BASELINE] 则通常为正。

返回：
该文本的基线偏移量。

getStrikethroughOffset

public abstract float getStrikethroughOffset()
返回删除线相对于基线的位置。

返回：
删除线的位置。

getStrikethroughThickness

public abstract float getStrikethroughThickness()
返回删除线的宽度。

返回：
删除线的宽度。

getUnderlineOffset

public abstract float getUnderlineOffset()
返回下划线相对于基线的位置。

返回：
下划线的位置。

getUnderlineThickness

public abstract float getUnderlineThickness()
返回下划线的宽度。

返回：
下划线的宽度。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultipleMaster (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
接口 MultipleMaster

public interface MultipleMaster

MultipleMaster 接口表示 Type 1 Multiple Master 字体。特定的 Font 对象可以实现此接口。

方法摘要
 Font deriveMMFont(float[] axes)
根据指定数组中包含的设计轴值，创建 multiple master 字体的新实例。
 Font deriveMMFont(float[] glyphWidths, float avgStemWidth, float typicalCapHeight, float typicalXHeight, float italicAngle)
根据详细的规格信息，创建 multiple master 字体的新实例。
 float[] getDesignAxisDefaults()
返回每个轴的默认设计值的数组。
 String[] getDesignAxisNames()
返回每个设计轴的名称。
 float[] getDesignAxisRanges()
为每个轴返回以 [from->to] 形式交错的设计限制的数组。
 int getNumDesignAxes()
返回 multiple master 设计控制的数量。

方法详细信息

getNumDesignAxes

int getNumDesignAxes()
返回 multiple master 设计控制的数量。设计轴包括 width、weight 和视觉缩放等。

返回：
multiple master 设计控制的数量

getDesignAxisRanges

float[] getDesignAxisRanges()
为每个轴返回以 [from->to] 形式交错的设计限制的数组。例如，weight 的设计限制可以从 0.1 到 1.0。该值的返回顺序与 getDesignAxisNames 的返回顺序相同。

返回：
每个轴的设计限制的数组。

getDesignAxisDefaults

float[] getDesignAxisDefaults()
返回每个轴的默认设计值的数组。例如，weight 的默认值可以是 1.6。该值的返回顺序与 getDesignAxisNames 的返回顺序相同。

返回：
针对每个轴的设计限制值的数组。

getDesignAxisNames

String[] getDesignAxisNames()
返回每个设计轴的名称。这还可以确定返回每个轴的值的顺序。

返回：
包含每个设计轴的名称的数组。

deriveMMFont

Font deriveMMFont(float[] axes)
根据指定数组中包含的设计轴值，创建 multiple master 字体的新实例。该数组的大小必须对应于 getNumDesignAxes 返回的值，并且该数组元素的值必须落在 getDesignAxesLimits 指定的限制范围之内。出现错误时，返回 null。

参数：
axes - 包含轴值的数组
返回：
一个 Font 对象，它是 MultipleMaster 的一个实例，并且是根据 axes 提供的设计轴值创建的。

deriveMMFont

Font deriveMMFont(float[] glyphWidths,
                  float avgStemWidth,
                  float typicalCapHeight,
                  float typicalXHeight,
                  float italicAngle)
根据详细的规格信息，创建 multiple master 字体的新实例。出现错误时，返回 null。

参数：
glyphWidths - 表示字体空间中每个字形所需宽度的 float 数组
avgStemWidth - 字体空间中总字体的平均 stem 宽度
typicalCapHeight - 典型的大写 char 的高度
typicalXHeight - 典型的小写 char 的高度
italicAngle - 斜体字从垂直以逆时针方向倾斜的角度
返回：
一个 Font 对象，它是 MultipleMaster 的一个实例，并且是根据指定的规格信息创建的。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumericShaper (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 NumericShaper

java.lang.Object
    继承者  java.awt.font.NumericShaper
所有已实现的接口：
Serializable
public final class NumericShaper
extends Object
implements Serializable

NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。此类的用户主要是那些希望使用民族数字形状显示数据，但又发现使用 Latin-1（欧洲语）数字内部表示该数据更方便的人。此类不能解释过时的数字形状选择器字符 (U+206E)。

NumericShaper 的实例通常用作具有 TextAttribute 类的 NUMERIC_SHAPING 属性的文本属性。例如，以下代码片段可使 TextLayout 将欧洲数字转换成阿拉伯语上下文中的阿拉伯数字：

 Map map = new HashMap();
 map.put(TextAttribute.NUMERIC_SHAPING,
     NumericShaper.getContextualShaper(NumericShaper.ARABIC));
 FontRenderContext frc = ...;
 TextLayout layout = new TextLayout(text, map, frc);
 layout.draw(g2d, x, y);

它还可能使用 NumericShaper 的实例显式执行数字成形，如以下代码片断所演示的：
   char[] text = ...;
   // shape all EUROPEAN digits (except zero) to ARABIC digits
   NumericShaper shaper = NumericShaper.getShaper(NumericShaper.ARABIC);
   shaper.shape(text, start, count);

   // shape European digits to ARABIC digits if preceding text is Arabic, or
   // shape European digits to TAMIL digits if preceding text is Tamil, or
   // leave European digits alone if there is no preceding text, or
   // preceding text is neither Arabic nor Tamil
   NumericShaper shaper =
      NumericShaper.getContextualShaper(NumericShaper.ARABIC |
                                              NumericShaper.TAMIL,
                                              NumericShaper.EUROPEAN);
   shaper.shape(text. start, count);

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
static int | ALL_RANGES 标识所有的范围，用于完整的上下文成形。
static int | ARABIC 标识 ARABIC 范围和十进制基数。
static int | BENGALI 标识 BENGALI 范围和十进制基数。
static int | DEVANAGARI 标识 DEVANAGARI 范围和十进制基数。
static int | EASTERN_ARABIC 标识 ARABIC 范围和 ARABIC_EXTENDED 十进制基数。
static int | ETHIOPIC 标识 ETHIOPIC 范围和十进制基数。
static int | EUROPEAN 标识 Latin-1（欧洲语）和扩展范围，以及 Latin-1（欧洲语）十进制基数。
static int | GUJARATI 标识 GUJARATI 范围和十进制基数。
static int | GURMUKHI 标识 GURMUKHI 范围和十进制基数。
static int | KANNADA 标识 KANNADA 范围和十进制基数。
static int | KHMER 标识 KHMER 范围和十进制基数。
static int | LAO 标识 LAO 范围和十进制基数。
static int | MALAYALAM 标识 MALAYALAM 范围和十进制基数。
static int | MONGOLIAN 标识 MONGOLIAN 范围和十进制基数。
static int | MYANMAR 标识 MYANMAR 范围和十进制基数。
static int | ORIYA 标识 ORIYA 范围和十进制基数。
static int | TAMIL 标识 TAMIL 范围和十进制基数。
static int | TELUGU 标识 TELUGU 范围和十进制基数。
static int | THAI 标识 THAI 范围和十进制基数。
static int | TIBETAN 标识 TIBETAN 范围和十进制基数。
方法摘要
boolean | equals(Object o) 如果指定的对象是 NumericShaper 的一个实例，并且完全一致地成形到此实例，则返回 true。
static NumericShaper | getContextualShaper(int ranges) 返回提供的 unicode 范围的上下文成形器。
static NumericShaper | getContextualShaper(int ranges, int defaultContext) 返回提供的 unicode 范围的上下文成形器。
int | getRanges() 返回一个 int，它使用或操作 (OR) 连接所有将成形的范围的值。
static NumericShaper | getShaper(int singleRange) 返回所提供的 unicode 范围的成形器。
int | hashCode() 返回此成形器的哈希码。
boolean | isContextual() 返回一个 boolean 值，指示此成形器是否以上下文方式成形。
void | shape(char[] text, int start, int count) 转换文本中在 start 和 start + count 之间出现的数字。
void | shape(char[] text, int start, int count, int context) 使用提供的上下文，转换文本中在 start 和 start + count 之间出现的数字。
String | toString() 返回描述此成形器的 String。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

EUROPEAN

public static final int EUROPEAN
标识 Latin-1（欧洲语）和扩展范围，以及 Latin-1（欧洲语）十进制基数。

另请参见：
常量字段值

ARABIC

public static final int ARABIC
标识 ARABIC 范围和十进制基数。

另请参见：
常量字段值

EASTERN_ARABIC

public static final int EASTERN_ARABIC
标识 ARABIC 范围和 ARABIC_EXTENDED 十进制基数。

另请参见：
常量字段值

DEVANAGARI

public static final int DEVANAGARI
标识 DEVANAGARI 范围和十进制基数。

另请参见：
常量字段值

BENGALI

public static final int BENGALI
标识 BENGALI 范围和十进制基数。

另请参见：
常量字段值

GURMUKHI

public static final int GURMUKHI
标识 GURMUKHI 范围和十进制基数。

另请参见：
常量字段值

GUJARATI

public static final int GUJARATI
标识 GUJARATI 范围和十进制基数。

另请参见：
常量字段值

ORIYA

public static final int ORIYA
标识 ORIYA 范围和十进制基数。

另请参见：
常量字段值

TAMIL

public static final int TAMIL
标识 TAMIL 范围和十进制基数。泰米尔语没有十进制数字 0，所以使用 Latin-1（欧洲语）0。

另请参见：
常量字段值

TELUGU

public static final int TELUGU
标识 TELUGU 范围和十进制基数。

另请参见：
常量字段值

KANNADA

public static final int KANNADA
标识 KANNADA 范围和十进制基数。

另请参见：
常量字段值

MALAYALAM

public static final int MALAYALAM
标识 MALAYALAM 范围和十进制基数。

另请参见：
常量字段值

THAI

public static final int THAI
标识 THAI 范围和十进制基数。

另请参见：
常量字段值

LAO

public static final int LAO
标识 LAO 范围和十进制基数。

另请参见：
常量字段值

TIBETAN

public static final int TIBETAN
标识 TIBETAN 范围和十进制基数。

另请参见：
常量字段值

MYANMAR

public static final int MYANMAR
标识 MYANMAR 范围和十进制基数。

另请参见：
常量字段值

ETHIOPIC

public static final int ETHIOPIC
标识 ETHIOPIC 范围和十进制基数。

另请参见：
常量字段值

KHMER

public static final int KHMER
标识 KHMER 范围和十进制基数。

另请参见：
常量字段值

MONGOLIAN

public static final int MONGOLIAN
标识 MONGOLIAN 范围和十进制基数。

另请参见：
常量字段值

ALL_RANGES

public static final int ALL_RANGES
标识所有的范围，用于完整的上下文成形。

另请参见：
常量字段值
方法详细信息

getShaper

public static NumericShaper getShaper(int singleRange)
返回所提供的 unicode 范围的成形器。将所有 Latin-1（欧洲语）数字转换成相应的十进制 unicode 数字。

参数：
singleRange - 指定的 Unicode 范围
返回：
非上下文的数字成形器
抛出：
IllegalArgumentException - 如果范围不是单个范围

getContextualShaper

public static NumericShaper getContextualShaper(int ranges)
返回提供的 unicode 范围的上下文成形器。将 Latin-1（欧洲语）数字转换成与前述文本范围对应的十进制数字（如果该范围是提供的范围之一）。通过或操作连接这些值（如 NumericShaper.ARABIC | NumericShaper.THAI）来表示多个范围。该成形器假定 EUROPEAN 为初始上下文，即如果在字符串中在任何强方向文本之前碰到 EUROPEAN 数字，则该上下文将被假定为 EUROPEAN，因此将不成形数字。

参数：
ranges - 指定的 Unicode 范围
返回：
指定范围的成形器

getContextualShaper

public static NumericShaper getContextualShaper(int ranges,
                                                int defaultContext)
返回提供的 unicode 范围的上下文成形器。将 Latin-1（欧洲语）数字转换成与前述文本范围对应的十进制数字（如果该范围是提供的范围之一）。通过或操作连接这些值（例如 NumericShaper.ARABIC | NumericShaper.THAI）来表示多个范围。该成形器将 defaultContext 用作初始上下文。

参数：
ranges - 指定的 Unicode 范围
defaultContext - 初始上下文，如 NumericShaper.EUROPEAN
返回：
指定 Unicode 范围的成形器。
抛出：
IllegalArgumentException - 如果指定的 defaultContext 不是一个有效范围。

shape

public void shape(char[] text,
                  int start,
                  int count)
转换文本中在 start 和 start + count 之间出现的数字。

参数：
text - 要转换的字符数组
start - 要开始转换的 text 的索引
count - 要转换的 text 中的字符数
抛出：
IndexOutOfBoundsException - 如果 start 或 start + count 超出范围
NullPointerException - 如果 text 为 null

shape

public void shape(char[] text,
                  int start,
                  int count,
                  int context)
使用提供的上下文，转换文本中在 start 和 start + count 之间出现的数字。如果该成形器不是上下文成形器，则忽略上下文。

参数：
text - 字符数组
start - 要开始转换的 text 的索引
count - 要转换的 text 中的字符数
context - 向其转换字符（如 NumericShaper.EUROPEAN）的上下文
抛出：
IndexOutOfBoundsException - 如果 start 或 start + count 超出范围
NullPointerException - 如果 text 为 null
IllegalArgumentException - 如果这是一个上下文成形器，并且指定的 context 不是一个有效范围。

isContextual

public boolean isContextual()
返回一个 boolean 值，指示此成形器是否以上下文方式成形。

返回：
如果此成形器是上下文的，则返回 true；否则返回 false。

getRanges

public int getRanges()
返回一个 int，它使用或操作 (OR) 连接所有将成形的范围的值。

例如，要检查成形器是否成形阿拉伯数字，应使用以下语句：

if ((shaper.getRanges() & shaper.ARABIC) != 0) { ...

返回：
要成形的所有范围的值。

hashCode

public int hashCode()
返回此成形器的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此成形器的哈希码。
另请参见：
Object.hashCode()

equals

public boolean equals(Object o)
如果指定的对象是 NumericShaper 的一个实例，并且完全一致地成形到此实例，则返回 true。

覆盖：
类 Object 中的 equals
参数：
o - 要与此 NumericShaper 进行比较的指定对象
返回：
如果 o 是 NumericShaper 的一个实例，并且以相同的方式成形，则返回 true；否则返回 false。
另请参见：
Object.equals(java.lang.Object)

toString

public String toString()
返回描述此成形器的 String。该方法仅用于调试目的。

覆盖：
类 Object 中的 toString
返回：
描述此成形器的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
接口 OpenType

public interface OpenType

OpenType 接口表示 OpenType 和 TrueType 字体。此接口能够从该字体获得 sfnt 表。特定的 Font 对象可以实现此接口。

有关 TrueType 字体的更多信息，请参阅 Apple TrueType Reference Manual ( http://fonts.apple.com/TTRefMan/index.html )。

字段摘要
static int | TAG_ACNT 重音符附件。
static int | TAG_AVAR 轴变体。
static int | TAG_BASE 基线数据。
static int | TAG_BDAT 位图数据。
static int | TAG_BLOC 位图位置。
static int | TAG_BSLN 基线表。
static int | TAG_CFF 紧凑字体格式（Type1 字体）。
static int | TAG_CMAP 字形映射的字符。
static int | TAG_CVAR CVT 变体。
static int | TAG_CVT 控制值表。
static int | TAG_DSIG 数字签名。
static int | TAG_EBDT 内嵌位图数据。
static int | TAG_EBLC 内嵌位图位置。
static int | TAG_EBSC 内嵌位图缩放。
static int | TAG_FDSC 字体描述符。
static int | TAG_FEAT 特性名称。
static int | TAG_FMTX 字体规格。
static int | TAG_FPGM 字体程序。
static int | TAG_FVAR 字体变体。
static int | TAG_GASP 网格适应和扫描转换过程。
static int | TAG_GDEF 字形定义。
static int | TAG_GLYF 字形数据。
static int | TAG_GPOS 字形定位。
static int | TAG_GSUB 字形替换。
static int | TAG_GVAR 字形变体。
static int | TAG_HDMX 水平设备规格。
static int | TAG_HEAD 字体头部。
static int | TAG_HHEA 水平规格头部。
static int | TAG_HMTX 水平规格。
static int | TAG_JSTF 调整。
static int | TAG_JUST 调整。
static int | TAG_KERN 字距调整。
static int | TAG_LCAR 连字插入符。
static int | TAG_LOCA 位置索引。
static int | TAG_LTSH 线性阈值。
static int | TAG_MAXP 最大轮廓。
static int | TAG_MMFX Multiple Master 字体规格。
static int | TAG_MMSD Multiple master 增补数据。
static int | TAG_MORT 字形变化。
static int | TAG_NAME 命名表。
static int | TAG_OPBD 视觉边界。
static int | TAG_OS2 OS/2 和 Windows 特定规格。
static int | TAG_PCLT PCL 5 数据。
static int | TAG_POST PostScript 信息。
static int | TAG_PREP CVT 预编程。
static int | TAG_PROP 字形属性。
static int | TAG_TRAK 跟踪。
static int | TAG_TYP1 Adobe Type 1 字体数据。
static int | TAG_VDMX 垂直设备规格。
static int | TAG_VHEA 垂直规格头部。
static int | TAG_VMTX 垂直规格。
方法摘要
byte[] | getFontTable(int sfntTag) 返回作为指定标签字节数组的表。
byte[] | getFontTable(int sfntTag, int offset, int count) 返回作为指定标签字节数组的表的子集。
byte[] | getFontTable(String strSfntTag) 返回作为指定标签字节数组的表。
byte[] | getFontTable(String strSfntTag, int offset, int count) 返回作为指定标签字节数组的表的子集。
int | getFontTableSize(int sfntTag) 返回指定标签的表的大小。
int | getFontTableSize(String strSfntTag) 返回指定标签的表的大小。
int | getVersion() 返回 OpenType 字体的版本。

字段详细信息

TAG_CMAP

static final int TAG_CMAP
字形映射的字符。Open Type Specification 中的表标签 "cmap"。

另请参见：
常量字段值

TAG_HEAD

static final int TAG_HEAD
字体头部。Open Type Specification 中的表标签 "head"。

另请参见：
常量字段值

TAG_NAME

static final int TAG_NAME
命名表。Open Type Specification 中的表标签 "name"。

另请参见：
常量字段值

TAG_GLYF

static final int TAG_GLYF
字形数据。Open Type Specification 中的表标签 "glyf"。

另请参见：
常量字段值

TAG_MAXP

static final int TAG_MAXP
最大轮廓。Open Type Specification 中的表标签 "maxp"。

另请参见：
常量字段值

TAG_PREP

static final int TAG_PREP
CVT 预编程。Open Type Specification 中的表标签 "prep"。

另请参见：
常量字段值

TAG_HMTX

static final int TAG_HMTX
水平规格。Open Type Specification 中的表标签 "hmtx"。

另请参见：
常量字段值

TAG_KERN

static final int TAG_KERN
字距调整。Open Type Specification 中的表标签 "kern"。

另请参见：
常量字段值

TAG_HDMX

static final int TAG_HDMX
水平设备规格。Open Type Specification 中的表标签 "hdmx"。

另请参见：
常量字段值

TAG_LOCA

static final int TAG_LOCA
位置索引。Open Type Specification 中的表标签 "loca"。

另请参见：
常量字段值

TAG_POST

static final int TAG_POST
PostScript 信息。Open Type Specification 中的表标签 "post"。

另请参见：
常量字段值

TAG_OS2

static final int TAG_OS2
OS/2 和 Windows 特定规格。Open Type Specification 中的表标签 "OS/2"。

另请参见：
常量字段值

TAG_CVT

static final int TAG_CVT
控制值表。Open Type Specification 中的表标签 "cvt "。

另请参见：
常量字段值

TAG_GASP

static final int TAG_GASP
网格适应和扫描转换过程。Open Type Specification 中的表标签 "gasp"。

另请参见：
常量字段值

TAG_VDMX

static final int TAG_VDMX
垂直设备规格。Open Type Specification 中的表标签 "VDMX"。

另请参见：
常量字段值

TAG_VMTX

static final int TAG_VMTX
垂直规格。Open Type Specification 中的表标签 "vmtx"。

另请参见：
常量字段值

TAG_VHEA

static final int TAG_VHEA
垂直规格头部。Open Type Specification 中的表标签 "vhea"。

另请参见：
常量字段值

TAG_HHEA

static final int TAG_HHEA
水平规格头部。Open Type Specification 中的表标签 "hhea"。

另请参见：
常量字段值

TAG_TYP1

static final int TAG_TYP1
Adobe Type 1 字体数据。Open Type Specification 中的表标签 "typ1"。

另请参见：
常量字段值

TAG_BSLN

static final int TAG_BSLN
基线表。Open Type Specification 中的表标签 "bsln"。

另请参见：
常量字段值

TAG_GSUB

static final int TAG_GSUB
字形替换。Open Type Specification 中的表标签 "GSUB"。

另请参见：
常量字段值

TAG_DSIG

static final int TAG_DSIG
数字签名。Open Type Specification 中的表标签 "DSIG"。

另请参见：
常量字段值

TAG_FPGM

static final int TAG_FPGM
字体程序。Open Type Specification 中的表标签 "fpgm"。

另请参见：
常量字段值

TAG_FVAR

static final int TAG_FVAR
字体变体。Open Type Specification 中的表标签 "fvar"。

另请参见：
常量字段值

TAG_GVAR

static final int TAG_GVAR
字形变体。Open Type Specification 中的表标签 "gvar"。

另请参见：
常量字段值

TAG_CFF

static final int TAG_CFF
紧凑字体格式（Type1 字体）。Open Type Specification 中的表标签 "CFF "。

另请参见：
常量字段值

TAG_MMSD

static final int TAG_MMSD
Multiple master 增补数据。Open Type Specification 中的表标签 "MMSD"。

另请参见：
常量字段值

TAG_MMFX

static final int TAG_MMFX
Multiple Master 字体规格。Open Type Specification 中的表标签 "MMFX"。

另请参见：
常量字段值

TAG_BASE

static final int TAG_BASE
基线数据。Open Type Specification 中的表标签 "BASE"。

另请参见：
常量字段值

TAG_GDEF

static final int TAG_GDEF
字形定义。Open Type Specification 中的表标签 "GDEF"。

另请参见：
常量字段值

TAG_GPOS

static final int TAG_GPOS
字形定位。Open Type Specification 中的表标签 "GPOS"。

另请参见：
常量字段值

TAG_JSTF

static final int TAG_JSTF
调整。Open Type Specification 中的表标签 "JSTF"。

另请参见：
常量字段值

TAG_EBDT

static final int TAG_EBDT
内嵌位图数据。Open Type Specification 中的表标签 "EBDT"。

另请参见：
常量字段值

TAG_EBLC

static final int TAG_EBLC
内嵌位图位置。Open Type Specification 中的表标签 "EBLC"。

另请参见：
常量字段值

TAG_EBSC

static final int TAG_EBSC
内嵌位图缩放。Open Type Specification 中的表标签 "EBSC"。

另请参见：
常量字段值

TAG_LTSH

static final int TAG_LTSH
线性阈值。Open Type Specification 中的表标签 "LTSH"。

另请参见：
常量字段值

TAG_PCLT

static final int TAG_PCLT
PCL 5 数据。Open Type Specification 中的表标签 "PCLT"。

另请参见：
常量字段值

TAG_ACNT

static final int TAG_ACNT
重音符附件。Open Type Specification 中的表标签 "acnt"。

另请参见：
常量字段值

TAG_AVAR

static final int TAG_AVAR
轴变体。Open Type Specification 中的表标签 "avar"。

另请参见：
常量字段值

TAG_BDAT

static final int TAG_BDAT
位图数据。Open Type Specification 中的表标签 "bdat"。

另请参见：
常量字段值

TAG_BLOC

static final int TAG_BLOC
位图位置。Open Type Specification 中的表标签 "bloc"。

另请参见：
常量字段值

TAG_CVAR

static final int TAG_CVAR
CVT 变体。Open Type Specification 中的表标签 "cvar"。

另请参见：
常量字段值

TAG_FEAT

static final int TAG_FEAT
特性名称。Open Type Specification 中的表标签 "feat"。

另请参见：
常量字段值

TAG_FDSC

static final int TAG_FDSC
字体描述符。Open Type Specification 中的表标签 "fdsc"。

另请参见：
常量字段值

TAG_FMTX

static final int TAG_FMTX
字体规格。Open Type Specification 中的表标签 "fmtx"。

另请参见：
常量字段值

TAG_JUST

static final int TAG_JUST
调整。Open Type Specification 中的表标签 "just"。

另请参见：
常量字段值

TAG_LCAR

static final int TAG_LCAR
连字插入符。Open Type Specification 中的表标签 "lcar"。

另请参见：
常量字段值

TAG_MORT

static final int TAG_MORT
字形变化。Open Type Specification 中的表标签 "mort"。

另请参见：
常量字段值

TAG_OPBD

static final int TAG_OPBD
视觉边界。Open Type Specification 中的表标签 "opbd"。

另请参见：
常量字段值

TAG_PROP

static final int TAG_PROP
字形属性。Open Type Specification 中的表标签 "prop"。

另请参见：
常量字段值

TAG_TRAK

static final int TAG_TRAK
跟踪。Open Type Specification 中的表标签 "trak"。

另请参见：
常量字段值
方法详细信息

getVersion

int getVersion()
返回 OpenType 字体的版本。1.0 表示为 0x00010000。

返回：
OpenType 字体的版本。

getFontTable

byte[] getFontTable(int sfntTag)
返回作为指定标签字节数组的表。sfnt 表的标签包括诸如 cmap、name 和 head 之类的项。返回的 byte 数组是内存中字体数据的一个副本。

参数：
sfntTag - 作为 32 位整数的四字符代码
返回：
作为表的 byte 数组，该表包含与指定标签对应的字体数据。

getFontTable

byte[] getFontTable(String strSfntTag)
返回作为指定标签字节数组的表。sfnt 表的标签包括诸如 cmap、name 和 head 之类的项。返回的字节数组是内存中字体数据的一个副本。

参数：
strSfntTag - 作为 String 的四字符代码
返回：
作为表的 byte 数组，该表包含与指定标签对应的字体数据。

getFontTable

byte[] getFontTable(int sfntTag,
                    int offset,
                    int count)
返回作为指定标签字节数组的表的子集。sfnt 表的标签包括诸如 cmap、name 和 head 之类的项。返回的字节数组是内存中字体数据的一个副本。

参数：
sfntTag - 作为 32 位整数的四字符代码
offset - 要从表返回的第一个字节的索引
count - 要从表返回的字节数
返回：
表的子集，它对应于 sfntTag，并且包含以下字节：从 offset 字节开始并包括 count 字节。

getFontTable

byte[] getFontTable(String strSfntTag,
                    int offset,
                    int count)
返回作为指定标签字节数组的表的子集。sfnt 表的标签包括诸如 cmap、name 和 head 之类的项。返回的 byte 数组是内存中字体数据的一个副本。

参数：
strSfntTag - 作为 String 的四字符代码
offset - 要从表返回的第一个字节的索引
count - 要从表返回的字节数
返回：
表的子集，它对应于 strSfntTag，并且包含以下字节：从 offset 字节开始并包括 count 字节。

getFontTableSize

int getFontTableSize(int sfntTag)
返回指定标签的表的大小。sfnt 表的标签包括诸如 cmap、name 和 head 之类的项。

参数：
sfntTag - 作为 32 位整数的四字符代码
返回：
与指定标签对应的表的大小。

getFontTableSize

int getFontTableSize(String strSfntTag)
返回指定标签的表的大小。sfnt 表的标签包括诸如 cmap、name 和 head 之类的项。

参数：
strSfntTag - 作为 String 的四字符代码
返回：
与指定标签对应的表的大小。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShapeGraphicAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 ShapeGraphicAttribute

java.lang.Object
    继承者  java.awt.font.GraphicAttribute
        继承者  java.awt.font.ShapeGraphicAttribute

public final class ShapeGraphicAttribute
extends GraphicAttribute

ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。

另请参见：
GraphicAttribute

字段摘要
static boolean | FILL 指示应填充该形状的键。
static boolean | STROKE 指示该形状应使用 1 像素宽的笔画进行勾画的键。
从类 java.awt.font.GraphicAttribute 继承的字段
BOTTOM_ALIGNMENT, CENTER_BASELINE, HANGING_BASELINE, ROMAN_BASELINE, TOP_ALIGNMENT
构造方法摘要
ShapeGraphicAttribute(Shape shape, int alignment, boolean stroke)
针对指定 Shape 构造 ShapeGraphicAttribute。
方法摘要
void | draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
boolean | equals(Object rhs) 将此 ShapeGraphicAttribute 与指定的 Object 进行比较。
boolean | equals(ShapeGraphicAttribute rhs) 将此 ShapeGraphicAttribute 与指定的 ShapeGraphicAttribute 进行比较。
float | getAdvance() 返回此 ShapeGraphicAttribute 的 advance。
float | getAscent() 返回此 ShapeGraphicAttribute 的 ascent。
Rectangle2D | getBounds() 返回一个 Rectangle2D，它封装此 ShapeGraphicAttribute 相对于呈现位置绘制的所有位。
float | getDescent() 返回此 ShapeGraphicAttribute 的 descent。
Shape | getOutline(AffineTransform tx) 返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。
int | hashCode() 返回此 ShapeGraphicAttribute 的哈希码。
从类 java.awt.font.GraphicAttribute 继承的方法
getAlignment, getJustificationInfo
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STROKE

public static final boolean STROKE
指示该形状应使用 1 像素宽的笔画进行勾画的键。

另请参见：
常量字段值

FILL

public static final boolean FILL
指示应填充该形状的键。

另请参见：
常量字段值
构造方法详细信息

ShapeGraphicAttribute

public ShapeGraphicAttribute(Shape shape,
                             int alignment,
                             boolean stroke)
针对指定 Shape 构造 ShapeGraphicAttribute。

参数：
shape - 要呈现的 Shape。呈现此 Shape，其原点在宿主 TextLayout 中此 ShapeGraphicAttribute 的原点位置。此对象维护对 shape 的引用。
alignment - 此 ShapeGraphicAttribute 的对齐方式之一。
stroke - 如果要勾画 Shape，则为 true；如果要填充 Shape，则为 false。
方法详细信息

getAscent

public float getAscent()
返回此 ShapeGraphicAttribute 的 ascent。ShapeGraphicAttribute 的 ascent 是从其 Shape 的原点到其 Shape 边界顶端的绝对距离。

指定者：
类 GraphicAttribute 中的 getAscent
返回：
此 ShapeGraphicAttribute 的 ascent。
另请参见：
GraphicAttribute.getBounds()

getDescent

public float getDescent()
返回此 ShapeGraphicAttribute 的 descent。ShapeGraphicAttribute 的 descent 是从其 Shape 的原点到其 Shape 边界底部的距离。

指定者：
类 GraphicAttribute 中的 getDescent
返回：
此 ShapeGraphicAttribute 的 descent。
另请参见：
GraphicAttribute.getBounds()

getAdvance

public float getAdvance()
返回此 ShapeGraphicAttribute 的 advance。ShapeGraphicAttribute 的 advance 是从其 Shape 的原点到其 Shape 边界右侧的距离。

指定者：
类 GraphicAttribute 中的 getAdvance
返回：
此 ShapeGraphicAttribute 的 advance。
另请参见：
GraphicAttribute.getBounds()

draw

public void draw(Graphics2D graphics,
                 float x,
                 float y)
在指定的位置呈现此 GraphicAttribute。

指定者：
类 GraphicAttribute 中的 draw
参数：
graphics - 将该图形呈现到的 Graphics2D

getBounds

public Rectangle2D getBounds()
返回一个 Rectangle2D，它封装此 ShapeGraphicAttribute 相对于呈现位置绘制的所有位。图形可以呈现在其原点、ascent、descent 和 advance 之外；但如果这样做，此方法的实现应指示呈现该图形的位置。

覆盖：
类 GraphicAttribute 中的 getBounds
返回：
封装此 ShapeGraphicAttribute 呈现的所有位的 Rectangle2D。

getOutline

public Shape getOutline(AffineTransform tx)
返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。此方法在请求 TextLayout 返回文本轮廓时使用。该轮廓（未变换）不能扩展 getBounds 返回的矩形边界。

覆盖：
类 GraphicAttribute 中的 getOutline
参数：
tx - 将应用于此 ShapeGraphicAttribute 的可选 AffineTransform。该参数可以为 null。
返回：
表示此此图形属性的 Shape，适用于勾画或填充。
从以下版本开始：
1.6

hashCode

public int hashCode()
返回此 ShapeGraphicAttribute 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 ShapeGraphicAttribute 的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object rhs)
将此 ShapeGraphicAttribute 与指定的 Object 进行比较。

覆盖：
类 Object 中的 equals
参数：
rhs - 比较相等性的 Object
返回：
如果此 ShapeGraphicAttribute 等于 rhs，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

equals

public boolean equals(ShapeGraphicAttribute rhs)
将此 ShapeGraphicAttribute 与指定的 ShapeGraphicAttribute 进行比较。

参数：
rhs - 要比较相等性的 ShapeGraphicAttribute
返回：
如果此 ShapeGraphicAttribute 等于 rhs，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 TextAttribute

java.lang.Object
    继承者  java.text.AttributedCharacterIterator.Attribute
        继承者  java.awt.font.TextAttribute
所有已实现的接口：
Serializable
public final class TextAttribute
extends AttributedCharacterIterator.Attribute

TextAttribute 类定义用于呈现文本的属性键和属性值。

TextAttribute 实例被用作属性键，标识 Font、TextLayout、AttributedCharacterIterator 和其他处理文本属性的类中的属性。此类中定义的其他常量可以用作属性值。

对于每个文本属性，文档提供了：

  • 其值的类型，
  • 相关预定义常量（如果有）
  • 属性不存在时的默认效果
  • 有限制时的有效值
  • 效果的描述。

值

  • 属性值必须始终是不可变的。
  • 在给出值限制的情况下，限制集合以外的任何值都是为将来使用保留的，该值将被视为默认值。
  • null 值将被视为默认值并导致默认行为。
  • 如果值的类型不正确，则忽略该属性。
  • 值的标识无关紧要，只要是实际值即可。例如，TextAttribute.WEIGHT_BOLD 和 new Float(2.0) 指示相同的 WEIGHT。
  • Number 类型的属性值（用于 WEIGHT、WIDTH、POSTURE、SIZE、JUSTIFICATION 和 TRACKING）随其自然范围的变化而变化，且不受预定义常量的限制。Number.floatValue() 用于从 Number 中获取实际值。
  • WEIGHT、WIDTH 和 POSTURE 的值由系统插入，系统可以选择“最适用的”字体或者其他技巧来大致满足用户请求。

属性摘要

键 | 值类型 | 主要常量 | 默认值
FAMILY | String | 请参阅 Font DIALOG、DIALOG_INPUT、 SERIF、SANS_SERIF 和 MONOSPACED。 | "Default"（使用平台默认值）
WEIGHT | Number | WEIGHT_REGULAR、WEIGHT_BOLD | WEIGHT_REGULAR
WIDTH | Number | WIDTH_CONDENSED、WIDTH_REGULAR 、 WIDTH_EXTENDED | WIDTH_REGULAR
POSTURE | Number | POSTURE_REGULAR、POSTURE_OBLIQUE | POSTURE_REGULAR
SIZE | Number | 无 | 12.0
TRANSFORM | TransformAttribute | 请参阅 TransformAttribute IDENTITY | TransformAttribute.IDENTITY
SUPERSCRIPT | Integer | SUPERSCRIPT_SUPER、SUPERSCRIPT_SUB | 0（使用标准字形和规格）
FONT | Font | 无 | null（不重写字体分辨率）
CHAR_REPLACEMENT | GraphicAttribute | 无 | null（使用字体字形绘制文本）
FOREGROUND | Paint | 无 | null（使用当前图形绘制）
BACKGROUND | Paint | 无 | null（不呈现背景）
UNDERLINE | Integer | UNDERLINE_ON | -1（不呈现下划线）
STRIKETHROUGH | Boolean | STRIKETHROUGH_ON | false（不呈现删除线）
RUN_DIRECTION | Boolean | RUN_DIRECTION_LTR、 RUN_DIRECTION_RTL | null（使用 Bidi 标准默认值）
BIDI_EMBEDDING | Integer | 无 | 0（使用基线方向）
JUSTIFICATION | Number | JUSTIFICATION_FULL | JUSTIFICATION_FULL
INPUT_METHOD_HIGHLIGHT | InputMethodHighlight 和 Annotation | （参见类） | null（不应用输入高亮显示）
INPUT_METHOD_UNDERLINE | Integer | UNDERLINE_LOW_ONE_PIXEL、 UNDERLINE_LOW_TWO_PIXEL | -1（不呈现下划线）
SWAP_COLORS | Boolean | SWAP_COLORS_ON | false（不交换颜色）
NUMERIC_SHAPING | NumericShaper | 无 | null（不对数字进行定形）
KERNING | Integer | KERNING_ON | 0（不要求进行字距调整）
LIGATURES | Integer | LIGATURES_ON | 0（不形成可选的连字）
TRACKING | Number | TRACKING_LOOSE、TRACKING_TIGHT | 0（不添加跟踪）

另请参见：
Font, TextLayout, AttributedCharacterIterator, 序列化表格

字段摘要
static TextAttribute | BACKGROUND 用于呈现文本背景的 paint 的属性键。
static TextAttribute | BIDI_EMBEDDING 文本嵌入级别的属性键。
static TextAttribute | CHAR_REPLACEMENT 用于取代字符的字体标准字型显示的用户定义字形的属性键。
static TextAttribute | FAMILY 字体名称的属性键。
static TextAttribute | FONT 用于提供呈现文本字体的属性键。
static TextAttribute | FOREGROUND 用于呈现文本的 paint 的属性键。
static TextAttribute | INPUT_METHOD_HIGHLIGHT 用于输入法高亮显示样式的属性键。
static TextAttribute | INPUT_METHOD_UNDERLINE 输入法下划线的属性键。
static TextAttribute | JUSTIFICATION 段落调整的属性键。
static Float | JUSTIFICATION_FULL 将线条调整到完整的请求宽度。
static Float | JUSTIFICATION_NONE 不允许调整线条。
static TextAttribute | KERNING 请求进行字距调整的属性键。
static Integer | KERNING_ON 请求标准字距调整。
static TextAttribute | LIGATURES 启用可选连字的属性键。
static Integer | LIGATURES_ON 请求标准可选连字。
static TextAttribute | NUMERIC_SHAPING 将 ASCII 十进制数字转换为其他十进制范围数字的属性键。
static TextAttribute | POSTURE 字体形态的属性键。
static Float | POSTURE_OBLIQUE 标准斜体形态。
static Float | POSTURE_REGULAR 标准直立形态。
static TextAttribute | RUN_DIRECTION 线条延伸方向的属性键。
static Boolean | RUN_DIRECTION_LTR 从左到右的延伸方向。
static Boolean | RUN_DIRECTION_RTL 从右到左的延伸方向。
static TextAttribute | SIZE 字体大小的属性键。
static TextAttribute | STRIKETHROUGH 删除线的属性键。
static Boolean | STRIKETHROUGH_ON 单删除线。
static TextAttribute | SUPERSCRIPT 用于上标和下标的属性键。
static Integer | SUPERSCRIPT_SUB 标准下标。
static Integer | SUPERSCRIPT_SUPER 标准上标。
static TextAttribute | SWAP_COLORS 交换前景和背景 Paint 的属性键。
static Boolean | SWAP_COLORS_ON 交换前景和背景。
static TextAttribute | TRACKING 控制跟踪的属性键。
static Float | TRACKING_LOOSE 执行宽松跟踪。
static Float | TRACKING_TIGHT 执行紧密跟踪。
static TextAttribute | TRANSFORM 字体转换的属性键。
static TextAttribute | UNDERLINE 下划线的属性键。
static Integer | UNDERLINE_LOW_DASHED 单像素虚线低下划线。
static Integer | UNDERLINE_LOW_DOTTED 单像素点线式低下划线。
static Integer | UNDERLINE_LOW_GRAY 双像素灰色低下划线。
static Integer | UNDERLINE_LOW_ONE_PIXEL 单像素实心低下划线。
static Integer | UNDERLINE_LOW_TWO_PIXEL 双像素实心低下划线。
static Integer | UNDERLINE_ON 标准下划线。
static TextAttribute | WEIGHT 字体 weight 的属性键。
static Float | WEIGHT_BOLD 标准的粗体 weight。
static Float | WEIGHT_DEMIBOLD 比 WEIGHT_BOLD 稍轻的 weight。
static Float | WEIGHT_DEMILIGHT WEIGHT_LIGHT 和 WEIGHT_STANDARD 之间的中间 weight。
static Float | WEIGHT_EXTRA_LIGHT 最轻的预定义 weight。
static Float | WEIGHT_EXTRABOLD 特别重的 weight。
static Float | WEIGHT_HEAVY 比 WEIGHT_BOLD 稍重的 weight。
static Float | WEIGHT_LIGHT 标准的轻 weight。
static Float | WEIGHT_MEDIUM WEIGHT_REGULAR 和 WEIGHT_BOLD 之间的中间 weight。
static Float | WEIGHT_REGULAR 标准 weight。
static Float | WEIGHT_SEMIBOLD 比 WEIGHT_REGULAR 稍重的 weight。
static Float | WEIGHT_ULTRABOLD 最重的预定义 weight。
static TextAttribute | WIDTH 字体宽度的属性键。
static Float | WIDTH_CONDENSED 最精简的预定义 width。
static Float | WIDTH_EXTENDED 最大扩展的预定义 width。
static Float | WIDTH_REGULAR 标准 width。
static Float | WIDTH_SEMI_CONDENSED 适度精简的 width。
static Float | WIDTH_SEMI_EXTENDED 适度扩展的 width。
从类 java.text.AttributedCharacterIterator.Attribute 继承的字段
INPUT_METHOD_SEGMENT, LANGUAGE, READING
构造方法摘要
protected TextAttribute(String name)
构造一个具有指定名称的 TextAttribute。
方法摘要
protected  Object readResolve()
将反序列化的实例解析为预定义常量。
从类 java.text.AttributedCharacterIterator.Attribute 继承的方法
equals, getName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

FAMILY

public static final TextAttribute FAMILY
字体名称的属性键。这些值是 String 的实例。默认值是 "Default"，该值导致使用平台默认字体系列。

Font 类定义用于逻辑字体名称 DIALOG、DIALOG_INPUT、SANS_SERIF、SERIF 和 MONOSPACED 的常量。

这定义了作为 name 传递给 Font 构造方法的值。逻辑字体名称和实际字体名称都允许使用。如果没有发现具有所请求名称的字体，则使用默认字体。

注：此属性不幸被错误命名，因为它指定了外观名称，而不只是系列名称。因此，“Lucida Sans Bold”之类的值会选择该外观（如果存在）。注意，如果请求的外观不存在，则默认字体可以与常规 weight 一起使用。该名称中的“Bold”是外观名称的一部分，而不是字体 weight 为粗体的单独请求。

WEIGHT

public static final TextAttribute WEIGHT
字体 weight 的属性键。这些值是 Number 的实例。默认值为 WEIGHT_REGULAR。

这里提供了一些常量值，请参阅 WEIGHT_EXTRA_LIGHT、WEIGHT_LIGHT、WEIGHT_DEMILIGHT、WEIGHT_REGULAR、WEIGHT_SEMIBOLD、WEIGHT_MEDIUM、WEIGHT_DEMIBOLD、WEIGHT_BOLD、WEIGHT_HEAVY、WEIGHT_EXTRABOLD 和 WEIGHT_ULTRABOLD。WEIGHT_BOLD 值对应于传递给 Font 构造方法的样式值 Font.BOLD。

该值大致为词干宽度与常规 weight 的比。

系统可以插入提供的值。

WEIGHT_EXTRA_LIGHT

public static final Float WEIGHT_EXTRA_LIGHT
最轻的预定义 weight。

另请参见：
WEIGHT

WEIGHT_LIGHT

public static final Float WEIGHT_LIGHT
标准的轻 weight。

另请参见：
WEIGHT

WEIGHT_DEMILIGHT

public static final Float WEIGHT_DEMILIGHT
WEIGHT_LIGHT 和 WEIGHT_STANDARD 之间的中间 weight。

另请参见：
WEIGHT

WEIGHT_REGULAR

public static final Float WEIGHT_REGULAR
标准 weight。这是 WEIGHT 的默认值。

另请参见：
WEIGHT

WEIGHT_SEMIBOLD

public static final Float WEIGHT_SEMIBOLD
比 WEIGHT_REGULAR 稍重的 weight。

另请参见：
WEIGHT

WEIGHT_MEDIUM

public static final Float WEIGHT_MEDIUM
WEIGHT_REGULAR 和 WEIGHT_BOLD 之间的中间 weight。

另请参见：
WEIGHT

WEIGHT_DEMIBOLD

public static final Float WEIGHT_DEMIBOLD
比 WEIGHT_BOLD 稍轻的 weight。

另请参见：
WEIGHT

WEIGHT_BOLD

public static final Float WEIGHT_BOLD
标准的粗体 weight。

另请参见：
WEIGHT

WEIGHT_HEAVY

public static final Float WEIGHT_HEAVY
比 WEIGHT_BOLD 稍重的 weight。

另请参见：
WEIGHT

WEIGHT_EXTRABOLD

public static final Float WEIGHT_EXTRABOLD
特别重的 weight。

另请参见：
WEIGHT

WEIGHT_ULTRABOLD

public static final Float WEIGHT_ULTRABOLD
最重的预定义 weight。

另请参见：
WEIGHT

WIDTH

public static final TextAttribute WIDTH
字体宽度的属性键。这些值是 Number 的实例。默认值为 WIDTH_REGULAR。

这里提供了一些常量值，请参阅 WIDTH_CONDENSED、WIDTH_SEMI_CONDENSED、WIDTH_REGULAR、WIDTH_SEMI_EXTENDED 和 WIDTH_EXTENDED。

该值大致为 advance 宽度与常规宽度的比。

系统可以插入提供的值。

WIDTH_CONDENSED

public static final Float WIDTH_CONDENSED
最精简的预定义 width。

另请参见：
WIDTH

WIDTH_SEMI_CONDENSED

public static final Float WIDTH_SEMI_CONDENSED
适度精简的 width。

另请参见：
WIDTH

WIDTH_REGULAR

public static final Float WIDTH_REGULAR
标准 width。这是 WIDTH 的默认值。

另请参见：
WIDTH

WIDTH_SEMI_EXTENDED

public static final Float WIDTH_SEMI_EXTENDED
适度扩展的 width。

另请参见：
WIDTH

WIDTH_EXTENDED

public static final Float WIDTH_EXTENDED
最大扩展的预定义 width。

另请参见：
WIDTH

POSTURE

public static final TextAttribute POSTURE
字体形态的属性键。这些值是 Number 的实例。默认值为 POSTURE_REGULAR。

这里提供了两个常量值 POSTURE_REGULAR 和 POSTURE_OBLIQUE。POSTURE_OBLIQUE 值对应于传递给 Font 构造方法的样式值 Font.ITALIC。

该值粗略地表示了字体词干的倾斜度，它以邻边除以对边的形式表示。正值表示向右倾斜。

系统可以插入提供的值。

这将会影响字体的倾斜角度，该角度由 Font.getItalicAngle 返回。

另请参见：
Font.getItalicAngle()

POSTURE_REGULAR

public static final Float POSTURE_REGULAR
标准直立形态。这是 POSTURE 的默认值。

另请参见：
POSTURE

POSTURE_OBLIQUE

public static final Float POSTURE_OBLIQUE
标准斜体形态。

另请参见：
POSTURE

SIZE

public static final TextAttribute SIZE
字体大小的属性键。这些值是 Number 的实例。默认值为 12pt。

这对应于 Font 构造方法的 size 参数。

非常大或非常小的大小将影响呈现性能，呈现系统可能不会以这些大小呈现文本。负大小是非法的，会导致使用默认尺寸。

注意，采用 2x 转换的 12pt 字体的外观和规格可能与未转换的 24pt 字体不同。

TRANSFORM

public static final TextAttribute TRANSFORM
字体转换的属性键。这些值是 TransformAttribute 的实例。默认值为 TransformAttribute.IDENTITY。

TransformAttribute 类定义了常量 IDENTITY。

这对应于传递给 Font.deriveFont(AffineTransform) 的转换。由于该转换是可变的，并且 TextAttribute 值不可以为 null，所以使用的是 TransformAttribute 包装器类。

该值主要用于支持缩放和倾斜，但可能还有其他作用。

某些转换会导致基线旋转和/或移位。将文本和基线一起转换，从而文本将遵循新的基线。例如，对于水平基线上的文本，新的基线将遵循通过转换得到的 x 向量单元的方向。文本规格是针对此新基线进行测量的。因此，如果其他属性相同，使用旋转的 TRANSFORM 和非旋转的 TRANSFORM 呈现的文本都将视为具有相同上行高度 (ascent)、下行高度 (descent) 和步进 (advance)。

在样式化文本中，每个这样延伸的基线都将一个接一个地排列，从而可能为整个文本延伸创建一条非线性的基线。有关更多信息，请参阅 TextLayout.getLayoutPath()。

另请参见：
TransformAttribute, AffineTransform

SUPERSCRIPT

public static final TextAttribute SUPERSCRIPT
用于上标和下标的属性键。这些值是 Integer 的实例。默认值为 0，意味着没有使用上标或下标。

这里提供了两个常量值，请参阅 SUPERSCRIPT_SUPER 和 SUPERSCRIPT_SUB。这两个常量的值分别为 1 和 -1。较大的大小值定义上标或下标的较高级别，例如，2 对应于 super-superscript，3 对应于 super-super-superscript，同样地，对于负值和下标，级别可以高达 7（或 -7）。超出此范围的值被保留；这些值代表的行为与平台有关。

SUPERSCRIPT 会影响字体的 ascent 和 descent。但是，ascent 和 descent 始终不能为负。

SUPERSCRIPT_SUPER

public static final Integer SUPERSCRIPT_SUPER
标准上标。

另请参见：
SUPERSCRIPT

SUPERSCRIPT_SUB

public static final Integer SUPERSCRIPT_SUB
标准下标。

另请参见：
SUPERSCRIPT

FONT

public static final TextAttribute FONT
用于提供呈现文本字体的属性键。这些值是 Font 的实例。默认值为 null，指示应该根据属性执行 Font 的正常分辨率。

TextLayout 和 AttributedCharacterIterator 根据 TextAttribute 的 Map 进行工作。通常，所有属性都被检查，并被用于选择和配置 Font 实例。然而，如果存在 FONT 属性，将使用其关联 Font。这为用户提供了一种将字体的分辨率属性重写到 Font，或强制使用特定 Font 实例的方法。这还允许用户在可以子类化 Font 的情况下指定 Font 的子类。

FONT 适用于特殊情形，在这些情形下，客户端已经拥有 Font 实例但是仍然需要使用基于 Map 的 API。通常，Map 中除了 FONT 属性以外没有其他属性。对于基于 Map 的 API，常见情形是单独指定所有属性，因此无需 FONT。

但是，如果 FONT 和其他属性都存在于 Map 中，那么呈现系统会将 Font 中定义的属性与附加属性合并。此合并过程将 TextAttributes 分为两组。一组（“主要”组）被认为是字体的选择和规格行为的基础。这些属性有 FAMILY、WEIGHT、WIDTH、POSTURE、SIZE、TRANSFORM、SUPERSCRIPT 和 TRACKING。另一组（“次要”组）由除了 FONT 自身以外的所有其他已定义属性组成。

要生成新的 Map，首先需要从 FONT 属性获得 Font，并将它的所有 属性提取为一个新的 Map。然后，只将取自原始 Map 的次要 属性添加到新 Map 的属性中。因此，主要属性的值仅取自 Font，而次要属性的值源自 Font，但可以用 Map 中的其他值重写它们。

注：Font 的基于 Map 的构造方法和 deriveFont 方法不处理 FONT 属性，因为这些属性用于创建新的 Font 对象。相反，Font.getFont(Map) 应该用于处理 FONT 属性。

另请参见：
Font

CHAR_REPLACEMENT

public static final TextAttribute CHAR_REPLACEMENT
用于取代字符的字体标准字型显示的用户定义字形的属性键。这些值是 GraphicAttribute 的实例。默认值为 null，指示应该使用字体提供的标准字形。

此属性用于为图形或文本行中嵌入的其他组件保留空间。在执行双向重排序（请参阅 Bidi）时，它对于正确排列“内联”组件在某一行中的位置是必需的。每个字符（Unicode 代码点）都将使用提供的 GraphicAttribute 呈现。通常，应用此属性的字符应是 \uFFFC。

GraphicAttribute 确定文本的逻辑边界和可视边界；实际 Font 值被忽略。

另请参见：
GraphicAttribute

FOREGROUND

public static final TextAttribute FOREGROUND
用于呈现文本的 paint 的属性键。这些值是 Paint 的实例。默认值为 null，指示使用呈现时在 Graphics2D 上设置的 Paint。

无论 Graphics 上设置的 Paint 值是什么，字形都将使用此 Paint 呈现（但是请参阅 SWAP_COLORS）。

另请参见：
Paint, SWAP_COLORS

BACKGROUND

public static final TextAttribute BACKGROUND
用于呈现文本背景的 paint 的属性键。这些值是 Paint 的实例。默认值为 null，指示不应呈现背景。

文本的逻辑边界将使用此 Paint 填充，然后该文本呈现于 Paint 之上（但是请参阅 SWAP_COLORS）。

如果有必要，可以扩展文本的可视边界来包含逻辑边界。轮廓不会受影响。

另请参见：
Paint, SWAP_COLORS

UNDERLINE

public static final TextAttribute UNDERLINE
下划线的属性键。这些值是 Integer 的实例。默认值为 -1，表示没有下划线。

提供的常量值是 UNDERLINE_ON。

下划线可影响可视边界和文本轮廓。

UNDERLINE_ON

public static final Integer UNDERLINE_ON
标准下划线。

另请参见：
UNDERLINE

STRIKETHROUGH

public static final TextAttribute STRIKETHROUGH
删除线的属性键。这些值是 Boolean 的实例。默认值为 false，表示没有删除线。

提供的常量值是 STRIKETHROUGH_ON。

删除线可影响可视边界和文本轮廓。

STRIKETHROUGH_ON

public static final Boolean STRIKETHROUGH_ON
单删除线。

另请参见：
STRIKETHROUGH

RUN_DIRECTION

public static final TextAttribute RUN_DIRECTION
线条延伸方向的属性键。这些值是 Boolean 的实例。默认值为 null，指示用来确定延伸方向的标准 Bidi 算法应该与 Bidi.DIRECTION_DEFAULT_LEFT_TO_RIGHT 值一起使用。

提供的常量是 RUN_DIRECTION_RTL 和 RUN_DIRECTION_LTR。

这确定了传递给 Bidi 构造方法的值，以选择段落中文本的主方向。

注：对于段落中的所有文本，此属性都应该具有相同的值，否则，行为将是不确定的。

另请参见：
Bidi

RUN_DIRECTION_LTR

public static final Boolean RUN_DIRECTION_LTR
从左到右的延伸方向。

另请参见：
RUN_DIRECTION

RUN_DIRECTION_RTL

public static final Boolean RUN_DIRECTION_RTL
从右到左的延伸方向。

另请参见：
RUN_DIRECTION

BIDI_EMBEDDING

public static final TextAttribute BIDI_EMBEDDING
文本嵌入级别的属性键。这些值是 Integer 的实例。默认值为 null，指示在没有显式嵌入的情况下应该使用双向算法。

1 到 61 的正值是嵌入 级别，-1 到 -61 的负值是重写 级别。0 值表示使用基线方向。这些级别被传入 Bidi 构造方法的嵌入级别数组。

注：如果此属性出现在段落中的任何位置，则该段落中的所有 Unicode bidi 控制字符（RLO、LRO、RLE、LRE 和 PDF）都将被忽略，没有此属性的情况下，文本延伸时假定此属性存在，并且属性值为 0。

另请参见：
Bidi

JUSTIFICATION

public static final TextAttribute JUSTIFICATION
段落调整的属性键。这些值是 Number 的实例。默认值为 1，指示调整时应该使用所提供的完整宽度。这些值被限制在 [0..1] 范围内。

提供的常量是 JUSTIFICATION_FULL 和 JUSTIFICATION_NONE。

当请求在 TextLayout 上进行调整时，指定要使用的额外空间部分。例如，如果该线条宽为 50 磅，要求调整到 70 磅，则值 0.75 会使用多余空间的四分之三（或 15 磅）来填补，这样得到的线条长度为 65 磅。

注：对于段落中的所有文本，此属性都应该具有相同的值，否则，行为将是不确定的。

另请参见：
TextLayout.getJustifiedLayout(float)

JUSTIFICATION_FULL

public static final Float JUSTIFICATION_FULL
将线条调整到完整的请求宽度。这是 JUSTIFICATION 的默认值。

另请参见：
JUSTIFICATION

JUSTIFICATION_NONE

public static final Float JUSTIFICATION_NONE
不允许调整线条。

另请参见：
JUSTIFICATION

INPUT_METHOD_HIGHLIGHT

public static final TextAttribute INPUT_METHOD_HIGHLIGHT
用于输入法高亮显示样式的属性键。

这些值是 InputMethodHighlight 或 Annotation 的实例。默认值为 null，指示在呈现前不应该应用输入法样式。

如果需要单独呈现具有相同 InputMethodHighlight 的文本邻近延伸，则应在 Annotation 实例中包装 InputMethodHighlight。

在使用输入法撰写文本时，将使用输入法高亮显示。即使是通常只处理无样式文本的文本编辑组件，也应保留输入法高亮显示，并使它们可用于绘制例程。

另请参见：
Font, InputMethodHighlight, Annotation

INPUT_METHOD_UNDERLINE

public static final TextAttribute INPUT_METHOD_UNDERLINE
输入法下划线的属性键。这些值是 Integer 的实例。默认值为 -1，表示没有下划线。

这里提供了一些常量值，请参阅 UNDERLINE_LOW_ONE_PIXEL、UNDERLINE_LOW_TWO_PIXEL、UNDERLINE_LOW_DOTTED、UNDERLINE_LOW_GRAY 和 UNDERLINE_LOW_DASHED。

如果需要，此值可以与 UNDERLINE 一起使用。该值主要用于输入法。在其他地方使用这些简单装饰下划线可能会使用户迷惑。

输入法下划线可影响可视边界和文本轮廓。

从以下版本开始：
1.3

UNDERLINE_LOW_ONE_PIXEL

public static final Integer UNDERLINE_LOW_ONE_PIXEL
单像素实心低下划线。

从以下版本开始：
1.3
另请参见：
INPUT_METHOD_UNDERLINE

UNDERLINE_LOW_TWO_PIXEL

public static final Integer UNDERLINE_LOW_TWO_PIXEL
双像素实心低下划线。

从以下版本开始：
1.3
另请参见：
INPUT_METHOD_UNDERLINE

UNDERLINE_LOW_DOTTED

public static final Integer UNDERLINE_LOW_DOTTED
单像素点线式低下划线。

从以下版本开始：
1.3
另请参见：
INPUT_METHOD_UNDERLINE

UNDERLINE_LOW_GRAY

public static final Integer UNDERLINE_LOW_GRAY
双像素灰色低下划线。

从以下版本开始：
1.3
另请参见：
INPUT_METHOD_UNDERLINE

UNDERLINE_LOW_DASHED

public static final Integer UNDERLINE_LOW_DASHED
单像素虚线低下划线。

从以下版本开始：
1.3
另请参见：
INPUT_METHOD_UNDERLINE

SWAP_COLORS

public static final TextAttribute SWAP_COLORS
交换前景和背景 Paint 的属性键。这些值是 Boolean 的实例。默认值为 false，表示不交换颜色。

定义的常量值是 SWAP_COLORS_ON。

如果设置 FOREGROUND 属性，则它的 Paint 将被用作背景，否则，将使用当前 Graphics 上的 Paint。如果设置 BACKGROUND 属性，则它的 Paint 将被用作前景，否则，系统将给（已解析）背景找到一种对比色，使文本可见。

另请参见：
FOREGROUND, BACKGROUND

SWAP_COLORS_ON

public static final Boolean SWAP_COLORS_ON
交换前景和背景。

从以下版本开始：
1.3
另请参见：
SWAP_COLORS

NUMERIC_SHAPING

public static final TextAttribute NUMERIC_SHAPING
将 ASCII 十进制数字转换为其他十进制范围数字的属性键。这些值是 NumericShaper 的实例。默认值为 null，表示不执行数字成形。

当定义了一个数字成形器时，在执行其他任何文本分析之前，首先用成形器处理该文本。

注：对于段落中的所有文本，此属性都应该具有相同的值，否则行为将是不确定的。

从以下版本开始：
1.4
另请参见：
NumericShaper

KERNING

public static final TextAttribute KERNING
请求进行字距调整的属性键。这些值是 Integer 的实例。默认值为 0，表示不请求进行字距调整。

提供的常量值是 KERNING_ON。

单个字符的默认 advance 不适合某些字符序列，例如，“To”或“AWAY”。若没有进行字距调整，那么相邻字符看起来好像使用了太多的空格来分隔。字距调整使选定的字符序列采用不同的空格来分隔，以获得更舒适的可视外观。

从以下版本开始：
1.6

KERNING_ON

public static final Integer KERNING_ON
请求标准字距调整。

从以下版本开始：
1.6
另请参见：
KERNING

LIGATURES

public static final TextAttribute LIGATURES
启用可选连字的属性键。这些值是 Integer 的实例。默认值为 0，表示不使用可选的连字。

定义的常量值是 LIGATURES_ON。

始终启用书写系统所需的连字。

从以下版本开始：
1.6

LIGATURES_ON

public static final Integer LIGATURES_ON
请求标准可选连字。

从以下版本开始：
1.6
另请参见：
LIGATURES

TRACKING

public static final TextAttribute TRACKING
控制跟踪的属性键。这些值是 Number 的实例。默认值为 0，表示没有附加的跟踪。

提供的常量值是 TRACKING_TIGHT 和 TRACKING_LOOSE。

跟踪值与字体磅值大小相乘，并通过字体转换传递，以确定要添加到每种字形群的 advance 的附加量。正跟踪值将禁止可选连字格式。跟踪值通常在 -0.1 与 0.3 之间，超出此范围的值通常是不需要的。

从以下版本开始：
1.6

TRACKING_TIGHT

public static final Float TRACKING_TIGHT
执行紧密跟踪。

从以下版本开始：
1.6
另请参见：
TRACKING

TRACKING_LOOSE

public static final Float TRACKING_LOOSE
执行宽松跟踪。

从以下版本开始：
1.6
另请参见：
TRACKING
构造方法详细信息

TextAttribute

protected TextAttribute(String name)
构造一个具有指定名称的 TextAttribute。

参数：
name - 分配给此 TextAttribute 的属性名
方法详细信息

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将反序列化的实例解析为预定义常量。

覆盖：
类 AttributedCharacterIterator.Attribute 中的 readResolve
抛出：
InvalidObjectException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextHitInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 TextHitInfo

java.lang.Object
    继承者  java.awt.font.TextHitInfo

public final class TextHitInfo
extends Object

TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。斜线是开始边（对于从左到右的字符为左边缘）或者结尾边（对于从左到右的字符为右边缘）。TextHitInfo 的实例用于指定插入符和在文本中的插入位置。

例如，可以考虑一下文本 "abc"。TextHitInfo.trailing(1) 对应于文本中 'b' 的右边。

TextHitInfo 主要由 TextLayout 和 TextLayout 的客户端使用。TextLayout 的客户端查询 TextHitInfo 实例，以获得插入偏移量，新文本在此处插入到文本模型中。插入偏移量等于 TextHitInfo 中的字符位置（如果斜线为开始边），或者在某个字符之后（如果斜线为结尾边）。TextHitInfo.trailing(1) 的插入偏移量为 2。

有时，构造一个具有与现有 TextHitInfo 相同的插入偏移量的 TextHitInfo 很方便，不过要在相对的字符上。getOtherHit 方法构造一个具有与现有 TextHitInfo 相同的插入偏移量的新 TextHitInfo，目标字符在插入偏移量的另一侧。在 trailing(1) 上调用 getOtherHit 将返回 leading(2)。一般来说，trailing(n) 的 getOtherHit 返回 leading(n+1)，leading(n) 的 getOtherHit 返回 trailing(n-1)。

示例：

将图形点转换为文本模型中的插入点

 TextLayout layout = ...;
 Point2D.Float hitPoint = ...;
 TextHitInfo hitInfo = layout.hitTestChar(hitPoint.x, hitPoint.y);
 int insPoint = hitInfo.getInsertionIndex();
 // insPoint is relative to layout;  may need to adjust for use
 // in a text model

另请参见：
TextLayout

方法摘要
static TextHitInfo | afterOffset(int offset) 在指定偏移量处创建一个与偏移量之后的字符关联的 TextHitInfo。
static TextHitInfo | beforeOffset(int offset) 在指定偏移量处创建一个与偏移量之前的字符关联的 TextHitInfo。
boolean | equals(Object obj) 如果指定的 Object 是一个 TextHitInfo 并且等于此 TextHitInfo，则返回 true。
boolean | equals(TextHitInfo hitInfo) 如果指定的 TextHitInfo 具有与此 TextHitInfo 相同的 charIndex 和 isLeadingEdge，则返回 true。
int | getCharIndex() 返回目标字符的索引。
int | getInsertionIndex() 返回插入索引。
TextHitInfo | getOffsetHit(int delta) 创建一个 TextHitInfo，其字符索引从此 TextHitInfo 的 charIndex 偏移 delta。
TextHitInfo | getOtherHit() 在插入点的另一侧创建一个 TextHitInfo。
int | hashCode() 返回哈希码。
boolean | isLeadingEdge() 如果字符的开始边是插入点，则返回 true。
static TextHitInfo | leading(int charIndex) 在指定 charIndex 处的字符开始边上创建一个 TextHitInfo。
String | toString() 返回表示此 TextHitInfo 的 String，只用于调试目的。
static TextHitInfo | trailing(int charIndex) 在指定 charIndex 处的字符的结尾边上创建一个 TextHitInfo。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getCharIndex

public int getCharIndex()
返回目标字符的索引。

返回：
目标字符的索引。

isLeadingEdge

public boolean isLeadingEdge()
如果字符的开始边是插入点，则返回 true。

返回：
如果字符的开始边是插入点，则返回 true；否则返回 false。

getInsertionIndex

public int getInsertionIndex()
返回插入索引。如果字符的开始边是插入点，则插入索引为字符索引，如果字符的结尾边是插入点，则插入索引比字符索引大 1。

返回：
插入索引。

hashCode

public int hashCode()
返回哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 TextHitInfo 的哈希码，也是此 TextHitInfo 的 charIndex。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
如果指定的 Object 是一个 TextHitInfo 并且等于此 TextHitInfo，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 测试相等性的 Object
返回：
如果指定的 Object 等于此 TextHitInfo，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

equals

public boolean equals(TextHitInfo hitInfo)
如果指定的 TextHitInfo 具有与此 TextHitInfo 相同的 charIndex 和 isLeadingEdge，则返回 true。这与具有相同插入偏移量不同。

参数：
hitInfo - 一个指定的 TextHitInfo
返回：
如果指定的 TextHitInfo 具有与此 TextHitInfo 相同的 charIndex 和 isLeadingEdge，则返回 true。

toString

public String toString()
返回表示此 TextHitInfo 的 String，只用于调试目的。

覆盖：
类 Object 中的 toString
返回：
表示此 TextHitInfo 的 String。

leading

public static TextHitInfo leading(int charIndex)
在指定 charIndex 处的字符开始边上创建一个 TextHitInfo。

参数：
charIndex - 目标字符的索引
返回：
在指定 charIndex 处字符的开始边上的 TextHitInfo。

trailing

public static TextHitInfo trailing(int charIndex)
在指定 charIndex 处的字符的结尾边上创建一个 TextHitInfo。

参数：
charIndex - 目标字符的索引
返回：
在指定 charIndex 处的字符的结尾边上的 TextHitInfo。

beforeOffset

public static TextHitInfo beforeOffset(int offset)
在指定偏移量处创建一个与偏移量之前的字符关联的 TextHitInfo。

参数：
offset - 与偏移量之前的字符关联的偏移量
返回：
在指定偏移量处的 TextHitInfo。

afterOffset

public static TextHitInfo afterOffset(int offset)
在指定偏移量处创建一个与偏移量之后的字符关联的 TextHitInfo。

参数：
offset - 与偏移量之后的字符关联的偏移量
返回：
在指定偏移量处的 TextHitInfo。

getOtherHit

public TextHitInfo getOtherHit()
在插入点的另一侧创建一个 TextHitInfo。此 TextHitInfo 保持不变。

返回：
插入点另一侧的 TextHitInfo。

getOffsetHit

public TextHitInfo getOffsetHit(int delta)
创建一个 TextHitInfo，其字符索引从此 TextHitInfo 的 charIndex 偏移 delta。此 TextHitInfo 保持不变。

参数：
delta - 偏移此 charIndex 的值
返回：
一个 TextHitInfo，其 charIndex 从此 TextHitInfo 的 charIndex 偏移 delta。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 TextLayout

java.lang.Object
    继承者  java.awt.font.TextLayout
所有已实现的接口：
Cloneable
public final class TextLayout
extends Object
implements Cloneable

TextLayout 是样式字符数据的不可变图形表示形式。

它提供以下功能：

  • 隐式双向分析和重排序
  • 光标定位和移动，包括针对混向文本的拆分光标
  • ，包括针对混向文本的逻辑和可视高亮显示
  • 多个基线（罗马字体、悬挂和居中）
  • 命中测试
  • 调整
  • 默认字体替换
  • 规格信息，如 ascent、descent 和 advance
  • 呈现

TextLayout 对象可以使用其 draw 方法呈现。

可以直接或通过使用 LineBreakMeasurer 构造 TextLayout。直接构造时，源文本表示一个段落。LineBreakMeasurer 允许带样式的文本断行，以适应特定的宽度。有关更多信息，请参阅 LineBreakMeasurer 文档。

TextLayout 的逻辑构造过程如下：

  • 提取并检查段落属性
  • 对文本进行双向重排分析，并在需要时计算重排信息
  • 根据样式排列对文本进行分段
  • 为样式排列选择的字体，如果存在 TextAttribute.FONT 属性，则首先使用该字体，否则，通过使用已定义的属性计算默认字体
  • 如果文本位于多个基线上，则排列或子排列被进一步拆分为共享公共基线的子排列
  • 使用所选字体为每个排列生成字形向量
  • 对字形向量执行最后的双向重排

从 TextLayout 对象的方法返回的所有图形信息都相对于 TextLayout 的原点，它是 TextLayout 对象的基线与其左边缘的交叉点。同样，假定传递到 TextLayout 对象方法的坐标也相对于 TextLayout 对象的原点。客户端通常需要在 TextLayout 对象的坐标系和另一对象（如 Graphics 对象）中的坐标系之间进行转换。

根据样式文本创建 TextLayout 对象，但它们不保留对其源文本的引用。因此，对先前用来生成 TextLayout 文本的改动不会影响 TextLayout。

TextLayout 对象的三个方法（getNextRightHit、getNextLeftHit 和 hitTestChar）都返回 TextHitInfo 实例。这些 TextHitInfo 对象中的偏移量相对于 TextLayout 的起始处，而不是相对于用来创建 TextLayout 的文本。同样，接受 TextHitInfo 实例作为参数的 TextLayout 方法将 TextHitInfo 对象的偏移量看做相对于 TextLayout，而不是其他任何基础文本存储模型。

示例：

构造并绘制 TextLayout 及其边界矩形：

   Graphics2D g = ...;
   Point2D loc = ...;
   Font font = Font.getFont("Helvetica-bold-italic");
   FontRenderContext frc = g.getFontRenderContext();
   TextLayout layout = new TextLayout("This is a string", font, frc);
   layout.draw(g, (float)loc.getX(), (float)loc.getY());

   Rectangle2D bounds = layout.getBounds();
   bounds.setRect(bounds.getX()+loc.getX(),
                  bounds.getY()+loc.getY(),
                  bounds.getWidth(),
                  bounds.getHeight());
   g.draw(bounds);

对 TextLayout 进行命中测试（确定哪个字符位于特定图形位置上）：

   Point2D click = ...;
   TextHitInfo hit = layout.hitTestChar(
                         (float) (click.getX() - loc.getX()),
                         (float) (click.getY() - loc.getY()));

对按下向右方向键进行响应：

   int insertionIndex = ...;
   TextHitInfo next = layout.getNextRightHit(insertionIndex);
   if (next != null) {
       // translate graphics to origin of layout on screen
       g.translate(loc.getX(), loc.getY());
       Shape[] carets = layout.getCaretShapes(next.getInsertionIndex());
       g.draw(carets[0]);
       if (carets[1] != null) {
           g.draw(carets[1]);
       }
   }

绘制一个对应于源文本中子字符串的选择范围。选择的区域在视觉上可能是不连续的：

   // selStart, selLimit should be relative to the layout,
   // not to the source text

   int selStart = ..., selLimit = ...;
   Color selectionColor = ...;
   Shape selection = layout.getLogicalHighlightShape(selStart, selLimit);
   // selection may consist of disjoint areas
   // graphics is assumed to be tranlated to origin of layout
   g.setColor(selectionColor);
   g.fill(selection);

绘制一个视觉上连续的选择范围。选择范围可能对应源文本中的多个子字符串。通过 getLogicalRangesForVisualSelection() 可以获得相应源文本的子字符串范围：

   TextHitInfo selStart = ..., selLimit = ...;
   Shape selection = layout.getVisualHighlightShape(selStart, selLimit);
   g.setColor(selectionColor);
   g.fill(selection);
   int[] ranges = getLogicalRangesForVisualSelection(selStart, selLimit);
   // ranges[0], ranges[1] is the first selection range,
   // ranges[2], ranges[3] is the second selection range, etc.

注：字体旋转可能导致文本基线旋转，多次进行不同的旋转可能够导致基线弯曲或出现 Z 形转角。为了处理好这种（少有的）可能性，需要指定一些 API 返回规格，并采用“相对于基线的坐标中”的参数（比如 ascent 和 advance），以及其他一些“标准坐标中”的规格和参数（比如 getBounds）。相对于基线的坐标中的值将 'x' 坐标映射到沿基线的某段距离处（正 x 表示沿基线的正方向），将 'y' 坐标映射到 'x' 坐标处基线垂直方向的某段距离处（正 y 表示从基线向量顺时针旋转 90 度）。标准坐标中的值是沿 x 轴和 y 轴进行测量的，0,0 是 TextLayout 的原点。用于每个相关 API 的文档都将指示哪些值位于坐标系中。通常，与测量有关的 API 位于与相对于基线的坐标中，而与显示有关的 API 则位于标准坐标中。

另请参见：
LineBreakMeasurer, TextAttribute, TextHitInfo, LayoutPath

嵌套类摘要
static class TextLayout.CaretPolicy
定义确定强插入符位置的策略。
字段摘要
static TextLayout.CaretPolicy DEFAULT_CARET_POLICY
客户端未指定策略时使用此 CaretPolicy。
构造方法摘要
TextLayout(AttributedCharacterIterator text, FontRenderContext frc)
根据样式文本上的迭代器构造一个 TextLayout。
TextLayout(String string, Font font, FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。
TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。
方法摘要
protected Object | clone() 创建此 TextLayout 的副本。
void | draw(Graphics2D g2, float x, float y) 在指定的 Graphics2D 上下文中的指定位置上呈现此 TextLayout。
boolean | equals(Object obj) 如果指定 Object 是一个 TextLayout 对象，且指定的 Object 等于此 TextLayout，则返回 true。
boolean | equals(TextLayout rhs) 如果两个布局相等，则返回 true。
float | getAdvance() 返回此 TextLayout 的 advance。
float | getAscent() 返回此 TextLayout 的 ascent。
byte | getBaseline() 返回此 TextLayout 的基线。
float[] | getBaselineOffsets() 返回用于此 TextLayout 的基线偏移量数组。
Shape | getBlackBoxBounds(int firstEndpoint, int secondEndpoint) 返回指定范围中字符的黑框边界。
Rectangle2D | getBounds() 返回此 TextLayout 的边界。
float[] | getCaretInfo(TextHitInfo hit) 返回与对应于 hit 的插入符有关的信息。
float[] | getCaretInfo(TextHitInfo hit, Rectangle2D bounds) 返回与对应于 hit 的插入符有关的信息。
Shape | getCaretShape(TextHitInfo hit) 返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。
Shape | getCaretShape(TextHitInfo hit, Rectangle2D bounds) 返回表示指定边界内指定目标字符处插入符的 Shape。
Shape[] | getCaretShapes(int offset) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | getCaretShapes(int offset, Rectangle2D bounds) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | getCaretShapes(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy) 返回对应于强插入符和弱插入符的两条路径。
int | getCharacterCount() 返回由此 TextLayout 表示的字符数。
byte | getCharacterLevel(int index) 返回 index 处字符的级别。
float | getDescent() 返回此 TextLayout 的 descent。
TextLayout | getJustifiedLayout(float justificationWidth) 创建调整到指定宽度的此 TextLayout 的一个副本。
LayoutPath | getLayoutPath() 返回 LayoutPath，如果布局路径是默认路径（x 映射到 advance，y 映射到 offset），则返回 null。
float | getLeading() 返回 TextLayout 的行距。
Shape | getLogicalHighlightShape(int firstEndpoint, int secondEndpoint) 返回封装指定范围中逻辑选择范围的 Shape，它扩展到此 TextLayout 的自然边界。
Shape | getLogicalHighlightShape(int firstEndpoint, int secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。
int[] | getLogicalRangesForVisualSelection(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回对应于可视选择范围的逻辑文本范围。
TextHitInfo | getNextLeftHit(int offset) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | getNextLeftHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | getNextLeftHit(TextHitInfo hit) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | getNextRightHit(int offset) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | getNextRightHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | getNextRightHit(TextHitInfo hit) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
Shape | getOutline(AffineTransform tx) 返回表示此 TextLayout 的轮廓的 Shape。
Rectangle | getPixelBounds(FontRenderContext frc, float x, float y) 返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。
float | getVisibleAdvance() 返回此 TextLayout 的 advance，减去结尾空格。
Shape | getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。
Shape | getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。
TextHitInfo | getVisualOtherHit(TextHitInfo hit) 返回位于指定目标字符插入符另一侧的目标字符。
protected void | handleJustify(float justificationWidth) 调整此布局。
int | hashCode() 返回此 TextLayout 的哈希码。
TextHitInfo | hitTestChar(float x, float y) 返回对应于指定点的 TextHitInfo。
TextHitInfo | hitTestChar(float x, float y, Rectangle2D bounds) 返回对应于指定点的 TextHitInfo。
void | hitToPoint(TextHitInfo hit, Point2D point) 将一个命中点转换为标准坐标中的一个点。
boolean | isLeftToRight() 如果此 TextLayout 的基本方向是从左到右，则返回 true；如果基本方向是从右到左，则返回 false。
boolean | isVertical() 如果此 TextLayout 是垂直的，则返回 true。
String | toString() 返回此 TextLayout 的调试信息。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_CARET_POLICY

public static final TextLayout.CaretPolicy DEFAULT_CARET_POLICY
客户端未指定策略时使用此 CaretPolicy。使用此策略，方向与行方向相同的字符的命中要强于对反方向字符的命中。如果字符的方向相同，则对字符开始边的命中要强于对字符结尾边的命中。

构造方法详细信息

TextLayout

public TextLayout(String string,
                  Font font,
                  FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。使用指定的 Font 样式化所有文本。

String 必须指定单个文本段，因为双向算法需要整个段落。

参数：
string - 要显示的文本
font - 用于样式化文本的 Font
frc - 包含关于正确测量文本所需图形设备的信息。根据设备分辨率和属性（如抗锯齿）的不同，文本测量可能稍有变化。此参数未指定 TextLayout 和用户空间之间的转换。

TextLayout

public TextLayout(String string,
                  Map<? extends AttributedCharacterIterator.Attribute,?> attributes,
                  FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。

使用提供的属性样式化所有文本。

String 必须指定单个文本段，因为双向算法需要整个段落。

参数：
string - 要显示的文本
attributes - 用于样式化文本的属性
frc - 包含关于正确测量文本所需图形设备的信息。根据设备分辨率和属性（如抗锯齿）的不同，文本测量可能稍有变化。此参数未指定 TextLayout 和用户空间之间的转换。

TextLayout

public TextLayout(AttributedCharacterIterator text,
                  FontRenderContext frc)
根据样式文本上的迭代器构造一个 TextLayout。

该迭代器必须指定单个文本段，因为双向算法需要整个段落。

参数：
text - 要显示的样式文本
frc - 包含关于正确测量文本所需图形设备的信息。根据设备分辨率和属性（如抗锯齿）的不同，文本测量可能稍有变化。此参数未指定 TextLayout 和用户空间之间的转换。
方法详细信息

clone

protected Object clone()
创建此 TextLayout 的副本。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getJustifiedLayout

public TextLayout getJustifiedLayout(float justificationWidth)
创建调整到指定宽度的此 TextLayout 的一个副本。

如果已调整了此 TextLayout，则抛出异常。如果此 TextLayout 对象的调整率为零，将返回与此 TextLayout 相同的 TextLayout。

参数：
justificationWidth - 调整行时使用的宽度。要获得最佳结果，该宽度与行的当前 advance 不应有太大差别。
返回：
调整到指定宽度的 TextLayout。
抛出：
Error - 如果已调整了此布局，则抛出 Error。

handleJustify

protected void handleJustify(float justificationWidth)
调整此布局。子类重写该方法来控制调整（如果存在子类，即……）。 只在段落属性（来自源文本，可以是布局属性的默认值）指示一个非零调整率时才调整布局。将文本调整到指示的宽度。当前实现还调整标点和尾部空白，使其接近于调整宽度。调整布局之后将不会对其进行再调整。

某些代码依赖于布局的不可变性。因此子类不应直接调用该方法，而应调用 getJustifiedLayout，getJustifiedLayout 将在此布局的副本上调用此方法，并保留原始布局。

参数：
justificationWidth - 调整行时使用的宽度。要获得最佳结果，该宽度与行的当前 advance 不应有太大差别。
另请参见：
getJustifiedLayout(float)

getBaseline

public byte getBaseline()
返回此 TextLayout 的基线。基线是 Font 中定义的一个值，它可以是 roman、centered 或 hanging。Ascent 和 descent 相对于此基线。baselineOffsets 也相对于此基线。

返回：
此 TextLayout 的基线。
另请参见：
getBaselineOffsets(), Font

getBaselineOffsets

public float[] getBaselineOffsets()
返回用于此 TextLayout 的基线偏移量数组。

该数组用 Font 中定义的 roman、centered 或 hanging 值之一进行索引。这些值相对于此 TextLayout 对象的基线，从而 getBaselineOffsets[getBaseline()] == 0。将偏移量添加到 TextLayout 对象基线所在的位置，以获取新基线的位置。

返回：
包含用于此 TextLayout 基线的偏移量数组。
另请参见：
getBaseline(), Font

getAdvance

public float getAdvance()
返回此 TextLayout 的 advance。该 advance 是从原点到最右边（最底部）字符的 advance 的距离。返回值位于相对于基线的坐标中。

返回：
此 TextLayout 的 advance。

getVisibleAdvance

public float getVisibleAdvance()
返回此 TextLayout 的 advance，减去结尾空格。返回值位于相对于基线的坐标中。

返回：
此 TextLayout 的 advance，不包括结尾的空格。
另请参见：
getAdvance()

getAscent

public float getAscent()
返回此 TextLayout 的 ascent。ascent 是从 TextLayout 的顶端（右端）到基线的距离。它始终为正数或零。ascent 足以容纳上标文本，它是每个字形的 ascent、偏移量和基线总和的最大值。该 ascent 是 TextLayout 中所有文本基线的最大 ascent。返回值位于相对于基线的坐标中。

返回：
此 TextLayout 的 ascent。

getDescent

public float getDescent()
返回此 TextLayout 的 descent。descent 是从基线到 TextLayout 底部（左端）的距离。它始终为正数或零。descent 足以容纳下标文本，它是每个字形的 descent、偏移量和基线总和的最大值。该 ascent 是 TextLayout 中所有文本基线的最大 descent。返回值位于相对于基线的坐标中。

返回：
此 TextLayout 的 descent。

getLeading

public float getLeading()
返回 TextLayout 的行距。行距是此 TextLayout 的建议行间距。返回值位于相对于基线的坐标中。

行距通过 TextLayout 中所有字形向量的行距、descent 和基线计算。算法大致如下：

 maxD = 0;
 maxDL = 0;
 for (GlyphVector g in all glyphvectors) {
    maxD = max(maxD, g.getDescent() + offsets[g.getBaseline()]);
    maxDL = max(maxDL, g.getDescent() + g.getLeading() +
                       offsets[g.getBaseline()]);
 }
 return maxDL - maxD;

返回：
此 TextLayout 的行距。

getBounds

public Rectangle2D getBounds()
返回此 TextLayout 的边界。这些边界位于标准坐标中。因为光栅化效果，这些边界可能没有封装 TextLayout 呈现的所有像素。它可能与 TextLayout 的 ascent、descent、origin 或 advance 并不完全一致。

返回：
作为此 TextLayout 边界的 Rectangle2D。

getPixelBounds

public Rectangle getPixelBounds(FontRenderContext frc,
                                float x,
                                float y)
返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。图形呈现上下文不必与用来创建此 TextLayout 的 FontRenderContext 相同，并且可以为 null。如果为 null，则使用此 TextLayout 的 FontRenderContext。

参数：
frc - Graphics 的 FontRenderContext。
x - 呈现此 TextLayout 处的 x 坐标。
y - 呈现此 TextLayout 处的 y 坐标。
返回：
封装受影响像素的 Rectangle。
从以下版本开始：
1.6
另请参见：
GlyphVector.getPixelBounds(java.awt.font.FontRenderContext, float, float)

isLeftToRight

public boolean isLeftToRight()
如果此 TextLayout 的基本方向是从左到右，则返回 true；如果基本方向是从右到左，则返回 false。TextLayout 的基本方向是从左到右 (LTR) 或从右到左 (RTL)。基本方向与行中文本的实际方向无关，实际方向可以是 LTR、RTL 或混向。默认情况下，从左到右布局按左对齐来定位。如果布局在制表行上进行，那么制表符将从左到右，从而逻辑连续布局的定位将从左到右。对于 RTL 布局则相反。默认情况下，它们是按左对齐来定位的，制表符将从右到左。

返回：
如果此 TextLayout 的基本方向是从左到右，则返回 true；否则返回 false。

isVertical

public boolean isVertical()
如果此 TextLayout 是垂直的，则返回 true。

返回：
如果此 TextLayout 是垂直的，则返回 true；否则返回 false。

getCharacterCount

public int getCharacterCount()
返回由此 TextLayout 表示的字符数。

返回：
此 TextLayout 中的字符数。

getCaretInfo

public float[] getCaretInfo(TextHitInfo hit,
                            Rectangle2D bounds)
返回与对应于 hit 的插入符有关的信息。数组的第一个元素是插入符与基线的交集，它是沿基线的一段距离。数组的第二个元素是插入符的反斜面（排列/上升），它是根据位于该点的基线进行测量的。

此方法仅用于获取信息。要显示插入符，最好使用 getCaretShapes。

参数：
hit - 此 TextLayout 中的目标字符
bounds - 构造插入符位置的边界。这些边界位于相对于基线的坐标中。
返回：
包含插入符位置和斜面的两元素数组。返回的插入符信息位于相对于基线的坐标中。
另请参见：
getCaretShapes(int, Rectangle2D, TextLayout.CaretPolicy), Font.getItalicAngle()

getCaretInfo

public float[] getCaretInfo(TextHitInfo hit)
返回与对应于 hit 的插入符有关的信息。此方法是 getCaretInfo 的便捷用法，它使用了此 TextLayout 的自然边界。

参数：
hit - 此 TextLayout 中的目标字符
返回：
有关对应于目标字符的插入符的信息。返回的插入符信息位于相对于基线的坐标中。

getNextRightHit

public TextHitInfo getNextRightHit(TextHitInfo hit)
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。如果目标字符索引超出范围，则抛出 IllegalArgumentException。

参数：
hit - 此布局中的目标字符
返回：
插入符显示在所提供目标字符的插入符右侧（底部）下一个位置的目标字符，或者返回 null。

getNextRightHit

public TextHitInfo getNextRightHit(int offset,
                                   TextLayout.CaretPolicy policy)
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。目标字符位于指定偏移量处根据指定策略确定的强插入符右侧。返回的目标字符是根据指定策略确定的两个可能目标字符中较强的一个。

参数：
offset - 此 TextLayout 中的插入偏移量。不能小于 0 或大于此 TextLayout 对象的字符计数。
policy - 用来选择强插入符的策略
返回：
插入符显示在所提供目标字符的插入符右侧（底部）下一个位置的目标字符，或者返回 null。

getNextRightHit

public TextHitInfo getNextRightHit(int offset)
返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。目标字符位于指定偏移量处根据默认策略确定的强插入符右侧。返回的目标字符是根据默认策略确定的两个可能目标字符中较强的一个。

参数：
offset - 此 TextLayout 中的插入偏移量。不能小于 0 或大于该 TextLayout 对象的字符计数。
返回：
插入符显示在所提供目标字符的插入符右侧（底部）下一个位置的目标字符，或者返回 null。

getNextLeftHit

public TextHitInfo getNextLeftHit(TextHitInfo hit)
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。如果目标字符索引超出范围，则抛出 IllegalArgumentException。

参数：
hit - 此 TextLayout 中的目标字符。
返回：
插入符显示在所提供目标字符的插入符左侧（顶部）下一个位置的目标字符，或者返回 null。

getNextLeftHit

public TextHitInfo getNextLeftHit(int offset,
                                  TextLayout.CaretPolicy policy)
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。目标字符位于指定偏移量处根据指定策略确定的强插入符左侧。返回的目标字符是根据指定策略确定的两个可能目标字符中较强的一个。

参数：
offset - 此 TextLayout 中的插入偏移量。不能小于 0 或大于此 TextLayout 对象的字符计数。
policy - 用来选择强插入符的策略
返回：
插入符显示在所提供目标字符的插入符左侧（顶部）下一个位置的目标字符，或者返回 null。

getNextLeftHit

public TextHitInfo getNextLeftHit(int offset)
返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。目标字符位于指定偏移量处根据默认策略确定的强插入符左侧。返回的目标字符是根据默认策略确定的两个可能目标字符中较强的一个。

参数：
offset - 此 TextLayout 中的插入偏移量。不能小于 0 或大于此 TextLayout 对象的字符计数。
返回：
插入符显示在所提供目标字符的插入符左侧（顶部）下一个位置的目标字符，或者返回 null。

getVisualOtherHit

public TextHitInfo getVisualOtherHit(TextHitInfo hit)
返回位于指定目标字符插入符另一侧的目标字符。

参数：
hit - 指定的目标字符
返回：
位于指定字符插入符另一侧的目标字符。

getCaretShape

public Shape getCaretShape(TextHitInfo hit,
                           Rectangle2D bounds)
返回表示指定边界内指定目标字符处插入符的 Shape。

参数：
hit - 生成插入符处的目标字符
bounds - 用于生成插入符的 TextLayout 的边界。这些边界位于相对于基线的坐标中。
返回：
表示插入符的 Shape。返回的形状位于标准坐标中。

getCaretShape

public Shape getCaretShape(TextHitInfo hit)
返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。

参数：
hit - 生成插入符处的目标字符
返回：
表示插入符的 Shape。返回的形状位于标准坐标中。

getCharacterLevel

public byte getCharacterLevel(int index)
返回 index 处字符的级别。索引 -1 和 characterCount 被分配为此 TextLayout 的基本级别。

参数：
index - 可获取级别的字符索引
返回：
指定 index 处字符的级别。

getCaretShapes

public Shape[] getCaretShapes(int offset,
                              Rectangle2D bounds,
                              TextLayout.CaretPolicy policy)
返回对应于强插入符和弱插入符的两条路径。

参数：
offset - 此 TextLayout 中的偏移量
bounds - 插入符扩展到的边界。这些边界位于相对于基线的坐标中。
policy - 指定的 CaretPolicy
返回：
包含两条路径的数组。元素零是强插入符。如果有两个插入符，则元素 1 为弱插入符，否则为 null。返回的形状位于标准坐标中。

getCaretShapes

public Shape[] getCaretShapes(int offset,
                              Rectangle2D bounds)
返回对应于强插入符和弱插入符的两条路径。此方法是使用默认插入符策略的 getCaretShapes 的便捷用法。

参数：
offset - 此 TextLayout 中的偏移量
bounds - 插入符扩展到的边界。此边界位于相对于基线的坐标中。
返回：
对应于 DEFAULT_CARET_POLICY 定义的强插入符和弱插入符的两条路径。这些路径位于标准坐标中。

getCaretShapes

public Shape[] getCaretShapes(int offset)
返回对应于强插入符和弱插入符的两条路径。此方法是 getCaretShapes 的便捷用法，后者使用默认插入符策略和此 TextLayout 对象的自然边界。

参数：
offset - 此 TextLayout 中的偏移量
返回：
对应于 DEFAULT_CARET_POLICY 定义的强插入符和弱插入符的两条路径。这两条路径位于标准坐标中。

getLogicalRangesForVisualSelection

public int[] getLogicalRangesForVisualSelection(TextHitInfo firstEndpoint,
                                                TextHitInfo secondEndpoint)
返回对应于可视选择范围的逻辑文本范围。

参数：
firstEndpoint - 可视范围的端点
secondEndpoint - 可视范围的另一个端点。此端点可以小于 firstEndpoint。
返回：
表示所选范围的开始/限制对的整数数组。
另请参见：
getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D)

getVisualHighlightShape

public Shape getVisualHighlightShape(TextHitInfo firstEndpoint,
                                     TextHitInfo secondEndpoint,
                                     Rectangle2D bounds)
返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。

如果选择范围包括最左侧（最顶部）的位置，那么它将扩展到 bounds 的左侧（顶部）。如果选择范围包括最右侧（最底部）的位置，那么它将扩展到边界的右侧（底部）。选择范围的高度（垂直行上的宽度）始终扩展到 bounds。

尽管选择范围始终是连续的，但逻辑选择文本在混向文本的行上可能是不连续的。所选文本的逻辑范围可以使用 getLogicalRangesForVisualSelection 检索。例如，假设文本 "ABCdef" 中的大写字母表示在从右到左的行上呈现的从右到左的文本，可视选择范围从 0L（"A" 的开始边）到 3T（"d" 的结尾边）。文本显示如下，粗体下划线区域表示选择范围：

    defCBA
因为视觉上连续的文本在逻辑上是不连续的，所以逻辑选择范围为 0-3、4-6 (ABC, ef)。还请注意的是，由于选择了布局上最右侧的位置（"A" 的右边），因此选择范围将扩展到边界的右侧。

参数：
firstEndpoint - 可视选择范围的端点
secondEndpoint - 可视选择范围的另一个端点
bounds - 选择范围扩展到的边界矩形。此矩形位于相对于基线的坐标中。
返回：
封闭选择范围的 Shape。此形状位于标准坐标中。
另请参见：
getLogicalRangesForVisualSelection(TextHitInfo, TextHitInfo), getLogicalHighlightShape(int, int, Rectangle2D)

getVisualHighlightShape

public Shape getVisualHighlightShape(TextHitInfo firstEndpoint,
                                     TextHitInfo secondEndpoint)
返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。此方法是 getVisualHighlightShape 的便捷用法，后者使用了此 TextLayout 的自然边界。

参数：
firstEndpoint - 可视选择范围的端点
secondEndpoint - 可视选择范围的另一个端点
返回：
封闭选择范围的 Shape。此形状位于标准坐标中。

getLogicalHighlightShape

public Shape getLogicalHighlightShape(int firstEndpoint,
                                      int secondEndpoint,
                                      Rectangle2D bounds)
返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。

如果选择范围包括第一个逻辑字符，那么它将扩展到此 TextLayout 的起点之前的 bounds 部分。如果该范围包括最后的逻辑字符，那么它将扩展到此 TextLayout 的结束点之后的 bounds 部分。选择范围的高度（垂直行上的宽度）始终扩展到 bounds。

选择范围在混向文本的行上可能是不连续的。只有逻辑范围中开始和限制之间的那些字符才显示为被选中。例如，假定文本 "ABCdef" 的大写字母表示在从右到左的行上呈现从右到左的文本，逻辑选择范围是从 0 到 4 ('ABCd')。文本显示如下，粗体表示选择范围，下划线表示扩展：

    defCBA
因为选择的字符在视觉上是不连续的，该选择范围是不连续的。还请注意的是，由于该范围包括第一个逻辑字符 (A)，所以该选择范围将扩展到布局开始之前的 bounds 部分，在本例中（从右到左的行）是 bounds 的右半部。

参数：
firstEndpoint - 选择的字符范围的端点
secondEndpoint - 选择的字符范围的另一个端点。可以小于 firstEndpoint。此范围包括 min(firstEndpoint, secondEndpoint) 处的字符，但不包括 max(firstEndpoint, secondEndpoint) 处的字符。
bounds - 选择范围扩展到的边界矩形。此矩形位于相对于基线的坐标中。
返回：
封装该选择范围的区域。此区域位于标准坐标中。
另请参见：
getVisualHighlightShape(TextHitInfo, TextHitInfo, Rectangle2D)

getLogicalHighlightShape

public Shape getLogicalHighlightShape(int firstEndpoint,
                                      int secondEndpoint)
返回封装指定范围中逻辑选择范围的 Shape，它扩展到此 TextLayout 的自然边界。此方法是 getLogicalHighlightShape 的便捷用法，后者使用了此 TextLayout 的自然边界。

参数：
firstEndpoint - 选择的字符范围的端点
secondEndpoint - 选择的字符范围的另一个端点。可以小于 firstEndpoint。此范围包括 min(firstEndpoint, secondEndpoint) 处的字符，但不包括 max(firstEndpoint, secondEndpoint) 处的字符。
返回：
封装选择范围的 Shape。 此形状位于标准坐标中。

getBlackBoxBounds

public Shape getBlackBoxBounds(int firstEndpoint,
                               int secondEndpoint)
返回指定范围中字符的黑框边界。黑框边界是所有对应于开始和限制之间字符字形的边界框并集。此区域可以不相交。

参数：
firstEndpoint - 字符范围的端点
secondEndpoint - 字符范围的另一个端点。可以小于 firstEndpoint。
返回：
封装黑框边界的 Shape。此形状位于标准坐标中。

hitTestChar

public TextHitInfo hitTestChar(float x,
                               float y,
                               Rectangle2D bounds)
返回对应于指定点的 TextHitInfo。将 TextLayout 边界之外的坐标映射到第一个逻辑字符开始边上的点，或映射到最后一个逻辑字符结束边上的点（如果合适），而不考虑该字符在行中的位置。该方法只使用基线方向。

参数：
x - 距离此 TextLayout 原点的 x 偏移量。此偏移量位于标准坐标中。
y - 距离此 TextLayout 原点的 y 偏移量。此偏移量位于标准坐标中。
bounds - TextLayout 的边界。此边界位于相对于基线的坐标中。
返回：
描述指定点处字符和边缘（开始边或结尾边）的 TextHitInfo。

hitTestChar

public TextHitInfo hitTestChar(float x,
                               float y)
返回对应于指定点的 TextHitInfo。此方法是 hitTestChar 的便捷用法，后者使用了此 TextLayout 的自然边界。

参数：
x - 距离此 TextLayout 原点的 x 偏移量。此偏移量位于标准坐标中。
y - 距离此 TextLayout 原点的 y 偏移量。此偏移量位于标准坐标中。
返回：
描述指定点下字符和边缘（开始边或结尾边）的 TextHitInfo。

hashCode

public int hashCode()
返回此 TextLayout 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 TextLayout 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
如果指定 Object 是一个 TextLayout 对象，且指定的 Object 等于此 TextLayout，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 用于测试相等性的 Object
返回：
如果指定的 Object 等于此 TextLayout，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

equals

public boolean equals(TextLayout rhs)
如果两个布局相等，则返回 true。如果两个布局包含具有相同顺序的相等字形向量，则这两个布局相等。

参数：
rhs - 要与此 TextLayout 进行比较的 TextLayout
返回：
如果指定的 TextLayout 等于此 TextLayout，则返回 true。

toString

public String toString()
返回此 TextLayout 的调试信息。

覆盖：
类 Object 中的 toString
返回：
此 TextLayout 的 String 形式的 textLine

draw

public void draw(Graphics2D g2,
                 float x,
                 float y)
在指定的 Graphics2D 上下文中的指定位置上呈现此 TextLayout。布局的原点置于 x, y。呈现可能涉及此位置的 getBounds() 中的任何点。此方法不改变 g2。文本是沿着基线路径呈现的。

参数：
g2 - 呈现布局的 Graphics2D 上下文
x - 此 TextLayout 的 X 坐标
y - 此 TextLayout 的 Y 坐标
另请参见：
getBounds()

getOutline

public Shape getOutline(AffineTransform tx)
返回表示此 TextLayout 的轮廓的 Shape。

参数：
tx - 应用于此 TextLayout 轮廓的可选 AffineTransform。
返回：
此 TextLayout 的轮廓的 Shape。此形状位于标准坐标中。

getLayoutPath

public LayoutPath getLayoutPath()
返回 LayoutPath，如果布局路径是默认路径（x 映射到 advance，y 映射到 offset），则返回 null。

返回：
布局路径
从以下版本开始：
1.6

hitToPoint

public void hitToPoint(TextHitInfo hit,
                       Point2D point)
将一个命中点转换为标准坐标中的一个点。该点在字符的基线上，在适当的情况下，它可以位于字符的开始边或结尾边上。如果路径在通过命中表示的字符边上断开，那么该点将与此字符相邻。

参数：
hit - 命中检查。此参数必须是 TextLayout 上的一次有效命中。
point - 返回的点。此点位于标准坐标中。
抛出：
IllegalArgumentException - 如果 hit 对于 TextLayout 无效。
NullPointerException - 如果 hit 或 point 为 null。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextLayout.CaretPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 TextLayout.CaretPolicy

java.lang.Object
    继承者  java.awt.font.TextLayout.CaretPolicy
正在封闭类：
TextLayout
public static class TextLayout.CaretPolicy
extends Object

定义确定强插入符位置的策略。此类包含一个 getStrongCaret 方法，该方法用于指定在双插入符文本中确定强插入符的策略。强插入符用于将插入符向左或向右移动。此类的实例可以传递给 getCaretShapes、getNextLeftHit 和 getNextRightHit，以自定义强插入符选择。

要指定可选插入符策略，创建 CaretPolicy 的子类并重写 getStrongCaret。getStrongCaret 应检查两个 TextHitInfo 参数，并选择其中一个作为强插入符。

大多数客户端不需要使用此类。

构造方法摘要
TextLayout.CaretPolicy()
构造一个 CaretPolicy。
方法摘要
 TextHitInfo getStrongCaret(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout)
选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TextLayout.CaretPolicy

public TextLayout.CaretPolicy()
构造一个 CaretPolicy。

方法详细信息

getStrongCaret

public TextHitInfo getStrongCaret(TextHitInfo hit1,
                                  TextHitInfo hit2,
                                  TextLayout layout)
选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。

参数：
hit1 - layout 中的一次有效命中
hit2 - layout 中的一次有效命中
layout - 在其中使用 hit1 和 hit2 的 TextLayout
返回：
hit1 或 hit2（或等效的 TextHitInfo），指示强插入符。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextMeasurer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 TextMeasurer

java.lang.Object
    继承者  java.awt.font.TextMeasurer
所有已实现的接口：
Cloneable
public final class TextMeasurer
extends Object
implements Cloneable

TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。该类还提供了段落增量编辑的方法。

TextMeasurer 对象是使用表示单个文本段落的 AttributedCharacterIterator 构造的。AttributedCharacterIterator 的 getBeginIndex 方法返回的值定义了第一个字符的绝对索引。AttributedCharacterIterator 的 getEndIndex 方法返回的值定义了最后一个字符后的索引。这些值定义了调用 TextMeasurer 的时使用的索引范围。例如，要通过调用获取文本范围的 advance 或文本范围的换行，则必须使用开始索引值和结束索引值之间的索引。调用 insertChar 和 deleteChar 重置 TextMeasurer 要使用在这些调用中传入的 AttributedCharacterIterator 的开始索引和结束索引。

大多数客户端将使用更方便的 LineBreakMeasurer，它实现了标准的换行策略（在每一行上放置尽可能多的适合的单词）。

从以下版本开始：
1.3
另请参见：
LineBreakMeasurer

构造方法摘要
TextMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
从源文本构造 TextMeasurer。
方法摘要
protected Object | clone() 创建并返回此对象的一个副本。
void | deleteChar(AttributedCharacterIterator newParagraph, int deletePos) 从当前由此 TextMeasurer 表示的段落中删除一个字符后，更新 TextMeasurer。
float | getAdvanceBetween(int start, int limit) 返回从 start 开始并包括一直到 limit 的字符的行的图形宽度。
TextLayout | getLayout(int start, int limit) 返回给定字符范围上的 TextLayout。
int | getLineBreakIndex(int start, float maxAdvance) 返回不能置于文本行上的第一个字符，该文本行从 start 开始并可能测量到图形宽度的 maxAdvance。
void | insertChar(AttributedCharacterIterator newParagraph, int insertPos) 在将单个字符插入当前由此 TextMeasurer 表示的段落中后，更新该 TextMeasurer。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TextMeasurer

public TextMeasurer(AttributedCharacterIterator text,
                    FontRenderContext frc)
从源文本构造 TextMeasurer。源文本应为一个整段。

参数：
text - 源段落。不能为 null。
frc - 关于需要正确测量文本的图形设备的信息。不能为 null。
方法详细信息

clone

protected Object clone()
从类 Object 复制的描述
创建并返回此对象的一个副本。“副本”的准确含义可能依赖于对象的类。这样做的目的是，对于任何对象 x，表达式：
x.clone() != x
为 true，表达式：
x.clone().getClass() == x.getClass()
也为 true，但这些并非必须要满足的要求。一般情况下：
x.clone().equals(x)
为 true，但这并非必须要满足的要求。

按照惯例，返回的对象应该通过调用 super.clone 获得。如果一个类及其所有的超类（Object 除外）都遵守此约定，则 x.clone().getClass() == x.getClass()。

按照惯例，此方法返回的对象应该独立于该对象（正被复制的对象）。要获得此独立性，在 super.clone 返回对象之前，有必要对该对象的一个或多个字段进行修改。这通常意味着要复制包含正在被复制对象的内部“深层结构”的所有可变对象，并使用对副本的引用替换对这些对象的引用。如果一个类只包含基本字段或对不变对象的引用，那么通常不需要修改 super.clone 返回的对象中的字段。

Object 类的 clone 方法执行特定的复制操作。首先，如果此对象的类不能实现接口 Cloneable，则会抛出 CloneNotSupportedException。注意，所有的数组都被视为实现接口 Cloneable。否则，此方法会创建此对象的类的一个新实例，并像通过分配那样，严格使用此对象相应字段的内容初始化该对象的所有字段；这些字段的内容没有被自我复制。所以，此方法执行的是该对象的“浅表复制”，而不“深层复制”操作。

Object 类本身不实现接口 Cloneable，所以在类为 Object 的对象上调用 clone 方法将会导致在运行时抛出异常。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getLineBreakIndex

public int getLineBreakIndex(int start,
                             float maxAdvance)
返回不能置于文本行上的第一个字符，该文本行从 start 开始并可能测量到图形宽度的 maxAdvance。

参数：
start - 从此处开始测量的字符索引。start 是一个绝对索引，而不是相对于段落开始处的相对索引
maxAdvance - 文本行必须符合的图形宽度
返回：
置于从 start 开始、不长于 maxAdvance 文本行上的最后一个字符后的索引
抛出：
IllegalArgumentException - 如果 start 小于段落的开始位置。

getAdvanceBetween

public float getAdvanceBetween(int start,
                               int limit)
返回从 start 开始并包括一直到 limit 的字符的行的图形宽度。start 和 limit 是绝对索引，不是相对于段落开始处的相对索引。

参数：
start - 开始测量的字符索引
limit - 停止测量的字符索引
返回：
从 start 处开始并包括一直到 limit 的字符的行的图形宽度
抛出：
IndexOutOfBoundsException - 如果 limit 小于 start
IllegalArgumentException - 如果 start 或 limit 不在段落开始处和段落结束处之间。

getLayout

public TextLayout getLayout(int start,
                            int limit)
返回给定字符范围上的 TextLayout。

参数：
start - 第一个字符的索引
limit - 最后一个字符之后的索引。必须大于 start
返回：
从 start 开始（不包括）直到 limit 的字符的 TextLayout
抛出：
IndexOutOfBoundsException - 如果 limit 小于 start
IllegalArgumentException - 如果 start 或 limit 不在段落开始处和段落结束处之间。

insertChar

public void insertChar(AttributedCharacterIterator newParagraph,
                       int insertPos)
在将单个字符插入当前由此 TextMeasurer 表示的段落中后，更新该 TextMeasurer。在此调用后，该 TextMeasurer 等效于从文本创建的新 TextMeasurer；不过，更新现有 TextMeasurer 通常比重新创建一个新 TextMeasurer 效率更高。

参数：
newParagraph - 执行插入后段落的文本。不能为 null。
insertPos - 插入字符在文本中的位置。不能小于 newParagraph 的开始，且必须小于 newParagraph 的结束。
抛出：
IndexOutOfBoundsException - 如果 insertPos 小于 newParagraph 的开始或者大于或等于 newParagraph 的结束
NullPointerException - 如果 newParagraph 为 null

deleteChar

public void deleteChar(AttributedCharacterIterator newParagraph,
                       int deletePos)
从当前由此 TextMeasurer 表示的段落中删除一个字符后，更新 TextMeasurer。在此调用后，该 TextMeasurer 等效于从文本创建的新 TextMeasurer；不过，更新现有 TextMeasurer 通常比重新创建一个新 TextMeasurer 效率更高。

参数：
newParagraph - 执行删除后的段落文本。不能为 null。
deletePos - 所移除字符在文本中的位置。不能小于 newParagraph 的开始，而且不能大于 newParagraph 的结束。
抛出：
IndexOutOfBoundsException - 如果 deletePos 小于 newParagraph 的开始或大于 newParagraph 的结束
NullPointerException - 如果 newParagraph 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransformAttribute (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.font
类 TransformAttribute

java.lang.Object
    继承者  java.awt.font.TransformAttribute
所有已实现的接口：
Serializable
public final class TransformAttribute
extends Object
implements Serializable

TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。

另请参见：
序列化表格

字段摘要
static TransformAttribute IDENTITY
表示恒等变换的 TransformAttribute。
构造方法摘要
TransformAttribute(AffineTransform transform)
包装指定的转换。
方法摘要
boolean | equals(Object rhs) 如果 rhs 是一个变换等效于此 TransformAttribute 变换的 TransformAttribute，则返回 true。
AffineTransform | getTransform() 返回包装转换的一个副本。
int | hashCode() 返回该对象的哈希码值。
boolean | isIdentity() 如果包装转换是一个恒等变换，则返回 true。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IDENTITY

public static final TransformAttribute IDENTITY
表示恒等变换的 TransformAttribute。

从以下版本开始：
1.6
构造方法详细信息

TransformAttribute

public TransformAttribute(AffineTransform transform)
包装指定的转换。此转换被复制，并保存该副本的一个引用。初始转换不会更改。如果传递 null 作为参数，则此构造方法的行为与执行恒等变换一样。（注意，在这种情况下首选 IDENTITY。）

参数：
transform - 要包装的指定 AffineTransform，或者为 null。
方法详细信息

getTransform

public AffineTransform getTransform()
返回包装转换的一个副本。

返回：
此 TransformAttribute 的包装转换的一个副本 AffineTransform。

isIdentity

public boolean isIdentity()
如果包装转换是一个恒等变换，则返回 true。

返回：
如果包装转换是一个恒等变换，则返回 true；否则返回 false。
从以下版本开始：
1.4

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
从以下版本开始：
1.6
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object rhs)
如果 rhs 是一个变换等效于此 TransformAttribute 变换的 TransformAttribute，则返回 true。

覆盖：
类 Object 中的 equals
参数：
rhs - 要与之比较的对象
返回：
如果该参数是一个变换等效于此 TransformAttribute 变换的 TransformAttribute，则返回 true。
从以下版本开始：
1.6
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.font (Java 2 Platform SE 6)

 java.awt.font
接口
MultipleMaster
OpenType
类
FontRenderContext
GlyphJustificationInfo
GlyphMetrics
GlyphVector
GraphicAttribute
ImageGraphicAttribute
LayoutPath
LineBreakMeasurer
LineMetrics
NumericShaper
ShapeGraphicAttribute
TextAttribute
TextHitInfo
TextLayout
TextLayout.CaretPolicy
TextMeasurer
TransformAttribute


java.awt.font (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.font

提供与字体相关的类和接口。

请参见：
描述

接口摘要
MultipleMaster | MultipleMaster 接口表示 Type 1 Multiple Master 字体。
OpenType | OpenType 接口表示 OpenType 和 TrueType 字体。

类摘要
FontRenderContext | FontRenderContext 类是正确测量文本所需的信息容器。
GlyphJustificationInfo | GlyphJustificationInfo 类表示关于字形调整属性的信息。
GlyphMetrics | GlyphMetrics 类表示单个字形的信息。
GlyphVector | GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。
GraphicAttribute | 此类与 CHAR_REPLACEMENT 属性一起使用。
ImageGraphicAttribute | ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。
LayoutPath | LayoutPath 提供相对于基线的位置与用户空间中的点之间的映射。
LineBreakMeasurer | LineBreakMeasurer 类允许将样式化的文本断为行（或段），以符合特定的可视 advance。
LineMetrics | LineMetrics 类允许访问沿着一行布局字符和多行布局所需要的规格。
NumericShaper | NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。
ShapeGraphicAttribute | ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。
TextAttribute | TextAttribute 类定义用于呈现文本的属性键和属性值。
TextHitInfo | TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。
TextLayout | TextLayout 是样式字符数据的不可变图形表示形式。
TextLayout.CaretPolicy | 定义确定强插入符位置的策略。
TextMeasurer | TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。
TransformAttribute | TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。

软件包 java.awt.font 的描述

提供与字体相关的类和接口。它包含对表示 Type 1、Type 1 Multiple Master 字体、OpenType 字体和 TrueType 字体的支持。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.font 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.font 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.text.AttributedCharacterIterator.Attribute (implements java.io.Serializable)
      • java.awt.font.TextAttribute
    • java.awt.font.FontRenderContext
    • java.awt.font.GlyphJustificationInfo
    • java.awt.font.GlyphMetrics
    • java.awt.font.GlyphVector (implements java.lang.Cloneable)
    • java.awt.font.GraphicAttribute
      • java.awt.font.ImageGraphicAttribute
      • java.awt.font.ShapeGraphicAttribute
    • java.awt.font.LayoutPath
    • java.awt.font.LineBreakMeasurer
    • java.awt.font.LineMetrics
    • java.awt.font.NumericShaper (implements java.io.Serializable)
    • java.awt.font.TextHitInfo
    • java.awt.font.TextLayout (implements java.lang.Cloneable)
    • java.awt.font.TextLayout.CaretPolicy
    • java.awt.font.TextMeasurer (implements java.lang.Cloneable)
    • java.awt.font.TransformAttribute (implements java.io.Serializable)

接口分层结构

  • java.awt.font.MultipleMaster
  • java.awt.font.OpenType
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.font 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.font
的使用

使用 java.awt.font 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt 使用的 java.awt.font 中的类
FontRenderContext
FontRenderContext 类是正确测量文本所需的信息容器。
GlyphVector
GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。
LineMetrics
LineMetrics 类允许访问沿着一行布局字符和多行布局所需要的规格。
TextAttribute
TextAttribute 类定义用于呈现文本的属性键和属性值。

java.awt.event 使用的 java.awt.font 中的类
TextHitInfo
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。

java.awt.font 使用的 java.awt.font 中的类
FontRenderContext
FontRenderContext 类是正确测量文本所需的信息容器。
GlyphJustificationInfo
GlyphJustificationInfo 类表示关于字形调整属性的信息。
GlyphMetrics
GlyphMetrics 类表示单个字形的信息。
GlyphVector
GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。
GraphicAttribute
此类与 CHAR_REPLACEMENT 属性一起使用。
ImageGraphicAttribute
ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。
LayoutPath
LayoutPath 提供相对于基线的位置与用户空间中的点之间的映射。
NumericShaper
NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。
ShapeGraphicAttribute
ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。
TextAttribute
TextAttribute 类定义用于呈现文本的属性键和属性值。
TextHitInfo
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。
TextLayout
TextLayout 是样式字符数据的不可变图形表示形式。
TextLayout.CaretPolicy
定义确定强插入符位置的策略。
TransformAttribute
TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。

java.awt.im 使用的 java.awt.font 中的类
TextAttribute
TextAttribute 类定义用于呈现文本的属性键和属性值。
TextHitInfo
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。

java.awt.im.spi 使用的 java.awt.font 中的类
TextHitInfo
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.GlyphJustificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GlyphJustificationInfo
的使用

使用 GlyphJustificationInfo 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 GlyphJustificationInfo 的使用

返回 GlyphJustificationInfo 的 java.awt.font 中的方法
abstract GlyphJustificationInfo | GlyphVector.getGlyphJustificationInfo(int glyphIndex) 返回此 GlyphVector 中指定索引处的字形调整信息。
GlyphJustificationInfo | GraphicAttribute.getJustificationInfo() 返回此 GraphicAttribute 的调整信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.GlyphMetrics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GlyphMetrics
的使用

使用 GlyphMetrics 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 GlyphMetrics 的使用

返回 GlyphMetrics 的 java.awt.font 中的方法
abstract  GlyphMetrics GlyphVector.getGlyphMetrics(int glyphIndex)
返回此 GlyphVector 中指定索引处的字形规格。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.GraphicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GraphicAttribute
的使用

使用 GraphicAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 GraphicAttribute 的使用

java.awt.font 中 GraphicAttribute 的子类
class | ImageGraphicAttribute ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。
class | ShapeGraphicAttribute ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.ImageGraphicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.ImageGraphicAttribute
的使用

使用 ImageGraphicAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 ImageGraphicAttribute 的使用

参数类型为 ImageGraphicAttribute 的 java.awt.font 中的方法
 boolean ImageGraphicAttribute.equals(ImageGraphicAttribute rhs)
比较此 ImageGraphicAttribute 与指定的 ImageGraphicAttribute。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.LayoutPath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.LayoutPath
的使用

使用 LayoutPath 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 LayoutPath 的使用

返回 LayoutPath 的 java.awt.font 中的方法
 LayoutPath TextLayout.getLayoutPath()
返回 LayoutPath，如果布局路径是默认路径（x 映射到 advance，y 映射到 offset），则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.LineBreakMeasurer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.LineBreakMeasurer
的使用

没有 java.awt.font.LineBreakMeasurer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.font.MultipleMaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.font.MultipleMaster
的使用

没有 java.awt.font.MultipleMaster 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.NumericShaper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.NumericShaper
的使用

使用 NumericShaper 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 NumericShaper 的使用

返回 NumericShaper 的 java.awt.font 中的方法
static NumericShaper | NumericShaper.getContextualShaper(int ranges) 返回提供的 unicode 范围的上下文成形器。
static NumericShaper | NumericShaper.getContextualShaper(int ranges, int defaultContext) 返回提供的 unicode 范围的上下文成形器。
static NumericShaper | NumericShaper.getShaper(int singleRange) 返回所提供的 unicode 范围的成形器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.font.OpenType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.font.OpenType
的使用

没有 java.awt.font.OpenType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.ShapeGraphicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.ShapeGraphicAttribute
的使用

使用 ShapeGraphicAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 ShapeGraphicAttribute 的使用

参数类型为 ShapeGraphicAttribute 的 java.awt.font 中的方法
 boolean ShapeGraphicAttribute.equals(ShapeGraphicAttribute rhs)
将此 ShapeGraphicAttribute 与指定的 ShapeGraphicAttribute 进行比较。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.TextHitInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextHitInfo
的使用

使用 TextHitInfo 的软件包
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.event 中 TextHitInfo 的使用

返回 TextHitInfo 的 java.awt.event 中的方法
TextHitInfo | InputMethodEvent.getCaret() 获取插入符。
TextHitInfo | InputMethodEvent.getVisiblePosition() 获取对于可见性至关重要的位置。

参数类型为 TextHitInfo 的 java.awt.event 中的构造方法
InputMethodEvent(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。

java.awt.font 中 TextHitInfo 的使用

返回 TextHitInfo 的 java.awt.font 中的方法
static TextHitInfo | TextHitInfo.afterOffset(int offset) 在指定偏移量处创建一个与偏移量之后的字符关联的 TextHitInfo。
static TextHitInfo | TextHitInfo.beforeOffset(int offset) 在指定偏移量处创建一个与偏移量之前的字符关联的 TextHitInfo。
TextHitInfo | TextLayout.getNextLeftHit(int offset) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextLeftHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextLeftHit(TextHitInfo hit) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(int offset) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(TextHitInfo hit) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextHitInfo.getOffsetHit(int delta) 创建一个 TextHitInfo，其字符索引从此 TextHitInfo 的 charIndex 偏移 delta。
TextHitInfo | TextHitInfo.getOtherHit() 在插入点的另一侧创建一个 TextHitInfo。
TextHitInfo | TextLayout.CaretPolicy.getStrongCaret(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout) 选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。
TextHitInfo | TextLayout.getVisualOtherHit(TextHitInfo hit) 返回位于指定目标字符插入符另一侧的目标字符。
TextHitInfo | TextLayout.hitTestChar(float x, float y) 返回对应于指定点的 TextHitInfo。
TextHitInfo | TextLayout.hitTestChar(float x, float y, Rectangle2D bounds) 返回对应于指定点的 TextHitInfo。
static TextHitInfo | TextHitInfo.leading(int charIndex) 在指定 charIndex 处的字符开始边上创建一个 TextHitInfo。
static TextHitInfo | TextHitInfo.trailing(int charIndex) 在指定 charIndex 处的字符的结尾边上创建一个 TextHitInfo。

参数类型为 TextHitInfo 的 java.awt.font 中的方法
boolean | TextHitInfo.equals(TextHitInfo hitInfo) 如果指定的 TextHitInfo 具有与此 TextHitInfo 相同的 charIndex 和 isLeadingEdge，则返回 true。
float[] | TextLayout.getCaretInfo(TextHitInfo hit) 返回与对应于 hit 的插入符有关的信息。
float[] | TextLayout.getCaretInfo(TextHitInfo hit, Rectangle2D bounds) 返回与对应于 hit 的插入符有关的信息。
Shape | TextLayout.getCaretShape(TextHitInfo hit) 返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。
Shape | TextLayout.getCaretShape(TextHitInfo hit, Rectangle2D bounds) 返回表示指定边界内指定目标字符处插入符的 Shape。
int[] | TextLayout.getLogicalRangesForVisualSelection(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回对应于可视选择范围的逻辑文本范围。
TextHitInfo | TextLayout.getNextLeftHit(TextHitInfo hit) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(TextHitInfo hit) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.CaretPolicy.getStrongCaret(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout) 选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。
TextHitInfo | TextLayout.getVisualOtherHit(TextHitInfo hit) 返回位于指定目标字符插入符另一侧的目标字符。
void | TextLayout.hitToPoint(TextHitInfo hit, Point2D point) 将一个命中点转换为标准坐标中的一个点。

java.awt.im 中 TextHitInfo 的使用

返回 TextHitInfo 的 java.awt.im 中的方法
 TextHitInfo InputMethodRequests.getLocationOffset(int x, int y)
获取撰写文本相对于屏幕上指定 x 和 y 绝对坐标的偏移量。

参数类型为 TextHitInfo 的 java.awt.im 中的方法
 Rectangle InputMethodRequests.getTextLocation(TextHitInfo offset)
获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。

java.awt.im.spi 中 TextHitInfo 的使用

参数类型为 TextHitInfo 的 java.awt.im.spi 中的方法
 void InputMethodContext.dispatchInputMethodEvent(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
根据给定的参数创建输入方法事件并将其指派到客户端组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.TextLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextLayout
的使用

使用 TextLayout 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 TextLayout 的使用

返回 TextLayout 的 java.awt.font 中的方法
TextLayout | TextLayout.getJustifiedLayout(float justificationWidth) 创建调整到指定宽度的此 TextLayout 的一个副本。
TextLayout | TextMeasurer.getLayout(int start, int limit) 返回给定字符范围上的 TextLayout。
TextLayout | LineBreakMeasurer.nextLayout(float wrappingWidth) 返回下一个布局，并更新当前位置。
TextLayout | LineBreakMeasurer.nextLayout(float wrappingWidth, int offsetLimit, boolean requireNextWord) 返回下一个布局，并更新当前位置。

参数类型为 TextLayout 的 java.awt.font 中的方法
boolean | TextLayout.equals(TextLayout rhs) 如果两个布局相等，则返回 true。
TextHitInfo | TextLayout.CaretPolicy.getStrongCaret(TextHitInfo hit1, TextHitInfo hit2, TextLayout layout) 选择一个指定的 TextHitInfo 实例作为指定 TextLayout 中的强插入符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.TextLayout.CaretPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextLayout.CaretPolicy
的使用

使用 TextLayout.CaretPolicy 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 TextLayout.CaretPolicy 的使用

声明为 TextLayout.CaretPolicy 的 java.awt.font 中的字段
static TextLayout.CaretPolicy TextLayout.DEFAULT_CARET_POLICY
客户端未指定策略时使用此 CaretPolicy。

参数类型为 TextLayout.CaretPolicy 的 java.awt.font 中的方法
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy) 返回对应于强插入符和弱插入符的两条路径。
TextHitInfo | TextLayout.getNextLeftHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符左侧（顶部）的目标字符；如果没有这样的字符，则返回 null。
TextHitInfo | TextLayout.getNextRightHit(int offset, TextLayout.CaretPolicy policy) 返回下一个插入符右侧（底部）的目标字符；如果没有这样的字符，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.TextMeasurer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextMeasurer
的使用

没有 java.awt.font.TextMeasurer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.TransformAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TransformAttribute
的使用

使用 TransformAttribute 的软件包
java.awt.font 提供与字体相关的类和接口。

java.awt.font 中 TransformAttribute 的使用

声明为 TransformAttribute 的 java.awt.font 中的字段
static TransformAttribute TransformAttribute.IDENTITY
表示恒等变换的 TransformAttribute。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.LineMetrics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.LineMetrics
的使用

使用 LineMetrics 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 LineMetrics 的使用

返回 LineMetrics 的 java.awt 中的方法
LineMetrics | Font.getLineMetrics(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, FontRenderContext frc) 返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.GlyphVector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.GlyphVector
的使用

使用 GlyphVector 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。

java.awt 中 GlyphVector 的使用

返回 GlyphVector 的 java.awt 中的方法
GlyphVector | Font.createGlyphVector(FontRenderContext frc, char[] chars) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, CharacterIterator ci) 根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, int[] glyphCodes) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, String str) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.layoutGlyphVector(FontRenderContext frc, char[] text, int start, int limit, int flags) 返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。

参数类型为 GlyphVector 的 java.awt 中的方法
abstract  void Graphics2D.drawGlyphVector(GlyphVector g, float x, float y)
使用 Graphics2D 上下文的呈现属性，呈现指定 GlyphVector 的文本。

java.awt.font 中 GlyphVector 的使用

参数类型为 GlyphVector 的 java.awt.font 中的方法
abstract  boolean GlyphVector.equals(GlyphVector set)
测试指定的 GlyphVector 是否恰好等于此 GlyphVector。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.FontRenderContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.FontRenderContext
的使用

使用 FontRenderContext 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。

java.awt 中 FontRenderContext 的使用

返回 FontRenderContext 的 java.awt 中的方法
FontRenderContext | FontMetrics.getFontRenderContext() 获取此 FontMetrics 对象用来测量文本的 FontRenderContext。
abstract FontRenderContext | Graphics2D.getFontRenderContext() 获取此 Graphics2D 上下文中 Font 的呈现上下文。

参数类型为 FontRenderContext 的 java.awt 中的方法
GlyphVector | Font.createGlyphVector(FontRenderContext frc, char[] chars) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, CharacterIterator ci) 根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, int[] glyphCodes) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, String str) 根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。
LineMetrics | Font.getLineMetrics(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, FontRenderContext frc) 返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。
LineMetrics | Font.getLineMetrics(String str, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
Rectangle2D | Font.getMaxCharBounds(FontRenderContext frc) 返回最大边界定义在 FontRenderContext 中的字符的边界。
Rectangle2D | Font.getStringBounds(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 指定字符数组的逻辑边界。
Rectangle2D | Font.getStringBounds(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
Rectangle2D | Font.getStringBounds(String str, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
Rectangle2D | Font.getStringBounds(String str, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
GlyphVector | Font.layoutGlyphVector(FontRenderContext frc, char[] text, int start, int limit, int flags) 返回一个新 GlyphVector 对象，执行完整的文本布局（如有可能）。

java.awt.font 中 FontRenderContext 的使用

返回 FontRenderContext 的 java.awt.font 中的方法
abstract  FontRenderContext GlyphVector.getFontRenderContext()
返回与此 GlyphVector 关联的 FontRenderContext。

参数类型为 FontRenderContext 的 java.awt.font 中的方法
boolean | FontRenderContext.equals(FontRenderContext rhs) 如果 rhs 具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。
Rectangle | GlyphVector.getGlyphPixelBounds(int index, FontRenderContext renderFRC, float x, float y) 返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。
Rectangle | TextLayout.getPixelBounds(FontRenderContext frc, float x, float y) 返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。
Rectangle | GlyphVector.getPixelBounds(FontRenderContext renderFRC, float x, float y) 返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。

参数类型为 FontRenderContext 的 java.awt.font 中的构造方法
LineBreakMeasurer(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
LineBreakMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
TextLayout(AttributedCharacterIterator text, FontRenderContext frc)
根据样式文本上的迭代器构造一个 TextLayout。
TextLayout(String string, Font font, FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。
TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。
TextMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
从源文本构造 TextMeasurer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.font.TextAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.font.TextAttribute
的使用

使用 TextAttribute 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。

java.awt 中 TextAttribute 的使用

返回变量类型为 TextAttribute 的类型的 java.awt 中的方法
Map<TextAttribute,?> | Font.getAttributes() 返回此 Font 中可用的字体属性的映射。
abstract Map<TextAttribute,?> | Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight) 返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。

java.awt.font 中 TextAttribute 的使用

声明为 TextAttribute 的 java.awt.font 中的字段
static TextAttribute | TextAttribute.BACKGROUND 用于呈现文本背景的 paint 的属性键。
static TextAttribute | TextAttribute.BIDI_EMBEDDING 文本嵌入级别的属性键。
static TextAttribute | TextAttribute.CHAR_REPLACEMENT 用于取代字符的字体标准字型显示的用户定义字形的属性键。
static TextAttribute | TextAttribute.FAMILY 字体名称的属性键。
static TextAttribute | TextAttribute.FONT 用于提供呈现文本字体的属性键。
static TextAttribute | TextAttribute.FOREGROUND 用于呈现文本的 paint 的属性键。
static TextAttribute | TextAttribute.INPUT_METHOD_HIGHLIGHT 用于输入法高亮显示样式的属性键。
static TextAttribute | TextAttribute.INPUT_METHOD_UNDERLINE 输入法下划线的属性键。
static TextAttribute | TextAttribute.JUSTIFICATION 段落调整的属性键。
static TextAttribute | TextAttribute.KERNING 请求进行字距调整的属性键。
static TextAttribute | TextAttribute.LIGATURES 启用可选连字的属性键。
static TextAttribute | TextAttribute.NUMERIC_SHAPING 将 ASCII 十进制数字转换为其他十进制范围数字的属性键。
static TextAttribute | TextAttribute.POSTURE 字体形态的属性键。
static TextAttribute | TextAttribute.RUN_DIRECTION 线条延伸方向的属性键。
static TextAttribute | TextAttribute.SIZE 字体大小的属性键。
static TextAttribute | TextAttribute.STRIKETHROUGH 删除线的属性键。
static TextAttribute | TextAttribute.SUPERSCRIPT 用于上标和下标的属性键。
static TextAttribute | TextAttribute.SWAP_COLORS 交换前景和背景 Paint 的属性键。
static TextAttribute | TextAttribute.TRACKING 控制跟踪的属性键。
static TextAttribute | TextAttribute.TRANSFORM 字体转换的属性键。
static TextAttribute | TextAttribute.UNDERLINE 下划线的属性键。
static TextAttribute | TextAttribute.WEIGHT 字体 weight 的属性键。
static TextAttribute | TextAttribute.WIDTH 字体宽度的属性键。

java.awt.im 中 TextAttribute 的使用

返回变量类型为 TextAttribute 的类型的 java.awt.im 中的方法
 Map<TextAttribute,?> InputMethodHighlight.getStyle()
返回文本范围的呈现样式属性，或 null。

类型变量类型为 TextAttribute 的 java.awt.im 中的构造方法参数
InputMethodHighlight(boolean selected, int state, int variation, Map<TextAttribute,?> style)
构造输入方法高亮显示记录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AffineTransform (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 AffineTransform

java.lang.Object
    继承者  java.awt.geom.AffineTransform
所有已实现的接口：
Serializable, Cloneable
public class AffineTransform
extends Object
implements Cloneable, Serializable

AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。可以使用一系列平移 (translation)、缩放 (scale)、翻转 (flip)、旋转 (rotation) 和错切 (shear) 来构造仿射变换。

这样的坐标变换可以使用一个 3 行乘 3 列的矩阵来表示，最后一行默认为 [ 0 0 1 ]。此矩阵将源坐标 (x,y) 变换为目标坐标 (x',y')，这一过程将坐标视为列向量，并用矩阵乘以坐标向量，步骤如下：

        [ x']   [  m00  m01  m02  ] [ x ]   [ m00x + m01y + m02 ]
        [ y'] = [  m10  m11  m12  ] [ y ] = [ m10x + m11y + m12 ]
        [ 1 ]   [   0    0    1   ] [ 1 ]   [         1         ]

处理 90 度旋转

在 AffineTransform 类的 rotate 方法的一些变量中，双精度参数指定了以弧度表示的旋转角度。这些方法为近似 90 度（包括倍数诸如 180、270 和 360 度）的旋转提供特殊的处理，以便更有效地处理象限旋转这类常见情形。这种特殊处理可以导致旋转角度非常接近于 90 度的倍数，从而可以将其视为正好是 90 度的倍数。对于 90 度的小倍数，被视为象限旋转的角度范围大约是 0.00000121 度宽。这一节解释为什么需要特别小心以及如何实现它。

因为 90 度用弧度表示是 PI/2，而 PI 是无限不循环小数（因此是无理数），所以它不能像用弧度表示的精确双精度值那样准确地表示 90 度的倍数。因此，理论上不可以使用 PI 来描述象限旋转（90、180、270 或 360 度）。双精度浮点值可以非常接近 PI/2 的非零倍数，但是不够接近到正弦或余弦能精确到 0.0、1.0 或 -1.0。只有在 Math.sin(0.0) 的情况下，Math.sin() 和 Math.cos() 实现才相应地返回 0.0。但是，对于接近每个 90 度倍数的某些范围内的数，相样的实现却返回 1.0 和 -1.0，因为正确答案是如此接近 1.0 或 -1.0，以至于双精度的有效位数无法像表示接近 0.0 的数那样精确地表示差值。

这些问题归结为：如果在执行这些基于弧度的旋转操作期间，使用 Math.sin() 和 Math.cos() 方法直接生成用于矩阵修改的值，那么严格来说，得到的变换不能归类为象限旋转（即使对于 rotate(Math.PI/2.0) 这样的简单情况也是如此），因为执行正弦和余弦操作而得到的非 0.0 值将造成矩阵的细微变化。如果这些变换不能归类为象限旋转，那么试图根据变换类型优化下一步操作的后续代码会被移交到它最通用的实现中。

因为象限旋转相当常见，所以在对变换应用旋转和对坐标应用所得变换时，此类应该快速合理地处理这些情况。为了达到最佳处理，以弧度为单位测量旋转角度的方法试图检测象限旋转的角度并以这种方式处理它们。因此，如果 Math.sin(theta) 或 Math.cos(theta) 正好返回 1.0 或 -1.0，那么这些方法会将角度 theta 视为象限旋转。实际经验证明，此特性可用于 Math.PI/2.0 的小倍数大约 0.0000000211 弧度（0.00000121 度）的范围。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
static int | TYPE_FLIP 此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行关于某个坐标轴的镜像翻转操作，此操作将通常的右旋坐标系更改为左旋坐标系。
static int | TYPE_GENERAL_ROTATION 此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行任意角度的旋转操作。
static int | TYPE_GENERAL_SCALE 此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行常规缩放操作。
static int | TYPE_GENERAL_TRANSFORM 此常量指示此对象定义的变换执行输入坐标的任意转换操作。
static int | TYPE_IDENTITY 此常量指示此对象定义的变换是恒等变换。
static int | TYPE_MASK_ROTATION 此常量是所有旋转标志位的位掩码。
static int | TYPE_MASK_SCALE 此常量是所有缩放标志位的位掩码。
static int | TYPE_QUADRANT_ROTATION 此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还通过乘以 90 度的某个倍数执行象限旋转操作。
static int | TYPE_TRANSLATION 此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行平移操作。
static int | TYPE_UNIFORM_SCALE 此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行统一缩放操作。
构造方法摘要
AffineTransform()
构造一个表示恒等变换的新 AffineTransform。
AffineTransform(AffineTransform Tx)
构造一个新 AffineTransform，让它作为指定 AffineTransform 对象的副本。
AffineTransform(double[] flatmatrix)
根据双精度值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示它的 6 个可指定条目。
AffineTransform(double m00, double m10, double m01, double m11, double m02, double m12)
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个双精度值构造一个新 AffineTransform。
AffineTransform(float[] flatmatrix)
根据一个浮点值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示 3x3 变换矩阵的 6 个可指定条目。
AffineTransform(float m00, float m10, float m01, float m11, float m02, float m12)
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个浮点值构造一个新 AffineTransform。
方法摘要
Object | clone() 返回此 AffineTransform 对象的副本。
void | concatenate(AffineTransform Tx) 以最常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，以提供由 Tx 映射到以前用户空间的新用户空间。
AffineTransform | createInverse() 返回表示逆向变换的 AffineTransform 对象。
Shape | createTransformedShape(Shape pSrc) 返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。
void | deltaTransform(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts) 通过此变换来变换相对距离向量数组。
Point2D | deltaTransform(Point2D ptSrc, Point2D ptDst) 变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。
boolean | equals(Object obj) 如果此 AffineTransform 表示与指定参数相同的仿射坐标变换，则返回 true。
double | getDeterminant() 返回变换的矩阵表示形式的决定因子。
void | getMatrix(double[] flatmatrix) 在 3x3 仿射变换矩阵中检索 6 个可指定值，并将其置于双精度值的数组中。
static AffineTransform | getQuadrantRotateInstance(int numquadrants) 返回按指定象限数旋转坐标的变换。
static AffineTransform | getQuadrantRotateInstance(int numquadrants, double anchorx, double anchory) 返回按指定象限数绕指定锚点旋转坐标的变换。
static AffineTransform | getRotateInstance(double theta) 返回表示旋转变换的变换。
static AffineTransform | getRotateInstance(double vecx, double vecy) 返回根据旋转向量旋转坐标的变换。
static AffineTransform | getRotateInstance(double theta, double anchorx, double anchory) 返回绕锚点旋转坐标的变换。
static AffineTransform | getRotateInstance(double vecx, double vecy, double anchorx, double anchory) 返回根据旋转向量绕锚点坐标旋转坐标的变换。
static AffineTransform | getScaleInstance(double sx, double sy) 返回表示缩放变换的变换。
double | getScaleX() 返回 3x3 仿射变换矩阵缩放元素 (m00) 的 X 坐标。
double | getScaleY() 返回 3x3 仿射变换矩阵缩放元素 (m11) 的 Y 坐标。
static AffineTransform | getShearInstance(double shx, double shy) 返回表示错切变换的变换。
double | getShearX() 返回 3x3 仿射变换矩阵错切元素 (m01) 的 X 坐标。
double | getShearY() 返回 3x3 仿射变换矩阵错切元素 (m10) 的 Y 坐标。
static AffineTransform | getTranslateInstance(double tx, double ty) 返回表示平移变换的变换。
double | getTranslateX() 返回 3x3 仿射变换矩阵平移元素 (m02) 的 X 坐标。
double | getTranslateY() 返回 3x3 仿射变换矩阵平移元素 (m12) 的 Y 坐标。
int | getType() 检索描述此变换的变换属性的标志位。
int | hashCode() 返回此变换的哈希码。
void | inverseTransform(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts) 通过此变换来逆向变换双精度坐标数组。
Point2D | inverseTransform(Point2D ptSrc, Point2D ptDst) 逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
void | invert() 将此变换设置为它自身的逆变换。
boolean | isIdentity() 如果此 AffineTransform 是恒等变换，则返回 true。
void | preConcatenate(AffineTransform Tx) 以不常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，从而 Tx 相对于绝对像素空间（而非相对于现有用户空间）修改坐标变换。
void | quadrantRotate(int numquadrants) 连接此变换与按照指定象限数旋转坐标的变换。
void | quadrantRotate(int numquadrants, double anchorx, double anchory) 连接此变换与按指定象限数绕指定锚点旋转坐标的变换。
void | rotate(double theta) 连接此变换与旋转变换。
void | rotate(double vecx, double vecy) 连接此变换与根据旋转向量旋转坐标的变换。
void | rotate(double theta, double anchorx, double anchory) 连接此变换与绕锚点旋转坐标的变换。
void | rotate(double vecx, double vecy, double anchorx, double anchory) 连接此变换与根据旋转向量绕锚点旋转坐标的变换。
void | scale(double sx, double sy) 连接此变换与缩放变换。
void | setToIdentity() 将此变换重置为恒等变换。
void | setToQuadrantRotation(int numquadrants) 将此变换设置为按指定象限数旋转坐标的旋转变换。
void | setToQuadrantRotation(int numquadrants, double anchorx, double anchory) 将此变换设置为按指定象限数绕指定锚点旋转坐标的平移旋转变换。
void | setToRotation(double theta) 将此变换设置为旋转变换。
void | setToRotation(double vecx, double vecy) 将此变换设置为根据旋转向量旋转坐标的旋转变换。
void | setToRotation(double theta, double anchorx, double anchory) 将此变换设置为平移的旋转变换。
void | setToRotation(double vecx, double vecy, double anchorx, double anchory) 将此变换设置为根据旋转向量绕锚点旋转坐标的旋转变换。
void | setToScale(double sx, double sy) 将此变换设置为缩放变换。
void | setToShear(double shx, double shy) 将此变换设置为错切变换。
void | setToTranslation(double tx, double ty) 将此变换设置为平移变换。
void | setTransform(AffineTransform Tx) 将此变换设置为指定 AffineTransform 对象中变换的副本。
void | setTransform(double m00, double m10, double m01, double m11, double m02, double m12) 将此变换设置为 6 个双精度值指定的矩阵。
void | shear(double shx, double shy) 连接此变换与错切变换。
String | toString() 返回表示此 Object 值的 String。
void | transform(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts) 通过此变换来变换双精度坐标数组。
void | transform(double[] srcPts, int srcOff, float[] dstPts, int dstOff, int numPts) 通过此变换来变换双精度坐标数组，并将结果存储在 float 数组中。
void | transform(float[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts) 通过此变换来变换浮点坐标数组，并将结果存储在 double 数组中。
void | transform(float[] srcPts, int srcOff, float[] dstPts, int dstOff, int numPts) 通过此变换来变换浮点坐标数组。
void | transform(Point2D[] ptSrc, int srcOff, Point2D[] ptDst, int dstOff, int numPts) 通过此变换来变换点对象数组。
Point2D | transform(Point2D ptSrc, Point2D ptDst) 变换指定的 ptSrc 并将结果存储在 ptDst 中。
void | translate(double tx, double ty) 连接此变换与平移变换。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TYPE_IDENTITY

public static final int TYPE_IDENTITY
此常量指示此对象定义的变换是恒等变换。恒等变换是一种输出坐标始终与输入坐标相同的变换。如果此变换不是恒等变换，则类型要么是常量 GENERAL_TRANSFORM，要么是此变换执行的不同坐标转换的适当标志位的组合。

从以下版本开始：
1.2
另请参见：
TYPE_TRANSLATION, TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, TYPE_FLIP, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, TYPE_GENERAL_TRANSFORM, getType(), 常量字段值

TYPE_TRANSLATION

public static final int TYPE_TRANSLATION
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行平移操作。平移按照常量 x 和 y 移动坐标，不改变向量的长度和角度。

从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, TYPE_FLIP, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, TYPE_GENERAL_TRANSFORM, getType(), 常量字段值

TYPE_UNIFORM_SCALE

public static final int TYPE_UNIFORM_SCALE
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行统一缩放操作。统一缩放在 x 和 y 方向上使用相同的量乘以向量的长度，不改变向量之间的角度。此标志位与 TYPE_GENERAL_SCALE 标志互斥。

从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_TRANSLATION, TYPE_GENERAL_SCALE, TYPE_FLIP, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, TYPE_GENERAL_TRANSFORM, getType(), 常量字段值

TYPE_GENERAL_SCALE

public static final int TYPE_GENERAL_SCALE
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行常规缩放操作。常规缩放在 x 和 y 方向上使用不同的量乘以向量的长度，不改变垂直向量之间的角度。此标志位与 TYPE_UNIFORM_SCALE 标志互斥。

从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_TRANSLATION, TYPE_UNIFORM_SCALE, TYPE_FLIP, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, TYPE_GENERAL_TRANSFORM, getType(), 常量字段值

TYPE_MASK_SCALE

public static final int TYPE_MASK_SCALE
此常量是所有缩放标志位的位掩码。

从以下版本开始：
1.2
另请参见：
TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, 常量字段值

TYPE_FLIP

public static final int TYPE_FLIP
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行关于某个坐标轴的镜像翻转操作，此操作将通常的右旋坐标系更改为左旋坐标系。右旋坐标系按逆时针方向旋转 X 正半轴能覆盖 Y 正半轴，类似于凝视右手拇指末端时其余手指弯曲的方向。左旋坐标系按顺时针方向旋转 X 正半轴能覆盖 Y 正半轴，类似于左手手指弯曲的方向。不存在确定初始反转或镜像变换角度的数学方式，因为给定适当的调整旋转后，翻转的所有角度都相同。

从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_TRANSLATION, TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, TYPE_GENERAL_TRANSFORM, getType(), 常量字段值

TYPE_QUADRANT_ROTATION

public static final int TYPE_QUADRANT_ROTATION
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还通过乘以 90 度的某个倍数执行象限旋转操作。旋转按相同的量更改向量的角度，不管向量的初始方向如何，也不改变向量的长度。此标志位与 TYPE_GENERAL_ROTATION 标志互斥。

从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_TRANSLATION, TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, TYPE_FLIP, TYPE_GENERAL_ROTATION, TYPE_GENERAL_TRANSFORM, getType(), 常量字段值

TYPE_GENERAL_ROTATION

public static final int TYPE_GENERAL_ROTATION
此标志位指示此对象定义的变换除了执行其他标志位指示的转换外，还执行任意角度的旋转操作。旋转按相同的量更改向量的角度，不管向量的初始方向如何，也不改变向量的长度。此标志位与 TYPE_QUADRANT_ROTATION 标志互斥。

从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_TRANSLATION, TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, TYPE_FLIP, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_TRANSFORM, getType(), 常量字段值

TYPE_MASK_ROTATION

public static final int TYPE_MASK_ROTATION
此常量是所有旋转标志位的位掩码。

从以下版本开始：
1.2
另请参见：
TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, 常量字段值

TYPE_GENERAL_TRANSFORM

public static final int TYPE_GENERAL_TRANSFORM
此常量指示此对象定义的变换执行输入坐标的任意转换操作。如果此变换能归类为上述任意一种常量，则类型要么是常量 TYPE_IDENTITY，要么是此变换所执行的各种坐标转换的适当标志位。

从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_TRANSLATION, TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, TYPE_FLIP, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, getType(), 常量字段值
构造方法详细信息

AffineTransform

public AffineTransform()
构造一个表示恒等变换的新 AffineTransform。

从以下版本开始：
1.2

AffineTransform

public AffineTransform(AffineTransform Tx)
构造一个新 AffineTransform，让它作为指定 AffineTransform 对象的副本。

参数：
Tx - 要复制的 AffineTransform 对象
从以下版本开始：
1.2

AffineTransform

public AffineTransform(float m00,
                       float m10,
                       float m01,
                       float m11,
                       float m02,
                       float m12)
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个浮点值构造一个新 AffineTransform。

参数：
m00 - 3x3 矩阵缩放元素的 X 坐标
m10 - 3x3 矩阵剪切元素的 Y 坐标
m01 - 3x3 矩阵剪切元素的 X 坐标
m11 - 3x3 矩阵缩放元素的 Y 坐标
m02 - 3x3 矩阵平移元素的 X 坐标
m12 - 3x3 矩阵平移元素的 Y 坐标
从以下版本开始：
1.2

AffineTransform

public AffineTransform(float[] flatmatrix)
根据一个浮点值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示 3x3 变换矩阵的 6 个可指定条目。从该数组中检索到的值为 { m00 m10 m01 m11 [m02 m12]}。

参数：
flatmatrix - float 数组，包含要在新 AffineTransform 对象中设置的值。假定数组的长度至少为 4。如果数组的长度小于 6，则仅采用前 4 个值。如果数组的长度大于 6，则采用前 6 个值。
从以下版本开始：
1.2

AffineTransform

public AffineTransform(double m00,
                       double m10,
                       double m01,
                       double m11,
                       double m02,
                       double m12)
根据表示 3x3 变换矩阵 6 个可指定条目的 6 个双精度值构造一个新 AffineTransform。

参数：
m00 - 3x3 矩阵缩放元素的 X 坐标
m10 - 3x3 矩阵剪切元素的 Y 坐标
m01 - 3x3 矩阵剪切元素的 X 坐标
m11 - 3x3 矩阵缩放元素的 Y 坐标
m02 - 3x3 矩阵平移元素的 X 坐标
m12 - 3x3 矩阵平移元素的 Y 坐标
从以下版本开始：
1.2

AffineTransform

public AffineTransform(double[] flatmatrix)
根据双精度值数组构造一个新 AffineTransform，该数组要么表示 3x3 变换矩阵的 4 个非平移条目，要么表示它的 6 个可指定条目。从该数组中检索到的值为 { m00 m10 m01 m11 [m02 m12]}。

参数：
flatmatrix - double 数组，包含要在新 AffineTransform 对象中设置的值。假定数组的长度至少为 4。如果数组的长度小于 6，则仅采用前 4 个值。如果数组的长度大于 6，则采用前 6 个值。
从以下版本开始：
1.2
方法详细信息

getTranslateInstance

public static AffineTransform getTranslateInstance(double tx,
                                                   double ty)
返回表示平移变换的变换。表示返回变换的矩阵是：
                [   1    0    tx  ]
                [   0    1    ty  ]
                [   0    0    1   ]

参数：
tx - 坐标在 X 轴方向上平移的距离
ty - 坐标在 Y 轴方向上平移的距离
返回：
表示平移变换的 AffineTransform 对象，该对象是使用指定向量创建的。
从以下版本开始：
1.2

getRotateInstance

public static AffineTransform getRotateInstance(double theta)
返回表示旋转变换的变换。表示返回变换的矩阵是：
                [   cos(theta)    -sin(theta)    0   ]
                [   sin(theta)     cos(theta)    0   ]
                [       0              0         1   ]
用正角度 theta 进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。还要注意上文处理 90 度旋转的讨论。

参数：
theta - 用弧度测量的旋转角度
返回：
使用指定旋转角度创建的、作为旋转变换的 AffineTransform 对象。
从以下版本开始：
1.2

getRotateInstance

public static AffineTransform getRotateInstance(double theta,
                                                double anchorx,
                                                double anchory)
返回绕锚点旋转坐标的变换。此操作等效于：平移坐标，使锚点位于原点 (S1)，然后绕新原点 (S2) 旋转它们，最后再平移，将中间原点恢复为初始锚点 (S3) 的坐标。

此操作等效于以下调用序列：

AffineTransform Tx = new AffineTransform();
Tx.translate(anchorx, anchory);    // S3:final translation
Tx.rotate(theta);                     // S2:rotate around anchor
Tx.translate(-anchorx, -anchory);  // S1:translate anchor to origin
表示返回变换的矩阵是：
                [   cos(theta)    -sin(theta)    x-x*cos+y*sin  ]
                [   sin(theta)     cos(theta)    y-x*sin-y*cos  ]
                [       0              0               1        ]
用正角度 theta 进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。还要注意上文处理 90 度旋转的讨论。

参数：
theta - 用弧度测量的旋转角度
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
返回：
按指定的旋转角度绕指定点旋转坐标的 AffineTransform 对象。
从以下版本开始：
1.2

getRotateInstance

public static AffineTransform getRotateInstance(double vecx,
                                                double vecy)
返回根据旋转向量旋转坐标的变换。所有坐标以相同的量绕原点旋转。旋转量使沿原 X 轴正半轴的坐标随后将与从坐标原点指向指定向量坐标的向量对齐。如果 vecx 和 vecy 都是 0.0，则返回一个恒等变换。此操作等效于调用：
AffineTransform.getRotateInstance(Math.atan2(vecy, vecx));

参数：
vecx - 旋转向量的 X 坐标
vecy - 旋转向量的 Y 坐标
返回：
根据指定旋转向量旋转坐标的 AffineTransform 对象。
从以下版本开始：
1.6

getRotateInstance

public static AffineTransform getRotateInstance(double vecx,
                                                double vecy,
                                                double anchorx,
                                                double anchory)
返回根据旋转向量绕锚点坐标旋转坐标的变换。所有坐标按相同的量绕指定的锚坐标旋转。旋转量使沿原 X 轴正半轴的坐标随后将与从坐标原点指向指定向量坐标的向量对齐。如果 vecx 和 vecy 都是 0.0，则返回一个恒等变换。此操作等效于调用：
AffineTransform.getRotateInstance(Math.atan2(vecy, vecx),
anchorx, anchory);

参数：
vecx - 旋转向量的 X 坐标
vecy - 旋转向量的 Y 坐标
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
返回：
根据指定旋转向量绕指定点旋转坐标的 AffineTransform 对象。
从以下版本开始：
1.6

getQuadrantRotateInstance

public static AffineTransform getQuadrantRotateInstance(int numquadrants)
返回按指定象限数旋转坐标的变换。此操作等效于调用：
AffineTransform.getRotateInstance(numquadrants * Math.PI / 2.0);
用正象限数进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。

参数：
numquadrants - 要旋转的 90 度弧数
返回：
按指定象限数旋转坐标的 AffineTransform 对象。
从以下版本开始：
1.6

getQuadrantRotateInstance

public static AffineTransform getQuadrantRotateInstance(int numquadrants,
                                                        double anchorx,
                                                        double anchory)
返回按指定象限数绕指定锚点旋转坐标的变换。此操作等效于调用：
AffineTransform.getRotateInstance(numquadrants * Math.PI / 2.0,
anchorx, anchory);
用正象限数进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。

参数：
numquadrants - 要旋转的 90 度弧数
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
返回：
按指定的象限数绕指定的锚点旋转坐标的 AffineTransform 对象。
从以下版本开始：
1.6

getScaleInstance

public static AffineTransform getScaleInstance(double sx,
                                               double sy)
返回表示缩放变换的变换。表示返回变换的矩阵是：
                [   sx   0    0   ]
                [   0    sy   0   ]
                [   0    0    1   ]

参数：
sx - 坐标沿 X 轴方向缩放的因子
sy - 坐标沿 Y 轴方向缩放的因子
返回：
按指定因子缩放坐标的 AffineTransform 对象。
从以下版本开始：
1.2

getShearInstance

public static AffineTransform getShearInstance(double shx,
                                               double shy)
返回表示错切变换的变换。表示返回变换的矩阵是：
                [   1   shx   0   ]
                [  shy   1    0   ]
                [   0    0    1   ]

参数：
shx - 坐标在 X 正半轴方向上进行位移的乘数，与其 Y 坐标的因子一样
shy - 坐标在 Y 正半轴方向上进行位移的乘数，与其 X 坐标的因子一样
返回：
按指定乘数错切坐标的 AffineTransform 对象。
从以下版本开始：
1.2

getType

public int getType()
检索描述此变换的变换属性的标志位。返回值要么是常量 TYPE_IDENTITY 或 TYPE_GENERAL_TRANSFORM 中的一个，要么是适当标志位的组合。标志位的有效组合是一个异或操作，该操作除了组合 TYPE_UNIFORM_SCALE 或 TYPE_GENERAL_SCALE 标志位以及 TYPE_QUADRANT_ROTATION 或 TYPE_GENERAL_ROTATION 标志位之外，还可以组合 TYPE_TRANSLATION 标志位。

返回：
应用于此变换的所有指示标志的 OR 组合
从以下版本开始：
1.2
另请参见：
TYPE_IDENTITY, TYPE_TRANSLATION, TYPE_UNIFORM_SCALE, TYPE_GENERAL_SCALE, TYPE_QUADRANT_ROTATION, TYPE_GENERAL_ROTATION, TYPE_GENERAL_TRANSFORM

getDeterminant

public double getDeterminant()
返回变换的矩阵表示形式的决定因子。决定因子用于确定变换是否可逆，以及获取表示变换的组合 X 和 Y 缩放的单个值。

如果决定因子非零，则此变换是可逆的，依赖于此逆向变换的各种方法均无需抛出 NoninvertibleTransformException。如果决定因子为零，则此变换是不可逆的，因为变换将所有输入坐标映射到线或点上。如果决定因子非常接近零，则逆向变换操作可能不够精确，无法生成有意义结果。

如果像 getType 方法指示的那样，此变换表示统一缩放，则决定因子还表示统一缩放因子的平方。所有点都通过该缩放因子从原点展开或向原点收缩。如果此变换表示非统一缩放或较通用的变换，则决定因子只表示确定逆向变换是否可能，而不表示除此之外任何有用值。

在数学上，使用以下公式计算决定因子：

                |  m00  m01  m02  |
                |  m10  m11  m12  |  =  m00 * m11 - m01 * m10
                |   0    0    1   |

返回：
用于变换坐标的矩阵的决定因子。
从以下版本开始：
1.2
另请参见：
getType(),
createInverse(),
inverseTransform(java.awt.geom.Point2D, java.awt.geom.Point2D),
TYPE_UNIFORM_SCALE

getMatrix

public void getMatrix(double[] flatmatrix)
在 3x3 仿射变换矩阵中检索 6 个可指定值，并将其置于双精度值的数组中。值将以 { m00 m10 m01 m11 m02 m12 } 形式存储到该数组中。也可以指定包含 4 个 double 值的数组，在这种情况下，仅检索表示数组中非变换部分的前四个元素，并将值以 { m00 m10 m01 m11 } 的形式存储到数组中。

参数：
flatmatrix - 用于存储返回值的 double 数组。
从以下版本开始：
1.2
另请参见：
getScaleX(),
getScaleY(),
getShearX(),
getShearY(),
getTranslateX(),
getTranslateY()

getScaleX

public double getScaleX()
返回 3x3 仿射变换矩阵缩放元素 (m00) 的 X 坐标。

返回：
作为仿射变换矩阵缩放元素的 X 坐标的 double 值。
从以下版本开始：
1.2
另请参见：
getMatrix(double[])

getScaleY

public double getScaleY()
返回 3x3 仿射变换矩阵缩放元素 (m11) 的 Y 坐标。

返回：
作为仿射变换矩阵缩放元素的 Y 坐标的 double 值。
从以下版本开始：
1.2
另请参见：
getMatrix(double[])

getShearX

public double getShearX()
返回 3x3 仿射变换矩阵错切元素 (m01) 的 X 坐标。

返回：
作为仿射变换矩阵错切元素的 X 坐标的 double 值。
从以下版本开始：
1.2
另请参见：
getMatrix(double[])

getShearY

public double getShearY()
返回 3x3 仿射变换矩阵错切元素 (m10) 的 Y 坐标。

返回：
作为仿射变换矩阵错切元素的 Y 坐标的 double 值。
从以下版本开始：
1.2
另请参见：
getMatrix(double[])

getTranslateX

public double getTranslateX()
返回 3x3 仿射变换矩阵平移元素 (m02) 的 X 坐标。

返回：
作为仿射变换矩阵平移元素的 X 坐标的 double 值。
从以下版本开始：
1.2
另请参见：
getMatrix(double[])

getTranslateY

public double getTranslateY()
返回 3x3 仿射变换矩阵平移元素 (m12) 的 Y 坐标。

返回：
作为仿射变换矩阵平移元素的 Y 坐标的 double 值。
从以下版本开始：
1.2
另请参见：
getMatrix(double[])

translate

public void translate(double tx,
                      double ty)
连接此变换与平移变换。这等效于调用 concatenate(T)，其中 T 为 AffineTransform，由以下矩阵表示：
                [   1    0    tx  ]
                [   0    1    ty  ]
                [   0    0    1   ]

参数：
tx - 坐标在 X 轴方向上平移的距离
ty - 坐标在 Y 轴方向上平移的距离
从以下版本开始：
1.2

rotate

public void rotate(double theta)
连接此变换与旋转变换。这等效于调用 concatenate(R)，其中 R 为 AffineTransform，由以下矩阵表示：
                [   cos(theta)    -sin(theta)    0   ]
                [   sin(theta)     cos(theta)    0   ]
                [       0              0         1   ]
用正角度 theta 进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。还要注意上文处理 90 度旋转的讨论。

参数：
theta - 用弧度测量的旋转角度
从以下版本开始：
1.2

rotate

public void rotate(double theta,
                   double anchorx,
                   double anchory)
连接此变换与绕锚点旋转坐标的变换。此操作等效于：平移坐标，使锚点位于原点 (S1)，然后绕新原点 (S2) 旋转它们，最后再平移，将中间原点恢复为初始锚点 (S3) 的坐标。

此操作等效于以下调用序列：

translate(anchorx, anchory);      // S3:final translation
rotate(theta);                    // S2:rotate around anchor
translate(-anchorx, -anchory);    // S1:translate anchor to origin
用正角度 theta 进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。还要注意上文处理 90 度旋转的讨论。

参数：
theta - 用弧度测量的旋转角度
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
从以下版本开始：
1.2

rotate

public void rotate(double vecx,
                   double vecy)
连接此变换与根据旋转向量旋转坐标的变换。所有坐标按相同的量绕原点旋转。旋转量使沿原 X 轴正半轴的坐标随后将与从坐标原点指向指定向量坐标的向量对齐。如果 vecx 和 vecy 都是 0.0，则没有附加的旋转添加到此变换。此操作等效于调用：
rotate(Math.atan2(vecy, vecx));

参数：
vecx - 旋转向量的 X 坐标
vecy - 旋转向量的 Y 坐标
从以下版本开始：
1.6

rotate

public void rotate(double vecx,
                   double vecy,
                   double anchorx,
                   double anchory)
连接此变换与根据旋转向量绕锚点旋转坐标的变换。所有坐标按相同的量绕指定的锚坐标旋转。旋转量使沿原 X 轴正半轴的坐标随后将与从坐标原点指向指定向量坐标的向量对齐。如果 vecx 和 vecy 都是 0.0，则不以任何方式修改此变换。此方法等效于调用：
rotate(Math.atan2(vecy, vecx), anchorx, anchory);

参数：
vecx - 旋转向量的 X 坐标
vecy - 旋转向量的 Y 坐标
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
从以下版本开始：
1.6

quadrantRotate

public void quadrantRotate(int numquadrants)
连接此变换与按照指定象限数旋转坐标的变换。此方法等效于调用：
rotate(numquadrants * Math.PI / 2.0);
用正象限数进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。

参数：
numquadrants - 要旋转的 90 度弧数
从以下版本开始：
1.6

quadrantRotate

public void quadrantRotate(int numquadrants,
                           double anchorx,
                           double anchory)
连接此变换与按指定象限数绕指定锚点旋转坐标的变换。此方法等效于调用：
rotate(numquadrants * Math.PI / 2.0, anchorx, anchory);
用正象限数进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。

参数：
numquadrants - 要旋转的 90 度弧数
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
从以下版本开始：
1.6

scale

public void scale(double sx,
                  double sy)
连接此变换与缩放变换。这等效于调用 concatenate(S)，其中 S 为 AffineTransform，由以下矩阵表示：
                [   sx   0    0   ]
                [   0    sy   0   ]
                [   0    0    1   ]

参数：
sx - 坐标沿 X 轴方向缩放的因子
sy - 坐标沿 Y 轴方向缩放的因子
从以下版本开始：
1.2

shear

public void shear(double shx,
                  double shy)
连接此变换与错切变换。这等效于调用 concatenate(SH)，其中 SH 为 AffineTransform，由以下矩阵表示：
                [   1   shx   0   ]
                [  shy   1    0   ]
                [   0    0    1   ]

参数：
shx - 坐标在正 X 轴方向上进行位移的乘数，与其 Y 坐标的因子一样
shy - 坐标在正 Y 轴方向上进行位移的乘数，与其 X 坐标的因子一样
从以下版本开始：
1.2

setToIdentity

public void setToIdentity()
将此变换重置为恒等变换。

从以下版本开始：
1.2

setToTranslation

public void setToTranslation(double tx,
                             double ty)
将此变换设置为平移变换。表示此变换的矩阵将变成：
                [   1    0    tx  ]
                [   0    1    ty  ]
                [   0    0    1   ]

参数：
tx - 坐标在 X 轴方向上平移的距离
ty - 坐标在 Y 轴方向上平移的距离
从以下版本开始：
1.2

setToRotation

public void setToRotation(double theta)
将此变换设置为旋转变换。表示此变换的矩阵将变成：
                [   cos(theta)    -sin(theta)    0   ]
                [   sin(theta)     cos(theta)    0   ]
                [       0              0         1   ]
用正角度 theta 进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。还要注意上文处理 90 度旋转的讨论。

参数：
theta - 用弧度测量的旋转角度
从以下版本开始：
1.2

setToRotation

public void setToRotation(double theta,
                          double anchorx,
                          double anchory)
将此变换设置为平移的旋转变换。此操作等效于：平移坐标，使锚点位于原点 (S1)，然后绕新原点 (S2) 旋转它们，最后再平移，将中间原点恢复为初始锚点 (S3) 的坐标。

此操作等效于以下调用序列：

setToTranslation(anchorx, anchory); // S3:final translation
rotate(theta);                      // S2:rotate around anchor
translate(-anchorx, -anchory);      // S1:translate anchor to origin
表示此变换的矩阵将变成：
                [   cos(theta)    -sin(theta)    x-x*cos+y*sin  ]
                [   sin(theta)     cos(theta)    y-x*sin-y*cos  ]
                [       0              0               1        ]
用正角度 theta 进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。还要注意上文处理 90 度旋转的讨论。

参数：
theta - 用弧度测量的旋转角度
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
从以下版本开始：
1.2

setToRotation

public void setToRotation(double vecx,
                          double vecy)
将此变换设置为根据旋转向量旋转坐标的旋转变换。所有坐标按相同的量绕原点旋转。旋转量使沿原 X 轴正半轴的坐标随后将与从坐标原点指向指定向量坐标的向量对齐。如果 vecx 和 vecy 都是 0.0，则将该变换设置为恒等变换。此操作等效于调用：
setToRotation(Math.atan2(vecy, vecx));

参数：
vecx - 旋转向量的 X 坐标
vecy - 旋转向量的 Y 坐标
从以下版本开始：
1.6

setToRotation

public void setToRotation(double vecx,
                          double vecy,
                          double anchorx,
                          double anchory)
将此变换设置为根据旋转向量绕锚点旋转坐标的旋转变换。所有坐标按相同的量绕指定的锚坐标旋转。旋转量使沿原 X 轴正半轴的坐标随后将与从坐标原点指向指定向量坐标的向量对齐。如果 vecx 和 vecy 都是 0.0，则将该变换设置为恒等变换。此操作等效于调用：
setToTranslation(Math.atan2(vecy, vecx), anchorx, anchory);

参数：
vecx - 旋转向量的 X 坐标
vecy - 旋转向量的 Y 坐标
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
从以下版本开始：
1.6

setToQuadrantRotation

public void setToQuadrantRotation(int numquadrants)
将此变换设置为按指定象限数旋转坐标的旋转变换。此操作等效于调用：
setToRotation(numquadrants * Math.PI / 2.0);
用正象限数进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。

参数：
numquadrants - 要旋转的 90 度弧数
从以下版本开始：
1.6

setToQuadrantRotation

public void setToQuadrantRotation(int numquadrants,
                                  double anchorx,
                                  double anchory)
将此变换设置为按指定象限数绕指定锚点旋转坐标的平移旋转变换。此操作等效于调用：
setToRotation(numquadrants * Math.PI / 2.0, anchorx, anchory);
用正象限数进行的旋转将 X 正半轴上的点向 Y 正半轴旋转。

参数：
numquadrants - 要旋转的 90 度弧数
anchorx - 旋转锚点的 X 坐标
anchory - 旋转锚点的 Y 坐标
从以下版本开始：
1.6

setToScale

public void setToScale(double sx,
                       double sy)
将此变换设置为缩放变换。表示此变换的矩阵将变成：
                [   sx   0    0   ]
                [   0    sy   0   ]
                [   0    0    1   ]

参数：
sx - 坐标沿 X 轴方向缩放的因子
sy - 坐标沿 Y 轴方向缩放的因子
从以下版本开始：
1.2

setToShear

public void setToShear(double shx,
                       double shy)
将此变换设置为错切变换。表示此变换的矩阵将变成：
                [   1   shx   0   ]
                [  shy   1    0   ]
                [   0    0    1   ]

参数：
shx - 坐标在正 X 轴方向上进行位移的乘数，与其 Y 坐标的因子一样
shy - 坐标在正 Y 轴方向上进行位移的乘数，与其 X 坐标的因子一样
从以下版本开始：
1.2

setTransform

public void setTransform(AffineTransform Tx)
将此变换设置为指定 AffineTransform 对象中变换的副本。

参数：
Tx - 从中复制变换的 AffineTransform 对象
从以下版本开始：
1.2

setTransform

public void setTransform(double m00,
                         double m10,
                         double m01,
                         double m11,
                         double m02,
                         double m12)
将此变换设置为 6 个双精度值指定的矩阵。

参数：
m00 - 3x3 矩阵缩放元素的 X 坐标
m10 - 3x3 矩阵错切元素的 Y 坐标
m01 - 3x3 矩阵错切元素的 X 坐标
m11 - 3x3 矩阵缩放元素的 Y 坐标
m02 - 3x3 矩阵平移元素的 X 坐标
m12 - 3x3 矩阵平移元素的 Y 坐标
从以下版本开始：
1.2

concatenate

public void concatenate(AffineTransform Tx)
以最常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，以提供由 Tx 映射到以前用户空间的新用户空间。更新 Cx 以执行组合变换。通过更新的变换 Cx' 来对点 p 进行变换等效于首先通过 Tx 变换 p，然后通过初始变换 Cx 变换所得结果，如下所示：Cx'(p) = Cx(Tx(p))。在矩阵符号中，如果此变换 Cx 由矩阵 [this] 表示，Tx 由矩阵 [Tx] 表示，则此方法执行以下操作：
                [this] = [this] x [Tx]

参数：
Tx - 要与此 AffineTransform 对象连接的 AffineTransform 对象。
从以下版本开始：
1.2
另请参见：
preConcatenate(java.awt.geom.AffineTransform)

preConcatenate

public void preConcatenate(AffineTransform Tx)
以不常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，从而 Tx 相对于绝对像素空间（而非相对于现有用户空间）修改坐标变换。更新 Cx 以执行组合变换。通过更新的变换 Cx' 来对点 p 进行变换等效于首先通过初始变换 Cx 变换 p，然后通过 Tx 变换所得结果，如下所示：Cx'(p) = Tx(Cx(p))。在矩阵符号中，如果此变换 Cx 由矩阵 [this] 表示，Tx 由矩阵 [Tx] 表示，则此方法执行以下操作：
                [this] = [Tx] x [this]

参数：
Tx - 要与此 AffineTransform 对象连接的 AffineTransform 对象。
从以下版本开始：
1.2
另请参见：
concatenate(java.awt.geom.AffineTransform)

createInverse

public AffineTransform createInverse()
                              throws NoninvertibleTransformException
返回表示逆向变换的 AffineTransform 对象。此变换 Tx 的逆向变换 Tx' 将由 Tx 变换的坐标映射回其初始坐标。换句话说，Tx'(Tx(p)) = p = Tx(Tx'(p))。

如果此变换将所有坐标映射到点或线上，那么它将不能进行逆向变换，因为不位于目标点或线上的坐标没有逆向映射。getDeterminant 方法可用于确定此变换是否不可逆，若不可逆，则调用 createInverse 方法时将抛出异常。

返回：
表示逆向变换的新 AffineTransform 对象。
抛出：
NoninvertibleTransformException - 如果矩阵不可逆。
从以下版本开始：
1.2
另请参见：
getDeterminant()

invert

public void invert()
            throws NoninvertibleTransformException
将此变换设置为它自身的逆变换。此变换 Tx 的逆向变换 Tx' 将由 Tx 变换的坐标映射回其初始坐标。换句话说，Tx'(Tx(p)) = p = Tx(Tx'(p))。

如果此变换将所有坐标映射到点或线上，那么它将不能进行逆向变换，因为不位于目标点或线上的坐标没有逆向映射。getDeterminant 方法可用于确定此变换是否不可逆，若不可逆，则调用 invert 方法时将抛出异常。

抛出：
NoninvertibleTransformException - 如果矩阵不可逆。
从以下版本开始：
1.6
另请参见：
getDeterminant()

transform

public Point2D transform(Point2D ptSrc,
                         Point2D ptDst)
变换指定的 ptSrc 并将结果存储在 ptDst 中。如果 ptDst 为 null，则分配一个新的 Point2D 对象，然后将变换的结果存储在此对象中。在任何一种情况下，为方便起见，都将返回包含变换点的 ptDst。如果 ptSrc 和 ptDst 是同一个对象，则将使用变换点正确地改写输入点。

参数：
ptSrc - 要变换的指定 Point2D
ptDst - 存储变换 ptSrc 结果的指定 Point2D
返回：
变换 ptSrc 并将结果存入 ptDst 后的 ptDst。
从以下版本开始：
1.2

transform

public void transform(Point2D[] ptSrc,
                      int srcOff,
                      Point2D[] ptDst,
                      int dstOff,
                      int numPts)
通过此变换来变换点对象数组。如果 ptDst 数组的任何元素为 null，那么在存储变换结果之前，新的 Point2D 对象将被分配并存储到该元素中。

注意，此方法没有针对如何避免将结果存储到 Point2D 对象（这些对象将用作源数组背后某些计算的源）时产生的问题采取任何预防措施。此方法可保证，如果指定的 Point2D 对象同时作为同一个单点变换操作的源和目标，则在计算完成之前不存储结果，从而避免将结果存储在该操作数上。但是，如果一个操作的目标 Point2D 对象与源数组背后另一个操作的源 Point2D 对象相同，那么在转换该点初始坐标之前，这些坐标都将被改写。

参数：
ptSrc - 包含源点对象的数组
ptDst - 从其中返回变换点对象的数组
srcOff - 源数组中要变换的第一个点对象的偏移量
dstOff - 目标数组中存储的第一个变换点对象的位置的偏移量
numPts - 要变换的点对象数
从以下版本开始：
1.2

transform

public void transform(float[] srcPts,
                      int srcOff,
                      float[] dstPts,
                      int dstOff,
                      int numPts)
通过此变换来变换浮点坐标数组。两个坐标数组部分可以完全相同，也可以是同一数组的重叠部分，这对结果的有效性都没有影响。此方法可确保在变换源坐标之前，它们不会被以前的操作改写。这些坐标从指定偏移量开始按照 [x0, y0, x1, y1, ..., xn, yn] 的顺序存储在数组中。

参数：
srcPts - 包含源点坐标的数组。每个点都存储为一对 x, y 坐标。
dstPts - 从其中返回变换点坐标的数组。每个点都存储为一对 x, y 坐标。
srcOff - 源数组中要变换的第一个点的偏移量
dstOff - 目标数组中存储的第一个变换点位置的偏移量
numPts - 要变换的点数
从以下版本开始：
1.2

transform

public void transform(double[] srcPts,
                      int srcOff,
                      double[] dstPts,
                      int dstOff,
                      int numPts)
通过此变换来变换双精度坐标数组。两个坐标数组部分可以完全相同，也可以是同一数组的重叠部分，这对结果的有效性都没有影响。此方法可确保在变换源坐标之前，它们不会被以前的操作改写。这些坐标从指示偏移量开始按照 [x0, y0, x1, y1, ..., xn, yn] 的顺序存储在数组中。

参数：
srcPts - 包含源点坐标的数组。每个点都存储为一对 x, y 坐标。
dstPts - 从其中返回变换点坐标的数组。每个点都存储为一对 x, y 坐标。
srcOff - 源数组中要变换的第一个点的偏移量
dstOff - 目标数组中存储的第一个变换点位置的偏移量
numPts - 要变换的点对象数
从以下版本开始：
1.2

transform

public void transform(float[] srcPts,
                      int srcOff,
                      double[] dstPts,
                      int dstOff,
                      int numPts)
通过此变换来变换浮点坐标数组，并将结果存储在 double 数组中。这些坐标从指定偏移量开始按照 [x0, y0, x1, y1, ..., xn, yn] 的顺序存储在数组中。

参数：
srcPts - 包含源点坐标的数组。每个点都存储为一对 x, y 坐标。
dstPts - 从其中返回变换点坐标的数组。每个点都存储为一对 x, y 坐标。
srcOff - 源数组中要变换的第一个点的偏移量
dstOff - 目标数组中存储的第一个变换点位置的偏移量
numPts - 要变换的点数
从以下版本开始：
1.2

transform

public void transform(double[] srcPts,
                      int srcOff,
                      float[] dstPts,
                      int dstOff,
                      int numPts)
通过此变换来变换双精度坐标数组，并将结果存储在 float 数组中。这些坐标从指定偏移量开始按照 [x0, y0, x1, y1, ..., xn, yn] 的顺序存储在数组中。

参数：
srcPts - 包含源点坐标的数组。每个点都存储为一对 x, y 坐标。
dstPts - 从其中返回变换点坐标的数组。每个点都存储为一对 x, y 坐标。
srcOff - 源数组中要变换的第一个点的偏移量
dstOff - 目标数组中存储的第一个变换点位置的偏移量
numPts - 要变换的点对象数
从以下版本开始：
1.2

inverseTransform

public Point2D inverseTransform(Point2D ptSrc,
                                Point2D ptDst)
                         throws NoninvertibleTransformException
逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。如果 ptDst 为 null，则分配一个新的 Point2D 对象，然后将变换的结果存储在此对象中。无论是哪种情况，为方便起见，都将返回包含变换点的 ptDst。如果 ptSrc 和 ptDst 是同一个对象，则将使用变换点正确地改写输入点。

参数：
ptSrc - 要逆向变换的点
ptDst - 得到的变换点
返回：
ptDst，它包含逆向变换的结果。
抛出：
NoninvertibleTransformException - 如果矩阵不可逆。
从以下版本开始：
1.2

inverseTransform

public void inverseTransform(double[] srcPts,
                             int srcOff,
                             double[] dstPts,
                             int dstOff,
                             int numPts)
                      throws NoninvertibleTransformException
通过此变换来逆向变换双精度坐标数组。两个坐标数组部分可以完全相同，也可以是同一数组的重叠部分，这对结果的有效性都没有影响。此方法可确保在变换源坐标之前，它们不会被以前的操作改写。这些坐标从指定偏移量开始按照 [x0, y0, x1, y1, ..., xn, yn] 的顺序存储在数组中。

参数：
srcPts - 包含源点坐标的数组。每个点都存储为一对 x, y 坐标。
dstPts - 从其中返回变换点坐标的数组。每个点都存储为一对 x, y 坐标。
srcOff - 源数组中要变换的第一个点的偏移量
dstOff - 目标数组中存储的第一个变换点位置的偏移量
numPts - 要变换的点对象数
抛出：
NoninvertibleTransformException - 如果矩阵不可逆。
从以下版本开始：
1.2

deltaTransform

public Point2D deltaTransform(Point2D ptSrc,
                              Point2D ptDst)
变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。使用以下方程式变换相对距离向量，不应用仿射变换矩阵的平移组件：
        [  x' ]   [  m00  m01 (m02) ] [  x  ]   [ m00x + m01y ]
        [  y' ] = [  m10  m11 (m12) ] [  y  ] = [ m10x + m11y ]
        [ (1) ]   [  (0)  (0) ( 1 ) ] [ (1) ]   [     (1)     ]
如果 ptDst 为 null，则分配一个新的 Point2D 对象，然后将变换的结果存储在此对象中。无论是哪种情况，为方便起见，都将返回包含变换点的 ptDst。如果 ptSrc 和 ptDst 是同一个对象，则将使用变换点正确地改写输入点。

参数：
ptSrc - 要进行 delta 变换的距离向量
ptDst - 得到的变换距离向量
返回：
ptDst，它包含变换的结果。
从以下版本开始：
1.2

deltaTransform

public void deltaTransform(double[] srcPts,
                           int srcOff,
                           double[] dstPts,
                           int dstOff,
                           int numPts)
通过此变换来变换相对距离向量数组。使用以下方程式变换相对距离向量，不应用仿射变换矩阵的平移组件：
        [  x' ]   [  m00  m01 (m02) ] [  x  ]   [ m00x + m01y ]
        [  y' ] = [  m10  m11 (m12) ] [  y  ] = [ m10x + m11y ]
        [ (1) ]   [  (0)  (0) ( 1 ) ] [ (1) ]   [     (1)     ]
两个坐标数组部分可以完全相同，也可以是同一数组的重叠部分，这对结果的有效性都没有影响。此方法可确保在变换源坐标之前，它们不会被以前的操作改写。这些坐标从指示偏移量开始按照 [x0, y0, x1, y1, ..., xn, yn] 的顺序存储在数组中。

参数：
srcPts - 包含源距离向量的数组。每个向量都存储为一对相对 x, y 坐标。
dstPts - 从其中返回变换距离向量的数组。每个向量都存储为一对相对 x, y 坐标。
srcOff - 源数组中要变换的第一个向量的偏移量
dstOff - 目标数组中存储的第一个变换向量位置的偏移量
numPts - 要变换的向量坐标对的数量
从以下版本开始：
1.2

createTransformedShape

public Shape createTransformedShape(Shape pSrc)
返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。

参数：
pSrc - 要被此变换变换的指定 Shape 对象。
返回：
由变换的 Shape 的几何形状所定义的新 Shape 对象；如果 pSrc 为 null，则返回 null。
从以下版本开始：
1.2

toString

public String toString()
返回表示此 Object 值的 String。

覆盖：
类 Object 中的 toString
返回：
表示此 Object 值的 String。
从以下版本开始：
1.2

isIdentity

public boolean isIdentity()
如果此 AffineTransform 是恒等变换，则返回 true。

返回：
如果此 AffineTransform 是恒等变换，则返回 true；否则返回 false。
从以下版本开始：
1.2

clone

public Object clone()
返回此 AffineTransform 对象的副本。

覆盖：
类 Object 中的 clone
返回：
作为此 AffineTransform 对象副本的 Object。
从以下版本开始：
1.2
另请参见：
Cloneable

hashCode

public int hashCode()
返回此变换的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此变换的哈希码。
从以下版本开始：
1.2
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
如果此 AffineTransform 表示与指定参数相同的仿射坐标变换，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要测试与此 AffineTransform 相等性的 Object
返回：
如果 obj 等于此 AffineTransform 对象，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Arc2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Arc2D

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Arc2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
Arc2D.Double, Arc2D.Float
public abstract class Arc2D
extends RectangularShape

Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。

弧度是其父 RectangularShape 窗体矩形内切完整椭圆的一部分。 角度是相对于非正方形的窗体矩形指定的，从而 45 度角总是落在椭圆中心到窗体矩形右上角的连线上。因此，如果窗体矩形沿一条轴的长度远长于沿另一条轴的长度，则弧段起始点和结束点间的角度将沿窗体长轴发生较大偏斜。

坐标的实际存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
字段摘要
static int | CHORD 闭合类型，用于通过从弧段的起始点到弧段的结束点画一条直线来闭合的弧。
static int | OPEN 闭合类型，用于不具有用来连接弧段两个端点的路径段的开弧。
static int | PIE 闭合类型，用于通过从弧段的起始点到完整椭圆的中心，再从圆心到弧段的结束点画直线来闭合的弧。
构造方法摘要
protected Arc2D(int type)
这是一个不能直接实例化的抽象类。
方法摘要
boolean | contains(double x, double y) 确定指定的点是否位于弧的边界内。
boolean | contains(double x, double y, double w, double h) 确定弧的内部是否完全包含指定的矩形。
boolean | contains(Rectangle2D r) 确定弧的内部是否完全包含指定的矩形。
boolean | containsAngle(double angle) 确定指定的角度是否位于弧的角跨越内。
boolean | equals(Object obj) 确定指定的 Object 是否与此 Arc2D 相等。
abstract double | getAngleExtent() 返回弧的角跨越。
abstract double | getAngleStart() 返回弧的起始角度。
int | getArcType() 返回弧的弧闭合类型：OPEN、CHORD 或 PIE。
Rectangle2D | getBounds2D() 返回弧的高精度窗体矩形。
Point2D | getEndPoint() 返回弧的结束点。
PathIterator | getPathIterator(AffineTransform at) 返回定义弧边界的迭代对象。
Point2D | getStartPoint() 返回弧的起始点。
int | hashCode() 返回此 Arc2D 的哈希码。
boolean | intersects(double x, double y, double w, double h) 确定弧的内部与指定矩形的内部是否相交。
protected abstract Rectangle2D | makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
abstract void | setAngleExtent(double angExt) 将此弧的角跨越设置为指定的 double 值。
void | setAngles(double x1, double y1, double x2, double y2) 使用两组坐标设置此弧的起始角度和角跨越。
void | setAngles(Point2D p1, Point2D p2) 使用两个点设置此弧的起始角度和角跨越。
abstract void | setAngleStart(double angSt) 将此弧的起始角度设置为指定的 double 值。
void | setAngleStart(Point2D p) 将此弧的起始角度设置为由指定点定义、相对于此弧中心的角度。
void | setArc(Arc2D a) 将此弧设置为与指定弧相同。
abstract void | setArc(double x, double y, double w, double h, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
void | setArc(Point2D loc, Dimension2D size, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | setArc(Rectangle2D rect, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | setArcByCenter(double x, double y, double radius, double angSt, double angExt, int closure) 将此弧的位置、边界、角跨越和闭合类型设置为指定值。
void | setArcByTangent(Point2D p1, Point2D p2, Point2D p3, double radius) 将此弧的位置、边界和角跨越设置为指定值。
void | setArcType(int type) 将此弧的闭合类型设置为指定值：OPEN、CHORD 或 PIE。
void | setFrame(double x, double y, double w, double h) 将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OPEN

public static final int OPEN
闭合类型，用于不具有用来连接弧段两个端点的路径段的开弧。

从以下版本开始：
1.2
另请参见：
常量字段值

CHORD

public static final int CHORD
闭合类型，用于通过从弧段的起始点到弧段的结束点画一条直线来闭合的弧。

从以下版本开始：
1.2
另请参见：
常量字段值

PIE

public static final int PIE
闭合类型，用于通过从弧段的起始点到完整椭圆的中心，再从圆心到弧段的结束点画直线来闭合的弧。

从以下版本开始：
1.2
另请参见：
常量字段值
构造方法详细信息

Arc2D

protected Arc2D(int type)
这是一个不能直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

参数：
type - 此弧的闭合类型：OPEN、CHORD 或 PIE。
从以下版本开始：
1.2
另请参见：
Arc2D.Float, Arc2D.Double
方法详细信息

getAngleStart

public abstract double getAngleStart()
返回弧的起始角度。

返回：
一个 double 值，表示弧的起始角度（以度数表示）。
从以下版本开始：
1.2
另请参见：
setAngleStart(double)

getAngleExtent

public abstract double getAngleExtent()
返回弧的角跨越。

返回：
一个 double 值，表示弧的角跨越（以度数表示）。
从以下版本开始：
1.2
另请参见：
setAngleExtent(double)

getArcType

public int getArcType()
返回弧的弧闭合类型：OPEN、CHORD 或 PIE。

返回：
在此类中定义的整数常量闭合类型之一。
从以下版本开始：
1.2
另请参见：
setArcType(int)

getStartPoint

public Point2D getStartPoint()
返回弧的起始点。此点是起始角度定义的中心发出的射线与弧椭圆边界的交点。

返回：
一个 Point2D 对象，表示弧起始点的 x、y 坐标。
从以下版本开始：
1.2

getEndPoint

public Point2D getEndPoint()
返回弧的结束点。此点是起始角度加上弧的角跨越所定义的中心发出的射线与弧椭圆边界的交点。

返回：
一个 Point2D 对象，表示弧结束点的 x、y 坐标。
从以下版本开始：
1.2

setArc

public abstract void setArc(double x,
                            double y,
                            double w,
                            double h,
                            double angSt,
                            double angExt,
                            int closure)
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。

参数：
x - 弧的左上角的 X 坐标。
y - 弧的左上角的 Y 坐标。
w - 完整椭圆的总宽度，此弧是该椭圆的一部分。
h - 完整椭圆的总高度，此弧是该椭圆的一部分。
angSt - 弧的起始角度（以度数表示）。
angExt - 弧的角跨越（以度数表示）。
closure - 弧的闭合类型：OPEN、CHORD 或 PIE。
从以下版本开始：
1.2

setArc

public void setArc(Point2D loc,
                   Dimension2D size,
                   double angSt,
                   double angExt,
                   int closure)
将此弧的位置、大小、角跨越和闭合类型设置为指定值。

参数：
loc - 表示弧的左上角坐标的 Point2D。
size - 表示完整椭圆宽度和高度的 Dimension2D，此弧是该椭圆的一部分。
angSt - 弧的起始角度（以度数表示）。
angExt - 弧的角跨越（以度数表示）。
closure - 弧的闭合类型：OPEN、CHORD 或 PIE。
从以下版本开始：
1.2

setArc

public void setArc(Rectangle2D rect,
                   double angSt,
                   double angExt,
                   int closure)
将此弧的位置、大小、角跨越和闭合类型设置为指定值。

参数：
rect - 定义完整椭圆外部边界的窗体矩形，此弧是该椭圆的一部分。
angSt - 弧的起始角度（以度数表示）。
angExt - 弧的角跨越（以度数表示）。
closure - 弧的闭合类型：OPEN、CHORD 或 PIE。
从以下版本开始：
1.2

setArc

public void setArc(Arc2D a)
将此弧设置为与指定弧相同。

参数：
a - 用于设置弧值的 Arc2D。
从以下版本开始：
1.2

setArcByCenter

public void setArcByCenter(double x,
                           double y,
                           double radius,
                           double angSt,
                           double angExt,
                           int closure)
将此弧的位置、边界、角跨越和闭合类型设置为指定值。弧是由中心点和半径（而不是完整椭圆的窗体矩形）定义的。

参数：
x - 弧中心的 X 坐标。
y - 弧中心的 Y 坐标。
radius - 弧的半径。
angSt - 弧的起始角度（以度数表示）。
angExt - 弧的角跨越（以度数表示）。
closure - 弧的闭合类型：OPEN、CHORD 或 PIE。
从以下版本开始：
1.2

setArcByTangent

public void setArcByTangent(Point2D p1,
                            Point2D p2,
                            Point2D p3,
                            double radius)
将此弧的位置、边界和角跨越设置为指定值。弧的起始角度是点 (p1, p2) 指定的线的正切，结束角度是点 (p2, p3) 指定的线的正切，弧还具有指定的半径。

参数：
p1 - 定义弧的第一个点。弧的起始角度是点 (p1, p2) 指定的线的正切。
p2 - 定义弧的第二个点。弧的起始角度是点 (p1, p2) 指定的线的正切。弧的结束角度是点 (p2, p3) 指定的线的正切。
p3 - 定义弧的第三个点。弧的结束角度是点 (p2, p3) 指定的线的正切。
radius - 弧的半径。
从以下版本开始：
1.2

setAngleStart

public abstract void setAngleStart(double angSt)
将此弧的起始角度设置为指定的 double 值。

参数：
angSt - 弧的起始角度（以度数表示）。
从以下版本开始：
1.2
另请参见：
getAngleStart()

setAngleExtent

public abstract void setAngleExtent(double angExt)
将此弧的角跨越设置为指定的 double 值。

参数：
angExt - 弧的角跨越（以度数表示）。
从以下版本开始：
1.2
另请参见：
getAngleExtent()

setAngleStart

public void setAngleStart(Point2D p)
将此弧的起始角度设置为由指定点定义、相对于此弧中心的角度。弧的角跨越将保持不变。

参数：
p - 定义起始角度的 Point2D。
从以下版本开始：
1.2
另请参见：
getAngleStart()

setAngles

public void setAngles(double x1,
                      double y1,
                      double x2,
                      double y2)
使用两组坐标设置此弧的起始角度和角跨越。第一组坐标用于确定相对于弧中心起始点的角度。第二组坐标用于确定相对于弧中心结束点的角度。弧始终是非空的，按逆时针方向以弧形从第一点延伸到第二点。

参数：
x1 - 弧起始点的 X 坐标。
y1 - 弧起始点的 Y 坐标。
x2 - 弧结束点的 X 坐标。
y2 - 弧结束点的 Y 坐标。
从以下版本开始：
1.2

setAngles

public void setAngles(Point2D p1,
                      Point2D p2)
使用两个点设置此弧的起始角度和角跨越。第一点用于确定相对于弧中心起始点的角度。第二点用于确定相对于弧中心结束点的角度。弧始终是非空的，按逆时针方向以弧形从第一点延伸到第二点。

参数：
p1 - 定义弧起始点的 Point2D。
p2 - 定义弧结束点的 Point2D。
从以下版本开始：
1.2

setArcType

public void setArcType(int type)
将此弧的闭合类型设置为指定值：OPEN、CHORD 或 PIE。

参数：
type - 表示此弧闭合类型的整数常量：OPEN、CHORD 或 PIE。
抛出：
IllegalArgumentException - 如果 type 不是 0、1 或 2。
从以下版本开始：
1.2
另请参见：
getArcType()

setFrame

public void setFrame(double x,
                     double y,
                     double w,
                     double h)
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 setFrame
参数：
x - 指定矩形左上角的 X 坐标
y - 指定矩形左上角的 Y 坐标
w - 指定矩形的宽度
h - 指定矩形的高度
从以下版本开始：
1.2
另请参见：
RectangularShape.getFrame()

getBounds2D

public Rectangle2D getBounds2D()
返回弧的高精度窗体矩形。该窗体矩形仅包含此 Arc2D 的一部分，即起始角度和结束角度之间的部分；如果此 Arc2D 的闭合类型为 PIE，则还包含扇形边。

此方法不同于 getBounds，getBounds 方法仅返回此 Arc2D 封闭椭圆的边界，而不考虑此 Arc2D 的起始角度和结束角度。

返回：
表示弧的窗体矩形的 Rectangle2D。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()

makeBounds

protected abstract Rectangle2D makeBounds(double x,
                                          double y,
                                          double w,
                                          double h)
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。

参数：
x - 窗体矩形左上角的 X 坐标。
y - 窗体矩形左上角的 Y 坐标。
w - 窗体矩形的宽度。
h - 窗体矩形的高度。
返回：
作为此弧窗体矩形的 Rectangle2D。
从以下版本开始：
1.2

containsAngle

public boolean containsAngle(double angle)
确定指定的角度是否位于弧的角跨越内。

参数：
angle - 要测试的角度。
返回：
如果弧包含角度，则返回 true；如果弧不包含角度，则返回 false。
从以下版本开始：
1.2

contains

public boolean contains(double x,
                        double y)
确定指定的点是否位于弧的边界内。

参数：
x - 要测试的点的 X 坐标。
y - 要测试的点的 Y 坐标。
返回：
如果点位于弧的边界内，则返回 true；如果点位于弧的边界外，则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
确定弧的内部与指定矩形的内部是否相交。

参数：
x - 矩形左上角的 X 坐标。
y - 矩形左上角的 Y 坐标。
w - 矩形的宽度。
h - 矩形的高度。
返回：
如果弧与矩形相交，则返回 true；如果弧与矩形不相交，则返回 false。
从以下版本开始：
1.2
另请参见：
Area

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
确定弧的内部是否完全包含指定的矩形。

参数：
x - 矩形左上角的 X 坐标。
y - 矩形左上角的 Y 坐标。
w - 矩形的宽度。
h - 矩形的高度。
返回：
如果弧包含矩形，则返回 true；如果弧不包含矩形，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

contains

public boolean contains(Rectangle2D r)
确定弧的内部是否完全包含指定的矩形。

指定者：
接口 Shape 中的 contains
覆盖：
类 RectangularShape 中的 contains
参数：
r - 要测试的 Rectangle2D。
返回：
如果弧包含矩形，则返回 true；如果弧不包含矩形，则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.contains(double, double, double, double)

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回定义弧边界的迭代对象。此迭代器是多线程安全的。Arc2D 保证对弧几何形状的修改不影响该几何形状任何进行中的迭代。

参数：
at - 可选的 AffineTransform，应用于迭代中返回的坐标；如果需要未转换的坐标，则为 null。
返回：
定义弧边界的 PathIterator。
从以下版本开始：
1.2

hashCode

public int hashCode()
返回此 Arc2D 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Arc2D 的哈希码。
从以下版本开始：
1.6
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
确定指定的 Object 是否与此 Arc2D 相等。如果该对象是一个 Arc2D 实例，并且其位置、大小、弧度跨越和类型与此 Arc2D 相同，则指定的 Object 与此 Arc2D 相等。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此 Arc2D 进行比较的 Object。
返回：
如果 obj 是一个 Arc2D 实例并且具有相同的值，则返回 true；否则返回 false。
从以下版本开始：
1.6
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Arc2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Arc2D.Double

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Arc2D
            继承者  java.awt.geom.Arc2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Arc2D
public static class Arc2D.Double
extends Arc2D
implements Serializable

此类定义以 double 精度指定的弧。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Arc2D 继承的嵌套类/接口
Arc2D.Double, Arc2D.Float
字段摘要
double | extent 弧的角跨越（以度数表示）。
double | height 完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。
double | start 弧的起始角度（以度数表示）。
double | width 完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。
double | x 弧的窗体矩形左上角的 X 坐标。
double | y 弧的窗体矩形左上角的 Y 坐标。
从类 java.awt.geom.Arc2D 继承的字段
CHORD, OPEN, PIE
构造方法摘要
Arc2D.Double()
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。
Arc2D.Double(double x, double y, double w, double h, double start, double extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Double(int type)
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)、指定的闭合类型。
Arc2D.Double(Rectangle2D ellipseBounds, double start, double extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
方法摘要
double | getAngleExtent() 返回弧的角跨越。
double | getAngleStart() 返回弧的起始角度。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
protected Rectangle2D | makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
void | setAngleExtent(double angExt) 将此弧的角跨越设置为指定的 double 值。
void | setAngleStart(double angSt) 将此弧的起始角度设置为指定的 double 值。
void | setArc(double x, double y, double w, double h, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
从类 java.awt.geom.Arc2D 继承的方法
contains, contains, contains, containsAngle, equals, getArcType, getBounds2D, getEndPoint, getPathIterator, getStartPoint, hashCode, intersects, setAngles, setAngles, setAngleStart, setArc, setArc, setArc, setArcByCenter, setArcByTangent, setArcType, setFrame
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x

public double x
弧的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

public double y
弧的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

public double width
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

height

public double height
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

start

public double start
弧的起始角度（以度数表示）。

从以下版本开始：
1.2

extent

public double extent
弧的角跨越（以度数表示）。

从以下版本开始：
1.2
构造方法详细信息

Arc2D.Double

public Arc2D.Double()
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。

从以下版本开始：
1.2

Arc2D.Double

public Arc2D.Double(int type)
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)、指定的闭合类型。

参数：
type - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2

Arc2D.Double

public Arc2D.Double(double x,
                    double y,
                    double w,
                    double h,
                    double start,
                    double extent,
                    int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。

参数：
x - 弧的窗体矩形左上角的 X 坐标。
y - 弧的窗体矩形左上角的 Y 坐标。
w - 完整椭圆的总宽度，此弧是该椭圆的一部分。
h - 完整椭圆的总高度，此弧是该椭圆的一部分。
start - 弧的起始角度（以度数表示）。
extent - 弧的角跨越（以度数表示）。
type - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2

Arc2D.Double

public Arc2D.Double(Rectangle2D ellipseBounds,
                    double start,
                    double extent,
                    int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。

参数：
ellipseBounds - 定义完整椭圆外部边界的窗体矩形，此弧是该椭圆的一部分。
start - 弧的起始角度（以度数表示）。
extent - 弧的角跨越（以度数表示）。
type - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

getAngleStart

public double getAngleStart()
返回弧的起始角度。

指定者：
类 Arc2D 中的 getAngleStart
返回：
一个 double 值，表示弧的起始角度（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.setAngleStart(double)

getAngleExtent

public double getAngleExtent()
返回弧的角跨越。

指定者：
类 Arc2D 中的 getAngleExtent
返回：
一个 double 值，表示弧的角跨越（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.setAngleExtent(double)

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setArc

public void setArc(double x,
                   double y,
                   double w,
                   double h,
                   double angSt,
                   double angExt,
                   int closure)
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。

指定者：
类 Arc2D 中的 setArc
参数：
x - 弧的左上角的 X 坐标。
y - 弧的左上角的 Y 坐标。
w - 完整椭圆的总宽度，此弧是该椭圆的一部分。
h - 完整椭圆的总高度，此弧是该椭圆的一部分。
angSt - 弧的起始角度（以度数表示）。
angExt - 弧的角跨越（以度数表示）。
closure - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2

setAngleStart

public void setAngleStart(double angSt)
将此弧的起始角度设置为指定的 double 值。

指定者：
类 Arc2D 中的 setAngleStart
参数：
angSt - 弧的起始角度（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.getAngleStart()

setAngleExtent

public void setAngleExtent(double angExt)
将此弧的角跨越设置为指定的 double 值。

指定者：
类 Arc2D 中的 setAngleExtent
参数：
angExt - 弧的角跨越（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.getAngleExtent()

makeBounds

protected Rectangle2D makeBounds(double x,
                                 double y,
                                 double w,
                                 double h)
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。

指定者：
类 Arc2D 中的 makeBounds
参数：
x - 窗体矩形左上角的 X 坐标。
y - 窗体矩形左上角的 Y 坐标。
w - 窗体矩形的宽度。
h - 窗体矩形的高度。
返回：
作为此弧窗体矩形的 Rectangle2D。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Arc2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Arc2D.Float

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Arc2D
            继承者  java.awt.geom.Arc2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Arc2D
public static class Arc2D.Float
extends Arc2D
implements Serializable

此类定义以 float 精度指定的弧。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Arc2D 继承的嵌套类/接口
Arc2D.Double, Arc2D.Float
字段摘要
float | extent 弧的角跨越（以度数表示）。
float | height 完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。
float | start 弧的起始角度（以度数表示）。
float | width 完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。
float | x 弧的窗体矩形左上角的 X 坐标。
float | y 弧的窗体矩形左上角的 Y 坐标。
从类 java.awt.geom.Arc2D 继承的字段
CHORD, OPEN, PIE
构造方法摘要
Arc2D.Float()
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。
Arc2D.Float(float x, float y, float w, float h, float start, float extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Float(int type)
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)，角跨越 (start = 0, extent = 0)、指定的闭合类型。
Arc2D.Float(Rectangle2D ellipseBounds, float start, float extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
方法摘要
double | getAngleExtent() 返回弧的角跨越。
double | getAngleStart() 返回弧的起始角度。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
protected Rectangle2D | makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
void | setAngleExtent(double angExt) 将此弧的角跨越设置为指定的 double 值。
void | setAngleStart(double angSt) 将此弧的起始角度设置为指定的 double 值。
void | setArc(double x, double y, double w, double h, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。
从类 java.awt.geom.Arc2D 继承的方法
contains, contains, contains, containsAngle, equals, getArcType, getBounds2D, getEndPoint, getPathIterator, getStartPoint, hashCode, intersects, setAngles, setAngles, setAngleStart, setArc, setArc, setArc, setArcByCenter, setArcByTangent, setArcType, setFrame
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x

public float x
弧的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

public float y
弧的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

public float width
完整椭圆的总宽度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

height

public float height
完整椭圆的总高度（不考虑角跨越），此弧是该椭圆的一部分。

从以下版本开始：
1.2

start

public float start
弧的起始角度（以度数表示）。

从以下版本开始：
1.2

extent

public float extent
弧的角跨越（以度数表示）。

从以下版本开始：
1.2
构造方法详细信息

Arc2D.Float

public Arc2D.Float()
构造一个新 OPEN 弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)、角跨越 (start = 0, extent = 0)。

从以下版本开始：
1.2

Arc2D.Float

public Arc2D.Float(int type)
构造一个新弧，并将其初始化为：位置 (0, 0)、大小 (0, 0)，角跨越 (start = 0, extent = 0)、指定的闭合类型。

参数：
type - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2

Arc2D.Float

public Arc2D.Float(float x,
                   float y,
                   float w,
                   float h,
                   float start,
                   float extent,
                   int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。

参数：
x - 弧的窗体矩形左上角的 X 坐标。
y - 弧的窗体矩形左上角的 Y 坐标。
w - 完整椭圆的总宽度，此弧是该椭圆的一部分。
h - 完整椭圆的总高度，此弧是该椭圆的一部分。
start - 弧的起始角度（以度数表示）。
extent - 弧的角跨越（以度数表示）。
type - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2

Arc2D.Float

public Arc2D.Float(Rectangle2D ellipseBounds,
                   float start,
                   float extent,
                   int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。

参数：
ellipseBounds - 定义完整椭圆外部边界的窗体矩形，此弧是该椭圆的一部分。
start - 以度数表示的弧起始角度。
extent - 以度数表示的弧的角跨越。
type - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。 注意，该弧部分内切于此 RectangularShape 的窗体矩形。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

getAngleStart

public double getAngleStart()
返回弧的起始角度。

指定者：
类 Arc2D 中的 getAngleStart
返回：
一个 double 值，表示弧的起始角度（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.setAngleStart(double)

getAngleExtent

public double getAngleExtent()
返回弧的角跨越。

指定者：
类 Arc2D 中的 getAngleExtent
返回：
一个 double 值，表示弧的角跨越（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.setAngleExtent(double)

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setArc

public void setArc(double x,
                   double y,
                   double w,
                   double h,
                   double angSt,
                   double angExt,
                   int closure)
将此弧的位置、大小、角跨越和闭合类型设置为指定的 double 值。

指定者：
类 Arc2D 中的 setArc
参数：
x - 弧的左上角的 X 坐标。
y - 弧的左上角的 Y 坐标。
w - 完整椭圆的总宽度，此弧是该椭圆的一部分。
h - 完整椭圆的总高度，此弧是该椭圆的一部分。
angSt - 弧的起始角度（以度数表示）。
angExt - 弧的角跨越（以度数表示）。
closure - 弧的闭合类型：Arc2D.OPEN、Arc2D.CHORD 或 Arc2D.PIE。
从以下版本开始：
1.2

setAngleStart

public void setAngleStart(double angSt)
将此弧的起始角度设置为指定的 double 值。

指定者：
类 Arc2D 中的 setAngleStart
参数：
angSt - 弧的起始角度（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.getAngleStart()

setAngleExtent

public void setAngleExtent(double angExt)
将此弧的角跨越设置为指定的 double 值。

指定者：
类 Arc2D 中的 setAngleExtent
参数：
angExt - 弧的角跨越（以度数表示）。
从以下版本开始：
1.2
另请参见：
Arc2D.getAngleExtent()

makeBounds

protected Rectangle2D makeBounds(double x,
                                 double y,
                                 double w,
                                 double h)
构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。

指定者：
类 Arc2D 中的 makeBounds
参数：
x - 窗体矩形左上角的 X 坐标。
y - 窗体矩形左上角的 Y 坐标。
w - 窗体矩形的宽度。
h - 窗体矩形的高度。
返回：
作为此弧窗体矩形的 Rectangle2D。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Area (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Area

java.lang.Object
    继承者  java.awt.geom.Area
所有已实现的接口：
Shape, Cloneable
public class Area
extends Object
implements Shape, Cloneable

Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。在与其他 Area 对象合并时，Area 对象可以被变换，并可执行各种构造区域几何形状 (Constructive Area Geometry，CAG) 操作。CAG 操作包括对区域进行加、减、交和异或。有关各种操作的示例，请参阅链接的方法文档。

Area 类实现了 Shape 接口，并提供对所有目标测试和路径迭代设施的完全支持，但 Area 在许多方面比一般化的路径更具体：

  • 仅存储封闭的路径和子路径。在构造期间隐式关闭根据未封闭路径构造的 Area 对象，就像通过 Graphics2D.fill 方法填充这些路径一样。
  • 单个存储子路径的内部都是非空且不重叠的。在构造期间，路径被分解为独立组件的不重叠部分，路径的空白部分被丢弃，然后通过所有后续 CAG 操作维护那些非空且不重叠的属性。不同组件子路径的轮廓可以互相接触，只要它们不相交从而造成封闭区域重叠即可。
  • 描述 Area 轮廓的路径几何形状类似于为了描述同一封闭 2 维区域而构造的路径，但可以使用完全不同的类型和路径段排序来完成路径构造。
在使用 Area 时，一些并不总是很明显但值得注意的问题包括：
  • 在未封闭（开放）Shape 中创建一个 Area 导致在 Area 对象中产生一个封闭的轮廓。
  • 在不封闭任何区域（甚至在“封闭”时）的 Shape 中创建一个 Area 将产生一个空的 Area。该问题的一个常见示例是：用一条直线生成的 Area 将是空的，因为该直线无法封闭任何区域。一个空的 Area 将不会迭代其 PathIterator 对象中的任何几何形状。
  • 一个自相交的 Shape 可以分割成两条（或更多条）子路径，每条子路径都封闭原始路径的非相交部分之一。
  • Area 可以采用更多路径段来描述相同的几何形状，即使在原始轮廓非常简单和明显时也是如此。正如人们所认识到的那样，Area 类必须在路径上执行的分析可能并不能反映“简单而明显”的概念。

从以下版本开始：
1.2

构造方法摘要
Area()
创建空区域的默认构造方法。
Area(Shape s)
Area 类可以根据指定的 Shape 对象创建区域几何形状。
方法摘要
void | add(Area rhs) 将指定 Area 的形状添加到此 Area 的形状中。
Object | clone() 返回此 Area 对象的精确副本。
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
boolean | contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
Area | createTransformedArea(AffineTransform t) 创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。
boolean | equals(Area other) 测试两个 Area 对象的几何形状是否相等。
void | exclusiveOr(Area rhs) 将此 Area 的形状设置为其当前形状与指定 Area 形状的组合区域，并减去其交集。
Rectangle | getBounds() 返回完全包围此 Area 的边界 Rectangle。
Rectangle2D | getBounds2D() 返回完全包围此 Area 的高精度边界 Rectangle2D。
PathIterator | getPathIterator(AffineTransform at) 为此 Area 对象的轮廓创建一个 PathIterator。
PathIterator | getPathIterator(AffineTransform at, double flatness) 为此 Area 对象的变平轮廓创建 PathIterator。
void | intersect(Area rhs) 将此 Area 的形状设置为其当前形状与指定 Area 形状的交集。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
boolean | intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | isEmpty() 测试此 Area 对象是否包括其他区域。
boolean | isPolygonal() 测试此 Area 是否完全由直边多边形组成。
boolean | isRectangular() 测试此 Area 的形状是否为矩形。
boolean | isSingular() 测试此 Area 是否由单个封闭子路径组成。
void | reset() 从此 Area 删除所有几何形状，将其恢复为空区域。
void | subtract(Area rhs) 从此 Area 的形状中减去指定 Area 的形状。
void | transform(AffineTransform t) 使用指定的 AffineTransform 变换此 Area 的几何形状。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Area

public Area()
创建空区域的默认构造方法。

从以下版本开始：
1.2

Area

public Area(Shape s)
Area 类可以根据指定的 Shape 对象创建区域几何形状。如果 Shape 还不是封闭的，则显式地封闭几何形状。由 Shape 的几何形状指定的填充规则（奇偶或缠绕）用于确定得到的封闭区域。

参数：
s - 据以构造区域的 Shape
抛出：
NullPointerException - 如果 s 为 null
从以下版本开始：
1.2
方法详细信息

add

public void add(Area rhs)
将指定 Area 的形状添加到此 Area 的形状中。得到的 Area 形状将包括两个形状的并集，或者包含此 Area 或指定 Area 中的所有区域。
//Example:
Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
a1.add(a2);

a1(before)     +         a2         =     a1(after)

     ################     ################     ################
     ##############         ##############     ################
     ############             ############     ################
     ##########                 ##########     ################
     ########                     ########     ################
     ######                         ######     ######    ######
     ####                             ####     ####        ####
     ##                                 ##     ##            ##

参数：
rhs - 将添加到当前形状的 Area
抛出：
NullPointerException - 如果 rhs 为 null
从以下版本开始：
1.2

subtract

public void subtract(Area rhs)
从此 Area 的形状中减去指定 Area 的形状。得到的 Area 形状将包括那些仅包括那些包含在此 Area 且不包含在指定 Area 中的区域。
//Example:
Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
a1.subtract(a2);

a1(before)     -         a2         =     a1(after)

     ################     ################
     ##############         ##############     ##
     ############             ############     ####
     ##########                 ##########     ######
     ########                     ########     ########
     ######                         ######     ######
     ####                             ####     ####
     ##                                 ##     ##

参数：
rhs - 将从当前形状中删除的 Area
抛出：
NullPointerException - 如果 rhs 为 null
从以下版本开始：
1.2

intersect

public void intersect(Area rhs)
将此 Area 的形状设置为其当前形状与指定 Area 形状的交集。得到的 Area 形状将仅包括那些既包含在此 Area 中也包含在指定 Area 中的区域。
//Example:
Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
a1.intersect(a2);

a1(before)   intersect     a2         =     a1(after)

     ################     ################     ################
     ##############         ##############       ############
     ############             ############         ########
     ##########                 ##########           ####
     ########                     ########
     ######                         ######
     ####                             ####
     ##                                 ##

参数：
rhs - 将与此 Area 相交的 Area
抛出：
NullPointerException - 如果 rhs 为 null
从以下版本开始：
1.2

exclusiveOr

public void exclusiveOr(Area rhs)
将此 Area 的形状设置为其当前形状与指定 Area 形状的组合区域，并减去其交集。得到的 Area 形状将仅包括那些包含在此 Area 或指定 Area 中、但不同时出现在两者中的区域。
//Example:
Area a1 = new Area([triangle 0,0 => 8,0 => 0,8]);
Area a2 = new Area([triangle 0,0 => 8,0 => 8,8]);
a1.exclusiveOr(a2);

a1(before)    xor        a2         =     a1(after)

     ################     ################
     ##############         ##############     ##            ##
     ############             ############     ####        ####
     ##########                 ##########     ######    ######
     ########                     ########     ################
     ######                         ######     ######    ######
     ####                             ####     ####        ####
     ##                                 ##     ##            ##

参数：
rhs - 将与此 Area 进行异或运算的 Area。
抛出：
NullPointerException - 如果 rhs 为 null
从以下版本开始：
1.2

reset

public void reset()
从此 Area 删除所有几何形状，将其恢复为空区域。

从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
测试此 Area 对象是否包括其他区域。

返回：
如果此 Area 对象表示空区域，则返回 true；否则返回 false。
从以下版本开始：
1.2

isPolygonal

public boolean isPolygonal()
测试此 Area 是否完全由直边多边形组成。

返回：
如果此 Area 全部由线段组成，则返回 true；否则返回 false。
从以下版本开始：
1.2

isRectangular

public boolean isRectangular()
测试此 Area 的形状是否为矩形。

返回：
如果此 Area 的几何形状是矩形，则返回 true；否则返回 false。
从以下版本开始：
1.2

isSingular

public boolean isSingular()
测试此 Area 是否由单个封闭子路径组成。如果路径包含 0 个或 1 个子路径，则此方法返回 true；如果路径包含 1 个以上的子路径，则返回 false。子路径是根据路径中出现的 SEG_MOVETO 段数来计算的。

返回：
如果 Area 由单个基本几何形状组成，则返回 true；否则返回 false。
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回完全包围此 Area 的高精度边界 Rectangle2D。

Area 类将试图为 Shape 返回可能的最紧密的边界框。不要填充边界框以包含 Shape 轮廓上的曲线控制点，而应该让边界框紧密地适合轮廓本身的实际几何形状。

指定者：
接口 Shape 中的 getBounds2D
返回：
Area 的边界 Rectangle2D。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()

getBounds

public Rectangle getBounds()
返回完全包围此 Area 的边界 Rectangle。

Area 类将试图为 Shape 返回可能的最紧密的边界框。不要填充边界框以包含 Shape 轮廓上的曲线控制点，而应该让边界框紧密地适合轮廓本身的实际几何形状。因为返回的对象使用整数表示边界框，所以边界框只能是围绕 Shape 几何形状尽可能紧密的整数坐标。

指定者：
接口 Shape 中的 getBounds
返回：
Area 的边界 Rectangle。
从以下版本开始：
1.2
另请参见：
Shape.getBounds2D()

clone

public Object clone()
返回此 Area 对象的精确副本。

覆盖：
类 Object 中的 clone
返回：
创建的副本对象
从以下版本开始：
1.2
另请参见：
Cloneable

equals

public boolean equals(Area other)
测试两个 Area 对象的几何形状是否相等。如果参数为 null，则此方法将返回 false。

参数：
other - 将与此 Area 比较的 Area
返回：
如果两个几何形状相等，则返回 true；否则返回 false。
从以下版本开始：
1.2

transform

public void transform(AffineTransform t)
使用指定的 AffineTransform 变换此 Area 的几何形状。适当地变换几何形状，它将永久更改由此对象定义的封闭区域。

参数：
t - 用于变换区域的变换
抛出：
NullPointerException - 如果 t 为 null
从以下版本开始：
1.2

createTransformedArea

public Area createTransformedArea(AffineTransform t)
创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。此 Area 对象不变。

参数：
t - 用于变换新 Area 的指定 AffineTransform
返回：
表示已变换的几何形状的新 Area 对象。
抛出：
NullPointerException - 如果 t 为 null
从以下版本开始：
1.2

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

contains

public boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
p - 要测试的指定的 Point2D
返回：
如果指定的 Point2D 在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

contains

public boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：
  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含 Rectangle2D 的代价太高。
这意味着对于某些 Shape，即使 Shape 包含 Rectangle2D，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部完全包含 Rectangle2D，则返回 true；否则，如果 Shape 包含 Rectangle2D、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.contains(double, double, double, double)

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

intersects

public boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.intersects(double, double, double, double)

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
为此 Area 对象的轮廓创建一个 PathIterator。此 Area 对象不变。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 一个可选的 AffineTransform，应用于在迭代中返回的坐标；如果需要未变换的坐标，则为 null
返回：
返回此 Area 轮廓几何形状的 PathIterator 对象，一次一段。
从以下版本开始：
1.2

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
为此 Area 对象的变平轮廓创建 PathIterator。迭代器只返回 SEG_MOVETO、SEG_LINETO 和 SEG_CLOSE 点类型所表示的非曲线路径段。此 Area 对象不变。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 一个可选的 AffineTransform，应用于在迭代中返回的坐标；如果需要未变换的坐标，则为 null
flatness - 在使用连接端点的直线取代分段曲线之前，给定曲线的控制点可以从共线变化的最大值
返回：
返回此 Area 轮廓几何形状的 PathIterator 对象，一次一段。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CubicCurve2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 CubicCurve2D

java.lang.Object
    继承者  java.awt.geom.CubicCurve2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
CubicCurve2D.Double, CubicCurve2D.Float
public abstract class CubicCurve2D
extends Object
implements Shape, Cloneable

CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。

此类是所有存储 2D 三次曲线段的对象的惟一抽象超类。坐标的实际存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。
构造方法摘要
protected CubicCurve2D()
这是一个不可直接实例化的抽象类。
方法摘要
Object | clone() 创建一个与此对象具有相同类的新对象。
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
boolean | contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
Rectangle | getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
abstract Point2D | getCtrlP1() 返回第一个控制点。
abstract Point2D | getCtrlP2() 返回第二个控制点。
abstract double | getCtrlX1() 以 double 精度返回第一个控制点的 X 坐标。
abstract double | getCtrlX2() 以 double 精度返回第二个控制点的 X 坐标。
abstract double | getCtrlY1() 以 double 精度返回第一个控制点的 Y 坐标。
abstract double | getCtrlY2() 以 double 精度返回第二个控制点的 Y 坐标。
double | getFlatness() 返回此曲线的平面度。
static double | getFlatness(double[] coords, int offset) 返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线的平面度。
static double | getFlatness(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2) 返回由指示控制点指定的三次曲线的平面度。
double | getFlatnessSq() 返回此曲线平面度的平方。
static double | getFlatnessSq(double[] coords, int offset) 返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线平面度的平方。
static double | getFlatnessSq(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2) 返回由指示的控制点指定的三次曲线平面度的平方。
abstract Point2D | getP1() 返回起始点。
abstract Point2D | getP2() 返回结束点。
PathIterator | getPathIterator(AffineTransform at) 返回定义形状边界的迭代对象。
PathIterator | getPathIterator(AffineTransform at, double flatness) 返回定义变平形状边界的迭代对象。
abstract double | getX1() 以 double 精度返回起始点的 X 坐标。
abstract double | getX2() 以 double 精度返回结束点的 X 坐标。
abstract double | getY1() 以 double 精度返回起始点的 Y 坐标。
abstract double | getY2() 以 double 精度返回结束点的 Y 坐标。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
boolean | intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
void | setCurve(CubicCurve2D c) 将此曲线端点和控制点的位置设置为与指定的 CubicCurve2D 相同。
void | setCurve(double[] coords, int offset) 将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 double 坐标。
abstract void | setCurve(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2) 将此曲线端点和控制点的位置设置为指定的 double 坐标。
void | setCurve(Point2D[] pts, int offset) 将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 Point2D 对象的坐标。
void | setCurve(Point2D p1, Point2D cp1, Point2D cp2, Point2D p2) 将此曲线端点和控制点的位置设置为指定的 Point2D 坐标。
static int | solveCubic(double[] eqn) 解系数位于 eqn 数组中的三次曲线，并将非复数的根放回该数组，同时返回根数。
static int | solveCubic(double[] eqn, double[] res) 解系数位于 eqn 数组中的三次曲线，并将非复数的根放入 res 数组，同时返回根数。
void | subdivide(CubicCurve2D left, CubicCurve2D right) 细分此三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
static void | subdivide(CubicCurve2D src, CubicCurve2D left, CubicCurve2D right) 细分由 src 参数指定的三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
static void | subdivide(double[] src, int srcoff, double[] left, int leftoff, double[] right, int rightoff) 细分由存储在 src 数组 srcoff 到 (srcoff + 7) 索引处的坐标指定的三次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Shape 继承的方法
getBounds2D

构造方法详细信息

CubicCurve2D

protected CubicCurve2D()
这是一个不可直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
CubicCurve2D.Float, CubicCurve2D.Double
方法详细信息

getX1

public abstract double getX1()
以 double 精度返回起始点的 X 坐标。

返回：
CubicCurve2D 起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public abstract double getY1()
以 double 精度返回起始点的 Y 坐标。

返回：
CubicCurve2D 起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public abstract Point2D getP1()
返回起始点。

返回：
作为 CubicCurve2D 起始点的 Point2D。
从以下版本开始：
1.2

getCtrlX1

public abstract double getCtrlX1()
以 double 精度返回第一个控制点的 X 坐标。

返回：
CubicCurve2D 第一个控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY1

public abstract double getCtrlY1()
以 double 精度返回第一个控制点的 Y 坐标。

返回：
CubicCurve2D 第一个控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlP1

public abstract Point2D getCtrlP1()
返回第一个控制点。

返回：
CubicCurve2D 第一个控制点的 Point2D。
从以下版本开始：
1.2

getCtrlX2

public abstract double getCtrlX2()
以 double 精度返回第二个控制点的 X 坐标。

返回：
CubicCurve2D 第二个控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY2

public abstract double getCtrlY2()
以 double 精度返回第二个控制点的 Y 坐标。

返回：
CubicCurve2D 第二个控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlP2

public abstract Point2D getCtrlP2()
返回第二个控制点。

返回：
作为 CubicCurve2D 第二个控制点的 Point2D。
从以下版本开始：
1.2

getX2

public abstract double getX2()
以 double 精度返回结束点的 X 坐标。

返回：
CubicCurve2D 结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public abstract double getY2()
以 double 精度返回结束点的 Y 坐标。

返回：
CubicCurve2D 结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public abstract Point2D getP2()
返回结束点。

返回：
作为 CubicCurve2D 结束点的 Point2D。
从以下版本开始：
1.2

setCurve

public abstract void setCurve(double x1,
                              double y1,
                              double ctrlx1,
                              double ctrly1,
                              double ctrlx2,
                              double ctrly2,
                              double x2,
                              double y2)
将此曲线端点和控制点的位置设置为指定的 double 坐标。

参数：
x1 - 用于设置此 CubicCurve2D 起始点的 X 坐标
y1 - 用于设置此 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 用于设置此 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 用于设置此 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 用于设置此 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 用于设置此 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 用于设置此 CubicCurve2D 结束点的 X 坐标
y2 - 用于设置此 CubicCurve2D 结束点的 Y 坐标
从以下版本开始：
1.2

setCurve

public void setCurve(double[] coords,
                     int offset)
将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 double 坐标。

参数：
coords - 包含坐标的 double 数组
offset - coords 的索引，从该索引处开始将此曲线端点和控制点设置为 coords 中包含的坐标
从以下版本开始：
1.2

setCurve

public void setCurve(Point2D p1,
                     Point2D cp1,
                     Point2D cp2,
                     Point2D p2)
将此曲线端点和控制点的位置设置为指定的 Point2D 坐标。

参数：
p1 - 用于设置此曲线起始点的第一个指定的 Point2D
cp1 - 用于设置此曲线第一个控制点的第二个指定的 Point2D
cp2 - 用于设置此曲线第二个控制点的第三个指定的 Point2D
p2 - 用于设置此曲线结束点的第四个指定的 Point2D
从以下版本开始：
1.2

setCurve

public void setCurve(Point2D[] pts,
                     int offset)
将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 Point2D 对象的坐标。

参数：
pts - Point2D 对象数组
offset - pts 的索引，从该索引处开始将此曲线端点和控制点设置为 pts 中包含的点
从以下版本开始：
1.2

setCurve

public void setCurve(CubicCurve2D c)
将此曲线端点和控制点的位置设置为与指定的 CubicCurve2D 相同。

参数：
c - 指定的 CubicCurve2D
从以下版本开始：
1.2

getFlatnessSq

public static double getFlatnessSq(double x1,
                                   double y1,
                                   double ctrlx1,
                                   double ctrly1,
                                   double ctrlx2,
                                   double ctrly2,
                                   double x2,
                                   double y2)
返回由指示的控制点指定的三次曲线平面度的平方。平面度是控制点到连接端点的线之间的最大距离。

参数：
x1 - 指定 CubicCurve2D 起始点的 X 坐标
y1 - 指定 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 指定 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 指定 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 指定 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 指定 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 指定 CubicCurve2D 结束点的 X 坐标
y2 - 指定 CubicCurve2D 结束点的 Y 坐标
返回：
用指定坐标表示的 CubicCurve2D 平面度的平方。
从以下版本开始：
1.2

getFlatness

public static double getFlatness(double x1,
                                 double y1,
                                 double ctrlx1,
                                 double ctrly1,
                                 double ctrlx2,
                                 double ctrly2,
                                 double x2,
                                 double y2)
返回由指示控制点指定的三次曲线的平面度。平面度是控制点到连接端点的线之间的最大距离。

参数：
x1 - 指定 CubicCurve2D 起始点的 X 坐标
y1 - 指定 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 指定 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 指定 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 指定 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 指定 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 指定 CubicCurve2D 结束点的 X 坐标
y2 - 指定 CubicCurve2D 结束点的 Y 坐标
返回：
用指定坐标表示的 CubicCurve2D 平面度。
从以下版本开始：
1.2

getFlatnessSq

public static double getFlatnessSq(double[] coords,
                                   int offset)
返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线平面度的平方。平面度是控制点到连接端点的线之间的最大距离。

参数：
coords - 包含坐标的数组
offset - coords 的索引，从该索引处开始设置此曲线的端点和控制点
返回：
由 coords 中指定偏移量处的坐标指定的 CubicCurve2D 平面度的平方。
从以下版本开始：
1.2

getFlatness

public static double getFlatness(double[] coords,
                                 int offset)
返回由控制点（存储在指示数组中的指示索引处）指定的三次曲线的平面度。平面度是控制点到连接端点的线之间的最大距离。

参数：
coords - 包含坐标的数组
offset - coords 的索引，从该索引处开始设置此曲线的端点和控制点
返回：
由 coords 中指定偏移量处的坐标指定的 CubicCurve2D 平面度。
从以下版本开始：
1.2

getFlatnessSq

public double getFlatnessSq()
返回此曲线平面度的平方。平面度是控制点到连接端点的线之间的最大距离。

返回：
此曲线平面度的平方。
从以下版本开始：
1.2

getFlatness

public double getFlatness()
返回此曲线的平面度。平面度是控制点到连接端点的线之间的最大距离。

返回：
此曲线的平面度。
从以下版本开始：
1.2

subdivide

public void subdivide(CubicCurve2D left,
                      CubicCurve2D right)
细分此三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。left 和 right 两个对象中的一个（或两者）可以与此对象相同，也可以为 null。

参数：
left - 用于存储左边一半（或第一半）细分曲线的三次曲线对象
right - 用于存储右边一半（或第二半）细分曲线的三次曲线对象
从以下版本开始：
1.2

subdivide

public static void subdivide(CubicCurve2D src,
                             CubicCurve2D left,
                             CubicCurve2D right)
细分由 src 参数指定的三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。left 和 right 两个对象的一个（或两个）可以与 src 对象相同，也可以为 null。

参数：
src - 要细分的三次曲线
left - 用于存储左边一半（或第一半）细分曲线的三次曲线对象
right - 用于存储右边一半（或第二半）细分曲线的三次曲线对象
从以下版本开始：
1.2

subdivide

public static void subdivide(double[] src,
                             int srcoff,
                             double[] left,
                             int leftoff,
                             double[] right,
                             int rightoff)
细分由存储在 src 数组 srcoff 到 (srcoff + 7) 索引处的坐标指定的三次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。left 和 right 数组中的一个（或两者）可以为 null，也可以是到与 src 相同的数组的引用。注意，第一个细分曲线的最后一点就是第二个细分曲线的第一点。因此，可以为 left 和 right 传递相同的数组并使用偏移量（如 rightoff 等于 (leftoff + 6)），以避免为此公共点分配额外的存储区。

参数：
src - 保存源曲线坐标的数组
srcoff - 6 个源坐标的开头在数组中的偏移量
left - 存储第一半细分曲线坐标的数组
leftoff - 6 个左坐标的开头在数组中的偏移量
right - 存储第二半细分曲线坐标的数组
rightoff - 6 个右坐标的开头在数组中的偏移量
从以下版本开始：
1.2

solveCubic

public static int solveCubic(double[] eqn)
解系数位于 eqn 数组中的三次曲线，并将非复数的根放回该数组，同时返回根数。用以下方程表示三次曲线的解：
     eqn = {c, b, a, d}
     dx^3 + ax^2 + bx + c = 0
返回值 -1 用于区分常数方程（可以始终为 0 或永远不为 0）与不包含任何零的方程。

参数：
eqn - 包含三次曲线系数的数组
返回：
根数；如果方程是常数方程，则返回 -1。
从以下版本开始：
1.2

solveCubic

public static int solveCubic(double[] eqn,
                             double[] res)
解系数位于 eqn 数组中的三次曲线，并将非复数的根放入 res 数组，同时返回根数。用以下方程表示三次曲线的解：eqn = {c, b, a, d} dx^3 + ax^2 + bx + c = 0。返回值 -1 用于区分常数方程（可以始终为 0 或永远不为 0）与不包含任何零的方程。

参数：
eqn - 用于解三次曲线方程的指定系数数组
res - 包含求解三次曲线方程所得非复数根的数组
返回：
根数；如果方程是常数方程，则返回 -1
从以下版本开始：
1.3

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

contains

public boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
p - 要测试的指定的 Point2D
返回：
如果指定的 Point2D 在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

intersects

public boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.intersects(double, double, double, double)

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

contains

public boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：
  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含 Rectangle2D 的代价太高。
这意味着对于某些 Shape，即使 Shape 包含 Rectangle2D，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部完全包含 Rectangle2D，则返回 true；否则，如果 Shape 包含 Rectangle2D、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.contains(double, double, double, double)

getBounds

public Rectangle getBounds()
返回一个完全包围 Shape 的整型 Rectangle。注意，不保证返回的 Rectangle 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle 中。如果 Shape 超出了整数数据类型的有效范围，则返回的 Rectangle 也可能不完全包围 Shape。getBounds2D 方法由于在表示形式上具有更大的灵活性，所以通常返回更紧密的边界框。

指定者：
接口 Shape 中的 getBounds
返回：
完全包围 Shape 的整型 Rectangle。
从以下版本开始：
1.2
另请参见：
Shape.getBounds2D()

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回定义形状边界的迭代对象。此类的迭代器不是多线程安全的，这意味着此 CubicCurve2D 类不保证对此 CubicCurve2D 对象几何形状所作的修改不会影响该几何形状中正进行的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 一个可选的 AffineTransform，用于在迭代中返回的坐标；如果需要未变换的坐标，则为 null
返回：
返回此 CubicCurve2D 轮廓几何形状的 PathIterator 对象，一次一段。
从以下版本开始：
1.2

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
返回定义变平形状边界的迭代对象。此类的迭代器不是多线程安全的，这意味着此 CubicCurve2D 类不保证对此 CubicCurve2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 一个可选的 AffineTransform，用于迭代中返回的坐标；如果需要未变换的坐标，则为 null
flatness - 在由连接端点的直线取代细分曲线之前，给定曲线的控制点可以从共线变化的最大量
返回：
返回此 CubicCurve2D 轮廓几何形状的 PathIterator 对象，一次一段。
从以下版本开始：
1.2

clone

public Object clone()
创建一个与此对象具有相同类的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.2
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CubicCurve2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 CubicCurve2D.Double

java.lang.Object
    继承者  java.awt.geom.CubicCurve2D
        继承者  java.awt.geom.CubicCurve2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
CubicCurve2D
public static class CubicCurve2D.Double
extends CubicCurve2D
implements Serializable

使用 double 坐标指定的三次参数曲线段。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.CubicCurve2D 继承的嵌套类/接口
CubicCurve2D.Double, CubicCurve2D.Float
字段摘要
double | ctrlx1 三次曲线段第一个控制点的 X 坐标。
double | ctrlx2 三次曲线段第二个控制点的 X 坐标。
double | ctrly1 三次曲线段第一个控制点的 Y 坐标。
double | ctrly2 三次曲线段第二个控制点的 Y 坐标。
double | x1 三次曲线段起始点的 X 坐标。
double | x2 三次曲线段结束点的 X 坐标。
double | y1 三次曲线段起始点的 Y 坐标。
double | y2 三次曲线段结束点的 Y 坐标。
构造方法摘要
CubicCurve2D.Double()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。
CubicCurve2D.Double(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2)
根据指定的 double 坐标构造并初始化一个 CubicCurve2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Point2D | getCtrlP1() 返回第一个控制点。
Point2D | getCtrlP2() 返回第二个控制点。
double | getCtrlX1() 以 double 精度返回第一个控制点的 X 坐标。
double | getCtrlX2() 以 double 精度返回第二个控制点的 X 坐标。
double | getCtrlY1() 以 double 精度返回第一个控制点的 Y 坐标。
double | getCtrlY2() 以 double 精度返回第二个控制点的 Y 坐标。
Point2D | getP1() 返回起始点。
Point2D | getP2() 返回结束点。
double | getX1() 以 double 精度返回起始点的 X 坐标。
double | getX2() 以 double 精度返回结束点的 X 坐标。
double | getY1() 以 double 精度返回起始点的 Y 坐标。
double | getY2() 以 double 精度返回结束点的 Y 坐标。
void | setCurve(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2) 将此曲线端点和控制点的位置设置为指定的 double 坐标。
从类 java.awt.geom.CubicCurve2D 继承的方法
clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveCubic, solveCubic, subdivide, subdivide, subdivide
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x1

public double x1
三次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

public double y1
三次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx1

public double ctrlx1
三次曲线段第一个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly1

public double ctrly1
三次曲线段第一个控制点的 Y 坐标。

从以下版本开始：
1.2

ctrlx2

public double ctrlx2
三次曲线段第二个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly2

public double ctrly2
三次曲线段第二个控制点的 Y 坐标。

从以下版本开始：
1.2

x2

public double x2
三次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

public double y2
三次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

CubicCurve2D.Double

public CubicCurve2D.Double()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。

从以下版本开始：
1.2

CubicCurve2D.Double

public CubicCurve2D.Double(double x1,
                           double y1,
                           double ctrlx1,
                           double ctrly1,
                           double ctrlx2,
                           double ctrly2,
                           double x2,
                           double y2)
根据指定的 double 坐标构造并初始化一个 CubicCurve2D。

参数：
x1 - 得到的 CubicCurve2D 起始点的 X 坐标
y1 - 得到的 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 得到的 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 得到的 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 得到的 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 得到的 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 得到的 CubicCurve2D 结束点的 X 坐标
y2 - 得到的 CubicCurve2D 结束点的 Y 坐标
从以下版本开始：
1.2
方法详细信息

getX1

public double getX1()
以 double 精度返回起始点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getX1
返回：
CubicCurve2D 起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public double getY1()
以 double 精度返回起始点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getY1
返回：
CubicCurve2D 起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public Point2D getP1()
返回起始点。

指定者：
类 CubicCurve2D 中的 getP1
返回：
作为 CubicCurve2D 起始点的 Point2D。
从以下版本开始：
1.2

getCtrlX1

public double getCtrlX1()
以 double 精度返回第一个控制点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlX1
返回：
CubicCurve2D 第一个控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY1

public double getCtrlY1()
以 double 精度返回第一个控制点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlY1
返回：
CubicCurve2D 第一个控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlP1

public Point2D getCtrlP1()
返回第一个控制点。

指定者：
类 CubicCurve2D 中的 getCtrlP1
返回：
CubicCurve2D 第一个控制点的 Point2D。
从以下版本开始：
1.2

getCtrlX2

public double getCtrlX2()
以 double 精度返回第二个控制点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlX2
返回：
CubicCurve2D 第二个控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY2

public double getCtrlY2()
以 double 精度返回第二个控制点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlY2
返回：
CubicCurve2D 第二个控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlP2

public Point2D getCtrlP2()
返回第二个控制点。

指定者：
类 CubicCurve2D 中的 getCtrlP2
返回：
作为 CubicCurve2D 第二个控制点的 Point2D。
从以下版本开始：
1.2

getX2

public double getX2()
以 double 精度返回结束点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getX2
返回：
CubicCurve2D 结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public double getY2()
以 double 精度返回结束点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getY2
返回：
CubicCurve2D 结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public Point2D getP2()
返回结束点。

指定者：
类 CubicCurve2D 中的 getP2
返回：
作为 CubicCurve2D 结束点的 Point2D。
从以下版本开始：
1.2

setCurve

public void setCurve(double x1,
                     double y1,
                     double ctrlx1,
                     double ctrly1,
                     double ctrlx2,
                     double ctrly2,
                     double x2,
                     double y2)
将此曲线端点和控制点的位置设置为指定的 double 坐标。

指定者：
类 CubicCurve2D 中的 setCurve
参数：
x1 - 用于设置此 CubicCurve2D 起始点的 X 坐标
y1 - 用于设置此 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 用于设置此 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 用于设置此 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 用于设置此 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 用于设置此 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 用于设置此 CubicCurve2D 结束点的 X 坐标
y2 - 用于设置此 CubicCurve2D 结束点的 Y 坐标
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CubicCurve2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 CubicCurve2D.Float

java.lang.Object
    继承者  java.awt.geom.CubicCurve2D
        继承者  java.awt.geom.CubicCurve2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
CubicCurve2D
public static class CubicCurve2D.Float
extends CubicCurve2D
implements Serializable

使用 float 坐标指定的三次参数曲线段。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.CubicCurve2D 继承的嵌套类/接口
CubicCurve2D.Double, CubicCurve2D.Float
字段摘要
float | ctrlx1 三次曲线段第一个控制点的 X 坐标。
float | ctrlx2 三次曲线段第二个控制点的 X 坐标。
float | ctrly1 三次曲线段第一个控制点的 Y 坐标。
float | ctrly2 三次曲线段第二个控制点的 Y 坐标。
float | x1 三次曲线段起始点的 X 坐标。
float | x2 三次曲线段结束点的 X 坐标。
float | y1 三次曲线段起始点的 Y 坐标。
float | y2 三次曲线段结束点的 Y 坐标。
构造方法摘要
CubicCurve2D.Float()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。
CubicCurve2D.Float(float x1, float y1, float ctrlx1, float ctrly1, float ctrlx2, float ctrly2, float x2, float y2)
根据指定的 float 坐标构造并初始化一个 CubicCurve2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Point2D | getCtrlP1() 返回第一个控制点。
Point2D | getCtrlP2() 返回第二个控制点。
double | getCtrlX1() 以 double 精度返回第一个控制点的 X 坐标。
double | getCtrlX2() 以 double 精度返回第二个控制点的 X 坐标。
double | getCtrlY1() 以 double 精度返回第一个控制点的 Y 坐标。
double | getCtrlY2() 以 double 精度返回第二个控制点的 Y 坐标。
Point2D | getP1() 返回起始点。
Point2D | getP2() 返回结束点。
double | getX1() 以 double 精度返回起始点的 X 坐标。
double | getX2() 以 double 精度返回结束点的 X 坐标。
double | getY1() 以 double 精度返回起始点的 Y 坐标。
double | getY2() 以 double 精度返回结束点的 Y 坐标。
void | setCurve(double x1, double y1, double ctrlx1, double ctrly1, double ctrlx2, double ctrly2, double x2, double y2) 将此曲线端点和控制点的位置设置为指定的 double 坐标。
void | setCurve(float x1, float y1, float ctrlx1, float ctrly1, float ctrlx2, float ctrly2, float x2, float y2) 将此曲线结束点和控制点的位置设置为指定的 float 坐标。
从类 java.awt.geom.CubicCurve2D 继承的方法
clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveCubic, solveCubic, subdivide, subdivide, subdivide
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x1

public float x1
三次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

public float y1
三次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx1

public float ctrlx1
三次曲线段第一个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly1

public float ctrly1
三次曲线段第一个控制点的 Y 坐标。

从以下版本开始：
1.2

ctrlx2

public float ctrlx2
三次曲线段第二个控制点的 X 坐标。

从以下版本开始：
1.2

ctrly2

public float ctrly2
三次曲线段第二个控制点的 Y 坐标。

从以下版本开始：
1.2

x2

public float x2
三次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

public float y2
三次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

CubicCurve2D.Float

public CubicCurve2D.Float()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 CubicCurve。

从以下版本开始：
1.2

CubicCurve2D.Float

public CubicCurve2D.Float(float x1,
                          float y1,
                          float ctrlx1,
                          float ctrly1,
                          float ctrlx2,
                          float ctrly2,
                          float x2,
                          float y2)
根据指定的 float 坐标构造并初始化一个 CubicCurve2D。

参数：
x1 - 得到的 CubicCurve2D 起始点的 X 坐标
y1 - 得到的 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 得到的 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 得到的 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 得到的 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 得到的 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 得到的 CubicCurve2D 结束点的 X 坐标
y2 - 得到的 CubicCurve2D 结束点的 Y 坐标
从以下版本开始：
1.2
方法详细信息

getX1

public double getX1()
以 double 精度返回起始点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getX1
返回：
CubicCurve2D 起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public double getY1()
以 double 精度返回起始点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getY1
返回：
CubicCurve2D 起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public Point2D getP1()
返回起始点。

指定者：
类 CubicCurve2D 中的 getP1
返回：
作为 CubicCurve2D 起始点的 Point2D。
从以下版本开始：
1.2

getCtrlX1

public double getCtrlX1()
以 double 精度返回第一个控制点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlX1
返回：
CubicCurve2D 第一个控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY1

public double getCtrlY1()
以 double 精度返回第一个控制点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlY1
返回：
CubicCurve2D 第一个控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlP1

public Point2D getCtrlP1()
返回第一个控制点。

指定者：
类 CubicCurve2D 中的 getCtrlP1
返回：
CubicCurve2D 第一个控制点的 Point2D。
从以下版本开始：
1.2

getCtrlX2

public double getCtrlX2()
以 double 精度返回第二个控制点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlX2
返回：
CubicCurve2D 第二个控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY2

public double getCtrlY2()
以 double 精度返回第二个控制点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getCtrlY2
返回：
CubicCurve2D 第二个控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlP2

public Point2D getCtrlP2()
返回第二个控制点。

指定者：
类 CubicCurve2D 中的 getCtrlP2
返回：
作为 CubicCurve2D 第二个控制点的 Point2D。
从以下版本开始：
1.2

getX2

public double getX2()
以 double 精度返回结束点的 X 坐标。

指定者：
类 CubicCurve2D 中的 getX2
返回：
CubicCurve2D 结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public double getY2()
以 double 精度返回结束点的 Y 坐标。

指定者：
类 CubicCurve2D 中的 getY2
返回：
CubicCurve2D 结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public Point2D getP2()
返回结束点。

指定者：
类 CubicCurve2D 中的 getP2
返回：
作为 CubicCurve2D 结束点的 Point2D。
从以下版本开始：
1.2

setCurve

public void setCurve(double x1,
                     double y1,
                     double ctrlx1,
                     double ctrly1,
                     double ctrlx2,
                     double ctrly2,
                     double x2,
                     double y2)
将此曲线端点和控制点的位置设置为指定的 double 坐标。

指定者：
类 CubicCurve2D 中的 setCurve
参数：
x1 - 用于设置此 CubicCurve2D 起始点的 X 坐标
y1 - 用于设置此 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 用于设置此 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 用于设置此 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 用于设置此 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 用于设置此 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 用于设置此 CubicCurve2D 结束点的 X 坐标
y2 - 用于设置此 CubicCurve2D 结束点的 Y 坐标
从以下版本开始：
1.2

setCurve

public void setCurve(float x1,
                     float y1,
                     float ctrlx1,
                     float ctrly1,
                     float ctrlx2,
                     float ctrly2,
                     float x2,
                     float y2)
将此曲线结束点和控制点的位置设置为指定的 float 坐标。

参数：
x1 - 用于设置此 CubicCurve2D 起始点的 X 坐标
y1 - 用于设置此 CubicCurve2D 起始点的 Y 坐标
ctrlx1 - 用于设置此 CubicCurve2D 第一个控制点的 X 坐标
ctrly1 - 用于设置此 CubicCurve2D 第一个控制点的 Y 坐标
ctrlx2 - 用于设置此 CubicCurve2D 第二个控制点的 X 坐标
ctrly2 - 用于设置此 CubicCurve2D 第二个控制点的 Y 坐标
x2 - 用于设置此 CubicCurve2D 结束点的 X 坐标
y2 - 用于设置此 CubicCurve2D 结束点的 Y 坐标
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Dimension2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Dimension2D

java.lang.Object
    继承者  java.awt.geom.Dimension2D
所有已实现的接口：
Cloneable
直接已知子类：
Dimension
public abstract class Dimension2D
extends Object
implements Cloneable

Dimension2D 类用于封装宽度和高度尺寸。

此类是所有存储 2D 尺寸的对象的惟一抽象超类。大小的实际存储表示形式由子类决定。

从以下版本开始：
1.2

构造方法摘要
protected Dimension2D()
这是一个不可直接实例化的抽象类。
方法摘要
Object | clone() 创建一个与此对象具有相同类的新对象。
abstract double | getHeight() 返回此 Dimension 的高度（以 double 精度表示）。
abstract double | getWidth() 返回此 Dimension 的宽度（以 double 精度表示）。
void | setSize(Dimension2D d) 将 Dimension2D 对象的大小设置为指定大小。
abstract void | setSize(double width, double height) 将此 Dimension 对象的大小设置为指定的宽度和高度。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Dimension2D

protected Dimension2D()
这是一个不可直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
Dimension
方法详细信息

getWidth

public abstract double getWidth()
返回此 Dimension 的宽度（以 double 精度表示）。

返回：
此 Dimension 的宽度。
从以下版本开始：
1.2

getHeight

public abstract double getHeight()
返回此 Dimension 的高度（以 double 精度表示）。

返回：
此 Dimension 的高度。
从以下版本开始：
1.2

setSize

public abstract void setSize(double width,
                             double height)
将此 Dimension 对象的大小设置为指定的宽度和高度。包含此方法是出于完整性考虑，与 Component 的 getSize 方法对应。

参数：
width - Dimension 对象的新宽度
height - Dimension 对象的新高度
从以下版本开始：
1.2

setSize

public void setSize(Dimension2D d)
将 Dimension2D 对象的大小设置为指定大小。包含此方法是出于完整性考虑，与 Component 的 getSize 方法对应。

参数：
d - Dimension2D 对象的新大小
从以下版本开始：
1.2

clone

public Object clone()
创建一个与此对象具有相同类的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.2
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Ellipse2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Ellipse2D

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Ellipse2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
Ellipse2D.Double, Ellipse2D.Float
public abstract class Ellipse2D
extends RectangularShape

Ellipse2D 类描述窗体矩形定义的椭圆。

此类是所有存储 2D 椭圆的对象的惟一抽象超类。坐标的实际存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
构造方法摘要
protected Ellipse2D()
这是一个无法直接实例化的抽象类。
方法摘要
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
boolean | equals(Object obj) 确定指定的 Object 是否与此 Ellipse2D 相等。
PathIterator | getPathIterator(AffineTransform at) 返回定义此 Ellipse2D 边界的迭代对象。
int | hashCode() 返回此 Ellipse2D 的哈希码。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Shape 继承的方法
getBounds2D

构造方法详细信息

Ellipse2D

protected Ellipse2D()
这是一个无法直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
Ellipse2D.Float, Ellipse2D.Double
方法详细信息

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在 Shape 的边界内。

参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回定义此 Ellipse2D 边界的迭代对象。此类的迭代器是多线程安全的，这意味着此 Ellipse2D 类保证对此 Ellipse2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

参数：
at - 一个可选的 AffineTransform，用于在迭代中返回的坐标；如果需要未转换的坐标，则为 null
返回：
返回此 Ellipse2D 轮廓几何形状的 PathIterator 对象，一次一段。
从以下版本开始：
1.2

hashCode

public int hashCode()
返回此 Ellipse2D 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Ellipse2D 的哈希码。
从以下版本开始：
1.6
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
确定指定的 Object 是否与此 Ellipse2D 相等。如果指定的 Object 是一个 Ellipse2D 实例并且其位置和大小与此 Ellipse2D 相同，那么该对象与此 Ellipse2D 相等。

覆盖：
类 Object 中的 equals
参数：
obj - 将与此 Ellipse2D 进行比较的 Object。
返回：
如果 obj 是一个 Ellipse2D 实例并且具有相同的值，则返回 true；否则返回 false。
从以下版本开始：
1.6
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Ellipse2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Ellipse2D.Double

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Ellipse2D
            继承者  java.awt.geom.Ellipse2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Ellipse2D
public static class Ellipse2D.Double
extends Ellipse2D
implements Serializable

Double 类以 double 精度定义椭圆。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Ellipse2D 继承的嵌套类/接口
Ellipse2D.Double, Ellipse2D.Float
字段摘要
double | height 此 Ellipse2D 的总高度。
double | width 此 Ellipse2D 的总宽度。
double | x 此 Ellipse2D 的窗体矩形左上角的 X 坐标。
double | y 此 Ellipse2D 的窗体矩形左上角的 Y 坐标。
构造方法摘要
Ellipse2D.Double()
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Ellipse2D.Double(double x, double y, double w, double h)
根据指定坐标构造和初始化 Ellipse2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
void | setFrame(double x, double y, double w, double h) 将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
从类 java.awt.geom.Ellipse2D 继承的方法
contains, contains, equals, getPathIterator, hashCode, intersects
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x

public double x
此 Ellipse2D 的窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

public double y
此 Ellipse2D 的窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

public double width
此 Ellipse2D 的总宽度。

从以下版本开始：
1.2

height

public double height
此 Ellipse2D 的总高度。

从以下版本开始：
1.2
构造方法详细信息

Ellipse2D.Double

public Ellipse2D.Double()
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。

从以下版本开始：
1.2

Ellipse2D.Double

public Ellipse2D.Double(double x,
                        double y,
                        double w,
                        double h)
根据指定坐标构造和初始化 Ellipse2D。

参数：
x - 窗体矩形左上角的 X 坐标
y - 窗体矩形左上角的 Y 坐标
w - 窗体矩形的宽度
h - 窗体矩形的高度
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setFrame

public void setFrame(double x,
                     double y,
                     double w,
                     double h)
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。

指定者：
类 RectangularShape 中的 setFrame
参数：
x - 指定矩形左上角的 X 坐标
y - 指定矩形左上角的 Y 坐标
w - 指定矩形的宽度
h - 指定矩形的高度
从以下版本开始：
1.2
另请参见：
RectangularShape.getFrame()

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Ellipse2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Ellipse2D.Float

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Ellipse2D
            继承者  java.awt.geom.Ellipse2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Ellipse2D
public static class Ellipse2D.Float
extends Ellipse2D
implements Serializable

Float 类以 float 精度定义椭圆。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Ellipse2D 继承的嵌套类/接口
Ellipse2D.Double, Ellipse2D.Float
字段摘要
float | height 此 Ellipse2D 的总高度。
float | width 此 Ellipse2D 的总宽度。
float | x 此 Ellipse2D 窗体矩形左上角的 X 坐标。
float | y 此 Ellipse2D 窗体矩形左上角的 Y 坐标。
构造方法摘要
Ellipse2D.Float()
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Ellipse2D.Float(float x, float y, float w, float h)
根据指定坐标构造和初始化 Ellipse2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
void | setFrame(double x, double y, double w, double h) 将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
void | setFrame(float x, float y, float w, float h) 将此 Shape 窗体矩形的位置和大小设置为指定矩形值。
从类 java.awt.geom.Ellipse2D 继承的方法
contains, contains, equals, getPathIterator, hashCode, intersects
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x

public float x
此 Ellipse2D 窗体矩形左上角的 X 坐标。

从以下版本开始：
1.2

y

public float y
此 Ellipse2D 窗体矩形左上角的 Y 坐标。

从以下版本开始：
1.2

width

public float width
此 Ellipse2D 的总宽度。

从以下版本开始：
1.2

height

public float height
此 Ellipse2D 的总高度。

从以下版本开始：
1.2
构造方法详细信息

Ellipse2D.Float

public Ellipse2D.Float()
构造一个新 Ellipse2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。

从以下版本开始：
1.2

Ellipse2D.Float

public Ellipse2D.Float(float x,
                       float y,
                       float w,
                       float h)
根据指定坐标构造和初始化 Ellipse2D。

参数：
x - 窗体矩形左上角的 X 坐标
y - 窗体矩形左上角的 Y 坐标
w - 窗体矩形的宽度
h - 窗体矩形的高度
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setFrame

public void setFrame(float x,
                     float y,
                     float w,
                     float h)
将此 Shape 窗体矩形的位置和大小设置为指定矩形值。

参数：
x - 指定矩形的左上角的 X 坐标
y - 指定矩形的左上角的 Y 坐标
w - 指定矩形的宽度
h - 指定矩形的高度
从以下版本开始：
1.2

setFrame

public void setFrame(double x,
                     double y,
                     double w,
                     double h)
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。

指定者：
类 RectangularShape 中的 setFrame
参数：
x - 指定矩形左上角的 X 坐标
y - 指定矩形左上角的 Y 坐标
w - 指定矩形的宽度
h - 指定矩形的高度
从以下版本开始：
1.2
另请参见：
RectangularShape.getFrame()

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlatteningPathIterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 FlatteningPathIterator

java.lang.Object
    继承者  java.awt.geom.FlatteningPathIterator
所有已实现的接口：
PathIterator
public class FlatteningPathIterator
extends Object
implements PathIterator

FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。其他 Shape 类可以使用此类为其路径提供变平行为，无需自己进行插值计算。

字段摘要
从接口 java.awt.geom.PathIterator 继承的字段
SEG_CLOSE, SEG_CUBICTO, SEG_LINETO, SEG_MOVETO, SEG_QUADTO, WIND_EVEN_ODD, WIND_NON_ZERO
构造方法摘要
FlatteningPathIterator(PathIterator src, double flatness)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
FlatteningPathIterator(PathIterator src, double flatness, int limit)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
方法摘要
int | currentSegment(double[] coords) 使用迭代返回当前路径段的坐标和类型。
int | currentSegment(float[] coords) 使用迭代返回当前路径段的坐标和类型。
double | getFlatness() 返回此迭代器的平面度。
int | getRecursionLimit() 返回此迭代器的递归限制。
int | getWindingRule() 返回用于确定路径迭代的旋绕规则。
boolean | isDone() 测试迭代是否完成。
void | next() 只要最初的遍历方向上存在多个点，就沿该方向将迭代器移动到下一个路径段。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FlatteningPathIterator

public FlatteningPathIterator(PathIterator src,
                              double flatness)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。迭代器不会将从源迭代器读取的任何曲线细分至 10 级以上，10 级以上的细分超过了每曲线 1024 个线段这一最大值。

参数：
src - 要在其上迭代的未变平初始路径
flatness - 控制点与变平曲线间允许的最大距离

FlatteningPathIterator

public FlatteningPathIterator(PathIterator src,
                              double flatness,
                              int limit)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。可以使用 limit 参数控制迭代器在不依靠 flatness 参数进行测量的情况下假定曲线已经足够平之前，可以进行的最大递归细分次数。因此，变平迭代永远不会为每个曲线生成多于最大值 (2^limit) 的线段数。

参数：
src - 要在其上迭代的未变平初始路径
flatness - 控制点到变平曲线间允许的最大距离
limit - 允许对任何曲线段进行递归细分的最大次数
抛出：
IllegalArgumentException - 如果 flatness 或 limit 小于零。
方法详细信息

getFlatness

public double getFlatness()
返回此迭代器的平面度。

返回：
此 FlatteningPathIterator 的平面度。

getRecursionLimit

public int getRecursionLimit()
返回此迭代器的递归限制。

返回：
此 FlatteningPathIterator 的递归限制。

getWindingRule

public int getWindingRule()
返回用于确定路径迭代的旋绕规则。

指定者：
接口 PathIterator 中的 getWindingRule
返回：
要在其上进行迭代的未变平初始路径的旋绕规则。
另请参见：
PathIterator.WIND_EVEN_ODD, PathIterator.WIND_NON_ZERO

isDone

public boolean isDone()
测试迭代是否完成。

指定者：
接口 PathIterator 中的 isDone
返回：
如果已经读取了所有的段，则返回 true；否则返回 false。

next

public void next()
只要最初的遍历方向上存在多个点，就沿该方向将迭代器移动到下一个路径段。

指定者：
接口 PathIterator 中的 next

currentSegment

public int currentSegment(float[] coords)
使用迭代返回当前路径段的坐标和类型。返回值就是路径段类型：SEG_MOVETO、SEG_LINETO 或 SEG_CLOSE。必须传入长度为 6 的 float 数组，该数组可用于存储点的坐标。每个点都存储为一对 float x、y 坐标。SEG_MOVETO 和 SEG_LINETO 类型均返回一个点，而 SEG_CLOSE 不返回点。

指定者：
接口 PathIterator 中的 currentSegment
参数：
coords - 保存从此方法返回数据的数组
返回：
当前路径段的路径段类型。
抛出：
NoSuchElementException - 如果在要返回的变平路径中不存在多个元素。
另请参见：
PathIterator.SEG_MOVETO, PathIterator.SEG_LINETO, PathIterator.SEG_CLOSE

currentSegment

public int currentSegment(double[] coords)
使用迭代返回当前路径段的坐标和类型。返回值就是路径段类型：SEG_MOVETO、SEG_LINETO 或 SEG_CLOSE。必须传入长度为 6 的 double 数组，该数组可用于存储点的坐标。每个点都存储为一对 double x、y 坐标。SEG_MOVETO 和 SEG_LINETO 类型均返回一个点，而 SEG_CLOSE 不返回点。

指定者：
接口 PathIterator 中的 currentSegment
参数：
coords - 保存从此方法返回数据的数组
返回：
当前路径段的路径段类型。
抛出：
NoSuchElementException - 如果在要返回的变平路径中不存在多个元素。
另请参见：
PathIterator.SEG_MOVETO, PathIterator.SEG_LINETO, PathIterator.SEG_CLOSE
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GeneralPath (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 GeneralPath

java.lang.Object
    继承者  java.awt.geom.Path2D
        继承者  java.awt.geom.Path2D.Float
            继承者  java.awt.geom.GeneralPath
所有已实现的接口：
Shape, Serializable, Cloneable
public final class GeneralPath
extends Path2D.Float

GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。它可以包含多个子路径。

GeneralPath 是一个遗留的 final 类，它精确地实现了其超类 Path2D.Float 的行为。与 Path2D.Double 一起，Path2D 类提供了通用几何路径的完整实现，支持 Shape 和 PathIterator 接口的所有功能，能够显式地选择不同级别的内部坐标精度。

在处理能够表示且能使用浮点精度的数据时，可以使用 Path2D.Float（或此遗留 GeneralPath 子类）。对于要求双精度的准确性或范围的数据，可以使用 Path2D.Double。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Path2D 继承的嵌套类/接口
Path2D.Double, Path2D.Float
字段摘要
从类 java.awt.geom.Path2D 继承的字段
WIND_EVEN_ODD, WIND_NON_ZERO
构造方法摘要
GeneralPath()
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 GeneralPath 对象。
GeneralPath(int rule)
根据指定旋绕规则构造一个新的 GeneralPath 对象，以控制需要定义路径内部的操作。
GeneralPath(int rule, int initialCapacity)
根据指定旋绕规则和指定初始容量构造一个新的 GeneralPath 对象，以存储路径坐标。
GeneralPath(Shape s)
根据任意 Shape 对象构造一个新 GeneralPath 对象。
方法摘要
从类 java.awt.geom.Path2D.Float 继承的方法
append, clone, curveTo, curveTo, getBounds2D, getPathIterator, lineTo, lineTo, moveTo, moveTo, quadTo, quadTo, transform
从类 java.awt.geom.Path2D 继承的方法
append, closePath, contains, contains, contains, contains, contains, contains, contains, contains, createTransformedShape, getBounds, getCurrentPoint, getPathIterator, getWindingRule, intersects, intersects, intersects, intersects, reset, setWindingRule
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GeneralPath

public GeneralPath()
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 GeneralPath 对象。

从以下版本开始：
1.2

GeneralPath

public GeneralPath(int rule)
根据指定旋绕规则构造一个新的 GeneralPath 对象，以控制需要定义路径内部的操作。

参数：
rule - 旋绕规则
从以下版本开始：
1.2
另请参见：
Path2D.WIND_EVEN_ODD, Path2D.WIND_NON_ZERO

GeneralPath

public GeneralPath(int rule,
                   int initialCapacity)
根据指定旋绕规则和指定初始容量构造一个新的 GeneralPath 对象，以存储路径坐标。此数是对将添加到路径中的路径段数量的初始猜测，但存储量可以根据需要扩展，以存储添加的所有路径段。

参数：
rule - 旋绕规则
initialCapacity - 对路径中路径段数量的估计
从以下版本开始：
1.2
另请参见：
Path2D.WIND_EVEN_ODD, Path2D.WIND_NON_ZERO

GeneralPath

public GeneralPath(Shape s)
根据任意 Shape 对象构造一个新 GeneralPath 对象。此路径的所有初始几何形状和旋绕规则均取自指定的 Shape 对象。

参数：
s - 指定的 Shape 对象
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalPathStateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 IllegalPathStateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.awt.geom.IllegalPathStateException
所有已实现的接口：
Serializable
public class IllegalPathStateException
extends RuntimeException

对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。

另请参见：
序列化表格

构造方法摘要
IllegalPathStateException()
构造不带任何详细消息的 IllegalPathStateException。
IllegalPathStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalPathStateException

public IllegalPathStateException()
构造不带任何详细消息的 IllegalPathStateException。

从以下版本开始：
1.2

IllegalPathStateException

public IllegalPathStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。

参数：
s - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Line2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Line2D

java.lang.Object
    继承者  java.awt.geom.Line2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
Line2D.Double, Line2D.Float
public abstract class Line2D
extends Object
implements Shape, Cloneable

Line2D 表示 (x,y) 坐标空间中的线段。像 Java 2D API 的所有类一样，此类使用称为用户空间 的默认坐标系，其中 Y 轴的值向下增大，X 轴的值向右增大。有关用户空间坐标系的更多信息，请参阅 Java 2D Programmer's Guide 中的 Coordinate Systems 部分。

此类是所有存储 2D 线段的对象的惟一抽象超类。坐标的实际存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。
构造方法摘要
protected Line2D()
这是一个无法直接实例化的抽象类。
方法摘要
Object | clone() 创建一个与此对象具有相同类的新对象。
boolean | contains(double x, double y) 测试指定坐标是否在此 Line2D 对象的边界内。
boolean | contains(double x, double y, double w, double h) 测试此 Line2D 的内部是否完全包含指定矩形坐标集。
boolean | contains(Point2D p) 测试给定 Point2D 是否在此 Line2D 的边界内。
boolean | contains(Rectangle2D r) 测试此 Line2D 内部是否完全包含指定的 Rectangle2D。
Rectangle | getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
abstract Point2D | getP1() 返回此 Line2D 的起始 Point2D。
abstract Point2D | getP2() 返回此 Line2D 的结束 Point2D。
PathIterator | getPathIterator(AffineTransform at) 返回定义此 Line2D 边界的迭代对象。
PathIterator | getPathIterator(AffineTransform at, double flatness) 返回定义此变平的 Line2D 边界的迭代对象。
abstract double | getX1() 返回起始点的 X 坐标（以 double 精度表示）。
abstract double | getX2() 返回结束点的 X 坐标（以 double 精度表示）。
abstract double | getY1() 返回起始点的 Y 坐标（以 double 精度表示）。
abstract double | getY2() 返回结束点的 Y 坐标（以 double 精度表示）。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
boolean | intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | intersectsLine(double x1, double y1, double x2, double y2) 测试从 (x1,y1) 到 (x2,y2) 的线段是否与此线段相交。
boolean | intersectsLine(Line2D l) 测试指定的线段是否与此线段相交。
static boolean | linesIntersect(double x1, double y1, double x2, double y2, double x3, double y3, double x4, double y4) 测试从 (x1,y1) 到 (x2,y2) 的线段是否与从 (x3,y3) 到 (x4,y4) 的线段相交。
double | ptLineDist(double px, double py) 返回从点到此线的距离。
static double | ptLineDist(double x1, double y1, double x2, double y2, double px, double py) 返回从点到线的距离。
double | ptLineDist(Point2D pt) 返回从 Point2D 到此线的距离。
double | ptLineDistSq(double px, double py) 返回从点到此线的距离的平方。
static double | ptLineDistSq(double x1, double y1, double x2, double y2, double px, double py) 返回从点到线的距离的平方。
double | ptLineDistSq(Point2D pt) 返回从指定 Point2D 到此线的距离的平方。
double | ptSegDist(double px, double py) 返回从点到此线段的距离。
static double | ptSegDist(double x1, double y1, double x2, double y2, double px, double py) 返回从点到线段的距离。
double | ptSegDist(Point2D pt) 返回从 Point2D 到此线段的距离的平方。
double | ptSegDistSq(double px, double py) 返回从点到此线段的距离的平方。
static double | ptSegDistSq(double x1, double y1, double x2, double y2, double px, double py) 返回从点到线段的距离的平方。
double | ptSegDistSq(Point2D pt) 返回从 Point2D 到此线段的距离的平方。
int | relativeCCW(double px, double py) 返回一个指示符，指示指定点 (px,py) 相对于此线段的位置。
static int | relativeCCW(double x1, double y1, double x2, double y2, double px, double py) 返回一个指示符，指示指定点 (px,py) 相对于从 (x1,y1) 到 (x2,y2) 的线段的位置。
int | relativeCCW(Point2D p) 返回一个指示符，指示指定 Point2D 相对于此线段的位置。
abstract void | setLine(double x1, double y1, double x2, double y2) 将此 Line2D 的端点位置设置为指定的 double 坐标。
void | setLine(Line2D l) 将此 Line2D 端点的位置设置为与指定 Line2D 的这些端点相同。
void | setLine(Point2D p1, Point2D p2) 将此 Line2D 端点的位置设置为指定的 Point2D 坐标。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Shape 继承的方法
getBounds2D

构造方法详细信息

Line2D

protected Line2D()
这是一个无法直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
Line2D.Float, Line2D.Double
方法详细信息

getX1

public abstract double getX1()
返回起始点的 X 坐标（以 double 精度表示）。

返回：
此 Line2D 对象起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public abstract double getY1()
返回起始点的 Y 坐标（以 double 精度表示）。

返回：
此 Line2D 对象起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public abstract Point2D getP1()
返回此 Line2D 的起始 Point2D。

返回：
此 Line2D 的起始 Point2D。

getX2

public abstract double getX2()
返回结束点的 X 坐标（以 double 精度表示）。

返回：
此 Line2D 对象结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public abstract double getY2()
返回结束点的 Y 坐标（以 double 精度表示）。

返回：
此 Line2D 对象结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public abstract Point2D getP2()
返回此 Line2D 的结束 Point2D。

返回：
此 Line2D 的结束 Point2D。
从以下版本开始：
1.2

setLine

public abstract void setLine(double x1,
                             double y1,
                             double x2,
                             double y2)
将此 Line2D 的端点位置设置为指定的 double 坐标。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

setLine

public void setLine(Point2D p1,
                    Point2D p2)
将此 Line2D 端点的位置设置为指定的 Point2D 坐标。

参数：
p1 - 线段的起始 Point2D
p2 - 线段的结束 Point2D
从以下版本开始：
1.2

setLine

public void setLine(Line2D l)
将此 Line2D 端点的位置设置为与指定 Line2D 的这些端点相同。

参数：
l - 指定的 Line2D
从以下版本开始：
1.2

relativeCCW

public static int relativeCCW(double x1,
                              double y1,
                              double x2,
                              double y2,
                              double px,
                              double py)
返回一个指示符，指示指定点 (px,py) 相对于从 (x1,y1) 到 (x2,y2) 的线段的位置。返回值可以为 1、-1 或 0，指示为了指向指定点 (px,py)，指定的线段必须绕其第一个端点 (x1,y1) 旋转的方向。

返回值 1 指示线段转动的方向是从 X 正半轴到 Y 负半轴。在 Java 2D 使用的默认坐标系中，此方向为逆时针方向。

返回值 -1 指示线段转动的方向是从 X 正半轴到 Y 正半轴。在默认的坐标系中，此方向为顺时针方向。

返回值 0 指示点恰好位于线段上。注意，指示符 0 是非常罕见的，并且因浮点舍入问题而不可用于确定共线性。

如果点与线段共线，但是不在端点之间，则点位于“(x1,y1) 之外”时值为 -1，点位于“(x2,y2) 之外”时值为 1。

参数：
x1 - 指定线段起始点的 X 坐标
y1 - 指定线段起始点的 Y 坐标
x2 - 指定线段结束点的 X 坐标
y2 - 指定线段结束点的 Y 坐标
px - 将与指定线段比较的指定点的 X 坐标
py - 将与指定线段比较的指定点的 Y 坐标
返回：
一个整数，指示第三个指定坐标相对于前两个指定坐标所形成线段的位置。
从以下版本开始：
1.2

relativeCCW

public int relativeCCW(double px,
                       double py)
返回一个指示符，指示指定点 (px,py) 相对于此线段的位置。关于返回值的解释，请参见 relativeCCW(double, double, double, double, double, double) 的方法注释。

参数：
px - 将与此 Line2D 比较的指定点的 X 坐标
py - 将与此 Line2D 比较的指定点的 Y 坐标
返回：
一个整数，指示指定坐标相对于此 Line2D 的位置
从以下版本开始：
1.2
另请参见：
relativeCCW(double, double, double, double, double, double)

relativeCCW

public int relativeCCW(Point2D p)
返回一个指示符，指示指定 Point2D 相对于此线段的位置。关于返回值的解释，请参见 relativeCCW(double, double, double, double, double, double) 的方法注释。

参数：
p - 将与此 Line2D 比较的指定 Point2D
返回：
一个整数，指示指定 Point2D 相对于此 Line2D 的位置
从以下版本开始：
1.2
另请参见：
relativeCCW(double, double, double, double, double, double)

linesIntersect

public static boolean linesIntersect(double x1,
                                     double y1,
                                     double x2,
                                     double y2,
                                     double x3,
                                     double y3,
                                     double x4,
                                     double y4)
测试从 (x1,y1) 到 (x2,y2) 的线段是否与从 (x3,y3) 到 (x4,y4) 的线段相交。

参数：
x1 - 第一个指定线段起始点的 X 坐标
y1 - 第一个指定线段起始点的 Y 坐标
x2 - 第一个指定线段结束点的 X 坐标
y2 - 第一个指定线段结束点的 Y 坐标
x3 - 第二个指定线段起始点的 X 坐标
y3 - 第二个指定线段起始点的 Y 坐标
x4 - 第二个指定线段结束点的 X 坐标
y4 - 第二个指定线段结束点的 Y 坐标
返回：
如果第一个指定线段与第二个指定线段彼此相交，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersectsLine

public boolean intersectsLine(double x1,
                              double y1,
                              double x2,
                              double y2)
测试从 (x1,y1) 到 (x2,y2) 的线段是否与此线段相交。

参数：
x1 - 指定线段起始点的 X 坐标
y1 - 指定线段起始点的 Y 坐标
x2 - 指定线段结束点的 X 坐标
y2 - 指定线段结束点的 Y 坐标
返回：
如果此线段与指定线段彼此相交，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersectsLine

public boolean intersectsLine(Line2D l)
测试指定的线段是否与此线段相交。

参数：
l - 指定的 Line2D
返回：
如果此线段与指定线段彼此相交，则返回 true；否则返回 false。
从以下版本开始：
1.2

ptSegDistSq

public static double ptSegDistSq(double x1,
                                 double y1,
                                 double x2,
                                 double y2,
                                 double px,
                                 double py)
返回从点到线段的距离的平方。测量的距离是从指定点到位于指定端点间的最近点之间的距离。如果指定点与线段相交于端点之间，则此方法返回 0.0。

参数：
x1 - 指定线段起始点的 X 坐标
y1 - 指定线段起始点的 Y 坐标
x2 - 指定线段结束点的 X 坐标
y2 - 指定线段结束点的 Y 坐标
px - 将对照指定线段进行测量的指定点的 X 坐标
py - 将对照指定线段进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到指定线段的距离平方。
从以下版本开始：
1.2
另请参见：
ptLineDistSq(double, double, double, double, double, double)

ptSegDist

public static double ptSegDist(double x1,
                               double y1,
                               double x2,
                               double y2,
                               double px,
                               double py)
返回从点到线段的距离。测量的距离是从指定点到位于指定端点间的最近点之间的距离。如果指定点与线段相交于端点之间，则此方法返回 0.0。

参数：
x1 - 指定线段起始点的 X 坐标
y1 - 指定线段起始点的 Y 坐标
x2 - 指定线段结束点的 X 坐标
y2 - 指定线段结束点的 Y 坐标
px - 将对照指定线段进行测量的指定点的 X 坐标
py - 将对照指定线段进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到指定线段的距离。
从以下版本开始：
1.2
另请参见：
ptLineDist(double, double, double, double, double, double)

ptSegDistSq

public double ptSegDistSq(double px,
                          double py)
返回从点到此线段的距离的平方。测量的距离是从指定点到位于当前线端点间的最近点之间的距离。如果指定点与线段相交于端点之间，则此方法返回 0.0。

参数：
px - 将对照此线段进行测量的指定点的 X 坐标
py - 将对照此线段进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到当前线段的距离平方。
从以下版本开始：
1.2
另请参见：
ptLineDistSq(double, double)

ptSegDistSq

public double ptSegDistSq(Point2D pt)
返回从 Point2D 到此线段的距离的平方。测量的距离是从指定点到位于当前线端点间的最近点之间的距离。如果指定点与线段相交于端点之间，则此方法返回 0.0。

参数：
pt - 将对照此线段进行测量的指定 Point2D。
返回：
一个 double 值，它是从指定 Point2D 到当前线段的距离平方。
从以下版本开始：
1.2
另请参见：
ptLineDistSq(Point2D)

ptSegDist

public double ptSegDist(double px,
                        double py)
返回从点到此线段的距离。测量的距离是从指定点到位于当前线端点间的最近点之间的距离。如果指定点与线段相交于端点之间，则此方法返回 0.0。

参数：
px - 将对照此线段进行测量的指定点的 X 坐标
py - 将对照此线段进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到当前线段的距离。
从以下版本开始：
1.2
另请参见：
ptLineDist(double, double)

ptSegDist

public double ptSegDist(Point2D pt)
返回从 Point2D 到此线段的距离的平方。测量的距离是从指定点到位于当前线端点间的最近点之间的距离。如果指定点与线段相交于端点之间，则此方法返回 0.0。

参数：
pt - 将对照此线段进行测量的指定 Point2D
返回：
一个 double 值，它是从指定 Point2D 到当前线段的距离。
从以下版本开始：
1.2
另请参见：
ptLineDist(Point2D)

ptLineDistSq

public static double ptLineDistSq(double x1,
                                  double y1,
                                  double x2,
                                  double y2,
                                  double px,
                                  double py)
返回从点到线的距离的平方。测量的距离是指定点与位于指定坐标定义的无限延长线上的最近点之间的距离。如果指定点与线相交，则此方法返回 0.0。

参数：
x1 - 指定线段起始点的 X 坐标
y1 - 指定线段起始点的 Y 坐标
x2 - 指定线段结束点的 X 坐标
y2 - 指定线段结束点的 Y 坐标
px - 将对照指定线段进行测量的指定点的 X 坐标
py - 将对照指定线段进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到指定线段的距离的平方。
从以下版本开始：
1.2
另请参见：
ptSegDistSq(double, double, double, double, double, double)

ptLineDist

public static double ptLineDist(double x1,
                                double y1,
                                double x2,
                                double y2,
                                double px,
                                double py)
返回从点到线的距离。测量的距离是指定点与位于指定坐标定义的无限延长线上的最近点之间的距离。如果指定点与线相交，则此方法返回 0.0。

参数：
x1 - 指定线段起始点的 X 坐标
y1 - 指定线段起始点的 Y 坐标
x2 - 指定线段结束点的 X 坐标
y2 - 指定线段结束点的 Y 坐标
px - 将对照指定线段进行测量的指定点的 X 坐标
py - 将对照指定线段进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到指定线段的距离。
从以下版本开始：
1.2
另请参见：
ptSegDist(double, double, double, double, double, double)

ptLineDistSq

public double ptLineDistSq(double px,
                           double py)
返回从点到此线的距离的平方。测量的距离是指定点与位于此 Line2D 定义的无限延长线上的最近点之间的距离。如果指定点与线相交，则此方法返回 0.0。

参数：
px - 将对照此线进行测量的指定点的 X 坐标
py - 将对照此线进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到当前线的距离平方。
从以下版本开始：
1.2
另请参见：
ptSegDistSq(double, double)

ptLineDistSq

public double ptLineDistSq(Point2D pt)
返回从指定 Point2D 到此线的距离的平方。测量的距离是指定点与位于此 Line2D 定义的无限延长线上的最近点之间的距离。如果指定点与线相交，则此方法返回 0.0。

参数：
pt - 将对照此线进行测量的指定 Point2D
返回：
一个 double 值，它是从指定 Point2D 到当前线的距离平方。
从以下版本开始：
1.2
另请参见：
ptSegDistSq(Point2D)

ptLineDist

public double ptLineDist(double px,
                         double py)
返回从点到此线的距离。测量的距离是指定点与位于此 Line2D 定义的无限延长线上的最近点之间的距离。如果指定点与线相交，则此方法返回 0.0。

参数：
px - 将对照此线进行测量的指定点的 X 坐标
py - 将对照此线进行测量的指定点的 Y 坐标
返回：
一个 double 值，它是从指定点到当前线的距离。
从以下版本开始：
1.2
另请参见：
ptSegDist(double, double)

ptLineDist

public double ptLineDist(Point2D pt)
返回从 Point2D 到此线的距离。测量的距离是指定点与位于此 Line2D 定义的无限延长线上的最近点之间的距离。如果指定点与线相交，则此方法返回 0.0。

参数：
pt - 要测量的指定 Point2D
返回：
一个 double 值，它是从指定 Point2D 到当前线的距离。
从以下版本开始：
1.2
另请参见：
ptSegDist(Point2D)

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在此 Line2D 对象的边界内。此方法需要实现 Shape 接口，但是对于 Line2D 对象来说，它始终返回 false，因为线不包含任何区域。

指定者：
接口 Shape 中的 contains
参数：
x - 将被测试的指定点的 X 坐标
y - 将被测试的指定点的 Y 坐标
返回：
false，因为 Line2D 不包含任何区域。
从以下版本开始：
1.2

contains

public boolean contains(Point2D p)
测试给定 Point2D 是否在此 Line2D 的边界内。此方法需要实现 Shape 接口，但是对于 Line2D 对象来说，它始终返回 false，因为线不包含任何区域。

指定者：
接口 Shape 中的 contains
参数：
p - 要测试的指定 Point2D
返回：
false，因为 Line2D 不包含任何区域。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

intersects

public boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.intersects(double, double, double, double)

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试此 Line2D 的内部是否完全包含指定矩形坐标集。此方法需要实现 Shape 接口，但是对于 Line2D 对象来说，它始终返回 false，因为线不包含任何区域。

指定者：
接口 Shape 中的 contains
参数：
x - 指定矩形区域的左上角的 X 坐标
y - 指定矩形区域的左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
false，因为 Line2D 不包含任何区域。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

contains

public boolean contains(Rectangle2D r)
测试此 Line2D 内部是否完全包含指定的 Rectangle2D。此方法需要实现 Shape 接口，但是对于 Line2D 对象来说，它始终返回 false，因为线不包含任何区域。

指定者：
接口 Shape 中的 contains
参数：
r - 要测试的指定 Rectangle2D
返回：
false，因为 Line2D 不包含任何区域。
从以下版本开始：
1.2
另请参见：
Shape.contains(double, double, double, double)

getBounds

public Rectangle getBounds()
返回一个完全包围 Shape 的整型 Rectangle。注意，不保证返回的 Rectangle 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle 中。如果 Shape 超出了整数数据类型的有效范围，则返回的 Rectangle 也可能不完全包围 Shape。getBounds2D 方法由于在表示形式上具有更大的灵活性，所以通常返回更紧密的边界框。

指定者：
接口 Shape 中的 getBounds
返回：
完全包围 Shape 的整型 Rectangle。
从以下版本开始：
1.2
另请参见：
Shape.getBounds2D()

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回定义此 Line2D 边界的迭代对象。此类的迭代器不是多线程安全的，这意味着此 Line2D 类不保证对此 Line2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 指定的 AffineTransform
返回：
定义此 Line2D 的边界的 PathIterator。
从以下版本开始：
1.2

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
返回定义此变平的 Line2D 边界的迭代对象。此类的迭代器不是多线程安全的，这意味着此 Line2D 类不保证对此 Line2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 指定的 AffineTransform
flatness - 在由连接端点的直线取代细分曲线之前，给定曲线的控制点可以从共线变化的最大量。因为 Line2D 对象始终是平的，所以此参数会被忽略。
返回：
定义变平的 Line2D 边界的 PathIterator
从以下版本开始：
1.2

clone

public Object clone()
创建一个与此对象具有相同类的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.2
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Path2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Path2D

java.lang.Object
    继承者  java.awt.geom.Path2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
Path2D.Double, Path2D.Float
public abstract class Path2D
extends Object
implements Shape, Cloneable

Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。它可以完整地表示可通过 PathIterator 接口进行迭代的任何路径（包括其所有线段类型和旋绕规则），并实现 Shape 接口的所有基本目标测试方法。

在处理能够表示且能使用浮点精度的数据时，可以使用 Path2D.Float。对于要求双精度的准确性或范围的数据，可以使用 Path2D.Double。

Path2D 为基本构造、几何路径管理以及几乎没有附加解释的上述接口的实现精确地提供其所需的设施。如果除简单目标测试以外，它对操作封闭几何形状的内部有用，则 Area 类提供专用于封闭图形的附加容量。虽然两个类名义上都可以实现 Shape 接口，但它们的目的各不一样，并且它们一起提供了两个有用的几何形状视图，在该视图上，Path2D 主要处理由路径段形成的轨迹，而 Area 主要处理解释和操作 2D 几何空间的封闭区域。

PathIterator 接口有更多关于组成路径的线段类型、控制如何确定哪些区域位于路径之内或之外的旋绕规则的详细描述。

从以下版本开始：
1.6

嵌套类摘要
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
字段摘要
static int | WIND_EVEN_ODD 用于确定路径内部的奇偶旋绕规则。
static int | WIND_NON_ZERO 用于确定路径内部的非零旋绕规则。
方法摘要
abstract void | append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
void | append(Shape s, boolean connect) 将指定 Shape 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
abstract Object | clone() 创建一个与此对象具有相同类的新对象。
void | closePath() 通过绘制一条向后延伸到最后一个 moveTo 的坐标的直线，封闭当前子路径。
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
static boolean | contains(PathIterator pi, double x, double y) 测试指定的坐标是否在指定 PathIterator 的封闭边界内。
static boolean | contains(PathIterator pi, double x, double y, double w, double h) 测试指定矩形区域是否完全在指定 PathIterator 的封闭边界内。
static boolean | contains(PathIterator pi, Point2D p) 测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。
static boolean | contains(PathIterator pi, Rectangle2D r) 测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。
boolean | contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
Shape | createTransformedShape(AffineTransform at) 返回一个表示此 Path2D 变换形式的新 Shape。
abstract void | curveTo(double x1, double y1, double x2, double y2, double x3, double y3) 通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
Rectangle | getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Point2D | getCurrentPoint() 返回最近添加到路径尾部的坐标（以 Point2D 对象形式）。
PathIterator | getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
int | getWindingRule() 返回填充风格旋绕规则。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
static boolean | intersects(PathIterator pi, double x, double y, double w, double h) 测试指定 PathIterator 的内部是否与指定直角坐标集的内部相交。
static boolean | intersects(PathIterator pi, Rectangle2D r) 测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。
boolean | intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
abstract void | lineTo(double x, double y) 通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
abstract void | moveTo(double x, double y) 通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
abstract void | quadTo(double x1, double y1, double x2, double y2) 通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
void | reset() 将路径重置为空。
void | setWindingRule(int rule) 将此路径的旋绕规则设置为指定值。
abstract void | transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Shape 继承的方法
getBounds2D, getPathIterator

字段详细信息

WIND_EVEN_ODD

public static final int WIND_EVEN_ODD
用于确定路径内部的奇偶旋绕规则。

从以下版本开始：
1.6
另请参见：
PathIterator.WIND_EVEN_ODD, 常量字段值

WIND_NON_ZERO

public static final int WIND_NON_ZERO
用于确定路径内部的非零旋绕规则。

从以下版本开始：
1.6
另请参见：
PathIterator.WIND_NON_ZERO, 常量字段值
方法详细信息

moveTo

public abstract void moveTo(double x,
                            double y)
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6

lineTo

public abstract void lineTo(double x,
                            double y)
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6

quadTo

public abstract void quadTo(double x1,
                            double y1,
                            double x2,
                            double y2)
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。所有坐标都以双精度指定。

参数：
x1 - 二次曲线控制点的 X 坐标
y1 - 二次曲线控制点的 Y 坐标
x2 - 终端点的 X 坐标
y2 - 终端点的 Y 坐标
从以下版本开始：
1.6

curveTo

public abstract void curveTo(double x1,
                             double y1,
                             double x2,
                             double y2,
                             double x3,
                             double y3)
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。所有坐标都以双精度指定。

参数：
x1 - 第一个 Bézier 控制点的 X 坐标
y1 - 第一个 Bézier 控制点的 Y 坐标
x2 - 第二个 Bézier 控制点的 X 坐标
y2 - 第二个 Bézier 控制点的 Y 坐标
x3 - 终端点的 X 坐标
y3 - 终端点的 Y 坐标
从以下版本开始：
1.6

closePath

public final void closePath()
通过绘制一条向后延伸到最后一个 moveTo 的坐标的直线，封闭当前子路径。如果该路径已封闭，则此方法无效。

从以下版本开始：
1.6

append

public final void append(Shape s,
                         boolean connect)
将指定 Shape 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。如果 connect 参数为 true 且路径是非空的，则添加的 Shape 几何形状的所有初始 moveTo 将被转换为 lineTo 段。如果这种连接 lineTo 段的目标坐标与当前开放子路径的结束坐标匹配，那么该线段将被作为多余线段忽略。指定 Shape 的旋绕规则将被忽略，添加的几何形状由为此路径指定的旋绕规则来管理。

参数：
s - 其几何形状将被添加到此路径的 Shape
connect - 一个 boolean 值，用于控制是否将初始 moveTo 段转换为 lineTo 段，从而将新几何形状连接到现有路径
从以下版本开始：
1.6

append

public abstract void append(PathIterator pi,
                            boolean connect)
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。如果 connect 参数为 true 且路径是非空的，则添加的 Shape 几何形状的所有初始 moveTo 将被转换为 lineTo 段。如果这种连接 lineTo 段的目标坐标与当前开放子路径的结束坐标匹配，那么该线段将被作为多余线段忽略。指定 Shape 的旋绕规则将被忽略，添加的几何形状由为此路径指定的旋绕规则来管理。

参数：
pi - 其几何形状将被添加到此路径的 PathIterator
connect - 一个 boolean 值，用于控制是否将初始 moveTo 段转换为 lineTo 段，从而将新几何形状连接到现有路径
从以下版本开始：
1.6

getWindingRule

public final int getWindingRule()
返回填充风格旋绕规则。

返回：
表示当前旋绕规则的整数。
从以下版本开始：
1.6
另请参见：
WIND_EVEN_ODD, WIND_NON_ZERO, setWindingRule(int)

setWindingRule

public final void setWindingRule(int rule)
将此路径的旋绕规则设置为指定值。

参数：
rule - 表示指定旋绕规则的整数
抛出：
IllegalArgumentException - 如果 rule 既不是 WIND_EVEN_ODD 也不是 WIND_NON_ZERO
从以下版本开始：
1.6
另请参见：
getWindingRule()

getCurrentPoint

public final Point2D getCurrentPoint()
返回最近添加到路径尾部的坐标（以 Point2D 对象形式）。

返回：
包含路径结束坐标的 Point2D 对象；如果路径中没有任何点，则返回 null。
从以下版本开始：
1.6

reset

public final void reset()
将路径重置为空。将添加位置设置回路径的开头并遗弃所有坐标和点类型。

从以下版本开始：
1.6

transform

public abstract void transform(AffineTransform at)
使用指定的 AffineTransform 变换此路径的几何形状。原地变换几何形状，它将永久更改由此对象定义的边界。

参数：
at - 用于变换区域的 AffineTransform
从以下版本开始：
1.6

createTransformedShape

public final Shape createTransformedShape(AffineTransform at)
返回一个表示此 Path2D 变换形式的新 Shape。注意，没有为此方法指定返回值的确切类型和坐标精度。该方法将返回一个 Shape，它所包含的变换的几何形状精度不小于此 Path2D 当前维持的精度，但它也不可能大于该精度。如果精度与结果中存储量大小的权衡很重要，那么应该使用 Path2D.Float 和 Path2D.Double 子类中的一些便捷构造方法，使选择更明确。

参数：
at - 用于变换新 Shape 的 AffineTransform。
返回：
新的 Shape，它使用指定的 AffineTransform 变换而来。
从以下版本开始：
1.6

getBounds

public final Rectangle getBounds()
返回一个完全包围 Shape 的整型 Rectangle。注意，不保证返回的 Rectangle 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle 中。如果 Shape 超出了整数数据类型的有效范围，则返回的 Rectangle 也可能不完全包围 Shape。getBounds2D 方法由于在表示形式上具有更大的灵活性，所以通常返回更紧密的边界框。

指定者：
接口 Shape 中的 getBounds
返回：
完全包围 Shape 的整型 Rectangle。
从以下版本开始：
1.6
另请参见：
Shape.getBounds2D()

contains

public static boolean contains(PathIterator pi,
                               double x,
                               double y)
测试指定的坐标是否在指定 PathIterator 的封闭边界内。

此方法为 Shape 接口的实现程序提供了基本设施，以实现对 Shape.contains(double, double) 方法的支持。

参数：
pi - 指定的 PathIterator
x - 指定的 X 坐标
y - 指定的 Y 坐标
返回：
如果指定的坐标在指定的 PathIterator 内部，则返回 true；否则返回 false
从以下版本开始：
1.6

contains

public static boolean contains(PathIterator pi,
                               Point2D p)
测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。

此方法为 Shape 接口的实现程序提供了基本设施，以实现对 Shape.contains(Point2D) 方法的支持。

参数：
pi - 指定的 PathIterator
p - 指定的 Point2D
返回：
如果指定的坐标在指定 PathIterator 内，则返回 true；否则返回 false
从以下版本开始：
1.6

contains

public final boolean contains(double x,
                              double y)
测试指定坐标是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.6

contains

public final boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
p - 要测试的指定的 Point2D
返回：
如果指定的 Point2D 在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.6

contains

public static boolean contains(PathIterator pi,
                               double x,
                               double y,
                               double w,
                               double h)
测试指定矩形区域是否完全在指定 PathIterator 的封闭边界内。

此方法为 Shape 接口的实现程序提供了基本设施，以实现对 Shape.contains(double, double, double, double) 方法的支持。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 false。如果这些线段是遵守 WIND_NON_ZERO 旋绕规则的路径的一部分，或者这些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，那么这些线段可能完全位于路径内部。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

参数：
pi - 指定的 PathIterator
x - 指定的 X 坐标
y - 指定的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果指定的 PathIterator 包含指定矩形区域，则返回 true；否则返回 false。
从以下版本开始：
1.6

contains

public static boolean contains(PathIterator pi,
                               Rectangle2D r)
测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。

此方法为 Shape 接口的实现程序提供了基本设施，以实现对 Shape.contains(Rectangle2D) 方法的支持。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 false。如果这些线段是遵守 WIND_NON_ZERO 旋绕规则的路径的一部分，或者这些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，那么这些线段可能完全位于路径内部。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

参数：
pi - 指定的 PathIterator
r - 指定的 Rectangle2D
返回：
如果指定的 PathIterator 包含指定的 Rectangle2D，则返回 true；否则返回 false。
从以下版本开始：
1.6

contains

public final boolean contains(double x,
                              double y,
                              double w,
                              double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 false。如果这些线段是遵守 WIND_NON_ZERO 旋绕规则的路径的一部分，或者这些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，那么这些线段可能完全位于路径内部。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

指定者：
接口 Shape 中的 contains
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.6
另请参见：
Area, Shape.intersects(double, double, double, double)

contains

public final boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：
  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含 Rectangle2D 的代价太高。
这意味着对于某些 Shape，即使 Shape 包含 Rectangle2D，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 false。如果这些线段是遵守 WIND_NON_ZERO 旋绕规则的路径的一部分，或者这些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，那么这些线段可能完全位于路径内部。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

指定者：
接口 Shape 中的 contains
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部完全包含 Rectangle2D，则返回 true；否则，如果 Shape 包含 Rectangle2D、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.6
另请参见：
Shape.contains(double, double, double, double)

intersects

public static boolean intersects(PathIterator pi,
                                 double x,
                                 double y,
                                 double w,
                                 double h)
测试指定 PathIterator 的内部是否与指定直角坐标集的内部相交。

此方法为 Shape 接口的实现程序提供了基本设施，以实现对 Shape.intersects(double, double, double, double) 方法的支持。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 true。如果路径的一些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，则可能发生这种情况。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

参数：
pi - 指定的 PathIterator
x - 指定的 X 坐标
y - 指定的 Y 坐标
w - 指定直角坐标的宽度
h - 指定直角坐标的高度
返回：
如果指定 PathIterator 和指定直角坐标集的内部相交，则返回 true；否则返回 false。
从以下版本开始：
1.6

intersects

public static boolean intersects(PathIterator pi,
                                 Rectangle2D r)
测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。

此方法为 Shape 接口的实现程序提供基本设施，以实现对 Shape.intersects(Rectangle2D) 方法的支持。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 true。如果路径的一些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，则可能发生这种情况。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

参数：
pi - 指定的 PathIterator
r - 指定的 Rectangle2D
返回：
如果指定 PathIterator 和指定 Rectangle2D 的内部相交，则返回 true；否则返回 false。
从以下版本开始：
1.6

intersects

public final boolean intersects(double x,
                                double y,
                                double w,
                                double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 true。如果路径的一些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，则可能发生这种情况。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

指定者：
接口 Shape 中的 intersects
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.6
另请参见：
Area

intersects

public final boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

在指定矩形区域与路径段相交，但该路径段不表示路径内部和外部之间的边界的情况下，此方法对象可能会谨慎地返回 true。如果路径的一些线段反方向折回，从而两组线段互相抵消且两组线段间没有任何外部区域，则可能发生这种情况。要确定线段是否表示路径内部的真实边界需要大量的计算，这些计算涉及所有路径段和旋绕规则，因此超出此实现的范围。

指定者：
接口 Shape 中的 intersects
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.6
另请参见：
Shape.intersects(double, double, double, double)

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。

迭代器只返回 SEG_MOVETO、SEG_LINETO 和 SEG_CLOSE 点类型。

如果指定一个可选 AffineTransform，则相应地转换迭代中返回的坐标。

flatness 参数控制曲线段分段的数量，指定转换的不平曲线上任一点能够偏离返回的变平路径段的最大距离。注意，变平路径的精度限制可能稍微受到影响，使非常小的变平参数作为较大的值来处理。如果有这样的限制，那么该限制是由使用的特定实现定义的。

每次调用此方法都会返回一个最新的、遍历 Shape 对象几何形状的 PathIterator 对象，该对象独立于其他所有同时使用的 PathIterator 对象。

建议但不保证实现 Shape 接口的对象将进行中的迭代与该迭代期间可能对原始对象几何形状所做的任何更改隔离开来。

此类的迭代器不是多线程安全的，这意味着此 Path2D 类不保证对此 Path2D 对象几何形状所作的修改不会影响该几何形状已在处理中的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 一个可选 AffineTransform，用于在迭代中返回的坐标，如果需要未转换的坐标，则返回 null
flatness - 用来近似曲线段的直线段偏离原始曲线上任一点的最大距离
返回：
一个新的、独立地遍历 Shape 几何形状的平面视图的 PathIterator。
从以下版本开始：
1.6

clone

public abstract Object clone()
创建一个与此对象具有相同类的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.6
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Line2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Line2D.Double

java.lang.Object
    继承者  java.awt.geom.Line2D
        继承者  java.awt.geom.Line2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Line2D
public static class Line2D.Double
extends Line2D
implements Serializable

使用 double 坐标指定的线段。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Line2D 继承的嵌套类/接口
Line2D.Double, Line2D.Float
字段摘要
double | x1 线段起始点的 X 坐标。
double | x2 线段结束点的 X 坐标。
double | y1 线段起始点的 Y 坐标。
double | y2 线段结束点的 Y 坐标。
构造方法摘要
Line2D.Double()
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。
Line2D.Double(double x1, double y1, double x2, double y2)
根据指定坐标构造并初始化 Line2D。
Line2D.Double(Point2D p1, Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Point2D | getP1() 返回此 Line2D 的起始 Point2D。
Point2D | getP2() 返回此 Line2D 的结束 Point2D。
double | getX1() 返回起始点的 X 坐标（以 double 精度表示）。
double | getX2() 返回结束点的 X 坐标（以 double 精度表示）。
double | getY1() 返回起始点的 Y 坐标（以 double 精度表示）。
double | getY2() 返回结束点的 Y 坐标（以 double 精度表示）。
void | setLine(double x1, double y1, double x2, double y2) 将此 Line2D 的端点位置设置为指定的 double 坐标。
从类 java.awt.geom.Line2D 继承的方法
clone, contains, contains, contains, contains, getBounds, getPathIterator, getPathIterator, intersects, intersects, intersectsLine, intersectsLine, linesIntersect, ptLineDist, ptLineDist, ptLineDist, ptLineDistSq, ptLineDistSq, ptLineDistSq, ptSegDist, ptSegDist, ptSegDist, ptSegDistSq, ptSegDistSq, ptSegDistSq, relativeCCW, relativeCCW, relativeCCW, setLine, setLine
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x1

public double x1
线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

public double y1
线段起始点的 Y 坐标。

从以下版本开始：
1.2

x2

public double x2
线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

public double y2
线段结束点的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

Line2D.Double

public Line2D.Double()
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。

从以下版本开始：
1.2

Line2D.Double

public Line2D.Double(double x1,
                     double y1,
                     double x2,
                     double y2)
根据指定坐标构造并初始化 Line2D。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

Line2D.Double

public Line2D.Double(Point2D p1,
                     Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。

参数：
p1 - 此线段的起始 Point2D
p2 - 此线段的结束 Point2D
从以下版本开始：
1.2
方法详细信息

getX1

public double getX1()
返回起始点的 X 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getX1
返回：
此 Line2D 对象起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public double getY1()
返回起始点的 Y 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getY1
返回：
此 Line2D 对象起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public Point2D getP1()
返回此 Line2D 的起始 Point2D。

指定者：
类 Line2D 中的 getP1
返回：
此 Line2D 的起始 Point2D。
从以下版本开始：
1.2

getX2

public double getX2()
返回结束点的 X 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getX2
返回：
此 Line2D 对象结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public double getY2()
返回结束点的 Y 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getY2
返回：
此 Line2D 对象结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public Point2D getP2()
返回此 Line2D 的结束 Point2D。

指定者：
类 Line2D 中的 getP2
返回：
此 Line2D 的结束 Point2D。
从以下版本开始：
1.2

setLine

public void setLine(double x1,
                    double y1,
                    double x2,
                    double y2)
将此 Line2D 的端点位置设置为指定的 double 坐标。

指定者：
类 Line2D 中的 setLine
参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Line2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Line2D.Float

java.lang.Object
    继承者  java.awt.geom.Line2D
        继承者  java.awt.geom.Line2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Line2D
public static class Line2D.Float
extends Line2D
implements Serializable

使用 float 坐标指定的线段。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Line2D 继承的嵌套类/接口
Line2D.Double, Line2D.Float
字段摘要
float | x1 线段起始点的 X 坐标。
float | x2 线段结束点的 X 坐标。
float | y1 线段起始点的 Y 坐标。
float | y2 线段结束点的 Y 坐标。
构造方法摘要
Line2D.Float()
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。
Line2D.Float(float x1, float y1, float x2, float y2)
根据指定坐标构造并初始化 Line。
Line2D.Float(Point2D p1, Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Point2D | getP1() 返回此 Line2D 的起始 Point2D。
Point2D | getP2() 返回此 Line2D 的结束 Point2D。
double | getX1() 返回起始点的 X 坐标（以 double 精度表示）。
double | getX2() 返回结束点的 X 坐标（以 double 精度表示）。
double | getY1() 返回起始点的 Y 坐标（以 double 精度表示）。
double | getY2() 返回结束点的 Y 坐标（以 double 精度表示）。
void | setLine(double x1, double y1, double x2, double y2) 将此 Line2D 的端点位置设置为指定的 double 坐标。
void | setLine(float x1, float y1, float x2, float y2) 将此 Line2D 端点的位置设置为指定的 float 坐标。
从类 java.awt.geom.Line2D 继承的方法
clone, contains, contains, contains, contains, getBounds, getPathIterator, getPathIterator, intersects, intersects, intersectsLine, intersectsLine, linesIntersect, ptLineDist, ptLineDist, ptLineDist, ptLineDistSq, ptLineDistSq, ptLineDistSq, ptSegDist, ptSegDist, ptSegDist, ptSegDistSq, ptSegDistSq, ptSegDistSq, relativeCCW, relativeCCW, relativeCCW, setLine, setLine
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x1

public float x1
线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

public float y1
线段起始点的 Y 坐标。

从以下版本开始：
1.2

x2

public float x2
线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

public float y2
线段结束点的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

Line2D.Float

public Line2D.Float()
使用坐标 (0, 0) -> (0, 0) 构造并初始化一个 Line。

从以下版本开始：
1.2

Line2D.Float

public Line2D.Float(float x1,
                    float y1,
                    float x2,
                    float y2)
根据指定坐标构造并初始化 Line。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

Line2D.Float

public Line2D.Float(Point2D p1,
                    Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。

参数：
p1 - 此线段的起始 Point2D
p2 - 此线段的结束 Point2D
从以下版本开始：
1.2
方法详细信息

getX1

public double getX1()
返回起始点的 X 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getX1
返回：
此 Line2D 对象起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public double getY1()
返回起始点的 Y 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getY1
返回：
此 Line2D 对象起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public Point2D getP1()
返回此 Line2D 的起始 Point2D。

指定者：
类 Line2D 中的 getP1
返回：
此 Line2D 的起始 Point2D。
从以下版本开始：
1.2

getX2

public double getX2()
返回结束点的 X 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getX2
返回：
此 Line2D 对象结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public double getY2()
返回结束点的 Y 坐标（以 double 精度表示）。

指定者：
类 Line2D 中的 getY2
返回：
此 Line2D 对象结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public Point2D getP2()
返回此 Line2D 的结束 Point2D。

指定者：
类 Line2D 中的 getP2
返回：
此 Line2D 的结束 Point2D。
从以下版本开始：
1.2

setLine

public void setLine(double x1,
                    double y1,
                    double x2,
                    double y2)
将此 Line2D 的端点位置设置为指定的 double 坐标。

指定者：
类 Line2D 中的 setLine
参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

setLine

public void setLine(float x1,
                    float y1,
                    float x2,
                    float y2)
将此 Line2D 端点的位置设置为指定的 float 坐标。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoninvertibleTransformException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 NoninvertibleTransformException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.geom.NoninvertibleTransformException
所有已实现的接口：
Serializable
public class NoninvertibleTransformException
extends Exception

NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

另请参见：
序列化表格

构造方法摘要
NoninvertibleTransformException(String s)
构造具有指定详细消息的 NoninvertibleTransformException 的实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoninvertibleTransformException

public NoninvertibleTransformException(String s)
构造具有指定详细消息的 NoninvertibleTransformException 的实例。

参数：
s - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Path2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Path2D.Double

java.lang.Object
    继承者  java.awt.geom.Path2D
        继承者  java.awt.geom.Path2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Path2D
public static class Path2D.Double
extends Path2D
implements Serializable

Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。

从以下版本开始：
1.6
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Path2D 继承的嵌套类/接口
Path2D.Double, Path2D.Float
字段摘要
从类 java.awt.geom.Path2D 继承的字段
WIND_EVEN_ODD, WIND_NON_ZERO
构造方法摘要
Path2D.Double()
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的双精度空 Path2D 对象。
Path2D.Double(int rule)
根据指定旋绕规则构造一个新的双精度空 Path2D 对象，以控制需要定义路径内部的操作。
Path2D.Double(int rule, int initialCapacity)
根据指定旋绕规则和指定初始容量构造一个新的双精度空 Path2D 对象，以存储路径段。
Path2D.Double(Shape s)
根据任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Double(Shape s, AffineTransform at)
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。
方法摘要
void | append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
Object | clone() 创建一个与此对象具有相同类的新对象。
void | curveTo(double x1, double y1, double x2, double y2, double x3, double y3) 通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
PathIterator | getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
void | lineTo(double x, double y) 通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
void | moveTo(double x, double y) 通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
void | quadTo(double x1, double y1, double x2, double y2) 通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
void | transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。
从类 java.awt.geom.Path2D 继承的方法
append, closePath, contains, contains, contains, contains, contains, contains, contains, contains, createTransformedShape, getBounds, getCurrentPoint, getPathIterator, getWindingRule, intersects, intersects, intersects, intersects, reset, setWindingRule
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Path2D.Double

public Path2D.Double()
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的双精度空 Path2D 对象。

从以下版本开始：
1.6

Path2D.Double

public Path2D.Double(int rule)
根据指定旋绕规则构造一个新的双精度空 Path2D 对象，以控制需要定义路径内部的操作。

参数：
rule - 旋绕规则
从以下版本开始：
1.6
另请参见：
Path2D.WIND_EVEN_ODD, Path2D.WIND_NON_ZERO

Path2D.Double

public Path2D.Double(int rule,
                     int initialCapacity)
根据指定旋绕规则和指定初始容量构造一个新的双精度空 Path2D 对象，以存储路径段。此数是对路径中的路径段数量的初始猜测，但存储量可以根据需要扩展，以存储添加到此路径的所有路径段。

参数：
rule - 旋绕规则
initialCapacity - 对路径中路径段数量的估计
从以下版本开始：
1.6
另请参见：
Path2D.WIND_EVEN_ODD, Path2D.WIND_NON_ZERO

Path2D.Double

public Path2D.Double(Shape s)
根据任意 Shape 对象构造一个新的双精度 Path2D 对象。此路径的所有初始几何形状和旋绕规则均取自指定的 Shape 对象。

参数：
s - 指定的 Shape 对象
从以下版本开始：
1.6

Path2D.Double

public Path2D.Double(Shape s,
                     AffineTransform at)
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。此路径的所有初始几何形状和旋绕规则均取自指定的 Shape 对象，并由指定的 AffineTransform 对象变换。

参数：
s - 指定的 Shape 对象
at - 指定的 AffineTransform 对象
从以下版本开始：
1.6
方法详细信息

moveTo

public final void moveTo(double x,
                         double y)
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。

指定者：
类 Path2D 中的 moveTo
参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6

lineTo

public final void lineTo(double x,
                         double y)
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。

指定者：
类 Path2D 中的 lineTo
参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6

quadTo

public final void quadTo(double x1,
                         double y1,
                         double x2,
                         double y2)
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。所有坐标都以双精度指定。

指定者：
类 Path2D 中的 quadTo
参数：
x1 - 二次曲线控制点的 X 坐标
y1 - 二次曲线控制点的 Y 坐标
x2 - 终端点的 X 坐标
y2 - 终端点的 Y 坐标
从以下版本开始：
1.6

curveTo

public final void curveTo(double x1,
                          double y1,
                          double x2,
                          double y2,
                          double x3,
                          double y3)
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。所有坐标都以双精度指定。

指定者：
类 Path2D 中的 curveTo
参数：
x1 - 第一个 Bézier 控制点的 X 坐标
y1 - 第一个 Bézier 控制点的 Y 坐标
x2 - 第二个 Bézier 控制点的 X 坐标
y2 - 第二个 Bézier 控制点的 Y 坐标
x3 - 终端点的 X 坐标
y3 - 终端点的 Y 坐标
从以下版本开始：
1.6

append

public final void append(PathIterator pi,
                         boolean connect)
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。如果 connect 参数为 true 且路径是非空的，则添加的 Shape 几何形状的所有初始 moveTo 将被转换为 lineTo 段。如果这种连接 lineTo 段的目标坐标与当前开放子路径的结束坐标匹配，那么该线段将被作为多余线段忽略。指定 Shape 的旋绕规则将被忽略，添加的几何形状由为此路径指定的旋绕规则来管理。

指定者：
类 Path2D 中的 append
参数：
pi - 其几何形状将被添加到此路径的 PathIterator
connect - 一个 boolean 值，用于控制是否将初始 moveTo 段转换为 lineTo 段，从而将新几何形状连接到现有路径
从以下版本开始：
1.6

transform

public final void transform(AffineTransform at)
使用指定的 AffineTransform 变换此路径的几何形状。原地变换几何形状，它将永久更改由此对象定义的边界。

指定者：
类 Path2D 中的 transform
参数：
at - 用于变换区域的 AffineTransform
从以下版本开始：
1.6

getBounds2D

public final Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.6
另请参见：
Shape.getBounds()

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。如果指定一个可选 AffineTransform，则相应地转换迭代中返回的坐标。

每次调用此方法都会返回一个最新的、遍历 Shape 对象几何形状的 PathIterator 对象，该对象独立于其他所有同时使用的 PathIterator 对象。

建议但不保证实现 Shape 接口的对象将进行中的迭代与该迭代期间可能对原始对象几何形状所做的任何更改隔离开来。

此类的迭代器不是多线程安全的，这意味着 Path2D 类不保证对此 Path2D 对象几何形状所作的修改不影响该几何形状已在处理中的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - AffineTransform
返回：
沿此 Shape 边界进行迭代并提供对此 Shape 轮廓几何形状进行访问的新 PathIterator
从以下版本开始：
1.6

clone

public final Object clone()
创建一个与此对象具有相同类的新对象。

指定者：
类 Path2D 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.6
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Path2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Path2D.Float

java.lang.Object
    继承者  java.awt.geom.Path2D
        继承者  java.awt.geom.Path2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
直接已知子类：
GeneralPath
正在封闭类：
Path2D
public static class Path2D.Float
extends Path2D
implements Serializable

Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。

从以下版本开始：
1.6
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Path2D 继承的嵌套类/接口
Path2D.Double, Path2D.Float
字段摘要
从类 java.awt.geom.Path2D 继承的字段
WIND_EVEN_ODD, WIND_NON_ZERO
构造方法摘要
Path2D.Float()
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 Path2D 对象。
Path2D.Float(int rule)
根据指定旋绕规则构造一个新的单精度空 Path2D 对象，以控制需要定义路径内部的操作。
Path2D.Float(int rule, int initialCapacity)
根据指定旋绕规则和指定初始容量构造一个新的单精度空 Path2D 对象，以存储路径段。
Path2D.Float(Shape s)
根据任意 Shape 对象构造一个新的单精度 Path2D 对象。
Path2D.Float(Shape s, AffineTransform at)
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。
方法摘要
void | append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
Object | clone() 创建一个与此对象具有相同类的新对象。
void | curveTo(double x1, double y1, double x2, double y2, double x3, double y3) 通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
void | curveTo(float x1, float y1, float x2, float y2, float x3, float y3) 通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
PathIterator | getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
void | lineTo(double x, double y) 通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。
void | lineTo(float x, float y) 通过绘制一条从当前坐标到指定新坐标（以 float 精度指定）的直线，将一个点添加到路径中。
void | moveTo(double x, double y) 通过移动到指定坐标（以双精度指定），将一个点添加到路径中。
void | moveTo(float x, float y) 通过移动到指定的坐标（以 float 精度指定），将一个点添加到路径中。
void | quadTo(double x1, double y1, double x2, double y2) 通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
void | quadTo(float x1, float y1, float x2, float y2) 通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。
void | transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。
从类 java.awt.geom.Path2D 继承的方法
append, closePath, contains, contains, contains, contains, contains, contains, contains, contains, createTransformedShape, getBounds, getCurrentPoint, getPathIterator, getWindingRule, intersects, intersects, intersects, intersects, reset, setWindingRule
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Path2D.Float

public Path2D.Float()
根据 Path2D.WIND_NON_ZERO 的默认旋绕规则构造一个新的单精度空 Path2D 对象。

从以下版本开始：
1.6

Path2D.Float

public Path2D.Float(int rule)
根据指定旋绕规则构造一个新的单精度空 Path2D 对象，以控制需要定义路径内部的操作。

参数：
rule - 旋绕规则
从以下版本开始：
1.6
另请参见：
Path2D.WIND_EVEN_ODD, Path2D.WIND_NON_ZERO

Path2D.Float

public Path2D.Float(int rule,
                    int initialCapacity)
根据指定旋绕规则和指定初始容量构造一个新的单精度空 Path2D 对象，以存储路径段。此数是对将添加到路径中的路径段数量的初始猜测，但存储量可以根据需要扩展，以存储添加的所有路径段。

参数：
rule - 旋绕规则
initialCapacity - 对路径中路径段数量的估计
从以下版本开始：
1.6
另请参见：
Path2D.WIND_EVEN_ODD, Path2D.WIND_NON_ZERO

Path2D.Float

public Path2D.Float(Shape s)
根据任意 Shape 对象构造一个新的单精度 Path2D 对象。此路径的所有初始几何形状和旋绕规则均取自指定的 Shape 对象。

参数：
s - 指定的 Shape 对象
从以下版本开始：
1.6

Path2D.Float

public Path2D.Float(Shape s,
                    AffineTransform at)
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。此路径的所有初始几何形状和旋绕规则均取自指定的 Shape 对象，并由指定的 AffineTransform 对象变换。

参数：
s - 指定的 Shape 对象
at - 指定的 AffineTransform 对象
从以下版本开始：
1.6
方法详细信息

moveTo

public final void moveTo(double x,
                         double y)
通过移动到指定坐标（以双精度指定），将一个点添加到路径中。

指定者：
类 Path2D 中的 moveTo
参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6

moveTo

public final void moveTo(float x,
                         float y)
通过移动到指定的坐标（以 float 精度指定），将一个点添加到路径中。

此方法提供了基本 Path2D 类上的双精度 moveTo() 方法的单精度变体。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6
另请参见：
Path2D.moveTo(double, double)

lineTo

public final void lineTo(double x,
                         double y)
通过绘制一条从当前坐标到新指定坐标（以双精度指定）的直线，将一个点添加到路径中。

指定者：
类 Path2D 中的 lineTo
参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6

lineTo

public final void lineTo(float x,
                         float y)
通过绘制一条从当前坐标到指定新坐标（以 float 精度指定）的直线，将一个点添加到路径中。

此方法提供了基本 Path2D 类上的双精度 lineTo() 方法的单精度变体。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
从以下版本开始：
1.6
另请参见：
Path2D.lineTo(double, double)

quadTo

public final void quadTo(double x1,
                         double y1,
                         double x2,
                         double y2)
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。所有坐标都以双精度指定。

指定者：
类 Path2D 中的 quadTo
参数：
x1 - 二次曲线控制点的 X 坐标
y1 - 二次曲线控制点的 Y 坐标
x2 - 终端点的 X 坐标
y2 - 终端点的 Y 坐标
从以下版本开始：
1.6

quadTo

public final void quadTo(float x1,
                         float y1,
                         float x2,
                         float y2)
通过绘制与当前坐标和指定坐标 (x2,y2) 都相交的二次曲线，并将指定点 (x1,y1) 用作二次曲线参数控制点，可以将由两个新点定义的曲线段添加到路径中。所有坐标都以 float 精度指定。

此方法提供了基本 Path2D 类上的双精度 quadTo() 方法的单精度变体。

参数：
x1 - 二次曲线控制点的 X 坐标
y1 - 二次曲线控制点的 Y 坐标
x2 - 终端点的 X 坐标
y2 - 终端点的 Y 坐标
从以下版本开始：
1.6

curveTo

public final void curveTo(double x1,
                          double y1,
                          double x2,
                          double y2,
                          double x3,
                          double y3)
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。所有坐标都以双精度指定。

指定者：
类 Path2D 中的 curveTo
参数：
x1 - 第一个 Bézier 控制点的 X 坐标
y1 - 第一个 Bézier 控制点的 Y 坐标
x2 - 第二个 Bézier 控制点的 X 坐标
y2 - 第二个 Bézier 控制点的 Y 坐标
x3 - 终端点的 X 坐标
y3 - 终端点的 Y 坐标
从以下版本开始：
1.6

curveTo

public final void curveTo(float x1,
                          float y1,
                          float x2,
                          float y2,
                          float x3,
                          float y3)
通过绘制与当前坐标和指定坐标 (x3,y3) 都相交的 Bézier 曲线，并将指定点 (x1,y1) 和 (x2,y2) 用作 Bézier 曲线的控制点，可以将由三个新点定义的曲线段添加到路径中。所有坐标都以 float 精度指定。

此方法提供了基本 Path2D 类上的双精度 curveTo() 方法的单精度变体。

参数：
x1 - 第一个 Bézier 控制点的 X 坐标
y1 - 第一个 Bézier 控制点的 Y 坐标
x2 - 第二个 Bézier 控制点的 X 坐标
y2 - 第二个 Bézier 控制点的 Y 坐标
x3 - 终端点的 X 坐标
y3 - 终端点的 Y 坐标
从以下版本开始：
1.6

append

public final void append(PathIterator pi,
                         boolean connect)
将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。如果 connect 参数为 true 且路径是非空的，则添加的 Shape 几何形状的所有初始 moveTo 将被转换为 lineTo 段。如果这种连接 lineTo 段的目标坐标与当前开放子路径的结束坐标匹配，那么该线段将被作为多余线段忽略。指定 Shape 的旋绕规则将被忽略，添加的几何形状由为此路径指定的旋绕规则来管理。

指定者：
类 Path2D 中的 append
参数：
pi - 其几何形状将被添加到此路径的 PathIterator
connect - 一个 boolean 值，用于控制是否将初始 moveTo 段转换为 lineTo 段，从而将新几何形状连接到现有路径
从以下版本开始：
1.6

transform

public final void transform(AffineTransform at)
使用指定的 AffineTransform 变换此路径的几何形状。原地变换几何形状，它将永久更改由此对象定义的边界。

指定者：
类 Path2D 中的 transform
参数：
at - 用于变换区域的 AffineTransform
从以下版本开始：
1.6

getBounds2D

public final Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.6
另请参见：
Shape.getBounds()

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。如果指定一个可选 AffineTransform，则相应地转换迭代中返回的坐标。

每次调用此方法都会返回一个最新的、遍历 Shape 对象几何形状的 PathIterator 对象，该对象独立于其他所有同时使用的 PathIterator 对象。

建议但不保证实现 Shape 接口的对象将进行中的迭代与该迭代期间可能对原始对象几何形状所做的任何更改隔离开来。

此类的迭代器不是多线程安全的，这意味着该 Path2D 类不保证对此 Path2D 对象几何形状所作的修改不影响该几何形状已在处理中的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 一个可选的 AffineTransform，用于在迭代中返回的坐标，如果需要未转换的坐标，则返回 null
返回：
一个新的、独立地遍历 Shape 的几何形状的 PathIterator 对象。
从以下版本开始：
1.6

clone

public final Object clone()
创建一个与此对象具有相同类的新对象。

指定者：
类 Path2D 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.6
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PathIterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
接口 PathIterator

所有已知实现类：
FlatteningPathIterator
public interface PathIterator

PathIterator 接口通过允许调用者一次一段地获取边界的路径，为实现 Shape 接口的对象提供返回其边界几何形状的机制。此接口允许这些对象一次一段地获取其边界，方法是使用从一阶到三阶 Bézier 曲线，这些曲线是直线、二次或三次 Bézier 样条。

多个子路径可以通过使用 "MOVETO" 段在几何形状中创建间断性以从一个子路径的结尾移动到下一个子路径的开头来表示。

每个子路径都可以被手动关闭，方法是在该子路径的起始 "MOVETO" 段所在的坐标上结束子路径中的最后一段，或者使用 "CLOSE" 段追加一条线段连接最后一点和第一点。应该知道，相对于使用 "CLOSE" 段关闭路径而言，手动关闭轮廓可能导致在子路径的结束点使用不同的线风格装饰。例如，BasicStroke 对象使用线 "JOIN" 装饰来连接第一点和最后一点（如果遇到 "CLOSE" 段），而在该开头坐标上结束路径将导致在结尾使用线 "CAP" 装饰。

另请参见：
Shape, BasicStroke

字段摘要
static int | SEG_CLOSE 该段类型常量指定应该通过将线段追加到与最新 SEG_MOVETO 对应的点来关闭前面的子路径。
static int | SEG_CUBICTO 该段类型常量针对某个 3 个点的集合，指定要根据最新指定点绘制的三次参数曲线。
static int | SEG_LINETO 该段类型常量针对某个点，指定要根据最新指定点绘制的线的结束点。
static int | SEG_MOVETO 该段类型常量针对某个点，指定新子路径的起始位置。
static int | SEG_QUADTO 该段类型常量针对某对点，指定要根据最新指定点绘制的二次参数曲线。
static int | WIND_EVEN_ODD 用于指定确定路径内部的奇偶规则的旋绕规则常量。
static int | WIND_NON_ZERO 用于指定确定路径内部的非零规则的旋绕规则常量。
方法摘要
int | currentSegment(double[] coords) 使用迭代返回当前路径段的坐标和类型。
int | currentSegment(float[] coords) 使用迭代返回当前路径段的坐标和类型。
int | getWindingRule() 返回用于确定路径迭代的旋绕规则。
boolean | isDone() 测试迭代是否完成。
void | next() 只要最初的遍历方向上还存在点，就沿该方向将迭代器移动到下一个路径段。

字段详细信息

WIND_EVEN_ODD

static final int WIND_EVEN_ODD
用于指定确定路径内部的奇偶规则的旋绕规则常量。奇偶规则规定，如果路径段穿过任意方向上从一点向无穷大绘制的射线的次数为奇数,则该点位于路径内。

另请参见：
常量字段值

WIND_NON_ZERO

static final int WIND_NON_ZERO
用于指定确定路径内部的非零规则的旋绕规则常量。非零规则规定，如果路径段按逆时针方向与按顺时针方向穿过任意方向上从一点向无穷大绘制的射线的次数不同，则该点位于路径内。

另请参见：
常量字段值

SEG_MOVETO

static final int SEG_MOVETO
该段类型常量针对某个点，指定新子路径的起始位置。

另请参见：
常量字段值

SEG_LINETO

static final int SEG_LINETO
该段类型常量针对某个点，指定要根据最新指定点绘制的线的结束点。

另请参见：
常量字段值

SEG_QUADTO

static final int SEG_QUADTO
该段类型常量针对某对点，指定要根据最新指定点绘制的二次参数曲线。该曲线通过使用最新指定的（当前）点 (CP)、第一个控制点 (P1) 和最后一个内插的控制点 (P2) 在 (t=[0..1]) 范围内解参数控制方程来内插。此曲线的参数控制方程为：
          P(t) = B(2,0)*CP + B(2,1)*P1 + B(2,2)*P2
          0 <= t <= 1

        B(n,m) = mth coefficient of nth degree Bernstein polynomial
               = C(n,m) * t^(m) * (1 - t)^(n-m)
        C(n,m) = Combinations of n things, taken m at a time
               = n! / (m! * (n-m)!)

另请参见：
常量字段值

SEG_CUBICTO

static final int SEG_CUBICTO
该段类型常量针对某个 3 个点的集合，指定要根据最新指定点绘制的三次参数曲线。该曲线通过使用最新指定的（当前）点 (CP)、第一个控制点 (P1)、第二个控制点 (P2) 和最后一个内插的控制点 (P3) 在 (t=[0..1]) 范围内解参数控制方程来内插。此曲线的参数控制方程为：
          P(t) = B(3,0)*CP + B(3,1)*P1 + B(3,2)*P2 + B(3,3)*P3
          0 <= t <= 1

        B(n,m) = mth coefficient of nth degree Bernstein polynomial
               = C(n,m) * t^(m) * (1 - t)^(n-m)
        C(n,m) = Combinations of n things, taken m at a time
               = n! / (m! * (n-m)!)
这一形式的曲线通常称为 Bézier 曲线。

另请参见：
常量字段值

SEG_CLOSE

static final int SEG_CLOSE
该段类型常量指定应该通过将线段追加到与最新 SEG_MOVETO 对应的点来关闭前面的子路径。

另请参见：
常量字段值
方法详细信息

getWindingRule

int getWindingRule()
返回用于确定路径迭代的旋绕规则。

返回：
旋绕规则。
另请参见：
WIND_EVEN_ODD, WIND_NON_ZERO

isDone

boolean isDone()
测试迭代是否完成。

返回：
如果已经读取了所有的段，则返回 true；否则返回 false。

next

void next()
只要最初的遍历方向上还存在点，就沿该方向将迭代器移动到下一个路径段。

currentSegment

int currentSegment(float[] coords)
使用迭代返回当前路径段的坐标和类型。返回值就是路径段类型：SEG_MOVETO、SEG_LINETO、SEG_QUADTO、SEG_CUBICTO 或 SEG_CLOSE。必须传入长度为 6 的 float 数组，该数组可用于存储点的坐标。每个点都存储为一对 float x、y 坐标。SEG_MOVETO 和 SEG_LINETO 类型返回一个点，SEG_QUADTO 返回两个点，SEG_CUBICTO 返回 3 个点，SEG_CLOSE 不返回任何点。

参数：
coords - 保存从此方法返回数据的数组
返回：
当前路径段的路径段类型。
另请参见：
SEG_MOVETO, SEG_LINETO, SEG_QUADTO, SEG_CUBICTO, SEG_CLOSE

currentSegment

int currentSegment(double[] coords)
使用迭代返回当前路径段的坐标和类型。返回值就是路径段类型：SEG_MOVETO、SEG_LINETO、SEG_QUADTO、SEG_CUBICTO 或 SEG_CLOSE。必须传入长度为 6 的 double 数组，该数组可用于存储点的坐标。每个点都存储为一对 double x、y 坐标。SEG_MOVETO 和 SEG_LINETO 类型返回一个点，SEG_QUADTO 返回两个点，SEG_CUBICTO 返回 3 个点，SEG_CLOSE 不返回任何点。

参数：
coords - 保存从此方法返回数据的数组
返回：
当前路径段的路径段类型。
另请参见：
SEG_MOVETO, SEG_LINETO, SEG_QUADTO, SEG_CUBICTO, SEG_CLOSE
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Point2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Point2D

java.lang.Object
    继承者  java.awt.geom.Point2D
所有已实现的接口：
Cloneable
直接已知子类：
Point, Point2D.Double, Point2D.Float
public abstract class Point2D
extends Object
implements Cloneable

Point2D 类定义表示 (x,y) 坐标空间中位置的点。

此类是所有存储 2D 坐标的对象的惟一抽象超类。坐标的实际存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | Point2D.Double Double 类以 double 精度定义指定的点。
static class | Point2D.Float Float 类以 float 精度定义指定的点。
构造方法摘要
protected Point2D()
这是一个无法直接实例化的抽象类。
方法摘要
Object | clone() 创建一个与此对象具有相同类和相同内容的新对象。
double | distance(double px, double py) 返回从此 Point2D 到指定点的距离。
static double | distance(double x1, double y1, double x2, double y2) 返回两个点之间距离。
double | distance(Point2D pt) 返回从此 Point2D 到指定 Point2D 的距离。
double | distanceSq(double px, double py) 返回从此 Point2D 到指定点的距离的平方。
static double | distanceSq(double x1, double y1, double x2, double y2) 返回两个点之间距离的平方。
double | distanceSq(Point2D pt) 返回从此 Point2D 到指定 Point2D 的距离的平方。
boolean | equals(Object obj) 确定两个点是否相等。
abstract double | getX() 以 double 精度返回此 Point2D 的 X 坐标。
abstract double | getY() 以 double 精度返回此 Point2D 的 Y 坐标。
int | hashCode() 返回此 Point2D 的哈希码。
abstract void | setLocation(double x, double y) 将此 Point2D 的位置设为指定的 double 坐标。
void | setLocation(Point2D p) 将此 Point2D 的位置设为指定 Point2D 对象的坐标。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Point2D

protected Point2D()
这是一个无法直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
Point2D.Float, Point2D.Double, Point
方法详细信息

getX

public abstract double getX()
以 double 精度返回此 Point2D 的 X 坐标。

返回：
此 Point2D 的 X 坐标。
从以下版本开始：
1.2

getY

public abstract double getY()
以 double 精度返回此 Point2D 的 Y 坐标。

返回：
此 Point2D 的 Y 坐标。
从以下版本开始：
1.2

setLocation

public abstract void setLocation(double x,
                                 double y)
将此 Point2D 的位置设为指定的 double 坐标。

参数：
x - 此 Point2D 的新 X 坐标
y - 此 Point2D 的新 Y 坐标
从以下版本开始：
1.2

setLocation

public void setLocation(Point2D p)
将此 Point2D 的位置设为指定 Point2D 对象的坐标。

参数：
p - 用于设置此 Point2D 的指定 Point2D
从以下版本开始：
1.2

distanceSq

public static double distanceSq(double x1,
                                double y1,
                                double x2,
                                double y2)
返回两个点之间距离的平方。

参数：
x1 - 第一个指定点的 X 坐标
y1 - 第一个指定点的 Y 坐标
x2 - 第二个指定点的 X 坐标
y2 - 第二个指定点的 Y 坐标
返回：
两组指定坐标之间距离的平方。
从以下版本开始：
1.2

distance

public static double distance(double x1,
                              double y1,
                              double x2,
                              double y2)
返回两个点之间距离。

参数：
x1 - 第一个指定点的 X 坐标
y1 - 第一个指定点的 Y 坐标
x2 - 第二个指定点的 X 坐标
y2 - 第二个指定点的 Y 坐标
返回：
两组指定坐标之间的距离。
从以下版本开始：
1.2

distanceSq

public double distanceSq(double px,
                         double py)
返回从此 Point2D 到指定点的距离的平方。

参数：
px - 将对照此 Point2D 进行测量的指定点的 X 坐标
py - 将对照此 Point2D 进行测量的指定点的 X 坐标
返回：
此 Point2D 与指定点之间距离的平方。
从以下版本开始：
1.2

distanceSq

public double distanceSq(Point2D pt)
返回从此 Point2D 到指定 Point2D 的距离的平方。 将对照此 Point2D 进行测量的指定点的 X 坐标

参数：
py - 将对照此 Point2D 进行测量的指定点的 X 坐标
返回：
此 Point2D 与指定点之间的距离。
从以下版本开始：
1.2

distance

public double distance(double px,
                       double py)
返回从此 Point2D 到指定点的距离。

参数：
px - 将对照此 Point2D 进行测量的指定点的 X 坐标
py - 将对照此 Point2D 进行测量的指定点的 X 坐标
返回：
此 Point2D 与指定点之间的距离。
从以下版本开始：
1.2

distance

public double distance(Point2D pt)
返回从此 Point2D 到指定 Point2D 的距离。

参数：
pt - 将对照此 Point2D 进行测量的指定点
返回：
此 Point2D 和指定 Point2D 之间的距离。
从以下版本开始：
1.2

clone

public Object clone()
创建一个与此对象具有相同类和相同内容的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.2
另请参见：
Cloneable

hashCode

public int hashCode()
返回此 Point2D 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Point2D 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
确定两个点是否相等。如果 Point2D 的两个实例的 x 和 y 成员字段值相同，则它们是相等的，这表示它们在坐标空间中的位置是一样的。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此 Point2D 的实例进行比较的对象
返回：
如果要比较的对象是 Point2D 的实例且值相同，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Point2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Point2D.Double

java.lang.Object
    继承者  java.awt.geom.Point2D
        继承者  java.awt.geom.Point2D.Double
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
Point2D
public static class Point2D.Double
extends Point2D
implements Serializable

Double 类以 double 精度定义指定的点。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Point2D 继承的嵌套类/接口
Point2D.Double, Point2D.Float
字段摘要
double | x 此 Point2D 的 X 坐标。
double | y 此 Point2D 的 Y 坐标。
构造方法摘要
Point2D.Double()
使用坐标 (0,0) 构造并初始化一个 Point2D。
Point2D.Double(double x, double y)
使用指定坐标构造并初始化一个 Point2D。
方法摘要
double | getX() 以 double 精度返回此 Point2D 的 X 坐标。
double | getY() 以 double 精度返回此 Point2D 的 Y 坐标。
void | setLocation(double x, double y) 将此 Point2D 的位置设为指定的 double 坐标。
String | toString() 返回表示此 Point2D 值的 String。
从类 java.awt.geom.Point2D 继承的方法
clone, distance, distance, distance, distanceSq, distanceSq, distanceSq, equals, hashCode, setLocation
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

x

public double x
此 Point2D 的 X 坐标。

从以下版本开始：
1.2

y

public double y
此 Point2D 的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

Point2D.Double

public Point2D.Double()
使用坐标 (0,0) 构造并初始化一个 Point2D。

从以下版本开始：
1.2

Point2D.Double

public Point2D.Double(double x,
                      double y)
使用指定坐标构造并初始化一个 Point2D。

参数：
x - 新构造 Point2D 的 X 坐标
y - 新构造 Point2D 的 Y 坐标
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回此 Point2D 的 X 坐标。

指定者：
类 Point2D 中的 getX
返回：
此 Point2D 的 X 坐标。

getY

public double getY()
以 double 精度返回此 Point2D 的 Y 坐标。

指定者：
类 Point2D 中的 getY
返回：
此 Point2D 的 Y 坐标。

setLocation

public void setLocation(double x,
                        double y)
将此 Point2D 的位置设为指定的 double 坐标。

指定者：
类 Point2D 中的 setLocation
参数：
x - 此 Point2D 的新 X 坐标
y - 此 Point2D 的新 Y 坐标
从以下版本开始：
1.2

toString

public String toString()
返回表示此 Point2D 值的 String。

覆盖：
类 Object 中的 toString
返回：
此 Point2D 的字符串表示形式。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Point2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Point2D.Float

java.lang.Object
    继承者  java.awt.geom.Point2D
        继承者  java.awt.geom.Point2D.Float
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
Point2D
public static class Point2D.Float
extends Point2D
implements Serializable

Float 类以 float 精度定义指定的点。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Point2D 继承的嵌套类/接口
Point2D.Double, Point2D.Float
字段摘要
float | x 此 Point2D 的 X 坐标。
float | y 此 Point2D 的 Y 坐标。
构造方法摘要
Point2D.Float()
使用坐标 (0,0) 构造并初始化一个 Point2D。
Point2D.Float(float x, float y)
使用指定坐标构造并初始化一个 Point2D。
方法摘要
double | getX() 以 double 精度返回此 Point2D 的 X 坐标。
double | getY() 以 double 精度返回此 Point2D 的 Y 坐标。
void | setLocation(double x, double y) 将此 Point2D 的位置设为指定的 double 坐标。
void | setLocation(float x, float y) 将此 Point2D 的位置设为指定的 float 坐标。
String | toString() 返回表示此 Point2D 值的 String。
从类 java.awt.geom.Point2D 继承的方法
clone, distance, distance, distance, distanceSq, distanceSq, distanceSq, equals, hashCode, setLocation
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

x

public float x
此 Point2D 的 X 坐标。

从以下版本开始：
1.2

y

public float y
此 Point2D 的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

Point2D.Float

public Point2D.Float()
使用坐标 (0,0) 构造并初始化一个 Point2D。

从以下版本开始：
1.2

Point2D.Float

public Point2D.Float(float x,
                     float y)
使用指定坐标构造并初始化一个 Point2D。

参数：
x - 新构造 Point2D 的 X 坐标
y - 新构造 Point2D 的 Y 坐标
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回此 Point2D 的 X 坐标。

指定者：
类 Point2D 中的 getX
返回：
此 Point2D 的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回此 Point2D 的 Y 坐标。

指定者：
类 Point2D 中的 getY
返回：
此 Point2D 的 Y 坐标。
从以下版本开始：
1.2

setLocation

public void setLocation(double x,
                        double y)
将此 Point2D 的位置设为指定的 double 坐标。

指定者：
类 Point2D 中的 setLocation
参数：
x - 此 Point2D 的新 X 坐标
y - 此 Point2D 的新 Y 坐标
从以下版本开始：
1.2

setLocation

public void setLocation(float x,
                        float y)
将此 Point2D 的位置设为指定的 float 坐标。

参数：
x - 此 Point2D 的新 X 坐标
y - 此 Point2D 的新 Y 坐标
从以下版本开始：
1.2

toString

public String toString()
返回表示此 Point2D 值的 String。

覆盖：
类 Object 中的 toString
返回：
此 Point2D 的字符串表示形式。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


QuadCurve2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 QuadCurve2D

java.lang.Object
    继承者  java.awt.geom.QuadCurve2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
QuadCurve2D.Double, QuadCurve2D.Float
public abstract class QuadCurve2D
extends Object
implements Shape, Cloneable

QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。

此类是所有存储 2D 二次曲线段的对象的惟一抽象超类。坐标的实际存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。
构造方法摘要
protected QuadCurve2D()
这是一个不可直接实例化的抽象类。
方法摘要
Object | clone() 创建一个与此对象具有相同类和相同内容的新对象。
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
boolean | contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
Rectangle | getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
abstract Point2D | getCtrlPt() 返回控制点。
abstract double | getCtrlX() 以 double 精度返回控制点的 X 坐标。
abstract double | getCtrlY() 以 double 精度返回控制点的 Y 坐标。
double | getFlatness() 返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）。
static double | getFlatness(double[] coords, int offset) 返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。
static double | getFlatness(double x1, double y1, double ctrlx, double ctrly, double x2, double y2) 返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。
double | getFlatnessSq() 返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）的平方。
static double | getFlatnessSq(double[] coords, int offset) 返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。
static double | getFlatnessSq(double x1, double y1, double ctrlx, double ctrly, double x2, double y2) 返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。
abstract Point2D | getP1() 返回起始点。
abstract Point2D | getP2() 返回结束点。
PathIterator | getPathIterator(AffineTransform at) 返回定义此 QuadCurve2D 的形状边界的迭代对象。
PathIterator | getPathIterator(AffineTransform at, double flatness) 返回定义此 QuadCurve2D 的变平形状边界的迭代对象。
abstract double | getX1() 以 double 精度返回起始点的 X 坐标。
abstract double | getX2() 以 double 精度返回结束点的 X 坐标。
abstract double | getY1() 以 double 精度返回起始点的 Y 坐标。
abstract double | getY2() 以 double 精度返回结束点的 Y 坐标。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
boolean | intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
void | setCurve(double[] coords, int offset) 将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处的 double 坐标。
abstract void | setCurve(double x1, double y1, double ctrlx, double ctrly, double x2, double y2) 将此曲线端点和控制点的位置设置为指定的 double 坐标。
void | setCurve(Point2D[] pts, int offset) 将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处 Point2D 对象的坐标。
void | setCurve(Point2D p1, Point2D cp, Point2D p2) 将此 QuadCurve2D 端点和控制点的位置设置为指定的 Point2D 坐标。
void | setCurve(QuadCurve2D c) 将此 QuadCurve2D 端点和控制点的位置设置为与指定的 QuadCurve2D 相同。
static int | solveQuadratic(double[] eqn) 解系数位于 eqn 数组中的二次曲线，并将非复数的根放回该数组，同时返回根数。
static int | solveQuadratic(double[] eqn, double[] res) 解系数位于 eqn 数组中的二次曲线，并将非复数的根放入 res 数组，同时返回根数。
static void | subdivide(double[] src, int srcoff, double[] left, int leftoff, double[] right, int rightoff) 细分由存储在 src 数组 srcoff 到 (srcoff + 5) 索引处的坐标指定的二次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。
void | subdivide(QuadCurve2D left, QuadCurve2D right) 细分此 QuadCurve2D 并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
static void | subdivide(QuadCurve2D src, QuadCurve2D left, QuadCurve2D right) 细分由 src 参数指定的二次曲线并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Shape 继承的方法
getBounds2D

构造方法详细信息

QuadCurve2D

protected QuadCurve2D()
这是一个不可直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
QuadCurve2D.Float, QuadCurve2D.Double
方法详细信息

getX1

public abstract double getX1()
以 double 精度返回起始点的 X 坐标。

返回：
起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public abstract double getY1()
以 double 精度返回起始点的 Y 坐标。

返回：
起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public abstract Point2D getP1()
返回起始点。

返回：
作为此 QuadCurve2D 起始点的 Point2D。
从以下版本开始：
1.2

getCtrlX

public abstract double getCtrlX()
以 double 精度返回控制点的 X 坐标。

返回：
控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY

public abstract double getCtrlY()
以 double 精度返回控制点的 Y 坐标。

返回：
控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlPt

public abstract Point2D getCtrlPt()
返回控制点。

返回：
作为此 Point2D 控制点的 Point2D。
从以下版本开始：
1.2

getX2

public abstract double getX2()
以 double 精度返回结束点的 X 坐标。

返回：
结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public abstract double getY2()
以 double 精度返回结束点的 Y 坐标。

返回：
结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public abstract Point2D getP2()
返回结束点。

返回：
作为 Point2D 结束点的 Point 对象。
从以下版本开始：
1.2

setCurve

public abstract void setCurve(double x1,
                              double y1,
                              double ctrlx,
                              double ctrly,
                              double x2,
                              double y2)
将此曲线端点和控制点的位置设置为指定的 double 坐标。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

setCurve

public void setCurve(double[] coords,
                     int offset)
将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处的 double 坐标。

参数：
coords - 包含坐标值的数组
offset - 数组中的索引，从此处开始获取坐标值并将其赋给此 QuadCurve2D
从以下版本开始：
1.2

setCurve

public void setCurve(Point2D p1,
                     Point2D cp,
                     Point2D p2)
将此 QuadCurve2D 端点和控制点的位置设置为指定的 Point2D 坐标。

参数：
p1 - 起始点
cp - 控制点
p2 - 结束点
从以下版本开始：
1.2

setCurve

public void setCurve(Point2D[] pts,
                     int offset)
将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处 Point2D 对象的坐标。

参数：
pts - 包含定义坐标值的 Point2D 的数组
offset - pts 中的索引，从此处开始获取坐标值并将其赋给此 QuadCurve2D
从以下版本开始：
1.2

setCurve

public void setCurve(QuadCurve2D c)
将此 QuadCurve2D 端点和控制点的位置设置为与指定的 QuadCurve2D 相同。

参数：
c - 指定的 QuadCurve2D
从以下版本开始：
1.2

getFlatnessSq

public static double getFlatnessSq(double x1,
                                   double y1,
                                   double ctrlx,
                                   double ctrly,
                                   double x2,
                                   double y2)
返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
返回：
由指定坐标定义的二次曲线平面度的平方。
从以下版本开始：
1.2

getFlatness

public static double getFlatness(double x1,
                                 double y1,
                                 double ctrlx,
                                 double ctrly,
                                 double x2,
                                 double y2)
返回由指示控制点指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
返回：
由指定坐标定义的二次曲线平面度
从以下版本开始：
1.2

getFlatnessSq

public static double getFlatnessSq(double[] coords,
                                   int offset)
返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）的平方。

参数：
coords - 包含坐标值的数组
offset - coords 中的索引，从此处开始从数组中获取值
返回：
由指定数组指定索引处的值定义的二次曲线平面度。
从以下版本开始：
1.2

getFlatness

public static double getFlatness(double[] coords,
                                 int offset)
返回由控制点（存储在指示数组中的指示索引处）指定的二次曲线平面度（或者说从控制点到连接端点的线的最大距离）。

参数：
coords - 包含坐标值的数组
offset - coords 中的索引，从此处开始获取坐标值
返回：
由指定数组中指定偏移量定义的二次曲线平面度。
从以下版本开始：
1.2

getFlatnessSq

public double getFlatnessSq()
返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）的平方。

返回：
此 QuadCurve2D 平面度的平方。
从以下版本开始：
1.2

getFlatness

public double getFlatness()
返回此 QuadCurve2D 的平面度（或者说从控制点到连接端点的线的最大距离）。

返回：
此 QuadCurve2D 的平面度。
从以下版本开始：
1.2

subdivide

public void subdivide(QuadCurve2D left,
                      QuadCurve2D right)
细分此 QuadCurve2D 并将得到的两个细分曲线存储到 left 和 right 曲线参数中。left 和 right 两个对象的一个（或两个）可以与 QuadCurve2D 对象相同，也可以为 null。

参数：
left - 用于存储左边一半（或第一半）细分曲线的 QuadCurve2D 对象
right - 用于存储右边一半（或第二半）细分曲线的 QuadCurve2D 对象
从以下版本开始：
1.2

subdivide

public static void subdivide(QuadCurve2D src,
                             QuadCurve2D left,
                             QuadCurve2D right)
细分由 src 参数指定的二次曲线并将得到的两个细分曲线存储到 left 和 right 曲线参数中。left 和 right 两个对象的任何一个或两者都可以与 src 对象相同，也可以为 null。

参数：
src - 要细分的二次曲线
left - 用于存储左边一半（或第一半）细分曲线的 QuadCurve2D 对象
right - 用于存储右边一半（或第二半）细分曲线的 QuadCurve2D 对象
从以下版本开始：
1.2

subdivide

public static void subdivide(double[] src,
                             int srcoff,
                             double[] left,
                             int leftoff,
                             double[] right,
                             int rightoff)
细分由存储在 src 数组 srcoff 到 (srcoff + 5) 索引处的坐标指定的二次曲线，并将得到的两个细分曲线存储到所得数组的相应索引中。left 和 right 数组中的一个（或两个）可以为 null，也可以为到与 src 相同的数组和偏移量的引用。注意，第一个细分曲线的最后一点就是第二个细分曲线的第一点。因此，可以为 left 和 right 传递相同的数组，并使用偏移量（如 rightoff 等于 (leftoff + 4），以避免为此公共点分配额外的存储区。

参数：
src - 保存源曲线坐标的数组
srcoff - 6 个源坐标的开头在数组中的偏移量
left - 存储第一半细分曲线坐标的数组
leftoff - 6 个左坐标的开头在数组中的偏移量
right - 存储第二半细分曲线坐标的数组
rightoff - 6 个右坐标的开头在数组中的偏移量
从以下版本开始：
1.2

solveQuadratic

public static int solveQuadratic(double[] eqn)
解系数位于 eqn 数组中的二次曲线，并将非复数的根放回该数组，同时返回根数。用以下方程表示二次曲线的解：
     eqn = {C, B, A};
     ax^2 + bx + c = 0
返回值 -1 用于区分常数方程（可以始终为 0 或永远不为 0）与不包含任何零的方程。

参数：
eqn - 包含二次曲线系数的数组
返回：
根数；如果方程是常数方程，则返回 -1
从以下版本开始：
1.2

solveQuadratic

public static int solveQuadratic(double[] eqn,
                                 double[] res)
解系数位于 eqn 数组中的二次曲线，并将非复数的根放入 res 数组，同时返回根数。用以下方程表示二次曲线的解：
     eqn = {C, B, A};
     ax^2 + bx + c = 0
返回值 -1 用于区分常数方程（可以始终为 0 或永远不为 0）与不包含任何零的方程。

参数：
eqn - 用于解二次曲线方程的指定系数数组
res - 包含求解二次曲线方程所得非复数根的数组
返回：
根数；如果方程是常数方程，则返回 -1。
从以下版本开始：
1.3

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

contains

public boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
p - 要测试的指定的 Point2D
返回：
如果指定的 Point2D 在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

intersects

public boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.intersects(double, double, double, double)

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

contains

public boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：
  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含 Rectangle2D 的代价太高。
这意味着对于某些 Shape，即使 Shape 包含 Rectangle2D，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部完全包含 Rectangle2D，则返回 true；否则，如果 Shape 包含 Rectangle2D、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.contains(double, double, double, double)

getBounds

public Rectangle getBounds()
返回一个完全包围 Shape 的整型 Rectangle。注意，不保证返回的 Rectangle 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle 中。如果 Shape 超出了整数数据类型的有效范围，则返回的 Rectangle 也可能不完全包围 Shape。getBounds2D 方法由于在表示形式上具有更大的灵活性，所以通常返回更紧密的边界框。

指定者：
接口 Shape 中的 getBounds
返回：
完全包围 Shape 的整型 Rectangle。
从以下版本开始：
1.2
另请参见：
Shape.getBounds2D()

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回定义此 QuadCurve2D 的形状边界的迭代对象。此类的迭代器不是多线程安全的，这意味着此 QuadCurve2D 类不保证对此 QuadCurve2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 要应用于形状边界的可选的 AffineTransform
返回：
定义形状边界的 PathIterator 对象。
从以下版本开始：
1.2

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
返回定义此 QuadCurve2D 的变平形状边界的迭代对象。此类的迭代器不是多线程安全的，这意味着此 QuadCurve2D 类不保证对此 QuadCurve2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 要应用于形状边界的可选的 AffineTransform
flatness - 在连接端点的直线取代曲线前，细分曲线的控制端点可以相对于连接此曲线端点的线的最大距离。
返回：
定义变平的形状边界的 PathIterator 对象。
从以下版本开始：
1.2

clone

public Object clone()
创建一个与此对象具有相同类和相同内容的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.2
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


QuadCurve2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 QuadCurve2D.Double

java.lang.Object
    继承者  java.awt.geom.QuadCurve2D
        继承者  java.awt.geom.QuadCurve2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
QuadCurve2D
public static class QuadCurve2D.Double
extends QuadCurve2D
implements Serializable

使用 double 坐标指定的二次参数曲线段。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.QuadCurve2D 继承的嵌套类/接口
QuadCurve2D.Double, QuadCurve2D.Float
字段摘要
double | ctrlx 二次曲线段控制点的 X 坐标。
double | ctrly 二次曲线段控制点的 Y 坐标。
double | x1 二次曲线段起始点的 X 坐标。
double | x2 二次曲线段结束点的 X 坐标。
double | y1 二次曲线段起始点的 Y 坐标。
double | y2 二次曲线段结束点的 Y 坐标。
构造方法摘要
QuadCurve2D.Double()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。
QuadCurve2D.Double(double x1, double y1, double ctrlx, double ctrly, double x2, double y2)
根据指定 double 坐标构造并初始化 QuadCurve2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Point2D | getCtrlPt() 返回控制点。
double | getCtrlX() 以 double 精度返回控制点的 X 坐标。
double | getCtrlY() 以 double 精度返回控制点的 Y 坐标。
Point2D | getP1() 返回起始点。
Point2D | getP2() 返回结束点。
double | getX1() 以 double 精度返回起始点的 X 坐标。
double | getX2() 以 double 精度返回结束点的 X 坐标。
double | getY1() 以 double 精度返回起始点的 Y 坐标。
double | getY2() 以 double 精度返回结束点的 Y 坐标。
void | setCurve(double x1, double y1, double ctrlx, double ctrly, double x2, double y2) 将此曲线端点和控制点的位置设置为指定的 double 坐标。
从类 java.awt.geom.QuadCurve2D 继承的方法
clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveQuadratic, solveQuadratic, subdivide, subdivide, subdivide
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x1

public double x1
二次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

public double y1
二次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx

public double ctrlx
二次曲线段控制点的 X 坐标。

从以下版本开始：
1.2

ctrly

public double ctrly
二次曲线段控制点的 Y 坐标。

从以下版本开始：
1.2

x2

public double x2
二次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

public double y2
二次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

QuadCurve2D.Double

public QuadCurve2D.Double()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。

从以下版本开始：
1.2

QuadCurve2D.Double

public QuadCurve2D.Double(double x1,
                          double y1,
                          double ctrlx,
                          double ctrly,
                          double x2,
                          double y2)
根据指定 double 坐标构造并初始化 QuadCurve2D。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2
方法详细信息

getX1

public double getX1()
以 double 精度返回起始点的 X 坐标。

指定者：
类 QuadCurve2D 中的 getX1
返回：
起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public double getY1()
以 double 精度返回起始点的 Y 坐标。

指定者：
类 QuadCurve2D 中的 getY1
返回：
起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public Point2D getP1()
返回起始点。

指定者：
类 QuadCurve2D 中的 getP1
返回：
作为此 QuadCurve2D 起始点的 Point2D。
从以下版本开始：
1.2

getCtrlX

public double getCtrlX()
以 double 精度返回控制点的 X 坐标。

指定者：
类 QuadCurve2D 中的 getCtrlX
返回：
控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY

public double getCtrlY()
以 double 精度返回控制点的 Y 坐标。

指定者：
类 QuadCurve2D 中的 getCtrlY
返回：
控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlPt

public Point2D getCtrlPt()
返回控制点。

指定者：
类 QuadCurve2D 中的 getCtrlPt
返回：
作为此 Point2D 控制点的 Point2D。
从以下版本开始：
1.2

getX2

public double getX2()
以 double 精度返回结束点的 X 坐标。

指定者：
类 QuadCurve2D 中的 getX2
返回：
结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public double getY2()
以 double 精度返回结束点的 Y 坐标。

指定者：
类 QuadCurve2D 中的 getY2
返回：
结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public Point2D getP2()
返回结束点。

指定者：
类 QuadCurve2D 中的 getP2
返回：
作为 Point2D 结束点的 Point 对象。
从以下版本开始：
1.2

setCurve

public void setCurve(double x1,
                     double y1,
                     double ctrlx,
                     double ctrly,
                     double x2,
                     double y2)
将此曲线端点和控制点的位置设置为指定的 double 坐标。

指定者：
类 QuadCurve2D 中的 setCurve
参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


QuadCurve2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 QuadCurve2D.Float

java.lang.Object
    继承者  java.awt.geom.QuadCurve2D
        继承者  java.awt.geom.QuadCurve2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
QuadCurve2D
public static class QuadCurve2D.Float
extends QuadCurve2D
implements Serializable

使用 float 坐标指定的二次参数曲线段。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.QuadCurve2D 继承的嵌套类/接口
QuadCurve2D.Double, QuadCurve2D.Float
字段摘要
float | ctrlx 二次曲线段控制点的 X 坐标。
float | ctrly 二次曲线段控制点的 Y 坐标。
float | x1 二次曲线段起始点的 X 坐标。
float | x2 二次曲线段结束点的 X 坐标。
float | y1 二次曲线段起始点的 Y 坐标。
float | y2 二次曲线段结束点的 Y 坐标。
构造方法摘要
QuadCurve2D.Float()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。
QuadCurve2D.Float(float x1, float y1, float ctrlx, float ctrly, float x2, float y2)
根据指定 float 坐标构造并初始化一个 QuadCurve2D。
方法摘要
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Point2D | getCtrlPt() 返回控制点。
double | getCtrlX() 以 double 精度返回控制点的 X 坐标。
double | getCtrlY() 以 double 精度返回控制点的 Y 坐标。
Point2D | getP1() 返回起始点。
Point2D | getP2() 返回结束点。
double | getX1() 以 double 精度返回起始点的 X 坐标。
double | getX2() 以 double 精度返回结束点的 X 坐标。
double | getY1() 以 double 精度返回起始点的 Y 坐标。
double | getY2() 以 double 精度返回结束点的 Y 坐标。
void | setCurve(double x1, double y1, double ctrlx, double ctrly, double x2, double y2) 将此曲线端点和控制点的位置设置为指定的 double 坐标。
void | setCurve(float x1, float y1, float ctrlx, float ctrly, float x2, float y2) 将此曲线端点和控制点的位置设置为指定的 float 坐标。
从类 java.awt.geom.QuadCurve2D 继承的方法
clone, contains, contains, contains, contains, getBounds, getFlatness, getFlatness, getFlatness, getFlatnessSq, getFlatnessSq, getFlatnessSq, getPathIterator, getPathIterator, intersects, intersects, setCurve, setCurve, setCurve, setCurve, solveQuadratic, solveQuadratic, subdivide, subdivide, subdivide
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x1

public float x1
二次曲线段起始点的 X 坐标。

从以下版本开始：
1.2

y1

public float y1
二次曲线段起始点的 Y 坐标。

从以下版本开始：
1.2

ctrlx

public float ctrlx
二次曲线段控制点的 X 坐标。

从以下版本开始：
1.2

ctrly

public float ctrly
二次曲线段控制点的 Y 坐标。

从以下版本开始：
1.2

x2

public float x2
二次曲线段结束点的 X 坐标。

从以下版本开始：
1.2

y2

public float y2
二次曲线段结束点的 Y 坐标。

从以下版本开始：
1.2
构造方法详细信息

QuadCurve2D.Float

public QuadCurve2D.Float()
使用坐标 (0, 0, 0, 0, 0, 0) 构造并初始化一个 QuadCurve2D。

从以下版本开始：
1.2

QuadCurve2D.Float

public QuadCurve2D.Float(float x1,
                         float y1,
                         float ctrlx,
                         float ctrly,
                         float x2,
                         float y2)
根据指定 float 坐标构造并初始化一个 QuadCurve2D。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2
方法详细信息

getX1

public double getX1()
以 double 精度返回起始点的 X 坐标。

指定者：
类 QuadCurve2D 中的 getX1
返回：
起始点的 X 坐标。
从以下版本开始：
1.2

getY1

public double getY1()
以 double 精度返回起始点的 Y 坐标。

指定者：
类 QuadCurve2D 中的 getY1
返回：
起始点的 Y 坐标。
从以下版本开始：
1.2

getP1

public Point2D getP1()
返回起始点。

指定者：
类 QuadCurve2D 中的 getP1
返回：
作为此 QuadCurve2D 起始点的 Point2D。
从以下版本开始：
1.2

getCtrlX

public double getCtrlX()
以 double 精度返回控制点的 X 坐标。

指定者：
类 QuadCurve2D 中的 getCtrlX
返回：
控制点的 X 坐标。
从以下版本开始：
1.2

getCtrlY

public double getCtrlY()
以 double 精度返回控制点的 Y 坐标。

指定者：
类 QuadCurve2D 中的 getCtrlY
返回：
控制点的 Y 坐标。
从以下版本开始：
1.2

getCtrlPt

public Point2D getCtrlPt()
返回控制点。

指定者：
类 QuadCurve2D 中的 getCtrlPt
返回：
作为此 Point2D 控制点的 Point2D。
从以下版本开始：
1.2

getX2

public double getX2()
以 double 精度返回结束点的 X 坐标。

指定者：
类 QuadCurve2D 中的 getX2
返回：
结束点的 X 坐标。
从以下版本开始：
1.2

getY2

public double getY2()
以 double 精度返回结束点的 Y 坐标。

指定者：
类 QuadCurve2D 中的 getY2
返回：
结束点的 Y 坐标。
从以下版本开始：
1.2

getP2

public Point2D getP2()
返回结束点。

指定者：
类 QuadCurve2D 中的 getP2
返回：
作为 Point2D 结束点的 Point 对象。
从以下版本开始：
1.2

setCurve

public void setCurve(double x1,
                     double y1,
                     double ctrlx,
                     double ctrly,
                     double x2,
                     double y2)
将此曲线端点和控制点的位置设置为指定的 double 坐标。

指定者：
类 QuadCurve2D 中的 setCurve
参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

setCurve

public void setCurve(float x1,
                     float y1,
                     float ctrlx,
                     float ctrly,
                     float x2,
                     float y2)
将此曲线端点和控制点的位置设置为指定的 float 坐标。

参数：
x1 - 起始点的 X 坐标
y1 - 起始点的 Y 坐标
ctrlx - 控制点的 X 坐标
ctrly - 控制点的 Y 坐标
x2 - 结束点的 X 坐标
y2 - 结束点的 Y 坐标
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Rectangle2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Rectangle2D

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Rectangle2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
Rectangle, Rectangle2D.Double, Rectangle2D.Float
public abstract class Rectangle2D
extends RectangularShape

Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。

此类是所有存储 2D 矩形的对象的惟一抽象超类。坐标的实际存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
字段摘要
static int | OUT_BOTTOM 指示点位于此 Rectangle2D 下方的位掩码。
static int | OUT_LEFT 指示点位于此 Rectangle2D 左边的位掩码。
static int | OUT_RIGHT 指示点位于此 Rectangle2D 右边的位掩码。
static int | OUT_TOP 指示点位于此 Rectangle2D 上方的位掩码。
构造方法摘要
protected Rectangle2D()
这是一个不可直接实例化的抽象类。
方法摘要
void | add(double newx, double newy) 将由 double 精度参数 newx 和 newy 指定的点添加到此 Rectangle2D 中。
void | add(Point2D pt) 将 Point2D 对象 pt 添加到此 Rectangle2D 中。
void | add(Rectangle2D r) 将 Rectangle2D 对象添加到此 Rectangle2D 中。
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
abstract Rectangle2D | createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
abstract Rectangle2D | createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
boolean | equals(Object obj) 确定指定的 Object 是否与此 Rectangle2D 相等。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
PathIterator | getPathIterator(AffineTransform at) 返回定义此 Rectangle2D 边界的迭代对象。
PathIterator | getPathIterator(AffineTransform at, double flatness) 返回定义变平的 Rectangle2D 边界的迭代对象。
int | hashCode() 返回此 Rectangle2D 的哈希码。
static void | intersect(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest) 将指定的一对源 Rectangle2D 对象相交，并将结果置于指定的目标 Rectangle2D 对象中。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
boolean | intersectsLine(double x1, double y1, double x2, double y2) 测试指定线段是否与此 Rectangle2D 的内部相交。
boolean | intersectsLine(Line2D l) 测试指定的线段是否与此 Rectangle2D 的内部相交。
abstract int | outcode(double x, double y) 确定指定坐标相对于此 Rectangle2D 的位置。
int | outcode(Point2D p) 确定指定 Point2D 相对于此 Rectangle2D 的位置。
void | setFrame(double x, double y, double w, double h) 将此 Rectangle2D 外部边界的位置和大小设置为指定矩形值。
abstract void | setRect(double x, double y, double w, double h) 将此 Rectangle2D 的位置和大小设置为指定的 double 值。
void | setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
static void | union(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest) 将一对源 Rectangle2D 对象合并，并将结果置于指定的目标 Rectangle2D 对象中。
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OUT_LEFT

public static final int OUT_LEFT
指示点位于此 Rectangle2D 左边的位掩码。

从以下版本开始：
1.2
另请参见：
常量字段值

OUT_TOP

public static final int OUT_TOP
指示点位于此 Rectangle2D 上方的位掩码。

从以下版本开始：
1.2
另请参见：
常量字段值

OUT_RIGHT

public static final int OUT_RIGHT
指示点位于此 Rectangle2D 右边的位掩码。

从以下版本开始：
1.2
另请参见：
常量字段值

OUT_BOTTOM

public static final int OUT_BOTTOM
指示点位于此 Rectangle2D 下方的位掩码。

从以下版本开始：
1.2
另请参见：
常量字段值
构造方法详细信息

Rectangle2D

protected Rectangle2D()
这是一个不可直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
Rectangle2D.Float, Rectangle2D.Double, Rectangle
方法详细信息

setRect

public abstract void setRect(double x,
                             double y,
                             double w,
                             double h)
将此 Rectangle2D 的位置和大小设置为指定的 double 值。

参数：
x - 此 Rectangle2D 左上角的 X 坐标
y - 此 Rectangle2D 左上角的 Y 坐标
w - 此 Rectangle2D 的宽度
h - 此 Rectangle2D 的高度
从以下版本开始：
1.2

setRect

public void setRect(Rectangle2D r)
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。

参数：
r - 指定的 Rectangle2D
从以下版本开始：
1.2

intersectsLine

public boolean intersectsLine(double x1,
                              double y1,
                              double x2,
                              double y2)
测试指定线段是否与此 Rectangle2D 的内部相交。

参数：
x1 - 指定线段起始点的 X 坐标
y1 - 指定线段起始点的 Y 坐标
x2 - 指定线段结束点的 X 坐标
y2 - 指定线段结束点的 Y 坐标
返回：
如果指定线段与此 Rectangle2D 的内部相交，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersectsLine

public boolean intersectsLine(Line2D l)
测试指定的线段是否与此 Rectangle2D 的内部相交。

参数：
l - 要测试是否与此 Rectangle2D 内部相交的指定 Line2D
返回：
如果指定 Line2D 与此 Rectangle2D 的内部相交，则返回 true；否则返回 false。
从以下版本开始：
1.2

outcode

public abstract int outcode(double x,
                            double y)
确定指定坐标相对于此 Rectangle2D 的位置。此方法计算适当掩码值的二进制或 (OR)，这些掩码值针对此 Rectangle2D 的每个边指示指定坐标是否在此 Rectangle2D 其余边缘的同一侧。

参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
返回：
所有适当外码的逻辑或。
从以下版本开始：
1.2
另请参见：
OUT_LEFT, OUT_TOP, OUT_RIGHT, OUT_BOTTOM

outcode

public int outcode(Point2D p)
确定指定 Point2D 相对于此 Rectangle2D 的位置。此方法计算适当掩码值的二进制或，这些值针对此 Rectangle2D 的每个边指示指定 Point2D 是否在此 Rectangle2D 其余边缘的同一侧。

参数：
p - 指定的 Point2D
返回：
所有适当外码的逻辑或。
从以下版本开始：
1.2
另请参见：
OUT_LEFT, OUT_TOP, OUT_RIGHT, OUT_BOTTOM

setFrame

public void setFrame(double x,
                     double y,
                     double w,
                     double h)
将此 Rectangle2D 外部边界的位置和大小设置为指定矩形值。

指定者：
类 RectangularShape 中的 setFrame
参数：
x - 此 Rectangle2D 左上角的 X 坐标
y - 此 Rectangle2D 左上角的 Y 坐标
w - 此 Rectangle2D 的宽度
h - 此 Rectangle2D 的高度
从以下版本开始：
1.2
另请参见：
RectangularShape.getFrame()

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在 Shape 的边界内。

参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

createIntersection

public abstract Rectangle2D createIntersection(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。

参数：
r - 与此 Rectangle2D 相交的 Rectangle2D
返回：
同时被指定 Rectangle2D 和此 Rectangle2D 包含的最大 Rectangle2D。
从以下版本开始：
1.2

intersect

public static void intersect(Rectangle2D src1,
                             Rectangle2D src2,
                             Rectangle2D dest)
将指定的一对源 Rectangle2D 对象相交，并将结果置于指定的目标 Rectangle2D 对象中。为了避免创建第三个 Rectangle2D 对象，将其中一个源矩形作为目标矩形也是可以的，但这样此方法将改写源矩形的初始点。

参数：
src1 - 要彼此相交的一对 Rectangle2D 对象中的第一个对象
src2 - 要彼此相交的一对 Rectangle2D 对象中的第二个对象
dest - 保存 src1 与 src2 相交结果的 Rectangle2D
从以下版本开始：
1.2

createUnion

public abstract Rectangle2D createUnion(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。

参数：
r - 与此 Rectangle2D 合并的 Rectangle2D
返回：
包含指定 Rectangle2D 和此 Rectangle2D 的最小 Rectangle2D。
从以下版本开始：
1.2

union

public static void union(Rectangle2D src1,
                         Rectangle2D src2,
                         Rectangle2D dest)
将一对源 Rectangle2D 对象合并，并将结果置于指定的目标 Rectangle2D 对象中。为了避免创建第三个 Rectangle2D 对象，将其中一个源矩形作为目标矩形也是可以的，但这样此方法将改写源矩形的初始点。

参数：
src1 - 要彼此合并的一对 Rectangle2D 对象中的第一个对象
src2 - 要彼此合并的 Rectangle2D 对象中的第二个对象
dest - 保存 src1 与 src2 合并结果的 Rectangle2D
从以下版本开始：
1.2

add

public void add(double newx,
                double newy)
将由 double 精度参数 newx 和 newy 指定的点添加到此 Rectangle2D 中。所得到的 Rectangle2D 是同时包含原始 Rectangle2D 和指定点的最小 Rectangle2D。

在添加一个点后，以添加的点作为参数调用 contains 方法不一定返回 true。对于矩形的右边和底边上的点，contains 方法不返回 true。所以，如果添加的点落在放大的矩形的左边和底边上，则 contains 将对该点返回 false。

参数：
newx - 新点的 X 坐标
newy - 新点的 Y 坐标
从以下版本开始：
1.2

add

public void add(Point2D pt)
将 Point2D 对象 pt 添加到此 Rectangle2D 中。所得到的 Rectangle2D 是同时包含原始 Rectangle2D 和指定的 Point2D 的最小的 Rectangle2D。

在添加一个点后，以添加的点为参数调用 contains 方法不一定返回 true。对于矩形的右边和底部边界线上的点，contains 方法不返回 true。所以，如果添加的点落在放大的矩形的左边和底部边界线上，则 contains 将针对该点返回 false。

参数：
pt - 添加到此 Rectangle2D 中的新 Point2D
从以下版本开始：
1.2

add

public void add(Rectangle2D r)
将 Rectangle2D 对象添加到此 Rectangle2D 中。得到的 Rectangle2D 是两个 Rectangle2D 对象的并集。

参数：
r - 要添加到此 Rectangle2D 中的 Rectangle2D。
从以下版本开始：
1.2

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回定义此 Rectangle2D 边界的迭代对象。此类的迭代器是多线程安全的，这意味着此 Rectangle2D 类保证对此 Rectangle2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

参数：
at - 一个可选的 AffineTransform，用于在迭代中返回的坐标；如果需要未转换的坐标，则为 null
返回：
返回此 Rectangle2D 轮廓几何形状的 PathIterator 对象，一次一段。
从以下版本开始：
1.2

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
返回定义变平的 Rectangle2D 边界的迭代对象。因为矩形已经是平的，所以 flatness 参数将被忽略。此类的迭代器是多线程安全的，这意味着此 Rectangle2D 类保证对此 Rectangle2D 对象几何形状所作的修改不会影响该几何形状中正在进行的迭代。

指定者：
接口 Shape 中的 getPathIterator
覆盖：
类 RectangularShape 中的 getPathIterator
参数：
at - 一个可选 AffineTransform，用于在迭代中返回的坐标；如果需要未转换的坐标，则为 null
flatness - 用来近似曲线段的直线段偏离原始曲线上任一点的最大距离。因为矩形已经是平的，所以 flatness 参数将被忽略。
返回：
PathIterator 对象，该对象返回此 Rectangle2D 的轮廓的几何形状，一次一段。
从以下版本开始：
1.2

hashCode

public int hashCode()
返回此 Rectangle2D 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Rectangle2D 对象的哈希码。
从以下版本开始：
1.2
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
确定指定的 Object 是否与此 Rectangle2D 相等。如果指定的 Object 是 Rectangle2D 的实例并且位置和大小与此 Rectangle2D 相同，则其与此 Rectangle2D 相等。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此 Rectangle2D 进行比较的 Object。
返回：
如果 obj 是 Rectangle2D 的实例并且与 Rectangle2D 具有相同值，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Rectangle2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Rectangle2D.Double

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Rectangle2D
            继承者  java.awt.geom.Rectangle2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Rectangle2D
public static class Rectangle2D.Double
extends Rectangle2D
implements Serializable

Double 类定义一个在 double 坐标中指定的矩形。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Rectangle2D 继承的嵌套类/接口
Rectangle2D.Double, Rectangle2D.Float
字段摘要
double | height 此 Rectangle2D 的高度。
double | width 此 Rectangle2D 的宽度。
double | x 此 Rectangle2D 的 X 坐标。
double | y 此 Rectangle2D 的 Y 坐标。
从类 java.awt.geom.Rectangle2D 继承的字段
OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP
构造方法摘要
Rectangle2D.Double()
构造一个新 Rectangle2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。
Rectangle2D.Double(double x, double y, double w, double h)
根据指定的 double 坐标构造和初始化 Rectangle2D。
方法摘要
Rectangle2D | createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
int | outcode(double x, double y) 确定指定坐标相对于此 Rectangle2D 的位置。
void | setRect(double x, double y, double w, double h) 将此 Rectangle2D 的位置和大小设置为指定的 double 值。
void | setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
String | toString() 返回此 Rectangle2D 的 String 表示形式。
从类 java.awt.geom.Rectangle2D 继承的方法
add, add, add, contains, contains, equals, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, union
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

x

public double x
此 Rectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

public double y
此 Rectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

public double width
此 Rectangle2D 的宽度。

从以下版本开始：
1.2

height

public double height
此 Rectangle2D 的高度。

从以下版本开始：
1.2
构造方法详细信息

Rectangle2D.Double

public Rectangle2D.Double()
构造一个新 Rectangle2D，并将其初始化为：位置 (0, 0)、大小 (0, 0)。

从以下版本开始：
1.2

Rectangle2D.Double

public Rectangle2D.Double(double x,
                          double y,
                          double w,
                          double h)
根据指定的 double 坐标构造和初始化 Rectangle2D。

参数：
x - 新构造 Rectangle2D 左上角的 X 坐标
y - 新构造 Rectangle2D 左上角的 Y 坐标
w - 新构造 Rectangle2D 的宽度
h - 新构造 Rectangle2D 的高度
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setRect

public void setRect(double x,
                    double y,
                    double w,
                    double h)
将此 Rectangle2D 的位置和大小设置为指定的 double 值。

指定者：
类 Rectangle2D 中的 setRect
参数：
x - 此 Rectangle2D 左上角的 X 坐标
y - 此 Rectangle2D 左上角的 Y 坐标
w - 此 Rectangle2D 的宽度
h - 此 Rectangle2D 的高度
从以下版本开始：
1.2

setRect

public void setRect(Rectangle2D r)
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。

覆盖：
类 Rectangle2D 中的 setRect
参数：
r - 指定的 Rectangle2D
从以下版本开始：
1.2

outcode

public int outcode(double x,
                   double y)
确定指定坐标相对于此 Rectangle2D 的位置。此方法计算适当掩码值的二进制或 (OR)，这些掩码值针对此 Rectangle2D 的每个边指示指定坐标是否在此 Rectangle2D 其余边缘的同一侧。

指定者：
类 Rectangle2D 中的 outcode
参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
返回：
所有适当外码的逻辑或。
从以下版本开始：
1.2
另请参见：
Rectangle2D.OUT_LEFT, Rectangle2D.OUT_TOP, Rectangle2D.OUT_RIGHT, Rectangle2D.OUT_BOTTOM

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
覆盖：
类 Rectangle2D 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()

createIntersection

public Rectangle2D createIntersection(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。

指定者：
类 Rectangle2D 中的 createIntersection
参数：
r - 与此 Rectangle2D 相交的 Rectangle2D
返回：
同时被指定 Rectangle2D 和此 Rectangle2D 包含的最大 Rectangle2D。
从以下版本开始：
1.2

createUnion

public Rectangle2D createUnion(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。

指定者：
类 Rectangle2D 中的 createUnion
参数：
r - 与此 Rectangle2D 合并的 Rectangle2D
返回：
包含指定 Rectangle2D 和此 Rectangle2D 的最小 Rectangle2D。
从以下版本开始：
1.2

toString

public String toString()
返回此 Rectangle2D 的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
表示此 Rectangle2D 的 String。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Rectangle2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 Rectangle2D.Float

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.Rectangle2D
            继承者  java.awt.geom.Rectangle2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
Rectangle2D
public static class Rectangle2D.Float
extends Rectangle2D
implements Serializable

Float 类定义一个在 float 坐标中指定的矩形。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.Rectangle2D 继承的嵌套类/接口
Rectangle2D.Double, Rectangle2D.Float
字段摘要
float | height 此 Rectangle2D 的高度。
float | width 此 Rectangle2D 的宽度。
float | x 此 Rectangle2D 的 X 坐标。
float | y 此 Rectangle2D 的 Y 坐标。
从类 java.awt.geom.Rectangle2D 继承的字段
OUT_BOTTOM, OUT_LEFT, OUT_RIGHT, OUT_TOP
构造方法摘要
Rectangle2D.Float()
构造一个新 Rectangle2D，并将其初始化为：位置 (0.0, 0.0)、大小 (0.0, 0.0)。
Rectangle2D.Float(float x, float y, float w, float h)
根据指定的 float 坐标构造和初始化 Rectangle2D。
方法摘要
Rectangle2D | createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
int | outcode(double x, double y) 确定指定坐标相对于此 Rectangle2D 的位置。
void | setRect(double x, double y, double w, double h) 将此 Rectangle2D 的位置和大小设置为指定的 double 值。
void | setRect(float x, float y, float w, float h) 将此 Rectangle2D 的位置和大小设置为指定的 float 值。
void | setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
String | toString() 返回此 Rectangle2D 的 String 表示形式。
从类 java.awt.geom.Rectangle2D 继承的方法
add, add, add, contains, contains, equals, getPathIterator, getPathIterator, hashCode, intersect, intersects, intersectsLine, intersectsLine, outcode, setFrame, union
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

x

public float x
此 Rectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

public float y
此 Rectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

public float width
此 Rectangle2D 的宽度。

从以下版本开始：
1.2

height

public float height
此 Rectangle2D 的高度。

从以下版本开始：
1.2
构造方法详细信息

Rectangle2D.Float

public Rectangle2D.Float()
构造一个新 Rectangle2D，并将其初始化为：位置 (0.0, 0.0)、大小 (0.0, 0.0)。

从以下版本开始：
1.2

Rectangle2D.Float

public Rectangle2D.Float(float x,
                         float y,
                         float w,
                         float h)
根据指定的 float 坐标构造和初始化 Rectangle2D。

参数：
x - 新构造 Rectangle2D 的左上角的 X 坐标
y - 新构造 Rectangle2D 的左上角的 Y 坐标
w - 新构造 Rectangle2D 的宽度
h - 新构造 Rectangle2D 的高度
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setRect

public void setRect(float x,
                    float y,
                    float w,
                    float h)
将此 Rectangle2D 的位置和大小设置为指定的 float 值。

参数：
x - 此 Rectangle2D 左上角的 X 坐标
y - 此 Rectangle2D 左上角的 Y 坐标
w - 此 Rectangle2D 的宽度
h - 此 Rectangle2D 的高度
从以下版本开始：
1.2

setRect

public void setRect(double x,
                    double y,
                    double w,
                    double h)
将此 Rectangle2D 的位置和大小设置为指定的 double 值。

指定者：
类 Rectangle2D 中的 setRect
参数：
x - 此 Rectangle2D 左上角的 X 坐标
y - 此 Rectangle2D 左上角的 Y 坐标
w - 此 Rectangle2D 的宽度
h - 此 Rectangle2D 的高度
从以下版本开始：
1.2

setRect

public void setRect(Rectangle2D r)
将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。

覆盖：
类 Rectangle2D 中的 setRect
参数：
r - 指定的 Rectangle2D
从以下版本开始：
1.2

outcode

public int outcode(double x,
                   double y)
确定指定坐标相对于此 Rectangle2D 的位置。此方法计算适当掩码值的二进制或 (OR)，这些掩码值针对此 Rectangle2D 的每个边指示指定坐标是否在此 Rectangle2D 其余边缘的同一侧。

指定者：
类 Rectangle2D 中的 outcode
参数：
x - 指定的 X 坐标
y - 指定的 Y 坐标
返回：
所有适当外码的逻辑或。
从以下版本开始：
1.2
另请参见：
Rectangle2D.OUT_LEFT, Rectangle2D.OUT_TOP, Rectangle2D.OUT_RIGHT, Rectangle2D.OUT_BOTTOM

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
覆盖：
类 Rectangle2D 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()

createIntersection

public Rectangle2D createIntersection(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。

指定者：
类 Rectangle2D 中的 createIntersection
参数：
r - 与此 Rectangle2D 相交的 Rectangle2D
返回：
同时被指定 Rectangle2D 和此 Rectangle2D 包含的最大 Rectangle2D。
从以下版本开始：
1.2

createUnion

public Rectangle2D createUnion(Rectangle2D r)
返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。

指定者：
类 Rectangle2D 中的 createUnion
参数：
r - 与此 Rectangle2D 合并的 Rectangle2D
返回：
包含指定 Rectangle2D 和此 Rectangle2D 的最小 Rectangle2D。
从以下版本开始：
1.2

toString

public String toString()
返回此 Rectangle2D 的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
表示此 Rectangle2D 的 String。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RectangularShape (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 RectangularShape

java.lang.Object
    继承者  java.awt.geom.RectangularShape
所有已实现的接口：
Shape, Cloneable
直接已知子类：
Arc2D, Ellipse2D, Rectangle2D, RoundRectangle2D
public abstract class RectangularShape
extends Object
implements Shape, Cloneable

RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。此类本身不直接指定任何特定的几何形状，而只是提供由整个 Shape 对象种类继承的操纵方法。由此类提供的操纵方法可用于查询和修改矩形窗体，为子类定义其几何形状提供引用。

从以下版本开始：
1.2

构造方法摘要
protected RectangularShape()
这是一个不可直接实例化的抽象类。
方法摘要
Object | clone() 创建一个与此对象具有相同类和相同内容的新对象。
boolean | contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
Rectangle | getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
double | getCenterX() 以 double 精度返回 Shape 的窗体矩形中心的 X 坐标。
double | getCenterY() 以 double 精度返回 Shape 的窗体矩形中心的 Y 坐标。
Rectangle2D | getFrame() 返回定义此对象的总体形状的窗体 Rectangle2D。
abstract double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getMaxX() 以 double 精度返回 Shape 窗体矩形的最大 X 坐标。
double | getMaxY() 以 double 精度返回 Shape 窗体矩形的最大 Y 坐标。
double | getMinX() 以 double 精度返回 Shape 窗体矩形的最小 X 坐标。
double | getMinY() 以 double 精度返回 Shape 窗体矩形的最小 Y 坐标。
PathIterator | getPathIterator(AffineTransform at, double flatness) 返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。
abstract double | getWidth() 以 double 精度返回窗体矩形的宽度。
abstract double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
abstract double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
abstract boolean | isEmpty() 确定 RectangularShape 是否为空。
abstract void | setFrame(double x, double y, double w, double h) 将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
void | setFrame(Point2D loc, Dimension2D size) 将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。
void | setFrame(Rectangle2D r) 将此 Shape 窗体矩形设置为指定的 Rectangle2D。
void | setFrameFromCenter(double centerX, double centerY, double cornerX, double cornerY) 基于指定的中心点坐标和角点坐标设置此 Shape 的窗体矩形。
void | setFrameFromCenter(Point2D center, Point2D corner) 基于指定的中心 Point2D 和角 Point2D 设置此 Shape 的窗体矩形。
void | setFrameFromDiagonal(double x1, double y1, double x2, double y2) 基于两个指定的坐标设置此 Shape 窗体矩形的对角线。
void | setFrameFromDiagonal(Point2D p1, Point2D p2) 基于两个指定的 Point2D 对象设置此 Shape 窗体矩形的对角线。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Shape 继承的方法
contains, contains, getBounds2D, getPathIterator, intersects

构造方法详细信息

RectangularShape

protected RectangularShape()
这是一个不可直接实例化的抽象类。

从以下版本开始：
1.2
另请参见：
Arc2D, Ellipse2D, Rectangle2D, RoundRectangle2D
方法详细信息

getX

public abstract double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。

返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public abstract double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。

返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public abstract double getWidth()
以 double 精度返回窗体矩形的宽度。

返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public abstract double getHeight()
以 double 精度返回窗体矩形的高度。

返回：
窗体矩形的高度。
从以下版本开始：
1.2

getMinX

public double getMinX()
以 double 精度返回 Shape 窗体矩形的最小 X 坐标。

返回：
Shape 窗体矩形的最小 X 坐标。
从以下版本开始：
1.2

getMinY

public double getMinY()
以 double 精度返回 Shape 窗体矩形的最小 Y 坐标。

返回：
Shape 窗体矩形的最小 Y 坐标。
从以下版本开始：
1.2

getMaxX

public double getMaxX()
以 double 精度返回 Shape 窗体矩形的最大 X 坐标。

返回：
Shape 窗体矩形的最大 X 坐标。
从以下版本开始：
1.2

getMaxY

public double getMaxY()
以 double 精度返回 Shape 窗体矩形的最大 Y 坐标。

返回：
Shape 窗体矩形的最大 Y 坐标。
从以下版本开始：
1.2

getCenterX

public double getCenterX()
以 double 精度返回 Shape 的窗体矩形中心的 X 坐标。

返回：
Shape 对象的窗体矩形中心的 X 坐标。
从以下版本开始：
1.2

getCenterY

public double getCenterY()
以 double 精度返回 Shape 的窗体矩形中心的 Y 坐标。

返回：
Shape 对象的窗体矩形中心的 Y 坐标。
从以下版本开始：
1.2

getFrame

public Rectangle2D getFrame()
返回定义此对象的总体形状的窗体 Rectangle2D。

返回：
一个 Rectangle2D，它是使用 double 坐标指定的。
从以下版本开始：
1.2
另请参见：
setFrame(double, double, double, double),
setFrame(Point2D, Dimension2D),
setFrame(Rectangle2D)

isEmpty

public abstract boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setFrame

public abstract void setFrame(double x,
                              double y,
                              double w,
                              double h)
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。

参数：
x - 指定矩形左上角的 X 坐标
y - 指定矩形左上角的 Y 坐标
w - 指定矩形的宽度
h - 指定矩形的高度
从以下版本开始：
1.2
另请参见：
getFrame()

setFrame

public void setFrame(Point2D loc,
                     Dimension2D size)
将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。窗体矩形供 RectangularShape 的子类定义其几何形状。

参数：
loc - 指定的 Point2D
size - 指定的 Dimension2D
从以下版本开始：
1.2
另请参见：
getFrame()

setFrame

public void setFrame(Rectangle2D r)
将此 Shape 窗体矩形设置为指定的 Rectangle2D。窗体矩形供 RectangularShape 的子类定义其几何形状。

参数：
r - 指定的 Rectangle2D
从以下版本开始：
1.2
另请参见：
getFrame()

setFrameFromDiagonal

public void setFrameFromDiagonal(double x1,
                                 double y1,
                                 double x2,
                                 double y2)
基于两个指定的坐标设置此 Shape 窗体矩形的对角线。窗体矩形供 RectangularShape 的子类定义其几何形状。

参数：
x1 - 指定对角线起始点的 X 坐标
y1 - 指定对角线起始点的 Y 坐标
x2 - 指定对角线结束点的 X 坐标
y2 - 指定对角线结束点的 Y 坐标
从以下版本开始：
1.2

setFrameFromDiagonal

public void setFrameFromDiagonal(Point2D p1,
                                 Point2D p2)
基于两个指定的 Point2D 对象设置此 Shape 窗体矩形的对角线。窗体矩形供 RectangularShape 的子类定义其几何形状。

参数：
p1 - 指定对角线的起始 Point2D
p2 - 指定对角线的结束 Point2D
从以下版本开始：
1.2

setFrameFromCenter

public void setFrameFromCenter(double centerX,
                               double centerY,
                               double cornerX,
                               double cornerY)
基于指定的中心点坐标和角点坐标设置此 Shape 的窗体矩形。窗体矩形供 RectangularShape 的子类定义其几何形状。

参数：
centerX - 指定中心点的 X 坐标
centerY - 指定中心点的 X 坐标
cornerX - 指定角点的 X 坐标
cornerY - 指定角点的 Y 坐标
从以下版本开始：
1.2

setFrameFromCenter

public void setFrameFromCenter(Point2D center,
                               Point2D corner)
基于指定的中心 Point2D 和角 Point2D 设置此 Shape 的窗体矩形。窗体矩形供 RectangularShape 的子类定义其几何形状。

参数：
center - 指定的中心 Point2D
corner - 指定的角 Point2D
从以下版本开始：
1.2

contains

public boolean contains(Point2D p)
测试指定的 Point2D 是否在 Shape 的边界内。

指定者：
接口 Shape 中的 contains
参数：
p - 要测试的指定的 Point2D
返回：
如果指定的 Point2D 在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(Rectangle2D r)
测试 Shape 内部是否与指定 Rectangle2D 内部相交。在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：
  • Rectangle2D 与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使 Rectangle2D 没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

指定者：
接口 Shape 中的 intersects
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部与指定 Rectangle2D 内部相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.intersects(double, double, double, double)

contains

public boolean contains(Rectangle2D r)
测试 Shape 内部是否完全包含指定的 Rectangle2D。在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：
  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含 Rectangle2D 的代价太高。
这意味着对于某些 Shape，即使 Shape 包含 Rectangle2D，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

指定者：
接口 Shape 中的 contains
参数：
r - 指定的 Rectangle2D
返回：
如果 Shape 内部完全包含 Rectangle2D，则返回 true；否则，如果 Shape 包含 Rectangle2D、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Shape.contains(double, double, double, double)

getBounds

public Rectangle getBounds()
返回一个完全包围 Shape 的整型 Rectangle。注意，不保证返回的 Rectangle 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle 中。如果 Shape 超出了整数数据类型的有效范围，则返回的 Rectangle 也可能不完全包围 Shape。getBounds2D 方法由于在表示形式上具有更大的灵活性，所以通常返回更紧密的边界框。

指定者：
接口 Shape 中的 getBounds
返回：
完全包围 Shape 的整型 Rectangle。
从以下版本开始：
1.2
另请参见：
Shape.getBounds2D()

getPathIterator

public PathIterator getPathIterator(AffineTransform at,
                                    double flatness)
返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。

迭代器将只返回 SEG_MOVETO、SEG_LINETO 和 SEG_CLOSE 点类型。

flatness 参数控制曲线段分段的数量，指定变换的不平曲线上任一点能够偏离返回的变平路径段的最大距离。可以指定一个可选的 AffineTransform，以便相应地变换迭代中返回的坐标。

指定者：
接口 Shape 中的 getPathIterator
参数：
at - 可选的 AffineTransform，应用于迭代中返回坐标；如果需要未变换的坐标，则为 null。
flatness - 用来近似曲线段的直线段偏离原始曲线上任一点的最大距离
返回：
提供对 Shape 对象的变平几何形状的访问的 PathIterator 对象。
从以下版本开始：
1.2

clone

public Object clone()
创建一个与此对象具有相同类和相同内容的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
OutOfMemoryError - 如果没有足够的内存。
从以下版本开始：
1.2
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


java.awt.geom (Java 2 Platform SE 6)

 java.awt.geom
接口
PathIterator
类
AffineTransform
Arc2D
Arc2D.Double
Arc2D.Float
Area
CubicCurve2D
CubicCurve2D.Double
CubicCurve2D.Float
Dimension2D
Ellipse2D
Ellipse2D.Double
Ellipse2D.Float
FlatteningPathIterator
GeneralPath
Line2D
Line2D.Double
Line2D.Float
Path2D
Path2D.Double
Path2D.Float
Point2D
Point2D.Double
Point2D.Float
QuadCurve2D
QuadCurve2D.Double
QuadCurve2D.Float
Rectangle2D
Rectangle2D.Double
Rectangle2D.Float
RectangularShape
RoundRectangle2D
RoundRectangle2D.Double
RoundRectangle2D.Float
异常
IllegalPathStateException
NoninvertibleTransformException


RoundRectangle2D (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 RoundRectangle2D

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.RoundRectangle2D
所有已实现的接口：
Shape, Cloneable
直接已知子类：
RoundRectangle2D.Double, RoundRectangle2D.Float
public abstract class RoundRectangle2D
extends RectangularShape

RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。

此类是所有保存 2D 圆角矩形的对象的抽象超类。实际的坐标存储表示形式由子类决定。

从以下版本开始：
1.2

嵌套类摘要
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。
构造方法摘要
protected RoundRectangle2D()
这是一个无法直接实例化的抽象类。
方法摘要
boolean | contains(double x, double y) 测试指定坐标是否在 Shape 的边界内。
boolean | contains(double x, double y, double w, double h) 测试 Shape 内部是否完全包含指定矩形区域。
boolean | equals(Object obj) 确定指定的 Object 是否与此 RoundRectangle2D 相等。
abstract double | getArcHeight() 获取圆角弧的高度。
abstract double | getArcWidth() 获取圆角弧的宽度。
PathIterator | getPathIterator(AffineTransform at) 返回定义此 RoundRectangle2D 边界的迭代对象。
int | hashCode() 返回此 RoundRectangle2D 的哈希码。
boolean | intersects(double x, double y, double w, double h) 测试 Shape 内部是否与指定矩形区域的内部相交。
void | setFrame(double x, double y, double w, double h) 将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。
abstract void | setRoundRect(double x, double y, double w, double h, double arcWidth, double arcHeight) 将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
void | setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getHeight, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, getWidth, getX, getY, intersects, isEmpty, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.Shape 继承的方法
getBounds2D

构造方法详细信息

RoundRectangle2D

protected RoundRectangle2D()
这是一个无法直接实例化的抽象类。特定于类型的实现子类可用于实例化，并提供用于存储满足以下各种存取方法所需信息的多种格式。

从以下版本开始：
1.2
另请参见：
RoundRectangle2D.Float, RoundRectangle2D.Double
方法详细信息

getArcWidth

public abstract double getArcWidth()
获取圆角弧的宽度。

返回：
此 RoundRectangle2D 圆角弧的宽度。
从以下版本开始：
1.2

getArcHeight

public abstract double getArcHeight()
获取圆角弧的高度。

返回：
此 RoundRectangle2D 圆角弧的高度。
从以下版本开始：
1.2

setRoundRect

public abstract void setRoundRect(double x,
                                  double y,
                                  double w,
                                  double h,
                                  double arcWidth,
                                  double arcHeight)
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。

参数：
x - 设置此 RoundRectangle2D 的 X 坐标
y - 设置此 RoundRectangle2D 的 Y 坐标
w - 设置此 RoundRectangle2D 的宽度
h - 设置此 RoundRectangle2D 的高度
arcWidth - 设置此 RoundRectangle2D 的弧宽
arcHeight - 设置此 RoundRectangle2D 的弧高
从以下版本开始：
1.2

setRoundRect

public void setRoundRect(RoundRectangle2D rr)
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。

参数：
rr - 指定的 RoundRectangle2D
从以下版本开始：
1.2

setFrame

public void setFrame(double x,
                     double y,
                     double w,
                     double h)
将此 Shape 窗体矩形的位置和大小设置为指定的矩形值。

指定者：
类 RectangularShape 中的 setFrame
参数：
x - 指定矩形左上角的 X 坐标
y - 指定矩形左上角的 Y 坐标
w - 指定矩形的宽度
h - 指定矩形的高度
从以下版本开始：
1.2
另请参见：
RectangularShape.getFrame()

contains

public boolean contains(double x,
                        double y)
测试指定坐标是否在 Shape 的边界内。

参数：
x - 要测试的指定的 X 坐标
y - 要测试的指定的 Y 坐标
返回：
如果指定坐标在 Shape 边界内，则返回 true；否则返回 false。
从以下版本开始：
1.2

intersects

public boolean intersects(double x,
                          double y,
                          double w,
                          double h)
测试 Shape 内部是否与指定矩形区域的内部相交。如果任何一个点既包含在 Shape 内，又包含在指定矩形区域内，则认为矩形区域与 Shape 相交。

在下列情况下，Shape.intersects() 方法允许 Shape 实现谨慎地返回 true：

  • 矩形区域与 Shape 相交的可能性很大，但是
  • 精确确定相交的计算代价太高。
这意味着对于某些 Shape，即使矩形区域没有与该 Shape 相交，此方法也可能返回 true。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地计算几何相交，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 的内部区域与矩形的内部区域相交，或者相交的可能性很大且执行计算的代价太高，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Area

contains

public boolean contains(double x,
                        double y,
                        double w,
                        double h)
测试 Shape 内部是否完全包含指定矩形区域。矩形区域内的所有坐标都必须位于 Shape 中，才可以认为整个矩形区域包含在 Shape中。

在下列情况下，Shape.contains() 方法允许 Shape 实现谨慎地返回 false：

  • intersect 方法返回 true 并且
  • 计算 Shape 是否完全包含矩形区域的代价太高。
这意味着对于某些 Shape，即使 Shape 包含矩形区域，此方法也可能返回 false。如果需要更精确的答案，由于 Area 类比大多数 Shape 对象更为准确地执行几何计算，因此可以使用该类。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
如果 Shape 内部完全包含指定矩形区域，则返回 true；否则，如果 Shape 包含矩形区域、intersects 方法返回 true 且执行包含计算代价太高，则返回 false。
从以下版本开始：
1.2
另请参见：
Area, Shape.intersects(double, double, double, double)

getPathIterator

public PathIterator getPathIterator(AffineTransform at)
返回定义此 RoundRectangle2D 边界的迭代对象。此类的迭代器是多线程安全的，这意味着此 RoundRectangle2D 类保证对此 RoundRectangle2D 对象几何形状所作的修改不影响该几何形状已在进程中的迭代器。

参数：
at - 一个可选的 AffineTransform，用于在迭代中返回的坐标；如果需要未变换的坐标，则为 null
返回：
返回此 RoundRectangle2D 轮廓几何形状的 PathIterator 对象，一次一段。
从以下版本开始：
1.2

hashCode

public int hashCode()
返回此 RoundRectangle2D 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 RoundRectangle2D 的哈希码。
从以下版本开始：
1.6
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
确定指定的 Object 是否与此 RoundRectangle2D 相等。如果指定的 Object 是一个 RoundRectangle2D 实例，且其位置、大小和圆角弧维度与此 RoundRectangle2D 相同，则该指定对象与此 RoundRectangle2D 相等。

覆盖：
类 Object 中的 equals
参数：
obj - 将与此 RoundRectangle2D 进行比较的 Object。
返回：
如果 obj 是一个 RoundRectangle2D 实例并且值相同，则返回 true；否则返回 false。
从以下版本开始：
1.6
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoundRectangle2D.Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 RoundRectangle2D.Double

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.RoundRectangle2D
            继承者  java.awt.geom.RoundRectangle2D.Double
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
RoundRectangle2D
public static class RoundRectangle2D.Double
extends RoundRectangle2D
implements Serializable

Double 类定义一个所有圆角都使用 double 坐标指定的矩形。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.RoundRectangle2D 继承的嵌套类/接口
RoundRectangle2D.Double, RoundRectangle2D.Float
字段摘要
double | archeight 圆角弧的高度。
double | arcwidth 圆角弧的宽度。
double | height 此 RoundRectangle2D 的高度。
double | width 此 RoundRectangle2D 的宽度。
double | x 此 RoundRectangle2D 的 X 坐标。
double | y 此 RoundRectangle2D 的 Y 坐标。
构造方法摘要
RoundRectangle2D.Double()
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。
RoundRectangle2D.Double(double x, double y, double w, double h, double arcw, double arch)
根据指定 double 坐标构造并初始化 RoundRectangle2D。
方法摘要
double | getArcHeight() 获取圆角弧的高度。
double | getArcWidth() 获取圆角弧的宽度。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
void | setRoundRect(double x, double y, double w, double h, double arcw, double arch) 将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
void | setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
从类 java.awt.geom.RoundRectangle2D 继承的方法
contains, contains, equals, getPathIterator, hashCode, intersects, setFrame
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x

public double x
此 RoundRectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

public double y
此 RoundRectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

public double width
此 RoundRectangle2D 的宽度。

从以下版本开始：
1.2

height

public double height
此 RoundRectangle2D 的高度。

从以下版本开始：
1.2

arcwidth

public double arcwidth
圆角弧的宽度。

从以下版本开始：
1.2

archeight

public double archeight
圆角弧的高度。

从以下版本开始：
1.2
构造方法详细信息

RoundRectangle2D.Double

public RoundRectangle2D.Double()
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。

从以下版本开始：
1.2

RoundRectangle2D.Double

public RoundRectangle2D.Double(double x,
                               double y,
                               double w,
                               double h,
                               double arcw,
                               double arch)
根据指定 double 坐标构造并初始化 RoundRectangle2D。

参数：
x - 新构造 RoundRectangle2D 的 X 坐标
y - 新构造 RoundRectangle2D 的 Y 坐标
w - 设置新构造 RoundRectangle2D 的宽度
设置新构造 - RoundRectangle2D 的高度
arcw - 新构造 RoundRectangle2D 的圆角弧宽度
arch - 新构造 RoundRectangle2D 的圆角弧高度
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

getArcWidth

public double getArcWidth()
获取圆角弧的宽度。

指定者：
类 RoundRectangle2D 中的 getArcWidth
返回：
此 RoundRectangle2D 圆角弧的宽度。
从以下版本开始：
1.2

getArcHeight

public double getArcHeight()
获取圆角弧的高度。

指定者：
类 RoundRectangle2D 中的 getArcHeight
返回：
此 RoundRectangle2D 圆角弧的高度。
从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setRoundRect

public void setRoundRect(double x,
                         double y,
                         double w,
                         double h,
                         double arcw,
                         double arch)
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。

指定者：
类 RoundRectangle2D 中的 setRoundRect
参数：
x - 设置此 RoundRectangle2D 的 X 坐标
y - 设置此 RoundRectangle2D 的 Y 坐标
w - 设置此 RoundRectangle2D 的宽度
h - 设置此 RoundRectangle2D 的高度
arcw - 设置此 RoundRectangle2D 的弧宽
arch - 设置此 RoundRectangle2D 的弧高
从以下版本开始：
1.2

setRoundRect

public void setRoundRect(RoundRectangle2D rr)
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。

覆盖：
类 RoundRectangle2D 中的 setRoundRect
参数：
rr - 指定的 RoundRectangle2D
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoundRectangle2D.Float (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.geom
类 RoundRectangle2D.Float

java.lang.Object
    继承者  java.awt.geom.RectangularShape
        继承者  java.awt.geom.RoundRectangle2D
            继承者  java.awt.geom.RoundRectangle2D.Float
所有已实现的接口：
Shape, Serializable, Cloneable
正在封闭类：
RoundRectangle2D
public static class RoundRectangle2D.Float
extends RoundRectangle2D
implements Serializable

Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
从类 java.awt.geom.RoundRectangle2D 继承的嵌套类/接口
RoundRectangle2D.Double, RoundRectangle2D.Float
字段摘要
float | archeight 圆角弧的高度。
float | arcwidth 圆角弧的宽度。
float | height 此 RoundRectangle2D 的高度。
float | width 此 RoundRectangle2D 的宽度。
float | x 此 RoundRectangle2D 的 X 坐标。
float | y 此 RoundRectangle2D 的 Y 坐标。
构造方法摘要
RoundRectangle2D.Float()
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。
RoundRectangle2D.Float(float x, float y, float w, float h, float arcw, float arch)
根据指定 float 坐标构造并初始化 RoundRectangle2D。
方法摘要
double | getArcHeight() 获取圆角弧的高度。
double | getArcWidth() 获取圆角弧的宽度。
Rectangle2D | getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
double | getHeight() 以 double 精度返回窗体矩形的高度。
double | getWidth() 以 double 精度返回窗体矩形的宽度。
double | getX() 以 double 精度返回窗体矩形左上角的 X 坐标。
double | getY() 以 double 精度返回窗体矩形左上角的 Y 坐标。
boolean | isEmpty() 确定 RectangularShape 是否为空。
void | setRoundRect(double x, double y, double w, double h, double arcw, double arch) 将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。
void | setRoundRect(float x, float y, float w, float h, float arcw, float arch) 将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 float 值。
void | setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
从类 java.awt.geom.RoundRectangle2D 继承的方法
contains, contains, equals, getPathIterator, hashCode, intersects, setFrame
从类 java.awt.geom.RectangularShape 继承的方法
clone, contains, contains, getBounds, getCenterX, getCenterY, getFrame, getMaxX, getMaxY, getMinX, getMinY, getPathIterator, intersects, setFrame, setFrame, setFrameFromCenter, setFrameFromCenter, setFrameFromDiagonal, setFrameFromDiagonal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

x

public float x
此 RoundRectangle2D 的 X 坐标。

从以下版本开始：
1.2

y

public float y
此 RoundRectangle2D 的 Y 坐标。

从以下版本开始：
1.2

width

public float width
此 RoundRectangle2D 的宽度。

从以下版本开始：
1.2

height

public float height
此 RoundRectangle2D 的高度。

从以下版本开始：
1.2

arcwidth

public float arcwidth
圆角弧的宽度。

从以下版本开始：
1.2

archeight

public float archeight
圆角弧的高度。

从以下版本开始：
1.2
构造方法详细信息

RoundRectangle2D.Float

public RoundRectangle2D.Float()
构造一个新 RoundRectangle2D，并将其初始化为：位置 (0.0,0)、大小 (0.0,0.0)、圆角弧半径 0.0。

从以下版本开始：
1.2

RoundRectangle2D.Float

public RoundRectangle2D.Float(float x,
                              float y,
                              float w,
                              float h,
                              float arcw,
                              float arch)
根据指定 float 坐标构造并初始化 RoundRectangle2D。

参数：
x - 新构造 RoundRectangle2D 的 X 坐标
y - 新构造 RoundRectangle2D 的 Y 坐标
w - 设置新构造 RoundRectangle2D 的宽度
h - 设置新构造 RoundRectangle2D 的高度
arcw - 新构造 RoundRectangle2D 的圆角弧宽度
arch - 新构造 RoundRectangle2D 的圆角弧高度
从以下版本开始：
1.2
方法详细信息

getX

public double getX()
以 double 精度返回窗体矩形左上角的 X 坐标。

指定者：
类 RectangularShape 中的 getX
返回：
窗体矩形左上角的 X 坐标。
从以下版本开始：
1.2

getY

public double getY()
以 double 精度返回窗体矩形左上角的 Y 坐标。

指定者：
类 RectangularShape 中的 getY
返回：
窗体矩形左上角的 Y 坐标。
从以下版本开始：
1.2

getWidth

public double getWidth()
以 double 精度返回窗体矩形的宽度。

指定者：
类 RectangularShape 中的 getWidth
返回：
窗体矩形的宽度。
从以下版本开始：
1.2

getHeight

public double getHeight()
以 double 精度返回窗体矩形的高度。

指定者：
类 RectangularShape 中的 getHeight
返回：
窗体矩形的高度。
从以下版本开始：
1.2

getArcWidth

public double getArcWidth()
获取圆角弧的宽度。

指定者：
类 RoundRectangle2D 中的 getArcWidth
返回：
此 RoundRectangle2D 圆角弧的宽度。
从以下版本开始：
1.2

getArcHeight

public double getArcHeight()
获取圆角弧的高度。

指定者：
类 RoundRectangle2D 中的 getArcHeight
返回：
此 RoundRectangle2D 圆角弧的高度。
从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
确定 RectangularShape 是否为空。当 RectangularShape 为空时，它不封闭任何区域。

指定者：
类 RectangularShape 中的 isEmpty
返回：
如果 RectangularShape 为空，则返回 true；否则返回 false。
从以下版本开始：
1.2

setRoundRect

public void setRoundRect(float x,
                         float y,
                         float w,
                         float h,
                         float arcw,
                         float arch)
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 float 值。

参数：
x - 设置此 RoundRectangle2D 的 X 坐标
y - 设置此 RoundRectangle2D 的 Y 坐标
w - 设置此 RoundRectangle2D 的宽度
h - 设置此 RoundRectangle2D 的高度
arcw - 设置此 RoundRectangle2D 的弧宽
arch - 设置此 RoundRectangle2D 的弧高
从以下版本开始：
1.2

setRoundRect

public void setRoundRect(double x,
                         double y,
                         double w,
                         double h,
                         double arcw,
                         double arch)
将此 RoundRectangle2D 的位置、大小和圆角半径设置为指定的 double 值。

指定者：
类 RoundRectangle2D 中的 setRoundRect
参数：
x - 设置此 RoundRectangle2D 的 X 坐标
y - 设置此 RoundRectangle2D 的 Y 坐标
w - 设置此 RoundRectangle2D 的宽度
h - 设置此 RoundRectangle2D 的高度
arcw - 设置此 RoundRectangle2D 的弧宽
arch - 设置此 RoundRectangle2D 的弧高
从以下版本开始：
1.2

setRoundRect

public void setRoundRect(RoundRectangle2D rr)
将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。

覆盖：
类 RoundRectangle2D 中的 setRoundRect
参数：
rr - 指定的 RoundRectangle2D
从以下版本开始：
1.2

getBounds2D

public Rectangle2D getBounds2D()
返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。注意，不保证返回的 Rectangle2D 是包围 Shape 的最小边界框，只保证 Shape 完全位于指示的 Rectangle2D 中。此方法返回的边界框通常比 getBounds 方法返回的更紧密，而且永远不会因为溢出问题而出错，因为返回值可以是一个使用双精度值存储尺寸的 Rectangle2D 实例。

指定者：
接口 Shape 中的 getBounds2D
返回：
一个 Rectangle2D 实例，它是 Shape 的高精度边界框。
从以下版本开始：
1.2
另请参见：
Shape.getBounds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.geom (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.geom

提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

请参见：
描述

接口摘要
PathIterator PathIterator 接口通过允许调用者一次一段地获取边界的路径，为实现 Shape 接口的对象提供返回其边界几何形状的机制。

类摘要
AffineTransform | AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
Arc2D | Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
Arc2D.Double | 此类定义以 double 精度指定的弧。
Arc2D.Float | 此类定义以 float 精度指定的弧。
Area | Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
CubicCurve2D | CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
CubicCurve2D.Double | 使用 double 坐标指定的三次参数曲线段。
CubicCurve2D.Float | 使用 float 坐标指定的三次参数曲线段。
Dimension2D | Dimension2D 类用于封装宽度和高度尺寸。
Ellipse2D | Ellipse2D 类描述窗体矩形定义的椭圆。
Ellipse2D.Double | Double 类以 double 精度定义椭圆。
Ellipse2D.Float | Float 类以 float 精度定义椭圆。
FlatteningPathIterator | FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。
GeneralPath | GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
Line2D | Line2D 表示 (x,y) 坐标空间中的线段。
Line2D.Double | 使用 double 坐标指定的线段。
Line2D.Float | 使用 float 坐标指定的线段。
Path2D | Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
Path2D.Double | Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
Path2D.Float | Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
Point2D | Point2D 类定义表示 (x,y) 坐标空间中位置的点。
Point2D.Double | Double 类以 double 精度定义指定的点。
Point2D.Float | Float 类以 float 精度定义指定的点。
QuadCurve2D | QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
QuadCurve2D.Double | 使用 double 坐标指定的二次参数曲线段。
QuadCurve2D.Float | 使用 float 坐标指定的二次参数曲线段。
Rectangle2D | Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
Rectangle2D.Double | Double 类定义一个在 double 坐标中指定的矩形。
Rectangle2D.Float | Float 类定义一个在 float 坐标中指定的矩形。
RectangularShape | RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
RoundRectangle2D | RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
RoundRectangle2D.Double | Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
RoundRectangle2D.Float | Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

异常摘要
IllegalPathStateException | 对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
NoninvertibleTransformException | NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

软件包 java.awt.geom 的描述

提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。包的一些重要功能包括：

  • 操纵几何形状（如 AffineTransform）的类和所有 Shape 对象都实现的 PathIterator 接口。
  • 实现 Shape 接口（如 CubicCurve2D、Ellipse2D、Line2D、Rectangle2D 和 GeneralShape）的类。
  • 提供在其他 Shape 对象上进行加（合并）、减、相交、异或操作机制的 Area 类。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.geom 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.geom 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.geom.AffineTransform (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.geom.Area (implements java.lang.Cloneable, java.awt.Shape)
    • java.awt.geom.CubicCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.CubicCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.CubicCurve2D.Float (implements java.io.Serializable)
    • java.awt.geom.Dimension2D (implements java.lang.Cloneable)
    • java.awt.geom.FlatteningPathIterator (implements java.awt.geom.PathIterator)
    • java.awt.geom.Line2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Line2D.Double (implements java.io.Serializable)
      • java.awt.geom.Line2D.Float (implements java.io.Serializable)
    • java.awt.geom.Path2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Path2D.Double (implements java.io.Serializable)
      • java.awt.geom.Path2D.Float (implements java.io.Serializable)
        • java.awt.geom.GeneralPath
    • java.awt.geom.Point2D (implements java.lang.Cloneable)
      • java.awt.geom.Point2D.Double (implements java.io.Serializable)
      • java.awt.geom.Point2D.Float (implements java.io.Serializable)
    • java.awt.geom.QuadCurve2D (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.QuadCurve2D.Double (implements java.io.Serializable)
      • java.awt.geom.QuadCurve2D.Float (implements java.io.Serializable)
    • java.awt.geom.RectangularShape (implements java.lang.Cloneable, java.awt.Shape)
      • java.awt.geom.Arc2D
        • java.awt.geom.Arc2D.Double (implements java.io.Serializable)
        • java.awt.geom.Arc2D.Float (implements java.io.Serializable)
      • java.awt.geom.Ellipse2D
        • java.awt.geom.Ellipse2D.Double (implements java.io.Serializable)
        • java.awt.geom.Ellipse2D.Float (implements java.io.Serializable)
      • java.awt.geom.Rectangle2D
        • java.awt.geom.Rectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.Rectangle2D.Float (implements java.io.Serializable)
      • java.awt.geom.RoundRectangle2D
        • java.awt.geom.RoundRectangle2D.Double (implements java.io.Serializable)
        • java.awt.geom.RoundRectangle2D.Float (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.awt.geom.NoninvertibleTransformException
        • java.lang.RuntimeException
          • java.awt.geom.IllegalPathStateException

接口分层结构

  • java.awt.geom.PathIterator
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.geom 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.geom
的使用

使用 java.awt.geom 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 使用的 java.awt.geom 中的类
AffineTransform
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
Dimension2D
Dimension2D 类用于封装宽度和高度尺寸。
PathIterator
PathIterator 接口通过允许调用者一次一段地获取边界的路径，为实现 Shape 接口的对象提供返回其边界几何形状的机制。
Point2D
Point2D 类定义表示 (x,y) 坐标空间中位置的点。
Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
RectangularShape
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。

java.awt.font 使用的 java.awt.geom 中的类
AffineTransform
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
Point2D
Point2D 类定义表示 (x,y) 坐标空间中位置的点。
Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。

java.awt.geom 使用的 java.awt.geom 中的类
AffineTransform
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
Arc2D
Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
Area
Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
CubicCurve2D
CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
Dimension2D
Dimension2D 类用于封装宽度和高度尺寸。
Ellipse2D
Ellipse2D 类描述窗体矩形定义的椭圆。
Line2D
Line2D 表示 (x,y) 坐标空间中的线段。
NoninvertibleTransformException
NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。
Path2D
Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
Path2D.Float
Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
PathIterator
PathIterator 接口通过允许调用者一次一段地获取边界的路径，为实现 Shape 接口的对象提供返回其边界几何形状的机制。
Point2D
Point2D 类定义表示 (x,y) 坐标空间中位置的点。
QuadCurve2D
QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
RectangularShape
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
RoundRectangle2D
RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。

java.awt.image 使用的 java.awt.geom 中的类
AffineTransform
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
Point2D
Point2D 类定义表示 (x,y) 坐标空间中位置的点。
Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。

java.awt.image.renderable 使用的 java.awt.geom 中的类
AffineTransform
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。

javax.swing.plaf 使用的 java.awt.geom 中的类
Dimension2D
Dimension2D 类用于封装宽度和高度尺寸。

javax.swing.plaf.basic 使用的 java.awt.geom 中的类
Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
RectangularShape
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。

javax.swing.text 使用的 java.awt.geom 中的类
Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
RectangularShape
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Arc2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Arc2D
的使用

使用 Arc2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Arc2D 的使用

java.awt.geom 中 Arc2D 的子类
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。

参数类型为 Arc2D 的 java.awt.geom 中的方法
 void Arc2D.setArc(Arc2D a)
将此弧设置为与指定弧相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Arc2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Arc2D.Float
的使用

没有 java.awt.geom.Arc2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Arc2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Arc2D.Double
的使用

没有 java.awt.geom.Arc2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Area 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Area
的使用

使用 Area 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Area 的使用

返回 Area 的 java.awt.geom 中的方法
 Area Area.createTransformedArea(AffineTransform t)
创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。

参数类型为 Area 的 java.awt.geom 中的方法
void | Area.add(Area rhs) 将指定 Area 的形状添加到此 Area 的形状中。
boolean | Area.equals(Area other) 测试两个 Area 对象的几何形状是否相等。
void | Area.exclusiveOr(Area rhs) 将此 Area 的形状设置为其当前形状与指定 Area 形状的组合区域，并减去其交集。
void | Area.intersect(Area rhs) 将此 Area 的形状设置为其当前形状与指定 Area 形状的交集。
void | Area.subtract(Area rhs) 从此 Area 的形状中减去指定 Area 的形状。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.CubicCurve2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.CubicCurve2D
的使用

使用 CubicCurve2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 CubicCurve2D 的使用

java.awt.geom 中 CubicCurve2D 的子类
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。

参数类型为 CubicCurve2D 的 java.awt.geom 中的方法
void | CubicCurve2D.setCurve(CubicCurve2D c) 将此曲线端点和控制点的位置设置为与指定的 CubicCurve2D 相同。
void | CubicCurve2D.subdivide(CubicCurve2D left, CubicCurve2D right) 细分此三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
static void | CubicCurve2D.subdivide(CubicCurve2D src, CubicCurve2D left, CubicCurve2D right) 细分由 src 参数指定的三次曲线，并将得到的两个细分曲线存储到 left 和 right 曲线参数中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.CubicCurve2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.CubicCurve2D.Float
的使用

没有 java.awt.geom.CubicCurve2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.CubicCurve2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.CubicCurve2D.Double
的使用

没有 java.awt.geom.CubicCurve2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Ellipse2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Ellipse2D
的使用

使用 Ellipse2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Ellipse2D 的使用

java.awt.geom 中 Ellipse2D 的子类
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Ellipse2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Ellipse2D.Float
的使用

没有 java.awt.geom.Ellipse2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Ellipse2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Ellipse2D.Double
的使用

没有 java.awt.geom.Ellipse2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.FlatteningPathIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.FlatteningPathIterator
的使用

没有 java.awt.geom.FlatteningPathIterator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.IllegalPathStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.IllegalPathStateException
的使用

没有 java.awt.geom.IllegalPathStateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Line2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Line2D
的使用

使用 Line2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Line2D 的使用

java.awt.geom 中 Line2D 的子类
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。

参数类型为 Line2D 的 java.awt.geom 中的方法
boolean | Line2D.intersectsLine(Line2D l) 测试指定的线段是否与此线段相交。
boolean | Rectangle2D.intersectsLine(Line2D l) 测试指定的线段是否与此 Rectangle2D 的内部相交。
void | Line2D.setLine(Line2D l) 将此 Line2D 端点的位置设置为与指定 Line2D 的这些端点相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Line2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Line2D.Float
的使用

没有 java.awt.geom.Line2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Line2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Line2D.Double
的使用

没有 java.awt.geom.Line2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.NoninvertibleTransformException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.NoninvertibleTransformException
的使用

使用 NoninvertibleTransformException 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 NoninvertibleTransformException 的使用

抛出 NoninvertibleTransformException 的 java.awt.geom 中的方法
AffineTransform | AffineTransform.createInverse() 返回表示逆向变换的 AffineTransform 对象。
void | AffineTransform.inverseTransform(double[] srcPts, int srcOff, double[] dstPts, int dstOff, int numPts) 通过此变换来逆向变换双精度坐标数组。
Point2D | AffineTransform.inverseTransform(Point2D ptSrc, Point2D ptDst) 逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
void | AffineTransform.invert() 将此变换设置为它自身的逆变换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Path2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Path2D
的使用

使用 Path2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Path2D 的使用

java.awt.geom 中 Path2D 的子类
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Path2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Path2D.Float
的使用

使用 Path2D.Float 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 Path2D.Float 的使用

java.awt.geom 中 Path2D.Float 的子类
 class GeneralPath
GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Path2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Path2D.Double
的使用

没有 java.awt.geom.Path2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.geom.PathIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.geom.PathIterator
的使用

使用 PathIterator 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt 中 PathIterator 的使用

返回 PathIterator 的 java.awt 中的方法
PathIterator | Polygon.getPathIterator(AffineTransform at) 返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Polygon.getPathIterator(AffineTransform at, double flatness) 返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。

java.awt.geom 中 PathIterator 的使用

实现 PathIterator 的 java.awt.geom 中的类
 class FlatteningPathIterator
FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。

返回 PathIterator 的 java.awt.geom 中的方法
PathIterator | Arc2D.getPathIterator(AffineTransform at) 返回定义弧边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at) 为此 Area 对象的轮廓创建一个 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at) 返回定义形状边界的迭代对象。
PathIterator | Ellipse2D.getPathIterator(AffineTransform at) 返回定义此 Ellipse2D 边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at) 返回定义此 Line2D 边界的迭代对象。
PathIterator | Path2D.Float.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Path2D.Double.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at) 返回定义此 QuadCurve2D 的形状边界的迭代对象。
PathIterator | RoundRectangle2D.getPathIterator(AffineTransform at) 返回定义此 RoundRectangle2D 边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at) 返回定义此 Rectangle2D 边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at, double flatness) 为此 Area 对象的变平轮廓创建 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平形状边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at, double flatness) 返回定义此变平的 Line2D 边界的迭代对象。
PathIterator | Path2D.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义此 QuadCurve2D 的变平形状边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平的 Rectangle2D 边界的迭代对象。
PathIterator | RectangularShape.getPathIterator(AffineTransform at, double flatness) 返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。

参数类型为 PathIterator 的 java.awt.geom 中的方法
abstract void | Path2D.append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
void | Path2D.Float.append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
void | Path2D.Double.append(PathIterator pi, boolean connect) 将指定 PathIterator 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
static boolean | Path2D.contains(PathIterator pi, double x, double y) 测试指定的坐标是否在指定 PathIterator 的封闭边界内。
static boolean | Path2D.contains(PathIterator pi, double x, double y, double w, double h) 测试指定矩形区域是否完全在指定 PathIterator 的封闭边界内。
static boolean | Path2D.contains(PathIterator pi, Point2D p) 测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。
static boolean | Path2D.contains(PathIterator pi, Rectangle2D r) 测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。
static boolean | Path2D.intersects(PathIterator pi, double x, double y, double w, double h) 测试指定 PathIterator 的内部是否与指定直角坐标集的内部相交。
static boolean | Path2D.intersects(PathIterator pi, Rectangle2D r) 测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。

参数类型为 PathIterator 的 java.awt.geom 中的构造方法
FlatteningPathIterator(PathIterator src, double flatness)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。
FlatteningPathIterator(PathIterator src, double flatness, int limit)
构造一个在路径上迭代时能使路径变平的新 FlatteningPathIterator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.QuadCurve2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.QuadCurve2D
的使用

使用 QuadCurve2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 QuadCurve2D 的使用

java.awt.geom 中 QuadCurve2D 的子类
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。

参数类型为 QuadCurve2D 的 java.awt.geom 中的方法
void | QuadCurve2D.setCurve(QuadCurve2D c) 将此 QuadCurve2D 端点和控制点的位置设置为与指定的 QuadCurve2D 相同。
void | QuadCurve2D.subdivide(QuadCurve2D left, QuadCurve2D right) 细分此 QuadCurve2D 并将得到的两个细分曲线存储到 left 和 right 曲线参数中。
static void | QuadCurve2D.subdivide(QuadCurve2D src, QuadCurve2D left, QuadCurve2D right) 细分由 src 参数指定的二次曲线并将得到的两个细分曲线存储到 left 和 right 曲线参数中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.QuadCurve2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.QuadCurve2D.Float
的使用

没有 java.awt.geom.QuadCurve2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.QuadCurve2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.QuadCurve2D.Double
的使用

没有 java.awt.geom.QuadCurve2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.RoundRectangle2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RoundRectangle2D
的使用

使用 RoundRectangle2D 的软件包
java.awt.geom 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.geom 中 RoundRectangle2D 的使用

java.awt.geom 中 RoundRectangle2D 的子类
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

参数类型为 RoundRectangle2D 的 java.awt.geom 中的方法
void | RoundRectangle2D.setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
void | RoundRectangle2D.Float.setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。
void | RoundRectangle2D.Double.setRoundRect(RoundRectangle2D rr) 将此 RoundRectangle2D 设置为与指定的 RoundRectangle2D 相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.RoundRectangle2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RoundRectangle2D.Float
的使用

没有 java.awt.geom.RoundRectangle2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.RoundRectangle2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RoundRectangle2D.Double
的使用

没有 java.awt.geom.RoundRectangle2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.GeneralPath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.GeneralPath
的使用

没有 java.awt.geom.GeneralPath 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Rectangle2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Rectangle2D
的使用

使用 Rectangle2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Rectangle2D 的使用

java.awt 中 Rectangle2D 的子类
 class Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

返回 Rectangle2D 的 java.awt 中的方法
Rectangle2D | Rectangle.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | TexturePaint.getAnchorRect() 返回定位纹理图像并设置其大小的固定矩形的副本。
Rectangle2D | Polygon.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Shape.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Font.getMaxCharBounds(FontRenderContext frc) 返回最大边界定义在 FontRenderContext 中的字符的边界。
Rectangle2D | FontMetrics.getMaxCharBounds(Graphics context) 返回指定 Graphics 上下文中具有最大边界的字符的边界。
Rectangle2D | Font.getStringBounds(char[] chars, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 指定字符数组的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的边界。
Rectangle2D | Font.getStringBounds(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。
Rectangle2D | Font.getStringBounds(String str, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。
Rectangle2D | Font.getStringBounds(String str, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中指定 String 的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。

参数类型为 Rectangle2D 的 java.awt 中的方法
boolean | Polygon.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | Shape.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
Rectangle2D | Rectangle.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
boolean | Polygon.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | Shape.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。

参数类型为 Rectangle2D 的 java.awt 中的构造方法
RadialGradientPaint(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
TexturePaint(BufferedImage txtr, Rectangle2D anchor)
构造 TexturePaint 对象。

java.awt.font 中 Rectangle2D 的使用

返回 Rectangle2D 的 java.awt.font 中的方法
Rectangle2D | GraphicAttribute.getBounds() 返回包括所有位的 Rectangle2D，这些位由与呈现位置相关的 GraphicAttribute 绘制。
Rectangle2D | ImageGraphicAttribute.getBounds() 返回一个 Rectangle2D，它封装此 ImageGraphicAttribute 相对于呈现位置呈现的所有位。
Rectangle2D | ShapeGraphicAttribute.getBounds() 返回一个 Rectangle2D，它封装此 ShapeGraphicAttribute 相对于呈现位置绘制的所有位。
Rectangle2D | TextLayout.getBounds() 返回此 TextLayout 的边界。
Rectangle2D | GlyphMetrics.getBounds2D() 返回该字形的边界。
abstract Rectangle2D | GlyphVector.getLogicalBounds() 返回此 GlyphVector 的逻辑边界。
abstract Rectangle2D | GlyphVector.getVisualBounds() 返回此 GlyphVector 的可视边界，可视边界是此 GlyphVector 轮廓的边界框。

参数类型为 Rectangle2D 的 java.awt.font 中的方法
float[] | TextLayout.getCaretInfo(TextHitInfo hit, Rectangle2D bounds) 返回与对应于 hit 的插入符有关的信息。
Shape | TextLayout.getCaretShape(TextHitInfo hit, Rectangle2D bounds) 返回表示指定边界内指定目标字符处插入符的 Shape。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy) 返回对应于强插入符和弱插入符的两条路径。
Shape | TextLayout.getLogicalHighlightShape(int firstEndpoint, int secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。
TextHitInfo | TextLayout.hitTestChar(float x, float y, Rectangle2D bounds) 返回对应于指定点的 TextHitInfo。

参数类型为 Rectangle2D 的 java.awt.font 中的构造方法
GlyphMetrics(boolean horizontal, float advanceX, float advanceY, Rectangle2D bounds, byte glyphType)
构造一个 GlyphMetrics 对象。
GlyphMetrics(float advance, Rectangle2D bounds, byte glyphType)
构造一个 GlyphMetrics 对象。

java.awt.geom 中 Rectangle2D 的使用

java.awt.geom 中 Rectangle2D 的子类
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。

返回 Rectangle2D 的 java.awt.geom 中的方法
abstract Rectangle2D | Rectangle2D.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Float.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Double.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
abstract Rectangle2D | Rectangle2D.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Float.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Double.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Arc2D.getBounds2D() 返回弧的高精度窗体矩形。
Rectangle2D | Area.getBounds2D() 返回完全包围此 Area 的高精度边界 Rectangle2D。
Rectangle2D | CubicCurve2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | CubicCurve2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Ellipse2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Ellipse2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Line2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Line2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Path2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Path2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | QuadCurve2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | QuadCurve2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | RoundRectangle2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | RoundRectangle2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle2D.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle2D.Float.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | Rectangle2D.Double.getBounds2D() 返回一个高精度的、比 getBounds 方法更准确的 Shape 边界框。
Rectangle2D | RectangularShape.getFrame() 返回定义此对象的总体形状的窗体 Rectangle2D。
protected abstract Rectangle2D | Arc2D.makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
protected Rectangle2D | Arc2D.Float.makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。
protected Rectangle2D | Arc2D.Double.makeBounds(double x, double y, double w, double h) 构造一个适当精度的 Rectangle2D，以保存为此弧的窗体矩形计算出的参数。

参数类型为 Rectangle2D 的 java.awt.geom 中的方法
void | Rectangle2D.add(Rectangle2D r) 将 Rectangle2D 对象添加到此 Rectangle2D 中。
static boolean | Path2D.contains(PathIterator pi, Rectangle2D r) 测试指定的 Rectangle2D 是否完全在指定 PathIterator 的封闭区域内。
boolean | Arc2D.contains(Rectangle2D r) 确定弧的内部是否完全包含指定的矩形。
boolean | Area.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | CubicCurve2D.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | Line2D.contains(Rectangle2D r) 测试此 Line2D 内部是否完全包含指定的 Rectangle2D。
boolean | Path2D.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | QuadCurve2D.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
boolean | RectangularShape.contains(Rectangle2D r) 测试 Shape 内部是否完全包含指定的 Rectangle2D。
abstract Rectangle2D | Rectangle2D.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Float.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
Rectangle2D | Rectangle2D.Double.createIntersection(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的交集。
abstract Rectangle2D | Rectangle2D.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Float.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
Rectangle2D | Rectangle2D.Double.createUnion(Rectangle2D r) 返回一个新的 Rectangle2D 对象，它表示此 Rectangle2D 与指定 Rectangle2D 的并集。
static void | Rectangle2D.intersect(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest) 将指定的一对源 Rectangle2D 对象相交，并将结果置于指定的目标 Rectangle2D 对象中。
static boolean | Path2D.intersects(PathIterator pi, Rectangle2D r) 测试指定 PathIterator 的内部是否与指定 Rectangle2D 的内部相交。
boolean | Area.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | CubicCurve2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | Line2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | Path2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | QuadCurve2D.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
boolean | RectangularShape.intersects(Rectangle2D r) 测试 Shape 内部是否与指定 Rectangle2D 内部相交。
void | Arc2D.setArc(Rectangle2D rect, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | RectangularShape.setFrame(Rectangle2D r) 将此 Shape 窗体矩形设置为指定的 Rectangle2D。
void | Rectangle2D.setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
void | Rectangle2D.Float.setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
void | Rectangle2D.Double.setRect(Rectangle2D r) 将此 Rectangle2D 设置为与指定的 Rectangle2D 相同。
static void | Rectangle2D.union(Rectangle2D src1, Rectangle2D src2, Rectangle2D dest) 将一对源 Rectangle2D 对象合并，并将结果置于指定的目标 Rectangle2D 对象中。

参数类型为 Rectangle2D 的 java.awt.geom 中的构造方法
Arc2D.Double(Rectangle2D ellipseBounds, double start, double extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。
Arc2D.Float(Rectangle2D ellipseBounds, float start, float extent, int type)
构造一个新弧，并将其初始化为指定的位置、大小、角跨越和闭合类型。

java.awt.image 中 Rectangle2D 的使用

返回 Rectangle2D 的 java.awt.image 中的方法
Rectangle2D | AffineTransformOp.getBounds2D(BufferedImage src) 返回转换后的目标图像的边界框。
Rectangle2D | BufferedImageOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(BufferedImage src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | LookupOp.getBounds2D(BufferedImage src) 返回过滤后的目标图像的边界框。
Rectangle2D | RescaleOp.getBounds2D(BufferedImage src) 返回重缩放后的目标图像的边界框。
Rectangle2D | AffineTransformOp.getBounds2D(Raster src) 返回转换后的目标图像的边界框。
Rectangle2D | BandCombineOp.getBounds2D(Raster src) 返回变换后目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(Raster src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(Raster src) 返回已过滤目标 Raster 的边界框。
Rectangle2D | LookupOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RasterOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RescaleOp.getBounds2D(Raster src) 返回重缩放后的目标 Raster 的边界框。

java.awt.image.renderable 中 Rectangle2D 的使用

返回 Rectangle2D 的 java.awt.image.renderable 中的方法
 Rectangle2D ContextualRenderedImageFactory.getBounds2D(ParameterBlock paramBlock)
返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。

javax.swing.plaf.basic 中 Rectangle2D 的使用

javax.swing.plaf.basic 中 Rectangle2D 的子类
static class BasicTextUI.BasicCaret

javax.swing.text 中 Rectangle2D 的使用

javax.swing.text 中 Rectangle2D 的子类
 class DefaultCaret
插入符的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Rectangle2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Rectangle2D.Float
的使用

没有 java.awt.geom.Rectangle2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Rectangle2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Rectangle2D.Double
的使用

没有 java.awt.geom.Rectangle2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.RectangularShape 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.RectangularShape
的使用

使用 RectangularShape 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 RectangularShape 的使用

java.awt 中 RectangularShape 的子类
 class Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

java.awt.geom 中 RectangularShape 的使用

java.awt.geom 中 RectangularShape 的子类
class | Arc2D Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
class | Ellipse2D Ellipse2D 类描述窗体矩形定义的椭圆。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | Rectangle2D Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
class | RoundRectangle2D RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

javax.swing.plaf.basic 中 RectangularShape 的使用

javax.swing.plaf.basic 中 RectangularShape 的子类
static class BasicTextUI.BasicCaret

javax.swing.text 中 RectangularShape 的使用

javax.swing.text 中 RectangularShape 的子类
 class DefaultCaret
插入符的默认实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Point2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Point2D
的使用

使用 Point2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 Point2D 的使用

java.awt 中 Point2D 的子类
 class Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。

返回 Point2D 的 java.awt 中的方法
Point2D | RadialGradientPaint.getCenterPoint() 返回辐射状渐变中心点的副本。
Point2D | LinearGradientPaint.getEndPoint() 返回渐变轴结束点的副本。
Point2D | RadialGradientPaint.getFocusPoint() 返回渐变轴结束点的副本。
Point2D | GradientPaint.getPoint1() 返回着第一种颜色的点 P1 的副本。
Point2D | GradientPaint.getPoint2() 返回着第二种颜色的点 P2 的副本。
Point2D | LinearGradientPaint.getStartPoint() 返回渐变轴起始点的副本。

参数类型为 Point2D 的 java.awt 中的方法
boolean | Polygon.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | Shape.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。

参数类型为 Point2D 的 java.awt 中的构造方法
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。

java.awt.font 中 Point2D 的使用

返回 Point2D 的 java.awt.font 中的方法
abstract  Point2D GlyphVector.getGlyphPosition(int glyphIndex)
返回与此 GlyphVector 原点对应的指定字形的位置。

参数类型为 Point2D 的 java.awt.font 中的方法
void | TextLayout.hitToPoint(TextHitInfo hit, Point2D point) 将一个命中点转换为标准坐标中的一个点。
abstract void | LayoutPath.pathToPoint(Point2D location, boolean preceding, Point2D point) 将相对于路径的位置转换为用户坐标中的点。
abstract boolean | LayoutPath.pointToPath(Point2D point, Point2D location) 将用户空间中的点转换为相对于路径的位置。
abstract void | GlyphVector.setGlyphPosition(int glyphIndex, Point2D newPos) 设置此 GlyphVector 中的指定字形位置。

java.awt.geom 中 Point2D 的使用

java.awt.geom 中 Point2D 的子类
static class | Point2D.Double Double 类以 double 精度定义指定的点。
static class | Point2D.Float Float 类以 float 精度定义指定的点。

返回 Point2D 的 java.awt.geom 中的方法
Point2D | AffineTransform.deltaTransform(Point2D ptSrc, Point2D ptDst) 变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。
abstract Point2D | CubicCurve2D.getCtrlP1() 返回第一个控制点。
Point2D | CubicCurve2D.Float.getCtrlP1() 返回第一个控制点。
Point2D | CubicCurve2D.Double.getCtrlP1() 返回第一个控制点。
abstract Point2D | CubicCurve2D.getCtrlP2() 返回第二个控制点。
Point2D | CubicCurve2D.Float.getCtrlP2() 返回第二个控制点。
Point2D | CubicCurve2D.Double.getCtrlP2() 返回第二个控制点。
abstract Point2D | QuadCurve2D.getCtrlPt() 返回控制点。
Point2D | QuadCurve2D.Float.getCtrlPt() 返回控制点。
Point2D | QuadCurve2D.Double.getCtrlPt() 返回控制点。
Point2D | Path2D.getCurrentPoint() 返回最近添加到路径尾部的坐标（以 Point2D 对象形式）。
Point2D | Arc2D.getEndPoint() 返回弧的结束点。
abstract Point2D | CubicCurve2D.getP1() 返回起始点。
Point2D | CubicCurve2D.Float.getP1() 返回起始点。
Point2D | CubicCurve2D.Double.getP1() 返回起始点。
abstract Point2D | Line2D.getP1() 返回此 Line2D 的起始 Point2D。
Point2D | Line2D.Float.getP1() 返回此 Line2D 的起始 Point2D。
Point2D | Line2D.Double.getP1() 返回此 Line2D 的起始 Point2D。
abstract Point2D | QuadCurve2D.getP1() 返回起始点。
Point2D | QuadCurve2D.Float.getP1() 返回起始点。
Point2D | QuadCurve2D.Double.getP1() 返回起始点。
abstract Point2D | CubicCurve2D.getP2() 返回结束点。
Point2D | CubicCurve2D.Float.getP2() 返回结束点。
Point2D | CubicCurve2D.Double.getP2() 返回结束点。
abstract Point2D | Line2D.getP2() 返回此 Line2D 的结束 Point2D。
Point2D | Line2D.Float.getP2() 返回此 Line2D 的结束 Point2D。
Point2D | Line2D.Double.getP2() 返回此 Line2D 的结束 Point2D。
abstract Point2D | QuadCurve2D.getP2() 返回结束点。
Point2D | QuadCurve2D.Float.getP2() 返回结束点。
Point2D | QuadCurve2D.Double.getP2() 返回结束点。
Point2D | Arc2D.getStartPoint() 返回弧的起始点。
Point2D | AffineTransform.inverseTransform(Point2D ptSrc, Point2D ptDst) 逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
Point2D | AffineTransform.transform(Point2D ptSrc, Point2D ptDst) 变换指定的 ptSrc 并将结果存储在 ptDst 中。

参数类型为 Point2D 的 java.awt.geom 中的方法
void | Rectangle2D.add(Point2D pt) 将 Point2D 对象 pt 添加到此 Rectangle2D 中。
static boolean | Path2D.contains(PathIterator pi, Point2D p) 测试指定的 Point2D 是否在指定 PathIterator 的封闭边界内。
boolean | Area.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | CubicCurve2D.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | Line2D.contains(Point2D p) 测试给定 Point2D 是否在此 Line2D 的边界内。
boolean | Path2D.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | QuadCurve2D.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
boolean | RectangularShape.contains(Point2D p) 测试指定的 Point2D 是否在 Shape 的边界内。
Point2D | AffineTransform.deltaTransform(Point2D ptSrc, Point2D ptDst) 变换由 ptSrc 指定的相对距离向量，并将结果存储在 ptDst 中。
double | Point2D.distance(Point2D pt) 返回从此 Point2D 到指定 Point2D 的距离。
double | Point2D.distanceSq(Point2D pt) 返回从此 Point2D 到指定 Point2D 的距离的平方。
Point2D | AffineTransform.inverseTransform(Point2D ptSrc, Point2D ptDst) 逆向变换指定的 ptSrc 并将结果存储在 ptDst 中。
int | Rectangle2D.outcode(Point2D p) 确定指定 Point2D 相对于此 Rectangle2D 的位置。
double | Line2D.ptLineDist(Point2D pt) 返回从 Point2D 到此线的距离。
double | Line2D.ptLineDistSq(Point2D pt) 返回从指定 Point2D 到此线的距离的平方。
double | Line2D.ptSegDist(Point2D pt) 返回从 Point2D 到此线段的距离的平方。
double | Line2D.ptSegDistSq(Point2D pt) 返回从 Point2D 到此线段的距离的平方。
int | Line2D.relativeCCW(Point2D p) 返回一个指示符，指示指定 Point2D 相对于此线段的位置。
void | Arc2D.setAngles(Point2D p1, Point2D p2) 使用两个点设置此弧的起始角度和角跨越。
void | Arc2D.setAngleStart(Point2D p) 将此弧的起始角度设置为由指定点定义、相对于此弧中心的角度。
void | Arc2D.setArc(Point2D loc, Dimension2D size, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | Arc2D.setArcByTangent(Point2D p1, Point2D p2, Point2D p3, double radius) 将此弧的位置、边界和角跨越设置为指定值。
void | CubicCurve2D.setCurve(Point2D[] pts, int offset) 将此曲线端点和控制点的位置设置为指定数组中指定偏移量的 Point2D 对象的坐标。
void | QuadCurve2D.setCurve(Point2D[] pts, int offset) 将此 QuadCurve2D 端点和控制点的位置设置为指定数组中指定偏移量处 Point2D 对象的坐标。
void | QuadCurve2D.setCurve(Point2D p1, Point2D cp, Point2D p2) 将此 QuadCurve2D 端点和控制点的位置设置为指定的 Point2D 坐标。
void | CubicCurve2D.setCurve(Point2D p1, Point2D cp1, Point2D cp2, Point2D p2) 将此曲线端点和控制点的位置设置为指定的 Point2D 坐标。
void | RectangularShape.setFrame(Point2D loc, Dimension2D size) 将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。
void | RectangularShape.setFrameFromCenter(Point2D center, Point2D corner) 基于指定的中心 Point2D 和角 Point2D 设置此 Shape 的窗体矩形。
void | RectangularShape.setFrameFromDiagonal(Point2D p1, Point2D p2) 基于两个指定的 Point2D 对象设置此 Shape 窗体矩形的对角线。
void | Line2D.setLine(Point2D p1, Point2D p2) 将此 Line2D 端点的位置设置为指定的 Point2D 坐标。
void | Point2D.setLocation(Point2D p) 将此 Point2D 的位置设为指定 Point2D 对象的坐标。
void | AffineTransform.transform(Point2D[] ptSrc, int srcOff, Point2D[] ptDst, int dstOff, int numPts) 通过此变换来变换点对象数组。
void | AffineTransform.transform(Point2D[] ptSrc, int srcOff, Point2D[] ptDst, int dstOff, int numPts) 通过此变换来变换点对象数组。
Point2D | AffineTransform.transform(Point2D ptSrc, Point2D ptDst) 变换指定的 ptSrc 并将结果存储在 ptDst 中。

参数类型为 Point2D 的 java.awt.geom 中的构造方法
Line2D.Double(Point2D p1, Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。
Line2D.Float(Point2D p1, Point2D p2)
根据指定的 Point2D 对象构造并初始化 Line2D。

java.awt.image 中 Point2D 的使用

返回 Point2D 的 java.awt.image 中的方法
Point2D | AffineTransformOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | BandCombineOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源 Raster 中给定点对应的目标点的位置。
Point2D | BufferedImageOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | ColorConvertOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点的位置。
Point2D | ConvolveOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点位置。
Point2D | LookupOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源图像中某个点的情况下，返回目标点的位置。
Point2D | RasterOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源 Raster 中一个点的情况下，返回目标点的位置。
Point2D | RescaleOp.getPoint2D(Point2D srcPt, Point2D dstPt) 给定源中的一个点，返回对应目标点的位置。

参数类型为 Point2D 的 java.awt.image 中的方法
Point2D | AffineTransformOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | BandCombineOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源 Raster 中给定点对应的目标点的位置。
Point2D | BufferedImageOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
Point2D | ColorConvertOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点的位置。
Point2D | ConvolveOp.getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点位置。
Point2D | LookupOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源图像中某个点的情况下，返回目标点的位置。
Point2D | RasterOp.getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源 Raster 中一个点的情况下，返回目标点的位置。
Point2D | RescaleOp.getPoint2D(Point2D srcPt, Point2D dstPt) 给定源中的一个点，返回对应目标点的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Point2D.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Point2D.Float
的使用

没有 java.awt.geom.Point2D.Float 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Point2D.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Point2D.Double
的使用

没有 java.awt.geom.Point2D.Double 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.AffineTransform 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.AffineTransform
的使用

使用 AffineTransform 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt 中的方法
abstract AffineTransform | GraphicsConfiguration.getDefaultTransform() 返回此 GraphicsConfiguration 的默认 AffineTransform。
abstract AffineTransform | GraphicsConfiguration.getNormalizingTransform() 返回可与 GraphicsConfiguration 的默认 AffineTransform 连接的 AffineTransform，从而用户空间的 72 单位等于设备空间的 1 英寸。
AffineTransform | MultipleGradientPaint.getTransform() 返回应用于渐变的变换的副本。
abstract AffineTransform | Graphics2D.getTransform() 返回 Graphics2D 上下文中当前 Transform 的副本。
AffineTransform | Font.getTransform() 返回与此 Font 相关的变换的副本。

参数类型为 AffineTransform 的 java.awt 中的方法
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
Font | Font.deriveFont(AffineTransform trans) 通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。
Font | Font.deriveFont(int style, AffineTransform trans) 通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。
abstract boolean | Graphics2D.drawImage(Image img, AffineTransform xform, ImageObserver obs) 呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
abstract void | Graphics2D.drawRenderableImage(RenderableImage img, AffineTransform xform) 呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。
abstract void | Graphics2D.drawRenderedImage(RenderedImage img, AffineTransform xform) 呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。
PathIterator | Polygon.getPathIterator(AffineTransform at) 返回迭代器对象，此对象沿此 Polygon 的边界进行迭代，并且提供对此 Polygon 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Polygon.getPathIterator(AffineTransform at, double flatness) 返回迭代器对象，此对象沿 Shape 的边界进行迭代，并且提供了对 Shape 轮廓的几何形状的访问。
PathIterator | Shape.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
abstract void | Graphics2D.setTransform(AffineTransform Tx) 重写 Graphics2D 上下文中的 Transform。
abstract void | Graphics2D.transform(AffineTransform Tx) 根据“最后指定首先应用”规则，使用此 Graphics2D 中的 Transform 组合 AffineTransform 对象。

参数类型为 AffineTransform 的 java.awt 中的构造方法
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。

java.awt.font 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.font 中的方法
abstract AffineTransform | GlyphVector.getGlyphTransform(int glyphIndex) 返回此 GlyphVector 中指定字形的转换。
AffineTransform | TransformAttribute.getTransform() 返回包装转换的一个副本。
AffineTransform | FontRenderContext.getTransform() 获取用于在此 FontRenderContext 中将印刷点缩放为像素的转换。

参数类型为 AffineTransform 的 java.awt.font 中的方法
Shape | GraphicAttribute.getOutline(AffineTransform tx) 返回表示此 GraphicAttribute 呈现区域的 Shape。
Shape | ShapeGraphicAttribute.getOutline(AffineTransform tx) 返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。
Shape | TextLayout.getOutline(AffineTransform tx) 返回表示此 TextLayout 的轮廓的 Shape。
abstract void | GlyphVector.setGlyphTransform(int glyphIndex, AffineTransform newTX) 设置此 GlyphVector 中指定字形的转换。

参数类型为 AffineTransform 的 java.awt.font 中的构造方法
FontRenderContext(AffineTransform tx, boolean isAntiAliased, boolean usesFractionalMetrics)
根据可选的 AffineTransform 和两个 boolean 值构造一个 FontRenderContext 对象，这两个 boolean 值确定新构造的对象是否具有 anti-aliasing 或 fractional metrics 属性。
FontRenderContext(AffineTransform tx, Object aaHint, Object fmHint)
根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。
TransformAttribute(AffineTransform transform)
包装指定的转换。

java.awt.geom 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.geom 中的方法
AffineTransform | AffineTransform.createInverse() 返回表示逆向变换的 AffineTransform 对象。
static AffineTransform | AffineTransform.getQuadrantRotateInstance(int numquadrants) 返回按指定象限数旋转坐标的变换。
static AffineTransform | AffineTransform.getQuadrantRotateInstance(int numquadrants, double anchorx, double anchory) 返回按指定象限数绕指定锚点旋转坐标的变换。
static AffineTransform | AffineTransform.getRotateInstance(double theta) 返回表示旋转变换的变换。
static AffineTransform | AffineTransform.getRotateInstance(double vecx, double vecy) 返回根据旋转向量旋转坐标的变换。
static AffineTransform | AffineTransform.getRotateInstance(double theta, double anchorx, double anchory) 返回绕锚点旋转坐标的变换。
static AffineTransform | AffineTransform.getRotateInstance(double vecx, double vecy, double anchorx, double anchory) 返回根据旋转向量绕锚点坐标旋转坐标的变换。
static AffineTransform | AffineTransform.getScaleInstance(double sx, double sy) 返回表示缩放变换的变换。
static AffineTransform | AffineTransform.getShearInstance(double shx, double shy) 返回表示错切变换的变换。
static AffineTransform | AffineTransform.getTranslateInstance(double tx, double ty) 返回表示平移变换的变换。

参数类型为 AffineTransform 的 java.awt.geom 中的方法
void | AffineTransform.concatenate(AffineTransform Tx) 以最常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，以提供由 Tx 映射到以前用户空间的新用户空间。
Area | Area.createTransformedArea(AffineTransform t) 创建一个新 Area 对象，使它与由指定 AffineTransform 变换的 Area 包含相同的几何形状。
Shape | Path2D.createTransformedShape(AffineTransform at) 返回一个表示此 Path2D 变换形式的新 Shape。
PathIterator | Arc2D.getPathIterator(AffineTransform at) 返回定义弧边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at) 为此 Area 对象的轮廓创建一个 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at) 返回定义形状边界的迭代对象。
PathIterator | Ellipse2D.getPathIterator(AffineTransform at) 返回定义此 Ellipse2D 边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at) 返回定义此 Line2D 边界的迭代对象。
PathIterator | Path2D.Float.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | Path2D.Double.getPathIterator(AffineTransform at) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at) 返回定义此 QuadCurve2D 的形状边界的迭代对象。
PathIterator | RoundRectangle2D.getPathIterator(AffineTransform at) 返回定义此 RoundRectangle2D 边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at) 返回定义此 Rectangle2D 边界的迭代对象。
PathIterator | Area.getPathIterator(AffineTransform at, double flatness) 为此 Area 对象的变平轮廓创建 PathIterator。
PathIterator | CubicCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平形状边界的迭代对象。
PathIterator | Line2D.getPathIterator(AffineTransform at, double flatness) 返回定义此变平的 Line2D 边界的迭代对象。
PathIterator | Path2D.getPathIterator(AffineTransform at, double flatness) 返回一个沿着 Shape 边界迭代并提供对 Shape 轮廓几何形状的平面视图访问的迭代器对象。
PathIterator | QuadCurve2D.getPathIterator(AffineTransform at, double flatness) 返回定义此 QuadCurve2D 的变平形状边界的迭代对象。
PathIterator | Rectangle2D.getPathIterator(AffineTransform at, double flatness) 返回定义变平的 Rectangle2D 边界的迭代对象。
PathIterator | RectangularShape.getPathIterator(AffineTransform at, double flatness) 返回一个迭代器对象，它可沿 Shape 对象的边界进行迭代，并提供对 Shape 对象轮廓几何形状平面视图的访问。
void | AffineTransform.preConcatenate(AffineTransform Tx) 以不常用的方式将 AffineTransform Tx 连接到此 AffineTransform Cx，从而 Tx 相对于绝对像素空间（而非相对于现有用户空间）修改坐标变换。
void | AffineTransform.setTransform(AffineTransform Tx) 将此变换设置为指定 AffineTransform 对象中变换的副本。
void | Area.transform(AffineTransform t) 使用指定的 AffineTransform 变换此 Area 的几何形状。
abstract void | Path2D.transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。
void | Path2D.Float.transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。
void | Path2D.Double.transform(AffineTransform at) 使用指定的 AffineTransform 变换此路径的几何形状。

参数类型为 AffineTransform 的 java.awt.geom 中的构造方法
AffineTransform(AffineTransform Tx)
构造一个新 AffineTransform，让它作为指定 AffineTransform 对象的副本。
Path2D.Double(Shape s, AffineTransform at)
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Float(Shape s, AffineTransform at)
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。

java.awt.image 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.image 中的方法
 AffineTransform AffineTransformOp.getTransform()
返回此转换操作使用的仿射转换。

参数类型为 AffineTransform 的 java.awt.image 中的构造方法
AffineTransformOp(AffineTransform xform, int interpolationType)
根据仿射转换和插值类型构造一个 AffineTransformOp。
AffineTransformOp(AffineTransform xform, RenderingHints hints)
根据仿射转换构造 AffineTransformOp。

java.awt.image.renderable 中 AffineTransform 的使用

返回 AffineTransform 的 java.awt.image.renderable 中的方法
 AffineTransform RenderContext.getTransform()
获取当前“用户到设备”的 AffineTransform。

参数类型为 AffineTransform 的 java.awt.image.renderable 中的方法
void | RenderContext.concatenateTransform(AffineTransform modTransform) 通过追加另一变换修改当前的“用户到设备”变换。
void | RenderContext.concetenateTransform(AffineTransform modTransform) 已过时。 由 concatenateTransform(AffineTransform) 所替代。
void | RenderContext.preConcatenateTransform(AffineTransform modTransform) 通过预先挂起另一变换修改当前的“用户到设备”变换。
void | RenderContext.preConcetenateTransform(AffineTransform modTransform) 已过时。 由 preConcatenateTransform(AffineTransform) 所取代。
void | RenderContext.setTransform(AffineTransform newTransform) 将 RenderContext 中包含的当前“用户到设备”的 AffineTransform 设置为给定的变换。

参数类型为 AffineTransform 的 java.awt.image.renderable 中的构造方法
RenderContext(AffineTransform usr2dev)
构造具有给定变换的 RenderContext。
RenderContext(AffineTransform usr2dev, RenderingHints hints)
构造具有给定转换和呈现提示的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi)
构造具有给定变换和感兴趣区域的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
构造具有给定转换的 RenderContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.geom.Dimension2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.geom.Dimension2D
的使用

使用 Dimension2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

java.awt 中 Dimension2D 的使用

java.awt 中 Dimension2D 的子类
 class Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。

java.awt.geom 中 Dimension2D 的使用

参数类型为 Dimension2D 的 java.awt.geom 中的方法
void | Arc2D.setArc(Point2D loc, Dimension2D size, double angSt, double angExt, int closure) 将此弧的位置、大小、角跨越和闭合类型设置为指定值。
void | RectangularShape.setFrame(Point2D loc, Dimension2D size) 将此 Shape 窗体矩形的位置和大小分别设置为指定的 Point2D 和 Dimension2D。
void | Dimension2D.setSize(Dimension2D d) 将 Dimension2D 对象的大小设置为指定大小。

javax.swing.plaf 中 Dimension2D 的使用

javax.swing.plaf 中 Dimension2D 的子类
 class DimensionUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


InputContext (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.im
类 InputContext

java.lang.Object
    继承者  java.awt.im.InputContext

public class InputContext
extends Object

提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。两种方法可以处理输入方法和键盘布局：selectInputMethod 让客户端组件根据语言环境选择输入方法或键盘布局；getLocale 让客户端组件获得当前输入方法或键盘布局的语言环境。其他方法更明确地支持与输入方法之间的交互：它们让客户端组件控制输入方法的行为，并将客户端组件中的事件指派到该输入方法。

在默认情况下，每个 Window 实例创建一个 InputContext 实例，并且窗口的容器层次结构内部所有组件都共享此输入上下文。不过，这意味着在一个窗口中每一次只能进行一项文本输入操作，并且该文本需要在将焦点从一个文本组件中移到另一文本组件时提交。如果不需要此项操作，则文本组件可以创建自己的输入上下文实例。

Java 平台支持使用 java.awt.im.spi 包中的接口在 Java 编程语言中开发而且作为扩展安装在 Java SE 运行时环境中的输入方法。实现还可以支持使用其运行平台上的本机输入方法；不过，不是所有平台和语言环境都提供输入方法。键盘布局由主机平台提供。

如果 (a) 没有安装使用 Java 编程语言编写的输入方法和 (b) Java 平台实现或基础平台不支持本机输入方法，则输入方法不可用。在这种情况下，仍要创建和使用输入上下文；其行为可以根据下面的具体方法指定。

从以下版本开始：
1.2
另请参见：
Component.getInputContext(), Component.enableInputMethods(boolean)

构造方法摘要
protected InputContext()
构造一个 InputContext。
方法摘要
void | dispatchEvent(AWTEvent event) 将事件指派到处于活动状态的输入方法。
void | dispose() 释放由此输入上下文使用过的资源。
void | endComposition() 结束当前可能在此上下文进行的任何输入撰写。
Object | getInputMethodControlObject() 返回当前输入方法中的一个控制对象，或 null。
static InputContext | getInstance() 返回新 InputContext 实例。
Locale | getLocale() 返回当前输入方法或键盘布局的当前语言环境。
boolean | isCompositionEnabled() 确定是否已启用当前输入方法以进行撰写。
void | reconvert() 让当前输入方法从当前客户端组件中恢复文本。
void | removeNotify(Component client) 通知输入上下文，客户端组件已从它的包含层次结构中移除，或该组件已禁用输入方法支持。
boolean | selectInputMethod(Locale locale) 试图选择一个支持给定语言环境的输入方法或键盘布局，并返回指示是否成功选定此类输入方法或键盘布局的值。
void | setCharacterSubsets(Character.Subset[] subsets) 设置此输入上下文的输入方法应允许输入的 Unicode 字符集的子集。
void | setCompositionEnabled(boolean enable) 根据参数 enable 的值启用或禁用当前输入方法进行撰写。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputContext

protected InputContext()
构造一个 InputContext。此方法受到保护，所以客户端不能直接实例化 InputContext。输入上下文通过调用 getInstance() 获得。

方法详细信息

getInstance

public static InputContext getInstance()
返回新 InputContext 实例。

selectInputMethod

public boolean selectInputMethod(Locale locale)
试图选择一个支持给定语言环境的输入方法或键盘布局，并返回指示是否成功选定此类输入方法或键盘布局的值。按以下步骤操作，直到选定了输入方法:

  • 如果当前已选定的输入方法或键盘布局支持所请求的语言环境，则保留已有选定。
  • 如果没有支持所请求的语言环境的可用输入方法或键盘布局，则仍保留选定当前输入方法或键盘布局。
  • 如果用户以前已从用户界面选择了所请求语言环境的输入方法或键盘布局，则重新选择最近选择的此类输入方法或键盘布局。
  • 否则，要依赖于实现选定支持所请求语言环境的输入方法或键盘布局。

切换输入方法之前，提交当前任何未提交的文本。如果没有支持所请求语言环境的输入方法或键盘布局，则返回 false。

不是所有主机操作系统都提供 API 来确定当前已选定的本机输入方法或键盘布局的语言环境，和选择语言环境的本机输入方法或键盘布局。对于未提供此类 API 的主机操作系统而言，selectInputMethod 假定该主机操作系统提供的本机输入方法或键盘布局只支持该系统默认的语言环境。

例如，当用户更改插入点时，文本编辑组件可能调用此方法，让用户立即使用周围文本的语言继续键入。

参数：
locale - 所需的新语言环境。
返回：
true 如果此调用后处于活动状态的输入方法或键盘布局支持所需语言环境。
抛出：
NullPointerException - 如果 locale 为 null

getLocale

public Locale getLocale()
返回当前输入方法或键盘布局的当前语言环境。如果输入上下文没有当前输入方法或键盘布局，或者当前输入方法的 InputMethod.getLocale() 方法返回 null，则返回 null。

不是所有主机操作系统都提供 API 来确定当前已选定的本机输入方法或键盘布局的语言环境。对于未提供此类 API 的主机操作系统而言，getLocale 假定该主机操作系统提供的所有本机输入方法或键盘布局的当前语言环境是该系统的默认语言环境。

返回：
当前输入方法或键盘布局的当前语言环境
从以下版本开始：
1.3

setCharacterSubsets

public void setCharacterSubsets(Character.Subset[] subsets)
设置此输入上下文的输入方法应允许输入的 Unicode 字符集的子集。可能会传入 Null，以指示允许输入所有字符。初始值为 null。该设置适用于当前输入方法，也适用于进行此调用后选定的输入方法。不过，应用程序不能依靠此具有所需影响的调用，因为不能将此设置传递到所有主机输入方法 - 应用程序仍需要应用自己的字符验证。如果没有可用的输入方法，则此方法不起作用。

参数：
subsets - 可以从其输入字符的 Unicode 字符集的子集

setCompositionEnabled

public void setCompositionEnabled(boolean enable)
根据参数 enable 的值启用或禁用当前输入方法进行撰写。

撰写中已启用的输入方法将解释用于撰写和控制的传入事件，而禁用的输入方法不会解释用于撰写的事件。但要注意，不管是否已启用该输入方法，都要将事件传入其中；已禁用进行撰写的输入方法可能仍会因控制目的而解释事件，包括启用或禁用自身进行撰写。

因为输入方法是由主机操作系统提供的，所以可能无法一直确定是否支持此项操作。例如，一个输入方法可能只对某些语言环境启用撰写，而对另一些语言环境不执行任何操作。对于此类输入方法，此方法可能不会抛出 UnsupportedOperationException，并且也不会影响是否已启用撰写。

参数：
enable - 是否启用撰写的当前输入方法
抛出：
UnsupportedOperationException - 如果没有当前可用的输入方法或当前输入方法不支持启用/禁用操作
从以下版本开始：
1.3
另请参见：
isCompositionEnabled()

isCompositionEnabled

public boolean isCompositionEnabled()
确定是否已启用当前输入方法以进行撰写。撰写中已启用的输入方法将解释用于撰写和控制的传入事件，而禁用的输入方法不会解释用于撰写的事件。

返回：
如果当前输入方法已启用撰写，则返回 true；否则返回 false
抛出：
UnsupportedOperationException - 如果没有当前可用的输入方法或当前输入方法不支持检查是否已启用撰写
从以下版本开始：
1.3
另请参见：
setCompositionEnabled(boolean)

reconvert

public void reconvert()
让当前输入方法从当前客户端组件中恢复文本。该输入方法使用 InputMethodRequests.getSelectedText 方法获得要从客户端组件恢复的文本。必须准备其他 InputMethodRequests 方法来处理该输入方法需要的深层信息请求。将撰写文本和/或提交文本作为 InputMethodEvent 的序列发送到客户端组件。如果输入方法不能恢复给定的文本，则会将该文本作为 InputMethodEvent 中的提交文本返回。

抛出：
UnsupportedOperationException - 如果没有当前可用的输入方法，或当前输入方法不支持恢复操作。
从以下版本开始：
1.3

dispatchEvent

public void dispatchEvent(AWTEvent event)
将事件指派到处于活动状态的输入方法。由 AWT 调用。如果没有可用的输入方法，则永远无法使用该事件。

参数：
event - 事件
抛出：
NullPointerException - 如果 event 为 null

removeNotify

public void removeNotify(Component client)
通知输入上下文，客户端组件已从它的包含层次结构中移除，或该组件已禁用输入方法支持。此方法通常从客户端组件的 Component.removeNotify 方法中调用。丢弃此组件的输入方法中可能挂起的输入。如果没有可用的输入方法，则此方法不起作用。

参数：
client - 客户端组件
抛出：
NullPointerException - 如果 client 为 null

endComposition

public void endComposition()
结束当前可能在此上下文进行的任何输入撰写。这样做可能会提交或删除未提交的文本，具体取决于平台和用户可能做出的首选项。对该文本做出的任何更改都可以使用一个输入方法事件传送到处于活动状态的组件。如果没有可用的输入方法，则此方法不起作用。

编辑组件的文本可以在各种情况下调用此方法，例如，用户可在文本内（但在撰写文本外）移动插入点时，或者在将组件的文本保存到文件上或复制到粘贴板上时都可调用。

dispose

public void dispose()
释放由此输入上下文使用过的资源。由 AWT 调用，用于每个 Window 的默认输入上下文。如果没有可用的输入方法，则此方法不起作用。

getInputMethodControlObject

public Object getInputMethodControlObject()
返回当前输入方法中的一个控制对象，或 null。控制对象提供了控制该输入方法的行为或从该输入方法获得信息的方法。对象的类型是输入方法的特定类。客户端必须将其结果与已知输入方法的控制对象类进行对比，并强制转换为适当的类，以调用所提供的方法。

如果没有可用的输入方法，或当前输入方法没有提供输入方法控制对象，则返回 null。

返回：
当前输入方法中的一个控制对象，或 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InputMethodHighlight (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.im
类 InputMethodHighlight

java.lang.Object
    继承者  java.awt.im.InputMethodHighlight

public class InputMethodHighlight
extends Object

InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。该描述可以有两个级别：抽象级，它可指定转换状态和是否已选定文本；具体级，它可指定用来呈现高亮显示的样式属性。InputMethodHighlight 必须提供抽象级描述；可提供也可以不提供具体级描述。如果不提供具体样式，则呈现程序应使用 Toolkit.mapInputMethodHighlight(java.awt.im.InputMethodHighlight) 来映射一个具体样式。

抽象描述由三个字段组成：selected、state 和 variation。selected 指示文本范围是否是输入方法当前使用的范围，例如，当前在菜单上显示转换备选项的单元。state 表示转换状态。状态值由输入方法框架定义，并且应该在从抽象样式到具体样式的所有映射中明确地表示出来。当前定义的状态值是原值（未转换）和已转换的值。建议在采取撰写文本的主要转换步骤前后使用这些状态值，比方说，在 kana->kanji 或 pinyin->hanzi 转换前后。variation 字段允许输入方法表达有关转换结果的其他信息。

InputMethodHighlight 通常用作从用于 INPUT_METHOD_HIGHLIGHT 属性的 AttributedCharacterIterator 返回的属性值。可以将它们包装到 Annotation 实例中，以指示独立的文本单元。

从以下版本开始：
1.2
另请参见：
AttributedCharacterIterator

字段摘要
static int | CONVERTED_TEXT 已转换文本状态的常量。
static int | RAW_TEXT 原文本状态的常量。
static InputMethodHighlight | SELECTED_CONVERTED_TEXT_HIGHLIGHT 已选定已转换文本的默认高亮显示常量。
static InputMethodHighlight | SELECTED_RAW_TEXT_HIGHLIGHT 已选定原文本的默认高亮显示常量。
static InputMethodHighlight | UNSELECTED_CONVERTED_TEXT_HIGHLIGHT 未选定已转换文本的默认高亮显示常量。
static InputMethodHighlight | UNSELECTED_RAW_TEXT_HIGHLIGHT 未选定原文本的默认高亮显示常量。
构造方法摘要
InputMethodHighlight(boolean selected, int state)
构造输入方法高亮显示记录。
InputMethodHighlight(boolean selected, int state, int variation)
构造输入方法高亮显示记录。
InputMethodHighlight(boolean selected, int state, int variation, Map<TextAttribute,?> style)
构造输入方法高亮显示记录。
方法摘要
int | getState() 返回文本范围的转换状态。
Map<TextAttribute,?> | getStyle() 返回文本范围的呈现样式属性，或 null。
int | getVariation() 返回文本范围的变量。
boolean | isSelected() 返回是否已选定文本范围。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RAW_TEXT

public static final int RAW_TEXT
原文本状态的常量。

另请参见：
常量字段值

CONVERTED_TEXT

public static final int CONVERTED_TEXT
已转换文本状态的常量。

另请参见：
常量字段值

UNSELECTED_RAW_TEXT_HIGHLIGHT

public static final InputMethodHighlight UNSELECTED_RAW_TEXT_HIGHLIGHT
未选定原文本的默认高亮显示常量。

SELECTED_RAW_TEXT_HIGHLIGHT

public static final InputMethodHighlight SELECTED_RAW_TEXT_HIGHLIGHT
已选定原文本的默认高亮显示常量。

UNSELECTED_CONVERTED_TEXT_HIGHLIGHT

public static final InputMethodHighlight UNSELECTED_CONVERTED_TEXT_HIGHLIGHT
未选定已转换文本的默认高亮显示常量。

SELECTED_CONVERTED_TEXT_HIGHLIGHT

public static final InputMethodHighlight SELECTED_CONVERTED_TEXT_HIGHLIGHT
已选定已转换文本的默认高亮显示常量。

构造方法详细信息

InputMethodHighlight

public InputMethodHighlight(boolean selected,
                            int state)
构造输入方法高亮显示记录。变量设置为 0，样式设置为 null。

参数：
selected - 是否已选定文本范围
state - 文本范围的转换状态——RAW_TEXT 或 CONVERTED_TEXT
抛出：
IllegalArgumentException - 如果给定了 RAW_TEXT 或 CONVERTED_TEXT 之外的状态
另请参见：
RAW_TEXT, CONVERTED_TEXT

InputMethodHighlight

public InputMethodHighlight(boolean selected,
                            int state,
                            int variation)
构造输入方法高亮显示记录。样式设置为 null。

参数：
selected - 是否已选定文本范围
state - 文本范围的转换状态——RAW_TEXT 和 CONVERTED_TEXT
variation - 文本范围的样式变量
抛出：
IllegalArgumentException - 如果给定了 RAW_TEXT 或 CONVERTED_TEXT 之外的状态
另请参见：
RAW_TEXT, CONVERTED_TEXT

InputMethodHighlight

public InputMethodHighlight(boolean selected,
                            int state,
                            int variation,
                            Map<TextAttribute,?> style)
构造输入方法高亮显示记录。所提供的样式属性映射必须是不可修改的。

参数：
selected - 是否已选定文本范围
state - 文本范围的转换状态——RAW_TEXT 或 CONVERTED_TEXT
variation - 文本范围的变量
style - 文本范围的呈现样式属性，或 null
抛出：
IllegalArgumentException - 如果给定了 RAW_TEXT 或 CONVERTED_TEXT 之外的状态
从以下版本开始：
1.3
另请参见：
RAW_TEXT, CONVERTED_TEXT
方法详细信息

isSelected

public boolean isSelected()
返回是否已选定文本范围。

getState

public int getState()
返回文本范围的转换状态。

返回：
文本范围的转换状态——RAW_TEXT 或 CONVERTED_TEXT。
另请参见：
RAW_TEXT, CONVERTED_TEXT

getVariation

public int getVariation()
返回文本范围的变量。

getStyle

public Map<TextAttribute,?> getStyle()
返回文本范围的呈现样式属性，或 null。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputMethodRequests (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.im
接口 InputMethodRequests

所有已知子接口：
InputMethodContext
public interface InputMethodRequests

InputMethodRequests 定义文本编辑组件为了与输入方法一起使用而必须处理的请求。该组件可以实现此接口本身，也可以使用实现此接口的单独对象。实现此接口的对象必须根据组件的 getInputMethodRequests 方法返回。

文本编辑组件还必须提供输入方法事件侦听器。

设计此接口的目的是支持两个输入用户界面中的其中一个界面：

  • 当场 输入，撰写文本作为文本组件的文本正文的一部分显示在此界面中。
  • 场下 输入，在此界面上，撰写文本显示在单独的撰写窗口中，该窗口就在文本提交时要插入的插入点下。注意，如果在组件的文本正文中选定了文本，此文本将由提交时的提交文本替换；因此，不将其视为文本输入其中的上下文的组成部分。

从以下版本开始：
1.2
另请参见：
Component.getInputMethodRequests(), InputMethodListener

方法摘要
AttributedCharacterIterator | cancelLatestCommittedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。
AttributedCharacterIterator | getCommittedText(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes) 获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。
int | getCommittedTextLength() 获取文本编辑组件中包含的除未提交（撰写）文本外整个文本的长度。
int | getInsertPositionOffset() 获取文本编辑组件中包含的提交文本中的插入位置偏移量。
TextHitInfo | getLocationOffset(int x, int y) 获取撰写文本相对于屏幕上指定 x 和 y 绝对坐标的偏移量。
AttributedCharacterIterator | getSelectedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取当前已选定文本。
Rectangle | getTextLocation(TextHitInfo offset) 获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。

方法详细信息

getTextLocation

Rectangle getTextLocation(TextHitInfo offset)
获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。例如，此信息用来确定在撰写文本附近的候选窗口的位置，或确定将插入提交文本的位置附近的撰写窗口的位置。

如果组件有撰写文本（因为给它发送的最新 InputMethodEvent 包含撰写文本），则该偏移量是相对于撰写文本的——偏移量 0 指示撰写文本中的第一个字符。返回的位置应该是针对此字符的。

如果组件没有撰写文本，则应该忽略偏移量，返回的位置应该反映出包含已选定文本的最后一行中高亮显示的开始处（行方向）。例如，对于水平方向从左到右排列的文本（如英文），则返回包含已选定文本的最后一行上最左边的字符左边的位置。对于垂直方向从上到下排列的文本，行从右向左排列，则返回包含已选定文本的最左边一行的上端位置。

该位置表示为 0 厚度补字号，也就是说，如果文本是水平排列的，则为 0 宽度，如果文本是垂直排列的，则为 0 高度。其他文本方向需要映射到水平或垂直方向。矩形使用绝对值屏幕坐标。

参数：
offset - 撰写文本中的偏移量（如果有撰写文本）；否则为 null
返回：
表示屏幕偏移量的位置的矩形

getLocationOffset

TextHitInfo getLocationOffset(int x,
                              int y)
获取撰写文本相对于屏幕上指定 x 和 y 绝对坐标的偏移量。例如，此信息可用来处理鼠标单击和鼠标光标。偏移量是相对于撰写文本的，因此，偏移量 0 指示撰写文本的开始处。

如果位置在撰写文本占用的区域外，则返回 null。

参数：
x - 屏幕上 x 的绝对坐标
y - 屏幕上 y 的绝对坐标
返回：
描述撰写文本中偏移量的文本单击信息。

getInsertPositionOffset

int getInsertPositionOffset()
获取文本编辑组件中包含的提交文本中的插入位置偏移量。这是通过某个输入方法输入的字符插入位置的偏移量。例如，输入方法使用此信息来检查插入位置周围的文本。

返回：
插入位置的偏移量

getCommittedText

AttributedCharacterIterator getCommittedText(int beginIndex,
                                             int endIndex,
                                             AttributedCharacterIterator.Attribute[] attributes)
获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。应该在索引计算时忽略未提交（撰写）文本，并且也不应让其通过迭代器访问。

输入方法可以提供一个它感兴趣的属性的列表。在这种情况下，有关实现程序可能具有的其他属性的信息不需要通过迭代器进行访问。如果列表为 null，则应该让所有可用的属性信息都可访问。

参数：
beginIndex - 第一个字符的索引
endIndex - 最后一个字符后面的字符的索引
attributes - 输入方法感兴趣的属性列表
返回：
提供对文本及其属性访问的迭代器

getCommittedTextLength

int getCommittedTextLength()
获取文本编辑组件中包含的除未提交（撰写）文本外整个文本的长度。

返回：
除未提交文本外的文本的长度

cancelLatestCommittedText

AttributedCharacterIterator cancelLatestCommittedText(AttributedCharacterIterator.Attribute[] attributes)
从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。此操作用于某些输入方法中的“撤消提交”功能，其中的已提交文本将转换成它以前的撰写状态。可以将该撰写文本发送到使用 InputMethodEvent 的组件。

通常，只有在文本提交后才应立即支持此功能，而不是在用户对文本执行了其他操作后才支持。该功能不受支持时，返回 null。

输入方法可以提供一个它感兴趣的属性的列表。在这种情况下，有关实现程序可能具有的其他属性的信息不需要通过迭代器进行访问。如果列表为 null，则应该让所有可用的属性信息都可访问。

参数：
attributes - 输入方法感兴趣的属性的列表
返回：
最新的提交文本，或在不支持“撤消提交”功能时返回 null

getSelectedText

AttributedCharacterIterator getSelectedText(AttributedCharacterIterator.Attribute[] attributes)
从文本编辑组件中获取当前已选定文本。此操作可以用于各种目的。其中一个就是某些输入方法中的“恢复”功能。在这种情况下，输入方法通常会发送输入方法事件以用撰写文本替换已选定文本。根据输入方法的功能，这可以是已选定文本的原始撰写文本、在文本中任何位置输入的最新撰写文本、文本中任何地方输入的最新撰写文本或从已选定文本中转换回文本的版本。

输入方法可以提供一个它感兴趣的属性的列表。在这种情况下，有关实现程序可能具有的其他属性的信息不需要通过迭代器进行访问。如果列表为 null，则应该让所有可用的属性信息都可访问。

参数：
attributes - 输入方法感兴趣的属性的列表
返回：
当前已选定的文本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputSubset (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.im
类 InputSubset

java.lang.Object
    继承者  java.lang.Character.Subset
        继承者  java.awt.im.InputSubset

public final class InputSubset
extends Character.Subset

定义输入方法使用的其他 Unicode 子集。与 Character.UnicodeBlock 类中定义的 UnicodeBlock 子集不同，这些常量不直接对应于 Unicode 代码块。

从以下版本开始：
1.2

字段摘要
static InputSubset | FULLWIDTH_DIGITS Unicode 半角和全角字符块中包括的全角数字常量。
static InputSubset | FULLWIDTH_LATIN Unicode 半角和全角字符块的全角 ASCII 变体子集常量。
static InputSubset | HALFWIDTH_KATAKANA Unicode 半角和全角字符块的半角片假名子集常量。
static InputSubset | HANJA 编写韩语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项的韩语汉字字集。
static InputSubset | KANJI 编写日语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的日语汉字字集。
static InputSubset | LATIN 所有拉丁字符常量，包括 BASIC_LATIN、LATIN_1_SUPPLEMENT、LATIN_EXTENDED_A、LATIN_EXTENDED_B Unicode 字符块中的字符。
static InputSubset | LATIN_DIGITS BASIC_LATIN Unicode 字符块中包括的数字常量。
static InputSubset | SIMPLIFIED_HANZI 编写简体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的简体中文汉字字集。
static InputSubset | TRADITIONAL_HANZI 编写繁体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的繁体中文汉字字集。
方法摘要
从类 java.lang.Character.Subset 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

LATIN

public static final InputSubset LATIN
所有拉丁字符常量，包括 BASIC_LATIN、LATIN_1_SUPPLEMENT、LATIN_EXTENDED_A、LATIN_EXTENDED_B Unicode 字符块中的字符。

LATIN_DIGITS

public static final InputSubset LATIN_DIGITS
BASIC_LATIN Unicode 字符块中包括的数字常量。

TRADITIONAL_HANZI

public static final InputSubset TRADITIONAL_HANZI
编写繁体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的繁体中文汉字字集。

SIMPLIFIED_HANZI

public static final InputSubset SIMPLIFIED_HANZI
编写简体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的简体中文汉字字集。

KANJI

public static final InputSubset KANJI
编写日语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的日语汉字字集。

HANJA

public static final InputSubset HANJA
编写韩语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项的韩语汉字字集。

HALFWIDTH_KATAKANA

public static final InputSubset HALFWIDTH_KATAKANA
Unicode 半角和全角字符块的半角片假名子集常量。

FULLWIDTH_LATIN

public static final InputSubset FULLWIDTH_LATIN
Unicode 半角和全角字符块的全角 ASCII 变体子集常量。

从以下版本开始：
1.3

FULLWIDTH_DIGITS

public static final InputSubset FULLWIDTH_DIGITS
Unicode 半角和全角字符块中包括的全角数字常量。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.im (Java 2 Platform SE 6)

 java.awt.im
接口
InputMethodRequests
类
InputContext
InputMethodHighlight
InputSubset


java.awt.im (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.im

提供输入方法框架所需的类和接口。

请参见：
描述

接口摘要
InputMethodRequests InputMethodRequests 定义文本编辑组件为了与输入方法一起使用而必须处理的请求。

类摘要
InputContext | 提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。
InputMethodHighlight | InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。
InputSubset | 定义输入方法使用的其他 Unicode 子集。

软件包 java.awt.im 的描述

提供输入方法框架所需的类和接口。此包可以通过输入方法启用文本编辑组件来接收文本输入。输入方法是一些软件组件，允许用户以其他方式输入文本，而不仅仅局限于简单的键盘输入。使用它们，通常可用非常有限的几个键盘键即可完成日语、汉语或韩语的输入——这些语言都使用了数千个不同的字符。不过，该框架还支持其他语言的输入方法，并且使用完全不同的输入机制，如手写识别或语音识别。

包规范

  • Input Method Framework Specification
  • Input Method Client API Reference

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：

  • Input Method Framework Overview
  • Input Method Client API Tutorial

    从以下版本开始：
    1.2
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个软件包 下一个软件包 框架 无框架


java.awt.im 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.im 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Character.Subset
      • java.awt.im.InputSubset
    • java.awt.im.InputContext
    • java.awt.im.InputMethodHighlight

接口分层结构

  • java.awt.im.InputMethodRequests
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.im 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.im
的使用

使用 java.awt.im 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 使用的 java.awt.im 中的类
InputContext
提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。
InputMethodHighlight
InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。
InputMethodRequests
InputMethodRequests 定义文本编辑组件为了与输入方法一起使用而必须处理的请求。

java.awt.im 使用的 java.awt.im 中的类
InputContext
提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。
InputMethodHighlight
InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。
InputSubset
定义输入方法使用的其他 Unicode 子集。

java.awt.im.spi 使用的 java.awt.im 中的类
InputMethodRequests
InputMethodRequests 定义文本编辑组件为了与输入方法一起使用而必须处理的请求。

javax.swing.text 使用的 java.awt.im 中的类
InputMethodRequests
InputMethodRequests 定义文本编辑组件为了与输入方法一起使用而必须处理的请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


InputMethod (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.im.spi
接口 InputMethod

public interface InputMethod

定义支持复杂文本输入的输入方法接口。输入方法通常支持多语言文本输入，这些语言（如汉语、日语和韩语）都有无法在标准键盘上直接表示的字符。不过，它们也可以用来支持英语语音文本输入或泰语字符的重新排序。

InputMethod 的子类可以由输入方法框架加载；然后可以通过 API (InputContext.selectInputMethod) 或通过用户界面（输入方法选择菜单）对其进行选择。

从以下版本开始：
1.3

方法摘要
void | activate() 激活输入方法，以便立即进行输入处理。
void | deactivate(boolean isTemporary) 让输入方法处于非活动状态。
void | dispatchEvent(AWTEvent event) 将事件指派到输入方法。
void | dispose() 释放由此输入方法使用的资源。
void | endComposition() 结束当前可能在此上下文中正进行的任何输入撰写。
Object | getControlObject() 从此输入方法返回一个控制对象，或 null。
Locale | getLocale() 返回当前的输入语言环境。
void | hideWindows() 关闭或隐藏由此输入方法实例或其类打开的所有窗口。
boolean | isCompositionEnabled() 确定此输入方法是否已启用。
void | notifyClientWindowChange(Rectangle bounds) 通知此输入方法客户端窗口位置或状态的更改。
void | reconvert() 启动恢复操作。
void | removeNotify() 通知输入方法已从客户端组件所在容器层次结构中移除该客户端组件，或通知它该组件已禁用输入方法支持。
void | setCharacterSubsets(Character.Subset[] subsets) 设置允许此输入方法进行输入的 Unicode 字符集的子集。
void | setCompositionEnabled(boolean enable) 启用或禁用输入方法的撰写功能，具体取决于参数 enable 的值。
void | setInputMethodContext(InputMethodContext context) 设置输入方法的上下文，这样可以将输入方法事件指派到客户端组件并能从客户端组件请求信息。
boolean | setLocale(Locale locale) 试图设置输入语言环境。

方法详细信息

setInputMethodContext

void setInputMethodContext(InputMethodContext context)
设置输入方法的上下文，这样可以将输入方法事件指派到客户端组件并能从客户端组件请求信息。

实例化此输入方法之后马上就会调用一次此方法。

参数：
context - 此输入方法的输入方法上下文
抛出：
NullPointerException - 如果 context 为 null

setLocale

boolean setLocale(Locale locale)
试图设置输入语言环境。如果输入方法支持所需的语言环境，则此输入方法将更改自己的行为以支持该语言环境的输入并返回 true。否则，它将返回 false，且不会更改自己的行为。

以下情况可调用此方法

  • 由 InputContext.selectInputMethod 调用。
  • 如果用户指定了语言环境，或者以前已选定输入方法的 getLocale 方法返回一个非 null 值，则当通过用户界面切换为该输入方法时调用。

参数：
locale - 要输入的语言环境
返回：
是否支持指定的语言环境
抛出：
NullPointerException - 如果 locale 为 null

getLocale

Locale getLocale()
返回当前的输入语言环境。异常情况下可能返回 null。

以下情况可调用此方法

  • 由 InputContext.getLocale 调用，和
  • 通过用户界面从此输入方法切换为另一种输入方法时调用。

返回：
当前的输入语言环境，或 null

setCharacterSubsets

void setCharacterSubsets(Character.Subset[] subsets)
设置允许此输入方法进行输入的 Unicode 字符集的子集。可能会传入 Null，以指示允许输入所有字符。

以下情况可调用此方法

  • 实例化此输入方法后立即调用，
  • 当从另一种输入方法切换到此输入方法时，以及
  • 由 InputContext.setCharacterSubsets 调用。

参数：
subsets - 可以从其输入字符的 Unicode 字符集的子集

setCompositionEnabled

void setCompositionEnabled(boolean enable)
启用或禁用输入方法的撰写功能，具体取决于参数 enable 的值。

启用输入方法的撰写功能将出于撰写和控制目的解释传入事件，而禁用的输入方法不能解释出于撰写目的的事件。但要注意：无论输入方法是启用还是禁用，事件都会传到该输入方法；禁用输入方法的撰写功能可能仍会出于控制目的解释包括为撰写而启用或禁用自身在内的事件。

对于由主机操作系统提供的输入方法，并不总能确定是否支持此操作。例如，某个输入方法可能只对某些语言环境启用了撰写功能，而对另一些语言环境不执行任何操作。对于此类输入方法，此方法有可能既不抛出 UnsupportedOperationException，也不影响是否已启用撰写功能。

以下情况可调用此方法

  • 由 InputContext.setCompositionEnabled 调用。
  • 如果以前已选定输入方法的 isCompositionEnabled 方法在没有抛出异常的情况下返回，则当使用用户界面或 InputContext.selectInputMethod 从另一种输入方法切换到此输入方法时调用。

参数：
enable - 是否启用输入方法的撰写功能
抛出：
UnsupportedOperationException - 如果此输入方法不支持启用/禁用操作
另请参见：
isCompositionEnabled()

isCompositionEnabled

boolean isCompositionEnabled()
确定此输入方法是否已启用。启用撰写功能的输入方法将出于撰写和控制目的解释传入事件，而禁用的输入方法不会出于撰写目的解释事件。

以下情况可调用此方法

  • 由 InputContext.isCompositionEnabled 调用，并且
  • 当使用用户界面或 InputContext.selectInputMethod 从此输入方法切换到另一种输入方法时调用。

返回：
如果为进行撰写启用了此输入方法，则返回 true；否则返回 false。
抛出：
UnsupportedOperationException - 如果此输入方法不支持是否已启用撰写功能检查
另请参见：
setCompositionEnabled(boolean)

reconvert

void reconvert()
启动恢复操作。输入方法使用 InputMethodRequests.getSelectedText 方法从当前客户端组件中获得要恢复的文本。它也可以使用其他 InputMethodRequests 方法请求恢复操作所需的其他信息。此操作生成的已混合且已提交文本将作为 InputMethodEvent 序列发送到客户端组件。如果给定的文本不能恢复，则会把相同的文本作为已提交文本发送到客户端组件。

可由 InputContext.reconvert 调用此方法。

抛出：
UnsupportedOperationException - 如果输入方法不支持恢复操作。

dispatchEvent

void dispatchEvent(AWTEvent event)
将事件指派到输入方法。如果拥有焦点的组件已启用输入方法支持，某些类型的传入事件将被指派到此组件的当前输入方法，然后才指派到该组件的方法或事件侦听器。该输入方法决定是否需要处理此事件。如果需要处理，它还要调用该事件的 consume 方法；这样做会导致该事件不能被指派到组件的事件处理方法或事件侦听器。

如果事件为 InputEvent 或其子类的实例，则会指派它们。这包括 AWT 类 KeyEvent 和 MouseEvent 的实例。

可由 InputContext.dispatchEvent 调用此方法。

参数：
event - 正指派到输入方法的事件
抛出：
NullPointerException - 如果 event 为 null

notifyClientWindowChange

void notifyClientWindowChange(Rectangle bounds)
通知此输入方法客户端窗口位置或状态的更改。当该输入方法是其输入上下文的当前输入方法且已启用其通知时调用此方法（请参见 InputMethodContext.enableClientWindowNotification）。如果调用了输入上下文的 removeNotify 方法，则会临时挂起对此方法的调用；当新的客户端组件激活此输入方法时，将恢复此方法的调用。将在以下情形调用此方法：
  • 包含当前客户端组件的窗口，其位置、大小、可见性、iconification 状态更改时，或关闭窗口时。
  • 如果当前客户端组件存在，则从 enableClientWindowNotification(inputMethod, true) 调用。
  • 如果调用期间没有可用的当前客户端组件，则在该输入方法调用 enableClientWindowNotification(inputMethod, true) 后首次激活它时调用。
  • 在调用输入上下文的 removeNotify 方法之后，激活新客户端组件的输入方法时调用。

参数：
bounds - 屏幕上客户端窗口的 bounds；如果客户端窗口已图标化或不可见，则为 null

activate

void activate()
激活输入方法，以便立即进行输入处理。

如果某种输入方法提供了自己的窗口，则此时它应确保所有必要的窗口都已打开并可见。

以下情况可调用此方法

  • 当客户端组件收到 FOCUS_GAINED 事件时由 InputContext.dispatchEvent 调用。
  • 使用用户界面或 InputContext.selectInputMethod 从另一种输入方法切换到此输入方法时调用。
只有当输入方法处于非活动状态时才能调用该方法。假定新实例化的输入方法处于非活动状态。

deactivate

void deactivate(boolean isTemporary)
让输入方法处于非活动状态。isTemporary 参数与 FocusEvent.isTemporary 中的参数含义相同。

如果输入方法提供了自己的窗口，则此时只应关闭与当前撰写功能相关的窗口（如查找选择窗口）。该输入方法有可能被另一个客户端组件再次激活，并且关闭或重新打开较稳定的窗口（如控制面板）可能会造成不必要的屏幕闪烁。在激活另一种输入方法类的实例之前，当前输入方法将调用 hideWindows()。

以下情况可调用此方法

  • 当客户端组件收到 FOCUS_LOST 事件时，由 InputContext.dispatchEvent 调用。
  • 使用用户界面或 InputContext.selectInputMethod 从此输入方法切换到另一种输入方法时调用。
  • 如果当前客户端组件被移除，则在 removeNotify 之前调用。
只有当输入方法处于活动状态时才能调用该方法。

参数：
isTemporary - 焦点更改是否为临时的

hideWindows

void hideWindows()
关闭或隐藏由此输入方法实例或其类打开的所有窗口。

以下情况可调用此方法

  • 对另一种输入方法类实例调用 activate 之前调用。
  • 对此输入方法调用 dispose 之前调用。
只有当输入方法处于非活动状态时才能调用该方法。

removeNotify

void removeNotify()
通知输入方法已从客户端组件所在容器层次结构中移除该客户端组件，或通知它该组件已禁用输入方法支持。

可由 InputContext.removeNotify 调用此方法。

只有当输入方法处于非活动状态时才能调用该方法。

endComposition

void endComposition()
结束当前可能在此上下文中正进行的任何输入撰写。这样做可能会提交或删除未提交的文本，具体取决于平台和用户可能做出的首选项。使用一个输入方法事件可将对文本的任何更改传送到处于活动状态的组件。

编辑组件的文本可以在各种情况下调用此方法，例如，用户可在文本内（但在撰写文本外）移动插入点时，或者在将组件的文本保存到文件上或复制到粘贴板上时都可调用。

以下情况可调用此方法

  • 由 InputContext.endComposition 调用。
  • 在切换到另一个客户端组件时可由 InputContext.dispatchEvent 调用
  • 当使用用户界面或 InputContext.selectInputMethod 从此输入方法切换到另一种输入方法时调用。

dispose

void dispose()
释放由此输入方法使用的资源。特别要提出的是，输入方法应释放窗口并关闭不再需要的文件。

可由 InputContext.dispose 调用此方法。

只有当输入方法处于非活动状态时才能调用该方法。释放之后，就无法针对此实例调用该接口的方法了。

getControlObject

Object getControlObject()
从此输入方法返回一个控制对象，或 null。控制对象提供了控制该输入方法的行为或从该输入方法获得信息的方法。对象的类型是输入方法的特定类。客户端必须将其结果与已知输入方法的控制对象类进行对比，并传递给适当的类以调用所提供的方法。

可由 InputContext.getInputMethodControlObject 调用此方法。

返回：
此输入方法的一个控制对象，或 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InputMethodContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.im.spi
接口 InputMethodContext

所有超级接口：
InputMethodRequests
public interface InputMethodContext
extends InputMethodRequests

提供输入方法可以用来与其客户端组件通信或用来请求其他服务的方法。此接口由输入方法框架实现，并且输入方法针对其通过 InputMethod.setInputMethodContext(java.awt.im.spi.InputMethodContext) 收到的实例调用其方法。此外再没有其他实现程序或调用者。

从以下版本开始：
1.3

方法摘要
JFrame | createInputMethodJFrame(String title, boolean attachToInputContext) 创建输入方法使用的顶层 Swing JFrame。
Window | createInputMethodWindow(String title, boolean attachToInputContext) 创建输入方法使用的顶层窗口。
void | dispatchInputMethodEvent(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition) 根据给定的参数创建输入方法事件并将其指派到客户端组件。
void | enableClientWindowNotification(InputMethod inputMethod, boolean enable) 启用或禁用指定输入方法的当前客户端窗口位置或状态的通知。
从接口 java.awt.im.InputMethodRequests 继承的方法
cancelLatestCommittedText, getCommittedText, getCommittedTextLength, getInsertPositionOffset, getLocationOffset, getSelectedText, getTextLocation

方法详细信息

dispatchInputMethodEvent

void dispatchInputMethodEvent(int id,
                              AttributedCharacterIterator text,
                              int committedCharacterCount,
                              TextHitInfo caret,
                              TextHitInfo visiblePosition)
根据给定的参数创建输入方法事件并将其指派到客户端组件。有关参数的信息，请参阅 InputMethodEvent.InputMethodEvent(java.awt.Component, int, java.awt.font.TextHitInfo, java.awt.font.TextHitInfo)。

createInputMethodWindow

Window createInputMethodWindow(String title,
                               boolean attachToInputContext)
创建输入方法使用的顶层窗口。此窗口预期的行为是：
  • 浮动于所有文档窗口和对话框上方
  • 它和它包含的所有组件都不接收焦点
  • 该窗口略有装饰，如减化的无标题拖动区域
不过，对应于这三项的实际行为与平台有关。

标题可以显示也可以不显示，具体取决于所创建窗口的实际类型。

如果 attachToInputContext 为 true，该新窗口将共享对应于此输入方法上下文的输入上下文，以便自动将窗口中的组件事件指派到该输入方法。此外，使用 setVisible(true) 打开窗口时，输入上下文将阻止可能的对输入方法的停用或激活调用。

如果不再需要已返回的输入方法窗口，则输入方法必须调用该窗口上的 Window.dispose。

参数：
title - 窗口标题栏（如果有此标题栏）中显示的标题。将 null 值看作空字符串 ("")。
attachToInputContext - 是否应共享对应于此输入方法上下文的输入上下文
返回：
带有输入方法使用的特殊特征的窗口
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true

createInputMethodJFrame

JFrame createInputMethodJFrame(String title,
                               boolean attachToInputContext)
创建输入方法使用的顶层 Swing JFrame。此窗口预期的行为是：
  • 浮动于所有文档窗口和对话框上方
  • 它和它包含的所有组件都不接收焦点
  • 该窗口略有装饰，如减化的无标题拖动区域
不过，对应于这三项的实际行为与平台有关。

标题可以显示也可以不显示，具体取决于所创建窗口的实际类型。

如果 attachToInputContext 为 true，该新窗口将共享对应于此输入方法上下文的输入上下文，以便自动将窗口中的组件事件指派到该输入方法。此外，使用 setVisible(true) 打开窗口时，输入上下文将阻止可能的对输入方法的停用或激活调用。

如果不再需要已返回的输入方法窗口，则输入方法必须调用该窗口上的 Window.dispose。

参数：
title - 窗口标题栏（如果有此标题栏）中显示的标题。将 null 值看作空字符串 ("")。
attachToInputContext - 是否应共享对应于此输入方法上下文的输入上下文
返回：
带有输入方法使用的特殊特征的 JFrame
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
从以下版本开始：
1.4

enableClientWindowNotification

void enableClientWindowNotification(InputMethod inputMethod,
                                    boolean enable)
启用或禁用指定输入方法的当前客户端窗口位置或状态的通知。启用通知时，按方法规范中描述的那样调用该输入方法的 notifyClientWindowChange 方法。释放掉输入方法后将自动禁用通知。

参数：
inputMethod - 已启用或已禁用通知的输入方法
enable - true 表示启用，false 表示禁用
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputMethodDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.im.spi
接口 InputMethodDescriptor

public interface InputMethodDescriptor

定义提供足够的关于输入方法启用选择和该输入方法加载信息的方法。输入方法只有在实际使用时才加载其自身。

从以下版本开始：
1.3

方法摘要
InputMethod | createInputMethod() 创建相应输入方法的新实例。
Locale[] | getAvailableLocales() 返回相应输入方法支持的语言环境。
String | getInputMethodDisplayName(Locale inputLocale, Locale displayLanguage) 用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。
Image | getInputMethodIcon(Locale inputLocale) 返回相应输入方法的图标。
boolean | hasDynamicLocaleList() 返回可用语言环境列表是否可在运行时更改。

方法详细信息

getAvailableLocales

Locale[] getAvailableLocales()
                             throws AWTException
返回相应输入方法支持的语言环境。该语言环境可能只描述语言；如果需要，还可能包括国家/地区和变量信息。该信息用于按语言环境选择输入方法 (InputContext.selectInputMethod(Locale))。还可以按用户可视输入方法列表的语言环境将它用于输入方法排序。

只应返回输入方法的主要语言环境。例如，如果日语输入方法也有通向罗马字符的模式，通常仍只返回日语。因此，已返回的语言环境列表通常是相应输入方法的 InputMethod.setLocale(java.util.Locale) 实现返回 true 的语言环境的子集。

如果 hasDynamicLocaleList() 返回 true，则每次需要信息时就调用此方法。这就在资源变得可用或不可用时给依赖于网络资源的输入方法提供了添加或移除语言环境的机会。

返回：
输入方法支持的语言环境
抛出：
AWTException - 如果能够确定输入方法不可操作（例如，由于安装不完整）。

hasDynamicLocaleList

boolean hasDynamicLocaleList()
返回可用语言环境列表是否可在运行时更改。例如，通过网络访问实际输入方法的适配器可能会发生这种情况。

getInputMethodDisplayName

String getInputMethodDisplayName(Locale inputLocale,
                                 Locale displayLanguage)
用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。

inputLocale 参数指定文本输入的语言环境。此参数只可以采取通过此描述符的 getAvailableLocales() 方法获得的值或 null。如果为 null，将返回该输入方法的某个独立于输入语言环境的名称。

如果所需显示语言的名称不可用，该方法可能会转回到其他某种语言。

参数：
inputLocale - 支持文本输入的语言环境，或 null
displayLanguage - 显示名称的语言

getInputMethodIcon

Image getInputMethodIcon(Locale inputLocale)
返回相应输入方法的图标。该图标可以用于用户界面，供选择输入方法使用。

inputLocale 参数指定文本输入的语言环境。此参数只可以采取通过此描述符的 getAvailableLocales() 方法获得的值或 null。如果为 null，将返回该输入方法的某个独立于输入语言环境的图标。

图标的大小应是 16×16 像素。

参数：
inputLocale - 支持文本输入的语言环境，或 null
返回：
相应输入方法的图标，或 null

createInputMethod

InputMethod createInputMethod()
                              throws Exception
创建相应输入方法的新实例。

返回：
相应输入方法的新实例
抛出：
Exception - 可能在创建输入方法实例时发生的任何异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.im.spi (Java 2 Platform SE 6)

 java.awt.im.spi
接口
InputMethod
InputMethodContext
InputMethodDescriptor


java.awt.im.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.im.spi

提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

请参见：
描述

接口摘要
InputMethod | 定义支持复杂文本输入的输入方法接口。
InputMethodContext | 提供输入方法可以用来与其客户端组件通信或用来请求其他服务的方法。
InputMethodDescriptor | 定义提供足够的关于输入方法启用选择和该输入方法加载信息的方法。

软件包 java.awt.im.spi 的描述

提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。输入方法是一些软件组件，允许用户以其他方式输入文本，而不仅仅局限于简单的键盘输入。使用它们，通常可用非常有限的几个键盘键即可完成日语、汉语或韩语的输入——这些语言都使用了数千个不同的字符。不过，此包还允许开发其他语言的输入方法和使用完全不同的输入机制，如手写识别。

包规范

  • Input Method Framework Specification
  • Input Method Engine SPI Reference

打包输入方法

输入方法被打包为已安装的扩展，这由 Extension Mechanism 指定。输入方法的主要 JAR 文件必须包含文件：

    META-INF/services/java.awt.im.spi.InputMethodDescriptor

该文件应该包含一个实现 java.awt.im.spi.InputMethodDescriptor 接口的类的完全限定类名称的列表（每行一个名称）。忽略各名称周围的空格字符和制表符以及空行。注释字符为 '#' (\u0023)；将忽略每行的第一个注释字符后面的所有字符。文件必须使用 UTF-8 编码。

例如，如果实现 Foo 输入方法的 java.awt.im.spi.InputMethodDesciptor 的类的完全限定名称为 com.sun.ime.FooInputMethodDescriptor，则文件 META-INF/services/java.awt.im.spi.InputMethodDescriptor 包含这样一行：

    com.sun.ime.FooInputMethodDescriptor

输入方法还必须提供至少两个类：一个实现 java.awt.im.spi.InputMethodDescriptor 接口的类，一个实现 java.awt.im.spi.InputMethod 接口的类。输入方法必须分别实现这些接口，以便推迟到实际需要时才加载实现 InputMethod 的类。

加载输入方法

输入方法框架通常会推迟到绝对需要时才加载输入方法类。它在 AWT 初始化期间只加载 InputMethodDescriptor 实现。在已选定输入方法时加载 InputMethod 实现。

Java 输入方法和同级文本组件

Java 输入方法框架意在支持所有输入方法（主机输入方法和 Java 输入方法）和组件（同级或轻量级）的撰写。不过，因为基础平台的限制，它不会总是能够启用 Java 输入方法和同级 AWT 组件之间的通信。因此，对具体撰写的支持与平台有关。在 Sun 的 Java SE 运行时环境中，此撰写在 Windows 上受支持，但在 Solaris 上不受支持。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：

  • Input Method Framework Overview
  • Input Method Engine SPI Tutorial

    从以下版本开始：
    JDK1.3
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个软件包 下一个软件包 框架 无框架


java.awt.im.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.im.spi 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • java.awt.im.spi.InputMethod
  • java.awt.im.spi.InputMethodDescriptor
  • java.awt.im.InputMethodRequests
    • java.awt.im.spi.InputMethodContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.im.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.im.spi
的使用

使用 java.awt.im.spi 的软件包
java.awt.im.spi 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.im.spi 使用的 java.awt.im.spi 中的类
InputMethod
定义支持复杂文本输入的输入方法接口。
InputMethodContext
提供输入方法可以用来与其客户端组件通信或用来请求其他服务的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.im.spi.InputMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.spi.InputMethod
的使用

使用 InputMethod 的软件包
java.awt.im.spi 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.im.spi 中 InputMethod 的使用

返回 InputMethod 的 java.awt.im.spi 中的方法
 InputMethod InputMethodDescriptor.createInputMethod()
创建相应输入方法的新实例。

参数类型为 InputMethod 的 java.awt.im.spi 中的方法
 void InputMethodContext.enableClientWindowNotification(InputMethod inputMethod, boolean enable)
启用或禁用指定输入方法的当前客户端窗口位置或状态的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.im.spi.InputMethodDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.spi.InputMethodDescriptor
的使用

没有 java.awt.im.spi.InputMethodDescriptor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.im.spi.InputMethodContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.spi.InputMethodContext
的使用

使用 InputMethodContext 的软件包
java.awt.im.spi 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.im.spi 中 InputMethodContext 的使用

参数类型为 InputMethodContext 的 java.awt.im.spi 中的方法
 void InputMethod.setInputMethodContext(InputMethodContext context)
设置输入方法的上下文，这样可以将输入方法事件指派到客户端组件并能从客户端组件请求信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.im.InputMethodHighlight 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.im.InputMethodHighlight
的使用

使用 InputMethodHighlight 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im | 提供输入方法框架所需的类和接口。

java.awt 中 InputMethodHighlight 的使用

参数类型为 InputMethodHighlight 的 java.awt 中的方法
abstract  Map<TextAttribute,?> Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight)
返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。

java.awt.im 中 InputMethodHighlight 的使用

声明为 InputMethodHighlight 的 java.awt.im 中的字段
static InputMethodHighlight | InputMethodHighlight.SELECTED_CONVERTED_TEXT_HIGHLIGHT 已选定已转换文本的默认高亮显示常量。
static InputMethodHighlight | InputMethodHighlight.SELECTED_RAW_TEXT_HIGHLIGHT 已选定原文本的默认高亮显示常量。
static InputMethodHighlight | InputMethodHighlight.UNSELECTED_CONVERTED_TEXT_HIGHLIGHT 未选定已转换文本的默认高亮显示常量。
static InputMethodHighlight | InputMethodHighlight.UNSELECTED_RAW_TEXT_HIGHLIGHT 未选定原文本的默认高亮显示常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.im.InputSubset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.im.InputSubset
的使用

使用 InputSubset 的软件包
java.awt.im 提供输入方法框架所需的类和接口。

java.awt.im 中 InputSubset 的使用

声明为 InputSubset 的 java.awt.im 中的字段
static InputSubset | InputSubset.FULLWIDTH_DIGITS Unicode 半角和全角字符块中包括的全角数字常量。
static InputSubset | InputSubset.FULLWIDTH_LATIN Unicode 半角和全角字符块的全角 ASCII 变体子集常量。
static InputSubset | InputSubset.HALFWIDTH_KATAKANA Unicode 半角和全角字符块的半角片假名子集常量。
static InputSubset | InputSubset.HANJA 编写韩语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项的韩语汉字字集。
static InputSubset | InputSubset.KANJI 编写日语使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的日语汉字字集。
static InputSubset | InputSubset.LATIN 所有拉丁字符常量，包括 BASIC_LATIN、LATIN_1_SUPPLEMENT、LATIN_EXTENDED_A、LATIN_EXTENDED_B Unicode 字符块中的字符。
static InputSubset | InputSubset.LATIN_DIGITS BASIC_LATIN Unicode 字符块中包括的数字常量。
static InputSubset | InputSubset.SIMPLIFIED_HANZI 编写简体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的简体中文汉字字集。
static InputSubset | InputSubset.TRADITIONAL_HANZI 编写繁体中文使用的所有汉字字集常量，包括统一的 CJK 表意符号的子集和可定义为代理项字符的繁体中文汉字字集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.im.InputMethodRequests 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.im.InputMethodRequests
的使用

使用 InputMethodRequests 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 InputMethodRequests 的使用

返回 InputMethodRequests 的 java.awt 中的方法
InputMethodRequests | TextComponent.getInputMethodRequests()
InputMethodRequests | Component.getInputMethodRequests() 获取输入方法请求处理程序，该处理程序支持此组件输入方法发出的请求。

java.awt.im.spi 中 InputMethodRequests 的使用

java.awt.im.spi 中 InputMethodRequests 的子接口
 interface InputMethodContext
提供输入方法可以用来与其客户端组件通信或用来请求其他服务的方法。

javax.swing.text 中 InputMethodRequests 的使用

返回 InputMethodRequests 的 javax.swing.text 中的方法
 InputMethodRequests JTextComponent.getInputMethodRequests()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.im.InputContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.im.InputContext
的使用

使用 InputContext 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im | 提供输入方法框架所需的类和接口。

java.awt 中 InputContext 的使用

返回 InputContext 的 java.awt 中的方法
InputContext | Window.getInputContext() 获取此窗口的输入上下文。
InputContext | Component.getInputContext() 获取此组件使用的输入上下文，用于处理在此组件中输入文本时与输入方法的通信。

java.awt.im 中 InputContext 的使用

返回 InputContext 的 java.awt.im 中的方法
static InputContext InputContext.getInstance()
返回新 InputContext 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AffineTransformOp (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 AffineTransformOp

java.lang.Object
    继承者  java.awt.image.AffineTransformOp
所有已实现的接口：
BufferedImageOp, RasterOp
public class AffineTransformOp
extends Object
implements BufferedImageOp, RasterOp

此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。所使用的插值类型由构造方法通过一个 RenderingHints 对象或通过此类中定义的整数插值类型之一来指定。

如果在构造方法中指定了 RenderingHints 对象，则使用插值提示和呈现的质量提示为此操作设置插值类型。要求进行颜色转换时，可以使用颜色呈现提示和抖动提示。

注意，务必要满足以下约束：

  • 源图像与目标图像必须不同。
  • 对于 Raster 对象，源图像中的 band 数必须等于目标图像中的 band 数。

另请参见：
AffineTransform, BufferedImageFilter, RenderingHints.KEY_INTERPOLATION, RenderingHints.KEY_RENDERING, RenderingHints.KEY_COLOR_RENDERING, RenderingHints.KEY_DITHERING

字段摘要
static int | TYPE_BICUBIC 双三次插值类型。
static int | TYPE_BILINEAR 双线性的插值类型。
static int | TYPE_NEAREST_NEIGHBOR 最接近的邻插值类型。
构造方法摘要
AffineTransformOp(AffineTransform xform, int interpolationType)
根据仿射转换和插值类型构造一个 AffineTransformOp。
AffineTransformOp(AffineTransform xform, RenderingHints hints)
根据仿射转换构造 AffineTransformOp。
方法摘要
BufferedImage | createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
WritableRaster | createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的经过检查的目标 Raster。
BufferedImage | filter(BufferedImage src, BufferedImage dst) 转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。
WritableRaster | filter(Raster src, WritableRaster dst) 转换源 Raster 并将结果存储在目标 Raster 中。
Rectangle2D | getBounds2D(BufferedImage src) 返回转换后的目标图像的边界框。
Rectangle2D | getBounds2D(Raster src) 返回转换后的目标图像的边界框。
int | getInterpolationType() 返回由此 op 使用的插值类型。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
RenderingHints | getRenderingHints() 返回此转换操作使用的呈现提示。
AffineTransform | getTransform() 返回此转换操作使用的仿射转换。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_NEAREST_NEIGHBOR

public static final int TYPE_NEAREST_NEIGHBOR
最接近的邻插值类型。

另请参见：
常量字段值

TYPE_BILINEAR

public static final int TYPE_BILINEAR
双线性的插值类型。

另请参见：
常量字段值

TYPE_BICUBIC

public static final int TYPE_BICUBIC
双三次插值类型。

另请参见：
常量字段值
构造方法详细信息

AffineTransformOp

public AffineTransformOp(AffineTransform xform,
                         RenderingHints hints)
根据仿射转换构造 AffineTransformOp。根据 RenderingHints 对象确定插值类型。如果定义了插值提示，则要使用该提示。否则，如果定义了呈现的质量提示，则根据其值确定插值类型。如果没有指定提示（hints 为 null），则插值类型为 TYPE_NEAREST_NEIGHBOR。

参数：
xform - 该操作要使用的 AffineTransform。
hints - 用于指定该操作插值类型的 RenderingHints 对象。
抛出：
ImagingOpException - 如果转换是不可逆的。
另请参见：
RenderingHints.KEY_INTERPOLATION, RenderingHints.KEY_RENDERING

AffineTransformOp

public AffineTransformOp(AffineTransform xform,
                         int interpolationType)
根据仿射转换和插值类型构造一个 AffineTransformOp。

参数：
xform - 该操作要使用的 AffineTransform。
interpolationType - 由此类定义的整数插值类型常量之一：TYPE_NEAREST_NEIGHBOR、TYPE_BILINEAR、TYPE_BICUBIC。
抛出：
ImagingOpException - 如果转换是不可逆的。
方法详细信息

getInterpolationType

public final int getInterpolationType()
返回由此 op 使用的插值类型。

返回：
插值类型。
另请参见：
TYPE_NEAREST_NEIGHBOR, TYPE_BILINEAR, TYPE_BICUBIC

filter

public final BufferedImage filter(BufferedImage src,
                                  BufferedImage dst)
转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。如果两个图像的颜色模型不匹配，则将颜色模型转换成目标颜色模型。如果目标图像为 null，则使用源 ColorModel 创建 BufferedImage。

由 getBounds2D(BufferedImage) 返回的矩形坐标不一定与由此方法返回的 BufferedImage 的坐标相同。如果矩形的左上角坐标为负，则不用绘制矩形的这一部分。如果矩形的左上角坐标为正，则在目标 BufferedImage 中的该位置绘制过滤后的图像。

如果源图像与目标图像相同，则抛出 IllegalArgumentException。

指定者：
接口 BufferedImageOp 中的 filter
参数：
src - 要转换的 BufferedImage。
dst - 要在其中存储转换结果的 BufferedImage。
返回：
过滤后的 BufferedImage。
抛出：
IllegalArgumentException - 如果 src 和 dst 相同
ImagingOpException - 如果由于无效的图像格式、tile 格式、图像处理操作或任何其他不受支持的操作引起的数据处理错误，导致该图像无法转换。

filter

public final WritableRaster filter(Raster src,
                                   WritableRaster dst)
转换源 Raster 并将结果存储在目标 Raster 中。此操作逐个 band 执行转换。

如果目标 Raster 为 null，则创建一个新的 Raster。如果源 Raster 与目标 Raster 相同，或者源 Raster 中的 band 数不等于目标 Raster 中的 band 数，则可能抛出 IllegalArgumentException。

由 getBounds2D(Raster) 返回的矩形坐标不一定与由此方法返回的 WritableRaster 的坐标相同。如果矩形的左上角坐标为负，则不用绘制矩形的这一部分。如果矩形的左上角坐标为正数，则在目标 Raster 中的该位置绘制过滤后的图像。

指定者：
接口 RasterOp 中的 filter
参数：
src - 要转换的 Raster。
dst - 要在其中存储转换结果的 Raster。
返回：
转换后的 Raster。
抛出：
ImagingOpException - 如果由于无效的图像格式、tile 格式、图像处理操作或任何其他不受支持的操作引起的数据处理错误，导致该 raster 无法转换。

getBounds2D

public final Rectangle2D getBounds2D(BufferedImage src)
返回转换后的目标图像的边界框。返回的矩形是转换后的点的实际边界框。返回矩形的左上角坐标不一定是 (0, 0)。

指定者：
接口 BufferedImageOp 中的 getBounds2D
参数：
src - 要转换的 BufferedImage。
返回：
表示目标图像边界框的 Rectangle2D。

getBounds2D

public final Rectangle2D getBounds2D(Raster src)
返回转换后的目标图像的边界框。返回的矩形将是转换后的点的实际边界框。返回矩形的左上角坐标不一定是 (0, 0)。

指定者：
接口 RasterOp 中的 getBounds2D
参数：
src - 要转换的 Raster。
返回：
表示目标图像边界框的 Rectangle2D。

createCompatibleDestImage

public BufferedImage createCompatibleDestImage(BufferedImage src,
                                               ColorModel destCM)
创建一个具有正确大小和 band 数的经过检查的目标图像。如果转换后的宽度和高度等于 0，则可能抛出 RasterFormatException。

如果 destCM 为 null，则使用合适的 ColorModel；即使源 ColorModel 是不透明的，此 ColorModel 也可能具有一个 alpha 通道。

指定者：
接口 BufferedImageOp 中的 createCompatibleDestImage
参数：
src - 要转换的 BufferedImage。
destCM - 目标 ColorModel。如果它为 null，则使用一个合适的 ColorModel。
返回：
经过检查的目标图像。

createCompatibleDestRaster

public WritableRaster createCompatibleDestRaster(Raster src)
创建一个具有正确大小和 band 数的经过检查的目标 Raster。如果转换后的宽度和高度等于 0，则可能抛出 RasterFormatException。

指定者：
接口 RasterOp 中的 createCompatibleDestRaster
参数：
src - 要转换的 Raster。
返回：
经过检查的目标 Raster。

getPoint2D

public final Point2D getPoint2D(Point2D srcPt,
                                Point2D dstPt)
返回与源图像中给定点对应的目标点的位置。如果指定了 dstPt，则使用它来保存返回值。

指定者：
接口 BufferedImageOp 中的 getPoint2D
指定者：
接口 RasterOp 中的 getPoint2D
参数：
srcPt - 表示源点 Point2D。
dstPt - 用于存储结果 Point2D。
返回：
与源图像中指定点对应的目标图像中的 Point2D。

getTransform

public final AffineTransform getTransform()
返回此转换操作使用的仿射转换。

返回：
与此操作关联的 AffineTransform。

getRenderingHints

public final RenderingHints getRenderingHints()
返回此转换操作使用的呈现提示。

指定者：
接口 BufferedImageOp 中的 getRenderingHints
指定者：
接口 RasterOp 中的 getRenderingHints
返回：
与此操作关联的 RenderingHints 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AreaAveragingScaleFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 AreaAveragingScaleFilter

java.lang.Object
    继承者  java.awt.image.ImageFilter
        继承者  java.awt.image.ReplicateScaleFilter
            继承者  java.awt.image.AreaAveragingScaleFilter
所有已实现的接口：
ImageConsumer, Cloneable
public class AreaAveragingScaleFilter
extends ReplicateScaleFilter

这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。

此类扩展 ImageFilter 基类来对现有图像进行缩放，并为包含重新取样图像的新图像提供一个源图像。源图像中的像素被混合以产生指定尺寸图像的像素。混合过程类似于以下过程：首先使用像素复制将源图像按比例放大为目标尺寸的若干倍，其后通过对落在目标图像给定像素内的超大尺寸图像中的所有像素简单地进行平均，将图像按比例缩小回目标尺寸。如果源数据不按 TopDownLeftRight 顺序传送，则过滤器将退回为一个简单的像素复制行为，并最终使用 requestTopDownLeftRightResend() 方法以一种更好的方式来重新过滤像素。

这意味着它可与 FilteredImageSource 对象联合使用，以生成现有图像的缩放版本。由于与实现相关，不同平台上过滤的图像像素值可能存在差异。

另请参见：
FilteredImageSource, ReplicateScaleFilter, ImageFilter

字段摘要
从类 java.awt.image.ReplicateScaleFilter 继承的字段
destHeight, destWidth, outpixbuf, srccols, srcHeight, srcrows, srcWidth
从类 java.awt.image.ImageFilter 继承的字段
consumer
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
AreaAveragingScaleFilter(int width, int height)
构造一个 AreaAveragingScaleFilter，它对由 width 和 height 参数所指定的源图像的像素进行缩放。
方法摘要
void | setHints(int hints) 检测数据是否正使用必要的提示进行传送，从而允许平均算法执行其功能。
void | setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 将已传送 byte 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
void | setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 将已传送 int 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
从类 java.awt.image.ReplicateScaleFilter 继承的方法
setDimensions, setProperties
从类 java.awt.image.ImageFilter 继承的方法
clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setColorModel
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AreaAveragingScaleFilter

public AreaAveragingScaleFilter(int width,
                                int height)
构造一个 AreaAveragingScaleFilter，它对由 width 和 height 参数所指定的源图像的像素进行缩放。

参数：
width - 要缩放图像的目标宽度
height - 要缩放图像的目标高度
方法详细信息

setHints

public void setHints(int hints)
检测数据是否正使用必要的提示进行传送，从而允许平均算法执行其功能。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setHints
覆盖：
类 ImageFilter 中的 setHints
参数：
hints - ImageConsumer 用于处理像素的提示集合
另请参见：
ImageConsumer.setHints(int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
将已传送 byte 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。如果在 setHints 的调用中没有指定正确的提示，则将工作转交给超类，不管何种传送提示，超类都可以对像素进行缩放。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ReplicateScaleFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ReplicateScaleFilter

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
将已传送 int 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。如果在 setHints 的调用中没有指定正确的提示，则将工作转交给超类，不管何种传送提示，超类都可以对像素进行缩放。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ReplicateScaleFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ReplicateScaleFilter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BandCombineOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 BandCombineOp

java.lang.Object
    继承者  java.awt.image.BandCombineOp
所有已实现的接口：
RasterOp
public class BandCombineOp
extends Object
implements RasterOp

此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。

矩阵的宽度必须等于源 Raster 中的 band 数（可以加一）。如果矩阵中的列数比 band 数多 1，则在 band 样本向量的结尾处存在一个隐含的 1，它表示一个像素。矩阵的高度必须等于目标图像中的 band 数。

例如，对于一个 band 数为 3 的 Raster，为了反转 Raster 的第二个 band，可以对每个像素应用以下变换。

   [ 1.0   0.0   0.0    0.0  ]     [ b1 ]
   [ 0.0  -1.0   0.0  255.0  ]  x  [ b2 ]
   [ 0.0   0.0   1.0    0.0  ]     [ b3 ]
                                   [ 1 ]

注意，源图像和目标图像可以是同一个对象。

构造方法摘要
BandCombineOp(float[][] matrix, RenderingHints hints)
构造一个具有指定矩阵的 BandCombineOp。
方法摘要
WritableRaster | createCompatibleDestRaster(Raster src) 创建一个经过检查的目标 Raster，它具有正确大小和 band 数。
WritableRaster | filter(Raster src, WritableRaster dst) 使用构造方法中指定的矩阵变换该 Raster。
Rectangle2D | getBounds2D(Raster src) 返回变换后目标图像的边界框。
float[][] | getMatrix() 返回线性组合矩阵的一个副本。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源 Raster 中给定点对应的目标点的位置。
RenderingHints | getRenderingHints() 返回针对此操作呈现的提示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BandCombineOp

public BandCombineOp(float[][] matrix,
                     RenderingHints hints)
构造一个具有指定矩阵的 BandCombineOp。矩阵的宽度必须等于源 Raster 中的 band 数（可以加一）。如果矩阵中的列数比 band 数多 1，则在 band 样本向量的结尾处存在一个隐含的 1，它表示一个像素。矩阵的高度必须等于目标图像中的 band 数。

第一个下标是行索引，第二个下标是列索引。此操作没有使用当前定义的呈现提示；RenderingHints 参数可以为 null。

参数：
matrix - 进行 band 组合操作要使用的矩阵。
hints - 用于此操作的 RenderingHints 对象。当前没有使用提示，因此它可以为 null。
方法详细信息

getMatrix

public final float[][] getMatrix()
返回线性组合矩阵的一个副本。

返回：
与此 band 组合操作关联的矩阵。

filter

public WritableRaster filter(Raster src,
                             WritableRaster dst)
使用构造方法中指定的矩阵变换该 Raster。如果源图像或目标图像中的 band 数与矩阵不一致，则抛出 IllegalArgumentException。有关更多详细信息，请参阅类注释。

如果目标图像为 null，则将创建它，使 band 数等于矩阵中的行数。即使该操作引起数据溢出，也不会抛出异常。

指定者：
接口 RasterOp 中的 filter
参数：
src - 要过滤的 Raster。
dst - 要在其中存储过滤操作结果的 Raster。
返回：
过滤后的 Raster。
抛出：
IllegalArgumentException - 如果源图像或目标图像中的 band 数与矩阵不一致。

getBounds2D

public final Rectangle2D getBounds2D(Raster src)
返回变换后目标图像的边界框。由于这不是一个几何操作，因此源图像和目标图像的边界框相同。如果源图像中的 band 数与矩阵不一致，则抛出 IllegalArgumentException。有关更多详细信息，请参阅类注释。

指定者：
接口 RasterOp 中的 getBounds2D
参数：
src - 要过滤的 Raster。
返回：
表示目标图像边界框的 Rectangle2D。
抛出：
IllegalArgumentException - 如果源图像中的 band 数与矩阵不一致。

createCompatibleDestRaster

public WritableRaster createCompatibleDestRaster(Raster src)
创建一个经过检查的目标 Raster，它具有正确大小和 band 数。如果源图像中的 band 数与矩阵不一致，则抛出 IllegalArgumentException。有关更多详细信息，请参阅类注释。

指定者：
接口 RasterOp 中的 createCompatibleDestRaster
参数：
src - 要过滤的 Raster。
返回：
经过检查的目标 Raster。

getPoint2D

public final Point2D getPoint2D(Point2D srcPt,
                                Point2D dstPt)
返回与源 Raster 中给定点对应的目标点的位置。如果指定了 dstPt，则使用它来保存返回值。由于这不是一个几何操作，因此返回的点与指定的 srcPt 相同。

指定者：
接口 RasterOp 中的 getPoint2D
参数：
srcPt - 表示源 Raster 中点的 Point2D
dstPt - 用于存储结果的 Point2D。
返回：
与源图像中指定点对应的目标图像中的 Point2D。

getRenderingHints

public final RenderingHints getRenderingHints()
返回针对此操作呈现的提示。

指定者：
接口 RasterOp 中的 getRenderingHints
返回：
与此操作关联的 RenderingHints 对象。如果没有设置提示，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BandedSampleModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 BandedSampleModel

java.lang.Object
    继承者  java.awt.image.SampleModel
        继承者  java.awt.image.ComponentSampleModel
            继承者  java.awt.image.BandedSampleModel

public final class BandedSampleModel
extends ComponentSampleModel

此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。此类是 ComponentSampleModel 的子类，但是对于访问 band 交错图像数据来说，它提供的实现比 ComponentSampleModel 提供的实现更有效。当处理存储在不同 DataBuffer 存储单元中每个 band 样本数据的图像时，通常应该使用此类。由于提供了存取方法，因此可以直接对图像数据进行操作。像素间距是同一 扫描行上同一 band 的两个样本之间的数据数组元素数。BandedSampleModel 的像素间距为 1。扫描行间距是给定样本与下一扫描行的同一列中对应样本之间的数据数组元素数。band 偏移量表示从保存每个 band 的 DataBuffer 存储单元第一个数据数组元素到 band 第一个样本之间的数据数组元素数。这些 band 从 0 到 N-1 进行编号。存储单元索引表示数据缓冲区存储单元与图像数据 band 之间的对应关系。此类支持 TYPE_BYTE、TYPE_USHORT、TYPE_SHORT、TYPE_INT、TYPE_FLOAT 和 TYPE_DOUBLE 数据类型。

字段摘要
从类 java.awt.image.ComponentSampleModel 继承的字段
bandOffsets, bankIndices, numBands, numBanks, pixelStride, scanlineStride
从类 java.awt.image.SampleModel 继承的字段
dataType, height, width
构造方法摘要
BandedSampleModel(int dataType, int w, int h, int numBands)
构造一个具有指定参数的 BandedSampleModel。
BandedSampleModel(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets)
构造一个具有指定参数的 BandedSampleModel。
方法摘要
SampleModel | createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的新的 BandedSampleModel。
DataBuffer | createDataBuffer() 创建一个与此 BandedSampleModel 对应的 DataBuffer，该 DataBuffer 的数据类型、存储单元数和大小都将与此 BandedSampleModel 一致。
SampleModel | createSubsetSampleModel(int[] bands) 创建一个具有此 BandedSampleModel 的 band 子集的新 BandedSampleModel。
Object | getDataElements(int x, int y, Object obj, DataBuffer data) 在 TransferType 类型基本数组中返回单个像素的数据。
int[] | getPixel(int x, int y, int[] iArray, DataBuffer data) 在 int 数组中返回指定像素的所有样本。
int[] | getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在 int 数组中返回指定像素矩形的所有样本，每个数据数组元素对应一个样本。
int | getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
int[] | getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数据数组元素对应一个样本。
int | hashCode() 返回该对象的哈希码值。
void | setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置对应于像素矩形的所有样本，int 数组中每个数组元素包含一个样本。
void | setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，int 数组中每个数据数组元素包含一个样本。
从类 java.awt.image.ComponentSampleModel 继承的方法
equals, getBandOffsets, getBankIndices, getNumDataElements, getOffset, getOffset, getPixelStride, getSampleSize, getSampleSize, getScanlineStride
从类 java.awt.image.SampleModel 继承的方法
getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSamples, setSamples
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BandedSampleModel

public BandedSampleModel(int dataType,
                         int w,
                         int h,
                         int numBands)
构造一个具有指定参数的 BandedSampleModel。像素间距将为一个数据元素。扫描行间距与宽度相同。每个 band 都存储在一个单独的存储单元中，所有 band 偏移量都为零。

参数：
dataType - 存储样本的数据类型。
w - 所描述的图像数据区域的宽度（以像素为单位）。
h - 所描述的图像数据区域的高度（以像素为单位）。
numBands - 图像数据的 band 数。
抛出：
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一

BandedSampleModel

public BandedSampleModel(int dataType,
                         int w,
                         int h,
                         int scanlineStride,
                         int[] bankIndices,
                         int[] bandOffsets)
构造一个具有指定参数的 BandedSampleModel。可以从 bandOffsets bankIndices 数组的长度推断 band 数，它们必须相等。像素间距将为一个数据元素。

参数：
dataType - 存储样本的数据类型。
w - 所描述的图像数据区域的宽度（以像素为单位）。
h - 所描述的图像数据区域的高度（以像素为单位）。
scanlineStride - 图像数据的行间距。
bankIndices - 每个 band 的存储单元索引。
bandOffsets - 每个 band 的 band 偏移量。
抛出：
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一
方法详细信息

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
创建一个具有指定宽度和高度的新的 BandedSampleModel。新 BandedSampleModel 将具有与此 BandedSampleModel 相同的 band 数、存储数据类型和存储单元索引。band 偏移量将被压缩，使得 band 之间的偏移量为 w*pixelStride，并且所有 band 偏移量的最小值为零。

覆盖：
类 ComponentSampleModel 中的 createCompatibleSampleModel
参数：
w - 得到的 BandedSampleModel 的宽度
h - 得到的 BandedSampleModel 的高度
返回：
具有指定宽度和高度的新 BandedSampleModel。
抛出：
IllegalArgumentException - 如果 w 或 h 等于 Integer.MAX_VALUE 或 Integer.MIN_VALUE
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一

createSubsetSampleModel

public SampleModel createSubsetSampleModel(int[] bands)
创建一个具有此 BandedSampleModel 的 band 子集的新 BandedSampleModel。新的 BandedSampleModel 可以与任何使用现有 BandedSampleModel 的 DataBuffer 一起使用。新的 BandedSampleModel/DataBuffer 组合将表示一个具有原 BandedSampleModel/DataBuffer 组合 band 子集的图像。

覆盖：
类 ComponentSampleModel 中的 createSubsetSampleModel
参数：
bands - 此 ComponentSampleModel 的 band 子集
返回：
已创建的具有此 ComponentSampleModel band 子集的 ComponentSampleModel。
抛出：
RasterFormatException - 如果 band 数大于此样本模型中的存储单元数。
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一

createDataBuffer

public DataBuffer createDataBuffer()
创建一个与此 BandedSampleModel 对应的 DataBuffer，该 DataBuffer 的数据类型、存储单元数和大小都将与此 BandedSampleModel 一致。

覆盖：
类 ComponentSampleModel 中的 createDataBuffer
返回：
数据类型、存储单元的数量和大小与此 ComponentSampleModel 一致的 DataBuffer。
抛出：
IllegalArgumentException - 如果 dataType 不是受支持的类型之一。

getDataElements

public Object getDataElements(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
在 TransferType 类型基本数组中返回单个像素的数据。对于 BandedSampleModel，返回的数据与 data 类型相同，并将对每个数组元素返回一个样本。通常，obj 作为 null 传入，从而 Object 将被自动创建，并具有正确的基本数据类型。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 BandedSampleModel bsm1 描述）传输到 DataBuffer db2（其存储布局由 BandedSampleModel bsm2 描述）。通常，该传输比使用 getPixel/setPixel 方法更高效。

             BandedSampleModel bsm1, bsm2;
             DataBufferInt db1, db2;
             bsm2.setDataElements(x, y, bsm1.getDataElements(x, y, null, db1),
                            db2);
如果两个 SampleModel 具有相同的 band 数，相应 band 的每个样本具有相同的位数，且 TransferType 相同，则使用 getDataElements/setDataElements 在这两个 DataBuffer/SampleModel 对之间传输数据是合法的。

如果 obj 不为 null，则它应该是一个 TransferType 类型基本数组。否则抛出 ClassCastException。如果坐标不在边界内部，或者 obj 不为 null 且大小不足以容纳像素数据，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 getDataElements
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
obj - 如果不为 null，则为一个接收返回像素数据的基本数组。
data - 包含图像数据的 DataBuffer。
返回：
指定像素的数据。
另请参见：
setDataElements(int, int, Object, DataBuffer)

getPixel

public int[] getPixel(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
在 int 数组中返回指定像素的所有样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 getPixel
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - 如果不为 null，则在此数组中返回样本
data - 包含图像数据的 DataBuffer
返回：
指定像素的样本。
另请参见：
setPixel(int, int, int[], DataBuffer)

getPixels

public int[] getPixels(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
在 int 数组中返回指定像素矩形的所有样本，每个数据数组元素对应一个样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 getPixels
参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
iArray - 如果不为 null，则在此数组中返回样本
data - 包含图像数据的 DataBuffer
返回：
指定区域中像素的样本。
另请参见：
setPixels(int, int, int, int, int[], DataBuffer)

getSample

public int getSample(int x,
                     int y,
                     int b,
                     DataBuffer data)
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 getSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
data - 包含图像数据的 DataBuffer
返回：
指定 band 中对应于指定像素的样本。
另请参见：
setSample(int, int, int, int, DataBuffer)

getSampleFloat

public float getSampleFloat(int x,
                            int y,
                            int b,
                            DataBuffer data)
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 getSampleFloat
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
data - 包含图像数据的 DataBuffer
返回：
一个 float 值，表示指定 band 中对应于指定像素的样本。

getSampleDouble

public double getSampleDouble(int x,
                              int y,
                              int b,
                              DataBuffer data)
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 getSampleDouble
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
data - 包含图像数据的 DataBuffer
返回：
一个 double 值，表示指定 band 中对应于指定像素的样本。

getSamples

public int[] getSamples(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
在 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数据数组元素对应一个样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 getSamples
参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
b - 要返回的 band
iArray - 如果不为 null，则返回此数组中的样本
data - 包含图像数据的 DataBuffer
返回：
指定 band 中对应于指定区域内像素的样本。
另请参见：
setSamples(int, int, int, int, int, int[], DataBuffer)

setDataElements

public void setDataElements(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。对于 BandedSampleModel，设置的数据与 data 类型相同，且每个数组元素传输一个样本。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 BandedSampleModel bsm1 描述）传输到 DataBuffer db2（其存储布局由 BandedSampleModel bsm2 描述）。通常，该传输比使用 getPixel/setPixel 更高效。

             BandedSampleModel bsm1, bsm2;
             DataBufferInt db1, db2;
             bsm2.setDataElements(x, y, bsm1.getDataElements(x, y, null, db1),
                            db2);
如果两个 SampleModels 具有相同的 band 数，相应 band 的每个样本具有相同的位数，且 TransferTypes 相同，则使用 getDataElements/setDataElements 在这两个 DataBuffer/SampleModel 对之间传输数据是合法的。

obj 必须是一个 TransferType 类型基本数组。否则抛出 ClassCastException。如果坐标不在边界内部，或者 obj 的大小不足以容纳像素数据，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 setDataElements
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
obj - 如果不为 null，则返回此对象中的基本数组
data - 包含图像数据的 DataBuffer
另请参见：
getDataElements(int, int, Object, DataBuffer)

setPixel

public void setPixel(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
使用输入样本的 int 数组设置 DataBuffer 中的像素。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 setPixel
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - int 数组中的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getPixel(int, int, int[], DataBuffer)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
根据 int 数组设置对应于像素矩形的所有样本，int 数组中每个数组元素包含一个样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 setPixels
参数：
x - 像素位置左上角的 X 坐标
y - 像素位置左上角的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
iArray - int 数组中的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getPixels(int, int, int, int, int[], DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
使用输入的 int 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 setSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要设置的 band
s - 输入的样本（int 形式）
data - 包含图像数据的 DataBuffer
另请参见：
getSample(int, int, int, DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      float s,
                      DataBuffer data)
使用输入的 float 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 setSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要设置的 band
s - 输入的样本（float 形式）
data - 包含图像数据的 DataBuffer
另请参见：
getSample(int, int, int, DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      double s,
                      DataBuffer data)
使用输入的 double 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 setSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要设置的 band
s - 输入的样本（为一个 double 值）
data - 包含图像数据的 DataBuffer
另请参见：
getSample(int, int, int, DataBuffer)

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，int 数组中每个数据数组元素包含一个样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ComponentSampleModel 中的 setSamples
参数：
x - 像素位置左上角的 X 坐标
y - 像素位置左上角的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
b - 要设置的 band
iArray - 输入的样本数组
data - 包含图像数据的 DataBuffer
另请参见：
getSamples(int, int, int, int, int, int[], DataBuffer)

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 ComponentSampleModel 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferedImage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 BufferedImage

java.lang.Object
    继承者  java.awt.Image
        继承者  java.awt.image.BufferedImage
所有已实现的接口：
RenderedImage, WritableRenderedImage, Transparency
public class BufferedImage
extends Image
implements WritableRenderedImage, Transparency

BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。BufferedImage 由图像数据的 ColorModel 和 Raster 组成。Raster 的 SampleModel 中 band 的数量和类型必须与 ColorModel 所要求的数量和类型相匹配，以表示其颜色和 alpha 分量。所有 BufferedImage 对象的左上角坐标都为 (0, 0)。因此，用来构造 BufferedImage 的任何 Raster 都必须满足：minX=0 且 minY=0。

此类依靠 Raster 的数据获取方法、数据设置方法，以及 ColorModel 的颜色特征化方法。

另请参见：
ColorModel, Raster, WritableRaster

字段摘要
static int | TYPE_3BYTE_BGR 表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 风格的 BGR 颜色模型，具有用 3 字节存储的 Blue、Green 和 Red 三种颜色。
static int | TYPE_4BYTE_ABGR 表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。
static int | TYPE_4BYTE_ABGR_PRE 表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。
static int | TYPE_BYTE_BINARY 表示一个不透明的以字节打包的 1、2 或 4 位图像。
static int | TYPE_BYTE_GRAY 表示无符号 byte 灰度级图像（无索引）。
static int | TYPE_BYTE_INDEXED 表示带索引的字节图像。
static int | TYPE_CUSTOM 没有识别出图像类型，因此它必定是一个自定义图像。
static int | TYPE_INT_ARGB 表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。
static int | TYPE_INT_ARGB_PRE 表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。
static int | TYPE_INT_BGR 表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 或 Solaris 风格的 BGR 颜色模型，具有打包为整数像素的 Blue、Green 和 Red 三种颜色。
static int | TYPE_INT_RGB 表示一个图像，它具有合成整数像素的 8 位 RGB 颜色分量。
static int | TYPE_USHORT_555_RGB 表示一个具有 5-5-5 RGB 颜色分量（5 位 red、5 位 green、5 位 blue）的图像，不带 alpha。
static int | TYPE_USHORT_565_RGB 表示一个具有 5-6-5 RGB 颜色分量（5 位 red、6 位 green、5 位 blue）的图像，不带 alpha。
static int | TYPE_USHORT_GRAY 表示一个无符号 short 灰度级图像（无索引）。
从类 java.awt.Image 继承的字段
accelerationPriority, SCALE_AREA_AVERAGING, SCALE_DEFAULT, SCALE_FAST, SCALE_REPLICATE, SCALE_SMOOTH, UndefinedProperty
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
BufferedImage(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
BufferedImage(int width, int height, int imageType)
构造一个类型为预定义图像类型之一的 BufferedImage。
BufferedImage(int width, int height, int imageType, IndexColorModel cm)
构造一个类型为预定义图像类型之一的 BufferedImage：TYPE_BYTE_BINARY 或 TYPE_BYTE_INDEXED。
方法摘要
void | addTileObserver(TileObserver to) 添加一个 tile observer。
void | coerceData(boolean isAlphaPremultiplied) 强制该数据与 isAlphaPremultiplied 变量中指定的状态相匹配。
WritableRaster | copyData(WritableRaster outRaster) 计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。
Graphics2D | createGraphics() 创建一个 Graphics2D，可以将它绘制到此 BufferedImage 中。
WritableRaster | getAlphaRaster() 返回一个 WritableRaster，它使用支持单独空间 alpha 通道的 ColorModel 对象（比如 ComponentColorModel 和 DirectColorModel）表示 BufferedImage 对象的 alpha 通道。
ColorModel | getColorModel() 返回 ColorModel。
Raster | getData() 以一个大 tile 的形式返回图像。
Raster | getData(Rectangle rect) 计算并返回 BufferedImage 的一个任意区域。
Graphics | getGraphics() 此方法返回 Graphics2D，但此处是出于向后兼容性的考虑。
int | getHeight() 返回 BufferedImage 的高度。
int | getHeight(ImageObserver observer) 返回 BufferedImage 的高度。
int | getMinTileX() 返回 x 方向的最小 tile 索引。
int | getMinTileY() 返回 y 方向的最小 tile 索引。
int | getMinX() 返回此 BufferedImage 的最小 x 坐标。
int | getMinY() 返回此 BufferedImage 的最小 y 坐标。
int | getNumXTiles() 返回 x 方向的 tile 数。
int | getNumYTiles() 返回 y 方向的 tile 数。
Object | getProperty(String name) 按名称返回图像的属性。
Object | getProperty(String name, ImageObserver observer) 按名称返回图像的属性。
String[] | getPropertyNames() 返回由 getProperty(String) 识别的名称数组；如果没有识别出属性名，则返回 null。
WritableRaster | getRaster() 返回 WritableRaster。
int | getRGB(int x, int y) 返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素。
int[] | getRGB(int startX, int startY, int w, int h, int[] rgbArray, int offset, int scansize) 从图像数据的某一部分返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中整数像素数组。
SampleModel | getSampleModel() 返回与此 BufferedImage 关联的 SampleModel。
ImageProducer | getSource() 返回生成该图像像素的对象。
Vector<RenderedImage> | getSources() 返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。
BufferedImage | getSubimage(int x, int y, int w, int h) 返回由指定矩形区域定义的子图像。
Raster | getTile(int tileX, int tileY) 返回 tile (tileX, tileY)。
int | getTileGridXOffset() 返回 tile 网格相对于原点的 x 偏移量（例如，tile (0, 0) 位置的 x 坐标）。
int | getTileGridYOffset() 返回 tile 网格相对于原点的 y 偏移量（例如，tile (0, 0) 位置的 y 坐标）。
int | getTileHeight() 返回 tile 高度（以像素为单位）。
int | getTileWidth() 返回 tile 宽度（以像素为单位）。
int | getTransparency() 返回透明度。
int | getType() 返回图像类型。
int | getWidth() 返回 BufferedImage 的宽度。
int | getWidth(ImageObserver observer) 返回 BufferedImage 的宽度。
WritableRaster | getWritableTile(int tileX, int tileY) 为写入签出一个 tile。
Point[] | getWritableTileIndices() 返回 Point 对象的数组，它指示为写入签出了哪些 tile。
boolean | hasTileWriters() 返回是否有为写入签出的 tile。
boolean | isAlphaPremultiplied() 返回是否已预乘以 alpha。
boolean | isTileWritable(int tileX, int tileY) 返回当前是否为写入签出 tile。
void | releaseWritableTile(int tileX, int tileY) 放弃写入一个 tile 的权限。
void | removeTileObserver(TileObserver to) 移除一个 tile observer。
void | setData(Raster r) 将图像的矩形区域设置为指定 Raster r 的内容，假定该区域与 BufferedImage 处于相同的坐标空间。
void | setRGB(int x, int y, int rgb) 将此 BufferedImage 中的像素设置为指定的 RGB 值。
void | setRGB(int startX, int startY, int w, int h, int[] rgbArray, int offset, int scansize) 将默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素数组设置为图像数据的一部分。
String | toString() 返回此 BufferedImage 对象及其值的 String 表示形式。
从类 java.awt.Image 继承的方法
flush, getAccelerationPriority, getCapabilities, getScaledInstance, setAccelerationPriority
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

TYPE_CUSTOM

public static final int TYPE_CUSTOM
没有识别出图像类型，因此它必定是一个自定义图像。此类型仅用作 getType() 方法的返回值。

另请参见：
常量字段值

TYPE_INT_RGB

public static final int TYPE_INT_RGB
表示一个图像，它具有合成整数像素的 8 位 RGB 颜色分量。该图像具有不带 alpha 的 DirectColorModel。当具有透明 alpha 的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃 alpha，如 AlphaComposite 文档中的描述。

另请参见：
常量字段值

TYPE_INT_ARGB

public static final int TYPE_INT_ARGB
表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。该图像具有带 alpha 的 DirectColorModel。认为此图像中的颜色数据没有预乘以 alpha。当使用此类型作为 BufferedImage 构造方法的 imageType 参数时，所创建的图像与 JDK1.1 和更早期版本中创建的图像一致。

另请参见：
常量字段值

TYPE_INT_ARGB_PRE

public static final int TYPE_INT_ARGB_PRE
表示一个图像，它具有合成整数像素的 8 位 RGBA 颜色分量。该图像具有带 alpha 的 DirectColorModel。认为此图像中的颜色数据已预乘以 alpha。

另请参见：
常量字段值

TYPE_INT_BGR

public static final int TYPE_INT_BGR
表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 或 Solaris 风格的 BGR 颜色模型，具有打包为整数像素的 Blue、Green 和 Red 三种颜色。不存在 alpha。该图像具有一个 DirectColorModel。当具有透明 alpha 的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃 alpha，如 AlphaComposite 文档中的描述。

另请参见：
常量字段值

TYPE_3BYTE_BGR

public static final int TYPE_3BYTE_BGR
表示一个具有 8 位 RGB 颜色分量的图像，对应于 Windows 风格的 BGR 颜色模型，具有用 3 字节存储的 Blue、Green 和 Red 三种颜色。不存在 alpha。该图像具有一个 ComponentColorModel。当具有透明 alpha 的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃 alpha，如 AlphaComposite 文档中的描述。

另请参见：
常量字段值

TYPE_4BYTE_ABGR

public static final int TYPE_4BYTE_ABGR
表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。该图像具有带 alpha 的 ComponentColorModel。认为此图像中的颜色数据没有预乘以 alpha。按照每个像素中字节地址从低到高的顺序 A、B、G、R 将字节数据插入单个字节数组中。

另请参见：
常量字段值

TYPE_4BYTE_ABGR_PRE

public static final int TYPE_4BYTE_ABGR_PRE
表示一个具有 8 位 RGBA 颜色分量的图像，具有用 3 字节存储的 Blue、Green 和 Red 颜色以及 1 字节的 alpha。该图像具有带 alpha 的 ComponentColorModel。认为此图像中的颜色数据已预乘以 alpha。按照每个像素中字节地址从低到高的顺序 A、B、G、R 将字节数据插入单个字节数组中。

另请参见：
常量字段值

TYPE_USHORT_565_RGB

public static final int TYPE_USHORT_565_RGB
表示一个具有 5-6-5 RGB 颜色分量（5 位 red、6 位 green、5 位 blue）的图像，不带 alpha。该图像具有一个 DirectColorModel。当具有透明 alpha 的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃 alpha，如 AlphaComposite 文档中的描述。

另请参见：
常量字段值

TYPE_USHORT_555_RGB

public static final int TYPE_USHORT_555_RGB
表示一个具有 5-5-5 RGB 颜色分量（5 位 red、5 位 green、5 位 blue）的图像，不带 alpha。此图像具有一个 DirectColorModel。当具有透明 alpha 的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃 alpha，如 AlphaComposite 文档中的描述。

另请参见：
常量字段值

TYPE_BYTE_GRAY

public static final int TYPE_BYTE_GRAY
表示无符号 byte 灰度级图像（无索引）。该图像具有带 CS_GRAY ColorSpace 的 ComponentColorModel。当具有透明 alpha 的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃 alpha，如 AlphaComposite 文档中的描述。

另请参见：
常量字段值

TYPE_USHORT_GRAY

public static final int TYPE_USHORT_GRAY
表示一个无符号 short 灰度级图像（无索引）。该图像具有带 CS_GRAY ColorSpace 的 ComponentColorModel。当具有透明 alpha 的数据存储在此类型的图像中时，必须将颜色数据调整为非预乘形式并丢弃 alpha，如 AlphaComposite 文档中的描述。

另请参见：
常量字段值

TYPE_BYTE_BINARY

public static final int TYPE_BYTE_BINARY
表示一个不透明的以字节打包的 1、2 或 4 位图像。该图像具有不带 alpha 的 IndexColorModel。当此类型用作 BufferedImage 构造方法（带 imageType 参数而不是 ColorModel 参数）的 imageType 参数时，创建一个 1 位图像，且其 IndexColorModel 具有默认 sRGB ColorSpace 中的两种颜色：{0, 0, 0} 和 {255, 255, 255}。

每个像素 2 位或 4 位的图像可以通过 BufferedImage 构造方法构造，该构造方法带一个 ColorModel 参数，这通过提供一个具有合适映射大小的 ColorModel 实现。

每个像素 8 位的图像应该使用 TYPE_BYTE_INDEXED 或 TYPE_BYTE_GRAY 图像类型，具体取决于它们的 ColorModel。

当颜色数据存储在此类型的图像中时，由 IndexColorModel 确定 colormap 中最接近的颜色，并存储得到的索引。根据 IndexColorModel colormap 中的颜色，可以得到 alpha 分量或颜色分量的近似值及丢失的 alpha 或颜色分量。

另请参见：
常量字段值

TYPE_BYTE_INDEXED

public static final int TYPE_BYTE_INDEXED
表示带索引的字节图像。当此类型用作 BufferedImage 构造方法（带 imageType 参数而不带 ColorModel 参数 ）的 imageType 参数时，创建一个 IndexColorModel，它具有 256 色 6/6/6 三色调色板，其余从 216 到 255 的颜色由默认 sRGB ColorSpace 的灰度级值填充。

当颜色数据存储在此类型的图像中时，由 IndexColorModel 确定 colormap 中最接近的颜色，并存储得到的索引。根据 IndexColorModel colormap 中的颜色，可以得到 alpha 分量或颜色分量的近似值及丢失的 alpha 或颜色分量。

另请参见：
常量字段值
构造方法详细信息

BufferedImage

public BufferedImage(int width,
                     int height,
                     int imageType)
构造一个类型为预定义图像类型之一的 BufferedImage。该图像的 ColorSpace 为默认的 sRGB 空间。

参数：
width - 所创建图像的宽度
height - 所创建图像的高度
imageType - 所创建图像的类型
另请参见：
ColorSpace, TYPE_INT_RGB, TYPE_INT_ARGB, TYPE_INT_ARGB_PRE, TYPE_INT_BGR, TYPE_3BYTE_BGR, TYPE_4BYTE_ABGR, TYPE_4BYTE_ABGR_PRE, TYPE_BYTE_GRAY, TYPE_USHORT_GRAY, TYPE_BYTE_BINARY, TYPE_BYTE_INDEXED, TYPE_USHORT_565_RGB, TYPE_USHORT_555_RGB

BufferedImage

public BufferedImage(int width,
                     int height,
                     int imageType,
                     IndexColorModel cm)
构造一个类型为预定义图像类型之一的 BufferedImage：TYPE_BYTE_BINARY 或 TYPE_BYTE_INDEXED。

如果图像类型为 TYPE_BYTE_BINARY，则使用颜色模型中的条目数确定图像的每像素具有 1、2 还是 4 位。如果颜色模型具有 1 或 2 个条目，则该图像每像素具有 1 位。如果颜色模型具有 3 或 4 个条目，则该图像的每像素具有 2 位。如果颜色模型的条目数在 5 到 16 之间，则该图像的每像素具有 4 位。否则，将抛出 IllegalArgumentException。

参数：
width - 所创建图像的宽度
height - 所创建图像的高度
imageType - 所创建图像的类型
cm - 所创建图像的 IndexColorModel
抛出：
IllegalArgumentException - 如果 imageType 不为 TYPE_BYTE_BINARY 或 TYPE_BYTE_INDEXED，或者 imageType 为 TYPE_BYTE_BINARY 且颜色映射的条目数大于 16。
另请参见：
TYPE_BYTE_BINARY, TYPE_BYTE_INDEXED

BufferedImage

public BufferedImage(ColorModel cm,
                     WritableRaster raster,
                     boolean isRasterPremultiplied,
                     Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。如果 Raster 的 SampleModel 中 band 的数量和类型与 ColorModel（表示其颜色和 alpha 分量）所要求的数量和类型不匹配，则抛出 RasterFormatException。此方法可以将 Raster 颜色数据乘以或除以 alpha，以匹配 ColorModel 中的 alphaPremultiplied 状态。可以通过传入 String/Object 对的 Hashtable 建立此 BufferedImage 的属性。

参数：
cm - 新图像的 ColorModel
raster - 图像数据的 Raster
isRasterPremultiplied - 如果为 true，则 raster 中的数据已预乘以 alpha。
properties - String/Object 对的 Hashtable。
抛出：
RasterFormatException - 如果 Raster 的 SampleModel 中 band 的数量和类型与 ColorModel（表示其颜色和 alpha 分量）所要求的数量和类型不匹配。
IllegalArgumentException - 如果 raster 与 cm 不一致
另请参见：
ColorModel, Raster, WritableRaster
方法详细信息

getType

public int getType()
返回图像类型。如果它不是已知的类型之一，则返回 TYPE_CUSTOM 。

返回：
此 BufferedImage 的图像类型。
另请参见：
TYPE_INT_RGB, TYPE_INT_ARGB, TYPE_INT_ARGB_PRE, TYPE_INT_BGR, TYPE_3BYTE_BGR, TYPE_4BYTE_ABGR, TYPE_4BYTE_ABGR_PRE, TYPE_BYTE_GRAY, TYPE_BYTE_BINARY, TYPE_BYTE_INDEXED, TYPE_USHORT_GRAY, TYPE_USHORT_565_RGB, TYPE_USHORT_555_RGB, TYPE_CUSTOM

getColorModel

public ColorModel getColorModel()
返回 ColorModel。

指定者：
接口 RenderedImage 中的 getColorModel
返回：
此 BufferedImage 的 ColorModel。

getRaster

public WritableRaster getRaster()
返回 WritableRaster。

返回：
此 BufferedImage 的 WriteableRaster。

getAlphaRaster

public WritableRaster getAlphaRaster()
返回一个 WritableRaster，它使用支持单独空间 alpha 通道的 ColorModel 对象（比如 ComponentColorModel 和 DirectColorModel）表示 BufferedImage 对象的 alpha 通道。如果此图像中没有与 ColorModel 关联的 alpha 通道，则返回 null。此方法假定 IndexColorModel 之外的所有 ColorModel 对象都具有一个单独的 alpha 通道（如果 ColorModel 支持 alpha），该通道存储为图像数据的最后一个 band。如果该图像使用查找表中一个具有 alpha 的 IndexColorModel，则此方法返回 null，因为不存在空间上离散的 alpha 通道。此方法创建一个新的 WritableRaster，但是共享原数据数组。

返回：
WritableRaster；如果此 BufferedImage 不具有与其 ColorModel 关联的 alpha 通道，则返回 null。

getRGB

public int getRGB(int x,
                  int y)
返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素。如果此默认模型与该图像的 ColorModel 不匹配，则发生颜色转换。在使用此方法所返回的数据中，每个颜色分量只有 8 位精度。

如果坐标不在边界内部，则抛出 ArrayOutOfBoundsException。但是，不保证进行显式的边界检查。

参数：
x - 像素的 X 坐标，从该坐标可以得到默认 RGB 颜色模型和 sRGB 颜色空间中的像素
y - 像素的 Y 坐标，从该坐标可以得到默认 RGB 颜色模型和 sRGB 颜色空间中的像素
返回：
默认 RGB 颜色模型和默认 sRGB 颜色空间中的整数像素。
另请参见：
setRGB(int, int, int), setRGB(int, int, int, int, int[], int, int)

getRGB

public int[] getRGB(int startX,
                    int startY,
                    int w,
                    int h,
                    int[] rgbArray,
                    int offset,
                    int scansize)
从图像数据的某一部分返回默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中整数像素数组。如果该默认模型与该图像的 ColorModel 不匹配，则发生颜色转换。在使用此方法所返回的数据中，每个颜色分量只有 8 位精度。通过图像中指定的坐标 (x, y)，ARGB 像素可以按如下方式访问：

    pixel   = rgbArray[offset + (y-startY)*scansize + (x-startX)];

如果该区域不在边界内部，则抛出 ArrayOutOfBoundsException。但是，不保证进行显式的边界检查。

参数：
startX - 起始 X 坐标
startY - 起始 Y 坐标
w - 区域的宽度
h - 区域的高度
rgbArray - 如果不为 null，则在此写入 rgb 像素
offset - rgbArray 中的偏移量
scansize - rgbArray 的扫描行间距
返回：
RGB 像素数组。
另请参见：
setRGB(int, int, int), setRGB(int, int, int, int, int[], int, int)

setRGB

public void setRGB(int x,
                   int y,
                   int rgb)
将此 BufferedImage 中的像素设置为指定的 RGB 值。假定该像素使用默认 RGB 颜色模型、TYPE_INT_ARGB 和默认 sRGB 颜色空间。对于具有 IndexColorModel 的图像，则选择最接近的颜色的索引。

如果坐标不在边界内部，则抛出 ArrayOutOfBoundsException。但是，不保证进行显式的边界检查。

参数：
x - 要设置的像素的 X 坐标
y - 要设置的像素的 Y 坐标
rgb - RGB 值
另请参见：
getRGB(int, int), getRGB(int, int, int, int, int[], int, int)

setRGB

public void setRGB(int startX,
                   int startY,
                   int w,
                   int h,
                   int[] rgbArray,
                   int offset,
                   int scansize)
将默认 RGB 颜色模型 (TYPE_INT_ARGB) 和默认 sRGB 颜色空间中的整数像素数组设置为图像数据的一部分。如果该默认模型与该图像的 ColorModel 不匹配，则发生颜色转换。在使用此方法所返回的数据中，每个颜色分量只有 8 位精度。通过此图像中指定的坐标 (x, y)，ARGB 像素可以按如下方式访问：
    pixel   = rgbArray[offset + (y-startY)*scansize + (x-startX)];
警告：无抖动发生。

如果该区域不在边界内部，则抛出 ArrayOutOfBoundsException。但是，不保证进行显式的边界检查。

参数：
startX - 起始 X 坐标
startY - 起始 Y 坐标
w - 区域的宽度
h - 区域的高度
rgbArray - rgb 像素
offset - rgbArray 中的偏移量
scansize - rgbArray 的扫描行间距
另请参见：
getRGB(int, int), getRGB(int, int, int, int, int[], int, int)

getWidth

public int getWidth()
返回 BufferedImage 的宽度。

指定者：
接口 RenderedImage 中的 getWidth
返回：
此 BufferedImage 的宽度

getHeight

public int getHeight()
返回 BufferedImage 的高度。

指定者：
接口 RenderedImage 中的 getHeight
返回：
此 BufferedImage 的高度

getWidth

public int getWidth(ImageObserver observer)
返回 BufferedImage 的宽度。

指定者：
类 Image 中的 getWidth
参数：
observer - 忽略
返回：
此 BufferedImage 的宽度
另请参见：
Image.getHeight(java.awt.image.ImageObserver), ImageObserver

getHeight

public int getHeight(ImageObserver observer)
返回 BufferedImage 的高度。

指定者：
类 Image 中的 getHeight
参数：
observer - 忽略
返回：
此 BufferedImage 的高度
另请参见：
Image.getWidth(java.awt.image.ImageObserver), ImageObserver

getSource

public ImageProducer getSource()
返回生成该图像像素的对象。

指定者：
类 Image 中的 getSource
返回：
用于生成该图像像素的 ImageProducer。
另请参见：
ImageProducer

getProperty

public Object getProperty(String name,
                          ImageObserver observer)
按名称返回图像的属性。个别属性名可用各种图像格式定义。如果属性不是为特定图像定义的，则此方法返回 UndefinedProperty 字段。如果此图像的属性目前未知，则此方法返回 null，然后通知 ImageObserver 对象。属性名 "comment" 应该用于存储可选注释，它可以作为对图像的描述（来源或作者）呈现给用户。

指定者：
类 Image 中的 getProperty
参数：
name - 属性名
observer - 接收关于图像信息通知的 ImageObserver
返回：
Object，它是由指定 name 所引用的属性；如果此图像的属性未知，则返回 null。
抛出：
NullPointerException - 如果属性名为 null。
另请参见：
ImageObserver, Image.UndefinedProperty

getProperty

public Object getProperty(String name)
按名称返回图像的属性。

指定者：
接口 RenderedImage 中的 getProperty
参数：
name - 属性名
返回：
Object，它是由指定 name 所引用的属性。
抛出：
NullPointerException - 如果属性名为 null。
另请参见：
Image.UndefinedProperty

getGraphics

public Graphics getGraphics()
此方法返回 Graphics2D，但此处是出于向后兼容性的考虑。createGraphics 更为方便，因为它被声明为返回 Graphics2D。

指定者：
类 Image 中的 getGraphics
返回：
Graphics2D，可用于绘制此图像。
另请参见：
Graphics, Component.createImage(int, int)

createGraphics

public Graphics2D createGraphics()
创建一个 Graphics2D，可以将它绘制到此 BufferedImage 中。

返回：
Graphics2D，可用于绘制此图像。

getSubimage

public BufferedImage getSubimage(int x,
                                 int y,
                                 int w,
                                 int h)
返回由指定矩形区域定义的子图像。返回的 BufferedImage 与源图像共享相同的数据数组。

参数：
x - 指定矩形区域左上角的 X 坐标
y - 指定矩形区域左上角的 Y 坐标
w - 指定矩形区域的宽度
h - 指定矩形区域的高度
返回：
BufferedImage，它是此 BufferedImage 的子图像。
抛出：
RasterFormatException - 如果指定区域不包含在此 BufferedImage 中。

isAlphaPremultiplied

public boolean isAlphaPremultiplied()
返回是否已预乘以 alpha。如果不存在 alpha，则返回 false。

返回：
如果已经预乘以 alpha，则返回 true；否则返回 false。

coerceData

public void coerceData(boolean isAlphaPremultiplied)
强制该数据与 isAlphaPremultiplied 变量中指定的状态相匹配。可以将颜色 raster 数据乘以或除以 alpha，如果该数据处于正确状态，则不执行任何操作。

参数：
isAlphaPremultiplied - 如果已经预乘以 alpha，则为 true；否则为 false。

toString

public String toString()
返回此 BufferedImage 对象及其值的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
此 BufferedImage 的 String 表示形式。

getSources

public Vector<RenderedImage> getSources()
返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。如果 BufferedImage 没有关于其直接来源的信息，则此方法返回 null。如果 BufferedImage 没有直接来源，则它返回一个空 Vector。

指定者：
接口 RenderedImage 中的 getSources
返回：
一个 Vector，它包含此 BufferedImage 对象图像日期的直接来源；如果此 BufferedImage 没有关于其直接来源的信息，则返回 null；如果此 BufferedImage 没有直接来源，则返回一个空 Vector。

getPropertyNames

public String[] getPropertyNames()
返回由 getProperty(String) 识别的名称数组；如果没有识别出属性名，则返回 null。

指定者：
接口 RenderedImage 中的 getPropertyNames
返回：
一个 String 数组，它包含 getProperty(String) 识别的所有属性名；如果没有识别出属性名，则返回 null。

getMinX

public int getMinX()
返回此 BufferedImage 的最小 x 坐标。最小 x 坐标始终为零。

指定者：
接口 RenderedImage 中的 getMinX
返回：
此 BufferedImage 的最小 x 坐标。

getMinY

public int getMinY()
返回此 BufferedImage 的最小 y 坐标。最小 y 坐标始终为零。

指定者：
接口 RenderedImage 中的 getMinY
返回：
此 BufferedImage 的最小 y 坐标。

getSampleModel

public SampleModel getSampleModel()
返回与此 BufferedImage 关联的 SampleModel。

指定者：
接口 RenderedImage 中的 getSampleModel
返回：
此 BufferedImage 的 SampleModel。

getNumXTiles

public int getNumXTiles()
返回 x 方向的 tile 数。它始终为 1。

指定者：
接口 RenderedImage 中的 getNumXTiles
返回：
x 方向的 tile 数。

getNumYTiles

public int getNumYTiles()
返回 y 方向的 tile 数。它始终为 1。

指定者：
接口 RenderedImage 中的 getNumYTiles
返回：
y 方向的 tile 数。

getMinTileX

public int getMinTileX()
返回 x 方向的最小 tile 索引。它始终为零。

指定者：
接口 RenderedImage 中的 getMinTileX
返回：
x 方向的最小 tile 索引。

getMinTileY

public int getMinTileY()
返回 y 方向的最小 tile 索引。它始终为零。

指定者：
接口 RenderedImage 中的 getMinTileY
返回：
y 方向的最小 tile 索引。

getTileWidth

public int getTileWidth()
返回 tile 宽度（以像素为单位）。

指定者：
接口 RenderedImage 中的 getTileWidth
返回：
tile 宽度（以像素为单位）。

getTileHeight

public int getTileHeight()
返回 tile 高度（以像素为单位）。

指定者：
接口 RenderedImage 中的 getTileHeight
返回：
tile 高度（以像素为单位）。

getTileGridXOffset

public int getTileGridXOffset()
返回 tile 网格相对于原点的 x 偏移量（例如，tile (0, 0) 位置的 x 坐标）。它始终为零。

指定者：
接口 RenderedImage 中的 getTileGridXOffset
返回：
tile 网格的 x 偏移量。

getTileGridYOffset

public int getTileGridYOffset()
返回 tile 网格相对于原点的 y 偏移量（例如，tile (0, 0) 位置的 y 坐标）。它始终为零。

指定者：
接口 RenderedImage 中的 getTileGridYOffset
返回：
tile 网格的 y 偏移量。

getTile

public Raster getTile(int tileX,
                      int tileY)
返回 tile (tileX, tileY)。注意，tileX 和 tileY 是 tile 数组中的索引，而不是像素位置。返回的 Raster 是动态的，这意味着如果图像改变，则 Raster 将更新。

指定者：
接口 RenderedImage 中的 getTile
参数：
tileX - tile 数组中所请求的 tile 的 x 索引
tileY - tile 数组中所请求的 tile 的 y 索引
返回：
Raster，它是由参数 tileX 和 tileY 定义的 tile。
抛出：
ArrayIndexOutOfBoundsException - 如果 tileX 和 tileY 都不等于 0

getData

public Raster getData()
以一个大 tile 的形式返回图像。返回的 Raster 是图像数据的副本，图像改变时它不会更新。

指定者：
接口 RenderedImage 中的 getData
返回：
Raster，它是图像数据的副本。
另请参见：
setData(Raster)

getData

public Raster getData(Rectangle rect)
计算并返回 BufferedImage 的一个任意区域。返回的 Raster 是图像数据的副本，图像改变时它不会更新。

指定者：
接口 RenderedImage 中的 getData
参数：
rect - 要返回的 BufferedImage 区域。
返回：
Raster，它是 BufferedImage 指定区域的图像数据的副本
另请参见：
setData(Raster)

copyData

public WritableRaster copyData(WritableRaster outRaster)
计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。要计算的区域由指定 WritableRaster 的边界确定。指定 WritableRaster 必须具有与此图像兼容的 SampleModel。如果 outRaster 为 null，则创建一个合适的 WritableRaster。

指定者：
接口 RenderedImage 中的 copyData
参数：
outRaster - 保存图像返回部分的 WritableRaster, 或者为 null
返回：
对所提供的或创建的 WritableRaster 的引用。

setData

public void setData(Raster r)
将图像的矩形区域设置为指定 Raster r 的内容，假定该区域与 BufferedImage 处于相同的坐标空间。操作被限制在 BufferedImage 的边界内。

指定者：
接口 WritableRenderedImage 中的 setData
参数：
r - 指定的 Raster
另请参见：
getData(), getData(Rectangle)

addTileObserver

public void addTileObserver(TileObserver to)
添加一个 tile observer。如果该 observer 已经存在，则它接收多个通知。

指定者：
接口 WritableRenderedImage 中的 addTileObserver
参数：
to - 指定的 TileObserver

removeTileObserver

public void removeTileObserver(TileObserver to)
移除一个 tile observer。如果 observer 没有注册，则不发生任何操作。如果 observer 已对多个通知注册，则现在其注册的通知数将减少一个。

指定者：
接口 WritableRenderedImage 中的 removeTileObserver
参数：
to - 指定的 TileObserver。

isTileWritable

public boolean isTileWritable(int tileX,
                              int tileY)
返回当前是否为写入签出 tile。

指定者：
接口 WritableRenderedImage 中的 isTileWritable
参数：
tileX - tile 的 x 索引。
tileY - tile 的 y 索引。
返回：
如果为写入签出了由指定索引所指定的 tile，则返回 true；否则，返回 false。
抛出：
ArrayIndexOutOfBoundsException - 如果 tileX 和 tileY 都不等于 0

getWritableTileIndices

public Point[] getWritableTileIndices()
返回 Point 对象的数组，它指示为写入签出了哪些 tile。如果没有签出任何 tile，则返回 null。

指定者：
接口 WritableRenderedImage 中的 getWritableTileIndices
返回：
一个 Point 数组，它指示为写入签出的 tile；如果没有为写入签出的 tile，则返回 null。

hasTileWriters

public boolean hasTileWriters()
返回是否有为写入签出的 tile。语义上等效于
 (getWritableTileIndices() != null)。

指定者：
接口 WritableRenderedImage 中的 hasTileWriters
返回：
如果为写入签出了任何 tile，则返回 true；否则返回 false。

getWritableTile

public WritableRaster getWritableTile(int tileX,
                                      int tileY)
为写入签出一个 tile。当一个 tile 从没有 writer 变为有一个 writer 时，通知所有已注册的 TileObserver。

指定者：
接口 WritableRenderedImage 中的 getWritableTile
参数：
tileX - tile 的 x 索引
tileY - tile 的 y 索引
返回：
一个 WritableRaster，它是为写入而签出的、由指定索引指示的 tile。

releaseWritableTile

public void releaseWritableTile(int tileX,
                                int tileY)
放弃写入一个 tile 的权限。如果调用者继续写入 tile，则结果是不确定的。此方法的调用应该与 getWritableTile(int, int) 的调用成对出现。任何其他用法都会导致不明确的结果。当 tile 从有一个 writer 变为没有 writer 时，通知所有已注册的 TileObserver。

指定者：
接口 WritableRenderedImage 中的 releaseWritableTile
参数：
tileX - tile 的 x 索引
tileY - tile 的 y 索引

getTransparency

public int getTransparency()
返回透明度。返回 OPAQUE、BITMASK 或 TRANSLUCENT 中的一个。

指定者：
接口 Transparency 中的 getTransparency
返回：
此 BufferedImage 的透明度。
从以下版本开始：
1.5
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferedImageFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 BufferedImageFilter

java.lang.Object
    继承者  java.awt.image.ImageFilter
        继承者  java.awt.image.BufferedImageFilter
所有已实现的接口：
ImageConsumer, Cloneable
public class BufferedImageFilter
extends ImageFilter
implements Cloneable

BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。这些图像操作符的例子有：ConvolveOp、AffineTransformOp 和 LookupOp。

另请参见：
ImageFilter, BufferedImage, BufferedImageOp

字段摘要
从类 java.awt.image.ImageFilter 继承的字段
consumer
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
BufferedImageFilter(BufferedImageOp op)
构造具有指定单一源图像/单一目标图像操作符的 BufferedImageFilter。
方法摘要
BufferedImageOp | getBufferedImageOp() 返回 BufferedImageOp。
void | imageComplete(int status) 过滤 ImageConsumer 接口的 imageComplete 方法中提供的信息。
void | setColorModel(ColorModel model) 过滤 ImageConsumer 接口的 setColorModel 方法提供的信息。
void | setDimensions(int width, int height) 过滤 ImageConsumer 接口的 setDimensions 方法中提供的信息。
void | setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 过滤 ImageConsumer 接口（采用字节数组）的 setPixels 方法中提供的信息。
void | setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 过滤 ImageConsumer 接口（采用整数数组）的 setPixels 方法中提供的信息。
从类 java.awt.image.ImageFilter 继承的方法
clone, getFilterInstance, resendTopDownLeftRight, setHints, setProperties
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BufferedImageFilter

public BufferedImageFilter(BufferedImageOp op)
构造具有指定单一源图像/单一目标图像操作符的 BufferedImageFilter。

参数：
op - 用于过滤 BufferedImage 的指定 BufferedImageOp
抛出：
NullPointerException - 如果 op 为 null
方法详细信息

getBufferedImageOp

public BufferedImageOp getBufferedImageOp()
返回 BufferedImageOp。

返回：
此 BufferedImageFilter 的操作符。

setDimensions

public void setDimensions(int width,
                          int height)
过滤 ImageConsumer 接口的 setDimensions 方法中提供的信息。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类从图像中获得像素的开发人员应该避免直接调用此方法，因为该操作可能导致与获得请求像素相关的一些问题。

指定者：
接口 ImageConsumer 中的 setDimensions
覆盖：
类 ImageFilter 中的 setDimensions
参数：
width - 要设置此 BufferedImageFilter 的宽度
height - 要设置此 BufferedImageFilter 的高度
另请参见：
ImageConsumer.setDimensions(int, int)

setColorModel

public void setColorModel(ColorModel model)
过滤 ImageConsumer 接口的 setColorModel 方法提供的信息。

如果 model 为 null，则此方法清除 BufferedImageFilter 的当前 ColorModel。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类从图像中获得像素的开发人员应该避免直接调用此方法，因为该操作可能导致与获得请求像素相关的一些问题。

指定者：
接口 ImageConsumer 中的 setColorModel
覆盖：
类 ImageFilter 中的 setColorModel
参数：
model - 此 BufferedImageFilter 的 ColorModel 将被设置为该 ColorModel
另请参见：
ImageConsumer.setColorModel(java.awt.image.ColorModel)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
过滤 ImageConsumer 接口（采用字节数组）的 setPixels 方法中提供的信息。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类从图像中获得像素的开发人员应该避免直接调用此方法，因为该操作可能导致与获得请求像素相关的一些问题。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
抛出：
IllegalArgumentException - 如果 width 或 height 小于零。
另请参见：
ImageConsumer.setPixels(int, int, int, int, ColorModel, byte[], int, int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
过滤 ImageConsumer 接口（采用整数数组）的 setPixels 方法中提供的信息。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类从图像中获得像素的开发人员应该避免直接调用此方法，因为该操作可能导致与获得请求像素相关的一些问题。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
抛出：
IllegalArgumentException - 如果 width 或 height 小于零。
另请参见：
ImageConsumer.setPixels(int, int, int, int, ColorModel, int[], int, int)

imageComplete

public void imageComplete(int status)
过滤 ImageConsumer 接口的 imageComplete 方法中提供的信息。

注：此方法将由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类从图像中获得像素的开发人员应该避免直接调用此方法，因为该操作可能导致与获得请求像素相关的一些问题。

指定者：
接口 ImageConsumer 中的 imageComplete
覆盖：
类 ImageFilter 中的 imageComplete
参数：
status - 图像加载的状态
抛出：
ImagingOpException - 如果调用与此实例相关的 BufferedImageOp 的过滤器方法时出现问题。
另请参见：
ImageConsumer.imageComplete(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferedImageOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 BufferedImageOp

所有已知实现类：
AffineTransformOp, ColorConvertOp, ConvolveOp, LookupOp, RescaleOp
public interface BufferedImageOp

此接口描述对 BufferedImage 对象所执行的单输入/单输出操作。它由 AffineTransformOp、ConvolveOp、ColorConvertOp、RescaleOp 和 LookupOp 实现。这些对象可以传入到一个 BufferedImageFilter，以便对 ImageProducer-ImageFilter-ImageConsumer 范例中的 BufferedImage 进行操作。

实现此接口的类必须指定它们是否允许进行适当的过滤，在此过滤操作中源对象等于目标对象。

无法使用此接口描述更复杂的操作，比如那些针对多个源对象的操作。注意，此限制还意味着，在进行该操作之前目标像素的值不用作过滤操作的输入。

另请参见：
BufferedImage, BufferedImageFilter, AffineTransformOp, BandCombineOp, ColorConvertOp, ConvolveOp, LookupOp, RescaleOp

方法摘要
BufferedImage | createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | filter(BufferedImage src, BufferedImage dest) 对 BufferedImage 执行单输入/单输出操作。
Rectangle2D | getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 返回与源图像中给定点对应的目标点的位置。
RenderingHints | getRenderingHints() 返回针对此操作所呈现的提示。

方法详细信息

filter

BufferedImage filter(BufferedImage src,
                     BufferedImage dest)
对 BufferedImage 执行单输入/单输出操作。如果两个图像的颜色模型不匹配，则将颜色模型转换成目标颜色模型。如果目标图像为 null，则创建一个具有合适 ColorModel 的 BufferedImage。

如果源图像和/或目标图像与实现此过滤器的类所允许的图像类型不兼容，则可能抛出 IllegalArgumentException。

参数：
src - 要过滤的 BufferedImage
dest - 用于存储 results$ 的 BufferedImage
返回：
过滤后的 BufferedImage。
抛出：
IllegalArgumentException - 如果源图像和/或目标图像与实现此过滤器的类所允许的图像类型不兼容。

getBounds2D

Rectangle2D getBounds2D(BufferedImage src)
返回已过滤目标图像的边界框。如果源图像与实现此过滤器的类所允许的图像类型不兼容，则可能抛出 IllegalArgumentException。

参数：
src - 要过滤的 BufferedImage
返回：
表示目标图像边界框的 Rectangle2D。

createCompatibleDestImage

BufferedImage createCompatibleDestImage(BufferedImage src,
                                        ColorModel destCM)
创建一个具有正确大小和 band 数的经过检查的目标图像。如果源图像与实现此过滤器的类所允许的图像类型不兼容，则可能抛出 IllegalArgumentException。

参数：
src - 要过滤的 BufferedImage
destCM - 目标 ColorModel。如果目标 ColorModel 为 null，则使用源 ColorModel。
返回：
经过检查的目标图像。

getPoint2D

Point2D getPoint2D(Point2D srcPt,
                   Point2D dstPt)
返回与源图像中给定点对应的目标点的位置。如果指定了 dstPt，则使用它保存返回值。

参数：
srcPt - 表示源图像中点的 Point2D
dstPt - 用于存储结果的 Point2D
返回：
与源图像中指定点对应的目标图像中的 Point2D。

getRenderingHints

RenderingHints getRenderingHints()
返回针对此操作所呈现的提示。

返回：
针对此 BufferedImageOp 的 RenderingHints 对象。如果没有设置提示，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferStrategy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 BufferStrategy

java.lang.Object
    继承者  java.awt.image.BufferStrategy
直接已知子类：
Component.BltBufferStrategy, Component.FlipBufferStrategy
public abstract class BufferStrategy
extends Object

BufferStrategy 类表示用来在特定的 Canvas 或 Window 上组织复杂内存的机制。硬件和软件限制决定了是否能够实现特定的缓冲区策略以及如何实现它。从创建 Canvas 或 Window 时所用 GraphicsConfiguration 的性能中可以发觉这些限制。

值得注意的是，术语 buffer 和 surface 意思相同：视频设备内存或系统内存中的连续内存区域。

存在几种类型的复杂缓冲区策略，包括连续环形缓冲和 blit 缓冲。连续环形缓冲（即双缓冲或三次缓冲）是最常见的缓冲区策略；将一个应用程序绘制到单个后备缓冲区，然后只用一个步骤将其内容移入到前端（显示），这可通过复制数据或移动视频指针完成。移动视频指针可交换缓冲区，于是绘制的第一个缓冲区成为前端缓冲区，或称设备上当前所显示的内容；这称为页面翻转。

作为一种替代方式，可以复制后备缓冲区的内容，即使用链而不是移动视频指针进行位图传输 (blitted)。

双缓冲：
                    ***********         ***********
                    *         * ------> *         *
 [到显示器]    <---- * Front B *   显示  * Back B. * <---- 呈现
                    *         * <------ *         *
                    ***********         ***********

三次缓冲：

 [到      ***********         ***********        ***********
显示器]   *         * --------+---------+------> *         *
    <---- * Front B *   显示  * Mid. B. *        * Back B. * <---- 呈现
          *         * <------ *         * <----- *         *
          ***********         ***********        ***********

以下是一个如何创建和使用缓冲区策略的例子：

 // Check the capabilities of the GraphicsConfiguration
 ...

 // Create our component
 Window w = new Window(gc);

 // Show our window
 w.setVisible(true);

 // Create a general double-buffering strategy
 w.createBufferStrategy(2);
 BufferStrategy strategy = w.getBufferStrategy();

// Main loop
 while (!done) {
     // Prepare for rendering the next frame
     // ...

     // Render single frame
     do {
         // The following loop ensures that the contents of the drawing buffer
         // are consistent in case the underlying surface was recreated
         do {
             // Get a new graphics context every time through the loop
             // to make sure the strategy is validated
             Graphics graphics = strategy.getDrawGraphics();

             // Render to graphics
             // ...

             // Dispose the graphics
             graphics.dispose();

             // Repeat the rendering if the drawing buffer contents
             // were restored
         } while (strategy.contentsRestored());

         // Display the buffer
         strategy.show();

         // Repeat the rendering if the drawing buffer was lost
     } while (strategy.contentsLost());
 }

 // Dispose the window
 w.setVisible(false);
 w.dispose();

从以下版本开始：
1.4
另请参见：
Component, GraphicsConfiguration, VolatileImage

构造方法摘要
BufferStrategy()
方法摘要
abstract boolean | contentsLost() 返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。
abstract boolean | contentsRestored() 返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。
void | dispose() 释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。
abstract BufferCapabilities | getCapabilities() 返回此 BufferStrategy 的 BufferCapabilities。
abstract Graphics | getDrawGraphics() 创建用于绘制缓冲区的图形上下文。
abstract void | show() 通过复制内存（位图传输）或更改显示指针（翻转）使下一个可用缓冲区可见。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BufferStrategy

public BufferStrategy()
方法详细信息

getCapabilities

public abstract BufferCapabilities getCapabilities()
返回此 BufferStrategy 的 BufferCapabilities。

返回：
此策略的缓冲性能

getDrawGraphics

public abstract Graphics getDrawGraphics()
创建用于绘制缓冲区的图形上下文。由于性能的原因，此方法可能不是同步的；多个线程使用此方法时，应该在应用层对其进行处理。对所得到的图形对象的释放必须由应用程序来处理。

返回：
用于绘制缓冲区的图形上下文

contentsLost

public abstract boolean contentsLost()
返回上次调用 getDrawGraphics 后绘制缓冲区是否丢失。由于使用缓冲区策略的缓冲区通常是 VolatileImage 类型的，因此它们有可能丢失。有关对丢失缓冲区的讨论，请参阅 VolatileImage。

返回：
上次调用 getDrawGraphics 之后绘图缓冲区是否丢失
另请参见：
VolatileImage

contentsRestored

public abstract boolean contentsRestored()
返回绘制缓冲区最近是否从丢失状态恢复，并重新初始化为默认背景色（白色）。由于使用缓冲区策略的缓冲区通常是 VolatileImage 类型的，因此它们有可能丢失。如果上次调用 getDrawGraphics 后，缓冲区最近已从丢失状态恢复，则缓冲区可能要求重新绘制。有关对丢失缓冲区的讨论，请参阅 VolatileImage。

返回：
上次调用 getDrawGraphics 之后是否恢复了绘图缓冲区
另请参见：
VolatileImage

show

public abstract void show()
通过复制内存（位图传输）或更改显示指针（翻转）使下一个可用缓冲区可见。

dispose

public void dispose()
释放当前由此 BufferStrategy 使用的系统资源，并从关联 Component 中移除它们。在调用此方法之后，getBufferStrategy 将返回 null。试图在释放 BufferStrategy 后使用它将导致不确定的行为。

从以下版本开始：
1.6
另请参见：
Component.createBufferStrategy(int), Component.getBufferStrategy()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ByteLookupTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ByteLookupTable

java.lang.Object
    继承者  java.awt.image.LookupTable
        继承者  java.awt.image.ByteLookupTable

public class ByteLookupTable
extends LookupTable

此类定义一个 lookup table 对象。使用此类的对象的 lookup 操作的输出被解释为无符号的字节数量。lookup table 包含字节数据数组，用于图像的一个或多个 band（或分量），还包含一个偏移量，对数组进行索引之前要从输入值减去该偏移量。这允许数组小于为限制输入而提供的本机数据大小。如果在 lookup table 中只有一个数组，则该数组将应用于所有的 band。

另请参见：
ShortLookupTable, LookupOp

构造方法摘要
ByteLookupTable(int offset, byte[] data)
根据字节数组（表示应用于所有 band 的 lookup table）构造一个 ByteLookupTable 对象。
ByteLookupTable(int offset, byte[][] data)
根据字节数组的数组（表示每个 band 的 lookup table）构造一个 ByteLookupTable 对象。
方法摘要
byte[][] | getTable() 按引用返回 lookup table 数据。
byte[] | lookupPixel(byte[] src, byte[] dst) 返回像素的样本数组，使用 lookup table 进行转换。
int[] | lookupPixel(int[] src, int[] dst) 返回像素的样本数组，使用 lookup table 进行转换。
从类 java.awt.image.LookupTable 继承的方法
getNumComponents, getOffset
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ByteLookupTable

public ByteLookupTable(int offset,
                       byte[][] data)
根据字节数组的数组（表示每个 band 的 lookup table）构造一个 ByteLookupTable 对象。对数组元素进行索引之前从输入值减去该偏移量。band 的数量是数据参数的长度。每个 band 的数据数组存储为一个引用。

参数：
offset - 对数组元素进行索引之前从输入值减去的值
data - 一个字节数组的数组，表示每个 band 的 lookup table
抛出：
IllegalArgumentException - 如果 offset 小于 0 或者 data 的长度小于 1

ByteLookupTable

public ByteLookupTable(int offset,
                       byte[] data)
根据字节数组（表示应用于所有 band 的 lookup table）构造一个 ByteLookupTable 对象。对数组元素进行索引之前从输入值减去该偏移量。数据数组存储为一个引用。

参数：
offset - 对数组元素进行索引之前从输入值减去的值
data - 字节数组
抛出：
IllegalArgumentException - 如果 offset 小于 0 或者 data 的长度小于 1
方法详细信息

getTable

public final byte[][] getTable()
按引用返回 lookup table 数据。如果此 ByteLookupTable 是使用单字节数组构造的，则返回数组的长度为 1。

返回：
此 ByteLookupTable 的数据数组。

lookupPixel

public int[] lookupPixel(int[] src,
                         int[] dst)
返回像素的样本数组，使用 lookup table 进行转换。源数组和目标数组可以是相同的数组。返回 dst 数组。

指定者：
类 LookupTable 中的 lookupPixel
参数：
src - 源数组。
dst - 目标数组。此数组必须至少与 src 一样长。如果 dst 为 null，则分配一个与 src 具有相同长度的新数组。
返回：
dst 数组，一个 int 样本数组。
抛出：
ArrayIndexOutOfBoundsException - 如果 src 的长度大于 dst 的长度，或者对于 src 的任何元素 i，src[i]-offset 小于零，或者大于等于任何 band 的 lookup table 的长度。

lookupPixel

public byte[] lookupPixel(byte[] src,
                          byte[] dst)
返回像素的样本数组，使用 lookup table 进行转换。源数组和目标数组可以是相同的数组。返回 dst 数组。

参数：
src - 源数组。
dst - 目标数组。此数组必须至少与 src 一样长。如果 dst 为 null，则分配一个与 src 具有相同长度的新数组。
返回：
dst 数组，一个 int 样本数组。
抛出：
ArrayIndexOutOfBoundsException - 如果 src 的长度大于 dst 的长度，或者对于 src 的任何元素 i，(src[i]&0xff)-offset 小于零，或者大于等于任何 band 的 lookup table 的长度。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ColorConvertOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ColorConvertOp

java.lang.Object
    继承者  java.awt.image.ColorConvertOp
所有已实现的接口：
BufferedImageOp, RasterOp
public class ColorConvertOp
extends Object
implements BufferedImageOp, RasterOp

此类对源图像中的数据执行逐像素的颜色转换。得到的颜色值可以扩展到目标图像的精度。颜色转换可以通过 ColorSpace 对象的数组或 ICC_Profile 对象的数组指定。

如果源是预乘了 alpha 的 BufferedImage，则在颜色转换前要将颜色分量除以 alpha 分量。如果目标是预乘了 alpha 的 BufferedImage，则要在颜色转换后将颜色分量乘以 alpha 分量。Raster 被认为是没有 alpha 通道的，也即所有 band 都是颜色 band。

如果 RenderingHints 对象是在构造方法中指定的，则可以使用颜色呈现提示和抖动提示来控制颜色转换。

注意，Source 和 Destination 可以是同一个对象。

另请参见：
RenderingHints.KEY_COLOR_RENDERING, RenderingHints.KEY_DITHERING

构造方法摘要
ColorConvertOp(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
根据两个 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ColorSpace cspace, RenderingHints hints)
根据 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ICC_Profile[] profiles, RenderingHints hints)
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。
ColorConvertOp(RenderingHints hints)
构造从源颜色空间到目标颜色空间转换的新 ColorConvertOp。
方法摘要
BufferedImage | createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建给定源的具有正确大小和 band 数量的归零目标图像。
WritableRaster | createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
BufferedImage | filter(BufferedImage src, BufferedImage dest) 对源 BufferedImage 进行颜色转换。
WritableRaster | filter(Raster src, WritableRaster dest) 对源 Raster 中的图像数据进行颜色转换。
Rectangle2D | getBounds2D(BufferedImage src) 返回给定源的目标边界框。
Rectangle2D | getBounds2D(Raster src) 返回给定源的目标边界框。
ICC_Profile[] | getICC_Profiles() 返回用于构造此 ColorConvertOp 的 ICC_Profiles 的数组。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点的位置。
RenderingHints | getRenderingHints() 此操作使用的呈现提示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ColorConvertOp

public ColorConvertOp(RenderingHints hints)
构造从源颜色空间到目标颜色空间转换的新 ColorConvertOp。RenderingHints 参数可以为 null。此操作只能与 BufferedImage 一起使用，并将直接从源图像的 ColorSpace 转换为目标图像的 ColorSpace。过滤器方法的目标参数不能指定为 null。

参数：
hints - 用来控制颜色转换的 RenderingHints 对象，或 null

ColorConvertOp

public ColorConvertOp(ColorSpace cspace,
                      RenderingHints hints)
根据 ColorSpace 对象构造新的 ColorConvertOp。RenderingHints 参数可以为 null。此操作只能与 BufferedImages 一起使用，并且在目标参数为 null 的情况下调用 filter 方法时特别有用。在这种情况下，ColorSpace 定义由过滤器方法创建的目标的目标颜色空间。否则，ColorSpace 将定义一个中间空间，源转换为目标空间之前要先转换为这个中间空间。

参数：
cspace - 定义目标 ColorSpace 或中间 ColorSpace
hints - 用来控制颜色转换的 RenderingHints 对象，或 null
抛出：
NullPointerException - 如果 cspace 为 null

ColorConvertOp

public ColorConvertOp(ColorSpace srcCspace,
                      ColorSpace dstCspace,
                      RenderingHints hints)
根据两个 ColorSpace 对象构造新的 ColorConvertOp。RenderingHints 参数可以为 null。此操作在调用 Raster 的过滤方法时特别有用，在这种情况下，这两个 ColorSpace 将定义对 Raster 执行的操作。在这种情况下，源 Raster 中的 band 数量必须与 srcCspace 中分量的数量匹配，并且目标 Raster 中的 band 数量必须与 dstCspace 中分量的数量匹配。对于 BufferedImages，这两个 ColorSpace 将定义一个中间空间，源在转换为目标空间之前要先转换为中间空间。

参数：
srcCspace - 源 ColorSpace
dstCspace - 目标 ColorSpace
hints - 用于控制颜色转换的 RenderingHints 对象，或 null
抛出：
NullPointerException - 如果 srcCspace 或 dstCspace 为 null

ColorConvertOp

public ColorConvertOp(ICC_Profile[] profiles,
                      RenderingHints hints)
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。RenderingHints 参数可以为 null。配置文件序列可以包括表示颜色空间的配置文件、表示效果的配置文件等。如果整个序列不表示定义良好的颜色转换，则抛出异常。

对于 BufferedImages，如果源 BufferedImage 的 ColorSpace 与数组中的第一个配置文件的要求不匹配，则首次转换要转换到适当的 ColorSpace。如果目标 BufferedImage 的 ColorSpace 不能满足数组中的最后一个配置文件的要求，则最后一次转换要转换到目标的 ColorSpace。

对于 Raster，源 Raster 中的 band 数量必须与数组中第一个配置文件的要求匹配，并且目标 Raster 中的 band 数量必须与数组中最后一个配置文件的要求匹配。该数组至少有两个元素，否则调用 Raster 的过滤方法将抛出 IllegalArgumentException。

参数：
profiles - ICC_Profile 对象的数组
hints - 用于控制颜色转换的 RenderingHints 对象，或 null
抛出：
IllegalArgumentException - 在配置文件序列未指定定义良好的颜色转换时
NullPointerException - 如果配置文件为 null
方法详细信息

getICC_Profiles

public final ICC_Profile[] getICC_Profiles()
返回用于构造此 ColorConvertOp 的 ICC_Profiles 的数组。如果 ColorConvertOp 不是通过此类数组构造的，则返回 null。

返回：
此 ColorConvertOp 的 ICC_Profile 对象的数组，或 null 如果此 ColorConvertOp 不是通过 ICC_Profile 对象构造的。

filter

public final BufferedImage filter(BufferedImage src,
                                  BufferedImage dest)
对源 BufferedImage 进行颜色转换。如果目标图像为 null，则根据适当的 ColorModel 创建 BufferedImage。

指定者：
接口 BufferedImageOp 中的 filter
参数：
src - 要转换的源 BufferedImage
dest - 目标 BufferedImage，或 null
返回：
通过 src 转换的 dest 颜色，或已转换的新 BufferedImage（如果 dest 为 null）
抛出：
IllegalArgumentException - 如果 dest 为 null，并且此操作是使用因操作定义得不好而只采用 RenderingHints 参数的构造方法构造的。

filter

public final WritableRaster filter(Raster src,
                                   WritableRaster dest)
对源 Raster 中的图像数据进行颜色转换。如果目标 Raster 为 null，则创建新 Raster。源和目标 Raster 中的 band 数量必须满足上述要求。用于创建此 ColorConvertOp 的构造方法必须提供足够的可用来定义源和目标颜色空间的信息。请参阅上文。否则，将抛出异常。

指定者：
接口 RasterOp 中的 filter
参数：
src - 要转换的源 Raster
dest - 目标 WritableRaster，或 null
返回：
通过 src 转换的 dest 颜色，或已转换的新 WritableRaster（如果 dest 为 null）
抛出：
IllegalArgumentException - 如果源或目标 band 数量不正确，或未定义源或目标颜色空间，或此操作是通过只应用于 BufferedImages 上的操作的构造方法之一构造的。

getBounds2D

public final Rectangle2D getBounds2D(BufferedImage src)
返回给定源的目标边界框。注意，此框与源的边界框相同。

指定者：
接口 BufferedImageOp 中的 getBounds2D
参数：
src - 源 BufferedImage
返回：
在指定 src 的情况下返回目标边界框 Rectangle2D

getBounds2D

public final Rectangle2D getBounds2D(Raster src)
返回给定源的目标边界框。注意，此框与源的边界框相同。

指定者：
接口 RasterOp 中的 getBounds2D
参数：
src - 源 Raster
返回：
在指定 src 的情况下返回目标边界框 Rectangle2D

createCompatibleDestImage

public BufferedImage createCompatibleDestImage(BufferedImage src,
                                               ColorModel destCM)
创建给定源的具有正确大小和 band 数量的归零目标图像。

指定者：
接口 BufferedImageOp 中的 createCompatibleDestImage
参数：
src - 进行过滤操作的源图像。
destCM - 该目标的 ColorModel。如果为 null，则使用适当的 ColorModel。
返回：
指定 src 中具有正确 band 大小和数量的 BufferedImage。
抛出：
IllegalArgumentException - 如果 destCM 为 null，并且此 ColorConvertOp 不是通过针对目标定义的任何 ICC_Profile 或 ColorSpace 创建的

createCompatibleDestRaster

public WritableRaster createCompatibleDestRaster(Raster src)
创建给定源且具有正确 band 大小和数量的归零目标 Raster。

指定者：
接口 RasterOp 中的 createCompatibleDestRaster
参数：
src - 指定 Raster
返回：
指定 src 中具有正确 band 大小和数量的 WritableRaster
抛出：
IllegalArgumentException - 如果此 ColorConvertOp 不是根据足以定义 dst 和 src 颜色空间的信息创建的

getPoint2D

public final Point2D getPoint2D(Point2D srcPt,
                                Point2D dstPt)
返回源中给定点的目标点的位置。如果 dstPt 为非 null，则使用它存储返回值。注意，对于此类，目标点将与源点相同。

指定者：
接口 BufferedImageOp 中的 getPoint2D
指定者：
接口 RasterOp 中的 getPoint2D
参数：
srcPt - 指定源 Point2D
dstPt - 目标 Point2D
返回：
将其位置设置为与 srcPt 相同之后返回 dstPt。

getRenderingHints

public final RenderingHints getRenderingHints()
此操作使用的呈现提示。

指定者：
接口 BufferedImageOp 中的 getRenderingHints
指定者：
接口 RasterOp 中的 getRenderingHints
返回：
此 ColorConvertOp 的 RenderingHints 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ColorModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ColorModel

java.lang.Object
    继承者  java.awt.image.ColorModel
所有已实现的接口：
Transparency
直接已知子类：
ComponentColorModel, IndexColorModel, PackedColorModel
public abstract class ColorModel
extends Object
implements Transparency

此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。为了将图像呈现到屏幕、打字机或其他图像上，必须将像素值转换为颜色和 alpha 分量。与此类方法的参数或返回值一样，可以把像素表示为 32 位 int，或表示为基本类型的数组。ColorModel 颜色分量的数量、顺序和解释由其 ColorSpace 指定。与未包含 alpha 信息的像素数据一起使用的 ColorModel 将所有像素视为不透明的（alpha 值为 1.0）。

此 ColorModel 类支持像素值的两种表示形式。像素值可以为单个 32 位 int，也可以为一个基本类型的数组。Java(tm) Platform 1.0 和 1.1 API 将像素表示为单 byte 或单 int 值。根据此 ColorModel 类用途，可按 int 形式传递像素值参数。Java(tm) 2 Platform API 引入了表示图像的其他类。对于 BufferedImage 或 RenderedImage 对象（基于 Raster 和 SampleModel 类），像素值用单个 int 表示可能不太方便。因此，ColorModel 现在提供了以基本类型数组表示像素值的方法。特定 ColorModel 对象使用的基本类型被称作其转换类型。

当调用采用单个 int 像素参数的方法时，与其像素值不便于表示为单个 int 的图像一起使用的 ColorModel 对象会抛出 IllegalArgumentException。ColorModel 的子类必须指定出现这种情况的条件。对于 DirectColorModel 或 IndexColorModel 对象，不会出现这种情况。

当前，受 Java 2D(tm) API 支持的转换类型有 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 和 DataBuffer.TYPE_DOUBLE。当使用 ColorModel 和这些类型中前三个类型的图像时，多数呈现操作都会被更快地执行。而 ColorModel 和后三种类型的图像可能不支持某些图像的过滤操作。在创建特定 ColorModel 对象时，通常会显式或默认指定该对象的转换类型。ColorModel 的所有子类必须指定可能的转换类型和如何确定表示像素基本数组中元素的数量。

对于 BufferedImages，其 Raster 和该 Raster 对象的 SampleModel（从这些类的 getTransferType 方法中获得）的转换类型必须与 ColorModel 的转换类型匹配。表示 Raster 和 SampleModel（从这些类的 getNumDataElements 方法中获得）的像素的数组中的元素数量必须与 ColorModel 的数量匹配。

用于将像素值转换为颜色和 alpha 分量的算法随子类不同而不同。例如，从 BufferedImage 对象的 Raster 和颜色/alpha 分量的 SampleModel 中得到的样本之间不需要一一对应。即使有此对应关系，样本中的位数也不必与相应的颜色/alpha 分量中的位数相同。每个子类必须指定如何从像素值到颜色/alpha 分量的转换。

该 ColorModel 类中的方法使用两种不同的颜色和 alpha 分量表示形式：标准化形式和非标准化形式。在标准化形式中，每个分量都是介于某个最小值和最大值之间的 float 值。对于 alpha 分量，最小值为 0.0，最大值为 1.0。对于颜色分量，每个分量的最小值和最大值可以从 ColorSpace 对象中得到。这些值通常为 0.0 和 1.0（例如，默认 sRGB 颜色空间的标准化分量值的范围为 0.0 到 1.0），但某些颜色空间的分量值可能有不同的上限和下限。这些极限值可以使用 ColorSpace 类的 getMinValue 和 getMaxValue 方法得到。标准化的颜色分量值未预乘。所有 ColorModels 必须支持标准化形式。

在非标准化形式中，每个分量都是 0 和 2n - 1 之间的无符号整数值，其中 n 为特定分量的有效位数。如果特定 ColorModel 的像素值表示预乘了 alpha 样本的颜色样本，则非标准化颜色分量也要预乘。非标准化形式只能与其 ColorSpace 所有分量的最小值为 0.0，所有分量的最大值为 1.0 的 ColorModel 的实例一起使用。颜色和 alpha 分量的非标准化形式可以是其标准化分量值都位于 0.0 和 1.0 之间的 ColorModels 的便捷表示形式。在这种情况下，整数值 0 映射到 0.0，而值 2n - 1 映射到 1.0。其他情况下，如标准化分量值可以为负数或正数、非标准化形式不方便使用。当调用包含非标准化参数的方法时，此类 ColorModel 对象将抛出 IllegalArgumentException。ColorModel 的子类必须指定出现这种情况的条件。

另请参见：
IndexColorModel, ComponentColorModel, PackedColorModel, DirectColorModel, Image, BufferedImage, RenderedImage, ColorSpace, SampleModel, Raster, DataBuffer

字段摘要
protected int | pixel_bits 像素总位数。
protected int | transferType 用于表示像素值的数组的数据类型。
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
 | ColorModel(int bits) 构造 ColorModel，将指定位数的像素转换为颜色/alpha 分量。
protected | ColorModel(int pixel_bits, int[] bits, ColorSpace cspace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType) 构造将像素值转换为颜色/alpha 分量的 ColorModel。
方法摘要
ColorModel | coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
SampleModel | createCompatibleSampleModel(int w, int h) 用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
WritableRaster | createCompatibleWritableRaster(int w, int h) 用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
boolean | equals(Object obj) 测试指定的 Object 是否是 ColorModel 的实例，以及它是否等于此 ColorModel。
void | finalize() 一旦不再引用此 ColorModel，就要释放与此 ColorModel 相关的系统资源。
abstract int | getAlpha(int pixel) 返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
int | getAlpha(Object inData) 返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
WritableRaster | getAlphaRaster(WritableRaster raster) 返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。
abstract int | getBlue(int pixel) 返回指定像素的蓝色分量的值，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getBlue(Object inData) 返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
ColorSpace | getColorSpace() 返回与此 ColorModel 相关的 ColorSpace。
int[] | getComponents(int pixel, int[] components, int offset) 返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。
int[] | getComponents(Object pixel, int[] components, int offset) 返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。
int[] | getComponentSize() 返回每个颜色/alpha 分量的位数数组。
int | getComponentSize(int componentIdx) 返回指定颜色/alpha 分量的位数。
int | getDataElement(float[] normComponents, int normOffset) 在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
int | getDataElement(int[] components, int offset) 在已给定非标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中以 int 类型表示的像素值。
Object | getDataElements(float[] normComponents, int normOffset, Object obj) 在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
Object | getDataElements(int[] components, int offset, Object obj) 在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
Object | getDataElements(int rgb, Object pixel) 在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
abstract int | getGreen(int pixel) 返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getGreen(Object inData) 返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255）。
float[] | getNormalizedComponents(int[] components, int offset, float[] normComponents, int normOffset) 在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。
float[] | getNormalizedComponents(Object pixel, float[] normComponents, int normOffset) 返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。
int | getNumColorComponents() 返回此 ColorModel 中颜色分量数。
int | getNumComponents() 返回此 ColorModel 中分量数（包括 alpha 分量数）。
int | getPixelSize() 返回由此 ColorModel 描述的每像素的位数。
abstract int | getRed(int pixel) 返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getRed(Object inData) 返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getRGB(int pixel) 返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。
int | getRGB(Object inData) 返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
static ColorModel | getRGBdefault() 返回描述整数 RGB 值的默认格式的 DirectColorModel，该整数 RGB 值可以在便于程序员使用的 AWT 图像接口中的许多方法中使用。
int | getTransferType() 返回此 ColorModel 的转换类型。
int | getTransparency() 返回透明度。
int[] | getUnnormalizedComponents(float[] normComponents, int normOffset, int[] components, int offset) 在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。
boolean | hasAlpha() 返回此 ColorModel 中是否支持 alpha。
int | hashCode() 返回此 ColorModel 的哈希码。
boolean | isAlphaPremultiplied() 返回是否在由此 ColorModel 转换的像素值中预乘 alpha。
boolean | isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
boolean | isCompatibleSampleModel(SampleModel sm) 检查 SampleModel 是否与此 ColorModel 兼容。
String | toString() 返回此 ColorModel 对象的内容的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

pixel_bits

protected int pixel_bits
像素总位数。

transferType

protected int transferType
用于表示像素值的数组的数据类型。

构造方法详细信息

ColorModel

public ColorModel(int bits)
构造 ColorModel，将指定位数的像素转换为颜色/alpha 分量。颜色空间默认为 RGB ColorSpace（即 sRGB）。假定像素值包含 alpha 信息。如果像素值中的颜色和 alpha 信息表示为独立的空间 band，则假定颜色 band 未与 alpha 值预乘。透明度类型为 java.awt.Transparency.TRANSLUCENT。转换类型将为可以存储单个像素的 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 中的最小者（或 DataBuffer.TYPE_UNDEFINED，如果位数大于 32）。因为此构造方法没有关于每个颜色和 alpha 分量的位数信息，所以任何调用此构造方法的子类都应该重写需要此信息的所有方法。

参数：
bits - 像素的位数
抛出：
IllegalArgumentException - 如果 bits 中的位数小于 1

ColorModel

protected ColorModel(int pixel_bits,
                     int[] bits,
                     ColorSpace cspace,
                     boolean hasAlpha,
                     boolean isAlphaPremultiplied,
                     int transparency,
                     int transferType)
构造将像素值转换为颜色/alpha 分量的 ColorModel。颜色分量将位于指定的 ColorSpace 中。pixel_bits 为像素值中的位数。位数组指定每个颜色和 alpha 分量的有效位数。如果像素值中不包含 alpha 信息，则其长度应为 ColorSpace 中的分量数；如果包含 alpha 信息，则其长度比此数要大。hasAlpha 指示是否存在 alpha 信息。boolean isAlphaPremultiplied 指定如何解释像素值，其中颜色和 alpha 信息表示为独立的空间 band。如果 boolean 为 true，则假定颜色样本已经与 alpha 样本相乘。该 transparency 指定可以由此颜色模型表示的 alpha 值。转换类型是用于表示像素值的基本数组的类型。注意，位数组包含从像素值转换后每个颜色/alpha 分量的有效位数。例如，对于 pixel_bits 等于 16 的 IndexColorModel，该位数组可能有四个每个元素都设置为 8 的元素。

参数：
pixel_bits - 像素值中的位数
bits - 指定每个颜色和 alpha 分量的有效位数的数组
cspace - 指定 ColorSpace
hasAlpha - true 如果包含 alpha 信息；否则为 false
isAlphaPremultiplied - true 如果假定颜色样本预乘了 alpha 样本；否则为 false
transparency - 可以由此颜色模型表示的 alpha 值
transferType - 用于表示像素值的数组类型
抛出：
IllegalArgumentException - 如果位数组的长度小于此 ColorModel 中颜色或 alpha 分量的数量，或者透明度不为有效值。
IllegalArgumentException - 如果 bits 中位数的和小于 1，或者 bits 中任何一个元素小于 0。
另请参见：
Transparency
方法详细信息

getRGBdefault

public static ColorModel getRGBdefault()
返回描述整数 RGB 值的默认格式的 DirectColorModel，该整数 RGB 值可以在便于程序员使用的 AWT 图像接口中的许多方法中使用。颜色空间为默认的 ColorSpace（即 sRGB）。RGB 值的格式是一个 8 位的整数，从最高有效字节到最低有效字节的相应顺序排列 alpha、红色、绿色和蓝色颜色分量，格式如下：0xAARRGGBB。颜色分量未与 alpha 分量预乘。此格式不一定表示特定设备或所有图像的本机或最有效的 ColorModel。它只是一种通用的颜色模型格式。

返回：
描述默认 RGB 值的 DirectColorModel 对象。

hasAlpha

public final boolean hasAlpha()
返回此 ColorModel 中是否支持 alpha。

返回：
如果此 ColorModel 中支持 alpha，则返回 true；否则返回 false。

isAlphaPremultiplied

public final boolean isAlphaPremultiplied()
返回是否在由此 ColorModel 转换的像素值中预乘 alpha。如果布尔变量为 true，则使用此 ColorModel 解释其中颜色和 alpha 信息表示为独立空间 band 的像素值，并且假定颜色样本已经与 alpha 样本相乘。

返回：
如果已在由此 ColorModel 转换的像素值中预乘 alpha 值，则返回 true；否则返回 false。

getTransferType

public final int getTransferType()
返回此 ColorModel 的转换类型。该转换类型是一个基本数组类型，可用来以数组形式表示像素值。

返回：
转换类型。
从以下版本开始：
1.3

getPixelSize

public int getPixelSize()
返回由此 ColorModel 描述的每像素的位数。

返回：
每像素的位数。

getComponentSize

public int getComponentSize(int componentIdx)
返回指定颜色/alpha 分量的位数。按 ColorSpace 中指定的顺序索引颜色分量。通常，此顺序反映了颜色空间类型的名称。例如，对于 TYPE_RGB，索引 0 对应于红色，索引 1 对应于绿色，索引 2 对应于蓝色。如果此 ColorModel 支持 alpha，则该 alpha 分量对应于最后一个颜色分量后面的索引。

参数：
componentIdx - 颜色/alpha 分量的索引
返回：
指定索引处颜色/alpha 分量的位数。
抛出：
ArrayIndexOutOfBoundsException - 如果 componentIdx 大于分量数或小于 0
NullPointerException - 如果位数数组为 null

getComponentSize

public int[] getComponentSize()
返回每个颜色/alpha 分量的位数数组。该数组包含以 ColorSpace 指定的顺序排列的颜色分量，后面是 alpha 分量（如果存在）。

返回：
每个颜色/alpha 分量的位数的数组

getTransparency

public int getTransparency()
返回透明度。返回 OPAQUE、BITMASK 或 TRANSLUCENT。

指定者：
接口 Transparency 中的 getTransparency
返回：
此 ColorModel 的透明度。
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT

getNumComponents

public int getNumComponents()
返回此 ColorModel 中分量数（包括 alpha 分量数）。此分量数等于颜色分量数，或者加 1（如果存在 alpha 分量）。

返回：
此 ColorModel 中分量数

getNumColorComponents

public int getNumColorComponents()
返回此 ColorModel 中颜色分量数。这是 ColorSpace.getNumComponents() 返回的分量数。

返回：
此 ColorModel 中颜色分量数。
另请参见：
ColorSpace.getNumComponents()

getRed

public abstract int getRed(int pixel)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将该像素值指定为 int。如果此 ColorModel 的像素值不便于用单个 int 表示，则抛出 IllegalArgumentException。返回的值不是预先乘得的值。例如，如果预乘了 alpha，则此方法会在返回值之前除以 alpha。如果 alpha 值为 0，则红色值为 0。

参数：
pixel - 指定的像素
返回：
指定像素的红色分量的值。

getGreen

public abstract int getGreen(int pixel)
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将该像素值指定为 int。如果此 ColorModel 的像素值不便于用单个 int 表示，则抛出 IllegalArgumentException。返回的值是一个非预先乘得的值。例如，如果预乘了 alpha，则此方法会在返回值之前除以 alpha。如果 alpha 值为 0，则绿色值为 0。

参数：
pixel - 指定的像素
返回：
指定像素的绿色分量的值。

getBlue

public abstract int getBlue(int pixel)
返回指定像素的蓝色分量的值，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将该像素值指定为 int。如果此 ColorModel 的像素值不便于用单个 int 表示，则抛出 IllegalArgumentException。返回的值为非预先乘得的值，例如，如果与 alpha 预先相乘，此方法会在返回值之前除以 alpha。如果 alpha 值为 0，则蓝色值为 0。

参数：
pixel - 指定的像素
返回：
指定像素的蓝色分量的值。

getAlpha

public abstract int getAlpha(int pixel)
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。像素值指定为 int。如果此 ColorModel 的像素值不便于用单个 int 表示，则抛出 IllegalArgumentException。

参数：
pixel - 指定的像素
返回：
该指定像素的 alpha 分量的值。

getRGB

public int getRGB(int pixel)
返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。如有必要，可进行颜色转换。将该像素值指定为 int。如果此 ColorModel 的像素值不便于用单个 int 表示，则抛出 IllegalArgumentException。返回的值是非预乘格式。例如，如果预乘 alpha，此方法会将 alpha 从颜色分量中除出来。如果 alpha 值为 0，则颜色值为 0。

参数：
pixel - 指定的像素
返回：
指定像素的颜色/alpha 分量的 RGB 值。
另请参见：
getRGBdefault()

getRed

public int getRed(Object inData)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。返回的值是一个非预先乘得的值。例如，如果预乘了 alpha，则此方法会在返回值之前除以 alpha。如果 alpha 值为 0，则红色值为 0。如果 inData 不为类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。如果此 transferType 不受支持，则抛出 UnsupportedOperationException。因为 ColorModel 为抽象类，所以任何实例必须是子类的实例。子类可以继承此方法的实现，并且如果子类未重写此方法，则在该子类使用除 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之外的 transferType 时，此方法将抛出异常。

参数：
inData - 像素值的数组
返回：
指定像素的红色分量的值。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此 ColorModel 的像素值
UnsupportedOperationException - 如果此 tranferType 不受此 ColorModel 支持

getGreen

public int getGreen(Object inData)
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255）。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。返回的值为非预先乘得的值。例如，如果预乘了 alpha，则此方法会在返回值之前除以 alpha。如果 alpha 值为 0，则绿色值为 0。如果 inData 不为类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。如果此 transferType 不受支持，则抛出 UnsupportedOperationException。因为 ColorModel 为抽象类，所以任何实例必须是子类的实例。子类可以继承此方法的实现，并且如果子类未重写此方法，则在该子类使用除 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之外的 transferType 时，此方法将抛出异常。

参数：
inData - 像素值的数组
返回：
指定像素的绿色分量的值。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此 ColorModel 的像素值
UnsupportedOperationException - 如果此 tranferType 不受此 ColorModel 支持

getBlue

public int getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。返回的值是一个非预先乘得的值。例如，如果预乘了 alpha，则此方法会在返回值之前除以 alpha。如果 alpha 值为 0，则蓝色值将为 0。如果 inData 不为类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。如果此 transferType 不受支持，则抛出 UnsupportedOperationException。因为 ColorModel 为抽象类，所以任何实例必须是子类的实例。子类可以继承此方法的实现，并且如果子类未重写此方法，则在该子类使用除 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之外的 transferType 时，此方法将抛出异常。

参数：
inData - 像素值的数组
返回：
指定像素的蓝色分量的值。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此 ColorModel 的像素值
UnsupportedOperationException - 如果此 tranferType 不受此 ColorModel 支持

getAlpha

public int getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果 inData 不为类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。如果此 transferType 不受支持，则抛出 UnsupportedOperationException。因为 ColorModel 为抽象类，所以任何实例必须是子类的实例。子类可以继承此方法的实现，并且如果子类未重写此方法，则在该子类使用除 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之外的 transferType 时，此方法将抛出异常。

参数：
inData - 指定的像素
返回：
指定像素（从 0 到 255 缩放）的 alpha 分量。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此 ColorModel 的像素值
UnsupportedOperationException - 如果此 tranferType 不受此 ColorModel 支持

getRGB

public int getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果 inData 不为类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。返回的值将是非预乘格式，例如，如果与 alpha 预先相乘，此方法会将其从颜色分量中除出来（如果 alpha 值为 0，则颜色值将为 0）。

参数：
inData - 指定像素
返回：
该指定像素的颜色和 alpha 分量。
另请参见：
getRGBdefault()

getDataElements

public Object getDataElements(int rgb,
                              Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。然后将此数组传递到 WritableRaster 对象的 WritableRaster.setDataElements(int, int, java.lang.Object) 方法。如果像素变量为 null，则分配一个新数组。如果 pixel 不为 null，则它必须是类型 transferType 的基本数组；否则将抛出 ClassCastException。如果 pixel 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。返回该像素数组。如果此 transferType 不受支持，则抛出 UnsupportedOperationException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
rgb - 默认 RGB 颜色模式中的整数像素表示形式
pixel - 指定像素
返回：
此 ColorModel 中指定像素的数组表示形式。
抛出：
ClassCastException - 如果 pixel 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 pixel 不是特别大，不能存储此 ColorModel 的像素值
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getComponents

public int[] getComponents(int pixel,
                           int[] components,
                           int offset)
返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。将像素值指定为 int。如果此 ColorModel 的像素值不便于用单个 int 表示，或者此 ColorModel 的颜色分量值不便于以非标准化形式表示，则将抛出 IllegalArgumentException。例如，此方法可用于检索 DirectColorModel 中特定像素值的分量。如果分量数组为 null，则分配一个新数组。该分量数组将被返回。将颜色/alpha 分量存储在以 offset 开头的 component 数组中，即便此方法已分配了数组也如此。如果分量数组不为 null，且不是特别大，不能存储以偏移量开头的所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
pixel - 指定的像素
components - 收到指定像素的颜色和 alpha 分量的数组
offset - 开始存储颜色和 alpha 分量时的 components 数组的偏移量
返回：
包含以指定偏移量开头的指定像素的颜色和 alpha 分量的数组。
抛出：
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持

getComponents

public int[] getComponents(Object pixel,
                           int[] components,
                           int offset)
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果 pixel 不为类型 transferType 的基本数组，则抛出 ClassCastException。如果此 ColorModel 的颜色分量值不方便以非标准化形式表示，则抛出 IllegalArgumentException。如果 pixel 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。此方法可用于获取任何 ColorModel 中的指定像素值的分量。如果分量数组为 null，则分配一个新数组。该分量数组将被返回。将颜色/alpha 分量存储在以 offset 开头的 components 数组中，即便此方法已分配了数组也如此。如果分量数组不为 null，且不是特别大，不能存储所有颜色和 alpha 分量（以 offset开头），则抛出 ArrayIndexOutOfBoundsException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
pixel - 指定像素
components - 收到该指定像素的颜色和 alpha 分量的数组
offset - 在其处开始存储指定像素的颜色和 alpha 分量的 components 数组的索引
返回：
包含以指定偏移量开头的指定像素的颜色和 alpha 分量的数组。
抛出：
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持

getUnnormalizedComponents

public int[] getUnnormalizedComponents(float[] normComponents,
                                       int normOffset,
                                       int[] components,
                                       int offset)
在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。非标准化分量为 0 和 2n - 1 之间的无符号整数值，其中 n 为特定分量的位数。标准化分量为 float 值，这些值介于此 ColorModel 的 ColorSpace 对象指定的每个分量的最小值和最大值之间。如果此 ColorModel 的颜色分量值不便于用非标准化形式表示，则抛出 IllegalArgumentException。如果 components 数组为 null，则分配一个新数组。该 components 数组将被返回。将颜色/alpha 分量存储在以 offset 开头的 components 数组中，即便此方法已分配了数组也如此。如果 components 数组不为 null，且不是特别大，不能存储所有颜色和 alpha 分量（以 offset 开头），则抛出 ArrayIndexOutOfBoundsException。如果 normComponents 数组不是特别大，不能存储以 normOffset 开头的所有颜色和 alpha 分量，则抛出 IllegalArgumentException。

参数：
normComponents - 包含标准化分量的数组
normOffset - 开始检索标准化分量的 normComponents 数组的偏移量
components - 从 normComponents 检索分量的数组
offset - 在其处开始存储 normComponents 的 components 的索引
返回：
包含非标准化颜色和 alpha 分量的数组。
抛出：
IllegalArgumentException - 如果此 ColorModel 的分量值不便于用非标准化形式表示。
IllegalArgumentException - 如果 normComponents 的长度减去 normOffset 小于 numComponents
UnsupportedOperationException - 如果此 ColorModel 的构造方法调用了 super(bits) 构造方法，但未重写此方法。参见构造方法，ColorModel(int)。

getNormalizedComponents

public float[] getNormalizedComponents(int[] components,
                                       int offset,
                                       float[] normComponents,
                                       int normOffset)
在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。非标准化分量为 0 和 2n - 1 之间的无符号整数值，其中 n 为特定分量的位数。标准化分量为 float 值，这些值介于此 ColorModel 的 ColorSpace 对象指定的每个分量的最小值和最大值之间。如果此 ColorModel 的颜色分量值不便于用非标准化形式表示，则抛出 IllegalArgumentException。如果 normComponents 数组为 null，则分配一个新数组。该 normComponents 数组将被返回。颜色/alpha 分量存储在以 normOffset 开头的 normComponents 数组中，即使此方法已分配了数组也如此。如果 normComponents 数组不为 null，且不是特别大，不能存储所有颜色和 alpha 分量（以 normOffset 开头），则抛出 ArrayIndexOutOfBoundsException。如果 components 数组不是特别大，不能存储以 offset 开头的所有颜色和 alpha 分量，则抛出 IllegalArgumentException。

因为 ColorModel 为抽象类，所以任何实例都是子类的实例。此抽象类中该方法的默认实现假定此类的分量值可以方便地以非标准化的形式表示。因此，可能有不支持非标准化形式的实例的子类必须重写此方法。

参数：
components - 包含非标准化分量的数组
offset - 开始检索非标准化分量的 components 数组的偏移量
normComponents - 收到标准化分量的数组
normOffset - 在其处开始存储标准化分量的 normComponents 的索引
返回：
包含标准化颜色和 alpha 分量的数组。
抛出：
IllegalArgumentException - 如果此 ColorModel 的分量值不便于用非标准化形式表示。
UnsupportedOperationException - 如果此 ColorModel 的构造方法调用了 super(bits) 构造方法，但未重写此方法。参见构造方法，ColorModel(int)。
UnsupportedOperationException - 如果此方法不能确定每个分量的位数

getDataElement

public int getDataElement(int[] components,
                          int offset)
在已给定非标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中以 int 类型表示的像素值。如果此 ColorModel 中的分量值不便于用单个 int 表示，或者此 ColorModel 的颜色分量值不便于用非标准化形式表示，则此方法将抛出 IllegalArgumentException。如果 components 数组不是特别大，不能存储所有以 offset 开始的颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
components - 非标准化的颜色和 alpha 分量的数组
offset - 开始检索颜色和 alpha 分量处的 components 的索引
返回：
此 ColorModel 中与指定分量相对应的 int 像素值。
抛出：
IllegalArgumentException - 如果此 ColorModel 的像素值不便于用单个 int 表示
IllegalArgumentException - 如果此 ColorModel 的分量值不便于用非标准化形式表示
ArrayIndexOutOfBoundsException - 如果 components 数组不是特别大，不能存储以 offset 开头的所有颜色和 alpha 分量
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持

getDataElements

public Object getDataElements(int[] components,
                              int offset,
                              Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。然后可以将此数组传递给 WritableRaster 对象的 setDataElements 方法。如果此 ColorModel 的颜色分量值不便于用非标准化形式表示，则此方法将抛出 IllegalArgumentException。如果 components 数组不是特别大，不能存储所有以 offset 开始的颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。如果 obj 变量为 null，则分配一个新数组。如果 obj 不为 null，则它必须为类型 transferType 的基本数组；否则将抛出 ClassCastException。如果 obj 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
components - 非标准化的颜色和 alpha 分量的数组
offset - 开始检索颜色和 alpha 分量处的 components 的索引
obj - 表示颜色和 alpha 分量的数组的 Object
返回：
表示颜色和 alpha 分量的数组的 Object。
抛出：
ClassCastException - 如果 obj 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 obj 不是特别大，不能存储此 ColorModel 的像素值，或者 components 数组不是特别大，不能存储以 offset 开头的所有颜色和 alpha 分量
IllegalArgumentException - 如果此 ColorModel 的分量值不便于用非标准化形式表示
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getDataElement

public int getDataElement(float[] normComponents,
                          int normOffset)
在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。如果此 ColorModel 的像素值不便于用单个 int，则此方法将抛出 IllegalArgumentException。如果 normComponents 数组不是特别大，不能存储所有以 normOffset 开头的颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。此抽象类中该方法的默认实现先从标准化形式转换到非标准化形式，然后再调用 getDataElement(int[], int)。可能有不支持非标准化形式的实例的子类必须重写此方法。

参数：
normComponents - 标准化颜色和 alpha 分量的数组
normOffset - 开始检索颜色和 alpha 分量的 normComponents 的索引
返回：
此 ColorModel 中对应于指定分量的 int 像素值。
抛出：
IllegalArgumentException - 如果此 ColorModel 的像素值不便于用单个 int 表示
ArrayIndexOutOfBoundsException - 如果 normComponents 数组不是特别大，不能存储以 normOffset 开头的所有颜色和 alpha 分量
从以下版本开始：
1.4

getDataElements

public Object getDataElements(float[] normComponents,
                              int normOffset,
                              Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。然后可以将此数组传递给 WritableRaster 对象的 setDataElements 方法。如果 normComponents 数组不是特别大，不能存储所有以 normOffset 开头的颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。如果 obj 变量为 null，则分配一个新数组。如果 obj 不为 null，则它必须为类型 transferType 的基本数组；否则将抛出 ClassCastException。如果 obj 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。此抽象类中该方法的默认实现先从标准化形式转换到非标准化形式，然后再调用 getDataElement(int[], int, Object)。可能有不支持非标准化形式的实例的子类必须重写此方法。

参数：
normComponents - 标准化颜色和 alpha 分量的数组
normOffset - 开始检索颜色和 alpha 分量的 normComponents 的索引
obj - 保存返回的像素的基本数据数组
返回：
为像素的基本数据数组表示形式的 Object
抛出：
ClassCastException - 如果 obj 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 obj 不是特别大，不能存储此 ColorModel 的像素值，或者 normComponents 数组不是特别大，不能存储以 normOffset 开头的所有颜色和 alpha 分量
从以下版本开始：
1.4
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getNormalizedComponents

public float[] getNormalizedComponents(Object pixel,
                                       float[] normComponents,
                                       int normOffset)
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果像素不为类型 transferType 的基本数组，则抛出 ClassCastException。如果 pixel 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。标准化分量为 float 值，这些值介于此 ColorModel 的 ColorSpace 对象指定的每个分量的最小值和最大值之间。如果 normComponents 数组为 null，则分配一个新数组。该 normComponents 数组将被返回。颜色/alpha 分量存储在以 normOffset 开头的 normComponents 数组中，即使此方法已分配了数组也如此。如果 normComponents 数组不为 null，且不是特别大，不能存储所有颜色和 alpha 分量（以 normOffset 开头），则抛出 ArrayIndexOutOfBoundsException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。此抽象类中该方法的默认实现先使用 getComponents(Object, int[], int) 检索以非标准化形式存在的颜色和 alpha 分量，然后再调用 getNormalizedComponents(int[], int, float[], int)。可能有不支持非标准化形式的实例的子类必须重写此方法。

参数：
pixel - 指定像素
normComponents - 检索标准化分量的数组
normOffset - 在其处开始存储标准化分量的 normComponents 数组的偏移量
返回：
包含标准化颜色和 alpha 分量的数组。
抛出：
ClassCastException - 如果 pixel 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 normComponents 不是特别大，不能存储以 normOffset 开头的所有颜色和 alpha 分量
ArrayIndexOutOfBoundsException - 如果 pixel 不是特别大，不能存储此 ColorModel 的像素值。
UnsupportedOperationException - 如果此 ColorModel 的构造方法调用了 super(bits) 构造方法，但未重写此方法。参见构造方法，ColorModel(int)。
UnsupportedOperationException - 如果此方法不能确定每个分量的位数
从以下版本开始：
1.4

equals

public boolean equals(Object obj)
测试指定的 Object 是否是 ColorModel 的实例，以及它是否等于此 ColorModel。

覆盖：
类 Object 中的 equals
参数：
obj - 用来进行相等性测试的 Object
返回：
如果指定的 Object 为 ColorModel 的实例，且等于此 ColorModel，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 ColorModel 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 ColorModel 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

getColorSpace

public final ColorSpace getColorSpace()
返回与此 ColorModel 相关的 ColorSpace。

返回：
此 ColorModel 的 ColorSpace。

coerceData

public ColorModel coerceData(WritableRaster raster,
                             boolean isAlphaPremultiplied)
强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。可以将颜色 raster 数据乘以或除以 alpha，如果该数据处于正确状态，则不执行任何操作。如果需要对该数据强制匹配，则此方法还将相应地返回一个带有 isAlphaPremultiplied 标志集的 ColorModel 的实例。如果此方法不受 ColorModel 支持，则它将抛出 UnsupportedOperationException。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
raster - WritableRaster 数据
isAlphaPremultiplied - 如果与 alpha 预乘，则返回 true；否则将返回 false
返回：
表示被强制匹配数据的 ColorModel 对象。

isCompatibleRaster

public boolean isCompatibleRaster(Raster raster)
如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
raster - 进行兼容性测试的 Raster 对象
返回：
true 如果 raster 与此 ColorModel 兼容。
抛出：
UnsupportedOperationException - 如果此方法不是为此 ColorModel 实现的。

createCompatibleWritableRaster

public WritableRaster createCompatibleWritableRaster(int w,
                                                     int h)
用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
w - 应用到新 WritableRaster 的宽度
h - 应用到新 WritableRaster 的高度
返回：
具有指定宽度和高度的 WritableRaster 对象。
抛出：
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持
另请参见：
WritableRaster, SampleModel

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
w - 应用于新的 SampleModel 的宽度
h - 应用于新的 SampleModel 的高度
返回：
具有指定宽度和高度的 SampleModel 对象。
抛出：
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持
另请参见：
SampleModel

isCompatibleSampleModel

public boolean isCompatibleSampleModel(SampleModel sm)
检查 SampleModel 是否与此 ColorModel 兼容。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，因为此抽象类中的实现抛出了 UnsupportedOperationException。

参数：
sm - 指定的 SampleModel
返回：
如果指定的 SampleModel 与此 ColorModel 兼容，则返回 true；否则返回 false。
抛出：
UnsupportedOperationException - 如果此方法不受此 ColorModel 支持
另请参见：
SampleModel

finalize

public void finalize()
一旦不再引用此 ColorModel，就要释放与此 ColorModel 相关的系统资源。

覆盖：
类 Object 中的 finalize

getAlphaRaster

public WritableRaster getAlphaRaster(WritableRaster raster)
返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。此方法假定与此类 ColorModel 相关的 Raster 对象将 alpha 的 band（如果存在）存储为图像数据的最后一个 band。如果不存在与此 ColorModel 相关的独立空间 alpha 通道，则返回 null。如果在查询表中有一个具有 alpha 的 IndexColorModel，则此方法将返回 null，因为没有空间上截然不同的 alpha 通道。此方法将创建新的 Raster（但将共享数据数组）。因为 ColorModel 为抽象类，所以任何实例都是子类的实例。子类必须重写此方法，以获取除返回 null 之外的任何行为，因为此抽象类中的实现返回 null。

参数：
raster - 指定的 Raster
返回：
表示图像（从指定的 Raster 中得到）的 alpha 通道的 Raster。

toString

public String toString()
返回此 ColorModel 对象的内容的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
表示此 ColorModel 对象的内容的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentColorModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ComponentColorModel

java.lang.Object
    继承者  java.awt.image.ColorModel
        继承者  java.awt.image.ComponentColorModel
所有已实现的接口：
Transparency
public class ComponentColorModel
extends ColorModel

使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。此类可以与任意 ColorSpace 一起使用。像素值中的颜色样本数必须与 ColorSpace 中的颜色分量数相同。可以有单个 alpha 样本。

对于那些使用 transferType 类型的基本数组像素表示形式的方法，数组的长度与颜色和 alpha 样本数相同。颜色样本存储在后跟 alpha 样本（如果存在）的数组的前面。颜色样本的顺序由 ColorSpace 指定。通常，此顺序反映颜色空间类型的名称。例如，对于 TYPE_RGB，索引 0 对应于红色，索引 1 对应于绿色，索引 2 对应于蓝色。

出于显示或处理目的而执行的像素值到颜色/alpha 分量的转换是基于从样本到分量的一一对应关系进行的。由实例表示的像素样本值可以是有符号的或无符号的，也可以是整型或者 float 或 double 类型（有关细节请参见以下内容），具体取决于用来创建 ComponentColorModel 实例的传输类型。从样本值到标准化颜色/alpha 分量的转换必须遵循一定的规则。对于 float 和 double 样本，转换为一种标识，即标准化分量值等于相应的样本值。对于整数样本，转换应该只是简单缩放和偏移，其中每个分量的缩放和偏移常量可以有所不同。应用缩放和偏移常量的结果是形成一组颜色/alpha 分量值，这样可以保证这些值落到一定范围内。通常，颜色分量的范围将为由 ColorSpace 类的 getMinValue 和 getMaxValue 方法定义的范围。alpha 分量的范围应为从 0.0 到 1.0。

用传输类型 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 和 DataBuffer.TYPE_INT 创建的 ComponentColorModel 的实例具有被视为无符号整数值的像素样本值。像素值的颜色或 alpha 样本中的位数可能不同于传递到 ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) 构造方法的相应颜色或 alpha 样本的位数。在这种情况下，此类假定样本值的 n 位最低有效位保存分量值，其中 n 为传递到构造方法的分量的有效位数。它还假定样本值中所有较高位都为零。因此，样本值的范围为 0 到 2n - 1。此类将这些样本值映射到标准化颜色分量值，以使 0 映射到从每个分量的 ColorSpace 的 getMinValue 方法得到的值，2n - 1 映射到从 getMaxValue 得到的值。创建具有不同颜色样本映射的 ComponentColorModel 需要子类化此类，并重写 getNormalizedComponents(Object, float[], int) 方法。alpha 样本的映射始终将 0 映射到 0.0，将 2n - 1 映射到 1.0。

对于带有无符号样本值的实例，仅当两个条件都具备时，非标准化的颜色/alpha 分量表示形式才受支持。首先，样本值 0 必须映射到标准化分量值 0.0，样本值 2n - 1 映射到 1.0。其次，ColorSpace 的所有颜色分量的最小值/最大取值范围必须为 0.0 到 1.0 之间。在这种情况下，分量表示形式为相应样本的 n 位最低有效位。因此，每个分量都为介于 0 和 2n - 1 之间的无符号整数值，其中 n 为特定分量的有效位数。如果未满足这些条件，则采用非标准化分量参数的任何方法都将抛出 IllegalArgumentException。

用传输类型 DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 和 DataBuffer.TYPE_DOUBLE 创建的 ComponentColorModel 的实例具有被视为有符号的 short、float 或 double 值的像素样本值。此类实例不支持非标准化的颜色/alpha 分量表示形式，因此将此类表示形式用作参数在这些实例的其中之一上调用任何方法都将抛出 IllegalArgumentException。此类实例的标准化分量的取值范围取决于传输类型，如下所示：对于 float 样本，则为 float 数据类型的完整范围；对于 double 样本，则为 float 数据类型（通过将 double 强制转换为 float 得到）的完整范围；对于 short 样本，大致为 -maxVal 到 +maxVal，其中 maxVal 为 ColorSpace 的每分量最大值（-32767 映射到 -maxVal，0 映射到 0.0，32767 映射到 +maxVal）。通过重写 getNormalizedComponents(Object, float[], int) 方法，子类可以重写 short 样本值到标准化分量值的缩放。对于 float 和 double 样本，标准化分量值被视为等于相应的样本值，子类不应试图添加这些传输类型的任何非标识缩放。

用传输类型 DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 和 DataBuffer.TYPE_DOUBLE 创建的 ComponentColorModel 的实例使用所有样本值的所有位。因此，使用 DataBuffer.TYPE_SHORT 时所有颜色/alpha 分量都有 16 位，使用 DataBuffer.TYPE_FLOAT 时都有 32，使用 DataBuffer.TYPE_DOUBLE 时都有 64 位。当构造方法的 ComponentColorModel(ColorSpace, int[], boolean, boolean, int, int) 形式与这些传输类型之一一起使用时，位数组参数将被忽略。

可能将不能合理解释的颜色/alpha 样本值视为用于呈现的分量值。当子类化 ComponentColorModel 以重写无符号样本值到标准化颜色分量值的映射时，或当使用某一范围之外的有符号样本值时，此现象可能发生。（例如，将 alpha 分量指定为范围 0 到 32767（即标准化范围 0.0 到 1.0）之外的有符号 short 值可能导致不可预料的结果）。应用程序负责在呈现之前适当缩放像素数据，以使颜色分量落在 ColorSpace（使用 ColorSpace 类的 getMinValue 和 getMaxValue 方法得到）的标准化范围内，并使 alpha 分量位于 0.0 和 1.0 之间。如果颜色或 alpha 分量值超出这些范围，则呈现结果是不确定的。

使用单个 int 像素表示形式的方法抛出 IllegalArgumentException，除非 ComponentColorModel 的分量数为 1 且分量值无符号，即使用 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 的传输类型的单个颜色分量，没有 alpha 分量。

ComponentColorModel 可以与 ComponentSampleModel、BandedSampleModel 或 PixelInterleavedSampleModel 一起使用，以构造 BufferedImage。

另请参见：
ColorModel, ColorSpace, ComponentSampleModel, BandedSampleModel, PixelInterleavedSampleModel, BufferedImage

字段摘要
从类 java.awt.image.ColorModel 继承的字段
pixel_bits, transferType
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
ComponentColorModel(ColorSpace colorSpace, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
根据指定参数构造 ComponentColorModel。
ComponentColorModel(ColorSpace colorSpace, int[] bits, boolean hasAlpha, boolean isAlphaPremultiplied, int transparency, int transferType)
根据指定参数构造 ComponentColorModel。
方法摘要
ColorModel | coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
SampleModel | createCompatibleSampleModel(int w, int h) 用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
WritableRaster | createCompatibleWritableRaster(int w, int h) 用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
boolean | equals(Object obj) 将此颜色模型与其他模型进行相等性比较。
int | getAlpha(int pixel) 返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
int | getAlpha(Object inData) 返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
WritableRaster | getAlphaRaster(WritableRaster raster) 返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。
int | getBlue(int pixel) 返回指定像素的蓝色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getBlue(Object inData) 返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int[] | getComponents(int pixel, int[] components, int offset) 返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。
int[] | getComponents(Object pixel, int[] components, int offset) 返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。
int | getDataElement(float[] normComponents, int normOffset) 在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
int | getDataElement(int[] components, int offset) 返回在 ColorModel 中表示为 int 的像素值（已给定非标准化颜色/alpha 分量的数组）。
Object | getDataElements(float[] normComponents, int normOffset, Object obj) 在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
Object | getDataElements(int[] components, int offset, Object obj) 在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。
Object | getDataElements(int rgb, Object pixel) 在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
int | getGreen(int pixel) 返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getGreen(Object inData) 返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
float[] | getNormalizedComponents(int[] components, int offset, float[] normComponents, int normOffset) 在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。
float[] | getNormalizedComponents(Object pixel, float[] normComponents, int normOffset) 返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。
int | getRed(int pixel) 返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getRed(Object inData) 返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getRGB(int pixel) 返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。
int | getRGB(Object inData) 返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
int[] | getUnnormalizedComponents(float[] normComponents, int normOffset, int[] components, int offset) 在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。
boolean | isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。
boolean | isCompatibleSampleModel(SampleModel sm) 检查指定 SampleModel 是否与此 ColorModel 兼容。
从类 java.awt.image.ColorModel 继承的方法
finalize, getColorSpace, getComponentSize, getComponentSize, getNumColorComponents, getNumComponents, getPixelSize, getRGBdefault, getTransferType, getTransparency, hasAlpha, hashCode, isAlphaPremultiplied, toString
从类 java.lang.Object 继承的方法
clone, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ComponentColorModel

public ComponentColorModel(ColorSpace colorSpace,
                           int[] bits,
                           boolean hasAlpha,
                           boolean isAlphaPremultiplied,
                           int transparency,
                           int transferType)
根据指定参数构造 ComponentColorModel。颜色分量将在指定的 ColorSpace 中。受支持的传输类型为 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 和 DataBuffer.TYPE_DOUBLE。如果不为 null，则 bits 数组指定每个颜色和 alpha 分量的有效位数，并且如果像素值中不存在 alpha 信息，则其长度至少应该是 ColorSpace 中分量数，如果存在 alpha 信息，则其长度大于此数。当 transferType 为 DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 时，忽略 bits 数组参数。hasAlpha 指示是否存在 alpha 信息。如果 hasAlpha 为 true，则布尔值 isAlphaPremultiplied 指定如何解释像素值中的颜色和 alpha 样本。如果布尔值为 true，则假定颜色样本已与 alpha 样本相乘。transparency 指定可以由此颜色模型表示的 alpha 值。可以接受的 transparency 值为 OPAQUE、BITMASK 或 TRANSLUCENT。transferType 是用于表示像素值的基本数组的类型。

参数：
colorSpace - 与此颜色模型关联的 ColorSpace。
bits - 每个分量的有效位数。可以为 null，在这种情况下，所有分量样本的所有位都将有效。如果 transferType 为 DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 之一，则忽略，在这种情况下，所有分量样本的所有位都将有效。
hasAlpha - 如果为 true，则此颜色模型支持 alpha。
isAlphaPremultiplied - 如果为 true，则 alpha 预乘的。
transparency - 指定可以由此颜色模型表示的 alpha 值。
transferType - 指定用于表示像素值的基本数组的类型。
抛出：
IllegalArgumentException - 如果 bits 数组参数不为 null，则其长度小于颜色和 alpha 分量数，且 transferType 为 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之一。
IllegalArgumentException - 如果 transferType 不为 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 之一。
另请参见：
ColorSpace, Transparency

ComponentColorModel

public ComponentColorModel(ColorSpace colorSpace,
                           boolean hasAlpha,
                           boolean isAlphaPremultiplied,
                           int transparency,
                           int transferType)
根据指定参数构造 ComponentColorModel。颜色分量将在指定的 ColorSpace 中。受支持的传输类型为 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 和 DataBuffer.TYPE_DOUBLE。每个颜色和 alpha 分量的有效位数都分别为 8、16、32、16、32 或 64。颜色分量数为 ColorSpace 中的分量数。如果 hasAlpha 为 true，则存在 alpha 分量。如果 hasAlpha 为 true，则布尔值 isAlphaPremultiplied 指定如何解释像素值中的颜色和 alpha 样本。如果布尔值为 true，则假定颜色样本已与 alpha 样本相乘。transparency 指定可以由此颜色模型表示的 alpha 值。可以接受的 transparency 值为 OPAQUE、BITMASK 或 TRANSLUCENT。transferType 是用于表示像素值的基本数组的类型。

参数：
colorSpace - 与此颜色模型关联的 ColorSpace。
hasAlpha - 如果为 true，则此颜色模型支持 alpha。
isAlphaPremultiplied - 如果为 true，则 alpha 预乘的。
transparency - 指定可以由此颜色模型表示的 alpha 值。
transferType - 指定用于表示像素值的基本数组的类型。
抛出：
IllegalArgumentException - 如果 transferType 不为 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 之一。
从以下版本开始：
1.4
另请参见：
ColorSpace, Transparency
方法详细信息

getRed

public int getRed(int pixel)
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将像素值指定为 int。返回的值为非预先乘得的值。如果与 alpha 预先相乘，此方法将在返回值（如果 alpha 值为 0，则红色值将为 0）之前将其除出来。

指定者：
类 ColorModel 中的 getRed
参数：
pixel - 要从中获取红色分量的像素。
返回：
指定像素（int 类型）的红色分量。
抛出：
IllegalArgumentException - 如果此 ColorModel 中有一个以上的分量。
IllegalArgumentException - 如果此 ColorModel 的分量值为有符号的。

getGreen

public int getGreen(int pixel)
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将像素值指定为 int。返回的值为非预先乘得的值。如果与 alpha 预先相乘，此方法将在返回值（如果 alpha 值为 0，则绿色值将为 0）之前将其除出来。

指定者：
类 ColorModel 中的 getGreen
参数：
pixel - 要从中获取绿色分量的像素。
返回：
指定像素（int 类型）的绿色分量。
抛出：
IllegalArgumentException - 如果此 ColorModel 中有一个以上的分量。
IllegalArgumentException - 如果此 ColorModel 的分量值为有符号的。

getBlue

public int getBlue(int pixel)
返回指定像素的蓝色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将像素值指定为 int。返回的值为非预先乘得的值。如果与 alpha 预先相乘，此方法将在返回值（如果 alpha 值为 0，则蓝色值将为 0）之前将其除出来。

指定者：
类 ColorModel 中的 getBlue
参数：
pixel - 要从中获取蓝色分量的像素。
返回：
指定像素（int 类型）的蓝色分量。
抛出：
IllegalArgumentException - 如果此 ColorModel 中有一个以上的分量。
IllegalArgumentException - 如果此 ColorModel 的分量值为有符号的。

getAlpha

public int getAlpha(int pixel)
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。像素值指定为 int。

指定者：
类 ColorModel 中的 getAlpha
参数：
pixel - 要从中获取 alpha 分量的像素。
返回：
指定像素（int 类型）的 alpha 分量。
抛出：
IllegalArgumentException - 如果此 ColorModel 中有一个以上的分量。
IllegalArgumentException - 如果此 ColorModel 的分量值为有符号的。

getRGB

public int getRGB(int pixel)
返回默认的 RGB 颜色模型格式中像素的颜色/alpha 分量。如有必要，可进行颜色转换。返回的值是非预乘格式。如果与 alpha 预先相乘，此方法会将其从颜色分量（如果 alpha 值为 0，则颜色值为 0）中除出来。

覆盖：
类 ColorModel 中的 getRGB
参数：
pixel - 要从中获取颜色/alpha 分量的像素。
返回：
指定像素（int 类型）的颜色/alpha 分量。
抛出：
IllegalArgumentException - 如果此 ColorModel 中有一个以上的分量。
IllegalArgumentException - 如果此 ColorModel 的分量值为有符号的。
另请参见：
ColorModel.getRGBdefault()

getRed

public int getRed(Object inData)
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。pixel 值由作为对象引用而传入的类型 transferType 的数据元素的数组指定。返回的值为非预先乘得的值。如果与 alpha 预先相乘，此方法将在返回值（如果 alpha 值为 0，则红色值将为 0）之前将其除出来。因为 ComponentColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getRed
参数：
inData - 要从中获取红色分量（由类型 transferType 的数据元素的数组指定）的像素。
返回：
指定像素（int 类型）的红色分量。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组。
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能保存此 ColorModel 的像素值。
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下受支持的传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE。

getGreen

public int getGreen(Object inData)
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。pixel 值由作为对象引用而传入的类型 transferType 的数据元素的数组指定。返回的值是一个非预先乘得的值。如果与 alpha 预先相乘，此方法将在返回值（如果 alpha 值为 0，则绿色值将为 0）之前将其除出来。因为 ComponentColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getGreen
参数：
inData - 要从中获取绿色分量（由类型 transferType 的数据元素的数组指定）的像素。
返回：
指定像素（int 类型）的绿色分量。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组。
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能保存此 ColorModel 的像素值。
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下受支持的传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE。

getBlue

public int getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。pixel 值由作为对象引用而传入的类型 transferType 的数据元素的数组指定。返回的值是一个非预先乘得的值。如果与 alpha 预先相乘，此方法将在返回值（如果 alpha 值为 0，则蓝色值将为 0）之前将其除出来。因为 ComponentColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getBlue
参数：
inData - 要从中获取蓝色分量（由类型 transferType 的数据元素的数组指定）的像素。
返回：
指定像素（int 类型）的蓝色分量。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组。
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能保存此 ColorModel 的像素值。
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下受支持的传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE。

getAlpha

public int getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。因为 ComponentColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getAlpha
参数：
inData - 要从中获取 alpha 分量（由类型 transferType 的数据元素的数组指定）的像素。
返回：
指定像素（int 类型）的 alpha 分量。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组。
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能保存此 ColorModel 的像素值。
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下受支持的传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE。

getRGB

public int getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。如有必要，可进行颜色转换。像素值由作为一个对象引用而传入的 transferType 类型的数据元素数组指定。返回的值是非预乘格式。如果与 alpha 预先相乘，此方法会将其从颜色分量（如果 alpha 值为 0，则颜色值为 0）中除出来。因为 ComponentColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getRGB
参数：
inData - 要从中获取颜色/alpha 分量（由类型 transferType 的数据元素的数组指定）的像素。
返回：
指定像素（int 类型）的颜色/alpha 分量。
抛出：
ClassCastException - 如果 inData 不为类型 transferType 的基本数组。
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能保存此 ColorModel 的像素值。
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下受支持的传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE。
另请参见：
ColorModel.getRGBdefault()

getDataElements

public Object getDataElements(int rgb,
                              Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。然后可以将此数组传递给 WritableRaster 对象的 setDataElements 方法。如果 pixel 参数为 null，则分配新数组。因为 ComponentColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getDataElements
参数：
rgb - RGB 颜色模型中像素的整数表示形式
pixel - 指定像素
返回：
此 ColorModel 中像素的数据元素数组表示形式。
抛出：
ClassCastException - 如果 pixel 不为 null 且不为类型 transferType 的基本数组。
ArrayIndexOutOfBoundsException - 如果 pixel 不是特别大，不能保存此 ColorModel 的像素值。
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下受支持的传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE。
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getComponents

public int[] getComponents(int pixel,
                           int[] components,
                           int offset)
返回在 ColorModel 中已给定像素的非标准化颜色/alpha 分量。如果此 ColorModel 的分量值不便于以非标准化形式表示，则返回 IllegalArgumentException。将颜色/alpha 分量存储在以 offset 开头的 components 数组中，即便此方法已分配了数组也是如此。

覆盖：
类 ColorModel 中的 getComponents
参数：
pixel - 指定为整数的像素值。
components - 在其中存储非标准化颜色/alpha 分量的整数数组。如果 components 数组为 null，则分配新数组。
offset - components 数组的偏移量。
返回：
分量数组。
抛出：
IllegalArgumentException - 如果此 ColorModel 中有一个以上的分量。
IllegalArgumentException - 如果此 ColorModel 不支持非标准化形式
ArrayIndexOutOfBoundsException - 如果 components 数组不为 null 且不是特别大，不能保存所有颜色和 alpha 分量（以偏移量开头）。

getComponents

public int[] getComponents(Object pixel,
                           int[] components,
                           int offset)
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。像素值由作为一个对象引用而传入的 transferType 类型的数据元素数组指定。如果此 ColorModel 的分量值不便于以非标准化形式表示，则返回 IllegalArgumentException。将颜色/alpha 分量存储在以 offset 开头的 components 数组中，即便此方法已分配了数组也是如此。因为 ComponentColorModel可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则在其使用不受支持的 transferType 时此方法可能抛出异常。

覆盖：
类 ColorModel 中的 getComponents
参数：
pixel - 由类型 transferType 的数据元素的数组指定的像素值。
components - 在其中存储非标准化颜色/alpha 分量的整数数组。如果 components 数组为 null，则分配新数组。
offset - components 数组的偏移量。
返回：
components 数组。
抛出：
IllegalArgumentException - 如果此 ComponentColorModel 不支持非标准化形式
UnsupportedOperationException - 在某些情况下，如果此 ComponentColorModel 的传输类型不为以下传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT。
ClassCastException - 如果 pixel 不为类型 transferType 的基本数组。
IllegalArgumentException - 如果 components 数组不为 null 且不是特别大，不能保存所有颜色或 alpha 分量（以偏移量开头），或者 pixel 不是特别大，不能保存此 ColorModel 的像素值。

getUnnormalizedComponents

public int[] getUnnormalizedComponents(float[] normComponents,
                                       int normOffset,
                                       int[] components,
                                       int offset)
在已给定标准化分量数组的情况下，返回以非标准化形式存在的所有颜色/alpha 分量的数组。非标准化分量为 0 和 2n - 1 之间的无符号整数值，其中 n 为特定分量的位数。标准化分量为 float 值，这些值介于此 ColorModel 的 ColorSpace 对象指定的每个分量的最小值和最大值之间。如果此 ColorModel 的颜色分量值不便于用非标准化形式表示，则抛出 IllegalArgumentException。如果 components 数组为 null，则分配一个新数组。components 数组将返回。将颜色/alpha 分量存储在以 offset 开头的 components 数组中，即便此方法已分配了数组也是如此。如果 components 数组不为 null 且不是特别大，不能以 offset 开头保存所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。如果 normComponents 数组不是特别大，不能保存以 normOffset 开头的所有颜色和 alpha 分量，则抛出 IllegalArgumentException。

覆盖：
类 ColorModel 中的 getUnnormalizedComponents
参数：
normComponents - 包含标准化分量的数组
normOffset - 开始检索标准化分量的 normComponents 数组的偏移量
components - 从 normComponents 检索分量的数组
offset - 在其处开始存储 normComponents 的 components 的索引
返回：
包含非标准化颜色和 alpha 分量的数组。
抛出：
IllegalArgumentException - 如果此 ComponentColorModel 不支持非标准化形式
IllegalArgumentException - 如果 normComponents 的长度减去 normOffset 小于 numComponents

getNormalizedComponents

public float[] getNormalizedComponents(int[] components,
                                       int offset,
                                       float[] normComponents,
                                       int normOffset)
在给定标准化分量数组的情况下，返回以标准化形式存在的所有颜色/alpha 分量的数组。非标准化分量为 0 和 2n - 1 之间的无符号整数值，其中 n 为特定分量的位数。标准化分量为 float 值，这些值介于此 ColorModel 的 ColorSpace 对象指定的每个分量的最小值和最大值之间。如果此 ColorModel 的颜色分量值不便于用非标准化形式表示，则抛出 IllegalArgumentException。如果 normComponents 数组为 null，则分配一个新数组。normComponents 数组将返回。颜色/alpha 分量存储在以 normOffset 开头的 normComponents 数组中，即使此方法已分配了数组也如此。如果 normComponents 数组不为 null，且不是特别大，不能保存所有颜色和 alpha 分量（以 normOffset 开头），则抛出 ArrayIndexOutOfBoundsException。如果 components 数组不是特别大，不能保存以 offset 开头的所有颜色和 alpha 分量，则抛出 IllegalArgumentException。

覆盖：
类 ColorModel 中的 getNormalizedComponents
参数：
components - 包含非标准化分量的数组
offset - 开始检索非标准化分量的 components 数组的偏移量
normComponents - 收到标准化分量的数组
normOffset - 在其处开始存储标准化分量的 normComponents 的索引
返回：
包含标准化颜色和 alpha 分量的数组。
抛出：
IllegalArgumentException - 如果此 ComponentColorModel 不支持非标准化形式

getDataElement

public int getDataElement(int[] components,
                          int offset)
返回在 ColorModel 中表示为 int 的像素值（已给定非标准化颜色/alpha 分量的数组）。

覆盖：
类 ColorModel 中的 getDataElement
参数：
components - 非标准化颜色/alpha 分量的数组。
offset - components 数组的偏移量。
返回：
表示为 int 的像素值。
抛出：
IllegalArgumentException - 如果此 ColorModel 中有一个以上的分量。
IllegalArgumentException - 如果此 ComponentColorModel 不支持非标准化形式

getDataElements

public Object getDataElements(int[] components,
                              int offset,
                              Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。然后可以将此数组传递给 WritableRaster 对象的 setDataElements 方法。

覆盖：
类 ColorModel 中的 getDataElements
参数：
components - 非标准化颜色/alpha 分量的数组。
offset - components 数组的整数偏移量。
obj - 在其中存储像素的数据元素数组表示形式的对象。如果 obj 变量为 null，则分配新数组。如果 obj 不为 null，则其必须为类型 transferType 的基本数组。如果 obj 不是特别大，不能保存此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 ComponentColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。
返回：
此 ColorModel 中像素的数据元素数组表示形式。
抛出：
IllegalArgumentException - 如果分量数组不是特别大，不能保存所有以偏移量开头的颜色和 alpha 分量。
ClassCastException - 如果 obj 不为 null 且不为类型 transferType 的基本数组。
ArrayIndexOutOfBoundsException - 如果 obj 不是特别大，不能保存此 ColorModel 的像素值。
IllegalArgumentException - 如果此 ComponentColorModel 不支持非标准化形式
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT。
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getDataElement

public int getDataElement(float[] normComponents,
                          int normOffset)
在已给定标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。如果此 ColorModel 的像素值不便于用单个 int，则此方法将抛出 IllegalArgumentException。如果 normComponents 数组不是特别大，不能保存所有以 normOffset 开头的颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ColorModel 中的 getDataElement
参数：
normComponents - 标准化颜色和 alpha 分量的数组
normOffset - 开始检索颜色和 alpha 分量的 normComponents 的索引
返回：
此 ColorModel 中对应于指定分量的 int 像素值。
抛出：
IllegalArgumentException - 如果此 ColorModel 的像素值不便于用单个 int 表示
ArrayIndexOutOfBoundsException - 如果 normComponents 数组不是特别大，不能保存以 normOffset 开头的所有颜色和 alpha 分量
从以下版本开始：
1.4

getDataElements

public Object getDataElements(float[] normComponents,
                              int normOffset,
                              Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。然后可以将此数组传递给 WritableRaster 对象的 setDataElements 方法。如果 normComponents 数组不是特别大，不能保存所有以 normOffset 开头的颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。如果 obj 变量为 null，则分配一个新数组。如果 obj 不为 null，则它必须为类型 transferType 的基本数组；否则将抛出 ClassCastException。如果 obj 不是特别大，不能保存此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ColorModel 中的 getDataElements
参数：
normComponents - 标准化颜色和 alpha 分量的数组
normOffset - 开始检索颜色和 alpha 分量的 normComponents 的索引
obj - 保存返回的像素的基本数据数组
返回：
为像素的基本数据数组表示形式的 Object
抛出：
ClassCastException - 如果 obj 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 obj 不是特别大，不能保存此 ColorModel 的像素值，或者 normComponents 数组不是特别大，不能保存以 normOffset 开头的所有颜色和 alpha 分量
从以下版本开始：
1.4
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getNormalizedComponents

public float[] getNormalizedComponents(Object pixel,
                                       float[] normComponents,
                                       int normOffset)
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果像素不为类型 transferType 的基本数组，则抛出 ClassCastException。如果 pixel 不是特别大，不能保存此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。标准化分量为 float 值，这些值介于此 ColorModel 的 ColorSpace 对象指定的每个分量的最小值和最大值之间。如果 normComponents 数组为 null，则分配一个新数组。normComponents 数组将返回。颜色/alpha 分量存储在以 normOffset 开头的 normComponents 数组中，即使此方法已分配了数组也如此。如果 normComponents 数组不为 null，且不是特别大，不能保存所有颜色和 alpha 分量（以 normOffset 开头），则抛出 ArrayIndexOutOfBoundsException。

如果某子类旨在以非默认方式将像素样本值转换为颜色分量值，则该子类必须重写此方法。此类实现的默认转换在类的注释中描述。实现非默认转换的任何子类都必须遵循对此处定义的允许转换的限制。

覆盖：
类 ColorModel 中的 getNormalizedComponents
参数：
pixel - 指定像素
normComponents - 检索标准化分量的数组
normOffset - 在其处开始存储标准化分量的 normComponents 数组的偏移量
返回：
包含标准化颜色和 alpha 分量的数组。
抛出：
ClassCastException - 如果 pixel 不为类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 normComponents 不是特别大，不能保存以 normOffset 开头的所有颜色和 alpha 分量
ArrayIndexOutOfBoundsException - 如果 pixel 不是特别大，不能保存此 ColorModel 的像素值。
从以下版本开始：
1.4

coerceData

public ColorModel coerceData(WritableRaster raster,
                             boolean isAlphaPremultiplied)
强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。可以将颜色 raster 数据乘以或除以 alpha，如果该数据处于正确状态，则不执行任何操作。如果需要对该数据强制匹配，则此方法还将相应地返回一个带有 isAlphaPremultiplied 标志集的 ColorModel 的实例。因为 ColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 coerceData
参数：
raster - WritableRaster 数据
isAlphaPremultiplied - 如果与 alpha 预乘，则返回 true；否则将返回 false
返回：
表示被强制匹配数据的 ColorModel 对象。
抛出：
NullPointerException - 如果 raster 为 null 且需要数据强制。
UnsupportedOperationException - 如果此 ComponentColorModel 的传输类型不为以下受支持的传输类型之一：DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE。

isCompatibleRaster

public boolean isCompatibleRaster(Raster raster)
如果 raster 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。

覆盖：
类 ColorModel 中的 isCompatibleRaster
参数：
raster - 用于测试兼容性的 Raster。
返回：
如果 raster 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。

createCompatibleWritableRaster

public WritableRaster createCompatibleWritableRaster(int w,
                                                     int h)
用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。

覆盖：
类 ColorModel 中的 createCompatibleWritableRaster
参数：
w - 要创建的 WritableRaster 的宽度。
h - 要创建的 WritableRaster 的高度。
返回：
与此 ColorModel 兼容的 WritableRaster。
另请参见：
WritableRaster, SampleModel

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。

覆盖：
类 ColorModel 中的 createCompatibleSampleModel
参数：
w - 要创建的 SampleModel 的宽度。
h - 要创建的 SampleModel 的高度。
返回：
与此 ColorModel 兼容的 SampleModel。
另请参见：
SampleModel

isCompatibleSampleModel

public boolean isCompatibleSampleModel(SampleModel sm)
检查指定 SampleModel 是否与此 ColorModel 兼容。

覆盖：
类 ColorModel 中的 isCompatibleSampleModel
参数：
sm - 用于测试兼容性的 SampleModel。
返回：
如果 SampleModel 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。
另请参见：
SampleModel

getAlphaRaster

public WritableRaster getAlphaRaster(WritableRaster raster)
返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。此方法假定与此 ColorModel 关联的 Raster 对象将 alpha band（如果有）存储为图像数据的最后一个 band。如果不存在与此 ColorModel 相关的独立空间 alpha 通道，则返回 null。此方法创建一个新的 Raster，但是共享原来的数据数组。

覆盖：
类 ColorModel 中的 getAlphaRaster
参数：
raster - 从中提取 alpha 通道的 WritableRaster。
返回：
包含图像的 alpha 通道的 WritableRaster。

equals

public boolean equals(Object obj)
将此颜色模型与其他模型进行相等性比较。

覆盖：
类 ColorModel 中的 equals
参数：
obj - 要与此颜色模型比较的对象。
返回：
如果颜色模型对象相等，则返回 true；如果不相等，则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentSampleModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ComponentSampleModel

java.lang.Object
    继承者  java.awt.image.SampleModel
        继承者  java.awt.image.ComponentSampleModel
直接已知子类：
BandedSampleModel, PixelInterleavedSampleModel
public class ComponentSampleModel
extends SampleModel

此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。它可存储 N 个样本，这 N 个样本可通过 N 个独立的数据数组元素组成像素。不同的 band 可能位于 DataBuffer 的不同存储单元中。由于提供了存取方法，因此可以直接对图像数据进行操作。此类可以支持不同类型的交错，如 band 交错、扫描行交错和像素交错等。像素间距是同一扫描行上同一 band 的两个样本之间的数据数组元素数。扫描行间距是给定样本与下一扫描行的同一列中对应样本之间的数据数组元素数。band 偏移量表示从保存每个 band 的 DataBuffer 存储单元第一个数据数组元素到 band 第一个样本之间的数据数组元素数。band 从 0 到 N-1 进行编号。此类可以表示以下图像数据：每个样本都是可以按 8、16 或 32 位存储的无符号整数的图像数据（分别使用 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT）、每个样本都是可以按 16 位存储的有符号整数的图像数据（使用 DataBuffer.TYPE_SHORT）、每个样本都是有符号 float 和 double 量的图像数据（分别使用 DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE）。所有给定的 ComponentSampleModel 样本都是以同样的精度存储的。所有间距和偏移量必须为非负数。此类支持 TYPE_BYTE、TYPE_USHORT、TYPE_SHORT、TYPE_INT、TYPE_FLOAT 和 TYPE_DOUBLE。

另请参见：
PixelInterleavedSampleModel, BandedSampleModel

字段摘要
protected int[] | bandOffsets 数据数组元素中所有 band 的偏移量。
protected int[] | bankIndices 各个存储图像数据 band 的存储单元的索引。
protected int | numBands 此 ComponentSampleModel 中的 band 数量。
protected int | numBanks 此 ComponentSampleModel 中的存储单元数量。
protected int | pixelStride 由此 ComponentSampleModel 所描述的图像数据区域的像素间距（以数据数组元素表示）。
protected int | scanlineStride 由此 ComponentSampleModel 所描述的图像数据区域的行间距（以数据数组元素表示）。
从类 java.awt.image.SampleModel 继承的字段
dataType, height, width
构造方法摘要
ComponentSampleModel(int dataType, int w, int h, int pixelStride, int scanlineStride, int[] bandOffsets)
构造具有指定参数的 ComponentSampleModel。
ComponentSampleModel(int dataType, int w, int h, int pixelStride, int scanlineStride, int[] bankIndices, int[] bandOffsets)
构造具有指定参数的 ComponentSampleModel。
方法摘要
 SampleModel createCompatibleSampleModel(int w, int h)
创建具有指定宽度和高度的 ComponentSampleModel。
 DataBuffer createDataBuffer()
创建对应于此 ComponentSampleModel 的 DataBuffer。
 SampleModel createSubsetSampleModel(int[] bands)
创建具有此 ComponentSampleModel 的 band 子集的新 ComponentSampleModel。
 boolean equals(Object o)
指示其他某个对象是否与此对象“相等”。
 int[] getBandOffsets()
返回所有 band 的 band 偏移量。
 int[] getBankIndices()
返回所有 band 的存储单元索引。
 Object getDataElements(int x, int y, Object obj, DataBuffer data)
以 TransferType 类型基本数组形式返回单个像素的数据。
 int getNumDataElements()
返回使用 getDataElements(int, int, Object, DataBuffer) 和 setDataElements(int, int, Object, DataBuffer) 方法传输像素所需的数据元素的数量。
 int getOffset(int x, int y)
获取像素 (x,y) 的第一个 band 的偏移量。
 int getOffset(int x, int y, int b)
获取像素 (x,y) 的 band b 的偏移量。
 int[] getPixel(int x, int y, int[] iArray, DataBuffer data)
返回对应 int 数组中指定像素的所有样本，每个数组元素对应一个样本。
 int[] getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data)
返回对应 int 数组中像素指定矩形区域的所有样本（每个数组元素对应一个样本）。
 int getPixelStride()
返回此 ComponentSampleModel 的像素间距。
 int getSample(int x, int y, int b, DataBuffer data)
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
 double getSampleDouble(int x, int y, int b, DataBuffer data)
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
 float getSampleFloat(int x, int y, int b, DataBuffer data)
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
 int[] getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
返回指定 band 中对应于 int 数组中指定像素矩形的样本，每个数据数组元素一个样本。
 int[] getSampleSize()
返回所有 band 每个样本的位数。
 int getSampleSize(int band)
返回指定 band 每个样本的位数。
 int getScanlineStride()
返回此 ComponentSampleModel 的扫描行间距。
 int hashCode()
返回该对象的哈希码值。
 void setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
 void setPixel(int x, int y, int[] iArray, DataBuffer data)
使用输入样本的 int 数组设置 DataBuffer 中的像素。
 void setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data)
根据 int 数组（每个数组元素包含一个样本）设置对应于像素矩形区域的所有样本。
 void setSample(int x, int y, int b, double s, DataBuffer data)
使用输入的 double 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
 void setSample(int x, int y, int b, float s, DataBuffer data)
使用输入的 float 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
 void setSample(int x, int y, int b, int s, DataBuffer data)
使用输入的 int 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
 void setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data)
根据 int 数组（每个数据数组元素包含一个样本），在指定 band 中设置对应于指定像素矩形的样本。
从类 java.awt.image.SampleModel 继承的方法
getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSamples, setSamples
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

bandOffsets

protected int[] bandOffsets
数据数组元素中所有 band 的偏移量。

bankIndices

protected int[] bankIndices
各个存储图像数据 band 的存储单元的索引。

numBands

protected int numBands
此 ComponentSampleModel 中的 band 数量。

numBanks

protected int numBanks
此 ComponentSampleModel 中的存储单元数量。

scanlineStride

protected int scanlineStride
由此 ComponentSampleModel 所描述的图像数据区域的行间距（以数据数组元素表示）。

pixelStride

protected int pixelStride
由此 ComponentSampleModel 所描述的图像数据区域的像素间距（以数据数组元素表示）。

构造方法详细信息

ComponentSampleModel

public ComponentSampleModel(int dataType,
                            int w,
                            int h,
                            int pixelStride,
                            int scanlineStride,
                            int[] bandOffsets)
构造具有指定参数的 ComponentSampleModel。band 数量将由 bandOffsets 数组的长度给定。所有 band 都将存储在 DataBuffer 的第一个存储单元中。

参数：
dataType - 存储样本的数据类型
w - 描述的图像数据区域的宽度（以像素为单位）
h - 描述的图像数据区域的高度（以像素为单位）
pixelStride - 描述的图像数据区域的像素间距
scanlineStride - 描述的图像数据区域的行间距
bandOffsets - 所有 band 的偏移量
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0
IllegalArgumentException - 如果 pixelStride 小于 0
IllegalArgumentException - 如果 scanlineStride 小于 0
IllegalArgumentException - 如果 numBands 小于 1
IllegalArgumentException - 如果 w 和 h 的乘积大于 Integer.MAX_VALUE
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一

ComponentSampleModel

public ComponentSampleModel(int dataType,
                            int w,
                            int h,
                            int pixelStride,
                            int scanlineStride,
                            int[] bankIndices,
                            int[] bandOffsets)
构造具有指定参数的 ComponentSampleModel。band 数量将由 bandOffsets 数组的长度给定。不同的 band 可以存储在 DataBuffer 的不同存储单元中。

参数：
dataType - 存储样本的数据类型
w - 描述的图像数据区域的宽度（以像素为单位）
h - 描述的图像数据区域的高度（以像素为单位）
pixelStride - 描述的图像数据区域的像素间距
scanlineStride - 描述的图像数据区域的行间距
bankIndices - 所有 band 的存储单元索引
bandOffsets - 所有 band 的 band 偏移量
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0
IllegalArgumentException - 如果 pixelStride 小于 0
IllegalArgumentException - 如果 scanlineStride 小于 0
IllegalArgumentException - 如果 bankIndices 的长度不等于 bankOffsets 的长度
IllegalArgumentException - 如果 bandIndices 的 band 索引中任何一项小于 0
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一
方法详细信息

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
创建具有指定宽度和高度的 ComponentSampleModel。新的 SampleModel 将有与此 SampleModel 相同的 band 数量、存储数据类型、交错方案和像素间距。

指定者：
类 SampleModel 中的 createCompatibleSampleModel
参数：
w - 得到的 SampleModel 的宽度
h - 得到的 SampleModel 的高度
返回：
具有指定大小的 ComponentSampleModel
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0

createSubsetSampleModel

public SampleModel createSubsetSampleModel(int[] bands)
创建具有此 ComponentSampleModel 的 band 子集的新 ComponentSampleModel。新的 ComponentSampleModel 可以与任何现有 ComponentSampleModel 可与之一起使用的 DataBuffer 一起使用。新的 ComponentSampleModel/DataBuffer 组合表示具有原 ComponentSampleModel/DataBuffer 组合 band 子集的图像。

指定者：
类 SampleModel 中的 createSubsetSampleModel
参数：
bands - 此 ComponentSampleModel 的 band 子集
返回：
已创建的具有此 ComponentSampleModel band 子集的 ComponentSampleModel。

createDataBuffer

public DataBuffer createDataBuffer()
创建对应于此 ComponentSampleModel 的 DataBuffer。DataBuffer 对象的数据类型、存储单元的数量和大小与此 ComponentSampleModel 一致。

指定者：
类 SampleModel 中的 createDataBuffer
返回：
数据类型、存储单元的数量和大小与此 ComponentSampleModel 一致的 DataBuffer。

getOffset

public int getOffset(int x,
                     int y)
获取像素 (x,y) 的第一个 band 的偏移量。第一个 band 的样本可以从具有 ComponentSampleModel csm 的 DataBuffer data 中检索，如下所示：
        data.getElem(csm.getOffset(x, y));

参数：
x - 像素的 X 坐标
y - 像素的 Y 坐标
返回：
指定像素第一个 band 的偏移量。

getOffset

public int getOffset(int x,
                     int y,
                     int b)
获取像素 (x,y) 的 band b 的偏移量。band b 的样本可以从具有 ComponentSampleModel csm 的 DataBuffer data 中检索，如下所示：
       data.getElem(csm.getOffset(x, y, b));

参数：
x - 指定像素的 X 坐标
y - 指定像素的 Y 坐标
b - 指定的 band
返回：
指定像素的指定 band 的偏移量。

getSampleSize

public final int[] getSampleSize()
返回所有 band 每个样本的位数。

指定者：
类 SampleModel 中的 getSampleSize
返回：
包含所有 band 每样本位数的数组，数组中每个元素都表示一个 band。

getSampleSize

public final int getSampleSize(int band)
返回指定 band 每个样本的位数。

指定者：
类 SampleModel 中的 getSampleSize
参数：
band - 指定的 band
返回：
指定 band 每个样本的位数。

getBankIndices

public final int[] getBankIndices()
返回所有 band 的存储单元索引。

返回：
所有 band 的存储单元索引。

getBandOffsets

public final int[] getBandOffsets()
返回所有 band 的 band 偏移量。

返回：
所有 band 的 band 偏移量。

getScanlineStride

public final int getScanlineStride()
返回此 ComponentSampleModel 的扫描行间距。

返回：
此 ComponentSampleModel 的扫描行间距。

getPixelStride

public final int getPixelStride()
返回此 ComponentSampleModel 的像素间距。

返回：
此 ComponentSampleModel 的像素间距。

getNumDataElements

public final int getNumDataElements()
返回使用 getDataElements(int, int, Object, DataBuffer) 和 setDataElements(int, int, Object, DataBuffer) 方法传输像素所需的数据元素的数量。对于 ComponentSampleModel，这与 band 的数量相同。

指定者：
类 SampleModel 中的 getNumDataElements
返回：
使用 getDataElements 和 setDataElements 方法传输像素所需的数据元素的数量。
另请参见：
SampleModel.getNumDataElements(), SampleModel.getNumBands()

getDataElements

public Object getDataElements(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
以 TransferType 类型基本数组形式返回单个像素的数据。对于 ComponentSampleModel，返回的数据与 data 类型相同，且每个数组元素返回一个样本。通常，obj 应该作为 null 传入，以便 Object 能自动创建并成为正确的基本数据类型。

以下代码说明了如何将像素的数据从 DataBuffer db1（其存储布局由 ComponentSampleModel csm1 描述）传输到 DataBuffer db2（其存储布局由 ComponentSampleModel csm2 描述）。该传输通常比使用 getPixel 和 setPixel 更有效。

             ComponentSampleModel csm1, csm2;
             DataBufferInt db1, db2;
             csm2.setDataElements(x, y,
                            csm1.getDataElements(x, y, null, db1), db2);
如果 SampleModel 对象具有相同数量的 band，相应 band 具有相同数量的每样本位数，并且 TransferType 相同，则使用 getDataElements 和 setDataElements 在两个 DataBuffer/SampleModel 对之间传输是合法的。

如果 obj 不为 null，则它应该是 TransferType 类型的基本数组。否则，将抛出 ClassCastException。如果坐标不在边界内部，或者 obj 不为 null 且不足以保存像素数据，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 getDataElements
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
obj - 如果为非 null，则是一个要在其中返回像素数据的基本数组
data - 包含图像数据的 DataBuffer
返回：
指定像素的数据
抛出：
NullPointerException - 如果数据为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 obj 太小而不能保存输出。
另请参见：
setDataElements(int, int, Object, DataBuffer)

getPixel

public int[] getPixel(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
返回对应 int 数组中指定像素的所有样本，每个数组元素对应一个样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getPixel
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - 如果为非 null，则返回此数组中的样本
data - 包含图像数据的 DataBuffer
返回：
指定像素的样本。
抛出：
NullPointerException - 如果数据为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 iArray 太小而不能保存输出。
另请参见：
setPixel(int, int, int[], DataBuffer)

getPixels

public int[] getPixels(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
返回对应 int 数组中像素指定矩形区域的所有样本（每个数组元素对应一个样本）。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getPixels
参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形区域的宽度
h - 像素矩形区域的高度
iArray - 如果为非 null，则返回此数组中的样本
data - 包含图像数据的 DataBuffer
返回：
指定区域内的像素的样本。
另请参见：
setPixels(int, int, int, int, int[], DataBuffer)

getSample

public int getSample(int x,
                     int y,
                     int b,
                     DataBuffer data)
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内部，则可能抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 getSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
data - 包含图像数据的 DataBuffer
返回：
指定像素的指定 band 中的样本
另请参见：
setSample(int, int, int, int, DataBuffer)

getSampleFloat

public float getSampleFloat(int x,
                            int y,
                            int b,
                            DataBuffer data)
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getSampleFloat
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
data - 包含图像数据的 DataBuffer
返回：
表示指定像素的指定 band 中样本的 float 值。

getSampleDouble

public double getSampleDouble(int x,
                              int y,
                              int b,
                              DataBuffer data)
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getSampleDouble
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
data - 包含图像数据的 DataBuffer
返回：
表示指定像素的指定 band 中样本的 double 值。

getSamples

public int[] getSamples(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
返回指定 band 中对应于 int 数组中指定像素矩形的样本，每个数据数组元素一个样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getSamples
参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形区域的宽度
h - 像素矩形区域的高度
b - 要返回的 band
iArray - 如果为非 null，则返回此数组中的样本
data - 包含图像数据的 DataBuffer
返回：
指定像素的指定 band 中的样本
另请参见：
setSamples(int, int, int, int, int, int[], DataBuffer)

setDataElements

public void setDataElements(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。对于 ComponentSampleModel，设置的数据与 data 类型相同，且每个数组元素传输一个样本。

以下代码说明了如何将像素的数据从 DataBuffer db1（其存储布局由 ComponentSampleModel csm1 描述）传输到 DataBuffer db2（其存储布局由 ComponentSampleModel csm2 描述）。该传输通常比使用 getPixel 和 setPixel 更有效。

             ComponentSampleModel csm1, csm2;
             DataBufferInt db1, db2;
             csm2.setDataElements(x, y, csm1.getDataElements(x, y, null, db1),
                            db2);
如果 SampleModel 对象具有相同数量的 band，相应 band 具有相同数量的每样本位数，并且 TransferType 相同，则使用 getDataElements 和 setDataElements 在两个 DataBuffer/SampleModel 对之间传输是合法的。

如果 obj 不是 TransferType 类型基本数组，则返回 ClassCastException。如果坐标不在边界内部，或者 obj 不足以保存像素数据，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 setDataElements
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
obj - 包含像素数据的基本数组
data - 包含图像数据的 DataBuffer
另请参见：
getDataElements(int, int, Object, DataBuffer)

setPixel

public void setPixel(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
使用输入样本的 int 数组设置 DataBuffer 中的像素。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setPixel
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - int 数组形式的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getPixel(int, int, int[], DataBuffer)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
根据 int 数组（每个数组元素包含一个样本）设置对应于像素矩形区域的所有样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setPixels
参数：
x - 像素位置左上角的 X 坐标
y - 像素位置左上角的 Y 坐标
w - 像素矩形区域的宽度
h - 像素矩形区域的高度
iArray - int 数组形式的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getPixels(int, int, int, int, int[], DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
使用输入的 int 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 setSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要设置的 band
s - int 类型的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getSample(int, int, int, DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      float s,
                      DataBuffer data)
使用输入的 float 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要设置的 band
s - float 类型的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getSample(int, int, int, DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      double s,
                      DataBuffer data)
使用输入的 double 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setSample
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要设置的 band
s - double 类型的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getSample(int, int, int, DataBuffer)

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
根据 int 数组（每个数据数组元素包含一个样本），在指定 band 中设置对应于指定像素矩形的样本。如果坐标不在边界内部，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setSamples
参数：
x - 像素位置左上角的 X 坐标
y - 像素位置左上角的 Y 坐标
w - 像素矩形区域的宽度
h - 像素矩形区域的高度
b - 要设置的 band
iArray - int 数组形式的输入样本
data - 包含图像数据的 DataBuffer
另请参见：
getSamples(int, int, int, int, int, int[], DataBuffer)

equals

public boolean equals(Object o)
从类 Object 复制的描述
指示其他某个对象是否与此对象“相等”。

equals 方法在非空对象引用上实现相等关系：

  • 自反性：对于任何非空引用值 x，x.equals(x) 都应返回 true。
  • 对称性：对于任何非空引用值 x 和 y，当且仅当 y.equals(x) 返回 true 时，x.equals(y) 才应返回 true。
  • 传递性：对于任何非空引用值 x、y 和 z，如果 x.equals(y) 返回 true，并且 y.equals(z) 返回 true，那么 x.equals(z) 应返回 true。
  • 一致性：对于任何非空引用值 x 和 y，多次调用 x.equals(y) 始终返回 true 或始终返回 false，前提是对象上 equals 比较中所用的信息没有被修改。
  • 对于任何非空引用值 x，x.equals(null) 都应返回 false。

Object 类的 equals 方法实现对象上差别可能性最大的相等关系；即，对于任何非空引用值 x 和 y，当且仅当 x 和 y 引用同一个对象时，此方法才返回 true（x == y 具有值 true）。

注意：当此方法被重写时，通常有必要重写 hashCode 方法，以维护 hashCode 方法的常规协定，该协定声明相等对象必须具有相等的哈希码。

覆盖：
类 Object 中的 equals
参数：
o - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConvolveOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ConvolveOp

java.lang.Object
    继承者  java.awt.image.ConvolveOp
所有已实现的接口：
BufferedImageOp, RasterOp
public class ConvolveOp
extends Object
implements BufferedImageOp, RasterOp

此类实现从源到目标的卷积。使用卷积核的卷积是一种通过输入像素来计算输出像素的空间运算，方法是将核与输入像素邻域相乘。这种运算使得直接邻域可按核数学指定的方式影响输出像素。

此类可对颜色分量预乘 alpha 分量的 BufferedImage 数据进行运算。如果源 BufferedImage 有 alpha 分量，并且颜色分量没有预乘 alpha 分量，则在卷积运算前要先预乘该数据。如果 Destination 有未进行预乘的颜色分量，则在存入到 Destination 之前除以 alpha 分量（如果 alpha 为 0，则颜色分量被设置为 0）。如果 Destination 没有 alpha 分量，则在颜色分量除以 alpha 分量之从后即丢弃 alpha 分量。

Raster 被看作是没有 alpha 通道的。如果不希望对 BufferedImage 中的 alpha 通道进行上述处理，则可以通过获取源 BufferedImage 的 Raster 和使用与 Raster 一起工作的此类的 filter 方法予以避免。

如果 RenderingHints 对象是在构造方法中指定的，则在需要进行颜色变换时使用颜色呈现提示和抖动提示。

注意，Source 和 Destination 可能不是同一个对象。

另请参见：
Kernel, RenderingHints.KEY_COLOR_RENDERING, RenderingHints.KEY_DITHERING

字段摘要
static int | EDGE_NO_OP 将位于源图像边缘的像素复制为目标中相应的像素，不加修改。
static int | EDGE_ZERO_FILL 位于目标图像边缘的像素被设置为 0。
构造方法摘要
ConvolveOp(Kernel kernel)
构造给定了 Kernel 的 ConvolveOp。
ConvolveOp(Kernel kernel, int edgeCondition, RenderingHints hints)
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。
方法摘要
BufferedImage | createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建具有正确 band 大小和数量的归零目标图像。
WritableRaster | createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
BufferedImage | filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行卷积运算。
WritableRaster | filter(Raster src, WritableRaster dst) 对 Raster 执行卷积运算。
Rectangle2D | getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | getBounds2D(Raster src) 返回已过滤目标 Raster 的边界框。
int | getEdgeCondition() 返回边缘条件。
Kernel | getKernel() 返回 Kernel。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 返回源中给定点的目标点位置。
RenderingHints | getRenderingHints() 返回此 op 的呈现提示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

EDGE_ZERO_FILL

public static final int EDGE_ZERO_FILL
位于目标图像边缘的像素被设置为 0。这是默认设置。

另请参见：
常量字段值

EDGE_NO_OP

public static final int EDGE_NO_OP
将位于源图像边缘的像素复制为目标中相应的像素，不加修改。

另请参见：
常量字段值
构造方法详细信息

ConvolveOp

public ConvolveOp(Kernel kernel,
                  int edgeCondition,
                  RenderingHints hints)
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。

参数：
kernel - 指定的 Kernel
edgeCondition - 指定的边缘条件
hints - 指定的 RenderingHints 对象
另请参见：
Kernel, EDGE_NO_OP, EDGE_ZERO_FILL, RenderingHints

ConvolveOp

public ConvolveOp(Kernel kernel)
构造给定了 Kernel 的 ConvolveOp。边缘条件将为 EDGE_ZERO_FILL。

参数：
kernel - 指定的 Kernel
另请参见：
Kernel, EDGE_ZERO_FILL
方法详细信息

getEdgeCondition

public int getEdgeCondition()
返回边缘条件。

返回：
ConvolveOp 的边缘条件。
另请参见：
EDGE_NO_OP, EDGE_ZERO_FILL

getKernel

public final Kernel getKernel()
返回 Kernel。

返回：
ConvolveOp 的 Kernel。

filter

public final BufferedImage filter(BufferedImage src,
                                  BufferedImage dst)
对 BufferedImage 执行卷积运算。源图像的每个分量都将被卷积处理（包括 alpha 分量，如果存在）。如果源图像中的颜色模型与目标图像中的不相同，则像素将按目标中像素转换。如果目标图像为 null，则使用源 ColorModel 创建 BufferedImage。如果源与目标相同，则可能抛出 IllegalArgumentException。

指定者：
接口 BufferedImageOp 中的 filter
参数：
src - 要过滤的源 BufferedImage
dst - 已过滤的 src 的目标 BufferedImage
返回：
已过滤的 BufferedImage
抛出：
NullPointerException - 如果 src 为 null
IllegalArgumentException - 如果 src 等于 dst
ImagingOpException - 如果 src 不能过滤

filter

public final WritableRaster filter(Raster src,
                                   WritableRaster dst)
对 Raster 执行卷积运算。源 Raster 的每个 band 都将被卷积处理。源和目标必须有相同数量的 band。如果目标 Raster 为 null，则创建新 Raster。如果源与目标相同，则可能抛出 IllegalArgumentException。

指定者：
接口 RasterOp 中的 filter
参数：
src - 要过滤的源 Raster
dst - 已过滤的 src 的目标 WritableRaster
返回：
已过滤的 WritableRaster
抛出：
NullPointerException - 如果 src 为 null
ImagingOpException - 如果 src 和 dst 没有相同数量的 band
ImagingOpException - 如果 src 不能过滤
IllegalArgumentException - 如果 src 等于 dst

createCompatibleDestImage

public BufferedImage createCompatibleDestImage(BufferedImage src,
                                               ColorModel destCM)
创建具有正确 band 大小和数量的归零目标图像。如果 destCM 为 null，则使用适当的 ColorModel。

指定者：
接口 BufferedImageOp 中的 createCompatibleDestImage
参数：
src - 进行过滤操作的源图像。
destCM - 目标的 ColorModel。可以为 null。
返回：
具有正确 band 大小和数量的 BufferedImage。

createCompatibleDestRaster

public WritableRaster createCompatibleDestRaster(Raster src)
创建给定源且具有正确 band 大小和数量的归零目标 Raster。

指定者：
接口 RasterOp 中的 createCompatibleDestRaster
参数：
src - 源 Raster
返回：
与 src 兼容的 WritableRaster

getBounds2D

public final Rectangle2D getBounds2D(BufferedImage src)
返回已过滤目标图像的边界框。因为这不是几何操作，所以边界框不变。

指定者：
接口 BufferedImageOp 中的 getBounds2D
参数：
src - 要过滤的 BufferedImage
返回：
表示目标图像边界框的 Rectangle2D。

getBounds2D

public final Rectangle2D getBounds2D(Raster src)
返回已过滤目标 Raster 的边界框。因为这不是几何操作，所以边界框不变。

指定者：
接口 RasterOp 中的 getBounds2D
参数：
src - 源 Raster
返回：
一个 Rectangle2D，它是从过滤操作得到的 Raster 的边界框。

getPoint2D

public final Point2D getPoint2D(Point2D srcPt,
                                Point2D dstPt)
返回源中给定点的目标点位置。如果 dstPt 为非 null，则该位置将用来存储返回值。因为这不是几何操作，所以 srcPt 将等于 dstPt。

指定者：
接口 BufferedImageOp 中的 getPoint2D
指定者：
接口 RasterOp 中的 getPoint2D
参数：
srcPt - 表示源图像中点的 Point2D
dstPt - 用于存储结果的 Point2D
返回：
与源图像中指定点对应的目标图像中的 Point2D。

getRenderingHints

public final RenderingHints getRenderingHints()
返回此 op 的呈现提示。

指定者：
接口 BufferedImageOp 中的 getRenderingHints
指定者：
接口 RasterOp 中的 getRenderingHints
返回：
针对此 BufferedImageOp 的 RenderingHints 对象。如果没有设置提示，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CropImageFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 CropImageFilter

java.lang.Object
    继承者  java.awt.image.ImageFilter
        继承者  java.awt.image.CropImageFilter
所有已实现的接口：
ImageConsumer, Cloneable
public class CropImageFilter
extends ImageFilter

用于裁剪图像的 ImageFilter 类。此类扩展了基本 ImageFilter 类，可提取现有 Image 中的给定矩形区域，为包含刚提取区域的新图像提供源。也就是它要与 FilteredImageSource 对象结合使用，以生成现有图像的裁剪版本。

另请参见：
FilteredImageSource, ImageFilter

字段摘要
从类 java.awt.image.ImageFilter 继承的字段
consumer
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
CropImageFilter(int x, int y, int w, int h)
按指定 x、y、w 和 h 参数从源 Image 提取绝对矩形区域来构造 CropImageFilter。
方法摘要
void | setDimensions(int w, int h) 重写源图像的维度，并将矩形裁剪区域的维度传递给 ImageConsumer。
void | setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 确定已传递的字节像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
void | setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 确定已传递的 int 像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
void | setProperties(Hashtable<?,?> props) 添加指示裁剪区域的属性后传递源对象的属性。
从类 java.awt.image.ImageFilter 继承的方法
clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setColorModel, setHints
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CropImageFilter

public CropImageFilter(int x,
                       int y,
                       int w,
                       int h)
按指定 x、y、w 和 h 参数从源 Image 提取绝对矩形区域来构造 CropImageFilter。

参数：
x - 要提取的矩形顶部的 x 位置
y - 要提取的矩形顶部的 y 位置
w - 要提取的矩形宽度
h - 要提取的矩形高度
方法详细信息

setProperties

public void setProperties(Hashtable<?,?> props)
添加指示裁剪区域的属性后传递源对象的属性。此方法调用 super.setProperties，这可能会导致添加其他属性。

注：此方法专门由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setProperties
覆盖：
类 ImageFilter 中的 setProperties
参数：
props - 来自源对象的属性

setDimensions

public void setDimensions(int w,
                          int h)
重写源图像的维度，并将矩形裁剪区域的维度传递给 ImageConsumer。

注：此方法专门由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setDimensions
覆盖：
类 ImageFilter 中的 setDimensions
参数：
w - 源图像的宽度
h - 源图像的高度
另请参见：
ImageConsumer

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
确定已传递的字节像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。

注：此方法专门由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
确定已传递的 int 像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。

注：此方法专门由 Image（其像素正被过滤）的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Kernel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 Kernel

java.lang.Object
    继承者  java.awt.image.Kernel
所有已实现的接口：
Cloneable
public class Kernel
extends Object
implements Cloneable

Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。X 原点和 Y 原点指示 kernel 矩阵元素对应于为其计算输出值的像素位置。

另请参见：
ConvolveOp

构造方法摘要
Kernel(int width, int height, float[] data)
根据 float 数组构造一个 Kernel 对象。
方法摘要
Object | clone() 复制此对象。
int | getHeight() 返回此 Kernel 的高度。
float[] | getKernelData(float[] data) 以行优先顺序返回 kernel 数据。
int | getWidth() 返回此 Kernel 的宽度。
int | getXOrigin() 返回此 Kernel 的 X 原点。
int | getYOrigin() 返回此 Kernel 的 Y 原点。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Kernel

public Kernel(int width,
              int height,
              float[] data)
根据 float 数组构造一个 Kernel 对象。复制 data 数组的前 width*height 个元素。如果 data 数组的长度小于 width*height，则抛出 IllegalArgumentException。X 原点是 (width-1)/2，Y 原点是 (height-1)/2。

参数：
width - 该 kernel 的宽度
height - 该 kernel 的高度
data - 以行优先顺序提供的 kernel 数据
抛出：
IllegalArgumentException - 如果 data 的长度小于 width 和 height 的乘积
方法详细信息

getXOrigin

public final int getXOrigin()
返回此 Kernel 的 X 原点。

返回：
X 原点。

getYOrigin

public final int getYOrigin()
返回此 Kernel 的 Y 原点。

返回：
Y 原点。

getWidth

public final int getWidth()
返回此 Kernel 的宽度。

返回：
此 Kernel 的宽度。

getHeight

public final int getHeight()
返回此 Kernel 的高度。

返回：
此 Kernel 的高度。

getKernelData

public final float[] getKernelData(float[] data)
以行优先顺序返回 kernel 数据。返回 data 数组。如果 data 为 null，则分配一个新数组。

参数：
data - 如果为非 null，则包含返回的 kernel 数据
返回：
以行优先顺序包含 kernel 数据的 data 数组，如果 data 为 null，则返回以行优先顺序包含 kernel 数据的新分配数组
抛出：
IllegalArgumentException - 如果 data 小于此 Kernel 的大小

clone

public Object clone()
复制此对象。

覆盖：
类 Object 中的 clone
返回：
此对象的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DataBuffer

java.lang.Object
    继承者  java.awt.image.DataBuffer
直接已知子类：
DataBufferByte, DataBufferDouble, DataBufferFloat, DataBufferInt, DataBufferShort, DataBufferUShort
public abstract class DataBuffer
extends Object

此类用于包装一个或多个数据数组。DataBuffer 中的每个数据数组都可称作存储单元。获取或设置 DataBuffer 的存储单元中元素的存取方法可以有也可以没有存储单元标识符。没有存储单元标识符的方法使用默认的 0 号存储单元。DataBuffer 可以采用可选的每存储单元偏移量，以便现有数组中的数据即使所需数据不是从数组位置 0 开始也可以使用。要获取或设置存储单元的 0 号元素，请使用数组的 (0+offset) 号元素。size 字段指定数据数组中有多少元素可供使用。给定存储单元的 size + offset 永远不应该大于相关数据数组的长度。数据缓冲区的数据类型指示数据数组的类型，还可以指示其他语义，例如，在字节数组的元素中存储无符号 8 位数据。数据类型可以是 TYPE_UNDEFINED，也可以是下面定义的类型之一。其他类型可以在将来添加。通常，类 DataBuffer 的对象将强制转换为其数据类型的特定子类之一来访问数据类型的特定方法以便改善性能。当前，Java 2D(tm) API 图像类使用 TYPE_BYTE、TYPE_USHORT、TYPE_INT、TYPE_SHORT、TYPE_FLOAT 和 TYPE_DOUBLE DataBuffer 存储图像数据。

另请参见：
Raster, SampleModel

字段摘要
protected int | banks 此 DataBuffer 中存储单元的数量。
protected int | dataType 此 DataBuffer 的数据类型。
protected int | offset 默认（第一个）存储单元的偏移量，从中可获得第一个元素。
protected int[] | offsets 所有存储单元的偏移量。
protected int | size 所有存储单元的可用大小。
static int | TYPE_BYTE 无符号 byte 数据的标记
static int | TYPE_DOUBLE double 数据的标记。
static int | TYPE_FLOAT float 数据的标记。
static int | TYPE_INT int 数据的标记。
static int | TYPE_SHORT 有符号 short 数据的标记。
static int | TYPE_UNDEFINED 未定义数据的标记。
static int | TYPE_USHORT 无符号 short 数据的标记
构造方法摘要
protected | DataBuffer(int dataType, int size) 构造包含一个指定数据类型和大小的存储单元的 DataBuffer。
protected | DataBuffer(int dataType, int size, int numBanks) 构造包含了指定数量的存储单元的 DataBuffer。
protected | DataBuffer(int dataType, int size, int numBanks, int offset) 构造包含指定存储单元数量的 DataBuffer。
protected | DataBuffer(int dataType, int size, int numBanks, int[] offsets) 构造包含指定存储单元数量的 DataBuffer。
方法摘要
int | getDataType() 返回此 DataBuffer 的数据类型。
static int | getDataTypeSize(int type) 返回由给定 datatype 标记所代表的数据类型的大小（以位为单位）。
int | getElem(int i) 以整数类型返回第一个（默认）存储单元中所请求的数据数组元素。
abstract int | getElem(int bank, int i) 以整数类型返回指定存储单元中所请求的数据数组元素。
double | getElemDouble(int i) 以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。
double | getElemDouble(int bank, int i) 以 double 类型返回指定存储单元所请求的数据数组元素。
float | getElemFloat(int i) 以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
float | getElemFloat(int bank, int i) 以 float 类型返回指定存储单元中所请求的数据数组元素。
int | getNumBanks() 返回此 DataBuffer 中存储单元的数量。
int | getOffset() 返回数组元素中默认存储单元的偏移量。
int[] | getOffsets() 返回所有存储单元的偏移量（按数组元素）。
int | getSize() 返回所有存储单元的大小（按数组元素）。
void | setElem(int i, int val) 根据给定的整数设置第一个（默认）存储单元中所请求的数据数组元素。
abstract void | setElem(int bank, int i, int val) 根据给定的整数设置指定存储单元中所请求的数据数组元素。
void | setElemDouble(int i, double val) 根据给定的 double 设置第一个（默认）存储单元中所请求的数据数组元素。
void | setElemDouble(int bank, int i, double val) 根据给定的 double 设置指定存储单元中所请求的数据数组元素。
void | setElemFloat(int i, float val) 根据给定的 float 设置第一个（默认）存储单元中所请求的数据数组元素。
void | setElemFloat(int bank, int i, float val) 根据给定的 float 设置指定存储单元中所请求的数据数组元素。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE_BYTE

public static final int TYPE_BYTE
无符号 byte 数据的标记

另请参见：
常量字段值

TYPE_USHORT

public static final int TYPE_USHORT
无符号 short 数据的标记

另请参见：
常量字段值

TYPE_SHORT

public static final int TYPE_SHORT
有符号 short 数据的标记。供将来使用的占位符。

另请参见：
常量字段值

TYPE_INT

public static final int TYPE_INT
int 数据的标记。

另请参见：
常量字段值

TYPE_FLOAT

public static final int TYPE_FLOAT
float 数据的标记。供将来使用的占位符。

另请参见：
常量字段值

TYPE_DOUBLE

public static final int TYPE_DOUBLE
double 数据的标记。供将来使用的占位符。

另请参见：
常量字段值

TYPE_UNDEFINED

public static final int TYPE_UNDEFINED
未定义数据的标记。

另请参见：
常量字段值

dataType

protected int dataType
此 DataBuffer 的数据类型。

banks

protected int banks
此 DataBuffer 中存储单元的数量。

offset

protected int offset
默认（第一个）存储单元的偏移量，从中可获得第一个元素。

size

protected int size
所有存储单元的可用大小。

offsets

protected int[] offsets
所有存储单元的偏移量。

构造方法详细信息

DataBuffer

protected DataBuffer(int dataType,
                     int size)
构造包含一个指定数据类型和大小的存储单元的 DataBuffer。

参数：
dataType - 此 DataBuffer 的数据类型
size - 存储单元的大小

DataBuffer

protected DataBuffer(int dataType,
                     int size,
                     int numBanks)
构造包含了指定数量的存储单元的 DataBuffer。每个存储单元都有指定的大小和 0 偏移量。

参数：
dataType - 此 DataBuffer 的数据类型
size - 存储单元的大小
numBanks - 此 DataBuffer 中存储单元的数量。

DataBuffer

protected DataBuffer(int dataType,
                     int size,
                     int numBanks,
                     int offset)
构造包含指定存储单元数量的 DataBuffer。每个存储单元都有指定的数据类型、大小和偏移量。

参数：
dataType - 此 DataBuffer 的数据类型
size - 存储单元的大小
numBanks - 此 DataBuffer 中存储单元的数量
offset - 每个存储单元的偏移量

DataBuffer

protected DataBuffer(int dataType,
                     int size,
                     int numBanks,
                     int[] offsets)
构造包含指定存储单元数量的 DataBuffer。每个存储单元都有指定的数据类型和大小。每个存储单元的偏移量由其各自在偏移量数组中的项指定。

参数：
dataType - 此 DataBuffer 的数据类型
size - 存储单元的大小
numBanks - 此 DataBuffer 中的存储单元数
offsets - 包含每个存储单元的偏移量的数组。
抛出：
ArrayIndexOutOfBoundsException - 如果 numBanks 不等于 offsets 的长度
方法详细信息

getDataTypeSize

public static int getDataTypeSize(int type)
返回由给定 datatype 标记所代表的数据类型的大小（以位为单位）。

参数：
type - 已定义的 datatype 标记之一的值
返回：
数据类型的大小
抛出：
IllegalArgumentException - 如果 type 小于零或大于 TYPE_DOUBLE

getDataType

public int getDataType()
返回此 DataBuffer 的数据类型。

返回：
此 DataBuffer 的数据类型。

getSize

public int getSize()
返回所有存储单元的大小（按数组元素）。

返回：
所有存储单元的大小。

getOffset

public int getOffset()
返回数组元素中默认存储单元的偏移量。

返回：
默认存储单元的偏移量。

getOffsets

public int[] getOffsets()
返回所有存储单元的偏移量（按数组元素）。

返回：
所有存储单元的偏移量。

getNumBanks

public int getNumBanks()
返回此 DataBuffer 中存储单元的数量。

返回：
存储单元的数量。

getElem

public int getElem(int i)
以整数类型返回第一个（默认）存储单元中所请求的数据数组元素。

参数：
i - 所请求的数据数组元素的索引
返回：
指定索引处的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

getElem

public abstract int getElem(int bank,
                            int i)
以整数类型返回指定存储单元中所请求的数据数组元素。

参数：
bank - 指定的存储单元
i - 所请求的数据数组元素的索引
返回：
在指定索引处的指定存储单元中指定索引处的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

setElem

public void setElem(int i,
                    int val)
根据给定的整数设置第一个（默认）存储单元中所请求的数据数组元素。

参数：
i - 数据数组中的指定索引
val - 用来在数据数组中指定索引处设置元素的数据
另请参见：
getElem(int), getElem(int, int)

setElem

public abstract void setElem(int bank,
                             int i,
                             int val)
根据给定的整数设置指定存储单元中所请求的数据数组元素。

参数：
bank - 指定的存储单元
i - 数据数组中的指定索引
val - 用来在数据数组中指定索引处的指定存储单元中设置元素的数据
另请参见：
getElem(int), getElem(int, int)

getElemFloat

public float getElemFloat(int i)
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。此类中的实现是将 getElem(i) 强制转换为 float。如果需要其他实现，则子类可以重写此方法。

参数：
i - 所请求的数据数组元素的索引
返回：
表示指定索引处数据数组元素的 float 值。
另请参见：
setElemFloat(int, float), setElemFloat(int, int, float)

getElemFloat

public float getElemFloat(int bank,
                          int i)
以 float 类型返回指定存储单元中所请求的数据数组元素。此类中的实现是将 getElem(int, int) 强制转换为 float。如果需要其他实现，则子类可以重写此方法。

参数：
bank - 指定的存储单元
i - 所请求的数据数组元素的索引
返回：
表示指定索引处指定存储单元中的数据数组元素的 float 值。
另请参见：
setElemFloat(int, float), setElemFloat(int, int, float)

setElemFloat

public void setElemFloat(int i,
                         float val)
根据给定的 float 设置第一个（默认）存储单元中所请求的数据数组元素。此类中的实现是将 val 强制转换为 int 并调用 setElem(int, int)。如果需要其他实现，则子类可以重写此方法。

参数：
i - 指定的索引
val - 用来在数据数组中指定索引处设置元素的值
另请参见：
getElemFloat(int), getElemFloat(int, int)

setElemFloat

public void setElemFloat(int bank,
                         int i,
                         float val)
根据给定的 float 设置指定存储单元中所请求的数据数组元素。此类中的实现是将 val 强制转换为 int 并调用 setElem(int, int)。如果需要其他实现，则子类可以重写此方法。

参数：
bank - 指定的存储单元
i - 指定的索引
val - 用来在数据数组中指定索引处的指定存储单元中设置元素的值
另请参见：
getElemFloat(int), getElemFloat(int, int)

getElemDouble

public double getElemDouble(int i)
以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。此类中的实现是将 getElem(int) 强制转换为 double。如果需要其他实现，则子类可以重写此方法。

参数：
i - 指定的索引
返回：
代表数据数组中指定索引处的元素的 double。
另请参见：
setElemDouble(int, double), setElemDouble(int, int, double)

getElemDouble

public double getElemDouble(int bank,
                            int i)
以 double 类型返回指定存储单元所请求的数据数组元素。此类中的实现是将 getElem(bank, i) 强制转换为 double。如果需要其他实现，则子类可以重写此方法。

参数：
bank - 指定的存储单元
i - 指定的索引
返回：
表示数据数组中指定索引处的指定存储单元中元素的 double 值。
另请参见：
setElemDouble(int, double), setElemDouble(int, int, double)

setElemDouble

public void setElemDouble(int i,
                          double val)
根据给定的 double 设置第一个（默认）存储单元中所请求的数据数组元素。此类中的实现是将 val 强制转换为 int 并调用 setElem(int, int)。如果需要其他实现，则子类可以重写此方法。

参数：
i - 指定的索引
val - 用来在数据数组中的指定索引处设置元素的值
另请参见：
getElemDouble(int), getElemDouble(int, int)

setElemDouble

public void setElemDouble(int bank,
                          int i,
                          double val)
根据给定的 double 设置指定存储单元中所请求的数据数组元素。此类中的实现是将 val 强制转换为 int 并调用 setElem(int, int)。如果需要其他实现，则子类可以重写此方法。

参数：
bank - 指定的存储单元
i - 指定的索引
val - 用来在数据数组的指定存储单元中的指定索引处进行设置的数值
另请参见：
getElemDouble(int), getElemDouble(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataBufferByte (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DataBufferByte

java.lang.Object
    继承者  java.awt.image.DataBuffer
        继承者  java.awt.image.DataBufferByte

public final class DataBufferByte
extends DataBuffer

此类扩展了 DataBuffer，并在内部按字节存储数据。存储在此 DataBuffer 的字节数组中的值被视为无符号值。

字段摘要
从类 java.awt.image.DataBuffer 继承的字段
banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT
构造方法摘要
DataBufferByte(byte[][] dataArray, int size)
构造具有指定数组且基于字节的 DataBuffer。
DataBufferByte(byte[][] dataArray, int size, int[] offsets)
构造具有指定数组、大小和偏移量且基于字节的 DataBuffer。
DataBufferByte(byte[] dataArray, int size)
使用指定数组构造具有单个存储单元且基于字节的 DataBuffer。
DataBufferByte(byte[] dataArray, int size, int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于字节的 DataBuffer。
DataBufferByte(int size)
构造具有单个存储单元和指定大小且基于字节的 DataBuffer。
DataBufferByte(int size, int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于字节的 DataBuffer。
方法摘要
byte[][] | getBankData() 返回所有存储单元的数据数组。
byte[] | getData() 返回默认（第一个）字节数据数组。
byte[] | getData(int bank) 返回指定存储单元的数据数组。
int | getElem(int i) 返回第一个（默认）存储单元中所请求的数据数组元素。
int | getElem(int bank, int i) 返回指定存储单元中所请求的数据数组元素。
void | setElem(int i, int val) 将第一个（默认）存储单元中所请求的数据数组设置为指定值。
void | setElem(int bank, int i, int val) 根据给定的整数设置指定存储单元中所请求的数据数组元素。
从类 java.awt.image.DataBuffer 继承的方法
getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataBufferByte

public DataBufferByte(int size)
构造具有单个存储单元和指定大小且基于字节的 DataBuffer。

参数：
size - DataBuffer 的大小。

DataBufferByte

public DataBufferByte(int size,
                      int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于字节的 DataBuffer。

参数：
size - DataBuffer 中的存储单元大小。
numBanks - DataBuffer 中的存储单元数量。

DataBufferByte

public DataBufferByte(byte[] dataArray,
                      int size)
使用指定数组构造具有单个存储单元且基于字节的 DataBuffer。此 DataBuffer 的访问器只能使用头 size 个元素。dataArray 必须足够大，能够存储 size 个元素。

参数：
dataArray - DataBuffer 的字节数组。
size - DataBuffer 存储单元大小。

DataBufferByte

public DataBufferByte(byte[] dataArray,
                      int size,
                      int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于字节的 DataBuffer。dataArray 至少必须有 offset + size 个元素。此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的字节数组。
size - DataBuffer 存储单元大小。
offset - dataArray 的偏移量。dataArray 至少必须有 offset + size 个元素。

DataBufferByte

public DataBufferByte(byte[][] dataArray,
                      int size)
构造具有指定数组且基于字节的 DataBuffer。存储单元的数量等于 dataArray.length。此 DataBuffer 的访问器只能使用每个数组的头 size 个元素。

参数：
dataArray - DataBuffer 的字节数组。
size - DataBuffer 中的存储单元大小。

DataBufferByte

public DataBufferByte(byte[][] dataArray,
                      int size,
                      int[] offsets)
构造具有指定数组、大小和偏移量且基于字节的 DataBuffer。存储单元的数量等于 dataArray.length。每个数组至少必须与 size + 相应的 offset 大小相同。每个 dataArray 项的 offset 数组中必须有一个项。对于每个存储单元，此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的字节数组。
size - DataBuffer 中的存储单元大小。
offsets - 每个数组中的偏移量。
方法详细信息

getData

public byte[] getData()
返回默认（第一个）字节数据数组。

返回：
第一个字节数据数组。

getData

public byte[] getData(int bank)
返回指定存储单元的数据数组。

参数：
bank - 要获取其数据数组的存储单元。
返回：
指定存储单元的数据数组。

getBankData

public byte[][] getBankData()
返回所有存储单元的数据数组。

返回：
所有数据数组。

getElem

public int getElem(int i)
返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElem
参数：
i - 要获取的数据数组元素。
返回：
所请求的整数类型的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

getElem

public int getElem(int bank,
                   int i)
返回指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 getElem
参数：
bank - 要从中获取数据数组元素的存储单元。
i - 要获取的数据数组元素。
返回：
所请求的整数类型的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

setElem

public void setElem(int i,
                    int val)
将第一个（默认）存储单元中所请求的数据数组设置为指定值。

覆盖：
类 DataBuffer 中的 setElem
参数：
i - 要获取的数据数组元素。
val - 要将数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)

setElem

public void setElem(int bank,
                    int i,
                    int val)
根据给定的整数设置指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 setElem
参数：
bank - 想在其中设置数据数组元素的存储单元。
i - 要获取的数据数组元素。
val - 要将指定数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataBufferDouble (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DataBufferDouble

java.lang.Object
    继承者  java.awt.image.DataBuffer
        继承者  java.awt.image.DataBufferDouble

public final class DataBufferDouble
extends DataBuffer

此类扩展了 DataBuffer，并在内部以 double 形式存储数据。

从以下版本开始：
1.4
另请参见：
DataBuffer

字段摘要
从类 java.awt.image.DataBuffer 继承的字段
banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT
构造方法摘要
DataBufferDouble(double[][] dataArray, int size)
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[][] dataArray, int size, int[] offsets)
构造具有指定数据数组、大小和每存储单元偏移量且基于 double 的 DataBuffer。
DataBufferDouble(double[] dataArray, int size)
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(double[] dataArray, int size, int offset)
构造具有指定数据数组且基于 double 的 DataBuffer。
DataBufferDouble(int size)
构造具有指定大小且基于 double 的 DataBuffer。
DataBufferDouble(int size, int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 double 的 DataBuffer。
方法摘要
double[][] | getBankData() 返回所有存储单元的数据数组。
double[] | getData() 返回默认（第一个）double 数据数组。
double[] | getData(int bank) 返回指定存储单元的数据数组。
int | getElem(int i) 以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。
int | getElem(int bank, int i) 以 int 类型返回指定存储单元中所请求的数据数组元素。
double | getElemDouble(int i) 以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。
double | getElemDouble(int bank, int i) 以 double 类型返回指定存储单元中所请求的数据数组元素。
float | getElemFloat(int i) 以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
float | getElemFloat(int bank, int i) 以 float 类型返回指定存储单元中所请求的数据数组元素。
void | setElem(int i, int val) 将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。
void | setElem(int bank, int i, int val) 将指定存储单元中所请求的数据数组元素设置为给定的 int。
void | setElemDouble(int i, double val) 将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。
void | setElemDouble(int bank, int i, double val) 将指定存储单元中所请求的数据数组元素设置为给定的 double。
void | setElemFloat(int i, float val) 将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。
void | setElemFloat(int bank, int i, float val) 将指定存储单元中所请求的数据数组元素设置为给定的 float。
从类 java.awt.image.DataBuffer 继承的方法
getDataType, getDataTypeSize, getNumBanks, getOffset, getOffsets, getSize
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataBufferDouble

public DataBufferDouble(int size)
构造具有指定大小且基于 double 的 DataBuffer。

参数：
size - DataBuffer 中的元素数量。

DataBufferDouble

public DataBufferDouble(int size,
                        int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 double 的 DataBuffer。

参数：
size - DataBuffer 的每个存储单元中的元素数量。
numBanks - DataBuffer 中存储单元的数量。

DataBufferDouble

public DataBufferDouble(double[] dataArray,
                        int size)
构造具有指定数据数组且基于 double 的 DataBuffer。只有前几个 size 元素可供此 DataBuffer 使用。该数组必须足够大，能够存储 size 元素。

参数：
dataArray - 用作此 DataBuffer 的第一个且是惟一存储单元的 double 的数组。
size - 要使用的数组的元素数量。

DataBufferDouble

public DataBufferDouble(double[] dataArray,
                        int size,
                        int offset)
构造具有指定数据数组且基于 double 的 DataBuffer。只有 offset 和 offset + size - 1 之间的元素可供此 DataBuffer 使用。该数组必须足够大，能够存储 offset + size 元素。

参数：
dataArray - 用作此 DataBuffer 的第一个且是惟一存储单元的 double 的数组。
size - 要使用的数组的元素数量。
offset - 要使用的数组的第一个元素的偏移量。

DataBufferDouble

public DataBufferDouble(double[][] dataArray,
                        int size)
构造具有指定数据数组且基于 double 的 DataBuffer。只有每个数组的前几个 size 元素可供此 DataBuffer 使用。存储单元的数量将等于 dataArray.length。

参数：
dataArray - 用作此 DataBuffer 存储单元的 double 数组的数组。
size - 要使用的每个数组的元素数量。

DataBufferDouble

public DataBufferDouble(double[][] dataArray,
                        int size,
                        int[] offsets)
构造具有指定数据数组、大小和每存储单元偏移量且基于 double 的 DataBuffer。存储单元的数量等于 dataArray.length。每个数组至少必须和 size 加上相应的偏移量大小相同。每个数据数组的 offsets 数组中必须有一个项。

参数：
dataArray - 用作此 DataBuffer 存储单元的 double 数组的数组。
size - 要使用的每个数组的元素数量。
offsets - 整数偏移量数组，每个存储单元一个。
方法详细信息

getData

public double[] getData()
返回默认（第一个）double 数据数组。

返回：
第一个 double 数据数组。

getData

public double[] getData(int bank)
返回指定存储单元的数据数组。

参数：
bank - 数据数组
返回：
由 bank 指定的数据数组。

getBankData

public double[][] getBankData()
返回所有存储单元的数据数组。

返回：
此数据缓冲区中的所有数据数组。

getElem

public int getElem(int i)
以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElem
参数：
i - 所需数据数组元素。
返回：
int 类型的数据项。
另请参见：
setElem(int, int), setElem(int, int, int)

getElem

public int getElem(int bank,
                   int i)
以 int 类型返回指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 getElem
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
返回：
int 类型的数据项。
另请参见：
setElem(int, int), setElem(int, int, int)

setElem

public void setElem(int i,
                    int val)
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。

覆盖：
类 DataBuffer 中的 setElem
参数：
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElem(int), getElem(int, int)

setElem

public void setElem(int bank,
                    int i,
                    int val)
将指定存储单元中所请求的数据数组元素设置为给定的 int。

指定者：
类 DataBuffer 中的 setElem
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElem(int), getElem(int, int)

getElemFloat

public float getElemFloat(int i)
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemFloat
参数：
i - 所需数据数组元素。
返回：
float 类型的数据项。
另请参见：
setElemFloat(int, float), setElemFloat(int, int, float)

getElemFloat

public float getElemFloat(int bank,
                          int i)
以 float 类型返回指定存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemFloat
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
返回：
float 类型的数据项。
另请参见：
setElemFloat(int, float), setElemFloat(int, int, float)

setElemFloat

public void setElemFloat(int i,
                         float val)
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。

覆盖：
类 DataBuffer 中的 setElemFloat
参数：
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemFloat(int), getElemFloat(int, int)

setElemFloat

public void setElemFloat(int bank,
                         int i,
                         float val)
将指定存储单元中所请求的数据数组元素设置为给定的 float。

覆盖：
类 DataBuffer 中的 setElemFloat
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemFloat(int), getElemFloat(int, int)

getElemDouble

public double getElemDouble(int i)
以 double 类型返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemDouble
参数：
i - 所需数据数组元素。
返回：
double 类型的数据项。
另请参见：
setElemDouble(int, double), setElemDouble(int, int, double)

getElemDouble

public double getElemDouble(int bank,
                            int i)
以 double 类型返回指定存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemDouble
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
返回：
double 类型的数据项。
另请参见：
setElemDouble(int, double), setElemDouble(int, int, double)

setElemDouble

public void setElemDouble(int i,
                          double val)
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。

覆盖：
类 DataBuffer 中的 setElemDouble
参数：
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemDouble(int), getElemDouble(int, int)

setElemDouble

public void setElemDouble(int bank,
                          int i,
                          double val)
将指定存储单元中所请求的数据数组元素设置为给定的 double。

覆盖：
类 DataBuffer 中的 setElemDouble
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemDouble(int), getElemDouble(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataBufferFloat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DataBufferFloat

java.lang.Object
    继承者  java.awt.image.DataBuffer
        继承者  java.awt.image.DataBufferFloat

public final class DataBufferFloat
extends DataBuffer

此类扩展了 DataBuffer，并在内部以 float 形式存储数据。

从以下版本开始：
1.4
另请参见：
DataBuffer

字段摘要
从类 java.awt.image.DataBuffer 继承的字段
banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT
构造方法摘要
DataBufferFloat(float[][] dataArray, int size)
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[][] dataArray, int size, int[] offsets)
构造具有指定数据数组、大小和每存储单元偏移量且基于 float 的 DataBuffer。
DataBufferFloat(float[] dataArray, int size)
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(float[] dataArray, int size, int offset)
构造具有指定数据数组且基于 float 的 DataBuffer。
DataBufferFloat(int size)
构造具有指定大小的且基于 float 的 DataBuffer。
DataBufferFloat(int size, int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 float 的 DataBuffer。
方法摘要
float[][] | getBankData() 返回所有存储单元的数据数组。
float[] | getData() 返回默认（第一个）float 数据数组。
float[] | getData(int bank) 返回指定存储单元的数据数组。
int | getElem(int i) 以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。
int | getElem(int bank, int i) 以 int 类型返回指定存储单元中所请求的数据数组元素。
double | getElemDouble(int i) 以 double 类型返回第一个（默认）存储单元所请求的数据数组元素。
double | getElemDouble(int bank, int i) 以 double 类型返回指定存储单元所请求的数据数组元素。
float | getElemFloat(int i) 以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。
float | getElemFloat(int bank, int i) 以 float 类型返回指定存储单元中所请求的数据数组元素。
void | setElem(int i, int val) 将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。
void | setElem(int bank, int i, int val) 将指定存储单元中所请求的数据数组元素设置为给定的 int。
void | setElemDouble(int i, double val) 将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。
void | setElemDouble(int bank, int i, double val) 将指定存储单元中所请求的数据数组元素设置为 double。
void | setElemFloat(int i, float val) 将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。
void | setElemFloat(int bank, int i, float val) 将指定存储单元中所请求的数据数组元素设置为给定的 float。
从类 java.awt.image.DataBuffer 继承的方法
getDataType, getDataTypeSize, getNumBanks, getOffset, getOffsets, getSize
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataBufferFloat

public DataBufferFloat(int size)
构造具有指定大小的且基于 float 的 DataBuffer。

参数：
size - DataBuffer 中的元素数量。

DataBufferFloat

public DataBufferFloat(int size,
                       int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 float 的 DataBuffer。

参数：
size - DataBuffer 的每个存储单元中的元素数量。
numBanks - DataBuffer 中存储单元的数量。

DataBufferFloat

public DataBufferFloat(float[] dataArray,
                       int size)
构造具有指定数据数组且基于 float 的 DataBuffer。只有前几个 size 元素可供此 DataBuffer 使用。该数组必须足够大，能够存储 size 元素。

参数：
dataArray - 用作此 DataBuffer 的第一个且是惟一存储单元的 float 的数组。
size - 要使用的数组的元素数量。

DataBufferFloat

public DataBufferFloat(float[] dataArray,
                       int size,
                       int offset)
构造具有指定数据数组且基于 float 的 DataBuffer。只有 offset 和 offset + size - 1 之间的元素可供此 DataBuffer 使用。该数组必须足够大，能够存储 offset + size 元素。

参数：
dataArray - 用作此 DataBuffer 的第一个且是惟一存储单元的 float 的数组。
size - 要使用的数组的元素数量。
offset - 要使用的数组的第一个元素的偏移量。

DataBufferFloat

public DataBufferFloat(float[][] dataArray,
                       int size)
构造具有指定数据数组且基于 float 的 DataBuffer。只有每个数组的前几个 size 元素可供此 DataBuffer 使用。存储单元的数量将等于 dataArray.length。

参数：
dataArray - 用作此 DataBuffer 存储单元的 float 数组的数组。
size - 要使用的每个数组的元素数量。

DataBufferFloat

public DataBufferFloat(float[][] dataArray,
                       int size,
                       int[] offsets)
构造具有指定数据数组、大小和每存储单元偏移量且基于 float 的 DataBuffer。存储单元的数量等于 dataArray.length。每个数组至少必须和 size 加上相应的偏移量大小相同。每个数据数组的偏移量数组中必须有一个项。

参数：
dataArray - 用作此 DataBuffer 存储单元的 float 数组的数组。
size - 要使用的每个数组的元素数量。
offsets - 整数偏移量数组，每个存储单元一个。
方法详细信息

getData

public float[] getData()
返回默认（第一个）float 数据数组。

返回：
第一个 float 数据数组。

getData

public float[] getData(int bank)
返回指定存储单元的数据数组。

参数：
bank - 数据数组
返回：
由 bank 指定的数据数组。

getBankData

public float[][] getBankData()
返回所有存储单元的数据数组。

返回：
此数据缓冲区中的所有数据数组。

getElem

public int getElem(int i)
以 int 类型返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElem
参数：
i - 所需数据数组元素。
返回：
int 类型的数据项。
另请参见：
setElem(int, int), setElem(int, int, int)

getElem

public int getElem(int bank,
                   int i)
以 int 类型返回指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 getElem
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
返回：
int 类型的数据项。
另请参见：
setElem(int, int), setElem(int, int, int)

setElem

public void setElem(int i,
                    int val)
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 int。

覆盖：
类 DataBuffer 中的 setElem
参数：
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElem(int), getElem(int, int)

setElem

public void setElem(int bank,
                    int i,
                    int val)
将指定存储单元中所请求的数据数组元素设置为给定的 int。

指定者：
类 DataBuffer 中的 setElem
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElem(int), getElem(int, int)

getElemFloat

public float getElemFloat(int i)
以 float 类型返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemFloat
参数：
i - 所需数据数组元素。
返回：
float 类型的数据项。
另请参见：
setElemFloat(int, float), setElemFloat(int, int, float)

getElemFloat

public float getElemFloat(int bank,
                          int i)
以 float 类型返回指定存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemFloat
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
返回：
float 类型的数据项。
另请参见：
setElemFloat(int, float), setElemFloat(int, int, float)

setElemFloat

public void setElemFloat(int i,
                         float val)
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 float。

覆盖：
类 DataBuffer 中的 setElemFloat
参数：
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemFloat(int), getElemFloat(int, int)

setElemFloat

public void setElemFloat(int bank,
                         int i,
                         float val)
将指定存储单元中所请求的数据数组元素设置为给定的 float。

覆盖：
类 DataBuffer 中的 setElemFloat
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemFloat(int), getElemFloat(int, int)

getElemDouble

public double getElemDouble(int i)
以 double 类型返回第一个（默认）存储单元所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemDouble
参数：
i - 所需数据数组元素。
返回：
double 类型的数据项。
另请参见：
setElemDouble(int, double), setElemDouble(int, int, double)

getElemDouble

public double getElemDouble(int bank,
                            int i)
以 double 类型返回指定存储单元所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElemDouble
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
返回：
double 类型的数据项。
另请参见：
setElemDouble(int, double), setElemDouble(int, int, double)

setElemDouble

public void setElemDouble(int i,
                          double val)
将第一个（默认）存储单元中所请求的数据数组元素设置为给定的 double。

覆盖：
类 DataBuffer 中的 setElemDouble
参数：
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemDouble(int), getElemDouble(int, int)

setElemDouble

public void setElemDouble(int bank,
                          int i,
                          double val)
将指定存储单元中所请求的数据数组元素设置为 double。

覆盖：
类 DataBuffer 中的 setElemDouble
参数：
bank - 存储单元的数量。
i - 所需数据数组元素。
val - 要设置的值。
另请参见：
getElemDouble(int), getElemDouble(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataBufferInt (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DataBufferInt

java.lang.Object
    继承者  java.awt.image.DataBuffer
        继承者  java.awt.image.DataBufferInt

public final class DataBufferInt
extends DataBuffer

此类扩展了 DataBuffer，并在内部以整数形式存储数据。

字段摘要
从类 java.awt.image.DataBuffer 继承的字段
banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT
构造方法摘要
DataBufferInt(int size)
构造具有单个存储单元和指定大小且基于整数的 DataBuffer。
DataBufferInt(int[][] dataArray, int size)
构造具有指定数组且基于整数的 DataBuffer。
DataBufferInt(int[][] dataArray, int size, int[] offsets)
构造具有指定数组、大小和偏移量且基于整数的 DataBuffer。
DataBufferInt(int[] dataArray, int size)
使用指定数组构造具有单个存储单元且基于整数的 DataBuffer。
DataBufferInt(int[] dataArray, int size, int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于整数的 DataBuffer。
DataBufferInt(int size, int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于整数的 DataBuffer。
方法摘要
int[][] | getBankData() 返回所有存储单元的数据数组。
int[] | getData() 返回 DataBuffer 中的默认（第一个）int 数据数组。
int[] | getData(int bank) 返回指定存储单元的数据数组。
int | getElem(int i) 返回第一个（默认）存储单元中所请求的数据数组元素。
int | getElem(int bank, int i) 返回指定存储单元中所请求的数据数组元素。
void | setElem(int i, int val) 将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
void | setElem(int bank, int i, int val) 将指定存储单元中所请求的数据数组元素设置为整数值 i。
从类 java.awt.image.DataBuffer 继承的方法
getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataBufferInt

public DataBufferInt(int size)
构造具有单个存储单元和指定大小且基于整数的 DataBuffer。

参数：
size - DataBuffer 的大小。

DataBufferInt

public DataBufferInt(int size,
                     int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于整数的 DataBuffer。

参数：
size - DataBuffer 中的存储单元大小。
numBanks - DataBuffer 中的存储单元数量。

DataBufferInt

public DataBufferInt(int[] dataArray,
                     int size)
使用指定数组构造具有单个存储单元且基于整数的 DataBuffer。此 DataBuffer 的访问器只能使用头 size 个元素。dataArray 必须足够大，能够存储 size 个元素。

参数：
dataArray - DataBuffer 的整数数组。
size - DataBuffer 存储单元大小。

DataBufferInt

public DataBufferInt(int[] dataArray,
                     int size,
                     int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于整数的 DataBuffer。dataArray 至少必须有 offset + size 个元素。此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的整数数组。
size - DataBuffer 存储单元大小。
offset - dataArray 的偏移量。

DataBufferInt

public DataBufferInt(int[][] dataArray,
                     int size)
构造具有指定数组且基于整数的 DataBuffer。存储单元的数量将等于 dataArray.length。此 DataBuffer 的访问器只能使用每个数组的头 size 个元素。

参数：
dataArray - DataBuffer 的整数数组。
size - DataBuffer 中的存储单元大小。

DataBufferInt

public DataBufferInt(int[][] dataArray,
                     int size,
                     int[] offsets)
构造具有指定数组、大小和偏移量且基于整数的 DataBuffer。存储单元的数量等于 dataArray.length。每个数组至少必须和 size 加上相应偏移量大小相同。每个 dataArray 项的偏移量数组中必须有一个项。对于每个存储单元，此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的整数数组。
size - DataBuffer 中的存储单元大小。
offsets - 每个数组中的偏移量。
方法详细信息

getData

public int[] getData()
返回 DataBuffer 中的默认（第一个）int 数据数组。

返回：
第一个整数数据数组。

getData

public int[] getData(int bank)
返回指定存储单元的数据数组。

参数：
bank - 要获取其数据数组的存储单元。
返回：
指定存储单元的数据数组。

getBankData

public int[][] getBankData()
返回所有存储单元的数据数组。

返回：
所有数据数组。

getElem

public int getElem(int i)
返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElem
参数：
i - 要获取的数据数组元素。
返回：
所请求的整数类型的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

getElem

public int getElem(int bank,
                   int i)
返回指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 getElem
参数：
bank - 要从中获取数据数组元素的存储单元。
i - 要获取的数据数组元素。
返回：
所请求的整数类型的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

setElem

public void setElem(int i,
                    int val)
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。

覆盖：
类 DataBuffer 中的 setElem
参数：
i - 要获取的数据数组元素。
val - 要将数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)

setElem

public void setElem(int bank,
                    int i,
                    int val)
将指定存储单元中所请求的数据数组元素设置为整数值 i。

指定者：
类 DataBuffer 中的 setElem
参数：
bank - 要在其中设置数据数组元素的存储单元。
i - 要获取的数据数组元素。
val - 要将指定数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataBufferShort (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DataBufferShort

java.lang.Object
    继承者  java.awt.image.DataBuffer
        继承者  java.awt.image.DataBufferShort

public final class DataBufferShort
extends DataBuffer

此类扩展了 DataBuffer，并在内部以 short 类型存储数据。

字段摘要
从类 java.awt.image.DataBuffer 继承的字段
banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT
构造方法摘要
DataBufferShort(int size)
构造具有单个存储单元和指定大小且基于 short 的 DataBuffer。
DataBufferShort(int size, int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 short 的 DataBuffer。
DataBufferShort(short[][] dataArray, int size)
构造具有指定数组且基于 short 的 DataBuffer。
DataBufferShort(short[][] dataArray, int size, int[] offsets)
构造具有指定数组、大小和偏移量且基于 short 的 DataBuffer。
DataBufferShort(short[] dataArray, int size)
使用指定数组构造具有单个存储单元且基于 short 的 DataBuffer。
DataBufferShort(short[] dataArray, int size, int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于 short 的 DataBuffer。
方法摘要
short[][] | getBankData() 返回所有存储单元的数据数组。
short[] | getData() 返回默认（第一个）字节数据数组。
short[] | getData(int bank) 返回指定存储单元的数据数组。
int | getElem(int i) 返回第一个（默认）存储单元中所请求的数据数组元素。
int | getElem(int bank, int i) 返回指定存储单元中所请求的数据数组元素。
void | setElem(int i, int val) 将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
void | setElem(int bank, int i, int val) 根据给定的整数设置指定存储单元中所请求的数据数组元素。
从类 java.awt.image.DataBuffer 继承的方法
getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataBufferShort

public DataBufferShort(int size)
构造具有单个存储单元和指定大小且基于 short 的 DataBuffer。

参数：
size - DataBuffer 的大小。

DataBufferShort

public DataBufferShort(int size,
                       int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于 short 的 DataBuffer。

参数：
size - DataBuffer 中的存储单元大小。
numBanks - DataBuffer 中的存储单元数量。

DataBufferShort

public DataBufferShort(short[] dataArray,
                       int size)
使用指定数组构造具有单个存储单元且基于 short 的 DataBuffer。此 DataBuffer 的访问器只能使用头 size 个元素。dataArray 必须足够大，能够存储 size 个元素。

参数：
dataArray - DataBuffer 的 short 数组。
size - DataBuffer 存储单元大小。

DataBufferShort

public DataBufferShort(short[] dataArray,
                       int size,
                       int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于 short 的 DataBuffer。dataArray 至少必须有 offset + size 个元素。此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的 short 数组。
size - DataBuffer 存储单元大小。
offset - dataArray 的偏移量。

DataBufferShort

public DataBufferShort(short[][] dataArray,
                       int size)
构造具有指定数组且基于 short 的 DataBuffer。存储单元的数量将等于 dataArray.length。此 DataBuffer 的访问器只能使用每个数组的头 size 个元素。

参数：
dataArray - DataBuffer 的 short 数组。
size - DataBuffer 中的存储单元大小。

DataBufferShort

public DataBufferShort(short[][] dataArray,
                       int size,
                       int[] offsets)
构造具有指定数组、大小和偏移量且基于 short 的 DataBuffer。存储单元的数量等于 dataArray.length。每个数组至少必须和 size 加上相应偏移量大小相同。每个 dataArray 项的偏移量数组中必须有一个项。对于每个存储单元，此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的 short 数组。
size - DataBuffer 中的存储单元大小。
offsets - 每个数组中的偏移量。
方法详细信息

getData

public short[] getData()
返回默认（第一个）字节数据数组。

返回：
第一个 short 数据数组。

getData

public short[] getData(int bank)
返回指定存储单元的数据数组。

参数：
bank - 要获得其数据数组的存储单元。
返回：
指定存储单元的数据数组。

getBankData

public short[][] getBankData()
返回所有存储单元的数据数组。

返回：
所有数据数组。

getElem

public int getElem(int i)
返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElem
参数：
i - 要获取的数据数组元素。
返回：
以整数为单位所请求的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

getElem

public int getElem(int bank,
                   int i)
返回指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 getElem
参数：
bank - 要从中获取数据数组元素的存储单元。
i - 要获取的数据数组元素。
返回：
所请求的整数类型的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

setElem

public void setElem(int i,
                    int val)
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。

覆盖：
类 DataBuffer 中的 setElem
参数：
i - 要设置的数据数组元素。
val - 要将数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)

setElem

public void setElem(int bank,
                    int i,
                    int val)
根据给定的整数设置指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 setElem
参数：
bank - 要在其中设置数据数组元素的存储单元。
i - 要设置的数据数组元素。
val - 要将指定数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataBufferUShort (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DataBufferUShort

java.lang.Object
    继承者  java.awt.image.DataBuffer
        继承者  java.awt.image.DataBufferUShort

public final class DataBufferUShort
extends DataBuffer

此类扩展了 DataBuffer，并在内部以 short 类型存储数据。存储在此 DataBuffer 的 short 数组中的值被视为无符号值。

字段摘要
从类 java.awt.image.DataBuffer 继承的字段
banks, dataType, offset, offsets, size, TYPE_BYTE, TYPE_DOUBLE, TYPE_FLOAT, TYPE_INT, TYPE_SHORT, TYPE_UNDEFINED, TYPE_USHORT
构造方法摘要
DataBufferUShort(int size)
构造具有单个存储单元和指定大小且基于无符号 short 的 DataBuffer。
DataBufferUShort(int size, int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[][] dataArray, int size)
构造具有指定数组且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[][] dataArray, int size, int[] offsets)
构造具有指定数组、大小和偏移量且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[] dataArray, int size)
使用指定数组构造具有单个存储单元且基于无符号 short 的 DataBuffer。
DataBufferUShort(short[] dataArray, int size, int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于无符号 short 的 DataBuffer。
方法摘要
short[][] | getBankData() 返回所有存储单元的数据数组。
short[] | getData() 返回默认的（第一个）无符号 short 数据数组。
short[] | getData(int bank) 返回指定存储单元的数据数组。
int | getElem(int i) 返回第一个（默认）存储单元中所请求的数据数组元素。
int | getElem(int bank, int i) 返回指定存储单元中所请求的数据数组元素。
void | setElem(int i, int val) 将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。
void | setElem(int bank, int i, int val) 根据给定的整数设置指定存储单元中所请求的数据数组元素。
从类 java.awt.image.DataBuffer 继承的方法
getDataType, getDataTypeSize, getElemDouble, getElemDouble, getElemFloat, getElemFloat, getNumBanks, getOffset, getOffsets, getSize, setElemDouble, setElemDouble, setElemFloat, setElemFloat
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataBufferUShort

public DataBufferUShort(int size)
构造具有单个存储单元和指定大小且基于无符号 short 的 DataBuffer。

参数：
size - DataBuffer 的大小。

DataBufferUShort

public DataBufferUShort(int size,
                        int numBanks)
构造具有指定数量的存储单元（这些存储单元都指定了大小）且基于无符号 short 的 DataBuffer。

参数：
size - DataBuffer 中的存储单元大小。
numBanks - DataBuffer 中的存储单元数量。

DataBufferUShort

public DataBufferUShort(short[] dataArray,
                        int size)
使用指定数组构造具有单个存储单元且基于无符号 short 的 DataBuffer。此 DataBuffer 的访问器只能使用头 size 个元素。dataArray 必须足够大，能够存储 size 个元素。

参数：
dataArray - DataBuffer 的无符号 short 数组。
size - DataBuffer 存储单元大小。

DataBufferUShort

public DataBufferUShort(short[] dataArray,
                        int size,
                        int offset)
使用指定数组、大小和偏移量构造具有单个存储单元且基于无符号 short 的 DataBuffer。dataArray 至少必须有 offset + size 个元素。此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的无符号 short 数组。
size - DataBuffer 存储单元大小。
offset - dataArray 的偏移量。

DataBufferUShort

public DataBufferUShort(short[][] dataArray,
                        int size)
构造具有指定数组且基于无符号 short 的 DataBuffer。存储单元的数量将等于 dataArray.length。此 DataBuffer 的访问器只能使用每个数组的头 size 个元素。

参数：
dataArray - DataBuffer 的无符号 short 数组。
size - DataBuffer 中的存储单元大小。

DataBufferUShort

public DataBufferUShort(short[][] dataArray,
                        int size,
                        int[] offsets)
构造具有指定数组、大小和偏移量且基于无符号 short 的 DataBuffer。存储单元的数量等于 dataArray.length。每个数组至少必须和 size 加上相应偏移量大小相同。每个 dataArray 项的偏移量数组中必须有一个项。对于每个存储单元，此 DataBuffer 的访问器只能使用 offset 到 offset + size - 1 个元素。

参数：
dataArray - DataBuffer 的无符号 short 数组。
size - DataBuffer 中的存储单元大小。
offsets - 每个数组的偏移量。
方法详细信息

getData

public short[] getData()
返回默认的（第一个）无符号 short 数据数组。

返回：
第一个无符号 short 数据数组。

getData

public short[] getData(int bank)
返回指定存储单元的数据数组。

参数：
bank - 要获取其数据数组的存储单元。
返回：
指定存储单元的数据数组。

getBankData

public short[][] getBankData()
返回所有存储单元的数据数组。

返回：
所有数据数组。

getElem

public int getElem(int i)
返回第一个（默认）存储单元中所请求的数据数组元素。

覆盖：
类 DataBuffer 中的 getElem
参数：
i - 要获取的数据数组元素。
返回：
所请求的整数类型的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

getElem

public int getElem(int bank,
                   int i)
返回指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 getElem
参数：
bank - 要从中获取数据数组元素的存储单元。
i - 要获取的数据数组元素。
返回：
所请求的整数类型的数据数组元素。
另请参见：
setElem(int, int), setElem(int, int, int)

setElem

public void setElem(int i,
                    int val)
将第一个（默认）存储单元中所请求的数据数组元素设置为指定值。

覆盖：
类 DataBuffer 中的 setElem
参数：
i - 要设置的数据数组元素。
val - 要将数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)

setElem

public void setElem(int bank,
                    int i,
                    int val)
根据给定的整数设置指定存储单元中所请求的数据数组元素。

指定者：
类 DataBuffer 中的 setElem
参数：
bank - 要在其中设置数据数组元素的存储单元。
i - 要设置的数据数组元素。
val - 要将指定数据数组元素设置为的整数值。
另请参见：
getElem(int), getElem(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DirectColorModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 DirectColorModel

java.lang.Object
    继承者  java.awt.image.ColorModel
        继承者  java.awt.image.PackedColorModel
            继承者  java.awt.image.DirectColorModel
所有已实现的接口：
Transparency
public class DirectColorModel
extends PackedColorModel

DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。此类只能与类型 ColorSpace.TYPE_RGB 的 ColorSpaces 一起使用。此外，对于 ColorSpace 的每个分量，通过 ColorSpace 的 getMinValue() 方法得到的最小标准化分量值必须是 0.0，通过 getMaxValue() 方法得到的最大值必须是 1.0（这些最小/最大值是 RGB 空间的常见值）。像素值中必须有三个颜色样本，且可以有一个 alpha 样本。对于那些使用类型 transferType 的基本数组像素表示形式的方法，数组长度总是 1。受支持的转换类型是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 和 DataBuffer.TYPE_INT。颜色和 alpha 样本以位为单位存储在位掩码指示的数组的单个元素中。每个位掩码必须是连续的，并且掩码一定不能重叠。相同的掩码可以应用于由其他方法使用的单个 int 像素表示形式。掩码和颜色/alpha 样本间的对应关系如下：

  • 如果 alpha 不存在，掩码则由运行 0 到 2 的索引标识，如果 alpha 存在，则由运行 3 的索引标识。
  • 前三个索引指的是颜色样本；索引 0 对应于红色，索引 1 对应于绿色，索引 2 对应于蓝色。
  • 索引 3 对应于 alpha 样本（如果存在）。

出于显示或处理的目的，像素值到颜色/alpha 分量的转换是从样本到分量一一对应的。DirectColorModel 通常与使用掩码定义打包样本的图像数据一起使用。例如，DirectColorModel 可以与 SinglePixelPackedSampleModel 一起使用来构造 BufferedImage。通常，SampleModel 和 ColorModel 使用的掩码是相同的。但是，如果掩码不相同，像素数据的颜色解释将根据 ColorModel 的掩码进行。

单个 int 像素表示形式对此类的所有对象都有效，因为它总是能够表示在单个 int 中与此类一起使用的像素值。因此，使用此表示形式的方法将不会因无效的像素值而抛出 IllegalArgumentException。

此颜色模型类似于 X11 TrueColor 可视分量。由 getRGBdefault 方法指定的默认 RGB ColorModel 是一个具有以下参数的 DirectColorModel：

位数：        32
红色掩码：0x00ff0000
绿色掩码：0x0000ff00
蓝色掩码：0x000000ff
Alpha 掩码：0xff000000
颜色空间：sRGB
isAlphaPremultiplied：False
透明度：Transparency.TRANSLUCENT
transferType：DataBuffer.TYPE_INT

此类中的许多方法都是 final。这是因为基础本机图形代码假定此类的布局和操作，并在此处标记 final 的方法实现中反映了这些假定。您可以出于其他原因将此类子类化，但不能重写或修改那些方法的行为。

另请参见：
ColorModel, ColorSpace, SinglePixelPackedSampleModel, BufferedImage, ColorModel.getRGBdefault()

字段摘要
从类 java.awt.image.ColorModel 继承的字段
pixel_bits, transferType
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
DirectColorModel(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int transferType)
根据指定参数构造 DirectColorModel。
DirectColorModel(int bits, int rmask, int gmask, int bmask)
根据指定的指示 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本的掩码构造 DirectColorModel。
DirectColorModel(int bits, int rmask, int gmask, int bmask, int amask)
根据指定的指示在 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本与 alpha 样本（如果存在）的掩码构造 DirectColorModel。
方法摘要
ColorModel | coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。
WritableRaster | createCompatibleWritableRaster(int w, int h) 创建具有指定宽度和高度、拥有与此 ColorModel 兼容的数据布局 (SampleModel) 的 WritableRaster。
int | getAlpha(int pixel) 返回指定像素（缩放范围从 0 到 255）的 alpha 分量。
int | getAlpha(Object inData) 返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。
int | getAlphaMask() 返回指示 int 像素表示形式中哪些位包含 alpha 分量的掩码。
int | getBlue(int pixel) 返回指定像素的蓝色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getBlue(Object inData) 返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getBlueMask() 返回指示 int 像素表示形式中哪些位包含蓝色颜色分量的掩码。
int[] | getComponents(int pixel, int[] components, int offset) 返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。
int[] | getComponents(Object pixel, int[] components, int offset) 返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。
int | getDataElement(int[] components, int offset) 在给定未标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。
Object | getDataElements(int[] components, int offset, Object obj) 在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。
Object | getDataElements(int rgb, Object pixel) 在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。
int | getGreen(int pixel) 返回指定像素的绿色颜色分量，指定像素在默认 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getGreen(Object inData) 返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getGreenMask() 返回指示 int 像素表示形式中哪些位包含绿色颜色分量的掩码。
int | getRed(int pixel) 返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getRed(Object inData) 返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。
int | getRedMask() 返回指定 int 像素表示形式中哪些位包含红色分量的掩码。
int | getRGB(int pixel) 返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
int | getRGB(Object inData) 返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。
boolean | isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
String | toString() 返回表示此 DirectColorModel 的 String。
从类 java.awt.image.PackedColorModel 继承的方法
createCompatibleSampleModel, equals, getAlphaRaster, getMask, getMasks, isCompatibleSampleModel
从类 java.awt.image.ColorModel 继承的方法
finalize, getColorSpace, getComponentSize, getComponentSize, getDataElement, getDataElements, getNormalizedComponents, getNormalizedComponents, getNumColorComponents, getNumComponents, getPixelSize, getRGBdefault, getTransferType, getTransparency, getUnnormalizedComponents, hasAlpha, hashCode, isAlphaPremultiplied
从类 java.lang.Object 继承的方法
clone, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DirectColorModel

public DirectColorModel(int bits,
                        int rmask,
                        int gmask,
                        int bmask)
根据指定的指示 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本的掩码构造 DirectColorModel。因为像素值不包含 alpha 信息，所以所有像素都可视为不透明的，这意味着 alpha = 1.0。每个掩码中的所有位必须是连续的，并且符合 int 像素表示形式的最低有效位的指定数量。ColorSpace 是默认的 sRGB 空间。透明度值为 Transparency.OPAQUE。转换类型是存储单个像素的 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 中的最小者。

参数：
bits - 像素值中的位数量；例如，掩码中位的数量总和。
rmask - 指定指示整数像素中哪些位包含红色分量的掩码
gmask - 指定指示整数像素中哪些位包含绿色分量的掩码
bmask - 指定指示整数像素中哪些位包含蓝色分量的掩码

DirectColorModel

public DirectColorModel(int bits,
                        int rmask,
                        int gmask,
                        int bmask,
                        int amask)
根据指定的指示在 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本与 alpha 样本（如果存在）的掩码构造 DirectColorModel。如果 amask 为 0，则像素值不包含 alpha 信息，且所有像素都可视为不透明的，这意味着 alpha = 1.0。每个掩码中的所有位必须是连续的，并且符合 int 像素表示形式的最低有效位的指定数量。Alpha（如果存在）不是预先乘得的值。ColorSpace 是默认的 sRGB 空间。如果 alpha 不存在，则透明度值是 Transparency.OPAQUE，否则是 Transparency.TRANSLUCENT。转换类型是存储单个像素的 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 中的最小者。

参数：
bits - 像素值中的位数量；例如，掩码中位的数量总和。
rmask - 指定指示整数像素中哪些位包含红色分量的掩码
gmask - 指定指示整数像素中哪些位包含绿色分量的掩码
bmask - 指定指示整数像素中哪些位包含蓝色分量的掩码
amask - 指定指示整数像素中哪些位包含 alpha 分量的掩码

DirectColorModel

public DirectColorModel(ColorSpace space,
                        int bits,
                        int rmask,
                        int gmask,
                        int bmask,
                        int amask,
                        boolean isAlphaPremultiplied,
                        int transferType)
根据指定参数构造 DirectColorModel。颜色分量位于指定的 ColorSpace，后者必须属于类型 ColorSpace.TYPE_RGB，并且必须具有都是 0.0 的最小标准化分量值和都是 1.0 的最大值。掩码指定在 int 像素表示形式中哪些位包含红色、绿色和蓝色颜色样本与 alpha 样本（如果存在）。如果 amask 为 0，则像素值不包含 alpha 信息，且所有像素都可视为不透明的，这意味着 alpha = 1.0。每个掩码中的所有位必须是连续的，并且符合 int 像素表示形式的最低有效位的指定数量。如果 alpha 存在，则 boolean isAlphaPremultiplied 指定如何解释像素值中的颜色和 alpha 样本。如果 boolean 为 true，则假定颜色样本已经乘以 alpha 样本。如果 alpha 不存在，则透明度值为 Transparency.OPAQUE，否则为 Transparency.TRANSLUCENT。转换类型是用来表示像素值的基本数组的类型，并且必须是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之一。

参数：
space - 指定的 ColorSpace
bits - 像素值中位的数量；例如，掩码中位的数量和。
rmask - 指定指示整数像素中哪些位包含红色分量的掩码
gmask - 指定指示整数像素中哪些位包含绿色分量的掩码
bmask - 指定指示整数像素中哪些位包含蓝色分量的掩码
amask - 指定指示整数像素中哪些位包含 alpha 分量的掩码
isAlphaPremultiplied - true 如果将颜色样本预先乘以 alpha 样本；否则 false
transferType - 用来表示像素值的数组的类型
抛出：
IllegalArgumentException - 如果 space 不是 TYPE_RGB 空间，或如果最小/最大标准化分量值不是 0.0/1.0。
方法详细信息

getRedMask

public final int getRedMask()
返回指定 int 像素表示形式中哪些位包含红色分量的掩码。

返回：
指示 int 像素表示形式的哪些位包含红色颜色样本的掩码。

getGreenMask

public final int getGreenMask()
返回指示 int 像素表示形式中哪些位包含绿色颜色分量的掩码。

返回：
指示 int 像素表示形式的哪些位包含绿色颜色样本的掩码。

getBlueMask

public final int getBlueMask()
返回指示 int 像素表示形式中哪些位包含蓝色颜色分量的掩码。

返回：
指示 int 像素表示形式的哪些位包含蓝色颜色样本的掩码。

getAlphaMask

public final int getAlphaMask()
返回指示 int 像素表示形式中哪些位包含 alpha 分量的掩码。

返回：
指示 int 像素表示形式的哪些位包含 alpha 样本的掩码。

getRed

public final int getRed(int pixel)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将像素值指定为 int。返回的值是一个非预先乘得的值。因此，如果预乘 alpha，则此方法会在返回该值之前将其分离出来。例如，如果 alpha 值为 0，则红色值为 0。

指定者：
类 ColorModel 中的 getRed
参数：
pixel - 指定的像素
返回：
指定像素（在 sRGB ColorSpace 中缩放范围从 0 到 255）的红色颜色分量。

getGreen

public final int getGreen(int pixel)
返回指定像素的绿色颜色分量，指定像素在默认 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将像素值指定为 int。返回的值是一个非预先乘得的值。因此，如果预乘 alpha，则此方法会在返回该值之前将其分离出来。例如，如果 alpha 值为 0，则绿色值为 0。

指定者：
类 ColorModel 中的 getGreen
参数：
pixel - 指定像素
返回：
指定像素（在 sRGB ColorSpace 中缩放范围从 0 到 255）的绿色颜色分量。

getBlue

public final int getBlue(int pixel)
返回指定像素的蓝色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。将像素值指定为 int。返回的值是一个非预先乘得的值。因此，如果预乘 alpha，则此方法会在返回该值之前将其分离出来。例如，如果 alpha 值为 0，则蓝色值为 0。

指定者：
类 ColorModel 中的 getBlue
参数：
pixel - 指定的像素
返回：
指定像素（在 sRGB ColorSpace 中缩放范围从 0 到 255）的蓝色颜色分量。

getAlpha

public final int getAlpha(int pixel)
返回指定像素（缩放范围从 0 到 255）的 alpha 分量。像素值指定为 int。

指定者：
类 ColorModel 中的 getAlpha
参数：
pixel - 指定像素
返回：
pixel（0 到 255）的 alpha 分量的值。

getRGB

public final int getRGB(int pixel)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。如有必要，可进行颜色转换。将像素值指定为 int。返回的值是非预乘格式。因此，如果预乘 alpha，则此方法会将它从颜色分量中分离出来。例如，如果 alpha 值为 0，则颜色值每个分量都是 0。

覆盖：
类 ColorModel 中的 getRGB
参数：
pixel - 指定的像素
返回：
指定像素的颜色/alpha 分量的 RGB 值。
另请参见：
ColorModel.getRGBdefault()

getRed

public int getRed(Object inData)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。返回的值是一个非预先乘得的值。因此，如果预乘 alpha，则此方法会在返回该值之前将其分离出来。例如，如果 alpha 值为 0，则红色值为 0。如果 inData 不是类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。如果此 transferType 不受该 ColorModel 支持，则抛出 UnsupportedOperationException。

覆盖：
类 ColorModel 中的 getRed
参数：
inData - 包含该像素值的数组
返回：
指定像素的红色分量的值。
抛出：
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此颜色模型的像素值
ClassCastException - 如果 inData 不是类型 transferType 的基本数组
UnsupportedOperationException - 如果此颜色模型不支持 transferType

getGreen

public int getGreen(Object inData)
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。返回的值是一个非预先乘得的值。因此，如果预乘 alpha，则此方法会在返回该值之前将其分离出来。例如，如果 alpha 值为 0，则绿色值为 0。如果 inData 不是类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。如果此 transferType 不受该 ColorModel 支持，则抛出 UnsupportedOperationException。

覆盖：
类 ColorModel 中的 getGreen
参数：
inData - 包含该像素值的数组
返回：
指定像素的绿色分量的值。
抛出：
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此颜色模型的像素值
ClassCastException - 如果 inData 不是类型 transferType 的基本数组
UnsupportedOperationException - 如果此颜色模型不支持 transferType

getBlue

public int getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。返回的值是一个非预先乘得的值。因此，如果预乘 alpha，则此方法会在返回该值之前将其分离出来。例如，如果 alpha 值为 0，则蓝色值为 0。如果 inData 不是类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。如果此 transferType 不受该 ColorModel 支持，则抛出 UnsupportedOperationException。

覆盖：
类 ColorModel 中的 getBlue
参数：
inData - 包含像素值的数组
返回：
指定像素的蓝色分量的值。
抛出：
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此颜色模型的像素值
ClassCastException - 如果 inData 不是类型 transferType 的基本数组
UnsupportedOperationException - 如果此颜色模型不支持 transferType

getAlpha

public int getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果 inData 不是类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。如果此 transferType 不受支持，则抛出 UnsupportedOperationException。

覆盖：
类 ColorModel 中的 getAlpha
参数：
inData - 指定的像素
返回：
指定像素（在 0 到 255 之间缩放）的 alpha 分量
抛出：
ClassCastException - 如果 inData 不是类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 inData 不是特别大，不能存储此 ColorModel 的像素
UnsupportedOperationException - 如果此 tranferType 不受此 ColorModel 支持

getRGB

public int getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。如有必要，可进行颜色转换。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果 inData 不是类型 transferType 的基本数组，则抛出 ClassCastException。如果 inData 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。返回的值是非预乘格式。因此，如果预乘 alpha，则此方法会将它从颜色分量中分离出来。例如，如果 alpha 值为 0，则颜色值为 0。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getRGB
参数：
inData - 指定的像素
返回：
指定像素的颜色和 alpha 分量。
抛出：
UnsupportedOperationException - 如果该 transferType 不受此 ColorModel 支持
另请参见：
ColorModel.getRGBdefault()

getDataElements

public Object getDataElements(int rgb,
                              Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。然后可以将此数组传递给 WritableRaster 对象的 setDataElements 方法。如果像素变量为 null，则分配一个新数组。如果 pixel 不为 null，则它必须是类型 transferType 的基本数组；否则，抛出 ClassCastException。如果 pixel 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。此像素数组被返回。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getDataElements
参数：
rgb - 默认的 RGB 颜色模型中的整数像素表示形式
pixel - 指定像素
返回：
此 ColorModel 中指定像素的数组表示形式
抛出：
ClassCastException - 如果 pixel 不是类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 pixel 不是特别大，不能存储此 ColorModel 的像素值
UnsupportedOperationException - 如果此 transferType 不受此 ColorModel 支持
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getComponents

public final int[] getComponents(int pixel,
                                 int[] components,
                                 int offset)
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。将像素值指定为 int。如果该 components 数组为 null，则分配一个新数组。该 components 数组被返回。将颜色/alpha 分量存储在以 offset 开头的 components 数组中，即便此方法已分配了数组也如此。如果 components 数组不为 null 且不是特别大，不能以 offset 开头存储所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ColorModel 中的 getComponents
参数：
pixel - 指定的像素
components - 接收指定像素的颜色和 alpha 分量的数组
offset - 开始存储颜色和 alpha 分量时的 components 数组的偏移量
返回：
包含以指定偏移量开头的指定像素的颜色和 alpha 分量的数组。

getComponents

public final int[] getComponents(Object pixel,
                                 int[] components,
                                 int offset)
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。像素值由作为对象引用传入的类型 transferType 的数据元素的数组指定。如果 pixel 不是类型 transferType 的基本数组，则抛出 ClassCastException。如果 pixel 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。如果该 components 数组为 null，则分配一个新数组。该 components 数组被返回。将颜色/alpha 分量存储在以 offset 开头的 components 数组中，即便此方法已分配了数组也如此。如果 components 数组不为 null 且不是特别大，不能以 offset 开头存储所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getComponents
参数：
pixel - 指定的像素
components - 接收指定像素的颜色和 alpha 分量的数组
offset - 开始存储颜色和 alpha 分量时的 components 数组的偏移量
返回：
包含以指定偏移量开头的指定像素的颜色和 alpha 分量的数组。
抛出：
ClassCastException - 如果 pixel 不是类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 pixel 不是特别大，不能存储此 ColorModel 的像素值，或如果 components 不为 null 且不是特别大，不能以 offset 开头保存所有颜色和 alpha 分量
UnsupportedOperationException - 如果此 transferType 不受此颜色模型支持

createCompatibleWritableRaster

public final WritableRaster createCompatibleWritableRaster(int w,
                                                           int h)
创建具有指定宽度和高度、拥有与此 ColorModel 兼容的数据布局 (SampleModel) 的 WritableRaster。

覆盖：
类 ColorModel 中的 createCompatibleWritableRaster
参数：
w - 应用到新 WritableRaster 的宽度
h - 应用到新 WritableRaster 的高度
返回：
具有指定宽度和高度的 WritableRaster 对象。
抛出：
IllegalArgumentException - 如果 w 或 h 小于或等于 0
另请参见：
WritableRaster, SampleModel

getDataElement

public int getDataElement(int[] components,
                          int offset)
在给定未标准化颜色/alpha 分量的数组的情况下，返回以 int 类型表示在此 ColorModel 中的像素值。如果 components 数组不是特别大，不能以 offset 开头存储所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ColorModel 中的 getDataElement
参数：
components - 未标准化的颜色和 alpha 分量的数组
offset - 开始检索颜色和 alpha 分量处的 components 的索引
返回：
此 ColorModel 中与指定分量相对应的 int 像素值。
抛出：
ArrayIndexOutOfBoundsException - 如果 components 数组不是特别大，不能存储所有以 offset 开头的颜色和 alpha 分量

getDataElements

public Object getDataElements(int[] components,
                              int offset,
                              Object obj)
在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。然后可以将此数组传递给 WritableRaster 对象的 setDataElements 方法。如果 components 数组不是特别大，不能存储所有以偏移量开头的颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。如果 obj 变量为 null，则分配一个新数组。如果 obj 不为 null，则它必须是类型 transferType 的基本数组；否则，抛出 ClassCastException。如果 obj 不是特别大，不能存储此 ColorModel 的像素值，则抛出 ArrayIndexOutOfBoundsException。因为 DirectColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 getDataElements
参数：
components - 未标准化的颜色和 alpha 分量的数组
offset - 开始检索颜色和 alpha 分量处的 components 的索引
obj - 表示颜色和 alpha 分量的数组的 Object
返回：
表示颜色和 alpha 分量的数组的 Object。
抛出：
ClassCastException - 如果 obj 不是类型 transferType 的基本数组
ArrayIndexOutOfBoundsException - 如果 obj 不是特别大，不能存储此 ColorModel 的像素值，或该 components 数组不是特别大，不能存储所有以 offset 开头的颜色和 alpha 分量
UnsupportedOperationException - 如果此 transferType 不受此颜色模型支持
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

coerceData

public final ColorModel coerceData(WritableRaster raster,
                                   boolean isAlphaPremultiplied)
强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。可以将颜色光栅数据乘以或除以 alpha，如果该数据处于正确状态，则不执行任何操作。如果需要对该数据强制匹配，则此方法还将相应地返回一个带有 isAlphaPremultiplied 标志集的 ColorModel 实例。如果此 transferType 不受此 ColorModel 支持，则此方法将抛出 UnsupportedOperationException。因为 ColorModel 可以子类化，所以子类可以继承此方法的实现，并且如果不重写此方法，则当它们使用不受支持的 transferType 时，将抛出异常。

覆盖：
类 ColorModel 中的 coerceData
参数：
raster - WritableRaster 数据
isAlphaPremultiplied - 如果 alpha 是预先乘得的，则为 true；否则为 false
返回：
表示被强制数据的 ColorModel 对象。
抛出：
UnsupportedOperationException - 如果此 transferType 不受此颜色模型支持

isCompatibleRaster

public boolean isCompatibleRaster(Raster raster)
如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。

覆盖：
类 ColorModel 中的 isCompatibleRaster
参数：
raster - 测试兼容性的 Raster 对象
返回：
true 如果 raster 与此 ColorModel 兼容；否则 false。

toString

public String toString()
返回表示此 DirectColorModel 的 String。

覆盖：
类 ColorModel 中的 toString
返回：
表示此 DirectColorModel 的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilteredImageSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 FilteredImageSource

java.lang.Object
    继承者  java.awt.image.FilteredImageSource
所有已实现的接口：
ImageProducer
public class FilteredImageSource
extends Object
implements ImageProducer

此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。下面的示例通过交换红色和蓝色分量来过滤图像：

        Image src = getImage("doc:///demo/images/duke/T1.gif");
        ImageFilter colorfilter = new RedBlueSwapFilter();
        Image img = createImage(new FilteredImageSource(src.getSource(),
                                                        colorfilter));

另请参见：
ImageProducer

构造方法摘要
FilteredImageSource(ImageProducer orig, ImageFilter imgf)
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。
方法摘要
void | addConsumer(ImageConsumer ic) 将指定的 ImageConsumer 添加到对过滤图像的数据感兴趣的使用者列表。
boolean | isConsumer(ImageConsumer ic) 确定一个 ImageConsumer 是否在对此图像数据感兴趣的使用者列表中。
void | removeConsumer(ImageConsumer ic) 从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
void | requestTopDownLeftRightResend(ImageConsumer ic) 请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
void | startProduction(ImageConsumer ic) 开始生成过滤图像。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FilteredImageSource

public FilteredImageSource(ImageProducer orig,
                           ImageFilter imgf)
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。

参数：
orig - 指定的 ImageProducer
imgf - 指定的 ImageFilter
另请参见：
ImageFilter, Component.createImage(java.awt.image.ImageProducer)
方法详细信息

addConsumer

public void addConsumer(ImageConsumer ic)
将指定的 ImageConsumer 添加到对过滤图像的数据感兴趣的使用者列表。创建原 ImageFilter 的一个实例（使用过滤器的 getFilterInstance 方法），以操作指定 ImageConsumer 的图像数据。然后将新创建的过滤器实例传递到原 ImageProducer 的 addConsumer 方法。

作为实现 ImageProducer 接口的此类的一个副作用，此方法是公共的。不应从用户代码中调用此方法，如果这样调用，则其行为是未指定的。

指定者：
接口 ImageProducer 中的 addConsumer
参数：
ic - 过滤图像的使用者
另请参见：
ImageConsumer

isConsumer

public boolean isConsumer(ImageConsumer ic)
确定一个 ImageConsumer 是否在对此图像数据感兴趣的使用者列表中。

作为实现 ImageProducer 接口的此类的一个副作用，此方法是公共的。不应从用户代码中调用此方法，如果这样调用，则其行为是未指定的。

指定者：
接口 ImageProducer 中的 isConsumer
参数：
ic - 指定的 ImageConsumer
返回：
如果 ImageConsumer 在列表中，则返回 true；否则返回 false
另请参见：
ImageConsumer

removeConsumer

public void removeConsumer(ImageConsumer ic)
从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。

作为实现 ImageProducer 接口的此类的一个副作用，此方法是公共的。不应从用户代码中调用此方法，如果这样调用，则其行为是未指定的。

指定者：
接口 ImageProducer 中的 removeConsumer
参数：
ic - 指定的 ImageConsumer
另请参见：
ImageConsumer

startProduction

public void startProduction(ImageConsumer ic)
开始生成过滤图像。如果指定的 ImageConsumer 还不是过滤图像的使用者，则创建原 ImageFilter 的一个实例（使用过滤器的 getFilterInstance 方法），以操作 ImageConsumer 的图像数据。然后将 ImageConsumer 的过滤器实例传递给原 ImageProducer 的 startProduction 方法。

作为实现 ImageProducer 接口的此类的一个副作用，此方法是公共的。不应从用户代码中调用此方法，如果这样调用，则其行为是未指定的。

指定者：
接口 ImageProducer 中的 startProduction
参数：
ic - 过滤图像的使用者
另请参见：
ImageConsumer

requestTopDownLeftRightResend

public void requestTopDownLeftRightResend(ImageConsumer ic)
请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。因为保留像素顺序的能力取决于过滤器，所以该请求被传递到 ImageFilter 做进一步的处理。

作为实现 ImageProducer 接口的此类的一个副作用，此方法是公共的。不应从用户代码中调用此方法，如果这样调用，则其行为是未指定的。

指定者：
接口 ImageProducer 中的 requestTopDownLeftRightResend
参数：
ic - 指定的 ImageConsumer
另请参见：
ImageConsumer
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageConsumer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 ImageConsumer

所有已知实现类：
AreaAveragingScaleFilter, BufferedImageFilter, CropImageFilter, GrayFilter, ImageFilter, PixelGrabber, ReplicateScaleFilter, RGBImageFilter
public interface ImageConsumer

对通过 ImageProducer 接口的图像数据感兴趣的对象接口。将一个使用者添加到图像生产者时，生产者会使用此接口中定义的方法调用传递所有关于图像的数据。

另请参见：
ImageProducer

字段摘要
static int | COMPLETESCANLINES 按照一次（多个）完整扫描行的方式传递像素。
static int | IMAGEABORTED 图像创建进程被故意中止。
static int | IMAGEERROR 生成图像时遇到错误。
static int | RANDOMPIXELORDER 按随机顺序传递像素。
static int | SINGLEFRAME 该图像包含单幅静态图像。
static int | SINGLEFRAMEDONE 图像的某一帧已完成，但还有更多的帧要传递。
static int | SINGLEPASS 以单通道的方式传递像素。
static int | STATICIMAGEDONE 图像已完成，不再有像素或帧要传递。
static int | TOPDOWNLEFTRIGHT 按从上到下、从左到右的顺序传递像素。
方法摘要
void | imageComplete(int status) 当 ImageProducer 已完成源图像所含所有像素的传递时，或者已完成多帧动画的单个帧时，或者加载或生成图像中出现错误时，就调用 imageComplete 方法。
void | setColorModel(ColorModel model) 设置用于大多数像素的 ColorModel 对象，这些像素使用 setPixels 方法调用进行报告。
void | setDimensions(int width, int height) 使用 setDimensions 方法调用报告源图像尺寸。
void | setHints(int hintflags) 设置 ImageConsumer 用于处理 ImageProducer 所传递像素的提示。
void | setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 一次或多次调用此方法来传递图像的像素。
void | setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 一次或多次调用 setPixels 方法来传递图像的像素。
void | setProperties(Hashtable<?,?> props) 设置与此图像关联的可扩展属性列表。

字段详细信息

RANDOMPIXELORDER

static final int RANDOMPIXELORDER
按随机顺序传递像素。该字段告知 ImageConsumer 不要使用任何依赖于像素传递顺序的优化方法，在没有任何对 setHints 方法的调用时这应是默认的假定情况。

另请参见：
setHints(int), 常量字段值

TOPDOWNLEFTRIGHT

static final int TOPDOWNLEFTRIGHT
按从上到下、从左到右的顺序传递像素。

另请参见：
setHints(int), 常量字段值

COMPLETESCANLINES

static final int COMPLETESCANLINES
按照一次（多个）完整扫描行的方式传递像素。

另请参见：
setHints(int), 常量字段值

SINGLEPASS

static final int SINGLEPASS
以单通道的方式传递像素。每个像素只出现在某一个对 setPixels 方法的调用中。不符合此标准的一种图像格式是渐变 JPEG 图像，该图像以多通道的方式定义像素，每个通道都比前一个通道更为精确。

另请参见：
setHints(int), 常量字段值

SINGLEFRAME

static final int SINGLEFRAME
该图像包含单幅静态图像。像素将在调用 setPixels 方法时定义，不再传递图像数据之后，将调用带有 STATICIMAGEDONE 标志的 imageComplete 方法。不符合这些标准的一种图像类型是视频馈送输出，或由用户操作的 3D 呈现表示形式。通过调用带有 SINGLEFRAMEDONE 标志的 imageComplete 方法来指示这些图像类型中每一帧的结束。

另请参见：
setHints(int), imageComplete(int), 常量字段值

IMAGEERROR

static final int IMAGEERROR
生成图像时遇到错误。

另请参见：
imageComplete(int), 常量字段值

SINGLEFRAMEDONE

static final int SINGLEFRAMEDONE
图像的某一帧已完成，但还有更多的帧要传递。

另请参见：
imageComplete(int), 常量字段值

STATICIMAGEDONE

static final int STATICIMAGEDONE
图像已完成，不再有像素或帧要传递。

另请参见：
imageComplete(int), 常量字段值

IMAGEABORTED

static final int IMAGEABORTED
图像创建进程被故意中止。

另请参见：
imageComplete(int), 常量字段值
方法详细信息

setDimensions

void setDimensions(int width,
                   int height)
使用 setDimensions 方法调用报告源图像尺寸。

参数：
width - 源图像的宽度
height - 源图像的高度

setProperties

void setProperties(Hashtable<?,?> props)
设置与此图像关联的可扩展属性列表。

参数：
props - 要与此图像关联的属性列表

setColorModel

void setColorModel(ColorModel model)
设置用于大多数像素的 ColorModel 对象，这些像素使用 setPixels 方法调用进行报告。注意，使用 setPixels 传递的每个像素集合都包含其自己的 ColorModel 对象，所以不应假设此模型是传递像素值时使用的惟一模型。可以看到多个 ColorModel 对象时，一种值得注意的情况是过滤图像，对于它所过滤的每一个像素集合，过滤器确定是否可以使用原 ColorModel 不做改动地发送像素，或者是否应该使用对于过滤过程更方便的 ColorModel 修改（过滤）并传递像素。

参数：
model - 指定的 ColorModel
另请参见：
ColorModel

setHints

void setHints(int hintflags)
设置 ImageConsumer 用于处理 ImageProducer 所传递像素的提示。ImageProducer 能以任意顺序传递像素，但是如果 ImageConsumer 预先知道某些有关像素传递方式的信息，那么它就能够更高效或以更高的质量将像素缩放或转换到目标 ColorModel。应该在调用带提示位掩码（其中包含有关像素传递方式的信息）的任意 setPixels 方法前调用 setHints 方法。如果 ImageProducer 未遵从指定的提示准则，则结果是不明确的。

参数：
hintflags - ImageConsumer 用于处理像素的提示集合

setPixels

void setPixels(int x,
               int y,
               int w,
               int h,
               ColorModel model,
               byte[] pixels,
               int off,
               int scansize)
一次或多次调用此方法来传递图像的像素。每次调用都指定像素数组中所含源像素的矩形位置和大小。应该使用指定的 ColorModel 对象将像素转换为相应的颜色和 alpha 分量。像素 (m,n) 存储在像素数组的索引 (n * scansize + m + off) 处。使用此方法所传递的像素都以 byte 类型存储。

参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ColorModel

setPixels

void setPixels(int x,
               int y,
               int w,
               int h,
               ColorModel model,
               int[] pixels,
               int off,
               int scansize)
一次或多次调用 setPixels 方法来传递图像的像素。每次调用都指定像素数组中所含源像素的矩形位置和大小。应该使用指定的 ColorModel 对象将像素转换为相应的颜色和 alpha 分量。像素 (m,n) 存储在像素数组的索引 (n * scansize + m + off) 处。使用此方法所传递的像素都以 int 形式存储。此方法都以 int 形式存储。

参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ColorModel

imageComplete

void imageComplete(int status)
当 ImageProducer 已完成源图像所含所有像素的传递时，或者已完成多帧动画的单个帧时，或者加载或生成图像中出现错误时，就调用 imageComplete 方法。除非 ImageConsumer 还对后续的帧感兴趣，否则此时应该从以 ImageProducer 注册的使用者列表中将其自身移除。

参数：
status - 图像加载的状态
另请参见：
ImageProducer.removeConsumer(java.awt.image.ImageConsumer)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ImageFilter

java.lang.Object
    继承者  java.awt.image.ImageFilter
所有已实现的接口：
ImageConsumer, Cloneable
直接已知子类：
BufferedImageFilter, CropImageFilter, ReplicateScaleFilter, RGBImageFilter
public class ImageFilter
extends Object
implements ImageConsumer, Cloneable

此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。它应该与 FilteredImageSource 对象结合使用，以生成现有图像的过滤版本。它是一个基类，提供的方法并没有实际实现过滤功能，因此对通过的数据并没有任何作用，是一个“空过滤器”。过滤器应该创建此类的子类，并且重写那些处理需要过滤数据的方法并根据需要修改方法。

另请参见：
FilteredImageSource, ImageConsumer

字段摘要
protected  ImageConsumer consumer
特定图像数据流的使用者，而此 ImageFilter 实例也是为这个使用者来过滤数据的。
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
ImageFilter()
方法摘要
Object | clone() 复制此对象。
ImageFilter | getFilterInstance(ImageConsumer ic) 返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。
void | imageComplete(int status) 过滤 ImageConsumer 接口的 imageComplete 方法中所提供的信息。
void | resendTopDownLeftRight(ImageProducer ip) 响应来自 ImageConsumer 的一个按 TopDownLeftRight (TDLR) 顺序将像素数据重新发送的请求。
void | setColorModel(ColorModel model) 过滤 ImageConsumer 接口的 setColorModel 方法中所提供的信息。
void | setDimensions(int width, int height) 过滤 ImageConsumer 接口的 setDimensions 方法中所提供的信息。
void | setHints(int hints) 过滤 ImageConsumer 接口的 setHints 方法中所提供的信息。
void | setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以 byte 数组为参数。
void | setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以整数数组为参数。
void | setProperties(Hashtable<?,?> props) 添加一个属性，来指示已通过的过滤器流，并在这之后从源对象传递这些属性。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

consumer

protected ImageConsumer consumer
特定图像数据流的使用者，而此 ImageFilter 实例也是为这个使用者来过滤数据的。它不是在构造方法中进行初始化的，而是当 FilteredImageSource 正在为特定图像数据流创建此对象的惟一实例时，在 getFilterInstance() 方法调用期间进行初始化。

另请参见：
getFilterInstance(java.awt.image.ImageConsumer), ImageConsumer
构造方法详细信息

ImageFilter

public ImageFilter()
方法详细信息

getFilterInstance

public ImageFilter getFilterInstance(ImageConsumer ic)
返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。默认的实现只是复制此对象。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

参数：
ic - 指定的 ImageConsumer
返回：
用于为指定 ImageConsumer 执行过滤的 ImageFilter。

setDimensions

public void setDimensions(int width,
                          int height)
过滤 ImageConsumer 接口的 setDimensions 方法中所提供的信息。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

指定者：
接口 ImageConsumer 中的 setDimensions
参数：
width - 源图像的宽度
height - 源图像的高度
另请参见：
ImageConsumer.setDimensions(int, int)

setProperties

public void setProperties(Hashtable<?,?> props)
添加一个属性，来指示已通过的过滤器流，并在这之后从源对象传递这些属性。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

指定者：
接口 ImageConsumer 中的 setProperties
参数：
props - 来自源对象的属性
抛出：
NullPointerException - 如果 props 为 null

setColorModel

public void setColorModel(ColorModel model)
过滤 ImageConsumer 接口的 setColorModel 方法中所提供的信息。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

指定者：
接口 ImageConsumer 中的 setColorModel
参数：
model - 指定的 ColorModel
另请参见：
ImageConsumer.setColorModel(java.awt.image.ColorModel)

setHints

public void setHints(int hints)
过滤 ImageConsumer 接口的 setHints 方法中所提供的信息。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

指定者：
接口 ImageConsumer 中的 setHints
参数：
hints - ImageConsumer 用于处理像素的提示集合
另请参见：
ImageConsumer.setHints(int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以 byte 数组为参数。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以整数数组为参数。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

imageComplete

public void imageComplete(int status)
过滤 ImageConsumer 接口的 imageComplete 方法中所提供的信息。

注：此方法由其像素正在被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能影响过滤操作。

指定者：
接口 ImageConsumer 中的 imageComplete
参数：
status - 图像加载的状态
另请参见：
ImageConsumer.imageComplete(int)

resendTopDownLeftRight

public void resendTopDownLeftRight(ImageProducer ip)
响应来自 ImageConsumer 的一个按 TopDownLeftRight (TDLR) 顺序将像素数据重新发送的请求。当由此 ImageFilter 的某个实例所送入数据的 ImageConsumer 请求按 TDLR 顺序重新发送数据时，FilteredImageSource 就调用 ImageFilter 的此方法。

ImageFilter 子类不一定重写此方法，这取决于它是否可以以及如何以 TDLR 顺序发送数据。有三种可能的响应方式：

  • 不重写此方法。这使得该子类使用默认的实现，即将这一请求转发到指定的 ImageProducer，而这一 ImageProducer 把这一过滤器当作请求的 ImageConsumer。如果过滤器可以确定其上游生产者对象以 TDLR 顺序发送像素，那么它也将以 TDLR 顺序转发像素，那么该行为是合适的。
  • 重写该方法，只是简单地发送数据。如果过滤器可以自行处理请求（例如，如果生成的像素已经保存在某类缓冲区中），则此行为是合适的。
  • 重写此方法，不执行任何操作。如果过滤器无法以 TDLR 顺序生成过滤数据，则此行为是合适的。

参数：
ip - 为此过滤器实例送入数据的 ImageProducer，必要时也可是应该将请求转发到的 ImageProducer
抛出：
NullPointerException - 如果 ip 为 null
另请参见：
ImageProducer.requestTopDownLeftRightResend(java.awt.image.ImageConsumer)

clone

public Object clone()
复制此对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageObserver (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 ImageObserver

所有已知实现类：
AbstractButton, AbstractColorChooserPanel, Applet, BasicArrowButton, BasicComboBoxRenderer, BasicComboBoxRenderer.UIResource, BasicComboPopup, BasicInternalFrameTitlePane, BasicInternalFrameTitlePane.SystemMenuBar, BasicSplitPaneDivider, BasicToolBarUI.DragWindow, Box, Box.Filler, Button, Canvas, CellRendererPane, Checkbox, Choice, Component, Container, DefaultListCellRenderer, DefaultListCellRenderer.UIResource, DefaultTableCellRenderer, DefaultTableCellRenderer.UIResource, DefaultTreeCellEditor.DefaultTextField, DefaultTreeCellEditor.EditorContainer, DefaultTreeCellRenderer, Dialog, FileDialog, Frame, JApplet, JButton, JCheckBox, JCheckBoxMenuItem, JColorChooser, JComboBox, JComponent, JDesktopPane, JDialog, JEditorPane, JFileChooser, JFormattedTextField, JFrame, JInternalFrame, JInternalFrame.JDesktopIcon, JLabel, JLayeredPane, JList, JMenu, JMenuBar, JMenuItem, JOptionPane, JPanel, JPasswordField, JPopupMenu, JPopupMenu.Separator, JProgressBar, JRadioButton, JRadioButtonMenuItem, JRootPane, JScrollBar, JScrollPane, JScrollPane.ScrollBar, JSeparator, JSlider, JSpinner, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, JSplitPane, JTabbedPane, JTable, JTableHeader, JTextArea, JTextComponent, JTextField, JTextPane, JToggleButton, JToolBar, JToolBar.Separator, JToolTip, JTree, JViewport, JWindow, Label, List, MetalComboBoxButton, MetalComboBoxUI.MetalComboPopup, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer, MetalInternalFrameTitlePane, MetalScrollButton, Panel, Scrollbar, ScrollPane, TextArea, TextComponent, TextField, Window
public interface ImageObserver

用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

字段摘要
static int | ABORT imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像在生成完成前即已中止。
static int | ALLBITS imageUpdate 的 infoflags 参数中的此标志指示现在已完成了一幅以前绘制的静态图像，并且可以其最终形式再次绘制它。
static int | ERROR imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像遇到了错误。
static int | FRAMEBITS imageUpdate 的 infoflags 参数中的此标志指示多帧图像（以前绘制的）的另一个完整帧现在可以再次绘制。
static int | HEIGHT imageUpdate 的 infoflags 参数中的此标志指示基本图像的高度现在可用，并且可从 height 参数中获取此高度到 imageUpdate 回调方法。
static int | PROPERTIES imageUpdate 的 infoflags 参数中的此标志指示该图像的属性现在可用。
static int | SOMEBITS imageUpdate 的 infoflags 参数中的此标志指示已提供了绘制图像缩放变体所需的更多像素。
static int | WIDTH imageUpdate 的 infoflags 参数中的此标志指示基本图像的宽度现在可用，并且可从 width 参数中获取此宽度到 imageUpdate 回调方法。
方法摘要
 boolean imageUpdate(Image img, int infoflags, int x, int y, int width, int height)
当以前使用异步接口所请求的图像的信息变得可用时就调用此方法。

字段详细信息

WIDTH

static final int WIDTH
imageUpdate 的 infoflags 参数中的此标志指示基本图像的宽度现在可用，并且可从 width 参数中获取此宽度到 imageUpdate 回调方法。

另请参见：
Image.getWidth(java.awt.image.ImageObserver), imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值

HEIGHT

static final int HEIGHT
imageUpdate 的 infoflags 参数中的此标志指示基本图像的高度现在可用，并且可从 height 参数中获取此高度到 imageUpdate 回调方法。

另请参见：
Image.getHeight(java.awt.image.ImageObserver), imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值

PROPERTIES

static final int PROPERTIES
imageUpdate 的 infoflags 参数中的此标志指示该图像的属性现在可用。

另请参见：
Image.getProperty(java.lang.String, java.awt.image.ImageObserver), imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值

SOMEBITS

static final int SOMEBITS
imageUpdate 的 infoflags 参数中的此标志指示已提供了绘制图像缩放变体所需的更多像素。可从 x、y、width 和 height 参数中获取新像素的边界框到 imageUpdate 回调方法。

另请参见：
Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver), imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值

FRAMEBITS

static final int FRAMEBITS
imageUpdate 的 infoflags 参数中的此标志指示多帧图像（以前绘制的）的另一个完整帧现在可以再次绘制。应该忽略 imageUpdate 回调方法的 x、y、width 和 height 参数。

另请参见：
Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver), imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值

ALLBITS

static final int ALLBITS
imageUpdate 的 infoflags 参数中的此标志指示现在已完成了一幅以前绘制的静态图像，并且可以其最终形式再次绘制它。应该忽略 imageUpdate 回调方法的 x、y、width 和 height 参数。

另请参见：
Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver), imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值

ERROR

static final int ERROR
imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像遇到了错误。没有更多信息可用，并且图像绘制将失败。出于方便的考虑，同时还将指定 ABORT 标志，以指示图像生成已中止。

另请参见：
imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值

ABORT

static final int ABORT
imageUpdate 的 infoflags 参数中的此标志指示被异步跟踪的图像在生成完成前即已中止。在没有进一步的动作以触发另一个图像生成序列的情况下，没有更多可用信息。如果在此图像更新中没有设置 ERROR 标志，则访问图像中的任何数据都会再次重新开始图像的生成（可能是从头开始）。

另请参见：
imageUpdate(java.awt.Image, int, int, int, int, int), 常量字段值
方法详细信息

imageUpdate

boolean imageUpdate(Image img,
                    int infoflags,
                    int x,
                    int y,
                    int width,
                    int height)
当以前使用异步接口所请求的图像的信息变得可用时就调用此方法。异步接口是将 ImageObserver 对象作为参数的方法调用，如 getWidth(ImageObserver) 和 drawImage(img, x, y, ImageObserver)。这些方法要么将调用者注册为对有关总体图像本身的信息感兴趣（对于 getWidth(ImageObserver)），要么注册为对有关图像输出版本的信息感兴趣（对于调用 drawImage(img, x, y, [w, h,] ImageObserver)）。

如果需要进一步的更新，则此方法应该返回 true，如果已获得所需的信息，则应返回 false。使用 img 参数传入所跟踪的图像。组合各种常量即可形成 infoflags 参数，指示哪种图像信息现在可用。对 x、y、width 和 height 参数的解释取决于 infoflags 参数的内容。

infoflags 参数应该是对下列标志按位进行 OR 运算后的结果：WIDTH、HEIGHT、PROPERTIES、SOMEBITS、FRAMEBITS、ALLBITS、ERROR、ABORT。

参数：
img - 正在观察的图像。
infoflags - 下列标志按位 OR 运算后的结果：WIDTH、HEIGHT、PROPERTIES、SOMEBITS、FRAMEBITS、ALLBITS、ERROR、ABORT。
x - x 坐标。
y - y 坐标。
width - 宽度。
height - 高度。
返回：
如果 infoflags 指示已完全加载了图像，则返回 false；否则返回 true。
另请参见：
WIDTH, HEIGHT, PROPERTIES, SOMEBITS, FRAMEBITS, ALLBITS, ERROR, ABORT, Image.getWidth(java.awt.image.ImageObserver), Image.getHeight(java.awt.image.ImageObserver), Graphics.drawImage(java.awt.Image, int, int, java.awt.image.ImageObserver)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageProducer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 ImageProducer

所有已知实现类：
FilteredImageSource, MemoryImageSource, RenderableImageProducer
public interface ImageProducer

可为 Image 生成图像数据的对象的接口。每幅图像都包含一个用于在需要时（例如在缩放 Image 的新大小时，或者在请求 Image 的宽度或高度时）重构图像的 ImageProducer。

另请参见：
ImageConsumer

方法摘要
void | addConsumer(ImageConsumer ic) 为了在稍后的 Image 重构期间访问图像数据，向 ImageProducer 注册一个 ImageConsumer。
boolean | isConsumer(ImageConsumer ic) 确定指定的 ImageConsumer 对象目前是否已向此 ImageProducer 注册为其使用者之一。
void | removeConsumer(ImageConsumer ic) 从目前已注册以接收图像数据的使用者列表中移除指定的 ImageConsumer 对象。
void | requestTopDownLeftRightResend(ImageConsumer ic) 代表 ImageConsumer 请求 ImageProducer 尝试再次以 TOPDOWNLEFTRIGHT 的顺序重新发送图像数据，从而可以使用依赖于按顺序接收像素的高质量转换算法以生成更佳的图像输出。
void | startProduction(ImageConsumer ic) 将指定的 ImageConsumer 对象注册为使用者，并立即开始图像数据的重构，然后这些图像数据将传递到此使用者和已经向该生产者注册的所有其他使用者。

方法详细信息

addConsumer

void addConsumer(ImageConsumer ic)
为了在稍后的 Image 重构期间访问图像数据，向 ImageProducer 注册一个 ImageConsumer。ImageProducer 可能自行决定是立即开始使用 ImageConsumer 接口向使用者传递图像数据，还是通过调用 startProduction 方法触发下一个可用图像的重构。

参数：
ic - 指定的 ImageConsumer
另请参见：
startProduction(java.awt.image.ImageConsumer)

isConsumer

boolean isConsumer(ImageConsumer ic)
确定指定的 ImageConsumer 对象目前是否已向此 ImageProducer 注册为其使用者之一。

参数：
ic - 指定的 ImageConsumer
返回：
如果指定的 ImageConsumer 已向此 ImageProducer 注册，则返回 true；否则返回 false。

removeConsumer

void removeConsumer(ImageConsumer ic)
从目前已注册以接收图像数据的使用者列表中移除指定的 ImageConsumer 对象。移除目前尚未注册的使用者不被认为是错误。一旦移除使用者后，ImageProducer 就应停止向此使用者发送数据。

参数：
ic - 指定的 ImageConsumer

startProduction

void startProduction(ImageConsumer ic)
将指定的 ImageConsumer 对象注册为使用者，并立即开始图像数据的重构，然后这些图像数据将传递到此使用者和已经向该生产者注册的所有其他使用者。此方法与 addConsumer 方法不同，因为它应该尽快触发图像数据的重构。

参数：
ic - 指定的 ImageConsumer
另请参见：
addConsumer(java.awt.image.ImageConsumer)

requestTopDownLeftRightResend

void requestTopDownLeftRightResend(ImageConsumer ic)
代表 ImageConsumer 请求 ImageProducer 尝试再次以 TOPDOWNLEFTRIGHT 的顺序重新发送图像数据，从而可以使用依赖于按顺序接收像素的高质量转换算法以生成更佳的图像输出。如果 ImageProducer 无法按该顺序重新发送数据，则它可以忽略此调用。如果可以重新发送数据，则 ImageProducer 应该进行响应，方法是执行下列最小的 ImageConsumer 方法调用集：
        ic.setHints(TOPDOWNLEFTRIGHT | < otherhints >);
        ic.setPixels(...);      // As many times as needed
        ic.imageComplete();

参数：
ic - 指定的 ImageConsumer
另请参见：
ImageConsumer.setHints(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImagingOpException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ImagingOpException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.awt.image.ImagingOpException
所有已实现的接口：
Serializable
public class ImagingOpException
extends RuntimeException

如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。

另请参见：
序列化表格

构造方法摘要
ImagingOpException(String s)
构造带指定消息的 ImagingOpException 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ImagingOpException

public ImagingOpException(String s)
构造带指定消息的 ImagingOpException 对象。

参数：
s - 抛出 ImagingOpException 时要生成的消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndexColorModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 IndexColorModel

java.lang.Object
    继承者  java.awt.image.ColorModel
        继承者  java.awt.image.IndexColorModel
所有已实现的接口：
Transparency
public class IndexColorModel
extends ColorModel

IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。colormap 指定了对应于每个索引的红色、绿色、蓝色和可选的 alpha 分量。在 colormap 中，所有分量都以 8 位无符号整数值表示。某些构造方法允许调用者在 colormap 中指定“空洞”：通过 BigInteger 对象中的位集指示哪些 colormap 项是有效的，以及哪些项表示不可用的颜色。此颜色模型与 X11 PseudoColor 可视化模型类似。

某些构造方法还提供了为 colormap 中的每个像素指定 alpha 分量的方法，而其他构造方法则要么不提供这种方法，要么在某些情况中使用一个标志来指示 colormap 数据是否包含 alpha 值。如果未向构造方法提供 alpha 值，则将为每个条目假定一个不透明的 alpha 分量 (alpha = 1.0)。无论为像素值提供或假定使用何种 alpha 分量，都可以提供一个指示该像素完全透明的可选透明像素值。注意，IndexColorModel 对象 colormap 中的颜色分量不会预乘 alpha 分量。

确定 IndexColorModel 对象透明度的方式如下：检查 colormap 中各颜色的 alpha 分量，并在考虑可选的 alpha 值和所有指定的透明索引后选择最具体的值。只有在 colormap 中的所有有效颜色都为不透明，并且不存在有效的透明像素时，透明度值才为 Transparency.OPAQUE。如果 colormap 中的所有有效颜色要么是完全不透明的 (alpha = 1.0)，要么是完全透明的 (alpha = 0.0)（通常在指定了有效透明像素时出现该情况），则透明值为 Transparency.BITMASK。否则透明值将为 Transparency.TRANSLUCENT，指示有效颜色具有的 alpha 分量既不是完全透明的，也不是完全不透明的 (0.0 < alpha < 1.0)。

如果 IndexColorModel 对象的透明值是 Transparency.OPAQUE，则 hasAlpha 和 getNumComponents 方法（均继承自 ColorModel）分别返回 false 和 3。对于所有其他透明度值，hasAlpha 返回 true，getNumComponents 返回 4。

用于 colormap 中索引的那些值取自像素表示形式的最低有效 n 位，其中 n 基于构造方法中指定的像素大小。对于小于 8 位的像素大小，n 向上舍入为 2 的次幂（3 变为 4，5、6 和 7 则变为 8）。对于介于 8 和 16 位之间的像素大小，n 就等于像素大小。大于 16 位的像素大小不受此类的支持。在像素表示形式中，超过 n 的高位字节将被忽略。大于或等于映射大小、但小于 2n 的索引值是未定义的，并对所有颜色和 alpha 组件返回 0。

对于那些使用 transferType 类型基本数组像素表示形式的方法，数组的长度总是一。支持的传输类型有 DataBuffer.TYPE_BYTE 和 DataBuffer.TYPE_USHORT。因为总是能以单个 int 值表示此类使用的像素值，所以单个 int 像素表示形式对于此类的所有对象都是有效的。因此，使用这种表示形式的方法不会因无效的像素值而抛出 IllegalArgumentException。

此类中的很多方法都声明为 final。这样做的原因是底层本机图形代码做出了有关布局和此类操作的假设，并且这些假设反映在标记为 final 的方法实现中。用户可以出于其他原因子类化此类，但是无法重写或修改这些方法的行为。

另请参见：
ColorModel, ColorSpace, DataBuffer

字段摘要
从类 java.awt.image.ColorModel 继承的字段
pixel_bits, transferType
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
IndexColorModel(int bits, int size, byte[] r, byte[] g, byte[] b)
根据指定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。
IndexColorModel(int bits, int size, byte[] r, byte[] g, byte[] b, byte[] a)
根据给定的红色、绿色、蓝色和 alpha 分量数组构造一个 IndexColorModel。
IndexColorModel(int bits, int size, byte[] r, byte[] g, byte[] b, int trans)
根据给定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。
IndexColorModel(int bits, int size, byte[] cmap, int start, boolean hasalpha)
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。
IndexColorModel(int bits, int size, byte[] cmap, int start, boolean hasalpha, int trans)
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。
IndexColorModel(int bits, int size, int[] cmap, int start, boolean hasalpha, int trans, int transferType)
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和可选 alpha 分量构成。
IndexColorModel(int bits, int size, int[] cmap, int start, int transferType, BigInteger validBits)
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和 alpha 分量构成。
方法摘要
BufferedImage | convertToIntDiscrete(Raster raster, boolean forceARGB) 返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。
SampleModel | createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
WritableRaster | createCompatibleWritableRaster(int w, int h) 创建一个具有指定宽度和高度、数据布局 (SampleModel) 与此 ColorModel 兼容的 WritableRaster。
void | finalize() 不再引用此 ColorModel 后，释放与此 ColorModel 关联的系统资源。
int | getAlpha(int pixel) 返回指定像素的 alpha 分量，该值为 0 到 255。
void | getAlphas(byte[] a) 将 alpha 透明度分量数组复制到指定的数组中。
int | getBlue(int pixel) 返回指定像素的蓝色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
void | getBlues(byte[] b) 将蓝色分量数组复制到指定的数组中。
int[] | getComponents(int pixel, int[] components, int offset) 返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。
int[] | getComponents(Object pixel, int[] components, int offset) 返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。
int[] | getComponentSize() 返回包含各个颜色/alpha 分量位数的数组。
int | getDataElement(int[] components, int offset) 在给定非标准化颜色/alpha 分量数组的情况下，以 int 形式返回此 ColorModel 中的像素值。
Object | getDataElements(int[] components, int offset, Object pixel) 在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。
Object | getDataElements(int rgb, Object pixel) 根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。
int | getGreen(int pixel) 返回指定像素的绿色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
void | getGreens(byte[] g) 将绿色分量数组复制到指定的数组中。
int | getMapSize() 返回此 IndexColorModel 中颜色/alpha 分量数组的大小。
int | getRed(int pixel) 返回指定像素的红色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。
void | getReds(byte[] r) 将红色分量数组复制到指定的数组中。
int | getRGB(int pixel) 以默认 RGB 颜色模型格式返回像素的颜色/alpha 分量。
void | getRGBs(int[] rgb) 将颜色和 alpha 分量数组中每个索引的数据转换成默认 RGB ColorModel 格式的 int 值，并将得到的 32 位 ARGB 值复制到指定数组中。
int | getTransparency() 返回透明度。
int | getTransparentPixel() 返回此 IndexColorModel 中透明像素的索引；如果没有 alpha 值为 0 的像素，则返回 -1。
BigInteger | getValidPixels() 返回一个指示 colormap 中有效/无效像素的 BigInteger。
boolean | isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true；如果不与此 ColorModel 兼容，则返回 false。
boolean | isCompatibleSampleModel(SampleModel sm) 检查指定的 SampleModel 是否与此 ColorModel 兼容。
boolean | isValid() 返回所有像素是否有效。
boolean | isValid(int pixel) 返回像素是否有效。
String | toString() 返回此 ColorModel 对象内容的 String 表示形式。
从类 java.awt.image.ColorModel 继承的方法
coerceData, equals, getAlpha, getAlphaRaster, getBlue, getColorSpace, getComponentSize, getDataElement, getDataElements, getGreen, getNormalizedComponents, getNormalizedComponents, getNumColorComponents, getNumComponents, getPixelSize, getRed, getRGB, getRGBdefault, getTransferType, getUnnormalizedComponents, hasAlpha, hashCode, isAlphaPremultiplied
从类 java.lang.Object 继承的方法
clone, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

IndexColorModel

public IndexColorModel(int bits,
                       int size,
                       byte[] r,
                       byte[] g,
                       byte[] b)
根据指定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。此颜色模型所描述的像素都具有非标准化的 255（标准化是 1.0）alpha 分量，这意味着这些像素是完全不透明的。所有指定颜色分量的数组都必须至少具有指定的条目数。ColorSpace 是默认的 sRGB 空间。由于此构造方法的所有参数中都没有 alpha 信息，所以透明度值总是为 Transparency.OPAQUE。传输类型是 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 中能够保存单个像素的最小值。

参数：
bits - 每个像素占用的位数
size - 颜色分量数组的大小
r - 红色分量数组
g - 绿色分量数组
b - 蓝色分量数组
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 16
IllegalArgumentException - 如果 size 小于 1

IndexColorModel

public IndexColorModel(int bits,
                       int size,
                       byte[] r,
                       byte[] g,
                       byte[] b,
                       int trans)
根据给定的红色、绿色和蓝色分量数组构造一个 IndexColorModel。此颜色模型所描述的像素都具有非标准化的 255（标准化是 1.0）alpha 分量，这意味着这些像素是完全不透明的，但指示呈现为透明的像素除外。所有指定颜色分量的数组都必须至少具有指定的条目数。ColorSpace 是默认的 sRGB 空间。根据参数的不同，透明度值可能是 Transparency.OPAQUE 或 Transparency.BITMASK，正如上文类描述中所指定的。传输类型是能够保存单个像素的 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 的最小值。

参数：
bits - 每个像素占用的位数
size - 颜色分量数组的大小
r - 红色分量数组
g - 绿色分量数组
b - 蓝色分量数组
trans - 透明像素的索引
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 16
IllegalArgumentException - 如果 size 小于 1

IndexColorModel

public IndexColorModel(int bits,
                       int size,
                       byte[] r,
                       byte[] g,
                       byte[] b,
                       byte[] a)
根据给定的红色、绿色、蓝色和 alpha 分量数组构造一个 IndexColorModel。所有指定分量的数组都必须至少具有指定的条目数。ColorSpace 是默认的 sRGB 空间。根据参数的不同，透明度值可能是 Transparency.OPAQUE、Transparency.BITMASK 或 Transparency.TRANSLUCENT，正如上文类描述中所指定的。传输类型是能够保存单个像素的 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 的最小值。

参数：
bits - 每个像素占用的位数
size - 颜色分量数组的大小
r - 红色分量数组
g - 绿色分量数组
b - 蓝色分量数组
a - alpha 值分量数组
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 16
IllegalArgumentException - 如果 size 小于 1

IndexColorModel

public IndexColorModel(int bits,
                       int size,
                       byte[] cmap,
                       int start,
                       boolean hasalpha)
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。该数组中必须具有足够的值，以填充具有指定大小的所有所需分量数组。ColorSpace 是默认的 sRGB 空间。根据参数的不同，透明度值可能是 Transparency.OPAQUE、Transparency.BITMASK 或 Transparency.TRANSLUCENT，正如上文类描述中所指定的。传输类型是能够保存单个像素的 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 的最小值。

参数：
bits - 每个像素占用的位数
size - 颜色分量数组的大小
cmap - 颜色分量数组
start - 第一个颜色分量的起始偏移量
hasalpha - 指示 cmap 数组中是否包含 alpha 值
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 16
IllegalArgumentException - 如果 size 小于 1

IndexColorModel

public IndexColorModel(int bits,
                       int size,
                       byte[] cmap,
                       int start,
                       boolean hasalpha,
                       int trans)
根据交错存取红色、绿色、蓝色和可选 alpha 分量的单个数组构造一个 IndexColorModel。指定的透明索引表示完全透明的像素，无论为其指定的 alpha 值是什么。该数组中必须具有足够的值，以填充具有指定大小的所有所需分量数组。ColorSpace 是默认的 sRGB 空间。根据参数的不同，透明度值可能是 Transparency.OPAQUE、Transparency.BITMASK 或 Transparency.TRANSLUCENT，正如上文类描述中所指定的。传输类型是能够保存单个像素的 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 的最小值。

参数：
bits - 每个像素占用的位数
size - 颜色分量数组的大小
cmap - 颜色分量数组
start - 第一个颜色分量的起始偏移量
hasalpha - 指示 cmap 数组中是否包含 alpha 值
trans - 完全透明像素的索引
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 16
IllegalArgumentException - 如果 size 小于 1

IndexColorModel

public IndexColorModel(int bits,
                       int size,
                       int[] cmap,
                       int start,
                       boolean hasalpha,
                       int trans,
                       int transferType)
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和可选 alpha 分量构成。指定的透明索引表示完全透明的像素，无论为其指定的 alpha 值是什么。该数组中必须具有足够的值，以填充具有指定大小的所有所需分量数组。ColorSpace 是默认的 sRGB 空间。根据参数的不同，透明度值可能是 Transparency.OPAQUE、Transparency.BITMASK 或 Transparency.TRANSLUCENT，正如上文类描述中所指定的。

参数：
bits - 每个像素占用的位数
size - 颜色分量数组的大小
cmap - 颜色分量数组
start - 第一个颜色分量的起始偏移量
hasalpha - 指示 cmap 数组中是否包含 alpha 值
trans - 完全透明像素的索引
transferType - 用于表示像素值的数组数据类型。该数据类型必须是 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT。
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 16
IllegalArgumentException - 如果 size 小于 1
IllegalArgumentException - 如果 transferType 不是 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 之一

IndexColorModel

public IndexColorModel(int bits,
                       int size,
                       int[] cmap,
                       int start,
                       int transferType,
                       BigInteger validBits)
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和 alpha 分量构成。该数组中必须具有足够的值，以填充具有指定大小的所有所需分量数组。ColorSpace 是默认的 sRGB 空间。根据参数的不同，透明度值可能是 Transparency.OPAQUE、Transparency.BITMASK 或 Transparency.TRANSLUCENT，正如上文类描述中所指定的。该数据类型必须是 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 之一。BigInteger 对象指定了 cmap 数组中的有效/无效像素。如果设置了某个索引处的 BigInteger 值，则该像素是有效的；如果未设置该索引处的 BigInteger 位，则该像素是无效的。

参数：
bits - 每个像素占用的位数
size - 颜色分量数组的大小
cmap - 颜色分量数组
start - 第一个颜色分量的起始偏移量
transferType - 指定的数据类型
validBits - 一个 BigInteger 对象。如果设置了 BigInteger 中的某个位，则该索引处的像素是有效的。如果未设置该位，则认为该索引处的像素无效。如果为 null，则所有像素都是有效的。只考虑从 0 到 colormap 大小的所有位。
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 16
IllegalArgumentException - 如果 size 小于 1
IllegalArgumentException - 如果 transferType 不是 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT 之一
从以下版本开始：
1.3
方法详细信息

getTransparency

public int getTransparency()
返回透明度。返回 OPAQUE、BITMASK 或 TRANSLUCENT

指定者：
接口 Transparency 中的 getTransparency
覆盖：
类 ColorModel 中的 getTransparency
返回：
此 IndexColorModel 的透明度值
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT

getComponentSize

public int[] getComponentSize()
返回包含各个颜色/alpha 分量位数的数组。该数组包含颜色分量的顺序是红色、绿色、蓝色，最后是 alpha 分量（如果存在）。

覆盖：
类 ColorModel 中的 getComponentSize
返回：
包含此 IndexColorModel 的各个颜色和 alpha 分量位数的数组

getMapSize

public final int getMapSize()
返回此 IndexColorModel 中颜色/alpha 分量数组的大小。

返回：
颜色和 alpha 分量数组的大小。

getTransparentPixel

public final int getTransparentPixel()
返回此 IndexColorModel 中透明像素的索引；如果没有 alpha 值为 0 的像素，则返回 -1。如果通过像素的索引在某个构造方法中显式地指定了透明像素，则优先返回该像素，否则可能返回任何正好是完全透明像素的索引。

返回：
此 IndexColorModel 对象中透明像素的索引；如果没有这样的像素，则为 -1

getReds

public final void getReds(byte[] r)
将红色分量数组复制到指定的数组中。只写入 getMapSize 指定的初始数组条目。

参数：
r - 指定的数组，红色分量数组元素要复制到该数组中

getGreens

public final void getGreens(byte[] g)
将绿色分量数组复制到指定的数组中。只写入 getMapSize 指定的初始数组条目。

参数：
g - 指定的数组，绿色分量数组元素要复制到该数组中

getBlues

public final void getBlues(byte[] b)
将蓝色分量数组复制到指定的数组中。只写入 getMapSize 指定的初始数组条目。

参数：
b - 指定的数组，蓝色分量数组元素要复制到该数组中

getAlphas

public final void getAlphas(byte[] a)
将 alpha 透明度分量数组复制到指定的数组中。只写入 getMapSize 指定的初始数组条目。

参数：
a - 指定的数组，alpha 分量数组元素要复制到该数组中

getRGBs

public final void getRGBs(int[] rgb)
将颜色和 alpha 分量数组中每个索引的数据转换成默认 RGB ColorModel 格式的 int 值，并将得到的 32 位 ARGB 值复制到指定数组中。只写入 getMapSize 指定的初始数组条目。

参数：
rgb - 指定的数组，从颜色和 alpha 分量数组转换得到的 ARGB 值要复制到该数组中。

getRed

public final int getRed(int pixel)
返回指定像素的红色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。该像素值指定为 int 值。只有像素值的较低 n 位用于计算返回的值，正如上文类描述中所指定的。返回值是一个未预乘的值。

指定者：
类 ColorModel 中的 getRed
参数：
pixel - 指定的像素
返回：
指定像素的红色分量值

getGreen

public final int getGreen(int pixel)
返回指定像素的绿色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。该像素值指定为 int 值。只有像素值的较低 n 位用于计算返回的值，正如上文类描述中所指定的。返回值是一个未预乘的值。

指定者：
类 ColorModel 中的 getGreen
参数：
pixel - 指定的像素
返回：
指定像素的绿色分量值

getBlue

public final int getBlue(int pixel)
返回指定像素的蓝色分量，在默认的 RGB ColorSpace (sRGB) 中为 0 到 255。该像素值指定为 int 值。只有像素值的较低 n 位用于计算返回的值，正如上文类描述中所指定的。返回值是一个未预乘的值。

指定者：
类 ColorModel 中的 getBlue
参数：
pixel - 指定的像素
返回：
指定像素的蓝色分量值

getAlpha

public final int getAlpha(int pixel)
返回指定像素的 alpha 分量，该值为 0 到 255。该像素值指定为 int 值。只有像素值的较低 n 位用于计算返回的值，正如上文类描述中所指定的。

指定者：
类 ColorModel 中的 getAlpha
参数：
pixel - 指定的像素
返回：
指定像素的 alpha 分量值

getRGB

public final int getRGB(int pixel)
以默认 RGB 颜色模型格式返回像素的颜色/alpha 分量。该像素值指定为 int 值。只有像素值的较低 n 位用于计算返回的值，正如上文类描述中所指定的。返回值是一个未预乘格式的值。

覆盖：
类 ColorModel 中的 getRGB
参数：
pixel - 指定的像素
返回：
指定像素的颜色和 alpha 分量
另请参见：
ColorModel.getRGBdefault()

getDataElements

public Object getDataElements(int rgb,
                              Object pixel)
根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。然后可将此数组传递到 WritableRaster 对象的 setDataElements 方法。如果 pixel 变量为 null，则分配一个新数组。如果 pixel 不为 null，则它必须是一个 transferType 类型的基本数组；否则抛出 ClassCastException。如果 pixel 不足以保存此 ColorModel 的一个像素值，则抛出 ArrayIndexOutOfBoundsException。返回 pixel 数组。

因为可以子类化 IndexColorModel，所以子类继承此方法的实现，如果不重写子类，则在使用不受支持的 transferType 时将抛出异常。

覆盖：
类 ColorModel 中的 getDataElements
参数：
rgb - 默认 RGB 颜色模型中的整数像素表示形式
pixel - 指定的像素
返回：
表示此 IndexColorModel 中指定像素的数组。
抛出：
ClassCastException - 如果 pixel 不是 transferType 类型的基本数组
ArrayIndexOutOfBoundsException - 如果 pixel 不足以保存此 ColorModel 中的一个像素值
UnsupportedOperationException - 如果 transferType 无效
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

getComponents

public int[] getComponents(int pixel,
                           int[] components,
                           int offset)
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。该像素值指定为 int 值。如果 components 数组为 null，则分配一个包含 offset + getNumComponents() 个元素的新数组。返回 components 数组，仅在 hasAlpha 返回 true 时，该数组才包括 alpha 分量。即使从 offset 开始的 components 数组是由此方法所分配的，颜色/alpha 分量也将存储在该数组中。如果 components 数组不为 null 并且大小不足以保存从 offset 处开始的所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 ColorModel 中的 getComponents
参数：
pixel - 指定的像素
components - 接收指定像素的颜色和 alpha 分量的数组
offset - components 数组中的偏移量，从此处开始存储颜色和 alpha 分量
返回：
包含从指定偏移量处开始的指定像素的颜色和 alpha 分量的数组。
另请参见：
ColorModel.hasAlpha(), ColorModel.getNumComponents()

getComponents

public int[] getComponents(Object pixel,
                           int[] components,
                           int offset)
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。像素值由作为对象引用传入的 transferType 类型的数据元素数组指定。如果 pixel 不是 transferType 类型的基本数组，则抛出 ClassCastException。如果 pixel 大小不足以保存此 ColorModel 的一个像素值，则抛出 ArrayIndexOutOfBoundsException。如果 components 数组为 null，则分配一个包含 offset + getNumComponents() 个元素的新数组。返回 components 数组，仅在 hasAlpha 返回 true 时，该数组才包括 alpha 分量。即使从 offset 开始的 components 数组是由此方法所分配的，颜色/alpha 分量也将存储在该数组中。如果 components 数组不为 null 并且大小不足以保存从 offset 处开始的所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。

因为可以子类化 IndexColorModel，所以子类继承此方法的实现，如果不重写子类，则在使用不受支持的 transferType 时将抛出异常。

覆盖：
类 ColorModel 中的 getComponents
参数：
pixel - 指定的像素
components - 接收指定像素的颜色和 alpha 分量的数组
offset - components 数组中的索引，从此处开始存储指定像素的颜色和 alpha 分量
返回：
从指定偏移量处开始包含指定像素的颜色和 alpha 分量的数组。
抛出：
ArrayIndexOutOfBoundsException - 如果 pixel 大小不足以保存此 ColorModel 的一个像素值，或者 components 数组不为 null 并且大小不足以保存从 offset 处开始的所有颜色和 alpha 分量
ClassCastException - 如果 pixel 不是 transferType 类型的基本数组
UnsupportedOperationException - 如果 transferType 不是受支持的传送类型之一
另请参见：
ColorModel.hasAlpha(), ColorModel.getNumComponents()

getDataElement

public int getDataElement(int[] components,
                          int offset)
在给定非标准化颜色/alpha 分量数组的情况下，以 int 形式返回此 ColorModel 中的像素值。如果 components 数组大小不足以保存从 offset 处开始的所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。因为可以子类化 ColorModel，所以子类继承此方法的实现，如果不重写子类，则在使用不受支持的 transferType 时将抛出异常。

覆盖：
类 ColorModel 中的 getDataElement
参数：
components - 非标准化颜色和 alpha 分量的数组
offset - components 数组中的索引，从此处开始检索颜色和 alpha 分量
返回：
对应于指定分量的此 ColorModel 中的 int 像素值。
抛出：
ArrayIndexOutOfBoundsException - 如果 components 数组大小不足以保存从 offset 处开始的所有颜色和 alpha 分量
UnsupportedOperationException - 如果 transferType 无效

getDataElements

public Object getDataElements(int[] components,
                              int offset,
                              Object pixel)
在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。然后可将此数组传递到 WritableRaster 对象的 setDataElements 方法。如果 components 数组大小不足以保存从 offset 处开始的所有颜色和 alpha 分量，则抛出 ArrayIndexOutOfBoundsException。如果 pixel 变量为 null，则分配一个新数组。如果 pixel 不为 null，则它必须是一个 transferType 类型的基本数组；否则抛出 ClassCastException。如果 pixel 大小不足以保存此 ColorModel 的一个像素值，则抛出 ArrayIndexOutOfBoundsException。

因为可以子类化 IndexColorModel，所以子类继承此方法的实现，如果不重写子类，则在使用不受支持的 transferType 时将抛出异常。

覆盖：
类 ColorModel 中的 getDataElements
参数：
components - 非标准化颜色和 alpha 分量的数组
offset - components 中的索引，从此处开始检索颜色和 alpha 分量
pixel - 表示颜色和 alpha 分量数组的 Object
返回：
一个表示颜色和 alpha 分量数组的 Object。
抛出：
ClassCastException - 如果 pixel 不是 transferType 类型的基本数组
ArrayIndexOutOfBoundsException - 如果 pixel 大小不足以保存此 ColorModel 的一个像素值，或者 components 大小不足以保存从 offset 处开始的所有颜色和 alpha 分量
UnsupportedOperationException - 如果 transferType 不是受支持的传输类型之一
另请参见：
WritableRaster.setDataElements(int, int, java.lang.Object), SampleModel.setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer)

createCompatibleWritableRaster

public WritableRaster createCompatibleWritableRaster(int w,
                                                     int h)
创建一个具有指定宽度和高度、数据布局 (SampleModel) 与此 ColorModel 兼容的 WritableRaster。此方法只对每个像素使用 16 或更少位的颜色模型有效。

因为可以子类化 IndexColorModel，所以任何支持每像素使用多于 16 位的子类必须重写此方法。

覆盖：
类 ColorModel 中的 createCompatibleWritableRaster
参数：
w - 应用于新 WritableRaster 的宽度
h - 应用于新 WritableRaster 的高度
返回：
具有指定宽度和高度的 WritableRaster 对象。
抛出：
UnsupportedOperationException - 如果像素中的位数大于 16
另请参见：
WritableRaster, SampleModel

isCompatibleRaster

public boolean isCompatibleRaster(Raster raster)
如果 raster 与此 ColorModel 兼容，则返回 true；如果不与此 ColorModel 兼容，则返回 false。

覆盖：
类 ColorModel 中的 isCompatibleRaster
参数：
raster - 要测试兼容性的 Raster 对象
返回：
如果 raster 与此 ColorModel 兼容，则返回 true；否则返回 false。

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。

覆盖：
类 ColorModel 中的 createCompatibleSampleModel
参数：
w - 应用于新 SampleModel 的宽度
h - 应用于新 SampleModel 的高度
返回：
具有指定宽度和高度的 SampleModel 对象。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0
另请参见：
SampleModel

isCompatibleSampleModel

public boolean isCompatibleSampleModel(SampleModel sm)
检查指定的 SampleModel 是否与此 ColorModel 兼容。如果 sm 为 null，则此方法返回 false。

覆盖：
类 ColorModel 中的 isCompatibleSampleModel
参数：
sm - 指定的 SampleModel，或者为 null
返回：
如果指定的 SampleModel 与此 ColorModel 兼容，则返回 true；否则返回 false。
另请参见：
SampleModel

convertToIntDiscrete

public BufferedImage convertToIntDiscrete(Raster raster,
                                          boolean forceARGB)
返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。只有源 Raster 中每个像素值的较低 n 位用于计算返回图像中的 color/alpha 值，正如上文类描述中所指定的。如果 forceARGB 为 true，则无论此 ColorModel 是否有 alpha 分量数组或透明像素，都返回一幅 TYPE_INT_ARGB 图像。

参数：
raster - 指定的 Raster
forceARGB - 如果为 true，则返回的 BufferedImage 是 TYPE_INT_ARGB；否则是 TYPE_INT_RGB
返回：
使用指定 Raster 创建的 BufferedImage
抛出：
IllegalArgumentException - 如果 raster 参数与此 IndexColorModel 不兼容

isValid

public boolean isValid(int pixel)
返回像素是否有效。

参数：
pixel - 指定的像素值
返回：
如果 pixel 有效，则返回 true；否则返回 false。
从以下版本开始：
1.3

isValid

public boolean isValid()
返回所有像素是否有效。

返回：
如果所有像素都有效，则返回 true；否则返回 false。
从以下版本开始：
1.3

getValidPixels

public BigInteger getValidPixels()
返回一个指示 colormap 中有效/无效像素的 BigInteger。如果设置了某个位索引处的 BigInteger 值，则该位是有效的；如果未设置该索引处的 BigInteger 值，则该位是无效的。BigInteger 中惟一有效的查询范围是 0 到 colormap 的大小。

返回：
一个指示有效/无效像素的 BigInteger。
从以下版本开始：
1.3

finalize

public void finalize()
不再引用此 ColorModel 后，释放与此 ColorModel 关联的系统资源。

覆盖：
类 ColorModel 中的 finalize

toString

public String toString()
返回此 ColorModel 对象内容的 String 表示形式。

覆盖：
类 ColorModel 中的 toString
返回：
表示此 ColorModel 对象内容的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LookupOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 LookupOp

java.lang.Object
    继承者  java.awt.image.LookupOp
所有已实现的接口：
BufferedImageOp, RasterOp
public class LookupOp
extends Object
implements BufferedImageOp, RasterOp

此类实现从源到目标的查找操作。LookupTable 对象可能包含单个数组或多个数组，遵循如下限制。

对 Raster，对 band 执行查找操作。查找数组的数目可能为一，此时对所有 band 应用同一个数组，否则查找数组的数目必须等于 Source Raster 的 band 数。

对于 BufferedImage，对颜色和 alpha 分量执行查找操作。查找数组的数目可能为一，此时对所有颜色（但没有 alpha）分量应用同一个数组。否则查找数组的数目可能等于 Source 的颜色分量数，此时如果存在 alpha 分量，则不执行此分量的查找。如果这两种情况都不适用，则查找数组的数目必须等于 Source 颜色分量数加上 alpha 分量数，此时对所有颜色和 alpha 分量执行查找。这就允许多 band BufferedImage 的非一致缩放。

对于查找操作，处理具有预乘 alpha 数据的 BufferedImage 源的方式与处理没有预乘的图像的方式相同。也就是说，无论是否预乘了数据，查找都是对 BufferedImage 源的原始数据的每个 band 执行。如果需要进行到目标 ColorModel 的颜色转换，则此步骤将考虑源和目标的预乘状态。

不能使用具有 IndexColorModel 的图像。

如果在构造方法中指定了 RenderingHints 对象，则在需要颜色转换时可以使用颜色呈现提示和抖动提示。

此类允许 Source 与 Destination 相同。

另请参见：
LookupTable, RenderingHints.KEY_COLOR_RENDERING, RenderingHints.KEY_DITHERING

构造方法摘要
LookupOp(LookupTable lookup, RenderingHints hints)
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。
方法摘要
BufferedImage | createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一幅具有正确大小和 band 数的、经过检查的目标图像。
WritableRaster | createCompatibleDestRaster(Raster src) 在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。
BufferedImage | filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行查找操作。
WritableRaster | filter(Raster src, WritableRaster dst) 在 Raster 上执行查找操作。
Rectangle2D | getBounds2D(BufferedImage src) 返回过滤后的目标图像的边界框。
Rectangle2D | getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源图像中某个点的情况下，返回目标点的位置。
RenderingHints | getRenderingHints() 返回此操作的呈现提示。
LookupTable | getTable() 返回 LookupTable。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LookupOp

public LookupOp(LookupTable lookup,
                RenderingHints hints)
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。

参数：
lookup - 指定的 LookupTable
hints - 指定的 RenderingHints，或者为 null
方法详细信息

getTable

public final LookupTable getTable()
返回 LookupTable。

返回：
此 LookupOp 的 LookupTable。

filter

public final BufferedImage filter(BufferedImage src,
                                  BufferedImage dst)
对 BufferedImage 执行查找操作。如果源图像的颜色模型与目标图像的不同，则在目标图像中转换像素。如果目标图像为 null，则创建一个具有合适的 ColorModel 的 BufferedImage。如果 LookupTable 中的数组数不符合上面类注释所声明的限制，如果源图像有一个 IndexColorModel，则抛出 IllegalArgumentException。

指定者：
接口 BufferedImageOp 中的 filter
参数：
src - 要过滤的 BufferedImage
dst - 存储过滤操作结果的 BufferedImage
返回：
过滤后的 BufferedImage。
抛出：
IllegalArgumentException - 如果 LookupTable 中的数组数不符合上面类注释所声明的限制，或者源图像有一个 IndexColorModel。

filter

public final WritableRaster filter(Raster src,
                                   WritableRaster dst)
在 Raster 上执行查找操作。如果目标 Raster 为 null，则创建一个新的 Raster。如果源 Raster 和目标 Raster 的 band 数不同，或者 LookupTable 中的数组数不符合上面类注释所声明的限制，则可能抛出 IllegalArgumentException。

指定者：
接口 RasterOp 中的 filter
参数：
src - 要过滤的源 Raster
dst - 用于已过滤 src 的目标 WritableRaster
返回：
过滤后的 WritableRaster。
抛出：
IllegalArgumentException - 如果源和目标 raster 的 band 数不同，或者 LookupTable 中的数组数不符合上面类注释所声明的限制。

getBounds2D

public final Rectangle2D getBounds2D(BufferedImage src)
返回过滤后的目标图像的边界框。因为这不是一个几何操作，所以不会改变边界框。

指定者：
接口 BufferedImageOp 中的 getBounds2D
参数：
src - 要过滤的 BufferedImage
返回：
过滤后的目标图像的边界。

getBounds2D

public final Rectangle2D getBounds2D(Raster src)
返回过滤后目标 Raster 的边界框。因为这不是一个几何操作，所以不会改变边界框。

指定者：
接口 RasterOp 中的 getBounds2D
参数：
src - 要过滤的 Raster
返回：
过滤后的目标 Raster 的边界。

createCompatibleDestImage

public BufferedImage createCompatibleDestImage(BufferedImage src,
                                               ColorModel destCM)
创建一幅具有正确大小和 band 数的、经过检查的目标图像。如果 destCM 为 null，则将使用适当的 ColorModel。

指定者：
接口 BufferedImageOp 中的 createCompatibleDestImage
参数：
src - 过滤操作的源图像。
destCM - 目标的 ColorModel，可以为 null。
返回：
过滤后的目标 BufferedImage。

createCompatibleDestRaster

public WritableRaster createCompatibleDestRaster(Raster src)
在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。

指定者：
接口 RasterOp 中的 createCompatibleDestRaster
参数：
src - 要转换的 Raster
返回：
经过检查的目标 Raster。

getPoint2D

public final Point2D getPoint2D(Point2D srcPt,
                                Point2D dstPt)
在给定源图像中某个点的情况下，返回目标点的位置。如果 dstPt 不为 null，则使用它来保存返回值。因为这不是一个几何操作，所以 srcPt 将等于 dstPt。

指定者：
接口 BufferedImageOp 中的 getPoint2D
指定者：
接口 RasterOp 中的 getPoint2D
参数：
srcPt - 表示源图像中某个点的 Point2D
dstPt - 表示目标图像中位置的 Point2D
返回：
与源图像中指定点相对应的目标图像中的 Point2D。

getRenderingHints

public final RenderingHints getRenderingHints()
返回此操作的呈现提示。

指定者：
接口 BufferedImageOp 中的 getRenderingHints
指定者：
接口 RasterOp 中的 getRenderingHints
返回：
与此操作相关联的 RenderingHints 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LookupTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 LookupTable

java.lang.Object
    继承者  java.awt.image.LookupTable
直接已知子类：
ByteLookupTable, ShortLookupTable
public abstract class LookupTable
extends Object

此抽象类定义了一个查找表对象。ByteLookupTable 和 ShortLookupTable 是分别包含 byte 和 short 数据的子类。查找表包含图像的一个或多个 band（或分量）的数据数组（例如独立的 R、G 和 B 数组），还包含一个偏移量，在对数组进行索引前要从输入值中减去该偏移量。这就允许为受约束的输入提供一个小于本机数据大小的数组。如果查找表中仅有一个数组，则将其应用到所有的 band。所有数组必须具有相同的大小。

另请参见：
ByteLookupTable, ShortLookupTable, LookupOp

构造方法摘要
protected LookupTable(int offset, int numComponents)
根据分量数和查找表中的偏移量构造一个新 LookupTable。
方法摘要
int | getNumComponents() 返回查找表中的分量数。
int | getOffset() 返回偏移量。
abstract int[] | lookupPixel(int[] src, int[] dest) 返回一个像素的 int 分量数组。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LookupTable

protected LookupTable(int offset,
                      int numComponents)
根据分量数和查找表中的偏移量构造一个新 LookupTable。

参数：
offset - 在对此 LookupTable 的数据数组进行索引前，要从输入值减去的偏移量
numComponents - 此 LookupTable 中的数据数组数目
抛出：
IllegalArgumentException - 如果 offset 小于 0，或者 numComponents 小于 1
方法详细信息

getNumComponents

public int getNumComponents()
返回查找表中的分量数。

返回：
此 LookupTable 中的分量数。

getOffset

public int getOffset()
返回偏移量。

返回：
此 LookupTable 的偏移量。

lookupPixel

public abstract int[] lookupPixel(int[] src,
                                  int[] dest)
返回一个像素的 int 分量数组。dest 数组包含查找的结果并返回。如果 dest 为 null，则分配一个新数组。源和目标可以相等。

参数：
src - 一个像素的源分量数组
dest - 一个像素的目标分量数组，使用此 LookupTable 转换
返回：
一个像素的 int 分量数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryImageSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 MemoryImageSource

java.lang.Object
    继承者  java.awt.image.MemoryImageSource
所有已实现的接口：
ImageProducer
public class MemoryImageSource
extends Object
implements ImageProducer

此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。下面的示例计算了一幅 100x100 的图像，表示沿 X 轴从黑色渐变到蓝色，沿 Y 轴从黑色渐变到红色：

        int w = 100;
        int h = 100;
        int pix[] = new int[w * h];
        int index = 0;
        for (int y = 0; y < h; y++) {
            int red = (y * 255) / (h - 1);
            for (int x = 0; x < w; x++) {
                int blue = (x * 255) / (w - 1);
                pix[index++] = (255 << 24) | (red << 16) | blue;
            }
        }
        Image img = createImage(new MemoryImageSource(w, h, pix, 0, w));
MemoryImageSource 还能够管理随时间的推移而变化的内存图像，以实现动画或自定义呈现。下面的示例显示了如何设置动画源并通知数据的改变（改编自 Garth Dickie 的 MemoryAnimationSourceDemo）：

        int pixels[];
        MemoryImageSource source;

        public void init() {
            int width = 50;
            int height = 50;
            int size = width * height;
            pixels = new int[size];

            int value = getBackground().getRGB();
            for (int i = 0; i < size; i++) {
                pixels[i] = value;
            }

            source = new MemoryImageSource(width, height, pixels, 0, width);
            source.setAnimated(true);
            image = createImage(source);
        }

        public void run() {
            Thread me = Thread.currentThread( );
            me.setPriority(Thread.MIN_PRIORITY);

            while (true) {
                try {
                    thread.sleep(10);
                } catch( InterruptedException e ) {
                    return;
                }

                // Modify the values in the pixels array at (x, y, w, h)

                // Send the new data to the interested ImageConsumers
                source.newPixels(x, y, w, h);
            }
        }

另请参见：
ImageProducer

构造方法摘要
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, int[] pix, int off, int scan)
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。
方法摘要
void | addConsumer(ImageConsumer ic) 将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表。
boolean | isConsumer(ImageConsumer ic) 确定某个 ImageConsumer 目前是否处于对此图像数据感兴趣的使用者列表中。
void | newPixels() 将全部的新像素缓冲区发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。
void | newPixels(byte[] newpix, ColorModel newmodel, int offset, int scansize) 改用一个新的 byte 数组以保存此图像的像素。
void | newPixels(int[] newpix, ColorModel newmodel, int offset, int scansize) 改用一个新的 int 数组以保存此图像的像素。
void | newPixels(int x, int y, int w, int h) 将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。
void | newPixels(int x, int y, int w, int h, boolean framenotify) 将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer。
void | removeConsumer(ImageConsumer ic) 从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
void | requestTopDownLeftRightResend(ImageConsumer ic) 请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
void | setAnimated(boolean animated) 根据 animated 参数将此内存图像更改为多帧动画或单帧静态图像。
void | setFullBufferUpdates(boolean fullbuffers) 指定在像素缓冲区发生变化时，是否总是通过发送像素的完整缓冲区来更新此动画内存图像。
void | startProduction(ImageConsumer ic) 将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表中，并立即开始通过 ImageConsumer 接口传递图像数据。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MemoryImageSource

public MemoryImageSource(int w,
                         int h,
                         ColorModel cm,
                         byte[] pix,
                         int off,
                         int scan)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。

参数：
w - 像素矩形的宽度
h - 像素矩形的高度
cm - 指定的 ColorModel
pix - 一个像素数组
off - 数组中存储首个像素的偏移量
scan - 数组中一行像素到下一行像素之间的距离
另请参见：
Component.createImage(java.awt.image.ImageProducer)

MemoryImageSource

public MemoryImageSource(int w,
                         int h,
                         ColorModel cm,
                         byte[] pix,
                         int off,
                         int scan,
                         Hashtable<?,?> props)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。

参数：
w - 像素矩形的宽度
h - 像素矩形的高度
cm - 指定的 ColorModel
pix - 一个像素数组
off - 数组中存储首个像素的偏移量
scan - 数组中一行像素到下一行像素之间的距离
props - ImageProducer 用于处理图像的属性列表
另请参见：
Component.createImage(java.awt.image.ImageProducer)

MemoryImageSource

public MemoryImageSource(int w,
                         int h,
                         ColorModel cm,
                         int[] pix,
                         int off,
                         int scan)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。

参数：
w - 像素矩形的宽度
h - 像素矩形的高度
cm - 指定的 ColorModel
pix - 一个像素数组
off - 数组中存储首个像素的偏移量
scan - 数组中一行像素到下一行像素之间的距离
另请参见：
Component.createImage(java.awt.image.ImageProducer)

MemoryImageSource

public MemoryImageSource(int w,
                         int h,
                         ColorModel cm,
                         int[] pix,
                         int off,
                         int scan,
                         Hashtable<?,?> props)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。

参数：
w - 像素矩形的宽度
h - 像素矩形的高度
cm - 指定的 ColorModel
pix - 一个像素数组
off - 数组中存储首个像素的偏移量
scan - 数组中一行像素到下一行像素之间的距离
props - ImageProducer 用于处理图像的属性列表
另请参见：
Component.createImage(java.awt.image.ImageProducer)

MemoryImageSource

public MemoryImageSource(int w,
                         int h,
                         int[] pix,
                         int off,
                         int scan)
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。

参数：
w - 像素矩形的宽度
h - 像素矩形的高度
pix - 一个像素数组
off - 数组中存储首个像素的偏移量
scan - 数组中一行像素到下一行像素之间的距离
另请参见：
Component.createImage(java.awt.image.ImageProducer), ColorModel.getRGBdefault()

MemoryImageSource

public MemoryImageSource(int w,
                         int h,
                         int[] pix,
                         int off,
                         int scan,
                         Hashtable<?,?> props)
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。

参数：
w - 像素矩形的宽度
h - 像素矩形的高度
pix - 一个像素数组
off - 数组中存储首个像素的偏移量
scan - 数组中一行像素到下一行像素之间的距离
props - ImageProducer 用于处理图像的属性列表
另请参见：
Component.createImage(java.awt.image.ImageProducer), ColorModel.getRGBdefault()
方法详细信息

addConsumer

public void addConsumer(ImageConsumer ic)
将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表。

指定者：
接口 ImageProducer 中的 addConsumer
参数：
ic - 指定的 ImageConsumer
抛出：
NullPointerException - 如果指定的 ImageConsumer 为 null
另请参见：
ImageConsumer

isConsumer

public boolean isConsumer(ImageConsumer ic)
确定某个 ImageConsumer 目前是否处于对此图像数据感兴趣的使用者列表中。

指定者：
接口 ImageProducer 中的 isConsumer
参数：
ic - 指定的 ImageConsumer
返回：
如果该 ImageConsumer 处于列表中，则返回 true；否则返回 false。
另请参见：
ImageConsumer

removeConsumer

public void removeConsumer(ImageConsumer ic)
从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。

指定者：
接口 ImageProducer 中的 removeConsumer
参数：
ic - 指定的 ImageConsumer
另请参见：
ImageConsumer

startProduction

public void startProduction(ImageConsumer ic)
将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表中，并立即开始通过 ImageConsumer 接口传递图像数据。

指定者：
接口 ImageProducer 中的 startProduction
参数：
ic - 通过 ImageConsumer 接口的指定 ImageConsumer 图像数据。
另请参见：
ImageConsumer

requestTopDownLeftRightResend

public void requestTopDownLeftRightResend(ImageConsumer ic)
请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。

指定者：
接口 ImageProducer 中的 requestTopDownLeftRightResend
参数：
ic - 指定的 ImageConsumer
另请参见：
ImageConsumer

setAnimated

public void setAnimated(boolean animated)
根据 animated 参数将此内存图像更改为多帧动画或单帧静态图像。

应该在构造 MemoryImageSource 后和使用它创建图像前立即调用此方法，以确保所有的 ImageConsumer 都将接收正确的多帧数据。如果在设置此标志前将一个 ImageConsumer 添加到此 ImageProducer 中，则该 ImageConsumer 将只能看到在它连接时可用的一个像素数据快照。

参数：
animated - 如果该图像是一个多帧动画，则为 true

setFullBufferUpdates

public void setFullBufferUpdates(boolean fullbuffers)
指定在像素缓冲区发生变化时，是否总是通过发送像素的完整缓冲区来更新此动画内存图像。如果未通过 setAnimated() 方法打开 animation 标志，则忽略此标志。

应该在构造 MemoryImageSource 后和使用它创建图像前立即调用此方法，以确保所有的 ImageConsumer 都将接收正确的像素传递提示。

参数：
fullbuffers - 如果总是应该发送完整的像素缓冲区，则为 true
另请参见：
setAnimated(boolean)

newPixels

public void newPixels()
将全部的新像素缓冲区发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。仅在通过 setAnimated() 方法打开 animation 标志时，此方法才有效。

另请参见：
newPixels(int, int, int, int, boolean), ImageConsumer, setAnimated(boolean)

newPixels

public void newPixels(int x,
                      int y,
                      int w,
                      int h)
将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer，并通知这些 ImageConsumer 一个动画帧已完成。仅在通过 setAnimated() 方法打开 animation 标志时，此方法才有效。如果已使用 setFullBufferUpdates() 方法打开了全部缓冲区更新标志，则将忽略矩形参数并且始终发送整个缓冲区。

参数：
x - 要发送的像素矩形左上角的 x 坐标
y - 要发送的像素矩形左上角的 y 坐标
w - 要发送的像素矩形的宽度
h - 要发送的像素矩形的高度
另请参见：
newPixels(int, int, int, int, boolean), ImageConsumer, setAnimated(boolean), setFullBufferUpdates(boolean)

newPixels

public void newPixels(int x,
                      int y,
                      int w,
                      int h,
                      boolean framenotify)
将像素缓冲区的矩形区域发送到所有目前对此图像数据感兴趣的 ImageConsumer。如果 framenotify 参数为 true，则通知使用者一幅动画帧已完成。仅在通过 setAnimated() 方法打开 animation 标志时，此方法才有效。如果已使用 setFullBufferUpdates() 方法打开了全部缓冲区更新标志，则将忽略矩形参数并且始终发送整个缓冲区。

参数：
x - 要发送的像素矩形左上角的 x 坐标
y - 要发送的像素矩形左上角的 y 坐标
w - 要发送的像素矩形的宽度
h - 要发送的像素矩形的高度
framenotify - 如果应该向使用者发送 SINGLEFRAMEDONE 通知，则为 true
另请参见：
ImageConsumer, setAnimated(boolean), setFullBufferUpdates(boolean)

newPixels

public void newPixels(byte[] newpix,
                      ColorModel newmodel,
                      int offset,
                      int scansize)
改用一个新的 byte 数组以保存此图像的像素。如果已通过 setAnimated() 方法打开了 animation 标志，则立即将新的像素传递到所有目前对此图像数据感兴趣的 ImageConsumer。

参数：
newpix - 新的像素数组
newmodel - 指定的 ColorModel
offset - 数组中的偏移量
scansize - 数组中一行像素到下一行像素之间的距离
另请参见：
newPixels(int, int, int, int, boolean), setAnimated(boolean)

newPixels

public void newPixels(int[] newpix,
                      ColorModel newmodel,
                      int offset,
                      int scansize)
改用一个新的 int 数组以保存此图像的像素。如果已通过 setAnimated() 方法打开了 animation 标志，则立即将新的像素传递到所有目前对此图像数据感兴趣的 ImageConsumer。

参数：
newpix - 新的像素数组
newmodel - 指定的 ColorModel
offset - 数组中的偏移量
scansize - 数组中一行像素到下一行像素之间的距离
另请参见：
newPixels(int, int, int, int, boolean), setAnimated(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiPixelPackedSampleModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 MultiPixelPackedSampleModel

java.lang.Object
    继承者  java.awt.image.SampleModel
        继承者  java.awt.image.MultiPixelPackedSampleModel

public class MultiPixelPackedSampleModel
extends SampleModel

MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。像素不能跨越数据元素。数据类型可以是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT。每个像素必须是位数的 2 的次幂，像素数的 2 的次幂也必须正好能放入一个数据元素。像素位的间距等于每个像素的位数。扫描行间距在数据元素中，最后几个数据元素可以由未使用的像素填充。数据位的偏移量是从 DataBuffer 起始处到第一个像素的位偏移量，必须是像素位间距的倍数。

以下代码说明了如何从 DataBuffer data 中提取像素 x, y 的位并将像素数据存储到 dataType 类型的数据元素中：

      int dataElementSize = DataBuffer.getDataTypeSize(dataType);
      int bitnum = dataBitOffset + x*pixelBitStride;
      int element = data.getElem(y*scanlineStride + bitnum/dataElementSize);
      int shift = dataElementSize - (bitnum & (dataElementSize-1))
                  - pixelBitStride;
      int pixel = (element >> shift) & ((1 << pixelBitStride) - 1);

字段摘要
从类 java.awt.image.SampleModel 继承的字段
dataType, height, numBands, width
构造方法摘要
MultiPixelPackedSampleModel(int dataType, int w, int h, int numberOfBits)
构造一个具有指定数据类型、宽度、高度和每像素位数的 MultiPixelPackedSampleModel。
MultiPixelPackedSampleModel(int dataType, int w, int h, int numberOfBits, int scanlineStride, int dataBitOffset)
构造一个具有指定数据类型、宽度、高度、每像素位数、扫描行间距和数据位偏移量的 MultiPixelPackedSampleModel。
方法摘要
 SampleModel createCompatibleSampleModel(int w, int h)
构造一个具有指定宽度和高度的新 MultiPixelPackedSampleModel。
 DataBuffer createDataBuffer()
创建一个与此 MultiPixelPackedSampleModel 对应的 DataBuffer。
 SampleModel createSubsetSampleModel(int[] bands)
创建一个具有此 MultiPixelPackedSampleModel band 子集的新 MultiPixelPackedSampleModel。
 boolean equals(Object o)
指示其他某个对象是否与此对象“相等”。
 int getBitOffset(int x)
返回数据元素中存储扫描行第 x 个像素的偏移量(以位为单位)。
 int getDataBitOffset()
返回数据位的偏移量（以位为单位）。
 Object getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。
 int getNumDataElements()
返回通过 getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 和 setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 方法传输一个像素所需的数据元素数。
 int getOffset(int x, int y)
返回数据数组元素中像素 (x, y) 的偏移量。
 int[] getPixel(int x, int y, int[] iArray, DataBuffer data)
返回 int 数组第一个元素中的指定单个 band 像素。
 int getPixelBitStride()
返回像素位间距，以位为单位。
 int getSample(int x, int y, int b, DataBuffer data)
以 int 形式返回指定 band 中对应于 (x, y) 处像素的样本。
 int[] getSampleSize()
返回所有 band 的每样本位数。
 int getSampleSize(int band)
返回指定 band 的每样本位数。
 int getScanlineStride()
返回扫描行的间距。
 int getTransferType()
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
 int hashCode()
返回该对象的哈希码值。
 void setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
 void setPixel(int x, int y, int[] iArray, DataBuffer data)
使用输入的 int 数组设置 DataBuffer 中的某个像素。
 void setSample(int x, int y, int b, int s, DataBuffer data)
使用输入的 int，设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
从类 java.awt.image.SampleModel 继承的方法
getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getPixels, getSampleDouble, getSampleFloat, getSamples, getSamples, getSamples, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setPixels, setSample, setSample, setSamples, setSamples, setSamples
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MultiPixelPackedSampleModel

public MultiPixelPackedSampleModel(int dataType,
                                   int w,
                                   int h,
                                   int numberOfBits)
构造一个具有指定数据类型、宽度、高度和每像素位数的 MultiPixelPackedSampleModel。

参数：
dataType - 存储样本的数据类型
w - 所描述的图像数据区域的宽度，以像素为单位
h - 所描述的图像数据区域的高度，以像素为单位
numberOfBits - 每个像素的位数
抛出：
IllegalArgumentException - 如果 dataType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT

MultiPixelPackedSampleModel

public MultiPixelPackedSampleModel(int dataType,
                                   int w,
                                   int h,
                                   int numberOfBits,
                                   int scanlineStride,
                                   int dataBitOffset)
构造一个具有指定数据类型、宽度、高度、每像素位数、扫描行间距和数据位偏移量的 MultiPixelPackedSampleModel。

参数：
dataType - 存储采用的数据类型
w - 所描述的图像数据区域的宽度，以像素为单位
h - 所描述的图像数据区域的高度，以像素为单位
numberOfBits - 每个像素的位数
scanlineStride - 图像数据的行间距
dataBitOffset - 所描述的图像数据区域的数据位偏移量
抛出：
RasterFormatException - 如果每像素位数不是 2 的次幂，或者像素数的 2 的次幂不能放入一个数据元素。
IllegalArgumentException - 如果 w 或 h 不大于 0
IllegalArgumentException - 如果 dataType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT
方法详细信息

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
构造一个具有指定宽度和高度的新 MultiPixelPackedSampleModel。这个新 MultiPixelPackedSampleModel 具有与此 MultiPixelPackedSampleModel 相同的存储数据类型和每像素位数。

指定者：
类 SampleModel 中的 createCompatibleSampleModel
参数：
w - 指定的宽度
h - 指定的高度
返回：
一个 SampleModel，具有指定宽度和高度，并且具有与此 MultiPixelPackedSampleModel 相同的存储数据类型和每像素位数。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0

createDataBuffer

public DataBuffer createDataBuffer()
创建一个与此 MultiPixelPackedSampleModel 对应的 DataBuffer。该 DataBuffer 对象的数据类型和大小与此 MultiPixelPackedSampleModel 一致。DataBuffer 具有单个存储单元。

指定者：
类 SampleModel 中的 createDataBuffer
返回：
数据类型和大小与此 MultiPixelPackedSampleModel 相同的 DataBuffer。

getNumDataElements

public int getNumDataElements()
返回通过 getDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 和 setDataElements(int, int, java.lang.Object, java.awt.image.DataBuffer) 方法传输一个像素所需的数据元素数。对于 MultiPixelPackedSampleModel，该值是一。

指定者：
类 SampleModel 中的 getNumDataElements
返回：
数据元素数。
另请参见：
SampleModel.getDataElements(int, int, Object, DataBuffer),
SampleModel.getDataElements(int, int, int, int, Object, DataBuffer),
SampleModel.setDataElements(int, int, Object, DataBuffer),
SampleModel.setDataElements(int, int, int, int, Object, DataBuffer),
SampleModel.getTransferType()

getSampleSize

public int[] getSampleSize()
返回所有 band 的每样本位数。

指定者：
类 SampleModel 中的 getSampleSize
返回：
每个样本的位数。

getSampleSize

public int getSampleSize(int band)
返回指定 band 的每样本位数。

指定者：
类 SampleModel 中的 getSampleSize
参数：
band - 指定的 band
返回：
指定 band 的每样本位数。

getOffset

public int getOffset(int x,
                     int y)
返回数据数组元素中像素 (x, y) 的偏移量。

参数：
x - 指定像素的 X 坐标
y - 指定像素的 Y 坐标
返回：
指定像素的偏移量。

getBitOffset

public int getBitOffset(int x)
返回数据元素中存储扫描行第 x 个像素的偏移量(以位为单位)。此偏移量对于所有扫描行都相同。

参数：
x - 指定的像素
返回：
指定像素的位偏移量。

getScanlineStride

public int getScanlineStride()
返回扫描行的间距。

返回：
此 MultiPixelPackedSampleModel 的扫描行间距。

getPixelBitStride

public int getPixelBitStride()
返回像素位间距，以位为单位。此值与每像素位数相同。

返回：
此 MultiPixelPackedSampleModel 的 pixelBitStride。

getDataBitOffset

public int getDataBitOffset()
返回数据位的偏移量（以位为单位）。

返回：
此 MultiPixelPackedSampleModel 的 dataBitOffset。

getTransferType

public int getTransferType()
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。该 TransferType 可能与存储 DataType 相同，也可能不同。TransferType 是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之一。

覆盖：
类 SampleModel 中的 getTransferType
返回：
transfertype。
另请参见：
SampleModel.getDataElements(int, int, Object, DataBuffer),
SampleModel.getDataElements(int, int, int, int, Object, DataBuffer),
SampleModel.setDataElements(int, int, Object, DataBuffer),
SampleModel.setDataElements(int, int, int, int, Object, DataBuffer),
SampleModel.getNumDataElements(),
DataBuffer

createSubsetSampleModel

public SampleModel createSubsetSampleModel(int[] bands)
创建一个具有此 MultiPixelPackedSampleModel band 子集的新 MultiPixelPackedSampleModel。因为 MultiPixelPackedSampleModel 只有一个 band，所以 bands 参数的长度必须为 1，指示第 0 个 band。

指定者：
类 SampleModel 中的 createSubsetSampleModel
参数：
bands - 指定的 band
返回：
具有此 MultiPixelPackedSampleModel band 子集的新 SampleModel。
抛出：
RasterFormatException - 如果请求的 band 数不是 1。
IllegalArgumentException - 如果 w 或 h 不大于 0

getSample

public int getSample(int x,
                     int y,
                     int b,
                     DataBuffer data)
以 int 形式返回指定 band 中对应于 (x, y) 处像素的样本。如果坐标超出了范围，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 getSample
参数：
x - 指定像素的 X 坐标
y - 指定像素的 Y 坐标
b - 返回的 band，假定为 0
data - 包含图像数据的 DataBuffer
返回：
包含指定像素样本的指定 band
抛出：
ArrayIndexOutOfBoundException - 如果指定的坐标超出了范围。
另请参见：
setSample(int, int, int, int, DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
使用输入的 int，设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。如果坐标超出了范围，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 setSample
参数：
x - 指定像素的 X 坐标
y - 指定像素的 Y 坐标
b - 返回的 band，假定为 0
s - int 形式的输入样本
data - 存储图像数据的 DataBuffer
抛出：
ArrayIndexOutOfBoundsException - 如果坐标超出了范围。
另请参见：
getSample(int, int, int, DataBuffer)

getDataElements

public Object getDataElements(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。对于 MultiPixelPackedSampleModel，该数组有一个元素，类型为可保存单个像素的 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 中的最小值。通常，obj 作为 null 传入，从而 Object 将被自动创建，并具有正确的基本数据类型。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 MultiPixelPackedSampleModel mppsm1 描述）传输到 DataBuffer db2（其存储布局由 MultiPixelPackedSampleModel mppsm2 描述）。该传输通常比使用 getPixel 或 setPixel 更为高效。

             MultiPixelPackedSampleModel mppsm1, mppsm2;
             DataBufferInt db1, db2;
             mppsm2.setDataElements(x, y, mppsm1.getDataElements(x, y, null,
                              db1), db2);
如果两个 SampleModel 具有相同的 band 数，相应的 band 具有相同的每样本位数，并且 TransferType 也相同，则使用 getDataElements 或 setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

如果 obj 不为 null，则它应是一个 TransferType 类型的基本数组。否则将抛出 ClassCastException。如果坐标超出了范围，或者 obj 不为 null 并且其大小不足以保存该像素数据，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 getDataElements
参数：
x - 指定像素的 X 坐标
y - 指定像素的 Y 坐标
obj - 一个基本数组，像素数据将返回到该数组中；或者为 null。
data - 包含图像数据的 DataBuffer。
返回：
包含指定像素数据的 Object。
抛出：
ClassCastException - 如果 obj 不是 TransferType 类型的基本数组，或者不为 null
ArrayIndexOutOfBoundsException - 如果坐标超出了范围，或者 obj 不为 null 或其大小不足以保存该像素数据
另请参见：
setDataElements(int, int, Object, DataBuffer)

getPixel

public int[] getPixel(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
返回 int 数组第一个元素中的指定单个 band 像素。如果坐标超出了范围，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getPixel
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - 包含要返回像素的数组，或者为 null
data - 存储图像数据的 DataBuffer
返回：
包含指定像素的数组。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标超出了范围范围
另请参见：
setPixel(int, int, int[], DataBuffer)

setDataElements

public void setDataElements(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。对于 MultiPixelPackedSampleModel，只有数组的第一个元素才保存有效数据，类型必须为可以保存单个像素的 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 的最小值。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 MultiPixelPackedSampleModel mppsm1 所描述）传输到 DataBuffer db2（其存储布局由 MultiPixelPackedSampleModel mppsm2 所描述）。该传输通常比使用 getPixel 或 setPixel 更为高效。

             MultiPixelPackedSampleModel mppsm1, mppsm2;
             DataBufferInt db1, db2;
             mppsm2.setDataElements(x, y, mppsm1.getDataElements(x, y, null,
                              db1), db2);
如果两个 SampleModel 对象具有相同的 band 数，相应的 band 具有相同的每样本位数，并且 TransferType 也相同，则使用 getDataElements 或 setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

obj 必须是 TransferType 类型的基本数组。否则将抛出 ClassCastException。如果坐标超出了范围，或者 obj 大小不足以保存该像素数据，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 setDataElements
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
obj - 包含像素数据的基本数组
data - 包含图像数据的 DataBuffer
另请参见：
getDataElements(int, int, Object, DataBuffer)

setPixel

public void setPixel(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
使用输入的 int 数组设置 DataBuffer 中的某个像素。如果坐标超出了范围，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setPixel
参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - int 数组中的输入像素
data - 包含图像数据的 DataBuffer
另请参见：
getPixel(int, int, int[], DataBuffer)

equals

public boolean equals(Object o)
从类 Object 复制的描述
指示其他某个对象是否与此对象“相等”。

equals 方法在非空对象引用上实现相等关系：

  • 自反性：对于任何非空引用值 x，x.equals(x) 都应返回 true。
  • 对称性：对于任何非空引用值 x 和 y，当且仅当 y.equals(x) 返回 true 时，x.equals(y) 才应返回 true。
  • 传递性：对于任何非空引用值 x、y 和 z，如果 x.equals(y) 返回 true，并且 y.equals(z) 返回 true，那么 x.equals(z) 应返回 true。
  • 一致性：对于任何非空引用值 x 和 y，多次调用 x.equals(y) 始终返回 true 或始终返回 false，前提是对象上 equals 比较中所用的信息没有被修改。
  • 对于任何非空引用值 x，x.equals(null) 都应返回 false。

Object 类的 equals 方法实现对象上差别可能性最大的相等关系；即，对于任何非空引用值 x 和 y，当且仅当 x 和 y 引用同一个对象时，此方法才返回 true（x == y 具有值 true）。

注意：当此方法被重写时，通常有必要重写 hashCode 方法，以维护 hashCode 方法的常规协定，该协定声明相等对象必须具有相等的哈希码。

覆盖：
类 Object 中的 equals
参数：
o - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PackedColorModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 PackedColorModel

java.lang.Object
    继承者  java.awt.image.ColorModel
        继承者  java.awt.image.PackedColorModel
所有已实现的接口：
Transparency
直接已知子类：
DirectColorModel
public abstract class PackedColorModel
extends ColorModel

PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。此类可与任意 ColorSpace 一起使用。像素值中的颜色采样数必须与 ColorSpace 中的颜色分量数相同。可以有单个 alpha 采样。对于那些使用 transferType 类型的基本数组像素表示形式的方法，数组的长度总是 1。受支持的传输类型有 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 和 DataBuffer.TYPE_INT。颜色和 alpha 采样按位掩码所指示的位存储在数组的单个元素中。每个位掩码必须是连续的，并且掩码不能重叠。相同的掩码适用于其他方法使用的单个 int 像素表示形式。掩码和颜色/alpha 采样的对应关系如下：

  • 通过 0 到 getNumComponents - 1 的索引来标识各掩码。
  • 前 getNumColorComponents 个索引指颜色采样。
  • 如果存在 alpha 采样，则对应于最后一个索引。
  • 颜色索引的顺序由 ColorSpace 所指定。此顺序通常反映颜色空间类型的名称（例如 TYPE_RGB），索引 0 对应于红色、索引 1 对应于绿色、索引 2 则对应于蓝色。

出于显示或处理目的而执行的像素值到颜色/alpha 分量的转换是采样到分量的一一对应关系。PackedColorModel 通常与使用掩码来定义已打包采样的图像数据一起使用。例如，可结合使用 PackedColorModel 和 SinglePixelPackedSampleModel 来构造一个 BufferedImage。通常 SampleModel 所用的掩码与 ColorModel 使用的相同。但是如果它们不同，则根据 ColorModel 的掩码对像素数据进行颜色解释。

单个 int 的像素表示形式对于此类的所有对象都是有效的，因为总是能够以单个 int 表示此类使用的像素值。因此，使用此种表示形式的方法不会由于无效的像素值而抛出 IllegalArgumentException。

PackedColorModel 的子类是 DirectColorModel，类似于 X11 TrueColor 可视化模型类型。

另请参见：
DirectColorModel, SinglePixelPackedSampleModel, BufferedImage

字段摘要
从类 java.awt.image.ColorModel 继承的字段
pixel_bits, transferType
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
PackedColorModel(ColorSpace space, int bits, int[] colorMaskArray, int alphaMask, boolean isAlphaPremultiplied, int trans, int transferType)
根据颜色掩码数组（指定了 int 像素表示形式中哪些位包含每个颜色的采样）和 alpha 掩码来构造一个 PackedColorModel。
PackedColorModel(ColorSpace space, int bits, int rmask, int gmask, int bmask, int amask, boolean isAlphaPremultiplied, int trans, int transferType)
根据指定的掩码构造一个 PackedColorModel，该掩码指示 int 像素表示形式中的哪些位包含 alpha、红色、绿色和蓝色采样。
方法摘要
SampleModel | createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
boolean | equals(Object obj) 测试指定的 Object 是否为 PackedColorModel 的一个实例并且等于此 PackedColorModel。
WritableRaster | getAlphaRaster(WritableRaster raster) 返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。
int | getMask(int index) 返回指示像素中哪些位包含指定颜色/alpha 采样的掩码。
int[] | getMasks() 返回指示像素中的哪些位包含颜色和 alpha 采样的掩码数组。
boolean | isCompatibleSampleModel(SampleModel sm) 检查指定的 SampleModel 是否与此 ColorModel 兼容。
从类 java.awt.image.ColorModel 继承的方法
coerceData, createCompatibleWritableRaster, finalize, getAlpha, getAlpha, getBlue, getBlue, getColorSpace, getComponents, getComponents, getComponentSize, getComponentSize, getDataElement, getDataElement, getDataElements, getDataElements, getDataElements, getGreen, getGreen, getNormalizedComponents, getNormalizedComponents, getNumColorComponents, getNumComponents, getPixelSize, getRed, getRed, getRGB, getRGB, getRGBdefault, getTransferType, getTransparency, getUnnormalizedComponents, hasAlpha, hashCode, isAlphaPremultiplied, isCompatibleRaster, toString
从类 java.lang.Object 继承的方法
clone, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PackedColorModel

public PackedColorModel(ColorSpace space,
                        int bits,
                        int[] colorMaskArray,
                        int alphaMask,
                        boolean isAlphaPremultiplied,
                        int trans,
                        int transferType)
根据颜色掩码数组（指定了 int 像素表示形式中哪些位包含每个颜色的采样）和 alpha 掩码来构造一个 PackedColorModel。颜色分量在指定的 ColorSpace 中。colorMaskArray 的长度应该是 ColorSpace 中的分量数。每个掩码中的所有位必须是连续的，并且能够放入指定 int 像素表示形式的最低有效位数中。如果 alphaMask 为 0，则不存在 alpha。如果存在 alpha，则 boolean 值 isAlphaPremultiplied 指定如何解释像素值中的颜色和 alpha 采样。如果该 boolean 值为 true，则假定颜色采样已经预乘以 alpha 采样。透明度 trans 指定了此颜色模型可以表示的 alpha 值。传输类型是用于表示像素值的基本数组类型。

参数：
space - 指定的 ColorSpace
bits - 像素值中的位数
colorMaskArray - 指定掩码的数组，该掩码表示像素值中表示颜色分量的位
alphaMask - 指定像素值中表示 alpha 分量的位掩码
isAlphaPremultiplied - 如果颜色采样预乘了 alpha 采样，则为 true；否则为 false
trans - 指定可由此颜色模型表示的 alpha 值
transferType - 用于表示像素值的数组类型
抛出：
IllegalArgumentException - 如果 bits 小于 1 或大于 32

PackedColorModel

public PackedColorModel(ColorSpace space,
                        int bits,
                        int rmask,
                        int gmask,
                        int bmask,
                        int amask,
                        boolean isAlphaPremultiplied,
                        int trans,
                        int transferType)
根据指定的掩码构造一个 PackedColorModel，该掩码指示 int 像素表示形式中的哪些位包含 alpha、红色、绿色和蓝色采样。颜色分量在指定的 ColorSpace 中，并且必须是 ColorSpace.TYPE_RGB 类型。每个掩码中的所有位必须是连续的，并且能够放入指定 int 像素表示形式的最低有效位数中。如果 amask 是 0，则不存在 alpha。如果存在 alpha，则 boolean 值 isAlphaPremultiplied 指定如何解释像素值中的颜色和 alpha 采样。如果该 boolean 值为 true，则假定颜色采样已经预乘以 alpha 采样。透明度 trans 指定了此颜色模型可以表示的 alpha 值。传输类型是用于表示像素值的基本数组类型。

参数：
space - 指定的 ColorSpace
bits - 像素值中的位数
rmask - 指定像素值中表示红色分量的位掩码
gmask - 指定像素值中表示绿色分量的位掩码
bmask - 指定像素值中表示蓝色分量的位掩码
amask - 指定像素值中表示 alpha 分量的位掩码
isAlphaPremultiplied - 如果颜色采样预乘了 alpha 采样，则为 true；否则为 false
trans - 指定可由此颜色模型表示的 alpha 值
transferType - 用于表示像素值的数组类型
抛出：
IllegalArgumentException - 如果 space 不是 TYPE_RGB 空间
另请参见：
ColorSpace
方法详细信息

getMask

public final int getMask(int index)
返回指示像素中哪些位包含指定颜色/alpha 采样的掩码。对于颜色采样，index 对应于颜色空间中颜色采样名称的放置位置。因此对于 CMYK ColorSpace，index 0 对应 Cyan，而 index 1 则对应 Magenta。如果存在 alpha，则 alpha 的 index 是：
      alphaIndex = numComponents() - 1;

参数：
index - 指定的颜色或 alpha 采样
返回：
指示 int 像素表示中的哪些位包含 index 所指定的颜色或 alpha 采样的掩码。
抛出：
ArrayIndexOutOfBoundsException - 如果 index 大于此 PackedColorModel 中的分量数减 1，或者 index 小于 0

getMasks

public final int[] getMasks()
返回指示像素中的哪些位包含颜色和 alpha 采样的掩码数组。

返回：
掩码数组，指示 int 像素表示形式中的哪些位包含颜色或 alpha 采样。

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。

覆盖：
类 ColorModel 中的 createCompatibleSampleModel
参数：
w - 所描述的图像数据区域的宽度（以像素为单位）
h - 所描述的图像数据区域的高度（以像素为单位）
返回：
新创建的 SampleModel。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0
另请参见：
SampleModel

isCompatibleSampleModel

public boolean isCompatibleSampleModel(SampleModel sm)
检查指定的 SampleModel 是否与此 ColorModel 兼容。如果 sm 为 null，则此方法返回 false。

覆盖：
类 ColorModel 中的 isCompatibleSampleModel
参数：
sm - 指定的 SampleModel，或者为 null
返回：
如果指定的 SampleModel 与此 ColorModel 兼容，则返回 true；否则返回 false。
另请参见：
SampleModel

getAlphaRaster

public WritableRaster getAlphaRaster(WritableRaster raster)
返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。此方法假定与此 ColorModel 关联的 WritableRaster 对象将 alpha band（如果有）存储为图像数据的最后一个 band。如果没有与此 ColorModel 关联的、占据独立空间的 alpha 通道，则返回 null。此方法创建一个新的 WritableRaster，但是共享原来的数据数组。

覆盖：
类 ColorModel 中的 getAlphaRaster
参数：
raster - 包含图像的 WritableRaster
返回：
表示 raster 中所含图像 alpha 通道的 WritableRaster。

equals

public boolean equals(Object obj)
测试指定的 Object 是否为 PackedColorModel 的一个实例并且等于此 PackedColorModel。

覆盖：
类 ColorModel 中的 equals
参数：
obj - 要测试相等性的 Object
返回：
如果指定的 Object 是 PackedColorModel 的一个实例并且等于此 PackedColorModel，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PixelGrabber (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 PixelGrabber

java.lang.Object
    继承者  java.awt.image.PixelGrabber
所有已实现的接口：
ImageConsumer
public class PixelGrabber
extends Object
implements ImageConsumer

PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。下面是一个示例：

 public void handlesinglepixel(int x, int y, int pixel) {
        int alpha = (pixel >> 24) & 0xff;
        int red   = (pixel >> 16) & 0xff;
        int green = (pixel >>  8) & 0xff;
        int blue  = (pixel      ) & 0xff;
        // Deal with the pixel as necessary...
 }

 public void handlepixels(Image img, int x, int y, int w, int h) {
        int[] pixels = new int[w * h];
        PixelGrabber pg = new PixelGrabber(img, x, y, w, h, pixels, 0, w);
        try {
            pg.grabPixels();
        } catch (InterruptedException e) {
            System.err.println("interrupted waiting for pixels!");
            return;
        }
        if ((pg.getStatus() & ImageObserver.ABORT) != 0) {
            System.err.println("image fetch aborted or errored");
            return;
        }
        for (int j = 0; j < h; j++) {
            for (int i = 0; i < w; i++) {
                handlesinglepixel(x+i, y+j, pixels[j * w + i]);
            }
        }
 }

另请参见：
ColorModel.getRGBdefault()

字段摘要
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
PixelGrabber(Image img, int x, int y, int w, int h, boolean forceRGB)
创建一个 PixelGrabber 对象，以从指定的图像中抓取像素矩形部分 (x, y, w, h)。
PixelGrabber(Image img, int x, int y, int w, int h, int[] pix, int off, int scansize)
创建一个 PixelGrabber 对象，以从指定图像将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。
PixelGrabber(ImageProducer ip, int x, int y, int w, int h, int[] pix, int off, int scansize)
创建一个 PixelGrabber 对象，以从指定 ImageProducer 所生成的图像中将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。
方法摘要
void | abortGrabbing() 请求 PixelGrabber 中止获取图像。
ColorModel | getColorModel() 获取该数组中所存储像素的 ColorModel。
int | getHeight() 获取（调整图像高度后的）像素缓冲区的高度。
Object | getPixels() 获取像素缓冲区。
int | getStatus() 返回像素的状态。
int | getWidth() 获取（调整图像宽度后的）像素缓冲区的宽度。
boolean | grabPixels() 请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素。
boolean | grabPixels(long ms) 请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素，或者等待到用完超时期。
void | imageComplete(int status) imageComplete 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | setColorModel(ColorModel model) setColorModel 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | setDimensions(int width, int height) setDimensions 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | setHints(int hints) setHints 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | setPixels(int srcX, int srcY, int srcW, int srcH, ColorModel model, byte[] pixels, int srcOff, int srcScan) setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | setPixels(int srcX, int srcY, int srcW, int srcH, ColorModel model, int[] pixels, int srcOff, int srcScan) setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | setProperties(Hashtable<?,?> props) setProperties 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | startGrabbing() 请求 PixelGrabber 开始获取像素。
int | status() 返回像素的状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PixelGrabber

public PixelGrabber(Image img,
                    int x,
                    int y,
                    int w,
                    int h,
                    int[] pix,
                    int off,
                    int scansize)
创建一个 PixelGrabber 对象，以从指定图像将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。以默认的 RGB ColorModel 形式将像素存储到数组中。像素 (i, j)（(i, j) 处于矩形 (x, y, w, h) 内）的 RGB 数据存储在数组中的 pix[(j - y) * scansize + (i - x) + off] 位置处。

参数：
img - 从中检索像素的图像
x - 从图像中进行检索的像素矩形左上角 x 坐标，其相对于默认（未缩放）图像大小
y - 从图像中进行检索的像素矩形左上角 y 坐标
w - 要检索的像素矩形的宽度
h - 要检索的像素矩形的高度
pix - 用于保存从图像中检索的 RGB 像素的整数数组
off - 数组中存储第一个像素的偏移量
scansize - 数组中一行像素到下一行像素之间的距离
另请参见：
ColorModel.getRGBdefault()

PixelGrabber

public PixelGrabber(ImageProducer ip,
                    int x,
                    int y,
                    int w,
                    int h,
                    int[] pix,
                    int off,
                    int scansize)
创建一个 PixelGrabber 对象，以从指定 ImageProducer 所生成的图像中将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。以默认的 RGB ColorModel 形式将像素存储到数组中。像素 (i, j)（(i, j) 处于矩形 (x, y, w, h) 内）的 RGB 数据存储在数组中的 pix[(j - y) * scansize + (i - x) + off] 位置处。

参数：
ip - 生成图像的 ImageProducer，从该图像中检索像素
x - 从图像中进行检索的像素矩形左上角 x 坐标，其相对于默认（未缩放）图像大小
y - 从图像中进行检索的像素矩形左上角 y 坐标
w - 要检索的像素矩形的宽度
h - 要检索的像素矩形的高度
pix - 用于保存从图像中检索的 RGB 像素的整数数组
off - 数组中存储第一个像素的偏移量
scansize - 数组中一行像素到下一行像素之间的距离
另请参见：
ColorModel.getRGBdefault()

PixelGrabber

public PixelGrabber(Image img,
                    int x,
                    int y,
                    int w,
                    int h,
                    boolean forceRGB)
创建一个 PixelGrabber 对象，以从指定的图像中抓取像素矩形部分 (x, y, w, h)。如果每次调用 setPixels 都使用相同的 ColorModel，则像素以原 ColorModel 形式存储，否则像素将以默认 RGB ColorModel 形式存储。如果 forceRGB 参数为 true，则像素将总是以默认 RGB ColorModel 形式存储。无论是哪种情况，PixelGrabber 都会分配一个缓冲区来保存这些像素。如果 (w < 0) 或 (h < 0)，则它们默认为传递信息时保存的源数据的宽度和高度。

参数：
img - 要从中检索图像数据的图像
x - 从图像中进行检索的像素矩形左上角 x 坐标，其相对于默认（未缩放）图像大小
y - 从图像中进行检索的像素矩形左上角 y 坐标
w - 要检索的像素矩形的宽度
h - 要检索的像素矩形的高度
forceRGB - 如果总是应该将像素转换为默认 RGB ColorModel，则为 true
方法详细信息

startGrabbing

public void startGrabbing()
请求 PixelGrabber 开始获取像素。

abortGrabbing

public void abortGrabbing()
请求 PixelGrabber 中止获取图像。

grabPixels

public boolean grabPixels()
                   throws InterruptedException
请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素。

返回：
如果成功抓取了像素，则返回 true；在中止、有错误或超时的情况下返回 false
抛出：
InterruptedException - 另一个线程中断了此线程。

grabPixels

public boolean grabPixels(long ms)
                   throws InterruptedException
请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素，或者等待到用完超时期。根据 ms 值的不同，此方法的行为如下：
  • 如果 ms == 0，则等待到传递完所有像素
  • 如果 ms > 0，则传递所有像素，直到超时为止。
  • 如果 ms < 0，则若抓取了所有像素，便返回 true；否则返回 false 且不等待。

参数：
ms - 在超时前等待获取图像像素的毫秒数
返回：
如果成功抓取了像素，则返回 true；在中止、有错误或超时的情况下返回 false
抛出：
InterruptedException - 另一个线程中断了此线程。

getStatus

public int getStatus()
返回像素的状态。返回表示可用像素信息的 ImageObserver 标志。

返回：
所有相关 ImageObserver 标志的按位或
另请参见：
ImageObserver

getWidth

public int getWidth()
获取（调整图像宽度后的）像素缓冲区的宽度。如果未指定要抓取的像素矩形的宽度，则只有在为图像传递尺寸后此信息才有效。

返回：
像素缓冲区的最终宽度；如果宽度未知，则为 -1
另请参见：
getStatus()

getHeight

public int getHeight()
获取（调整图像高度后的）像素缓冲区的高度。如果未指定要抓取的像素矩形的高度，则只有在为图像传递尺寸后此信息才有效。

返回：
像素缓冲区的最终高度；如果高度未知，则为 -1
另请参见：
getStatus()

getPixels

public Object getPixels()
获取像素缓冲区。如果没有使用保存像素的显式像素缓冲区来构造 PixelGrabber，则在知道图像数据的大小和格式前，此方法将返回 null。因为当源图像使用多个 ColorModel 来传递数据时，PixelGrabber 随时都可能回退到以默认 RGB ColorModel 方式存储数据，所以在图像抓取完成前，此方法返回的数组对象可能随时间的推移而更改。

返回：
byte 数组或 int 数组
另请参见：
getStatus(), setPixels(int, int, int, int, ColorModel, byte[], int, int), setPixels(int, int, int, int, ColorModel, int[], int, int)

getColorModel

public ColorModel getColorModel()
获取该数组中所存储像素的 ColorModel。如果使用显式像素缓冲区构造此 PixelGrabber，则此方法将始终返回默认的 RGB ColorModel；否则，在知道 ImageProducer 使用的 ColorModel 前，此方法可能返回 null。因为当源图像使用多个 ColorModel 来传递数据时，PixelGrabber 随时都可能回退到以默认 RGB ColorModel 形式存储数据，所以在图像抓取完成前，此方法返回的 ColorModel 对象可能随时间的推移而更改，且可能无法反映 ImageProducer 用来传递像素的任何 ColorModel 对象。

返回：
存储像素所用的 ColorModel 对象
另请参见：
getStatus(),
ColorModel.getRGBdefault(),
setColorModel(ColorModel)

setDimensions

public void setDimensions(int width,
                          int height)
setDimensions 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。

注：此方法应该由要从中抓取像素的 Image 的 ImageProducer 调用。使用此类检索图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能导致检索请求像素时出现问题。

指定者：
接口 ImageConsumer 中的 setDimensions
参数：
width - 尺寸的宽度
height - 尺寸的高度

setHints

public void setHints(int hints)
setHints 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。

注：此方法应该由要从中抓取像素的 Image 的 ImageProducer 调用。使用此类检索图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能导致检索请求像素时出现问题。

指定者：
接口 ImageConsumer 中的 setHints
参数：
hints - 用于处理像素的提示集

setProperties

public void setProperties(Hashtable<?,?> props)
setProperties 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。

注：此方法应该由要从中抓取像素的 Image 的 ImageProducer 调用。使用此类检索图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能导致检索请求像素时出现问题。

指定者：
接口 ImageConsumer 中的 setProperties
参数：
props - 属性列表

setColorModel

public void setColorModel(ColorModel model)
setColorModel 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。

注：此方法应该由要从中抓取像素的 Image 的 ImageProducer 调用。使用此类检索图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能导致检索请求像素时出现问题。

指定者：
接口 ImageConsumer 中的 setColorModel
参数：
model - 指定的 ColorModel
另请参见：
getColorModel()

setPixels

public void setPixels(int srcX,
                      int srcY,
                      int srcW,
                      int srcH,
                      ColorModel model,
                      byte[] pixels,
                      int srcOff,
                      int srcScan)
setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。

注：此方法应该由要从中抓取像素的 Image 的 ImageProducer 调用。使用此类检索图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能导致检索请求像素时出现问题。

指定者：
接口 ImageConsumer 中的 setPixels
参数：
srcX - 要设置的像素区域左上角的 X 坐标
srcY - 要设置的像素区域左上角的 Y 坐标
srcW - 像素区域的宽度
srcH - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
srcOff - 像素数组中的偏移量
srcScan - 像素数组中一行像素到下一行的距离
另请参见：
getPixels()

setPixels

public void setPixels(int srcX,
                      int srcY,
                      int srcW,
                      int srcH,
                      ColorModel model,
                      int[] pixels,
                      int srcOff,
                      int srcScan)
setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。

注：此方法应该由要从中抓取像素的 Image 的 ImageProducer 调用。使用此类检索图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能导致检索请求像素时出现问题。

指定者：
接口 ImageConsumer 中的 setPixels
参数：
srcX - 要设置的像素区域左上角的 X 坐标
srcY - 要设置的像素区域左上角的 Y 坐标
srcW - 像素区域的宽度
srcH - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
srcOff - 像素数组中的偏移量
srcScan - 像素数组中一行像素到下一行的距离
另请参见：
getPixels()

imageComplete

public void imageComplete(int status)
imageComplete 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。

注：此方法应该由要从中抓取像素的 Image 的 ImageProducer 调用。使用此类检索图像像素的开发人员应该避免直接调用此方法，因为该调用操作可能导致检索请求像素时出现问题。

指定者：
接口 ImageConsumer 中的 imageComplete
参数：
status - 正在加载的图像的状态
另请参见：
ImageProducer.removeConsumer(java.awt.image.ImageConsumer)

status

public int status()
返回像素的状态。返回表示可用像素信息的 ImageObserver 标志。此方法和 getStatus 具有相同的实现，但是优先使用 getStatus 方法，因为它遵循检索信息方法的命名约定，即 "getXXX" 的形式。

返回：
所有相关 ImageObserver 标志的按位或
另请参见：
ImageObserver, getStatus()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PixelInterleavedSampleModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 PixelInterleavedSampleModel

java.lang.Object
    继承者  java.awt.image.SampleModel
        继承者  java.awt.image.ComponentSampleModel
            继承者  java.awt.image.PixelInterleavedSampleModel

public class PixelInterleavedSampleModel
extends ComponentSampleModel

此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。该类子类化 ComponentSampleModel，不过在对像素交替存储图像数据的访问方面，它提供的实现比 ComponentSampleModel 提供的要更为高效。此类在 DataBuffer 的单个存储单元中存储所有 band 的采样数据。还提供了存取方法，这样就可以直接操作图像数据。像素跨度是相同扫描行上同一 band 的两个采样之间的数据数组元素数。扫描行跨度是给定采样和下一扫描行同一列中的对应采样之间的数据数组元素数。band 偏移量表示从保存每个 band 的 DataBuffer 存储单元的第一个数据数组元素到第一个 band 采样之间的数据数组元素数。band 编号从 0 到 N-1。band 索引表示数据缓冲区的存储单元和图像数据 band 之间的对应关系。此类支持 TYPE_BYTE、TYPE_USHORT、TYPE_SHORT、TYPE_INT、TYPE_FLOAT 和 TYPE_DOUBLE 数据类型。

字段摘要
从类 java.awt.image.ComponentSampleModel 继承的字段
bandOffsets, bankIndices, numBands, numBanks, pixelStride, scanlineStride
从类 java.awt.image.SampleModel 继承的字段
dataType, height, width
构造方法摘要
PixelInterleavedSampleModel(int dataType, int w, int h, int pixelStride, int scanlineStride, int[] bandOffsets)
构造一个带指定参数的 PixelInterleavedSampleModel。
方法摘要
SampleModel | createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的 PixelInterleavedSampleModel。
SampleModel | createSubsetSampleModel(int[] bands) 创建一个具有此 PixelInterleavedSampleModel 的 band 子集的 PixelInterleavedSampleModel。
int | hashCode() 返回该对象的哈希码值。
从类 java.awt.image.ComponentSampleModel 继承的方法
createDataBuffer, equals, getBandOffsets, getBankIndices, getDataElements, getNumDataElements, getOffset, getOffset, getPixel, getPixels, getPixelStride, getSample, getSampleDouble, getSampleFloat, getSamples, getSampleSize, getSampleSize, getScanlineStride, setDataElements, setPixel, setPixels, setSample, setSample, setSample, setSamples
从类 java.awt.image.SampleModel 继承的方法
getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSamples, setSamples
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PixelInterleavedSampleModel

public PixelInterleavedSampleModel(int dataType,
                                   int w,
                                   int h,
                                   int pixelStride,
                                   int scanlineStride,
                                   int[] bandOffsets)
构造一个带指定参数的 PixelInterleavedSampleModel。通过 bandOffsets 数组的长度给出 band 数。

参数：
dataType - 存储采样的数据类型。
w - 所描述的图像数据区域的宽度（以像素为单位）。
h - 所描述的图像数据区域的高度（以像素为单位）。
pixelStride - 图像数据的像素跨度。
scanlineStride - 图像数据的行跨度。
bandOffsets - 所有 band 的偏移量。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0
IllegalArgumentException - 如果任意 band 之间的偏移量大于扫描行跨度
IllegalArgumentException - 如果 pixelStride 和 w 的乘积大于 scanlineStride
IllegalArgumentException - 如果 pixelStride 小于任意 band 之间的偏移量
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一
方法详细信息

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
创建一个具有指定宽度和高度的 PixelInterleavedSampleModel。新的 PixelInterleavedSampleModel 具有与此 PixelInterleavedSampleModel 相同的 band 数、数据存储类型和像素跨度。可能压缩 band 偏移量，使得所有 band 偏移量的最小值是 0。

覆盖：
类 ComponentSampleModel 中的 createCompatibleSampleModel
参数：
w - 所得 SampleModel 的宽度
h - 所得 SampleModel 的高度
返回：
具有指定宽度和高度的新 SampleModel。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0

createSubsetSampleModel

public SampleModel createSubsetSampleModel(int[] bands)
创建一个具有此 PixelInterleavedSampleModel 的 band 子集的 PixelInterleavedSampleModel。新的 PixelInterleavedSampleModel 可以与现有 PixelInterleavedSampleModel 一起使用的所有 DataBuffer 一起使用。新的 PixelInterleavedSampleModel/DataBuffer 组合表示的图像具有原 PixelInterleavedSampleModel/DataBuffer 组合的 band 子集。

覆盖：
类 ComponentSampleModel 中的 createSubsetSampleModel
参数：
bands - 此 ComponentSampleModel 的 band 子集
返回：
已创建的具有此 ComponentSampleModel band 子集的 ComponentSampleModel。

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 ComponentSampleModel 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Raster (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 Raster

java.lang.Object
    继承者  java.awt.image.Raster
直接已知子类：
WritableRaster
public class Raster
extends Object

表示像素矩形数组的类。Raster 封装存储样本值的 DataBuffer，以及描述如何在 DataBuffer 中定位给定样本值的 SampleModel。

Raster 定义占据特定平面矩形区域的像素值，该区域不一定包括 (0, 0)。该矩形也称为 Raster 的边界矩形，可以通过 getBounds 方法获得，由 minX、minY、width 和 height 值定义。minX 和 minY 值定义 Raster 左上角的坐标。对边界矩形外部像素的引用可能导致抛出异常，也可能导致引用与 Raster 的关联 DataBuffer 无关的元素。用户应该避免访问这种像素。

SampleModel 描述如何将 Raster 的样本存储在 DataBuffer 的基本数组元素中。可按每个数据元素一个样本的方式存储样本（使用 PixelInterleavedSampleModel 或 BandedSampleModel），或者将多个样本打包到一个元素中（使用 SinglePixelPackedSampleModel 或 MultiPixelPackedSampleModel）。SampleModel 还控制样本是否为符号扩展的，即是否允许将无符号数据以有符号的 Java 数据类型（如 byte、short 和 int）存储。

虽然 Raster 可能存在于平面中的任何位置，但 SampleModel 使用从 (0, 0) 开始的简单坐标系。因此 Raster 包含一个平移系数，允许在 Raster 的坐标系和 SampleModel 的坐标系之间映射像素位置。通过 getSampleModelTranslateX 和 getSampleModelTranslateY 方法可获取从 SampleModel 坐标系到 Raster 坐标系的平移。

通过显示构造或使用 createChild 和 createTranslatedChild 方法，Raster 可与另一个 Raster 共享 DataBuffer。这些方法创建的 Raster 可以返回对通过 getParent 方法创建的 Raster 的引用。对于不是通过调用 createTranslatedChild 或 createChild 构造的 Raster，getParent 将返回 null。

createTranslatedChild 方法返回一个与当前 Raster 共享所有数据的新 Raster，但却占用一个具有不同开始点、相同宽度和高度的边界矩形。例如，如果父 Raster 占用 (10, 10) 到 (100, 100) 的区域，并定义了平移的 Raster 从 (50, 50) 开始，则父 Raster 的像素 (20, 20) 和子 Raster 的像素 (60, 60) 占用两个 Raster 共享的 DataBuffer 中的同一位置。在第一种情况中，像素坐标应该加上 (-10, -10) 以得到对应的 SampleModel 坐标，第二种情况中则应加上 (-50, -50)。

通过从父 Raster 的 sampleModelTranslateX 和 sampleModelTranslateY 值中减去子 Raster 的 sampleModelTranslateX 和 sampleModelTranslateY 值，可以确定父 Raster 和子 Raster 之间的平移。

createChild 方法可用于创建新的 Raster，该 Raster 只占用其父 Raster 边界矩形的一个子集（具有相同或平移后的坐标系），或者具有其父 Raster 的 band 子集。

所有构造方法都是受保护的。创建 Raster 的正确方式是使用此类中定义的某个静态创建方法。这些方法创建使用标准 Interleaved、Banded 和 Packed SampleModel 的 Raster 实例，相比通过结合外部生成的 SampleModel 和 DataBuffer 所创建的 Raster，该 Raster 的处理要更高效。

另请参见：
DataBuffer, SampleModel, PixelInterleavedSampleModel, BandedSampleModel, SinglePixelPackedSampleModel, MultiPixelPackedSampleModel

字段摘要
protected DataBuffer | dataBuffer 存储图像数据的 DataBuffer。
protected int | height 此 Raster 的高度。
protected int | minX 此 Raster 左上角像素的 X 坐标。
protected int | minY 此 Raster 左上角像素的 Y 坐标。
protected int | numBands Raster 中的 band 数。
protected int | numDataElements 每个像素的 DataBuffer 数据元素数。
protected Raster | parent 此 Raster 的父 Raster，或者为 null。
protected SampleModel | sampleModel 描述此 Raster 的像素在 DataBuffer 中存储方式的 SampleModel。
protected int | sampleModelTranslateX 从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 X 平移。
protected int | sampleModelTranslateY 从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 Y 平移。
protected int | width 此 Raster 的宽度。
构造方法摘要
protected | Raster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin) 构建具有给定 SampleModel 和 DataBuffer 的 Raster。
protected | Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent) 构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
protected | Raster(SampleModel sampleModel, Point origin) 构建具有给定 SampleModel 的 Raster。
方法摘要
static WritableRaster | createBandedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | createBandedRaster(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | createBandedRaster(int dataType, int w, int h, int bands, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
Raster | createChild(int parentX, int parentY, int width, int height, int childMinX, int childMinY, int[] bandList) 返回共享此 Raster 全部或部分 DataBuffer 的新 Raster。
WritableRaster | createCompatibleWritableRaster() 创建一个兼容的 WritableRaster，使其具有与此 Raster 相同的大小、SampleModel，以及一个新初始化的 DataBuffer。
WritableRaster | createCompatibleWritableRaster(int w, int h) 创建一个兼容的 WritableRaster，使其具有指定大小、新 SampleModel 和新初始化的 DataBuffer。
WritableRaster | createCompatibleWritableRaster(int x, int y, int w, int h) 创建一个兼容的 WritableRaster，使其具有指定位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
WritableRaster | createCompatibleWritableRaster(Rectangle rect) 创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
static WritableRaster | createInterleavedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | createInterleavedRaster(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | createInterleavedRaster(int dataType, int w, int h, int bands, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
static WritableRaster | createPackedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
static WritableRaster | createPackedRaster(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location) 根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
static WritableRaster | createPackedRaster(int dataType, int w, int h, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。
static WritableRaster | createPackedRaster(int dataType, int w, int h, int bands, int bitsPerBand, Point location) 根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。
static Raster | createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
Raster | createTranslatedChild(int childMinX, int childMinY) 创建一个 Raster，使其大小、SampleModel 和 DataBuffer 与此 Raster 相同，但是位置不同。
static WritableRaster | createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
static WritableRaster | createWritableRaster(SampleModel sm, Point location) 创建一个具有指定 SampleModel 的 WritableRaster。
Rectangle | getBounds() 返回此 Raster 的边界 Rectangle。
DataBuffer | getDataBuffer() 返回与此 Raster 关联的 DataBuffer。
Object | getDataElements(int x, int y, int w, int h, Object outData) 以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。
Object | getDataElements(int x, int y, Object outData) 以 TransferType 类型的基本数组形式返回单个像素的数据。
int | getHeight() 返回 Raster 的像素高度。
int | getMinX() 返回 Raster 的最小有效 X 坐标。
int | getMinY() 返回 Raster 的最小有效 Y 坐标。
int | getNumBands() 返回此 Raster 中的 band 数（每像素样本）。
int | getNumDataElements() 返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
Raster | getParent() 返回此 Raster 的父 Raster（如果有），或者 null。
double[] | getPixel(int x, int y, double[] dArray) 以 double 数组形式返回指定像素的样本。
float[] | getPixel(int x, int y, float[] fArray) 以 float 数组形式返回指定像素的样本。
int[] | getPixel(int x, int y, int[] iArray) 以 int 数组形式返回指定像素的样本。
double[] | getPixels(int x, int y, int w, int h, double[] dArray) 返回一个包含像素矩形所有样本的 double 数组，每个数组元素对应一个样本。
float[] | getPixels(int x, int y, int w, int h, float[] fArray) 返回一个包含像素矩形所有样本的 float 数组，每个数组元素对应一个样本。
int[] | getPixels(int x, int y, int w, int h, int[] iArray) 返回一个包含像素矩形所有样本的 int 数组，每个数组元素对应一个样本。
int | getSample(int x, int y, int b) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | getSampleDouble(int x, int y, int b) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | getSampleFloat(int x, int y, int b) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
SampleModel | getSampleModel() 返回描述图像数据布局的 SampleModel。
int | getSampleModelTranslateX() 返回从 SampleModel 坐标系到 Raster 坐标系的 X 平移。
int | getSampleModelTranslateY() 返回从 SampleModel 坐标系到 Raster 坐标系的 Y 平移。
double[] | getSamples(int x, int y, int w, int h, int b, double[] dArray) 以 double 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
float[] | getSamples(int x, int y, int w, int h, int b, float[] fArray) 以 float 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int[] | getSamples(int x, int y, int w, int h, int b, int[] iArray) 以 int 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int | getTransferType() 返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
int | getWidth() 返回 Raster 的像素宽度。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

sampleModel

protected SampleModel sampleModel
描述此 Raster 的像素在 DataBuffer 中存储方式的 SampleModel。

dataBuffer

protected DataBuffer dataBuffer
存储图像数据的 DataBuffer。

minX

protected int minX
此 Raster 左上角像素的 X 坐标。

minY

protected int minY
此 Raster 左上角像素的 Y 坐标。

width

protected int width
此 Raster 的宽度。

height

protected int height
此 Raster 的高度。

sampleModelTranslateX

protected int sampleModelTranslateX
从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 X 平移。

sampleModelTranslateY

protected int sampleModelTranslateY
从 Raster 的 SampleModel 坐标空间到该 Raster 坐标空间的 Y 平移。

numBands

protected int numBands
Raster 中的 band 数。

numDataElements

protected int numDataElements
每个像素的 DataBuffer 数据元素数。

parent

protected Raster parent
此 Raster 的父 Raster，或者为 null。

构造方法详细信息

Raster

protected Raster(SampleModel sampleModel,
                 Point origin)
构建具有给定 SampleModel 的 Raster。Raster 的左上角是原点，其大小与 SampleModel 相同。自动创建大小足以容纳该 Raster 的 DataBuffer。

参数：
sampleModel - 指定布局的 SampleModel
origin - 指定原点的 Point
抛出：
RasterFormatException - 如果计算 origin.x + sampleModel.getWidth() 或 origin.y + sampleModel.getHeight() 导致整数溢出
NullPointerException - 如果 sampleModel 或 origin 为 null

Raster

protected Raster(SampleModel sampleModel,
                 DataBuffer dataBuffer,
                 Point origin)
构建具有给定 SampleModel 和 DataBuffer 的 Raster。Raster 的左上角是原点，其大小与 SampleModel 相同。DataBuffer 没有初始化，且必须与 SampleModel 兼容。

参数：
sampleModel - 指定布局的 SampleModel
dataBuffer - 包含图像数据的 DataBuffer
origin - 指定原点的 Point
抛出：
RasterFormatException - 如果计算 origin.x + sampleModel.getWidth() 或 origin.y + sampleModel.getHeight() 导致整数溢出
NullPointerException - 如果 sampleModel 或 origin 为 null

Raster

protected Raster(SampleModel sampleModel,
                 DataBuffer dataBuffer,
                 Rectangle aRegion,
                 Point sampleModelTranslate,
                 Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。aRegion 指定新 Raster 的边界矩形。平移到基 Raster 的坐标系时，基 Raster 必须包含 aRegion。（对于没有父 Raster 的 Raster 而言，基 Raster 是其祖先。）sampleModelTranslate 指定新 Raster 的 sampleModelTranslateX 和 sampleModelTranslateY 值。注意，此构造方法通常应该由其他构造方法或创建方法调用，不应直接使用它。

参数：
sampleModel - 指定布局的 SampleModel
dataBuffer - 包含图像数据的 DataBuffer
aRegion - 指定图像区域的 Rectangle
sampleModelTranslate - 指定从 SampleModel 向 Raster 坐标平移的 Point
parent - 此 Raster 的父 Raster（如果有）
抛出：
NullPointerException - 如果任意 sampleModel、dataBuffer、aRegion 或 sampleModelTranslate 为 null
RasterFormatException - 如果 aRegion 的宽度或高度小于等于 0，或者计算 aRegion.x + aRegion.width 或 aRegion.y + aRegion.height 导致整数溢出
方法详细信息

createInterleavedRaster

public static WritableRaster createInterleavedRaster(int dataType,
                                                     int w,
                                                     int h,
                                                     int bands,
                                                     Point location)
根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。

Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。dataType 参数应该是 DataBuffer 类中定义的某个枚举值。

注意，不支持交错存取的 DataBuffer.TYPE_INT Raster。要创建 DataBuffer.TYPE_INT 类型的一 band Raster，请使用 Raster.createPackedRaster()。

当前受支持的 dataType 只有 TYPE_BYTE 和 TYPE_USHORT。

参数：
dataType - 存储样本的数据类型
w - 图像数据的像素宽度
h - 图像数据的像素高度
bands - band 数
location - Raster 的左上角
返回：
具有指定数据类型、宽度、高度和 band 数的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出

createInterleavedRaster

public static WritableRaster createInterleavedRaster(int dataType,
                                                     int w,
                                                     int h,
                                                     int scanlineStride,
                                                     int pixelStride,
                                                     int[] bandOffsets,
                                                     Point location)
根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。从 bandOffsets.length 可以推导出 band 数。

Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。dataType 参数应该是 DataBuffer 类中定义的某个枚举值。

注意，不支持交错存取的 DataBuffer.TYPE_INT Raster。要创建 DataBuffer.TYPE_INT 类型的一 band Raster，请使用 Raster.createPackedRaster()。

当前受支持的 dataType 只有 TYPE_BYTE 和 TYPE_USHORT。

参数：
dataType - 存储样本的数据类型
w - 图像数据的像素宽度
h - 图像数据的像素高度
scanlineStride - 图像数据的行间距
pixelStride - 图像数据的像素间距
bandOffsets - 所有 band 的偏移量
location - Raster 的左上角
返回：
具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE 或 DataBuffer.TYPE_USHORT。

createBandedRaster

public static WritableRaster createBandedRaster(int dataType,
                                                int w,
                                                int h,
                                                int bands,
                                                Point location)
根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。

Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。dataType 参数应该是 DataBuffer 类中定义的某个枚举值。

当前受支持的 dataType 只有 TYPE_BYTE 和 TYPE_USHORT。

参数：
dataType - 存储样本的数据类型
w - 图像数据的像素宽度
h - 图像数据的像素高度
bands - band 数
location - Raster 的左上角
返回：
具有指定数据类型、宽度、高度和 band 数的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
ArrayIndexOutOfBoundsException - 如果 bands 小于 1

createBandedRaster

public static WritableRaster createBandedRaster(int dataType,
                                                int w,
                                                int h,
                                                int scanlineStride,
                                                int[] bankIndices,
                                                int[] bandOffsets,
                                                Point location)
根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。从 bankIndices.length 和 bandOffsets.length（这两个数必须相同）可以推导出 band 数。

Raster 的左上角由 location 参数给定。dataType 参数应该是 DataBuffer 类中定义的某个枚举值。

当前受支持的 dataType 只有 TYPE_BYTE 和 TYPE_USHORT。

参数：
dataType - 存储样本的数据类型
w - 图像数据的像素宽度
h - 图像数据的像素高度
scanlineStride - 图像数据的行间距
bankIndices - 每个 band 的存储单元索引
bandOffsets - 所有 band 的偏移量
location - Raster 的左上角
返回：
具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT
ArrayIndexOutOfBoundsException - 如果 bankIndices 或 bandOffsets 为 null

createPackedRaster

public static WritableRaster createPackedRaster(int dataType,
                                                int w,
                                                int h,
                                                int[] bandMasks,
                                                Point location)
根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。从 bandMasks.length 可以推导出 band 数。

Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。dataType 参数应该是 DataBuffer 类中定义的某个枚举值。

当前受支持的 dataType 只有 TYPE_BYTE 和 TYPE_USHORT。

参数：
dataType - 存储样本的数据类型
w - 图像数据的像素宽度
h - 图像数据的像素高度
bandMasks - 包含每个 band 项的数组
location - Raster 的左上角
返回：
具有指定数据类型、宽度、高度和 band 掩码的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT

createPackedRaster

public static WritableRaster createPackedRaster(int dataType,
                                                int w,
                                                int h,
                                                int bands,
                                                int bitsPerBand,
                                                Point location)
根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。如果 band 数是 1，则 SampleModel 将是一个 MultiPixelPackedSampleModel。

如果 band 数大于 1，则 SampleModel 将是一个 SinglePixelPackedSampleModel，每个 band 有 bitsPerBand 位。无论是哪种情况，都要满足相应 SampleModel 对 dataType 和 bitsPerBand 的要求。

Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。dataType 参数应该是 DataBuffer 类中定义的某个枚举值。

当前受支持的 dataType 只有 TYPE_BYTE 和 TYPE_USHORT。

参数：
dataType - 存储样本的数据类型
w - 图像数据的像素宽度
h - 图像数据的像素高度
bands - band 数
bitsPerBand - 每个 band 的位数
location - Raster 的左上角
返回：
具有指定数据类型、宽度、高度、band 数和每个 band 位数的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 bitsPerBand 和 bands 的乘积大于 dataType 保存的位数
IllegalArgumentException - 如果 bitsPerBand 或 bands 小于 0
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT

createInterleavedRaster

public static WritableRaster createInterleavedRaster(DataBuffer dataBuffer,
                                                     int w,
                                                     int h,
                                                     int scanlineStride,
                                                     int pixelStride,
                                                     int[] bandOffsets,
                                                     Point location)
根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。从 bandOffsets.length 可以推导出 band 数。Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。

注意，不支持交错存取的 DataBuffer.TYPE_INT Raster。要创建 DataBuffer.TYPE_INT 类型的一 band Raster，请使用 Raster.createPackedRaster()。

参数：
dataBuffer - 包含图像数据的 DataBuffer
w - 图像数据的像素宽度
h - 图像数据的像素高度
scanlineStride - 图像数据的行间距
pixelStride - 图像数据的像素间距
bandOffsets - 所有 band 的偏移量
location - Raster 的左上角
返回：
具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT
RasterFormatException - 如果 dataBuffer 有多个存储单元。
NullPointerException - 如果 dataBuffer 为 null

createBandedRaster

public static WritableRaster createBandedRaster(DataBuffer dataBuffer,
                                                int w,
                                                int h,
                                                int scanlineStride,
                                                int[] bankIndices,
                                                int[] bandOffsets,
                                                Point location)
根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。从 bankIndices.length 和 bandOffsets.length（这两个数必须相同）可以推导出 band 数。Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。

参数：
dataBuffer - 包含图像数据的 DataBuffer
w - 图像数据的像素宽度
h - 图像数据的像素高度
scanlineStride - 图像数据的行间距
bankIndices - 每个 band 的存储单元索引
bandOffsets - 所有 band 的偏移量
location - Raster 的左上角
返回：
具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT
NullPointerException - 如果 dataBuffer 为 null

createPackedRaster

public static WritableRaster createPackedRaster(DataBuffer dataBuffer,
                                                int w,
                                                int h,
                                                int scanlineStride,
                                                int[] bandMasks,
                                                Point location)
根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。从 bandMasks.length 可以推导出 band 数。通过 location 参数给出 Raster 的左上角。如果 location 为 null，则将使用 (0, 0)。

参数：
dataBuffer - 包含图像数据的 DataBuffer
w - 图像数据的像素宽度
h - 图像数据的像素高度
scanlineStride - 图像数据的行间距
bandMasks - 包含每个 band 项的数组
location - Raster 的左上角
返回：
具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT
RasterFormatException - 如果 dataBuffer 有多个存储单元。
NullPointerException - 如果 dataBuffer 为 null

createPackedRaster

public static WritableRaster createPackedRaster(DataBuffer dataBuffer,
                                                int w,
                                                int h,
                                                int bitsPerPixel,
                                                Point location)
根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。

参数：
dataBuffer - 包含图像数据的 DataBuffer
w - 图像数据的像素宽度
h - 图像数据的像素高度
bitsPerPixel - 每像素的位数
location - Raster 的左上角
返回：
具有指定 DataBuffer、宽度、高度和每像素位数的 WritableRaster 对象。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 location.x + w 或 location.y + h 导致整数溢出
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一，即 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT
RasterFormatException - 如果 dataBuffer 有多个存储单元。
NullPointerException - 如果 dataBuffer 为 null

createRaster

public static Raster createRaster(SampleModel sm,
                                  DataBuffer db,
                                  Point location)
创建具有指定 SampleModel 和 DataBuffer 的 Raster。Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。

参数：
sm - 指定的 SampleModel
db - 指定的 DataBuffer
location - Raster 的左上角
返回：
具有指定 SampleModel、DataBuffer 和 location 的Raster。
抛出：
RasterFormatException - 如果计算 location.x + sm.getWidth() 或 location.y + sm.getHeight() 导致整数溢出
RasterFormatException - 如果 dataBuffer 具有多个存储单元且 sampleModel 是 PixelInterleavedSampleModel、SinglePixelPackedSampleModel 或 MultiPixelPackedSampleModel。
NullPointerException - 如果 SampleModel 或 DataBuffer 为 null

createWritableRaster

public static WritableRaster createWritableRaster(SampleModel sm,
                                                  Point location)
创建一个具有指定 SampleModel 的 WritableRaster。Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。

参数：
sm - 指定的 SampleModel
location - WritableRaster 的左上角
返回：
具有指定 SampleModel 和 location 的 WritableRaster。
抛出：
RasterFormatException - 如果计算 location.x + sm.getWidth() 或 location.y + sm.getHeight() 导致整数溢出

createWritableRaster

public static WritableRaster createWritableRaster(SampleModel sm,
                                                  DataBuffer db,
                                                  Point location)
创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。Raster 的左上角由 location 参数给定。如果 location 为 null，则将使用 (0, 0)。

参数：
sm - 指定的 SampleModel
db - 指定的 DataBuffer
location - WritableRaster 的左上角
返回：
具有指定 SampleModel、DataBuffer 和 location 的 WritableRaster。
抛出：
RasterFormatException - 如果计算 location.x + sm.getWidth() 或 location.y + sm.getHeight() 导致整数溢出
RasterFormatException - 如果 dataBuffer 具有多个存储单元且 sampleModel 是 PixelInterleavedSampleModel、SinglePixelPackedSampleModel 或 MultiPixelPackedSampleModel。
NullPointerException - 如果 SampleModel 或 DataBuffer 为 null

getParent

public Raster getParent()
返回此 Raster 的父 Raster（如果有），或者 null。

返回：
父 Raster 或 null。

getSampleModelTranslateX

public final int getSampleModelTranslateX()
返回从 SampleModel 坐标系到 Raster 坐标系的 X 平移。要将像素的 X 坐标从 Raster 坐标系转换到 SampleModel 坐标系，必须减去此值。

返回：
从 Raster 的 SampleModel 坐标空间到 Raster 坐标空间的 X 平移。

getSampleModelTranslateY

public final int getSampleModelTranslateY()
返回从 SampleModel 坐标系到 Raster 坐标系的 Y 平移。要将像素的 Y 坐标从 Raster 坐标系转换到 SampleModel 坐标系，必须减去此值。

返回：
从 Raster 的 SampleModel 坐标空间到 Raster 坐标空间的 Y 平移。

createCompatibleWritableRaster

public WritableRaster createCompatibleWritableRaster()
创建一个兼容的 WritableRaster，使其具有与此 Raster 相同的大小、SampleModel，以及一个新初始化的 DataBuffer。

返回：
具有相同样本模型和新数据缓冲区的兼容 WritableRaster。

createCompatibleWritableRaster

public WritableRaster createCompatibleWritableRaster(int w,
                                                     int h)
创建一个兼容的 WritableRaster，使其具有指定大小、新 SampleModel 和新初始化的 DataBuffer。

参数：
w - 新 WritableRaster 的指定宽度
h - 新 WritableRaster 的指定高度
返回：
具有指定大小，以及新样本模型和数据缓冲区的兼容 WritableRaster。
抛出：
RasterFormatException - 如果 width 或 height 小于等于 0。

createCompatibleWritableRaster

public WritableRaster createCompatibleWritableRaster(Rectangle rect)
创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。

参数：
rect - 指定 WritableRaster 的大小和位置的 Rectangle
返回：
具有指定大小和位置、新样本模型和数据缓冲区的 WritableRaster。
抛出：
RasterFormatException - 如果 rect 的宽度或高度小于等于 0，或者计算 rect.x + rect.width 或 rect.y + rect.height 导致整数溢出
NullPointerException - 如果 rect 为 null

createCompatibleWritableRaster

public WritableRaster createCompatibleWritableRaster(int x,
                                                     int y,
                                                     int w,
                                                     int h)
创建一个兼容的 WritableRaster，使其具有指定位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。

参数：
x - WritableRaster 左上角的 X 坐标
y - WritableRaster 左上角的 Y 坐标
w - WritableRaster 的指定宽度
h - WritableRaster 的指定高度
返回：
具有指定大小和位置、新 SampleModel 和 DataBuffer 的兼容 WritableRaster。
抛出：
RasterFormatException - 如果 w 或 h 小于等于 0，或者计算 x + w 或 y + h 导致整数溢出

createTranslatedChild

public Raster createTranslatedChild(int childMinX,
                                    int childMinY)
创建一个 Raster，使其大小、SampleModel 和 DataBuffer 与此 Raster 相同，但是位置不同。新 Raster 拥有对当前 Raster 的引用，可以通过其 getParent() 方法进行访问。

参数：
childMinX - 新 Raster 左上角的 X 坐标
childMinY - 新 Raster 左上角的 Y 坐标
返回：
大小、SampleModel 和 DataBuffer 与此 Raster 相同，但是具有指定位置的 Raster。
抛出：
RasterFormatException - 如果计算 childMinX + this.getWidth() 或 childMinY + this.getHeight() 导致整数溢出

createChild

public Raster createChild(int parentX,
                          int parentY,
                          int width,
                          int height,
                          int childMinX,
                          int childMinY,
                          int[] bandList)
返回共享此 Raster 全部或部分 DataBuffer 的新 Raster。新 Raster 拥有对当前 Raster 的引用，可以通过其 getParent() 方法进行访问。

parentX、parentY、width 和 height 参数在此 Raster 的坐标空间中形成一个 Rectangle，指示要共享的像素区域。如果此 Rectangle 未包含在当前 Raster 的边界内，则抛出错误。

新 Raster 可能被平移到与当前 Raster 所用坐标系不同的平面坐标系中。childMinX 和 childMinY 参数给出返回的 Raster 左上角像素的新 (x, y) 坐标；新 Raster 中的坐标 (childMinX, childMinY) 将映射到当前 Raster 中与坐标 (parentX, parentY) 相同的像素。

可以定义新 Raster 只包含当前 Raster 的 band 子集，通过 bandList 参数，可以对该子集重新排序。如果 bandList 为 null，则将按当前顺序包含 Raster 的所有 band。

要创建一个包含当前 Raster 子区域，但是共享其坐标系和 band 的新 Raster，应该调用此方法，并使 childMinX 等于 parentX，childMinY 等于 parentY，bandList 等于 null。

参数：
parentX - 此 Raster 坐标空间中左上角的 X 坐标
parentY - 此 Raster 坐标空间中左上角的 Y 坐标
width - 从 (parentX, parentY) 开始的区域宽度
height - 从 (parentX, parentY) 开始的区域高度。
childMinX - 返回的 Raster 左上角的 X 坐标
childMinY - 返回的 Raster 左上角的 Y 坐标
bandList - band 索引数组；如果要使用所有 band，则该参数为 null
返回：
一个新的 Raster。
抛出：
RasterFormatException - 如果指定的子区域处于 Raster 的边界外。
RasterFormatException - 如果 width 或 height 小于等于 0，或者计算 parentX + width、parentY + height、childMinX + width 或 childMinY + height 导致整数溢出

getBounds

public Rectangle getBounds()
返回此 Raster 的边界 Rectangle。此函数返回的信息与 getMinX/MinY/Width/Height 相同。

返回：
此 Raster 的边界框。

getMinX

public final int getMinX()
返回 Raster 的最小有效 X 坐标。

返回：
此 Raster 的最小 x 坐标。

getMinY

public final int getMinY()
返回 Raster 的最小有效 Y 坐标。

返回：
此 Raster 的最小 y 坐标。

getWidth

public final int getWidth()
返回 Raster 的像素宽度。

返回：
此 Raster 的宽度。

getHeight

public final int getHeight()
返回 Raster 的像素高度。

返回：
此 Raster 的高度。

getNumBands

public final int getNumBands()
返回此 Raster 中的 band 数（每像素样本）。

返回：
此 Raster 的 band 数。

getNumDataElements

public final int getNumDataElements()
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。通过这些方法传输像素时，可以以打包或未打包的格式进行传输，具体取决于底层 SampleModel 的实现。使用这些方法，可以将像素作为基本类型的 getNumDataElements() 元素数组传输，其中基本类型由 getTransferType() 给定。TransferType 不一定与 DataBuffer 的存储数据类型相同。

返回：
数据元素数。

getTransferType

public final int getTransferType()
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。通过这些方法传输像素时，可以以打包或未打包的格式进行传输，具体取决于底层 SampleModel 的实现。可以将像素作为基本类型的 getNumDataElements() 元素数组传输，其中基本类型由 getTransferType() 给定。TransferType 不一定与 DataBuffer 的存储数据类型相同。TransferType 是 DataBuffer 中已定义的类型之一。

返回：
传输类型。

getDataBuffer

public DataBuffer getDataBuffer()
返回与此 Raster 关联的 DataBuffer。

返回：
此 Raster 的 DataBuffer。

getSampleModel

public SampleModel getSampleModel()
返回描述图像数据布局的 SampleModel。

返回：
此 Raster 的 SampleModel。

getDataElements

public Object getDataElements(int x,
                              int y,
                              Object outData)
以 TransferType 类型的基本数组形式返回单个像素的数据。对于 Java 2D(tm) API 支持的图像数据，此数据是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 之一。可以打包格式返回数据，从而提高数据的传输效率。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。如果输入对象不为 null 且引用了 TransferType 数组以外的任何对象，则抛出 ClassCastException。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
outData - 数组的对象引用，该数组类型由 getTransferType() 定义，长度由 getNumDataElements() 定义。如果为 null，则分配一个适当类型和大小的数组。
返回：
数组的对象引用，该数组类型由 getTransferType() 定义，包含所请求的像素数据。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 outData 太小而无法保存输出内容。
另请参见：
SampleModel.getDataElements(int, int, Object, DataBuffer)

getDataElements

public Object getDataElements(int x,
                              int y,
                              int w,
                              int h,
                              Object outData)
以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。对于 Java 2D API 支持的图像数据，此数据是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 之一。可以打包格式返回数据，从而提高数据的传输效率。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。如果输入对象不为 null 且引用了 TransferType 数组以外的任何对象，则抛出 ClassCastException。

参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
outData - 数组的对象引用，该数组类型由 getTransferType() 定义，长度由 w*h*getNumDataElements()定义。如果为 null，则分配一个适当类型和大小的数组。
返回：
数组的对象引用，该数组类型由 getTransferType() 定义，包含所请求的像素数据。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 outData 太小而无法保存输出内容。
另请参见：
SampleModel.getDataElements(int, int, int, int, Object, DataBuffer)

getPixel

public int[] getPixel(int x,
                      int y,
                      int[] iArray)
以 int 数组形式返回指定像素的样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - 一个可选的、预分配的 int 数组
返回：
指定像素的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 iArray 太小而无法保存输出内容。

getPixel

public float[] getPixel(int x,
                        int y,
                        float[] fArray)
以 float 数组形式返回指定像素的样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
fArray - 一个可选的、预分配的 float 数组
返回：
指定像素的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 fArray 太小而无法保存输出内容。

getPixel

public double[] getPixel(int x,
                         int y,
                         double[] dArray)
以 double 数组形式返回指定像素的样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
dArray - 一个可选的、预分配的 double 数组
返回：
指定像素的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 dArray 太小而无法保存输出内容。

getPixels

public int[] getPixels(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray)
返回一个包含像素矩形所有样本的 int 数组，每个数组元素对应一个样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
iArray - 一个可选的、预分配的 int 数组
返回：
指定像素矩形的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 iArray 太小而无法保存输出内容。

getPixels

public float[] getPixels(int x,
                         int y,
                         int w,
                         int h,
                         float[] fArray)
返回一个包含像素矩形所有样本的 float 数组，每个数组元素对应一个样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
fArray - 一个可选的、预分配的 float 数组
返回：
指定像素矩形的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 fArray 太小而无法保存输出内容。

getPixels

public double[] getPixels(int x,
                          int y,
                          int w,
                          int h,
                          double[] dArray)
返回一个包含像素矩形所有样本的 double 数组，每个数组元素对应一个样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
dArray - 一个可选的、预分配的 double 数组
返回：
指定像素矩形的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 dArray 太小而无法保存输出内容。

getSample

public int getSample(int x,
                     int y,
                     int b)
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
返回：
指定 band 中对应于指定坐标处像素的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。

getSampleFloat

public float getSampleFloat(int x,
                            int y,
                            int b)
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
返回：
指定 band 中对应于指定坐标处像素的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。

getSampleDouble

public double getSampleDouble(int x,
                              int y,
                              int b)
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
b - 要返回的 band
返回：
指定 band 中对应于指定坐标处像素的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。

getSamples

public int[] getSamples(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray)
以 int 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
b - 要返回的 band
iArray - 一个可选的、预分配的 int 数组
返回：
指定 band 中对应于指定像素矩形的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 iArray 太小而无法保存输出内容。

getSamples

public float[] getSamples(int x,
                          int y,
                          int w,
                          int h,
                          int b,
                          float[] fArray)
以 float 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
b - 要返回的 band
fArray - 一个可选的、预分配的 float 数组
返回：
指定 band 中对应于指定像素矩形的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 fArray 太小而无法保存输出内容。

getSamples

public double[] getSamples(int x,
                           int y,
                           int w,
                           int h,
                           int b,
                           double[] dArray)
以 double 数组形式返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。如果坐标不在边界之内，则抛出 ArrayIndexOutOfBoundsException。但是不保证进行显式的边界检查。

参数：
x - 左上角像素位置的 X 坐标
y - 左上角像素位置的 Y 坐标
w - 像素矩形的宽度
h - 像素矩形的高度
b - 要返回的 band
iArray - 一个可选的、预分配的 double 数组
返回：
指定 band 中对应于指定像素矩形的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 dArray 太小而无法保存输出内容。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RasterFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 RasterFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.awt.image.RasterFormatException
所有已实现的接口：
Serializable
public class RasterFormatException
extends RuntimeException

如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

另请参见：
序列化表格

构造方法摘要
RasterFormatException(String s)
构造带指定消息的新 RasterFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RasterFormatException

public RasterFormatException(String s)
构造带指定消息的新 RasterFormatException。

参数：
s - 抛出 RasterFormatException 时所生成的消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RasterOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 RasterOp

所有已知实现类：
AffineTransformOp, BandCombineOp, ColorConvertOp, ConvolveOp, LookupOp, RescaleOp
public interface RasterOp

此接口描述对 Raster 对象执行的单输入/单输出操作。该接口由诸如 AffineTransformOp、ConvolveOp 和 LookupOp 之类的类实现。针对实现此接口的特定类，Source 和 Destination 对象必须包含合适数量的 band。否则，会抛出异常。此接口不能用于描述更复杂的操作，如接受多个源的操作。实现此接口的每个类都必须指出是否允许就地进行过滤操作（也就是源对象等于目标对象的操作）。注意，对单输入操作的限制意味着进行操作前的目标像素值不能用作过滤操作的输入。

另请参见：
AffineTransformOp, BandCombineOp, ColorConvertOp, ConvolveOp, LookupOp, RescaleOp

方法摘要
WritableRaster | createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的归零目标 Raster。
WritableRaster | filter(Raster src, WritableRaster dest) 执行从源 Raster 到目标 Raster 的单输入/单输出操作。
Rectangle2D | getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 在给定源 Raster 中一个点的情况下，返回目标点的位置。
RenderingHints | getRenderingHints() 返回此 RasterOp 的呈现提示。

方法详细信息

filter

WritableRaster filter(Raster src,
                      WritableRaster dest)
执行从源 Raster 到目标 Raster 的单输入/单输出操作。如果目标 Raster 为 null，则创建一个新 Raster。如果源和/或目标 Raster 与实现此过滤器的类所允许的 Raster 类型不兼容，则可能抛出 IllegalArgumentException。

参数：
src - 源 Raster
dest - 目标 WritableRaster
返回：
表示过滤操作结果的 WritableRaster。

getBounds2D

Rectangle2D getBounds2D(Raster src)
返回过滤后目标 Raster 的边界框。如果源 Raster 与实现此过滤器的类所允许的 Raster 类型不兼容，则可能抛出 IllegalArgumentException。

参数：
src - 源 Raster
返回：
一个 Rectangle2D，它是从过滤操作得到的 Raster 的边界框。

createCompatibleDestRaster

WritableRaster createCompatibleDestRaster(Raster src)
创建一个具有正确大小和 band 数的归零目标 Raster。如果源 Raster 与实现此过滤器的类所允许的 Raster 类型不兼容，则可能抛出 IllegalArgumentException。

参数：
src - 源 Raster
返回：
与 src 兼容的 WritableRaster

getPoint2D

Point2D getPoint2D(Point2D srcPt,
                   Point2D dstPt)
在给定源 Raster 中一个点的情况下，返回目标点的位置。如果 dstPt 不为 null，则使用它来保存返回值。

参数：
srcPt - 源 Point2D
dstPt - 目标 Point2D
返回：
目标点的位置。

getRenderingHints

RenderingHints getRenderingHints()
返回此 RasterOp 的呈现提示。如果尚未设置提示，则返回 null。

返回：
此 RasterOp 的 RenderingHints 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderedImage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 RenderedImage

所有已知子接口：
WritableRenderedImage
所有已知实现类：
BufferedImage
public interface RenderedImage

RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。图像数据可以作为单个 tile 或 tile 规则数组被存储/生成。

方法摘要
WritableRaster | copyData(WritableRaster raster) 计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。
ColorModel | getColorModel() 返回与此图像相关的 ColorModel。
Raster | getData() 以一个大 tile 的形式返回图像（对于基于 tile 的图像，此方法需要获取整个图像并复制全部图像数据）。
Raster | getData(Rectangle rect) 计算并返回 RenderedImage 的任意区域。
int | getHeight() 返回 RenderedImage 的高度。
int | getMinTileX() 返回 X 方向的最小 tile 索引。
int | getMinTileY() 返回 Y 方向的最小 tile 索引。
int | getMinX() 返回 RenderedImage 的最小 X 坐标（包括）。
int | getMinY() 返回 RenderedImage 的最小 Y 坐标（包括）。
int | getNumXTiles() 返回 X 方向的 tile 数量。
int | getNumYTiles() 返回 Y 方向的 tile 数量。
Object | getProperty(String name) 从此图像的属性设置中获取一个属性。
String[] | getPropertyNames() 返回由 getProperty(String) 识别的名称的数组，如果没有属性名被识别，则返回 null。
SampleModel | getSampleModel() 返回与此图像相关的 SampleModel。
Vector<RenderedImage> | getSources() 返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。
Raster | getTile(int tileX, int tileY) 返回 tile (tileX, tileY)。
int | getTileGridXOffset() 返回 tile 网格相对于原点的 X 偏移量，即 tile (0, 0) 左上角像素的 X 坐标。
int | getTileGridYOffset() 返回 tile 网格相对于原点的 Y 偏移量，即 tile (0, 0) 左上角像素的 Y 坐标。
int | getTileHeight() 返回 tile 的高度，以像素为单位。
int | getTileWidth() 返回 tile 的宽度，以像素为单位。
int | getWidth() 返回 RenderedImage 的宽度。

方法详细信息

getSources

Vector<RenderedImage> getSources()
返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。如果 RenderedImage 对象没有关于其直接源的信息，则此方法返回 null。如果 RenderedImage 对象没有直接源，则返回一个空向量。

返回：
RenderedImage 对象的一个 Vector。

getProperty

Object getProperty(String name)
从此图像的属性设置中获取一个属性。属性的设置以及它是否不可变由正在实现的类确定。如果此 RenderedImage 没有定义指定属性，则此方法返回 java.awt.Image.UndefinedProperty。

参数：
name - 属性名
返回：
由指定名称指示的属性。
另请参见：
Image.UndefinedProperty

getPropertyNames

String[] getPropertyNames()
返回由 getProperty(String) 识别的名称的数组，如果没有属性名被识别，则返回 null。

返回：
包含 getProperty(String) 识别的所有属性名的 String 数组；如果没有属性名被识别，则返回 null。

getColorModel

ColorModel getColorModel()
返回与此图像相关的 ColorModel。所有从此图像返回的 Raster 都将该 ColorModel 作为其 ColorModel。此方法可以返回 null。

返回：
此图像的 ColorModel。

getSampleModel

SampleModel getSampleModel()
返回与此图像相关的 SampleModel。所有从此图像返回的 Raster 都将该 SampleModel 作为其 SampleModel。

返回：
此图像的 SampleModel。

getWidth

int getWidth()
返回 RenderedImage 的宽度。

返回：
此 RenderedImage 的宽度。

getHeight

int getHeight()
返回 RenderedImage 的高度。

返回：
此 RenderedImage 的高度。

getMinX

int getMinX()
返回 RenderedImage 的最小 X 坐标（包括）。

返回：
此 RenderedImage 的 X 坐标。

getMinY

int getMinY()
返回 RenderedImage 的最小 Y 坐标（包括）。

返回：
此 RenderedImage 的 Y 坐标。

getNumXTiles

int getNumXTiles()
返回 X 方向的 tile 数量。

返回：
X 方向的 tile 数量。

getNumYTiles

int getNumYTiles()
返回 Y 方向的 tile 数量。

返回：
Y 方向的 tile 数量。

getMinTileX

int getMinTileX()
返回 X 方向的最小 tile 索引。

返回：
X 方向的最小 tile 索引。

getMinTileY

int getMinTileY()
返回 Y 方向的最小 tile 索引。

返回：
Y 方向的最小 tile 索引。

getTileWidth

int getTileWidth()
返回 tile 的宽度，以像素为单位。所有 tile 都必须有相同的宽度。

返回：
tile 的宽度，以像素为单位。

getTileHeight

int getTileHeight()
返回 tile 的高度，以像素为单位。所有 tile 都必须有相同的高度。

返回：
tile 的高度，以像素为单位。

getTileGridXOffset

int getTileGridXOffset()
返回 tile 网格相对于原点的 X 偏移量，即 tile (0, 0) 左上角像素的 X 坐标。（注意，实际上可能不存在 tile (0, 0)。）

返回：
tile 网格相对于原点的 X 偏移量。

getTileGridYOffset

int getTileGridYOffset()
返回 tile 网格相对于原点的 Y 偏移量，即 tile (0, 0) 左上角像素的 Y 坐标。（注意，实际上可能不存在 tile (0, 0)。）

返回：
tile 网格相对于原点的 Y 偏移量。

getTile

Raster getTile(int tileX,
               int tileY)
返回 tile (tileX, tileY)。注意，tileX 和 tileY 是 tile 数组中的索引，不是像素位置。返回的 Raster 是活动的，随图像更改而更新。

参数：
tileX - tile 数组中请求 tile 的 X 索引
tileY - tile 数组中请求 tile 的 Y 索引
返回：
已给出指定索引的 tile。

getData

Raster getData()
以一个大 tile 的形式返回图像（对于基于 tile 的图像，此方法需要获取整个图像并复制全部图像数据）。返回的 Raster 是图像数据的副本，不会随图像更改而更新。

返回：
以一个大 tile 的形式返回图像。

getData

Raster getData(Rectangle rect)
计算并返回 RenderedImage 的任意区域。返回的 Raster 是图像数据的副本，不会随图像更改而更新。

参数：
rect - 要返回的 RenderedImage 的区域。
返回：
指定 Rectangle 指示的 RenderedImage 的区域。

copyData

WritableRaster copyData(WritableRaster raster)
计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。要计算的区域根据提供的 WritableRaster 的边界确定。提供的 WritableRaster 必须有一个与此图像兼容的 SampleModel。如果 raster 为 null，则创建一个合适的 WritableRaster。

参数：
raster - 保存图像返回部分的 WritableRaster，或者为 null。
返回：
对提供的或创建的 WritableRaster 的引用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReplicateScaleFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ReplicateScaleFilter

java.lang.Object
    继承者  java.awt.image.ImageFilter
        继承者  java.awt.image.ReplicateScaleFilter
所有已实现的接口：
ImageConsumer, Cloneable
直接已知子类：
AreaAveragingScaleFilter
public class ReplicateScaleFilter
extends ImageFilter

使用最简单的算法缩放图像的 ImageFilter 类。此类扩展基本的 ImageFilter Class，以缩放现有图像，并为包含再采样图像的新图像提供源图像。对源图像中的像素进行采样，以生成指定大小的图像像素，这一过程通过复制像素的行和列来放大或通过忽略像素的行和列来缩小实现。

它要与 FilteredImageSource 对象结合使用以生成现有图像的缩放图像。因为它是与实现相关的，所以在不同平台上过滤的图像像素值可能有所不同。

另请参见：
FilteredImageSource, ImageFilter

字段摘要
protected int | destHeight 缩放图像的目标高度。
protected int | destWidth 缩放图像的目标宽度。
protected Object | outpixbuf 使用 destWidth 的大小初始化的 byte 数组，用于将像素数据行传递给 ImageConsumer。
protected int[] | srccols 包含关于像素列信息的 int 数组。
protected int | srcHeight 源图像的高度。
protected int[] | srcrows 包含关于像素行信息的 int 数组。
protected int | srcWidth 源图像的宽度。
从类 java.awt.image.ImageFilter 继承的字段
consumer
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
ReplicateScaleFilter(int width, int height)
构造一个根据 width 和 height 参数指定的源 Image 来缩放像素的 ReplicateScaleFilter。
方法摘要
void | setDimensions(int w, int h) 覆盖源像素的尺寸，并将缩放后的新尺寸传递给 ImageConsumer。
void | setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 从传递的 byte pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
void | setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 从传递的 int pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
void | setProperties(Hashtable<?,?> props) 在添加一个指示所应用的缩放比例的属性后传递来自源对象的属性。
从类 java.awt.image.ImageFilter 继承的方法
clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setColorModel, setHints
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

srcWidth

protected int srcWidth
源图像的宽度。

srcHeight

protected int srcHeight
源图像的高度。

destWidth

protected int destWidth
缩放图像的目标宽度。

destHeight

protected int destHeight
缩放图像的目标高度。

srcrows

protected int[] srcrows
包含关于像素行信息的 int 数组。

srccols

protected int[] srccols
包含关于像素列信息的 int 数组。

outpixbuf

protected Object outpixbuf
使用 destWidth 的大小初始化的 byte 数组，用于将像素数据行传递给 ImageConsumer。

构造方法详细信息

ReplicateScaleFilter

public ReplicateScaleFilter(int width,
                            int height)
构造一个根据 width 和 height 参数指定的源 Image 来缩放像素的 ReplicateScaleFilter。

参数：
width - 缩放图像的目标宽度
height - 缩放图像的目标高度
抛出：
IllegalArgumentException - 如果 width 等于零或 height 等于零
方法详细信息

setProperties

public void setProperties(Hashtable<?,?> props)
在添加一个指示所应用的缩放比例的属性后传递来自源对象的属性。此方法调用 super.setProperties，这可能导致添加额外的属性。

注：此方法应由其像素正被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setProperties
覆盖：
类 ImageFilter 中的 setProperties
参数：
props - 来自源对象的属性

setDimensions

public void setDimensions(int w,
                          int h)
覆盖源像素的尺寸，并将缩放后的新尺寸传递给 ImageConsumer。

注：此方法应由其像素正被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setDimensions
覆盖：
类 ImageFilter 中的 setDimensions
参数：
w - 源图像的宽度
h - 源图像的高度
另请参见：
ImageConsumer

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
从传递的 byte pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。

注：此方法应由其像素正被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
从传递的 int pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。

注：此方法应由其像素正被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ImageConsumer.setPixels(int, int, int, int, java.awt.image.ColorModel, byte[], int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RescaleOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 RescaleOp

java.lang.Object
    继承者  java.awt.image.RescaleOp
所有已实现的接口：
BufferedImageOp, RasterOp
public class RescaleOp
extends Object
implements BufferedImageOp, RasterOp

通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。缩放后的样本值被限制在目标图像中的最小/最大可表示形式。

重缩放操作的伪代码如下：

for each pixel from Source object {
    for each band/component of the pixel {
        dstElement = (srcElement*scaleFactor) + offset
    }
}

对于 Raster，重缩放在 band 上运行。缩放常量集合的数量可能为 1，在这种情况下，对所有 band 都应用相同的常量，或者该数量必须等于 Source Raster band 的数量。

对于 BufferedImage，重缩放在颜色和 alpha 分量上进行。缩放常量集合的数量可能为 1，在这种情况下，对所有颜色（但不包括 alpha）分量应用相同的常量。否则，缩放常量集合的数量必须等于 Source 颜色分量，在这种情况下，不对 alpha 分量（如果存在）执行重缩放。如果这两种情况都不适用，则缩放常量集合的数量必须等于 Source 颜色分量加上 alpha 分量的数量，在这种情况下，要对所有颜色和 alpha 分量都执行重缩放。

无论所 band 数据是否自左乘 alpha，对于 BufferedImage 源执行重缩放的方式都是相同的。也就是说，无论数据是否自左乘 alpha，在 BufferedImage 源的原始数据的每个 band 上都执行重缩放。如果需要将颜色转换到目标 ColorModel，则该步骤要考虑源和目标的自左乘状态。

不能重缩放具有 IndexColorModel 的图像。

如果在构造方法中定义了 RenderingHints 对象，当需要颜色转换时，可以使用颜色呈现提示和抖动提示。

注意，允许进行 in-place 操作（也就是说，源和目标可以是相同的对象）。

另请参见：
RenderingHints.KEY_COLOR_RENDERING, RenderingHints.KEY_DITHERING

构造方法摘要
RescaleOp(float[] scaleFactors, float[] offsets, RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
RescaleOp(float scaleFactor, float offset, RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
方法摘要
BufferedImage | createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经检查的目标图像。
WritableRaster | createCompatibleDestRaster(Raster src) 在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。
BufferedImage | filter(BufferedImage src, BufferedImage dst) 对源 BufferedImage 进行重缩放。
WritableRaster | filter(Raster src, WritableRaster dst) 对源 Raster 中的像素数据进行重缩放。
Rectangle2D | getBounds2D(BufferedImage src) 返回重缩放后的目标图像的边界框。
Rectangle2D | getBounds2D(Raster src) 返回重缩放后的目标 Raster 的边界框。
int | getNumFactors() 返回此 RescaleOp 中使用的缩放因子和偏移量的数量。
float[] | getOffsets(float[] offsets) 返回给定数组中的偏移量。
Point2D | getPoint2D(Point2D srcPt, Point2D dstPt) 给定源中的一个点，返回对应目标点的位置。
RenderingHints | getRenderingHints() 返回此操作的呈现提示。
float[] | getScaleFactors(float[] scaleFactors) 返回给定数组中的缩放因子。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RescaleOp

public RescaleOp(float[] scaleFactors,
                 float[] offsets,
                 RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。scaleFactor 和 offset 数组的长度必须满足上述类注释中规定的限制。RenderingHints 参数可以为 null。

参数：
scaleFactors - 指定的缩放因子
offsets - 指定的偏移量
hints - 指定的 RenderingHints 或 null

RescaleOp

public RescaleOp(float scaleFactor,
                 float offset,
                 RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。scaleFactor 和 offset 在源 Raster 中将应用于所有 band，在 BufferedImage 中将应用于所有颜色（但不包括 alpha）分量。RenderingHints 参数可以为 null。

参数：
scaleFactor - 指定的缩放因子
offset - 指定的偏移量
hints - 指定的 RenderingHints 或 null
方法详细信息

getScaleFactors

public final float[] getScaleFactors(float[] scaleFactors)
返回给定数组中的缩放因子。为方便起见，也返回数组。如果 scaleFactors 为 null，则分配一个新数组。

参数：
scaleFactors - 包含此 RescaleOp 的缩放因子的数组
返回：
此 RescaleOp 的缩放因子。

getOffsets

public final float[] getOffsets(float[] offsets)
返回给定数组中的偏移量。为方便起见，也返回数组。如果 offset 为 null，则分配一个新数组。

参数：
offsets - 包含此 RescaleOp 的偏移量的数组
返回：
此 RescaleOp 的偏移量。

getNumFactors

public final int getNumFactors()
返回此 RescaleOp 中使用的缩放因子和偏移量的数量。

返回：
此 RescaleOp 的缩放因子和偏移量的数量。

filter

public final BufferedImage filter(BufferedImage src,
                                  BufferedImage dst)
对源 BufferedImage 进行重缩放。如果源图像中的颜色模型与目标图像中的不同，则在目标中转换像素。如果目标图像为 null，则使用源 ColorModel 创建一个 BufferedImage。如果此对象中缩放因子/偏移量的数量不符合上述类注释中规定的限制，或者源图像有一个 IndexColorModel，则可能抛出 IllegalArgumentException。

指定者：
接口 BufferedImageOp 中的 filter
参数：
src - 要过滤的 BufferedImage
dst - 过滤操作的目标或 null
返回：
过滤的 BufferedImage。
抛出：
IllegalArgumentException - 如果 src 的 ColorModel 是一个 IndexColorModel，或者此 RescaleOp 中缩放因子和偏移量的数量不符合上述类注释中规定的限制。

filter

public final WritableRaster filter(Raster src,
                                   WritableRaster dst)
对源 Raster 中的像素数据进行重缩放。如果目标 Raster 为 null，则创建一个新 Raster。源和目标必须具有相同的 band 数。否则抛出 IllegalArgumentException。注意，此对象中缩放因子/偏移量的数量必须满足上述类注释中规定的限制。否则抛出 IllegalArgumentException。

指定者：
接口 RasterOp 中的 filter
参数：
src - 要过滤的 Raster
dst - 过滤操作的目标或 null
返回：
过滤的 WritableRaster。
抛出：
IllegalArgumentException - 如果 src 和 dst 没有相同的 band 数，或者此 RescaleOp 中缩放因子和偏移量的数量不符合上述类注释中规定的限制。

getBounds2D

public final Rectangle2D getBounds2D(BufferedImage src)
返回重缩放后的目标图像的边界框。因为这不是一个几何操作，所以边界框不会改变。

指定者：
接口 BufferedImageOp 中的 getBounds2D
参数：
src - 要过滤的 BufferedImage
返回：
表示目标图像边界框的 Rectangle2D。

getBounds2D

public final Rectangle2D getBounds2D(Raster src)
返回重缩放后的目标 Raster 的边界框。因为这不是一个几何操作，所以边界框不会改变。

指定者：
接口 RasterOp 中的 getBounds2D
参数：
src - 重缩放后的目标 Raster
返回：
指定 Raster 的边界。

createCompatibleDestImage

public BufferedImage createCompatibleDestImage(BufferedImage src,
                                               ColorModel destCM)
创建一个具有正确大小和 band 数的经检查的目标图像。

指定者：
接口 BufferedImageOp 中的 createCompatibleDestImage
参数：
src - 过滤操作的源图像。
destCM - 目标的 ColorModel。如果为 null，则使用源的 ColorModel。
返回：
经检查的目标图像。

createCompatibleDestRaster

public WritableRaster createCompatibleDestRaster(Raster src)
在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。

指定者：
接口 RasterOp 中的 createCompatibleDestRaster
参数：
src - 源 Raster
返回：
经检查的目标 Raster。

getPoint2D

public final Point2D getPoint2D(Point2D srcPt,
                                Point2D dstPt)
给定源中的一个点，返回对应目标点的位置。如果 dstPt 为非 null，则使用它保存返回值。因为这不是一个几何操作，所以 srcPt 将等于 dstPt。

指定者：
接口 BufferedImageOp 中的 getPoint2D
指定者：
接口 RasterOp 中的 getPoint2D
参数：
srcPt - 源图像中的一个点
dstPt - 目标点或 null
返回：
目标点的位置。

getRenderingHints

public final RenderingHints getRenderingHints()
返回此操作的呈现提示。

指定者：
接口 BufferedImageOp 中的 getRenderingHints
指定者：
接口 RasterOp 中的 getRenderingHints
返回：
此 RescaleOp 的呈现提示。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RGBImageFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 RGBImageFilter

java.lang.Object
    继承者  java.awt.image.ImageFilter
        继承者  java.awt.image.RGBImageFilter
所有已实现的接口：
ImageConsumer, Cloneable
直接已知子类：
GrayFilter
public abstract class RGBImageFilter
extends ImageFilter

此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。这意味着要与 FilteredImageSource 对象结合使用来生成现有图像的过滤形式。该类是一个抽象类，它提供引导所有像素数据通过单独某个方法所需的调用，其中，无论 ImageProducer 正使用何种 ColorModel，该方法每次都会转换默认 RGB ColorModel 中的一个像素。创建可用图像过滤器需要定义的惟一方法是 filterRGB 方法。以下是定义交换图像中红色分量和蓝色分量过滤器的一个例子：

        class RedBlueSwapFilter extends RGBImageFilter {
            public RedBlueSwapFilter() {
                // The filter's operation does not depend on the
                // pixel's location, so IndexColorModels can be
                // filtered directly.
                canFilterIndexColorModel = true;
            }

            public int filterRGB(int x, int y, int rgb) {
                return ((rgb & 0xff00ff00)
                        | ((rgb & 0xff0000) >> 16)
                        | ((rgb & 0xff) << 16));
            }
        }

另请参见：
FilteredImageSource, ImageFilter, ColorModel.getRGBdefault()

字段摘要
protected boolean | canFilterIndexColorModel 此布尔值指示是否可以接受用 filterRGB 方法的颜色过滤替代逐像素过滤，并应用于 IndexColorModel 对象的颜色表项。
protected ColorModel | newmodel 用户调用 substituteColorModel 时替换 origmodel 的 ColorModel。
protected ColorModel | origmodel 用户调用 substituteColorModel 时将由 newmodel 替换的 ColorModel。
从类 java.awt.image.ImageFilter 继承的字段
consumer
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
RGBImageFilter()
方法摘要
IndexColorModel | filterIndexColorModel(IndexColorModel icm) 过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。
abstract int | filterRGB(int x, int y, int rgb) 子类必须指定该方法，以将使用默认 RGB ColorModel 的单个输入像素转换成单个输出像素。
void | filterRGBPixels(int x, int y, int w, int h, int[] pixels, int off, int scansize) 过滤缓冲区中使用默认 RGB ColorModel 的像素：将其一个接一个地传递给 filterRGB 方法。
void | setColorModel(ColorModel model) 如果 ColorModel 是 IndexColorModel 且子类将 canFilterIndexColorModel 标志设置为 true，则将此处及 setPixels 方法中任何出现原始 ColorModel 对象的地方替换为过滤后的颜色模型。
void | setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素。
void | setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素，否则，将整数像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法进行逐一转换。
void | substituteColorModel(ColorModel oldcm, ColorModel newcm) 注册两个用于替换的 ColorModel 对象。
从类 java.awt.image.ImageFilter 继承的方法
clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setDimensions, setHints, setProperties
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

origmodel

protected ColorModel origmodel
用户调用 substituteColorModel 时将由 newmodel 替换的 ColorModel。

newmodel

protected ColorModel newmodel
用户调用 substituteColorModel 时替换 origmodel 的 ColorModel。

canFilterIndexColorModel

protected boolean canFilterIndexColorModel
此布尔值指示是否可以接受用 filterRGB 方法的颜色过滤替代逐像素过滤，并应用于 IndexColorModel 对象的颜色表项。如果子类的 filterRGB 方法不依赖过滤像素的坐标，则子类应在其构造方法中将此变量设置为 true。

另请参见：
substituteColorModel(java.awt.image.ColorModel, java.awt.image.ColorModel), filterRGB(int, int, int), IndexColorModel
构造方法详细信息

RGBImageFilter

public RGBImageFilter()
方法详细信息

setColorModel

public void setColorModel(ColorModel model)
如果 ColorModel 是 IndexColorModel 且子类将 canFilterIndexColorModel 标志设置为 true，则将此处及 setPixels 方法中任何出现原始 ColorModel 对象的地方替换为过滤后的颜色模型。如果 ColorModel 不是 IndexColorModel 或者为 null，则此方法重写由 ImageProducer 使用的默认 ColorModel，并指定默认 RGB ColorModel。

注：此方法应由其像素将被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setColorModel
覆盖：
类 ImageFilter 中的 setColorModel
参数：
model - 指定的 ColorModel
另请参见：
ImageConsumer, ColorModel.getRGBdefault()

substituteColorModel

public void substituteColorModel(ColorModel oldcm,
                                 ColorModel newcm)
注册两个用于替换的 ColorModel 对象。如果在运行 setPixels 方法期间遇到 oldcm，则用 newcm 替换它，并不加变动地传递像素（但使用新的 ColorModel 对象）。

参数：
oldcm - 要被动态替换的 ColorModel 对象
newcm - 要动态替换 oldcm 的 ColorModel 对象

filterIndexColorModel

public IndexColorModel filterIndexColorModel(IndexColorModel icm)
过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。使用坐标 -1 指示将过滤的是颜色表项，而不是实际像素值。

参数：
icm - 要过滤的 IndexColorModel 对象
返回：
表示已过滤颜色的新 IndexColorModel
抛出：
NullPointerException - 如果 icm 为 null

filterRGBPixels

public void filterRGBPixels(int x,
                            int y,
                            int w,
                            int h,
                            int[] pixels,
                            int off,
                            int scansize)
过滤缓冲区中使用默认 RGB ColorModel 的像素：将其一个接一个地传递给 filterRGB 方法。

参数：
x - 像素区域左上角的 X 坐标
y - 像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - 数组中从一行像素到下一行像素的距离
另请参见：
ColorModel.getRGBdefault(), filterRGB(int, int, int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      byte[] pixels,
                      int off,
                      int scansize)
如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素。否则，将字节像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法进行逐一转换。

注：此方法应由其像素将被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ColorModel.getRGBdefault(), filterRGBPixels(int, int, int, int, int[], int, int)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      ColorModel model,
                      int[] pixels,
                      int off,
                      int scansize)
如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素，否则，将整数像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法进行逐一转换。将整数像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法。

注：此方法应由其像素将被过滤的 Image 的 ImageProducer 调用。使用此类过滤图像像素的开发人员应该避免直接调用此方法，因为该操作可能干扰过滤操作。

指定者：
接口 ImageConsumer 中的 setPixels
覆盖：
类 ImageFilter 中的 setPixels
参数：
x - 要设置的像素区域左上角的 X 坐标
y - 要设置的像素区域左上角的 Y 坐标
w - 像素区域的宽度
h - 像素区域的高度
model - 指定的 ColorModel
pixels - 像素数组
off - pixels 数组中的偏移量
scansize - pixels 数组中一行像素到下一行的距离
另请参见：
ColorModel.getRGBdefault(), filterRGBPixels(int, int, int, int, int[], int, int)

filterRGB

public abstract int filterRGB(int x,
                              int y,
                              int rgb)
子类必须指定该方法，以将使用默认 RGB ColorModel 的单个输入像素转换成单个输出像素。

参数：
x - 像素的 X 坐标
y - 像素的 Y 坐标
rgb - 使用默认 RGB 颜色模型的整数像素表示
返回：
使用默认 RGB 颜色模型的过滤后的像素。
另请参见：
ColorModel.getRGBdefault(), filterRGBPixels(int, int, int, int, int[], int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SampleModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 SampleModel

java.lang.Object
    继承者  java.awt.image.SampleModel
直接已知子类：
ComponentSampleModel, MultiPixelPackedSampleModel, SinglePixelPackedSampleModel
public abstract class SampleModel
extends Object

此抽象类定义一个提取图像像素样本的接口。所有图像数据都被表示成一个像素集合。每个像素由多个样本组成。样本是一个图像 band 的基本数据，band 由图像中某一特定类型的所有样本组成。例如，一个像素可能包含三个样本，分别表示红、绿、蓝的分量。在包含此相素的图像中有三个 band。其中一个 band 由图像中所有像素的红色样本组成。第二个 band 由所有绿色样本组成，第三个 band 由所有蓝色样本组成。像素可以以各种格式存储。例如，特定 band 中的所有样本可以连续存储，单个像素的所有样本也可以连续存储。

SampleModel 的子类指定它们能够表示的样本类型（例如，无符号 8 位 byte、有符号 16 位 short 等），并且可以指定如何在内存中组织样本。在 Java 2D(tm) API 中，内置的图像处理运算符可能无法处理所有可能的样本类型，但通常可以处理 16 位或 16 位以下的无符号整数样本。某些运算符支持更大范围的样本类型。

像素的集合被表示为一个 Raster，它由 DataBuffer 和 SampleModel 组成。SampleModel 允许访问 DataBuffer 中的样本，并提供程序员可以用来直接操作 DataBuffer 中样本和像素的低级别信息。

此类通常是处理图像的一个回调方法。更为有效的代码将 SampleModel 强行转换为适当的子类，并提取直接操作 DataBuffer 中的像素所需的信息。

另请参见：
DataBuffer, Raster, ComponentSampleModel, PixelInterleavedSampleModel, BandedSampleModel, MultiPixelPackedSampleModel, SinglePixelPackedSampleModel

字段摘要
protected int | dataType 存储像素数据的 DataBuffer 的数据类型。
protected int | height 此 SampleModel 描述的图像数据区域的高度（以像素位单位）。
protected int | numBands 此 SampleModel 描述的图像数据的 band 数。
protected int | width 此 SampleModel 描述的图像数据区域的宽度（以像素位单位）。
构造方法摘要
SampleModel(int dataType, int w, int h, int numBands)
构造一个具有指定参数的 SampleModel。
方法摘要
abstract SampleModel | createCompatibleSampleModel(int w, int h) 创建一个用此 SampleModel 的格式描述数据，但宽度和高度不同的 SampleModel。
abstract DataBuffer | createDataBuffer() 创建一个对应于此 SampleModel 的 DataBuffer。
abstract SampleModel | createSubsetSampleModel(int[] bands) 创建一个新 SampleModel，它具有此 SampleModel 的 band 子集。
Object | getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data) 在 TransferType 类型基本数组中返回指定像素矩形的像素数据。
abstract Object | getDataElements(int x, int y, Object obj, DataBuffer data) 在 TransferType 类型的基本数组中返回单个像素的数据。
int | getDataType() 返回存储像素数据的 DataBuffer 的数据类型。
int | getHeight() 返回像素高度。
int | getNumBands() 返回图像数据的总 band 数。
abstract int | getNumDataElements() 返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
double[] | getPixel(int x, int y, double[] dArray, DataBuffer data) 在一个 double 数组中返回指定像素的样本。
float[] | getPixel(int x, int y, float[] fArray, DataBuffer data) 在一个 float 数组中返回指定像素的样本。
int[] | getPixel(int x, int y, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定像素的样本，每个数组元素对应一个样本。
double[] | getPixels(int x, int y, int w, int h, double[] dArray, DataBuffer data) 在一个 double 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
float[] | getPixels(int x, int y, int w, int h, float[] fArray, DataBuffer data) 在一个 float 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
int[] | getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在一个 int 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
abstract int | getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double[] | getSamples(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data) 在一个 double 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
float[] | getSamples(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data) 在一个 float 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int[] | getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
abstract int[] | getSampleSize() 返回所有 band 样本的大小（以位为单位）。
abstract int | getSampleSize(int band) 返回指定 band 样本的大小（以位为单位）。
int | getTransferType() 返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。
int | getWidth() 返回像素宽度。
void | setDataElements(int x, int y, int w, int h, Object obj, DataBuffer data) 根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。
abstract void | setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | setPixel(int x, int y, double[] dArray, DataBuffer data) 使用输入的 double 样本数组设置 DataBuffer 中的像素。
void | setPixel(int x, int y, float[] fArray, DataBuffer data) 使用输入的 float 样本数组设置 DataBuffer 中的像素。
void | setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入的 int 样本数组设置 DataBuffer 中的像素。
void | setPixels(int x, int y, int w, int h, double[] dArray, DataBuffer data) 根据 double 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | setPixels(int x, int y, int w, int h, float[] fArray, DataBuffer data) 根据 float 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
abstract void | setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | setSamples(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data) 根据 double 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | setSamples(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data) 根据 float 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

width

protected int width
此 SampleModel 描述的图像数据区域的宽度（以像素位单位）。

height

protected int height
此 SampleModel 描述的图像数据区域的高度（以像素位单位）。

numBands

protected int numBands
此 SampleModel 描述的图像数据的 band 数。

dataType

protected int dataType
存储像素数据的 DataBuffer 的数据类型。

另请参见：
DataBuffer
构造方法详细信息

SampleModel

public SampleModel(int dataType,
                   int w,
                   int h,
                   int numBands)
构造一个具有指定参数的 SampleModel。

参数：
dataType - 存储像素数据的 DataBuffer 的数据类型。
w - 图像数据区域的宽度（以像素为单位）。
h - 图像数据区域的高度（以像素为单位）。
numBands - 图像数据的 band 数。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0
IllegalArgumentException - 如果 w 和 h 的乘积大于 Integer.MAX_VALUE
IllegalArgumentException - 如果 dataType 不是受支持的数据类型之一
方法详细信息

getWidth

public final int getWidth()
返回像素宽度。

返回：
此 SampleModel 描述的图像数据区域的宽度（以像素为单位）。

getHeight

public final int getHeight()
返回像素高度。

返回：
此 SampleModel 描述的图像数据区域的高度（以像素为单位）。

getNumBands

public final int getNumBands()
返回图像数据的总 band 数。

返回：
此 SampleModel 描述的图像数据的 band 数。

getNumDataElements

public abstract int getNumDataElements()
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。当通过这些方法传输像素时，可以使用压缩或非压缩格式，具体取决于 SampleModel 的实现。使用这些方法，像素就可以作为基本类型的 getNumDataElements() 元素数组传输，基本类型由 getTransferType() 给定。TransferType 可以与 DataType 的存储数据类型相同，也可以不同。

返回：
数据元素的数量。
另请参见：
getDataElements(int, int, Object, DataBuffer),
getDataElements(int, int, int, int, Object, DataBuffer),
setDataElements(int, int, Object, DataBuffer),
setDataElements(int, int, int, int, Object, DataBuffer),
getTransferType()

getDataType

public final int getDataType()
返回存储像素数据的 DataBuffer 的数据类型。

返回：
数据类型。

getTransferType

public int getTransferType()
返回通过 getDataElements 和 setDataElements 方法传输像素所使用的 TransferType。当通过这些方法传输像素时，可以使用压缩或非压缩格式，具体取决于 SampleModel 的实现。使用这些方法，像素就可以作为基本类型的 getNumDataElements() 元素数组传输，基本类型由 getTransferType() 给定。TransferType 可以与 DataType 的存储数据类型相同，也可以不同。TransferType 将是 DataBuffer 中定义的类型之一。

返回：
传输类型。
另请参见：
getDataElements(int, int, Object, DataBuffer),
getDataElements(int, int, int, int, Object, DataBuffer),
setDataElements(int, int, Object, DataBuffer),
setDataElements(int, int, int, int, Object, DataBuffer),
getNumDataElements(),
DataBuffer

getPixel

public int[] getPixel(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
在一个 int 数组中返回指定像素的样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标
y - 像素位置的 Y 坐标
iArray - 如果不为 null，则在此数组中返回样本
data - 包含图像数据的 DataBuffer
返回：
指定像素的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 iArray 太小而不能容纳输出。
另请参见：
setPixel(int, int, int[], DataBuffer)

getDataElements

public abstract Object getDataElements(int x,
                                       int y,
                                       Object obj,
                                       DataBuffer data)
在 TransferType 类型的基本数组中返回单个像素的数据。对于 Java 2D API 所支持的图像数据，这将是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 中的一个。可以使用压缩格式返回数据，从而提高数据传输的效率。通常，obj 应作为 null 传入，从而 Object 将被自动创建，并具有正确的基本数据类型。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 SampleModel sm1 描述）传输到 DataBuffer db2（其存储布局由 SampleModel sm2 描述）。该传输通常比使用 getPixel/setPixel 更有效。

             SampleModel sm1, sm2;
             DataBuffer db1, db2;
             sm2.setDataElements(x, y, sm1.getDataElements(x, y, null, db1), db2);
如果两个 SampleModel 具有相同的 band 数量，相应 band 的每个样本具有相同的位数，且 TransferType 相同，则使用 getDataElements/setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

如果 obj 不为 null，则它应是 TransferType 类型的基本数组。否则抛出 ClassCastException。如果坐标不在边界内，或者 obj 不为 null 且大小不足以保存像素数据，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
obj - 如果不为 null，则 obj 是接收返回像素数据的基本数组。
data - 包含图像数据的 DataBuffer。
返回：
指定像素的数据元素。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 obj 太小而不能容纳输出。
另请参见：
getNumDataElements(), getTransferType(), DataBuffer, setDataElements(int, int, Object, DataBuffer)

getDataElements

public Object getDataElements(int x,
                              int y,
                              int w,
                              int h,
                              Object obj,
                              DataBuffer data)
在 TransferType 类型基本数组中返回指定像素矩形的像素数据。对于 Java 2D API 所支持的图像数据，这将是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 中的一个。可以使用压缩格式返回数据，从而提高数据传输的效率。通常，obj 作为 null 传入，从而 Object 将被自动创建，并具有正确的基本数据类型。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 SampleModel sm1 描述）传输到 DataBuffer db2（其存储布局由 SampleModel sm2 描述）。该传输通常比使用 getPixels/setPixels 更有效。

             SampleModel sm1, sm2;
             DataBuffer db1, db2;
             sm2.setDataElements(x, y, w, h, sm1.getDataElements(x, y, w,
                           h, null, db1), db2);
如果两个 SampleModel 具有相同的 band 数量，相应 band 的每个样本具有相同的位数，且 TransferType 相同，则使用 getDataElements/setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

如果 obj 不为 null，则它应是 TransferType 类型的基本数组。否则抛出 ClassCastException。如果坐标不在边界内，或者 obj 不为 null 且大小不足以保存像素数据，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素矩形的最小 X 坐标。
y - 像素矩形的最小 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
obj - 如果不为 null，则 obj 是接收返回像素数据的基本数组。
data - 包含图像数据的 DataBuffer。
返回：
指定像素区域的数据元素。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 obj 太小而不能容纳输出。
另请参见：
getNumDataElements(),
getTransferType(),
setDataElements(int, int, int, int, Object, DataBuffer),
DataBuffer

setDataElements

public abstract void setDataElements(int x,
                                     int y,
                                     Object obj,
                                     DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。对于 Java 2D API 所支持的图像数据，这将是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 中的一个。数组中的数据可以是压缩格式，从而提高数据传输的效率。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 SampleModel sm1 描述）传输到 DataBuffer db2（其存储布局由 SampleModel sm2 描述）。该传输通常比使用 getPixel/setPixel 更有效。

             SampleModel sm1, sm2;
             DataBuffer db1, db2;
             sm2.setDataElements(x, y, sm1.getDataElements(x, y, null, db1),
                           db2);
如果两个 SampleModel 具有相同的 band 数量，相应 band 的每个样本具有相同的位数，且 TransferType 相同，则使用 getDataElements/setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

obj 必须是 TransferType 类型的基本数组。否则抛出 ClassCastException。如果坐标不在边界内，或者 obj 的大小不足以容纳像素数据，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
obj - 包含像素数据的基本数组。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 obj 太小而不能容纳输入。
另请参见：
getNumDataElements(),
getTransferType(),
getDataElements(int, int, Object, DataBuffer),
DataBuffer

setDataElements

public void setDataElements(int x,
                            int y,
                            int w,
                            int h,
                            Object obj,
                            DataBuffer data)
根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。对于 Java 2D API 所支持的图像数据，这将是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 中的一个。数组中的数据可以是压缩格式，从而提高数据传输的效率。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 SampleModel sm1 描述）传输到 DataBuffer db2（其存储布局由 SampleModel sm2 描述）。该传输通常比使用 getPixels/setPixels 更有效。

             SampleModel sm1, sm2;
             DataBuffer db1, db2;
             sm2.setDataElements(x, y, w, h, sm1.getDataElements(x, y, w, h,
                           null, db1), db2);
如果两个 SampleModel 具有相同的 band 数量，相应 band 的每个样本具有相同的位数，且 TransferType 相同，则使用 getDataElements/setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

obj 必须是 TransferType 类型的基本数组。否则抛出 ClassCastException。如果坐标不在边界内，或者 obj 的大小不足以容纳像素数据，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素矩形的最小 X 坐标。
y - 像素矩形的最小 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
obj - 包含像素数据的基本数组。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 obj 太小而不能容纳输入。
另请参见：
getNumDataElements(),
getTransferType(),
getDataElements(int, int, int, int, Object, DataBuffer),
DataBuffer

getPixel

public float[] getPixel(int x,
                        int y,
                        float[] fArray,
                        DataBuffer data)
在一个 float 数组中返回指定像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
fArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定像素的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 fArray 太小而不能容纳输出。
另请参见：
setPixel(int, int, float[], DataBuffer)

getPixel

public double[] getPixel(int x,
                         int y,
                         double[] dArray,
                         DataBuffer data)
在一个 double 数组中返回指定像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
dArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定像素的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 dArray 太小而不能容纳输出。
另请参见：
setPixel(int, int, double[], DataBuffer)

getPixels

public int[] getPixels(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
在一个 int 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
iArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定像素区域的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 iArray 太小而不能容纳输出。
另请参见：
setPixels(int, int, int, int, int[], DataBuffer)

getPixels

public float[] getPixels(int x,
                         int y,
                         int w,
                         int h,
                         float[] fArray,
                         DataBuffer data)
在一个 float 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
fArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定像素区域的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 fArray 太小而不能容纳输出。
另请参见：
setPixels(int, int, int, int, float[], DataBuffer)

getPixels

public double[] getPixels(int x,
                          int y,
                          int w,
                          int h,
                          double[] dArray,
                          DataBuffer data)
在一个 double 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
dArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定像素区域的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 dArray 太小而不能容纳输出。
另请参见：
setPixels(int, int, int, int, double[], DataBuffer)

getSample

public abstract int getSample(int x,
                              int y,
                              int b,
                              DataBuffer data)
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要返回的 band。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。
另请参见：
setSample(int, int, int, int, DataBuffer)

getSampleFloat

public float getSampleFloat(int x,
                            int y,
                            int b,
                            DataBuffer data)
以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要返回的 band。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。

getSampleDouble

public double getSampleDouble(int x,
                              int y,
                              int b,
                              DataBuffer data)
以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要返回的 band。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。

getSamples

public int[] getSamples(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要返回的 band。
iArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素区域的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 iArray 太小而不能容纳输出。
另请参见：
setSamples(int, int, int, int, int, int[], DataBuffer)

getSamples

public float[] getSamples(int x,
                          int y,
                          int w,
                          int h,
                          int b,
                          float[] fArray,
                          DataBuffer data)
在一个 float 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要返回的 band。
fArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素区域的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 fArray 太小而不能容纳输出。
另请参见：
setSamples(int, int, int, int, int, float[], DataBuffer)

getSamples

public double[] getSamples(int x,
                           int y,
                           int w,
                           int h,
                           int b,
                           double[] dArray,
                           DataBuffer data)
在一个 double 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要返回的 band。
dArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素区域的样本。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 dArray 太小而不能容纳输出。
另请参见：
setSamples(int, int, int, int, int, double[], DataBuffer)

setPixel

public void setPixel(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
使用输入的 int 样本数组设置 DataBuffer 中的像素。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
iArray - int 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 iArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 iArray 太小而不能容纳输入。
另请参见：
getPixel(int, int, int[], DataBuffer)

setPixel

public void setPixel(int x,
                     int y,
                     float[] fArray,
                     DataBuffer data)
使用输入的 float 样本数组设置 DataBuffer 中的像素。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
fArray - float 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 fArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 fArray 太小而不能容纳输入。
另请参见：
getPixel(int, int, float[], DataBuffer)

setPixel

public void setPixel(int x,
                     int y,
                     double[] dArray,
                     DataBuffer data)
使用输入的 double 样本数组设置 DataBuffer 中的像素。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
dArray - double 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 dArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 fArray 太小而不能容纳输入。
另请参见：
getPixel(int, int, double[], DataBuffer)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
iArray - int 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 iArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 iArray 太小而不能容纳输入。
另请参见：
getPixels(int, int, int, int, int[], DataBuffer)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      float[] fArray,
                      DataBuffer data)
根据 float 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
fArray - float 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 fArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 fArray 太小而不能容纳输入。
另请参见：
getPixels(int, int, int, int, float[], DataBuffer)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      double[] dArray,
                      DataBuffer data)
根据 double 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
dArray - double 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 dArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内，或者 dArray 太小而不能容纳输入。
另请参见：
getPixels(int, int, int, int, double[], DataBuffer)

setSample

public abstract void setSample(int x,
                               int y,
                               int b,
                               int s,
                               DataBuffer data)
使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要设置的 band。
s - int 形式的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。
另请参见：
getSample(int, int, int, DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      float s,
                      DataBuffer data)
使用输入的 float 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。此方法的默认实现将输入 float 样本强制转换为 int 值，然后使用该 int 值调用 setSample(int, int, int, DataBuffer) 方法。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要设置的 band。
s - float 形式的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。
另请参见：
getSample(int, int, int, DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      double s,
                      DataBuffer data)
使用输入的 double 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。此方法的默认实现将输入 double 样本强制转换为 int 值，然后使用该 int 值调用 setSample(int, int, int, DataBuffer) 方法。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要设置的 band。
s - double 形式的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内。
另请参见：
getSample(int, int, int, DataBuffer)

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要设置的 band。
iArray - int 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 iArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 iArray 太小而不能容纳输入。
另请参见：
getSamples(int, int, int, int, int, int[], DataBuffer)

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       float[] fArray,
                       DataBuffer data)
根据 float 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要设置的 band。
fArray - float 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 fArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 fArray 太小而不能容纳输入。
另请参见：
getSamples(int, int, int, int, int, float[], DataBuffer)

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       double[] dArray,
                       DataBuffer data)
根据 double 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要设置的 band。
dArray - double 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
抛出：
NullPointerException - 如果 dArray 或 data 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 dArray 太小而不能容纳输入。
另请参见：
getSamples(int, int, int, int, int, double[], DataBuffer)

createCompatibleSampleModel

public abstract SampleModel createCompatibleSampleModel(int w,
                                                        int h)
创建一个用此 SampleModel 的格式描述数据，但宽度和高度不同的 SampleModel。

参数：
w - 图像数据的宽度
h - 图像数据的高度
返回：
描绘的数据与此 SampleModel 相同，但大小不同的 SampleModel。

createSubsetSampleModel

public abstract SampleModel createSubsetSampleModel(int[] bands)
创建一个新 SampleModel，它具有此 SampleModel 的 band 子集。

参数：
bands - 此 SampleModel 的 band 子集
返回：
具有此 SampleModel band 子集的 SampleModel。

createDataBuffer

public abstract DataBuffer createDataBuffer()
创建一个对应于此 SampleModel 的 DataBuffer。DataBuffer 的宽度和高度将与此 SampleModel 匹配。

返回：
对应于此 SampleModel 的 DataBuffer。

getSampleSize

public abstract int[] getSampleSize()
返回所有 band 样本的大小（以位为单位）。

返回：
所有 band 样本的大小。

getSampleSize

public abstract int getSampleSize(int band)
返回指定 band 样本的大小（以位为单位）。

参数：
band - 指定的 band
返回：
指定 band 样本的大小。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShortLookupTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 ShortLookupTable

java.lang.Object
    继承者  java.awt.image.LookupTable
        继承者  java.awt.image.ShortLookupTable

public class ShortLookupTable
extends LookupTable

此类定义了一个查找表对象。使用此类的对象的查找操作的输出被解释为一个无符号 short 量。查找表包含图像的一个或多个 band（或分量）的 short 型数据数组，并包含在对数组建立索引前将从输入值中减掉的偏移量。这使得数组小于为约束输入提供的本机数据大小。如果查找表中只有一个数组，则将该数组应用于所有 band。

另请参见：
ByteLookupTable, LookupOp

构造方法摘要
ShortLookupTable(int offset, short[] data)
根据表示每个 band 的查找表的 short 型数组构造 ShortLookupTable 对象。
ShortLookupTable(int offset, short[][] data)
根据表示每个 band 的查找表的 short 型数组的数组构造 ShortLookupTable 对象。
方法摘要
short[][] | getTable() 根据引用返回查找表数据。
int[] | lookupPixel(int[] src, int[] dst) 返回一个使用查找表转换后的像素样本数组。
short[] | lookupPixel(short[] src, short[] dst) 返回一个使用查找表转换后的像素样本数组。
从类 java.awt.image.LookupTable 继承的方法
getNumComponents, getOffset
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ShortLookupTable

public ShortLookupTable(int offset,
                        short[][] data)
根据表示每个 band 的查找表的 short 型数组的数组构造 ShortLookupTable 对象。在为数组建立索引前，将从输入值中减去 offset。band 的数量是 data 参数的长度。每个 band 的数据数组都被存储为一个引用。

参数：
offset - 在为数组建立索引前从输入值中减掉的值
data - 表示每个 band 的查找表的 short 型数组的数组

ShortLookupTable

public ShortLookupTable(int offset,
                        short[] data)
根据表示每个 band 的查找表的 short 型数组构造 ShortLookupTable 对象。在为数组建立索引前，将从输入值中减去 offset。数据数组被存储为一个引用。

参数：
offset - 在为数组建立索引前从输入值中减掉的值
data - short 型数组
方法详细信息

getTable

public final short[][] getTable()
根据引用返回查找表数据。如果此 ShortLookupTable 是使用单个 short 型数组构造的，则返回数组的长度为 1。

返回：
ShortLookupTable 数据数组。

lookupPixel

public int[] lookupPixel(int[] src,
                         int[] dst)
返回一个使用查找表转换后的像素样本数组。源数组和目标数组可以是相同数组。返回数组 dst。

指定者：
类 LookupTable 中的 lookupPixel
参数：
src - 源数组。
dst - 目标数组。此数组至少必须和 src 一样长。如果 dst 为 null，则将分配一个长度与 src 相同的新数组。
返回：
数组 dst，它是样本的 int 数组。
抛出：
ArrayIndexOutOfBoundsException - 如果 src 长于 dst，或者对于 src 的任意元素 i，(src[i]&0xffff)-offset 小于零，或者大于或等于任意 band 的查找表长度。

lookupPixel

public short[] lookupPixel(short[] src,
                           short[] dst)
返回一个使用查找表转换后的像素样本数组。源数组和目标数组可以是相同数组。返回数组 dst。

参数：
src - 源数组。
dst - 目标数组。此数组至少必须和 src 一样长。如果 dst 为 null，则将分配一个长度与 src 相同的新数组。
返回：
数组 dst，它是样本的 int 数组。
抛出：
ArrayIndexOutOfBoundsException - 如果 src 长于 dst，或者对于 src 的任意元素 i，(src[i]&0xffff)-offset 小于零，或者大于或等于任意 band 的查找表长度。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SinglePixelPackedSampleModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 SinglePixelPackedSampleModel

java.lang.Object
    继承者  java.awt.image.SampleModel
        继承者  java.awt.image.SinglePixelPackedSampleModel

public class SinglePixelPackedSampleModel
extends SampleModel

此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。此类支持 TYPE_BYTE、TYPE_USHORT 和 TYPE_INT 数据类型。所有数据数组元素都位于 DataBuffer 的第一个存储单元中。该类提供了一些存取方法，以便直接操作图像数据。扫描行间距是给定样本和下一个扫描行同一列中对应样本之间的数据数组元素数。位掩码是提取表示像素 band 样本所需的掩码。位偏移量是样本数据数组元素中位的偏移量，其中样本表示像素的 band。

以下代码说明了如何从 DataBuffer data 中提取表示像素 x,y 处 band b 的样本位：

      int sample = data.getElem(y * scanlineStride + x);
      sample = (sample & bitMasks[b]) >>> bitOffsets[b];

字段摘要
从类 java.awt.image.SampleModel 继承的字段
dataType, height, numBands, width
构造方法摘要
SinglePixelPackedSampleModel(int dataType, int w, int h, int[] bitMasks)
构造一个具有 bitMasks.length band 的 SinglePixelPackedSampleModel。
SinglePixelPackedSampleModel(int dataType, int w, int h, int scanlineStride, int[] bitMasks)
构造一个 SinglePixelPackedSampleModel，使其具有 bitMasks.length band，且扫描行间距等于 scanlineStride 数据数组元素。
方法摘要
SampleModel | createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的新 SinglePixelPackedSampleModel。
DataBuffer | createDataBuffer() 创建一个对应于此 SinglePixelPackedSampleModel 的 DataBuffer。
SampleModel | createSubsetSampleModel(int[] bands) 创建一个新 SinglePixelPackedSampleModel，使其具有此 SinglePixelPackedSampleModel 的 band 子集。
boolean | equals(Object o) 指示其他某个对象是否与此对象“相等”。
int[] | getBitMasks() 返回所有 band 的位掩码。
int[] | getBitOffsets() 返回表示所有 band 像素的数据数组元素中的位偏移量。
Object | getDataElements(int x, int y, Object obj, DataBuffer data) 返回 TransferType 类型基本数组中单个像素的数据。
int | getNumDataElements() 返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。
int | getOffset(int x, int y) 返回像素 (x,y)（在数据数组元素中）的偏移量。
int[] | getPixel(int x, int y, int[] iArray, DataBuffer data) 在一个 int 数组中返回对应于指定像素的所有样本。
int[] | getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在一个 int 数组中返回对应于指定像素矩形的所有样本，每个数组元素对应一个样本。
int | getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
int[] | getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int[] | getSampleSize() 返回所有 band 的每样本位数。
int | getSampleSize(int band) 返回指定 band 的每样本位数。
int | getScanlineStride() 返回此 SinglePixelPackedSampleModel 的扫描行间距。
int | hashCode() 返回该对象的哈希码值。
void | setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。
void | setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
从类 java.awt.image.SampleModel 继承的方法
getDataElements, getDataType, getHeight, getNumBands, getPixel, getPixel, getPixels, getPixels, getSampleDouble, getSampleFloat, getSamples, getSamples, getTransferType, getWidth, setDataElements, setPixel, setPixel, setPixels, setPixels, setSample, setSample, setSamples, setSamples
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SinglePixelPackedSampleModel

public SinglePixelPackedSampleModel(int dataType,
                                    int w,
                                    int h,
                                    int[] bitMasks)
构造一个具有 bitMasks.length band 的 SinglePixelPackedSampleModel。每个样本都存储在数据数组元素中其对应位掩码的位置处。每个位掩码必须是连续的，掩码不得重叠。

参数：
dataType - 存储样本使用的数据类型。
w - 所描述的图像数据区域的宽度（以像素为单位）。
h - 所描述的图像数据区域的高度（以像素为单位）。
bitMasks - 所有 band 的位掩码。
抛出：
IllegalArgumentException - 如果 dataType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT

SinglePixelPackedSampleModel

public SinglePixelPackedSampleModel(int dataType,
                                    int w,
                                    int h,
                                    int scanlineStride,
                                    int[] bitMasks)
构造一个 SinglePixelPackedSampleModel，使其具有 bitMasks.length band，且扫描行间距等于 scanlineStride 数据数组元素。每个样本都存储在数据数组元素中其对应位掩码的位置处。每个位掩码必须是连续的，掩码不得重叠。

参数：
dataType - 存储样本使用的数据类型。
w - 所描述的图像数据区域的宽度（以像素为单位）。
h - 所描述的图像数据区域的高度（以像素为单位）。
scanlineStride - 图像数据的行间距。
bitMasks - 所有 band 的位掩码。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0
IllegalArgumentException - 如果 bitMask 中的任何掩码不连续
IllegalArgumentException - 如果 dataType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT
方法详细信息

getNumDataElements

public int getNumDataElements()
返回通过 getDataElements 和 setDataElements 方法传输一个像素所需的数据元素数。对于 SinglePixelPackedSampleModel，此元素数为 1。

指定者：
类 SampleModel 中的 getNumDataElements
返回：
数据元素的数量。
另请参见：
SampleModel.getDataElements(int, int, Object, DataBuffer),
SampleModel.getDataElements(int, int, int, int, Object, DataBuffer),
SampleModel.setDataElements(int, int, Object, DataBuffer),
SampleModel.setDataElements(int, int, int, int, Object, DataBuffer),
SampleModel.getTransferType()

createCompatibleSampleModel

public SampleModel createCompatibleSampleModel(int w,
                                               int h)
创建一个具有指定宽度和高度的新 SinglePixelPackedSampleModel。新 SinglePixelPackedSampleModel 的存储数据类型和位掩码与此 SinglePixelPackedSampleModel 相同。

指定者：
类 SampleModel 中的 createCompatibleSampleModel
参数：
w - 得到的 SampleModel 的宽度
h - 得到的 SampleModel 的高度
返回：
具有指定宽度和高度的 SinglePixelPackedSampleModel。
抛出：
IllegalArgumentException - 如果 w 或 h 不大于 0

createDataBuffer

public DataBuffer createDataBuffer()
创建一个对应于此 SinglePixelPackedSampleModel 的 DataBuffer。DataBuffer 的数据类型和大小将与此 SinglePixelPackedSampleModel 一致。DataBuffer 只有一个存储单元。

指定者：
类 SampleModel 中的 createDataBuffer
返回：
对应于此 SampleModel 的 DataBuffer。

getSampleSize

public int[] getSampleSize()
返回所有 band 的每样本位数。

指定者：
类 SampleModel 中的 getSampleSize
返回：
所有 band 样本的大小。

getSampleSize

public int getSampleSize(int band)
返回指定 band 的每样本位数。

指定者：
类 SampleModel 中的 getSampleSize
参数：
band - 指定的 band
返回：
指定 band 样本的大小。

getOffset

public int getOffset(int x,
                     int y)
返回像素 (x,y)（在数据数组元素中）的偏移量。包含像素 x,y 的数据元素可以使用 SinglePixelPackedSampleModel sppsm 从 DataBuffer data 中检索：
        data.getElem(sppsm.getOffset(x, y));

参数：
x - 指定像素的 X 坐标
y - 指定像素的 Y 坐标
返回：
指定像素的偏移量。

getBitOffsets

public int[] getBitOffsets()
返回表示所有 band 像素的数据数组元素中的位偏移量。

返回：
表示所有 band 像素的位偏移量。

getBitMasks

public int[] getBitMasks()
返回所有 band 的位掩码。

返回：
所有 band 的位掩码。

getScanlineStride

public int getScanlineStride()
返回此 SinglePixelPackedSampleModel 的扫描行间距。

返回：
此 SinglePixelPackedSampleModel 的扫描行间距。

createSubsetSampleModel

public SampleModel createSubsetSampleModel(int[] bands)
创建一个新 SinglePixelPackedSampleModel，使其具有此 SinglePixelPackedSampleModel 的 band 子集。新 SinglePixelPackedSampleModel 可以使用现有 SinglePixelPackedSampleModel 可使用的 DataBuffer。新 SinglePixelPackedSampleModel/DataBuffer 组合将表示一个图像，该图像具有原始 SinglePixelPackedSampleModel/DataBuffer 组合的 band 子集。

指定者：
类 SampleModel 中的 createSubsetSampleModel
参数：
bands - 此 SampleModel 的 band 子集
返回：
具有此 SampleModel band 子集的 SampleModel。
抛出：
RasterFormatException - 如果 band 参数的长度大于样本模型中 band 的数量。

getDataElements

public Object getDataElements(int x,
                              int y,
                              Object obj,
                              DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。对于 SinglePixelPackedSampleModel，数组将有一个元素，且类型与存储数据类型相同。通常，obj 作为 null 传入，从而 Object 将被自动创建，并具有正确的基本数据类型。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 SinglePixelPackedSampleModel sppsm1 描述）传输到 DataBuffer db2（其存储布局由 SinglePixelPackedSampleModel sppsm2 描述）。该传输通常比使用 getPixel/setPixel 更有效。

             SinglePixelPackedSampleModel sppsm1, sppsm2;
             DataBufferInt db1, db2;
             sppsm2.setDataElements(x, y, sppsm1.getDataElements(x, y, null,
                              db1), db2);
如果两个 SampleModel 具有相同的 band 数量，相应 band 的每个样本具有相同的位数，且 TransferType 相同，则使用 getDataElements/setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

如果 obj 不为 null，则它应是 TransferType 类型的基本数组。否则抛出 ClassCastException。如果坐标不在范围内，或者 obj 不为 null 且大小不足以保存像素数据，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 getDataElements
参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
obj - 如果不为 null，则 obj 是接收返回像素数据的基本数组。
data - 包含图像数据的 DataBuffer。
返回：
指定像素的数据。
另请参见：
setDataElements(int, int, Object, DataBuffer)

getPixel

public int[] getPixel(int x,
                      int y,
                      int[] iArray,
                      DataBuffer data)
在一个 int 数组中返回对应于指定像素的所有样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getPixel
参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
iArray - 如果不为 null，则在此数组中返回样本
data - 包含图像数据的 DataBuffer。
返回：
对应于指定像素的所有样本。
另请参见：
setPixel(int, int, int[], DataBuffer)

getPixels

public int[] getPixels(int x,
                       int y,
                       int w,
                       int h,
                       int[] iArray,
                       DataBuffer data)
在一个 int 数组中返回对应于指定像素矩形的所有样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getPixels
参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
iArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定像素区域的所有样本。
另请参见：
setPixels(int, int, int, int, int[], DataBuffer)

getSample

public int getSample(int x,
                     int y,
                     int b,
                     DataBuffer data)
以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 getSample
参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要返回的 band。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素的样本。
另请参见：
setSample(int, int, int, int, DataBuffer)

getSamples

public int[] getSamples(int x,
                        int y,
                        int w,
                        int h,
                        int b,
                        int[] iArray,
                        DataBuffer data)
在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 getSamples
参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要返回的 band。
iArray - 如果不为 null，则在此数组中返回样本。
data - 包含图像数据的 DataBuffer。
返回：
指定 band 中对应于指定像素区域的样本。
另请参见：
setSamples(int, int, int, int, int, int[], DataBuffer)

setDataElements

public void setDataElements(int x,
                            int y,
                            Object obj,
                            DataBuffer data)
根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。对于 SinglePixelPackedSampleModel，只有数组的第一个元素将保存有效值，且数组类型必须与 SinglePixelPackedSampleModel 的存储数据类型相同。

以下代码说明了如何将一个像素的数据从 DataBuffer db1（其存储布局由 SinglePixelPackedSampleModel sppsm1 描述）传输到 DataBuffer db2（其存储布局由 SinglePixelPackedSampleModel sppsm2 描述）。该传输通常比使用 getPixel/setPixel 更有效。

             SinglePixelPackedSampleModel sppsm1, sppsm2;
             DataBufferInt db1, db2;
             sppsm2.setDataElements(x, y, sppsm1.getDataElements(x, y, null,
                              db1), db2);
如果两个 SampleModel 具有相同的 band 数量，相应 band 的每个样本具有相同的位数，且 TransferType 相同，则使用 getDataElements/setDataElements 在两个 DataBuffer/SampleModel 对之间进行传输是合法的。

obj 必须是 TransferType 类型的基本数组。否则抛出 ClassCastException。如果坐标不在范围内，或者 obj 的大小不足以容纳像素数据，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 setDataElements
参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
obj - 包含像素数据的基本数组。
data - 包含图像数据的 DataBuffer。
另请参见：
getDataElements(int, int, Object, DataBuffer)

setPixel

public void setPixel(int x,
                     int y,
                     int[] iArray,
                     DataBuffer data)
使用输入样本的 int 数组设置 DataBuffer 中的像素。如果坐标不在范围内，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setPixel
参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
iArray - int 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
另请参见：
getPixel(int, int, int[], DataBuffer)

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray,
                      DataBuffer data)
根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setPixels
参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
iArray - int 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
另请参见：
getPixels(int, int, int, int, int[], DataBuffer)

setSample

public void setSample(int x,
                      int y,
                      int b,
                      int s,
                      DataBuffer data)
使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

指定者：
类 SampleModel 中的 setSample
参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要设置的 band。
s - int 形式的输入样本。
data - 包含图像数据的 DataBuffer。
另请参见：
getSample(int, int, int, DataBuffer)

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray,
                       DataBuffer data)
根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。如果坐标不在边界内，则抛出 ArrayIndexOutOfBoundsException。

覆盖：
类 SampleModel 中的 setSamples
参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要设置的 band。
iArray - int 数组中的输入样本。
data - 包含图像数据的 DataBuffer。
另请参见：
getSamples(int, int, int, int, int, int[], DataBuffer)

equals

public boolean equals(Object o)
从类 Object 复制的描述
指示其他某个对象是否与此对象“相等”。

equals 方法在非空对象引用上实现相等关系：

  • 自反性：对于任何非空引用值 x，x.equals(x) 都应返回 true。
  • 对称性：对于任何非空引用值 x 和 y，当且仅当 y.equals(x) 返回 true 时，x.equals(y) 才应返回 true。
  • 传递性：对于任何非空引用值 x、y 和 z，如果 x.equals(y) 返回 true，并且 y.equals(z) 返回 true，那么 x.equals(z) 应返回 true。
  • 一致性：对于任何非空引用值 x 和 y，多次调用 x.equals(y) 始终返回 true 或始终返回 false，前提是对象上 equals 比较中所用的信息没有被修改。
  • 对于任何非空引用值 x，x.equals(null) 都应返回 false。

Object 类的 equals 方法实现对象上差别可能性最大的相等关系；即，对于任何非空引用值 x 和 y，当且仅当 x 和 y 引用同一个对象时，此方法才返回 true（x == y 具有值 true）。

注意：当此方法被重写时，通常有必要重写 hashCode 方法，以维护 hashCode 方法的常规协定，该协定声明相等对象必须具有相等的哈希码。

覆盖：
类 Object 中的 equals
参数：
o - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TileObserver (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 TileObserver

public interface TileObserver

希望在出现以下情况时被通知的对象的接口：某个 writer 通过调用 getWritableTile 使 WritableRenderedImage 的 tile 变得可修改；通过最后调用 releaseWritableTile 使这些 tile 变得不可修改。

另请参见：
WritableRenderedImage

方法摘要
 void tileUpdate(WritableRenderedImage source, int tileX, int tileY, boolean willBeWritable)
即将被更新的 tile（此 tile 或者即将被获取以写入，或者正在从写入释放）。

方法详细信息

tileUpdate

void tileUpdate(WritableRenderedImage source,
                int tileX,
                int tileY,
                boolean willBeWritable)
即将被更新的 tile（此 tile 或者即将被获取以写入，或者正在从写入释放）。

参数：
source - 拥有 tile 的图像。
tileX - 正在被更新的 tile 的 X 索引。
tileY - 正在被更新的 tile 的 Y 索引。
willBeWritable - 如果为 true，则 tile 将被获取以写入，否则它正在被释放。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VolatileImage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 VolatileImage

java.lang.Object
    继承者  java.awt.Image
        继承者  java.awt.image.VolatileImage
所有已实现的接口：
Transparency
public abstract class VolatileImage
extends Image
implements Transparency

VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。由于存在硬件加速的潜力，VolatileImage 对象在某些平台上能够获得显著的性能受益。

图像的绘制表面（图像内容实际驻留的内存）可以丢失或失效，从而引起该内存的内容丢失。因此，绘制表面需要恢复或重新创建，表面的内容需要重新呈现。VolatileImage 提供了一个接口，此接口允许用户检测这些问题，并在出现这些问题时修复它们。

当创建 VolatileImage 对象时，可能为支持图像而分配了显存 (VRAM) 之类的有限系统资源。当不再使用 VolatileImage 对象时，可以将它作为垃圾回收，并返还其占用的系统资源，但此过程无法在保证的时间内发生。创建许多 VolatileImage 对象的应用程序（例如，在窗口大小改变时可以强行重建其后台缓冲区的可调整大小窗口）可能会为新的 VolatileImage 对象用光最优系统资源，因为原有对象还没有从系统中移除。（仍然可以创建新的 VolatileImage 对象，但它们执行起来可能不如那些在加速内存中创建的对象）。 可以调用 flush 方法在任何时间主动释放由 VolatileImage 使用的资源，这样就不会妨碍后续 VolatileImage 对象的加速操作。按照这种方式，应用程序可以对过时的 VolatileImage 对象所占用的资源状态拥有更多的控制权。

不能直接为此图像创建子类，而应该使用 Component.createVolatileImage 或 GraphicsConfiguration.createCompatibleVolatileImage(int, int) 方法来创建。

以下是一个使用 VolatileImage 对象的示例：

 // image creation
 VolatileImage vImg = createVolatileImage(w, h);

 // rendering to the image
 void renderOffscreen() {
        do {
            if (vImg.validate(getGraphicsConfiguration()) ==
                VolatileImage.IMAGE_INCOMPATIBLE)
            {
                // old vImg doesn't work with new GraphicsConfig; re-create it
                vImg = createVolatileImage(w, h);
            }
            Graphics2D g = vImg.createGraphics();
            //
            // miscellaneous rendering commands...
            //
            g.dispose();
        } while (vImg.contentsLost());
 }

 // copying from the image (here, gScreen is the Graphics
 // object for the onscreen window)
 do {
        int returnCode = vImg.validate(getGraphicsConfiguration());
        if (returnCode == VolatileImage.IMAGE_RESTORED) {
            // Contents need to be restored
            renderOffscreen();      // restore contents
        } else if (returnCode == VolatileImage.IMAGE_INCOMPATIBLE) {
            // old vImg doesn't work with new GraphicsConfig; re-create it
            vImg = createVolatileImage(w, h);
            renderOffscreen();
        }
        gScreen.drawImage(vImg, 0, 0, this);
 } while (vImg.contentsLost());

注意，此类是从 Image 类创建的子类，Image 类包含带有 ImageObserver 参数的方法，用于从潜在 ImageProducer 收到信息时的异步通知。由于此 VolatileImage 不是从异步源加载的，因此带有 ImageObserver 参数的不同方法的行为就好像已经从 ImageProducer 中获得了数据。明确地说，这意味着这些方法的返回值永远不会指示信息尚不可用，并且永远不需要为了异步回调通知而记录这些方法中使用的 ImageObserver。

从以下版本开始：
1.4

字段摘要
static int | IMAGE_INCOMPATIBLE 经验证的图像与提供的 GraphicsConfiguration 对象不兼容，应该重新创建适当的图像。
static int | IMAGE_OK 经验证的图像准备按原样使用。
static int | IMAGE_RESTORED 经验证的图像已经被恢复并准备使用。
protected int | transparency 创建此图像所使用的透明度值。
从类 java.awt.Image 继承的字段
accelerationPriority, SCALE_AREA_AVERAGING, SCALE_DEFAULT, SCALE_FAST, SCALE_REPLICATE, SCALE_SMOOTH, UndefinedProperty
从接口 java.awt.Transparency 继承的字段
BITMASK, OPAQUE, TRANSLUCENT
构造方法摘要
VolatileImage()
方法摘要
abstract boolean | contentsLost() 如果上次调用 validate 后呈现数据丢失，则返回 true。
abstract Graphics2D | createGraphics() 创建一个 Graphics2D，可以将它绘制到此 VolatileImage 中。
abstract ImageCapabilities | getCapabilities() 返回 ImageCapabilities 对象，查询此对象即可了解此 VolatileImage 的特定功能。
Graphics | getGraphics() 此方法返回 Graphics2D，但它存在于此处是出于向后兼容性的考虑。
abstract int | getHeight() 返回此 VolatileImage 的高度。
abstract BufferedImage | getSnapshot() 返回此对象的静态快照图像。
ImageProducer | getSource() 此方法返回此 VolatileImage 的 ImageProducer。
int | getTransparency() 返回透明度。
abstract int | getWidth() 返回 VolatileImage 的宽度。
abstract int | validate(GraphicsConfiguration gc) 如果上次调用 validate 后绘制表面丢失，则试图恢复图像的绘制表面。
从类 java.awt.Image 继承的方法
flush, getAccelerationPriority, getCapabilities, getHeight, getProperty, getScaledInstance, getWidth, setAccelerationPriority
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

IMAGE_OK

public static final int IMAGE_OK
经验证的图像准备按原样使用。

另请参见：
常量字段值

IMAGE_RESTORED

public static final int IMAGE_RESTORED
经验证的图像已经被恢复并准备使用。注意，恢复引起图像内容的丢失。

另请参见：
常量字段值

IMAGE_INCOMPATIBLE

public static final int IMAGE_INCOMPATIBLE
经验证的图像与提供的 GraphicsConfiguration 对象不兼容，应该重新创建适当的图像。从 validate 收到此返回代码后按原样使用图像的行为是不明确的。

另请参见：
常量字段值

transparency

protected int transparency
创建此图像所使用的透明度值。

从以下版本开始：
1.5
另请参见：
GraphicsConfiguration.createCompatibleVolatileImage(int, int,int), GraphicsConfiguration.createCompatibleVolatileImage(int, int,ImageCapabilities,int), Transparency
构造方法详细信息

VolatileImage

public VolatileImage()
方法详细信息

getSnapshot

public abstract BufferedImage getSnapshot()
返回此对象的静态快照图像。返回的 BufferedImage 仅与请求时刻的 VolatileImage 保持一致，不随 VolatileImage 未来的更改而更新。

返回：
此 VolatileImage 的 BufferedImage 表示形式
另请参见：
BufferedImage

getWidth

public abstract int getWidth()
返回 VolatileImage 的宽度。

返回：
此 VolatileImage 的宽度。

getHeight

public abstract int getHeight()
返回此 VolatileImage 的高度。

返回：
此 VolatileImage 的高度。

getSource

public ImageProducer getSource()
此方法返回此 VolatileImage 的 ImageProducer。注意，用于呈现操作和位图传输到屏幕或其他 VolatileImage 对象时，VolatileImage 对象很理想，但用于读回图像的像素时则相反。因此，getSource 这类操作的执行速度可能不如不依赖读取像素的那些操作。同样要注意，从图像读取的像素值只与获取时图像的像素值保持一致。此方法在作出请求时拍下图像的快照，返回的 ImageProducer 对象使用该静态快照，而不是原始的 VolatileImage 进行工作。调用 getSource() 等效于调用 getSnapshot().getSource()。

指定者：
类 Image 中的 getSource
返回：
ImageProducer，它可以为此 Image 的 BufferedImage 表示形式生成像素。
另请参见：
ImageProducer, getSnapshot()

getGraphics

public Graphics getGraphics()
此方法返回 Graphics2D，但它存在于此处是出于向后兼容性的考虑。createGraphics 更为方便，因为它被声明为返回 Graphics2D。

指定者：
类 Image 中的 getGraphics
返回：
Graphics2D，可以将它绘制到此图像中。
另请参见：
Graphics, Component.createImage(int, int)

createGraphics

public abstract Graphics2D createGraphics()
创建一个 Graphics2D，可以将它绘制到此 VolatileImage 中。

返回：
Graphics2D，用于绘制到此图像中。

validate

public abstract int validate(GraphicsConfiguration gc)
如果上次调用 validate 后绘制表面丢失，则试图恢复图像的绘制表面。还要依靠给定的 GraphicsConfiguration 参数验证此图像，即查看从此图像到 GraphicsConfiguration 的操作是否兼容。以下情形就是一个不兼容组合的例子：VolatileImage 对象在一个图形设备上创建，然后在另一个不同的图形设备上呈现。由于 VolatileImage 对象与设备特别相关，此操作可能不会按预期进行，因此调用此 validate 返回的代码将记录这种不兼容性。null 或不正确的 gc 值可能引起 validate 返回不正确的值，随后可能引起呈现问题。

参数：
gc - 一个 GraphicsConfiguration 对象，图像依靠此对象进行验证。gc 为 null 意味着 validate 方法应该跳过兼容性测试。
返回：
如果图像不需要验证，则返回 IMAGE_OK。
如果图像需要恢复，则返回 IMAGE_RESTORED。恢复意味着图像内容可能已受到影响，并且图像可能需要重新呈现。
如果图像与传入 validate 方法的 GraphicsConfiguration 对象不兼容，则返回 IMAGE_INCOMPATIBLE。不兼容意味着图像可能需要用新的 Component 或 GraphicsConfiguration 重新创建，以获得一个能够用此 GraphicsConfiguration 成功使用的图像。不兼容的图像不会检查是否需要恢复，因此在 IMAGE_INCOMPATIBLE 值返回后图像的状态不变，这个返回值与图像是否需要恢复无关。
另请参见：
GraphicsConfiguration, Component, IMAGE_OK, IMAGE_RESTORED, IMAGE_INCOMPATIBLE

contentsLost

public abstract boolean contentsLost()
如果上次调用 validate 后呈现数据丢失，则返回 true。在对图像进行的任何系列呈现操作的结尾，应用程序应该调用此方法，以查看图像是否需要验证和重新呈现。

返回：
如果绘制表面需要恢复，则返回 true；否则返回 false。

getCapabilities

public abstract ImageCapabilities getCapabilities()
返回 ImageCapabilities 对象，查询此对象即可了解此 VolatileImage 的特定功能。这允许程序员查找关于他们已经创建的特定 VolatileImage 对象的更多运行时信息。例如，用户可能要创建一个 VolatileImage，但系统剩余的显存可能不足以创建该尺寸的图像，因此尽管该对象是 VolatileImage，但它可能不会像此平台上其他 VolatileImage 对象一样被加速。用户可能需要该信息来寻找解决问题的其他方案。

返回：
包含此 VolatileImage 的功能的 ImageCapabilities 对象。
从以下版本开始：
1.4

getTransparency

public int getTransparency()
返回透明度。返回 OPAQUE、BITMASK 或 TRANSLUCENT 中的一个。

指定者：
接口 Transparency 中的 getTransparency
返回：
此 VolatileImage 的透明度。
从以下版本开始：
1.5
另请参见：
Transparency.OPAQUE, Transparency.BITMASK, Transparency.TRANSLUCENT
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WritableRaster (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image
类 WritableRaster

java.lang.Object
    继承者  java.awt.image.Raster
        继承者  java.awt.image.WritableRaster

public class WritableRaster
extends Raster

此类扩展了 Raster 以提供像素写入功能。有关 Raster 如何存储像素的描述，请参阅 Raster 的类注释。

此类的构造方法为 protected。要实例化 WritableRaster，需使用 Raster 类中的一个 createWritableRaster 工厂方法。

字段摘要
从类 java.awt.image.Raster 继承的字段
dataBuffer, height, minX, minY, numBands, numDataElements, parent, sampleModel, sampleModelTranslateX, sampleModelTranslateY, width
构造方法摘要
protected | WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin) 构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
protected | WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent) 构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。
protected | WritableRaster(SampleModel sampleModel, Point origin) 构造具有给定 SampleModel 的 WritableRaster。
方法摘要
WritableRaster | createWritableChild(int parentX, int parentY, int w, int h, int childMinX, int childMinY, int[] bandList) 返回新的 WritableRaster，它共享此 WritableRaster 的全部或部分 DataBuffer。
WritableRaster | createWritableTranslatedChild(int childMinX, int childMinY) 在不同的位置上创建一个与此 WritableRaster 具有相同大小、SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster | getWritableParent() 返回此 WritableRaster 的父 WritableRaster（如果有），否则返回 null。
void | setDataElements(int x, int y, int w, int h, Object inData) 为类型 TransferType 基本数组中的像素矩形设置数据。
void | setDataElements(int x, int y, Object inData) 为类型 TransferType 基本数组中的单个像素设置数据。
void | setDataElements(int x, int y, Raster inRaster) 为输入 Raster 中的像素矩形设置数据。
void | setPixel(int x, int y, double[] dArray) 使用输入样本的 double 型数组设置 DataBuffer 中的像素。
void | setPixel(int x, int y, float[] fArray) 使用输入样本的 float 型数组设置 DataBuffer 中的像素。
void | setPixel(int x, int y, int[] iArray) 使用输入样本的 int 型数组设置 DataBuffer 中的像素。
void | setPixels(int x, int y, int w, int h, double[] dArray) 为每个数组元素包含一个样本的 double 型数组中的像素矩形设置所有样本。
void | setPixels(int x, int y, int w, int h, float[] fArray) 为每个数组元素包含一个样本的 float 型数组中的像素矩形设置所有样本。
void | setPixels(int x, int y, int w, int h, int[] iArray) 为每个数组元素包含一个样本的 int 型数组中的像素矩形设置所有样本。
void | setRect(int dx, int dy, Raster srcRaster) 将像素从 Raster srcRaster 复制到此 WritableRaster。
void | setRect(Raster srcRaster) 将像素从 Raster srcRaster 复制到此 WritableRaster。
void | setSample(int x, int y, int b, double s) 使用 double 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
void | setSample(int x, int y, int b, float s) 使用 float 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
void | setSample(int x, int y, int b, int s) 使用 int 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。
void | setSamples(int x, int y, int w, int h, int b, double[] dArray) 为每个数组元素包含一个样本的 double 型数组中指定的像素矩形在指定 band 中设置样本。
void | setSamples(int x, int y, int w, int h, int b, float[] fArray) 为每个数组元素包含一个样本的 float 型数组中指定的像素矩形在指定 band 中设置样本。
void | setSamples(int x, int y, int w, int h, int b, int[] iArray) 为每个数组元素包含一个样本的 int 型数组中指定的像素矩形在指定 band 中设置样本。
从类 java.awt.image.Raster 继承的方法
createBandedRaster, createBandedRaster, createBandedRaster, createChild, createCompatibleWritableRaster, createCompatibleWritableRaster, createCompatibleWritableRaster, createCompatibleWritableRaster, createInterleavedRaster, createInterleavedRaster, createInterleavedRaster, createPackedRaster, createPackedRaster, createPackedRaster, createPackedRaster, createRaster, createTranslatedChild, createWritableRaster, createWritableRaster, getBounds, getDataBuffer, getDataElements, getDataElements, getHeight, getMinX, getMinY, getNumBands, getNumDataElements, getParent, getPixel, getPixel, getPixel, getPixels, getPixels, getPixels, getSample, getSampleDouble, getSampleFloat, getSampleModel, getSampleModelTranslateX, getSampleModelTranslateY, getSamples, getSamples, getSamples, getTransferType, getWidth
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WritableRaster

protected WritableRaster(SampleModel sampleModel,
                         Point origin)
构造具有给定 SampleModel 的 WritableRaster。WritableRaster 的左上角为原点，其大小与 SampleModel 相同。自动创建一个大小足以描述 WritableRaster 的 DataBuffer。

参数：
sampleModel - 指定布局的 SampleModel。
origin - 指定原点的 Point。
抛出：
RasterFormatException - 如果 origin.x + sampleModel.getWidth() 或者 origin.y + sampleModel.getHeight() 的计算结果整数溢出

WritableRaster

protected WritableRaster(SampleModel sampleModel,
                         DataBuffer dataBuffer,
                         Point origin)
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。WritableRaster 的左上角为原点，其大小与 SampleModel 相同。DataBuffer 是未初始化的，它必须与 SampleModel 兼容。

参数：
sampleModel - 指定布局的 SampleModel。
dataBuffer - 包含图像数据的 DataBuffer。
origin - 指定原点的 Point。
抛出：
RasterFormatException - 如果 origin.x + sampleModel.getWidth() 或 origin.y + sampleModel.getHeight() 的计算结果整数溢出

WritableRaster

protected WritableRaster(SampleModel sampleModel,
                         DataBuffer dataBuffer,
                         Rectangle aRegion,
                         Point sampleModelTranslate,
                         WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。aRegion 指定新 Raster 的边界矩形。当向基 Raster 的坐标系转换时，基 Raster 必须包含 aRegion。（基 Raster 是 Raster 的祖先，它没有父亲）sampleModelTranslate 指定新 Raster 的 sampleModelTranslateX 值和 sampleModelTranslateY 值。 注意，此构造方法通常应该由其他构造方法或创建方法调用，不应该直接使用。

参数：
sampleModel - 指定布局的 SampleModel。
dataBuffer - 包含图像数据的 DataBuffer。
aRegion - 指定图像区域的 Rectangle。
sampleModelTranslate - 指定从 SampleModel 向 Raster 进行坐标转换的 Point。
parent - 此 raster 的父亲（如果有）。
抛出：
RasterFormatException - 如果 aRegion 的宽度和高度小于等于 0，或者 aRegion.x + aRegion.width 或 aRegion.y + aRegion.height 的计算结果整数溢出
方法详细信息

getWritableParent

public WritableRaster getWritableParent()
返回此 WritableRaster 的父 WritableRaster（如果有），否则返回 null。

返回：
此 WritableRaster 的父亲，或 null。

createWritableTranslatedChild

public WritableRaster createWritableTranslatedChild(int childMinX,
                                                    int childMinY)
在不同的位置上创建一个与此 WritableRaster 具有相同大小、SampleModel 和 DataBuffer 的 WritableRaster。新 WritableRaster 将具有对当前 WritableRaster 的引用，可以通过其 getParent() 和 getWritableParent() 方法进行访问。

参数：
childMinX - 新 Raster 左上角的 X 坐标。
childMinY - 新 Raster 左上角的 Y 坐标。
返回：
除了指定的位置不同外，与此 WritableRaster 相同的 WritableRaster。
抛出：
RasterFormatException - 如果 childMinX + this.getWidth() 或 childMinY + this.getHeight() 的计算结果整数溢出

createWritableChild

public WritableRaster createWritableChild(int parentX,
                                          int parentY,
                                          int w,
                                          int h,
                                          int childMinX,
                                          int childMinY,
                                          int[] bandList)
返回新的 WritableRaster，它共享此 WritableRaster 的全部或部分 DataBuffer。新 WritableRaster 将具有对当前 WritableRaster 的引用，可以通过其 getParent() 和 getWritableParent() 方法进行访问。

parentX、parentY、width 和 height 参数在此 WritableRaster 坐标空间中形成一个 Rectangle，指示要共享的像素区域。如果此 Rectangle 没有包含在当前 WritableRaster 的边界内部，则会抛出错误。

新 WritableRaster 可以另外转换到与当前 WritableRaster 不同的平面坐标系中。childMinX 和 childMinY 参数给定返回的 WritableRaster 左上角像素的新 (x, y) 坐标；新 WritableRaster 中的坐标 (childMinX, childMinY) 将映射到当前 WritableRaster 中相同像素的坐标 (parentX, parentY)。

新 WritableRaster 可以定义为只包含当前 WritableRaster band 的一个子集，该子集可能通过 bandList 参数进行了重新排序。如果 bandList 为 null，则它将以其当前顺序包含当前 WritableRaster 的所有 band。

要创建新的 WritableRaster，使其包含当前 WritableRaster 的子区域，但共享其坐标系和 band，此方法在调用时应该令 childMinX 等于 parentX，childMinY 等于 parentY 且 bandList 为 null。

参数：
parentX - 此 WritableRaster 坐标中左上角的 X 坐标。
parentY - 此 WritableRaster 坐标中左上角的 Y 坐标。
w - 从 (parentX, parentY) 开始的区域宽度。
w - 从 (parentX, parentY) 开始的区域高度。
childMinX - 返回的 WritableRaster 左上角的 X 坐标。
childMinY - 返回的 WritableRaster 左上角的 Y 坐标。
bandList - band 的索引数组，取 null 则使用所有 band。
返回：
WritableRaster，它共享此 WritableRaster 全部或部分 DataBuffer。
抛出：
RasterFormatException - 如果子区域位于光栅边界的外部。
RasterFormatException - 如果 w 或 h 小于等于 0，或者 parentX + w、parentY + h、childMinX + w 或 childMinY + h 中任何一个的计算结果整数溢出

setDataElements

public void setDataElements(int x,
                            int y,
                            Object inData)
为类型 TransferType 基本数组中的单个像素设置数据。对于 Java 2D(tm) API 所支持的图像数据，这将是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 中的一个。数组中的数据可以是打包的格式，从而提高数据传输的效率。如果坐标不在边界内部，或者 inData 的大小不够容纳像素数据，则会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。如果输入对象不为 null 且引用 TransferType 数组之外的任何数组，则会抛出 ClassCastException。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
inData - 引用类型数组的对象，该类型由 getTransferType() 定义，并且其长度 getNumDataElements() 包含到 x,y 位置的像素数据。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 inData 太小不能容纳输入。
另请参见：
SampleModel.setDataElements(int, int, Object, DataBuffer)

setDataElements

public void setDataElements(int x,
                            int y,
                            Raster inRaster)
为输入 Raster 中的像素矩形设置数据。输入的 Raster 必须与此 WritableRaster 兼容，因为它们必须具有相同的 band，对应 band 的每个样本必须具有相同的位数，TransferType 和 NumDataElement 必须相同，并且 getDataElements/setDataElements 使用的打包方式必须一致。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
inRaster - 包含 x,y 位置数据的 Raster。
抛出：
NullPointerException - 如果 inRaster 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部。

setDataElements

public void setDataElements(int x,
                            int y,
                            int w,
                            int h,
                            Object inData)
为类型 TransferType 基本数组中的像素矩形设置数据。对于 Java 2D API 所支持的图像数据，这将是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT、DataBuffer.TYPE_INT、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_FLOAT 或 DataBuffer.TYPE_DOUBLE 中的一个。 数组中的数据可以是打包的格式，从而提高数据传输的效率。如果坐标不在边界内部，或者 inData 的大小不足以容纳像素数据，则会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。如果输入对象不为 null 且引用除 TransferType 数组之外的其他任何数组，则会抛出 ClassCastException。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
inData - 引用类型数组的对象，该类型是由 getTransferType() 定义的，并且它的长度 w*h*getNumDataElements() 包含 x,y 和 x+w-1, y+h-1 位置之间的像素数据。
抛出：
NullPointerException - 如果 inData 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 inData 太小不能容纳输入。
另请参见：
SampleModel.setDataElements(int, int, int, int, Object, DataBuffer)

setRect

public void setRect(Raster srcRaster)
将像素从 Raster srcRaster 复制到此 WritableRaster。srcRaster 中的每个像素被复制到此光栅的相同的 x,y 地址，除非地址位于此光栅边界的外部。srcRaster 必须具有与此 WritableRaster 相同的 band 数。这是从源样本到对应的目标样本的简单复制。

如果源 Raster 和目标 Raster 的所有样本都是整型，且大小小于等于 32 位，则调用此方法等价于对源 Raster 和目标 Raster 中所有有效的 x,y 地址执行以下代码。

       Raster srcRaster;
       WritableRaster dstRaster;
       for (int b = 0; b < srcRaster.getNumBands(); b++) {
           dstRaster.setSample(x, y, b, srcRaster.getSample(x, y, b));
       }
因此，当将整型的源复制到整型的目标时，如果对于特定的 band 源样本大小大于目标样本大小，则源样本的高位将被截断。如果特定 band 的源样本大小小于目标样本大小，则根据 srcRaster 的 SampleModel 是将样本作为有符号的量还是无符号的量，对目标样本的高位进行零扩展或符号扩展。

当从一个 float 型或 double 型的源复制到整型的目标时，每个源样本强制转换为目标类型。当从整形的源复制到 float 型或 double 型的目标时，源首先使用上面的整型转换规则转换为 32-位的 int（如果需要的话），然后此 int 强制转换为 float 型或 double 型。

参数：
srcRaster - 从其复制像素的 Raster。
抛出：
NullPointerException - 如果 srcRaster 为 null。

setRect

public void setRect(int dx,
                    int dy,
                    Raster srcRaster)
将像素从 Raster srcRaster 复制到此 WritableRaster。对于 srcRaster 中的每个 (x, y) 地址，对应的像素被复制到此 WritableRaster 中的地址 (x+dx, y+dy)，除非 (x+dx, y+dy) 位于此光栅边界的外部。srcRaster 必须具有与此 WritableRaster 相同的 band 数。这是从源样本到对应的目标样本的简单复制。有关详细信息，请参见 setRect(Raster)。

参数：
dx - 从 src 空间复制到 dst 空间的 X 转换因子。
dy - 从 src 空间复制到 dst 空间的 Y 转换因子。
srcRaster - 从其复制像素的 Raster。
抛出：
NullPointerException - 如果 srcRaster 为 null。

setPixel

public void setPixel(int x,
                     int y,
                     int[] iArray)
使用输入样本的 int 型数组设置 DataBuffer 中的像素。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
iArray - 以 int 型数组表示的输入样本。
抛出：
NullPointerException - 如果 iArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 iArray 太小不能容纳输入。

setPixel

public void setPixel(int x,
                     int y,
                     float[] fArray)
使用输入样本的 float 型数组设置 DataBuffer 中的像素。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
fArray - 以 float 型数组表示的输入样本。
抛出：
NullPointerException - 如果 fArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 fArray 太小不能容纳输入。

setPixel

public void setPixel(int x,
                     int y,
                     double[] dArray)
使用输入样本的 double 型数组设置 DataBuffer 中的像素。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
dArray - 以 double 型数组表示的输入样本。
抛出：
NullPointerException - 如果 dArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 dArray 太小不能容纳输入。

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      int[] iArray)
为每个数组元素包含一个样本的 int 型数组中的像素矩形设置所有样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
iArray - 输入的 int 像素数组。
抛出：
NullPointerException - 如果 iArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 iArray 太小不能容纳输入。

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      float[] fArray)
为每个数组元素包含一个样本的 float 型数组中的像素矩形设置所有样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
fArray - 输入的 float 型像素数组。
抛出：
NullPointerException - 如果 fArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 fArray 太小不能容纳输入。

setPixels

public void setPixels(int x,
                      int y,
                      int w,
                      int h,
                      double[] dArray)
为每个数组元素包含一个样本的 double 型数组中的像素矩形设置所有样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
dArray - 输入的 double 型数组。
抛出：
NullPointerException - 如果 dArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标不在边界内部，或者 dArray 太小不能容纳输入。

setSample

public void setSample(int x,
                      int y,
                      int b,
                      int s)
使用 int 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要设置的 band。
s - 输入样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内部。

setSample

public void setSample(int x,
                      int y,
                      int b,
                      float s)
使用 float 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要设置的 band。
s - 以 float 的形式输入的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内部。

setSample

public void setSample(int x,
                      int y,
                      int b,
                      double s)
使用 double 型的输入样本，在指定 band 中为位于 DataBuffer 中 (x,y) 位置的像素设置样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 像素位置的 X 坐标。
y - 像素位置的 Y 坐标。
b - 要设置的 band。
s - 以 double 形式输入的样本。
抛出：
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内部。

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       int[] iArray)
为每个数组元素包含一个样本的 int 型数组中指定的像素矩形在指定 band 中设置样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要设置的 band。
iArray - 输入的 int 型样本数组。
抛出：
NullPointerException - 如果 iArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内部，或者 iArray 太小不能容纳输入。

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       float[] fArray)
为每个数组元素包含一个样本的 float 型数组中指定的像素矩形在指定 band 中设置样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要设置的 band。
fArray - 输入的 float 型样本数组。
抛出：
NullPointerException - 如果 fArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内部，或者 fArray 太小不能容纳输入。

setSamples

public void setSamples(int x,
                       int y,
                       int w,
                       int h,
                       int b,
                       double[] dArray)
为每个数组元素包含一个样本的 double 型数组中指定的像素矩形在指定 band 中设置样本。如果坐标不在边界内部，则可能会抛出 ArrayIndexOutOfBoundsException。但是，不保证显示的边界检查。

参数：
x - 左上角像素位置的 X 坐标。
y - 左上角像素位置的 Y 坐标。
w - 像素矩形的宽度。
h - 像素矩形的高度。
b - 要设置的 band。
dArray - 输入的 double 型样本数组。
抛出：
NullPointerException - 如果 dArray 为 null。
ArrayIndexOutOfBoundsException - 如果坐标或 band 索引不在边界内，或者 dArray 太小不能容纳输入。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WritableRenderedImage (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.image
接口 WritableRenderedImage

所有超级接口：
RenderedImage
所有已知实现类：
BufferedImage
public interface WritableRenderedImage
extends RenderedImage

WriteableRenderedImage 公共接口用于那些包含或者能够生成 Rasters 形式图像数据的对象，以及能够被修改和/或写入的对象。图像数据可以作为单个 tile 或 tile 规则数组被存储/生成。

当为写入签出了一个 tile（通过 getWritableTile 方法），以及一个特定 tile 最后的 writer 放弃其访问（通过调用 releaseWritableTile）时，WritableRenderedImage 通知其他感兴趣的对象。此外，它允许任何调用者确定当前是否签出了任何 tile（通过 hasTileWriters），并允许获得这种 tile 的列表（通过 getWritableTileIndices，以 Point 对象的 Vector 形式表示）。

希望 tile 可写入性更改时被通知的对象必须实现 TileObserver 接口，并通过调用 addTileObserver 添加。对同一个对象多次调用 addTileObserver 将产生多个通知。现有的观察器可以通过调用 removeTileObserver 来减少其通知；如果观察器没有通知，则该操作是无操作。

WritableRenderedImage 必须确保仅在第一个 writer 获得 tile 和最后一个 writer 释放它时发出通知。

方法摘要
void | addTileObserver(TileObserver to) 添加一个观察器。
WritableRaster | getWritableTile(int tileX, int tileY) 为写入签出一个 tile。
Point[] | getWritableTileIndices() 返回 Point 对象的数组，它指示为写入签出了哪些 tile。
boolean | hasTileWriters() 返回是否有为写入而签出的 tile。
boolean | isTileWritable(int tileX, int tileY) 返回当前是否正在为写入签出 tile。
void | releaseWritableTile(int tileX, int tileY) 放弃写入一个 tile 的权力。
void | removeTileObserver(TileObserver to) 移除一个观察器。
void | setData(Raster r) 将图像的 rect 设置为 Raster r 的内容，假定 r 位于与 WritableRenderedImage 相同的坐标空间。
从接口 java.awt.image.RenderedImage 继承的方法
copyData, getColorModel, getData, getData, getHeight, getMinTileX, getMinTileY, getMinX, getMinY, getNumXTiles, getNumYTiles, getProperty, getPropertyNames, getSampleModel, getSources, getTile, getTileGridXOffset, getTileGridYOffset, getTileHeight, getTileWidth, getWidth

方法详细信息

addTileObserver

void addTileObserver(TileObserver to)
添加一个观察器。如果观察器已经存在，则它将接受多个通知。

参数：
to - 指定的 TileObserver

removeTileObserver

void removeTileObserver(TileObserver to)
移除一个观察器。如果观察器没有注册，则不发生任何操作。如果观察器为多个通知注册，则现在其注册的通知数将减少一个。

参数：
to - 指定的 TileObserver

getWritableTile

WritableRaster getWritableTile(int tileX,
                               int tileY)
为写入签出一个 tile。当一个 tile 从没有 writer 变为有一个 writer 时，WritableRenderedImage 负责通知其所有的 TileObserver。

参数：
tileX - tile 的 X 索引。
tileY - tile 的 Y 索引。
返回：
一个可写入的 tile。

releaseWritableTile

void releaseWritableTile(int tileX,
                         int tileY)
放弃写入一个 tile 的权力。如果调用者继续写入 tile，则结果是不确定的。此方法的调用应该与 getWritableTile 的调用成对出现；任何其他用法将导致不确定的结果。当一个 tile 从有一个 writer 变为没有 writer 时，WritableRenderedImage 负责通知其所有的 TileObserver。

参数：
tileX - tile 的 X 索引。
tileY - tile 的 Y 索引。

isTileWritable

boolean isTileWritable(int tileX,
                       int tileY)
返回当前是否正在为写入签出 tile。

参数：
tileX - tile 的 X 索引。
tileY - tile 的 Y 索引。
返回：
如果为写入签出了指定的 tile ，则返回 true；否则返回 false。

getWritableTileIndices

Point[] getWritableTileIndices()
返回 Point 对象的数组，它指示为写入签出了哪些 tile。如果没有签出任何 tile，则返回 null。

返回：
包含为写入而签出的 tile 的位置数组。

hasTileWriters

boolean hasTileWriters()
返回是否有为写入而签出的 tile。在语义上等价于 (getWritableTileIndices() != null)。

返回：
如果有为写入而签出的 tile，则返回 true；否则返回 false。

setData

void setData(Raster r)
将图像的 rect 设置为 Raster r 的内容，假定 r 位于与 WritableRenderedImage 相同的坐标空间。操作被限制在 WritableRenderedImage 的边界内。

参数：
r - 指定的 Raster
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.image (Java 2 Platform SE 6)

 java.awt.image
接口
BufferedImageOp
ImageConsumer
ImageObserver
ImageProducer
RasterOp
RenderedImage
TileObserver
WritableRenderedImage
类
AffineTransformOp
AreaAveragingScaleFilter
BandCombineOp
BandedSampleModel
BufferedImage
BufferedImageFilter
BufferStrategy
ByteLookupTable
ColorConvertOp
ColorModel
ComponentColorModel
ComponentSampleModel
ConvolveOp
CropImageFilter
DataBuffer
DataBufferByte
DataBufferDouble
DataBufferFloat
DataBufferInt
DataBufferShort
DataBufferUShort
DirectColorModel
FilteredImageSource
ImageFilter
IndexColorModel
Kernel
LookupOp
LookupTable
MemoryImageSource
MultiPixelPackedSampleModel
PackedColorModel
PixelGrabber
PixelInterleavedSampleModel
Raster
ReplicateScaleFilter
RescaleOp
RGBImageFilter
SampleModel
ShortLookupTable
SinglePixelPackedSampleModel
VolatileImage
WritableRaster
异常
ImagingOpException
RasterFormatException


java.awt.image (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.image

提供创建和修改图像的各种类。

请参见：
描述

接口摘要
BufferedImageOp | 此接口描述对 BufferedImage 对象所执行的单输入/单输出操作。
ImageConsumer | 对通过 ImageProducer 接口的图像数据感兴趣的对象接口。
ImageObserver | 用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。
ImageProducer | 可为 Image 生成图像数据的对象的接口。
RasterOp | 此接口描述对 Raster 对象执行的单输入/单输出操作。
RenderedImage | RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。
TileObserver | 希望在出现以下情况时被通知的对象的接口：某个 writer 通过调用 getWritableTile 使 WritableRenderedImage 的 tile 变得可修改；通过最后调用 releaseWritableTile 使这些 tile 变得不可修改。
WritableRenderedImage | WriteableRenderedImage 公共接口用于那些包含或者能够生成 Rasters 形式图像数据的对象，以及能够被修改和/或写入的对象。

类摘要
AffineTransformOp | 此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。
AreaAveragingScaleFilter | 这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
BandCombineOp | 此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。
BandedSampleModel | 此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。
BufferedImage | BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
BufferedImageFilter | BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
BufferStrategy | BufferStrategy 类表示用来在特定的 Canvas 或 Window 上组织复杂内存的机制。
ByteLookupTable | 此类定义一个 lookup table 对象。
ColorConvertOp | 此类对源图像中的数据执行逐像素的颜色转换。
ColorModel | 此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
ComponentColorModel | 使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。
ComponentSampleModel | 此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。
ConvolveOp | 此类实现从源到目标的卷积。
CropImageFilter | 用于裁剪图像的 ImageFilter 类。
DataBuffer | 此类用于包装一个或多个数据数组。
DataBufferByte | 此类扩展了 DataBuffer，并在内部按字节存储数据。
DataBufferDouble | 此类扩展了 DataBuffer，并在内部以 double 形式存储数据。
DataBufferFloat | 此类扩展了 DataBuffer，并在内部以 float 形式存储数据。
DataBufferInt | 此类扩展了 DataBuffer，并在内部以整数形式存储数据。
DataBufferShort | 此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
DataBufferUShort | 此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
DirectColorModel | DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。
FilteredImageSource | 此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。
ImageFilter | 此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
IndexColorModel | IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
Kernel | Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。
LookupOp | 此类实现从源到目标的查找操作。
LookupTable | 此抽象类定义了一个查找表对象。
MemoryImageSource | 此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。
MultiPixelPackedSampleModel | MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。
PackedColorModel | PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。
PixelGrabber | PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。
PixelInterleavedSampleModel | 此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。
Raster | 表示像素矩形数组的类。
ReplicateScaleFilter | 使用最简单的算法缩放图像的 ImageFilter 类。
RescaleOp | 通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。
RGBImageFilter | 此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。
SampleModel | 此抽象类定义一个提取图像像素样本的接口。
ShortLookupTable | 此类定义了一个查找表对象。
SinglePixelPackedSampleModel | 此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。
VolatileImage | VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。
WritableRaster | 此类扩展了 Raster 以提供像素写入功能。

异常摘要
ImagingOpException | 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
RasterFormatException | 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

软件包 java.awt.image 的描述

提供创建和修改图像的各种类。使用流框架来处理图像，该框架涉及图像生产者、可选的图像过滤器和图像使用者。此框架使得在获取和生成图像的同时逐步呈现该图像成为可能。而且，该框架允许应用程序丢弃图像使用的存储空间并随时重新生成它。此包提供了多种图像生产者、使用者和过滤器，可以根据图像处理的需要来配置它们。

从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.image 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.image 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.image.AffineTransformOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.BandCombineOp (implements java.awt.image.RasterOp)
    • java.awt.image.BufferStrategy
    • java.awt.image.ColorConvertOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.ColorModel (implements java.awt.Transparency)
      • java.awt.image.ComponentColorModel
      • java.awt.image.IndexColorModel
      • java.awt.image.PackedColorModel
        • java.awt.image.DirectColorModel
    • java.awt.image.ConvolveOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.DataBuffer
      • java.awt.image.DataBufferByte
      • java.awt.image.DataBufferDouble
      • java.awt.image.DataBufferFloat
      • java.awt.image.DataBufferInt
      • java.awt.image.DataBufferShort
      • java.awt.image.DataBufferUShort
    • java.awt.image.FilteredImageSource (implements java.awt.image.ImageProducer)
    • java.awt.Image
      • java.awt.image.BufferedImage (implements java.awt.Transparency, java.awt.image.WritableRenderedImage)
      • java.awt.image.VolatileImage (implements java.awt.Transparency)
    • java.awt.image.ImageFilter (implements java.lang.Cloneable, java.awt.image.ImageConsumer)
      • java.awt.image.BufferedImageFilter (implements java.lang.Cloneable)
      • java.awt.image.CropImageFilter
      • java.awt.image.ReplicateScaleFilter
        • java.awt.image.AreaAveragingScaleFilter
      • java.awt.image.RGBImageFilter
    • java.awt.image.Kernel (implements java.lang.Cloneable)
    • java.awt.image.LookupOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.LookupTable
      • java.awt.image.ByteLookupTable
      • java.awt.image.ShortLookupTable
    • java.awt.image.MemoryImageSource (implements java.awt.image.ImageProducer)
    • java.awt.image.PixelGrabber (implements java.awt.image.ImageConsumer)
    • java.awt.image.Raster
      • java.awt.image.WritableRaster
    • java.awt.image.RescaleOp (implements java.awt.image.BufferedImageOp, java.awt.image.RasterOp)
    • java.awt.image.SampleModel
      • java.awt.image.ComponentSampleModel
        • java.awt.image.BandedSampleModel
        • java.awt.image.PixelInterleavedSampleModel
      • java.awt.image.MultiPixelPackedSampleModel
      • java.awt.image.SinglePixelPackedSampleModel
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.awt.image.ImagingOpException
          • java.awt.image.RasterFormatException

接口分层结构

  • java.awt.image.BufferedImageOp
  • java.awt.image.ImageConsumer
  • java.awt.image.ImageObserver
  • java.awt.image.ImageProducer
  • java.awt.image.RasterOp
  • java.awt.image.RenderedImage
    • java.awt.image.WritableRenderedImage
  • java.awt.image.TileObserver
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.image 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.image
的使用

使用 java.awt.image 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 使用的 java.awt.image 中的类
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

java.awt 使用的 java.awt.image 中的类
BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
BufferedImageOp
此接口描述对 BufferedImage 对象所执行的单输入/单输出操作。
BufferStrategy
BufferStrategy 类表示用来在特定的 Canvas 或 Window 上组织复杂内存的机制。
ColorModel
此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。
ImageProducer
可为 Image 生成图像数据的对象的接口。
Raster
表示像素矩形数组的类。
RenderedImage
RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。
VolatileImage
VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。
WritableRaster
此类扩展了 Raster 以提供像素写入功能。

java.awt.image 使用的 java.awt.image 中的类
BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
BufferedImageOp
此接口描述对 BufferedImage 对象所执行的单输入/单输出操作。
ColorModel
此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
ComponentSampleModel
此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。
DataBuffer
此类用于包装一个或多个数据数组。
ImageConsumer
对通过 ImageProducer 接口的图像数据感兴趣的对象接口。
ImageFilter
此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。
ImageProducer
可为 Image 生成图像数据的对象的接口。
IndexColorModel
IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
Kernel
Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。
LookupTable
此抽象类定义了一个查找表对象。
PackedColorModel
PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。
Raster
表示像素矩形数组的类。
RasterOp
此接口描述对 Raster 对象执行的单输入/单输出操作。
RenderedImage
RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。
ReplicateScaleFilter
使用最简单的算法缩放图像的 ImageFilter 类。
SampleModel
此抽象类定义一个提取图像像素样本的接口。
TileObserver
希望在出现以下情况时被通知的对象的接口：某个 writer 通过调用 getWritableTile 使 WritableRenderedImage 的 tile 变得可修改；通过最后调用 releaseWritableTile 使这些 tile 变得不可修改。
WritableRaster
此类扩展了 Raster 以提供像素写入功能。
WritableRenderedImage
WriteableRenderedImage 公共接口用于那些包含或者能够生成 Rasters 形式图像数据的对象，以及能够被修改和/或写入的对象。

java.awt.image.renderable 使用的 java.awt.image 中的类
ImageConsumer
对通过 ImageProducer 接口的图像数据感兴趣的对象接口。
ImageProducer
可为 Image 生成图像数据的对象的接口。
RenderedImage
RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。

javax.imageio 使用的 java.awt.image 中的类
BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
ColorModel
此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
Raster
表示像素矩形数组的类。
RenderedImage
RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。
SampleModel
此抽象类定义一个提取图像像素样本的接口。

javax.imageio.event 使用的 java.awt.image 中的类
BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。

javax.imageio.spi 使用的 java.awt.image 中的类
RenderedImage
RenderedImage 是一个通用接口，用于包含或生成 Raster 形式图像数据的对象。

javax.swing 使用的 java.awt.image 中的类
ImageConsumer
对通过 ImageProducer 接口的图像数据感兴趣的对象接口。
ImageFilter
此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。
RGBImageFilter
此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

javax.swing.colorchooser 使用的 java.awt.image 中的类
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

javax.swing.plaf.basic 使用的 java.awt.image 中的类
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

javax.swing.plaf.metal 使用的 java.awt.image 中的类
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

javax.swing.table 使用的 java.awt.image 中的类
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

javax.swing.text 使用的 java.awt.image 中的类
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

javax.swing.tree 使用的 java.awt.image 中的类
ImageObserver
用于在构造 Image 时，接收有关 Image 信息通知的异步更新接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ContextualRenderedImageFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.image.renderable
接口 ContextualRenderedImageFactory

所有超级接口：
RenderedImageFactory
public interface ContextualRenderedImageFactory
extends RenderedImageFactory

ContextualRenderedImageFactory 为在 RenderableImageOp 实例之间可能不同的功能提供接口。因此，单个类（如 RenderedImageOp）可以通过使用 ContextualRenderedImageFactory 的多个实例对 RenderableImage 执行不同的操作。名称 ContextualRenderedImageFactory 通常缩写为 "CRIF"。

所有要在与呈现无关的链中使用的操作必须实现 ContextualRenderedImageFactory。

实现此接口的类必须提供不带参数的构造方法。

方法摘要
 RenderedImage create(RenderContext renderContext, ParameterBlock paramBlock)
根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
 Rectangle2D getBounds2D(ParameterBlock paramBlock)
返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。
 Object getProperty(ParameterBlock paramBlock, String name)
获取由 name 参数指定的属性的适当实例。
 String[] getPropertyNames()
返回由 getProperty 识别的名称列表。
 boolean isDynamic()
如果使用相同参数的后续呈现（即调用 create(RenderContext, ParameterBlock)）可以生成不同的结果，则返回 true。
 RenderContext mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。
从接口 java.awt.image.renderable.RenderedImageFactory 继承的方法
create

方法详细信息

mapRenderContext

RenderContext mapRenderContext(int i,
                               RenderContext renderContext,
                               ParameterBlock paramBlock,
                               RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。这对以下操作非常有用：可以在 RenderContext 中完整表达或仅作为替换的一部分表达的操作，如仿射映射；为节省处理工作或传输带宽，希望获取源的较低质量的呈现的操作。某些操作（如模糊处理）也可以使用此机制来避免获取高于所需质量的源。

参数：
i - 源图像的索引。
renderContext - 应用于操作的 RenderContext。
paramBlock - 包含操作的源和参数的 ParameterBlock。
image - 正被呈现的 RenderableImage。
返回：
源的 RenderContext，该源位于指定 ParameterBlock 包含的参数 Vector 的指定索引处。

create

RenderedImage create(RenderContext renderContext,
                     ParameterBlock paramBlock)
根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。输出一个用 RenderContext 确定其在图像平面上的尺寸和位置的 RenderedImage。此方法内含“智能”，允许与呈现无关的操作，以适合特定的 RenderContext。

参数：
renderContext - 指定呈现的 RenderContext
paramBlock - 包含操作的源和参数的 ParameterBlock
返回：
根据指定 ParameterBlock 中的源和参数并按照指定 RenderContext 的呈现指令确定的 RenderedImage。

getBounds2D

Rectangle2D getBounds2D(ParameterBlock paramBlock)
返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。该边界作为一个 Rectangle2D 返回，即一个带浮点值角坐标的沿轴对齐的（axis-aligned）矩形。

参数：
paramBlock - 包含操作的源和参数的 ParameterBlock。
返回：
指定输出的与呈现无关的边界框的 Rectangle2D。

getProperty

Object getProperty(ParameterBlock paramBlock,
                   String name)
获取由 name 参数指定的属性的适当实例。如果存在多个源，并且每个源都指定某个属性，此方法必须确定返回该属性的哪个实例。

参数：
paramBlock - 包含操作的源和参数的 ParameterBlock。
name - 命名所需属性的字符串。
返回：
引用所请求属性的值的对象。

getPropertyNames

String[] getPropertyNames()
返回由 getProperty 识别的名称列表。

返回：
属性名称的列表。

isDynamic

boolean isDynamic()
如果使用相同参数的后续呈现（即调用 create(RenderContext, ParameterBlock)）可以生成不同的结果，则返回 true。可以使用此方法来确定某个现有呈现是否可以被缓存或重用。返回 true 表示始终安全。

返回：
如果使用相同参数的后续呈现可以生成不同结果，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ParameterBlock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image.renderable
类 ParameterBlock

java.lang.Object
    继承者  java.awt.image.renderable.ParameterBlock
所有已实现的接口：
Serializable, Cloneable
public class ParameterBlock
extends Object
implements Cloneable, Serializable

ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。

尽管可以将任意对象放入源 Vector，但此类的用户可能会强加一些语义限制，如要求所有源都作为 RenderedImages 或 RenderableImage。ParameterBlock 本身只是一个容器，而且不对源或参数类型执行检查。

ParameterBlock 中的所有参数都是对象；可以使用便捷的 add 和 set 方法，这些方法带基本类型的参数并构建 Number（Integer 或 Float）的适当子类。相应的 get 方法执行向下强制转换并拥有基本类型的返回值；如果存储的值没有正确的类型，则会抛出异常。无法区分 "short s; add(s)" 和 "add(new Short(s))" 之间的结果。

注意，get 和 set 方法对引用进行操作。因此，需要小心的是，在不适当的时候一定不要共享 ParameterBlock 之间的引用。例如，要创建一个与旧 ParameterBlock（除了添加的源之外）相等的新 ParameterBlock，有人可能会尝试编写以下程序：

 ParameterBlock addSource(ParameterBlock pb, RenderableImage im) {
     ParameterBlock pb1 = new ParameterBlock(pb.getSources());
     pb1.addSource(im);
     return pb1;
 }

这段代码具有替换原来 ParameterBlock 的负作用，因为 getSources 操作返回一个对其源 Vector 的引用。pb 和 pb1 同时共享其源 Vector，而且对其中之一的更改相对于两者来说都是可见的。

编写 addSource 函数的正确方法是复制源 Vector：

 ParameterBlock addSource (ParameterBlock pb, RenderableImage im) {
     ParameterBlock pb1 = new ParameterBlock(pb.getSources().clone());
     pb1.addSource(im);
     return pb1;
 }

因此，定义了 ParameterBlock 的 clone 方法，以执行源和参数 Vectors 的副本。可以使用标准的浅表副本 shallowClone。

定义了 addSource、setSource、add 和 set 方法，以在添加其参数后返回 'this'。这允许使用类似以下的语法：

 ParameterBlock pb = new ParameterBlock();
 op = new RenderableImageOp("operation", pb.add(arg1).add(arg2));

另请参见：
序列化表格

字段摘要
protected Vector<Object> | parameters 一个非源参数的 Vector，存储为任意 Object。
protected Vector<Object> | sources 源的 Vector，存储为任意 Objects。
构造方法摘要
ParameterBlock()
一个 dummy 构造方法。
ParameterBlock(Vector<Object> sources)
使用源的给定 Vector 构造一个 ParameterBlock。
ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。
方法摘要
ParameterBlock | add(byte b) 将一个 Byte 添加到此参数列表。
ParameterBlock | add(char c) 将一个 Character 添加到此参数列表。
ParameterBlock | add(double d) 将一个 Double 添加到此参数列表。
ParameterBlock | add(float f) 将一个 Float 添加到此参数列表。
ParameterBlock | add(int i) 将一个 Integer 添加到此参数列表。
ParameterBlock | add(long l) 将一个 Long 添加到此参数列表。
ParameterBlock | add(Object obj) 将一个 Object 添加到此参数列表。
ParameterBlock | add(short s) 将一个 Short 添加到此参数列表。
ParameterBlock | addSource(Object source) 将一个图像添加到源列表的末尾。
Object | clone() 创建 ParameterBlock 的一个副本。
byte | getByteParameter(int index) 作为 byte 返回参数的便捷方法。
char | getCharParameter(int index) 作为 char 返回参数的便捷方法。
double | getDoubleParameter(int index) 作为 double 返回参数的便捷方法。
float | getFloatParameter(int index) 作为 float 返回参数的便捷方法。
int | getIntParameter(int index) 作为 int 返回参数的便捷方法。
long | getLongParameter(int index) 作为 long 返回参数的便捷方法。
int | getNumParameters() 返回参数的数量（不包括源图像）。
int | getNumSources() 返回源图像的数量。
Object | getObjectParameter(int index) 获取作为对象的参数。
Class[] | getParamClasses() 返回描述该参数的 Class 对象的数组。
Vector<Object> | getParameters() 返回参数的整个 Vector。
RenderableImage | getRenderableSource(int index) 返回作为 RenderableImage 的源。
RenderedImage | getRenderedSource(int index) 返回作为 RenderedImage 的源。
short | getShortParameter(int index) 作为 short 返回参数的便捷方法。
Object | getSource(int index) 返回作为通用 Object 的源。
Vector<Object> | getSources() 返回源的整个 Vector。
void | removeParameters() 清除参数列表。
void | removeSources() 清除源图像的列表。
ParameterBlock | set(byte b, int index) 使用 Byte 替换参数列表中的一个 Object。
ParameterBlock | set(char c, int index) 使用 Character 替换参数列表中的一个 Object。
ParameterBlock | set(double d, int index) 使用 Double 替换参数列表中的一个 Object。
ParameterBlock | set(float f, int index) 使用 Float 替换参数列表中的一个 Object。
ParameterBlock | set(int i, int index) 使用 Integer 替换参数列表中的一个 Object。
ParameterBlock | set(long l, int index) 使用 Long 替换参数列表中的一个 Object。
ParameterBlock | set(Object obj, int index) 替换此参数列表中的一个 Object。
ParameterBlock | set(short s, int index) 使用 Short 替换参数列表中的一个 Object。
void | setParameters(Vector<Object> parameters) 将参数的整个 Vector 设置为给定 Vector。
ParameterBlock | setSource(Object source, int index) 将源列表中的某个项替换为一个新源。
void | setSources(Vector<Object> sources) 将源的整个 Vector 设置为给定 Vector。
Object | shallowClone() 创建 ParameterBlock 的一个浅表副本。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

sources

protected Vector<Object> sources
源的 Vector，存储为任意 Objects。

parameters

protected Vector<Object> parameters
一个非源参数的 Vector，存储为任意 Object。

构造方法详细信息

ParameterBlock

public ParameterBlock()
一个 dummy 构造方法。

ParameterBlock

public ParameterBlock(Vector<Object> sources)
使用源的给定 Vector 构造一个 ParameterBlock。

参数：
sources - 源映像的 Vector

ParameterBlock

public ParameterBlock(Vector<Object> sources,
                      Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。

参数：
sources - 源映像的 Vector
parameters - 要在呈现操作中使用的参数的 Vector
方法详细信息

shallowClone

public Object shallowClone()
创建 ParameterBlock 的一个浅表副本。按引用复制源和参数 Vectors，添加或更改将对两个版本都可见。

返回：
ParameterBlock 的 Object 副本。

clone

public Object clone()
创建 ParameterBlock 的一个副本。复制源和参数 Vector，但实际源和参数按引用复制。这允许对副本中源和参数的顺序和数量的更改在初始 ParameterBlock 中可见。对共享源或参数本身的更改仍将可见。

覆盖：
类 Object 中的 clone
返回：
ParameterBlock 的 Object 副本。
另请参见：
Cloneable

addSource

public ParameterBlock addSource(Object source)
将一个图像添加到源列表的末尾。将图像存储为对象，以便将来允许新的节点类型。

参数：
source - 将存储到源列表中的图像对象。
返回：
包含指定 source 的新 ParameterBlock。

getSource

public Object getSource(int index)
返回作为通用 Object 的源。调用者必须将其强制转换为一个适当的类型。

参数：
index - 要返回的源的索引。
返回：
表示位于 sources Vector 中指定索引处的源的 Object。
另请参见：
setSource(Object, int)

setSource

public ParameterBlock setSource(Object source,
                                int index)
将源列表中的某个项替换为一个新源。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
source - 指定的源图像
index - 指向 sources Vector 索引，在该处将插入指定的 source
返回：
包含位于指定 index 处的指定 source 的新 ParameterBlock。
另请参见：
getSource(int)

getRenderedSource

public RenderedImage getRenderedSource(int index)
返回作为 RenderedImage 的源。这是一种便捷方法。如果源不是 RenderedImage，则会抛出异常。

参数：
index - 要返回的源的索引
返回：
表示位于 sources Vector 中指定索引处的源图像的 RenderedImage。

getRenderableSource

public RenderableImage getRenderableSource(int index)
返回作为 RenderableImage 的源。这是一种便捷方法。如果源不是 RenderableImage，则会抛出异常。

参数：
index - 要返回的源的索引
返回：
表示位于此 sources Vector 中指定索引处的源图像的 RenderableImage。

getNumSources

public int getNumSources()
返回源图像的数量。

返回：
返回此 sources Vector 中源图像的数量。

getSources

public Vector<Object> getSources()
返回源的整个 Vector。

返回：
sources Vector。
另请参见：
setSources(Vector)

setSources

public void setSources(Vector<Object> sources)
将源的整个 Vector 设置为给定 Vector。

参数：
sources - 源图像的 Vector
另请参见：
getSources()

removeSources

public void removeSources()
清除源图像的列表。

getNumParameters

public int getNumParameters()
返回参数的数量（不包括源图像）。

返回：
此 parameters Vector 中的参数数量。

getParameters

public Vector<Object> getParameters()
返回参数的整个 Vector。

返回：
parameters Vector。
另请参见：
setParameters(Vector)

setParameters

public void setParameters(Vector<Object> parameters)
将参数的整个 Vector 设置为给定 Vector。

参数：
parameters - 参数的指定 Vector
另请参见：
getParameters()

removeParameters

public void removeParameters()
清除参数列表。

add

public ParameterBlock add(Object obj)
将一个 Object 添加到此参数列表。

参数：
obj - 要添加到此 parameters Vector 的 Object
返回：
一个包含指定参数的新 ParameterBlock。

add

public ParameterBlock add(byte b)
将一个 Byte 添加到此参数列表。

参数：
b - 要添加到此 parameters Vector 的 Byte
返回：
一个包含指定参数的新 ParameterBlock。

add

public ParameterBlock add(char c)
将一个 Character 添加到此参数列表。

参数：
c - 要添加到此 parameters Vector 的 char
返回：
包含指定参数的新 ParameterBlock。

add

public ParameterBlock add(short s)
将一个 Short 添加到此参数列表。

参数：
s - 要添加到此 parameters Vector 的 short
返回：
一个包含指定参数的新 ParameterBlock。

add

public ParameterBlock add(int i)
将一个 Integer 添加到此参数列表。

参数：
i - 要添加到此 parameters Vector 的 int
返回：
一个包含指定参数的新 ParameterBlock。

add

public ParameterBlock add(long l)
将一个 Long 添加到此参数列表。

参数：
l - 要添加到此 parameters Vector 的 long
返回：
一个包含指定参数的新 ParameterBlock。

add

public ParameterBlock add(float f)
将一个 Float 添加到此参数列表。

参数：
f - 要添加到此 parameters Vector 的 float
返回：
一个包含指定参数的新 ParameterBlock。

add

public ParameterBlock add(double d)
将一个 Double 添加到此参数列表。

参数：
d - 要添加到此 parameters Vector 的 double
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(Object obj,
                          int index)
替换此参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
obj - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(byte b,
                          int index)
使用 Byte 替换参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
b - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(char c,
                          int index)
使用 Character 替换参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
c - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(short s,
                          int index)
使用 Short 替换参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
s - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(int i,
                          int index)
使用 Integer 替换参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
i - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(long l,
                          int index)
使用 Long 替换参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
l - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(float f,
                          int index)
使用 Float 替换参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
f - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

set

public ParameterBlock set(double d,
                          int index)
使用 Double 替换参数列表中的一个 Object。如果索引位于当前源列表之外，则该列表将根据需要使用 null 进行扩展。

参数：
d - 替换 parameters Vector 中指定索引处参数的参数
index - 要使用指定参数替换的参数索引
返回：
一个包含指定参数的新 ParameterBlock。

getObjectParameter

public Object getObjectParameter(int index)
获取作为对象的参数。

参数：
index - 要获取的参数的索引
返回：
表示 parameters Vector 中指定索引处参数的 Object。

getByteParameter

public byte getByteParameter(int index)
作为 byte 返回参数的便捷方法。如果该参数为 null 或者不是一个 Byte，则抛出异常。

参数：
index - 要返回的参数的索引。
返回：
指定索引处作为 byte 值的参数。
抛出：
ClassCastException - 如果指定索引处的参数不是一个 Byte
NullPointerException - 如果指定索引处的参数为 null
ArrayIndexOutOfBoundsException - 如果 index 为负或不小于此 ParameterBlock 对象的当前大小

getCharParameter

public char getCharParameter(int index)
作为 char 返回参数的便捷方法。如果该参数为 null 或者不是 Character，则抛出异常。

参数：
index - 要返回的参数的索引。
返回：
指定索引处作为 char 值的参数。
抛出：
ClassCastException - 如果指定索引处的参数不是一个 Character
NullPointerException - 如果指定索引处的参数为 null
ArrayIndexOutOfBoundsException - 如果 index 为负或不小于此 ParameterBlock 对象的当前大小

getShortParameter

public short getShortParameter(int index)
作为 short 返回参数的便捷方法。如果该参数为 null 或者不是一个 Short，则抛出异常。

参数：
index - 要返回的参数的索引。
返回：
指定索引处作为 short 值的参数。
抛出：
ClassCastException - 如果指定索引处的参数不是一个 Short
NullPointerException - 如果指定索引处的参数为 null
ArrayIndexOutOfBoundsException - 如果 index 为负或不小于此 ParameterBlock 对象的当前大小

getIntParameter

public int getIntParameter(int index)
作为 int 返回参数的便捷方法。如果该参数为 null 或者不是一个 Integer，则抛出异常。

参数：
index - 要返回的参数的索引。
返回：
指定索引处作为 int 值的参数。
抛出：
ClassCastException - 如果指定索引处的参数不是一个 Integer
NullPointerException - 如果指定索引处的参数为 null
ArrayIndexOutOfBoundsException - 如果 index 为负或不小于此 ParameterBlock 对象的当前大小

getLongParameter

public long getLongParameter(int index)
作为 long 返回参数的便捷方法。如果该参数为 null 或者不是 Long，则抛出异常。

参数：
index - 要返回的参数的索引。
返回：
指定索引处作为 long 值的参数。
抛出：
ClassCastException - 如果指定索引处的参数不是一个 Long
NullPointerException - 如果指定索引处的参数为 null
ArrayIndexOutOfBoundsException - 如果 index 为负或不小于此 ParameterBlock 对象的当前大小

getFloatParameter

public float getFloatParameter(int index)
作为 float 返回参数的便捷方法。如果该参数为 null 或者不是一个 Float，则抛出异常。

参数：
index - 要返回的参数的索引。
返回：
指定索引处作为 float 值的参数。
抛出：
ClassCastException - 如果指定索引处的参数不是一个 Float
NullPointerException - 如果指定索引处的参数为 null
ArrayIndexOutOfBoundsException - 如果 index 为负或不小于此 ParameterBlock 对象的当前大小

getDoubleParameter

public double getDoubleParameter(int index)
作为 double 返回参数的便捷方法。如果该参数为 null 或者不是一个 Double，则抛出异常。

参数：
index - 要返回的参数的索引。
返回：
指定索引处作为 double 值的参数。
抛出：
ClassCastException - 如果指定索引处的参数不是一个 Double
NullPointerException - 如果指定索引处的参数为 null
ArrayIndexOutOfBoundsException - 如果 index 为负或不小于此 ParameterBlock 对象的当前大小

getParamClasses

public Class[] getParamClasses()
返回描述该参数的 Class 对象的数组。

返回：
Class 对象的数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderableImage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image.renderable
接口 RenderableImage

所有已知实现类：
RenderableImageOp
public interface RenderableImage

RenderableImage 是与呈现无关的图像（该概念包含与分辨率无关的意思）的公共接口。与呈现无关的图像也就是被描述的、应用与其任何特定呈现无关的操作的那些图像。例如，一个满足以下条件的 RenderableImage：它可以旋转并可以按与分辨率无关的条件进行裁剪。然后，它可以针对各种特定的上下文（如草图预览、高质量屏幕显示或打印机）以最优方式呈现。

RenderedImage 通过 createRendering() 方法从 RenderableImage 返回，该方法采用 RenderContext 作为参数。RenderContext 指定 RenderedImage 的构造方式。注意，不能直接从 RenderableImage 中提取像素。

createDefaultRendering() 和 createScaledRendering() 方法是内部构造适当 RenderContext 的便捷方法。所有呈现方法都可以返回对以前生成的呈现的引用。

字段摘要
static String HINTS_OBSERVED
可以用于在通过 createRendering 或 createScaledRendering 方法获取的 RenderedImage 上标识属性的字符串常量。
方法摘要
 RenderedImage createDefaultRendering()
返回此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
 RenderedImage createRendering(RenderContext renderContext)
使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。
 RenderedImage createScaledRendering(int w, int h, RenderingHints hints)
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
 float getHeight()
获取用户坐标空间中的高度。
 float getMinX()
获取与呈现无关的图像数据的最小 X 坐标。
 float getMinY()
获取与呈现无关的图像数据的最小 Y 坐标。
 Object getProperty(String name)
从此图像的属性集中获取某个属性。
 String[] getPropertyNames()
返回由 getProperty 识别的名称列表。
 Vector<RenderableImage> getSources()
返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。
 float getWidth()
获取用户坐标空间中的宽度。
 boolean isDynamic()
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同的结果，则返回 true。

字段详细信息

HINTS_OBSERVED

static final String HINTS_OBSERVED
可以用于在通过 createRendering 或 createScaledRendering 方法获取的 RenderedImage 上标识属性的字符串常量。如果存在此类属性，则该属性的值将是一个 RenderingHints 对象，该对象指定在创建该呈现时要注意的提示。

另请参见：
常量字段值
方法详细信息

getSources

Vector<RenderableImage> getSources()
返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。注意，此方法可能返回空向量，指示该图像没有源，或者返回 null，指示没有可用信息。

返回：
RenderableImages 的（可能为空的）Vector，或者 null。

getProperty

Object getProperty(String name)
从此图像的属性集中获取某个属性。如果该属性名无法识别，将返回 java.awt.Image.UndefinedProperty。

参数：
name - 要获取的属性名称（以 String 形式）。
返回：
对属性 Object 的引用，或者值 java.awt.Image.UndefinedProperty。

getPropertyNames

String[] getPropertyNames()
返回由 getProperty 识别的名称列表。

返回：
属性名称列表。

isDynamic

boolean isDynamic()
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同的结果，则返回 true。此方法可用于确定是否可以缓存和重用现有呈现。返回 true 始终安全。

返回：
如果使用相同参数的后续呈现可以生成不同结果，则返回 true；否则返回 false。

getWidth

float getWidth()
获取用户坐标空间中的宽度。按照惯例，RenderableImage 的常规宽度等于该图像的高宽比（宽度除以高度）。

返回：
用户坐标中图像的宽度。

getHeight

float getHeight()
获取用户坐标空间中的高度。按照惯例，RenderedImage 的常规宽度等于 1.0F。

返回：
用户坐标中图像的高度。

getMinX

float getMinX()
获取与呈现无关的图像数据的最小 X 坐标。

返回：
与呈现无关的图像数据的最小 X 坐标。

getMinY

float getMinY()
获取与呈现无关的图像数据的最小 Y 坐标。

返回：
与呈现无关的图像数据的最小 Y 坐标。

createScaledRendering

RenderedImage createScaledRendering(int w,
                                    int h,
                                    RenderingHints hints)
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。使用适当的 usr2dev 变换和完整图像的感兴趣区域自动构建 RenderContext。所有呈现提示均来自传入的提示。

如果 w == 0，则该值将等于 Math.round(h*(getWidth()/getHeight()))。类似地，如果 h == 0，则该值将等于 Math.round(w*(getHeight()/getWidth()))。w 和 h 中必须有一个不为零，否则将抛出 IllegalArgumentException。

创建的 RenderedImage 可能有一个由字符串 HINTS_OBSERVED 标识的属性，以指示使用了哪些 RenderingHints 创建该图像。此外，通过创建的 RenderedImage 上的 getSources() 方法获得的任何 RenderedImage 都可能具该属性。

参数：
w - 所呈现图像的宽度（以像素为单位），或者为 0。
h - 所呈现图像的高度（以像素为单位），或者为 0。
hints - 包含提示的 RenderingHints 对象。
返回：
包含所呈现数据的 RenderedImage。

createDefaultRendering

RenderedImage createDefaultRendering()
返回此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。使用适当的 usr2dev 变换和完整图像的感兴趣区域自动构建 RenderContext。该呈现提示为空。为提高速度，createDefaultRendering 可能会使用已存储的呈现。

返回：
包含所呈现数据的 RenderedImage。

createRendering

RenderedImage createRendering(RenderContext renderContext)
使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。这是获得 RenderableImage 的呈现的最通用的方法。

创建的 RenderedImage 可能有一个由字符串 HINTS_OBSERVED 标识的属性，以指示使用了哪些 RenderingHints（来自 RenderContext）创建该图像。此外，通过创建的 RenderedImage 上的 getSources() 方法获得的任何 RenderedImage 都可能具有该属性。

参数：
renderContext - 用于生成呈现的 RenderContext。
返回：
包含所呈现数据的 RenderedImage。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderableImageOp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image.renderable
类 RenderableImageOp

java.lang.Object
    继承者  java.awt.image.renderable.RenderableImageOp
所有已实现的接口：
RenderableImage
public class RenderableImageOp
extends Object
implements RenderableImage

此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。

字段摘要
从接口 java.awt.image.renderable.RenderableImage 继承的字段
HINTS_OBSERVED
构造方法摘要
RenderableImageOp(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。
方法摘要
 RenderedImage createDefaultRendering()
获取此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
 RenderedImage createRendering(RenderContext renderContext)
创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。
 RenderedImage createScaledRendering(int w, int h, RenderingHints hints)
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
 float getHeight()
获取用户坐标空间中的高度。
 float getMinX()
获取与呈现无关的图像数据的最小 X 坐标。
 float getMinY()
获取与呈现无关的图像数据的最小 Y 坐标。
 ParameterBlock getParameterBlock()
返回到对当前参数块的一个引用。
 Object getProperty(String name)
从此图像的属性集中获取某个属性。
 String[] getPropertyNames()
返回由 getProperty 识别的名称列表。
 Vector<RenderableImage> getSources()
返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。
 float getWidth()
获取用户坐标空间中的宽度。
 boolean isDynamic()
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同结果，则返回 true。
 ParameterBlock setParameterBlock(ParameterBlock paramBlock)
更改操作的当前 ParameterBlock，允许编辑图像呈现链。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RenderableImageOp

public RenderableImageOp(ContextualRenderedImageFactory CRIF,
                         ParameterBlock paramBlock)
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。由 ParameterBlock 引用的任何 RenderedImage 源都将被忽略。

参数：
CRIF - 一个 ContextualRenderedImageFactory 对象
paramBlock - 一个包含此操作的源图像和该操作运行所必须的其他参数的 ParameterBlock。
方法详细信息

getSources

public Vector<RenderableImage> getSources()
返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。注意，此方法可能返回空向量，指示该图像没有源，或者返回 null，指示没有可用信息。

指定者：
接口 RenderableImage 中的 getSources
返回：
RenderableImage 的 Vector（可能为空），或者 null。

getProperty

public Object getProperty(String name)
从此图像的属性集中获取某个属性。如果该属性名无法识别，将返回 java.awt.Image.UndefinedProperty。

指定者：
接口 RenderableImage 中的 getProperty
参数：
name - 要获取的属性的名称（以 String 形式）。
返回：
对属性 Object 的引用，或者值 java.awt.Image.UndefinedProperty。

getPropertyNames

public String[] getPropertyNames()
返回由 getProperty 识别的名称列表。

指定者：
接口 RenderableImage 中的 getPropertyNames
返回：
属性名称列表。

isDynamic

public boolean isDynamic()
如果使用相同参数的后续呈现（即调用 createRendering() 或 createScaledRendering()）可以生成不同结果，则返回 true。此方法可用于确定是否可以缓存和重用现有呈现。将调用 CRIF 的 isDynamic 方法。

指定者：
接口 RenderableImage 中的 isDynamic
返回：
如果使用相同参数的后续呈现可以生成不同结果，则返回 true；否则返回 false。

getWidth

public float getWidth()
获取用户坐标空间中的宽度。按照惯例，RenderableImage 的常规宽度等于该图像的高宽比（宽度除以高度）。

指定者：
接口 RenderableImage 中的 getWidth
返回：
用户坐标中图像的宽度。

getHeight

public float getHeight()
获取用户坐标空间中的高度。按照惯例，RenderedImage 的常规高度等于 1.0F。

指定者：
接口 RenderableImage 中的 getHeight
返回：
用户坐标中图像的高度。

getMinX

public float getMinX()
获取与呈现无关的图像数据的最小 X 坐标。

指定者：
接口 RenderableImage 中的 getMinX
返回：
与呈现无关的图像数据的最小 X 坐标。

getMinY

public float getMinY()
获取与呈现无关的图像数据的最小 Y 坐标。

指定者：
接口 RenderableImage 中的 getMinY
返回：
与呈现无关的图像数据的最小 Y 坐标。

setParameterBlock

public ParameterBlock setParameterBlock(ParameterBlock paramBlock)
更改操作的当前 ParameterBlock，允许编辑图像呈现链。当根据此 RenderableImageOp 或任何相关 RenderableImageOp 创建新呈现时，此更改的效果将是可见的。

参数：
paramBlock - 新的 ParameterBlock。
返回：
旧的 ParameterBlock。
另请参见：
getParameterBlock()

getParameterBlock

public ParameterBlock getParameterBlock()
返回到对当前参数块的一个引用。

返回：
此 RenderableImageOp 的 ParameterBlock。
另请参见：
setParameterBlock(ParameterBlock)

createScaledRendering

public RenderedImage createScaledRendering(int w,
                                           int h,
                                           RenderingHints hints)
创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。使用适当的 usr2dev 变换和完整图像感兴趣的区域自动构建 RenderContext。所有呈现提示均来自传入的提示。

如果 w == 0，则该值将等于 Math.round(h*(getWidth()/getHeight()))。类似地，如果 h == 0，则该值将等于 Math.round(w*(getHeight()/getWidth()))。w 和 h 中必须有一个不为零，否则将抛出 IllegalArgumentException。

创建的 RenderedImage 可能有一个由字符串 HINTS_OBSERVED 标识的属性，以指示使用了哪些 RenderingHints 创建该图像。此外，通过创建的 RenderedImage 上的 getSources() 方法获得的任何 RenderedImage 都可能具有该属性。

指定者：
接口 RenderableImage 中的 createScaledRendering
参数：
w - 所呈现图像的宽度（以像素为单位），或者为 0。
h - 所呈现图像的高度（以像素为单位），或者为 0。
hints - 包含提示的 RenderingHints 对象。
返回：
包含所呈现数据的 RenderedImage。

createDefaultRendering

public RenderedImage createDefaultRendering()
获取此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。使用适当的 usr2dev 变换和完整图像感兴趣的区域自动构建 RenderContext。所有呈现提示均来自传入的提示。此接口的实现者必须保证存在已定义的默认宽度和高度。

指定者：
接口 RenderableImage 中的 createDefaultRendering
返回：
包含所呈现数据的 RenderedImage。

createRendering

public RenderedImage createRendering(RenderContext renderContext)
创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。

此方法支持 Renderable 或 RenderedImage 操作的链接。如果用于构造 RenderableImageOp 的 ParameterBlock 中的源为 RenderableImages，则遵循一个三步骤的过程：

  1. 对每个 RenderableImage 源在相关的 CRIF 上调用 mapRenderContext()；
  2. 使用在第 1 步中获取的向后映射的 RenderContext 在每个 RenderableImage 源上调用 createRendering()，得到每个源的呈现；
  3. 调用 ContextualRenderedImageFactory.create()，使用一个新 ParameterBlock，其包含通过调用 createRendering() 创建的 RenderedImage 和 RenderableImageOp 的参数。

如果用于构造 RenderableImageOp 的 ParameterBlock 源 Vector 的元素是 RenderedImage 实例，则立即使用初始 ParameterBlock 调用 CRIF.create() 方法。这为递归提供了一个基本方案。

创建的 RenderedImage 可能有一个由字符串 HINTS_OBSERVED 标识的属性，以指示使用了哪些 RenderingHints（来自 RenderContext）创建该图像。此外，通过创建的 RenderedImage 上的 getSources() 方法获得的任何 RenderedImages 都可能具有该属性。

指定者：
接口 RenderableImage 中的 createRendering
参数：
renderContext - 用于执行呈现的 RenderContext。
返回：
包含所需输出图像的 RenderedImage。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderableImageProducer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image.renderable
类 RenderableImageProducer

java.lang.Object
    继承者  java.awt.image.renderable.RenderableImageProducer
所有已实现的接口：
ImageProducer, Runnable
public class RenderableImageProducer
extends Object
implements ImageProducer, Runnable

实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。ImageConsumer 的大小由 RenderContext 中 usr2dev 变换的缩放因子确定。如果 RenderContext 为 null，则使用 RenderableImage 的默认呈现。此类实现用一个分辨率在一个线程中生成图像的异步生成。可以为此类创建子类，以实现使用多个线程呈现图像的版本。这些线程可以用越来越好的质量呈现同一个图像，也可以用单一分辨率呈现图像的不同部分。

构造方法摘要
RenderableImageProducer(RenderableImage rdblImage, RenderContext rc)
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。
方法摘要
void | addConsumer(ImageConsumer ic) 将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表。
boolean | isConsumer(ImageConsumer ic) 确定某个 ImageConsumer 是否在当前对此图像的数据感兴趣的使用者列表。
void | removeConsumer(ImageConsumer ic) 从对此图像的数据感兴趣的使用者列表中删除一个 ImageConsumer。
void | requestTopDownLeftRightResend(ImageConsumer ic) 请求给定 ImageConsumer 按从上到下、从左到右的顺序再次提交图像数据。
void | run() 此类的 runnable 方法。
void | setRenderContext(RenderContext rc) 设置下一次调用 startProduction() 要使用的新 RenderContext。
void | startProduction(ImageConsumer ic) 将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表，并立即通过 ImageConsumer 接口开始提交该图像数据。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RenderableImageProducer

public RenderableImageProducer(RenderableImage rdblImage,
                               RenderContext rc)
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。

参数：
rdblImage - 要呈现的 RenderableImage。
rc - 用于生成像素的 RenderContext。
方法详细信息

setRenderContext

public void setRenderContext(RenderContext rc)
设置下一次调用 startProduction() 要使用的新 RenderContext。

参数：
rc - 新 RenderContext。

addConsumer

public void addConsumer(ImageConsumer ic)
将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表。

指定者：
接口 ImageProducer 中的 addConsumer
参数：
ic - 要添加到兴趣列表的 ImageConsumer。
另请参见：
ImageProducer.startProduction(java.awt.image.ImageConsumer)

isConsumer

public boolean isConsumer(ImageConsumer ic)
确定某个 ImageConsumer 是否在当前对此图像的数据感兴趣的使用者列表。

指定者：
接口 ImageProducer 中的 isConsumer
参数：
ic - 要检查的 ImageConsumer。
返回：
如果 ImageConsumer 在列表上，则返回 true；否则返回 false。

removeConsumer

public void removeConsumer(ImageConsumer ic)
从对此图像的数据感兴趣的使用者列表中删除一个 ImageConsumer。

指定者：
接口 ImageProducer 中的 removeConsumer
参数：
ic - 要删除的 ImageConsumer。

startProduction

public void startProduction(ImageConsumer ic)
将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表，并立即通过 ImageConsumer 接口开始提交该图像数据。

指定者：
接口 ImageProducer 中的 startProduction
参数：
ic - 要添加到使用者列表的 ImageConsumer。
另请参见：
ImageProducer.addConsumer(java.awt.image.ImageConsumer)

requestTopDownLeftRightResend

public void requestTopDownLeftRightResend(ImageConsumer ic)
请求给定 ImageConsumer 按从上到下、从左到右的顺序再次提交图像数据。

指定者：
接口 ImageProducer 中的 requestTopDownLeftRightResend
参数：
ic - 请求重新发送的 ImageConsumer。
另请参见：
ImageConsumer.setHints(int)

run

public void run()
此类的 runnable 方法。这将使用当前的 RenderableImage 和 RenderContext 生成一个图像，并将其发送到所有当前已向此类注册的 ImageConsumer。

指定者：
接口 Runnable 中的 run
另请参见：
Thread.run()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.image.renderable
类 RenderContext

java.lang.Object
    继承者  java.awt.image.renderable.RenderContext
所有已实现的接口：
Cloneable
public class RenderContext
extends Object
implements Cloneable

RenderContext 封装从 enderableImage 生成特定呈现所需的信息。它包含与呈现无关的条件中指定的要呈现的区域、呈现执行的分辨率和用于控制呈现过程的提示。

用户创建 RenderContext 并通过 createRendering 方法将它们传递到 RenderableImage。RenderContext 的多数方法不是为了让应用程序直接使用，而是由它传递到的 RenderableImage 和操作符类直接使用。

传入此类和从此类传出的 AffineTransform 参数被复制。RenderingHints 和 Shape 参数不一定是可复制的，并因此仅复制引用。改变正在由 RenderContext 实例使用的 RenderingHints 或 Shape 实例可能产生不希望出现的负作用。

构造方法摘要
RenderContext(AffineTransform usr2dev)
构造具有给定变换的 RenderContext。
RenderContext(AffineTransform usr2dev, RenderingHints hints)
构造具有给定转换和呈现提示的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi)
构造具有给定变换和感兴趣区域的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
构造具有给定转换的 RenderContext。
方法摘要
Object | clone() 对 RenderContext 进行复制。
void | concatenateTransform(AffineTransform modTransform) 通过追加另一变换修改当前的“用户到设备”变换。
void | concetenateTransform(AffineTransform modTransform) 已过时。 由 concatenateTransform(AffineTransform) 所替代。
Shape | getAreaOfInterest() 获取当前包含在 RenderContext 中的感兴趣区域。
RenderingHints | getRenderingHints() 获取此 RenderContext 的呈现提示。
AffineTransform | getTransform() 获取当前“用户到设备”的 AffineTransform。
void | preConcatenateTransform(AffineTransform modTransform) 通过预先挂起另一变换修改当前的“用户到设备”变换。
void | preConcetenateTransform(AffineTransform modTransform) 已过时。 由 preConcatenateTransform(AffineTransform) 所取代。
void | setAreaOfInterest(Shape newAoi) 设置当前的感兴趣区域。
void | setRenderingHints(RenderingHints hints) 设置此 RenderContext 的呈现提示。
void | setTransform(AffineTransform newTransform) 将 RenderContext 中包含的当前“用户到设备”的 AffineTransform 设置为给定的变换。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RenderContext

public RenderContext(AffineTransform usr2dev,
                     Shape aoi,
                     RenderingHints hints)
构造具有给定转换的 RenderContext。感兴趣的区域作为一个 Shape 提供，呈现提示作为一个 RenderingHints 对象提供。

参数：
usr2dev - 一个 AffineTransform。
aoi - 表示感兴趣区域的 Shape。
hints - 包含呈现提示的 RenderingHints 对象。

RenderContext

public RenderContext(AffineTransform usr2dev)
构造具有给定变换的 RenderContext。感兴趣的区域被用做整个可呈现区域。不使用呈现提示。

参数：
usr2dev - 一个 AffineTransform。

RenderContext

public RenderContext(AffineTransform usr2dev,
                     RenderingHints hints)
构造具有给定转换和呈现提示的 RenderContext。感兴趣的区域被用做整个可呈现区域。

参数：
usr2dev - 一个 AffineTransform。
hints - 包含呈现提示的 RenderingHints 对象。

RenderContext

public RenderContext(AffineTransform usr2dev,
                     Shape aoi)
构造具有给定变换和感兴趣区域的 RenderContext。感兴趣区域作为一个 Shape 提供。不使用呈现提示。

参数：
usr2dev - 一个 AffineTransform。
aoi - 表示感兴趣区域的 Shape。
方法详细信息

getRenderingHints

public RenderingHints getRenderingHints()
获取此 RenderContext 的呈现提示。

返回：
表示此 RenderContext 呈现提示的 RenderingHints 对象。
另请参见：
setRenderingHints(RenderingHints)

setRenderingHints

public void setRenderingHints(RenderingHints hints)
设置此 RenderContext 的呈现提示。

参数：
hints - 表示赋给此 RenderContext 的呈现提示的 RenderingHints 对象。
另请参见：
getRenderingHints()

setTransform

public void setTransform(AffineTransform newTransform)
将 RenderContext 中包含的当前“用户到设备”的 AffineTransform 设置为给定的变换。

参数：
newTransform - 新的 AffineTransform。
另请参见：
getTransform()

preConcatenateTransform

public void preConcatenateTransform(AffineTransform modTransform)
通过预先挂起另一变换修改当前的“用户到设备”变换。用矩阵表示该操作为：
 [this] = [modTransform] x [this]

参数：
modTransform - 预先挂起到当前 usr2dev 变换的 AffineTransform。
从以下版本开始：
1.3

preConcetenateTransform

@Deprecated
public void preConcetenateTransform(AffineTransform modTransform)
已过时。 由 preConcatenateTransform(AffineTransform) 所取代。

通过预先挂起另一变换修改当前的“用户到设备”变换。用矩阵表示该操作为：
 [this] = [modTransform] x [this]
此方法与 preConcatenateTransform 方法的作用相同。保留此方法是为了与以前发布版本的向后兼容，以前版本中该方法的名称拼写错误。

参数：
modTransform - 预先挂起到当前 usr2dev 变换的 AffineTransform。

concatenateTransform

public void concatenateTransform(AffineTransform modTransform)
通过追加另一变换修改当前的“用户到设备”变换。用矩阵表示该操作为：
 [this] = [this] x [modTransform]

参数：
modTransform - 追加到当前 usr2dev 变换的 AffineTransform。
从以下版本开始：
1.3

concetenateTransform

@Deprecated
public void concetenateTransform(AffineTransform modTransform)
已过时。 由 concatenateTransform(AffineTransform) 所替代。

通过追加另一变换修改当前的“用户到设备”转换。用矩阵表示该操作为：
 [this] = [this] x [modTransform]
此方法与 concatenateTransform 方法的作用相同。保留此方法是为了与以前发布版本的向后兼容，以前版本中该方法的名称拼写错误。

参数：
modTransform - 追加到当前 usr2dev 变换的 AffineTransform。

getTransform

public AffineTransform getTransform()
获取当前“用户到设备”的 AffineTransform。

返回：
当前 AffineTransform 的一个引用。
另请参见：
setTransform(AffineTransform)

setAreaOfInterest

public void setAreaOfInterest(Shape newAoi)
设置当前的感兴趣区域。丢弃旧区域。

参数：
newAoi - 新的感兴趣区域。
另请参见：
getAreaOfInterest()

getAreaOfInterest

public Shape getAreaOfInterest()
获取当前包含在 RenderContext 中的感兴趣区域。

返回：
对 RenderContext 的感兴趣区域的引用，如果未指定，则返回 null。
另请参见：
setAreaOfInterest(Shape)

clone

public Object clone()
对 RenderContext 进行复制。感兴趣区域由引用复制。复制 usr2dev AffineTransform 和提示，而感兴趣区域由引用复制。

覆盖：
类 Object 中的 clone
返回：
新复制的 RenderContext。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RenderedImageFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.image.renderable
接口 RenderedImageFactory

所有已知子接口：
ContextualRenderedImageFactory
public interface RenderedImageFactory

RenderedImageFactory 接口（通常简称为 RIF）由希望充当工厂以生成不同呈现的类实现，例如，根据一组特定的参数、属性和呈现提示集，通过对一组源执行一连串的 BufferedImageOp。

方法摘要
 RenderedImage create(ParameterBlock paramBlock, RenderingHints hints)
针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。

方法详细信息

create

RenderedImage create(ParameterBlock paramBlock,
                     RenderingHints hints)
针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。RIF 还可以根据需要查询由 ParameterBlock 引用的任何源图像，以了解其维度、SampleModel 和属性等。

如果 RenderedImageFactory 不能为给定的源图像和参数集生成输出，则 create() 方法返回 null。例如，如果 RenderedImageFactory 在单一 band 的图像数据上只能执行 3x3 卷积，并且源图像有多个 band 或者卷积 Kernel 为 5x5，则应返回 null。

应考虑提示，也可以忽略它。创建的 RenderedImage 可能有由字符串 HINTS_OBSERVED 标识的属性，以指示使用了哪些 RenderingHint 创建该图像。此外，通过创建的 RenderedImage 上的 getSources() 方法获取的任何 RenderedImage 都可能具有该属性。

参数：
paramBlock - 包含要创建的 RenderedImage 的源和参数的 ParameterBlock。
hints - 包含提示的 RenderingHints 对象。
返回：
包含所需输出的 RenderedImage。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.image.renderable (Java 2 Platform SE 6)

 java.awt.image.renderable
接口
ContextualRenderedImageFactory
RenderableImage
RenderedImageFactory
类
ParameterBlock
RenderableImageOp
RenderableImageProducer
RenderContext


java.awt.image.renderable (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.image.renderable

提供用于生成与呈现无关的图像的类和接口。

请参见：
描述

接口摘要
ContextualRenderedImageFactory | ContextualRenderedImageFactory 为在 RenderableImageOp 实例之间可能不同的功能提供接口。
RenderableImage | RenderableImage 是与呈现无关的图像（该概念包含与分辨率无关的意思）的公共接口。
RenderedImageFactory | RenderedImageFactory 接口（通常简称为 RIF）由希望充当工厂以生成不同呈现的类实现，例如，根据一组特定的参数、属性和呈现提示集，通过对一组源执行一连串的 BufferedImageOp。

类摘要
ParameterBlock | ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。
RenderableImageOp | 此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。
RenderableImageProducer | 实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。
RenderContext | RenderContext 封装从 enderableImage 生成特定呈现所需的信息。

软件包 java.awt.image.renderable 的描述

提供用于生成与呈现无关的图像的类和接口。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.image.renderable 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.image.renderable 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.image.renderable.ParameterBlock (implements java.lang.Cloneable, java.io.Serializable)
    • java.awt.image.renderable.RenderableImageOp (implements java.awt.image.renderable.RenderableImage)
    • java.awt.image.renderable.RenderableImageProducer (implements java.awt.image.ImageProducer, java.lang.Runnable)
    • java.awt.image.renderable.RenderContext (implements java.lang.Cloneable)

接口分层结构

  • java.awt.image.renderable.RenderableImage
  • java.awt.image.renderable.RenderedImageFactory
    • java.awt.image.renderable.ContextualRenderedImageFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.image.renderable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.image.renderable
的使用

使用 java.awt.image.renderable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 使用的 java.awt.image.renderable 中的类
RenderableImage
RenderableImage 是与呈现无关的图像（该概念包含与分辨率无关的意思）的公共接口。

java.awt.image.renderable 使用的 java.awt.image.renderable 中的类
ContextualRenderedImageFactory
ContextualRenderedImageFactory 为在 RenderableImageOp 实例之间可能不同的功能提供接口。
ParameterBlock
ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。
RenderableImage
RenderableImage 是与呈现无关的图像（该概念包含与分辨率无关的意思）的公共接口。
RenderContext
RenderContext 封装从 enderableImage 生成特定呈现所需的信息。
RenderedImageFactory
RenderedImageFactory 接口（通常简称为 RIF）由希望充当工厂以生成不同呈现的类实现，例如，根据一组特定的参数、属性和呈现提示集，通过对一组源执行一连串的 BufferedImageOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.renderable.ContextualRenderedImageFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.renderable.ContextualRenderedImageFactory
的使用

使用 ContextualRenderedImageFactory 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 ContextualRenderedImageFactory 的使用

参数类型为 ContextualRenderedImageFactory 的 java.awt.image.renderable 中的构造方法
RenderableImageOp(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.renderable.ParameterBlock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.ParameterBlock
的使用

使用 ParameterBlock 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 ParameterBlock 的使用

返回 ParameterBlock 的 java.awt.image.renderable 中的方法
ParameterBlock | ParameterBlock.add(byte b) 将一个 Byte 添加到此参数列表。
ParameterBlock | ParameterBlock.add(char c) 将一个 Character 添加到此参数列表。
ParameterBlock | ParameterBlock.add(double d) 将一个 Double 添加到此参数列表。
ParameterBlock | ParameterBlock.add(float f) 将一个 Float 添加到此参数列表。
ParameterBlock | ParameterBlock.add(int i) 将一个 Integer 添加到此参数列表。
ParameterBlock | ParameterBlock.add(long l) 将一个 Long 添加到此参数列表。
ParameterBlock | ParameterBlock.add(Object obj) 将一个 Object 添加到此参数列表。
ParameterBlock | ParameterBlock.add(short s) 将一个 Short 添加到此参数列表。
ParameterBlock | ParameterBlock.addSource(Object source) 将一个图像添加到源列表的末尾。
ParameterBlock | RenderableImageOp.getParameterBlock() 返回到对当前参数块的一个引用。
ParameterBlock | ParameterBlock.set(byte b, int index) 使用 Byte 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(char c, int index) 使用 Character 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(double d, int index) 使用 Double 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(float f, int index) 使用 Float 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(int i, int index) 使用 Integer 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(long l, int index) 使用 Long 替换参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(Object obj, int index) 替换此参数列表中的一个 Object。
ParameterBlock | ParameterBlock.set(short s, int index) 使用 Short 替换参数列表中的一个 Object。
ParameterBlock | RenderableImageOp.setParameterBlock(ParameterBlock paramBlock) 更改操作的当前 ParameterBlock，允许编辑图像呈现链。
ParameterBlock | ParameterBlock.setSource(Object source, int index) 将源列表中的某个项替换为一个新源。

参数类型为 ParameterBlock 的 java.awt.image.renderable 中的方法
RenderedImage | RenderedImageFactory.create(ParameterBlock paramBlock, RenderingHints hints) 针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
RenderedImage | ContextualRenderedImageFactory.create(RenderContext renderContext, ParameterBlock paramBlock) 根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
Rectangle2D | ContextualRenderedImageFactory.getBounds2D(ParameterBlock paramBlock) 返回操作的输出的边界框，该操作在与呈现无关的空间中给定的一组源上执行。
Object | ContextualRenderedImageFactory.getProperty(ParameterBlock paramBlock, String name) 获取由 name 参数指定的属性的适当实例。
RenderContext | ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image) 将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。
ParameterBlock | RenderableImageOp.setParameterBlock(ParameterBlock paramBlock) 更改操作的当前 ParameterBlock，允许编辑图像呈现链。

参数类型为 ParameterBlock 的 java.awt.image.renderable 中的构造方法
RenderableImageOp(ContextualRenderedImageFactory CRIF, ParameterBlock paramBlock)
根据给定 ContextualRenderedImageFactory 对象以及一个包含 RenderableImage 源和其他参数的 ParameterBlock 构造 RenderedImageOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.renderable.RenderContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.RenderContext
的使用

使用 RenderContext 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 RenderContext 的使用

返回 RenderContext 的 java.awt.image.renderable 中的方法
 RenderContext ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。

参数类型为 RenderContext 的 java.awt.image.renderable 中的方法
 RenderedImage ContextualRenderedImageFactory.create(RenderContext renderContext, ParameterBlock paramBlock)
根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
 RenderedImage RenderableImage.createRendering(RenderContext renderContext)
使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。
 RenderedImage RenderableImageOp.createRendering(RenderContext renderContext)
创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。
 RenderContext ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。
 void RenderableImageProducer.setRenderContext(RenderContext rc)
设置下一次调用 startProduction() 要使用的新 RenderContext。

参数类型为 RenderContext 的 java.awt.image.renderable 中的构造方法
RenderableImageProducer(RenderableImage rdblImage, RenderContext rc)
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.renderable.RenderableImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.renderable.RenderableImage
的使用

使用 RenderableImage 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 RenderableImage 的使用

参数类型为 RenderableImage 的 java.awt 中的方法
abstract  void Graphics2D.drawRenderableImage(RenderableImage img, AffineTransform xform)
呈现 RenderableImage，在绘制前进行从图像空间到用户空间的转换。

java.awt.image.renderable 中 RenderableImage 的使用

实现 RenderableImage 的 java.awt.image.renderable 中的类
 class RenderableImageOp
此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。

返回 RenderableImage 的 java.awt.image.renderable 中的方法
 RenderableImage ParameterBlock.getRenderableSource(int index)
返回作为 RenderableImage 的源。

返回变量类型为 RenderableImage 的类型的 java.awt.image.renderable 中的方法
Vector<RenderableImage> | RenderableImage.getSources() 返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。
Vector<RenderableImage> | RenderableImageOp.getSources() 返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。

参数类型为 RenderableImage 的 java.awt.image.renderable 中的方法
 RenderContext ContextualRenderedImageFactory.mapRenderContext(int i, RenderContext renderContext, ParameterBlock paramBlock, RenderableImage image)
将该操作的输出 RenderContext 映射到每个操作源的 RenderContext。

参数类型为 RenderableImage 的 java.awt.image.renderable 中的构造方法
RenderableImageProducer(RenderableImage rdblImage, RenderContext rc)
根据 RenderableImage 和 RenderContext 构造新的 RenderableImageProducer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.renderable.RenderableImageOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.RenderableImageOp
的使用

没有 java.awt.image.renderable.RenderableImageOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.renderable.RenderableImageProducer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.renderable.RenderableImageProducer
的使用

没有 java.awt.image.renderable.RenderableImageProducer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.renderable.RenderedImageFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.renderable.RenderedImageFactory
的使用

使用 RenderedImageFactory 的软件包
java.awt.image.renderable 提供用于生成与呈现无关的图像的类和接口。

java.awt.image.renderable 中 RenderedImageFactory 的使用

java.awt.image.renderable 中 RenderedImageFactory 的子接口
 interface ContextualRenderedImageFactory
ContextualRenderedImageFactory 为在 RenderableImageOp 实例之间可能不同的功能提供接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.AffineTransformOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.AffineTransformOp
的使用

没有 java.awt.image.AffineTransformOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.AreaAveragingScaleFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.AreaAveragingScaleFilter
的使用

没有 java.awt.image.AreaAveragingScaleFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.BandCombineOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BandCombineOp
的使用

没有 java.awt.image.BandCombineOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.BandedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BandedSampleModel
的使用

没有 java.awt.image.BandedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.BufferedImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BufferedImageFilter
的使用

没有 java.awt.image.BufferedImageFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.BufferedImageOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.BufferedImageOp
的使用

使用 BufferedImageOp 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 BufferedImageOp 的使用

参数类型为 BufferedImageOp 的 java.awt 中的方法
abstract  void Graphics2D.drawImage(BufferedImage img, BufferedImageOp op, int x, int y)
呈现使用 BufferedImageOp 过滤的 BufferedImage。

java.awt.image 中 BufferedImageOp 的使用

实现 BufferedImageOp 的 java.awt.image 中的类
class | AffineTransformOp 此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。
class | ColorConvertOp 此类对源图像中的数据执行逐像素的颜色转换。
class | ConvolveOp 此类实现从源到目标的卷积。
class | LookupOp 此类实现从源到目标的查找操作。
class | RescaleOp 通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。

返回 BufferedImageOp 的 java.awt.image 中的方法
 BufferedImageOp BufferedImageFilter.getBufferedImageOp()
返回 BufferedImageOp。

参数类型为 BufferedImageOp 的 java.awt.image 中的构造方法
BufferedImageFilter(BufferedImageOp op)
构造具有指定单一源图像/单一目标图像操作符的 BufferedImageFilter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ByteLookupTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ByteLookupTable
的使用

没有 java.awt.image.ByteLookupTable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ColorConvertOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ColorConvertOp
的使用

没有 java.awt.image.ColorConvertOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ComponentColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ComponentColorModel
的使用

没有 java.awt.image.ComponentColorModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ConvolveOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ConvolveOp
的使用

没有 java.awt.image.ConvolveOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.CropImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.CropImageFilter
的使用

没有 java.awt.image.CropImageFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DataBufferDouble 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferDouble
的使用

没有 java.awt.image.DataBufferDouble 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DataBufferFloat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferFloat
的使用

没有 java.awt.image.DataBufferFloat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DataBufferShort 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferShort
的使用

没有 java.awt.image.DataBufferShort 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DataBufferUShort 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferUShort
的使用

没有 java.awt.image.DataBufferUShort 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ImagingOpException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ImagingOpException
的使用

没有 java.awt.image.ImagingOpException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.Kernel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.Kernel
的使用

使用 Kernel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 Kernel 的使用

返回 Kernel 的 java.awt.image 中的方法
 Kernel ConvolveOp.getKernel()
返回 Kernel。

参数类型为 Kernel 的 java.awt.image 中的构造方法
ConvolveOp(Kernel kernel)
构造给定了 Kernel 的 ConvolveOp。
ConvolveOp(Kernel kernel, int edgeCondition, RenderingHints hints)
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.LookupOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.LookupOp
的使用

没有 java.awt.image.LookupOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.LookupTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.LookupTable
的使用

使用 LookupTable 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 LookupTable 的使用

java.awt.image 中 LookupTable 的子类
class | ByteLookupTable 此类定义一个 lookup table 对象。
class | ShortLookupTable 此类定义了一个查找表对象。

返回 LookupTable 的 java.awt.image 中的方法
 LookupTable LookupOp.getTable()
返回 LookupTable。

参数类型为 LookupTable 的 java.awt.image 中的构造方法
LookupOp(LookupTable lookup, RenderingHints hints)
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.MemoryImageSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.MemoryImageSource
的使用

没有 java.awt.image.MemoryImageSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.MultiPixelPackedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.MultiPixelPackedSampleModel
的使用

没有 java.awt.image.MultiPixelPackedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.PixelGrabber 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.PixelGrabber
的使用

没有 java.awt.image.PixelGrabber 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.RasterFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.RasterFormatException
的使用

没有 java.awt.image.RasterFormatException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.RasterOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.RasterOp
的使用

使用 RasterOp 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 RasterOp 的使用

实现 RasterOp 的 java.awt.image 中的类
class | AffineTransformOp 此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。
class | BandCombineOp 此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。
class | ColorConvertOp 此类对源图像中的数据执行逐像素的颜色转换。
class | ConvolveOp 此类实现从源到目标的卷积。
class | LookupOp 此类实现从源到目标的查找操作。
class | RescaleOp 通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ReplicateScaleFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ReplicateScaleFilter
的使用

使用 ReplicateScaleFilter 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 ReplicateScaleFilter 的使用

java.awt.image 中 ReplicateScaleFilter 的子类
 class AreaAveragingScaleFilter
这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.RescaleOp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.RescaleOp
的使用

没有 java.awt.image.RescaleOp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ShortLookupTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ShortLookupTable
的使用

没有 java.awt.image.ShortLookupTable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.TileObserver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.TileObserver
的使用

使用 TileObserver 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 TileObserver 的使用

参数类型为 TileObserver 的 java.awt.image 中的方法
void | BufferedImage.addTileObserver(TileObserver to) 添加一个 tile observer。
void | WritableRenderedImage.addTileObserver(TileObserver to) 添加一个观察器。
void | BufferedImage.removeTileObserver(TileObserver to) 移除一个 tile observer。
void | WritableRenderedImage.removeTileObserver(TileObserver to) 移除一个观察器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.FilteredImageSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.FilteredImageSource
的使用

没有 java.awt.image.FilteredImageSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.RGBImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.RGBImageFilter
的使用

使用 RGBImageFilter 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 RGBImageFilter 的使用

javax.swing 中 RGBImageFilter 的子类
 class GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ImageFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ImageFilter
的使用

使用 ImageFilter 的软件包
java.awt.image | 提供创建和修改图像的各种类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.image 中 ImageFilter 的使用

java.awt.image 中 ImageFilter 的子类
class | AreaAveragingScaleFilter 这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
class | BufferedImageFilter BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
class | CropImageFilter 用于裁剪图像的 ImageFilter 类。
class | ReplicateScaleFilter 使用最简单的算法缩放图像的 ImageFilter 类。
class | RGBImageFilter 此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

返回 ImageFilter 的 java.awt.image 中的方法
 ImageFilter ImageFilter.getFilterInstance(ImageConsumer ic)
返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。

参数类型为 ImageFilter 的 java.awt.image 中的构造方法
FilteredImageSource(ImageProducer orig, ImageFilter imgf)
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。

javax.swing 中 ImageFilter 的使用

javax.swing 中 ImageFilter 的子类
 class GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DataBufferInt 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferInt
的使用

没有 java.awt.image.DataBufferInt 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.SinglePixelPackedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.SinglePixelPackedSampleModel
的使用

没有 java.awt.image.SinglePixelPackedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.BufferedImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BufferedImage
的使用

使用 BufferedImage 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。

java.awt 中 BufferedImage 的使用

返回 BufferedImage 的 java.awt 中的方法
abstract BufferedImage | GraphicsConfiguration.createCompatibleImage(int width, int height) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
BufferedImage | GraphicsConfiguration.createCompatibleImage(int width, int height, int transparency) 返回一个支持指定透明度，并且数据布局和颜色模型与此 GraphicsConfiguration 兼容的 BufferedImage。
BufferedImage | Robot.createScreenCapture(Rectangle screenRect) 创建包含从屏幕中读取的像素的图像。
BufferedImage | TexturePaint.getImage() 返回用于填充形状的 BufferedImage 纹理。

参数类型为 BufferedImage 的 java.awt 中的方法
abstract Graphics2D | GraphicsEnvironment.createGraphics(BufferedImage img) 返回一个呈现指定 BufferedImage 的 Graphics2D 对象。
abstract void | Graphics2D.drawImage(BufferedImage img, BufferedImageOp op, int x, int y) 呈现使用 BufferedImageOp 过滤的 BufferedImage。

参数类型为 BufferedImage 的 java.awt 中的构造方法
TexturePaint(BufferedImage txtr, Rectangle2D anchor)
构造 TexturePaint 对象。

java.awt.image 中 BufferedImage 的使用

返回 BufferedImage 的 java.awt.image 中的方法
BufferedImage | IndexColorModel.convertToIntDiscrete(Raster raster, boolean forceARGB) 返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。
BufferedImage | AffineTransformOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | BufferedImageOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | ColorConvertOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建给定源的具有正确大小和 band 数量的归零目标图像。
BufferedImage | ConvolveOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建具有正确 band 大小和数量的归零目标图像。
BufferedImage | LookupOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一幅具有正确大小和 band 数的、经过检查的目标图像。
BufferedImage | RescaleOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经检查的目标图像。
BufferedImage | AffineTransformOp.filter(BufferedImage src, BufferedImage dst) 转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。
BufferedImage | BufferedImageOp.filter(BufferedImage src, BufferedImage dest) 对 BufferedImage 执行单输入/单输出操作。
BufferedImage | ColorConvertOp.filter(BufferedImage src, BufferedImage dest) 对源 BufferedImage 进行颜色转换。
BufferedImage | ConvolveOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行卷积运算。
BufferedImage | LookupOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行查找操作。
BufferedImage | RescaleOp.filter(BufferedImage src, BufferedImage dst) 对源 BufferedImage 进行重缩放。
abstract BufferedImage | VolatileImage.getSnapshot() 返回此对象的静态快照图像。
BufferedImage | BufferedImage.getSubimage(int x, int y, int w, int h) 返回由指定矩形区域定义的子图像。

参数类型为 BufferedImage 的 java.awt.image 中的方法
BufferedImage | AffineTransformOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | BufferedImageOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | ColorConvertOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建给定源的具有正确大小和 band 数量的归零目标图像。
BufferedImage | ConvolveOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建具有正确 band 大小和数量的归零目标图像。
BufferedImage | LookupOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一幅具有正确大小和 band 数的、经过检查的目标图像。
BufferedImage | RescaleOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经检查的目标图像。
BufferedImage | AffineTransformOp.filter(BufferedImage src, BufferedImage dst) 转换源 BufferedImage 并将结果存储在目标 BufferedImage 中。
BufferedImage | BufferedImageOp.filter(BufferedImage src, BufferedImage dest) 对 BufferedImage 执行单输入/单输出操作。
BufferedImage | ColorConvertOp.filter(BufferedImage src, BufferedImage dest) 对源 BufferedImage 进行颜色转换。
BufferedImage | ConvolveOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行卷积运算。
BufferedImage | LookupOp.filter(BufferedImage src, BufferedImage dst) 对 BufferedImage 执行查找操作。
BufferedImage | RescaleOp.filter(BufferedImage src, BufferedImage dst) 对源 BufferedImage 进行重缩放。
Rectangle2D | AffineTransformOp.getBounds2D(BufferedImage src) 返回转换后的目标图像的边界框。
Rectangle2D | BufferedImageOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(BufferedImage src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(BufferedImage src) 返回已过滤目标图像的边界框。
Rectangle2D | LookupOp.getBounds2D(BufferedImage src) 返回过滤后的目标图像的边界框。
Rectangle2D | RescaleOp.getBounds2D(BufferedImage src) 返回重缩放后的目标图像的边界框。

javax.imageio 中 BufferedImage 的使用

声明为 BufferedImage 的 javax.imageio 中的字段
protected  BufferedImage ImageReadParam.destination
当前目标 BufferedImage；如果没有设置目标图像，则为 null。

类型参数类型为 BufferedImage 的 javax.imageio 中的字段
protected  List<? extends BufferedImage> IIOImage.thumbnails
BufferedImage 缩略图的 List，或为 null。

返回 BufferedImage 的 javax.imageio 中的方法
BufferedImage | ImageTypeSpecifier.createBufferedImage(int width, int height) 根据此对象中包含的规范创建一个具有给定宽度和高度的 BufferedImage。
BufferedImage | ImageReadParam.getDestination() 返回当前由 setDestination 方法设置的 BufferedImage，如果没有设置，则返回 null。
protected static BufferedImage | ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height) 返回应该在其中写入解码的像素数据的 BufferedImage。
BufferedImage | IIOImage.getThumbnail(int index) 返回与主图像关联的缩略图。
static BufferedImage | ImageIO.read(File input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
static BufferedImage | ImageIO.read(ImageInputStream stream) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。
static BufferedImage | ImageIO.read(InputStream input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。
BufferedImage | ImageReader.read(int imageIndex) 使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。
abstract BufferedImage | ImageReader.read(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
static BufferedImage | ImageIO.read(URL input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。
BufferedImage | ImageReader.readThumbnail(int imageIndex, int thumbnailIndex) 以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。
BufferedImage | ImageReader.readTile(int imageIndex, int tileX, int tileY) 读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。

返回变量类型为 BufferedImage 的类型的 javax.imageio 中的方法
 List<? extends BufferedImage> IIOImage.getThumbnails()
返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。

参数类型为 BufferedImage 的 javax.imageio 中的方法
protected static void | ImageReader.computeRegions(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion) 计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
protected void | ImageReader.processImageUpdate(BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 imageUpdate 方法向其广播样本集合的更新。
protected void | ImageReader.processPassComplete(BufferedImage theImage) 通过调用所有已注册 IIOReadUpdateListener 的 passComplete 方法向其广播逐步传递的结束。
protected void | ImageReader.processPassStarted(BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 passStarted 方法向其广播逐步传递的开始。
protected void | ImageReader.processThumbnailPassComplete(BufferedImage theThumbnail) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassComplete 方法向其广播缩略图逐步传递的结束。
protected void | ImageReader.processThumbnailPassStarted(BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassStarted 方法向其广播缩略图逐步传递的开始。
protected void | ImageReader.processThumbnailUpdate(BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailUpdate 方法向其广播缩略图图像中样本集合的更新。
void | ImageReadParam.setDestination(BufferedImage destination) 提供一个 BufferedImage，将其用作解码像素数据的目标。

类型变量类型为 BufferedImage 的 javax.imageio 中的方法参数
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | IIOImage.setThumbnails(List<? extends BufferedImage> thumbnails) 将缩略图列表设置为 BufferedImage 的一个新 List 或 null。

类型变量类型为 BufferedImage 的 javax.imageio 中的构造方法参数
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。

javax.imageio.event 中 BufferedImage 的使用

参数类型为 BufferedImage 的 javax.imageio.event 中的方法
void | IIOReadUpdateListener.imageUpdate(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新图像的给定区域。
void | IIOReadUpdateListener.passComplete(ImageReader source, BufferedImage theImage) 报告当前读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.passStarted(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的读操作将开始逐步传递 (progressive pass)。
void | IIOReadUpdateListener.thumbnailPassComplete(ImageReader source, BufferedImage theThumbnail) 报告当前缩略图读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.thumbnailPassStarted(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的缩略图读操作将开始逐步传递。
void | IIOReadUpdateListener.thumbnailUpdate(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新缩略图图像的给定区域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.WritableRenderedImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.WritableRenderedImage
的使用

使用 WritableRenderedImage 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 WritableRenderedImage 的使用

实现 WritableRenderedImage 的 java.awt.image 中的类
 class BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。

参数类型为 WritableRenderedImage 的 java.awt.image 中的方法
 void TileObserver.tileUpdate(WritableRenderedImage source, int tileX, int tileY, boolean willBeWritable)
即将被更新的 tile（此 tile 或者即将被获取以写入，或者正在从写入释放）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.RenderedImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.RenderedImage
的使用

使用 RenderedImage 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

java.awt 中 RenderedImage 的使用

参数类型为 RenderedImage 的 java.awt 中的方法
abstract  void Graphics2D.drawRenderedImage(RenderedImage img, AffineTransform xform)
呈现 RenderedImage，在绘制前进行从图像空间到用户空间的转换。

java.awt.image 中 RenderedImage 的使用

java.awt.image 中 RenderedImage 的子接口
 interface WritableRenderedImage
WriteableRenderedImage 公共接口用于那些包含或者能够生成 Rasters 形式图像数据的对象，以及能够被修改和/或写入的对象。

实现 RenderedImage 的 java.awt.image 中的类
 class BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。

返回变量类型为 RenderedImage 的类型的 java.awt.image 中的方法
Vector<RenderedImage> | BufferedImage.getSources() 返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。
Vector<RenderedImage> | RenderedImage.getSources() 返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。

java.awt.image.renderable 中 RenderedImage 的使用

返回 RenderedImage 的 java.awt.image.renderable 中的方法
RenderedImage | RenderedImageFactory.create(ParameterBlock paramBlock, RenderingHints hints) 针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
RenderedImage | ContextualRenderedImageFactory.create(RenderContext renderContext, ParameterBlock paramBlock) 根据给定包含操作的源和参数的 RenderContext 和 ParameterBlock 创建一个呈现。
RenderedImage | RenderableImage.createDefaultRendering() 返回此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImageOp.createDefaultRendering() 获取此图像具有默认宽度和高度（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImage.createRendering(RenderContext renderContext) 使用给定的 RenderContext 创建表示此图像一个呈现的 RenderedImage。
RenderedImage | RenderableImageOp.createRendering(RenderContext renderContext) 创建一个表示根据给定 RenderContext 呈现的 RenderableImageOp（包括其 Renderable 源）的 RenderedImage。
RenderedImage | RenderableImage.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImageOp.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | ParameterBlock.getRenderedSource(int index) 返回作为 RenderedImage 的源。

javax.imageio 中 RenderedImage 的使用

声明为 RenderedImage 的 javax.imageio 中的字段
protected  RenderedImage IIOImage.image
正被引用的 RenderedImage。

返回 RenderedImage 的 javax.imageio 中的方法
RenderedImage | IIOImage.getRenderedImage() 返回当前设置好的 RenderedImage，如果只有一个 Raster 可用，则返回 null。
RenderedImage | ImageReader.readAsRenderedImage(int imageIndex, ImageReadParam param) 返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。

参数类型为 RenderedImage 的 javax.imageio 中的方法
static ImageTypeSpecifier | ImageTypeSpecifier.createFromRenderedImage(RenderedImage image) 返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。
void | ImageWriter.replacePixels(RenderedImage image, ImageWriteParam param) 用给定图像部分替换已出现在输出中的图像部分。
void | IIOImage.setRenderedImage(RenderedImage image) 设置当前 RenderedImage。
void | ImageWriter.write(RenderedImage image) 将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。
static boolean | ImageIO.write(RenderedImage im, String formatName, File output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 File。
static boolean | ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。
static boolean | ImageIO.write(RenderedImage im, String formatName, OutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。

参数类型为 RenderedImage 的 javax.imageio 中的构造方法
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。
ImageTypeSpecifier(RenderedImage image)
根据 RenderedImage 构造一个 ImageTypeSpecifier。

javax.imageio.spi 中 RenderedImage 的使用

参数类型为 RenderedImage 的 javax.imageio.spi 中的方法
 boolean ImageWriterSpi.canEncodeImage(RenderedImage im)
如果与此服务提供者关联的 ImageWriter 实现能够编码给定的 RenderedImage 实例，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.WritableRaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.WritableRaster
的使用

使用 WritableRaster 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 WritableRaster 的使用

参数类型为 WritableRaster 的 java.awt 中的方法
 void CompositeContext.compose(Raster src, Raster dstIn, WritableRaster dstOut)
组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。

java.awt.image 中 WritableRaster 的使用

返回 WritableRaster 的 java.awt.image 中的方法
WritableRaster | BufferedImage.copyData(WritableRaster outRaster) 计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。
WritableRaster | RenderedImage.copyData(WritableRaster raster) 计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。
static WritableRaster | Raster.createBandedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int bands, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
WritableRaster | AffineTransformOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的经过检查的目标 Raster。
WritableRaster | BandCombineOp.createCompatibleDestRaster(Raster src) 创建一个经过检查的目标 Raster，它具有正确大小和 band 数。
WritableRaster | ColorConvertOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | ConvolveOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | LookupOp.createCompatibleDestRaster(Raster src) 在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。
WritableRaster | RasterOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的归零目标 Raster。
WritableRaster | RescaleOp.createCompatibleDestRaster(Raster src) 在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。
WritableRaster | Raster.createCompatibleWritableRaster() 创建一个兼容的 WritableRaster，使其具有与此 Raster 相同的大小、SampleModel，以及一个新初始化的 DataBuffer。
WritableRaster | ComponentColorModel.createCompatibleWritableRaster(int w, int h) 用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
WritableRaster | Raster.createCompatibleWritableRaster(int w, int h) 创建一个兼容的 WritableRaster，使其具有指定大小、新 SampleModel 和新初始化的 DataBuffer。
WritableRaster | IndexColorModel.createCompatibleWritableRaster(int w, int h) 创建一个具有指定宽度和高度、数据布局 (SampleModel) 与此 ColorModel 兼容的 WritableRaster。
WritableRaster | DirectColorModel.createCompatibleWritableRaster(int w, int h) 创建具有指定宽度和高度、拥有与此 ColorModel 兼容的数据布局 (SampleModel) 的 WritableRaster。
WritableRaster | ColorModel.createCompatibleWritableRaster(int w, int h) 用指定宽度和高度创建的 WritableRaster，具有与此 ColorModel 兼容的数据布局 (SampleModel)。
WritableRaster | Raster.createCompatibleWritableRaster(int x, int y, int w, int h) 创建一个兼容的 WritableRaster，使其具有指定位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
WritableRaster | Raster.createCompatibleWritableRaster(Rectangle rect) 创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
static WritableRaster | Raster.createInterleavedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int bands, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location) 根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int bands, int bitsPerBand, Point location) 根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。
WritableRaster | WritableRaster.createWritableChild(int parentX, int parentY, int w, int h, int childMinX, int childMinY, int[] bandList) 返回新的 WritableRaster，它共享此 WritableRaster 的全部或部分 DataBuffer。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, Point location) 创建一个具有指定 SampleModel 的 WritableRaster。
WritableRaster | WritableRaster.createWritableTranslatedChild(int childMinX, int childMinY) 在不同的位置上创建一个与此 WritableRaster 具有相同大小、SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster | AffineTransformOp.filter(Raster src, WritableRaster dst) 转换源 Raster 并将结果存储在目标 Raster 中。
WritableRaster | BandCombineOp.filter(Raster src, WritableRaster dst) 使用构造方法中指定的矩阵变换该 Raster。
WritableRaster | ColorConvertOp.filter(Raster src, WritableRaster dest) 对源 Raster 中的图像数据进行颜色转换。
WritableRaster | ConvolveOp.filter(Raster src, WritableRaster dst) 对 Raster 执行卷积运算。
WritableRaster | LookupOp.filter(Raster src, WritableRaster dst) 在 Raster 上执行查找操作。
WritableRaster | RasterOp.filter(Raster src, WritableRaster dest) 执行从源 Raster 到目标 Raster 的单输入/单输出操作。
WritableRaster | RescaleOp.filter(Raster src, WritableRaster dst) 对源 Raster 中的像素数据进行重缩放。
WritableRaster | BufferedImage.getAlphaRaster() 返回一个 WritableRaster，它使用支持单独空间 alpha 通道的 ColorModel 对象（比如 ComponentColorModel 和 DirectColorModel）表示 BufferedImage 对象的 alpha 通道。
WritableRaster | ComponentColorModel.getAlphaRaster(WritableRaster raster) 返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。
WritableRaster | PackedColorModel.getAlphaRaster(WritableRaster raster) 返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。
WritableRaster | ColorModel.getAlphaRaster(WritableRaster raster) 返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。
WritableRaster | BufferedImage.getRaster() 返回 WritableRaster。
WritableRaster | WritableRaster.getWritableParent() 返回此 WritableRaster 的父 WritableRaster（如果有），否则返回 null。
WritableRaster | BufferedImage.getWritableTile(int tileX, int tileY) 为写入签出一个 tile。
WritableRaster | WritableRenderedImage.getWritableTile(int tileX, int tileY) 为写入签出一个 tile。

参数类型为 WritableRaster 的 java.awt.image 中的方法
ColorModel | ComponentColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
ColorModel | DirectColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。
ColorModel | ColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
WritableRaster | BufferedImage.copyData(WritableRaster outRaster) 计算 BufferedImage 的一个任意矩形区域，并将其复制到指定的 WritableRaster。
WritableRaster | RenderedImage.copyData(WritableRaster raster) 计算 RenderedImage 的任意矩形区域，并将其复制到调用者提供的 WritableRaster 中。
WritableRaster | AffineTransformOp.filter(Raster src, WritableRaster dst) 转换源 Raster 并将结果存储在目标 Raster 中。
WritableRaster | BandCombineOp.filter(Raster src, WritableRaster dst) 使用构造方法中指定的矩阵变换该 Raster。
WritableRaster | ColorConvertOp.filter(Raster src, WritableRaster dest) 对源 Raster 中的图像数据进行颜色转换。
WritableRaster | ConvolveOp.filter(Raster src, WritableRaster dst) 对 Raster 执行卷积运算。
WritableRaster | LookupOp.filter(Raster src, WritableRaster dst) 在 Raster 上执行查找操作。
WritableRaster | RasterOp.filter(Raster src, WritableRaster dest) 执行从源 Raster 到目标 Raster 的单输入/单输出操作。
WritableRaster | RescaleOp.filter(Raster src, WritableRaster dst) 对源 Raster 中的像素数据进行重缩放。
WritableRaster | ComponentColorModel.getAlphaRaster(WritableRaster raster) 返回表示某图像（从输入 Raster 提取）的 alpha 通道的 Raster。
WritableRaster | PackedColorModel.getAlphaRaster(WritableRaster raster) 返回从输入 WritableRaster 提取，并且表示图像 alpha 通道的 WritableRaster。
WritableRaster | ColorModel.getAlphaRaster(WritableRaster raster) 返回表示图像（从输入 Raster 中提取）的 alpha 通道的 Raster，除非此 ColorModel 的像素值将颜色和 alpha 信息表示为独立的空间 band（如 ComponentColorModel 和 DirectColorModel）。

参数类型为 WritableRaster 的 java.awt.image 中的构造方法
BufferedImage(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.PixelInterleavedSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.PixelInterleavedSampleModel
的使用

没有 java.awt.image.PixelInterleavedSampleModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ComponentSampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ComponentSampleModel
的使用

使用 ComponentSampleModel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 ComponentSampleModel 的使用

java.awt.image 中 ComponentSampleModel 的子类
class | BandedSampleModel 此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。
class | PixelInterleavedSampleModel 此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.SampleModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.SampleModel
的使用

使用 SampleModel 的软件包
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt.image 中 SampleModel 的使用

java.awt.image 中 SampleModel 的子类
class | BandedSampleModel 此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。
class | ComponentSampleModel 此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。
class | MultiPixelPackedSampleModel MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。
class | PixelInterleavedSampleModel 此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。
class | SinglePixelPackedSampleModel 此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。

声明为 SampleModel 的 java.awt.image 中的字段
protected  SampleModel Raster.sampleModel
描述此 Raster 的像素在 DataBuffer 中存储方式的 SampleModel。

返回 SampleModel 的 java.awt.image 中的方法
SampleModel | BandedSampleModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的新的 BandedSampleModel。
SampleModel | ComponentColorModel.createCompatibleSampleModel(int w, int h) 用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
SampleModel | MultiPixelPackedSampleModel.createCompatibleSampleModel(int w, int h) 构造一个具有指定宽度和高度的新 MultiPixelPackedSampleModel。
SampleModel | SinglePixelPackedSampleModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的新 SinglePixelPackedSampleModel。
SampleModel | PixelInterleavedSampleModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度的 PixelInterleavedSampleModel。
SampleModel | ComponentSampleModel.createCompatibleSampleModel(int w, int h) 创建具有指定宽度和高度的 ComponentSampleModel。
abstract SampleModel | SampleModel.createCompatibleSampleModel(int w, int h) 创建一个用此 SampleModel 的格式描述数据，但宽度和高度不同的 SampleModel。
SampleModel | IndexColorModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
SampleModel | PackedColorModel.createCompatibleSampleModel(int w, int h) 创建一个具有指定宽度和高度、数据布局与此 ColorModel 兼容的 SampleModel。
SampleModel | ColorModel.createCompatibleSampleModel(int w, int h) 用指定宽度和高度创建的 SampleModel，具有与此 ColorModel 兼容的数据布局。
SampleModel | BandedSampleModel.createSubsetSampleModel(int[] bands) 创建一个具有此 BandedSampleModel 的 band 子集的新 BandedSampleModel。
SampleModel | MultiPixelPackedSampleModel.createSubsetSampleModel(int[] bands) 创建一个具有此 MultiPixelPackedSampleModel band 子集的新 MultiPixelPackedSampleModel。
SampleModel | SinglePixelPackedSampleModel.createSubsetSampleModel(int[] bands) 创建一个新 SinglePixelPackedSampleModel，使其具有此 SinglePixelPackedSampleModel 的 band 子集。
SampleModel | PixelInterleavedSampleModel.createSubsetSampleModel(int[] bands) 创建一个具有此 PixelInterleavedSampleModel 的 band 子集的 PixelInterleavedSampleModel。
SampleModel | ComponentSampleModel.createSubsetSampleModel(int[] bands) 创建具有此 ComponentSampleModel 的 band 子集的新 ComponentSampleModel。
abstract SampleModel | SampleModel.createSubsetSampleModel(int[] bands) 创建一个新 SampleModel，它具有此 SampleModel 的 band 子集。
SampleModel | BufferedImage.getSampleModel() 返回与此 BufferedImage 关联的 SampleModel。
SampleModel | RenderedImage.getSampleModel() 返回与此图像相关的 SampleModel。
SampleModel | Raster.getSampleModel() 返回描述图像数据布局的 SampleModel。

参数类型为 SampleModel 的 java.awt.image 中的方法
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, Point location) 创建一个具有指定 SampleModel 的 WritableRaster。
boolean | ComponentColorModel.isCompatibleSampleModel(SampleModel sm) 检查指定 SampleModel 是否与此 ColorModel 兼容。
boolean | IndexColorModel.isCompatibleSampleModel(SampleModel sm) 检查指定的 SampleModel 是否与此 ColorModel 兼容。
boolean | PackedColorModel.isCompatibleSampleModel(SampleModel sm) 检查指定的 SampleModel 是否与此 ColorModel 兼容。
boolean | ColorModel.isCompatibleSampleModel(SampleModel sm) 检查 SampleModel 是否与此 ColorModel 兼容。

参数类型为 SampleModel 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
Raster(SampleModel sampleModel, Point origin)
构建具有给定 SampleModel 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。
WritableRaster(SampleModel sampleModel, Point origin)
构造具有给定 SampleModel 的 WritableRaster。

javax.imageio 中 SampleModel 的使用

声明为 SampleModel 的 javax.imageio 中的字段
protected  SampleModel ImageTypeSpecifier.sampleModel
将用作原型的 SampleModel。

返回 SampleModel 的 javax.imageio 中的方法
SampleModel | ImageTypeSpecifier.getSampleModel() 根据此对象中封装的设置返回一个 SampleModel。
SampleModel | ImageTypeSpecifier.getSampleModel(int width, int height) 根据此对象中封装的设置值返回一个 SampleModel。

参数类型为 SampleModel 的 javax.imageio 中的构造方法
ImageTypeSpecifier(ColorModel colorModel, SampleModel sampleModel)
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DataBufferByte 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBufferByte
的使用

没有 java.awt.image.DataBufferByte 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DataBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DataBuffer
的使用

使用 DataBuffer 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 DataBuffer 的使用

java.awt.image 中 DataBuffer 的子类
class | DataBufferByte 此类扩展了 DataBuffer，并在内部按字节存储数据。
class | DataBufferDouble 此类扩展了 DataBuffer，并在内部以 double 形式存储数据。
class | DataBufferFloat 此类扩展了 DataBuffer，并在内部以 float 形式存储数据。
class | DataBufferInt 此类扩展了 DataBuffer，并在内部以整数形式存储数据。
class | DataBufferShort 此类扩展了 DataBuffer，并在内部以 short 类型存储数据。
class | DataBufferUShort 此类扩展了 DataBuffer，并在内部以 short 类型存储数据。

声明为 DataBuffer 的 java.awt.image 中的字段
protected  DataBuffer Raster.dataBuffer
存储图像数据的 DataBuffer。

返回 DataBuffer 的 java.awt.image 中的方法
DataBuffer | BandedSampleModel.createDataBuffer() 创建一个与此 BandedSampleModel 对应的 DataBuffer，该 DataBuffer 的数据类型、存储单元数和大小都将与此 BandedSampleModel 一致。
DataBuffer | MultiPixelPackedSampleModel.createDataBuffer() 创建一个与此 MultiPixelPackedSampleModel 对应的 DataBuffer。
DataBuffer | SinglePixelPackedSampleModel.createDataBuffer() 创建一个对应于此 SinglePixelPackedSampleModel 的 DataBuffer。
DataBuffer | ComponentSampleModel.createDataBuffer() 创建对应于此 ComponentSampleModel 的 DataBuffer。
abstract DataBuffer | SampleModel.createDataBuffer() 创建一个对应于此 SampleModel 的 DataBuffer。
DataBuffer | Raster.getDataBuffer() 返回与此 Raster 关联的 DataBuffer。

参数类型为 DataBuffer 的 java.awt.image 中的方法
static WritableRaster | Raster.createBandedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location) 根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
Object | SampleModel.getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data) 在 TransferType 类型基本数组中返回指定像素矩形的像素数据。
Object | BandedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 在 TransferType 类型基本数组中返回单个像素的数据。
Object | MultiPixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 返回 TransferType 类型基本数组中单个像素的数据。
Object | SinglePixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 返回 TransferType 类型基本数组中单个像素的数据。
Object | ComponentSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 以 TransferType 类型基本数组形式返回单个像素的数据。
abstract Object | SampleModel.getDataElements(int x, int y, Object obj, DataBuffer data) 在 TransferType 类型的基本数组中返回单个像素的数据。
double[] | SampleModel.getPixel(int x, int y, double[] dArray, DataBuffer data) 在一个 double 数组中返回指定像素的样本。
float[] | SampleModel.getPixel(int x, int y, float[] fArray, DataBuffer data) 在一个 float 数组中返回指定像素的样本。
int[] | BandedSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 在 int 数组中返回指定像素的所有样本。
int[] | MultiPixelPackedSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 返回 int 数组第一个元素中的指定单个 band 像素。
int[] | SinglePixelPackedSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 在一个 int 数组中返回对应于指定像素的所有样本。
int[] | ComponentSampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 返回对应 int 数组中指定像素的所有样本，每个数组元素对应一个样本。
int[] | SampleModel.getPixel(int x, int y, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定像素的样本，每个数组元素对应一个样本。
double[] | SampleModel.getPixels(int x, int y, int w, int h, double[] dArray, DataBuffer data) 在一个 double 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
float[] | SampleModel.getPixels(int x, int y, int w, int h, float[] fArray, DataBuffer data) 在一个 float 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
int[] | BandedSampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在 int 数组中返回指定像素矩形的所有样本，每个数据数组元素对应一个样本。
int[] | SinglePixelPackedSampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在一个 int 数组中返回对应于指定像素矩形的所有样本，每个数组元素对应一个样本。
int[] | ComponentSampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 返回对应 int 数组中像素指定矩形区域的所有样本（每个数组元素对应一个样本）。
int[] | SampleModel.getPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 在一个 int 数组中返回像素矩形的所有样本，每个数组元素对应一个样本。
int | BandedSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
int | MultiPixelPackedSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x, y) 处像素的样本。
int | SinglePixelPackedSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
int | ComponentSampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
abstract int | SampleModel.getSample(int x, int y, int b, DataBuffer data) 以 int 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | BandedSampleModel.getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | ComponentSampleModel.getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double | SampleModel.getSampleDouble(int x, int y, int b, DataBuffer data) 以 double 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | BandedSampleModel.getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | ComponentSampleModel.getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
float | SampleModel.getSampleFloat(int x, int y, int b, DataBuffer data) 以 float 形式返回指定 band 中对应于 (x,y) 处像素的样本。
double[] | SampleModel.getSamples(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data) 在一个 double 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
float[] | SampleModel.getSamples(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data) 在一个 float 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int[] | BandedSampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数据数组元素对应一个样本。
int[] | SinglePixelPackedSampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
int[] | ComponentSampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 返回指定 band 中对应于 int 数组中指定像素矩形的样本，每个数据数组元素一个样本。
int[] | SampleModel.getSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 在一个 int 数组中返回指定 band 中对应于指定像素矩形的样本，每个数组元素对应一个样本。
void | SampleModel.setDataElements(int x, int y, int w, int h, Object obj, DataBuffer data) 根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。
void | BandedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | MultiPixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | SinglePixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。
void | ComponentSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
abstract void | SampleModel.setDataElements(int x, int y, Object obj, DataBuffer data) 根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。
void | SampleModel.setPixel(int x, int y, double[] dArray, DataBuffer data) 使用输入的 double 样本数组设置 DataBuffer 中的像素。
void | SampleModel.setPixel(int x, int y, float[] fArray, DataBuffer data) 使用输入的 float 样本数组设置 DataBuffer 中的像素。
void | BandedSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | MultiPixelPackedSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入的 int 数组设置 DataBuffer 中的某个像素。
void | SinglePixelPackedSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | ComponentSampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入样本的 int 数组设置 DataBuffer 中的像素。
void | SampleModel.setPixel(int x, int y, int[] iArray, DataBuffer data) 使用输入的 int 样本数组设置 DataBuffer 中的像素。
void | SampleModel.setPixels(int x, int y, int w, int h, double[] dArray, DataBuffer data) 根据 double 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | SampleModel.setPixels(int x, int y, int w, int h, float[] fArray, DataBuffer data) 根据 float 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | BandedSampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置对应于像素矩形的所有样本，int 数组中每个数组元素包含一个样本。
void | SinglePixelPackedSampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | ComponentSampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组（每个数组元素包含一个样本）设置对应于像素矩形区域的所有样本。
void | SampleModel.setPixels(int x, int y, int w, int h, int[] iArray, DataBuffer data) 根据 int 数组设置像素矩形的所有样本，该数组为每个数组元素包含一个样本。
void | BandedSampleModel.setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | ComponentSampleModel.setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
void | SampleModel.setSample(int x, int y, int b, double s, DataBuffer data) 使用输入的 double 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | BandedSampleModel.setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | ComponentSampleModel.setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
void | SampleModel.setSample(int x, int y, int b, float s, DataBuffer data) 使用输入的 float 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | BandedSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 值设置指定 band 中对应于 DataBuffer 中 (x,y) 处像素的样本。
void | MultiPixelPackedSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int，设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | SinglePixelPackedSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | ComponentSampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 值，在指定 band 中设置对应于 DataBuffer 中 (x,y) 处像素的样本。
abstract void | SampleModel.setSample(int x, int y, int b, int s, DataBuffer data) 使用输入的 int 设置指定 band 中对应于 DataBuffer (x,y) 处像素的样本。
void | SampleModel.setSamples(int x, int y, int w, int h, int b, double[] dArray, DataBuffer data) 根据 double 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | SampleModel.setSamples(int x, int y, int w, int h, int b, float[] fArray, DataBuffer data) 根据 float 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | BandedSampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，int 数组中每个数据数组元素包含一个样本。
void | SinglePixelPackedSampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。
void | ComponentSampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组（每个数据数组元素包含一个样本），在指定 band 中设置对应于指定像素矩形的样本。
void | SampleModel.setSamples(int x, int y, int w, int h, int b, int[] iArray, DataBuffer data) 根据 int 数组设置指定 band 中对应于指定像素矩形的样本，该数组为每个数组元素包含一个样本。

参数类型为 DataBuffer 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.Raster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.Raster
的使用

使用 Raster 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt 中 Raster 的使用

返回 Raster 的 java.awt 中的方法
 Raster PaintContext.getRaster(int x, int y, int w, int h)
返回包含为图形操作生成的颜色的 Raster。

参数类型为 Raster 的 java.awt 中的方法
 void CompositeContext.compose(Raster src, Raster dstIn, WritableRaster dstOut)
组合两个源 Raster 对象并将结果置于目标 WritableRaster 中。

java.awt.image 中 Raster 的使用

java.awt.image 中 Raster 的子类
 class WritableRaster
此类扩展了 Raster 以提供像素写入功能。

声明为 Raster 的 java.awt.image 中的字段
protected  Raster Raster.parent
此 Raster 的父 Raster，或者为 null。

返回 Raster 的 java.awt.image 中的方法
Raster | Raster.createChild(int parentX, int parentY, int width, int height, int childMinX, int childMinY, int[] bandList) 返回共享此 Raster 全部或部分 DataBuffer 的新 Raster。
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
Raster | Raster.createTranslatedChild(int childMinX, int childMinY) 创建一个 Raster，使其大小、SampleModel 和 DataBuffer 与此 Raster 相同，但是位置不同。
Raster | BufferedImage.getData() 以一个大 tile 的形式返回图像。
Raster | RenderedImage.getData() 以一个大 tile 的形式返回图像（对于基于 tile 的图像，此方法需要获取整个图像并复制全部图像数据）。
Raster | BufferedImage.getData(Rectangle rect) 计算并返回 BufferedImage 的一个任意区域。
Raster | RenderedImage.getData(Rectangle rect) 计算并返回 RenderedImage 的任意区域。
Raster | Raster.getParent() 返回此 Raster 的父 Raster（如果有），或者 null。
Raster | BufferedImage.getTile(int tileX, int tileY) 返回 tile (tileX, tileY)。
Raster | RenderedImage.getTile(int tileX, int tileY) 返回 tile (tileX, tileY)。

参数类型为 Raster 的 java.awt.image 中的方法
BufferedImage | IndexColorModel.convertToIntDiscrete(Raster raster, boolean forceARGB) 返回一个 TYPE_INT_ARGB 或 TYPE_INT_RGB 的新 BufferedImage，其 Raster 的像素数据是通过使用此 ColorModel 的颜色/alpha 分量数组扩展源 Raster 中的各索引来计算的。
WritableRaster | AffineTransformOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的经过检查的目标 Raster。
WritableRaster | BandCombineOp.createCompatibleDestRaster(Raster src) 创建一个经过检查的目标 Raster，它具有正确大小和 band 数。
WritableRaster | ColorConvertOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | ConvolveOp.createCompatibleDestRaster(Raster src) 创建给定源且具有正确 band 大小和数量的归零目标 Raster。
WritableRaster | LookupOp.createCompatibleDestRaster(Raster src) 在给定源 Raster 的情况下，创建一幅具有正确大小和 band 数的、经过检查的目标 Raster。
WritableRaster | RasterOp.createCompatibleDestRaster(Raster src) 创建一个具有正确大小和 band 数的归零目标 Raster。
WritableRaster | RescaleOp.createCompatibleDestRaster(Raster src) 在给出源的情况下，创建一个具有正确大小和 band 数的经检查的目标 Raster。
WritableRaster | AffineTransformOp.filter(Raster src, WritableRaster dst) 转换源 Raster 并将结果存储在目标 Raster 中。
WritableRaster | BandCombineOp.filter(Raster src, WritableRaster dst) 使用构造方法中指定的矩阵变换该 Raster。
WritableRaster | ColorConvertOp.filter(Raster src, WritableRaster dest) 对源 Raster 中的图像数据进行颜色转换。
WritableRaster | ConvolveOp.filter(Raster src, WritableRaster dst) 对 Raster 执行卷积运算。
WritableRaster | LookupOp.filter(Raster src, WritableRaster dst) 在 Raster 上执行查找操作。
WritableRaster | RasterOp.filter(Raster src, WritableRaster dest) 执行从源 Raster 到目标 Raster 的单输入/单输出操作。
WritableRaster | RescaleOp.filter(Raster src, WritableRaster dst) 对源 Raster 中的像素数据进行重缩放。
Rectangle2D | AffineTransformOp.getBounds2D(Raster src) 返回转换后的目标图像的边界框。
Rectangle2D | BandCombineOp.getBounds2D(Raster src) 返回变换后目标图像的边界框。
Rectangle2D | ColorConvertOp.getBounds2D(Raster src) 返回给定源的目标边界框。
Rectangle2D | ConvolveOp.getBounds2D(Raster src) 返回已过滤目标 Raster 的边界框。
Rectangle2D | LookupOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RasterOp.getBounds2D(Raster src) 返回过滤后目标 Raster 的边界框。
Rectangle2D | RescaleOp.getBounds2D(Raster src) 返回重缩放后的目标 Raster 的边界框。
boolean | ComponentColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true；如果不兼容，则返回 false。
boolean | IndexColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true；如果不与此 ColorModel 兼容，则返回 false。
boolean | DirectColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
boolean | ColorModel.isCompatibleRaster(Raster raster) 如果 raster 与此 ColorModel 兼容，则返回 true，如果不兼容，则返回 false。
void | BufferedImage.setData(Raster r) 将图像的矩形区域设置为指定 Raster r 的内容，假定该区域与 BufferedImage 处于相同的坐标空间。
void | WritableRenderedImage.setData(Raster r) 将图像的 rect 设置为 Raster r 的内容，假定 r 位于与 WritableRenderedImage 相同的坐标空间。
void | WritableRaster.setDataElements(int x, int y, Raster inRaster) 为输入 Raster 中的像素矩形设置数据。
void | WritableRaster.setRect(int dx, int dy, Raster srcRaster) 将像素从 Raster srcRaster 复制到此 WritableRaster。
void | WritableRaster.setRect(Raster srcRaster) 将像素从 Raster srcRaster 复制到此 WritableRaster。

参数类型为 Raster 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。

javax.imageio 中 Raster 的使用

声明为 Raster 的 javax.imageio 中的字段
protected  Raster IIOImage.raster
正被引用的 Raster。

返回 Raster 的 javax.imageio 中的方法
Raster | IIOImage.getRaster() 返回当前设置好的 Raster，如果只有一个 RenderedImage 可用，则返回 null。
Raster | ImageReader.readRaster(int imageIndex, ImageReadParam param) 返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。
Raster | ImageReader.readTileRaster(int imageIndex, int tileX, int tileY) 返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。

参数类型为 Raster 的 javax.imageio 中的方法
void | ImageWriter.replacePixels(Raster raster, ImageWriteParam param) 用给定 Raster 部分替换已出现在输出中的图像部分。
void | IIOImage.setRaster(Raster raster) 设置当前 Raster。

参数类型为 Raster 的 javax.imageio 中的构造方法
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.ImageConsumer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.ImageConsumer
的使用

使用 ImageConsumer 的软件包
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt.image 中 ImageConsumer 的使用

实现 ImageConsumer 的 java.awt.image 中的类
class | AreaAveragingScaleFilter 这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
class | BufferedImageFilter BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
class | CropImageFilter 用于裁剪图像的 ImageFilter 类。
class | ImageFilter 此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
class | PixelGrabber PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。
class | ReplicateScaleFilter 使用最简单的算法缩放图像的 ImageFilter 类。
class | RGBImageFilter 此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

声明为 ImageConsumer 的 java.awt.image 中的字段
protected  ImageConsumer ImageFilter.consumer
特定图像数据流的使用者，而此 ImageFilter 实例也是为这个使用者来过滤数据的。

参数类型为 ImageConsumer 的 java.awt.image 中的方法
void | MemoryImageSource.addConsumer(ImageConsumer ic) 将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表。
void | FilteredImageSource.addConsumer(ImageConsumer ic) 将指定的 ImageConsumer 添加到对过滤图像的数据感兴趣的使用者列表。
void | ImageProducer.addConsumer(ImageConsumer ic) 为了在稍后的 Image 重构期间访问图像数据，向 ImageProducer 注册一个 ImageConsumer。
ImageFilter | ImageFilter.getFilterInstance(ImageConsumer ic) 返回为指定 ImageConsumer 实际执行过滤的 ImageFilter 对象的惟一实例。
boolean | MemoryImageSource.isConsumer(ImageConsumer ic) 确定某个 ImageConsumer 目前是否处于对此图像数据感兴趣的使用者列表中。
boolean | FilteredImageSource.isConsumer(ImageConsumer ic) 确定一个 ImageConsumer 是否在对此图像数据感兴趣的使用者列表中。
boolean | ImageProducer.isConsumer(ImageConsumer ic) 确定指定的 ImageConsumer 对象目前是否已向此 ImageProducer 注册为其使用者之一。
void | MemoryImageSource.removeConsumer(ImageConsumer ic) 从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
void | FilteredImageSource.removeConsumer(ImageConsumer ic) 从对此图像数据感兴趣的使用者列表中移除 ImageConsumer。
void | ImageProducer.removeConsumer(ImageConsumer ic) 从目前已注册以接收图像数据的使用者列表中移除指定的 ImageConsumer 对象。
void | MemoryImageSource.requestTopDownLeftRightResend(ImageConsumer ic) 请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
void | FilteredImageSource.requestTopDownLeftRightResend(ImageConsumer ic) 请求给定的 ImageConsumer 再次按从上到下、从左到右的顺序传递图像数据。
void | ImageProducer.requestTopDownLeftRightResend(ImageConsumer ic) 代表 ImageConsumer 请求 ImageProducer 尝试再次以 TOPDOWNLEFTRIGHT 的顺序重新发送图像数据，从而可以使用依赖于按顺序接收像素的高质量转换算法以生成更佳的图像输出。
void | MemoryImageSource.startProduction(ImageConsumer ic) 将 ImageConsumer 添加到对此图像数据感兴趣的使用者列表中，并立即开始通过 ImageConsumer 接口传递图像数据。
void | FilteredImageSource.startProduction(ImageConsumer ic) 开始生成过滤图像。
void | ImageProducer.startProduction(ImageConsumer ic) 将指定的 ImageConsumer 对象注册为使用者，并立即开始图像数据的重构，然后这些图像数据将传递到此使用者和已经向该生产者注册的所有其他使用者。

java.awt.image.renderable 中 ImageConsumer 的使用

参数类型为 ImageConsumer 的 java.awt.image.renderable 中的方法
void | RenderableImageProducer.addConsumer(ImageConsumer ic) 将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表。
boolean | RenderableImageProducer.isConsumer(ImageConsumer ic) 确定某个 ImageConsumer 是否在当前对此图像的数据感兴趣的使用者列表。
void | RenderableImageProducer.removeConsumer(ImageConsumer ic) 从对此图像的数据感兴趣的使用者列表中删除一个 ImageConsumer。
void | RenderableImageProducer.requestTopDownLeftRightResend(ImageConsumer ic) 请求给定 ImageConsumer 按从上到下、从左到右的顺序再次提交图像数据。
void | RenderableImageProducer.startProduction(ImageConsumer ic) 将 ImageConsumer 添加到对此图像的数据感兴趣的使用者列表，并立即通过 ImageConsumer 接口开始提交该图像数据。

javax.swing 中 ImageConsumer 的使用

实现 ImageConsumer 的 javax.swing 中的类
 class GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.VolatileImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.VolatileImage
的使用

使用 VolatileImage 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 VolatileImage 的使用

声明为 VolatileImage 的 java.awt 中的字段
protected VolatileImage[] | Component.BltBufferStrategy.backBuffers 后台缓冲区
protected VolatileImage | Component.FlipBufferStrategy.drawVBuffer 作为可变图像的绘制缓冲区。

返回 VolatileImage 的 java.awt 中的方法
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容的 VolatileImage。
VolatileImage | Component.createVolatileImage(int width, int height) 创建一幅用于双缓冲的、可变的、可在屏幕外绘制的图像。
VolatileImage | Component.createVolatileImage(int width, int height, ImageCapabilities caps) 创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.ImageProducer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.ImageProducer
的使用

使用 ImageProducer 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 ImageProducer 的使用

返回 ImageProducer 的 java.awt 中的方法
abstract  ImageProducer Image.getSource()
获取生成图像像素的对象。

参数类型为 ImageProducer 的 java.awt 中的方法
abstract Image | Toolkit.createImage(ImageProducer producer) 使用指定的图像生成器创建一幅图像。
Image | Component.createImage(ImageProducer producer) 根据指定的图像生成器创建一幅图像。

java.awt.image 中 ImageProducer 的使用

实现 ImageProducer 的 java.awt.image 中的类
class | FilteredImageSource 此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。
class | MemoryImageSource 此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。

返回 ImageProducer 的 java.awt.image 中的方法
ImageProducer | BufferedImage.getSource() 返回生成该图像像素的对象。
ImageProducer | VolatileImage.getSource() 此方法返回此 VolatileImage 的 ImageProducer。

参数类型为 ImageProducer 的 java.awt.image 中的方法
 void ImageFilter.resendTopDownLeftRight(ImageProducer ip)
响应来自 ImageConsumer 的一个按 TopDownLeftRight (TDLR) 顺序将像素数据重新发送的请求。

参数类型为 ImageProducer 的 java.awt.image 中的构造方法
FilteredImageSource(ImageProducer orig, ImageFilter imgf)
根据现有的 ImageProducer 和过滤器对象构造一个 ImageProducer 对象。
PixelGrabber(ImageProducer ip, int x, int y, int w, int h, int[] pix, int off, int scansize)
创建一个 PixelGrabber 对象，以从指定 ImageProducer 所生成的图像中将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。

java.awt.image.renderable 中 ImageProducer 的使用

实现 ImageProducer 的 java.awt.image.renderable 中的类
 class RenderableImageProducer
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.BufferStrategy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.BufferStrategy
的使用

使用 BufferStrategy 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 BufferStrategy 的使用

java.awt 中 BufferStrategy 的子类
protected class | Component.BltBufferStrategy 用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。
protected class | Component.FlipBufferStrategy 在组件上翻转缓冲区的内部类。

返回 BufferStrategy 的 java.awt 中的方法
BufferStrategy | Canvas.getBufferStrategy() 返回由此组件使用的 BufferStrategy。
BufferStrategy | Window.getBufferStrategy() 返回此组件使用的 BufferStrategy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.IndexColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.IndexColorModel
的使用

使用 IndexColorModel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 IndexColorModel 的使用

返回 IndexColorModel 的 java.awt.image 中的方法
 IndexColorModel RGBImageFilter.filterIndexColorModel(IndexColorModel icm)
过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。

参数类型为 IndexColorModel 的 java.awt.image 中的方法
 IndexColorModel RGBImageFilter.filterIndexColorModel(IndexColorModel icm)
过滤 IndexColorModel 对象：通过 filterRGB 函数（RGBImageFilter 子类必须提供该函数）运行该对象颜色表中的每一项。

参数类型为 IndexColorModel 的 java.awt.image 中的构造方法
BufferedImage(int width, int height, int imageType, IndexColorModel cm)
构造一个类型为预定义图像类型之一的 BufferedImage：TYPE_BYTE_BINARY 或 TYPE_BYTE_INDEXED。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.ColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.ColorModel
的使用

使用 ColorModel 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.imageio | Java Image I/O API 的主要包。

java.awt 中 ColorModel 的使用

返回 ColorModel 的 java.awt 中的方法
ColorModel | PaintContext.getColorModel() 返回输出的 ColorModel。
abstract ColorModel | GraphicsConfiguration.getColorModel() 返回与此 GraphicsConfiguration 关联的 ColorModel。
abstract ColorModel | Toolkit.getColorModel() 确定此工具包屏幕的颜色模型。
ColorModel | Component.getColorModel() 获取用于在输出设备上显示组件的 ColorModel 实例。
abstract ColorModel | GraphicsConfiguration.getColorModel(int transparency) 返回与此 GraphicsConfiguration 关联并支持指定透明度的 ColorModel。

参数类型为 ColorModel 的 java.awt 中的方法
CompositeContext | AlphaComposite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 为合成操作创建一个上下文。
CompositeContext | Composite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 创建一个上下文，其中包含用于执行复合操作的状态。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。

java.awt.image 中 ColorModel 的使用

java.awt.image 中 ColorModel 的子类
class | ComponentColorModel 使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。
class | DirectColorModel DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。
class | IndexColorModel IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
class | PackedColorModel PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。

声明为 ColorModel 的 java.awt.image 中的字段
protected ColorModel | RGBImageFilter.newmodel 用户调用 substituteColorModel 时替换 origmodel 的 ColorModel。
protected ColorModel | RGBImageFilter.origmodel 用户调用 substituteColorModel 时将由 newmodel 替换的 ColorModel。

返回 ColorModel 的 java.awt.image 中的方法
ColorModel | ComponentColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
ColorModel | DirectColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定此 ColorModel 现在已对该数据进行正确描述。
ColorModel | ColorModel.coerceData(WritableRaster raster, boolean isAlphaPremultiplied) 强制使光栅数据与在 isAlphaPremultiplied 变量中指定的状态匹配，假定当前该数据已由此 ColorModel 正确描述。
ColorModel | PixelGrabber.getColorModel() 获取该数组中所存储像素的 ColorModel。
ColorModel | BufferedImage.getColorModel() 返回 ColorModel。
ColorModel | RenderedImage.getColorModel() 返回与此图像相关的 ColorModel。
static ColorModel | ColorModel.getRGBdefault() 返回描述整数 RGB 值的默认格式的 DirectColorModel，该整数 RGB 值可以在便于程序员使用的 AWT 图像接口中的许多方法中使用。

参数类型为 ColorModel 的 java.awt.image 中的方法
BufferedImage | AffineTransformOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | BufferedImageOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经过检查的目标图像。
BufferedImage | ColorConvertOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建给定源的具有正确大小和 band 数量的归零目标图像。
BufferedImage | ConvolveOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建具有正确 band 大小和数量的归零目标图像。
BufferedImage | LookupOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一幅具有正确大小和 band 数的、经过检查的目标图像。
BufferedImage | RescaleOp.createCompatibleDestImage(BufferedImage src, ColorModel destCM) 创建一个具有正确大小和 band 数的经检查的目标图像。
void | MemoryImageSource.newPixels(byte[] newpix, ColorModel newmodel, int offset, int scansize) 改用一个新的 byte 数组以保存此图像的像素。
void | MemoryImageSource.newPixels(int[] newpix, ColorModel newmodel, int offset, int scansize) 改用一个新的 int 数组以保存此图像的像素。
void | BufferedImageFilter.setColorModel(ColorModel model) 过滤 ImageConsumer 接口的 setColorModel 方法提供的信息。
void | PixelGrabber.setColorModel(ColorModel model) setColorModel 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | RGBImageFilter.setColorModel(ColorModel model) 如果 ColorModel 是 IndexColorModel 且子类将 canFilterIndexColorModel 标志设置为 true，则将此处及 setPixels 方法中任何出现原始 ColorModel 对象的地方替换为过滤后的颜色模型。
void | ImageFilter.setColorModel(ColorModel model) 过滤 ImageConsumer 接口的 setColorModel 方法中所提供的信息。
void | ImageConsumer.setColorModel(ColorModel model) 设置用于大多数像素的 ColorModel 对象，这些像素使用 setPixels 方法调用进行报告。
void | AreaAveragingScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 将已传送 byte 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
void | BufferedImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 过滤 ImageConsumer 接口（采用字节数组）的 setPixels 方法中提供的信息。
void | CropImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 确定已传递的字节像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
void | PixelGrabber.setPixels(int srcX, int srcY, int srcW, int srcH, ColorModel model, byte[] pixels, int srcOff, int srcScan) setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | ReplicateScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 从传递的 byte pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
void | RGBImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素。
void | ImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以 byte 数组为参数。
void | ImageConsumer.setPixels(int x, int y, int w, int h, ColorModel model, byte[] pixels, int off, int scansize) 一次或多次调用此方法来传递图像的像素。
void | AreaAveragingScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 将已传送 int 像素的分量组合到累加数组，并发送所有已完成像素行的平均数据。
void | BufferedImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 过滤 ImageConsumer 接口（采用整数数组）的 setPixels 方法中提供的信息。
void | CropImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 确定已传递的 int 像素是否与要提取的区域相交，只传递出现在输出区域的像素子集。
void | PixelGrabber.setPixels(int srcX, int srcY, int srcW, int srcH, ColorModel model, int[] pixels, int srcOff, int srcScan) setPixels 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | ReplicateScaleFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 从传递的 int pixels 中选择目标缩放图像需要的行和列，并只传递这些所需的行和列，必要时可复制。
void | RGBImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 如果 ColorModel 对象就是已转换后的对象，则使用转换后的 ColorModel 传递像素，否则，将整数像素的缓冲区转换为默认 RGB ColorModel，并将转换后的缓冲区传递给 filterRGBPixels 方法进行逐一转换。
void | ImageFilter.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 过滤由 ImageConsumer 接口的 setPixels 方法所提供的信息，该方法以整数数组为参数。
void | ImageConsumer.setPixels(int x, int y, int w, int h, ColorModel model, int[] pixels, int off, int scansize) 一次或多次调用 setPixels 方法来传递图像的像素。
void | RGBImageFilter.substituteColorModel(ColorModel oldcm, ColorModel newcm) 注册两个用于替换的 ColorModel 对象。

参数类型为 ColorModel 的 java.awt.image 中的构造方法
BufferedImage(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。

javax.imageio 中 ColorModel 的使用

声明为 ColorModel 的 javax.imageio 中的字段
protected  ColorModel ImageTypeSpecifier.colorModel
将用作原型的 ColorModel。

返回 ColorModel 的 javax.imageio 中的方法
 ColorModel ImageTypeSpecifier.getColorModel()
返回此对象指定的 ColorModel。

参数类型为 ColorModel 的 javax.imageio 中的构造方法
ImageTypeSpecifier(ColorModel colorModel, SampleModel sampleModel)
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.DirectColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.DirectColorModel
的使用

没有 java.awt.image.DirectColorModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.image.PackedColorModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.image.PackedColorModel
的使用

使用 PackedColorModel 的软件包
java.awt.image 提供创建和修改图像的各种类。

java.awt.image 中 PackedColorModel 的使用

java.awt.image 中 PackedColorModel 的子类
 class DirectColorModel
DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.image.ImageObserver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.image.ImageObserver
的使用

使用 ImageObserver 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 ImageObserver 的使用

实现 ImageObserver 的 java.applet 中的类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 ImageObserver 的使用

实现 ImageObserver 的 java.awt 中的类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Component component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
class | Panel Panel 是最简单的容器类。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

参数类型为 ImageObserver 的 java.awt 中的方法
int | Component.checkImage(Image image, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
abstract int | Toolkit.checkImage(Image image, int width, int height, ImageObserver observer) 指示正准备显示的指定图像的构造状态。
int | Component.checkImage(Image image, int width, int height, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
abstract boolean | Graphics2D.drawImage(Image img, AffineTransform xform, ImageObserver obs) 呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
abstract boolean | Graphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract int | Image.getHeight(ImageObserver observer) 确定图像的高度。
abstract Object | Image.getProperty(String name, ImageObserver observer) 通过名称获取此图像的属性。
abstract int | Image.getWidth(ImageObserver observer) 确定图像的宽度。
boolean | Component.prepareImage(Image image, ImageObserver observer) 准备一幅在此组件上呈现的图像。
abstract boolean | Toolkit.prepareImage(Image image, int width, int height, ImageObserver observer) 准备一个用于呈现的图像。
boolean | Component.prepareImage(Image image, int width, int height, ImageObserver observer) 以指定的宽度和高度准备一幅在此组件上呈现的图像。

java.awt.image 中 ImageObserver 的使用

参数类型为 ImageObserver 的 java.awt.image 中的方法
int | BufferedImage.getHeight(ImageObserver observer) 返回 BufferedImage 的高度。
Object | BufferedImage.getProperty(String name, ImageObserver observer) 按名称返回图像的属性。
int | BufferedImage.getWidth(ImageObserver observer) 返回 BufferedImage 的宽度。

javax.swing 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

返回 ImageObserver 的 javax.swing 中的方法
 ImageObserver ImageIcon.getImageObserver()
返回图像的图像观察者。

参数类型为 ImageObserver 的 javax.swing 中的方法
boolean | DebugGraphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 重写 Graphics.drawImage。
void | ImageIcon.setImageObserver(ImageObserver observer) 设置图像的图像观察者。

javax.swing.colorchooser 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.colorchooser 中的类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf.basic 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

javax.swing.plaf.metal 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.table 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 ImageObserver 的使用

实现 ImageObserver 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Book (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.print
类 Book

java.lang.Object
    继承者  java.awt.print.Book
所有已实现的接口：
Pageable
public class Book
extends Object
implements Pageable

Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。此类使用 Pageable 接口与 PrinterJob 交互。

另请参见：
Pageable, PrinterJob

字段摘要
从接口 java.awt.print.Pageable 继承的字段
UNKNOWN_NUMBER_OF_PAGES
构造方法摘要
Book()
创建新的空 Book。
方法摘要
void | append(Printable painter, PageFormat page) 将单个页面追加到此 Book 的尾部。
void | append(Printable painter, PageFormat page, int numPages) 将 numPages 个页面追加到此 Book 的尾部。
int | getNumberOfPages() 返回此 Book 中的页数。
PageFormat | getPageFormat(int pageIndex) 返回 pageIndex 指定的页面的 PageFormat。
Printable | getPrintable(int pageIndex) 返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。
void | setPage(int pageIndex, Printable painter, PageFormat page) 为指定的页码设置 PageFormat 和 Painter。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Book

public Book()
创建新的空 Book。

方法详细信息

getNumberOfPages

public int getNumberOfPages()
返回此 Book 中的页数。

指定者：
接口 Pageable 中的 getNumberOfPages
返回：
此 Book 包含的页数。

getPageFormat

public PageFormat getPageFormat(int pageIndex)
                         throws IndexOutOfBoundsException
返回 pageIndex 指定的页面的 PageFormat。

指定者：
接口 Pageable 中的 getPageFormat
参数：
pageIndex - 其 PageFormat 正被请求的页面基于零的索引
返回：
描述页面大小和方向的 PageFormat。
抛出：
IndexOutOfBoundsException - 如果 Pageable 不包含请求的页面

getPrintable

public Printable getPrintable(int pageIndex)
                       throws IndexOutOfBoundsException
返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。

指定者：
接口 Pageable 中的 getPrintable
参数：
pageIndex - 其 Printable 正被请求的页面基于零的索引
返回：
呈现该页面的 Printable。
抛出：
IndexOutOfBoundsException - 如果 Pageable 不包含请求的页面

setPage

public void setPage(int pageIndex,
                    Printable painter,
                    PageFormat page)
             throws IndexOutOfBoundsException
为指定的页码设置 PageFormat 和 Painter。

参数：
pageIndex - 其 painter 和格式要更改的页面基于零的索引
painter - 呈现页面的 Printable 实例
page - 页面的大小和方向
抛出：
IndexOutOfBoundsException - 如果指定的页面在此 Book 中不存在
NullPointerException - 如果 painter 或 page 参数为 null

append

public void append(Printable painter,
                   PageFormat page)
将单个页面追加到此 Book 的尾部。

参数：
painter - 呈现页面的 Printable 实例
page - 页面的大小和方向
抛出：
NullPointerException - 如果 painter 或 page 参数为 null

append

public void append(Printable painter,
                   PageFormat page,
                   int numPages)
将 numPages 个页面追加到此 Book 的尾部。每个页面都与 page 有关。

参数：
painter - 呈现页面的 Printable 实例
page - 页面的大小和方向
numPages - 要添加到此 Book 的页面数。
抛出：
NullPointerException - 如果 painter 或 page 参数为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Pageable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
接口 Pageable

所有已知实现类：
Book
public interface Pageable

Pageable 实现表示要打印的页面集合。Pageable 对象返回该集合中的页面总数，以及指定页面的 PageFormat 和 Printable。

另请参见：
PageFormat, Printable

字段摘要
static int UNKNOWN_NUMBER_OF_PAGES
如果集合中的页面数对于 Pageable 实现是未知的，则从 getNumberOfPages 方法返回此常量。
方法摘要
int | getNumberOfPages() 返回集合中的页面数。
PageFormat | getPageFormat(int pageIndex) 返回 pageIndex 指定的页面的 PageFormat。
Printable | getPrintable(int pageIndex) 返回负责呈现 pageIndex 指定的页面的 Printable 实例。

字段详细信息

UNKNOWN_NUMBER_OF_PAGES

static final int UNKNOWN_NUMBER_OF_PAGES
如果集合中的页面数对于 Pageable 实现是未知的，则从 getNumberOfPages 方法返回此常量。

另请参见：
常量字段值
方法详细信息

getNumberOfPages

int getNumberOfPages()
返回集合中的页面数。要启用高级打印功能，建议 Pageable 实现返回页面的实际数，而不是 UNKNOWN_NUMBER_OF_PAGES 常量。

返回：
此 Pageable 中的页面数。

getPageFormat

PageFormat getPageFormat(int pageIndex)
                         throws IndexOutOfBoundsException
返回 pageIndex 指定的页面的 PageFormat。

参数：
pageIndex - 其 PageFormat 正被请求的页面基于零的索引
返回：
描述页面大小和方向的 PageFormat。
抛出：
IndexOutOfBoundsException - 如果 Pageable 不包含请求的页面

getPrintable

Printable getPrintable(int pageIndex)
                       throws IndexOutOfBoundsException
返回负责呈现 pageIndex 指定的页面的 Printable 实例。

参数：
pageIndex - 其 Printable 正被请求的页面基于零的索引
返回：
呈现该页面的 Printable。
抛出：
IndexOutOfBoundsException - 如果 Pageable 不包含请求的页面
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
类 PageFormat

java.lang.Object
    继承者  java.awt.print.PageFormat
所有已实现的接口：
Cloneable
public class PageFormat
extends Object
implements Cloneable

PageFormat 类描述要打印的页面大小和方向。

字段摘要
static int | LANDSCAPE 原点位于纸张的左下方，x 的方向从下到上，y 的方向从左到右。
static int | PORTRAIT 原点在纸张的左上方，x 指向右方，y 指向下方。
static int | REVERSE_LANDSCAPE 原点位于纸张的右上方，x 的方向从上到下，y 的方向从右到左。
构造方法摘要
PageFormat()
创建默认的纵向 PageFormat。
方法摘要
Object | clone() 制作此 PageFormat 的副本，使它与此 PageFormat 具有相同的内容。
double | getHeight() 返回页面的高度（以 1/72 英寸为单位）。
double | getImageableHeight() 返回页面可成像区域的高度（以 1/72 英寸为单位）。
double | getImageableWidth() 返回页面可成像区域的宽度（以 1/72 英寸为单位）。
double | getImageableX() 返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 x 坐标。
double | getImageableY() 返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 y 坐标。
double[] | getMatrix() 返回一个变换矩阵，该矩阵将呈现的用户空间向请求的方向平移。
int | getOrientation() 返回此 PageFormat 的方向。
Paper | getPaper() 返回与此 PageFormat 相关的 Paper 对象的一个副本。
double | getWidth() 返回页面的宽度（以 1/72 英寸为单位）。
void | setOrientation(int orientation) 设置页面方向。
void | setPaper(Paper paper) 为此 PageFormat 设置 Paper 对象。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LANDSCAPE

public static final int LANDSCAPE
原点位于纸张的左下方，x 的方向从下到上，y 的方向从左到右。注意，这不是 Macintosh landscape，而是 Windows 和 PostScript landscape。

另请参见：
常量字段值

PORTRAIT

public static final int PORTRAIT
原点在纸张的左上方，x 指向右方，y 指向下方。

另请参见：
常量字段值

REVERSE_LANDSCAPE

public static final int REVERSE_LANDSCAPE
原点位于纸张的右上方，x 的方向从上到下，y 的方向从右到左。注意，这是 Macintosh landscape。

另请参见：
常量字段值
构造方法详细信息

PageFormat

public PageFormat()
创建默认的纵向 PageFormat。

方法详细信息

clone

public Object clone()
制作此 PageFormat 的副本，使它与此 PageFormat 具有相同的内容。

覆盖：
类 Object 中的 clone
返回：
此 PageFormat 的副本。
另请参见：
Cloneable

getWidth

public double getWidth()
返回页面的宽度（以 1/72 英寸为单位）。在确定宽度时，此方法考虑了该页面方向。

返回：
页面的宽度。

getHeight

public double getHeight()
返回页面的高度（以 1/72 英寸为单位）。在确定高度时，此方法考虑了页面方向。

返回：
页面的高度。

getImageableX

public double getImageableX()
返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 x 坐标。此方法考虑了页面的方向。

返回：
与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 x 坐标。

getImageableY

public double getImageableY()
返回与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 y 坐标。此方法考虑了页面的方向。

返回：
与此 PageFormat 相关的 Paper 对象的可成像区域左上方点的 y 坐标。

getImageableWidth

public double getImageableWidth()
返回页面可成像区域的宽度（以 1/72 英寸为单位）。此方法考虑了页面的方向。

返回：
页面的宽度。

getImageableHeight

public double getImageableHeight()
返回页面可成像区域的高度（以 1/72 英寸为单位）。此方法考虑了页面的方向。

返回：
页面的高度。

getPaper

public Paper getPaper()
返回与此 PageFormat 相关的 Paper 对象的一个副本。对从此方法返回的 Paper 对象进行的更改不影响此 PageFormat 的 Paper 对象。要更新此 PageFormat 的 Paper 对象，请创建新的 Paper 对象，并使用 setPaper(Paper) 方法将它设置到此 PageFormat 中。

返回：
与此 PageFormat 相关的 Paper 对象的一个副本。
另请参见：
setPaper(java.awt.print.Paper)

setPaper

public void setPaper(Paper paper)
为此 PageFormat 设置 Paper 对象。

参数：
paper - 作为 PageFormat 的 Paper 对象的设置目标的 Paper 对象。
抛出：
NullPointerException - 传递的页面实例参数为 null 。
另请参见：
getPaper()

setOrientation

public void setOrientation(int orientation)
                    throws IllegalArgumentException
设置页面方向。orientation 必须是以下常量之一：PORTRAIT、LANDSCAPE 或 REVERSE_LANDSCAPE。

参数：
orientation - 页面的新方向
抛出：
IllegalArgumentException - 如果请求了未知的方向
另请参见：
getOrientation()

getOrientation

public int getOrientation()
返回此 PageFormat 的方向。

返回：
此 PageFormat 对象的方向。
另请参见：
setOrientation(int)

getMatrix

public double[] getMatrix()
返回一个变换矩阵，该矩阵将呈现的用户空间向请求的方向平移。将值按 AffineTransform 构造方法所要求的形式 { m00, m10, m01, m11, m02, m12} 放入数组中。

返回：
用于将呈现的用户空间向页面的方向平移的矩阵。
另请参见：
AffineTransform
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Paper (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
类 Paper

java.lang.Object
    继承者  java.awt.print.Paper
所有已实现的接口：
Cloneable
public class Paper
extends Object
implements Cloneable

Paper 类描述一张纸的物理特征。

创建 Paper 对象时，应用程序负责确保纸张大小与可成像区域兼容。例如，如果将纸张大小从 11 x 17 更改为 8.5 x 11，则应用程序可能需要减小可成像区域，以便打印的内容适合该页面。

另请参见：
setSize(double, double), setImageableArea(double, double, double, double)

构造方法摘要
Paper()
创建信函大小的一张纸，页边空白为一英寸。
方法摘要
Object | clone() 创建此 Paper 的一个副本，内容与此 Paper 相同。
double | getHeight() 返回页面的高度（以 1/72 英寸为单位）。
double | getImageableHeight() 返回此 Paper 对象可成像区域的高度。
double | getImageableWidth() 返回此 Paper 对象可成像区域的宽度。
double | getImageableX() 返回此 Paper 对象可成像区域左上角的 x 坐标。
double | getImageableY() 返回此 Paper 对象可成像区域左上角的 y 坐标。
double | getWidth() 返回页面的宽度（以 1/72 英寸为单位）。
void | setImageableArea(double x, double y, double width, double height) 设置此 Paper 的可成像区域。
void | setSize(double width, double height) 设置此 Paper 对象的宽和高，它表示要用来打印的页面的属性。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Paper

public Paper()
创建信函大小的一张纸，页边空白为一英寸。

方法详细信息

clone

public Object clone()
创建此 Paper 的一个副本，内容与此 Paper 相同。

覆盖：
类 Object 中的 clone
返回：
此 Paper 的副本。
另请参见：
Cloneable

getHeight

public double getHeight()
返回页面的高度（以 1/72 英寸为单位）。

返回：
此 Paper 描述的页面高度。

setSize

public void setSize(double width,
                    double height)
设置此 Paper 对象的宽和高，它表示要用来打印的页面的属性。尺寸以 1/72 英寸为单位表示。

参数：
width - 设置此 Paper 对象宽度的值
height - 设置此 Paper 对象高度的值。

getWidth

public double getWidth()
返回页面的宽度（以 1/72 英寸为单位）。

返回：
此 Paper 描述的页面宽度。

setImageableArea

public void setImageableArea(double x,
                             double y,
                             double width,
                             double height)
设置此 Paper 的可成像区域。可成像区域是页面上用来打印的区域。

参数：
x - 用来设置此 Paper 可成像区域左上角的 X 坐标
y - 用来设置此 Paper 可成像区域左上角的 Y 坐标
width - 用来设置此 Paper 可成像区域宽度的值
height - 用来设置此 Paper 可成像区域高度的值

getImageableX

public double getImageableX()
返回此 Paper 对象可成像区域左上角的 x 坐标。

返回：
可成像区域的 x 坐标。

getImageableY

public double getImageableY()
返回此 Paper 对象可成像区域左上角的 y 坐标。

返回：
可成像区域的 y 坐标。

getImageableWidth

public double getImageableWidth()
返回此 Paper 对象可成像区域的宽度。

返回：
可成像区域的宽度。

getImageableHeight

public double getImageableHeight()
返回此 Paper 对象可成像区域的高度。

返回：
可成像区域的高度。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Printable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
接口 Printable

public interface Printable

Printable 接口由当前页面 painter 的 print 方法实现，该方法由打印系统调用，以呈现页面。构建 Pageable 时，使用 PageFormat 实例和实现此接口的实例构成的实例用于描述每个页面。调用实现 Printable 的实例，以打印页面的图形。

在 PrinterJob 上可以设置 Printable(..)。当客户端随后通过调用 PrinterJob.print(..) 启动打印时，控制被传送到打印系统，直到所有的页面完成打印。这是通过在文档中所有页面打印完成前一直调用 Printable.print(..) 来实现的。使用 Printable 接口时，只要打印系统请求，该打印就将页面内容提交给图像。

Printable.print(..) 的参数包括描述该页面可打印区域（计算适合该页面的内容所需要的区域）的 PageFormat 和页面索引（它指定请求页面的从 0 开始的打印流索引）。

要正确的进行打印，应注意以下几点：

  • 打印系统可能多次请求页面索引。对于每种情况，都将提供等效的 PageFormat 参数。
  • 打印系统将使用单调递增的页面索引来调用 Printable.print(..)，尽管上文已说明，Printable 应期望多次调用页面索引，并期望当客户端或用户通过打印对话指定页面范围时，可以跳过页面索引。
  • 如果请求文档多次逐份打印，并且打印机本身不支持此行为，那么该文档可能成像多次。将从最低打印流页面索引页面开始每次打印。
  • 除了为多次逐份打印重新成像整个文档外，递增的页面索引顺序意味着，当请求页面 N 时，如果客户端需要计算页面中断位置，则可以安全地丢弃任何与 < N 的页面相关的状态，并将页面 N 设置为当前状态。在与页面起始部分对应的文档中，“状态”通常就是计算的位置。
  • 当被打印系统调用时，Printable 必须检查并遵照提供的 PageFormat 参数以及页面索引。要绘制的页面格式由提供的 pageFormat 指定。所以该页面的大小、方向和可成像区域已经确定，并且必须在此可成像区域中呈现。这是正确进行打印的关键，它暗示客户端负责跟踪指定页面上所属的内容。
  • 从客户端提供的 Pageable 获取 Printable 时，该客户端可能为每个页面索引提供不同的 PageFormat。计算页面中断必须考虑到这一点。

另请参见：
Pageable, PageFormat, PrinterJob

字段摘要
static int | NO_SUCH_PAGE 从 print 返回，表示 pageIndex 太大以及请求的页面不存在。
static int | PAGE_EXISTS 从 print(Graphics, PageFormat, int) 返回，表示请求的页面被呈现。
方法摘要
 int print(Graphics graphics, PageFormat pageFormat, int pageIndex)
将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。

字段详细信息

PAGE_EXISTS

static final int PAGE_EXISTS
从 print(Graphics, PageFormat, int) 返回，表示请求的页面被呈现。

另请参见：
常量字段值

NO_SUCH_PAGE

static final int NO_SUCH_PAGE
从 print 返回，表示 pageIndex 太大以及请求的页面不存在。

另请参见：
常量字段值
方法详细信息

print

int print(Graphics graphics,
          PageFormat pageFormat,
          int pageIndex)
          throws PrinterException
将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。PrinterJob 调用 Printable 接口，以请求将页面呈现到 graphics 指定的上下文。pageFormat 指定要绘制的页面格式。pageIndex 指定请求页面从 0 开始的索引。如果请求的页面不存在，那么此方法将返回 NO_SUCH_PAGE；否则返回 PAGE_EXISTS。Graphics 类或子类实现 PrinterGraphics 接口，以提供附加信息。如果 Printable 对象中止该打印作业，那么它将抛出 PrinterException。

参数：
graphics - 用来绘制页面的上下文
pageFormat - 将绘制的页面的大小和方向
pageIndex - 要绘制的页面从 0 开始的索引
返回：
如果成功呈现该页面，则返回 PAGE_EXISTS；如果 pageIndex 指定不存在的页面，则返回 NO_SUCH_PAGE。
抛出：
PrinterException - 打印作业被终止时抛出。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterAbortException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
类 PrinterAbortException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.print.PrinterException
                继承者  java.awt.print.PrinterAbortException
所有已实现的接口：
Serializable
public class PrinterAbortException
extends PrinterException

PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。

另请参见：
序列化表格

构造方法摘要
PrinterAbortException()
构造不带详细信息的新 PrinterAbortException。
PrinterAbortException(String msg)
构造带指定详细信息的新 PrinterAbortException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterAbortException

public PrinterAbortException()
构造不带详细信息的新 PrinterAbortException。

PrinterAbortException

public PrinterAbortException(String msg)
构造带指定详细信息的新 PrinterAbortException。

参数：
msg - 抛出 PrinterAbortException 时生成的信息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
类 PrinterException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.print.PrinterException
所有已实现的接口：
Serializable
直接已知子类：
PrinterAbortException, PrinterIOException
public class PrinterException
extends Exception

PrinterException 类及其子类用于指示打印系统中发生的异常情况。

另请参见：
序列化表格

构造方法摘要
PrinterException()
构造不带详细信息的新 PrinterException 对象。
PrinterException(String msg)
构造带指定详细信息的新 PrinterException 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterException

public PrinterException()
构造不带详细信息的新 PrinterException 对象。

PrinterException

public PrinterException(String msg)
构造带指定详细信息的新 PrinterException 对象。

参数：
msg - 抛出 PrinterException 时生成的信息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterGraphics (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
接口 PrinterGraphics

public interface PrinterGraphics

PrinterGraphics 接口由被传递到 Printable 对象以呈现页面的 Graphics 对象实现。该接口允许应用程序查找正在控制打印的 PrinterJob 对象。

方法摘要
 PrinterJob getPrinterJob()
返回正在控制当前呈现请求的 PrinterJob。

方法详细信息

getPrinterJob

PrinterJob getPrinterJob()
返回正在控制当前呈现请求的 PrinterJob。

返回：
控制当前呈现请求的 PrinterJob。
另请参见：
Printable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterIOException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.awt.print
类 PrinterIOException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.awt.print.PrinterException
                继承者  java.awt.print.PrinterIOException
所有已实现的接口：
Serializable
public class PrinterIOException
extends PrinterException

PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

从 1.4 版本开始，此异常已经改进，以符合通用异常链机制。在构造时提供并通过 getIOException() 方法访问的“终止打印作业的 IOException”就是目前所说的 cause，可以通过 Throwable.getCause() 方法以及上述“遗留方法”访问它。

另请参见：
序列化表格

构造方法摘要
PrinterIOException(IOException exception)
构造具有指定 IOException 字符串表示形式的新 PrinterIOException。
方法摘要
Throwable | getCause() 返回此异常的 cause（终止打印作业的 IOException）。
IOException | getIOException() 返回终止打印作业的 IOException。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterIOException

public PrinterIOException(IOException exception)
构造具有指定 IOException 字符串表示形式的新 PrinterIOException。

参数：
exception - 指定的 IOException
方法详细信息

getIOException

public IOException getIOException()
返回终止打印作业的 IOException。

这是通用异常链设施之前的方法。现在 Throwable.getCause() 方法是获得此信息的首选方法。

返回：
终止打印作业的 IOException。
另请参见：
IOException

getCause

public Throwable getCause()
返回此异常的 cause（终止打印作业的 IOException）。

覆盖：
类 Throwable 中的 getCause
返回：
此异常的 cause。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterJob (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.awt.print
类 PrinterJob

java.lang.Object
    继承者  java.awt.print.PrinterJob

public abstract class PrinterJob
extends Object

PrinterJob 类是控制打印的主要类。应用程序调用此类中的方法设置作业、（可选地）调用与用户的打印对话框，然后打印作业的页面。

构造方法摘要
PrinterJob()
应使用静态 getPrinterJob 方法创建 PrinterJob 对象。
方法摘要
abstract void | cancel() 取消正在进行的打印作业。
PageFormat | defaultPage() 创建新的 PageFormat 实例，并将它设置为默认大小和方向。
abstract PageFormat | defaultPage(PageFormat page) 复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。
abstract int | getCopies() 获取要打印的副本数。
abstract String | getJobName() 获取要打印的文档名称。
PageFormat | getPageFormat(PrintRequestAttributeSet attributes) 使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。
static PrinterJob | getPrinterJob() 创建并返回初始化时与默认打印机关联的 PrinterJob。
PrintService | getPrintService() 返回此打印机作业的服务（打印机）。
abstract String | getUserName() 获取打印用户的名称。
abstract boolean | isCancelled() 如果打印作业正在进行中，而下一次打印作业将被取消，则返回 true；否则返回 false。
static PrintService[] | lookupPrintServices() 查找 2D 打印服务的便捷方法。
static StreamPrintServiceFactory[] | lookupStreamPrintServices(String mimeType) 定位可以成像 2D 图形的流打印服务工厂的便捷方法。
abstract PageFormat | pageDialog(PageFormat page) 显示允许修改 PageFormat 实例的对话框。
PageFormat | pageDialog(PrintRequestAttributeSet attributes) 显示跨平台页面设置对话框的便捷方法。
abstract void | print() 打印一组页面。
void | print(PrintRequestAttributeSet attributes) 使用属性集中的设置打印一组页面。
abstract boolean | printDialog() 向用户呈现一个对话框，用来更改打印作业的属性。
boolean | printDialog(PrintRequestAttributeSet attributes) 为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。
abstract void | setCopies(int copies) 设置要打印的副本数。
abstract void | setJobName(String jobName) 设置要打印的文档名称。
abstract void | setPageable(Pageable document) 查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。
abstract void | setPrintable(Printable painter) 调用 painter 以呈现页面。
abstract void | setPrintable(Printable painter, PageFormat format) 调用 painter，用指定的 format 呈现该页面。
void | setPrintService(PrintService service) 将此 PrinterJob 与新的 PrintService 关联。
abstract PageFormat | validatePage(PageFormat page) 返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PrinterJob

public PrinterJob()
应使用静态 getPrinterJob 方法创建 PrinterJob 对象。

方法详细信息

getPrinterJob

public static PrinterJob getPrinterJob()
创建并返回初始化时与默认打印机关联的 PrinterJob。如果系统上没有可用的打印机，则仍从此方法返回 PrinterJob，但是，getPrintService() 将返回 null，并且使用此 PrinterJob 调用 print 可能产生异常。需要在创建 PrinterJob 之前确定是否有合适打印机的应用程序应确保从 lookupPrintServices 返回的数组不为空。

返回：
新的 PrinterJob。
抛出：
SecurityException - 如果安全管理器存在并且其 SecurityManager.checkPrintJobAccess() 方法不允许此线程创建打印作业请求

lookupPrintServices

public static PrintService[] lookupPrintServices()
查找 2D 打印服务的便捷方法。在支持打印服务的 PrinterJob 上可以安装从此方法返回的服务。调用此方法等效于调用 PrintServiceLookup.lookupPrintServices() 并指定一个 Pageable DocFlavor。

返回：
2D 打印服务数组，可能为空。
从以下版本开始：
1.4

lookupStreamPrintServices

public static StreamPrintServiceFactory[] lookupStreamPrintServices(String mimeType)
定位可以成像 2D 图形的流打印服务工厂的便捷方法。示例用法：
 FileOutputStream outstream;
 StreamPrintService psPrinter;
 String psMimeType = "application/postscript";

 StreamPrintServiceFactory[] factories =
     PrinterJob.lookupStreamPrintServices(psMimeType);
 if (factories.length > 0) {
     try {
         outstream = new File("out.ps");
         psPrinter =  factories[0].getPrintService(fos);
         // psPrinter can now be set as the service on a PrinterJob
     } catch (FileNotFoundException e) {
     }
 }
在支持打印服务的 PrinterJob 实例上可以安装从此方法返回的服务。调用此方法等效于调用 StreamPrintServiceFactory.lookupStreamPrintServiceFactories() 并指定一个 Pageable DocFlavor。

参数：
mimeType - 需要的输出格式；或 null，指任何格式。
返回：
2D 流打印服务工厂的数组，可能为空。
从以下版本开始：
1.4

getPrintService

public PrintService getPrintService()
返回此打印机作业的服务（打印机）。不支持打印服务的此类的实现可能返回 null。如果没有打印机可用，也将返回 null。

返回：
此打印机作业的服务。
从以下版本开始：
1.4
另请参见：
setPrintService(PrintService), getPrinterJob()

setPrintService

public void setPrintService(PrintService service)
                     throws PrinterException
将此 PrinterJob 与新的 PrintService 关联。支持指定 Print Service 的子类重写此方法。 如果指定的服务不能支持执行 2D 打印所需的 Pageable 和 Printable 接口，则抛出 PrinterException。

参数：
service - 支持 2D 打印的打印服务
抛出：
PrinterException - 如果指定的服务不支持 2D 打印；此 PrinterJob 类不支持设置 2D 打印服务；指定的服务不是有效的打印服务。
从以下版本开始：
1.4
另请参见：
getPrintService()

setPrintable

public abstract void setPrintable(Printable painter)
调用 painter 以呈现页面。Printable 对象 painter 可以呈现此 PrinterJob 打印的文档中的页面。每页的 PageFormat 是默认的页面格式。

参数：
painter - 呈现文档每个页面的 Printable。

setPrintable

public abstract void setPrintable(Printable painter,
                                  PageFormat format)
调用 painter，用指定的 format 呈现该页面。Printable 对象 painter 可以呈现此 PrinterJob 打印的文档中的页面。每个页面的 PageFormat 为 format。

参数：
painter - 呈现文档的每个页面所调用的 Printable
format - 要打印的每个页面的大小和方向

setPageable

public abstract void setPageable(Pageable document)
                          throws NullPointerException
查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。

参数：
document - 要打印的页面。它不能为 null。
抛出：
NullPointerException - 传入的 Pageable 为 null。
另请参见：
PageFormat, Printable

printDialog

public abstract boolean printDialog()
                             throws HeadlessException
向用户呈现一个对话框，用来更改打印作业的属性。如果选择本机打印服务，则此方法将显示本机对话框，并且用户选择的打印机将限于这些本机打印服务。若要为所有服务（包括本机服务）呈现跨平台打印对话框，请使用 printDialog(PrintRequestAttributeSet)。

可以使用 PrintService 实现的 PrinterJob 实现将更新 PrintService，以便此 PrinterJob 反映用户选择的新服务。

返回：
如果用户不取消该对话框，则返回 true；否则返回 false。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

printDialog

public boolean printDialog(PrintRequestAttributeSet attributes)
                    throws HeadlessException
为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。在最初显示对话框时，选择的打印机将反映当前连接到此打印作业的打印服务。如果用户更改了打印服务，则 PrinterJob 将被更新以反映此更改，除非该用户取消该对话框。除了允许用户选择目标打印机外，用户还可以选择各种打印请求属性的值。

输入的 attributes 参数将反映用户对话框中最初选择所需的应用程序。未指定 attributes 时使用服务的默认应用程序显示。返回时，它将反映用户的选择。实现可能更新选择，以与当前选择的打印服务支持的值一致。

当用户滚动到新的打印服务选择时，复制的值将基于以前服务的设置，以及任何用户更改。这些值不基于客户端提供的初始设置。

除了选择的打印机外，不会为反映该用户的更改而更新 PrinterJob 的状态。对于影响打印机作业的选择，在对 print(PrintRequestAttributeSet) 方法的调用中必须指定 attributes。如果使用 Pageable 接口，打算使用用户选择媒体的客户端必须创建继承自用户选择的 PageFormat。如果用户取消对话框，则 attributes 将不会反映用户进行的任何更改。

参数：
attributes - 输入时，该参数是为应用程序提供的属性；输出时，内容将更新以反映用户的选择。此参数不可以为 null。
返回：
如果用户不取消该对话框，则返回 true；否则返回 false。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
NullPointerException - 如果 attributes 参数为 null。
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()

pageDialog

public abstract PageFormat pageDialog(PageFormat page)
                               throws HeadlessException
显示允许修改 PageFormat 实例的对话框。page 参数用于在页面设置对话框中初始化控件。如果用户取消对话框，则此方法将返回未修改的初始 page 对象。如果用户确认对话框，那么此方法将返回具有指示更改的新 PageFormat 对象。无论是哪种情况，都不会修改初始 page 对象。

参数：
page - 提供给用户用来修改的默认 PageFormat。
返回：
如果取消对话框，则返回初始 page 对象；如果承认对话框，则返回包含用户指示格式的新 PageFormat 对象。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
1.2
另请参见：
GraphicsEnvironment.isHeadless()

pageDialog

public PageFormat pageDialog(PrintRequestAttributeSet attributes)
                      throws HeadlessException
显示跨平台页面设置对话框的便捷方法。可用的选择将反映当前在此 PrinterJob 上设置的打印服务。

输入的 attributes 参数将反映用户对话框中最初选择所需的客户端。未指定 attributes 时使用该服务的默认应用程序显示。返回时，它将反映用户的选择。可以更新选择，以与当前选择的打印服务支持的值一致。

返回值为 PageFormat，它等于 PrintRequestAttributeSet 中选择的值。如果用户取消对话框，则 attributes 将不会反映用户进行的任何更改，并且返回值将为 null。

参数：
attributes - 对于输入，该参数是为用户提供的属性；对于输出，内容将更新以反映用户的选择。此参数不可以为 null。
返回：
如果用户不取消该对话框，则返回页面格式；否则返回 null。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
NullPointerException - 如果 attributes 参数为 null。
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()

defaultPage

public abstract PageFormat defaultPage(PageFormat page)
复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。

参数：
page - 要复制和更改的 PageFormat
返回：
page 的副本，已为描述默认的 PageFormat 而更改。

defaultPage

public PageFormat defaultPage()
创建新的 PageFormat 实例，并将它设置为默认大小和方向。

返回：
要设置为默认大小和方向的 PageFormat。

getPageFormat

public PageFormat getPageFormat(PrintRequestAttributeSet attributes)
使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。

调用此方法不会更新作业。对于拥有一组从 printDialog(PrintRequestAttributeSet attributes) 中获得的属性并需要 PageFormat 来打印 Pageable 对象的客户机而言，这很有用。

参数：
attributes - 一组打印属性，例如通过调用 printDialog 获得的属性。如果 attributes 为 null，则返回默认 PageFormat。
返回：
设置符合当前服务和指定属性要求的 PageFormat。
从以下版本开始：
1.6

validatePage

public abstract PageFormat validatePage(PageFormat page)
返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。例如，返回的 PageFormat 所具有的可成像区域应该调整到适合当前打印机使用的纸张的物理区域。

参数：
page - 复制的 PageFormat，其设置被更改为与当前打印机兼容
返回：
从 page 复制的 PageFormat，其设置被更改为符合此 PrinterJob。

print

public abstract void print()
                    throws PrinterException
打印一组页面。

抛出：
PrinterException - 打印系统中出现导致作业中断的错误。
另请参见：
Book, Pageable, Printable

print

public void print(PrintRequestAttributeSet attributes)
           throws PrinterException
使用属性集中的设置打印一组页面。默认实现忽略属性集。

注意，通过调用等效的方法（例如，副本：setcopies(int)、作业名称：setJobName(String)）和指定媒体大小和方向（通过 PageFormat 对象）可以直接在 PrinterJob 上设置某些属性。

如果在此属性集中指定了支持的属性值，则该属性值仅对此 print() 操作优先于 API 设置。对于 PageFormat，指定以下行为：如果客户端使用 Printable 接口，则检查此方法的 attributes 参数，以了解指定媒体（按大小）、方向和可成像区域的属性以及用于构建新 PageFormat（传递到 Printable 对象的 print() 方法）的属性。有关 Printable 为确保通过 PrinterJob 进行最佳打印所需行为的解释，请参阅 Printable。对于 Pageable 接口的客户端，每个页面上的 PageFormat 将始终由该接口提供。

这些行为允许应用程序直接将从 printDialog(PrintRequestAttributeSet attributes) 返回的用户设置传递到此 print() 方法。

参数：
attributes - 作业的属性集
抛出：
PrinterException - 打印系统中出现导致作业中断的错误。
从以下版本开始：
1.4
另请参见：
Book, Pageable, Printable

setCopies

public abstract void setCopies(int copies)
设置要打印的副本数。

参数：
copies - 要打印的副本数
另请参见：
getCopies()

getCopies

public abstract int getCopies()
获取要打印的副本数。

返回：
要打印的副本数。
另请参见：
setCopies(int)

getUserName

public abstract String getUserName()
获取打印用户的名称。

返回：
打印用户的名称

setJobName

public abstract void setJobName(String jobName)
设置要打印的文档名称。文档名称不能为 null。

参数：
jobName - 要打印的文档名称
另请参见：
getJobName()

getJobName

public abstract String getJobName()
获取要打印的文档名称。

返回：
要打印的文档名称。
另请参见：
setJobName(java.lang.String)

cancel

public abstract void cancel()
取消正在进行的打印作业。如果调用了 print，但未返回，那么此方法会发送下一次应取消该作业的信号。如果没有正在进行的打印作业，则此调用不执行任何操作。

isCancelled

public abstract boolean isCancelled()
如果打印作业正在进行中，而下一次打印作业将被取消，则返回 true；否则返回 false。

返回：
如果进行中的作业将被取消，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.awt.print (Java 2 Platform SE 6)

 java.awt.print
接口
Pageable
Printable
PrinterGraphics
类
Book
PageFormat
Paper
PrinterJob
异常
PrinterAbortException
PrinterException
PrinterIOException


java.awt.print (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.awt.print

为通用的打印 API 提供类和接口。

请参见：
描述

接口摘要
Pageable | Pageable 实现表示要打印的页面集合。
Printable | Printable 接口由当前页面 painter 的 print 方法实现，该方法由打印系统调用，以呈现页面。
PrinterGraphics | PrinterGraphics 接口由被传递到 Printable 对象以呈现页面的 Graphics 对象实现。

类摘要
Book | Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。
PageFormat | PageFormat 类描述要打印的页面大小和方向。
Paper | Paper 类描述一张纸的物理特征。
PrinterJob | PrinterJob 类是控制打印的主要类。

异常摘要
PrinterAbortException | PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
PrinterException | PrinterException 类及其子类用于指示打印系统中发生的异常情况。
PrinterIOException | PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

软件包 java.awt.print 的描述

为通用的打印 API 提供类和接口。该 API 包括以下功能：

  • 指定文档类型的功能
  • 控制页面设置和页面格式的机制
  • 管理作业控制对话的功能

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.awt.print 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.print 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.awt.print.Book (implements java.awt.print.Pageable)
    • java.awt.print.PageFormat (implements java.lang.Cloneable)
    • java.awt.print.Paper (implements java.lang.Cloneable)
    • java.awt.print.PrinterJob
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.awt.print.PrinterException
          • java.awt.print.PrinterAbortException
          • java.awt.print.PrinterIOException

接口分层结构

  • java.awt.print.Pageable
  • java.awt.print.Printable
  • java.awt.print.PrinterGraphics
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.awt.print 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.awt.print
的使用

使用 java.awt.print 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 使用的 java.awt.print 中的类
Pageable
Pageable 实现表示要打印的页面集合。
PageFormat
PageFormat 类描述要打印的页面大小和方向。
Paper
Paper 类描述一张纸的物理特征。
Printable
Printable 接口由当前页面 painter 的 print 方法实现，该方法由打印系统调用，以呈现页面。
PrinterException
PrinterException 类及其子类用于指示打印系统中发生的异常情况。
PrinterJob
PrinterJob 类是控制打印的主要类。

javax.swing 使用的 java.awt.print 中的类
Printable
Printable 接口由当前页面 painter 的 print 方法实现，该方法由打印系统调用，以呈现页面。
PrinterException
PrinterException 类及其子类用于指示打印系统中发生的异常情况。

javax.swing.text 使用的 java.awt.print 中的类
Printable
Printable 接口由当前页面 painter 的 print 方法实现，该方法由打印系统调用，以呈现页面。
PrinterException
PrinterException 类及其子类用于指示打印系统中发生的异常情况。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.print.Book 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.Book
的使用

没有 java.awt.print.Book 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.print.PageFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PageFormat
的使用

使用 PageFormat 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 PageFormat 的使用

返回 PageFormat 的 java.awt.print 中的方法
 PageFormat PrinterJob.defaultPage()
创建新的 PageFormat 实例，并将它设置为默认大小和方向。
abstract  PageFormat PrinterJob.defaultPage(PageFormat page)
复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。
 PageFormat Book.getPageFormat(int pageIndex)
返回 pageIndex 指定的页面的 PageFormat。
 PageFormat Pageable.getPageFormat(int pageIndex)
返回 pageIndex 指定的页面的 PageFormat。
 PageFormat PrinterJob.getPageFormat(PrintRequestAttributeSet attributes)
使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。
abstract  PageFormat PrinterJob.pageDialog(PageFormat page)
显示允许修改 PageFormat 实例的对话框。
 PageFormat PrinterJob.pageDialog(PrintRequestAttributeSet attributes)
显示跨平台页面设置对话框的便捷方法。
abstract  PageFormat PrinterJob.validatePage(PageFormat page)
返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。

参数类型为 PageFormat 的 java.awt.print 中的方法
void | Book.append(Printable painter, PageFormat page) 将单个页面追加到此 Book 的尾部。
void | Book.append(Printable painter, PageFormat page, int numPages) 将 numPages 个页面追加到此 Book 的尾部。
abstract PageFormat | PrinterJob.defaultPage(PageFormat page) 复制 PageFormat 参数，并更改该副本，以描述默认页面的大小和方向。
abstract PageFormat | PrinterJob.pageDialog(PageFormat page) 显示允许修改 PageFormat 实例的对话框。
int | Printable.print(Graphics graphics, PageFormat pageFormat, int pageIndex) 将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。
void | Book.setPage(int pageIndex, Printable painter, PageFormat page) 为指定的页码设置 PageFormat 和 Painter。
abstract void | PrinterJob.setPrintable(Printable painter, PageFormat format) 调用 painter，用指定的 format 呈现该页面。
abstract PageFormat | PrinterJob.validatePage(PageFormat page) 返回 page 的副本，调整其设置，以与此 PrinterJob 的当前打印机兼容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.print.Pageable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.print.Pageable
的使用

使用 Pageable 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 Pageable 的使用

实现 Pageable 的 java.awt.print 中的类
 class Book
Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。

参数类型为 Pageable 的 java.awt.print 中的方法
abstract  void PrinterJob.setPageable(Pageable document)
查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.print.Paper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.Paper
的使用

使用 Paper 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 Paper 的使用

返回 Paper 的 java.awt.print 中的方法
 Paper PageFormat.getPaper()
返回与此 PageFormat 相关的 Paper 对象的一个副本。

参数类型为 Paper 的 java.awt.print 中的方法
 void PageFormat.setPaper(Paper paper)
为此 PageFormat 设置 Paper 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.print.PrinterAbortException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterAbortException
的使用

没有 java.awt.print.PrinterAbortException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.print.PrinterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterException
的使用

使用 PrinterException 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 PrinterException 的使用

java.awt.print 中 PrinterException 的子类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

抛出 PrinterException 的 java.awt.print 中的方法
abstract void | PrinterJob.print() 打印一组页面。
int | Printable.print(Graphics graphics, PageFormat pageFormat, int pageIndex) 将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。
void | PrinterJob.print(PrintRequestAttributeSet attributes) 使用属性集中的设置打印一组页面。
void | PrinterJob.setPrintService(PrintService service) 将此 PrinterJob 与新的 PrintService 关联。

javax.swing 中 PrinterException 的使用

抛出 PrinterException 的 javax.swing 中的方法
boolean | JTable.print() 一个便捷的方法，它显示一个打印对话框，然后以 PrintMode.FIT_WIDTH 模式打印此 JTable，不打印标题或脚注文本。
boolean | JTable.print(JTable.PrintMode printMode) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

javax.swing.text 中 PrinterException 的使用

抛出 PrinterException 的 javax.swing.text 中的方法
boolean | JTextComponent.print() 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，不打印标题和脚注文本。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive) 打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.print.PrinterIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterIOException
的使用

没有 java.awt.print.PrinterIOException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.print.Printable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.print.Printable
的使用

使用 Printable 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 Printable 的使用

返回 Printable 的 java.awt.print 中的方法
Printable | Book.getPrintable(int pageIndex) 返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。
Printable | Pageable.getPrintable(int pageIndex) 返回负责呈现 pageIndex 指定的页面的 Printable 实例。

参数类型为 Printable 的 java.awt.print 中的方法
void | Book.append(Printable painter, PageFormat page) 将单个页面追加到此 Book 的尾部。
void | Book.append(Printable painter, PageFormat page, int numPages) 将 numPages 个页面追加到此 Book 的尾部。
void | Book.setPage(int pageIndex, Printable painter, PageFormat page) 为指定的页码设置 PageFormat 和 Painter。
abstract void | PrinterJob.setPrintable(Printable painter) 调用 painter 以呈现页面。
abstract void | PrinterJob.setPrintable(Printable painter, PageFormat format) 调用 painter，用指定的 format 呈现该页面。

javax.swing 中 Printable 的使用

返回 Printable 的 javax.swing 中的方法
 Printable JTable.getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat)
返回打印此 JTable 中所使用的 Printable。

javax.swing.text 中 Printable 的使用

返回 Printable 的 javax.swing.text 中的方法
 Printable JTextComponent.getPrintable(MessageFormat headerFormat, MessageFormat footerFormat)
返回一个 Printable，用于打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.print.PrinterGraphics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.print.PrinterGraphics
的使用

没有 java.awt.print.PrinterGraphics 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.print.PrinterJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.print.PrinterJob
的使用

使用 PrinterJob 的软件包
java.awt.print 为通用的打印 API 提供类和接口。

java.awt.print 中 PrinterJob 的使用

返回 PrinterJob 的 java.awt.print 中的方法
PrinterJob | PrinterGraphics.getPrinterJob() 返回正在控制当前呈现请求的 PrinterJob。
static PrinterJob | PrinterJob.getPrinterJob() 创建并返回初始化时与默认打印机关联的 PrinterJob。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AWT Threading Issues

Listeners and threads

Unless otherwise noted all AWT listeners are notified on the event dispatch thread. It is safe to remove/add listeners from any thread during dispatching, but the changes only effect subsequent notification.
For example, if a key listeners is added from another key listener, the newly added listener is only notified on subsequent key events.

Auto-shutdown

According to The JavaTM Virtual Machine Specification, Second edition (see �2.17.9 and �2.19), the Java virtual machine (JVM) initially starts up with a single non-daemon thread, which typically calls the main method of some class. The virtual machine terminates all its activity and exits when one of two things happens:
  • All the threads that are not daemon threads terminate.
  • Some thread invokes the exit method of class Runtime or class System, and the exit operation is permitted by the security manager.

This implies that if an application doesn't start any threads itself, the JVM will exit as soon as main terminates. This is not the case, however, for a simple application that creates and displays a java.awt.Frame:

        public static void main(String[] args) {
            Frame frame = new Frame();
            frame.setVisible(true);
         }
The reason is that AWT encapsulates asynchronous event dispatch machinery to process events AWT or Swing components can fire. The exact behavior of this machinery is implementation-dependent. In particular, it can start non-daemon helper threads for its internal purposes. In fact, these are the threads that prevent the example above from exiting. The only restrictions imposed on the behavior of this machinery are as follows:
  • EventQueue.isDispatchThread returns true if and only if the calling thread is the event dispatch thread started by the machinery;
  • AWTEvents which were actually enqueued to a particular EventQueue (note that events being posted to the EventQueue can be coalesced) are dispatched:
    • Sequentially.
      That is, it is not permitted that several events from this queue are dispatched simultaneously.
    • In the same order as they are enqueued.
      That is, if AWTEvent A is enqueued to the EventQueue before AWTEvent B then event B will not be dispatched before event A.
  • There is at least one alive non-daemon thread while there is at least one displayable AWT or Swing component within the application (see Component.isDisplayable).
The implications of the third restriction are as follows:
  • The JVM will exit if some thread invokes the exit method of class Runtime or class System regardless of the presence of displayable components;
  • Even if the application terminates all non-daemon threads it started, the JVM will not exit while there is at least one displayable component.
It depends on the implementation if and when the non-daemon helper threads are terminated once all components are made undisplayable. The implementation-specific details are given below.

Implementation-dependent behavior.

Prior to 1.4, the helper threads were never terminated.

Starting with 1.4, the behavior has changed as a result of the fix for 4030718. With the current implementation, AWT terminates all its helper threads allowing the application to exit cleanly when the following three conditions are true:

  • There are no displayable AWT or Swing components.
  • There are no native events in the native event queue.
  • There are no AWT events in java EventQueues.
Therefore, a stand-alone AWT application that wishes to exit cleanly without calling System.exit must:
  • Make sure that all AWT or Swing components are made undisplayable when the application finishes. This can be done by calling Window.dispose on all top-level Windows. See Frame.getFrames.
  • Make sure that no method of AWT event listeners registered by the application with any AWT or Swing component can run into an infinite loop or hang indefinitely. For example, an AWT listener method triggered by some AWT event can post a new AWT event of the same type to the EventQueue. The argument is that methods of AWT event listeners are typically executed on helper threads.
Note, that while an application following these recommendations will exit cleanly under normal conditions, it is not guaranteed that it will exit cleanly in all cases. Two examples:
  • Other packages can create displayable components for internal needs and never make them undisplayable. See 4515058, 4671025, and 4465537.
  • Both Microsoft Windows and X11 allow an application to send native events to windows that belong to another application. With this feature it is possible to write a malicious program that will continuously send events to all available windows preventing any AWT application from exiting cleanly.
On the other hand, if you require the JVM to continue running even after the application has made all components undisplayable you should start a non-daemon thread that blocks forever.
        <...>
        Runnable r = new Runnable() {
            public void run() {
                Object o = new Object();
                try {
                    synchronized (o) {
                        o.wait();
                    }
                } catch (InterruptedException ie) {
                }
            }
        };
        Thread t = new Thread(r);
        t.setDaemon(false);
        t.start();
        <...>
The Java Virtual Machine Specification guarantees that the JVM doesn't exit until this thread terminates.


AWT Desktop Properties

The following refers to standard AWT desktop properties that may be obtained via the Toolkit.getDesktopProperty method.

Each desktop property is named by a unique string, which is the "name" of that property.

Desktop properties supported by the AWT but not documented elsewhere - typically because there is no suitable method or class - are documented here.

Desktop properties documented elsewhere are those which are tightly coupled with a method or class which documents them.

Since desktop properties abstract an underlying platform setting, they may not be available in environments that do not support them. In the event that a desktop property is unavailable for any reason, the implementation will return null.

The following table summarizes the desktop properties documented here, and their value types.

Property Name | Value Type | Summary Description
awt.font.desktophints | java.util.Map | Font smoothing (text antialiasing) settings.

Desktop Font Rendering Hints

Desktop Property: "awt.font.desktophints"

Modern desktops support various forms of text antialiasing (font smoothing).

These are applied by platform-specific heavyweight components. However an application may want to render text using the same text antialiasing on a drawing surface or lightweight (non-platform) component using Graphics2D methods. This is particularly important when creating Swing components which are required to appear consistent with native desktop components or other Swing components.

Basic Usage

The standard desktop property named "awt.font.desktophints" can be used to obtain the rendering hints that best match the desktop settings. The return value is a Map of RenderingHints which can be directly applied to a Graphics2D.

It is a Map as more than one hint may be needed. If non-null this can be directly applied to the Graphics2D.

Toolkit tk = Toolkit.getDefaultToolkit();
Map map = (Map)(tk.getDesktopProperty("awt.font.desktophints"));
if (map != null) {
    graphics2D.addRenderingHints(map);
}

Advanced Usage Tips

Listening for changes

An application can listen for changes in the property using a PropertyChangeListener :

tk.addPropertyChangeListener("awt.font.desktophints", pcl);
Listening for changes is recommended as users can, on rare occasions, reconfigure a desktop environment whilst applications are running in a way that may affect the selection of these hints, and furthermore many desktop environments support dynamic reconfiguration of these running applications to conform to the new settings.

There is no direct way to discover if dynamic reconfiguration is expected of running applications but the default assumption should be that it is expected, since most modern desktop environments do provide this capability.

Text Measurement

Text always needs to be measured using the same FontRenderContext as used for rendering. The text anti-aliasing hint is a component of the FontRenderContext. A FontMetrics obtained from the Graphics object on which the hint has been set will measure text appropriately. This is not a unique requirement for clients that specify this hint directly, since the value of the FontRenderContext should never be assumed, so is discussed here principally as a reminder.

Saving and restoring Graphics State

Sometimes an application may need to apply these hints on a shared Graphics only temporarily, restoring the previous values after they have been applied to text rendering operations. The following sample code shows one way to do this.

/**
  * Get rendering hints from a Graphics instance.
  * "hintsToSave" is a Map of RenderingHint key-values.
  * For each hint key present in that map, the value of that
  * hint is obtained from the Graphics and stored as the value
  * for the key in savedHints.
  */
RenderingHints getRenderingHints(Graphics2D g2d,
                                  RenderingHints hintsToSave,
                                  RenderingHints savedHints) {
     if (savedHints == null) {
         savedHints = new RenderingHints(null);
     } else {
         savedHints.clear();
     }
     if (hintsToSave.size() == 0) {
         return savedHints;
     }
     /* RenderingHints.keySet() returns Set  */
     for (Object o : hintsToSave.keySet()) {
         RenderingHints.Key key = (RenderingHints.Key)o;
         Object value = g2d.getRenderingHint(key);
         savedHints.put(key, value);
     }
     return savedHints;
}

Toolkit tk = Toolkit.getDefaultToolkit();
Map map = (Map)(tk.getDesktopProperty("awt.font.desktophints"));
Map oldHints;
if (map != null) {
     oldHints = getRenderingHints(graphic2D, map, null);
     graphics2D.addRenderingHints(map);
     ..
     graphics2D.addRenderingHints(oldHints);
}

Details

  • The return value will always be null or a Map

  • If the return value is null, then no desktop properties are available,
and dynamic updates will not be available. This is a typical behaviour if
the JDK does not recognise the desktop environment, or it is one which
has no such settings. The Headless toolkit is one such example.
Therefore it is important to test against null before using the map.

  • If non-null the value will be a Map of
RenderingHints such that every key is an instance of
RenderingHints.Key and the value is a legal value for that key.

  • The map may contain the default value for a hint. This is
needed in the event there is a previously a non-default value for the hint
set on the Graphics2D. If the map did not contain
the default value, then addRenderingHints(Map) would leave
the previous hint which may not correspond to the desktop setting.

An application can use setRenderingHints(Map) to reinitialise
all hints, but this would affect unrelated hints too.

  • A multi-screen desktop may support per-screen device settings in which
case the returned value is for the default screen of the desktop.
An application may want to use the settings for the screen on
which they will be applied.
The per-screen device hints may be obtained by per-device property names
which are constructed as the String concatenation

"awt.font.desktophints" + "." + GraphicsDevice.getIDstring();

An application can also listen for changes on these properties.

However this is an extremely unlikely configuration, so to help
ease of development, if only a single, desktop-wide setting is supported,
then querying each of these per-device settings will return null.
So to determine if there are per-device settings it is sufficient to
determine that there is a non-null return for any screen device using
the per-device property name.


The AWT Focus Subsystem

Prior to Java 2 Standard Edition, JDK 1.4, the AWT focus subsystem was inadequate. It suffered from major design and API problems, as well as over a hundred open bugs. Many of these bugs were caused by platform inconsistencies, or incompatibilities between the native focus system for heavyweights and the Java focus system for lightweights.

The single worst problem with the AWT focus implementation was the inability to query for the currently focused Component. Not only was there no API for such a query, but also, because of an insufficient architecture, such information was not even maintained by the code.

Almost as bad was the inability of lightweight children of a Window (not a Frame or a Dialog) to receive keyboard input. This problem existed because Windows never received WINDOW_ACTIVATED events and thus could never be activated, and only active Windows could contain focused Components.

In addition, many developers noted that the APIs for FocusEvent and WindowEvent were insufficient because they did not provide a way for determining the "opposite" Component involved in the focus or activation change. For example, when a Component received a FOCUS_LOST event, it had no way of knowing which Component was gaining focus. Since Microsoft Windows provides this functionality for free, developers migrating from Microsoft Windows C/C++ or Visual Basic to Java had been frustrated by the omission.

To address these and other deficiencies, we have designed a new focus model for the AWT in JDK 1.4. The primary design changes were the construction of a new centralized KeyboardFocusManager class, and a lightweight focus architecture. The amount of focus-related, platform-dependent code has been minimized and replaced by fully pluggable and extensible public APIs in the AWT. While we have attempted to remain backward compatible with the existing implementation, we were forced to make minor incompatible changes in order to reach an elegant and workable conclusion. We anticipate that these incompatibilities will have only a trivial impact on existing applications.

This document is a formal specification both of the new APIs and of existing APIs which remain relevant in the new model. Combined with the javadoc for focus-related classes and methods, this document should enable developers to create substantial AWT and Swing applications with a focus behavior that is customized yet consistent across platforms. This document has the following sections:

  • Overview of KeyboardFocusManager
  • KeyboardFocusManager and Browser Contexts
  • KeyEventDispatcher
  • FocusEvent and WindowEvent
  • Event Delivery
  • Opposite Components and Windows
  • Temporary FocusEvents
  • Focus Traversal
  • Focus Traversal Policy
  • Focus Traversal Policy Providers
  • Programmatic Traversal
  • Focusability
  • Focusable Windows
  • Requesting Focus
  • Focus and PropertyChangeListener
  • Focus and VetoableChangeListener
  • Z-Order
  • Replacing DefaultKeyboardFocusManager
  • Incompatibilities with Previous Releases

Overview of KeyboardFocusManager

The focus model is centralized around a single class, KeyboardFocusManager, that provides a set of APIs for client code to inquire about the current focus state, initiate focus changes, and replace default focus event dispatching with a custom dispatcher. Clients can inquire about the focus state directly, or can register a PropertyChangeListener that will receive PropertyChangeEvents when a change to the focus state occurs.

KeyboardFocusManager introduces seven main concepts and their terminology:

  1. The "focus owner" -- the Component which typically receives keyboard input.
  2. The "permanent focus owner" -- the last Component to receive focus permanently. The "focus owner" and the "permanent focus owner" are equivalent unless a temporary focus change is currently in effect. In such a situation, the "permanent focus owner" will again be the "focus owner" when the temporary focus change ends.
  3. The "focused Window" -- the Window which contains the "focus owner".
  4. The "active Window" -- the Frame or Dialog that is either the "focused Window", or the first Frame or Dialog that is an owner of the "focused Window".
  5. "Focus traversal" -- the user's ability to change the "focus owner" without moving the cursor. Typically, this is done using the keyboard (for example, by using the TAB key), or an equivalent device in an accessible environment. Client code can also initiate traversal programmatically. Normal focus traversal can be either "forward" to the "next" Component, or "backward" to the "previous" Component.
  6. "Focus traversal cycle" -- a portion of the Component hierarchy, such that normal focus traversal "forward" (or "backward") will traverse through all of the Components in the focus cycle, but no other Components. This cycle provides a mapping from an arbitrary Component in the cycle to its "next" (forward traversal) and "previous" (backward traversal) Components.
  7. "Focus cycle root" -- Container that is the root of the Component hierarchy for a particular "focus traversal cycle". When the "focus owner" is a Component inside a particular cycle, normal forward and backward focus traversal cannot move the "focus owner" above the focus cycle root in the Component hierarchy. Instead, two additional traversal operations, "up cycle" and "down cycle", are defined to allow keyboard and programmatic navigation up and down the focus traversal cycle hierarchy.
  8. "Focus traversal policy provider" - Container which has "FocusTraversalPolicyProvider" property as true. This Container will be used to acquire focus traversal policy. This container doesn't define new focus cycle but only modifies the order by which its children are traversed "forward" and "backward". Focus traversal policy provider can be set using setFocusTraversalPolicyProvider on the Container.

Every Window and JInternalFrame is, by default, a "focus cycle root". If it's the only focus cycle root, then all of its focusable descendants should be in its focus cycle, and its focus traversal policy should enforce that they are by making sure that all will be reached during normal forward (or backward) traversal. If, on the other hand, the Window or JInternalFrame has descendants that are also focus cycle roots, then each such descendant is a member of two focus cycles: the one that it is the root of, and the one of its nearest focus-cycle-root ancestor. In order to traverse the focusable components belonging to the focus cycle of such a "descendant" focus cycle root, one first traverses (forward or backward) to reach the descendant, and then uses the "down cycle" operation to reach, in turn, its descendants.

Here is an example:
Three groups as described below: ABCF BDE and DGH.

Assume the following:

  • A is a Window, which means that it must be a focus cycle root.
  • B and D are Containers that are focus cycle roots.
  • C is a Container that is not a focus cycle root.
  • G, H, E, and F are all Components.
There are a total of three focus cycle roots in this example:
  1. A is a root, and A, B, C, and F are members of A's cycle.
  2. B is a root, and B, D, and E are members of B's cycle.
  3. D is a root, and D, G, and H are members of D's cycle.
Windows are the only Containers which, by default, are focus cycle roots. KeyboardFocusManager is an abstract class. AWT provides a default implementation in the DefaultKeyboardFocusManager class.

KeyboardFocusManager and Browser Contexts

Some browsers partition applets in different code bases into separate contexts, and establish walls between these contexts. Each thread and each Component is associated with a particular context and cannot interfere with threads or access Components in other contexts. In such a scenario, there will be one KeyboardFocusManager per context. Other browsers place all applets into the same context, implying that there will be only a single, global KeyboardFocusManager for all applets. This behavior is implementation-dependent. Consult your browser's documentation for more information. No matter how many contexts there may be, however, there can never be more than one focus owner, focused Window, or active Window, per ClassLoader.

KeyEventDispatcher and KeyEventPostProcessor

While the user's KeyEvents should generally be delivered to the focus owner, there are rare cases where this is not desirable. An input method is an example of a specialized Component that should receive KeyEvents even though its associated text Component is and should remain the focus owner.

A KeyEventDispatcher is a lightweight interface that allows client code to pre-listen to all KeyEvents in a particular context. Instances of classes that implement the interface and are registered with the current KeyboardFocusManager will receive KeyEvents before they are dispatched to the focus owner, allowing the KeyEventDispatcher to retarget the event, consume it, dispatch it itself, or make other changes.

For consistency, KeyboardFocusManager itself is a KeyEventDispatcher. By default, the current KeyboardFocusManager will be the sink for all KeyEvents not dispatched by the registered KeyEventDispatchers. The current KeyboardFocusManager cannot be completely deregistered as a KeyEventDispatcher. However, if a KeyEventDispatcher reports that it dispatched the KeyEvent, regardless of whether it actually did so, the KeyboardFocusManager will take no further action with regard to the KeyEvent. (While it is possible for client code to register the current KeyboardFocusManager as a KeyEventDispatcher one or more times, there is no obvious reason why this would be necessary, and therefore it is not recommended.)

Client-code may also post-listen to KeyEvents in a particular context using the KeyEventPostProcessor interface. KeyEventPostProcessors registered with the current KeyboardFocusManager will receive KeyEvents after the KeyEvents have been dispatched to and handled by the focus owner. The KeyEventPostProcessors will also receive KeyEvents that would have been otherwise discarded because no Component in the application currently owns the focus. This will allow applications to implement features that require global KeyEvent post- handling, such as menu shortcuts.

Like KeyEventDispatcher, KeyboardFocusManager also implements KeyEventPostProcessor, and similar restrictions apply to its use in that capacity.

FocusEvent and WindowEvent

The AWT defines the following six event types central to the focus model in two different java.awt.event classes:

  1. WindowEvent.WINDOW_ACTIVATED: This event is dispatched to a Frame or Dialog (but never a Window which is not a Frame or Dialog) when it becomes the active Window.
  2. WindowEvent.WINDOW_GAINED_FOCUS: This event is dispatched to a Window when it becomes the focused Window. Only focusable Windows can receive this event.
  3. FocusEvent.FOCUS_GAINED: This event is dispatched to a Component when it becomes the focus owner. Only focusable Components can receive this event.
  4. FocusEvent.FOCUS_LOST: This event is dispatched to a Component when it is no longer the focus owner.
  5. WindowEvent.WINDOW_LOST_FOCUS: This event is dispatched to a Window when it is no longer the focused Window.
  6. WindowEvent.WINDOW_DEACTIVATED: This event is dispatched to a Frame or Dialog (but never a Window which is not a Frame or Dialog) when it is no longer the active Window.

Event Delivery

If the focus is not in java application and the user clicks on a focusable child Componenta of an inactive Frame b, the following events will be dispatched and handled in order:

  1. b will receive a WINDOW_ACTIVATED event.
  2. Next, b will receive a WINDOW_GAINED_FOCUS event.
  3. Finally, a will receive a FOCUS_GAINED event.
If the user later clicks on a focusable child Component c of another Frame d, the following events will be dispatched and handled in order:
  1. a will receive a FOCUS_LOST event.
  2. b will receive a WINDOW_LOST_FOCUS event.
  3. b will receive a WINDOW_DEACTIVATED event.
  4. d will receive a WINDOW_ACTIVATED event.
  5. d will receive a WINDOW_GAINED_FOCUS event.
  6. c will receive a FOCUS_GAINED event.
Note that each event will be fully handled before the next event is dispatched. This restriction will be enforced even if the Components are in different contexts and are handled on different event dispatching threads.

In addition, each event type will be dispatched in 1-to-1 correspondence with its opposite event type. For example, if a Component receives a FOCUS_GAINED event, under no circumstances can it ever receive another FOCUS_GAINED event without an intervening FOCUS_LOST event.

Finally, it is important to note that these events are delivered for informational purposes only. It is impossible, for example, to prevent the delivery of a pending FOCUS_GAINED event by requesting focus back to the Component losing focus while handling the preceding FOCUS_LOST event. While client code may make such a request, the pending FOCUS_GAINED will still be delivered, followed later by the events transferring focus back to the original focus owner.

If it is absolutely necessary to suppress the FOCUS_GAINED event, client code can install a VetoableChangeListener which rejects the focus change. See Focus and VetoableChangeListener.

Opposite Components and Windows

Each event includes information about the "opposite" Component or Window involved in the focus or activation change. For example, for a FOCUS_GAINED event, the opposite Component is the Component that lost focus. If the focus or activation change occurs with a native application, with a Java application in a different VM or context, or with no other Component, then the opposite Component or Window is null. This information is accessible using FocusEvent.getOppositeComponent or WindowEvent.getOppositeWindow.

On some platforms, it is not possible to discern the opposite Component or Window when the focus or activation change occurs between two different heavyweight Components. In these cases, the opposite Component or Window may be set to null on some platforms, and to a valid non-null value on other platforms. However, for a focus change between two lightweight Components which share the same heavyweight Container, the opposite Component will always be set correctly. Thus, a pure Swing application can ignore this platform restriction when using the opposite Component of a focus change that occurred within a top-level Window.

Temporary FocusEvents

FOCUS_GAINED and FOCUS_LOST events are marked as either temporary or permanent.

Temporary FOCUS_LOST events are sent when a Component is losing the focus, but will regain the focus shortly. These events can be useful when focus changes are used as triggers for validation of data. For instance, a text Component may want to commit its contents when the user begins interacting with another Component, and can accomplish this by responding to FOCUS_LOST events. However, if the FocusEvent received is temporary, the commit should not be done, since the text field will be receiving the focus again shortly.

A permanent focus transfer typically occurs as the result of a user clicking on a selectable, heavyweight Component, focus traversal with the keyboard or an equivalent input device, or from a call to requestFocus() or requestFocusInWindow().

A temporary focus transfer typically occurs as the result of showing a Menu or PopupMenu, clicking or dragging a Scrollbar, moving a Window by dragging the title bar, or making another Window the focused Window. Note that on some platforms, these actions may not generate any FocusEvents at all. On others, temporary focus transfers will occur.

When a Component receives a temporary FOCUS_LOST event, the event's opposite Component (if any) may receive a temporary FOCUS_GAINED event, but could also receive a permanent FOCUS_GAINED event. Showing a Menu or PopupMenu, or clicking or dragging a Scrollbar, should generate a temporary FOCUS_GAINED event. Changing the focused Window, however, will yield a permanent FOCUS_GAINED event for the new focus owner.

The Component class includes variants of requestFocus and requestFocusInWindow which take a desired temporary state as a parameter. However, because specifying an arbitrary temporary state may not be implementable on all native windowing systems, correct behavior for this method can be guaranteed only for lightweight Components. This method is not intended for general use, but exists instead as a hook for lightweight Component libraries, such as Swing.

Focus Traversal

Each Component defines its own Set of focus traversal keys for a given focus traversal operation. Components support separate Sets of keys for forward and backward traversal, and also for traversal up one focus traversal cycle. Containers which are focus cycle roots also support a Set of keys for traversal down one focus traversal cycle. If a Set is not explicitly defined for a Component, that Component recursively inherits a Set from its parent, and ultimately from a context-wide default set on the current KeyboardFocusManager.

Using the AWTKeyStroke API, client code can specify on which of two specific KeyEvents, KEY_PRESSED or KEY_RELEASED, the focus traversal operation will occur. Regardless of which KeyEvent is specified, however, all KeyEvents related to the focus traversal key, including the associated KEY_TYPED event, will be consumed, and will not be dispatched to any Component. It is a runtime error to specify a KEY_TYPED event as mapping to a focus traversal operation, or to map the same event to multiple focus traversal operations for any particular Component or for a KeyboardFocusManager's defaults.

The default focus traversal keys are implementation-dependent. Sun recommends that the all implementations for a particular native platform use the same keys. For Windows and Unix, the recommendations are:

  • traverse forward to the next Component:
    TextAreas: CTRL-TAB on KEY_PRESSED
    All others: TAB on KEY_PRESSED and CTRL-TAB on KEY_PRESSED
  • traverse backward to the previous Component:
    TextAreas: CTRL-SHIFT-TAB on KEY_PRESSED
    All others: SHIFT-TAB on KEY_PRESSED and CTRL-SHIFT-TAB on KEY_PRESSED
  • traverse up one focus traversal cycle : <none>
  • traverse down one focus traversal cycle : <none>

Components can enable and disable all of their focus traversal keys en masse using Component.setFocusTraversalKeysEnabled. When focus traversal keys are disabled, the Component receives all KeyEvents for those keys. When focus traversal keys are enabled, the Component never receives KeyEvents for traversal keys; instead, the KeyEvents are automatically mapped to focus traversal operations.

For normal forward and backward traversal, the AWT focus implementation determines which Component to focus next based on the FocusTraversalPolicy of the focus owner's focus cycle root or focus traversal policy provider. If the focus owner is a focus cycle root, then it may be ambiguous as to which Components represent the next and previous Components to focus during normal focus traversal. Thus, the current KeyboardFocusManager maintains a reference to the "current" focus cycle root, which is global across all contexts. The current focus cycle root is used to resolve the ambiguity.

For up-cycle traversal, the focus owner is set to the current focus owner's focus cycle root, and the current focus cycle root is set to the new focus owner's focus cycle root. If, however, the current focus owner's focus cycle root is a top-level window, then the focus owner is set to the focus cycle root's default component to focus, and the current focus cycle root is unchanged.

For down-cycle traversal, if the current focus owner is a focus cycle root, then the focus owner is set to the current focus owner's default component to focus, and the current focus cycle root is set to the current focus owner. If the current focus owner is not a focus cycle root, then no focus traversal operation occurs.

FocusTraversalPolicy

A FocusTraversalPolicy defines the order in which Components within a particular focus cycle root or focus traversal policy provider are traversed. Instances of FocusTraversalPolicy can be shared across Containers, allowing those Containers to implement the same traversal policy. FocusTraversalPolicies do not need to be reinitialized when the focus-traversal-cycle hierarchy changes.

Each FocusTraversalPolicy must define the following five algorithms:

  1. Given a focus cycle root and a Component a in that cycle, the next Component after a.
  2. Given a focus cycle root and a Component a in that cycle, the previous Component before a.
  3. Given a focus cycle root, the "first" Component in that cycle. The "first" Component is the Component to focus when traversal wraps in the forward direction.
  4. Given a focus cycle root, the "last" Component in that cycle. The "last" Component is the Component to focus when traversal wraps in the reverse direction.
  5. Given a focus cycle root, the "default" Component in that cycle. The "default" Component will be the first to receive focus when traversing down into a new focus traversal cycle. This may be the same as the "first" Component, but need not be.

A FocusTraversalPolicy may optionally provide an algorithm for the following:

Given a Window, the "initial" Component in that Window. The initial Component will be the first to receive focus when the Window is first made visible. By default, this is the same as the "default" Component.
In addition, Swing provides a subclass of FocusTraversalPolicy, InternalFrameFocusTraversalPolicy, which allows developers to provide an algorithm for the following:
Given a JInternalFrame, the "initial" Component in that JInternalFrame. The initial Component is the first to receive focus when the JInternalFrame is first selected. By default, this is the same as the JInternalFrame's default Component to focus.
A FocusTraversalPolicy is installed on a Container using Container.setFocusTraversalPolicy. If a policy is not explicitly set, then a Container inherits its policy from its nearest focus-cycle-root ancestor. Top-levels initialize their focus traversal policies using the context default policy. The context default policy is established by using KeyboardFocusManager. setDefaultFocusTraversalPolicy.

AWT provides two standard FocusTraversalPolicy implementations for use by client code.

  1. ContainerOrderFocusTraversalPolicy: Iterates across the Components in a focus traversal cycle in the order they were added to their Containers. Each Component is tested for fitness using the accept(Component) method. By default, a Component is fit only if it is visible, displayable, enabled, and focusable.
    By default, ContainerOrderFocusTraversalPolicy implicitly transfers focus down-cycle. That is, during normal forward focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This provides backward compatibility with applications designed without the concepts of up- and down-cycle traversal.
  2. DefaultFocusTraversalPolicy: A subclass of ContainerOrderFocusTraversalPolicy which redefines the fitness test. If client code has explicitly set the focusability of a Component by either overriding Component.isFocusTraversable() or Component.isFocusable(), or by calling Component.setFocusable(boolean), then a DefaultFocusTraversalPolicy behaves exactly like a ContainerOrderFocusTraversalPolicy. If, however, the Component is relying on default focusability, then a DefaultFocusTraversalPolicy will reject all Components with non-focusable peers.
    The focusability of a peer is implementation-dependent. Sun recommends that all implementations for a particular native platform construct peers with the same focusability. The recommendations for Windows and Unix are that Canvases, Labels, Panels, Scrollbars, ScrollPanes, Windows, and lightweight Components have non-focusable peers, and all other Components have focusable peers. These recommendations are used in the Sun AWT implementations. Note that the focusability of a Component's peer is different from, and does not impact, the focusability of the Component itself.

Swing provides two additional, standard FocusTraversalPolicy implementations for use by client code. Each implementation is an InternalFrameFocusTraversalPolicy.

  1. SortingFocusTraversalPolicy: Determines traversal order by sorting the Components of a focus traversal cycle based on a given Comparator. Each Component is tested for fitness using the accept(Component) method. By default, a Component is fit only if it is visible, displayable, enabled, and focusable.
  2. By default, SortingFocusTraversalPolicy implicitly transfers focus down-cycle. That is, during normal forward focus traversal, the Component traversed after a focus cycle root will be the focus-cycle-root's default Component to focus. This provides backward compatibility with applications designed without the concepts of up- and down-cycle traversal.
  3. LayoutFocusTraversalPolicy: A subclass of SortingFocusTraversalPolicy which sorts Components based on their size, position, and orientation. Based on their size and position, Components are roughly categorized into rows and columns. For a Container with horizontal orientation, columns run left-to-right or right-to-left, and rows run top-to-bottom. For a Container with vertical orientation, columns run top-to-bottom and rows run left-to-right or right-to-left. All columns in a row are fully traversed before proceeding to the next row.
    In addition, the fitness test is extended to exclude JComponents that have or inherit empty InputMaps.

Swing applications, or mixed Swing/AWT applications, that use one of the standard look and feels, or any other look and feel derived from BasicLookAndFeel, will use LayoutFocusTraversalPolicy for all Containers by default.

All other applications, including pure AWT applications, will use DefaultFocusTraversalPolicy by default.

Focus Traversal Policy Providers

A Container that isn't a focus cycle root has an option to provide a FocusTraversalPolicy of its own. To do so, one needs to set Container's focus traversal policy provider property to true with the call to

    Container.setFocusTraversalPolicyProvider(boolean)
To determine whether a Container is a focus traversal policy provider, the following method should be used:
    Container.isFocusTraversalPolicyProvider()
If focus traversal policy provider property is set on a focus cycle root, it isn't considered a focus traversal policy provider and behaves just like any other focus cycle root.

The main difference between focus cycle roots and focus traversal policy providers is that the latter allow focus to enter and leave them just as all other Containers. However, children inside focus traversal policy provider are traversed in the order determined by provider's FocusTraversalPolicy. In order to enable focus traversal policy providers to behave this way, FocusTraversalPolicies treat them in the following manner:

  • Focus traversal policy providers can be passed to FocusTraversalPolicy methods instead of focus cycle roots.
  • When calculating next or previous Component in FocusTraversalPolicy.getComponentAfter or FocusTraversalPolicy.getComponentBefore,
    • if obtained Component is a Container and a focus traversal policy provider, that Container's FocusTraversalPolicy is inquired for the default Component, and that default Component is returned as the result
    • if a Component is a child of a focus traversal policy provider, the next and previous for this Component are determined using this focus traversal policy provider's FocusTraversalPolicy. However, in order for focus to leave the provider, the following rules are applied:
      • if at some point the next found Component is the first Component of focus traversal policy provider, the Component after the focus traversal policy provider is returned
      • if at some point the previous found Component is the last Component of focus traversal policy provider, the Component before the focus traversal policy provider is returned
  • When calculating the first or the last Component in FocusTraversalPolicy.getFirstComponent or FocusTraversalPolicy.getLastComponent,
    • if obtained Component is a Container and a focus traversal policy provider, that Container's FocusTraversalPolicy is inquired for the default Component, and that default Component is returned as the result

Programmatic Traversal

In addition to user-initiated focus traversal, client code can initiate a focus traversal operation programmatically. To client code, programmatic traversals are indistinguishable from user-initiated traversals. The preferred way to initiate a programmatic traversal is to use one of the following methods on KeyboardFocusManager:

    KeyboardFocusManager.focusNextComponent() KeyboardFocusManager.focusPreviousComponent() KeyboardFocusManager.upFocusCycle() KeyboardFocusManager.downFocusCycle()

Each of these methods initiates the traversal operation with the current focus owner. If there is currently no focus owner, then no traversal operation occurs. In addition, if the focus owner is not a focus cycle root, then downFocusCycle() performs no traversal operation.

KeyboardFocusManager also supports the following variants of these methods:

  • KeyboardFocusManager.focusNextComponent(Component)
  • KeyboardFocusManager.focusPreviousComponent(Component)
  • KeyboardFocusManager.upFocusCycle(Component)
  • KeyboardFocusManager.downFocusCycle(Container)
Each of these methods initiates the traversal operation with the specified Component rather than the focus owner. That is, the traversal occurs as though the specified Component is the focus owner, though it need not be.

Alternate, but equivalent, APIs are defined on the Component and Container classes themselves:

  • Component.transferFocus()
  • Component.transferFocusBackward()
  • Component.transferFocusUpCycle()
  • Container.transferFocusDownCycle()
As with the KeyboardFocusManager variants, each of these methods initiates the traversal operation as though the Component is the focus owner, though it need not be.

Also note that hiding or disabling the focus owner, directly or indirectly via an ancestor, or making the focus owner non-displayable or non-focusable, initiates an automatic, forward focus traversal. While hiding any ancestor, lightweight or heavyweight, will always indirectly hide its children, only disabling a heavyweight ancestor will disable its children. Thus, disabling a lightweight ancestor of the focus owner does not automatically initiate a focus traversal.

If client code initiates a focus traversal, and there is no other Component to focus, then the focus owner remains unchanged. If client code initiates an automatic focus traversal by hiding the focus owner, directly or indirectly, or by making the focus owner non-displayable or non-focusable, and there is no other Component to focus, then the global focus owner is cleared. If client code initiates an automatic focus traversal by disabling the focus owner, directly or indirectly, and there is no other Component to focus, then the focus owner remains unchanged.

Focusability

A focusable Component can become the focus owner ("focusability") and participates in keyboard focus traversal ("focus traversability") with a FocusTraversalPolicy. There is no separation of these two concepts; a Component must either be both focusable and focus traversable, or neither. A Component expresses this state via the isFocusable() method. By default, all Components return true from this method. Client code can change this default by calling Component.setFocusable(boolean).

Focusable Windows

To support palette windows and input methods, client code can prevent a Window from becoming the focused Window. By transitivity, this prevents the Window or any of its descendants from becoming the focus owner. Non-focusable Windows may still own Windows that are focusable. By default, every Frame and Dialog is focusable. Every Window which is not a Frame or Dialog, but whose nearest owning Frame or Dialog is showing on the screen, and which has at least one Component in its focus traversal cycle, is also focusable by default. To make a Window non-focusable, use Window.setFocusableWindowState(false).

If a Window is non-focusable, this restriction is enforced when the KeyboardFocusManager sees a WINDOW_GAINED_FOCUS event for the Window. At this point, the focus change is rejected and focus is reset to a different Window. The rejection recovery scheme is the same as if a VetoableChangeListener rejected the focus change. See Focus and VetoableChangeListener.

Because the new focus implementation requires that KeyEvents intended for a Window or its descendants be proxied through a child of the Window's owner, and because this proxy must be mapped on X11 in order to receive events, a Window whose nearest owning Frame or Dialog is not showing could never receive KeyEvents on X11. To support this restriction, we have made a distinction between a Window's "window focusability" and its "window focusability state". A Window's focusability state is combined with the showing state of the Window's nearest owning Frame or Dialog to determine the Window's focusability. By default, all Windows have a focusability state of true. Setting a Window's focusability state to false ensures that it will not become the focused Window regardless of the showing state of its nearest owning Frame or Dialog.

Swing allows applications to create JWindows with null owners. Swing constructs all such JWindows so that they are owned by a private, hidden Frame. Because the showing state of this Frame will always be false, a JWindow constructed will a null owner can never be the focused Window, even if it has a Window focusability state of true.

If the focused Window is made non-focusable, then the AWT will attempt to focus the most recently focused Component of the Window's owner. The Window's owner will thus become the new focused Window. If the Window's owner is also a non-focusable Window, then the focus change request will proceed up the ownership hierarchy recursively. Since not all platforms support cross-Window focus changes (see Requesting Focus), it is possible that all such focus change requests will fail. In this case, the global focus owner will be cleared and the focused Window will remain unchanged.

Requesting Focus

A Component can request that it become the focus owner by calling Component.requestFocus(). This initiates a permanent focus transfer to the Component only if the Component is displayable, focusable, visible and all of its ancestors (with the exception of the top-level Window) are visible. The request will be immediately denied if any of these conditions is not met. A disabled Component may be the focus owner; however, in this case, all KeyEvents will be discarded.

The request will also be denied if the Component's top-level Window is not the focused Window and the platform does not support requesting focus across Windows. If the request is denied for this reason, the request is remembered and will be granted when the Window is later focused by the user. Otherwise, the focus change request changes the focused Window as well. Currently, Microsoft Windows supports cross-Window focus transfers while Solaris does not.

There is no way to determine synchronously whether a focus change request has been granted. Instead, client code must install a FocusListener on the Component and watch for the delivery of a FOCUS_GAINED event. Client code must not assume that the Component is the focus owner until it receives this event. The event may or may not be delivered before requestFocus() returns. Developers must not assume one behavior or the other.

The AWT supports type-ahead if all focus change requests are made on the EventDispatchThread. If client code requests a focus change, and the AWT determines that this request might be granted by the native windowing system, then the AWT will notify the current KeyboardFocusManager that is should enqueue all KeyEvents with a timestamp later than the that of the event currently being handled. These KeyEvents will not be dispatched until the new Component becomes the focus owner. The AWT will cancel the delayed dispatching request if the focus change does not succeed at the native level, if the Component's peer is disposed, or if the focus change is vetoed by a VetoableChangeListener. KeyboardFocusManagers are not required to support type-ahead if a focus change request is made from a thread other than the EventDispatchThread.

Because Component.requestFocus() cannot be implemented consistently across platforms, developers are encouraged to use Component.requestFocusInWindow() instead. This method denies cross-Window focus transfers on all platforms automatically. By eliminating the only platform-specific element of the focus transfer, this method achieves consistent cross-platform behavior.

In addition, requestFocusInWindow() returns a boolean value. If 'false' is returned, the request is guaranteed to fail. If 'true' is returned, the request will succeed unless it is vetoed, or an extraordinary event, such as disposal of the Component's peer, occurs before the request can be granted by the native windowing system. Again, while a return value of 'true' indicates that the request is likely to succeed, developers must never assume that this Component is the focus owner until this Component receives a FOCUS_GAINED event.

If client code wants no Component in the application to be the focus owner, it can call the method KeyboardFocusManager. clearGlobalFocusOwner() on the current KeyboardFocusManager. If there exists a focus owner when this method is called, the focus owner will receive a permanent FOCUS_LOST event. After this point, the AWT focus implementation will discard all KeyEvents until the user or client code explicitly sets focus to a Component.

The Component class also supports variants of requestFocus and requestFocusInWindow that allow client code to specify a temporary state. See Temporary FocusEvents

Focus and PropertyChangeListener

Client code can listen to changes in context-wide focus state, or to changes in focus-related state in Components, via PropertyChangeListeners.

The KeyboardFocusManager supports the following properties:

  1. focusOwner: the focus owner
  2. focusedWindow: the focused Window
  3. activeWindow: the active Window
  4. defaultFocusTraversalPolicy: the default focus traversal policy
  5. forwardDefaultFocusTraversalKeys: the Set of default FORWARD_TRAVERSAL_KEYS
  6. backwardDefaultFocusTraversalKeys: the Set of default BACKWARD_TRAVERSAL_KEYS
  7. upCycleDefaultFocusTraversalKeys: the Set of default UP_CYCLE_TRAVERSAL_KEYS
  8. downCycleDefaultFocusTraversalKeys: the Set of default DOWN_CYCLE_TRAVERSAL_KEYS
  9. currentFocusCycleRoot: the current focus cycle root

A PropertyChangeListener installed on the current KeyboardFocusManager will only see these changes within the KeyboardFocusManager's context, even though the focus owner, focused Window, active Window, and current focus cycle root comprise the global focus state shared by all contexts. We believe this is less intrusive than requiring client code to pass a security check before installing a PropertyChangeListener.

Component supports the following focus-related properties:

  1. focusable: the Component's focusability
  2. focusTraversalKeysEnabled: the Component's focus traversal keys enabled state
  3. forwardFocusTraversalKeys: the Component's Set of FORWARD_TRAVERSAL_KEYS
  4. backwardFocusTraversalKeys: the Component's Set of BACKWARD_TRAVERSAL_KEYS
  5. upCycleFocusTraversalKeys: the Component's Set of UP_CYCLE_TRAVERSAL_KEYS

In addition to the Component properties, Container supports the following focus-related properties:

  1. downCycleFocusTraversalKeys: the Container's Set of DOWN_CYCLE_TRAVERSAL_KEYS
  2. focusTraversalPolicy: the Container's focus traversal policy
  3. focusCycleRoot: the Container's focus-cycle-root state

In addition to the Container properties, Window supports the following focus-related property:

  1. focusableWindow: the Window's focusable Window state

Also note that a PropertyChangeListener installed on a Window will never see a PropertyChangeEvent for the focusCycleRoot property. A Window is always a focus cycle root; this property cannot change.

Focus and VetoableChangeListener

The KeyboardFocusManager also supports VetoableChangeListeners for the following properties:

  1. "focusOwner": the focus owner
  2. "focusedWindow": the focused Window
  3. "activeWindow": the active Window
If a VetoableChangeListener vetoes a focus or activation change by throwing a PropertyVetoException, the change is aborted. Any VetoableChangeListeners which had already approved the change will asynchronously receive PropertyChangeEvents indicating a reversion of state to the previous value.

VetoableChangeListeners are notified of the state change before the change is reflected in the KeyboardFocusManager. Conversely, PropertyChangeListeners are notified after the change is reflected. It follows that all VetoableChangeListeners will be notified before any PropertyChangeListener.

VetoableChangeListeners must be idempotent, and must veto both loss and gain events for a particular focus change (e.g., both FOCUS_LOST and FOCUS_GAINED). For example, if a VetoableChangeListener vetoes a FOCUS_LOST event, a KeyboardFocusManager is not required to search the EventQueue and remove the associated pending FOCUS_GAINED event. Instead, the KeyboardFocusManager is free to attempt to dispatch this event and it is the responsibility of the VetoableChangeListener to veto it as well. In addition, during processing of the FOCUS_GAINED event, the KeyboardFocusManager may attempt to resync the global focus state by synthesizing another FOCUS_LOST event. This event must be vetoed just as the first FOCUS_LOST event was.

A KeyboardFocusManager may not hold any locks while notifying PropertyChangeListeners of a state change. This requirement is relaxed for VetoableChangeListeners, however. Therefore, client-definied VetoableChangeListeners should avoid acquiring additional locks inside vetoableChange(PropertyChangeEvent) as this may lead to deadlock. If a focus or activation change is rejected, the KeyboardFocusManager will initiate rejection recovery as follows:

  • If a focused or active Window change was rejected, then the focused or active Window will be reset to the Window which was previously the focused or active Window. If there is no such Window, then the KeyboardFocusManager will clear the global focus owner.
  • If a focus owner change was rejected, then the focus owner will be reset to the Component which was previously the focus owner. If that is not possible, then it will be reset to the next Component in the focus traversal cycle after the previous focus owner. If that is also not possible, then the KeyboardFocusManager will clear the global focus owner.
VetoableChangeListeners must be careful to avoid vetoing focus changes initiated as a result of veto rejection recovery. Failure to anticipate this situation could lead to an infinite cycle of vetoed focus changes and recovery attempts.

Z-Order

On some native windowing systems, the Z-order of a Window can affect its focused or active (if applicable) state. On Microsoft Windows, the top-most Window is naturally the focused Window as well. However, on Solaris, many window managers use a point-to-focus model that ignores Z-order in determining the focused Window. When focusing or activating Windows, the AWT adheres to the UI requirements of the native platform. Therefore, the focus behavior of Z-order-related methods such as:

  • Window.toFront()
  • Window.toBack()
  • Window.show()
  • Window.hide()
  • Window.setVisible(boolean)
  • Window.dispose()
  • Frame.setState(int)
is platform-dependent. In JDK 1.4, the behavior of these methods on Microsoft Windows and Solaris is as follows:
  • Window.toFront():
    Microsoft Windows: The Window is moved to front, if possible. While we will always be able to move this Window in front of other Windows in the same VM, Windows 98 and Windows 2000 do not allow an application to bring any of its windows to the front unless one of that application's windows is already in the foreground. In this case, Windows will instead flash the Window's icon in the taskbar. If the Window is moved to the front, it will be made the focused and (if applicable) active Window.
    Solaris: The Window is moved to front. In a point-to-focus window manager, the Window will become the focused Window if it is the top-most Window underneath the cursor. In a click-to-focus window manager, the focused Window will remain unchanged.
  • Window.toBack():
    Microsoft Windows: The Window is moved to back. Note however that Microsoft Windows insists that an owned Window always be in front of all of its recursive owners. Thus, after the completion of this operation, the Window may not be the lowest Java Window in the Z-order. If the Window, or any of its owners, was the focused Window, then the focused Window is reset to the top-most Window in the VM.
    Solaris: The Window is moved to back. Like Microsoft Windows, some window managers insist than an owned Window always be in front of all of its recursive owners. Thus, after the completion of this operation, the Window may not be the lowest Java Window in the Z-order. If the Window was the focused Window, it will lose focus in a point-to-focus window manager if it is no longer the top-most Window under the cursor. In a click-to-focus window manager, the focused Window will remain unchanged.
  • Window.show()/Window.setVisible(true)/Frame.setState(NORMAL):
    Microsoft Windows: The Window is moved to front and becomes the focused Window.
    Solaris: The Window is moved to front. In a point-to-focus focus window manager, the Window will be focused if it is now the top-most Window under the cursor. In a click-to-focus window manager, the Window will become the focused Window.
  • Window.hide()/Window.setVisible(false)/Window.dispose()/ Frame.setState(ICONIFIED):
    Microsoft Windows: If the Window was the focused Window, the focused Window is reset to a window chosen by the OS, or to no window. The window may be in a native application, or a Java application in another VM.
    Solaris: If the Window was the focused Window, in a point-to- focus window manager, the top-most Window under the cursor will become the focused Window. In a click-to-focus window manager, the focused Window is reset to a window chosen by the window manager. The window may be in a native application, or a Java application in another VM.

Replacing DefaultKeyboardFocusManager

KeyboardFocusManagers are pluggable at the browser context level. Client code can subclass KeyboardFocusManager or DefaultKeyboardFocusManager to modify the way that WindowEvents related to focus, FocusEvents, and KeyEvents are handled and dispatched, and to examine and modify the global focus state. A custom KeyboardFocusManager can also reject focus changes at a more fundamental level then a FocusListener or WindowListener ever could.

While giving a developer ultimate control over the focus model, replacing the entire KeyboardFocusManager is a difficult process requiring a thorough understanding of the peer focus layer. Fortunately, most applications do not need this much control. Developers are encouraged to use KeyEventDispatchers, KeyEventPostProcessors, FocusTraversalPolicies, VetoableChangeListeners, and other concepts discussed in this document before resorting to a full replacement of the KeyboardFocusManager.

First note that, because unhindered access to Components in other contexts represents a security hole, the SecurityManager must grant a new permission, "replaceKeyboardFocusManager", before client code is permitted to replace the KeyboardFocusManager with an arbitrary subclass instance. Because of the security check, replacing the KeyboardFocusManager is not an option for applications that will be deployed in environments with a SecurityManager, such as applets in a browser.

Once installed, a KeyboardFocusManager instance has access to the global focus state via a set of protected functions. The KeyboardFocusManager can only call these functions if it is installed in the calling thread's context. This ensures that malicious code cannot circumvent the security check in KeyboardFocusManager.setCurrentFocusManager. A KeyboardFocusManager should always work with the global focus state instead of the context focus state. Failure to do this will lead to incorrect behavior of the KeyboardFocusManager.

The primary responsibility of a KeyboardFocusManager is the dispatch of the following events:

  • all KeyEvents
  • all FocusEvents
  • WindowEvent.WINDOW_GAINED_FOCUS
  • WindowEvent.WINDOW_LOST_FOCUS
  • WindowEvent.WINDOW_ACTIVATED
  • WindowEvent.WINDOW_DEACTIVATED
The peer layer will provide the KeyboardFocusManager with all of the above events except WINDOW_ACTIVATED and WINDOW_DEACTIVATED. The KeyboardFocusManager must synthesize WINDOW_ACTIVATED and WINDOW_DEACTIVATED events when appropriate and target them accordingly.

The KeyboardFocusManager may need to retarget the events provided by the peer layer to its own notion of the focus owner or focused Window:

  • A KeyEvent must be retargeted to the focus owner. Because the peer layer is unaware of any lightweight Components, KeyEvents will arrive from the peer layer targeted to the focus owner's heavyweight Container, not the focus owner.
  • A FOCUS_LOST event must be retargeted to the focus owner. Again, this is necessary because the peer layer is unaware of lightweight Components.
  • A WINDOW_LOST_FOCUS event must be retargeted to the focused Window. The implementation of the Window class may cause the native focused Window to differ from the Java focused Window.

A KeyboardFocusManager must ensure proper event ordering, and a 1-to-1 correspondence between an event and its opposite event type. The peer layer does not make any of these guarantees. For example, it is possible for the peer layer to send a FOCUS_GAINED event before a WINDOW_GAINED_FOCUS event. The KeyboardFocusManager is responsible for ensuring that the WINDOW_GAINED_FOCUS event is dispatched before the FOCUS_GAINED event.

Before redispatching an event via KeyboardFocusManager. redispatchEvent, a KeyboardFocusManager must attempt to update the global focus state. Typically, this is done using one of the KeyboardFocusManager.setGlobal* methods; however, an implementation is free to implement its own methods. After attempting an update, the KeyboardFocusManager must verify that the global focus state change was not rejected. A rejection is detected when a call to the corresponding getGlobal* method returns a value different than the value just set. Rejections occur in three standard cases:

  • If the KeyboardFocusManager attempts to set the global focus owner to a non-focusable Component.
  • If the KeyboardFocusManager attempts to set the global focused Window to a non-focusable Window.
  • If the change is rejected by an installed VetoableChangeListener.

Client-defined implementations of KeyboardFocusManager can adjust the set of focus transfers which are rejected by overriding the accessor and mutator methods for the global focus state.

If a request to change the global focus state is rejected, the KeyboardFocusManager must discard the event which prompted the focus change request. The Component to which the event was targeted must not receive the event.

The KeyboardFocusManager is also expected to initiate rejection recovery as outlined in Focus and VetoableChangeListener.

Finally, a KeyboardFocusManager must handle the following set of special cases:

  • When handling a WINDOW_GAINED_FOCUS event, the KeyboardFocusManager must set focus to the appropriate child Component of the Window. If a child Component of the Window previously requested focus, but the focus change was rejected because the platform does not support cross-Window focus change requests, then focus should be set to that child Component. Otherwise, if the Window has never been focused, focus should be set to the Window's initial Component to focus. If the Window was previously focused, focus should be set to the Window's most recent focus owner.
  • The KeyboardFocusManager must ensure that the opposite Component or Window are as accurate as the native windowing platform permits. For example, the KeyboardFocusManager may need to retarget the opposite Component to a lightweight child of the heavyweight initially specified by the peer layer.
    If the peer layer states that the opposite Component or Window is null, it is acceptable for the KeyboardFocusManager to propagate this value. null indicates that it is highly probably that no other Component or Window was involved in the focus or activation change. Because of platform limitations, this computation may be subject to a heuristic and could be incorrect. Nevertheless, this heuristic will be the best possible guess which the peer layer could make.
  • Focus and activation changes in which a Component or Window loses focus or activation to itself must be discarded.
  • Events posted by the peer layer claiming that the active Window has lost focus to the focused Window must be discarded. The peer implementation of the Window class may generate these spurious events.

Incompatibilities with Previous Releases

Cross-platform changes:

  1. The default focus traversability for all Components is now 'true'. Previously, some Components (in particular, all lightweights), had a default focus traversability of 'false'. Note that despite this change, however, the DefaultFocusTraversalPolicy for all AWT Containers will preserve the traversal order of previous releases.
  2. A request to focus a non-focus traversable (i.e., non-focusable) Component will be denied. Previously, such requests were granted.
  3. Window.toFront() and Window.toBack() now perform no operation if the Window is not visible. Previously, the behavior was platform-dependent.
  4. KeyListeners installed on Components will no longer see KeyEvents that map to focus traversal operations, and Component.handleEvent() will no longer be invoked for such events. Previously, AWT Components saw these events and had an opportunity to consume them before AWT initiated focus traversal. Code that requires this functionality should instead disable focus traversal keys on its Components and handle focus traversal itself. Alternately, the code can use an AWTEventListener or KeyEventDispatcher to pre-listen to all KeyEvents.

Changes specific to Microsoft Windows:

  1. Window.toBack() changes the focused Window to the top-most Window after the Z-order change.
  2. requestFocus() now allows cross-Window focus change requests in all cases. Previously, requests were granted for heavyweights, but denied for lightweights.


The AWT Modality

This document, together with the API documentation for modality-related classes (such as java.awt.Dialog), briefly describes the new modality features and how to use them. It contains the following sections:

  • Definitions
  • Modality types
  • Show/hide blocking
  • Modal exclusion
  • Related AWT features
  • Security
  • Platform support
  • Compatibility
  • Examples

Definitions

Document - a window without an owner that, together with all its child hierarchy, may be operated on as a single self-contained document. Every window belongs to some document — its root can be found as the closest ancestor window without an owner.

Modal blocked window - a window, that:

  • doesn't receive any user input events
  • doesn't receive input focus
  • keeps its Z-order below the modal dialog that blocks it
Warning! Some window managers allow users to change the window Z-order in an arbitrary way — in that case the last requirement may not be met.

Modal dialog - a dialog that blocks some windows while it is visible. The blocked windows are determined according to the dialog's scope of blocking.

Modal excluded window - a window that stays unblocked while the modal dialog is visible. If a window is modal excluded then all its owned windows and child components are also excluded.

Scope of blocking (SB) - the set of windows (instances of java.awt.Window and all derived classes) that are blocked by the modal dialog while it is visible.

Note: Everywhere in this document the notion of "window" is equal to a top-level window in the Java programming language — in other words an instance of java.awt.Window or any descendant class.

Modality types

There are four supported modality types :

  • toolkit
  • application
  • document
  • modeless
A dialog is, by default, modeless. A modal dialog is, by default, application-modal.

  1. Modeless dialogs
    A modeless dialog doesn't block any windows while visible.
  2. Document-modal dialogs
    A document-modal dialog blocks all windows from the same document except those from its child hierarchy. The document root is determined as the closest ancestor window without an owner.
  3. Application-modal dialogs
    An application-modal dialog blocks all windows from the same application except for those from its child hierarchy. If there are several applets launched in a browser, they can be treated either as separate applications or a single application. This behavior is implementation-dependent.
  4. Toolkit-modal dialogs
    A toolkit-modal dialog blocks all windows that run in the same toolkit except those from its child hierarchy. If there are several applets launched all of them run with the same toolkit, so a toolkit-modal dialog shown from an applet may affect other applets and all windows of the browser instance which embeds the Java runtime environment for this toolkit. See the security section below.

Modality priority is arranged by the strength of blocking: modeless, document-modal, application-modal and toolkit-modal. This arrangement is used when determining what dialog should remain unblocked if two are visible and block each other. It naturally reflects the nesting of a dialog's scope of blocking (SB): a modeless dialog has an empty SB, a document-modal dialog's SB is complete in some applications, and all the applications are run in one toolkit.

Notes about owners:

  • Creating a document-modal dialog without an owner:
    Since Dialog is a class derived from Window, a Dialog instance automatically becomes the root of the document if it has no owner. Thus, if such a dialog is document-modal, its scope of blocking is empty and it behaves the same way as a modeless dialog.
  • Creating an application-modal or toolkit-modal dialog with an owner:
    The scope of blocking for an application- or toolkit-modal dialog, as opposed to a document-modal dialog, doesn't depend on its owner. Thus, in this case the only thing that the owner affects is the Z-order: the dialog always stays on top of its owner.

Implementation note: Changing the modality type for a visible dialog may have no effect until it is hidden and then shown again.

Show/hide blocking

Showing the window or modeless dialog: "F"
All the visible modal dialogs are looked through — if F is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, F remains unblocked.

Showing the modal dialog: "M"
When modal dialog M is shown, all the visible windows fall into one of three distinct groups:

  • Blockers of M (modal dialogs that block M and either are in M's child hierarchy, or are not blocked by M, or have a greater mode of modality, or block some other blocker of M)
  • Blocked by M (windows from M's SB that are not blockers and are not in child hierarchy of any blocker)
  • All other windows (windows or modeless dialogs outside M's SB and modal dialogs outside M's SB that do not block M).

After the modal dialog M is shown, it becomes blocked by the first shown dialog from the first group (if there are any), all the windows from the second one become blocked by M, and all the windows from the third group remain untouched.

In typical cases, when no child dialogs are shown before their owners, this rule can be simplified. (The following, simplified case, may leave out some details).

Showing the document-modal dialog: "M"
All the visible application- and toolkit-modal dialogs are looked through — if M is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, M remains unblocked.

Showing the application-modal dialog: "M"
All the visible toolkit-modal dialogs are looked through — if M is from the SB of one of them, it becomes blocked by it. If there are several such dialogs, the first shown is used. If no such dialogs exist, M remains unblocked.

Showing the toolkit-modal dialog: "M"
M remains unblocked.

The Standard Blocking Matrix
current/shown | frame & modeless | document | application | toolkit
- | - | - | - | -
document | blocked | - | - | -
application | blocked | blocked | - | -
toolkit | blocked | blocked | blocked | -

After the modal dialog is shown, all the windows from its SB are blocked, except those that block this modal dialog.

Hiding the window or modeless dialog: "F"
If F was blocked by any modal dialog M, it becomes unblocked and is removed from M's blocked windows list.

Hiding the modal dialog: "M"
If M was blocked by any other modal dialog, for example, "N", it becomes unblocked and is removed from N's blocked windows list. Then, all the windows and dialogs blocked by M become unblocked, and after that the same checks (as in Showing the modal dialog: "M") are performed for each of them in the order they were initially shown.

Modal exclusion

There are two modal exclusion types introduced as of JDK 6

  • Exclusion from blocking of toolkit-modal dialogs
  • Exclusion from blocking of application-modal dialogs
By default, a window's modal exclusion property is turned off.

  1. Application-modal exclusion
    If a window is application-modal excluded, it is not blocked by any application-modal dialogs. Also, it is not blocked by document-modal dialogs from outside of its child hierarchy.
  2. Toolkit-modal exclusion
    If a window is toolkit-modal excluded, it is not blocked by any application- or toolkit-modal dialogs. Also, it is not blocked by document-modal dialogs from outside of their child hierarchy.

Implementation note: Changing the modal exclusion type for a visible window may have no effect until it is hidden and then shown again.

Related AWT features

Always-On-Top
When a modal dialog that is not always-on-top blocks an always-on-top window, their relative Z-order is unspecified and platform-dependent.

The toFront() and toBack() methods
A modal dialog should always be above all its blocked windows. Thus, if a blocked window is brought to the front, its blocking dialog, if any, is also brought to the front and remains above the blocked window. Likewise, if a modal dialog is sent to the back, all of its blocked windows are sent to the back to keep them below the blocking dialog.

Minimizing, maximizing and closing blocked windows
When a modal dialog blocks a window, the user may not be able to maximize or minimize the blocked window— however, the actual behavior is unspecified and platform-dependent. In any case, the user can't close the blocked window interactively— but it can be closed programmatically by calling the setVisible(false) or dispose() methods on the blocked window.

Blocked windows activations
When the user selects a blocked window, it may be brought to the front, along with the blocking modal dialog which would then become the active window— however, the actual behavior is unspecified and platform-dependent.

Hiding a modal dialog
When the modal dialog that currently has focus is hidden, it is unspecified and platform-dependent, which other window will become the active window. Any of the following may become the active window:

  1. The owner of the modal dialog - if the owner is unblocked.
  2. The Window, which was active before this modal dialog gained focus - if the owner of the modal dialog is absent or is blocked.
If the modal dialog to be hidden does not have focus, the active window remains unchanged.

Security

A special AWTPermission, "toolkitModality", is required to show toolkit-modal dialogs. This would prevent, for example, blocking a browser or Java Web Start (JWS) by modal dialogs shown from applets.

The same permission is required to exclude a window from toolkit modality. This would prevent, for example, a dialog shown from an applet not to be blocked by a browser's or JWS's modal dialog.

Platform support

Two java.awt.Toolkit methods allow you to check whether the current platform supports specific modality features:

  • isModalityTypeSupported(modalityType)
    Returns whether the specified modality type is supported on the current platform. If mode "M" is not supported and a dialog is set to M-modal, it behaves as modeless.
  • isModalExclusionTypeSupported(modalExclusionType)
    Returns whether the given modal exclusion type is supported on the current platform. If exclusion type "E" is not supported and a window is marked as E-excluded, this has no effect.

Compatibility

The default modality type is application-modal. It is used by the API calls: Dialog.setModal(true), Dialog(owner, true), etc. Prior to JDK 6 the default type was toolkit-modal, but the only distinction between application- and toolkit-modality is for applets and applications launched from Java Web Start.

Examples

  1. Frame "F" is shown
  2. Document-modal dialog "Di" is shown
  3. F becomes blocked by Di — it's in the same document
  4. Document-modal dialog "Dii" is shown
  5. Di becomes blocked by Dii — it's in the same document
  1. Frame "F" is shown
  2. Document-modal dialog "Di" is shown
  3. F becomes blocked by Di — it's in the same document
  4. Document-modal dialog "Dii" is shown
  5. Di becomes blocked by Dii — it's in the same document
  6. Di is hidden
  7. F becomes blocked by Dii — it's in the same document
  1. Frame "F" is shown
  2. Toolkit-modal dialog "Di" is created, but not shown
  3. Document-modal dialog "Dii" is shown
  4. F becomes blocked by Dii — it's in the same document
  5. Application-modal dialog "Diii" is shown
  6. Dii becomes blocked by Diii — it's in the same application
  7. Di is shown
  8. Di becomes blocked by Dii — it's its owner
  9. Diii remains unblocked — it blocks Dii and Dii blocks Di
  1. Frame "F" is shown
  2. Toolkit-modal dialog "Di" is created, but not shown
  3. Document-modal dialog "Dii" is shown
  4. F becomes blocked by Dii — it's in the same document
  5. Application-modal dialog "Diii" is shown
  6. Dii becomes blocked by Diii — it's in the same application
  7. Di is shown
  8. Diii becomes blocked by Di — Di is not blocked
  9. Di remains unblocked


类 java.awt.AWTError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTError
的使用

没有 java.awt.AWTError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Button 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Button
的使用

使用 Button 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Button 的使用

参数类型为 Button 的 java.awt 中的方法
protected abstract  java.awt.peer.ButtonPeer Toolkit.createButton(Button target)
使用指定同位体接口创建此工具包的 Button 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Button.AccessibleAWTButton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Button.AccessibleAWTButton
的使用

没有 java.awt.Button.AccessibleAWTButton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Checkbox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Checkbox
的使用

使用 Checkbox 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Checkbox 的使用

返回 Checkbox 的 java.awt 中的方法
 Checkbox CheckboxGroup.getCurrent()
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
 Checkbox CheckboxGroup.getSelectedCheckbox()
从此复选框组中获取当前选择。

参数类型为 Checkbox 的 java.awt 中的方法
protected abstract java.awt.peer.CheckboxPeer | Toolkit.createCheckbox(Checkbox target) 使用指定同位体接口创建此工具包的 Checkbox 实现。
void | CheckboxGroup.setCurrent(Checkbox box) 已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
void | CheckboxGroup.setSelectedCheckbox(Checkbox box) 将此组中当前选中的复选框设置为指定的复选框。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Checkbox.AccessibleAWTCheckbox 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Checkbox.AccessibleAWTCheckbox
的使用

没有 java.awt.Checkbox.AccessibleAWTCheckbox 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.CheckboxGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CheckboxGroup
的使用

使用 CheckboxGroup 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 CheckboxGroup 的使用

返回 CheckboxGroup 的 java.awt 中的方法
 CheckboxGroup Checkbox.getCheckboxGroup()
确定此复选框的组。

参数类型为 CheckboxGroup 的 java.awt 中的方法
 void Checkbox.setCheckboxGroup(CheckboxGroup g)
将此复选框的组设置为指定复选框组。

参数类型为 CheckboxGroup 的 java.awt 中的构造方法
Checkbox(String label, boolean state, CheckboxGroup group)
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。
Checkbox(String label, CheckboxGroup group, boolean state)
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.CheckboxMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CheckboxMenuItem
的使用

使用 CheckboxMenuItem 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 CheckboxMenuItem 的使用

参数类型为 CheckboxMenuItem 的 java.awt 中的方法
protected abstract  java.awt.peer.CheckboxMenuItemPeer Toolkit.createCheckboxMenuItem(CheckboxMenuItem target)
使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
的使用

没有 java.awt.CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Choice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Choice
的使用

使用 Choice 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Choice 的使用

参数类型为 Choice 的 java.awt 中的方法
protected abstract  java.awt.peer.ChoicePeer Toolkit.createChoice(Choice target)
使用指定同位体接口创建此工具包的 Choice 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Choice.AccessibleAWTChoice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Choice.AccessibleAWTChoice
的使用

没有 java.awt.Choice.AccessibleAWTChoice 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.CompositeContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.CompositeContext
的使用

使用 CompositeContext 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 CompositeContext 的使用

返回 CompositeContext 的 java.awt 中的方法
CompositeContext | AlphaComposite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 为合成操作创建一个上下文。
CompositeContext | Composite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 创建一个上下文，其中包含用于执行复合操作的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Desktop 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Desktop
的使用

使用 Desktop 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Desktop 的使用

返回 Desktop 的 java.awt 中的方法
static Desktop Desktop.getDesktop()
返回当前浏览器上下文的 Desktop 实例。

参数类型为 Desktop 的 java.awt 中的方法
protected abstract  java.awt.peer.DesktopPeer Toolkit.createDesktopPeer(Desktop target)
使用指定的同位体接口创建此工具包的 Desktop 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Desktop.Action 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Desktop.Action
的使用

使用 Desktop.Action 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Desktop.Action 的使用

返回 Desktop.Action 的 java.awt 中的方法
static Desktop.Action | Desktop.Action.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Desktop.Action[] | Desktop.Action.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Desktop.Action 的 java.awt 中的方法
 boolean Desktop.isSupported(Desktop.Action action)
测试当前平台是否支持某一动作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.DisplayMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.DisplayMode
的使用

使用 DisplayMode 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 DisplayMode 的使用

返回 DisplayMode 的 java.awt 中的方法
DisplayMode | GraphicsDevice.getDisplayMode() 返回此 GraphicsDevice 的当前显示模式。
DisplayMode[] | GraphicsDevice.getDisplayModes() 返回可用于此 GraphicsDevice 的所有显示模式。

参数类型为 DisplayMode 的 java.awt 中的方法
boolean | DisplayMode.equals(DisplayMode dm) 返回对两个显示模式是否相同的判断。
void | GraphicsDevice.setDisplayMode(DisplayMode dm) 设置此图形设备的显示模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.FileDialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FileDialog
的使用

使用 FileDialog 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 FileDialog 的使用

参数类型为 FileDialog 的 java.awt 中的方法
protected abstract  java.awt.peer.FileDialogPeer Toolkit.createFileDialog(FileDialog target)
使用指定同位体接口创建此工具包的 FileDialog 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.List 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.List
的使用

使用 List 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 List 的使用

参数类型为 List 的 java.awt 中的方法
protected abstract  java.awt.peer.ListPeer Toolkit.createList(List target)
使用指定同位体接口创建此工具包的 List 实现。

参数类型为 List 的 java.awt 中的构造方法
List.AccessibleAWTList.AccessibleAWTListChild(List parent, int indexInParent)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GradientPaint
的使用

没有 java.awt.GradientPaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GraphicsConfigTemplate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsConfigTemplate
的使用

使用 GraphicsConfigTemplate 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GraphicsConfigTemplate 的使用

参数类型为 GraphicsConfigTemplate 的 java.awt 中的方法
 GraphicsConfiguration GraphicsDevice.getBestConfiguration(GraphicsConfigTemplate gct)
返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GridBagConstraints 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridBagConstraints
的使用

使用 GridBagConstraints 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 GridBagConstraints 的使用

声明为 GridBagConstraints 的 java.awt 中的字段
protected  GridBagConstraints GridBagLayout.defaultConstraints
此字段保持包含默认值的网格包约束实例，因此如果某个组件没有与其相关联的网格包约束，则会分配给该组件一个 defaultConstraints 的副本。

类型参数类型为 GridBagConstraints 的 java.awt 中的字段
protected  Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
此哈希表维持组件与其网格包约束之间的关联。

返回 GridBagConstraints 的 java.awt 中的方法
GridBagConstraints | GridBagLayout.getConstraints(Component comp) 获取指定组件的约束。
protected GridBagConstraints | GridBagLayout.lookupConstraints(Component comp) 检索指定组件的约束。

参数类型为 GridBagConstraints 的 java.awt 中的方法
protected void | GridBagLayout.adjustForGravity(GridBagConstraints constraints, Rectangle r) 根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。
protected void | GridBagLayout.AdjustForGravity(GridBagConstraints constraints, Rectangle r) 此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。
void | GridBagLayout.setConstraints(Component comp, GridBagConstraints constraints) 设置此布局中指定组件的约束条件。

javax.swing.plaf.basic 中 GridBagConstraints 的使用

参数类型为 GridBagConstraints 的 javax.swing.plaf.basic 中的方法
protected  void BasicOptionPaneUI.addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)
创建表示 msg 的适当对象并将其置于 container 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GridBagLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridBagLayout
的使用

没有 java.awt.GridBagLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GridBagLayoutInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridBagLayoutInfo
的使用

使用 GridBagLayoutInfo 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GridBagLayoutInfo 的使用

声明为 GridBagLayoutInfo 的 java.awt 中的字段
protected  GridBagLayoutInfo GridBagLayout.layoutInfo
此字段保持网格包的布局信息。

返回 GridBagLayoutInfo 的 java.awt 中的方法
protected GridBagLayoutInfo | GridBagLayout.getLayoutInfo(Container parent, int sizeflag) 为当前受管子级的集合填充 GridBagLayoutInfo 的实例。
protected GridBagLayoutInfo | GridBagLayout.GetLayoutInfo(Container parent, int sizeflag) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。

参数类型为 GridBagLayoutInfo 的 java.awt 中的方法
protected Dimension | GridBagLayout.getMinSize(Container parent, GridBagLayoutInfo info) 基于 getLayoutInfo 中的信息计算其所有者的最小大小。
protected Dimension | GridBagLayout.GetMinSize(Container parent, GridBagLayoutInfo info) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.IllegalComponentStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.IllegalComponentStateException
的使用

使用 IllegalComponentStateException 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 IllegalComponentStateException 的使用

抛出 IllegalComponentStateException 的 javax.accessibility 中的方法
abstract  Locale AccessibleContext.getLocale()
获取该组件的语言环境。

javax.swing 中 IllegalComponentStateException 的使用

抛出 IllegalComponentStateException 的 javax.swing 中的方法
Locale | ProgressMonitor.AccessibleProgressMonitor.getLocale() 获取该组件的语言环境。
Locale | ImageIcon.AccessibleImageIcon.getLocale() 返回此对象的区域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.JobAttributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes
的使用

使用 JobAttributes 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes 的使用

参数类型为 JobAttributes 的 java.awt 中的方法
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
void | JobAttributes.set(JobAttributes obj) 将此 JobAttributes 的所有属性设置为与 obj 的属性相同的值。

参数类型为 JobAttributes 的 java.awt 中的构造方法
JobAttributes(JobAttributes obj)
构造一个 JobAttributes 实例，作为所提供的 JobAttributes 的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.JobAttributes.DefaultSelectionType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.DefaultSelectionType
的使用

使用 JobAttributes.DefaultSelectionType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.DefaultSelectionType 的使用

声明为 JobAttributes.DefaultSelectionType 的 java.awt 中的字段
static JobAttributes.DefaultSelectionType | JobAttributes.DefaultSelectionType.ALL 用于指定应该打印全部作业页面的 DefaultSelectionType 实例。
static JobAttributes.DefaultSelectionType | JobAttributes.DefaultSelectionType.RANGE 用于指定应该打印一定范围的作业页面的 DefaultSelectionType 实例。
static JobAttributes.DefaultSelectionType | JobAttributes.DefaultSelectionType.SELECTION 用于指定应该打印当前选择作业页面的 DefaultSelectionType 实例。

返回 JobAttributes.DefaultSelectionType 的 java.awt 中的方法
 JobAttributes.DefaultSelectionType JobAttributes.getDefaultSelection()
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。

参数类型为 JobAttributes.DefaultSelectionType 的 java.awt 中的方法
 void JobAttributes.setDefaultSelection(JobAttributes.DefaultSelectionType defaultSelection)
指定应用程序应该为使用这些属性的作业打印所有页面，即 getPageRanges 的返回值所指定范围的页面，还是打印当前选择的页面。

参数类型为 JobAttributes.DefaultSelectionType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.JobAttributes.DestinationType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.DestinationType
的使用

使用 JobAttributes.DestinationType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.DestinationType 的使用

声明为 JobAttributes.DestinationType 的 java.awt 中的字段
static JobAttributes.DestinationType | JobAttributes.DestinationType.FILE 用于指定打印到文件的 DestinationType 实例。
static JobAttributes.DestinationType | JobAttributes.DestinationType.PRINTER 用于指定打印到打印机的 DestinationType 实例。

返回 JobAttributes.DestinationType 的 java.awt 中的方法
 JobAttributes.DestinationType JobAttributes.getDestination()
指定将输出到打印机还是使用这些属性的作业文件。

参数类型为 JobAttributes.DestinationType 的 java.awt 中的方法
 void JobAttributes.setDestination(JobAttributes.DestinationType destination)
指定将输出到打印机还是使用这些属性的作业文件。

参数类型为 JobAttributes.DestinationType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.JobAttributes.DialogType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.DialogType
的使用

使用 JobAttributes.DialogType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.DialogType 的使用

声明为 JobAttributes.DialogType 的 java.awt 中的字段
static JobAttributes.DialogType | JobAttributes.DialogType.COMMON 用于指定跨平台的纯 Java 打印对话框的 DialogType 实例。
static JobAttributes.DialogType | JobAttributes.DialogType.NATIVE 用于指定平台的本机打印对话框的 DialogType 实例。
static JobAttributes.DialogType | JobAttributes.DialogType.NONE 用于指定无打印对话框的 DialogType 实例。

返回 JobAttributes.DialogType 的 java.awt 中的方法
 JobAttributes.DialogType JobAttributes.getDialog()
返回对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。

参数类型为 JobAttributes.DialogType 的 java.awt 中的方法
 void JobAttributes.setDialog(JobAttributes.DialogType dialog)
指定对于使用这些属性的作业，用户是否应该看到用于修改打印设置的打印对话框，以及显示哪种类型的打印对话框。

参数类型为 JobAttributes.DialogType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.JobAttributes.MultipleDocumentHandlingType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.MultipleDocumentHandlingType
的使用

使用 JobAttributes.MultipleDocumentHandlingType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.MultipleDocumentHandlingType 的使用

声明为 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的字段
static JobAttributes.MultipleDocumentHandlingType | JobAttributes.MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_COLLATED_COPIES 用于指定应该将作业分成单独的、已整理的副本的 MultipleDocumentHandlingType 实例。
static JobAttributes.MultipleDocumentHandlingType | JobAttributes.MultipleDocumentHandlingType.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 用于指定应该将作业分成单独的、未整理的副本的 MultipleDocumentHandlingType 实例。

返回 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的方法
 JobAttributes.MultipleDocumentHandlingType JobAttributes.getMultipleDocumentHandling()
为使用这些属性的作业指定多份处理，包括整理。

参数类型为 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的方法
 void JobAttributes.setMultipleDocumentHandling(JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling)
为使用这些属性的作业指定多份处理，包括整理。

参数类型为 JobAttributes.MultipleDocumentHandlingType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.JobAttributes.SidesType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.JobAttributes.SidesType
的使用

使用 JobAttributes.SidesType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 JobAttributes.SidesType 的使用

声明为 JobAttributes.SidesType 的 java.awt 中的字段
static JobAttributes.SidesType | JobAttributes.SidesType.ONE_SIDED SidesType 实例用于指定应该在连续介质纸张的同一面打印连续作业页面。
static JobAttributes.SidesType | JobAttributes.SidesType.TWO_SIDED_LONG_EDGE SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在长边上一样。
static JobAttributes.SidesType | JobAttributes.SidesType.TWO_SIDED_SHORT_EDGE SidesType 实例用于指定应该在连续介质纸张的前后两面打印连续作业页面，以便介质上每一页（两面）的方向正对着读者，像绑定在短边上一样。

返回 JobAttributes.SidesType 的 java.awt 中的方法
 JobAttributes.SidesType JobAttributes.getSides()
返回对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。

参数类型为 JobAttributes.SidesType 的 java.awt 中的方法
 void JobAttributes.setSides(JobAttributes.SidesType sides)
指定对于使用这些属性的作业，如何在打印介质的面上强制应用连续页。

参数类型为 JobAttributes.SidesType 的 java.awt 中的构造方法
JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.LinearGradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.LinearGradientPaint
的使用

没有 java.awt.LinearGradientPaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Robot 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Robot
的使用

没有 java.awt.Robot 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.List.AccessibleAWTList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.List.AccessibleAWTList
的使用

没有 java.awt.List.AccessibleAWTList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.List.AccessibleAWTList.AccessibleAWTListChild
的使用

没有 java.awt.List.AccessibleAWTList.AccessibleAWTListChild 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MouseInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MouseInfo
的使用

没有 java.awt.MouseInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MultipleGradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MultipleGradientPaint
的使用

使用 MultipleGradientPaint 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MultipleGradientPaint 的使用

java.awt 中 MultipleGradientPaint 的子类
class | LinearGradientPaint LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
class | RadialGradientPaint RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MultipleGradientPaint.CycleMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MultipleGradientPaint.CycleMethod
的使用

使用 MultipleGradientPaint.CycleMethod 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MultipleGradientPaint.CycleMethod 的使用

返回 MultipleGradientPaint.CycleMethod 的 java.awt 中的方法
MultipleGradientPaint.CycleMethod | MultipleGradientPaint.getCycleMethod() 返回指定循环行为的枚举类型。
static MultipleGradientPaint.CycleMethod | MultipleGradientPaint.CycleMethod.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MultipleGradientPaint.CycleMethod[] | MultipleGradientPaint.CycleMethod.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 MultipleGradientPaint.CycleMethod 的 java.awt 中的构造方法
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。
RadialGradientPaint(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MultipleGradientPaint.ColorSpaceType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MultipleGradientPaint.ColorSpaceType
的使用

使用 MultipleGradientPaint.ColorSpaceType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MultipleGradientPaint.ColorSpaceType 的使用

返回 MultipleGradientPaint.ColorSpaceType 的 java.awt 中的方法
MultipleGradientPaint.ColorSpaceType | MultipleGradientPaint.getColorSpace() 返回指定用于插值的颜色空间的枚举类型。
static MultipleGradientPaint.ColorSpaceType | MultipleGradientPaint.ColorSpaceType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MultipleGradientPaint.ColorSpaceType[] | MultipleGradientPaint.ColorSpaceType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 MultipleGradientPaint.ColorSpaceType 的 java.awt 中的构造方法
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PageAttributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes
的使用

使用 PageAttributes 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes 的使用

参数类型为 PageAttributes 的 java.awt 中的方法
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
void | PageAttributes.set(PageAttributes obj) 将此 PageAttributes 的所有属性设置为与 obj 的属性相同的值。

参数类型为 PageAttributes 的 java.awt 中的构造方法
PageAttributes(PageAttributes obj)
构造一个 PageAttributes 实例，它是所提供的 PageAttributes 的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PageAttributes.ColorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.ColorType
的使用

使用 PageAttributes.ColorType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.ColorType 的使用

声明为 PageAttributes.ColorType 的 java.awt 中的字段
static PageAttributes.ColorType | PageAttributes.ColorType.COLOR 用来指定颜色打印的 ColorType 实例。
static PageAttributes.ColorType | PageAttributes.ColorType.MONOCHROME 用来指定单色打印的 ColorType 实例。

返回 PageAttributes.ColorType 的 java.awt 中的方法
 PageAttributes.ColorType PageAttributes.getColor()
返回使用这些属性的页面是以彩色呈现，还是以单色呈现。

参数类型为 PageAttributes.ColorType 的 java.awt 中的方法
 void PageAttributes.setColor(PageAttributes.ColorType color)
指定使用这些属性的页面以彩色呈现，还是以单色呈现。

参数类型为 PageAttributes.ColorType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PageAttributes.MediaType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.MediaType
的使用

使用 PageAttributes.MediaType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.MediaType 的使用

声明为 PageAttributes.MediaType 的 java.awt 中的字段
static PageAttributes.MediaType | PageAttributes.MediaType.A Engineering A (8 1/2 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.A0 ISO_A0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A1 ISO_A1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A10 ISO_A10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A2 ISO_A2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A3 ISO_A3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A4 ISO_A4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A5 ISO_A5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A6 ISO_A6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A7 ISO_A7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A8 ISO_A8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.A9 ISO_A9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B Engineering B (11 x 17 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.B0 ISO_B0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B1 ISO_B1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B10 ISO_B10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B2 ISO_B2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B3 ISO_B3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B4 ISO_B4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B5 ISO_B5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B6 ISO_B6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B7 ISO_B7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B8 ISO_B8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.B9 ISO_B9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C Engineering C (17 x 22 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.C0 ISO_C0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C1 ISO_C1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C10 ISO_C10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C2 ISO_C2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C3 ISO_C3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C4 ISO_C4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C5 ISO_C5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C6 ISO_C6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C7 ISO_C7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C8 ISO_C8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.C9 ISO_C9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.D Engineering D (22 x 34 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.E Engineering E (34 x 44 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10 NA_NUMBER_10_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10X13 NA_10X13_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10X14 NA_10X14_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_10X15 NA_10X15_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_11 NA_NUMBER_11_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_12 NA_NUMBER_12_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_14 NA_NUMBER_14_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_6X9 NA_6X9_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_7X9 NA_7X9_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_9 NA_NUMBER_9_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_9X11 NA_9X11_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_9X12 NA_9X12_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_INVITE INVITE_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_ITALY ITALY_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_MONARCH MONARCH_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ENV_PERSONAL PERSONAL_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.EXECUTIVE Executive (7 1/4 x 10 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.FOLIO Folio (8 1/2 x 13 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.INVITE INVITE_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.INVITE_ENVELOPE Invitation Envelope (220 x 220 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.INVOICE Invoice (5 1/2 x 8 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_2A0 ISO/DIN & JIS 2A0 (1189 x 1682 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_4A0 ISO/DIN & JIS 4A0 ( 1682 x 2378 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A0 ISO/DIN & JIS A0 (841 x 1189 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A1 ISO/DIN & JIS A1 (594 x 841 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A10 ISO/DIN & JIS A10 (26 x 37 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A2 ISO/DIN & JIS A2 (420 x 594 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A3 ISO/DIN & JIS A3 (297 x 420 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A4 ISO/DIN & JIS A4 (210 x 297 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A5 ISO/DIN & JIS A5 (148 x 210 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A6 ISO/DIN & JIS A6 (105 x 148 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A7 ISO/DIN & JIS A7 (74 x 105 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A8 ISO/DIN & JIS A8 (52 x 74 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_A9 ISO/DIN & JIS A9 (37 x 52 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B0 ISO/DIN B0 (1000 x 1414 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B1 ISO/DIN B1 ( 707 x 1000 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B10 ISO/DIN B10 (31 x 44 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B2 ISO/DIN B2 (500 x 707 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B3 ISO/DIN B3 (353 x 500 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B4 ISO/DIN B4 (250 x 353 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B4_ENVELOPE ISO_B4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B5 ISO/DIN B5 (176 x 250 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B5_ENVELOPE ISO_B5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B6 ISO/DIN B6 (125 x 176 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B7 ISO/DIN B7 (88 x 125 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B8 ISO/DIN B8 (62 x 88 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_B9 ISO/DIN B9 (44 x 62 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C0 ISO/DIN C0 (917 x 1297 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C0_ENVELOPE ISO_C0 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C1 ISO/DIN C1 (648 x 917 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C1_ENVELOPE ISO_C1 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C10 ISO/DIN C10 (28 x 40 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C10_ENVELOPE ISO_C10 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C2 ISO/DIN C2 (458 x 648 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C2_ENVELOPE ISO_C2 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C3 ISO/DIN C3 (324 x 458 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C3_ENVELOPE ISO_C3 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C4 ISO/DIN C4 (229 x 324 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C4_ENVELOPE ISO_C4 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C5 ISO/DIN C5 (162 x 229 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C5_ENVELOPE ISO_C5 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C6 ISO/DIN C6 (114 x 162 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C6_ENVELOPE ISO_C6 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C7 ISO/DIN C7 (81 x 114 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C7_ENVELOPE ISO_C7 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C8 ISO/DIN C8 (57 x 81 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C8_ENVELOPE ISO_C8 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C9 ISO/DIN C9 (40 x 57 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_C9_ENVELOPE ISO_C9 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_DESIGNATED_LONG ISO Designated Long (110 x 220 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.ISO_DESIGNATED_LONG_ENVELOPE ISO_DESIGNATED_LONG 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ITALY ITALY_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.ITALY_ENVELOPE Italy Envelope (110 x 230 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B0 JIS B0 (1030 x 1456 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B1 JIS B1 (728 x 1030 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B10 JIS B10 (32 x 45 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B2 JIS B2 (515 x 728 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B3 JIS B3 (364 x 515 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B4 JIS B4 (257 x 364 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B5 JIS B5 (182 x 257 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B6 JIS B6 (128 x 182 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B7 JIS B7 (91 x 128 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B8 JIS B8 (64 x 91 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.JIS_B9 JIS B9 (45 x 64 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.LEDGER Ledger (11 x 17 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.LEGAL NA_LEGAL 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.LETTER NA_LETTER 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.MONARCH MONARCH_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.MONARCH_ENVELOPE Monarch Envelope (3 7/8 x 7 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_10X13_ENVELOPE North American (10 x 13 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_10X14_ENVELOPE North American (10 x 14 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_10X15_ENVELOPE North American (10 x 15 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_6X9_ENVELOPE North American (6 x 9 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_7X9_ENVELOPE North American (7 x 9 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_9X11_ENVELOPE North American (9 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_9X12_ENVELOPE North American (9 x 12 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_LEGAL North American Legal (8 1/2 x 14 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_LETTER North American Letter (8 1/2 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_10_ENVELOPE North American #10 Business Envelope (4 1/8 x 9 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_11_ENVELOPE North American #11 Business Envelope (4 1/2 x 10 3/8 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_12_ENVELOPE North American #12 Business Envelope (4 3/4 x 11 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_14_ENVELOPE North American #14 Business Envelope (5 x 11 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NA_NUMBER_9_ENVELOPE North American #9 Business Envelope (3 7/8 x 8 7/8 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.NOTE NA_LETTER 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.PERSONAL PERSONAL_ENVELOPE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.PERSONAL_ENVELOPE 6 3/4 envelope (3 5/8 x 6 1/2 in) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.QUARTO Quarto (215 x 275 mm) 的 MediaType 实例。
static PageAttributes.MediaType | PageAttributes.MediaType.STATEMENT INVOICE 的别名。
static PageAttributes.MediaType | PageAttributes.MediaType.TABLOID LEDGER 的别名。

返回 PageAttributes.MediaType 的 java.awt 中的方法
 PageAttributes.MediaType PageAttributes.getMedia()
返回使用这些属性的页面的纸张尺寸。

参数类型为 PageAttributes.MediaType 的 java.awt 中的方法
 void PageAttributes.setMedia(PageAttributes.MediaType media)
指定使用这些属性的页面所需的纸张尺寸。

参数类型为 PageAttributes.MediaType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PageAttributes.OrientationRequestedType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.OrientationRequestedType
的使用

使用 PageAttributes.OrientationRequestedType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.OrientationRequestedType 的使用

声明为 PageAttributes.OrientationRequestedType 的 java.awt 中的字段
static PageAttributes.OrientationRequestedType | PageAttributes.OrientationRequestedType.LANDSCAPE 用于指定横向方向的 OrientationRequestedType 实例。
static PageAttributes.OrientationRequestedType | PageAttributes.OrientationRequestedType.PORTRAIT 用于指定纵向方向的 OrientationRequestedType 实例。

返回 PageAttributes.OrientationRequestedType 的 java.awt 中的方法
 PageAttributes.OrientationRequestedType PageAttributes.getOrientationRequested()
返回使用这些属性的页面的打印方向。

参数类型为 PageAttributes.OrientationRequestedType 的 java.awt 中的方法
 void PageAttributes.setOrientationRequested(PageAttributes.OrientationRequestedType orientationRequested)
指定使用这些属性的页面的打印方向。

参数类型为 PageAttributes.OrientationRequestedType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PageAttributes.OriginType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.OriginType
的使用

使用 PageAttributes.OriginType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.OriginType 的使用

声明为 PageAttributes.OriginType 的 java.awt 中的字段
static PageAttributes.OriginType | PageAttributes.OriginType.PHYSICAL 用于指定物理原点的 OriginType 实例。
static PageAttributes.OriginType | PageAttributes.OriginType.PRINTABLE 用于指定可打印原点的 OriginType 实例。

返回 PageAttributes.OriginType 的 java.awt 中的方法
 PageAttributes.OriginType PageAttributes.getOrigin()
返回在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。

参数类型为 PageAttributes.OriginType 的 java.awt 中的方法
 void PageAttributes.setOrigin(PageAttributes.OriginType origin)
指定在使用这些属性的页面上的 (0, 0) 绘制的起始位置，即是从逻辑页面的左上角开始绘制，还是从可打印区域的左上角开始绘制。

参数类型为 PageAttributes.OriginType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PageAttributes.PrintQualityType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PageAttributes.PrintQualityType
的使用

使用 PageAttributes.PrintQualityType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PageAttributes.PrintQualityType 的使用

声明为 PageAttributes.PrintQualityType 的 java.awt 中的字段
static PageAttributes.PrintQualityType | PageAttributes.PrintQualityType.DRAFT 用于指定草稿打印质量的 PrintQualityType 实例。
static PageAttributes.PrintQualityType | PageAttributes.PrintQualityType.HIGH 用于指定高打印质量的 PrintQualityType 实例。
static PageAttributes.PrintQualityType | PageAttributes.PrintQualityType.NORMAL 用于指定标准打印质量的 PrintQualityType 实例。

返回 PageAttributes.PrintQualityType 的 java.awt 中的方法
 PageAttributes.PrintQualityType PageAttributes.getPrintQuality()
返回使用这些属性的页面的打印质量。

参数类型为 PageAttributes.PrintQualityType 的 java.awt 中的方法
 void PageAttributes.setPrintQuality(PageAttributes.PrintQualityType printQuality)
指定使用这些属性的页面的打印质量。

参数类型为 PageAttributes.PrintQualityType 的 java.awt 中的构造方法
PageAttributes(PageAttributes.ColorType color, PageAttributes.MediaType media, PageAttributes.OrientationRequestedType orientationRequested, PageAttributes.OriginType origin, PageAttributes.PrintQualityType printQuality, int[] printerResolution)
构造一个具有每个属性的指定值的 PageAttributes 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.PaintContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.PaintContext
的使用

使用 PaintContext 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PaintContext 的使用

返回 PaintContext 的 java.awt 中的方法
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Polygon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Polygon
的使用

使用 Polygon 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Polygon 的使用

参数类型为 Polygon 的 java.awt 中的方法
void | Graphics.drawPolygon(Polygon p) 绘制由指定的 Polygon 对象定义的多边形边框。
void | Graphics.fillPolygon(Polygon p) 用图形上下文的当前颜色填充指定 Polygon 对象定义的多边形。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PrintJob
的使用

使用 PrintJob 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PrintJob 的使用

返回 PrintJob 的 java.awt 中的方法
PrintJob | PrintGraphics.getPrintJob() 返回从其产生 PrintGraphics 对象的 PrintJob 对象。
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
abstract PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.RadialGradientPaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.RadialGradientPaint
的使用

没有 java.awt.RadialGradientPaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.ScrollPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ScrollPane
的使用

使用 ScrollPane 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 ScrollPane 的使用

参数类型为 ScrollPane 的 java.awt 中的方法
protected abstract  java.awt.peer.ScrollPanePeer Toolkit.createScrollPane(ScrollPane target)
使用指定同位体接口创建此工具包的 ScrollPane 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.ScrollPane.AccessibleAWTScrollPane 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ScrollPane.AccessibleAWTScrollPane
的使用

没有 java.awt.ScrollPane.AccessibleAWTScrollPane 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.ScrollPaneAdjustable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ScrollPaneAdjustable
的使用

没有 java.awt.ScrollPaneAdjustable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Scrollbar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Scrollbar
的使用

使用 Scrollbar 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Scrollbar 的使用

参数类型为 Scrollbar 的 java.awt 中的方法
protected abstract  java.awt.peer.ScrollbarPeer Toolkit.createScrollbar(Scrollbar target)
使用指定同位体接口创建此工具包的 Scrollbar 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Scrollbar.AccessibleAWTScrollBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Scrollbar.AccessibleAWTScrollBar
的使用

没有 java.awt.Scrollbar.AccessibleAWTScrollBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.SplashScreen 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.SplashScreen
的使用

使用 SplashScreen 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 SplashScreen 的使用

返回 SplashScreen 的 java.awt 中的方法
static SplashScreen SplashScreen.getSplashScreen()
返回用于 Java 启动闪现屏幕控制的 SplashScreen 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.SystemTray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.SystemTray
的使用

使用 SystemTray 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 SystemTray 的使用

返回 SystemTray 的 java.awt 中的方法
static SystemTray SystemTray.getSystemTray()
获取表示桌面托盘区的 SystemTray 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TextArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextArea
的使用

使用 TextArea 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextArea 的使用

参数类型为 TextArea 的 java.awt 中的方法
protected abstract  java.awt.peer.TextAreaPeer Toolkit.createTextArea(TextArea target)
使用指定同位体接口创建此工具包的 TextArea 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TextArea.AccessibleAWTTextArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextArea.AccessibleAWTTextArea
的使用

没有 java.awt.TextArea.AccessibleAWTTextArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TextComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextComponent
的使用

使用 TextComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextComponent 的使用

java.awt 中 TextComponent 的子类
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextField TextField 对象是允许编辑单行文本的文本组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TextComponent.AccessibleAWTTextComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextComponent.AccessibleAWTTextComponent
的使用

使用 TextComponent.AccessibleAWTTextComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextComponent.AccessibleAWTTextComponent 的使用

java.awt 中 TextComponent.AccessibleAWTTextComponent 的子类
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextField
的使用

使用 TextField 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TextField 的使用

参数类型为 TextField 的 java.awt 中的方法
protected abstract  java.awt.peer.TextFieldPeer Toolkit.createTextField(TextField target)
使用指定同位体接口创建此工具包的 TextField 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TextField.AccessibleAWTTextField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TextField.AccessibleAWTTextField
的使用

没有 java.awt.TextField.AccessibleAWTTextField 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TexturePaint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TexturePaint
的使用

没有 java.awt.TexturePaint 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TrayIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TrayIcon
的使用

使用 TrayIcon 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TrayIcon 的使用

返回 TrayIcon 的 java.awt 中的方法
 TrayIcon[] SystemTray.getTrayIcons()
返回由此应用程序添加到托盘中的所有图标的数组。

参数类型为 TrayIcon 的 java.awt 中的方法
void | SystemTray.add(TrayIcon trayIcon) 将 TrayIcon 添加到 SystemTray。
void | SystemTray.remove(TrayIcon trayIcon) 从 SystemTray 中移除指定的 TrayIcon。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.TrayIcon.MessageType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.TrayIcon.MessageType
的使用

使用 TrayIcon.MessageType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 TrayIcon.MessageType 的使用

返回 TrayIcon.MessageType 的 java.awt 中的方法
static TrayIcon.MessageType | TrayIcon.MessageType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TrayIcon.MessageType[] | TrayIcon.MessageType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 TrayIcon.MessageType 的 java.awt 中的方法
 void TrayIcon.displayMessage(String caption, String text, TrayIcon.MessageType messageType)
在托盘图标附近显示弹出消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MenuShortcut 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuShortcut
的使用

使用 MenuShortcut 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuShortcut 的使用

返回 MenuShortcut 的 java.awt 中的方法
 MenuShortcut MenuItem.getShortcut()
获取与此菜单项关联的 MenuShortcut 对象。

返回变量类型为 MenuShortcut 的类型的 java.awt 中的方法
 Enumeration<MenuShortcut> MenuBar.shortcuts()
获取此菜单栏正在管理的所有菜单快捷方式的枚举。

参数类型为 MenuShortcut 的 java.awt 中的方法
void | MenuBar.deleteShortcut(MenuShortcut s) 删除指定的菜单快捷方式。
boolean | MenuShortcut.equals(MenuShortcut s) 返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。
MenuItem | MenuBar.getShortcutMenuItem(MenuShortcut s) 获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。
void | MenuItem.setShortcut(MenuShortcut s) 设置与此菜单项关联的 MenuShortcut 对象。

参数类型为 MenuShortcut 的 java.awt 中的构造方法
MenuItem(String label, MenuShortcut s)
创建具有关联的键盘快捷方式的菜单项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.AWTPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTPermission
的使用

没有 java.awt.AWTPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GridLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GridLayout
的使用

没有 java.awt.GridLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.PrintGraphics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.PrintGraphics
的使用

没有 java.awt.PrintGraphics 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MenuBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuBar
的使用

使用 MenuBar 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuBar 的使用

返回 MenuBar 的 java.awt 中的方法
 MenuBar Frame.getMenuBar()
获取此窗体的菜单栏。

参数类型为 MenuBar 的 java.awt 中的方法
protected abstract java.awt.peer.MenuBarPeer | Toolkit.createMenuBar(MenuBar target) 使用指定同位体接口创建此工具包的 MenuBar 实现。
void | Frame.setMenuBar(MenuBar mb) 将此窗体的菜单栏设置为指定的菜单栏。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MenuBar.AccessibleAWTMenuBar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuBar.AccessibleAWTMenuBar
的使用

没有 java.awt.MenuBar.AccessibleAWTMenuBar 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Panel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Panel
的使用

使用 Panel 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.applet 中 Panel 的使用

java.applet 中 Panel 的子类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Panel 的使用

参数类型为 Panel 的 java.awt 中的方法
protected abstract  java.awt.peer.PanelPeer Toolkit.createPanel(Panel target)
使用指定同位体接口创建此工具包的 Panel 实现。

javax.swing 中 Panel 的使用

javax.swing 中 Panel 的子类
 class JApplet
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Panel.AccessibleAWTPanel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Panel.AccessibleAWTPanel
的使用

使用 Panel.AccessibleAWTPanel 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.applet 中 Panel.AccessibleAWTPanel 的使用

java.applet 中 Panel.AccessibleAWTPanel 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

javax.swing 中 Panel.AccessibleAWTPanel 的使用

javax.swing 中 Panel.AccessibleAWTPanel 的子类
protected  class JApplet.AccessibleJApplet
此类实现对 JApplet 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.Adjustable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Adjustable
的使用

使用 Adjustable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Adjustable 的使用

实现 Adjustable 的 java.awt 中的类
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPaneAdjustable 此类表示 ScrollPane 的水平或垂直滚动条的状态。

返回 Adjustable 的 java.awt 中的方法
Adjustable | ScrollPane.getHAdjustable() 返回表示水平滚动条状态的 ScrollPaneAdjustable 对象。
Adjustable | ScrollPane.getVAdjustable() 返回表示垂直滚动条状态的 ScrollPaneAdjustable 对象。

java.awt.event 中 Adjustable 的使用

返回 Adjustable 的 java.awt.event 中的方法
 Adjustable AdjustmentEvent.getAdjustable()
返回发起此事件的 Adjustable 对象。

参数类型为 Adjustable 的 java.awt.event 中的构造方法
AdjustmentEvent(Adjustable source, int id, int type, int value)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。
AdjustmentEvent(Adjustable source, int id, int type, int value, boolean isAdjusting)
用指定的 Adjustable 源、事件类型、调整类型和值构造一个 AdjustmentEvent 对象。

javax.swing 中 Adjustable 的使用

实现 Adjustable 的 javax.swing 中的类
class | JScrollBar 滚动条的实现。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.CardLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.CardLayout
的使用

没有 java.awt.CardLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.AWTEventMulticaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTEventMulticaster
的使用

没有 java.awt.AWTEventMulticaster 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Canvas 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Canvas
的使用

使用 Canvas 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Canvas 的使用

参数类型为 Canvas 的 java.awt 中的方法
protected abstract  java.awt.peer.CanvasPeer Toolkit.createCanvas(Canvas target)
使用指定同位体接口创建此工具包的 Canvas 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.FontFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FontFormatException
的使用

使用 FontFormatException 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 FontFormatException 的使用

抛出 FontFormatException 的 java.awt 中的方法
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
static Font | Font.createFont(int fontFormat, InputStream fontStream) 返回一个使用指定字体类型和输入数据的新 Font。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Canvas.AccessibleAWTCanvas 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Canvas.AccessibleAWTCanvas
的使用

没有 java.awt.Canvas.AccessibleAWTCanvas 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MediaTracker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MediaTracker
的使用

使用 MediaTracker 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 MediaTracker 的使用

声明为 MediaTracker 的 javax.swing 中的字段
protected static MediaTracker ImageIcon.tracker

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.ItemSelectable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.ItemSelectable
的使用

使用 ItemSelectable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

java.awt 中 ItemSelectable 的使用

实现 ItemSelectable 的 java.awt 中的类
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Choice Choice 类表示一个弹出式选择菜单。
class | List List 组件为用户提供了一个可滚动的文本项列表。

java.awt.event 中 ItemSelectable 的使用

返回 ItemSelectable 的 java.awt.event 中的方法
 ItemSelectable ItemEvent.getItemSelectable()
返回事件的产生程序。

参数类型为 ItemSelectable 的 java.awt.event 中的构造方法
ItemEvent(ItemSelectable source, int id, Object item, int stateChange)
构造一个 ItemEvent 对象。

javax.swing 中 ItemSelectable 的使用

javax.swing 中 ItemSelectable 的子接口
 interface ButtonModel
按钮的状态模型。

实现 ItemSelectable 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | DefaultButtonModel Button 组件的数据模型的默认实现。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuItem 菜单中的项的实现。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
static class | JToggleButton.ToggleButtonModel ToggleButton 模型。

javax.swing.plaf.basic 中 ItemSelectable 的使用

实现 ItemSelectable 的 javax.swing.plaf.basic 中的类
 class BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

javax.swing.plaf.metal 中 ItemSelectable 的使用

实现 ItemSelectable 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.FlowLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FlowLayout
的使用

没有 java.awt.FlowLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.FontMetrics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FontMetrics
的使用

使用 FontMetrics 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 FontMetrics 的使用

返回 FontMetrics 的 java.awt 中的方法
FontMetrics | Graphics.getFontMetrics() 获取当前字体的字体规格。
FontMetrics | List.AccessibleAWTList.AccessibleAWTListChild.getFontMetrics(Font f) 设置此对象的 FontMetrics。
FontMetrics | MenuComponent.AccessibleAWTMenuComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
abstract FontMetrics | Graphics.getFontMetrics(Font f) 获取指定字体的字体规格。
abstract FontMetrics | Toolkit.getFontMetrics(Font font) 已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
FontMetrics | Component.getFontMetrics(Font font) 获取指定字体的字体规格。
FontMetrics | Component.AccessibleAWTComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。

javax.accessibility 中 FontMetrics 的使用

返回 FontMetrics 的 javax.accessibility 中的方法
 FontMetrics AccessibleComponent.getFontMetrics(Font f)
获取此对象的 FontMetrics。

javax.swing 中 FontMetrics 的使用

返回 FontMetrics 的 javax.swing 中的方法
FontMetrics | DebugGraphics.getFontMetrics() 重写 Graphics.getFontMetrics。
FontMetrics | DebugGraphics.getFontMetrics(Font f) 重写 Graphics.getFontMetrics。
FontMetrics | JTree.AccessibleJTree.AccessibleJTreeNode.getFontMetrics(Font f)
FontMetrics | JTable.AccessibleJTable.AccessibleJTableCell.getFontMetrics(Font f) 获取此对象的 FontMetrics。
FontMetrics | JList.AccessibleJList.AccessibleJListChild.getFontMetrics(Font f)
FontMetrics | JComponent.getFontMetrics(Font font) 获取指定 Font 的 FontMetrics。

参数类型为 FontMetrics 的 javax.swing 中的方法
static int | SwingUtilities.computeStringWidth(FontMetrics fm, String str) 使用具有指定“规格”（大小）的字体计算字符串的宽度。
static String | SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap) 计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static String | SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap) 计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

javax.swing.plaf.basic 中 FontMetrics 的使用

返回 FontMetrics 的 javax.swing.plaf.basic 中的方法
protected  FontMetrics BasicTabbedPaneUI.getFontMetrics()

参数类型为 FontMetrics 的 javax.swing.plaf.basic 中的方法
protected  int BasicTabbedPaneUI.calculateTabWidth(int tabPlacement, int tabIndex, FontMetrics metrics)
protected  String BasicInternalFrameTitlePane.getTitle(String text, FontMetrics fm, int availTextWidth)
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)

javax.swing.plaf.synth 中 FontMetrics 的使用

参数类型为 FontMetrics 的 javax.swing.plaf.synth 中的方法
int | SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text) 返回传入字符串的大小。
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。

javax.swing.table 中 FontMetrics 的使用

返回 FontMetrics 的 javax.swing.table 中的方法
 FontMetrics JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFontMetrics(Font f)

javax.swing.text 中 FontMetrics 的使用

声明为 FontMetrics 的 javax.swing.text 中的字段
protected  FontMetrics PlainView.metrics
当前字体的字体规格。

返回 FontMetrics 的 javax.swing.text 中的方法
protected FontMetrics | LabelView.getFontMetrics() 已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。
protected FontMetrics | FieldView.getFontMetrics() 获取与承载此视图组件相关的字体规格。
FontMetrics | StyleContext.getFontMetrics(Font f) 获取某种字体的字体规格。

参数类型为 FontMetrics 的 javax.swing.text 中的方法
static int | Utilities.getBreakLocation(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定对给定文本进行拆分的位置，以符合给定的跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset) 确定给定文本中的某个相对偏移量，使其能最好的表示视图坐标系统中的给定跨距。
static int | Utilities.getTabbedTextOffset(Segment s, FontMetrics metrics, int x0, int x, TabExpander e, int startOffset, boolean round)
static int | Utilities.getTabbedTextWidth(Segment s, FontMetrics metrics, int x, TabExpander e, int startOffset) 确定给定的考虑制表符的文本段的宽度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Image 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Image
的使用

使用 Image 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 Image 的使用

返回 Image 的 java.applet 中的方法
Image | AppletContext.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url, String name) 返回能被绘制到屏幕上的 Image 对象。

java.awt 中 Image 的使用

声明为 Image 的 java.awt 中的字段
protected  Image Component.FlipBufferStrategy.drawBuffer
绘制缓冲区。

返回 Image 的 java.awt 中的方法
Image | Toolkit.createImage(byte[] imagedata) 创建一幅图像，该图像对存储在指定字节数组中的图像进行解码。
abstract Image | Toolkit.createImage(byte[] imagedata, int imageoffset, int imagelength) 创建一幅图像，该图像对存储在指定字节数组中指定偏移量和长度处的图像进行解码。
abstract Image | Toolkit.createImage(ImageProducer producer) 使用指定的图像生成器创建一幅图像。
Image | Component.createImage(ImageProducer producer) 根据指定的图像生成器创建一幅图像。
Image | Component.createImage(int width, int height) 创建一幅用于双缓冲的、可在屏幕外绘制的图像。
abstract Image | Toolkit.createImage(String filename) 返回从指定文件获取像素数据的图像。
abstract Image | Toolkit.createImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
protected Image | Component.FlipBufferStrategy.getBackBuffer()
Image | Frame.getIconImage() 返回要作为此窗体图标显示的图像。
Image | TrayIcon.getImage() 返回用于此 TrayIcon 的当前图像。
abstract Image | Toolkit.getImage(String filename) 返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。
abstract Image | Toolkit.getImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
Image | Image.getScaledInstance(int width, int height, int hints) 创建此图像的缩放版本。

返回变量类型为 Image 的类型的 java.awt 中的方法
 List<Image> Window.getIconImages()
返回要作为此窗口的图标显示的图像序列。

参数类型为 Image 的 java.awt 中的方法
void | MediaTracker.addImage(Image image, int id) 向此媒体跟踪器正在跟踪的图像列表添加一个图像。
void | MediaTracker.addImage(Image image, int id, int w, int h) 向此媒体跟踪器正在跟踪的图像列表添加一个经过缩放的图像。
int | Component.checkImage(Image image, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
abstract int | Toolkit.checkImage(Image image, int width, int height, ImageObserver observer) 指示正准备显示的指定图像的构造状态。
int | Component.checkImage(Image image, int width, int height, ImageObserver observer) 返回指定图像屏幕表示的构造状态。
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
abstract boolean | Graphics2D.drawImage(Image img, AffineTransform xform, ImageObserver obs) 呈现一个图像，在绘制前进行从图像空间到用户空间的转换。
abstract boolean | Graphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
boolean | Component.imageUpdate(Image img, int infoflags, int x, int y, int w, int h) 图像已改变时重绘组件。
boolean | Component.prepareImage(Image image, ImageObserver observer) 准备一幅在此组件上呈现的图像。
abstract boolean | Toolkit.prepareImage(Image image, int width, int height, ImageObserver observer) 准备一个用于呈现的图像。
boolean | Component.prepareImage(Image image, int width, int height, ImageObserver observer) 以指定的宽度和高度准备一幅在此组件上呈现的图像。
void | MediaTracker.removeImage(Image image) 从此媒体跟踪器移除指定的图像。
void | MediaTracker.removeImage(Image image, int id) 从此媒体跟踪器的指定跟踪 ID 中移除指定的图像。
void | MediaTracker.removeImage(Image image, int id, int width, int height) 从此媒体跟踪器移除具有指定宽度、高度和 ID 的指定图像。
void | Frame.setIconImage(Image image) 设置要作为此窗口图标显示的图像。
void | Window.setIconImage(Image image) 设置要作为此窗口图标显示的图像。
void | TrayIcon.setImage(Image image) 设置此 TrayIcon 的图像。

类型变量类型为 Image 的 java.awt 中的方法参数
 void Window.setIconImages(List<? extends Image> icons)
设置要作为此窗口的图标显示的图像序列。

参数类型为 Image 的 java.awt 中的构造方法
TrayIcon(Image image)
创建带有指定图像的 TrayIcon。
TrayIcon(Image image, String tooltip)
创建带有指定图像和工具提示文本的 TrayIcon。
TrayIcon(Image image, String tooltip, PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。

java.awt.dnd 中 Image 的使用

参数类型为 Image 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 Image 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

java.awt.font 中 Image 的使用

参数类型为 Image 的 java.awt.font 中的构造方法
ImageGraphicAttribute(Image image, int alignment)
根据指定的 Image 构造一个 ImageGraphicAttribute。
ImageGraphicAttribute(Image image, int alignment, float originX, float originY)
根据指定的 Image 构造一个 ImageGraphicAttribute。

java.awt.im.spi 中 Image 的使用

返回 Image 的 java.awt.im.spi 中的方法
 Image InputMethodDescriptor.getInputMethodIcon(Locale inputLocale)
返回相应输入方法的图标。

java.awt.image 中 Image 的使用

java.awt.image 中 Image 的子类
class | BufferedImage BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
class | VolatileImage VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。

参数类型为 Image 的 java.awt.image 中的方法
 boolean ImageObserver.imageUpdate(Image img, int infoflags, int x, int y, int width, int height)
当以前使用异步接口所请求的图像的信息变得可用时就调用此方法。

参数类型为 Image 的 java.awt.image 中的构造方法
PixelGrabber(Image img, int x, int y, int w, int h, boolean forceRGB)
创建一个 PixelGrabber 对象，以从指定的图像中抓取像素矩形部分 (x, y, w, h)。
PixelGrabber(Image img, int x, int y, int w, int h, int[] pix, int off, int scansize)
创建一个 PixelGrabber 对象，以从指定图像将像素矩形部分 (x, y, w, h) 抓取到给定的数组中。

java.beans 中 Image 的使用

返回 Image 的 java.beans 中的方法
Image | BeanInfo.getIcon(int iconKind) 此方法返回一个图像对象，可用该对象表示工具框、工具栏等中的 bean。
Image | SimpleBeanInfo.getIcon(int iconKind) 声明没有可用的图标。
Image | SimpleBeanInfo.loadImage(String resourceName) 这是帮助加载图标图像的实用工具方法。

javax.swing 中 Image 的使用

声明为 Image 的 javax.swing 中的字段
protected  Image JViewport.backingStoreImage
用于后备存储的视图图像。

返回 Image 的 javax.swing 中的方法
static Image | GrayFilter.createDisabledImage(Image i) 创建一个禁用图像
Image | ImageIcon.getImage() 返回此图标的 Image。
Image | RepaintManager.getOffscreenBuffer(Component c, int proposedWidth, int proposedHeight) 返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。
Image | RepaintManager.getVolatileOffscreenBuffer(Component c, int proposedWidth, int proposedHeight) 返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。

参数类型为 Image 的 javax.swing 中的方法
static Image | GrayFilter.createDisabledImage(Image i) 创建一个禁用图像
boolean | DebugGraphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 重写 Graphics.drawImage。
boolean | AbstractButton.imageUpdate(Image img, int infoflags, int x, int y, int w, int h) 重写的此方法在当前 Icon 的 Image 不等于传入的 Image img 时返回 false。
boolean | JLabel.imageUpdate(Image img, int infoflags, int x, int y, int w, int h) 如果当前图标的图像不等于传入的图像 img，则重写此方法以返回 false。
protected void | ImageIcon.loadImage(Image image) 加载图像，并且只在图像已加载时返回。
void | JFrame.setIconImage(Image image) 设置要作为此窗口图标显示的图像。
void | ImageIcon.setImage(Image image) 设置由此图标显示的图像。

参数类型为 Image 的 javax.swing 中的构造方法
ImageIcon(Image image)
根据图像对象创建一个 ImageIcon。
ImageIcon(Image image, String description)
根据图像创建一个 ImageIcon。

javax.swing.text.html 中 Image 的使用

返回 Image 的 javax.swing.text.html 中的方法
 Image ImageView.getImage()
返回要呈现的图像。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PointerInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PointerInfo
的使用

使用 PointerInfo 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PointerInfo 的使用

返回 PointerInfo 的 java.awt 中的方法
static PointerInfo MouseInfo.getPointerInfo()
返回表示鼠标指针当前位置的 PointerInfo 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.BufferCapabilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BufferCapabilities
的使用

使用 BufferCapabilities 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 BufferCapabilities 的使用

声明为 BufferCapabilities 的 java.awt 中的字段
protected BufferCapabilities | Component.FlipBufferStrategy.caps 缓冲能力。
protected BufferCapabilities | Component.BltBufferStrategy.caps 缓冲区能力

返回 BufferCapabilities 的 java.awt 中的方法
BufferCapabilities | GraphicsConfiguration.getBufferCapabilities() 返回此 GraphicsConfiguration 的缓冲区能力。
BufferCapabilities | Component.FlipBufferStrategy.getCapabilities()
BufferCapabilities | Component.BltBufferStrategy.getCapabilities()

参数类型为 BufferCapabilities 的 java.awt 中的方法
protected void | Component.FlipBufferStrategy.createBuffers(int numBuffers, BufferCapabilities caps) 创建一个或多个具有给定能力的、复杂的翻转缓冲区。
void | Canvas.createBufferStrategy(int numBuffers, BufferCapabilities caps) 创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。
void | Window.createBufferStrategy(int numBuffers, BufferCapabilities caps) 根据所需缓冲区能力为此组件上的多缓冲创建新策略。

参数类型为 BufferCapabilities 的 java.awt 中的构造方法
Component.BltBufferStrategy(int numBuffers, BufferCapabilities caps)
围绕组件创建一个新的 blt 缓冲区策略
Component.FlipBufferStrategy(int numBuffers, BufferCapabilities caps)
为此组件创建新的翻转缓冲区策略。

java.awt.image 中 BufferCapabilities 的使用

返回 BufferCapabilities 的 java.awt.image 中的方法
abstract  BufferCapabilities BufferStrategy.getCapabilities()
返回此 BufferStrategy 的 BufferCapabilities。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.BufferCapabilities.FlipContents 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BufferCapabilities.FlipContents
的使用

使用 BufferCapabilities.FlipContents 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 BufferCapabilities.FlipContents 的使用

声明为 BufferCapabilities.FlipContents 的 java.awt 中的字段
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.BACKGROUND 当翻转内容为 BACKGROUND 时，后台缓冲区的内容在翻转后使用背景颜色清除。
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.COPIED 当翻转内容为 COPIED 时，翻转时将后台缓冲区的内容复制到前台缓冲区。
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.PRIOR 当翻转内容为 PRIOR 时，后台缓冲区的内容为前台缓冲区的先前内容（真实的页面翻转）。
static BufferCapabilities.FlipContents | BufferCapabilities.FlipContents.UNDEFINED 当翻转内容为 UNDEFINED 时，后台缓冲区的内容在翻转后是不明确的。

返回 BufferCapabilities.FlipContents 的 java.awt 中的方法
 BufferCapabilities.FlipContents BufferCapabilities.getFlipContents()

参数类型为 BufferCapabilities.FlipContents 的 java.awt 中的方法
protected  void Component.FlipBufferStrategy.flip(BufferCapabilities.FlipContents flipAction)
将底层缓冲区的内容翻转移动到前台缓冲区，可通过复制或移动视频指针来执行。

参数类型为 BufferCapabilities.FlipContents 的 java.awt 中的构造方法
BufferCapabilities(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
创建一个指定缓冲区能力的新对象

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Event
的使用

使用 Event 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Event 的使用

声明为 Event 的 java.awt 中的字段
 Event Event.evt
下一事件。

参数类型为 Event 的 java.awt 中的方法
boolean | Component.action(Event evt, Object what) 已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
void | Container.deliverEvent(Event e) 已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
void | Component.deliverEvent(Event e) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
boolean | Component.gotFocus(Event evt, Object what) 已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
boolean | Component.handleEvent(Event evt) 已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
boolean | Component.keyDown(Event evt, int key) 已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
boolean | Component.keyUp(Event evt, int key) 已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
boolean | Component.lostFocus(Event evt, Object what) 已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
boolean | Component.mouseDown(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | Component.mouseDrag(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
boolean | Component.mouseEnter(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | Component.mouseExit(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | Component.mouseMove(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
boolean | Component.mouseUp(Event evt, int x, int y) 已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
boolean | MenuComponent.postEvent(Event evt) 已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。
boolean | Window.postEvent(Event e) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
boolean | Component.postEvent(Event e) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
boolean | MenuContainer.postEvent(Event evt) 已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。

参数类型为 Event 的 java.awt 中的构造方法
AWTEvent(Event event)
从 1.0 样式的事件参数构造一个 AWTEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PopupMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PopupMenu
的使用

使用 PopupMenu 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 PopupMenu 的使用

返回 PopupMenu 的 java.awt 中的方法
 PopupMenu TrayIcon.getPopupMenu()
返回与此 TrayIcon 关联的弹出菜单。

参数类型为 PopupMenu 的 java.awt 中的方法
void | Component.add(PopupMenu popup) 向组件添加指定的弹出菜单。
protected abstract java.awt.peer.PopupMenuPeer | Toolkit.createPopupMenu(PopupMenu target) 使用指定同位体接口创建此工具包的 PopupMenu 实现。
void | TrayIcon.setPopupMenu(PopupMenu popup) 设置此 TrayIcon 的弹出菜单。

参数类型为 PopupMenu 的 java.awt 中的构造方法
TrayIcon(Image image, String tooltip, PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.PopupMenu.AccessibleAWTPopupMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.PopupMenu.AccessibleAWTPopupMenu
的使用

没有 java.awt.PopupMenu.AccessibleAWTPopupMenu 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Menu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Menu
的使用

使用 Menu 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Menu 的使用

java.awt 中 Menu 的子类
 class PopupMenu
此类实现能够在组件中的指定位置上动态弹出的菜单。

返回 Menu 的 java.awt 中的方法
Menu | MenuBar.add(Menu m) 将指定的菜单添加到菜单栏。
Menu | MenuBar.getHelpMenu() 获取该菜单栏上的帮助菜单。
Menu | MenuBar.getMenu(int i) 获取指定的菜单。

参数类型为 Menu 的 java.awt 中的方法
Menu | MenuBar.add(Menu m) 将指定的菜单添加到菜单栏。
protected abstract java.awt.peer.MenuPeer | Toolkit.createMenu(Menu target) 使用指定同位体接口创建此工具包的 Menu 实现。
void | MenuBar.setHelpMenu(Menu m) 将指定的菜单设置为此菜单栏的帮助菜单。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Menu.AccessibleAWTMenu 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Menu.AccessibleAWTMenu
的使用

使用 Menu.AccessibleAWTMenu 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Menu.AccessibleAWTMenu 的使用

java.awt 中 Menu.AccessibleAWTMenu 的子类
protected  class PopupMenu.AccessibleAWTPopupMenu
用于为可访问性提供默认支持的 PopupMenu 的内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuItem
的使用

使用 MenuItem 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuItem 的使用

java.awt 中 MenuItem 的子类
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。

返回 MenuItem 的 java.awt 中的方法
MenuItem | Menu.add(MenuItem mi) 将指定的菜单项添加到此菜单。
MenuItem | Menu.getItem(int index) 获取此菜单的指定索引处的项。
MenuItem | MenuBar.getShortcutMenuItem(MenuShortcut s) 获取与指定 MenuShortcut 对象关联的 MenuItem 的实例，如果此菜单栏正在管理的菜单项均与指定的菜单快捷方式无关联，则为 null。

参数类型为 MenuItem 的 java.awt 中的方法
MenuItem | Menu.add(MenuItem mi) 将指定的菜单项添加到此菜单。
protected abstract java.awt.peer.MenuItemPeer | Toolkit.createMenuItem(MenuItem target) 使用指定同位体接口创建此工具包的 MenuItem 实现。
void | Menu.insert(MenuItem menuitem, int index) 将菜单项插入到此菜单的指定位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MenuComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuComponent
的使用

使用 MenuComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuComponent 的使用

java.awt 中 MenuComponent 的子类
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
class | MenuItem 菜单中的所有项必须属于类 MenuItem 或其子类之一。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。

参数类型为 MenuComponent 的 java.awt 中的方法
void | MenuBar.remove(MenuComponent m) 从此菜单栏移除指定的菜单组件。
void | Menu.remove(MenuComponent item) 从此菜单移除指定的菜单项。
void | Frame.remove(MenuComponent m) 从此窗体移除指定的菜单栏。
void | Component.remove(MenuComponent popup) 从组件移除指定的弹出菜单。
void | MenuContainer.remove(MenuComponent comp)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MenuItem.AccessibleAWTMenuItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuItem.AccessibleAWTMenuItem
的使用

使用 MenuItem.AccessibleAWTMenuItem 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuItem.AccessibleAWTMenuItem 的使用

java.awt 中 MenuItem.AccessibleAWTMenuItem 的子类
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.MenuComponent.AccessibleAWTMenuComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.MenuComponent.AccessibleAWTMenuComponent
的使用

使用 MenuComponent.AccessibleAWTMenuComponent 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 MenuComponent.AccessibleAWTMenuComponent 的使用

java.awt 中 MenuComponent.AccessibleAWTMenuComponent 的子类
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.HeadlessException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.HeadlessException
的使用

使用 HeadlessException 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.applet 中 HeadlessException 的使用

抛出 HeadlessException 的 java.applet 中的构造方法
Applet()
构造一个新 Applet。

java.awt 中 HeadlessException 的使用

抛出 HeadlessException 的 java.awt 中的方法
protected abstract java.awt.peer.ButtonPeer | Toolkit.createButton(Button target) 使用指定同位体接口创建此工具包的 Button 实现。
protected abstract java.awt.peer.CheckboxPeer | Toolkit.createCheckbox(Checkbox target) 使用指定同位体接口创建此工具包的 Checkbox 实现。
protected abstract java.awt.peer.CheckboxMenuItemPeer | Toolkit.createCheckboxMenuItem(CheckboxMenuItem target) 使用指定同位体接口创建此工具包的 CheckboxMenuItem 实现。
protected abstract java.awt.peer.ChoicePeer | Toolkit.createChoice(Choice target) 使用指定同位体接口创建此工具包的 Choice 实现。
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
protected abstract java.awt.peer.DesktopPeer | Toolkit.createDesktopPeer(Desktop target) 使用指定的同位体接口创建此工具包的 Desktop 实现。
protected abstract java.awt.peer.DialogPeer | Toolkit.createDialog(Dialog target) 使用指定同位体接口创建此工具包的 Dialog 实现。
protected abstract java.awt.peer.FileDialogPeer | Toolkit.createFileDialog(FileDialog target) 使用指定同位体接口创建此工具包的 FileDialog 实现。
protected abstract java.awt.peer.FramePeer | Toolkit.createFrame(Frame target) 使用指定同位体接口创建此工具包的 Frame 实现。
protected abstract java.awt.peer.LabelPeer | Toolkit.createLabel(Label target) 使用指定同位体接口创建此工具包的 Label 实现。
protected abstract java.awt.peer.ListPeer | Toolkit.createList(List target) 使用指定同位体接口创建此工具包的 List 实现。
protected abstract java.awt.peer.MenuPeer | Toolkit.createMenu(Menu target) 使用指定同位体接口创建此工具包的 Menu 实现。
protected abstract java.awt.peer.MenuBarPeer | Toolkit.createMenuBar(MenuBar target) 使用指定同位体接口创建此工具包的 MenuBar 实现。
protected abstract java.awt.peer.MenuItemPeer | Toolkit.createMenuItem(MenuItem target) 使用指定同位体接口创建此工具包的 MenuItem 实现。
protected abstract java.awt.peer.PopupMenuPeer | Toolkit.createPopupMenu(PopupMenu target) 使用指定同位体接口创建此工具包的 PopupMenu 实现。
protected abstract java.awt.peer.ScrollbarPeer | Toolkit.createScrollbar(Scrollbar target) 使用指定同位体接口创建此工具包的 Scrollbar 实现。
protected abstract java.awt.peer.ScrollPanePeer | Toolkit.createScrollPane(ScrollPane target) 使用指定同位体接口创建此工具包的 ScrollPane 实现。
protected abstract java.awt.peer.TextAreaPeer | Toolkit.createTextArea(TextArea target) 使用指定同位体接口创建此工具包的 TextArea 实现。
protected abstract java.awt.peer.TextFieldPeer | Toolkit.createTextField(TextField target) 使用指定同位体接口创建此工具包的 TextField 实现。
protected abstract java.awt.peer.WindowPeer | Toolkit.createWindow(Window target) 使用指定同位体接口创建此工具包的 Window 实现。
Dimension | Toolkit.getBestCursorSize(int preferredWidth, int preferredHeight) 返回最接近所需大小的受支持光标尺寸。
Point | GraphicsEnvironment.getCenterPoint() 返回 Windows 应居中的点。
abstract ColorModel | Toolkit.getColorModel() 确定此工具包屏幕的颜色模型。
abstract GraphicsDevice | GraphicsEnvironment.getDefaultScreenDevice() 返回默认的屏幕 GraphicsDevice。
int | Toolkit.getMaximumCursorColors() 返回自定义光标调色板中 Toolkit 支持的最大颜色数。
Rectangle | GraphicsEnvironment.getMaximumWindowBounds() 返回居中 Windows 的最大边界。
int | Toolkit.getMenuShortcutKeyMask() 确定哪一个修改键是菜单快捷方式的适当加速键。
Point | Component.getMousePosition() 如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。
Point | Container.getMousePosition(boolean allowChildren) 如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。
static int | MouseInfo.getNumberOfButtons() 返回鼠标上的按钮数。
static PointerInfo | MouseInfo.getPointerInfo() 返回表示鼠标指针当前位置的 PointerInfo 实例。
abstract GraphicsDevice[] | GraphicsEnvironment.getScreenDevices() 返回所有屏幕 GraphicsDevice 对象组成的数组。
Insets | Toolkit.getScreenInsets(GraphicsConfiguration gc) 获得屏幕的 insets。
abstract int | Toolkit.getScreenResolution() 返回屏幕分辨率，以每英寸的点数为单位。
abstract Dimension | Toolkit.getScreenSize() 获取屏幕的大小。
abstract Clipboard | Toolkit.getSystemClipboard() 获取系统 Clipboard 的一个实例，该 Clipboard 可作为本机平台提供的剪贴板工具的接口。
static Cursor | Cursor.getSystemCustomCursor(String name) 返回与指定名称匹配的特定于系统的定制光标对象。
Clipboard | Toolkit.getSystemSelection() 以 Clipboard 对象的形式获取系统选择的一个实例。
boolean | Toolkit.isDynamicLayoutActive() 返回当前是否激活了调整大小时的动态布局（以编程方式设置，并受底层操作系统和/或窗口管理器支持）。
protected boolean | Toolkit.isDynamicLayoutSet() 返回 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。
boolean | Toolkit.isFrameStateSupported(int state) 返回 Toolkit 是否支持 Frame 状态。
protected void | Toolkit.loadSystemColors(int[] systemColors) 使用当前系统颜色值填充作为参数提供的整数数组。
abstract Map<TextAttribute,?> | Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight) 返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。
void | Toolkit.setDynamicLayout(boolean dynamic) 控制 Container 的布局是在调整大小期间动态地生效，还是在完成调整大小后静态地生效。

抛出 HeadlessException 的 java.awt 中的构造方法
Button()
构造一个标签字符串为空的按钮。
Button(String label)
构造一个带指定标签的按钮。
Checkbox()
使用空字符串标签创建一个复选框。
Checkbox(String label)
使用指定标签创建一个复选框。
Checkbox(String label, boolean state)
使用指定标签创建一个复选框，并将它设置为指定状态。
Checkbox(String label, boolean state, CheckboxGroup group)
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。
Checkbox(String label, CheckboxGroup group, boolean state)
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。
CheckboxMenuItem()
创建具有空标签的复选框菜单项。
CheckboxMenuItem(String label)
创建具有指定标签的复选框菜单项。
CheckboxMenuItem(String label, boolean state)
创建 具有指定标签和状态的复选框菜单项。
Choice()
创建一个新的选择菜单。
Frame()
构造一个最初不可见的 Frame 新实例（）。
Frame(String title)
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。
Label()
构造一个空标签。
Label(String text)
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。
Label(String text, int alignment)
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。
List()
创建新的滚动列表。
List(int rows)
创建一个用指定可视行数初始化的新滚动列表。
List(int rows, boolean multipleMode)
创建一个初始化为显示指定行数的新滚动列表。
Menu()
构造具有空标签的新菜单。
Menu(String label)
构造具有指定标签的新菜单。
Menu(String label, boolean tearOff)
构造具有指定标签的新菜单，指示该菜单是否可以分离。
MenuBar()
创建新的菜单栏。
MenuComponent()
创建 MenuComponent。
MenuItem()
构造具有空标签且没有键盘快捷方式的新菜单项。
MenuItem(String label)
构造具有指定的标签且没有键盘快捷方式的新菜单项。
MenuItem(String label, MenuShortcut s)
创建具有关联的键盘快捷方式的菜单项。
PopupMenu()
创建具有空名称的新弹出式菜单。
PopupMenu(String label)
创建具有指定名称的新弹出式菜单。
Scrollbar()
构造一个新的垂直滚动条。
Scrollbar(int orientation)
构造一个具有指定方向的新滚动条。
Scrollbar(int orientation, int value, int visible, int minimum, int maximum)
构造一个新的滚动条，它具有指定的方向、初始值、可见量、最小值和最大值。
ScrollPane()
创建一个具有滚动条策略 "as needed" 的新滚动窗格容器。
ScrollPane(int scrollbarDisplayPolicy)
创建新的滚动窗格容器。
TextArea()
构造一个将空字符串作为文本的新文本区。
TextArea(int rows, int columns)
构造一个新文本区，该文本区具有指定的行数和列数，并将空字符串作为文本。
TextArea(String text)
构造具有指定文本的新文本区。
TextArea(String text, int rows, int columns)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。
TextArea(String text, int rows, int columns, int scrollbars)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。
TextField()
构造新文本字段。
TextField(int columns)
构造具有指定列数的新空文本字段。
TextField(String text)
构造使用指定文本初始化的新文本字段。
TextField(String text, int columns)
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。

java.awt.dnd 中 HeadlessException 的使用

抛出 HeadlessException 的 java.awt.dnd 中的构造方法
DragSource()
创建一个新的 DragSource。
DropTarget()
创建一个 DropTarget
DropTarget(Component c, DropTargetListener dtl)
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。

java.awt.print 中 HeadlessException 的使用

抛出 HeadlessException 的 java.awt.print 中的方法
abstract PageFormat | PrinterJob.pageDialog(PageFormat page) 显示允许修改 PageFormat 实例的对话框。
PageFormat | PrinterJob.pageDialog(PrintRequestAttributeSet attributes) 显示跨平台页面设置对话框的便捷方法。
abstract boolean | PrinterJob.printDialog() 向用户呈现一个对话框，用来更改打印作业的属性。
boolean | PrinterJob.printDialog(PrintRequestAttributeSet attributes) 为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。

javax.print 中 HeadlessException 的使用

抛出 HeadlessException 的 javax.print 中的方法
static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
为用户提供一个选择 PrintService（打印机）的对话框。

javax.swing 中 HeadlessException 的使用

抛出 HeadlessException 的 javax.swing 中的方法
protected JDialog | JFileChooser.createDialog(Component parent) 创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
JDialog | JOptionPane.createDialog(Component parentComponent, String title) 创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
static JDialog | JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener) 创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
JDialog | JOptionPane.createDialog(String title) 创建并返回一个新的带有指定标题的无父 JDialog。
static Frame | JOptionPane.getFrameForComponent(Component parentComponent) 返回指定组件的 Frame。
static Frame | JOptionPane.getRootFrame() 返回用于不提供窗体的类方法中的 Frame。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message) 调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType) 调出一个由 optionType 参数确定其中选项数的对话框。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType) 调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。
static int | JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon) 调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
int | JFileChooser.showDialog(Component parent, String approveButtonText) 弹出具有自定义 approve 按钮的自定义文件选择器对话框。
static Color | JColorChooser.showDialog(Component component, String title, Color initialColor) 显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。
static String | JOptionPane.showInputDialog(Component parentComponent, Object message) 显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String | JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType) 显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。
static Object | JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue) 提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
static String | JOptionPane.showInputDialog(Object message) 显示请求用户输入的问题消息对话框。
static void | JOptionPane.showMessageDialog(Component parentComponent, Object message) 调出标题为 "Message" 的信息消息对话框。
static void | JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType) 调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。
static void | JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon) 调出一个显示信息的对话框，为其指定了所有参数。
int | JFileChooser.showOpenDialog(Component parent) 弹出一个 "Open File" 文件选择器对话框。
static int | JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue) 调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
int | JFileChooser.showSaveDialog(Component parent) 弹出一个 "Save File" 文件选择器对话框。

抛出 HeadlessException 的 javax.swing 中的构造方法
JApplet()
创建一个 swing applet 实例。
JFrame()
构造一个初始时不可见的新窗体。
JFrame(String title)
创建一个新的、初始不可见的、具有指定标题的 Frame。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.AWTException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTException
的使用

使用 AWTException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt 中 AWTException 的使用

抛出 AWTException 的 java.awt 中的方法
void | SystemTray.add(TrayIcon trayIcon) 将 TrayIcon 添加到 SystemTray。
protected void | Component.FlipBufferStrategy.createBuffers(int numBuffers, BufferCapabilities caps) 创建一个或多个具有给定能力的、复杂的翻转缓冲区。
void | Canvas.createBufferStrategy(int numBuffers, BufferCapabilities caps) 创建一个新的策略，使用所需的缓冲区能力对此组件进行多次缓冲。
void | Window.createBufferStrategy(int numBuffers, BufferCapabilities caps) 根据所需缓冲区能力为此组件上的多缓冲创建新策略。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
VolatileImage | Component.createVolatileImage(int width, int height, ImageCapabilities caps) 创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。
static Cursor | Cursor.getSystemCustomCursor(String name) 返回与指定名称匹配的特定于系统的定制光标对象。

抛出 AWTException 的 java.awt 中的构造方法
Component.FlipBufferStrategy(int numBuffers, BufferCapabilities caps)
为此组件创建新的翻转缓冲区策略。
Robot()
在基本屏幕坐标系中构造一个 Robot 对象。
Robot(GraphicsDevice screen)
为给定屏幕设备创建一个 Robot 。

java.awt.im.spi 中 AWTException 的使用

抛出 AWTException 的 java.awt.im.spi 中的方法
 Locale[] InputMethodDescriptor.getAvailableLocales()
返回相应输入方法支持的语言环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Point 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Point
的使用

使用 Point 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.image | 提供创建和修改图像的各种类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.imageio | Java Image I/O API 的主要包。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Point 的使用

返回 Point 的 java.awt 中的方法
 Point GraphicsEnvironment.getCenterPoint()
返回 Windows 应居中的点。
 Point GridBagLayout.getLayoutOrigin()
在目标容器的图形坐标空间确定布局区域的原点。
 Point List.AccessibleAWTList.AccessibleAWTListChild.getLocation()
获取此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
 Point PointerInfo.getLocation()
返回在屏幕上表示指针坐标的 Point。
 Point MenuComponent.AccessibleAWTMenuComponent.getLocation()
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
 Point Point.getLocation()
返回此点的位置。
 Point Rectangle.getLocation()
返回此 Rectangle 的位置。
 Point Component.getLocation()
获取组件的位置，形式是指定组件左上角的一个点。
 Point Component.AccessibleAWTComponent.getLocation()
通过用一个点指定该对象的左上角在屏幕坐标空间中的位置的形式，获取此对象相对于父对象的位置。
 Point Component.getLocation(Point rv)
将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。
 Point List.AccessibleAWTList.AccessibleAWTListChild.getLocationOnScreen()
返回对象在屏幕上的位置。
 Point MenuComponent.AccessibleAWTMenuComponent.getLocationOnScreen()
返回对象在屏幕上的位置。
 Point Component.getLocationOnScreen()
获取组件的位置，形式是一个指定屏幕坐标空间中组件左上角的一个点。
 Point Component.AccessibleAWTComponent.getLocationOnScreen()
返回对象在屏幕上的位置。
 Point Component.getMousePosition()
如果此 Component 正好位于鼠标指针下，则返回鼠标指针在该 Component 的坐标空间中的位置；否则返回 null。
 Point Container.getMousePosition(boolean allowChildren)
如果 Container 位于鼠标指针下，则返回鼠标指针在此 Container 的坐标中的位置，否则返回 null。
 Point ScrollPane.getScrollPosition()
返回子组件中的当前 x,y 位置，子组件显示在滚动窗格视口的 0,0 位置。
 Point Component.location()
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。
 Point GridBagLayout.location(int x, int y)
确定在布局网格中哪个单元包含由 (x, y) 指定的点。

参数类型为 Point 的 java.awt 中的方法
void | Rectangle.add(Point pt) 将指定的 Point 添加到此 Rectangle 的边界。
boolean | List.AccessibleAWTList.AccessibleAWTListChild.contains(Point p) 检查指定点是否位于此对象的界限中，其中该点的 X 坐标和 Y 坐标是相对于对象的定义的。
boolean | Polygon.contains(Point p) 确定指定的 Point 是否位于此 Polygon 的内部。
boolean | MenuComponent.AccessibleAWTMenuComponent.contains(Point p) 检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系相关。
boolean | Rectangle.contains(Point p) 检查此 Rectangle 是否包含指定的 Point。
boolean | Component.contains(Point p) 检查组件是否“包含”指定的点，其中该点的 x 和 y 坐标是相对于此组件的坐标系定义的。
boolean | Component.AccessibleAWTComponent.contains(Point p) 检查指定的点是否在此对象的边界内，该点的 x 坐标和 y 坐标是相对于该对象的坐标系来定义的。
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
Component | Container.findComponentAt(Point p) 对包含指定点的可视子组件进行定位。
Accessible | List.AccessibleAWTList.getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。
Accessible | Container.AccessibleAWTContainer.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | Component.AccessibleAWTComponent.getAccessibleAt(Point p) 返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。
Component | Container.getComponentAt(Point p) 获取包含指定点的组件。
Component | Component.getComponentAt(Point p) 返回包含指定点的组件或子组件。
int | TextComponent.AccessibleAWTTextComponent.getIndexAtPoint(Point p) 给出本地坐标中的一个点，返回该 Point 下的、从零开始的字符索引。
Point | Component.getLocation(Point rv) 将组件的 x，y 原点存储到“返回值” rv 中并返回 rv。
void | List.AccessibleAWTList.AccessibleAWTListChild.setLocation(Point p) 设置对象相对于父级的位置。
void | MenuComponent.AccessibleAWTMenuComponent.setLocation(Point p) 设置该对象相对于父对象的位置。
void | Point.setLocation(Point p) 将点的位置设为指定位置。
void | Rectangle.setLocation(Point p) 将此 Rectangle 移动到指定位置。
void | Component.setLocation(Point p) 将组件移到新位置。
void | Component.AccessibleAWTComponent.setLocation(Point p) 设置对象相对父对象的位置。
void | ScrollPane.setScrollPosition(Point p) 滚动到子组件中的指定位置。

参数类型为 Point 的 java.awt 中的构造方法
Point(Point p)
构造并初始化一个与指定的 Point 对象具有相同位置的点。
Rectangle(Point p)
构造一个新的 Rectangle，其左上角是指定的 Point，其宽度和高度均为 0。
Rectangle(Point p, Dimension d)
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。

java.awt.dnd 中 Point 的使用

返回 Point 的 java.awt.dnd 中的方法
Point | DragGestureEvent.getDragOrigin() 返回 Component 坐标中开始拖动位置的 Point。
Point | DragSourceEvent.getLocation() 此方法返回一个 Point，指示事件发生时光标在屏幕坐标中的位置，如果没有为此事件指定光标位置，则返回 null。
Point | DropTargetDragEvent.getLocation() 此方法返回一个指示 Component 坐标中 Cursor 当前位置的 Point。
Point | DropTargetDropEvent.getLocation() 此方法返回一个 Point，指示 Component 坐标中 Cursor 的当前位置。

参数类型为 Point 的 java.awt.dnd 中的方法
void | Autoscroll.autoscroll(Point cursorLocn) 通知 Component 自动滚动
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
protected DropTarget.DropTargetAutoScroller | DropTarget.createDropTargetAutoScroller(Component c, Point p) 创建一个嵌入式自动滚动条
protected void | DragGestureRecognizer.fireDragGestureRecognized(int dragAction, Point p) 通知 DragGestureListener 已发生了 Drag 和 Drop 开始动作。
protected void | DropTarget.initializeAutoscrolling(Point p) 初始化自动滚动
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
protected void | DropTarget.updateAutoscroll(Point dragCursorLocn) 使用当前的光标位置更新自动滚动
protected void | DropTarget.DropTargetAutoScroller.updateLocation(Point newLocn) 导致发生自动滚动

参数类型为 Point 的 java.awt.dnd 中的构造方法
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。
DropTarget.DropTargetAutoScroller(Component c, Point p)
构造一个 DropTargetAutoScroller
DropTargetDragEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 "Drag" Cursor 热点的位置、用户 drop 操作和源 drop 操作的情况下，构造一个 DropTargetDragEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions)
在给出此操作的 DropTargetContext、Component 坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作和当前受源对象支持的操作集合的情况下，构造一个 DropTargetDropEvent。
DropTargetDropEvent(DropTargetContext dtc, Point cursorLocn, int dropAction, int srcActions, boolean isLocal)
在给出此操作的 DropTargetContext、Component 的坐标中 drag Cursor 的热点位置、目前选择的用户 drop 操作、当前受源对象支持的操作集合，以及一个指示源对象与目标对象是否在同一 JVM 中的 boolean 值的情况下，构造一个 DropTargetEvent。

java.awt.event 中 Point 的使用

返回 Point 的 java.awt.event 中的方法
Point | MouseEvent.getLocationOnScreen() 返回事件的绝对 x, y 坐标。
Point | MouseEvent.getPoint() 返回事件相对于源组件的 x, y 坐标。

java.awt.image 中 Point 的使用

返回 Point 的 java.awt.image 中的方法
Point[] | BufferedImage.getWritableTileIndices() 返回 Point 对象的数组，它指示为写入签出了哪些 tile。
Point[] | WritableRenderedImage.getWritableTileIndices() 返回 Point 对象的数组，它指示为写入签出了哪些 tile。

参数类型为 Point 的 java.awt.image 中的方法
static WritableRaster | Raster.createBandedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int scanlineStride, int[] bankIndices, int[] bandOffsets, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、存储单元索引和 band 偏移量的 Raster。
static WritableRaster | Raster.createBandedRaster(int dataType, int w, int h, int bands, Point location) 根据 BandedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
static WritableRaster | Raster.createInterleavedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int scanlineStride, int pixelStride, int[] bandOffsets, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度、扫描行间距、像素间距和 band 偏移量的 Raster。
static WritableRaster | Raster.createInterleavedRaster(int dataType, int w, int h, int bands, Point location) 根据 PixelInterleavedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 数的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int scanlineStride, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度、扫描行间距和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(DataBuffer dataBuffer, int w, int h, int bitsPerPixel, Point location) 根据 MultiPixelPackedSampleModel 创建一个具有指定 DataBuffer、宽度、高度和每像素位数的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int[] bandMasks, Point location) 根据 SinglePixelPackedSampleModel 创建一个具有指定数据类型、宽度、高度和 band 掩码的 Raster。
static WritableRaster | Raster.createPackedRaster(int dataType, int w, int h, int bands, int bitsPerBand, Point location) 根据打包的 SampleModel 创建一个具有指定数据类型、宽度、高度、band 数和每 band 位数的 Raster。
static Raster | Raster.createRaster(SampleModel sm, DataBuffer db, Point location) 创建具有指定 SampleModel 和 DataBuffer 的 Raster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, DataBuffer db, Point location) 创建一个具有指定 SampleModel 和 DataBuffer 的 WritableRaster。
static WritableRaster | Raster.createWritableRaster(SampleModel sm, Point location) 创建一个具有指定 SampleModel 的 WritableRaster。

参数类型为 Point 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构建具有给定 SampleModel 和 DataBuffer 的 Raster。
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
Raster(SampleModel sampleModel, Point origin)
构建具有给定 SampleModel 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Point origin)
构造具有给定 SampleModel 和 DataBuffer 的 WritableRaster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。
WritableRaster(SampleModel sampleModel, Point origin)
构造具有给定 SampleModel 的 WritableRaster。

javax.accessibility 中 Point 的使用

返回 Point 的 javax.accessibility 中的方法
Point | AccessibleComponent.getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | AccessibleComponent.getLocationOnScreen() 返回对象在屏幕上的位置。

参数类型为 Point 的 javax.accessibility 中的方法
boolean | AccessibleComponent.contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
Accessible | AccessibleComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
int | AccessibleText.getIndexAtPoint(Point p) 给定本地坐标中的一点，返回在该点下的字符从 0 开始的索引。
void | AccessibleComponent.setLocation(Point p) 设置对象相对于父级的位置。

javax.imageio 中 Point 的使用

声明为 Point 的 javax.imageio 中的字段
protected  Point IIOParam.destinationOffset
目标区域中的偏移量，应将左上部解码像素置于此处。

返回 Point 的 javax.imageio 中的方法
 Point IIOParam.getDestinationOffset()
返回目标图像中的偏移量，像素将置于该处。

参数类型为 Point 的 javax.imageio 中的方法
 void IIOParam.setDestinationOffset(Point destinationOffset)
指定目标图像中的偏移量。

javax.swing 中 Point 的使用

声明为 Point 的 javax.swing 中的字段
protected  Point JViewport.lastPaintPosition
我们绘制的最后一个 viewPosition，因此我们知道有多少有效的后备存储图像。

返回 Point 的 javax.swing 中的方法
static Point | SwingUtilities.convertPoint(Component source, int x, int y, Component destination) 将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。
static Point | SwingUtilities.convertPoint(Component source, Point aPoint, Component destination) 将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
Point | TransferHandler.DropLocation.getDropPoint() 返回放置点，表示组件内鼠标的当前位置。
Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocation()
Point | JTable.AccessibleJTable.AccessibleJTableCell.getLocation() 以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
Point | JList.AccessibleJList.AccessibleJListChild.getLocation()
Point | JComponent.getLocation(Point rv) 将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。
protected Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocationInJTree()
Point | JTree.AccessibleJTree.AccessibleJTreeNode.getLocationOnScreen()
Point | JTable.AccessibleJTable.AccessibleJTableCell.getLocationOnScreen() 返回对象在屏幕上的位置。
Point | JList.AccessibleJList.AccessibleJListChild.getLocationOnScreen()
Point | JComponent.getPopupLocation(MouseEvent event) 返回在此组件坐标系统中显示弹出式菜单的首选位置。
protected Point | JMenu.getPopupMenuOrigin() 计算 JMenu 的弹出菜单的原点。
Point | JComponent.getToolTipLocation(MouseEvent event) 返回工具提示在此组件坐标系统中的位置。
Point | JViewport.getViewPosition() 返回显示在视口左上角的视图坐标，如果不存在视图，则返回（0,0）。
Point | JList.indexToLocation(int index) 返回列表的坐标系统中指定项的原点。
Point | JViewport.toViewCoordinates(Point p) 将一个点的像素坐标转换为视图坐标。

参数类型为 Point 的 javax.swing 中的方法
 int JTable.columnAtPoint(Point point)
返回 point 所在的列索引；如果结果不在 [0, getColumnCount()-1] 范围内，则返回 -1。
 Component MenuSelectionManager.componentForPoint(Component source, Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。
protected  boolean JViewport.computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
 boolean JTree.AccessibleJTree.AccessibleJTreeNode.contains(Point p)
 boolean JTable.AccessibleJTable.AccessibleJTableCell.contains(Point p)
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。
 boolean JList.AccessibleJList.AccessibleJListChild.contains(Point p)
static Point SwingUtilities.convertPoint(Component source, Point aPoint, Component destination)
将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
static void SwingUtilities.convertPointFromScreen(Point p, Component c)
将一个点从屏幕坐标转换到组件的坐标系统
static void SwingUtilities.convertPointToScreen(Point p, Component c)
将一个点从组件的坐标系统转换到屏幕坐标。
static Accessible SwingUtilities.getAccessibleAt(Component c, Point p)
如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
 Accessible JEditorPane.AccessibleJEditorPaneHTML.getAccessibleAt(Point p)
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
 Accessible JTree.AccessibleJTree.getAccessibleAt(Point p)
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
 Accessible JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAt(Point p)
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
 Accessible JTable.AccessibleJTable.getAccessibleAt(Point p)
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。
 Accessible JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAt(Point p)
 Accessible JTabbedPane.AccessibleJTabbedPane.getAccessibleAt(Point p)
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
 Accessible JList.AccessibleJList.getAccessibleAt(Point p)
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
 Accessible JList.AccessibleJList.AccessibleJListChild.getAccessibleAt(Point p)
 int JSpinner.AccessibleJSpinner.getIndexAtPoint(Point p)
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
 int ProgressMonitor.AccessibleProgressMonitor.getIndexAtPoint(Point p)
在本地坐标中给定一个点，返回该 Point 下字符的从零开始的索引。
 int AbstractButton.AccessibleAbstractButton.getIndexAtPoint(Point p)
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
 int JLabel.AccessibleJLabel.getIndexAtPoint(Point p)
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
 Point JComponent.getLocation(Point rv)
将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。
 int JList.locationToIndex(Point location)
返回最接近列表的坐标系统中给定位置的单元索引。
 int JTable.rowAtPoint(Point point)
返回 point 所在的行索引；如果结果不在 [0, getRowCount()-1] 范围内，则返回 -1。
 void JTree.AccessibleJTree.AccessibleJTreeNode.setLocation(Point p)
 void JTable.AccessibleJTable.AccessibleJTableCell.setLocation(Point p)
设置该对象相对于父对象的位置。
 void JList.AccessibleJList.AccessibleJListChild.setLocation(Point p)
 void JViewport.setViewPosition(Point p)
设置显示在视口左上角的视图坐标，如果不存在视图，则不执行任何操作。
 Point JViewport.toViewCoordinates(Point p)
将一个点的像素坐标转换为视图坐标。

参数类型为 Point 的 javax.swing 中的构造方法
TransferHandler.DropLocation(Point dropPoint)
构造给定点的放置位置。

javax.swing.plaf 中 Point 的使用

返回 Point 的 javax.swing.plaf 中的方法
abstract  Point ListUI.indexToLocation(JList list, int index)
返回列表坐标系统中给定 JList 中指定项的原点。

参数类型为 Point 的 javax.swing.plaf 中的方法
String | TextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
abstract int | ListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
abstract int | TextUI.viewToModel(JTextComponent t, Point pt, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射关系。

javax.swing.plaf.basic 中 Point 的使用

声明为 Point 的 javax.swing.plaf.basic 中的字段
protected  Point BasicToolBarUI.DockingListener.origin

返回 Point 的 javax.swing.plaf.basic 中的方法
Point | BasicToolBarUI.DragWindow.getOffset()
protected Point | BasicProgressBarUI.getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height) 指定将绘制进度字符串的位置。
Point | BasicListUI.indexToLocation(JList list, int index) 返回列表坐标系统中给定 JList 中指定项的原点。

参数类型为 Point 的 javax.swing.plaf.basic 中的方法
boolean | BasicToolBarUI.canDock(Component c, Point p)
protected void | BasicToolBarUI.dragTo(Point position, Point origin)
protected void | BasicToolBarUI.floatAt(Point position, Point origin)
String | BasicTextUI.getToolTipText(JTextComponent t, Point pt) 返回在传入位置上用作工具提示的字符串。
int | BasicListUI.locationToIndex(JList list, Point location) 返回指定 JList 中与列表坐标系统中给定位置最接近的单元索引。
void | BasicToolBarUI.setFloating(boolean b, Point p)
void | BasicToolBarUI.DragWindow.setOffset(Point p)
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。
int | BasicTextUI.viewToModel(JTextComponent tc, Point pt, Position.Bias[] biasReturn) 将视图坐标系统中的给定位置转换成模型中最有代表性的位置。

javax.swing.plaf.metal 中 Point 的使用

参数类型为 Point 的 javax.swing.plaf.metal 中的方法
protected  void MetalToolBarUI.setDragOffset(Point p)

javax.swing.plaf.multi 中 Point 的使用

返回 Point 的 javax.swing.plaf.multi 中的方法
 Point MultiListUI.indexToLocation(JList a, int b)
在由此对象处理的每个 UI 上调用 indexToLocation 方法。

参数类型为 Point 的 javax.swing.plaf.multi 中的方法
String | MultiTextUI.getToolTipText(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 getToolTipText 方法。
int | MultiListUI.locationToIndex(JList a, Point b) 在由此对象处理的每个 UI 上调用 locationToIndex 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b) 在由此对象处理的每个 UI 上调用 viewToModel 方法。
int | MultiTextUI.viewToModel(JTextComponent a, Point b, Position.Bias[] c) 在由此对象处理的每个 UI 上调用 viewToModel 方法。

javax.swing.table 中 Point 的使用

返回 Point 的 javax.swing.table 中的方法
Point | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocation()
Point | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocationOnScreen()

参数类型为 Point 的 javax.swing.table 中的方法
int | JTableHeader.columnAtPoint(Point point) 返回该 point 所处列的索引，如果列位于边界外，则返回 -1。
boolean | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.contains(Point p)
Accessible | JTableHeader.AccessibleJTableHeader.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAt(Point p)
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setLocation(Point p)

javax.swing.text 中 Point 的使用

返回 Point 的 javax.swing.text 中的方法
Point | DefaultCaret.getMagicCaretPosition() 获取保存的插入符位置。
Point | Caret.getMagicCaretPosition() 获取当前插入符可见位置。

参数类型为 Point 的 javax.swing.text 中的方法
int | JTextComponent.AccessibleJTextComponent.getIndexAtPoint(Point p) 在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
void | DefaultCaret.setMagicCaretPosition(Point p) 保存当前插入符位置。
void | Caret.setMagicCaretPosition(Point p) 设置当前插入符的可视位置。
int | JTextComponent.viewToModel(Point pt) 将视图坐标系统中的给定位置转换为模型中最具代表性的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.SystemColor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.SystemColor
的使用

使用 SystemColor 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 SystemColor 的使用

声明为 SystemColor 的 java.awt 中的字段
static SystemColor | SystemColor.activeCaption 为当前活动窗口的窗口标题提供的背景色。
static SystemColor | SystemColor.activeCaptionBorder 为当前活动窗口的边框提供的颜色。
static SystemColor | SystemColor.activeCaptionText 为当前活动窗口的窗口标题文本提供的颜色。
static SystemColor | SystemColor.control 为控制面板和控制对象（比如按钮）提供的颜色。
static SystemColor | SystemColor.controlDkShadow 为 3D 控制对象（比如按钮）的加黑阴影区域提供的颜色。
static SystemColor | SystemColor.controlHighlight 为 3D 控制对象（比如按钮）的亮区提供的颜色。
static SystemColor | SystemColor.controlLtHighlight 为 3D 控制对象（比如按钮）的高亮区域提供的颜色。
static SystemColor | SystemColor.controlShadow 为 3D 控制对象（比如按钮）的阴影区域提供的颜色。
static SystemColor | SystemColor.controlText 为控制面板和控制对象（比如按钮）的文本提供的颜色。
static SystemColor | SystemColor.desktop 为桌面背景提供的颜色。
static SystemColor | SystemColor.inactiveCaption 为非活动窗口的窗口标题提供的背景色。
static SystemColor | SystemColor.inactiveCaptionBorder 为非活动窗口的边框提供的颜色。
static SystemColor | SystemColor.inactiveCaptionText 为非活动窗口的窗口标题文本提供的颜色。
static SystemColor | SystemColor.info 为工具栏提示或定点帮助提供的背景色。
static SystemColor | SystemColor.infoText 为工具栏提示或定点帮助的文本提供的颜色。
static SystemColor | SystemColor.menu 为菜单提供的背景色。
static SystemColor | SystemColor.menuText 为菜单文本提供的颜色。
static SystemColor | SystemColor.scrollbar 为滚动条提供的背景色。
static SystemColor | SystemColor.text 为文本控制对象（比如文本字段和组合框）提供的背景色。
static SystemColor | SystemColor.textHighlight 为选则项（比如菜单、组合框和文本）提供的背景色。
static SystemColor | SystemColor.textHighlightText 为选则项（比如菜单、组合框和文本）的文本提供的颜色。
static SystemColor | SystemColor.textInactiveText 为非活动项（比如菜单中的项）的文本提供的颜色。
static SystemColor | SystemColor.textText 为文本控制对象（比如文本字段和组合框）的文本提供的颜色。
static SystemColor | SystemColor.window 为窗口的内部区域提供的背景色。
static SystemColor | SystemColor.windowBorder 为窗口内部区域的边框提供的颜色。
static SystemColor | SystemColor.windowText 为窗口内部区域的文本提供的颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.DefaultFocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.DefaultFocusTraversalPolicy
的使用

没有 java.awt.DefaultFocusTraversalPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.ContainerOrderFocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ContainerOrderFocusTraversalPolicy
的使用

使用 ContainerOrderFocusTraversalPolicy 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 ContainerOrderFocusTraversalPolicy 的使用

java.awt 中 ContainerOrderFocusTraversalPolicy 的子类
 class DefaultFocusTraversalPolicy
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.FocusTraversalPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.FocusTraversalPolicy
的使用

使用 FocusTraversalPolicy 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 FocusTraversalPolicy 的使用

java.awt 中 FocusTraversalPolicy 的子类
class | ContainerOrderFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
class | DefaultFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

返回 FocusTraversalPolicy 的 java.awt 中的方法
FocusTraversalPolicy | KeyboardFocusManager.getDefaultFocusTraversalPolicy() 返回默认 FocusTraversalPolicy。
FocusTraversalPolicy | Container.getFocusTraversalPolicy() 返回焦点遍历策略，用于管理此 Container 子组件的键盘遍历；如果此 Container 不是一个焦点循环根，则返回 null。

参数类型为 FocusTraversalPolicy 的 java.awt 中的方法
void | KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy defaultPolicy) 设置默认 FocusTraversalPolicy。
void | Container.setFocusTraversalPolicy(FocusTraversalPolicy policy) 如果此 Container 是一个焦点循环根，则设置将管理此 Container 的子代的键盘遍历的焦点遍历策略。

javax.swing 中 FocusTraversalPolicy 的使用

javax.swing 中 FocusTraversalPolicy 的子类
class | InternalFrameFocusTraversalPolicy 该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。
class | LayoutFocusTraversalPolicy 根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
class | SortingFocusTraversalPolicy 通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.DefaultKeyboardFocusManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.DefaultKeyboardFocusManager
的使用

使用 DefaultKeyboardFocusManager 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DefaultKeyboardFocusManager 的使用

javax.swing 中 DefaultKeyboardFocusManager 的子类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.AWTKeyStroke 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTKeyStroke
的使用

使用 AWTKeyStroke 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 AWTKeyStroke 的使用

返回 AWTKeyStroke 的 java.awt 中的方法
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(char keyChar) 返回表示指定字符的 KEY_TYPED 事件的 AWTKeyStroke 的一个共享实例。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(Character keyChar, int modifiers) 返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(int keyCode, int modifiers) 在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(int keyCode, int modifiers, boolean onKeyRelease) 在给出一个数字键代码和一组修饰符的情况下，返回 AWTKeyStroke 的一个共享实例，指定该键在按下或释放时是否是被激活。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStroke(String s) 分析字符串并返回一个 AWTKeyStroke。
static AWTKeyStroke | AWTKeyStroke.getAWTKeyStrokeForEvent(KeyEvent anEvent) 返回一个 AWTKeyStroke，它表示生成给定 KeyEvent 的键击事件。

返回变量类型为 AWTKeyStroke 的类型的 java.awt 中的方法
Set<AWTKeyStroke> | KeyboardFocusManager.getDefaultFocusTraversalKeys(int id) 返回给定遍历操作的默认焦点遍历键的 Set。
Set<AWTKeyStroke> | Window.getFocusTraversalKeys(int id) 获取此窗口的焦点遍历键。
Set<AWTKeyStroke> | Container.getFocusTraversalKeys(int id) 为此 Container 的给定遍历操作返回焦点遍历键的 Set。
Set<AWTKeyStroke> | Component.getFocusTraversalKeys(int id) 返回此 Component 的给定遍历操作的焦点遍历键 Set。

类型变量类型为 AWTKeyStroke 的 java.awt 中的方法参数
void | KeyboardFocusManager.setDefaultFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 设置给定遍历操作的默认焦点遍历键。
void | Container.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Container 的给定遍历操作设置焦点遍历键。
void | Component.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Component 的给定遍历操作设置焦点遍历键。

javax.swing 中 AWTKeyStroke 的使用

javax.swing 中 AWTKeyStroke 的子类
 class KeyStroke
表示键盘或等效输入设置上的键操作的 KeyStroke。

类型变量类型为 AWTKeyStroke 的 javax.swing 中的方法参数
 void JComponent.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
设置针对此 Component 的给定遍历操作的焦点遍历键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.KeyboardFocusManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.KeyboardFocusManager
的使用

使用 KeyboardFocusManager 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 KeyboardFocusManager 的使用

java.awt 中 KeyboardFocusManager 的子类
 class DefaultKeyboardFocusManager
AWT 应用程序的默认 KeyboardFocusManager。

返回 KeyboardFocusManager 的 java.awt 中的方法
static KeyboardFocusManager KeyboardFocusManager.getCurrentKeyboardFocusManager()
返回调用线程上下文的当前 KeyboardFocusManager 实例。

参数类型为 KeyboardFocusManager 的 java.awt 中的方法
static void KeyboardFocusManager.setCurrentKeyboardFocusManager(KeyboardFocusManager newManager)
设置调用线程上下文的当前 KeyboardFocusManager 实例。

javax.swing 中 KeyboardFocusManager 的使用

javax.swing 中 KeyboardFocusManager 的子类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.KeyEventPostProcessor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.KeyEventPostProcessor
的使用

使用 KeyEventPostProcessor 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 KeyEventPostProcessor 的使用

实现 KeyEventPostProcessor 的 java.awt 中的类
class | DefaultKeyboardFocusManager AWT 应用程序的默认 KeyboardFocusManager。
class | KeyboardFocusManager KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。

返回变量类型为 KeyEventPostProcessor 的类型的 java.awt 中的方法
protected  List<KeyEventPostProcessor> KeyboardFocusManager.getKeyEventPostProcessors()
作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。

参数类型为 KeyEventPostProcessor 的 java.awt 中的方法
void | KeyboardFocusManager.addKeyEventPostProcessor(KeyEventPostProcessor processor) 将 KeyEventPostProcessor 添加到此 KeyboardFocusManager 的后处理器链中。
void | KeyboardFocusManager.removeKeyEventPostProcessor(KeyEventPostProcessor processor) 从此 KeyboardFocusManager 的后处理器链中移除以前添加的 KeyEventPostProcessor。

javax.swing 中 KeyEventPostProcessor 的使用

实现 KeyEventPostProcessor 的 javax.swing 中的类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.KeyEventDispatcher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.KeyEventDispatcher
的使用

使用 KeyEventDispatcher 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 KeyEventDispatcher 的使用

实现 KeyEventDispatcher 的 java.awt 中的类
class | DefaultKeyboardFocusManager AWT 应用程序的默认 KeyboardFocusManager。
class | KeyboardFocusManager KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。

返回变量类型为 KeyEventDispatcher 的类型的 java.awt 中的方法
protected  List<KeyEventDispatcher> KeyboardFocusManager.getKeyEventDispatchers()
作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。

参数类型为 KeyEventDispatcher 的 java.awt 中的方法
void | KeyboardFocusManager.addKeyEventDispatcher(KeyEventDispatcher dispatcher) 将 KeyEventDispatcher 添加到此 KeyboardFocusManager 的调度程序链中。
void | KeyboardFocusManager.removeKeyEventDispatcher(KeyEventDispatcher dispatcher) 移除以前添加到此 KeyboardFocusManager 调度程序链中的 KeyEventDispatcher。

javax.swing 中 KeyEventDispatcher 的使用

实现 KeyEventDispatcher 的 javax.swing 中的类
class | DefaultFocusManager 此类已被废弃，用 1.4 focus API 取代。
class | FocusManager 从 1.4 focus API 开始，此类已被废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Insets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Insets
的使用

使用 Insets 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Insets 的使用

声明为 Insets 的 java.awt 中的字段
 Insets GridBagConstraints.insets
此字段指定组件的外部填充，即组件与其显示区域边缘之间间距的最小量。

返回 Insets 的 java.awt 中的方法
 Insets Container.getInsets()
确定此容器的 insets，它指示容器边框的大小。
 Insets Toolkit.getScreenInsets(GraphicsConfiguration gc)
获得屏幕的 insets。
 Insets Container.insets()
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。

参数类型为 Insets 的 java.awt 中的构造方法
GridBagConstraints(int gridx, int gridy, int gridwidth, int gridheight, double weightx, double weighty, int anchor, int fill, Insets insets, int ipadx, int ipady)
创建一个 GridBagConstraints 对象，将其所有字段都设置为传入参数。

java.awt.dnd 中 Insets 的使用

返回 Insets 的 java.awt.dnd 中的方法
 Insets Autoscroll.getAutoscrollInsets()
此方法返回 Insets，用于描述相对于实现 Component 几何形状的自动滚动区域或边界。

javax.swing 中 Insets 的使用

返回 Insets 的 javax.swing 中的方法
Insets | JViewport.getInsets() 返回 inset（边框）维数 (0,0,0,0)，因为在 JViewport 上不支持边框。
Insets | JComponent.getInsets() 如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
Insets | JViewport.getInsets(Insets insets) 返回包含此 JViewport 的 inset 值的 inset 对象。
Insets | JComponent.getInsets(Insets insets) 返回包含此组件 inset 值的 Insets 对象。
Insets | UIDefaults.getInsets(Object key) 如果 key 值为一个 Insets，则返回它，否则返回 null。
static Insets | UIManager.getInsets(Object key) 从默认值中返回一个 Insets 对象。
Insets | UIDefaults.getInsets(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。
static Insets | UIManager.getInsets(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Insets 对象。
Insets | JPopupMenu.getMargin() 返回弹出菜单的边框与其包含内容之间的空白（以像素表示）。
Insets | JMenuBar.getMargin() 返回菜单栏的边框与其菜单之间的空白。
Insets | JToolBar.getMargin() 返回工具栏边框和它的按钮之间的空白。
Insets | AbstractButton.getMargin() 返回按钮边框和标签之间的空白。

参数类型为 Insets 的 javax.swing 中的方法
Insets | JViewport.getInsets(Insets insets) 返回包含此 JViewport 的 inset 值的 inset 对象。
Insets | JComponent.getInsets(Insets insets) 返回包含此组件 inset 值的 Insets 对象。
void | JMenuBar.setMargin(Insets m) 设置菜单栏的边框与其菜单之间的空白。
void | JToolBar.setMargin(Insets m) 设置工具栏边框和它的按钮之间的空白。
void | AbstractButton.setMargin(Insets m) 设置按钮边框和标签之间的空白。

javax.swing.border 中 Insets 的使用

返回 Insets 的 javax.swing.border 中的方法
Insets | MatteBorder.getBorderInsets() 返回此边框的 insets。
Insets | EmptyBorder.getBorderInsets() 返回此边框的 insets。
Insets | SoftBevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | TitledBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | BevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | EtchedBorder.getBorderInsets(Component c) 返回边框的 insets
Insets | LineBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | MatteBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | CompoundBorder.getBorderInsets(Component c) 返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。
Insets | EmptyBorder.getBorderInsets(Component c) 返回此边框的 insets
Insets | AbstractBorder.getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | Border.getBorderInsets(Component c) 返回该边框的 insets。
Insets | SoftBevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | TitledBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | BevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EtchedBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | LineBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | MatteBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | CompoundBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EmptyBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | AbstractBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。

参数类型为 Insets 的 javax.swing.border 中的方法
Insets | SoftBevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | TitledBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | BevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EtchedBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | LineBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | MatteBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | CompoundBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EmptyBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | AbstractBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。

参数类型为 Insets 的 javax.swing.border 中的构造方法
EmptyBorder(Insets borderInsets)
创建具有指定 insets 的空边框
MatteBorder(Insets borderInsets, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(Insets borderInsets, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。

javax.swing.plaf 中 Insets 的使用

javax.swing.plaf 中 Insets 的子类
 class InsetsUIResource

返回 Insets 的 javax.swing.plaf 中的方法
 Insets BorderUIResource.getBorderInsets(Component c)

参数类型为 Insets 的 javax.swing.plaf 中的构造方法
BorderUIResource.EmptyBorderUIResource(Insets insets)

javax.swing.plaf.basic 中 Insets 的使用

声明为 Insets 的 javax.swing.plaf.basic 中的字段
protected Insets | BasicTabbedPaneUI.contentBorderInsets
protected Insets | BasicSliderUI.focusInsets
protected Insets | BasicSliderUI.insetCache
protected Insets | BasicTabbedPaneUI.selectedTabPadInsets
protected Insets | BasicTabbedPaneUI.tabAreaInsets
protected Insets | BasicTabbedPaneUI.tabInsets

返回 Insets 的 javax.swing.plaf.basic 中的方法
 Insets BasicBorders.ButtonBorder.getBorderInsets(Component c)
 Insets BasicBorders.ToggleButtonBorder.getBorderInsets(Component c)
 Insets BasicBorders.RadioButtonBorder.getBorderInsets(Component c)
 Insets BasicBorders.MenuBarBorder.getBorderInsets(Component c)
 Insets BasicBorders.MarginBorder.getBorderInsets(Component c)
 Insets BasicBorders.FieldBorder.getBorderInsets(Component c)
 Insets BasicBorders.SplitPaneBorder.getBorderInsets(Component c)
 Insets BasicBorders.ButtonBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.ToggleButtonBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.RadioButtonBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.MenuBarBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.MarginBorder.getBorderInsets(Component c, Insets insets)
 Insets BasicBorders.FieldBorder.getBorderInsets(Component c, Insets insets)
protected  Insets BasicTabbedPaneUI.getContentBorderInsets(int tabPlacement)
static Insets BasicGraphicsUtils.getEtchedInsets()
返回 drawEtchedRect() 绘制边框占用的空间量。
static Insets BasicGraphicsUtils.getGrooveInsets()
返回 drawGroove() 绘制边框占用的空间量。
 Insets BasicSplitPaneDivider.getInsets()
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
protected  Insets BasicComboBoxUI.getInsets()
获取 JComboBox 的 insets。
 Insets BasicToolBarUI.DragWindow.getInsets()
 Insets BasicDesktopIconUI.getInsets(JComponent c)
 Insets BasicSplitPaneUI.getInsets(JComponent jc)
返回 insets。
protected  Insets BasicTabbedPaneUI.getSelectedTabPadInsets(int tabPlacement)
protected  Insets BasicTabbedPaneUI.getTabAreaInsets(int tabPlacement)
protected  Insets BasicTabbedPaneUI.getTabInsets(int tabPlacement, int tabIndex)

参数类型为 Insets 的 javax.swing.plaf.basic 中的方法
protected int | BasicProgressBarUI.getAmountFull(Insets b, int width, int height) 此方法确定进度条的量，该量应该基于从模型搜集的完成百分比填充。
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getAvailableSize(Dimension containerSize, Insets insets) 返回基于容器大小和 Insets 的可用宽度。
Insets | BasicBorders.ButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.ToggleButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.RadioButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MenuBarBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MarginBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.FieldBorder.getBorderInsets(Component c, Insets insets)
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getInitialLocation(Insets insets) 如果 Insets 不为 null，则返回左边 inset；如果其为 null，则返回 0。
protected void | BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的展开（切换）部分。
protected void | BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制支路 (leg) 的水平部分。
protected void | BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf) 绘制 row 的渲染器部分。
protected void | BasicProgressBarUI.paintString(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
protected void | BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path) 绘制支路的垂直部分。
protected static void | BasicTabbedPaneUI.rotateInsets(Insets topInsets, Insets targetInsets, int targetPlacement)
protected void | BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize) 将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。

javax.swing.plaf.metal 中 Insets 的使用

声明为 Insets 的 javax.swing.plaf.metal 中的字段
protected static Insets | MetalBorders.ButtonBorder.borderInsets
protected static Insets | MetalBorders.MenuBarBorder.borderInsets
protected static Insets | MetalBorders.MenuItemBorder.borderInsets
protected static Insets | MetalBorders.PopupMenuBorder.borderInsets
protected static Insets | MetalComboBoxEditor.editorBorderInsets 默认编辑器边框 Insets。
protected Insets | MetalBorders.TableHeaderBorder.editorBorderInsets

返回 Insets 的 javax.swing.plaf.metal 中的方法
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.ScrollPaneBorder.getBorderInsets(Component c)
Insets | MetalBorders.TableHeaderBorder.getBorderInsets(Component c)
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c, Insets newInsets)

参数类型为 Insets 的 javax.swing.plaf.metal 中的方法
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c, Insets newInsets)
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

javax.swing.plaf.synth 中 Insets 的使用

返回 Insets 的 javax.swing.plaf.synth 中的方法
 Insets SynthStyle.getInsets(SynthContext context, Insets insets)
返回用来计算大小调整信息的 Insets。

参数类型为 Insets 的 javax.swing.plaf.synth 中的方法
 Insets SynthStyle.getInsets(SynthContext context, Insets insets)
返回用来计算大小调整信息的 Insets。

javax.swing.text 中 Insets 的使用

返回 Insets 的 javax.swing.text 中的方法
 Insets JTextComponent.getMargin()
返回文本组件的边框和它的文本之间的空白。

参数类型为 Insets 的 javax.swing.text 中的方法
 void JTextComponent.setMargin(Insets m)
设置组件的边框和它的文本之间的空白。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.ActiveEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.ActiveEvent
的使用

使用 ActiveEvent 的软件包
java.awt.event 提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt.event 中 ActiveEvent 的使用

实现 ActiveEvent 的 java.awt.event 中的类
 class InvocationEvent
当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.EventQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.EventQueue
的使用

使用 EventQueue 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 EventQueue 的使用

返回 EventQueue 的 java.awt 中的方法
EventQueue | Toolkit.getSystemEventQueue() 获取应用程序或 applet 的 EventQueue 实例。
protected abstract EventQueue | Toolkit.getSystemEventQueueImpl() 获取应用程序或 applet 的 EventQueue 实例，不检查访问权。

参数类型为 EventQueue 的 java.awt 中的方法
 void EventQueue.push(EventQueue newEventQueue)
用指定的事件队列替换现有的 EventQueue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Rectangle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Rectangle
的使用

使用 Rectangle 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.imageio | Java Image I/O API 的主要包。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Rectangle 的使用

声明为 Rectangle 的 java.awt 中的字段
protected  Rectangle Polygon.bounds
此 Polygon 的边界。

返回 Rectangle 的 java.awt 中的方法
 Rectangle Component.bounds()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 Rectangle Polygon.getBoundingBox()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 Rectangle List.AccessibleAWTList.AccessibleAWTListChild.getBounds()
以 Rectangle 对象的形式获取此对象的界限。
 Rectangle Polygon.getBounds()
获取此 Polygon 的边界框。
 Rectangle SplashScreen.getBounds()
以 Rectangle 形式返回闪现屏幕窗口的边界。
 Rectangle MenuComponent.AccessibleAWTMenuComponent.getBounds()
以 Rectangle 对象的形式获取此对象的边界。
 Rectangle Rectangle.getBounds()
获取此 Rectangle 的边界 Rectangle。
abstract  Rectangle GraphicsConfiguration.getBounds()
返回 GraphicsConfiguration 在设备坐标中的边界。
 Rectangle Shape.getBounds()
返回一个完全包围 Shape 的整型 Rectangle。
 Rectangle Component.getBounds()
以 Rectangle 对象的形式获取组件的边界。
 Rectangle Component.AccessibleAWTComponent.getBounds()
获取此对象的边界，用 Rectangle 对象的形式表示它。
 Rectangle Component.getBounds(Rectangle rv)
将组件的边界存储到“返回值”rv 中并返回 rv。
 Rectangle TextComponent.AccessibleAWTTextComponent.getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。
abstract  Rectangle Graphics.getClipBounds()
返回当前剪贴区域的边界矩形。
 Rectangle Graphics.getClipBounds(Rectangle r)
返回当前剪贴区域的边界矩形。
 Rectangle Graphics.getClipRect()
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。
 Rectangle Frame.getMaximizedBounds()
获取此窗体的最大化边界。
 Rectangle GraphicsEnvironment.getMaximumWindowBounds()
返回居中 Windows 的最大边界。
 Rectangle Rectangle.intersection(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的交集。
 Rectangle Rectangle.union(Rectangle r)
计算此 Rectangle 与指定 Rectangle 的并集。

参数类型为 Rectangle 的 java.awt 中的方法
void | Rectangle.add(Rectangle r) 将一个 Rectangle 添加到此 Rectangle 中。
protected void | GridBagLayout.adjustForGravity(GridBagConstraints constraints, Rectangle r) 根据约束几何结构和填充将 x、y、宽度和高度四个字段调整为正确值。
protected void | GridBagLayout.AdjustForGravity(GridBagConstraints constraints, Rectangle r) 此方法已过时，仅为提供向后兼容性；新代码应该调用 adjustForGravity 来代替。
boolean | Rectangle.contains(Rectangle r) 检查此 Rectangle 是否完全包含指定的 Rectangle。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
BufferedImage | Robot.createScreenCapture(Rectangle screenRect) 创建包含从屏幕中读取的像素的图像。
Rectangle | Component.getBounds(Rectangle rv) 将组件的边界存储到“返回值”rv 中并返回 rv。
Rectangle | Graphics.getClipBounds(Rectangle r) 返回当前剪贴区域的边界矩形。
abstract boolean | Graphics2D.hit(Rectangle rect, Shape s, boolean onStroke) 检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。
Rectangle | Rectangle.intersection(Rectangle r) 计算此 Rectangle 与指定 Rectangle 的交集。
boolean | Rectangle.intersects(Rectangle r) 确定此 Rectangle 是否与指定的 Rectangle 相交。
void | List.AccessibleAWTList.AccessibleAWTListChild.setBounds(Rectangle r) 以 Rectangle 对象的形式设置此对象的界限。
void | MenuComponent.AccessibleAWTMenuComponent.setBounds(Rectangle r) 以 Rectangle 对象的形式设置此对象的边界。
void | Rectangle.setBounds(Rectangle r) 设置此 Rectangle 的边界 Rectangle，以匹配指定的 Rectangle。
void | Window.setBounds(Rectangle r) 移动组件并调整其大小，使其符合新的有界矩形 r。
void | Component.setBounds(Rectangle r) 移动组件并调整其大小，使其符合新的有界矩形 r。
void | Component.AccessibleAWTComponent.setBounds(Rectangle r) 设置此对象的边界，用 Rectangle 对象的形式表示它。
void | Frame.setMaximizedBounds(Rectangle bounds) 设置此窗体的最大化边界。
Rectangle | Rectangle.union(Rectangle r) 计算此 Rectangle 与指定 Rectangle 的并集。

参数类型为 Rectangle 的 java.awt 中的构造方法
Rectangle(Rectangle r)
构造一个新的 Rectangle，并将其初始化，以与指定 Rectangle 的值匹配。

java.awt.event 中 Rectangle 的使用

返回 Rectangle 的 java.awt.event 中的方法
 Rectangle PaintEvent.getUpdateRect()
返回表示需要重绘区域以响应此事件的矩形。

参数类型为 Rectangle 的 java.awt.event 中的方法
 void PaintEvent.setUpdateRect(Rectangle updateRect)
设置表示需要进行重绘区域以响应此事件的矩形。

参数类型为 Rectangle 的 java.awt.event 中的构造方法
PaintEvent(Component source, int id, Rectangle updateRect)
构造一个具有指定源组件和类型的 PaintEvent 对象。

java.awt.font 中 Rectangle 的使用

返回 Rectangle 的 java.awt.font 中的方法
Rectangle | GlyphVector.getGlyphPixelBounds(int index, FontRenderContext renderFRC, float x, float y) 返回当此 GlyphVector 在 Graphics 中以给定 FontRenderContext 在给定位置呈现时，index 处字形的像素边界。
Rectangle | TextLayout.getPixelBounds(FontRenderContext frc, float x, float y) 返回在图形中使用给定 FontRenderContext 在给定位置处呈现 TextLayout 时的像素边界。
Rectangle | GlyphVector.getPixelBounds(FontRenderContext renderFRC, float x, float y) 返回此 GlyphVector 在图形中以给定 FontRenderContext 在给定位置处呈现时的像素边界。

java.awt.geom 中 Rectangle 的使用

返回 Rectangle 的 java.awt.geom 中的方法
Rectangle | Area.getBounds() 返回完全包围此 Area 的边界 Rectangle。
Rectangle | CubicCurve2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | Line2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | Path2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | QuadCurve2D.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。
Rectangle | RectangularShape.getBounds() 返回一个完全包围 Shape 的整型 Rectangle。

java.awt.im 中 Rectangle 的使用

返回 Rectangle 的 java.awt.im 中的方法
 Rectangle InputMethodRequests.getTextLocation(TextHitInfo offset)
获取当前撰写文本中指定偏移量的位置，或已提交文本中的选择位置。

java.awt.im.spi 中 Rectangle 的使用

参数类型为 Rectangle 的 java.awt.im.spi 中的方法
 void InputMethod.notifyClientWindowChange(Rectangle bounds)
通知此输入方法客户端窗口位置或状态的更改。

java.awt.image 中 Rectangle 的使用

返回 Rectangle 的 java.awt.image 中的方法
 Rectangle Raster.getBounds()
返回此 Raster 的边界 Rectangle。

参数类型为 Rectangle 的 java.awt.image 中的方法
WritableRaster | Raster.createCompatibleWritableRaster(Rectangle rect) 创建一个兼容的 WritableRaster，使其具有由 rect 指定的位置 (minX, minY) 和大小 (width, height)、新 SampleModel 和新初始化的 DataBuffer。
Raster | BufferedImage.getData(Rectangle rect) 计算并返回 BufferedImage 的一个任意区域。
Raster | RenderedImage.getData(Rectangle rect) 计算并返回 RenderedImage 的任意区域。

参数类型为 Rectangle 的 java.awt.image 中的构造方法
Raster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, Raster parent)
构造具有给定 SampleModel、DataBuffer 和父 Raster 的 Raster。
WritableRaster(SampleModel sampleModel, DataBuffer dataBuffer, Rectangle aRegion, Point sampleModelTranslate, WritableRaster parent)
构造具有给定 SampleModel、DataBuffer 和父亲的 WritableRaster。

java.beans 中 Rectangle 的使用

参数类型为 Rectangle 的 java.beans 中的方法
void | PropertyEditor.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。
void | PropertyEditorSupport.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。

javax.accessibility 中 Rectangle 的使用

返回 Rectangle 的 javax.accessibility 中的方法
Rectangle | AccessibleComponent.getBounds() 获取 Rectangle 对象形式的此对象的边界。
Rectangle | AccessibleText.getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
Rectangle | AccessibleExtendedText.getTextBounds(int startIndex, int endIndex) 返回两个索引之间文本的边界矩形。

参数类型为 Rectangle 的 javax.accessibility 中的方法
 void AccessibleComponent.setBounds(Rectangle r)
设置 Rectangle 对象形式的此对象的边界。

javax.imageio 中 Rectangle 的使用

声明为 Rectangle 的 javax.imageio 中的字段
protected  Rectangle IIOParam.sourceRegion
源区域；如果没有设置源区域，则为 null。

返回 Rectangle 的 javax.imageio 中的方法
Rectangle | IIOParam.getSourceRegion() 返回将使用的源区域。
protected static Rectangle | ImageReader.getSourceRegion(ImageReadParam param, int srcWidth, int srcHeight) reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。

参数类型为 Rectangle 的 javax.imageio 中的方法
protected static void | ImageReader.computeRegions(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion) 计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
void | ImageWriter.prepareReplacePixels(int imageIndex, Rectangle region) 准备好 writer，处理一系列对 replacePixels 方法的调用。
void | IIOParam.setSourceRegion(Rectangle sourceRegion) 设置感兴趣的源区域。

javax.swing 中 Rectangle 的使用

返回 Rectangle 的 javax.swing 中的方法
static Rectangle SwingUtilities.calculateInnerArea(JComponent c, Rectangle r)
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
static Rectangle[] SwingUtilities.computeDifference(Rectangle rectA, Rectangle rectB)
返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。
static Rectangle SwingUtilities.computeIntersection(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的交集的便捷方法。
static Rectangle SwingUtilities.computeUnion(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的并集的便捷方法。
static Rectangle SwingUtilities.convertRectangle(Component source, Rectangle aRectangle, Component destination)
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
 Rectangle JTree.AccessibleJTree.AccessibleJTreeNode.getBounds()
 Rectangle JTable.AccessibleJTable.AccessibleJTableCell.getBounds()
 Rectangle JList.AccessibleJList.AccessibleJListChild.getBounds()
 Rectangle JComponent.getBounds(Rectangle rv)
将此组件的边界存储到“返回值”rv 中并返回 rv。
 Rectangle JTabbedPane.getBoundsAt(int index)
返回 index 位置的选项卡边界。
protected  Rectangle DefaultDesktopManager.getBoundsForIconOf(JInternalFrame f)
iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。
 Rectangle JList.getCellBounds(int index0, int index1)
返回列表的坐标系统中两个索引所指定单元范围内的边界矩形。
 Rectangle JTable.getCellRect(int row, int column, boolean includeSpacing)
返回位于 row 和 column 相交位置的单元格矩形。
 Rectangle JSpinner.AccessibleJSpinner.getCharacterBounds(int i)
确定给定字符串索引处字符的边界。
 Rectangle ProgressMonitor.AccessibleProgressMonitor.getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。
 Rectangle AbstractButton.AccessibleAbstractButton.getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。
 Rectangle JLabel.AccessibleJLabel.getCharacterBounds(int i)
确定给定字符串索引处字符的边界框。
 Rectangle DebugGraphics.getClipBounds()
重写 Graphics.getClipBounds。
 Rectangle RepaintManager.getDirtyRegion(JComponent aComponent)
返回组件的当前脏区。
static Rectangle SwingUtilities.getLocalBounds(Component aComponent)
返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。
 Rectangle JInternalFrame.getNormalBounds()
如果 JInternalFrame 未处于最大化状态，则返回 getBounds()；否则返回还原 JInternalFrame 后的边界。
 Rectangle JTree.getPathBounds(TreePath path)
返回将指定节点绘入的 Rectangle。
protected  Rectangle DefaultDesktopManager.getPreviousBounds(JInternalFrame f)
在将组件最大化之前，获得该组件的普通边界。
 Rectangle JTree.getRowBounds(int row)
返回将指定行处的节点绘入的 Rectangle。
 Rectangle JScrollPane.getViewportBorderBounds()
返回视口边界的范围。
 Rectangle ScrollPaneLayout.getViewportBorderBounds(JScrollPane scrollpane)
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
 Rectangle JViewport.getViewRect()
返回一个矩形，其原位置在 getViewPosition，大小为 getExtentSize。
 Rectangle JComponent.getVisibleRect()
返回该 Component 的“可见矩形”，即此组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight()) 及其所有祖先的可见矩形的交集。

参数类型为 Rectangle 的 javax.swing 中的方法
static Rectangle SwingUtilities.calculateInnerArea(JComponent c, Rectangle r)
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
protected  boolean JViewport.computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
static Rectangle[] SwingUtilities.computeDifference(Rectangle rectA, Rectangle rectB)
返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。
static Rectangle SwingUtilities.computeIntersection(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的交集的便捷方法。
static Rectangle SwingUtilities.computeUnion(int x, int y, int width, int height, Rectangle dest)
在未分配新矩形的情况下计算两个矩形的并集的便捷方法。
 void JComponent.computeVisibleRect(Rectangle visibleRect)
返回该 Component 的“可见 rect 矩形”，即此组件及其所有祖先的可见矩形的交集。
static Rectangle SwingUtilities.convertRectangle(Component source, Rectangle aRectangle, Component destination)
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
 Rectangle JComponent.getBounds(Rectangle rv)
将此组件的边界存储到“返回值”rv 中并返回 rv。
 int JTree.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
返回块增量的数量，它是基于 orientation 的 visibleRect 高度或宽度。
 int JTable.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
返回 visibleRect.height 或 visibleRect.width，这取决于此表的方向。
 int JList.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
返回为显露上一个或下一个块而滚动的距离。
 int Scrollable.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
 int JTree.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
返回滚动时增加的数量。
 int JTable.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
返回完全呈现出一个新行或新列（取决于方向）的滚动增量（以像素为单位）。
 int JTextArea.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
显示逻辑行或列的组件应根据方向的值计算滚动增量，此滚动增量将完全显示一个新行或新列。
 int JList.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
返回为显露上一个或下一个行（垂直滚动）或列（水平滚动）而滚动的距离。
 int Scrollable.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
static boolean SwingUtilities.isRectangleContainingRectangle(Rectangle a, Rectangle b)
如果 a 包含 b，则返回 true。
static String SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static String SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 void JComponent.paintImmediately(Rectangle r)
立即绘制指定的区域。
 void DefaultListCellRenderer.repaint(Rectangle r)
因为性能原因而被重写。
 void JComponent.repaint(Rectangle r)
如果要显示该组件，则将指定的区域添加到脏区列表。
 void JTextField.scrollRectToVisible(Rectangle r)
将字段向左或向右滚动。
 void JViewport.scrollRectToVisible(Rectangle contentRect)
滚动该视图，使该视图中的 Rectangle 变得可见。
 void JComponent.scrollRectToVisible(Rectangle aRect)
将 scrollRectToVisible() 消息转发到 JComponent 的父组件。
 void JTree.AccessibleJTree.AccessibleJTreeNode.setBounds(Rectangle r)
 void JTable.AccessibleJTable.AccessibleJTableCell.setBounds(Rectangle r)
 void JList.AccessibleJList.AccessibleJListChild.setBounds(Rectangle r)
 void JInternalFrame.setNormalBounds(Rectangle r)
设置此内部窗体的正常边界，即此内部窗体从其最大化状态还原后的边界。
protected  void DefaultDesktopManager.setPreviousBounds(JInternalFrame f, Rectangle r)
在进行 maximize 调用之前存储组件的边界。

javax.swing.border 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.border 中的方法
static Rectangle | AbstractBorder.getInteriorRectangle(Component c, Border b, int x, int y, int width, int height) 返回一个用所给的参数减去边框 insets 得到的矩形。
Rectangle | AbstractBorder.getInteriorRectangle(Component c, int x, int y, int width, int height) 此便捷方法调用静态方法。

javax.swing.plaf 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.plaf 中的方法
abstract Rectangle | ListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
abstract Rectangle | TreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
abstract Rectangle | TabbedPaneUI.getTabBounds(JTabbedPane pane, int index)
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
abstract Rectangle | TextUI.modelToView(JTextComponent t, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。

javax.swing.plaf.basic 中 Rectangle 的使用

javax.swing.plaf.basic 中 Rectangle 的子类
static class BasicTextUI.BasicCaret

声明为 Rectangle 的 javax.swing.plaf.basic 中的字段
protected Rectangle | BasicProgressBarUI.boxRect 用于保存要绘制的跳动框（由 getBox 返回）的位置和大小。
protected Rectangle | BasicTabbedPaneUI.calcRect 用于通用布局计算以避免运行中构造多个新 Rectangle 的矩形。
protected Rectangle | BasicSliderUI.contentRect
protected Rectangle | BasicSliderUI.focusRect
protected Rectangle | BasicSliderUI.labelRect
protected Rectangle[] | BasicTabbedPaneUI.rects
protected Rectangle | BasicSliderUI.thumbRect
protected Rectangle | BasicScrollBarUI.thumbRect
protected Rectangle | BasicSliderUI.tickRect
protected Rectangle | BasicSliderUI.trackRect
protected Rectangle | BasicScrollBarUI.trackRect

返回 Rectangle 的 javax.swing.plaf.basic 中的方法
protected Rectangle | BasicComboPopup.computePopupBounds(int px, int py, int pw, int ph) 基于组合框的位置和封闭的屏幕界限计算组合框的弹出部分的位置和大小。
protected Rectangle | BasicProgressBarUI.getBox(Rectangle r) 存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。
Rectangle | BasicListUI.getCellBounds(JList list, int index1, int index2) 返回给定列表坐标系统中的有界矩形，单元的范围由两个索引指定。
Rectangle | BasicTreeUI.NodeDimensionsHandler.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size) 负责获取特定节点的大小。
Rectangle | BasicTreeUI.getPathBounds(JTree tree, TreePath path) 返回封闭标签部分的 Rectangle，路径中的最后一个项将在这一部分绘制。
protected Rectangle | BasicTabbedPaneUI.getTabBounds(int tabIndex, Rectangle dest) 返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。
Rectangle | BasicTabbedPaneUI.getTabBounds(JTabbedPane pane, int i) 返回指定选项卡索引的边界。
protected Rectangle | BasicScrollBarUI.getThumbBounds() 返回 thumb 的当前大小/位置。
protected Rectangle | BasicScrollBarUI.getTrackBounds() 返回滑道的当前边界，即递增和递减按钮之间的空间（减去 insets）。
protected Rectangle | BasicTextUI.getVisibleEditorRect() 获取给出根 View 的分配。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
Rectangle | BasicTextUI.modelToView(JTextComponent tc, int pos, Position.Bias bias) 将模型中的给定位置转换成视图坐标系统中的某一个位置。
protected Rectangle | BasicComboBoxUI.rectangleForCurrentValue() 返回为绘制当前所选项而保留的区域。

参数类型为 Rectangle 的 javax.swing.plaf.basic 中的方法
protected  Rectangle BasicProgressBarUI.getBox(Rectangle r)
存储将为 r 中的当前动画索引绘制并返回 r 的跳动框中位置和大小。
 Rectangle BasicTreeUI.NodeDimensionsHandler.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size)
负责获取特定节点的大小。
protected  Rectangle BasicTabbedPaneUI.getTabBounds(int tabIndex, Rectangle dest)
返回 JTabbedPane 组件的坐标空间中指定选项卡的边界。
protected  String BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。
protected  void BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。
 void BasicComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项。
 void BasicComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项的背景。
protected  void BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的展开（切换）部分。
protected  void BasicButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected  void BasicRadioButtonUI.paintFocus(Graphics g, Rectangle textRect, Dimension size)
protected  void BasicTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制支路 (leg) 的水平部分。
protected  void BasicToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
protected  void BasicTabbedPaneUI.paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
protected  void BasicButtonUI.paintIcon(Graphics g, JComponent c, Rectangle iconRect)
protected  void BasicSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的渲染器部分。
protected  void BasicTabbedPaneUI.paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
protected  void BasicTabbedPaneUI.paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
protected  void BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
呈现当前按钮文本的方法。
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
protected  void BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected  void BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
呈现当前菜单项的文本。
protected  void BasicScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected  void BasicScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected  void BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
绘制支路的垂直部分。

javax.swing.plaf.metal 中 Rectangle 的使用

参数类型为 Rectangle 的 javax.swing.plaf.metal 中的方法
void | MetalComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项。
void | MetalComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项的背景。
protected void | MetalToggleButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalRadioButtonUI.paintFocus(Graphics g, Rectangle t, Dimension d)
protected void | MetalTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | MetalTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect) 在空间 iconRect 中绘制按钮 b 的适当图标。
protected void | MetalSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected void | MetalSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected void | MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | MetalScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)

javax.swing.plaf.multi 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.plaf.multi 中的方法
Rectangle | MultiListUI.getCellBounds(JList a, int b, int c) 在由此对象处理的每个 UI 上调用 getCellBounds 方法。
Rectangle | MultiTreeUI.getPathBounds(JTree a, TreePath b) 在由此对象处理的每个 UI 上调用 getPathBounds 方法。
Rectangle | MultiTabbedPaneUI.getTabBounds(JTabbedPane a, int b) 在由此对象处理的每个 UI 上调用 getTabBounds 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b) 在由此对象处理的每个 UI 上调用 modelToView 方法。
Rectangle | MultiTextUI.modelToView(JTextComponent a, int b, Position.Bias c) 在由此对象处理的每个 UI 上调用 modelToView 方法。

javax.swing.plaf.synth 中 Rectangle 的使用

参数类型为 Rectangle 的 javax.swing.plaf.synth 中的方法
String | SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap) 根据通过引用返回的放置图标和文本的位置，布局文本和图标。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex) 在指定位置上绘制文本。

javax.swing.table 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.table 中的方法
Rectangle | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBounds()
Rectangle | JTableHeader.getHeaderRect(int column) 返回包含 column 处头 tile 的矩形。

参数类型为 Rectangle 的 javax.swing.table 中的方法
void | DefaultTableCellRenderer.repaint(Rectangle r) 因为性能原因而被重写。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setBounds(Rectangle r)

javax.swing.text 中 Rectangle 的使用

javax.swing.text 中 Rectangle 的子类
 class DefaultCaret
插入符的默认实现。

声明为 Rectangle 的 javax.swing.text 中的字段
protected Rectangle | AsyncBoxView.ChildLocator.childAlloc 用于子级分配区域以避免创建大量垃圾的形状。
protected Rectangle | AsyncBoxView.ChildLocator.lastAlloc 最后的可见分配区域（用于向上刷新更改时进行重新绘制）。

返回 Rectangle 的 javax.swing.text 中的方法
Rectangle | JTextComponent.AccessibleJTextComponent.getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
protected Rectangle | CompositeView.getInsideAllocation(Shape a) 将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。
Rectangle | JTextComponent.AccessibleJTextComponent.getTextBounds(int startIndex, int endIndex) 返回包围两个索引之间文本的 Rectangle。
protected Rectangle | PlainView.lineToRect(Shape a, int line) 确定表示给定行的矩形。
Rectangle | JTextComponent.modelToView(int pos) 将模型中给定位置转换为视图坐标系统中的位置。

参数类型为 Rectangle 的 javax.swing.text 中的方法
protected void | DefaultCaret.adjustVisibility(Rectangle nloc) 滚动关联的视图（如果有）以使插入符可见。
void | FlowView.FlowStrategy.changedUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
protected void | BoxView.childAllocation(int index, Rectangle alloc) 为子视图分配一个区域。
protected abstract void | CompositeView.childAllocation(int index, Rectangle a) 返回给定子级的分配区域。
protected void | DefaultCaret.damage(Rectangle r) 毁坏围绕插入符的区域以使该区域在新的位置重绘。
int | JTextComponent.getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
int | JTextComponent.getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。
protected View | BoxView.getViewAtPoint(int x, int y, Rectangle alloc) 获取给定坐标处的子视图。
protected abstract View | CompositeView.getViewAtPoint(int x, int y, Rectangle alloc) 获取位于给定坐标的子视图。
protected View | CompositeView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
protected View | TableView.TableRow.getViewAtPosition(int pos, Rectangle a) 获取表示模型中给定位置的子视图。
void | FlowView.FlowStrategy.insertUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected boolean | BoxView.isAfter(int x, int y, Rectangle innerAlloc) 确定一个点是否位于分配区域的后面。
protected abstract boolean | CompositeView.isAfter(int x, int y, Rectangle alloc) 测试一个点是否位于矩形范围之后。
protected boolean | BoxView.isBefore(int x, int y, Rectangle innerAlloc) 确定一个点是否位于分配区域的前面。
protected abstract boolean | CompositeView.isBefore(int x, int y, Rectangle alloc) 测试一个点是否位于矩形范围之前。
protected void | BoxView.paintChild(Graphics g, Rectangle alloc, int index) 绘制一个子级。
void | FlowView.FlowStrategy.removeUpdate(FlowView fv, DocumentEvent e, Rectangle alloc) 发出通知，通知已从文档中此给定流视图负责的某个位置移除某些内容。

javax.swing.text.html 中 Rectangle 的使用

参数类型为 Rectangle 的 javax.swing.text.html 中的方法
protected  void ListView.paintChild(Graphics g, Rectangle alloc, int index)
通过调用 paint() 绘制其中的一个子级。

javax.swing.tree 中 Rectangle 的使用

返回 Rectangle 的 javax.swing.tree 中的方法
Rectangle | FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回给出绘制路径所需边界的矩形。
Rectangle | VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
abstract Rectangle | AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回一个矩形，该矩形给出了绘制路径所需的 bounds。
protected Rectangle | AbstractLayoutCache.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn) 返回通过 placeIn 中的引用，表示 value 所需的大小。
abstract Rectangle | AbstractLayoutCache.NodeDimensions.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds) 通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。

参数类型为 Rectangle 的 javax.swing.tree 中的方法
Rectangle | FixedHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回给出绘制路径所需边界的矩形。
Rectangle | VariableHeightLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回 Rectangle，它包围在其中绘制 path 标识的项的标签部分。
abstract Rectangle | AbstractLayoutCache.getBounds(TreePath path, Rectangle placeIn) 返回一个矩形，该矩形给出了绘制路径所需的 bounds。
protected Rectangle | AbstractLayoutCache.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn) 返回通过 placeIn 中的引用，表示 value 所需的大小。
abstract Rectangle | AbstractLayoutCache.NodeDimensions.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds) 通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。
int | VariableHeightLayoutCache.getPreferredWidth(Rectangle bounds) 返回 visibleRegion 中区域的首选宽度和高度。
int | AbstractLayoutCache.getPreferredWidth(Rectangle bounds) 返回传入区域的首选宽度。
void | DefaultTreeCellRenderer.repaint(Rectangle r) 因为性能原因而被重写。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.BorderLayout 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BorderLayout
的使用

没有 java.awt.BorderLayout 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.LayoutManager2 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.LayoutManager2
的使用

使用 LayoutManager2 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 LayoutManager2 的使用

实现 LayoutManager2 的 java.awt 中的类
class | BorderLayout 这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
class | CardLayout CardLayout 对象是容器的布局管理器。
class | GridBagLayout GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。

javax.swing 中 LayoutManager2 的使用

实现 LayoutManager2 的 javax.swing 中的类
class | BoxLayout 允许垂直或水平布置多个组件的布局管理器。
class | GroupLayout GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。
protected class | JRootPane.RootLayout 该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
class | OverlayLayout 要在彼此顶部安排组件的布局管理器。
class | SpringLayout SpringLayout 根据一组约束布置其相关容器的子组件。

javax.swing.plaf.basic 中 LayoutManager2 的使用

实现 LayoutManager2 的 javax.swing.plaf.basic 中的类
class | BasicSplitPaneUI.BasicHorizontalLayoutManager 具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
class | BasicSplitPaneUI.BasicVerticalLayoutManager 用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.BasicStroke 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.BasicStroke
的使用

没有 java.awt.BasicStroke 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.Stroke 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Stroke
的使用

使用 Stroke 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Stroke 的使用

实现 Stroke 的 java.awt 中的类
 class BasicStroke
BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。

返回 Stroke 的 java.awt 中的方法
abstract  Stroke Graphics2D.getStroke()
返回 Graphics2D 上下文中的当前 Stroke

参数类型为 Stroke 的 java.awt 中的方法
abstract  void Graphics2D.setStroke(Stroke s)
为 Graphics2D 上下文设置 Stroke

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.AlphaComposite 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AlphaComposite
的使用

使用 AlphaComposite 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 AlphaComposite 的使用

声明为 AlphaComposite 的 java.awt 中的字段
static AlphaComposite | AlphaComposite.Clear 实现不透明 CLEAR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.Dst 实现不透明 DST 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstAtop 实现不透明 DST_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstIn 实现不透明 DST_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstOut 实现不透明 DST_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.DstOver 实现不透明 DST_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.Src 实现不透明 SRC 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcAtop 实现不透明 SRC_ATOP 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcIn 实现不透明 SRC_IN 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcOut 实现不透明 SRC_OUT 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.SrcOver 实现不透明 SRC_OVER 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。
static AlphaComposite | AlphaComposite.Xor 实现不透明 XOR 规则的 AlphaComposite 对象，具有 1.0f 的 alpha 值。

返回 AlphaComposite 的 java.awt 中的方法
AlphaComposite | AlphaComposite.derive(float alpha) 返回一个类似的 AlphaComposite 对象，该对象使用指定的 alpha 值。
AlphaComposite | AlphaComposite.derive(int rule) 返回一个类似的 AlphaComposite 对象，该对象使用指定的复合规则。
static AlphaComposite | AlphaComposite.getInstance(int rule) 创建一个具有指定规则的 AlphaComposite 对象。
static AlphaComposite | AlphaComposite.getInstance(int rule, float alpha) 创建一个 AlphaComposite 对象，它具有指定的规则和用来乘源色 alpha 值的常量 alpha 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Color 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Color
的使用

使用 Color 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Color 的使用

java.awt 中 Color 的子类
 class SystemColor
封装表示系统中本机 GUI 对象颜色的象征性颜色的类。

声明为 Color 的 java.awt 中的字段
static Color | Color.black 黑色。
static Color | Color.BLACK 黑色。
static Color | Color.blue 蓝色。
static Color | Color.BLUE 蓝色。
static Color | Color.cyan 青色。
static Color | Color.CYAN 青色。
static Color | Color.DARK_GRAY 深灰色。
static Color | Color.darkGray 深灰色。
static Color | Color.gray 灰色。
static Color | Color.GRAY 灰色。
static Color | Color.green 绿色。
static Color | Color.GREEN 绿色。
static Color | Color.LIGHT_GRAY 浅灰色。
static Color | Color.lightGray 浅灰色。
static Color | Color.magenta 洋红色。
static Color | Color.MAGENTA 洋红色。
static Color | Color.orange 桔黄色。
static Color | Color.ORANGE 桔黄色。
static Color | Color.pink 粉红色。
static Color | Color.PINK 粉红色。
static Color | Color.red 红色。
static Color | Color.RED 红色。
static Color | Color.white 白色。
static Color | Color.WHITE 白色。
static Color | Color.yellow 黄色。
static Color | Color.YELLOW 黄色。

返回 Color 的 java.awt 中的方法
Color | Color.brighter() 创建一个新 Color，它具有比此 Color 更亮的颜色。
Color | Color.darker() 创建一个新 Color，它具有比此 Color 更暗的颜色。
static Color | Color.decode(String nm) 将 String 转换成整数，并返回指定的不透明 Color。
Color | List.AccessibleAWTList.AccessibleAWTListChild.getBackground() 获取此对象的背景颜色。
Color | TextComponent.getBackground() 获得此文本组件的背景色。
Color | MenuComponent.AccessibleAWTMenuComponent.getBackground() 获取此对象的背景色。
abstract Color | Graphics2D.getBackground() 返回用于清除区域的背景色。
Color | Component.getBackground() 获取组件的背景色。
Color | Component.AccessibleAWTComponent.getBackground() 获取此对象的背景色。
abstract Color | Graphics.getColor() 获取此图形上下文的当前颜色。
static Color | Color.getColor(String nm) 查找系统属性中的一种颜色。
static Color | Color.getColor(String nm, Color v) 查找系统属性中的一种颜色。
static Color | Color.getColor(String nm, int v) 查找系统属性中的一种颜色。
Color | GradientPaint.getColor1() 返回点 P1 的颜色 C1。
Color | GradientPaint.getColor2() 返回点 P2 的颜色 C2。
Color[] | MultipleGradientPaint.getColors() 返回此渐变所使用的颜色数组的副本。
Color | List.AccessibleAWTList.AccessibleAWTListChild.getForeground() 获取此对象的前景颜色。
Color | MenuComponent.AccessibleAWTMenuComponent.getForeground() 获取此对象的前景色。
Color | Component.getForeground() 获取组件的前景色。
Color | Component.AccessibleAWTComponent.getForeground() 获取此对象的前景色。
static Color | Color.getHSBColor(float h, float s, float b) 根据所指定的数值，创建一个基于 HSB 颜色模型的 Color 对象。
Color | Robot.getPixelColor(int x, int y) 返回给定屏幕坐标处的像素颜色。

参数类型为 Color 的 java.awt 中的方法
abstract boolean | Graphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 绘制指定图像中当前可用的图像。
abstract boolean | Graphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 绘制指定图像中已缩放到适合指定矩形内部的图像。
abstract boolean | Graphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 绘制当前可用的指定图像的指定区域，动态地缩放图像使其符合目标绘制表面的指定区域。
static Color | Color.getColor(String nm, Color v) 查找系统属性中的一种颜色。
void | List.AccessibleAWTList.AccessibleAWTListChild.setBackground(Color c) 设置此对象的背景颜色。
void | TextComponent.setBackground(Color c) 设置此文本组件的背景色。
void | MenuComponent.AccessibleAWTMenuComponent.setBackground(Color c) 设置此对象的背景色。
abstract void | Graphics2D.setBackground(Color color) 设置 Graphics2D 上下文的背景色。
void | Component.setBackground(Color c) 设置组件的背景色。
void | Component.AccessibleAWTComponent.setBackground(Color c) 设置此对象的背景色。
abstract void | Graphics.setColor(Color c) 将此图形上下文的当前颜色设置为指定颜色。
void | List.AccessibleAWTList.AccessibleAWTListChild.setForeground(Color c) 设置此对象的前景颜色。
void | MenuComponent.AccessibleAWTMenuComponent.setForeground(Color c) 设置此对象的前景色。
void | Component.setForeground(Color c) 设置组件的前景色。
void | Component.AccessibleAWTComponent.setForeground(Color c) 设置此对象的前景色。
abstract void | Graphics.setXORMode(Color c1) 将此图形上下文的绘图模式设置为在此图形上下文的当前颜色和新的指定颜色之间交替。

参数类型为 Color 的 java.awt 中的构造方法
GradientPaint(float x1, float y1, Color color1, float x2, float y2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(float x1, float y1, Color color1, float x2, float y2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2)
构造一个简单的非周期性 GradientPaint 对象。
GradientPaint(Point2D pt1, Color color1, Point2D pt2, Color color2, boolean cyclic)
根据 boolean 参数构造一个周期性或非周期性的 GradientPaint 对象。
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(float startX, float startY, float endX, float endY, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors)
构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 LinearGradientPaint。
LinearGradientPaint(Point2D start, Point2D end, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 LinearGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(float cx, float cy, float radius, float fx, float fy, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors)
用中心点作为焦点，构造一个具有默认 NO_CYCLE 重复方法和 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
用中心点作为焦点，构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。
RadialGradientPaint(Point2D center, float radius, Point2D focus, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod, MultipleGradientPaint.ColorSpaceType colorSpace, AffineTransform gradientTransform)
构造一个 RadialGradientPaint。
RadialGradientPaint(Rectangle2D gradientBounds, float[] fractions, Color[] colors, MultipleGradientPaint.CycleMethod cycleMethod)
构造一个具有默认 SRGB 颜色空间的 RadialGradientPaint。

javax.accessibility 中 Color 的使用

返回 Color 的 javax.accessibility 中的方法
Color | AccessibleComponent.getBackground() 获取此对象的背景色。
Color | AccessibleComponent.getForeground() 获取此对象的前景色。

参数类型为 Color 的 javax.accessibility 中的方法
void | AccessibleComponent.setBackground(Color c) 设置此对象的背景色。
void | AccessibleComponent.setForeground(Color c) 设置此对象的前景色。

javax.swing 中 Color 的使用

声明为 Color 的 javax.swing 中的字段
protected Color | JTable.gridColor 网格的颜色。
protected Color | JTable.selectionBackground 已选定单元格的背景色。
protected Color | JTable.selectionForeground 已选定单元格的前景色。

返回 Color 的 javax.swing 中的方法
static Color | DebugGraphics.flashColor() 返回用于 flash 绘制操作的 Color。
Color | JTree.AccessibleJTree.AccessibleJTreeNode.getBackground() 获取此对象的背景色。
Color | JTable.AccessibleJTable.AccessibleJTableCell.getBackground() 获取此对象的背景色。
Color | JList.AccessibleJList.AccessibleJListChild.getBackground()
Color | JTabbedPane.getBackgroundAt(int index) 返回 index 位置的选项卡背景色。
Color | DebugGraphics.getColor() 返回用于文本绘制操作的 Color。
Color | JColorChooser.getColor() 获取颜色选取器的当前颜色值。
Color | UIDefaults.getColor(Object key) 如果 key 值为一个 Color，则返回它，否则返回 null。
static Color | UIManager.getColor(Object key) 从默认值返回一种颜色。
Color | UIDefaults.getColor(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。
static Color | UIManager.getColor(Object key, Locale l) 从适合给定语言环境的默认值中返回一种颜色。
Color | JTree.AccessibleJTree.AccessibleJTreeNode.getForeground() 获取此对象的前景色。
Color | JTable.AccessibleJTable.AccessibleJTableCell.getForeground() 获取此对象的前景色。
Color | JList.AccessibleJList.AccessibleJListChild.getForeground()
Color | JTabbedPane.getForegroundAt(int index) 返回 index 位置的选项卡背景色。
Color | JTable.getGridColor() 返回用来绘制网格线的颜色。
Color | JTable.getSelectionBackground() 返回选定单元格的背景色。
Color | JList.getSelectionBackground() 返回用于绘制选定项的背景的颜色。
Color | JTable.getSelectionForeground() 返回选定单元格的前景色。
Color | JList.getSelectionForeground() 返回用于绘制选定项的前景的颜色。
static Color | JColorChooser.showDialog(Component component, String title, Color initialColor) 显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。

参数类型为 Color 的 javax.swing 中的方法
static Border | BorderFactory.createBevelBorder(int type, Color highlight, Color shadow) 使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。
static Border | BorderFactory.createBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner) 创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。
static Border | BorderFactory.createEtchedBorder(Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createEtchedBorder(int type, Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createLineBorder(Color color) 创建一个具有指定颜色的线边框。
static Border | BorderFactory.createLineBorder(Color color, int thickness) 创建一个具有指定颜色和宽度的线边框。
static MatteBorder | BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Color color) 使用纯色创建一个类似衬边的边框。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
boolean | DebugGraphics.drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | DebugGraphics.drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setBackground(Color c) 设置此对象的背景色。
void | JTable.AccessibleJTable.AccessibleJTableCell.setBackground(Color c) 设置此对象的背景色。
void | JList.AccessibleJList.AccessibleJListChild.setBackground(Color c)
void | JComponent.setBackground(Color bg) 设置此组件的背景色。
void | JTabbedPane.setBackgroundAt(int index, Color background) 将 index 位置的背景色设置为 background，它可以为 null，在这种情况下选项卡的背景色默认为 tabbedpane 的背景色。
void | DebugGraphics.setColor(Color aColor) 设置用于绘制和填充线条和图形的颜色。
void | JColorChooser.setColor(Color color) 将颜色选取器的当前颜色设置为指定颜色。
static void | DebugGraphics.setFlashColor(Color flashColor) 设置用于 flash 绘制操作的 Color。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setForeground(Color c)
void | JTable.AccessibleJTable.AccessibleJTableCell.setForeground(Color c) 设置此对象的前景色。
void | JList.AccessibleJList.AccessibleJListChild.setForeground(Color c)
void | JComponent.setForeground(Color fg) 设置此组件的前景色。
void | JTabbedPane.setForegroundAt(int index, Color foreground) 将 index 位置的前景色设置为 foreground，它可以为 null，在这种情况下选项卡的前景色默认为此 tabbedpane 的前景色。
void | JTable.setGridColor(Color gridColor) 将用来绘制网格线的颜色设置为 gridColor 并重新显示它。
void | JTable.setSelectionBackground(Color selectionBackground) 设置选定单元格的背景色。
void | JList.setSelectionBackground(Color selectionBackground) 设置用于绘制选定项的背景的颜色，单元渲染器可以使用此颜色填充所选单元。
void | JTable.setSelectionForeground(Color selectionForeground) 设置选定单元格的前景色。
void | JList.setSelectionForeground(Color selectionForeground) 设置用于绘制选定项的前景的颜色，单元渲染器可以使用此颜色呈现文本和图形。
void | DebugGraphics.setXORMode(Color aColor) 重写 Graphics.setXORMode。
static Color | JColorChooser.showDialog(Component component, String title, Color initialColor) 显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。

参数类型为 Color 的 javax.swing 中的构造方法
JColorChooser(Color initialColor)
创建具有指定初始颜色的颜色选取器窗格。

javax.swing.border 中 Color 的使用

声明为 Color 的 javax.swing.border 中的字段
protected Color | MatteBorder.color
protected Color | EtchedBorder.highlight
protected Color | BevelBorder.highlightInner
protected Color | BevelBorder.highlightOuter
protected Color | LineBorder.lineColor
protected Color | EtchedBorder.shadow
protected Color | BevelBorder.shadowInner
protected Color | BevelBorder.shadowOuter
protected Color | TitledBorder.titleColor

返回 Color 的 javax.swing.border 中的方法
Color | EtchedBorder.getHighlightColor() 返回浮雕化边框的高亮显示颜色。
Color | EtchedBorder.getHighlightColor(Component c) 返回浮雕化边框在指定组件上呈现的高亮显示颜色。
Color | BevelBorder.getHighlightInnerColor() 返回斜面边框内部的高亮显示颜色。
Color | BevelBorder.getHighlightInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部高亮显示颜色。
Color | BevelBorder.getHighlightOuterColor() 返回斜面边框外部的高亮显示颜色。
Color | BevelBorder.getHighlightOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部高亮显示颜色。
Color | LineBorder.getLineColor() 返回边框的颜色。
Color | MatteBorder.getMatteColor() 返回平铺边框的颜色，如果使用了平铺图标，则返回 null。
Color | EtchedBorder.getShadowColor() 返回浮雕化边框的阴影颜色。
Color | EtchedBorder.getShadowColor(Component c) 返回浮雕化边框在指定组件上呈现的阴影颜色。
Color | BevelBorder.getShadowInnerColor() 返回斜面边框内部的阴影颜色。
Color | BevelBorder.getShadowInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部阴影颜色。
Color | BevelBorder.getShadowOuterColor() 返回斜面边框的外部阴影颜色。
Color | BevelBorder.getShadowOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部阴影颜色。
Color | TitledBorder.getTitleColor() 返回带标题边框的标题颜色。

参数类型为 Color 的 javax.swing.border 中的方法
 void TitledBorder.setTitleColor(Color titleColor)
设置带标题边框的标题颜色。

参数类型为 Color 的 javax.swing.border 中的构造方法
BevelBorder(int bevelType, Color highlight, Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
BevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
EtchedBorder(Color highlight, Color shadow)
创建具有指定高亮显示和阴影颜色的阴刻浮雕化边框
EtchedBorder(int etchType, Color highlight, Color shadow)
创建具有指定蚀刻类型、高亮显示和阴影颜色的浮雕化边框
LineBorder(Color color)
创建具有指定颜色、厚度为 1（thickness = 1）的线边框。
LineBorder(Color color, int thickness)
创建具有指定颜色和厚度的线边框。
LineBorder(Color color, int thickness, boolean roundedCorners)
创建具有指定颜色、厚度和拐角形状的线条边框。
MatteBorder(Insets borderInsets, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(int top, int left, int bottom, int right, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
SoftBevelBorder(int bevelType, Color highlight, Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
SoftBevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

javax.swing.colorchooser 中 Color 的使用

返回 Color 的 javax.swing.colorchooser 中的方法
protected Color | AbstractColorChooserPanel.getColorFromModel() 返回当前所选取的颜色。
Color | ColorSelectionModel.getSelectedColor() 返回所选取的 Color，它不应为 null。
Color | DefaultColorSelectionModel.getSelectedColor() 返回所选取的 Color，它不应为 null。

参数类型为 Color 的 javax.swing.colorchooser 中的方法
void | ColorSelectionModel.setSelectedColor(Color color) 将选取的颜色设置为 color。
void | DefaultColorSelectionModel.setSelectedColor(Color color) 将选取的颜色设置为 color。

参数类型为 Color 的 javax.swing.colorchooser 中的构造方法
DefaultColorSelectionModel(Color color)
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 color，该颜色不应为 null。

javax.swing.plaf 中 Color 的使用

javax.swing.plaf 中 Color 的子类
 class ColorUIResource

参数类型为 Color 的 javax.swing.plaf 中的构造方法
BorderUIResource.BevelBorderUIResource(int bevelType, Color highlight, Color shadow)
BorderUIResource.BevelBorderUIResource(int bevelType, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner)
BorderUIResource.EtchedBorderUIResource(Color highlight, Color shadow)
BorderUIResource.EtchedBorderUIResource(int etchType, Color highlight, Color shadow)
BorderUIResource.LineBorderUIResource(Color color)
BorderUIResource.LineBorderUIResource(Color color, int thickness)
BorderUIResource.MatteBorderUIResource(int top, int left, int bottom, int right, Color color)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
ColorUIResource(Color c)

javax.swing.plaf.basic 中 Color 的使用

声明为 Color 的 javax.swing.plaf.basic 中的字段
protected Color | BasicMenuItemUI.acceleratorForeground
protected Color | BasicMenuItemUI.acceleratorSelectionForeground
protected Color | BasicBorders.ButtonBorder.darkShadow
protected Color | BasicBorders.FieldBorder.darkShadow
protected Color | BasicTabbedPaneUI.darkShadow
protected Color | BasicMenuItemUI.disabledForeground
protected Color | BasicToolBarUI.dockingBorderColor
protected Color | BasicToolBarUI.dockingColor
protected Color | BasicToolBarUI.floatingBorderColor
protected Color | BasicToolBarUI.floatingColor
protected Color | BasicTabbedPaneUI.focus
protected Color | BasicBorders.ButtonBorder.highlight
protected Color | BasicBorders.FieldBorder.highlight
protected Color | BasicBorders.SplitPaneBorder.highlight
protected Color | BasicTabbedPaneUI.highlight
protected Color | BasicSeparatorUI.highlight
protected Color | BasicBorders.ButtonBorder.lightHighlight
protected Color | BasicBorders.FieldBorder.lightHighlight
protected Color | BasicTabbedPaneUI.lightHighlight
protected Color | BasicInternalFrameTitlePane.notSelectedTextColor
protected Color | BasicInternalFrameTitlePane.notSelectedTitleColor
protected Color | BasicInternalFrameTitlePane.selectedTextColor
protected Color | BasicInternalFrameTitlePane.selectedTitleColor
protected Color | BasicMenuItemUI.selectionBackground
protected Color | BasicMenuItemUI.selectionForeground
protected Color | BasicBorders.ButtonBorder.shadow
protected Color | BasicBorders.FieldBorder.shadow
protected Color | BasicBorders.SplitPaneBorder.shadow
protected Color | BasicTabbedPaneUI.shadow
protected Color | BasicSeparatorUI.shadow
protected Color | BasicScrollBarUI.thumbColor
protected Color | BasicScrollBarUI.thumbDarkShadowColor
protected Color | BasicScrollBarUI.thumbHighlightColor
protected Color | BasicScrollBarUI.thumbLightShadowColor
protected Color | BasicScrollBarUI.trackColor
protected Color | BasicScrollBarUI.trackHighlightColor

返回 Color 的 javax.swing.plaf.basic 中的方法
Color | BasicToolBarUI.DragWindow.getBorderColor()
Color | BasicToolBarUI.getDockingColor() 获取在连接 (docking) 区域上时显示的颜色。
Color | BasicToolBarUI.getFloatingColor() 获取在浮动区域上时显示的颜色。
protected Color | BasicSliderUI.getFocusColor()
protected Color | BasicTreeUI.getHashColor()
protected Color | BasicSliderUI.getHighlightColor()
protected Color | BasicProgressBarUI.getSelectionBackground() 如果在进度条的未填充区域上绘制文本，则文本的颜色为 "selectionBackground"。
protected Color | BasicProgressBarUI.getSelectionForeground() 如果在进度条的填充区域上绘制文本，文本的颜色为 "selectionForeground"。
protected Color | BasicSliderUI.getShadowColor()

参数类型为 Color 的 javax.swing.plaf.basic 中的方法
static void | BasicGraphicsUtils.drawBezel(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void | BasicGraphicsUtils.drawEtchedRect(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void | BasicGraphicsUtils.drawGroove(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
static void | BasicGraphicsUtils.drawLoweredBezel(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
protected void | BasicMenuItemUI.paintBackground(Graphics g, JMenuItem menuItem, Color bgColor) 绘制菜单项的背景。
protected void | BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
void | BasicToolBarUI.DragWindow.setBorderColor(Color c)
void | BasicToolBarUI.setDockingColor(Color c) 设置在连接区域上时显示的颜色。
void | BasicToolBarUI.setFloatingColor(Color c) 设置在浮动区域上时显示的颜色。
protected void | BasicTreeUI.setHashColor(Color color)

参数类型为 Color 的 javax.swing.plaf.basic 中的构造方法
BasicArrowButton(int direction, Color background, Color shadow, Color darkShadow, Color highlight)
创建一个在指定方向上绘制其箭头并具有指定颜色的 BasicArrowButton。
BasicBorders.ButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.FieldBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.MenuBarBorder(Color shadow, Color highlight)
BasicBorders.RadioButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.RolloverButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
BasicBorders.SplitPaneBorder(Color highlight, Color shadow)
BasicBorders.ToggleButtonBorder(Color shadow, Color darkShadow, Color highlight, Color lightHighlight)

javax.swing.plaf.metal 中 Color 的使用

声明为 Color 的 javax.swing.plaf.metal 中的字段
protected static Color | MetalSliderUI.darkShadowColor
protected Color | MetalRadioButtonUI.disabledTextColor
protected Color | MetalToggleButtonUI.disabledTextColor
protected Color | MetalButtonUI.disabledTextColor
protected Color | MetalRadioButtonUI.focusColor
protected Color | MetalToggleButtonUI.focusColor
protected Color | MetalButtonUI.focusColor
protected static Color | MetalSliderUI.highlightColor
protected Color | MetalRadioButtonUI.selectColor
protected Color | MetalTabbedPaneUI.selectColor
protected Color | MetalToggleButtonUI.selectColor
protected Color | MetalButtonUI.selectColor
protected Color | MetalTabbedPaneUI.selectHighlight
protected Color | MetalTabbedPaneUI.tabAreaBackground
protected static Color | MetalSliderUI.thumbColor

返回 Color 的 javax.swing.plaf.metal 中的方法
protected Color | MetalTabbedPaneUI.getColorForGap(int currentRun, int x, int y)
protected Color | MetalRadioButtonUI.getDisabledTextColor()
protected Color | MetalToggleButtonUI.getDisabledTextColor()
protected Color | MetalButtonUI.getDisabledTextColor()
protected Color | MetalRadioButtonUI.getFocusColor()
protected Color | MetalToggleButtonUI.getFocusColor()
protected Color | MetalButtonUI.getFocusColor()
protected Color | MetalRadioButtonUI.getSelectColor()
protected Color | MetalToggleButtonUI.getSelectColor()
protected Color | MetalButtonUI.getSelectColor()

javax.swing.plaf.synth 中 Color 的使用

返回 Color 的 javax.swing.plaf.synth 中的方法
Color | SynthStyle.getColor(SynthContext context, ColorType type) 返回指定状态的颜色。
protected abstract Color | SynthStyle.getColorForState(SynthContext context, ColorType type) 返回指定状态的颜色。

javax.swing.table 中 Color 的使用

返回 Color 的 javax.swing.table 中的方法
Color | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getBackground()
Color | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getForeground()

参数类型为 Color 的 javax.swing.table 中的方法
void | DefaultTableCellRenderer.setBackground(Color c) 重写 JComponent.setBackground 将未选定单元格的背景色分配为指定颜色。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setBackground(Color c)
void | DefaultTableCellRenderer.setForeground(Color c) 重写 JComponent.setForeground 将未选定单元格的前景色分配为指定颜色。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setForeground(Color c)

javax.swing.text 中 Color 的使用

返回 Color 的 javax.swing.text 中的方法
Color | GlyphView.getBackground() 获取用于呈现字形的背景色。
Color | LabelView.getBackground() 获取用于呈现字形的背景色。
Color | DefaultStyledDocument.getBackground(AttributeSet attr) 从属性集获得背景颜色。
Color | StyledDocument.getBackground(AttributeSet attr) 使用一个属性集并将其转换为一个背景色规范。
static Color | StyleConstants.getBackground(AttributeSet a) 从属性列表中获取背景色设置。
Color | StyleContext.getBackground(AttributeSet attr) 使用一个属性集并将其转换成为一个背景色规范。
Color | JTextComponent.getCaretColor() 获取用于呈现插入符的当前颜色。
Color | DefaultHighlighter.DefaultHighlightPainter.getColor() 返回高亮显示的颜色。
Color | JTextComponent.getDisabledTextColor() 获取用于呈现禁用文本的当前颜色。
Color | GlyphView.getForeground() 获取用于呈现字形的前景色。
Color | LabelView.getForeground() 获取用于呈现字形的前景色。
Color | DefaultStyledDocument.getForeground(AttributeSet attr) 从属性集获得前景色。
Color | StyledDocument.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
static Color | StyleConstants.getForeground(AttributeSet a) 从属性列表中获取前景色设置。
Color | StyleContext.getForeground(AttributeSet attr) 使用一个属性集并将其转换成为一个前景色规范。
Color | JTextComponent.getSelectedTextColor() 获取用于呈现选定文本的当前颜色。
Color | JTextComponent.getSelectionColor() 获取用于呈现选定的当前颜色。

参数类型为 Color 的 javax.swing.text 中的方法
protected void | LabelView.setBackground(Color bg) 设置视图的背景色。
static void | StyleConstants.setBackground(MutableAttributeSet a, Color fg) 设置背景色。
void | JTextComponent.setCaretColor(Color c) 设置用于呈现插入符的当前颜色。
void | JTextComponent.setDisabledTextColor(Color c) 设置用于呈现禁用文本的当前颜色。
static void | StyleConstants.setForeground(MutableAttributeSet a, Color fg) 设置前景色。
void | JTextComponent.setSelectedTextColor(Color c) 设置用于呈现选定文本的当前颜色。
void | JTextComponent.setSelectionColor(Color c) 设置用于呈现选定的当前颜色。

参数类型为 Color 的 javax.swing.text 中的构造方法
DefaultHighlighter.DefaultHighlightPainter(Color c)
构造新的高亮显示 painter。
StyledEditorKit.ForegroundAction(String nm, Color fg)
创建新的 ForegroundAction。

javax.swing.text.html 中 Color 的使用

返回 Color 的 javax.swing.text.html 中的方法
Color | StyleSheet.getBackground(AttributeSet a) 获取一个属性集并将其转换为背景色规范。
Color | StyleSheet.getForeground(AttributeSet a) 获取一个属性集并将其转换为前景色规范。
Color | StyleSheet.stringToColor(String string) 将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。

javax.swing.tree 中 Color 的使用

声明为 Color 的 javax.swing.tree 中的字段
protected Color | DefaultTreeCellRenderer.backgroundNonSelectionColor 不选定节点时用于背景的颜色。
protected Color | DefaultTreeCellRenderer.backgroundSelectionColor 选定节点时用于背景的颜色。
protected Color | DefaultTreeCellEditor.borderSelectionColor 如果应绘制边框选择色，则为 true。
protected Color | DefaultTreeCellRenderer.borderSelectionColor 节点具有焦点时，用于焦点指示符的颜色。
protected Color | DefaultTreeCellRenderer.textNonSelectionColor 用于非选定节点的前景颜色。
protected Color | DefaultTreeCellRenderer.textSelectionColor 用于选定节点的前景颜色。

返回 Color 的 javax.swing.tree 中的方法
Color | DefaultTreeCellRenderer.getBackgroundNonSelectionColor() 返回用于非选定节点的背景色。
Color | DefaultTreeCellRenderer.getBackgroundSelectionColor() 返回在选定节点的情况下背景所使用的颜色。
Color | DefaultTreeCellEditor.getBorderSelectionColor() 返回绘制边框的颜色。
Color | DefaultTreeCellRenderer.getBorderSelectionColor() 返回绘制边框时所使用的颜色。
Color | DefaultTreeCellRenderer.getTextNonSelectionColor() 返回未选定节点时绘制文本所使用的颜色。
Color | DefaultTreeCellRenderer.getTextSelectionColor() 返回选定节点时绘制文本所使用的颜色。

参数类型为 Color 的 javax.swing.tree 中的方法
void | DefaultTreeCellRenderer.setBackground(Color color) 创建子类，以便将 ColorUIResource 映射为 null。
void | DefaultTreeCellRenderer.setBackgroundNonSelectionColor(Color newColor) 设置用于非选定节点的背景色。
void | DefaultTreeCellRenderer.setBackgroundSelectionColor(Color newColor) 设置在选定节点的情况下背景所使用的颜色。
void | DefaultTreeCellEditor.setBorderSelectionColor(Color newColor) 设置用于边框的颜色。
void | DefaultTreeCellRenderer.setBorderSelectionColor(Color newColor) 设置用于边框的颜色。
void | DefaultTreeCellRenderer.setTextNonSelectionColor(Color newColor) 设置选定节点时绘制文本所使用的颜色。
void | DefaultTreeCellRenderer.setTextSelectionColor(Color newColor) 设置选定节点时绘制文本所使用的颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.Paint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Paint
的使用

使用 Paint 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

java.awt 中 Paint 的使用

实现 Paint 的 java.awt 中的类
class | Color Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
class | GradientPaint GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。
class | LinearGradientPaint LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
class | MultipleGradientPaint 这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
class | RadialGradientPaint RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。
class | SystemColor 封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
class | TexturePaint TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。

返回 Paint 的 java.awt 中的方法
abstract  Paint Graphics2D.getPaint()
返回 Graphics2D 上下文中的当前 Paint

参数类型为 Paint 的 java.awt 中的方法
abstract  void Graphics2D.setPaint(Paint paint)
为 Graphics2D 上下文设置 Paint 属性。

javax.swing.plaf 中 Paint 的使用

实现 Paint 的 javax.swing.plaf 中的类
 class ColorUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Graphics2D 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Graphics2D
的使用

使用 Graphics2D 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 Graphics2D 的使用

返回 Graphics2D 的 java.awt 中的方法
Graphics2D | SplashScreen.createGraphics() 创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。
abstract Graphics2D | GraphicsEnvironment.createGraphics(BufferedImage img) 返回一个呈现指定 BufferedImage 的 Graphics2D 对象。

java.awt.font 中 Graphics2D 的使用

参数类型为 Graphics2D 的 java.awt.font 中的方法
abstract void | GraphicAttribute.draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
void | ImageGraphicAttribute.draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
void | ShapeGraphicAttribute.draw(Graphics2D graphics, float x, float y) 在指定的位置呈现此 GraphicAttribute。
void | TextLayout.draw(Graphics2D g2, float x, float y) 在指定的 Graphics2D 上下文中的指定位置上呈现此 TextLayout。

java.awt.image 中 Graphics2D 的使用

返回 Graphics2D 的 java.awt.image 中的方法
Graphics2D | BufferedImage.createGraphics() 创建一个 Graphics2D，可以将它绘制到此 BufferedImage 中。
abstract Graphics2D | VolatileImage.createGraphics() 创建一个 Graphics2D，可以将它绘制到此 VolatileImage 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Graphics 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Graphics
的使用

使用 Graphics 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Graphics 的使用

java.awt 中 Graphics 的子类
 class Graphics2D
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。

返回 Graphics 的 java.awt 中的方法
abstract Graphics | Graphics.create() 创建一个新的 Graphics 对象，它是此 Graphics 对象的副本。
Graphics | Graphics.create(int x, int y, int width, int height) 基于此 Graphics 对象创建一个新的 Graphics 对象，但是使用新的转换和剪贴区域。
Graphics | Component.FlipBufferStrategy.getDrawGraphics()
Graphics | Component.BltBufferStrategy.getDrawGraphics()
abstract Graphics | PrintJob.getGraphics() 获取将绘制到下一页的 Graphics 对象。
abstract Graphics | Image.getGraphics() 创建供绘制闭屏图像（off-screen image）使用的图形上下文。
Graphics | Component.getGraphics() 为组件创建一个图形上下文。

参数类型为 Graphics 的 java.awt 中的方法
LineMetrics | FontMetrics.getLineMetrics(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。
Rectangle2D | FontMetrics.getMaxCharBounds(Graphics context) 返回指定 Graphics 上下文中具有最大边界的字符的边界。
Rectangle2D | FontMetrics.getStringBounds(char[] chars, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定字符数组的边界。
Rectangle2D | FontMetrics.getStringBounds(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。
Rectangle2D | FontMetrics.getStringBounds(String str, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。
Rectangle2D | FontMetrics.getStringBounds(String str, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 String 的边界。
void | Canvas.paint(Graphics g) 绘制此 canvas。
void | Container.paint(Graphics g) 绘制容器。
void | Component.paint(Graphics g) 绘制此组件。
void | Component.paintAll(Graphics g) 绘制此组件及其所有子组件。
void | Container.paintComponents(Graphics g) 绘制此容器中的每个组件。
void | Container.print(Graphics g) 打印容器。
void | Component.print(Graphics g) 打印此组件。
void | Component.printAll(Graphics g) 打印此组件及其所有子组件。
void | ScrollPane.printComponents(Graphics g) 显示此滚动窗格中的组件。
void | Container.printComponents(Graphics g) 打印此容器中的每个组件。
void | Canvas.update(Graphics g) 更新此 canvas。
void | Container.update(Graphics g) 更新容器。
void | Component.update(Graphics g) 更新组件。

java.awt.image 中 Graphics 的使用

返回 Graphics 的 java.awt.image 中的方法
abstract Graphics | BufferStrategy.getDrawGraphics() 创建用于绘制缓冲区的图形上下文。
Graphics | BufferedImage.getGraphics() 此方法返回 Graphics2D，但此处是出于向后兼容性的考虑。
Graphics | VolatileImage.getGraphics() 此方法返回 Graphics2D，但它存在于此处是出于向后兼容性的考虑。

java.awt.print 中 Graphics 的使用

参数类型为 Graphics 的 java.awt.print 中的方法
 int Printable.print(Graphics graphics, PageFormat pageFormat, int pageIndex)
将指定索引处的页面用指定格式打印到指定的 Graphics 上下文。

java.beans 中 Graphics 的使用

参数类型为 Graphics 的 java.beans 中的方法
void | PropertyEditor.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。
void | PropertyEditorSupport.paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。

javax.swing 中 Graphics 的使用

javax.swing 中 Graphics 的子类
 class DebugGraphics
支持图形调试的图形子类。

返回 Graphics 的 javax.swing 中的方法
Graphics | DebugGraphics.create() 重写 Graphics.create 来返回一个 DebugGraphics 对象。
Graphics | DebugGraphics.create(int x, int y, int width, int height) 重写 Graphics.create 来返回一个 DebugGraphics 对象。
protected Graphics | JComponent.getComponentGraphics(Graphics g) 返回用于绘制此组件的图形对象。
Graphics | JApplet.getGraphics() 为组件创建一个图形上下文。
Graphics | JWindow.getGraphics() 为组件创建一个图形上下文。
Graphics | JDialog.getGraphics() 为组件创建一个图形上下文。
Graphics | JComponent.getGraphics() 返回此组件的图形上下文，该上下文允许您绘制组件。
Graphics | JFrame.getGraphics() 为组件创建一个图形上下文。

参数类型为 Graphics 的 javax.swing 中的方法
protected  Graphics JComponent.getComponentGraphics(Graphics g)
返回用于绘制此组件的图形对象。
 void JViewport.paint(Graphics g)
通过后备存储绘制图像，或者使用后备存储“位图传送”剩余图像来仅绘制最新暴露的部分，这具体取决于是否启用 backingStore。
 void CellRendererPane.paint(Graphics g)
不应调用。
 void JLayeredPane.paint(Graphics g)
在指定的图形上下文中绘制此 JLayeredPane。
 void JComponent.paint(Graphics g)
由 Swing 调用，以绘制组件。
protected  void JProgressBar.paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制进度条的边框。
protected  void JPopupMenu.paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制弹出菜单的边框。
protected  void JMenuBar.paintBorder(Graphics g)
如果 BorderPainted 属性为 true，则绘制菜单栏的边框。
protected  void JToolBar.paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制工具栏边框。
protected  void AbstractButton.paintBorder(Graphics g)
如果 BorderPainted 属性为 true 并且按钮有边框，则绘制该按钮边框。
protected  void JComponent.paintBorder(Graphics g)
绘制组件的边框。
protected  void JSplitPane.paintChildren(Graphics g)
通知超类后，UI 通过 finishedPaintingChildren 通知子类，同时绘制边框。
protected  void JComponent.paintChildren(Graphics g)
绘制此组件的子组件。
protected  void Box.paintComponent(Graphics g)
绘制此 Box。
protected  void Box.Filler.paintComponent(Graphics g)
绘制此 Filler。
protected  void JInternalFrame.paintComponent(Graphics g)
重写此方法，以便在拖动内部窗体时允许进行优化的绘制。
protected  void JComponent.paintComponent(Graphics g)
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
在指定的 Graphics 上绘制组件。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 void ImageIcon.paintIcon(Component c, Graphics g, int x, int y)
绘制图标。
 void Icon.paintIcon(Component c, Graphics g, int x, int y)
在指定位置上绘制图标。
 void JComponent.print(Graphics g)
调用此方法打印指定 Graphics 的组件。
 void JComponent.printAll(Graphics g)
调用此方法打印组件。
protected  void JComponent.printBorder(Graphics g)
打印组件的边框。
protected  void JComponent.printChildren(Graphics g)
打印此组件的子组件。
protected  void JComponent.printComponent(Graphics g)
在打印操作期间调用此方法。
 void JApplet.update(Graphics g)
调用 paint(g)。
 void JWindow.update(Graphics g)
调用 paint(g)。
 void CellRendererPane.update(Graphics g)
不应调用。
 void JDialog.update(Graphics g)
调用 paint(g)。
 void JComponent.update(Graphics g)
调用 paint。
 void JFrame.update(Graphics g)
只是调用 paint(g)。

参数类型为 Graphics 的 javax.swing 中的构造方法
DebugGraphics(Graphics graphics)
根据现有图形上下文构造一个调试图形上下文，该上下文支持减慢绘制。
DebugGraphics(Graphics graphics, JComponent component)
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。

javax.swing.border 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.border 中的方法
void | SoftBevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸绘制指定组件的边框。
void | TitledBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和大小为指定的组件绘制边框。
void | BevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
void | EtchedBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框
void | LineBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框。
void | MatteBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制衬边边框。
void | CompoundBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。
void | EmptyBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 默认情况下不执行绘制。
void | AbstractBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
void | Border.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
protected void | BevelBorder.paintLoweredBevel(Component c, Graphics g, int x, int y, int width, int height)
protected void | BevelBorder.paintRaisedBevel(Component c, Graphics g, int x, int y, int width, int height)

javax.swing.colorchooser 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.colorchooser 中的方法
 void AbstractColorChooserPanel.paint(Graphics g)
绘制面板。

javax.swing.plaf 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf 中的方法
abstract void | SplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g) 在 JSplitPane 接收方提供外观来绘制其子组件之后传递消息。
void | ComponentUI.paint(Graphics g, JComponent c) 绘制指定组件，使其适合外观。
void | BorderUIResource.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | IconUIResource.paintIcon(Component c, Graphics g, int x, int y)
void | ComponentUI.update(Graphics g, JComponent c) 通知此 UI 委托开始绘制指定的组件。

javax.swing.plaf.basic 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.basic 中的方法
static void BasicGraphicsUtils.drawBezel(Graphics g, int x, int y, int w, int h, boolean isPressed, boolean isDefault, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
protected  void BasicTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
protected  void BasicTreeUI.drawDashedHorizontalLine(Graphics g, int y, int x1, int x2)
static void BasicGraphicsUtils.drawDashedRect(Graphics g, int x, int y, int width, int height)
protected  void BasicTreeUI.drawDashedVerticalLine(Graphics g, int x, int y1, int y2)
static void BasicGraphicsUtils.drawEtchedRect(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void BasicGraphicsUtils.drawGroove(Graphics g, int x, int y, int w, int h, Color shadow, Color highlight)
static void BasicGraphicsUtils.drawLoweredBezel(Graphics g, int x, int y, int w, int h, Color shadow, Color darkShadow, Color highlight, Color lightHighlight)
static void BasicGraphicsUtils.drawString(Graphics g, String text, int underlinedChar, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。
static void BasicGraphicsUtils.drawStringUnderlineCharAt(Graphics g, String text, int underlinedIndex, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。
 void BasicSplitPaneUI.finishedPaintingChildren(JSplitPane jc, Graphics g)
在 JSplitPane 接收者将为绘制其子级提供外观后传递消息。
protected  Point BasicProgressBarUI.getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height)
指定将绘制进度字符串的位置。
 void BasicInternalFrameTitlePane.SystemMenuBar.paint(Graphics g)
 void BasicSplitPaneDivider.paint(Graphics g)
绘制分隔符。
 void BasicArrowButton.paint(Graphics g)
 void BasicToolBarUI.DragWindow.paint(Graphics g)
 void BasicDesktopPaneUI.paint(Graphics g, JComponent c)
 void BasicPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
 void BasicToolTipUI.paint(Graphics g, JComponent c)
 void BasicSliderUI.paint(Graphics g, JComponent c)
 void BasicSplitPaneUI.paint(Graphics g, JComponent jc)
传递消息以绘制外观。
 void BasicTreeUI.paint(Graphics g, JComponent c)
 void BasicTableUI.paint(Graphics g, JComponent c)
绘制用 installUI() 设置的 table 实例的表示形式。
 void BasicTableHeaderUI.paint(Graphics g, JComponent c)
 void BasicProgressBarUI.paint(Graphics g, JComponent c)
将绘制委托给两种方法之一：paintDeterminate 和 paintIndeterminate。
 void BasicRadioButtonUI.paint(Graphics g, JComponent c)
绘制单选按钮
 void BasicTabbedPaneUI.paint(Graphics g, JComponent c)
 void BasicToolBarSeparatorUI.paint(Graphics g, JComponent c)
 void BasicTextUI.paint(Graphics g, JComponent c)
绘制界面。
 void BasicScrollPaneUI.paint(Graphics g, JComponent c)
 void BasicListUI.paint(Graphics g, JComponent c)
绘制与 Graphics 对象 clipRect 相交的行。
 void BasicComboBoxUI.paint(Graphics g, JComponent c)
 void BasicScrollBarUI.paint(Graphics g, JComponent c)
 void BasicSeparatorUI.paint(Graphics g, JComponent c)
 void BasicMenuItemUI.paint(Graphics g, JComponent c)
 void BasicToggleButtonUI.paint(Graphics g, JComponent c)
 void BasicButtonUI.paint(Graphics g, JComponent c)
 void BasicLabelUI.paint(Graphics g, JComponent c)
使用前景色绘制标签文本，如果标签不透明，则利用背景色绘制整个背景。
protected  void BasicTextUI.paintBackground(Graphics g)
绘制视图的背景。
protected  void BasicMenuItemUI.paintBackground(Graphics g, JMenuItem menuItem, Color bgColor)
绘制菜单项的背景。
 void BasicBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
 void BasicBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.RadioButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.FieldBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
 void BasicBorders.SplitPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
protected  void BasicButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected  void BasicListUI.paintCell(Graphics g, int row, Rectangle rowBounds, ListCellRenderer cellRenderer, ListModel dataModel, ListSelectionModel selModel, int leadIndex)
绘制一个 List 单元格：计算相关状态，获取“橡皮图章”单元格渲染器组件，然后使用 CellRendererPane 来绘制它。
 void BasicInternalFrameTitlePane.paintComponent(Graphics g)
protected  void BasicTabbedPaneUI.paintContentBorder(Graphics g, int tabPlacement, int selectedIndex)
protected  void BasicTabbedPaneUI.paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected  void BasicTabbedPaneUI.paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected  void BasicTabbedPaneUI.paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected  void BasicTabbedPaneUI.paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
 void BasicComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项。
 void BasicComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus)
绘制当前所选项的背景。
protected  void BasicScrollBarUI.paintDecreaseHighlight(Graphics g)
protected  void BasicProgressBarUI.paintDeterminate(Graphics g, JComponent c)
对几乎所有线性、确定进度条都能正确执行操作的多用途绘制方法。
protected  void BasicLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。
protected  void BasicToolBarUI.paintDragWindow(Graphics g)
绘制用于拖动的窗口的内容。
protected  void BasicLabelUI.paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。
protected  void BasicTreeUI.paintExpandControl(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的展开（切换）部分。
 void BasicSliderUI.paintFocus(Graphics g)
protected  void BasicButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected  void BasicRadioButtonUI.paintFocus(Graphics g, Rectangle textRect, Dimension size)
protected  void BasicTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected  void BasicSliderUI.paintHorizontalLabel(Graphics g, int value, Component label)
为标签表中的每个标签调用此方法。
protected  void BasicTreeUI.paintHorizontalLine(Graphics g, JComponent c, int y, int left, int right)
绘制水平线。
protected  void BasicTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制支路 (leg) 的水平部分。
protected  void BasicToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect)
protected  void BasicTabbedPaneUI.paintIcon(Graphics g, int tabPlacement, int tabIndex, Icon icon, Rectangle iconRect, boolean isSelected)
protected  void BasicButtonUI.paintIcon(Graphics g, JComponent c, Rectangle iconRect)
protected  void BasicScrollBarUI.paintIncreaseHighlight(Graphics g)
protected  void BasicProgressBarUI.paintIndeterminate(Graphics g, JComponent c)
对所有线性跳动框进度条都能正确执行操作的多用途绘制方法。
 void BasicSliderUI.paintLabels(Graphics g)
protected  void BasicSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicMenuItemUI.paintMenuItem(Graphics g, JComponent c, Icon checkIcon, Icon arrowIcon, Color background, Color foreground, int defaultTextIconGap)
protected  void BasicSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected  void BasicSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
protected  void BasicTreeUI.paintRow(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
绘制 row 的渲染器部分。
protected  void BasicTextUI.paintSafely(Graphics g)
安全地绘制界面，保证模型不会根据此线程的视图发生更改。
protected  void BasicProgressBarUI.paintString(Graphics g, int x, int y, int width, int height, int amountFull, Insets b)
protected  void BasicTabbedPaneUI.paintTab(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect)
protected  void BasicTabbedPaneUI.paintTabArea(Graphics g, int tabPlacement, int selectedIndex)
在选项卡区域绘制选项卡。
protected  void BasicTabbedPaneUI.paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected  void BasicTabbedPaneUI.paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
此方法围绕每个选项卡绘制边框。
protected  void BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
呈现当前按钮文本的方法。
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)
protected  void BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。
protected  void BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
呈现当前菜单项的文本。
 void BasicSliderUI.paintThumb(Graphics g)
protected  void BasicScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
 void BasicSliderUI.paintTicks(Graphics g)
protected  void BasicInternalFrameTitlePane.paintTitleBackground(Graphics g)
从 paintComponent 调用。
 void BasicSliderUI.paintTrack(Graphics g)
protected  void BasicScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
 void BasicArrowButton.paintTriangle(Graphics g, int x, int y, int size, int direction, boolean isEnabled)
绘制一个三角形。
protected  void BasicSliderUI.paintVerticalLabel(Graphics g, int value, Component label)
为标签表中的每个标签调用此方法。
protected  void BasicTreeUI.paintVerticalLine(Graphics g, JComponent c, int x, int top, int bottom)
绘制垂直线。
protected  void BasicTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
绘制支路的垂直部分。
 void BasicTextUI.update(Graphics g, JComponent c)
超类以无法控制的方式绘制背景（即有人可能希望将图像平铺在背景中）。
 void BasicMenuItemUI.update(Graphics g, JComponent c)
使用 paintMenuItem() 绘制背景，从而重写 update（默认情况下填充不透明组件的背景）以调用 paint()。

javax.swing.plaf.metal 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.metal 中的方法
protected void | MetalCheckBoxIcon.drawCheck(Component c, Graphics g, int x, int y)
void | MetalScrollButton.paint(Graphics g)
void | MetalToolTipUI.paint(Graphics g, JComponent c)
void | MetalTreeUI.paint(Graphics g, JComponent c)
void | MetalRadioButtonUI.paint(Graphics g, JComponent c)
void | MetalTabbedPaneUI.paint(Graphics g, JComponent c)
void | MetalComboBoxUI.paint(Graphics g, JComponent c)
void | MetalPopupMenuSeparatorUI.paint(Graphics g, JComponent c)
void | MetalSeparatorUI.paint(Graphics g, JComponent c)
void | MetalBorders.Flush3DBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.InternalFrameBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PaletteBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.OptionDialogBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuItemBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PopupMenuBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToolBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TextFieldBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ScrollPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TableHeaderBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintBottomTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | MetalToggleButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
protected void | MetalButtonUI.paintButtonPressed(Graphics g, AbstractButton b)
void | MetalInternalFrameTitlePane.paintComponent(Graphics g)
void | MetalComboBoxButton.paintComponent(Graphics g)
protected void | MetalTabbedPaneUI.paintContentBorderBottomEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintContentBorderLeftEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintContentBorderRightEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
protected void | MetalTabbedPaneUI.paintContentBorderTopEdge(Graphics g, int tabPlacement, int selectedIndex, int x, int y, int w, int h)
void | MetalComboBoxUI.paintCurrentValue(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项。
void | MetalComboBoxUI.paintCurrentValueBackground(Graphics g, Rectangle bounds, boolean hasFocus) 如有必要，绘制当前所选项的背景。
void | MetalProgressBarUI.paintDeterminate(Graphics g, JComponent c) 在进度条上绘制少量特殊的高亮显示。
protected void | MetalLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY) 只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。
void | MetalSliderUI.paintFocus(Graphics g)
protected void | MetalToggleButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalButtonUI.paintFocus(Graphics g, AbstractButton b, Rectangle viewRect, Rectangle textRect, Rectangle iconRect)
protected void | MetalRadioButtonUI.paintFocus(Graphics g, Rectangle t, Dimension d)
protected void | MetalTabbedPaneUI.paintFocusIndicator(Graphics g, int tabPlacement, Rectangle[] rects, int tabIndex, Rectangle iconRect, Rectangle textRect, boolean isSelected)
protected void | MetalTreeUI.paintHorizontalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, Rectangle bounds, TreePath path, int row, boolean isExpanded, boolean hasBeenExpanded, boolean isLeaf)
protected void | MetalTreeUI.paintHorizontalSeparators(Graphics g, JComponent c)
void | MetalCheckBoxIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalComboBoxIcon.paintIcon(Component c, Graphics g, int x, int y) 绘制 MetalComboBox 的水平条
void | MetalIconFactory.PaletteCloseIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FolderIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FileIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.TreeControlIcon.paintIcon(Component c, Graphics g, int x, int y)
protected void | MetalToggleButtonUI.paintIcon(Graphics g, AbstractButton b, Rectangle iconRect) 在空间 iconRect 中绘制按钮 b 的适当图标。
void | MetalProgressBarUI.paintIndeterminate(Graphics g, JComponent c) 在进度条和跳动框上绘制少量特殊的高亮显示。
protected void | MetalTabbedPaneUI.paintLeftTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | MetalSliderUI.paintMajorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMajorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
void | MetalIconFactory.TreeControlIcon.paintMe(Component c, Graphics g, int x, int y)
protected void | MetalSliderUI.paintMinorTickForHorizSlider(Graphics g, Rectangle tickBounds, int x)
protected void | MetalSliderUI.paintMinorTickForVertSlider(Graphics g, Rectangle tickBounds, int y)
void | MetalInternalFrameTitlePane.paintPalette(Graphics g)
protected void | MetalTabbedPaneUI.paintRightTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
protected void | MetalTabbedPaneUI.paintTabBackground(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected void | MetalTabbedPaneUI.paintTabBorder(Graphics g, int tabPlacement, int tabIndex, int x, int y, int w, int h, boolean isSelected)
protected void | MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
protected void | MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
void | MetalSliderUI.paintThumb(Graphics g)
protected void | MetalScrollBarUI.paintThumb(Graphics g, JComponent c, Rectangle thumbBounds)
protected void | MetalTabbedPaneUI.paintTopTabBorder(int tabIndex, Graphics g, int x, int y, int w, int h, int btm, int rght, boolean isSelected)
void | MetalSliderUI.paintTrack(Graphics g)
protected void | MetalScrollBarUI.paintTrack(Graphics g, JComponent c, Rectangle trackBounds)
protected void | MetalTreeUI.paintVerticalPartOfLeg(Graphics g, Rectangle clipBounds, Insets insets, TreePath path)
void | MetalTabbedPaneUI.update(Graphics g, JComponent c)
void | MetalToolBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalMenuBarUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalToggleButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。
void | MetalButtonUI.update(Graphics g, JComponent c) 如果必要，绘制组件的背景，然后调用 paint。

javax.swing.plaf.multi 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.multi 中的方法
void | MultiSplitPaneUI.finishedPaintingChildren(JSplitPane a, Graphics b) 在由此对象处理的每个 UI 上调用 finishedPaintingChildren 方法。
void | MultiButtonUI.paint(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 paint 方法。
void | MultiColorChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法
void | MultiComboBoxUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopIconUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiDesktopPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiFileChooserUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiInternalFrameUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiLabelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiListUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiMenuItemUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiOptionPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPanelUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiPopupMenuUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiProgressBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiRootPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiScrollPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSeparatorUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSliderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSpinnerUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiSplitPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTabbedPaneUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableHeaderUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTableUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTextUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolBarUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiToolTipUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiTreeUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiViewportUI.paint(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 paint 方法。
void | MultiButtonUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiColorChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiComboBoxUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopIconUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiDesktopPaneUI.update(Graphics a, JComponent b) 在此对象处理的每个 UI 上调用 update 方法。
void | MultiFileChooserUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiInternalFrameUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiLabelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiListUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiMenuItemUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiOptionPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPanelUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiPopupMenuUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiProgressBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiRootPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiScrollPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSeparatorUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSliderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSpinnerUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiSplitPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTabbedPaneUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableHeaderUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTableUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTextUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolBarUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiToolTipUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiTreeUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。
void | MultiViewportUI.update(Graphics a, JComponent b) 在由此对象处理的每个 UI 上调用 update 方法。

javax.swing.plaf.synth 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.plaf.synth 中的方法
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2) 在两个端点之间绘制一条线。
void | SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey) 在两个端点之间绘制一条线。
void | SynthPainter.paintArrowButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的背景。
void | SynthPainter.paintArrowButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制箭头按钮的边框。
void | SynthPainter.paintArrowButtonForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int direction) 绘制箭头按钮的前景。
void | SynthPainter.paintButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的背景。
void | SynthPainter.paintButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制按钮的边框。
void | SynthPainter.paintCheckBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的背景。
void | SynthPainter.paintCheckBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框的边框。
void | SynthPainter.paintCheckBoxMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的背景。
void | SynthPainter.paintCheckBoxMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制复选框菜单项的边框。
void | SynthPainter.paintColorChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的背景。
void | SynthPainter.paintColorChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制颜色选择器的边框。
void | SynthPainter.paintComboBoxBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的背景。
void | SynthPainter.paintComboBoxBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制组合框的边框。
void | SynthPainter.paintDesktopIconBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的背景。
void | SynthPainter.paintDesktopIconBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面图标的边框。
void | SynthPainter.paintDesktopPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的背景。
void | SynthPainter.paintDesktopPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制桌面窗格的边框。
void | SynthPainter.paintEditorPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的背景。
void | SynthPainter.paintEditorPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制编辑器窗格的边框。
void | SynthPainter.paintFileChooserBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的背景。
void | SynthPainter.paintFileChooserBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文件选择器的边框。
void | SynthPainter.paintFormattedTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的背景。
void | SynthPainter.paintFormattedTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制已格式化文本字段的边框。
void | SynthPainter.paintInternalFrameBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的背景。
void | SynthPainter.paintInternalFrameBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体的边框。
void | SynthPainter.paintInternalFrameTitlePaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的背景。
void | SynthPainter.paintInternalFrameTitlePaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制内部窗体标题窗格的边框。
void | SynthPainter.paintLabelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的背景。
void | SynthPainter.paintLabelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制标签的边框。
void | SynthPainter.paintListBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的背景。
void | SynthPainter.paintListBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制列表的边框。
void | SynthPainter.paintMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的背景。
void | SynthPainter.paintMenuBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的背景。
void | SynthPainter.paintMenuBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单栏的边框。
void | SynthPainter.paintMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单的边框。
void | SynthPainter.paintMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的背景。
void | SynthPainter.paintMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制菜单项的边框。
void | SynthPainter.paintOptionPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的背景。
void | SynthPainter.paintOptionPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项窗格的边框。
void | SynthPainter.paintPanelBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的背景。
void | SynthPainter.paintPanelBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制面板的边框。
void | SynthPainter.paintPasswordFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的背景。
void | SynthPainter.paintPasswordFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制密码字段的边框。
void | SynthPainter.paintPopupMenuBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的背景。
void | SynthPainter.paintPopupMenuBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制弹出菜单的边框。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的背景。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制进度条的边框。
void | SynthPainter.paintProgressBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的边框。
void | SynthPainter.paintProgressBarForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制进度条的前景。
void | SynthPainter.paintRadioButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的背景。
void | SynthPainter.paintRadioButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮的边框。
void | SynthPainter.paintRadioButtonMenuItemBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的背景。
void | SynthPainter.paintRadioButtonMenuItemBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制单选钮菜单项的边框。
void | SynthPainter.paintRootPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的背景。
void | SynthPainter.paintRootPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制根窗体的边框。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的背景。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的边框。
void | SynthPainter.paintScrollBarThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的背景。
void | SynthPainter.paintScrollBarThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条的 thumb 的边框。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的背景。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollBarTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滚动条滑道的边框。
void | SynthPainter.paintScrollPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的背景。
void | SynthPainter.paintScrollPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滚动窗格的边框。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的背景。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的边框。
void | SynthPainter.paintSeparatorForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔符的前景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的背景。
void | SynthPainter.paintSliderBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的背景。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的边框。
void | SynthPainter.paintSliderBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的边框。
void | SynthPainter.paintSliderThumbBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的背景。
void | SynthPainter.paintSliderThumbBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的 thumb 的边框。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的背景。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制滑块的滑道的边框。
void | SynthPainter.paintSliderTrackBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制滑块的滑道的边框。
void | SynthPainter.paintSpinnerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的背景。
void | SynthPainter.paintSpinnerBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制 spinner 的边框。
void | SynthPainter.paintSplitPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的背景。
void | SynthPainter.paintSplitPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的边框。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的背景。
void | SynthPainter.paintSplitPaneDividerForeground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制分隔窗格的分隔栏的前景。
void | SynthPainter.paintSplitPaneDragDivider(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 当用户拖动分隔符时，绘制分隔窗格的分隔栏。
void | SynthPainter.paintTabbedPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的背景。
void | SynthPainter.paintTabbedPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的边框。
void | SynthPainter.paintTabbedPaneContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的背景。
void | SynthPainter.paintTabbedPaneContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含选项卡窗格中所选选项卡内容的区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的背景。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制选项卡窗格的选项卡背后区域的边框。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的背景。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTabbedPaneTabBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int tabIndex, int orientation) 绘制选项卡窗格的选项卡的边框。
void | SynthPainter.paintTableBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的背景。
void | SynthPainter.paintTableBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表的边框。
void | SynthPainter.paintTableHeaderBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的背景。
void | SynthPainter.paintTableHeaderBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制表标题的边框。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset) 绘制图标和文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex) 在指定位置上绘制文本。
void | SynthPainter.paintTextAreaBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的背景。
void | SynthPainter.paintTextAreaBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本区域的边框。
void | SynthPainter.paintTextFieldBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的背景。
void | SynthPainter.paintTextFieldBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本字段的边框。
void | SynthPainter.paintTextPaneBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的背景。
void | SynthPainter.paintTextPaneBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制文本窗格的边框。
void | SynthPainter.paintToggleButtonBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的背景。
void | SynthPainter.paintToggleButtonBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制切换按钮的边框。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的背景。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏的边框。
void | SynthPainter.paintToolBarBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏的边框。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的背景。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarContentBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏内容区的边框。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBackground(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的背景。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolBarDragWindowBorder(SynthContext context, Graphics g, int x, int y, int w, int h, int orientation) 绘制工具栏从主窗体中脱离出来时包含它的窗口的边框。
void | SynthPainter.paintToolTipBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的背景。
void | SynthPainter.paintToolTipBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制工具提示的边框。
void | SynthPainter.paintTreeBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的背景。
void | SynthPainter.paintTreeBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制树的边框。
void | SynthPainter.paintTreeCellBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的背景。
void | SynthPainter.paintTreeCellBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制包含树中某个单元格的行的边框。
void | SynthPainter.paintTreeCellFocus(SynthContext context, Graphics g, int x, int y, int w, int h) 当树中某个单元格拥有焦点时，绘制该单元格的焦点指示器。
void | SynthPainter.paintViewportBackground(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的背景。
void | SynthPainter.paintViewportBorder(SynthContext context, Graphics g, int x, int y, int w, int h) 绘制视口的边框。

javax.swing.text 中 Graphics 的使用

返回 Graphics 的 javax.swing.text 中的方法
 Graphics View.getGraphics()
获取用于呈现的 Graphics。

参数类型为 Graphics 的 javax.swing.text 中的方法
protected int | PasswordView.drawEchoCharacter(Graphics g, int x, int y, char c) 呈现回显字符，或呈现用来显示密码字符的图形。
protected void | PlainView.drawLine(int lineIndex, Graphics g, int x, int y) 呈现文本的某一行，取消末尾的空白并扩展所有的制表符。
protected void | WrappedPlainView.drawLine(int p0, int p1, Graphics g, int x, int y) 取消结尾空格并扩展所有制表符，从而呈现一行文本。
protected int | PasswordView.drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为选定文本。
protected int | WrappedPlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为所选文本。
protected int | PlainView.drawSelectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为选定文本。
static int | Utilities.drawTabbedText(Segment s, int x, int y, Graphics g, TabExpander e, int startOffset) 使用给定的制表符扩展方式来扩展给定文本所包含的任何制表符，从而绘制给定的文本。
protected int | PasswordView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为正常的未选定文本。
protected int | WrappedPlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中的给定范围呈现为普通未选择的文本。
protected int | PlainView.drawUnselectedText(Graphics g, int x, int y, int p0, int p1) 将模型中给定的范围呈现为正常的未选定文本。
abstract void | GlyphView.GlyphPainter.paint(GlyphView v, Graphics g, Shape a, int p0, int p1) 绘制表示给定范围的字形。
void | DefaultHighlighter.paint(Graphics g) 呈现高亮显示区域。
void | Highlighter.paint(Graphics g) 呈现高亮显示。
void | DefaultCaret.paint(Graphics g) 将插入符作为垂直线呈现。
void | Caret.paint(Graphics g) 呈现插入符。
void | DefaultHighlighter.DefaultHighlightPainter.paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c) 绘制高亮显示区域。
void | Highlighter.HighlightPainter.paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c) 呈现高亮显示。
void | AsyncBoxView.paint(Graphics g, Shape alloc) 使用给定的分配和呈现表面呈现该视图。
void | BoxView.paint(Graphics g, Shape allocation) 使用该面给定的呈现面和区域呈现 BoxView。
void | ComponentView.paint(Graphics g, Shape a) 真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。
void | GlyphView.paint(Graphics g, Shape a) 呈现一部分运行的文本样式。
void | IconView.paint(Graphics g, Shape a) 绘制图标。
void | ParagraphView.paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
void | WrappedPlainView.paint(Graphics g, Shape a) 使用给定的呈现表面和表现上的区域来呈现。
void | FieldView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
void | PlainView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
abstract void | View.paint(Graphics g, Shape allocation) 使用给定的呈现表面和该表面上的区域来呈现。
protected void | BoxView.paintChild(Graphics g, Rectangle alloc, int index) 绘制一个子级。
void | AsyncBoxView.ChildLocator.paintChildren(Graphics g) 绘制与剪贴区域相交的子级。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。

javax.swing.text.html 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.text.html 中的方法
 void StyleSheet.BoxPainter.paint(Graphics g, float x, float y, float w, float h, View v)
根据给定的属性绘制 CSS 框。
 void StyleSheet.ListPainter.paint(Graphics g, float x, float y, float w, float h, View v, int item)
根据给定的属性绘制 CSS 列表装饰。
 void BlockView.paint(Graphics g, Shape allocation)
使用给定呈现面和该表面的区域呈现。
 void ImageView.paint(Graphics g, Shape a)
绘制 View。
 void ListView.paint(Graphics g, Shape allocation)
使用给定呈现面和该表面的区域呈现。
 void ParagraphView.paint(Graphics g, Shape a)
使用给定的呈现面和该面上的区域进行呈现。
protected  void ListView.paintChild(Graphics g, Rectangle alloc, int index)
通过调用 paint() 绘制其中的一个子级。

javax.swing.tree 中 Graphics 的使用

参数类型为 Graphics 的 javax.swing.tree 中的方法
void | DefaultTreeCellEditor.EditorContainer.paint(Graphics g) 重写 Container.paint 以绘制节点的图标，并使用选定的背景色。
void | DefaultTreeCellRenderer.paint(Graphics g) 绘制值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.Composite 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Composite
的使用

使用 Composite 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Composite 的使用

实现 Composite 的 java.awt 中的类
 class AlphaComposite
AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。

返回 Composite 的 java.awt 中的方法
abstract  Composite Graphics2D.getComposite()
返回 Graphics2D 上下文中的当前 Composite

参数类型为 Composite 的 java.awt 中的方法
abstract  void Graphics2D.setComposite(Composite comp)
为 Graphics2D 上下文设置 Composite。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.Transparency 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Transparency
的使用

使用 Transparency 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

java.awt 中 Transparency 的使用

java.awt 中 Transparency 的子接口
 interface Paint
此 Paint 接口定义如何为 Graphics2D 操作生成颜色模式。

实现 Transparency 的 java.awt 中的类
class | Color Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
class | GradientPaint GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。
class | LinearGradientPaint LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。
class | MultipleGradientPaint 这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。
class | RadialGradientPaint RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。
class | SystemColor 封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
class | TexturePaint TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。

java.awt.image 中 Transparency 的使用

实现 Transparency 的 java.awt.image 中的类
class | BufferedImage BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。
class | ColorModel 此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。
class | ComponentColorModel 使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。
class | DirectColorModel DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。
class | IndexColorModel IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。
class | PackedColorModel PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。
class | VolatileImage VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。

javax.swing.plaf 中 Transparency 的使用

实现 Transparency 的 javax.swing.plaf 中的类
 class ColorUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.ImageCapabilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ImageCapabilities
的使用

使用 ImageCapabilities 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。

java.awt 中 ImageCapabilities 的使用

返回 ImageCapabilities 的 java.awt 中的方法
ImageCapabilities | BufferCapabilities.getBackBufferCapabilities()
ImageCapabilities | Image.getCapabilities(GraphicsConfiguration gc) 返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。
ImageCapabilities | BufferCapabilities.getFrontBufferCapabilities()
ImageCapabilities | GraphicsConfiguration.getImageCapabilities() 返回此 GraphicsConfiguration 的图像能力。

参数类型为 ImageCapabilities 的 java.awt 中的方法
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力的 VolatileImage。
VolatileImage | GraphicsConfiguration.createCompatibleVolatileImage(int width, int height, ImageCapabilities caps, int transparency) 返回一个数据布局和颜色模型与此 GraphicsConfiguration 兼容并使用指定图像能力和透明度值的 VolatileImage。
VolatileImage | Component.createVolatileImage(int width, int height, ImageCapabilities caps) 创建一幅具有给定能力的、可变的、可在屏幕外绘制的图像。

参数类型为 ImageCapabilities 的 java.awt 中的构造方法
BufferCapabilities(ImageCapabilities frontCaps, ImageCapabilities backCaps, BufferCapabilities.FlipContents flipContents)
创建一个指定缓冲区能力的新对象

java.awt.image 中 ImageCapabilities 的使用

返回 ImageCapabilities 的 java.awt.image 中的方法
abstract  ImageCapabilities VolatileImage.getCapabilities()
返回 ImageCapabilities 对象，查询此对象即可了解此 VolatileImage 的特定功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GraphicsConfiguration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsConfiguration
的使用

使用 GraphicsConfiguration 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 GraphicsConfiguration 的使用

返回 GraphicsConfiguration 的 java.awt 中的方法
GraphicsConfiguration | GraphicsDevice.getBestConfiguration(GraphicsConfigTemplate gct) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
abstract GraphicsConfiguration | GraphicsConfigTemplate.getBestConfiguration(GraphicsConfiguration[] gc) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
abstract GraphicsConfiguration[] | GraphicsDevice.getConfigurations() 返回与此 GraphicsDevice 关联的所有 GraphicsConfiguration 对象。
abstract GraphicsConfiguration | GraphicsDevice.getDefaultConfiguration() 返回与此 GraphicsDevice 关联的默认 GraphicsConfiguration。
abstract GraphicsConfiguration | Graphics2D.getDeviceConfiguration() 返回与此 Graphics2D 关联的设备配置。
GraphicsConfiguration | Window.getGraphicsConfiguration() 此方法返回由此窗口使用的 GraphicsConfiguration。
GraphicsConfiguration | Component.getGraphicsConfiguration() 获取与此 Component 相关的 GraphicsConfiguration。

参数类型为 GraphicsConfiguration 的 java.awt 中的方法
abstract GraphicsConfiguration | GraphicsConfigTemplate.getBestConfiguration(GraphicsConfiguration[] gc) 返回通过了 GraphicsConfigTemplate 中定义的标准的可能“最佳”配置。
ImageCapabilities | Image.getCapabilities(GraphicsConfiguration gc) 返回 ImageCapabilities 对象，查询该对象便可以了解使用指定 GraphicsConfiguration 时此 Image 的功能。
Insets | Toolkit.getScreenInsets(GraphicsConfiguration gc) 获得屏幕的 insets。
abstract boolean | GraphicsConfigTemplate.isGraphicsConfigSupported(GraphicsConfiguration gc) 返回一个 boolean，它指示指定的 GraphicsConfiguration 是否可用于创建支持指定功能的绘图面。

参数类型为 GraphicsConfiguration 的 java.awt 中的构造方法
Canvas(GraphicsConfiguration config)
根据给定 GraphicsConfiguration 对象构造一个新的 Canvas。
Dialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。
Dialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。
Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。
Frame(GraphicsConfiguration gc)
使用指定的 GraphicsConfiguration 构造一个最初不可见的新 Frame。
Frame(String title, GraphicsConfiguration gc)
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。
Window(Window owner, GraphicsConfiguration gc)
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。

java.awt.image 中 GraphicsConfiguration 的使用

参数类型为 GraphicsConfiguration 的 java.awt.image 中的方法
abstract  int VolatileImage.validate(GraphicsConfiguration gc)
如果上次调用 validate 后绘制表面丢失，则试图恢复图像的绘制表面。

javax.print 中 GraphicsConfiguration 的使用

参数类型为 GraphicsConfiguration 的 javax.print 中的方法
static PrintService ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
为用户提供一个选择 PrintService（打印机）的对话框。

javax.swing 中 GraphicsConfiguration 的使用

参数类型为 GraphicsConfiguration 的 javax.swing 中的构造方法
JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。
JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。
JFrame(GraphicsConfiguration gc)
以屏幕设备的指定 GraphicsConfiguration 和空白标题创建一个 Frame。
JFrame(String title, GraphicsConfiguration gc)
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。
JWindow(GraphicsConfiguration gc)
使用屏幕设备的指定 GraphicsConfiguration 创建窗口。
JWindow(Window owner, GraphicsConfiguration gc)
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GraphicsDevice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsDevice
的使用

使用 GraphicsDevice 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GraphicsDevice 的使用

返回 GraphicsDevice 的 java.awt 中的方法
abstract GraphicsDevice | GraphicsEnvironment.getDefaultScreenDevice() 返回默认的屏幕 GraphicsDevice。
GraphicsDevice | PointerInfo.getDevice() 返回在创建此 PointerInfo 时鼠标指针所在的 GraphicsDevice。
abstract GraphicsDevice | GraphicsConfiguration.getDevice() 返回与此 GraphicsConfiguration 关联的 GraphicsDevice。
abstract GraphicsDevice[] | GraphicsEnvironment.getScreenDevices() 返回所有屏幕 GraphicsDevice 对象组成的数组。

参数类型为 GraphicsDevice 的 java.awt 中的构造方法
Robot(GraphicsDevice screen)
为给定屏幕设备创建一个 Robot 。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.Shape 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.Shape
的使用

使用 Shape 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Shape 的使用

实现 Shape 的 java.awt 中的类
class | Polygon Polygon 类封装了坐标空间中封闭的二维区域的描述。
class | Rectangle Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

返回 Shape 的 java.awt 中的方法
Shape | BasicStroke.createStrokedShape(Shape s) 返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。
Shape | Stroke.createStrokedShape(Shape p) 返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。
abstract Shape | Graphics.getClip() 获取当前剪贴区域。

参数类型为 Shape 的 java.awt 中的方法
abstract void | Graphics2D.clip(Shape s) 将当前 Clip 与指定 Shape 的内部区域相交，并将 Clip 设置为所得的交集。
Shape | BasicStroke.createStrokedShape(Shape s) 返回一个 Shape，它在内部定义了指定 Shape 的笔划轮廓。
Shape | Stroke.createStrokedShape(Shape p) 返回一个轮廓 Shape，它封闭了应该在根据规则描绘 Shape 时绘制的区域，这些规则是由实现 Stroke 接口的对象定义的。
abstract void | Graphics2D.draw(Shape s) 使用当前 Graphics2D 上下文的设置勾画 Shape 的轮廓。
abstract void | Graphics2D.fill(Shape s) 使用 Graphics2D 上下文的设置，填充 Shape 的内部区域。
abstract boolean | Graphics2D.hit(Rectangle rect, Shape s, boolean onStroke) 检查指定的 Shape 是否与设备空间中的指定 Rectangle 相交。
abstract void | Graphics.setClip(Shape clip) 将当前剪贴区域设置为任意的剪贴形状。

java.awt.font 中 Shape 的使用

返回 Shape 的 java.awt.font 中的方法
Shape | TextLayout.getBlackBoxBounds(int firstEndpoint, int secondEndpoint) 返回指定范围中字符的黑框边界。
Shape | TextLayout.getCaretShape(TextHitInfo hit) 返回表示此 TextLayout 的自然边界中指定目标字符处插入符的 Shape。
Shape | TextLayout.getCaretShape(TextHitInfo hit, Rectangle2D bounds) 返回表示指定边界内指定目标字符处插入符的 Shape。
Shape[] | TextLayout.getCaretShapes(int offset) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds) 返回对应于强插入符和弱插入符的两条路径。
Shape[] | TextLayout.getCaretShapes(int offset, Rectangle2D bounds, TextLayout.CaretPolicy policy) 返回对应于强插入符和弱插入符的两条路径。
abstract Shape | GlyphVector.getGlyphLogicalBounds(int glyphIndex) 返回此 GlyphVector 中指定字形的逻辑边界。
abstract Shape | GlyphVector.getGlyphOutline(int glyphIndex) 返回其内部区域与此 GlyphVector 中指定字形的可视表示形式对应的 Shape。
Shape | GlyphVector.getGlyphOutline(int glyphIndex, float x, float y) 返回一个 Shape，其内部区域与此 GlyphVector 中指定字形的可视表示形式对应，并偏移到 x、y。
abstract Shape | GlyphVector.getGlyphVisualBounds(int glyphIndex) 返回 GlyphVector 中指定字形的可视边界。
Shape | TextLayout.getLogicalHighlightShape(int firstEndpoint, int secondEndpoint) 返回封装指定范围中逻辑选择范围的 Shape，它扩展到此 TextLayout 的自然边界。
Shape | TextLayout.getLogicalHighlightShape(int firstEndpoint, int secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到指定 bounds 的逻辑选择范围的 Shape。
abstract Shape | GlyphVector.getOutline() 返回其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
Shape | GraphicAttribute.getOutline(AffineTransform tx) 返回表示此 GraphicAttribute 呈现区域的 Shape。
Shape | ShapeGraphicAttribute.getOutline(AffineTransform tx) 返回一个表示此 ShapeGraphicAttribute 呈现区域的 Shape。
Shape | TextLayout.getOutline(AffineTransform tx) 返回表示此 TextLayout 的轮廓的 Shape。
abstract Shape | GlyphVector.getOutline(float x, float y) 返回在 x、y 处呈现时，其内部区域与此 GlyphVector 的可视表示形式对应的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint) 返回封闭指定范围中扩展到指定边界的可视选择范围的 Shape。
Shape | TextLayout.getVisualHighlightShape(TextHitInfo firstEndpoint, TextHitInfo secondEndpoint, Rectangle2D bounds) 返回封闭指定范围中扩展到 bounds 的可视选择范围的路径。

参数类型为 Shape 的 java.awt.font 中的构造方法
ShapeGraphicAttribute(Shape shape, int alignment, boolean stroke)
针对指定 Shape 构造 ShapeGraphicAttribute。

java.awt.geom 中 Shape 的使用

实现 Shape 的 java.awt.geom 中的类
class | Arc2D Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
class | Area Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
class | CubicCurve2D CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。
class | Ellipse2D Ellipse2D 类描述窗体矩形定义的椭圆。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
class | Line2D Line2D 表示 (x,y) 坐标空间中的线段。
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。
class | Path2D Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
class | QuadCurve2D QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。
class | Rectangle2D Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
class | RectangularShape RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
class | RoundRectangle2D RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

返回 Shape 的 java.awt.geom 中的方法
Shape | Path2D.createTransformedShape(AffineTransform at) 返回一个表示此 Path2D 变换形式的新 Shape。
Shape | AffineTransform.createTransformedShape(Shape pSrc) 返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。

参数类型为 Shape 的 java.awt.geom 中的方法
void | Path2D.append(Shape s, boolean connect) 将指定 Shape 对象的几何形状添加到路径中，可能要使用一条线段将新几何形状连接到现有路径段。
Shape | AffineTransform.createTransformedShape(Shape pSrc) 返回新的 Shape 对象，它在通过此变换之后，由指定 Shape 的几何形状定义。

参数类型为 Shape 的 java.awt.geom 中的构造方法
Area(Shape s)
Area 类可以根据指定的 Shape 对象创建区域几何形状。
GeneralPath(Shape s)
根据任意 Shape 对象构造一个新 GeneralPath 对象。
Path2D.Double(Shape s)
根据任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Double(Shape s, AffineTransform at)
根据由 AffineTransform 对象变换的任意 Shape 对象构造一个新的双精度 Path2D 对象。
Path2D.Float(Shape s)
根据任意 Shape 对象构造一个新的单精度 Path2D 对象。
Path2D.Float(Shape s, AffineTransform at)
根据 AffineTransform 对象变换的任意 Shape 对象构造一个新的单精度 Path2D 对象。

java.awt.image.renderable 中 Shape 的使用

返回 Shape 的 java.awt.image.renderable 中的方法
 Shape RenderContext.getAreaOfInterest()
获取当前包含在 RenderContext 中的感兴趣区域。

参数类型为 Shape 的 java.awt.image.renderable 中的方法
 void RenderContext.setAreaOfInterest(Shape newAoi)
设置当前的感兴趣区域。

参数类型为 Shape 的 java.awt.image.renderable 中的构造方法
RenderContext(AffineTransform usr2dev, Shape aoi)
构造具有给定变换和感兴趣区域的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
构造具有给定转换的 RenderContext。

javax.swing 中 Shape 的使用

返回 Shape 的 javax.swing 中的方法
 Shape DebugGraphics.getClip()
重写 Graphics.getClip。

参数类型为 Shape 的 javax.swing 中的方法
 void DebugGraphics.setClip(Shape clip)
重写 Graphics.setClip。

javax.swing.plaf.basic 中 Shape 的使用

实现 Shape 的 javax.swing.plaf.basic 中的类
static class BasicTextUI.BasicCaret

javax.swing.text 中 Shape 的使用

实现 Shape 的 javax.swing.text 中的类
 class DefaultCaret
插入符的默认实现。

返回 Shape 的 javax.swing.text 中的方法
protected Shape | FieldView.adjustAllocation(Shape a) 调整给定视图的分配区域，使其适合文本字段的分配区域。
protected Shape | AsyncBoxView.ChildLocator.getChildAllocation(int index) 获取用于子视图的分配区域。
Shape | AsyncBoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配区域。
Shape | AsyncBoxView.ChildLocator.getChildAllocation(int index, Shape a) 获取用于子视图的分配区域。
Shape | BoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
Shape | CompositeView.getChildAllocation(int index, Shape a) 获取要在其中呈现的给定子视图的分配区域。
Shape | View.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
Shape | View.modelToView(int pos, Shape a) 已过时。
Shape | AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | BoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
Shape | ComponentView.modelToView(int pos, Shape a, Position.Bias b) 提供模型坐标空间到视图坐标空间的映射。
Shape | CompositeView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | GlyphView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | IconView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PasswordView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | FieldView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PlainView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract Shape | View.modelToView(int pos, Shape a, Position.Bias b) 为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)

参数类型为 Shape 的 javax.swing.text 中的方法
protected Shape | FieldView.adjustAllocation(Shape a) 调整给定视图的分配区域，使其适合文本字段的分配区域。
View | ParagraphView.breakView(int axis, float len, Shape a) 以给定的长度在给定的轴上拆分此视图。
void | FlowView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | GlyphView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | LabelView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
void | ParagraphView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | WrappedPlainView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出文档中此视图负责的位置上的属性已发生更改的通知。
void | PlainView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的某个位置的属性已更改。
void | View.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
protected void | PlainView.damageLineRange(int line0, int line1, Shape a, Component host) 重新绘制给定的行范围。
protected void | BoxView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要接收模型更改通知的子视图。
protected void | TableView.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f)
protected void | View.forwardUpdate(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a, ViewFactory f) 将给定的 DocumentEvent 转发给需要被通知模型更改的子视图。
protected void | View.forwardUpdateToView(View v, DocumentEvent e, Shape a, ViewFactory f) 将 DocumentEvent 转发到给定的子视图。
Shape | AsyncBoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配区域。
Shape | AsyncBoxView.ChildLocator.getChildAllocation(int index, Shape a) 获取用于子视图的分配区域。
Shape | BoxView.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
Shape | CompositeView.getChildAllocation(int index, Shape a) 获取要在其中呈现的给定子视图的分配区域。
Shape | View.getChildAllocation(int index, Shape a) 获取给定子视图的分配。
protected int | ParagraphView.getClosestPositionTo(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet, int rowIndex, int x) 返回最接近 x 处的模型位置。
protected Rectangle | CompositeView.getInsideAllocation(Shape a) 将分配给视图的不可变分配区域转换为表示内部分配区域的可变分配区域（即给定分配区域的边界，其顶部、左部、底部和右部的 insets 已移除）。
protected int | CompositeView.getNextEastWestVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在东或在西。
protected int | CompositeView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 返回光标的下一个可视位置，可以在北也可以在南。
protected int | ParagraphView.getNextNorthSouthVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 在东或西方向返回光标的下一个可视位置。
int | GlyphView.GlyphPainter.getNextVisualPositionFrom(GlyphView v, int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | AsyncBoxView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供确定下一个以可视化形式表示的模型位置的方法，用户可以在此位置放置一个插入符。
int | CompositeView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | GlyphView.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供一种方法来确定下一个以可视化形式表示的模型位置，用户可以在此位置放置一个插入符。
int | View.getNextVisualPositionFrom(int pos, Position.Bias b, Shape a, int direction, Position.Bias[] biasRet) 提供某种途径来确定可以放置一个插入符的下一个可视表示模型位置。
String | View.getToolTipText(float x, float y, Shape allocation) 返回提定位置的工具提示文本。
int | View.getViewIndex(float x, float y, Shape allocation) 返回表示视图中给定位置的子视图索引。
int | AsyncBoxView.ChildLocator.getViewIndexAtPoint(float x, float y, Shape a) 获取位于给定点的子视图索引。
void | FlowView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | GlyphView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
void | WrappedPlainView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出在文档中此视图负责的位置插入了某些内容的通知。
void | ZoneView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出在文档中此视图负责的位置插入了某些内容的通知。
void | FieldView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.insertUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
void | View.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知在文档中此视图负责的某个位置已插入内容。
protected Rectangle | PlainView.lineToRect(Shape a, int line) 确定表示给定行的矩形。
abstract Shape | GlyphView.GlyphPainter.modelToView(GlyphView v, int pos, Position.Bias bias, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | CompositeView.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | View.modelToView(int p0, Position.Bias b0, int p1, Position.Bias b1, Shape a) 为给定区域提供从文档模型坐标空间到视图坐标空间的映射。
Shape | View.modelToView(int pos, Shape a) 已过时。
Shape | AsyncBoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | BoxView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型的坐标空间到映射到它的视图的坐标空间的映射。
Shape | ComponentView.modelToView(int pos, Shape a, Position.Bias b) 提供模型坐标空间到视图坐标空间的映射。
Shape | CompositeView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | GlyphView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | IconView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PasswordView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | FieldView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
Shape | PlainView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
abstract Shape | View.modelToView(int pos, Shape a, Position.Bias b) 为给定字符提供从文档模型坐标空间到视图坐标空间的映射。
abstract void | GlyphView.GlyphPainter.paint(GlyphView v, Graphics g, Shape a, int p0, int p1) 绘制表示给定范围的字形。
void | DefaultHighlighter.DefaultHighlightPainter.paint(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c) 绘制高亮显示区域。
void | Highlighter.HighlightPainter.paint(Graphics g, int p0, int p1, Shape bounds, JTextComponent c) 呈现高亮显示。
void | AsyncBoxView.paint(Graphics g, Shape alloc) 使用给定的分配和呈现表面呈现该视图。
void | BoxView.paint(Graphics g, Shape allocation) 使用该面给定的呈现面和区域呈现 BoxView。
void | ComponentView.paint(Graphics g, Shape a) 真正的绘制行为自然来源于组件与其父容器（容纳此视图的同一容器）之间的关联。
void | GlyphView.paint(Graphics g, Shape a) 呈现一部分运行的文本样式。
void | IconView.paint(Graphics g, Shape a) 绘制图标。
void | ParagraphView.paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
void | WrappedPlainView.paint(Graphics g, Shape a) 使用给定的呈现表面和表现上的区域来呈现。
void | FieldView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
void | PlainView.paint(Graphics g, Shape a) 使用给定呈现面和该表面的区域呈现。
abstract void | View.paint(Graphics g, Shape allocation) 使用给定的呈现表面和该表面上的区域来呈现。
Shape | DefaultHighlighter.DefaultHighlightPainter.paintLayer(Graphics g, int offs0, int offs1, Shape bounds, JTextComponent c, View view) 绘制高亮显示的某一部分。
abstract Shape | LayeredHighlighter.LayerPainter.paintLayer(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view)
void | DefaultHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当要呈现叶 View （例如，LabelView）时，要调用此方法。
abstract void | LayeredHighlighter.paintLayeredHighlights(Graphics g, int p0, int p1, Shape viewBounds, JTextComponent editor, View view) 当叶 View（如 LabelView）呈现时，它们应调用此方法。
void | FlowView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 发出通知，通知从文档中此视图负责的某个位置已移除内容。
void | GlyphView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
void | WrappedPlainView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出从文档中此视图负责的位置移除了某些内容的通知。
void | ZoneView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
void | FieldView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | PlainView.removeUpdate(DocumentEvent changes, Shape a, ViewFactory f) 通知在文档中此视图负责的某个位置已插入内容。
void | View.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 给出从文档中此视图负责的位置移除了某些内容的通知。
protected void | AsyncBoxView.ChildLocator.setAllocation(Shape a) 将当前已分配的形状复制到用于存储当前分配区域的 Rectangle 中。
protected void | PlainView.updateDamage(DocumentEvent changes, Shape a, ViewFactory f) 重新绘制给定文档事件覆盖的更改区域。
protected void | AsyncBoxView.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接收的更改通知。
protected void | View.updateLayout(DocumentEvent.ElementChange ec, DocumentEvent e, Shape a) 更新布局，以响应从模型接受的更改通知。
int | View.viewToModel(float x, float y, Shape a) 已过时。
int | AsyncBoxView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | BoxView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | ComponentView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | CompositeView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
int | GlyphView.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。
int | IconView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PasswordView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | FieldView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
int | PlainView.viewToModel(float fx, float fy, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。
abstract int | View.viewToModel(float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型的逻辑坐标空间的映射。
abstract int | GlyphView.GlyphPainter.viewToModel(GlyphView v, float x, float y, Shape a, Position.Bias[] biasReturn) 提供从视图坐标空间到模型逻辑坐标空间的映射。

javax.swing.text.html 中 Shape 的使用

返回 Shape 的 javax.swing.text.html 中的方法
 Shape ImageView.modelToView(int pos, Shape a, Position.Bias b)
提供从文档模型坐标空间到所映射的视图坐标空间的映射。

参数类型为 Shape 的 javax.swing.text.html 中的方法
void | BlockView.changedUpdate(DocumentEvent changes, Shape a, ViewFactory f)
void | ImageView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 当 Elements 属性已更改时调用。
void | InlineView.changedUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档此视图负责的位置处的属性已更改。
String | ImageView.getToolTipText(float x, float y, Shape allocation) 对于图像，工具提示文本来自于 ALT 属性指定的文本。
void | InlineView.insertUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已插入内容。
Shape | ImageView.modelToView(int pos, Shape a, Position.Bias b) 提供从文档模型坐标空间到所映射的视图坐标空间的映射。
void | BlockView.paint(Graphics g, Shape allocation) 使用给定呈现面和该表面的区域呈现。
void | ImageView.paint(Graphics g, Shape a) 绘制 View。
void | ListView.paint(Graphics g, Shape allocation) 使用给定呈现面和该表面的区域呈现。
void | ParagraphView.paint(Graphics g, Shape a) 使用给定的呈现面和该面上的区域进行呈现。
void | InlineView.removeUpdate(DocumentEvent e, Shape a, ViewFactory f) 发出通知，通知文档中此视图负责的位置已移除内容。
int | ImageView.viewToModel(float x, float y, Shape a, Position.Bias[] bias) 提供从视图坐标空间到该模型的逻辑坐标空间的映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.RenderingHints 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.RenderingHints
的使用

使用 RenderingHints 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。

java.awt 中 RenderingHints 的使用

返回 RenderingHints 的 java.awt 中的方法
abstract  RenderingHints Graphics2D.getRenderingHints()
获取呈现算法的首选项。

参数类型为 RenderingHints 的 java.awt 中的方法
void | RenderingHints.add(RenderingHints hints) 将指定 RenderingHints 对象中的所有键和相应的值添加到此 RenderingHints 对象中。
CompositeContext | AlphaComposite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 为合成操作创建一个上下文。
CompositeContext | Composite.createContext(ColorModel srcColorModel, ColorModel dstColorModel, RenderingHints hints) 创建一个上下文，其中包含用于执行复合操作的状态。
PaintContext | GradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的上下文。
PaintContext | LinearGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | RadialGradientPaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform transform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。
PaintContext | TexturePaint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用于生成颜色模式的上下文。
PaintContext | SystemColor.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成纯色模式的 PaintContext。
PaintContext | Color.createContext(ColorModel cm, Rectangle r, Rectangle2D r2d, AffineTransform xform, RenderingHints hints) 创建并返回用来生成固定颜色模式的 PaintContext。
PaintContext | Paint.createContext(ColorModel cm, Rectangle deviceBounds, Rectangle2D userBounds, AffineTransform xform, RenderingHints hints) 创建并返回用来生成颜色模式的 PaintContext。

java.awt.image 中 RenderingHints 的使用

返回 RenderingHints 的 java.awt.image 中的方法
RenderingHints | AffineTransformOp.getRenderingHints() 返回此转换操作使用的呈现提示。
RenderingHints | BandCombineOp.getRenderingHints() 返回针对此操作呈现的提示。
RenderingHints | BufferedImageOp.getRenderingHints() 返回针对此操作所呈现的提示。
RenderingHints | ColorConvertOp.getRenderingHints() 此操作使用的呈现提示。
RenderingHints | ConvolveOp.getRenderingHints() 返回此 op 的呈现提示。
RenderingHints | LookupOp.getRenderingHints() 返回此操作的呈现提示。
RenderingHints | RasterOp.getRenderingHints() 返回此 RasterOp 的呈现提示。
RenderingHints | RescaleOp.getRenderingHints() 返回此操作的呈现提示。

参数类型为 RenderingHints 的 java.awt.image 中的构造方法
AffineTransformOp(AffineTransform xform, RenderingHints hints)
根据仿射转换构造 AffineTransformOp。
BandCombineOp(float[][] matrix, RenderingHints hints)
构造一个具有指定矩阵的 BandCombineOp。
ColorConvertOp(ColorSpace srcCspace, ColorSpace dstCspace, RenderingHints hints)
根据两个 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ColorSpace cspace, RenderingHints hints)
根据 ColorSpace 对象构造新的 ColorConvertOp。
ColorConvertOp(ICC_Profile[] profiles, RenderingHints hints)
根据 ICC_Profiles 的数组构造新的 ColorConvertOp。
ColorConvertOp(RenderingHints hints)
构造从源颜色空间到目标颜色空间转换的新 ColorConvertOp。
ConvolveOp(Kernel kernel, int edgeCondition, RenderingHints hints)
构造给定 Kernel、边缘条件和 RenderingHint 对象（可以为 null）的 ConvolveOp。
LookupOp(LookupTable lookup, RenderingHints hints)
在给定查找表和 RenderingHints 对象（可能为 null）的情况下，构造一个 LookupOp 对象。
RescaleOp(float[] scaleFactors, float[] offsets, RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。
RescaleOp(float scaleFactor, float offset, RenderingHints hints)
构造一个具有所希望的缩放因子和偏移量的新 RescaleOp。

java.awt.image.renderable 中 RenderingHints 的使用

返回 RenderingHints 的 java.awt.image.renderable 中的方法
 RenderingHints RenderContext.getRenderingHints()
获取此 RenderContext 的呈现提示。

参数类型为 RenderingHints 的 java.awt.image.renderable 中的方法
RenderedImage | RenderedImageFactory.create(ParameterBlock paramBlock, RenderingHints hints) 针对给定的 ParameterBlock 和 RenderingHints 创建表示成像操作（或操作链）结果的 RenderedImage。
RenderedImage | RenderableImage.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
RenderedImage | RenderableImageOp.createScaledRendering(int w, int h, RenderingHints hints) 创建此图像具有宽度 w 和高度 h（以像素为单位）的一个 RenderedImage 实例。
void | RenderContext.setRenderingHints(RenderingHints hints) 设置此 RenderContext 的呈现提示。

参数类型为 RenderingHints 的 java.awt.image.renderable 中的构造方法
RenderContext(AffineTransform usr2dev, RenderingHints hints)
构造具有给定转换和呈现提示的 RenderContext。
RenderContext(AffineTransform usr2dev, Shape aoi, RenderingHints hints)
构造具有给定转换的 RenderContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.RenderingHints.Key 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.RenderingHints.Key
的使用

使用 RenderingHints.Key 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 RenderingHints.Key 的使用

声明为 RenderingHints.Key 的 java.awt 中的字段
static RenderingHints.Key | RenderingHints.KEY_ALPHA_INTERPOLATION Alpha 插值提示键。
static RenderingHints.Key | RenderingHints.KEY_ANTIALIASING 抗锯齿提示键。
static RenderingHints.Key | RenderingHints.KEY_COLOR_RENDERING 颜色呈现提示键。
static RenderingHints.Key | RenderingHints.KEY_DITHERING 抖动提示键。
static RenderingHints.Key | RenderingHints.KEY_FRACTIONALMETRICS 字体小数规格提示键。
static RenderingHints.Key | RenderingHints.KEY_INTERPOLATION 插值提示键。
static RenderingHints.Key | RenderingHints.KEY_RENDERING 呈现提示键。
static RenderingHints.Key | RenderingHints.KEY_STROKE_CONTROL 笔划规范化控制提示键。
static RenderingHints.Key | RenderingHints.KEY_TEXT_ANTIALIASING 文本抗锯齿提示键。
static RenderingHints.Key | RenderingHints.KEY_TEXT_LCD_CONTRAST LCD 文本对比呈现提示键。

参数类型为 RenderingHints.Key 的 java.awt 中的方法
abstract Object | Graphics2D.getRenderingHint(RenderingHints.Key hintKey) 返回呈现算法的单个首选项的值。
abstract void | Graphics2D.setRenderingHint(RenderingHints.Key hintKey, Object hintValue) 为呈现算法设置单个首选项的值。

参数类型为 RenderingHints.Key 的 java.awt 中的构造方法
RenderingHints(RenderingHints.Key key, Object value)
构造一个具有指定键/值对的新对象。

类型变量类型为 RenderingHints.Key 的 java.awt 中的构造方法参数
RenderingHints(Map<RenderingHints.Key,?> init)
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Font 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Font
的使用

使用 Font 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 Font 的使用

声明为 Font 的 java.awt 中的字段
protected  Font FontMetrics.font
实际的 Font，字体规格是由此创建的。

返回 Font 的 java.awt 中的方法
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
static Font | Font.createFont(int fontFormat, InputStream fontStream) 返回一个使用指定字体类型和输入数据的新 Font。
static Font | Font.decode(String str) 返回 str 参数所描述的 Font。
Font | Font.deriveFont(AffineTransform trans) 通过复制当前 Font 对象并应用新的变换，创建一个新 Font 对象。
Font | Font.deriveFont(float size) 通过复制当前 Font 对象并应用新的大小，创建一个新 Font 对象。
Font | Font.deriveFont(int style) 通过复制当前的 Font 对象，并应用新的样式，创建一个新 Font 对象。
Font | Font.deriveFont(int style, AffineTransform trans) 通过复制此 Font 对象并应用新样式和变换，创建一个新 Font 对象。
Font | Font.deriveFont(int style, float size) 通过复制此 Font 对象并应用新样式和大小，创建一个新 Font 对象。
Font | Font.deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
abstract Font[] | GraphicsEnvironment.getAllFonts() 返回一个数组，它包含此 GraphicsEnvironment 中所有可用字体的像素级实例。
Font | List.AccessibleAWTList.AccessibleAWTListChild.getFont() 获取此对象的 Font。
Font | FontMetrics.getFont() 获取此 FontMetrics 对象所描述的 Font。
Font | MenuComponent.getFont() 获取用于此菜单组件的字体。
Font | MenuComponent.AccessibleAWTMenuComponent.getFont() 获取此对象的 Font。
abstract Font | Graphics.getFont() 获取当前字体。
Font | Component.getFont() 获取组件的字体。
Font | Component.AccessibleAWTComponent.getFont() 获取此对象的 Font。
Font | MenuContainer.getFont()
static Font | Font.getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 返回适合于这些属性的 Font。
static Font | Font.getFont(String nm) 从系统属性列表返回一个 Font 对象。
static Font | Font.getFont(String nm, Font font) 从系统属性列表获取指定的 Font。

参数类型为 Font 的 java.awt 中的方法
static Font | Font.getFont(String nm, Font font) 从系统属性列表获取指定的 Font。
FontMetrics | List.AccessibleAWTList.AccessibleAWTListChild.getFontMetrics(Font f) 设置此对象的 FontMetrics。
FontMetrics | MenuComponent.AccessibleAWTMenuComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
abstract FontMetrics | Graphics.getFontMetrics(Font f) 获取指定字体的字体规格。
abstract FontMetrics | Toolkit.getFontMetrics(Font font) 已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
FontMetrics | Component.getFontMetrics(Font font) 获取指定字体的字体规格。
FontMetrics | Component.AccessibleAWTComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
boolean | GraphicsEnvironment.registerFont(Font font) 在此 GraphicsEnvironment 中注册一个/已创建的 Font。
void | List.AccessibleAWTList.AccessibleAWTListChild.setFont(Font f) 设置此对象的 Font。
void | MenuComponent.setFont(Font f) 将用于此菜单组件的字体设置为指定字体。
void | MenuComponent.AccessibleAWTMenuComponent.setFont(Font f) 设置此对象的 Font。
abstract void | Graphics.setFont(Font font) 将此图形上下文的字体设置为指定字体。
void | Container.setFont(Font f) 设置此容器的字体。
void | Component.setFont(Font f) 设置组件的字体。
void | Component.AccessibleAWTComponent.setFont(Font f) 设置此对象的 Font。

参数类型为 Font 的 java.awt 中的构造方法
Font(Font font)
根据指定 font 创建一个新 Font。
FontMetrics(Font font)
创建一个新 FontMetrics 对象，用于查找该 Font 中关于指定 Font 和特定字符字形的 height 和 width 信息。

java.awt.font 中 Font 的使用

返回 Font 的 java.awt.font 中的方法
Font | MultipleMaster.deriveMMFont(float[] axes) 根据指定数组中包含的设计轴值，创建 multiple master 字体的新实例。
Font | MultipleMaster.deriveMMFont(float[] glyphWidths, float avgStemWidth, float typicalCapHeight, float typicalXHeight, float italicAngle) 根据详细的规格信息，创建 multiple master 字体的新实例。
abstract Font | GlyphVector.getFont() 返回与此 GlyphVector 关联的 Font。

参数类型为 Font 的 java.awt.font 中的构造方法
TextLayout(String string, Font font, FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。

javax.accessibility 中 Font 的使用

返回 Font 的 javax.accessibility 中的方法
 Font AccessibleComponent.getFont()
获取此对象的 Font。

参数类型为 Font 的 javax.accessibility 中的方法
FontMetrics | AccessibleComponent.getFontMetrics(Font f) 获取此对象的 FontMetrics。
void | AccessibleComponent.setFont(Font f) 设置此对象的 Font。

javax.swing 中 Font 的使用

返回 Font 的 javax.swing 中的方法
Font | DebugGraphics.getFont() 返回用于文本绘制操作的 Font。
Font | JTree.AccessibleJTree.AccessibleJTreeNode.getFont()
Font | JTable.AccessibleJTable.AccessibleJTableCell.getFont() 获取此对象的 Font。
Font | JList.AccessibleJList.AccessibleJListChild.getFont()
Font | UIDefaults.getFont(Object key) 如果 key 值为一个 Font，则返回该 Font，否则返回 null。
static Font | UIManager.getFont(Object key) 从默认值返回一种字体。
Font | UIDefaults.getFont(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。
static Font | UIManager.getFont(Object key, Locale l) 从适合给定语言环境的默认值中返回一种字体。

参数类型为 Font 的 javax.swing 中的方法
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont) 向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
FontMetrics | DebugGraphics.getFontMetrics(Font f) 重写 Graphics.getFontMetrics。
FontMetrics | JTree.AccessibleJTree.AccessibleJTreeNode.getFontMetrics(Font f)
FontMetrics | JTable.AccessibleJTable.AccessibleJTableCell.getFontMetrics(Font f) 获取此对象的 FontMetrics。
FontMetrics | JList.AccessibleJList.AccessibleJListChild.getFontMetrics(Font f)
FontMetrics | JComponent.getFontMetrics(Font font) 获取指定 Font 的 FontMetrics。
void | DebugGraphics.setFont(Font aFont) 设置用于文本绘制操作的 Font。
void | JSlider.setFont(Font font) 设置此组件的字体。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setFont(Font f)
void | JTable.AccessibleJTable.AccessibleJTableCell.setFont(Font f) 设置此对象的 Font。
void | JTextArea.setFont(Font f) 设置当前字体。
void | JTextField.setFont(Font f) 设置当前字体。
void | JList.AccessibleJList.AccessibleJListChild.setFont(Font f)
void | JComponent.setFont(Font font) 设置此组件的字体。

javax.swing.border 中 Font 的使用

声明为 Font 的 javax.swing.border 中的字段
protected  Font TitledBorder.titleFont

返回 Font 的 javax.swing.border 中的方法
protected Font | TitledBorder.getFont(Component c)
Font | TitledBorder.getTitleFont() 返回带标题边框的标题字体。

参数类型为 Font 的 javax.swing.border 中的方法
 void TitledBorder.setTitleFont(Font titleFont)
设置带标题边框的标题字体。

参数类型为 Font 的 javax.swing.border 中的构造方法
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

javax.swing.plaf 中 Font 的使用

javax.swing.plaf 中 Font 的子类
 class FontUIResource
实现 UIResource 的 java.awt.Font 的子类。

参数类型为 Font 的 javax.swing.plaf 中的构造方法
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
FontUIResource(Font font)

javax.swing.plaf.basic 中 Font 的使用

声明为 Font 的 javax.swing.plaf.basic 中的字段
protected  Font BasicMenuItemUI.acceleratorFont

参数类型为 Font 的 javax.swing.plaf.basic 中的方法
protected  void BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)

javax.swing.plaf.synth 中 Font 的使用

返回 Font 的 javax.swing.plaf.synth 中的方法
Font | SynthStyle.getFont(SynthContext context) 返回指定状态的 Font。
protected abstract Font | SynthStyle.getFontForState(SynthContext context) 返回指定状态的字体。

参数类型为 Font 的 javax.swing.plaf.synth 中的方法
int | SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text) 返回传入字符串的大小。
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。

javax.swing.table 中 Font 的使用

返回 Font 的 javax.swing.table 中的方法
 Font JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFont()

参数类型为 Font 的 javax.swing.table 中的方法
FontMetrics | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getFontMetrics(Font f)
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setFont(Font f)

javax.swing.text 中 Font 的使用

返回 Font 的 javax.swing.text 中的方法
Font | GlyphView.getFont() 获取字形应该以其为依据的字体。
Font | LabelView.getFont() 获取字形应该以其为依据的字体。
Font | DefaultStyledDocument.getFont(AttributeSet attr) 从属性集获得字体。
Font | StyledDocument.getFont(AttributeSet attr) 使用一个属性集并将其转换为字体规范。
Font | StyleContext.getFont(AttributeSet attr) 从属性集中获取字体。
Font | StyleContext.getFont(String family, int style, int size) 获取新字体。

参数类型为 Font 的 javax.swing.text 中的方法
 FontMetrics StyleContext.getFontMetrics(Font f)
获取某种字体的字体规格。

javax.swing.text.html 中 Font 的使用

返回 Font 的 javax.swing.text.html 中的方法
 Font StyleSheet.getFont(AttributeSet a)
获取给定属性集使用的字体。

javax.swing.tree 中 Font 的使用

声明为 Font 的 javax.swing.tree 中的字段
protected  Font DefaultTreeCellEditor.font
用以绘制的字体，null 指示将使用呈现器的字体。

返回 Font 的 javax.swing.tree 中的方法
Font | DefaultTreeCellEditor.getFont() 获取用于编辑的字体。
Font | DefaultTreeCellEditor.DefaultTextField.getFont()
Font | DefaultTreeCellRenderer.getFont() 获取此组件的字体。

参数类型为 Font 的 javax.swing.tree 中的方法
void | DefaultTreeCellEditor.setFont(Font font) 设置编辑使用的字体。
void | DefaultTreeCellRenderer.setFont(Font font) 创建子类，以便将 FontUIResource 映射为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Dialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog
的使用

使用 Dialog 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Dialog 的使用

java.awt 中 Dialog 的子类
 class FileDialog
FileDialog 类显示一个对话框窗口，用户可以从中选择文件。

参数类型为 Dialog 的 java.awt 中的方法
protected abstract  java.awt.peer.DialogPeer Toolkit.createDialog(Dialog target)
使用指定同位体接口创建此工具包的 Dialog 实现。

参数类型为 Dialog 的 java.awt 中的构造方法
Dialog(Dialog owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Dialog 和一个空标题。
Dialog(Dialog owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。
Dialog(Dialog owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。
Dialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。
FileDialog(Dialog parent)
创建一个文件对话框，用于加载文件。
FileDialog(Dialog parent, String title)
创建一个具有指定标题的文件对话框，用于加载文件。
FileDialog(Dialog parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

javax.swing 中 Dialog 的使用

javax.swing 中 Dialog 的子类
 class JDialog
创建对话框窗口的主要类。

参数类型为 Dialog 的 javax.swing 中的构造方法
JDialog(Dialog owner)
创建一个没有标题但将指定的 Dialog 作为其所有者的无模式对话框。
JDialog(Dialog owner, boolean modal)
创建一个具有指定所有者 Dialog 和模式的对话框。
JDialog(Dialog owner, String title)
创建一个具有指定标题和指定所有者对话框的无模式对话框。
JDialog(Dialog owner, String title, boolean modal)
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。
JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Dialog.ModalityType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog.ModalityType
的使用

使用 Dialog.ModalityType 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Dialog.ModalityType 的使用

声明为 Dialog.ModalityType 的 java.awt 中的字段
static Dialog.ModalityType Dialog.DEFAULT_MODALITY_TYPE
有模式 dialog 的默认模式类型。

返回 Dialog.ModalityType 的 java.awt 中的方法
Dialog.ModalityType | Dialog.getModalityType() 返回此 dialog 的模式类型。
static Dialog.ModalityType | Dialog.ModalityType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Dialog.ModalityType[] | Dialog.ModalityType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Dialog.ModalityType 的 java.awt 中的方法
abstract boolean | Toolkit.isModalityTypeSupported(Dialog.ModalityType modalityType) 返回此工具包是否支持给定的模式类型。
void | Dialog.setModalityType(Dialog.ModalityType type) 设置此 dialog 的模式类型。

参数类型为 Dialog.ModalityType 的 java.awt 中的构造方法
Dialog(Window owner, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。
Dialog(Window owner, String title, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。
Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。

javax.swing 中 Dialog.ModalityType 的使用

参数类型为 Dialog.ModalityType 的 javax.swing 中的构造方法
JDialog(Window owner, Dialog.ModalityType modalityType)
创建一个具有指定所有者 Window、模式和空标题的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Dialog.ModalExclusionType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog.ModalExclusionType
的使用

使用 Dialog.ModalExclusionType 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Dialog.ModalExclusionType 的使用

返回 Dialog.ModalExclusionType 的 java.awt 中的方法
Dialog.ModalExclusionType | Window.getModalExclusionType() 返回此窗口的模式排斥类型。
static Dialog.ModalExclusionType | Dialog.ModalExclusionType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Dialog.ModalExclusionType[] | Dialog.ModalExclusionType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Dialog.ModalExclusionType 的 java.awt 中的方法
abstract boolean | Toolkit.isModalExclusionTypeSupported(Dialog.ModalExclusionType modalExclusionType) 返回此工具包是否支持给定的模式排斥类型。
void | Window.setModalExclusionType(Dialog.ModalExclusionType exclusionType) 指定此窗口的模式排斥类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Dialog.AccessibleAWTDialog 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dialog.AccessibleAWTDialog
的使用

使用 Dialog.AccessibleAWTDialog 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Dialog.AccessibleAWTDialog 的使用

javax.swing 中 Dialog.AccessibleAWTDialog 的子类
protected  class JDialog.AccessibleJDialog
此类实现对 JDialog 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Cursor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Cursor
的使用

使用 Cursor 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Cursor 的使用

声明为 Cursor 的 java.awt 中的字段
protected static Cursor[] Cursor.predefined

返回 Cursor 的 java.awt 中的方法
Cursor | Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name) 创建一个新的自定义光标对象。
Cursor | List.AccessibleAWTList.AccessibleAWTListChild.getCursor() 获取此对象的 Cursor。
Cursor | MenuComponent.AccessibleAWTMenuComponent.getCursor() 获取此对象的 Cursor。
Cursor | Component.getCursor() 获取组件中的光标集合。
Cursor | Component.AccessibleAWTComponent.getCursor() 获取此对象的 Cursor。
static Cursor | Cursor.getDefaultCursor() 返回系统默认光标。
static Cursor | Cursor.getPredefinedCursor(int type) 返回一个具有指定预定义类型的光标对象。
static Cursor | Cursor.getSystemCustomCursor(String name) 返回与指定名称匹配的特定于系统的定制光标对象。

参数类型为 Cursor 的 java.awt 中的方法
void | List.AccessibleAWTList.AccessibleAWTListChild.setCursor(Cursor cursor) 设置此对象的 Cursor。
void | MenuComponent.AccessibleAWTMenuComponent.setCursor(Cursor cursor) 设置此对象的 Cursor。
void | Window.setCursor(Cursor cursor) 设置指定光标的光标图像。
void | Component.setCursor(Cursor cursor) 为指定的光标设置光标图像。
void | Component.AccessibleAWTComponent.setCursor(Cursor cursor) 设置此对象的 Cursor。

java.awt.dnd 中 Cursor 的使用

声明为 Cursor 的 java.awt.dnd 中的字段
static Cursor | DragSource.DefaultCopyDrop 用于复制操作的默认 Cursor，指示当前允许放置。
static Cursor | DragSource.DefaultCopyNoDrop 用于复制操作的默认 Cursor，指示当前不允许放置。
static Cursor | DragSource.DefaultLinkDrop 用于链接操作的默认 Cursor，指示当前允许放置。
static Cursor | DragSource.DefaultLinkNoDrop 用于链接操作的默认 Cursor，指示当前不允许放置。
static Cursor | DragSource.DefaultMoveDrop 用于移动操作的默认 Cursor，指示当前允许放置。
static Cursor | DragSource.DefaultMoveNoDrop 用于移动操作的默认 Cursor，指示当前不允许放置。

返回 Cursor 的 java.awt.dnd 中的方法
 Cursor DragSourceContext.getCursor()
返回当前的拖动 Cursor

参数类型为 Cursor 的 java.awt.dnd 中的方法
protected DragSourceContext | DragSource.createDragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent dgl, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable t, DragSourceListener dsl) 创建处理此拖动的 DragSourceContext。
void | DragSourceContext.setCursor(Cursor c) 将此拖动操作的光标设置为指定的 Cursor。
void | DragGestureEvent.startDrag(Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、拖动 Image、Image 的偏移量、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable) 在给定拖动操作的 Cursor 和表示拖动操作源数据的 Transferable 的情况下开始拖动此操作。
void | DragGestureEvent.startDrag(Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定要显示的初始 Cursor、Transferable 对象和要使用的 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point dragOffset, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point imageOffset, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、要拖动的 Image、Image 原点距离触发时 Cursor 热点的偏移量、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据和 DragSourceListener 的情况下开始拖动。
void | DragSource.startDrag(DragGestureEvent trigger, Cursor dragCursor, Transferable transferable, DragSourceListener dsl, FlavorMap flavorMap) 在给定发起拖动的 DragGestureEvent、使用的初始 Cursor、拖动的 Transferable 目标数据、DragSourceListener 和 FlavorMap 的情况下开始拖动。

参数类型为 Cursor 的 java.awt.dnd 中的构造方法
DragSourceContext(java.awt.dnd.peer.DragSourceContextPeer dscp, DragGestureEvent trigger, Cursor dragCursor, Image dragImage, Point offset, Transferable t, DragSourceListener dsl)
从 DragSource 调用，此构造方法创建一个新 DragSourceContext，使其具有为此 Drag 指定的 DragSourceContextPeer、触发该 Drag 的 DragGestureEvent、用于该 Drag 的初始 Cursor、进行 Drag 时显示的 Image（可选）、Image 原点与触发事件时距离热点的偏移量、Transferable 目标数据、Drag 和 Drop 操作期间使用的 DragSourceListener。

javax.accessibility 中 Cursor 的使用

返回 Cursor 的 javax.accessibility 中的方法
 Cursor AccessibleComponent.getCursor()
获取此对象的 Cursor。

参数类型为 Cursor 的 javax.accessibility 中的方法
 void AccessibleComponent.setCursor(Cursor cursor)
设置此对象的 Cursor。

javax.swing 中 Cursor 的使用

返回 Cursor 的 javax.swing 中的方法
Cursor | JTree.AccessibleJTree.AccessibleJTreeNode.getCursor()
Cursor | JTable.AccessibleJTable.AccessibleJTableCell.getCursor() 获取此对象的 Cursor。
Cursor | JList.AccessibleJList.AccessibleJListChild.getCursor()
Cursor | JInternalFrame.getLastCursor() 返回通过 setCursor 方法设置的最后一个 Cursor，它是不可调整大小的 Cursor。

参数类型为 Cursor 的 javax.swing 中的方法
void | JTree.AccessibleJTree.AccessibleJTreeNode.setCursor(Cursor c)
void | JTable.AccessibleJTable.AccessibleJTableCell.setCursor(Cursor c) 设置此对象的 Cursor。
void | JList.AccessibleJList.AccessibleJListChild.setCursor(Cursor c)
void | JInternalFrame.setCursor(Cursor cursor) 为指定的光标设置光标图像。

javax.swing.table 中 Cursor 的使用

返回 Cursor 的 javax.swing.table 中的方法
 Cursor JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getCursor()

参数类型为 Cursor 的 javax.swing.table 中的方法
 void JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setCursor(Cursor c)

javax.swing.text.html 中 Cursor 的使用

返回 Cursor 的 javax.swing.text.html 中的方法
Cursor | HTMLEditorKit.getDefaultCursor() 返回默认光标。
Cursor | HTMLEditorKit.getLinkCursor() 返回要在超链接上使用的光标。

参数类型为 Cursor 的 javax.swing.text.html 中的方法
void | HTMLEditorKit.setDefaultCursor(Cursor cursor) 设置默认光标。
void | HTMLEditorKit.setLinkCursor(Cursor cursor) 设置要在链接上使用的光标。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.ComponentOrientation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.ComponentOrientation
的使用

使用 ComponentOrientation 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 ComponentOrientation 的使用

声明为 ComponentOrientation 的 java.awt 中的字段
static ComponentOrientation | ComponentOrientation.LEFT_TO_RIGHT 各项从左到右布局，各行从上到下，示例：英语、法语。
static ComponentOrientation | ComponentOrientation.RIGHT_TO_LEFT 各项从右到左布局，各行从上到下，示例：阿拉伯语、希伯来语。
static ComponentOrientation | ComponentOrientation.UNKNOWN 表示尚未设置组件的方向。

返回 ComponentOrientation 的 java.awt 中的方法
 ComponentOrientation Component.getComponentOrientation()
检索将用于排序此组件内的元素或文本的语言敏感的方向。
static ComponentOrientation ComponentOrientation.getOrientation(Locale locale)
返回适合于给定区域的方向。
static ComponentOrientation ComponentOrientation.getOrientation(ResourceBundle bdl)
已过时。 在 J2SE 1.4 中，使用 getOrientation(java.util.Locale)。

参数类型为 ComponentOrientation 的 java.awt 中的方法
void | Container.applyComponentOrientation(ComponentOrientation o) 设置此容器和其中包含的所有组件的 ComponentOrientation 属性。
void | Component.applyComponentOrientation(ComponentOrientation orientation) 设置此组件及其包含的所有组件的 ComponentOrientation 属性。
void | Component.setComponentOrientation(ComponentOrientation o) 设置语言敏感的方向，用于排序此组件内的元素或文本。

javax.swing 中 ComponentOrientation 的使用

参数类型为 ComponentOrientation 的 javax.swing 中的方法
void | JMenu.applyComponentOrientation(ComponentOrientation o) 设置此菜单及其中包含的所有组件的 ComponentOrientation 属性。
void | JScrollPane.setComponentOrientation(ComponentOrientation co) 设置由 ComponentOrientation 参数确定的垂直和水平滚动条方向。
void | JMenu.setComponentOrientation(ComponentOrientation o)

javax.swing.text 中 ComponentOrientation 的使用

参数类型为 ComponentOrientation 的 javax.swing.text 中的方法
 void JTextComponent.setComponentOrientation(ComponentOrientation o)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Dimension 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Dimension
的使用

使用 Dimension 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.imageio | Java Image I/O API 的主要包。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Dimension 的使用

参数类型为 Dimension 的 java.applet 中的方法
 void Applet.resize(Dimension d)
请求调整此 applet 的大小。

java.awt 中 Dimension 的使用

返回 Dimension 的 java.awt 中的方法
 Dimension Toolkit.getBestCursorSize(int preferredWidth, int preferredHeight)
返回最接近所需大小的受支持光标尺寸。
 Dimension Container.getMaximumSize()
返回此容器的最大大小。
 Dimension Component.getMaximumSize()
获取组件的最大大小。
 Dimension List.getMinimumSize()
确定此滚动列表的最小大小。
 Dimension TextArea.getMinimumSize()
确定此文本区的最小大小。
 Dimension TextField.getMinimumSize()
获取此文本字段的最小尺寸。
 Dimension Container.getMinimumSize()
返回此容器的最小大小。
 Dimension Component.getMinimumSize()
获取组件的最小大小。
 Dimension List.getMinimumSize(int rows)
获取具有指定行数的列表的最少维数。
 Dimension TextField.getMinimumSize(int columns)
获取具有指定列数的文本字段的最小尺寸。
 Dimension TextArea.getMinimumSize(int rows, int columns)
确定具有指定行数和列数的文本区的最小大小。
protected  Dimension GridBagLayout.getMinSize(Container parent, GridBagLayoutInfo info)
基于 getLayoutInfo 中的信息计算其所有者的最小大小。
protected  Dimension GridBagLayout.GetMinSize(Container parent, GridBagLayoutInfo info)
此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。
abstract  Dimension PrintJob.getPageDimension()
返回页面的维数，以像素为单位。
 Dimension List.getPreferredSize()
获取此滚动列表的首选大小。
 Dimension TextArea.getPreferredSize()
确定此文本区的首选大小。
 Dimension TextField.getPreferredSize()
获取此文本字段的首选大小。
 Dimension Container.getPreferredSize()
返回此容器的首选大小。
 Dimension Component.getPreferredSize()
获取组件的首选大小。
 Dimension List.getPreferredSize(int rows)
获取具有指定行数的列表的首选维数。
 Dimension TextField.getPreferredSize(int columns)
获取具有指定列数的文本字段的首选大小。
 Dimension TextArea.getPreferredSize(int rows, int columns)
确定具有指定行数和列数的文本区的首选大小。
abstract  Dimension Toolkit.getScreenSize()
获取屏幕的大小。
 Dimension List.AccessibleAWTList.AccessibleAWTListChild.getSize()
以 Dimension 对象的形式返回此对象的大小。
 Dimension SplashScreen.getSize()
以 Dimension 形式返回闪现屏幕窗口的大小。
 Dimension TrayIcon.getSize()
返回托盘图标在系统托盘上占用的空间大小（以像素为单位）。
 Dimension MenuComponent.AccessibleAWTMenuComponent.getSize()
以 Dimension 对象的形式返回此对象的大小。
 Dimension Rectangle.getSize()
获取此 Rectangle 的大小，用返回的 Dimension 表示。
 Dimension Dimension.getSize()
获取此 Dimension 对象的大小。
 Dimension Component.getSize()
以 Dimension 对象的形式返回组件的大小。
 Dimension Component.AccessibleAWTComponent.getSize()
返回此对象的大小，用 Dimension 对象的形式表示它。
 Dimension Component.getSize(Dimension rv)
将组件的宽度/高度存储到“返回值”rv 中并返回 rv。
 Dimension SystemTray.getTrayIconSize()
返回托盘图标在系统托盘中占用的空间大小（以像素为单位）。
 Dimension ScrollPane.getViewportSize()
返回滚动条窗格视口的当前大小。
 Dimension GridBagLayout.maximumLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的最大维数
 Dimension CardLayout.maximumLayoutSize(Container target)
给出指定目标容器中的组件，返回此布局的最大尺寸。
 Dimension BorderLayout.maximumLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。
 Dimension LayoutManager2.maximumLayoutSize(Container target)
给定指定容器的组件，计算该容器的最大大小维数。
 Dimension GridBagLayout.minimumLayoutSize(Container parent)
使用此网格包布局确定 parent 容器的最小大小。
 Dimension GridLayout.minimumLayoutSize(Container parent)
使用此网络布局确定最小大小的容器参数。
 Dimension CardLayout.minimumLayoutSize(Container parent)
计算指定面板大小的最小值。
 Dimension FlowLayout.minimumLayoutSize(Container target)
返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。
 Dimension BorderLayout.minimumLayoutSize(Container target)
使用此布局管理器确定 target 容器的最小大小。
 Dimension LayoutManager.minimumLayoutSize(Container parent)
给定指定容器所包含的组件，计算该容器的最小大小维数。
 Dimension List.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextArea.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextField.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension Container.minimumSize()
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。
 Dimension Component.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension List.minimumSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextField.minimumSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextArea.minimumSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
 Dimension GridBagLayout.preferredLayoutSize(Container parent)
使用此网络包布局确定 parent 容器的首选大小。
 Dimension GridLayout.preferredLayoutSize(Container parent)
使用此网格布局确定容器参数的首选大小。
 Dimension CardLayout.preferredLayoutSize(Container parent)
使用此卡片布局确定容器参数的首选大小。
 Dimension FlowLayout.preferredLayoutSize(Container target)
给出指定目标容器中的 visible 组件，返回此布局的首选维数。
 Dimension BorderLayout.preferredLayoutSize(Container target)
基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。
 Dimension LayoutManager.preferredLayoutSize(Container parent)
给定指定容器所包含的组件，计算该容器的首选大小维数。
 Dimension List.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextArea.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextField.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension Container.preferredSize()
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。
 Dimension Component.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension List.preferredSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextField.preferredSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextArea.preferredSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
 Dimension Component.size()
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。

参数类型为 Dimension 的 java.awt 中的方法
Dimension | Component.getSize(Dimension rv) 将组件的宽度/高度存储到“返回值”rv 中并返回 rv。
void | Component.resize(Dimension d) 已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
void | Component.setMaximumSize(Dimension maximumSize) 将组件的最大大小设置为常量值。
void | Window.setMinimumSize(Dimension minimumSize) 将此窗口的最小大小设置为一个常量值。
void | Component.setMinimumSize(Dimension minimumSize) 将组件的最小大小设置为常量值。
void | Component.setPreferredSize(Dimension preferredSize) 将组件的首选大小设置为常量值。
void | List.AccessibleAWTList.AccessibleAWTListChild.setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | MenuComponent.AccessibleAWTMenuComponent.setSize(Dimension d) 调整此对象的大小。
void | Rectangle.setSize(Dimension d) 设置此 Rectangle 的大小，以匹配指定的 Dimension。
void | Dimension.setSize(Dimension d) 将 Dimension 对象的大小设置为指定大小。
void | Window.setSize(Dimension d) 调整组件的大小，使其宽度为 d.width，高度为 d.height。
void | Component.setSize(Dimension d) 调整组件的大小，使其宽度为 d.width，高度为 d.height。
void | Component.AccessibleAWTComponent.setSize(Dimension d) 调整此对象的大小，使它具有宽度和高度。

参数类型为 Dimension 的 java.awt 中的构造方法
Dimension(Dimension d)
创建 Dimension 的一个实例（宽度和高度与指定的 dimension 相同）。
Rectangle(Dimension d)
构造一个新的 Rectangle，其左上角为 (0,0)，其宽度和高度由 Dimension 参数指定。
Rectangle(Point p, Dimension d)
构造一个新的 Rectangle，其左上角由 Point 参数指定，其宽度和高度由 Dimension 参数指定。

javax.accessibility 中 Dimension 的使用

返回 Dimension 的 javax.accessibility 中的方法
 Dimension AccessibleComponent.getSize()
以 Dimension 对象的形式返回此对象的大小。

参数类型为 Dimension 的 javax.accessibility 中的方法
 void AccessibleComponent.setSize(Dimension d)
调整此对象，使其具有高度和宽度。

javax.imageio 中 Dimension 的使用

声明为 Dimension 的 javax.imageio 中的字段
protected Dimension[] | ImageWriteParam.preferredTileSizes 首选 tile 大小范围对组成的数组。
protected Dimension | ImageReadParam.sourceRenderSize 如果 canSetSourceRenderSize 为 true，则为源的所需呈现宽度和高度；或者为 null。

返回 Dimension 的 javax.imageio 中的方法
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
Dimension[] | ImageWriteParam.getPreferredTileSizes() 返回一个 Dimension 数组，指示在输出文件或流中进行编码时 tile 的合法大小范围。
Dimension | ImageReadParam.getSourceRenderSize() 返回解码期间将呈现的源图像的宽度和高度，如果已经通过 setSourceRenderSize 方法设置了的话。

参数类型为 Dimension 的 javax.imageio 中的方法
 void ImageReadParam.setSourceRenderSize(Dimension size)
如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。

javax.swing 中 Dimension 的使用

声明为 Dimension 的 javax.swing 中的字段
protected  Dimension JTable.preferredViewportSize
Scrollable 接口使用它来确定初始的可见区域。

返回 Dimension 的 javax.swing 中的方法
Dimension | UIDefaults.getDimension(Object key) 如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
static Dimension | UIManager.getDimension(Object key) 从默认值中返回一个维数。
Dimension | UIDefaults.getDimension(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
static Dimension | UIManager.getDimension(Object key, Locale l) 从适合给定语言环境的默认值中返回一个维数。
Dimension | RepaintManager.getDoubleBufferMaximumSize() 返回最大双缓冲区大小。
Dimension | JViewport.getExtentSize() 返回视图坐标中视图的可见部分的大小。
Dimension | JTable.getIntercellSpacing() 返回单元格之间的水平间距和垂直间距。
Dimension | JScrollBar.getMaximumSize() 滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
Dimension | JToolBar.Separator.getMaximumSize() 返回分隔符的最小大小。
Dimension | JComponent.getMaximumSize() 如果已将最大大小设置为一个非 null 值，则返回该值。
Dimension | JScrollBar.getMinimumSize() 滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
Dimension | JToolBar.Separator.getMinimumSize() 返回分隔符的最小大小。
Dimension | JComponent.getMinimumSize() 如果已将最小大小设置为一个非 null 值，则返回该值。
Dimension | JTree.getPreferredScrollableViewportSize() 返回 JTree 的首选显示大小。
Dimension | JTable.getPreferredScrollableViewportSize() 返回此表视口的首选大小。
Dimension | JTextArea.getPreferredScrollableViewportSize() 如果此组件被嵌入 JScrollPane 中，则返回 viewport 的首选大小。
Dimension | JList.getPreferredScrollableViewportSize() 计算显示 visibleRowCount 行所需的视口的大小。
Dimension | Scrollable.getPreferredScrollableViewportSize() 返回视图组件视口的首选大小。
Dimension | JEditorPane.getPreferredSize() 返回该 JEditorPane 的首选大小。
Dimension | JTextArea.getPreferredSize() 返回 TextArea 的首选大小。
Dimension | JTextField.getPreferredSize() 返回此 TextField 所需的首选大小 Dimensions。
Dimension | JToolBar.Separator.getPreferredSize() 返回分隔符的首选大小。
Dimension | JComponent.getPreferredSize() 如果 preferredSize 已设置为一个非 null 值，则返回该值。
Dimension | JToolBar.Separator.getSeparatorSize() 返回分隔符的大小
Dimension | JTree.AccessibleJTree.AccessibleJTreeNode.getSize()
Dimension | JTable.AccessibleJTable.AccessibleJTableCell.getSize()
Dimension | JList.AccessibleJList.AccessibleJListChild.getSize()
Dimension | JComponent.getSize(Dimension rv) 将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。
Dimension | JViewport.getViewSize() 如果未显式设置视图的大小，则返回首选大小，否则返回该视图的当前大小。
Dimension | GroupLayout.maximumLayoutSize(Container parent) 返回指定容器的最大大小。
Dimension | OverlayLayout.maximumLayoutSize(Container target) 返回需要布置组件的最大维数，该组件包含在指定的目标容器中。
Dimension | SpringLayout.maximumLayoutSize(Container parent)
Dimension | BoxLayout.maximumLayoutSize(Container target) 返回目标容器布置其所包含的组件时可使用的最大尺寸。
Dimension | JRootPane.RootLayout.maximumLayoutSize(Container target) 返回布局能够使用的最大空间量。
Dimension | GroupLayout.minimumLayoutSize(Container parent) 返回指定容器的最小大小。
Dimension | JSpinner.DefaultEditor.minimumLayoutSize(Container parent) 返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。
Dimension | OverlayLayout.minimumLayoutSize(Container target) 返回需要布置组件的最小维数，该组件包含在指定的目标容器中。
Dimension | SpringLayout.minimumLayoutSize(Container parent)
Dimension | ViewportLayout.minimumLayoutSize(Container parent) 返回需要布置指定目标容器中包含的组件的最小维数。
Dimension | ScrollPaneLayout.minimumLayoutSize(Container parent) ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。
Dimension | BoxLayout.minimumLayoutSize(Container target) 返回布置包含在指定目标容器中的组件所需的最小尺寸。
Dimension | JRootPane.RootLayout.minimumLayoutSize(Container parent) 返回布局需要的最小空间量。
Dimension | GroupLayout.preferredLayoutSize(Container parent) 返回指定容器的首选大小。
Dimension | JSpinner.DefaultEditor.preferredLayoutSize(Container parent) 返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。
Dimension | OverlayLayout.preferredLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
Dimension | SpringLayout.preferredLayoutSize(Container parent)
Dimension | ViewportLayout.preferredLayoutSize(Container parent) 在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
Dimension | ScrollPaneLayout.preferredLayoutSize(Container parent) ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。
Dimension | BoxLayout.preferredLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
Dimension | JRootPane.RootLayout.preferredLayoutSize(Container parent) 返回布局要使用的空间量。
Dimension | JViewport.toViewCoordinates(Dimension size) 将一个大小的像素坐标转换为视图坐标。

参数类型为 Dimension 的 javax.swing 中的方法
void | JToolBar.addSeparator(Dimension size) 将指定大小的分隔符添加到工具栏的末尾。
void | Box.Filler.changeShape(Dimension min, Dimension pref, Dimension max) 更改此形状的大小请求。
protected boolean | JViewport.computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint) 计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
static Component | Box.createRigidArea(Dimension d) 创建一个总是具有指定大小的不可见组件。
Dimension | JComponent.getSize(Dimension rv) 将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。
void | RepaintManager.setDoubleBufferMaximumSize(Dimension d) 设置最大双缓冲区大小。
void | JViewport.setExtentSize(Dimension newExtent) 使用视图坐标设置该视图可见部分的大小。
void | JTable.setIntercellSpacing(Dimension intercellSpacing) 将 rowMargin 和 columnMargin（单元格之间间距的高度和宽度）设置为 intercellSpacing。
void | JComponent.setMaximumSize(Dimension maximumSize) 将此组件的最大大小设置为一个常量值。
void | JComponent.setMinimumSize(Dimension minimumSize) 将此组件的最小大小设置为一个常量值。
void | JPopupMenu.setPopupSize(Dimension d) 使用 Dimension 对象设置弹出窗口的大小。
void | JTable.setPreferredScrollableViewportSize(Dimension size) 设置此表视口的首选大小。
void | JComponent.setPreferredSize(Dimension preferredSize) 设置此组件的首选大小。
void | JToolBar.Separator.setSeparatorSize(Dimension size) 设置分隔符的大小。
void | JTree.AccessibleJTree.AccessibleJTreeNode.setSize(Dimension d)
void | JTable.AccessibleJTable.AccessibleJTableCell.setSize(Dimension d)
void | JList.AccessibleJList.AccessibleJListChild.setSize(Dimension d)
void | JViewport.setViewSize(Dimension newSize) 设置视图的大小。
Dimension | JViewport.toViewCoordinates(Dimension size) 将一个大小的像素坐标转换为视图坐标。

参数类型为 Dimension 的 javax.swing 中的构造方法
Box.Filler(Dimension min, Dimension pref, Dimension max)
使用给定的大小范围创建形状的构造方法。
JToolBar.Separator(Dimension size)
创建具有指定大小的新的工具栏分隔符。

javax.swing.border 中 Dimension 的使用

返回 Dimension 的 javax.swing.border 中的方法
 Dimension TitledBorder.getMinimumSize(Component c)
返回此边框完全显示边框和标题所需的最小大小。

javax.swing.plaf 中 Dimension 的使用

javax.swing.plaf 中 Dimension 的子类
 class DimensionUIResource

返回 Dimension 的 javax.swing.plaf 中的方法
Dimension | ComponentUI.getMaximumSize(JComponent c) 返回指定组件的适合外观的最大大小。
Dimension | ComponentUI.getMinimumSize(JComponent c) 返回指定组件的适合外观的最小大小。
Dimension | ComponentUI.getPreferredSize(JComponent c) 返回指定组件的适合外观的首选大小。

javax.swing.plaf.basic 中 Dimension 的使用

声明为 Dimension 的 javax.swing.plaf.basic 中的字段
protected Dimension | BasicComboBoxUI.cachedMinimumSize
protected Dimension | BasicScrollBarUI.maximumThumbSize
protected Dimension | BasicOptionPaneUI.minimumSize
protected Dimension | BasicScrollBarUI.minimumThumbSize
protected Dimension | BasicTreeUI.preferredMinSize 最小首选大小。
protected Dimension | BasicTreeUI.preferredSize 完全显示所有节点所需的大小。

返回 Dimension 的 javax.swing.plaf.basic 中的方法
protected  Dimension BasicTabbedPaneUI.TabbedPaneLayout.calculateSize(boolean minimum)
protected  Dimension BasicComboBoxUI.getDefaultSize()
返回使用当前渲染器和字体的组合框的空显示区域的默认大小。
protected  Dimension BasicComboBoxUI.getDisplaySize()
返回显示区域的计算大小。
 Dimension BasicArrowButton.getMaximumSize()
返回 BasicArrowButton 的最大大小。
 Dimension BasicDesktopIconUI.getMaximumSize(JComponent c)
不能调整桌面图标的大小。
 Dimension BasicDesktopPaneUI.getMaximumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMaximumSize(JComponent x)
 Dimension BasicToolTipUI.getMaximumSize(JComponent c)
 Dimension BasicSliderUI.getMaximumSize(JComponent c)
 Dimension BasicSplitPaneUI.getMaximumSize(JComponent jc)
返回传入组件的最大大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMaximumSize(JComponent c)
返回此组件的最大大小，如果实例当前位于 JTree 中或 0, 0 处，则该大小将为首选大小。
 Dimension BasicTableUI.getMaximumSize(JComponent c)
返回表的最大大小。
 Dimension BasicTableHeaderUI.getMaximumSize(JComponent c)
返回标题的最大大小。
 Dimension BasicProgressBarUI.getMaximumSize(JComponent c)
 Dimension BasicTabbedPaneUI.getMaximumSize(JComponent c)
 Dimension BasicTextUI.getMaximumSize(JComponent c)
获取编辑器组件的最大大小。
 Dimension BasicScrollPaneUI.getMaximumSize(JComponent c)
 Dimension BasicComboBoxUI.getMaximumSize(JComponent c)
 Dimension BasicScrollBarUI.getMaximumSize(JComponent c)
 Dimension BasicSeparatorUI.getMaximumSize(JComponent c)
 Dimension BasicMenuUI.getMaximumSize(JComponent c)
 Dimension BasicMenuItemUI.getMaximumSize(JComponent c)
 Dimension BasicMenuBarUI.getMaximumSize(JComponent c)
 Dimension BasicButtonUI.getMaximumSize(JComponent c)
 Dimension BasicLabelUI.getMaximumSize(JComponent c)
protected  Dimension BasicScrollBarUI.getMaximumThumbSize()
返回 thumb 的最大可接受大小。
 Dimension BasicSliderUI.getMinimumHorizontalSize()
 Dimension BasicOptionPaneUI.getMinimumOptionPaneSize()
返回选项窗格应该具有的最小大小。
 Dimension BasicSplitPaneDivider.getMinimumSize()
返回 dividerSize x dividerSize
 Dimension BasicArrowButton.getMinimumSize()
返回 BasicArrowButton 的最小大小。
 Dimension BasicDesktopIconUI.getMinimumSize(JComponent c)
 Dimension BasicDesktopPaneUI.getMinimumSize(JComponent c)
 Dimension BasicInternalFrameUI.getMinimumSize(JComponent x)
 Dimension BasicToolTipUI.getMinimumSize(JComponent c)
 Dimension BasicSliderUI.getMinimumSize(JComponent c)
 Dimension BasicTextAreaUI.getMinimumSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getMinimumSize(JComponent jc)
返回传入组件的最小大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getMinimumSize(JComponent c)
返回此组件的最小大小。
 Dimension BasicTableUI.getMinimumSize(JComponent c)
返回表的最小大小。
 Dimension BasicTableHeaderUI.getMinimumSize(JComponent c)
返回标题的最小大小。
 Dimension BasicProgressBarUI.getMinimumSize(JComponent c)
此组件的最小大小为 10。
 Dimension BasicTabbedPaneUI.getMinimumSize(JComponent c)
 Dimension BasicTextUI.getMinimumSize(JComponent c)
获取编辑器组件的最小大小。
 Dimension BasicComboBoxUI.getMinimumSize(JComponent c)
最小大小为显示区域加上 insets 再加上按钮的大小。
 Dimension BasicSeparatorUI.getMinimumSize(JComponent c)
 Dimension BasicMenuItemUI.getMinimumSize(JComponent c)
 Dimension BasicMenuBarUI.getMinimumSize(JComponent c)
 Dimension BasicButtonUI.getMinimumSize(JComponent c)
 Dimension BasicLabelUI.getMinimumSize(JComponent c)
protected  Dimension BasicScrollBarUI.getMinimumThumbSize()
返回 thumb 的最小可接受大小。
 Dimension BasicSliderUI.getMinimumVerticalSize()
static Dimension BasicGraphicsUtils.getPreferredButtonSize(AbstractButton b, int textIconGap)
 Dimension BasicSliderUI.getPreferredHorizontalSize()
protected  Dimension BasicProgressBarUI.getPreferredInnerHorizontal()
protected  Dimension BasicProgressBarUI.getPreferredInnerVertical()
protected  Dimension BasicMenuItemUI.getPreferredMenuItemSize(JComponent c, Icon checkIcon, Icon arrowIcon, int defaultTextIconGap)
 Dimension BasicTreeUI.getPreferredMinSize()
返回最小首选大小。
 Dimension BasicSplitPaneDivider.getPreferredSize()
返回 dividerSize x dividerSize
 Dimension BasicComboBoxRenderer.getPreferredSize()
 Dimension BasicArrowButton.getPreferredSize()
返回 BasicArrowButton 的首选大小。
 Dimension BasicDesktopIconUI.getPreferredSize(JComponent c)
 Dimension BasicDesktopPaneUI.getPreferredSize(JComponent c)
 Dimension BasicInternalFrameUI.getPreferredSize(JComponent x)
 Dimension BasicOptionPaneUI.getPreferredSize(JComponent c)
如果 c 为包含接收者的 JOptionPane，则返回的首选大小为 JOptionPane 的 LayoutManager 的最大首选大小和 getMinimumOptionPaneSize。
 Dimension BasicPopupMenuSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicToolTipUI.getPreferredSize(JComponent c)
 Dimension BasicSliderUI.getPreferredSize(JComponent c)
 Dimension BasicTextAreaUI.getPreferredSize(JComponent c)
重写此方法以将插入符的宽度考虑在内。
 Dimension BasicSplitPaneUI.getPreferredSize(JComponent jc)
返回传入组件的首选大小，该大小将传递给当前布局管理器。
 Dimension BasicTreeUI.getPreferredSize(JComponent c)
返回首选大小以正确显示树，这是一种 getPreferredSize(c, false) 的替代方法。
 Dimension BasicTableUI.getPreferredSize(JComponent c)
返回表的首选大小。
 Dimension BasicTableHeaderUI.getPreferredSize(JComponent c)
返回标题的首选大小。
 Dimension BasicProgressBarUI.getPreferredSize(JComponent c)
 Dimension BasicRadioButtonUI.getPreferredSize(JComponent c)
单选按钮的首选大小。
 Dimension BasicToolBarSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicTextUI.getPreferredSize(JComponent c)
获取编辑器组件的首选大小。
 Dimension BasicListUI.getPreferredSize(JComponent c)
列表的 preferredSize 依赖于布局方向。
 Dimension BasicComboBoxUI.getPreferredSize(JComponent c)
 Dimension BasicScrollBarUI.getPreferredSize(JComponent c)
垂直滚动条的首选宽度是（非 null）递增/递减按钮的首选宽度的最大值，也是 thumb 的最小宽度。
 Dimension BasicSeparatorUI.getPreferredSize(JComponent c)
 Dimension BasicMenuItemUI.getPreferredSize(JComponent c)
 Dimension BasicButtonUI.getPreferredSize(JComponent c)
 Dimension BasicLabelUI.getPreferredSize(JComponent c)
 Dimension BasicTreeUI.getPreferredSize(JComponent c, boolean checkConsistancy)
返回首选大小以表示 c 中的树。
 Dimension BasicSliderUI.getPreferredVerticalSize()
protected  Dimension BasicSliderUI.getThumbSize()
 Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.maximumLayoutSize(Container target)
返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。
 Dimension BasicInternalFrameTitlePane.TitlePaneLayout.minimumLayoutSize(Container c)
 Dimension BasicInternalFrameUI.InternalFrameLayout.minimumLayoutSize(Container c)
 Dimension BasicOptionPaneUI.ButtonAreaLayout.minimumLayoutSize(Container c)
 Dimension BasicSplitPaneDivider.DividerLayout.minimumLayoutSize(Container c)
 Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.minimumLayoutSize(Container container)
返回包含子级所需的最小大小。
 Dimension BasicTabbedPaneUI.TabbedPaneLayout.minimumLayoutSize(Container parent)
 Dimension BasicComboBoxUI.ComboBoxLayoutManager.minimumLayoutSize(Container parent)
 Dimension BasicScrollBarUI.minimumLayoutSize(Container scrollbarContainer)
 Dimension BasicInternalFrameTitlePane.TitlePaneLayout.preferredLayoutSize(Container c)
 Dimension BasicInternalFrameUI.InternalFrameLayout.preferredLayoutSize(Container c)
 Dimension BasicOptionPaneUI.ButtonAreaLayout.preferredLayoutSize(Container c)
 Dimension BasicSplitPaneDivider.DividerLayout.preferredLayoutSize(Container c)
 Dimension BasicSplitPaneUI.BasicHorizontalLayoutManager.preferredLayoutSize(Container container)
返回包含子级所需的首选大小。
 Dimension BasicTabbedPaneUI.TabbedPaneLayout.preferredLayoutSize(Container parent)
 Dimension BasicComboBoxUI.ComboBoxLayoutManager.preferredLayoutSize(Container parent)
 Dimension BasicScrollBarUI.preferredLayoutSize(Container scrollbarContainer)
 Dimension DefaultMenuLayout.preferredLayoutSize(Container target)

参数类型为 Dimension 的 javax.swing.plaf.basic 中的方法
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getAvailableSize(Dimension containerSize, Insets insets) 返回基于容器大小和 Insets 的可用宽度。
protected void | BasicRadioButtonUI.paintFocus(Graphics g, Rectangle textRect, Dimension size)
protected void | BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize) 将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。
void | BasicTreeUI.setPreferredMinSize(Dimension newSize) 设置首选最小大小。

javax.swing.plaf.metal 中 Dimension 的使用

返回 Dimension 的 javax.swing.plaf.metal 中的方法
Dimension | MetalScrollButton.getMaximumSize()
Dimension | MetalDesktopIconUI.getMaximumSize(JComponent c)
Dimension | MetalFileChooserUI.getMaximumSize(JComponent c) 返回 JFileChooser 的最大大小。
Dimension | MetalComboBoxButton.getMinimumSize()
Dimension | MetalScrollButton.getMinimumSize()
Dimension | MetalDesktopIconUI.getMinimumSize(JComponent c)
Dimension | MetalFileChooserUI.getMinimumSize(JComponent c) 返回 JFileChooser 的最小大小。
Dimension | MetalComboBoxUI.getMinimumSize(JComponent c)
protected Dimension | MetalScrollBarUI.getMinimumThumbSize()
Dimension | MetalScrollButton.getPreferredSize()
Dimension | MetalDesktopIconUI.getPreferredSize(JComponent c)
Dimension | MetalFileChooserUI.getPreferredSize(JComponent c) 返回指定 JFileChooser 的首选大小。
Dimension | MetalToolTipUI.getPreferredSize(JComponent c)
Dimension | MetalScrollBarUI.getPreferredSize(JComponent c)
Dimension | MetalPopupMenuSeparatorUI.getPreferredSize(JComponent c)
Dimension | MetalSeparatorUI.getPreferredSize(JComponent c)
protected Dimension | MetalSliderUI.getThumbSize()

参数类型为 Dimension 的 javax.swing.plaf.metal 中的方法
protected  void MetalRadioButtonUI.paintFocus(Graphics g, Rectangle t, Dimension d)

javax.swing.plaf.multi 中 Dimension 的使用

返回 Dimension 的 javax.swing.plaf.multi 中的方法
Dimension | MultiButtonUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiColorChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiComboBoxUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopIconUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiDesktopPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiFileChooserUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法
Dimension | MultiInternalFrameUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiLabelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiListUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiMenuItemUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiOptionPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPanelUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiPopupMenuUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiProgressBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiRootPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiScrollPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSeparatorUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSliderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSpinnerUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiSplitPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTabbedPaneUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableHeaderUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTableUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTextUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolBarUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiToolTipUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiTreeUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiViewportUI.getMaximumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMaximumSize 方法。
Dimension | MultiButtonUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiColorChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiComboBoxUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopIconUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiDesktopPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiFileChooserUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiInternalFrameUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiLabelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiListUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiMenuItemUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiOptionPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPanelUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiPopupMenuUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiProgressBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiRootPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiScrollPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSeparatorUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSliderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSpinnerUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiSplitPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTabbedPaneUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableHeaderUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTableUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTextUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolBarUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiToolTipUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiTreeUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiViewportUI.getMinimumSize(JComponent a) 在由此对象处理的每个 UI 上调用 getMinimumSize 方法。
Dimension | MultiButtonUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiColorChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiComboBoxUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopIconUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiDesktopPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiFileChooserUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiInternalFrameUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiLabelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiListUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiMenuItemUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiOptionPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPanelUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiPopupMenuUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiProgressBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiRootPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiScrollPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSeparatorUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSliderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSpinnerUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiSplitPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTabbedPaneUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableHeaderUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTableUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTextUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolBarUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiToolTipUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiTreeUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。
Dimension | MultiViewportUI.getPreferredSize(JComponent a) 在由此对象处理的每个 UI 上调用 getPreferredSize 方法。

javax.swing.plaf.synth 中 Dimension 的使用

返回 Dimension 的 javax.swing.plaf.synth 中的方法
Dimension | SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最大大小。
Dimension | SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的最小大小。
Dimension | SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex) 返回正确呈现图标和文本所需的首选大小。

javax.swing.table 中 Dimension 的使用

返回 Dimension 的 javax.swing.table 中的方法
 Dimension JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getSize()

参数类型为 Dimension 的 javax.swing.table 中的方法
 void JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setSize(Dimension d)

javax.swing.text 中 Dimension 的使用

返回 Dimension 的 javax.swing.text 中的方法
 Dimension JTextComponent.getPreferredScrollableViewportSize()
返回视图组件视口的首选大小。

javax.swing.tree 中 Dimension 的使用

返回 Dimension 的 javax.swing.tree 中的方法
Dimension | DefaultTreeCellEditor.DefaultTextField.getPreferredSize() 重写 JTextField.getPreferredSize，以根据当前字体（如果设置）返回首选大小，否则使用 renderer 的字体。
Dimension | DefaultTreeCellEditor.EditorContainer.getPreferredSize() 返回 Container 的首选大小。
Dimension | DefaultTreeCellRenderer.getPreferredSize() 重写 JComponent.getPreferredSize，以返回稍宽的首选大小值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.LayoutManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.LayoutManager
的使用

使用 LayoutManager 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

java.awt 中 LayoutManager 的使用

java.awt 中 LayoutManager 的子接口
 interface LayoutManager2
为类定义接口，该类知道如何根据布局约束对象来布置 Container。

实现 LayoutManager 的 java.awt 中的类
class | BorderLayout 这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
class | CardLayout CardLayout 对象是容器的布局管理器。
class | FlowLayout 流布局用于安排有向流中的组件，这非常类似于段落中的文本行。
class | GridBagLayout GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。
class | GridLayout GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。

返回 LayoutManager 的 java.awt 中的方法
 LayoutManager Container.getLayout()
获取此容器的布局管理器。

参数类型为 LayoutManager 的 java.awt 中的方法
void | ScrollPane.setLayout(LayoutManager mgr) 设置此容器的布局管理器。
void | Container.setLayout(LayoutManager mgr) 设置此容器的布局管理器。

参数类型为 LayoutManager 的 java.awt 中的构造方法
Panel(LayoutManager layout)
创建具有指定布局管理器的新面板。

javax.swing 中 LayoutManager 的使用

实现 LayoutManager 的 javax.swing 中的类
class | BoxLayout 允许垂直或水平布置多个组件的布局管理器。
class | GroupLayout GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。
protected class | JRootPane.RootLayout 该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | OverlayLayout 要在彼此顶部安排组件的布局管理器。
class | ScrollPaneLayout JScrollPane 使用的布局管理器。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。
class | SpringLayout SpringLayout 根据一组约束布置其相关容器的子组件。
class | ViewportLayout JViewport 的默认布局管理器。

返回 LayoutManager 的 javax.swing 中的方法
protected LayoutManager | JViewport.createLayoutManager() 子类可以重写此方法以在该构造方法中安装一个不同布局的管理器（或者为 null）。
protected LayoutManager | JRootPane.createRootLayout() 由构造方法调用以便创建默认的 layoutManager。

参数类型为 LayoutManager 的 javax.swing 中的方法
 void JApplet.setLayout(LayoutManager manager)
设置 LayoutManager。
 void JWindow.setLayout(LayoutManager manager)
设置 LayoutManager。
 void JScrollPane.setLayout(LayoutManager layout)
设置此 JScrollPane 的布局管理器。
 void Box.setLayout(LayoutManager l)
抛出一个 AWTError，因为 Box 只能使用 BoxLayout。
 void JToolBar.setLayout(LayoutManager mgr)
 void JDialog.setLayout(LayoutManager manager)
设置 LayoutManager。
 void AbstractButton.setLayout(LayoutManager mgr)
为此容器设置布局管理器，有关此方法的完整描述，请参阅 Container.setLayout(LayoutManager)。
 void JInternalFrame.setLayout(LayoutManager manager)
确保默认情况下无法设置此组件的布局。
 void JFrame.setLayout(LayoutManager manager)
设置 LayoutManager。

参数类型为 LayoutManager 的 javax.swing 中的构造方法
JPanel(LayoutManager layout)
创建具有指定布局管理器的新缓冲 JPanel。
JPanel(LayoutManager layout, boolean isDoubleBuffered)
创建具有指定布局管理器和缓冲策略的新 JPanel。

javax.swing.plaf.basic 中 LayoutManager 的使用

实现 LayoutManager 的 javax.swing.plaf.basic 中的类
class | BasicComboBoxUI.ComboBoxLayoutManager 此布局管理器处理组合框的“标准”布局。
class | BasicInternalFrameTitlePane.TitlePaneLayout 此类应视为“受保护”内部类。
class | BasicInternalFrameUI.InternalFrameLayout
static class | BasicOptionPaneUI.ButtonAreaLayout ButtonAreaLayout 的行为方式类似于 FlowLayout。
class | BasicScrollBarUI 基本外观的 ScrollBarUI 的实现
protected class | BasicSplitPaneDivider.DividerLayout 用于布置 BasicSplitPaneDivider。
class | BasicSplitPaneUI.BasicHorizontalLayoutManager 具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。
class | BasicSplitPaneUI.BasicVerticalLayoutManager 用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。
class | BasicTabbedPaneUI.TabbedPaneLayout 此类应视为“受保护”内部类。
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

声明为 LayoutManager 的 javax.swing.plaf.basic 中的字段
protected  LayoutManager BasicInternalFrameUI.internalFrameLayout

返回 LayoutManager 的 javax.swing.plaf.basic 中的方法
protected LayoutManager | BasicInternalFrameTitlePane.createLayout()
protected LayoutManager | BasicSpinnerUI.createLayout() 创建管理 JSpinner 的 editor、nextButton 和 previousButton 子级的 LayoutManager。
protected LayoutManager | BasicInternalFrameUI.createLayoutManager()
protected LayoutManager | BasicOptionPaneUI.createLayoutManager()
protected LayoutManager | BasicTabbedPaneUI.createLayoutManager() 由 installUI 调用，用于创建布局管理器对象以管理 JTabbedPane。
protected LayoutManager | BasicComboBoxUI.createLayoutManager() 创建用于管理构成组合框的组件的布局管理器。

javax.swing.plaf.metal 中 LayoutManager 的使用

实现 LayoutManager 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxUI.MetalComboBoxLayoutManager 此内部类因编译器故障而被标记为 "public"。
class | MetalScrollBarUI ScrollBarUI 的 Metal 外观实现
class | MetalTabbedPaneUI.TabbedPaneLayout 此内部类由于编译器故障而被标记为 "public"。

返回 LayoutManager 的 javax.swing.plaf.metal 中的方法
protected LayoutManager | MetalInternalFrameTitlePane.createLayout()
protected LayoutManager | MetalTabbedPaneUI.createLayoutManager()
protected LayoutManager | MetalComboBoxUI.createLayoutManager()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.AWTEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.AWTEvent
的使用

使用 AWTEvent 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing.event | 供 Swing 组件触发的事件使用。

java.awt 中 AWTEvent 的使用

返回 AWTEvent 的 java.awt 中的方法
protected AWTEvent | Component.coalesceEvents(AWTEvent existingEvent, AWTEvent newEvent) 将正发送的事件与现有事件组合在一起。
static AWTEvent | EventQueue.getCurrentEvent() 返回当前正在被 EventQueue（它与正在调用的线程相关）指派的事件。
AWTEvent | EventQueue.getNextEvent() 从 EventQueue 中移除一个事件，并返回该事件。
AWTEvent | EventQueue.peekEvent() 返回 EventQueue 上的第一个事件，而不移除它。
AWTEvent | EventQueue.peekEvent(int id) 返回指定 id（如果有） 的第一个事件。

参数类型为 AWTEvent 的 java.awt 中的方法
protected AWTEvent | Component.coalesceEvents(AWTEvent existingEvent, AWTEvent newEvent) 将正发送的事件与现有事件组合在一起。
void | MenuComponent.dispatchEvent(AWTEvent e) 将事件传递给此组件或其子组件之一。
boolean | DefaultKeyboardFocusManager.dispatchEvent(AWTEvent e) 此方法由 AWT 事件调度程序调用，该调度程序请求当前的 KeyboardFocusManager 以它的名义指派指定的事件。
abstract boolean | KeyboardFocusManager.dispatchEvent(AWTEvent e) AWT 事件调度程序可以调用此方法，请求当前的 KeyboardFocusManager 为其指派指定的事件。
protected void | EventQueue.dispatchEvent(AWTEvent event) 指派一个事件。
void | Component.dispatchEvent(AWTEvent e) 为组件或其子组件之一指派事件。
void | EventQueue.postEvent(AWTEvent theEvent) 将一个 1.1 样式的事件发送到 EventQueue 中。
protected void | Button.processEvent(AWTEvent e) 处理此按钮上的事件。
protected void | Checkbox.processEvent(AWTEvent e) 处理关于此复选框的事件。
protected void | CheckboxMenuItem.processEvent(AWTEvent e) 处理此复选框菜单项上的事件。
protected void | Choice.processEvent(AWTEvent e) 处理关于此选择的事件。
protected void | List.processEvent(AWTEvent e) 此滚动列表的进程事件。
protected void | Scrollbar.processEvent(AWTEvent e) 处理在滚动条上发生的事件。
protected void | TextComponent.processEvent(AWTEvent e) 处理此文本组件上发生的事件。
protected void | TextField.processEvent(AWTEvent e) 处理此文本字段上的事件。
protected void | MenuItem.processEvent(AWTEvent e) 处理此菜单项上的事件。
protected void | MenuComponent.processEvent(AWTEvent e) 处理发生在此菜单组件上的事件。
protected void | Window.processEvent(AWTEvent e) 处理此窗口上的事件。
protected void | Container.processEvent(AWTEvent e) 处理关于此容器的事件。
protected void | Component.processEvent(AWTEvent e) 处理组件上发生的事件。
void | KeyboardFocusManager.redispatchEvent(Component target, AWTEvent e) 重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。

java.awt.event 中 AWTEvent 的使用

java.awt.event 中 AWTEvent 的子类
class | ActionEvent 指示发生了组件定义的动作的语义事件。
class | AdjustmentEvent 由 Adjustable 对象所发出的调整事件。
class | ComponentEvent 指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | HierarchyEvent 指示 Component 所属的 Component 层次结构发生更改的事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | InputMethodEvent 输入方法事件包含有关使用输入方法进行撰写的文本的信息。
class | InvocationEvent 当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
class | ItemEvent 指示项被选定或取消选定的语义事件。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | TextEvent 指示对象文本已改变的语义事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

参数类型为 AWTEvent 的 java.awt.event 中的方法
void | AWTEventListenerProxy.eventDispatched(AWTEvent evt) 将属性更改事件转发给侦听器代理。
void | AWTEventListener.eventDispatched(AWTEvent event) 在 AWT 中指派事件时调用。

java.awt.im 中 AWTEvent 的使用

参数类型为 AWTEvent 的 java.awt.im 中的方法
 void InputContext.dispatchEvent(AWTEvent event)
将事件指派到处于活动状态的输入方法。

java.awt.im.spi 中 AWTEvent 的使用

参数类型为 AWTEvent 的 java.awt.im.spi 中的方法
 void InputMethod.dispatchEvent(AWTEvent event)
将事件指派到输入方法。

javax.swing.event 中 AWTEvent 的使用

javax.swing.event 中 AWTEvent 的子类
class | AncestorEvent 报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
class | InternalFrameEvent 以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Toolkit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Toolkit
的使用

使用 Toolkit 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Toolkit 的使用

返回 Toolkit 的 java.awt 中的方法
static Toolkit | Toolkit.getDefaultToolkit() 获取默认工具包。
Toolkit | Window.getToolkit() 返回此窗体的工具包。
Toolkit | Component.getToolkit() 获取此组件的工具包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.GraphicsEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.GraphicsEnvironment
的使用

使用 GraphicsEnvironment 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 GraphicsEnvironment 的使用

返回 GraphicsEnvironment 的 java.awt 中的方法
static GraphicsEnvironment GraphicsEnvironment.getLocalGraphicsEnvironment()
返回本地 GraphicsEnvironment。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Label 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Label
的使用

使用 Label 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 Label 的使用

参数类型为 Label 的 java.awt 中的方法
protected abstract  java.awt.peer.LabelPeer Toolkit.createLabel(Label target)
使用指定同位体接口创建此工具包的 Label 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Label.AccessibleAWTLabel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Label.AccessibleAWTLabel
的使用

没有 java.awt.Label.AccessibleAWTLabel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Frame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Frame
的使用

使用 Frame 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Frame 的使用

返回 Frame 的 java.awt 中的方法
static Frame[] Frame.getFrames()
返回一个此应用程序创建的所有 Frame 所组成的数组。

参数类型为 Frame 的 java.awt 中的方法
protected abstract java.awt.peer.FramePeer | Toolkit.createFrame(Frame target) 使用指定同位体接口创建此工具包的 Frame 实现。
PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。
abstract PrintJob | Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props) 获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

参数类型为 Frame 的 java.awt 中的构造方法
Dialog(Frame owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Frame 和一个空标题。
Dialog(Frame owner, boolean modal)
构造一个最初不可见的 Dialog，它带有指定所有者 Frame、模式和一个空标题。
Dialog(Frame owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。
Dialog(Frame owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。
Dialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。
FileDialog(Frame parent)
创建一个文件对话框，用于加载文件。
FileDialog(Frame parent, String title)
创建一个具有指定标题的文件对话框窗口，用于加载文件。
FileDialog(Frame parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。
Window(Frame owner)
构造一个新的、最初不可见的窗口，使用指定的 Frame 作为其所有者。

javax.swing 中 Frame 的使用

javax.swing 中 Frame 的子类
 class JFrame
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。

返回 Frame 的 javax.swing 中的方法
static Frame | JOptionPane.getFrameForComponent(Component parentComponent) 返回指定组件的 Frame。
static Frame | JOptionPane.getRootFrame() 返回用于不提供窗体的类方法中的 Frame。

参数类型为 Frame 的 javax.swing 中的方法
static void JOptionPane.setRootFrame(Frame newRootFrame)
设置窗体，以用于不提供窗体的类方法。

参数类型为 Frame 的 javax.swing 中的构造方法
JDialog(Frame owner)
创建一个没有标题但将指定的 Frame 作为其所有者的无模式对话框。
JDialog(Frame owner, boolean modal)
创建一个具有指定所有者 Frame、模式和空标题的对话框。
JDialog(Frame owner, String title)
创建一个具有指定标题和指定所有者窗体的无模式对话框。
JDialog(Frame owner, String title, boolean modal)
创建一个具有指定标题、所有者 Frame 和模式的对话框。
JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。
JWindow(Frame owner)
使用指定的所有者框架创建窗口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Frame.AccessibleAWTFrame 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Frame.AccessibleAWTFrame
的使用

使用 Frame.AccessibleAWTFrame 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 Frame.AccessibleAWTFrame 的使用

javax.swing 中 Frame.AccessibleAWTFrame 的子类
protected  class JFrame.AccessibleJFrame
此类实现对 JFrame 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Window 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Window
的使用

使用 Window 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 Window 的使用

java.awt 中 Window 的子类
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。

返回 Window 的 java.awt 中的方法
Window | KeyboardFocusManager.getActiveWindow() 如果活动 Window 与调用线程位于同一个上下文中，则返回活动 Window。
Window | KeyboardFocusManager.getFocusedWindow() 如果聚焦窗口与调用线程位于同一个上下文中，则返回聚焦窗口。
Window | GraphicsDevice.getFullScreenWindow() 如果设备处于全屏模式，则返回表示全屏窗口的 Window 对象。
protected Window | KeyboardFocusManager.getGlobalActiveWindow() 返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。
protected Window | KeyboardFocusManager.getGlobalFocusedWindow() 返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。
Window[] | Window.getOwnedWindows() 返回包含此窗口当前拥有的所有窗口的数组。
Window | Window.getOwner() 返回此窗口的所有者。
static Window[] | Window.getOwnerlessWindows() 返回一个数组，该数组由此应用程序创建的所有没有所有者的 Window 组成。
static Window[] | Window.getWindows() 返回一个数组，该数组由此应用程序创建的所有 Window（包括被拥有的和不被拥有的）组成。

参数类型为 Window 的 java.awt 中的方法
protected abstract java.awt.peer.WindowPeer | Toolkit.createWindow(Window target) 使用指定同位体接口创建此工具包的 Window 实现。
Component | FocusTraversalPolicy.getInitialComponent(Window window) 返回第一次将窗口设置为可见时，应该接收焦点的 Component。
void | GraphicsDevice.setFullScreenWindow(Window w) 进入全屏模式，或返回窗口化模式。
protected void | KeyboardFocusManager.setGlobalActiveWindow(Window activeWindow) 设置活动 Window。
protected void | KeyboardFocusManager.setGlobalFocusedWindow(Window focusedWindow) 设置聚焦 Window。

参数类型为 Window 的 java.awt 中的构造方法
Dialog(Window owner)
构造一个最初不可见的、无模式的 Dialog，它带有指定所有者 Window 和一个空标题。
Dialog(Window owner, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定所有者 Window、模式和一个空标题。
Dialog(Window owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。
Dialog(Window owner, String title, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。
Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。
Window(Window owner)
构造一个新的、最初不可见的窗口，使用指定 Window 作为其所有者。
Window(Window owner, GraphicsConfiguration gc)
构造一个新的、最初不可见的窗口，使用指定的所有者 Window 和屏幕设备的 GraphicsConfiguration。

java.awt.event 中 Window 的使用

返回 Window 的 java.awt.event 中的方法
Window | WindowEvent.getOppositeWindow() 返回在此焦点或活动性变化中所涉及的其他 Window。
Window | WindowEvent.getWindow() 返回事件的发起方。

参数类型为 Window 的 java.awt.event 中的构造方法
WindowEvent(Window source, int id)
构造一个 WindowEvent 对象。
WindowEvent(Window source, int id, int oldState, int newState)
构造一个具有指定的以前和新窗口状态的 WindowEvent 对象。
WindowEvent(Window source, int id, Window opposite)
构造一个具有指定对应 Window 的 WindowEvent 对象。
WindowEvent(Window source, int id, Window opposite, int oldState, int newState)
构造一个 WindowEvent 对象。

java.awt.im.spi 中 Window 的使用

返回 Window 的 java.awt.im.spi 中的方法
 Window InputMethodContext.createInputMethodWindow(String title, boolean attachToInputContext)
创建输入方法使用的顶层窗口。

javax.swing 中 Window 的使用

javax.swing 中 Window 的子类
class | JDialog 创建对话框窗口的主要类。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

返回 Window 的 javax.swing 中的方法
static Window | SwingUtilities.getWindowAncestor(Component c) 返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
static Window | SwingUtilities.windowForComponent(Component c) 返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。

参数类型为 Window 的 javax.swing 中的方法
 void RepaintManager.addDirtyRegion(Window window, int x, int y, int w, int h)
将 window 添加到需要重绘的 Component 列表。

参数类型为 Window 的 javax.swing 中的构造方法
JDialog(Window owner)
创建一个具有指定所有者 Window 和空标题的无模式对话框。
JDialog(Window owner, Dialog.ModalityType modalityType)
创建一个具有指定所有者 Window、模式和空标题的对话框。
JDialog(Window owner, String title)
创建一个具有指定标题和所有者 Window 的无模式对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。
JWindow(Window owner)
使用指定的所有者窗口创建窗口。
JWindow(Window owner, GraphicsConfiguration gc)
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。

javax.swing.plaf.basic 中 Window 的使用

javax.swing.plaf.basic 中 Window 的子类
protected  class BasicToolBarUI.DragWindow

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Window.AccessibleAWTWindow 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Window.AccessibleAWTWindow
的使用

使用 Window.AccessibleAWTWindow 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Window.AccessibleAWTWindow 的使用

java.awt 中 Window.AccessibleAWTWindow 的子类
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。

javax.swing 中 Window.AccessibleAWTWindow 的使用

javax.swing 中 Window.AccessibleAWTWindow 的子类
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Container 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Container
的使用

使用 Container 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Container 的使用

java.applet 中 Container 的子类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Container 的使用

java.awt 中 Container 的子类
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Panel Panel 是最简单的容器类。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

返回 Container 的 java.awt 中的方法
Container | KeyboardFocusManager.getCurrentFocusCycleRoot() 如果当前焦点循环根与调用线程位于相同的上下文中，则返回当前焦点循环根。
Container | Window.getFocusCycleRootAncestor() 始终返回 null，因为窗口没有祖先；它们表示组件层次结构的顶层。
Container | Component.getFocusCycleRootAncestor() 返回作为此 Component 焦点遍历循环的焦点循环根的 Container。
protected Container | KeyboardFocusManager.getGlobalCurrentFocusCycleRoot() 返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。
protected static Container | Toolkit.getNativeContainer(Component c) 使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。
Container | Component.getParent() 获取此组件的父级。

参数类型为 Container 的 java.awt 中的方法
protected void | GridBagLayout.arrangeGrid(Container parent) 布置网格。
protected void | GridBagLayout.ArrangeGrid(Container parent) 此方法已过时，仅为提供向后兼容性；新代码应该调用 arrangeGrid 来代替。
void | DefaultKeyboardFocusManager.downFocusCycle(Container aContainer) 将焦点下移一个焦点遍历循环。
abstract void | KeyboardFocusManager.downFocusCycle(Container aContainer) 将焦点下移一个焦点遍历循环。
void | CardLayout.first(Container parent) 翻转到容器的第一张卡片。
Component | ContainerOrderFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent) 返回应该接收 aComponent 后面的焦点的 Component。
abstract Component | FocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent) 返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
Component | ContainerOrderFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent) 返回应该接收 aComponent 前面的焦点的 Component。
abstract Component | FocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent) 返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
Component | ContainerOrderFocusTraversalPolicy.getDefaultComponent(Container aContainer) 返回默认拥有焦点的 Component。
abstract Component | FocusTraversalPolicy.getDefaultComponent(Container aContainer) 返回要聚焦的默认 Component。
Component | ContainerOrderFocusTraversalPolicy.getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
abstract Component | FocusTraversalPolicy.getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
Component | ContainerOrderFocusTraversalPolicy.getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
abstract Component | FocusTraversalPolicy.getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
float | GridBagLayout.getLayoutAlignmentX(Container parent) 返回沿 X 轴的对齐方式。
float | CardLayout.getLayoutAlignmentX(Container parent) 返回沿 x 轴的对齐方式。
float | BorderLayout.getLayoutAlignmentX(Container parent) 返回沿 x 轴的对齐方式。
float | LayoutManager2.getLayoutAlignmentX(Container target) 返回沿 X 轴的对齐方式。
float | GridBagLayout.getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
float | CardLayout.getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
float | BorderLayout.getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
float | LayoutManager2.getLayoutAlignmentY(Container target) 返回沿 Y 轴的对齐方式。
Component | BorderLayout.getLayoutComponent(Container target, Object constraints) 基于目标 Container 的组件方向，返回给定约束位置对应的组件。
protected GridBagLayoutInfo | GridBagLayout.getLayoutInfo(Container parent, int sizeflag) 为当前受管子级的集合填充 GridBagLayoutInfo 的实例。
protected GridBagLayoutInfo | GridBagLayout.GetLayoutInfo(Container parent, int sizeflag) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getLayoutInfo 来代替。
protected Dimension | GridBagLayout.getMinSize(Container parent, GridBagLayoutInfo info) 基于 getLayoutInfo 中的信息计算其所有者的最小大小。
protected Dimension | GridBagLayout.GetMinSize(Container parent, GridBagLayoutInfo info) 此方法已过时，仅为提供向后兼容性；新代码应该调用 getMinSize 来代替。
void | GridBagLayout.invalidateLayout(Container target) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | CardLayout.invalidateLayout(Container target) 使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | BorderLayout.invalidateLayout(Container target) 使布局无效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | LayoutManager2.invalidateLayout(Container target) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
boolean | Container.isFocusCycleRoot(Container container) 返回指定的 Container 是否是此 Container 的焦点遍历循环的焦点循环根。
boolean | Component.isFocusCycleRoot(Container container) 返回指定的 Container 是否为此 Component 焦点遍历循环的焦点循环根。
void | CardLayout.last(Container parent) 翻转到容器的最后一张卡片。
void | GridBagLayout.layoutContainer(Container parent) 使用此网格包布局布置指定容器。
void | GridLayout.layoutContainer(Container parent) 使用此布局布置指定容器。
void | CardLayout.layoutContainer(Container parent) 使用此卡片布局布置指定的容器。
void | FlowLayout.layoutContainer(Container target) 布置该容器。
void | BorderLayout.layoutContainer(Container target) 使用此边框布局对容器参数进行布局。
void | LayoutManager.layoutContainer(Container parent) 布置指定容器。
Dimension | GridBagLayout.maximumLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的最大维数
Dimension | CardLayout.maximumLayoutSize(Container target) 给出指定目标容器中的组件，返回此布局的最大尺寸。
Dimension | BorderLayout.maximumLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的最大尺寸。
Dimension | LayoutManager2.maximumLayoutSize(Container target) 给定指定容器的组件，计算该容器的最大大小维数。
Dimension | GridBagLayout.minimumLayoutSize(Container parent) 使用此网格包布局确定 parent 容器的最小大小。
Dimension | GridLayout.minimumLayoutSize(Container parent) 使用此网络布局确定最小大小的容器参数。
Dimension | CardLayout.minimumLayoutSize(Container parent) 计算指定面板大小的最小值。
Dimension | FlowLayout.minimumLayoutSize(Container target) 返回需要布置 visible 组件的最小维数，该组件包含在指定的目标容器中。
Dimension | BorderLayout.minimumLayoutSize(Container target) 使用此布局管理器确定 target 容器的最小大小。
Dimension | LayoutManager.minimumLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的最小大小维数。
void | CardLayout.next(Container parent) 翻转到指定容器的下一张卡片。
Dimension | GridBagLayout.preferredLayoutSize(Container parent) 使用此网络包布局确定 parent 容器的首选大小。
Dimension | GridLayout.preferredLayoutSize(Container parent) 使用此网格布局确定容器参数的首选大小。
Dimension | CardLayout.preferredLayoutSize(Container parent) 使用此卡片布局确定容器参数的首选大小。
Dimension | FlowLayout.preferredLayoutSize(Container target) 给出指定目标容器中的 visible 组件，返回此布局的首选维数。
Dimension | BorderLayout.preferredLayoutSize(Container target) 基于容器中的组件，使用此布局管理器确定 target 容器的首选大小。
Dimension | LayoutManager.preferredLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | CardLayout.previous(Container parent) 翻转到指定容器的前一张卡片。
void | KeyboardFocusManager.setGlobalCurrentFocusCycleRoot(Container newFocusCycleRoot) 设置当前焦点循环根。
void | CardLayout.show(Container parent, String name) 翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。

java.awt.event 中 Container 的使用

返回 Container 的 java.awt.event 中的方法
 Container HierarchyEvent.getChangedParent()
返回由 getChanged() 返回的 Component 的父级。
 Container ContainerEvent.getContainer()
返回事件的始发者。

参数类型为 Container 的 java.awt.event 中的构造方法
HierarchyEvent(Component source, int id, Component changed, Container changedParent)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyEvent(Component source, int id, Component changed, Container changedParent, long changeFlags)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。

java.beans.beancontext 中 Container 的使用

返回 Container 的 java.beans.beancontext 中的方法
 Container BeanContextContainerProxy.getContainer()
获得与此 BeanContext 相关联的 java.awt.Container。

javax.swing 中 Container 的使用

javax.swing 中 Container 的子类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

声明为 Container 的 javax.swing 中的字段
protected  Container JRootPane.contentPane
内容窗格。

返回 Container 的 javax.swing 中的方法
protected Container | JRootPane.createContentPane() 由构造方法调用以便创建默认的 contentPane。
static Container | SwingUtilities.getAncestorNamed(String name, Component comp) 在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。
static Container | SwingUtilities.getAncestorOfClass(Class<?> c, Component comp) 在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
Container | JApplet.getContentPane() 返回此 applet 的 contentPane 对象。
Container | JWindow.getContentPane() 返回作为此窗口的 contentPane 的 Container。
Container | JDialog.getContentPane() 返回此对话框的 contentPane 对象。
Container | JInternalFrame.getContentPane() 返回此内部窗体的内容窗格。
Container | JRootPane.getContentPane() 返回内容窗格，它是保存以根窗格为父级的组件的容器。
Container | JFrame.getContentPane() 返回此窗体的 contentPane 对象
Container | RootPaneContainer.getContentPane() 返回 contentPane。
Container | JInternalFrame.getFocusCycleRootAncestor() 始终返回 null，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
Container | OverlayLayout.getTarget() 返回使用此布局管理器的容器。
Container | BoxLayout.getTarget() 返回使用此布局管理器的容器。
Container | JComponent.getTopLevelAncestor() 返回此组件的顶层祖先（包含的 Window 或 Applet）；如果尚未将此组件添加到任意容器中，则返回 null。

参数类型为 Container 的 javax.swing 中的方法
 Component DefaultFocusManager.getComponentAfter(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应在 aComponent 之后接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
 Component DefaultFocusManager.getComponentBefore(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应在 aComponent 之前接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
abstract  int LayoutStyle.getContainerGap(JComponent component, int position, Container parent)
返回组件与其父容器的指定边缘之间放置的空格数量。
 Component SortingFocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。
 Component DefaultFocusManager.getFirstComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component SortingFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component DefaultFocusManager.getLastComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component SortingFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 float GroupLayout.getLayoutAlignmentX(Container parent)
返回沿 x 轴的对齐方式。
 float OverlayLayout.getLayoutAlignmentX(Container target)
返回容器沿 X 轴的对齐方式。
 float SpringLayout.getLayoutAlignmentX(Container p)
返回 0.5f（居中）。
 float BoxLayout.getLayoutAlignmentX(Container target)
返回容器沿 X 轴的对齐方式。
 float JRootPane.RootLayout.getLayoutAlignmentX(Container target)
 float GroupLayout.getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。
 float OverlayLayout.getLayoutAlignmentY(Container target)
返回容器沿 Y 轴的对齐方式。
 float SpringLayout.getLayoutAlignmentY(Container p)
返回 0.5f（居中）。
 float BoxLayout.getLayoutAlignmentY(Container target)
返回容器沿 Y 轴的对齐方式。
 float JRootPane.RootLayout.getLayoutAlignmentY(Container target)
abstract  int LayoutStyle.getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent)
返回两个组件之间使用的空格的数量。
 void GroupLayout.invalidateLayout(Container parent)
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
 void OverlayLayout.invalidateLayout(Container target)
指示子容器已更改其布局相关信息，这会导致刷新所有缓存计算。
 void SpringLayout.invalidateLayout(Container p)
 void BoxLayout.invalidateLayout(Container target)
指示一个子容器已经更改其布局相关信息，因此应该刷新所有已缓存的计算结果。
 void JRootPane.RootLayout.invalidateLayout(Container target)
 void GroupLayout.layoutContainer(Container parent)
布置指定的容器。
 void JSpinner.DefaultEditor.layoutContainer(Container parent)
调整一个（并且是唯一）子级的大小，以完全填充父 insets 中的区域。
 void OverlayLayout.layoutContainer(Container target)
当需要布置指定的容器时，由 AWT 调用。
 void SpringLayout.layoutContainer(Container parent)
 void ViewportLayout.layoutContainer(Container parent)
在需要布置指定容器时由 AWT 调用。
 void ScrollPaneLayout.layoutContainer(Container parent)
布置滚动窗格。
 void BoxLayout.layoutContainer(Container target)
在需要布置指定容器时，由 AWT 调用 。
 void JRootPane.RootLayout.layoutContainer(Container parent)
指示布局管理器为指定的容器执行布局。
 Dimension GroupLayout.maximumLayoutSize(Container parent)
返回指定容器的最大大小。
 Dimension OverlayLayout.maximumLayoutSize(Container target)
返回需要布置组件的最大维数，该组件包含在指定的目标容器中。
 Dimension SpringLayout.maximumLayoutSize(Container parent)
 Dimension BoxLayout.maximumLayoutSize(Container target)
返回目标容器布置其所包含的组件时可使用的最大尺寸。
 Dimension JRootPane.RootLayout.maximumLayoutSize(Container target)
返回布局能够使用的最大空间量。
 Dimension GroupLayout.minimumLayoutSize(Container parent)
返回指定容器的最小大小。
 Dimension JSpinner.DefaultEditor.minimumLayoutSize(Container parent)
返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。
 Dimension OverlayLayout.minimumLayoutSize(Container target)
返回需要布置组件的最小维数，该组件包含在指定的目标容器中。
 Dimension SpringLayout.minimumLayoutSize(Container parent)
 Dimension ViewportLayout.minimumLayoutSize(Container parent)
返回需要布置指定目标容器中包含的组件的最小维数。
 Dimension ScrollPaneLayout.minimumLayoutSize(Container parent)
ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。
 Dimension BoxLayout.minimumLayoutSize(Container target)
返回布置包含在指定目标容器中的组件所需的最小尺寸。
 Dimension JRootPane.RootLayout.minimumLayoutSize(Container parent)
返回布局需要的最小空间量。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
在指定的 Graphics 上绘制组件。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 Dimension GroupLayout.preferredLayoutSize(Container parent)
返回指定容器的首选大小。
 Dimension JSpinner.DefaultEditor.preferredLayoutSize(Container parent)
返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。
 Dimension OverlayLayout.preferredLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
 Dimension SpringLayout.preferredLayoutSize(Container parent)
 Dimension ViewportLayout.preferredLayoutSize(Container parent)
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
 Dimension ScrollPaneLayout.preferredLayoutSize(Container parent)
ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。
 Dimension BoxLayout.preferredLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
 Dimension JRootPane.RootLayout.preferredLayoutSize(Container parent)
返回布局要使用的空间量。
 void JApplet.setContentPane(Container contentPane)
设置 contentPane 属性。
 void JWindow.setContentPane(Container contentPane)
设置此窗口的 contentPane 属性。
 void JDialog.setContentPane(Container contentPane)
设置 contentPane 属性。
 void JInternalFrame.setContentPane(Container c)
设置此 JInternalFrame 的 contentPane 属性。
 void JRootPane.setContentPane(Container content)
设置内容窗格，它是保存以根窗格为父级的组件的容器。
 void JFrame.setContentPane(Container contentPane)
设置 contentPane 属性。
 void RootPaneContainer.setContentPane(Container contentPane)
"contentPane" 是应用程序特定组件的主要容器。

参数类型为 Container 的 javax.swing 中的构造方法
BoxLayout(Container target, int axis)
创建一个将沿给定轴放置组件的布局管理器。
GroupLayout(Container host)
为指定的 Container 创建 GroupLayout。
OverlayLayout(Container target)
构造执行子容器的覆盖安排的布局管理器。

javax.swing.colorchooser 中 Container 的使用

javax.swing.colorchooser 中 Container 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.event 中 Container 的使用

返回 Container 的 javax.swing.event 中的方法
Container | AncestorEvent.getAncestor() 返回实际发生事件的祖先组件。
Container | AncestorEvent.getAncestorParent() 返回实际发生事件的祖先组件的父组件。

参数类型为 Container 的 javax.swing.event 中的构造方法
AncestorEvent(JComponent source, int id, Container ancestor, Container ancestorParent)
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。

javax.swing.plaf.basic 中 Container 的使用

javax.swing.plaf.basic 中 Container 的子类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

返回 Container 的 javax.swing.plaf.basic 中的方法
protected Container | BasicOptionPaneUI.createButtonArea() 创建并返回包含按钮的 Container。
protected Container | BasicOptionPaneUI.createMessageArea() 从 installComponents 获取消息以创建包含消息正文的 Container。
protected Container | BasicOptionPaneUI.createSeparator()

参数类型为 Container 的 javax.swing.plaf.basic 中的方法
protected void | BasicOptionPaneUI.addButtonComponents(Container container, Object[] buttons, int initialIndex) 创建表示 buttons 中每个对象的适当对象并将其添加到 container。
protected void | BasicOptionPaneUI.addIcon(Container top) 创建并添加 JLabel，它表示对 top 调用 getIcon 所返回的图标。
protected void | BasicOptionPaneUI.addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated) 创建表示 msg 的适当对象并将其置于 container 中。
protected void | BasicOptionPaneUI.burstStringInto(Container c, String d, int maxll) 递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。
float | BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentX(Container target) 返回容器沿 X 轴的对齐方式。
float | BasicSplitPaneUI.BasicHorizontalLayoutManager.getLayoutAlignmentY(Container target) 返回容器沿 Y 轴的对齐方式。
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.invalidateLayout(Container c) 不执行任何操作。
void | BasicInternalFrameTitlePane.TitlePaneLayout.layoutContainer(Container c)
void | BasicInternalFrameUI.InternalFrameLayout.layoutContainer(Container c)
void | BasicOptionPaneUI.ButtonAreaLayout.layoutContainer(Container container)
void | BasicSplitPaneDivider.DividerLayout.layoutContainer(Container c)
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.layoutContainer(Container container) 进行实际布局。
void | BasicTabbedPaneUI.TabbedPaneLayout.layoutContainer(Container parent)
void | BasicComboBoxUI.ComboBoxLayoutManager.layoutContainer(Container parent)
void | BasicScrollBarUI.layoutContainer(Container scrollbarContainer)
Dimension | BasicSplitPaneUI.BasicHorizontalLayoutManager.maximumLayoutSize(Container target) 返回最大布局大小，该大小在两个方向上都是 Integer.MAX_VALUE。
Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.minimumLayoutSize(Container c)
Dimension | BasicInternalFrameUI.InternalFrameLayout.minimumLayoutSize(Container c)
Dimension | BasicOptionPaneUI.ButtonAreaLayout.minimumLayoutSize(Container c)
Dimension | BasicSplitPaneDivider.DividerLayout.minimumLayoutSize(Container c)
Dimension | BasicSplitPaneUI.BasicHorizontalLayoutManager.minimumLayoutSize(Container container) 返回包含子级所需的最小大小。
Dimension | BasicTabbedPaneUI.TabbedPaneLayout.minimumLayoutSize(Container parent)
Dimension | BasicComboBoxUI.ComboBoxLayoutManager.minimumLayoutSize(Container parent)
Dimension | BasicScrollBarUI.minimumLayoutSize(Container scrollbarContainer)
Dimension | BasicInternalFrameTitlePane.TitlePaneLayout.preferredLayoutSize(Container c)
Dimension | BasicInternalFrameUI.InternalFrameLayout.preferredLayoutSize(Container c)
Dimension | BasicOptionPaneUI.ButtonAreaLayout.preferredLayoutSize(Container c)
Dimension | BasicSplitPaneDivider.DividerLayout.preferredLayoutSize(Container c)
Dimension | BasicSplitPaneUI.BasicHorizontalLayoutManager.preferredLayoutSize(Container container) 返回包含子级所需的首选大小。
Dimension | BasicTabbedPaneUI.TabbedPaneLayout.preferredLayoutSize(Container parent)
Dimension | BasicComboBoxUI.ComboBoxLayoutManager.preferredLayoutSize(Container parent)
Dimension | BasicScrollBarUI.preferredLayoutSize(Container scrollbarContainer)
Dimension | DefaultMenuLayout.preferredLayoutSize(Container target)

参数类型为 Container 的 javax.swing.plaf.basic 中的构造方法
DefaultMenuLayout(Container target, int axis)

javax.swing.plaf.metal 中 Container 的使用

javax.swing.plaf.metal 中 Container 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

参数类型为 Container 的 javax.swing.plaf.metal 中的方法
void | MetalComboBoxUI.layoutComboBox(Container parent, MetalComboBoxUI.MetalComboBoxLayoutManager manager)
void | MetalComboBoxUI.MetalComboBoxLayoutManager.layoutContainer(Container parent)
void | MetalComboBoxUI.MetalComboBoxLayoutManager.superLayout(Container parent)

javax.swing.table 中 Container 的使用

javax.swing.table 中 Container 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 Container 的使用

javax.swing.text 中 Container 的子类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

返回 Container 的 javax.swing.text 中的方法
 Container View.getContainer()
获取承载视图的容器。

javax.swing.tree 中 Container 的使用

javax.swing.tree 中 Container 的子类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

声明为 Container 的 javax.swing.tree 中的字段
protected  Container DefaultTreeCellEditor.editingContainer
将包含 editorComponent 的编辑容器。

返回 Container 的 javax.swing.tree 中的方法
protected  Container DefaultTreeCellEditor.createContainer()
创建管理 editingComponent 放置的容器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Container.AccessibleAWTContainer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Container.AccessibleAWTContainer
的使用

使用 Container.AccessibleAWTContainer 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 Container.AccessibleAWTContainer 的使用

java.applet 中 Container.AccessibleAWTContainer 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 Container.AccessibleAWTContainer 的使用

java.awt 中 Container.AccessibleAWTContainer 的子类
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

javax.swing 中 Container.AccessibleAWTContainer 的使用

javax.swing 中 Container.AccessibleAWTContainer 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

javax.swing.table 中 Container.AccessibleAWTContainer 的使用

javax.swing.table 中 Container.AccessibleAWTContainer 的子类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 Container.AccessibleAWTContainer 的使用

javax.swing.text 中 Container.AccessibleAWTContainer 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler
的使用

没有 java.awt.Container.AccessibleAWTContainer.AccessibleContainerHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Component 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component
的使用

使用 Component 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Component 的使用

java.applet 中 Component 的子类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Component 的使用

java.awt 中 Component 的子类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
class | Panel Panel 是最简单的容器类。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

类型参数类型为 Component 的 java.awt 中的字段
protected  Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
此哈希表维持组件与其网格包约束之间的关联。

返回 Component 的 java.awt 中的方法
 Component Container.add(Component comp)
将指定组件追加到此容器的尾部。
 Component Container.add(Component comp, int index)
将指定组件添加到此容器的给定位置上。
 Component Container.add(String name, Component comp)
将指定组件添加到此容器中。
 Component Container.findComponentAt(int x, int y)
对包含指定位置的可视子组件进行定位。
 Component Container.findComponentAt(Point p)
对包含指定点的可视子组件进行定位。
 Component Container.getComponent(int n)
获取此容器中的第 n 个组件。
 Component ContainerOrderFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
 Component Container.getComponentAt(int x, int y)
对包含 x，y 位置的组件进行定位。
 Component Component.getComponentAt(int x, int y)
确定此组件或其直接子组件之一是否包含（x，y）位置，并且如果是，则返回包含该位置的组件。
 Component Container.getComponentAt(Point p)
获取包含指定点的组件。
 Component Component.getComponentAt(Point p)
返回包含指定点的组件或子组件。
 Component ContainerOrderFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
 Component[] Container.getComponents()
获取此容器中的所有组件。
 Component ContainerOrderFocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。
abstract  Component FocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回要聚焦的默认 Component。
 Component ContainerOrderFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
abstract  Component FocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component KeyboardFocusManager.getFocusOwner()
如果焦点所有者与调用线程位于同一个上下文中，则返回该焦点所有者。
 Component Window.getFocusOwner()
如果此窗口为焦点窗口，则返回是焦点窗口的子组件；否则返回 null。
protected  Component KeyboardFocusManager.getGlobalFocusOwner()
返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。
protected  Component KeyboardFocusManager.getGlobalPermanentFocusOwner()
返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。
 Component FocusTraversalPolicy.getInitialComponent(Window window)
返回第一次将窗口设置为可见时，应该接收焦点的 Component。
 Component ContainerOrderFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
abstract  Component FocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component BorderLayout.getLayoutComponent(Container target, Object constraints)
基于目标 Container 的组件方向，返回给定约束位置对应的组件。
 Component BorderLayout.getLayoutComponent(Object constraints)
获取使用给定约束添加的组件。
 Component Window.getMostRecentFocusOwner()
返回此窗口的子组件，该子组件在此窗口为焦点窗口时将接收焦点。
 Component KeyboardFocusManager.getPermanentFocusOwner()
如果持久焦点所有者与调用线程位于同一个上下文中，则返回持久焦点所有者。
 Component Container.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
 Component Component.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。

参数类型为 Component 的 java.awt 中的方法
protected  boolean DefaultFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点所有者。
protected  boolean ContainerOrderFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
 Component Container.add(Component comp)
将指定组件追加到此容器的尾部。
 Component Container.add(Component comp, int index)
将指定组件添加到此容器的给定位置上。
 void Container.add(Component comp, Object constraints)
将指定的组件添加到此容器的尾部。
 void Container.add(Component comp, Object constraints, int index)
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。
 Component Container.add(String name, Component comp)
将指定组件添加到此容器中。
protected  void ScrollPane.addImpl(Component comp, Object constraints, int index)
将指定的组件添加到此滚动窗格容器。
protected  void Container.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。
 void GridBagLayout.addLayoutComponent(Component comp, Object constraints)
使用指定 constraints 对象将指定组件添加到布局中。
 void CardLayout.addLayoutComponent(Component comp, Object constraints)
将指定的组件添加到此卡片布局的内部名称表。
 void BorderLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。
 void LayoutManager2.addLayoutComponent(Component comp, Object constraints)
使用指定约束对象，将指定组件添加到布局。
 void GridBagLayout.addLayoutComponent(String name, Component comp)
无效，因为此布局管理器不使用每组件字符串。
 void GridLayout.addLayoutComponent(String name, Component comp)
将具有指定名称的指定组件添加到布局。
 void CardLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 void FlowLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。
 void BorderLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 void LayoutManager.addLayoutComponent(String name, Component comp)
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
protected  java.awt.peer.LightweightPeer Toolkit.createComponent(Component target)
创建组件或容器的同位体。
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。
protected  void DefaultKeyboardFocusManager.dequeueKeyEvents(long after, Component untilFocused)
释放正常指派到当前焦点所有者的所有 KeyEvent，这些 KeyEvent 因为调用了具有相同时间戳和 Component 的 enqueueKeyEvents 而被加入队列。
protected abstract  void KeyboardFocusManager.dequeueKeyEvents(long after, Component untilFocused)
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
protected  void DefaultKeyboardFocusManager.discardKeyEvents(Component comp)
放弃因为一次或多次调用具有指定 Component 或其子代之一的 enqueueKeyEvents 而加入队列的所有 KeyEvent。
protected abstract  void KeyboardFocusManager.discardKeyEvents(Component comp)
由 AWT 调用以通知 KeyboardFocusManager 应该取消延迟指派 KeyEvent。
protected  void DefaultKeyboardFocusManager.enqueueKeyEvents(long after, Component untilFocused)
延迟对 KeyEvent 的指派，直到指定的 Component 成为焦点所有者。
protected abstract  void KeyboardFocusManager.enqueueKeyEvents(long after, Component untilFocused)
在指定的 Component 成为焦点所有者以前由 AWT 调用，以通知 KeyboardFocusManager 延迟指派 KeyEvent。
 void DefaultKeyboardFocusManager.focusNextComponent(Component aComponent)
使 aComponent 后面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
abstract  void KeyboardFocusManager.focusNextComponent(Component aComponent)
聚焦 aComponent 之后的 Component，通常基于 FocusTraversalPolicy。
 void DefaultKeyboardFocusManager.focusPreviousComponent(Component aComponent)
使 aComponent 前面的 Component 拥有焦点，通常基于 FocusTraversalPolicy。
abstract  void KeyboardFocusManager.focusPreviousComponent(Component aComponent)
聚焦 aComponent 之前的 Component，通常基于 FocusTraversalPolicy。
 Component ContainerOrderFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 之后的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或者焦点遍历策略提供者。
 Component ContainerOrderFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
abstract  Component FocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 之前的焦点的 Component，aContainer 必须是 aComponent 的焦点循环根，或焦点遍历策略提供者。
 int Container.getComponentZOrder(Component comp)
返回容器内组件的 z 顺序索引。
 GridBagConstraints GridBagLayout.getConstraints(Component comp)
获取指定组件的约束。
 Object BorderLayout.getConstraints(Component comp)
获取指定组件的约束
protected static Container Toolkit.getNativeContainer(Component c)
使本机同位体能够查询给定本机组件的本机容器（例如，直接父组件可以是轻量级的）。
 boolean Container.isAncestorOf(Component c)
检查该组件是否包含在此容器的组件层次结构中。
protected  GridBagConstraints GridBagLayout.lookupConstraints(Component comp)
检索指定组件的约束。
 void DefaultKeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e)
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法才会启动一个焦点遍历操作。
abstract  void KeyboardFocusManager.processKeyEvent(Component focusedComponent, KeyEvent e)
当且仅当该 KeyEvent 表示指定 focusedComponent 的焦点遍历键时，此方法启动焦点遍历操作。
 void KeyboardFocusManager.redispatchEvent(Component target, AWTEvent e)
重新指派 AWTEvent 的方式是，AWT 事件调度程序不会递归式请求 KeyboardFocusManager 或任何已安装的 KeyEventDispatcher 再次指派该事件。
 void Container.remove(Component comp)
从此容器中移除指定组件。
 void GridBagLayout.removeLayoutComponent(Component comp)
从此布局移除指定组件。
 void GridLayout.removeLayoutComponent(Component comp)
从布局移除指定组件。
 void CardLayout.removeLayoutComponent(Component comp)
从布局中移除指定的组件。
 void FlowLayout.removeLayoutComponent(Component comp)
从布局中移除指定的组件。
 void BorderLayout.removeLayoutComponent(Component comp)
从此边框布局中移除指定组件。
 void LayoutManager.removeLayoutComponent(Component comp)
从布局移除指定组件。
 void Container.setComponentZOrder(Component comp, int index)
将指定组件移动到容器中指定的 z 顺序索引。
 void GridBagLayout.setConstraints(Component comp, GridBagConstraints constraints)
设置此布局中指定组件的约束条件。
protected  void KeyboardFocusManager.setGlobalFocusOwner(Component focusOwner)
设置焦点所有者。
protected  void KeyboardFocusManager.setGlobalPermanentFocusOwner(Component permanentFocusOwner)
设置持久焦点所有者。
 void Window.setLocationRelativeTo(Component c)
设置窗口相对于指定组件的位置。
 void PopupMenu.show(Component origin, int x, int y)
在相对于初始组件的 x、y 位置上显示弹出式菜单。
 void DefaultKeyboardFocusManager.upFocusCycle(Component aComponent)
将焦点上移一个焦点遍历循环。
abstract  void KeyboardFocusManager.upFocusCycle(Component aComponent)
将焦点上移一个焦点遍历循环。

参数类型为 Component 的 java.awt 中的构造方法
MediaTracker(Component comp)
创建媒体跟踪器以跟踪给定组件的图像。

java.awt.dnd 中 Component 的使用

声明为 Component 的 java.awt.dnd 中的字段
protected  Component DragGestureRecognizer.component
与此 DragGestureRecognizer 关联的 Component。

返回 Component 的 java.awt.dnd 中的方法
Component | DragGestureEvent.getComponent() 返回与此 DragGestureEvent 关联的 Component。
Component | DragGestureRecognizer.getComponent() 此方法返回 DragGestureRecognizer 所“观察”的 Component，以便了解拖动开始动作。
Component | DragSourceContext.getComponent() 返回与此 DragSourceContext 关联的 Component。
Component | DropTargetContext.getComponent() 此方法返回与此 DropTargetContext 相关的 Component。
Component | DropTarget.getComponent() 获取与此 DropTarget 关联的 Component。

参数类型为 Component 的 java.awt.dnd 中的方法
 DragGestureRecognizer DragSource.createDefaultDragGestureRecognizer(Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，为此 DragSource 实现 DragGestureRecognizer 的默认抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
protected  DropTarget.DropTargetAutoScroller DropTarget.createDropTargetAutoScroller(Component c, Point p)
创建一个嵌入式自动滚动条
 void DragGestureRecognizer.setComponent(Component c)
设置与该 DragGestureRecognizer 关联的 Component 使用此方法时还会调用 registerListeners() 和 unregisterListeners()。
 void DropTarget.setComponent(Component c)
注意：要求此接口允许 DropTarget 以下面两种方式之一与 Component 安全关联：component.setDropTarget(droptarget) 或 droptarget.setComponent(component)。

参数类型为 Component 的 java.awt.dnd 中的构造方法
DragGestureRecognizer(DragSource ds, Component c)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource 和此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component。
DragGestureRecognizer(DragSource ds, Component c, int sa)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component 和此 Drag 和 Drop 操作所支持的动作。
DragGestureRecognizer(DragSource ds, Component c, int sa, DragGestureListener dgl)
构造一个新的 DragGestureRecognizer，使其具有给定此 Drag 和 Drop 操作中使用的 DragSource、此 DragGestureRecognizer 应该“观察”拖动开始动作的 Component、此 Drag 和 Drop 操作所支持的操作和一旦检测到拖动开始动作要通知的 DragGestureListener。
DropTarget.DropTargetAutoScroller(Component c, Point p)
构造一个 DropTargetAutoScroller
DropTarget(Component c, DropTargetListener dtl)
在给出与之关联的 Component 和执行事件处理的 DropTargetListener 的情况下创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值和执行事件处理的 DropTargetListener 的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act)
在给出与之关联的 Component、表示支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener 和表示 DropTarget 当前是否接受 drop 的 boolean 值的情况下，创建一个 DropTarget。
DropTarget(Component c, int ops, DropTargetListener dtl, boolean act, FlavorMap fm)
在给出与之关联的 Component、表示要支持的默认可接受操作的 int 值、执行事件处理的 DropTargetListener、表示 DropTarget 当前是否接受 drop 的 boolean 值和要使用的 FlavorMap（使用默认 FlavorMap 时为 null）的情况下，创建一个新的 DropTarget。
MouseDragGestureRecognizer(DragSource ds, Component c)
给出 Component c 的 DragSource、要观察的 Component，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act)
给出 Component c 的 DragSource、要观察的 Component，以及此拖动操作允许的操作，构造一个新的 MouseDragGestureRecognizer。
MouseDragGestureRecognizer(DragSource ds, Component c, int act, DragGestureListener dgl)
给出 Component c 的 DragSource、要观察的 Component、此拖动操作允许的操作，以及检测到拖动动作时发出通知的 DragGestureListener，构造一个新的 MouseDragGestureRecognizer。

java.awt.event 中 Component 的使用

返回 Component 的 java.awt.event 中的方法
Component | HierarchyEvent.getChanged() 返回位于被更改层次结构顶部的 Component。
Component | ContainerEvent.getChild() 返回受事件影响的组件。
Component | HierarchyEvent.getComponent() 返回事件的始发者。
Component | ComponentEvent.getComponent() 返回事件的始发者。
Component | FocusEvent.getOppositeComponent() 返回此焦点更改中涉及的另一个 Component。

参数类型为 Component 的 java.awt.event 中的构造方法
ComponentEvent(Component source, int id)
构造一个 ComponentEvent 对象。
ContainerEvent(Component source, int id, Component child)
构造一个 ContainerEvent 对象。
FocusEvent(Component source, int id)
构造一个 FocusEvent 对象，并将它标识为一个持久性焦点更改。
FocusEvent(Component source, int id, boolean temporary)
构造一个 FocusEvent 对象，并将标识更改是否为暂时的。
FocusEvent(Component source, int id, boolean temporary, Component opposite)
构造一个 FocusEvent 对象，它具有指定的暂时状态和对立 Component。
HierarchyEvent(Component source, int id, Component changed, Container changedParent)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
HierarchyEvent(Component source, int id, Component changed, Container changedParent, long changeFlags)
构造一个 HierarchyEvent 对象来标识 Component 层次结构中的更改。
InputMethodEvent(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、插入符和 visiblePosition 来构造 InputMethodEvent。
KeyEvent(Component source, int id, long when, int modifiers, int keyCode)
已过时。 从 JDK1.1 开始
KeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar)
构造一个 KeyEvent 对象。
KeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, int keyLocation)
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int button)
构造一个具有指定源组件、类型、修饰符、坐标和单击计数的 MouseEvent 对象。
MouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int button)
构造一个具有指定源组件、类型、修饰符、相对坐标、绝对坐标和单击计数的 MouseEvent 对象。
MouseWheelEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、滚动类型、滚动量和滚轮旋转的 MouseWheelEvent。
MouseWheelEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, int scrollType, int scrollAmount, int wheelRotation)
构造一个具有指定源组件、类型、修改键、坐标、绝对坐标、滚动类型、滚动量和滚轮滚动的 MouseWheelEvent 对象。
PaintEvent(Component source, int id, Rectangle updateRect)
构造一个具有指定源组件和类型的 PaintEvent 对象。

java.awt.im 中 Component 的使用

参数类型为 Component 的 java.awt.im 中的方法
 void InputContext.removeNotify(Component client)
通知输入上下文，客户端组件已从它的包含层次结构中移除，或该组件已禁用输入方法支持。

java.beans 中 Component 的使用

返回 Component 的 java.beans 中的方法
Component | PropertyEditor.getCustomEditor() PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
Component | PropertyEditorSupport.getCustomEditor() PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。

java.beans.beancontext 中 Component 的使用

返回 Component 的 java.beans.beancontext 中的方法
 Component BeanContextChildComponentProxy.getComponent()
获得与此 BeanContextChild 相关联的 java.awt.Component。

javax.swing 中 Component 的使用

javax.swing 中 Component 的子类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

声明为 Component 的 javax.swing 中的字段
protected static Component | ImageIcon.component
protected Component | JTable.editorComp 在编辑时处理编辑的 Component。
protected Component | JRootPane.glassPane 覆盖菜单栏和内容窗格的玻璃窗格，便于截取鼠标移动等操作。
protected Component | JLabel.labelFor
protected Component | JSplitPane.leftComponent 左边或者顶部的组件。
protected Component | ScrollPaneLayout.lowerLeft 左下角显示的组件。
protected Component | JScrollPane.lowerLeft 在左下角显示的组件。
protected Component | ScrollPaneLayout.lowerRight 右下角显示的组件。
protected Component | JScrollPane.lowerRight 在右下角显示的组件。
protected Component | JSplitPane.rightComponent 右边或者底部的组件。
protected Component | ScrollPaneLayout.upperLeft 左上角显示的组件。
protected Component | JScrollPane.upperLeft 在左上角显示的组件。
protected Component | ScrollPaneLayout.upperRight 右上角显示的组件。
protected Component | JScrollPane.upperRight 在右上角显示的组件。

返回 Component 的 javax.swing 中的方法
 Component JTabbedPane.add(Component component)
添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。
 Component JMenu.add(Component c)
将某个组件追加到此菜单的末尾。
 Component JTabbedPane.add(Component component, int index)
在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。
 Component JMenu.add(Component c, int index)
将指定组件添加到此容器的给定位置上。
 Component JTabbedPane.add(String title, Component component)
添加具有指定选项卡标题的 component。
protected  Component ScrollPaneLayout.addSingletonComponent(Component oldC, Component newC)
移除现有组件。
 Component MenuSelectionManager.componentForPoint(Component source, Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。
protected  Component JRootPane.createGlassPane()
由构造方法调用以便创建默认的 glassPane。
static Component Box.createGlue()
创建一个不可见的 "glue" 组件，其可见组件有一个最大宽度（对于横向 box）或高度（对于纵向 box）的 Box，该组件可能很有用。
static Component Box.createHorizontalGlue()
创建一个横向 glue 组件。
static Component Box.createHorizontalStrut(int width)
创建一个不可见的、固定宽度的组件。
static Component Box.createRigidArea(Dimension d)
创建一个总是具有指定大小的不可见组件。
static Component Box.createVerticalGlue()
创建一个纵向 glue 组件。
static Component Box.createVerticalStrut(int height)
创建一个不可见的、固定高度的组件。
static Component SwingUtilities.findFocusOwner(Component c)
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
 Component JSplitPane.getBottomComponent()
返回分隔条下面或者右边的组件。
 Component Renderer.getComponent()
返回用于呈现该值的组件。
 Component DefaultCellEditor.getComponent()
返回对编辑器组件的引用。
 Component TransferHandler.TransferSupport.getComponent()
返回此传输的目标组件。
 Component JPopupMenu.getComponent()
返回此 JPopupMenu 组件。
 Component JMenuBar.getComponent()
实现为 MenuElement。
 Component JMenu.getComponent()
返回用于绘制此 MenuElement 的 java.awt.Component。
 Component JMenuItem.getComponent()
返回用于绘制此对象的 java.awt.Component。
 Component MenuElement.getComponent()
此方法应返回用于绘制接收元素的 java.awt.Component。
 Component DefaultFocusManager.getComponentAfter(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应在 aComponent 之后接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
 Component JTabbedPane.getComponentAt(int index)
返回 index 位置的组件。
 Component JPopupMenu.getComponentAtIndex(int i)
已过时。 由 Container.getComponent(int) 取代
 Component JMenuBar.getComponentAtIndex(int i)
已过时。 由 getComponent(int i) 取代
 Component JToolBar.getComponentAtIndex(int i)
返回指定索引位置的组件。
 Component DefaultFocusManager.getComponentBefore(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应在 aComponent 之前接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
 Component[] JLayeredPane.getComponentsInLayer(int layer)
返回指定层中组件的数组。
 Component ScrollPaneLayout.getCorner(String key)
返回位于指定角的 Component。
 Component JScrollPane.getCorner(String key)
返回位于指定角的组件。
protected  Component JTable.AccessibleJTable.AccessibleJTableCell.getCurrentComponent()
获取表单元格渲染器组件。
static Component SwingUtilities.getDeepestComponentAt(Component parent, int x, int y)
返回包含位置 x、y 的 parent 的最深可见后代组件。
 Component SortingFocusTraversalPolicy.getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。
 Component JTable.getEditorComponent()
返回处理编辑会话的组件。
 Component ComboBoxEditor.getEditorComponent()
返回应该添加到此编辑器的树层次结构中的组件。
 Component DefaultFocusManager.getFirstComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component SortingFocusTraversalPolicy.getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。
 Component JInternalFrame.getFocusOwner()
如果此 JInternalFrame 处于激活状态，则返回具有焦点的子组件。
 Component JApplet.getGlassPane()
返回此 applet 的 glassPane 对象。
 Component JWindow.getGlassPane()
返回此窗口的 glassPane Component。
 Component JDialog.getGlassPane()
返回此对话框的 glassPane 对象。
 Component JInternalFrame.getGlassPane()
返回此内部窗体的玻璃窗格。
 Component JRootPane.getGlassPane()
返回此 JRootPane 的当前玻璃窗格。
 Component JFrame.getGlassPane()
返回此窗体的 glassPane 对象。
 Component RootPaneContainer.getGlassPane()
返回 glassPane。
 Component InternalFrameFocusTraversalPolicy.getInitialComponent(JInternalFrame frame)
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。
 Component JPopupMenu.getInvoker()
返回作为此弹出菜单的“调用者”的组件。
 Component JLabel.getLabelFor()
获取要添加标签的组件。
 Component DefaultFocusManager.getLastComponent(Container aContainer)
 Component LayoutFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component SortingFocusTraversalPolicy.getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。
 Component JSplitPane.getLeftComponent()
返回分隔条左边（或者上面）的组件。
 Component DefaultListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
 Component ListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
返回已配置用于显示指定值的组件。
 Component JMenu.getMenuComponent(int n)
返回位于位置 n 的组件。
 Component[] JMenu.getMenuComponents()
返回菜单子组件的 Component 数组。
 Component JInternalFrame.getMostRecentFocusOwner()
返回选定此 JInternalFrame 时，将接收焦点的 JInternalFrame 子组件。
 Component JComponent.getNextFocusableComponent()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。
 Component JSplitPane.getRightComponent()
返回分隔条右边（或者下面）的组件。
static Component SwingUtilities.getRoot(Component c)
返回当前组件树结构的根组件。
 Component JTabbedPane.getSelectedComponent()
返回此选项卡窗格当前选择的组件。
 Component JTabbedPane.getTabComponentAt(int index)
返回 index 位置上的选项卡组件。
 Component DefaultCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
实现 TableCellEditor 接口。
 Component JSplitPane.getTopComponent()
返回分隔条上面或者左边的组件。
 Component DefaultCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
实现 TreeCellEditor 接口。
 Component JViewport.getView()
返回 JViewport 的一个子对象或 null。
 Component JTable.prepareEditor(TableCellEditor editor, int row, int column)
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。
 Component JTable.prepareRenderer(TableCellRenderer renderer, int row, int column)
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。

返回变量类型为 Component 的类型的 javax.swing 中的方法
protected Comparator<? super Component> | SortingFocusTraversalPolicy.getComparator() 返回将用于对焦点遍历循环中的 Components 排序的 Comparator。
protected Hashtable<Component,Integer> | JLayeredPane.getComponentToLayer() 返回将组件映射到层的哈希表。

参数类型为 Component 的 javax.swing 中的方法
protected  boolean LayoutFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择指定的 Component 作为新的焦点所有者。
protected  boolean SortingFocusTraversalPolicy.accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点拥有者。
 Component JTabbedPane.add(Component component)
添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。
 Component JMenu.add(Component c)
将某个组件追加到此菜单的末尾。
 Component JTabbedPane.add(Component component, int index)
在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。
 Component JMenu.add(Component c, int index)
将指定组件添加到此容器的给定位置上。
 void JTabbedPane.add(Component component, Object constraints)
将一个 component 添加到选项卡窗格中。
 void JTabbedPane.add(Component component, Object constraints, int index)
在指定的选项卡索引位置添加一个 component。
 Component JTabbedPane.add(String title, Component component)
添加具有指定选项卡标题的 component。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component)
将 Component 添加到此 Group。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(boolean useAsBaseline, Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
 GroupLayout.Group GroupLayout.Group.addComponent(Component component)
将 Component 添加到此 Group。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(Component component)
将 Component 添加到此 Group。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component)
将 Component 添加到此 Group。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment)
使用指定的对齐方式将 Component 添加到此 ParallelGroup。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max)
使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
 GroupLayout.Group GroupLayout.Group.addComponent(Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
 GroupLayout.SequentialGroup GroupLayout.SequentialGroup.addComponent(Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
 GroupLayout.ParallelGroup GroupLayout.ParallelGroup.addComponent(Component component, int min, int pref, int max)
使用指定大小将 Component 添加到此 Group。
protected  void JDesktopPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。
protected  void JApplet.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void JWindow.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void JViewport.addImpl(Component child, Object constraints, int index)
设置 JViewport 的轻量子对象，可以为 null。
protected  void CellRendererPane.addImpl(Component x, Object constraints, int index)
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。
protected  void JSplitPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此分隔窗格。
protected  void JToolBar.addImpl(Component comp, Object constraints, int index)
在添加 JButton 时，它最初被设置为 disabled。
protected  void JDialog.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void AbstractButton.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。
protected  void JInternalFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
protected  void JLayeredPane.addImpl(Component comp, Object constraints, int index)
protected  void JRootPane.addImpl(Component comp, Object constraints, int index)
重写以便将玻璃组件的位置强行设置成零位子级。
protected  void JFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
 void GroupLayout.addLayoutComponent(Component component, Object constraints)
已将 Component 添加到父容器的通知。
 void OverlayLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。
 void SpringLayout.addLayoutComponent(Component component, Object constraints)
如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。
 void BoxLayout.addLayoutComponent(Component comp, Object constraints)
此类不使用。
 void JRootPane.RootLayout.addLayoutComponent(Component comp, Object constraints)
 void GroupLayout.addLayoutComponent(String name, Component component)
已将 Component 添加到父容器的通知。
 void JSpinner.DefaultEditor.addLayoutComponent(String name, Component child)
此 LayoutManager 方法不执行任何操作。
 void OverlayLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。
 void SpringLayout.addLayoutComponent(String name, Component c)
无效，因为此布局管理器不使用每组件字符串。
 void ViewportLayout.addLayoutComponent(String name, Component c)
将指定的组件添加到布局中。
 void ScrollPaneLayout.addLayoutComponent(String s, Component c)
将指定的组件添加到布局中。
 void BoxLayout.addLayoutComponent(String name, Component comp)
此类不使用。
 void JRootPane.RootLayout.addLayoutComponent(String name, Component comp)
protected  Component ScrollPaneLayout.addSingletonComponent(Component oldC, Component newC)
移除现有组件。
 void JTabbedPane.addTab(String title, Component component)
添加一个由 title 表示，且没有图标的 component。
 void JTabbedPane.addTab(String title, Icon icon, Component component)
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。
 void JTabbedPane.addTab(String title, Icon icon, Component component, String tip)
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。
 boolean DefaultFocusManager.compareTabOrder(Component a, Component b)
 Component MenuSelectionManager.componentForPoint(Component source, Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。
static MouseEvent SwingUtilities.convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination)
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。
static Point SwingUtilities.convertPoint(Component source, int x, int y, Component destination)
将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。
static Point SwingUtilities.convertPoint(Component source, Point aPoint, Component destination)
将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
static void SwingUtilities.convertPointFromScreen(Point p, Component c)
将一个点从屏幕坐标转换到组件的坐标系统
static void SwingUtilities.convertPointToScreen(Point p, Component c)
将一个点从组件的坐标系统转换到屏幕坐标。
static Rectangle SwingUtilities.convertRectangle(Component source, Rectangle aRectangle, Component destination)
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
protected  JDialog JFileChooser.createDialog(Component parent)
创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
 JDialog JOptionPane.createDialog(Component parentComponent, String title)
创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
static JDialog JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
 JInternalFrame JOptionPane.createInternalFrame(Component parentComponent, String title)
创建并返回 JInternalFrame 的实例。
static RepaintManager RepaintManager.currentManager(Component c)
在给定 Component 的情况下，返回调用线程的 RepaintManager。
static Component SwingUtilities.findFocusOwner(Component c)
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
static Accessible SwingUtilities.getAccessibleAt(Component c, Point p)
如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
static Accessible SwingUtilities.getAccessibleChild(Component c, int i)
返回对象的第 n 个可访问子对象。
static int SwingUtilities.getAccessibleChildrenCount(Component c)
返回对象中可访问的子对象数。
static int SwingUtilities.getAccessibleIndexInParent(Component c)
获取此对象在其可访问的父对象中的索引。
static AccessibleStateSet SwingUtilities.getAccessibleStateSet(Component c)
获取此对象的状态。
static Container SwingUtilities.getAncestorNamed(String name, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。
static Container SwingUtilities.getAncestorOfClass(Class<?> c, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
 Component DefaultFocusManager.getComponentAfter(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应在 aComponent 之后接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentAfter(Container aContainer, Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。
 Component DefaultFocusManager.getComponentBefore(Container aContainer, Component aComponent)
 Component LayoutFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应在 aComponent 之前接收焦点的 Component。
 Component SortingFocusTraversalPolicy.getComponentBefore(Container aContainer, Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。
 int JPopupMenu.getComponentIndex(Component c)
返回指定组件的索引。
 int JMenuBar.getComponentIndex(Component c)
返回指定组件的索引。
 int JToolBar.getComponentIndex(Component c)
返回指定组件的索引。
 Spring SpringLayout.getConstraint(String edgeName, Component c)
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。
 SpringLayout.Constraints SpringLayout.getConstraints(Component c)
返回指定组件的约束。
static Component SwingUtilities.getDeepestComponentAt(Component parent, int x, int y)
返回包含位置 x、y 的 parent 的最深可见后代组件。
static JDesktopPane JOptionPane.getDesktopPaneForComponent(Component parentComponent)
返回指定组件的桌面窗格。
static Frame JOptionPane.getFrameForComponent(Component parentComponent)
返回指定组件的 Frame。
 int JLayeredPane.getIndexOf(Component c)
返回指定 Component 的索引。
 int JLayeredPane.getLayer(Component c)
返回指定 Component 的 layer 属性。
static JLayeredPane JLayeredPane.getLayeredPaneAbove(Component c)
一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。
static Rectangle SwingUtilities.getLocalBounds(Component aComponent)
返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。
 Image RepaintManager.getOffscreenBuffer(Component c, int proposedWidth, int proposedHeight)
返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。
 Popup PopupFactory.getPopup(Component owner, Component contents, int x, int y)
为包含 Component contents 的 Component owner 创建 Popup。
 int JLayeredPane.getPosition(Component c)
获得该组件在其所在层中的相对位置。
static Component SwingUtilities.getRoot(Component c)
返回当前组件树结构的根组件。
static JRootPane SwingUtilities.getRootPane(Component c)
如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。
 Image RepaintManager.getVolatileOffscreenBuffer(Component c, int proposedWidth, int proposedHeight)
返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。
static Window SwingUtilities.getWindowAncestor(Component c)
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
static Spring Spring.height(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。
 int JTabbedPane.indexOfComponent(Component component)
返回指定组件的选项卡索引。
 int JTabbedPane.indexOfTabComponent(Component tabComponent)
返回指定选项卡组件的选项卡索引。
 void JPopupMenu.insert(Component component, int index)
将指定组件插入到菜单的给定位置。
 void JTextPane.insertComponent(Component c)
将一个组件插入到文档中，以替换当前选择的内容。
 void JTabbedPane.insertTab(String title, Icon icon, Component component, String tip, int index)
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。
 boolean MenuSelectionManager.isComponentPartOfCurrentMenu(Component c)
如果 c 是当前使用菜单的一部分，则返回 true
static boolean SwingUtilities.isDescendingFrom(Component a, Component b)
如果组件 a 从组件 b 继承，则返回 true。
static boolean JComponent.isLightweightComponent(Component c)
如果此组件是轻量的，也就是说，如果它没有本机窗口系统同位体，则返回 true。
 boolean JMenu.isMenuComponent(Component c)
如果在子菜单层次结构中存在指定的组件，则返回 true。
 void GroupLayout.linkSize(Component... components)
将指定组件强制调整为具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
 void GroupLayout.linkSize(int axis, Component... components)
将指定组件强制调整为沿指定轴具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
 void JLayeredPane.moveToBack(Component c)
将该组件移到当前层中所有组件的底层（位置 -1）。
 void JLayeredPane.moveToFront(Component c)
将该组件移到当前层中所有组件的顶层（位置 0）。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
在指定的 Graphics 上绘制组件。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。
 void CellRendererPane.paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
static void SwingUtilities.paintComponent(Graphics g, Component c, Container p, Rectangle r)
在指定的 Graphics 上绘制组件。
 void ImageIcon.paintIcon(Component c, Graphics g, int x, int y)
绘制图标。
 void Icon.paintIcon(Component c, Graphics g, int x, int y)
在指定位置上绘制图标。
 void LookAndFeel.provideErrorFeedback(Component component)
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
 void SpringLayout.putConstraint(String e1, Component c1, int pad, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。
 void SpringLayout.putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2。
 void JApplet.remove(Component comp)
从容器中移除指定的组件。
 void JTabbedPane.remove(Component component)
从 JTabbedPane 中移除指定 Component。
 void JWindow.remove(Component comp)
从该容器中移除指定组件。
 void JViewport.remove(Component child)
移除 Viewport 的一个轻量子对象。
 void JSplitPane.remove(Component component)
移除窗格中的子组件 component。
 void JDialog.remove(Component comp)
从该容器中移除指定组件。
 void JMenu.remove(Component c)
从此菜单移除组件 c。
 void JInternalFrame.remove(Component comp)
从此容器中移除指定组件。
 void JFrame.remove(Component comp)
从该容器中移除指定组件。
 void GroupLayout.removeLayoutComponent(Component component)
已从父容器中移除 Component 的通知。
 void JSpinner.DefaultEditor.removeLayoutComponent(Component child)
此 LayoutManager 方法不执行任何操作。
 void OverlayLayout.removeLayoutComponent(Component comp)
从布局移除指定组件。
 void SpringLayout.removeLayoutComponent(Component c)
移除与指定组件相关的约束。
 void ViewportLayout.removeLayoutComponent(Component c)
从布局中移除指定组件。
 void ScrollPaneLayout.removeLayoutComponent(Component c)
从布局中移除指定的组件。
 void BoxLayout.removeLayoutComponent(Component comp)
此类不使用。
 void JRootPane.RootLayout.removeLayoutComponent(Component comp)
 void GroupLayout.replace(Component existingComponent, Component newComponent)
使用新的组件替代现有组件。
 void JSplitPane.setBottomComponent(Component comp)
将组件设置到分隔条的下面或者右边。
 void JScrollPane.setColumnHeaderView(Component view)
创建一个列标题视口（如果有必要），设置其视图然后将此列标题视口添加到滚动窗格。
 void JTabbedPane.setComponentAt(int index, Component component)
将 index 位置的组件设置为 component。
 void JDesktopPane.setComponentZOrder(Component comp, int index)
将指定组件移动到容器中指定的 z 顺序索引。
 void JScrollPane.setCorner(String key, Component corner)
添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。
 void JApplet.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void JWindow.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void JDialog.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void JInternalFrame.setGlassPane(Component glass)
设置此 JInternalFrame 的 glassPane 属性。
 void JRootPane.setGlassPane(Component glass)
将指定的 Component 设置为此根窗格的玻璃窗格。
 void JFrame.setGlassPane(Component glassPane)
设置 glassPane 属性。
 void RootPaneContainer.setGlassPane(Component glassPane)
glassPane 始终为 rootPane 的第一个子组件，rootPanes 布局管理器确保它始终与 rootPane 一样大。
 void GroupLayout.setHonorsVisibility(Component component, Boolean honorsVisibility)
设置确定组件的大小和位置时是否要考虑组件的可见性。
 void JPopupMenu.setInvoker(Component invoker)
设置此弹出菜单的调用者，即弹出菜单在其中显示的组件。
 void JLabel.setLabelFor(Component c)
设置要添加标签的组件。
 void JLayeredPane.setLayer(Component c, int layer)
设置指定组件的 layer 属性，使之成为该层中最底部的组件。
 void JLayeredPane.setLayer(Component c, int layer, int position)
为指定组件设置 layer 属性，并设置它在该层中的位置。
 void JSplitPane.setLeftComponent(Component comp)
将组件设置到分隔条的左边（或上面）。
 void JComponent.setNextFocusableComponent(Component aComponent)
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代
 void JLayeredPane.setPosition(Component c, int position)
将该组件移到当前层中的 position 处，其中 0 表示该层中的最顶层位置，-1 表示最底层位置。
 void JSplitPane.setRightComponent(Component comp)
将组件设置到分隔条的右边（或者下面）。
 void JScrollPane.setRowHeaderView(Component view)
创建一个行标题视口（如果有必要），设置其视图然后将此行标题视口添加到滚动窗格。
 void JPopupMenu.setSelected(Component sel)
设置当前选择的组件，此方法将更改选择模型。
 void JMenuBar.setSelected(Component sel)
设置当前选择的组件，更改选择模型。
 void JTabbedPane.setSelectedComponent(Component c)
设置此选项卡窗格的已选组件。
 void JTabbedPane.setTabComponentAt(int index, Component component)
设置负责呈现指定选项卡标题的组件。
 void JSplitPane.setTopComponent(Component comp)
将组件设置到分隔条的上面或者左边。
 void JViewport.setView(Component view)
设置 JViewport 的一个轻量子对象 (view)，可以为 null。
 void JScrollPane.setViewportView(Component view)
创建一个视口（如果有必要）并设置其视图。
 void JPopupMenu.show(Component invoker, int x, int y)
在组件调用者的坐标空间中的位置 X、Y 显示弹出菜单。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的对话框。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。
static int JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
 int JFileChooser.showDialog(Component parent, String approveButtonText)
弹出具有自定义 approve 按钮的自定义文件选择器对话框。
static Color JColorChooser.showDialog(Component component, String title, Color initialColor)
显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。
static String JOptionPane.showInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String JOptionPane.showInputDialog(Component parentComponent, Object message, Object initialSelectionValue)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。
static Object JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。
static int JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。
static String JOptionPane.showInternalInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。
static String JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。
static Object JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message)
调出内部确认对话框面板。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。
static void JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。
static int JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message)
调出标题为 "Message" 的信息消息对话框。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。
static void JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。
 int JFileChooser.showOpenDialog(Component parent)
弹出一个 "Open File" 文件选择器对话框。
static int JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
 int JFileChooser.showSaveDialog(Component parent)
弹出一个 "Save File" 文件选择器对话框。
static void SwingUtilities.updateComponentTreeUI(Component c)
简单的外观更改：将树结构中的每个节点转到 updateUI() -- 也就是说，通过当前外观初始化其 UI 属性。
static Spring Spring.width(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。
static Window SwingUtilities.windowForComponent(Component c)
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。

类型变量类型为 Component 的 javax.swing 中的方法参数
protected  void SortingFocusTraversalPolicy.setComparator(Comparator<? super Component> comparator)
设置将用于对焦点遍历循环中的 Components 排序的 Comparator。

参数类型为 Component 的 javax.swing 中的构造方法
JScrollPane(Component view)
创建一个显示指定组件内容的 JScrollPane，只要组件的内容超过视图大小就会显示水平和垂直滚动条。
JScrollPane(Component view, int vsbPolicy, int hsbPolicy)
创建一个 JScrollPane，它将视图组件显示在一个视口中，视图位置可使用一对滚动条控制。
JSplitPane(int newOrientation, boolean newContinuousLayout, Component newLeftComponent, Component newRightComponent)
创建一个具有指定方向、重绘方式和指定组件的新 JSplitPane。
JSplitPane(int newOrientation, Component newLeftComponent, Component newRightComponent)
创建一个具有指定方向和不连续重绘的指定组件的新 JSplitPane。
Popup(Component owner, Component contents, int x, int y)
为包含 Component content 的 Component owner 创建 Popup。
ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。
ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
构造一个对象，以监视输入流的进度。
SpringLayout.Constraints(Component c)
创建组件 c 的合适 x、y、width 和 height spring 的 Constraints 对象。
TransferHandler.TransferSupport(Component component, Transferable transferable)
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。

类型变量类型为 Component 的 javax.swing 中的构造方法参数
SortingFocusTraversalPolicy(Comparator<? super Component> comparator)
构造具有指定 Comparator 的 SortingFocusTraversalPolicy。

javax.swing.border 中 Component 的使用

参数类型为 Component 的 javax.swing.border 中的方法
int | TitledBorder.getBaseline(Component c, int width, int height) 返回基线。
int | AbstractBorder.getBaseline(Component c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | TitledBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | AbstractBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
Insets | SoftBevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | TitledBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | BevelBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | EtchedBorder.getBorderInsets(Component c) 返回边框的 insets
Insets | LineBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | MatteBorder.getBorderInsets(Component c) 返回边框的 insets。
Insets | CompoundBorder.getBorderInsets(Component c) 返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。
Insets | EmptyBorder.getBorderInsets(Component c) 返回此边框的 insets
Insets | AbstractBorder.getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | Border.getBorderInsets(Component c) 返回该边框的 insets。
Insets | SoftBevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | TitledBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | BevelBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EtchedBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | LineBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | MatteBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | CompoundBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Insets | EmptyBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
Insets | AbstractBorder.getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
protected Font | TitledBorder.getFont(Component c)
Color | EtchedBorder.getHighlightColor(Component c) 返回浮雕化边框在指定组件上呈现的高亮显示颜色。
Color | BevelBorder.getHighlightInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部高亮显示颜色。
Color | BevelBorder.getHighlightOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部高亮显示颜色。
static Rectangle | AbstractBorder.getInteriorRectangle(Component c, Border b, int x, int y, int width, int height) 返回一个用所给的参数减去边框 insets 得到的矩形。
Rectangle | AbstractBorder.getInteriorRectangle(Component c, int x, int y, int width, int height) 此便捷方法调用静态方法。
Dimension | TitledBorder.getMinimumSize(Component c) 返回此边框完全显示边框和标题所需的最小大小。
Color | EtchedBorder.getShadowColor(Component c) 返回浮雕化边框在指定组件上呈现的阴影颜色。
Color | BevelBorder.getShadowInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部阴影颜色。
Color | BevelBorder.getShadowOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部阴影颜色。
void | SoftBevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸绘制指定组件的边框。
void | TitledBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和大小为指定的组件绘制边框。
void | BevelBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
void | EtchedBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框
void | LineBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框。
void | MatteBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制衬边边框。
void | CompoundBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。
void | EmptyBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 默认情况下不执行绘制。
void | AbstractBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
void | Border.paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
protected void | BevelBorder.paintLoweredBevel(Component c, Graphics g, int x, int y, int width, int height)
protected void | BevelBorder.paintRaisedBevel(Component c, Graphics g, int x, int y, int width, int height)

javax.swing.colorchooser 中 Component 的使用

javax.swing.colorchooser 中 Component 的子类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.event 中 Component 的使用

参数类型为 Component 的 javax.swing.event 中的构造方法
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。

javax.swing.plaf 中 Component 的使用

参数类型为 Component 的 javax.swing.plaf 中的方法
Insets | BorderUIResource.getBorderInsets(Component c)
void | BorderUIResource.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | IconUIResource.paintIcon(Component c, Graphics g, int x, int y)

javax.swing.plaf.basic 中 Component 的使用

javax.swing.plaf.basic 中 Component 的子类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

声明为 Component 的 javax.swing.plaf.basic 中的字段
protected Component[] | BasicSplitPaneUI.BasicHorizontalLayoutManager.components
protected Component | BasicTreeUI.MouseInputHandler.destination 接收所有事件的目的地。
protected Component | BasicTreeUI.editingComponent 编辑时，它将是进行实际编辑的 Component。
protected Component | BasicComboBoxUI.editor
protected Component | BasicSplitPaneDivider.hiddenDivider 用于非连续布局模式的分隔符。
protected Component | BasicOptionPaneUI.initialFocusComponent 利用 selectInitialValue 传递消息时接收焦点的组件。
protected Component | BasicSplitPaneUI.nonContinuousLayoutDivider 使用非连续布局时分隔符阴影的实例。
protected Component | BasicTreeUI.MouseInputHandler.source 发起事件的源。
Component | BasicMenuUI.ChangeHandler.wasFocused

返回 Component 的 javax.swing.plaf.basic 中的方法
protected Component | BasicSplitPaneUI.createDefaultNonContinuousLayoutDivider() 返回默认的非连续布局分隔符，该分隔符是使用深灰色填充背景的 Canvas 的实例。
protected Component | BasicSpinnerUI.createNextButton() 创建将用 spinner.getNextValue 返回的对象取代 spinner 模型值的组件。
protected Component | BasicSpinnerUI.createPreviousButton() 创建将用 spinner.getPreviousValue 返回的对象取代 spinner 模型值的组件。
Component | BasicComboBoxEditor.getEditorComponent()
protected Component | BasicSliderUI.getHighestValueLabel() 返回与标签表中的最低滑块值相对应的标签。
Component | BasicComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
protected Component | BasicSliderUI.getLowestValueLabel() 返回与标签表中的最高滑块值相对应的标签。
Component | BasicSplitPaneUI.getNonContinuousLayoutDivider() 返回要在将 splitPane 配置为非连续布局时使用的分隔符。
protected Component | BasicTabbedPaneUI.getVisibleComponent()

参数类型为 Component 的 javax.swing.plaf.basic 中的方法
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(Component comp, Object constraints) 使用指定的约束对象将指定组件添加到布局中。
void | BasicInternalFrameTitlePane.TitlePaneLayout.addLayoutComponent(String name, Component c)
void | BasicInternalFrameUI.InternalFrameLayout.addLayoutComponent(String name, Component c)
void | BasicOptionPaneUI.ButtonAreaLayout.addLayoutComponent(String string, Component comp)
void | BasicSplitPaneDivider.DividerLayout.addLayoutComponent(String string, Component c)
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(String place, Component component) 在 place 位置添加组件。
void | BasicTabbedPaneUI.TabbedPaneLayout.addLayoutComponent(String name, Component comp)
void | BasicComboBoxUI.ComboBoxLayoutManager.addLayoutComponent(String name, Component comp)
void | BasicScrollBarUI.addLayoutComponent(String name, Component child)
boolean | BasicToolBarUI.canDock(Component c, Point p)
protected void | BasicTreeUI.drawCentered(Component c, Graphics graphics, Icon icon, int x, int y)
Insets | BasicBorders.ButtonBorder.getBorderInsets(Component c)
Insets | BasicBorders.ToggleButtonBorder.getBorderInsets(Component c)
Insets | BasicBorders.RadioButtonBorder.getBorderInsets(Component c)
Insets | BasicBorders.MenuBarBorder.getBorderInsets(Component c)
Insets | BasicBorders.MarginBorder.getBorderInsets(Component c)
Insets | BasicBorders.FieldBorder.getBorderInsets(Component c)
Insets | BasicBorders.SplitPaneBorder.getBorderInsets(Component c)
Insets | BasicBorders.ButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.ToggleButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.RadioButtonBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MenuBarBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.MarginBorder.getBorderInsets(Component c, Insets insets)
Insets | BasicBorders.FieldBorder.getBorderInsets(Component c, Insets insets)
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getPreferredSizeOfComponent(Component c) 返回传入 Component 的首选大小的宽度。
protected int | BasicSplitPaneUI.BasicHorizontalLayoutManager.getSizeOfComponent(Component c) 返回传入组件的宽度。
protected void | BasicSpinnerUI.installNextButtonListeners(Component c) 在下一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
protected void | BasicSpinnerUI.installPreviousButtonListeners(Component c) 在上一个按钮（c）上安装必要的侦听器以更新 JSpinner 来响应用户动作。
void | BasicBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | BasicBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.RadioButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.FieldBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
void | BasicBorders.SplitPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int width, int height)
protected void | BasicSliderUI.paintHorizontalLabel(Graphics g, int value, Component label) 为标签表中的每个标签调用此方法。
protected void | BasicSliderUI.paintVerticalLabel(Graphics g, int value, Component label) 为标签表中的每个标签调用此方法。
void | BasicInternalFrameTitlePane.TitlePaneLayout.removeLayoutComponent(Component c)
void | BasicInternalFrameUI.InternalFrameLayout.removeLayoutComponent(Component c)
void | BasicOptionPaneUI.ButtonAreaLayout.removeLayoutComponent(Component c)
void | BasicSplitPaneDivider.DividerLayout.removeLayoutComponent(Component c)
void | BasicSplitPaneUI.BasicHorizontalLayoutManager.removeLayoutComponent(Component component) 根据了解的情况移除指定的组件。
void | BasicTabbedPaneUI.TabbedPaneLayout.removeLayoutComponent(Component comp)
void | BasicComboBoxUI.ComboBoxLayoutManager.removeLayoutComponent(Component comp)
void | BasicScrollBarUI.removeLayoutComponent(Component child)
protected void | BasicToolBarUI.setBorderToNonRollover(Component c) 将组件的边框设置为具有由 createNonRolloverBorder 创建的翻转边框。
protected void | BasicToolBarUI.setBorderToNormal(Component c) 将组件的边框设置为具有普通边框。
protected void | BasicToolBarUI.setBorderToRollover(Component c) 将组件的边框设置为具有由 createRolloverBorder 创建的翻转边框。
protected void | BasicSplitPaneUI.BasicHorizontalLayoutManager.setComponentToSize(Component c, int size, int location, Insets insets, Dimension containerSize) 将组件 c 的宽度设置为 size（将其 x 的位置放置到 location），将 y 和高度分别设置为 insets.top 和 containersize.height 减去上下 insets。
protected void | BasicSplitPaneUI.setNonContinuousLayoutDivider(Component newDivider) 设置要在将 splitPane 配置为非连续布局时使用的分隔符。
protected void | BasicSplitPaneUI.setNonContinuousLayoutDivider(Component newDivider, boolean rememberSizes) 设置要使用的分隔符。
protected void | BasicTabbedPaneUI.setVisibleComponent(Component component)

参数类型为 Component 的 javax.swing.plaf.basic 中的构造方法
BasicTreeUI.MouseInputHandler(Component source, Component destination, MouseEvent event)

javax.swing.plaf.metal 中 Component 的使用

javax.swing.plaf.metal 中 Component 的子类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

返回 Component 的 javax.swing.plaf.metal 中的方法
 Component MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

参数类型为 Component 的 javax.swing.plaf.metal 中的方法
protected void | MetalCheckBoxIcon.drawCheck(Component c, Graphics g, int x, int y)
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c)
Insets | MetalBorders.ScrollPaneBorder.getBorderInsets(Component c)
Insets | MetalBorders.TableHeaderBorder.getBorderInsets(Component c)
Insets | MetalBorders.Flush3DBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ButtonBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.InternalFrameBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PaletteBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.OptionDialogBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuBarBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.MenuItemBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.PopupMenuBorder.getBorderInsets(Component c, Insets newInsets)
Insets | MetalBorders.ToolBarBorder.getBorderInsets(Component c, Insets newInsets)
void | MetalBorders.Flush3DBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.InternalFrameBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PaletteBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.OptionDialogBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.MenuItemBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.PopupMenuBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.RolloverButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToolBarBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TextFieldBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ScrollPaneBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.ToggleButtonBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalBorders.TableHeaderBorder.paintBorder(Component c, Graphics g, int x, int y, int w, int h)
void | MetalCheckBoxIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalComboBoxIcon.paintIcon(Component c, Graphics g, int x, int y) 绘制 MetalComboBox 的水平条
void | MetalIconFactory.PaletteCloseIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FolderIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.FileIcon16.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.TreeControlIcon.paintIcon(Component c, Graphics g, int x, int y)
void | MetalIconFactory.TreeControlIcon.paintMe(Component c, Graphics g, int x, int y)
void | MetalLookAndFeel.provideErrorFeedback(Component component) 在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
protected void | MetalToolBarUI.setBorderToNonRollover(Component c)

javax.swing.plaf.synth 中 Component 的使用

参数类型为 Component 的 javax.swing.plaf.synth 中的方法
static void SynthLookAndFeel.updateStyles(Component c)
更新与 c 关联的样式以及其所有子样式。

javax.swing.table 中 Component 的使用

javax.swing.table 中 Component 的子类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

返回 Component 的 javax.swing.table 中的方法
Component | TableCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column) 为编辑器设置初始 value。
Component | DefaultTableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回默认的表单元格渲染器。
Component | TableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column) 返回用于绘制单元格的组件。

javax.swing.text 中 Component 的使用

javax.swing.text 中 Component 的子类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

返回 Component 的 javax.swing.text 中的方法
protected Component | ComponentView.createComponent() 创建与此视图关联的组件。
Component | ComponentView.getComponent() 获取与此视图关联的组件。
static Component | StyleConstants.getComponent(AttributeSet a) 从属性列表中获取组件设置。

参数类型为 Component 的 javax.swing.text 中的方法
protected void | PlainView.damageLineRange(int line0, int line1, Shape a, Component host) 重新绘制给定的行范围。
static void | StyleConstants.setComponent(MutableAttributeSet a, Component c) 设置组件属性。

javax.swing.text.html 中 Component 的使用

返回 Component 的 javax.swing.text.html 中的方法
protected Component | FormView.createComponent() 创建组件。
protected Component | ObjectView.createComponent() 创建组件。

javax.swing.tree 中 Component 的使用

javax.swing.tree 中 Component 的子类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

声明为 Component 的 javax.swing.tree 中的字段
protected  Component DefaultTreeCellEditor.editingComponent
用于编辑的组件，从 editingContainer 获取。

返回 Component 的 javax.swing.tree 中的方法
Component | DefaultTreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 配置编辑器。
Component | TreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 设置编辑器的初始值。
Component | DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus) 配置基于传入组件的渲染器。
Component | TreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus) 将当前树单元格的值设置为 value。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Component.BaselineResizeBehavior 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.BaselineResizeBehavior
的使用

使用 Component.BaselineResizeBehavior 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 java.awt 中的方法
Component.BaselineResizeBehavior | Component.getBaselineResizeBehavior() 返回一个指示组件的基线如何随大小发生更改的枚举。
static Component.BaselineResizeBehavior | Component.BaselineResizeBehavior.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Component.BaselineResizeBehavior[] | Component.BaselineResizeBehavior.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.swing 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing 中的方法
Component.BaselineResizeBehavior | JSpinner.DefaultEditor.getBaselineResizeBehavior() 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | JComponent.getBaselineResizeBehavior() 返回一个枚举，指示组件的基线如何随大小更改而发生更改。

javax.swing.border 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing.border 中的方法
Component.BaselineResizeBehavior | TitledBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | AbstractBorder.getBaselineResizeBehavior(Component c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。

javax.swing.plaf 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing.plaf 中的方法
 Component.BaselineResizeBehavior ComponentUI.getBaselineResizeBehavior(JComponent c)
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。

javax.swing.plaf.basic 中 Component.BaselineResizeBehavior 的使用

返回 Component.BaselineResizeBehavior 的 javax.swing.plaf.basic 中的方法
Component.BaselineResizeBehavior | BasicSpinnerUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicSliderUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTextAreaUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTreeUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTableUI.getBaselineResizeBehavior(JComponent c) 返回指示该组件的基线如何随大小的改变而发生更改的枚举。
Component.BaselineResizeBehavior | BasicProgressBarUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTabbedPaneUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicTextFieldUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicScrollPaneUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicListUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicComboBoxUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicButtonUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicLabelUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
Component.BaselineResizeBehavior | BasicPanelUI.getBaselineResizeBehavior(JComponent c) 返回一个枚举，它指示该组件的基线如何随大小的改变而发生更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Component.FlipBufferStrategy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.FlipBufferStrategy
的使用

没有 java.awt.Component.FlipBufferStrategy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Component.BltBufferStrategy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.BltBufferStrategy
的使用

没有 java.awt.Component.BltBufferStrategy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Component.AccessibleAWTComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.AccessibleAWTComponent
的使用

使用 Component.AccessibleAWTComponent 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 Component.AccessibleAWTComponent 的使用

java.applet 中 Component.AccessibleAWTComponent 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 Component.AccessibleAWTComponent 的使用

java.awt 中 Component.AccessibleAWTComponent 的子类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

javax.swing 中 Component.AccessibleAWTComponent 的使用

javax.swing 中 Component.AccessibleAWTComponent 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

javax.swing.table 中 Component.AccessibleAWTComponent 的使用

javax.swing.table 中 Component.AccessibleAWTComponent 的子类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 Component.AccessibleAWTComponent 的使用

javax.swing.text 中 Component.AccessibleAWTComponent 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
的使用

没有 java.awt.Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
的使用

没有 java.awt.Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.awt.MenuContainer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.awt.MenuContainer
的使用

使用 MenuContainer 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 MenuContainer 的使用

实现 MenuContainer 的 java.applet 中的类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 MenuContainer 的使用

实现 MenuContainer 的 java.awt 中的类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Component component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
class | Panel Panel 是最简单的容器类。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

返回 MenuContainer 的 java.awt 中的方法
MenuContainer | PopupMenu.getParent() 返回此菜单组件的父容器。
MenuContainer | MenuComponent.getParent() 返回此菜单组件的父容器。

javax.swing 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing 中的类
class | AbstractButton 定义按钮和菜单项的一般行为。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。

javax.swing.colorchooser 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.colorchooser 中的类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf.basic 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicToolBarUI.DragWindow

javax.swing.plaf.metal 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.table 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。

javax.swing.text 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.tree 中 MenuContainer 的使用

实现 MenuContainer 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AppletInitializer (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 AppletInitializer

public interface AppletInitializer

此接口设计用于与 java.beans.Beans.instantiate 联合使用。在通过 java.beans.Beans.instantiate() 进行实例化的过程中，该接口将提供允许适当初始化 JavaBeans 的机制。

从以下版本开始：
1.2
另请参见：
Beans.instantiate(java.lang.ClassLoader, java.lang.String)

方法摘要
void | activate(Applet newApplet) 激活和/或将 Applet 标记为激活。
void | initialize(Applet newAppletBean, BeanContext bCtxt) 如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。

方法详细信息

initialize

void initialize(Applet newAppletBean,
                BeanContext bCtxt)

如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。

遵守该接口的实现将：

  1. 将新近实例化的 Applet 与适当的 AppletContext 相关联。
  2. 实例化一个 AppletStub()，并通过调用 setStub() 将该 AppletStub 与 Applet 相关联。
  3. 如果 BeanContext 参数为 null，则应该通过调用 add() 将 Applet 添加到其 Container 中，使该 Applet 与适当的 Container 相关联。如果 BeanContext 参数不为 null，则由 BeanContext 负责在后续调用其 addChildren() 方法期间，将 Applet 与其 Container 相关联。

参数：
newAppletBean - 新近实例化的 JavaBean
bCtxt - 打算用于此 Applet 的 BeanContext，或者为 null。

activate

void activate(Applet newApplet)

激活和/或将 Applet 标记为激活。此接口的实现应将此 Applet 标记为激活，并选择性地调用其 start() 方法。

参数：
newApplet - 新近实例化的 JavaBean
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BeanDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 BeanDescriptor

java.lang.Object
    继承者  java.beans.FeatureDescriptor
        继承者  java.beans.BeanDescriptor

public class BeanDescriptor
extends FeatureDescriptor

BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。

这是由 BeanInfo 对象返回的描述符种类之一，该对象还返回属性、方法和事件的描述符。

构造方法摘要
BeanDescriptor(Class<?> beanClass)
为没有 customizer 的 bean 创建一个 BeanDescriptor。
BeanDescriptor(Class<?> beanClass, Class<?> customizerClass)
为有 customizer 的 bean 创建一个 BeanDescriptor。
方法摘要
Class<?> | getBeanClass() 获得 bean 的 Class 对象。
Class<?> | getCustomizerClass() 获得 bean 的 customizer 的 Class 对象。
从类 java.beans.FeatureDescriptor 继承的方法
attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BeanDescriptor

public BeanDescriptor(Class<?> beanClass)
为没有 customizer 的 bean 创建一个 BeanDescriptor。

参数：
beanClass - 实现 bean 的 Java 类的 Class 对象。例如 sun.beans.OurButton.class。

BeanDescriptor

public BeanDescriptor(Class<?> beanClass,
                      Class<?> customizerClass)
为有 customizer 的 bean 创建一个 BeanDescriptor。

参数：
beanClass - 实现 bean 的 Java 类的 Class 对象。例如 sun.beans.OurButton.class。
customizerClass - 实现 bean 的 Customizer 的 Java 类的 Class 对象。例如 sun.beans.OurButtonCustomizer.class。
方法详细信息

getBeanClass

public Class<?> getBeanClass()
获得 bean 的 Class 对象。

返回：
bean 的 Class 对象。

getCustomizerClass

public Class<?> getCustomizerClass()
获得 bean 的 customizer 的 Class 对象。

返回：
bean 的 customizer 的 Class 对象。如果 bean 没有 customizer，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 BeanInfo

所有已知子接口：
BeanContextServiceProviderBeanInfo
所有已知实现类：
SimpleBeanInfo
public interface BeanInfo

希望提供有关其 bean 的显式信息的 bean 实现者可以提供某个 BeanInfo 类，该类实现此 BeanInfo 接口并提供有关其 bean 的方法、属性、事件等显式信息。

bean 实现者不必提供一组完整的显式信息。可以挑选出希望提供的信息，其余部分将通过使用 bean 类方法的低级别反射和应用标准设计模式的自动分析来获得。

有机会提供大量不同的信息作为各种 XyZDescriptor 类的一部分。但不必惊慌，真正需要的只是提供各种构造方法所需的最少核心信息。

请参见 SimpleBeanInfo 类，它提供了用于 BeanInfo 类的一个便捷 "noop" 基类，可以为那些想要返回显式信息的特定位置重写该基类。

要学习有关 bean 的所有行为，请参见 Introspector 类。

字段摘要
static int | ICON_COLOR_16x16 指示 16 x 16 彩色图标的常量。
static int | ICON_COLOR_32x32 指示 32 x 32 彩色图标的常量。
static int | ICON_MONO_16x16 指示 16 x 16 单色图标的常量。
static int | ICON_MONO_32x32 指示 32 x 32 单色图标的常量。
方法摘要
BeanInfo[] | getAdditionalBeanInfo() 此方法允许 BeanInfo 对象返回提供关于当前 bean 额外信息的 BeanInfo 对象组成的任意集合。
BeanDescriptor | getBeanDescriptor() 获得 beans BeanDescriptor。
int | getDefaultEventIndex() bean 可能有一个“默认”事件，即使用 bean 时通常最有可能由用户使用的事件。
int | getDefaultPropertyIndex() bean 可能有一个“默认”属性，即通常最有可能由自定义 bean 的用户一开始就选择更新的属性。
EventSetDescriptor[] | getEventSetDescriptors() 获得 beans EventSetDescriptor。
Image | getIcon(int iconKind) 此方法返回一个图像对象，可用该对象表示工具框、工具栏等中的 bean。
MethodDescriptor[] | getMethodDescriptors() 获得 beans MethodDescriptor。
PropertyDescriptor[] | getPropertyDescriptors() 获得 beans PropertyDescriptor。

字段详细信息

ICON_COLOR_16x16

static final int ICON_COLOR_16x16
指示 16 x 16 彩色图标的常量。

另请参见：
常量字段值

ICON_COLOR_32x32

static final int ICON_COLOR_32x32
指示 32 x 32 彩色图标的常量。

另请参见：
常量字段值

ICON_MONO_16x16

static final int ICON_MONO_16x16
指示 16 x 16 单色图标的常量。

另请参见：
常量字段值

ICON_MONO_32x32

static final int ICON_MONO_32x32
指示 32 x 32 单色图标的常量。

另请参见：
常量字段值
方法详细信息

getBeanDescriptor

BeanDescriptor getBeanDescriptor()
获得 beans BeanDescriptor。

返回：
提供有关 bean 的全面信息的 BeanDescriptor，比如其 displayName、customizer 等等。如果该信息应该通过自动分析获得，则可能返回 null。

getEventSetDescriptors

EventSetDescriptor[] getEventSetDescriptors()
获得 beans EventSetDescriptor。

返回：
描述由此 bean 激发事件种类的 EventSetDescriptor 数组。如果该信息应该通过自动分析获得，则可能返回 null。

getDefaultEventIndex

int getDefaultEventIndex()
bean 可能有一个“默认”事件，即使用 bean 时通常最有可能由用户使用的事件。

返回：
位于由 getEventSetDescriptors 返回的 EventSetDescriptor 数组中的默认事件的索引。

如果没有默认事件，则返回 -1。

getPropertyDescriptors

PropertyDescriptor[] getPropertyDescriptors()
获得 beans PropertyDescriptor。

返回：
描述受此 bean 支持的可编辑属性的 PropertyDescriptor 数组。如果该信息应该通过自动分析获得，则可能返回 null。

如果某个属性已建立索引，则结果数组中该属性的条目将属于 PropertyDescriptor 的 IndexedPropertyDescriptor 子类。getPropertyDescriptors 的客户端可以使用 "instanceof" 来检查给定 PropertyDescriptor 是否是一个 IndexedPropertyDescriptor。

getDefaultPropertyIndex

int getDefaultPropertyIndex()
bean 可能有一个“默认”属性，即通常最有可能由自定义 bean 的用户一开始就选择更新的属性。

返回：
位于由 getPropertyDescriptors 返回的 PropertyDescriptor 数组中的默认属性的索引。

如果没有默认属性，则返回 -1。

getMethodDescriptors

MethodDescriptor[] getMethodDescriptors()
获得 beans MethodDescriptor。

返回：
描述受此 bean 支持的扩展可见方法的 MethodDescriptor 数组。如果该信息应该通过自动分析获得，则可能返回 null。

getAdditionalBeanInfo

BeanInfo[] getAdditionalBeanInfo()
此方法允许 BeanInfo 对象返回提供关于当前 bean 额外信息的 BeanInfo 对象组成的任意集合。

如果不同 BeanInfo 对象提供的信息之间有冲突和重叠，则当前 BeanInfo 优先于 getAdditionalBeanInfo 对象，数组中后面的元素优先于前面的元素。

返回：
BeanInfo 对象数组。可能返回 null。

getIcon

Image getIcon(int iconKind)
此方法返回一个图像对象，可用该对象表示工具框、工具栏等中的 bean。图标图像通常是 GIF，但将来可能包括其他格式。

bean 不需要提供图标，并且可能从此方法返回 null。

有四种可能的图标风格（16x16 彩色、32x32 彩色、16x16 单色、32x32 单色）。如果 bean 选择只支持一个图标，则建议支持 16x16 彩色。

建议该图标有一个“透明的”背景，这样就可以将它们呈现在现有的背景上。

参数：
iconKind - 所请求图标的种类。此参数应该是以下常数值之一：ICON_COLOR_16x16、ICON_COLOR_32x32、ICON_MONO_16x16 和 ICON_MONO_32x32。
返回：
表示所请求图标的图像对象。如果没有合适的图标可用，则可能返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Beans (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 Beans

java.lang.Object
    继承者  java.beans.Beans

public class Beans
extends Object

此类提供一些通用的 bean 控制方法。

构造方法摘要
Beans()
方法摘要
static Object | getInstanceOf(Object bean, Class<?> targetType) 从给定 bean 中获得表示源对象的指定类型视图的对象。
static Object | instantiate(ClassLoader cls, String beanName) 实例化 JavaBean。
static Object | instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。
static boolean | isDesignTime() 测试是否正处于设计模式。
static boolean | isGuiAvailable() 确定 bean 是否可以假定某个 GUI 是可用的。
static boolean | isInstanceOf(Object bean, Class<?> targetType) 检查是否可以将 bean 视为给定目标类型。
static void | setDesignTime(boolean isDesignTime) 用于指示是否正运行在应用程序生成器环境中。
static void | setGuiAvailable(boolean isGuiAvailable) 用于指示是否正运行在可进行 GUI 交互的环境中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Beans

public Beans()
方法详细信息

instantiate

public static Object instantiate(ClassLoader cls,
                                 String beanName)
                          throws IOException,
                                 ClassNotFoundException

实例化 JavaBean。

参数：
cls - 应该在其中创建 bean 的类加载器。如果该参数为 null，则使用系统类加载器。
beanName - 类加载器中 bean 的名称。例如 "sun.beanbox.foobah"
抛出：
ClassNotFoundException - 如果找不到序列化对象的类。
IOException - 如果发生 I/O 错误。

instantiate

public static Object instantiate(ClassLoader cls,
                                 String beanName,
                                 BeanContext beanContext)
                          throws IOException,
                                 ClassNotFoundException

实例化 JavaBean。

参数：
cls - 应该在其中创建 bean 的类加载器。如果该参数为 null，则使用系统类加载器。
beanName - 类加载器中 bean 的名称。例如 "sun.beanbox.foobah"
beanContext - 在其中嵌套新的 bean 的 BeanContext
抛出：
ClassNotFoundException - 如果找不到序列化对象的类。
IOException - 如果发生 I/O 错误。

instantiate

public static Object instantiate(ClassLoader cls,
                                 String beanName,
                                 BeanContext beanContext,
                                 AppletInitializer initializer)
                          throws IOException,
                                 ClassNotFoundException
实例化 bean。

基于相对于某个类加载器的名称创建 bean。此名称应该是以句点分隔的名称，例如 "a.b.c"。

在 Beans 1.0 中，给定名称可以指示一个序列化对象或一个类。其他机制可以在将来添加。在 beans 1.0 中，首先试着将 beanName 作为序列化的对象名称对待，然后将它作为类名称对待。

在将 beanName 用作序列化对象名称时，要将给定的 beanName 转换为资源路径名，并添加后缀 ".ser"。然后试着从该资源加载序列化对象。

例如，给定一个 beanName "x.y"，Beans.instantiate 首先将试着从资源 "x/y.ser" 中读取一个序列化对象，如果失败，它会试着加载类 "x.y" 并创建该类的一个实例。

如果 bean 是 java.applet.Applet 的子类型，则为它提供一些特殊的初始化。首先，向它提供默认的 AppletStub 和 AppletContext。其次，如果根据类名称实例化 bean，则调用 applet 的 "init" 方法。（如果 bean 被反序列化，则跳过此步骤。）

注意，对于作为 applet 的 bean，由调用者负责在 applet 上调用 "start"。为了运转正常，应该在已经将 applet 添加到可见 AWT 容器中后执行该步骤。

注意，通过 beans.instantiate 创建的 applet 运行在与浏览器中运行的 applet 稍有不同的环境中。尤其要指出的是，bean applet 无法访问 "parameters"，因此它们可能希望提供属性 get/set 方法来设置参数值。建议 bean-applet 开发人员对照 JDK appletviewer（对于引用浏览器环境）和 BDK BeanBox（对于引用 bean 容器）来测试他们的 bean-applet。

参数：
cls - 应该在其中创建 bean 的类加载器。如果该参数为 null，则使用系统类加载器。
beanName - 类加载器中 bean 的名称。例如 "sun.beanbox.foobah"
beanContext - 在其中嵌套新 bean 的 BeanContext
initializer - 用于新 bean 的 AppletInitializer
抛出：
ClassNotFoundException - 如果找不到序列化对象的类。
IOException - 如果发生 I/O 错误。

getInstanceOf

public static Object getInstanceOf(Object bean,
                                   Class<?> targetType)
从给定 bean 中获得表示源对象的指定类型视图的对象。

结果可能是相同的对象或不同的对象。如果所请求的目标视图不可用，则返回给定 bean。

此方法在 Beans 1.0 中作为一个钩子 (hook) 提供，以允许以后添加更灵活的 bean 行为。

参数：
bean - 想从中获得视图的对象。
targetType - 想获得的视图类型。

isInstanceOf

public static boolean isInstanceOf(Object bean,
                                   Class<?> targetType)
检查是否可以将 bean 视为给定目标类型。如果可以在给定 bean 上使用 Beans.getInstanceof 方法来获得表示指定 targetType 类型视图的对象，则结果将为 true。

参数：
bean - 想从中获得视图的 bean。
targetType - 想获得的视图类型。
返回：
如果给定 bean 支持给定 targetType，则返回 "true"。

isDesignTime

public static boolean isDesignTime()
测试是否正处于设计模式。

返回：
如果正运行在应用程序构造环境中，则返回 true。
另请参见：
DesignMode

isGuiAvailable

public static boolean isGuiAvailable()
确定 bean 是否可以假定某个 GUI 是可用的。

返回：
如果正运行在这种环境：bean 可以假定交互 GUI 为可用，从而可以弹出对话框等，则返回 true。在窗口环境中，此方法通常将返回 true，而在服务器环境中，或者应用程序作为批处理任务的一部分运行时，此方法通常将返回 false。
另请参见：
Visibility

setDesignTime

public static void setDesignTime(boolean isDesignTime)
                          throws SecurityException
用于指示是否正运行在应用程序生成器环境中。

注意，此方法是经过安全检查的，不可以用于（例如）不受信任的 applet。更明确地说，如果有安全管理器，则调用其 checkPropertiesAccess 方法。这可能会导致 SecurityException 异常。

参数：
isDesignTime - 如果正在使用应用程序生成器工具，则该参数为 true。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许设置系统属性。
另请参见：
SecurityManager.checkPropertiesAccess()

setGuiAvailable

public static void setGuiAvailable(boolean isGuiAvailable)
                            throws SecurityException
用于指示是否正运行在可进行 GUI 交互的环境中。

注意，此方法是经过安全检查的，不可以用于（例如）不受信任的 applet。更明确地说，如果有安全管理器，则调用其 checkPropertiesAccess 方法。这可能会导致 SecurityException 异常。

参数：
isGuiAvailable - 如果可以进行 GUI 交互，则该参数为 true。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许设置系统属性。
另请参见：
SecurityManager.checkPropertiesAccess()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConstructorProperties (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

java.beans
注释类型 ConstructorProperties

@Documented
@Target(value=CONSTRUCTOR)
@Retention(value=RUNTIME)
public @interface ConstructorProperties

关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。例如：

   public class Point {

从以下版本开始：

1.6

必需元素摘要

 String[]
value

getter 方法名。

元素详细信息

value

public abstract String[] value

getter 方法名。

返回：
与被注释构造方法中参数相对应的获取方法名。

      概述
      软件包
    类
      使用
      树
      已过时
      索引
      帮助

JavaTM 2 Platform
Standard Ed. 6

 上一个类
 下一个类

  框架
 无框架

  摘要： 必需 | 可选

详细信息： 元素


Customizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 Customizer

public interface Customizer

customizer 类提供一个用来自定义目标 Java Bean 的完全自定义 GUI。

每个 customizer 都应该从 java.awt.Component 类继承，因此它们可以在 AWT 对话框或面板中被实例化。

每个 customizer 都应该有一个 null 构造方法。

方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | setObject(Object bean) 设置将要自定义的对象。

方法详细信息

setObject

void setObject(Object bean)
设置将要自定义的对象。此方法应该仅在已将 Customizer 添加到任何父 AWT 容器中之前调用一次。

参数：
bean - 要自定义的对象。

addPropertyChangeListener

void addPropertyChangeListener(PropertyChangeListener listener)
注册一个用于 PropertyChange 事件的侦听器。无论 customizer 在何时以可能需要将显示属性刷新的方式更改目标 bean，都将激发一个 PropertyChange 事件。

参数：
listener - 激发 PropertyChange 事件时要调用的对象。

removePropertyChangeListener

void removePropertyChangeListener(PropertyChangeListener listener)
移除一个用于 PropertyChange 事件的侦听器。

参数：
listener - 要移除的 PropertyChange 侦听器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultPersistenceDelegate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 DefaultPersistenceDelegate

java.lang.Object
    继承者  java.beans.PersistenceDelegate
        继承者  java.beans.DefaultPersistenceDelegate

public class DefaultPersistenceDelegate
extends PersistenceDelegate

DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。DefaultPersistenceDelegate 为遵从 JavaBeans 惯例的类提供可恢复的、基于公共 API 的持久性，而无需任何特定于类的配置。

关键假定是：该类有一个 null 构造方法，并通过按照 Introspector 返回的顺序匹配 "setter" 和 "getter" 方法对来精确地表示其状态。除了为 JavaBeans 提供无需编写代码的持久性，对于那些构造方法为非 null 时只需要将一些属性值作为参数的类，DefaultPersistenceDelegate 提供了一个实现持久存储的便捷方法。

从以下版本开始：
1.4
另请参见：
DefaultPersistenceDelegate(String[]), Introspector

构造方法摘要
DefaultPersistenceDelegate()
为具有 null 构造方法的类创建持久委托。
DefaultPersistenceDelegate(String[] constructorPropertyNames)
为其构造方法的参数是属性名称值（由 constructorPropertyNames 指定）的类创建默认持久委托。
方法摘要
protected  void initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。
protected  Expression instantiate(Object oldInstance, Encoder out)
instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。
protected  boolean mutatesTo(Object oldInstance, Object newInstance)
如果指定构造方法中的参数数量不为零，且 oldInstance 的类显式声明了一个 "equals" 方法，则此方法返回 oldInstance.equals(newInstance) 的值。
从类 java.beans.PersistenceDelegate 继承的方法
writeObject
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultPersistenceDelegate

public DefaultPersistenceDelegate()
为具有 null 构造方法的类创建持久委托。

另请参见：
DefaultPersistenceDelegate(java.lang.String[])

DefaultPersistenceDelegate

public DefaultPersistenceDelegate(String[] constructorPropertyNames)
为其构造方法的参数是属性名称值（由 constructorPropertyNames 指定）的类创建默认持久委托。构造方法参数是通过按提供顺序对属性名称求值来创建的。要使用此类指定特定类型序列化中使用的单个首选构造方法，需要声明组成构造方法参数的属性的名称。例如，没有定义 null 构造方法的 Font 类可以使用以下持久委托来处理：
     new DefaultPersistenceDelegate(new String[]{"name", "style", "size"});

参数：
constructorPropertyNames - 此构造方法参数的属性名称。
另请参见：
instantiate(java.lang.Object, java.beans.Encoder)
方法详细信息

mutatesTo

protected boolean mutatesTo(Object oldInstance,
                            Object newInstance)
如果指定构造方法中的参数数量不为零，且 oldInstance 的类显式声明了一个 "equals" 方法，则此方法返回 oldInstance.equals(newInstance) 的值。否则，此方法使用超类的定义，即在两个实例的类相等情况下返回 true。

覆盖：
类 PersistenceDelegate 中的 mutatesTo
参数：
oldInstance - 要复制的实例。
newInstance - 要修改的实例。
返回：
如果通过对 oldInstance 施加一系列变换可以创建 newInstance 的等效副本，则返回 true。
另请参见：
DefaultPersistenceDelegate(String[])

instantiate

protected Expression instantiate(Object oldInstance,
                                 Encoder out)
instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。

指定者：
类 PersistenceDelegate 中的 instantiate
参数：
oldInstance - 要实例化的实例。
out - 代码输出流。
返回：
值为 oldInstance 的一个表达式。
另请参见：
DefaultPersistenceDelegate(String[])

initialize

protected void initialize(Class<?> type,
                          Object oldInstance,
                          Object newInstance,
                          Encoder out)
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。如果属性描述符使用等于 Boolean.TRUE 的值来定义一个 "transient"属性，则此默认实现将忽略该属性。注意，单词 "transient" 的使用完全独立于 ObjectOutputStream 使用的字段修饰符。

对于每个非瞬态属性，创建一个表达式，在其中将非 null "getter" 方法应用于 oldInstance。此表达式的值是将被序列化实例中的属性值。如果在复制环境中此表达式的值 (mutatesTo 目标值)，则将初始化新值，使其等于旧值。在这种情况下，因为属性值没有发生更改，所以不需要调用相应的 "setter" 方法，也不需要发出声明。不然的话此值的表达式就会被另一个表达式（通常是一个构造方法）替代，并且要调用相应的 "setter" 方法，在对象中安装新属性值。此方案使用此代理从流生成的输出中移除默认信息。

在将这些语句传递到输出流（这些语句将在其中执行）时，newInstance 将产生副作用。在大多数情况下，这允许其值相互依赖的属性的问题通过减少需要写入到输出的语句量来实际帮助序列化进程。通常，处理相互依赖的属性问题被归结为这样一个问题：找出类中属性的某种顺序，从而没有任何属性依赖后续属性的值。

覆盖：
类 PersistenceDelegate 中的 initialize
参数：
oldInstance - 要复制的实例。
newInstance - 需修改的实例。
out - 所有的初始化语句都应该写入其中的流。
另请参见：
Introspector.getBeanInfo(java.lang.Class), PropertyDescriptor
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DesignMode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 DesignMode

所有已知子接口：
BeanContext, BeanContextServices
所有已知实现类：
BeanContextServicesSupport, BeanContextSupport
public interface DesignMode

此接口由 java.beans.beancontext.BeanContext 的实例实现或委托，以便将当前的 "designTime" 属性传播到 java.beans.beancontext.BeanContextChild 实例的嵌套层次结构。

JavaBeans 规范将设计时间的概念定义为某种模式，在这种模式下，JavaBeans 实例应该在其交互设计、合成或构造工具的组合和自定义期间运行，在 JavaBean 是 applet、应用程序或其他激活的 Java 可执行抽象概念的一部分时，设计时间与运行时间相对应。

从以下版本开始：
1.2
另请参见：
BeanContext, BeanContextChild, BeanContextMembershipListener, PropertyChangeEvent

字段摘要
static String PROPERTYNAME
从 BeanContext 或 PropertyChangeEvent 的其他源激发的 propertyName 的标准值。
方法摘要
boolean | isDesignTime() 值为 true 表示 JavaBeans 应该在设计时间模式下运转，而 false 表示应该在运行时运转。
void | setDesignTime(boolean designTime) 设置 "designTime" 属性的 "value"。

字段详细信息

PROPERTYNAME

static final String PROPERTYNAME
从 BeanContext 或 PropertyChangeEvent 的其他源激发的 propertyName 的标准值。

另请参见：
常量字段值
方法详细信息

setDesignTime

void setDesignTime(boolean designTime)
设置 "designTime" 属性的 "value"。

如果实现对象是 java.beans.beancontext.BeanContext 的一个实例，或是其中的一个子接口，则 BeanContext 将使用以下参数对已注册的 BeanContextMembershipListeners 激发一个 PropertyChangeEvent：

  • propertyName - java.beans.DesignMode.PROPERTYNAME
  • oldValue - "designTime" 以前的值
  • newValue - "designTime" 的当前值
注意，BeanContextChild 调用与其中嵌套的 BeanContext 相关联的此方法是不合法的。

参数：
designTime - "designTime" 属性的当前 "value"
另请参见：
BeanContext, BeanContextMembershipListener, PropertyChangeEvent

isDesignTime

boolean isDesignTime()
值为 true 表示 JavaBeans 应该在设计时间模式下运转，而 false 表示应该在运行时运转。

返回：
"designTime" 属性的当前 "value"。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Encoder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 Encoder

java.lang.Object
    继承者  java.beans.Encoder
直接已知子类：
XMLEncoder
public class Encoder
extends Object

Encoder 是这样的类，它可用于创建根据其公共 API 对 JavaBeans 集合状态进行编码的文件或流。Encoder 结合其持久委托，负责将对象图形拆分成一系列可用于创建它的 Statements 和 Expression。子类通常使用某种可读形式（比如 Java 源代码或 XML）提供这些表达式的语法。

从以下版本开始：
1.4

构造方法摘要
Encoder()
方法摘要
Object | get(Object oldInstance) 在由此流创建的环境中返回 oldInstance 的一个实验值。
ExceptionListener | getExceptionListener() 获得此流的异常处理程序。
PersistenceDelegate | getPersistenceDelegate(Class<?> type) 返回给定类型的持久委托。
Object | remove(Object oldInstance) 移除此实例的条目，返回旧条目。
void | setExceptionListener(ExceptionListener exceptionListener) 将此流的异常处理程序设置为 exceptionListener。
void | setPersistenceDelegate(Class<?> type, PersistenceDelegate persistenceDelegate) 将与此 type 相关联的持久委托设置为 persistenceDelegate。
void | writeExpression(Expression oldExp) 该实现首先查看使用此值的表达式是否已经被写入。
protected void | writeObject(Object o) 将指定对象写入输出流中。
void | writeStatement(Statement oldStm) 将语句 oldStm 写入流中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Encoder

public Encoder()
方法详细信息

writeObject

protected void writeObject(Object o)
将指定对象写入输出流中。序列化的形式将表示一系列的表达式，在读取输入流时，这种形式的组合效果将创建等效的对象。默认情况下，假定对象是具有 null 构造方法的 JavaBean，其状态通过 Introspector 返回的 "setter" 和 "getter" 方法的匹配对来定义。

参数：
o - 要写入流中的对象。
另请参见：
XMLDecoder.readObject()

setExceptionListener

public void setExceptionListener(ExceptionListener exceptionListener)
将此流的异常处理程序设置为 exceptionListener。当此流捕获可恢复的异常时，异常处理程序会获得通知。

参数：
exceptionListener - 此流的异常处理程序；如果该参数为 null，则使用默认异常侦听器。
另请参见：
getExceptionListener()

getExceptionListener

public ExceptionListener getExceptionListener()
获得此流的异常处理程序。

返回：
此流的异常处理程序；如果没有显式设置此处理程序，则返回默认异常侦听器。
另请参见：
setExceptionListener(java.beans.ExceptionListener)

getPersistenceDelegate

public PersistenceDelegate getPersistenceDelegate(Class<?> type)
返回给定类型的持久委托。持久委托是通过按顺序应用以下规则来计算的：
  • 如果 type 是一个数组，则返回内部持久委托，它将实例化适当类型和长度数组，初始化其每个元素，就好像它们是属性一样。
  • 如果 type 是一个代理，则返回内部持久委托，它将使用 Proxy 类中定义的静态 "newProxyInstance" 方法实例化一个新的代理实例。
  • 如果此类型的 BeanInfo 有一个定义了 "persistenceDelegate" 属性的 BeanDescriptor，则返回此值。
  • 在其他所有情况下返回默认持久委托。默认持久委托假定 type 是一个 JavaBean，这意味着它有一个默认构造方法，其状态通过 Introspector 返回的 "setter" 和 "getter" 方法的匹配对来定义。默认构造方法是有 ConstructorProperties 注释的、参数最多的构造方法。如果没有一个构造方法有 ConstructorProperties 注释，则使用 null 构造方法。例如，在下列语句中，对于 Foo 将使用 null 构造方法；对于 Bar 将使用有两个参数的构造方法。 public class Foo { public Foo() { ... } public Foo(int x) { ... } } public class Bar { public Bar() { ... }

    参数：
    type - 对象类型。
    返回：
    此对象类型的持久委托。
    另请参见：
    setPersistenceDelegate(java.lang.Class, java.beans.PersistenceDelegate),
Introspector.getBeanInfo(java.lang.Class),
BeanInfo.getBeanDescriptor()

setPersistenceDelegate

public void setPersistenceDelegate(Class<?> type,
                                   PersistenceDelegate persistenceDelegate)
将与此 type 相关联的持久委托设置为 persistenceDelegate。

参数：
type - 对其应用 persistenceDelegate 的对象的类。
persistenceDelegate - 用于 type 的实例的持久委托。
另请参见：
getPersistenceDelegate(java.lang.Class),
Introspector.getBeanInfo(java.lang.Class),
BeanInfo.getBeanDescriptor()

remove

public Object remove(Object oldInstance)
移除此实例的条目，返回旧条目。

参数：
oldInstance - 应该移除的条目。
返回：
被移除的条目。
另请参见：
get(java.lang.Object)

get

public Object get(Object oldInstance)
在由此流创建的环境中返回 oldInstance 的一个实验值。持久委托可以使用其 mutatesTo 方法来确定是否可以初始化此值，以便输出时形成等效的对象，或者确定新对象是否必须被重新实例化。如果流未发现此值，则返回 null。

参数：
oldInstance - 要查找的实例。
返回：
该对象，如果以前没有看见该对象，则返回 null。

writeStatement

public void writeStatement(Statement oldStm)
将语句 oldStm 写入流中。oldStm 应该完全根据调用者环境写入，也就是说，目标和所有参数都应该是将被写入的对象图形的一部分。这些表达式表示一系列的“发生了什么”表达式，告知输出流如何生成类似源对象图形的对象图形。

此方法的实现将产生另一个表达式，它表示读取流时将存在的环境中的同一表达式。通过在目标和所有参数上调用 writeObject 并使用结果构建一个新的表达式可以做到这一点。

参数：
oldStm - 要写入流中的表达式。

writeExpression

public void writeExpression(Expression oldExp)
该实现首先查看使用此值的表达式是否已经被写入。如果尚未写入，则使用与 writeStatement 相同的过程复制该表达式，通过调用 writeObject 方法使表达式的值与复制表达式的值一致。

参数：
oldExp - 要写入流中的表达式。
概述  软件包   类  使用  树  已过时  索引  帮助
JavaTM 2 Platform
Standard Ed. 6
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 EventHandler

java.lang.Object
    继承者  java.beans.EventHandler
所有已实现的接口：
InvocationHandler
public class EventHandler
extends Object
implements InvocationHandler

EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。

EventHandler 类由交互工具（比如应用程序生成器）使用，这些工具允许开发人员在 bean 之间建立连接。通常是建立从用户界面 bean（事件 source）到应用程序逻辑 bean（target）的连接。大多数这类有效连接隔离了应用程序逻辑与用户界面。例如，用于从 JCheckBox 到接受 boolean 值的方法之间连接的 EventHandler 可以处理复选框状态的提取，以及处理将其直接传递给该方法，从而使该方法与用户界面层隔离。

内部类是处理来自用户界面的事件的另一种更常见方法。EventHandler 类只处理可能使用内部类的事件的子集。不过，EventHandler 使用长期持久方案要比使用内部类更有效。同样，在同一接口被实现很多次的大型应用程序中，使用 EventHandler 可以减少应用程序的磁盘和内存占用。

使用 EventHandler 创建侦听器占用内存如此之少的原因是，EventHandler 所依赖的 Proxy 类共享了同一接口的实现。例如，如果使用 EventHandler 的 create 方法生成某个应用程序中的所有 ActionListener，则所有动作侦听器都将是单个类（由 Proxy 类创建）的实例。通常，基于 Proxy 类的侦听器要求为每个侦听器类型（接口）创建一个侦听器类，而使用内部类方法时要求为每个侦听器（实现接口的对象）创建一个类。

通常不需要直接处理 EventHandler 实例。相反，可使用 EventHandler 的 create 方法之一创建实现给定侦听器接口的对象。此侦听器对象在后台使用一个 EventHandler 对象来封装关于事件的信息、发生事件时发送消息的对象、要发送的消息（方法）和方法的任意参数。以下部分给出了如何使用 create 方法创建侦听器对象的示例。

使用 EventHandler 的示例

EventHandler 最简单的使用方法是安装一个侦听器，不带参数地在目标对象上调用某个方法。在以下示例中，将创建一个在 javax.swing.JFrame 实例上调用 toFront 方法的 ActionListener。
myButton.addActionListener(
    (ActionListener)EventHandler.create(ActionListener.class, frame, "toFront"));
当按下 myButton 时，将执行 frame.toFront() 语句。通过定义 ActionListener 接口的新实现并将其实例添加到按钮中，用户可以获得同样的效果，且具有额外的编译时类型安全：
//Equivalent code using an inner class instead of EventHandler.
myButton.addActionListener(new ActionListener() {
    public void actionPerformed(ActionEvent e) {
        frame.toFront();
    }
});
EventHandler 的另一种最简单用法是从侦听器接口（通常是一个事件对象）中的方法的第一个参数中提取属性值，并用其设置目标对象中的属性值。在以下示例中，将创建一个 ActionListener，它将目标 (myButton) 对象的 nextFocusableComponent 属性设置为事件的 "source" 属性的值。
EventHandler.create(ActionListener.class, myButton, "nextFocusableComponent", "source")
这将对应于以下内部类实现：
//Equivalent code using an inner class instead of EventHandler.
new ActionListener() {
    public void actionPerformed(ActionEvent e) {
        myButton.setNextFocusableComponent((Component)e.getSource());
    }
}
也可以创建一个只是将传入事件对象传递给目标动作的 EventHandler。如果 EventHandler.create 中的第四个参数为空字符串，则事件的传递方式如下：
EventHandler.create(ActionListener.class, target, "doActionEvent", "")
这将对应于以下内部类实现：
//Equivalent code using an inner class instead of EventHandler.
new ActionListener() {
    public void actionPerformed(ActionEvent e) {
        target.doActionEvent(e);
    }
}
EventHandler 最常见的用法可能是从事件对象的 source 中提取属性值，并将此值设置为目标对象的属性值。在以下示例中，将创建一个 ActionListener，它将目标对象的 "label" 属性设置为事件源的 "text" 属性的值（"source" 属性的值）。
EventHandler.create(ActionListener.class, myButton, "label", "source.text")
这将对应于以下内部类实现：
//Equivalent code using an inner class instead of EventHandler.
new ActionListener {
    public void actionPerformed(ActionEvent e) {
        myButton.setLabel(((JTextField)e.getSource()).getText());
    }
}
可以使用以 "." 字符分隔的任意数量的属性前缀来“限定”事件属性。采用出现在 "." 字符前面的“限定”名称作为将应用于事件对象的属性名称，最左边的最先应用。

例如，以下动作侦听器

EventHandler.create(ActionListener.class, target, "a", "b.c.d")
可以写成以下内部类（假定所有属性都有规范的获取方法并返回适当的类型）：
//Equivalent code using an inner class instead of EventHandler.
new ActionListener {
    public void actionPerformed(ActionEvent e) {
        target.setA(e.getB().getC().isD());
    }
}
也可以使用以 "." 字符分隔的任意数量的属性前缀来“限定”目标属性。例如，以下动作侦听器：
   EventHandler.create(ActionListener.class, target, "a.b", "c.d")
可以写成以下内部类（假定所有属性都有规范的获取方法并返回适当的类型）：
   //Equivalent code using an inner class instead of EventHandler.
   new ActionListener {
     public void actionPerformed(ActionEvent e) {
         target.getA().setB(e.getC().isD());
    }
}

由于 EventHandler 最终依赖反射来调用方法，所以建议不要以重载方法为目标。 例如，如果目标是类 MyTarget 的一个实例，而 MyTarget 定义如下：

   public class MyTarget {
     public void doIt(String);
     public void doIt(Object);
   }
那么方法 doIt 被重载。EventHandler 将基于源调用恰当的方法。如果源为 null，那么两个方法都可以，具体调用哪个方法是不确定的。因此，建议不要以重载方法为目标。

从以下版本开始：
1.4
另请参见：
Proxy, EventObject

构造方法摘要
EventHandler(Object target, String action, String eventPropertyName, String listenerMethodName)
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。
方法摘要
static
<T> T
create(Class<T> listenerInterface, Object target, String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。
static
<T> T
create(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
static
<T> T
create(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
 String getAction()
返回此事件处理程序将设置的目标的可写属性名称，或者此事件处理程序将在目标上调用的方法名称。
 String getEventPropertyName()
返回应该在应用于目标的动作中使用的事件属性。
 String getListenerMethodName()
返回将触发动作的属性名称。
 Object getTarget()
返回此事件处理程序将为其发送消息的对象。
 Object invoke(Object proxy, Method method, Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventHandler

public EventHandler(Object target,
                    String action,
                    String eventPropertyName,
                    String listenerMethodName)
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。有关 eventPropertyName 和 listenerMethodName 参数的完整描述，请参考 create 的一般形式。

参数：
target - 将执行动作的对象
action - 目标上属性或方法的（可能受限定的）名称
eventPropertyName - 传入事件的可读属性的（可能受限定的）名称
listenerMethodName - 应该触发该动作的侦听器接口中的方法名称
另请参见：
EventHandler,
create(Class, Object, String, String, String),
getTarget(),
getAction(),
getEventPropertyName(),
getListenerMethodName()
方法详细信息

getTarget

public Object getTarget()
返回此事件处理程序将为其发送消息的对象。

返回：
此事件处理程序的目标
另请参见：
EventHandler(Object, String, String, String)

getAction

public String getAction()
返回此事件处理程序将设置的目标的可写属性名称，或者此事件处理程序将在目标上调用的方法名称。

返回：
此事件处理程序的动作
另请参见：
EventHandler(Object, String, String, String)

getEventPropertyName

public String getEventPropertyName()
返回应该在应用于目标的动作中使用的事件属性。

返回：
事件属性
另请参见：
EventHandler(Object, String, String, String)

getListenerMethodName

public String getListenerMethodName()
返回将触发动作的属性名称。返回值为 null 表示侦听器接口中的所有方法都将触发该动作。

返回：
将触发该动作的方法名称
另请参见：
EventHandler(Object, String, String, String)

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。

指定者：
接口 InvocationHandler 中的 invoke
参数：
proxy - 代理对象
method - 侦听器接口中的方法
arguments - 包含传入代理实例上方法调用的参数值的对象数组，如果接口方法不使用参数，则为 null。基本类型的参数被包装在适当基本包装器类（如 java.lang.Integer 或 java.lang.Boolean）的实例中。
返回：
对目标应用该操作的结果
另请参见：
EventHandler

create

public static <T> T create(Class<T> listenerInterface,
                           Object target,
                           String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。此方法是通过调用其他更常见的 create 方法实现来实现的，其中 eventPropertyName 和 listenerMethodName 都采用 null 值。有关 action 参数的完整描述，请参考 create 的一般形式。

要创建一个使用 dialog.show() 显示 JDialog 的 ActionListener，用户可以编写以下代码：

EventHandler.create(ActionListener.class, dialog, "show")

参数：
listenerInterface - 要为其创建代理的侦听器接口
target - 将执行动作的对象
action - 目标上的某个方法或（可能受限定的）属性的名称
返回：
实现 listenerInterface 的对象
抛出：
NullPointerException - 如果 listenerInterface 为 null
NullPointerException - 如果 target 为 null
NullPointerException - 如果 action 为 null
另请参见：
create(Class, Object, String, String)

create

public static <T> T create(Class<T> listenerInterface,
                           Object target,
                           String action,
                           String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。此方法是通过调用更常见的 create 方法实现来实现的，其中 listenerMethodName 采用 null 值。有关 action 和 eventPropertyName 参数的完整描述，请参考 create 的一般形式。

要创建一个将 JLabel 的文本设置为传入事件 JTextField 源的文本值的 ActionListener，可以使用以下代码：

EventHandler.create(ActionListener.class, label, "text", "source.text");
这等同于以下代码：
//Equivalent code using an inner class instead of EventHandler.
new ActionListener() {
    public void actionPerformed(ActionEvent event) {
        label.setText(((JTextField)(event.getSource())).getText());
     }
};

参数：
listenerInterface - 要为其创建代理的侦听器接口
target - 将执行动作的对象
action - 目标上的某个（可能受限定的）属性或方法的名称
eventPropertyName - 传入事件的某个可读属性的（可能受限定的）名称
返回：
实现 listenerInterface 的对象
抛出：
NullPointerException - 如果 listenerInterface 为 null
NullPointerException - 如果 target 为 null
NullPointerException - 如果 action 为 null
另请参见：
create(Class, Object, String, String, String)

create

public static <T> T create(Class<T> listenerInterface,
                           Object target,
                           String action,
                           String eventPropertyName,
                           String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。其他所有侦听器方法不执行任何操作。

eventPropertyName 字符串用来从传递给目标方法的传入事件对象中提取值。一般情况下目标方法不带任何参数，在这种情况下 eventPropertyName 应该使用 null 值。此外，如果希望传入事件对象直接传递给目标方法，则应该使用空字符串。eventPropertyName 字符串的格式是一个方法或属性序列，其中从传入事件对象开始，每一个方法或属性都应用于前一个方法所返回的值。语法如下：propertyName{.propertyName}* 其中 propertyName 与方法或属性匹配。例如，要从 MouseEvent 中提取 point 属性，可以使用 "point" 或 "getPoint" 作为 eventPropertyName。要从具有 JLabel 源的 MouseEvent 中提取 "text" 属性，可以使用以下值之一作为 eventPropertyName："source.text"、"getSource.text"、"getSource.getText" 或者 "source.getText"。如果无法找到某个方法，或者作为调用方法的过程中生成某个异常，则在指派时将抛出 RuntimeException。例如，如果传入事件对象为 null，且 eventPropertyName 为非 null 或非空，则将抛出 RuntimeException。

action 参数的格式与 eventPropertyName 参数相同，其中最后一个属性名标识一个方法名或可写属性。

如果 listenerMethodName 为 null，则接口中的所有 方法都会触发将在 target 上执行的 action。

例如，要创建一个 MouseListener，使其在每次按下鼠标按键时，都将目标对象的 origin 属性设置为传入 MouseEvent 的位置（即 mouseEvent.getPoint() 的值），则应编写以下代码：

EventHandler.create(MouseListener.class, "mousePressed", target, "origin", "point");
这相当于编写一个 MouseListener，其中除 mousePressed 以外的所有方法都是无操作：
//Equivalent code using an inner class instead of EventHandler.
new MouseAdapter() {
    public void mousePressed(MouseEvent e) {
        target.setOrigin(e.getPoint());
    }
}

参数：
listenerInterface - 要为其创建代理的侦听器接口
target - 将执行动作的对象
action - 目标上的某个（可能受限制的）属性或方法的名称
eventPropertyName - 传入事件的某个可读属性的（可能受限定的）名称
listenerMethodName - 应触发该动作的侦听器接口中的方法名称
返回：
实现 listenerInterface 的对象
抛出：
NullPointerException - 如果 listenerInterface 为 null
NullPointerException - 如果 target 为 null
NullPointerException - 如果 action 为 null
另请参见：
EventHandler
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventSetDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 EventSetDescriptor

java.lang.Object
    继承者  java.beans.FeatureDescriptor
        继承者  java.beans.EventSetDescriptor

public class EventSetDescriptor
extends FeatureDescriptor

描述给定 Java bean 激发的一组事件的 EventSetDescriptor。

给定的事件组都是作为方法调用在单个事件侦听器接口上传递的，事件侦听器对象可以通过调用事件源提供的注册方法进行注册。

构造方法摘要
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
方法摘要
Method | getAddListenerMethod() 获得用来添加事件侦听器的方法。
Method | getGetListenerMethod() 获得用来访问已注册事件侦听器的方法。
MethodDescriptor[] | getListenerMethodDescriptors() 获得目标侦听器接口的 MethodDescriptor。
Method[] | getListenerMethods() 获得目标侦听器接口的方法。
Class<?> | getListenerType() 获得目标接口的 Class 对象。
Method | getRemoveListenerMethod() 获得用来移除事件侦听器的方法。
boolean | isInDefaultEventSet() 报告事件集是否在“默认”集合中。
boolean | isUnicast() 通常事件源是多播的。
void | setInDefaultEventSet(boolean inDefaultEventSet) 将事件集标记为“默认”集合（或非默认集合）。
void | setUnicast(boolean unicast) 将事件集标记为单播（或非单播）。
从类 java.beans.FeatureDescriptor 继承的方法
attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventSetDescriptor

public EventSetDescriptor(Class<?> sourceClass,
                          String eventSetName,
                          Class<?> listenerType,
                          String listenerMethodName)
                   throws IntrospectionException
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。

参数：
sourceClass - 激发事件的类。
eventSetName - 事件的编程名称。例如 "fred"。注意，此参数通常应该以小写字母开头。
listenerType - 事件将被传递到的目标接口。
listenerMethodName - 事件传递到其目标侦听器接口时调用的方法。
抛出：
IntrospectionException - 如果在内省期间发生异常。

EventSetDescriptor

public EventSetDescriptor(Class<?> sourceClass,
                          String eventSetName,
                          Class<?> listenerType,
                          String[] listenerMethodNames,
                          String addListenerMethodName,
                          String removeListenerMethodName)
                   throws IntrospectionException
使用字符串名称从头开始创建 EventSetDescriptor。

参数：
sourceClass - 激发事件的类。
eventSetName - 事件集的编程名称。注意，此参数通常应该以小写字母开头。
listenerType - 事件将被传递到的目标接口的 Class。
listenerMethodNames - 事件传递到其目标侦听器接口时调用的方法的名称。
addListenerMethodName - 可用来注册事件侦听器对象的事件源上的方法名称。
removeListenerMethodName - 可用来取消注册事件侦听器对象的事件源上的方法名称。
抛出：
IntrospectionException - 如果在内省期间发生异常。

EventSetDescriptor

public EventSetDescriptor(Class<?> sourceClass,
                          String eventSetName,
                          Class<?> listenerType,
                          String[] listenerMethodNames,
                          String addListenerMethodName,
                          String removeListenerMethodName,
                          String getListenerMethodName)
                   throws IntrospectionException
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。

参数：
sourceClass - 激发事件的类。
eventSetName - 事件集的编程名称。注意，此参数通常应该以小写字母开头。
listenerType - 事件将被传递到的目标接口的 Class。
listenerMethodNames - 事件传递到其目标侦听器接口时调用的方法的名称。
addListenerMethodName - 可用来注册事件侦听器对象的事件源上的方法名称。
removeListenerMethodName - 可用来取消注册事件侦听器对象的事件源上的方法名称。
getListenerMethodName - 可用来访问事件侦听器对象数组的事件源上的方法。
抛出：
IntrospectionException - 如果在内省期间发生异常。
从以下版本开始：
1.4

EventSetDescriptor

public EventSetDescriptor(String eventSetName,
                          Class<?> listenerType,
                          Method[] listenerMethods,
                          Method addListenerMethod,
                          Method removeListenerMethod)
                   throws IntrospectionException
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

参数：
eventSetName - 事件集的编程名称。
listenerType - 侦听器接口的 Class。
listenerMethods - 描述处理目标侦听器中方法的每个事件的 Method 对象数组。
addListenerMethod - 可用来注册事件侦听器对象的事件源上的方法。
removeListenerMethod - 可用来取消注册事件侦听器对象的事件源上的方法。
抛出：
IntrospectionException - 如果在内省期间发生异常。

EventSetDescriptor

public EventSetDescriptor(String eventSetName,
                          Class<?> listenerType,
                          Method[] listenerMethods,
                          Method addListenerMethod,
                          Method removeListenerMethod,
                          Method getListenerMethod)
                   throws IntrospectionException
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

参数：
eventSetName - 事件集的编程名称。
listenerType - 侦听器接口的 Class。
listenerMethods - 描述处理目标侦听器中方法的每个事件的 Method 对象数组。
addListenerMethod - 可用来注册事件侦听器对象的事件源上的方法。
removeListenerMethod - 可用来取消注册事件侦听器对象的事件源上的方法。
getListenerMethod - 可用来访问事件侦听器对象数组的事件源上的方法。
抛出：
IntrospectionException - 如果在内省期间发生异常。
从以下版本开始：
1.4

EventSetDescriptor

public EventSetDescriptor(String eventSetName,
                          Class<?> listenerType,
                          MethodDescriptor[] listenerMethodDescriptors,
                          Method addListenerMethod,
                          Method removeListenerMethod)
                   throws IntrospectionException
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

参数：
eventSetName - 事件集的编程名称。
listenerType - 侦听器接口的 Class。
listenerMethodDescriptors - 描述处理目标侦听器中方法的每个事件的 MethodDescriptor 对象数组。
addListenerMethod - 可用来注册事件侦听器对象的事件源上的方法。
removeListenerMethod - 可用来取消注册事件侦听器对象的事件源上的方法。
抛出：
IntrospectionException - 如果在内省期间发生异常。
方法详细信息

getListenerType

public Class<?> getListenerType()
获得目标接口的 Class 对象。

返回：
激发事件时将调用的目标接口的 Class 对象。

getListenerMethods

public Method[] getListenerMethods()
获得目标侦听器接口的方法。

返回：
激发事件时将调用的目标侦听器接口中目标方法的 Method 对象数组。

getListenerMethodDescriptors

public MethodDescriptor[] getListenerMethodDescriptors()
获得目标侦听器接口的 MethodDescriptor。

返回：
激发事件时将调用的目标侦听器接口中目标方法的 MethodDescriptor 对象数组。

getAddListenerMethod

public Method getAddListenerMethod()
获得用来添加事件侦听器的方法。

返回：
用来在事件源注册侦听器的方法。

getRemoveListenerMethod

public Method getRemoveListenerMethod()
获得用来移除事件侦听器的方法。

返回：
用来在事件源移除侦听器的方法。

getGetListenerMethod

public Method getGetListenerMethod()
获得用来访问已注册事件侦听器的方法。

返回：
用来访问事件源处的侦听器数组的方法，如果不存在侦听器，则返回 null。
从以下版本开始：
1.4

setUnicast

public void setUnicast(boolean unicast)
将事件集标记为单播（或非单播）。

参数：
unicast - 如果事件集是单播的，则该参数为 true。

isUnicast

public boolean isUnicast()
通常事件源是多播的。不过也有是严格单播的一些例外。

返回：
如果事件集是单播的，则返回 true。默认值为 false。

setInDefaultEventSet

public void setInDefaultEventSet(boolean inDefaultEventSet)
将事件集标记为“默认”集合（或非默认集合）。默认情况下，该值为 true。

参数：
inDefaultEventSet - 如果事件集在“默认”集合中，则该参数为 true，否则为 false

isInDefaultEventSet

public boolean isInDefaultEventSet()
报告事件集是否在“默认”集合中。

返回：
如果事件集在“默认”集合中，则返回 true。默认值为 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExceptionListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 ExceptionListener

public interface ExceptionListener

ExceptionListener 是在发生内部异常时获得通知。

从以下版本开始：
1.4

方法摘要
 void exceptionThrown(Exception e)
此方法在捕获可恢复的异常时调用。

方法详细信息

exceptionThrown

void exceptionThrown(Exception e)
此方法在捕获可恢复的异常时调用。

参数：
e - 被捕获的异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Expression (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 Expression

java.lang.Object
    继承者  java.beans.Statement
        继承者  java.beans.Expression

public class Expression
extends Statement

Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。

除了超类的属性之外，Expression 对象还提供了一个值，它是在对这个表达式进行求值时所返回的对象。返回值通常不由调用者提供，而是通过动态查找方法并在第一次调用 getValue 时调用查找到的方法来计算。

从以下版本开始：
1.4
另请参见：
getValue(), setValue(java.lang.Object)

构造方法摘要
Expression(Object value, Object target, String methodName, Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。
Expression(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。
方法摘要
Object | getValue() 如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。
void | setValue(Object value) 将此表达式的值设置为 value。
String | toString() 使用 Java 风格的语法打印此表达式的值。
从类 java.beans.Statement 继承的方法
execute, getArguments, getMethodName, getTarget
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Expression

public Expression(Object target,
                  String methodName,
                  Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

参数：
target - 此表达式的 target。
methodName - 此表达式的 methodName。
arguments - 此表达式的 arguments。如果该参数为 null，则使用一个空数组。
另请参见：
getValue()

Expression

public Expression(Object value,
                  Object target,
                  String methodName,
                  Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。但是永远都不会计算结果，因为此构造方法通过调用 setValue 方法，使用 value 参数来设置 value 属性。

参数：
value - 此表达式的 value。
target - 此表达式的 target。
methodName - 此表达式的 methodName。
arguments - 此表达式的 arguments。如果该参数为 null，则使用一个空数组。
另请参见：
setValue(java.lang.Object)
方法详细信息

getValue

public Object getValue()
                throws Exception
如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。方法调用的结果首先被复制到此表达式的 value 属性中，然后作为 getValue 的结果返回。如果通过调用 setValue 或因为以前调用 getValue 已经设置 value 属性，则返回该 value 属性，无需查找或调用该方法。

默认情况下，Expression 的 value 属性被设置为唯一私有（非 null）值，此值被用作指示该方法尚未被调用的内部指示。返回值 null 将替代此默认值，其他任何值也是如此操作，以确保表达式不会被多次求值。

关于如何使用动态类型的 target 和 arguments 选择方法的细节，请参见 excecute 方法。

返回：
对这些 arguments 应用此方法的结果。
抛出：
Exception
另请参见：
Statement.execute(), setValue(java.lang.Object)

setValue

public void setValue(Object value)
将此表达式的值设置为 value。此值将由 getValue 方法返回，无需调用与此表达式相关联的方法。

参数：
value - 此表达式的 value。
另请参见：
getValue()

toString

public String toString()
使用 Java 风格的语法打印此表达式的值。

覆盖：
类 Statement 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FeatureDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 FeatureDescriptor

java.lang.Object
    继承者  java.beans.FeatureDescriptor
直接已知子类：
BeanDescriptor, EventSetDescriptor, MethodDescriptor, ParameterDescriptor, PropertyDescriptor
public class FeatureDescriptor
extends Object

FeatureDescriptor 类是 PropertyDescriptor、EventSetDescriptor 和 MethodDescriptor 等的公共基类。

它支持一些可以设置和检索任意的内省描述符的公共信息。

此外，它还提供了一种扩展机制，从而任意属性/值对都可以与设计特性相关联。

构造方法摘要
FeatureDescriptor()
构造一个 FeatureDescriptor。
方法摘要
Enumeration<String> | attributeNames() 获得与语言环境无关的此特性名称的枚举。
String | getDisplayName() 获得此特性的本地化显示名称。
String | getName() 获得此特性的编程名称。
String | getShortDescription() 获得此特性的简短描述。
Object | getValue(String attributeName) 利用此特性检索指定属性。
boolean | isExpert() "expert" 标志用于区分那些打算供高级用户使用的特性与那些打算供普通用户使用的特性。
boolean | isHidden() "hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。
boolean | isPreferred() "preferred" 标志用于标识呈现给用户的特别重要的特性。
void | setDisplayName(String displayName) 设置此特性的本地化显示名称。
void | setExpert(boolean expert) "expert" 标志用于区分打算供高级用户使用的特性和那些打算供普通用户使用的特性。
void | setHidden(boolean hidden) "hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。
void | setName(String name) 设置此特性的编程名称。
void | setPreferred(boolean preferred) "preferred" 标志用于标识呈现给用户的特别重要的特性。
void | setShortDescription(String text) 可以将简短描述性字符串与某一特性相关联。
void | setValue(String attributeName, Object value) 将某一指定属性与此特性相关联。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FeatureDescriptor

public FeatureDescriptor()
构造一个 FeatureDescriptor。

方法详细信息

getName

public String getName()
获得此特性的编程名称。

返回：
属性/方法/事件的编程名称

setName

public void setName(String name)
设置此特性的编程名称。

参数：
name - 属性/方法/事件的编程名称

getDisplayName

public String getDisplayName()
获得此特性的本地化显示名称。

返回：
属性/方法/事件的本地化显示名称。此名称默认与 getName 返回的编程名称相同。

setDisplayName

public void setDisplayName(String displayName)
设置此特性的本地化显示名称。

参数：
displayName - 属性/方法/事件的本地化显示名称。

isExpert

public boolean isExpert()
"expert" 标志用于区分那些打算供高级用户使用的特性与那些打算供普通用户使用的特性。

返回：
如果此特性只打算供高级用户使用，则返回 true。

setExpert

public void setExpert(boolean expert)
"expert" 标志用于区分打算供高级用户使用的特性和那些打算供普通用户使用的特性。

参数：
expert - 如果此特性只打算供高级用户使用，则该参数为 true。

isHidden

public boolean isHidden()
"hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。

返回：
如果应对人类用户隐藏此特性，则返回 true。

setHidden

public void setHidden(boolean hidden)
"hidden" 标志用于标识只打算供工具使用、不应对人类开放的特性。

参数：
hidden - 如果应对人类用户隐藏此特性，则该参数为 true。

isPreferred

public boolean isPreferred()
"preferred" 标志用于标识呈现给用户的特别重要的特性。

返回：
如果应该优先向人类用户显示此特性，则返回 true。

setPreferred

public void setPreferred(boolean preferred)
"preferred" 标志用于标识呈现给用户的特别重要的特性。

参数：
preferred - 如果应该优先向人类用户显示此特性，则该参数为 true。

getShortDescription

public String getShortDescription()
获得此特性的简短描述。

返回：
与此属性/方法/事件有关的本地化简短描述。默认简短描述为显示名称。

setShortDescription

public void setShortDescription(String text)
可以将简短描述性字符串与某一特性相关联。这些描述性字符串通常应该少于 40 个字符。

参数：
text - 与此属性/方法/事件有关的（本地化）简短描述。

setValue

public void setValue(String attributeName,
                     Object value)
将某一指定属性与此特性相关联。

参数：
attributeName - 与语言环境无关的属性名称
value - 值。

getValue

public Object getValue(String attributeName)
利用此特性检索指定属性。

参数：
attributeName - 与语言环境无关的属性名称
返回：
属性值。如果属性是未知的，则返回 null。

attributeNames

public Enumeration<String> attributeNames()
获得与语言环境无关的此特性名称的枚举。

返回：
已向 setValue 注册的与语言环境无关的所有属性名称的枚举。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndexedPropertyChangeEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 IndexedPropertyChangeEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.beans.PropertyChangeEvent
            继承者  java.beans.IndexedPropertyChangeEvent
所有已实现的接口：
Serializable
public class IndexedPropertyChangeEvent
extends PropertyChangeEvent

无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。此类是 PropertyChangeEvent 的扩展，但它包含已更改属性的索引。

如果旧值和新值的真实值是未知的，则可能为它们提供 null 值。

事件源可能发送一个 null 对象作为名称，以指示其属性的任意事件集已更改。在这种情况下，旧值和新值应该仍然为 null。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
IndexedPropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue, int index)
构造一个新的 IndexedPropertyChangeEvent 对象。
方法摘要
 int getIndex()
获得被更改属性的索引。
从类 java.beans.PropertyChangeEvent 继承的方法
getNewValue, getOldValue, getPropagationId, getPropertyName, setPropagationId
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IndexedPropertyChangeEvent

public IndexedPropertyChangeEvent(Object source,
                                  String propertyName,
                                  Object oldValue,
                                  Object newValue,
                                  int index)
构造一个新的 IndexedPropertyChangeEvent 对象。

参数：
source - 激发事件的 bean。
propertyName - 被更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。
index - 被更改属性元素的索引。
方法详细信息

getIndex

public int getIndex()
获得被更改属性的索引。

返回：
指定被更改属性元素的索引。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndexedPropertyDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 IndexedPropertyDescriptor

java.lang.Object
    继承者  java.beans.FeatureDescriptor
        继承者  java.beans.PropertyDescriptor
            继承者  java.beans.IndexedPropertyDescriptor

public class IndexedPropertyDescriptor
extends PropertyDescriptor

IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。

索引 (indexed) 属性还可以提供简单的非索引读和写方法。如果存在这些方法，它们可读取和写入索引读方法所返回类型的读写数组。

构造方法摘要
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass)
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。
IndexedPropertyDescriptor(String propertyName, Method readMethod, Method writeMethod, Method indexedReadMethod, Method indexedWriteMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
方法摘要
boolean | equals(Object obj) 将此 PropertyDescriptor 与指定对象比较。
Class<?> | getIndexedPropertyType() 获得索引属性类型的 Class 对象。
Method | getIndexedReadMethod() 获得应该用于读取索引属性值的方法。
Method | getIndexedWriteMethod() 获得应该用于写入索引属性值的方法。
int | hashCode() 返回对象的哈希码值。
void | setIndexedReadMethod(Method readMethod) 设置应该用于读取索引属性值的方法。
void | setIndexedWriteMethod(Method writeMethod) 设置应该用于写入索引属性值的方法。
从类 java.beans.PropertyDescriptor 继承的方法
createPropertyEditor, getPropertyEditorClass, getPropertyType, getReadMethod, getWriteMethod, isBound, isConstrained, setBound, setConstrained, setPropertyEditorClass, setReadMethod, setWriteMethod
从类 java.beans.FeatureDescriptor 继承的方法
attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IndexedPropertyDescriptor

public IndexedPropertyDescriptor(String propertyName,
                                 Class<?> beanClass)
                          throws IntrospectionException
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。

因此，如果参数名为 "fred"，则假定有一个索引 reader 方法 "getFred"、一个也称为 "getFred" 的非索引（数组）reader 方法、一个索引 writer 方法 "setFred" 和一个非索引 writer 方法 "setFred"。

参数：
propertyName - 属性的编程名称。
beanClass - 目标 bean 的 Class 对象。
抛出：
IntrospectionException - 如果在内省期间发生异常。

IndexedPropertyDescriptor

public IndexedPropertyDescriptor(String propertyName,
                                 Class<?> beanClass,
                                 String readMethodName,
                                 String writeMethodName,
                                 String indexedReadMethodName,
                                 String indexedWriteMethodName)
                          throws IntrospectionException
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。

参数：
propertyName - 属性的编程名称。
beanClass - 目标 bean 的 Class 对象。
readMethodName - 用来以数组形式读取属性值的方法的名称。如果该属性是只写的或是必须建立索引的，则可能返回 null。
writeMethodName - 用来以数组形式写入属性值的方法的名称。如果该属性是只读的或是必须建立索引的，则可能返回 null。
indexedReadMethodName - 用于读取索引属性值的方法的名称。如果属性是只写的，则该参数可能为 null。
indexedWriteMethodName - 用于写入索引属性值的方法的名称。如果属性是只读的，则该参数可能为 null。
抛出：
IntrospectionException - 如果在内省期间发生异常。

IndexedPropertyDescriptor

public IndexedPropertyDescriptor(String propertyName,
                                 Method readMethod,
                                 Method writeMethod,
                                 Method indexedReadMethod,
                                 Method indexedWriteMethod)
                          throws IntrospectionException
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

参数：
propertyName - 属性的编程名称。
readMethod - 用来以数组形式读取属性值的方法。如果该属性是只写的或是必须建立索引的，则可能返回 null。
writeMethod - 用来以数组形式写入属性值的方法。如果该属性是只读的或是必须建立索引的，则可能返回 null。
indexedReadMethod - 用于读取索引属性值的方法。如果属性是只写的，则该参数可能为 null。
indexedWriteMethod - 用于写入索引属性值的方法。如果属性是只读的，则该参数可能为 null。
抛出：
IntrospectionException - 如果在内省期间发生异常。
方法详细信息

getIndexedReadMethod

public Method getIndexedReadMethod()
获得应该用于读取索引属性值的方法。

返回：
应该用于读取索引属性值的方法。如果该属性没有建立索引或是只写的，则可能返回 null。

setIndexedReadMethod

public void setIndexedReadMethod(Method readMethod)
                          throws IntrospectionException
设置应该用于读取索引属性值的方法。

参数：
readMethod - 新的索引读取方法。
抛出：
IntrospectionException

getIndexedWriteMethod

public Method getIndexedWriteMethod()
获得应该用于写入索引属性值的方法。

返回：
应该用于写入索引属性值的方法。如果该属性没有建立索引或是只读的，则可能返回 null。

setIndexedWriteMethod

public void setIndexedWriteMethod(Method writeMethod)
                           throws IntrospectionException
设置应该用于写入索引属性值的方法。

参数：
writeMethod - 新的索引写入方法。
抛出：
IntrospectionException

getIndexedPropertyType

public Class<?> getIndexedPropertyType()
获得索引属性类型的 Class 对象。返回的 Class 可能描述诸如 int 的基本类型。

返回：
用于索引属性类型的 Class；如果类型无法确定，则可能返回 null。

equals

public boolean equals(Object obj)
将此 PropertyDescriptor 与指定对象比较。如果对象是相同的，则返回 true。如果读取、写入、属性类型、属性编辑器和标记都是等同的，则两个 PropertyDescriptor 是相同的。

覆盖：
类 PropertyDescriptor 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
从以下版本开始：
1.4
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回对象的哈希码值。关于完整的描述，请参阅 Object.hashCode()。

覆盖：
类 PropertyDescriptor 中的 hashCode
返回：
此对象的哈希码值。
从以下版本开始：
1.5
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IntrospectionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 IntrospectionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.beans.IntrospectionException
所有已实现的接口：
Serializable
public class IntrospectionException
extends Exception

在 Introspection 期间发生异常时抛出异常。

典型的 cause 包括：无法将字符串类名称映射到 Class 对象、无法解析字符串方法名，或者指定对其用途而言具有错误类型签名的方法名称。

另请参见：
序列化表格

构造方法摘要
IntrospectionException(String mess)
构造带详细消息的 IntrospectionException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IntrospectionException

public IntrospectionException(String mess)
构造带详细消息的 IntrospectionException。

参数：
mess - 描述性消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Introspector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 Introspector

java.lang.Object
    继承者  java.beans.Introspector

public class Introspector
extends Object

Introspector 类为通过工具学习有关受目标 Java Bean 支持的属性、事件和方法的知识提供了一个标准方法。

对于这三种信息，Introspector 将分别分析 bean 的类和超类，寻找显式或隐式信息，使用这些信息构建一个全面描述目标 bean 的 BeanInfo 对象。

对于每个 "Foo" 类，如果存在相应的 "FooBeanInfo" 类，显式信息可能是可用的，查询这些信息时，FooBeanInfo 类会提供一个非 null 值。通过获得目标 bean 类的完全受限定包名称并追加 "BeanInfo" 形成一个新类，首先查找 BeanInfo 类。如果此操作失败，则采用此名称的最终类名称组件，在 BeanInfo 包搜索路径中指定的每个包中搜索该类。

因此对于某个类，比如说 "sun.xyz.OurButton"，首先需要查找称为 "sun.xyz.OurButtonBeanInfo" 的 BeanInfo 类，如果失败，则查找 BeanInfo 搜索路径中的每个包来搜索 OurButtonBeanInfo 类。对于默认搜索路径，这意味着将查找 "sun.beans.infos.OurButtonBeanInfo"。

如果某个类提供有关其自身的显式 BeanInfo，则将它添加到从分析所有派生类得到的 BeanInfo 信息中，并将显式信息视为当前类及其基类的确定的信息，无需进一步深入超类链进行分析。

如果没有在某个类上发现显式 BeanInfo，则使用低层次的反射来研究类的方法，并应用标准设计模式来标识属性存储器、事件源或公共方法。然后深入分析类的超类，从它那里（可能在超类链的顶部）添加信息。

因为 Introspector 缓存 BeanInfo 类来获得更好的性能，所以如果在使用多个类加载器的应用程序中使用它，则需小心谨慎。通常，在破坏一个已用于 introspect 类的 ClassLoader 时，应使用 Introspector.flushCaches 或 Introspector.flushFromCaches 方法从缓存中清除所有内省的类。

有关内省和设计模式的更多信息，请参阅 JavaBeans specification。

字段摘要
static int | IGNORE_ALL_BEANINFO
static int | IGNORE_IMMEDIATE_BEANINFO
static int | USE_ALL_BEANINFO
方法摘要
static String | decapitalize(String name) 获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。
static void | flushCaches() 刷新所有 Introspector 的内部缓存。
static void | flushFromCaches(Class<?> clz) 刷新给定类的 Introspector 的内部缓存信息。
static BeanInfo | getBeanInfo(Class<?> beanClass) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
static BeanInfo | getBeanInfo(Class<?> beanClass, Class<?> stopClass) 在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo | getBeanInfo(Class<?> beanClass, int flags) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。
static String[] | getBeanInfoSearchPath() 获得将用来查找 BeanInfo 类的包名称的列表。
static void | setBeanInfoSearchPath(String[] path) 更改将用来查找 BeanInfo 类的包名称的列表。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

USE_ALL_BEANINFO

public static final int USE_ALL_BEANINFO
另请参见：
常量字段值

IGNORE_IMMEDIATE_BEANINFO

public static final int IGNORE_IMMEDIATE_BEANINFO
另请参见：
常量字段值

IGNORE_ALL_BEANINFO

public static final int IGNORE_ALL_BEANINFO
另请参见：
常量字段值
方法详细信息

getBeanInfo

public static BeanInfo getBeanInfo(Class<?> beanClass)
                            throws IntrospectionException
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。

如果 Java Bean 的 BeanInfo 类以前已经被内省，则从 BeanInfo 缓存中检索 BeanInfo 类。

参数：
beanClass - 将要分析的 bean 类。
返回：
描述目标 bean 的 BeanInfo 对象。
抛出：
IntrospectionException - 如果在内省期间发生异常。
另请参见：
flushCaches(), flushFromCaches(java.lang.Class)

getBeanInfo

public static BeanInfo getBeanInfo(Class<?> beanClass,
                                   int flags)
                            throws IntrospectionException
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。

如果 Java Bean 的 BeanInfo 类以前已经基于相同的参数被内省，则从 BeanInfo 缓存中检索 BeanInfo 类。

参数：
beanClass - 将要分析的 bean 类。
flags - 控制内省的标记。如果 flags == USE_ALL_BEANINFO，则使用可以发现的所有 BeanInfo 类。如果 flags == IGNORE_IMMEDIATE_BEANINFO，则忽略与指定 beanClass 相关联的任何 BeanInfo。如果 flags == IGNORE_ALL_BEANINFO，则忽略与指定 beanClass 相关联的所有 BeanInfo 及其所有父类。
返回：
描述目标 bean 的 BeanInfo 对象。
抛出：
IntrospectionException - 如果在内省期间发生异常。

getBeanInfo

public static BeanInfo getBeanInfo(Class<?> beanClass,
                                   Class<?> stopClass)
                            throws IntrospectionException
在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。

如果 Java Bean 的 BeanInfo 类以前已经基于相同的参数被内省，则从 BeanInfo 缓存中检索 BeanInfo 类。

参数：
beanClass - 将要分析的 bean 类。
stopClass - 从其所在位置开始停止分析的基类。stopClass 或其基类中的所有方法/属性/事件都将在分析中被忽略。
抛出：
IntrospectionException - 如果在内省期间发生异常。

decapitalize

public static String decapitalize(String name)
获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。这通常意味着将首字符从大写转换成小写，但在（不平常的）特殊情况下，当有多个字符且第一个和第二个字符都是大写字符时，不执行任何操作。

因此 "FooBah" 变成 "fooBah"，"X" 变成 "x"，但 "URL" 仍然是 "URL"。

参数：
name - 要取消大写化的字符串。
返回：
取消大写化的字符串。

getBeanInfoSearchPath

public static String[] getBeanInfoSearchPath()
获得将用来查找 BeanInfo 类的包名称的列表。

返回：
为了查找 BeanInfo 类而被搜索的包名称数组。此数组的默认值与实现有关，例如 Sun 实现最初设置为 {"sun.beans.infos"}。

setBeanInfoSearchPath

public static void setBeanInfoSearchPath(String[] path)
更改将用来查找 BeanInfo 类的包名称的列表。如果参数 path 为 null，则此方法的行为是未定义的。

如果有安全管理器，则首先调用其 checkPropertiesAccess 方法。这可能会导致 SecurityException 异常。

参数：
path - 包名称数组。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许设置系统属性。
另请参见：
SecurityManager.checkPropertiesAccess()

flushCaches

public static void flushCaches()
刷新所有 Introspector 的内部缓存。通常不需要此方法。通常只有高级工具才需要使用此方法，这些工具需要在适当的位置更新现有的 "Class" 对象，并需要使 Introspector 重新分析现有的 Class 对象。

flushFromCaches

public static void flushFromCaches(Class<?> clz)
刷新给定类的 Introspector 的内部缓存信息。通常不需要此方法。通常只有高级工具才需要使用此方法，这些工具需要在适当的位置更新现有的 "Class" 对象，并需要使 Introspector 重新分析现有的 Class 对象。 注意，只刷新与目标 Class 对象有关联的直接状态。不需要刷新具有相同名称的其他 Class 对象的状态，也不需要刷新所有相关 Class 对象（比如子类）的状态，这些状态甚至可能包括间接从目标 Class 对象中获得的信息。

参数：
clz - 要刷新的 Class 对象。
抛出：
NullPointerException - 如果 Class 对象为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MethodDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 MethodDescriptor

java.lang.Object
    继承者  java.beans.FeatureDescriptor
        继承者  java.beans.MethodDescriptor

public class MethodDescriptor
extends FeatureDescriptor

MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。

构造方法摘要
MethodDescriptor(Method method)
根据 Method 构造一个 MethodDescriptor。
MethodDescriptor(Method method, ParameterDescriptor[] parameterDescriptors)
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。
方法摘要
Method | getMethod() 获得此 MethodDescriptor 封装的方法。
ParameterDescriptor[] | getParameterDescriptors() 获得此 MethodDescriptor 每个方法参数的 ParameterDescriptor。
从类 java.beans.FeatureDescriptor 继承的方法
attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MethodDescriptor

public MethodDescriptor(Method method)
根据 Method 构造一个 MethodDescriptor。

参数：
method - 低级方法信息。

MethodDescriptor

public MethodDescriptor(Method method,
                        ParameterDescriptor[] parameterDescriptors)
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。

参数：
method - 低级方法信息。
parameterDescriptors - 每个方法参数的描述性信息。
方法详细信息

getMethod

public Method getMethod()
获得此 MethodDescriptor 封装的方法。

返回：
方法的低级描述

getParameterDescriptors

public ParameterDescriptor[] getParameterDescriptors()
获得此 MethodDescriptor 每个方法参数的 ParameterDescriptor。

返回：
与语言环境无关的参数名。如果参数名是未知的，则可能返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParameterDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 ParameterDescriptor

java.lang.Object
    继承者  java.beans.FeatureDescriptor
        继承者  java.beans.ParameterDescriptor

public class ParameterDescriptor
extends FeatureDescriptor

ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。

当前所有状态都来自 FeatureDescriptor 基类。

构造方法摘要
ParameterDescriptor()
公共默认构造方法。
方法摘要
从类 java.beans.FeatureDescriptor 继承的方法
attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ParameterDescriptor

public ParameterDescriptor()
公共默认构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PersistenceDelegate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PersistenceDelegate

java.lang.Object
    继承者  java.beans.PersistenceDelegate
直接已知子类：
DefaultPersistenceDelegate
public abstract class PersistenceDelegate
extends Object

PersistenceDelegate 类负责根据类的公共 API 中的方法表示给定类的实例状态。不是根据它完成时的样子，通过（例如）ObjectOutputStream 使用的 readObject 和 writeObject 方法，将持久存储的责任与类本身关联起来，而是让使用此委托模型的类似 XMLEncoder 的流可以拥有不依赖于类本身控制的自己的行为。通常，该类是放置信息的最佳地方，它可以很容易地在此委托方案中表示约定，以完成操作。不过有时会出现这样的情况，单个类中的一个很小的问题阻止了整个对象图形的写入，这可能会使得应用程序开发人员毫无办法，只有试图局部隐藏有问题的类，或使用替代的持久存储技巧。在这种情况下，委托模型提供了一个相关的清理机制，使应用程序开发人员干涉序列化过程的所有部分，不需要对不是应用程序本身一部分的类的实现进行修改。

除了使用委托模型，此持久方案不同于传统序列化方案的地方在于，它需要 writeObject 方法的仿真，而不需要相应的 readObject 方法。根据此公共 API，writeObject 仿真对每个实例编码，并且不需要定义 readObject 仿真，因为读取序列化格式的过程由方法调用的语义定义，正如 Java Language Specification 中展示的那样。打破 writeObject 与 readObject 实现之前的依赖关系，这可能会改变版本，因此它是使此技术产生的档案不受它们所参考类的私有实现更改影响的关键。

持久委托可以控制对象持久性的所有方面，其中包括：

  • 确定某一实例是否可以转变成同一个类的另一个实例。
  • 通过调用公共构造方法或公共工厂方法实例化该对象。
  • 对该对象进行实例化。

从以下版本开始：
1.4
另请参见：
XMLEncoder

构造方法摘要
PersistenceDelegate()
方法摘要
protected void | initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out) 产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。
protected abstract Expression | instantiate(Object oldInstance, Encoder out) 返回其值为 oldInstance 的表达式。
protected boolean | mutatesTo(Object oldInstance, Object newInstance) 如果 oldInstance 的等效 副本可以可以通过应用 newInstance 的一系列语句来创建，则返回 true。
void | writeObject(Object oldInstance, Encoder out) writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PersistenceDelegate

public PersistenceDelegate()
方法详细信息

writeObject

public void writeObject(Object oldInstance,
                        Encoder out)
writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。尽管此方法不是最终方法，但在普通环境下不必为其创建子类。

此实现首先检查流是否已经遇到此对象。接着调用 mutatesTo 方法查看是否可以将从流中返回的候选者转变成 oldInstance 的精确副本。如果可以，则调用 initialize 方法执行初始化。如果不可以，则从流中移除该候选者，并调用 instantiate 方法为此对象创建一个新候选者。

参数：
oldInstance - 将由此表达式创建的实例。
out - 将在其中写入此表达式的流。

mutatesTo

protected boolean mutatesTo(Object oldInstance,
                            Object newInstance)
如果 oldInstance 的等效 副本可以可以通过应用 newInstance 的一系列语句来创建，则返回 true。在此方法的规范中，等效是指修改后的实例其公共 API 中相关方法的行为与 oldInstance 没有区别。[注：在这里使用短语相关 方法而不是使用所有 方法只是因为，为了保证完全正确，类似 hashCode 和 toString 这样的方法阻止大多数类实际产生其实例的无区别副本]。

如果两个实例的类是相同的，则默认行为返回 true。

参数：
oldInstance - 要复制的实例。
newInstance - 要修改的实例。
返回：
如果通过对 oldInstance 进行一系列的修改能够创建 newInstance 的等效副本，则返回 true。

instantiate

protected abstract Expression instantiate(Object oldInstance,
                                          Encoder out)
返回其值为 oldInstance 的表达式。此方法用于描述应该用来创建给定对象的构造方法或工厂方法。例如，用于 Field 类的持久委托的 instantiate 方法可以定义如下：
 Field f = (Field)oldInstance;
 return new Expression(f, f.getDeclaringClass(), "getField", new Object[]{f.getName()});
注意，这里声明了所返回表达式的值，因此该表达式的值（由 getValue 返回）将等于 oldInstance。

参数：
oldInstance - 将由此表达式创建的实例。
out - 将在其中写入此表达式的流。
返回：
值为 oldInstance 的表达式。

initialize

protected void initialize(Class<?> type,
                          Object oldInstance,
                          Object newInstance,
                          Encoder out)
产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。在此方法的规范中，等效是指在该方法返回之后，修改后的实例其公共 API 中所有方法的行为都与 newInstance 没有区别。

该实现通常通过产生一系列涉及 oldInstance 及其公共可用状态的 "what happened" 语句来达到此目的。这些语句使用其 writeExpression 方法发送到输出流中，在输入流读取期间，在模拟输入流状态的复制环境中返回涉及元素的表达式。每个返回的语句都将使用新环境中所存在对象代替旧环境中的所有实例。特别是这些语句目标的引用，开始它们是 oldInstance 的引用，返回时成为 newInstance 的引用。执行这些语句会以新环境中对象的一系列修改的形式，实现两个对象状态的递增调整。到 initialize 方法返回时，则无法通过使用公共 API 来区别两个实例。最重要的是，用来使这些对象看起来相同的步骤顺序将被输出流记录，当刷新流时，将形成实际的输出。

默认实现调用该类型超类的 initialize 方法。

参数：
oldInstance - 要复制的实例。
newInstance - 要修改的实例。
out - 保存所有应该写入的初始化语句的流。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyChangeEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PropertyChangeEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.beans.PropertyChangeEvent
所有已实现的接口：
Serializable
直接已知子类：
IndexedPropertyChangeEvent
public class PropertyChangeEvent
extends EventObject

无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。PropertyChangeEvent 对象被作为参数发送给 PropertyChangeListener 和 VetoableChangeListener 方法。

通常 PropertyChangeEvent 还附带名称和已更改属性的旧值和新值。如果新值是基本类型（比如 int 或 boolean），则必须将它包装为相应的 java.lang.* Object 类型（比如 Integer 或 Boolean）。

如果旧值和新值的真实值是未知的，则可能为它们提供 null 值。

事件源可能发送一个 null 对象作为名称，以指示其属性的任意事件集已更改。在这种情况下，旧值和新值应该仍然为 null。

另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue)
构造一个新的 PropertyChangeEvent。
方法摘要
Object | getNewValue() 获取属性的新值，以 Object 的形式表示。
Object | getOldValue() 获取属性的旧值，以 Object 的形式表示。
Object | getPropagationId() 保留 "propagationId" 字段以供将来使用。
String | getPropertyName() 获取已更改属性的编程名称。
void | setPropagationId(Object propagationId) 设置事件的 propagationId 对象。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PropertyChangeEvent

public PropertyChangeEvent(Object source,
                           String propertyName,
                           Object oldValue,
                           Object newValue)
构造一个新的 PropertyChangeEvent。

参数：
source - 激发事件的 bean。
propertyName - 被更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。
方法详细信息

getPropertyName

public String getPropertyName()
获取已更改属性的编程名称。

返回：
被更改属性的编程名称。如果多个属性被更改，则返回 null。

getNewValue

public Object getNewValue()
获取属性的新值，以 Object 的形式表示。

返回：
属性的新值，以 Object 的形式表示。如果多个属性被更改，则返回 null。

getOldValue

public Object getOldValue()
获取属性的旧值，以 Object 的形式表示。

返回：
属性的旧值，以 Object 的形式表示。如果多个属性被更改，则返回 null。

setPropagationId

public void setPropagationId(Object propagationId)
设置事件的 propagationId 对象。

参数：
propagationId - 事件的 propagationId 对象。

getPropagationId

public Object getPropagationId()
保留 "propagationId" 字段以供将来使用。在 Beans 1.0 中，唯一要求是，如果侦听器捕获一个 PropertyChangeEvent 并随后激发自己的 PropertyChangeEvent，则应该确保将 propagationId 字段从其传入事件传播到其传出事件。

返回：
与绑定/约束 (bound/constrained) 属性更新关联的 propagationId 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 PropertyChangeListener

所有超级接口：
EventListener
所有已知实现类：
BasicButtonListener, BasicColorChooserUI.PropertyHandler, BasicComboBoxUI.PropertyChangeHandler, BasicComboPopup.PropertyChangeHandler, BasicDirectoryModel, BasicInternalFrameTitlePane.PropertyChangeHandler, BasicInternalFrameUI.InternalFramePropertyChangeListener, BasicLabelUI, BasicListUI.PropertyChangeHandler, BasicOptionPaneUI.PropertyChangeHandler, BasicRootPaneUI, BasicScrollBarUI.PropertyChangeHandler, BasicScrollPaneUI.PropertyChangeHandler, BasicSliderUI.PropertyChangeHandler, BasicSplitPaneDivider, BasicSplitPaneUI.PropertyHandler, BasicTabbedPaneUI.PropertyChangeHandler, BasicToolBarUI.PropertyListener, BasicTreeUI.PropertyChangeHandler, BasicTreeUI.SelectionModelPropertyChangeHandler, BeanContextServicesSupport, BeanContextSupport, DefaultTableColumnModel, JList.AccessibleJList, JPopupMenu.AccessibleJPopupMenu, JScrollPane.AccessibleJScrollPane, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, JTable.AccessibleJTable, MetalComboBoxUI.MetalPropertyChangeListener, MetalFileChooserUI.FilterComboBoxModel, MetalLabelUI, MetalRootPaneUI, MetalSliderUI.MetalPropertyListener, MetalToolBarUI.MetalRolloverListener, ProgressMonitor.AccessibleProgressMonitor, PropertyChangeListenerProxy
public interface PropertyChangeListener
extends EventListener

无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。可以向源 bean 注册一个 PropertyChangeListener，以便获得所有绑定 (bound) 属性更改的通知。

方法摘要
 void propertyChange(PropertyChangeEvent evt)
在绑定属性发生更改时调用此方法。

方法详细信息

propertyChange

void propertyChange(PropertyChangeEvent evt)
在绑定属性发生更改时调用此方法。

参数：
evt - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyChangeListenerProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PropertyChangeListenerProxy

java.lang.Object
    继承者  java.util.EventListenerProxy
        继承者  java.beans.PropertyChangeListenerProxy
所有已实现的接口：
PropertyChangeListener, EventListener
public class PropertyChangeListenerProxy
extends EventListenerProxy
implements PropertyChangeListener

扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。可以将此类的实例作为 PropertyChangeListener 添加到某一对象中。

如果该对象有一个 getPropertyChangeListeners() 方法，则返回的数组可以是 PropertyChangeListener 和 PropertyChangeListenerProxy 对象的混合。

从以下版本开始：
1.4
另请参见：
EventListenerProxy

构造方法摘要
PropertyChangeListenerProxy(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 绑定到特定属性的构造方法。
方法摘要
String | getPropertyName() 返回与侦听器相关联的指定属性的名称。
void | propertyChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
从类 java.util.EventListenerProxy 继承的方法
getListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PropertyChangeListenerProxy

public PropertyChangeListenerProxy(String propertyName,
                                   PropertyChangeListener listener)
将 PropertyChangeListener 绑定到特定属性的构造方法。

参数：
listener - 侦听器对象
propertyName - 要侦听的属性的名称。
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent evt)
将属性更改事件转发给侦听器代理。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
evt - 属性更改事件

getPropertyName

public String getPropertyName()
返回与侦听器相关联的指定属性的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyChangeSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PropertyChangeSupport

java.lang.Object
    继承者  java.beans.PropertyChangeSupport
所有已实现的接口：
Serializable
直接已知子类：
SwingPropertyChangeSupport
public class PropertyChangeSupport
extends Object
implements Serializable

这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。可以使用此类的实例作为 bean 的成员字段，并将各种工作委托给它。 此类是可序列化的。在对它进行序列化时，它将保存（并恢复）本身可序列化的所有侦听器。在序列化期间，将跳过所有不可序列化的侦听器。

另请参见：
序列化表格

构造方法摘要
PropertyChangeSupport(Object sourceBean)
构造一个 PropertyChangeSupport 对象。
方法摘要
 void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。
 void addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
为指定的属性向侦听器列表中添加一个 PropertyChangeListener。
 void fireIndexedPropertyChange(String propertyName, int index, boolean oldValue, boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定索引属性更新。
 void fireIndexedPropertyChange(String propertyName, int index, int oldValue, int newValue)
以 int 值形式报告所有已注册侦听器的绑定索引属性更新。
 void fireIndexedPropertyChange(String propertyName, int index, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。
 void firePropertyChange(PropertyChangeEvent evt)
对所有已注册侦听器激发一个现有 PropertyChangeEvent。
 void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定属性更新。
 void firePropertyChange(String propertyName, int oldValue, int newValue)
以 int 值形式报告所有已注册侦听器的绑定属性更新。
 void firePropertyChange(String propertyName, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定属性更新。
 PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 PropertyChangeSupport 对象中的所有侦听器组成的数组。
 PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的列表。
 boolean hasListeners(String propertyName)
检查是否存在特定属性的任何侦听器，包括那些已在所有属性上注册的侦听器。
 void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。
 void removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
为特定属性移除一个 PropertyChangeListener。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PropertyChangeSupport

public PropertyChangeSupport(Object sourceBean)
构造一个 PropertyChangeSupport 对象。

参数：
sourceBean - 作为所有事件的源提供的 bean。
方法详细信息

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。该侦听器是为所有属性注册的。同一侦听器对象可以被添加多次，并且它们被调用的次数与添加它们的次数相同。如果 listener 为 null，则不会抛出异常并且不执行操作。

参数：
listener - 要添加的 PropertyChangeListener

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。如果将 listener 多次添加到同一事件源，则在被移除之后，它至少将被通知一次。如果 listener 为 null，或者从未被添加，则不会抛出异常并且不执行操作。

参数：
listener - 要移除的 PropertyChangeListener

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 PropertyChangeSupport 对象中的所有侦听器组成的数组。

如果已经使用指定属性添加一些侦听器，则返回的数组将是 PropertyChangeListener 和 PropertyChangeListenerProxy 的混合物。如果调用方法对区别侦听器感兴趣，那么它必须测试每个元素，以查看该元素是否是一个 PropertyChangeListenerProxy，然后执行强制转换并检查该参数。

 PropertyChangeListener[] listeners = bean.getPropertyChangeListeners();
 for (int i = 0; i < listeners.length; i++) {
         if (listeners[i] instanceof PropertyChangeListenerProxy) {
     PropertyChangeListenerProxy proxy =
                    (PropertyChangeListenerProxy)listeners[i];
     if (proxy.getPropertyName().equals("foo")) {
       // proxy is a PropertyChangeListener which was associated
       // with the property named "foo"
     }
   }
 }

返回：
添加的所有 PropertyChangeListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
PropertyChangeListenerProxy

addPropertyChangeListener

public void addPropertyChangeListener(String propertyName,
                                      PropertyChangeListener listener)
为指定的属性向侦听器列表中添加一个 PropertyChangeListener。该侦听器只在调用 firePropertyChange 为特定属性命名时调用。可以多次添加同一侦听器对象。对于每个属性，该侦听器被调用的次数与为该属性添加此侦听器的次数相同。如果 propertyName 或 listener 为 null，则不会抛出异常并且不执行操作。

参数：
propertyName - 要侦听的属性的名称。
listener - 要添加的 PropertyChangeListener

removePropertyChangeListener

public void removePropertyChangeListener(String propertyName,
                                         PropertyChangeListener listener)
为特定属性移除一个 PropertyChangeListener。如果将 listener 多次添加到指定属性的同一事件源，则在被移除之后，它至少将被通知一次。如果 propertyName 为 null，则不会抛出异常并且不执行操作。如果 listener 为 null，或者从不为指定属性添加 pcl，则不抛出异常并不执行任何操作。

参数：
propertyName - 已被侦听的属性的名称。
listener - 要移除的 PropertyChangeListener

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的列表。

参数：
propertyName - 将被侦听的属性的名称
返回：
与指定属性相关联的所有 PropertyChangeListener。如果没有添加这样的侦听器，或者 propertyName 为 null，则返回一个空数组。
从以下版本开始：
1.4

firePropertyChange

public void firePropertyChange(String propertyName,
                               Object oldValue,
                               Object newValue)
报告所有已注册侦听器的绑定属性更新。如果新属性和旧属性相同并且是非 null 的，则不会触发事件。

这只是一个用来包装获取 PropertyChangeEvent 值的更一般 firePropertyChange 方法的便捷包装器。

参数：
propertyName - 被更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。

firePropertyChange

public void firePropertyChange(String propertyName,
                               int oldValue,
                               int newValue)
以 int 值形式报告所有已注册侦听器的绑定属性更新。如果新属性和旧属性相同，则不会触发事件。

这只是一个用来包装获取 Object 值的更常见 firePropertyChange 方法的便捷包装器。

参数：
propertyName - 被更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。

firePropertyChange

public void firePropertyChange(String propertyName,
                               boolean oldValue,
                               boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定属性更新。如果新属性和旧属性相同，则不会触发事件。

这只是一个用来包装获取 Object 值的更常见 firePropertyChange 方法的便捷包装器。

参数：
propertyName - 被更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。

firePropertyChange

public void firePropertyChange(PropertyChangeEvent evt)
对所有已注册侦听器激发一个现有 PropertyChangeEvent。如果给定事件的旧值和新值相等并且都是非 null 的，则不会激发事件。

参数：
evt - PropertyChangeEvent 对象。

fireIndexedPropertyChange

public void fireIndexedPropertyChange(String propertyName,
                                      int index,
                                      Object oldValue,
                                      Object newValue)
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。

如果旧值和新值相等并且都是非 null 的，则不会激发事件。

这只是一个用来包装获取 PropertyChangeEvent 值的更一般 firePropertyChange 方法的便捷包装器。

参数：
propertyName - 被更改属性的编程名称。
index - 被更改属性元素的索引。
oldValue - 属性的旧值。
newValue - 属性的新值。
从以下版本开始：
1.5

fireIndexedPropertyChange

public void fireIndexedPropertyChange(String propertyName,
                                      int index,
                                      int oldValue,
                                      int newValue)
以 int 值形式报告所有已注册侦听器的绑定索引属性更新。

如果旧值和新值相等，则不会激发事件。

这只是一个用来包装获取 Object 值的更常见 fireIndexedPropertyChange 方法的便捷包装器。

参数：
propertyName - 被更改属性的编程名称。
index - 被更改属性元素的索引。
oldValue - 属性的旧值。
newValue - 属性的新值。
从以下版本开始：
1.5

fireIndexedPropertyChange

public void fireIndexedPropertyChange(String propertyName,
                                      int index,
                                      boolean oldValue,
                                      boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定索引属性更新。

如果旧值和新值相等，则不会激发事件。

这只是一个用来包装获取 Object 值的更常见 fireIndexedPropertyChange 方法的便捷包装器。

参数：
propertyName - 被更改属性的编程名称。
index - 被更改属性元素的索引。
oldValue - 属性的旧值。
newValue - 属性的新值。
从以下版本开始：
1.5

hasListeners

public boolean hasListeners(String propertyName)
检查是否存在特定属性的任何侦听器，包括那些已在所有属性上注册的侦听器。如果 propertyName 为 null，则只检查所有属性上注册的侦听器。

参数：
propertyName - 属性名。
返回：
如果存在给定属性的一个或多个侦听器，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PropertyDescriptor

java.lang.Object
    继承者  java.beans.FeatureDescriptor
        继承者  java.beans.PropertyDescriptor
直接已知子类：
IndexedPropertyDescriptor
public class PropertyDescriptor
extends FeatureDescriptor

PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。

构造方法摘要
PropertyDescriptor(String propertyName, Class<?> beanClass)
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。
PropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。
PropertyDescriptor(String propertyName, Method readMethod, Method writeMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
方法摘要
PropertyEditor | createPropertyEditor(Object bean) 使用当前属性编辑器类构造一个属性编辑器实例。
boolean | equals(Object obj) 将此 PropertyDescriptor 与指定对象进行比较。
Class<?> | getPropertyEditorClass() 获得已为此属性注册的任何显式 PropertyEditor Class。
Class<?> | getPropertyType() 获得属性的 Class 对象。
Method | getReadMethod() 获得应该用于读取属性值的方法。
Method | getWriteMethod() 获得应该用于写入属性值的方法。
int | hashCode() 返回对象的哈希码。
boolean | isBound() 更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。
boolean | isConstrained() 试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。
void | setBound(boolean bound) 更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。
void | setConstrained(boolean constrained) 试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。
void | setPropertyEditorClass(Class<?> propertyEditorClass) 通常 PropertyEditor 是使用 PropertyEditorManager 找到的。
void | setReadMethod(Method readMethod) 设置应该用于读取属性值的方法。
void | setWriteMethod(Method writeMethod) 设置应该用于写入属性值的方法。
从类 java.beans.FeatureDescriptor 继承的方法
attributeNames, getDisplayName, getName, getShortDescription, getValue, isExpert, isHidden, isPreferred, setDisplayName, setExpert, setHidden, setName, setPreferred, setShortDescription, setValue
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PropertyDescriptor

public PropertyDescriptor(String propertyName,
                          Class<?> beanClass)
                   throws IntrospectionException
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。因此如果参数名为 "fred"，则假定 writer 方法为 "setFred"，reader 方法为 "getFred"（对于 boolean 属性则为 "isFred"）。注意，属性名应该以小写字母开头，而方法名称中的首写字母将是大写的。

参数：
propertyName - 属性的编程名称。
beanClass - 目标 bean 的 Class 对象。例如 sun.beans.OurButton.class。
抛出：
IntrospectionException - 如果在内省期间发生异常。

PropertyDescriptor

public PropertyDescriptor(String propertyName,
                          Class<?> beanClass,
                          String readMethodName,
                          String writeMethodName)
                   throws IntrospectionException
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。

参数：
propertyName - 属性的编程名称。
beanClass - 目标 bean 的 Class 对象。例如 sun.beans.OurButton.class。
readMethodName - 用于读取属性值的方法名称。如果属性是只写的，则该参数可能为 null。
writeMethodName - 用于写入属性值的方法名称。如果属性是只读的，则该参数可能为 null。
抛出：
IntrospectionException - 如果在内省期间发生异常。

PropertyDescriptor

public PropertyDescriptor(String propertyName,
                          Method readMethod,
                          Method writeMethod)
                   throws IntrospectionException
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

参数：
propertyName - 属性的编程名称。
readMethod - 用于读取属性值的方法。如果属性是只写的，则该参数可能为 null。
writeMethod - 用于写入属性值的方法。如果属性是只读的，则该参数可能为 null。
抛出：
IntrospectionException - 如果在内省期间发生异常。
方法详细信息

getPropertyType

public Class<?> getPropertyType()
获得属性的 Class 对象。

返回：
属性的 Java 类型信息。注意，"Class" 对象可以描述内置 Java 类型，比如 "int"。如果此属性是一个不支持非索引访问的索引 (indexed) 属性，则结果可能是 "null"。

而这里的类型是由 ReadMethod 返回的类型。

getReadMethod

public Method getReadMethod()
获得应该用于读取属性值的方法。

返回：
应该用于读取属性值的方法。如果无法读取该属性，则可能返回。

setReadMethod

public void setReadMethod(Method readMethod)
                   throws IntrospectionException
设置应该用于读取属性值的方法。

参数：
readMethod - 新的读取方法。
抛出：
IntrospectionException

getWriteMethod

public Method getWriteMethod()
获得应该用于写入属性值的方法。

返回：
应该用于写入属性值的方法。如果无法写入该属性，则可能返回。

setWriteMethod

public void setWriteMethod(Method writeMethod)
                    throws IntrospectionException
设置应该用于写入属性值的方法。

参数：
writeMethod - 新的写入方法。
抛出：
IntrospectionException

isBound

public boolean isBound()
更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。

返回：
如果该属性是绑定 (bound) 属性，则返回 true。

setBound

public void setBound(boolean bound)
更新 "bound" 属性将导致更改该属性时激发 "PropertyChange" 事件。

参数：
bound - 如果该属性是绑定属性，则该属性为 true。

isConstrained

public boolean isConstrained()
试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。

返回：
如果该属性是约束 (constrained) 属性，则返回 true。

setConstrained

public void setConstrained(boolean constrained)
试图更新 "Constrained" 属性将导致更改该属性时激发 "VetoableChange" 事件。

参数：
constrained - 如果该属性是约束属性，则该属性为 true。

setPropertyEditorClass

public void setPropertyEditorClass(Class<?> propertyEditorClass)
通常 PropertyEditor 是使用 PropertyEditorManager 找到的。不过，如果出于某些原因想将特定 PropertyEditor 与某一给定属性相关联，那么可以使用此方法做到这一点。

参数：
propertyEditorClass - 所需 PropertyEditor 的 Class。

getPropertyEditorClass

public Class<?> getPropertyEditorClass()
获得已为此属性注册的任何显式 PropertyEditor Class。

返回：
已为此属性注册的任何显式 PropertyEditor Class。通常此方法将返回 "null"，指示没有注册特殊编辑器，所以 PropertyEditorManager 应该用于查找合适的 PropertyEditor。

createPropertyEditor

public PropertyEditor createPropertyEditor(Object bean)
使用当前属性编辑器类构造一个属性编辑器实例。

如果属性编辑器类拥有一个带有 Object 参数的公共构造方法，则将通过使用 bean 参数作为变量来调用它。否则将调用默认构造方法。

参数：
bean - 源对象
返回：
属性编辑器实例，如果没有定义或无法创建属性编辑器，则返回 null
从以下版本开始：
1.5

equals

public boolean equals(Object obj)
将此 PropertyDescriptor 与指定对象进行比较。如果对象是相同的，则返回 true。如果读取、写入、属性类型、属性编辑器和标记都是等同的，则两个 PropertyDescriptor 是相同的。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
从以下版本开始：
1.4
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回对象的哈希码。关于完整的描述，请参阅 Object.hashCode()。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
从以下版本开始：
1.5
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 PropertyEditor

所有已知实现类：
PropertyEditorSupport
public interface PropertyEditor

PropertyEditor 类为希望允许用户编辑某个给定类型的属性值的 GUI 提供支持。

PropertyEditor 支持各种不同类型的显示和更新属性值的方式。大多数 PropertyEditor 只需要支持此 API 中可用的不同选项的一个子集。

简单的 PropertyEditor 可能只支持 getAsText 和 setAsText 方法，不需要支持（比如说）paintValue 或 getCustomEditor。更多复杂类型的 PropertyEditor 可能无法支持 getAsText 和 setAsText，但它们将改为支持 paintValue 和 getCustomEditor。

每个 propertyEditor 都必须支持三种简单显示样式之一或更多。这样便可以：(1) 支持 isPaintable；(2) 从 getTags() 返回一个非 null 的 String[]，以及从 getAsText 返回一个非 null 值；(3) 只从 getAsText() 返回一个非 null 的 String。

当此类是参数对象类型相对应的 propertyEditor 时，每个属性编辑器都必须支持调用 setValue。此外，每个属性编辑器都必须支持一个自定义编辑器，或者支持 setAsText。

每个 PropertyEditor 都应该有一个 null 构造方法。

方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
String | getAsText() 以文本形式获得属性值。
Component | getCustomEditor() PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
String | getJavaInitializationString() 返回一部分 Java 代码，可以使用这部分代码来设置某个属性，以匹配编辑器当前状态。
String[] | getTags() 如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记数组。
Object | getValue() 获取属性值。
boolean | isPaintable() 确定此属性编辑器是否是可绘制的。
void | paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。
void | removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | setAsText(String text) 通过解析给定 String 设置属性值。
void | setValue(Object value) 设置（或更改）将编辑的对象。
boolean | supportsCustomEditor() 确定此属性编辑器是否支持自定义编辑器。

方法详细信息

setValue

void setValue(Object value)
设置（或更改）将编辑的对象。必须将基本类型（比如 "int"）包装为相应的对象类型，比如 "java.lang.Integer"。

参数：
value - 要编辑的新目标对象。注意，不应由 PropertyEditor 修改此对象，相反 PropertyEditor 应该创建一个新对象来保存所有修改值。

getValue

Object getValue()
获取属性值。

返回：
属性值。将基本类型（比如 "int"）包装为相应的对象类型，比如 "java.lang.Integer"。

isPaintable

boolean isPaintable()
确定此属性编辑器是否是可绘制的。

返回：
如果该类支持 paintValue 方法，则返回 true。

paintValue

void paintValue(Graphics gfx,
                Rectangle box)
在屏幕实际状态给定区域中绘制值的表示形式。注意，propertyEditor 负责裁剪自身，以适应给定的矩形。

如果 PropertyEditor 不支持绘制请求（参见 isPaintable），则此方法应该是一个静寂的无操作。

给定 Graphics 对象将拥有父容器的默认字体、颜色等等。PropertyEditor 可以更改图形属性（比如字体和颜色），并且无需恢复旧值。

参数：
gfx - 要绘制的 Graphics 对象。
box - 应该在其中绘制图形对象的矩形。

getJavaInitializationString

String getJavaInitializationString()
返回一部分 Java 代码，可以使用这部分代码来设置某个属性，以匹配编辑器当前状态。此方法在生成 Java 代码来反映通过属性编辑器产生的更改时使用。

代码片段应该是上下文无关的，并且必须是一个合法的 Java 表示式，正如 JLS 所规定的那样。

明确地说，如果表达式表示某一计算，则所有类和静态成员都应是完全限定的。此规则适用于构造方法、静态方法和非基本参数。

在对该表达式求值时应该使用警告，因为它可能抛出异常。特别要指出的是，代码生成器必须确保生成的代码能够在存在可能抛出已检查异常的表达式的情况下进行编译。

示例结果是：

  • 基本表达式：2
  • 类构造方法：new java.awt.Color(127,127,34)
  • 静态字段：java.awt.Color.orange
  • 静态方法：javax.swing.Box.createRigidArea(new java.awt.Dimension(0, 5))

返回：
表示用于当前值的 initializer 的 Java 代码片段。它不应该包含结束表达式的分号 (';')。

getAsText

String getAsText()
以文本形式获得属性值。

返回：
可编辑字符串形式的属性值。

如果无法将该值表示为可编辑的字符串，则返回 null。

如果返回的是一个非 null 值，则应该准备好 PropertyEditor，以便回到 setAsText() 中解析字符串。

setAsText

void setAsText(String text)
               throws IllegalArgumentException
通过解析给定 String 设置属性值。如果该 String 格式出错或者无法将此类属性表示为文本，则可能引发 java.lang.IllegalArgumentException。

参数：
text - 要解析的字符串。
抛出：
IllegalArgumentException

getTags

String[] getTags()
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记数组。可以用此方法来表示（例如）枚举值。如果 PropertyEditor 支持标记，那么它应该支持使用 setAsText（同时使用标记值）作为设置值的一种方式，并支持使用 getAsText 来标识当前值。

返回：
此属性的标记值。如果无法将此属性表示为加标记的值，则返回 null。

getCustomEditor

Component getCustomEditor()
PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。PropertyEditor 负责将其自身与其编辑器 Component 联系起来，并报告由于激发 PropertyChange 事件而造成的属性值更改。

调用 getCustomEditor 的更高级别的代码可以将 Component 嵌入一些更大的属性表单，或者放入它们自己的个别对话框，或者……

返回：
允许用户直接编辑当前属性值的 java.awt.Component。如果这不受支持，则返回 null。

supportsCustomEditor

boolean supportsCustomEditor()
确定此属性编辑器是否支持自定义编辑器。

返回：
如果 propertyEditor 可以提供一个自定义编辑器，则返回 true。

addPropertyChangeListener

void addPropertyChangeListener(PropertyChangeListener listener)
注册一个用于 PropertyChange 事件的侦听器。当 PropertyEditor 更改自己的值时，它应该在所有已注册的 PropertyChangeListener 上激发一个 PropertyChange 事件，指定 null 值为属性名称，并指定自身为源。

参数：
listener - 激发 PropertyChange 事件时要调用的对象。

removePropertyChangeListener

void removePropertyChangeListener(PropertyChangeListener listener)
移除一个用于 PropertyChange 事件的侦听器。

参数：
listener - 要移除的 PropertyChange 侦听器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyEditorManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PropertyEditorManager

java.lang.Object
    继承者  java.beans.PropertyEditorManager

public class PropertyEditorManager
extends Object

PropertyEditorManager 可用于查找任何给定类型名称的属性编辑器。此属性编辑器必须支持 java.beans.PropertyEditor 接口，以编辑给定的对象。

PropertyEditorManager 使用三种技术来查找给定类型的编辑器。首先，它提供一个 registerEditor 方法，允许专门为某一给定类型注册编辑器。其次，它试图通过将 "Editor" 添加到给定类型的完全限定类名中（例如 "foo.bah.FozEditor"）来查找合适的类。最后，它使用简单的类名称（没有包名称）添加 "Editor"，并在包的搜索路径中查找匹配类。

因此，对于输入类 foo.bah.Fred，PropertyEditorManager 首先将查看其表以确定是否已经为 foo.bah.Fred 注册了编辑器，若已注册，则使用它。然后它将查找 foo.bah.FredEditor 类。接着将查找（比如说）standardEditorsPackage.FredEditor 类。

默认 PropertyEditor 将被提供给 Java 基本类型 "boolean"、"byte"、"short"、"int"、"long"、"float" 和 "double"；并提供给类 java.lang.String、java.awt.Color 和 java.awt.Font。

构造方法摘要
PropertyEditorManager()
方法摘要
static PropertyEditor | findEditor(Class<?> targetType) 查找给定目标类型的值编辑器。
static String[] | getEditorSearchPath() 获得用来搜索属性编辑器的包名称。
static void | registerEditor(Class<?> targetType, Class<?> editorClass) 注册一个将用来编辑给定目标类的值的编辑器类。
static void | setEditorSearchPath(String[] path) 更改将用来查找属性编辑器的包名称的列表。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PropertyEditorManager

public PropertyEditorManager()
方法详细信息

registerEditor

public static void registerEditor(Class<?> targetType,
                                  Class<?> editorClass)
注册一个将用来编辑给定目标类的值的编辑器类。

如果有安全管理器，则首先调用其 checkPropertiesAccess 方法。这可能会导致 SecurityException 异常。

参数：
targetType - 要被编辑类型的 Class 对象
editorClass - 编辑器类的 Class 对象。如果该参数为 null，则将移除所有现有定义。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许设置系统属性。
另请参见：
SecurityManager.checkPropertiesAccess()

findEditor

public static PropertyEditor findEditor(Class<?> targetType)
查找给定目标类型的值编辑器。

参数：
targetType - 要被编辑类型的 Class 对象
返回：
给定目标类的编辑器对象。如果没有发现合适的编辑器，则结果为 null。

getEditorSearchPath

public static String[] getEditorSearchPath()
获得用来搜索属性编辑器的包名称。

返回：
为了查找属性编辑器而被搜索的包名称数组。

此数组的默认值与实现有关，例如，Sun 实现最初被设置为 {"sun.beans.editors"}。

setEditorSearchPath

public static void setEditorSearchPath(String[] path)
更改将用来查找属性编辑器的包名称的列表。

如果有安全管理器，则首先调用其 checkPropertiesAccess 方法。这可能会导致 SecurityException 异常。

参数：
path - 包名称数组。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许设置系统属性。
另请参见：
SecurityManager.checkPropertiesAccess()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyEditorSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PropertyEditorSupport

java.lang.Object
    继承者  java.beans.PropertyEditorSupport
所有已实现的接口：
PropertyEditor
public class PropertyEditorSupport
extends Object
implements PropertyEditor

这是一个帮助构建属性编辑器的支持类。

可以将该类用作一个基类或是一个代理。

构造方法摘要
PropertyEditorSupport()
构造一个 PropertyEditorSupport 对象。
PropertyEditorSupport(Object source)
构造一个 PropertyEditorSupport 对象。
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | firePropertyChange() 报告已经修改所有感兴趣的侦听器。
String | getAsText() 获得人类可编辑的适当字符串表示形式的属性值。
Component | getCustomEditor() PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。
String | getJavaInitializationString() 生成 Java 代码来设置属性值时使用此方法。
Object | getSource() 返回用作事件源的 bean。
String[] | getTags() 如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记值数组。
Object | getValue() 获得属性值。
boolean | isPaintable() 确定该类是否支持 paintValue 方法。
void | paintValue(Graphics gfx, Rectangle box) 在屏幕实际状态给定区域中绘制值的表示形式。
void | removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | setAsText(String text) 通过解析给定字符串设置属性值。
void | setSource(Object source) 设置源 bean。
void | setValue(Object value) 设置（或更改）将被编辑的对象。
boolean | supportsCustomEditor() 确定 propertyEditor 是否可以提供自定义编辑器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PropertyEditorSupport

public PropertyEditorSupport()
构造一个 PropertyEditorSupport 对象。

从以下版本开始：
1.5

PropertyEditorSupport

public PropertyEditorSupport(Object source)
构造一个 PropertyEditorSupport 对象。

参数：
source - 用来激发事件的源
从以下版本开始：
1.5
方法详细信息

getSource

public Object getSource()
返回用作事件源的 bean。如果没有显式设置源，则返回 PropertyEditorSupport 的此实例。

返回：
源对象或此实例
从以下版本开始：
1.5

setSource

public void setSource(Object source)
设置源 bean。

源 bean 被用作属性更改的事件源。此源应该仅用于获得信息，不应被 PropertyEditor 修改。

参数：
source - 将用于事件的源对象
从以下版本开始：
1.5

setValue

public void setValue(Object value)
设置（或更改）将被编辑的对象。

指定者：
接口 PropertyEditor 中的 setValue
参数：
value - 要编辑的新目标对象。注意，不应由 PropertyEditor 修改此对象，相反 PropertyEditor 应该创建一个新对象来保存所有修改值。

getValue

public Object getValue()
获得属性值。

指定者：
接口 PropertyEditor 中的 getValue
返回：
属性值。

isPaintable

public boolean isPaintable()
确定该类是否支持 paintValue 方法。

指定者：
接口 PropertyEditor 中的 isPaintable
返回：
如果该类支持 paintValue 方法，则返回 true。

paintValue

public void paintValue(Graphics gfx,
                       Rectangle box)
在屏幕实际状态给定区域中绘制值的表示形式。注意，propertyEditor 负责裁剪自身，以适应给定的矩形。

如果 PropertyEditor 不支持绘制请求（参见 isPaintable），则此方法应该是一个静寂的无操作。

指定者：
接口 PropertyEditor 中的 paintValue
参数：
gfx - 要绘制的 Graphics 对象。
box - 应该在其中绘制图形对象的矩形。

getJavaInitializationString

public String getJavaInitializationString()
生成 Java 代码来设置属性值时使用此方法。它应该返回一段可以用来利用当前属性值初始化变量的 Java 代码。

示例结果是 "2"、"new Color(127,127,34)"、"Color.orange" 等等。

指定者：
接口 PropertyEditor 中的 getJavaInitializationString
返回：
表示用于当前值的 initializer 的 Java 代码片段。

getAsText

public String getAsText()
获得人类可编辑的适当字符串表示形式的属性值。

指定者：
接口 PropertyEditor 中的 getAsText
返回：
人类可编辑的适当字符串表示形式的属性值。

如果无法将该值表示为字符串，则返回 "null"。

如果返回的是一个非 null 值，则应该准备好 PropertyEditor，以便回到 setAsText() 解析该字符串。

setAsText

public void setAsText(String text)
               throws IllegalArgumentException
通过解析给定字符串设置属性值。如果该 String 格式出错或者无法将此类属性表示为文本，则可能引发 java.lang.IllegalArgumentException。

指定者：
接口 PropertyEditor 中的 setAsText
参数：
text - 要解析的字符串。
抛出：
IllegalArgumentException

getTags

public String[] getTags()
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记值数组。可以用此方法来表示（例如）枚举值。如果 PropertyEditor 支持标记，则它应该支持使用 setAsText（同时使用标记值）作为设置值的一种方式。

指定者：
接口 PropertyEditor 中的 getTags
返回：
此属性的标记值。如果无法将此属性表示为加标记的值，则返回 null。

getCustomEditor

public Component getCustomEditor()
PropertyEditor 可以选择使用完全自定义的 Component 来编辑自己的属性值。PropertyEditor 负责将其自身与其编辑器 Component 联系起来，并报告由于激发 PropertyChange 事件而造成的属性值更改。

调用 getCustomEditor 的更高级别的代码可以将 Component 嵌入一些较大的属性表，或者将它们放入自己的对话框，或者……

指定者：
接口 PropertyEditor 中的 getCustomEditor
返回：
允许用户直接编辑当前属性值的 java.awt.Component。如果这不受支持，则返回 null。

supportsCustomEditor

public boolean supportsCustomEditor()
确定 propertyEditor 是否可以提供自定义编辑器。

指定者：
接口 PropertyEditor 中的 supportsCustomEditor
返回：
如果 propertyEditor 可以提供一个自定义编辑器，则返回 true。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
注册一个用于 PropertyChange 事件的侦听器。只要更新该值，该类就会激发一个 PropertyChange 值。

指定者：
接口 PropertyEditor 中的 addPropertyChangeListener
参数：
listener - 激发 PropertyChange 事件时要调用的对象。

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
移除一个用于 PropertyChange 事件的侦听器。

指定者：
接口 PropertyEditor 中的 removePropertyChangeListener
参数：
listener - 要移除的 PropertyChange 侦听器。

firePropertyChange

public void firePropertyChange()
报告已经修改所有感兴趣的侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyVetoException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 PropertyVetoException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.beans.PropertyVetoException
所有已实现的接口：
Serializable
public class PropertyVetoException
extends Exception

当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

另请参见：
序列化表格

构造方法摘要
PropertyVetoException(String mess, PropertyChangeEvent evt)
构造带详细消息的 PropertyVetoException。
方法摘要
 PropertyChangeEvent getPropertyChangeEvent()
获得禁止的 PropertyChangeEvent。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PropertyVetoException

public PropertyVetoException(String mess,
                             PropertyChangeEvent evt)
构造带详细消息的 PropertyVetoException。

参数：
mess - 描述性消息
evt - 描述所禁止更改的 PropertyChangeEvent。
方法详细信息

getPropertyChangeEvent

public PropertyChangeEvent getPropertyChangeEvent()
获得禁止的 PropertyChangeEvent。

返回：
描述所禁止更改的 PropertyChangeEvent。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Statement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 Statement

java.lang.Object
    继承者  java.beans.Statement
直接已知子类：
Expression
public class Statement
extends Object

Statement 对象表示基本语句，其中将单个方法应用于某一目标和一组参数，以返回结果，比如 "a.setFoo(b)"。注意，此示例使用名称来指示目标及其参数，statement 对象不需要名称空间，可以使用值本身构造。statement 对象将指定方法与其环境相关联，作为值的简单集合：目标和参数值数组。

从以下版本开始：
1.4

构造方法摘要
Statement(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。
方法摘要
void | execute() 执行方法找到一个与 methodName 属性同名的方法，并在目标上调用该方法。
Object[] | getArguments() 返回此语句的参数。
String | getMethodName() 返回方法名称。
Object | getTarget() 返回此语句的目标。
String | toString() 使用 Java 风格的语法打印此语句的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Statement

public Statement(Object target,
                 String methodName,
                 Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

参数：
target - 此语句的目标。
methodName - 此语句的 methodName。
arguments - 此语句的参数。如果该参数为 null，则使用一个空数组。
方法详细信息

getTarget

public Object getTarget()
返回此语句的目标。

返回：
此语句的目标。

getMethodName

public String getMethodName()
返回方法名称。

返回：
方法名称。

getArguments

public Object[] getArguments()
返回此语句的参数。

返回：
此语句的参数。

execute

public void execute()
             throws Exception
执行方法找到一个与 methodName 属性同名的方法，并在目标上调用该方法。 当目标的类使用给定名称定义大量方法时，该实现应该使用 Java Language Specification (15.11) 中指定的算法选择最明确的方法。目标和参数的动态类被用于替换编译时类型信息，与 java.lang.reflect.Method 类本身类似，基本值与相关包装器类之间的转换是内部处理的。

以下方法类型被作为特殊情况处理：

  • 可以通过将类对象用作目标来调用静态方法。
  • 使用保留的方法名 "new" 调用类的构造方法，如同所有类都定义了静态 "new" 方法。构造方法调用通常被认为是 Expression 而不是 Statement，因为它们返回一个值。
  • java.util.List 接口中定义的方法名称 "get" 和 "set" 也可以应用于数组实例，映射到 Array 类中同一名称的静态方法。

抛出：
Exception

toString

public String toString()
使用 Java 风格的语法打印此语句的值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleBeanInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 SimpleBeanInfo

java.lang.Object
    继承者  java.beans.SimpleBeanInfo
所有已实现的接口：
BeanInfo
public class SimpleBeanInfo
extends Object
implements BeanInfo

这是一个使得用户提供 BeanInfo 类更容易的支持类。

该类在默认情况下提供 "noop" 信息，可以选择性地重写该类来提供有关所选择主题的更明确信息。当 introspector 参阅 "noop" 值时，它将应用低级内省和设计模式来自动分析目标 bean。

字段摘要
从接口 java.beans.BeanInfo 继承的字段
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
构造方法摘要
SimpleBeanInfo()
方法摘要
BeanInfo[] | getAdditionalBeanInfo() 声明没有其他有关的 BeanInfo 对象。
BeanDescriptor | getBeanDescriptor() 拒绝关于 bean 的类和 customizer 的信息。
int | getDefaultEventIndex() 拒绝默认事件的信息。
int | getDefaultPropertyIndex() 拒绝默认属性的信息。
EventSetDescriptor[] | getEventSetDescriptors() 拒绝事件集的信息。
Image | getIcon(int iconKind) 声明没有可用的图标。
MethodDescriptor[] | getMethodDescriptors() 拒绝方法的信息。
PropertyDescriptor[] | getPropertyDescriptors() 拒绝属性的信息。
Image | loadImage(String resourceName) 这是帮助加载图标图像的实用工具方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SimpleBeanInfo

public SimpleBeanInfo()
方法详细信息

getBeanDescriptor

public BeanDescriptor getBeanDescriptor()
拒绝关于 bean 的类和 customizer 的信息。如果希望提供明确信息，可以重写此方法。

指定者：
接口 BeanInfo 中的 getBeanDescriptor
返回：
提供有关 bean 的全面信息的 BeanDescriptor，比如其 displayName、customizer 等等。如果该信息应该通过自动分析获得，则可能返回 null。

getPropertyDescriptors

public PropertyDescriptor[] getPropertyDescriptors()
拒绝属性的信息。如果希望提供明确属性信息，可以重写此方法。

指定者：
接口 BeanInfo 中的 getPropertyDescriptors
返回：
描述受此 bean 支持的可编辑属性的 PropertyDescriptor 数组。如果该信息应该通过自动分析获得，则可能返回 null。

如果某个属性已建立索引，则结果数组中该属性的条目将属于 PropertyDescriptor 的 IndexedPropertyDescriptor 子类。getPropertyDescriptors 的客户端可以使用 "instanceof" 来检查给定 PropertyDescriptor 是否是一个 IndexedPropertyDescriptor。

getDefaultPropertyIndex

public int getDefaultPropertyIndex()
拒绝默认属性的信息。如果希望为 bean 定义默认属性，可以重写此方法。

指定者：
接口 BeanInfo 中的 getDefaultPropertyIndex
返回：
位于由 getPropertyDescriptors 返回的 PropertyDescriptor 数组中的默认属性的索引。

如果没有默认属性，则返回 -1。

getEventSetDescriptors

public EventSetDescriptor[] getEventSetDescriptors()
拒绝事件集的信息。如果希望提供明确事件集信息，可以重写此方法。

指定者：
接口 BeanInfo 中的 getEventSetDescriptors
返回：
描述由此 bean 激发事件种类的 EventSetDescriptor 数组。如果该信息应该通过自动分析获得，则可能返回 null。

getDefaultEventIndex

public int getDefaultEventIndex()
拒绝默认事件的信息。如果希望为 bean 定义默认事件，可以重写此方法。

指定者：
接口 BeanInfo 中的 getDefaultEventIndex
返回：
位于由 getEventSetDescriptors 返回的 EventSetDescriptor 数组中的默认事件的索引。

如果没有默认事件，则返回 -1。

getMethodDescriptors

public MethodDescriptor[] getMethodDescriptors()
拒绝方法的信息。如果希望提供明确方法信息，可以重写此方法。

指定者：
接口 BeanInfo 中的 getMethodDescriptors
返回：
描述受此 bean 支持的扩展可见方法的 MethodDescriptor 数组。如果该信息应该通过自动分析获得，则可能返回 null。

getAdditionalBeanInfo

public BeanInfo[] getAdditionalBeanInfo()
声明没有其他有关的 BeanInfo 对象。如果想（比如说）为基类返回 BeanInfo，则可以重写此方法。

指定者：
接口 BeanInfo 中的 getAdditionalBeanInfo
返回：
BeanInfo 对象数组。可能返回 null。

getIcon

public Image getIcon(int iconKind)
声明没有可用的图标。如果想为 bean 提供图标，则可以重写此方法。

指定者：
接口 BeanInfo 中的 getIcon
参数：
iconKind - 所请求图标的种类。此参数应该是以下常数值之一：ICON_COLOR_16x16、ICON_COLOR_32x32、ICON_MONO_16x16 和 ICON_MONO_32x32。
返回：
表示所请求图标的图像对象。如果没有合适的图标可用，则可能返回 null。

loadImage

public Image loadImage(String resourceName)
这是帮助加载图标图像的实用工具方法。该方法使用与当前对象的类文件相关联的资源文件名称，并从该文件加载图像对象。通常图像会是 GIF 格式的。

参数：
resourceName - 与保存当前类的类文件的目录有关的路径名。例如 "wombat.gif"。
返回：
图像对象。如果加载失败，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VetoableChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 VetoableChangeListener

所有超级接口：
EventListener
所有已知实现类：
BeanContextServicesSupport, BeanContextSupport, VetoableChangeListenerProxy
public interface VetoableChangeListener
extends EventListener

只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。可以向源 bean 注册一个 VetoableChangeListener，以便获得所有约束 (constrained) 属性更改的通知。

方法摘要
 void vetoableChange(PropertyChangeEvent evt)
在约束属性发生更改时调用此方法。

方法详细信息

vetoableChange

void vetoableChange(PropertyChangeEvent evt)
                    throws PropertyVetoException
在约束属性发生更改时调用此方法。

参数：
evt - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
抛出：
PropertyVetoException - 如果接收方希望回滚属性更改。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VetoableChangeListenerProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 VetoableChangeListenerProxy

java.lang.Object
    继承者  java.util.EventListenerProxy
        继承者  java.beans.VetoableChangeListenerProxy
所有已实现的接口：
VetoableChangeListener, EventListener
public class VetoableChangeListenerProxy
extends EventListenerProxy
implements VetoableChangeListener

扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。可以将此类的实例作为一个 VetoableChangeListener 添加到支持激发 VetoableChange 事件的 bean。

如果该对象有一个 getVetoableChangeListeners() 方法，则返回的数组可以是 VetoableChangeListener 和 VetoableChangeListenerProxy 对象的混合。

从以下版本开始：
1.4
另请参见：
EventListenerProxy, VetoableChangeListener, VetoableChangeSupport.getVetoableChangeListeners()

构造方法摘要
VetoableChangeListenerProxy(String propertyName, VetoableChangeListener listener)
方法摘要
String | getPropertyName() 返回与侦听器有关联的指定属性的名称。
void | vetoableChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
从类 java.util.EventListenerProxy 继承的方法
getListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VetoableChangeListenerProxy

public VetoableChangeListenerProxy(String propertyName,
                                   VetoableChangeListener listener)
参数：
propertyName - 将侦听的属性的名称。
listener - 侦听器对象
方法详细信息

vetoableChange

public void vetoableChange(PropertyChangeEvent evt)
                    throws PropertyVetoException
将属性更改事件转发给侦听器代理。

指定者：
接口 VetoableChangeListener 中的 vetoableChange
参数：
evt - 属性更改事件
抛出：
PropertyVetoException - 如果接收方希望回滚属性更改。

getPropertyName

public String getPropertyName()
返回与侦听器有关联的指定属性的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VetoableChangeSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 VetoableChangeSupport

java.lang.Object
    继承者  java.beans.VetoableChangeSupport
所有已实现的接口：
Serializable
public class VetoableChangeSupport
extends Object
implements Serializable

这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。可以使用此类的实例作为 bean 的成员字段，并将各种工作委托给它。 此类是可序列化的。在对它进行序列化时，它将保存（并恢复）本身可序列化的所有侦听器。在序列化期间，将跳过所有不可序列化的侦听器。

另请参见：
序列化表格

构造方法摘要
VetoableChangeSupport(Object sourceBean)
构造一个 VetoableChangeSupport 对象。
方法摘要
void | addVetoableChangeListener(String propertyName, VetoableChangeListener listener) 为特定属性添加一个 VetoableChangeListener。
void | addVetoableChangeListener(VetoableChangeListener listener) 向侦听器列表添加一个 VetoableListener。
void | fireVetoableChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个 vetoable 属性更新。
void | fireVetoableChange(String propertyName, boolean oldValue, boolean newValue) 向所有已注册的侦听器报告一个 boolean vetoable 属性更新。
void | fireVetoableChange(String propertyName, int oldValue, int newValue) 向所有已注册的侦听器报告一个 int vetoable 属性更新。
void | fireVetoableChange(String propertyName, Object oldValue, Object newValue) 向所有已注册的侦听器报告 vetoable 属性更新。
VetoableChangeListener[] | getVetoableChangeListeners() 返回 VetoableChangeListener 的列表。
VetoableChangeListener[] | getVetoableChangeListeners(String propertyName) 返回与指定属性相关联的所有侦听器组成的数组。
boolean | hasListeners(String propertyName) 检查是否存在特定属性的侦听器，包括那些已在所有属性上注册的侦听器。
void | removeVetoableChangeListener(String propertyName, VetoableChangeListener listener) 为特定属性移除一个 VetoableChangeListener。
void | removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除一个 VetoableChangeListener。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

VetoableChangeSupport

public VetoableChangeSupport(Object sourceBean)
构造一个 VetoableChangeSupport 对象。

参数：
sourceBean - 作为所有事件的源提供的 bean。
方法详细信息

addVetoableChangeListener

public void addVetoableChangeListener(VetoableChangeListener listener)
向侦听器列表添加一个 VetoableListener。该侦听器是为所有属性注册的。同一侦听器对象可以被添加多次，并且它们被调用的次数将与添加它们的次数相同。如果 listener 为 null，则不会抛出任何异常并且不执行任何操作。

参数：
listener - 要添加的 VetoableChangeListener

removeVetoableChangeListener

public void removeVetoableChangeListener(VetoableChangeListener listener)
从侦听器列表移除一个 VetoableChangeListener。此方法移除了一个为所有属性注册的 VetoableChangeListener。如果将 listener 多次添加到同一事件源，则在被移除之后，它获得的通知将减少一次。如果 listener 为 null，或者从未被添加，则不会抛出任何异常并且不执行任何操作。

参数：
listener - 要移除的 VetoableChangeListener

getVetoableChangeListeners

public VetoableChangeListener[] getVetoableChangeListeners()
返回 VetoableChangeListener 的列表。如果已添加指定 vetoable 更改侦听器，则将返回 VetoableChangeListenerProxy 包装器

返回：
如果已添加指定的属性更改侦听器,则返回 VetoableChangeListener 和 VetoableChangeListenerProxy 的列表，。
从以下版本开始：
1.4

addVetoableChangeListener

public void addVetoableChangeListener(String propertyName,
                                      VetoableChangeListener listener)
为特定属性添加一个 VetoableChangeListener。该侦听器只在调用 fireVetoableChange 为特定属性命名时调用。可以多次添加同一侦听器对象。对于每个属性，该侦听器被调用的次数与为该属性添加此侦听器的次数相同。如果 propertyName 或 listener 为 null，则不会抛出异常并且不执行操作。

参数：
propertyName - 要侦听的属性的名称。
listener - 要添加的 VetoableChangeListener

removeVetoableChangeListener

public void removeVetoableChangeListener(String propertyName,
                                         VetoableChangeListener listener)
为特定属性移除一个 VetoableChangeListener。如果将 listener 多次添加到指定属性的同一事件源，则在被移除之后，它获得的通知将减少一次。如果 propertyName 为 null，则不会抛出任何异常并且不执行任何操作。如果 listener 为 null，或者从不为指定属性添加了侦听器，则不抛出任何异常并且不执行任何操作。

参数：
propertyName - 已被侦听的属性的名称。
listener - 要移除的 VetoableChangeListener

getVetoableChangeListeners

public VetoableChangeListener[] getVetoableChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器组成的数组。

参数：
propertyName - 将被侦听的属性的名称
返回：
与指定属性相关联的所有 VetoableChangeListener。如果没有添加此类侦听器，或者 propertyName 为 null，则返回一个空数组。
从以下版本开始：
1.4

fireVetoableChange

public void fireVetoableChange(String propertyName,
                               Object oldValue,
                               Object newValue)
                        throws PropertyVetoException
向所有已注册的侦听器报告 vetoable 属性更新。如果任何人禁止更改，则触发一个新的事件，该事件将每个人的属性还原为旧值，然后再次抛出 PropertyVetoException。

如果新属性和旧属性相等并且是非 null 的，则不会触发事件。

参数：
propertyName - 将更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。
抛出：
PropertyVetoException - 如果接收方希望回滚属性更改。

fireVetoableChange

public void fireVetoableChange(String propertyName,
                               int oldValue,
                               int newValue)
                        throws PropertyVetoException
向所有已注册的侦听器报告一个 int vetoable 属性更新。如果新属性和旧属性相等，则不会触发事件。

这只是一个用来包装获取 Object 值的更一般 fireVetoableChange 方法的便捷包装器。

参数：
propertyName - 将更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。
抛出：
PropertyVetoException

fireVetoableChange

public void fireVetoableChange(String propertyName,
                               boolean oldValue,
                               boolean newValue)
                        throws PropertyVetoException
向所有已注册的侦听器报告一个 boolean vetoable 属性更新。如果新属性和旧属性相等，则不会触发事件。

这只是一个用来包装获取 Object 值的更一般 fireVetoableChange 方法的便捷包装器。

参数：
propertyName - 将更改属性的编程名称。
oldValue - 属性的旧值。
newValue - 属性的新值。
抛出：
PropertyVetoException

fireVetoableChange

public void fireVetoableChange(PropertyChangeEvent evt)
                        throws PropertyVetoException
对所有已注册侦听器激发一个 vetoable 属性更新。如果任何人禁止更改，则触发一个新的事件，该事件将每个人的属性还原为旧值，然后再次抛出 PropertyVetoException。

如果新属性和旧属性相等并且是非 null 的，则不会触发事件。

参数：
evt - 要激发的 PropertyChangeEvent。
抛出：
PropertyVetoException - 如果接收方希望回滚属性更改。

hasListeners

public boolean hasListeners(String propertyName)
检查是否存在特定属性的侦听器，包括那些已在所有属性上注册的侦听器。如果 propertyName 为 null，则只检查所有属性上注册的侦听器。

参数：
propertyName - 属性名。
返回：
如果存在给定属性的一个或多个侦听器，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Visibility (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
接口 Visibility

所有已知子接口：
BeanContext, BeanContextServices
所有已知实现类：
BeanContextServicesSupport, BeanContextSupport
public interface Visibility

在某些情况下，bean 可能运行在 GUI 不可用的服务器上。可以使用此接口来查询 bean，以确定它是否绝对需要一个 GUI，并为该 bean 提供 GUI 是否可用的建议。

此接口是为专业开发人员设计的，普通的简单 bean 不需要它。为了避免混淆终端用户，应避免对这些方法使用 getXXX setXXX 设计模式。

方法摘要
boolean | avoidingGui() 确定此 bean 是否避免使用 GUI。
void | dontUseGui() 此方法指示不应该使用 Gui 的 bean。
boolean | needsGui() 确定此 bean 是否需要一个 GUI。
void | okToUseGui() 此方法指示可以使用 Gui 的 bean。

方法详细信息

needsGui

boolean needsGui()
确定此 bean 是否需要一个 GUI。

返回：
如果 bean 绝对需要一个可用 GUI 来完成自己的工作，则返回 true。

dontUseGui

void dontUseGui()
此方法指示不应该使用 Gui 的 bean。

okToUseGui

void okToUseGui()
此方法指示可以使用 Gui 的 bean。

avoidingGui

boolean avoidingGui()
确定此 bean 是否避免使用 GUI。

返回：
如果该 bean 当前避免使用 Gui，例如调用了 dontUseGui()，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLDecoder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans
类 XMLDecoder

java.lang.Object
    继承者  java.beans.XMLDecoder

public class XMLDecoder
extends Object

XMLDecoder 类用于读取使用 XMLEncoder 创建的 XML 文档，用途类似于 ObjectInputStream。例如，用户可以使用以下代码片段来读取以 XML 文档形式（通过 XMLEncoder 类写入）定义的第一个对象：

       XMLDecoder d = new XMLDecoder(
                          new BufferedInputStream(
                              new FileInputStream("Test.xml")));
       Object result = d.readObject();
       d.close();

有关的更多信息，还可以参阅 The Swing Connection 中的 Long Term Persistence of JavaBeans Components:XML Schema 一文。

从以下版本开始：
1.4
另请参见：
XMLEncoder, ObjectInputStream

构造方法摘要
XMLDecoder(InputStream in)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
方法摘要
void | close() 此方法关闭与此流相关联的输入流。
ExceptionListener | getExceptionListener() 获得此流的异常处理程序。
Object | getOwner() 获得此解码器的所有者。
Object | readObject() 从基础输入流中读取下一个对象。
void | setExceptionListener(ExceptionListener exceptionListener) 将此流的异常处理程序设置为 exceptionListener。
void | setOwner(Object owner) 将此解码器的所有者设置为 owner。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLDecoder

public XMLDecoder(InputStream in)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

参数：
in - 基础流。
另请参见：
XMLEncoder.XMLEncoder(java.io.OutputStream)

XMLDecoder

public XMLDecoder(InputStream in,
                  Object owner)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

参数：
in - 基础流。
owner - 此流的所有者。

XMLDecoder

public XMLDecoder(InputStream in,
                  Object owner,
                  ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

参数：
in - 基础流。
owner - 此流的所有者。
exceptionListener - 该流的异常处理程序，如果为 null，则使用默认异常处理程序。

XMLDecoder

public XMLDecoder(InputStream in,
                  Object owner,
                  ExceptionListener exceptionListener,
                  ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

参数：
in - 基础流。可以传递 null 而不会出现错误，尽管得到的 XMLDecoder 将是无用的
owner - 此流的所有者。null 是一个合法值
exceptionListener - 流的异常处理程序，null 表示使用默认处理程序
cl - 用于实例化对象的类加载器。null 指示应该使用默认类加载器
从以下版本开始：
1.5
方法详细信息

close

public void close()
此方法关闭与此流相关联的输入流。

setExceptionListener

public void setExceptionListener(ExceptionListener exceptionListener)
将此流的异常处理程序设置为 exceptionListener。当此流捕获可恢复的异常时，异常处理程序会获得通知。

参数：
exceptionListener - 此流的异常处理程序，如果该参数为 null，则使用默认异常处理程序。
另请参见：
getExceptionListener()

getExceptionListener

public ExceptionListener getExceptionListener()
获得此流的异常处理程序。

返回：
此流的异常处理程序。如果没有显式设置异常处理程序，则返回默认异常侦听器。
另请参见：
setExceptionListener(java.beans.ExceptionListener)

readObject

public Object readObject()
从基础输入流中读取下一个对象。

返回：
读取的下一个对象
抛出：
ArrayIndexOutOfBoundsException - 如果流中没有包含任何对象（或者没有更多的对象）
另请参见：
XMLEncoder.writeObject(java.lang.Object)

setOwner

public void setOwner(Object owner)
将此解码器的所有者设置为 owner。

参数：
owner - 此解码器的所有者。
另请参见：
getOwner()

getOwner

public Object getOwner()
获得此解码器的所有者。

返回：
此解码器的所有者。
另请参见：
setOwner(java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLEncoder (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.beans
类 XMLEncoder

java.lang.Object
    继承者  java.beans.Encoder
        继承者  java.beans.XMLEncoder

public class XMLEncoder
extends Encoder

XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。例如，可以使用以下代码片段创建所提供的 JavaBean 及其所有属性的文本表示形式：

       XMLEncoder e = new XMLEncoder(
                          new BufferedOutputStream(
                              new FileOutputStream("Test.xml")));
       e.writeObject(new JButton("Hello, world"));
       e.close();
尽管两者的 API 类似，但 XMLEncoder 类仅设计用于将 JavaBean 的图形归档为其公共属性的文本表示形式。与 Java 源文件类似，以这种方式写入的文档在所涉及类的实现中可自然免除更改。在进程间通信和通用序列化中继续推荐使用 ObjectOutputStream。

XMLEncoder 类提供 JavaBean 的默认指示，其中它们被表示为符合 1.0 版的 XML 规范和 Unicode/ISO 10646 字符集 UTF-8 字符编码的 XML 文档。由 XMLEncoder 类生成的 XML 文档如下：

  • 轻便且版本灵活：它们不依赖于任何类的私有实现，因此，与 Java 源文件类似，可以在某些不同版本的类之间或不同的供应商的 VM 之间交换它们。
  • 结构紧凑：XMLEncoder 类在内部使用删减冗余 (redundancy elimination) 算法，因此 Bean 属性的默认值不会被写入流中。
  • 容错性：文件中的非结构性错误（由于文件的破坏或在归档文件中对类进行的 API 更改导致）仍然保持本地化，因此 reader 可以报告错误，并继续加载不受错误影响的那部分文档。

以下是一个 XML 归档文件的示例，它包含 swing 工具包中一些用户界面组件：

 <?xml version="1.0" encoding="UTF-8"?>
 <java version="1.0" class="java.beans.XMLDecoder">
 <object class="javax.swing.JFrame">
   <void property="name">
     <string>frame1</string>
   </void>
   <void property="bounds">
     <object class="java.awt.Rectangle">
       <int>0</int>
       <int>0</int>
       <int>200</int>
       <int>200</int>
     </object>
   </void>
   <void property="contentPane">
     <void method="add">
       <object class="javax.swing.JButton">
         <void property="label">
           <string>Hello</string>
         </void>
       </object>
     </void>
   </void>
   <void property="visible">
     <boolean>true</boolean>
   </void>
 </object>
 </java>
XML 语法使用以下约定：
  • 每个元素表示一个方法调用。
  • "object" 标记表示一个表达式，其值被用作参数来封闭元素。
  • "void" 标记表示将要执行的语句，但其结果不会被用作参数来封闭方法。
  • 包含元素的元素使用这些元素作为参数，除非它们有以下标记："void"。
  • 方法的名称由 "method" 属性表示。
  • XML 的标准 "id" 和 "idref" 属性用于引用以前的表达式，以便处理对象图形中的环形。
  • "class" 属性用于显式指定静态方法的目标或构造方法；其值是类的完全限定名。
  • 如果没有通过 "class" 属性定义目标，则使用外部上下文将带有 "void" 标记的元素作为目标执行。
  • Java 的 String 类被特殊对待并被写入 <string>Hello, world</string>，其中使用 UTF-8 字符编码将字符串的字符转换成字节。

尽管只使用这三个标记就可以写入所有对象图形，但以下定义也包括在内，以便能够更具体地表示普通数据结构：

  • 默认方法名是 "new"。
  • java 类的引用是以 <class>javax.swing.JButton</class> 形式写入的。
  • 用于 Java 基本类型的包装器类的实例是通过将基本类型的名称用做标记来写入的。例如，Integer 类的实例可以写为：<int>123</int>。注意，XMLEncoder 类使用了 Java 的反射包，在该包中，Java 的基本类型与其相关“包装器类”之间的转换是内部处理的。XMLEncoder 类自身的 API 只处理 Object。
  • 在表示 null 方法（其名称以 "get" 开头）的元素中，"method" 属性被 "property" 属性替代，后者的值是通过移除 "get" 前缀并取消所得结果的大写化得到的。
  • 在表示一元方法（其名称以 "set" 开头）的元素中，"method" 属性被 "property" 属性替代，后者的值是通过移除 "set" 前缀并取消所得结果的大写化得到的。
  • 在表示名为 "get" 且使用一个整数参数的方法的元素中，"method" 属性由 "index" 属性替换，后者的值是第一个参数的值。
  • 在表示名为 "set" 且使用两个参数（第一个参数为整数）的方法的元素中，"method" 属性由 "index" 属性替换，后者的值是第一个参数的值。
  • 数组的引用是使用 "array" 标记来编写的。"class" 和 "length" 属性分别指定数组的子类型和它的长度。

有关的更多信息，还可以参阅 The Swing Connection 中的 Using XMLEncoder 一文。

从以下版本开始：
1.4
另请参见：
XMLDecoder, ObjectOutputStream

构造方法摘要
XMLEncoder(OutputStream out)
使用 XML 编码创建一个新的输出流，将 JavaBeans 发送给流 out。
方法摘要
void | close() 此方法调用 flush，写入结束后文，然后关闭与此流有关的输出流。
void | flush() 如果还没有写出导言，那么此方法将写出与 XML 编码有关的导言，并随后写出从最后一次调用 flush 以来写入流中的所有值。
Object | getOwner() 获得此编码器的所有者。
void | setOwner(Object owner) 将此编码器的所有者设置为 owner。
void | writeExpression(Expression oldExp) 记录 Expression，以便 Encoder 在刷新流的缓存时产生实际输出。
void | writeObject(Object o) 将指定对象的 XML 表示形式写入输出中。
void | writeStatement(Statement oldStm) 记录 Statement，以便 Encoder 在刷新流的缓存时产生实际输出。
从类 java.beans.Encoder 继承的方法
get, getExceptionListener, getPersistenceDelegate, remove, setExceptionListener, setPersistenceDelegate
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLEncoder

public XMLEncoder(OutputStream out)
使用 XML 编码创建一个新的输出流，将 JavaBeans 发送给流 out。

参数：
out - 接收对象的 XML 表示形式的流。
另请参见：
XMLDecoder.XMLDecoder(InputStream)
方法详细信息

setOwner

public void setOwner(Object owner)
将此编码器的所有者设置为 owner。

参数：
owner - 此编码器的所有者。
另请参见：
getOwner()

getOwner

public Object getOwner()
获得此编码器的所有者。

返回：
此编码器的所有者。
另请参见：
setOwner(java.lang.Object)

writeObject

public void writeObject(Object o)
将指定对象的 XML 表示形式写入输出中。

覆盖：
类 Encoder 中的 writeObject
参数：
o - 要写入流中的对象。
另请参见：
XMLDecoder.readObject()

writeStatement

public void writeStatement(Statement oldStm)
记录 Statement，以便 Encoder 在刷新流的缓存时产生实际输出。

此方法只应在初始化持久委托的上下文中调用。

覆盖：
类 Encoder 中的 writeStatement
参数：
oldStm - 将写入流中的语句。
另请参见：
PersistenceDelegate.initialize(java.lang.Class, java.lang.Object, java.lang.Object, java.beans.Encoder)

writeExpression

public void writeExpression(Expression oldExp)
记录 Expression，以便 Encoder 在刷新流的缓存时产生实际输出。

此方法只应在初始化持久委托或设置编码器从资源包中读取数据的上下文中调用。

有关利用 XMLEncoder 使用资源包的更多信息，请参阅 http://java.sun.com/products/jfc/tsc/articles/persistence4/#i18n

覆盖：
类 Encoder 中的 writeExpression
参数：
oldExp - 将写入流中的表达式。
另请参见：
PersistenceDelegate.initialize(java.lang.Class, java.lang.Object, java.lang.Object, java.beans.Encoder)

flush

public void flush()
如果还没有写出导言，那么此方法将写出与 XML 编码有关的导言，并随后写出从最后一次调用 flush 以来写入流中的所有值。在刷新缓存之后，对已写入此流中的值的所有内部引用都被清除。

close

public void close()
此方法调用 flush，写入结束后文，然后关闭与此流有关的输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.beans (Java 2 Platform SE 6)

 java.beans
接口
AppletInitializer
BeanInfo
Customizer
DesignMode
ExceptionListener
PropertyChangeListener
PropertyEditor
VetoableChangeListener
Visibility
类
BeanDescriptor
Beans
DefaultPersistenceDelegate
Encoder
EventHandler
EventSetDescriptor
Expression
FeatureDescriptor
IndexedPropertyChangeEvent
IndexedPropertyDescriptor
Introspector
MethodDescriptor
ParameterDescriptor
PersistenceDelegate
PropertyChangeEvent
PropertyChangeListenerProxy
PropertyChangeSupport
PropertyDescriptor
PropertyEditorManager
PropertyEditorSupport
SimpleBeanInfo
Statement
VetoableChangeListenerProxy
VetoableChangeSupport
XMLDecoder
XMLEncoder
异常
IntrospectionException
PropertyVetoException
注释类型
ConstructorProperties


java.beans (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.beans

包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

请参见：
描述

接口摘要
AppletInitializer | 此接口设计用于与 java.beans.Beans.instantiate 联合使用。
BeanInfo | 希望提供有关其 bean 的显式信息的 bean 实现者可以提供某个 BeanInfo 类，该类实现此 BeanInfo 接口并提供有关其 bean 的方法、属性、事件等显式信息。
Customizer | customizer 类提供一个用来自定义目标 Java Bean 的完全自定义 GUI。
DesignMode | 此接口由 java.beans.beancontext.BeanContext 的实例实现或委托，以便将当前的 "designTime" 属性传播到 java.beans.beancontext.BeanContextChild 实例的嵌套层次结构。
ExceptionListener | ExceptionListener 是在发生内部异常时获得通知。
PropertyChangeListener | 无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
PropertyEditor | PropertyEditor 类为希望允许用户编辑某个给定类型的属性值的 GUI 提供支持。
VetoableChangeListener | 只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。
Visibility | 在某些情况下，bean 可能运行在 GUI 不可用的服务器上。

类摘要
BeanDescriptor | BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。
Beans | 此类提供一些通用的 bean 控制方法。
DefaultPersistenceDelegate | DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。
Encoder | Encoder 是这样的类，它可用于创建根据其公共 API 对 JavaBeans 集合状态进行编码的文件或流。
EventHandler | EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。
EventSetDescriptor | 描述给定 Java bean 激发的一组事件的 EventSetDescriptor。
Expression | Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。
FeatureDescriptor | FeatureDescriptor 类是 PropertyDescriptor、EventSetDescriptor 和 MethodDescriptor 等的公共基类。
IndexedPropertyChangeEvent | 无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。
IndexedPropertyDescriptor | IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。
Introspector | Introspector 类为通过工具学习有关受目标 Java Bean 支持的属性、事件和方法的知识提供了一个标准方法。
MethodDescriptor | MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。
ParameterDescriptor | ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。
PersistenceDelegate | PersistenceDelegate 类负责根据类的公共 API 中的方法表示给定类的实例状态。
PropertyChangeEvent | 无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeListenerProxy | 扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。
PropertyChangeSupport | 这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
PropertyDescriptor | PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。
PropertyEditorManager | PropertyEditorManager 可用于查找任何给定类型名称的属性编辑器。
PropertyEditorSupport | 这是一个帮助构建属性编辑器的支持类。
SimpleBeanInfo | 这是一个使得用户提供 BeanInfo 类更容易的支持类。
Statement | Statement 对象表示基本语句，其中将单个方法应用于某一目标和一组参数，以返回结果，比如 "a.setFoo(b)"。
VetoableChangeListenerProxy | 扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。
VetoableChangeSupport | 这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。
XMLDecoder | XMLDecoder 类用于读取使用 XMLEncoder 创建的 XML 文档，用途类似于 ObjectInputStream。
XMLEncoder | XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。

异常摘要
IntrospectionException | 在 Introspection 期间发生异常时抛出异常。
PropertyVetoException | 当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

注释类型摘要
ConstructorProperties 关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

软件包 java.beans 的描述

包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。少数类可由 bean 使用，也能以应用程序的形式运行。例如，event 类由激发属性和禁止更改事件的 bean 使用（参见 PropertyChangeEvent）。不过，此包中的大多数类由 bean 编辑器（即自定义 bean 并将其汇集起来以创建应用程序的开发环境）使用。特别要指出的是，这些类帮助 bean 编辑器创建用户可以用来自定义 bean 的用户界面。例如，bean 可能包含 bean 编辑器也许不知道如何处理的特殊类型的属性。通过使用 PropertyEditor 接口，bean 开发人员可以为此特殊类型提供一个编辑器。

为了最大限度地减少 bean 使用的资源，只在要编辑 bean 时加载 bean 编辑器使用的类。当 bean 以应用程序的形式运行时，不需要这些类，所以不用加载它们。此信息在称为 bean-info 的类中（参见 BeanInfo）。

除非显式声明，否则 null 值或空 String 对于此包中的方法是无效参数。如果使用这些参数，可能将引发异常。

长期持久性

从 v1.4 开始，java.beans 包提供了对长期持久性 的支持，即以其属性值的文本表示形式读取或写入 bean。这些属性值被视为 bean，它们被递归地读取或写入，以捕获其公共可用状态。此方法适用于长期存储，因为它只依赖于公共 API 而不是很可能发生更改的私有实现。
注： 持久性方案无法自动实例化自定义内部类，比如用于事件处理程序。通过使用 EventHandler 类而不是自定义事件处理程序的内部类，可以避免此问题。

可分别使用 XMLDecoder 和 XMLEncoder 类读取和写出 XML 格式的 bean。持久性方案的一个显著特性是，读入 bean 不需要该 bean 的特定信息。

另一方面，写出 bean 有时需要 bean 类型的特定信息。如果可以只使用无参数构造方法以及公共获取方法和设置方法表达 bean 的状态，则无需 bean 的特定信息。否则，bean 需要一个自定义持久委托，即负责写出特殊类型的 bean 的对象。从 java.awt.Component 继承的 JDK 中提供的所有类及其所有属性都将自动拥有持久委托。

如果需要（或选择）为 bean 提供持久委托，则可以通过使用 DefaultPersistenceDelegate 实例或通过创建自己的 PersistenceDelegate 子类来实现。如果 bean 需要持久委托的唯一原因是因为用户想调用 bean 使用属性值作为参数的构造方法，则可以使用单参数的 DefaultPersistenceDelegate 构造方法创建 bean 的持久委托。否则，用户需要实现自己的持久委托，对此，可能需要以下类：

PersistenceDelegate
这是一个抽象类，所有持久委托都是从它遗传的。子类应该使用它所知的 bean 类型信息来提供创建 bean 和恢复其状态所需的任何 Statement 和 Expression。
Statement
表示某一对象上的单个方法的调用。包括该方法的参数集合。
Expression
用于返回一个值的那些方法的 Statement 的子类。

一旦创建了一个持久委托，就可以使用 XMLEncoder 的 setPersistenceDelegate 方法注册它。

相关文档

有关概述、架构和教程文档的信息，请参阅：
  • JavaBeans，The Java Tutorial 的结尾处。
  • Long-Term Persistence，The Swing Connection 中的一篇文章。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.beans 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.beans 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.beans.Beans
    • java.beans.Encoder
      • java.beans.XMLEncoder
    • java.beans.EventHandler (implements java.lang.reflect.InvocationHandler)
    • java.util.EventListenerProxy (implements java.util.EventListener)
      • java.beans.PropertyChangeListenerProxy (implements java.beans.PropertyChangeListener)
      • java.beans.VetoableChangeListenerProxy (implements java.beans.VetoableChangeListener)
    • java.util.EventObject (implements java.io.Serializable)
      • java.beans.PropertyChangeEvent
        • java.beans.IndexedPropertyChangeEvent
    • java.beans.FeatureDescriptor
      • java.beans.BeanDescriptor
      • java.beans.EventSetDescriptor
      • java.beans.MethodDescriptor
      • java.beans.ParameterDescriptor
      • java.beans.PropertyDescriptor
        • java.beans.IndexedPropertyDescriptor
    • java.beans.Introspector
    • java.beans.PersistenceDelegate
      • java.beans.DefaultPersistenceDelegate
    • java.beans.PropertyChangeSupport (implements java.io.Serializable)
    • java.beans.PropertyEditorManager
    • java.beans.PropertyEditorSupport (implements java.beans.PropertyEditor)
    • java.beans.SimpleBeanInfo (implements java.beans.BeanInfo)
    • java.beans.Statement
      • java.beans.Expression
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.beans.IntrospectionException
        • java.beans.PropertyVetoException
    • java.beans.VetoableChangeSupport (implements java.io.Serializable)
    • java.beans.XMLDecoder

接口分层结构

  • java.beans.AppletInitializer
  • java.beans.BeanInfo
  • java.beans.Customizer
  • java.beans.DesignMode
  • java.util.EventListener
    • java.beans.PropertyChangeListener
    • java.beans.VetoableChangeListener
  • java.beans.ExceptionListener
  • java.beans.PropertyEditor
  • java.beans.Visibility

注释类型分层结构

  • java.beans.ConstructorProperties (implements java.lang.annotation.Annotation)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.beans 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.beans
的使用

使用 java.beans 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 使用的 java.beans 中的类
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
PropertyChangeSupport
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
PropertyVetoException
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
VetoableChangeListener
只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。

java.beans 使用的 java.beans 中的类
AppletInitializer
此接口设计用于与 java.beans.Beans.instantiate 联合使用。
BeanDescriptor
BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。
BeanInfo
希望提供有关其 bean 的显式信息的 bean 实现者可以提供某个 BeanInfo 类，该类实现此 BeanInfo 接口并提供有关其 bean 的方法、属性、事件等显式信息。
Encoder
Encoder 是这样的类，它可用于创建根据其公共 API 对 JavaBeans 集合状态进行编码的文件或流。
EventSetDescriptor
描述给定 Java bean 激发的一组事件的 EventSetDescriptor。
ExceptionListener
ExceptionListener 是在发生内部异常时获得通知。
Expression
Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。
FeatureDescriptor
FeatureDescriptor 类是 PropertyDescriptor、EventSetDescriptor 和 MethodDescriptor 等的公共基类。
IntrospectionException
在 Introspection 期间发生异常时抛出异常。
MethodDescriptor
MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。
ParameterDescriptor
ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。
PersistenceDelegate
PersistenceDelegate 类负责根据类的公共 API 中的方法表示给定类的实例状态。
PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
PropertyDescriptor
PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。
PropertyEditor
PropertyEditor 类为希望允许用户编辑某个给定类型的属性值的 GUI 提供支持。
PropertyVetoException
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
Statement
Statement 对象表示基本语句，其中将单个方法应用于某一目标和一组参数，以返回结果，比如 "a.setFoo(b)"。
VetoableChangeListener
只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。

java.beans.beancontext 使用的 java.beans 中的类
BeanInfo
希望提供有关其 bean 的显式信息的 bean 实现者可以提供某个 BeanInfo 类，该类实现此 BeanInfo 接口并提供有关其 bean 的方法、属性、事件等显式信息。
DesignMode
此接口由 java.beans.beancontext.BeanContext 的实例实现或委托，以便将当前的 "designTime" 属性传播到 java.beans.beancontext.BeanContextChild 实例的嵌套层次结构。
PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
PropertyChangeSupport
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
PropertyVetoException
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
VetoableChangeListener
只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。
VetoableChangeSupport
这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。
Visibility
在某些情况下，bean 可能运行在 GUI 不可用的服务器上。

java.lang.management 使用的 java.beans 中的类
ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.util.jar 使用的 java.beans 中的类
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。

java.util.logging 使用的 java.beans 中的类
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。

javax.accessibility 使用的 java.beans 中的类
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。

javax.swing 使用的 java.beans 中的类
PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
PropertyChangeSupport
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
PropertyVetoException
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
VetoableChangeListener
只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。

javax.swing.event 使用的 java.beans 中的类
PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeSupport
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。

javax.swing.plaf.basic 使用的 java.beans 中的类
PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。

javax.swing.plaf.metal 使用的 java.beans 中的类
PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。

javax.swing.table 使用的 java.beans 中的类
PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。

javax.swing.tree 使用的 java.beans 中的类
PropertyChangeListener
无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BeanContext (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContext

所有超级接口：
BeanContextChild, Collection, DesignMode, Iterable, Visibility
所有已知子接口：
BeanContextServices
所有已知实现类：
BeanContextServicesSupport, BeanContextSupport
public interface BeanContext
extends BeanContextChild, Collection, DesignMode, Visibility

BeanContext 是 JavaBean 的逻辑层次容器。

从以下版本开始：
1.2
另请参见：
Beans, BeanContextChild, BeanContextMembershipListener, PropertyChangeEvent, java.beans.VetoableChangeEvent, DesignMode, Visibility, Collection

字段摘要
static Object globalHierarchyLock
BeanContext 和 BeanContextServices 实现者均使用此全局锁定来序列化 BeanContext 中的更改和所有服务请求等。
从接口 java.beans.DesignMode 继承的字段
PROPERTYNAME
方法摘要
 void addBeanContextMembershipListener(BeanContextMembershipListener bcml)
添加指定的 BeanContextMembershipListener，以便无论何时添加或移除一个子 Component，都可以接收来自此 BeanContext 的 BeanContextMembershipEvents。
 URL getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 Object instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。
 void removeBeanContextMembershipListener(BeanContextMembershipListener bcml)
移除指定的 BeanContextMembershipListener，以便在添加或移除子 Component 时不再接收 BeanContextMembershipEvent。
从接口 java.beans.beancontext.BeanContextChild 继承的方法
addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext
从接口 java.util.Collection 继承的方法
add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray
从接口 java.beans.DesignMode 继承的方法
isDesignTime, setDesignTime
从接口 java.beans.Visibility 继承的方法
avoidingGui, dontUseGui, needsGui, okToUseGui

字段详细信息

globalHierarchyLock

static final Object globalHierarchyLock
BeanContext 和 BeanContextServices 实现者均使用此全局锁定来序列化 BeanContext 中的更改和所有服务请求等。

方法详细信息

instantiateChild

Object instantiateChild(String beanName)
                        throws IOException,
                               ClassNotFoundException
实例化指定为此 BeanContext 的一个子级的 javaBean。JavaBean 的实现源自 beanName 参数的值，并由 java.beans.Beans.instantiate() 方法定义。

参数：
beanName - 要实例化为此 BeanContext 的子级的 JavaBean 的名称
抛出：
IOException
ClassNotFoundException - 如果没有找到由 beanName 参数标识的类
IOException
ClassNotFoundException

getResourceAsStream

InputStream getResourceAsStream(String name,
                                BeanContextChild bcc)
                                throws IllegalArgumentException
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

参数：
name - 资源的名称
bcc - 指定的子级
返回：
用于读取资源的 InputStream，如果无法找到资源，则返回 null。
抛出：
IllegalArgumentException - 如果资源无效
IllegalArgumentException

getResource

URL getResource(String name,
                BeanContextChild bcc)
                throws IllegalArgumentException
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

参数：
name - 资源的名称
bcc - 指定的子级
返回：
指定子级的指定资源的 URL
抛出：
IllegalArgumentException - 如果资源无效
IllegalArgumentException

addBeanContextMembershipListener

void addBeanContextMembershipListener(BeanContextMembershipListener bcml)
添加指定的 BeanContextMembershipListener，以便无论何时添加或移除一个子 Component，都可以接收来自此 BeanContext 的 BeanContextMembershipEvents。

参数：
bcml - 要添加的 BeanContextMembershipListener

removeBeanContextMembershipListener

void removeBeanContextMembershipListener(BeanContextMembershipListener bcml)
移除指定的 BeanContextMembershipListener，以便在添加或移除子 Component 时不再接收 BeanContextMembershipEvent。

参数：
bcml - 要移除的 BeanContextMembershipListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BeanContextChild (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextChild

所有已知子接口：
BeanContext, BeanContextServices
所有已知实现类：
BeanContextChildSupport, BeanContextServicesSupport, BeanContextSupport
public interface BeanContextChild

正如 BeanContext 子接口所定义的，希望在其中进行嵌套并获得对其执行环境（或文本）的引用的 JavaBeans 应该实现此接口。

作为添加 BeanContextChild 对象的副作用，遵守此接口的 BeanContext 应该通过接口的 setBeanContext() 方法将一个引用传递给自身。

注意，BeanContextChild 可能通过在响应时抛出 PropertyVetoedException 来对拒绝状态的更改。

为了使持久性机制在各种情况下都能在 BeanContextChild 实例上正确地发挥作用，此接口的实现类需要所有或全部的字段（或实例变量）定义为 transient，这些字段可能包含（或表示）对嵌套 BeanContext 实例或通过任何未指定的机制从 BeanContext 中获得的其他资源的引用。

从以下版本开始：
1.2
另请参见：
BeanContext, PropertyChangeEvent, PropertyChangeListener, java.beans.PropertyVetoEvent, java.beans.PropertyVetoListener, PropertyVetoException

方法摘要
void | addPropertyChangeListener(String name, PropertyChangeListener pcl) 将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。
void | addVetoableChangeListener(String name, VetoableChangeListener vcl) 将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。
BeanContext | getBeanContext() 获得与此 BeanContextChild 相关联的 BeanContext。
void | removePropertyChangeListener(String name, PropertyChangeListener pcl) 从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。
void | removeVetoableChangeListener(String name, VetoableChangeListener vcl) 从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。
void | setBeanContext(BeanContext bc) 实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。

方法详细信息

setBeanContext

void setBeanContext(BeanContext bc)
                    throws PropertyVetoException

实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。

可以通过抛出适当异常来禁止对此 BeanContextChild 的嵌套 BeanContext 属性值进行更改。

参数：
bc - 与此 BeanContextChild 相关联的 BeanContext。
抛出：
PropertyVetoException - 如果拒绝添加指定的 BeanContext。
PropertyVetoException

getBeanContext

BeanContext getBeanContext()
获得与此 BeanContextChild 相关联的 BeanContext。

返回：
与此 BeanContextChild 相关联的 BeanContext。

addPropertyChangeListener

void addPropertyChangeListener(String name,
                               PropertyChangeListener pcl)
将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。

参数：
name - 要侦听的属性的名称
pcl - 要添加的 PropertyChangeListener

removePropertyChangeListener

void removePropertyChangeListener(String name,
                                  PropertyChangeListener pcl)
从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。

参数：
name - 已被侦听的属性的名称
pcl - 要移除的 PropertyChangeListener

addVetoableChangeListener

void addVetoableChangeListener(String name,
                               VetoableChangeListener vcl)
将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。

参数：
name - 要侦听的属性的名称
vcl - 要添加的 VetoableChangeListener

removeVetoableChangeListener

void removeVetoableChangeListener(String name,
                                  VetoableChangeListener vcl)
从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。

参数：
name - 已被侦听的属性的名称。
vcl - 要移除的 VetoableChangeListener。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextChildComponentProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextChildComponentProxy

public interface BeanContextChildComponentProxy

此接口由具有与之相关的 AWT Component 的 BeanContextChildren 实现。

从以下版本开始：
1.2
另请参见：
BeanContext, BeanContextSupport

方法摘要
 Component getComponent()
获得与此 BeanContextChild 相关联的 java.awt.Component。

方法详细信息

getComponent

Component getComponent()
获得与此 BeanContextChild 相关联的 java.awt.Component。

返回：
与此 BeanContextChild 相关联的 Component
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextChildSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextChildSupport

java.lang.Object
    继承者  java.beans.beancontext.BeanContextChildSupport
所有已实现的接口：
BeanContextChild, BeanContextServiceRevokedListener, BeanContextServicesListener, Serializable, EventListener
直接已知子类：
BeanContextSupport
public class BeanContextChildSupport
extends Object
implements BeanContextChild, BeanContextServicesListener, Serializable

这是一个为实现 BeanContextChild 协议提供支持的一般支持类。 要为给定的组件实现此接口，可以直接为此类创建子类，也可以封装和委托此类。

从以下版本开始：
1.2
另请参见：
BeanContext, BeanContextServices, BeanContextChild, 序列化表格

字段摘要
protected BeanContext | beanContext
BeanContextChild | beanContextChildPeer 在其中嵌套此 BeanContextChild 的 BeanContext。
protected PropertyChangeSupport | pcSupport 与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。
protected boolean | rejectedSetBCOnce 一个标志，指示在试图执行 setBeanContext 操作时，至少已经抛出了一个 PropertyChangeVetoException。
protected VetoableChangeSupport | vcSupport 与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。
构造方法摘要
BeanContextChildSupport()
构造一个 BeanContextChildSupport，其中已经为此类创建了子类以便实现 JavaBean 组件自身。
BeanContextChildSupport(BeanContextChild bcc)
构造一个 BeanContextChildSupport，其中 JavaBean 组件自身实现 BeanContextChild 并封装它，并将该接口委托给此实现
方法摘要
void | addPropertyChangeListener(String name, PropertyChangeListener pcl) 为特定属性添加一个 PropertyChangeListener。
void | addVetoableChangeListener(String name, VetoableChangeListener vcl) 为特定属性添加一个 VetoableChangeListener。
void | firePropertyChange(String name, Object oldValue, Object newValue) 向所有已注册的侦听器报告绑定 (bound) 属性更新。
void | fireVetoableChange(String name, Object oldValue, Object newValue) 向所有已注册的侦听器报告 vetoable 属性更新。
BeanContext | getBeanContext() 获得此 BeanContextChildSupport 的嵌套 BeanContext。
BeanContextChild | getBeanContextChildPeer() 获得与此 BeanContextChildSupport 相关联的 BeanContextChild。
protected void | initializeBeanContextResources() 子类可重写此方法来提供它们自己的初始化行为。
boolean | isDelegated() 报告此类是否是另一个类的委托。
protected void | releaseBeanContextResources() 子类可重写此方法来提供它们自己的释放行为。
void | removePropertyChangeListener(String name, PropertyChangeListener pcl) 为特定属性移除一个 PropertyChangeListener。
void | removeVetoableChangeListener(String name, VetoableChangeListener vcl) 移除一个 VetoableChangeListener。
void | serviceAvailable(BeanContextServiceAvailableEvent bcsae) 可从嵌套 BeanContext 中获得新的服务。
void | serviceRevoked(BeanContextServiceRevokedEvent bcsre) 由嵌套 BeanContext 提供的服务已经被取消。
void | setBeanContext(BeanContext bc) 设置此 BeanContextChildSupport 的 BeanContext。
boolean | validatePendingSetBeanContext(BeanContext newValue) 从 setBeanContext 调用，以验证（或相反）嵌套 BeanContext 属性值中的挂起更改。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

beanContextChildPeer

public BeanContextChild beanContextChildPeer
在其中嵌套此 BeanContextChild 的 BeanContext。

pcSupport

protected PropertyChangeSupport pcSupport
与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。

vcSupport

protected VetoableChangeSupport vcSupport
与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。

beanContext

protected transient BeanContext beanContext

rejectedSetBCOnce

protected transient boolean rejectedSetBCOnce
一个标志，指示在试图执行 setBeanContext 操作时，至少已经抛出了一个 PropertyChangeVetoException。

构造方法详细信息

BeanContextChildSupport

public BeanContextChildSupport()
构造一个 BeanContextChildSupport，其中已经为此类创建了子类以便实现 JavaBean 组件自身。

BeanContextChildSupport

public BeanContextChildSupport(BeanContextChild bcc)
构造一个 BeanContextChildSupport，其中 JavaBean 组件自身实现 BeanContextChild 并封装它，并将该接口委托给此实现

方法详细信息

setBeanContext

public void setBeanContext(BeanContext bc)
                    throws PropertyVetoException
设置此 BeanContextChildSupport 的 BeanContext。

指定者：
接口 BeanContextChild 中的 setBeanContext
参数：
bc - 分配给 BeanContext 属性的新值
抛出：
PropertyVetoException - 如果拒绝更改
PropertyVetoException

getBeanContext

public BeanContext getBeanContext()
获得此 BeanContextChildSupport 的嵌套 BeanContext。

指定者：
接口 BeanContextChild 中的 getBeanContext
返回：
此 BeanContextChildSupport 的嵌套 BeanContext。

addPropertyChangeListener

public void addPropertyChangeListener(String name,
                                      PropertyChangeListener pcl)
为特定属性添加一个 PropertyChangeListener。可以多次添加同一侦听器对象。对于每个属性，该侦听器被调用的次数与为该属性添加此侦听器的次数相同。如果 name 或 pcl 为 null，则不会抛出任何异常并且不执行任何操作。

指定者：
接口 BeanContextChild 中的 addPropertyChangeListener
参数：
name - 要侦听的属性的名称
pcl - 要添加的 PropertyChangeListener

removePropertyChangeListener

public void removePropertyChangeListener(String name,
                                         PropertyChangeListener pcl)
为特定属性移除一个 PropertyChangeListener。如果将 pcl 多次添加到指定属性的同一事件源，则在被移除之后，它获得的通知将减少一次。如果 name 为 null，则不会抛出任何异常并且不执行任何操作。如果 pcl 为 null，或者从不为指定属性添加 pcl，则不抛出任何异常并且不执行任何操作。

指定者：
接口 BeanContextChild 中的 removePropertyChangeListener
参数：
name - 已被侦听的属性的名称
pcl - 要移除的 PropertyChangeListener

addVetoableChangeListener

public void addVetoableChangeListener(String name,
                                      VetoableChangeListener vcl)
为特定属性添加一个 VetoableChangeListener。可以多次添加同一侦听器对象。对于每个属性，该侦听器被调用的次数与为该属性添加此侦听器的次数相同。如果 name 或 vcl 为 null，则不会抛出任何异常并且不执行任何操作。

指定者：
接口 BeanContextChild 中的 addVetoableChangeListener
参数：
name - 要侦听的属性的名称
vcl - 要添加的 VetoableChangeListener

removeVetoableChangeListener

public void removeVetoableChangeListener(String name,
                                         VetoableChangeListener vcl)
移除一个 VetoableChangeListener。如果将 pcl 多次添加到指定属性的同一事件源，则在被移除之后，它获得的通知将减少一次。如果 name 为 null，则不会抛出任何异常并且不执行任何操作。如果 vcl 为 null，或者从不为指定属性添加 pcl，则不抛出任何异常并且不执行任何操作。

指定者：
接口 BeanContextChild 中的 removeVetoableChangeListener
参数：
name - 已被侦听的属性的名称
vcl - 要移除的 VetoableChangeListener

serviceRevoked

public void serviceRevoked(BeanContextServiceRevokedEvent bcsre)
由嵌套 BeanContext 提供的服务已经被取消。 子类可以重写此方法以便实现自己的行为。

指定者：
接口 BeanContextServiceRevokedListener 中的 serviceRevoked
参数：
bcsre - 由于取消服务而触发的 BeanContextServiceRevokedEvent

serviceAvailable

public void serviceAvailable(BeanContextServiceAvailableEvent bcsae)
可从嵌套 BeanContext 中获得新的服务。 子类可以重写此方法以便实现自己的行为。

指定者：
接口 BeanContextServicesListener 中的 serviceAvailable
参数：
bcsae - 由于服务变得可用而触发的 BeanContextServiceAvailableEvent

getBeanContextChildPeer

public BeanContextChild getBeanContextChildPeer()
获得与此 BeanContextChildSupport 相关联的 BeanContextChild。

返回：
此类的 BeanContextChild 同位体。

isDelegated

public boolean isDelegated()
报告此类是否是另一个类的委托。

返回：
true 如果此类是另一个类的委托

firePropertyChange

public void firePropertyChange(String name,
                               Object oldValue,
                               Object newValue)
向所有已注册的侦听器报告绑定 (bound) 属性更新。如果新属性和旧属性相同并且是非 null 的，则不会触发事件。

参数：
name - 已更改属性的编程名称
oldValue - 属性的旧值
newValue - 属性的新值

fireVetoableChange

public void fireVetoableChange(String name,
                               Object oldValue,
                               Object newValue)
                        throws PropertyVetoException
向所有已注册的侦听器报告 vetoable 属性更新。如果任何人禁止更改，则触发一个新的事件，该事件将每个人的属性还原为旧值，然后再次抛出 PropertyVetoException。

如果新属性和旧属性相等并且是非 null 的，则不会触发事件。

参数：
name - 将更改属性的编程名称
oldValue - 属性的旧值
newValue - 属性的新值
抛出：
PropertyVetoException - 如果接收方希望回滚属性更改。

validatePendingSetBeanContext

public boolean validatePendingSetBeanContext(BeanContext newValue)
从 setBeanContext 调用，以验证（或相反）嵌套 BeanContext 属性值中的挂起更改。返回 false 将造成 setBeanContext 抛出 PropertyVetoException。

参数：
newValue - 已为 BeanContext 属性请求的新值
返回：
如果禁止执行更改操作，则返回 true

releaseBeanContextResources

protected void releaseBeanContextResources()
子类可重写此方法来提供它们自己的释放行为。在调用此方法时，应该释放此实例从其当前 BeanContext 属性中获得的所有资源，因为对象不再嵌套在 BeanContext 中。

initializeBeanContextResources

protected void initializeBeanContextResources()
子类可重写此方法来提供它们自己的初始化行为。在调用此方法时，BeanContextChild 所需的资源应该从当前 BeanContext 中获得。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextContainerProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextContainerProxy

public interface BeanContextContainerProxy

此接口由具有与之关联的 AWT Container 的 BeanContext 实现。

从以下版本开始：
1.2
另请参见：
BeanContext, BeanContextSupport

方法摘要
 Container getContainer()
获得与此 BeanContext 相关联的 java.awt.Container。

方法详细信息

getContainer

Container getContainer()
获得与此 BeanContext 相关联的 java.awt.Container。

返回：
与此 BeanContext 相关联的 java.awt.Container。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.beans.beancontext.BeanContextEvent
所有已实现的接口：
Serializable
直接已知子类：
BeanContextMembershipEvent, BeanContextServiceAvailableEvent, BeanContextServiceRevokedEvent
public abstract class BeanContextEvent
extends EventObject

BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。此类引入某种机制来允许 BeanContextEvent 子类通过 BeanContext 的层次结构进行传播。setPropagatedFrom() 和 getPropagatedFrom() 方法允许 BeanContext 将自身标识为传播事件的源。

从以下版本开始：
1.2
另请参见：
BeanContext, 序列化表格

字段摘要
protected  BeanContext propagatedFrom
作为此事件传播源的 BeanContext
从类 java.util.EventObject 继承的字段
source
构造方法摘要
protected BeanContextEvent(BeanContext bc)
构造一个 BeanContextEvent
方法摘要
BeanContext | getBeanContext() 获得与此事件相关联的 BeanContext。
BeanContext | getPropagatedFrom() 获得作为此事件传播源的 BeanContext。
boolean | isPropagated() 报告此事件是否传播自某些其他 BeanContext。
void | setPropagatedFrom(BeanContext bc) 设置作为此事件传播源的 BeanContext。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

propagatedFrom

protected BeanContext propagatedFrom
作为此事件传播源的 BeanContext

构造方法详细信息

BeanContextEvent

protected BeanContextEvent(BeanContext bc)
构造一个 BeanContextEvent

参数：
bc - BeanContext 源
方法详细信息

getBeanContext

public BeanContext getBeanContext()
获得与此事件相关联的 BeanContext。

返回：
与此事件相关联的 BeanContext。

setPropagatedFrom

public void setPropagatedFrom(BeanContext bc)
设置作为此事件传播源的 BeanContext。

参数：
bc - 作为此事件传播源的 BeanContext

getPropagatedFrom

public BeanContext getPropagatedFrom()
获得作为此事件传播源的 BeanContext。

返回：
作为此事件传播源的 BeanContext

isPropagated

public boolean isPropagated()
报告此事件是否传播自某些其他 BeanContext。

返回：
如果传播而来则返回 true，否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextMembershipEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextMembershipEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.beans.beancontext.BeanContextEvent
            继承者  java.beans.beancontext.BeanContextMembershipEvent
所有已实现的接口：
Serializable
public class BeanContextMembershipEvent
extends BeanContextEvent

BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。只要在给定 BeanContext 实例上成功调用 add()、remove()、retainAll()、removeAll() 或 clear()，就会触发此事件的一个实例。对接收此类型的事件感兴趣的对象必须实现 BeanContextMembershipListener 接口，并且必须通过 BeanContext 的 addBeanContextMembershipListener(BeanContextMembershipListener bcml) 方法注册其意向。

从以下版本开始：
1.2
另请参见：
BeanContext, BeanContextEvent, BeanContextMembershipListener, 序列化表格

字段摘要
protected  Collection children
受此事件通知影响的子级的列表。
从类 java.beans.beancontext.BeanContextEvent 继承的字段
propagatedFrom
从类 java.util.EventObject 继承的字段
source
构造方法摘要
BeanContextMembershipEvent(BeanContext bc, Collection changes)
构造一个 BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext bc, Object[] changes)
构造一个 BeanContextMembershipEvent
方法摘要
boolean | contains(Object child) 指定子级受事件影响吗？
Iterator | iterator() 获得受此事件影响的子级的数组。
int | size() 获得受通知影响的子级的数量。
Object[] | toArray() 获得受此事件影响的子级的数组。
从类 java.beans.beancontext.BeanContextEvent 继承的方法
getBeanContext, getPropagatedFrom, isPropagated, setPropagatedFrom
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

children

protected Collection children
受此事件通知影响的子级的列表。

构造方法详细信息

BeanContextMembershipEvent

public BeanContextMembershipEvent(BeanContext bc,
                                  Collection changes)
构造一个 BeanContextMembershipEvent

参数：
bc - BeanContext 源
changes - 受影响的 Children
抛出：
NullPointerException - 如果 changes 为 null

BeanContextMembershipEvent

public BeanContextMembershipEvent(BeanContext bc,
                                  Object[] changes)
构造一个 BeanContextMembershipEvent

参数：
bc - BeanContext 源
changes - 受影响的 Children
抛出：
NullPointerException - 如果与此事件关联的更改为 null。
方法详细信息

size

public int size()
获得受通知影响的子级的数量。

返回：
受通知影响的子级的数量

contains

public boolean contains(Object child)
指定子级受事件影响吗？

返回：
如果受影响则返回 true，否则返回 false

toArray

public Object[] toArray()
获得受此事件影响的子级的数组。

返回：
受影响的子级的数组

iterator

public Iterator iterator()
获得受此事件影响的子级的数组。

返回：
受影响的子级的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextMembershipListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextMembershipListener

所有超级接口：
EventListener
public interface BeanContextMembershipListener
extends EventListener

当 BeanContext 的成员关系状态发生更改时，兼容的 BeanContext 在此接口上触发事件。

从以下版本开始：
1.2
另请参见：
BeanContext

方法摘要
void | childrenAdded(BeanContextMembershipEvent bcme) 在将一个子级或子级列表添加到此侦听器在其中注册的 BeanContext 中时调用。
void | childrenRemoved(BeanContextMembershipEvent bcme) 在将一个子级或子级列表从此侦听器在其中注册的 BeanContext 中移除时调用。

方法详细信息

childrenAdded

void childrenAdded(BeanContextMembershipEvent bcme)
在将一个子级或子级列表添加到此侦听器在其中注册的 BeanContext 中时调用。

参数：
bcme - 描述所发生更改的 BeanContextMembershipEvent。

childrenRemoved

void childrenRemoved(BeanContextMembershipEvent bcme)
在将一个子级或子级列表从此侦听器在其中注册的 BeanContext 中移除时调用。

参数：
bcme - 描述所发生更改的 BeanContextMembershipEvent。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextProxy

public interface BeanContextProxy

此接口由并不直接拥有（通过实现该接口或一个子接口拥有）与之关联的 BeanContext(Child)，但是拥有它代理的一个公共 BeanContext(Child) 的 JavaBean 实现。例如，java.awt.Container 的子类可以有一个与之关联的 BeanContext，它将包含该 Container 的所有子 Component。

一个对象不能同时实现此接口和 BeanContextChild 接口（或者所有子接口），它们互不相容。

为了获得 BeanContextChild 的特定子接口，此接口的调用者应检查返回类型，如下所示：

 BeanContextChild bcc = o.getBeanContextProxy();

 if (bcc instanceof BeanContext) {
        // ...
 }

 or

 BeanContextChild bcc = o.getBeanContextProxy();
 BeanContext      bc  = null;

 try {
     bc = (BeanContext)bcc;
 } catch (ClassCastException cce) {
     // cast failed, bcc is not an instanceof BeanContext
 }

返回值是一个常量，表示实现实例的生存期

从以下版本开始：
1.2
另请参见：
BeanContextChild, BeanContextChildSupport

方法摘要
 BeanContextChild getBeanContextProxy()
获得与此对象相关联的 BeanContextChild（或子接口）。

方法详细信息

getBeanContextProxy

BeanContextChild getBeanContextProxy()
获得与此对象相关联的 BeanContextChild（或子接口）。

返回：
与此对象相关联的 BeanContextChild（或子接口）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServiceAvailableEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextServiceAvailableEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.beans.beancontext.BeanContextEvent
            继承者  java.beans.beancontext.BeanContextServiceAvailableEvent
所有已实现的接口：
Serializable
public class BeanContextServiceAvailableEvent
extends BeanContextEvent

BeanContextServicesListener 使用此事件类型来标识将被注册的服务。

另请参见：
序列化表格

字段摘要
protected  Class serviceClass
新近可用服务的 Class 引用
从类 java.beans.beancontext.BeanContextEvent 继承的字段
propagatedFrom
从类 java.util.EventObject 继承的字段
source
构造方法摘要
BeanContextServiceAvailableEvent(BeanContextServices bcs, Class sc)
构造一个 BeanContextAvailableServiceEvent。
方法摘要
Iterator | getCurrentServiceSelectors() 获得与服务相关的选择器列表。
Class | getServiceClass() 获得作为此通知主题的服务类。
BeanContextServices | getSourceAsBeanContextServices() 获得作为 BeanContextServices 类型引用的源。
从类 java.beans.beancontext.BeanContextEvent 继承的方法
getBeanContext, getPropagatedFrom, isPropagated, setPropagatedFrom
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

serviceClass

protected Class serviceClass
新近可用服务的 Class 引用

构造方法详细信息

BeanContextServiceAvailableEvent

public BeanContextServiceAvailableEvent(BeanContextServices bcs,
                                        Class sc)
构造一个 BeanContextAvailableServiceEvent。

参数：
bcs - 服务在其中变得可用的上下文
sc - 新近可用服务的 Class 引用
方法详细信息

getSourceAsBeanContextServices

public BeanContextServices getSourceAsBeanContextServices()
获得作为 BeanContextServices 类型引用的源。

返回：
服务在其中已变得可用的上下文

getServiceClass

public Class getServiceClass()
获得作为此通知主题的服务类。

返回：
新近可用服务的 Class 引用

getCurrentServiceSelectors

public Iterator getCurrentServiceSelectors()
获得与服务相关的选择器列表。

返回：
可从该服务中得到的当前选择器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServiceProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextServiceProvider

所有已知实现类：
BeanContextServicesSupport.BCSSProxyServiceProvider
public interface BeanContextServiceProvider

BeanContext 的主要功能之一是充当 JavaBeans 与 BeanContextServiceProviders 之间的集合点。

嵌套在 BeanContext 中的 JavaBean 可能要求 BeanContext 提供 "service" 的一个实例，该 JavaBean 基于表示该服务的 Java Class 对象的引用。

在上下文委托自己的上下文来满足服务请求的情况下，如果已经向上下文或其某个嵌套上下文注册了一个此类服务，那么会请求与该服务相关联的 BeanContextServiceProvider 提供该服务的一个实例。

ServcieProvider 可能总是返回相同的实例，它也可能为每个请求构造一个新的实例。

方法摘要
Iterator | getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass) 由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
Object | getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector) 由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
void | releaseService(BeanContextServices bcs, Object requestor, Object service) 由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。

方法详细信息

getService

Object getService(BeanContextServices bcs,
                  Object requestor,
                  Class serviceClass,
                  Object serviceSelector)
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。

参数：
bcs - 与此特定请求相关联的 BeanContextServices。此参数允许 BeanContextServiceProvider 区别来自多个源的服务请求。
requestor - 请求服务的对象
serviceClass - 请求的服务
serviceSelector - 用于特定服务的与服务有关的参数，如果不适用，则为 null。
返回：
所请求服务的一个引用

releaseService

void releaseService(BeanContextServices bcs,
                    Object requestor,
                    Object service)
由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。

参数：
bcs - 与此特定释放请求相关联的 BeanContextServices
requestor - 请求释放服务的对象
service - 要释放的服务

getCurrentServiceSelectors

Iterator getCurrentServiceSelectors(BeanContextServices bcs,
                                    Class serviceClass)
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。服务选择器是一种特定于服务的参数，它的典型示例可能包括：用于服务实现类的构造方法的参数、特定服务的属性值或已存在实现的映射中的键。

参数：
bcs - 此请求的 BeanContextServices
serviceClass - 指定的服务
返回：
指定 serviceClass 的当前服务选择器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServiceProviderBeanInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextServiceProviderBeanInfo

所有超级接口：
BeanInfo
public interface BeanContextServiceProviderBeanInfo
extends BeanInfo

希望提供关于其 bean 可能提供服务的显式消息的 BeanContextServiceProvider 实现者应实现某个 BeanInfo 类，该类实现此 BeanInfo 的子接口并提供有关其服务的方法、属性、事件等显式信息。

字段摘要
从接口 java.beans.BeanInfo 继承的字段
ICON_COLOR_16x16, ICON_COLOR_32x32, ICON_MONO_16x16, ICON_MONO_32x32
方法摘要
 BeanInfo[] getServicesBeanInfo()
获得一个 BeanInfo 数组，为每个可从此 ServiceProvider 中静态得到的类或接口返回一个数组。
从接口 java.beans.BeanInfo 继承的方法
getAdditionalBeanInfo, getBeanDescriptor, getDefaultEventIndex, getDefaultPropertyIndex, getEventSetDescriptors, getIcon, getMethodDescriptors, getPropertyDescriptors

方法详细信息

getServicesBeanInfo

BeanInfo[] getServicesBeanInfo()
获得一个 BeanInfo 数组，为每个可从此 ServiceProvider 中静态得到的类或接口返回一个数组。

返回：
BeanInfo 数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServiceRevokedEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextServiceRevokedEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.beans.beancontext.BeanContextEvent
            继承者  java.beans.beancontext.BeanContextServiceRevokedEvent
所有已实现的接口：
Serializable
public class BeanContextServiceRevokedEvent
extends BeanContextEvent

BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。

另请参见：
序列化表格

字段摘要
protected  Class serviceClass
将被取消服务的 Class 引用。
从类 java.beans.beancontext.BeanContextEvent 继承的字段
propagatedFrom
从类 java.util.EventObject 继承的字段
source
构造方法摘要
BeanContextServiceRevokedEvent(BeanContextServices bcs, Class sc, boolean invalidate)
构造一个 BeanContextServiceEvent。
方法摘要
Class | getServiceClass() 获得作为此通知主题的服务类
BeanContextServices | getSourceAsBeanContextServices() 获得作为 BeanContextServices 类型引用的源
boolean | isCurrentServiceInvalidNow() 报告当前服务是否被强行取消，在该情况下，引用当前无效并且不能使用。
boolean | isServiceClass(Class service) 检查此事件，以确定将被取消的服务是否属于某个特定类。
从类 java.beans.beancontext.BeanContextEvent 继承的方法
getBeanContext, getPropagatedFrom, isPropagated, setPropagatedFrom
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

serviceClass

protected Class serviceClass
将被取消服务的 Class 引用。

构造方法详细信息

BeanContextServiceRevokedEvent

public BeanContextServiceRevokedEvent(BeanContextServices bcs,
                                      Class sc,
                                      boolean invalidate)
构造一个 BeanContextServiceEvent。

参数：
bcs - 将从中取消此服务的 BeanContextServices
sc - 将被取消的服务
invalidate - true 表示立即取消
方法详细信息

getSourceAsBeanContextServices

public BeanContextServices getSourceAsBeanContextServices()
获得作为 BeanContextServices 类型引用的源

返回：
将从中取消此服务的 BeanContextServices

getServiceClass

public Class getServiceClass()
获得作为此通知主题的服务类

返回：
将被取消服务的 Class 引用

isServiceClass

public boolean isServiceClass(Class service)
检查此事件，以确定将被取消的服务是否属于某个特定类。

参数：
service - 感兴趣的类（应该为非 null )
返回：
如果将被取消的服务与指定服务属于同一个类，则返回 true

isCurrentServiceInvalidNow

public boolean isCurrentServiceInvalidNow()
报告当前服务是否被强行取消，在该情况下，引用当前无效并且不能使用。

返回：
如果当前服务被强行取消，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServiceRevokedListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextServiceRevokedListener

所有超级接口：
EventListener
所有已知子接口：
BeanContextServices, BeanContextServicesListener
所有已知实现类：
BeanContextChildSupport, BeanContextServicesSupport, BeanContextServicesSupport.BCSSProxyServiceProvider, BeanContextSupport
public interface BeanContextServiceRevokedListener
extends EventListener

用于接收 BeanContextServiceRevokedEvent 对象的侦听器接口。对处理 BeanContextServiceRevokedEvent 感兴趣的类实现此接口。

方法摘要
 void serviceRevoked(BeanContextServiceRevokedEvent bcsre)
指定服务已被取消。

方法详细信息

serviceRevoked

void serviceRevoked(BeanContextServiceRevokedEvent bcsre)
指定服务已被取消。不再能满足此服务的 getService 请求。

参数：
bcsre - 由此侦听器接收的 BeanContextServiceRevokedEvent。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServices (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextServices

所有超级接口：
BeanContext, BeanContextChild, BeanContextServiceRevokedListener, BeanContextServicesListener, Collection, DesignMode, EventListener, Iterable, Visibility
所有已知实现类：
BeanContextServicesSupport
public interface BeanContextServices
extends BeanContext, BeanContextServicesListener

BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

字段摘要
从接口 java.beans.beancontext.BeanContext 继承的字段
globalHierarchyLock
从接口 java.beans.DesignMode 继承的字段
PROPERTYNAME
方法摘要
 void addBeanContextServicesListener(BeanContextServicesListener bcsl)
将一个 BeanContextServicesListener 添加到此 BeanContext
 boolean addService(Class serviceClass, BeanContextServiceProvider serviceProvider)
向此 BeanContext 添加服务。
 Iterator getCurrentServiceClasses()
获得此上下文的当前可用服务。
 Iterator getCurrentServiceSelectors(Class serviceClass)
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
 Object getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
 boolean hasService(Class serviceClass)
报告是否可以从此上下文中得到给定服务。
 void releaseService(BeanContextChild child, Object requestor, Object service)
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。
 void removeBeanContextServicesListener(BeanContextServicesListener bcsl)
从此 BeanContext 中移除一个 BeanContextServicesListener
 void revokeService(Class serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。
从接口 java.beans.beancontext.BeanContext 继承的方法
addBeanContextMembershipListener, getResource, getResourceAsStream, instantiateChild, removeBeanContextMembershipListener
从接口 java.beans.beancontext.BeanContextChild 继承的方法
addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext
从接口 java.util.Collection 继承的方法
add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray
从接口 java.beans.DesignMode 继承的方法
isDesignTime, setDesignTime
从接口 java.beans.Visibility 继承的方法
avoidingGui, dontUseGui, needsGui, okToUseGui
从接口 java.beans.beancontext.BeanContextServicesListener 继承的方法
serviceAvailable
从接口 java.beans.beancontext.BeanContextServiceRevokedListener 继承的方法
serviceRevoked

方法详细信息

addService

boolean addService(Class serviceClass,
                   BeanContextServiceProvider serviceProvider)
向此 BeanContext 添加服务。BeanContextServiceProvider 调用此方法来向此上下文注册一个特定服务。如果该服务不是以前已添加的服务，则 BeanContextServices 会将该服务与 BeanContextServiceProvider 相关联，并对所有当前已注册的 BeanContextServicesListeners 激发一个 BeanContextServiceAvailableEvent。然后该方法返回 true，指示成功添加了服务。如果已添加给定服务，则此方法仅返回 false。

参数：
serviceClass - 要添加的服务
serviceProvider - 与该服务相关联的 BeanContextServiceProvider

revokeService

void revokeService(Class serviceClass,
                   BeanContextServiceProvider serviceProvider,
                   boolean revokeCurrentServicesNow)
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。在撤消该服务时，BeanContextServices 对当前已注册的 BeanContextServiceRevokedListeners 和 BeanContextServicesListeners 的列表触发一个 BeanContextServiceRevokedEvent。

参数：
serviceClass - 要从此 BeanContextServices 中取消的服务
serviceProvider - 与将取消的特定服务有关联的 BeanContextServiceProvider
revokeCurrentServicesNow - 值为 true 指示一个异常环境，在该环境中，BeanContextServiceProvider 或 BeanContextServices 希望立即终止为指定服务的所有当前突出引用提供服务。

hasService

boolean hasService(Class serviceClass)
报告是否可以从此上下文中得到给定服务。

参数：
serviceClass - 相关服务
返回：
如果可得到服务，则返回 true

getService

Object getService(BeanContextChild child,
                  Object requestor,
                  Class serviceClass,
                  Object serviceSelector,
                  BeanContextServiceRevokedListener bcsrl)
                  throws TooManyListenersException
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。此方法在调用时通过在基础 BeanContextServiceProvider 上调用 getService() 获得服务。

参数：
child - 与此请求相关联的 BeanContextChild
requestor - 请求服务的对象
serviceClass - 所请求服务的类
serviceSelector - 与服务有关的参数
bcsrl - 通知稍后是否应该取消服务的 BeanContextServiceRevokedListener
返回：
所请求的此上下文的指定 Service 的引用，或 null
抛出：
TooManyListenersException

releaseService

void releaseService(BeanContextChild child,
                    Object requestor,
                    Object service)
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。

参数：
child - BeanContextChild
requestor - 请求者
service - 服务

getCurrentServiceClasses

Iterator getCurrentServiceClasses()
获得此上下文的当前可用服务。

返回：
由当前可用服务组成的 Iterator

getCurrentServiceSelectors

Iterator getCurrentServiceSelectors(Class serviceClass)
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。

参数：
serviceClass - 指定服务
返回：
指定 serviceClass 的当前可用的服务选择器

addBeanContextServicesListener

void addBeanContextServicesListener(BeanContextServicesListener bcsl)
将一个 BeanContextServicesListener 添加到此 BeanContext

参数：
bcsl - 要添加的 BeanContextServicesListener

removeBeanContextServicesListener

void removeBeanContextServicesListener(BeanContextServicesListener bcsl)
从此 BeanContext 中移除一个 BeanContextServicesListener

参数：
bcsl - 要从此上下文移除的 BeanContextServicesListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServicesListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
接口 BeanContextServicesListener

所有超级接口：
BeanContextServiceRevokedListener, EventListener
所有已知子接口：
BeanContextServices
所有已知实现类：
BeanContextChildSupport, BeanContextServicesSupport, BeanContextSupport
public interface BeanContextServicesListener
extends BeanContextServiceRevokedListener

用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。对处理 BeanContextServiceAvailableEvent 感兴趣的类实现此接口。

方法摘要
 void serviceAvailable(BeanContextServiceAvailableEvent bcsae)
指定服务已被注册。
从接口 java.beans.beancontext.BeanContextServiceRevokedListener 继承的方法
serviceRevoked

方法详细信息

serviceAvailable

void serviceAvailable(BeanContextServiceAvailableEvent bcsae)
指定服务已被注册。现在可以对此服务发出 getService 请求。

参数：
bcsae - BeanContextServiceAvailableEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServicesSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextServicesSupport

java.lang.Object
    继承者  java.beans.beancontext.BeanContextChildSupport
        继承者  java.beans.beancontext.BeanContextSupport
            继承者  java.beans.beancontext.BeanContextServicesSupport
所有已实现的接口：
BeanContext, BeanContextChild, BeanContextServiceRevokedListener, BeanContextServices, BeanContextServicesListener, DesignMode, PropertyChangeListener, VetoableChangeListener, Visibility, Serializable, Iterable, Collection, EventListener
public class BeanContextServicesSupport
extends BeanContextSupport
implements BeanContextServices

此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。

因为此类直接实现 BeanContextServices 接口，所以可以通过创建此实现的子类来使用该类，或者由通过 BeanContextProxy 接口的另一个实例对此类实例的委托来使用该类。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
protected class | BeanContextServicesSupport.BCSSChild
protected class | BeanContextServicesSupport.BCSSProxyServiceProvider
protected static class | BeanContextServicesSupport.BCSSServiceProvider 子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。
从类 java.beans.beancontext.BeanContextSupport 继承的嵌套类/接口
BeanContextSupport.BCSChild, BeanContextSupport.BCSIterator
字段摘要
protected ArrayList | bcsListeners BeanContextServicesListener 对象的列表。
protected BeanContextServicesSupport.BCSSProxyServiceProvider | proxy BeanContextServiceProvider 的委托。
protected int | serializable 可序列化 BeanContextServceProvider 的实例数。
protected HashMap | services protected transient HashMap services 字段的所有访问在该对象上都应该是同步的。
从类 java.beans.beancontext.BeanContextSupport 继承的字段
bcmListeners, children, designTime, locale, okToUseGui
从类 java.beans.beancontext.BeanContextChildSupport 继承的字段
beanContext, beanContextChildPeer, pcSupport, rejectedSetBCOnce, vcSupport
从接口 java.beans.beancontext.BeanContext 继承的字段
globalHierarchyLock
从接口 java.beans.DesignMode 继承的字段
PROPERTYNAME
构造方法摘要
BeanContextServicesSupport()
创建不是另一个对象代理的实例。
BeanContextServicesSupport(BeanContextServices peer)
创建一个具有同位体的实例
BeanContextServicesSupport(BeanContextServices peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextServicesSupport 实例
方法摘要
 void addBeanContextServicesListener(BeanContextServicesListener bcsl)
添加一个 BeanContextServicesListener。
 boolean addService(Class serviceClass, BeanContextServiceProvider bcsp)
添加服务。
protected  boolean addService(Class serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
添加服务。
protected  void bcsPreDeserializationHook(ObjectInputStream ois)
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
protected  void bcsPreSerializationHook(ObjectOutputStream oos)
在序列化子级之前，从 BeanContextSupport writeObject 中调用。
protected  void childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
在已成功移除子级之后，从超类的子级移除操作中调用。
protected  BeanContextSupport.BCSChild createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
protected  BeanContextServicesSupport.BCSSServiceProvider createBCSSServiceProvider(Class sc, BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。
protected  void fireServiceAdded(BeanContextServiceAvailableEvent bcssae)
触发一个指示新服务已变得可用的 BeanContextServiceAvailableEvent。
protected  void fireServiceAdded(Class serviceClass)
触发一个通知新服务的 BeanContextServiceEvent。
protected  void fireServiceRevoked(BeanContextServiceRevokedEvent bcsre)
触发一个通知将被取消的服务的 BeanContextServiceEvent。
protected  void fireServiceRevoked(Class serviceClass, boolean revokeNow)
触发一个指示某一特定服务不再可用的 BeanContextServiceRevokedEvent。
 BeanContextServices getBeanContextServicesPeer()
获得与此 BeanContextServicesSupport 相关联的 BeanContextServices。
protected static BeanContextServicesListener getChildBeanContextServicesListener(Object child)
获得指定子级的 BeanContextServicesListener（如果有）。
 Iterator getCurrentServiceClasses()
获得此上下文的当前可用服务。
 Iterator getCurrentServiceSelectors(Class serviceClass)
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
 Object getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。
 boolean hasService(Class serviceClass)
具有一个可被委托的服务。
 void initialize()
由 BeanContextSupport 超类在构造和反序列化期间调用，以初始化子类的瞬态。
protected  void initializeBeanContextResources()
从 setBeanContext 中调用，以通知 BeanContextChild 分配从嵌套 BeanContext 中获得的资源。
protected  void releaseBeanContextResources()
从 setBeanContext 中调用，以通知 BeanContextChild 释放从嵌套 BeanContext 中获得的资源。
 void releaseService(BeanContextChild child, Object requestor, Object service)
释放服务。
 void removeBeanContextServicesListener(BeanContextServicesListener bcsl)
移除一个 BeanContextServicesListener。
 void revokeService(Class serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
移除服务。
 void serviceAvailable(BeanContextServiceAvailableEvent bcssae)
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
 void serviceRevoked(BeanContextServiceRevokedEvent bcssre)
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
从类 java.beans.beancontext.BeanContextSupport 继承的方法
add, addAll, addBeanContextMembershipListener, avoidingGui, bcsChildren, childDeserializedHook, childJustAddedHook, classEquals, clear, contains, containsAll, containsKey, copyChildren, deserialize, dontUseGui, fireChildrenAdded, fireChildrenRemoved, getBeanContextPeer, getChildBeanContextChild, getChildBeanContextMembershipListener, getChildPropertyChangeListener, getChildSerializable, getChildVetoableChangeListener, getChildVisibility, getLocale, getResource, getResourceAsStream, instantiateChild, isDesignTime, isEmpty, isSerializing, iterator, needsGui, okToUseGui, propertyChange, readChildren, remove, remove, removeAll, removeBeanContextMembershipListener, retainAll, serialize, setDesignTime, setLocale, size, toArray, toArray, validatePendingAdd, validatePendingRemove, vetoableChange, writeChildren
从类 java.beans.beancontext.BeanContextChildSupport 继承的方法
addPropertyChangeListener, addVetoableChangeListener, firePropertyChange, fireVetoableChange, getBeanContext, getBeanContextChildPeer, isDelegated, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext, validatePendingSetBeanContext
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.beans.beancontext.BeanContext 继承的方法
addBeanContextMembershipListener, getResource, getResourceAsStream, instantiateChild, removeBeanContextMembershipListener
从接口 java.beans.beancontext.BeanContextChild 继承的方法
addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext
从接口 java.util.Collection 继承的方法
add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray
从接口 java.beans.DesignMode 继承的方法
isDesignTime, setDesignTime
从接口 java.beans.Visibility 继承的方法
avoidingGui, dontUseGui, needsGui, okToUseGui

字段详细信息

services

protected transient HashMap services
protected transient HashMap services 字段的所有访问在该对象上都应该是同步的。

serializable

protected transient int serializable
可序列化 BeanContextServceProvider 的实例数。

proxy

protected transient BeanContextServicesSupport.BCSSProxyServiceProvider proxy
BeanContextServiceProvider 的委托。

bcsListeners

protected transient ArrayList bcsListeners
BeanContextServicesListener 对象的列表。

构造方法详细信息

BeanContextServicesSupport

public BeanContextServicesSupport(BeanContextServices peer,
                                  Locale lcle,
                                  boolean dTime,
                                  boolean visible)

构造一个 BeanContextServicesSupport 实例

参数：
peer - 将为其提供实现的同位体 BeanContext，如果该参数为 null，则此对象是它自己的同位体
lcle - 此 BeanContext 的当前 Locale。
dtime - 初始状态，如果在设计模式下，则该参数为 true，如果在运行状态下，则该参数为 false。
visible - 初始可见性。

BeanContextServicesSupport

public BeanContextServicesSupport(BeanContextServices peer,
                                  Locale lcle,
                                  boolean dtime)
使用指定 Locale 和设计模式创建一个实例。

参数：
peer - 将为其提供实现的同位体 BeanContext，如果该参数为 null，则此对象是它自己的同位体
lcle - 此 BeanContext 的当前 Locale。
dtime - 初始状态，如果在设计模式下，则该参数为 true，如果在运行状态下，则该参数为 false。

BeanContextServicesSupport

public BeanContextServicesSupport(BeanContextServices peer,
                                  Locale lcle)
使用指定语言环境创建一个实例。

参数：
peer - 将为其提供实现的同位体 BeanContext，如果该参数为 null，则此对象是它自己的同位体
lcle - 此 BeanContext 的当前 Locale。

BeanContextServicesSupport

public BeanContextServicesSupport(BeanContextServices peer)
创建一个具有同位体的实例

参数：
peer - 将为其提供实现的同位体 BeanContext，如果该参数为 null，则此对象是它自己的同位体。

BeanContextServicesSupport

public BeanContextServicesSupport()
创建不是另一个对象代理的实例。

方法详细信息

initialize

public void initialize()
由 BeanContextSupport 超类在构造和反序列化期间调用，以初始化子类的瞬态。 子类可以封装此方法，但不应该重写或直接调用它。

覆盖：
类 BeanContextSupport 中的 initialize

getBeanContextServicesPeer

public BeanContextServices getBeanContextServicesPeer()
获得与此 BeanContextServicesSupport 相关联的 BeanContextServices。

返回：
BeanContext 的实例，此对象将为其提供实现。

createBCSChild

protected BeanContextSupport.BCSChild createBCSChild(Object targetChild,
                                                     Object peer)

子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

覆盖：
类 BeanContextSupport 中的 createBCSChild
参数：
targetChild - 要创建自己的 Child 的子级
peer - 同位体，如果 targetChild 和同位体通过 BeanContextProxy 建立联系

createBCSSServiceProvider

protected BeanContextServicesSupport.BCSSServiceProvider createBCSSServiceProvider(Class sc,
                                                                                BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。

addBeanContextServicesListener

public void addBeanContextServicesListener(BeanContextServicesListener bcsl)
添加一个 BeanContextServicesListener。

指定者：
接口 BeanContextServices 中的 addBeanContextServicesListener
参数：
bcsl - 要添加的 BeanContextServicesListener

removeBeanContextServicesListener

public void removeBeanContextServicesListener(BeanContextServicesListener bcsl)
移除一个 BeanContextServicesListener。

指定者：
接口 BeanContextServices 中的 removeBeanContextServicesListener
参数：
bcsl - 要从此上下文移除的 BeanContextServicesListener

addService

public boolean addService(Class serviceClass,
                          BeanContextServiceProvider bcsp)
添加服务。

指定者：
接口 BeanContextServices 中的 addService
参数：
serviceClass - 要添加的服务
bcsp - 与该服务相关联的 BeanContextServiceProvider

addService

protected boolean addService(Class serviceClass,
                             BeanContextServiceProvider bcsp,
                             boolean fireEvent)
添加服务。

revokeService

public void revokeService(Class serviceClass,
                          BeanContextServiceProvider bcsp,
                          boolean revokeCurrentServicesNow)
移除服务。

指定者：
接口 BeanContextServices 中的 revokeService
参数：
serviceClass - 要从此 BeanContextServices 中取消的服务
bcsp - 与将取消的特定服务有关联的 BeanContextServiceProvider
revokeCurrentServicesNow - 值为 true 指示一个异常环境，在该环境中，BeanContextServiceProvider 或 BeanContextServices 希望立即终止为指定服务的所有当前突出引用提供服务。

hasService

public boolean hasService(Class serviceClass)
具有一个可被委托的服务。

指定者：
接口 BeanContextServices 中的 hasService
参数：
serviceClass - 相关服务
返回：
如果可得到服务，则返回 true

getService

public Object getService(BeanContextChild child,
                         Object requestor,
                         Class serviceClass,
                         Object serviceSelector,
                         BeanContextServiceRevokedListener bcsrl)
                  throws TooManyListenersException
获得一个可被委托的服务。

指定者：
接口 BeanContextServices 中的 getService
参数：
child - 与此请求相关联的 BeanContextChild
requestor - 请求服务的对象
serviceClass - 所请求服务的类
serviceSelector - 与服务有关的参数
bcsrl - 通知稍后是否应该取消服务的 BeanContextServiceRevokedListener
返回：
所请求的此上下文的指定 Service 的引用，或 null
抛出：
TooManyListenersException

releaseService

public void releaseService(BeanContextChild child,
                           Object requestor,
                           Object service)
释放服务。

指定者：
接口 BeanContextServices 中的 releaseService
参数：
child - BeanContextChild
requestor - 请求者
service - 服务

getCurrentServiceClasses

public Iterator getCurrentServiceClasses()
从接口 BeanContextServices 复制的描述
获得此上下文的当前可用服务。

指定者：
接口 BeanContextServices 中的 getCurrentServiceClasses
返回：
所有当前已注册服务类的迭代器。

getCurrentServiceSelectors

public Iterator getCurrentServiceSelectors(Class serviceClass)
从接口 BeanContextServices 复制的描述
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。

指定者：
接口 BeanContextServices 中的 getCurrentServiceSelectors
参数：
serviceClass - 指定服务
返回：
所有可用于指定服务的当前可用服务选择器（如果有）的迭代器。

serviceAvailable

public void serviceAvailable(BeanContextServiceAvailableEvent bcssae)
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。 子类可重写或封装此方法来实现自己的传播语义。

指定者：
接口 BeanContextServicesListener 中的 serviceAvailable
覆盖：
类 BeanContextChildSupport 中的 serviceAvailable
参数：
bcssae - 由于服务变得可用而触发的 BeanContextServiceAvailableEvent

serviceRevoked

public void serviceRevoked(BeanContextServiceRevokedEvent bcssre)
BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。 子类可重写或封装此方法来实现自己的传播语义。

指定者：
接口 BeanContextServiceRevokedListener 中的 serviceRevoked
覆盖：
类 BeanContextChildSupport 中的 serviceRevoked
参数：
bcssre - 由于取消服务而触发的 BeanContextServiceRevokedEvent

getChildBeanContextServicesListener

protected static final BeanContextServicesListener getChildBeanContextServicesListener(Object child)
获得指定子级的 BeanContextServicesListener（如果有）。

参数：
child - 指定子级
返回：
指定子级的 BeanContextServicesListener（如果有）

childJustRemovedHook

protected void childJustRemovedHook(Object child,
                                    BeanContextSupport.BCSChild bcsc)
在已成功移除子级之后，从超类的子级移除操作中调用。使用同步的子级调用。 如果此子级是一个 BeanContextChild，则该子类使用此钩子 (hook) 立即取消正由此子级使用的所有服务。 为了实现自己的子级移除副作用，子类可以封装此方法。

覆盖：
类 BeanContextSupport 中的 childJustRemovedHook

releaseBeanContextResources

protected void releaseBeanContextResources()
从 setBeanContext 中调用，以通知 BeanContextChild 释放从嵌套 BeanContext 中获得的资源。 此方法取消从其父级中获得的所有服务。 子类可以封装此方法来实现自己的语义。

覆盖：
类 BeanContextChildSupport 中的 releaseBeanContextResources

initializeBeanContextResources

protected void initializeBeanContextResources()
从 setBeanContext 中调用，以通知 BeanContextChild 分配从嵌套 BeanContext 中获得的资源。 子类可以封装此方法来实现自己的语义。

覆盖：
类 BeanContextChildSupport 中的 initializeBeanContextResources

fireServiceAdded

protected final void fireServiceAdded(Class serviceClass)
触发一个通知新服务的 BeanContextServiceEvent。

fireServiceAdded

protected final void fireServiceAdded(BeanContextServiceAvailableEvent bcssae)
触发一个指示新服务已变得可用的 BeanContextServiceAvailableEvent。

参数：
bcssae - BeanContextServiceAvailableEvent

fireServiceRevoked

protected final void fireServiceRevoked(BeanContextServiceRevokedEvent bcsre)
触发一个通知将被取消的服务的 BeanContextServiceEvent。

参数：
bcsre - BeanContextServiceRevokedEvent

fireServiceRevoked

protected final void fireServiceRevoked(Class serviceClass,
                                        boolean revokeNow)
触发一个指示某一特定服务不再可用的 BeanContextServiceRevokedEvent。

bcsPreSerializationHook

protected void bcsPreSerializationHook(ObjectOutputStream oos)
                                throws IOException
在序列化子级之前，从 BeanContextSupport writeObject 中调用。 此类将序列化这里的所有 Serializable BeanContextServiceProviders。 子类可以封装此方法来插入自己的序列化处理，该处理操作必须发生在序列化子级之前。

覆盖：
类 BeanContextSupport 中的 bcsPreSerializationHook
抛出：
IOException

bcsPreDeserializationHook

protected void bcsPreDeserializationHook(ObjectInputStream ois)
                                  throws IOException,
                                         ClassNotFoundException
在反序列化子级之前，从 BeanContextSupport readObject 中调用。 此类将反序列化以前已序列化的所有 Serializable BeanContextServiceProviders，这样可以使它们在反序列化时用于子级。 子类可以封装此方法来插入自己的序列化处理，该处理操作必须发生在序列化子级之前。

覆盖：
类 BeanContextSupport 中的 bcsPreDeserializationHook
抛出：
IOException
ClassNotFoundException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServicesSupport.BCSSChild (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextServicesSupport.BCSSChild

java.lang.Object
    继承者  java.beans.beancontext.BeanContextSupport.BCSChild
        继承者  java.beans.beancontext.BeanContextServicesSupport.BCSSChild
所有已实现的接口：
Serializable
正在封闭类：
BeanContextServicesSupport
protected class BeanContextServicesSupport.BCSSChild
extends BeanContextSupport.BCSChild

另请参见：
序列化表格

方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServicesSupport.BCSSProxyServiceProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextServicesSupport.BCSSProxyServiceProvider

java.lang.Object
    继承者  java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider
所有已实现的接口：
BeanContextServiceProvider, BeanContextServiceRevokedListener, EventListener
正在封闭类：
BeanContextServicesSupport
protected class BeanContextServicesSupport.BCSSProxyServiceProvider
extends Object
implements BeanContextServiceProvider, BeanContextServiceRevokedListener

方法摘要
Iterator | getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass) 由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
Object | getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector) 由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
void | releaseService(BeanContextServices bcs, Object requestor, Object service) 由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。
void | serviceRevoked(BeanContextServiceRevokedEvent bcsre) 指定服务已被取消。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getService

public Object getService(BeanContextServices bcs,
                         Object requestor,
                         Class serviceClass,
                         Object serviceSelector)
从接口 BeanContextServiceProvider 复制的描述
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。

指定者：
接口 BeanContextServiceProvider 中的 getService
参数：
bcs - 与此特定请求相关联的 BeanContextServices。此参数允许 BeanContextServiceProvider 区别来自多个源的服务请求。
requestor - 请求服务的对象
serviceClass - 请求的服务
serviceSelector - 用于特定服务的与服务有关的参数，如果不适用，则为 null。
返回：
所请求服务的一个引用

releaseService

public void releaseService(BeanContextServices bcs,
                           Object requestor,
                           Object service)
从接口 BeanContextServiceProvider 复制的描述
由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。

指定者：
接口 BeanContextServiceProvider 中的 releaseService
参数：
bcs - 与此特定释放请求相关联的 BeanContextServices
requestor - 请求释放服务的对象
service - 要释放的服务

getCurrentServiceSelectors

public Iterator getCurrentServiceSelectors(BeanContextServices bcs,
                                           Class serviceClass)
从接口 BeanContextServiceProvider 复制的描述
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。服务选择器是一种特定于服务的参数，它的典型示例可能包括：用于服务实现类的构造方法的参数、特定服务的属性值或已存在实现的映射中的键。

指定者：
接口 BeanContextServiceProvider 中的 getCurrentServiceSelectors
参数：
bcs - 此请求的 BeanContextServices
serviceClass - 指定的服务
返回：
指定 serviceClass 的当前服务选择器

serviceRevoked

public void serviceRevoked(BeanContextServiceRevokedEvent bcsre)
从接口 BeanContextServiceRevokedListener 复制的描述
指定服务已被取消。不再能满足此服务的 getService 请求。

指定者：
接口 BeanContextServiceRevokedListener 中的 serviceRevoked
参数：
bcsre - 由此侦听器接收的 BeanContextServiceRevokedEvent。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextServicesSupport.BCSSServiceProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextServicesSupport.BCSSServiceProvider

java.lang.Object
    继承者  java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider
所有已实现的接口：
Serializable
正在封闭类：
BeanContextServicesSupport
protected static class BeanContextServicesSupport.BCSSServiceProvider
extends Object
implements Serializable

子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。

另请参见：
序列化表格

字段摘要
protected  BeanContextServiceProvider serviceProvider
方法摘要
protected  BeanContextServiceProvider getServiceProvider()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

serviceProvider

protected BeanContextServiceProvider serviceProvider
方法详细信息

getServiceProvider

protected BeanContextServiceProvider getServiceProvider()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextSupport

java.lang.Object
    继承者  java.beans.beancontext.BeanContextChildSupport
        继承者  java.beans.beancontext.BeanContextSupport
所有已实现的接口：
BeanContext, BeanContextChild, BeanContextServiceRevokedListener, BeanContextServicesListener, DesignMode, PropertyChangeListener, VetoableChangeListener, Visibility, Serializable, Iterable, Collection, EventListener
直接已知子类：
BeanContextServicesSupport
public class BeanContextSupport
extends BeanContextChildSupport
implements BeanContext, Serializable, PropertyChangeListener, VetoableChangeListener

此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

因为此类直接实现 BeanContext 接口，所以可以通过创建此实现的子类来使用该类，或者由另一个实例对此类实例的特别委托来使用该类。

从以下版本开始：
1.2
另请参见：
序列化表格

嵌套类摘要
protected class | BeanContextSupport.BCSChild
protected static class | BeanContextSupport.BCSIterator 受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。
字段摘要
protected ArrayList | bcmListeners protected ArrayList bcmListeners 字段的所有访问在该对象上都将是同步的。
protected HashMap | children protected HashMap children 字段的所有访问在该对象上都将是同步的。
protected boolean | designTime 指示此对象目前是否处于设计时间模式下的 boolean 值。
protected Locale | locale 此 BeanContext 的当前语言环境。
protected boolean | okToUseGui 指示此实例现在能否呈现 GUI 的 boolean 值。
从类 java.beans.beancontext.BeanContextChildSupport 继承的字段
beanContext, beanContextChildPeer, pcSupport, rejectedSetBCOnce, vcSupport
从接口 java.beans.beancontext.BeanContext 继承的字段
globalHierarchyLock
从接口 java.beans.DesignMode 继承的字段
PROPERTYNAME
构造方法摘要
BeanContextSupport()
创建不是另一个对象代理的实例。
BeanContextSupport(BeanContext peer)
使用默认语言环境创建一个实例
BeanContextSupport(BeanContext peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextSupport 实例。
方法摘要
 boolean add(Object targetChild)
在此 BeanContext 中添加/嵌套一个子级。
 boolean addAll(Collection c)
将 Collection 添加到 Children（不受支持的）实现的集合，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
 void addBeanContextMembershipListener(BeanContextMembershipListener bcml)
添加一个 BeanContextMembershipListener。
 boolean avoidingGui()
用于确定 BeanContext 子级是否避免使用其 GUI。
protected  Iterator bcsChildren()
返回此 BeanContext 所有子级的迭代器。
protected  void bcsPreDeserializationHook(ObjectInputStream ois)
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
protected  void bcsPreSerializationHook(ObjectOutputStream oos)
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。
protected  void childDeserializedHook(Object child, BeanContextSupport.BCSChild bcsc)
由 readObject 利用新近反序列化的子级和 BCSChild 调用。
protected  void childJustAddedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。
protected  void childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。
protected static boolean classEquals(Class first, Class second)
测试以查看两个类对象或其名称是否相等。
 void clear()
清除子对象（不受支持的）实现，这些实现在分层结构锁定和 "children" 受保护字段上必须是同步的
 boolean contains(Object o)
确定指定对象当前是否是此 BeanContext 的子级。
 boolean containsAll(Collection c)
测试以查看指定 Collection 中的所有对象是否是此 BeanContext 的子对象。
 boolean containsKey(Object o)
确定指定对象当前是否是此 BeanContext 的子级。
protected  Object[] copyChildren()
获得此 BeanContext 子级的副本。
protected  BeanContextSupport.BCSChild createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
protected  void deserialize(ObjectInputStream ois, Collection coll)
readObject 使用此方法来反序列化一个 collection。
 void dontUseGui()
通知此实例它可以不再呈现一个 GUI。
protected  void fireChildrenAdded(BeanContextMembershipEvent bcme)
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
protected  void fireChildrenRemoved(BeanContextMembershipEvent bcme)
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
 BeanContext getBeanContextPeer()
获得 BeanContext 的实例，此对象将为其提供实现。
protected static BeanContextChild getChildBeanContextChild(Object child)
与指定 Child 相关联的 BeanContextChild（如果有）。
protected static BeanContextMembershipListener getChildBeanContextMembershipListener(Object child)
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。
protected static PropertyChangeListener getChildPropertyChangeListener(Object child)
与指定 Child 相关联的 PropertyChangeListener（如果有）
protected static Serializable getChildSerializable(Object child)
获得与指定 Child 相关联的 Serializable（如果有）
protected static VetoableChangeListener getChildVetoableChangeListener(Object child)
与指定 Child 相关联的 VetoableChangeListener（如果有）。
protected static Visibility getChildVisibility(Object child)
获得与指定子级相关联的 Component（如果有）。
 Locale getLocale()
获得此 BeanContext 的语言环境。
 URL getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
protected  void initialize()
从构造方法和 readObject 调用的受保护方法，以初始化 BeanContextSupport 实例的瞬态。
 Object instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。
 boolean isDesignTime()
报告此对象当前是否处于设计时间模式下。
 boolean isEmpty()
报告此 BeanContext 是否为空。
 boolean isSerializing()
此 BeanContext 正处于序列化过程中吗？
 Iterator iterator()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。
 boolean needsGui()
此方法通常从环境中调用，以便确定实现者是否“需要” GUI。
 void okToUseGui()
通知此实例它现在可以呈现一个 GUI。
 void propertyChange(PropertyChangeEvent pce)
子类可以封装此方法来监视子类属性的更改。
 void readChildren(ObjectInputStream ois)
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。
 boolean remove(Object targetChild)
从此 BeanContext 中移除一个子对象。
protected  boolean remove(Object targetChild, boolean callChildSetBC)
当由意外的 setBeanContext 或 remove() 调用导致移除时使用的内部移除方法。
 boolean removeAll(Collection c)
移除所有指定 Children（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
 void removeBeanContextMembershipListener(BeanContextMembershipListener bcml)
移除一个 BeanContextMembershipListener。
 boolean retainAll(Collection c)
仅保留指定子对象（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
protected  void serialize(ObjectOutputStream oos, Collection coll)
writeObject 使用此方法来序列化一个 Collection。
 void setDesignTime(boolean dTime)
为此 BeanContext 设置新的设计时间值。
 void setLocale(Locale newLocale)
设置此 BeanContext 的语言环境。
 int size()
获得当前嵌套在此 BeanContext 中的子级数。
 Object[] toArray()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。
 Object[] toArray(Object[] arry)
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。
protected  boolean validatePendingAdd(Object targetChild)
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象添加到 BeanContext 之前立即检查它们。
protected  boolean validatePendingRemove(Object targetChild)
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象从 BeanContext 中移除之前立即检查它们。
 void vetoableChange(PropertyChangeEvent pce)
子类可以封装此方法来监视子类属性的更改。
 void writeChildren(ObjectOutputStream oos)
用于序列化此 BeanContext 的所有子级。
从类 java.beans.beancontext.BeanContextChildSupport 继承的方法
addPropertyChangeListener, addVetoableChangeListener, firePropertyChange, fireVetoableChange, getBeanContext, getBeanContextChildPeer, initializeBeanContextResources, isDelegated, releaseBeanContextResources, removePropertyChangeListener, removeVetoableChangeListener, serviceAvailable, serviceRevoked, setBeanContext, validatePendingSetBeanContext
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.beans.beancontext.BeanContextChild 继承的方法
addPropertyChangeListener, addVetoableChangeListener, getBeanContext, removePropertyChangeListener, removeVetoableChangeListener, setBeanContext
从接口 java.util.Collection 继承的方法
equals, hashCode

字段详细信息

children

protected transient HashMap children
protected HashMap children 字段的所有访问在该对象上都将是同步的。

bcmListeners

protected transient ArrayList bcmListeners
protected ArrayList bcmListeners 字段的所有访问在该对象上都将是同步的。

locale

protected Locale locale
此 BeanContext 的当前语言环境。

okToUseGui

protected boolean okToUseGui
指示此实例现在能否呈现 GUI 的 boolean 值。

designTime

protected boolean designTime
指示此对象目前是否处于设计时间模式下的 boolean 值。

构造方法详细信息

BeanContextSupport

public BeanContextSupport(BeanContext peer,
                          Locale lcle,
                          boolean dTime,
                          boolean visible)
构造一个 BeanContextSupport 实例。

参数：
peer - 将为其提供实现的同位体 BeanContext，如果此对象是它自己的同位体，则该参数为 null
lcle - 此 BeanContext 的当前 Locale。如果 lcle 为 null，则默认语言环境被分配给 BeanContext 实例。
dTime - 初始状态，如果在设计模式下，则该参数为 true，如果在运行状态下，则该参数为 false。
visible - 初始可见性。
另请参见：
Locale.getDefault(), Locale.setDefault(java.util.Locale)

BeanContextSupport

public BeanContextSupport(BeanContext peer,
                          Locale lcle,
                          boolean dtime)
使用指定 Locale 和设计模式创建一个实例。

参数：
peer - 将为其提供实现的同位体 BeanContext，如果此对象是它自己的同位体，则该参数为 null
lcle - 此 BeanContext 的当前 Locale。如果 lcle 为 null，则默认语言环境被分配给 BeanContext 实例。
dtime - 初始状态，如果在设计模式下，则该参数为 true，如果在运行状态下，则该参数为 false。
另请参见：
Locale.getDefault(), Locale.setDefault(java.util.Locale)

BeanContextSupport

public BeanContextSupport(BeanContext peer,
                          Locale lcle)
使用指定语言环境创建一个实例。

参数：
peer - 将为其提供实现的同位体 BeanContext，如果此对象是它自己的同位体，则该参数为 null
lcle - 此 BeanContext 的当前 Locale。如果 lcle 为 null，则默认语言环境被分配给 BeanContext 实例。
另请参见：
Locale.getDefault(), Locale.setDefault(java.util.Locale)

BeanContextSupport

public BeanContextSupport(BeanContext peer)
使用默认语言环境创建一个实例

参数：
peer - 将为其提供实现的同位体 BeanContext，如果此对象是它自己的同位体，则该参数为 null

BeanContextSupport

public BeanContextSupport()
创建不是另一个对象代理的实例。

方法详细信息

getBeanContextPeer

public BeanContext getBeanContextPeer()
获得 BeanContext 的实例，此对象将为其提供实现。

返回：
BeanContext 实例

instantiateChild

public Object instantiateChild(String beanName)
                        throws IOException,
                               ClassNotFoundException

instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。

beanName 参数的语义由 java.beans.Beans.instantate 定义。

指定者：
接口 BeanContext 中的 instantiateChild
参数：
beanName - 要在此 BeanContext 中实例化的 Bean 的名称
返回：
新对象
抛出：
IOException - 如果在该 bean 正被反序列化时发生 I/O 错误
ClassNotFoundException - 如果没有找到由 beanName 参数标识的类

size

public int size()
获得当前嵌套在此 BeanContext 中的子级数。

指定者：
接口 Collection 中的 size
返回：
子级数

isEmpty

public boolean isEmpty()
报告此 BeanContext 是否为空。当 BeanContext 不包含任何嵌套子级时，可认为它为空。

指定者：
接口 Collection 中的 isEmpty
返回：
如果没有子级

contains

public boolean contains(Object o)
确定指定对象当前是否是此 BeanContext 的子级。

指定者：
接口 Collection 中的 contains
参数：
o - 相关 Object
返回：
如果此对象是一个子对象

containsKey

public boolean containsKey(Object o)
确定指定对象当前是否是此 BeanContext 的子级。

参数：
o - 相关 Object
返回：
如果此对象是一个子对象

iterator

public Iterator iterator()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。

指定者：
接口 Iterable 中的 iterator
指定者：
接口 Collection 中的 iterator
返回：
嵌套子级的 Iterator

toArray

public Object[] toArray()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。

指定者：
接口 Collection 中的 toArray
返回：
包含此 collection 中所有元素的数组

toArray

public Object[] toArray(Object[] arry)
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。

指定者：
接口 Collection 中的 toArray
参数：
arry - 感兴趣的对象类型数组。
返回：
子级的数组

createBCSChild

protected BeanContextSupport.BCSChild createBCSChild(Object targetChild,
                                                     Object peer)

子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

参数：
targetChild - 要创建自己的 Child 的子级
peer - 同位体，如果 tragetChild 和同位体通过实现 BeanContextProxy 建立联系

add

public boolean add(Object targetChild)
在此 BeanContext 中添加/嵌套一个子级。

作为 java.beans.Beans.instantiate() 的副作用调用。如果子对象对于添加无效，则此方法抛出 IllegalStateException。

指定者：
接口 Collection 中的 add
参数：
targetChild - 嵌套在此 BeanContext 中的子对象
返回：
如果成功添加了子对象，则返回 true。
另请参见：
validatePendingAdd(java.lang.Object)

remove

public boolean remove(Object targetChild)
从此 BeanContext 中移除一个子对象。如果子对象不适用于添加，则此方法抛出 IllegalStateException。

指定者：
接口 Collection 中的 remove
参数：
targetChild - 要移除的子对象
返回：
如果此调用将移除一个元素，则返回 true
另请参见：
validatePendingRemove(java.lang.Object)

remove

protected boolean remove(Object targetChild,
                         boolean callChildSetBC)
当由意外的 setBeanContext 或 remove() 调用导致移除时使用的内部移除方法。

参数：
targetChild - 要移除的 JavaBean、BeanContext 或 Object
callChildSetBC - 用于指示应该通知子对象它不再嵌套在此 BeanContext 中。

containsAll

public boolean containsAll(Collection c)
测试以查看指定 Collection 中的所有对象是否是此 BeanContext 的子对象。

指定者：
接口 Collection 中的 containsAll
参数：
c - 指定的 Collection
返回：
如果 collection 中的所有对象都是此 BeanContext 的子对象，则返回 true，否则返回 false。
另请参见：
Collection.contains(Object)

addAll

public boolean addAll(Collection c)
将 Collection 添加到 Children（不受支持的）实现的集合，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的

指定者：
接口 Collection 中的 addAll
参数：
c - 包含要添加到此 collection 的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException
另请参见：
Collection.add(Object)

removeAll

public boolean removeAll(Collection c)
移除所有指定 Children（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的

指定者：
接口 Collection 中的 removeAll
参数：
c - 办好要从此 collection 移除的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException
另请参见：
Collection.remove(Object), Collection.contains(Object)

retainAll

public boolean retainAll(Collection c)
仅保留指定子对象（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的

指定者：
接口 Collection 中的 retainAll
参数：
c - 包含保留在此 collection 中的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException
另请参见：
Collection.remove(Object), Collection.contains(Object)

clear

public void clear()
清除子对象（不受支持的）实现，这些实现在分层结构锁定和 "children" 受保护字段上必须是同步的

指定者：
接口 Collection 中的 clear
抛出：
UnsupportedOperationException

addBeanContextMembershipListener

public void addBeanContextMembershipListener(BeanContextMembershipListener bcml)
添加一个 BeanContextMembershipListener。

指定者：
接口 BeanContext 中的 addBeanContextMembershipListener
参数：
bcml - 要添加的 BeanContextMembershipListener
抛出：
NullPointerException

removeBeanContextMembershipListener

public void removeBeanContextMembershipListener(BeanContextMembershipListener bcml)
移除一个 BeanContextMembershipListener。

指定者：
接口 BeanContext 中的 removeBeanContextMembershipListener
参数：
bcml - 要移除的 BeanContextMembershipListener
抛出：
NullPointerException

getResourceAsStream

public InputStream getResourceAsStream(String name,
                                       BeanContextChild bcc)
从接口 BeanContext 复制的描述
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

指定者：
接口 BeanContext 中的 getResourceAsStream
参数：
name - 所需资源的名称。
bcc - 做出请求的子对象。
返回：
以 InputStream 形式返回所需的资源
抛出：
NullPointerException

getResource

public URL getResource(String name,
                       BeanContextChild bcc)
从接口 BeanContext 复制的描述
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

指定者：
接口 BeanContext 中的 getResource
参数：
name - 所需资源的名称。
bcc - 做出请求的子对象。
返回：
以 InputStream 形式返回所需的资源

setDesignTime

public void setDesignTime(boolean dTime)
为此 BeanContext 设置新的设计时间值。

指定者：
接口 DesignMode 中的 setDesignTime
参数：
新的 - designTime 值
另请参见：
BeanContext, BeanContextMembershipListener, PropertyChangeEvent

isDesignTime

public boolean isDesignTime()
报告此对象当前是否处于设计时间模式下。

指定者：
接口 DesignMode 中的 isDesignTime
返回：
如果处于设计时间模式下，则返回 true，否则返回 false

setLocale

public void setLocale(Locale newLocale)
               throws PropertyVetoException
设置此 BeanContext 的语言环境。

参数：
newLocale - 新的语言环境。如果 newLocale 为 null，则此方法调用将无效。
抛出：
PropertyVetoException - 如果拒绝新值。

getLocale

public Locale getLocale()
获得此 BeanContext 的语言环境。

返回：
BeanContext 的当前 Locale

needsGui

public boolean needsGui()

此方法通常从环境中调用，以便确定实现者是否“需要” GUI。

这里使用的算法测试 BeanContextPeer 及其当前子级，以确定它们是 Container 还是 Component，或者确定它们是否实现 Visibility 并返回 needsGui() == true。

指定者：
接口 Visibility 中的 needsGui
返回：
如果实现者需要一个 GUI，则返回 true

dontUseGui

public void dontUseGui()
通知此实例它可以不再呈现一个 GUI。

指定者：
接口 Visibility 中的 dontUseGui

okToUseGui

public void okToUseGui()
通知此实例它现在可以呈现一个 GUI。

指定者：
接口 Visibility 中的 okToUseGui

avoidingGui

public boolean avoidingGui()
用于确定 BeanContext 子级是否避免使用其 GUI。

指定者：
接口 Visibility 中的 avoidingGui
返回：
此实例避免使用其 GUI 吗？
另请参见：
Visibility

isSerializing

public boolean isSerializing()
此 BeanContext 正处于序列化过程中吗？

返回：
此 BeanContext 当前是否正被序列化

bcsChildren

protected Iterator bcsChildren()
返回此 BeanContext 所有子级的迭代器。

返回：
用于所有当前 BCSChild 值的迭代器

bcsPreSerializationHook

protected void bcsPreSerializationHook(ObjectOutputStream oos)
                                throws IOException
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。 子类可重写此方法，以在此超类序列化子级之前对其状态执行自定义序列化。 不过，此方法不应由子类用于替换它们自己的 writeObject() 实现（如果有）。

抛出：
IOException

bcsPreDeserializationHook

protected void bcsPreDeserializationHook(ObjectInputStream ois)
                                  throws IOException,
                                         ClassNotFoundException
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。 子类可重写此方法，以在此超类反序列化子级之前对其状态执行自定义反序列化。 不过，此方法不应由子类用于替换它们自己的 readObject() 实现（如果有）。

抛出：
IOException
ClassNotFoundException

childDeserializedHook

protected void childDeserializedHook(Object child,
                                     BeanContextSupport.BCSChild bcsc)
由 readObject 利用新近反序列化的子级和 BCSChild 调用。

参数：
child - 新近反序列化的子级
bcsc - 新近反序列化的 BCSChild

serialize

protected final void serialize(ObjectOutputStream oos,
                               Collection coll)
                        throws IOException
writeObject 使用此方法来序列化一个 Collection。

参数：
oos - 序列化期间将使用的 ObjectOutputStream
coll - 要序列化的 Collection
抛出：
IOException - 如果序列化失败

deserialize

protected final void deserialize(ObjectInputStream ois,
                                 Collection coll)
                          throws IOException,
                                 ClassNotFoundException
readObject 使用此方法来反序列化一个 collection。

参数：
ois - 要使用的 ObjectInputStream
coll - Collection
抛出：
IOException
ClassNotFoundException

writeChildren

public final void writeChildren(ObjectOutputStream oos)
                         throws IOException
用于序列化此 BeanContext 的所有子级。

参数：
oos - 序列化期间将使用的 ObjectOutputStream
抛出：
IOException - 如果序列化失败

readChildren

public final void readChildren(ObjectInputStream ois)
                        throws IOException,
                               ClassNotFoundException
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。

抛出：
IOException
ClassNotFoundException

vetoableChange

public void vetoableChange(PropertyChangeEvent pce)
                    throws PropertyVetoException
子类可以封装此方法来监视子类属性的更改。

指定者：
接口 VetoableChangeListener 中的 vetoableChange
参数：
pce - 描述事件源和已更改属性的 PropertyChangeEvent 对象。
抛出：
PropertyVetoException - 如果接收方希望回滚属性更改。

propertyChange

public void propertyChange(PropertyChangeEvent pce)
子类可以封装此方法来监视子类属性的更改。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
pce - 描述事件源和已更改属性的 PropertyChangeEvent 对象。

validatePendingAdd

protected boolean validatePendingAdd(Object targetChild)

此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象添加到 BeanContext 之前立即检查它们。

返回：
如果可以将子对象添加到此 BeanContext 中，则返回 true，否则返回 false。

validatePendingRemove

protected boolean validatePendingRemove(Object targetChild)

此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象从 BeanContext 中移除之前立即检查它们。

返回：
如果可以从此 BeanContext 中移除子对象，则返回 true，否则返回 false。

childJustAddedHook

protected void childJustAddedHook(Object child,
                                  BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。该方法使用同步的子对象调用。

childJustRemovedHook

protected void childJustRemovedHook(Object child,
                                    BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。该方法使用同步的子对象调用。

getChildVisibility

protected static final Visibility getChildVisibility(Object child)
获得与指定子级相关联的 Component（如果有）。

参数：
child - 指定子级
返回：
与指定子级相关联的 Component（如果有）。

getChildSerializable

protected static final Serializable getChildSerializable(Object child)
获得与指定 Child 相关联的 Serializable（如果有）

参数：
child - 指定子级
返回：
与指定 Child 相关联的 Serializable（如果有）

getChildPropertyChangeListener

protected static final PropertyChangeListener getChildPropertyChangeListener(Object child)
与指定 Child 相关联的 PropertyChangeListener（如果有）

参数：
child - 指定子级
返回：
与指定子级相关联的 PropertyChangeListener（如果有）

getChildVetoableChangeListener

protected static final VetoableChangeListener getChildVetoableChangeListener(Object child)
与指定 Child 相关联的 VetoableChangeListener（如果有）。

参数：
child - 指定子级
返回：
与指定子级相关联的 VetoableChangeListener（如果有）

getChildBeanContextMembershipListener

protected static final BeanContextMembershipListener getChildBeanContextMembershipListener(Object child)
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。

参数：
child - 指定子级
返回：
与指定子级相关联的 BeanContextMembershipListener（如果有）

getChildBeanContextChild

protected static final BeanContextChild getChildBeanContextChild(Object child)
与指定 Child 相关联的 BeanContextChild（如果有）。

参数：
child - 指定子级
返回：
与指定子级相关联的 BeanContextChild（如果有）
抛出：
IllegalArgumentException - 如果子级既实现 BeanContextChild 又实现 BeanContextProxy

fireChildrenAdded

protected final void fireChildrenAdded(BeanContextMembershipEvent bcme)
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。

fireChildrenRemoved

protected final void fireChildrenRemoved(BeanContextMembershipEvent bcme)
在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。

initialize

protected void initialize()
从构造方法和 readObject 调用的受保护方法，以初始化 BeanContextSupport 实例的瞬态。 该类使用此方法来实例化用于监视子级上的 PropertyChange 和 VetoableChange 事件的内部类侦听器。 子类可以封装此方法来添加自己的初始化行为。

copyChildren

protected final Object[] copyChildren()
获得此 BeanContext 子级的副本。

返回：
当前嵌套子级的副本

classEquals

protected static final boolean classEquals(Class first,
                                           Class second)
测试以查看两个类对象或其名称是否相等。

参数：
first - 第一个对象
second - 第二个对象
返回：
如果两个对象相等，则返回 true，否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextSupport.BCSChild (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextSupport.BCSChild

java.lang.Object
    继承者  java.beans.beancontext.BeanContextSupport.BCSChild
所有已实现的接口：
Serializable
直接已知子类：
BeanContextServicesSupport.BCSSChild
正在封闭类：
BeanContextSupport
protected class BeanContextSupport.BCSChild
extends Object
implements Serializable

另请参见：
序列化表格

方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BeanContextSupport.BCSIterator (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.beans.beancontext
类 BeanContextSupport.BCSIterator

java.lang.Object
    继承者  java.beans.beancontext.BeanContextSupport.BCSIterator
所有已实现的接口：
Iterator
正在封闭类：
BeanContextSupport
protected static final class BeanContextSupport.BCSIterator
extends Object
implements Iterator

受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。

方法摘要
boolean | hasNext() 如果仍有元素可以迭代，则返回 true。
Object | next() 返回迭代的下一个元素。
void | remove() 从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

hasNext

public boolean hasNext()
从接口 Iterator 复制的描述
如果仍有元素可以迭代，则返回 true。（换句话说，如果 next 返回了元素而不是抛出异常，则返回 true）。

指定者：
接口 Iterator 中的 hasNext
返回：
如果迭代器具有多个元素，则返回 true。

next

public Object next()
从接口 Iterator 复制的描述
返回迭代的下一个元素。

指定者：
接口 Iterator 中的 next
返回：
迭代的下一个元素。

remove

public void remove()
从接口 Iterator 复制的描述
从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。每次调用 next 只能调用一次此方法。如果进行迭代时用调用此方法之外的其他方式修改了该迭代器所指向的 collection，则迭代器的行为是不确定的。

指定者：
接口 Iterator 中的 remove
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.beans.beancontext (Java 2 Platform SE 6)

 java.beans.beancontext
接口
BeanContext
BeanContextChild
BeanContextChildComponentProxy
BeanContextContainerProxy
BeanContextMembershipListener
BeanContextProxy
BeanContextServiceProvider
BeanContextServiceProviderBeanInfo
BeanContextServiceRevokedListener
BeanContextServices
BeanContextServicesListener
类
BeanContextChildSupport
BeanContextEvent
BeanContextMembershipEvent
BeanContextServiceAvailableEvent
BeanContextServiceRevokedEvent
BeanContextServicesSupport
BeanContextServicesSupport.BCSSServiceProvider
BeanContextSupport
BeanContextSupport.BCSIterator


java.beans.beancontext (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.beans.beancontext

提供与 bean 上下文有关的类和接口。

请参见：
描述

接口摘要
BeanContext | BeanContext 是 JavaBean 的逻辑层次容器。
BeanContextChild | 正如 BeanContext 子接口所定义的，希望在其中进行嵌套并获得对其执行环境（或文本）的引用的 JavaBeans 应该实现此接口。
BeanContextChildComponentProxy | 此接口由具有与之相关的 AWT Component 的 BeanContextChildren 实现。
BeanContextContainerProxy | 此接口由具有与之关联的 AWT Container 的 BeanContext 实现。
BeanContextMembershipListener | 当 BeanContext 的成员关系状态发生更改时，兼容的 BeanContext 在此接口上触发事件。
BeanContextProxy | 此接口由并不直接拥有（通过实现该接口或一个子接口拥有）与之关联的 BeanContext(Child)，但是拥有它代理的一个公共 BeanContext(Child) 的 JavaBean 实现。
BeanContextServiceProvider | BeanContext 的主要功能之一是充当 JavaBeans 与 BeanContextServiceProviders 之间的集合点。
BeanContextServiceProviderBeanInfo | 希望提供关于其 bean 可能提供服务的显式消息的 BeanContextServiceProvider 实现者应实现某个 BeanInfo 类，该类实现此 BeanInfo 的子接口并提供有关其服务的方法、属性、事件等显式信息。
BeanContextServiceRevokedListener | 用于接收 BeanContextServiceRevokedEvent 对象的侦听器接口。
BeanContextServices | BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
BeanContextServicesListener | 用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。

类摘要
BeanContextChildSupport | 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
BeanContextEvent | BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
BeanContextMembershipEvent | BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
BeanContextServiceAvailableEvent | BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
BeanContextServiceRevokedEvent | BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。
BeanContextServicesSupport | 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
BeanContextServicesSupport.BCSSServiceProvider | 子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。
BeanContextSupport | 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。
BeanContextSupport.BCSIterator | 受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。

软件包 java.beans.beancontext 的描述

提供与 bean 上下文有关的类和接口。bean 上下文是一个 bean 的容器，它定义所包含 bean 的执行环境。但单个 bean 上下文中可能有几个 bean，一个 bean 上下文可以嵌套在另一个 bean 上下文中。此包还包含将在某个 bean 上下文中添加和移除的 bean 的事件及侦听器接口。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.beans.beancontext 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.beans.beancontext 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.beans.beancontext.BeanContextChildSupport (implements java.beans.beancontext.BeanContextChild, java.beans.beancontext.BeanContextServicesListener, java.io.Serializable)
      • java.beans.beancontext.BeanContextSupport (implements java.beans.beancontext.BeanContext, java.beans.PropertyChangeListener, java.io.Serializable, java.beans.VetoableChangeListener)
        • java.beans.beancontext.BeanContextServicesSupport (implements java.beans.beancontext.BeanContextServices)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider (implements java.beans.beancontext.BeanContextServiceProvider, java.beans.beancontext.BeanContextServiceRevokedListener)
    • java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider (implements java.io.Serializable)
    • java.beans.beancontext.BeanContextSupport.BCSChild (implements java.io.Serializable)
      • java.beans.beancontext.BeanContextServicesSupport.BCSSChild
    • java.beans.beancontext.BeanContextSupport.BCSIterator (implements java.util.Iterator<E>)
    • java.util.EventObject (implements java.io.Serializable)
      • java.beans.beancontext.BeanContextEvent
        • java.beans.beancontext.BeanContextMembershipEvent
        • java.beans.beancontext.BeanContextServiceAvailableEvent
        • java.beans.beancontext.BeanContextServiceRevokedEvent

接口分层结构

  • java.beans.beancontext.BeanContextChild
    • java.beans.beancontext.BeanContext (并 extends java.util.Collection<E>, java.beans.DesignMode, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
  • java.beans.beancontext.BeanContextChildComponentProxy
  • java.beans.beancontext.BeanContextContainerProxy
  • java.beans.beancontext.BeanContextProxy
  • java.beans.beancontext.BeanContextServiceProvider
  • java.beans.BeanInfo
    • java.beans.beancontext.BeanContextServiceProviderBeanInfo
  • java.beans.DesignMode
    • java.beans.beancontext.BeanContext (并 extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.Visibility)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
  • java.util.EventListener
    • java.beans.beancontext.BeanContextMembershipListener
    • java.beans.beancontext.BeanContextServiceRevokedListener
      • java.beans.beancontext.BeanContextServicesListener
        • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContext)
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.beans.beancontext.BeanContext (并 extends java.beans.beancontext.BeanContextChild, java.beans.DesignMode, java.beans.Visibility)
        • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
  • java.beans.Visibility
    • java.beans.beancontext.BeanContext (并 extends java.beans.beancontext.BeanContextChild, java.util.Collection<E>, java.beans.DesignMode)
      • java.beans.beancontext.BeanContextServices (并 extends java.beans.beancontext.BeanContextServicesListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.beans.beancontext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.beans.beancontext
的使用

使用 java.beans.beancontext 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。

java.beans 使用的 java.beans.beancontext 中的类
BeanContext
BeanContext 是 JavaBean 的逻辑层次容器。

java.beans.beancontext 使用的 java.beans.beancontext 中的类
BeanContext
BeanContext 是 JavaBean 的逻辑层次容器。
BeanContextChild
正如 BeanContext 子接口所定义的，希望在其中进行嵌套并获得对其执行环境（或文本）的引用的 JavaBeans 应该实现此接口。
BeanContextChildSupport
这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
BeanContextEvent
BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
BeanContextMembershipEvent
BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
BeanContextMembershipListener
当 BeanContext 的成员关系状态发生更改时，兼容的 BeanContext 在此接口上触发事件。
BeanContextServiceAvailableEvent
BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
BeanContextServiceProvider
BeanContext 的主要功能之一是充当 JavaBeans 与 BeanContextServiceProviders 之间的集合点。
BeanContextServiceRevokedEvent
BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。
BeanContextServiceRevokedListener
用于接收 BeanContextServiceRevokedEvent 对象的侦听器接口。
BeanContextServices
BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
BeanContextServicesListener
用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。
BeanContextServicesSupport.BCSSProxyServiceProvider
BeanContextServicesSupport.BCSSServiceProvider
子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。
BeanContextSupport
此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。
BeanContextSupport.BCSChild

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContext
的使用

使用 BeanContext 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。

java.beans 中 BeanContext 的使用

参数类型为 BeanContext 的 java.beans 中的方法
void | AppletInitializer.initialize(Applet newAppletBean, BeanContext bCtxt) 如果传递给 java.beans.Beans.instantiate 的适当变体，将调用此方法来将新近实例化的 Applet (JavaBean) 与其 AppletContext、AppletStub 和 Container 相关联。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

java.beans.beancontext 中 BeanContext 的使用

java.beans.beancontext 中 BeanContext 的子接口
 interface BeanContextServices
BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 BeanContext 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

声明为 BeanContext 的 java.beans.beancontext 中的字段
protected BeanContext | BeanContextChildSupport.beanContext
protected BeanContext | BeanContextEvent.propagatedFrom 作为此事件传播源的 BeanContext

返回 BeanContext 的 java.beans.beancontext 中的方法
BeanContext | BeanContextChild.getBeanContext() 获得与此 BeanContextChild 相关联的 BeanContext。
BeanContext | BeanContextChildSupport.getBeanContext() 获得此 BeanContextChildSupport 的嵌套 BeanContext。
BeanContext | BeanContextEvent.getBeanContext() 获得与此事件相关联的 BeanContext。
BeanContext | BeanContextSupport.getBeanContextPeer() 获得 BeanContext 的实例，此对象将为其提供实现。
BeanContext | BeanContextEvent.getPropagatedFrom() 获得作为此事件传播源的 BeanContext。

参数类型为 BeanContext 的 java.beans.beancontext 中的方法
void | BeanContextChild.setBeanContext(BeanContext bc) 实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。
void | BeanContextChildSupport.setBeanContext(BeanContext bc) 设置此 BeanContextChildSupport 的 BeanContext。
void | BeanContextEvent.setPropagatedFrom(BeanContext bc) 设置作为此事件传播源的 BeanContext。
boolean | BeanContextChildSupport.validatePendingSetBeanContext(BeanContext newValue) 从 setBeanContext 调用，以验证（或相反）嵌套 BeanContext 属性值中的挂起更改。

参数类型为 BeanContext 的 java.beans.beancontext 中的构造方法
BeanContextEvent(BeanContext bc)
构造一个 BeanContextEvent
BeanContextMembershipEvent(BeanContext bc, Collection changes)
构造一个 BeanContextMembershipEvent
BeanContextMembershipEvent(BeanContext bc, Object[] changes)
构造一个 BeanContextMembershipEvent
BeanContextSupport(BeanContext peer)
使用默认语言环境创建一个实例
BeanContextSupport(BeanContext peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextSupport 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextChild
的使用

使用 BeanContextChild 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextChild 的使用

java.beans.beancontext 中 BeanContextChild 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 BeanContextChild 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

声明为 BeanContextChild 的 java.beans.beancontext 中的字段
 BeanContextChild BeanContextChildSupport.beanContextChildPeer
在其中嵌套此 BeanContextChild 的 BeanContext。

返回 BeanContextChild 的 java.beans.beancontext 中的方法
BeanContextChild | BeanContextChildSupport.getBeanContextChildPeer() 获得与此 BeanContextChildSupport 相关联的 BeanContextChild。
BeanContextChild | BeanContextProxy.getBeanContextProxy() 获得与此对象相关联的 BeanContextChild（或子接口）。
protected static BeanContextChild | BeanContextSupport.getChildBeanContextChild(Object child) 与指定 Child 相关联的 BeanContextChild（如果有）。

参数类型为 BeanContextChild 的 java.beans.beancontext 中的方法
 URL BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 URL BeanContextSupport.getResource(String name, BeanContextChild bcc)
 InputStream BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream BeanContextSupport.getResourceAsStream(String name, BeanContextChild bcc)
 Object BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
 Object BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。
 void BeanContextServices.releaseService(BeanContextChild child, Object requestor, Object service)
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。
 void BeanContextServicesSupport.releaseService(BeanContextChild child, Object requestor, Object service)
释放服务。

参数类型为 BeanContextChild 的 java.beans.beancontext 中的构造方法
BeanContextChildSupport(BeanContextChild bcc)
构造一个 BeanContextChildSupport，其中 JavaBean 组件自身实现 BeanContextChild 并封装它，并将该接口委托给此实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextChildComponentProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextChildComponentProxy
的使用

没有 java.beans.beancontext.BeanContextChildComponentProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextChildSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextChildSupport
的使用

使用 BeanContextChildSupport 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextChildSupport 的使用

java.beans.beancontext 中 BeanContextChildSupport 的子类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextContainerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextContainerProxy
的使用

没有 java.beans.beancontext.BeanContextContainerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextEvent
的使用

使用 BeanContextEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextEvent 的使用

java.beans.beancontext 中 BeanContextEvent 的子类
class | BeanContextMembershipEvent BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
class | BeanContextServiceAvailableEvent BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
class | BeanContextServiceRevokedEvent BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextMembershipEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextMembershipEvent
的使用

使用 BeanContextMembershipEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextMembershipEvent 的使用

参数类型为 BeanContextMembershipEvent 的 java.beans.beancontext 中的方法
void | BeanContextMembershipListener.childrenAdded(BeanContextMembershipEvent bcme) 在将一个子级或子级列表添加到此侦听器在其中注册的 BeanContext 中时调用。
void | BeanContextMembershipListener.childrenRemoved(BeanContextMembershipEvent bcme) 在将一个子级或子级列表从此侦听器在其中注册的 BeanContext 中移除时调用。
protected void | BeanContextSupport.fireChildrenAdded(BeanContextMembershipEvent bcme) 在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。
protected void | BeanContextSupport.fireChildrenRemoved(BeanContextMembershipEvent bcme) 在 BeanContextMembershipListener 接口上触发一个 BeanContextshipEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextMembershipListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextMembershipListener
的使用

使用 BeanContextMembershipListener 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextMembershipListener 的使用

返回 BeanContextMembershipListener 的 java.beans.beancontext 中的方法
protected static BeanContextMembershipListener BeanContextSupport.getChildBeanContextMembershipListener(Object child)
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。

参数类型为 BeanContextMembershipListener 的 java.beans.beancontext 中的方法
void | BeanContext.addBeanContextMembershipListener(BeanContextMembershipListener bcml) 添加指定的 BeanContextMembershipListener，以便无论何时添加或移除一个子 Component，都可以接收来自此 BeanContext 的 BeanContextMembershipEvents。
void | BeanContextSupport.addBeanContextMembershipListener(BeanContextMembershipListener bcml) 添加一个 BeanContextMembershipListener。
void | BeanContext.removeBeanContextMembershipListener(BeanContextMembershipListener bcml) 移除指定的 BeanContextMembershipListener，以便在添加或移除子 Component 时不再接收 BeanContextMembershipEvent。
void | BeanContextSupport.removeBeanContextMembershipListener(BeanContextMembershipListener bcml) 移除一个 BeanContextMembershipListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextProxy
的使用

没有 java.beans.beancontext.BeanContextProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextServiceAvailableEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServiceAvailableEvent
的使用

使用 BeanContextServiceAvailableEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceAvailableEvent 的使用

参数类型为 BeanContextServiceAvailableEvent 的 java.beans.beancontext 中的方法
protected void | BeanContextServicesSupport.fireServiceAdded(BeanContextServiceAvailableEvent bcssae) 触发一个指示新服务已变得可用的 BeanContextServiceAvailableEvent。
void | BeanContextChildSupport.serviceAvailable(BeanContextServiceAvailableEvent bcsae) 可从嵌套 BeanContext 中获得新的服务。
void | BeanContextServicesListener.serviceAvailable(BeanContextServiceAvailableEvent bcsae) 指定服务已被注册。
void | BeanContextServicesSupport.serviceAvailable(BeanContextServiceAvailableEvent bcssae) BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServiceProvider
的使用

使用 BeanContextServiceProvider 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceProvider 的使用

实现 BeanContextServiceProvider 的 java.beans.beancontext 中的类
protected  class BeanContextServicesSupport.BCSSProxyServiceProvider

声明为 BeanContextServiceProvider 的 java.beans.beancontext 中的字段
protected  BeanContextServiceProvider BeanContextServicesSupport.BCSSServiceProvider.serviceProvider

返回 BeanContextServiceProvider 的 java.beans.beancontext 中的方法
protected  BeanContextServiceProvider BeanContextServicesSupport.BCSSServiceProvider.getServiceProvider()

参数类型为 BeanContextServiceProvider 的 java.beans.beancontext 中的方法
 boolean BeanContextServices.addService(Class serviceClass, BeanContextServiceProvider serviceProvider)
向此 BeanContext 添加服务。
 boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp)
添加服务。
protected  boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
添加服务。
protected  BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider(Class sc, BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。
 void BeanContextServices.revokeService(Class serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。
 void BeanContextServicesSupport.revokeService(Class serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
移除服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextServiceProviderBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServiceProviderBeanInfo
的使用

没有 java.beans.beancontext.BeanContextServiceProviderBeanInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextServiceRevokedEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServiceRevokedEvent
的使用

使用 BeanContextServiceRevokedEvent 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceRevokedEvent 的使用

参数类型为 BeanContextServiceRevokedEvent 的 java.beans.beancontext 中的方法
protected void | BeanContextServicesSupport.fireServiceRevoked(BeanContextServiceRevokedEvent bcsre) 触发一个通知将被取消的服务的 BeanContextServiceEvent。
void | BeanContextChildSupport.serviceRevoked(BeanContextServiceRevokedEvent bcsre) 由嵌套 BeanContext 提供的服务已经被取消。
void | BeanContextServiceRevokedListener.serviceRevoked(BeanContextServiceRevokedEvent bcsre) 指定服务已被取消。
void | BeanContextServicesSupport.serviceRevoked(BeanContextServiceRevokedEvent bcssre) BeanContextServicesListener 回调，如果此 BeanContextService 自己尚未实现此服务，则将事件传播到所有当前已注册侦听器和 BeanContextServices 子级。
void | BeanContextServicesSupport.BCSSProxyServiceProvider.serviceRevoked(BeanContextServiceRevokedEvent bcsre)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextServiceRevokedListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServiceRevokedListener
的使用

使用 BeanContextServiceRevokedListener 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServiceRevokedListener 的使用

java.beans.beancontext 中 BeanContextServiceRevokedListener 的子接口
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
interface | BeanContextServicesListener 用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。

实现 BeanContextServiceRevokedListener 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
protected class | BeanContextServicesSupport.BCSSProxyServiceProvider
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

参数类型为 BeanContextServiceRevokedListener 的 java.beans.beancontext 中的方法
Object | BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
Object | BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) 获得一个可被委托的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextServices 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServices
的使用

使用 BeanContextServices 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServices 的使用

实现 BeanContextServices 的 java.beans.beancontext 中的类
 class BeanContextServicesSupport
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。

返回 BeanContextServices 的 java.beans.beancontext 中的方法
BeanContextServices | BeanContextServicesSupport.getBeanContextServicesPeer() 获得与此 BeanContextServicesSupport 相关联的 BeanContextServices。
BeanContextServices | BeanContextServiceAvailableEvent.getSourceAsBeanContextServices() 获得作为 BeanContextServices 类型引用的源。
BeanContextServices | BeanContextServiceRevokedEvent.getSourceAsBeanContextServices() 获得作为 BeanContextServices 类型引用的源

参数类型为 BeanContextServices 的 java.beans.beancontext 中的方法
Iterator | BeanContextServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass) 由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
Iterator | BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
Object | BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector) 由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
Object | BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
void | BeanContextServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service) 由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。
void | BeanContextServicesSupport.BCSSProxyServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service)

参数类型为 BeanContextServices 的 java.beans.beancontext 中的构造方法
BeanContextServiceAvailableEvent(BeanContextServices bcs, Class sc)
构造一个 BeanContextAvailableServiceEvent。
BeanContextServiceRevokedEvent(BeanContextServices bcs, Class sc, boolean invalidate)
构造一个 BeanContextServiceEvent。
BeanContextServicesSupport(BeanContextServices peer)
创建一个具有同位体的实例
BeanContextServicesSupport(BeanContextServices peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextServicesSupport 实例

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.beancontext.BeanContextServicesListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.beancontext.BeanContextServicesListener
的使用

使用 BeanContextServicesListener 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServicesListener 的使用

java.beans.beancontext 中 BeanContextServicesListener 的子接口
 interface BeanContextServices
BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 BeanContextServicesListener 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 BeanContextServicesListener 的 java.beans.beancontext 中的方法
protected static BeanContextServicesListener BeanContextServicesSupport.getChildBeanContextServicesListener(Object child)
获得指定子级的 BeanContextServicesListener（如果有）。

参数类型为 BeanContextServicesListener 的 java.beans.beancontext 中的方法
void | BeanContextServices.addBeanContextServicesListener(BeanContextServicesListener bcsl) 将一个 BeanContextServicesListener 添加到此 BeanContext
void | BeanContextServicesSupport.addBeanContextServicesListener(BeanContextServicesListener bcsl) 添加一个 BeanContextServicesListener。
void | BeanContextServices.removeBeanContextServicesListener(BeanContextServicesListener bcsl) 从此 BeanContext 中移除一个 BeanContextServicesListener
void | BeanContextServicesSupport.removeBeanContextServicesListener(BeanContextServicesListener bcsl) 移除一个 BeanContextServicesListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextServicesSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport
的使用

没有 java.beans.beancontext.BeanContextServicesSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextServicesSupport.BCSSChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport.BCSSChild
的使用

没有 java.beans.beancontext.BeanContextServicesSupport.BCSSChild 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport.BCSSServiceProvider
的使用

使用 BeanContextServicesSupport.BCSSServiceProvider 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServicesSupport.BCSSServiceProvider 的使用

返回 BeanContextServicesSupport.BCSSServiceProvider 的 java.beans.beancontext 中的方法
protected  BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider(Class sc, BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextServicesSupport.BCSSProxyServiceProvider
的使用

使用 BeanContextServicesSupport.BCSSProxyServiceProvider 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextServicesSupport.BCSSProxyServiceProvider 的使用

声明为 BeanContextServicesSupport.BCSSProxyServiceProvider 的 java.beans.beancontext 中的字段
protected  BeanContextServicesSupport.BCSSProxyServiceProvider BeanContextServicesSupport.proxy
BeanContextServiceProvider 的委托。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextSupport
的使用

使用 BeanContextSupport 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextSupport 的使用

java.beans.beancontext 中 BeanContextSupport 的子类
 class BeanContextServicesSupport
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextSupport.BCSIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextSupport.BCSIterator
的使用

没有 java.beans.beancontext.BeanContextSupport.BCSIterator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.beancontext.BeanContextSupport.BCSChild 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.beancontext.BeanContextSupport.BCSChild
的使用

使用 BeanContextSupport.BCSChild 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 BeanContextSupport.BCSChild 的使用

java.beans.beancontext 中 BeanContextSupport.BCSChild 的子类
protected  class BeanContextServicesSupport.BCSSChild

返回 BeanContextSupport.BCSChild 的 java.beans.beancontext 中的方法
protected  BeanContextSupport.BCSChild BeanContextServicesSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。
protected  BeanContextSupport.BCSChild BeanContextSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

参数类型为 BeanContextSupport.BCSChild 的 java.beans.beancontext 中的方法
protected  void BeanContextSupport.childDeserializedHook(Object child, BeanContextSupport.BCSChild bcsc)
由 readObject 利用新近反序列化的子级和 BCSChild 调用。
protected  void BeanContextSupport.childJustAddedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。
protected  void BeanContextServicesSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
在已成功移除子级之后，从超类的子级移除操作中调用。
protected  void BeanContextSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.AppletInitializer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.AppletInitializer
的使用

使用 AppletInitializer 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 AppletInitializer 的使用

参数类型为 AppletInitializer 的 java.beans 中的方法
static Object Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
实例化 bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.BeanDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.BeanDescriptor
的使用

使用 BeanDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 BeanDescriptor 的使用

返回 BeanDescriptor 的 java.beans 中的方法
BeanDescriptor | BeanInfo.getBeanDescriptor() 获得 beans BeanDescriptor。
BeanDescriptor | SimpleBeanInfo.getBeanDescriptor() 拒绝关于 bean 的类和 customizer 的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.BeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.BeanInfo
的使用

使用 BeanInfo 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。

java.beans 中 BeanInfo 的使用

实现 BeanInfo 的 java.beans 中的类
 class SimpleBeanInfo
这是一个使得用户提供 BeanInfo 类更容易的支持类。

返回 BeanInfo 的 java.beans 中的方法
BeanInfo[] | BeanInfo.getAdditionalBeanInfo() 此方法允许 BeanInfo 对象返回提供关于当前 bean 额外信息的 BeanInfo 对象组成的任意集合。
BeanInfo[] | SimpleBeanInfo.getAdditionalBeanInfo() 声明没有其他有关的 BeanInfo 对象。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass) 在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, int flags) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。

java.beans.beancontext 中 BeanInfo 的使用

java.beans.beancontext 中 BeanInfo 的子接口
 interface BeanContextServiceProviderBeanInfo
希望提供关于其 bean 可能提供服务的显式消息的 BeanContextServiceProvider 实现者应实现某个 BeanInfo 类，该类实现此 BeanInfo 的子接口并提供有关其服务的方法、属性、事件等显式信息。

返回 BeanInfo 的 java.beans.beancontext 中的方法
 BeanInfo[] BeanContextServiceProviderBeanInfo.getServicesBeanInfo()
获得一个 BeanInfo 数组，为每个可从此 ServiceProvider 中静态得到的类或接口返回一个数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.Beans 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Beans
的使用

没有 java.beans.Beans 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.ConstructorProperties 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.ConstructorProperties
的使用

使用 ConstructorProperties 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ConstructorProperties 的使用

注释类型为 ConstructorProperties 的 java.lang.management 中的构造方法
LockInfo(String className, int identityHashCode)
构造一个 LockInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.Customizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.Customizer
的使用

没有 java.beans.Customizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.DefaultPersistenceDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.DefaultPersistenceDelegate
的使用

没有 java.beans.DefaultPersistenceDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.DesignMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.DesignMode
的使用

使用 DesignMode 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 DesignMode 的使用

java.beans.beancontext 中 DesignMode 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 DesignMode 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.Encoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Encoder
的使用

使用 Encoder 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 Encoder 的使用

java.beans 中 Encoder 的子类
 class XMLEncoder
XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。

参数类型为 Encoder 的 java.beans 中的方法
protected void | DefaultPersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out) initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。
protected void | PersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out) 产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。
protected Expression | DefaultPersistenceDelegate.instantiate(Object oldInstance, Encoder out) instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。
protected abstract Expression | PersistenceDelegate.instantiate(Object oldInstance, Encoder out) 返回其值为 oldInstance 的表达式。
void | PersistenceDelegate.writeObject(Object oldInstance, Encoder out) writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.EventHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.EventHandler
的使用

没有 java.beans.EventHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.EventSetDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.EventSetDescriptor
的使用

使用 EventSetDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 EventSetDescriptor 的使用

返回 EventSetDescriptor 的 java.beans 中的方法
EventSetDescriptor[] | BeanInfo.getEventSetDescriptors() 获得 beans EventSetDescriptor。
EventSetDescriptor[] | SimpleBeanInfo.getEventSetDescriptors() 拒绝事件集的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.ExceptionListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.ExceptionListener
的使用

使用 ExceptionListener 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 ExceptionListener 的使用

返回 ExceptionListener 的 java.beans 中的方法
ExceptionListener | Encoder.getExceptionListener() 获得此流的异常处理程序。
ExceptionListener | XMLDecoder.getExceptionListener() 获得此流的异常处理程序。

参数类型为 ExceptionListener 的 java.beans 中的方法
void | Encoder.setExceptionListener(ExceptionListener exceptionListener) 将此流的异常处理程序设置为 exceptionListener。
void | XMLDecoder.setExceptionListener(ExceptionListener exceptionListener) 将此流的异常处理程序设置为 exceptionListener。

参数类型为 ExceptionListener 的 java.beans 中的构造方法
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.Expression 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Expression
的使用

使用 Expression 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 Expression 的使用

返回 Expression 的 java.beans 中的方法
protected Expression | DefaultPersistenceDelegate.instantiate(Object oldInstance, Encoder out) instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。
protected abstract Expression | PersistenceDelegate.instantiate(Object oldInstance, Encoder out) 返回其值为 oldInstance 的表达式。

参数类型为 Expression 的 java.beans 中的方法
void | Encoder.writeExpression(Expression oldExp) 该实现首先查看使用此值的表达式是否已经被写入。
void | XMLEncoder.writeExpression(Expression oldExp) 记录 Expression，以便 Encoder 在刷新流的缓存时产生实际输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.FeatureDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.FeatureDescriptor
的使用

使用 FeatureDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 FeatureDescriptor 的使用

java.beans 中 FeatureDescriptor 的子类
class | BeanDescriptor BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。
class | EventSetDescriptor 描述给定 Java bean 激发的一组事件的 EventSetDescriptor。
class | IndexedPropertyDescriptor IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。
class | MethodDescriptor MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。
class | ParameterDescriptor ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。
class | PropertyDescriptor PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.IndexedPropertyChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.IndexedPropertyChangeEvent
的使用

没有 java.beans.IndexedPropertyChangeEvent 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.IndexedPropertyDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.IndexedPropertyDescriptor
的使用

没有 java.beans.IndexedPropertyDescriptor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.IntrospectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.IntrospectionException
的使用

使用 IntrospectionException 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 IntrospectionException 的使用

抛出 IntrospectionException 的 java.beans 中的方法
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass) 在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo | Introspector.getBeanInfo(Class<?> beanClass, int flags) 在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。
void | IndexedPropertyDescriptor.setIndexedReadMethod(Method readMethod) 设置应该用于读取索引属性值的方法。
void | IndexedPropertyDescriptor.setIndexedWriteMethod(Method writeMethod) 设置应该用于写入索引属性值的方法。
void | PropertyDescriptor.setReadMethod(Method readMethod) 设置应该用于读取属性值的方法。
void | PropertyDescriptor.setWriteMethod(Method writeMethod) 设置应该用于写入属性值的方法。

抛出 IntrospectionException 的 java.beans 中的构造方法
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass)
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。
IndexedPropertyDescriptor(String propertyName, Method readMethod, Method writeMethod, Method indexedReadMethod, Method indexedWriteMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
PropertyDescriptor(String propertyName, Class<?> beanClass)
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。
PropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。
PropertyDescriptor(String propertyName, Method readMethod, Method writeMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.Introspector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Introspector
的使用

没有 java.beans.Introspector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.MethodDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.MethodDescriptor
的使用

使用 MethodDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 MethodDescriptor 的使用

返回 MethodDescriptor 的 java.beans 中的方法
MethodDescriptor[] | EventSetDescriptor.getListenerMethodDescriptors() 获得目标侦听器接口的 MethodDescriptor。
MethodDescriptor[] | BeanInfo.getMethodDescriptors() 获得 beans MethodDescriptor。
MethodDescriptor[] | SimpleBeanInfo.getMethodDescriptors() 拒绝方法的信息。

参数类型为 MethodDescriptor 的 java.beans 中的构造方法
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.ParameterDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.ParameterDescriptor
的使用

使用 ParameterDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 ParameterDescriptor 的使用

返回 ParameterDescriptor 的 java.beans 中的方法
 ParameterDescriptor[] MethodDescriptor.getParameterDescriptors()
获得此 MethodDescriptor 每个方法参数的 ParameterDescriptor。

参数类型为 ParameterDescriptor 的 java.beans 中的构造方法
MethodDescriptor(Method method, ParameterDescriptor[] parameterDescriptors)
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PersistenceDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PersistenceDelegate
的使用

使用 PersistenceDelegate 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 PersistenceDelegate 的使用

java.beans 中 PersistenceDelegate 的子类
 class DefaultPersistenceDelegate
DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。

返回 PersistenceDelegate 的 java.beans 中的方法
 PersistenceDelegate Encoder.getPersistenceDelegate(Class<?> type)
返回给定类型的持久委托。

参数类型为 PersistenceDelegate 的 java.beans 中的方法
 void Encoder.setPersistenceDelegate(Class<?> type, PersistenceDelegate persistenceDelegate)
将与此 type 相关联的持久委托设置为 persistenceDelegate。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PropertyDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyDescriptor
的使用

使用 PropertyDescriptor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 PropertyDescriptor 的使用

java.beans 中 PropertyDescriptor 的子类
 class IndexedPropertyDescriptor
IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。

返回 PropertyDescriptor 的 java.beans 中的方法
PropertyDescriptor[] | BeanInfo.getPropertyDescriptors() 获得 beans PropertyDescriptor。
PropertyDescriptor[] | SimpleBeanInfo.getPropertyDescriptors() 拒绝属性的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.PropertyEditor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.PropertyEditor
的使用

使用 PropertyEditor 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 PropertyEditor 的使用

实现 PropertyEditor 的 java.beans 中的类
 class PropertyEditorSupport
这是一个帮助构建属性编辑器的支持类。

返回 PropertyEditor 的 java.beans 中的方法
PropertyEditor | PropertyDescriptor.createPropertyEditor(Object bean) 使用当前属性编辑器类构造一个属性编辑器实例。
static PropertyEditor | PropertyEditorManager.findEditor(Class<?> targetType) 查找给定目标类型的值编辑器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PropertyEditorManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyEditorManager
的使用

没有 java.beans.PropertyEditorManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PropertyEditorSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyEditorSupport
的使用

没有 java.beans.PropertyEditorSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.SimpleBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.SimpleBeanInfo
的使用

没有 java.beans.SimpleBeanInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.Statement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.Statement
的使用

使用 Statement 的软件包
java.beans 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans 中 Statement 的使用

java.beans 中 Statement 的子类
 class Expression
Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。

参数类型为 Statement 的 java.beans 中的方法
void | Encoder.writeStatement(Statement oldStm) 将语句 oldStm 写入流中。
void | XMLEncoder.writeStatement(Statement oldStm) 记录 Statement，以便 Encoder 在刷新流的缓存时产生实际输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.VetoableChangeListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.VetoableChangeListenerProxy
的使用

没有 java.beans.VetoableChangeListenerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.VetoableChangeSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.VetoableChangeSupport
的使用

使用 VetoableChangeSupport 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 VetoableChangeSupport 的使用

声明为 VetoableChangeSupport 的 java.beans.beancontext 中的字段
protected  VetoableChangeSupport BeanContextChildSupport.vcSupport
与此 BeanContextChildSupport 相关联的 VetoableChangeSupport。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.Visibility 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.Visibility
的使用

使用 Visibility 的软件包
java.beans.beancontext 提供与 bean 上下文有关的类和接口。

java.beans.beancontext 中 Visibility 的使用

java.beans.beancontext 中 Visibility 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 Visibility 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 Visibility 的 java.beans.beancontext 中的方法
protected static Visibility BeanContextSupport.getChildVisibility(Object child)
获得与指定子级相关联的 Component（如果有）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.XMLDecoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.XMLDecoder
的使用

没有 java.beans.XMLDecoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.XMLEncoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.XMLEncoder
的使用

没有 java.beans.XMLEncoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PropertyVetoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyVetoException
的使用

使用 PropertyVetoException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 java.awt 中的方法
protected  void KeyboardFocusManager.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应可否决属性中的更改。

java.beans 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 java.beans 中的方法
void | VetoableChangeSupport.fireVetoableChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个 vetoable 属性更新。
void | VetoableChangeSupport.fireVetoableChange(String propertyName, boolean oldValue, boolean newValue) 向所有已注册的侦听器报告一个 boolean vetoable 属性更新。
void | VetoableChangeSupport.fireVetoableChange(String propertyName, int oldValue, int newValue) 向所有已注册的侦听器报告一个 int vetoable 属性更新。
void | VetoableChangeSupport.fireVetoableChange(String propertyName, Object oldValue, Object newValue) 向所有已注册的侦听器报告 vetoable 属性更新。
void | VetoableChangeListenerProxy.vetoableChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
void | VetoableChangeListener.vetoableChange(PropertyChangeEvent evt) 在约束属性发生更改时调用此方法。

java.beans.beancontext 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 java.beans.beancontext 中的方法
void | BeanContextChildSupport.fireVetoableChange(String name, Object oldValue, Object newValue) 向所有已注册的侦听器报告 vetoable 属性更新。
void | BeanContextChild.setBeanContext(BeanContext bc) 实现此接口的对象应使用以下参数激活一个 java.beans.PropertyChangeEvent：propertyName "beanContext"、oldValue（以前的嵌套 BeanContext 实例，或 null）、newValue（当前的嵌套 BeanContext 实例，或 null）。
void | BeanContextChildSupport.setBeanContext(BeanContext bc) 设置此 BeanContextChildSupport 的 BeanContext。
void | BeanContextSupport.setLocale(Locale newLocale) 设置此 BeanContext 的语言环境。
void | BeanContextSupport.vetoableChange(PropertyChangeEvent pce) 子类可以封装此方法来监视子类属性的更改。

javax.swing 中 PropertyVetoException 的使用

抛出 PropertyVetoException 的 javax.swing 中的方法
protected void | JComponent.fireVetoableChange(String propertyName, Object oldValue, Object newValue) 支持报告约束 (constrained) 属性的更改。
void | JInternalFrame.setClosed(boolean b) 如果参数为 true，则关闭此内部窗体。
void | JInternalFrame.setIcon(boolean b) 如果外观支持图标化，则对此内部窗体执行图标化或取消图标化。
void | JInternalFrame.setMaximum(boolean b) 最大化并还原此内部窗体。
void | JInternalFrame.setSelected(boolean selected) 如果要显示内部窗体，则选定或取消选定该窗体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.VetoableChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.VetoableChangeListener
的使用

使用 VetoableChangeListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 VetoableChangeListener 的使用

返回 VetoableChangeListener 的 java.awt 中的方法
VetoableChangeListener[] | KeyboardFocusManager.getVetoableChangeListeners() 返回在此键盘焦点管理器上注册的所有可否决更改侦听器组成的数组。
VetoableChangeListener[] | KeyboardFocusManager.getVetoableChangeListeners(String propertyName) 返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。

参数类型为 VetoableChangeListener 的 java.awt 中的方法
void | KeyboardFocusManager.addVetoableChangeListener(String propertyName, VetoableChangeListener listener) 将 VetoableChangeListener 添加到特定属性的侦听器列表。
void | KeyboardFocusManager.addVetoableChangeListener(VetoableChangeListener listener) 将 VetoableChangeListener 添加到侦听器列表。
void | KeyboardFocusManager.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener) 从特定属性的侦听器列表移除 VetoableChangeListener。
void | KeyboardFocusManager.removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除 VetoableChangeListener。

java.beans 中 VetoableChangeListener 的使用

实现 VetoableChangeListener 的 java.beans 中的类
 class VetoableChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

返回 VetoableChangeListener 的 java.beans 中的方法
VetoableChangeListener[] | VetoableChangeSupport.getVetoableChangeListeners() 返回 VetoableChangeListener 的列表。
VetoableChangeListener[] | VetoableChangeSupport.getVetoableChangeListeners(String propertyName) 返回与指定属性相关联的所有侦听器组成的数组。

参数类型为 VetoableChangeListener 的 java.beans 中的方法
void | VetoableChangeSupport.addVetoableChangeListener(String propertyName, VetoableChangeListener listener) 为特定属性添加一个 VetoableChangeListener。
void | VetoableChangeSupport.addVetoableChangeListener(VetoableChangeListener listener) 向侦听器列表添加一个 VetoableListener。
void | VetoableChangeSupport.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener) 为特定属性移除一个 VetoableChangeListener。
void | VetoableChangeSupport.removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除一个 VetoableChangeListener。

参数类型为 VetoableChangeListener 的 java.beans 中的构造方法
VetoableChangeListenerProxy(String propertyName, VetoableChangeListener listener)

java.beans.beancontext 中 VetoableChangeListener 的使用

实现 VetoableChangeListener 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 VetoableChangeListener 的 java.beans.beancontext 中的方法
protected static VetoableChangeListener BeanContextSupport.getChildVetoableChangeListener(Object child)
与指定 Child 相关联的 VetoableChangeListener（如果有）。

参数类型为 VetoableChangeListener 的 java.beans.beancontext 中的方法
void | BeanContextChild.addVetoableChangeListener(String name, VetoableChangeListener vcl) 将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。
void | BeanContextChildSupport.addVetoableChangeListener(String name, VetoableChangeListener vcl) 为特定属性添加一个 VetoableChangeListener。
void | BeanContextChild.removeVetoableChangeListener(String name, VetoableChangeListener vcl) 从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。
void | BeanContextChildSupport.removeVetoableChangeListener(String name, VetoableChangeListener vcl) 移除一个 VetoableChangeListener。

javax.swing 中 VetoableChangeListener 的使用

返回 VetoableChangeListener 的 javax.swing 中的方法
 VetoableChangeListener[] JComponent.getVetoableChangeListeners()
返回在此组件上注册的所有可否决更改侦听器所组成的数组。

参数类型为 VetoableChangeListener 的 javax.swing 中的方法
void | JComponent.addVetoableChangeListener(VetoableChangeListener listener) 向侦听器列表添加一个 VetoableChangeListener。
void | JComponent.removeVetoableChangeListener(VetoableChangeListener listener) 从侦听器列表移除一个 VetoableChangeListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PropertyChangeListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyChangeListenerProxy
的使用

没有 java.beans.PropertyChangeListenerProxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.beans.PropertyChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.beans.PropertyChangeListener
的使用

使用 PropertyChangeListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 PropertyChangeListener 的使用

返回 PropertyChangeListener 的 java.awt 中的方法
PropertyChangeListener[] | KeyboardFocusManager.getPropertyChangeListeners() 返回在此键盘焦点管理器上注册的所有属性更改侦听器组成的数组。
PropertyChangeListener[] | Toolkit.getPropertyChangeListeners() 返回在此工具包上所有已注册的属性更改侦听器所组成的数组。
PropertyChangeListener[] | Component.getPropertyChangeListeners() 返回在此组件上所有已注册的属性更改侦听器的数组。
PropertyChangeListener[] | SystemTray.getPropertyChangeListeners(String propertyName) 返回与指定属性关联的所有侦听器的数组。
PropertyChangeListener[] | KeyboardFocusManager.getPropertyChangeListeners(String propertyName) 返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。
PropertyChangeListener[] | Toolkit.getPropertyChangeListeners(String propertyName) 返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。
PropertyChangeListener[] | Component.getPropertyChangeListeners(String propertyName) 返回与指定属性相关联的所有侦听器的数组。

参数类型为 PropertyChangeListener 的 java.awt 中的方法
void | KeyboardFocusManager.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | Window.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | Container.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | Container.AccessibleAWTContainer.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | Component.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | Component.AccessibleAWTComponent.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表中。
void | SystemTray.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到特定属性的侦听器列表中。
void | KeyboardFocusManager.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到特定属性的侦听器列表。
void | Toolkit.addPropertyChangeListener(String name, PropertyChangeListener pcl) 为指定的桌面属性添加指定的属性更改侦听器。
void | Window.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将 PropertyChangeListener 添加到某个特定属性的侦听器列表。
void | Container.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。
void | Component.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 向指定属性的侦听器列表添加一个 PropertyChangeListener。
void | KeyboardFocusManager.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | Component.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
void | Component.AccessibleAWTComponent.removePropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 从侦听器列表中移除。
void | SystemTray.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从特定属性的侦听器列表中移除 PropertyChangeListener。
void | KeyboardFocusManager.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从特定属性的侦听器列表移除 PropertyChangeListener。
void | Toolkit.removePropertyChangeListener(String name, PropertyChangeListener pcl) 为指定的桌面属性移除指定的属性更改侦听器。
void | Component.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 从指定属性的侦听器列表中移除一个 PropertyChangeListener。

java.beans 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 java.beans 中的类
 class PropertyChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。

返回 PropertyChangeListener 的 java.beans 中的方法
 PropertyChangeListener[] PropertyChangeSupport.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 PropertyChangeSupport 对象中的所有侦听器组成的数组。
 PropertyChangeListener[] PropertyChangeSupport.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的列表。

参数类型为 PropertyChangeListener 的 java.beans 中的方法
void | Customizer.addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | PropertyEditor.addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | PropertyEditorSupport.addPropertyChangeListener(PropertyChangeListener listener) 注册一个用于 PropertyChange 事件的侦听器。
void | PropertyChangeSupport.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | PropertyChangeSupport.addPropertyChangeListener(String propertyName, PropertyChangeListener listener) 为指定的属性向侦听器列表中添加一个 PropertyChangeListener。
void | Customizer.removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | PropertyEditor.removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | PropertyEditorSupport.removePropertyChangeListener(PropertyChangeListener listener) 移除一个用于 PropertyChange 事件的侦听器。
void | PropertyChangeSupport.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
void | PropertyChangeSupport.removePropertyChangeListener(String propertyName, PropertyChangeListener listener) 为特定属性移除一个 PropertyChangeListener。

参数类型为 PropertyChangeListener 的 java.beans 中的构造方法
PropertyChangeListenerProxy(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 绑定到特定属性的构造方法。

java.beans.beancontext 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

返回 PropertyChangeListener 的 java.beans.beancontext 中的方法
protected static PropertyChangeListener BeanContextSupport.getChildPropertyChangeListener(Object child)
与指定 Child 相关联的 PropertyChangeListener（如果有）

参数类型为 PropertyChangeListener 的 java.beans.beancontext 中的方法
void | BeanContextChild.addPropertyChangeListener(String name, PropertyChangeListener pcl) 将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。
void | BeanContextChildSupport.addPropertyChangeListener(String name, PropertyChangeListener pcl) 为特定属性添加一个 PropertyChangeListener。
void | BeanContextChild.removePropertyChangeListener(String name, PropertyChangeListener pcl) 从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。
void | BeanContextChildSupport.removePropertyChangeListener(String name, PropertyChangeListener pcl) 为特定属性移除一个 PropertyChangeListener。

java.util.jar 中 PropertyChangeListener 的使用

参数类型为 PropertyChangeListener 的 java.util.jar 中的方法
 void Pack200.Packer.addPropertyChangeListener(PropertyChangeListener listener)
为属性映射上的 PropertyChange 事件注册一个侦听器。
 void Pack200.Unpacker.addPropertyChangeListener(PropertyChangeListener listener)
为属性映射上的 PropertyChange 事件注册一个侦听器。
 void Pack200.Packer.removePropertyChangeListener(PropertyChangeListener listener)
移除由 Pack200.Packer.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。
 void Pack200.Unpacker.removePropertyChangeListener(PropertyChangeListener listener)
移除由 Pack200.Unpacker.addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。

java.util.logging 中 PropertyChangeListener 的使用

参数类型为 PropertyChangeListener 的 java.util.logging 中的方法
void | LogManager.addPropertyChangeListener(PropertyChangeListener l) 添加重读日志属性时调用的事件侦听器。
void | LogManager.removePropertyChangeListener(PropertyChangeListener l) 移除属性更改事件的事件侦听器。

javax.accessibility 中 PropertyChangeListener 的使用

参数类型为 PropertyChangeListener 的 javax.accessibility 中的方法
void | AccessibleContext.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | AccessibleContext.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。

javax.swing 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing 中的类
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

返回 PropertyChangeListener 的 javax.swing 中的方法
protected  PropertyChangeListener JToolBar.createActionChangeListener(JButton b)
返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。
protected  PropertyChangeListener JPopupMenu.createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected  PropertyChangeListener JMenu.createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected  PropertyChangeListener JTextField.createActionPropertyChangeListener(Action a)
创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。
protected  PropertyChangeListener JComboBox.createActionPropertyChangeListener(Action a)
创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。
protected  PropertyChangeListener AbstractButton.createActionPropertyChangeListener(Action a)
创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。
 PropertyChangeListener[] AbstractAction.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 AbstractAction 中的所有 PropertyChangeListener 组成的数组。
 PropertyChangeListener[] UIDefaults.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 UIDefaults 的所有 PropertyChangeListener 组成的数组。
static PropertyChangeListener[] UIManager.getPropertyChangeListeners()
返回添加到此 UIManager（具有 addPropertyChangeListener()）的所有 PropertyChangeListener 的数组。

参数类型为 PropertyChangeListener 的 javax.swing 中的方法
void | SwingWorker.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | JTree.AccessibleJTree.AccessibleJTreeNode.addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
void | JTable.AccessibleJTable.AccessibleJTableCell.addPropertyChangeListener(PropertyChangeListener l) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | AbstractAction.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
void | JList.AccessibleJList.AccessibleJListChild.addPropertyChangeListener(PropertyChangeListener l)
void | Action.addPropertyChangeListener(PropertyChangeListener listener) 添加一个 PropertyChange 侦听器。
void | UIDefaults.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表添加一个 PropertyChangeListener。
static void | UIManager.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表。
void | JComponent.AccessibleJComponent.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | SwingWorker.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表中移除一个 PropertyChangeListener。
void | JTree.AccessibleJTree.AccessibleJTreeNode.removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表中移除 PropertyChangeListener。
void | JTable.AccessibleJTable.AccessibleJTableCell.removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除一个 PropertyChangeListener。
void | AbstractAction.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表中移除一个 PropertyChangeListener。
void | JList.AccessibleJList.AccessibleJListChild.removePropertyChangeListener(PropertyChangeListener l)
void | Action.removePropertyChangeListener(PropertyChangeListener listener) 移除一个 PropertyChange 侦听器。
void | UIDefaults.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
static void | UIManager.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | JComponent.AccessibleJComponent.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。

javax.swing.plaf.basic 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicColorChooserUI.PropertyHandler 因编译器故障而被标记为 "public" 的内部类。
class | BasicComboBoxUI.PropertyChangeHandler 此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
protected class | BasicComboPopup.PropertyChangeHandler 此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。
class | BasicDirectoryModel 文件列表的基本实现。
class | BasicInternalFrameTitlePane.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicInternalFrameUI.InternalFramePropertyChangeListener
class | BasicLabelUI LabelUI 的 Windows L&F 实现。
class | BasicListUI.PropertyChangeHandler 在 installUI 时添加到 JList 的 PropertyChangeListener。
class | BasicOptionPaneUI.PropertyChangeHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicRootPaneUI RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
class | BasicScrollBarUI.PropertyChangeHandler
class | BasicScrollPaneUI.PropertyChangeHandler
class | BasicSliderUI.PropertyChangeHandler
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
class | BasicSplitPaneUI.PropertyHandler JSplitPane UI 使用的 PropertyChangeListener 的实现。
class | BasicTabbedPaneUI.PropertyChangeHandler 此类应视为“受保护”内部类。
protected class | BasicToolBarUI.PropertyListener
class | BasicTreeUI.PropertyChangeHandler 树的 PropertyChangeListener。
class | BasicTreeUI.SelectionModelPropertyChangeHandler TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。

声明为 PropertyChangeListener 的 javax.swing.plaf.basic 中的字段
protected PropertyChangeListener | BasicColorChooserUI.propertyChangeListener
protected PropertyChangeListener | BasicInternalFrameTitlePane.propertyChangeListener
protected PropertyChangeListener | BasicInternalFrameUI.propertyChangeListener
protected PropertyChangeListener | BasicOptionPaneUI.propertyChangeListener
protected PropertyChangeListener | BasicSliderUI.propertyChangeListener
protected PropertyChangeListener | BasicSplitPaneUI.propertyChangeListener 此 JSplitPane 的 PropertyChangeListener 的实例。
protected PropertyChangeListener | BasicTabbedPaneUI.propertyChangeListener
protected PropertyChangeListener | BasicListUI.propertyChangeListener
protected PropertyChangeListener | BasicComboPopup.propertyChangeListener 此受保护字段是特定于实现的。
protected PropertyChangeListener | BasicComboBoxUI.propertyChangeListener 此受保护字段是特定于实现的。
protected PropertyChangeListener | BasicScrollBarUI.propertyChangeListener
protected PropertyChangeListener | BasicMenuItemUI.propertyChangeListener 从 createPropertyChangeListener 返回的 PropertyChangeListener。
protected PropertyChangeListener | BasicToolBarUI.propertyListener
protected PropertyChangeListener | BasicScrollPaneUI.spPropertyChangeListener

返回 PropertyChangeListener 的 javax.swing.plaf.basic 中的方法
protected  PropertyChangeListener BasicColorChooserUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicDesktopPaneUI.createPropertyChangeListener()
返回要安装到 JDesktopPane 上的 PropertyChangeListener。
protected  PropertyChangeListener BasicInternalFrameTitlePane.createPropertyChangeListener()
protected  PropertyChangeListener BasicInternalFrameUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicOptionPaneUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicSpinnerUI.createPropertyChangeListener()
创建一个可以添加到 JSpinner 本身的 PropertyChangeListener。
protected  PropertyChangeListener BasicSplitPaneUI.createPropertyChangeListener()
创建 JSplitPane UI 的 PropertyChangeListener。
protected  PropertyChangeListener BasicTreeUI.createPropertyChangeListener()
创建负责基于树的更改方式更新 UI 的侦听器。
protected  PropertyChangeListener BasicTabbedPaneUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicScrollPaneUI.createPropertyChangeListener()
创建由 installUI() 添加到 JScrollPane 的 PropertyChangeListener 的实例。
protected  PropertyChangeListener BasicListUI.createPropertyChangeListener()
创建由 installUI() 添加到 JList 的 PropertyChangeHandler 的实例。
protected  PropertyChangeListener BasicComboPopup.createPropertyChangeListener()
创建将添加到组合框的 PropertyChangeListener。
protected  PropertyChangeListener BasicComboBoxUI.createPropertyChangeListener()
创建将添加到组合框的 PropertyChangeListener。
protected  PropertyChangeListener BasicScrollBarUI.createPropertyChangeListener()
protected  PropertyChangeListener BasicMenuUI.createPropertyChangeListener(JComponent c)
protected  PropertyChangeListener BasicMenuItemUI.createPropertyChangeListener(JComponent c)
创建一个将被添加到菜单项的 PropertyChangeListener。
 PropertyChangeListener BasicFileChooserUI.createPropertyChangeListener(JFileChooser fc)
protected  PropertyChangeListener BasicSliderUI.createPropertyChangeListener(JSlider slider)
protected  PropertyChangeListener BasicToolBarUI.createPropertyListener()
protected  PropertyChangeListener BasicTreeUI.createSelectionModelPropertyChangeListener()
创建负责从选择模型获取属性更改事件的侦听器。
 PropertyChangeListener[] BasicDirectoryModel.getPropertyChangeListeners()
返回一个在此组件上注册的所有属性更改侦听器的数组。

参数类型为 PropertyChangeListener 的 javax.swing.plaf.basic 中的方法
void | BasicDirectoryModel.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表。
void | BasicDirectoryModel.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。

javax.swing.plaf.metal 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxUI.MetalPropertyChangeListener 此内部类由于编译器故障而被标记为 "public"。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。
class | MetalLabelUI LabelUI 的 Windows L&F 实现。
class | MetalRootPaneUI 提供 RootPaneUI 的 metal 外观实现。
protected class | MetalSliderUI.MetalPropertyListener
protected class | MetalToolBarUI.MetalRolloverListener

声明为 PropertyChangeListener 的 javax.swing.plaf.metal 中的字段
protected  PropertyChangeListener MetalToolBarUI.rolloverListener
此受保护的字段是特定于实现的。

返回 PropertyChangeListener 的 javax.swing.plaf.metal 中的方法
protected PropertyChangeListener | MetalInternalFrameTitlePane.createPropertyChangeListener()
PropertyChangeListener | MetalComboBoxUI.createPropertyChangeListener()
protected PropertyChangeListener | MetalScrollBarUI.createPropertyChangeListener()
PropertyChangeListener | MetalFileChooserUI.createPropertyChangeListener(JFileChooser fc)
protected PropertyChangeListener | MetalSliderUI.createPropertyChangeListener(JSlider slider)
protected PropertyChangeListener | MetalToolBarUI.createRolloverListener() 创建一个将添加到 JToolBar 中的属性更改侦听器。
protected PropertyChangeListener | MetalScrollPaneUI.createScrollBarSwapListener()

javax.swing.table 中 PropertyChangeListener 的使用

实现 PropertyChangeListener 的 javax.swing.table 中的类
 class DefaultTableColumnModel
JTable 的标准列处理程序。

返回 PropertyChangeListener 的 javax.swing.table 中的方法
 PropertyChangeListener[] TableColumn.getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 TableColumn 的所有 PropertyChangeListener 组成的数组。

参数类型为 PropertyChangeListener 的 javax.swing.table 中的方法
void | TableColumn.addPropertyChangeListener(PropertyChangeListener listener) 向侦听器列表中添加一个 PropertyChangeListener。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.addPropertyChangeListener(PropertyChangeListener l)
void | TableColumn.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表中移除一个 PropertyChangeListener。
void | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.removePropertyChangeListener(PropertyChangeListener l)

javax.swing.tree 中 PropertyChangeListener 的使用

返回 PropertyChangeListener 的 javax.swing.tree 中的方法
 PropertyChangeListener[] DefaultTreeSelectionModel.getPropertyChangeListeners()
返回此 DefaultTreeSelectionModel 上注册的所有属性更改侦听器组成的数组。

参数类型为 PropertyChangeListener 的 javax.swing.tree 中的方法
void | DefaultTreeSelectionModel.addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | TreeSelectionModel.addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
void | DefaultTreeSelectionModel.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | TreeSelectionModel.removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PropertyChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyChangeEvent
的使用

使用 PropertyChangeEvent 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.beans 中 PropertyChangeEvent 的使用

java.beans 中 PropertyChangeEvent 的子类
 class IndexedPropertyChangeEvent
无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。

返回 PropertyChangeEvent 的 java.beans 中的方法
 PropertyChangeEvent PropertyVetoException.getPropertyChangeEvent()
获得禁止的 PropertyChangeEvent。

参数类型为 PropertyChangeEvent 的 java.beans 中的方法
void | PropertyChangeSupport.firePropertyChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个现有 PropertyChangeEvent。
void | VetoableChangeSupport.fireVetoableChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个 vetoable 属性更新。
void | PropertyChangeListenerProxy.propertyChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
void | PropertyChangeListener.propertyChange(PropertyChangeEvent evt) 在绑定属性发生更改时调用此方法。
void | VetoableChangeListenerProxy.vetoableChange(PropertyChangeEvent evt) 将属性更改事件转发给侦听器代理。
void | VetoableChangeListener.vetoableChange(PropertyChangeEvent evt) 在约束属性发生更改时调用此方法。

参数类型为 PropertyChangeEvent 的 java.beans 中的构造方法
PropertyVetoException(String mess, PropertyChangeEvent evt)
构造带详细消息的 PropertyVetoException。

java.beans.beancontext 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 java.beans.beancontext 中的方法
void | BeanContextSupport.propertyChange(PropertyChangeEvent pce) 子类可以封装此方法来监视子类属性的更改。
void | BeanContextSupport.vetoableChange(PropertyChangeEvent pce) 子类可以封装此方法来监视子类属性的更改。

javax.swing 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing 中的方法
void | JSpinner.DefaultEditor.propertyChange(PropertyChangeEvent e) 由 JFormattedTextField 的 PropertyChangeListener 调用。
void | ProgressMonitor.AccessibleProgressMonitor.propertyChange(PropertyChangeEvent e) 更改绑定 (bound) 属性时，调用此方法。
void | JTable.AccessibleJTable.propertyChange(PropertyChangeEvent e) 跟踪选择模型、列模型等的变更，从而能够重新将侦听器放置这些模型上，以便把信息传递给 Accessibility PropertyChange 机制
void | JScrollPane.AccessibleJScrollPane.propertyChange(PropertyChangeEvent e) 当有一个绑定 (bound) 属性改变时，此方法被调用。
void | JList.AccessibleJList.propertyChange(PropertyChangeEvent e) Property Change Listener 更改方法。
void | JPopupMenu.AccessibleJPopupMenu.propertyChange(PropertyChangeEvent e) 更改绑定 (bound) 属性时调用此方法。

javax.swing.event 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.event 中的方法
 void SwingPropertyChangeSupport.firePropertyChange(PropertyChangeEvent evt)
对所有已注册侦听器激发一个现有 PropertyChangeEvent。

javax.swing.plaf.basic 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.plaf.basic 中的方法
void | BasicColorChooserUI.PropertyHandler.propertyChange(PropertyChangeEvent e)
void | BasicDirectoryModel.propertyChange(PropertyChangeEvent e)
protected void | BasicEditorPaneUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，调用此方法。
void | BasicInternalFrameTitlePane.PropertyChangeHandler.propertyChange(PropertyChangeEvent evt)
void | BasicInternalFrameUI.InternalFramePropertyChangeListener.propertyChange(PropertyChangeEvent evt) 从 JInternalFrame 检测状态更改并处理动作。
void | BasicOptionPaneUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e) 如果 PropertyChangeEvent e 的源等于 optionPane 并且为 ICON_PROPERTY、MESSAGE_PROPERTY、OPTIONS_PROPERTY 或 INITIAL_VALUE_PROPERTY 之一，则调用 validateComponent。
protected void | BasicTextPaneUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
void | BasicSliderUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
protected void | BasicTextAreaUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定 (bound) 属性改变时，此方法被调用。
void | BasicSplitPaneDivider.propertyChange(PropertyChangeEvent e) 属性更改事件（假定发自 JSplitPane）将在必要时传递 updateOrientation 的消息。
void | BasicSplitPaneUI.PropertyHandler.propertyChange(PropertyChangeEvent e) 从包含接收者的 JSplitPane 传递消息。
void | BasicTreeUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent event)
void | BasicTreeUI.SelectionModelPropertyChangeHandler.propertyChange(PropertyChangeEvent event)
void | BasicTabbedPaneUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
protected void | BasicTextUI.propertyChange(PropertyChangeEvent evt) 当关联的 JTextComponent 上有一个绑定属性更改时，此方法被调用。
void | BasicScrollPaneUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicListUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicComboPopup.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicComboBoxUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicScrollBarUI.PropertyChangeHandler.propertyChange(PropertyChangeEvent e)
void | BasicToolBarUI.PropertyListener.propertyChange(PropertyChangeEvent e)
void | BasicButtonListener.propertyChange(PropertyChangeEvent e)
void | BasicLabelUI.propertyChange(PropertyChangeEvent e)
void | BasicRootPaneUI.propertyChange(PropertyChangeEvent e) 在根窗格上发生属性更改时调用。
protected void | BasicScrollPaneUI.updateColumnHeader(PropertyChangeEvent e)
protected void | BasicScrollPaneUI.updateRowHeader(PropertyChangeEvent e)
protected void | BasicScrollPaneUI.updateScrollBarDisplayPolicy(PropertyChangeEvent e)
protected void | BasicScrollPaneUI.updateViewport(PropertyChangeEvent e)

javax.swing.plaf.metal 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.plaf.metal 中的方法
protected void | MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent e) 已过时。 从 Java 2 platform v1.4 开始。
void | MetalFileChooserUI.FilterComboBoxModel.propertyChange(PropertyChangeEvent e)
void | MetalSliderUI.MetalPropertyListener.propertyChange(PropertyChangeEvent e)
void | MetalTextFieldUI.propertyChange(PropertyChangeEvent evt) 此方法在关联的 JTextComponent 上的绑定 (bound) 属性发生更改时调用。
void | MetalComboBoxUI.MetalPropertyChangeListener.propertyChange(PropertyChangeEvent e)
void | MetalRootPaneUI.propertyChange(PropertyChangeEvent e) 属性更改时调用。

javax.swing.table 中 PropertyChangeEvent 的使用

参数类型为 PropertyChangeEvent 的 javax.swing.table 中的方法
 void DefaultTableColumnModel.propertyChange(PropertyChangeEvent evt)
Property Change Listener 更改方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.beans.PropertyChangeSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.beans.PropertyChangeSupport
的使用

使用 PropertyChangeSupport 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

java.awt 中 PropertyChangeSupport 的使用

声明为 PropertyChangeSupport 的 java.awt 中的字段
protected  PropertyChangeSupport Toolkit.desktopPropsSupport

java.beans.beancontext 中 PropertyChangeSupport 的使用

声明为 PropertyChangeSupport 的 java.beans.beancontext 中的字段
protected  PropertyChangeSupport BeanContextChildSupport.pcSupport
与此 BeanContextChildSupport 相关联的 PropertyChangeSupport。

javax.swing 中 PropertyChangeSupport 的使用

返回 PropertyChangeSupport 的 javax.swing 中的方法
 PropertyChangeSupport SwingWorker.getPropertyChangeSupport()
返回此 SwingWorker 的 PropertyChangeSupport。

javax.swing.event 中 PropertyChangeSupport 的使用

javax.swing.event 中 PropertyChangeSupport 的子类
 class SwingPropertyChangeSupport
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BufferedInputStream (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.io
类 BufferedInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.io.BufferedInputStream
所有已实现的接口：
Closeable
public class BufferedInputStream
extends FilterInputStream

BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。在创建 BufferedInputStream 时，会创建一个内部缓冲区数组。在读取或跳过流中的字节时，可根据需要从包含的输入流再次填充该内部缓冲区，一次填充多个字节。mark 操作记录输入流中的某个点，reset 操作使得在从包含的输入流中获取新字节之前，再次读取自最后一次 mark 操作后读取的所有字节。

从以下版本开始：
JDK1.0

字段摘要
protected byte[] | buf 存储数据的内部缓冲区数组。
protected int | count 比缓冲区中最后一个有效字节的索引大 1 的索引。
protected int | marklimit 调用 mark 方法后，在后续调用 reset 方法失败之前所允许的最大提前读取量。
protected int | markpos 最后一次调用 mark 方法时 pos 字段的值。
protected int | pos 缓冲区中的当前位置。
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
BufferedInputStream(InputStream in)
创建一个 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
BufferedInputStream(InputStream in, int size)
创建具有指定缓冲区大小的 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
方法摘要
int | available() 返回可以从此输入流读取（或跳过）、且不受此输入流接下来的方法调用阻塞的估计字节数。
void | close() 关闭此输入流并释放与该流关联的所有系统资源。
void | mark(int readlimit) 参见 InputStream 的 mark 方法的常规协定。
boolean | markSupported() 测试此输入流是否支持 mark 和 reset 方法。
int | read() 参见 InputStream 的 read 方法的常规协定。
int | read(byte[] b, int off, int len) 从此字节输入流中给定偏移量处开始将各字节读取到指定的 byte 数组中。
void | reset() 参见 InputStream 的 reset 方法的常规协定。
long | skip(long n) 参见 InputStream 的 skip 方法的常规协定。
从类 java.io.FilterInputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buf

protected volatile byte[] buf
存储数据的内部缓冲区数组。必要时可用另一个不同大小的数组替换它。

count

protected int count
比缓冲区中最后一个有效字节的索引大 1 的索引。此值始终处于 0 到 buf.length 的范围内；从 buf[0] 到 buf[count-1] 的元素包含从底层输入流中获取的缓冲输入数据。

pos

protected int pos
缓冲区中的当前位置。这是将从 buf 数组中读取的下一个字符的索引。

此值始终处于 0 到 count 的范围内。如果此值小于 count，则 buf[pos] 将作为下一个输入字节；如果此值等于 count，则下一次 read 或 skip 操作需要从包含的输入流中读取更多的字节。

另请参见：
buf

markpos

protected int markpos
最后一次调用 mark 方法时 pos 字段的值。

此值始终处于 -1 到 pos 的范围内。如果输入流中没有被标记的位置，则此字段为 -1。如果输入流中有被标记的位置，则 buf[markpos] 将用作 reset 操作后的第一个输入字节。如果 markpos 不是 -1，则从位置 buf[markpos] 到 buf[pos-1] 之间的所有字节都必须保留在缓冲区数组中（尽管对 count、pos 和 markpos 的值进行适当调整后，这些字节可能移动到缓冲区数组中的其他位置）；除非 pos 与 markpos 的差超过 marklimit，否则不能将其丢弃。

另请参见：
mark(int), pos

marklimit

protected int marklimit
调用 mark 方法后，在后续调用 reset 方法失败之前所允许的最大提前读取量。只要 pos 与 markpos 之差超过 marklimit，就可以通过将 markpos 设置为 -1 来删除该标记。

另请参见：
mark(int), reset()
构造方法详细信息

BufferedInputStream

public BufferedInputStream(InputStream in)
创建一个 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。创建一个内部缓冲区数组并将其存储在 buf 中。

参数：
in - 底层输入流。

BufferedInputStream

public BufferedInputStream(InputStream in,
                           int size)
创建具有指定缓冲区大小的 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。创建一个长度为 size 的内部缓冲区数组并将其存储在 buf 中。

参数：
in - 底层输入流。
size - 缓冲区大小。
抛出：
IllegalArgumentException - 如果 size <= 0
方法详细信息

read

public int read()
         throws IOException
参见 InputStream 的 read 方法的常规协定。

覆盖：
类 FilterInputStream 中的 read
返回：
下一个数据字节，如果到达流末尾，则返回 -1。
抛出：
IOException - 如果已经调用其 close() 方法关闭了此输入流，或者发生 I/O 错误。
另请参见：
FilterInputStream.in

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从此字节输入流中给定偏移量处开始将各字节读取到指定的 byte 数组中。

此方法实现了 InputStream 类相应 read 方法的常规协定。另一个便捷之处在于，它将通过重复地调用底层流的 read 方法，尝试读取尽可能多的字节。这种迭代的 read 会一直继续下去，直到满足以下条件之一：

  • 已经读取了指定的字节数，
  • 底层流的 read 方法返回 -1，指示文件末尾（end-of-file），或者
  • 底层流的 available 方法返回 0，指示将阻塞后续的输入请求。
如果第一次对底层流调用 read 返回 -1（指示文件末尾），则此方法返回 -1。否则此方法返回实际读取的字节数。

鼓励（但不是必须）此类的各个子类以相同的方式尝试读取尽可能多的字节。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 目标缓冲区。
off - 开始存储字节处的偏移量。
len - 要读取的最大字节数。
返回：
读取的字节数；如果已到达流末尾，则返回 -1。
抛出：
IOException - 如果已经调用其 close() 方法关闭了此输入流，或者发生 I/O 错误。
另请参见：
FilterInputStream.in

skip

public long skip(long n)
          throws IOException
参见 InputStream 的 skip 方法的常规协定。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。
抛出：
IOException - 如果流不支持查找操作；或者已经调用其 close() 方法关闭了此输入流；或者发生 I/O 错误。

available

public int available()
              throws IOException
返回可以从此输入流读取（或跳过）、且不受此输入流接下来的方法调用阻塞的估计字节数。接下来的调用可能是同一个线程，也可能是不同的线程。一次读取或跳过这么多字节将不会受阻塞，但可以读取或跳过数量更少的字节。

此方法返回缓冲区中剩余的待读取字节数 (count - pos) 与调用 in.available() 的结果之和。

覆盖：
类 FilterInputStream 中的 available
返回：
可以不受阻塞地从此输入流读取（或跳过）的估计字节数。
抛出：
IOException - 如果已经调用其 close() 方法关闭了此输入流，或者发生 I/O 错误。

mark

public void mark(int readlimit)
参见 InputStream 的 mark 方法的常规协定。

覆盖：
类 FilterInputStream 中的 mark
参数：
readlimit - 在标记位置变为无效之前可以读取字节的最大限制。
另请参见：
reset()

reset

public void reset()
           throws IOException
参见 InputStream 的 reset 方法的常规协定。

如果 markpos 为 -1（尚未设置标记，或者标记已失效），则抛出 IOException。否则将 pos 设置为与 markpos 相等。

覆盖：
类 FilterInputStream 中的 reset
抛出：
IOException - 如果尚未标记此流；或者标记已失效；或者已经调用其 close() 方法关闭了此输入流；或者发生 I/O 错误。
另请参见：
mark(int)

markSupported

public boolean markSupported()
测试此输入流是否支持 mark 和 reset 方法。BufferedInputStream 的 markSupported 方法返回 true。

覆盖：
类 FilterInputStream 中的 markSupported
返回：
一个 boolean 值，指示此流类型是否支持 mark 和 reset 方法。
另请参见：
InputStream.mark(int), InputStream.reset()

close

public void close()
           throws IOException
关闭此输入流并释放与该流关联的所有系统资源。关闭了该流之后，后续的 read()、available()、reset() 或 skip() 调用都将抛出 IOException。关闭之前已关闭的流不会产生任何效果。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BufferedOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 BufferedOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.io.BufferedOutputStream
所有已实现的接口：
Closeable, Flushable
public class BufferedOutputStream
extends FilterOutputStream

该类实现缓冲的输出流。通过设置这种输出流，应用程序就可以将各个字节写入底层输出流中，而不必针对每次字节写入调用底层系统。

从以下版本开始：
JDK1.0

字段摘要
protected byte[] | buf 存储数据的内部缓冲区。
protected int | count 缓冲区中的有效字节数。
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
BufferedOutputStream(OutputStream out)
创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
BufferedOutputStream(OutputStream out, int size)
创建一个新的缓冲输出流，以将具有指定缓冲区大小的数据写入指定的底层输出流。
方法摘要
void | flush() 刷新此缓冲的输出流。
void | write(byte[] b, int off, int len) 将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此缓冲的输出流。
void | write(int b) 将指定的字节写入此缓冲的输出流。
从类 java.io.FilterOutputStream 继承的方法
close, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buf

protected byte[] buf
存储数据的内部缓冲区。

count

protected int count
缓冲区中的有效字节数。此值始终处于 0 到 buf.length 范围内；元素 buf[0] 到 buf[count-1] 包含有效的字节数据。

构造方法详细信息

BufferedOutputStream

public BufferedOutputStream(OutputStream out)
创建一个新的缓冲输出流，以将数据写入指定的底层输出流。

参数：
out - 底层输出流。

BufferedOutputStream

public BufferedOutputStream(OutputStream out,
                            int size)
创建一个新的缓冲输出流，以将具有指定缓冲区大小的数据写入指定的底层输出流。

参数：
out - 底层输出流。
size - 缓冲区的大小。
抛出：
IllegalArgumentException - 如果 size <= 0
方法详细信息

write

public void write(int b)
           throws IOException
将指定的字节写入此缓冲的输出流。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要写入的字节。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此缓冲的输出流。

一般来说，此方法将给定数组的字节存入此流的缓冲区中，根据需要将该缓冲区刷新，并转到底层输出流。但是，如果请求的长度至少与此流的缓冲区大小相同，则此方法将刷新该缓冲区并将各个字节直接写入底层输出流。因此多余的 BufferedOutputStream 将不必复制数据。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 数据。
off - 数据的起始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.write(int)

flush

public void flush()
           throws IOException
刷新此缓冲的输出流。这迫使所有缓冲的输出字节被写出到底层输出流中。

指定者：
接口 Flushable 中的 flush
覆盖：
类 FilterOutputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferedReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 BufferedReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.BufferedReader
所有已实现的接口：
Closeable, Readable
直接已知子类：
LineNumberReader
public class BufferedReader
extends Reader

从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。

可以指定缓冲区的大小，或者可使用默认的大小。大多数情况下，默认值就足够大了。

通常，Reader 所作的每个读取请求都会导致对底层字符或字节流进行相应的读取请求。因此，建议用 BufferedReader 包装所有其 read() 操作可能开销很高的 Reader（如 FileReader 和 InputStreamReader）。例如，

 BufferedReader in
   = new BufferedReader(new FileReader("foo.in"));
将缓冲指定文件的输入。如果没有缓冲，则每次调用 read() 或 readLine() 都会导致从文件中读取字节，并将其转换为字符后返回，而这是极其低效的。

通过用合适的 BufferedReader 替代每个 DataInputStream，可以对将 DataInputStream 用于文字输入的程序进行本地化。

从以下版本开始：
JDK1.1
另请参见：
FileReader, InputStreamReader

字段摘要
从类 java.io.Reader 继承的字段
lock
构造方法摘要
BufferedReader(Reader in)
创建一个使用默认大小输入缓冲区的缓冲字符输入流。
BufferedReader(Reader in, int sz)
创建一个使用指定大小输入缓冲区的缓冲字符输入流。
方法摘要
 void close()
关闭该流并释放与之关联的所有资源。
 void mark(int readAheadLimit)
标记流中的当前位置。
 boolean markSupported()
判断此流是否支持 mark() 操作（它一定支持）。
 int read()
读取单个字符。
 int read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 String readLine()
读取一个文本行。
 boolean ready()
判断此流是否已准备好被读取。
 void reset()
将流重置到最新的标记。
 long skip(long n)
跳过字符。
从类 java.io.Reader 继承的方法
read, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BufferedReader

public BufferedReader(Reader in,
                      int sz)
创建一个使用指定大小输入缓冲区的缓冲字符输入流。

参数：
in - 一个 Reader
sz - 输入缓冲区的大小
抛出：
IllegalArgumentException - 如果 sz <= 0

BufferedReader

public BufferedReader(Reader in)
创建一个使用默认大小输入缓冲区的缓冲字符输入流。

参数：
in - 一个 Reader
方法详细信息

read

public int read()
         throws IOException
读取单个字符。

覆盖：
类 Reader 中的 read
返回：
作为一个整数（其范围从 0 到 65535 (0x00-0xffff)）读入的字符，如果已到达流末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException
将字符读入数组的某一部分。

此方法实现 Reader 类相应 read 方法的常规协定。另一个便捷之处在于，它将通过重复地调用底层流的 read 方法，尝试读取尽可能多的字符。这种迭代的 read 会一直继续下去，直到满足以下条件之一：

  • 已经读取了指定的字符数，
  • 底层流的 read 方法返回 -1，指示文件末尾（end-of-file），或者
  • 底层流的 ready 方法返回 false，指示将阻塞后续的输入请求。
如果第一次对底层流调用 read 返回 -1（指示文件末尾），则此方法返回 -1。否则此方法返回实际读取的字符数。

鼓励（但不是必须）此类的各个子类以相同的方式尝试读取尽可能多的字符。

一般来说，此方法从此流的字符缓冲区中获得字符，根据需要从底层流中填充缓冲区。但是，如果缓冲区为空、标记无效，并且所请求的长度至少与缓冲区相同，则此方法将直接从底层流中将字符读取到给定的数组中。因此多余的 BufferedReader 将不必复制数据。

指定者：
类 Reader 中的 read
参数：
cbuf - 目标缓冲区
off - 开始存储字符处的偏移量
len - 要读取的最大字符数
返回：
读取的字符数，如果已到达流末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

readLine

public String readLine()
                throws IOException
读取一个文本行。通过下列字符之一即可认为某行已终止：换行 ('\n')、回车 ('\r') 或回车后直接跟着换行。

返回：
包含该行内容的字符串，不包含任何行终止符，如果已到达流末尾，则返回 null
抛出：
IOException - 如果发生 I/O 错误

skip

public long skip(long n)
          throws IOException
跳过字符。

覆盖：
类 Reader 中的 skip
参数：
n - 要跳过的字符数
返回：
实际跳过的字符数
抛出：
IllegalArgumentException - 如果 n 为负。
IOException - 如果发生 I/O 错误

ready

public boolean ready()
              throws IOException
判断此流是否已准备好被读取。如果缓冲区不为空，或者底层字符流已准备就绪，则缓冲的字符流准备就绪。

覆盖：
类 Reader 中的 ready
返回：
如果保证下一个 read() 不阻塞输入，则返回 True，否则返回 false。注意，返回 false 并不保证阻塞下一次读取。
抛出：
IOException - 如果发生 I/O 错误

markSupported

public boolean markSupported()
判断此流是否支持 mark() 操作（它一定支持）。

覆盖：
类 Reader 中的 markSupported
返回：
当且仅当此流支持此 mark 操作时，返回 true。

mark

public void mark(int readAheadLimit)
          throws IOException
标记流中的当前位置。对 reset() 的后续调用将尝试将该流重新定位到此点。

覆盖：
类 Reader 中的 mark
参数：
readAheadLimit - 在仍保留该标记的情况下，对可读取字符数量的限制。在读取达到或超过此限制的字符后，尝试重置流可能会失败。限制值大于输入缓冲区的大小将导致分配一个新缓冲区，其大小不小于该限制值。因此应该小心使用较大的值。
抛出：
IllegalArgumentException - 如果 readAheadLimit < 0
IOException - 如果发生 I/O 错误

reset

public void reset()
           throws IOException
将流重置到最新的标记。

覆盖：
类 Reader 中的 reset
抛出：
IOException - 如果从未标记过该流，或者标记已失效。

close

public void close()
           throws IOException
从类 Reader 复制的描述
关闭该流并释放与之关联的所有资源。在关闭该流后，再调用 read()、ready()、mark()、reset() 或 skip() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Reader 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferedWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 BufferedWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.BufferedWriter
所有已实现的接口：
Closeable, Flushable, Appendable
public class BufferedWriter
extends Writer

将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。

可以指定缓冲区的大小，或者接受默认的大小。在大多数情况下，默认值就足够大了。

该类提供了 newLine() 方法，它使用平台自己的行分隔符概念，此概念由系统属性 line.separator 定义。并非所有平台都使用新行符 ('\n') 来终止各行。因此调用此方法来终止每个输出行要优于直接写入新行符。

通常 Writer 将其输出立即发送到底层字符或字节流。除非要求提示输出，否则建议用 BufferedWriter 包装所有其 write() 操作可能开销很高的 Writer（如 FileWriters 和 OutputStreamWriters）。例如，

 PrintWriter out
   = new PrintWriter(new BufferedWriter(new FileWriter("foo.out")));
将缓冲 PrintWriter 对文件的输出。如果没有缓冲，则每次调用 print() 方法会导致将字符转换为字节，然后立即写入到文件，而这是极其低效的。

从以下版本开始：
JDK1.1
另请参见：
PrintWriter, FileWriter, OutputStreamWriter

字段摘要
从类 java.io.Writer 继承的字段
lock
构造方法摘要
BufferedWriter(Writer out)
创建一个使用默认大小输出缓冲区的缓冲字符输出流。
BufferedWriter(Writer out, int sz)
创建一个使用给定大小输出缓冲区的新缓冲字符输出流。
方法摘要
void | close() 关闭此流，但要先刷新它。
void | flush() 刷新该流的缓冲。
void | newLine() 写入一个行分隔符。
void | write(char[] cbuf, int off, int len) 写入字符数组的某一部分。
void | write(int c) 写入单个字符。
void | write(String s, int off, int len) 写入字符串的某一部分。
从类 java.io.Writer 继承的方法
append, append, append, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BufferedWriter

public BufferedWriter(Writer out)
创建一个使用默认大小输出缓冲区的缓冲字符输出流。

参数：
out - 一个 Writer

BufferedWriter

public BufferedWriter(Writer out,
                      int sz)
创建一个使用给定大小输出缓冲区的新缓冲字符输出流。

参数：
out - 一个 Writer
sz - 输出缓冲区的大小，是一个正整数
抛出：
IllegalArgumentException - 如果 sz <= 0
方法详细信息

write

public void write(int c)
           throws IOException
写入单个字符。

覆盖：
类 Writer 中的 write
参数：
c - 指定要写入字符的 int。
抛出：
IOException - 如果发生 I/O 错误

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
写入字符数组的某一部分。

一般来说，此方法将给定数组的字符存入此流的缓冲区中，根据需要刷新该缓冲区，并转到底层流。但是，如果请求的长度至少与此缓冲区大小相同，则此方法将刷新该缓冲区并将各个字符直接写入底层流。因此多余的 BufferedWriter 将不必复制数据。

指定者：
类 Writer 中的 write
参数：
cbuf - 字符数组
off - 开始读取字符处的偏移量
len - 要写入的字符数
抛出：
IOException - 如果发生 I/O 错误

write

public void write(String s,
                  int off,
                  int len)
           throws IOException
写入字符串的某一部分。

如果 len 参数的值为负数，则不写入任何字符。这与超类中此方法的规范正好相反，它要求抛出 IndexOutOfBoundsException。

覆盖：
类 Writer 中的 write
参数：
s - 要写入的字符串
off - 开始读取字符处的偏移量
len - 要写入的字符数
抛出：
IOException - 如果发生 I/O 错误

newLine

public void newLine()
             throws IOException
写入一个行分隔符。行分隔符字符串由系统属性 line.separator 定义，并且不一定是单个新行 ('\n') 符。

抛出：
IOException - 如果发生 I/O 错误

flush

public void flush()
           throws IOException
刷新该流的缓冲。

指定者：
接口 Flushable 中的 flush
指定者：
类 Writer 中的 flush
抛出：
IOException - 如果发生 I/O 错误

close

public void close()
           throws IOException
从类 Writer 复制的描述
关闭此流，但要先刷新它。在关闭该流之后，再调用 write() 或 flush() 将导致抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Writer 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ByteArrayInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ByteArrayInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.ByteArrayInputStream
所有已实现的接口：
Closeable
public class ByteArrayInputStream
extends InputStream

ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。内部计数器跟踪 read 方法要提供的下一个字节。

关闭 ByteArrayInputStream 无效。此类中的方法在关闭此流后仍可被调用，而不会产生任何 IOException。

从以下版本开始：
JDK1.0
另请参见：
StringBufferInputStream

字段摘要
protected byte[] | buf 由该流的创建者提供的 byte 数组。
protected int | count 比输入流缓冲区中最后一个有效字符的索引大一的索引。
protected int | mark 流中当前的标记位置。
protected int | pos 要从输入流缓冲区中读取的下一个字符的索引。
构造方法摘要
ByteArrayInputStream(byte[] buf)
创建一个 ByteArrayInputStream，使用 buf 作为其缓冲区数组。
ByteArrayInputStream(byte[] buf, int offset, int length)
创建 ByteArrayInputStream，使用 buf 作为其缓冲区数组。
方法摘要
int | available() 返回可从此输入流读取（或跳过）的剩余字节数。
void | close() 关闭 ByteArrayInputStream 无效。
void | mark(int readAheadLimit) 设置流中的当前标记位置。
boolean | markSupported() 测试此 InputStream 是否支持 mark/reset。
int | read() 从此输入流中读取下一个数据字节。
int | read(byte[] b, int off, int len) 将最多 len 个数据字节从此输入流读入 byte 数组。
void | reset() 将缓冲区的位置重置为标记位置。
long | skip(long n) 从此输入流中跳过 n 个输入字节。
从类 java.io.InputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buf

protected byte[] buf
由该流的创建者提供的 byte 数组。元素 buf[0] 到 buf[count-1] 是只能从流中读取的字节；元素 buf[pos] 是要读取的下一个字节。

pos

protected int pos
要从输入流缓冲区中读取的下一个字符的索引。此值应该始终是非负数，并且不应大于 count 值。从输入流缓冲区中读取的下一个字节是 buf[pos]。

mark

protected int mark
流中当前的标记位置。构造时默认将 ByteArrayInputStream 对象标记在位置零处。通过 mark() 方法可将其标记在缓冲区内的另一个位置处。通过 reset() 方法将当前缓冲区位置设置为此点。

如果尚未设置标记，则标记值是传递给构造方法的偏移量（如果未提供偏移量，则标记值为 0）。

从以下版本开始：
JDK1.1

count

protected int count
比输入流缓冲区中最后一个有效字符的索引大一的索引。此值应该始终是非负数，并且不应大于 buf 的长度。它比 buf 中最后一个可从输入流缓冲区中读取的字节位置大一。

构造方法详细信息

ByteArrayInputStream

public ByteArrayInputStream(byte[] buf)
创建一个 ByteArrayInputStream，使用 buf 作为其缓冲区数组。该缓冲区数组不是复制得到的。pos 的初始值是 0，count 的初始值是 buf 的长度。

参数：
buf - 输入缓冲区。

ByteArrayInputStream

public ByteArrayInputStream(byte[] buf,
                            int offset,
                            int length)
创建 ByteArrayInputStream，使用 buf 作为其缓冲区数组。pos 的初始值是 offset，count 的初始值是 offset+length 和 buf.length 中的最小值。该缓冲区数组不是复制得到的。将该缓冲区的标记设置为指定的偏移量。

参数：
buf - 输入缓冲区。
offset - 缓冲区中要读取的第一个字节的偏移量。
length - 从缓冲区中读取的最大字节数。
方法详细信息

read

public int read()
从此输入流中读取下一个数据字节。返回一个 0 到 255 范围内的 int 字节值。如果因为到达流末尾而没有可用的字节，则返回值 -1。

此 read 方法不会阻塞。

指定者：
类 InputStream 中的 read
返回：
下一个数据字节，如果到达流末尾，则返回 -1。

read

public int read(byte[] b,
                int off,
                int len)
将最多 len 个数据字节从此输入流读入 byte 数组。如果 pos 等于 count，则返回 -1 指示文件结束。否则，读取的字节数 k 等于 len 和 count-pos 中的较小者。如果 k 是正数，则以 System.arraycopy 执行的方式将 buf[pos] 到 buf[pos+k-1] 的字节复制到 b[off] 到 b[off+k-1] 中。将值 k 与 pos 相加并返回 k。

此 read 方法不会阻塞。

覆盖：
类 InputStream 中的 read
参数：
b - 存储读入数据的缓冲区。
off - 目标数组 b 的起始偏移量。
len - 读取的最大字节数。
返回：
读入缓冲区的总字节数，如果由于已到达流末尾而不再有数据，则返回 -1。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，len 为负，或者 len 大于 b.length - off
另请参见：
InputStream.read()

skip

public long skip(long n)
从此输入流中跳过 n 个输入字节。如果已到达输入流末尾，则可能会跳过较少的字节。实际跳过的字节数 k 等于 n 和 count-pos 中的较小者。将值 k 与 pos 相加并返回 k。

覆盖：
类 InputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。

available

public int available()
返回可从此输入流读取（或跳过）的剩余字节数。

返回值是 count - pos，它是要从输入缓冲区中读取的剩余字节数。

覆盖：
类 InputStream 中的 available
返回：
不受阻塞地从此输入流读取（或跳过）的剩余字节数。

markSupported

public boolean markSupported()
测试此 InputStream 是否支持 mark/reset。ByteArrayInputStream 的 markSupported 方法始终返回 true。

覆盖：
类 InputStream 中的 markSupported
返回：
如果此输入流实例支持 mark 和 reset 方法，则返回 true；否则返回 false。
从以下版本开始：
JDK1.1
另请参见：
InputStream.mark(int), InputStream.reset()

mark

public void mark(int readAheadLimit)
设置流中的当前标记位置。构造时默认将 ByteArrayInputStream 对象标记在位置零处。通过此方法可将其标记在缓冲区内的另一个位置处。

如果尚未设置标记，则标记值是传递给构造方法的偏移量（如果未提供偏移量，则标记值为 0）。

注：readAheadLimit 对于此类没有意义。

覆盖：
类 InputStream 中的 mark
参数：
readAheadLimit - 在标记位置失效前可以读取字节的最大限制。
从以下版本开始：
JDK1.1
另请参见：
InputStream.reset()

reset

public void reset()
将缓冲区的位置重置为标记位置。除非已标记了另一个位置，或者在构造方法中指定了一个偏移量，否则该标记位置是 0。

覆盖：
类 InputStream 中的 reset
另请参见：
InputStream.mark(int), IOException

close

public void close()
           throws IOException
关闭 ByteArrayInputStream 无效。此类中的方法在关闭此流后仍可被调用，而不会产生任何 IOException。

指定者：
接口 Closeable 中的 close
覆盖：
类 InputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ByteArrayOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ByteArrayOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.ByteArrayOutputStream
所有已实现的接口：
Closeable, Flushable
public class ByteArrayOutputStream
extends OutputStream

此类实现了一个输出流，其中的数据被写入一个 byte 数组。缓冲区会随着数据的不断写入而自动增长。可使用 toByteArray() 和 toString() 获取数据。

关闭 ByteArrayOutputStream 无效。此类中的方法在关闭此流后仍可被调用，而不会产生任何 IOException。

从以下版本开始：
JDK1.0

字段摘要
protected byte[] | buf 存储数据的缓冲区。
protected int | count 缓冲区中的有效字节数。
构造方法摘要
ByteArrayOutputStream()
创建一个新的 byte 数组输出流。
ByteArrayOutputStream(int size)
创建一个新的 byte 数组输出流，它具有指定大小的缓冲区容量（以字节为单位）。
方法摘要
void | close() 关闭 ByteArrayOutputStream 无效。
void | reset() 将此 byte 数组输出流的 count 字段重置为零，从而丢弃输出流中目前已累积的所有输出。
int | size() 返回缓冲区的当前大小。
byte[] | toByteArray() 创建一个新分配的 byte 数组。
String | toString() 使用平台默认的字符集，通过解码字节将缓冲区内容转换为字符串。
String | toString(int hibyte) 已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。
String | toString(String charsetName) 使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。
void | write(byte[] b, int off, int len) 将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此 byte 数组输出流。
void | write(int b) 将指定的字节写入此 byte 数组输出流。
void | writeTo(OutputStream out) 将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。
从类 java.io.OutputStream 继承的方法
flush, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

buf

protected byte[] buf
存储数据的缓冲区。

count

protected int count
缓冲区中的有效字节数。

构造方法详细信息

ByteArrayOutputStream

public ByteArrayOutputStream()
创建一个新的 byte 数组输出流。缓冲区的容量最初是 32 字节，如有必要可增加其大小。

ByteArrayOutputStream

public ByteArrayOutputStream(int size)
创建一个新的 byte 数组输出流，它具有指定大小的缓冲区容量（以字节为单位）。

参数：
size - 初始大小。
抛出：
IllegalArgumentException - 如果 size 为负。
方法详细信息

write

public void write(int b)
将指定的字节写入此 byte 数组输出流。

指定者：
类 OutputStream 中的 write
参数：
b - 要写入的字节。

write

public void write(byte[] b,
                  int off,
                  int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此 byte 数组输出流。

覆盖：
类 OutputStream 中的 write
参数：
b - 数据。
off - 数据的初始偏移量。
len - 要写入的字节数。

writeTo

public void writeTo(OutputStream out)
             throws IOException
将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。

参数：
out - 要写入数据的输出流。
抛出：
IOException - 如果发生 I/O 错误。

reset

public void reset()
将此 byte 数组输出流的 count 字段重置为零，从而丢弃输出流中目前已累积的所有输出。通过重新使用已分配的缓冲区空间，可以再次使用该输出流。

另请参见：
ByteArrayInputStream.count

toByteArray

public byte[] toByteArray()
创建一个新分配的 byte 数组。其大小是此输出流的当前大小，并且缓冲区的有效内容已复制到该数组中。

返回：
以 byte 数组的形式返回此输出流的当前内容。
另请参见：
size()

size

public int size()
返回缓冲区的当前大小。

返回：
count 字段的值，这是此输出流中有效字节的数目。
另请参见：
count

toString

public String toString()
使用平台默认的字符集，通过解码字节将缓冲区内容转换为字符串。新 String 的长度是字符集的函数，因此可能不等于缓冲区的大小。

此方法总是使用平台默认字符集的默认替代字符串替代错误输入 (malformed-input) 和不可映射字符 (unmappable-character) 序列。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

覆盖：
类 Object 中的 toString
返回：
从缓冲区内容解码的字符串。
从以下版本开始：
JDK1.1

toString

public String toString(String charsetName)
                throws UnsupportedEncodingException
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。新 String 的长度是字符集的函数，因此可能不等于缓冲区的大小。

此方法总是使用平台默认字符集的默认替代字符串替代错误输入 (malformed-input) 和不可映射字符 (unmappable-character) 序列。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

参数：
charsetName - charset 支持的名称
返回：
从缓冲区内容解码的字符串。
抛出：
UnsupportedEncodingException - 如果不支持指定的字符集。
从以下版本开始：
JDK1.1

toString

@Deprecated
public String toString(int hibyte)
已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。

创建一个新分配的字符串。其大小是该输出流的当前大小，并且缓冲区的有效内容已复制到其中。得到的字符串中的每个字符 c 都根据 byte 数组中的相应元素 b 构造，如下所示：
     c == (char)(((hibyte & 0xff) << 8) | (b & 0xff))

参数：
hibyte - 每个结果 Unicode 字符的高次字节。
返回：
以字符串的形式返回输出流的当前内容。
另请参见：
size(), toString(String), toString()

close

public void close()
           throws IOException
关闭 ByteArrayOutputStream 无效。此类中的方法在关闭此流后仍可被调用，而不会产生任何 IOException 时。

指定者：
接口 Closeable 中的 close
覆盖：
类 OutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述  软件包   类  使用  树  已过时  索引  帮助
JavaTM 2 Platform
Standard Ed. 6
 上一个类   下一个类 框架    无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharArrayReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 CharArrayReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.CharArrayReader
所有已实现的接口：
Closeable, Readable
public class CharArrayReader
extends Reader

此类实现一个可用作字符输入流的字符缓冲区。

从以下版本开始：
JDK1.1

字段摘要
protected char[] | buf 字符缓冲区。
protected int | count 此缓冲区结尾处的索引。
protected int | markedPos 缓冲区中标记的位置。
protected int | pos 当前缓冲区位置。
从类 java.io.Reader 继承的字段
lock
构造方法摘要
CharArrayReader(char[] buf)
根据指定的 char 数组创建一个 CharArrayReader。
CharArrayReader(char[] buf, int offset, int length)
根据指定的 char 数组创建一个 CharArrayReader。
方法摘要
 void close()
关闭该流并释放与之关联的所有系统资源。
 void mark(int readAheadLimit)
标记流中的当前位置。
 boolean markSupported()
判断此流是否支持 mark() 操作（它一定支持）。
 int read()
读取单个字符。
 int read(char[] b, int off, int len)
将字符读入数组的某一部分。
 boolean ready()
判断此流是否已准备好被读取。
 void reset()
将该流重置为最新的标记，如果从未标记过，则将其重置到开头。
 long skip(long n)
跳过字符。
从类 java.io.Reader 继承的方法
read, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buf

protected char[] buf
字符缓冲区。

pos

protected int pos
当前缓冲区位置。

markedPos

protected int markedPos
缓冲区中标记的位置。

count

protected int count
此缓冲区结尾处的索引。在此索引及其以后的位置处没有有效数据。

构造方法详细信息

CharArrayReader

public CharArrayReader(char[] buf)
根据指定的 char 数组创建一个 CharArrayReader。

参数：
buf - 输入缓冲区（不是复制得到的）

CharArrayReader

public CharArrayReader(char[] buf,
                       int offset,
                       int length)
根据指定的 char 数组创建一个 CharArrayReader。

得到的 reader 将从给定的 offset 处开始读取。可从此 reader 中读取的 char 值总数是 length 或 buf.length-offset，取其中的较小者。

参数：
buf - 输入缓冲区（不是复制得到的）
offset - 要读取的第一个 char 的偏移量
length - 要读取的 char 数目
抛出：
IllegalArgumentException - 如果 offset 为负或大于 buf.length，或者 length 为负，或者这两个值的和为负。
方法详细信息

read

public int read()
         throws IOException
读取单个字符。

覆盖：
类 Reader 中的 read
返回：
作为整数读取的字符，范围在 0 到 65535 之间 (0x00-0xffff)，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] b,
                int off,
                int len)
         throws IOException
将字符读入数组的某一部分。

指定者：
类 Reader 中的 read
参数：
b - 目标缓冲区
off - 开始存储字符处的偏移量
len - 要读取的最大字符数
返回：
读取的实际字符数；如果到达流末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

skip

public long skip(long n)
          throws IOException
跳过字符。返回跳过的字符数。

n 参数可以为负数，尽管 Reader 超类的 skip 方法在此情况下会抛出一个异常。如果 n 为负数，则此方法不执行任何操作并返回 0。

覆盖：
类 Reader 中的 skip
参数：
n - 要跳过的字符数
返回：
已跳过的实际字符数
抛出：
IOException - 如果流已关闭，或者发生 I/O 错误

ready

public boolean ready()
              throws IOException
判断此流是否已准备好被读取。Character-array reader 总是准备好被读取。

覆盖：
类 Reader 中的 ready
返回：
如果保证下一个 read() 不阻塞输入，则返回 True，否则返回 false。注意，返回 false 并不保证阻塞下一次读取。
抛出：
IOException - 如果发生 I/O 错误

markSupported

public boolean markSupported()
判断此流是否支持 mark() 操作（它一定支持）。

覆盖：
类 Reader 中的 markSupported
返回：
当且仅当此流支持此 mark 操作时，返回 true。

mark

public void mark(int readAheadLimit)
          throws IOException
标记流中的当前位置。对 reset() 的后续调用会将该流重新定位到此点。

覆盖：
类 Reader 中的 mark
参数：
readAheadLimit - 在仍保留该标记的情况下，对可读取字符数量的限制。因为该流的输入来自字符数组，没有实际的限制；所以忽略此参数。
抛出：
IOException - 如果发生 I/O 错误

reset

public void reset()
           throws IOException
将该流重置为最新的标记，如果从未标记过，则将其重置到开头。

覆盖：
类 Reader 中的 reset
抛出：
IOException - 如果发生 I/O 错误

close

public void close()
关闭该流并释放与之关联的所有系统资源。关闭该流后，再调用 read()、ready()、mark()、reset() 或 skip() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Reader 中的 close
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharArrayWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 CharArrayWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.CharArrayWriter
所有已实现的接口：
Closeable, Flushable, Appendable
public class CharArrayWriter
extends Writer

此类实现一个可用作 Writer 的字符缓冲区。缓冲区会随向流中写入数据而自动增长。可使用 toCharArray() 和 toString() 获取数据。

注：在此类上调用 close() 无效，并且在关闭该流后可以调用此类中的各个方法，而不会产生任何 IOException。

从以下版本开始：
JDK1.1

字段摘要
protected char[] | buf 存储数据的缓冲区。
protected int | count 缓冲区中的 char 数目。
从类 java.io.Writer 继承的字段
lock
构造方法摘要
CharArrayWriter()
创建一个新的 CharArrayWriter。
CharArrayWriter(int initialSize)
创建一个具有指定初始大小的新 CharArrayWriter。
方法摘要
CharArrayWriter | append(char c) 将指定字符添加到此 writer。
CharArrayWriter | append(CharSequence csq) 将指定的字符序列添加到此 writer。
CharArrayWriter | append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
void | close() 关闭该流。
void | flush() 刷新该流的缓冲。
void | reset() 重置该缓冲区，以便再次使用它而无需丢弃已分配的缓冲区。
int | size() 返回缓冲区的当前大小。
char[] | toCharArray() 返回输入数据的副本。
String | toString() 将输入数据转换为字符串。
void | write(char[] c, int off, int len) 将字符写入缓冲区。
void | write(int c) 将一个字符写入缓冲区。
void | write(String str, int off, int len) 将字符串的某一部分写入缓冲区。
void | writeTo(Writer out) 将缓冲区的内容写入另一个字符流。
从类 java.io.Writer 继承的方法
write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

buf

protected char[] buf
存储数据的缓冲区。

count

protected int count
缓冲区中的 char 数目。

构造方法详细信息

CharArrayWriter

public CharArrayWriter()
创建一个新的 CharArrayWriter。

CharArrayWriter

public CharArrayWriter(int initialSize)
创建一个具有指定初始大小的新 CharArrayWriter。

参数：
initialSize - 一个指定缓冲区初始大小的 int。
抛出：
IllegalArgumentException - 如果 initialSize 为负。
方法详细信息

write

public void write(int c)
将一个字符写入缓冲区。

覆盖：
类 Writer 中的 write
参数：
c - 指定要写入字符的 int。

write

public void write(char[] c,
                  int off,
                  int len)
将字符写入缓冲区。

指定者：
类 Writer 中的 write
参数：
c - 要写入的数据
off - 数据中的起始偏移量
len - 写入的 char 数目

write

public void write(String str,
                  int off,
                  int len)
将字符串的某一部分写入缓冲区。

覆盖：
类 Writer 中的 write
参数：
str - 要写入的字符串
off - 开始读取字符处的偏移量
len - 要写入的字符数

writeTo

public void writeTo(Writer out)
             throws IOException
将缓冲区的内容写入另一个字符流。

参数：
out - 要写入的输出流
抛出：
IOException - 如果发生 I/O 错误。

append

public CharArrayWriter append(CharSequence csq)
将指定的字符序列添加到此 writer。

以 out.append(csq) 形式调用此方法与以下调用具有完全相同的行为：

out.write(csq.toString())

可能不会添加整个序列，这取决于针对字符序列 csq 的 toString 规范。例如，调用一个字符缓冲区的 toString 方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
csq - 要添加的字符序列。如果 csq 为 null，则向此 writer 添加四个字符 "null"。
返回：
此 writer
从以下版本开始：
1.5

append

public CharArrayWriter append(CharSequence csq,
                              int start,
                              int end)
将指定字符序列的子序列添加到此 writer。

当 csq 不为 null 时，以 out.append(csq, start, end) 形式调用此方法与以下调用具有完全相同的行为：

     out.write(csq.subSequence(start, end).toString())

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
csq - 其子序列将被添加的字符序列。如果 csq 为 null，则添加四个字符 "null"，就好像 csq 包含这些字符一样。
start - 子序列中第一个字符的索引
end - 子序列中最后一个字符后面的字符的索引
返回：
此 writer
抛出：
IndexOutOfBoundsException - 如果 start 或 end 为负，start 大于 end 或者 end 大于 csq.length()
从以下版本开始：
1.5

append

public CharArrayWriter append(char c)
将指定字符添加到此 writer。

以 out.append(c) 形式调用此方法与以下调用具有完全相同的行为：

     out.write(c)

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
c - 要添加的 16 位字符
返回：
此 writer
从以下版本开始：
1.5

reset

public void reset()
重置该缓冲区，以便再次使用它而无需丢弃已分配的缓冲区。

toCharArray

public char[] toCharArray()
返回输入数据的副本。

返回：
复制输入数据所得到的 char 数组。

size

public int size()
返回缓冲区的当前大小。

返回：
表示缓冲区当前大小的 int 值。

toString

public String toString()
将输入数据转换为字符串。

覆盖：
类 Object 中的 toString
返回：
字符串。

flush

public void flush()
刷新该流的缓冲。

指定者：
接口 Flushable 中的 flush
指定者：
类 Writer 中的 flush

close

public void close()
关闭该流。此方法并不释放缓冲区，因为仍然可能需要其内容。注：在此类中调用此方法无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Writer 中的 close
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharConversionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 CharConversionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.CharConversionException
所有已实现的接口：
Serializable
public class CharConversionException
extends IOException

用于字符转换异常的基类。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
CharConversionException()
此异常不提供详细消息。
CharConversionException(String s)
此异常提供详细消息。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CharConversionException

public CharConversionException()
此异常不提供详细消息。

CharConversionException

public CharConversionException(String s)
此异常提供详细消息。

参数：
s - 与该异常关联的详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Closeable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 Closeable

所有已知子接口：
ByteChannel, Channel, GatheringByteChannel, InterruptibleChannel, JavaFileManager, JMXConnector, ReadableByteChannel, RMIConnection, ScatteringByteChannel, StandardJavaFileManager, WritableByteChannel
所有已知实现类：
AbstractInterruptibleChannel, AbstractSelectableChannel, AudioInputStream, BufferedInputStream, BufferedOutputStream, BufferedReader, BufferedWriter, ByteArrayInputStream, ByteArrayOutputStream, CharArrayReader, CharArrayWriter, CheckedInputStream, CheckedOutputStream, CipherInputStream, CipherOutputStream, DatagramChannel, DataInputStream, DataOutputStream, DeflaterInputStream, DeflaterOutputStream, DigestInputStream, DigestOutputStream, FileChannel, FileInputStream, FileOutputStream, FileReader, FileWriter, FilterInputStream, FilterOutputStream, FilterReader, FilterWriter, Formatter, ForwardingJavaFileManager, GZIPInputStream, GZIPOutputStream, InflaterInputStream, InflaterOutputStream, InputStream, InputStream, InputStream, InputStreamReader, JarInputStream, JarOutputStream, LineNumberInputStream, LineNumberReader, LogStream, ObjectInputStream, ObjectOutputStream, OutputStream, OutputStream, OutputStream, OutputStreamWriter, Pipe.SinkChannel, Pipe.SourceChannel, PipedInputStream, PipedOutputStream, PipedReader, PipedWriter, PrintStream, PrintWriter, ProgressMonitorInputStream, PushbackInputStream, PushbackReader, RandomAccessFile, Reader, RMIConnectionImpl, RMIConnectionImpl_Stub, RMIConnector, RMIIIOPServerImpl, RMIJRMPServerImpl, RMIServerImpl, SelectableChannel, SequenceInputStream, ServerSocketChannel, SocketChannel, StringBufferInputStream, StringReader, StringWriter, Writer, ZipInputStream, ZipOutputStream
public interface Closeable

Closeable 是可以关闭的数据源或目标。调用 close 方法可释放对象保存的资源（如打开文件）。

从以下版本开始：
1.5

方法摘要
 void close()
关闭此流并释放与此流关联的所有系统资源。

方法详细信息

close

void close()
           throws IOException
关闭此流并释放与此流关联的所有系统资源。如果已经关闭该流，则调用此方法无效。

抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Console (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 Console

java.lang.Object
    继承者  java.io.Console
所有已实现的接口：
Flushable
public final class Console
extends Object
implements Flushable

此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。

虚拟机是否具有控制台取决于底层平台，还取决于调用虚拟机的方式。如果虚拟机从一个交互式命令行开始启动，且没有重定向标准输入和输出流，那么其控制台将存在，并且通常连接到键盘并从虚拟机启动的地方显示。如果虚拟机是自动启动的（例如，由后台作业调度程序启动），那么它通常没有控制台。

如果此虚拟机具有控制台，那么它将由此类唯一的实例（可通过调用 System.console() 方法获得）表示。如果没有可用的控制台设备，那么对该方法的调用将返回 null。

读写操作是同步的，以保证关键操作能完整地完成；因此调用方法 readLine()、readPassword()、format()、printf() 以及对 reader() 和 writer() 返回对象的读取、格式化和写入操作在多线程情况下可能阻塞。

在 reader() 和 writer() 返回的对象上调用 close() 不会关闭这些对象的底层流。

在到达控制台输入流的尾部时，如键入 control-D (Unix) 或键入 control-Z (Windows)，读取控制台的方法将返回 null。如果之后在控制台输入设备上输入了其他字符，则后续读取操作将成功执行。

除非另行指定，否则将 null 参数传递给此类中的任何方法都会抛出 NullPointerException。

安全注释： 如果应用程序需要读取密码或其他安全数据，则它应该使用 readPassword() 或 readPassword(String, Object...)，并在执行后手工将返回的字符数组归零，以最大限度地缩短内存中敏感数据的生存期。

Console cons;
char[] passwd;
if ((cons = System.console()) != null &&
(passwd = cons.readPassword("[%s]", "Password:"))!= null) {
     ...
java.util.Arrays.fill(passwd, ' ');
 }

从以下版本开始：
1.6

方法摘要
void | flush() 刷新控制台，并强制立即写入所有缓冲的输出。
Console | format(String fmt, Object... args) 使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。
Console | printf(String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。
Reader | reader() 获取与此控制台关联的唯一 Reader 对象。
String | readLine() 从控制台读取单行文本。
String | readLine(String fmt, Object... args) 提供一个格式化提示，然后从控制台读取单行文本。
char[] | readPassword() 从控制台读取密码，禁用回显。
char[] | readPassword(String fmt, Object... args) 提供一个格式化提示，然后从控制台读取密码，禁用回显。
PrintWriter | writer() 获取与此控制台关联的唯一 PrintWriter 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

writer

public PrintWriter writer()
获取与此控制台关联的唯一 PrintWriter 对象。

返回：
与此控制台关联的 Printwriter

reader

public Reader reader()
获取与此控制台关联的唯一 Reader 对象。

此方法仅供复杂应用程序（例如，利用 Scanner 提供的丰富分析／扫描功能的 Scanner 对象）使用：

Console con = System.console();
if (con != null) {
Scanner sc = new Scanner(con.reader());
     ...
 }

对于只需按行读取的简单应用程序，使用 readLine(java.lang.String, java.lang.Object...)。

每次调用时，对返回对象的批量读取操作 read(char[]) 、read(char[], int, int) 和 read(java.nio.CharBuffer) 不会读入行边界之外的字符，即使目标缓冲区还有可容纳更多字符的空间。下列字符之一被认为是行边界：换行 ('\n')、回车 ('\r')、回车后紧跟换行，或者流末尾。

返回：
与此控制台关联的 reader

format

public Console format(String fmt,
                      Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。

参数：
fmt - 格式字符串语法中描述的格式字符串
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java 虚拟机规范定义的 Java 数组最大维数的限制。null 参数的行为取决于转换。
返回：
此控制台
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。

printf

public Console printf(String format,
                      Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。

此方法 con.printf(format, args) 形式的调用与以下调用的行为完全相同：

con.format(format, args)
.

参数：
format - 格式字符串语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java 虚拟机规范定义的 Java 数组最大维数的限制。null 参数的行为取决于转换。
返回：
此控制台
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。

readLine

public String readLine(String fmt,
                       Object... args)
提供一个格式化提示，然后从控制台读取单行文本。

参数：
fmt - 格式字符串语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的最大数量受到 Java 虚拟机规范定义的 Java 数组最大维数的限制。
返回：
包含从控制台读取的行的字符串，该字符串不包含任何行终止符；如果已到达流的末尾，则返回 null。
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
IOError - 如果发生 I/O 错误。

readLine

public String readLine()
从控制台读取单行文本。

返回：
包含从控制台读取的行的字符串，该字符串不包含任何行终止符；如果已到达流的末尾，则返回 null。
抛出：
IOError - 如果发生 I/O 错误。

readPassword

public char[] readPassword(String fmt,
                           Object... args)
提供一个格式化提示，然后从控制台读取密码，禁用回显。

参数：
fmt - 提示文本的格式字符串语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的最大数量受到 Java 虚拟机规范定义的 Java 数组最大维数的限制。
返回：
包含从控制台读取的密码的字符数组，该字符数组不包含任何行终止符；如果已到达流的末尾，则返回 null。
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
IOError - 如果发生 I/O 错误。

readPassword

public char[] readPassword()
从控制台读取密码，禁用回显。

返回：
包含从控制台读取的密码的字符数组，该字符数组不包含任何行终止符；如果已到达流的末尾，则返回 null。
抛出：
IOError - 如果发生 I/O 错误。

flush

public void flush()
刷新控制台，并强制立即写入所有缓冲的输出。

指定者：
接口 Flushable 中的 flush
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataInput (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 DataInput

所有已知子接口：
ImageInputStream, ImageOutputStream, ObjectInput
所有已知实现类：
DataInputStream, FileCacheImageInputStream, FileCacheImageOutputStream, FileImageInputStream, FileImageOutputStream, ImageInputStreamImpl, ImageOutputStreamImpl, MemoryCacheImageInputStream, MemoryCacheImageOutputStream, ObjectInputStream, RandomAccessFile
public interface DataInput

DataInput 接口用于从二进制流中读取字节，并根据所有 Java 基本类型数据进行重构。同时还提供根据 UTF-8 修改版格式的数据重构 String 的工具。

对于此接口中的所有数据读取例程来说，如果在读取所需字节数之前已经到达文件末尾 (end of file)，则将抛出 EOFException（IOException 的一种）。如果因为到达文件末尾以外的其他原因无法读取字节，则将抛出 IOException 而不是 EOFException。尤其是，在输入流已关闭的情况下，将抛出 IOException。

UTF-8 修改版

DataInput 和 DataOutput 接口的实现表示稍作改版的 UTF-8 格式的 Unicode 字符串。（关于标准 UTF-8 格式的信息，请参阅 The Unicode Standard, Version 4.0 的 3.9 Unicode Encoding Forms 节）。注意，在下表中，最高有效位显示在最左边的列中。

'\u0001' 到 '\u007F' 范围内的所有字符都是用单个字节表示的：

位值
字节 1
0
位 6-0

null 字符 '\u0000' 以及从 '\u0080' 到 '\u07FF' 的范围内的字符用两个字节表示：

位值
字节 1
1
1
0
位 10-6
字节 2
1
0
位 5-0

'\u0800' 到 '\uFFFF' 范围内的 char 值用三个字节表示：
位值
字节 1
1
1
1
0
位 15-12
字节 2
1
0
位 11-6
字节 3
1
0
位 5-0

这种格式与标准 UTF-8 格式之间的不同如下：

  • null 字节 '\u0000' 是用 2-byte 格式而不是 1-byte 格式编码的，因此已编码的字符串中决不会有嵌入的 null。
  • 仅使用 1-byte、2-byte 和 3-byte 格式。
  • 增补字符是以代理项对的形式表示的。

从以下版本开始：
JDK1.0
另请参见：
DataInputStream, DataOutput

方法摘要
boolean | readBoolean() 读取一个输入字节，如果该字节不是零，则返回 true，如果是零，则返回 false。
byte | readByte() 读取并返回一个输入字节。
char | readChar() 读取两个输入字节并返回一个 char 值。
double | readDouble() 读取八个输入字节并返回一个 double 值。
float | readFloat() 读取四个输入字节并返回一个 float 值。
void | readFully(byte[] b) 从输入流中读取一些字节，并将它们存储在缓冲区数组 b 中。
void | readFully(byte[] b, int off, int len) 从输入流中读取 len 个字节。
int | readInt() 读取四个输入字节并返回一个 int 值。
String | readLine() 从输入流中读取下一文本行。
long | readLong() 读取八个输入字节并返回一个 long 值。
short | readShort() 读取两个输入字节并返回一个 short 值。
int | readUnsignedByte() 读取一个输入字节，将它左侧补零 (zero-extend) 转变为 int 类型，并返回结果，所以结果的范围是 0 到 255。
int | readUnsignedShort() 读取两个输入字节，并返回 0 到 65535 范围内的一个 int 值。
String | readUTF() 读入一个已使用 UTF-8 修改版格式编码的字符串。
int | skipBytes(int n) 试图在输入流中跳过数据的 n 个字节，并丢弃跳过的字节。

方法详细信息

readFully

void readFully(byte[] b)
               throws IOException
从输入流中读取一些字节，并将它们存储在缓冲区数组 b 中。读取的字节数等于 b 的长度。

在出现以下条件之一以前，此方法将一直阻塞：

  • 输入数据的 b.length 个字节是可用的，在这种情况下，正常返回。
  • 检测到文件末尾，在这种情况下，抛出 EOFException。
  • 发生 I/O 错误，在这种情况下，将抛出 IOException，而不是 EOFException。

如果 b 为 null，则抛出 NullPointerException。如果 b.length 为零，则不读取字节。否则，将读取的第一个字节存储到元素 b[0] 中，下一个字节存储到 b[1] 中，依此类推。如果此方法抛出异常，则可能是因为已经用输入流中的数据更新了 b 的某些（但非全部）字节。

参数：
b - 存储读取数据的缓冲区。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(byte[] b,
               int off,
               int len)
               throws IOException
从输入流中读取 len 个字节。

在出现以下条件之一以前，此方法将一直阻塞：

  • 输入数据的 len 个字节是可用的，在这种情况下，正常返回。
  • 检测到文件末尾，在这种情况下，抛出 EOFException。
  • 如果发生 I/O 错误，在这种情况下，将抛出 IOException，而不是 EOFException。

如果 b 为 null，则抛出 NullPointerException。如果 off 为负，或 len 为负，或者 off+len 大于数组 b 的长度，则抛出 IndexOutOfBoundsException。如果 len 为零，则不读取字节。否则，将读取的第一个字节存储到元素 b[off] 中，下一个字节存储到 b[off+1] 中，依此类推。读取的字节数至多等于 b[0]。

参数：
b - 存储读取数据的缓冲区。
off - 指定数据中的偏移量的 int 值。
len - 指定读取的字节数的 int 值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

skipBytes

int skipBytes(int n)
              throws IOException
试图在输入流中跳过数据的 n 个字节，并丢弃跳过的字节。不过，可以跳过更少的字节数，该字节数甚至可以为零。这可能由很多情况引起；在已经跳过 n 个字节前到达文件末尾只是其中的一种可能。此方法从不抛出 EOFException。返回实际跳过的字节数。

参数：
n - 要跳过的字节数。
返回：
实际跳过的字节数。
抛出：
IOException - 如果发生 I/O 错误。

readBoolean

boolean readBoolean()
                    throws IOException
读取一个输入字节，如果该字节不是零，则返回 true，如果是零，则返回 false。此方法适用于读取用接口 DataOutput 的 writeBoolean 方法写入的字节。

返回：
读取的 boolean 值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readByte

byte readByte()
              throws IOException
读取并返回一个输入字节。该字节被看作是 -128 到 127（包含）范围内的一个有符号值。此方法适用于读取用接口 DataOutput 的 writeByte 方法写入的字节。

返回：
读取的 8 位值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readUnsignedByte

int readUnsignedByte()
                     throws IOException
读取一个输入字节，将它左侧补零 (zero-extend) 转变为 int 类型，并返回结果，所以结果的范围是 0 到 255。如果接口 DataOutput 的 writeByte 方法的参数是 0 到 255 之间的值，则此方法适用于读取用 writeByte 写入的字节。

返回：
读取的无符号 8 位值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readShort

short readShort()
                throws IOException
读取两个输入字节并返回一个 short 值。设 a 为第一个读取字节，b 为第二个读取字节。返回的值是：

(short)((a << 8) | (b & 0xff))
此方法适用于读取用接口 DataOutput 的 writeShort 方法写入的字节。

返回：
读取的 16 位值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readUnsignedShort

int readUnsignedShort()
                      throws IOException
读取两个输入字节，并返回 0 到 65535 范围内的一个 int 值。设 a 为第一个读取字节，b 为第二个读取字节。返回的值是：

(((a & 0xff) << 8) | (b & 0xff))
如果接口 DataOutput 的 writeShort 方法的参数是 0 到 65535 范围内的值，则此方法适用于读取用 writeShort 写入的字节。

返回：
读取的无符号 16 位值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readChar

char readChar()
              throws IOException
读取两个输入字节并返回一个 char 值。设 a 为第一个读取字节，b 为第二个读取字节。返回的值是：

(char)((a << 8) | (b & 0xff))
此方法适用于读取用接口 DataOutput 的 writeChar 方法写入的字节。

返回：
读取的 char 值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readInt

int readInt()
            throws IOException
读取四个输入字节并返回一个 int 值。设 a-d 为四个读取字节中的第一个字节。返回的值是：

 (((a & 0xff) << 24) | ((b & 0xff) << 16) |
  ((c & 0xff) << 8) | (d & 0xff))
此方法适用于读取用接口 DataOutput 的 writeInt 方法写入的字节。

返回：
读取的 int 值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readLong

long readLong()
              throws IOException
读取八个输入字节并返回一个 long 值。设 a-h 为八个读取字节中的第一个字节。返回的值是：

 (((long)(a & 0xff) << 56) |
  ((long)(b & 0xff) << 48) |
  ((long)(c & 0xff) << 40) |
  ((long)(d & 0xff) << 32) |
  ((long)(e & 0xff) << 24) |
  ((long)(f & 0xff) << 16) |
  ((long)(g & 0xff) <<  8) |
  ((long)(h & 0xff)))

此方法适用于读取用接口 DataOutput 的 writeLong 方法写入的字节。

返回：
读取的 long 值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFloat

float readFloat()
                throws IOException
读取四个输入字节并返回一个 float 值。实现这一点的方法是：先使用与 readInt 方法完全相同的方式构造一个 int 值，然后使用与 Float.intBitsToFloat 方法完全相同的方式将此 int 值转换成一个 float 值。此方法适用于读取用接口 DataOutput 的 writeFloat 方法写入的字节。

返回：
读取的 float 值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readDouble

double readDouble()
                  throws IOException
读取八个输入字节并返回一个 double 值。实现这一点的方法是：先使用与 readlong 方法完全相同的方式构造一个 long 值，然后使用与 Double.longBitsToDouble 方法完全相同的方式将此 long 值转换成一个 double 值。此方法适用于读取用接口 DataOutput 的 writeDouble 方法写入的字节。

返回：
读取的 double 值。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readLine

String readLine()
                throws IOException
从输入流中读取下一文本行。该方法读取连续的字节，将每个字节分别转换成一个字符，直到遇到行结尾符或到达末尾；然后以 String 形式返回读取的字符。注意，因为此方法用于处理字符，所以它不支持整个 Unicode 字符集的输入。

如果在一个字节都没有读取的时候就到达文件末尾，则返回 null。否则，通过左侧补零将读取的每个字节转换成 char 类型的值。如果遇到字符 '\n'，则丢弃它并且停止读取。如果遇到字符 '\r' 则丢弃它，如果后续字节转变成字符 '\n'，则同样丢弃它并停止读取。如果在遇到字符 '\n' 和 '\r' 之一前到达文件末尾，则停止读取。一旦已停止读取，则返回一个 String，它按顺序包含所有已读取且未丢弃的字符。注意，此字符串中的每个字符的值都将小于 \u0100（即 (char)256）的值。

返回：
输入流中文本的下一行，如果还没有读取一个字节就到达文件末尾，则返回 null。
抛出：
IOException - 如果发生 I/O 错误。

readUTF

String readUTF()
               throws IOException
读入一个已使用 UTF-8 修改版格式编码的字符串。readUTF 的常规协定是：该方法读取使用 UTF-8 修改版格式编码的 Unicode 字符串的表示形式；然后以 String 的形式返回此字符串。

首先读取两个字节，并使用它们构造一个无符号 16 位整数，构造方式与 readUnsignedShort 方法的方式完全相同。该整数值被称为 UTF 长度，它指定要读取的额外字节数。然后成组地将这些字节转换为字符。每组的长度根据该组第一个字节的值计算。紧跟在某个组后面的字节（如果有）是下一组的第一个字节。

如果组的第一个字节与位模式 0xxxxxxx（其中 x 表示“可能为 0 或 1”）匹配，则该组只有这一个字节。该字节被左侧补零，转换成一个字符。

如果组的第一个字节与位模式 110xxxxx 匹配，则该组只由字节 a 和另一个字节 b 组成。如果没有字节 b（因为字节 a 是要读取的最后一个字节），或者字节 b 与位模式 10xxxxxx 不匹配，则抛出 UTFDataFormatException。否则，将该组转换成字符：

(char)(((a& 0x1F) << 6) | (b & 0x3F))
如果组的第一个字节与位模式 1110xxxx 匹配，则该组由字节 a 和另外两个字节 b 和 c 组成。如果没有字节 c（因为字节 a 是要读取的最后两个字节之一），或者字节 b 或字节 c 与位模式 10xxxxxx 不匹配，则抛出 UTFDataFormatException。否则，将该组转换成字符：

 (char)(((a & 0x0F) << 12) | ((b & 0x3F) << 6) | (c & 0x3F))
如果组的第一个字节与模式 1111xxxx 或模式 10xxxxxx 匹配，则抛出 UTFDataFormatException。

如果在执行整个过程中的任意时间到达文件末尾，则抛出 EOFException。

在通过此过程将每个组转换成字符后，按照从输入流中读取相应组的顺序，将这些字符收集在一起，形成一个 String，然后该字符串将被返回。

可以使用 DataOutput 接口的 writeUTF 方法写入适合此方法读取的数据。

返回：
一个 Unicode 字符串。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
UTFDataFormatException - 如果这些字节不表示一个有效的、UTF-8 修改版编码的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 DataInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.io.DataInputStream
所有已实现的接口：
Closeable, DataInput
public class DataInputStream
extends FilterInputStream
implements DataInput

数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。应用程序可以使用数据输出流写入稍后由数据输入流读取的数据。

DataInputStream 对于多线程访问不一定是安全的。 线程安全是可选的，它由此类方法的使用者负责。

从以下版本开始：
JDK1.0
另请参见：
DataOutputStream

字段摘要
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
DataInputStream(InputStream in)
使用指定的底层 InputStream 创建一个 DataInputStream。
方法摘要
 int read(byte[] b)
从包含的输入流中读取一定数量的字节，并将它们存储到缓冲区数组 b 中。
 int read(byte[] b, int off, int len)
从包含的输入流中将最多 len 个字节读入一个 byte 数组中。
 boolean readBoolean()
参见 DataInput 的 readBoolean 方法的常规协定。
 byte readByte()
参见 DataInput 的 readByte 方法的常规协定。
 char readChar()
参见 DataInput 的 readChar 方法的常规协定。
 double readDouble()
参见 DataInput 的 readDouble 方法的常规协定。
 float readFloat()
参见 DataInput 的 readFloat 方法的常规协定。
 void readFully(byte[] b)
参见 DataInput 的 readFully 方法的常规协定。
 void readFully(byte[] b, int off, int len)
参见 DataInput 的 readFully 方法的常规协定。
 int readInt()
参见 DataInput 的 readInt 方法的常规协定。
 String readLine()
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
 long readLong()
参见 DataInput 的 readLong 方法的常规协定。
 short readShort()
参见 DataInput 的 readShort 方法的常规协定。
 int readUnsignedByte()
参见 DataInput 的 readUnsignedByte 方法的常规协定。
 int readUnsignedShort()
参见 DataInput 的 readUnsignedShort 方法的常规协定。
 String readUTF()
参见 DataInput 的 readUTF 方法的常规协定。
static String readUTF(DataInput in)
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。
 int skipBytes(int n)
参见 DataInput 的 skipBytes 方法的常规协定。
从类 java.io.FilterInputStream 继承的方法
available, close, mark, markSupported, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataInputStream

public DataInputStream(InputStream in)
使用指定的底层 InputStream 创建一个 DataInputStream。

参数：
in - 指定输入流
方法详细信息

read

public final int read(byte[] b)
               throws IOException
从包含的输入流中读取一定数量的字节，并将它们存储到缓冲区数组 b 中。以整数形式返回实际读取的字节数。在输入数据可用、检测到文件末尾 (end of file) 或抛出异常之前，此方法将一直阻塞。

如果 b 为 null，则抛出 NullPointerException。如果 b 的长度为 0，则不读取字节并返回 0；否则，尝试读取至少一个字节。如果因为流位于文件末尾而没有字节可用，则返回值 -1；否则至少读取一个字节并将其存储到 b 中。

将读取的第一个字节存储到元素 b[0] 中，将下一个字节存储到 b[1] 中，依此类推。读取的字节数至多等于 b 的长度。设 k 为实际读取的字节数；这些字节将存储在从 b[0] 到 b[k-1] 的元素中，b[k] 到 b[b.length-1] 的元素不受影响。

read(b) 方法与以下方法的效果相同：

 read(b, 0, b.length)

覆盖：
类 FilterInputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
返回：
读入缓冲区的字节总数；如果因为已经到达流末尾而没有更多的数据，则返回 -1。
抛出：
IOException - 如果不是因为流位于文件末尾而无法读取第一个字节；该流已关闭并且底层输入流在关闭后不支持读取操作；发生其他 I/O 错误。
另请参见：
FilterInputStream.in, InputStream.read(byte[], int, int)

read

public final int read(byte[] b,
                      int off,
                      int len)
               throws IOException
从包含的输入流中将最多 len 个字节读入一个 byte 数组中。尽量读取 len 个字节，但读取的字节数可能少于 len 个，也可能为零。以整数形式返回实际读取的字节数。

在输入数据可用、检测到文件末尾或抛出异常之前，此方法将阻塞。

如果 len 为零，则不读取任何字节并返回 0；否则，尝试读取至少一个字节。如果因为流位于文件未尾而没有字节可用，则返回值 -1；否则，至少读取一个字节并将其存储到 b 中。

将读取的第一个字节存储到元素 b[off] 中，将下一个字节存储到 b[off+1] 中，依此类推。读取的字节数至多等于 len。设 k 为实际读取的字节数；这些字节将存储在 b[off] 到 b[off+k-1] 的元素中，b[off+k] 到 b[off+len-1] 的元素不受影响。

在所有情况下，b[0] 到 b[off] 的元素和 b[off+len] 到 b[b.length-1] 的元素都不受影响。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
off - 目标数组 b 中的起始偏移量
len - 读取的最大字节数。
返回：
读入缓冲区的字节总数；如果因为已经到达流末尾而没有更多的数据，则返回 -1。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，len 为负，或者 len 大于 b.length - off
IOException - 如果不是因为流位于文件末尾而无法读取第一个字节；该流已关闭并且底层输入流在关闭后不支持读取操作；发生其他 I/O 错误。
另请参见：
FilterInputStream.in, InputStream.read(byte[], int, int)

readFully

public final void readFully(byte[] b)
                     throws IOException
参见 DataInput 的 readFully 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readFully
参数：
b - 存储读取数据的缓冲区。
抛出：
EOFException - 如果此输入流在读取所有字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readFully

public final void readFully(byte[] b,
                            int off,
                            int len)
                     throws IOException
参见 DataInput 的 readFully 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readFully
参数：
b - 存储读取数据的缓冲区。
off - 数据的起始偏移量。
len - 要读取的字节数。
抛出：
EOFException - 如果此输入流在读取所有字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

skipBytes

public final int skipBytes(int n)
                    throws IOException
参见 DataInput 的 skipBytes 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 skipBytes
参数：
n - 要跳过的字节数。
返回：
实际跳过的字节数。
抛出：
IOException - 如果包含的输入流不支持查找操作；该流已关闭并且包含的输入流在关闭后不支持读取操作；发生其他 I/O 错误。

readBoolean

public final boolean readBoolean()
                          throws IOException
参见 DataInput 的 readBoolean 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readBoolean
返回：
读取的 boolean 值。
抛出：
EOFException - 如果此输入流已经到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生另其他 I/O 错误。
另请参见：
FilterInputStream.in

readByte

public final byte readByte()
                    throws IOException
参见 DataInput 的 readByte 方法的常规协定。

从所包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readByte
返回：
此输入流的下一个字节，以有符号 8 位 byte 的形式表示。
抛出：
EOFException - 如果此输入流已经到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readUnsignedByte

public final int readUnsignedByte()
                           throws IOException
参见 DataInput 的 readUnsignedByte 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readUnsignedByte
返回：
此输入流的下一个字节，将它解释为一个无符号 8 位数。
抛出：
EOFException - 如果此输入流已经到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readShort

public final short readShort()
                      throws IOException
参见 DataInput 的 readShort 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readShort
返回：
此输入流的下两个字节，将它们解释为一个有符号 16 位数。
抛出：
EOFException - 如果此输入流在读取这两个字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readUnsignedShort

public final int readUnsignedShort()
                            throws IOException
参见 DataInput 的 readUnsignedShort 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readUnsignedShort
返回：
此输入流的下两个字节，将它们解释为一个无符号 16 位整数。
抛出：
EOFException - 如果此输入流在读取这两个字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readChar

public final char readChar()
                    throws IOException
参见 DataInput 的 readChar 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readChar
返回：
此输入流的下两个字节，将它们解释为一个 char。
抛出：
EOFException - 如果此输入流在读取这两个字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readInt

public final int readInt()
                  throws IOException
参见 DataInput 的 readInt 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readInt
返回：
此输入流的下四个字节，将它们解释为一个 int。
抛出：
EOFException - 如果此输入流在读取这四个字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readLong

public final long readLong()
                    throws IOException
参见 DataInput 的 readLong 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readLong
返回：
此输入流的下八个字节，将它们解释为一个 long。
抛出：
EOFException - 如果此输入流在读取这八个字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
FilterInputStream.in

readFloat

public final float readFloat()
                      throws IOException
参见 DataInput 的 readFloat 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readFloat
返回：
此输入流的下四个字节，将它们解释为一个 float。
抛出：
EOFException - 如果此输入流在读取这四个字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
readInt(), Float.intBitsToFloat(int)

readDouble

public final double readDouble()
                        throws IOException
参见 DataInput 的 readDouble 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readDouble
返回：
此输入流的下八个字节，将它们解释为一个 double。
抛出：
EOFException - 如果此输入流在读取这八个字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
另请参见：
readLong(), Double.longBitsToDouble(long)

readLine

@Deprecated
public final String readLine()
                      throws IOException
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));

参见 DataInput 的 readLine 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readLine
返回：
此输入流中的下一文本行。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
BufferedReader.readLine(), FilterInputStream.in

readUTF

public final String readUTF()
                     throws IOException
参见 DataInput 的 readUTF 方法的常规协定。

从包含的输入流中读取此操作需要的字节。

指定者：
接口 DataInput 中的 readUTF
返回：
一个 Unicode 字符串。
抛出：
EOFException - 如果此输入流在读取所有字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
UTFDataFormatException - 如果这些字节不表示一个有效的、UTF-8 修改版编码的字符串。
另请参见：
readUTF(java.io.DataInput)

readUTF

public static final String readUTF(DataInput in)
                            throws IOException
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。UTF-8 修改版表示形式的一些细节与 DataInput 的 readUTF 方法完全相同。

参数：
in - 数据输入流。
返回：
一个 Unicode 字符串。
抛出：
EOFException - 如果此输入流在读取所有字节之前到达末尾。
IOException - 该流已关闭并且包含的输入流在关闭后不支持读取操作，或者发生其他 I/O 错误。
UTFDataFormatException - 如果这些字节不表示一个有效的、UTF-8 修改版编码的 Unicode 字符串。
另请参见：
readUnsignedShort()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataOutput (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 DataOutput

所有已知子接口：
ImageOutputStream, ObjectOutput
所有已知实现类：
DataOutputStream, FileCacheImageOutputStream, FileImageOutputStream, ImageOutputStreamImpl, MemoryCacheImageOutputStream, ObjectOutputStream, RandomAccessFile
public interface DataOutput

DataOutput 接口用于将数据从任意 Java 基本类型转换为一系列字节，并将这些字节写入二进制流。同时还提供了一个将 String 转换成 UTF-8 修改版格式并写入所得到的系列字节的工具。

对于此接口中写入字节的所有方法，如果由于某种原因无法写入某个字节，则抛出 IOException。

从以下版本开始：
JDK1.0
另请参见：
DataInput, DataOutputStream

方法摘要
void | write(byte[] b) 将数组 b 中的所有字节写入输出流。
void | write(byte[] b, int off, int len) 将数组 b 中的 len 个字节按顺序写入输出流。
void | write(int b) 将参数 b 的八个低位写入输出流。
void | writeBoolean(boolean v) 将一个 boolean 值写入输出流。
void | writeByte(int v) 将参数 v 的八个低位写入输出流。
void | writeBytes(String s) 将一个字符串写入输出流。
void | writeChar(int v) 将一个 char 值写入输出流，该值由两个字节组成。
void | writeChars(String s) 将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。
void | writeDouble(double v) 将一个 double 值写入输出流，该值由八个字节组成。
void | writeFloat(float v) 将一个 float 值写入输出流，该值由四个字节组成。
void | writeInt(int v) 将一个 int 值写入输出流，该值由四个字节组成。
void | writeLong(long v) 将一个 long 值写入输出流，该值由八个字节组成。
void | writeShort(int v) 将两个字节写入输出流，用它们表示参数值。
void | writeUTF(String s) 将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。

方法详细信息

write

void write(int b)
           throws IOException
将参数 b 的八个低位写入输出流。忽略 b 的 24 个高位。

参数：
b - 要写入的字节。
抛出：
IOException - 如果发生 I/O 错误。

write

void write(byte[] b)
           throws IOException
将数组 b 中的所有字节写入输出流。如果 b 为 null，则抛出 NullPointerException。如果 b.length 为零，则不写入字节。否则，首先写入字节 b[0]，然后写入字节 b[1]，依此类推；最后一个写入字节是 b[b.length-1]。

参数：
b - 数据。
抛出：
IOException - 如果发生 I/O 错误。

write

void write(byte[] b,
           int off,
           int len)
           throws IOException
将数组 b 中的 len 个字节按顺序写入输出流。如果 b 为 null，则抛出 NullPointerException。如果 off 为负，或 len 为负，抑或 off+len 大于数组 b 的长度，则抛出 IndexOutOfBoundsException。如果 len 为零，则不写入字节。否则，首先写入字节 b[off]，然后写入字节 b[off+1]，依此类推；最后一个写入字节是 b[off+len-1]。

参数：
b - 数据。
off - 数据中的起始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。

writeBoolean

void writeBoolean(boolean v)
                  throws IOException
将一个 boolean 值写入输出流。如果参数 v 为 true，则写入值 (byte)1；如果 v 为 false，则写入值 (byte)0。此方法写入的字节可由 DataInput 接口的 readBoolean 方法读取，然后该方法将返回一个等于 v 的 boolean 值。

参数：
v - 要写入的 boolean 值。
抛出：
IOException - 如果发生 I/O 错误。

writeByte

void writeByte(int v)
               throws IOException
将参数 v 的八个低位写入输出流。忽略 v 的 24 个高位。（这意味着 writeByte 的作用与使用整数做参数的 write 完全相同。）此方法写入的字节可由 DataInput 接口的 readByte 方法读取，然后该方法将返回一个等于 (byte)v 的 byte 值。

参数：
v - 要写入的字节值。
抛出：
IOException - 如果发生 I/O 错误。

writeShort

void writeShort(int v)
                throws IOException
将两个字节写入输出流，用它们表示参数值。要写入的字节值（按顺序显示）是：

 (byte)(0xff & (v >> 8))
 (byte)(0xff & v)

此方法写入的字节可由 DataInput 接口的 readShort 方法读取，然后该方法将返回一个等于 (short)v 的 short 值。

参数：
v - 要写入的 short 值。
抛出：
IOException - 如果发生 I/O 错误。

writeChar

void writeChar(int v)
               throws IOException
将一个 char 值写入输出流，该值由两个字节组成。要写入的字节值（按顺序显示）是：

 (byte)(0xff & (v >> 8))
 (byte)(0xff & v)

此方法写入的字节可由 DataInput 接口的 readChar 方法读取，然后该方法将返回一个等于 (char)v 的 char 值。

参数：
v - 要写入的 char 值。
抛出：
IOException - 如果发生 I/O 错误。

writeInt

void writeInt(int v)
              throws IOException
将一个 int 值写入输出流，该值由四个字节组成。要写入的字节值（按顺序显示）是：

 (byte)(0xff & (v >> 24))
 (byte)(0xff & (v >> 16))
 (byte)(0xff & (v >>    8))
 (byte)(0xff & v)

此方法写入的字节可由 DataInput 接口的 readInt 方法读取，然后该方法将返回一个等于 v 的 int 值。

参数：
v - 要写入的 int 值。
抛出：
IOException - 如果发生 I/O 错误。

writeLong

void writeLong(long v)
               throws IOException
将一个 long 值写入输出流，该值由八个字节组成。要写入的字节值（按顺序显示）是：

 (byte)(0xff & (v >> 56))
 (byte)(0xff & (v >> 48))
 (byte)(0xff & (v >> 40))
 (byte)(0xff & (v >> 32))
 (byte)(0xff & (v >> 24))
 (byte)(0xff & (v >> 16))
 (byte)(0xff & (v >>  8))
 (byte)(0xff & v)

此方法写入的字节可由 DataInput 接口的 readLong 方法读取，然后该方法将返回一个等于 v 的 long 值。

参数：
v - 要写入的 long 值。
抛出：
IOException - 如果发生 I/O 错误。

writeFloat

void writeFloat(float v)
                throws IOException
将一个 float 值写入输出流，该值由四个字节组成。实现这一点的方式是：首先使用与 Float.floatToIntBits 方法完全相同的方式将此 float 值转换为一个 int 值，然后使用与 writeInt 方法完全相同的方式写入该 int 值。此方法写入的字节可由 DataInput 接口的 readFloat 方法读取，然后该方法将返回一个等于 v 的 float 值。

参数：
v - 要写入的 float 值。
抛出：
IOException - 如果发生 I/O 错误。

writeDouble

void writeDouble(double v)
                 throws IOException
将一个 double 值写入输出流，该值由八个字节组成。实现这一点的方式是：首先使用与 Double.doubleToLongBits 方法相同的方式将此 double 值转换为一个 long 值，然后使用与 writeLong 方法完全相同的方式写入该 long 值。此方法写入的字节可由 DataInput 接口的 readDouble 方法读取，然后该方法将返回一个等于 v 的 double 值。

参数：
v - 要写入的 double 值。
抛出：
IOException - 如果发生 I/O 错误。

writeBytes

void writeBytes(String s)
                throws IOException
将一个字符串写入输出流。字符串 s 中的每一个字符被依次写入输出流，每个字符用一个字节表示。如果 s 为 null，则抛出 NullPointerException。

如果 s.length 为零，则不写入字节。否则，首先写入字符 s[0]，然后写入字符 s[1]，依此类推；最后一个写入字符是 s[s.length-1]。使用与 writeByte 方法完全相同的方法为每个字符写入一个低位字节。忽略字符串中每个字符的八个高位。

参数：
s - 要写入的字节字符串。
抛出：
IOException - 如果发生 I/O 错误。

writeChars

void writeChars(String s)
                throws IOException
将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。如果 s 为 null，则抛出 NullPointerException。如果 s.length 为零，则不写入字符。否则，首先写入字符 s[0]，然后写入字符 s[1]，依此类推；最后一个写入字符是 s[s.length-1]。使用与 writeChar 方法完全相同的方法为每个字符实际写入两个字节，先使用高位字节。

参数：
s - 要写入的字符串值。
抛出：
IOException - 如果发生 I/O 错误。

writeUTF

void writeUTF(String s)
              throws IOException
将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。如果 s 为 null，则抛出 NullPointerException。根据字符的值，将字符串 s 中每个字符转换成一个字节、两个字节或三个字节的字节组。

如果字符 c 在 \u0001 到 \u007f 的范围内，则用一个字节表示：

(byte)c

如果字符 c 是 \u0000 或者它在 \u0080 到 \u07ff 的范围内，则用两个字节表示，写入顺序如下：

 (byte)(0xc0 | (0x1f & (c >> 6)))
 (byte)(0x80 | (0x3f & c))

如果字符 c 在 \u0800 到 \uffff 的范围内，则用三个字节表示，写入顺序如下：

 (byte)(0xe0 | (0x0f & (c >> 12)))
 (byte)(0x80 | (0x3f & (c >>  6)))
 (byte)(0x80 | (0x3f & c))

首先，要计算表示 s 中所有字符所需的字节总数。如果总数大于 65535，则抛出 UTFDataFormatException。否则，使用与 writeShort 方法完全相同的方式将此长度写入输出流，然后写入字符串 s 中所有字符的 1 字节、2 字节或 3 字节表示形式。

此方法写入的字节可由 DataInput 接口的 readUTF 方法读取，然后该方法将返回一个等于 s 的 String 值。

参数：
s - 要写入的字符串值。
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 DataOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.io.DataOutputStream
所有已实现的接口：
Closeable, DataOutput, Flushable
public class DataOutputStream
extends FilterOutputStream
implements DataOutput

数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。然后，应用程序可以使用数据输入流将数据读入。

从以下版本开始：
JDK1.0
另请参见：
DataInputStream

字段摘要
protected  int written
到目前为止写入数据输出流的字节数。
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
DataOutputStream(OutputStream out)
创建一个新的数据输出流，将数据写入指定基础输出流。
方法摘要
void | flush() 清空此数据输出流。
int | size() 返回计数器 written 的当前值，即到目前为止写入此数据输出流的字节数。
void | write(byte[] b, int off, int len) 将指定 byte 数组中从偏移量 off 开始的 len 个字节写入基础输出流。
void | write(int b) 将指定字节（参数 b 的八个低位）写入基础输出流。
void | writeBoolean(boolean v) 将一个 boolean 值以 1-byte 值形式写入基础输出流。
void | writeByte(int v) 将一个 byte 值以 1-byte 值形式写出到基础输出流中。
void | writeBytes(String s) 将字符串按字节顺序写出到基础输出流中。
void | writeChar(int v) 将一个 char 值以 2-byte 值形式写入基础输出流中，先写入高字节。
void | writeChars(String s) 将字符串按字符顺序写入基础输出流。
void | writeDouble(double v) 使用 Double 类中的 doubleToLongBits 方法将 double 参数转换为一个 long 值，然后将该 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
void | writeFloat(float v) 使用 Float 类中的 floatToIntBits 方法将 float 参数转换为一个 int 值，然后将该 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
void | writeInt(int v) 将一个 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
void | writeLong(long v) 将一个 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
void | writeShort(int v) 将一个 short 值以 2-byte 值形式写入基础输出流中，先写入高字节。
void | writeUTF(String str) 以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。
从类 java.io.FilterOutputStream 继承的方法
close, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.io.DataOutput 继承的方法
write

字段详细信息

written

protected int written
到目前为止写入数据输出流的字节数。如果此计数器溢出，则将它包装成 Integer.MAX_VALUE。

构造方法详细信息

DataOutputStream

public DataOutputStream(OutputStream out)
创建一个新的数据输出流，将数据写入指定基础输出流。计数器 written 被设置为零。

参数：
out - 基础输出流，将被保存供以后使用。
另请参见：
FilterOutputStream.out
方法详细信息

write

public void write(int b)
           throws IOException
将指定字节（参数 b 的八个低位）写入基础输出流。如果没有抛出异常，则计数器 written 增加 1。

实现 OutputStream 的 write 方法。

指定者：
接口 DataOutput 中的 write
覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要写入的 byte。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入基础输出流。如果没有抛出异常，则计数器 written 增加 len。

指定者：
接口 DataOutput 中的 write
覆盖：
类 FilterOutputStream 中的 write
参数：
b - 数据。
off - 数据中的起始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

flush

public void flush()
           throws IOException
清空此数据输出流。这迫使所有缓冲的输出字节被写出到流中。

DataOutputStream 的 flush 方法调用其基础输出流的 flush 方法。

指定者：
接口 Flushable 中的 flush
覆盖：
类 FilterOutputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out, OutputStream.flush()

writeBoolean

public final void writeBoolean(boolean v)
                        throws IOException
将一个 boolean 值以 1-byte 值形式写入基础输出流。值 true 以值 (byte)1 的形式被写出；值 false 以值 (byte)0 的形式被写出。如果没有抛出异常，则计数器 written 增加 1。

指定者：
接口 DataOutput 中的 writeBoolean
参数：
v - 要写入的 boolean 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

writeByte

public final void writeByte(int v)
                     throws IOException
将一个 byte 值以 1-byte 值形式写出到基础输出流中。如果没有抛出异常，则计数器 written 增加 1。

指定者：
接口 DataOutput 中的 writeByte
参数：
v - 要写入的 byte 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

writeShort

public final void writeShort(int v)
                      throws IOException
将一个 short 值以 2-byte 值形式写入基础输出流中，先写入高字节。如果没有抛出异常，则计数器 written 增加 2。

指定者：
接口 DataOutput 中的 writeShort
参数：
v - 要写入的 short 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

writeChar

public final void writeChar(int v)
                     throws IOException
将一个 char 值以 2-byte 值形式写入基础输出流中，先写入高字节。如果没有抛出异常，则计数器 written 增加 2。

指定者：
接口 DataOutput 中的 writeChar
参数：
v - 要写入的 char 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

writeInt

public final void writeInt(int v)
                    throws IOException
将一个 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。如果没有抛出异常，则计数器 written 增加 4。

指定者：
接口 DataOutput 中的 writeInt
参数：
v - 要写入的 int 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

writeLong

public final void writeLong(long v)
                     throws IOException
将一个 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。如果没有抛出异常，则计数器 written 增加 8。

指定者：
接口 DataOutput 中的 writeLong
参数：
v - 要写入的 long 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

writeFloat

public final void writeFloat(float v)
                      throws IOException
使用 Float 类中的 floatToIntBits 方法将 float 参数转换为一个 int 值，然后将该 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。如果没有抛出异常，则计数器 written 增加 4。

指定者：
接口 DataOutput 中的 writeFloat
参数：
v - 要写入的 float 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out, Float.floatToIntBits(float)

writeDouble

public final void writeDouble(double v)
                       throws IOException
使用 Double 类中的 doubleToLongBits 方法将 double 参数转换为一个 long 值，然后将该 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。如果没有抛出异常，则计数器 written 增加 8。

指定者：
接口 DataOutput 中的 writeDouble
参数：
v - 要写入的 double 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out, Double.doubleToLongBits(double)

writeBytes

public final void writeBytes(String s)
                      throws IOException
将字符串按字节顺序写出到基础输出流中。按顺序写出字符串中每个字符，丢弃其八个高位。如果没有抛出异常，则计数器 written 增加 s 的长度。

指定者：
接口 DataOutput 中的 writeBytes
参数：
s - 要写入的字节字符串。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterOutputStream.out

writeChars

public final void writeChars(String s)
                      throws IOException
将字符串按字符顺序写入基础输出流。通过 writeChar 方法将每个字符写入数据输出流。如果没有抛出异常，则计数器 written 增加 s 长度的两倍。

指定者：
接口 DataOutput 中的 writeChars
参数：
s - 要写入的 String 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
writeChar(int), FilterOutputStream.out

writeUTF

public final void writeUTF(String str)
                    throws IOException
以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。

首先，通过 writeShort 方法将两个字节写入输出流，表示后跟的字节数。该值是实际写出的字节数，不是字符串的长度。根据此长度，使用字符的 UTF-8 修改版编码按顺序输出字符串的每个字符。如果没有抛出异常，则计数器 written 增加写入输出流的字节总数。该值至少是 2 加 str 的长度，最多是 2 加 str 的三倍长度。

指定者：
接口 DataOutput 中的 writeUTF
参数：
str - 要写入的字符串。
抛出：
IOException - 如果发生 I/O 错误。

size

public final int size()
返回计数器 written 的当前值，即到目前为止写入此数据输出流的字节数。如果计数器溢出，则将它包装到 Integer.MAX_VALUE。

返回：
written 字段的值。
另请参见：
written
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


File (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 File

java.lang.Object
    继承者  java.io.File
所有已实现的接口：
Serializable, Comparable<File>
public class File
extends Object
implements Serializable, Comparable<File>

文件和目录路径名的抽象表示形式。

用户界面和操作系统使用与系统相关的路径名字符串 来命名文件和目录。此类呈现分层路径名的一个抽象的、与系统无关的视图。抽象路径名 有两个组件：

  1. 一个可选的与系统有关的前缀 字符串，比如盘符，"/" 表示 UNIX 中的根目录，"\\\\" 表示 Microsoft Windows UNC 路径名。
  2. 零个或更多字符串名称 的序列。
抽象路径名中的第一个名称是目录名，对于 Microsoft Windows UNC 路径名则是主机名。抽象路径名中第一个名称之后的每个名称表示一个目录；最后一个名称既可以表示目录，也可以表示文件。空 抽象路径名没有前缀和名称序列。

路径名字符串与抽象路径名之间的转换与系统有关。将抽象路径名转换为路径名字符串时，每个名称与下一个名称之间用一个默认分隔符 隔开。默认名称分隔符由系统属性 file.separator 定义，可通过此类的公共静态字段 separator 和 separatorChar 使其可用。将路径名字符串转换为抽象路径名时，可以使用默认名称分隔符或者底层系统支持的任何其他名称分隔符来分隔其中的名称。

无论是抽象路径名还是路径名字符串，都可以是绝对 路径名或相对 路径名。绝对路径名是完整的路径名，不需要任何其他信息就可以定位它所表示的文件。相反，相对路径名必须使用取自其他路径名的信息进行解释。默认情况下，java.io 包中的类总是根据当前用户目录来解析相对路径名。此目录由系统属性 user.dir 指定，通常是 Java 虚拟机的调用目录。

调用此类的 getParent() 方法可以获取抽象路径名的父 路径名，它由路径名前缀以及路径名名称序列中的每个名称（最后一个除外）组成。对于任何具有绝对抽象路径名的 File 对象，如果其绝对抽象路径名以某个目录的绝对路径名开头，那么该目录的绝对路径名是该 File 对象的祖先。例如，抽象路径名 "/usr" 表示的目录是路径名 "/usr/local/bin" 所表示目录的一个祖先。

在处理 UNIX 平台的根目录，以及 Microsoft Windows 平台的盘符、根目录和 UNC 路径名时，将用到前缀这一概念。如下所示：

  • 对于 UNIX 平台，绝对路径名的前缀始终是 "/"。相对路径名没有前缀。表示根目录的绝对路径名的前缀为 "/" 且名称序列为空。
  • 对于 Microsoft Windows 平台，包含盘符的路径名前缀由驱动器号和一个 ":" 组成。如果路径名是绝对路径名，还可能后跟 "\\"。UNC 路径名的前缀是 "\\\\"；主机名和共享名是名称序列中的前两个名称。没有指定驱动器的相对路径名没有前缀。

此类的实例可能表示（也可能不表示）实际文件系统对象，如文件或目录。如果它表示这种对象，那么该对象驻留在一个分区 中。分区是文件系统特定于操作系统的存储分区。一个存储设备（例如，物理磁盘驱动器、闪存、CD-ROM）可以包含多个分区。对象（如果有）将驻留在此路径名（绝对形式）某个祖先指定的分区上。

文件系统可以实现对实际文件系统对象上的某些操作（比如，读、写、执行）进行限制。这些限制统称为访问权限。文件系统可以对一个对象设置多个访问权限。例如，一个设置可能适用于对象的所有者，另一个设置则可能适用于所有其他用户。对象上的访问权限可能导致此类的某些方法执行失败。

File 类的实例是不可变的；也就是说，一旦创建，File 对象表示的抽象路径名将永不改变。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static String | pathSeparator 与系统有关的路径分隔符，为了方便，它被表示为一个字符串。
static char | pathSeparatorChar 与系统有关的路径分隔符。
static String | separator 与系统有关的默认名称分隔符，为了方便，它被表示为一个字符串。
static char | separatorChar 与系统有关的默认名称分隔符。
构造方法摘要
File(File parent, String child)
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。
File(String pathname)
通过将给定路径名字符串转换为抽象路径名来创建一个新 File 实例。
File(String parent, String child)
根据 parent 路径名字符串和 child 路径名字符串创建一个新 File 实例。
File(URI uri)
通过将给定的 file: URI 转换为一个抽象路径名来创建一个新的 File 实例。
方法摘要
boolean | canExecute() 测试应用程序是否可以执行此抽象路径名表示的文件。
boolean | canRead() 测试应用程序是否可以读取此抽象路径名表示的文件。
boolean | canWrite() 测试应用程序是否可以修改此抽象路径名表示的文件。
int | compareTo(File pathname) 按字母顺序比较两个抽象路径名。
boolean | createNewFile() 当且仅当不存在具有此抽象路径名指定名称的文件时，不可分地创建一个新的空文件。
static File | createTempFile(String prefix, String suffix) 在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。
static File | createTempFile(String prefix, String suffix, File directory) 在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
boolean | delete() 删除此抽象路径名表示的文件或目录。
void | deleteOnExit() 在虚拟机终止时，请求删除此抽象路径名表示的文件或目录。
boolean | equals(Object obj) 测试此抽象路径名与给定对象是否相等。
boolean | exists() 测试此抽象路径名表示的文件或目录是否存在。
File | getAbsoluteFile() 返回此抽象路径名的绝对路径名形式。
String | getAbsolutePath() 返回此抽象路径名的绝对路径名字符串。
File | getCanonicalFile() 返回此抽象路径名的规范形式。
String | getCanonicalPath() 返回此抽象路径名的规范路径名字符串。
long | getFreeSpace() 返回此抽象路径名指定的分区中未分配的字节数。
String | getName() 返回由此抽象路径名表示的文件或目录的名称。
String | getParent() 返回此抽象路径名父目录的路径名字符串；如果此路径名没有指定父目录，则返回 null。
File | getParentFile() 返回此抽象路径名父目录的抽象路径名；如果此路径名没有指定父目录，则返回 null。
String | getPath() 将此抽象路径名转换为一个路径名字符串。
long | getTotalSpace() 返回此抽象路径名指定的分区大小。
long | getUsableSpace() 返回此抽象路径名指定的分区上可用于此虚拟机的字节数。
int | hashCode() 计算此抽象路径名的哈希码。
boolean | isAbsolute() 测试此抽象路径名是否为绝对路径名。
boolean | isDirectory() 测试此抽象路径名表示的文件是否是一个目录。
boolean | isFile() 测试此抽象路径名表示的文件是否是一个标准文件。
boolean | isHidden() 测试此抽象路径名指定的文件是否是一个隐藏文件。
long | lastModified() 返回此抽象路径名表示的文件最后一次被修改的时间。
long | length() 返回由此抽象路径名表示的文件的长度。
String[] | list() 返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中的文件和目录。
String[] | list(FilenameFilter filter) 返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。
File[] | listFiles() 返回一个抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件。
File[] | listFiles(FileFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
File[] | listFiles(FilenameFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
static File[] | listRoots() 列出可用的文件系统根。
boolean | mkdir() 创建此抽象路径名指定的目录。
boolean | mkdirs() 创建此抽象路径名指定的目录，包括所有必需但不存在的父目录。
boolean | renameTo(File dest) 重新命名此抽象路径名表示的文件。
boolean | setExecutable(boolean executable) 设置此抽象路径名所有者执行权限的一个便捷方法。
boolean | setExecutable(boolean executable, boolean ownerOnly) 设置此抽象路径名的所有者或所有用户的执行权限。
boolean | setLastModified(long time) 设置此抽象路径名指定的文件或目录的最后一次修改时间。
boolean | setReadable(boolean readable) 设置此抽象路径名所有者读权限的一个便捷方法。
boolean | setReadable(boolean readable, boolean ownerOnly) 设置此抽象路径名的所有者或所有用户的读权限。
boolean | setReadOnly() 标记此抽象路径名指定的文件或目录，从而只能对其进行读操作。
boolean | setWritable(boolean writable) 设置此抽象路径名所有者写权限的一个便捷方法。
boolean | setWritable(boolean writable, boolean ownerOnly) 设置此抽象路径名的所有者或所有用户的写权限。
String | toString() 返回此抽象路径名的路径名字符串。
URI | toURI() 构造一个表示此抽象路径名的 file: URI。
URL | toURL() 已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

separatorChar

public static final char separatorChar
与系统有关的默认名称分隔符。此字段被初始化为包含系统属性 file.separator 值的第一个字符。在 UNIX 系统上，此字段的值为 '/'；在 Microsoft Windows 系统上，它为 '\\'。

另请参见：
System.getProperty(java.lang.String)

separator

public static final String separator
与系统有关的默认名称分隔符，为了方便，它被表示为一个字符串。此字符串只包含一个字符，即 separatorChar。

pathSeparatorChar

public static final char pathSeparatorChar
与系统有关的路径分隔符。此字段被初始为包含系统属性 path.separator 值的第一个字符。此字符用于分隔以路径列表 形式给定的文件序列中的文件名。在 UNIX 系统上，此字段为 ':'；在 Microsoft Windows 系统上，它为 ';'。

另请参见：
System.getProperty(java.lang.String)

pathSeparator

public static final String pathSeparator
与系统有关的路径分隔符，为了方便，它被表示为一个字符串。此字符串只包含一个字符，即 pathSeparatorChar。

构造方法详细信息

File

public File(String pathname)
通过将给定路径名字符串转换为抽象路径名来创建一个新 File 实例。如果给定字符串是空字符串，那么结果是空抽象路径名。

参数：
pathname - 路径名字符串
抛出：
NullPointerException - 如果 pathname 参数为 null

File

public File(String parent,
            String child)
根据 parent 路径名字符串和 child 路径名字符串创建一个新 File 实例。

如果 parent 为 null，则创建一个新的 File 实例，这与调用以给定 child 路径名字符串作为参数的单参数 File 构造方法效果一样。

否则，parent 路径名字符串用于表示目录，child 路径名字符串用于表示目录或文件。如果 child 路径名字符串是绝对路径名，则用与系统有关的方式将它转换为一个相对路径名。如果 parent 是空字符串，则通过将 child 转换为抽象路径名，并根据与系统有关的默认目录解析结果来创建新的 File 实例。否则，将每个路径名字符串转换为一个抽象路径名，并根据父抽象路径名解析子抽象路径名。

参数：
parent - 父路径名字符串
child - 子路径名字符串
抛出：
NullPointerException - 如果 child 为 null

File

public File(File parent,
            String child)
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。

如果 parent 为 null，则创建一个新的 File 实例，这与调用给定 child 路径名字符串的单参数 File 构造方法的效果一样。

否则，parent 抽象路径名用于表示目录，child 路径名字符串用于表示目录或文件。如果 child 路径名字符串是绝对路径名，则用与系统有关的方式将它转换为一个相对路径名。如果 parent 是空抽象路径名，则通过将 child 转换为抽象路径名，并根据与系统有关的默认目录解析结果来创建新的 File 实例。否则，将每个路径名字符串转换为一个抽象路径名，并根据父抽象路径名解析子抽象路径名。

参数：
parent - 父抽象路径名
child - 子路径名字符串
抛出：
NullPointerException - 如果 child 为 null

File

public File(URI uri)
通过将给定的 file: URI 转换为一个抽象路径名来创建一个新的 File 实例。

file: URI 的具体形式与系统有关，因此，由此构造方法执行的转换也与系统有关。

对于某个给定抽象路径名 f，可以保证：

new File( f.toURI()).equals( f.getAbsoluteFile())
只要原始抽象路径名、URI 和新抽象路径名都是在同一 Java 虚拟机（或者它的不同调用）中创建的。但是，当在某一操作系统上的虚拟机中创建的 file: URI 在不同操作系统上的虚拟机中被转换为抽象路径名时，这种关系通常是不成立的。

参数：
uri - 一个绝对分层 URI，由一个等于 "file" 的 scheme、非空的 path 组件，以及未定义的 authority、query 和 fragment 组件组成
抛出：
NullPointerException - 如果 uri 为 null
IllegalArgumentException - 如果关于参数的前提不成立
从以下版本开始：
1.4
另请参见：
toURI(), URI
方法详细信息

getName

public String getName()
返回由此抽象路径名表示的文件或目录的名称。该名称是路径名名称序列中的最后一个名称。如果路径名名称序列为空，则返回空字符串。

返回：
此抽象路径名表示的文件或目录的名称；如果路径名的名称序列为空，则返回空字符串

getParent

public String getParent()
返回此抽象路径名父目录的路径名字符串；如果此路径名没有指定父目录，则返回 null。

抽象路径名的父 路径名由路径名的前缀（如果有），以及路径名名称序列中最后一个名称以外的所有名称组成。如果名称序列为空，那么该路径名没有指定父目录。

返回：
此抽象路径名指定父目录的路径名字符串；如果此路径名没有指定父目录，则返回 null

getParentFile

public File getParentFile()
返回此抽象路径名父目录的抽象路径名；如果此路径名没有指定父目录，则返回 null。

抽象路径名的父 路径名由路径名的前缀（如果有），以及路径名名称序列中最后一个名称以外的所有名称组成。如果名称序列为空，那么该路径名没有指定父目录。

返回：
此抽象路径名指定父目录的抽象路径名；如果此路径名没有指定父目录，则返回 null
从以下版本开始：
1.2

getPath

public String getPath()
将此抽象路径名转换为一个路径名字符串。所得字符串使用默认名称分隔符分隔名称序列中的名称。

返回：
此抽象路径名的字符串形式

isAbsolute

public boolean isAbsolute()
测试此抽象路径名是否为绝对路径名。绝对路径名的定义与系统有关。在 UNIX 系统上，如果路径名的前缀是 "/"，那么该路径名是绝对路径名。在 Microsoft Windows 系统上，如果路径名的前缀是后跟 "\\" 的盘符，或者是 "\\\\"，那么该路径名是绝对路径名。

返回：
如果此抽象路径名是绝对路径名，则返回 true；否则返回 false

getAbsolutePath

public String getAbsolutePath()
返回此抽象路径名的绝对路径名字符串。

如果此抽象路径名已经是绝对路径名，则返回该路径名字符串，这与 getPath() 方法一样。如果此抽象路径名是空抽象路径名，则返回当前用户目录的路径名字符串，该目录由系统属性 user.dir 指定。否则，使用与系统有关的方式解析此路径名。在 UNIX 系统上，根据当前用户目录解析相对路径名，可使该路径名成为绝对路径名。在 Microsoft Windows 系统上，根据路径名指定的当前驱动器目录（如果有）解析相对路径名，可使该路径名成为绝对路径名；否则，可以根据当前用户目录解析它。

返回：
绝对路径名字符串，它与此抽象路径名表示相同的文件或目录
抛出：
SecurityException - 如果无法访问所需的系统属性值。
另请参见：
isAbsolute()

getAbsoluteFile

public File getAbsoluteFile()
返回此抽象路径名的绝对路径名形式。等同于 new File(this.getAbsolutePath())。

返回：
绝对抽象路径名，它与此抽象路径名表示相同的文件或目录
抛出：
SecurityException - 如果无法访问所需的系统属性值。
从以下版本开始：
1.2

getCanonicalPath

public String getCanonicalPath()
                        throws IOException
返回此抽象路径名的规范路径名字符串。

规范路径名是绝对路径名，并且是惟一的。规范路径名的准确定义与系统有关。如有必要，此方法首先将路径名转换为绝对路径名，这与调用 getAbsolutePath() 方法的效果一样，然后用与系统相关的方式将它映射到其惟一路径名。这通常涉及到从路径名中移除多余的名称（比如 "." 和 ".."）、解析符号连接（对于 UNIX 平台），以及将驱动器号转换为标准大小写形式（对于 Microsoft Windows 平台）。

每个表示现存文件或目录的路径名都有一个惟一的规范形式。每个表示不存在文件或目录的路径名也有一个惟一的规范形式。不存在文件或目录路径名的规范形式可能不同于创建文件或目录之后同一路径名的规范形式。同样，现存文件或目录路径名的规范形式可能不同于删除文件或目录之后同一路径名的规范形式。

返回：
规范路径名字符串，它与此抽象路径名表示相同的文件或目录
抛出：
IOException - 如果发生 I/O 错误（可能是因为构造规范路径名需要进行文件系统查询）
SecurityException - 如果无法访问所需的系统属性值，或者存在安全管理器，且其 SecurityManager.checkRead(java.io.FileDescriptor) 方法拒绝对文件进行读访问
从以下版本开始：
JDK1.1

getCanonicalFile

public File getCanonicalFile()
                      throws IOException
返回此抽象路径名的规范形式。等同于 new File(this.getCanonicalPath())。

返回：
规范路径名字符串，它与此抽象路径名表示相同的文件或目录
抛出：
IOException - 如果发生 I/O 错误（可能是因为构造规范路径名需要进行文件系统查询）
SecurityException - 如果无法访问所需的系统属性值，或者存在安全管理器，且其 SecurityManager.checkRead(java.io.FileDescriptor) 方法拒绝对文件进行读访问
从以下版本开始：
1.2

toURL

@Deprecated
public URL toURL()
          throws MalformedURLException
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。

将此抽象路径名转换为一个 file: URL。该 URL 的具体形式与系统有关。如果可以确定此抽象路径名表示的文件是一个目录，那么所得 URL 将以斜杠结束。

返回：
表示等价文件 URL 的 URL 对象
抛出：
MalformedURLException - 如果无法将路径解析为 URL
从以下版本开始：
1.2
另请参见：
toURI(), URI, URI.toURL(), URL

toURI

public URI toURI()
构造一个表示此抽象路径名的 file: URI。

该 URI 的具体形式与系统有关。如果可以确定此抽象路径名表示的文件是一个目录，那么所得 URI 将以斜杠结束。

对于某个给定抽象路径名 f，可保证：

new File( f.toURI()).equals( f.getAbsoluteFile())
只要原始抽象路径名、URI 和新抽象路径名都是在同一 Java 虚拟机（或者它的不同调用）中创建的。但是，由于抽象路径名与系统有关的特性，当在某一操作系统上的虚拟机中创建的 file: URI 在不同操作系统上的虚拟机中被转换为抽象路径名时，这种关系通常是不成立的。

返回：
一个绝对分层 URI，由一个等于 "file" 的 scheme、表示此抽象路径名的 path，以及未定义的 authority、query 和 fragment 组件组成
抛出：
SecurityException - 如果不能访问请求的系统属性值。
从以下版本开始：
1.4
另请参见：
File(java.net.URI), URI, URI.toURL()

canRead

public boolean canRead()
测试应用程序是否可以读取此抽象路径名表示的文件。

返回：
当且仅当此抽象路径名指定的文件存在且 可被应用程序读取时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读访问

canWrite

public boolean canWrite()
测试应用程序是否可以修改此抽象路径名表示的文件。

返回：
当且仅当文件系统实际包含此抽象路径名表示的文件且 允许应用程序对该文件进行写入时，返回 true；否则返回 false。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写访问

exists

public boolean exists()
测试此抽象路径名表示的文件或目录是否存在。

返回：
当且仅当此抽象路径名表示的文件或目录存在时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件或目录进行写访问

isDirectory

public boolean isDirectory()
测试此抽象路径名表示的文件是否是一个目录。

返回：
当且仅当此抽象路径名表示的文件存在且 是一个目录时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读访问

isFile

public boolean isFile()
测试此抽象路径名表示的文件是否是一个标准文件。如果该文件不是一个目录，并且满足其他与系统有关的标准，那么该文件是标准 文件。由 Java 应用程序创建的所有非目录文件一定是标准文件。

返回：
当且仅当此抽象路径名表示的文件存在且 是一个标准文件时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读访问

isHidden

public boolean isHidden()
测试此抽象路径名指定的文件是否是一个隐藏文件。隐藏 的具体定义与系统有关。在 UNIX 系统上，如果文件名以句点字符 ('.') 开头，则认为该文件被隐藏。在 Microsoft Windows 系统上，如果在文件系统中文件被标记为隐藏，则认为该文件被隐藏。

返回：
当且仅当此抽象路径名表示的文件根据底层平台约定是隐藏文件时，返回 true
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读访问
从以下版本开始：
1.2

lastModified

public long lastModified()
返回此抽象路径名表示的文件最后一次被修改的时间。

返回：
表示文件最后一次被修改的时间的 long 值，用与时间点（1970 年 1 月 1 日，00:00:00 GMT）之间的毫秒数表示；如果该文件不存在，或者发生 I/O 错误，则返回 0L
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读访问

length

public long length()
返回由此抽象路径名表示的文件的长度。如果此路径名表示一个目录，则返回值是不确定的。

返回：
此抽象路径名表示的文件的长度，以字节为单位；如果文件不存在，则返回 0L。对于表示特定于系统的实体（比如设备或管道）的路径名，某些操作系统可能返回 0L。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对文件进行读访问

createNewFile

public boolean createNewFile()
                      throws IOException
当且仅当不存在具有此抽象路径名指定名称的文件时，不可分地创建一个新的空文件。检查文件是否存在，若不存在则创建该文件，这是单个操作，对于其他所有可能影响该文件的文件系统活动来说，该操作是不可分的。

注：此方法不应该 用于文件锁定，因为所得协议可能无法可靠地工作。应该使用 FileLock 机制替代。

返回：
如果指定的文件不存在并成功地创建，则返回 true；如果指定的文件已经存在，则返回 false
抛出：
IOException - 如果发生 I/O 错误
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写访问
从以下版本开始：
1.2

delete

public boolean delete()
删除此抽象路径名表示的文件或目录。如果此路径名表示一个目录，则该目录必须为空才能删除。

返回：
当且仅当成功删除文件或目录时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkDelete(java.lang.String) 方法拒绝对文件进行删除访问

deleteOnExit

public void deleteOnExit()
在虚拟机终止时，请求删除此抽象路径名表示的文件或目录。 文件（或目录）将以与注册相反的顺序删除。调用此方法删除已注册为删除的文件或目录无效。根据 Java 语言规范中的定义，只有在虚拟机正常终止时，才会尝试执行删除操作。

一旦请求了删除操作，就无法取消该请求。所以应小心使用此方法。

注：此方法不应该 用于文件锁定，因为所得协议可能无法可靠地工作。应该使用 FileLock 设施替代。

抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkDelete(java.lang.String) 方法拒绝对文件进行删除访问
从以下版本开始：
1.2
另请参见：
delete()

list

public String[] list()
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中的文件和目录。

如果此抽象路径名不表示一个目录，那么此方法将返回 null。否则返回一个字符串数组，每个数组元素对应目录中的每个文件或目录。表示目录本身及其父目录的名称不包括在结果中。每个字符串是一个文件名，而不是一条完整路径。

不保证所得数组中的相同字符串将以特定顺序出现，特别是不保证它们按字母顺序出现。

返回：
字符串数组，这些字符串指定此抽象路径名表示的目录中的文件和目录。如果目录为空，那么数组也将为空。如果此抽象路径名不表示一个目录，或者发生 I/O 错误，则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对目录进行读访问

list

public String[] list(FilenameFilter filter)
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。除了返回数组中的字符串必须满足过滤器外，此方法的行为与 list() 方法相同。如果给定 filter 为 null，则接受所有名称。否则，当且仅当在此抽象路径名及其表示的目录中的文件名或目录名上调用过滤器的 FilenameFilter.accept(java.io.File, java.lang.String) 方法返回 true 时，该名称才满足过滤器。

参数：
filter - 文件名过滤器
返回：
字符串数组，这些字符串指定此抽象路径名表示的目录中给定 filter 能接受的文件和目录。如果目录为空，或者没有名称被过滤器接受，那么该数组将为空。如果抽象路径名不表示一个目录，或者发生 I/O 错误，则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对目录进行读访问

listFiles

public File[] listFiles()
返回一个抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件。

如果此抽象路径名不表示一个目录，那么此方法将返回 null。否则返回一个 File 对象数组，每个数组元素对应目录中的每个文件或目录。表示目录本身及其父目录的名称不包括在结果中。得到的每个抽象路径名都是根据此抽象路径名，使用 File(File, String) 构造方法构造的。所以，如果此路径名是绝对路径名，那么得到的每个路径名都是绝对路径名；如果此路径名是相对路径名，那么得到的每个路径名都是相对于同一目录的路径名。

不保证所得数组中的相同字符串将以特定顺序出现，特别是不保证它们按字母顺序出现。

返回：
抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件和目录。如果目录为空，那么数组也将为空。如果抽象路径名不表示一个目录，或者发生 I/O 错误，则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对目录进行读访问
从以下版本开始：
1.2

listFiles

public File[] listFiles(FilenameFilter filter)
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。除了返回数组中的路径名必须满足过滤器外，此方法的行为与 listFiles() 方法相同。如果给定 filter 为 null，则接受所有路径名。否则，当且仅当在此抽象路径名及其表示的目录中的文件名或目录名上调用过滤器的 FilenameFilter.accept(java.io.File, java.lang.String) 方法返回 true 时，该路径名才满足过滤器。

参数：
filter - 文件名过滤器
返回：
抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件和目录。如果目录为空，那么数组也将为空。如果此抽象路径名不表示一个目录，或者发生 I/O 错误，则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对目录进行读访问
从以下版本开始：
1.2

listFiles

public File[] listFiles(FileFilter filter)
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。除了返回数组中的路径名必须满足过滤器外，此方法的行为与 listFiles() 方法相同。如果给定 filter 为 null，则接受所有路径名。否则，当且仅当在路径名上调用过滤器的 FileFilter.accept(java.io.File) 方法返回 true 时，该路径名才满足过滤器。

参数：
filter - 文件过滤器
返回：
抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件和目录。如果目录为空，那么数组也将为空。如果抽象路径名不表示一个目录，或者发生 I/O 错误，则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对目录进行读访问
从以下版本开始：
1.2

mkdir

public boolean mkdir()
创建此抽象路径名指定的目录。

返回：
当且仅当已创建目录时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法不允许创建指定的目录

mkdirs

public boolean mkdirs()
创建此抽象路径名指定的目录，包括所有必需但不存在的父目录。注意，此操作失败时也可能已经成功地创建了一部分必需的父目录。

返回：
当且仅当已创建目录以及所有必需的父目录时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法不允许验证指定目录和所有必需的父目录是否存在；或者 SecurityManager.checkWrite(java.lang.String) 方法不允许创建指定的目录和所有必需的父目录

renameTo

public boolean renameTo(File dest)
重新命名此抽象路径名表示的文件。

此方法行为的许多方面都是与平台有关的：重命名操作无法将一个文件从一个文件系统移动到另一个文件系统，该操作不是不可分的，如果已经存在具有目标抽象路径名的文件，那么该操作可能无法获得成功。应该始终检查返回值，以确保重命名操作成功。

参数：
dest - 指定文件的新抽象路径名
返回：
当且仅当重命名成功时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对原路径名和新路径名进行写访问
NullPointerException - 如果参数 dest 为 null

setLastModified

public boolean setLastModified(long time)
设置此抽象路径名指定的文件或目录的最后一次修改时间。

所有平台都支持将文件修改时间设置为最接近的秒数，而且一些平台会提供更精确的值。该参数将被截取，以满足受支持的精度。如果该操作成功，并且没有在文件上发生其他干扰操作，则下一次调用 lastModified() 方法将返回传递给此方法的 time 参数（可能被截取）。

参数：
time - 新的最后一次修改时间，用与时间点（1970 年 1 月 1 日，00:00:00 GMT）之间的毫秒数表示
返回：
当且仅当该操作成功时，返回 true；否则返回 false
抛出：
IllegalArgumentException - 如果该参数为负
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对指定文件进行写访问
从以下版本开始：
1.2

setReadOnly

public boolean setReadOnly()
标记此抽象路径名指定的文件或目录，从而只能对其进行读操作。调用此方法后，可以保证在被删除或被标记为允许写访问之前，文件或目录不会发生更改。是否可以删除某个只读文件或目录则取决于底层系统。

返回：
当且仅当该操作成功时，返回 true；否则返回 false
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对指定文件进行写访问
从以下版本开始：
1.2

setWritable

public boolean setWritable(boolean writable,
                           boolean ownerOnly)
设置此抽象路径名的所有者或所有用户的写权限。

参数：
writable - 如果为 true，则设置允许写操作的访问权限；如果为 false，则不允许写操作。
ownerOnly - 如果为 true，则写权限只适用于所有者的写权限；否则适用于所有用户。如果底层文件系统不能区分所有者写权限与其他写权限，那么无论该参数为何值，写权限将适用于所有用户。
返回：
当且仅当操作成功时返回 true。如果用户不具有更改此抽象路径名访问权限的权限，那么操作将失败。
抛出：
SecurityException - 如果安全管理器存在且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对指定文件进行写访问。
从以下版本开始：
1.6

setWritable

public boolean setWritable(boolean writable)
设置此抽象路径名所有者写权限的一个便捷方法。

此方法 file.setWritable(arg) 形式的调用与以下调用的行为完全相同：

     file.setWritable(arg, true)

参数：
writable - 如果为 true，则设置允许写操作的访问权限；如果为 false，则不允许写操作。
返回：
当且仅当操作成功时返回 true。如果用户不具有更改此抽象路径名访问权限的权限，那么操作将失败。
抛出：
SecurityException - 如果安全管理器存在且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写访问。
从以下版本开始：
1.6

setReadable

public boolean setReadable(boolean readable,
                           boolean ownerOnly)
设置此抽象路径名的所有者或所有用户的读权限。

参数：
readable - 如果为 true，则设置允许读操作的访问权限；如果为 false，则不允许读操作。
ownerOnly - 如果为 true，则读权限只适用于所有者的读权限；否则适用于所有用户。如果底层文件系统不能区分所有者读权限与其他读权限，那么无论该参数为何值，读权限将适用于所有用户。
返回：
当且仅当操作成功时返回 true。如果用户不具有更改此抽象路径名访问权限的权限，那么操作将失败。如果 readable 为 false，并且底层文件系统不实现读权限，那么操作也将失败。
抛出：
SecurityException - 如果安全管理器存在且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写访问。
从以下版本开始：
1.6

setReadable

public boolean setReadable(boolean readable)
设置此抽象路径名所有者读权限的一个便捷方法。

此方法 file.setReadable(arg) 形式的调用与以下调用的行为完全相同：

     file.setReadable(arg, true)

参数：
readable - 如果为 true，则设置允许读操作的访问权限；如果为 false，则不允许读操作。
返回：
当且仅当操作成功时返回 true。如果用户不具有更改此抽象路径名访问权限的权限，那么操作将失败。如果 readable 为 false，并且底层文件系统不实现读权限，那么操作也将失败。
抛出：
SecurityException - 如果安全管理器存在且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写访问。
从以下版本开始：
1.6

setExecutable

public boolean setExecutable(boolean executable,
                             boolean ownerOnly)
设置此抽象路径名的所有者或所有用户的执行权限。

参数：
executable - 如果为 true，则设置允许执行操作的访问权限；如果为 false，则不允许执行操作。
ownerOnly - 如果为 true，则执行权限只适用于所有者的执行权限；否则适用于所有用户。如果底层文件系统不能区分所有者执行权限与其他执行权限，那么无论该参数为何值，执行权限将适用于所有用户。
返回：
当且仅当操作成功时返回 true。如果用户不具有更改此抽象路径名访问权限的权限，那么操作将失败。如果 executable 为 false，并且底层文件系统不实现执行权限，那么操作也将失败。
抛出：
SecurityException - 如果安全管理器存在且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写访问。
从以下版本开始：
1.6

setExecutable

public boolean setExecutable(boolean executable)
设置此抽象路径名所有者执行权限的一个便捷方法。

此方法 file.setExcutable(arg) 形式的调用与以下调用的行为完全相同：

     file.setExecutable(arg, true)

参数：
executable - 如果为 true，则设置允许执行操作的访问权限；如果为 false，则不允许执行操作。
返回：
当且仅当操作成功时返回 true。如果用户不具有更改此抽象路径名访问权限的权限，那么操作将失败。如果 executable 为 false，并且底层文件系统不实现执行权限，那么操作也将失败。
抛出：
SecurityException - 如果安全管理器存在且其 SecurityManager.checkWrite(java.lang.String) 方法拒绝对文件进行写访问。
从以下版本开始：
1.6

canExecute

public boolean canExecute()
测试应用程序是否可以执行此抽象路径名表示的文件。

返回：
当且仅当抽象路径名存在且 允许应用程序执行文件时返回 true。
抛出：
SecurityException - 如果安全管理器存在且其 SecurityManager.checkExec(java.lang.String) 方法拒绝对文件进行执行访问。
从以下版本开始：
1.6

listRoots

public static File[] listRoots()
列出可用的文件系统根。

特定 Java 平台可以支持零个或更多个分层组织的文件系统。每个文件系统有一个 root 目录，可以从这里到达文件系统中的所有其他文件。例如，Windows 平台为每个活动驱动器提供了一个根目录；UNIX 平台只有一个根目录，即 "/"。可用文件系统根的设置受各种系统级操作的影响，比如可移动介质的插入和弹出，以及断开或卸载那些物理磁盘或虚拟磁盘。

此方法返回一个 File 对象数组，这些对象表示可用文件系统根的根目录。可以保证本地机器上物理存在的任何文件的规范路径名都以此方法返回的根之一开始。

位于其他一些机器上的文件的规范路径名是通过远程文件系统协议（比如 SMB 或 NFS）访问的，它们可能以此方法返回的根之一开始，也可能不是这样。如果远程文件的路径名在语法上无法与本地文件的路径名进行区分，那么它将以此方法返回的根之一开始。例如，此方法将返回表示 Windows 平台上映射为网络驱动器根目录的 File 对象，而不返回包含 UNC 路径名的 File 对象。

与此类中的大多数方法不同，此方法不抛出安全性异常。如果存在安全管理器，且其 SecurityManager.checkRead(java.lang.String) 方法拒绝对特定根目录进行读访问，那么该目录将不会出现在结果中。

返回：
表示可用文件系统根的 File 对象数组；如果无法确定根集，则返回 null。如果没有文件系统，那么该数组将为空。
从以下版本开始：
1.2

getTotalSpace

public long getTotalSpace()
返回此抽象路径名指定的分区大小。

返回：
分区的大小，以字节为单位；如果此抽象路径名没有指定分区，则返回 0L。
抛出：
SecurityException - 如果安装了安全管理器，并且安全管理器拒绝 RuntimePermission ("getFileSystemAttributes")，或者其 SecurityManager.checkRead(String) 方法拒绝对此抽象路径名指定的文件进行读访问
从以下版本开始：
1.6

getFreeSpace

public long getFreeSpace()
返回此抽象路径名指定的分区中未分配的字节数。

返回的未分配字节数是一个提示，而不是一个保证，只能使用这些字节的一部分。未分配字节数很可能在此调用后立即与实际相符。某些外部 I/O 操作可能使其与实际不符，这些操作包括那些在此虚拟机外部系统上进行的操作。此方法不保证对此文件系统的写操作将成功。

返回：
分区上的未分配字节数；如果抽象路径名没有指定分区，则返回 0L。返回值将小于等于 getTotalSpace() 返回的总文件系统大小。
抛出：
SecurityException - 如果安装了安全管理器，并且安全管理器拒绝 RuntimePermission ("getFileSystemAttributes")，或者其 SecurityManager.checkRead(String) 方法拒绝对此抽象路径名指定的文件进行读访问
从以下版本开始：
1.6

getUsableSpace

public long getUsableSpace()
返回此抽象路径名指定的分区上可用于此虚拟机的字节数。若有可能，此方法将检查写权限和其他操作系统限制，因此与 getFreeSpace() 相比，此方法能更准确地估计可实际写入的新数据数。

返回的可用字节数是一个提示，而不是一个保证，只能使用这些字节的一部分。未分配字节数很可能在此调用后立即与实际相符。某些外部 I/O 操作可能使其与实际不符，这些操作包括那些在此虚拟机外部系统上进行的操作。此方法不保证对此文件系统的写操作将成功。

返回：
分区上的可用字节数；如果抽象路径名没有指定分区，则返回 0L。在此信息不可用的系统上，此方法等效于调用 getFreeSpace()。
抛出：
SecurityException - 如果安装了安全管理器，并且安全管理器拒绝 RuntimePermission ("getFileSystemAttributes")，或者其 SecurityManager.checkRead(String) 方法拒绝对此抽象路径名指定的文件进行读访问
从以下版本开始：
1.6

createTempFile

public static File createTempFile(String prefix,
                                  String suffix,
                                  File directory)
                           throws IOException

在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。如果此方法成功返回，则可以保证：

  1. 由返回的抽象路径名表示的文件在此方法被调用之前不存在。
  2. 此方法及其所有变体都不会在虚拟机的当前调用中再次返回相同的抽象路径名。
此方法只提供了临时文件的部分功能。要安排自动删除此方法创建的文件，可使用 deleteOnExit() 方法。

prefix 参数至少必须是三个字节长。建议前缀使用一个短的、有意义的字符串，比如 "hjb" 或 "mail"。suffix 参数可以为 null，在这种情况下，将使用后缀 ".tmp"。

要创建新文件，可能首先要调整前缀和后缀，使其满足底层平台的限制。如果前缀太长，则将它截断，但前三个字符将始终保留。如果后缀太长，则将它截断，但如果它以句点字符 ('.') 开始，则该句点以及后跟的前三个字符将始终保留。进行了这些调整后，通过连接前缀、五个或更多个内部生成的字符以及后缀，便生成了新文件的名称。

如果 directory 参数为 null，则使用与系统有关的默认临时文件目录。默认临时文件目录由系统属性 java.io.tmpdir 指定。在 UNIX 系统上，此属性的默认值通常是 "/tmp" 或 "/var/tmp"；在 Microsoft Windows 系统上，该值通常是 "C:\\WINNT\\TEMP"。在调用 Java 虚拟机时，可为此系统属性提供不同的值，但不保证使用程序更改此属性会对此方法使用的临时目录产生影响。

参数：
prefix - 用于生成文件名的前缀字符串；必须至少是三字符长
suffix - 用于生成文件名的后缀字符串；可以为 null，在这种情况下，将使用后缀 ".tmp"
directory - 将创建的文件所在的目录；如果使用默认临时文件目录，则该参数为 null
返回：
表示新建空文件的抽象路径名
抛出：
IllegalArgumentException - 如果 prefix 参数包含的字符少于三个
IOException - 如果无法创建文件
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法不允许创建文件
从以下版本开始：
1.2

createTempFile

public static File createTempFile(String prefix,
                                  String suffix)
                           throws IOException
在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。调用此方法等同于调用 createTempFile(prefix, suffix, null)。

参数：
prefix - 用于生成文件名的前缀字符串；必须至少是三字符长
suffix - 用于生成文件名的后缀字符串；可以为 null，在这种情况下，将使用后缀 ".tmp"
返回：
表示新建空文件的抽象路径名
抛出：
IllegalArgumentException - 如果 prefix 参数包含的字符少于三个
IOException - 如果无法创建文件
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkWrite(java.lang.String) 方法不允许创建文件
从以下版本开始：
1.2

compareTo

public int compareTo(File pathname)
按字母顺序比较两个抽象路径名。此方法定义的顺序取决于底层系统。在 UNIX 系统上，比较路径名时，字母大小写通常很重要，而在 Microsoft Windows 系统上，这通常不重要。

指定者：
接口 Comparable<File> 中的 compareTo
参数：
pathname - 将与此抽象路径名进行比较的抽象路径名
返回：
如果该参数等于此抽象路径名，则返回零；如果此抽象路径名在字母顺序上小于该参数，则返回小于零的值；如果此抽象路径名在字母顺序上大于该参数，则返回大于零的值
从以下版本开始：
1.2

equals

public boolean equals(Object obj)
测试此抽象路径名与给定对象是否相等。当且仅当该参数不是 null，而是一个与此抽象路径名表示相同的文件或目录的抽象路径名时，返回 true。两个抽象路径名是否相等取决于底层系统。在 UNIX 系统上，比较路径名时，字母大小写通常很重要，而在 Microsoft Windows 系统上，这通常不重要。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此抽象路径名进行比较的对象
返回：
当且仅当对象相同时，返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
计算此抽象路径名的哈希码。因为抽象路径名的相等性与系统有关，所以对其哈希码的计算也与系统有关。在 UNIX 系统上，抽象路径名的哈希码等于其路径名字符串和十进制值 1234321 的哈希码的异或。在 Microsoft Windows 系统上，哈希码等于其转换为小写的路径名字符串和十进制值 1234321 的哈希码的异或。在将路径名字符串转换为小写时不考虑语言环境。

覆盖：
类 Object 中的 hashCode
返回：
此抽象路径名的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此抽象路径名的路径名字符串。该字符串就是 getPath() 方法返回的字符串。

覆盖：
类 Object 中的 toString
返回：
此抽象路径名的字符串形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EOFException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 EOFException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.EOFException
所有已实现的接口：
Serializable
public class EOFException
extends IOException

当输入过程中意外到达文件或流的末尾时，抛出此异常。

此异常主要被数据输入流用来表明到达流的末尾。注意，其他许多输入操作返回一个特殊值表示到达流的末尾，而不是抛出异常。

从以下版本开始：
JDK1.0
另请参见：
DataInputStream, IOException, 序列化表格

构造方法摘要
EOFException()
构造 EOFException，使用 null 作为其错误详细消息。
EOFException(String s)
构造带有指定详细消息的 EOFException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

EOFException

public EOFException()
构造 EOFException，使用 null 作为其错误详细消息。

EOFException

public EOFException(String s)
构造带有指定详细消息的 EOFException。稍后可以通过 java.lang.Throwable 类的 Throwable.getMessage() 方法获取字符串 s。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Externalizable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 Externalizable

所有超级接口：
Serializable
所有已知子接口：
RemoteRef, ServerRef
所有已知实现类：
ActivationDataFlavor, DataFlavor, MimeType, MLet, PrivateMLet
public interface Externalizable
extends Serializable

Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。 若某个要完全控制某一对象及其超类型的流格式和内容，则它要实现 Externalizable 接口的 writeExternal 和 readExternal 方法。这些方法必须显式与超类型进行协调以保存其状态。这些方法将代替定制的 writeObject 和 readObject 方法实现。
Serialization 对象将使用 Serializable 和 Externalizable 接口。对象持久性机制也可以使用它们。要存储的每个对象都需要检测是否支持 Externalizable 接口。如果对象支持 Externalizable，则调用 writeExternal 方法。如果对象不支持 Externalizable 但实现了 Serializable，则使用 ObjectOutputStream 保存该对象。
在重构 Externalizable 对象时，先使用无参数的公共构造方法创建一个实例，然后调用 readExternal 方法。通过从 ObjectInputStream 中读取 Serializable 对象可以恢复这些对象。
Externalizable 实例可以通过 Serializable 接口中记录的 writeReplace 和 readResolve 方法来指派一个替代对象。

从以下版本开始：
JDK1.1
另请参见：
ObjectOutputStream, ObjectInputStream, ObjectOutput, ObjectInput, Serializable

方法摘要
void | readExternal(ObjectInput in) 对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。
void | writeExternal(ObjectOutput out) 该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。

方法详细信息

writeExternal

void writeExternal(ObjectOutput out)
                   throws IOException
该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。

参数：
out - 要写入对象的流
抛出：
IOException - 包含可能发生的所有 I/O 异常

readExternal

void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。readExternal 方法必须按照与 writeExternal 方法写入值时使用的相同顺序和类型来读取这些值。

参数：
in - 为了恢复对象而从中读取数据的流
抛出：
IOException - 如果发生 I/O 错误
ClassNotFoundException - 如果无法找到需要恢复的某个对象的类。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FileDescriptor

java.lang.Object
    继承者  java.io.FileDescriptor

public final class FileDescriptor
extends Object

文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。文件描述符的主要实际用途是创建一个包含该结构的 FileInputStream 或 FileOutputStream。

应用程序不应创建自己的文件描述符。

从以下版本开始：
JDK1.0
另请参见：
FileInputStream, FileOutputStream

字段摘要
static FileDescriptor | err 标准错误流的句柄。
static FileDescriptor | in 标准输入流的句柄。
static FileDescriptor | out 标准输出流的句柄。
构造方法摘要
FileDescriptor()
构造一个（无效的）FileDescriptor 对象。
方法摘要
void | sync() 强制所有系统缓冲区与基础设备同步。
boolean | valid() 测试此文件描述符对象是否有效。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

in

public static final FileDescriptor in
标准输入流的句柄。通常，此文件描述符不是直接使用的，而是通过称为 System.in 的输入流使用的。

另请参见：
System.in

out

public static final FileDescriptor out
标准输出流的句柄。通常，此文件描述符不是直接使用的，而是通过称为 System.out 的输出流使用的。

另请参见：
System.out

err

public static final FileDescriptor err
标准错误流的句柄。通常，此文件描述符不是直接使用的，而是通过称为 System.err 的输出流使用的。

另请参见：
System.err
构造方法详细信息

FileDescriptor

public FileDescriptor()
构造一个（无效的）FileDescriptor 对象。

方法详细信息

valid

public boolean valid()
测试此文件描述符对象是否有效。

返回：
如果文件描述符对象表示一个有效的、开放的文件、套接字或其他活动 I/O 连接，则返回 true；否则返回 false。

sync

public void sync()
          throws SyncFailedException
强制所有系统缓冲区与基础设备同步。该方法在此 FileDescriptor 的所有修改数据和属性都写入相关设备后返回。特别是，如果此 FileDescriptor 引用物理存储介质，比如文件系统中的文件，则一直要等到将与此 FileDesecriptor 有关的缓冲区的所有内存中修改副本写入物理介质中，sync 方法才会返回。 sync 方法由要求物理存储（比例文件）处于某种已知状态下的代码使用。例如，提供简单事务处理设施的类可以使用 sync 来确保某个文件所有由给定事务造成的更改都记录在存储介质上。 sync 只影响此 FileDescriptor 的缓冲区下游。如果正通过应用程序（例如，通过一个 BufferedOutputStream 对象）实现内存缓冲，那么必须在数据受 sync 影响之前将这些缓冲区刷新，并转到 FileDescriptor 中（例如，通过调用 OutputStream.flush）。

抛出：
SyncFailedException - 无法刷新缓冲区时抛出，或者在因为系统无法保证所有缓冲区都与物理介质同步时抛出。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 FileFilter

public interface FileFilter

用于抽象路径名的过滤器。

此接口的实例可传递给 File 类的 listFiles(FileFilter) 方法。

从以下版本开始：
1.2

方法摘要
 boolean accept(File pathname)
测试指定抽象路径名是否应该包含在某个路径名列表中。

方法详细信息

accept

boolean accept(File pathname)
测试指定抽象路径名是否应该包含在某个路径名列表中。

参数：
pathname - 要测试的抽象路径名
返回：
当且仅当应该包含 pathname 时返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FileInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FileInputStream
所有已实现的接口：
Closeable
public class FileInputStream
extends InputStream

FileInputStream 从文件系统中的某个文件中获得输入字节。哪些文件可用取决于主机环境。

FileInputStream 用于读取诸如图像数据之类的原始字节流。要读取字符流，请考虑使用 FileReader。

从以下版本开始：
JDK1.0
另请参见：
File, FileDescriptor, FileOutputStream

构造方法摘要
FileInputStream(File file)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。
FileInputStream(FileDescriptor fdObj)
通过使用文件描述符 fdObj 创建一个 FileInputStream，该文件描述符表示到文件系统中某个实际文件的现有连接。
FileInputStream(String name)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。
方法摘要
int | available() 返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
void | close() 关闭此文件输入流并释放与此流有关的所有系统资源。
protected void | finalize() 确保在不再引用文件输入流时调用其 close 方法。
FileChannel | getChannel() 返回与此文件输入流有关的唯一 FileChannel 对象。
FileDescriptor | getFD() 返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。
int | read() 从此输入流中读取一个数据字节。
int | read(byte[] b) 从此输入流中将最多 b.length 个字节的数据读入一个 byte 数组中。
int | read(byte[] b, int off, int len) 从此输入流中将最多 len 个字节的数据读入一个 byte 数组中。
long | skip(long n) 从输入流中跳过并丢弃 n 个字节的数据。
从类 java.io.InputStream 继承的方法
mark, markSupported, reset
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileInputStream

public FileInputStream(String name)
                throws FileNotFoundException
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。创建一个新 FileDescriptor 对象来表示此文件连接。

首先，如果有安全管理器，则用 name 作为参数调用其 checkRead 方法。

如果指定文件不存在，或者它是一个目录，而不是一个常规文件，抑或因为其他某些原因而无法打开进行读取，则抛出 FileNotFoundException。

参数：
name - 与系统有关的文件名。
抛出：
FileNotFoundException - 如果该文件不存在，或者它是一个目录，而不是一个常规文件，抑或因为其他某些原因而无法打开进行读取。
SecurityException - 如果存在安全管理器，且其 checkRead 方法拒绝对文件进行读取访问。
另请参见：
SecurityManager.checkRead(java.lang.String)

FileInputStream

public FileInputStream(File file)
                throws FileNotFoundException
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。创建一个新 FileDescriptor 对象来表示此文件连接。

首先，如果有安全管理器，则用 file 参数表示的路径作为参数调用其 checkRead 方法。

如果指定文件不存在，或者它是一个目录，而不是一个常规文件，抑或因为其他某些原因而无法打开进行读取，则抛出 FileNotFoundException。

参数：
file - 为了进行读取而打开的文件。
抛出：
FileNotFoundException - 如果该文件不存在，或者它是一个目录，而不是一个常规文件，抑或因为其他某些原因而无法打开进行读取。
SecurityException - 如果存在安全管理器，且其 checkRead 方法拒绝对文件进行读取访问。
另请参见：
File.getPath(), SecurityManager.checkRead(java.lang.String)

FileInputStream

public FileInputStream(FileDescriptor fdObj)
通过使用文件描述符 fdObj 创建一个 FileInputStream，该文件描述符表示到文件系统中某个实际文件的现有连接。

首先，如果有安全管理器，则用文件描述符 fdObj 作为参数调用其 checkRead 方法，以查看它是否可以读取该文件描述符。如果拒绝对该文件描述符进行读取访问，则抛出 SecurityException。

如果 fdObj 为 null，则抛出 NullPointerException。

参数：
fdObj - 为了进行读取而打开的文件描述符。
抛出：
SecurityException - 如果存在安全管理器，且其 checkRead 方法拒绝对文件描述符进行读取访问
另请参见：
SecurityManager.checkRead(java.io.FileDescriptor)
方法详细信息

read

public int read()
         throws IOException
从此输入流中读取一个数据字节。如果没有输入可用，则此方法将阻塞。

指定者：
类 InputStream 中的 read
返回：
下一个数据字节；如果已到达文件末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

read

public int read(byte[] b)
         throws IOException
从此输入流中将最多 b.length 个字节的数据读入一个 byte 数组中。在某些输入可用之前，此方法将阻塞。

覆盖：
类 InputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
返回：
读入缓冲区的字节总数，如果因为已经到达文件末尾而没有更多的数据，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
InputStream.read(byte[], int, int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从此输入流中将最多 len 个字节的数据读入一个 byte 数组中。如果 len 不为 0，则在输入可用之前，该方法将阻塞；否则，不读取任何字节并返回 0。

覆盖：
类 InputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
off - 目标数组 b 中的起始偏移量。
len - 读取的最大字节数。
返回：
读入缓冲区的字节总数，如果因为已经到达文件末尾而没有更多的数据，则返回 -1。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负、len 为负，或者 len 大于 b.length - off
IOException - 如果发生 I/O 错误。
另请参见：
InputStream.read()

skip

public long skip(long n)
          throws IOException
从输入流中跳过并丢弃 n 个字节的数据。

出于各种原因，skip 方法最终跳过的字节数可能更少一些，甚至可能为 0。如果 n 为负，则抛出 IOException，即使 InputStream 超类的 skip 方法在这种情况下没有执行任何操作。返回实际跳过的字节数。

此方法跳过的字节可能多于底层实现文件中剩余的字节。这不会产生异常，并且跳过的字节数可能包括底层实现文件的 EOF（文件结束符）之后的一些字节数。如果试图在跳过末尾之后读取流，那么会返回 -1（指示文件结束）。

覆盖：
类 InputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
实际跳过的字节数。
抛出：
IOException - 如果 n 为负，如果该流不支持查找操作，或者发生 I/O 错误。

available

public int available()
              throws IOException
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。下一次调用可能是同一个线程，也可能是另一个线程。一次读取或跳过此数量个字节不会发生阻塞，但读取或跳过的字节可能小于该数。

在某些情况下，非阻塞的读取（或跳过）操作在执行很慢时看起来受阻塞，例如，在网速缓慢的网络上读取大文件时。

覆盖：
类 InputStream 中的 available
返回：
可以不受阻塞地从此输入流中读取（或跳过）的估计剩余字节数。
抛出：
IOException - 如果此文件输入流已通过调用 close 关闭，或者发生 I/O 错误。

close

public void close()
           throws IOException
关闭此文件输入流并释放与此流有关的所有系统资源。

如果此流有一个与之关联的通道，则关闭该通道。

指定者：
接口 Closeable 中的 close
覆盖：
类 InputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。

getFD

public final FileDescriptor getFD()
                           throws IOException
返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。

返回：
与此流有关的文件描述符对象。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FileDescriptor

getChannel

public FileChannel getChannel()
返回与此文件输入流有关的唯一 FileChannel 对象。

所返回通道的初始 position 将等于到目前为止从文件中读取的字节数。从此流中读取的字节会使通道的位置递增。显式地或通过读取来更改通道的位置会更改此流的文件位置。

返回：
与此文件输入流有关的文件通道
从以下版本开始：
1.4

finalize

protected void finalize()
                 throws IOException
确保在不再引用文件输入流时调用其 close 方法。

覆盖：
类 Object 中的 finalize
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
close()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilenameFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 FilenameFilter

public interface FilenameFilter

实现此接口的类实例可用于过滤器文件名。Abstract Window Toolkit 的文件对话框组件使用这些实例过滤 File 类的 list 方法中的目录清单。

从以下版本开始：
JDK1.0
另请参见：
FileDialog.setFilenameFilter(java.io.FilenameFilter), File, File.list(java.io.FilenameFilter)

方法摘要
 boolean accept(File dir, String name)
测试指定文件是否应该包含在某一文件列表中。

方法详细信息

accept

boolean accept(File dir,
               String name)
测试指定文件是否应该包含在某一文件列表中。

参数：
dir - 被找到的文件所在的目录。
name - 文件的名称。
返回：
当且仅当该名称应该包含在文件列表中时返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FileNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.FileNotFoundException
所有已实现的接口：
Serializable
public class FileNotFoundException
extends IOException

当试图打开指定路径名表示的文件失败时，抛出此异常。

在不存在具有指定路径名的文件时，此异常将由 FileInputStream、FileOutputStream 和 RandomAccessFile 构造方法抛出。如果该文件存在，但是由于某些原因不可访问，比如试图打开一个只读文件进行写入，则此时这些构造方法仍然会抛出该异常。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
FileNotFoundException()
使用 null 作为错误详细消息构造 FileNotFoundException。
FileNotFoundException(String s)
构造带有指定详细消息的 FileNotFoundException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FileNotFoundException

public FileNotFoundException()
使用 null 作为错误详细消息构造 FileNotFoundException。

FileNotFoundException

public FileNotFoundException(String s)
构造带有指定详细消息的 FileNotFoundException。然后可以通过 java.lang.Throwable 类的 Throwable.getMessage() 方法获取字符串 s。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FileOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FileOutputStream
所有已实现的接口：
Closeable, Flushable
public class FileOutputStream
extends OutputStream

文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。文件是否可用或能否可以被创建取决于基础平台。特别是某些平台一次只允许一个 FileOutputStream（或其他文件写入对象）打开文件进行写入。在这种情况下，如果所涉及的文件已经打开，则此类中的构造方法将失败。

FileOutputStream 用于写入诸如图像数据之类的原始字节的流。要写入字符流，请考虑使用 FileWriter。

从以下版本开始：
JDK1.0
另请参见：
File, FileDescriptor, FileInputStream

构造方法摘要
FileOutputStream(File file)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(File file, boolean append)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(FileDescriptor fdObj)
创建一个向指定文件描述符处写入数据的输出文件流，该文件描述符表示一个到文件系统中的某个实际文件的现有连接。
FileOutputStream(String name)
创建一个向具有指定名称的文件中写入数据的输出文件流。
FileOutputStream(String name, boolean append)
创建一个向具有指定 name 的文件中写入数据的输出文件流。
方法摘要
void | close() 关闭此文件输出流并释放与此流有关的所有系统资源。
protected void | finalize() 清理到文件的连接，并确保在不再引用此文件输出流时调用此流的 close 方法。
FileChannel | getChannel() 返回与此文件输出流有关的唯一 FileChannel 对象。
FileDescriptor | getFD() 返回与此流有关的文件描述符。
void | write(byte[] b) 将 b.length 个字节从指定 byte 数组写入此文件输出流中。
void | write(byte[] b, int off, int len) 将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此文件输出流。
void | write(int b) 将指定字节写入此文件输出流。
从类 java.io.OutputStream 继承的方法
flush
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileOutputStream

public FileOutputStream(String name)
                 throws FileNotFoundException
创建一个向具有指定名称的文件中写入数据的输出文件流。创建一个新 FileDescriptor 对象来表示此文件连接。

首先，如果有安全管理器，则用 name 作为参数调用 checkWrite 方法。

如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它，则抛出 FileNotFoundException。

参数：
name - 与系统有关的文件名
抛出：
FileNotFoundException - 如果文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它
SecurityException - 如果存在安全管理器，且其 checkWrite 方法拒绝对文件进行写入访问。
另请参见：
SecurityManager.checkWrite(java.lang.String)

FileOutputStream

public FileOutputStream(String name,
                        boolean append)
                 throws FileNotFoundException
创建一个向具有指定 name 的文件中写入数据的输出文件流。如果第二个参数为 true，则将字节写入文件末尾处，而不是写入文件开始处。创建一个新 FileDescriptor 对象来表示此文件连接。

首先，如果有安全管理器，则用 name 作为参数调用 checkWrite 方法。

如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它，则抛出 FileNotFoundException。

参数：
name - 与系统有关的文件名
append - 如果为 true，则将字节写入文件末尾处，而不是写入文件开始处
抛出：
FileNotFoundException - 如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它。
SecurityException - 如果存在安全管理器，且其 checkWrite 方法拒绝对文件进行写入访问。
从以下版本开始：
JDK1.1
另请参见：
SecurityManager.checkWrite(java.lang.String)

FileOutputStream

public FileOutputStream(File file)
                 throws FileNotFoundException
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。创建一个新 FileDescriptor 对象来表示此文件连接。

首先，如果有安全管理器，则用 file 参数表示的路径作为参数来调用 checkWrite 方法。

如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开，则抛出 FileNotFoundException。

参数：
file - 为了进行写入而打开的文件。
抛出：
FileNotFoundException - 如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开
SecurityException - 如果存在安全管理器，且其 checkWrite 方法拒绝对文件进行写入访问。
另请参见：
File.getPath(), SecurityException, SecurityManager.checkWrite(java.lang.String)

FileOutputStream

public FileOutputStream(File file,
                        boolean append)
                 throws FileNotFoundException
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。如果第二个参数为 true，则将字节写入文件末尾处，而不是写入文件开始处。创建一个新 FileDescriptor 对象来表示此文件连接。

首先，如果有安全管理器，则用 file 参数表示的路径作为参数来调用 checkWrite 方法。

如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它，则抛出 FileNotFoundException。

参数：
file - 为了进行写入而打开的文件。
append - 如果为 true，则将字节写入文件末尾处，而不是写入文件开始处
抛出：
FileNotFoundException - 如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它
SecurityException - 如果存在安全管理器，且其 checkWrite 方法拒绝对文件进行写入访问。
从以下版本开始：
1.4
另请参见：
File.getPath(), SecurityException, SecurityManager.checkWrite(java.lang.String)

FileOutputStream

public FileOutputStream(FileDescriptor fdObj)
创建一个向指定文件描述符处写入数据的输出文件流，该文件描述符表示一个到文件系统中的某个实际文件的现有连接。

首先，如果有安全管理器，则用文件描述符 fdObj 参数作为参数来调用 checkRead 方法。

参数：
fdObj - 为进行写入而打开的文件描述符
抛出：
SecurityException - 如果存在安全管理器，且其 checkWrite 方法拒绝对文件描述符进行写入访问
另请参见：
SecurityManager.checkWrite(java.io.FileDescriptor)
方法详细信息

write

public void write(int b)
           throws IOException
将指定字节写入此文件输出流。实现 OutputStream 的 write 方法。

指定者：
类 OutputStream 中的 write
参数：
b - 要写入的字节。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b)
           throws IOException
将 b.length 个字节从指定 byte 数组写入此文件输出流中。

覆盖：
类 OutputStream 中的 write
参数：
b - 数据。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
OutputStream.write(byte[], int, int)

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此文件输出流。

覆盖：
类 OutputStream 中的 write
参数：
b - 数据。
off - 数据中的起始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。

close

public void close()
           throws IOException
关闭此文件输出流并释放与此流有关的所有系统资源。此文件输出流不能再用于写入字节。

如果此流有一个与之关联的通道，则关闭该通道。

指定者：
接口 Closeable 中的 close
覆盖：
类 OutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。

getFD

public final FileDescriptor getFD()
                           throws IOException
返回与此流有关的文件描述符。

返回：
表示到文件系统中的某个文件的连接的 FileDescriptor 对象，该文件系统正被此 FileOutputStream 对象使用。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FileDescriptor

getChannel

public FileChannel getChannel()
返回与此文件输出流有关的唯一 FileChannel 对象。

所返回通道的初始 java.nio.channels.FileChannel#position()position 将等于到目前为止从文件中读取的字节数，除非此流处于挂起模式，在这种情况下，它将等于文件的大小。将字节写入此流中会使通道的位置相应地增加。显式地或通过写入来更改通道的位置会更改此流的文件位置。

返回：
与此文件输出流有关的文件通道
从以下版本开始：
1.4

finalize

protected void finalize()
                 throws IOException
清理到文件的连接，并确保在不再引用此文件输出流时调用此流的 close 方法。

覆盖：
类 Object 中的 finalize
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FileInputStream.close()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilePermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FilePermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.io.FilePermission
所有已实现的接口：
Serializable, Guard
public final class FilePermission
extends Permission
implements Serializable

此类表示对文件和目录的访问。FilePermission 由路径名和对该路径名有效的操作集合组成。

路径名是授予指定操作的文件或目录的路径名。以 "/*"（其中 "/" 是文件分隔符字符，即 File.separatorChar）结尾的路径名指示包含在该目录中的所有文件和目录。以 "/-" 结尾的路径名（递归地）指示包含在该目录中的所有文件和子目录。由特殊标记 "<<ALL FILES>>" 组成的路径名可匹配任何文件。

注：由单个 "*" 组成的路径名指示当前目录中的所有文件，而由单个 "-" 组成的路径名指示当前目录中的所有文件，并（递归地）指示包含在当前目录中的所有文件和子目录。

将所要授予的操作以字符串的形式传递给构造方法，该字符串包含由一个或多个用逗号分隔的关键字组成的列表。可能的关键字有 "read"、"write"、"execute" 和 "delete"。其含义定义如下：

read
读权限
write
写权限
execute
执行权限。允许调用 Runtime.exec。对应于 SecurityManager.checkExec。
delete
删除权限。允许调用 File.delete。对应于 SecurityManager.checkDelete。

处理前会将操作字符串转换为小写字母。

在授予 FilePermission 权限时要小心。在对各种文件和目录授予读访问权和（尤其是）写访问权时，一定要慎重。对写操作授予 "<<ALL FILES>>" 权限特别危险。这允许对整个文件系统进行写操作。事实上它甚至允许对系统中的二进制文件（包括 JVM 运行时环境）进行替换。

请注意：代码总是可以读取自身所在目录（或该目录的子目录）中的文件，不需要对其进行显式授权。

从以下版本开始：
1.2
另请参见：
Permission, Permissions, PermissionCollection

构造方法摘要
FilePermission(String path, String actions)
创建具有指定操作的新 FilePermission 对象，path 是文件或目录的路径名，actions 包含对文件或目录授予的所需操作的列表，该列表由逗号分隔。
方法摘要
boolean | equals(Object obj) 检查两个 FilePermission 对象是否相等。
String | getActions() 返回操作的“规范化字符串表示形式”。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查 FilePermission 对象是否“隐含”指定的权限。
PermissionCollection | newPermissionCollection() 返回用于存储 FilePermission 对象的新 PermissionCollection 对象。
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

FilePermission

public FilePermission(String path,
                      String actions)
创建具有指定操作的新 FilePermission 对象，path 是文件或目录的路径名，actions 包含对文件或目录授予的所需操作的列表，该列表由逗号分隔。可能的操作有 "read"、"write"、"execute" 和 "delete"。

以 "/*"（其中 "/" 是文件分隔符，即 File.separatorChar）结尾的路径名指示所有包含在该目录中的文件和目录。以 "/-" 结尾的路径名（递归地）指示包含在该目录中的所有文件和子目录。特殊路径名 "<<ALL FILES>>" 与任意文件都匹配。

由单个 "*" 组成的路径名指示当前目录中的所有文件，而由单个 "-" 组成的路径名指示当前目录中的所有文件，并（递归地）指示包含在当前目录中的所有文件和子目录。

包含空字符串的路径名表示一个空路径。

参数：
path - 文件/目录的路径名。
actions - 操作字符串。
抛出：
IllegalArgumentException - 如果 actions 为 null 或空，或者包含一个除指定可能的操作之外的操作。
方法详细信息

implies

public boolean implies(Permission p)
检查 FilePermission 对象是否“隐含”指定的权限。

更明确地说，如果此方法满足以下条件，则返回 true：

  • p 是 FilePermission 的一个实例，

  • p 的操作是此对象的操作的一个真子集，并且

  • 此对象的路径名隐含 p 的路径名。例如，"/tmp/*" 隐含 "/tmp/foo"，因为 "/tmp/*" 涵盖 "/tmp" 目录中所有文件，包括命名为 "foo" 的文件。

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果指定的权限不为 null 并且此对象隐含该权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 FilePermission 对象是否相等。检查 obj 是否是一个 FilePermission，是否与此对象具有相同的路径名和操作。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 是一个 FilePermission，并且与此 FilePermission 对象具有相同的路径名和操作，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回操作的“规范化字符串表示形式”。也就是说，此方法总是以下列顺序返回存在的操作：read、write、execute、delete。例如，如果此 FilePermission 对象允许写和读操作，则调用 getActions 将返回字符串 "read,write"。

指定者：
类 Permission 中的 getActions
返回：
操作的规范化字符串表示形式。

newPermissionCollection

public PermissionCollection newPermissionCollection()
返回用于存储 FilePermission 对象的新 PermissionCollection 对象。

FilePermission 对象必须以允许将它们按任意顺序插入集合的方式来存储，但同时也允许以有效（并一致）的方式实现 PermissionCollection 的 implies 方法。

例如，如果有两个 FilePermissions：

  1. "/tmp/-", &\quot;read"
  2. "/tmp/scratch/foo", "write"

并且您正利用 FilePermission 权限调用 implies 方法：

   "/tmp/scratch/foo", "read,write",
那么 implies 函数必须对 "/tmp/-" 和 "/tmp/scratch/foo" 这两种权限都进行考虑，因此有效权限是 "read,write"，并且 implies 返回 true。FilePermission 的 "implies" 语义由此 newPermissionCollection 方法返回的 PermissionCollection 对象恰当地处理。

覆盖：
类 Permission 中的 newPermissionCollection
返回：
适合存储 FilePermissions 的新 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FileReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.InputStreamReader
            继承者  java.io.FileReader
所有已实现的接口：
Closeable, Readable
public class FileReader
extends InputStreamReader

用来读取字符文件的便捷类。此类的构造方法假定默认字符编码和默认字节缓冲区大小都是适当的。要自己指定这些值，可以先在 FileInputStream 上构造一个 InputStreamReader。

FileReader 用于读取字符流。要读取原始字节流，请考虑使用 FileInputStream。

从以下版本开始：
JDK1.1
另请参见：
InputStreamReader, FileInputStream

字段摘要
从类 java.io.Reader 继承的字段
lock
构造方法摘要
FileReader(File file)
在给定从中读取数据的 File 的情况下创建一个新 FileReader。
FileReader(FileDescriptor fd)
在给定从中读取数据的 FileDescriptor 的情况下创建一个新 FileReader。
FileReader(String fileName)
在给定从中读取数据的文件名的情况下创建一个新 FileReader。
方法摘要
从类 java.io.InputStreamReader 继承的方法
close, getEncoding, read, read, ready
从类 java.io.Reader 继承的方法
mark, markSupported, read, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileReader

public FileReader(String fileName)
           throws FileNotFoundException
在给定从中读取数据的文件名的情况下创建一个新 FileReader。

参数：
fileName - 要从中读取数据的文件的名称
抛出：
FileNotFoundException - 如果指定文件不存在，或者它是一个目录，而不是一个常规文件，抑或因为其他某些原因而无法打开进行读取。

FileReader

public FileReader(File file)
           throws FileNotFoundException
在给定从中读取数据的 File 的情况下创建一个新 FileReader。

参数：
file - 要从中读取数据的 File
抛出：
FileNotFoundException - 如果文件不存在，或者它是一个目录，而不是一个常规文件，抑或因为其他某些原因而无法打开进行读取。

FileReader

public FileReader(FileDescriptor fd)
在给定从中读取数据的 FileDescriptor 的情况下创建一个新 FileReader。

参数：
fd - 要从中读取数据的 FileDescriptor
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FileWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.OutputStreamWriter
            继承者  java.io.FileWriter
所有已实现的接口：
Closeable, Flushable, Appendable
public class FileWriter
extends OutputStreamWriter

用来写入字符文件的便捷类。此类的构造方法假定默认字符编码和默认字节缓冲区大小都是可接受的。要自己指定这些值，可以先在 FileOutputStream 上构造一个 OutputStreamWriter。

文件是否可用或是否可以被创建取决于底层平台。特别是某些平台一次只允许一个 FileWriter（或其他文件写入对象）打开文件进行写入。在这种情况下，如果所涉及的文件已经打开，则此类中的构造方法将失败。

FileWriter 用于写入字符流。要写入原始字节流，请考虑使用 FileOutputStream。

从以下版本开始：
JDK1.1
另请参见：
OutputStreamWriter, FileOutputStream

字段摘要
从类 java.io.Writer 继承的字段
lock
构造方法摘要
FileWriter(File file)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(File file, boolean append)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(FileDescriptor fd)
构造与某个文件描述符相关联的 FileWriter 对象。
FileWriter(String fileName)
根据给定的文件名构造一个 FileWriter 对象。
FileWriter(String fileName, boolean append)
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。
方法摘要
从类 java.io.OutputStreamWriter 继承的方法
close, flush, getEncoding, write, write, write
从类 java.io.Writer 继承的方法
append, append, append, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileWriter

public FileWriter(String fileName)
           throws IOException
根据给定的文件名构造一个 FileWriter 对象。

参数：
fileName - 一个字符串，表示与系统有关的文件名。
抛出：
IOException - 如果指定文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它

FileWriter

public FileWriter(String fileName,
                  boolean append)
           throws IOException
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。

参数：
fileName - 一个字符串，表示与系统有关的文件名。
append - 一个 boolean 值，如果为 true，则将数据写入文件末尾处，而不是写入文件开始处。
抛出：
IOException - 如果指定文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它

FileWriter

public FileWriter(File file)
           throws IOException
根据给定的 File 对象构造一个 FileWriter 对象。

参数：
file - 要写入数据的 File 对象。
抛出：
IOException - 如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它

FileWriter

public FileWriter(File file,
                  boolean append)
           throws IOException
根据给定的 File 对象构造一个 FileWriter 对象。如果第二个参数为 true，则将字节写入文件末尾处，而不是写入文件开始处。

参数：
file - 要写入数据的 File 对象
append - 如果为 true，则将字节写入文件末尾处，而不是写入文件开始处
抛出：
IOException - 如果该文件存在，但它是一个目录，而不是一个常规文件；或者该文件不存在，但无法创建它；抑或因为其他某些原因而无法打开它
从以下版本开始：
1.4

FileWriter

public FileWriter(FileDescriptor fd)
构造与某个文件描述符相关联的 FileWriter 对象。

参数：
fd - 要写入数据的 FileDescriptor 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilterInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FilterInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
所有已实现的接口：
Closeable
直接已知子类：
BufferedInputStream, CheckedInputStream, CipherInputStream, DataInputStream, DeflaterInputStream, DigestInputStream, InflaterInputStream, LineNumberInputStream, ProgressMonitorInputStream, PushbackInputStream
public class FilterInputStream
extends InputStream

FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。FilterInputStream 类本身只是简单地重写那些将所有请求传递给所包含输入流的 InputStream 的所有方法。FilterInputStream 的子类可进一步重写这些方法中的一些方法，并且还可以提供一些额外的方法和字段。

从以下版本开始：
JDK1.0

字段摘要
protected  InputStream in
要过滤的输入流。
构造方法摘要
protected FilterInputStream(InputStream in)
将参数 in 分配给字段 this.in，以便记住它供以后使用，通过这种方式创建一个 FilterInputStream。
方法摘要
int | available() 返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
void | close() 关闭此输入流并释放与此流关联的所有系统资源。
void | mark(int readlimit) 在输入流中的当前位置上作标记。
boolean | markSupported() 测试此输入流是否支持 mark 和 reset 方法。
int | read() 从此输入流中读取下一个数据字节。
int | read(byte[] b) 从此输入流中将 byte.length 个字节的数据读入一个 byte 数组中。
int | read(byte[] b, int off, int len) 从此输入流中将 len 个字节的数据读入一个 byte 数组中。
void | reset() 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
long | skip(long n) 跳过和丢弃此输入流中数据的 n 个字节。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

in

protected volatile InputStream in
要过滤的输入流。

构造方法详细信息

FilterInputStream

protected FilterInputStream(InputStream in)
将参数 in 分配给字段 this.in，以便记住它供以后使用，通过这种方式创建一个 FilterInputStream。

参数：
in - 底层输入流，如果要在没有底层流的情况下创建此实例，则该参数为 null。
方法详细信息

read

public int read()
         throws IOException
从此输入流中读取下一个数据字节。返回一个 0 到 255 范围内的 int 字节值。如果因为已经到达流末尾而没有字节可用，则返回 -1。在输入数据可用、检测到流末尾或抛出异常之前，此方法将一直阻塞。

此方法只执行 in.read() 并返回结果。

指定者：
类 InputStream 中的 read
返回：
下一个数据字节；如果已到达流末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
in

read

public int read(byte[] b)
         throws IOException
从此输入流中将 byte.length 个字节的数据读入一个 byte 数组中。在某些输入可用之前，此方法将阻塞。

此方法只执行 read(b, 0, b.length) 调用并返回结果。注意到它不 执行 in.read(b) 很重要；FilterInputStream 的某些子类依赖于实际使用的实现策略。

覆盖：
类 InputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
返回：
读入缓冲区的字节总数，如果因为已经到达流末尾而没有更多的数据，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
read(byte[], int, int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从此输入流中将 len 个字节的数据读入一个 byte 数组中。如果 len 不为 0，则在输入可用前，此方法将阻塞；否则，不读取任何字节并且返回 0。

此方法只执行 in.read(b, off, len) 并返回结果。

覆盖：
类 InputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
off - 目标数组 b 中的起始偏移量。
len - 读取的最大字节数。
返回：
读入缓冲区的字节总数，如果因为已经到达流末尾而没有更多的数据，则返回 -1。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负、len 为负，或者 len 大于 b.length - off
IOException - 如果发生 I/O 错误。
另请参见：
in

skip

public long skip(long n)
          throws IOException
跳过和丢弃此输入流中数据的 n 个字节。出于各种原因，skip 方法结束时跳过的字节数可能小于该数，也可能为 0。导致这种情况的原因很多，跳过 n 个字节之前已到达文件末尾只是其中一种可能。返回跳过的实际字节数。如果 n 为负，则不跳过任何字节。

此类的 skip 方法创建一个 byte 数组，然后重复将字节读入其中，直到读够 n 个字节或已到达流末尾为止。建议子类提供此方法更为有效的实现。例如，可依赖搜索能力的实现。

此方法只执行 in.skip(n)。

覆盖：
类 InputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。
抛出：
IOException - 如果流不支持搜索，或者发生其他 I/O 错误。

available

public int available()
              throws IOException
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。下一个调用者可能是同一个线程，也可能是另一个线程。一次读取或跳过此数量个字节不会发生阻塞，但读取或跳过的字节可能小于该数。

此方法返回 in.available() 的结果。

覆盖：
类 InputStream 中的 available
返回：
可以不受阻塞地从此输入流中读取（或跳过）的估计字节数。
抛出：
IOException - 如果发生 I/O 错误。

close

public void close()
           throws IOException
关闭此输入流并释放与此流关联的所有系统资源。此方法只执行 in.close()。

指定者：
接口 Closeable 中的 close
覆盖：
类 InputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
in

mark

public void mark(int readlimit)
在输入流中的当前位置上作标记。reset 方法的后续调用将此流重新定位在最后标记的位置上，以便后续读取操作重新读取相同的字节。

readlimit 参数告知此输入流在标记位置无效之前允许读取的字节数。

此方法只执行 in.mark(readlimit)。

覆盖：
类 InputStream 中的 mark
参数：
readlimit - 在标记位置变得无效前可以读取字节的最大限制。
另请参见：
in, reset()

reset

public void reset()
           throws IOException
将此流重新定位到对此输入流最后调用 mark 方法时的位置。

此方法只执行 in.reset()。

在需要提前读取一小部分数据以查看流中有什么的情况下，可以使用流的标记。通过调用通用解析器常常最容易做到这一点。如果流属于通过解析处理的类型，那么解析起来就很容易。如果流不属于那种类型，那么解析器应该在解析失败时抛出一个异常。如果这发生在 readlimit 个字节内，那么它允许外部代码重置流，并尝试另一种解析器。

覆盖：
类 InputStream 中的 reset
抛出：
IOException - 如果已经标记了该流，或者标记已经无效。
另请参见：
in, mark(int)

markSupported

public boolean markSupported()
测试此输入流是否支持 mark 和 reset 方法。此方法只执行 in.markSupported()。

覆盖：
类 InputStream 中的 markSupported
返回：
如果此流类型支持 mark 和 reset 方法，则返回 true；否则返回 false。
另请参见：
in, InputStream.mark(int), InputStream.reset()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilterOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FilterOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
所有已实现的接口：
Closeable, Flushable
直接已知子类：
BufferedOutputStream, CheckedOutputStream, CipherOutputStream, DataOutputStream, DeflaterOutputStream, DigestOutputStream, InflaterOutputStream, PrintStream
public class FilterOutputStream
extends OutputStream

此类是过滤输出流的所有类的超类。这些流位于已存在的输出流（基础 输出流）之上，它们将已存在的输出流作为其基本数据接收器，但可能直接传输数据或提供一些额外的功能。

FilterOutputStream 类本身只是简单地重写那些将所有请求传递给所包含输出流的 OutputStream 的所有方法。FilterOutputStream 的子类可进一步地重写这些方法中的一些方法，并且还可以提供一些额外的方法和字段。

从以下版本开始：
JDK1.0

字段摘要
protected  OutputStream out
要过滤的基础输出流。
构造方法摘要
FilterOutputStream(OutputStream out)
创建一个构建在指定基础输出流之上的输出流过滤器。
方法摘要
void | close() 关闭此输出流并释放与此流有关的所有系统资源。
void | flush() 刷新此输出流，并强制将所有已缓冲的输出字节写入该流中。
void | write(byte[] b) 将 b.length 个字节写入此输出流。
void | write(byte[] b, int off, int len) 将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
void | write(int b) 将指定 byte 写入此输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

out

protected OutputStream out
要过滤的基础输出流。

构造方法详细信息

FilterOutputStream

public FilterOutputStream(OutputStream out)
创建一个构建在指定基础输出流之上的输出流过滤器。

参数：
out - 分配给字段 this.out 以便以后使用的基础输出流，如果将在没有底层流的情况下创建此实例，则该参数为 null。
方法详细信息

write

public void write(int b)
           throws IOException
将指定 byte 写入此输出流。

FilterOutputStream 的 write 方法调用其基础输出流的 write 方法，也就是说，它执行 out.write(b)。

实现 OutputStream 的抽象 write 方法。

指定者：
类 OutputStream 中的 write
参数：
b - byte。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b)
           throws IOException
将 b.length 个字节写入此输出流。

FilterOutputStream 的 write 方法将 b、0 和 b.length 作为三个参数来调用 write 方法。

注意，此方法不调用其底层流的只带有单个参数 b 的 write 方法。

覆盖：
类 OutputStream 中的 write
参数：
b - 要写入的数据。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
write(byte[], int, int)

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。

FilterOutputStream 的 write 方法依次调用带一个参数的 write 方法来输出每个 byte。

注意，此方法不会调用其基础输入流的带有相同参数的 write 方法。FilterOutputStream 的子类应该提供此方法更有效的实现。

覆盖：
类 OutputStream 中的 write
参数：
b - 数据。
off - 数据中的起始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
write(int)

flush

public void flush()
           throws IOException
刷新此输出流，并强制将所有已缓冲的输出字节写入该流中。

FilterOutputStream 的 flush 方法调用其基础输出流的 flush 方法。

指定者：
接口 Flushable 中的 flush
覆盖：
类 OutputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
out

close

public void close()
           throws IOException
关闭此输出流并释放与此流有关的所有系统资源。

FilterOutputStream 的 close 方法先调用其 flush 方法，然后调用其基础输出流的 close 方法。

指定者：
接口 Closeable 中的 close
覆盖：
类 OutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
flush(), out
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilterReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FilterReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.FilterReader
所有已实现的接口：
Closeable, Readable
直接已知子类：
PushbackReader
public abstract class FilterReader
extends Reader

用于读取已过滤的字符流的抽象类。抽象类 FilterReader 自身提供了一些将所有请求传递给所包含的流的默认方法。FilterReader 的子类应重写这些方法中的一些方法，并且还可以提供一些额外的方法和字段。

从以下版本开始：
JDK1.1

字段摘要
protected  Reader in
底层字符输入流。
从类 java.io.Reader 继承的字段
lock
构造方法摘要
protected FilterReader(Reader in)
创建一个新的 filtered reader。
方法摘要
 void close()
关闭该流并释放与之关联的所有资源。
 void mark(int readAheadLimit)
在流中的当前位置上作标记。
 boolean markSupported()
判断此流是否支持 mark() 操作。
 int read()
读取单个字符。
 int read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 boolean ready()
判断此流是否已经准备好用于读取。
 void reset()
重置该流。
 long skip(long n)
跳过某些字符。
从类 java.io.Reader 继承的方法
read, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

in

protected Reader in
底层字符输入流。

构造方法详细信息

FilterReader

protected FilterReader(Reader in)
创建一个新的 filtered reader。

参数：
in - 提供底层流的 Reader 对象。
抛出：
NullPointerException - 如果 in 为 null
方法详细信息

read

public int read()
         throws IOException
读取单个字符。

覆盖：
类 Reader 中的 read
返回：
作为整数读取的字符，范围在 0 到 65535 之间 (0x00-0xffff)，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException
将字符读入数组的某一部分。

指定者：
类 Reader 中的 read
参数：
cbuf - 目标缓冲区
off - 开始存储字符处的偏移量
len - 要读取的最多字符数
返回：
读取的字符数，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

skip

public long skip(long n)
          throws IOException
跳过某些字符。

覆盖：
类 Reader 中的 skip
参数：
n - 要跳过的字符数
返回：
实际跳过的字符数
抛出：
IOException - 如果发生 I/O 错误

ready

public boolean ready()
              throws IOException
判断此流是否已经准备好用于读取。

覆盖：
类 Reader 中的 ready
返回：
如果保证下一个 read() 不阻塞输入，则返回 True，否则返回 false。注意，返回 false 并不保证阻塞下一次读取。
抛出：
IOException - 如果发生 I/O 错误

markSupported

public boolean markSupported()
判断此流是否支持 mark() 操作。

覆盖：
类 Reader 中的 markSupported
返回：
当且仅当此流支持此 mark 操作时，返回 true。

mark

public void mark(int readAheadLimit)
          throws IOException
在流中的当前位置上作标记。

覆盖：
类 Reader 中的 mark
参数：
readAheadLimit - 在仍保留该标记的情况下，对可读取字符数量的限制。在读取这样多的字符后，尝试重置流可能会失败。
抛出：
IOException - 如果发生 I/O 错误

reset

public void reset()
           throws IOException
重置该流。

覆盖：
类 Reader 中的 reset
抛出：
IOException - 如果发生 I/O 错误

close

public void close()
           throws IOException
从类 Reader 复制的描述
关闭该流并释放与之关联的所有资源。在关闭该流后，再调用 read()、ready()、mark()、reset() 或 skip() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Reader 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilterWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 FilterWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.FilterWriter
所有已实现的接口：
Closeable, Flushable, Appendable
public abstract class FilterWriter
extends Writer

用于写入已过滤的字符流的抽象类。抽象类 FilterWriter 自身提供了一些将所有请求传递给所包含的流的默认方法。FilterWriter 的子类应重写这些方法中的一些方法，并且还可以提供一些额外的方法和字段。

从以下版本开始：
JDK1.1

字段摘要
protected  Writer out
底层字符输出流。
从类 java.io.Writer 继承的字段
lock
构造方法摘要
protected FilterWriter(Writer out)
创建一个新的 filtered writer。
方法摘要
void | close() 关闭此流，但要先刷新它。
void | flush() 刷新该流的缓冲。
void | write(char[] cbuf, int off, int len) 将字符写入数组的某一部分。
void | write(int c) 写入单个字符。
void | write(String str, int off, int len) 写入一部分字符串。
从类 java.io.Writer 继承的方法
append, append, append, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

out

protected Writer out
底层字符输出流。

构造方法详细信息

FilterWriter

protected FilterWriter(Writer out)
创建一个新的 filtered writer。

参数：
out - 提供底层流的 Writer 对象。
抛出：
NullPointerException - 如果 out 为 null
方法详细信息

write

public void write(int c)
           throws IOException
写入单个字符。

覆盖：
类 Writer 中的 write
参数：
c - 指定要写入字符的 int。
抛出：
IOException - 如果发生 I/O 错误

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
将字符写入数组的某一部分。

指定者：
类 Writer 中的 write
参数：
cbuf - 要写入的字符缓冲区
off - 偏移量，从该处开始读取字符
len - 要写入字符的数量
抛出：
IOException - 如果发生 I/O 错误

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
写入一部分字符串。

覆盖：
类 Writer 中的 write
参数：
str - 要写入的字符串
off - 偏移量，从该处开始读取字符
len - 要写入字符的数量
抛出：
IOException - 如果发生 I/O 错误

flush

public void flush()
           throws IOException
刷新该流的缓冲。

指定者：
接口 Flushable 中的 flush
指定者：
类 Writer 中的 flush
抛出：
IOException - 如果发生 I/O 错误

close

public void close()
           throws IOException
从类 Writer 复制的描述
关闭此流，但要先刷新它。在关闭该流之后，再调用 write() 或 flush() 将导致抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Writer 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Flushable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 Flushable

所有已知子接口：
JavaFileManager, StandardJavaFileManager
所有已知实现类：
BufferedOutputStream, BufferedWriter, ByteArrayOutputStream, CharArrayWriter, CheckedOutputStream, CipherOutputStream, Console, DataOutputStream, DeflaterOutputStream, DigestOutputStream, FileOutputStream, FileWriter, FilterOutputStream, FilterWriter, Formatter, ForwardingJavaFileManager, GZIPOutputStream, InflaterOutputStream, JarOutputStream, LogStream, ObjectOutputStream, OutputStream, OutputStream, OutputStream, OutputStreamWriter, PipedOutputStream, PipedWriter, PrintStream, PrintWriter, StringWriter, Writer, ZipOutputStream
public interface Flushable

Flushable 是可刷新数据的目标地。调用 flush 方法将所有已缓冲输出写入底层流。

从以下版本开始：
1.5

方法摘要
 void flush()
通过将所有已缓冲输出写入底层流来刷新此流。

方法详细信息

flush

void flush()
           throws IOException
通过将所有已缓冲输出写入底层流来刷新此流。

抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 InputStream

java.lang.Object
    继承者  java.io.InputStream
所有已实现的接口：
Closeable
直接已知子类：
AudioInputStream, ByteArrayInputStream, FileInputStream, FilterInputStream, InputStream, ObjectInputStream, PipedInputStream, SequenceInputStream, StringBufferInputStream
public abstract class InputStream
extends Object
implements Closeable

此抽象类是表示字节输入流的所有类的超类。

需要定义 InputStream 子类的应用程序必须总是提供返回下一个输入字节的方法。

从以下版本开始：
JDK1.0
另请参见：
BufferedInputStream, ByteArrayInputStream, DataInputStream, FilterInputStream, read(), OutputStream, PushbackInputStream

构造方法摘要
InputStream()
方法摘要
int | available() 返回此输入流下一个方法调用可以不受阻塞地从此输入流读取（或跳过）的估计字节数。
void | close() 关闭此输入流并释放与该流关联的所有系统资源。
void | mark(int readlimit) 在此输入流中标记当前的位置。
boolean | markSupported() 测试此输入流是否支持 mark 和 reset 方法。
abstract int | read() 从输入流中读取数据的下一个字节。
int | read(byte[] b) 从输入流中读取一定数量的字节，并将其存储在缓冲区数组 b 中。
int | read(byte[] b, int off, int len) 将输入流中最多 len 个数据字节读入 byte 数组。
void | reset() 将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
long | skip(long n) 跳过和丢弃此输入流中数据的 n 个字节。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputStream

public InputStream()
方法详细信息

read

public abstract int read()
                  throws IOException
从输入流中读取数据的下一个字节。返回 0 到 255 范围内的 int 字节值。如果因为已经到达流末尾而没有可用的字节，则返回值 -1。在输入数据可用、检测到流末尾或者抛出异常前，此方法一直阻塞。

子类必须提供此方法的一个实现。

返回：
下一个数据字节；如果到达流的末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

read

public int read(byte[] b)
         throws IOException
从输入流中读取一定数量的字节，并将其存储在缓冲区数组 b 中。以整数形式返回实际读取的字节数。在输入数据可用、检测到文件末尾或者抛出异常前，此方法一直阻塞。

如果 b 的长度为 0，则不读取任何字节并返回 0；否则，尝试读取至少一个字节。如果因为流位于文件末尾而没有可用的字节，则返回值 -1；否则，至少读取一个字节并将其存储在 b 中。

将读取的第一个字节存储在元素 b[0] 中，下一个存储在 b[1] 中，依次类推。读取的字节数最多等于 b 的长度。设 k 为实际读取的字节数；这些字节将存储在 b[0] 到 b[k-1] 的元素中，不影响 b[k] 到 b[b.length-1] 的元素。

类 InputStream 的 read(b) 方法的效果等同于：

 read(b, 0, b.length)

参数：
b - 存储读入数据的缓冲区。
返回：
读入缓冲区的总字节数；如果因为已经到达流末尾而不再有数据可用，则返回 -1。
抛出：
IOException - 如果不是因为流位于文件末尾而无法读取第一个字节；如果输入流已关闭；如果发生其他 I/O 错误。
NullPointerException - 如果 b 为 null。
另请参见：
read(byte[], int, int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
将输入流中最多 len 个数据字节读入 byte 数组。尝试读取 len 个字节，但读取的字节也可能小于该值。以整数形式返回实际读取的字节数。

在输入数据可用、检测到流末尾或者抛出异常前，此方法一直阻塞。

如果 len 为 0，则不读取任何字节并返回 0；否则，尝试读取至少一个字节。如果因为流位于文件末尾而没有可用的字节，则返回值 -1；否则，至少读取一个字节并将其存储在 b 中。

将读取的第一个字节存储在元素 b[off] 中，下一个存储在 b[off+1] 中，依次类推。读取的字节数最多等于 len。设 k 为实际读取的字节数；这些字节将存储在 b[off] 到 b[off+k-1] 的元素中，不影响 b[off+k] 到 b[off+len-1] 的元素。

在任何情况下，b[0] 到 b[off] 的元素以及 b[off+len] 到 b[b.length-1] 的元素都不会受到影响。

类 InputStream 的 read(b, off, len) 方法重复调用方法 read()。如果第一次这样的调用导致 IOException，则从对 read(b, off, len) 方法的调用中返回该异常。如果对 read() 的任何后续调用导致 IOException，则捕获该异常并将其视为到达文件末尾；到达该点时读取的字节存储在 b 中，并返回发生异常之前读取的字节数。在已读取输入数据 len 的请求数量、检测到文件结束标记、抛出异常前，此方法的默认实现将一直阻塞。建议子类提供此方法更为有效的实现。

参数：
b - 读入数据的缓冲区。
off - 数组 b 中将写入数据的初始偏移量。
len - 要读取的最大字节数。
返回：
读入缓冲区的总字节数；如果因为已到达流末尾而不再有数据可用，则返回 -1。
抛出：
IOException - 如果不是因为位于文件末尾而无法读取第一个字节；如果输入流已关闭；如果发生其他 I/O 错误。
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，len 为负，或者 len 大于 b.length - off
另请参见：
read()

skip

public long skip(long n)
          throws IOException
跳过和丢弃此输入流中数据的 n 个字节。出于各种原因，skip 方法结束时跳过的字节数可能小于该数，也可能为 0。导致这种情况的原因很多，跳过 n 个字节之前已到达文件末尾只是其中一种可能。返回跳过的实际字节数。如果 n 为负，则不跳过任何字节。

此类的 skip 方法创建一个 byte 数组，然后重复将字节读入其中，直到读够 n 个字节或已到达流末尾为止。建议子类提供此方法更为有效的实现。例如，可依赖搜索能力的实现。

参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。
抛出：
IOException - 如果流不支持搜索，或者发生其他 I/O 错误。

available

public int available()
              throws IOException
返回此输入流下一个方法调用可以不受阻塞地从此输入流读取（或跳过）的估计字节数。下一个调用可能是同一个线程，也可能是另一个线程。一次读取或跳过此估计数个字节不会受阻塞，但读取或跳过的字节数可能小于该数。

注意，有些 InputStream 的实现将返回流中的字节总数，但也有很多实现不会这样做。试图使用此方法的返回值分配缓冲区，以保存此流所有数据的做法是不正确的。

如果已经调用 close() 方法关闭了此输入流，那么此方法的子类实现可以选择抛出 IOException。

类 InputStream 的 available 方法总是返回 0。

此方法应该由子类重写。

返回：
可以不受阻塞地从此输入流读取（或跳过）的估计字节数；如果到达输入流末尾，则返回 0。
抛出：
IOException - 如果发生 I/O 错误。

close

public void close()
           throws IOException
关闭此输入流并释放与该流关联的所有系统资源。

InputStream 的 close 方法不执行任何操作。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误。

mark

public void mark(int readlimit)
在此输入流中标记当前的位置。对 reset 方法的后续调用会在最后标记的位置重新定位此流，以便后续读取重新读取相同的字节。

readlimit 参数告知此输入流在标记位置失效之前允许读取的字节数。

mark 的常规协定是：如果方法 markSupported 返回 true，那么输入流总是在调用 mark 之后记录所有读取的字节，并时刻准备在调用方法 reset 时（无论何时），再次提供这些相同的字节。但是，如果在调用 reset 之前可以从流中读取多于 readlimit 的字节，则不需要该流记录任何数据。

标记已关闭的流对其无效。

InputStream 的 mark 方法不执行任何操作。

参数：
readlimit - 在标记位置失效前可以读取字节的最大限制。
另请参见：
reset()

reset

public void reset()
           throws IOException
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。

reset 的常规协定是：

  • 如果方法 markSupported 返回 true，那么：
    • 如果创建流以后未调用方法 mark，或最后调用 mark 以后从该流读取的字节数大于最后调用 mark 时的参数，则可能抛出 IOException。
    • 如果未抛出这样的 IOException，则将该流重新设置为这种状态：最近一次调用 mark 以后（如果未调用过 mark，则从文件开头开始）读取的所有字节将重新提供给 read 方法的后续调用者，后跟任何从调用 reset 时起将作为下一输入数据的字节。
  • 如果方法 markSupported 返回 false，那么：
    • 对 reset 的调用可能抛出 IOException。
    • 如果未抛出 IOException，则将该流重新设置为一种固定状态，该状态取决于输入流的特定类型及其创建方式。提供给 read 方法后续调用者的字节取决于特定类型的输入流。

除了抛出 IOException 之外，类 InputStream 的方法 reset 不执行任何操作。

抛出：
IOException - 如果未标记此流或该标记失效。
另请参见：
mark(int), IOException

markSupported

public boolean markSupported()
测试此输入流是否支持 mark 和 reset 方法。是否支持 mark 和 reset 是特定输入流实例的不变属性。InputStream 的 markSupported 方法返回 false。

返回：
如果此输入流实例支持 mark 和 reset 方法，则返回 true；否则返回 false。
另请参见：
mark(int), reset()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IOError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 IOError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.io.IOError
所有已实现的接口：
Serializable
public class IOError
extends Error

当发生严重的 I/O 错误时，抛出此错误。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
IOError(Throwable cause)
构造带有指定 cause 的新 IOError 实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IOError

public IOError(Throwable cause)
构造带有指定 cause 的新 IOError 实例。IOError 是使用详细消息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）创建的。

参数：
cause - 导致此错误的原因；如果未知，则为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputStreamReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 InputStreamReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.InputStreamReader
所有已实现的接口：
Closeable, Readable
直接已知子类：
FileReader
public class InputStreamReader
extends Reader

InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。它使用的字符集可以由名称指定或显式给定，或者可以接受平台默认的字符集。

每次调用 InputStreamReader 中的一个 read() 方法都会导致从底层输入流读取一个或多个字节。要启用从字节到字符的有效转换，可以提前从底层流读取更多的字节，使其超过满足当前读取操作所需的字节。

为了达到最高效率，可要考虑在 BufferedReader 内包装 InputStreamReader。例如：

 BufferedReader in
   = new BufferedReader(new InputStreamReader(System.in));

从以下版本开始：
JDK1.1
另请参见：
BufferedReader, InputStream, Charset

字段摘要
从类 java.io.Reader 继承的字段
lock
构造方法摘要
InputStreamReader(InputStream in)
创建一个使用默认字符集的 InputStreamReader。
InputStreamReader(InputStream in, Charset cs)
创建使用给定字符集的 InputStreamReader。
InputStreamReader(InputStream in, CharsetDecoder dec)
创建使用给定字符集解码器的 InputStreamReader。
InputStreamReader(InputStream in, String charsetName)
创建使用指定字符集的 InputStreamReader。
方法摘要
void | close() 关闭该流并释放与之关联的所有资源。
String | getEncoding() 返回此流使用的字符编码的名称。
int | read() 读取单个字符。
int | read(char[] cbuf, int offset, int length) 将字符读入数组中的某一部分。
boolean | ready() 判断此流是否已经准备好用于读取。
从类 java.io.Reader 继承的方法
mark, markSupported, read, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputStreamReader

public InputStreamReader(InputStream in)
创建一个使用默认字符集的 InputStreamReader。

参数：
in - InputStream

InputStreamReader

public InputStreamReader(InputStream in,
                         String charsetName)
                  throws UnsupportedEncodingException
创建使用指定字符集的 InputStreamReader。

参数：
in - InputStream
charsetName - 受支持的 charset 的名称
抛出：
UnsupportedEncodingException - 如果不支持指定的字符集

InputStreamReader

public InputStreamReader(InputStream in,
                         Charset cs)
创建使用给定字符集的 InputStreamReader。

参数：
in - InputStream
cs - 字符集
从以下版本开始：
1.4

InputStreamReader

public InputStreamReader(InputStream in,
                         CharsetDecoder dec)
创建使用给定字符集解码器的 InputStreamReader。

参数：
in - InputStream
dec - 字符集解码器
从以下版本开始：
1.4
方法详细信息

getEncoding

public String getEncoding()
返回此流使用的字符编码的名称。

如果该编码有历史上用过的名称，则返回该名称；否则返回该编码的规范化名称。

如果使用 InputStreamReader(InputStream, String) 构造方法创建此实例，则返回的由此编码生成的唯一名称可能与传递给该构造方法的名称不一样。如果流已经关闭，则此方法将会返回 null。

返回：
此编码的历史名称，如果流已经关闭，则返回 null
另请参见：
Charset

read

public int read()
         throws IOException
读取单个字符。

覆盖：
类 Reader 中的 read
返回：
读取的字符，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] cbuf,
                int offset,
                int length)
         throws IOException
将字符读入数组中的某一部分。

指定者：
类 Reader 中的 read
参数：
cbuf - 目标缓冲区
offset - 从其处开始存储字符的偏移量
length - 要读取的最大字符数
返回：
读取的字符数，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

ready

public boolean ready()
              throws IOException
判断此流是否已经准备好用于读取。如果其输入缓冲区不为空，或者可从底层字节流读取字节，则 InputStreamReader 已做好被读取准备。

覆盖：
类 Reader 中的 ready
返回：
如果保证下一个 read() 不阻塞输入，则返回 True，否则返回 false。注意，返回 false 并不保证阻塞下一次读取。
抛出：
IOException - 如果发生 I/O 错误

close

public void close()
           throws IOException
从类 Reader 复制的描述
关闭该流并释放与之关联的所有资源。在关闭该流后，再调用 read()、ready()、mark()、reset() 或 skip() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Reader 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InterruptedIOException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 InterruptedIOException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.InterruptedIOException
所有已实现的接口：
Serializable
直接已知子类：
SocketTimeoutException
public class InterruptedIOException
extends IOException

I/O 操作已中断信号，抛出此异常。抛出 InterruptedIOException 指示输入或输出传输已经终止，原因是执行此操作的线程中断。字段 bytesTransferred 指示在发生中断之前已成功传输了多少字节。

从以下版本开始：
JDK1.0
另请参见：
InputStream, OutputStream, Thread.interrupt(), 序列化表格

字段摘要
 int bytesTransferred
报告 I/O 操作中断之前传输了其中多少字节。
构造方法摘要
InterruptedIOException()
构造一个 InterruptedIOException，使用 null 作为其错误消息。
InterruptedIOException(String s)
构造带指定详细消息的 InterruptedIOException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

bytesTransferred

public int bytesTransferred
报告 I/O 操作中断之前传输了其中多少字节。

构造方法详细信息

InterruptedIOException

public InterruptedIOException()
构造一个 InterruptedIOException，使用 null 作为其错误消息。

InterruptedIOException

public InterruptedIOException(String s)
构造带指定详细消息的 InterruptedIOException。稍后可以通过 java.lang.Throwable 类的 Throwable.getMessage() 方法获取字符串 s。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidClassException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 InvalidClassException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
                    继承者  java.io.InvalidClassException
所有已实现的接口：
Serializable
public class InvalidClassException
extends ObjectStreamException

当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。

  • 该类的序列版本号与从流中读取的类描述符的版本号不匹配
  • 该类包含未知数据类型
  • 该类没有可访问的无参数构造方法

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
 String classname
无效类的名称。
构造方法摘要
InvalidClassException(String reason)
报告指定了原因的 InvalidClassException。
InvalidClassException(String cname, String reason)
构造一个 InvalidClassException 对象。
方法摘要
 String getMessage()
生成消息并包括类名称（如果存在）。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

classname

public String classname
无效类的名称。

构造方法详细信息

InvalidClassException

public InvalidClassException(String reason)
报告指定了原因的 InvalidClassException。

参数：
reason - 描写异常原因的字符串。

InvalidClassException

public InvalidClassException(String cname,
                             String reason)
构造一个 InvalidClassException 对象。

参数：
cname - 指定无效类的字符串。
reason - 描述异常原因的字符串。
方法详细信息

getMessage

public String getMessage()
生成消息并包括类名称（如果存在）。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidObjectException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 InvalidObjectException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
                    继承者  java.io.InvalidObjectException
所有已实现的接口：
Serializable
public class InvalidObjectException
extends ObjectStreamException

指示一个或多个反序列化对象未通过验证测试。该参数应该提供失败的原因。

从以下版本开始：
JDK1.1, JDK1.1
另请参见：
ObjectInputValidation, 序列化表格

构造方法摘要
InvalidObjectException(String reason)
构造一个 InvalidObjectException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidObjectException

public InvalidObjectException(String reason)
构造一个 InvalidObjectException。

参数：
reason - 解释失败原因的详细消息。
另请参见：
ObjectInputValidation
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IOException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 IOException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
所有已实现的接口：
Serializable
直接已知子类：
ChangedCharSetException, CharacterCodingException, CharConversionException, ClosedChannelException, EOFException, FileLockInterruptionException, FileNotFoundException, FilerException, HttpRetryException, IIOException, InterruptedIOException, InvalidPropertiesFormatException, JMXProviderException, JMXServerErrorException, MalformedURLException, ObjectStreamException, ProtocolException, RemoteException, SaslException, SocketException, SSLException, SyncFailedException, UnknownHostException, UnknownServiceException, UnsupportedDataTypeException, UnsupportedEncodingException, UTFDataFormatException, ZipException
public class IOException
extends Exception

当发生某种 I/O 异常时，抛出此异常。此类是失败或中断的 I/O 操作生成的异常的通用类。

从以下版本开始：
JDK1.0
另请参见：
InputStream, OutputStream, 序列化表格

构造方法摘要
IOException()
构造一个 IOException，使用 null 作为其错误详细消息。
IOException(String message)
构造带指定详细消息的 IOException。
IOException(String message, Throwable cause)
构造带有指定详细消息和 cause 的 IOException。
IOException(Throwable cause)
构造一个 IOException，使其具有指定的 cause 以及详细消息 (cause==null ? null : cause.toString())（通常包含类和 cause 的详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IOException

public IOException()
构造一个 IOException，使用 null 作为其错误详细消息。

IOException

public IOException(String message)
构造带指定详细消息的 IOException。

参数：
message - 详细消息（保存此消息，以便 Throwable.getMessage() 方法稍后获得该消息）

IOException

public IOException(String message,
                   Throwable cause)
构造带有指定详细消息和 cause 的 IOException。

注意，关联 cause 的详细消息不会 自动合并到此异常的详细消息中。

参数：
message - 详细消息（保存此消息，以便 Throwable.getMessage() 方法稍后获得该消息）
cause - cause（保存此 cause，以便 Throwable.getCause() 方法稍后获得它）。（允许使用 null 值，它表示 cause 不存在或未知。）
从以下版本开始：
1.6

IOException

public IOException(Throwable cause)
构造一个 IOException，使其具有指定的 cause 以及详细消息 (cause==null ? null : cause.toString())（通常包含类和 cause 的详细消息）。对于与其他 throwable 的包装器没有多大差别的 IO 异常，此构造方法很有用。

参数：
cause - cause（保存此 cause，以便 Throwable.getCause() 方法稍后获得它）。（允许使用 null 值，它表示 cause 不存在或未知。）
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineNumberInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 LineNumberInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.io.LineNumberInputStream
所有已实现的接口：
Closeable
已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。

@Deprecated
public class LineNumberInputStream
extends FilterInputStream

此类是一个输入流过滤器，它提供跟踪当前行号的附加功能。

行是以回车符 ('\r')、换行符 ('\n') 或回车符后面紧跟换行符结尾的字节序列。在所有这三种情况下，都以单个换行符形式返回行终止字符。

行号以 0 开头，并在 read 返回换行符时递增 1。

从以下版本开始：
JDK1.0
另请参见：
LineNumberReader

字段摘要
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
LineNumberInputStream(InputStream in)
已过时。 构造从指定输入流读取其输入的新行号输入流。
方法摘要
int | available() 已过时。 无阻塞情况下返回可以从此输入流中读取的字节数。
int | getLineNumber() 已过时。 返回当前行号。
void | mark(int readlimit) 已过时。 在此输入流中标记当前的位置。
int | read() 已过时。 从此输入流读取下一个数据字节。
int | read(byte[] b, int off, int len) 已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
void | reset() 已过时。 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
void | setLineNumber(int lineNumber) 已过时。 将行号设置为指定参数。
long | skip(long n) 已过时。 跳过和放弃此输入流中的 n 个数据字节。
从类 java.io.FilterInputStream 继承的方法
close, markSupported, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LineNumberInputStream

public LineNumberInputStream(InputStream in)
已过时。
构造从指定输入流读取其输入的新行号输入流。

参数：
in - 基础输入流。
方法详细信息

read

public int read()
         throws IOException
已过时。
从此输入流读取下一个数据字节。返回 0 到 255 范围内的 int 字节值。如果因流的末尾已到达而没有可用的字节，则返回值 -1。在输入数据可用、检测到流的末尾或者抛出异常前，此方法一直阻塞。

LineNumberInputStream 的 read 方法调用基础输入流的 read 方法。它检查输入中的回车和换行符，并相应地修改当前行号。回车符或后跟换行符的回车两者都可转换为单个换行符。

覆盖：
类 FilterInputStream 中的 read
返回：
下一个数据字节，如果已到达此流的末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in, getLineNumber()

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
已过时。
将最多 len 个数据字节从此输入流读入 byte 数组。在某个输入可用前，此方法一直阻塞。

LineNumberInputStream 的 read 方法重复调用 0 参数的 read 方法来填充 byte 数组。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 读入数据的缓冲区。
off - 数据的初始偏移量。
len - 读取的最大字节数。
返回：
读入缓冲区的总字节数，如果由于已到达此流的末尾而不再有数据，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
read()

skip

public long skip(long n)
          throws IOException
已过时。
跳过和放弃此输入流中的 n 个数据字节。出于各种原因，该 skip 方法跳过某些较小的字节数（可能是 0）后结束。返回跳过的实际字节数。如果 n 为负，则不跳过任何字节。

LineNumberInputStream 的 skip 方法创建 byte 数组，然后重复向其读入，直到读够 n 个字节或已到达流的末尾为止。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in

setLineNumber

public void setLineNumber(int lineNumber)
已过时。
将行号设置为指定参数。

参数：
lineNumber - 新行号。
另请参见：
getLineNumber()

getLineNumber

public int getLineNumber()
已过时。
返回当前行号。

返回：
当前行号。
另请参见：
setLineNumber(int)

available

public int available()
              throws IOException
已过时。
无阻塞情况下返回可以从此输入流中读取的字节数。

注意，如果基础输入流能够在无阻塞情况下提供 k 个输入字符，则 LineNumberInputStream 可以保证在无阻塞情况下只提供 k/2 个字符，因为基础输入流中的 k 个字符可能由 k/2 个 '\r' 和 '\n' 对组成，这些对只能转换为 k/2 '\n' 个字符。

覆盖：
类 FilterInputStream 中的 available
返回：
无阻塞情况下可以从此输入流读取的字节数。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in

mark

public void mark(int readlimit)
已过时。
在此输入流中标记当前的位置。对 reset 方法的后续调用会在最后标记的位置重新定位此流，以使后续读取重新读取相同的字节。

LineNumberInputStream 的 mark 方法会记住 private 变量中的当前行号，然后调用基础输入流的 mark 方法。

覆盖：
类 FilterInputStream 中的 mark
参数：
readlimit - 在标记位置失效前可以读取字节的最大限制。
另请参见：
FilterInputStream.in, reset()

reset

public void reset()
           throws IOException
已过时。
将此流重新定位到对此输入流最后调用 mark 方法时的位置。

LineNumberInputStream 的 reset 方法会重新将行号设置为调用 mark 方法时的行号，然后调用基础输入流的 reset 方法。

在需要提前从流中读取少量数据以查看流内容的情况下，可以使用流标记。通常，调用某些常规解析器可以非常方便地完成这项工作。如果流属于解析器处理的类型，则会非常顺利地完成。如果流不属于该类型，则解析器应该在其失败时抛出异常，如果这是在 readlimit 字节内发生的，它将允许使用外部代码重新设置该流并尝试其他解析器。

覆盖：
类 FilterInputStream 中的 reset
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in, mark(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineNumberReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 LineNumberReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.BufferedReader
            继承者  java.io.LineNumberReader
所有已实现的接口：
Closeable, Readable
public class LineNumberReader
extends BufferedReader

跟踪行号的缓冲字符输入流。此类定义了方法 setLineNumber(int) 和 getLineNumber()，它们可分别用于设置和获取当前行号。

默认情况下，行编号从 0 开始。该行号随数据读取在每个行结束符处递增，并且可以通过调用 setLineNumber(int) 更改行号。但要注意的是，setLineNumber(int) 不会实际更改流中的当前位置；它只更改将由 getLineNumber() 返回的值。

可认为行在遇到以下符号之一时结束：换行符（'\n'）、回车符（'\r'）、回车后紧跟换行符。

从以下版本开始：
JDK1.1

字段摘要
从类 java.io.Reader 继承的字段
lock
构造方法摘要
LineNumberReader(Reader in)
使用默认输入缓冲区的大小创建新的行编号 reader。
LineNumberReader(Reader in, int sz)
创建新的行编号 reader，将字符读入给定大小的缓冲区。
方法摘要
int | getLineNumber() 获得当前行号。
void | mark(int readAheadLimit) 标记该流中的当前位置。
int | read() 读取单个字符。
int | read(char[] cbuf, int off, int len) 将字符读入数组中的某一部分。
String | readLine() 读取文本行。
void | reset() 将该流重新设置为最新的标记。
void | setLineNumber(int lineNumber) 设置当前行号。
long | skip(long n) 跳过字符。
从类 java.io.BufferedReader 继承的方法
close, markSupported, ready
从类 java.io.Reader 继承的方法
read, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LineNumberReader

public LineNumberReader(Reader in)
使用默认输入缓冲区的大小创建新的行编号 reader。

参数：
in - 提供底层流的 Reader 对象

LineNumberReader

public LineNumberReader(Reader in,
                        int sz)
创建新的行编号 reader，将字符读入给定大小的缓冲区。

参数：
in - 提供底层流的 Reader 对象
sz - 指定缓冲区大小的 int 值
方法详细信息

setLineNumber

public void setLineNumber(int lineNumber)
设置当前行号。

参数：
lineNumber - 指定行号的 int 值
另请参见：
getLineNumber()

getLineNumber

public int getLineNumber()
获得当前行号。

返回：
当前行号
另请参见：
setLineNumber(int)

read

public int read()
         throws IOException
读取单个字符。行结束符被压缩为一个换行（'\n'）字符。无论何时读取行结束符，当前行号将加 1。

覆盖：
类 BufferedReader 中的 read
返回：
读取的字符；如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException
将字符读入数组中的某一部分。无论何时读取行结束符，当前行号都将加 1。

覆盖：
类 BufferedReader 中的 read
参数：
cbuf - 目标缓冲区
off - 开始存储字符处的偏移量
len - 要读取的最多字符数
返回：
读取的字节数量，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

readLine

public String readLine()
                throws IOException
读取文本行。无论何时读取行结束符，当前行号都将加 1。

覆盖：
类 BufferedReader 中的 readLine
返回：
包含行内容的字符串，不包括任何行结束符；如果已到达流的末尾，则返回 null
抛出：
IOException - 如果发生 I/O 错误

skip

public long skip(long n)
          throws IOException
跳过字符。

覆盖：
类 BufferedReader 中的 skip
参数：
n - 要跳过的字符数
返回：
实际跳过的字符数
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果 n 为负

mark

public void mark(int readAheadLimit)
          throws IOException
标记该流中的当前位置。对 reset() 的后续调用会尝试重新将流定位到此点，还将相应地重新设置行号。

覆盖：
类 BufferedReader 中的 mark
参数：
readAheadLimit - 在仍保留该标记的情况下，对可读取字符数量的限制。在读取这样多的字符后，尝试重置流可能会失败。
抛出：
IOException - 如果发生 I/O 错误

reset

public void reset()
           throws IOException
将该流重新设置为最新的标记。

覆盖：
类 BufferedReader 中的 reset
抛出：
IOException - 如果该流未被标记，或者该标记已失效
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotActiveException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 NotActiveException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
                    继承者  java.io.NotActiveException
所有已实现的接口：
Serializable
public class NotActiveException
extends ObjectStreamException

当序列化和反序列化不活动时，抛出此异常。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
NotActiveException()
创建不带原因的新 NotActiveException 的构造方法。
NotActiveException(String reason)
创建带给定原因的新 NotActiveException 的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotActiveException

public NotActiveException(String reason)
创建带给定原因的新 NotActiveException 的构造方法。

参数：
reason - 描写异常原因的字符串。

NotActiveException

public NotActiveException()
创建不带原因的新 NotActiveException 的构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotSerializableException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 NotSerializableException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
                    继承者  java.io.NotSerializableException
所有已实现的接口：
Serializable
public class NotSerializableException
extends ObjectStreamException

当实例需要具有序列化接口时，抛出此异常。序列化运行时或实例的类会抛出此异常。参数应该为类的名称。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
NotSerializableException()
构造一个 NotSerializableException 对象。
NotSerializableException(String classname)
构造带消息字符串的 NotSerializableException 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotSerializableException

public NotSerializableException(String classname)
构造带消息字符串的 NotSerializableException 对象。

参数：
classname - 正进行序列化/反序列化的实例的类。

NotSerializableException

public NotSerializableException()
构造一个 NotSerializableException 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectInput (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 ObjectInput

所有超级接口：
DataInput
所有已知实现类：
ObjectInputStream
public interface ObjectInput
extends DataInput

ObjectInput 扩展 DataInput 接口以包含对象的读操作。DataInput 包括基本类型的输入方法；ObjectInput 扩展了该接口，以包含对象、数组和 String 的输出方法。

从以下版本开始：
JDK1.1
另请参见：
InputStream, ObjectOutputStream, ObjectInputStream

方法摘要
int | available() 返回可以无阻塞地读取的字节数。
void | close() 关闭输入流。
int | read() 读取数据字节。
int | read(byte[] b) 读入 byte 数组。
int | read(byte[] b, int off, int len) 读入 byte 数组。
Object | readObject() 读取并返回对象。
long | skip(long n) 跳过输入的 n 个字节。
从接口 java.io.DataInput 继承的方法
readBoolean, readByte, readChar, readDouble, readFloat, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedShort, readUTF, skipBytes

方法详细信息

readObject

Object readObject()
                  throws ClassNotFoundException,
                         IOException
读取并返回对象。实现此接口的类定义从哪里“读取”对象。

返回：
从流读取的对象
抛出：
ClassNotFoundException - 如果无法找到已序列化对象的类。
IOException - 如果发生任何常规 Input/Output 相关的异常。

read

int read()
         throws IOException
读取数据字节。如果不存在可用的输入，此方法将发生阻塞。

返回：
读取的字节；如果已到达流的末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

read

int read(byte[] b)
         throws IOException
读入 byte 数组。在某些输入可用之前，此方法将发生阻塞。

参数：
b - 将数据读入的缓冲区
返回：
读取的实际字节数；当到达流的末尾时，返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

read

int read(byte[] b,
         int off,
         int len)
         throws IOException
读入 byte 数组。在某些输入可用之前，此方法将发生阻塞。

参数：
b - 将数据读入的缓冲区
off - 数据的初始偏移量
len - 读取的最大字节数
返回：
读取的实际字节数；当到达流的末尾时返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

skip

long skip(long n)
          throws IOException
跳过输入的 n 个字节。

参数：
n - 要跳过的字节数
返回：
跳过的实际字节数。
抛出：
IOException - 如果发生 I/O 错误。

available

int available()
              throws IOException
返回可以无阻塞地读取的字节数。

返回：
可用字节数。
抛出：
IOException - 如果发生 I/O 错误。

close

void close()
           throws IOException
关闭输入流。必须调用此方法以释放与流相关的所有资源。

抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ObjectInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.ObjectInputStream
所有已实现的接口：
Closeable, DataInput, ObjectInput, ObjectStreamConstants
public class ObjectInputStream
extends InputStream
implements ObjectInput, ObjectStreamConstants

ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。

ObjectOutputStream 和 ObjectInputStream 分别与 FileOutputStream 和 FileInputStream 一起使用时，可以为应用程序提供对对象图形的持久存储。ObjectInputStream 用于恢复那些以前序列化的对象。其他用途包括使用套接字流在主机之间传递对象，或者用于编组和解组远程通信系统中的实参和形参。

ObjectInputStream 确保从流创建的图形中所有对象的类型与 Java 虚拟机中显示的类相匹配。使用标准机制按需加载类。

只有支持 java.io.Serializable 或 java.io.Externalizable 接口的对象才能从流读取。

readObject 方法用于从流读取对象。应该使用 Java 的安全强制转换来获取所需的类型。在 Java 中，字符串和数组都是对象，所以在序列化期间将其视为对象。读取时，需要将其强制转换为期望的类型。

可以使用 DataInput 上的适当方法从流读取基本数据类型。

默认情况下，对象的反序列化机制会将每个字段的内容恢复为写入时它所具有的值和类型。反序列化进程将忽略声明为瞬态或静态的字段。对其他对象的引用使得根据需要从流中读取这些对象。使用引用共享机制能够正确地恢复对象的图形。反序列化时始终分配新对象，这样可以避免现有对象被重写。

读取对象类似于运行新对象的构造方法。为对象分配内存并将其初始化为零 (NULL)。为不可序列化类调用无参数构造方法，然后从以最接近 java.lang.object 的可序列化类开始和以对象的最特定类结束的流恢复可序列化类的字段。

例如，要从由 ObjectOutputStream 中的示例写入的流读取：

        FileInputStream fis = new FileInputStream("t.tmp");
        ObjectInputStream ois = new ObjectInputStream(fis);

        int i = ois.readInt();
        String today = (String) ois.readObject();
        Date date = (Date) ois.readObject();

        ois.close();

类控制实现 java.io.Serializable 或 java.io.Externalizable 接口时的序列化方式。

实现 Serializable 接口允许对象序列化，以保存和恢复对象的全部状态，并且允许类在写入流时的状态和从流读取时的状态之间变化。它自动遍历对象之间的引用，保存和恢复全部图形。

在序列化和反序列化进程中需要特殊处理的 Serializable 类应该实现以下方法：

 private void writeObject(java.io.ObjectOutputStream stream)
     throws IOException;
 private void readObject(java.io.ObjectInputStream stream)
     throws IOException, ClassNotFoundException;
 private void readObjectNoData()
     throws ObjectStreamException;

readObject 方法负责使用通过对应的 writeObject 方法写入流的数据，为特定类读取和恢复对象的状态。该方法本身的状态，不管是属于其超类还是属于其子类，都没有关系。恢复状态的方法是，从个别字段的 ObjectInputStream 读取数据并将其分配给对象的适当字段。DataInput 支持读取基本数据类型。

尝试读取由对应的 writeObject 方法写入的超出自定义数据边界的对象数据将导致抛出 OptionalDataException（eof 字段值为 true）。超出已分配数据末尾的非对象读取以指示流末尾的方式反映数据结束：按位读取与字节读取或字节数读取一样，将返回 -1，基元读取将抛出 EOFException。如果不存在对应的 writeObject 方法，则默认的序列化数据的末尾标记已分配数据的末尾。

从 readExternal 方法发出的基元和对象读取调用的行为方式一样：如果流已经定位在由相应 writeExternal 方法写入的数据末尾，则对象读取将抛出 OptionalDataException（其 eof 设置为 true），按位读取将返回 -1，基元读取将抛出 EOFException。注意，此行为不适用于使用旧 ObjectStreamConstants.PROTOCOL_VERSION_1 协议写入的流，在这些流中，没有划分出由 writeExternal 方法写入的数据末尾，因此无法检测。

如果序列化流没有将给定类列为要反序列化的对象的超类，则 readObjectNoData 方法负责初始化其特定类的对象状态。在接收方使用的反序列化实例类的版本不同于发送方，并且接收者版本扩展的类不是发送者版本扩展的类时，此事可能发生。如果序列化流已经被篡改，也会发生这种情况；因此，不管源流是“敌意的”还是不完整的，readObjectNoData 方法都可以用来正确地初始化反序列化的对象。

对于没有实现 java.io.Serializable 接口的任何对象，序列化不会对其字段进行读取或赋值。非 serializable 的 Object 的子类可以为 serializable。在此情况下，非 serializable 类必须具有无参数的构造方法以允许其字段能被初始化。在此情况下，子类负责保存和恢复非 serializable 类的状态。经常出现的情况是，该类的字段是可访问的（public、package 或 protected），或者存在可用于恢复状态的 get 和 set 方法。

反序列化对象进程中发生的所有异常将由 ObjectInputStream 捕获并将中止读取进程。

实现 Externalizable 接口允许对象假定可以完全控制对象的序列化形式的内容和格式。调用 Externalizable 接口的方法（writeExternal 和 readExternal）来保存和恢复对象状态。当这两种方法被某个类实现时，它们可以使用 ObjectOutput 和 ObjectInput 的所有方法读写其本身的状态。对象负责处理出现的任何版本控制。

Enum 常量的反序列化不同于普通的 serializable 或 externalizable 对象。Enum 常量的序列化形式只包含其名称；不传送常量的字段值。要反序列化 enum 常量，ObjectInputStream 需要从流中读取常量的名称；然后将 enum 常量的基本类型和接收到的常量名称作为参数，调用静态方法 Enum.valueOf(Class, String) 获取反序列化的常量。与其他 serializable 或 externalizable 对象一样，enum 常量可以作为序列化流中随后出现的反向引用的目标。不可以自定义 enum 常量的反序列化进程：在反序列化期间，enum 类型所定义的任何与类有关的 readObject、readObjectNoData 和 readResolve 方法都将被忽略。类似地，任何 serialPersistentFields 或 serialVersionUID 字段声明也将被忽略（所有 enum 类型都有一个固定的 0L 的 serialVersionUID）。

从以下版本开始：
JDK1.1
另请参见：
DataInput, ObjectOutputStream, Serializable, 对象序列化规范：Object Input Classes 第三节

嵌套类摘要
static class ObjectInputStream.GetField
提供对从输入流读取的持久字段的访问权限。
字段摘要
从接口 java.io.ObjectStreamConstants 继承的字段
baseWireHandle, PROTOCOL_VERSION_1, PROTOCOL_VERSION_2, SC_BLOCK_DATA, SC_ENUM, SC_EXTERNALIZABLE, SC_SERIALIZABLE, SC_WRITE_METHOD, STREAM_MAGIC, STREAM_VERSION, SUBCLASS_IMPLEMENTATION_PERMISSION, SUBSTITUTION_PERMISSION, TC_ARRAY, TC_BASE, TC_BLOCKDATA, TC_BLOCKDATALONG, TC_CLASS, TC_CLASSDESC, TC_ENDBLOCKDATA, TC_ENUM, TC_EXCEPTION, TC_LONGSTRING, TC_MAX, TC_NULL, TC_OBJECT, TC_PROXYCLASSDESC, TC_REFERENCE, TC_RESET, TC_STRING
构造方法摘要
protected | ObjectInputStream() 为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。
 | ObjectInputStream(InputStream in) 创建从指定 InputStream 读取的 ObjectInputStream。
方法摘要
int | available() 返回可以不受阻塞地读取的字节数。
void | close() 关闭输入流。
void | defaultReadObject() 从此流读取当前类的非静态和非瞬态字段。
protected boolean | enableResolveObject(boolean enable) 使流允许从该流读取的对象被替代。
int | read() 读取数据字节。
int | read(byte[] buf, int off, int len) 读入 byte 数组。
boolean | readBoolean() 读取一个 boolean 值。
byte | readByte() 读取一个 8 位的字节。
char | readChar() 读取一个 16 位的 char 值。
protected ObjectStreamClass | readClassDescriptor() 从序列化流读取类描述符。
double | readDouble() 读取一个 64 位的 double 值。
ObjectInputStream.GetField | readFields() 按名称从流中读取持久字段并使其可用。
float | readFloat() 读取一个 32 位的 float 值。
void | readFully(byte[] buf) 读取字节，同时阻塞直至读取所有字节。
void | readFully(byte[] buf, int off, int len) 读取字节，同时阻塞直至读取所有字节。
int | readInt() 读取一个 32 位的 int 值。
String | readLine() 已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
long | readLong() 读取一个 64 位的 long 值。
Object | readObject() 从 ObjectInputStream 读取对象。
protected Object | readObjectOverride() 此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。
short | readShort() 读取一个 16 位的 short 值。
protected void | readStreamHeader() 提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。
Object | readUnshared() 从 ObjectInputStream 读取“非共享”对象。
int | readUnsignedByte() 读取一个无符号的 8 位字节。
int | readUnsignedShort() 读取一个无符号的 16 位 short 值。
String | readUTF() 读取 UTF-8 修改版格式的 String。
void | registerValidation(ObjectInputValidation obj, int prio) 在返回图形前注册要验证的对象。
protected Class<?> | resolveClass(ObjectStreamClass desc) 加载指定流类描述的本地等价类。
protected Object | resolveObject(Object obj) 在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。
protected Class<?> | resolveProxyClass(String[] interfaces) 返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。
int | skipBytes(int len) 跳过字节。
从类 java.io.InputStream 继承的方法
mark, markSupported, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.io.ObjectInput 继承的方法
read, skip

构造方法详细信息

ObjectInputStream

public ObjectInputStream(InputStream in)
                  throws IOException
创建从指定 InputStream 读取的 ObjectInputStream。从流读取序列化头部并予以验证。在对应的 ObjectOutputStream 写入并刷新头部之前，此构造方法将阻塞。

如果安装了安全管理器，则重写 ObjectInputStream.readFields 或 ObjectInputStream.readUnshared 方法的子类的构造方法直接或间接调用此构造方法时，它将对 "enableSubclassImplementation" SerializablePermission 进行检查。

参数：
in - 要从中读取的输入流
抛出：
StreamCorruptedException - 如果流的头部不正确
IOException - 如果读取流头部时发生 I/O 错误
SecurityException - 如果不受信任的子类非法重写安全敏感的方法
NullPointerException - 如果 in 为 null
另请参见：
ObjectInputStream(),
readFields(),
ObjectOutputStream.ObjectOutputStream(OutputStream)

ObjectInputStream

protected ObjectInputStream()
                     throws IOException,
                            SecurityException
为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。

如果已经安装了安全管理器，则此方法首先通过 SerializablePermission("enableSubclassImplementation") 权限调用安全管理器的 checkPermission 方法，以确保可以启用子类化。

抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许启用子类化。
IOException
另请参见：
SecurityManager.checkPermission(java.security.Permission), SerializablePermission
方法详细信息

readObject

public final Object readObject()
                        throws IOException,
                               ClassNotFoundException
从 ObjectInputStream 读取对象。对象的类、类的签名和类及所有其超类型的非瞬态和非静态字段的值都将被读取。可以使用 writeObject 和 readObject 方法为类重写默认的反序列化。由此对象引用的对象是可传递读取的，这样 readObject 即可重新构造这些对象的完全等价的图形。

通过完全恢复根对象的所有字段及其引用的对象来完全恢复根对象。此时，对象验证回调的执行顺序基于其注册优先级。回调由对象在其个别恢复时（通过 readObject 特定方法）进行注册。

当 InputStream 中出现问题或者遇到不应反序列化的类时，将抛出异常。所有异常对于 InputStream 而言都是致命的，将使其处于不确定状态；是忽略还是恢复流状态取决于调用者。

指定者：
接口 ObjectInput 中的 readObject
返回：
从流读取的对象
抛出：
ClassNotFoundException - 找不到序列化对象的类。
InvalidClassException - 序列化使用的类出了问题。
StreamCorruptedException - 流中的控制信息不一致。
OptionalDataException - 在流中找到基本类型数据而非对象。
IOException - 任何常规的输入/输出相关的异常。

readObjectOverride

protected Object readObjectOverride()
                             throws IOException,
                                    ClassNotFoundException
此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。子类需要提供带有修饰符 "final" 的重写方法。

返回：
从流读取的 Object。
抛出：
ClassNotFoundException - 找不到序列化对象的类定义。
OptionalDataException - 在流中找到基本类型数据而非对象。
IOException - 如果从底层流执行读操作时发生 I/O 错误
从以下版本开始：
1.2
另请参见：
ObjectInputStream(), readObject()

readUnshared

public Object readUnshared()
                    throws IOException,
                           ClassNotFoundException
从 ObjectInputStream 读取“非共享”对象。此方法与 readObject 类似，不同点在于它可以防止对 readObject 和 readUnshared 的后续调用返回对通过此调用获取的反序列化实例的附加引用。尤其是：
  • 如果调用 readUnshared 反序列化反向引用（以前写入流的对象的流表示形式），则抛出 ObjectStreamException。
  • 如果 readUnshared 成功返回，则反序列化对由 readUnshared 反序列化的流句柄的反向引用的任何后续尝试，都将导致抛出 ObjectStreamException。
通过 readUnshared 反序列化一个对象使得与返回对象关联的流句柄无效。注意，此操作本身不能始终保证由 readUnshared 返回的引用是唯一的；反序列化对象可能定义一个 readResolve 方法，该方法将返回一个对其他方可见的对象，或者 readUnshared 可能返回一个从流中其他地方或通过外部方法获得的 Class 对象或 enum 常量。如果反序列化对象定义一个 readResolve 方法并且该方法的调用返回一个数组，则 readUnshared 返回该数组的浅表副本；此规则保证返回的数组对象是唯一的，不能通过对 ObjectInputStream 调用 readObject 或 readUnshared 再次获得，即使能操纵底层数据流时也是如此。

重写此方法的 ObjectInputStream 子类只能在处理 "enableSubclassImplementation" SerializablePermission 的安全上下文中构造；在不具有此权限的情况下，任何实例化这种子类的尝试都将导致抛出 SecurityException。

返回：
反序列化对象的引用
抛出：
ClassNotFoundException - 如果找不到要反序列化的对象的类
StreamCorruptedException - 如果流中的控制信息不一致
ObjectStreamException - 如果流中已经出现了要反序列化的对象
OptionalDataException - 如果基本数据是流中的下一项
IOException - 如果在反序列化期间发生 I/O 错误
从以下版本开始：
1.4

defaultReadObject

public void defaultReadObject()
                       throws IOException,
                              ClassNotFoundException
从此流读取当前类的非静态和非瞬态字段。此方法只能从正在反序列化的类的 readObject 方法中调用。如果从其他地方调用该字段，则将抛出 NotActiveException。

抛出：
ClassNotFoundException - 如果找不到序列化对象的类。
IOException - 如果发生 I/O 错误。
NotActiveException - 如果目前流没有正在读取对象。

readFields

public ObjectInputStream.GetField readFields()
                                      throws IOException,
                                             ClassNotFoundException
按名称从流中读取持久字段并使其可用。

返回：
表示正在反序列化的对象持久字段的 GetField 对象
抛出：
ClassNotFoundException - 如果找不到序列化对象的类。
IOException - 如果发生 I/O 错误。
NotActiveException - 如果目前流没有正在读取对象。
从以下版本开始：
1.2

registerValidation

public void registerValidation(ObjectInputValidation obj,
                               int prio)
                        throws NotActiveException,
                               InvalidObjectException
在返回图形前注册要验证的对象。与 resolveObject 类似，这些验证是在重构整个图形后调用的。通常，readObject 方法向流注册对象，这样恢复全部对象后，就可以执行最后一组验证了。

参数：
obj - 接收验证回调的对象。
prio - 控制回调的顺序；零是个好的默认值。使用较大数进行较早的回调，使用较小数进行较晚的回调。在一个优先级中，回调的处理没有特定顺序。
抛出：
NotActiveException - 因为目前流没有正在读取对象，所以注册回调无效。
InvalidObjectException - 验证对象为 null。

resolveClass

protected Class<?> resolveClass(ObjectStreamClass desc)
                         throws IOException,
                                ClassNotFoundException
加载指定流类描述的本地等价类。子类可以实现此方法，从而允许从替换源获取类。

ObjectOutputStream 中的相应方法是 annotateClass。对于流中的每个唯一类，此方法只调用一次。此方法可以由子类实现，从而使用替换加载机制，但是必须返回 Class 对象。返回后，如果该类不是数组类，则它的 serialVersionUID 将与序列化类的 serialVersionUID 进行比较，如果不匹配，则反序列化失败，并抛出 InvalidClassException。

在 ObjectInputStream 中此方法的默认实现返回调用

     Class.forName(desc.getName(), false, loader)
的结果，其中 loader 按以下情形确定：如果当前线程的堆栈上存在一种方法，它的声明类由用户定义的类加载器定义（不是一个为实现反射调用而生成的类），则 loader 是对应于最接近当前执行帧的这些方法的类加载器；否则，loader 为 null。如果此调用导致抛出 ClassNotFoundException，且传递的 ObjectStreamClass 实例的名称是 Java 语言中基本数据类型或 void 关键字，那么将返回表示该基本类型或 void 的 Class 对象（例如，名称为 "int" 的 ObjectStreamClass 将被解析为 Integer.TYPE）。否则，将向此方法的调用者抛出 ClassNotFoundException。

参数：
desc - ObjectStreamClass 类的实例
返回：
对应于 desc 的 Class 对象
抛出：
IOException - 任何常规输入/输出异常
ClassNotFoundException - 如果找不到序列化对象的类。

resolveProxyClass

protected Class<?> resolveProxyClass(String[] interfaces)
                              throws IOException,
                                     ClassNotFoundException
返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。

对于流中的每个唯一的代理类描述符，此方法只调用一次。

ObjectOutputStream 中的相应方法是 annotateProxyClass。对于重写此方法的 ObjectInputStream 的给定子类，ObjectOutputStream 的相应子类中的 annotateProxyClass 方法必须写入由此方法读取的任何数据或对象。

ObjectInputStream 中此方法的默认实现返回调用 Proxy.getProxyClass 的结果，同时带有在 interfaces 参数中指定接口的 Class 对象的列表。每个接口名称 i 的 Class 对象都是调用以下语句返回的值

     Class.forName(i, false, loader)
其中，loader 是执行堆栈上的第一个非 null 类加载器，如果在堆栈上不存在非 null 加载器（类加载器选项与 resolveClass 方法使用的相同），则为 null。如果所有解析的接口都是公共的，则 loader 的这一相同值还是传递给 Proxy.getProxyClass 的类加载器；如果出现非公共接口，则传递他们的类加载器（如果遇到一个以上的非公共接口类加载器，则抛出 IllegalAccessError）。如果 Proxy.getProxyClass 抛出 IllegalArgumentException，则 resolveProxyClass 将抛出包含 IllegalArgumentException 的 ClassNotFoundException。

参数：
interfaces - 代理类描述符中反序列化的接口名称的列表
返回：
指定接口的代理类
抛出：
IOException - 底层 InputStream 抛出任何异常
ClassNotFoundException - 如果找不到代理类或任何指定接口
从以下版本开始：
1.3
另请参见：
ObjectOutputStream.annotateProxyClass(Class)

resolveObject

protected Object resolveObject(Object obj)
                        throws IOException
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。在调用 enableResolveObject 之前，不允许取代对象。enableResolveObject 方法检查请求解析对象的流是否可以信任。将 serializable 对象的每个引用传递给 resolveObject。为了确保不无意暴露对象的私有状态，可以仅让受信任的流使用 resolveObject。

此方法在读取对象之后而在从 readObject 返回之前调用。默认的 resolveObject 方法仅返回相同的对象。

子类在取代对象时，必须确保替代对象与存储引用的每个字段兼容。如果对象的类型不是字段或数组元素类型的子类，则通过引发异常中止序列化并且不存储对象。

此方法仅在首次遇到每个对象时调用一次。对象的所有后续引用都将被重定向到新对象。

参数：
obj - 要替代的对象
返回：
替代对象
抛出：
IOException - 任何常规的输入/输出异常。

enableResolveObject

protected boolean enableResolveObject(boolean enable)
                               throws SecurityException
使流允许从该流读取的对象被替代。启用时，将为要反序列化每个对象调用 resolveObject 方法。

如果 enable 为真，并且安装了安全管理器，则此方法首先使用 SerializablePermission("enableSubstitution") 权限调用安全管理器的 checkPermission 方法，以确保使流允许从该流读取的对象被替代。

参数：
enable - 如果为 true，则允许为每个要反序列化的对象使用 resolveObject
返回：
调用此方法之前的以前的设置
抛出：
SecurityException - 如果安全管理器存在，且其 checkPermission 方法拒绝流允许从要替代的流读取对象。
另请参见：
SecurityManager.checkPermission(java.security.Permission), SerializablePermission

readStreamHeader

protected void readStreamHeader()
                         throws IOException,
                                StreamCorruptedException
提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。它可以读取并验证幻数和版本号。

抛出：
IOException - 如果从底层 InputStream 读取时发生 I/O 错误
StreamCorruptedException - 如果流中的控制信息不一致

readClassDescriptor

protected ObjectStreamClass readClassDescriptor()
                                         throws IOException,
                                                ClassNotFoundException
从序列化流读取类描述符。当 ObjectInputStream 期望与序列化流中的下一项具有相同的类描述符时调用此方法。ObjectInputStream 的子类可以重写此方法，以便在以非标准格式编写的类描述符中进行读取（那些类描述符是 ObjectOutputStream 的子类通过重写 writeClassDescriptor 方法编写的）。默认情况下，此方法根据对象序列化规范中定义的格式读取类描述符。

返回：
读取的类描述符
抛出：
IOException - 如果发生 I/O 错误。
ClassNotFoundException - 如果找不到类描述符表示形式中使用的序列化对象的 Class
从以下版本开始：
1.3
另请参见：
ObjectOutputStream.writeClassDescriptor(java.io.ObjectStreamClass)

read

public int read()
         throws IOException
读取数据字节。如果不存在可用的输入，此方法将发生阻塞。

指定者：
接口 ObjectInput 中的 read
指定者：
类 InputStream 中的 read
返回：
读取的字节；如果已到达流的末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

read

public int read(byte[] buf,
                int off,
                int len)
         throws IOException
读入 byte 数组。在某些输入可用之前，此方法将发生阻塞。考虑使用 java.io.DataInputStream.readFully 读取正确“长度”的字节。

指定者：
接口 ObjectInput 中的 read
覆盖：
类 InputStream 中的 read
参数：
buf - 读入数据的缓冲区
off - 数据的初始偏移量
len - 读取的最大字节数
返回：
读取字节的实际数，到达流末尾时返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
DataInputStream.readFully(byte[],int,int)

available

public int available()
              throws IOException
返回可以不受阻塞地读取的字节数。

指定者：
接口 ObjectInput 中的 available
覆盖：
类 InputStream 中的 available
返回：
可用字节数。
抛出：
IOException - 如果从底层 InputStream 读取时发生 I/O 错误

close

public void close()
           throws IOException
关闭输入流。必须调用此方法才能释放与流相关的所有资源。

指定者：
接口 Closeable 中的 close
指定者：
接口 ObjectInput 中的 close
覆盖：
类 InputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。

readBoolean

public boolean readBoolean()
                    throws IOException
读取一个 boolean 值。

指定者：
接口 DataInput 中的 readBoolean
返回：
读取的 boolean。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readByte

public byte readByte()
              throws IOException
读取一个 8 位的字节。

指定者：
接口 DataInput 中的 readByte
返回：
读取的 8 位字节。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readUnsignedByte

public int readUnsignedByte()
                     throws IOException
读取一个无符号的 8 位字节。

指定者：
接口 DataInput 中的 readUnsignedByte
返回：
读取的 8 位字节。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readChar

public char readChar()
              throws IOException
读取一个 16 位的 char 值。

指定者：
接口 DataInput 中的 readChar
返回：
读取的 16 位 char 值。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readShort

public short readShort()
                throws IOException
读取一个 16 位的 short 值。

指定者：
接口 DataInput 中的 readShort
返回：
读取的 16 位 short 值。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readUnsignedShort

public int readUnsignedShort()
                      throws IOException
读取一个无符号的 16 位 short 值。

指定者：
接口 DataInput 中的 readUnsignedShort
返回：
读取的 16 位 short 值。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readInt

public int readInt()
            throws IOException
读取一个 32 位的 int 值。

指定者：
接口 DataInput 中的 readInt
返回：
读取的 32 位整数。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readLong

public long readLong()
              throws IOException
读取一个 64 位的 long 值。

指定者：
接口 DataInput 中的 readLong
返回：
读取的 64 位 long 值。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readFloat

public float readFloat()
                throws IOException
读取一个 32 位的 float 值。

指定者：
接口 DataInput 中的 readFloat
返回：
读取的 32 位 float 值。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readDouble

public double readDouble()
                  throws IOException
读取一个 64 位的 double 值。

指定者：
接口 DataInput 中的 readDouble
返回：
读取的 64 位 double 值。
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readFully

public void readFully(byte[] buf)
               throws IOException
读取字节，同时阻塞直至读取所有字节。

指定者：
接口 DataInput 中的 readFully
参数：
buf - 读入数据的缓冲区
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

readFully

public void readFully(byte[] buf,
                      int off,
                      int len)
               throws IOException
读取字节，同时阻塞直至读取所有字节。

指定者：
接口 DataInput 中的 readFully
参数：
buf - 读入数据的缓冲区
off - 数据的初始偏移量
len - 要读取的最大字节数
抛出：
EOFException - 如果到达文件末尾。
IOException - 如果发生其他 I/O 错误。

skipBytes

public int skipBytes(int len)
              throws IOException
跳过字节。

指定者：
接口 DataInput 中的 skipBytes
参数：
len - 要跳过的字节数
返回：
跳过的实际字节数。
抛出：
IOException - 如果发生 I/O 错误。

readLine

@Deprecated
public String readLine()
                throws IOException
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。

在以 \n、\r、\r\n 或 EOF 结尾的行中读取。

指定者：
接口 DataInput 中的 readLine
返回：
行的 String 副本。
抛出：
IOException - 如果从底层 InputStream 读取时发生 I/O 错误

readUTF

public String readUTF()
               throws IOException
读取 UTF-8 修改版格式的 String。

指定者：
接口 DataInput 中的 readUTF
返回：
String。
抛出：
IOException - 如果从底层 InputStream 读取时发生 I/O 错误
UTFDataFormatException - 如果读取的字节不表示有效的 UTF-8 修改版编码的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectInputStream.GetField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ObjectInputStream.GetField

java.lang.Object
    继承者  java.io.ObjectInputStream.GetField
正在封闭类：
ObjectInputStream
public abstract static class ObjectInputStream.GetField
extends Object

提供对从输入流读取的持久字段的访问权限。

构造方法摘要
ObjectInputStream.GetField()
方法摘要
abstract boolean | defaulted(String name) 如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。
abstract boolean | get(String name, boolean val) 从持久字段获取指定的 boolean 字段值。
abstract byte | get(String name, byte val) 从持久字段获取指定字节字段的值。
abstract char | get(String name, char val) 从持久字段获取指定 char 字段的值。
abstract double | get(String name, double val) 从持久字段获取指定 double 字段的值。
abstract float | get(String name, float val) 从持久字段获取指定 float 字段的值。
abstract int | get(String name, int val) 从持久字段获取指定的 int 字段值。
abstract long | get(String name, long val) 从持久字段获取指定 long 字段的值。
abstract Object | get(String name, Object val) 从持久字段获取指定 Object 字段的值。
abstract short | get(String name, short val) 从持久字段获取指定的 short 字段值。
abstract ObjectStreamClass | getObjectStreamClass() 获取描述流中字段的 ObjectStreamClass。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectInputStream.GetField

public ObjectInputStream.GetField()
方法详细信息

getObjectStreamClass

public abstract ObjectStreamClass getObjectStreamClass()
获取描述流中字段的 ObjectStreamClass。

返回：
描述可序列化字段的描述符类

defaulted

public abstract boolean defaulted(String name)
                           throws IOException
如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。

参数：
name - 字段的名称
返回：
当且仅当指定的字段为默认字段时返回 true
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 与可序列化字段不对应

get

public abstract boolean get(String name,
                            boolean val)
                     throws IOException
从持久字段获取指定的 boolean 字段值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定的 boolean 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract byte get(String name,
                         byte val)
                  throws IOException
从持久字段获取指定字节字段的值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定的 byte 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract char get(String name,
                         char val)
                  throws IOException
从持久字段获取指定 char 字段的值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定的 char 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract short get(String name,
                          short val)
                   throws IOException
从持久字段获取指定的 short 字段值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定的 short 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract int get(String name,
                        int val)
                 throws IOException
从持久字段获取指定的 int 字段值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定的 int 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract long get(String name,
                         long val)
                  throws IOException
从持久字段获取指定 long 字段的值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定的 long 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract float get(String name,
                          float val)
                   throws IOException
从持久字段获取指定 float 字段的值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定的 float 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract double get(String name,
                           double val)
                    throws IOException
从持久字段获取指定 double 字段的值。

参数：
name - 字段的名称
name - 没有值的情况下要用的默认值
返回：
指定的 double 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确

get

public abstract Object get(String name,
                           Object val)
                    throws IOException
从持久字段获取指定 Object 字段的值。

参数：
name - 字段的名称
val - name 没有值的情况下要用的默认值
返回：
指定 Object 字段的值
抛出：
IOException - 如果从基础 InputStream 执行读取操作时发生 I/O 错误
IllegalArgumentException - 如果 name 的类型不是可序列化的或者字段类型不正确
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectInputValidation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 ObjectInputValidation

public interface ObjectInputValidation

允许验证图形中对象的回调接口。允许在反序列化完整的对象图形后调用对象。

从以下版本开始：
JDK1.1
另请参见：
ObjectInputStream, ObjectInputStream.registerValidation(java.io.ObjectInputValidation, int)

方法摘要
 void validateObject()
验证对象。

方法详细信息

validateObject

void validateObject()
                    throws InvalidObjectException
验证对象。

抛出：
InvalidObjectException - 如果对象无法自我验证。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectOutput (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 ObjectOutput

所有超级接口：
DataOutput
所有已知实现类：
ObjectOutputStream
public interface ObjectOutput
extends DataOutput

ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。DataOutput 包括基本类型的输出方法；ObjectOutput 扩展了该接口，以包含对象、数组和 String 的输出方法。

从以下版本开始：
JDK1.1
另请参见：
InputStream, ObjectOutputStream, ObjectInputStream

方法摘要
void | close() 关闭该流。
void | flush() 刷新该流的缓冲。
void | write(byte[] b) 写入 byte 数组。
void | write(byte[] b, int off, int len) 写入字节的子数组。
void | write(int b) 写入字节。
void | writeObject(Object obj) 将对象写入底层存储或流。
从接口 java.io.DataOutput 继承的方法
writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeDouble, writeFloat, writeInt, writeLong, writeShort, writeUTF

方法详细信息

writeObject

void writeObject(Object obj)
                 throws IOException
将对象写入底层存储或流。实现此接口的类定义如何写入对象。

参数：
obj - 要写入的对象
抛出：
IOException - 如果发生任何与常规 Input/Output 相关的异常。

write

void write(int b)
           throws IOException
写入字节。在实际写入字节前，此方法将阻塞。

指定者：
接口 DataOutput 中的 write
参数：
b - 字节
抛出：
IOException - 如果发生 I/O 错误

write

void write(byte[] b)
           throws IOException
写入 byte 数组。在实际写入字节前将发生阻塞。

指定者：
接口 DataOutput 中的 write
参数：
b - 要写入的数据
抛出：
IOException - 如果发生 I/O 错误。

write

void write(byte[] b,
           int off,
           int len)
           throws IOException
写入字节的子数组。

指定者：
接口 DataOutput 中的 write
参数：
b - 要写入的数据
off - 数据中的初始偏移量
len - 写入的字节数
抛出：
IOException - 如果发生 I/O 错误。

flush

void flush()
           throws IOException
刷新该流的缓冲。此操作将写入所有已缓冲的输出字节。

抛出：
IOException - 如果发生 I/O 错误。

close

void close()
           throws IOException
关闭该流。必须调用此方法以释放与此流相关的所有资源。

抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ObjectOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.ObjectOutputStream
所有已实现的接口：
Closeable, DataOutput, Flushable, ObjectOutput, ObjectStreamConstants
public class ObjectOutputStream
extends OutputStream
implements ObjectOutput, ObjectStreamConstants

ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。可以使用 ObjectInputStream 读取（重构）对象。通过在流中使用文件可以实现对象的持久存储。如果流是网络套接字流，则可以在另一台主机上或另一个进程中重构对象。

只能将支持 java.io.Serializable 接口的对象写入流中。每个 serializable 对象的类都被编码，编码内容包括类名和类签名、对象的字段值和数组值，以及从初始对象中引用的其他所有对象的闭包。

writeObject 方法用于将对象写入流中。所有对象（包括 String 和数组）都可以通过 writeObject 写入。可将多个对象或基元写入流中。必须使用与写入对象时相同的类型和顺序从相应 ObjectInputstream 中读回对象。

还可以使用 DataOutput 中的适当方法将基本数据类型写入流中。还可以使用 writeUTF 方法写入字符串。

对象的默认序列化机制写入的内容是：对象的类，类签名，以及非瞬态和非静态字段的值。其他对象的引用（瞬态和静态字段除外）也会导致写入那些对象。可使用引用共享机制对单个对象的多个引用进行编码，这样即可将对象的图形恢复为最初写入它们时的形状。

例如，要写入可通过 ObjectInputStream 中的示例读取的对象，请执行以下操作：

        FileOutputStream fos = new FileOutputStream("t.tmp");
        ObjectOutputStream oos = new ObjectOutputStream(fos);

        oos.writeInt(12345);
        oos.writeObject("Today");
        oos.writeObject(new Date());

        oos.close();

在序列化和反序列化过程中需要特殊处理的类必须实现具有下列准确签名的特殊方法：

 private void readObject(java.io.ObjectInputStream stream)
     throws IOException, ClassNotFoundException;
 private void writeObject(java.io.ObjectOutputStream stream)
     throws IOException
 private void readObjectNoData()
     throws ObjectStreamException;

writeObject 方法负责写入特定类的对象状态，以便相应的 readObject 方法可以恢复它。该方法本身不必与属于对象的超类或子类的状态有关。状态是通过使用 writeObject 方法或使用 DataOutput 支持的用于基本数据类型的方法将各个字段写入 ObjectOutputStream 来保存的。

序列化操作不写出没有实现 java.io.Serializable 接口的任何对象的字段。不可序列化的 Object 的子类可以是可序列化的。在此情况下，不可序列化的类必须有一个无参数构造方法，以便允许初始化其字段。在此情况下，子类负责保存和恢复不可序列化的类的状态。经常出现的情况是，该类的字段是可访问的（public、package 或 protected），或者存在可用来恢复状态的 get 和 set 方法。

在 writeObject 和 readObject 方法的实现中抛出 NotSerializableException，可以阻止对象的序列化。ObjectOutputStream 将捕获异常并中止序列化进程。

实现 Externalizable 接口允许对象假定可以完全控制对象的序列化形式的内容和格式。调用 Externalizable 接口的方法（writeExternal 和 readExternal）来保存和恢复对象的状态。通过类实现时，它们可以使用 ObjectOutput 和 ObjectInput 的所有方法读写它们自己的状态。对象负责处理出现的任何版本控制。

Enum 常量的序列化不同于普通的 serializable 或 externalizable 对象。enum 常量的序列化形式只包含其名称；常量的字段值不被传送。为了序列化 enum 常量，ObjectOutputStream 需要写入由常量的名称方法返回的字符串。与其他 serializable 或 externalizable 对象一样，enum 常量可以作为序列化流中后续出现的 back 引用的目标。用于序列化 enum 常量的进程不可定制；在序列化期间，由 enum 类型定义的所有类特定的 writeObject 和 writeReplace 方法都将被忽略。类似地，任何 serialPersistentFields 或 serialVersionUID 字段声明也将被忽略，所有 enum 类型都有一个 0L 的固定的 serialVersionUID。

基本数据（不包括 serializable 字段和 externalizable 数据）以块数据记录的形式写入 ObjectOutputStream 中。块数据记录由头部和数据组成。块数据部分包括标记和跟在部分后面的字节数。连续的基本写入数据被合并在一个块数据记录中。块数据记录的分块因子为 1024 字节。每个块数据记录都将填满 1024 字节，或者在终止块数据模式时被写入。调用 ObjectOutputStream 方法 writeObject、defaultWriteObject 和 writeFields 最初只是终止所有现有块数据记录。

从以下版本开始：
JDK1.1
另请参见：
DataOutput, ObjectInputStream, Serializable, Externalizable, Serialization Specification, Section 2, Object Output Classes

嵌套类摘要
static class ObjectOutputStream.PutField
提供对要写入 ObjectOutput 的持久字段的编程访问。
字段摘要
从接口 java.io.ObjectStreamConstants 继承的字段
baseWireHandle, PROTOCOL_VERSION_1, PROTOCOL_VERSION_2, SC_BLOCK_DATA, SC_ENUM, SC_EXTERNALIZABLE, SC_SERIALIZABLE, SC_WRITE_METHOD, STREAM_MAGIC, STREAM_VERSION, SUBCLASS_IMPLEMENTATION_PERMISSION, SUBSTITUTION_PERMISSION, TC_ARRAY, TC_BASE, TC_BLOCKDATA, TC_BLOCKDATALONG, TC_CLASS, TC_CLASSDESC, TC_ENDBLOCKDATA, TC_ENUM, TC_EXCEPTION, TC_LONGSTRING, TC_MAX, TC_NULL, TC_OBJECT, TC_PROXYCLASSDESC, TC_REFERENCE, TC_RESET, TC_STRING
构造方法摘要
protected | ObjectOutputStream() 为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。
 | ObjectOutputStream(OutputStream out) 创建写入指定 OutputStream 的 ObjectOutputStream。
方法摘要
protected void | annotateClass(Class<?> cl) 子类可以实现此方法，从而允许在流中存储类数据。
protected void | annotateProxyClass(Class<?> cl) 子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。
void | close() 关闭流。
void | defaultWriteObject() 将当前类的非静态和非瞬态字段写入此流。
protected void | drain() 排空 ObjectOutputStream 中的所有已缓冲数据。
protected boolean | enableReplaceObject(boolean enable) 允许流对流中的对象进行替换。
void | flush() 刷新该流的缓冲。
ObjectOutputStream.PutField | putFields() 获取用于缓冲写入流中的持久存储字段的对象。
protected Object | replaceObject(Object obj) 在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。
void | reset() 重置将丢弃已写入流中的所有对象的状态。
void | useProtocolVersion(int version) 指定要在写入流时使用的流协议版本。
void | write(byte[] buf) 写入一个 byte 数组。
void | write(byte[] buf, int off, int len) 写入字节的子数组。
void | write(int val) 写入一个字节。
void | writeBoolean(boolean val) 写入一个 boolean 值。
void | writeByte(int val) 写入一个 8 位字节。
void | writeBytes(String str) 以字节序列形式写入一个 String。
void | writeChar(int val) 写入一个 16 位的 char 值。
void | writeChars(String str) 以 char 序列形式写入一个 String。
protected void | writeClassDescriptor(ObjectStreamClass desc) 将指定的类描述符写入 ObjectOutputStream。
void | writeDouble(double val) 写入一个 64 位的 double 值。
void | writeFields() 将已缓冲的字段写入流中。
void | writeFloat(float val) 写入一个 32 位的 float 值。
void | writeInt(int val) 写入一个 32 位的 int 值。
void | writeLong(long val) 写入一个 64 位的 long 值。
void | writeObject(Object obj) 将指定的对象写入 ObjectOutputStream。
protected void | writeObjectOverride(Object obj) 子类用于重写默认 writeObject 方法的方法。
void | writeShort(int val) 写入一个 16 位的 short 值。
protected void | writeStreamHeader() 提供 writeStreamHeader 方法，这样子类可以将其自身的头部添加或预加到流中。
void | writeUnshared(Object obj) 将“未共享”对象写入 ObjectOutputStream。
void | writeUTF(String str) 以 UTF-8 修改版格式写入此 String 的基本数据。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectOutputStream

public ObjectOutputStream(OutputStream out)
                   throws IOException
创建写入指定 OutputStream 的 ObjectOutputStream。此构造方法将序列化流部分写入底层流；调用者可以通过立即刷新流，确保在读取头部时，用于接收 ObjectInputStreams 构造方法不会阻塞。

如果安装了安全管理器，则在通过重写 ObjectOutputStream.putFields 或 ObjectOutputStream.writeUnshared 方法的子类的构造方法来直接或间接调用此构造方法时，它将对 "enableSubclassImplementation" SerializablePermission 进行检查。

参数：
out - 要写入数据的输出流
抛出：
IOException - 如果在写入流部分时发生 I/O 错误
SecurityException - 如果不受信任的子类非法重写安全敏感方法
NullPointerException - 如果 out 为 null
从以下版本开始：
1.4
另请参见：
ObjectOutputStream(),
putFields(),
ObjectInputStream.ObjectInputStream(InputStream)

ObjectOutputStream

protected ObjectOutputStream()
                      throws IOException,
                             SecurityException
为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。

如果已经安装了安全管理器，则此方法首先利用 SerializablePermission("enableSubclassImplementation") 权限调用安全管理器的 checkPermission 方法，以确保可以启用子类化。

抛出：
SecurityException - 如果安全管理器存在，且其 checkPermission 方法不允许启用子类化。
IOException
另请参见：
SecurityManager.checkPermission(java.security.Permission), SerializablePermission
方法详细信息

useProtocolVersion

public void useProtocolVersion(int version)
                        throws IOException
指定要在写入流时使用的流协议版本。

此例程提供了一个钩子 (hook)，允许以与旧版的流格式向后兼容的格式写入当前版的 Serialization。

我们将尽最大努力避免造成额外的向后不兼容性；但有时没有其他替代方法。

参数：
version - 根据 java.io.ObjectStreamConstants 使用 ProtocolVersion。
抛出：
IllegalStateException - 如果在已序列化所有对象后调用。
IllegalArgumentException - 如果传入的版本无效。
IOException - 如果发生 I/O 错误
从以下版本开始：
1.2
另请参见：
ObjectStreamConstants.PROTOCOL_VERSION_1, ObjectStreamConstants.PROTOCOL_VERSION_2

writeObject

public final void writeObject(Object obj)
                       throws IOException
将指定的对象写入 ObjectOutputStream。对象的类、类的签名，以及类及其所有超类型的非瞬态和非静态字段的值都将被写入。可以使用 writeObject 和 readObject 方法重写类的默认序列化。由此对象引用的对象是以可变迁的方式写入的，这样，可以通过 ObjectInputStream 重新构造这些对象的完全等价的图形。

当 OutputStream 中出现问题或者遇到不应序列化的类时，将抛出异常。所有异常对于 OutputStream 而言都是致命的，使其处于不确定状态；并由调用者来忽略或恢复流的状态。

指定者：
接口 ObjectOutput 中的 writeObject
参数：
obj - 要写入的对象
抛出：
InvalidClassException - 序列化操作使用的类出了问题。
NotSerializableException - 某个要序列化的对象不能实现 java.io.Serializable 接口。
IOException - 由底层 OutputStream 抛出的任何异常。

writeObjectOverride

protected void writeObjectOverride(Object obj)
                            throws IOException
子类用于重写默认 writeObject 方法的方法。此方法由 ObjectInputStream 的受信任子类调用，可以使用受保护的无参数构造方法来构造 ObjectInputStream。子类需要使用修饰符 "final" 提供重写方法。

参数：
obj - 要写入底层流的对象
抛出：
IOException - 如果写入底层流时发生 I/O 错误
从以下版本开始：
1.2
另请参见：
ObjectOutputStream(), writeObject(Object)

writeUnshared

public void writeUnshared(Object obj)
                   throws IOException
将“未共享”对象写入 ObjectOutputStream。此方法等同于 writeObject，不同点在于它总是将给定对象作为流中唯一的新对象进行写入（相对于指向以前序列化实例的 back 引用而言）。尤其是：
  • 通过 writeUnshared 写入的对象总是作为新出现对象（未曾将对象写入流中）被序列化，不管该对象以前是否已经被写入过。
  • 如果使用 writeObject 写入以前通过 writeUnshared 写入的对象，则可将以前的 writeUnshared 操作视为写入一个单独对象。换句话说，ObjectOutputStream 永远不会生成通过调用 writeUnshared 写入的对象数据的 back 引用。
虽然通过 writeUnshared 写入对象本身不能保证反序列化对象时对象引用的唯一性，但它允许在流中多次定义单个对象，因此接收方对 readUnshared 的多个调用不会引发冲突。注意，上述规则仅应用于通过 writeUnshared 写入的基层对象,而不能应用于要序列化的对象图形中的任何可变迁方式引用的子对象。

重写此方法的 ObjectOutputStream 子类只能在处理 "enableSubclassImplementation" SerializablePermission 的安全上下文中构造；在不具有此权限的情况下，任何实例化这种子类的尝试都将导致抛出 SecurityException。

参数：
obj - 要写入流的对象
抛出：
NotSerializableException - 如果要序列化的图形中的对象不能实现 Serializable 接口
InvalidClassException - 如果要序列化的对象的类存在问题
IOException - 如果序列化期间发生 I/O 错误
从以下版本开始：
1.4

defaultWriteObject

public void defaultWriteObject()
                        throws IOException
将当前类的非静态和非瞬态字段写入此流。此字段只能从正在序列化的类的 writeObject 方法中调用。如果从其他地方调用该字段，则将抛出 NotActiveException。

抛出：
IOException - 如果在写入底层 OutputStream 中时发生 I/O 错误

putFields

public ObjectOutputStream.PutField putFields()
                                      throws IOException
获取用于缓冲写入流中的持久存储字段的对象。调用 writeFields 方法时，字段被写入流中。

返回：
保存 serializable 字段的 Putfield 类的实例
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
1.2

writeFields

public void writeFields()
                 throws IOException
将已缓冲的字段写入流中。

抛出：
IOException - 如果在写入底层流时发生 I/O 错误
NotActiveException - 未调用类 writeObject 方法来写入对象的状态时调用。
从以下版本开始：
1.2

reset

public void reset()
           throws IOException
重置将丢弃已写入流中的所有对象的状态。重新设置状态，使其与新的 ObjectOutputStream 相同。将流中的当前点标记为 reset，相应的 ObjectInputStream 也将在这一点重置。以前写入流中的对象不再被视为正位于流中。它们会再次被写入流。

抛出：
IOException - 如果在序列化对象时调用 reset()。

annotateClass

protected void annotateClass(Class<?> cl)
                      throws IOException
子类可以实现此方法，从而允许在流中存储类数据。默认情况下，此方法不执行任何操作。ObjectInputStream 中的相应方法是 resolveClass。对于流中的每个唯一的类，此方法只调用一次。类名和类签名已经写入流中。此方法可以随意使用 ObjectOutputStream 来保存它认为合适的类的任何表示形式（例如类文件的字节）。ObjectInputStream 的相应子类中的 resolveClass 方法必须读取并使用由 annotateClass 写入的数据或对象。

参数：
cl - 注释定制数据的类
抛出：
IOException - 底层 OutputStream 抛出任何异常。

annotateProxyClass

protected void annotateProxyClass(Class<?> cl)
                           throws IOException
子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。

对于流中的每个唯一的代理类描述符，此方法只调用一次。在 ObjectOutputStream 中，此方法的默认实现不执行任何操作。

ObjectInputStream 中的相应方法是 resolveProxyClass。对于重写此方法的 ObjectOutputStream 的给定子类，ObjectInputStream 的相应子类中的 resolveProxyClass 方法必须读取由 annotateProxyClass 写入的所有数据或对象。

参数：
cl - 注释定制数据的代理类
抛出：
IOException - 底层 OutputStream 抛出的任何异常
从以下版本开始：
1.3
另请参见：
ObjectInputStream.resolveProxyClass(String[])

replaceObject

protected Object replaceObject(Object obj)
                        throws IOException
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。在调用 enableReplaceObject 之前，不允许取代对象。enableReplaceObject 方法检查请求取代的流是否可以信任。写入序列化流的每个对象在第一次出现时被传递给 replaceObject。在后续引用中，该对象将由初始调用 replaceObject 所返回的对象取代。为了确保不会无意暴露对象的私有状态，可以仅让受信任的流使用 replaceObject。

ObjectOutputStream.writeObject 方法使用 Object 类型的参数（相对于 Serializable 类型），允许非 serializable 对象由 serializable 对象取代。

在子类取代对象时，必须确保要么在反序列化期间进行互补替代，要么替代对象与存储引用的每个字段兼容。如果对象的类型不是字段或数组元素类型的子类，则通过引发异常中止序列化并且不存储对象。

此方法仅在首次遇到每个对象时调用一次。对象的所有后续引用都将被重定向到新对象。此方法应该返回要替代的对象或初始对象。

替代对象时可以返回 null，但是在包含到初始对象的引用的类中可能导致 NullReferenceException，因为它们可能期望得到对象而不是 null。

参数：
obj - 要取代的对象
返回：
取代指定对象的替换对象
抛出：
IOException - 底层 OutputStream 抛出的任何异常。

enableReplaceObject

protected boolean enableReplaceObject(boolean enable)
                               throws SecurityException
允许流对流中的对象进行替换。启用时，将为正序列化的每个对象调用 replaceObject 方法。

如果 enable 为 true，并且安装了安全管理器，则此方法首先利用 SerializablePermission("enableSubstitution") 权限调用安全管理器的 checkPermission 方法，以确保允许流对流中的对象进行替换。

参数：
enable - 允许取代对象的 boolean 参数
返回：
调用此方法之前的以前的设置
抛出：
SecurityException - 如果安全管理器存在，且其 checkPermission 方法不允许流对流中的对象进行替换。
另请参见：
SecurityManager.checkPermission(java.security.Permission), SerializablePermission

writeStreamHeader

protected void writeStreamHeader()
                          throws IOException
提供 writeStreamHeader 方法，这样子类可以将其自身的头部添加或预加到流中。它可以将幻数 (magic number) 和版本写入流。

抛出：
IOException - 如果在写入底层流时发生 I/O 错误

writeClassDescriptor

protected void writeClassDescriptor(ObjectStreamClass desc)
                             throws IOException
将指定的类描述符写入 ObjectOutputStream。类描述符用于标识写入流中的对象的类。ObjectOutputStream 的子类可以重写此方法，从而定制将类描述符写入序列化流中的方式。然后，应该重写 ObjectInputStream 中的相应方法（readClassDescriptor），以便根据其定制的流表示形式来重构类描述符。默认情况下，此方法根据 Object Serialization 规范中定义的格式写入类描述符。

注意，仅当 ObjectOutputStream 没有使用旧的序列化流格式（通过调用 ObjectOutputStream 的 useProtocolVersion 方法设置）时才调用此方法。如果此序列化流在使用旧的格式（即 PROTOCOL_VERSION_1），则以不可重写或自定义的方式在内部写入类描述符。

参数：
desc - 要写入流的类描述符
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
1.3
另请参见：
ObjectInputStream.readClassDescriptor(), useProtocolVersion(int), ObjectStreamConstants.PROTOCOL_VERSION_1

write

public void write(int val)
           throws IOException
写入一个字节。在实际写入字节前，此方法将发生阻塞。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ObjectOutput 中的 write
指定者：
类 OutputStream 中的 write
参数：
val - 要写入流中的字节
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] buf)
           throws IOException
写入一个 byte 数组。在实际写入字节前，此方法将发生阻塞。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ObjectOutput 中的 write
覆盖：
类 OutputStream 中的 write
参数：
buf - 要写入的数据
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
OutputStream.write(byte[], int, int)

write

public void write(byte[] buf,
                  int off,
                  int len)
           throws IOException
写入字节的子数组。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ObjectOutput 中的 write
覆盖：
类 OutputStream 中的 write
参数：
buf - 要写入的数据
off - 数据中的初始偏移量
len - 写入的字节数
抛出：
IOException - 如果发生 I/O 错误。

flush

public void flush()
           throws IOException
刷新该流的缓冲。此操作将写入所有已缓冲的输出字节，并将它们刷新到底层流中。

指定者：
接口 Flushable 中的 flush
指定者：
接口 ObjectOutput 中的 flush
覆盖：
类 OutputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误。

drain

protected void drain()
              throws IOException
排空 ObjectOutputStream 中的所有已缓冲数据。与刷新类似，但没有将刷新传播到底层流。

抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

close

public void close()
           throws IOException
关闭流。必须调用此方法来释放与此流有关的所有资源。

指定者：
接口 Closeable 中的 close
指定者：
接口 ObjectOutput 中的 close
覆盖：
类 OutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。

writeBoolean

public void writeBoolean(boolean val)
                  throws IOException
写入一个 boolean 值。

指定者：
接口 DataOutput 中的 writeBoolean
参数：
val - 要写入的 boolean 值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeByte

public void writeByte(int val)
               throws IOException
写入一个 8 位字节。

指定者：
接口 DataOutput 中的 writeByte
参数：
val - 要写入的字节值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeShort

public void writeShort(int val)
                throws IOException
写入一个 16 位的 short 值。

指定者：
接口 DataOutput 中的 writeShort
参数：
val - 要写入的 short 值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeChar

public void writeChar(int val)
               throws IOException
写入一个 16 位的 char 值。

指定者：
接口 DataOutput 中的 writeChar
参数：
val - 要写入的 char 值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeInt

public void writeInt(int val)
              throws IOException
写入一个 32 位的 int 值。

指定者：
接口 DataOutput 中的 writeInt
参数：
val - 要写入的整数值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeLong

public void writeLong(long val)
               throws IOException
写入一个 64 位的 long 值。

指定者：
接口 DataOutput 中的 writeLong
参数：
val - 要写入的 long 值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeFloat

public void writeFloat(float val)
                throws IOException
写入一个 32 位的 float 值。

指定者：
接口 DataOutput 中的 writeFloat
参数：
val - 要写入的 float 值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeDouble

public void writeDouble(double val)
                 throws IOException
写入一个 64 位的 double 值。

指定者：
接口 DataOutput 中的 writeDouble
参数：
val - 要写入的 double 值
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeBytes

public void writeBytes(String str)
                throws IOException
以字节序列形式写入一个 String。

指定者：
接口 DataOutput 中的 writeBytes
参数：
str - 要写入的字节的 String
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeChars

public void writeChars(String str)
                throws IOException
以 char 序列形式写入一个 String。

指定者：
接口 DataOutput 中的 writeChars
参数：
str - 要写入的 char 的 String
抛出：
IOException - 如果在将数据写入底层流时发生 I/O 错误

writeUTF

public void writeUTF(String str)
              throws IOException
以 UTF-8 修改版格式写入此 String 的基本数据。注意，将 String 作为基本数据写入流中与将它作为 Object 写入流中明显不同。由 writeObject 写入的 String 实例最初是作为 String 写入流中的。然后，writeObject() 调用将对该字符串的引用写入流中。

指定者：
接口 DataOutput 中的 writeUTF
参数：
str - 要写入的 String
抛出：
IOException - 如果在将输入写入底层流时发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectOutputStream.PutField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ObjectOutputStream.PutField

java.lang.Object
    继承者  java.io.ObjectOutputStream.PutField
正在封闭类：
ObjectOutputStream
public abstract static class ObjectOutputStream.PutField
extends Object

提供对要写入 ObjectOutput 的持久字段的编程访问。

从以下版本开始：
1.2

构造方法摘要
ObjectOutputStream.PutField()
方法摘要
abstract void | put(String name, boolean val) 将指定的 boolean 字段的值置于持久字段中。
abstract void | put(String name, byte val) 将指定的 byte 字段值置于持久字段中。
abstract void | put(String name, char val) 将指定的 char 字段的值置于持久字段中。
abstract void | put(String name, double val) 将指定的 double 字段的值置于持久字段中。
abstract void | put(String name, float val) 将指定的 float 字段的值置于持久字段中。
abstract void | put(String name, int val) 将指定的 int 字段的值置于持久字段中。
abstract void | put(String name, long val) 将指定的 long 字段的值置于持久字段中。
abstract void | put(String name, Object val) 将指定的 Object 字段的值置于持久字段中。
abstract void | put(String name, short val) 将指定的 short 字段的值置于持久字段中。
abstract void | write(ObjectOutput out) 已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ObjectOutputStream.PutField

public ObjectOutputStream.PutField()
方法详细信息

put

public abstract void put(String name,
                         boolean val)
将指定的 boolean 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 boolean

put

public abstract void put(String name,
                         byte val)
将指定的 byte 字段值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 byte

put

public abstract void put(String name,
                         char val)
将指定的 char 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 char

put

public abstract void put(String name,
                         short val)
将指定的 short 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 short

put

public abstract void put(String name,
                         int val)
将指定的 int 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 int

put

public abstract void put(String name,
                         long val)
将指定的 long 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 long

put

public abstract void put(String name,
                         float val)
将指定的 float 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 float

put

public abstract void put(String name,
                         double val)
将指定的 double 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是 double

put

public abstract void put(String name,
                         Object val)
将指定的 Object 字段的值置于持久字段中。

参数：
name - 可序列化字段的名称
val - 将分配给字段的值（该值可能为 null）
抛出：
IllegalArgumentException - 如果 name 与该类（其字段正被写入）的可序列化字段的名称不匹配，或者指定字段的类型不是引用类型

write

@Deprecated
public abstract void write(ObjectOutput out)
                    throws IOException
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。

将数据和字段写入指定的 ObjectOutput 流，该流必须与生成此 PutField 对象的流相同。

参数：
out - 将写入数据和字段的流
抛出：
IOException - 如果写入底层流时发生 I/O 错误
IllegalArgumentException - 如果指定的流与生成此 PutField 对象的流不同
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectStreamClass (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ObjectStreamClass

java.lang.Object
    继承者  java.io.ObjectStreamClass
所有已实现的接口：
Serializable
public class ObjectStreamClass
extends Object
implements Serializable

类的序列化描述符。它包含类的名称和 serialVersionUID。可以使用 lookup 方法找到/创建在此 Java VM 中加载的具体类的 ObjectStreamClass。

计算 SerialVersionUID 的算法在 Object Serialization Specification, Section 4.6, Stream Unique Identifiers 中描述。

从以下版本开始：
JDK1.1
另请参见：
ObjectStreamField, Object Serialization Specification, Section 4, Class Descriptors, 序列化表格

字段摘要
static ObjectStreamField[] NO_FIELDS
指示不存在可序列化字段的 serialPersistentFields 值。
方法摘要
Class<?> | forClass() 返回此版本所映射的本地 VM 中的类。
ObjectStreamField | getField(String name) 按名称获取此类的字段。
ObjectStreamField[] | getFields() 返回此可序列化类的字段组成的数组。
String | getName() 返回由此描述符描述的类的名称。
long | getSerialVersionUID() 返回此类的 serialVersionUID。
static ObjectStreamClass | lookup(Class<?> cl) 查找可序列化类的描述符。
static ObjectStreamClass | lookupAny(Class<?> cl) 返回任意类的描述符，不考虑它是否实现 Serializable。
String | toString() 返回描述此 ObjectStreamClass 的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

NO_FIELDS

public static final ObjectStreamField[] NO_FIELDS
指示不存在可序列化字段的 serialPersistentFields 值。

方法详细信息

lookup

public static ObjectStreamClass lookup(Class<?> cl)
查找可序列化类的描述符。如果类的 ObjectStreamClass 实例不存在，则需要创建一个实例。如果指定的类不能实现 java.io.Serializable 或 java.io.Externalizable，则返回 null。

参数：
cl - 获取描述符的类
返回：
指定类的类描述符

lookupAny

public static ObjectStreamClass lookupAny(Class<?> cl)
返回任意类的描述符，不考虑它是否实现 Serializable。

参数：
cl - 获取描述符的类
返回：
指定类的类描述符
从以下版本开始：
1.6

getName

public String getName()
返回由此描述符描述的类的名称。此方法返回 Class.getName() 方法所使用格式中的类名称。

返回：
表示类的名称的字符串

getSerialVersionUID

public long getSerialVersionUID()
返回此类的 serialVersionUID。serialVersionUID 定义了一组具有相同名称的类，它们的名称都是从公共根类演化而来的，并且能够使用公共格式进行序列化和反序列化。NonSerializable 类的 serialVersionUID 为 0L。

返回：
由此描述符所描述类的 SUID

forClass

public Class<?> forClass()
返回此版本所映射的本地 VM 中的类。如果不存在对应的本地类，则返回 null。

返回：
此描述符表示的 Class 实例

getFields

public ObjectStreamField[] getFields()
返回此可序列化类的字段组成的数组。

返回：
包含此类的每个持久字段的元素组成的数组。如果没有字段，则返回长度为零的数组。
从以下版本开始：
1.2

getField

public ObjectStreamField getField(String name)
按名称获取此类的字段。

参数：
name - 要查找的数据字段的名称
返回：
指定字段的 ObjectStreamField 对象；如果不存在这种指定的字段，则返回 null。

toString

public String toString()
返回描述此 ObjectStreamClass 的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectStreamConstants (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 ObjectStreamConstants

所有已知实现类：
ObjectInputStream, ObjectOutputStream
public interface ObjectStreamConstants

写入 Object Serialization Stream 的常量。

从以下版本开始：
JDK 1.1

字段摘要
static int | baseWireHandle 分配的第一个句柄。
static int | PROTOCOL_VERSION_1 流协议的版本。
static int | PROTOCOL_VERSION_2 流协议的版本。
static byte | SC_BLOCK_DATA ObjectStreamClass 标志的位掩码。
static byte | SC_ENUM ObjectStreamClass 标志的位掩码。
static byte | SC_EXTERNALIZABLE ObjectStreamClass 标志的位掩码。
static byte | SC_SERIALIZABLE ObjectStreamClass 标志的位掩码。
static byte | SC_WRITE_METHOD ObjectStreamClass 标志的位掩码。
static short | STREAM_MAGIC 写入流头的幻数。
static short | STREAM_VERSION 写入流头的版本号。
static SerializablePermission | SUBCLASS_IMPLEMENTATION_PERMISSION 允许重写 readObject 和 writeObject。
static SerializablePermission | SUBSTITUTION_PERMISSION 允许在序列化/反序列化期间使用一个对象取代另一个对象。
static byte | TC_ARRAY 新的 Array。
static byte | TC_BASE 第一个标记值。
static byte | TC_BLOCKDATA 可选数据块。
static byte | TC_BLOCKDATALONG long Block 数据。
static byte | TC_CLASS Class 的引用。
static byte | TC_CLASSDESC 新的 Class Descriptor。
static byte | TC_ENDBLOCKDATA 可选块数据的末尾因对象而阻塞。
static byte | TC_ENUM 新的 Enum 常量。
static byte | TC_EXCEPTION 写入过程中的异常。
static byte | TC_LONGSTRING Long 字符串。
static byte | TC_MAX 最后一个标记值。
static byte | TC_NULL Null 对象引用。
static byte | TC_OBJECT 新的 Object。
static byte | TC_PROXYCLASSDESC 新的 Proxy Class Descriptor。
static byte | TC_REFERENCE 已写入流的对象的引用。
static byte | TC_RESET 重置流上下文。
static byte | TC_STRING 新的 String。

字段详细信息

STREAM_MAGIC

static final short STREAM_MAGIC
写入流头的幻数。

另请参见：
常量字段值

STREAM_VERSION

static final short STREAM_VERSION
写入流头的版本号。

另请参见：
常量字段值

TC_BASE

static final byte TC_BASE
第一个标记值。

另请参见：
常量字段值

TC_NULL

static final byte TC_NULL
Null 对象引用。

另请参见：
常量字段值

TC_REFERENCE

static final byte TC_REFERENCE
已写入流的对象的引用。

另请参见：
常量字段值

TC_CLASSDESC

static final byte TC_CLASSDESC
新的 Class Descriptor。

另请参见：
常量字段值

TC_OBJECT

static final byte TC_OBJECT
新的 Object。

另请参见：
常量字段值

TC_STRING

static final byte TC_STRING
新的 String。

另请参见：
常量字段值

TC_ARRAY

static final byte TC_ARRAY
新的 Array。

另请参见：
常量字段值

TC_CLASS

static final byte TC_CLASS
Class 的引用。

另请参见：
常量字段值

TC_BLOCKDATA

static final byte TC_BLOCKDATA
可选数据块。跟在标记后面的字节指示此块数据中的字节数。

另请参见：
常量字段值

TC_ENDBLOCKDATA

static final byte TC_ENDBLOCKDATA
可选块数据的末尾因对象而阻塞。

另请参见：
常量字段值

TC_RESET

static final byte TC_RESET
重置流上下文。重置写入流的所有句柄。

另请参见：
常量字段值

TC_BLOCKDATALONG

static final byte TC_BLOCKDATALONG
long Block 数据。跟在标记后面的 long 指示此块数据中的字节数。

另请参见：
常量字段值

TC_EXCEPTION

static final byte TC_EXCEPTION
写入过程中的异常。

另请参见：
常量字段值

TC_LONGSTRING

static final byte TC_LONGSTRING
Long 字符串。

另请参见：
常量字段值

TC_PROXYCLASSDESC

static final byte TC_PROXYCLASSDESC
新的 Proxy Class Descriptor。

另请参见：
常量字段值

TC_ENUM

static final byte TC_ENUM
新的 Enum 常量。

从以下版本开始：
1.5
另请参见：
常量字段值

TC_MAX

static final byte TC_MAX
最后一个标记值。

另请参见：
常量字段值

baseWireHandle

static final int baseWireHandle
分配的第一个句柄。

另请参见：
常量字段值

SC_WRITE_METHOD

static final byte SC_WRITE_METHOD
ObjectStreamClass 标志的位掩码。指示 Serializable 类，该类定义自身的 writeObject 方法。

另请参见：
常量字段值

SC_BLOCK_DATA

static final byte SC_BLOCK_DATA
ObjectStreamClass 标志的位掩码。指示以 Block Data 模式写入的 Externalizable 数据。为 PROTOCOL_VERSION_2 添加。

从以下版本开始：
1.2
另请参见：
PROTOCOL_VERSION_2, 常量字段值

SC_SERIALIZABLE

static final byte SC_SERIALIZABLE
ObjectStreamClass 标志的位掩码。指示类为 Serializable。

另请参见：
常量字段值

SC_EXTERNALIZABLE

static final byte SC_EXTERNALIZABLE
ObjectStreamClass 标志的位掩码。指示类为 Externalizable。

另请参见：
常量字段值

SC_ENUM

static final byte SC_ENUM
ObjectStreamClass 标志的位掩码。指示类为 enum 类型。

从以下版本开始：
1.5
另请参见：
常量字段值

SUBSTITUTION_PERMISSION

static final SerializablePermission SUBSTITUTION_PERMISSION
允许在序列化/反序列化期间使用一个对象取代另一个对象。

从以下版本开始：
1.2
另请参见：
ObjectOutputStream.enableReplaceObject(boolean), ObjectInputStream.enableResolveObject(boolean)

SUBCLASS_IMPLEMENTATION_PERMISSION

static final SerializablePermission SUBCLASS_IMPLEMENTATION_PERMISSION
允许重写 readObject 和 writeObject。

从以下版本开始：
1.2
另请参见：
ObjectOutputStream.writeObjectOverride(Object), ObjectInputStream.readObjectOverride()

PROTOCOL_VERSION_1

static final int PROTOCOL_VERSION_1
流协议的版本。

调用此方法后，所有可扩展的数据都将使用 JDK 1.1 外部数据格式写入。当流中包含 JDK 1.1.6 JVM 之前的版本可读取的 Externalizable 数据时，此版本为写入流所必需的。

从以下版本开始：
1.2
另请参见：
ObjectOutputStream.useProtocolVersion(int), 常量字段值

PROTOCOL_VERSION_2

static final int PROTOCOL_VERSION_2
流协议的版本。

此协议由 JVM 1.2 写入。 Externalizable 数据以块数据模式写入，使用 TC_ENDBLOCKDATA 终止。Externalizable 类描述符标志已启用 SC_BLOCK_DATA。JVM 1.1.6 及更高版本可以读取此格式的更改。 允许将 nonSerializable 类描述符写入流。将 nonSerializable 类的 serialVersionUID 设置为 0L。

从以下版本开始：
1.2
另请参见：
ObjectOutputStream.useProtocolVersion(int), SC_BLOCK_DATA, 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectStreamException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ObjectStreamException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
所有已实现的接口：
Serializable
直接已知子类：
InvalidClassException, InvalidObjectException, NotActiveException, NotSerializableException, OptionalDataException, StreamCorruptedException, WriteAbortedException
public abstract class ObjectStreamException
extends IOException

特定于 Object Stream 类的所有异常的超类。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
protected | ObjectStreamException() 创建一个 ObjectStreamException。
protected | ObjectStreamException(String classname) 创建具有指定参数的 ObjectStreamException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectStreamException

protected ObjectStreamException(String classname)
创建具有指定参数的 ObjectStreamException。

参数：
classname - 异常的详细消息

ObjectStreamException

protected ObjectStreamException()
创建一个 ObjectStreamException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectStreamField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 ObjectStreamField

java.lang.Object
    继承者  java.io.ObjectStreamField
所有已实现的接口：
Comparable<Object>
public class ObjectStreamField
extends Object
implements Comparable<Object>

Serializable 类中 Serializable 字段的描述。ObjectStreamField 的数组用于声明类的 Serializable 字段。

从以下版本开始：
1.2
另请参见：
ObjectStreamClass

构造方法摘要
ObjectStreamField(String name, Class<?> type)
创建具有指定类型的 Serializable 字段。
ObjectStreamField(String name, Class<?> type, boolean unshared)
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。
方法摘要
int | compareTo(Object obj) 将此字段与另一个 ObjectStreamField 进行比较。
String | getName() 获取此字段的名称。
int | getOffset() 实例数据中字段的偏移量。
Class<?> | getType() 获取字段的类型。
char | getTypeCode() 返回字段类型的字符编码。
String | getTypeString() 返回 JVM 类型签名。
boolean | isPrimitive() 如果此字段为基本类型，则返回 true。
boolean | isUnshared() 返回一个 boolean 值，指示由 ObjectStreamField 实例所表示的可序列化字段是否未共享。
protected void | setOffset(int offset) 实例数据中的偏移量。
String | toString() 返回描述此字段的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectStreamField

public ObjectStreamField(String name,
                         Class<?> type)
创建具有指定类型的 Serializable 字段。此字段应该使用 serialField 标记记录。

参数：
name - 可序列化字段的名称
type - 可序列化字段的 Class 对象。

ObjectStreamField

public ObjectStreamField(String name,
                         Class<?> type,
                         boolean unshared)
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。如果未共享为 false，则以默认方式序列化和反序列化所表示字段的值；如果字段为非基本类型，则像通过调用 writeObject 和 readObject 读写对象值那样序列化和反序列化它们。如果未共享为 true，则像通过调用 writeUnshared 和 readUnshared 读写所表示字段的值那样序列化和反序列化它们。

参数：
name - 字段名称
type - 字段类型
unshared - 如果为 false，则以与 writeObject/readObject 相同的方式读/写字段值；如果为 true，则以与 writeUnshared/readUnshared 相同的方式进行读/写
从以下版本开始：
1.4
方法详细信息

getName

public String getName()
获取此字段的名称。

返回：
表示可序列化字段名称的 String

getType

public Class<?> getType()
获取字段的类型。如果类型为非基本类型且此 ObjectStreamField 是从反序列化的 ObjectStreamClass 实例中获取的，则返回 Object.class。否则，返回字段类型的 Class 对象。

返回：
表示可序列化字段类型的 Class 对象

getTypeCode

public char getTypeCode()
返回字段类型的字符编码。编码如下：
 B            byte
 C            char
 D            double
 F            float
 I            int
 J            long
 L            class or interface
 S            short
 Z            boolean
 [            array

返回：
可序列化字段的类型代码

getTypeString

public String getTypeString()
返回 JVM 类型签名。

返回：
如果此字段为基本类型，则返回 null。

getOffset

public int getOffset()
实例数据中字段的偏移量。

返回：
此字段的偏移量
另请参见：
setOffset(int)

setOffset

protected void setOffset(int offset)
实例数据中的偏移量。

参数：
offset - 字段的偏移量
另请参见：
getOffset()

isPrimitive

public boolean isPrimitive()
如果此字段为基本类型，则返回 true。

返回：
当且仅当此字段对应于基本类型时返回 true

isUnshared

public boolean isUnshared()
返回一个 boolean 值，指示由 ObjectStreamField 实例所表示的可序列化字段是否未共享。

从以下版本开始：
1.4

compareTo

public int compareTo(Object obj)
将此字段与另一个 ObjectStreamField 进行比较。如果此字段较小则返回 -1，如果相等则返回 0，如果较大则返回 1。基本类型“小于”对象类型。如果相等，则比较字段名称。

指定者：
接口 Comparable<Object> 中的 compareTo
参数：
obj - 要比较的对象。
返回：
负整数、零或正整数，根据此对象是小于、等于还是大于指定对象。

toString

public String toString()
返回描述此字段的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OptionalDataException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 OptionalDataException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
                    继承者  java.io.OptionalDataException
所有已实现的接口：
Serializable
public class OptionalDataException
extends ObjectStreamException

指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。以下两种情况都可能抛出此异常：

  • 流中下一个元素是基本数据时试图读取对象。在这种情况下，OptionalDataException 的 length 字段设置成了可从流中直接读取的基本数据的字节数，而 eof 字段设置成了 false。
  • 试图使用类定义的 readObject 或 readExternal 方法读取数据末尾的后面。在这种情况下，OptionalDataException 的 eof 字段设置成了 true，而 length 字段设置成了 0。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
boolean | eof 如果流的缓冲部分不再有数据，则为 True。
int | length 当前缓冲区中可读取的基本数据的字节数。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

length

public int length
当前缓冲区中可读取的基本数据的字节数。

eof

public boolean eof
如果流的缓冲部分不再有数据，则为 True。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 OutputStream

java.lang.Object
    继承者  java.io.OutputStream
所有已实现的接口：
Closeable, Flushable
直接已知子类：
ByteArrayOutputStream, FileOutputStream, FilterOutputStream, ObjectOutputStream, OutputStream, PipedOutputStream
public abstract class OutputStream
extends Object
implements Closeable, Flushable

此抽象类是表示输出字节流的所有类的超类。输出流接受输出字节并将这些字节发送到某个接收器。

需要定义 OutputStream 子类的应用程序必须始终提供至少一种可写入一个输出字节的方法。

从以下版本开始：
JDK1.0
另请参见：
BufferedOutputStream, ByteArrayOutputStream, DataOutputStream, FilterOutputStream, InputStream, write(int)

构造方法摘要
OutputStream()
方法摘要
void | close() 关闭此输出流并释放与此流有关的所有系统资源。
void | flush() 刷新此输出流并强制写出所有缓冲的输出字节。
void | write(byte[] b) 将 b.length 个字节从指定的 byte 数组写入此输出流。
void | write(byte[] b, int off, int len) 将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
abstract void | write(int b) 将指定的字节写入此输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OutputStream

public OutputStream()
方法详细信息

write

public abstract void write(int b)
                    throws IOException
将指定的字节写入此输出流。write 的常规协定是：向输出流写入一个字节。要写入的字节是参数 b 的八个低位。b 的 24 个高位将被忽略。

OutputStream 的子类必须提供此方法的实现。

参数：
b - 字节
抛出：
IOException - 如果发生 I/O 错误。尤其是，如果已关闭输出流，则可能抛出 IOException。

write

public void write(byte[] b)
           throws IOException
将 b.length 个字节从指定的 byte 数组写入此输出流。write(b) 的常规协定是：应该与调用 write(b, 0, b.length) 的效果完全相同。

参数：
b - 数据。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
write(byte[], int, int)

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。write(b, off, len) 的常规协定是：将数组 b 中的某些字节按顺序写入输出流；元素 b[off] 是此操作写入的第一个字节，b[off+len-1] 是此操作写入的最后一个字节。

OutputStream 的 write 方法对每个要写出的字节调用一个参数的 write 方法。建议子类重写此方法并提供更有效的实现。

如果 b 为 null，则抛出 NullPointerException。

如果 off 为负，或 len 为负，或者 off+len 大于数组 b 的长度，则抛出 IndexOutOfBoundsException。

参数：
b - 数据。
off - 数据中的初始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。尤其是，如果关闭了输出流，则抛出 IOException。

flush

public void flush()
           throws IOException
刷新此输出流并强制写出所有缓冲的输出字节。flush 的常规协定是：如果此输出流的实现已经缓冲了以前写入的任何字节，则调用此方法指示应将这些字节立即写入它们预期的目标。

如果此流的预期目标是由基础操作系统提供的一个抽象（如一个文件），则刷新此流只能保证将以前写入到流的字节传递给操作系统进行写入，但不保证能将这些字节实际写入到物理设备（如磁盘驱动器）。

OutputStream 的 flush 方法不执行任何操作。

指定者：
接口 Flushable 中的 flush
抛出：
IOException - 如果发生 I/O 错误。

close

public void close()
           throws IOException
关闭此输出流并释放与此流有关的所有系统资源。close 的常规协定是：该方法将关闭输出流。关闭的流不能执行输出操作，也不能重新打开。

OutputStream 的 close 方法不执行任何操作。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OutputStreamWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 OutputStreamWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.OutputStreamWriter
所有已实现的接口：
Closeable, Flushable, Appendable
直接已知子类：
FileWriter
public class OutputStreamWriter
extends Writer

OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。它使用的字符集可以由名称指定或显式给定，否则将接受平台默认的字符集。

每次调用 write() 方法都会导致在给定字符（或字符集）上调用编码转换器。在写入底层输出流之前，得到的这些字节将在缓冲区中累积。可以指定此缓冲区的大小，不过，默认的缓冲区对多数用途来说已足够大。注意，传递给 write() 方法的字符没有缓冲。

为了获得最高效率，可考虑将 OutputStreamWriter 包装到 BufferedWriter 中，以避免频繁调用转换器。例如：

 Writer out
   = new BufferedWriter(new OutputStreamWriter(System.out));

代理对 是一个字符，它由两个 char 值序列表示：高 代理项的范围为 '\uD800' 到 '\uDBFF'，后跟范围为 '\uDC00' 到 '\uDFFF' 的低 代理项。

错误代理元素 指的是后面不跟低代理项的高代理项，或前面没有高代理项的低代理项。

此类总是使用字符集的默认替代序列 替代错误代理元素和不可映射的字符序列。如果需要更多地控制编码过程，则应该使用 CharsetEncoder 类。

从以下版本开始：
JDK1.1
另请参见：
BufferedWriter, OutputStream, Charset

字段摘要
从类 java.io.Writer 继承的字段
lock
构造方法摘要
OutputStreamWriter(OutputStream out)
创建使用默认字符编码的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, Charset cs)
创建使用给定字符集的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, CharsetEncoder enc)
创建使用给定字符集编码器的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, String charsetName)
创建使用指定字符集的 OutputStreamWriter。
方法摘要
void | close() 关闭此流，但要先刷新它。
void | flush() 刷新该流的缓冲。
String | getEncoding() 返回此流使用的字符编码的名称。
void | write(char[] cbuf, int off, int len) 写入字符数组的某一部分。
void | write(int c) 写入单个字符。
void | write(String str, int off, int len) 写入字符串的某一部分。
从类 java.io.Writer 继承的方法
append, append, append, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OutputStreamWriter

public OutputStreamWriter(OutputStream out,
                          String charsetName)
                   throws UnsupportedEncodingException
创建使用指定字符集的 OutputStreamWriter。

参数：
out - OutputStream
charsetName - 受支持 charset 的名称
抛出：
UnsupportedEncodingException - 如果不支持指定的编码

OutputStreamWriter

public OutputStreamWriter(OutputStream out)
创建使用默认字符编码的 OutputStreamWriter。

参数：
out - OutputStream

OutputStreamWriter

public OutputStreamWriter(OutputStream out,
                          Charset cs)
创建使用给定字符集的 OutputStreamWriter。

参数：
out - OutputStream
cs - 字符集
从以下版本开始：
1.4

OutputStreamWriter

public OutputStreamWriter(OutputStream out,
                          CharsetEncoder enc)
创建使用给定字符集编码器的 OutputStreamWriter。

参数：
out - OutputStream
enc - 字符集编码器
从以下版本开始：
1.4
方法详细信息

getEncoding

public String getEncoding()
返回此流使用的字符编码的名称。

如果该编码具有历史名称，则返回该名称；否则返回该编码的规范化名称。

如果此实例是用 OutputStreamWriter(OutputStream, String) 构造方法创建的，则返回的对于编码唯一的名称可能与传递给该构造方法的名称不同。如果流已经关闭，则此方法可能返回 null。

返回：
此编码的历史名称；如果流已经关闭，则可能返回 null
另请参见：
Charset

write

public void write(int c)
           throws IOException
写入单个字符。

覆盖：
类 Writer 中的 write
参数：
c - 指定要写入字符的 int。
抛出：
IOException - 如果发生 I/O 错误

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
写入字符数组的某一部分。

指定者：
类 Writer 中的 write
参数：
cbuf - 字符缓冲区
off - 开始写入字符处的偏移量
len - 要写入的字符数
抛出：
IOException - 如果发生 I/O 错误

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
写入字符串的某一部分。

覆盖：
类 Writer 中的 write
参数：
str - 字符串
off - 开始写入字符处的偏移量
len - 要写入的字符数
抛出：
IOException - 如果发生 I/O 错误

flush

public void flush()
           throws IOException
刷新该流的缓冲。

指定者：
接口 Flushable 中的 flush
指定者：
类 Writer 中的 flush
抛出：
IOException - 如果发生 I/O 错误

close

public void close()
           throws IOException
从类 Writer 复制的描述
关闭此流，但要先刷新它。在关闭该流之后，再调用 write() 或 flush() 将导致抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Writer 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PipedInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PipedInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.PipedInputStream
所有已实现的接口：
Closeable
public class PipedInputStream
extends InputStream

管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。通常，数据由某个线程从 PipedInputStream 对象读取，并由其他线程将其写入到相应的 PipedOutputStream。不建议对这两个对象尝试使用单个线程，因为这样可能死锁线程。管道输入流包含一个缓冲区，可在缓冲区限定的范围内将读操作和写操作分离开。 如果向连接管道输出流提供数据字节的线程不再存在，则认为该管道已损坏。

从以下版本开始：
JDK1.0
另请参见：
PipedOutputStream

字段摘要
protected byte[] | buffer 放置传入数据的循环缓冲区。
protected int | in 循环缓冲区中位置的索引，当从连接的管道输出流中接收到下一个数据字节时，会将其存储到该位置。
protected int | out 循环缓冲区中位置的索引，此管道输入流将从该位置读取下一个数据字节。
protected static int | PIPE_SIZE 管道循环输入缓冲区的默认大小。
构造方法摘要
PipedInputStream()
创建尚未连接的 PipedInputStream。
PipedInputStream(int pipeSize)
创建一个尚未连接的 PipedInputStream，并对管道缓冲区使用指定的管道大小。
PipedInputStream(PipedOutputStream src)
创建 PipedInputStream，使其连接到管道输出流 src。
PipedInputStream(PipedOutputStream src, int pipeSize)
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。
方法摘要
int | available() 返回可以不受阻塞地从此输入流中读取的字节数。
void | close() 关闭此管道输入流并释放与该流相关的所有系统资源。
void | connect(PipedOutputStream src) 使此管道输入流连接到管道输出流 src。
int | read() 读取此管道输入流中的下一个数据字节。
int | read(byte[] b, int off, int len) 将最多 len 个数据字节从此管道输入流读入 byte 数组。
protected void | receive(int b) 接收数据字节。
从类 java.io.InputStream 继承的方法
mark, markSupported, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PIPE_SIZE

protected static final int PIPE_SIZE
管道循环输入缓冲区的默认大小。

从以下版本开始：
JDK1.1
另请参见：
常量字段值

buffer

protected byte[] buffer
放置传入数据的循环缓冲区。

从以下版本开始：
JDK1.1

in

protected int in
循环缓冲区中位置的索引，当从连接的管道输出流中接收到下一个数据字节时，会将其存储到该位置。in<0 意味着缓冲区为空，in==out 意味着缓冲区已满。

从以下版本开始：
JDK1.1

out

protected int out
循环缓冲区中位置的索引，此管道输入流将从该位置读取下一个数据字节。

从以下版本开始：
JDK1.1
构造方法详细信息

PipedInputStream

public PipedInputStream(PipedOutputStream src)
                 throws IOException
创建 PipedInputStream，使其连接到管道输出流 src。写入 src 的数据字节可用作此流的输入。

参数：
src - 要连接的流。
抛出：
IOException - 如果发生 I/O 错误。

PipedInputStream

public PipedInputStream(PipedOutputStream src,
                        int pipeSize)
                 throws IOException
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。 写入 src 的数据字节可用作此流的输入。

参数：
src - 要连接的流。
pipeSize - 管道缓冲区的大小。
抛出：
IOException - 如果发生 I/O 错误。
IllegalArgumentException - 如果 pipeSize <= 0。
从以下版本开始：
1.6

PipedInputStream

public PipedInputStream()
创建尚未连接的 PipedInputStream。在使用前必须将其连接到 PipedOutputStream。

PipedInputStream

public PipedInputStream(int pipeSize)
创建一个尚未连接的 PipedInputStream，并对管道缓冲区使用指定的管道大小。在使用前必须将其连接到 PipedOutputStream。

参数：
pipeSize - 管道缓冲区的大小。
抛出：
IllegalArgumentException - 如果 pipeSize <= 0。
从以下版本开始：
1.6
方法详细信息

connect

public void connect(PipedOutputStream src)
             throws IOException
使此管道输入流连接到管道输出流 src。如果此对象已经连接到其他某个管道输出流，则抛出 IOException。

如果 src 为未连接的管道输出流，snk 为未连接的管道输入流，则可以通过以下任一调用使其连接：

snk.connect(src)

或：

src.connect(snk)

这两个调用的效果相同。

参数：
src - 要连接的管道输出流。
抛出：
IOException - 如果发生 I/O 错误。

receive

protected void receive(int b)
                throws IOException
接收数据字节。如果不存在可用的输入，此方法将发生阻塞。

参数：
b - 将接收的字节
抛出：
IOException - 如果管道损坏、未连接、关闭，或者发生 I/O 错误。
从以下版本开始：
JDK1.1

read

public int read()
         throws IOException
读取此管道输入流中的下一个数据字节。返回 0 到 255 范围内的 int 字节值。在输入数据可用、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
类 InputStream 中的 read
返回：
下一个数据字节；如果已到达流末尾，则返回 -1。
抛出：
IOException - 如果管道未连接、损坏、关闭，或者发生 I/O 错误。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
将最多 len 个数据字节从此管道输入流读入 byte 数组。如果已到达数据流的末尾，或者 len 超出管道缓冲区大小，则读取的字节数将少于 len。如果 len 为 0，则不读取任何字节并返回 0；否则，在至少 1 个输入字节可用、检测到流末尾、抛出异常前，该方法将一直阻塞。

覆盖：
类 InputStream 中的 read
参数：
b - 读入数据的缓冲区。
off - 目标数组 b 中的初始偏移量。
len - 读取的最多字节数。
返回：
读入缓冲区的总字节数；如果由于已到达流末尾而不再有数据，则返回 -1。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，len 为负，或者 len 大于 b.length - off
IOException - 如果管道损坏、未连接、关闭，或者发生 I/O 错误。
另请参见：
InputStream.read()

available

public int available()
              throws IOException
返回可以不受阻塞地从此输入流中读取的字节数。

覆盖：
类 InputStream 中的 available
返回：
可以不受阻塞地从此输入流读取的字节数；如果已经调用 close() 方法关闭此输入流、管道未连接或已损坏，则返回 0。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JDK1.0.2

close

public void close()
           throws IOException
关闭此管道输入流并释放与该流相关的所有系统资源。

指定者：
接口 Closeable 中的 close
覆盖：
类 InputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PipedOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PipedOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.PipedOutputStream
所有已实现的接口：
Closeable, Flushable
public class PipedOutputStream
extends OutputStream

可以将管道输出流连接到管道输入流来创建通信管道。管道输出流是管道的发送端。通常，数据由某个线程写入 PipedOutputStream 对象，并由其他线程从连接的 PipedInputStream 读取。不建议对这两个对象尝试使用单个线程，因为这样可能会造成该线程死锁。如果某个线程正从连接的管道输入流中读取数据字节，但该线程不再处于活动状态，则该管道被视为处于 毁坏 状态。

从以下版本开始：
JDK1.0
另请参见：
PipedInputStream

构造方法摘要
PipedOutputStream()
创建尚未连接到管道输入流的管道输出流。
PipedOutputStream(PipedInputStream snk)
创建连接到指定管道输入流的管道输出流。
方法摘要
void | close() 关闭此管道输出流并释放与此流有关的所有系统资源。
void | connect(PipedInputStream snk) 将此管道输出流连接到接收者。
void | flush() 刷新此输出流并强制写出所有缓冲的输出字节。
void | write(byte[] b, int off, int len) 将 len 字节从初始偏移量为 off 的指定 byte 数组写入该管道输出流。
void | write(int b) 将指定 byte 写入传送的输出流。
从类 java.io.OutputStream 继承的方法
write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PipedOutputStream

public PipedOutputStream(PipedInputStream snk)
                  throws IOException
创建连接到指定管道输入流的管道输出流。写入此流的数据字节稍后将用作 snk 的输入。

参数：
snk - 要连接的管道输入流。
抛出：
IOException - 如果发生 I/O 错误。

PipedOutputStream

public PipedOutputStream()
创建尚未连接到管道输入流的管道输出流。必须在使用之前将管道输出流连接到管道输入流（既可由接收者连接，也可由发送者连接）。

另请参见：
PipedInputStream.connect(java.io.PipedOutputStream), connect(java.io.PipedInputStream)
方法详细信息

connect

public void connect(PipedInputStream snk)
             throws IOException
将此管道输出流连接到接收者。如果此对象已经连接到其他某个管道输入流，则抛出 IOException。

如果 snk 是未连接的管道输入流，而 src 是未连接的管道输出流，则可以通过以下调用之一连接它们：

 src.connect(snk)
或：
 snk.connect(src)
这两个调用的效果相同。

参数：
snk - 要连接的管道输入流。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(int b)
           throws IOException
将指定 byte 写入传送的输出流。

实现 OutputStream 的 write 方法。

指定者：
类 OutputStream 中的 write
参数：
b - 要写入的 byte。
抛出：
IOException - 如果管道处于毁坏或未连接状态，或者发生 I/O 错误。

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将 len 字节从初始偏移量为 off 的指定 byte 数组写入该管道输出流。在将所有字节写入输出流之前，此方法一直处于阻塞状态。

覆盖：
类 OutputStream 中的 write
参数：
b - 数据。
off - 数据中的初始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果管道处于 毁坏或未连接状态，或者发生 I/O 错误。

flush

public void flush()
           throws IOException
刷新此输出流并强制写出所有缓冲的输出字节。这将通知所有 reader，告知它们管道中的字符处于等待中。

指定者：
接口 Flushable 中的 flush
覆盖：
类 OutputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误。

close

public void close()
           throws IOException
关闭此管道输出流并释放与此流有关的所有系统资源。此流可能无法再用于写入字节。

指定者：
接口 Closeable 中的 close
覆盖：
类 OutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PipedReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PipedReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.PipedReader
所有已实现的接口：
Closeable, Readable
public class PipedReader
extends Reader

传送的字符输入流。

从以下版本开始：
JDK1.1

字段摘要
从类 java.io.Reader 继承的字段
lock
构造方法摘要
PipedReader()
创建尚未连接的 PipedReader。
PipedReader(int pipeSize)
创建一个尚未连接的 PipedReader，并对管道缓冲区使用指定的管道大小。
PipedReader(PipedWriter src)
创建连接到传送 writer src 的 PipedReader。
PipedReader(PipedWriter src, int pipeSize)
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。
方法摘要
void | close() 关闭此传送流并释放与该流相关的所有系统资源。
void | connect(PipedWriter src) 使此传送 reader 连接到传送 writer src。
int | read() 读取此传送流中的下一个数据字符。
int | read(char[] cbuf, int off, int len) 将此传送流中最多 len 个数据字符读入字符数组。
boolean | ready() 告知是否准备读取此流。
从类 java.io.Reader 继承的方法
mark, markSupported, read, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PipedReader

public PipedReader(PipedWriter src)
            throws IOException
创建连接到传送 writer src 的 PipedReader。写入 src 的数据稍后将用作此流的输入。

参数：
src - 要连接的流。
抛出：
IOException - 如果发生 I/O 错误。

PipedReader

public PipedReader(PipedWriter src,
                   int pipeSize)
            throws IOException
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。写入到 src 的数据将可用作此流的输入。

参数：
src - 要连接的流。
pipeSize - 管道缓冲区的大小。
抛出：
IOException - 如果发生 I/O 错误。
IllegalArgumentException - 如果 pipeSize <= 0。
从以下版本开始：
1.6

PipedReader

public PipedReader()
创建尚未连接的 PipedReader。使用前必须将其连接到 PipedWriter。

PipedReader

public PipedReader(int pipeSize)
创建一个尚未连接的 PipedReader，并对管道缓冲区使用指定的管道大小。使用前必须将其连接到 PipedWriter。

参数：
pipeSize - 管道缓冲区的大小。
抛出：
IllegalArgumentException - 如果 pipeSize <= 0。
从以下版本开始：
1.6
方法详细信息

connect

public void connect(PipedWriter src)
             throws IOException
使此传送 reader 连接到传送 writer src。如果此对象已经连接到其他某个传送 writer，则抛出 IOException。

如果 src 是未连接的传送 writer，而 snk 是未连接的传送 reader，则可以通过以下调用之一连接它们：

snk.connect(src)

或：

src.connect(snk)

这两个调用的效果相同。

参数：
src - 要连接的传送 writer。
抛出：
IOException - 如果发生 I/O 错误。

read

public int read()
         throws IOException
读取此传送流中的下一个数据字符。如果因为已经到达流的末尾而没有可用的字符，则返回值 -1。在输入数据可用、检测到流的末尾或者抛出异常之前，此方法一直阻塞。

覆盖：
类 Reader 中的 read
返回：
下一个数据字符，如果到达流的末尾，则返回 -1。
抛出：
IOException - 如果管道处于 broken、未连接或关闭状态，或者发生 I/O 错误。

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException
将此传送流中最多 len 个数据字符读入字符数组。如果已到达数据流的末尾，或者 len 超出管道缓冲区大小，则读取的字符数少于 len。此方法一直阻塞，直到至少一个输入字符可用。

指定者：
类 Reader 中的 read
参数：
cbuf - 读入数据的缓冲区。
off - 数据的初始偏移量。
len - 读取的最大字符数。
返回：
读入缓冲区的总字符数，如果因为已经到达流末尾而不再有数据可用，则返回 -1。
抛出：
IOException - 如果管道处于 broken、未连接或关闭状态，或者发生 I/O 错误。

ready

public boolean ready()
              throws IOException
告知是否准备读取此流。如果循环缓冲区不为空，则传送字符流已做好被读取的准备。

覆盖：
类 Reader 中的 ready
返回：
如果保证下一个 read() 不阻塞输入，则返回 True，否则返回 false。注意，返回 false 并不保证阻塞下一次读取。
抛出：
IOException - 如果管道处于 broken、未连接或关闭状态。

close

public void close()
           throws IOException
关闭此传送流并释放与该流相关的所有系统资源。

指定者：
接口 Closeable 中的 close
指定者：
类 Reader 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PipedWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PipedWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.PipedWriter
所有已实现的接口：
Closeable, Flushable, Appendable
public class PipedWriter
extends Writer

传送的字符输出流。

从以下版本开始：
JDK1.1

字段摘要
从类 java.io.Writer 继承的字段
lock
构造方法摘要
PipedWriter()
创建一个尚未连接到传送 reader 的传送 writer。
PipedWriter(PipedReader snk)
创建传送 writer，使其连接到指定的传送 reader。
方法摘要
void | close() 关闭此管道输出流并释放与此流相关的所有系统资源。
void | connect(PipedReader snk) 将此传送 writer 连接到接收方。
void | flush() 刷新此输出流并强制写出所有缓冲的输出字符。
void | write(char[] cbuf, int off, int len) 将 len 字符从指定初始偏移量为 off 的字符数组写入到此管道输出流。
void | write(int c) 将指定的 char 写入管道输出流。
从类 java.io.Writer 继承的方法
append, append, append, write, write, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PipedWriter

public PipedWriter(PipedReader snk)
            throws IOException
创建传送 writer，使其连接到指定的传送 reader。写入此流的数据字符稍后将用作 snk 的输入。

参数：
snk - 连接的传送 reader。
抛出：
IOException - 如果发生 I/O 错误。

PipedWriter

public PipedWriter()
创建一个尚未连接到传送 reader 的传送 writer。必须在使用之前将其连接到传送 reader（既可由接收方连接，也可由发送方连接）。

另请参见：
PipedReader.connect(java.io.PipedWriter), connect(java.io.PipedReader)
方法详细信息

connect

public void connect(PipedReader snk)
             throws IOException
将此传送 writer 连接到接收方。如果此对象已经连接到其他某个传送 reader，则抛出 IOException。

如果 snk 为未连接的传送 reader，而 src 为未连接的传送 writer，则可以通过以下任一调用使其连接：

 src.connect(snk)
或：
 snk.connect(src)
这两个调用的效果相同。

参数：
snk - 连接的传送 reader。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(int c)
           throws IOException
将指定的 char 写入管道输出流。如果某个线程正从连接的管道输入流读取数据字符，但该线程不再处于活动状态，则抛出 IOException。

实现 Writer 的 write 方法。

覆盖：
类 Writer 中的 write
参数：
c - 要写入的 char。
抛出：
IOException - 如果管道 损坏、未连接、关闭或发生 I/O 错误。

write

public void write(char[] cbuf,
                  int off,
                  int len)
           throws IOException
将 len 字符从指定初始偏移量为 off 的字符数组写入到此管道输出流。在将所有字符写入输出流之前，此方法将阻塞。如果某个线程正从连接的管道输入流读取数据字符，但该线程不再处于活动状态，则抛出 IOException。

指定者：
类 Writer 中的 write
参数：
cbuf - 数据。
off - 数据中的初始偏移量。
len - 要写入的字符数。
抛出：
IOException - 如果管道 损坏、未连接、关闭或发生 I/O 错误。

flush

public void flush()
           throws IOException
刷新此输出流并强制写出所有缓冲的输出字符。这将通知所有 reader，告知它们管道中的字符处于等待中。

指定者：
接口 Flushable 中的 flush
指定者：
类 Writer 中的 flush
抛出：
IOException - 如果管道关闭，或者发生 I/O 错误。

close

public void close()
           throws IOException
关闭此管道输出流并释放与此流相关的所有系统资源。此流可能无法再用于写入字符。

指定者：
接口 Closeable 中的 close
指定者：
类 Writer 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PrintStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.io.PrintStream
所有已实现的接口：
Closeable, Flushable, Appendable
直接已知子类：
LogStream
public class PrintStream
extends FilterOutputStream
implements Appendable, Closeable

PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。它还提供其他两项功能。与其他输出流不同，PrintStream 永远不会抛出 IOException；而是，异常情况仅设置可通过 checkError 方法测试的内部标志。另外，为了自动刷新，可以创建一个 PrintStream；这意味着可在写入 byte 数组之后自动调用 flush 方法，可调用其中一个 println 方法，或写入一个换行符或字节 ('\n')。

PrintStream 打印的所有字符都使用平台的默认字符编码转换为字节。在需要写入字符而不是写入字节的情况下，应该使用 PrintWriter 类。

从以下版本开始：
JDK1.0

字段摘要
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
PrintStream(File file)
创建具有指定文件且不带自动行刷新的新打印流。
PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintStream(OutputStream out)
创建新的打印流。
PrintStream(OutputStream out, boolean autoFlush)
创建新的打印流。
PrintStream(OutputStream out, boolean autoFlush, String encoding)
创建新的打印流。
PrintStream(String fileName)
创建具有指定文件名称且不带自动行刷新的新打印流。
PrintStream(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
方法摘要
PrintStream | append(char c) 将指定字符添加到此输出流。
PrintStream | append(CharSequence csq) 将指定字符序列添加到此输出流。
PrintStream | append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此输出流。
boolean | checkError() 刷新流并检查其错误状态。
protected void | clearError() 清除此流的内部错误状态。
void | close() 关闭流。
void | flush() 刷新该流的缓冲。
PrintStream | format(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
PrintStream | format(String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
void | print(boolean b) 打印 boolean 值。
void | print(char c) 打印字符。
void | print(char[] s) 打印字符数组。
void | print(double d) 打印双精度浮点数。
void | print(float f) 打印浮点数。
void | print(int i) 打印整数。
void | print(long l) 打印 long 整数。
void | print(Object obj) 打印对象。
void | print(String s) 打印字符串。
PrintStream | printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
PrintStream | printf(String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
void | println() 通过写入行分隔符字符串终止当前行。
void | println(boolean x) 打印 boolean 值，然后终止行。
void | println(char x) 打印字符，然后终止该行。
void | println(char[] x) 打印字符数组，然后终止该行。
void | println(double x) 打印 double，然后终止该行。
void | println(float x) 打印 float，然后终止该行。
void | println(int x) 打印整数，然后终止该行。
void | println(long x) 打印 long，然后终止该行。
void | println(Object x) 打印 Object，然后终止该行。
void | println(String x) 打印 String，然后终止该行。
protected void | setError() 将该流的错误状态设置为 true。
void | write(byte[] buf, int off, int len) 将 len 字节从指定的初始偏移量为 off 的 byte 数组写入此流。
void | write(int b) 将指定的字节写入此流。
从类 java.io.FilterOutputStream 继承的方法
write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PrintStream

public PrintStream(OutputStream out)
创建新的打印流。此流将不会自动刷新。

参数：
out - 将向其打印值和对象的输出流
另请参见：
PrintWriter.PrintWriter(java.io.OutputStream)

PrintStream

public PrintStream(OutputStream out,
                   boolean autoFlush)
创建新的打印流。

参数：
out - 将向其打印值和对象的输出流
autoFlush - boolean 变量；如果为 true，则每当写入 byte 数组、调用其中一个 println 方法或写入换行符或字节 ('\n') 时都会刷新输出缓冲区
另请参见：
PrintWriter.PrintWriter(java.io.OutputStream, boolean)

PrintStream

public PrintStream(OutputStream out,
                   boolean autoFlush,
                   String encoding)
            throws UnsupportedEncodingException
创建新的打印流。

参数：
out - 将向其打印值和对象的输出流
autoFlush - boolean 变量；如果为 true，则每当写入 byte 数组、调用其中一个 println 方法或写入换行符或字节 ('\n') 时都会刷新缓冲区
encoding - 受支持的字符编码的名称
抛出：
UnsupportedEncodingException - 如果不支持指定的编码
从以下版本开始：
1.4

PrintStream

public PrintStream(String fileName)
            throws FileNotFoundException
创建具有指定文件名称且不带自动行刷新的新打印流。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用此 Java 虚拟机实例的默认 charset 进行字符编码。

参数：
fileName - 要用作此打印流目标的文件名称。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(fileName) 拒绝对文件进行写入访问。
从以下版本开始：
1.5

PrintStream

public PrintStream(String fileName,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用提供的字符集进行字符编码。

参数：
fileName - 要用作此打印流目标的文件名称。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(fileName) 拒绝对文件进行写入访问。
UnsupportedEncodingException - 如果不支持指定字符集
从以下版本开始：
1.5

PrintStream

public PrintStream(File file)
            throws FileNotFoundException
创建具有指定文件且不带自动行刷新的新打印流。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用此 Java 虚拟机实例的默认 charset 进行字符编码。

参数：
file - 要用作此打印流目标的文件。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(file.getPath()) 拒绝对文件进行写入访问。
从以下版本开始：
1.5

PrintStream

public PrintStream(File file,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用提供的字符集进行字符编码。

参数：
file - 要用作此打印流目标的文件。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(file.getPath()) 拒绝对文件进行写入访问
UnsupportedEncodingException - 如果不支持指定字符集
从以下版本开始：
1.5
方法详细信息

flush

public void flush()
刷新该流的缓冲。通过将所有缓冲的输出字节写入到底层输出流然后刷新该流的缓冲，完成此操作。

指定者：
接口 Flushable 中的 flush
覆盖：
类 FilterOutputStream 中的 flush
另请参见：
OutputStream.flush()

close

public void close()
关闭流。通过刷新流然后关闭底层输出流，完成此操作。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterOutputStream 中的 close
另请参见：
OutputStream.close()

checkError

public boolean checkError()
刷新流并检查其错误状态。当底层输出流抛出 IOException 而不是 InterruptedIOException 时，以及调用 setError 方法时，内部错误状态将被设置为 true。如果对底层输出流的操作抛出 InterruptedIOException，则通过调用以下方法或等效方法，PrintStream 将该异常转换回中断状态：
     Thread.currentThread().interrupt();

返回：
当且仅当此流遇到 IOException 而不是 InterruptedIOException 时，或已调用 setError 方法时，返回 true。

setError

protected void setError()
将该流的错误状态设置为 true。

在调用 clearError() 之前，此方法将导致 checkError() 的后续调用返回 true。

从以下版本开始：
JDK1.1

clearError

protected void clearError()
清除此流的内部错误状态。

在另一个写入操作失败并调用 setError() 之前，此方法将导致 checkError() 的后续调用返回 false。

从以下版本开始：
1.6

write

public void write(int b)
将指定的字节写入此流。如果字节为新行且启用了自动刷新，则调用 flush 方法。

要注意按给定写入字节；要写入将根据平台的默认字符编码转换的字符，请使用 print(char) 或 println(char) 方法。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要写入的字节
另请参见：
print(char), println(char)

write

public void write(byte[] buf,
                  int off,
                  int len)
将 len 字节从指定的初始偏移量为 off 的 byte 数组写入此流。如果启用自动刷新，则调用 flush 方法。

注意，要按给定写入字节；要写入将根据平台的默认字符编码转换的字符，请使用 print(char) 或 println(char) 方法。

覆盖：
类 FilterOutputStream 中的 write
参数：
buf - byte 数组
off - 相对于开始写入字节处的偏移量
len - 要写入的字节数
另请参见：
FilterOutputStream.write(int)

print

public void print(boolean b)
打印 boolean 值。按照平台的默认字符编码将 String.valueOf(boolean) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
b - 要打印的 boolean

print

public void print(char c)
打印字符。按照平台的默认字符编码将字符转换为一个或多个字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
c - 要打印的 char

print

public void print(int i)
打印整数。按照平台的默认字节编码将 String.valueOf(int) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
i - 要打印的 int
另请参见：
Integer.toString(int)

print

public void print(long l)
打印 long 整数。按照平台的默认字符编码将 String.valueOf(long) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
l - 要打印的 long
另请参见：
Long.toString(long)

print

public void print(float f)
打印浮点数。按照平台的默认字符编码将 String.valueOf(float) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
f - 要打印的 float
另请参见：
Float.toString(float)

print

public void print(double d)
打印双精度浮点数。按照平台的默认字符编码将 String.valueOf(double) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
d - 要打印的 double
另请参见：
Double.toString(double)

print

public void print(char[] s)
打印字符数组。按照平台的默认字符编码将字符转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
s - 要打印的字符数组
抛出：
NullPointerException - 如果 s 为 null

print

public void print(String s)
打印字符串。如果参数为 null，则打印字符串 "null"。否则，按照平台的默认字符编码将字符串的字符转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
s - 要打印的 String

print

public void print(Object obj)
打印对象。按照平台的默认字符串编码将 String.valueOf(Object) 方法生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
obj - 要打印的 Object
另请参见：
Object.toString()

println

public void println()
通过写入行分隔符字符串终止当前行。行分隔符字符串由系统属性 line.separator 定义，不一定是单个换行符 ('\n')。

println

public void println(boolean x)
打印 boolean 值，然后终止行。此方法的行为就像先调用 print(boolean) 然后调用 println() 一样。

参数：
x - 要打印的 boolean

println

public void println(char x)
打印字符，然后终止该行。此方法的行为就像先调用 print(char) 然后调用 println() 一样。

参数：
x - 要打印的 char。

println

public void println(int x)
打印整数，然后终止该行。此方法的行为就像先调用 print(int) 然后调用 println() 一样。

参数：
x - 要打印的 int。

println

public void println(long x)
打印 long，然后终止该行。此方法的行为就像先调用 print(long) 然后调用 println() 一样。

参数：
x - 要打印的 long。

println

public void println(float x)
打印 float，然后终止该行。此方法的行为就像先调用 print(float) 然后调用 println() 一样。

参数：
x - 要打印的 float。

println

public void println(double x)
打印 double，然后终止该行。此方法的行为就像先调用 print(double) 然后调用 println() 一样。

参数：
x - 要打印的 double。

println

public void println(char[] x)
打印字符数组，然后终止该行。此方法的行为就像先调用 print(char[]) 然后调用 println() 一样。

参数：
x - 要打印的字符数组。

println

public void println(String x)
打印 String，然后终止该行。此方法的行为就像先调用 print(String) 然后调用 println() 一样。

参数：
x - 要打印的 String。

println

public void println(Object x)
打印 Object，然后终止该行。此方法首先调用 String.valueOf(x) 获取打印对象的字符串值，然后的行为如同先调用 print(String) 再调用 println() 一样。

参数：
x - 要打印的 Object。

printf

public PrintStream printf(String format,
                          Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

调用此方法的 out.printf(format, args) 形式，行为与以下调用完全相同：

     out.format(format, args)

参数：
format - 在格式字符串的语法中描述的格式字符串
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于 conversion。
返回：
此输出流
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

printf

public PrintStream printf(Locale l,
                          String format,
                          Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

调用此方法的 out.printf(l, format, args) 形式，行为与以下调用完全相同：

     out.format(l, format, args)

参数：
l - 格式化过程中应用的 locale。如果 l 为 null，则不应用本地化。
format - 在格式字符串的语法中描述的格式字符串
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于 conversion。
返回：
此输出流
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

format

public PrintStream format(String format,
                          Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

始终使用的语言环境是由 Locale.getDefault() 返回的语言环境，不管以前在此对象上调用了其他什么样的格式化方法。

参数：
format - 在格式字符串的语法中描述的格式字符串
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于 conversion。
返回：
此输出流
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

format

public PrintStream format(Locale l,
                          String format,
                          Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

参数：
l - 格式化过程中应用的 locale。如果 l 为 null，则不应用本地化。
format - 在格式字符串的语法中描述的格式字符串
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于 conversion。
返回：
此输出流
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

append

public PrintStream append(CharSequence csq)
将指定字符序列添加到此输出流。

此方法调用 out.append(csq) 的行为与调用下列方法完全相同：

     out.print(csq.toString())

可能不添加整个序列，也可能添加，具体取决于字符序列 csq 的 toString 规范。例如，调用一个字符缓冲区的 toString 方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

指定者：
接口 Appendable 中的 append
参数：
csq - 要添加的字符序列。如果 csq 为 null，则向此输出流添加四个字符 "null"。
返回：
此输出流
从以下版本开始：
1.5

append

public PrintStream append(CharSequence csq,
                          int start,
                          int end)
将指定字符序列的子序列添加到此输出流。

当 csq 不为 null 时，调用该方法的 out.append(csq、start、end) 形式，行为与以下调用完全相同：

     out.print(csq.subSequence(start, end).toString())

指定者：
接口 Appendable 中的 append
参数：
csq - 要添加子序列的字符序列。如果 csq 为 null，则添加这些字符，就好像 csq 包含四个字符 "null" 一样。
start - 子序列中第一个字符的索引
end - 子序列中最后一个字符后面的字符的索引
返回：
此输出流
抛出：
IndexOutOfBoundsException - 如果 start 或 end 为负，而 start 大于 end 或者 end 大于 csq.length()
从以下版本开始：
1.5

append

public PrintStream append(char c)
将指定字符添加到此输出流。

调用此方法的 out.append(c) 形式，行为与以下调用完全相同：

     out.print(c)

指定者：
接口 Appendable 中的 append
参数：
c - 要添加的 16 位字符
返回：
此输出流
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PrintWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.PrintWriter
所有已实现的接口：
Closeable, Flushable, Appendable
public class PrintWriter
extends Writer

向文本输出流打印对象的格式化表示形式。此类实现在 PrintStream 中的所有 print 方法。它不包含用于写入原始字节的方法，对于这些字节，程序应该使用未编码的字节流进行写入。

与 PrintStream 类不同，如果启用了自动刷新，则只有在调用 println、printf 或 format 的其中一个方法时才可能完成此操作，而不是每当正好输出换行符时才完成。这些方法使用平台自有的行分隔符概念，而不是换行符。

此类中的方法不会抛出 I/O 异常，尽管其某些构造方法可能抛出异常。客户端可能会查询调用 checkError() 是否出现错误。

从以下版本开始：
JDK1.1

字段摘要
protected  Writer out
此 PrintWriter 的底层字符输出流。
从类 java.io.Writer 继承的字段
lock
构造方法摘要
PrintWriter(File file)
使用指定文件创建不具有自动行刷新的新 PrintWriter。
PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
PrintWriter(OutputStream out)
根据现有的 OutputStream 创建不带自动行刷新的新 PrintWriter。
PrintWriter(OutputStream out, boolean autoFlush)
通过现有的 OutputStream 创建新的 PrintWriter。
PrintWriter(String fileName)
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。
PrintWriter(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。
PrintWriter(Writer out)
创建不带自动行刷新的新 PrintWriter。
PrintWriter(Writer out, boolean autoFlush)
创建新 PrintWriter。
方法摘要
PrintWriter | append(char c) 将指定字符添加到此 writer。
PrintWriter | append(CharSequence csq) 将指定的字符序列添加到此 writer。
PrintWriter | append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
boolean | checkError() 如果流没有关闭，则刷新流且检查其错误状态。
protected void | clearError() 清除此流的错误状态。
void | close() 关闭该流并释放与之关联的所有系统资源。
void | flush() 刷新该流的缓冲。
PrintWriter | format(Locale l, String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
PrintWriter | format(String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
void | print(boolean b) 打印 boolean 值。
void | print(char c) 打印字符。
void | print(char[] s) 打印字符数组。
void | print(double d) 打印 double 精度浮点数。
void | print(float f) 打印一个浮点数。
void | print(int i) 打印整数。
void | print(long l) 打印 long 整数。
void | print(Object obj) 打印对象。
void | print(String s) 打印字符串。
PrintWriter | printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
PrintWriter | printf(String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
void | println() 通过写入行分隔符字符串终止当前行。
void | println(boolean x) 打印 boolean 值，然后终止该行。
void | println(char x) 打印字符，然后终止该行。
void | println(char[] x) 打印字符数组，然后终止该行。
void | println(double x) 打印双精度浮点数，然后终止该行。
void | println(float x) 打印浮点数，然后终止该行。
void | println(int x) 打印整数，然后终止该行。
void | println(long x) 打印 long 整数，然后终止该行。
void | println(Object x) 打印 Object，然后终止该行。
void | println(String x) 打印 String，然后终止该行。
protected void | setError() 指示已发生错误。
void | write(char[] buf) 写入字符数组。
void | write(char[] buf, int off, int len) 写入字符数组的某一部分。
void | write(int c) 写入单个字符。
void | write(String s) 写入字符串。
void | write(String s, int off, int len) 写入字符串的某一部分。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

out

protected Writer out
此 PrintWriter 的底层字符输出流。

从以下版本开始：
1.2
构造方法详细信息

PrintWriter

public PrintWriter(Writer out)
创建不带自动行刷新的新 PrintWriter。

参数：
out - 字符输出流

PrintWriter

public PrintWriter(Writer out,
                   boolean autoFlush)
创建新 PrintWriter。

参数：
out - 字符输出流
autoFlush - boolean 变量；如果为 true，则 println、printf 或 format 方法将刷新输出缓冲区

PrintWriter

public PrintWriter(OutputStream out)
根据现有的 OutputStream 创建不带自动行刷新的新 PrintWriter。此便捷构造方法创建必要的中间 OutputStreamWriter，后者使用默认字符编码将字符转换为字节。

参数：
out - 输出流
另请参见：
OutputStreamWriter.OutputStreamWriter(java.io.OutputStream)

PrintWriter

public PrintWriter(OutputStream out,
                   boolean autoFlush)
通过现有的 OutputStream 创建新的 PrintWriter。此便捷构造方法创建必要的中间 OutputStreamWriter，后者使用默认字符编码将字符转换为字节。

参数：
out - 输出流
autoFlush - boolean 变量；如果为 true，则 println、printf 或 format 方法将刷新输出缓冲区
另请参见：
OutputStreamWriter.OutputStreamWriter(java.io.OutputStream)

PrintWriter

public PrintWriter(String fileName)
            throws FileNotFoundException
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用此 Java 虚拟机实例的默认 charset 进行字符编码。

参数：
fileName - 用作此 writer 目标的文件名称。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
抛出：
FileNotFoundException - 如果给定的字符串不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(fileName) 拒绝对文件进行写入访问。
从以下版本开始：
1.5

PrintWriter

public PrintWriter(String fileName,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用提供的字符集进行字符编码。

参数：
fileName - 用作此 writer 目标的文件名称。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
抛出：
FileNotFoundException - 如果给定的字符串不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(fileName) 拒绝对文件进行写入访问。
UnsupportedEncodingException - 如果不支持指定字符集
从以下版本开始：
1.5

PrintWriter

public PrintWriter(File file)
            throws FileNotFoundException
使用指定文件创建不具有自动行刷新的新 PrintWriter。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用此 Java 虚拟机实例的默认 charset 进行字符编码。

参数：
file - 作为此 writer 的目标使用的文件。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(file.getPath()) 拒绝对文件进行写入访问。
从以下版本开始：
1.5

PrintWriter

public PrintWriter(File file,
                   String csn)
            throws FileNotFoundException,
                   UnsupportedEncodingException
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。此便捷构造方法创建必要的中间 OutputStreamWriter，后者将使用提供的字符集进行字符编码。

参数：
file - 作为此 writer 的目标使用的文件。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(file.getPath()) 拒绝对文件进行写入访问。
UnsupportedEncodingException - 如果不支持指定字符集
从以下版本开始：
1.5
方法详细信息

flush

public void flush()
刷新该流的缓冲。

指定者：
接口 Flushable 中的 flush
指定者：
类 Writer 中的 flush
另请参见：
checkError()

close

public void close()
关闭该流并释放与之关联的所有系统资源。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Writer 中的 close
另请参见：
checkError()

checkError

public boolean checkError()
如果流没有关闭，则刷新流且检查其错误状态。

返回：
如果该打印流在底层输出流上或在格式转换过程中遇到错误，则返回 true。

setError

protected void setError()
指示已发生错误。

在调用 clearError() 之前，此方法将导致 checkError() 的后续调用返回 true。

clearError

protected void clearError()
清除此流的错误状态。

在另一个写入操作失败并调用 setError() 之前，此方法将导致 checkError() 的后续调用返回 false。

从以下版本开始：
1.6

write

public void write(int c)
写入单个字符。

覆盖：
类 Writer 中的 write
参数：
c - 指定要写入的字符的 int。

write

public void write(char[] buf,
                  int off,
                  int len)
写入字符数组的某一部分。

指定者：
类 Writer 中的 write
参数：
buf - 字符数组
off - 以其处开始写入字符的偏移量
len - 要写入的字符数

write

public void write(char[] buf)
写入字符数组。此方法不能从 Writer 类继承，因为它必须取消 I/O 异常。

覆盖：
类 Writer 中的 write
参数：
buf - 要写入的字符数组

write

public void write(String s,
                  int off,
                  int len)
写入字符串的某一部分。

覆盖：
类 Writer 中的 write
参数：
s - 字符串
off - 以其处开始写入字符的偏移量
len - 要写入的字符数

write

public void write(String s)
写入字符串。此方法不能从 Writer 类继承，因为它必须取消 I/O 异常。

覆盖：
类 Writer 中的 write
参数：
s - 要写入的字符串

print

public void print(boolean b)
打印 boolean 值。按照平台的默认字符编码将 String.valueOf(boolean) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
b - 要打印的 boolean

print

public void print(char c)
打印字符。按照平台的默认字符编码将字符转换为一个或多个字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
c - 要打印的 char

print

public void print(int i)
打印整数。按照平台的默认字节编码将 String.valueOf(int) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
i - 要打印的 int
另请参见：
Integer.toString(int)

print

public void print(long l)
打印 long 整数。按照平台的默认字符编码将 String.valueOf(long) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
l - 要打印的 long
另请参见：
Long.toString(long)

print

public void print(float f)
打印一个浮点数。按照平台的默认字符编码将 String.valueOf(float) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
f - 要打印的 float
另请参见：
Float.toString(float)

print

public void print(double d)
打印 double 精度浮点数。按照平台的默认字符编码将 String.valueOf(double) 生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
d - 要打印的 double
另请参见：
Double.toString(double)

print

public void print(char[] s)
打印字符数组。按照平台的默认字符编码将字符转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
s - 要打印的字符数组
抛出：
NullPointerException - 如果 s 为 null

print

public void print(String s)
打印字符串。如果参数为 null，则打印字符串 "null"。否则，按照平台的默认字符编码将字符串的字符转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
s - 要打印的 String

print

public void print(Object obj)
打印对象。按照平台的默认字符串编码将 String.valueOf(Object) 方法生成的字符串转换为字节，并完全以 write(int) 方法的方式写入这些字节。

参数：
obj - 要打印的 Object
另请参见：
Object.toString()

println

public void println()
通过写入行分隔符字符串终止当前行。行分隔符字符串由系统属性 line.separator 定义，不一定是单个换行符 ('\n')。

println

public void println(boolean x)
打印 boolean 值，然后终止该行。此方法的行为就像先调用 print(boolean) 然后调用 println() 一样。

参数：
x - 要打印的 boolean 值

println

public void println(char x)
打印字符，然后终止该行。此方法的行为就像先调用 print(char) 然后调用 println() 一样。

参数：
x - 要打印的 char 值

println

public void println(int x)
打印整数，然后终止该行。此方法的行为就像先调用 print(int) 然后调用 println() 一样。

参数：
x - 要打印的 int 值

println

public void println(long x)
打印 long 整数，然后终止该行。此方法的行为就像先调用 print(long) 然后调用 println() 一样。

参数：
x - 要打印的 long 值

println

public void println(float x)
打印浮点数，然后终止该行。此方法的行为就像先调用 print(float) 然后调用 println() 一样。

参数：
x - 要打印的 float 值

println

public void println(double x)
打印双精度浮点数，然后终止该行。此方法的行为就像先调用 print(double) 然后调用 println() 一样。

参数：
x - 要打印的 double 值

println

public void println(char[] x)
打印字符数组，然后终止该行。此方法的行为就像先调用 print(char[]) 然后调用 println() 一样。

参数：
x - 要打印的 char 值的数组

println

public void println(String x)
打印 String，然后终止该行。此方法的行为就像先调用 print(String) 然后调用 println() 一样。

参数：
x - 要打印的 String 值

println

public void println(Object x)
打印 Object，然后终止该行。此方法首先调用 String.valueOf(x) 以获取打印对象的字符串值，行为就像先调用 print(String) 然后调用 println() 一样。

参数：
x - 要打印的 Object

printf

public PrintWriter printf(String format,
                          Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。如果启用自动刷新，则调用此方法将刷新输出缓冲区。

调用此方法的 out.printf(format, args) 形式，行为与以下调用完全相同：

     out.format(format, args)

参数：
format - 在格式字符串的语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于转换。
返回：
此 writer
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

printf

public PrintWriter printf(Locale l,
                          String format,
                          Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。如果启用自动刷新，则调用此方法将刷新输出缓冲区。

调用此方法的 out.printf(l, format, args) 形式，行为与以下调用完全相同：

     out.format(l, format, args)

参数：
l - 格式化过程中应用的 locale。如果 l 为 null，则不应用本地化。
format - 在格式字符串的语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于转换。
返回：
此 writer
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

format

public PrintWriter format(String format,
                          Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。如果启用自动刷新，则调用此方法将刷新输出缓冲区。

始终使用的语言环境是由 Locale.getDefault() 返回的语言环境，不管以前在此对象上调用了其他什么样的格式化方法。

参数：
format - 在格式字符串的语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于 conversion。
返回：
此 writer
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

format

public PrintWriter format(Locale l,
                          String format,
                          Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。如果启用自动刷新，则调用此方法将刷新输出缓冲区。

参数：
l - 格式化过程中应用的 locale。如果 l 为 null，则不应用本地化。
format - 在格式字符串的语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的数量是可变的，并且可以为零。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。针对 null 参数的行为依赖于 conversion。
返回：
此 writer
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5

append

public PrintWriter append(CharSequence csq)
将指定的字符序列添加到此 writer。

此方法调用 out.append(csq) 的行为与调用下列方法完全相同：

     out.write(csq.toString())

可能不添加整个序列，也可能添加，具体取决于字符序列 csq 的 toString 指定。例如，调用一个字符缓冲区的 toString 方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
csq - 要添加的字符串序列。如果 csq 为 null，则向此 writer 添加四个字符 "null"。
返回：
此 writer
从以下版本开始：
1.5

append

public PrintWriter append(CharSequence csq,
                          int start,
                          int end)
将指定字符序列的子序列添加到此 writer。

当 csq 不为 null 时，调用该方法的 out.append(csq、 start、 end) 形式，行为与以下调用完全相同：

     out.write(csq.subSequence(start, end).toString())

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
csq - 要添加子序列的字符序列。如果 csq 为 null，则添加四个字符 "null"，就好像 csq 包含这些字符一样。
start - 子序列中第一个字符的索引
end - 子序列中最后一个字符后面的字符的索引
返回：
此 writer
抛出：
IndexOutOfBoundsException - 如果 start 或 end 为负，而 start 大于 end 或者 end 大于 csq.length()
从以下版本开始：
1.5

append

public PrintWriter append(char c)
将指定字符添加到此 writer。

调用此方法的 out.append(c) 形式，行为与以下调用完全相同：

     out.write(c)

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
c - 要添加的 16 位字符
返回：
此 writer
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PushbackInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PushbackInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.io.PushbackInputStream
所有已实现的接口：
Closeable
public class PushbackInputStream
extends FilterInputStream

PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。在代码片段可以很方便地读取由特定字节值分隔的不定数量的数据字节时，这很有用；在读取终止字节后，代码片段可以“取消读取”该字节，这样，输入流上的下一个读取操作将会重新读取被推回的字节。例如，表示构成标识符字符的字节可能由表示操作符字符的字节终止；用于读取一个标识符的方法可以读取到遇到操作符为止，然后将该操作符推回以进行重读。

从以下版本开始：
JDK1.0

字段摘要
protected byte[] | buf 推回缓冲区。
protected int | pos 推回缓冲区中的位置，将读取该位置的下一个字节。
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
PushbackInputStream(InputStream in)
创建 PushbackInputStream 并保存其参数（即输入流 in），以供将来使用。
PushbackInputStream(InputStream in, int size)
使用指定 size 的推回缓冲区创建 PushbackInputStream，并保存其参数（即输入流 in），以供将来使用。
方法摘要
int | available() 返回可以不受下一次调用此输入流的方法阻塞地从此输入流读取（或跳过）的估计字节数。
void | close() 关闭此输入流并释放与该流关联的所有系统资源。
void | mark(int readlimit) 在此输入流中标记当前的位置。
boolean | markSupported() 测试此输入流是否支持 mark 和 reset 方法，此输入流不支持这两个方法。
int | read() 从此输入流中读取下一个数据字节。
int | read(byte[] b, int off, int len) 从此输入流将最多 len 个数据字节读入 byte 数组。
void | reset() 将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
long | skip(long n) 从此输入流中跳过并丢弃 n 个数据字节。
void | unread(byte[] b) 推回一个 byte 数组：将其复制到推回缓冲区之前。
void | unread(byte[] b, int off, int len) 推回 byte 数组的某一部分：将其复制到推回缓冲区之前。
void | unread(int b) 推回一个字节：将其复制到推回缓冲区之前。
从类 java.io.FilterInputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buf

protected byte[] buf
推回缓冲区。

从以下版本开始：
JDK1.1

pos

protected int pos
推回缓冲区中的位置，将读取该位置的下一个字节。缓冲区为空时，pos 等于 buf.length；缓冲区已满时，pos 等于 0。

从以下版本开始：
JDK1.1
构造方法详细信息

PushbackInputStream

public PushbackInputStream(InputStream in,
                           int size)
使用指定 size 的推回缓冲区创建 PushbackInputStream，并保存其参数（即输入流 in），以供将来使用。最初，不存在推回字节（字段 pushBack 被初始化为 -1）。

参数：
in - 从中读取字节的输入流。
size - 推回缓冲区的大小。
抛出：
IllegalArgumentException - 如果 size <= 0
从以下版本开始：
JDK1.1

PushbackInputStream

public PushbackInputStream(InputStream in)
创建 PushbackInputStream 并保存其参数（即输入流 in），以供将来使用。最初，不存在推回字节（字段 pushBack 被初始化为 -1）。

参数：
in - 从中读取字节的输入流。
方法详细信息

read

public int read()
         throws IOException
从此输入流中读取下一个数据字节。以 int 形式返回 0 到 255 范围内字节值。如果因为已经到达流末尾而没有可用的字节，则返回值 -1。在输入数据可用、检测到流末尾或者抛出异常之前，此方法一直阻塞。

此方法返回最近一次推回的字节（如果有），否则将调用其底层输入流的 read 方法，并返回该方法返回的任何值。

覆盖：
类 FilterInputStream 中的 read
返回：
下一个数据字节；如果已到达流末尾，则返回 -1。
抛出：
IOException - 如果已调用其 close() 方法关闭此输入流，或者发生 I/O 错误。
另请参见：
InputStream.read()

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从此输入流将最多 len 个数据字节读入 byte 数组。此方法首先读取所有推回字节；然后，如果读取的字节数少于 len 个字节，那么它将从底层输入流中读取字节。如果 len 不为 0，那么在至少 1 个输入字节可用之前，该方法将一直阻塞；否则，不读取任何字节并返回 0。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 读入数据的缓冲区。
off - 目标数组 b 中的初始偏移量。
len - 读取的最大字节数。
返回：
读入缓冲区的总字节数；如果因为已经到达流末尾而不再有数据可用，则返回 -1。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，len 为负，或者 len 大于 b.length - off
IOException - 如果已调用其 close() 方法关闭此输入流，或者发生 I/O 错误。
另请参见：
InputStream.read(byte[], int, int)

unread

public void unread(int b)
            throws IOException
推回一个字节：将其复制到推回缓冲区之前。此方法返回后，要读取的下一个字节的值将为 (byte)b。

参数：
b - 要推回其低位字节的 int 值。
抛出：
IOException - 如果推回缓冲区中没有足够的空间来存储字节，或者已调用其 close() 方法关闭此输入流。

unread

public void unread(byte[] b,
                   int off,
                   int len)
            throws IOException
推回 byte 数组的某一部分：将其复制到推回缓冲区之前。此方法返回后，要读取的下一个字节的值将为 b[off]，该字节之后的字节的值将为 b[off+1]，依此类推。

参数：
b - 要推回的 byte 数组。
off - 数据的初始偏移量。
len - 要推回的字节数。
抛出：
IOException - 如果推回缓冲区中没有足够的空间来存储指定字节数，或者已调用其 close() 方法关闭此输入流。
从以下版本开始：
JDK1.1

unread

public void unread(byte[] b)
            throws IOException
推回一个 byte 数组：将其复制到推回缓冲区之前。此方法返回后，要读取的下一个字节的值将为 b[0]，该字节之后的字节的值将为 b[1]，依此类推。

参数：
b - 要推回的 byte 数组
抛出：
IOException - 如果推回缓冲区中没有足够的空间来存储指定字节数，或者已调用其 close() 方法关闭此输入流。
从以下版本开始：
JDK1.1

available

public int available()
              throws IOException
返回可以不受下一次调用此输入流的方法阻塞地从此输入流读取（或跳过）的估计字节数。下一次调用可能是相同的线程，也可能是不同的线程。一次读取或跳过该估计数个字节不会受阻塞，但是读取或跳过的字节可能少于该数。

该方法返回已被推回的字节数与 available 返回的值之和。

覆盖：
类 FilterInputStream 中的 available
返回：
可以不受阻塞地从此输入流读取（或跳过）的字节数。
抛出：
IOException - 如果已调用其 close() 方法关闭此输入流，或者发生 I/O 错误。
另请参见：
FilterInputStream.in, InputStream.available()

skip

public long skip(long n)
          throws IOException
从此输入流中跳过并丢弃 n 个数据字节。由于多种原因，skip 方法结束时跳过的字节数可能少于该数，也可能为 0。如果 n 为负，则不跳过任何字节。

PushbackInputStream 的 skip 方法首先跳过推回缓冲区中的字节（如果有）。如果需要跳过更多字节，那么它将调用底层输入流的 skip 方法。返回跳过的实际字节数。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。
抛出：
IOException - 如果流不支持查找操作，或者已调用其 close() 方法关闭，或者发生 I/O 错误。
从以下版本开始：
1.2
另请参见：
FilterInputStream.in, InputStream.skip(long n)

markSupported

public boolean markSupported()
测试此输入流是否支持 mark 和 reset 方法，此输入流不支持这两个方法。

覆盖：
类 FilterInputStream 中的 markSupported
返回：
false，因为此类不支持 mark 和 reset 方法。
另请参见：
InputStream.mark(int), InputStream.reset()

mark

public void mark(int readlimit)
在此输入流中标记当前的位置。

PushbackInputStream 的 mark 方法不执行任何操作。

覆盖：
类 FilterInputStream 中的 mark
参数：
readlimit - 在标记位置变无效前可以读取字节的最大限制。
另请参见：
InputStream.reset()

reset

public void reset()
           throws IOException
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。

类 PushbackInputStream 的方法 reset 不执行任何操作，只抛出 IOException。

覆盖：
类 FilterInputStream 中的 reset
抛出：
IOException - 如果调用此方法。
另请参见：
InputStream.mark(int), IOException

close

public void close()
           throws IOException
关闭此输入流并释放与该流关联的所有系统资源。关闭流之后，再调用 read()、unread()、available()、reset() 或 skip() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Reader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 Reader

java.lang.Object
    继承者  java.io.Reader
所有已实现的接口：
Closeable, Readable
直接已知子类：
BufferedReader, CharArrayReader, FilterReader, InputStreamReader, PipedReader, StringReader
public abstract class Reader
extends Object
implements Readable, Closeable

用于读取字符流的抽象类。子类必须实现的方法只有 read(char[], int, int) 和 close()。但是，多数子类将重写此处定义的一些方法，以提供更高的效率和/或其他功能。

从以下版本开始：
JDK1.1
另请参见：
BufferedReader, LineNumberReader, CharArrayReader, InputStreamReader, FileReader, FilterReader, PushbackReader, PipedReader, StringReader, Writer

字段摘要
protected  Object lock
用于同步针对此流的操作的对象。
构造方法摘要
protected | Reader() 创建一个新的字符流 reader，其重要部分将同步其自身的 reader。
protected | Reader(Object lock) 创建一个新的字符流 reader，其重要部分将同步给定的对象。
方法摘要
abstract  void close()
关闭该流并释放与之关联的所有资源。
 void mark(int readAheadLimit)
标记流中的当前位置。
 boolean markSupported()
判断此流是否支持 mark() 操作。
 int read()
读取单个字符。
 int read(char[] cbuf)
将字符读入数组。
abstract  int read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int read(CharBuffer target)
试图将字符读入指定的字符缓冲区。
 boolean ready()
判断是否准备读取此流。
 void reset()
重置该流。
 long skip(long n)
跳过字符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

lock

protected Object lock
用于同步针对此流的操作的对象。为了提高效率，字符流对象可以使用其自身以外的对象来保护重要部分。因此，子类应使用此字段中的对象，而不是 this 或者同步的方法。

构造方法详细信息

Reader

protected Reader()
创建一个新的字符流 reader，其重要部分将同步其自身的 reader。

Reader

protected Reader(Object lock)
创建一个新的字符流 reader，其重要部分将同步给定的对象。

参数：
lock - 要同步的对象。
方法详细信息

read

public int read(CharBuffer target)
         throws IOException
试图将字符读入指定的字符缓冲区。缓冲区可照原样用作字符的存储库：所做的唯一改变是 put 操作的结果。不对缓冲区执行翻转或重绕操作。

指定者：
接口 Readable 中的 read
参数：
target - 要将字符读入的缓冲区
返回：
添加到缓冲区的字符数量，如果此字符源位于缓冲区末端，则返回 -1
抛出：
IOException - 如果发生 I/O 错误
NullPointerException - 如果目标为空
ReadOnlyBufferException - 如果目标是一个只读缓冲区
从以下版本开始：
1.5

read

public int read()
         throws IOException
读取单个字符。在字符可用、发生 I/O 错误或者已到达流的末尾前，此方法一直阻塞。

用于支持高效的单字符输入的子类应重写此方法。

返回：
作为整数读取的字符，范围在 0 到 65535 之间 (0x00-0xffff)，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] cbuf)
         throws IOException
将字符读入数组。在某个输入可用、发生 I/O 错误或者已到达流的末尾前，此方法一直阻塞。

参数：
cbuf - 目标缓冲区
返回：
读取的字符数，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public abstract int read(char[] cbuf,
                         int off,
                         int len)
                  throws IOException
将字符读入数组的某一部分。在某个输入可用、发生 I/O 错误或者到达流的末尾前，此方法一直阻塞。

参数：
cbuf - 目标缓冲区
off - 开始存储字符处的偏移量
len - 要读取的最多字符数
返回：
读取的字符数，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

skip

public long skip(long n)
          throws IOException
跳过字符。在某个字符可用、发生 I/O 错误或者已到达流的末尾前，此方法一直阻塞。

参数：
n - 要跳过的字符数
返回：
实际跳过的字符数
抛出：
IllegalArgumentException - 如果 n 为负。
IOException - 如果发生 I/O 错误

ready

public boolean ready()
              throws IOException
判断是否准备读取此流。

返回：
如果保证下一个 read() 不阻塞输入，则返回 True，否则返回 false。注意，返回 false 并不保证阻塞下一次读取。
抛出：
IOException - 如果发生 I/O 错误

markSupported

public boolean markSupported()
判断此流是否支持 mark() 操作。默认实现始终返回 false。子类应重写此方法。

返回：
当且仅当此流支持此 mark 操作时，返回 true。

mark

public void mark(int readAheadLimit)
          throws IOException
标记流中的当前位置。对 reset() 的后续调用将尝试将该流重新定位到此点。并不是所有的字符输入流都支持 mark() 操作。

参数：
readAheadLimit - 在仍保留该标记的情况下，对可读取字符数量的限制。在读取这样多的字符后，尝试重置流可能会失败。
抛出：
IOException - 如果该流不支持 mark()，或者发生一些其他 I/O 错误

reset

public void reset()
           throws IOException
重置该流。如果已标记该流，则尝试在该标记处重新定位该流。如果已标记该流，则以适用于特定流的某种方式尝试重置该流，例如，通过将该流重新定位到其起始点。并不是所有的字符输入流都支持 reset() 操作，有些支持 reset() 而不支持 mark()。

抛出：
IOException - 如果尚未标记流，或者该标记已失效，或者该流不支持 reset()，或者发生一些其他 I/O 错误

close

public abstract void close()
                    throws IOException
关闭该流并释放与之关联的所有资源。在关闭该流后，再调用 read()、ready()、mark()、reset() 或 skip() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PushbackReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 PushbackReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.FilterReader
            继承者  java.io.PushbackReader
所有已实现的接口：
Closeable, Readable
public class PushbackReader
extends FilterReader

允许将字符推回到流的字符流 reader。

从以下版本开始：
JDK1.1

字段摘要
从类 java.io.FilterReader 继承的字段
in
从类 java.io.Reader 继承的字段
lock
构造方法摘要
PushbackReader(Reader in)
创建具有单字符推回缓冲区的新推回 reader。
PushbackReader(Reader in, int size)
创建具有给定大小推回缓冲区的新推回 reader。
方法摘要
 void close()
关闭该流并释放与之关联的所有系统资源。
 void mark(int readAheadLimit)
标记流中的当前位置。
 boolean markSupported()
判断此流是否支持 mark() 操作（它一定不支持）。
 int read()
读取单个字符。
 int read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 boolean ready()
判断是否准备读取此流。
 void reset()
重置该流。
 long skip(long n)
跳过字符。
 void unread(char[] cbuf)
推回一个字符数组，方法是将其复制到推回缓冲区前面。
 void unread(char[] cbuf, int off, int len)
推回字符数组的某一部分，方法是将其复制到推回缓冲区的前面。
 void unread(int c)
推回单个字符：将其复制到推回缓冲区的前面。
从类 java.io.Reader 继承的方法
read, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PushbackReader

public PushbackReader(Reader in,
                      int size)
创建具有给定大小推回缓冲区的新推回 reader。

参数：
in - 将从中读取字符的 reader
size - 推回缓冲区的大小
抛出：
IllegalArgumentException - 如果 size <= 0

PushbackReader

public PushbackReader(Reader in)
创建具有单字符推回缓冲区的新推回 reader。

参数：
in - 将从中读取字符的 reader
方法详细信息

read

public int read()
         throws IOException
读取单个字符。

覆盖：
类 FilterReader 中的 read
返回：
读取的字符，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException
将字符读入数组的某一部分。

覆盖：
类 FilterReader 中的 read
参数：
cbuf - 目标缓冲区
off - 开始写入字符处的偏移量
len - 要读取的最多字符数
返回：
读取的字符数，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

unread

public void unread(int c)
            throws IOException
推回单个字符：将其复制到推回缓冲区的前面。在返回此方法后，要读取的下一个字符将具有值 (char)c。

参数：
c - int 值，表示要被推回的字符
抛出：
IOException - 如果推回缓冲区已满，或者发生一些其他 I/O 错误

unread

public void unread(char[] cbuf,
                   int off,
                   int len)
            throws IOException
推回字符数组的某一部分，方法是将其复制到推回缓冲区的前面。在返回此方法后，要读取的下一个字符将具有值 cbuf[off]，其后的字节将具有值 cbuf[off+1]，依次类推。

参数：
cbuf - 字符数组
off - 要推回的第一个字符的偏移量
len - 要推回的字符数
抛出：
IOException - 如果推回缓冲区中没有足够的空间，或者发生一些其他 I/O 错误

unread

public void unread(char[] cbuf)
            throws IOException
推回一个字符数组，方法是将其复制到推回缓冲区前面。在返回此方法后，要读取的下一个字符将具有值 cbuf[0]，其后的字节将具有值 cbuf[1]，依次类推。

参数：
cbuf - 要推回的字符数组
抛出：
IOException - 如果推回缓冲区中没有足够的空间，或者发生一些其他 I/O 错误

ready

public boolean ready()
              throws IOException
判断是否准备读取此流。

覆盖：
类 FilterReader 中的 ready
返回：
如果保证下一个 read() 不阻塞输入，则返回 True，否则返回 false。注意，返回 false 并不保证阻塞下一次读取。
抛出：
IOException - 如果发生 I/O 错误

mark

public void mark(int readAheadLimit)
          throws IOException
标记流中的当前位置。类 PushbackReader 的 mark 始终抛出异常。

覆盖：
类 FilterReader 中的 mark
参数：
readAheadLimit - 在仍保留该标记的情况下，对可读取字符数量的限制。在读取这样多的字符后，尝试重置流可能会失败。
抛出：
IOException - 始终抛出，原因是不支持标记功能

reset

public void reset()
           throws IOException
重置该流。PushbackReader 的 reset 方法始终抛出异常。

覆盖：
类 FilterReader 中的 reset
抛出：
IOException - 始终抛出，原因是不支持重置功能

markSupported

public boolean markSupported()
判断此流是否支持 mark() 操作（它一定不支持）。

覆盖：
类 FilterReader 中的 markSupported
返回：
当且仅当此流支持此 mark 操作时，返回 true。

close

public void close()
           throws IOException
关闭该流并释放与之关联的所有系统资源。在关闭流后，再调用 read()、unread()、ready() 或 skip() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterReader 中的 close
抛出：
IOException - 如果发生 I/O 错误

skip

public long skip(long n)
          throws IOException
跳过字符。在一些字符可用、发生 I/O 错误或者到达流的末尾前，此方法一直阻塞。

覆盖：
类 FilterReader 中的 skip
参数：
n - 要跳过的字符数
返回：
实际跳过的字符数
抛出：
IllegalArgumentException - 如果 n 为负。
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RandomAccessFile (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 RandomAccessFile

java.lang.Object
    继承者  java.io.RandomAccessFile
所有已实现的接口：
Closeable, DataInput, DataOutput
public class RandomAccessFile
extends Object
implements DataOutput, DataInput, Closeable

此类的实例支持对随机访问文件的读取和写入。随机访问文件的行为类似存储在文件系统中的一个大型 byte 数组。存在指向该隐含数组的光标或索引，称为文件指针；输入操作从文件指针开始读取字节，并随着对字节的读取而前移此文件指针。如果随机访问文件以读取/写入模式创建，则输出操作也可用；输出操作从文件指针开始写入字节，并随着对字节的写入而前移此文件指针。写入隐含数组的当前末尾之后的输出操作导致该数组扩展。该文件指针可以通过 getFilePointer 方法读取，并通过 seek 方法设置。

通常，如果此类中的所有读取例程在读取所需数量的字节之前已到达文件末尾，则抛出 EOFException（是一种 IOException）。如果由于某些原因无法读取任何字节，而不是在读取所需数量的字节之前已到达文件末尾，则抛出 IOException，而不是 EOFException。需要特别指出的是，如果流已被关闭，则可能抛出 IOException。

从以下版本开始：
JDK1.0

构造方法摘要
RandomAccessFile(File file, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。
RandomAccessFile(String name, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。
方法摘要
void | close() 关闭此随机访问文件流并释放与该流关联的所有系统资源。
FileChannel | getChannel() 返回与此文件关联的唯一 FileChannel 对象。
FileDescriptor | getFD() 返回与此流关联的不透明文件描述符对象。
long | getFilePointer() 返回此文件中的当前偏移量。
long | length() 返回此文件的长度。
int | read() 从此文件中读取一个数据字节。
int | read(byte[] b) 将最多 b.length 个数据字节从此文件读入 byte 数组。
int | read(byte[] b, int off, int len) 将最多 len 个数据字节从此文件读入 byte 数组。
boolean | readBoolean() 从此文件读取一个 boolean。
byte | readByte() 从此文件读取一个有符号的八位值。
char | readChar() 从此文件读取一个字符。
double | readDouble() 从此文件读取一个 double。
float | readFloat() 从此文件读取一个 float。
void | readFully(byte[] b) 将 b.length 个字节从此文件读入 byte 数组，并从当前文件指针开始。
void | readFully(byte[] b, int off, int len) 将正好 len 个字节从此文件读入 byte 数组，并从当前文件指针开始。
int | readInt() 从此文件读取一个有符号的 32 位整数。
String | readLine() 从此文件读取文本的下一行。
long | readLong() 从此文件读取一个有符号的 64 位整数。
short | readShort() 从此文件读取一个有符号的 16 位数。
int | readUnsignedByte() 从此文件读取一个无符号的八位数。
int | readUnsignedShort() 从此文件读取一个无符号的 16 位数。
String | readUTF() 从此文件读取一个字符串。
void | seek(long pos) 设置到此文件开头测量到的文件指针偏移量，在该位置发生下一个读取或写入操作。
void | setLength(long newLength) 设置此文件的长度。
int | skipBytes(int n) 尝试跳过输入的 n 个字节以丢弃跳过的字节。
void | write(byte[] b) 将 b.length 个字节从指定 byte 数组写入到此文件，并从当前文件指针开始。
void | write(byte[] b, int off, int len) 将 len 个字节从指定 byte 数组写入到此文件，并从偏移量 off 处开始。
void | write(int b) 向此文件写入指定的字节。
void | writeBoolean(boolean v) 按单字节值将 boolean 写入该文件。
void | writeByte(int v) 按单字节值将 byte 写入该文件。
void | writeBytes(String s) 按字节序列将该字符串写入该文件。
void | writeChar(int v) 按双字节值将 char 写入该文件，先写高字节。
void | writeChars(String s) 按字符序列将一个字符串写入该文件。
void | writeDouble(double v) 使用 Double 类中的 doubleToLongBits 方法将双精度参数转换为一个 long，然后按八字节数量将该 long 值写入该文件，先定高字节。
void | writeFloat(float v) 使用 Float 类中的 floatToIntBits 方法将浮点参数转换为一个 int，然后按四字节数量将该 int 值写入该文件，先写高字节。
void | writeInt(int v) 按四个字节将 int 写入该文件，先写高字节。
void | writeLong(long v) 按八个字节将 long 写入该文件，先写高字节。
void | writeShort(int v) 按两个字节将 short 写入该文件，先写高字节。
void | writeUTF(String str) 使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RandomAccessFile

public RandomAccessFile(String name,
                        String mode)
                 throws FileNotFoundException
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。将创建一个新的 FileDescriptor 对象来表示到文件的连接。

mode 参数指定用以打开文件的访问模式。允许的值及其含意如 RandomAccessFile(File,String) 构造方法所指定的那样。

如果存在安全管理器，则使用 name 作为其参数调用其 checkRead 方法，以查看是否允许对该文件进行读取访问。如果该模式允许写入，那么还使用 name 作为安全管理器的参数来调用其 checkWrite 方法，以查看是否允许对该文件进行写入访问。

参数：
name - 取决于系统的文件名
mode - 此访问 mode
抛出：
IllegalArgumentException - 如果此模式参数与 "r"、"rw"、"rws" 或 "rwd" 的其中一个不相等
FileNotFoundException - 如果该模式为 "r"，但给定的字符串表示一个现有的常规文件，或者该模式以 "rw" 开头，但给定的字符串不表示一个现有的可写常规文件，而且无法创建具有该名称的新常规文件，或者在打开或创建该文件时发生一些其他错误
SecurityException - 如果存在安全管理器，并且其 checkRead 方法拒绝对该文件的读取访问，或者该模式为 "rw"，并且该安全管理器的 checkWrite 方法拒绝对该文件的写入访问
另请参见：
SecurityException, SecurityManager.checkRead(java.lang.String), SecurityManager.checkWrite(java.lang.String)

RandomAccessFile

public RandomAccessFile(File file,
                        String mode)
                 throws FileNotFoundException
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。将创建一个新的 FileDescriptor 对象来表示此文件的连接。

mode 参数指定用以打开文件的访问模式。允许的值及其含意为：

值

含意

"r" | 以只读方式打开。调用结果对象的任何 write 方法都将导致抛出 IOException。
"rw" | 打开以便读取和写入。如果该文件尚不存在，则尝试创建该文件。
"rws" | 打开以便读取和写入，对于 "rw"，还要求对文件的内容或元数据的每个更新都同步写入到底层存储设备。
"rwd"   | 打开以便读取和写入，对于 "rw"，还要求对文件内容的每个更新都同步写入到底层存储设备。
"rws" 和 "rwd" 模式的工作方式极其类似 FileChannel 类的 force(boolean) 方法，分别传递 true 和 false 参数，除非它们始终应用于每个 I/O 操作，并因此通常更为高效。如果该文件位于本地存储设备上，那么当返回此类的一个方法的调用时，可以保证由该调用对此文件所做的所有更改均被写入该设备。这对确保在系统崩溃时不会丢失重要信息特别有用。如果该文件不在本地设备上，则无法提供这样的保证。

"rwd" 模式可用于减少执行的 I/O 操作数量。使用 "rwd" 仅要求更新要写入存储的文件的内容；使用 "rws" 要求更新要写入的文件内容及其元数据，这通常要求至少一个以上的低级别 I/O 操作。

如果存在安全管理器，则使用 file 参数的路径名作为其参数调用它的 checkRead 方法，以查看是否允许对该文件进行读取访问。如果该模式允许写入，那么还使用该路径参数调用该安全管理器的 checkWrite 方法，以查看是否允许对该文件进行写入访问。

参数：
file - 该文件对象
mode - 访问模式，如上所述
抛出：
IllegalArgumentException - 如果此模式参数与 "r"、"rw"、"rws" 或 "rwd" 的其中一个不相等
FileNotFoundException - 如果该模式为 "r"，但给定的文件对象不表示一个现有的常规文件，或者该模式以 "rw" 开头，但给定的文件对象不表示一个现有的可写常规文件，而且无法创建具有该名称的新常规文件，或者在打开或创建该文件时发生一些其他错误
SecurityException - 如果存在安全管理器，并且其 checkRead 方法拒绝对该文件的读取访问，或者该模式为 "rw"，并且该安全管理器的 checkWrite 方法拒绝对该文件的写入访问
另请参见：
SecurityManager.checkRead(java.lang.String),
SecurityManager.checkWrite(java.lang.String),
FileChannel.force(boolean)
方法详细信息

getFD

public final FileDescriptor getFD()
                           throws IOException
返回与此流关联的不透明文件描述符对象。

返回：
与此流关联的不透明文件描述符对象。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FileDescriptor

getChannel

public final FileChannel getChannel()
返回与此文件关联的唯一 FileChannel 对象。

返回通道的 java.nio.channels.FileChannel#position()position 将始终等于 getFilePointer 方法返回的此对象的文件指针偏移量。显式或者通过读取或写入字节来更改此对象的文件指针偏移量将更改通道的位置，反之亦然。通过此对象更改此文件的长度将更改通过文件通道看到的长度，反之亦然。

返回：
与此文件关联的文件通道
从以下版本开始：
1.4

read

public int read()
         throws IOException
从此文件中读取一个数据字节。以整数形式返回此字节，范围在 0 到 255 (0x00-0x0ff)。如果尚无输入可用，将阻塞此方法。

尽管 RandomAccessFile 不是 InputStream 的子类，但此方法的行为与 InputStream 的 InputStream.read() 方法完全一样。

返回：
下一个数据字节，如果已到达文件的末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。如果已到达文件的末尾，则不抛出此异常。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
将最多 len 个数据字节从此文件读入 byte 数组。在至少一个输入字节可用前，此方法一直阻塞。

尽管 RandomAccessFile 不是 InputStream 的子类，但此方法的行为与 InputStream 的 InputStream.read(byte[], int, int) 方法完全一样。

参数：
b - 读入数据的缓冲区。
off - 写入数据的数组 b 中的初始偏移量。
len - 读取的最多字节数。
返回：
读入缓冲区的总字节数，如果由于已到达文件的末尾而不再有数据，则返回 -1。
抛出：
IOException - 如果由于文件结束之外的某种原因不能读取第一个字节，或者随机访问文件已关闭，或者发生其他 I/O 错误。
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off为负，len 为负，或者 len 大于 b.length - off

read

public int read(byte[] b)
         throws IOException
将最多 b.length 个数据字节从此文件读入 byte 数组。在至少一个输入字节可用前，此方法一直阻塞。

尽管 RandomAccessFile 不是 InputStream 的子类，但此方法的行为与 InputStream 的 InputStream.read(byte[]) 方法完全一样。

参数：
b - 将数据读入的缓冲区。
返回：
读入缓冲区的总字节数，如果由于已到达此文件的末尾而不再有数据，则返回 -1。
抛出：
IOException - 如果由于文件结束之外的某种原因不能读取第一个字节，或者随机访问文件已关闭，或者发生其他 I/O 错误。
NullPointerException - 如果 b 为 null。

readFully

public final void readFully(byte[] b)
                     throws IOException
将 b.length 个字节从此文件读入 byte 数组，并从当前文件指针开始。在读取到请求数量的字节之前，此方法将从该文件重复读取。在读取了请求数量的字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readFully
参数：
b - 将数据读入的缓冲区。
抛出：
EOFException - 如果在读取所有字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public final void readFully(byte[] b,
                            int off,
                            int len)
                     throws IOException
将正好 len 个字节从此文件读入 byte 数组，并从当前文件指针开始。在读取到请求数量的字节之前，此方法将从该文件重复读取。在读取了请求数量的字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readFully
参数：
b - 读入数据的缓冲区。
off - 数据的初始偏移量。
len - 要读取的字节数。
抛出：
EOFException - 如果在读取所有字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。

skipBytes

public int skipBytes(int n)
              throws IOException
尝试跳过输入的 n 个字节以丢弃跳过的字节。

此方法可能跳过一些较少数量的字节（可能包括零）。这可能由任意数量的条件引起；在跳过 n 个字节之前已到达文件的末尾只是其中的一种可能。此方法从不抛出 EOFException。返回跳过的实际字节数。如果 n 为负数，则不跳过任何字节。

指定者：
接口 DataInput 中的 skipBytes
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(int b)
           throws IOException
向此文件写入指定的字节。从当前文件指针开始写入。

指定者：
接口 DataOutput 中的 write
参数：
b - 要写入的 byte。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b)
           throws IOException
将 b.length 个字节从指定 byte 数组写入到此文件，并从当前文件指针开始。

指定者：
接口 DataOutput 中的 write
参数：
b - 数据。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将 len 个字节从指定 byte 数组写入到此文件，并从偏移量 off 处开始。

指定者：
接口 DataOutput 中的 write
参数：
b - 数据。
off - 数据的初始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。

getFilePointer

public long getFilePointer()
                    throws IOException
返回此文件中的当前偏移量。

返回：
到此文件开头的偏移量（以字节为单位），在该位置发生下一个读取或写入操作。
抛出：
IOException - 如果发生 I/O 错误。

seek

public void seek(long pos)
          throws IOException
设置到此文件开头测量到的文件指针偏移量，在该位置发生下一个读取或写入操作。偏移量的设置可能会超出文件末尾。偏移量的设置超出文件末尾不会改变文件的长度。只有在偏移量的设置超出文件末尾的情况下对文件进行写入才会更改其长度。

参数：
pos - 从文件开头以字节为单位测量的偏移量位置，在该位置设置文件指针。
抛出：
IOException - 如果 pos 小于 0 或者发生 I/O 错误。

length

public long length()
            throws IOException
返回此文件的长度。

返回：
按字节测量的此文件的长度。
抛出：
IOException - 如果发生 I/O 错误。

setLength

public void setLength(long newLength)
               throws IOException
设置此文件的长度。

如果 length 方法返回的文件的现有长度大于 newLength 参数，则该文件将被截短。在此情况下，如果 getFilePointer 方法返回的文件偏移量大于 newLength，那么在返回此方法后，该偏移量将等于 newLength。

如果 length 方法返回的文件的现有长度小于 newLength 参数，则该文件将被扩展。在此情况下，未定义文件扩展部分的内容。

参数：
newLength - 文件的所需长度
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
1.2

close

public void close()
           throws IOException
关闭此随机访问文件流并释放与该流关联的所有系统资源。关闭的随机访问文件不能执行输入或输出操作，而且不能重新打开。

如果此文件具有一个关联的通道，那么该通道也会被关闭。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误。

readBoolean

public final boolean readBoolean()
                          throws IOException
从此文件读取一个 boolean。此方法从该文件的当前文件指针开始读取单个字节。值 0 表示 false。其他任何值表示 true。在读取了该字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readBoolean
返回：
读取的 boolean 值。
抛出：
EOFException - 如果此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readByte

public final byte readByte()
                    throws IOException
从此文件读取一个有符号的八位值。此方法从该文件的当前文件指针开始读取一个字节。如果读取的字节为 b，其中 0 <= b <= 255，则结果将是：
(byte)(b)

在读取了该字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readByte
返回：
以有符号的八位 byte 形式返回此文件的下一个字节。
抛出：
EOFException - 如果此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readUnsignedByte

public final int readUnsignedByte()
                           throws IOException
从此文件读取一个无符号的八位数。此方法从此文件的当前文件指针开始读取一个字节，并返回该字节。

在读取了该字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readUnsignedByte
返回：
此文件的下一个字节，解释为一个无符号的八位数。
抛出：
EOFException - 如果此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readShort

public final short readShort()
                      throws IOException
从此文件读取一个有符号的 16 位数。此方法从此文件的当前文件指针开始读取两个字节。如果按顺序读取的两个字节为 b1 和 b2，其中两个值都在 0 和 255之间（包含），则此结果等于：
(short)((b1 << 8) | b2)

在读取了这两个字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readShort
返回：
此文件的下两个字节，解释为一个有符号的 16 位数。
抛出：
EOFException - 如果在读取两个字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readUnsignedShort

public final int readUnsignedShort()
                            throws IOException
从此文件读取一个无符号的 16 位数。此方法从该文件的当前文件指针开始读取两个字节。如果按顺序读取的字节为 b1 和 b2，其中 0 <= b1, b2 <= 255，则结果将等于：
(b1 << 8) | b2

在读取了这两个字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readUnsignedShort
返回：
此文件的下两个字节，解释为一个无符号的 16 位整数。
抛出：
EOFException - 如果在读取两个字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readChar

public final char readChar()
                    throws IOException
从此文件读取一个字符。此方法从该文件的当前文件指针开始读取两个字节。如果按顺序读取的字节为 b1 和 b2，其中 0 <= b1, b2 <= 255，则结果将等于：
(char)((b1 << 8) | b2)

在读取了这两个字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readChar
返回：
此文件的下两个字节，解释为 char。
抛出：
EOFException - 如果在读取两个字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readInt

public final int readInt()
                  throws IOException
从此文件读取一个有符号的 32 位整数。此方法从该文件的当前文件指针开始读取 4 个字节。如果按顺序读取的字节为 b1、b2、b3 和 b4，其中 0 <= b1, b2, b3, b4 <= 255，则结果将等于：
(b1 << 24) | (b2 << 16) + (b3 << 8) + b4

在读取了这四个字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readInt
返回：
此文件的下四个字节，解释为一个 int。
抛出：
EOFException - 如果在读取四个字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readLong

public final long readLong()
                    throws IOException
从此文件读取一个有符号的 64 位整数。此方法从该文件的当前文件指针开始读取八个字节。如果按顺序读取的字节为 b1、b2、b3、b4、b5、b6、b7 和 b8，其中：
0 <= b1, b2, b3, b4, b5, b6, b7, b8 <=255,

则结果将等于：

((long)b1 << 56) + ((long)b2 << 48)
+ ((long)b3 << 40) + ((long)b4 << 32)
     + ((long)b5 << 24) + ((long)b6 << 16)
     + ((long)b7 << 8) + b8

在读取了这八个字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readLong
返回：
此文件的下八个字节，解释为一个 long。
抛出：
EOFException - 如果在读取八个字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。

readFloat

public final float readFloat()
                      throws IOException
从此文件读取一个 float。此方法从当前文件指针开始读取一个 int 值，类似于使用 readInt 方法，然后使用 Float 类中的 intBitsToFloat 方法将该 int 转换为一个 float。

在读取了这四个字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readFloat
返回：
此文件的下四个字节，解释为一个 float。
抛出：
EOFException - 如果在读取四个字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
readInt(), Float.intBitsToFloat(int)

readDouble

public final double readDouble()
                        throws IOException
从此文件读取一个 double。此方法从当前文件指针开始读取一个 long 值，类似于使用 readLong 方法，然后使用 Double 类中的 longBitsToDouble 方法将该 long 转换为一个 double。

在读取了这八个字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readDouble
返回：
此文件的下八个字节，解释为一个 double。
抛出：
EOFException - 如果在读取八个字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
readLong(), Double.longBitsToDouble(long)

readLine

public final String readLine()
                      throws IOException
从此文件读取文本的下一行。此方法可以从该文件的当前文件指针处成功地读取字节，直到到达行结束符或文件的末尾。每个字节都转换为一个字符，方法是采用该字符的低八位字节值，并将该字符的高八位设置为零。因此，此方法不支持完整的 Unicode 字符集。

文本行由回车符 ('\r') 和一个换行符 ('\n') 结束，回车符后面紧跟一个换行符，或者是文件的末尾。不使用行结束符，并且在返回的字符串中不包括结束符。

在读取了一个换行符、读取了一个回车符和它后面的字节（查看是否为一个新行），到达文件的末尾或者抛出异常之前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readLine
返回：
此文件文本的下一行，如果连一个字节也没有读取就已到达文件的末尾，则返回 null。
抛出：
IOException - 如果发生 I/O 错误。

readUTF

public final String readUTF()
                     throws IOException
从此文件读取一个字符串。该字符串已使用 UTF-8 修改版格式进行编码。

从当前文件指针开始读取前两个字节，类似于使用 readUnsignedShort。此值给出已编码字符串中随后的字节数，而不是结果字符串的长度。随后的字节然后解释为 UTF-8 修改版格式的字节编码字符，并转换为字符。

在读取了所有字节、检测到流的末尾或者抛出异常前，此方法一直阻塞。

指定者：
接口 DataInput 中的 readUTF
返回：
一个 Unicode 字符串。
抛出：
EOFException - 如果在读取所有字节之前此文件已到达末尾。
IOException - 如果发生 I/O 错误。
UTFDataFormatException - 如果这些字节不表示 Unicode 字符串的有效 UTF-8 修改版编码。
另请参见：
readUnsignedShort()

writeBoolean

public final void writeBoolean(boolean v)
                        throws IOException
按单字节值将 boolean 写入该文件。值 true 写出为值 (byte)1；值 false 写出为值 (byte)0。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeBoolean
参数：
v - 要写入的 boolean 值。
抛出：
IOException - 如果发生 I/O 错误。

writeByte

public final void writeByte(int v)
                     throws IOException
按单字节值将 byte 写入该文件。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeByte
参数：
v - 要写入的 byte 值。
抛出：
IOException - 如果发生 I/O 错误。

writeShort

public final void writeShort(int v)
                      throws IOException
按两个字节将 short 写入该文件，先写高字节。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeShort
参数：
v - 要写入的 short。
抛出：
IOException - 如果发生 I/O 错误。

writeChar

public final void writeChar(int v)
                     throws IOException
按双字节值将 char 写入该文件，先写高字节。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeChar
参数：
v - 要写入的 char 值。
抛出：
IOException - 如果发生 I/O 错误。

writeInt

public final void writeInt(int v)
                    throws IOException
按四个字节将 int 写入该文件，先写高字节。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeInt
参数：
v - 要写入的 int。
抛出：
IOException - 如果发生 I/O 错误。

writeLong

public final void writeLong(long v)
                     throws IOException
按八个字节将 long 写入该文件，先写高字节。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeLong
参数：
v - 要写入的 long。
抛出：
IOException - 如果发生 I/O 错误。

writeFloat

public final void writeFloat(float v)
                      throws IOException
使用 Float 类中的 floatToIntBits 方法将浮点参数转换为一个 int，然后按四字节数量将该 int 值写入该文件，先写高字节。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeFloat
参数：
v - 要写入的 float 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
Float.floatToIntBits(float)

writeDouble

public final void writeDouble(double v)
                       throws IOException
使用 Double 类中的 doubleToLongBits 方法将双精度参数转换为一个 long，然后按八字节数量将该 long 值写入该文件，先定高字节。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeDouble
参数：
v - 要写入的 double 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
Double.doubleToLongBits(double)

writeBytes

public final void writeBytes(String s)
                      throws IOException
按字节序列将该字符串写入该文件。该字符串中的每个字符均按顺序写出，并丢弃其高八位。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeBytes
参数：
s - 要写入的字节的字符串。
抛出：
IOException - 如果发生 I/O 错误。

writeChars

public final void writeChars(String s)
                      throws IOException
按字符序列将一个字符串写入该文件。每个字符均写入数据输出流，类似于使用 writeChar 方法。写入从文件指针的当前位置开始。

指定者：
接口 DataOutput 中的 writeChars
参数：
s - 要写入的 boolean 值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
writeChar(int)

writeUTF

public final void writeUTF(String str)
                    throws IOException
使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。

首先，把两个字节从文件的当前文件指针写入到此文件，类似于使用 writeShort 方法并给定要跟随的字节数。此值是实际写出的字节数，而不是该字符串的长度。在该长度之后，按顺序输出该字符串的每个字符，并对每个字符使用 UTF-8 修改版编码。

指定者：
接口 DataOutput 中的 writeUTF
参数：
str - 要写入的字符串。
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SequenceInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 SequenceInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.SequenceInputStream
所有已实现的接口：
Closeable
public class SequenceInputStream
extends InputStream

SequenceInputStream 表示其他输入流的逻辑串联。它从输入流的有序集合开始，并从第一个输入流开始读取，直到到达文件末尾，接着从第二个输入流读取，依次类推，直到到达包含的最后一个输入流的文件末尾为止。

从以下版本开始：
JDK1.0

构造方法摘要
SequenceInputStream(Enumeration<? extends InputStream> e)
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。
SequenceInputStream(InputStream s1, InputStream s2)
通过记住这两个参数来初始化新创建的 SequenceInputStream（将按顺序读取这两个参数，先读取 s1，然后读取 s2），以提供从此 SequenceInputStream 读取的字节。
方法摘要
int | available() 返回不受阻塞地从当前底层输入流读取（或跳过）的字节数的估计值，方法是通过下一次调用当前底层输入流的方法。
void | close() 关闭此输入流并释放与此流关联的所有系统资源。
int | read() 从此输入流中读取下一个数据字节。
int | read(byte[] b, int off, int len) 将最多 len 个数据字节从此输入流读入 byte 数组。
从类 java.io.InputStream 继承的方法
mark, markSupported, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SequenceInputStream

public SequenceInputStream(Enumeration<? extends InputStream> e)
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。将按顺序读取由该枚举生成的输入流，以提供从此 SequenceInputStream 读取的字节。在用尽枚举中的每个输入流之后，将通过调用该流的 close 方法将其关闭。

参数：
e - 输入流的一个枚举。
另请参见：
Enumeration

SequenceInputStream

public SequenceInputStream(InputStream s1,
                           InputStream s2)
通过记住这两个参数来初始化新创建的 SequenceInputStream（将按顺序读取这两个参数，先读取 s1，然后读取 s2），以提供从此 SequenceInputStream 读取的字节。

参数：
s1 - 要读取的第一个输入流。
s2 - 要读取的第二个输入流。
方法详细信息

available

public int available()
              throws IOException
返回不受阻塞地从当前底层输入流读取（或跳过）的字节数的估计值，方法是通过下一次调用当前底层输入流的方法。下一次调用可能是相同的或不同的线程。此方法的单个读取或跳过操作可以读取或跳过许多字节而不受阻塞，但也可能读取或跳过较少的字节。

此方法仅调用当前底层输入流的 available 方法并返回结果。

覆盖：
类 InputStream 中的 available
返回：
不受阻塞地从当前底层输入流读取（或跳过）的字节数的估计值，如果此输入流已通过调用其 close() 方法关闭，则返回 0
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JDK1.1

read

public int read()
         throws IOException
从此输入流中读取下一个数据字节。返回 0 到 255 范围内的 int 字节。如果因为已经到达流的末尾而没有可用的字节，则返回值 -1。在输入数据可用、检测到流的末尾或者抛出异常之前，此方法一直阻塞。

此方法尝试从当前子流读取一个字节。如果到达流的末尾，它将调用当前子流的 close 方法，并从下一个子流开始读取字节。

指定者：
类 InputStream 中的 read
返回：
下一个数据字节，如果到达流的末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
将最多 len 个数据字节从此输入流读入 byte 数组。如果 len 不为 0，则此方法一直阻塞，直到至少 1 个输入字节可用；否则，不读取字节并返回 0。

SequenceInputStream 的 read 方法尝试从当前子流中读取该数据。如果由于子流到达流的末尾而未能读取任何字符，那么它将调用当前子流的 close 方法，并从下一个子流开始读取。

覆盖：
类 InputStream 中的 read
参数：
b - 读入数据的缓冲区。
off - 写入数据的数组 b 中的初始偏移量。
len - 读取的最多字节数。
返回：
读取的字节数 int。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 或 len 为负，或者 len 大于 b.length - off
IOException - 如果发生 I/O 错误。
另请参见：
InputStream.read()

close

public void close()
           throws IOException
关闭此输入流并释放与此流关联的所有系统资源。关闭的 SequenceInputStream 无法执行输入操作，且无法重新打开。

如果此流是根据一个枚举创建的，则其余所有元素都是从该枚举中请求的，并在 close 方法返回之前关闭。

指定者：
接口 Closeable 中的 close
覆盖：
类 InputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Serializable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
接口 Serializable

所有已知子接口：
AdapterActivator, Attribute, Attribute, Attributes, BindingIterator, ClientRequestInfo, ClientRequestInterceptor, Codec, CodecFactory, Control, Current, Current, Current, CustomValue, DataInputStream, DataOutputStream, Descriptor, DHPrivateKey, DHPublicKey, DocAttribute, DomainManager, DSAPrivateKey, DSAPublicKey, DynAny, DynAnyFactory, DynArray, DynEnum, DynFixed, DynSequence, DynStruct, DynUnion, DynValue, DynValueBox, DynValueCommon, ECPrivateKey, ECPublicKey, ExtendedRequest, ExtendedResponse, Externalizable, IdAssignmentPolicy, IDLEntity, IDLType, IdUniquenessPolicy, ImplicitActivationPolicy, Interceptor, IORInfo, IORInterceptor, IORInterceptor_3_0, IRObject, Key, LifespanPolicy, Name, NamingContext, NamingContextExt, NotificationFilter, ObjectReferenceFactory, ObjectReferenceTemplate, ORBInitializer, ORBInitInfo, PBEKey, POA, POAManager, Policy, PolicyFactory, PrintJobAttribute, PrintRequestAttribute, PrintServiceAttribute, PrivateKey, PublicKey, QueryExp, RelationType, RemoteRef, RequestInfo, RequestProcessingPolicy, RSAMultiPrimePrivateCrtKey, RSAPrivateCrtKey, RSAPrivateKey, RSAPublicKey, RunTime, SecretKey, ServantActivator, ServantLocator, ServantManager, ServantRetentionPolicy, ServerRef, ServerRequestInfo, ServerRequestInterceptor, StreamableValue, SupportedValuesAttribute, ThreadPolicy, UnsolicitedNotification, ValueBase, ValueExp
public interface Serializable

类通过实现 java.io.Serializable 接口以启用其序列化功能。未实现此接口的类将无法使其任何状态序列化或反序列化。可序列化类的所有子类型本身都是可序列化的。序列化接口没有方法或字段，仅用于标识可序列化的语义。

要允许不可序列化类的子类型序列化，可以假定该子类型负责保存和恢复超类型的公用 (public)、受保护的 (protected) 和（如果可访问）包 (package) 字段的状态。仅在子类型扩展的类有一个可访问的无参数构造方法来初始化该类的状态时，才可以假定子类型有此职责。如果不是这种情况，则声明一个类为可序列化类是错误的。该错误将在运行时检测到。

在反序列化过程中，将使用该类的公用或受保护的无参数构造方法初始化不可序列化类的字段。可序列化的子类必须能够访问无参数构造方法。可序列化子类的字段将从该流中恢复。

当遍历一个图形时，可能会遇到不支持 Serializable 接口的对象。在此情况下，将抛出 NotSerializableException，并将标识不可序列化对象的类。

在序列化和反序列化过程中需要特殊处理的类必须使用下列准确签名来实现特殊方法：

 private void writeObject(java.io.ObjectOutputStream out)
     throws IOException
 private void readObject(java.io.ObjectInputStream in)
     throws IOException, ClassNotFoundException;
 private void readObjectNoData()
     throws ObjectStreamException;

writeObject 方法负责写入特定类的对象的状态，以便相应的 readObject 方法可以恢复它。通过调用 out.defaultWriteObject 可以调用保存 Object 的字段的默认机制。该方法本身不需要涉及属于其超类或子类的状态。通过使用 writeObject 方法或使用 DataOutput 支持的用于基本数据类型的方法将各个字段写入 ObjectOutputStream，状态可以被保存。

readObject 方法负责从流中读取并恢复类字段。它可以调用 in.defaultReadObject 来调用默认机制，以恢复对象的非静态和非瞬态字段。defaultReadObject 方法使用流中的信息来分配流中通过当前对象中相应指定字段保存的对象的字段。这用于处理类演化后需要添加新字段的情形。该方法本身不需要涉及属于其超类或子类的状态。通过使用 writeObject 方法或使用 DataOutput 支持的用于基本数据类型的方法将各个字段写入 ObjectOutputStream，状态可以被保存。

在序列化流不列出给定类作为将被反序列化对象的超类的情况下，readObjectNoData 方法负责初始化特定类的对象状态。这在接收方使用的反序列化实例类的版本不同于发送方，并且接收者版本扩展的类不是发送者版本扩展的类时发生。在序列化流已经被篡改时也将发生；因此，不管源流是“敌意的”还是不完整的，readObjectNoData 方法都可以用来正确地初始化反序列化的对象。

将对象写入流时需要指定要使用的替代对象的可序列化类，应使用准确的签名来实现此特殊方法：

 ANY-ACCESS-MODIFIER Object writeReplace() throws ObjectStreamException;

此 writeReplace 方法将由序列化调用，前提是如果此方法存在，而且它可以通过被序列化对象的类中定义的一个方法访问。因此，该方法可以拥有私有 (private)、受保护的 (protected) 和包私有 (package-private) 访问。子类对此方法的访问遵循 java 访问规则。

在从流中读取类的一个实例时需要指定替代的类应使用的准确签名来实现此特殊方法。

 ANY-ACCESS-MODIFIER Object readResolve() throws ObjectStreamException;

此 readResolve 方法遵循与 writeReplace 相同的调用规则和访问规则。

序列化运行时使用一个称为 serialVersionUID 的版本号与每个可序列化类相关联，该序列号在反序列化过程中用于验证序列化对象的发送者和接收者是否为该对象加载了与序列化兼容的类。如果接收者加载的该对象的类的 serialVersionUID 与对应的发送者的类的版本号不同，则反序列化将会导致 InvalidClassException。可序列化类可以通过声明名为 "serialVersionUID" 的字段（该字段必须是静态 (static)、最终 (final) 的 long 型字段）显式声明其自己的 serialVersionUID：

 ANY-ACCESS-MODIFIER static final long serialVersionUID = 42L;
如果可序列化类未显式声明 serialVersionUID，则序列化运行时将基于该类的各个方面计算该类的默认 serialVersionUID 值，如“Java(TM) 对象序列化规范”中所述。不过，强烈建议 所有可序列化类都显式声明 serialVersionUID 值，原因是计算默认的 serialVersionUID 对类的详细信息具有较高的敏感性，根据编译器实现的不同可能千差万别，这样在反序列化过程中可能会导致意外的 InvalidClassException。因此，为保证 serialVersionUID 值跨不同 java 编译器实现的一致性，序列化类必须声明一个明确的 serialVersionUID 值。还强烈建议使用 private 修饰符显示声明 serialVersionUID（如果可能），原因是这种声明仅应用于直接声明类 -- serialVersionUID 字段作为继承成员没有用处。数组类不能声明一个明确的 serialVersionUID，因此它们总是具有默认的计算值，但是数组类没有匹配 serialVersionUID 值的要求。

从以下版本开始：
JDK1.1
另请参见：
ObjectOutputStream, ObjectInputStream, ObjectOutput, ObjectInput, Externalizable

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SerializablePermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 SerializablePermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.io.SerializablePermission
所有已实现的接口：
Serializable, Guard
public final class SerializablePermission
extends BasicPermission

此类用于可序列化权限。SerializablePermission 包含一个名称（也称为“目标名称”），但没有动作列表；可以使用，也可以不使用指定权限。

目标名称是可序列化权限的名称（参见下面内容）。

下表列出了所有可能的 SerializablePermission 目标名称，并描述了每个名称允许何种权限，还讨论了授权代码权限的风险。

权限目标名称 | 允许的权限 | 允许此权限所带来的风险
enableSubclassImplementation | ObjectOutputStream 或 ObjectInputStream 的子类实现，可分别重写对象的默认序列化或反序列化 | 代码可以使用此实现以恶意方式序列化或反序列化类。例如，在序列化过程中，恶意代码可以使用此实现以易于攻击者访问的方式有目的地存储保密的私有字段数据。同样，在反序列化过程中，它可以反序列化一个类，并将其所有私有字段归零。
enableSubstitution | 在序列化或反序列化过程中用一个对象替代另一对象 | 这可能存在危险，因为恶意代码可以将实际对象替换为具有错误或恶意数据的对象。

从以下版本开始：
1.2
另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
SerializablePermission(String name)
创建具有指定名称的新 SerializablePermission。
SerializablePermission(String name, String actions)
创建具有指定名称的新 SerializablePermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

SerializablePermission

public SerializablePermission(String name)
创建具有指定名称的新 SerializablePermission。该名称是 SerializablePermission 的符号名，如“enableSubstitution”等。

参数：
name - SerializablePermission 的名称。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

SerializablePermission

public SerializablePermission(String name,
                              String actions)
创建具有指定名称的新 SerializablePermission 对象。此名称是 SerializablePermission 的符号名，而目前不使用动作 String，该字符串应该为 null。

参数：
name - SerializablePermission 的名称。
actions - 目前不使用而且必须设置为 null
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StreamCorruptedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 StreamCorruptedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
                    继承者  java.io.StreamCorruptedException
所有已实现的接口：
Serializable
public class StreamCorruptedException
extends ObjectStreamException

当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
StreamCorruptedException()
创建一个 StreamCorruptedException，但不列出抛出异常的原因。
StreamCorruptedException(String reason)
创建一个 StreamCorruptedException 并列出抛出异常的一个原因。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StreamCorruptedException

public StreamCorruptedException(String reason)
创建一个 StreamCorruptedException 并列出抛出异常的一个原因。

参数：
reason - 描述该异常原因的字符串。

StreamCorruptedException

public StreamCorruptedException()
创建一个 StreamCorruptedException，但不列出抛出异常的原因。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StreamTokenizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 StreamTokenizer

java.lang.Object
    继承者  java.io.StreamTokenizer

public class StreamTokenizer
extends Object

StreamTokenizer 类获取输入流并将其解析为“标记”，允许一次读取一个标记。解析过程由一个表和许多可以设置为各种状态的标志控制。该流的标记生成器可以识别标识符、数字、引用的字符串和各种注释样式。

从输入流读取的每个字节都被视为一个字符，范围在 '\u0000' 到 '\u00FF' 之间。字符值用于查找该字符的五个可能属性：空白、字母、数字、字符串引号 和注释字符。每个字符都可以有零个或多个这样的属性。

另外，一个实例还有四个标志。这些标志指示：

  • 行结束符是作为标记返回，还是被视为仅用于分隔标记的空白。
  • 是标识还是跳过 C 样式注释。
  • 是标识还是跳过 C++ 样式注释。
  • 是否将标识符的字符转换为小写字母。

典型的应用程序首先构造此类的一个实例，建立一个语法表，然后重复循环，调用该循环的每个迭代中的 nextToken 方法，直到返回值 TT_EOF。

从以下版本开始：
JDK1.0
另请参见：
nextToken(), TT_EOF

字段摘要
double | nval 如果当前标记是一个数字，则此字段将包含该数字的值。
String | sval 如果当前标记是一个文字标记，则此字段包含一个给出该文字标记的字符的字符串。
static int | TT_EOF 指示已读到流末尾的常量。
static int | TT_EOL 指示已读到行末尾的常量。
static int | TT_NUMBER 指示已读到一个数字标记的常量。
static int | TT_WORD 指示已读到一个文字标记的常量。
int | ttype 在调用 nextToken 方法之后，此字段将包含刚读取的标记的类型。
构造方法摘要
StreamTokenizer(InputStream is)
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);
StreamTokenizer(Reader r)
创建解析给定字符流的标记生成器。
方法摘要
void | commentChar(int ch) 指定该字符参数启动一个单行注释。
void | eolIsSignificant(boolean flag) 确定是否将行末尾视为标记。
int | lineno() 返回当前行号。
void | lowerCaseMode(boolean fl) 确定是否对文字标记自动使用小写字母。
int | nextToken() 从此标记生成器的输入流中解析下一个标记。
void | ordinaryChar(int ch) 指定字符参数在此标记生成器中是“普通”字符。
void | ordinaryChars(int low, int hi) 指定 low <= c <= high 范围中的所有字符 c 在此标记生成器中都是“普通”字符。
void | parseNumbers() 指定此标记生成器应解析的数字。
void | pushBack() 导致对此标记生成器的 nextToken 方法的下一个调用返回 ttype 字段中的当前值，而不修改 nval 或 sval 字段中的值。
void | quoteChar(int ch) 指定此字符的匹配对分隔此标记生成器中的字符串常量。
void | resetSyntax() 重置此标记生成器的语法表，使所有字符都成为“普通”字符。
void | slashSlashComments(boolean flag) 确定标记生成器是否识别 C++ 样式注释。
void | slashStarComments(boolean flag) 确定标记生成器是否识别 C 样式注释。
String | toString() 返回当前流标记和在其上发生的行号的字符串表示形式。
void | whitespaceChars(int low, int hi) 指定 low <= c <= high 范围中的所有字符 c 都是空白字符。
void | wordChars(int low, int hi) 指定 low <= c <= high 范围中的所有字符 c 都是文字成分。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ttype

public int ttype
在调用 nextToken 方法之后，此字段将包含刚读取的标记的类型。对于单个字符标记，其值是转换为一个整数的单一字符。对于引用的字符串标记，其值是引号字符。否则，其值是下列值之一：
  • TT_WORD 指示该标记是一个文字。
  • TT_NUMBER 指示该标记是一个数字。
  • TT_EOL 指示已读到行的末尾。如果已使用参数 true 调用 eolIsSignificant 方法，则该字段只能使用此值。
  • TT_EOF 指示已到达输入流的末尾。

此字段的初始值为 -4。

另请参见：
eolIsSignificant(boolean), nextToken(), quoteChar(int), TT_EOF, TT_EOL, TT_NUMBER, TT_WORD

TT_EOF

public static final int TT_EOF
指示已读到流末尾的常量。

另请参见：
常量字段值

TT_EOL

public static final int TT_EOL
指示已读到行末尾的常量。

另请参见：
常量字段值

TT_NUMBER

public static final int TT_NUMBER
指示已读到一个数字标记的常量。

另请参见：
常量字段值

TT_WORD

public static final int TT_WORD
指示已读到一个文字标记的常量。

另请参见：
常量字段值

sval

public String sval
如果当前标记是一个文字标记，则此字段包含一个给出该文字标记的字符的字符串。当前标记是一个引用的字符串标记时，此字段将包含该字符串的正文。

ttype 字段的值是 TT_WORD 时，当前标记将是一个文字。ttype 字段的值是一个引号字符时，当前标记将是一个引用的字符串标记。

此字段的初始值为 null。

另请参见：
quoteChar(int), TT_WORD, ttype

nval

public double nval
如果当前标记是一个数字，则此字段将包含该数字的值。ttype 字段的值是 TT_NUMBER 时，当前标记将是一个数字。

此字段的初始值为 0.0。

另请参见：
TT_NUMBER, ttype
构造方法详细信息

StreamTokenizer

@Deprecated
public StreamTokenizer(InputStream is)
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);

创建一个解析指定输入流的流标记生成器。该流标记生成器初始化为以下默认状态：
  • 从 'A' 到 'Z'、从 'a' 到 'z' 以及从 '\u00A0' 到 '\u00FF' 的所有字节值都被视为字母。
  • 从 '\u0000' 到 '\u0020' 的所有字节值都被视为空白。
  • '/' 是注释字符。
  • 单引号 '\'' 和双引号 '"' 字符串引用字符。
  • 数字被解析。
  • 行的末尾被视为空白，而不视为分隔标记。
  • C 样式和 C++ 样式的注释不被识别。

参数：
is - 输入流。
另请参见：
BufferedReader, InputStreamReader, StreamTokenizer(java.io.Reader)

StreamTokenizer

public StreamTokenizer(Reader r)
创建解析给定字符流的标记生成器。

参数：
r - 提供输入流的 Reader 对象。
从以下版本开始：
JDK1.1
方法详细信息

resetSyntax

public void resetSyntax()
重置此标记生成器的语法表，使所有字符都成为“普通”字符。有关普通字符的更多信息，请参阅 ordinaryChar 方法。

另请参见：
ordinaryChar(int)

wordChars

public void wordChars(int low,
                      int hi)
指定 low <= c <= high 范围中的所有字符 c 都是文字成分。文字标记由一个文字成分后跟零或更多文字成分或数字成分组成。

参数：
low - 该范围的低端。
hi - 该范围的高端。

whitespaceChars

public void whitespaceChars(int low,
                            int hi)
指定 low <= c <= high 范围中的所有字符 c 都是空白字符。空白字符仅用于分隔输入流中的标记。

指定范围中字符串的任何其他属性设置都被清除。

参数：
low - 该范围的低端。
hi - 该范围的高端。

ordinaryChars

public void ordinaryChars(int low,
                          int hi)
指定 low <= c <= high 范围中的所有字符 c 在此标记生成器中都是“普通”字符。关于普通字符的更多信息，请参见 ordinaryChar 方法。

参数：
low - 该范围的低端。
hi - 该范围的高端。
另请参见：
ordinaryChar(int)

ordinaryChar

public void ordinaryChar(int ch)
指定字符参数在此标记生成器中是“普通”字符。它可以移除该字符的任何特殊含意，如注释字符、文字元素、字符串分隔符、空白或数字字符。在解析器遇到此类字符时，解析器会将其视为单一字符标记，并将 ttype 字段设置为该字符的值。

将行结束符字符变为“普通”字符会妨碍 StreamTokenizer 计算行数的能力。lineno 方法将不再能够在其行计数中反映此类结束符字符的存在。

参数：
ch - 字符。
另请参见：
ttype

commentChar

public void commentChar(int ch)
指定该字符参数启动一个单行注释。从注释字符到行末尾的所有字符均被此流标记生成器忽略。

指定字符的任何其他属性设置均被清除。

参数：
ch - 字符。

quoteChar

public void quoteChar(int ch)
指定此字符的匹配对分隔此标记生成器中的字符串常量。

当 nextToken 方法遇到一个字符串常量时，ttype 字段将被设置为该字符串分隔符，sval 字段被设置为此字符串的正文。

如果遇到字符串引号字符，则将识别一个字符串，该字符串包括字符串引号字符（不包括）到下一个相同的字符串引号字符（不包括）之间、或者到行结束符或文件末尾的所有字符。常规的转义序列（如 "\n" 和 "\t"）将被识别，并在解析该字符串时转换为单一字符。

指定字符的任何其他属性设置均被清除。

参数：
ch - 字符。
另请参见：
nextToken(), sval, ttype

parseNumbers

public void parseNumbers()
指定此标记生成器应解析的数字。已修改此标记生成器的语法表，使以下十二个字符：
      0 1 2 3 4 5 6 7 8 9 . -

都具有“数字”属性。

当解析器遇到具有双精度浮点数字格式的文字标记时，会将该标记视为数字而不是文字，方法是通过将 ttype 字段设置为值 TT_NUMBER，并将该标记的数字值放入 nval 字段。

另请参见：
nval, TT_NUMBER, ttype

eolIsSignificant

public void eolIsSignificant(boolean flag)
确定是否将行末尾视为标记。如果该标志参数为 true，则此标记生成器将行末尾视为标记；在读到行末尾时，nextToken 方法返回 TT_EOL，还将 ttype 字段设置为此值。

一行是一个字符序列，以回车符 ('\r') 或者以新行符 ('\n') 结尾。另外，回车符后面紧跟新行符被视为一个单行末尾标记。

如果此 flag 为 false，行末尾字符被视为空白并仅用作分隔标记。

参数：
flag - 为 true 指示行末尾字符为分隔标记；为 false 指示行末尾字符为空白。
另请参见：
nextToken(), ttype, TT_EOL

slashStarComments

public void slashStarComments(boolean flag)
确定标记生成器是否识别 C 样式注释。如果标志参数为 true，此流标记生成器识别 C 样式注释。后面出现的 /* 和 */ 之间的所有文本将被丢弃。

如果此标志参数为 false，则不特殊对待 C 样式注释。

参数：
flag - 为 true 指示识别并忽略 C 样式注释。

slashSlashComments

public void slashSlashComments(boolean flag)
确定标记生成器是否识别 C++ 样式注释。如果标志参数为 true，此流标记生成器识别 C++ 样式注释。任何出现的两个连续斜线字符 ('/') 均被视为一个注释的开始并一直延伸到行的末尾。

如果此标志参数为 false，则不特殊对待 C++ 样式注释。

参数：
flag - 为 true 指示识别并忽略 C++ 样式注释。

lowerCaseMode

public void lowerCaseMode(boolean fl)
确定是否对文字标记自动使用小写字母。如果此标志参数为 true，则在此标记生成器的 nextToken 方法返回文字标记时（ttype 字段具有值 TT_WORD），sval 字段中的值为小写字母。

如果此标志参数为 false，则 sval 字段未被修改。

参数：
fl - 为 true 指示所有文字标记应为小写字母。
另请参见：
nextToken(), ttype, TT_WORD

nextToken

public int nextToken()
              throws IOException
从此标记生成器的输入流中解析下一个标记。下一个标记的类型在 ttype 字段中返回。关于该标记的其他信息可能位于此标记生成器的 nval 字段或 sval 字段中。

此类的典型客户机首先建立语法表，然后循环调用 nextToken 来解析后续标记，直到返回 TT_EOF。

返回：
ttype 字段的值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
nval, sval, ttype

pushBack

public void pushBack()
导致对此标记生成器的 nextToken 方法的下一个调用返回 ttype 字段中的当前值，而不修改 nval 或 sval 字段中的值。

另请参见：
nextToken(), nval, sval, ttype

lineno

public int lineno()
返回当前行号。

返回：
此流标记生成器的当前行号。

toString

public String toString()
返回当前流标记和在其上发生的行号的字符串表示形式。

未指定返回的精确字符串，但可以将以下示例视为典型示例：

Token['a'], line 10

覆盖：
类 Object 中的 toString
返回：
此标记的字符串表示形式
另请参见：
nval, sval, ttype
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringBufferInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 StringBufferInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.StringBufferInputStream
所有已实现的接口：
Closeable
已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。

@Deprecated
public class StringBufferInputStream
extends InputStream

此类允许应用程序创建输入流，在该流中读取的字节由字符串内容提供。应用程序还可以使用 ByteArrayInputStream 从 byte 数组中读取字节。

只有字符串中每个字符的低八位可以由此类使用。

从以下版本开始：
JDK1.0
另请参见：
ByteArrayInputStream, StringReader

字段摘要
protected String | buffer 已过时。 从中读取字节的字符串。
protected int | count 已过时。 输入流缓冲区中有效字符数。
protected int | pos 已过时。 要从输入流缓冲区中读取的下一个字符的索引。
构造方法摘要
StringBufferInputStream(String s)
已过时。 创建一个字符串输入流，以从指定字符串读取数据。
方法摘要
int | available() 已过时。 返回无阻塞情况下可以从此输入流读取的字节数。
int | read() 已过时。 从此输入流中读取下一个数据的字节。
int | read(byte[] b, int off, int len) 已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
void | reset() 已过时。 将输入流重置为开始读取此输入流的基础缓冲区的第一个字符处。
long | skip(long n) 已过时。 从此输入流中跳过输入的 n 个字节。
从类 java.io.InputStream 继承的方法
close, mark, markSupported, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buffer

protected String buffer
已过时。
从中读取字节的字符串。

pos

protected int pos
已过时。
要从输入流缓冲区中读取的下一个字符的索引。

另请参见：
buffer

count

protected int count
已过时。
输入流缓冲区中有效字符数。

另请参见：
buffer
构造方法详细信息

StringBufferInputStream

public StringBufferInputStream(String s)
已过时。
创建一个字符串输入流，以从指定字符串读取数据。

参数：
s - 基本输入缓冲区。
方法详细信息

read

public int read()
已过时。
从此输入流中读取下一个数据的字节。返回 0 到 255 范围内的 int 字节值。如果因流的末尾已到达而没有可用的字节，则返回值 -1。

StringBufferInputStream 的 read 方法不会阻塞。它返回此输入流的缓冲区中下一个字符的低八位。

指定者：
类 InputStream 中的 read
返回：
下一个数据字节，如果到达流的末尾，则返回 -1。

read

public int read(byte[] b,
                int off,
                int len)
已过时。
将最多 len 个数据字节从此输入流读入 byte 数组。

StringBufferInputStream 的 read 方法不会阻塞。它将此输入流的缓冲区中字符的低八位复制到 byte 数组参数中。

覆盖：
类 InputStream 中的 read
参数：
b - 读入数据的缓冲区。
off - 数据的初始偏移量。
len - 读取的最多字节数。
返回：
读入缓冲区的总字节数，如果由于流末尾已到达而不再有数据，则返回 -1。
另请参见：
InputStream.read()

skip

public long skip(long n)
已过时。
从此输入流中跳过输入的 n 个字节。如果已到达输入流的末尾，则可能会跳过非常少的字节。

覆盖：
类 InputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。

available

public int available()
已过时。
返回无阻塞情况下可以从此输入流读取的字节数。

覆盖：
类 InputStream 中的 available
返回：
count - pos 的值，它是要从输入缓冲区中读取的剩余字节数。

reset

public void reset()
已过时。
将输入流重置为开始读取此输入流的基础缓冲区的第一个字符处。

覆盖：
类 InputStream 中的 reset
另请参见：
InputStream.mark(int), IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 StringReader

java.lang.Object
    继承者  java.io.Reader
        继承者  java.io.StringReader
所有已实现的接口：
Closeable, Readable
public class StringReader
extends Reader

其源为一个字符串的字符流。

从以下版本开始：
JDK1.1

字段摘要
从类 java.io.Reader 继承的字段
lock
构造方法摘要
StringReader(String s)
创建一个新字符串 reader。
方法摘要
 void close()
关闭该流并释放与之关联的所有系统资源。
 void mark(int readAheadLimit)
标记流中的当前位置。
 boolean markSupported()
判断此流是否支持 mark() 操作以及支持哪一项操作。
 int read()
读取单个字符。
 int read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 boolean ready()
判断此流是否已经准备好用于读取。
 void reset()
将该流重置为最新的标记，如果从未标记过，则将其重置到该字符串的开头。
 long skip(long ns)
跳过流中指定数量的字符。
从类 java.io.Reader 继承的方法
read, read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringReader

public StringReader(String s)
创建一个新字符串 reader。

参数：
s - 提供字符流的字符串。
方法详细信息

read

public int read()
         throws IOException
读取单个字符。

覆盖：
类 Reader 中的 read
返回：
读取的字符，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

read

public int read(char[] cbuf,
                int off,
                int len)
         throws IOException
将字符读入数组的某一部分。

指定者：
类 Reader 中的 read
参数：
cbuf - 目标缓冲区
off - 开始写入字符处的偏移量
len - 要读取的最多字符数
返回：
读取的字符数，如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误

skip

public long skip(long ns)
          throws IOException
跳过流中指定数量的字符。返回跳过的字符数。

ns 参数可能为负数，即便 Reader 超类的 skip 方法在此情况下会抛出一个异常。ns 为负值导致此流向后跳读。负返回值指示向后跳读。向后跳读不可能超过字符串的开头。

如果读取或跳读了整个字符串，则此方法无效且始终返回 0。

覆盖：
类 Reader 中的 skip
参数：
ns - 要跳过的字符数
返回：
实际跳过的字符数
抛出：
IOException - 如果发生 I/O 错误

ready

public boolean ready()
              throws IOException
判断此流是否已经准备好用于读取。

覆盖：
类 Reader 中的 ready
返回：
如果保证下一个 read() 不阻塞输入，则返回 True
抛出：
IOException - 如果该流已关闭

markSupported

public boolean markSupported()
判断此流是否支持 mark() 操作以及支持哪一项操作。

覆盖：
类 Reader 中的 markSupported
返回：
当且仅当此流支持此 mark 操作时，返回 true。

mark

public void mark(int readAheadLimit)
          throws IOException
标记流中的当前位置。对 reset() 的后续调用会将该流重新定位到此点。

覆盖：
类 Reader 中的 mark
参数：
readAheadLimit - 在仍保留该标记的情况下，对可读取字符数量的限制。由于该流的输入来自一个字符串，不存在实际的限制，因此，此参数决不能为负数，否则将被忽略。
抛出：
IllegalArgumentException - 如果 readAheadLimit < 0
IOException - 如果发生 I/O 错误

reset

public void reset()
           throws IOException
将该流重置为最新的标记，如果从未标记过，则将其重置到该字符串的开头。

覆盖：
类 Reader 中的 reset
抛出：
IOException - 如果发生 I/O 错误

close

public void close()
关闭该流并释放与之关联的所有系统资源。在关闭该流后，再调用 read()、ready()、mark() 或 reset() 将抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
指定者：
类 Reader 中的 close
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 StringWriter

java.lang.Object
    继承者  java.io.Writer
        继承者  java.io.StringWriter
所有已实现的接口：
Closeable, Flushable, Appendable
public class StringWriter
extends Writer

一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。

关闭 StringWriter 无效。此类中的方法在关闭该流后仍可被调用，而不会产生任何 IOException。

从以下版本开始：
JDK1.1

字段摘要
从类 java.io.Writer 继承的字段
lock
构造方法摘要
StringWriter()
使用默认初始字符串缓冲区大小创建一个新字符串 writer。
StringWriter(int initialSize)
使用指定初始字符串缓冲区大小创建一个新字符串 writer。
方法摘要
StringWriter | append(char c) 将指定字符添加到此 writer。
StringWriter | append(CharSequence csq) 将指定的字符序列添加到此 writer。
StringWriter | append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
void | close() 关闭 StringWriter 无效。
void | flush() 刷新该流的缓冲。
StringBuffer | getBuffer() 返回该字符串缓冲区本身。
String | toString() 以字符串的形式返回该缓冲区的当前值。
void | write(char[] cbuf, int off, int len) 写入字符数组的某一部分。
void | write(int c) 写入单个字符。
void | write(String str) 写入一个字符串。
void | write(String str, int off, int len) 写入字符串的某一部分。
从类 java.io.Writer 继承的方法
write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StringWriter

public StringWriter()
使用默认初始字符串缓冲区大小创建一个新字符串 writer。

StringWriter

public StringWriter(int initialSize)
使用指定初始字符串缓冲区大小创建一个新字符串 writer。

参数：
initialSize - 在此缓冲区自动扩展前适合它的 char 值数。
抛出：
IllegalArgumentException - 如果 initialSize 为负
方法详细信息

write

public void write(int c)
写入单个字符。

覆盖：
类 Writer 中的 write
参数：
c - 指定要写入字符的 int。

write

public void write(char[] cbuf,
                  int off,
                  int len)
写入字符数组的某一部分。

指定者：
类 Writer 中的 write
参数：
cbuf - 字符数组
off - 开始写入字符处的偏移量
len - 要写入的字符数

write

public void write(String str)
写入一个字符串。

覆盖：
类 Writer 中的 write
参数：
str - 要写入的字符串

write

public void write(String str,
                  int off,
                  int len)
写入字符串的某一部分。

覆盖：
类 Writer 中的 write
参数：
str - 要写入的字符串
off - 开始写入字符处的偏移量
len - 要写入的字符数

append

public StringWriter append(CharSequence csq)
将指定的字符序列添加到此 writer。

以 out.append(csq) 的形式调用此方法，行为与以下调用完全相同：

     out.write(csq.toString())

可能不添加整个序列，也可能添加，具体取决于字符序列 csq 的 toString 指定。例如，调用一个字符缓冲区的 toString 方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
csq - 要添加的字符串序列。如果 csq 为 null，则向此 writer 添加四个字符 "null"。
返回：
此 writer
从以下版本开始：
1.5

append

public StringWriter append(CharSequence csq,
                           int start,
                           int end)
将指定字符序列的子序列添加到此 writer。

当 csq 不为 null 时，调用该方法的 out.append(csq、 start、 end) 形式，行为与以下调用完全相同：

     out.write(csq.subSequence(start, end).toString())

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
csq - 子序列将被添加的字符序列。如果 csq 为 null，则添加四个字符 "null"，就好像 csq 包含它们一样。
start - 子序列中第一个字符的索引
end - 子序列中最后一个字符后面的字符的索引
返回：
此 writer
抛出：
IndexOutOfBoundsException - 如果 start 或 end 为负，而 start 大于 end 或者 end 大于 csq.length()。
从以下版本开始：
1.5

append

public StringWriter append(char c)
将指定字符添加到此 writer。

以 out.append(c) 的形式调用此方法，行为与以下调用完全相同：

     out.write(c)

指定者：
接口 Appendable 中的 append
覆盖：
类 Writer 中的 append
参数：
c - 要添加的 16 位字符
返回：
此 writer
从以下版本开始：
1.5

toString

public String toString()
以字符串的形式返回该缓冲区的当前值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getBuffer

public StringBuffer getBuffer()
返回该字符串缓冲区本身。

返回：
保存当前缓冲区值的 StringBuffer。

flush

public void flush()
刷新该流的缓冲。

指定者：
接口 Flushable 中的 flush
指定者：
类 Writer 中的 flush

close

public void close()
           throws IOException
关闭 StringWriter 无效。此类中的方法在关闭该流后仍可被调用，而不会产生任何 IOException。

指定者：
接口 Closeable 中的 close
指定者：
类 Writer 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SyncFailedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 SyncFailedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.SyncFailedException
所有已实现的接口：
Serializable
public class SyncFailedException
extends IOException

当 sync 操作失败时，抛出此异常。

从以下版本开始：
JDK1.1
另请参见：
FileDescriptor.sync(), IOException, 序列化表格

构造方法摘要
SyncFailedException(String desc)
构造一个带详细消息的 SyncFailedException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SyncFailedException

public SyncFailedException(String desc)
构造一个带详细消息的 SyncFailedException。详细消息是描述这个特定异常的字符串。

参数：
desc - 描述该异常的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedEncodingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 UnsupportedEncodingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.UnsupportedEncodingException
所有已实现的接口：
Serializable
public class UnsupportedEncodingException
extends IOException

不支持字符编码。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
UnsupportedEncodingException()
构造不带详细消息的 UnsupportedEncodingException。
UnsupportedEncodingException(String s)
构造带详细消息的 UnsupportedEncodingException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedEncodingException

public UnsupportedEncodingException()
构造不带详细消息的 UnsupportedEncodingException。

UnsupportedEncodingException

public UnsupportedEncodingException(String s)
构造带详细消息的 UnsupportedEncodingException。

参数：
s - 描述该异常的原因。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UTFDataFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 UTFDataFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.UTFDataFormatException
所有已实现的接口：
Serializable
public class UTFDataFormatException
extends IOException

在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。有关读取和写入 UTF-8 修改版字符串的格式，请参阅 DataInput 类的描述。

从以下版本开始：
JDK1.0
另请参见：
DataInput, DataInputStream.readUTF(java.io.DataInput), IOException, 序列化表格

构造方法摘要
UTFDataFormatException()
构造用 null 作为其错误详细消息的 UTFDataFormatException。
UTFDataFormatException(String s)
构造带有指定详细消息的 UTFDataFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UTFDataFormatException

public UTFDataFormatException()
构造用 null 作为其错误详细消息的 UTFDataFormatException。

UTFDataFormatException

public UTFDataFormatException(String s)
构造带有指定详细消息的 UTFDataFormatException。然后可以通过 java.lang.Throwable 类的 Throwable.getMessage() 方法获取字符串 s。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WriteAbortedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.io
类 WriteAbortedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.ObjectStreamException
                    继承者  java.io.WriteAbortedException
所有已实现的接口：
Serializable
public class WriteAbortedException
extends ObjectStreamException

在写入操作过程中抛出 ObjectStreamException 之一的信号。在写入操作过程中抛出 ObjectStreamExceptions 之一时，在读取操作过程中将抛出此异常。终止写入的异常可在详细信息字段中找到。该流被重置为初始状态，而且对已经反序列化的对象的所有引用都被丢弃。

从版本 1.4 开始，已对此异常作出改进，以符合通用异常链机制。在构造时提供并通过公共 detail 字段访问的“导致中止的异常”现在称为 cause，并可通过 Throwable.getCause() 方法以及前述的“遗留字段”访问。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
 Exception detail
在写入 ObjectStream 时捕获的异常。
构造方法摘要
WriteAbortedException(String s, Exception ex)
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。
方法摘要
Throwable | getCause() 返回终止操作的异常（即 cause）。
String | getMessage() 生成此消息并包括嵌入异常的消息（如果有）。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

detail

public Exception detail
在写入 ObjectStream 时捕获的异常。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获得此信息的首选方法。

构造方法详细信息

WriteAbortedException

public WriteAbortedException(String s,
                             Exception ex)
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。

参数：
s - 描述该异常的字符串。
ex - 导致中止的异常。
方法详细信息

getMessage

public String getMessage()
生成此消息并包括嵌入异常的消息（如果有）。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。

getCause

public Throwable getCause()
返回终止操作的异常（即 cause）。

覆盖：
类 Throwable 中的 getCause
返回：
终止操作的异常（即 cause），可能为 null。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Writer (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.io
类 Writer

java.lang.Object
    继承者  java.io.Writer
所有已实现的接口：
Closeable, Flushable, Appendable
直接已知子类：
BufferedWriter, CharArrayWriter, FilterWriter, OutputStreamWriter, PipedWriter, PrintWriter, StringWriter
public abstract class Writer
extends Object
implements Appendable, Closeable, Flushable

写入字符流的抽象类。子类必须实现的方法仅有 write(char[], int, int)、flush() 和 close()。但是，多数子类将重写此处定义的一些方法，以提供更高的效率和/或其他功能。

从以下版本开始：
JDK1.1
另请参见：
Writer, BufferedWriter, CharArrayWriter, FilterWriter, OutputStreamWriter, FileWriter, PipedWriter, PrintWriter, StringWriter, Reader

字段摘要
protected  Object lock
用于同步针对此流的操作的对象。
构造方法摘要
protected | Writer() 创建一个新的字符流 writer，其关键部分将同步 writer 自身。
protected | Writer(Object lock) 创建一个新的字符流 writer，其关键部分将同步给定的对象。
方法摘要
Writer | append(char c) 将指定字符添加到此 writer。
Writer | append(CharSequence csq) 将指定字符序列添加到此 writer。
Writer | append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer.Appendable。
abstract void | close() 关闭此流，但要先刷新它。
abstract void | flush() 刷新该流的缓冲。
void | write(char[] cbuf) 写入字符数组。
abstract void | write(char[] cbuf, int off, int len) 写入字符数组的某一部分。
void | write(int c) 写入单个字符。
void | write(String str) 写入字符串。
void | write(String str, int off, int len) 写入字符串的某一部分。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

lock

protected Object lock
用于同步针对此流的操作的对象。为了提高效率，字符流对象可以使用其自身以外的对象来保护关键部分。因此，子类应使用此字段中的对象，而不是 this 或者同步的方法。

构造方法详细信息

Writer

protected Writer()
创建一个新的字符流 writer，其关键部分将同步 writer 自身。

Writer

protected Writer(Object lock)
创建一个新的字符流 writer，其关键部分将同步给定的对象。

参数：
lock - 要同步的对象。
方法详细信息

write

public void write(int c)
           throws IOException
写入单个字符。要写入的字符包含在给定整数值的 16 个低位中，16 高位被忽略。

用于支持高效单字符输出的子类应重写此方法。

参数：
c - 指定要写入字符的 int。
抛出：
IOException - 如果发生 I/O 错误

write

public void write(char[] cbuf)
           throws IOException
写入字符数组。

参数：
cbuf - 要写入的字符数组
抛出：
IOException - 如果发生 I/O 错误

write

public abstract void write(char[] cbuf,
                           int off,
                           int len)
                    throws IOException
写入字符数组的某一部分。

参数：
cbuf - 字符数组
off - 开始写入字符处的偏移量
len - 要写入的字符数
抛出：
IOException - 如果发生 I/O 错误

write

public void write(String str)
           throws IOException
写入字符串。

参数：
str - 要写入的字符串
抛出：
IOException - 如果发生 I/O 错误

write

public void write(String str,
                  int off,
                  int len)
           throws IOException
写入字符串的某一部分。

参数：
str - 字符串
off - 相对初始写入字符的偏移量
len - 要写入的字符数
抛出：
IndexOutOfBoundsException - 如果 off 或 len 为负，或者 off+len 为负或大于给定字符串的长度
IOException - 如果发生 I/O 错误

append

public Writer append(CharSequence csq)
              throws IOException
将指定字符序列添加到此 writer。

以 out.append(csq) 的形式调用此方法，行为与以下调用完全相同：

     out.write(csq.toString())

可能不添加整个序列，也可能添加，具体取决于字符序列 csq 的 toString 规范。例如，调用一个字符缓冲区的 toString 方法将返回一个子序列，其内容取决于缓冲区的位置和限制。

指定者：
接口 Appendable 中的 append
参数：
csq - 要添加的字符串序列。如果 csq 为 null，则向此 writer 添加四个字符 "null"。
返回：
此 writer
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
1.5

append

public Writer append(CharSequence csq,
                     int start,
                     int end)
              throws IOException
将指定字符序列的子序列添加到此 writer.Appendable。

当 csq 不为 null 时，以 out.append(csq, start, end) 的形式调用此方法，行为与以下调用完全相同：

     out.write(csq.subSequence(start, end).toString())

指定者：
接口 Appendable 中的 append
参数：
csq - 要添加子序列的字符序列。如果 csq 为 null，则添加四个字符 "null"，就好像 csq 包含这些字符一样。
start - 子序列中第一个字符的索引
end - 子序列中最后一个字符后面的字符的索引
返回：
此 writer
抛出：
IndexOutOfBoundsException - 如果 start 或 end 为负，而 start 大于 end 或者 end 大于 csq.length()
IOException - 如果发生 I/O 错误
从以下版本开始：
1.5

append

public Writer append(char c)
              throws IOException
将指定字符添加到此 writer。

以 out.append(c) 的形式调用此方法，行为与以下调用完全相同：

     out.write(c)

指定者：
接口 Appendable 中的 append
参数：
c - 要添加的 16 位字符
返回：
此 writer
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
1.5

flush

public abstract void flush()
                    throws IOException
刷新该流的缓冲。如果该流已保存缓冲区中各种 write() 方法的所有字符，则立即将它们写入预期目标。然后，如果该目标是另一个字符或字节流，则将其刷新。因此，一次 flush() 调用将刷新 Writer 和 OutputStream 链中的所有缓冲区。

如果此流的预期目标是由底层操作系统提供的一个抽象（如一个文件），则刷新该流只能保证将以前写入到流的字节传递给操作系统进行写入，但不保证能将这些字节实际写入到物理设备（如磁盘驱动器）。

指定者：
接口 Flushable 中的 flush
抛出：
IOException - 如果发生 I/O 错误

close

public abstract void close()
                    throws IOException
关闭此流，但要先刷新它。在关闭该流之后，再调用 write() 或 flush() 将导致抛出 IOException。关闭以前关闭的流无效。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.io (Java 2 Platform SE 6)

 java.io
接口
Closeable
DataInput
DataOutput
Externalizable
FileFilter
FilenameFilter
Flushable
ObjectInput
ObjectInputValidation
ObjectOutput
ObjectStreamConstants
Serializable
类
BufferedInputStream
BufferedOutputStream
BufferedReader
BufferedWriter
ByteArrayInputStream
ByteArrayOutputStream
CharArrayReader
CharArrayWriter
Console
DataInputStream
DataOutputStream
File
FileDescriptor
FileInputStream
FileOutputStream
FilePermission
FileReader
FileWriter
FilterInputStream
FilterOutputStream
FilterReader
FilterWriter
InputStream
InputStreamReader
LineNumberInputStream
LineNumberReader
ObjectInputStream
ObjectInputStream.GetField
ObjectOutputStream
ObjectOutputStream.PutField
ObjectStreamClass
ObjectStreamField
OutputStream
OutputStreamWriter
PipedInputStream
PipedOutputStream
PipedReader
PipedWriter
PrintStream
PrintWriter
PushbackInputStream
PushbackReader
RandomAccessFile
Reader
SequenceInputStream
SerializablePermission
StreamTokenizer
StringBufferInputStream
StringReader
StringWriter
Writer
异常
CharConversionException
EOFException
FileNotFoundException
InterruptedIOException
InvalidClassException
InvalidObjectException
IOException
NotActiveException
NotSerializableException
ObjectStreamException
OptionalDataException
StreamCorruptedException
SyncFailedException
UnsupportedEncodingException
UTFDataFormatException
WriteAbortedException
错误
IOError


java.io (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.io

通过数据流、序列化和文件系统提供系统输入和输出。

请参见：
描述

接口摘要
Closeable | Closeable 是可以关闭的数据源或目标。
DataInput | DataInput 接口用于从二进制流中读取字节，并根据所有 Java 基本类型数据进行重构。
DataOutput | DataOutput 接口用于将数据从任意 Java 基本类型转换为一系列字节，并将这些字节写入二进制流。
Externalizable | Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。
FileFilter | 用于抽象路径名的过滤器。
FilenameFilter | 实现此接口的类实例可用于过滤器文件名。
Flushable | Flushable 是可刷新数据的目标地。
ObjectInput | ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectInputValidation | 允许验证图形中对象的回调接口。
ObjectOutput | ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
ObjectStreamConstants | 写入 Object Serialization Stream 的常量。
Serializable | 类通过实现 java.io.Serializable 接口以启用其序列化功能。

类摘要
BufferedInputStream | BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
BufferedOutputStream | 该类实现缓冲的输出流。
BufferedReader | 从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
BufferedWriter | 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
ByteArrayInputStream | ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。
ByteArrayOutputStream | 此类实现了一个输出流，其中的数据被写入一个 byte 数组。
CharArrayReader | 此类实现一个可用作字符输入流的字符缓冲区。
CharArrayWriter | 此类实现一个可用作 Writer 的字符缓冲区。
Console | 此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。
DataInputStream | 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
DataOutputStream | 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
File | 文件和目录路径名的抽象表示形式。
FileDescriptor | 文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。
FileInputStream | FileInputStream 从文件系统中的某个文件中获得输入字节。
FileOutputStream | 文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
FilePermission | 此类表示对文件和目录的访问。
FileReader | 用来读取字符文件的便捷类。
FileWriter | 用来写入字符文件的便捷类。
FilterInputStream | FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterOutputStream | 此类是过滤输出流的所有类的超类。
FilterReader | 用于读取已过滤的字符流的抽象类。
FilterWriter | 用于写入已过滤的字符流的抽象类。
InputStream | 此抽象类是表示字节输入流的所有类的超类。
InputStreamReader | InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
LineNumberInputStream | 已过时。 此类错误假定字节能充分表示字符。
LineNumberReader | 跟踪行号的缓冲字符输入流。
ObjectInputStream | ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
ObjectInputStream.GetField | 提供对从输入流读取的持久字段的访问权限。
ObjectOutputStream | ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
ObjectOutputStream.PutField | 提供对要写入 ObjectOutput 的持久字段的编程访问。
ObjectStreamClass | 类的序列化描述符。
ObjectStreamField | Serializable 类中 Serializable 字段的描述。
OutputStream | 此抽象类是表示输出字节流的所有类的超类。
OutputStreamWriter | OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
PipedInputStream | 管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
PipedOutputStream | 可以将管道输出流连接到管道输入流来创建通信管道。
PipedReader | 传送的字符输入流。
PipedWriter | 传送的字符输出流。
PrintStream | PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter | 向文本输出流打印对象的格式化表示形式。
PushbackInputStream | PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。
PushbackReader | 允许将字符推回到流的字符流 reader。
RandomAccessFile | 此类的实例支持对随机访问文件的读取和写入。
Reader | 用于读取字符流的抽象类。
SequenceInputStream | SequenceInputStream 表示其他输入流的逻辑串联。
SerializablePermission | 此类用于可序列化权限。
StreamTokenizer | StreamTokenizer 类获取输入流并将其解析为“标记”，允许一次读取一个标记。
StringBufferInputStream | 已过时。 此类未能正确地将字符转换为字节。
StringReader | 其源为一个字符串的字符流。
StringWriter | 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
Writer | 写入字符流的抽象类。

异常摘要
CharConversionException | 用于字符转换异常的基类。
EOFException | 当输入过程中意外到达文件或流的末尾时，抛出此异常。
FileNotFoundException | 当试图打开指定路径名表示的文件失败时，抛出此异常。
InterruptedIOException | I/O 操作已中断信号，抛出此异常。
InvalidClassException | 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
InvalidObjectException | 指示一个或多个反序列化对象未通过验证测试。
IOException | 当发生某种 I/O 异常时，抛出此异常。
NotActiveException | 当序列化和反序列化不活动时，抛出此异常。
NotSerializableException | 当实例需要具有序列化接口时，抛出此异常。
ObjectStreamException | 特定于 Object Stream 类的所有异常的超类。
OptionalDataException | 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
StreamCorruptedException | 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
SyncFailedException | 当 sync 操作失败时，抛出此异常。
UnsupportedEncodingException | 不支持字符编码。
UTFDataFormatException | 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
WriteAbortedException | 在写入操作过程中抛出 ObjectStreamException 之一的信号。

错误摘要
IOError 当发生严重的 I/O 错误时，抛出此错误。

软件包 java.io 的描述

通过数据流、序列化和文件系统提供系统输入和输出。 除非另有说明，否则向此包的任何类或接口中的构造方法或方法传递 null 参数时，都将抛出 NullPointerException。

包规范

  • Java Object Serialization Specification

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • Serialization Enhancements

从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.io 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.io 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.io.Console (implements java.io.Flushable)
    • java.io.File (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.io.FileDescriptor
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.ByteArrayInputStream
      • java.io.FileInputStream
      • java.io.FilterInputStream
        • java.io.BufferedInputStream
        • java.io.DataInputStream (implements java.io.DataInput)
        • java.io.LineNumberInputStream
        • java.io.PushbackInputStream
      • java.io.ObjectInputStream (implements java.io.ObjectInput, java.io.ObjectStreamConstants)
      • java.io.PipedInputStream
      • java.io.SequenceInputStream
      • java.io.StringBufferInputStream
    • java.io.ObjectInputStream.GetField
    • java.io.ObjectOutputStream.PutField
    • java.io.ObjectStreamClass (implements java.io.Serializable)
    • java.io.ObjectStreamField (implements java.lang.Comparable<T>)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.ByteArrayOutputStream
      • java.io.FileOutputStream
      • java.io.FilterOutputStream
        • java.io.BufferedOutputStream
        • java.io.DataOutputStream (implements java.io.DataOutput)
        • java.io.PrintStream (implements java.lang.Appendable, java.io.Closeable)
      • java.io.ObjectOutputStream (implements java.io.ObjectOutput, java.io.ObjectStreamConstants)
      • java.io.PipedOutputStream
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.io.SerializablePermission
      • java.io.FilePermission (implements java.io.Serializable)
    • java.io.RandomAccessFile (implements java.io.Closeable, java.io.DataInput, java.io.DataOutput)
    • java.io.Reader (implements java.io.Closeable, java.lang.Readable)
      • java.io.BufferedReader
        • java.io.LineNumberReader
      • java.io.CharArrayReader
      • java.io.FilterReader
        • java.io.PushbackReader
      • java.io.InputStreamReader
        • java.io.FileReader
      • java.io.PipedReader
      • java.io.StringReader
    • java.io.StreamTokenizer
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.io.IOError
      • java.lang.Exception
        • java.io.IOException
          • java.io.CharConversionException
          • java.io.EOFException
          • java.io.FileNotFoundException
          • java.io.InterruptedIOException
          • java.io.ObjectStreamException
            • java.io.InvalidClassException
            • java.io.InvalidObjectException
            • java.io.NotActiveException
            • java.io.NotSerializableException
            • java.io.OptionalDataException
            • java.io.StreamCorruptedException
            • java.io.WriteAbortedException
          • java.io.SyncFailedException
          • java.io.UnsupportedEncodingException
          • java.io.UTFDataFormatException
    • java.io.Writer (implements java.lang.Appendable, java.io.Closeable, java.io.Flushable)
      • java.io.BufferedWriter
      • java.io.CharArrayWriter
      • java.io.FilterWriter
      • java.io.OutputStreamWriter
        • java.io.FileWriter
      • java.io.PipedWriter
      • java.io.PrintWriter
      • java.io.StringWriter

接口分层结构

  • java.io.Closeable
  • java.io.DataInput
    • java.io.ObjectInput
  • java.io.DataOutput
    • java.io.ObjectOutput
  • java.io.FileFilter
  • java.io.FilenameFilter
  • java.io.Flushable
  • java.io.ObjectInputValidation
  • java.io.ObjectStreamConstants
  • java.io.Serializable
    • java.io.Externalizable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.io 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.io
的使用

使用 java.io 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.jws |
javax.jws.soap |
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert | 为公钥证书提供类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
FilenameFilter
实现此接口的类实例可用于过滤器文件名。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
ObjectStreamException
特定于 Object Stream 类的所有异常的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.color 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectStreamException
特定于 Object Stream 类的所有异常的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.datatransfer 使用的 java.io 中的类
Externalizable
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInput
ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectOutput
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.dnd 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.event 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.font 使用的 java.io 中的类
InvalidObjectException
指示一个或多个反序列化对象未通过验证测试。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.geom 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.image 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.image.renderable 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.awt.print 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.beans 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.beans.beancontext 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.io 使用的 java.io 中的类
BufferedReader
从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
CharArrayWriter
此类实现一个可用作 Writer 的字符缓冲区。
Closeable
Closeable 是可以关闭的数据源或目标。
Console
此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。
DataInput
DataInput 接口用于从二进制流中读取字节，并根据所有 Java 基本类型数据进行重构。
DataOutput
DataOutput 接口用于将数据从任意 Java 基本类型转换为一系列字节，并将这些字节写入二进制流。
File
文件和目录路径名的抽象表示形式。
FileDescriptor
文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。
FileFilter
用于抽象路径名的过滤器。
FilenameFilter
实现此接口的类实例可用于过滤器文件名。
FileNotFoundException
当试图打开指定路径名表示的文件失败时，抛出此异常。
FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterOutputStream
此类是过滤输出流的所有类的超类。
FilterReader
用于读取已过滤的字符流的抽象类。
Flushable
Flushable 是可刷新数据的目标地。
InputStream
此抽象类是表示字节输入流的所有类的超类。
InputStreamReader
InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
InvalidObjectException
指示一个或多个反序列化对象未通过验证测试。
IOException
当发生某种 I/O 异常时，抛出此异常。
NotActiveException
当序列化和反序列化不活动时，抛出此异常。
ObjectInput
ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectInputStream.GetField
提供对从输入流读取的持久字段的访问权限。
ObjectInputValidation
允许验证图形中对象的回调接口。
ObjectOutput
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
ObjectOutputStream.PutField
提供对要写入 ObjectOutput 的持久字段的编程访问。
ObjectStreamClass
类的序列化描述符。
ObjectStreamConstants
写入 Object Serialization Stream 的常量。
ObjectStreamException
特定于 Object Stream 类的所有异常的超类。
ObjectStreamField
Serializable 类中 Serializable 字段的描述。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
OutputStreamWriter
OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
PipedInputStream
管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
PipedOutputStream
可以将管道输出流连接到管道输入流来创建通信管道。
PipedReader
传送的字符输入流。
PipedWriter
传送的字符输出流。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
SerializablePermission
此类用于可序列化权限。
StreamCorruptedException
当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
StringWriter
一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
SyncFailedException
当 sync 操作失败时，抛出此异常。
UnsupportedEncodingException
不支持字符编码。
Writer
写入字符流的抽象类。

java.lang 使用的 java.io 中的类
Console
此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。
File
文件和目录路径名的抽象表示形式。
FileDescriptor
文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
UnsupportedEncodingException
不支持字符编码。

java.lang.annotation 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.lang.instrument 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.lang.management 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.lang.reflect 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.math 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.net 使用的 java.io 中的类
FileDescriptor
文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。
InputStream
此抽象类是表示字节输入流的所有类的超类。
InterruptedIOException
I/O 操作已中断信号，抛出此异常。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
UnsupportedEncodingException
不支持字符编码。

java.nio 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.nio.channels 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

java.nio.channels.spi 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
IOException
当发生某种 I/O 异常时，抛出此异常。

java.nio.charset 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.rmi 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.rmi.activation 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.rmi.dgc 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.rmi.server 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
DataInput
DataInput 接口用于从二进制流中读取字节，并根据所有 Java 基本类型数据进行重构。
DataOutput
DataOutput 接口用于将数据从任意 Java 基本类型转换为一系列字节，并将这些字节写入二进制流。
Externalizable
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。
FilterOutputStream
此类是过滤输出流的所有类的超类。
Flushable
Flushable 是可刷新数据的目标地。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInput
ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectOutput
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
StreamCorruptedException
当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。

java.security 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
File
文件和目录路径名的抽象表示形式。
FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterOutputStream
此类是过滤输出流的所有类的超类。
Flushable
Flushable 是可刷新数据的目标地。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectStreamException
特定于 Object Stream 类的所有异常的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.security.acl 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.security.cert 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectStreamException
特定于 Object Stream 类的所有异常的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.security.interfaces 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.security.spec 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.sql 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

java.text 使用的 java.io 中的类
InvalidObjectException
指示一个或多个反序列化对象未通过验证测试。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.util 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
File
文件和目录路径名的抽象表示形式。
FileNotFoundException
当试图打开指定路径名表示的文件失败时，抛出此异常。
Flushable
Flushable 是可刷新数据的目标地。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
UnsupportedEncodingException
不支持字符编码。
Writer
写入字符流的抽象类。

java.util.concurrent 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.util.concurrent.atomic 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.util.concurrent.locks 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.util.jar 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
File
文件和目录路径名的抽象表示形式。
FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterOutputStream
此类是过滤输出流的所有类的超类。
Flushable
Flushable 是可刷新数据的目标地。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.util.logging 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
UnsupportedEncodingException
不支持字符编码。

java.util.prefs 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.util.regex 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

java.util.zip 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
File
文件和目录路径名的抽象表示形式。
FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterOutputStream
此类是过滤输出流的所有类的超类。
Flushable
Flushable 是可刷新数据的目标地。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.accessibility 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。

javax.activation 使用的 java.io 中的类
Externalizable
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInput
ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectOutput
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.activity 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.annotation 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.annotation.processing 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.crypto 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
FilterOutputStream
此类是过滤输出流的所有类的超类。
Flushable
Flushable 是可刷新数据的目标地。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.crypto.interfaces 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.crypto.spec 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.imageio 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.imageio.metadata 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.imageio.spi 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
IOException
当发生某种 I/O 异常时，抛出此异常。

javax.imageio.stream 使用的 java.io 中的类
DataInput
DataInput 接口用于从二进制流中读取字节，并根据所有 Java 基本类型数据进行重构。
DataOutput
DataOutput 接口用于将数据从任意 Java 基本类型转换为一系列字节，并将这些字节写入二进制流。
File
文件和目录路径名的抽象表示形式。
FileNotFoundException
当试图打开指定路径名表示的文件失败时，抛出此异常。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
RandomAccessFile
此类的实例支持对随机访问文件的读取和写入。

javax.jws 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.jws.soap 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.lang.model 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.lang.model.element 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.lang.model.type 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.lang.model.util 使用的 java.io 中的类
Writer
写入字符流的抽象类。

javax.management 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.loading 使用的 java.io 中的类
Externalizable
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInput
ObjectInput 扩展 DataInput 接口以包含对象的读操作。
ObjectOutput
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.modelmbean 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.monitor 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.openmbean 使用的 java.io 中的类
ObjectStreamException
特定于 Object Stream 类的所有异常的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.relation 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.remote 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.remote.rmi 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.management.timer 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.naming 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.naming.directory 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.naming.event 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.naming.ldap 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.naming.spi 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.net 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。

javax.net.ssl 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.print 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.print.attribute 使用的 java.io 中的类
ObjectStreamException
特定于 Object Stream 类的所有异常的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.print.attribute.standard 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.print.event 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.rmi.CORBA 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.rmi.ssl 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.script 使用的 java.io 中的类
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.security.auth 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.security.auth.callback 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.security.auth.kerberos 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.security.auth.login 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.security.auth.x500 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.security.cert 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。

javax.security.sasl 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.sound.midi 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.sound.midi.spi 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。

javax.sound.sampled 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.sound.sampled.spi 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。

javax.sql 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.sql.rowset 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.sql.rowset.serial 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.sql.rowset.spi 使用的 java.io 中的类
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.swing 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
File
文件和目录路径名的抽象表示形式。
FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.border 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.colorchooser 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.event 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.filechooser 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
IOException
当发生某种 I/O 异常时，抛出此异常。

javax.swing.plaf 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.plaf.basic 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.plaf.metal 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.plaf.multi 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。

javax.swing.plaf.synth 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.table 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.text 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.swing.text.html 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.swing.text.html.parser 使用的 java.io 中的类
DataInputStream
数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
IOException
当发生某种 I/O 异常时，抛出此异常。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.text.rtf 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.swing.tree 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.swing.undo 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.tools 使用的 java.io 中的类
Closeable
Closeable 是可以关闭的数据源或目标。
File
文件和目录路径名的抽象表示形式。
Flushable
Flushable 是可刷新数据的目标地。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.transaction 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.transaction.xa 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.bind 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.xml.bind.annotation 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.bind.helpers 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
UnsupportedEncodingException
不支持字符编码。
Writer
写入字符流的抽象类。

javax.xml.crypto 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.crypto.dsig 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.datatype 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.namespace 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.parsers 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.soap 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.stream 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

javax.xml.stream.events 使用的 java.io 中的类
Writer
写入字符流的抽象类。

javax.xml.transform 使用的 java.io 中的类
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.transform.stream 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Writer
写入字符流的抽象类。

javax.xml.validation 使用的 java.io 中的类
File
文件和目录路径名的抽象表示形式。
IOException
当发生某种 I/O 异常时，抛出此异常。

javax.xml.ws 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.ws.handler 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.ws.http 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.ws.soap 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

javax.xml.xpath 使用的 java.io 中的类
PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
PrintWriter
向文本输出流打印对象的格式化表示形式。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.ietf.jgss 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CORBA 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CORBA.DynAnyPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CORBA.ORBPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CORBA.TypeCodePackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CORBA.portable 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CORBA_2_3.portable 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CosNaming 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CosNaming.NamingContextExtPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.CosNaming.NamingContextPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.Dynamic 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.DynamicAny 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.IOP 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.IOP.CodecFactoryPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.IOP.CodecPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.PortableInterceptor 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.PortableInterceptor.ORBInitInfoPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.PortableServer 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.PortableServer.CurrentPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.PortableServer.POAManagerPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.PortableServer.POAPackage 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.SendingContext 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.omg.stub.java.rmi 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.w3c.dom 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.w3c.dom.events 使用的 java.io 中的类
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.w3c.dom.ls 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
OutputStream
此抽象类是表示输出字节流的所有类的超类。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。
Writer
写入字符流的抽象类。

org.xml.sax 使用的 java.io 中的类
InputStream
此抽象类是表示字节输入流的所有类的超类。
IOException
当发生某种 I/O 异常时，抛出此异常。
Reader
用于读取字符流的抽象类。
Serializable
类通过实现 java.io.Serializable 接口以启用其序列化功能。

org.xml.sax.ext 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。

org.xml.sax.helpers 使用的 java.io 中的类
IOException
当发生某种 I/O 异常时，抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.CharArrayReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.CharArrayReader
的使用

没有 java.io.CharArrayReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.CharArrayWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.CharArrayWriter
的使用

使用 CharArrayWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 CharArrayWriter 的使用

返回 CharArrayWriter 的 java.io 中的方法
CharArrayWriter | CharArrayWriter.append(char c) 将指定字符添加到此 writer。
CharArrayWriter | CharArrayWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
CharArrayWriter | CharArrayWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.CharConversionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.CharConversionException
的使用

没有 java.io.CharConversionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.Console 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.Console
的使用

使用 Console 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。

java.io 中 Console 的使用

返回 Console 的 java.io 中的方法
Console | Console.format(String fmt, Object... args) 使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。
Console | Console.printf(String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。

java.lang 中 Console 的使用

返回 Console 的 java.lang 中的方法
static Console System.console()
返回与当前 Java 虚拟机关联的唯一 Console 对象（如果有）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.FileFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.FileFilter
的使用

使用 FileFilter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 FileFilter 的使用

参数类型为 FileFilter 的 java.io 中的方法
 File[] File.listFiles(FileFilter filter)
返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FilterWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterWriter
的使用

没有 java.io.FilterWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.IOError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.IOError
的使用

没有 java.io.IOError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.InvalidObjectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InvalidObjectException
的使用

使用 InvalidObjectException 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.awt.font 中 InvalidObjectException 的使用

抛出 InvalidObjectException 的 java.awt.font 中的方法
protected  Object TextAttribute.readResolve()
将反序列化的实例解析为预定义常量。

java.io 中 InvalidObjectException 的使用

抛出 InvalidObjectException 的 java.io 中的方法
void | ObjectInputStream.registerValidation(ObjectInputValidation obj, int prio) 在返回图形前注册要验证的对象。
void | ObjectInputValidation.validateObject() 验证对象。

java.text 中 InvalidObjectException 的使用

抛出 InvalidObjectException 的 java.text 中的方法
protected Object | AttributedCharacterIterator.Attribute.readResolve() 解析将被反序列化为预定义常量的实例。
protected Object | NumberFormat.Field.readResolve() 将正被反序列化的实例解析为预定义的常量。
protected Object | DateFormat.Field.readResolve() 将反序列化的实例解析成预定义的常量。
protected Object | MessageFormat.Field.readResolve() 把正被反序列化的实例解析为预定义的常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.LineNumberInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.LineNumberInputStream
的使用

没有 java.io.LineNumberInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.LineNumberReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.LineNumberReader
的使用

没有 java.io.LineNumberReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.NotActiveException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.NotActiveException
的使用

使用 NotActiveException 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 NotActiveException 的使用

抛出 NotActiveException 的 java.io 中的方法
 void ObjectInputStream.registerValidation(ObjectInputValidation obj, int prio)
在返回图形前注册要验证的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.ObjectInputValidation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectInputValidation
的使用

使用 ObjectInputValidation 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectInputValidation 的使用

参数类型为 ObjectInputValidation 的 java.io 中的方法
 void ObjectInputStream.registerValidation(ObjectInputValidation obj, int prio)
在返回图形前注册要验证的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.OptionalDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.OptionalDataException
的使用

没有 java.io.OptionalDataException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PipedInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedInputStream
的使用

使用 PipedInputStream 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedInputStream 的使用

参数类型为 PipedInputStream 的 java.io 中的方法
 void PipedOutputStream.connect(PipedInputStream snk)
将此管道输出流连接到接收者。

参数类型为 PipedInputStream 的 java.io 中的构造方法
PipedOutputStream(PipedInputStream snk)
创建连接到指定管道输入流的管道输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PipedOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedOutputStream
的使用

使用 PipedOutputStream 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedOutputStream 的使用

参数类型为 PipedOutputStream 的 java.io 中的方法
 void PipedInputStream.connect(PipedOutputStream src)
使此管道输入流连接到管道输出流 src。

参数类型为 PipedOutputStream 的 java.io 中的构造方法
PipedInputStream(PipedOutputStream src)
创建 PipedInputStream，使其连接到管道输出流 src。
PipedInputStream(PipedOutputStream src, int pipeSize)
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PipedReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedReader
的使用

使用 PipedReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedReader 的使用

参数类型为 PipedReader 的 java.io 中的方法
 void PipedWriter.connect(PipedReader snk)
将此传送 writer 连接到接收方。

参数类型为 PipedReader 的 java.io 中的构造方法
PipedWriter(PipedReader snk)
创建传送 writer，使其连接到指定的传送 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PipedWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PipedWriter
的使用

使用 PipedWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 PipedWriter 的使用

参数类型为 PipedWriter 的 java.io 中的方法
 void PipedReader.connect(PipedWriter src)
使此传送 reader 连接到传送 writer src。

参数类型为 PipedWriter 的 java.io 中的构造方法
PipedReader(PipedWriter src)
创建连接到传送 writer src 的 PipedReader。
PipedReader(PipedWriter src, int pipeSize)
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PushbackReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PushbackReader
的使用

没有 java.io.PushbackReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.SequenceInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.SequenceInputStream
的使用

没有 java.io.SequenceInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.SerializablePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.SerializablePermission
的使用

使用 SerializablePermission 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 SerializablePermission 的使用

声明为 SerializablePermission 的 java.io 中的字段
static SerializablePermission | ObjectStreamConstants.SUBCLASS_IMPLEMENTATION_PERMISSION 允许重写 readObject 和 writeObject。
static SerializablePermission | ObjectStreamConstants.SUBSTITUTION_PERMISSION 允许在序列化/反序列化期间使用一个对象取代另一个对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.StreamCorruptedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StreamCorruptedException
的使用

使用 StreamCorruptedException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。

java.io 中 StreamCorruptedException 的使用

抛出 StreamCorruptedException 的 java.io 中的方法
protected  void ObjectInputStream.readStreamHeader()
提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。

java.rmi.server 中 StreamCorruptedException 的使用

抛出 StreamCorruptedException 的 java.rmi.server 中的方法
 ObjectOutput RemoteCall.getResultStream(boolean success)
已过时。 无替代版本

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.StringBufferInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StringBufferInputStream
的使用

没有 java.io.StringBufferInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.SyncFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.SyncFailedException
的使用

使用 SyncFailedException 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 SyncFailedException 的使用

抛出 SyncFailedException 的 java.io 中的方法
 void FileDescriptor.sync()
强制所有系统缓冲区与基础设备同步。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.UTFDataFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.UTFDataFormatException
的使用

没有 java.io.UTFDataFormatException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.WriteAbortedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.WriteAbortedException
的使用

没有 java.io.WriteAbortedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.InvalidClassException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InvalidClassException
的使用

没有 java.io.InvalidClassException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.NotSerializableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.NotSerializableException
的使用

没有 java.io.NotSerializableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ObjectStreamException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectStreamException
的使用

使用 ObjectStreamException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

java.awt 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.awt 中的方法
protected  Object AWTKeyStroke.readResolve()
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。

java.awt.color 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.awt.color 中的方法
protected  Object ICC_Profile.readResolve()
解析将被反序列化为用 CMM 注册的实例的实例。

java.io 中 ObjectStreamException 的使用

java.io 中 ObjectStreamException 的子类
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

java.security 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.security 中的方法
protected  Object KeyRep.readResolve()
解析 Key 对象。

java.security.cert 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 java.security.cert 中的方法
protected Object | CertPath.CertPathRep.readResolve() 返回根据类型和数据所构造的 CertPath。
protected Object | Certificate.CertificateRep.readResolve() 解析该 Certificate 对象。
protected Object | CertPath.writeReplace() 使用 CertPathRep 对象替换要被序列化的 CertPath。
protected Object | Certificate.writeReplace() 替换要被序列化的 Certificate。

javax.management.openmbean 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 javax.management.openmbean 中的方法
 Object SimpleType.readResolve()
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。

javax.print.attribute 中 ObjectStreamException 的使用

抛出 ObjectStreamException 的 javax.print.attribute 中的方法
protected  Object EnumSyntax.readResolve()
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.StreamTokenizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StreamTokenizer
的使用

没有 java.io.StreamTokenizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FileWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileWriter
的使用

没有 java.io.FileWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.DataOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.DataOutputStream
的使用

没有 java.io.DataOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.InterruptedIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InterruptedIOException
的使用

使用 InterruptedIOException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 InterruptedIOException 的使用

java.net 中 InterruptedIOException 的子类
 class SocketTimeoutException
如果在读取或接受套接字时发生超时，则抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PushbackInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PushbackInputStream
的使用

没有 java.io.PushbackInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.UnsupportedEncodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.UnsupportedEncodingException
的使用

使用 UnsupportedEncodingException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

java.io 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.io 中的方法
 String ByteArrayOutputStream.toString(String charsetName)
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。

抛出 UnsupportedEncodingException 的 java.io 中的构造方法
InputStreamReader(InputStream in, String charsetName)
创建使用指定字符集的 InputStreamReader。
OutputStreamWriter(OutputStream out, String charsetName)
创建使用指定字符集的 OutputStreamWriter。
PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintStream(OutputStream out, boolean autoFlush, String encoding)
创建新的打印流。
PrintStream(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
PrintWriter(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。

java.lang 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.lang 中的方法
 byte[] String.getBytes(String charsetName)
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。

抛出 UnsupportedEncodingException 的 java.lang 中的构造方法
String(byte[] bytes, int offset, int length, String charsetName)
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[] bytes, String charsetName)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。

java.net 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.net 中的方法
static String | URLDecoder.decode(String s, String enc) 使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。
static String | URLEncoder.encode(String s, String enc) 使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。

java.util 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.util 中的构造方法
Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(OutputStream os, String csn)
构造一个带指定输出流和字符集的新 formatter。
Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。
Formatter(String fileName, String csn)
构造一个带指定文件名和字符集的新 formatter。
Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。

java.util.logging 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 java.util.logging 中的方法
void | StreamHandler.setEncoding(String encoding) 设置（或更改）该 Handler 所用的字符编码。
void | Handler.setEncoding(String encoding) 设置该 Handler 所用的字符编码。

javax.xml.bind.helpers 中 UnsupportedEncodingException 的使用

抛出 UnsupportedEncodingException 的 javax.xml.bind.helpers 中的方法
protected  String AbstractMarshallerImpl.getJavaEncoding(String encoding)
从 IANA 名称获取相应的 Java 编码名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.StringWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StringWriter
的使用

使用 StringWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 StringWriter 的使用

返回 StringWriter 的 java.io 中的方法
StringWriter | StringWriter.append(char c) 将指定字符添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.EOFException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.EOFException
的使用

没有 java.io.EOFException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.Externalizable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Externalizable
的使用

使用 Externalizable 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。

java.awt.datatransfer 中 Externalizable 的使用

实现 Externalizable 的 java.awt.datatransfer 中的类
 class DataFlavor
DataFlavor 提供有关数据的元信息。

java.rmi.server 中 Externalizable 的使用

java.rmi.server 中 Externalizable 的子接口
interface | RemoteRef RemoteRef 表示远程对象的句柄。
interface | ServerRef ServerRef 表示远程对象实现的服务器端句柄。

javax.activation 中 Externalizable 的使用

实现 Externalizable 的 javax.activation 中的类
class | ActivationDataFlavor ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。
class | MimeType RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。

javax.management.loading 中 Externalizable 的使用

实现 Externalizable 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FilterReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterReader
的使用

使用 FilterReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 FilterReader 的使用

java.io 中 FilterReader 的子类
 class PushbackReader
允许将字符推回到流的字符流 reader。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.StringReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.StringReader
的使用

没有 java.io.StringReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.RandomAccessFile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.RandomAccessFile
的使用

使用 RandomAccessFile 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 RandomAccessFile 的使用

参数类型为 RandomAccessFile 的 javax.imageio.stream 中的构造方法
FileImageInputStream(RandomAccessFile raf)
构造一个将从给定 RandomAccessFile 进行读取的 FileImageInputStream。
FileImageOutputStream(RandomAccessFile raf)
构造一个向给定 FileImageOutputStream 进行写入的 RandomAccessFile。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ByteArrayOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ByteArrayOutputStream
的使用

没有 java.io.ByteArrayOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ByteArrayInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ByteArrayInputStream
的使用

没有 java.io.ByteArrayInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ObjectInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectInputStream
的使用

使用 ObjectInputStream 的软件包
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.beans.beancontext 中 ObjectInputStream 的使用

参数类型为 ObjectInputStream 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
protected  void BeanContextSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
protected  void BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll)
readObject 使用此方法来反序列化一个 collection。
 void BeanContextSupport.readChildren(ObjectInputStream ois)
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。

javax.management 中 ObjectInputStream 的使用

返回 ObjectInputStream 的 javax.management 中的方法
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。

javax.rmi.CORBA 中 ObjectInputStream 的使用

参数类型为 ObjectInputStream 的 javax.rmi.CORBA 中的方法
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。

javax.swing.text 中 ObjectInputStream 的使用

参数类型为 ObjectInputStream 的 javax.swing.text 中的方法
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ObjectInputStream.GetField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectInputStream.GetField
的使用

使用 ObjectInputStream.GetField 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectInputStream.GetField 的使用

返回 ObjectInputStream.GetField 的 java.io 中的方法
 ObjectInputStream.GetField ObjectInputStream.readFields()
按名称从流中读取持久字段并使其可用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.ObjectInput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectInput
的使用

使用 ObjectInput 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。

java.awt.datatransfer 中 ObjectInput 的使用

参数类型为 ObjectInput 的 java.awt.datatransfer 中的方法
 void DataFlavor.readExternal(ObjectInput is)
根据 Serialized 状态还原此 DataFlavor。

java.io 中 ObjectInput 的使用

实现 ObjectInput 的 java.io 中的类
 class ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。

参数类型为 ObjectInput 的 java.io 中的方法
 void Externalizable.readExternal(ObjectInput in)
对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。

java.rmi.server 中 ObjectInput 的使用

返回 ObjectInput 的 java.rmi.server 中的方法
 ObjectInput RemoteCall.getInputStream()
已过时。 无替代版本

参数类型为 ObjectInput 的 java.rmi.server 中的方法
static ObjID ObjID.read(ObjectInput in)
通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。

javax.activation 中 ObjectInput 的使用

参数类型为 ObjectInput 的 javax.activation 中的方法
 void MimeType.readExternal(ObjectInput in)
对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。

javax.management.loading 中 ObjectInput 的使用

参数类型为 ObjectInput 的 javax.management.loading 中的方法
 void MLet.readExternal(ObjectInput in)
从给定的 ObjectInput 恢复此 MLet 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.Reader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.Reader
的使用

使用 Reader 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.awt.datatransfer 中 Reader 的使用

返回 Reader 的 java.awt.datatransfer 中的方法
 Reader DataFlavor.getReaderForText(Transferable transferable)
获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。

java.io 中 Reader 的使用

java.io 中 Reader 的子类
class | BufferedReader 从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
class | CharArrayReader 此类实现一个可用作字符输入流的字符缓冲区。
class | FileReader 用来读取字符文件的便捷类。
class | FilterReader 用于读取已过滤的字符流的抽象类。
class | InputStreamReader InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
class | LineNumberReader 跟踪行号的缓冲字符输入流。
class | PipedReader 传送的字符输入流。
class | PushbackReader 允许将字符推回到流的字符流 reader。
class | StringReader 其源为一个字符串的字符流。

声明为 Reader 的 java.io 中的字段
protected  Reader FilterReader.in
底层字符输入流。

返回 Reader 的 java.io 中的方法
 Reader Console.reader()
获取与此控制台关联的唯一 Reader 对象。

参数类型为 Reader 的 java.io 中的构造方法
BufferedReader(Reader in)
创建一个使用默认大小输入缓冲区的缓冲字符输入流。
BufferedReader(Reader in, int sz)
创建一个使用指定大小输入缓冲区的缓冲字符输入流。
FilterReader(Reader in)
创建一个新的 filtered reader。
LineNumberReader(Reader in)
使用默认输入缓冲区的大小创建新的行编号 reader。
LineNumberReader(Reader in, int sz)
创建新的行编号 reader，将字符读入给定大小的缓冲区。
PushbackReader(Reader in)
创建具有单字符推回缓冲区的新推回 reader。
PushbackReader(Reader in, int size)
创建具有给定大小推回缓冲区的新推回 reader。
StreamTokenizer(Reader r)
创建解析给定字符流的标记生成器。

java.nio.channels 中 Reader 的使用

返回 Reader 的 java.nio.channels 中的方法
static Reader | Channels.newReader(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap) 构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。
static Reader | Channels.newReader(ReadableByteChannel ch, String csName) 构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。

java.sql 中 Reader 的使用

返回 Reader 的 java.sql 中的方法
Reader | Clob.getCharacterStream() 以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。
Reader | SQLXML.getCharacterStream() 以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。
Reader | CallableStatement.getCharacterStream(int parameterIndex) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getCharacterStream(int columnIndex) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | Clob.getCharacterStream(long pos, long length) 返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
Reader | CallableStatement.getCharacterStream(String parameterName) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getCharacterStream(String columnLabel) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | CallableStatement.getNCharacterStream(int parameterIndex) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getNCharacterStream(int columnIndex) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | CallableStatement.getNCharacterStream(String parameterName) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | ResultSet.getNCharacterStream(String columnLabel) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | SQLInput.readCharacterStream() 读取流中的下一个属性并将其作为 Unicode 字符流返回。

参数类型为 Reader 的 java.sql 中的方法
void | PreparedStatement.setCharacterStream(int parameterIndex, Reader reader) 将指定参数设置为给定 Reader 对象。
void | PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, int length) 将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, long length) 将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | CallableStatement.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | CallableStatement.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。
void | CallableStatement.setCharacterStream(String parameterName, Reader reader, long length) 将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | PreparedStatement.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | CallableStatement.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | CallableStatement.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNCharacterStream(int parameterIndex, Reader value) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | PreparedStatement.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | CallableStatement.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | ResultSet.updateCharacterStream(int columnIndex, Reader x) 用字符流值更新指定的列。
void | ResultSet.updateCharacterStream(int columnIndex, Reader x, int length) 用字符流值更新指定列，该列将具有指定字节数。
void | ResultSet.updateCharacterStream(int columnIndex, Reader x, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateCharacterStream(String columnLabel, Reader reader) 用字符流值更新指定列。
void | ResultSet.updateCharacterStream(String columnLabel, Reader reader, int length) 用字符流值更新指定列，该列具有指定的字节数。
void | ResultSet.updateCharacterStream(String columnLabel, Reader reader, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateClob(int columnIndex, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateClob(int columnIndex, Reader reader, long length) 使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
void | ResultSet.updateClob(String columnLabel, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateClob(String columnLabel, Reader reader, long length) 使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
void | ResultSet.updateNCharacterStream(int columnIndex, Reader x) 用字符流值更新指定的列。
void | ResultSet.updateNCharacterStream(int columnIndex, Reader x, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateNCharacterStream(String columnLabel, Reader reader) 用字符流值更新指定的列。
void | ResultSet.updateNCharacterStream(String columnLabel, Reader reader, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateNClob(int columnIndex, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateNClob(int columnIndex, Reader reader, long length) 使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
void | ResultSet.updateNClob(String columnLabel, Reader reader) 使用给定的 Reader 对象更新指定列。
void | ResultSet.updateNClob(String columnLabel, Reader reader, long length) 使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
void | SQLOutput.writeCharacterStream(Reader x) 将下一个属性作为 Unicode 字符的流写入流中。

java.util 中 Reader 的使用

参数类型为 Reader 的 java.util 中的方法
 void Properties.load(Reader reader)
按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。

参数类型为 Reader 的 java.util 中的构造方法
PropertyResourceBundle(Reader reader)
根据 Reader 创建属性资源包。

javax.print 中 Reader 的使用

返回 Reader 的 javax.print 中的方法
Reader | Doc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
Reader | SimpleDoc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。

javax.script 中 Reader 的使用

声明为 Reader 的 javax.script 中的字段
protected  Reader SimpleScriptContext.reader
此字段是用于脚本输入的 reader。

返回 Reader 的 javax.script 中的方法
Reader | ScriptContext.getReader() 返回脚本用来读取输入的 Reader。
Reader | SimpleScriptContext.getReader() 返回脚本用来读取输入的 Reader。

参数类型为 Reader 的 javax.script 中的方法
 CompiledScript Compilable.compile(Reader script)
编译脚本（从 Reader 读取的源），以便以后执行。
 Object AbstractScriptEngine.eval(Reader reader)
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。
 Object ScriptEngine.eval(Reader reader)
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。
 Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
 Object ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
 Object ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
 void ScriptContext.setReader(Reader reader)
设置脚本的 Reader，以读取输入。
 void SimpleScriptContext.setReader(Reader reader)
设置脚本的 Reader，以读取输入。

javax.sql 中 Reader 的使用

参数类型为 Reader 的 javax.sql 中的方法
void | RowSet.setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(int parameterIndex, Reader reader, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。
void | RowSet.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。
void | RowSet.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。

javax.sql.rowset 中 Reader 的使用

声明为 Reader 的 javax.sql.rowset 中的字段
protected  Reader BaseRowSet.charStream
将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。

参数类型为 Reader 的 javax.sql.rowset 中的方法
void | WebRowSet.readXml(Reader reader) 从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。
void | BaseRowSet.setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。
void | BaseRowSet.setCharacterStream(int parameterIndex, Reader reader, int length) 将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。
void | BaseRowSet.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | BaseRowSet.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。
void | BaseRowSet.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | BaseRowSet.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。

javax.sql.rowset.serial 中 Reader 的使用

返回 Reader 的 javax.sql.rowset.serial 中的方法
Reader | SerialClob.getCharacterStream() 以 Unicode 字符流的形式返回此 SerialClob 对象的数据。
Reader | SerialClob.getCharacterStream(long pos, long length)
Reader | SQLInputImpl.readCharacterStream() 以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 Reader 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeCharacterStream(Reader x)
将 Unicode 字符流写入此 SQLOutputImpl 对象。

javax.sql.rowset.spi 中 Reader 的使用

参数类型为 Reader 的 javax.sql.rowset.spi 中的方法
 void XmlReader.readXML(WebRowSet caller, Reader reader)
从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。

javax.swing.text 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text 中的方法
void | DefaultEditorKit.read(Reader in, Document doc, int pos) 插入取自给定流的内容，它将被视为纯文本。
abstract void | EditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | JTextComponent.read(Reader in, Object desc) 根据流进行初始化。

javax.swing.text.html 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text.html 中的方法
void | StyleSheet.loadRules(Reader in, URL ref) 加载 CSS1 语法中指定的规则集合。
abstract void | HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet) 解析给定的流并通过解析的结果驱动给定的回调。
void | HTMLEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容。

javax.swing.text.html.parser 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text.html.parser 中的方法
void | Parser.parse(Reader in) 在给定 DTD 的情况下，解析 HTML 流。
void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)

javax.swing.text.rtf 中 Reader 的使用

参数类型为 Reader 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.read(Reader in, Document doc, int pos)
插入来自给定流的内容，该内容将被视为纯文本。

javax.tools 中 Reader 的使用

返回 Reader 的 javax.tools 中的方法
 Reader FileObject.openReader(boolean ignoreEncodingErrors)
获取此对象的 reader。
 Reader ForwardingFileObject.openReader(boolean ignoreEncodingErrors)
 Reader SimpleJavaFileObject.openReader(boolean ignoreEncodingErrors)
在 Reader 中包装 SimpleJavaFileObject.getCharContent(boolean) 的结果。

javax.xml.bind 中 Reader 的使用

参数类型为 Reader 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 Reader 的使用

参数类型为 Reader 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(Reader reader)

javax.xml.stream 中 Reader 的使用

参数类型为 Reader 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, Reader reader) 根据 reader 创建一个新 XMLEventReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(Reader reader) 根据 reader 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, Reader reader) 根据 java.io.InputStream 创建一个新 XMLStreamReader。

javax.xml.transform.stream 中 Reader 的使用

返回 Reader 的 javax.xml.transform.stream 中的方法
 Reader StreamSource.getReader()
获取通过 setReader 设置的字符流。

参数类型为 Reader 的 javax.xml.transform.stream 中的方法
 void StreamSource.setReader(Reader reader)
调用要作为字符 reader 的输入。

参数类型为 Reader 的 javax.xml.transform.stream 中的构造方法
StreamSource(Reader reader)
从字符 reader 构造 StreamSource。
StreamSource(Reader reader, String systemId)
从字符 reader 构造 StreamSource。

org.w3c.dom.ls 中 Reader 的使用

返回 Reader 的 org.w3c.dom.ls 中的方法
 Reader LSInput.getCharacterStream()
依赖于语言和绑定类型的属性，表示 16 位单元流。

参数类型为 Reader 的 org.w3c.dom.ls 中的方法
 void LSInput.setCharacterStream(Reader characterStream)
依赖于语言和绑定类型的属性，表示 16 位单元的流。

org.xml.sax 中 Reader 的使用

返回 Reader 的 org.xml.sax 中的方法
 Reader InputSource.getCharacterStream()
获取此输入源的字符流。

参数类型为 Reader 的 org.xml.sax 中的方法
 void InputSource.setCharacterStream(Reader characterStream)
设置此输入源的字符流。

参数类型为 Reader 的 org.xml.sax 中的构造方法
InputSource(Reader characterStream)
使用字符流创建新的输入源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PrintWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PrintWriter
的使用

使用 PrintWriter 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt 中 PrintWriter 的使用

参数类型为 PrintWriter 的 java.awt 中的方法
void | Component.list(PrintWriter out) 将列表打印到指定的打印编写器。
void | Container.list(PrintWriter out, int indent) 将一个列表打印到指定打印编写器，从指定缩排位置开始。
void | Component.list(PrintWriter out, int indent) 将列表从指定的缩排开始打印到指定的打印编写器。

java.io 中 PrintWriter 的使用

返回 PrintWriter 的 java.io 中的方法
PrintWriter | PrintWriter.append(char c) 将指定字符添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
PrintWriter | PrintWriter.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
PrintWriter | PrintWriter.format(String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
PrintWriter | PrintWriter.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
PrintWriter | PrintWriter.printf(String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
PrintWriter | Console.writer() 获取与此控制台关联的唯一 PrintWriter 对象。

java.lang 中 PrintWriter 的使用

参数类型为 PrintWriter 的 java.lang 中的方法
 void Throwable.printStackTrace(PrintWriter s)
将此 throwable 及其追踪输出到指定的 PrintWriter。

java.sql 中 PrintWriter 的使用

返回 PrintWriter 的 java.sql 中的方法
static PrintWriter DriverManager.getLogWriter()
获取日志 writer。

参数类型为 PrintWriter 的 java.sql 中的方法
static void DriverManager.setLogWriter(PrintWriter out)
设置由 DriverManager 和所有驱动程序使用的日志/追踪 PrintWriter 对象。

java.util 中 PrintWriter 的使用

参数类型为 PrintWriter 的 java.util 中的方法
 void Properties.list(PrintWriter out)
将属性列表输出到指定的输出流。

javax.sql 中 PrintWriter 的使用

返回 PrintWriter 的 javax.sql 中的方法
 PrintWriter CommonDataSource.getLogWriter()
获取此 DataSource 对象的日志 writer。

参数类型为 PrintWriter 的 javax.sql 中的方法
 void CommonDataSource.setLogWriter(PrintWriter out)
将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。

javax.xml.bind 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.bind 中的方法
 void JAXBException.printStackTrace(PrintWriter s)
打印此 JAXBException 及其对 PrintWriter 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。

javax.xml.crypto 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.crypto 中的方法
void | KeySelectorException.printStackTrace(PrintWriter s) 将此 KeySelectorException、它的追踪和 cause 追踪打印到指定打印编写器。
void | MarshalException.printStackTrace(PrintWriter s) 将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印编写器。
void | NoSuchMechanismException.printStackTrace(PrintWriter s) 将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定打印编写器。
void | URIReferenceException.printStackTrace(PrintWriter s) 将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印编写器。

javax.xml.crypto.dsig 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.crypto.dsig 中的方法
void | TransformException.printStackTrace(PrintWriter s) 将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印编写器。
void | XMLSignatureException.printStackTrace(PrintWriter s) 将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。

javax.xml.transform 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.transform 中的方法
 void TransformerException.printStackTrace(PrintWriter s)
打印从中产生错误的方法跟踪。

javax.xml.xpath 中 PrintWriter 的使用

参数类型为 PrintWriter 的 javax.xml.xpath 中的方法
 void XPathException.printStackTrace(PrintWriter s)
将堆栈跟踪打印到指定的 PrintWriter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ObjectOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectOutputStream
的使用

使用 ObjectOutputStream 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 java.awt 中的方法
protected static void | AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)
protected void | AWTEventMulticaster.saveInternal(ObjectOutputStream s, String k)

java.beans.beancontext 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在序列化子级之前，从 BeanContextSupport writeObject 中调用。
protected  void BeanContextSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。
protected  void BeanContextSupport.serialize(ObjectOutputStream oos, Collection coll)
writeObject 使用此方法来序列化一个 Collection。
 void BeanContextSupport.writeChildren(ObjectOutputStream oos)
用于序列化此 BeanContext 的所有子级。

javax.rmi.CORBA 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 javax.rmi.CORBA 中的方法
 void StubDelegate.writeObject(Stub self, ObjectOutputStream s)
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

javax.swing.text 中 ObjectOutputStream 的使用

参数类型为 ObjectOutputStream 的 javax.swing.text 中的方法
void | StyleContext.writeAttributes(ObjectOutputStream out, AttributeSet a) 写出属性的特定于上下文的处理。
static void | StyleContext.writeAttributeSet(ObjectOutputStream out, AttributeSet a) 将属性集写入到给定的对象流以便序列化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ObjectOutputStream.PutField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectOutputStream.PutField
的使用

使用 ObjectOutputStream.PutField 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectOutputStream.PutField 的使用

返回 ObjectOutputStream.PutField 的 java.io 中的方法
 ObjectOutputStream.PutField ObjectOutputStream.putFields()
获取用于缓冲写入流中的持久存储字段的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.ObjectStreamConstants 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectStreamConstants
的使用

使用 ObjectStreamConstants 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectStreamConstants 的使用

实现 ObjectStreamConstants 的 java.io 中的类
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.ObjectOutput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.ObjectOutput
的使用

使用 ObjectOutput 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。

java.awt.datatransfer 中 ObjectOutput 的使用

参数类型为 ObjectOutput 的 java.awt.datatransfer 中的方法
 void DataFlavor.writeExternal(ObjectOutput os)
序列化此 DataFlavor。

java.io 中 ObjectOutput 的使用

实现 ObjectOutput 的 java.io 中的类
 class ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。

参数类型为 ObjectOutput 的 java.io 中的方法
abstract  void ObjectOutputStream.PutField.write(ObjectOutput out)
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。
 void Externalizable.writeExternal(ObjectOutput out)
该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。

java.rmi.server 中 ObjectOutput 的使用

返回 ObjectOutput 的 java.rmi.server 中的方法
ObjectOutput | RemoteCall.getOutputStream() 已过时。 无替代版本
ObjectOutput | RemoteCall.getResultStream(boolean success) 已过时。 无替代版本

参数类型为 ObjectOutput 的 java.rmi.server 中的方法
String | RemoteRef.getRefClass(ObjectOutput out) 返回要在流 'out' 上序列化的 ref 类型的类名称。
void | ObjID.write(ObjectOutput out) 将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。

javax.activation 中 ObjectOutput 的使用

参数类型为 ObjectOutput 的 javax.activation 中的方法
 void MimeType.writeExternal(ObjectOutput out)
对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。

javax.management.loading 中 ObjectOutput 的使用

参数类型为 ObjectOutput 的 javax.management.loading 中的方法
 void MLet.writeExternal(ObjectOutput out)
将此 MLet 的内容保存到给定的 ObjectOutput。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.DataOutput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.DataOutput
的使用

使用 DataOutput 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.io 中 DataOutput 的使用

java.io 中 DataOutput 的子接口
 interface ObjectOutput
ObjectOutput 扩展 DataOutput 接口以包含对象的写入操作。

实现 DataOutput 的 java.io 中的类
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | RandomAccessFile 此类的实例支持对随机访问文件的读取和写入。

java.rmi.server 中 DataOutput 的使用

参数类型为 DataOutput 的 java.rmi.server 中的方法
 void UID.write(DataOutput out)
将此 UID 的二进制表示形式编组为一个 DataOutput 实例。

javax.imageio.stream 中 DataOutput 的使用

javax.imageio.stream 中 DataOutput 的子接口
 interface ImageOutputStream
供 ImageWriter 使用的可查找输出流接口。

实现 DataOutput 的 javax.imageio.stream 中的类
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.DataInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.DataInputStream
的使用

使用 DataInputStream 的软件包
javax.swing.text.html.parser 提供默认的 HTML 解析器以及支持类。

javax.swing.text.html.parser 中 DataInputStream 的使用

参数类型为 DataInputStream 的 javax.swing.text.html.parser 中的方法
 void DTD.read(DataInputStream in)
根据存档格式重新创建一个 DTD。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.DataInput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.DataInput
的使用

使用 DataInput 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.io 中 DataInput 的使用

java.io 中 DataInput 的子接口
 interface ObjectInput
ObjectInput 扩展 DataInput 接口以包含对象的读操作。

实现 DataInput 的 java.io 中的类
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | RandomAccessFile 此类的实例支持对随机访问文件的读取和写入。

参数类型为 DataInput 的 java.io 中的方法
static String DataInputStream.readUTF(DataInput in)
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。

java.rmi.server 中 DataInput 的使用

参数类型为 DataInput 的 java.rmi.server 中的方法
static UID UID.read(DataInput in)
通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。

javax.imageio.stream 中 DataInput 的使用

javax.imageio.stream 中 DataInput 的子接口
interface | ImageInputStream 供 ImageReader 使用的可查找输入流接口。
interface | ImageOutputStream 供 ImageWriter 使用的可查找输出流接口。

实现 DataInput 的 javax.imageio.stream 中的类
class | FileCacheImageInputStream 从常规 InputStream 获取其输入的 ImageInputStream 的实现。
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageInputStream 从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageInputStreamImpl 实现 ImageInputStream 接口的抽象类。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageInputStream 从常规 InputStream 获取输入的 ImageInputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.FilenameFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.FilenameFilter
的使用

使用 FilenameFilter 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。

java.awt 中 FilenameFilter 的使用

返回 FilenameFilter 的 java.awt 中的方法
 FilenameFilter FileDialog.getFilenameFilter()
确定此文件对话框的文件名过滤器。

参数类型为 FilenameFilter 的 java.awt 中的方法
 void FileDialog.setFilenameFilter(FilenameFilter filter)
将此文件对话框窗口的文件名过滤器设置为指定的过滤器。

java.io 中 FilenameFilter 的使用

参数类型为 FilenameFilter 的 java.io 中的方法
String[] | File.list(FilenameFilter filter) 返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。
File[] | File.listFiles(FilenameFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FileNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileNotFoundException
的使用

使用 FileNotFoundException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.io 中 FileNotFoundException 的使用

抛出 FileNotFoundException 的 java.io 中的构造方法
FileInputStream(File file)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。
FileInputStream(String name)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。
FileOutputStream(File file)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(File file, boolean append)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(String name)
创建一个向具有指定名称的文件中写入数据的输出文件流。
FileOutputStream(String name, boolean append)
创建一个向具有指定 name 的文件中写入数据的输出文件流。
FileReader(File file)
在给定从中读取数据的 File 的情况下创建一个新 FileReader。
FileReader(String fileName)
在给定从中读取数据的文件名的情况下创建一个新 FileReader。
PrintStream(File file)
创建具有指定文件且不带自动行刷新的新打印流。
PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintStream(String fileName)
创建具有指定文件名称且不带自动行刷新的新打印流。
PrintStream(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintWriter(File file)
使用指定文件创建不具有自动行刷新的新 PrintWriter。
PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
PrintWriter(String fileName)
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。
PrintWriter(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。
RandomAccessFile(File file, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。
RandomAccessFile(String name, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。

java.util 中 FileNotFoundException 的使用

抛出 FileNotFoundException 的 java.util 中的构造方法
Formatter(File file)
构造一个带指定文件的新 formatter。
Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(String fileName)
构造一个带指定文件名的新 formatter。
Formatter(String fileName, String csn)
构造一个带指定文件名和字符集的新 formatter。
Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。
Scanner(File source)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(File source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。

javax.imageio.stream 中 FileNotFoundException 的使用

抛出 FileNotFoundException 的 javax.imageio.stream 中的构造方法
FileImageInputStream(File f)
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageOutputStream(File f)
构造一个将向给定 File 进行写入的 FileImageOutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.IOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.IOException
的使用

使用 IOException 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 IOException 的使用

抛出 IOException 的 java.applet 中的方法
 void AppletContext.setStream(String key, InputStream stream)
在此 applet 上下文中用指定的键关联指定的流。

java.awt 中 IOException 的使用

抛出 IOException 的 java.awt 中的方法
void | Desktop.browse(URI uri) 启动默认浏览器来显示 URI。
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
static Font | Font.createFont(int fontFormat, InputStream fontStream) 返回一个使用指定字体类型和输入数据的新 Font。
void | Desktop.edit(File file) 启动关联编辑器应用程序并打开用于编辑的文件。
void | Desktop.mail() 启动用户默认邮件客户端的邮件组合窗口。
void | Desktop.mail(URI mailtoURI) 启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。
void | Desktop.open(File file) 启动关联应用程序来打开文件。
void | Desktop.print(File file) 使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。
protected static void | AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)
protected void | AWTEventMulticaster.saveInternal(ObjectOutputStream s, String k)
void | SplashScreen.setImageURL(URL imageURL) 更改闪现屏幕图像。

java.awt.color 中 IOException 的使用

抛出 IOException 的 java.awt.color 中的方法
static ICC_Profile | ICC_Profile.getInstance(InputStream s) 构造一个与 InputStream 中的数据相对应的 ICC_Profile。
static ICC_Profile | ICC_Profile.getInstance(String fileName) 构造一个与文件中的数据相对应的 ICC_Profile。
void | ICC_Profile.write(OutputStream s) 将 ICC_Profile 写入一个 OutputStream。
void | ICC_Profile.write(String fileName) 将此 ICC_Profile 写入一个文件。

java.awt.datatransfer 中 IOException 的使用

抛出 IOException 的 java.awt.datatransfer 中的方法
Object | Clipboard.getData(DataFlavor flavor) 返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。
Reader | DataFlavor.getReaderForText(Transferable transferable) 获取文本 flavor 的 Reader，如果需要，则为期望的 charset（编码的）解码。
Object | StringSelection.getTransferData(DataFlavor flavor) 如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。
Object | Transferable.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示将要被传输的数据。
void | DataFlavor.readExternal(ObjectInput is) 根据 Serialized 状态还原此 DataFlavor。
void | DataFlavor.writeExternal(ObjectOutput os) 序列化此 DataFlavor。

java.awt.dnd 中 IOException 的使用

抛出 IOException 的 java.awt.dnd 中的方法
 Object DropTargetContext.TransferableProxy.getTransferData(DataFlavor df)
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。

java.awt.print 中 IOException 的使用

返回 IOException 的 java.awt.print 中的方法
 IOException PrinterIOException.getIOException()
返回终止打印作业的 IOException。

参数类型为 IOException 的 java.awt.print 中的构造方法
PrinterIOException(IOException exception)
构造具有指定 IOException 字符串表示形式的新 PrinterIOException。

java.beans 中 IOException 的使用

抛出 IOException 的 java.beans 中的方法
static Object | Beans.instantiate(ClassLoader cls, String beanName) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

java.beans.beancontext 中 IOException 的使用

抛出 IOException 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
protected  void BeanContextSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
protected  void BeanContextServicesSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在序列化子级之前，从 BeanContextSupport writeObject 中调用。
protected  void BeanContextSupport.bcsPreSerializationHook(ObjectOutputStream oos)
在调用 defaultWriteObject() 之后，但在序列化当前可序列化子级之前，由 writeObject 调用。
protected  void BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll)
readObject 使用此方法来反序列化一个 collection。
 Object BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。
 Object BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。
 void BeanContextSupport.readChildren(ObjectInputStream ois)
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。
protected  void BeanContextSupport.serialize(ObjectOutputStream oos, Collection coll)
writeObject 使用此方法来序列化一个 Collection。
 void BeanContextSupport.writeChildren(ObjectOutputStream oos)
用于序列化此 BeanContext 的所有子级。

java.io 中 IOException 的使用

java.io 中 IOException 的子类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

抛出 IOException 的 java.io 中的方法
protected  void ObjectOutputStream.annotateClass(Class<?> cl)
子类可以实现此方法，从而允许在流中存储类数据。
protected  void ObjectOutputStream.annotateProxyClass(Class<?> cl)
子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。
 Writer Writer.append(char c)
将指定字符添加到此 writer。
 Writer Writer.append(CharSequence csq)
将指定字符序列添加到此 writer。
 Writer Writer.append(CharSequence csq, int start, int end)
将指定字符序列的子序列添加到此 writer.Appendable。
 int LineNumberInputStream.available()
已过时。 无阻塞情况下返回可以从此输入流中读取的字节数。
 int PipedInputStream.available()
返回可以不受阻塞地从此输入流中读取的字节数。
 int SequenceInputStream.available()
返回不受阻塞地从当前底层输入流读取（或跳过）的字节数的估计值，方法是通过下一次调用当前底层输入流的方法。
 int PushbackInputStream.available()
返回可以不受下一次调用此输入流的方法阻塞地从此输入流读取（或跳过）的估计字节数。
 int ObjectInputStream.available()
返回可以不受阻塞地读取的字节数。
 int ObjectInput.available()
返回可以无阻塞地读取的字节数。
 int BufferedInputStream.available()
返回可以从此输入流读取（或跳过）、且不受此输入流接下来的方法调用阻塞的估计字节数。
 int FilterInputStream.available()
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
 int FileInputStream.available()
返回下一次对此输入流调用的方法可以不受阻塞地从此输入流读取（或跳过）的估计剩余字节数。
 int InputStream.available()
返回此输入流下一个方法调用可以不受阻塞地从此输入流读取（或跳过）的估计字节数。
 void FilterWriter.close()
 void PipedInputStream.close()
关闭此管道输入流并释放与该流相关的所有系统资源。
 void PipedOutputStream.close()
关闭此管道输出流并释放与此流有关的所有系统资源。
 void PipedReader.close()
关闭此传送流并释放与该流相关的所有系统资源。
 void PipedWriter.close()
关闭此管道输出流并释放与此流相关的所有系统资源。
 void PushbackReader.close()
关闭该流并释放与之关联的所有系统资源。
 void SequenceInputStream.close()
关闭此输入流并释放与此流关联的所有系统资源。
 void PushbackInputStream.close()
关闭此输入流并释放与该流关联的所有系统资源。
 void StringWriter.close()
关闭 StringWriter 无效。
 void FilterReader.close()
 void RandomAccessFile.close()
关闭此随机访问文件流并释放与该流关联的所有系统资源。
 void ByteArrayOutputStream.close()
关闭 ByteArrayOutputStream 无效。
 void ByteArrayInputStream.close()
关闭 ByteArrayInputStream 无效。
 void ObjectInputStream.close()
关闭输入流。
 void ObjectInput.close()
关闭输入流。
 void ObjectOutputStream.close()
关闭流。
 void ObjectOutput.close()
关闭该流。
 void InputStreamReader.close()
 void BufferedReader.close()
abstract  void Reader.close()
关闭该流并释放与之关联的所有资源。
 void BufferedWriter.close()
 void OutputStreamWriter.close()
abstract  void Writer.close()
关闭此流，但要先刷新它。
 void FilterOutputStream.close()
关闭此输出流并释放与此流有关的所有系统资源。
 void BufferedInputStream.close()
关闭此输入流并释放与该流关联的所有系统资源。
 void FilterInputStream.close()
关闭此输入流并释放与此流关联的所有系统资源。
 void FileOutputStream.close()
关闭此文件输出流并释放与此流有关的所有系统资源。
 void OutputStream.close()
关闭此输出流并释放与此流有关的所有系统资源。
 void FileInputStream.close()
关闭此文件输入流并释放与此流有关的所有系统资源。
 void InputStream.close()
关闭此输入流并释放与该流关联的所有系统资源。
 void Closeable.close()
关闭此流并释放与此流关联的所有系统资源。
 void PipedOutputStream.connect(PipedInputStream snk)
将此管道输出流连接到接收者。
 void PipedInputStream.connect(PipedOutputStream src)
使此管道输入流连接到管道输出流 src。
 void PipedWriter.connect(PipedReader snk)
将此传送 writer 连接到接收方。
 void PipedReader.connect(PipedWriter src)
使此传送 reader 连接到传送 writer src。
 boolean File.createNewFile()
当且仅当不存在具有此抽象路径名指定名称的文件时，不可分地创建一个新的空文件。
static File File.createTempFile(String prefix, String suffix)
在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。
static File File.createTempFile(String prefix, String suffix, File directory)
在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
abstract  boolean ObjectInputStream.GetField.defaulted(String name)
如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。
 void ObjectInputStream.defaultReadObject()
从此流读取当前类的非静态和非瞬态字段。
 void ObjectOutputStream.defaultWriteObject()
将当前类的非静态和非瞬态字段写入此流。
protected  void ObjectOutputStream.drain()
排空 ObjectOutputStream 中的所有已缓冲数据。
protected  void FileOutputStream.finalize()
清理到文件的连接，并确保在不再引用此文件输出流时调用此流的 close 方法。
protected  void FileInputStream.finalize()
确保在不再引用文件输入流时调用其 close 方法。
 void FilterWriter.flush()
刷新该流的缓冲。
 void PipedOutputStream.flush()
刷新此输出流并强制写出所有缓冲的输出字节。
 void PipedWriter.flush()
刷新此输出流并强制写出所有缓冲的输出字符。
 void DataOutputStream.flush()
清空此数据输出流。
 void ObjectOutputStream.flush()
刷新该流的缓冲。
 void ObjectOutput.flush()
刷新该流的缓冲。
 void BufferedWriter.flush()
刷新该流的缓冲。
 void OutputStreamWriter.flush()
刷新该流的缓冲。
abstract  void Writer.flush()
刷新该流的缓冲。
 void BufferedOutputStream.flush()
刷新此缓冲的输出流。
 void FilterOutputStream.flush()
刷新此输出流，并强制将所有已缓冲的输出字节写入该流中。
 void OutputStream.flush()
刷新此输出流并强制写出所有缓冲的输出字节。
 void Flushable.flush()
通过将所有已缓冲输出写入底层流来刷新此流。
abstract  boolean ObjectInputStream.GetField.get(String name, boolean val)
从持久字段获取指定的 boolean 字段值。
abstract  byte ObjectInputStream.GetField.get(String name, byte val)
从持久字段获取指定字节字段的值。
abstract  char ObjectInputStream.GetField.get(String name, char val)
从持久字段获取指定 char 字段的值。
abstract  double ObjectInputStream.GetField.get(String name, double val)
从持久字段获取指定 double 字段的值。
abstract  float ObjectInputStream.GetField.get(String name, float val)
从持久字段获取指定 float 字段的值。
abstract  int ObjectInputStream.GetField.get(String name, int val)
从持久字段获取指定的 int 字段值。
abstract  long ObjectInputStream.GetField.get(String name, long val)
从持久字段获取指定 long 字段的值。
abstract  Object ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。
abstract  short ObjectInputStream.GetField.get(String name, short val)
从持久字段获取指定的 short 字段值。
 File File.getCanonicalFile()
返回此抽象路径名的规范形式。
 String File.getCanonicalPath()
返回此抽象路径名的规范路径名字符串。
 FileDescriptor RandomAccessFile.getFD()
返回与此流关联的不透明文件描述符对象。
 FileDescriptor FileOutputStream.getFD()
返回与此流有关的文件描述符。
 FileDescriptor FileInputStream.getFD()
返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。
 long RandomAccessFile.getFilePointer()
返回此文件中的当前偏移量。
 long RandomAccessFile.length()
返回此文件的长度。
 void CharArrayReader.mark(int readAheadLimit)
标记流中的当前位置。
 void LineNumberReader.mark(int readAheadLimit)
标记该流中的当前位置。
 void PushbackReader.mark(int readAheadLimit)
标记流中的当前位置。
 void FilterReader.mark(int readAheadLimit)
在流中的当前位置上作标记。
 void StringReader.mark(int readAheadLimit)
标记流中的当前位置。
 void BufferedReader.mark(int readAheadLimit)
标记流中的当前位置。
 void Reader.mark(int readAheadLimit)
标记流中的当前位置。
 void BufferedWriter.newLine()
写入一个行分隔符。
 int StreamTokenizer.nextToken()
从此标记生成器的输入流中解析下一个标记。
 ObjectOutputStream.PutField ObjectOutputStream.putFields()
获取用于缓冲写入流中的持久存储字段的对象。
 int CharArrayReader.read()
读取单个字符。
 int LineNumberInputStream.read()
已过时。 从此输入流读取下一个数据字节。
 int LineNumberReader.read()
读取单个字符。
 int PipedInputStream.read()
读取此管道输入流中的下一个数据字节。
 int PipedReader.read()
读取此传送流中的下一个数据字符。
 int PushbackReader.read()
读取单个字符。
 int SequenceInputStream.read()
从此输入流中读取下一个数据字节。
 int PushbackInputStream.read()
从此输入流中读取下一个数据字节。
 int FilterReader.read()
读取单个字符。
 int StringReader.read()
读取单个字符。
 int RandomAccessFile.read()
从此文件中读取一个数据字节。
 int ObjectInputStream.read()
读取数据字节。
 int ObjectInput.read()
读取数据字节。
 int InputStreamReader.read()
读取单个字符。
 int BufferedReader.read()
读取单个字符。
 int Reader.read()
读取单个字符。
 int BufferedInputStream.read()
参见 InputStream 的 read 方法的常规协定。
 int FilterInputStream.read()
从此输入流中读取下一个数据字节。
 int FileInputStream.read()
从此输入流中读取一个数据字节。
abstract  int InputStream.read()
从输入流中读取数据的下一个字节。
 int RandomAccessFile.read(byte[] b)
将最多 b.length 个数据字节从此文件读入 byte 数组。
 int ObjectInput.read(byte[] b)
读入 byte 数组。
 int DataInputStream.read(byte[] b)
从包含的输入流中读取一定数量的字节，并将它们存储到缓冲区数组 b 中。
 int FilterInputStream.read(byte[] b)
从此输入流中将 byte.length 个字节的数据读入一个 byte 数组中。
 int FileInputStream.read(byte[] b)
从此输入流中将最多 b.length 个字节的数据读入一个 byte 数组中。
 int InputStream.read(byte[] b)
从输入流中读取一定数量的字节，并将其存储在缓冲区数组 b 中。
 int LineNumberInputStream.read(byte[] b, int off, int len)
已过时。 将最多 len 个数据字节从此输入流读入 byte 数组。
 int PipedInputStream.read(byte[] b, int off, int len)
将最多 len 个数据字节从此管道输入流读入 byte 数组。
 int SequenceInputStream.read(byte[] b, int off, int len)
将最多 len 个数据字节从此输入流读入 byte 数组。
 int PushbackInputStream.read(byte[] b, int off, int len)
从此输入流将最多 len 个数据字节读入 byte 数组。
 int RandomAccessFile.read(byte[] b, int off, int len)
将最多 len 个数据字节从此文件读入 byte 数组。
 int ObjectInputStream.read(byte[] buf, int off, int len)
读入 byte 数组。
 int ObjectInput.read(byte[] b, int off, int len)
读入 byte 数组。
 int DataInputStream.read(byte[] b, int off, int len)
从包含的输入流中将最多 len 个字节读入一个 byte 数组中。
 int BufferedInputStream.read(byte[] b, int off, int len)
从此字节输入流中给定偏移量处开始将各字节读取到指定的 byte 数组中。
 int FilterInputStream.read(byte[] b, int off, int len)
从此输入流中将 len 个字节的数据读入一个 byte 数组中。
 int FileInputStream.read(byte[] b, int off, int len)
从此输入流中将最多 len 个字节的数据读入一个 byte 数组中。
 int InputStream.read(byte[] b, int off, int len)
将输入流中最多 len 个数据字节读入 byte 数组。
 int Reader.read(char[] cbuf)
将字符读入数组。
 int CharArrayReader.read(char[] b, int off, int len)
将字符读入数组的某一部分。
 int LineNumberReader.read(char[] cbuf, int off, int len)
将字符读入数组中的某一部分。
 int PipedReader.read(char[] cbuf, int off, int len)
将此传送流中最多 len 个数据字符读入字符数组。
 int PushbackReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int FilterReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int StringReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int InputStreamReader.read(char[] cbuf, int offset, int length)
将字符读入数组中的某一部分。
 int BufferedReader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
abstract  int Reader.read(char[] cbuf, int off, int len)
将字符读入数组的某一部分。
 int Reader.read(CharBuffer target)
试图将字符读入指定的字符缓冲区。
 boolean RandomAccessFile.readBoolean()
从此文件读取一个 boolean。
 boolean ObjectInputStream.readBoolean()
读取一个 boolean 值。
 boolean DataInputStream.readBoolean()
参见 DataInput 的 readBoolean 方法的常规协定。
 boolean DataInput.readBoolean()
读取一个输入字节，如果该字节不是零，则返回 true，如果是零，则返回 false。
 byte RandomAccessFile.readByte()
从此文件读取一个有符号的八位值。
 byte ObjectInputStream.readByte()
读取一个 8 位的字节。
 byte DataInputStream.readByte()
参见 DataInput 的 readByte 方法的常规协定。
 byte DataInput.readByte()
读取并返回一个输入字节。
 char RandomAccessFile.readChar()
从此文件读取一个字符。
 char ObjectInputStream.readChar()
读取一个 16 位的 char 值。
 char DataInputStream.readChar()
参见 DataInput 的 readChar 方法的常规协定。
 char DataInput.readChar()
读取两个输入字节并返回一个 char 值。
protected  ObjectStreamClass ObjectInputStream.readClassDescriptor()
从序列化流读取类描述符。
 double RandomAccessFile.readDouble()
从此文件读取一个 double。
 double ObjectInputStream.readDouble()
读取一个 64 位的 double 值。
 double DataInputStream.readDouble()
参见 DataInput 的 readDouble 方法的常规协定。
 double DataInput.readDouble()
读取八个输入字节并返回一个 double 值。
 void Externalizable.readExternal(ObjectInput in)
对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。
 ObjectInputStream.GetField ObjectInputStream.readFields()
按名称从流中读取持久字段并使其可用。
 float RandomAccessFile.readFloat()
从此文件读取一个 float。
 float ObjectInputStream.readFloat()
读取一个 32 位的 float 值。
 float DataInputStream.readFloat()
参见 DataInput 的 readFloat 方法的常规协定。
 float DataInput.readFloat()
读取四个输入字节并返回一个 float 值。
 void RandomAccessFile.readFully(byte[] b)
将 b.length 个字节从此文件读入 byte 数组，并从当前文件指针开始。
 void ObjectInputStream.readFully(byte[] buf)
读取字节，同时阻塞直至读取所有字节。
 void DataInputStream.readFully(byte[] b)
参见 DataInput 的 readFully 方法的常规协定。
 void DataInput.readFully(byte[] b)
从输入流中读取一些字节，并将它们存储在缓冲区数组 b 中。
 void RandomAccessFile.readFully(byte[] b, int off, int len)
将正好 len 个字节从此文件读入 byte 数组，并从当前文件指针开始。
 void ObjectInputStream.readFully(byte[] buf, int off, int len)
读取字节，同时阻塞直至读取所有字节。
 void DataInputStream.readFully(byte[] b, int off, int len)
参见 DataInput 的 readFully 方法的常规协定。
 void DataInput.readFully(byte[] b, int off, int len)
从输入流中读取 len 个字节。
 int RandomAccessFile.readInt()
从此文件读取一个有符号的 32 位整数。
 int ObjectInputStream.readInt()
读取一个 32 位的 int 值。
 int DataInputStream.readInt()
参见 DataInput 的 readInt 方法的常规协定。
 int DataInput.readInt()
读取四个输入字节并返回一个 int 值。
 String LineNumberReader.readLine()
读取文本行。
 String RandomAccessFile.readLine()
从此文件读取文本的下一行。
 String ObjectInputStream.readLine()
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
 String DataInputStream.readLine()
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
 String DataInput.readLine()
从输入流中读取下一文本行。
 String BufferedReader.readLine()
读取一个文本行。
 long RandomAccessFile.readLong()
从此文件读取一个有符号的 64 位整数。
 long ObjectInputStream.readLong()
读取一个 64 位的 long 值。
 long DataInputStream.readLong()
参见 DataInput 的 readLong 方法的常规协定。
 long DataInput.readLong()
读取八个输入字节并返回一个 long 值。
 Object ObjectInputStream.readObject()
从 ObjectInputStream 读取对象。
 Object ObjectInput.readObject()
读取并返回对象。
protected  Object ObjectInputStream.readObjectOverride()
此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。
 short RandomAccessFile.readShort()
从此文件读取一个有符号的 16 位数。
 short ObjectInputStream.readShort()
读取一个 16 位的 short 值。
 short DataInputStream.readShort()
参见 DataInput 的 readShort 方法的常规协定。
 short DataInput.readShort()
读取两个输入字节并返回一个 short 值。
protected  void ObjectInputStream.readStreamHeader()
提供的 readStreamHeader 方法允许子类读取并验证它们自己的流头部。
 Object ObjectInputStream.readUnshared()
从 ObjectInputStream 读取“非共享”对象。
 int RandomAccessFile.readUnsignedByte()
从此文件读取一个无符号的八位数。
 int ObjectInputStream.readUnsignedByte()
读取一个无符号的 8 位字节。
 int DataInputStream.readUnsignedByte()
参见 DataInput 的 readUnsignedByte 方法的常规协定。
 int DataInput.readUnsignedByte()
读取一个输入字节，将它左侧补零 (zero-extend) 转变为 int 类型，并返回结果，所以结果的范围是 0 到 255。
 int RandomAccessFile.readUnsignedShort()
从此文件读取一个无符号的 16 位数。
 int ObjectInputStream.readUnsignedShort()
读取一个无符号的 16 位 short 值。
 int DataInputStream.readUnsignedShort()
参见 DataInput 的 readUnsignedShort 方法的常规协定。
 int DataInput.readUnsignedShort()
读取两个输入字节，并返回 0 到 65535 范围内的一个 int 值。
 String RandomAccessFile.readUTF()
从此文件读取一个字符串。
 String ObjectInputStream.readUTF()
读取 UTF-8 修改版格式的 String。
 String DataInputStream.readUTF()
参见 DataInput 的 readUTF 方法的常规协定。
 String DataInput.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。
static String DataInputStream.readUTF(DataInput in)
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。
 boolean CharArrayReader.ready()
判断此流是否已准备好被读取。
 boolean PipedReader.ready()
告知是否准备读取此流。
 boolean PushbackReader.ready()
判断是否准备读取此流。
 boolean FilterReader.ready()
判断此流是否已经准备好用于读取。
 boolean StringReader.ready()
判断此流是否已经准备好用于读取。
 boolean InputStreamReader.ready()
判断此流是否已经准备好用于读取。
 boolean BufferedReader.ready()
判断此流是否已准备好被读取。
 boolean Reader.ready()
判断是否准备读取此流。
protected  void PipedInputStream.receive(int b)
接收数据字节。
protected  Object ObjectOutputStream.replaceObject(Object obj)
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。
 void CharArrayReader.reset()
将该流重置为最新的标记，如果从未标记过，则将其重置到开头。
 void LineNumberInputStream.reset()
已过时。 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
 void LineNumberReader.reset()
将该流重新设置为最新的标记。
 void PushbackReader.reset()
重置该流。
 void PushbackInputStream.reset()
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
 void FilterReader.reset()
重置该流。
 void StringReader.reset()
将该流重置为最新的标记，如果从未标记过，则将其重置到该字符串的开头。
 void ObjectOutputStream.reset()
重置将丢弃已写入流中的所有对象的状态。
 void BufferedReader.reset()
将流重置到最新的标记。
 void Reader.reset()
重置该流。
 void BufferedInputStream.reset()
参见 InputStream 的 reset 方法的常规协定。
 void FilterInputStream.reset()
将此流重新定位到对此输入流最后调用 mark 方法时的位置。
 void InputStream.reset()
将此流重新定位到最后一次对此输入流调用 mark 方法时的位置。
protected  Class<?> ObjectInputStream.resolveClass(ObjectStreamClass desc)
加载指定流类描述的本地等价类。
protected  Object ObjectInputStream.resolveObject(Object obj)
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。
protected  Class<?> ObjectInputStream.resolveProxyClass(String[] interfaces)
返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。
 void RandomAccessFile.seek(long pos)
设置到此文件开头测量到的文件指针偏移量，在该位置发生下一个读取或写入操作。
 void RandomAccessFile.setLength(long newLength)
设置此文件的长度。
 long CharArrayReader.skip(long n)
跳过字符。
 long LineNumberInputStream.skip(long n)
已过时。 跳过和放弃此输入流中的 n 个数据字节。
 long LineNumberReader.skip(long n)
跳过字符。
 long PushbackReader.skip(long n)
跳过字符。
 long PushbackInputStream.skip(long n)
从此输入流中跳过并丢弃 n 个数据字节。
 long FilterReader.skip(long n)
跳过某些字符。
 long StringReader.skip(long ns)
跳过流中指定数量的字符。
 long ObjectInput.skip(long n)
跳过输入的 n 个字节。
 long BufferedReader.skip(long n)
跳过字符。
 long Reader.skip(long n)
跳过字符。
 long BufferedInputStream.skip(long n)
参见 InputStream 的 skip 方法的常规协定。
 long FilterInputStream.skip(long n)
跳过和丢弃此输入流中数据的 n 个字节。
 long FileInputStream.skip(long n)
从输入流中跳过并丢弃 n 个字节的数据。
 long InputStream.skip(long n)
跳过和丢弃此输入流中数据的 n 个字节。
 int RandomAccessFile.skipBytes(int n)
尝试跳过输入的 n 个字节以丢弃跳过的字节。
 int ObjectInputStream.skipBytes(int len)
跳过字节。
 int DataInputStream.skipBytes(int n)
参见 DataInput 的 skipBytes 方法的常规协定。
 int DataInput.skipBytes(int n)
试图在输入流中跳过数据的 n 个字节，并丢弃跳过的字节。
 void PushbackInputStream.unread(byte[] b)
推回一个 byte 数组：将其复制到推回缓冲区之前。
 void PushbackInputStream.unread(byte[] b, int off, int len)
推回 byte 数组的某一部分：将其复制到推回缓冲区之前。
 void PushbackReader.unread(char[] cbuf)
推回一个字符数组，方法是将其复制到推回缓冲区前面。
 void PushbackReader.unread(char[] cbuf, int off, int len)
推回字符数组的某一部分，方法是将其复制到推回缓冲区的前面。
 void PushbackReader.unread(int c)
推回单个字符：将其复制到推回缓冲区的前面。
 void PushbackInputStream.unread(int b)
推回一个字节：将其复制到推回缓冲区之前。
 void ObjectOutputStream.useProtocolVersion(int version)
指定要在写入流时使用的流协议版本。
 void RandomAccessFile.write(byte[] b)
将 b.length 个字节从指定 byte 数组写入到此文件，并从当前文件指针开始。
 void ObjectOutputStream.write(byte[] buf)
写入一个 byte 数组。
 void ObjectOutput.write(byte[] b)
写入 byte 数组。
 void DataOutput.write(byte[] b)
将数组 b 中的所有字节写入输出流。
 void FilterOutputStream.write(byte[] b)
将 b.length 个字节写入此输出流。
 void FileOutputStream.write(byte[] b)
将 b.length 个字节从指定 byte 数组写入此文件输出流中。
 void OutputStream.write(byte[] b)
将 b.length 个字节从指定的 byte 数组写入此输出流。
 void PipedOutputStream.write(byte[] b, int off, int len)
将 len 字节从初始偏移量为 off 的指定 byte 数组写入该管道输出流。
 void DataOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入基础输出流。
 void RandomAccessFile.write(byte[] b, int off, int len)
将 len 个字节从指定 byte 数组写入到此文件，并从偏移量 off 处开始。
 void ObjectOutputStream.write(byte[] buf, int off, int len)
写入字节的子数组。
 void ObjectOutput.write(byte[] b, int off, int len)
写入字节的子数组。
 void DataOutput.write(byte[] b, int off, int len)
将数组 b 中的 len 个字节按顺序写入输出流。
 void BufferedOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此缓冲的输出流。
 void FilterOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
 void FileOutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此文件输出流。
 void OutputStream.write(byte[] b, int off, int len)
将指定 byte 数组中从偏移量 off 开始的 len 个字节写入此输出流。
 void Writer.write(char[] cbuf)
写入字符数组。
 void FilterWriter.write(char[] cbuf, int off, int len)
将字符写入数组的某一部分。
 void PipedWriter.write(char[] cbuf, int off, int len)
将 len 字符从指定初始偏移量为 off 的字符数组写入到此管道输出流。
 void BufferedWriter.write(char[] cbuf, int off, int len)
写入字符数组的某一部分。
 void OutputStreamWriter.write(char[] cbuf, int off, int len)
写入字符数组的某一部分。
abstract  void Writer.write(char[] cbuf, int off, int len)
写入字符数组的某一部分。
 void FilterWriter.write(int c)
写入单个字符。
 void PipedOutputStream.write(int b)
将指定 byte 写入传送的输出流。
 void PipedWriter.write(int c)
将指定的 char 写入管道输出流。
 void DataOutputStream.write(int b)
将指定字节（参数 b 的八个低位）写入基础输出流。
 void RandomAccessFile.write(int b)
向此文件写入指定的字节。
 void ObjectOutputStream.write(int val)
写入一个字节。
 void ObjectOutput.write(int b)
写入字节。
 void DataOutput.write(int b)
将参数 b 的八个低位写入输出流。
 void BufferedWriter.write(int c)
写入单个字符。
 void OutputStreamWriter.write(int c)
写入单个字符。
 void Writer.write(int c)
写入单个字符。
 void BufferedOutputStream.write(int b)
将指定的字节写入此缓冲的输出流。
 void FilterOutputStream.write(int b)
将指定 byte 写入此输出流。
 void FileOutputStream.write(int b)
将指定字节写入此文件输出流。
abstract  void OutputStream.write(int b)
将指定的字节写入此输出流。
abstract  void ObjectOutputStream.PutField.write(ObjectOutput out)
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。
 void Writer.write(String str)
写入字符串。
 void FilterWriter.write(String str, int off, int len)
写入一部分字符串。
 void BufferedWriter.write(String s, int off, int len)
写入字符串的某一部分。
 void OutputStreamWriter.write(String str, int off, int len)
写入字符串的某一部分。
 void Writer.write(String str, int off, int len)
写入字符串的某一部分。
 void DataOutputStream.writeBoolean(boolean v)
将一个 boolean 值以 1-byte 值形式写入基础输出流。
 void RandomAccessFile.writeBoolean(boolean v)
按单字节值将 boolean 写入该文件。
 void ObjectOutputStream.writeBoolean(boolean val)
写入一个 boolean 值。
 void DataOutput.writeBoolean(boolean v)
将一个 boolean 值写入输出流。
 void DataOutputStream.writeByte(int v)
将一个 byte 值以 1-byte 值形式写出到基础输出流中。
 void RandomAccessFile.writeByte(int v)
按单字节值将 byte 写入该文件。
 void ObjectOutputStream.writeByte(int val)
写入一个 8 位字节。
 void DataOutput.writeByte(int v)
将参数 v 的八个低位写入输出流。
 void DataOutputStream.writeBytes(String s)
将字符串按字节顺序写出到基础输出流中。
 void RandomAccessFile.writeBytes(String s)
按字节序列将该字符串写入该文件。
 void ObjectOutputStream.writeBytes(String str)
以字节序列形式写入一个 String。
 void DataOutput.writeBytes(String s)
将一个字符串写入输出流。
 void DataOutputStream.writeChar(int v)
将一个 char 值以 2-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeChar(int v)
按双字节值将 char 写入该文件，先写高字节。
 void ObjectOutputStream.writeChar(int val)
写入一个 16 位的 char 值。
 void DataOutput.writeChar(int v)
将一个 char 值写入输出流，该值由两个字节组成。
 void DataOutputStream.writeChars(String s)
将字符串按字符顺序写入基础输出流。
 void RandomAccessFile.writeChars(String s)
按字符序列将一个字符串写入该文件。
 void ObjectOutputStream.writeChars(String str)
以 char 序列形式写入一个 String。
 void DataOutput.writeChars(String s)
将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。
protected  void ObjectOutputStream.writeClassDescriptor(ObjectStreamClass desc)
将指定的类描述符写入 ObjectOutputStream。
 void DataOutputStream.writeDouble(double v)
使用 Double 类中的 doubleToLongBits 方法将 double 参数转换为一个 long 值，然后将该 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeDouble(double v)
使用 Double 类中的 doubleToLongBits 方法将双精度参数转换为一个 long，然后按八字节数量将该 long 值写入该文件，先定高字节。
 void ObjectOutputStream.writeDouble(double val)
写入一个 64 位的 double 值。
 void DataOutput.writeDouble(double v)
将一个 double 值写入输出流，该值由八个字节组成。
 void Externalizable.writeExternal(ObjectOutput out)
该对象可实现 writeExternal 方法来保存其内容，它可以通过调用 DataOutput 的方法来保存其基本值，或调用 ObjectOutput 的 writeObject 方法来保存对象、字符串和数组。
 void ObjectOutputStream.writeFields()
将已缓冲的字段写入流中。
 void DataOutputStream.writeFloat(float v)
使用 Float 类中的 floatToIntBits 方法将 float 参数转换为一个 int 值，然后将该 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeFloat(float v)
使用 Float 类中的 floatToIntBits 方法将浮点参数转换为一个 int，然后按四字节数量将该 int 值写入该文件，先写高字节。
 void ObjectOutputStream.writeFloat(float val)
写入一个 32 位的 float 值。
 void DataOutput.writeFloat(float v)
将一个 float 值写入输出流，该值由四个字节组成。
 void DataOutputStream.writeInt(int v)
将一个 int 值以 4-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeInt(int v)
按四个字节将 int 写入该文件，先写高字节。
 void ObjectOutputStream.writeInt(int val)
写入一个 32 位的 int 值。
 void DataOutput.writeInt(int v)
将一个 int 值写入输出流，该值由四个字节组成。
 void DataOutputStream.writeLong(long v)
将一个 long 值以 8-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeLong(long v)
按八个字节将 long 写入该文件，先写高字节。
 void ObjectOutputStream.writeLong(long val)
写入一个 64 位的 long 值。
 void DataOutput.writeLong(long v)
将一个 long 值写入输出流，该值由八个字节组成。
 void ObjectOutputStream.writeObject(Object obj)
将指定的对象写入 ObjectOutputStream。
 void ObjectOutput.writeObject(Object obj)
将对象写入底层存储或流。
protected  void ObjectOutputStream.writeObjectOverride(Object obj)
子类用于重写默认 writeObject 方法的方法。
 void DataOutputStream.writeShort(int v)
将一个 short 值以 2-byte 值形式写入基础输出流中，先写入高字节。
 void RandomAccessFile.writeShort(int v)
按两个字节将 short 写入该文件，先写高字节。
 void ObjectOutputStream.writeShort(int val)
写入一个 16 位的 short 值。
 void DataOutput.writeShort(int v)
将两个字节写入输出流，用它们表示参数值。
protected  void ObjectOutputStream.writeStreamHeader()
提供 writeStreamHeader 方法，这样子类可以将其自身的头部添加或预加到流中。
 void ByteArrayOutputStream.writeTo(OutputStream out)
将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。
 void CharArrayWriter.writeTo(Writer out)
将缓冲区的内容写入另一个字符流。
 void ObjectOutputStream.writeUnshared(Object obj)
将“未共享”对象写入 ObjectOutputStream。
 void DataOutputStream.writeUTF(String str)
以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。
 void RandomAccessFile.writeUTF(String str)
使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。
 void ObjectOutputStream.writeUTF(String str)
以 UTF-8 修改版格式写入此 String 的基本数据。
 void DataOutput.writeUTF(String s)
将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。

抛出 IOException 的 java.io 中的构造方法
FileWriter(File file)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(File file, boolean append)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(String fileName)
根据给定的文件名构造一个 FileWriter 对象。
FileWriter(String fileName, boolean append)
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。
ObjectInputStream()
为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。
ObjectInputStream(InputStream in)
创建从指定 InputStream 读取的 ObjectInputStream。
ObjectOutputStream()
为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。
ObjectOutputStream(OutputStream out)
创建写入指定 OutputStream 的 ObjectOutputStream。
PipedInputStream(PipedOutputStream src)
创建 PipedInputStream，使其连接到管道输出流 src。
PipedInputStream(PipedOutputStream src, int pipeSize)
创建一个 PipedInputStream，使其连接到管道输出流 src，并对管道缓冲区使用指定的管道大小。
PipedOutputStream(PipedInputStream snk)
创建连接到指定管道输入流的管道输出流。
PipedReader(PipedWriter src)
创建连接到传送 writer src 的 PipedReader。
PipedReader(PipedWriter src, int pipeSize)
创建一个 PipedReader，使其连接到管道 writer src，并对管道缓冲区使用指定的管道大小。
PipedWriter(PipedReader snk)
创建传送 writer，使其连接到指定的传送 reader。

java.lang 中 IOException 的使用

抛出 IOException 的 java.lang 中的方法
Appendable | Appendable.append(char c) 向此 Appendable 添加指定字符。
Appendable | Appendable.append(CharSequence csq) 向此 Appendable 添加指定的字符序列。
Appendable | Appendable.append(CharSequence csq, int start, int end) 向此 Appendable 添加指定字符序列的子序列。
Process | Runtime.exec(String command) 在单独的进程中执行指定的字符串命令。
Process | Runtime.exec(String[] cmdarray) 在单独的进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp) 在指定环境的独立进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp, File dir) 在指定环境和工作目录的独立进程中执行指定的命令和变量。
Process | Runtime.exec(String command, String[] envp) 在指定环境的单独进程中执行指定的字符串命令。
Process | Runtime.exec(String command, String[] envp, File dir) 在有指定环境和工作目录的独立进程中执行指定的字符串命令。
protected Enumeration<URL> | ClassLoader.findResources(String name) 返回表示所有具有给定名称的资源的 URL 对象的枚举。
Enumeration<URL> | ClassLoader.getResources(String name) 查找所有给定名称的资源。
static Enumeration<URL> | ClassLoader.getSystemResources(String name) 从用来加载类的搜索路径中查找所有具有指定名称的资源。
static Channel | System.inheritedChannel() 返回从创建此 Java 虚拟机的实体中继承的信道。
int | Readable.read(CharBuffer cb) 试图将字符读入指定的字符缓冲区。
Process | ProcessBuilder.start() 使用此进程生成器的属性启动一个新进程。

java.lang.management 中 IOException 的使用

抛出 IOException 的 java.lang.management 中的方法
static
<T> T
ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

java.net 中 IOException 的使用

java.net 中 IOException 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。

参数类型为 IOException 的 java.net 中的方法
abstract  void ProxySelector.connectFailed(URI uri, SocketAddress sa, IOException ioe)
调用此方法来指示无法建立到代理/socks 服务器的连接。

抛出 IOException 的 java.net 中的方法
 Socket ServerSocket.accept()
侦听并接受到此套接字的连接。
protected abstract  void SocketImpl.accept(SocketImpl s)
接受连接。
protected abstract  int SocketImpl.available()
返回可以不受阻塞地从此套接字中读取的字节数。
protected abstract  void SocketImpl.bind(InetAddress host, int port)
将此套接字绑定到指定的本地 IP 地址和端口号。
 void ServerSocket.bind(SocketAddress endpoint)
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
 void Socket.bind(SocketAddress bindpoint)
将套接字绑定到本地地址。
 void ServerSocket.bind(SocketAddress endpoint, int backlog)
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
 void ServerSocket.close()
关闭此套接字。
protected abstract  void SocketImpl.close()
关闭此套接字。
 void Socket.close()
关闭此套接字。
abstract  void URLConnection.connect()
打开到此 URL 引用的资源的通信链接（如果尚未建立这样的连接）。
protected abstract  void SocketImpl.connect(InetAddress address, int port)
将此套接字连接到指定主机上的指定端口号。
 void Socket.connect(SocketAddress endpoint)
将此套接字连接到服务器。
protected abstract  void SocketImpl.connect(SocketAddress address, int timeout)
将此套接字连接到指定主机上的指定端口号。
 void Socket.connect(SocketAddress endpoint, int timeout)
将此套接字连接到服务器，并指定一个超时值。
protected abstract  void SocketImpl.connect(String host, int port)
将此套接字连接到指定主机上的指定端口。
protected abstract  void SocketImpl.create(boolean stream)
创建一个流或数据报套接字。
 Enumeration<URL> URLClassLoader.findResources(String name)
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。
abstract  Map<String,List<String>> CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
 Map<String,List<String>> CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract  CacheResponse ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。
 Attributes JarURLConnection.getAttributes()
如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
abstract  OutputStream CacheRequest.getBody()
返回可以将响应正文写入其中的 OutputStream。
abstract  InputStream CacheResponse.getBody()
以 InputStream 的形式返回响应正文。
 Certificate[] JarURLConnection.getCertificates()
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。
 Object URLConnection.getContent()
获取此 URL 连接的内容。
 Object URL.getContent()
获取此 URL 的内容。
 Object URLConnection.getContent(Class[] classes)
获取此 URL 连接的内容。
 Object URL.getContent(Class[] classes)
获取此 URL 的内容。
abstract  Object ContentHandler.getContent(URLConnection urlc)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。
 Object ContentHandler.getContent(URLConnection urlc, Class[] classes)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。
abstract  Map<String,List<String>> CacheResponse.getHeaders()
以 Map 的形式返回响应头。
protected abstract  InputStream SocketImpl.getInputStream()
返回此套接字的输入流。
 InputStream Socket.getInputStream()
返回此套接字的输入流。
 InputStream URLConnection.getInputStream()
返回从此打开的连接读取的输入流。
 JarEntry JarURLConnection.getJarEntry()
返回此连接的 JAR 条目对象（如果有）。
abstract  JarFile JarURLConnection.getJarFile()
返回此连接的 JAR 文件。
 Attributes JarURLConnection.getMainAttributes()
返回此连接的 JAR 文件的主要 Attribute。
 Manifest JarURLConnection.getManifest()
返回此连接的 Manifest；如果没有，则返回 null。
protected abstract  OutputStream SocketImpl.getOutputStream()
返回此套接字的输出流。
 OutputStream Socket.getOutputStream()
返回此套接字的输出流。
 OutputStream URLConnection.getOutputStream()
返回写入到此连接的输出流。
 Permission HttpURLConnection.getPermission()
 Permission URLConnection.getPermission()
返回一个权限对象，其代表建立此对象表示的连接所需的权限。
 int HttpURLConnection.getResponseCode()
从 HTTP 响应消息获取状态码。
 String HttpURLConnection.getResponseMessage()
获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。
 int ServerSocket.getSoTimeout()
获取 SO_TIMEOUT 的设置。
protected abstract  int DatagramSocketImpl.getTimeToLive()
获取 TTL （生存时间）选项。
 int MulticastSocket.getTimeToLive()
获取在套接字上发出的多播数据包的默认生存时间。
protected abstract  byte DatagramSocketImpl.getTTL()
已过时。 使用 getTimeToLive 代替。
 byte MulticastSocket.getTTL()
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
static String URLConnection.guessContentTypeFromStream(InputStream is)
根据输入流的开始字符尝试确定输入流的类型。
protected  void ServerSocket.implAccept(Socket s)
ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。
 boolean InetAddress.isReachable(int timeout)
测试是否可以达到该地址。
 boolean InetAddress.isReachable(NetworkInterface netif, int ttl, int timeout)
测试是否可以达到该地址。
protected abstract  void DatagramSocketImpl.join(InetAddress inetaddr)
加入多播组。
 void MulticastSocket.joinGroup(InetAddress mcastaddr)
加入多播组。
protected abstract  void DatagramSocketImpl.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入多播组。
 void MulticastSocket.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入指定接口上的指定多播组。
protected abstract  void DatagramSocketImpl.leave(InetAddress inetaddr)
退出多播组。
 void MulticastSocket.leaveGroup(InetAddress mcastaddr)
离开多播组。
protected abstract  void DatagramSocketImpl.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
退出多播组。
 void MulticastSocket.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
离开指定本地接口上的多播组。
protected abstract  void SocketImpl.listen(int backlog)
将传入连接指示（连接请求）的最大队列长度设置为 count 参数。
 URLConnection URL.openConnection()
返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。
 URLConnection URL.openConnection(Proxy proxy)
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
protected abstract  URLConnection URLStreamHandler.openConnection(URL u)
打开一个到 URL 参数引用的对象的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。
 InputStream URL.openStream()
打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。
protected abstract  int DatagramSocketImpl.peek(InetAddress i)
查看包来自哪里。
protected abstract  int DatagramSocketImpl.peekData(DatagramPacket p)
查看包来自哪里。
abstract  void CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders)
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
 void CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)
abstract  CacheRequest ResponseCache.put(URI uri, URLConnection conn)
协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。
protected abstract  void DatagramSocketImpl.receive(DatagramPacket p)
接收数据报包。
 void DatagramSocket.receive(DatagramPacket p)
从此套接字接收数据报包。
protected abstract  void DatagramSocketImpl.send(DatagramPacket p)
发送数据报包。
 void DatagramSocket.send(DatagramPacket p)
从此套接字发送数据报包。
 void MulticastSocket.send(DatagramPacket p, byte ttl)
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
protected abstract  void SocketImpl.sendUrgentData(int data)
在套接字上发送一个紧急数据字节。
 void Socket.sendUrgentData(int data)
在套接字上发送一个紧急数据字节。
static void DatagramSocket.setDatagramSocketImplFactory(DatagramSocketImplFactory fac)
为应用程序设置数据报套接字实现工厂。
static void ServerSocket.setSocketFactory(SocketImplFactory fac)
为应用程序设置服务器套接字实现工厂。
static void Socket.setSocketImplFactory(SocketImplFactory fac)
为应用程序设置客户端套接字实现工厂。
protected abstract  void DatagramSocketImpl.setTimeToLive(int ttl)
设置 TTL （生存时间）选项。
 void MulticastSocket.setTimeToLive(int ttl)
设置在此 MulticastSocket 上发出的多播数据包的默认生存时间，以便控制多播的范围。
protected abstract  void DatagramSocketImpl.setTTL(byte ttl)
已过时。 使用 setTimeToLive 代替。
 void MulticastSocket.setTTL(byte ttl)
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
protected  void SocketImpl.shutdownInput()
将此套接字的输入流置于“流的末尾”。
 void Socket.shutdownInput()
此套接字的输入流置于“流的末尾”。
protected  void SocketImpl.shutdownOutput()
禁用此套接字的输出流。
 void Socket.shutdownOutput()
禁用此套接字的输出流。

抛出 IOException 的 java.net 中的构造方法
MulticastSocket()
创建多播套接字。
MulticastSocket(int port)
创建多播套接字并将其绑定到特定端口。
MulticastSocket(SocketAddress bindaddr)
创建绑定到指定套接字地址的 MulticastSocket。
ServerSocket()
创建非绑定服务器套接字。
ServerSocket(int port)
创建绑定到特定端口的服务器套接字。
ServerSocket(int port, int backlog)
利用指定的 backlog 创建服务器套接字并将其绑定到指定的本地端口号。
ServerSocket(int port, int backlog, InetAddress bindAddr)
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。
Socket(InetAddress address, int port)
创建一个流套接字并将其连接到指定 IP 地址的指定端口号。
Socket(InetAddress host, int port, boolean stream)
已过时。 Use DatagramSocket instead for UDP transport.
Socket(InetAddress address, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程地址上的指定远程端口。
Socket(String host, int port)
创建一个流套接字并将其连接到指定主机上的指定端口号。
Socket(String host, int port, boolean stream)
已过时。 使用 DatagramSocket 取代 UDP 传输。
Socket(String host, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程主机上的指定远程端口。

java.nio 中 IOException 的使用

抛出 IOException 的 java.nio 中的方法
 int CharBuffer.read(CharBuffer target)
试图将字符读入指定的字符缓冲区。

java.nio.channels 中 IOException 的使用

java.nio.channels 中 IOException 的子类
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。

抛出 IOException 的 java.nio.channels 中的方法
abstract SocketChannel | ServerSocketChannel.accept() 接受到此通道套接字的连接。
abstract void | Selector.close() 关闭此选择器。
void | InterruptibleChannel.close() 关闭此通道。
void | Channel.close() 关闭此通道。
abstract SelectableChannel | SelectableChannel.configureBlocking(boolean block) 调整此通道的阻塞模式。
abstract DatagramChannel | DatagramChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract boolean | SocketChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract DatagramChannel | DatagramChannel.disconnect() 断开此通道套接字的连接。
abstract boolean | SocketChannel.finishConnect() 完成套接字通道的连接过程。
abstract void | FileChannel.force(boolean metaData) 强制将所有对此通道的文件更新写入包含该文件的存储设备中。
FileLock | FileChannel.lock() 获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.lock(long position, long size, boolean shared) 获取此通道的文件给定区域上的锁定。
abstract MappedByteBuffer | FileChannel.map(FileChannel.MapMode mode, long position, long size) 将此通道的文件区域直接映射到内存中。
static DatagramChannel | DatagramChannel.open() 打开数据报通道。
static Pipe | Pipe.open() 打开一个管道。
static Selector | Selector.open() 打开一个选择器。
static ServerSocketChannel | ServerSocketChannel.open() 打开服务器套接字通道。
static SocketChannel | SocketChannel.open() 打开套接字通道。
static SocketChannel | SocketChannel.open(SocketAddress remote) 打开套接字通道并将其连接到远程地址。
abstract long | FileChannel.position() 返回此通道的文件位置。
abstract FileChannel | FileChannel.position(long newPosition) 设置此通道的文件位置。
abstract int | DatagramChannel.read(ByteBuffer dst) 从此通道读取数据报。
abstract int | SocketChannel.read(ByteBuffer dst)
abstract int | FileChannel.read(ByteBuffer dst) 将字节序列从此通道读入给定的缓冲区。
int | ReadableByteChannel.read(ByteBuffer dst) 将字节序列从此通道中读入给定的缓冲区。
long | DatagramChannel.read(ByteBuffer[] dsts) 从此通道读取数据报。
long | SocketChannel.read(ByteBuffer[] dsts)
long | FileChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
long | ScatteringByteChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
abstract long | DatagramChannel.read(ByteBuffer[] dsts, int offset, int length) 从此通道读取数据报。
abstract long | SocketChannel.read(ByteBuffer[] dsts, int offset, int length)
abstract long | FileChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
long | ScatteringByteChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
abstract int | FileChannel.read(ByteBuffer dst, long position) 从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。
abstract SocketAddress | DatagramChannel.receive(ByteBuffer dst) 通过此通道接收数据报。
abstract void | FileLock.release() 释放此锁定。
abstract int | Selector.select() 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract int | Selector.select(long timeout) 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract int | Selector.selectNow() 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract int | DatagramChannel.send(ByteBuffer src, SocketAddress target) 通过此通道发送数据报。
abstract long | FileChannel.size() 返回此通道的文件的当前大小。
abstract long | FileChannel.transferFrom(ReadableByteChannel src, long position, long count) 将字节从给定的可读取字节通道传输到此通道的文件中。
abstract long | FileChannel.transferTo(long position, long count, WritableByteChannel target) 将字节从此通道的文件传输到给定的可写入字节通道。
abstract FileChannel | FileChannel.truncate(long size) 将此通道的文件截取为给定大小。
FileLock | FileChannel.tryLock() 试图获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.tryLock(long position, long size, boolean shared) 试图获取对此通道的文件给定区域的锁定。
abstract int | DatagramChannel.write(ByteBuffer src) 将数据报写入此通道。
abstract int | SocketChannel.write(ByteBuffer src)
abstract int | FileChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区写入此通道。
int | WritableByteChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区中写入此通道。
long | DatagramChannel.write(ByteBuffer[] srcs) 将数据报写入此通道。
long | SocketChannel.write(ByteBuffer[] srcs)
long | FileChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
abstract long | DatagramChannel.write(ByteBuffer[] srcs, int offset, int length) 将数据报写入此通道。
abstract long | SocketChannel.write(ByteBuffer[] srcs, int offset, int length)
abstract long | FileChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
abstract int | FileChannel.write(ByteBuffer src, long position) 从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。

java.nio.channels.spi 中 IOException 的使用

抛出 IOException 的 java.nio.channels.spi 中的方法
void | AbstractSelector.close() 关闭此选择器。
void | AbstractInterruptibleChannel.close() 关闭此通道。
SelectableChannel | AbstractSelectableChannel.configureBlocking(boolean block) 调整此通道的阻塞模式。
protected void | AbstractSelectableChannel.implCloseChannel() 关闭此通道。
protected abstract void | AbstractInterruptibleChannel.implCloseChannel() 关闭此通道。
protected abstract void | AbstractSelectableChannel.implCloseSelectableChannel() 关闭此可选择通道。
protected abstract void | AbstractSelector.implCloseSelector() 关闭此选择器。
protected abstract void | AbstractSelectableChannel.implConfigureBlocking(boolean block) 调整此通道的阻塞模式。
Channel | SelectorProvider.inheritedChannel() 返回从创建此 Java 虚拟机的实体中继承的通道。
abstract DatagramChannel | SelectorProvider.openDatagramChannel() 打开数据报通道。
abstract Pipe | SelectorProvider.openPipe() 打开一个管道。
abstract AbstractSelector | SelectorProvider.openSelector() 打开一个选择器。
abstract ServerSocketChannel | SelectorProvider.openServerSocketChannel() 打开服务器套接字通道。
abstract SocketChannel | SelectorProvider.openSocketChannel() 打开套接字通道。

java.nio.charset 中 IOException 的使用

java.nio.charset 中 IOException 的子类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。

java.rmi 中 IOException 的使用

java.rmi 中 IOException 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | MarshalException 如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

抛出 IOException 的 java.rmi 中的方法
 T MarshalledObject.get()
返回所包含的 marshalledobject 的新副本。

抛出 IOException 的 java.rmi 中的构造方法
MarshalledObject(T obj)
创建一个新的 MarshalledObject，它包含所提供对象的当前状态的序列化表示形式。

java.rmi.activation 中 IOException 的使用

java.rmi.activation 中 IOException 的子类
 class ActivateFailedException
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。

java.rmi.server 中 IOException 的使用

java.rmi.server 中 IOException 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

抛出 IOException 的 java.rmi.server 中的方法
ServerSocket | RMIServerSocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
abstract ServerSocket | RMISocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
Socket | RMIClientSocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。
abstract Socket | RMISocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。
void | RemoteCall.done() 已过时。 无替代版本
ObjectInput | RemoteCall.getInputStream() 已过时。 无替代版本
ObjectOutput | RemoteCall.getOutputStream() 已过时。 无替代版本
ObjectOutput | RemoteCall.getResultStream(boolean success) 已过时。 无替代版本
static UID | UID.read(DataInput in) 通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。
static ObjID | ObjID.read(ObjectInput in) 通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。
void | RemoteCall.releaseInputStream() 已过时。 无替代版本
void | RemoteCall.releaseOutputStream() 已过时。 无替代版本
static void | RMISocketFactory.setSocketFactory(RMISocketFactory fac) 设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。
void | UID.write(DataOutput out) 将此 UID 的二进制表示形式编组为一个 DataOutput 实例。
void | ObjID.write(ObjectOutput out) 将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。

java.security 中 IOException 的使用

抛出 IOException 的 java.security 中的方法
void | Certificate.decode(InputStream stream) 已过时。 从输入流解码证书。
void | Certificate.encode(OutputStream stream) 已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
protected abstract byte[] | AlgorithmParametersSpi.engineGetEncoded() 返回基本编码格式的参数。
protected abstract byte[] | AlgorithmParametersSpi.engineGetEncoded(String format) 返回以指定格式编码的参数。
protected abstract void | AlgorithmParametersSpi.engineInit(byte[] params) 根据参数的基本解码格式导入指定的参数并对其解码。
protected abstract void | AlgorithmParametersSpi.engineInit(byte[] params, String format) 根据指定的解码格式从 params 导入参数并对其解码。
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
byte[] | AlgorithmParameters.getEncoded() 返回基本编码格式的参数。
byte[] | AlgorithmParameters.getEncoded(String format) 返回以指定方案编码的参数。
Object | SignedObject.getObject() 获取已封装的对象。
void | AlgorithmParameters.init(byte[] params) 根据参数的基本解码格式导入指定的参数并对其解码。
void | AlgorithmParameters.init(byte[] params, String format) 根据指定的解码方案从 params 导入参数并对其解码。
void | Provider.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
int | DigestInputStream.read() 读取字节并更新消息摘要（如果开启了摘要功能）。
int | DigestInputStream.read(byte[] b, int off, int len) 读入 byte 数组并更新消息摘要（如果开启了摘要功能）。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。
void | DigestOutputStream.write(byte[] b, int off, int len) 使用指定的子数组更新消息摘要（如果开启了摘要功能），并将子数组写入输出流（不管是否开启了摘要功能）。
void | DigestOutputStream.write(int b) 使用指定的字节更新消息摘要（如果开启了摘要功能），并将字节写入输出流（不管是否开启了摘要功能）。

抛出 IOException 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.cert 中 IOException 的使用

抛出 IOException 的 java.security.cert 中的方法
 void X509CRLSelector.addIssuerName(byte[] name)
向 issuerNames 标准中添加名称。
 void X509CRLSelector.addIssuerName(String name)
已过时，使用 X509CRLSelector.addIssuer(X500Principal) 或 X509CRLSelector.addIssuerName(byte[]) 替代。
 void X509CertSelector.addPathToName(int type, byte[] name)
向 pathToNames 标准中添加一个名称。
 void X509CertSelector.addPathToName(int type, String name)
向 pathToNames 标准中添加一个名称。
 void X509CertSelector.addSubjectAlternativeName(int type, byte[] name)
向 subjectAlternativeNames 标准中添加一个名称。
 void X509CertSelector.addSubjectAlternativeName(int type, String name)
向 subjectAlternativeNames 标准中添加一个名称。
 byte[] X509CertSelector.getIssuerAsBytes()
返回以 byte 数组表示的 issuer 标准。
 byte[] X509CertSelector.getSubjectAsBytes()
以 byte 数组的形式返回 subject 标准。
 void X509CertSelector.setExtendedKeyUsage(Set<String> keyPurposeSet)
设置 extendedKeyUsage 标准。
 void X509CertSelector.setIssuer(byte[] issuerDN)
设置 issuer 标准。
 void X509CertSelector.setIssuer(String issuerDN)
已过时，使用 X509CertSelector.setIssuer(X500Principal) 或 X509CertSelector.setIssuer(byte[]) 替代。
 void X509CRLSelector.setIssuerNames(Collection<?> names)
注意：请使用 X509CRLSelector.setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。
 void X509CertSelector.setNameConstraints(byte[] bytes)
设置 NameConstraints 标准。
 void X509CertSelector.setPathToNames(Collection<List<?>> names)
设置 pathToNames 标准。
 void X509CertSelector.setPolicy(Set<String> certPolicySet)
设置策略限制。
 void X509CertSelector.setSubject(byte[] subjectDN)
设置 subject 标准。
 void X509CertSelector.setSubject(String subjectDN)
已过时，使用 X509CertSelector.setSubject(X500Principal) 或 X509CertSelector.setSubject(byte[]) 替代。
 void X509CertSelector.setSubjectAlternativeNames(Collection<List<?>> names)
设置 subjectAlternativeNames 标准。
 void X509CertSelector.setSubjectPublicKey(byte[] key)
设置 subjectPublicKey 标准。
 void X509CertSelector.setSubjectPublicKeyAlgID(String oid)
设置 subjectPublicKeyAlgID 标准。

抛出 IOException 的 java.security.cert 中的构造方法
PolicyQualifierInfo(byte[] encoded)
根据已编码的字节创建一个 PolicyQualifierInfo 实例。

java.util 中 IOException 的使用

java.util 中 IOException 的子类
 class InvalidPropertiesFormatException
当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。

返回 IOException 的 java.util 中的方法
IOException | Formatter.ioException() 返回由此 formatter 的 Appendable 方法上次抛出的 IOException 异常。
IOException | Scanner.ioException() 返回此 Scanner 的底层 Readable 最后抛出的 IOException。

抛出 IOException 的 java.util 中的方法
void | Properties.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | Properties.load(Reader reader) 按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。
void | Properties.loadFromXML(InputStream in) 将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。
ResourceBundle | ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload) 针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。
void | Properties.store(OutputStream out, String comments) 以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。
void | Properties.store(Writer writer, String comments) 以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。
void | Properties.storeToXML(OutputStream os, String comment) 发出一个表示此表中包含的所有属性的 XML 文档。
void | Properties.storeToXML(OutputStream os, String comment, String encoding) 使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。

抛出 IOException 的 java.util 中的构造方法
PropertyResourceBundle(InputStream stream)
根据 InputStream 创建属性资源包。
PropertyResourceBundle(Reader reader)
根据 Reader 创建属性资源包。

java.util.jar 中 IOException 的使用

java.util.jar 中 IOException 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

抛出 IOException 的 java.util.jar 中的方法
Attributes | JarEntry.getAttributes() 返回此条目的 Manifest Attributes；如果没有，则返回 null。
InputStream | JarFile.getInputStream(ZipEntry ze) 返回用于读取指定 zip 文件条目内容的输入流。
Manifest | JarFile.getManifest() 返回 jar 文件清单；如果没有，则返回 null。
ZipEntry | JarInputStream.getNextEntry() 读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。
JarEntry | JarInputStream.getNextJarEntry() 读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。
void | Pack200.Packer.pack(JarFile in, OutputStream out) 接收 JarFile 并将其转换为 Pack200 存档。
void | Pack200.Packer.pack(JarInputStream in, OutputStream out) 接收 JarInputStream 并将其转换成 Pack200 存档。
void | JarOutputStream.putNextEntry(ZipEntry ze) 开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。
int | JarInputStream.read(byte[] b, int off, int len) 从当前 JAR 文件条目读入字节数组。
void | Manifest.read(InputStream is) 从指定的 InputStream 读取 Manifest。
void | Pack200.Unpacker.unpack(File in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
void | Pack200.Unpacker.unpack(InputStream in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
void | Manifest.write(OutputStream out) 将 Manifest 写入指定的 OutputStream。

抛出 IOException 的 java.util.jar 中的构造方法
JarFile(File file)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify, int mode)
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。
JarFile(String name)
创建一个要从指定的文件 name 读取的新的 JarFile。
JarFile(String name, boolean verify)
创建一个要从指定的文件 name 读取的新的 JarFile。
JarInputStream(InputStream in)
创建新的 JarInputStream 并读取可选的清单。
JarInputStream(InputStream in, boolean verify)
创建新的 JarInputStream 并读取可选的清单。
JarOutputStream(OutputStream out)
创建不带清单的新的 JarOutputStream。
JarOutputStream(OutputStream out, Manifest man)
使用指定的 Manifest 创建新的 JarOutputStream。
Manifest(InputStream is)
从指定的输入流构造新的 Manifest。

java.util.logging 中 IOException 的使用

抛出 IOException 的 java.util.logging 中的方法
void | LogManager.readConfiguration() 重新初始化日志属性并重新读取日志配置。
void | LogManager.readConfiguration(InputStream ins) 从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。

抛出 IOException 的 java.util.logging 中的构造方法
FileHandler()
构造一个默认的 FileHandler。
FileHandler(String pattern)
初始化要写入给定文件名的 FileHandler 。
FileHandler(String pattern, boolean append)
初始化要写入给定文件名的 FileHandler（使用可选的 append）。
FileHandler(String pattern, int limit, int count)
初始化要写入文件集的 FileHandler。
FileHandler(String pattern, int limit, int count, boolean append)
初始化要写入文件集的 FileHandler（使用可选的 append）。
SocketHandler()
仅使用 LogManager 属性（或其默认值）创建 SocketHandler。
SocketHandler(String host, int port)
构造一个带有指定主机和端口的 SocketHandler。

java.util.prefs 中 IOException 的使用

抛出 IOException 的 java.util.prefs 中的方法
 void AbstractPreferences.exportNode(OutputStream os)
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
abstract  void Preferences.exportNode(OutputStream os)
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
 void AbstractPreferences.exportSubtree(OutputStream os)
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
abstract  void Preferences.exportSubtree(OutputStream os)
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。
static void Preferences.importPreferences(InputStream is)
导入指定输入流中由 XML 文档表示的所有首选项。

java.util.zip 中 IOException 的使用

java.util.zip 中 IOException 的子类
 class ZipException
如果某种 ZIP 异常发生，则抛出此错误。

抛出 IOException 的 java.util.zip 中的方法
int | DeflaterInputStream.available() 在到达 EOF 后返回 0；否则始终返回 1。
int | ZipInputStream.available() 在 EOF 到达当前条目数据后，返回 0；否则，始终返回 1。
int | InflaterInputStream.available() 在到达 EOF 后返回 0；否则始终返回 1。
void | DeflaterInputStream.close() 关闭此输入流和它的底层输入流，丢弃挂起的未压缩数据。
void | InflaterOutputStream.close() 将剩余未压缩数据写入输出流并关闭底层输出流。
void | ZipOutputStream.close() 关闭 ZIP 输出流和正在过滤的流。
void | DeflaterOutputStream.close() 将剩余压缩数据写入输出流并关闭底层流。
void | GZIPInputStream.close() 关闭此输入流并释放与该流关联的所有系统资源。
void | ZipInputStream.close() 关闭此输入流并释放与此流关联的所有系统资源。
void | InflaterInputStream.close() 关闭此输入流并释放与该流关联的所有系统资源。
void | ZipFile.close() 关闭 ZIP 文件。
void | ZipOutputStream.closeEntry() 关闭当前 ZIP 条目并定位流以写入下一个条目。
void | ZipInputStream.closeEntry() 关闭当前 ZIP 条目并定位流以读取下一个条目。
protected void | DeflaterOutputStream.deflate() 将下一个压缩数据块写入输出流。
protected void | InflaterInputStream.fill() 使用更多要解压缩的数据填充输入缓冲区。
protected void | ZipFile.finalize() 确保不再引用此 ZIP 文件时调用它的 close 方法。
void | GZIPOutputStream.finish() 完成将压缩数据写入输出流的操作，无需关闭底层流。
void | InflaterOutputStream.finish() 完成将未压缩数据写入输出流的操作，无需关闭底层流。
void | ZipOutputStream.finish() 完成写入 ZIP 输出流的内容，无需关闭底层流。
void | DeflaterOutputStream.finish() 完成将压缩数据写入输出流的操作，无需关闭底层流。
void | InflaterOutputStream.flush() 刷新此输出流，并强制写出挂起的所有缓冲输出字节。
InputStream | ZipFile.getInputStream(ZipEntry entry) 返回输入流以读取指定 ZIP 文件条目的内容。
ZipEntry | ZipInputStream.getNextEntry() 读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。
void | ZipOutputStream.putNextEntry(ZipEntry e) 开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。
int | CheckedInputStream.read() 读取字节。
int | DeflaterInputStream.read() 从输入流读取一个压缩数据的单个字节。
int | InflaterInputStream.read() 读取未压缩数据的字节。
int | CheckedInputStream.read(byte[] buf, int off, int len) 读入字节数组。
int | DeflaterInputStream.read(byte[] b, int off, int len) 将压缩数据读入 byte 数组。
int | GZIPInputStream.read(byte[] buf, int off, int len) 将未压缩数据读入字节数组。
int | ZipInputStream.read(byte[] b, int off, int len) 从当前 ZIP 条目读入字节数组。
int | InflaterInputStream.read(byte[] b, int off, int len) 将未压缩数据读入字节数组。
void | DeflaterInputStream.reset() 不支持此操作。
void | InflaterInputStream.reset() 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
long | CheckedInputStream.skip(long n) 跳过指定的输入字节数。
long | DeflaterInputStream.skip(long n) 从输入流中跳过并丢弃数据。
long | ZipInputStream.skip(long n) 跳过当前 ZIP 条目中指定的字节数。
long | InflaterInputStream.skip(long n) 跳过指定的未压缩数据的字节数。
void | CheckedOutputStream.write(byte[] b, int off, int len) 写入字节数组。
void | GZIPOutputStream.write(byte[] buf, int off, int len) 将字节数组写入压缩输出流。
void | InflaterOutputStream.write(byte[] b, int off, int len) 将 byte 数组写入未压缩输出流。
void | ZipOutputStream.write(byte[] b, int off, int len) 将字节数组写入当前 ZIP 条目数据。
void | DeflaterOutputStream.write(byte[] b, int off, int len) 将字节数组写入压缩的输出流。
void | CheckedOutputStream.write(int b) 写入字节。
void | InflaterOutputStream.write(int b) 将字节写入未压缩输出流。
void | DeflaterOutputStream.write(int b) 将字节写入压缩的输出流。

抛出 IOException 的 java.util.zip 中的构造方法
GZIPInputStream(InputStream in)
使用默认缓冲区大小创建新的输入流。
GZIPInputStream(InputStream in, int size)
使用指定缓冲区大小创建新的输入流。
GZIPOutputStream(OutputStream out)
使用默认缓冲区大小创建新的输出流。
GZIPOutputStream(OutputStream out, int size)
使用指定缓冲区大小创建新的输出流。
ZipFile(File file)
打开供阅读的 ZIP 文件，由指定的 File 对象给出。
ZipFile(File file, int mode)
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。
ZipFile(String name)
打开 ZIP 文件进行阅读。

javax.activation 中 IOException 的使用

javax.activation 中 IOException 的子类
 class UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

抛出 IOException 的 javax.activation 中的方法
Object | CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader) 返回已实例化的 JavaBean 组件。
Object | DataHandler.getContent() 以其首选 Object 的形式返回数据。
Object | DataContentHandler.getContent(DataSource ds) 返回一个对象，该对象表示其首选形式的数据。
InputStream | DataHandler.getInputStream() 获取此对象的 InputSteam。
InputStream | DataSource.getInputStream() 此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。
InputStream | FileDataSource.getInputStream() 此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。
InputStream | URLDataSource.getInputStream() URL 的 getInputStream 方法。
OutputStream | DataHandler.getOutputStream() 获取此 DataHandler 的 OutputStream，以允许重写底层数据。
OutputStream | DataSource.getOutputStream() 此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。
OutputStream | FileDataSource.getOutputStream() 此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。
OutputStream | URLDataSource.getOutputStream() URL 的 getOutputStream 方法。
Object | DataHandler.getTransferData(DataFlavor flavor) 返回一个对象，该对象表示要传输的数据。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。
void | MimeType.readExternal(ObjectInput in) 对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。
void | CommandObject.setCommandContext(String verb, DataHandler dh) 用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。
void | MimeType.writeExternal(ObjectOutput out) 对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。
void | DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os) 将对象转换为指定 MIME 类型的字节流，并将其写入输出流。
void | DataHandler.writeTo(OutputStream os) 将数据写入 OutputStream。

抛出 IOException 的 javax.activation 中的构造方法
MailcapCommandMap(String fileName)
允许调用者指定 mailcap 文件路径的构造方法。
MimetypesFileTypeMap(String mimeTypeFileName)
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。

javax.activity 中 IOException 的使用

javax.activity 中 IOException 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation.processing 中 IOException 的使用

javax.annotation.processing 中 IOException 的子类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

抛出 IOException 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。

javax.crypto 中 IOException 的使用

抛出 IOException 的 javax.crypto 中的方法
int | CipherInputStream.available() 返回不发生阻塞地从此输入流读取的字节数。
void | CipherInputStream.close() 关闭该输入流并释放任何与该流关联的系统资源。
void | CipherOutputStream.close() 关闭此输出流并释放任何与此流关联的系统资源。
void | CipherOutputStream.flush() 强制写出已由封装的密码对象处理的任何缓存输出字节来刷新此输出流。
byte[] | EncryptedPrivateKeyInfo.getEncoded() 返回此对象的 ASN.1 编码。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
int | CipherInputStream.read() 从该输入流读取下一数据字节。
int | CipherInputStream.read(byte[] b) 从该输入流将 b.length 个数据字节读入到字节数组中。
int | CipherInputStream.read(byte[] b, int off, int len) 从该输入流将 len 个字节数据读入到字节数组中。
long | CipherInputStream.skip(long n) 跳过不发生阻塞地从该输入流读取的字节中的 n 个字节的输入。
void | CipherOutputStream.write(byte[] b) 从指定的字节数组中将 b.length 个字节写入此输出流。
void | CipherOutputStream.write(byte[] b, int off, int len) 将指定的字节数组中从 off 偏移量开始的 len 个字节写入此输出流。
void | CipherOutputStream.write(int b) 将指定的字节写入此输出流。

抛出 IOException 的 javax.crypto 中的构造方法
EncryptedPrivateKeyInfo(byte[] encoded)
根据其 ASN.1 编码构造（即解析）EncryptedPrivateKeyInfo。
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

javax.imageio 中 IOException 的使用

javax.imageio 中 IOException 的子类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

抛出 IOException 的 javax.imageio 中的方法
boolean | ImageWriter.canInsertEmpty(int imageIndex) 如果 writer 支持在给定索引处插入新的空图像，则返回 true。
boolean | ImageWriter.canInsertImage(int imageIndex) 如果 writer 支持在给定索引处插入新图像，则返回 true。
boolean | ImageWriter.canRemoveImage(int imageIndex) 如果 writer 支持在给定索引处移除现有图像，则返回 true。
boolean | ImageWriter.canReplaceImageMetadata(int imageIndex) 如果有可能使用索引 imageIndex 替换与现有图像有关的图像元数据，则返回 true。
boolean | ImageWriter.canReplacePixels(int imageIndex) 如果 writer 允许使用 replacePixels 方法替换给定图像的索引，则返回 true。
boolean | ImageWriter.canReplaceStreamMetadata() 如果有可能替换已存在于输出中的流元数据，则返回 true。
boolean | ImageWriter.canWriteEmpty() 如果 writer 支持写入由单个图像组成的完整图像流，则返回 true，这些对象带有要输出的不确定像素值、有关元数据和缩略图。
static ImageInputStream | ImageIO.createImageInputStream(Object input) 返回一个 ImageInputStream，它将从给定 Object 中获取输入。
static ImageOutputStream | ImageIO.createImageOutputStream(Object output) 返回一个 ImageOutputStream，它将其输出发送到给定 Object。
void | ImageWriter.endInsertEmpty() 完成对新图像的插入，该操作是从以前调用 prepareInsertEmpty 开始的。
void | ImageWriter.endReplacePixels() 终止调用 replacePixels 的序列。
void | ImageWriter.endWriteEmpty() 完成对新图像的写入，该操作是从优先调用 prepareWriteEmpty 开始的。
void | ImageWriter.endWriteSequence() 完成以 prepareWriteSequence 开头的一系列图像的写入。
float | ImageReader.getAspectRatio(int imageIndex) 以 float 的形式返回给定图像的高宽比（即宽度除以高度）。
String | ImageReader.getFormatName() 返回一个标识输入源格式的 String。
abstract int | ImageReader.getHeight(int imageIndex) 返回输入源中的给定图像的高度，以像素为单位。
abstract IIOMetadata | ImageReader.getImageMetadata(int imageIndex) 返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames) 返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
abstract Iterator<ImageTypeSpecifier> | ImageReader.getImageTypes(int imageIndex) 以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。
abstract int | ImageReader.getNumImages(boolean allowSearch) 返回当前输入源中可用的图像数，不包括缩略图。
int | ImageReader.getNumThumbnails(int imageIndex) 返回与给定图像关联的缩略图预览图像的数量。
ImageTypeSpecifier | ImageReader.getRawImageType(int imageIndex) 返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。
abstract IIOMetadata | ImageReader.getStreamMetadata() 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames) 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。
int | ImageReader.getThumbnailHeight(int imageIndex, int thumbnailIndex) 返回通过索引 thumbnailIndex 指定的缩略图预览图像的高度，其与通过索引 ImageIndex 指定的图像关联。
int | ImageReader.getThumbnailWidth(int imageIndex, int thumbnailIndex) 返回通过索引 thumbnailIndex 指定的缩略图预览图像的宽度，其与通过索引 ImageIndex 指定的图像关联。
int | ImageReader.getTileGridXOffset(int imageIndex) 返回给定图像中 tile (0, 0) 的左上角的 X 坐标。
int | ImageReader.getTileGridYOffset(int imageIndex) 返回给定图像中 tile (0, 0) 的左上角的 Y 坐标。
int | ImageReader.getTileHeight(int imageIndex) 返回给定图像中 tile 的高度。
int | ImageReader.getTileWidth(int imageIndex) 返回给定图像中 tile 的宽度。
abstract int | ImageReader.getWidth(int imageIndex) 返回输入源中的给定图像的宽度，以像素为单位。
boolean | ImageReader.hasThumbnails(int imageIndex) 如果给定图像具有与之关联的缩略图预览图像，则返回 true。
boolean | ImageReader.isImageTiled(int imageIndex) 如果图像被组织成 tile（即等大小的非重叠矩形），则返回 true。
boolean | ImageReader.isRandomAccessEasy(int imageIndex) 如果给定图像的存储格式不会给像素的随机访问带来内在妨碍，则返回 true。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareReplacePixels(int imageIndex, Rectangle region) 准备好 writer，处理一系列对 replacePixels 方法的调用。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | ImageWriter.prepareWriteSequence(IIOMetadata streamMetadata) 使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。
static BufferedImage | ImageIO.read(File input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
static BufferedImage | ImageIO.read(ImageInputStream stream) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。
static BufferedImage | ImageIO.read(InputStream input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。
BufferedImage | ImageReader.read(int imageIndex) 使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。
abstract BufferedImage | ImageReader.read(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
static BufferedImage | ImageIO.read(URL input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。
IIOImage | ImageReader.readAll(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。
Iterator<IIOImage> | ImageReader.readAll(Iterator<? extends ImageReadParam> params) 以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。
RenderedImage | ImageReader.readAsRenderedImage(int imageIndex, ImageReadParam param) 返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。
Raster | ImageReader.readRaster(int imageIndex, ImageReadParam param) 返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。
BufferedImage | ImageReader.readThumbnail(int imageIndex, int thumbnailIndex) 以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。
BufferedImage | ImageReader.readTile(int imageIndex, int tileX, int tileY) 读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。
Raster | ImageReader.readTileRaster(int imageIndex, int tileX, int tileY) 返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。
void | ImageWriter.removeImage(int imageIndex) 从流中移除图像。
void | ImageWriter.replaceImageMetadata(int imageIndex, IIOMetadata imageMetadata) 替换与现有图像有关的图像元数据。
void | ImageWriter.replacePixels(Raster raster, ImageWriteParam param) 用给定 Raster 部分替换已出现在输出中的图像部分。
void | ImageWriter.replacePixels(RenderedImage image, ImageWriteParam param) 用给定图像部分替换已出现在输出中的图像部分。
void | ImageWriter.replaceStreamMetadata(IIOMetadata streamMetadata) 使用新信息替换输出中的流元数据。
void | ImageWriter.write(IIOImage image) 将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
void | ImageWriter.write(RenderedImage image) 将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。
static boolean | ImageIO.write(RenderedImage im, String formatName, File output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 File。
static boolean | ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。
static boolean | ImageIO.write(RenderedImage im, String formatName, OutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。
void | ImageWriter.writeInsert(int imageIndex, IIOImage image, ImageWriteParam param) 将新的图像插入现有图像流。
void | ImageWriter.writeToSequence(IIOImage image, ImageWriteParam param) 将单幅图像、可能相关的元数据和缩略图添加到输出中。

javax.imageio.metadata 中 IOException 的使用

javax.imageio.metadata 中 IOException 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

javax.imageio.spi 中 IOException 的使用

抛出 IOException 的 javax.imageio.spi 中的方法
abstract boolean | ImageReaderSpi.canDecodeInput(Object source) 如果给定的源对象看起来是此 reader 支持的格式，则返回 true。
ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
abstract ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
abstract ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
ImageReader | ImageReaderSpi.createReaderInstance() 返回与此服务提供者关联的 ImageReader 实现的实例。
abstract ImageReader | ImageReaderSpi.createReaderInstance(Object extension) 返回与此服务提供者关联的 ImageReader 实现的实例。
ImageWriter | ImageWriterSpi.createWriterInstance() 返回与此服务提供者关联的 ImageWriter 实现的实例。
abstract ImageWriter | ImageWriterSpi.createWriterInstance(Object extension) 返回与此服务提供者关联的 ImageWriter 实现的实例。

javax.imageio.stream 中 IOException 的使用

抛出 IOException 的 javax.imageio.stream 中的方法
protected  void ImageInputStreamImpl.checkClosed()
如果已经关闭流，则抛出 IOException。
 void FileCacheImageInputStream.close()
关闭此 FileCacheImageInputStream，关闭并移除缓存文件。
 void FileCacheImageOutputStream.close()
关闭此 FileCacheImageOututStream。
 void FileImageInputStream.close()
 void FileImageOutputStream.close()
 void ImageInputStream.close()
关闭流。
 void ImageInputStreamImpl.close()
 void MemoryCacheImageInputStream.close()
关闭此 MemoryCacheImageInputStream，释放缓存。
 void MemoryCacheImageOutputStream.close()
关闭此 MemoryCacheImageOutputStream。
 void ImageInputStream.flush()
丢弃当前流位置之前的流初始部分。
 void ImageInputStreamImpl.flush()
 void FileCacheImageOutputStream.flushBefore(long pos)
 void ImageInputStream.flushBefore(long pos)
丢弃所指示位置之前的流初始部分。
 void ImageInputStreamImpl.flushBefore(long pos)
 void ImageOutputStream.flushBefore(long pos)
刷新给定位置之前所有数据的缓冲并转到底层目标（如 OutputStream 或 File）。
 void MemoryCacheImageInputStream.flushBefore(long pos)
 void MemoryCacheImageOutputStream.flushBefore(long pos)
protected  void ImageOutputStreamImpl.flushBits()
如果位偏移量为非零，则将当前字节中的剩余位强制归 0，并将流位置前移一个字节。
 int ImageInputStream.getBitOffset()
以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。
 int ImageInputStreamImpl.getBitOffset()
 long ImageInputStream.getStreamPosition()
返回流的当前字节位置。
 long ImageInputStreamImpl.getStreamPosition()
 long ImageInputStream.length()
返回流的总长度（如果已知）。
 int FileCacheImageInputStream.read()
 int FileCacheImageOutputStream.read()
 int FileImageInputStream.read()
 int FileImageOutputStream.read()
 int ImageInputStream.read()
从流中读取单个字节，并以整数（0 到 255 之间）形式返回该字节。
abstract  int ImageInputStreamImpl.read()
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
 int MemoryCacheImageInputStream.read()
 int MemoryCacheImageOutputStream.read()
 int ImageInputStream.read(byte[] b)
从流中读取至多 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
 int ImageInputStreamImpl.read(byte[] b)
调用 read(b, 0, b.length) 的便捷方法。
 int FileCacheImageInputStream.read(byte[] b, int off, int len)
 int FileCacheImageOutputStream.read(byte[] b, int off, int len)
 int FileImageInputStream.read(byte[] b, int off, int len)
 int FileImageOutputStream.read(byte[] b, int off, int len)
 int ImageInputStream.read(byte[] b, int off, int len)
从流中读取至多 len 个字节，并将其存储到 b 中（从索引 off 开始）。
abstract  int ImageInputStreamImpl.read(byte[] b, int off, int len)
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
 int MemoryCacheImageInputStream.read(byte[] b, int off, int len)
 int MemoryCacheImageOutputStream.read(byte[] b, int off, int len)
 int ImageInputStream.readBit()
从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。
 int ImageInputStreamImpl.readBit()
 long ImageInputStream.readBits(int numBits)
从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。
 long ImageInputStreamImpl.readBits(int numBits)
 boolean ImageInputStream.readBoolean()
从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。
 boolean ImageInputStreamImpl.readBoolean()
 byte ImageInputStream.readByte()
从流中读取一个字节，并以 byte 值的形式返回该字节。
 byte ImageInputStreamImpl.readByte()
 void ImageInputStream.readBytes(IIOByteBuffer buf, int len)
从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
 void ImageInputStreamImpl.readBytes(IIOByteBuffer buf, int len)
 char ImageInputStream.readChar()
与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。
 char ImageInputStreamImpl.readChar()
 double ImageInputStream.readDouble()
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。
 double ImageInputStreamImpl.readDouble()
 float ImageInputStream.readFloat()
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。
 float ImageInputStreamImpl.readFloat()
 void ImageInputStream.readFully(byte[] b)
从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
 void ImageInputStreamImpl.readFully(byte[] b)
 void ImageInputStream.readFully(byte[] b, int off, int len)
从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(byte[] b, int off, int len)
 void ImageInputStream.readFully(char[] c, int off, int len)
根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(char[] c, int off, int len)
 void ImageInputStream.readFully(double[] d, int off, int len)
根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(double[] d, int off, int len)
 void ImageInputStream.readFully(float[] f, int off, int len)
根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(float[] f, int off, int len)
 void ImageInputStream.readFully(int[] i, int off, int len)
根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(int[] i, int off, int len)
 void ImageInputStream.readFully(long[] l, int off, int len)
根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(long[] l, int off, int len)
 void ImageInputStream.readFully(short[] s, int off, int len)
根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。
 void ImageInputStreamImpl.readFully(short[] s, int off, int len)
 int ImageInputStream.readInt()
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。
 int ImageInputStreamImpl.readInt()
 String ImageInputStream.readLine()
从输入流中读取文本的下一行。
 String ImageInputStreamImpl.readLine()
 long ImageInputStream.readLong()
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。
 long ImageInputStreamImpl.readLong()
 short ImageInputStream.readShort()
从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。
 short ImageInputStreamImpl.readShort()
 int ImageInputStream.readUnsignedByte()
从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。
 int ImageInputStreamImpl.readUnsignedByte()
 long ImageInputStream.readUnsignedInt()
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。
 long ImageInputStreamImpl.readUnsignedInt()
 int ImageInputStream.readUnsignedShort()
从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。
 int ImageInputStreamImpl.readUnsignedShort()
 String ImageInputStream.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。
 String ImageInputStreamImpl.readUTF()
 void ImageInputStream.reset()
返回在最近一次非匹配地调用 mark 时指向上一个位置（包括位偏移量）的流指针。
 void ImageInputStreamImpl.reset()
根据标记的堆栈重置当前流字节和位位置。
 void FileCacheImageOutputStream.seek(long pos)
设置当前流位置并将位偏移量重置为 0。
 void FileImageInputStream.seek(long pos)
 void FileImageOutputStream.seek(long pos)
设置当前流位置并将位偏移量重置为 0。
 void ImageInputStream.seek(long pos)
将当前流位置设置为所需的位置。
 void ImageInputStreamImpl.seek(long pos)
 void ImageInputStream.setBitOffset(int bitOffset)
将位偏移量设置为 0 到 7 之间（包含两者）的整数。
 void ImageInputStreamImpl.setBitOffset(int bitOffset)
 int ImageInputStream.skipBytes(int n)
将流位置向前移动给定的字节数。
 int ImageInputStreamImpl.skipBytes(int n)
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
 long ImageInputStream.skipBytes(long n)
将流位置向前移动给定的字节数。
 long ImageInputStreamImpl.skipBytes(long n)
通过调用 seek(getStreamPosition() + n) 推进当前流位置。
 void ImageOutputStream.write(byte[] b)
将字节序列写入到流中的当前位置。
 void ImageOutputStreamImpl.write(byte[] b)
 void FileCacheImageOutputStream.write(byte[] b, int off, int len)
 void FileImageOutputStream.write(byte[] b, int off, int len)
 void ImageOutputStream.write(byte[] b, int off, int len)
将字节序列写入到流中的当前位置。
abstract  void ImageOutputStreamImpl.write(byte[] b, int off, int len)
 void MemoryCacheImageOutputStream.write(byte[] b, int off, int len)
 void FileCacheImageOutputStream.write(int b)
 void FileImageOutputStream.write(int b)
 void ImageOutputStream.write(int b)
将单个字节写入到流中的当前位置。
abstract  void ImageOutputStreamImpl.write(int b)
 void MemoryCacheImageOutputStream.write(int b)
 void ImageOutputStream.writeBit(int bit)
将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。
 void ImageOutputStreamImpl.writeBit(int bit)
 void ImageOutputStream.writeBits(long bits, int numBits)
将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。
 void ImageOutputStreamImpl.writeBits(long bits, int numBits)
 void ImageOutputStream.writeBoolean(boolean v)
将一个 boolean 值写入到流中。
 void ImageOutputStreamImpl.writeBoolean(boolean v)
 void ImageOutputStream.writeByte(int v)
将 v 的 8 个低位写入到流中。
 void ImageOutputStreamImpl.writeByte(int v)
 void ImageOutputStream.writeBytes(String s)
将一个字符串写入输出流。
 void ImageOutputStreamImpl.writeBytes(String s)
 void ImageOutputStream.writeChar(int v)
此方法与 writeShort 同义。
 void ImageOutputStreamImpl.writeChar(int v)
 void ImageOutputStream.writeChars(char[] c, int off, int len)
将 char 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeChars(char[] c, int off, int len)
 void ImageOutputStream.writeChars(String s)
将一个字符串写入输出流。
 void ImageOutputStreamImpl.writeChars(String s)
 void ImageOutputStream.writeDouble(double v)
将一个 double 值写入输出流，该值由四个字节组成。
 void ImageOutputStreamImpl.writeDouble(double v)
 void ImageOutputStream.writeDoubles(double[] d, int off, int len)
将 double 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeDoubles(double[] d, int off, int len)
 void ImageOutputStream.writeFloat(float v)
将一个 float 值（由四个字节组成）写入输出流。
 void ImageOutputStreamImpl.writeFloat(float v)
 void ImageOutputStream.writeFloats(float[] f, int off, int len)
将 float 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeFloats(float[] f, int off, int len)
 void ImageOutputStream.writeInt(int v)
将 v 的 32 个位写入到流中。
 void ImageOutputStreamImpl.writeInt(int v)
 void ImageOutputStream.writeInts(int[] i, int off, int len)
将 int 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeInts(int[] i, int off, int len)
 void ImageOutputStream.writeLong(long v)
将 v 的 64 个位写入到流中。
 void ImageOutputStreamImpl.writeLong(long v)
 void ImageOutputStream.writeLongs(long[] l, int off, int len)
将 long 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeLongs(long[] l, int off, int len)
 void ImageOutputStream.writeShort(int v)
将 v 的 16 个低位写入到流中。
 void ImageOutputStreamImpl.writeShort(int v)
 void ImageOutputStream.writeShorts(short[] s, int off, int len)
将 short 序列写入到流中的当前位置。
 void ImageOutputStreamImpl.writeShorts(short[] s, int off, int len)
 void ImageOutputStream.writeUTF(String s)
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
 void ImageOutputStreamImpl.writeUTF(String s)

抛出 IOException 的 javax.imageio.stream 中的构造方法
FileCacheImageInputStream(InputStream stream, File cacheDir)
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
FileCacheImageOutputStream(OutputStream stream, File cacheDir)
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
FileImageInputStream(File f)
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageOutputStream(File f)
构造一个将向给定 File 进行写入的 FileImageOutputStream。

javax.management 中 IOException 的使用

抛出 IOException 的 javax.management 中的方法
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
AttributeList | MBeanServerConnection.getAttributes(ObjectName name, String[] attributes) 获得指定 MBean 的多个属性值。
String | MBeanServerConnection.getDefaultDomain() 返回对 MBean 命名时使用的默认域。
String[] | MBeanServerConnection.getDomains() 返回其中所有 MBean 当前已注册的域的列表。
Integer | MBeanServerConnection.getMBeanCount() 返回 MBean 服务器中已注册的 MBean 数目。
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。
ObjectInstance | MBeanServerConnection.getObjectInstance(ObjectName name) 获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
Object | MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature) 在 MBean 上调用某个操作。
boolean | MBeanServerConnection.isInstanceOf(ObjectName name, String className) 如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
boolean | MBeanServerConnection.isRegistered(ObjectName name) 检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。
void | MBeanServerConnection.unregisterMBean(ObjectName name) 从 MBean 服务器中注销一个 MBean。

javax.management.loading 中 IOException 的使用

抛出 IOException 的 javax.management.loading 中的方法
Enumeration<URL> | MLetMBean.getResources(String name) 查找所有具有给定名称的资源。
void | MLet.readExternal(ObjectInput in) 从给定的 ObjectInput 恢复此 MLet 的内容。
void | MLet.writeExternal(ObjectOutput out) 将此 MLet 的内容保存到给定的 ObjectOutput。

javax.management.remote 中 IOException 的使用

javax.management.remote 中 IOException 的子类
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

抛出 IOException 的 javax.management.remote 中的方法
void | JMXConnector.close() 关闭客户端到其服务器的连接。
void | JMXConnector.connect() 建立到连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
void | JMXConnector.connect(Map<String,?> env) 建立到连接器服务器的连接。
String | JMXConnector.getConnectionId() 获得来自连接器服务器的连接 ID。
MBeanServerConnection | JMXConnector.getMBeanServerConnection() 返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
MBeanServerConnection | JMXConnector.getMBeanServerConnection(Subject delegationSubject) 返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。
void | JMXConnectorServerMBean.start() 激活连接器服务器，即开始侦听客户端连接。
void | JMXConnectorServerMBean.stop() 取消激活连接器服务器，即停止对客户端连接的侦听。
JMXConnector | JMXConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
JMXConnector | JMXConnectorServerMBean.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

javax.management.remote.rmi 中 IOException 的使用

抛出 IOException 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
protected  void RMIServerImpl.clientClosed(RMIConnection client)
关闭由 makeClient 创建的客户端连接时调用的方法。
 void RMIConnection.close()
关闭此连接。
 void RMIConnectionImpl.close()
 void RMIConnectionImpl_Stub.close()
 void RMIConnector.close()
 void RMIServerImpl.close()
关闭此连接服务器。
protected  void RMIIIOPServerImpl.closeClient(RMIConnection client)
protected  void RMIJRMPServerImpl.closeClient(RMIConnection client)
protected abstract  void RMIServerImpl.closeClient(RMIConnection client)
关闭由 makeClient 建立的客户端连接。
protected  void RMIIIOPServerImpl.closeServer()
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
protected  void RMIJRMPServerImpl.closeServer()
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
protected abstract  void RMIServerImpl.closeServer()
由 RMIServerImpl.close() 调用以关闭连接器服务器。
 void RMIConnector.connect()
 void RMIConnector.connect(Map<String,?> environment)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
protected  void RMIIIOPServerImpl.export()
protected  void RMIJRMPServerImpl.export()
protected abstract  void RMIServerImpl.export()
导出此 RMI 对象。
 NotificationResult RMIConnection.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
检索来自连接器服务器的通知。
 NotificationResult RMIConnectionImpl.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
 NotificationResult RMIConnectionImpl_Stub.fetchNotifications(long $param_long_1, int $param_int_2, long $param_long_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 String RMIConnection.getConnectionId()
返回连接 ID。
 String RMIConnectionImpl.getConnectionId()
 String RMIConnectionImpl_Stub.getConnectionId()
 String RMIConnector.getConnectionId()
 String RMIConnection.getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。
 String RMIConnectionImpl.getDefaultDomain(Subject delegationSubject)
 String RMIConnectionImpl_Stub.getDefaultDomain(Subject $param_Subject_1)
 String[] RMIConnection.getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。
 String[] RMIConnectionImpl.getDomains(Subject delegationSubject)
 String[] RMIConnectionImpl_Stub.getDomains(Subject $param_Subject_1)
 Integer RMIConnection.getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 Integer RMIConnectionImpl.getMBeanCount(Subject delegationSubject)
 Integer RMIConnectionImpl_Stub.getMBeanCount(Subject $param_Subject_1)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 MBeanServerConnection RMIConnector.getMBeanServerConnection()
 MBeanServerConnection RMIConnector.getMBeanServerConnection(Subject delegationSubject)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 boolean RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
protected  RMIConnection RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
protected  RMIConnection RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
protected abstract  RMIConnection RMIServerImpl.makeClient(String connectionId, Subject subject)
创建一个新的客户端连接。
 RMIConnection RMIServer.newClient(Object credentials)
建立一个使用该 RMI 连接器的新连接。
 RMIConnection RMIServerImpl.newClient(Object credentials)
创建一个新的客户端连接。
 RMIConnection RMIServerImpl_Stub.newClient(Object $param_Object_1)
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnectorServer.start()
激活连接器服务器，即启动对客户端连接的侦听。
 void RMIConnectorServer.stop()
取消激活连接器服务器，即停止对客户端连接的侦听。
 JMXConnector RMIConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。
 Remote RMIIIOPServerImpl.toStub()
返回一个 IIOP stub。
 Remote RMIJRMPServerImpl.toStub()
返回此 RMIServer 对象的可序列化的 stub。
abstract  Remote RMIServerImpl.toStub()
返回此服务器对象的可远程化的 stub。
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

抛出 IOException 的 javax.management.remote.rmi 中的构造方法
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIIIOPServerImpl(Map<String,?> env)
创建新的 RMIServerImpl。
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

javax.naming.ldap 中 IOException 的使用

抛出 IOException 的 javax.naming.ldap 中的方法
abstract void | StartTlsResponse.close() 妥善地关闭 TLS 连接并转换回底层连接。
abstract SSLSession | StartTlsResponse.negotiate() 使用默认的 SSL 套接字工厂协商 TLS 会话。
abstract SSLSession | StartTlsResponse.negotiate(SSLSocketFactory factory) 使用 SSL 套接字工厂协商 TLS 会话。

抛出 IOException 的 javax.naming.ldap 中的构造方法
PagedResultsControl(int pageSize, boolean criticality)
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsControl(int pageSize, byte[] cookie, boolean criticality)
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsResponseControl(String id, boolean criticality, byte[] value)
构造分页结果响应控件。
SortControl(SortKey[] sortBy, boolean criticality)
构造一个控件来对排序键列表进行排序。
SortControl(String[] sortBy, boolean criticality)
构造一个控件来按升序对属性列表进行排序。
SortControl(String sortBy, boolean criticality)
构造一个控件来按升序对单个属性进行排序。
SortResponseControl(String id, boolean criticality, byte[] value)
构造一个控件来指示排序请求的结果。

javax.net 中 IOException 的使用

抛出 IOException 的 javax.net 中的方法
ServerSocket | ServerSocketFactory.createServerSocket() 返回未绑定的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port) 返回绑定到指定端口的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog) 返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog, InetAddress ifAddress) 返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。
Socket | SocketFactory.createSocket() 创建一个未连接的套接字。
abstract Socket | SocketFactory.createSocket(InetAddress host, int port) 创建一个套接字并把它连接到指定地址上的指定端口号。
abstract Socket | SocketFactory.createSocket(InetAddress address, int port, InetAddress localAddress, int localPort) 创建一个套接字并把它连接到指定远程端口上的指定远程地址。
abstract Socket | SocketFactory.createSocket(String host, int port) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 IOException 的使用

javax.net.ssl 中 IOException 的子类
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

抛出 IOException 的 javax.net.ssl 中的方法
abstract Socket | SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose) 返回在连接到指定主机的给定端口的现有套接字上分层的套接字。
abstract void | SSLSocket.startHandshake() 在此连接上开始 SSL 握手。

抛出 IOException 的 javax.net.ssl 中的构造方法
SSLServerSocket()
仅供子类使用。
SSLServerSocket(int port)
仅供子类使用。
SSLServerSocket(int port, int backlog)
仅供子类使用。
SSLServerSocket(int port, int backlog, InetAddress address)
仅供子类使用。
SSLSocket(InetAddress address, int port)
仅供子类使用。
SSLSocket(InetAddress address, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。
SSLSocket(String host, int port)
仅供子类使用。
SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

javax.print 中 IOException 的使用

抛出 IOException 的 javax.print 中的方法
Doc | MultiDoc.getDoc() 获取当前的 doc 对象。
Object | Doc.getPrintData() 获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。
Object | SimpleDoc.getPrintData()
Reader | Doc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
Reader | SimpleDoc.getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
InputStream | Doc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。
InputStream | SimpleDoc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。
MultiDoc | MultiDoc.next() 转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。

javax.rmi.CORBA 中 IOException 的使用

抛出 IOException 的 javax.rmi.CORBA 中的方法
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。
 void StubDelegate.writeObject(Stub self, ObjectOutputStream s)
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

javax.rmi.ssl 中 IOException 的使用

抛出 IOException 的 javax.rmi.ssl 中的方法
ServerSocket | SslRMIServerSocketFactory.createServerSocket(int port) 创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。
Socket | SslRMIClientSocketFactory.createSocket(String host, int port) 创建一个 SSL 套接字。

javax.security.auth.callback 中 IOException 的使用

抛出 IOException 的 javax.security.auth.callback 中的方法
 void CallbackHandler.handle(Callback[] callbacks)
获取或显示在提供的 Callback 中请求的信息。

javax.security.sasl 中 IOException 的使用

javax.security.sasl 中 IOException 的子类
class | AuthenticationException 此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

javax.sound.midi 中 IOException 的使用

抛出 IOException 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。
void | Sequencer.setSequence(InputStream stream) 设置 sequencer 所操作的当前 sequence。
static int | MidiSystem.write(Sequence in, int type, File out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。
static int | MidiSystem.write(Sequence in, int fileType, OutputStream out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。

javax.sound.midi.spi 中 IOException 的使用

抛出 IOException 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。
abstract int | MidiFileWriter.write(Sequence in, int fileType, File out) 写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。
abstract int | MidiFileWriter.write(Sequence in, int fileType, OutputStream out) 写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。

javax.sound.sampled 中 IOException 的使用

抛出 IOException 的 javax.sound.sampled 中的方法
int | AudioInputStream.available() 返回可不受阻塞地从此音频输入流中读取（或跳过）的最大字节数。
void | AudioInputStream.close() 关闭此音频输入流并释放与该流关联的所有系统资源。
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。
void | Clip.open(AudioInputStream stream) 使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。
int | AudioInputStream.read() 从音频输入流读取数据下一个字节。
int | AudioInputStream.read(byte[] b) 从音频输入流读取一定数量的字节，并将其存储在缓冲区数组 b 中。
int | AudioInputStream.read(byte[] b, int off, int len) 从音频流读取指定的最大数量的数据字节，并将其放入给定的字节数组中。
void | AudioInputStream.reset() 将此音频输入流重新定位到上一次调用其 mark 方法时的位置。
long | AudioInputStream.skip(long n) 跳过并丢弃此音频输入流中指定数量的字节。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示指定文件类型的音频文件的字节流写入所提供的输出流。

javax.sound.sampled.spi 中 IOException 的使用

抛出 IOException 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

javax.sql.rowset 中 IOException 的使用

抛出 IOException 的 javax.sql.rowset 中的方法
void | WebRowSet.readXml(InputStream iStream) 读取基于流的 XML 输入，以填充此 WebRowSet 对象。
void | WebRowSet.writeXml(OutputStream oStream) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
void | WebRowSet.writeXml(ResultSet rs, OutputStream oStream) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。

javax.swing 中 IOException 的使用

抛出 IOException 的 javax.swing 中的方法
void | ProgressMonitorInputStream.close() 重写 FilterInputStream.close，以便关闭进度监视器以及流。
protected InputStream | JEditorPane.getStream(URL page) 获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。
int | ProgressMonitorInputStream.read() 重写 FilterInputStream.read，以便在读取之后更新进度监视器。
int | ProgressMonitorInputStream.read(byte[] b) 重写 FilterInputStream.read，以读取之后更新进度监视器。
int | ProgressMonitorInputStream.read(byte[] b, int off, int len) 重写 FilterInputStream.read，以便在读取之后更新进度监视器。
void | JEditorPane.read(InputStream in, Object desc) 此方法根据流进行初始化。
void | ProgressMonitorInputStream.reset() 重写 FilterInputStream.reset，以重置进度监视器以及流。
void | JEditorPane.setPage(String url) 设置当前要显示的 URL。
void | JEditorPane.setPage(URL page) 设置当前要显示的 URL。
long | ProgressMonitorInputStream.skip(long n) 重写 FilterInputStream.skip，以便在跳过之后更新进度监视器。

抛出 IOException 的 javax.swing 中的构造方法
JEditorPane(String url)
根据包含 URL 规范的字符串创建一个 JEditorPane。
JEditorPane(URL initialPage)
根据用作输入的指定 URL 创建一个 JEditorPane。

javax.swing.filechooser 中 IOException 的使用

抛出 IOException 的 javax.swing.filechooser 中的方法
abstract  File FileSystemView.createNewFolder(File containingDir)
创建具有默认文件夹名称的新文件夹。

javax.swing.plaf.synth 中 IOException 的使用

抛出 IOException 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(URL url)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text 中 IOException 的使用

javax.swing.text 中 IOException 的子类
 class ChangedCharSetException
顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

抛出 IOException 的 javax.swing.text 中的方法
protected void | AbstractWriter.indent() 执行缩进。
protected void | AbstractWriter.output(char[] content, int start, int length) 写出内容过程的最后一步。
void | DefaultEditorKit.read(InputStream in, Document doc, int pos) 插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | EditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | DefaultEditorKit.read(Reader in, Document doc, int pos) 插入取自给定流的内容，它将被视为纯文本。
abstract void | EditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。
void | JTextComponent.read(Reader in, Object desc) 根据流进行初始化。
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。
protected void | AbstractWriter.text(Element elem) 写出文本。
protected abstract void | AbstractWriter.write() 需要由子类实现此抽象方法。
protected void | AbstractWriter.write(char ch) 写出字符。
protected void | AbstractWriter.write(char[] chars, int startIndex, int length) 所有 write 方法都调用到此方法。
void | DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract void | EditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
protected void | AbstractWriter.write(String content) 写出字符串。
void | JTextComponent.write(Writer out) 将模型的内容存储到给定的流中。
void | DefaultEditorKit.write(Writer out, Document doc, int pos, int len) 将取自文档的内容以纯文本格式写入给定流。
abstract void | EditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
protected void | AbstractWriter.writeAttributes(AttributeSet attr) 以 " =" 对的形式写出属性集。
void | StyleContext.writeAttributes(ObjectOutputStream out, AttributeSet a) 写出属性的特定于上下文的处理。
static void | StyleContext.writeAttributeSet(ObjectOutputStream out, AttributeSet a) 将属性集写入到给定的对象流以便序列化。
protected void | AbstractWriter.writeLineSeparator() 写入行分隔符。

javax.swing.text.html 中 IOException 的使用

抛出 IOException 的 javax.swing.text.html 中的方法
protected  void HTMLWriter.closeOutUnwantedEmbeddedTags(AttributeSet attr)
搜索属性集和存储在标记向量中的每个标记。
protected  void HTMLWriter.comment(Element elem)
写出注释。
protected  void HTMLWriter.emptyTag(Element elem)
写出所有空元素（没有对应结束标记的所有标记）。
protected  void MinimalHTMLWriter.endFontTag()
此方法已不再使用，而用写出 <span> 来替换。
protected  void HTMLWriter.endTag(Element elem)
写出元素的结束标记。
 void HTMLDocument.insertAfterEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之后。
 void HTMLDocument.insertAfterStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的起始处。
 void HTMLDocument.insertBeforeEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的结尾处。
 void HTMLDocument.insertBeforeStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之前。
 void HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
将 HTML 插入现有文档。
 void StyleSheet.loadRules(Reader in, URL ref)
加载 CSS1 语法中指定的规则集合。
protected  void HTMLWriter.output(char[] chars, int start, int length)
重写此方法来映射任何字符实体，例如 < 映射到 <。
abstract  void HTMLEditorKit.Parser.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
解析给定的流并通过解析的结果驱动给定的回调。
 void HTMLEditorKit.read(Reader in, Document doc, int pos)
插入来自给定流的内容。
protected  void HTMLWriter.selectContent(AttributeSet attr)
写出 SELECT 表单元素的内容。
 void HTMLDocument.setInnerHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换给定元素的子元素。
 void HTMLDocument.setOuterHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换父元素中的给定元素。
protected  void MinimalHTMLWriter.startFontTag(String style)
此方法已不再使用，而用写出 <span> 来替换。
protected  void HTMLWriter.startTag(Element elem)
写出元素的开始标记。
protected  void HTMLWriter.text(Element elem)
写出文本。
protected  void MinimalHTMLWriter.text(Element elem)
写出文本。
protected  void HTMLWriter.textAreaContent(AttributeSet attr)
写出 TEXTAREA 表单元素中所包含的文本。
 void HTMLWriter.write()
对 Element 树进行迭代并控制所有标记及其属性的写出。
 void MinimalHTMLWriter.write()
从 StyledDocument 生成 HTML 输出。
 void HTMLEditorKit.write(Writer out, Document doc, int pos, int len)
以适合此类内容处理程序的格式，将文档中的内容写入给定流。
protected  void HTMLWriter.writeAttributes(AttributeSet attr)
写出属性集。
protected  void MinimalHTMLWriter.writeAttributes(AttributeSet attr)
写出以下类型的所有属性：StyleConstants.ParagraphConstants、StyleConstants.CharacterConstants、StyleConstants.FontConstants、StyleConstants.ColorConstants。
protected  void MinimalHTMLWriter.writeBody()
对文档中的元素进行迭代，并基于元素是分支元素还是叶元素来处理它们。
protected  void MinimalHTMLWriter.writeComponent(Element elem)
负责处理 Component Elements；有意不实现它。
protected  void MinimalHTMLWriter.writeContent(Element elem, boolean needsIndenting)
以与 HTML 兼容的方式写出属性集。
protected  void HTMLWriter.writeEmbeddedTags(AttributeSet attr)
搜索 AttributeSet 中的嵌入式标记并写出它们。
protected  void MinimalHTMLWriter.writeEndParagraph()
发出 <p> 标记的结束标记。
protected  void MinimalHTMLWriter.writeEndTag(String endTag)
写出适当缩进的结束标记。
protected  void MinimalHTMLWriter.writeHeader()
写出 <head> 和 <style> 标记，然后调用 writeStyles()，以写出所有命名的样式，这些样式作为 <style> 标记的内容。
protected  void MinimalHTMLWriter.writeHTMLTags(AttributeSet attr)
基于文本的属性设置生成文本的 bold <b>、italic <i> 和 <u> 标记。
protected  void MinimalHTMLWriter.writeImage(Element elem)
负责处理 Icon Elements；有意不实现它。
protected  void MinimalHTMLWriter.writeLeaf(Element elem)
负责写出其他非文本叶元素。
protected  void HTMLWriter.writeLineSeparator()
写出行分隔符。
protected  void MinimalHTMLWriter.writeNonHTMLAttributes(AttributeSet attr)
以与 HTML 兼容的方式写出其余的字符级属性（bold、italic 和 underline 之外的属性）。
protected  void HTMLWriter.writeOption(Option option)
写出 Option 表单元素的内容。
protected  void MinimalHTMLWriter.writeStartParagraph(Element elem)
发出段落的开始标记。
protected  void MinimalHTMLWriter.writeStartTag(String tag)
写出适当缩进的开始标记。
protected  void MinimalHTMLWriter.writeStyles()
写出所有命名的样式，这些样式作为 <style> 标记的内容。

javax.swing.text.html.parser 中 IOException 的使用

抛出 IOException 的 javax.swing.text.html.parser 中的方法
static DTD | DTD.getDTD(String name) 返回具有指定 name 的 DTD。
void | Parser.parse(Reader in) 在给定 DTD 的情况下，解析 HTML 流。
void | DocumentParser.parse(Reader in, HTMLEditorKit.ParserCallback callback, boolean ignoreCharSet)
void | ParserDelegator.parse(Reader r, HTMLEditorKit.ParserCallback cb, boolean ignoreCharSet)
String | Parser.parseDTDMarkup() 解析 Document Type Declaration 标记声明。
protected boolean | Parser.parseMarkupDeclarations(StringBuffer strBuff) 解析标记声明。
void | DTD.read(DataInputStream in) 根据存档格式重新创建一个 DTD。

javax.swing.text.rtf 中 IOException 的使用

抛出 IOException 的 javax.swing.text.rtf 中的方法
void | RTFEditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。
void | RTFEditorKit.read(Reader in, Document doc, int pos) 插入来自给定流的内容，该内容将被视为纯文本。
void | RTFEditorKit.write(OutputStream out, Document doc, int pos, int len) 以适合此类内容处理程序的格式，将文档中的内容写入给定流。
void | RTFEditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容作为纯文本写入给定的流。

javax.tools 中 IOException 的使用

抛出 IOException 的 javax.tools 中的方法
 void ForwardingJavaFileManager.close()
 void JavaFileManager.close()
释放此文件管理器直接或间接打开的所有资源。
 void ForwardingJavaFileManager.flush()
 void JavaFileManager.flush()
刷新此文件管理器直接或间接为输出打开的所有资源。
 CharSequence FileObject.getCharContent(boolean ignoreEncodingErrors)
返回此文件对象的字符内容（如果有）。
 CharSequence ForwardingFileObject.getCharContent(boolean ignoreEncodingErrors)
 CharSequence SimpleJavaFileObject.getCharContent(boolean ignoreEncodingErrors)
此实现总是抛出 UnsupportedOperationException。
 FileObject ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
 FileObject JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。
 FileObject ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
 FileObject JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。
 JavaFileObject ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
 JavaFileObject JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
获取输入的文件对象，它表示给定位置处指定类型的指定类。
 JavaFileObject ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
 JavaFileObject JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定类型的指定类。
 Iterable<JavaFileObject> ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
 Iterable<JavaFileObject> JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
列出给定位置处符合给定标准的所有文件对象。
 InputStream FileObject.openInputStream()
获取此文件对象的 InputStream。
 InputStream ForwardingFileObject.openInputStream()
 InputStream SimpleJavaFileObject.openInputStream()
此实现总是抛出 UnsupportedOperationException。
 OutputStream FileObject.openOutputStream()
获取此文件对象的 OutputStream。
 OutputStream ForwardingFileObject.openOutputStream()
 OutputStream SimpleJavaFileObject.openOutputStream()
此实现总是抛出 UnsupportedOperationException。
 Reader FileObject.openReader(boolean ignoreEncodingErrors)
获取此对象的 reader。
 Reader ForwardingFileObject.openReader(boolean ignoreEncodingErrors)
 Reader SimpleJavaFileObject.openReader(boolean ignoreEncodingErrors)
在 Reader 中包装 SimpleJavaFileObject.getCharContent(boolean) 的结果。
 Writer FileObject.openWriter()
获取此文件对象的 Writer。
 Writer ForwardingFileObject.openWriter()
 Writer SimpleJavaFileObject.openWriter()
在 Writer 中包装 openOutputStream 的结果。
 void StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path)
将给定路径与给定位置关联。

javax.transaction 中 IOException 的使用

javax.transaction 中 IOException 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.xml.bind 中 IOException 的使用

抛出 IOException 的 javax.xml.bind 中的方法
abstract Result | SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName) 确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。
void | JAXBContext.generateSchema(SchemaOutputResolver outputResolver) 生成此上下文的模式文档。

javax.xml.parsers 中 IOException 的使用

抛出 IOException 的 javax.xml.parsers 中的方法
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。
abstract Document | DocumentBuilder.parse(InputSource is) 将给定输入源的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputSource is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定 InputSource 的内容解析为 XML。
void | SAXParser.parse(InputSource is, HandlerBase hb) 使用指定的 HandlerBase 将给定 InputSource 的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
Document | DocumentBuilder.parse(String uri) 将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(String uri, DefaultHandler dh) 使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。
void | SAXParser.parse(String uri, HandlerBase hb) 使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

javax.xml.soap 中 IOException 的使用

抛出 IOException 的 javax.xml.soap 中的方法
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
abstract void | SOAPMessage.writeTo(OutputStream out) 将此 SOAPMessage 对象写入给定输出流。

javax.xml.validation 中 IOException 的使用

抛出 IOException 的 javax.xml.validation 中的方法
void | Validator.validate(Source source) 验证指定的输入。
abstract void | Validator.validate(Source source, Result result) 验证指定输入并将扩充的验证结果发送到指定输出。

org.omg.CORBA.portable 中 IOException 的使用

抛出 IOException 的 org.omg.CORBA.portable 中的方法
int | InputStream.read()
void | OutputStream.write(int b) 将一个 integer（数组长度）写入此流。

org.xml.sax 中 IOException 的使用

抛出 IOException 的 org.xml.sax 中的方法
void | Parser.parse(InputSource source) 已过时。 解析 XML 文档。
void | XMLReader.parse(InputSource input) 解析 XML 文档。
void | Parser.parse(String systemId) 已过时。 从系统标识符 (URI) 解析 XML 文档。
void | XMLReader.parse(String systemId) 从系统标识符 (URI) 解析 XML 文档。
InputSource | EntityResolver.resolveEntity(String publicId, String systemId) 允许应用程序解析外部实体。

org.xml.sax.ext 中 IOException 的使用

抛出 IOException 的 org.xml.sax.ext 中的方法
 InputSource DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。
 InputSource EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。
 InputSource DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。
 InputSource DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。
 InputSource EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。

org.xml.sax.helpers 中 IOException 的使用

抛出 IOException 的 org.xml.sax.helpers 中的方法
void | ParserAdapter.parse(InputSource input) 解析 XML 文档。
void | XMLFilterImpl.parse(InputSource input) 解析一个文档。
void | XMLReaderAdapter.parse(InputSource input) 解析文档。
void | ParserAdapter.parse(String systemId) 解析 XML 文档。
void | XMLFilterImpl.parse(String systemId) 解析一个文档。
void | XMLReaderAdapter.parse(String systemId) 解析文档。
InputSource | DefaultHandler.resolveEntity(String publicId, String systemId) 解析外部实体。
InputSource | XMLFilterImpl.resolveEntity(String publicId, String systemId) 过滤一个外部实体解析。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FilePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilePermission
的使用

没有 java.io.FilePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ObjectStreamClass 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectStreamClass
的使用

使用 ObjectStreamClass 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectStreamClass 的使用

返回 ObjectStreamClass 的 java.io 中的方法
abstract ObjectStreamClass | ObjectInputStream.GetField.getObjectStreamClass() 获取描述流中字段的 ObjectStreamClass。
static ObjectStreamClass | ObjectStreamClass.lookup(Class<?> cl) 查找可序列化类的描述符。
static ObjectStreamClass | ObjectStreamClass.lookupAny(Class<?> cl) 返回任意类的描述符，不考虑它是否实现 Serializable。
protected ObjectStreamClass | ObjectInputStream.readClassDescriptor() 从序列化流读取类描述符。

参数类型为 ObjectStreamClass 的 java.io 中的方法
protected Class<?> | ObjectInputStream.resolveClass(ObjectStreamClass desc) 加载指定流类描述的本地等价类。
protected void | ObjectOutputStream.writeClassDescriptor(ObjectStreamClass desc) 将指定的类描述符写入 ObjectOutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FileReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileReader
的使用

没有 java.io.FileReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.InputStreamReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InputStreamReader
的使用

使用 InputStreamReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 InputStreamReader 的使用

java.io 中 InputStreamReader 的子类
 class FileReader
用来读取字符文件的便捷类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.BufferedReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedReader
的使用

使用 BufferedReader 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 BufferedReader 的使用

java.io 中 BufferedReader 的子类
 class LineNumberReader
跟踪行号的缓冲字符输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.File 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.File
的使用

使用 File 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。

java.awt 中 File 的使用

参数类型为 File 的 java.awt 中的方法
static Font | Font.createFont(int fontFormat, File fontFile) 返回一个使用指定字体类型和指定字体文件的新 Font。
void | Desktop.edit(File file) 启动关联编辑器应用程序并打开用于编辑的文件。
void | Desktop.open(File file) 启动关联应用程序来打开文件。
void | Desktop.print(File file) 使用关联应用程序的打印命令，用本机桌面打印设施来打印文件。

java.io 中 File 的使用

返回 File 的 java.io 中的方法
static File | File.createTempFile(String prefix, String suffix) 在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。
static File | File.createTempFile(String prefix, String suffix, File directory) 在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
File | File.getAbsoluteFile() 返回此抽象路径名的绝对路径名形式。
File | File.getCanonicalFile() 返回此抽象路径名的规范形式。
File | File.getParentFile() 返回此抽象路径名父目录的抽象路径名；如果此路径名没有指定父目录，则返回 null。
File[] | File.listFiles() 返回一个抽象路径名数组，这些路径名表示此抽象路径名表示的目录中的文件。
File[] | File.listFiles(FileFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
File[] | File.listFiles(FilenameFilter filter) 返回抽象路径名数组，这些路径名表示此抽象路径名表示的目录中满足指定过滤器的文件和目录。
static File[] | File.listRoots() 列出可用的文件系统根。

参数类型为 File 的 java.io 中的方法
boolean | FileFilter.accept(File pathname) 测试指定抽象路径名是否应该包含在某个路径名列表中。
boolean | FilenameFilter.accept(File dir, String name) 测试指定文件是否应该包含在某一文件列表中。
int | File.compareTo(File pathname) 按字母顺序比较两个抽象路径名。
static File | File.createTempFile(String prefix, String suffix, File directory) 在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。
boolean | File.renameTo(File dest) 重新命名此抽象路径名表示的文件。

参数类型为 File 的 java.io 中的构造方法
File(File parent, String child)
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。
FileInputStream(File file)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的 File 对象 file 指定。
FileOutputStream(File file)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileOutputStream(File file, boolean append)
创建一个向指定 File 对象表示的文件中写入数据的文件输出流。
FileReader(File file)
在给定从中读取数据的 File 的情况下创建一个新 FileReader。
FileWriter(File file)
根据给定的 File 对象构造一个 FileWriter 对象。
FileWriter(File file, boolean append)
根据给定的 File 对象构造一个 FileWriter 对象。
PrintStream(File file)
创建具有指定文件且不带自动行刷新的新打印流。
PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。
PrintWriter(File file)
使用指定文件创建不具有自动行刷新的新 PrintWriter。
PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。
RandomAccessFile(File file, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。

java.lang 中 File 的使用

返回 File 的 java.lang 中的方法
 File ProcessBuilder.directory()
返回此进程生成器的工作目录。

参数类型为 File 的 java.lang 中的方法
ProcessBuilder | ProcessBuilder.directory(File directory) 设置此进程生成器的工作目录。
Process | Runtime.exec(String[] cmdarray, String[] envp, File dir) 在指定环境和工作目录的独立进程中执行指定的命令和变量。
Process | Runtime.exec(String command, String[] envp, File dir) 在有指定环境和工作目录的独立进程中执行指定的字符串命令。

java.security 中 File 的使用

参数类型为 File 的 java.security 中的方法
static KeyStore.Builder KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

java.util 中 File 的使用

参数类型为 File 的 java.util 中的构造方法
Formatter(File file)
构造一个带指定文件的新 formatter。
Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Scanner(File source)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(File source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。

java.util.jar 中 File 的使用

参数类型为 File 的 java.util.jar 中的方法
 void Pack200.Unpacker.unpack(File in, JarOutputStream out)
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

参数类型为 File 的 java.util.jar 中的构造方法
JarFile(File file)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify, int mode)
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。

java.util.zip 中 File 的使用

参数类型为 File 的 java.util.zip 中的构造方法
ZipFile(File file)
打开供阅读的 ZIP 文件，由指定的 File 对象给出。
ZipFile(File file, int mode)
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。

javax.activation 中 File 的使用

返回 File 的 javax.activation 中的方法
 File FileDataSource.getFile()
返回与此 FileDataSource 对应的 File 对象。

参数类型为 File 的 javax.activation 中的方法
abstract String | FileTypeMap.getContentType(File file) 返回文件对象的类型。
String | MimetypesFileTypeMap.getContentType(File f) 返回该文件对象的 MIME 类型。

参数类型为 File 的 javax.activation 中的构造方法
FileDataSource(File file)
根据 File 对象创建 FileDataSource。

javax.imageio 中 File 的使用

返回 File 的 javax.imageio 中的方法
static File ImageIO.getCacheDirectory()
返回由 setCacheDirectory 设置的当前值；如果没有显式设置该值，则返回 null。

参数类型为 File 的 javax.imageio 中的方法
static BufferedImage | ImageIO.read(File input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
static void | ImageIO.setCacheDirectory(File cacheDirectory) 设置将在其中创建缓存文件的目录。
static boolean | ImageIO.write(RenderedImage im, String formatName, File output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 File。

javax.imageio.spi 中 File 的使用

参数类型为 File 的 javax.imageio.spi 中的方法
abstract ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
abstract ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。

javax.imageio.stream 中 File 的使用

参数类型为 File 的 javax.imageio.stream 中的构造方法
FileCacheImageInputStream(InputStream stream, File cacheDir)
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
FileCacheImageOutputStream(OutputStream stream, File cacheDir)
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
FileImageInputStream(File f)
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageOutputStream(File f)
构造一个将向给定 File 进行写入的 FileImageOutputStream。

javax.sound.midi 中 File 的使用

参数类型为 File 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static int | MidiSystem.write(Sequence in, int type, File out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。

javax.sound.midi.spi 中 File 的使用

参数类型为 File 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract int | MidiFileWriter.write(Sequence in, int fileType, File out) 写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。

javax.sound.sampled 中 File 的使用

参数类型为 File 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。

javax.sound.sampled.spi 中 File 的使用

参数类型为 File 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。

javax.swing 中 File 的使用

返回 File 的 javax.swing 中的方法
File | JFileChooser.getCurrentDirectory() 返回当前目录。
File | JFileChooser.getSelectedFile() 返回选中的文件。
File[] | JFileChooser.getSelectedFiles() 如果将文件选择器设置为允许选择多个文件，则返回选中文件的列表。

参数类型为 File 的 javax.swing 中的方法
boolean | JFileChooser.accept(File f) 如果应该显示该文件，则返回 true。
void | JFileChooser.ensureFileIsVisible(File f) 确保指定的文件是可见的，不是隐藏的。
String | JFileChooser.getDescription(File f) 返回文件描述。
Icon | JFileChooser.getIcon(File f) 返回此文件或文件类型的图标，这取决于系统。
String | JFileChooser.getName(File f) 返回文件名。
String | JFileChooser.getTypeDescription(File f) 返回文件类型。
boolean | JFileChooser.isTraversable(File f) 如果可以返回该文件（目录），则返回 true。
void | JFileChooser.setCurrentDirectory(File dir) 设置当前目录。
void | JFileChooser.setSelectedFile(File file) 设置选中的文件。
void | JFileChooser.setSelectedFiles(File[] selectedFiles) 如果将文件选择器设置为允许选择多个文件，则设置选中文件的列表。

参数类型为 File 的 javax.swing 中的构造方法
JFileChooser(File currentDirectory)
使用给定的 File 作为路径来构造一个 JFileChooser。
JFileChooser(File currentDirectory, FileSystemView fsv)
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。

javax.swing.filechooser 中 File 的使用

返回 File 的 javax.swing.filechooser 中的方法
File | FileSystemView.createFileObject(File dir, String filename) 返回根据给定的 filename 在 dir 中构造的 File 对象。
File | FileSystemView.createFileObject(String path) 返回根据给定路径字符串构造的 File 对象。
protected File | FileSystemView.createFileSystemRoot(File f) 创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。
abstract File | FileSystemView.createNewFolder(File containingDir) 创建具有默认文件夹名称的新文件夹。
File | FileSystemView.getChild(File parent, String fileName)
File | FileSystemView.getDefaultDirectory() 返回文件选择器的用户默认起始目录。
File[] | FileSystemView.getFiles(File dir, boolean useFileHiding) 获取显示的（即未隐藏）文件的列表。
File | FileSystemView.getHomeDirectory()
File | FileSystemView.getParentDirectory(File dir) 返回 dir 的父目录。
File[] | FileSystemView.getRoots() 返回此系统的所有根分区。

参数类型为 File 的 javax.swing.filechooser 中的方法
boolean | FileNameExtensionFilter.accept(File f) 测试指定的文件，如果该文件被接受，则返回 true，否则返回 false。
abstract boolean | FileFilter.accept(File f) 此过滤器是否接受给定的文件。
File | FileSystemView.createFileObject(File dir, String filename) 返回根据给定的 filename 在 dir 中构造的 File 对象。
protected File | FileSystemView.createFileSystemRoot(File f) 创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。
abstract File | FileSystemView.createNewFolder(File containingDir) 创建具有默认文件夹名称的新文件夹。
File | FileSystemView.getChild(File parent, String fileName)
String | FileView.getDescription(File f) 文件的可读描述。
File[] | FileSystemView.getFiles(File dir, boolean useFileHiding) 获取显示的（即未隐藏）文件的列表。
Icon | FileView.getIcon(File f) 表示 JFileChooser 中此文件的图标。
String | FileView.getName(File f) 文件名称。
File | FileSystemView.getParentDirectory(File dir) 返回 dir 的父目录。
String | FileSystemView.getSystemDisplayName(File f) 在系统文件浏览器中显示的文件、目录或文件夹名。
Icon | FileSystemView.getSystemIcon(File f) 在系统文件浏览器中显示的文件、目录或文件夹的图标。
String | FileSystemView.getSystemTypeDescription(File f) 在系统文件浏览器中显示的文件、目录或文件夹类型描述。
String | FileView.getTypeDescription(File f) 文件类型的可读描述。
boolean | FileSystemView.isComputerNode(File dir) UI 类使用此方法来决定是否为计算机节点显示特殊图标，例如，“我的电脑”或网络服务器。
boolean | FileSystemView.isDrive(File dir) UI 类使用此方法来决定是否为驱动器或分区显示特殊图标，例如，“硬盘”图标。
boolean | FileSystemView.isFileSystem(File f) 检查 f 是否表示一个相对于特殊文件夹（如 "Desktop"）的实际目录或文件。
boolean | FileSystemView.isFileSystemRoot(File dir) 判断 dir 是否是文件系统（如驱动器或分区）中的树的根。
boolean | FileSystemView.isFloppyDrive(File dir) UI 类使用此方法来决定是否为软盘显示特殊图标。
boolean | FileSystemView.isHiddenFile(File f) 返回某个文件是否被隐藏。
boolean | FileSystemView.isParent(File folder, File file) 在 Windows 中，一个文件可以出现在多个文件夹，但在文件系统中的父目录中除外。
boolean | FileSystemView.isRoot(File f) 确定给定文件是否是导航树中的根。
Boolean | FileSystemView.isTraversable(File f) 如果可以访问文件（目录），则返回 true。
Boolean | FileView.isTraversable(File f) 目录是否是可遍历的。

javax.swing.plaf 中 File 的使用

参数类型为 File 的 javax.swing.plaf 中的方法
abstract  void FileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)

javax.swing.plaf.basic 中 File 的使用

类型参数类型为 File 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<File,Icon> BasicFileChooserUI.BasicFileView.iconCache

返回 File 的 javax.swing.plaf.basic 中的方法
protected  File BasicFileChooserUI.getDirectory()
记忆当前在 UI 中选择的目录的属性。

返回变量类型为 File 的类型的 javax.swing.plaf.basic 中的方法
Vector<File> | BasicDirectoryModel.getDirectories()
Vector<File> | BasicDirectoryModel.getFiles()

参数类型为 File 的 javax.swing.plaf.basic 中的方法
boolean | BasicFileChooserUI.AcceptAllFileFilter.accept(File f)
void | BasicFileChooserUI.BasicFileView.cacheIcon(File f, Icon i)
void | BasicFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)
Icon | BasicFileChooserUI.BasicFileView.getCachedIcon(File f)
String | BasicFileChooserUI.BasicFileView.getDescription(File f)
Icon | BasicFileChooserUI.BasicFileView.getIcon(File f)
String | BasicFileChooserUI.BasicFileView.getName(File f)
String | BasicFileChooserUI.BasicFileView.getTypeDescription(File f)
Boolean | BasicFileChooserUI.BasicFileView.isHidden(File f)
protected boolean | BasicDirectoryModel.lt(File a, File b)
boolean | BasicDirectoryModel.renameFile(File oldFile, File newFile) 重命名底层文件系统中的文件。
protected void | BasicFileChooserUI.setDirectory(File f) 记忆当前在 UI 中选择的目录的属性。

类型变量类型为 File 的 javax.swing.plaf.basic 中的方法参数
protected  void BasicDirectoryModel.sort(Vector<? extends File> v)

javax.swing.plaf.metal 中 File 的使用

参数类型为 File 的 javax.swing.plaf.metal 中的方法
 void MetalFileChooserUI.ensureFileIsVisible(JFileChooser fc, File f)

javax.swing.plaf.multi 中 File 的使用

参数类型为 File 的 javax.swing.plaf.multi 中的方法
 void MultiFileChooserUI.ensureFileIsVisible(JFileChooser a, File b)
在由此对象处理的每个 UI 上调用 ensureFileIsVisible 方法。

javax.tools 中 File 的使用

返回变量类型为 File 的类型的 javax.tools 中的方法
 Iterable<? extends File> StandardJavaFileManager.getLocation(JavaFileManager.Location location)
获取与给定位置关联的路径。

参数类型为 File 的 javax.tools 中的方法
 Iterable<? extends JavaFileObject> StandardJavaFileManager.getJavaFileObjects(File... files)
获取表示给定文件的文件对象。

类型变量类型为 File 的 javax.tools 中的方法参数
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
void | StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path) 将给定路径与给定位置关联。

javax.xml.bind 中 File 的使用

参数类型为 File 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 File 的使用

参数类型为 File 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(File f)

javax.xml.parsers 中 File 的使用

参数类型为 File 的 javax.xml.parsers 中的方法
Document | DocumentBuilder.parse(File f) 将给定文件的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(File f, DefaultHandler dh) 使用指定的 DefaultHandler 将指定文件的内容解析为 XML。
void | SAXParser.parse(File f, HandlerBase hb) 使用指定的 HandlerBase 将指定文件的内容解析为 XML。

javax.xml.transform.stream 中 File 的使用

参数类型为 File 的 javax.xml.transform.stream 中的方法
void | StreamResult.setSystemId(File f) 设置来自 File 引用的系统 ID。
void | StreamSource.setSystemId(File f) 设置来自 File 引用的系统 ID。

参数类型为 File 的 javax.xml.transform.stream 中的构造方法
StreamResult(File f)
从 File 构造 StreamResult。
StreamSource(File f)
从 File 构造 StreamSource。

javax.xml.validation 中 File 的使用

参数类型为 File 的 javax.xml.validation 中的方法
 Schema SchemaFactory.newSchema(File schema)
解析作为模式的指定 File 并以 Schema 的形式返回它。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.BufferedWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedWriter
的使用

没有 java.io.BufferedWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.OutputStreamWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.OutputStreamWriter
的使用

使用 OutputStreamWriter 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 OutputStreamWriter 的使用

java.io 中 OutputStreamWriter 的子类
 class FileWriter
用来写入字符文件的便捷类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.Writer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.Writer
的使用

使用 Writer 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.w3c.dom.ls |

java.io 中 Writer 的使用

java.io 中 Writer 的子类
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedWriter 传送的字符输出流。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。

声明为 Writer 的 java.io 中的字段
protected Writer | FilterWriter.out 底层字符输出流。
protected Writer | PrintWriter.out 此 PrintWriter 的底层字符输出流。

返回 Writer 的 java.io 中的方法
Writer | Writer.append(char c) 将指定字符添加到此 writer。
Writer | Writer.append(CharSequence csq) 将指定字符序列添加到此 writer。
Writer | Writer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer.Appendable。

参数类型为 Writer 的 java.io 中的方法
 void CharArrayWriter.writeTo(Writer out)
将缓冲区的内容写入另一个字符流。

参数类型为 Writer 的 java.io 中的构造方法
BufferedWriter(Writer out)
创建一个使用默认大小输出缓冲区的缓冲字符输出流。
BufferedWriter(Writer out, int sz)
创建一个使用给定大小输出缓冲区的新缓冲字符输出流。
FilterWriter(Writer out)
创建一个新的 filtered writer。
PrintWriter(Writer out)
创建不带自动行刷新的新 PrintWriter。
PrintWriter(Writer out, boolean autoFlush)
创建新 PrintWriter。

java.nio.channels 中 Writer 的使用

返回 Writer 的 java.nio.channels 中的方法
static Writer | Channels.newWriter(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap) 构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。
static Writer | Channels.newWriter(WritableByteChannel ch, String csName) 构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。

java.sql 中 Writer 的使用

返回 Writer 的 java.sql 中的方法
Writer | SQLXML.setCharacterStream() 获取用于写入此 SQLXML 实例表示的 XML 值的流。
Writer | Clob.setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。

java.util 中 Writer 的使用

参数类型为 Writer 的 java.util 中的方法
 void Properties.store(Writer writer, String comments)
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。

javax.lang.model.util 中 Writer 的使用

参数类型为 Writer 的 javax.lang.model.util 中的方法
 void Elements.printElements(Writer w, Element... elements)
按指定顺序将元素的表示形式打印到给定 writer。

javax.script 中 Writer 的使用

声明为 Writer 的 javax.script 中的字段
protected Writer | SimpleScriptContext.errorWriter 此字段是用于脚本输出错误的 writer。
protected Writer | SimpleScriptContext.writer 此字段是用于脚本输出的 writer。

返回 Writer 的 javax.script 中的方法
Writer | ScriptContext.getErrorWriter() 返回用来显示错误输出的 Writer。
Writer | SimpleScriptContext.getErrorWriter() 返回用来显示错误输出的 Writer。
Writer | ScriptContext.getWriter() 返回脚本的 Writer，以便在显示输出时使用。
Writer | SimpleScriptContext.getWriter() 返回脚本的 Writer，以便在显示输出时使用。

参数类型为 Writer 的 javax.script 中的方法
void | ScriptContext.setErrorWriter(Writer writer) 设置用来显示错误输出的 Writer。
void | SimpleScriptContext.setErrorWriter(Writer writer) 设置用来显示错误输出的 Writer。
void | ScriptContext.setWriter(Writer writer) 设置脚本的 Writer，以便在显示输出时使用。
void | SimpleScriptContext.setWriter(Writer writer) 设置脚本的 Writer，以便在显示输出时使用。

javax.sql.rowset 中 Writer 的使用

参数类型为 Writer 的 javax.sql.rowset 中的方法
void | WebRowSet.writeXml(ResultSet rs, Writer writer) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。
void | WebRowSet.writeXml(Writer writer) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。

javax.sql.rowset.serial 中 Writer 的使用

返回 Writer 的 javax.sql.rowset.serial 中的方法
 Writer SerialClob.setCharacterStream(long pos)
获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。

javax.sql.rowset.spi 中 Writer 的使用

参数类型为 Writer 的 javax.sql.rowset.spi 中的方法
 void XmlWriter.writeXML(WebRowSet caller, Writer writer)
将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。

javax.swing.text 中 Writer 的使用

返回 Writer 的 javax.swing.text 中的方法
protected  Writer AbstractWriter.getWriter()
返回用于输出内容的 Writer。

参数类型为 Writer 的 javax.swing.text 中的方法
void | JTextComponent.write(Writer out) 将模型的内容存储到给定的流中。
void | DefaultEditorKit.write(Writer out, Document doc, int pos, int len) 将取自文档的内容以纯文本格式写入给定流。
abstract void | EditorKit.write(Writer out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

参数类型为 Writer 的 javax.swing.text 中的构造方法
AbstractWriter(Writer w, Document doc)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Document doc, int pos, int len)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Element root)
创建新的 AbstractWriter。
AbstractWriter(Writer w, Element root, int pos, int len)
创建新的 AbstractWriter。

javax.swing.text.html 中 Writer 的使用

参数类型为 Writer 的 javax.swing.text.html 中的方法
 void HTMLEditorKit.write(Writer out, Document doc, int pos, int len)
以适合此类内容处理程序的格式，将文档中的内容写入给定流。

参数类型为 Writer 的 javax.swing.text.html 中的构造方法
HTMLWriter(Writer w, HTMLDocument doc)
创建新的 HTMLWriter。
HTMLWriter(Writer w, HTMLDocument doc, int pos, int len)
创建新的 HTMLWriter。
MinimalHTMLWriter(Writer w, StyledDocument doc)
创建一个新的 MinimalHTMLWriter。
MinimalHTMLWriter(Writer w, StyledDocument doc, int pos, int len)
创建一个新的 MinimalHTMLWriter。

javax.swing.text.rtf 中 Writer 的使用

参数类型为 Writer 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.write(Writer out, Document doc, int pos, int len)
将文档中的内容作为纯文本写入给定的流。

javax.tools 中 Writer 的使用

返回 Writer 的 javax.tools 中的方法
Writer | FileObject.openWriter() 获取此文件对象的 Writer。
Writer | ForwardingFileObject.openWriter()
Writer | SimpleJavaFileObject.openWriter() 在 Writer 中包装 openOutputStream 的结果。

参数类型为 Writer 的 javax.tools 中的方法
 JavaCompiler.CompilationTask JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

javax.xml.bind 中 Writer 的使用

参数类型为 Writer 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, Writer writer)
将以 jaxbElement 为根的内容树编组到 Writer 中。

javax.xml.bind.helpers 中 Writer 的使用

参数类型为 Writer 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, Writer w)

javax.xml.stream 中 Writer 的使用

参数类型为 Writer 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(Writer stream) 创建一个写入到 writer 的新 XMLEventWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(Writer stream) 创建一个写入到 writer 的新 XMLStreamWriter。

javax.xml.stream.events 中 Writer 的使用

参数类型为 Writer 的 javax.xml.stream.events 中的方法
 void XMLEvent.writeAsEncodedUnicode(Writer writer)
此方法根据 XML 1.0 规范将 XMLEvent 编写为 Unicode 字符。

javax.xml.transform.stream 中 Writer 的使用

返回 Writer 的 javax.xml.transform.stream 中的方法
 Writer StreamResult.getWriter()
获取通过 setWriter 设置的字符流。

参数类型为 Writer 的 javax.xml.transform.stream 中的方法
 void StreamResult.setWriter(Writer writer)
设置要接收结果的 writer。

参数类型为 Writer 的 javax.xml.transform.stream 中的构造方法
StreamResult(Writer writer)
从字符流构造 StreamResult。

org.w3c.dom.ls 中 Writer 的使用

返回 Writer 的 org.w3c.dom.ls 中的方法
 Writer LSOutput.getCharacterStream()
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。

参数类型为 Writer 的 org.w3c.dom.ls 中的方法
 void LSOutput.setCharacterStream(Writer characterStream)
具有语言和绑定依赖性类型的属性，它表示可向其输出 16 位单元的可写流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.BufferedOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedOutputStream
的使用

没有 java.io.BufferedOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.PrintStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.PrintStream
的使用

使用 PrintStream 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt 中 PrintStream 的使用

参数类型为 PrintStream 的 java.awt 中的方法
void | Component.list(PrintStream out) 将组件列表打印到指定的输出流。
void | Container.list(PrintStream out, int indent) 将此容器的清单打印到指定输出流。
void | Component.list(PrintStream out, int indent) 将列表从指定的缩排开始打印到指定的打印流。

java.io 中 PrintStream 的使用

返回 PrintStream 的 java.io 中的方法
PrintStream | PrintStream.append(char c) 将指定字符添加到此输出流。
PrintStream | PrintStream.append(CharSequence csq) 将指定字符序列添加到此输出流。
PrintStream | PrintStream.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此输出流。
PrintStream | PrintStream.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
PrintStream | PrintStream.format(String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
PrintStream | PrintStream.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。
PrintStream | PrintStream.printf(String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

java.lang 中 PrintStream 的使用

声明为 PrintStream 的 java.lang 中的字段
static PrintStream | System.err “标准”错误输出流。
static PrintStream | System.out “标准”输出流。

参数类型为 PrintStream 的 java.lang 中的方法
void | Throwable.printStackTrace(PrintStream s) 将此 throwable 及其追踪输出到指定的输出流。
static void | System.setErr(PrintStream err) 重新分配“标准”错误输出流。
static void | System.setOut(PrintStream out) 重新分配“标准”输出流。

java.rmi.server 中 PrintStream 的使用

java.rmi.server 中 PrintStream 的子类
 class LogStream
已过时。 无替代版本

返回 PrintStream 的 java.rmi.server 中的方法
static PrintStream | LogStream.getDefaultStream() 已过时。 无替代版本
static PrintStream | RemoteServer.getLog() 返回用于 RMI 调用日志的流。

参数类型为 PrintStream 的 java.rmi.server 中的方法
static void LogStream.setDefaultStream(PrintStream newDefault)
已过时。 无替代版本

java.sql 中 PrintStream 的使用

返回 PrintStream 的 java.sql 中的方法
static PrintStream DriverManager.getLogStream()
已过时。

参数类型为 PrintStream 的 java.sql 中的方法
static void DriverManager.setLogStream(PrintStream out)
已过时。

java.util 中 PrintStream 的使用

参数类型为 PrintStream 的 java.util 中的方法
 void Properties.list(PrintStream out)
将属性列表输出到指定的输出流。

参数类型为 PrintStream 的 java.util 中的构造方法
Formatter(PrintStream ps)
构造一个带指定输出流的新 formatter。

javax.swing 中 PrintStream 的使用

返回 PrintStream 的 javax.swing 中的方法
static PrintStream DebugGraphics.logStream()
返回 DebugGraphics 在其中记录绘制操作的流。

参数类型为 PrintStream 的 javax.swing 中的方法
static void DebugGraphics.setLogStream(PrintStream stream)
设置 DebugGraphics 在其中记录绘制操作的流。

javax.swing.text 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.swing.text 中的方法
void | AbstractDocument.dump(PrintStream out) 提供诊断转储 (dump)。
void | AbstractDocument.AbstractElement.dump(PrintStream psOut, int indentAmount) 转储该元素层次结构的调试表示形式。

javax.xml.bind 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.bind 中的方法
void | JAXBException.printStackTrace(PrintStream s) 打印此 JAXBException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。
void | TypeConstraintException.printStackTrace(PrintStream s) 打印此 TypeConstraintException 及其对 PrintStream 的堆栈跟踪（如果为非 null，则包括该 linkedException 的堆栈跟踪）。

javax.xml.crypto 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.crypto 中的方法
void | KeySelectorException.printStackTrace(PrintStream s) 将此 KeySelectorException、它的追踪和 cause 追踪打印到指定的打印流。
void | MarshalException.printStackTrace(PrintStream s) 将此 MarshalException、它的追踪和 cause 的追踪打印到指定的打印流。
void | NoSuchMechanismException.printStackTrace(PrintStream s) 将此 NoSuchMechanismException、它的追踪和 cause 的追踪打印到指定的打印流。
void | URIReferenceException.printStackTrace(PrintStream s) 将此 URIReferenceException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流。

javax.xml.crypto.dsig 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.crypto.dsig 中的方法
void | TransformException.printStackTrace(PrintStream s) 将此 TransformException、它的追踪和 cause 的追踪打印到指定的打印流中。
void | XMLSignatureException.printStackTrace(PrintStream s) 将此 XMLSignatureException、它的追踪 (backtrace) 和 cause 的追踪打印到指定的打印流中。

javax.xml.transform 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.transform 中的方法
 void TransformerException.printStackTrace(PrintStream s)
打印从中产生错误的方法跟踪。

javax.xml.xpath 中 PrintStream 的使用

参数类型为 PrintStream 的 javax.xml.xpath 中的方法
 void XPathException.printStackTrace(PrintStream s)
将堆栈跟踪打印到指定的 PrintStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FilterOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterOutputStream
的使用

使用 FilterOutputStream 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。

java.io 中 FilterOutputStream 的使用

java.io 中 FilterOutputStream 的子类
class | BufferedOutputStream 该类实现缓冲的输出流。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。

java.rmi.server 中 FilterOutputStream 的使用

java.rmi.server 中 FilterOutputStream 的子类
 class LogStream
已过时。 无替代版本

java.security 中 FilterOutputStream 的使用

java.security 中 FilterOutputStream 的子类
 class DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

java.util.jar 中 FilterOutputStream 的使用

java.util.jar 中 FilterOutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 FilterOutputStream 的使用

java.util.zip 中 FilterOutputStream 的子类
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

javax.crypto 中 FilterOutputStream 的使用

javax.crypto 中 FilterOutputStream 的子类
 class CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.BufferedInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.BufferedInputStream
的使用

没有 java.io.BufferedInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FilterInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FilterInputStream
的使用

使用 FilterInputStream 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.security | 为安全框架提供类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.io 中 FilterInputStream 的使用

java.io 中 FilterInputStream 的子类
class | BufferedInputStream BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | PushbackInputStream PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。

java.security 中 FilterInputStream 的使用

java.security 中 FilterInputStream 的子类
 class DigestInputStream
使用通过流的位更新关联消息摘要的透明流。

java.util.jar 中 FilterInputStream 的使用

java.util.jar 中 FilterInputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

java.util.zip 中 FilterInputStream 的使用

java.util.zip 中 FilterInputStream 的子类
class | CheckedInputStream 需要维护所读取数据校验和的输入流。
class | DeflaterInputStream 为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | InflaterInputStream 此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。

javax.crypto 中 FilterInputStream 的使用

javax.crypto 中 FilterInputStream 的子类
 class CipherInputStream
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。

javax.swing 中 FilterInputStream 的使用

javax.swing 中 FilterInputStream 的子类
 class ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FileOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileOutputStream
的使用

没有 java.io.FileOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.OutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.OutputStream
的使用

使用 OutputStream 的软件包
java.awt.color | 提供用于颜色空间的类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.w3c.dom.ls |

java.awt.color 中 OutputStream 的使用

参数类型为 OutputStream 的 java.awt.color 中的方法
 void ICC_Profile.write(OutputStream s)
将 ICC_Profile 写入一个 OutputStream。

java.beans 中 OutputStream 的使用

参数类型为 OutputStream 的 java.beans 中的构造方法
XMLEncoder(OutputStream out)
使用 XML 编码创建一个新的输出流，将 JavaBeans 发送给流 out。

java.io 中 OutputStream 的使用

java.io 中 OutputStream 的子类
class | BufferedOutputStream 该类实现缓冲的输出流。
class | ByteArrayOutputStream 此类实现了一个输出流，其中的数据被写入一个 byte 数组。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | FileOutputStream 文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
class | FilterOutputStream 此类是过滤输出流的所有类的超类。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | PipedOutputStream 可以将管道输出流连接到管道输入流来创建通信管道。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。

声明为 OutputStream 的 java.io 中的字段
protected  OutputStream FilterOutputStream.out
要过滤的基础输出流。

参数类型为 OutputStream 的 java.io 中的方法
 void ByteArrayOutputStream.writeTo(OutputStream out)
将此 byte 数组输出流的全部内容写入到指定的输出流参数中，这与使用 out.write(buf, 0, count) 调用该输出流的 write 方法效果一样。

参数类型为 OutputStream 的 java.io 中的构造方法
BufferedOutputStream(OutputStream out)
创建一个新的缓冲输出流，以将数据写入指定的底层输出流。
BufferedOutputStream(OutputStream out, int size)
创建一个新的缓冲输出流，以将具有指定缓冲区大小的数据写入指定的底层输出流。
DataOutputStream(OutputStream out)
创建一个新的数据输出流，将数据写入指定基础输出流。
FilterOutputStream(OutputStream out)
创建一个构建在指定基础输出流之上的输出流过滤器。
ObjectOutputStream(OutputStream out)
创建写入指定 OutputStream 的 ObjectOutputStream。
OutputStreamWriter(OutputStream out)
创建使用默认字符编码的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, Charset cs)
创建使用给定字符集的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, CharsetEncoder enc)
创建使用给定字符集编码器的 OutputStreamWriter。
OutputStreamWriter(OutputStream out, String charsetName)
创建使用指定字符集的 OutputStreamWriter。
PrintStream(OutputStream out)
创建新的打印流。
PrintStream(OutputStream out, boolean autoFlush)
创建新的打印流。
PrintStream(OutputStream out, boolean autoFlush, String encoding)
创建新的打印流。
PrintWriter(OutputStream out)
根据现有的 OutputStream 创建不带自动行刷新的新 PrintWriter。
PrintWriter(OutputStream out, boolean autoFlush)
通过现有的 OutputStream 创建新的 PrintWriter。

java.lang 中 OutputStream 的使用

返回 OutputStream 的 java.lang 中的方法
OutputStream | Runtime.getLocalizedOutputStream(OutputStream out) 已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
abstract OutputStream | Process.getOutputStream() 获取子进程的输出流。

参数类型为 OutputStream 的 java.lang 中的方法
 OutputStream Runtime.getLocalizedOutputStream(OutputStream out)
已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。

java.net 中 OutputStream 的使用

返回 OutputStream 的 java.net 中的方法
abstract OutputStream | CacheRequest.getBody() 返回可以将响应正文写入其中的 OutputStream。
protected abstract OutputStream | SocketImpl.getOutputStream() 返回此套接字的输出流。
OutputStream | Socket.getOutputStream() 返回此套接字的输出流。
OutputStream | URLConnection.getOutputStream() 返回写入到此连接的输出流。

java.nio.channels 中 OutputStream 的使用

返回 OutputStream 的 java.nio.channels 中的方法
static OutputStream Channels.newOutputStream(WritableByteChannel ch)
构造向给定信道写入字节的流。

参数类型为 OutputStream 的 java.nio.channels 中的方法
static WritableByteChannel Channels.newChannel(OutputStream out)
构造向给定流写入字节的信道。

java.rmi.server 中 OutputStream 的使用

java.rmi.server 中 OutputStream 的子类
 class LogStream
已过时。 无替代版本

返回 OutputStream 的 java.rmi.server 中的方法
 OutputStream LogStream.getOutputStream()
已过时。 无替代版本

参数类型为 OutputStream 的 java.rmi.server 中的方法
static void | RemoteServer.setLog(OutputStream out) 将 RMI 调用记录到输出流 out 中。
void | LogStream.setOutputStream(OutputStream out) 已过时。 无替代版本

java.security 中 OutputStream 的使用

java.security 中 OutputStream 的子类
 class DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

参数类型为 OutputStream 的 java.security 中的方法
void | Certificate.encode(OutputStream stream) 已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

参数类型为 OutputStream 的 java.security 中的构造方法
DigestOutputStream(OutputStream stream, MessageDigest digest)
使用指定的输出流和消息摘要创建一个摘要输出流。

java.sql 中 OutputStream 的使用

返回 OutputStream 的 java.sql 中的方法
OutputStream | Clob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。
OutputStream | SQLXML.setBinaryStream() 获取可用于写入此 SQLXML 实例表示的 XML 值的流。
OutputStream | Blob.setBinaryStream(long pos) 获取用于写入此 Blob 对象表示的 BLOB 值的流。

java.util 中 OutputStream 的使用

参数类型为 OutputStream 的 java.util 中的方法
 void Properties.save(OutputStream out, String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
 void Properties.store(OutputStream out, String comments)
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。
 void Properties.storeToXML(OutputStream os, String comment)
发出一个表示此表中包含的所有属性的 XML 文档。
 void Properties.storeToXML(OutputStream os, String comment, String encoding)
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。

参数类型为 OutputStream 的 java.util 中的构造方法
Formatter(OutputStream os)
构造一个带指定输出流的新 formatter。
Formatter(OutputStream os, String csn)
构造一个带指定输出流和字符集的新 formatter。
Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。

java.util.jar 中 OutputStream 的使用

java.util.jar 中 OutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

参数类型为 OutputStream 的 java.util.jar 中的方法
void | Pack200.Packer.pack(JarFile in, OutputStream out) 接收 JarFile 并将其转换为 Pack200 存档。
void | Pack200.Packer.pack(JarInputStream in, OutputStream out) 接收 JarInputStream 并将其转换成 Pack200 存档。
void | Manifest.write(OutputStream out) 将 Manifest 写入指定的 OutputStream。

参数类型为 OutputStream 的 java.util.jar 中的构造方法
JarOutputStream(OutputStream out)
创建不带清单的新的 JarOutputStream。
JarOutputStream(OutputStream out, Manifest man)
使用指定的 Manifest 创建新的 JarOutputStream。

java.util.logging 中 OutputStream 的使用

参数类型为 OutputStream 的 java.util.logging 中的方法
protected  void StreamHandler.setOutputStream(OutputStream out)
更改输出流。

参数类型为 OutputStream 的 java.util.logging 中的构造方法
StreamHandler(OutputStream out, Formatter formatter)
创建带给定 Formatter 和输出流的 StreamHandler。

java.util.prefs 中 OutputStream 的使用

参数类型为 OutputStream 的 java.util.prefs 中的方法
 void AbstractPreferences.exportNode(OutputStream os)
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
abstract  void Preferences.exportNode(OutputStream os)
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
 void AbstractPreferences.exportSubtree(OutputStream os)
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
abstract  void Preferences.exportSubtree(OutputStream os)
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。

java.util.zip 中 OutputStream 的使用

java.util.zip 中 OutputStream 的子类
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

参数类型为 OutputStream 的 java.util.zip 中的构造方法
CheckedOutputStream(OutputStream out, Checksum cksum)
使用指定校验和创建输出流。
DeflaterOutputStream(OutputStream out)
使用默认压缩器和缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def)
使用指定压缩器和默认缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def, int size)
使用指定压缩器和缓冲区大小创建一个新输出流。
GZIPOutputStream(OutputStream out)
使用默认缓冲区大小创建新的输出流。
GZIPOutputStream(OutputStream out, int size)
使用指定缓冲区大小创建新的输出流。
InflaterOutputStream(OutputStream out)
创建一个带有默认解压缩器和缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl)
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl, int bufLen)
创建一个带有指定解压缩器和缓冲区大小的新输出流。
ZipOutputStream(OutputStream out)
创建新的 ZIP 输出流。

javax.activation 中 OutputStream 的使用

返回 OutputStream 的 javax.activation 中的方法
OutputStream | DataHandler.getOutputStream() 获取此 DataHandler 的 OutputStream，以允许重写底层数据。
OutputStream | DataSource.getOutputStream() 此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。
OutputStream | FileDataSource.getOutputStream() 此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。
OutputStream | URLDataSource.getOutputStream() URL 的 getOutputStream 方法。

参数类型为 OutputStream 的 javax.activation 中的方法
void | DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os) 将对象转换为指定 MIME 类型的字节流，并将其写入输出流。
void | DataHandler.writeTo(OutputStream os) 将数据写入 OutputStream。

javax.crypto 中 OutputStream 的使用

javax.crypto 中 OutputStream 的子类
 class CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

参数类型为 OutputStream 的 javax.crypto 中的构造方法
CipherOutputStream(OutputStream os)
从 OutputStream 构造 CipherOutputStream，不指定 Cipher。
CipherOutputStream(OutputStream os, Cipher c)
从 OutputStream 和 Cipher 构造 CipherOutputStream。

javax.imageio 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.imageio 中的方法
static boolean ImageIO.write(RenderedImage im, String formatName, OutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。

javax.imageio.stream 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.imageio.stream 中的构造方法
FileCacheImageOutputStream(OutputStream stream, File cacheDir)
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
MemoryCacheImageOutputStream(OutputStream stream)
构造将向给定 OutputStream 进行写入的 MemoryCacheImageOutputStream。

javax.print 中 OutputStream 的使用

返回 OutputStream 的 javax.print 中的方法
 OutputStream StreamPrintService.getOutputStream()
获得输出流。

参数类型为 OutputStream 的 javax.print 中的方法
abstract  StreamPrintService StreamPrintServiceFactory.getPrintService(OutputStream out)
返回可打印到指定输出流的 StreamPrintService。

参数类型为 OutputStream 的 javax.print 中的构造方法
StreamPrintService(OutputStream out)
构造一个 StreamPrintService 对象。

javax.sound.midi 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.midi 中的方法
static int MidiSystem.write(Sequence in, int fileType, OutputStream out)
将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。

javax.sound.midi.spi 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.midi.spi 中的方法
abstract  int MidiFileWriter.write(Sequence in, int fileType, OutputStream out)
写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。

javax.sound.sampled 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.sampled 中的方法
static int AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
将表示指定文件类型的音频文件的字节流写入所提供的输出流。

javax.sound.sampled.spi 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sound.sampled.spi 中的方法
abstract  int AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out)
将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

javax.sql.rowset 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.sql.rowset 中的方法
void | WebRowSet.writeXml(OutputStream oStream) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
void | WebRowSet.writeXml(ResultSet rs, OutputStream oStream) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。

javax.sql.rowset.serial 中 OutputStream 的使用

返回 OutputStream 的 javax.sql.rowset.serial 中的方法
OutputStream | SerialClob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
OutputStream | SerialBlob.setBinaryStream(long pos) 获取用于写入此 Blob 对象所表示的 BLOB 值的流。

javax.swing.text 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.swing.text 中的方法
void | DefaultEditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。
abstract void | EditorKit.write(OutputStream out, Document doc, int pos, int len) 将文档中的内容以适合此类型内容处理程序的格式写入给定的流。

javax.swing.text.rtf 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.write(OutputStream out, Document doc, int pos, int len)
以适合此类内容处理程序的格式，将文档中的内容写入给定流。

javax.tools 中 OutputStream 的使用

返回 OutputStream 的 javax.tools 中的方法
OutputStream | FileObject.openOutputStream() 获取此文件对象的 OutputStream。
OutputStream | ForwardingFileObject.openOutputStream()
OutputStream | SimpleJavaFileObject.openOutputStream() 此实现总是抛出 UnsupportedOperationException。

参数类型为 OutputStream 的 javax.tools 中的方法
 int Tool.run(InputStream in, OutputStream out, OutputStream err, String... arguments)
使用给定 I/O 通道和参数运行工具。

javax.xml.bind 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.bind 中的方法
 void Marshaller.marshal(Object jaxbElement, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。

javax.xml.bind.helpers 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.bind.helpers 中的方法
 void AbstractMarshallerImpl.marshal(Object obj, OutputStream os)

javax.xml.crypto.dsig 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.crypto.dsig 中的方法
 Data Transform.transform(Data data, XMLCryptoContext context, OutputStream os)
使用底层转换算法对指定数据进行转换。

javax.xml.soap 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.soap 中的方法
abstract  void SOAPMessage.writeTo(OutputStream out)
将此 SOAPMessage 对象写入给定输出流。

javax.xml.stream 中 OutputStream 的使用

参数类型为 OutputStream 的 javax.xml.stream 中的方法
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream) 创建一个写入到流的新 XMLEventWriter。
abstract XMLEventWriter | XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLEventWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream) 创建一个写入到流的新 XMLStreamWriter。
abstract XMLStreamWriter | XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding) 创建一个写入到流的新 XMLStreamWriter。

javax.xml.transform.stream 中 OutputStream 的使用

返回 OutputStream 的 javax.xml.transform.stream 中的方法
 OutputStream StreamResult.getOutputStream()
获取通过 setOutputStream 设置的字节流。

参数类型为 OutputStream 的 javax.xml.transform.stream 中的方法
 void StreamResult.setOutputStream(OutputStream outputStream)
设置要写入的 ByteStream。

参数类型为 OutputStream 的 javax.xml.transform.stream 中的构造方法
StreamResult(OutputStream outputStream)
从字节流构造 StreamResult。

org.ietf.jgss 中 OutputStream 的使用

参数类型为 OutputStream 的 org.ietf.jgss 中的方法
void | GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream) 由上下文接受端调用，以处理来自使用流的同位体的标记。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
int | GSSContext.initSecContext(InputStream inStream, OutputStream outStream) 由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

org.omg.CORBA.portable 中 OutputStream 的使用

org.omg.CORBA.portable 中 OutputStream 的子类
 class OutputStream
OuputStream 是用来将 IDL 类型写入 CDR 编组流的 Java API。

org.w3c.dom.ls 中 OutputStream 的使用

返回 OutputStream 的 org.w3c.dom.ls 中的方法
 OutputStream LSOutput.getByteStream()
具有语言和绑定依赖性类型的属性，表示字节的可写流。

参数类型为 OutputStream 的 org.w3c.dom.ls 中的方法
 void LSOutput.setByteStream(OutputStream byteStream)
具有语言和绑定依赖性类型的属性，表示字节的可写流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.Flushable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Flushable
的使用

使用 Flushable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 Flushable 的使用

实现 Flushable 的 java.io 中的类
class | BufferedOutputStream 该类实现缓冲的输出流。
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | ByteArrayOutputStream 此类实现了一个输出流，其中的数据被写入一个 byte 数组。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | Console 此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | FileOutputStream 文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterOutputStream 此类是过滤输出流的所有类的超类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | OutputStream 此抽象类是表示输出字节流的所有类的超类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedOutputStream 可以将管道输出流连接到管道输入流来创建通信管道。
class | PipedWriter 传送的字符输出流。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
class | Writer 写入字符流的抽象类。

java.rmi.server 中 Flushable 的使用

实现 Flushable 的 java.rmi.server 中的类
 class LogStream
已过时。 无替代版本

java.security 中 Flushable 的使用

实现 Flushable 的 java.security 中的类
 class DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

java.util 中 Flushable 的使用

实现 Flushable 的 java.util 中的类
 class Formatter
printf 风格的格式字符串的解释程序。

java.util.jar 中 Flushable 的使用

实现 Flushable 的 java.util.jar 中的类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 Flushable 的使用

实现 Flushable 的 java.util.zip 中的类
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

javax.crypto 中 Flushable 的使用

实现 Flushable 的 javax.crypto 中的类
 class CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

javax.tools 中 Flushable 的使用

javax.tools 中 Flushable 的子接口
interface | JavaFileManager 在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
interface | StandardJavaFileManager 基于 java.io.File 的文件管理器。

实现 Flushable 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FileDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileDescriptor
的使用

使用 FileDescriptor 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。

java.io 中 FileDescriptor 的使用

声明为 FileDescriptor 的 java.io 中的字段
static FileDescriptor | FileDescriptor.err 标准错误流的句柄。
static FileDescriptor | FileDescriptor.in 标准输入流的句柄。
static FileDescriptor | FileDescriptor.out 标准输出流的句柄。

返回 FileDescriptor 的 java.io 中的方法
FileDescriptor | RandomAccessFile.getFD() 返回与此流关联的不透明文件描述符对象。
FileDescriptor | FileOutputStream.getFD() 返回与此流有关的文件描述符。
FileDescriptor | FileInputStream.getFD() 返回表示到文件系统中实际文件的连接的 FileDescriptor 对象，该文件系统正被此 FileInputStream 使用。

参数类型为 FileDescriptor 的 java.io 中的构造方法
FileInputStream(FileDescriptor fdObj)
通过使用文件描述符 fdObj 创建一个 FileInputStream，该文件描述符表示到文件系统中某个实际文件的现有连接。
FileOutputStream(FileDescriptor fdObj)
创建一个向指定文件描述符处写入数据的输出文件流，该文件描述符表示一个到文件系统中的某个实际文件的现有连接。
FileReader(FileDescriptor fd)
在给定从中读取数据的 FileDescriptor 的情况下创建一个新 FileReader。
FileWriter(FileDescriptor fd)
构造与某个文件描述符相关联的 FileWriter 对象。

java.lang 中 FileDescriptor 的使用

参数类型为 FileDescriptor 的 java.lang 中的方法
void | SecurityManager.checkRead(FileDescriptor fd) 如果不允许调用线程从指定的文件描述符进行读取，则抛出 SecurityException。
void | SecurityManager.checkWrite(FileDescriptor fd) 如果不允许调用线程写入指定的文件描述符，则抛出 SecurityException。

java.net 中 FileDescriptor 的使用

声明为 FileDescriptor 的 java.net 中的字段
protected FileDescriptor | DatagramSocketImpl.fd 文件描述符对象。
protected FileDescriptor | SocketImpl.fd 此套接字的文件描述符对象。

返回 FileDescriptor 的 java.net 中的方法
protected FileDescriptor | DatagramSocketImpl.getFileDescriptor() 获取数据报套接字文件描述符。
protected FileDescriptor | SocketImpl.getFileDescriptor() 返回此套接字的 fd 字段的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.FileInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.FileInputStream
的使用

没有 java.io.FileInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.InputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.InputStream
的使用

使用 InputStream 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.management.loading | 提供实现高级动态加载的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert | 为公钥证书提供类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.applet 中 InputStream 的使用

返回 InputStream 的 java.applet 中的方法
 InputStream AppletContext.getStream(String key)
返回此 applet 上下文中指定键所关联的流。

参数类型为 InputStream 的 java.applet 中的方法
 void AppletContext.setStream(String key, InputStream stream)
在此 applet 上下文中用指定的键关联指定的流。

java.awt 中 InputStream 的使用

参数类型为 InputStream 的 java.awt 中的方法
static Font Font.createFont(int fontFormat, InputStream fontStream)
返回一个使用指定字体类型和输入数据的新 Font。

java.awt.color 中 InputStream 的使用

参数类型为 InputStream 的 java.awt.color 中的方法
static ICC_Profile ICC_Profile.getInstance(InputStream s)
构造一个与 InputStream 中的数据相对应的 ICC_Profile。

java.beans 中 InputStream 的使用

参数类型为 InputStream 的 java.beans 中的构造方法
XMLDecoder(InputStream in)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

java.beans.beancontext 中 InputStream 的使用

返回 InputStream 的 java.beans.beancontext 中的方法
 InputStream BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream BeanContextSupport.getResourceAsStream(String name, BeanContextChild bcc)

java.io 中 InputStream 的使用

java.io 中 InputStream 的子类
class | BufferedInputStream BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
class | ByteArrayInputStream ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | FileInputStream FileInputStream 从文件系统中的某个文件中获得输入字节。
class | FilterInputStream FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | PipedInputStream 管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
class | PushbackInputStream PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。
class | SequenceInputStream SequenceInputStream 表示其他输入流的逻辑串联。
class | StringBufferInputStream 已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。

声明为 InputStream 的 java.io 中的字段
protected  InputStream FilterInputStream.in
要过滤的输入流。

参数类型为 InputStream 的 java.io 中的构造方法
BufferedInputStream(InputStream in)
创建一个 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
BufferedInputStream(InputStream in, int size)
创建具有指定缓冲区大小的 BufferedInputStream 并保存其参数，即输入流 in，以便将来使用。
DataInputStream(InputStream in)
使用指定的底层 InputStream 创建一个 DataInputStream。
FilterInputStream(InputStream in)
将参数 in 分配给字段 this.in，以便记住它供以后使用，通过这种方式创建一个 FilterInputStream。
InputStreamReader(InputStream in)
创建一个使用默认字符集的 InputStreamReader。
InputStreamReader(InputStream in, Charset cs)
创建使用给定字符集的 InputStreamReader。
InputStreamReader(InputStream in, CharsetDecoder dec)
创建使用给定字符集解码器的 InputStreamReader。
InputStreamReader(InputStream in, String charsetName)
创建使用指定字符集的 InputStreamReader。
LineNumberInputStream(InputStream in)
已过时。 构造从指定输入流读取其输入的新行号输入流。
ObjectInputStream(InputStream in)
创建从指定 InputStream 读取的 ObjectInputStream。
PushbackInputStream(InputStream in)
创建 PushbackInputStream 并保存其参数（即输入流 in），以供将来使用。
PushbackInputStream(InputStream in, int size)
使用指定 size 的推回缓冲区创建 PushbackInputStream，并保存其参数（即输入流 in），以供将来使用。
SequenceInputStream(InputStream s1, InputStream s2)
通过记住这两个参数来初始化新创建的 SequenceInputStream（将按顺序读取这两个参数，先读取 s1，然后读取 s2），以提供从此 SequenceInputStream 读取的字节。
StreamTokenizer(InputStream is)
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);

类型变量类型为 InputStream 的 java.io 中的构造方法参数
SequenceInputStream(Enumeration<? extends InputStream> e)
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。

java.lang 中 InputStream 的使用

声明为 InputStream 的 java.lang 中的字段
static InputStream System.in
“标准”输入流。

返回 InputStream 的 java.lang 中的方法
abstract InputStream | Process.getErrorStream() 获取子进程的错误流。
abstract InputStream | Process.getInputStream() 获取子进程的输入流。
InputStream | Runtime.getLocalizedInputStream(InputStream in) 已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
InputStream | ClassLoader.getResourceAsStream(String name) 返回读取指定资源的输入流。
InputStream | Class.getResourceAsStream(String name) 查找具有给定名称的资源。
static InputStream | ClassLoader.getSystemResourceAsStream(String name) 从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。

参数类型为 InputStream 的 java.lang 中的方法
InputStream | Runtime.getLocalizedInputStream(InputStream in) 已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
static void | System.setIn(InputStream in) 重新分配“标准”输入流。

java.net 中 InputStream 的使用

返回 InputStream 的 java.net 中的方法
abstract InputStream | CacheResponse.getBody() 以 InputStream 的形式返回响应正文。
InputStream | HttpURLConnection.getErrorStream() 如果连接失败但服务器仍然发送了有用数据，则返回错误流。
protected abstract InputStream | SocketImpl.getInputStream() 返回此套接字的输入流。
InputStream | Socket.getInputStream() 返回此套接字的输入流。
InputStream | URLConnection.getInputStream() 返回从此打开的连接读取的输入流。
InputStream | URL.openStream() 打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。

参数类型为 InputStream 的 java.net 中的方法
static String URLConnection.guessContentTypeFromStream(InputStream is)
根据输入流的开始字符尝试确定输入流的类型。

java.nio.channels 中 InputStream 的使用

返回 InputStream 的 java.nio.channels 中的方法
static InputStream Channels.newInputStream(ReadableByteChannel ch)
构造从给定信道读取字节的流。

参数类型为 InputStream 的 java.nio.channels 中的方法
static ReadableByteChannel Channels.newChannel(InputStream in)
构造从给定流读取字节的信道。

java.security 中 InputStream 的使用

java.security 中 InputStream 的子类
 class DigestInputStream
使用通过流的位更新关联消息摘要的透明流。

参数类型为 InputStream 的 java.security 中的方法
void | Certificate.decode(InputStream stream) 已过时。 从输入流解码证书。
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | Provider.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。

参数类型为 InputStream 的 java.security 中的构造方法
DigestInputStream(InputStream stream, MessageDigest digest)
使用指定的输入流和消息摘要创建一个摘要输入流。

java.security.cert 中 InputStream 的使用

参数类型为 InputStream 的 java.security.cert 中的方法
abstract Certificate | CertificateFactorySpi.engineGenerateCertificate(InputStream inStream) 生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
abstract CRL | CertificateFactorySpi.engineGenerateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Certificate | CertificateFactory.generateCertificate(InputStream inStream) 生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactory.generateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CRL | CertificateFactory.generateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。

java.sql 中 InputStream 的使用

返回 InputStream 的 java.sql 中的方法
InputStream | Clob.getAsciiStream() 以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。
InputStream | ResultSet.getAsciiStream(int columnIndex) 以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | ResultSet.getAsciiStream(String columnLabel) 以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | Blob.getBinaryStream() 以流的形式获取此 Blob 实例指定的 BLOB 值。
InputStream | SQLXML.getBinaryStream() 以流的形式获取此 SQLXML 实例指定的 XML 值。
InputStream | ResultSet.getBinaryStream(int columnIndex) 以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | Blob.getBinaryStream(long pos, long length) 返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。
InputStream | ResultSet.getBinaryStream(String columnLabel) 以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | ResultSet.getUnicodeStream(int columnIndex) 已过时。 使用 getCharacterStream 取代 getUnicodeStream
InputStream | ResultSet.getUnicodeStream(String columnLabel) 已过时。 使用 getCharacterStream 代替
InputStream | SQLInput.readAsciiStream() 读取流中的下一个属性并将其作为 ASCII 字符流返回。
InputStream | SQLInput.readBinaryStream() 读取流中的下一个属性并将其作为未解释的字节流返回。

参数类型为 InputStream 的 java.sql 中的方法
void | PreparedStatement.setAsciiStream(int parameterIndex, InputStream x) 将指定参数设置为给定输入流。
void | PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将具有给定字节数。
void | PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将具有指定字节数。
void | CallableStatement.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | CallableStatement.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | CallableStatement.setAsciiStream(String parameterName, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | PreparedStatement.setBinaryStream(int parameterIndex, InputStream x) 将指定参数设置为给定输入流。
void | PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将具有给定字节数。
void | PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将具有指定字节数。
void | CallableStatement.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | CallableStatement.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | CallableStatement.setBinaryStream(String parameterName, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | PreparedStatement.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | PreparedStatement.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | CallableStatement.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | CallableStatement.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | PreparedStatement.setUnicodeStream(int parameterIndex, InputStream x, int length) 已过时。
void | ResultSet.updateAsciiStream(int columnIndex, InputStream x) 用 ascii 流值更新指定的列。
void | ResultSet.updateAsciiStream(int columnIndex, InputStream x, int length) 用 ascii 流值更新指定列，该列将具有指定字节数。
void | ResultSet.updateAsciiStream(int columnIndex, InputStream x, long length) 用 ascii 流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateAsciiStream(String columnLabel, InputStream x) 用 ascii 流值更新指定列。
void | ResultSet.updateAsciiStream(String columnLabel, InputStream x, int length) 用 ascii 流值更新指定列，该列具有指定的字节数。
void | ResultSet.updateAsciiStream(String columnLabel, InputStream x, long length) 用 ascii 流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateBinaryStream(int columnIndex, InputStream x) 用二进制流值更新指定的列。
void | ResultSet.updateBinaryStream(int columnIndex, InputStream x, int length) 用二进制流值更新指定列，该列将具有指定字节数。
void | ResultSet.updateBinaryStream(int columnIndex, InputStream x, long length) 用二进制流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateBinaryStream(String columnLabel, InputStream x) 用二进制流值更新指定列。
void | ResultSet.updateBinaryStream(String columnLabel, InputStream x, int length) 用二进制流值更新指定列，该列具有指定的字节数。
void | ResultSet.updateBinaryStream(String columnLabel, InputStream x, long length) 用二进制流值更新指定的列，该值将具有指定的字节数。
void | ResultSet.updateBlob(int columnIndex, InputStream inputStream) 使用给定输入流值更新指定列。
void | ResultSet.updateBlob(int columnIndex, InputStream inputStream, long length) 使用给定输入流更新指定的列，该流将具有指定的字节数。
void | ResultSet.updateBlob(String columnLabel, InputStream inputStream) 使用给定输入流值更新指定列。
void | ResultSet.updateBlob(String columnLabel, InputStream inputStream, long length) 使用给定输入流更新指定列，该流将具有指定的字节数。
void | SQLOutput.writeAsciiStream(InputStream x) 将下一个属性作为 ASCII 字符流写入流中。
void | SQLOutput.writeBinaryStream(InputStream x) 将下一个属性作为未解释字节流写入流中。

java.util 中 InputStream 的使用

参数类型为 InputStream 的 java.util 中的方法
void | Properties.load(InputStream inStream) 从输入流中读取属性列表（键和元素对）。
void | Properties.loadFromXML(InputStream in) 将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。

参数类型为 InputStream 的 java.util 中的构造方法
PropertyResourceBundle(InputStream stream)
根据 InputStream 创建属性资源包。
Scanner(InputStream source)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(InputStream source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。

java.util.jar 中 InputStream 的使用

java.util.jar 中 InputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

返回 InputStream 的 java.util.jar 中的方法
 InputStream JarFile.getInputStream(ZipEntry ze)
返回用于读取指定 zip 文件条目内容的输入流。

参数类型为 InputStream 的 java.util.jar 中的方法
void | Manifest.read(InputStream is) 从指定的 InputStream 读取 Manifest。
void | Pack200.Unpacker.unpack(InputStream in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

参数类型为 InputStream 的 java.util.jar 中的构造方法
JarInputStream(InputStream in)
创建新的 JarInputStream 并读取可选的清单。
JarInputStream(InputStream in, boolean verify)
创建新的 JarInputStream 并读取可选的清单。
Manifest(InputStream is)
从指定的输入流构造新的 Manifest。

java.util.logging 中 InputStream 的使用

参数类型为 InputStream 的 java.util.logging 中的方法
 void LogManager.readConfiguration(InputStream ins)
从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。

java.util.prefs 中 InputStream 的使用

参数类型为 InputStream 的 java.util.prefs 中的方法
static void Preferences.importPreferences(InputStream is)
导入指定输入流中由 XML 文档表示的所有首选项。

java.util.zip 中 InputStream 的使用

java.util.zip 中 InputStream 的子类
class | CheckedInputStream 需要维护所读取数据校验和的输入流。
class | DeflaterInputStream 为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | InflaterInputStream 此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。

返回 InputStream 的 java.util.zip 中的方法
 InputStream ZipFile.getInputStream(ZipEntry entry)
返回输入流以读取指定 ZIP 文件条目的内容。

参数类型为 InputStream 的 java.util.zip 中的构造方法
CheckedInputStream(InputStream in, Checksum cksum)
使用指定校验和创建输入流。
DeflaterInputStream(InputStream in)
创建一个带有默认压缩器和缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl)
创建一个带有指定压缩器和默认缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl, int bufLen)
创建一个带有指定压缩器和缓冲区大小的新输入流。
GZIPInputStream(InputStream in)
使用默认缓冲区大小创建新的输入流。
GZIPInputStream(InputStream in, int size)
使用指定缓冲区大小创建新的输入流。
InflaterInputStream(InputStream in)
使用默认解压缩器和缓冲区大小创建一个新输入流。
InflaterInputStream(InputStream in, Inflater inf)
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。
InflaterInputStream(InputStream in, Inflater inf, int size)
使用指定解压缩器和缓冲区大小创建一个新输入流。
ZipInputStream(InputStream in)
创建新的 ZIP 输入流。

javax.accessibility 中 InputStream 的使用

返回 InputStream 的 javax.accessibility 中的方法
 InputStream AccessibleStreamable.getStream(DataFlavor flavor)
返回 DataFlavor 的 InputStream

javax.activation 中 InputStream 的使用

返回 InputStream 的 javax.activation 中的方法
InputStream | DataHandler.getInputStream() 获取此对象的 InputSteam。
InputStream | DataSource.getInputStream() 此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。
InputStream | FileDataSource.getInputStream() 此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。
InputStream | URLDataSource.getInputStream() URL 的 getInputStream 方法。

参数类型为 InputStream 的 javax.activation 中的构造方法
MailcapCommandMap(InputStream is)
允许调用者指定一个包含 mailcap 文件的 InputStream 的构造方法。
MimetypesFileTypeMap(InputStream is)
用从 InputStream 中添加的编程条目构造 MimetypesFileTypeMap。

javax.crypto 中 InputStream 的使用

javax.crypto 中 InputStream 的子类
 class CipherInputStream
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。

参数类型为 InputStream 的 javax.crypto 中的构造方法
CipherInputStream(InputStream is)
根据 InputStream 构造 CipherInputStream，不指定 Cipher。
CipherInputStream(InputStream is, Cipher c)
根据 InputStream 和 Cipher 构造 CipherInputStream。

javax.imageio 中 InputStream 的使用

参数类型为 InputStream 的 javax.imageio 中的方法
static BufferedImage ImageIO.read(InputStream input)
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。

javax.imageio.stream 中 InputStream 的使用

参数类型为 InputStream 的 javax.imageio.stream 中的构造方法
FileCacheImageInputStream(InputStream stream, File cacheDir)
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
MemoryCacheImageInputStream(InputStream stream)
构造一个将从给定 InputStream 进行读取的 MemoryCacheImageInputStream。

javax.management.loading 中 InputStream 的使用

返回 InputStream 的 javax.management.loading 中的方法
 InputStream MLetMBean.getResourceAsStream(String name)
返回读取指定资源的输入流。

javax.print 中 InputStream 的使用

返回 InputStream 的 javax.print 中的方法
InputStream | Doc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。
InputStream | SimpleDoc.getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。

javax.security.auth.x500 中 InputStream 的使用

参数类型为 InputStream 的 javax.security.auth.x500 中的构造方法
X500Principal(InputStream is)
根据包含 ASN.1 DER 编码格式的标识名的 InputStream 创建 X500Principal。

javax.security.cert 中 InputStream 的使用

参数类型为 InputStream 的 javax.security.cert 中的方法
static X509Certificate X509Certificate.getInstance(InputStream inStream)
实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。

javax.sound.midi 中 InputStream 的使用

参数类型为 InputStream 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
void | Sequencer.setSequence(InputStream stream) 设置 sequencer 所操作的当前 sequence。

javax.sound.midi.spi 中 InputStream 的使用

参数类型为 InputStream 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。

javax.sound.sampled 中 InputStream 的使用

javax.sound.sampled 中 InputStream 的子类
 class AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。

参数类型为 InputStream 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。

参数类型为 InputStream 的 javax.sound.sampled 中的构造方法
AudioInputStream(InputStream stream, AudioFormat format, long length)
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。

javax.sound.sampled.spi 中 InputStream 的使用

参数类型为 InputStream 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。

javax.sql 中 InputStream 的使用

参数类型为 InputStream 的 javax.sql 中的方法
void | RowSet.setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setAsciiStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有给定字节数。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。

javax.sql.rowset 中 InputStream 的使用

声明为 InputStream 的 javax.sql.rowset 中的字段
protected InputStream | BaseRowSet.asciiStream 将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
protected InputStream | BaseRowSet.binaryStream 将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
protected InputStream | BaseRowSet.unicodeStream 将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

参数类型为 InputStream 的 javax.sql.rowset 中的方法
void | WebRowSet.readXml(InputStream iStream) 读取基于流的 XML 输入，以填充此 WebRowSet 对象。
void | BaseRowSet.setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | BaseRowSet.setAsciiStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。
void | BaseRowSet.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定的输入流。
void | BaseRowSet.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | BaseRowSet.setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | BaseRowSet.setBinaryStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。
void | BaseRowSet.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | BaseRowSet.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。
void | BaseRowSet.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | BaseRowSet.setUnicodeStream(int parameterIndex, InputStream x, int length) 已过时。 应该使用 getCharacterStream 替代它

javax.sql.rowset.serial 中 InputStream 的使用

返回 InputStream 的 javax.sql.rowset.serial 中的方法
InputStream | SerialClob.getAsciiStream() 以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
InputStream | SerialBlob.getBinaryStream() 以输入流的形式返回此 SerialBlob 对象。
InputStream | SerialBlob.getBinaryStream(long pos, long length) 返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。
InputStream | SQLInputImpl.readAsciiStream() 以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。
InputStream | SQLInputImpl.readBinaryStream() 以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。

参数类型为 InputStream 的 javax.sql.rowset.serial 中的方法
void | SQLOutputImpl.writeAsciiStream(InputStream x) 将 ASCII 字符流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBinaryStream(InputStream x) 将未解释字节流写入此 SQLOutputImpl 对象。

javax.swing 中 InputStream 的使用

javax.swing 中 InputStream 的子类
 class ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

返回 InputStream 的 javax.swing 中的方法
protected  InputStream JEditorPane.getStream(URL page)
获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。

参数类型为 InputStream 的 javax.swing 中的方法
 void JEditorPane.read(InputStream in, Object desc)
此方法根据流进行初始化。

参数类型为 InputStream 的 javax.swing 中的构造方法
ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
构造一个对象，以监视输入流的进度。

javax.swing.plaf.synth 中 InputStream 的使用

参数类型为 InputStream 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(InputStream input, Class<?> resourceBase)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text 中 InputStream 的使用

参数类型为 InputStream 的 javax.swing.text 中的方法
void | DefaultEditorKit.read(InputStream in, Document doc, int pos) 插入取自给定流的内容，其格式需要适合此类型的内容处理程序。
abstract void | EditorKit.read(InputStream in, Document doc, int pos) 插入来自给定流的内容，其格式需要适合此类型的内容处理程序。

javax.swing.text.rtf 中 InputStream 的使用

参数类型为 InputStream 的 javax.swing.text.rtf 中的方法
 void RTFEditorKit.read(InputStream in, Document doc, int pos)
插入来自给定流的内容，该内容的格式需要适合于此类内容处理程序。

javax.tools 中 InputStream 的使用

返回 InputStream 的 javax.tools 中的方法
InputStream | FileObject.openInputStream() 获取此文件对象的 InputStream。
InputStream | ForwardingFileObject.openInputStream()
InputStream | SimpleJavaFileObject.openInputStream() 此实现总是抛出 UnsupportedOperationException。

参数类型为 InputStream 的 javax.tools 中的方法
 int Tool.run(InputStream in, OutputStream out, OutputStream err, String... arguments)
使用给定 I/O 通道和参数运行工具。

javax.xml.bind 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.bind.helpers 中的方法
 Object AbstractUnmarshallerImpl.unmarshal(InputStream is)

javax.xml.crypto 中 InputStream 的使用

返回 InputStream 的 javax.xml.crypto 中的方法
 InputStream OctetStreamData.getOctetStream()
返回此 OctetStreamData 的输入流。

参数类型为 InputStream 的 javax.xml.crypto 中的构造方法
OctetStreamData(InputStream octetStream)
创建新的 SocketImpl。
OctetStreamData(InputStream octetStream, String uri, String mimeType)
创建新的 OctetStreamData。

javax.xml.crypto.dsig 中 InputStream 的使用

返回 InputStream 的 javax.xml.crypto.dsig 中的方法
InputStream | SignedInfo.getCanonicalizedData() 在执行签名或验证操作后，返回规范化的签名信息字节。
InputStream | Reference.getDigestInputStream() 如果已启用引用缓存，则返回预整理的输入流。

javax.xml.parsers 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.parsers 中的方法
Document | DocumentBuilder.parse(InputStream is) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。
void | SAXParser.parse(InputStream is, DefaultHandler dh) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, DefaultHandler dh, String systemId) 使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
void | SAXParser.parse(InputStream is, HandlerBase hb, String systemId) 使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。
Document | DocumentBuilder.parse(InputStream is, String systemId) 将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

javax.xml.soap 中 InputStream 的使用

返回 InputStream 的 javax.xml.soap 中的方法
abstract InputStream | AttachmentPart.getBase64Content() 以 Base64 编码字符数据的形式返回可用于获取 AttachmentPart 内容的 InputStream，此方法将对附件的原始字节进行 Base64 编码，然后返回该内容。
abstract InputStream | AttachmentPart.getRawContent() 以 InputStream 的形式获取此 AttachmentPart 对象的内容，等效于调用了 getContent 但没有为此 AttachmentPart 的 content-type 注册 DataContentHandler。

参数类型为 InputStream 的 javax.xml.soap 中的方法
abstract SOAPMessage | MessageFactory.createMessage(MimeHeaders headers, InputStream in) 将给定 InputStream 对象的内容内部化到新的 SOAPMessage 对象，并返回该 SOAPMessage 对象。
abstract void | AttachmentPart.setBase64Content(InputStream content, String contentType) 根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。
abstract void | AttachmentPart.setRawContent(InputStream content, String contentType) 将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

javax.xml.stream 中 InputStream 的使用

参数类型为 InputStream 的 javax.xml.stream 中的方法
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLEventReader | XMLInputFactory.createXMLEventReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLEventReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding) 根据 java.io.InputStream 创建一个新 XMLStreamReader。
abstract XMLStreamReader | XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream) 根据 java.io.InputStream 创建一个新 XMLStreamReader。

javax.xml.transform.stream 中 InputStream 的使用

返回 InputStream 的 javax.xml.transform.stream 中的方法
 InputStream StreamSource.getInputStream()
获取通过 setByteStream 设置的字节流。

参数类型为 InputStream 的 javax.xml.transform.stream 中的方法
 void StreamSource.setInputStream(InputStream inputStream)
设置要用作输入的字节流。

参数类型为 InputStream 的 javax.xml.transform.stream 中的构造方法
StreamSource(InputStream inputStream)
从字节流构造 StreamSource。
StreamSource(InputStream inputStream, String systemId)
从字节流构造 StreamSource。

org.ietf.jgss 中 InputStream 的使用

参数类型为 InputStream 的 org.ietf.jgss 中的方法
void | GSSContext.acceptSecContext(InputStream inStream, OutputStream outStream) 由上下文接受端调用，以处理来自使用流的同位体的标记。
void | GSSContext.getMIC(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来产生包含所提供消息的加密 MIC 的标记，以便传输到同位体应用程序。
int | GSSContext.initSecContext(InputStream inStream, OutputStream outStream) 由上下文初始端调用，以启动上下文的创建阶段，处理由使用流的同位体的 acceptSecContext 方法生成的任何标记。
void | GSSContext.unwrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 使用流来处理在上下文的另一方由 wrap 方法生成的标记。
void | GSSContext.verifyMIC(InputStream tokStream, InputStream msgStream, MessageProp msgProp) 通过提供的消息，使用流来验证包含在标记参数中的加密的 MIC。
void | GSSContext.wrap(InputStream inStream, OutputStream outStream, MessageProp msgProp) 将 per-message 安全服务应用于已创建的使用流的安全上下文。

参数类型为 InputStream 的 org.ietf.jgss 中的构造方法
Oid(InputStream derOid)
从其 ASN.1 DER 编码中创建 Oid 对象。

org.omg.CORBA.portable 中 InputStream 的使用

org.omg.CORBA.portable 中 InputStream 的子类
 class InputStream
InputStream 是用来从 CDR 编组流中读取 IDL 类型的 Java API。

org.w3c.dom.ls 中 InputStream 的使用

返回 InputStream 的 org.w3c.dom.ls 中的方法
 InputStream LSInput.getByteStream()
依赖于语言和绑定类型的属性，表示字节的流。

参数类型为 InputStream 的 org.w3c.dom.ls 中的方法
 void LSInput.setByteStream(InputStream byteStream)
依赖于语言和绑定类型的属性，表示字节流。

org.xml.sax 中 InputStream 的使用

返回 InputStream 的 org.xml.sax 中的方法
 InputStream InputSource.getByteStream()
获取此输入源的字节流。

参数类型为 InputStream 的 org.xml.sax 中的方法
 void InputSource.setByteStream(InputStream byteStream)
设置此输入源的字节流。

参数类型为 InputStream 的 org.xml.sax 中的构造方法
InputSource(InputStream byteStream)
使用字节流创建新的输入源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.Closeable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Closeable
的使用

使用 Closeable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.crypto | 为加密操作提供类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 Closeable 的使用

实现 Closeable 的 java.io 中的类
class | BufferedInputStream BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。
class | BufferedOutputStream 该类实现缓冲的输出流。
class | BufferedReader 从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | ByteArrayInputStream ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。
class | ByteArrayOutputStream 此类实现了一个输出流，其中的数据被写入一个 byte 数组。
class | CharArrayReader 此类实现一个可用作字符输入流的字符缓冲区。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | DataInputStream 数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。
class | DataOutputStream 数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。
class | FileInputStream FileInputStream 从文件系统中的某个文件中获得输入字节。
class | FileOutputStream 文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。
class | FileReader 用来读取字符文件的便捷类。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterInputStream FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。
class | FilterOutputStream 此类是过滤输出流的所有类的超类。
class | FilterReader 用于读取已过滤的字符流的抽象类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | InputStream 此抽象类是表示字节输入流的所有类的超类。
class | InputStreamReader InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | LineNumberReader 跟踪行号的缓冲字符输入流。
class | ObjectInputStream ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。
class | ObjectOutputStream ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。
class | OutputStream 此抽象类是表示输出字节流的所有类的超类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedInputStream 管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。
class | PipedOutputStream 可以将管道输出流连接到管道输入流来创建通信管道。
class | PipedReader 传送的字符输入流。
class | PipedWriter 传送的字符输出流。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | PushbackInputStream PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。
class | PushbackReader 允许将字符推回到流的字符流 reader。
class | RandomAccessFile 此类的实例支持对随机访问文件的读取和写入。
class | Reader 用于读取字符流的抽象类。
class | SequenceInputStream SequenceInputStream 表示其他输入流的逻辑串联。
class | StringBufferInputStream 已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。
class | StringReader 其源为一个字符串的字符流。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
class | Writer 写入字符流的抽象类。

java.nio.channels 中 Closeable 的使用

java.nio.channels 中 Closeable 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | Channel 用于 I/O 操作的连接。
interface | GatheringByteChannel 可从缓冲区序列写入字节的通道。
interface | InterruptibleChannel 可被异步关闭和中断的通道。
interface | ReadableByteChannel 可读取字节的通道。
interface | ScatteringByteChannel 可将字节读入缓冲区序列的通道。
interface | WritableByteChannel 可写入字节的通道。

实现 Closeable 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 Closeable 的使用

实现 Closeable 的 java.nio.channels.spi 中的类
class | AbstractInterruptibleChannel 可中断通道的基本实现类。
class | AbstractSelectableChannel 可选择通道的基本实现类。

java.rmi.server 中 Closeable 的使用

实现 Closeable 的 java.rmi.server 中的类
 class LogStream
已过时。 无替代版本

java.security 中 Closeable 的使用

实现 Closeable 的 java.security 中的类
class | DigestInputStream 使用通过流的位更新关联消息摘要的透明流。
class | DigestOutputStream 使用通过流的位更新关联消息摘要的透明流。

java.util 中 Closeable 的使用

实现 Closeable 的 java.util 中的类
 class Formatter
printf 风格的格式字符串的解释程序。

java.util.jar 中 Closeable 的使用

实现 Closeable 的 java.util.jar 中的类
class | JarInputStream JarInputStream 类用于从任何输入流读取 JAR 文件内容。
class | JarOutputStream JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 Closeable 的使用

实现 Closeable 的 java.util.zip 中的类
class | CheckedInputStream 需要维护所读取数据校验和的输入流。
class | CheckedOutputStream 需要维护写入数据校验和的输出流。
class | DeflaterInputStream 为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
class | DeflaterOutputStream 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | InflaterInputStream 此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
class | InflaterOutputStream 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

javax.crypto 中 Closeable 的使用

实现 Closeable 的 javax.crypto 中的类
class | CipherInputStream CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。
class | CipherOutputStream CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

javax.management.remote 中 Closeable 的使用

javax.management.remote 中 Closeable 的子接口
 interface JMXConnector
JMX API 连接器的客户端。

javax.management.remote.rmi 中 Closeable 的使用

javax.management.remote.rmi 中 Closeable 的子接口
 interface RMIConnection
RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。

实现 Closeable 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl RMIConnection 接口的实现。
class | RMIConnectionImpl_Stub
class | RMIConnector 一个到远程 RMI 连接器的连接。
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
class | RMIServerImpl 表示连接器服务器的 RMI 对象。

javax.sound.sampled 中 Closeable 的使用

实现 Closeable 的 javax.sound.sampled 中的类
 class AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。

javax.swing 中 Closeable 的使用

实现 Closeable 的 javax.swing 中的类
 class ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

javax.tools 中 Closeable 的使用

javax.tools 中 Closeable 的子接口
interface | JavaFileManager 在 Java™ 编程语言源和类文件之上进行操作的工具的文件管理器。
interface | StandardJavaFileManager 基于 java.io.File 的文件管理器。

实现 Closeable 的 javax.tools 中的类
 class ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.io.ObjectStreamField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.io.ObjectStreamField
的使用

使用 ObjectStreamField 的软件包
java.io 通过数据流、序列化和文件系统提供系统输入和输出。

java.io 中 ObjectStreamField 的使用

声明为 ObjectStreamField 的 java.io 中的字段
static ObjectStreamField[] ObjectStreamClass.NO_FIELDS
指示不存在可序列化字段的 serialPersistentFields 值。

返回 ObjectStreamField 的 java.io 中的方法
ObjectStreamField | ObjectStreamClass.getField(String name) 按名称获取此类的字段。
ObjectStreamField[] | ObjectStreamClass.getFields() 返回此可序列化类的字段组成的数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.io.Serializable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.io.Serializable
的使用

使用 Serializable 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.jws |
javax.jws.soap |
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.SendingContext | 为值类型的编组提供支持。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.applet 中 Serializable 的使用

实现 Serializable 的 java.applet 中的类
class | Applet applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。
protected class | Applet.AccessibleApplet 此类实现对 Applet 类的可访问性支持。

java.awt 中 Serializable 的使用

实现 Serializable 的 java.awt 中的类
class | AWTError 当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。
class | AWTEvent 所有 AWT 事件的根事件类。
class | AWTException 表示发生了 Absract Window Toolkit 异常。
class | AWTKeyStroke AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。
class | AWTPermission 此类用于 AWT 权限。
class | BorderLayout 这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。
class | Button 此类创建一个标签按钮。
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
class | CardLayout CardLayout 对象是容器的布局管理器。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
class | CheckboxGroup CheckboxGroup 类用于集合 Checkbox 按钮集。
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
class | Choice Choice 类表示一个弹出式选择菜单。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
class | Color Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。
class | Component component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。
protected class | Component.AccessibleAWTComponent 用来为可访问性提供默认支持的 Component 的内部类。
static class | Component.BaselineResizeBehavior 常见方式的枚举，指示组件的基线可以随大小的更改而更改。
class | ComponentOrientation ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。
class | Container 一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
class | ContainerOrderFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
class | Cursor 封装鼠标光标的位图表示形式的类。
class | DefaultFocusTraversalPolicy 根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。
static class | Desktop.Action 表示动作类型。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
static class | Dialog.ModalExclusionType 任何顶层窗口都可以标记为不受模式对话框阻塞。
static class | Dialog.ModalityType 模式对话框阻塞对某些顶层窗口的所有输入。
class | Dimension Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
class | Event 注：Event 类已废弃，只可用于向后兼容。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | FlowLayout 流布局用于安排有向流中的组件，这非常类似于段落中的文本行。
class | Font Font 类表示字体，可以使用它以可见方式呈现文本。
class | FontFormatException 此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
class | FontMetrics FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。
class | Frame Frame 是带有标题和边框的顶层窗口。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
class | GraphicsConfigTemplate GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。
class | GridBagConstraints GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
class | GridBagLayout GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。
class | GridBagLayoutInfo GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。
class | GridLayout GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。
class | Insets Insets 对象是容器边界的表示形式。
class | Label Label 对象是一个可在容器中放置文本的组件。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
class | List List 组件为用户提供了一个可滚动的文本项列表。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
class | MediaTracker MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
class | MenuComponent 抽象类 MenuComponent 是所有与菜单相关的组件的超类。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
class | MenuItem 菜单中的所有项必须属于类 MenuItem 或其子类之一。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
class | MenuShortcut 表示 MenuItem 键盘加速器的 MenuShortcut 类。
static class | MultipleGradientPaint.ColorSpaceType 在其中执行渐变插值操作的颜色空间。
static class | MultipleGradientPaint.CycleMethod 在渐变边界以外进行绘制时使用的方法。
class | Panel Panel 是最简单的容器类。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
class | Point 表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
class | Polygon Polygon 类封装了坐标空间中封闭的二维区域的描述。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
class | Rectangle Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
class | ScrollPaneAdjustable 此类表示 ScrollPane 的水平或垂直滚动条的状态。
class | SystemColor 封装表示系统中本机 GUI 对象颜色的象征性颜色的类。
class | TextArea TextArea 对象是显示文本的多行区域。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
static class | TrayIcon.MessageType MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

java.awt.color 中 Serializable 的使用

实现 Serializable 的 java.awt.color 中的类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ColorSpace 此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。
class | ICC_ColorSpace ICC_ColorSpace 类是抽象 ColorSpace 类的实现。
class | ICC_Profile 与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。
class | ICC_ProfileGray ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。
class | ICC_ProfileRGB ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.datatransfer 中 Serializable 的使用

实现 Serializable 的 java.awt.datatransfer 中的类
class | DataFlavor DataFlavor 提供有关数据的元信息。
class | FlavorEvent FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。
class | MimeTypeParseException 对分析相关异常的 MimeType 进行封装的类
class | UnsupportedFlavorException 在此 flavor 中不支持所请求的数据的信号。

java.awt.dnd 中 Serializable 的使用

实现 Serializable 的 java.awt.dnd 中的类
class | DragGestureEvent 当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
class | DragGestureRecognizer DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。
class | DragSource DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
class | DragSourceDragEvent 通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
class | DragSourceDropEvent 通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
class | DragSourceEvent 此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
class | DropTarget 在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
class | DropTargetContext 每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。
class | DropTargetDragEvent 通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
class | DropTargetDropEvent 通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
class | DropTargetEvent DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。
class | InvalidDnDOperationException java.awt.dnd 包中的各种方法都会抛出此异常。
class | MouseDragGestureRecognizer DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

java.awt.event 中 Serializable 的使用

实现 Serializable 的 java.awt.event 中的类
class | ActionEvent 指示发生了组件定义的动作的语义事件。
class | AdjustmentEvent 由 Adjustable 对象所发出的调整事件。
class | ComponentEvent 指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | HierarchyEvent 指示 Component 所属的 Component 层次结构发生更改的事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | InputMethodEvent 输入方法事件包含有关使用输入方法进行撰写的文本的信息。
class | InvocationEvent 当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
class | ItemEvent 指示项被选定或取消选定的语义事件。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | TextEvent 指示对象文本已改变的语义事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

java.awt.font 中 Serializable 的使用

实现 Serializable 的 java.awt.font 中的类
class | NumericShaper NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。
class | TextAttribute TextAttribute 类定义用于呈现文本的属性键和属性值。
class | TransformAttribute TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。

java.awt.geom 中 Serializable 的使用

实现 Serializable 的 java.awt.geom 中的类
class | AffineTransform AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
class | IllegalPathStateException 对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。
class | NoninvertibleTransformException NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
static class | Point2D.Double Double 类以 double 精度定义指定的点。
static class | Point2D.Float Float 类以 float 精度定义指定的点。
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

java.awt.image 中 Serializable 的使用

实现 Serializable 的 java.awt.image 中的类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.awt.image.renderable 中 Serializable 的使用

实现 Serializable 的 java.awt.image.renderable 中的类
 class ParameterBlock
ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。

java.awt.print 中 Serializable 的使用

实现 Serializable 的 java.awt.print 中的类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterException PrinterException 类及其子类用于指示打印系统中发生的异常情况。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

java.beans 中 Serializable 的使用

实现 Serializable 的 java.beans 中的类
class | IndexedPropertyChangeEvent 无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。
class | IntrospectionException 在 Introspection 期间发生异常时抛出异常。
class | PropertyChangeEvent 无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。
class | PropertyChangeSupport 这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。
class | PropertyVetoException 当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。
class | VetoableChangeSupport 这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。

java.beans.beancontext 中 Serializable 的使用

实现 Serializable 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextEvent BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
class | BeanContextMembershipEvent BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
class | BeanContextServiceAvailableEvent BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
class | BeanContextServiceRevokedEvent BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
protected class | BeanContextServicesSupport.BCSSChild
protected static class | BeanContextServicesSupport.BCSSServiceProvider 子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。
protected class | BeanContextSupport.BCSChild

返回 Serializable 的 java.beans.beancontext 中的方法
protected static Serializable BeanContextSupport.getChildSerializable(Object child)
获得与指定 Child 相关联的 Serializable（如果有）

java.io 中 Serializable 的使用

java.io 中 Serializable 的子接口
 interface Externalizable
Externalizable 实例类的唯一特性是可以被写入序列化流中，该类负责保存和恢复实例内容。

实现 Serializable 的 java.io 中的类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | File 文件和目录路径名的抽象表示形式。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | FilePermission 此类表示对文件和目录的访问。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | IOError 当发生严重的 I/O 错误时，抛出此错误。
class | IOException 当发生某种 I/O 异常时，抛出此异常。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamClass 类的序列化描述符。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | SerializablePermission 此类用于可序列化权限。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

java.lang 中 Serializable 的使用

实现 Serializable 的 java.lang 中的类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | AssertionError 抛出该异常指示某个断言失败。
class | Boolean Boolean 类将基本类型为 boolean 的值包装在一个对象中。
class | Byte Byte 类将基本类型 byte 的值包装在一个对象中。
class | Character Character 类在对象中包装一个基本类型 char 的值。
class | Class<T> Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ClassNotFoundException 当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
class | CloneNotSupportedException 当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
class | Double Double 类在对象中包装一个基本类型 double 的值。
class | Enum<E extends Enum<E>> 这是所有 Java 语言枚举类型的公共基本类。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | Error Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
class | Exception Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | Float Float 类在对象中包装一个基本类型 float 的值。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IllegalAccessException 当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | InstantiationException 当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
class | Integer Integer 类在对象中包装了一个基本类型 int 的值。
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | InterruptedException 当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
class | LinkageError LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
class | Long Long 类在对象中包装了基本类型 long 的值。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchFieldException 类不包含指定名称的字段时产生的信号。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | NoSuchMethodException 无法找到某一特定方法时，抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | Number 抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | RuntimeException RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
class | RuntimePermission 该类用于运行时权限。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | Short Short 类在对象中包装基本类型 short 的值。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | StackTraceElement 堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。
class | String String 类代表字符串。
class | StringBuffer 线程安全的可变字符序列。
class | StringBuilder 一个可变的字符序列。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
static class | Thread.State 线程状态。
class | ThreadDeath 调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
class | Throwable Throwable 类是 Java 语言中所有错误或异常的超类。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
class | VirtualMachineError 当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

java.lang.annotation 中 Serializable 的使用

实现 Serializable 的 java.lang.annotation 中的类
class | AnnotationFormatError 当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | ElementType 程序元素类型。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。
class | RetentionPolicy 注释保留策略。

java.lang.instrument 中 Serializable 的使用

实现 Serializable 的 java.lang.instrument 中的类
class | IllegalClassFormatException 当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
class | UnmodifiableClassException 在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

java.lang.management 中 Serializable 的使用

实现 Serializable 的 java.lang.management 中的类
class | ManagementPermission 使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。
class | MemoryType 内存池的类型。

java.lang.reflect 中 Serializable 的使用

实现 Serializable 的 java.lang.reflect 中的类
class | GenericSignatureFormatError 当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。
class | InvocationTargetException InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | Proxy Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。
class | ReflectPermission 反射操作的 Permission 类。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

java.math 中 Serializable 的使用

实现 Serializable 的 java.math 中的类
class | BigDecimal 不可变的、任意精度的有符号十进制数。
class | BigInteger 不可变的任意精度的整数。
class | MathContext 该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。
class | RoundingMode 为可能丢弃精度的数值操作指定一种舍入行为。

java.net 中 Serializable 的使用

实现 Serializable 的 java.net 中的类
static class | Authenticator.RequestorType 请求验证的实体的类型。
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | ConnectException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | Inet4Address 此类表示 Internet Protocol version 4 (IPv4) 地址。
class | Inet6Address 此类表示互联网协议第 6 版 (IPv6) 地址。
class | InetAddress 此类表示互联网协议 (IP) 地址。
class | InetSocketAddress 此类实现 IP 套接字地址（IP 地址 + 端口号）。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NetPermission 此类可用于各种网络权限。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
static class | Proxy.Type 表示代理类型。
class | SocketAddress 此类表示不带任何协议附件的 Socket Address。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketPermission 此类表示通过套接字对网络的访问。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。
class | URI 表示一个统一资源标识符 (URI) 引用。
class | URISyntaxException 抛出经过检查的指示字符串不能解析为 URI 引用的异常。
class | URL 类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.nio 中 Serializable 的使用

实现 Serializable 的 java.nio 中的类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 Serializable 的使用

实现 Serializable 的 java.nio.channels 中的类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 Serializable 的使用

实现 Serializable 的 java.nio.charset 中的类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | CoderMalfunctionError 当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.rmi 中 Serializable 的使用

实现 Serializable 的 java.rmi 中的类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | AlreadyBoundException 如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | MarshalException 如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
class | MarshalledObject<T> MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | NotBoundException 如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

java.rmi.activation 中 Serializable 的使用

实现 Serializable 的 java.rmi.activation 中的类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivateFailedException 在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
class | ActivationDesc 激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。
class | ActivationException 激活接口所使用的一般异常。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。
class | ActivationGroupDesc 激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。
static class | ActivationGroupDesc.CommandEnvironment ActivationGroup 实现的启动选项。
class | ActivationGroupID 针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。
class | ActivationID 激活利用特定的标识符来表示远程对象，对象能随着时间被激活。
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

java.rmi.dgc 中 Serializable 的使用

实现 Serializable 的 java.rmi.dgc 中的类
class | Lease 一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。
class | VMID VMID 是跨所有 Java 虚拟机都唯一的标识符。

java.rmi.server 中 Serializable 的使用

java.rmi.server 中 Serializable 的子接口
interface | RemoteRef RemoteRef 表示远程对象的句柄。
interface | ServerRef ServerRef 表示远程对象实现的服务器端句柄。

实现 Serializable 的 java.rmi.server 中的类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | ObjID ObjID 是用于标识导出到 RMI 运行时的远程对象。
class | RemoteObject 该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
class | RemoteObjectInvocationHandler 与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
class | RemoteServer 该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
class | RemoteStub 该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
class | ServerCloneException 如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
class | ServerNotActiveException 如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。
class | UID UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。
class | UnicastRemoteObject 用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

java.security 中 Serializable 的使用

java.security 中 Serializable 的子接口
interface | Key Key 是所有密钥的顶层接口。
interface | PrivateKey 私钥。
interface | PublicKey 公钥。

实现 Serializable 的 java.security 中的类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | AllPermission AllPermission 是暗含所有其他权限的权限。
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | BasicPermission BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
class | CodeSigner 此类封装关于代码签名者的信息。
class | CodeSource 此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。
class | DigestException 此为一般 Message Digest 异常。
class | GeneralSecurityException GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
class | GuardedObject GuardedObject 是一个用来保护对另一个对象的访问的对象。
class | Identity 已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyPair 此类是简单的密钥对（公钥和私钥）持有者。
class | KeyRep 已序列化的 Key 对象的标准表示形式。
static class | KeyRep.Type Key 类型。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | Permission 表示访问系统资源的抽象类。
class | PermissionCollection 表示 Permission 对象集合的抽象类。
class | Permissions 此类表示一个不同种类的 Permission 集合。
class | PrivilegedActionException doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
class | SecureRandom 此类提供强加密随机数生成器 (RNG)。
class | SecureRandomSpi 此类为 SecureRandom 类定义了服务提供者接口 (SPI)。
class | SecurityPermission 此类用于安全权限。
class | SignatureException 这是一般的签名异常。
class | SignedObject SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。
class | Timestamp 此类封装有关签署时间戳的信息。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。
class | UnresolvedPermission UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

参数类型为 Serializable 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.acl 中 Serializable 的使用

实现 Serializable 的 java.security.acl 中的类
class | AclNotFoundException 如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
class | LastOwnerException 如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
class | NotOwnerException 当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

java.security.cert 中 Serializable 的使用

实现 Serializable 的 java.security.cert 中的类
class | Certificate 管理各种身份证书的抽象类。
protected static class | Certificate.CertificateRep 用于序列化的替换 Certificate 类。
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题中的一种。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书尚无效异常。
class | CertificateParsingException 证书解析异常。
class | CertPath 不可变的证书序列（证书路径）。
protected static class | CertPath.CertPathRep 用于序列化的替换 CertPath 类。
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。
class | X509Certificate X.509 证书的抽象类。

java.security.interfaces 中 Serializable 的使用

java.security.interfaces 中 Serializable 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | DSAPublicKey DSA 公用密钥的接口。
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

java.security.spec 中 Serializable 的使用

实现 Serializable 的 java.security.spec 中的类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

java.sql 中 Serializable 的使用

实现 Serializable 的 java.sql 中的类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | ClientInfoStatus 无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | RowIdLifetime RowId 生存期值的枚举。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLPermission SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。

java.text 中 Serializable 的使用

实现 Serializable 的 java.text 中的类
static class | AttributedCharacterIterator.Attribute 定义用于标识文本属性的属性键。
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | DateFormat DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
static class | DateFormat.Field 定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
class | DateFormatSymbols DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
class | DecimalFormatSymbols 此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
class | Format Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
static class | Format.Field 定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
class | MessageFormat MessageFormat 提供了以与语言无关方式生成连接消息的方式。
static class | MessageFormat.Field 在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
static class | Normalizer.Form 此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。
class | NumberFormat NumberFormat 是所有数值格式的抽象基类。
static class | NumberFormat.Field 定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。
class | ParseException 表示解析时出现意外错误。
class | SimpleDateFormat SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

java.util 中 Serializable 的使用

实现 Serializable 的 java.util 中的类
static class | AbstractMap.SimpleEntry<K,V> 维护键和值的 Entry。
static class | AbstractMap.SimpleImmutableEntry<K,V> 维护不可变的键和值的 Entry。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | BitSet 此类实现了一个按需增长的位向量。
class | Calendar Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | Currency 表示货币。
class | Date 类 Date 表示特定的瞬间，精确到毫秒。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | EventObject 所有事件状态对象都将从其派生的根类。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
static class | Formatter.BigDecimalLayoutForm
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | GregorianCalendar GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | InvalidPropertiesFormatException 当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Locale Locale 对象表示了特定的地理、政治和文化地区。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | Properties Properties 类表示了一个持久的属性集。
class | PropertyPermission 此类用于属性权限。
class | Random 此类的实例用于生成伪随机数流。
class | ServiceConfigurationError 在加载服务提供者的过程中出错时抛出的错误。
class | SimpleTimeZone SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TimeZone TimeZone 表示时区偏移量，也可以计算夏令时。
class | TooManyListenersException TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。
class | UUID 表示通用唯一标识符 (UUID) 的类。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 Serializable 的使用

实现 Serializable 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | BrokenBarrierException 当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | ExecutionException 当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。
class | Semaphore 一个计数信号量。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。
class | TimeoutException 阻塞操作超时时，抛出该异常。
class | TimeUnit TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

java.util.concurrent.atomic 中 Serializable 的使用

实现 Serializable 的 java.util.concurrent.atomic 中的类
class | AtomicBoolean 可以用原子方式更新的 boolean 值。
class | AtomicInteger 可以用原子方式更新的 int 值。
class | AtomicIntegerArray 可以用原子方式更新其元素的 int 数组。
class | AtomicLong 可以用原子方式更新的 long 值。
class | AtomicLongArray 可以用原子方式更新其元素的 long 数组。
class | AtomicReference<V> 可以用原子方式更新的对象引用。
class | AtomicReferenceArray<E> 可以用原子方式更新其元素的对象引用数组。

java.util.concurrent.locks 中 Serializable 的使用

实现 Serializable 的 java.util.concurrent.locks 中的类
class | AbstractOwnableSynchronizer 可以由线程以独占方式拥有的同步器。
class | AbstractQueuedLongSynchronizer 以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。
class | AbstractQueuedLongSynchronizer.ConditionObject 作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
class | AbstractQueuedSynchronizer 为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。
class | AbstractQueuedSynchronizer.ConditionObject AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。
class | ReentrantLock 一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。
class | ReentrantReadWriteLock 支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。
static class | ReentrantReadWriteLock.ReadLock ReentrantReadWriteLock.readLock() 方法返回的锁。
static class | ReentrantReadWriteLock.WriteLock ReentrantReadWriteLock.writeLock() 方法返回的锁。

java.util.jar 中 Serializable 的使用

实现 Serializable 的 java.util.jar 中的类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.logging 中 Serializable 的使用

实现 Serializable 的 java.util.logging 中的类
class | Level Level 类定义了一组可用来控制日志输出的标准日志级别。
class | LoggingPermission 当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。
class | LogRecord LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。

java.util.prefs 中 Serializable 的使用

实现 Serializable 的 java.util.prefs 中的类
class | BackingStoreException 抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
class | InvalidPreferencesFormatException 抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。
class | NodeChangeEvent Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
class | PreferenceChangeEvent Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。

java.util.regex 中 Serializable 的使用

实现 Serializable 的 java.util.regex 中的类
class | Pattern 正则表达式的编译表示形式。
class | PatternSyntaxException 抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.zip 中 Serializable 的使用

实现 Serializable 的 java.util.zip 中的类
class | DataFormatException 当数据格式发生错误时，抛出此异常。
class | ZipError 发生不可恢复的错误时抛出。
class | ZipException 如果某种 ZIP 异常发生，则抛出此错误。

javax.activation 中 Serializable 的使用

实现 Serializable 的 javax.activation 中的类
class | ActivationDataFlavor ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。
class | MimeType RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。
class | UnsupportedDataTypeException 当请求操作不支持请求的数据类型时，抛出此异常。

javax.activity 中 Serializable 的使用

实现 Serializable 的 javax.activity 中的类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation 中 Serializable 的使用

实现 Serializable 的 javax.annotation 中的类
static class Resource.AuthenticationType
资源的两种可能验证类型。

javax.annotation.processing 中 Serializable 的使用

实现 Serializable 的 javax.annotation.processing 中的类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Serializable 的使用

javax.crypto 中 Serializable 的子接口
 interface SecretKey
秘密（对称）密钥。

实现 Serializable 的 javax.crypto 中的类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | SealedObject 此类使程序员能够用加密算法创建对象并保护其机密性。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

参数类型为 Serializable 的 javax.crypto 中的构造方法
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

javax.crypto.interfaces 中 Serializable 的使用

javax.crypto.interfaces 中 Serializable 的子接口
interface | DHPrivateKey Diffie-Hellman 私钥接口。
interface | DHPublicKey Diffie-Hellman 公钥接口。
interface | PBEKey 调用者 PBE 密钥接口。

javax.crypto.spec 中 Serializable 的使用

实现 Serializable 的 javax.crypto.spec 中的类
 class SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

javax.imageio 中 Serializable 的使用

实现 Serializable 的 javax.imageio 中的类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

javax.imageio.metadata 中 Serializable 的使用

实现 Serializable 的 javax.imageio.metadata 中的类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

javax.jws 中 Serializable 的使用

实现 Serializable 的 javax.jws 中的类
static class WebParam.Mode
参数的流向。

javax.jws.soap 中 Serializable 的使用

实现 Serializable 的 javax.jws.soap 中的类
static class | SOAPBinding.ParameterStyle 参数到 SOAP 消息的映射关系的样式。
static class | SOAPBinding.Style SOAP 绑定样式。
static class | SOAPBinding.Use SOAP 绑定的使用。

javax.lang.model 中 Serializable 的使用

实现 Serializable 的 javax.lang.model 中的类
 class SourceVersion
Java™ 编程语言的源版本。

javax.lang.model.element 中 Serializable 的使用

实现 Serializable 的 javax.lang.model.element 中的类
class | ElementKind 元素的 kind。
class | Modifier 表示程序元素（如类、方法或字段）上的修饰符。
class | NestingKind 某一类型元素的嵌套种类 (nesting kind)。
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 Serializable 的使用

实现 Serializable 的 javax.lang.model.type 中的类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | TypeKind 类型镜像的种类。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 Serializable 的使用

javax.management 中 Serializable 的子接口
interface | Descriptor JMX 元素的附加元数据。
interface | NotificationFilter 可由作为通知过滤器的任何类来实现。
interface | QueryExp 表示可在数据库查询“where 子句”中使用的相关约束。
interface | ValueExp 表示可以作为参数传递给关系表达式的值。

实现 Serializable 的 javax.management 中的类
class | Attribute 通过将 MBean 属性名与其值相关联来表示 MBean 属性。
class | AttributeChangeNotification 提供 MBean 所发送的属性更改通知的定义。
class | AttributeChangeNotificationFilter 此类实现 attribute change notification 的 NotificationFilter 接口。
class | AttributeList 表示 MBean 属性值的列表。
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | AttributeValueExp 表示用作关系约束参数的属性。
class | BadAttributeValueExpException 向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
class | BadBinaryOpValueExpException 向构造查询的方法传递无效的表达式时，抛出此异常。
class | BadStringOperationException 向构造查询的方法传递无效的字符串操作时，抛出此异常。
class | ImmutableDescriptor 不可变的描述符。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | InvalidApplicationException 试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | JMException 由 JMX 实现所抛出的异常。
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanFeatureInfo 提供 MBean 描述符对象的常规信息。
class | MBeanInfo 描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。
class | MBeanPermission 权限控制对 MBeanServer 操作的访问。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | MBeanServerNotification 表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | Notification Notification 类表示 MBean 所发出的通知。
class | NotificationFilterSupport 提供 NotificationFilter 接口的实现。
class | ObjectInstance 用于表示 MBean 对象名及其类名。
class | ObjectName 表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | QueryEval 允许在特定的 MBean 服务器上下文中执行查询。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。
class | StringValueExp 表示作为关系约束变量的字符串。

javax.management.loading 中 Serializable 的使用

实现 Serializable 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

javax.management.modelmbean 中 Serializable 的使用

实现 Serializable 的 javax.management.modelmbean 中的类
class | DescriptorSupport 此类表示 ModelMBean 元素的元数据集。
class | InvalidTargetObjectTypeException 当指定了无效的目标对象类型时，抛出此异常。
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanInfoSupport 此类表示 ModelMBean 的元数据。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。
class | XMLParseException 当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

javax.management.monitor 中 Serializable 的使用

实现 Serializable 的 javax.management.monitor 中的类
class | MonitorNotification 提供对监视器 MBean 发送的通知的定义。
class | MonitorSettingException 当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

javax.management.openmbean 中 Serializable 的使用

实现 Serializable 的 javax.management.openmbean 中的类
class | ArrayType<T> ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
class | CompositeDataSupport CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。
class | CompositeType CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
class | OpenDataException 因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanInfoSupport OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。
class | OpenType<T> OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。
class | SimpleType<T> SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
class | TabularDataSupport TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。
class | TabularType TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

javax.management.relation 中 Serializable 的使用

javax.management.relation 中 Serializable 的子接口
 interface RelationType
该 RelationType 接口必须由期望表示关系类型的任何类来实现。

实现 Serializable 的 javax.management.relation 中的类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | MBeanServerNotificationFilter MBeanServerNotification 的过滤器。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationNotification Relation Service（关系服务）中的更改通知。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RelationTypeSupport RelationTypeSupport 对象实现 RelationType 接口。
class | Role 表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。
class | RoleInfo RoleInfo 概括介绍关系类型中的角色。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。
class | RoleResult 表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。
class | RoleUnresolved 表示未解析的角色：由于存在问题而无法从关系中检索到的角色。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.management.remote 中 Serializable 的使用

实现 Serializable 的 javax.management.remote 中的类
class | JMXConnectionNotification 在客户端连接打开或关闭时，或者当通知丢失时发出的通知。
class | JMXPrincipal JMX Remote API 的远程客户端的身份。
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。
class | JMXServiceURL JMX API 连接器服务器的地址。
class | NotificationResult 缓存的通知的查询结果。
class | SubjectDelegationPermission 授权标识表示验证标识执行操作所需的权限。
class | TargetedNotification 一个 (Notification, Listener ID) 对。

javax.management.remote.rmi 中 Serializable 的使用

实现 Serializable 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl_Stub
class | RMIConnector 一个到远程 RMI 连接器的连接。
class | RMIServerImpl_Stub

javax.management.timer 中 Serializable 的使用

实现 Serializable 的 javax.management.timer 中的类
 class TimerNotification
此类定义了由计时器 MBean 发送的通知。

javax.naming 中 Serializable 的使用

javax.naming 中 Serializable 的子接口
 interface Name
Name 接口表示一个一般名称，即一个有序的组件序列。

实现 Serializable 的 javax.naming 中的类
class | AuthenticationException 当访问命名或目录服务发生验证错误时，抛出此异常。
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | BinaryRefAddr 此类表示通信终端地址的二进制形式。
class | Binding 此类表示上下文中一个名称到对象的绑定。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | LinkRef 此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameClassPair 此类表示存在于上下文中的某一绑定的对象名称和类名称对。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingException 此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | RefAddr 此类表示通信端点的地址。
class | Reference 此类表示对存在于命名/目录系统以外的对象的引用。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | StringRefAddr 此类表示通信终端地址的字符串形式。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

javax.naming.directory 中 Serializable 的使用

javax.naming.directory 中 Serializable 的子接口
interface | Attribute 此接口表示与命名对象关联的属性。
interface | Attributes 此接口表示属性的集合。

实现 Serializable 的 javax.naming.directory 中的类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | BasicAttribute 此类提供 Attribute 接口的基本实现。
class | BasicAttributes 此类提供 Attributes 接口的基本实现。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | ModificationItem 此类表示修改项。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。
class | SearchControls 此类封装确定搜索范围和搜索返回结果的因子。
class | SearchResult 此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

javax.naming.event 中 Serializable 的使用

实现 Serializable 的 javax.naming.event 中的类
class | NamingEvent 此类表示命名/目录服务触发的事件。
class | NamingExceptionEvent 此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。

javax.naming.ldap 中 Serializable 的使用

javax.naming.ldap 中 Serializable 的子接口
interface | Control 此接口表示在 RFC 2251 中定义的 LDAPv3 控件。
interface | ExtendedRequest 此接口表示在 RFC 2251 中定义的 LDAPv3 扩展操作请求。
interface | ExtendedResponse 此接口表示在 RFC 2251 中定义的 LDAP 扩展操作响应。
interface | UnsolicitedNotification 此接口表示在 RFC 2251 中定义的未经请求的通知。

实现 Serializable 的 javax.naming.ldap 中的类
class | BasicControl 此类提供 Control 接口的基本实现。
class | LdapName 此类表示 RFC 2253 指定的标识名。
class | LdapReferralException 此抽象类用于表示 LDAP 引用异常。
class | ManageReferralControl 将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
class | PagedResultsControl 请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
class | PagedResultsResponseControl 指示一批搜索结果的末尾。
class | Rdn 此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。
class | SortControl 请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
class | SortResponseControl 指示搜索结果的请求排序是否成功。
class | StartTlsRequest 此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。
class | StartTlsResponse 此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。
class | UnsolicitedNotificationEvent 此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

javax.naming.spi 中 Serializable 的使用

实现 Serializable 的 javax.naming.spi 中的类
 class ResolveResult
此类表示解析某一名称的结果。

javax.net.ssl 中 Serializable 的使用

实现 Serializable 的 javax.net.ssl 中的类
class | HandshakeCompletedEvent 此事件指示在给定的 SSL 连接上 SSL 握手结束。
static class | SSLEngineResult.HandshakeStatus 描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
static class | SSLEngineResult.Status 描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLPermission 此类用于各种网络权限。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。
class | SSLSessionBindingEvent 此事件向 SSLSessionBindingListener 传播。

javax.print 中 Serializable 的使用

实现 Serializable 的 javax.print 中的类
class | DocFlavor 类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
static class | DocFlavor.BYTE_ARRAY 类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.CHAR_ARRAY 类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.INPUT_STREAM 类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.READER 类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.SERVICE_FORMATTED 类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
static class | DocFlavor.STRING 类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.URL 类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。
class | PrintException 类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

javax.print.attribute 中 Serializable 的使用

javax.print.attribute 中 Serializable 的子接口
interface | DocAttribute 接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
interface | PrintJobAttribute PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
interface | PrintRequestAttribute 接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
interface | PrintServiceAttribute 接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
interface | SupportedValuesAttribute 接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。

实现 Serializable 的 javax.print.attribute 中的类
class | DateTimeSyntax 类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
class | EnumSyntax 类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
class | HashAttributeSet 类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
class | HashDocAttributeSet 类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
class | HashPrintJobAttributeSet 类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
class | HashPrintRequestAttributeSet 类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
class | HashPrintServiceAttributeSet 类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。
class | IntegerSyntax 类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
class | ResolutionSyntax 类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
class | SetOfIntegerSyntax 类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
class | Size2DSyntax 类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
class | TextSyntax 类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
class | UnmodifiableSetException 当由于设置不可修改而无法执行请求的操作时，抛出该异常。
class | URISyntax 类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

javax.print.attribute.standard 中 Serializable 的使用

实现 Serializable 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReason JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
class | JobStateReasons JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSize MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReason PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterStateReasons PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。
class | ReferenceUriSchemesSupported ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
class | Severity Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

javax.print.event 中 Serializable 的使用

实现 Serializable 的 javax.print.event 中的类
class | PrintEvent 类 PrintEvent 是所有 Print Service API 事件的超类。
class | PrintJobAttributeEvent 类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
class | PrintJobEvent 类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
class | PrintServiceAttributeEvent 类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

javax.rmi.CORBA 中 Serializable 的使用

实现 Serializable 的 javax.rmi.CORBA 中的类
class | ClassDesc 此类用于对 IIOP 上的 java.lang.Class 对象进行编组。
class | Stub 必须从其继承所有 RMI-IIOP stub 的基类。

返回 Serializable 的 javax.rmi.CORBA 中的方法
Serializable | ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender) 使用 Java 语义从流中读取一个值。
Serializable | ValueHandler.writeReplace(Serializable value) 如果该值包含 writeReplace 方法，则返回该结果。

参数类型为 Serializable 的 javax.rmi.CORBA 中的方法
Serializable | ValueHandler.writeReplace(Serializable value) 如果该值包含 writeReplace 方法，则返回该结果。
void | ValueHandler.writeValue(OutputStream out, Serializable value) 使用 Java 语义将一个值写入流。
void | ValueHandlerMultiFormat.writeValue(OutputStream out, Serializable value, byte streamFormatVersion) 允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。

javax.rmi.ssl 中 Serializable 的使用

实现 Serializable 的 javax.rmi.ssl 中的类
 class SslRMIClientSocketFactory
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。

javax.script 中 Serializable 的使用

实现 Serializable 的 javax.script 中的类
 class ScriptException
脚本 API 的一般 Exception 类。

javax.security.auth 中 Serializable 的使用

实现 Serializable 的 javax.security.auth 中的类
class | AuthPermission 此类用于验证权限。
class | DestroyFailedException 当 destroy 操作失败时，抛出此异常。
class | PrivateCredentialPermission 此类用来保护对属于特定 Subject 的私有 Credential 的访问。
class | RefreshFailedException 当 refresh 操作失败时，抛出此异常。
class | Subject Subject 表示某一项（如一个人）的一组相关信息。

javax.security.auth.callback 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.callback 中的类
class | ChoiceCallback 底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
class | ConfirmationCallback 底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。
class | LanguageCallback 底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。
class | NameCallback 底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。
class | PasswordCallback 底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。
class | TextInputCallback 底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。
class | TextOutputCallback 底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。
class | UnsupportedCallbackException 在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.kerberos 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.kerberos 中的类
class | DelegationPermission 此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
class | KerberosKey 此类为 Kerberos 主体封装一个长期秘密密钥。
class | KerberosPrincipal 此类封装 Kerberos 主体。
class | KerberosTicket 此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。
class | ServicePermission 此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

javax.security.auth.login 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.login 中的类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

javax.security.auth.x500 中 Serializable 的使用

实现 Serializable 的 javax.security.auth.x500 中的类
 class X500Principal
此类表示一个 X.500 Principal。

javax.security.sasl 中 Serializable 的使用

实现 Serializable 的 javax.security.sasl 中的类
class | AuthorizeCallback 此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。
class | RealmCallback SaslClient 和 SaslServer 使用此回调来获取领域信息。
class | RealmChoiceCallback SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

javax.sound.midi 中 Serializable 的使用

实现 Serializable 的 javax.sound.midi 中的类
class | InvalidMidiDataException 一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
class | MidiUnavailableException 当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

javax.sound.sampled 中 Serializable 的使用

实现 Serializable 的 javax.sound.sampled 中的类
class | AudioPermission AudioPermission 类表示对音频系统资源的访问权限。
class | LineEvent LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。
class | LineUnavailableException LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
class | UnsupportedAudioFileException UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

javax.sql 中 Serializable 的使用

实现 Serializable 的 javax.sql 中的类
class | ConnectionEvent 提供关于连接相关事件的源信息的 Event 对象。
class | RowSetEvent RowSet 对象发生事件时生成的 Event 对象。
class | StatementEvent StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。

javax.sql.rowset 中 Serializable 的使用

实现 Serializable 的 javax.sql.rowset 中的类
class | BaseRowSet 提供一个具有基本功能的 RowSet 对象的抽象类。
class | RowSetMetaDataImpl 为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。
class | RowSetWarning SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Serializable 的使用

实现 Serializable 的 javax.sql.rowset.serial 中的类
class | SerialArray 序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。
class | SerialBlob SQL BLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialClob SQL CLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialDatalink SQL DATALINK 值在 Java 编程语言中的序列化映射关系。
class | SerialException 指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。
class | SerialJavaObject SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。
class | SerialRef Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。
class | SerialStruct SQL 结构类型在 Java 编程语言中的序列化映射关系。

javax.sql.rowset.spi 中 Serializable 的使用

实现 Serializable 的 javax.sql.rowset.spi 中的类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Serializable 的使用

实现 Serializable 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
class | AbstractButton 定义按钮和菜单项的一般行为。
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | AbstractButton.ButtonChangeListener 将 ChangeListener 扩展为可序列化的。
class | AbstractCellEditor
class | AbstractListModel 该数据模型的抽象定义提供一个带内容的 List。
class | ActionMap ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
class | BoxLayout 允许垂直或水平布置多个组件的布局管理器。
class | ButtonGroup 此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
class | ComponentInputMap ComponentInputMap 是与特定 JComponent 相关联的 InputMap。
class | DefaultBoundedRangeModel BoundedRangeModel 的一般实现。
class | DefaultButtonModel Button 组件的数据模型的默认实现。
class | DefaultCellEditor 表单元格和树单元格的默认编辑器。
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
class | DefaultComboBoxModel 组合框的默认模型。
class | DefaultDesktopManager 此类是 DesktopManager 的实现。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | DefaultListModel 此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。
class | DefaultListSelectionModel 列表选择的默认数据模型。
class | DefaultSingleSelectionModel SingleSelectionModel 的一般实现。
class | DropMode 放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
static class | GroupLayout.Alignment ParallelGroup 能够对齐其子元素的可能方式的枚举。
class | ImageIcon 一个 Icon 接口的实现，它根据 Image 绘制 Icon。
protected class | ImageIcon.AccessibleImageIcon 此类实现 ImageIcon 类的可访问性支持。
class | InputMap InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
class | JButton "push" 按钮的实现。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent 该类是除顶层容器外所有 Swing 组件的基类。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
class | JDialog 创建对话框窗口的主要类。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
class | JEditorPane 可编辑各种内容的文本组件。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
static class | JFormattedTextField.AbstractFormatter JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
class | JLabel 用于短文本字符串或图像或二者的显示区。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenu.WinListener 观察弹出窗口关闭的侦听器类。
class | JMenuBar 菜单栏的实现。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
class | JMenuItem 菜单中的项的实现。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
class | JPanel JPanel 是一般轻量级容器。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JRootPane.RootLayout 该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
class | JScrollBar 滚动条的实现。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTabbedPane.ModelListener 将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
static class | JTable.PrintMode 用于打印 JTable 的打印模式。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
static class | JToggleButton.ToggleButtonModel ToggleButton 模型。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
class | JTree 将分层数据集显示为轮廓的控件。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
static class | JTree.DynamicUtilTreeNode DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
protected static class | JTree.EmptySelectionModel EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
protected class | JTree.TreeSelectionRedirector 使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JViewport.ViewListener 视图的侦听器。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。
class | KeyStroke 表示键盘或等效输入设置上的键操作的 KeyStroke。
class | LayoutFocusTraversalPolicy 根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
static class | LayoutStyle.ComponentPlacement ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
class | OverlayLayout 要在彼此顶部安排组件的布局管理器。
static class | RowFilter.ComparisonType 由某些默认 RowFilter 支持的可能比较值的枚举。
class | ScrollPaneLayout JScrollPane 使用的布局管理器。
static class | ScrollPaneLayout.UIResource ScrollPaneLayout 的 UI 资源版本。
class | SizeRequirements 为方便布局管理器，计算组件的有关大小和位置信息。
class | SortOrder SortOrder 是可能排序顺序的枚举。
class | SpinnerDateModel Date 序列的一个 SpinnerModel。
class | SpinnerListModel 其值由数组或 List 定义的 SpinnerModel 的简单实现。
class | SpinnerNumberModel 用于数字序列的 SpinnerModel。
static class | SwingWorker.StateValue state 绑定 (bound) 属性的值。
class | Timer 在指定时间间隔触发一个或多个 ActionEvent。
class | TransferHandler 此类用于处理往返于 Swing 组件的 Transferable 的传输。
class | UIDefaults Swing 组件的默认值表。
class | UIManager UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。
class | UnsupportedLookAndFeelException 指示在用户系统上不存在请求的外观管理类的异常。
class | ViewportLayout JViewport 的默认布局管理器。

javax.swing.border 中 Serializable 的使用

实现 Serializable 的 javax.swing.border 中的类
class | AbstractBorder 实现无大小限制的空边框类。
class | BevelBorder 该类实现简单的双线斜面边框。
class | CompoundBorder 一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
class | EmptyBorder 该类提供了一个占用空间但不执行绘制的空透明边框。
class | EtchedBorder 该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
class | LineBorder 实现单色、任意厚度线边框的类。
class | MatteBorder 该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
class | SoftBevelBorder 实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
class | TitledBorder 该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.colorchooser 中 Serializable 的使用

实现 Serializable 的 javax.swing.colorchooser 中的类
class | AbstractColorChooserPanel 这是用于颜色选取器的抽象超类。
class | DefaultColorSelectionModel ColorSelectionModel 的一般实现。

javax.swing.event 中 Serializable 的使用

实现 Serializable 的 javax.swing.event 中的类
class | AncestorEvent 报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
class | CaretEvent CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
class | ChangeEvent ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
class | EventListenerList 保存 EventListener 列表的类。
class | HyperlinkEvent HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
class | InternalFrameEvent 以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
class | ListDataEvent 定义一个封装列表更改的事件。
class | ListSelectionEvent 表现选择中更改的特征的事件。
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuEvent MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
class | PopupMenuEvent PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | RowSorterEvent RowSorterEvent 提供 RowSorter 的更改通知。
static class | RowSorterEvent.Type RowSorterEvent 类型的枚举。
class | SwingPropertyChangeSupport java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。
class | TableColumnModelEvent TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
class | TableModelEvent TableModelEvent 用于通知侦听器某一表模型已发生更改。
class | TreeExpansionEvent 用于标识树中的单个路径的事件。
class | TreeModelEvent 封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
class | TreeSelectionEvent 描述当前选择中的更改的事件。
class | UndoableEditEvent 指示发生了可撤消操作的事件。

javax.swing.plaf 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf 中的类
class | ActionMapUIResource 实现 UIResource 的 javax.swing.ActionMap 的子类。
class | BorderUIResource
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource
class | ColorUIResource
class | ComponentInputMapUIResource 实现 UIResource 的 javax.swing.ComponentInputMap 的子类。
class | DimensionUIResource
class | FontUIResource 实现 UIResource 的 java.awt.Font 的子类。
class | IconUIResource 实现 UIResource 的 Icon 包装类。
class | InputMapUIResource 实现 UIResource 的 javax.swing.InputMap 的子类。
class | InsetsUIResource

javax.swing.plaf.basic 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.ToggleButtonBorder
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
class | BasicDirectoryModel 文件列表的基本实现。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicIconFactory 提供适于基本 L & F 使用的 Icon 的工厂对象。
class | BasicInternalFrameTitlePane 管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
class | BasicLookAndFeel 为 Swing 创建外观时要使用的基类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
static class | BasicTextUI.BasicCaret
protected class | BasicToolBarUI.DragWindow
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。
class | DefaultMenuLayout Popup 菜单和菜单栏的默认布局管理器。

javax.swing.plaf.metal 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TableHeaderBorder Table Header 的边框
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder
class | MetalCheckBoxIcon OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxIcon 此实用工具类绘制指示 MetalComboBox 的水平条
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.DirectoryComboBoxAction 当 DirectoryComboBox 已更改所选项时调用。
protected class | MetalFileChooserUI.DirectoryComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.FileRenderer
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalIconFactory 为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。
static class | MetalIconFactory.FileIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.FolderIcon16 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.PaletteCloseIcon 定义一个用于 Palette 关闭的图标
static class | MetalIconFactory.TreeControlIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeFolderIcon 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalIconFactory.TreeLeafIcon
class | MetalInternalFrameTitlePane 管理 JLF 标题栏的类
class | MetalLookAndFeel Java 外观，也称为 Metal。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.plaf.synth 中 Serializable 的使用

实现 Serializable 的 javax.swing.plaf.synth 中的类
 class SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

javax.swing.table 中 Serializable 的使用

实现 Serializable 的 javax.swing.table 中的类
class | AbstractTableModel 此抽象类为 TableModel 接口中的大多数方法提供默认实现。
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | DefaultTableColumnModel JTable 的标准列处理程序。
class | DefaultTableModel 这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。
class | JTableHeader 这是管理 JTable 的头的对象。
protected class | JTableHeader.AccessibleJTableHeader 此类实现对 JTableHeader 类的可访问性支持。
class | TableColumn TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。

javax.swing.text 中 Serializable 的使用

实现 Serializable 的 javax.swing.text 中的类
class | AbstractDocument 文档接口的实现，可作为实现各种文档的基础。
class | AbstractDocument.AbstractElement 实现元素的抽象部分。
class | AbstractDocument.BranchElement 实现一个包含其他元素的复合元素。
class | AbstractDocument.DefaultDocumentEvent 存储修改文档时发生的文档更改。
static class | AbstractDocument.ElementEdit 一个 ElementChange 实现，可将其添加到文档事件中。
class | AbstractDocument.LeafElement 实现可直接表示某类内容的元素。
class | BadLocationException 此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
class | ChangedCharSetException 顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | DefaultCaret 插入符的默认实现。
class | DefaultEditorKit 这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
class | DefaultFormatter DefaultFormatter 格式化任意对象。
class | DefaultFormatterFactory JFormattedTextField.AbstractFormatterFactory 的一个实现。
class | DefaultStyledDocument 能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。
static class | DefaultStyledDocument.AttributeUndoableEdit 用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。
class | DefaultStyledDocument.ElementBuffer 管理对元素层次结构更改的类。
protected class | DefaultStyledDocument.SectionElement 文档的默认根元素... 与所包含的段落/行对应。
class | EditorKit 针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
class | GapContent AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | JTextComponent JTextComponent 是 swing 文本组件的基类。
class | JTextComponent.AccessibleJTextComponent 此类实现 JTextComponent 类的可访问性支持。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。
class | PlainDocument 维护无任何字符属性的普通文档。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StringContent AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。
class | StyleContext 样式池及其关联的资源。
class | StyleContext.NamedStyle 通常用于表示字符和段落样式的属性集合。
class | StyledEditorKit 这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TabSet 由许多 TabStop 组成的一个 TabSet。
class | TabStop 此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 Serializable 的使用

实现 Serializable 的 javax.swing.text.html 中的类
class | CSS 将 CSS attributes 集定义为类型安全的枚举。
class | FormSubmitEvent FormSubmitEvent 用于通知提交表单所需的参与者。
static class | FormSubmitEvent.MethodType 表示 HTML 表单方法类型。
static class | HTML.UnknownTag
class | HTMLDocument 对 HTML 进行建模的文档。
class | HTMLDocument.BlockElement 表示结构性 HTML 块 的元素。
class | HTMLDocument.RunElement 表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。
class | HTMLEditorKit Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。
class | HTMLFrameHyperlinkEvent HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。
class | Option 用来表示 <option> 元素的 ListModel 值。
class | StyleSheet 支持定义要呈现的 HTML 视图的可视化特征。
static class | StyleSheet.BoxPainter 可以执行某些 CSS 格式化任务的类。
static class | StyleSheet.ListPainter 要执行某些 CSS 列表格式化任务的类。

javax.swing.text.html.parser 中 Serializable 的使用

实现 Serializable 的 javax.swing.text.html.parser 中的类
class | ContentModel 内容模式的表示形式。
class | Element 使用 ELEMENT 构造在 DTD 中描述的一个元素。
class | ParserDelegator 负责每次在调用其 parse 方法时启动一个新的 DocumentParser。

javax.swing.text.rtf 中 Serializable 的使用

实现 Serializable 的 javax.swing.text.rtf 中的类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

javax.swing.tree 中 Serializable 的使用

实现 Serializable 的 javax.swing.tree 中的类
class | DefaultMutableTreeNode DefaultMutableTreeNode 是树数据结构中的通用节点。
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellEditor.EditorContainer 负责存放 editingComponent 的容器。
class | DefaultTreeCellRenderer 显示树中的条目。
class | DefaultTreeModel 使用 TreeNodes 的简单树数据模型。
class | DefaultTreeSelectionModel TreeSelectionModel 的默认实现。
class | ExpandVetoException 用于阻止扩展/折叠发生的异常。
class | TreePath 表示节点的路径。

javax.swing.undo 中 Serializable 的使用

实现 Serializable 的 javax.swing.undo 中的类
class | AbstractUndoableEdit UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。
class | CompoundEdit AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。
class | StateEdit StateEdit 是更改状态的对象的通用编辑。
class | UndoManager UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

javax.tools 中 Serializable 的使用

实现 Serializable 的 javax.tools 中的类
static class | Diagnostic.Kind 诊断的种类，例如，错误或者警告。
static class | JavaFileObject.Kind JavaFileObject 的种类。
class | StandardLocation 文件对象的标准位置。

javax.transaction 中 Serializable 的使用

实现 Serializable 的 javax.transaction 中的类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Serializable 的使用

实现 Serializable 的 javax.transaction.xa 中的类
 class XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml.bind 中 Serializable 的使用

实现 Serializable 的 javax.xml.bind 中的类
class | JAXBElement<T> Xml 元素的 JAXB 表示形式。
class | JAXBException 这是所有 JAXB 异常的根异常类。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | TypeConstraintException 此异常指示已检测到存在违反动态检查的类型约束的情况。
class | ValidationException 此异常指示在执行验证操作时发生错误。

javax.xml.bind.annotation 中 Serializable 的使用

实现 Serializable 的 javax.xml.bind.annotation 中的类
class | XmlAccessOrder 由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
class | XmlAccessType 由 XmlAccessorType 使用，用于控制字段或属性的序列化。
class | XmlNsForm XML 模式名称空间限定的枚举。

javax.xml.crypto 中 Serializable 的使用

实现 Serializable 的 javax.xml.crypto 中的类
class | KeySelectorException 指示由 KeySelector 抛出的异常条件。
class | NoSuchMechanismException 当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
class | URIReferenceException 指示取消引用 URIReference 时抛出的异常条件。

javax.xml.crypto.dsig 中 Serializable 的使用

实现 Serializable 的 javax.xml.crypto.dsig 中的类
class | TransformException 指示执行转换算法时出现异常的异常条件。
class | XMLSignatureException 指示生成或验证 XML 签名过程中发生的异常条件。

javax.xml.datatype 中 Serializable 的使用

实现 Serializable 的 javax.xml.datatype 中的类
 class DatatypeConfigurationException
指示严重的配置错误。

javax.xml.namespace 中 Serializable 的使用

实现 Serializable 的 javax.xml.namespace 中的类
 class QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

javax.xml.parsers 中 Serializable 的使用

实现 Serializable 的 javax.xml.parsers 中的类
class | FactoryConfigurationError 当解析器工厂的配置存在问题时抛出该异常。
class | ParserConfigurationException 指示一个严重的配置错误。

javax.xml.soap 中 Serializable 的使用

实现 Serializable 的 javax.xml.soap 中的类
 class SOAPException
当发生 SOAP 异常时，抛出此异常。

javax.xml.stream 中 Serializable 的使用

实现 Serializable 的 javax.xml.stream 中的类
 class XMLStreamException
用于不可预料处理错误的基本异常。

javax.xml.transform 中 Serializable 的使用

实现 Serializable 的 javax.xml.transform 中的类
class | TransformerConfigurationException 指示严重的配置错误。
class | TransformerException 此类指定了转换过程中发生的异常条件。
class | TransformerFactoryConfigurationError 当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

javax.xml.ws 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws 中的类
static class | Service.Mode 动态客户端或服务的方向。
class | WebServiceException WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。
class | WebServicePermission 此类定义 Web 服务权限。

javax.xml.ws.handler 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws.handler 中的类
static class MessageContext.Scope
属性作用域。

javax.xml.ws.http 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws.http 中的类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Serializable 的使用

实现 Serializable 的 javax.xml.ws.soap 中的类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.xpath 中 Serializable 的使用

实现 Serializable 的 javax.xml.xpath 中的类
class | XPathException XPathException 表示通用 XPath 异常。
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

org.ietf.jgss 中 Serializable 的使用

实现 Serializable 的 org.ietf.jgss 中的类
 class GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

org.omg.CORBA 中 Serializable 的使用

org.omg.CORBA 中 Serializable 的子接口
interface | Current 从 Current 接口派生的接口允许 ORB 和 CORBA 服务访问与它们正运行的执行线程关联的信息（上下文）。
interface | DataInputStream 定义用来从输入流读取基本数据类型的方法，以便解组自定义值类型。
interface | DataOutputStream 定义用来将基本数据类型写入输出流的方法，以便编组自定义值类型。
interface | DomainManager 提供用来建立关系并将其导航到高级域和从属域的机制，以及用来创建和访问策略的机制。
interface | IDLType 由所有表示 OMG IDL 类型的接口存储库（Interface Repository，IR）对象继承的抽象接口。
interface | IRObject IRObject IDL 接口表示最一般的接口，其他所有 Interface Repository 接口（甚至包括 Repository 自身）都派生自该接口。
interface | Policy 派生自 Policy 接口的接口允许 ORB 或 CORBA 服务访问影响其操作的某些选项。

实现 Serializable 的 org.omg.CORBA 中的类
class | _IDLTypeStub IDLType 的 Stub。
class | _PolicyStub Policy 的 Stub。
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | Any 充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | CompletionStatus 指示某一方法抛出 SystemException 时是否已结束运行的对象。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | DefinitionKind 该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NameValuePair 将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | ParameterMode Parameter 参数模式的枚举。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | PolicyError 发生策略错误时抛出的用户异常。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | ServiceDetail 表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。
class | ServiceInformation CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。
class | SetOverrideType 标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。
class | StructMember 描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | TypeCode 用于有关特定 CORBA 数据类型的信息的容器。
class | UnionMember 接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | ValueMember 接口存储库 (Interface Repository) 中关于 value 对象成员的描述。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

声明为 Serializable 的 org.omg.CORBA 中的字段
 Serializable ValueBaseHolder.value
此 ValueBaseHolder 对象保存的 java.io.Serializable 值。

返回 Serializable 的 org.omg.CORBA 中的方法
abstract Serializable | Any.extract_Value() 提取此 Any 对象 value 字段中的 java.io.Serializable 对象。
static Serializable | ValueBaseHelper.extract(Any a)
Serializable | DynAny.get_val() 已过时。 检索此 DynAny 对象中包含的 java.io.Serializable 对象。
Serializable | DataInputStream.read_Value() 从输入流读取 IDL 值类型。
Serializable | StringValueHelper.read_value(InputStream istream)
Serializable | WStringValueHelper.read_value(InputStream istream)
static Serializable | ValueBaseHelper.read(InputStream istream)

参数类型为 Serializable 的 org.omg.CORBA 中的方法
void | DynAny.insert_val(Serializable value) 已过时。 插入给定 java.io.Serializable 对象作为此 DynAny 对象的值。
abstract void | Any.insert_Value(Serializable v) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
abstract void | Any.insert_Value(Serializable v, TypeCode t) 将给定 java.io.Serializable 对象插入此 Any 对象的 value 字段。
static void | ValueBaseHelper.insert(Any a, Serializable that)
void | StringValueHelper.write_value(OutputStream ostream, Serializable value)
void | WStringValueHelper.write_value(OutputStream ostream, Serializable value)
void | DataOutputStream.write_Value(Serializable value) 将 IDL value 类型值写入输出流。
static void | ValueBaseHelper.write(OutputStream ostream, Serializable value)

参数类型为 Serializable 的 org.omg.CORBA 中的构造方法
ValueBaseHolder(Serializable initial)
构造一个新的 ValueBaseHolder 对象，并将其 value 字段初始化为给定的 java.io.Serializable。

org.omg.CORBA_2_3.portable 中 Serializable 的使用

返回 Serializable 的 org.omg.CORBA_2_3.portable 中的方法
Serializable | InputStream.read_value() 从输入流解组值类型。
Serializable | InputStream.read_value(BoxedValueHelper factory) 从输入流解组值类型。
Serializable | InputStream.read_value(Class clz) 从输入流解组值类型。
Serializable | InputStream.read_value(Serializable value) 从输入流解组值类型。
Serializable | InputStream.read_value(String rep_id) 从输入流解组值类型。

参数类型为 Serializable 的 org.omg.CORBA_2_3.portable 中的方法
Serializable | InputStream.read_value(Serializable value) 从输入流解组值类型。
void | OutputStream.write_value(Serializable value) 将值类型编组到输出流中。
void | OutputStream.write_value(Serializable value, BoxedValueHelper factory) 将值类型编组到输出流中。
void | OutputStream.write_value(Serializable value, Class clz) 将值类型编组到输出流中。
void | OutputStream.write_value(Serializable value, String repository_id) 将值类型编组到输出流中。

org.omg.CORBA.DynAnyPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CORBA.DynAnyPackage 中的类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CORBA.ORBPackage 中的类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Serializable 的使用

org.omg.CORBA.portable 中 Serializable 的子接口
interface | CustomValue 通过自定义值类型实现的 ValueBase 扩展。
interface | IDLEntity 一个不带任何成员的接口，其唯一目的是充当一个标记，用来指示实现类是 IDL 中的 Java 值类型且具有响应的 Helper 类。
interface | StreamableValue 为所有非自定义编码的非装箱 (boxed) IDL 值类型定义基本类型。
interface | ValueBase 所生成的对应于 valuetype IDL 类型的 Java 类实现此接口。

实现 Serializable 的 org.omg.CORBA.portable 中的类
class | ApplicationException 此类用来报告 ORB 和 stub 之间的应用程序级异常。
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | RemarshalException 此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

返回 Serializable 的 org.omg.CORBA.portable 中的方法
Serializable | BoxedValueHelper.read_value(InputStream is)
Serializable | ValueFactory.read_value(InputStream is) ORB 运行时在解组值类型的过程中调用此方法。

参数类型为 Serializable 的 org.omg.CORBA.portable 中的方法
 void BoxedValueHelper.write_value(OutputStream os, Serializable value)

org.omg.CORBA.TypeCodePackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CORBA.TypeCodePackage 中的类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming 中 Serializable 的使用

org.omg.CosNaming 中 Serializable 的子接口
interface | BindingIterator BindingIterator 接口允许客户端使用 next_one 或 next_n 迭代绑定。
interface | NamingContext 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
interface | NamingContextExt NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

实现 Serializable 的 org.omg.CosNaming 中的类
class | _BindingIteratorImplBase
class | _BindingIteratorStub BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。
class | _NamingContextExtStub NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。
class | _NamingContextImplBase
class | _NamingContextStub 命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。
class | BindingType 指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。
class | NameComponent org/omg/CosNaming/NameComponent.java。

org.omg.CosNaming.NamingContextExtPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CosNaming.NamingContextExtPackage 中的类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.CosNaming.NamingContextPackage 中的类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。
class | NotFoundReason 指示未能解析的原因。

org.omg.Dynamic 中 Serializable 的使用

实现 Serializable 的 org.omg.Dynamic 中的类
 class Parameter
org/omg/Dynamic/Parameter.java。

org.omg.DynamicAny 中 Serializable 的使用

org.omg.DynamicAny 中 Serializable 的子接口
interface | DynAny 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
interface | DynAnyFactory DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
interface | DynArray DynArray 对象支持对 IDL 数组的操作。
interface | DynEnum DynEnum 对象支持对 IDL 枚举值的操作。
interface | DynFixed DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。
interface | DynSequence DynSequence 对象支持对 IDL 序列的操作。
interface | DynStruct DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
interface | DynUnion DynUnion 对象支持对 IDL 联合 (union) 的操作。
interface | DynValue DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。
interface | DynValueBox DynValueBox 对象支持对 IDL 装箱 (boxed) 类型的操作。
interface | DynValueCommon DynValueCommon 提供 DynValue 和 DynValueBox 接口都支持的操作。

实现 Serializable 的 org.omg.DynamicAny 中的类
class | _DynAnyFactoryStub DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。
class | _DynAnyStub 通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。
class | _DynArrayStub DynArray 对象支持对 IDL 数组 (array) 的操作。
class | _DynEnumStub DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。
class | _DynFixedStub DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。
class | _DynSequenceStub DynSequence 对象支持对 IDL 序列 (sequence) 的操作。
class | _DynStructStub DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。
class | _DynUnionStub DynUnion 对象支持对 IDL 联合数据 (union) 的操作。
class | _DynValueStub DynValue 对象支持 IDL non-boxed value 类型的操作。
class | NameDynAnyPair org/omg/DynamicAny/NameDynAnyPair.java。

返回 Serializable 的 org.omg.DynamicAny 中的方法
Serializable | DynAnyOperations.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynAnyStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynArrayStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynEnumStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynFixedStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynSequenceStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynStructStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynUnionStub.get_val() 从此 DynAny 中提取 Serializable 对象。
Serializable | _DynValueStub.get_val() 从此 DynAny 中提取 Serializable 对象。

参数类型为 Serializable 的 org.omg.DynamicAny 中的方法
void | DynAnyOperations.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynAnyStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynArrayStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynEnumStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynFixedStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynSequenceStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynStructStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynUnionStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。
void | _DynValueStub.insert_val(Serializable value) 将对 Serializable 对象的引用插入此 DynAny 中。

org.omg.IOP 中 Serializable 的使用

org.omg.IOP 中 Serializable 的子接口
interface | Codec IOR 组件的格式和 ORB 服务使用的服务上下文数据通常被定义为 CDR 封装，该封装编码用 IDL 定义的数据类型的实例。
interface | CodecFactory Codec 可从 CodecFactory 中获得。

实现 Serializable 的 org.omg.IOP 中的类
class | Encoding org/omg/IOP/Encoding.java。
class | IOR org/omg/IOP/IOR.java。
class | ServiceContext org/omg/IOP/ServiceContext.java。
class | TaggedComponent org/omg/IOP/TaggedComponent.java。
class | TaggedProfile org/omg/IOP/TaggedProfile.java。

org.omg.IOP.CodecFactoryPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.IOP.CodecFactoryPackage 中的类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.IOP.CodecPackage 中的类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 Serializable 的使用

org.omg.PortableInterceptor 中 Serializable 的子接口
interface | ClientRequestInfo 客户端请求 interceptor 可访问的请求信息。
interface | ClientRequestInterceptor 客户端 interceptor。
interface | Interceptor 所有 Portable Interceptor 实现 Interceptor。
interface | IORInfo 提供服务器端的 ORB 服务，该服务能够在构建 IOR 期间访问适用的策略并添加组件。
interface | IORInterceptor Interceptor 用于在 IOR 内部配置文件中建立带标记的组件。
interface | IORInterceptor_3_0 org/omg/PortableInterceptor/IORInterceptor_3_0.java。
interface | ObjectReferenceFactory 对象引用工厂。
interface | ObjectReferenceTemplate 对象引用模板。
interface | ORBInitializer 便于注册 interceptor 和初始化 ORB。
interface | ORBInitInfo 传递给每个 ORBInitializer，允许其在初始化 ORB 时注册 interceptor 并执行其他职责。
interface | PolicyFactory 使得策略类型能够使用 CORBA.ORB.create_policy 来构建。
interface | RequestInfo Interceptor 可访问的请求信息。
interface | ServerRequestInfo 服务器端请求 interceptor 可访问的请求信息。
interface | ServerRequestInterceptor 服务器端的请求 interceptor。

实现 Serializable 的 org.omg.PortableInterceptor 中的类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 Serializable 的使用

org.omg.PortableServer 中 Serializable 的子接口
interface | AdapterActivator 一个适配器激活器，它提供具有随需创建子 POA 功能的 POA。
interface | IdAssignmentPolicy IdAssignmentPolicy 指定创建的 POA 中的 Object Id 是由应用程序还是由 ORB 生成的。
interface | IdUniquenessPolicy IdUniquenessPolicy 指定已创建的 POA 中激活的 servant 是否必须具有唯一的对象身份。
interface | ImplicitActivationPolicy 此策略指定已创建的 POA 中是否支持隐式激活 servant。
interface | LifespanPolicy LifespanPolicy 指定已创建 POA 中实现的对象的生存期。
interface | POA POA 对象管理对象集合的实现。
interface | POAManager 每个 POA 对象都有一个关联的 POAManager 对象。
interface | RequestProcessingPolicy 此策略指定已创建的 POA 处理请求的方式。
interface | ServantActivator POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。
interface | ServantLocator 当 POA 具有 NON_RETAIN 策略时，使用 ServantLocator 这种 servant 管理器。
interface | ServantManager servant 管理器提供一个 POA，该 POA 在接受以非激活的对象为目标的请求时能够根据需要激活对象。
interface | ServantRetentionPolicy 此策略指定已创建的 POA 是否在 Active Object Map 中保留激活的 servant。
interface | ThreadPolicy ThreadPolicy 指定已创建的 POA 所使用的线程模型 (threading model)。

实现 Serializable 的 org.omg.PortableServer 中的类
class | _ServantActivatorStub 当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。
class | _ServantLocatorStub POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。
class | ForwardRequest org/omg/PortableServer/ForwardRequest.java。
class | IdAssignmentPolicyValue IdAssignmentPolicyValue 可以具有以下值。
class | IdUniquenessPolicyValue IdUniquenessPolicyValue 可以具有以下值。
class | ImplicitActivationPolicyValue ImplicitActivationPolicyValue 具有以下语义。
class | LifespanPolicyValue LifespanPolicyValue 可以具有以下值。
class | RequestProcessingPolicyValue RequestProcessingPolicyValue 可以具有以下值。
class | ServantRetentionPolicyValue ServantRetentionPolicyValue 可以具有以下值。
class | ThreadPolicyValue ThreadPolicyValue 可以具有以下值。

org.omg.PortableServer.CurrentPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableServer.CurrentPackage 中的类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableServer.POAManagerPackage 中的类
class | AdapterInactive org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。
class | State 指定 POAManager 的状态。

org.omg.PortableServer.POAPackage 中 Serializable 的使用

实现 Serializable 的 org.omg.PortableServer.POAPackage 中的类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.omg.SendingContext 中 Serializable 的使用

org.omg.SendingContext 中 Serializable 的子接口
 interface RunTime
定义表示请求的发送上下文的基类。

org.omg.stub.java.rmi 中 Serializable 的使用

实现 Serializable 的 org.omg.stub.java.rmi 中的类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

org.w3c.dom 中 Serializable 的使用

实现 Serializable 的 org.w3c.dom 中的类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 Serializable 的使用

实现 Serializable 的 org.w3c.dom.events 中的类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Serializable 的使用

实现 Serializable 的 org.w3c.dom.ls 中的类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Serializable 的使用

实现 Serializable 的 org.xml.sax 中的类
class | SAXException 封装一般的 SAX 错误或警告。
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractMethodError (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang
类 AbstractMethodError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.IncompatibleClassChangeError
                    继承者  java.lang.AbstractMethodError
所有已实现的接口：
Serializable
public class AbstractMethodError
extends IncompatibleClassChangeError

当应用程序试图调用一个抽象方法时，抛出此错误。通常由编译器捕获此错误；如果某个类的定义自当前执行方法最后一次编译以后作了不兼容的更改，则此错误只可能在运行时发生。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
AbstractMethodError()
构造不带详细消息的 AbstractMethodError。
AbstractMethodError(String s)
构造带指定详细消息的 AbstractMethodError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractMethodError

public AbstractMethodError()
构造不带详细消息的 AbstractMethodError。

AbstractMethodError

public AbstractMethodError(String s)
构造带指定详细消息的 AbstractMethodError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Appendable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 Appendable

所有已知实现类：
BufferedWriter, CharArrayWriter, CharBuffer, FileWriter, FilterWriter, LogStream, OutputStreamWriter, PipedWriter, PrintStream, PrintWriter, StringBuffer, StringBuilder, StringWriter, Writer
public interface Appendable

能够被添加 char 序列和值的对象。如果某个类的实例打算接收取自 Formatter 的格式化输出，那么该类必须实现 Appendable 接口。

要添加的字符应该是有效的 Unicode 字符，正如 Unicode Character Representation 中描述的那样。注意，增补字符可能由多个 16 位 char 值组成。

Appendable 对于多线程访问而言没必要是安全的。线程安全由扩展和实现此接口的类负责。

由于此接口可能由具有不同的错误处理风格的现有类实现，所以无法保证错误不会传播给调用者。

从以下版本开始：
1.5

方法摘要
Appendable | append(char c) 向此 Appendable 添加指定字符。
Appendable | append(CharSequence csq) 向此 Appendable 添加指定的字符序列。
Appendable | append(CharSequence csq, int start, int end) 向此 Appendable 添加指定字符序列的子序列。

方法详细信息

append

Appendable append(CharSequence csq)
                  throws IOException
向此 Appendable 添加指定的字符序列。

有时可能没有添加整个序列，这取决于使用哪个类来实现字符序列 csq。例如，如果 csq 是 CharBuffer 的一个实例，则通过缓冲区的位置和限制来定义要添加的子序列。

参数：
csq - 要添加的字符串序列。如果 csq 为 null，则向该 Appendable 添加四个字符 "null"。
返回：
此 Appendable 的引用
抛出：
IOException - 如果发生 I/O 错误

append

Appendable append(CharSequence csq,
                  int start,
                  int end)
                  throws IOException
向此 Appendable 添加指定字符序列的子序列。

当 csq 不为 null 时，用 out.append(csq, start, end) 的形式调用此方法与用以下形式调用此方法的行为完全相同：

     out.append(csq.subSequence(start, end))

参数：
csq - 子序列将被添加的字符序列。如果 csq 为 null，则添加四个字符 "null"，就好像 csq 包含这些字符一样。
start - 子序列中第一个字符的索引
end - 紧随子序列中最后一个字符的字符的索引
返回：
此 Appendable 的引用
抛出：
IndexOutOfBoundsException - 如果 start 或 end 为负，以及 start 大于 end 或者 end 大于 csq.length()
IOException - 如果发生 I/O 错误

append

Appendable append(char c)
                  throws IOException
向此 Appendable 添加指定字符。

参数：
c - 要添加的字符
返回：
此 Appendable 的引用
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ArithmeticException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ArithmeticException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.ArithmeticException
所有已实现的接口：
Serializable
public class ArithmeticException
extends RuntimeException

当出现异常的运算条件时，抛出此异常。例如，一个整数“除以零”时，抛出此类的一个实例。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
ArithmeticException()
构造不带详细消息的 ArithmeticException。
ArithmeticException(String s)
构造具有指定详细消息的 ArithmeticException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ArithmeticException

public ArithmeticException()
构造不带详细消息的 ArithmeticException。

ArithmeticException

public ArithmeticException(String s)
构造具有指定详细消息的 ArithmeticException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ArrayIndexOutOfBoundsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ArrayIndexOutOfBoundsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IndexOutOfBoundsException
                    继承者  java.lang.ArrayIndexOutOfBoundsException
所有已实现的接口：
Serializable
public class ArrayIndexOutOfBoundsException
extends IndexOutOfBoundsException

用非法索引访问数组时抛出的异常。如果索引为负或大于等于数组大小，则该索引为非法索引。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
ArrayIndexOutOfBoundsException()
构造不带详细消息的 ArrayIndexOutOfBoundsException。
ArrayIndexOutOfBoundsException(int index)
构造具有指示非法索引的参数的新 ArrayIndexOutOfBoundsException 类。
ArrayIndexOutOfBoundsException(String s)
构造具有指定详细消息的 ArrayIndexOutOfBoundsException 类。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ArrayIndexOutOfBoundsException

public ArrayIndexOutOfBoundsException()
构造不带详细消息的 ArrayIndexOutOfBoundsException。

ArrayIndexOutOfBoundsException

public ArrayIndexOutOfBoundsException(int index)
构造具有指示非法索引的参数的新 ArrayIndexOutOfBoundsException 类。

参数：
index - 非法索引。

ArrayIndexOutOfBoundsException

public ArrayIndexOutOfBoundsException(String s)
构造具有指定详细消息的 ArrayIndexOutOfBoundsException 类。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ArrayStoreException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ArrayStoreException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.ArrayStoreException
所有已实现的接口：
Serializable
public class ArrayStoreException
extends RuntimeException

试图将错误类型的对象存储到一个对象数组时抛出的异常。例如，以下代码可生成一个 ArrayStoreException：

     Object x[] = new String[3];
     x[0] = new Integer(0);

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
ArrayStoreException()
构造不带详细消息的 ArrayStoreException。
ArrayStoreException(String s)
构造具有指定详细消息的 ArrayStoreException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ArrayStoreException

public ArrayStoreException()
构造不带详细消息的 ArrayStoreException。

ArrayStoreException

public ArrayStoreException(String s)
构造具有指定详细消息的 ArrayStoreException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AssertionError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 AssertionError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.AssertionError
所有已实现的接口：
Serializable
public class AssertionError
extends Error

抛出该异常指示某个断言失败。

此类提供七个单参数公共构造方法，确保通过以下调用返回的断言错误：

     new AssertionError(expression)
具有作为其详细消息的表达式 的字符串转换（这在 The Java Language Specification 第二版 的第 15.18.1.1 节中已定义），而不管表达式 的类型是什么。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
AssertionError()
构造一个不带详细消息的 AssertionError。
AssertionError(boolean detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 boolean，该 boolean 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(char detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 char，该 char 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(double detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 double，该 double 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(float detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 float，该 float 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(int detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 int，该 int 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(long detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 long，该 long 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
AssertionError(Object detailMessage)
构造一个 AssertionError，其详细消息派生于指定的对象，该对象将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AssertionError

public AssertionError()
构造一个不带详细消息的 AssertionError。

AssertionError

public AssertionError(Object detailMessage)
构造一个 AssertionError，其详细消息派生于指定的对象，该对象将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

如果指定对象是一个 Throwable 的实例，那么它将成为新构造的断言错误的 cause。

参数：
detailMessage - 用来构造详细消息的值
另请参见：
Throwable.getCause()

AssertionError

public AssertionError(boolean detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 boolean，该 boolean 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

参数：
detailMessage - 用来构造详细消息的值

AssertionError

public AssertionError(char detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 char，该 char 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

参数：
detailMessage - 用来构造详细消息的值

AssertionError

public AssertionError(int detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 int，该 int 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

参数：
detailMessage - 用来构造详细消息的值

AssertionError

public AssertionError(long detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 long，该 long 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

参数：
detailMessage - 用来构造详细消息的值

AssertionError

public AssertionError(float detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 float，该 float 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

参数：
detailMessage - 用来构造详细消息的值

AssertionError

public AssertionError(double detailMessage)
构造一个 AssertionError，其详细消息派生于指定的 double，该 double 将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

参数：
detailMessage - 用来构造详细消息的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Boolean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Boolean

java.lang.Object
    继承者  java.lang.Boolean
所有已实现的接口：
Serializable, Comparable<Boolean>
public final class Boolean
extends Object
implements Serializable, Comparable<Boolean>

Boolean 类将基本类型为 boolean 的值包装在一个对象中。一个 Boolean 类型的对象只包含一个类型为 boolean 的字段。

此外，此类还为 boolean 和 String 的相互转换提供了许多方法，并提供了处理 boolean 时非常有用的其他一些常量和方法。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static Boolean | FALSE 对应基值 false 的 Boolean 对象。
static Boolean | TRUE 对应基值 true 的 Boolean 对象。
static Class<Boolean> | TYPE 表示基本类型 boolean 的 Class 对象。
构造方法摘要
Boolean(boolean value)
分配一个表示 value 参数的 Boolean 对象。
Boolean(String s)
如果 String 参数不为 null 且在忽略大小写时等于 "true"，则分配一个表示 true 值的 Boolean 对象。
方法摘要
boolean | booleanValue() 将此 Boolean 对象的值作为基本布尔值返回。
int | compareTo(Boolean b) 将此 Boolean 实例与其他实例进行比较。
boolean | equals(Object obj) 当且仅当参数不是 null，而是一个与此对象一样，都表示同一个 Boolean 值的 boolean 对象时，才返回 true。
static boolean | getBoolean(String name) 当且仅当以参数命名的系统属性存在，且等于 "true" 字符串时，才返回 true。
int | hashCode() 返回该 Boolean 对象的哈希码。
static boolean | parseBoolean(String s) 将字符串参数解析为 boolean 值。
String | toString() 返回表示该布尔值的 String 对象。
static String | toString(boolean b) 返回一个表示指定布尔值的 String 对象。
static Boolean | valueOf(boolean b) 返回一个表示指定 boolean 值的 Boolean 实例。
static Boolean | valueOf(String s) 返回一个用指定的字符串表示值的 Boolean 值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TRUE

public static final Boolean TRUE
对应基值 true 的 Boolean 对象。

FALSE

public static final Boolean FALSE
对应基值 false 的 Boolean 对象。

TYPE

public static final Class<Boolean> TYPE
表示基本类型 boolean 的 Class 对象。

从以下版本开始：
JDK1.1
构造方法详细信息

Boolean

public Boolean(boolean value)
分配一个表示 value 参数的 Boolean 对象。

注：一般情况下都不宜使用该构造方法。若不需要新 的实例，则静态工厂 valueOf(boolean) 通常是一个更好的选择。这有可能显著提高空间和时间性能。

参数：
value - Boolean 的值。

Boolean

public Boolean(String s)
如果 String 参数不为 null 且在忽略大小写时等于 "true"，则分配一个表示 true 值的 Boolean 对象。否则分配一个表示 false 值的 Boolean 对象。示例：

new Boolean("True") 生成一个表示 true 的 Boolean 对象。
new Boolean("yes") 生成一个表示 false 的 Boolean 对象。

参数：
s - 要转换为 Boolean 的字符串。
方法详细信息

parseBoolean

public static boolean parseBoolean(String s)
将字符串参数解析为 boolean 值。如果 String 参数不是 null 且在忽略大小写时等于 "true"，则返回的 boolean 表示 true 值。

示例：Boolean.parseBoolean("True") 返回 true。
示例：Boolean.parseBoolean("yes") 返回 false。

参数：
s - 包含要解析的布尔表达式的 String
返回：
String 参数所表示的布尔值
从以下版本开始：
1.5

booleanValue

public boolean booleanValue()
将此 Boolean 对象的值作为基本布尔值返回。

返回：
此对象的基本 boolean 值。

valueOf

public static Boolean valueOf(boolean b)
返回一个表示指定 boolean 值的 Boolean 实例。如果指定的 boolean 值为 true，则此方法返回 Boolean.TRUE；如果为 false，则返回 Boolean.FALSE。如果不需要新的 Boolean 实例，则应优先使用此方法，而不是构造方法 Boolean(boolean)，因为此方法有可能大大提高空间和时间性能。

参数：
b - 布尔值。
返回：
一个表示 b 的 Boolean 实例。
从以下版本开始：
1.4

valueOf

public static Boolean valueOf(String s)
返回一个用指定的字符串表示值的 Boolean 值。如果字符串参数不为 null 且在忽略大小写时等于 "true"，则返回的 Boolean 表示 true 值。

参数：
s - 字符串。
返回：
该字符串所表示的 Boolean 值。

toString

public static String toString(boolean b)
返回一个表示指定布尔值的 String 对象。如果指定布尔值为 true，则将返回字符串 "true"，否则将返回字符串 "false"。

参数：
b - 要转换的布尔值
返回：
指定 boolean 值的字符串表达式
从以下版本开始：
1.4

toString

public String toString()
返回表示该布尔值的 String 对象。如果该对象表示 true 值，则返回等于 "true" 的字符串。否则返回等于 "false" 的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。

hashCode

public int hashCode()
返回该 Boolean 对象的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
如果此对象表示 true 则返回整数 1231；如果表示 false 则返回整数 1237。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
当且仅当参数不是 null，而是一个与此对象一样，都表示同一个 Boolean 值的 boolean 对象时，才返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 比较的对象。
返回：
如果这些布尔对象表示相同的值，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getBoolean

public static boolean getBoolean(String name)
当且仅当以参数命名的系统属性存在，且等于 "true" 字符串时，才返回 true。（从 JavaTM 平台的 1.0.2 版本开始，字符串的测试不再区分大小写。）通过 getProperty 方法可访问系统属性，此方法由 System 类定义。

如果没有以指定名称命名的属性或者指定名称为空或 null，则返回 false。

参数：
name - 系统属性名。
返回：
系统属性的 boolean 值。
另请参见：
System.getProperty(java.lang.String), System.getProperty(java.lang.String, java.lang.String)

compareTo

public int compareTo(Boolean b)
将此 Boolean 实例与其他实例进行比较。

指定者：
接口 Comparable<Boolean> 中的 compareTo
参数：
b - 要进行比较的 Boolean 实例
返回：
如果对象与参数表示的布尔值相同，则返回零；如果此对象表示 true，参数表示 false，则返回一个正值；如果此对象表示 false，参数表示 true，则返回一个负值
抛出：
NullPointerException - 如果参数为 null
从以下版本开始：
1.5
另请参见：
Comparable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Byte (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Byte

java.lang.Object
    继承者  java.lang.Number
        继承者  java.lang.Byte
所有已实现的接口：
Serializable, Comparable<Byte>
public final class Byte
extends Number
implements Comparable<Byte>

Byte 类将基本类型 byte 的值包装在一个对象中。一个 Byte 类型的对象只包含一个类型为 byte 的字段。

此外，该类还为 byte 和 String 的相互转换提供了几种方法，并提供了处理 byte 时非常有用的其他一些常量和方法。

从以下版本开始：
JDK1.1
另请参见：
Number, 序列化表格

字段摘要
static byte | MAX_VALUE 一个常量，保存 byte 类型可取的最大值，即 27-1。
static byte | MIN_VALUE 一个常量，保存 byte 类型可取的最小值，即 -27。
static int | SIZE 用于以二进制补码形式表示 byte 值的位数。
static Class<Byte> | TYPE 表示基本类型 byte 的 Class 实例。
构造方法摘要
Byte(byte value)
构造一个新分配的 Byte 对象，以表示指定的 byte 值。
Byte(String s)
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。
方法摘要
byte | byteValue() 作为一个 byte 返回此 Byte 的值。
int | compareTo(Byte anotherByte) 在数字上比较两个 Byte 对象。
static Byte | decode(String nm) 将 String 解码为 Byte。
double | doubleValue() 作为一个 double 返回此 Byte 的值。
boolean | equals(Object obj) 将此对象与指定对象比较。
float | floatValue() 作为一个 float 返回此 Byte 的值。
int | hashCode() 返回此 Byte 的哈希码。
int | intValue() 作为一个 int 返回此 Byte 的值。
long | longValue() 作为一个 long 返回此 Byte 的值。
static byte | parseByte(String s) 将 string 参数解析为有符号的十进制 byte。
static byte | parseByte(String s, int radix) 将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。
short | shortValue() 作为一个 short 返回此 Byte 的值。
String | toString() 返回表示此 Byte 的值的 String 对象。
static String | toString(byte b) 返回表示指定 byte 的一个新 String 对象。
static Byte | valueOf(byte b) 返回表示指定 byte 值的一个 Byte 实例。
static Byte | valueOf(String s) 返回一个保持指定 String 所给出的值的 Byte 对象。
static Byte | valueOf(String s, int radix) 返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MIN_VALUE

public static final byte MIN_VALUE
一个常量，保存 byte 类型可取的最小值，即 -27。

另请参见：
常量字段值

MAX_VALUE

public static final byte MAX_VALUE
一个常量，保存 byte 类型可取的最大值，即 27-1。

另请参见：
常量字段值

TYPE

public static final Class<Byte> TYPE
表示基本类型 byte 的 Class 实例。

SIZE

public static final int SIZE
用于以二进制补码形式表示 byte 值的位数。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

Byte

public Byte(byte value)
构造一个新分配的 Byte 对象，以表示指定的 byte 值。

参数：
value - Byte 对象所表示的值。

Byte

public Byte(String s)
     throws NumberFormatException
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。该字符串以使用基数 10 的 parseByte 方法所使用的方式被转换成一个 byte 值。

参数：
s - 要转换成 Byte 的 String
抛出：
NumberFormatException - 如果 String 不包含一个可解析的 byte。
另请参见：
parseByte(java.lang.String, int)
方法详细信息

toString

public static String toString(byte b)
返回表示指定 byte 的一个新 String 对象。假定基数为 10。

参数：
b - 要转换的 byte
返回：
指定 byte 的字符串表示形式
另请参见：
Integer.toString(int)

valueOf

public static Byte valueOf(byte b)
返回表示指定 byte 值的一个 Byte 实例。如果不需要新的 Byte 实例，则通常应优先使用此方法，而不是构造方法 Byte(byte)，因为该方法有可能通过缓存经常请求的值来显著提高空间和时间性能。

参数：
b - 一个 byte 值。
返回：
表示 b 的 Byte 实例。
从以下版本开始：
1.5

parseByte

public static byte parseByte(String s)
                      throws NumberFormatException
将 string 参数解析为有符号的十进制 byte。除了第一个字符可以是表示负值的 ASCII 负号 '-' ('\u002D') 之外，该字符串中的字符必须都是十进制数字。返回得到的 byte 值与以该 string 参数和基数 10 为参数的 parseByte(java.lang.String, int) 方法所返回的值一样。

参数：
s - 要解析的包含 byte 表示形式的 String
返回：
以十进制的参数表示的 byte 值
抛出：
NumberFormatException - 如果该 string 不包含一个可解析的 byte。

parseByte

public static byte parseByte(String s,
                             int radix)
                      throws NumberFormatException
将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。除了第一个字符可以是表示负值的 ASCII 负号 '-' ('\u002D') 之外（这取决于 Character.digit(char, int) 是否返回非负值），该 string 中的字符必须都是指定基数的数字。返回得到的 byte 值。

如果出现下列任何一种情况，则抛出一个 NumberFormatException 类型的异常：

  • 第一个参数为 null 或是一个长度为零的字符串。
  • 基数小于 Character.MIN_RADIX 或者大于 Character.MAX_RADIX。
  • 字符串的任一字符不是指定基数的数字，第一个字符是负号 '-' ('\u002D') 的情况除外（但此时字符串的长度应超过 1）。
  • 字符串所表示的值不是 byte 类型的值。

参数：
s - 要解析的包含 byte 表示形式的 String
radix - 在解析 s 时使用的基数
返回：
以指定基数表示的 string 参数所表示的 byte 值
抛出：
NumberFormatException - 如果该 string 不包含一个可解析的 byte。

valueOf

public static Byte valueOf(String s,
                           int radix)
                    throws NumberFormatException
返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。第一个参数被解释为用第二个参数所指定的基数表示一个有符号的 byte，正如将该参数指定给 parseByte(java.lang.String, int) 方法一样。结果是一个表示该 string 所指定的 byte 值的 Byte 对象。

换句话说，该方法返回一个等于以下代码的值的 Byte 对象：

new Byte(Byte.parseByte(s, radix))

参数：
s - 要解析的字符串
radix - 在解释 s 时使用的基数
返回：
保持用指定基数表示的字符串参数所表示的值的 Byte 对象。
抛出：
NumberFormatException - 如果 String 不包含一个可解析的 byte。

valueOf

public static Byte valueOf(String s)
                    throws NumberFormatException
返回一个保持指定 String 所给出的值的 Byte 对象。参数被解释为表示一个有符号的十进制的 byte，正如将该参数指定给 parseByte(java.lang.String) 方法一样。结果是一个表示该 string 所指定的 byte 值的 Byte 对象。

换句话说，该方法返回一个等于以下代码的值的 Byte 对象：

new Byte(Byte.parseByte(s))

参数：
s - 要解析的字符串
返回：
保持 string 参数所表示的值的 Byte 对象
抛出：
NumberFormatException - 如果该 String 不包含一个可解析的 byte。

decode

public static Byte decode(String nm)
                   throws NumberFormatException
将 String 解码为 Byte。接受按下列语法给出的十进制、十六进制和八进制数：
DecodableString:
Signopt DecimalNumeral
Signopt 0x HexDigits
Signopt 0X HexDigits
Signopt # HexDigits
Signopt 0 OctalDigits
Sign:
-
Java Language Specification 的 §3.10.1 中给出了 DecimalNumeral、HexDigits 和 OctalDigits 的定义。

对（可选）负号和/或基数说明符（“0x”、“0X”、“#” 或前导零）后面的字符序列进行解析就如同使用带指定基数（10、16 或 8）的 Byte.parseByte 方法一样。该字符序列必须表示一个正值，否则将抛出 NumberFormatException。如果指定 String 的第一个字符是负号，则结果将被求反。该 String 中不允许出现空白字符。

参数：
nm - 要解码的 String。
返回：
保持由 nm 表示的 byte 值的 Byte 对象
抛出：
NumberFormatException - 如果 String 不包含一个可解析的 byte。
另请参见：
parseByte(java.lang.String, int)

byteValue

public byte byteValue()
作为一个 byte 返回此 Byte 的值。

覆盖：
类 Number 中的 byteValue
返回：
转换为 byte 类型后该对象表示的数值。

shortValue

public short shortValue()
作为一个 short 返回此 Byte 的值。

覆盖：
类 Number 中的 shortValue
返回：
转换为 short 类型后该对象表示的数值。

intValue

public int intValue()
作为一个 int 返回此 Byte 的值。

指定者：
类 Number 中的 intValue
返回：
转换为 int 类型后该对象表示的数值。

longValue

public long longValue()
作为一个 long 返回此 Byte 的值。

指定者：
类 Number 中的 longValue
返回：
转换为 long 类型后该对象表示的数值。

floatValue

public float floatValue()
作为一个 float 返回此 Byte 的值。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 类型后该对象表示的数值。

doubleValue

public double doubleValue()
作为一个 double 返回此 Byte 的值。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 类型后该对象表示的数值。

toString

public String toString()
返回表示此 Byte 的值的 String 对象。该值被转换成有符号的十进制表示形式，并作为一个 string 返回，正如将 byte 值作为一个参数指定给 toString(byte) 方法所返回的一样。

覆盖：
类 Object 中的 toString
返回：
以基数 10 表示的此对象值的字符串表示形式。

hashCode

public int hashCode()
返回此 Byte 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，而是一个与此对象一样包含相同 Byte 值的 byte 对象时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要进行比较的对象
返回：
如果这些对象相同，则为 true；否则为 false。
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(Byte anotherByte)
在数字上比较两个 Byte 对象。

指定者：
接口 Comparable<Byte> 中的 compareTo
参数：
anotherByte - 要比较的 Byte。
返回：
如果此 Byte 等于参数 Byte，则返回 0；如果此 Byte 在数字上小于参数 Byte，则返回小于 0 的值；如果此 Byte 在数字上大于参数 Byte，则返回大于 0 的值（有符号比较）。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Character (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Character

java.lang.Object
    继承者  java.lang.Character
所有已实现的接口：
Serializable, Comparable<Character>
public final class Character
extends Object
implements Serializable, Comparable<Character>

Character 类在对象中包装一个基本类型 char 的值。Character 类型的对象包含类型为 char 的单个字段。

此外，该类提供了几种方法，以确定字符的类别（小写字母，数字，等等），并将字符从大写转换成小写，反之亦然。

字符信息基于 Unicode 标准，版本 4.0。

Character 类的方法和数据是通过 UnicodeData 文件中的信息定义的，该文件是 Unicode Consortium 维护的 Unicode Character Database 的一部分。此文件指定了各种属性，其中包括每个已定义 Unicode 代码点或字符范围的名称和常规类别。

此文件及其描述可从 Unicode Consortium 获得，网址如下：

  • http://www.unicode.org

Unicode 字符表示形式

char 数据类型（和 Character 对象封装的值）基于原始的 Unicode 规范，将字符定义为固定宽度的 16 位实体。Unicode 标准曾做过修改，以允许那些其表示形式需要超过 16 位的字符。合法代码点 的范围现在是从 U+0000 到 U+10FFFF，即通常所说的 Unicode 标量值。（请参阅 Unicode 标准中 U+n 表示法的定义。）

从 U+0000 到 U+FFFF 的字符集有时也称为 Basic Multilingual Plane (BMP)。代码点大于 U+FFFF 的字符称为增补字符。Java 2 平台在 char 数组以及 String 和 StringBuffer 类中使用 UTF-16 表示形式。在这种表现形式中，增补字符表示为一对 char 值，第一个值取自高代理项 范围，即 (\uD800-\uDBFF)，第二个值取自低代理项 范围，即 (\uDC00-\uDFFF)。

所以，char 值表示 Basic Multilingual Plane (BMP) 代码点，其中包括代理项代码点，或 UTF-16 编码的代码单元。int 值表示所有 Unicode 代码点，包括增补代码点。int 的 21 个低位（最低有效位）用于表示 Unicode 代码点，并且 11 个高位（最高有效位）必须为零。除非另有指定，否则与增补字符和代理项 char 值有关的行为如下：

  • 只接受一个 char 值的方法无法支持增补字符。它们将代理项字符范围内的 char 值视为未定义字符。例如，Character.isLetter('\uD840') 返回 false，即使是特定值，如果在字符串的后面跟着任何低代理项值，那么它将表示一个字母。
  • 接受一个 int 值的方法支持所有 Unicode 字符，其中包括增补字符。例如，Character.isLetter(0x2F81A) 返回 true，因为代码点值表示一个字母（一个 CJK 象形文字）。

在 Java SE API 文档中，Unicode 代码点 用于范围在 U+0000 与 U+10FFFF 之间的字符值，而 Unicode 代码点 用于作为 UTF-16 编码的代码单元的 16 位 char 值。有关 Unicode 技术的详细信息，请参阅 Unicode Glossary。

从以下版本开始：
1.0
另请参见：
序列化表格

嵌套类摘要
static class | Character.Subset 此类的实例表示 Unicode 字符集的特定子集。
static class | Character.UnicodeBlock 表示 Unicode 规范中字符块的一系列字符子集。
字段摘要
static byte | COMBINING_SPACING_MARK Unicode 规范中的常规类别“Mc”。
static byte | CONNECTOR_PUNCTUATION Unicode 规范中的常规类别“Pc”。
static byte | CONTROL Unicode 规范中的常规类别“Cc”。
static byte | CURRENCY_SYMBOL Unicode 规范中的常规类别“Sc”。
static byte | DASH_PUNCTUATION Unicode 规范中的常规类别“Pd”。
static byte | DECIMAL_DIGIT_NUMBER Unicode 规范中的常规类别“Nd”。
static byte | DIRECTIONALITY_ARABIC_NUMBER Unicode 规范中的弱双向字符类型“AN”。
static byte | DIRECTIONALITY_BOUNDARY_NEUTRAL Unicode 规范中的弱双向字符类型“BN”。
static byte | DIRECTIONALITY_COMMON_NUMBER_SEPARATOR Unicode 规范中的弱双向字符类型“CS”。
static byte | DIRECTIONALITY_EUROPEAN_NUMBER Unicode 规范中的弱双向字符类型“EN”。
static byte | DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR Unicode 规范中的弱双向字符类型“ES”。
static byte | DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR Unicode 规范中的弱双向字符类型“ET”。
static byte | DIRECTIONALITY_LEFT_TO_RIGHT Unicode 规范中的强双向字符类型“L”。
static byte | DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING Unicode 规范中的强双向字符类型“LRE”。
static byte | DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE Unicode 规范中的强双向字符类型“LRO”。
static byte | DIRECTIONALITY_NONSPACING_MARK Unicode 规范中的弱双向字符类型“NSM”。
static byte | DIRECTIONALITY_OTHER_NEUTRALS Unicode 规范中的非特定双向字符类型“ON”。
static byte | DIRECTIONALITY_PARAGRAPH_SEPARATOR Unicode 规范中的非特定双向字符类型“B”。
static byte | DIRECTIONALITY_POP_DIRECTIONAL_FORMAT Unicode 规范中的弱双向字符类型“PDF”。
static byte | DIRECTIONALITY_RIGHT_TO_LEFT Unicode 规范中的强双向字符类型“R”。
static byte | DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC Unicode 规范中的强双向字符类型“AL”。
static byte | DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING Unicode 规范中的强双向字符类型“RLE”。
static byte | DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE Unicode 规范中的强双向字符类型“RLO”。
static byte | DIRECTIONALITY_SEGMENT_SEPARATOR Unicode 规范中的非特定双向字符类型“S”。
static byte | DIRECTIONALITY_UNDEFINED 未定义的双向字符类型。
static byte | DIRECTIONALITY_WHITESPACE Unicode 规范中的非特定双向字符类型“WS”。
static byte | ENCLOSING_MARK Unicode 规范中的常规类别“Me”。
static byte | END_PUNCTUATION Unicode 规范中的常规类别“Pe”。
static byte | FINAL_QUOTE_PUNCTUATION Unicode 规范中的常规类别“Pf”。
static byte | FORMAT Unicode 规范中的常规类别“Cf”。
static byte | INITIAL_QUOTE_PUNCTUATION Unicode 规范中的常规类别“Pi”。
static byte | LETTER_NUMBER Unicode 规范中的常规类别“Nl”。
static byte | LINE_SEPARATOR Unicode 规范中的常规类别“Zl”。
static byte | LOWERCASE_LETTER Unicode 规范中的常规类别“Ll”。
static byte | MATH_SYMBOL Unicode 规范中的常规类别“Sm”。
static int | MAX_CODE_POINT Unicode 代码点的最大值。
static char | MAX_HIGH_SURROGATE UTF-16 编码中的 Unicode 高代理项代码单元的最大值。
static char | MAX_LOW_SURROGATE UTF-16 编码中的 Unicode 低代理项代码单元的最大值。
static int | MAX_RADIX 可用于与字符串相互转换的最大基数。
static char | MAX_SURROGATE UTF-16 编码中的 Unicode 代理项代码单元的最大值。
static char | MAX_VALUE 此字段的常量值是 char 类型的最大值，即 '\uFFFF'。
static int | MIN_CODE_POINT Unicode 代码点的最小值。
static char | MIN_HIGH_SURROGATE UTF-16 编码中的 Unicode 高代理项代码单元的最小值。
static char | MIN_LOW_SURROGATE UTF-16 编码中的 Unicode 低代理项代码单元的最小值。
static int | MIN_RADIX 可用于与字符串相互转换的最小基数。
static int | MIN_SUPPLEMENTARY_CODE_POINT 增补代码点的最小值。
static char | MIN_SURROGATE UTF-16 编码中的 Unicode 代理项代码单元的最小值。
static char | MIN_VALUE 此字段的常量值是 char 类型的最小值，即 '\u0000'。
static byte | MODIFIER_LETTER Unicode 规范中的常规类别“Lm”。
static byte | MODIFIER_SYMBOL Unicode 规范中的常规类别“Sk”。
static byte | NON_SPACING_MARK Unicode 规范中的常规类别“Mn”。
static byte | OTHER_LETTER Unicode 规范中的常规类别“Lo”。
static byte | OTHER_NUMBER Unicode 规范中的常规类别“No”。
static byte | OTHER_PUNCTUATION Unicode 规范中的常规类别“Po”。
static byte | OTHER_SYMBOL Unicode 规范中的常规类别“So”。
static byte | PARAGRAPH_SEPARATOR Unicode 规范中的常规类别“Zp”。
static byte | PRIVATE_USE Unicode 规范中的常规类别“Co”。
static int | SIZE 用来以无符号二进制形式表示 char 值的位数。
static byte | SPACE_SEPARATOR Unicode 规范中的常规类别“Zs”。
static byte | START_PUNCTUATION Unicode 规范中的常规类别“Ps”。
static byte | SURROGATE Unicode 规范中的常规类别“Cs”。
static byte | TITLECASE_LETTER Unicode 规范中的常规类别“Lt”。
static Class<Character> | TYPE 表示基本类型 char 的 Class 实例。
static byte | UNASSIGNED Unicode 规范中的常规类别“Cn”。
static byte | UPPERCASE_LETTER Unicode 规范中的常规类别“Lu”。
构造方法摘要
Character(char value)
构造一个新分配的 Character 对象，用以表示指定的 char 值。
方法摘要
static int | charCount(int codePoint) 确定表示指定字符（Unicode 代码点）所需的 char 值的数量。
char | charValue() 返回此 Character 对象的值。
static int | codePointAt(char[] a, int index) 返回 char 数组的给定索引上的代码点。
static int | codePointAt(char[] a, int index, int limit) 返回 char 数组的给定索引上的代码点，该数组中只有那些具有小于 limit 的 index 值的数组元素可以使用。
static int | codePointAt(CharSequence seq, int index) 返回 CharSequence 的给定索引上的代码点。
static int | codePointBefore(char[] a, int index) 返回 char 数组的给定索引前面的代码点。
static int | codePointBefore(char[] a, int index, int start) 返回 char 数组的给定索引前面的代码点，该数组中只有那些具有大于等于 start 的 index 值的数组元素可以使用。
static int | codePointBefore(CharSequence seq, int index) 返回 CharSequence 的给定索引前面的代码点。
static int | codePointCount(char[] a, int offset, int count) 返回 char 数组参数的子数组中 Unicode 代码点的数量。
static int | codePointCount(CharSequence seq, int beginIndex, int endIndex) 返回指定字符序列的文本范围内的 Unicode 代码点数量。
int | compareTo(Character anotherCharacter) 根据数字比较两个 Character 对象。
static int | digit(char ch, int radix) 返回使用指定基数的字符 ch 的数值。
static int | digit(int codePoint, int radix) 返回使用指定基数的指定字符（Unicode 代码点）的数值。
boolean | equals(Object obj) 将此对象与指定对象比较。
static char | forDigit(int digit, int radix) 确定使用指定基数的特定数字的字符表示形式。
static byte | getDirectionality(char ch) 返回给定字符的 Unicode 方向属性。
static byte | getDirectionality(int codePoint) 返回给定字符（Unicode 代码点）的 Unicode 方向属性。
static int | getNumericValue(char ch) 返回指定的 Unicode 字符表示的 int 值。
static int | getNumericValue(int codePoint) 返回指定字符（Unicode 代码点）表示的 int 值。
static int | getType(char ch) 返回一个指示字符的常规类别的值。
static int | getType(int codePoint) 返回一个指示字符的常规类别的值。
int | hashCode() 返回此 Character 的哈希码。
static boolean | isDefined(char ch) 确定字符是否被定义为 Unicode 中的字符。
static boolean | isDefined(int codePoint) 确定字符（Unicode 代码点）是否被定义为 Unicode 中的字符。
static boolean | isDigit(char ch) 确定指定字符是否为数字。
static boolean | isDigit(int codePoint) 确定指定字符（Unicode 代码点）是否为数字。
static boolean | isHighSurrogate(char ch) 确定给出的 char 值是否为一个高代理项代码单元（也称为前导代理项代码单元）。
static boolean | isIdentifierIgnorable(char ch) 确定是否应该认为指定字符是 Java 标识符或 Unicode 标识符中可忽略的一个字符。
static boolean | isIdentifierIgnorable(int codePoint) 确定是否应该认为指定字符（Unicode 代码点）是 Java 标识符或 Unicode 标识符中可忽略的一个字符。
static boolean | isISOControl(char ch) 确定指定字符是否为 ISO 控制字符。
static boolean | isISOControl(int codePoint) 确定引用的字符（Unicode 代码点）是否为 ISO 控制字符。
static boolean | isJavaIdentifierPart(char ch) 确定指定字符是否可以是 Java 标识符中首字符以外的部分。
static boolean | isJavaIdentifierPart(int codePoint) 确定字符（Unicode 代码点）是否可以是 Java 标识符中首字符以外的部分。
static boolean | isJavaIdentifierStart(char ch) 确定是否允许将指定字符作为 Java 标识符中的首字符。
static boolean | isJavaIdentifierStart(int codePoint) 确定是否允许将字符（Unicode 代码点）作为 Java 标识符中的首字符。
static boolean | isJavaLetter(char ch) 已过时。 由 isJavaIdentifierStart(char) 取代。
static boolean | isJavaLetterOrDigit(char ch) 已过时。 由 isJavaIdentifierPart(char) 取代。
static boolean | isLetter(char ch) 确定指定字符是否为字母。
static boolean | isLetter(int codePoint) 确定指定字符（Unicode 代码点）是否为字母。
static boolean | isLetterOrDigit(char ch) 确定指定字符是否为字母或数字。
static boolean | isLetterOrDigit(int codePoint) 确定指定字符（Unicode 代码点）是否为字母或数字。
static boolean | isLowerCase(char ch) 确定指定字符是否为小写字母。
static boolean | isLowerCase(int codePoint) 确定指定字符（Unicode 代码点）是否为小写字母。
static boolean | isLowSurrogate(char ch) 确定给定 char 值是否一个低代理项代码单元（也称为尾部代理项代码单元）。
static boolean | isMirrored(char ch) 确定指定字符依据 Unicode 规范是否对称。
static boolean | isMirrored(int codePoint) 确定指定字符（Unicode 代码点）依据 Unicode 规范是否对称。
static boolean | isSpace(char ch) 已过时。 由 isWhitespace(char) 取代。
static boolean | isSpaceChar(char ch) 确定指定字符是否为 Unicode 空白字符。
static boolean | isSpaceChar(int codePoint) 确定指定字符（Unicode 代码点）是否为 Unicode 空白字符。
static boolean | isSupplementaryCodePoint(int codePoint) 确定指定字符（Unicode 代码点）是否在增补字符范围内。
static boolean | isSurrogatePair(char high, char low) 确定指定的 char 值对是否为有效的代理项对。
static boolean | isTitleCase(char ch) 确定指定字符是否为首字母大写字符。
static boolean | isTitleCase(int codePoint) 确定指定字符（Unicode 代码点）是否为首字母大写字符。
static boolean | isUnicodeIdentifierPart(char ch) 确定指定字符是否可以是 Unicode 标识符中首字符以外的部分。
static boolean | isUnicodeIdentifierPart(int codePoint) 确定指定字符（Unicode 代码点）是否可以是 Unicode 标识符中首字符以外的部分。
static boolean | isUnicodeIdentifierStart(char ch) 确定是否允许将指定字符作为 Unicode 标识符中的首字符。
static boolean | isUnicodeIdentifierStart(int codePoint) 确定是否允许将指定字符（Unicode 代码点）作为 Unicode 标识符中的首字符。
static boolean | isUpperCase(char ch) 确定指定字符是否为大写字母。
static boolean | isUpperCase(int codePoint) 确定指定字符（Unicode 代码点）是否为大写字母。
static boolean | isValidCodePoint(int codePoint) 确定指定的代码点是否为从 0x0000 到 0x10FFFF 范围之内的有效 Unicode 代码点值。
static boolean | isWhitespace(char ch) 确定指定字符依据 Java 标准是否为空白字符。
static boolean | isWhitespace(int codePoint) 确定指定字符（Unicode 代码点）依据 Java 标准是否为空白字符。
static int | offsetByCodePoints(char[] a, int start, int count, int index, int codePointOffset) 返回给定 char 子数组中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
static int | offsetByCodePoints(CharSequence seq, int index, int codePointOffset) 返回给定字符序列中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
static char | reverseBytes(char ch) 返回通过反转指定 char 值中的字节顺序而获得的值。
static char[] | toChars(int codePoint) 将指定的字符（Unicode 代码点）转换成其存储在 char 数组中的 UTF-16 表示形式。
static int | toChars(int codePoint, char[] dst, int dstIndex) 将指定字符（Unicode 代码点）转换为其 UTF-16 表示形式。
static int | toCodePoint(char high, char low) 将指定的代理项对转换为其增补代码点值。
static char | toLowerCase(char ch) 使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为小写。
static int | toLowerCase(int codePoint) 使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为小写。
String | toString() 返回表示此 Character 值的 String 对象。
static String | toString(char c) 返回一个表示指定 char 值的 String 对象。
static char | toTitleCase(char ch) 使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为首字母大写。
static int | toTitleCase(int codePoint) 使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为首字母大写。
static char | toUpperCase(char ch) 使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为大写。
static int | toUpperCase(int codePoint) 使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为大写。
static Character | valueOf(char c) 返回一个表示指定 char 值的 Character 实例。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MIN_RADIX

public static final int MIN_RADIX
可用于与字符串相互转换的最小基数。此字段的常量值是基数转换方法（比如 Integer 类的 digit、forDigit 和 toString 方法）中所允许的基数参数的最小值。

另请参见：
digit(char, int),
forDigit(int, int),
Integer.toString(int, int),
Integer.valueOf(java.lang.String),
常量字段值

MAX_RADIX

public static final int MAX_RADIX
可用于与字符串相互转换的最大基数。此字段的常量值是基数转换方法（比如 Integer 类的 digit、forDigit 和 toString 方法）中所允许的基数参数的最大值。

另请参见：
digit(char, int),
forDigit(int, int),
Integer.toString(int, int),
Integer.valueOf(java.lang.String),
常量字段值

MIN_VALUE

public static final char MIN_VALUE
此字段的常量值是 char 类型的最小值，即 '\u0000'。

从以下版本开始：
1.0.2
另请参见：
常量字段值

MAX_VALUE

public static final char MAX_VALUE
此字段的常量值是 char 类型的最大值，即 '\uFFFF'。

从以下版本开始：
1.0.2
另请参见：
常量字段值

TYPE

public static final Class<Character> TYPE
表示基本类型 char 的 Class 实例。

从以下版本开始：
1.1

UNASSIGNED

public static final byte UNASSIGNED
Unicode 规范中的常规类别“Cn”。

从以下版本开始：
1.1
另请参见：
常量字段值

UPPERCASE_LETTER

public static final byte UPPERCASE_LETTER
Unicode 规范中的常规类别“Lu”。

从以下版本开始：
1.1
另请参见：
常量字段值

LOWERCASE_LETTER

public static final byte LOWERCASE_LETTER
Unicode 规范中的常规类别“Ll”。

从以下版本开始：
1.1
另请参见：
常量字段值

TITLECASE_LETTER

public static final byte TITLECASE_LETTER
Unicode 规范中的常规类别“Lt”。

从以下版本开始：
1.1
另请参见：
常量字段值

MODIFIER_LETTER

public static final byte MODIFIER_LETTER
Unicode 规范中的常规类别“Lm”。

从以下版本开始：
1.1
另请参见：
常量字段值

OTHER_LETTER

public static final byte OTHER_LETTER
Unicode 规范中的常规类别“Lo”。

从以下版本开始：
1.1
另请参见：
常量字段值

NON_SPACING_MARK

public static final byte NON_SPACING_MARK
Unicode 规范中的常规类别“Mn”。

从以下版本开始：
1.1
另请参见：
常量字段值

ENCLOSING_MARK

public static final byte ENCLOSING_MARK
Unicode 规范中的常规类别“Me”。

从以下版本开始：
1.1
另请参见：
常量字段值

COMBINING_SPACING_MARK

public static final byte COMBINING_SPACING_MARK
Unicode 规范中的常规类别“Mc”。

从以下版本开始：
1.1
另请参见：
常量字段值

DECIMAL_DIGIT_NUMBER

public static final byte DECIMAL_DIGIT_NUMBER
Unicode 规范中的常规类别“Nd”。

从以下版本开始：
1.1
另请参见：
常量字段值

LETTER_NUMBER

public static final byte LETTER_NUMBER
Unicode 规范中的常规类别“Nl”。

从以下版本开始：
1.1
另请参见：
常量字段值

OTHER_NUMBER

public static final byte OTHER_NUMBER
Unicode 规范中的常规类别“No”。

从以下版本开始：
1.1
另请参见：
常量字段值

SPACE_SEPARATOR

public static final byte SPACE_SEPARATOR
Unicode 规范中的常规类别“Zs”。

从以下版本开始：
1.1
另请参见：
常量字段值

LINE_SEPARATOR

public static final byte LINE_SEPARATOR
Unicode 规范中的常规类别“Zl”。

从以下版本开始：
1.1
另请参见：
常量字段值

PARAGRAPH_SEPARATOR

public static final byte PARAGRAPH_SEPARATOR
Unicode 规范中的常规类别“Zp”。

从以下版本开始：
1.1
另请参见：
常量字段值

CONTROL

public static final byte CONTROL
Unicode 规范中的常规类别“Cc”。

从以下版本开始：
1.1
另请参见：
常量字段值

FORMAT

public static final byte FORMAT
Unicode 规范中的常规类别“Cf”。

从以下版本开始：
1.1
另请参见：
常量字段值

PRIVATE_USE

public static final byte PRIVATE_USE
Unicode 规范中的常规类别“Co”。

从以下版本开始：
1.1
另请参见：
常量字段值

SURROGATE

public static final byte SURROGATE
Unicode 规范中的常规类别“Cs”。

从以下版本开始：
1.1
另请参见：
常量字段值

DASH_PUNCTUATION

public static final byte DASH_PUNCTUATION
Unicode 规范中的常规类别“Pd”。

从以下版本开始：
1.1
另请参见：
常量字段值

START_PUNCTUATION

public static final byte START_PUNCTUATION
Unicode 规范中的常规类别“Ps”。

从以下版本开始：
1.1
另请参见：
常量字段值

END_PUNCTUATION

public static final byte END_PUNCTUATION
Unicode 规范中的常规类别“Pe”。

从以下版本开始：
1.1
另请参见：
常量字段值

CONNECTOR_PUNCTUATION

public static final byte CONNECTOR_PUNCTUATION
Unicode 规范中的常规类别“Pc”。

从以下版本开始：
1.1
另请参见：
常量字段值

OTHER_PUNCTUATION

public static final byte OTHER_PUNCTUATION
Unicode 规范中的常规类别“Po”。

从以下版本开始：
1.1
另请参见：
常量字段值

MATH_SYMBOL

public static final byte MATH_SYMBOL
Unicode 规范中的常规类别“Sm”。

从以下版本开始：
1.1
另请参见：
常量字段值

CURRENCY_SYMBOL

public static final byte CURRENCY_SYMBOL
Unicode 规范中的常规类别“Sc”。

从以下版本开始：
1.1
另请参见：
常量字段值

MODIFIER_SYMBOL

public static final byte MODIFIER_SYMBOL
Unicode 规范中的常规类别“Sk”。

从以下版本开始：
1.1
另请参见：
常量字段值

OTHER_SYMBOL

public static final byte OTHER_SYMBOL
Unicode 规范中的常规类别“So”。

从以下版本开始：
1.1
另请参见：
常量字段值

INITIAL_QUOTE_PUNCTUATION

public static final byte INITIAL_QUOTE_PUNCTUATION
Unicode 规范中的常规类别“Pi”。

从以下版本开始：
1.4
另请参见：
常量字段值

FINAL_QUOTE_PUNCTUATION

public static final byte FINAL_QUOTE_PUNCTUATION
Unicode 规范中的常规类别“Pf”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_UNDEFINED

public static final byte DIRECTIONALITY_UNDEFINED
未定义的双向字符类型。未定义的 char 值在 Unicode 规范中具有未定义的方向性。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_LEFT_TO_RIGHT

public static final byte DIRECTIONALITY_LEFT_TO_RIGHT
Unicode 规范中的强双向字符类型“L”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_RIGHT_TO_LEFT

public static final byte DIRECTIONALITY_RIGHT_TO_LEFT
Unicode 规范中的强双向字符类型“R”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC

public static final byte DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC
Unicode 规范中的强双向字符类型“AL”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_EUROPEAN_NUMBER

public static final byte DIRECTIONALITY_EUROPEAN_NUMBER
Unicode 规范中的弱双向字符类型“EN”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR

public static final byte DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR
Unicode 规范中的弱双向字符类型“ES”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR

public static final byte DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR
Unicode 规范中的弱双向字符类型“ET”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_ARABIC_NUMBER

public static final byte DIRECTIONALITY_ARABIC_NUMBER
Unicode 规范中的弱双向字符类型“AN”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_COMMON_NUMBER_SEPARATOR

public static final byte DIRECTIONALITY_COMMON_NUMBER_SEPARATOR
Unicode 规范中的弱双向字符类型“CS”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_NONSPACING_MARK

public static final byte DIRECTIONALITY_NONSPACING_MARK
Unicode 规范中的弱双向字符类型“NSM”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_BOUNDARY_NEUTRAL

public static final byte DIRECTIONALITY_BOUNDARY_NEUTRAL
Unicode 规范中的弱双向字符类型“BN”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_PARAGRAPH_SEPARATOR

public static final byte DIRECTIONALITY_PARAGRAPH_SEPARATOR
Unicode 规范中的非特定双向字符类型“B”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_SEGMENT_SEPARATOR

public static final byte DIRECTIONALITY_SEGMENT_SEPARATOR
Unicode 规范中的非特定双向字符类型“S”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_WHITESPACE

public static final byte DIRECTIONALITY_WHITESPACE
Unicode 规范中的非特定双向字符类型“WS”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_OTHER_NEUTRALS

public static final byte DIRECTIONALITY_OTHER_NEUTRALS
Unicode 规范中的非特定双向字符类型“ON”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING

public static final byte DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING
Unicode 规范中的强双向字符类型“LRE”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE

public static final byte DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE
Unicode 规范中的强双向字符类型“LRO”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING

public static final byte DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING
Unicode 规范中的强双向字符类型“RLE”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE

public static final byte DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE
Unicode 规范中的强双向字符类型“RLO”。

从以下版本开始：
1.4
另请参见：
常量字段值

DIRECTIONALITY_POP_DIRECTIONAL_FORMAT

public static final byte DIRECTIONALITY_POP_DIRECTIONAL_FORMAT
Unicode 规范中的弱双向字符类型“PDF”。

从以下版本开始：
1.4
另请参见：
常量字段值

MIN_HIGH_SURROGATE

public static final char MIN_HIGH_SURROGATE
UTF-16 编码中的 Unicode 高代理项代码单元的最小值。高代理项也称为前导代理项。

从以下版本开始：
1.5
另请参见：
常量字段值

MAX_HIGH_SURROGATE

public static final char MAX_HIGH_SURROGATE
UTF-16 编码中的 Unicode 高代理项代码单元的最大值。高代理项也称为前导代理项。

从以下版本开始：
1.5
另请参见：
常量字段值

MIN_LOW_SURROGATE

public static final char MIN_LOW_SURROGATE
UTF-16 编码中的 Unicode 低代理项代码单元的最小值。低代理项也称为尾部代理项。

从以下版本开始：
1.5
另请参见：
常量字段值

MAX_LOW_SURROGATE

public static final char MAX_LOW_SURROGATE
UTF-16 编码中的 Unicode 低代理项代码单元的最大值。低代理项也称为尾部代理项。

从以下版本开始：
1.5
另请参见：
常量字段值

MIN_SURROGATE

public static final char MIN_SURROGATE
UTF-16 编码中的 Unicode 代理项代码单元的最小值。

从以下版本开始：
1.5
另请参见：
常量字段值

MAX_SURROGATE

public static final char MAX_SURROGATE
UTF-16 编码中的 Unicode 代理项代码单元的最大值。

从以下版本开始：
1.5
另请参见：
常量字段值

MIN_SUPPLEMENTARY_CODE_POINT

public static final int MIN_SUPPLEMENTARY_CODE_POINT
增补代码点的最小值。

从以下版本开始：
1.5
另请参见：
常量字段值

MIN_CODE_POINT

public static final int MIN_CODE_POINT
Unicode 代码点的最小值。

从以下版本开始：
1.5
另请参见：
常量字段值

MAX_CODE_POINT

public static final int MAX_CODE_POINT
Unicode 代码点的最大值。

从以下版本开始：
1.5
另请参见：
常量字段值

SIZE

public static final int SIZE
用来以无符号二进制形式表示 char 值的位数。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

Character

public Character(char value)
构造一个新分配的 Character 对象，用以表示指定的 char 值。

参数：
value - Character 对象表示的值。
方法详细信息

valueOf

public static Character valueOf(char c)
返回一个表示指定 char 值的 Character 实例。如果不需要新的 Character 实例，则通常应该优先采用此方法，而不是构造方法 Character(char)，因为该方法很可能通过缓存经常请求的值来显著提高空间和时间性能。

参数：
c - 一个 char 值。
返回：
表示 c 的 Character 实例。
从以下版本开始：
1.5

charValue

public char charValue()
返回此 Character 对象的值。

返回：
此对象表示的基本 char 值。

hashCode

public int hashCode()
返回此 Character 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不是 null，而是一个与此对象包含相同 char 值的 Character 对象时，结果才是 true。

覆盖：
类 Object 中的 equals
参数：
obj - 比较的对象。
返回：
如果对象相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回表示此 Character 值的 String 对象。结果是一个长度为 1 的字符串，其唯一组件是此 Character 对象表示的基本 char 值。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。

toString

public static String toString(char c)
返回一个表示指定 char 值的 String 对象。结果是长度为 1 的字符串，仅由指定的 char 组成。

参数：
c - 要转换的 char 值
返回：
指定 char 值的字符串表示形式
从以下版本开始：
1.4

isValidCodePoint

public static boolean isValidCodePoint(int codePoint)
确定指定的代码点是否为从 0x0000 到 0x10FFFF 范围之内的有效 Unicode 代码点值。该方法等效于以下表达式：
 codePoint >= 0x0000 && codePoint <= 0x10FFFF

参数：
codePoint - 要测试的 Unicode 代码点
返回：
如果指定的代码点值是一个有效的代码点值，则返回 true；否则返回 false。
从以下版本开始：
1.5

isSupplementaryCodePoint

public static boolean isSupplementaryCodePoint(int codePoint)
确定指定字符（Unicode 代码点）是否在增补字符范围内。该方法调用以下表达式：
 codePoint >= 0x10000 && codePoint <= 0x10FFFF

参数：
codePoint - 要测试的字符（Unicode 代码点）
返回：
如果指定字符在 Unicode 增补字符范围内，则返回 true；否则返回 false。
从以下版本开始：
1.5

isHighSurrogate

public static boolean isHighSurrogate(char ch)
确定给出的 char 值是否为一个高代理项代码单元（也称为前导代理项代码单元）。这类值并不表示它们本身的字符，而被用来表示 UTF-16 编码中的增补字符。

该方法返回 true 的条件是当且仅当

ch >= '\uD800' && ch <= '\uDBFF'
为 true。

参数：
ch - 要测试的 char 值。
返回：
如果 char 值在 '\uD800' 与 '\uDBFF' 所包含的范围之间，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isLowSurrogate(char), Character.UnicodeBlock.of(int)

isLowSurrogate

public static boolean isLowSurrogate(char ch)
确定给定 char 值是否一个低代理项代码单元（也称为尾部代理项代码单元）。这类值并不表示它们本身的字符，而被用来表示 UTF-16 编码中的增补字符。

该方法返回 true 的条件是当且仅当

ch >= '\uDC00' && ch <= '\uDFFF'
为 true。

参数：
ch - 要测试的 char 值。
返回：
如果 char 值在 '\uDC00' 与 '\uDFFF' 所包含的范围之间，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isHighSurrogate(char)

isSurrogatePair

public static boolean isSurrogatePair(char high,
                                      char low)
确定指定的 char 值对是否为有效的代理项对。该方法等效于以下表达式：
 isHighSurrogate(high) && isLowSurrogate(low)

参数：
high - 要测试的高代理项代码值
low - 要测试的低代理项代码值
返回：
如果指定的高代理项和低代理项代码值表示的是一个有效的代理项对，则返回 true；否则返回 false。
从以下版本开始：
1.5

charCount

public static int charCount(int codePoint)
确定表示指定字符（Unicode 代码点）所需的 char 值的数量。如果指定字符等于或大于 0x10000，则该方法返回的值为 2。否则，该方法返回的值为 1。

该方法没有验证指定的字符是否为一个有效的 Unicode 代码点。如有必要，调用者必须使用 isValidCodePoint 验证字符值。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符是一个有效的增补字符，则返回 2；否则返回 1。
从以下版本开始：
1.5
另请参见：
isSupplementaryCodePoint(int)

toCodePoint

public static int toCodePoint(char high,
                              char low)
将指定的代理项对转换为其增补代码点值。该方法没有验证指定的代理项对。如有必要，调用者必须使用 isSurrogatePair 验证它。

参数：
high - 高代理项代码单元
low - 低代理项代码单元
返回：
用指定代理项对组成的增补代码点
从以下版本开始：
1.5

codePointAt

public static int codePointAt(CharSequence seq,
                              int index)
返回 CharSequence 的给定索引上的代码点。如果 CharSequence 中的给定索引上的 char 值在高代理项范围内，则下列索引的长度小于 CharSequence 的长度，如果下列索引上的 char 值在低代理项范围内，则返回对应于此代理项对的增补代码点。否则，返回给定索引上的 char 值。

参数：
seq - char 值（Unicode 代码单元）的序列
index - 要转换的 seq 中的 char 值（Unicode 代码单元）的索引
返回：
给定索引上的 Unicode 代码点
抛出：
NullPointerException - 如果 seq 为 null。
IndexOutOfBoundsException - 如果 index 值为负或不小于 seq.length()。
从以下版本开始：
1.5

codePointAt

public static int codePointAt(char[] a,
                              int index)
返回 char 数组的给定索引上的代码点。如果 char 数组中的给定索引上的 char 值在高代理项范围内，则下一个索引的长度小于 char 数组的长度，如果下一个索引上的 char 值在低代理项范围内，则返回对应于此代理项对的增补代码点。否则，返回给定索引上的 char 值。

参数：
a - char 数组
index - 要转换的 char 数组中的 char 值（Unicode 代码单元）的索引
返回：
给定索引上的 Unicode 代码点
抛出：
NullPointerException - 如果 a 为 null。
IndexOutOfBoundsException - 如果 index 值为负或不小于 char 数组的长度。
从以下版本开始：
1.5

codePointAt

public static int codePointAt(char[] a,
                              int index,
                              int limit)
返回 char 数组的给定索引上的代码点，该数组中只有那些具有小于 limit 的 index 值的数组元素可以使用。如果 char 数组中的给定索引上的 char 值在高代理项范围内，则下一个索引小于 limit，如果下一个索引上的 char 值在低代理项范围内，则返回对应于此代理项对的增补代码点。否则，返回给定索引上的 char 值。

参数：
a - char 数组
index - 要转换的 char 数组中的 char 值（Unicode 代码点）的索引
limit - 可以在 char 数组中使用的最后一个数组元素后面的索引
返回：
给定索引上的 Unicode 代码点
抛出：
NullPointerException - 如果 a 为 null。
IndexOutOfBoundsException - 如果 index 参数为负或不小于 limit 参数，或者 limit 参数为负或大于 char 数组的长度。
从以下版本开始：
1.5

codePointBefore

public static int codePointBefore(CharSequence seq,
                                  int index)
返回 CharSequence 的给定索引前面的代码点。如果 CharSequence 中的 (index - 1) 上的 char 值在低代理项范围内，则 (index - 2) 为非负，如果 CharSequence 中的 (index - 2) 上的 char 值在高代理项范围内，则返回对应于此代理项对的增补代码点。否则，返回 (index - 1) 上的 char 值。

参数：
seq - CharSequence 实例
index - 应该返回的代码点后面的索引
返回：
给定索引前面的 Unicode 代码点值。
抛出：
NullPointerException - 如果 seq 为 null。
IndexOutOfBoundsException - 如果 index 参数小于 1 或者大于 seq.length()。
从以下版本开始：
1.5

codePointBefore

public static int codePointBefore(char[] a,
                                  int index)
返回 char 数组的给定索引前面的代码点。如果 char 数组中的 (index - 1) 上的 char 值在低代理项范围内，则 (index - 2) 为非负，如果 char 数组中的 (index - 2) 上的 char 值在高代理项范围内，则返回对应于此代理项对的增补代码点。否则，返回 (index - 1) 上的 char 值。

参数：
a - char 数组
index - 应该返回的代码点后面的索引
返回：
给定索引前面的 Unicode 代码点值。
抛出：
NullPointerException - 如果 a 为 null。
IndexOutOfBoundsException - 如果 index 参数小于 1 或大于 char 数组的长度
从以下版本开始：
1.5

codePointBefore

public static int codePointBefore(char[] a,
                                  int index,
                                  int start)
返回 char 数组的给定索引前面的代码点，该数组中只有那些具有大于等于 start 的 index 值的数组元素可以使用。如果 char 数组中的 (index - 1) 上的 char 值在低代理项范围内，则 (index - 2) 不小于 start，如果 char 数组中的 (index - 2) 上的 char 值在高代理项范围内，则返回对应于此代理项对的增补代码点。否则，返回 (index - 1) 上的 char 值。

参数：
a - char 数组
index - 应该返回的代码点后面的索引
start - char 数组中第一个数组元素的索引
返回：
给定索引前面的 Unicode 代码点。
抛出：
NullPointerException - 如果 a 为 null。
IndexOutOfBoundsException - 如果 index 参数不大于 start 参数或大于 char 数组的长度，或者 start 参数为负或小于 char 数组的长度。
从以下版本开始：
1.5

toChars

public static int toChars(int codePoint,
                          char[] dst,
                          int dstIndex)
将指定字符（Unicode 代码点）转换为其 UTF-16 表示形式。如果指定代码点是一个 BMP（Basic Multilingual Plane 或 Plane 0）值，则在 dst[dstIndex] 中存储相同的值，并返回 1。如果指定代码点是一个增补字符，则将其代理项值存储在 dst[dstIndex]（高代理项）和 dst[dstIndex+1]（低代理项）中，并返回 2。

参数：
codePoint - 要转换的字符（Unicode 代码点）。
dst - char 的一个数组，codePoint 的 UTF-16 值存储在其中。
dstIndex - 进入存储已转换值的 dst 数组中的起始索引。
返回：
如果代码点是一个 BMP 代码点，则返回 1，如果代码点是一个增补代码点，则返回 2。
抛出：
IllegalArgumentException - 如果指定的 codePoint 不是一个有效的 Unicode 代码点。
NullPointerException - 如果指定的 dst 为 null。
IndexOutOfBoundsException - 如果 dstIndex 为负或不小于 dst.length，或者 dstIndex 上的 dst 没有足够多的数组元素来存储得到的 char 值。（如果 dstIndex 等于 dst.length-1 并且指定的 codePoint 是一个增补字符，则不在 dst[dstIndex] 中存储高代理项值。）
从以下版本开始：
1.5

toChars

public static char[] toChars(int codePoint)
将指定的字符（Unicode 代码点）转换成其存储在 char 数组中的 UTF-16 表示形式。如果指定的代码点是一个 BMP（Basic Multilingual Plane 或 Plane 0）值，则得到的 char 数组具有与 codePoint 相同的值。如果指定的代码点是一个增补代码点，则得到的 char 数组具有相应的代理项对。

参数：
codePoint - 一个 Unicode 代码点
返回：
一个具有 codePoint 的 UTF-16 表示形式的 char 数组。
抛出：
IllegalArgumentException - 如果指定的 codePoint 不是一个有效的 Unicode 代码点。
从以下版本开始：
1.5

codePointCount

public static int codePointCount(CharSequence seq,
                                 int beginIndex,
                                 int endIndex)
返回指定字符序列的文本范围内的 Unicode 代码点数量。文本范围始于指定的 beginIndex，并扩展到索引 endIndex - 1 上的 char。因此文本范围的长度（char 形式）为 endIndex-beginIndex。文本范围内的不成对代理项是按一个代码点算作一个项进行计数的。

参数：
seq - 字符序列
beginIndex - 文本范围的第一个 char 的索引。
endIndex - 文本范围的最后一个 char 后面的索引。
返回：
指定文本范围内的 Unicode 代码点的数量
抛出：
NullPointerException - 如果 seq 为 null。
IndexOutOfBoundsException - 如果 beginIndex 为负，或者 endIndex 大于给定序列的长度，或者 beginIndex 大于 endIndex。
从以下版本开始：
1.5

codePointCount

public static int codePointCount(char[] a,
                                 int offset,
                                 int count)
返回 char 数组参数的子数组中 Unicode 代码点的数量。offset 参数是子数组的第一个 char 的索引，count 参数指定了 char 中的子数组的长度。子数组中不成对的代理项是按一个代码点算作一个项进行计数的。

参数：
a - char 数组
offset - 给定 char 数组中第一个 char 的索引
count - char 中的子数组的长度
返回：
指定子数组中 Unicode 代码点的数量
抛出：
NullPointerException - 如果 a 为 null。
IndexOutOfBoundsException - 如果 offset 或 count 为负，或者 offset + count 大于给定数组的长度。
从以下版本开始：
1.5

offsetByCodePoints

public static int offsetByCodePoints(CharSequence seq,
                                     int index,
                                     int codePointOffset)
返回给定字符序列中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。index 和 codePointOffset 给出的文本范围内的不成对代理项是按一个代码点算作一个项进行计数的。

参数：
seq - 字符序列
index - 要偏移的索引
codePointOffset - 代码点中的偏移量
返回：
字符序列内的索引
抛出：
NullPointerException - 如果 seq 为 null。
IndexOutOfBoundsException - 如果 index 为负或大于字符序列的长度，或者 codePointOffset 为负并且起始于 index 的子序列拥有的偏移量少于 codePointOffset 代码点，或者 codePointOffset 为负并且 index 前面的子序列的偏移量少于 codePointOffset 代码点的绝对值。
从以下版本开始：
1.5

offsetByCodePoints

public static int offsetByCodePoints(char[] a,
                                     int start,
                                     int count,
                                     int index,
                                     int codePointOffset)
返回给定 char 子数组中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。start 和 count 参数指定了 char 数组的一个子数组。index 和 codePointOffset 给出的文本范围内的不成对代理项是按一个代码点算作一个项进行计数的。

参数：
a - char 数组
start - 子数组的第一个 char 的索引
count - char 中的子数组的长度
index - 要偏移的索引
codePointOffset - 代码点中的偏移量
返回：
子数组内的索引
抛出：
NullPointerException - 如果 a 为 null。
IndexOutOfBoundsException - 如果存在以下情况：start 或 count 为负；start + count 大于给定数组的长度；index 小于 start 或大于 start + count；codePointOffset 为负并且起始于 index、终止于 start + count - 1 的文本字段的偏移量少于 codePointOffset 代码点；codePointOffset 为负并且起始于 start、终止于 index - 1 的文本字段的偏移量少于 codePointOffset 代码点的绝对值。
从以下版本开始：
1.5

isLowerCase

public static boolean isLowerCase(char ch)
确定指定字符是否为小写字母。

如果通过 Character.getType(ch) 提供的字符的常规类别类型为 LOWERCASE_LETTER，则字符为小写字母。

以下是小写字母的示例：

 a b c d e f g h i j k l m n o p q r s t u v w x y z
 '\u00DF' '\u00E0' '\u00E1' '\u00E2' '\u00E3' '\u00E4' '\u00E5' '\u00E6'
 '\u00E7' '\u00E8' '\u00E9' '\u00EA' '\u00EB' '\u00EC' '\u00ED' '\u00EE'
 '\u00EF' '\u00F0' '\u00F1' '\u00F2' '\u00F3' '\u00F4' '\u00F5' '\u00F6'
 '\u00F8' '\u00F9' '\u00FA' '\u00FB' '\u00FC' '\u00FD' '\u00FE' '\u00FF'

其他许多 Unicode 字符也是小写的。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isLowerCase(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为小写，则返回 true；否则返回 false。
另请参见：
isLowerCase(char), isTitleCase(char), toLowerCase(char), getType(char)

isLowerCase

public static boolean isLowerCase(int codePoint)
确定指定字符（Unicode 代码点）是否为小写字母。

如果通过 getType(codePoint) 提供的字符的常规类别的类型为 LOWERCASE_LETTER，则字符为小写字母。

以下是小写字母的示例：

 a b c d e f g h i j k l m n o p q r s t u v w x y z
 '\u00DF' '\u00E0' '\u00E1' '\u00E2' '\u00E3' '\u00E4' '\u00E5' '\u00E6'
 '\u00E7' '\u00E8' '\u00E9' '\u00EA' '\u00EB' '\u00EC' '\u00ED' '\u00EE'
 '\u00EF' '\u00F0' '\u00F1' '\u00F2' '\u00F3' '\u00F4' '\u00F5' '\u00F6'
 '\u00F8' '\u00F9' '\u00FA' '\u00FB' '\u00FC' '\u00FD' '\u00FE' '\u00FF'

其他许多 Unicode 字符也是小写的。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为小写，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isLowerCase(int), isTitleCase(int), toLowerCase(int), getType(int)

isUpperCase

public static boolean isUpperCase(char ch)
确定指定字符是否为大写字母。

如果通过 Character.getType(ch) 提供的字符的常规类别类型为 UPPERCASE_LETTER，则字符为大写字母。

以下是大写字母的示例：

 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
 '\u00C0' '\u00C1' '\u00C2' '\u00C3' '\u00C4' '\u00C5' '\u00C6' '\u00C7'
 '\u00C8' '\u00C9' '\u00CA' '\u00CB' '\u00CC' '\u00CD' '\u00CE' '\u00CF'
 '\u00D0' '\u00D1' '\u00D2' '\u00D3' '\u00D4' '\u00D5' '\u00D6' '\u00D8'
 '\u00D9' '\u00DA' '\u00DB' '\u00DC' '\u00DD' '\u00DE'

其他许多 Unicode 字符也是大写的。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isUpperCase(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为大写，则返回 true；否则返回 false。
从以下版本开始：
1.0
另请参见：
isLowerCase(char), isTitleCase(char), toUpperCase(char), getType(char)

isUpperCase

public static boolean isUpperCase(int codePoint)
确定指定字符（Unicode 代码点）是否为大写字母。

如果通过 getType(codePoint) 提供的字符的常规类别类型为 UPPERCASE_LETTER，则字符为大写字母。

以下是大写字母的示例：

 A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
 '\u00C0' '\u00C1' '\u00C2' '\u00C3' '\u00C4' '\u00C5' '\u00C6' '\u00C7'
 '\u00C8' '\u00C9' '\u00CA' '\u00CB' '\u00CC' '\u00CD' '\u00CE' '\u00CF'
 '\u00D0' '\u00D1' '\u00D2' '\u00D3' '\u00D4' '\u00D5' '\u00D6' '\u00D8'
 '\u00D9' '\u00DA' '\u00DB' '\u00DC' '\u00DD' '\u00DE'

其他许多 Unicode 字符也是大写的。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为大写，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isLowerCase(int), isTitleCase(int), toUpperCase(int), getType(int)

isTitleCase

public static boolean isTitleCase(char ch)
确定指定字符是否为首字母大写字符。

如果通过 Character.getType(ch) 提供的字符的常规类别类型为 TITLECASE_LETTER，则字符为首字母大写字符。

一些字符看似成对的 Latin 字母。例如，有一个看起来像“LJ”的大写字母和一个看起来像“lj”的对应小写字母。第三种形式看起来像“Lj”，这是呈现首字母大写的小写单词时使用的适当形式，比如用于书籍的标题。

下面是一些可以让该方法返回 true 的 Unicode 字符：

  • LATIN CAPITAL LETTER D WITH SMALL LETTER Z WITH CARON
  • LATIN CAPITAL LETTER L WITH SMALL LETTER J
  • LATIN CAPITAL LETTER N WITH SMALL LETTER J
  • LATIN CAPITAL LETTER D WITH SMALL LETTER Z

其他许多 Unicode 字符也是首字母大写的。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isTitleCase(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为首字母大写，则返回 true；否则返回 false。
从以下版本开始：
1.0.2
另请参见：
isLowerCase(char), isUpperCase(char), toTitleCase(char), getType(char)

isTitleCase

public static boolean isTitleCase(int codePoint)
确定指定字符（Unicode 代码点）是否为首字母大写字符。

如果通过 getType(codePoint) 提供的字符的常规类别类型为 TITLECASE_LETTER，则字符为首字母大写字符。

一些字符看似成对的 Latin 字母。例如，有一个看起来像“LJ”的大写字母和一个看起来像“lj”的对应小写字母。第三种形式看起来像“Lj”，这是呈现首字母大写的小写单词时使用的适当形式，比如用于书籍的标题。

下面是一些可以让该方法返回 true 的 Unicode 字符：

  • LATIN CAPITAL LETTER D WITH SMALL LETTER Z WITH CARON
  • LATIN CAPITAL LETTER L WITH SMALL LETTER J
  • LATIN CAPITAL LETTER N WITH SMALL LETTER J
  • LATIN CAPITAL LETTER D WITH SMALL LETTER Z

其他许多 Unicode 字符也是首字母大写的。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为首字母大写，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isLowerCase(int), isUpperCase(int), toTitleCase(int), getType(int)

isDigit

public static boolean isDigit(char ch)
确定指定字符是否为数字。

如果通过 Character.getType(ch) 提供的字符的常规类别类型为 DECIMAL_DIGIT_NUMBER，则字符为数字。

包含数字的 Unicode 字符范围：

  • '\u0030' 到 '\u0039'，ISO-LATIN-1 数字（'0' 到 '9'）
  • '\u0660' 到 '\u0669'，Arabic-Indic 数字
  • '\u06F0' 到 '\u06F9'，扩展了的 Arabic-Indic 数字
  • '\u0966' 到 '\u096F'，梵文数字
  • '\uFF10' 到 '\uFF19'，全形数字
其他许多字符范围也包含数字。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isDigit(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为数字，则返回 true；否则返回 false。
另请参见：
digit(char, int),
forDigit(int, int),
getType(char)

isDigit

public static boolean isDigit(int codePoint)
确定指定字符（Unicode 代码点）是否为数字。

如果通过 getType(codePoint) 提供的字符的常规类别类型为 DECIMAL_DIGIT_NUMBER，则字符为数字。

包含数字的 Unicode 字符范围：

  • '\u0030' 到 '\u0039'，ISO-LATIN-1 数字（'0' 到 '9'）
  • '\u0660' 到 '\u0669'，Arabic-Indic 数字
  • '\u06F0' 到 '\u06F9'，扩展了的 Arabic-Indic 数字
  • '\u0966' 到 '\u096F'，梵文数字
  • '\uFF10' 到 '\uFF19'，全形数字
其他许多字符范围也包含数字。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为数字，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
forDigit(int, int), getType(int)

isDefined

public static boolean isDefined(char ch)
确定字符是否被定义为 Unicode 中的字符。

如果以下条件中至少有一个为真，则字符被定义为 Unicode 中的字符：

  • 它具有 UnicodeData 文件中的条目。
  • 它具有 UnicodeData 文件定义的范围中的值。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isDefined(int) 方法。

参数：
ch - 要测试的字符
返回：
如果字符具有为 Unicode 中字符定义的含义，则返回 true；否则返回 false。
从以下版本开始：
1.0.2
另请参见：
isDigit(char), isLetter(char), isLetterOrDigit(char), isLowerCase(char), isTitleCase(char), isUpperCase(char)

isDefined

public static boolean isDefined(int codePoint)
确定字符（Unicode 代码点）是否被定义为 Unicode 中的字符。

如果以下条件中至少有一个为真，则字符被定义为 Unicode 中的字符：

  • 它具有 UnicodeData 文件中的条目。
  • 它具有 UnicodeData 文件定义的范围中的值。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符具有为 Unicode 中字符定义的含义，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isDigit(int), isLetter(int), isLetterOrDigit(int), isLowerCase(int), isTitleCase(int), isUpperCase(int)

isLetter

public static boolean isLetter(char ch)
确定指定字符是否为字母。

如果通过 Character.getType(ch) 为字符提供的常规类别的类型为以下类型中的任意一种，则认为该字符为字母：

  • UPPERCASE_LETTER
  • LOWERCASE_LETTER
  • TITLECASE_LETTER
  • MODIFIER_LETTER
  • OTHER_LETTER
并非所有的字母都有大小写。许多字符都是字母，但它们既不是大写的，也不是小写的，并且也不是首字母大写的。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isLetter(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为字母，则返回 true；否则返回 false。
另请参见：
isDigit(char), isJavaIdentifierStart(char), isJavaLetter(char), isJavaLetterOrDigit(char), isLetterOrDigit(char), isLowerCase(char), isTitleCase(char), isUnicodeIdentifierStart(char), isUpperCase(char)

isLetter

public static boolean isLetter(int codePoint)
确定指定字符（Unicode 代码点）是否为字母。

如果通过 getType(codePoint) 为字符提供的常规类别的类型为以下类型中的任意一种，则认为该字符为字母：

  • UPPERCASE_LETTER
  • LOWERCASE_LETTER
  • TITLECASE_LETTER
  • MODIFIER_LETTER
  • OTHER_LETTER
并非所有的字母都有大小写。许多字符都是字母，但它们既不是大写的，也不是小写的，并且也不是首字母大写的。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为字母，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isDigit(int), isJavaIdentifierStart(int), isLetterOrDigit(int), isLowerCase(int), isTitleCase(int), isUnicodeIdentifierStart(int), isUpperCase(int)

isLetterOrDigit

public static boolean isLetterOrDigit(char ch)
确定指定字符是否为字母或数字。

如果 Character.isLetter(char ch) 或 Character.isDigit(char ch) 对字符返回的是 true，则认为字符是一个字母或数字。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isLetterOrDigit(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为字符或数字，则返回 true；否则返回 false。
从以下版本开始：
1.0.2
另请参见：
isDigit(char), isJavaIdentifierPart(char), isJavaLetter(char), isJavaLetterOrDigit(char), isLetter(char), isUnicodeIdentifierPart(char)

isLetterOrDigit

public static boolean isLetterOrDigit(int codePoint)
确定指定字符（Unicode 代码点）是否为字母或数字。

如果 isLetter(codePoint) 或 isDigit(codePoint) 对字符返回的是 true，则认为字符是一个字母或数字。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为字符或数字，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isDigit(int), isJavaIdentifierPart(int), isLetter(int), isUnicodeIdentifierPart(int)

isJavaLetter

@Deprecated
public static boolean isJavaLetter(char ch)
已过时。 由 isJavaIdentifierStart(char) 取代。

确定是否允许将指定字符作为 Java 标识符中的首字符。

当且仅当以下条件之一为真时，字符才可以作为 Java 标识符的首字母：

  • isLetter(ch) 返回 true
  • getType(ch) 返回 LETTER_NUMBER
  • ch 是一个货币符号（如“$”）
  • ch 是一个连字符（如“_”）。

参数：
ch - 要测试的字符。
返回：
如果字符为 Java 标识符的首字符，则返回 true；否则返回 false。
从以下版本开始：
1.02
另请参见：
isJavaLetterOrDigit(char), isJavaIdentifierStart(char), isJavaIdentifierPart(char), isLetter(char), isLetterOrDigit(char), isUnicodeIdentifierStart(char)

isJavaLetterOrDigit

@Deprecated
public static boolean isJavaLetterOrDigit(char ch)
已过时。 由 isJavaIdentifierPart(char) 取代。

确定指定字符是否可以是 Java 标识符中首字符以外的部分。

当且仅当以下任何条件为真时，字符才可能是 Java 标识符的一部分：

  • 是一个字母
  • 是一个货币符号（如 '$'）
  • 是一个连字符（如 '_'）。
  • 是一个数字
  • 是一个数字字母（如罗马数字字符）
  • 是个合成标记
  • 是一个非空格标记
  • isIdentifierIgnorable 对字符返回的是 true。

参数：
ch - 要测试的字符。
返回：
如果字符可以为 Java 标识符的一部分，则返回 true；否则返回 false。
从以下版本开始：
1.02
另请参见：
isJavaLetter(char), isJavaIdentifierStart(char), isJavaIdentifierPart(char), isLetter(char), isLetterOrDigit(char), isUnicodeIdentifierPart(char), isIdentifierIgnorable(char)

isJavaIdentifierStart

public static boolean isJavaIdentifierStart(char ch)
确定是否允许将指定字符作为 Java 标识符中的首字符。

当且仅当以下条件之一为真时，字符才可以作为 Java 标识符的首字符：

  • isLetter(ch) 返回 true
  • getType(ch) 返回 LETTER_NUMBER
  • ch 是一个货币符号（如“$”）
  • ch 是一个连字符（如“_”）。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isJavaIdentifierStart(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为 Java 标识符的首字符，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isJavaIdentifierPart(char), isLetter(char), isUnicodeIdentifierStart(char), SourceVersion.isIdentifier(CharSequence)

isJavaIdentifierStart

public static boolean isJavaIdentifierStart(int codePoint)
确定是否允许将字符（Unicode 代码点）作为 Java 标识符中的首字符。

当且仅当以下条件之一为真时，字符才可以作为 Java 标识符的首字符：

  • isLetter(codePoint) 返回 true
  • getType(codePoint) 返回 LETTER_NUMBER
  • 引用的字符是一个货币符号（如“$”）
  • 引用的字符是一个连字符（如“_”）。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为 Java 标识符的首字符，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isJavaIdentifierPart(int), isLetter(int), isUnicodeIdentifierStart(int), SourceVersion.isIdentifier(CharSequence)

isJavaIdentifierPart

public static boolean isJavaIdentifierPart(char ch)
确定指定字符是否可以是 Java 标识符中首字符以外的部分。

如果以下任何条件为真，那么字符可能是 Java 标识符的一部分：

  • 是一个字母
  • 是一个货币符号（如 '$'）
  • 是一个连字符（如 '_'）。
  • 是一个数字
  • 是一个数字字母（如罗马数字字符）
  • 是个合成标记
  • 是一个非空格标记
  • isIdentifierIgnorable 对字符返回的是 true

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isJavaIdentifierPart(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符可以为 Java 标识符的一部分，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isIdentifierIgnorable(char), isJavaIdentifierStart(char), isLetterOrDigit(char), isUnicodeIdentifierPart(char), SourceVersion.isIdentifier(CharSequence)

isJavaIdentifierPart

public static boolean isJavaIdentifierPart(int codePoint)
确定字符（Unicode 代码点）是否可以是 Java 标识符中首字符以外的部分。

如果以下任何条件为真，那么字符可能是 Java 标识符的一部分：

  • 是一个字母
  • 是一个货币符号（如 '$'）
  • 是一个连字符（如 '_'）。
  • 是一个数字
  • 是一个数字字母（如罗马数字字符）
  • 是个合成标记
  • 是一个非空格标记
  • isIdentifierIgnorable(codePoint) 对字符返回的是 true

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符可以为 Java 标识符的一部分，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isIdentifierIgnorable(int), isJavaIdentifierStart(int), isLetterOrDigit(int), isUnicodeIdentifierPart(int), SourceVersion.isIdentifier(CharSequence)

isUnicodeIdentifierStart

public static boolean isUnicodeIdentifierStart(char ch)
确定是否允许将指定字符作为 Unicode 标识符中的首字符。

当且仅当以下条件之一为真时，字符才可以作为 Unicode 标识符的首字符：

  • isLetter(ch) 返回 true
  • getType(ch) 返回 LETTER_NUMBER。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isUnicodeIdentifierStart(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符可以作为 Unicode 标识符的首字符，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isJavaIdentifierStart(char), isLetter(char), isUnicodeIdentifierPart(char)

isUnicodeIdentifierStart

public static boolean isUnicodeIdentifierStart(int codePoint)
确定是否允许将指定字符（Unicode 代码点）作为 Unicode 标识符中的首字符。

当且仅当以下条件之一为真时，字符才可以作为 Unicode 标识符的首字符：

  • isLetter(codePoint) 返回 true
  • getType(codePoint) 返回 LETTER_NUMBER。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符可以作为 Unicode 标识符的首字符，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isJavaIdentifierStart(int), isLetter(int), isUnicodeIdentifierPart(int)

isUnicodeIdentifierPart

public static boolean isUnicodeIdentifierPart(char ch)
确定指定字符是否可以是 Unicode 标识符中首字符以外的部分。

当且仅当以下语句之一为真时，字符才可能是 Unicode 标识符的一部分：

  • 是一个字母
  • 是一个连字符（如 '_'）。
  • 是一个数字
  • 是一个数字字母（如罗马数字字符）
  • 是个合成标记
  • 是一个非空格标记
  • isIdentifierIgnorable 对该字符返回的是 true。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isUnicodeIdentifierPart(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符可以为 Unicode 标识符的一部分，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isIdentifierIgnorable(char), isJavaIdentifierPart(char), isLetterOrDigit(char), isUnicodeIdentifierStart(char)

isUnicodeIdentifierPart

public static boolean isUnicodeIdentifierPart(int codePoint)
确定指定字符（Unicode 代码点）是否可以是 Unicode 标识符中首字符以外的部分。

当且仅当以下语句之一为真时，字符才可能是 Unicode 标识符的一部分：

  • 是一个字母
  • 是一个连字符（如 '_'）。
  • 是一个数字
  • 是一个数字字母（如罗马数字字符）
  • 是个合成标记
  • 是一个非空格标记
  • isIdentifierIgnorable 对该字符返回的是 true。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符可以为 Unicode 标识符的一部分，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isIdentifierIgnorable(int), isJavaIdentifierPart(int), isLetterOrDigit(int), isUnicodeIdentifierStart(int)

isIdentifierIgnorable

public static boolean isIdentifierIgnorable(char ch)
确定是否应该认为指定字符是 Java 标识符或 Unicode 标识符中可忽略的一个字符。

以下 Unicode 字符是 Java 标识符或 Unicode 标识符中可忽略的字符：

  • 非空白的 ISO 控制字符
    • '\u0000' 到 '\u0008'
    • '\u000E' 到 '\u001B'
    • '\u007F' 到 '\u009F'
  • 拥有 FORMAT 常规类别值的所有字符

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isIdentifierIgnorable(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符是可以成为 Java 或 Unicode 标识符的一部分的可忽略控制字符，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isJavaIdentifierPart(char), isUnicodeIdentifierPart(char)

isIdentifierIgnorable

public static boolean isIdentifierIgnorable(int codePoint)
确定是否应该认为指定字符（Unicode 代码点）是 Java 标识符或 Unicode 标识符中可忽略的一个字符。

以下 Unicode 字符是 Java 标识符或 Unicode 标识符中可忽略的字符：

  • 非空白的 ISO 控制字符
    • '\u0000' 到 '\u0008'
    • '\u000E' 到 '\u001B'
    • '\u007F' 到 '\u009F'
  • 拥有 FORMAT 常规类别值的所有字符

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符是可以成为 Java 或 Unicode 标识符的一部分的可忽略控制字符，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isJavaIdentifierPart(int), isUnicodeIdentifierPart(int)

toLowerCase

public static char toLowerCase(char ch)
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为小写。

注意，对于某些范围内的字符，特别是那些是符号或表意符号的字符，Character.isLowerCase(Character.toLowerCase(ch)) 并不总是返回 true。

通常，应该使用 String.toLowerCase() 将字符映射为小写。String 大小写映射方法有几个胜过 Character 大小写映射方法的优点。String 大小写映射方法可以执行语言环境敏感的映射、上下文相关的映射和 1:M 字符映射，而 Character 大小写映射方法却不能。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 toLowerCase(int) 方法。

参数：
ch - 要转换的字符。
返回：
等效于字符的小写形式，如果有的话；否则返回字符本身。
另请参见：
isLowerCase(char), String.toLowerCase()

toLowerCase

public static int toLowerCase(int codePoint)
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为小写。

注意，对于某些范围内的字符，特别是那些是符号或表意符号的字符，Character.isLowerCase(Character.toLowerCase(codePoint)) 并不总是返回 true。

通常，应该使用 String.toLowerCase() 将字符映射为小写。String 大小写映射方法有几个胜过 Character 大小写映射方法的优点。String 大小写映射方法可以执行语言环境敏感的映射、上下文相关的映射和 1:M 字符映射，而 Character 大小写映射方法却不能。

参数：
codePoint - 要转换的字符（Unicode 代码点）。
返回：
等效于字符（Unicode 代码点）的小写形式，如果有的话；否则返回字符本身。
从以下版本开始：
1.5
另请参见：
isLowerCase(int), String.toLowerCase()

toUpperCase

public static char toUpperCase(char ch)
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为大写。

注意，对于某些范围内的字符，特别是那些是符号或表意符号的字符，Character.isUpperCase(Character.toUpperCase(ch)) 并不总是返回 true。

通常，应该使用 String.toUpperCase() 将字符映射为大写。String 大小写映射方法有几个胜过 Character 大小写映射方法的优点。String 大小写映射方法可以执行语言环境敏感的映射、上下文相关的映射和 1:M 字符映射，而 Character 大小写映射方法却不能。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 toUpperCase(int) 方法。

参数：
ch - 要转换的字符。
返回：
等效于字符的大写形式，如果有的话；否则返回字符本身。
另请参见：
isUpperCase(char), String.toUpperCase()

toUpperCase

public static int toUpperCase(int codePoint)
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为大写。

注意，对于某些范围内的字符，特别是那些是符号或表意符号的字符，Character.isUpperCase(Character.toUpperCase(codePoint)) 并不总是返回 true。

通常，应该使用 String.toUpperCase() 将字符映射为大写。String 大小写映射方法有几个胜过 Character 大小写映射方法的优点。String 大小写映射方法可以执行语言环境敏感的映射、上下文相关的映射和 1:M 字符映射，而 Character 大小写映射方法却不能。

参数：
codePoint - 要转换的字符（Unicode 代码点）。
返回：
等效于字符的大写形式，如果有的话；否则返回字符本身。
从以下版本开始：
1.5
另请参见：
isUpperCase(int), String.toUpperCase()

toTitleCase

public static char toTitleCase(char ch)
使用取自 UnicodeData 文件的大小写映射信息将字符参数转换为首字母大写。如果字符没有明确的首字母大写映射，并且根据 UnicodeData，它本身并不是一个首字母大写的 char，则返回大写映射作为等效的首字母大写映射。如果 char 参数总是一个首字母大写的 char，则返回相同的 char 值。

注意，对于某些范围内的字符，Character.isTitleCase(Character.toTitleCase(ch)) 并不总是返回 true。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 toTitleCase(int) 方法。

参数：
ch - 要转换的字符。
返回：
如果有的话，则返回等效于字符的首字母大写形式；否则返回字符本身。
从以下版本开始：
1.0.2
另请参见：
isTitleCase(char), toLowerCase(char), toUpperCase(char)

toTitleCase

public static int toTitleCase(int codePoint)
使用取自 UnicodeData 文件的大小写映射信息将字符（Unicode 代码点）参数转换为首字母大写。如果字符没有明确的首字母大写映射，并且根据 UnicodeData，它本身并不是一个首字母大写的 char，则返回大写映射作为等效的首字母大写映射。如果字符参数总是一个首字母大写的字符，则返回相同的字符值。

注意，对于某些范围内的字符，Character.isTitleCase(Character.toTitleCase(codePoint)) 并不总是返回 true。

参数：
codePoint - 要转换的字符（Unicode 代码点）。
返回：
如果有的话，则返回等效于字符的首字母大写形式；否则返回字符本身。
从以下版本开始：
1.5
另请参见：
isTitleCase(int), toLowerCase(int), toUpperCase(int)

digit

public static int digit(char ch,
                        int radix)
返回使用指定基数的字符 ch 的数值。

如果基数不在 MIN_RADIX <= radix <= MAX_RADIX 范围之内，或者 ch 的值是一个使用指定基数的无效数字，则返回 -1。如果以下条件中至少有一个为真，则字符是一个有效数字：

  • 方法 isDigit 为 true，且字符（或分解的单字符）的 Unicode 十进制数值小于指定的基数。在这种情况下，返回十进制数值。
  • 字符为 'A' 到 'Z' 范围内的大写拉丁字母之一，且它的代码小于 radix + 'A' - 10。在这种情况下，返回 ch - 'A' + 10。
  • 字符为 'a' 到 'z' 范围内的小写拉丁字母之一，且它的代码小于 radix + 'a' - 10。在这种情况下，返回 ch - 'a' + 10。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 digit(int, int) 方法。

参数：
ch - 要转换的字符。
radix - 基数。
返回：
使用指定基数的字符所表示的数值。
另请参见：
forDigit(int, int), isDigit(char)

digit

public static int digit(int codePoint,
                        int radix)
返回使用指定基数的指定字符（Unicode 代码点）的数值。

如果基数不在 MIN_RADIX <= radix <= MAX_RADIX 范围之内，或者字符是一个使用指定基数的无效数字，则返回 -1。如果以下条件中至少有一个为真，则字符是一个有效数字：

  • 方法 isDigit(codePoint) 为 true，且字符（或分解的单字符）的 Unicode 十进制数值小于指定的基数。在这种情况下，返回十进制数值。
  • 字符为 'A' 到 'Z' 范围内的大写拉丁字母之一，且它的代码小于 radix + 'A' - 10。在这种情况下，返回 ch - 'A' + 10。
  • 字符为 'a' 到 'z' 范围内的小写拉丁字母之一，且它的代码小于 radix + 'a' - 10。在这种情况下，返回 ch - 'a' + 10。

参数：
codePoint - 要转换的字符（Unicode 代码点）。
radix - 基数。
返回：
使用指定基数的字符所表示的数值。
从以下版本开始：
1.5
另请参见：
forDigit(int, int), isDigit(int)

getNumericValue

public static int getNumericValue(char ch)
返回指定的 Unicode 字符表示的 int 值。例如，字符 '\u216C'（罗马数字 50）将返回一个值为 50 的整数。

字母 A-Z 的大写（'\u0041' 到 '\u005A'）、小写（'\u0061' 到 '\u007A'）和全形参数（'\uFF21' 到 '\uFF3A' 和 '\uFF41' 到 '\uFF5A'）形式拥有从 10 到 35 的数值。这独立于 Unicode 规范，该规范没有为这些 char 值分配数值。

如果字符中没有数值，则返回 -1。如果字符中有一个数值，但无法将它表示为非负整数（例如，小数值），则返回 -2。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 getNumericValue(int) 方法。

参数：
ch - 要转换的字符。
返回：
以非负 int 值形式返回字符的数值；如果字符中有一个不是非负整数的数值，则返回 -2；如果字符中没有数值，则返回 -1。
从以下版本开始：
1.1
另请参见：
forDigit(int, int), isDigit(char)

getNumericValue

public static int getNumericValue(int codePoint)
返回指定字符（Unicode 代码点）表示的 int 值。例如，字符 '\u216C'（罗马数字 50）将返回一个值为 50 的 int 值。

字母 A-Z 的大写（'\u0041' 到 '\u005A'）、小写（'\u0061' 到 '\u007A'）和全形参数（'\uFF21' 到 '\uFF3A' 和 '\uFF41' 到 '\uFF5A'）形式拥有从 10 到 35 的数值。这独立于 Unicode 规范，该规范没有为这些 char 值分配数值。

如果字符中没有数字值，则返回 -1。如果字符中有一个数值，但无法将它表示为非负整数（例如，小数值），则返回 -2。

参数：
codePoint - 要转换的字符（Unicode 代码点）。
返回：
以非负 int 值形式返回字符的数值；如果字符中有一个不是非负整数的数值，则返回 -2；如果字符中没有数值，则返回 -1。
从以下版本开始：
1.5
另请参见：
forDigit(int, int), isDigit(int)

isSpace

@Deprecated
public static boolean isSpace(char ch)
已过时。 由 isWhitespace(char) 取代。

确定指定字符是否为 ISO-LATIN-1 空白。该方法只对以下五个字符返回 true：
'\t' | '\u0009' | HORIZONTAL TABULATION
'\n' | '\u000A' | NEW LINE
'\f' | '\u000C' | FORM FEED
'\r' | '\u000D' | CARRIAGE RETURN
' ' '\u0020' SPACE

参数：
ch - 要测试的字符。
返回：
如果字符为 ISO-LATIN-1 空白，则返回 true；否则返回 false。
另请参见：
isSpaceChar(char), isWhitespace(char)

isSpaceChar

public static boolean isSpaceChar(char ch)
确定指定字符是否为 Unicode 空白字符。当且仅当根据 Unicode 标准将字符指定为空白字符时，才认为字符是一个空白字符。如果字符的常规类别的类型为以下类型中的任意一种，则该方法返回 true：
  • SPACE_SEPARATOR
  • LINE_SEPARATOR
  • PARAGRAPH_SEPARATOR

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isSpaceChar(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为空白字符，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isWhitespace(char)

isSpaceChar

public static boolean isSpaceChar(int codePoint)
确定指定字符（Unicode 代码点）是否为 Unicode 空白字符。当且仅当根据 Unicode 标准将字符指定为空白字符时，才认为字符是一个空白字符。如果字符的常规类别的类型为以下类型中的任意一种，则该方法返回 true：
  • SPACE_SEPARATOR
  • LINE_SEPARATOR
  • PARAGRAPH_SEPARATOR

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为空白字符，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isWhitespace(int)

isWhitespace

public static boolean isWhitespace(char ch)
确定指定字符依据 Java 标准是否为空白字符。当且仅当字符满足以下标准时，该字符才是一个 Java 空白字符：
  • 它是 Unicode 空格字符（SPACE_SEPARATOR、LINE_SEPARATOR 或 PARAGRAPH_SEPARATOR)，但不是非中断空格（'\u00A0'、'\u2007'、'\u202F'）
  • 它是 '\u0009'，HORIZONTAL TABULATION
  • 它是 '\u000A'，LINE FEED
  • 它是 '\u000B'，VERTICAL TABULATION
  • 它是 '\u000C'，FORM FEED
  • 它是 '\u000D'，CARRIAGE RETURN
  • 它是 '\u001C'，FILE SEPARATOR
  • 它是 '\u001D'，GROUP SEPARATOR
  • 它是 '\u001E'，RECORD SEPARATOR
  • 它是 '\u001F'，UNIT SEPARATOR

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isWhitespace(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为 Java 空白字符，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isSpaceChar(char)

isWhitespace

public static boolean isWhitespace(int codePoint)
确定指定字符（Unicode 代码点）依据 Java 标准是否为空白字符。当且仅当字符满足以下标准时，该字符才是一个 Java 空白字符：
  • 它是一个 Unicode 空白字符（SPACE_SEPARATOR、LINE_SEPARATOR 或 PARAGRAPH_SEPARATOR），但不是一个不间断空格（'\u00A0'、'\u2007' 和 '\u202F'）。
  • '\u0009'，水平制表符。
  • '\u000A'，换行。
  • '\u000B'，纵向制表符。
  • '\u000C'，换页。
  • '\u000D'，回车。
  • '\u001C'，文件分隔符。
  • '\u001D'，组分隔符。
  • '\u001E'，记录分隔符。
  • '\u001F'，单元分隔符。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为 Java 空白字符，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isSpaceChar(int)

isISOControl

public static boolean isISOControl(char ch)
确定指定字符是否为 ISO 控制字符。如果字符的代码在从 '\u0000' 到 '\u001F' 或从 '\u007F' 到 '\u009F' 的范围内，则认为该字符是一个 ISO 控制字符。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isISOControl(int) 方法。

参数：
ch - 要测试的字符。
返回：
如果字符为 ISO 控制字符，则返回 true；否则返回 false。
从以下版本开始：
1.1
另请参见：
isSpaceChar(char), isWhitespace(char)

isISOControl

public static boolean isISOControl(int codePoint)
确定引用的字符（Unicode 代码点）是否为 ISO 控制字符。如果字符的代码在从 '\u0000' 到 '\u001F' 或从 '\u007F' 到 '\u009F' 的范围内，则认为该字符是一个 ISO 控制字符。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符为 ISO 控制字符，则返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
isSpaceChar(int), isWhitespace(int)

getType

public static int getType(char ch)
返回一个指示字符的常规类别的值。

注： 此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 getType(int) 方法。

参数：
ch - 要测试的字符。
返回：
表示字符的常规类别的 int 类型的值。
从以下版本开始：
1.1
另请参见：
COMBINING_SPACING_MARK, CONNECTOR_PUNCTUATION, CONTROL, CURRENCY_SYMBOL, DASH_PUNCTUATION, DECIMAL_DIGIT_NUMBER, ENCLOSING_MARK, END_PUNCTUATION, FINAL_QUOTE_PUNCTUATION, FORMAT, INITIAL_QUOTE_PUNCTUATION, LETTER_NUMBER, LINE_SEPARATOR, LOWERCASE_LETTER, MATH_SYMBOL, MODIFIER_LETTER, MODIFIER_SYMBOL, NON_SPACING_MARK, OTHER_LETTER, OTHER_NUMBER, OTHER_PUNCTUATION, OTHER_SYMBOL, PARAGRAPH_SEPARATOR, PRIVATE_USE, SPACE_SEPARATOR, START_PUNCTUATION, SURROGATE, TITLECASE_LETTER, UNASSIGNED, UPPERCASE_LETTER

getType

public static int getType(int codePoint)
返回一个指示字符的常规类别的值。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
表示字符的常规类别的 int 类型的值。
从以下版本开始：
1.5
另请参见：
COMBINING_SPACING_MARK, CONNECTOR_PUNCTUATION, CONTROL, CURRENCY_SYMBOL, DASH_PUNCTUATION, DECIMAL_DIGIT_NUMBER, ENCLOSING_MARK, END_PUNCTUATION, FINAL_QUOTE_PUNCTUATION, FORMAT, INITIAL_QUOTE_PUNCTUATION, LETTER_NUMBER, LINE_SEPARATOR, LOWERCASE_LETTER, MATH_SYMBOL, MODIFIER_LETTER, MODIFIER_SYMBOL, NON_SPACING_MARK, OTHER_LETTER, OTHER_NUMBER, OTHER_PUNCTUATION, OTHER_SYMBOL, PARAGRAPH_SEPARATOR, PRIVATE_USE, SPACE_SEPARATOR, START_PUNCTUATION, SURROGATE, TITLECASE_LETTER, UNASSIGNED, UPPERCASE_LETTER

forDigit

public static char forDigit(int digit,
                            int radix)
确定使用指定基数的特定数字的字符表示形式。如果 radix 的值不是一个有效基数，或者 digit 的值不是一个使用指定基数的有效数字，则返回 null 字符（'\u0000'）。

如果 radix 参数大于等于 MIN_RADIX 并且小于等于 MAX_RADIX，则该参数是有效的。如果 0 <=digit < radix，则 digit 参数是有效的。

如果数字小于 10，则返回 '0' + digit。否则，返回的值为 'a' + digit - 10。

参数：
digit - 转换为字符的数字。
radix - 基数。
返回：
使用指定基数的指定数字的 char 表示形式。
另请参见：
MIN_RADIX, MAX_RADIX, digit(char, int)

getDirectionality

public static byte getDirectionality(char ch)
返回给定字符的 Unicode 方向属性。利用字符方向性来计算文本的视觉顺序。未定义的 char 值的方向值是 DIRECTIONALITY_UNDEFINED。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 getDirectionality(int) 方法。

参数：
ch - 为其请求方向属性的 char。
返回：
char 值的方向属性。
从以下版本开始：
1.4
另请参见：
DIRECTIONALITY_UNDEFINED, DIRECTIONALITY_LEFT_TO_RIGHT, DIRECTIONALITY_RIGHT_TO_LEFT, DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC, DIRECTIONALITY_EUROPEAN_NUMBER, DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR, DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR, DIRECTIONALITY_ARABIC_NUMBER, DIRECTIONALITY_COMMON_NUMBER_SEPARATOR, DIRECTIONALITY_NONSPACING_MARK, DIRECTIONALITY_BOUNDARY_NEUTRAL, DIRECTIONALITY_PARAGRAPH_SEPARATOR, DIRECTIONALITY_SEGMENT_SEPARATOR, DIRECTIONALITY_WHITESPACE, DIRECTIONALITY_OTHER_NEUTRALS, DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING, DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE, DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING, DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE, DIRECTIONALITY_POP_DIRECTIONAL_FORMAT

getDirectionality

public static byte getDirectionality(int codePoint)
返回给定字符（Unicode 代码点）的 Unicode 方向属性。利用字符方向性来计算文本的视觉顺序。未定义字符的方向值是 DIRECTIONALITY_UNDEFINED。

参数：
codePoint - 为其请求方向属性的字符（Unicode 代码点）。
返回：
字符的方向属性。
从以下版本开始：
1.5
另请参见：
DIRECTIONALITY_UNDEFINED, DIRECTIONALITY_LEFT_TO_RIGHT, DIRECTIONALITY_RIGHT_TO_LEFT, DIRECTIONALITY_RIGHT_TO_LEFT_ARABIC, DIRECTIONALITY_EUROPEAN_NUMBER, DIRECTIONALITY_EUROPEAN_NUMBER_SEPARATOR, DIRECTIONALITY_EUROPEAN_NUMBER_TERMINATOR, DIRECTIONALITY_ARABIC_NUMBER, DIRECTIONALITY_COMMON_NUMBER_SEPARATOR, DIRECTIONALITY_NONSPACING_MARK, DIRECTIONALITY_BOUNDARY_NEUTRAL, DIRECTIONALITY_PARAGRAPH_SEPARATOR, DIRECTIONALITY_SEGMENT_SEPARATOR, DIRECTIONALITY_WHITESPACE, DIRECTIONALITY_OTHER_NEUTRALS, DIRECTIONALITY_LEFT_TO_RIGHT_EMBEDDING, DIRECTIONALITY_LEFT_TO_RIGHT_OVERRIDE, DIRECTIONALITY_RIGHT_TO_LEFT_EMBEDDING, DIRECTIONALITY_RIGHT_TO_LEFT_OVERRIDE, DIRECTIONALITY_POP_DIRECTIONAL_FORMAT

isMirrored

public static boolean isMirrored(char ch)
确定指定字符依据 Unicode 规范是否对称。当显示在以从右至左的方式显示的文本中时，对称字符的字形在水平方向上应该是对称的。例如，'\u0028' LEFT PARENTHESIS 在语义上被定义为是开括号。在从左至右显示的文本中，它将显示为“(”，但在以从右至左的方式显示的文本中，它显示为“)”。

注：此方法无法处理增补字符。若要支持所有 Unicode 字符，包括增补字符，请使用 isMirrored(int) 方法。

参数：
ch - 为其请求对称属性的 char
返回：
如果字符是对称的，则返回 true，如果 char 不是对称的或者尚未定义，则返回 false。
从以下版本开始：
1.4

isMirrored

public static boolean isMirrored(int codePoint)
确定指定字符（Unicode 代码点）依据 Unicode 规范是否对称。当显示在以从右至左的方式显示的文本中时，对称字符的字形在水平方向上应该是对称的。例如，'\u0028' LEFT PARENTHESIS 在语义上被定义为是开括号。在从左至右显示的文本中，它将显示为“(”，但在以从右至左的方式显示的文本中，它显示为“)”。

参数：
codePoint - 要测试的字符（Unicode 代码点）。
返回：
如果字符是对称的，则返回 true，如果字符是不对称的或者尚未定义，则返回 false。
从以下版本开始：
1.5

compareTo

public int compareTo(Character anotherCharacter)
根据数字比较两个 Character 对象。

指定者：
接口 Comparable<Character> 中的 compareTo
参数：
anotherCharacter - 要比较的 Character。
返回：
如果该 Character 等于此 Character，则返回 0；如果该 Character 的数值小于参数 Character，则返回小于 0 的值；如果该 Character 的数值大于参数 Character，则返回大于 0 的值（有符号比较）。注意，这是一次严格的数字比较；它并不依赖于区域。
从以下版本开始：
1.2

reverseBytes

public static char reverseBytes(char ch)
返回通过反转指定 char 值中的字节顺序而获得的值。

返回：
通过反转（或者等效于交换）指定 char 值中的字节而获得的值。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Character.Subset (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Character.Subset

java.lang.Object
    继承者  java.lang.Character.Subset
直接已知子类：
Character.UnicodeBlock, InputSubset
正在封闭类：
Character
public static class Character.Subset
extends Object

此类的实例表示 Unicode 字符集的特定子集。Character 类中定义的唯一子集系列是 UnicodeBlock。Java API 的其他部分可以针对其各自用途定义其他子集。

从以下版本开始：
1.2

构造方法摘要
protected Character.Subset(String name)
构造一个新的 Subset 实例。
方法摘要
 boolean equals(Object obj)
比较两个 Subset 对象的相等性。
 int hashCode()
返回 Object.hashCode() 方法定义的标准哈希码。
 String toString()
返回该子集的名称。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Character.Subset

protected Character.Subset(String name)
构造一个新的 Subset 实例。

参数：
name - 此子集的名称
抛出：
NullPointerException - 如果名称为 null
方法详细信息

equals

public final boolean equals(Object obj)
比较两个 Subset 对象的相等性。当且仅当 this 和参数引用同一对象时，此方法才返回 true，由于此方法为 final，这保证了保持所有子类。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
返回 Object.hashCode() 方法定义的标准哈希码。此方法为 final，可确保 equals 和 hashCode 方法在所有子类中一致。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public final String toString()
返回该子集的名称。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Character.UnicodeBlock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Character.UnicodeBlock

java.lang.Object
    继承者  java.lang.Character.Subset
        继承者  java.lang.Character.UnicodeBlock
正在封闭类：
Character
public static final class Character.UnicodeBlock
extends Character.Subset

表示 Unicode 规范中字符块的一系列字符子集。字符块通常定义用于特定脚本或目的的字符。一个字符至多可以包含在一个 Unicode 块中。

从以下版本开始：
1.2

字段摘要
static Character.UnicodeBlock | AEGEAN_NUMBERS “Aegean Numbers”Unicode 字符块的常量。
static Character.UnicodeBlock | ALPHABETIC_PRESENTATION_FORMS “Alphabetic Presentation Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | ARABIC “Arabic”Unicode 字符块的常量。
static Character.UnicodeBlock | ARABIC_PRESENTATION_FORMS_A “Arabic Presentation Forms-A”Unicode 字符块的常量。
static Character.UnicodeBlock | ARABIC_PRESENTATION_FORMS_B “Arabic Presentation Forms-B”Unicode 字符块的常量。
static Character.UnicodeBlock | ARMENIAN “Armenian”Unicode 字符块的常量。
static Character.UnicodeBlock | ARROWS “Arrows”Unicode 字符块的常量。
static Character.UnicodeBlock | BASIC_LATIN “Basic Latin”Unicode 字符块的常量。
static Character.UnicodeBlock | BENGALI “Bengali”Unicode 字符块的常量。
static Character.UnicodeBlock | BLOCK_ELEMENTS “Block Elements”Unicode 字符块的常量。
static Character.UnicodeBlock | BOPOMOFO “Bopomofo”Unicode 字符块的常量。
static Character.UnicodeBlock | BOPOMOFO_EXTENDED “Bopomofo Extended”Unicode 字符块的常量。
static Character.UnicodeBlock | BOX_DRAWING “Box Drawing”Unicode 字符块的常量。
static Character.UnicodeBlock | BRAILLE_PATTERNS “Braille Patterns”Unicode 字符块的常量。
static Character.UnicodeBlock | BUHID “Buhid”Unicode 字符块的常量。
static Character.UnicodeBlock | BYZANTINE_MUSICAL_SYMBOLS “Byzantine Musical Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | CHEROKEE “Cherokee”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_COMPATIBILITY “CJK Compatibility”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_COMPATIBILITY_FORMS “CJK Compatibility Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_COMPATIBILITY_IDEOGRAPHS “CJK Compatibility Ideographs”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT “CJK Compatibility Ideographs Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_RADICALS_SUPPLEMENT “CJK Radicals Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_SYMBOLS_AND_PUNCTUATION “CJK Symbols and Punctuation”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_UNIFIED_IDEOGRAPHS “CJK Unified Ideographs”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A “CJK Unified Ideographs Extension A”Unicode 字符块的常量。
static Character.UnicodeBlock | CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B “CJK Unified Ideographs Extension B”Unicode 字符块的常量。
static Character.UnicodeBlock | COMBINING_DIACRITICAL_MARKS “Combining Diacritical Marks”Unicode 字符块的常量。
static Character.UnicodeBlock | COMBINING_HALF_MARKS “Combining Half Marks”Unicode 字符块的常量。
static Character.UnicodeBlock | COMBINING_MARKS_FOR_SYMBOLS “Combining Diacritical Marks for Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | CONTROL_PICTURES “Control Pictures”Unicode 字符块的常量。
static Character.UnicodeBlock | CURRENCY_SYMBOLS “Currency Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | CYPRIOT_SYLLABARY “Cypriot Syllabary”Unicode 字符块的常量。
static Character.UnicodeBlock | CYRILLIC “Cyrillic”Unicode 字符块的常量。
static Character.UnicodeBlock | CYRILLIC_SUPPLEMENTARY “Cyrillic Supplementary”Unicode 字符块的常量。
static Character.UnicodeBlock | DESERET “Deseret”Unicode 字符块的常量。
static Character.UnicodeBlock | DEVANAGARI “Devanagari”Unicode 字符块的常量。
static Character.UnicodeBlock | DINGBATS “Dingbats”Unicode 字符块的常量。
static Character.UnicodeBlock | ENCLOSED_ALPHANUMERICS “Enclosed Alphanumerics”Unicode 字符块的常量。
static Character.UnicodeBlock | ENCLOSED_CJK_LETTERS_AND_MONTHS “Enclosed CJK Letters and Months”Unicode 字符块的常量。
static Character.UnicodeBlock | ETHIOPIC “Ethiopic”Unicode 字符块的常量。
static Character.UnicodeBlock | GENERAL_PUNCTUATION “General Punctuation”Unicode 字符块的常量。
static Character.UnicodeBlock | GEOMETRIC_SHAPES “Geometric Shapes”Unicode 字符块的常量。
static Character.UnicodeBlock | GEORGIAN “Georgian”Unicode 字符块的常量。
static Character.UnicodeBlock | GOTHIC “Gothic”Unicode 字符块的常量。
static Character.UnicodeBlock | GREEK “Greek and Coptic”Unicode 字符块的常量。
static Character.UnicodeBlock | GREEK_EXTENDED “Greek Extended”Unicode 字符块的常量。
static Character.UnicodeBlock | GUJARATI “Gujarati”Unicode 字符块的常量。
static Character.UnicodeBlock | GURMUKHI “Gurmukhi”Unicode 字符块的常量。
static Character.UnicodeBlock | HALFWIDTH_AND_FULLWIDTH_FORMS “Halfwidth and Fullwidth Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | HANGUL_COMPATIBILITY_JAMO “Hangul Compatibility Jamo”Unicode 字符块的常量。
static Character.UnicodeBlock | HANGUL_JAMO “Hangul Jamo”Unicode 字符块的常量。
static Character.UnicodeBlock | HANGUL_SYLLABLES “Hangul Syllables”Unicode 字符块的常量。
static Character.UnicodeBlock | HANUNOO “Hanunoo”Unicode 字符块的常量。
static Character.UnicodeBlock | HEBREW “Hebrew”Unicode 字符块的常量。
static Character.UnicodeBlock | HIGH_PRIVATE_USE_SURROGATES “High Private Use Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | HIGH_SURROGATES “High Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | HIRAGANA “Hiragana”Unicode 字符块的常量。
static Character.UnicodeBlock | IDEOGRAPHIC_DESCRIPTION_CHARACTERS “Ideographic Description Characters”Unicode 字符块的常量。
static Character.UnicodeBlock | IPA_EXTENSIONS “IPA Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | KANBUN “Kanbun”Unicode 字符块的常量。
static Character.UnicodeBlock | KANGXI_RADICALS “Kangxi Radicals”Unicode 字符块的常量。
static Character.UnicodeBlock | KANNADA “Kannada”Unicode 字符块的常量。
static Character.UnicodeBlock | KATAKANA “Katakana”Unicode 字符块的常量。
static Character.UnicodeBlock | KATAKANA_PHONETIC_EXTENSIONS “Katakana Phonetic Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | KHMER “Khmer”Unicode 字符块的常量。
static Character.UnicodeBlock | KHMER_SYMBOLS “Khmer Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | LAO “Lao”Unicode 字符块的常量。
static Character.UnicodeBlock | LATIN_1_SUPPLEMENT “Latin-1 Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | LATIN_EXTENDED_A “Latin Extended-A”Unicode 字符块的常量。
static Character.UnicodeBlock | LATIN_EXTENDED_ADDITIONAL “Latin Extended Additional”Unicode 字符块的常量。
static Character.UnicodeBlock | LATIN_EXTENDED_B “Latin Extended-B”Unicode 字符块的常量。
static Character.UnicodeBlock | LETTERLIKE_SYMBOLS “Letterlike Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | LIMBU “Limbu”Unicode 字符块的常量。
static Character.UnicodeBlock | LINEAR_B_IDEOGRAMS “Linear B Ideograms”Unicode 字符块的常量。
static Character.UnicodeBlock | LINEAR_B_SYLLABARY “Linear B Syllabary”Unicode 字符块的常量。
static Character.UnicodeBlock | LOW_SURROGATES “Low Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | MALAYALAM “Malayalam”Unicode 字符块的常量。
static Character.UnicodeBlock | MATHEMATICAL_ALPHANUMERIC_SYMBOLS “Mathematical Alphanumeric Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | MATHEMATICAL_OPERATORS “Mathematical Operators”Unicode 字符块的常量。
static Character.UnicodeBlock | MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A “Miscellaneous Mathematical Symbols-A”Unicode 字符块的常量。
static Character.UnicodeBlock | MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B “Miscellaneous Mathematical Symbols-B”Unicode 字符块的常量。
static Character.UnicodeBlock | MISCELLANEOUS_SYMBOLS “Miscellaneous Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | MISCELLANEOUS_SYMBOLS_AND_ARROWS “Miscellaneous Symbols and Arrows”Unicode 字符块的常量。
static Character.UnicodeBlock | MISCELLANEOUS_TECHNICAL “Miscellaneous Technical”Unicode 字符块的常量。
static Character.UnicodeBlock | MONGOLIAN “Mongolian”Unicode 字符块的常量。
static Character.UnicodeBlock | MUSICAL_SYMBOLS “Musical Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | MYANMAR “Myanmar”Unicode 字符块的常量。
static Character.UnicodeBlock | NUMBER_FORMS “Number Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | OGHAM “Ogham”Unicode 字符块的常量。
static Character.UnicodeBlock | OLD_ITALIC “Old Italic”Unicode 字符块的常量。
static Character.UnicodeBlock | OPTICAL_CHARACTER_RECOGNITION “Optical Character Recognition”Unicode 字符块的常量。
static Character.UnicodeBlock | ORIYA “Oriya”Unicode 字符块的常量。
static Character.UnicodeBlock | OSMANYA “Osmanya”Unicode 字符块的常量。
static Character.UnicodeBlock | PHONETIC_EXTENSIONS “Phonetic Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | PRIVATE_USE_AREA “Private Use Area”Unicode 字符块的常量。
static Character.UnicodeBlock | RUNIC “Runic”Unicode 字符块的常量。
static Character.UnicodeBlock | SHAVIAN “Shavian”Unicode 字符块的常量。
static Character.UnicodeBlock | SINHALA “Sinhala”Unicode 字符块的常量。
static Character.UnicodeBlock | SMALL_FORM_VARIANTS “Small Form Variants”Unicode 字符块的常量。
static Character.UnicodeBlock | SPACING_MODIFIER_LETTERS “Spacing Modifier Letters”Unicode 字符块的常量。
static Character.UnicodeBlock | SPECIALS “Specials”Unicode 字符块的常量。
static Character.UnicodeBlock | SUPERSCRIPTS_AND_SUBSCRIPTS “Superscripts and Subscripts”Unicode 字符块的常量。
static Character.UnicodeBlock | SUPPLEMENTAL_ARROWS_A “Supplemental Arrows-A”Unicode 字符块的常量。
static Character.UnicodeBlock | SUPPLEMENTAL_ARROWS_B “Supplemental Arrows-B”Unicode 字符块的常量。
static Character.UnicodeBlock | SUPPLEMENTAL_MATHEMATICAL_OPERATORS “Supplemental Mathematical Operators”Unicode 字符块的常量。
static Character.UnicodeBlock | SUPPLEMENTARY_PRIVATE_USE_AREA_A “Supplementary Private Use Area-A”Unicode 字符块的常量。
static Character.UnicodeBlock | SUPPLEMENTARY_PRIVATE_USE_AREA_B “Supplementary Private Use Area-B”Unicode 字符块的常量。
static Character.UnicodeBlock | SURROGATES_AREA 已过时。 从 J2SE 5 开始，使用 HIGH_SURROGATES、HIGH_PRIVATE_USE_SURROGATES 和 LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。of(char) 和 of(int) 方法返回新常量，而不是 SURROGATES_AREA。
static Character.UnicodeBlock | SYRIAC “Syriac”Unicode 字符块的常量。
static Character.UnicodeBlock | TAGALOG “Tagalog”Unicode 字符块的常量。
static Character.UnicodeBlock | TAGBANWA “Tagbanwa”Unicode 字符块的常量。
static Character.UnicodeBlock | TAGS “Tags”Unicode 字符块的常量。
static Character.UnicodeBlock | TAI_LE “Tai Le”Unicode 字符块的常量。
static Character.UnicodeBlock | TAI_XUAN_JING_SYMBOLS “Tai Xuan Jing Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | TAMIL “Tamil”Unicode 字符块的常量。
static Character.UnicodeBlock | TELUGU “Telugu”Unicode 字符块的常量。
static Character.UnicodeBlock | THAANA “Thaana”Unicode 字符块的常量。
static Character.UnicodeBlock | THAI “Thai”Unicode 字符块的常量。
static Character.UnicodeBlock | TIBETAN “Tibetan”Unicode 字符块的常量。
static Character.UnicodeBlock | UGARITIC “Ugaritic”Unicode 字符块的常量。
static Character.UnicodeBlock | UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS “Unified Canadian Aboriginal Syllabics”Unicode 字符块的常量。
static Character.UnicodeBlock | VARIATION_SELECTORS “Variation Selectors”Unicode 字符块的常量。
static Character.UnicodeBlock | VARIATION_SELECTORS_SUPPLEMENT “Variation Selectors Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | YI_RADICALS “Yi Radicals”Unicode 字符块的常量。
static Character.UnicodeBlock | YI_SYLLABLES “Yi Syllables”Unicode 字符块的常量。
static Character.UnicodeBlock | YIJING_HEXAGRAM_SYMBOLS “Yijing Hexagram Symbols”Unicode 字符块的常量。
方法摘要
static Character.UnicodeBlock | forName(String blockName) 返回带有给定名称的 UnicodeBlock。
static Character.UnicodeBlock | of(char c) 返回表示包含给定字符的 Unicode 块的对象；如果该字符不是某个定义块的成员，则返回 null。
static Character.UnicodeBlock | of(int codePoint) 返回表示包含给定字符（Unicode 代码点）的 Unicode 块的对象；如果该字符不是定义块的成员，则返回 null。
从类 java.lang.Character.Subset 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

BASIC_LATIN

public static final Character.UnicodeBlock BASIC_LATIN
“Basic Latin”Unicode 字符块的常量。

从以下版本开始：
1.2

LATIN_1_SUPPLEMENT

public static final Character.UnicodeBlock LATIN_1_SUPPLEMENT
“Latin-1 Supplement”Unicode 字符块的常量。

从以下版本开始：
1.2

LATIN_EXTENDED_A

public static final Character.UnicodeBlock LATIN_EXTENDED_A
“Latin Extended-A”Unicode 字符块的常量。

从以下版本开始：
1.2

LATIN_EXTENDED_B

public static final Character.UnicodeBlock LATIN_EXTENDED_B
“Latin Extended-B”Unicode 字符块的常量。

从以下版本开始：
1.2

IPA_EXTENSIONS

public static final Character.UnicodeBlock IPA_EXTENSIONS
“IPA Extensions”Unicode 字符块的常量。

从以下版本开始：
1.2

SPACING_MODIFIER_LETTERS

public static final Character.UnicodeBlock SPACING_MODIFIER_LETTERS
“Spacing Modifier Letters”Unicode 字符块的常量。

从以下版本开始：
1.2

COMBINING_DIACRITICAL_MARKS

public static final Character.UnicodeBlock COMBINING_DIACRITICAL_MARKS
“Combining Diacritical Marks”Unicode 字符块的常量。

从以下版本开始：
1.2

GREEK

public static final Character.UnicodeBlock GREEK
“Greek and Coptic”Unicode 字符块的常量。

该块以前称为“Greek”块。

从以下版本开始：
1.2

CYRILLIC

public static final Character.UnicodeBlock CYRILLIC
“Cyrillic”Unicode 字符块的常量。

从以下版本开始：
1.2

ARMENIAN

public static final Character.UnicodeBlock ARMENIAN
“Armenian”Unicode 字符块的常量。

从以下版本开始：
1.2

HEBREW

public static final Character.UnicodeBlock HEBREW
“Hebrew”Unicode 字符块的常量。

从以下版本开始：
1.2

ARABIC

public static final Character.UnicodeBlock ARABIC
“Arabic”Unicode 字符块的常量。

从以下版本开始：
1.2

DEVANAGARI

public static final Character.UnicodeBlock DEVANAGARI
“Devanagari”Unicode 字符块的常量。

从以下版本开始：
1.2

BENGALI

public static final Character.UnicodeBlock BENGALI
“Bengali”Unicode 字符块的常量。

从以下版本开始：
1.2

GURMUKHI

public static final Character.UnicodeBlock GURMUKHI
“Gurmukhi”Unicode 字符块的常量。

从以下版本开始：
1.2

GUJARATI

public static final Character.UnicodeBlock GUJARATI
“Gujarati”Unicode 字符块的常量。

从以下版本开始：
1.2

ORIYA

public static final Character.UnicodeBlock ORIYA
“Oriya”Unicode 字符块的常量。

从以下版本开始：
1.2

TAMIL

public static final Character.UnicodeBlock TAMIL
“Tamil”Unicode 字符块的常量。

从以下版本开始：
1.2

TELUGU

public static final Character.UnicodeBlock TELUGU
“Telugu”Unicode 字符块的常量。

从以下版本开始：
1.2

KANNADA

public static final Character.UnicodeBlock KANNADA
“Kannada”Unicode 字符块的常量。

从以下版本开始：
1.2

MALAYALAM

public static final Character.UnicodeBlock MALAYALAM
“Malayalam”Unicode 字符块的常量。

从以下版本开始：
1.2

THAI

public static final Character.UnicodeBlock THAI
“Thai”Unicode 字符块的常量。

从以下版本开始：
1.2

LAO

public static final Character.UnicodeBlock LAO
“Lao”Unicode 字符块的常量。

从以下版本开始：
1.2

TIBETAN

public static final Character.UnicodeBlock TIBETAN
“Tibetan”Unicode 字符块的常量。

从以下版本开始：
1.2

GEORGIAN

public static final Character.UnicodeBlock GEORGIAN
“Georgian”Unicode 字符块的常量。

从以下版本开始：
1.2

HANGUL_JAMO

public static final Character.UnicodeBlock HANGUL_JAMO
“Hangul Jamo”Unicode 字符块的常量。

从以下版本开始：
1.2

LATIN_EXTENDED_ADDITIONAL

public static final Character.UnicodeBlock LATIN_EXTENDED_ADDITIONAL
“Latin Extended Additional”Unicode 字符块的常量。

从以下版本开始：
1.2

GREEK_EXTENDED

public static final Character.UnicodeBlock GREEK_EXTENDED
“Greek Extended”Unicode 字符块的常量。

从以下版本开始：
1.2

GENERAL_PUNCTUATION

public static final Character.UnicodeBlock GENERAL_PUNCTUATION
“General Punctuation”Unicode 字符块的常量。

从以下版本开始：
1.2

SUPERSCRIPTS_AND_SUBSCRIPTS

public static final Character.UnicodeBlock SUPERSCRIPTS_AND_SUBSCRIPTS
“Superscripts and Subscripts”Unicode 字符块的常量。

从以下版本开始：
1.2

CURRENCY_SYMBOLS

public static final Character.UnicodeBlock CURRENCY_SYMBOLS
“Currency Symbols”Unicode 字符块的常量。

从以下版本开始：
1.2

COMBINING_MARKS_FOR_SYMBOLS

public static final Character.UnicodeBlock COMBINING_MARKS_FOR_SYMBOLS
“Combining Diacritical Marks for Symbols”Unicode 字符块的常量。

该块以前称为“Combining Marks for Symbols”。

从以下版本开始：
1.2

LETTERLIKE_SYMBOLS

public static final Character.UnicodeBlock LETTERLIKE_SYMBOLS
“Letterlike Symbols”Unicode 字符块的常量。

从以下版本开始：
1.2

NUMBER_FORMS

public static final Character.UnicodeBlock NUMBER_FORMS
“Number Forms”Unicode 字符块的常量。

从以下版本开始：
1.2

ARROWS

public static final Character.UnicodeBlock ARROWS
“Arrows”Unicode 字符块的常量。

从以下版本开始：
1.2

MATHEMATICAL_OPERATORS

public static final Character.UnicodeBlock MATHEMATICAL_OPERATORS
“Mathematical Operators”Unicode 字符块的常量。

从以下版本开始：
1.2

MISCELLANEOUS_TECHNICAL

public static final Character.UnicodeBlock MISCELLANEOUS_TECHNICAL
“Miscellaneous Technical”Unicode 字符块的常量。

从以下版本开始：
1.2

CONTROL_PICTURES

public static final Character.UnicodeBlock CONTROL_PICTURES
“Control Pictures”Unicode 字符块的常量。

从以下版本开始：
1.2

OPTICAL_CHARACTER_RECOGNITION

public static final Character.UnicodeBlock OPTICAL_CHARACTER_RECOGNITION
“Optical Character Recognition”Unicode 字符块的常量。

从以下版本开始：
1.2

ENCLOSED_ALPHANUMERICS

public static final Character.UnicodeBlock ENCLOSED_ALPHANUMERICS
“Enclosed Alphanumerics”Unicode 字符块的常量。

从以下版本开始：
1.2

BOX_DRAWING

public static final Character.UnicodeBlock BOX_DRAWING
“Box Drawing”Unicode 字符块的常量。

从以下版本开始：
1.2

BLOCK_ELEMENTS

public static final Character.UnicodeBlock BLOCK_ELEMENTS
“Block Elements”Unicode 字符块的常量。

从以下版本开始：
1.2

GEOMETRIC_SHAPES

public static final Character.UnicodeBlock GEOMETRIC_SHAPES
“Geometric Shapes”Unicode 字符块的常量。

从以下版本开始：
1.2

MISCELLANEOUS_SYMBOLS

public static final Character.UnicodeBlock MISCELLANEOUS_SYMBOLS
“Miscellaneous Symbols”Unicode 字符块的常量。

从以下版本开始：
1.2

DINGBATS

public static final Character.UnicodeBlock DINGBATS
“Dingbats”Unicode 字符块的常量。

从以下版本开始：
1.2

CJK_SYMBOLS_AND_PUNCTUATION

public static final Character.UnicodeBlock CJK_SYMBOLS_AND_PUNCTUATION
“CJK Symbols and Punctuation”Unicode 字符块的常量。

从以下版本开始：
1.2

HIRAGANA

public static final Character.UnicodeBlock HIRAGANA
“Hiragana”Unicode 字符块的常量。

从以下版本开始：
1.2

KATAKANA

public static final Character.UnicodeBlock KATAKANA
“Katakana”Unicode 字符块的常量。

从以下版本开始：
1.2

BOPOMOFO

public static final Character.UnicodeBlock BOPOMOFO
“Bopomofo”Unicode 字符块的常量。

从以下版本开始：
1.2

HANGUL_COMPATIBILITY_JAMO

public static final Character.UnicodeBlock HANGUL_COMPATIBILITY_JAMO
“Hangul Compatibility Jamo”Unicode 字符块的常量。

从以下版本开始：
1.2

KANBUN

public static final Character.UnicodeBlock KANBUN
“Kanbun”Unicode 字符块的常量。

从以下版本开始：
1.2

ENCLOSED_CJK_LETTERS_AND_MONTHS

public static final Character.UnicodeBlock ENCLOSED_CJK_LETTERS_AND_MONTHS
“Enclosed CJK Letters and Months”Unicode 字符块的常量。

从以下版本开始：
1.2

CJK_COMPATIBILITY

public static final Character.UnicodeBlock CJK_COMPATIBILITY
“CJK Compatibility”Unicode 字符块的常量。

从以下版本开始：
1.2

CJK_UNIFIED_IDEOGRAPHS

public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS
“CJK Unified Ideographs”Unicode 字符块的常量。

从以下版本开始：
1.2

HANGUL_SYLLABLES

public static final Character.UnicodeBlock HANGUL_SYLLABLES
“Hangul Syllables”Unicode 字符块的常量。

从以下版本开始：
1.2

PRIVATE_USE_AREA

public static final Character.UnicodeBlock PRIVATE_USE_AREA
“Private Use Area”Unicode 字符块的常量。

从以下版本开始：
1.2

CJK_COMPATIBILITY_IDEOGRAPHS

public static final Character.UnicodeBlock CJK_COMPATIBILITY_IDEOGRAPHS
“CJK Compatibility Ideographs”Unicode 字符块的常量。

从以下版本开始：
1.2

ALPHABETIC_PRESENTATION_FORMS

public static final Character.UnicodeBlock ALPHABETIC_PRESENTATION_FORMS
“Alphabetic Presentation Forms”Unicode 字符块的常量。

从以下版本开始：
1.2

ARABIC_PRESENTATION_FORMS_A

public static final Character.UnicodeBlock ARABIC_PRESENTATION_FORMS_A
“Arabic Presentation Forms-A”Unicode 字符块的常量。

从以下版本开始：
1.2

COMBINING_HALF_MARKS

public static final Character.UnicodeBlock COMBINING_HALF_MARKS
“Combining Half Marks”Unicode 字符块的常量。

从以下版本开始：
1.2

CJK_COMPATIBILITY_FORMS

public static final Character.UnicodeBlock CJK_COMPATIBILITY_FORMS
“CJK Compatibility Forms”Unicode 字符块的常量。

从以下版本开始：
1.2

SMALL_FORM_VARIANTS

public static final Character.UnicodeBlock SMALL_FORM_VARIANTS
“Small Form Variants”Unicode 字符块的常量。

从以下版本开始：
1.2

ARABIC_PRESENTATION_FORMS_B

public static final Character.UnicodeBlock ARABIC_PRESENTATION_FORMS_B
“Arabic Presentation Forms-B”Unicode 字符块的常量。

从以下版本开始：
1.2

HALFWIDTH_AND_FULLWIDTH_FORMS

public static final Character.UnicodeBlock HALFWIDTH_AND_FULLWIDTH_FORMS
“Halfwidth and Fullwidth Forms”Unicode 字符块的常量。

从以下版本开始：
1.2

SPECIALS

public static final Character.UnicodeBlock SPECIALS
“Specials”Unicode 字符块的常量。

从以下版本开始：
1.2

SURROGATES_AREA

@Deprecated
public static final Character.UnicodeBlock SURROGATES_AREA
已过时。 从 J2SE 5 开始，使用 HIGH_SURROGATES、HIGH_PRIVATE_USE_SURROGATES 和 LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。of(char) 和 of(int) 方法返回新常量，而不是 SURROGATES_AREA。

SYRIAC

public static final Character.UnicodeBlock SYRIAC
“Syriac”Unicode 字符块的常量。

从以下版本开始：
1.4

THAANA

public static final Character.UnicodeBlock THAANA
“Thaana”Unicode 字符块的常量。

从以下版本开始：
1.4

SINHALA

public static final Character.UnicodeBlock SINHALA
“Sinhala”Unicode 字符块的常量。

从以下版本开始：
1.4

MYANMAR

public static final Character.UnicodeBlock MYANMAR
“Myanmar”Unicode 字符块的常量。

从以下版本开始：
1.4

ETHIOPIC

public static final Character.UnicodeBlock ETHIOPIC
“Ethiopic”Unicode 字符块的常量。

从以下版本开始：
1.4

CHEROKEE

public static final Character.UnicodeBlock CHEROKEE
“Cherokee”Unicode 字符块的常量。

从以下版本开始：
1.4

UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS

public static final Character.UnicodeBlock UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS
“Unified Canadian Aboriginal Syllabics”Unicode 字符块的常量。

从以下版本开始：
1.4

OGHAM

public static final Character.UnicodeBlock OGHAM
“Ogham”Unicode 字符块的常量。

从以下版本开始：
1.4

RUNIC

public static final Character.UnicodeBlock RUNIC
“Runic”Unicode 字符块的常量。

从以下版本开始：
1.4

KHMER

public static final Character.UnicodeBlock KHMER
“Khmer”Unicode 字符块的常量。

从以下版本开始：
1.4

MONGOLIAN

public static final Character.UnicodeBlock MONGOLIAN
“Mongolian”Unicode 字符块的常量。

从以下版本开始：
1.4

BRAILLE_PATTERNS

public static final Character.UnicodeBlock BRAILLE_PATTERNS
“Braille Patterns”Unicode 字符块的常量。

从以下版本开始：
1.4

CJK_RADICALS_SUPPLEMENT

public static final Character.UnicodeBlock CJK_RADICALS_SUPPLEMENT
“CJK Radicals Supplement”Unicode 字符块的常量。

从以下版本开始：
1.4

KANGXI_RADICALS

public static final Character.UnicodeBlock KANGXI_RADICALS
“Kangxi Radicals”Unicode 字符块的常量。

从以下版本开始：
1.4

IDEOGRAPHIC_DESCRIPTION_CHARACTERS

public static final Character.UnicodeBlock IDEOGRAPHIC_DESCRIPTION_CHARACTERS
“Ideographic Description Characters”Unicode 字符块的常量。

从以下版本开始：
1.4

BOPOMOFO_EXTENDED

public static final Character.UnicodeBlock BOPOMOFO_EXTENDED
“Bopomofo Extended”Unicode 字符块的常量。

从以下版本开始：
1.4

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A

public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A
“CJK Unified Ideographs Extension A”Unicode 字符块的常量。

从以下版本开始：
1.4

YI_SYLLABLES

public static final Character.UnicodeBlock YI_SYLLABLES
“Yi Syllables”Unicode 字符块的常量。

从以下版本开始：
1.4

YI_RADICALS

public static final Character.UnicodeBlock YI_RADICALS
“Yi Radicals”Unicode 字符块的常量。

从以下版本开始：
1.4

CYRILLIC_SUPPLEMENTARY

public static final Character.UnicodeBlock CYRILLIC_SUPPLEMENTARY
“Cyrillic Supplementary”Unicode 字符块的常量。

从以下版本开始：
1.5

TAGALOG

public static final Character.UnicodeBlock TAGALOG
“Tagalog”Unicode 字符块的常量。

从以下版本开始：
1.5

HANUNOO

public static final Character.UnicodeBlock HANUNOO
“Hanunoo”Unicode 字符块的常量。

从以下版本开始：
1.5

BUHID

public static final Character.UnicodeBlock BUHID
“Buhid”Unicode 字符块的常量。

从以下版本开始：
1.5

TAGBANWA

public static final Character.UnicodeBlock TAGBANWA
“Tagbanwa”Unicode 字符块的常量。

从以下版本开始：
1.5

LIMBU

public static final Character.UnicodeBlock LIMBU
“Limbu”Unicode 字符块的常量。

从以下版本开始：
1.5

TAI_LE

public static final Character.UnicodeBlock TAI_LE
“Tai Le”Unicode 字符块的常量。

从以下版本开始：
1.5

KHMER_SYMBOLS

public static final Character.UnicodeBlock KHMER_SYMBOLS
“Khmer Symbols”Unicode 字符块的常量。

从以下版本开始：
1.5

PHONETIC_EXTENSIONS

public static final Character.UnicodeBlock PHONETIC_EXTENSIONS
“Phonetic Extensions”Unicode 字符块的常量。

从以下版本开始：
1.5

MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A

public static final Character.UnicodeBlock MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A
“Miscellaneous Mathematical Symbols-A”Unicode 字符块的常量。

从以下版本开始：
1.5

SUPPLEMENTAL_ARROWS_A

public static final Character.UnicodeBlock SUPPLEMENTAL_ARROWS_A
“Supplemental Arrows-A”Unicode 字符块的常量。

从以下版本开始：
1.5

SUPPLEMENTAL_ARROWS_B

public static final Character.UnicodeBlock SUPPLEMENTAL_ARROWS_B
“Supplemental Arrows-B”Unicode 字符块的常量。

从以下版本开始：
1.5

MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B

public static final Character.UnicodeBlock MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B
“Miscellaneous Mathematical Symbols-B”Unicode 字符块的常量。

从以下版本开始：
1.5

SUPPLEMENTAL_MATHEMATICAL_OPERATORS

public static final Character.UnicodeBlock SUPPLEMENTAL_MATHEMATICAL_OPERATORS
“Supplemental Mathematical Operators”Unicode 字符块的常量。

从以下版本开始：
1.5

MISCELLANEOUS_SYMBOLS_AND_ARROWS

public static final Character.UnicodeBlock MISCELLANEOUS_SYMBOLS_AND_ARROWS
“Miscellaneous Symbols and Arrows”Unicode 字符块的常量。

从以下版本开始：
1.5

KATAKANA_PHONETIC_EXTENSIONS

public static final Character.UnicodeBlock KATAKANA_PHONETIC_EXTENSIONS
“Katakana Phonetic Extensions”Unicode 字符块的常量。

从以下版本开始：
1.5

YIJING_HEXAGRAM_SYMBOLS

public static final Character.UnicodeBlock YIJING_HEXAGRAM_SYMBOLS
“Yijing Hexagram Symbols”Unicode 字符块的常量。

从以下版本开始：
1.5

VARIATION_SELECTORS

public static final Character.UnicodeBlock VARIATION_SELECTORS
“Variation Selectors”Unicode 字符块的常量。

从以下版本开始：
1.5

LINEAR_B_SYLLABARY

public static final Character.UnicodeBlock LINEAR_B_SYLLABARY
“Linear B Syllabary”Unicode 字符块的常量。

从以下版本开始：
1.5

LINEAR_B_IDEOGRAMS

public static final Character.UnicodeBlock LINEAR_B_IDEOGRAMS
“Linear B Ideograms”Unicode 字符块的常量。

从以下版本开始：
1.5

AEGEAN_NUMBERS

public static final Character.UnicodeBlock AEGEAN_NUMBERS
“Aegean Numbers”Unicode 字符块的常量。

从以下版本开始：
1.5

OLD_ITALIC

public static final Character.UnicodeBlock OLD_ITALIC
“Old Italic”Unicode 字符块的常量。

从以下版本开始：
1.5

GOTHIC

public static final Character.UnicodeBlock GOTHIC
“Gothic”Unicode 字符块的常量。

从以下版本开始：
1.5

UGARITIC

public static final Character.UnicodeBlock UGARITIC
“Ugaritic”Unicode 字符块的常量。

从以下版本开始：
1.5

DESERET

public static final Character.UnicodeBlock DESERET
“Deseret”Unicode 字符块的常量。

从以下版本开始：
1.5

SHAVIAN

public static final Character.UnicodeBlock SHAVIAN
“Shavian”Unicode 字符块的常量。

从以下版本开始：
1.5

OSMANYA

public static final Character.UnicodeBlock OSMANYA
“Osmanya”Unicode 字符块的常量。

从以下版本开始：
1.5

CYPRIOT_SYLLABARY

public static final Character.UnicodeBlock CYPRIOT_SYLLABARY
“Cypriot Syllabary”Unicode 字符块的常量。

从以下版本开始：
1.5

BYZANTINE_MUSICAL_SYMBOLS

public static final Character.UnicodeBlock BYZANTINE_MUSICAL_SYMBOLS
“Byzantine Musical Symbols”Unicode 字符块的常量。

从以下版本开始：
1.5

MUSICAL_SYMBOLS

public static final Character.UnicodeBlock MUSICAL_SYMBOLS
“Musical Symbols”Unicode 字符块的常量。

从以下版本开始：
1.5

TAI_XUAN_JING_SYMBOLS

public static final Character.UnicodeBlock TAI_XUAN_JING_SYMBOLS
“Tai Xuan Jing Symbols”Unicode 字符块的常量。

从以下版本开始：
1.5

MATHEMATICAL_ALPHANUMERIC_SYMBOLS

public static final Character.UnicodeBlock MATHEMATICAL_ALPHANUMERIC_SYMBOLS
“Mathematical Alphanumeric Symbols”Unicode 字符块的常量。

从以下版本开始：
1.5

CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B

public static final Character.UnicodeBlock CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B
“CJK Unified Ideographs Extension B”Unicode 字符块的常量。

从以下版本开始：
1.5

CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT

public static final Character.UnicodeBlock CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT
“CJK Compatibility Ideographs Supplement”Unicode 字符块的常量。

从以下版本开始：
1.5

TAGS

public static final Character.UnicodeBlock TAGS
“Tags”Unicode 字符块的常量。

从以下版本开始：
1.5

VARIATION_SELECTORS_SUPPLEMENT

public static final Character.UnicodeBlock VARIATION_SELECTORS_SUPPLEMENT
“Variation Selectors Supplement”Unicode 字符块的常量。

从以下版本开始：
1.5

SUPPLEMENTARY_PRIVATE_USE_AREA_A

public static final Character.UnicodeBlock SUPPLEMENTARY_PRIVATE_USE_AREA_A
“Supplementary Private Use Area-A”Unicode 字符块的常量。

从以下版本开始：
1.5

SUPPLEMENTARY_PRIVATE_USE_AREA_B

public static final Character.UnicodeBlock SUPPLEMENTARY_PRIVATE_USE_AREA_B
“Supplementary Private Use Area-B”Unicode 字符块的常量。

从以下版本开始：
1.5

HIGH_SURROGATES

public static final Character.UnicodeBlock HIGH_SURROGATES
“High Surrogates”Unicode 字符块的常量。该块表示高代理项范围（从 0xD800 到 0xDB7F）内的代码点值

从以下版本开始：
1.5

HIGH_PRIVATE_USE_SURROGATES

public static final Character.UnicodeBlock HIGH_PRIVATE_USE_SURROGATES
“High Private Use Surrogates”Unicode 字符块的常量。该块表示高代理项范围（从 0xDB80 到 0xDBFF）内的代码点值

从以下版本开始：
1.5

LOW_SURROGATES

public static final Character.UnicodeBlock LOW_SURROGATES
“Low Surrogates”Unicode 字符块的常量。该块表示高代理项范围（从 0xDC00 到 0xDFFF）内的代码点值

从以下版本开始：
1.5
方法详细信息

of

public static Character.UnicodeBlock of(char c)
返回表示包含给定字符的 Unicode 块的对象；如果该字符不是某个定义块的成员，则返回 null。

注：此方法无法处理增补字符。要支持包括增补字符在内的所有 Unicode 字符，请使用 of(int) 方法。

参数：
c - 相关字符
返回：
表示该字符所属的 Unicode 块的 UnicodeBlock 实例；如果该字符不是任何 Unicode 块的成员，则为 null

of

public static Character.UnicodeBlock of(int codePoint)
返回表示包含给定字符（Unicode 代码点）的 Unicode 块的对象；如果该字符不是定义块的成员，则返回 null。

参数：
codePoint - 相关字符（Unicode 代码点）。
返回：
表示该字符所属的 Unicode 块的 UnicodeBlock 实例；如果该字符不是任何 Unicode 块的成员，则为 null
抛出：
IllegalArgumentException - 如果指定的 codePoint 是一个无效的 Unicode 代码点。
从以下版本开始：
1.5
另请参见：
Character.isValidCodePoint(int)

forName

public static final Character.UnicodeBlock forName(String blockName)
返回带有给定名称的 UnicodeBlock。块名称由 Unicode 标准确定。文件 Blocks-<version>.txt 定义了特定标准版本的块。Character 类指定支持的标准版本。

此方法接受下列形式的块名称：

  1. Unicode 标准中定义的规范化块名称。例如，该标准定义一个“Basic Latin”块。因此，此方法接受“Basic Latin”作为有效的块名称。每个 UnicodeBlock 的文档都提供一个规范化名称。
  2. 移除所有空格的规范化块名称。例如，“BasicLatin”是“Basic Latin”块的一个有效块名称。
  3. 每个常量 UnicodeBlock 标识符的文本表示形式。例如，如果提供“BASIC_LATIN”名称，此方法将返回 BASIC_LATIN 块。这种形式将使用下划线取代规范化名称中的所有空格和连字符。
最后，对于所有有效的块名称形式而言，字符大小写将被忽略。例如，“BASIC_LATIN”和“basic_latin”都是有效的块名称。en_US 语言环境的大小写映射规则用于为块名称验证提供区分大小写的字符串比较。

如果 Unicode 标准更改块名称，以前和当前的名称都将被接受。

参数：
blockName - 一个 UnicodeBlock 名称。
返回：
由 blockName 标识的 UnicodeBlock 实例
抛出：
IllegalArgumentException - 如果 blockName 为无效的名称
NullPointerException - 如果 blockName 为 null
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharSequence (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 CharSequence

所有已知子接口：
Name
所有已知实现类：
CharBuffer, Segment, String, StringBuffer, StringBuilder
public interface CharSequence

CharSequence 是 char 值的一个可读序列。此接口对许多不同种类的 char 序列提供统一的只读访问。char 值表示 Basic Multilingual Plane (BMP) 或代理项中的一个字符。有关详细信息，请参阅 Unicode 字符表示形式。

此接口不修改 equals 和 hashCode 方法的常规协定。因此，通常未定义比较实现 CharSequence 的两个对象的结果。每个对象都可以通过一个不同的类实现，而且不能保证每个类能够测试其实例与其他类的实例的相等性。因此，使用任意 CharSequence 实例作为集合中的元素或映射中的键是不合适的。

从以下版本开始：
1.4

方法摘要
char | charAt(int index) 返回指定索引的 char 值。
int | length() 返回此字符序列的长度。
CharSequence | subSequence(int start, int end) 返回一个新的 CharSequence，它是此序列的子序列。
String | toString() 返回一个包含此序列中字符的字符串，该字符串与此序列的顺序相同。

方法详细信息

length

int length()
返回此字符序列的长度。该长度是序列中的 16 位 char 数。

返回：
此序列中的 char 数

charAt

char charAt(int index)
返回指定索引的 char 值。索引范围是从零到 length() - 1。对于数组索引，序列的第一个 char 值是索引零，下一个是索引一，依此类推。

如果索引指定的 char 值是代理项，则返回代理项的值。

参数：
index - 要返回的 char 值的索引
返回：
指定的 char 值
抛出：
IndexOutOfBoundsException - 如果 index 参数为负或不小于 length()

subSequence

CharSequence subSequence(int start,
                         int end)
返回一个新的 CharSequence，它是此序列的子序列。子序列从指定序列的 char 值开始，并在索引 end - 1 的 char 值结束。返回序列的长度（char 中）是 end - start，因此，如果 start == end，则返回一个空序列。

参数：
start - 开始索引（包括）
end - 结束索引（不包括）
返回：
指定的子序列
抛出：
IndexOutOfBoundsException - 如果 start 或 end 为负，end 大于 length() 或者 start 大于 end

toString

String toString()
返回一个包含此序列中字符的字符串，该字符串与此序列的顺序相同。字符串的长度就是此序列的长度。

覆盖：
类 Object 中的 toString
返回：
一个完全由此序列的字符组成的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Class (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Class<T>

java.lang.Object
    继承者  java.lang.Class<T>
类型参数：
T - 由此 Class 对象建模的类的类型。例如，String.class 的类型是 Class<String>。如果将被建模的类未知，则使用 Class<?>。
所有已实现的接口：
Serializable, AnnotatedElement, GenericDeclaration, Type
public final class Class<T>
extends Object
implements Serializable, GenericDeclaration, Type, AnnotatedElement

Class 类的实例表示正在运行的 Java 应用程序中的类和接口。枚举是一种类，注释是一种接口。每个数组属于被映射为 Class 对象的一个类，所有具有相同元素类型和维数的数组都共享该 Class 对象。基本的 Java 类型（boolean、byte、char、short、int、long、float 和 double）和关键字 void 也表示为 Class 对象。

Class 没有公共构造方法。Class 对象是在加载类时由 Java 虚拟机以及通过调用类加载器中的 defineClass 方法自动构造的。

以下示例使用 Class 对象来显示对象的类名：

     void printClassName(Object obj) {
         System.out.println("The class of " + obj +
                            " is " + obj.getClass().getName());
     }

还可以使用一个类字面值（JLS Section 15.8.2）来获取指定类型（或 void）的 Class 对象。例如：

     System.out.println("The name of class Foo is: "+Foo.class.getName());

从以下版本开始：
JDK1.0
另请参见：
ClassLoader.defineClass(byte[], int, int), 序列化表格

方法摘要
<U> Class<? extends U>
asSubclass(Class<U> clazz)
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。
 T cast(Object obj)
将一个对象强制转换成此 Class 对象所表示的类或接口。
 boolean desiredAssertionStatus()
如果要在调用此方法时将要初始化该类，则返回将分配给该类的断言状态。
static Class<?> forName(String className)
返回与带有给定字符串名的类或接口相关联的 Class 对象。
static Class<?> forName(String name, boolean initialize, ClassLoader loader)
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
<A extends Annotation>
A
getAnnotation(Class<A> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
 Annotation[] getAnnotations()
返回此元素上存在的所有注释。
 String getCanonicalName()
返回 Java Language Specification 中所定义的底层类的规范化名称。
 Class<?>[] getClasses()
返回一个包含某些 Class 对象的数组，这些对象表示属于此 Class 对象所表示的类的成员的所有公共类和接口。
 ClassLoader getClassLoader()
返回该类的类加载器。
 Class<?> getComponentType()
返回表示数组组件类型的 Class。
 Constructor<T> getConstructor(Class<?>... parameterTypes)
返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
 Constructor<?>[] getConstructors()
返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。
 Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。
 Class<?>[] getDeclaredClasses()
返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。
 Constructor<T> getDeclaredConstructor(Class<?>... parameterTypes)
返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
 Constructor<?>[] getDeclaredConstructors()
返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。
 Field getDeclaredField(String name)
返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
 Field[] getDeclaredFields()
返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。
 Method getDeclaredMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
 Method[] getDeclaredMethods()
返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。
 Class<?> getDeclaringClass()
如果此 Class 对象所表示的类或接口是另一个类的成员，则返回的 Class 对象表示该对象的声明类。
 Class<?> getEnclosingClass()
返回底层类的立即封闭类。
 Constructor<?> getEnclosingConstructor()
如果该 Class 对象表示构造方法中的一个本地或匿名类，则返回 Constructor 对象，它表示底层类的立即封闭构造方法。
 Method getEnclosingMethod()
如果此 Class 对象表示某一方法中的一个本地或匿名类，则返回 Method 对象，它表示底层类的立即封闭方法。
 T[] getEnumConstants()
如果此 Class 对象不表示枚举类型，则返回枚举类的元素或 null。
 Field getField(String name)
返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。
 Field[] getFields()
返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。
 Type[] getGenericInterfaces()
返回表示某些接口的 Type，这些接口由此对象所表示的类或接口直接实现。
 Type getGenericSuperclass()
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的直接超类的 Type。
 Class<?>[] getInterfaces()
确定此对象所表示的类或接口实现的接口。
 Method getMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
 Method[] getMethods()
返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。
 int getModifiers()
返回此类或接口以整数编码的 Java 语言修饰符。
 String getName()
以 String 的形式返回此 Class 对象所表示的实体（类、接口、数组类、基本类型或 void）名称。
 Package getPackage()
获取此类的包。
 ProtectionDomain getProtectionDomain()
返回该类的 ProtectionDomain。
 URL getResource(String name)
查找带有给定名称的资源。
 InputStream getResourceAsStream(String name)
查找具有给定名称的资源。
 Object[] getSigners()
获取此类的标记。
 String getSimpleName()
返回源代码中给出的底层类的简称。
 Class<? super T> getSuperclass()
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的超类的 Class。
 TypeVariable<Class<T>>[] getTypeParameters()
按声明顺序返回 TypeVariable 对象的一个数组，这些对象表示用此 GenericDeclaration 对象所表示的常规声明来声明的类型变量。
 boolean isAnnotation()
如果此 Class 对象表示一个注释类型则返回 true。
 boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。
 boolean isAnonymousClass()
当且仅当底层类是匿名类时返回 true。
 boolean isArray()
判定此 Class 对象是否表示一个数组类。
 boolean isAssignableFrom(Class<?> cls)
判定此 Class 对象所表示的类或接口与指定的 Class 参数所表示的类或接口是否相同，或是否是其超类或超接口。
 boolean isEnum()
当且仅当该类声明为源代码中的枚举时返回 true。
 boolean isInstance(Object obj)
判定指定的 Object 是否与此 Class 所表示的对象赋值兼容。
 boolean isInterface()
判定指定的 Class 对象是否表示一个接口类型。
 boolean isLocalClass()
当且仅当底层类是本地类时返回 true。
 boolean isMemberClass()
当且仅当底层类是成员类时返回 true。
 boolean isPrimitive()
判定指定的 Class 对象是否表示一个基本类型。
 boolean isSynthetic()
如果此类是复合类，则返回 true，否则 false。
 T newInstance()
创建此 Class 对象所表示的类的一个新实例。
 String toString()
将对象转换为字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

toString

public String toString()
将对象转换为字符串。字符串的表示形式为字符串 "class" 或 "interface" 后面紧跟一个空格，然后是该类的完全限定名，它具有 getName 返回的那种格式。如果此 Class 对象表示一个基本类型，则此方法返回该基本类型的名称。如果该 Class 对象表示 void，则此方法返回 "void"。

覆盖：
类 Object 中的 toString
返回：
表示此 class 对象的字符串。

forName

public static Class<?> forName(String className)
                        throws ClassNotFoundException
返回与带有给定字符串名的类或接口相关联的 Class 对象。调用此方法等效于：
  Class.forName(className, true, currentLoader)
其中 currentLoader 表示当前类的定义类加载器。

例如，以下代码片段返回命名为 java.lang.Thread 的类的运行时 Class 描述符。

   Class t = Class.forName("java.lang.Thread")

调用 forName("X") 将导致命名为 X 的类被初始化。

参数：
className - 所需类的完全限定名。
返回：
具有指定名的类的 Class 对象。
抛出：
LinkageError - 如果链接失败
ExceptionInInitializerError - 如果此方法所激发的初始化失败
ClassNotFoundException - 如果无法定位该类

forName

public static Class<?> forName(String name,
                               boolean initialize,
                               ClassLoader loader)
                        throws ClassNotFoundException
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。（以 getName 所返回的格式）给定一个类或接口的完全限定名，此方法会试图定位、加载和链接该类或接口。指定的类加载器用于加载该类或接口。如果参数 loader 为 null，则该类通过引导类加载器加载。只有 initialize 参数为 true 且以前未被初始化时，才初始化该类。

如果 name 表示一个基本类型或 void，则会尝试在未命名的包中定位用户定义的名为 name 的类。因此，该方法不能用于获得表示基本类型或 void 的任何 Class 对象。

如果 name 表示一个数组类，则会加载但不初始化该数组类的组件类型。

例如，在一个实例方法中，表达式：

  Class.forName("Foo")
等效于：
  Class.forName("Foo", true, this.getClass().getClassLoader())
注意，此方法会抛出与加载、链接或初始化相关的错误，Java Language Specification 的第 12.2、12.3 和 12.4 节对此进行了详细说明。 注意，此方法不检查调用者是否可访问其请求的类。

如果 loader 为 null，也存在安全管理器，并且调用者的类加载器不为 null，则此方法通过 RuntimePermission("getClassLoader") 权限调用安全管理器的 checkPermission 方法，以确保可以访问引导类加载器。

参数：
name - 所需类的完全限定名
initialize - 是否必须初始化类
loader - 用于加载类的类加载器
返回：
表示所需类的类对象
抛出：
LinkageError - 如果链接失败
ExceptionInInitializerError - 如果该方法激发的初始化失败
ClassNotFoundException - 如果指定的类加载器无法定位该类
从以下版本开始：
1.2
另请参见：
forName(String), ClassLoader

newInstance

public T newInstance()
              throws InstantiationException,
                     IllegalAccessException
创建此 Class 对象所表示的类的一个新实例。如同用一个带有一个空参数列表的 new 表达式实例化该类。如果该类尚未初始化，则初始化这个类。

注意，此方法传播 null 构造方法所抛出的任何异常，包括已检查的异常。使用此方法可以有效地绕过编译时的异常检查，而在其他情况下编译器都会执行该检查。 Constructor.newInstance 方法将该构造方法所抛出的任何异常包装在一个（已检查的）InvocationTargetException 中，从而避免了这一问题。

返回：
此对象所表示的类的一个新分配的实例。
抛出：
IllegalAccessException - 如果该类或其 null 构造方法是不可访问的。
InstantiationException - 如果此 Class 表示一个抽象类、接口、数组类、基本类型或 void； 或者该类没有 null 构造方法； 或者由于其他某种原因导致实例化失败。
ExceptionInInitializerError - 如果该方法引发的初始化失败。
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 拒绝创建该类的新实例
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包

isInstance

public boolean isInstance(Object obj)
判定指定的 Object 是否与此 Class 所表示的对象赋值兼容。此方法是 Java 语言 instanceof 运算符的动态等效方法。如果指定的 Object 参数非空，且能够在不引发 ClassCastException 的情况下被强制转换成该 Class 对象所表示的引用类型，则该方法返回 true；否则返回 false。

特别地，当该 Class 对象表示一个已声明的类时，若指定的 Object 参数是所表示类（或其任一子类）的一个实例，则此方法返回 true；否则返回 false。如果此 Class 对象表示一个数组类，且通过身份转换或扩展引用转换，指定的 Object 参数能转换为一个数组类的对象，则返回 true；否则返回 false。如果此 Class 对象表示一个接口，且指定 Object 参数的类或任一超类实现了此接口，则此方法返回 true；否则返回 false。如果此 Class 对象表示一个基本类型，则此方法返回 false。

参数：
obj - 要检查的对象
返回：
如果 obj 是此类的实例，则返回 true
从以下版本开始：
JDK1.1

isAssignableFrom

public boolean isAssignableFrom(Class<?> cls)
判定此 Class 对象所表示的类或接口与指定的 Class 参数所表示的类或接口是否相同，或是否是其超类或超接口。如果是则返回 true；否则返回 false。如果该 Class 表示一个基本类型，且指定的 Class 参数正是该 Class 对象，则该方法返回 true；否则返回 false。

特别地，通过身份转换或扩展引用转换，此方法能测试指定 Class 参数所表示的类型能否转换为此 Class 对象所表示的类型。有关详细信息，请参阅 Java Language Specification 的第 5.1.1 和 5.1.4 节。

参数：
cls - 要检查的 Class 对象
返回：
表明 cls 类型的对象能否赋予此类对象的 boolean 值
抛出：
NullPointerException - 如果指定的 Class 参数为 null。
从以下版本开始：
JDK1.1

isInterface

public boolean isInterface()
判定指定的 Class 对象是否表示一个接口类型。

返回：
如果此对象表示一个接口，则返回 true；否则返回 false。

isArray

public boolean isArray()
判定此 Class 对象是否表示一个数组类。

返回：
如果此对象表示一个数组类，则返回 true；否则返回 false。
从以下版本开始：
JDK1.1

isPrimitive

public boolean isPrimitive()
判定指定的 Class 对象是否表示一个基本类型。

有九种预定义的 Class 对象，表示八个基本类型和 void。这些类对象由 Java 虚拟机创建，与其表示的基本类型同名，即 boolean、byte、char、short、int、long、float 和 double。

这些对象仅能通过下列声明为 public static final 的变量访问，也是使此方法返回 true 的仅有的几个 Class 对象。

返回：
当且仅当该类表示一个基本类型时，才返回 true
从以下版本开始：
JDK1.1
另请参见：
Boolean.TYPE, Character.TYPE, Byte.TYPE, Short.TYPE, Integer.TYPE, Long.TYPE, Float.TYPE, Double.TYPE, Void.TYPE

isAnnotation

public boolean isAnnotation()
如果此 Class 对象表示一个注释类型则返回 true。注意，如果此方法返回 true，则 isInterface() 也返回 true，因为所有的注释类型同时也是接口。

返回：
如果此类对象表示一个注释类型，则返回 true；否则返回 false
从以下版本开始：
1.5

isSynthetic

public boolean isSynthetic()
如果此类是复合类，则返回 true，否则 false。

返回：
当且仅当该类为复合类时才返回 true，Java 语言规范对此作了详细说明。
从以下版本开始：
1.5

getName

public String getName()
以 String 的形式返回此 Class 对象所表示的实体（类、接口、数组类、基本类型或 void）名称。

如果此类对象表示的是非数组类型的引用类型，则返回该类的二进制名称，Java Language Specification, Second Edition 对此作了详细说明。

如果此类对象表示一个基本类型或 void，则返回的名字是一个与该基本类型或 void 所对应的 Java 语言关键字相同的 String。

如果此类对象表示一个数组类，则名字的内部形式为：表示该数组嵌套深度的一个或多个 '[' 字符加元素类型名。元素类型名的编码如下：

Element Type | Encoding
boolean | Z
byte | B
char | C
class or interface | Lclassname;
double | D
float | F
int | I
long | J
short | S

类或接口名 classname 是上面指定类的二进制名称。

示例：

 String.class.getName()
     returns "java.lang.String"
 byte.class.getName()
     returns "byte"
 (new Object[3]).getClass().getName()
     returns "[Ljava.lang.Object;"
 (new int[3][4][5][6][7][8][9]).getClass().getName()
     returns "[[[[[[[I"

返回：
此对象所表示的类或接口名。

getClassLoader

public ClassLoader getClassLoader()
返回该类的类加载器。有些实现可能使用 null 来表示引导类加载器。如果该类由引导类加载器加载，则此方法在这类实现中将返回 null。

如果存在安全管理器，并且调用者的类加载器不是 null，也不同于或是请求其类加载器的类的类加载器的祖先，则此方法通过 RuntimePermission("getClassLoader") 权限调用此安全管理器的 checkPermission 方法，以确保可以访问该类的类加载器。

如果此对象表示一个基本类型或 void，则返回 null。

返回：
加载此对象所表示的类或接口的类加载器。
抛出：
SecurityException - 如果存在安全管理器，并且 checkPermission 方法拒绝对该类类加载器的访问。
另请参见：
ClassLoader, SecurityManager.checkPermission(java.security.Permission), RuntimePermission

getTypeParameters

public TypeVariable<Class<T>>[] getTypeParameters()
按声明顺序返回 TypeVariable 对象的一个数组，这些对象表示用此 GenericDeclaration 对象所表示的常规声明来声明的类型变量。如果底层常规声明不声明类型变量，则返回长度为 0 的数组。

指定者：
接口 GenericDeclaration 中的 getTypeParameters
返回：
表示该常规声明所声明的类型变量的 TypeVariable 对象的一个数组
抛出：
GenericSignatureFormatError - 如果常规声明的常规签名不符合 Java Virtual Machine Specification, 3rd edition 规定的格式
从以下版本开始：
1.5

getSuperclass

public Class<? super T> getSuperclass()
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的超类的 Class。如果此 Class 表示 Object 类、一个接口、一个基本类型或 void，则返回 null。如果此对象表示一个数组类，则返回表示该 Object 类的 Class 对象。

返回：
此对象所表示的类的超类。

getGenericSuperclass

public Type getGenericSuperclass()
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的直接超类的 Type。

如果超类是参数化类型，则返回的 Type 对象必须准确反映源代码中所使用的实际类型参数。如果以前未曾创建表示超类的参数化类型，则创建这个类型。有关参数化类型创建过程的语义，请参阅 ParameterizedType 声明。如果此 Class 表示 Object 类、接口、基本类型或 void，则返回 null。如果此对象表示一个数组类，则返回表示 Object 类的 Class 对象。

返回：
此对象所表示的类的超类
抛出：
GenericSignatureFormatError - 如果常规类签名不符合 Java Virtual Machine Specification, 3rd edition 规定的格式
TypeNotPresentException - 如果常规超类引用不存在的类型声明
MalformedParameterizedTypeException - 如果常规超类引用的参数化类型由于某种原因无法实例化
从以下版本开始：
1.5

getPackage

public Package getPackage()
获取此类的包。此类的类加载器用于查找该包。如果该类是通过引导类加载器加载的，则搜索从 CLASSPATH 加载的包的集合，以查找该类的包。如果所有包对象都不是用该类的类加载器加载的，则返回 null。

只有该类的附属清单中定义了信息，并且类加载器使用该清单中的属性创建了包实例时，包才具有版本和规范属性。

返回：
该类的包，如果存档或基本代码中没有可用的包信息，则返回 null。

getInterfaces

public Class<?>[] getInterfaces()
确定此对象所表示的类或接口实现的接口。

如果此对象表示一个类，则返回值是一个数组，它包含了表示该类所实现的所有接口的对象。数组中接口对象顺序与此对象所表示的类的声明的 implements 子句中接口名顺序一致。例如，给定声明：

 class Shimmer implements FloorWax, DessertTopping { ... }
设 s 的值为 Shimmer 的一个实例；表达式：
 s.getClass().getInterfaces()[0]
的值为表示 FloorWax 接口的 Class 对象；
 s.getClass().getInterfaces()[1]
的值为表示 DessertTopping 接口的 Class 对象。

如果此对象表示一个接口，则该数组包含表示该接口扩展的所有接口的对象。数组中接口对象顺序与此对象所表示的接口的声明的 extends 子句中接口名顺序一致。

如果此对象表示一个不实现任何接口的类或接口，则此方法返回一个长度为 0 的数组。

如果此对象表示一个基本类型或 void，则此方法返回一个长度为 0 的数组。

返回：
该类所实现的接口的一个数组。

getGenericInterfaces

public Type[] getGenericInterfaces()
返回表示某些接口的 Type，这些接口由此对象所表示的类或接口直接实现。

如果超接口是参数化类型，则为它返回的 Type 对象必须准确反映源代码中所使用的实际类型参数。如果以前未曾创建表示每个超接口的参数化类型，则创建这个类型。有关参数化类型创建过程的语义，请参阅 ParameterizedType 声明。

如果此对象表示一个类，则返回一个包含这样一些对象的数组，这些对象表示该类实现的所有接口。数组中接口对象顺序与此对象所表示的类的声明的 implements 子句中接口名顺序一致。对于数组类，接口 Cloneable 和 Serializable 以该顺序返回。

如果此对象表示一个接口，则该数组包含表示该接口直接扩展的所有接口的对象。数组中接口对象顺序与此对象所表示的接口的声明的 extends 子句中接口名顺序一致。

如果此对象表示一个不实现任何接口的类或接口，则此方法返回一个长度为 0 的数组。

如果此对象表示一个基本类型或 void，则此方法返回一个长度为 0 的数组。

返回：
此类所实现的接口的一个数组
抛出：
GenericSignatureFormatError - 如果常规类签名不符合 Java Virtual Machine Specification, 3rd edition 规定的格式
TypeNotPresentException - 如果任意常规超接口引用不存在的类型声明
MalformedParameterizedTypeException - 如果任意常规超接口引用的参数化类型由于某种原因无法实例化
从以下版本开始：
1.5

getComponentType

public Class<?> getComponentType()
返回表示数组组件类型的 Class。如果此类不表示数组类，则此方法返回 null。

返回：
如果此类是数组，则返回表示此类组件类型的 Class
从以下版本开始：
JDK1.1
另请参见：
Array

getModifiers

public int getModifiers()
返回此类或接口以整数编码的 Java 语言修饰符。修饰符由 Java 虚拟机的 public、protected、private、final、static、abstract 和 interface 对应的常量组成；它们应当使用 Modifier 类的方法来解码。

如果底层类是数组类，则其 public、private 和 protected 修饰符与其组件类型的修饰符相同。如果此 Class 表示一个基本类型或 void，则其 public 修饰符始终为 true，protected 和 private 修饰符始终为 false。如果此对象表示一个数组类、一个基本类型或 void，则其 final 修饰符始终为 true，其接口修饰符始终为 false。该规范没有给定其他修饰符的值。

Java Virtual Machine Specification 中的表 4.1 对修饰符编码进行了详细说明。

返回：
表示该类修饰符的 int
从以下版本开始：
JDK1.1
另请参见：
Modifier

getSigners

public Object[] getSigners()
获取此类的标记。

返回：
此类的标记，若无标记则返回 null。特别地，如果此对象表示一个基本类型或 void，则此方法返回 null。
从以下版本开始：
JDK1.1

getEnclosingMethod

public Method getEnclosingMethod()
如果此 Class 对象表示某一方法中的一个本地或匿名类，则返回 Method 对象，它表示底层类的立即封闭方法。否则返回 null。 特别地，如果底层类是由一个类型声明、实例初始值设定项或静态初始值设定项立即封闭的本地或匿名类，则此方法返回 null。

返回：
如果该类是本地或匿名类，则返回底层类的立即封闭方法；否则返回 null。
从以下版本开始：
1.5

getEnclosingConstructor

public Constructor<?> getEnclosingConstructor()
如果该 Class 对象表示构造方法中的一个本地或匿名类，则返回 Constructor 对象，它表示底层类的立即封闭构造方法。否则返回 null。特别地，如果底层类是由一个类型声明、实例初始值设定项或静态初始值设定项立即封闭的本地或匿名类，则此方法返回 null。

返回：
如果该类是本地或匿名类，则返回底层类的立即封闭构造方法；否则返回 null。
从以下版本开始：
1.5

getDeclaringClass

public Class<?> getDeclaringClass()
如果此 Class 对象所表示的类或接口是另一个类的成员，则返回的 Class 对象表示该对象的声明类。如果该类或接口不是其他类的成员，则此方法返回 null。如果此 Class 对象表示一个数组类、基本类型或 void，则此方法返回 null。

返回：
该类的声明类
从以下版本开始：
JDK1.1

getEnclosingClass

public Class<?> getEnclosingClass()
返回底层类的立即封闭类。如果底层类是顶层类，则此方法返回 null。

返回：
底层类的立即封闭类
从以下版本开始：
1.5

getSimpleName

public String getSimpleName()
返回源代码中给出的底层类的简称。如果底层类是匿名的则返回一个空字符串。

数组的简称即附带 "[]" 的组件类型的简称。特别地，组件类型为匿名的数组的简称是 "[]"。

返回：
底层类的简称
从以下版本开始：
1.5

getCanonicalName

public String getCanonicalName()
返回 Java Language Specification 中所定义的底层类的规范化名称。如果底层类没有规范化名称（即如果底层类是一个组件类型没有规范化名称的本地类、匿名类或数组），则返回 null。

返回：
底层类的规范化名称（如果存在的话）；否则返回 null。
从以下版本开始：
1.5

isAnonymousClass

public boolean isAnonymousClass()
当且仅当底层类是匿名类时返回 true。

返回：
当且仅当此类是匿名类时，才返回 true。
从以下版本开始：
1.5

isLocalClass

public boolean isLocalClass()
当且仅当底层类是本地类时返回 true。

返回：
当且仅当该类是本地类时，才返回 true。
从以下版本开始：
1.5

isMemberClass

public boolean isMemberClass()
当且仅当底层类是成员类时返回 true。

返回：
当且仅当该类是成员类时，才返回 true。
从以下版本开始：
1.5

getClasses

public Class<?>[] getClasses()
返回一个包含某些 Class 对象的数组，这些对象表示属于此 Class 对象所表示的类的成员的所有公共类和接口。包括从超类继承的公共类和接口成员以及该类声明的公共类和接口成员。如果此 Class 对象没有公共成员类或接口，则此方法返回一个长度为 0 的数组。如果此 Class 对象表示一个基本类型、一个数组类或 void，则此方法也返回一个长度为 0 的数组。

返回：
表示该类公共成员的 Class 对象的数组
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 方法拒绝访问该类中的类
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getFields

public Field[] getFields()
                  throws SecurityException
返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。返回数组中的元素没有排序，也没有任何特定的顺序。如果类或接口没有可访问的公共字段，或者表示一个数组类、一个基本类型或 void，则此方法返回长度为 0 的数组。

特别地，如果该 Class 对象表示一个类，则此方法返回该类及其所有超类的公共字段。如果该 Class 对象表示一个接口，则此方法返回该接口及其所有超接口的公共字段。

该方法不反映数组类的隐式长度字段。用户代码应使用 Array 类的方法来操作数组。

请参阅 Java Language Specification 的第 8.2 和 8.3 节。

返回：
表示公共字段的 Field 对象的数组
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 拒绝访问该类中的字段
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getMethods

public Method[] getMethods()
                    throws SecurityException
返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。数组类返回从 Object 类继承的所有（公共）member 方法。返回数组中的元素没有排序，也没有任何特定的顺序。如果此 Class 对象表示没有公共成员方法的类或接口，或者表示一个基本类型或 void，则此方法返回长度为 0 的数组。

类初始化方法 <clinit> 不包含在返回的数组中。如果类声明了带有相同参数类型的多个公共成员方法，则它们都会包含在返回的数组中。

请参阅 Java Language Specification 的第 8.2 和 8.4 节。

返回：
表示此类中公共方法的 Method 对象的数组
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 拒绝访问该类中的方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getConstructors

public Constructor<?>[] getConstructors()
                                 throws SecurityException
返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。如果该类没有公共构造方法，或者该类是一个数组类，或者该类反映一个基本类型或 void，则返回一个长度为 0 的数组。 注意，此方法返回 Constructor<T> 对象的数组（即取自此类构造方法的数组）时，此方法的返回类型是 Constructor<?>[]，不是 预期的 Constructor<T>[]。此少量信息的返回类型是必需的，因为从此方法返回之后，该数组可能被修改以保存不同类的 Constructor 对象，而这将违反 Constructor<T>[] 的类型保证。

返回：
表示此类公共构造方法的 Constructor 对象数组
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 拒绝访问该类中的构造方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getField

public Field getField(String name)
               throws NoSuchFieldException,
                      SecurityException
返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。name 参数是一个 String，用于指定所需字段的简称。

要反映的字段由下面的算法确定。设 C 为此对象所表示的类：

  1. 如果 C 声明一个带有指定名的公共字段，则它就是要反映的字段。
  2. 如果在第 1 步中没有找到任何字段，则该算法被递归地应用于 C 的每一个直接超接口。直接超接口按其声明顺序进行搜索。
  3. 如果在第 1、2 两步没有找到任何字段，且 C 有一个超类 S，则在 S 上递归调用该算法。如果 C 没有超类，则抛出 NoSuchFieldException。

请参阅 Java Language Specification 的第 8.2 和 8.3 节。

参数：
name - 字段名
返回：
由 name 指定的该类的 Field 对象
抛出：
NoSuchFieldException - 如果没有找到带有指定名的字段。
NullPointerException - 如果 name 为 null
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 拒绝访问字段
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getMethod

public Method getMethod(String name,
                        Class<?>... parameterTypes)
                 throws NoSuchMethodException,
                        SecurityException
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。name 参数是一个 String，用于指定所需方法的简称。parameterTypes 参数是按声明顺序标识该方法形参类型的 Class 对象的一个数组。如果 parameterTypes 为 null，则按空数组处理。

如果 name 是 "<init>;" 或 "<clinit>"，则将引发 NoSuchMethodException。否则，要反映的方法由下面的算法确定（设 C 为此对象所表示的类）：

  1. 在 C 中搜索任一匹配的方法。如果找不到匹配的方法，则将在 C 的超类上递归调用第 1 步算法。
  2. 如果在第 1 步中没有找到任何方法，则在 C 的超接口中搜索匹配的方法。如果找到了这样的方法，则反映该方法。
在 C 类中查找匹配的方法：如果 C 正好声明了一个具有指定名称的公共方法并且恰恰有相同的形参类型，则它就是反映的方法。如果在 C 中找到了多个这样的方法，并且其中有一个方法的返回类型比其他方法的返回类型都特殊，则反映该方法；否则将从中任选一个方法。

注意，类中可以有多个匹配方法，因为尽管 Java 语言禁止类声明带有相同签名但不同返回类型的多个方法，但 Java 虚拟机并不禁止。这增加了虚拟机的灵活性，可以用来实现各种语言特性。例如，可以使用桥方法 (brige method)实现协变返回；桥方法以及将被重写的方法将具有相同的签名，不同的返回类型。

请参阅Java 语言规范 第 8.2 和 8.4 节。

参数：
name - 方法名
parameterTypes - 参数列表
返回：
与指定的 name 和 parameterTypes 匹配的 Method 对象
抛出：
NoSuchMethodException - 如果找不到匹配的方法，或者方法名为 "<init>" 或 "<clinit>"
NullPointerException - 如果 name 为 null
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 拒绝访问方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getConstructor

public Constructor<T> getConstructor(Class<?>... parameterTypes)
                              throws NoSuchMethodException,
                                     SecurityException
返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。parameterTypes 参数是 Class 对象的一个数组，这些 Class 对象按声明顺序标识构造方法的形参类型。 如果此 Class 对象表示非静态上下文中声明的内部类，则形参类型作为第一个参数包括显示封闭的实例。

要反映的构造方法是此 Class 对象所表示的类的公共构造方法，其形参类型与 parameterTypes 所指定的参数类型相匹配。

参数：
parameterTypes - 参数数组
返回：
与指定的 parameterTypes 相匹配的公共构造方法的 Constructor 对象
抛出：
NoSuchMethodException - 如果找不到匹配的方法。
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.PUBLIC) 拒绝访问构造方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getDeclaredClasses

public Class<?>[] getDeclaredClasses()
                              throws SecurityException
返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。包括该类所声明的公共、保护、默认（包）访问及私有类和接口，但不包括继承的类和接口。如果该类不将任何类或接口声明为成员，或者此 Class 对象表示基本类型、数组类或 void，则此方法返回一个长度为 0 的数组。

返回：
Class 对象的数组，表示该类的所有 declared 成员
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.DECLARED) 拒绝访问此类中已声明的类
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问此类的包
从以下版本开始：
JDK1.1

getDeclaredFields

public Field[] getDeclaredFields()
                          throws SecurityException
返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。包括公共、保护、默认（包）访问和私有字段，但不包括继承的字段。 返回数组中的元素没有排序，也没有任何特定的顺序。如果该类或接口不声明任何字段，或者此 Class 对象表示一个基本类型、一个数组类或 void，则此方法返回一个长度为 0 的数组。

请参阅 Java Language Specification 的第 8.2 和 8.3 节。

返回：
表示此类所有已声明字段的 Field 对象的数组
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.DECLARED) 拒绝访问此类中已声明的字段
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getDeclaredMethods

public Method[] getDeclaredMethods()
                            throws SecurityException
返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。 返回数组中的元素没有排序，也没有任何特定的顺序。如果该类或接口不声明任何方法，或者此 Class 对象 表示一个基本类型、一个数组类或 void，则此方法返回一个长度为 0 的数组。类初始化方法 <clinit> 不包含在返回数组中。如果该类声明带有相同参数类型的多个公共成员方法，则它们都包含在返回的数组中。

请参阅 Java Language Specification 第 8.2 节。

返回：
表示此类所有声明方法的 Method 对象的数组
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.DECLARED) 拒绝访问该类中已声明的方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getDeclaredConstructors

public Constructor<?>[] getDeclaredConstructors()
                                         throws SecurityException
返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。它们是公共、保护、默认（包）访问和私有构造方法。返回数组中的元素没有排序，也没有任何特定的顺序。如果该类存在一个默认构造方法，则它包含在返回的数组中。 如果此 Class 对象表示一个接口、一个基本类型、一个数组类或 void，则此方法返回一个长度为 0 的数组。

请参阅 Java Language Specification 第 8.2 节。

返回：
表示此类所有已声明的构造方法的 Constructor 对象的数组
抛出：
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.DECLARED) 拒绝访问该类中已声明的构造方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问此类的包
从以下版本开始：
JDK1.1

getDeclaredField

public Field getDeclaredField(String name)
                       throws NoSuchFieldException,
                              SecurityException
返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。name 参数是一个 String，它指定所需字段的简称。注意，此方法不反映数组类的 length 字段。

参数：
name - 字段名
返回：
此类中指定字段的 Field 对象
抛出：
NoSuchFieldException - 如果找不到带有指定名称的字段。
NullPointerException - 如果 name 为 null
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.DECLARED) 拒绝访问已声明字段
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getDeclaredMethod

public Method getDeclaredMethod(String name,
                                Class<?>... parameterTypes)
                         throws NoSuchMethodException,
                                SecurityException
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。name 参数是一个 String，它指定所需方法的简称，parameterTypes 参数是 Class 对象的一个数组，它按声明顺序标识该方法的形参类型。如果在某个类中声明了带有相同参数类型的多个方法，并且其中有一个方法的返回类型比其他方法的返回类型都特殊，则返回该方法；否则将从中任选一个方法。如果名称是 "<init>” 或 “<clinit>"，则引发一个 NoSuchMethodException。

参数：
name - 方法名
parameterTypes - 参数数组
返回：
该类与指定名和参数相匹配的方法的 Method 对象
抛出：
NoSuchMethodException - 如果找不到匹配的方法。
NullPointerException - 如果 name 为 null
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.DECLARED) 拒绝访问已声明方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getDeclaredConstructor

public Constructor<T> getDeclaredConstructor(Class<?>... parameterTypes)
                                      throws NoSuchMethodException,
                                             SecurityException
返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。parameterTypes 参数是 Class 对象的一个数组，它按声明顺序标识构造方法的形参类型。 如果此 Class 对象表示非静态上下文中声明的内部类，则形参类型作为第一个参数包括显示封闭的实例。

参数：
parameterTypes - 参数数组
返回：
带有指定参数列表的构造方法的 Constructor 对象
抛出：
NoSuchMethodException - 如果找不到匹配的方法。
SecurityException - 如果存在安全管理器 s，并满足下列任一条件：
  • 调用 s.checkMemberAccess(this, Member.DECLARED) 拒绝访问已声明的构造方法
  • 调用者的类加载器不同于也不是当前类的类加载器的一个祖先，并且对 s.checkPackageAccess() 的调用拒绝访问该类的包
从以下版本开始：
JDK1.1

getResourceAsStream

public InputStream getResourceAsStream(String name)
查找具有给定名称的资源。查找与给定类相关的资源的规则是通过定义类的 class loader 实现的。此方法委托此对象的类加载器。如果此对象通过引导类加载器加载，则此方法将委托给 ClassLoader.getSystemResourceAsStream(java.lang.String)。

在委托前，使用下面的算法从给定的资源名构造一个绝对资源名：

  • 如果 name 以 '/' 开始 ('\u002f')，则绝对资源名是 '/' 后面的 name 的一部分。
  • 否则，绝对名具有以下形式：
       modified_package_name/name

    其中 modified_package_name 是此对象的包名，该名用 '/' 取代了 '.' ('\u002e')。

参数：
name - 所需资源的名称
返回：
一个 InputStream 对象；如果找不到带有该名称的资源，则返回 null
抛出：
NullPointerException - 如果 name 是 null
从以下版本开始：
JDK1.1

getResource

public URL getResource(String name)
查找带有给定名称的资源。查找与给定类相关的资源的规则是通过定义类的 class loader 实现的。此方法委托给此对象的类加载器。如果此对象通过引导类加载器加载，则此方法将委托给 ClassLoader.getSystemResource(java.lang.String)。

在委托前，使用下面的算法从给定的资源名构造一个绝对资源名：

  • 如果 name 以 '/' ('\u002f') 开始，则绝对资源名是 '/' 后面的 name 的一部分。
  • 否则，绝对名具有以下形式：
       modified_package_name/name

    其中 modified_package_name 是此对象的包名，该名用 '/' 取代了 '.' ('\u002e')。

参数：
name - 所需资源的名称
返回：
一个 URL 对象；如果找不到带有该名称的资源，则返回 null
从以下版本开始：
JDK1.1

getProtectionDomain

public ProtectionDomain getProtectionDomain()
返回该类的 ProtectionDomain。如果安装了安全管理器，则此方法首先通过 RuntimePermission("getProtectionDomain") 权限调用安全管理器的 checkPermission 方法，以确保可以获取 ProtectionDomain。

返回：
该类的 ProtectionDomain
抛出：
SecurityException - 若安全管理器存在，并且其 checkPermission 方法不允许获取 ProtectionDomain。
从以下版本开始：
1.2
另请参见：
ProtectionDomain, SecurityManager.checkPermission(java.security.Permission), RuntimePermission

desiredAssertionStatus

public boolean desiredAssertionStatus()
如果要在调用此方法时将要初始化该类，则返回将分配给该类的断言状态。 如果已经设置了该类的断言状态，则返回其最新设置；如果有包默认断言状态属于此类，则返回最特殊的相关包默认断言状态的最新设置；如果该类不是系统类（即它有类加载器），则返回其类加载器的默认断言状态；否则返回系统类默认断言状态。

很少有程序员需要此方法；它是为 JRE 自身提供的。（它使类能够在初始化时确定是否启用断言。）注意，不保证此方法在（或将要）初始化指定类时返回与（或将与）该指定类相关的实际断言状态。

返回：
所需的指定类断言状态。
从以下版本开始：
1.4
另请参见：
ClassLoader.setClassAssertionStatus(java.lang.String, boolean),
ClassLoader.setPackageAssertionStatus(java.lang.String, boolean),
ClassLoader.setDefaultAssertionStatus(boolean)

isEnum

public boolean isEnum()
当且仅当该类声明为源代码中的枚举时返回 true。

返回：
当且仅当该类声明为源代码中的枚举时返回 true
从以下版本开始：
1.5

getEnumConstants

public T[] getEnumConstants()
如果此 Class 对象不表示枚举类型，则返回枚举类的元素或 null。

返回：
以声明顺序返回一个数组，该数组包含构成此 Class 对象所表示的枚举类的值，或者在此 Class 对象不表示枚举类型时返回 null
从以下版本开始：
1.5

cast

public T cast(Object obj)
将一个对象强制转换成此 Class 对象所表示的类或接口。

参数：
obj - 要强制转换的对象
返回：
强制转换返回该对象，若 obj 为 null 则返回 null
抛出：
ClassCastException - 如果该对象不是 null 也不能分配给类型 T。
从以下版本开始：
1.5

asSubclass

public <U> Class<? extends U> asSubclass(Class<U> clazz)
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。检查强制转换的有效性，如果无效则抛出 ClassCastException。如果此方法成功了，它将始终返回对此 class 对象的一个引用。

此方法的使用场合为：客户端需要“收缩转换” Class 对象的类型，以便将其传递给某个 API，且该 API 对它愿意接受的 Class 对象进行限制。强制转换会产生一个编译时警告，因为强制转换的正确性无法在运行时检查（因为常规类型是通过擦除实现的）。

返回：
此 Class 对象，它被强制转换以表示指定类对象的子类。
抛出：
ClassCastException - 如果该 Class 对象不表示指定类的子类（这里“子类”包括该类本身）。
从以下版本开始：
1.5

getAnnotation

public <A extends Annotation> A getAnnotation(Class<A> annotationClass)
从接口 AnnotatedElement 复制的描述
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

指定者：
接口 AnnotatedElement 中的 getAnnotation
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果该元素的指定注释类型的注释存在于此对象上，则返回这些注释，否则返回 null
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

isAnnotationPresent

public boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
从接口 AnnotatedElement 复制的描述
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。此方法主要是为了便于访问标记注释而设计的。

指定者：
接口 AnnotatedElement 中的 isAnnotationPresent
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果指定注释类型的注释存在于此对象上，则返回 true，否则返回 false
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getAnnotations

public Annotation[] getAnnotations()
从接口 AnnotatedElement 复制的描述
返回此元素上存在的所有注释。（如果此元素没有注释，则返回长度为零的数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getAnnotations
返回：
此元素上存在的所有注释
从以下版本开始：
1.5

getDeclaredAnnotations

public Annotation[] getDeclaredAnnotations()
从接口 AnnotatedElement 复制的描述
返回直接存在于此元素上的所有注释。与此接口中的其他方法不同，该方法将忽略继承的注释。（如果没有注释直接存在于此元素上，则返回长度为零的一个数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getDeclaredAnnotations
返回：
直接存在于此元素上的所有注释
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassCastException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ClassCastException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.ClassCastException
所有已实现的接口：
Serializable
public class ClassCastException
extends RuntimeException

当试图将对象强制转换为不是实例的子类时，抛出该异常。例如，以下代码将生成一个 ClassCastException：

     Object x = new Integer(0);
     System.out.println((String)x);

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
ClassCastException()
构造不带详细消息的 ClassCastException。
ClassCastException(String s)
构造带指定详细消息的 ClassCastException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClassCastException

public ClassCastException()
构造不带详细消息的 ClassCastException。

ClassCastException

public ClassCastException(String s)
构造带指定详细消息的 ClassCastException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassCircularityError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ClassCircularityError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.ClassCircularityError
所有已实现的接口：
Serializable
public class ClassCircularityError
extends LinkageError

当初始化类时检测到类的循环调用的时候，抛出该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
ClassCircularityError()
构造不带详细消息的 ClassCircularityError。
ClassCircularityError(String s)
构造带指定详细消息的 ClassCircularityError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClassCircularityError

public ClassCircularityError()
构造不带详细消息的 ClassCircularityError。

ClassCircularityError

public ClassCircularityError(String s)
构造带指定详细消息的 ClassCircularityError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassFormatError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ClassFormatError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.ClassFormatError
所有已实现的接口：
Serializable
直接已知子类：
GenericSignatureFormatError, UnsupportedClassVersionError
public class ClassFormatError
extends LinkageError

当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
ClassFormatError()
构造不带详细消息的 ClassFormatError。
ClassFormatError(String s)
构造带指定详细消息的 ClassFormatError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClassFormatError

public ClassFormatError()
构造不带详细消息的 ClassFormatError。

ClassFormatError

public ClassFormatError(String s)
构造带指定详细消息的 ClassFormatError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassLoader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ClassLoader

java.lang.Object
    继承者  java.lang.ClassLoader
直接已知子类：
SecureClassLoader
public abstract class ClassLoader
extends Object

类加载器是负责加载类的对象。ClassLoader 类是一个抽象类。如果给定类的二进制名称，那么类加载器会试图查找或生成构成类定义的数据。一般策略是将名称转换为某个文件名，然后从文件系统读取该名称的“类文件”。

每个 Class 对象都包含一个对定义它的 ClassLoader 的引用。

数组类的 Class 对象不是由类加载器创建的，而是由 Java 运行时根据需要自动创建。数组类的类加载器由 Class.getClassLoader() 返回，该加载器与其元素类型的类加载器是相同的；如果该元素类型是基本类型，则该数组类没有类加载器。

应用程序需要实现 ClassLoader 的子类，以扩展 Java 虚拟机动态加载类的方式。

类加载器通常由安全管理器使用，用于指示安全域。

ClassLoader 类使用委托模型来搜索类和资源。每个 ClassLoader 实例都有一个相关的父类加载器。需要查找类或资源时，ClassLoader 实例会在试图亲自查找类或资源之前，将搜索类或资源的任务委托给其父类加载器。虚拟机的内置类加载器（称为 "bootstrap class loader"）本身没有父类加载器，但是可以将它用作 ClassLoader 实例的父类加载器。

通常情况下，Java 虚拟机以与平台有关的方式，从本地文件系统中加载类。例如，在 UNIX 系统中，虚拟机从 CLASSPATH 环境变量定义的目录中加载类。

然而，有些类可能并非源自一个文件；它们可能源自其他来源（如网络），也可能是由应用程序构造的。defineClass 方法将一个 byte 数组转换为 Class 类的实例。这种新定义的类的实例可以使用 Class.newInstance 来创建。

类加载器所创建对象的方法和构造方法可以引用其他类。为了确定引用的类，Java 虚拟机将调用最初创建该类的类加载器的 loadClass 方法。

例如，应用程序可以创建一个网络类加载器，从服务器中下载类文件。示例代码如下所示：

   ClassLoader loader = new NetworkClassLoader(host, port);
   Object main = loader.loadClass("Main", true).newInstance();
          . . .

网络类加载器子类必须定义方法 findClass 和 loadClassData，以实现从网络加载类。下载组成该类的字节后，它应该使用方法 defineClass 来创建类实例。示例实现如下：

     class NetworkClassLoader extends ClassLoader {
         String host;
         int port;

         public Class findClass(String name) {
             byte[] b = loadClassData(name);
             return defineClass(name, b, 0, b.length);
         }

         private byte[] loadClassData(String name) {
             // load the class data from the connection
              . . .
         }
     }

二进制名称

按照《Java Language Specification》的定义，任何作为 String 类型参数传递给 ClassLoader 中方法的类名称都必须是一个二进制名称。

有效类名称的示例包括：

   "java.lang.String"
   "javax.swing.JSpinner$DefaultEditor"
   "java.security.KeyStore$Builder$FileBuilder$1"
   "java.net.URLClassLoader$3$1"

从以下版本开始：
1.0
另请参见：
resolveClass(Class)

构造方法摘要
protected ClassLoader()
使用方法 getSystemClassLoader() 返回的 ClassLoader 创建一个新的类加载器，将该加载器作为父类加载器。
protected ClassLoader(ClassLoader parent)
使用指定的、用于委托操作的父类加载器创建新的类加载器。
方法摘要
 void clearAssertionStatus()
将此类加载器的默认断言状态设置为 false，并放弃与此类加载器关联的所有默认包或类断言状态设置。
protected  Class<?> defineClass(byte[] b, int off, int len)
已过时。 由 defineClass(String, byte[], int, int) 取代
protected  Class<?> defineClass(String name, byte[] b, int off, int len)
将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。
protected  Package definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
根据 name 在此 ClassLoader 中定义包。
protected  Class<?> findClass(String name)
使用指定的二进制名称查找类。
protected  String findLibrary(String libname)
返回本机库的绝对路径名。
protected  Class<?> findLoadedClass(String name)
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。
protected  URL findResource(String name)
查找具有给定名称的资源。
protected  Enumeration<URL> findResources(String name)
返回表示所有具有给定名称的资源的 URL 对象的枚举。
protected  Class<?> findSystemClass(String name)
查找具有指定的二进制名称的类，必要时加载它。
protected  Package getPackage(String name)
返回由此类加载器或其任何祖先所定义的 Package。
protected  Package[] getPackages()
返回此类加载器及其祖先所定义的所有 Package。
 ClassLoader getParent()
返回委托的父类加载器。
 URL getResource(String name)
查找具有给定名称的资源。
 InputStream getResourceAsStream(String name)
返回读取指定资源的输入流。
 Enumeration<URL> getResources(String name)
查找所有给定名称的资源。
static ClassLoader getSystemClassLoader()
返回委托的系统类加载器。
static URL getSystemResource(String name)
从用来加载类的搜索路径中查找具有指定名称的资源。
static InputStream getSystemResourceAsStream(String name)
从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。
static Enumeration<URL> getSystemResources(String name)
从用来加载类的搜索路径中查找所有具有指定名称的资源。
 Class<?> loadClass(String name)
使用指定的二进制名称来加载类。
protected  Class<?> loadClass(String name, boolean resolve)
使用指定的二进制名称来加载类。
protected  void resolveClass(Class<?> c)
链接指定的类。
 void setClassAssertionStatus(String className, boolean enabled)
设置在此类加载器及其包含的嵌套类中指定的最高层类所需的断言状态。
 void setDefaultAssertionStatus(boolean enabled)
设置此类加载器的默认断言状态。
 void setPackageAssertionStatus(String packageName, boolean enabled)
为指定包设置默认断言状态。
protected  void setSigners(Class<?> c, Object[] signers)
设置类的签署者。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassLoader

protected ClassLoader(ClassLoader parent)
使用指定的、用于委托操作的父类加载器创建新的类加载器。

如果存在安全管理器，则调用其 checkCreateClassLoader 方法。这可能导致安全性异常。

参数：
parent - 父类加载器
抛出：
SecurityException - 如果存在安全管理器并且其 checkCreateClassLoader 方法不允许创建新的类加载器。
从以下版本开始：
1.2

ClassLoader

protected ClassLoader()
使用方法 getSystemClassLoader() 返回的 ClassLoader 创建一个新的类加载器，将该加载器作为父类加载器。

如果存在安全管理器，则调用其 checkCreateClassLoader 方法。这可能导致安全性异常。

抛出：
SecurityException - 如果存在安全管理器并且其 checkCreateClassLoader 方法不允许创建新的类加载器。
方法详细信息

loadClass

public Class<?> loadClass(String name)
                   throws ClassNotFoundException
使用指定的二进制名称来加载类。此方法使用与 loadClass(String, boolean) 方法相同的方式搜索类。Java 虚拟机调用它来分析类引用。调用此方法等效于调用 loadClass(name, false)。

参数：
name - 类的二进制名称
返回：
得到的 Class 对象
抛出：
ClassNotFoundException - 如果没有找到类

loadClass

protected Class<?> loadClass(String name,
                             boolean resolve)
                      throws ClassNotFoundException
使用指定的二进制名称来加载类。此方法的默认实现将按以下顺序搜索类：

  1. 调用 findLoadedClass(String) 来检查是否已经加载类。

  2. 在父类加载器上调用 loadClass 方法。如果父类加载器为 null，则使用虚拟机的内置类加载器。

  3. 调用 findClass(String) 方法查找类。

如果使用上述步骤找到类，并且 resolve 标志为真，则此方法将在得到的 Class 对象上调用 resolveClass(Class) 方法。

鼓励用 ClassLoader 的子类重写 findClass(String)，而不是使用此方法。

参数：
name - 类的二进制名称
resolve - 如果该参数为 true，则分析这个类
返回：
得到的 Class 对象
抛出：
ClassNotFoundException - 如果无法找到类

findClass

protected Class<?> findClass(String name)
                      throws ClassNotFoundException
使用指定的二进制名称查找类。此方法应该被类加载器的实现重写，该实现按照委托模型来加载类。在通过父类加载器检查所请求的类后，此方法将被 loadClass 方法调用。默认实现抛出一个 ClassNotFoundException。

参数：
name - 类的二进制名称
返回：
得到的 Class 对象
抛出：
ClassNotFoundException - 如果无法找到类
从以下版本开始：
1.2

defineClass

@Deprecated
protected final Class<?> defineClass(byte[] b,
                                                int off,
                                                int len)
                              throws ClassFormatError
已过时。 由 defineClass(String, byte[], int, int) 取代

将一个 byte 数组转换为 Class 类的实例。必须分析 Class，然后才能使用它。此方法已废弃，新版本将二进制名称作为该类的第一个参数，后者更加安全。

参数：
b - 组成类数据的字节。off 与 off+len-1 之间的字节应该具有《Java Virtual Machine Specification》定义的有效类文件的格式。
off - 类数据的 b 中的起始偏移量
len - 类数据的长度
返回：
从指定类数据创建的 Class 对象
抛出：
ClassFormatError - 如果数据不包含有效类
IndexOutOfBoundsException - 如果 off 或 len 为负，或者 off+len 大于 b.length。
另请参见：
loadClass(String, boolean), resolveClass(Class)

defineClass

protected final Class<?> defineClass(String name,
                                     byte[] b,
                                     int off,
                                     int len)
                              throws ClassFormatError
将一个 byte 数组转换为 Class 类的实例。必须分析 Class，然后才能使用它。

此方法将默认的 ProtectionDomain 分配给新定义的类。调用 Policy.getPolicy().getPermissions(new CodeSource(null, null)) 时，ProtectionDomain 被有效授予所返回的相同权限集。默认域在第一次调用 defineClass 时创建，并在后续调用时被重用。

要将特定的 ProtectionDomain 分配给类，需要使用 defineClass 方法，该方法将 ProtectionDomain 用作其参数之一。

参数：
name - 所需要的类的二进制名称，如果不知道此名称，则该参数为 null
b - 组成类数据的字节。off 与 off+len-1 之间的字节应该具有《Java Virtual Machine Specification》定义的有效类文件的格式。
off - 类数据的 b 中的起始偏移量
len - 类数据的长度
返回：
从指定类数据中创建的 Class 对象。
抛出：
ClassFormatError - 如果数据不包含有效类
IndexOutOfBoundsException - 如果 off 或 len 为负，或者 off+len 大于 b.length。
SecurityException - 如果试图将此类添加到包含由不同证书集签名的类（而不是此类，此类未签名）的包中，或者 name 以 "java." 开头。
从以下版本开始：
1.1
另请参见：
loadClass(String, boolean), resolveClass(Class), CodeSource, SecureClassLoader

defineClass

protected final Class<?> defineClass(String name,
                                     byte[] b,
                                     int off,
                                     int len,
                                     ProtectionDomain protectionDomain)
                              throws ClassFormatError
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。如果该域为 null，则将默认域分配给 defineClass(String, byte[], int, int) 的文档中指定的类。这个类必须分析后才能使用。

包中定义的第一个类确定在该包中定义的所有后续类必须包含的证书的确切集合。从该类的 ProtectionDomain 中的 CodeSource 可以获得类的证书集合。添加到该包中的任何类都必须包含相同的证书集合，否则抛出 SecurityException 异常。注意，如果 name 为 null，则不执行该检查。应该始终传入要定义的类的二进制名称以及字节。这可确保定义该类的正确性。

指定的 name 不能以 "java." 开头，因为 "java.*" 包中的所有类都只能由引导类加载器定义。如果 name 不是 null，则它必定等于由 byte 数组 "b" 指定的类的二进制名称，否则将抛出 NoClassDefFoundError。

参数：
name - 所需类的二进制名称，如果不知道此名称，则该参数为 null
b - 组成类数据的字节。从 off 到 off+len-1 的字节应该具有由《Java Virtual Machine Specification》定义的有效类文件的格式。
off - 类数据的 b 中的起始偏移量
len - 类数据的长度
protectionDomain - 类的 ProtectionDomain
返回：
从数据中创建的 Class 对象和可选的 ProtectionDomain。
抛出：
ClassFormatError - 如果数据不包含有效的类
NoClassDefFoundError - 如果 name 不等于 b 指定的类的二进制名称。
IndexOutOfBoundsException - 如果 off 或者 len 为负，或者 off+len 大于 b.length。
SecurityException - 如果试图将此类添加到某个包中，而这个包中包含由不同证书集合（而不是该类）签名的类，或者 name 以 "java." 开头。

defineClass

protected final Class<?> defineClass(String name,
                                     ByteBuffer b,
                                     ProtectionDomain protectionDomain)
                              throws ClassFormatError
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。如果该域为 null，则将默认域分配给 defineClass(String, byte[], int, int) 的文档中指定的类。这个类必须分析后才能使用。

有关包中定义的第一个类（它确定了包的证书集合）的规则，以及对类名称的限制，都与 defineClass(String, byte[], int, int, ProtectionDomain) 的文档中指定的相同。

调用形式为 cl.defineClass(name, bBuffer, pd) 的此方法所产生的结果与以下语句产生的结果相同

...
byte[] temp = new byte[bBuffer.remaining()];
bBuffer.get(temp);
return cl.defineClass (name, temp, 0, temp.length, pd);

参数：
name - 所需要的类的二进制名称，如果不知道此名称，则该参数为 null
b - 组成类数据的字节。从 b.position 到 b.position() + b.limit() -1 的字节应该具有由《Java Virtual Machine Specification》定义的有效类文件的格式。
protectionDomain - 类的 ProtectionDomain，或为 null。
返回：
从数据中创建的 Class 对象和可选的 ProtectionDomain。
抛出：
ClassFormatError - 如果数据不包含有效的类。
NoClassDefFoundError - 如果 name 不等于 b 指定的类的二进制名称。
SecurityException - 如果试图将此类添加到某个包中，而这个包中包含由不同证书集合（而不是该类）签名的类，或者 name 以 "java." 开头。
从以下版本开始：
1.5
另请参见：
defineClass(String, byte[], int, int, ProtectionDomain)

resolveClass

protected final void resolveClass(Class<?> c)
链接指定的类。类加载器可以使用此方法（其名称容易使人误解）来链接类。如果已经链接类 c，则仅返回此方法。否则，该类就按《Java Language Specification》中 "Execution" 一章所描述的进行链接。

参数：
c - 要链接的类
抛出：
NullPointerException - 如果 c 为 null。
另请参见：
defineClass(String, byte[], int, int)

findSystemClass

protected final Class<?> findSystemClass(String name)
                                  throws ClassNotFoundException
查找具有指定的二进制名称的类，必要时加载它。

此方法通过系统类加载器（参见 getSystemClassLoader()）来加载该类。返回的 Class 对象具有多个与之相关联的 ClassLoader。ClassLoader 的子类通常不必调用此方法，因为大多数类加载器只需重写 findClass(String) 即可。

参数：
name - 类的二进制名称
返回：
指定 name 的 Class 对象
抛出：
ClassNotFoundException - 如果找不到类
另请参见：
ClassLoader(ClassLoader), getParent()

findLoadedClass

protected final Class<?> findLoadedClass(String name)
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。否则，返回 null。

参数：
name - 类的二进制名称
返回：
Class 对象，如果类没有被加载，则返回 null
从以下版本开始：
1.1

setSigners

protected final void setSigners(Class<?> c,
                                Object[] signers)
设置类的签署者。应该在定义类后调用此方法。

参数：
c - Class 对象
signers - 类的签署者
从以下版本开始：
1.1

getResource

public URL getResource(String name)
查找具有给定名称的资源。资源是可以通过类代码以与代码基无关的方式访问的一些数据（图像、声音、文本等）。

资源名称是以 '/' 分隔的标识资源的路径名称。

此方法首先搜索资源的父类加载器；如果父类加载器为 null，则搜索的路径就是虚拟机的内置类加载器的路径。如果搜索失败，则此方法将调用 findResource(String) 来查找资源。

参数：
name - 资源名称
返回：
读取资源的 URL 对象；如果找不到该资源，或者调用者没有足够的权限获取该资源，则返回 null。
从以下版本开始：
1.1

getResources

public Enumeration<URL> getResources(String name)
                              throws IOException
查找所有给定名称的资源。资源是可以通过类代码以与代码基无关的方式访问的某些数据（图像、声音、文本等）。

资源名称是以 '/' 分隔的标识资源的路径名称。

getResource(String) 的文档中描述了搜索顺序。

参数：
name - 资源名称
返回：
资源的 URL 对象的枚举。如果找不到资源，则该枚举将为空。类加载器无权访问的资源不在此枚举中。
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
1.2
另请参见：
findResources(String)

findResource

protected URL findResource(String name)
查找具有给定名称的资源。类加载器实现应该重写此方法，以指定从何处查找资源。

参数：
name - 资源名称
返回：
用于读取资源的 URL 对象；如果无法找到资源，则返回 null
从以下版本开始：
1.2

findResources

protected Enumeration<URL> findResources(String name)
                                  throws IOException
返回表示所有具有给定名称的资源的 URL 对象的枚举。类加载器实现应该重写此方法，以指定从何处加载资源。

参数：
name - 资源名称
返回：
资源的 URL 对象的枚举
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
1.2

getSystemResource

public static URL getSystemResource(String name)
从用来加载类的搜索路径中查找具有指定名称的资源。此方法通过系统类加载器（参见 getSystemClassLoader()）来查找资源。

参数：
name - 资源名称
返回：
用于读取资源的 URL 对象，如果找不到资源，则返回 null
从以下版本开始：
1.1

getSystemResources

public static Enumeration<URL> getSystemResources(String name)
                                           throws IOException
从用来加载类的搜索路径中查找所有具有指定名称的资源。找到的资源作为 URL 对象的 Enumeration 返回。

getSystemResource(String) 的文档中描述了搜索顺序。

参数：
name - 资源名称
返回：
资源 URL 对象的枚举
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
1.2

getResourceAsStream

public InputStream getResourceAsStream(String name)
返回读取指定资源的输入流。

getResource(String) 的文档中描述了搜索顺序。

参数：
name - 资源名称
返回：
用于读取资源的输入流，如果无法找到资源，则返回 null
从以下版本开始：
1.1

getSystemResourceAsStream

public static InputStream getSystemResourceAsStream(String name)
从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。此方法通过系统类加载器（参见 getSystemClassLoader()）来查找资源。

参数：
name - 资源名称
返回：
用于读取资源的输入流，如果无法找到资源，则返回 null
从以下版本开始：
1.1

getParent

public final ClassLoader getParent()
返回委托的父类加载器。一些实现可能使用 null 来表示引导类加载器。如果类加载器的父类加载器就是引导类加载器，则此方法将在这样的实现中返回 null。

如果存在安全管理器，且调用者的类加载器既不是 null，也不是此类加载器的祖先，那么此方法将使用 RuntimePermission("getClassLoader") 权限调用安全管理器的 checkPermission 方法，以检验是否允许访问该类的父类加载器。如果无此权限，则抛出 SecurityException 异常。

返回：
父级 ClassLoader
抛出：
SecurityException - 如果存在安全管理器，并且其 checkPermission 方法不允许访问此类加载器的父类加载器。
从以下版本开始：
1.2

getSystemClassLoader

public static ClassLoader getSystemClassLoader()
返回委托的系统类加载器。该加载器是新的 ClassLoader 实例的默认委托父类加载器，通常是用来启动应用程序的类加载器。

在运行时启动序列的早期首先调用此方法，这时会创建系统类加载器并将其设置为调用 Thread 的上下文类加载器。

默认的系统类加载器是此类的一个与实现有关的实例。

如果在第一次调用此方法时定义系统属性 "java.system.class.loader"，那么该属性的值就是将作为系统类加载器返回的那个类的名称。该类是使用默认系统类加载器进行加载的，它必须定义一个公共的构造方法，此构造方法带有用作委托父类加载器的 ClassLoader 类型的单个参数。然后可以使用将默认系统类加载器用作参数的此构造方法创建一个实例。得到的类加载器被定义为系统类加载器。

如果存在安全管理器，且调用者的类加载器既不是 null，也不同于或不是系统类加载器的祖先，那么该方法将使用 RuntimePermission("getClassLoader") 权限调用安全管理器的 checkPermission 方法，以检验系统类加载器的访问权。如果无此权限，则抛出 SecurityException 异常。

返回：
委托的系统 ClassLoader，如果没有这样的类加载器，则返回 null
抛出：
SecurityException - 如果存在安全管理器，且其 checkPermission 方法不允许访问系统类加载器。
IllegalStateException - 如果在构造由 "java.system.class.loader" 属性指定的类加载器期间进行递归调用。
Error - 如果定义了系统属性 "java.system.class.loader"，但是无法加载指定的类，提供者类没有定义所需的构造方法，或者在调用该构造方法时抛出异常。可以通过 Throwable.getCause() 方法找出导致该错误的基本原因。

definePackage

protected Package definePackage(String name,
                                String specTitle,
                                String specVersion,
                                String specVendor,
                                String implTitle,
                                String implVersion,
                                String implVendor,
                                URL sealBase)
                         throws IllegalArgumentException
根据 name 在此 ClassLoader 中定义包。这允许类加载器定义用于它们的类的包。包必须在定义类之前创建，包名在类加载器中必须惟一，并且一旦创建就不能重新定义或更改。

参数：
name - 包名
specTitle - 规范标题
specVersion - 规范版本
specVendor - 规范供应商
implTitle - 实现标题
implVersion - 实现版本
implVendor - 实现供应商
sealBase - 如果不为 null，那么将此包对于给定代码源 URL 对象是密封的。否则，不密封此包。
返回：
新定义的 Package 对象
抛出：
IllegalArgumentException - 如果包名与此类加载器或其某个祖先中的现有包的名称重复
从以下版本开始：
1.2

getPackage

protected Package getPackage(String name)
返回由此类加载器或其任何祖先所定义的 Package。

参数：
name - 包名
返回：
与给定名称相对应的 Package；如果没有这样的包，则返回 null
从以下版本开始：
1.2

getPackages

protected Package[] getPackages()
返回此类加载器及其祖先所定义的所有 Package。

返回：
此 ClassLoader 定义的 Package 对象的数组
从以下版本开始：
1.2

findLibrary

protected String findLibrary(String libname)
返回本机库的绝对路径名。虚拟机 (VM) 调用此方法来查找那些属于利用此类加载器加载的类的本机库。如果此方法返回 null，则虚拟机沿指定为 "java.library.path" 属性的路径搜索该库。

参数：
libname - 库名称
返回：
本机库的绝对路径
从以下版本开始：
1.2
另请参见：
System.loadLibrary(String), System.mapLibraryName(String)

setDefaultAssertionStatus

public void setDefaultAssertionStatus(boolean enabled)
设置此类加载器的默认断言状态。此设置确定由此类加载器加载并在将来初始化的类在默认情况下是启用还是禁用断言。通过调用 setPackageAssertionStatus(String, boolean) 或 setClassAssertionStatus(String, boolean)，在每个包或每个类上重写此设置。

参数：
enabled - 如果由此类加载器加载的类将默认为启用断言，则该参数为 true；如果默认为禁用断言，则该参数为 false。
从以下版本开始：
1.4

setPackageAssertionStatus

public void setPackageAssertionStatus(String packageName,
                                      boolean enabled)
为指定包设置默认断言状态。包的默认断言状态确定了以后初始化属于指定包或其子包的类的断言状态。

名为 p 的包的子包是所有名称以 "p." 开头的包。例如，javax.swing.text 是 javax.swing 的子包，java.util 和 java.lang.reflect 是 java 的子包。

如果默认情况下多个包可应用于一个给定类，则默认与最特殊的包相关的包拥有高于其他包的优先级。例如，如果 javax.lang 和 javax.lang.reflect 都具有与之相关的默认包，则将后者应用于 javax.lang.reflect 中的类。

包的优先级默认情况下高于类加载器的默认断言状态，并且可以通过调用 setClassAssertionStatus(String, boolean) 在每个类的基础上进行重写。

参数：
packageName - 要设置其默认包断言状态的包名。null 值指示未命名的包为“当前”状态（Java Language Specification 的第 7.4.2 节）。
enabled - 如果由此类加载器加载并属于指定包或其子包的类在默认情况下启用断言，则该参数为 true；如果在默认情况下禁用断言，则该参数为 false。
从以下版本开始：
1.4

setClassAssertionStatus

public void setClassAssertionStatus(String className,
                                    boolean enabled)
设置在此类加载器及其包含的嵌套类中指定的最高层类所需的断言状态。该设置的优先级高于类加载器的默认断言状态以及可用的任何包的默认值。如果已经初始化指定类，则此方法无效。（初始化类后，其断言状态无法再改变。）

如果指定类不是最高层的类，则此调用对任何类的实际断言都无效。

参数：
className - 将要设置其断言状态的最高层类的完全限定类名。
enabled - 如果指定类在初始化时启用断言，则该参数为true；如果该类禁用断言，则该参数为false。
从以下版本开始：
1.4

clearAssertionStatus

public void clearAssertionStatus()
将此类加载器的默认断言状态设置为 false，并放弃与此类加载器关联的所有默认包或类断言状态设置。提供此方法可以让类加载器忽略任何命令行或持久断言状态设置，并且“无不良记录”。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClassNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ClassNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.ClassNotFoundException
所有已实现的接口：
Serializable
public class ClassNotFoundException
extends Exception

当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常：

  • Class 类中的 forName 方法。
  • ClassLoader 类中的 findSystemClass 方法。
  • ClassLoader 类中的 loadClass 方法。

但是没有找到具有指定名称的类的定义。

从 1.4 版本开始，此异常已经更新，以符合通用的异常链机制。在构造时提供并通过 getException() 方法访问的“加载类时引发的可选异常”，现在被称为原因，它可以通过 Throwable.getCause() 方法以及与上面提到的“遗留方法”来访问。

从以下版本开始：
JDK1.0
另请参见：
Class.forName(java.lang.String),
ClassLoader.findSystemClass(java.lang.String),
ClassLoader.loadClass(java.lang.String, boolean),
序列化表格

构造方法摘要
ClassNotFoundException()
构造不带详细消息的 ClassNotFoundException。
ClassNotFoundException(String s)
构造带指定详细消息的 ClassNotFoundException。
ClassNotFoundException(String s, Throwable ex)
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。
方法摘要
Throwable | getCause() 返回此异常的原因（尝试加载类时发生错误引发的异常；否则返回 null）。
Throwable | getException() 返回尝试加载类时发生错误引发的异常。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClassNotFoundException

public ClassNotFoundException()
构造不带详细消息的 ClassNotFoundException。

ClassNotFoundException

public ClassNotFoundException(String s)
构造带指定详细消息的 ClassNotFoundException。

参数：
s - 详细消息。

ClassNotFoundException

public ClassNotFoundException(String s,
                              Throwable ex)
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。

参数：
s - 详细消息
ex - 加载类时引发的异常
从以下版本开始：
1.2
方法详细信息

getException

public Throwable getException()
返回尝试加载类时发生错误引发的异常。否则，返回 null。

该方法早于通用异常链设施。Throwable.getCause() 方法现在是获得此信息的首选方法。

返回：
加载类时引发的 Exception
从以下版本开始：
1.2

getCause

public Throwable getCause()
返回此异常的原因（尝试加载类时发生错误引发的异常；否则返回 null）。

覆盖：
类 Throwable 中的 getCause
返回：
造成此异常的原因。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Cloneable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 Cloneable

所有已知子接口：
AclEntry, Attribute, AttributedCharacterIterator, Attributes, CertPathBuilderResult, CertPathParameters, CertPathValidatorResult, CertSelector, CertStoreParameters, CharacterIterator, CRLSelector, Descriptor, GSSCredential, Name
public interface Cloneable

此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。

如果在没有实现 Cloneable 接口的实例上调用 Object 的 clone 方法，则会导致抛出 CloneNotSupportedException 异常。

按照惯例，实现此接口的类应该使用公共方法重写 Object.clone（它是受保护的）。请参阅 Object.clone()，以获得有关重写此方法的详细信息。

注意，此接口不 包含 clone 方法。因此，因为某个对象实现了此接口就克隆它是不可能的。即使 clone 方法是反射性调用的，也无法保证它将获得成功。

从以下版本开始：
JDK1.0
另请参见：
CloneNotSupportedException, Object.clone()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CloneNotSupportedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 CloneNotSupportedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.CloneNotSupportedException
所有已实现的接口：
Serializable
直接已知子类：
ServerCloneException
public class CloneNotSupportedException
extends Exception

当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。

重写 clone 方法的应用程序也可能抛出此异常，指示不能或不应复制一个对象。

从以下版本开始：
JDK1.0
另请参见：
Cloneable, Object.clone(), 序列化表格

构造方法摘要
CloneNotSupportedException()
构造不带详细消息的 CloneNotSupportedException。
CloneNotSupportedException(String s)
构造带指定详细消息的 CloneNotSupportedException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CloneNotSupportedException

public CloneNotSupportedException()
构造不带详细消息的 CloneNotSupportedException。

CloneNotSupportedException

public CloneNotSupportedException(String s)
构造带指定详细消息的 CloneNotSupportedException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Comparable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 Comparable<T>

类型参数：
T - 可以与此对象进行比较的那些对象的类型
所有已知子接口：
Delayed, Name, RunnableScheduledFuture<V>, ScheduledFuture<V>
所有已知实现类：
Authenticator.RequestorType, BigDecimal, BigInteger, Boolean, Byte, ByteBuffer, Calendar, Character, CharBuffer, Charset, ClientInfoStatus, CollationKey, Component.BaselineResizeBehavior, CompositeName, CompoundName, Date, Date, Desktop.Action, Diagnostic.Kind, Dialog.ModalExclusionType, Dialog.ModalityType, Double, DoubleBuffer, DropMode, ElementKind, ElementType, Enum, File, Float, FloatBuffer, Formatter.BigDecimalLayoutForm, FormSubmitEvent.MethodType, GregorianCalendar, GroupLayout.Alignment, IntBuffer, Integer, JavaFileObject.Kind, JTable.PrintMode, KeyRep.Type, LayoutStyle.ComponentPlacement, LdapName, Long, LongBuffer, MappedByteBuffer, MemoryType, MessageContext.Scope, Modifier, MultipleGradientPaint.ColorSpaceType, MultipleGradientPaint.CycleMethod, NestingKind, Normalizer.Form, ObjectName, ObjectStreamField, Proxy.Type, Rdn, Resource.AuthenticationType, RetentionPolicy, RoundingMode, RowFilter.ComparisonType, RowIdLifetime, RowSorterEvent.Type, Service.Mode, Short, ShortBuffer, SOAPBinding.ParameterStyle, SOAPBinding.Style, SOAPBinding.Use, SortOrder, SourceVersion, SSLEngineResult.HandshakeStatus, SSLEngineResult.Status, StandardLocation, String, SwingWorker.StateValue, Thread.State, Time, Timestamp, TimeUnit, TrayIcon.MessageType, TypeKind, URI, UUID, WebParam.Mode, XmlAccessOrder, XmlAccessType, XmlNsForm
public interface Comparable<T>

此接口强行对实现它的每个类的对象进行整体排序。这种排序被称为类的自然排序，类的 compareTo 方法被称为它的自然比较方法。

实现此接口的对象列表（和数组）可以通过 Collections.sort（和 Arrays.sort）进行自动排序。实现此接口的对象可以用作有序映射中的键或有序集合中的元素，无需指定比较器。

对于类 C 的每一个 e1 和 e2 来说，当且仅当 e1.compareTo(e2) == 0 与 e1.equals(e2) 具有相同的 boolean 值时，类 C 的自然排序才叫做与 equals 一致。注意，null 不是任何类的实例，即使 e.equals(null) 返回 false，e.compareTo(null) 也将抛出 NullPointerException。

建议（虽然不是必需的）最好使自然排序与 equals 一致。这是因为在使用自然排序与 equals 不一致的元素（或键）时，没有显式比较器的有序集合（和有序映射表）行为表现“怪异”。尤其是，这样的有序集合（或有序映射表）违背了根据 equals 方法定义的集合（或映射表）的常规协定。

例如，如果将两个键 a 和 b 添加到没有使用显式比较器的有序集合中，使 (!a.equals(b) && a.compareTo(b) == 0)，那么第二个 add 操作将返回 false（有序集合的大小没有增加），因为从有序集合的角度来看，a 和 b 是相等的。

实际上，所有实现 Comparable 的 Java 核心类都具有与 equals 一致的自然排序。java.math.BigDecimal 是个例外，它的自然排序将值相等但精确度不同的 BigDecimal 对象（比如 4.0 和 4.00）视为相等。

从数学上讲，定义给定类 C 上自然排序的关系式 如下：

      {(x, y)|x.compareTo(y) <= 0}。
整体排序的商 是：
      {(x, y)|x.compareTo(y) == 0}。
它直接遵循 compareTo 的协定，商是 C 的等价关系，自然排序是 C 的整体排序。当说到类的自然排序与 equals 一致 时，是指自然排序的商是由类的 equals(Object) 方法定义的等价关系。
    {(x, y)|x.equals(y)}。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Comparator

方法摘要
 int compareTo(T o)
比较此对象与指定对象的顺序。

方法详细信息

compareTo

int compareTo(T o)
比较此对象与指定对象的顺序。如果该对象小于、等于或大于指定对象，则分别返回负整数、零或正整数。

实现类必须确保对于所有的 x 和 y 都存在 sgn(x.compareTo(y)) == -sgn(y.compareTo(x)) 的关系。（这意味着如果 y.compareTo(x) 抛出一个异常，则 x.compareTo(y) 也要抛出一个异常。）

实现类还必须确保关系是可传递的：(x.compareTo(y)>0 && y.compareTo(z)>0) 意味着 x.compareTo(z)>0。

最后，实现者必须确保 x.compareTo(y)==0 意味着对于所有的 z，都存在 sgn(x.compareTo(z)) == sgn(y.compareTo(z))。 强烈推荐 (x.compareTo(y)==0) == (x.equals(y)) 这种做法，但并不是 严格要求这样做。一般来说，任何实现 Comparable 接口和违背此条件的类都应该清楚地指出这一事实。推荐如此阐述：“注意：此类具有与 equals 不一致的自然排序。”

在前面的描述中，符号 sgn(expression) 指定 signum 数学函数，该函数根据 expression 的值是负数、零还是正数，分别返回 -1、0 或 1 中的一个值。

参数：
o - 要比较的对象。
返回：
负整数、零或正整数，根据此对象是小于、等于还是大于指定对象。
抛出：
ClassCastException - 如果指定对象的类型不允许它与此对象进行比较。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Compiler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Compiler

java.lang.Object
    继承者  java.lang.Compiler

public final class Compiler
extends Object

Compiler 类主要支持 Java 到本机代码的编译器及相关服务。根据设计，Compiler 类不做任何事情，它充当一个 JIT 编译器实现的占位符。

当第一次启动 Java 虚拟机时，它将确定系统属性 java.compiler 是否存在。（系统属性可通过 System 类定义的 getProperty 方法来访问。）如果存在，它将被假定为一个库名（带有特定于平台的确切位置和类型）；可以调用 System 类中的 loadLibrary 方法来加载此库。如果加载成功，则调用该库中名为 java_lang_Compiler_start() 的函数。

如果没有可用的编译器，那么上述这些方法不执行任何操作。

从以下版本开始：
JDK1.0
另请参见：
System.getProperty(java.lang.String),
System.getProperty(java.lang.String, java.lang.String),
System.loadLibrary(java.lang.String)

方法摘要
static Object | command(Object any) 检查参数类型及其字段，并执行一些文档操作。
static boolean | compileClass(Class<?> clazz) 编译指定的类。
static boolean | compileClasses(String string) 编译那些名称与指定字符串相匹配的所有类。
static void | disable() 使编译器停止操作。
static void | enable() 使编译器恢复操作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

compileClass

public static boolean compileClass(Class<?> clazz)
编译指定的类。

参数：
clazz - 一个类。
返回：
如果编译成功，则返回 true；如果编译失败或没有可用的编译器，则返回 false。
抛出：
NullPointerException - 如果 clazz 为 null。

compileClasses

public static boolean compileClasses(String string)
编译那些名称与指定字符串相匹配的所有类。

参数：
string - 要编译的类的名称。
返回：
如果编译成功，则返回 true；如果编译失败或没有可用的编译器，则返回 false。
抛出：
NullPointerException - 如果 string 为 null。

command

public static Object command(Object any)
检查参数类型及其字段，并执行一些文档操作。不需要指定特殊操作。

参数：
any - 参数。
返回：
特定于编译器的值；如果没有可用编译器，则返回 null。
抛出：
NullPointerException - 如果 any 为 null。

enable

public static void enable()
使编译器恢复操作。

disable

public static void disable()
使编译器停止操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Deprecated (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

java.lang
注释类型 Deprecated

@Documented
@Retention(value=RUNTIME)
public @interface Deprecated

用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。在使用不被赞成的程序元素或在不被赞成的代码中执行重写时，编译器会发出警告。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Double (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Double

java.lang.Object
    继承者  java.lang.Number
        继承者  java.lang.Double
所有已实现的接口：
Serializable, Comparable<Double>
public final class Double
extends Number
implements Comparable<Double>

Double 类在对象中包装一个基本类型 double 的值。每个 Double 类型的对象都包含一个 double 类型的字段。

此外，该类还提供多个方法，可以将 double 转换为 String，将 String 转换为 double，也提供了其他一些处理 double 时有用的常量和方法。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static int | MAX_EXPONENT 有限 double 变量可能具有的最大指数。
static double | MAX_VALUE 保存 double 类型的最大正有限值的常量，最大正有限值为 (2-2-52)·21023。
static int | MIN_EXPONENT 标准化 double 变量可能具有的最小指数。
static double | MIN_NORMAL 保存 double 类型的最小正标准值的常量，最小正标准值为 2-1022。
static double | MIN_VALUE 保存 double 类型的最小正非零值的常量，最小正非零值为 2-1074。
static double | NaN 保存 double 类型的 NaN 值的常量。
static double | NEGATIVE_INFINITY 保存 double 类型的负无穷大值的常量。
static double | POSITIVE_INFINITY 保存 double 类型的正无穷大值的常量。
static int | SIZE 用于表示 double 值的位数。
static Class<Double> | TYPE 表示基本类型 double 的 Class 实例。
构造方法摘要
Double(double value)
构造一个新分配的 Double 对象，它表示基本的 double 参数。
Double(String s)
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。
方法摘要
byte | byteValue() 以 byte 形式返回此 Double 的值（通过强制转换为 byte）。
static int | compare(double d1, double d2) 比较两个指定的 double 值。
int | compareTo(Double anotherDouble) 对两个 Double 对象所表示的数值进行比较。
static long | doubleToLongBits(double value) 根据 IEEE 754 浮点双精度格式 ("double format") 位布局，返回指定浮点值的表示形式。
static long | doubleToRawLongBits(double value) 根据 IEEE 754 浮点“双精度格式”位布局，返回指定浮点值的表示形式，并保留 NaN 值。
double | doubleValue() 返回此 Double 对象的 double 值。
boolean | equals(Object obj) 将此对象与指定对象比较。
float | floatValue() 返回此 Double 对象的 float 值。
int | hashCode() 返回此 Double 对象的哈希码。
int | intValue() 以 int 形式返回此 Double 的值（通过强制转换为 int 类型）。
boolean | isInfinite() 如果此 Double 值在数值上为无穷大，则返回 true；否则返回 false。
static boolean | isInfinite(double v) 如果指定数在数值上为无穷大，则返回 true；否则返回 false。
boolean | isNaN() 如果此 Double 值是非数字（NaN）值，则返回 true；否则返回 false。
static boolean | isNaN(double v) 如果指定的数是一个 NaN 值，则返回 true；否则返回 false。
static double | longBitsToDouble(long bits) 返回对应于给定位表示形式的 double 值。
long | longValue() 以 long 形式返回此 Double 的值（通过强制转换为 long 类型）。
static double | parseDouble(String s) 返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。
short | shortValue() 以 short 形式返回此 Double 的值（通过强制转换为 short）。
static String | toHexString(double d) 返回 double 参数的十六进制字符串表示形式。
String | toString() 返回此 Double 对象的字符串表示形式。
static String | toString(double d) 返回 double 参数的字符串表示形式。
static Double | valueOf(double d) 返回表示指定的 double 值的 Double 实例。
static Double | valueOf(String s) 返回保存用参数字符串 s 表示的 double 值的 Double 对象。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

POSITIVE_INFINITY

public static final double POSITIVE_INFINITY
保存 double 类型的正无穷大值的常量。它等于 Double.longBitsToDouble(0x7ff0000000000000L) 返回的值。

另请参见：
常量字段值

NEGATIVE_INFINITY

public static final double NEGATIVE_INFINITY
保存 double 类型的负无穷大值的常量。它等于 Double.longBitsToDouble(0xfff0000000000000L) 返回的值。

另请参见：
常量字段值

NaN

public static final double NaN
保存 double 类型的 NaN 值的常量。它等于 Double.longBitsToDouble(0x7ff8000000000000L) 返回的值。

另请参见：
常量字段值

MAX_VALUE

public static final double MAX_VALUE
保存 double 类型的最大正有限值的常量，最大正有限值为 (2-2-52)·21023。它等于十六进制的浮点字面值 0x1.fffffffffffffP+1023，也等于 Double.longBitsToDouble(0x7fefffffffffffffL)。

另请参见：
常量字段值

MIN_NORMAL

public static final double MIN_NORMAL
保存 double 类型的最小正标准值的常量，最小正标准值为 2-1022。它等于十六进制的浮点字面值 0x1.0p-1022，也等于 Double.longBitsToDouble(0x0010000000000000L)。

从以下版本开始：
1.6
另请参见：
常量字段值

MIN_VALUE

public static final double MIN_VALUE
保存 double 类型的最小正非零值的常量，最小正非零值为 2-1074。它等于十六进制的浮点字面值 0x0.0000000000001P-1022，也等于 Double.longBitsToDouble(0x1L)。

另请参见：
常量字段值

MAX_EXPONENT

public static final int MAX_EXPONENT
有限 double 变量可能具有的最大指数。它等于 Math.getExponent(Double.MAX_VALUE) 返回的值。

从以下版本开始：
1.6
另请参见：
常量字段值

MIN_EXPONENT

public static final int MIN_EXPONENT
标准化 double 变量可能具有的最小指数。它等于 Math.getExponent(Double.MIN_NORMAL) 返回的值。

从以下版本开始：
1.6
另请参见：
常量字段值

SIZE

public static final int SIZE
用于表示 double 值的位数。

从以下版本开始：
1.5
另请参见：
常量字段值

TYPE

public static final Class<Double> TYPE
表示基本类型 double 的 Class 实例。

从以下版本开始：
JDK1.1
构造方法详细信息

Double

public Double(double value)
构造一个新分配的 Double 对象，它表示基本的 double 参数。

参数：
value - 用 Double 表示的值。

Double

public Double(String s)
       throws NumberFormatException
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。该方法与 valueOf 方法一样，可将字符串转换为 double 值。

参数：
s - 要转换为 Double 的字符串。
抛出：
NumberFormatException - 如果字符串不包含可解析的数字。
另请参见：
valueOf(java.lang.String)
方法详细信息

toString

public static String toString(double d)
返回 double 参数的字符串表示形式。下面提到的所有字符都是 ASCII 字符。
  • 如果参数为 NaN，那么结果为字符串 "NaN"。
  • 否则，结果是表示参数符号和数值（绝对值）的字符串。如果符号为负，那么结果的第一个字符是 '-' ('\u002D')；如果符号为正，那么结果中不显示符号字符。对于数值 m：
    • 如果 m 为无穷大，则用字符 "Infinity" 表示；因此，正无穷大生成结果 "Infinity"，负无穷大生成结果 "-Infinity"。
    • 如果 m 为 0，则用字符 "0.0" 表示；因此，负 0 生成结果 "-0.0"，正 0 生成结果 "0.0"。
    • 如果 m 大于或者等于 10-3，但小于 107，则采用不带前导 0 的十进制形式，用 m 的整数部分表示，后跟 '.' ('\u002E')，再后面是表示 m 小数部分的一个或多个十进制数字。
    • 如果 m 小于 10-3 或大于等于 107，则使用所谓的“计算机科学记数法”表示。设 n 为满足 10n <= m < 10n+1 的唯一整数；然后设 a 为 m 与 10n 的精确算术商，从而 1 <= a < 10。那么，数值便表示为 a 的整数部分，其形式为：一个十进制数字，后跟 '.' ('\u002E')，接着是表示 a 小数部分的十进制数字，再后面是字母 'E' ('\u0045')，最后是用十进制整数形式表示的 n，这与方法 Integer.toString(int) 生成的结果一样。
必须为 m 或 a 的小数部分显示多少位呢？至少必须有一位数来表示小数部分，除此之外，需要更多（但只能和需要的一样多）位数来唯一地区分参数值和 double 类型的邻近值。这就是说，假设 x 是用十进制表示法表示的精确算术值，是通过对有限非 0 参数 d 调用此方法生成的。那么 d 一定是最接近 x 的 double 值；如果两个 double 值都同等地接近 x，那么 d 必须是其中之一，并且 d 的有效数字的最低有效位必须是 0。

要创建浮点值的本地化字符串表示形式，请使用 NumberFormat 的子类。

参数：
d - 要转换的 double 值。
返回：
参数的字符串表示形式。

toHexString

public static String toHexString(double d)
返回 double 参数的十六进制字符串表示形式。下面提到的所有字符都是 ASCII 字符。
  • 如果参数为 NaN，那么结果为字符串 "NaN"。
  • 否则，结果是表示参数符号和数值的字符串。如果符号为负，那么结果的第一个字符是 '-' ('\u002D')；如果符号为正，那么结果中不显示符号字符。对于数值 m：
    • 如果 m 为无穷大，则用字符串 "Infinity" 表示；因此，正无穷大生成结果 "Infinity"，负无穷大生成结果 "-Infinity"。
    • 如果 m 为 0，则用字符串 "0x0.0p0" 表示；因此，负 0 生成结果 "-0x0.0p0"，正 0 生成结果 "0x0.0p0"。
    • 如果 m 是具有标准化表示形式的 double 值，则使用子字符串表示有效数字和指数字段。有效数字用字符 "0x1." 表示，后跟该有效数字剩余小数部分的小写十六进制表示形式。除非所有位数都为 0，否则移除十六进制表示中的尾部 0，在所有位数都为零的情况下，可以用一个 0 表示。接下来用 "p" 表示指数，后跟无偏指数的十进制字符串，该值与通过对指数值调用 Integer.toString 生成的值相同。
    • 如果 m 是非标准表示形式的 double 值，则用字符 "0x0." 表示有效数字，后跟该有效数字剩余小数部分的十六进制表示形式。移除十六进制表示中的尾部 0。然后用 "p-1022" 表示指数。注意，在非标准有效数字中，必须至少有一个非 0 数字。

示例
浮点值 | 十六进制字符串
1.0 | 0x1.0p0
-1.0 | -0x1.0p0
2.0 | 0x1.0p1
3.0 | 0x1.8p1
0.5 | 0x1.0p-1
0.25 | 0x1.0p-2
Double.MAX_VALUE | 0x1.fffffffffffffp1023
Minimum Normal Value | 0x1.0p-1022
Maximum Subnormal Value | 0x0.fffffffffffffp-1022
Double.MIN_VALUE | 0x0.0000000000001p-1022

参数：
d - 要转换的 double 值。
返回：
参数的十六进制字符串表示形式。
从以下版本开始：
1.5

valueOf

public static Double valueOf(String s)
                      throws NumberFormatException
返回保存用参数字符串 s 表示的 double 值的 Double 对象。

如果 s 为 null，则抛出 NullPointerException 异常。

忽略 s 中的前导空白字符和尾部空白字符。就像调用 String.trim() 方法那样移除空白；这就是说，ASCII 空格和控制字符都要移除。s 的其余部分应该按词法语法规则所描述的那样构成一个 FloatValue：

FloatValue:
Signopt NaN
Signopt Infinity
Signopt FloatingPointLiteral
Signopt HexFloatingPointLiteral
SignedInteger

HexFloatingPointLiteral:
HexSignificand BinaryExponent FloatTypeSuffixopt

HexSignificand:
HexNumeral
HexNumeral .
0x HexDigitsopt. HexDigits
0X HexDigitsopt. HexDigits

BinaryExponent:
BinaryExponentIndicator SignedInteger

BinaryExponentIndicator:
p
P
其中 Sign、FloatingPointLiteral、HexNumeral、HexDigits、SignedInteger 和 FloatTypeSuffix 与 Java Language Specification 的词法结构部分中定义的相同。如果 s 不具有 FloatValue 的形式，则抛出 NumberFormatException。否则，可以认为 s 是一个以常用的“计算机科学记数法”表示的精确十进制值，或者是一个精确的十六进制值；在概念上，这个精确的数值将被转换为一个“无限精确的”二进制值，然后根据常用的 IEEE 754 浮点算法的“舍入为最接近的数”规则，将该值舍入为 double 类型，其中包括保留 0 值的符号。最后，返回表示此 double 值的 Double 对象。

要解释浮点值的本地化字符串表示形式，请使用 NumberFormat 的子类。

注意，尾部格式说明符、确定浮点字面值类型的说明符（1.0f 是一个 float 值；1.0d 是一个 double 值）不会 影响此方法的结果。换句话说，输入字符串的数值被直接转换为目标浮点类型。分两步的转换（先将字符串转换为 float，然后将 float 转换为 double）不 同于直接将字符串转换为 double。例如，float 字面值 0.1f 等于 double 值 0.10000000149011612；float 字面值 0.1f 表示与 double 字面值 0.1 不同的数值。（数值 0.1 无法用二进制浮点数准确表示。)

为了避免因为对无效字符串调用此方法而导致抛出 NumberFormatException，可以使用以下正则表达式作为输入到屏幕的字符串：

        final String Digits     = "(\\p{Digit}+)";
  final String HexDigits  = "(\\p{XDigit}+)";
        // an exponent is 'e' or 'E' followed by an optionally
        // .
        final String Exp        = "[eE][+-]?"+Digits;
        final String fpRegex    =
            ("[\\x00-\\x20]*"+        // Optional leading "whitespace"
             "[+-]?(" +       // Optional sign character
             "NaN|" +         // "NaN" string
             "Infinity|" +    // "Infinity" string

             // A decimal floating-point string representing a finite positive
             // number without a leading sign has at most five basic pieces:
             // Digits . Digits ExponentPart FloatTypeSuffix
             //
             // Since this method allows integer-only strings as input
             // in addition to strings of floating-point literals, the
             // two sub-patterns below are simplifications of the grammar
             // productions from the Java Language Specification, 2nd
             // edition, section 3.10.2.

             // Digits ._opt Digits_opt ExponentPart_opt FloatTypeSuffix_opt
             "((("+Digits+"(\\.)?("+Digits+"?)("+Exp+")?)|"+

             // . Digits ExponentPart_opt FloatTypeSuffix_opt
             "(\\.("+Digits+")("+Exp+")?)|"+

       // Hexadecimal strings
       "((" +
        // 0[xX] HexDigits ._opt BinaryExponent FloatTypeSuffix_opt
        "(0[xX]" + HexDigits + "(\\.)?)|" +

        // 0[xX] HexDigits_opt . HexDigits BinaryExponent FloatTypeSuffix_opt
        "(0[xX]" + HexDigits + "?(\\.)" + HexDigits + ")" +

        ")[pP][+-]?" + Digits + "))" +
             "[fFdD]?))" +
             "[\\x00-\\x20]*");// Optional trailing "whitespace"

  if (Pattern.matches(fpRegex, myString))
            Double.valueOf(myString); // Will not throw NumberFormatException
        else {
            // Perform suitable alternative action
        }

参数：
s - 要解析的字符串。
返回：
保存用 String 参数表示的值的 Double 对象。
抛出：
NumberFormatException - 如果字符串不包含可解析的数。

valueOf

public static Double valueOf(double d)
返回表示指定的 double 值的 Double 实例。如果不需要新的 Double 实例，则通常应优先使用此方法，而不是构造方法 Double(double)，因为此方法可能通过缓存经常请求的值来显著提高空间和时间性能。

参数：
d - 一个 double 值。
返回：
表示 d 的 Double 实例。
从以下版本开始：
1.5

parseDouble

public static double parseDouble(String s)
                          throws NumberFormatException
返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。

参数：
s - 要解析的字符串。
返回：
由字符串参数表示的 double 值。
抛出：
NumberFormatException - 如果字符串不包含可解析的 double 值。
从以下版本开始：
1.2
另请参见：
valueOf(String)

isNaN

public static boolean isNaN(double v)
如果指定的数是一个 NaN 值，则返回 true；否则返回 false。

参数：
v - 要测试的值。
返回：
如果参数值为 NaN，则返回 true；否则返回 false。

isInfinite

public static boolean isInfinite(double v)
如果指定数在数值上为无穷大，则返回 true；否则返回 false。

参数：
v - 要测试的值。
返回：
如果参数值是正无穷大或负无穷大，则返回 true；否则返回 false。

isNaN

public boolean isNaN()
如果此 Double 值是非数字（NaN）值，则返回 true；否则返回 false。

返回：
如果此对象表示的值为 NaN，则返回 true；否则返回 false。

isInfinite

public boolean isInfinite()
如果此 Double 值在数值上为无穷大，则返回 true；否则返回 false。

返回：
如果此对象所表示的值是正无穷大或负无穷大，则返回 true；否则返回 false。

toString

public String toString()
返回此 Double 对象的字符串表示形式。使用此对象表示的基本 double 值被转换为一个字符串，这与带一个参数的 toString 方法完全一样。

覆盖：
类 Object 中的 toString
返回：
此对象的 String 表示形式。
另请参见：
toString(double)

byteValue

public byte byteValue()
以 byte 形式返回此 Double 的值（通过强制转换为 byte）。

覆盖：
类 Number 中的 byteValue
返回：
转换为 byte 类型的由此对象所表示的 double 值
从以下版本开始：
JDK1.1

shortValue

public short shortValue()
以 short 形式返回此 Double 的值（通过强制转换为 short）。

覆盖：
类 Number 中的 shortValue
返回：
转换为 short 类型的由此对象所表示的 double 值
从以下版本开始：
JDK1.1

intValue

public int intValue()
以 int 形式返回此 Double 的值（通过强制转换为 int 类型）。

指定者：
类 Number 中的 intValue
返回：
转换为 int 类型的由此对象所表示的 double 值

longValue

public long longValue()
以 long 形式返回此 Double 的值（通过强制转换为 long 类型）。

指定者：
类 Number 中的 longValue
返回：
转换为 long 类型的由此对象所表示的 double 值

floatValue

public float floatValue()
返回此 Double 对象的 float 值。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 类型的由此对象所表示的 double 值
从以下版本开始：
JDK1.0

doubleValue

public double doubleValue()
返回此 Double 对象的 double 值。

指定者：
类 Number 中的 doubleValue
返回：
此对象所表示的 double 值

hashCode

public int hashCode()
返回此 Double 对象的哈希码。结果是此 Double 对象所表示的基本 double 值的 long 整数位表示形式（与 doubleToLongBits(double) 方法生成的结果完全一样）两部分整数之间的异或 (XOR)。也就是说，哈希码就是以下表达式的值：
 (int)(v^(v>>>32))
其中 v 的定义为：
 long v = Double.doubleToLongBits(this.doubleValue());

覆盖：
类 Object 中的 hashCode
返回：
此对象的 hashCode 值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不是 null 而是 Double 对象，且表示的 Double 值与此对象表示的 double 值相同时，结果为 true。为此，当且仅当将方法 doubleToLongBits(double) 应用于两个值所返回的 long 值相同时，才认为这两个 double 值相同。

注意，在大多数情况下，对于 Double 类的两个实例 d1 和 d2，当且仅当

   d1.doubleValue() == d2.doubleValue()

为 true 时，d1.equals(d2) 的值才为 true。但是，有以下两种例外情况：

  • 如果 d1 和 d2 都表示 Double.NaN，那么即使 Double.NaN==Double.NaN 值为 false，equals 方法也将返回 true。
  • 如果 d1 表示 +0.0 而 d2 表示 -0.0，或者相反，那么即使 +0.0==-0.0 值为 true，equals 测试也将返回 false。
此定义使得哈希表得以正确操作。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之进行比较的对象。
返回：
如果对象相同，则返回 true；否则返回 false。
另请参见：
doubleToLongBits(double)

doubleToLongBits

public static long doubleToLongBits(double value)
根据 IEEE 754 浮点双精度格式 ("double format") 位布局，返回指定浮点值的表示形式。

第 63 位（掩码 0x8000000000000000L 选定的位）表示浮点数的符号。第 62-52 位（掩码 0x7ff0000000000000L 选定的位）表示指数。第 51-0 位（掩码 0x000fffffffffffffL 选定的位）表示浮点数的有效数字（有时也称为尾数）。

如果参数是正无穷大，则结果为 0x7ff0000000000000L。

如果参数是负无穷大，则结果为 0xfff0000000000000L。

如果参数是 NaN，则结果为 0x7ff8000000000000L。

在所有情况下，结果都是一个 long 整数，将其赋予 longBitsToDouble(long) 方法将生成一个与 doubleToLongBits 的参数相同的浮点值（所有 NaN 值被压缩成一个“规范”NaN 值时除外）。

参数：
value - 双精度 (double) 浮点数。
返回：
表示浮点数的位。

doubleToRawLongBits

public static long doubleToRawLongBits(double value)
根据 IEEE 754 浮点“双精度格式”位布局，返回指定浮点值的表示形式，并保留 NaN 值。

第 63 位（掩码 0x8000000000000000L 选定的位）表示浮点数的符号。第 62-52 位（掩码 0x7ff0000000000000L 选定的位）表示指数。第 51-0 位（掩码 0x000fffffffffffffL 选定的位）表示浮点数的有效数字（有时也称为尾数）。

如果参数是正无穷大，则结果为 0x7ff0000000000000L。

如果参数是负无穷大，则结果为 0xfff0000000000000L。

如果参数是 NaN，则结果是表示实际 NaN 值的 long 整数。与 doubleToLongBits 方法不同，doubleToRawLongBits 并没有压缩那些将 NaN 编码为一个“规范的”NaN 值的所有位模式。

在所有情况下，结果都是一个 long 整数，将其赋予 longBitsToDouble(long) 方法将生成一个与 doubleToRawLongBits 的参数相同的浮点值。

参数：
value - 双精度 (double) 浮点数。
返回：
表示浮点数的位。
从以下版本开始：
1.3

longBitsToDouble

public static double longBitsToDouble(long bits)
返回对应于给定位表示形式的 double 值。根据 IEEE 754 浮点“双精度格式”位布局，参数被视为浮点值表示形式。

如果参数是 0x7ff0000000000000L，则结果为正无穷大。

如果参数是 0xfff0000000000000L，则结果为负无穷大。

如果参数值在 0x7ff0000000000001L 到 0x7fffffffffffffffL 之间或者在 0xfff0000000000001L 到 0xffffffffffffffffL 之间，则结果为 NaN。Java 提供的任何 IEEE 754 浮点操作都不能区分具有不同位模式的两个同类型 NaN 值。不同的 NaN 值只能使用 Double.doubleToRawLongBits 方法区分。

在所有其他情况下，设 s、e 和 m 为可以通过以下参数计算的三个值：

 int s = ((bits >> 63) == 0) ? 1 : -1;
 int e = (int)((bits >> 52) & 0x7ffL);
 long m = (e == 0) ?
                 (bits & 0xfffffffffffffL) << 1 :
                 (bits & 0xfffffffffffffL) | 0x10000000000000L;
那么浮点结果等于算术表达式 s·m·2e-1075 的值。

注意，此方法不能返回与 long 参数具有完全相同位模式的 double NaN。IEEE 754 区分了两种 NaN：quiet NaN 和 signaling NaN。这两种 NaN 之间的差别在 Java 中通常是不可见的。对 signaling NaN 进行的算术运算将它们转换为具有不同（但通常类似）位模式的 quiet NaN。但是在某些处理器上，只复制 signaling NaN 也执行这种转换。特别是在复制 signaling NaN 以将其返回给调用方法时，可能会执行这种转换。因此，longBitsToDouble 可能无法返回具有 signaling NaN 位模式的 double 值。所以，对于某些 long 值，doubleToRawLongBits(longBitsToDouble(start)) 可能不 等于 start。此外，尽管所有 NaN 位模式（不管是 quiet NaN 还是 signaling NaN）都必须在上面提到的 NaN 范围内，但表示 signaling NaN 的特定位模式与平台有关。

参数：
bits - 任意 long 整数。
返回：
具有相同位模式的 double 浮点值。

compareTo

public int compareTo(Double anotherDouble)
对两个 Double 对象所表示的数值进行比较。在应用到基本 double 值时，有两种方法可以比较执行此方法生成的值与执行 Java 语言数字比较运算符（<、<=、== 和 >= >）生成的值之间的区别：
  • 此方法认为 Double.NaN 等于它自身，且大于其他所有 double 值（包括 Double.POSITIVE_INFINITY）。
  • 此方法认为 0.0d 大于 -0.0d。
这可以确保受此方法影响的 Double 对象的自然顺序与 equals 一致。

指定者：
接口 Comparable<Double> 中的 compareTo
参数：
anotherDouble - 要比较的 Double 值。
返回：
如果 anotherDouble 在数字上等于此 Double，则返回 0；如果此 Double 在数字上小于 anotherDouble，则返回小于 0 的值；如果此 Double 在数字上大于此 anotherDouble，则返回大于 0 的值。
从以下版本开始：
1.2

compare

public static int compare(double d1,
                          double d2)
比较两个指定的 double 值。返回整数值的符号与以下调用返回的整数的符号相同：
    new Double(d1).compareTo(new Double(d2))

参数：
d1 - 要比较的第一个 double
d2 - 要比较的第二个 double
返回：
如果 d1 在数字上等于 d2，则返回 0；如果 d1 在数字上小于 d2，则返回小于 0 的值；如果 d1 在数字上大于d2，则返回大于 0 的值。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Enum (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Enum<E extends Enum<E>>

java.lang.Object
    继承者  java.lang.Enum<E>
所有已实现的接口：
Serializable, Comparable<E>
public abstract class Enum<E extends Enum<E>>
extends Object
implements Comparable<E>, Serializable

这是所有 Java 语言枚举类型的公共基本类。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
protected Enum(String name, int ordinal)
单独的构造方法。
方法摘要
protected  Object clone()
抛出 CloneNotSupportedException。
 int compareTo(E o)
比较此枚举与指定对象的顺序。
 boolean equals(Object other)
当指定对象等于此枚举常量时，返回 true。
protected  void finalize()
枚举类不能有 finalize 方法。
 Class<E> getDeclaringClass()
返回与此枚举常量的枚举类型相对应的 Class 对象。
 int hashCode()
返回枚举常量的哈希码。
 String name()
返回此枚举常量的名称，在其枚举声明中对其进行声明。
 int ordinal()
返回枚举常量的序数（它在枚举声明中的位置，其中初始常量序数为零）。
 String toString()
返回枚举常量的名称，它包含在声明中。
static
<T extends Enum<T>>
T
valueOf(Class<T> enumType, String name)
返回带指定名称的指定枚举类型的枚举常量。
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Enum

protected Enum(String name,
               int ordinal)
单独的构造方法。程序员无法调用此构造方法。该构造方法用于由响应枚举类型声明的编译器发出的代码。

参数：
name - - 此枚举常量的名称，它是用来声明该常量的标识符。
ordinal - - 枚举常量的序数（它在枚举声明中的位置，其中初始常量序数为零）。
方法详细信息

name

public final String name()
返回此枚举常量的名称，在其枚举声明中对其进行声明。 与此方法相比，大多数程序员应该优先考虑使用 toString() 方法，因为 toString 方法返回更加用户友好的名称。该方法主要设计用于特殊情形，其正确性取决于获取正确的名称，其名称不会随版本的改变而改变。

返回：
枚举常量的名称

ordinal

public final int ordinal()
返回枚举常量的序数（它在枚举声明中的位置，其中初始常量序数为零）。 大多数程序员不会使用此方法。它被设计用于复杂的基于枚举的数据结构，比如 EnumSet 和 EnumMap。

返回：
枚举常量的序数

toString

public String toString()
返回枚举常量的名称，它包含在声明中。可以重写此方法，虽然一般来说没有必要。当存在更加“程序员友好的”字符串形式时，应该使用枚举类型重写此方法。

覆盖：
类 Object 中的 toString
返回：
枚举常量的名称

equals

public final boolean equals(Object other)
当指定对象等于此枚举常量时，返回 true。

覆盖：
类 Object 中的 equals
参数：
other - 要与此对象进行相等性比较的对象。
返回：
如果指定对象等于此枚举常量，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
返回枚举常量的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
枚举常量的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

clone

protected final Object clone()
                      throws CloneNotSupportedException
抛出 CloneNotSupportedException。这可保证永远不会复制枚举，这对于保留其“单元素”状态是必需的。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable

compareTo

public final int compareTo(E o)
比较此枚举与指定对象的顺序。在该对象小于、等于或大于指定对象时，分别返回负整数、零或正整数。 枚举常量只能与相同枚举类型的其他枚举常量进行比较。该方法实现的自然顺序就是声明常量的顺序。

指定者：
接口 Comparable<E extends Enum<E>> 中的 compareTo
参数：
o - 要比较的对象。
返回：
负整数、零或正整数，根据此对象是小于、等于还是大于指定对象。

getDeclaringClass

public final Class<E> getDeclaringClass()
返回与此枚举常量的枚举类型相对应的 Class 对象。当且仅当 e1.getDeclaringClass() == e2.getDeclaringClass() 时，两个枚举常量 e1 和 e2 的枚举类型才相同。（由该方法返回的值不同于由 Object.getClass() 方法返回的值，Object.getClass() 方法用于带有特定常量的类主体的枚举常量。）

返回：
与此枚举常量的枚举类型相对应的 Class 对象

valueOf

public static <T extends Enum<T>> T valueOf(Class<T> enumType,
                                            String name)
返回带指定名称的指定枚举类型的枚举常量。名称必须与在此类型中声明枚举常量所用的标识符完全匹配。（不允许使用额外的空白字符。）

参数：
enumType - 要从中返回常量的枚举类型的 Class 对象
name - 要返回的常量名称
返回：
带指定名称的指定枚举类型的枚举常量
抛出：
IllegalArgumentException - 如果指定枚举类型不包含指定名称的常量，或者指定类对象不表示枚举类型
NullPointerException - 如果 enumType 或 name 为空
从以下版本开始：
1.5

finalize

protected final void finalize()
枚举类不能有 finalize 方法。

覆盖：
类 Object 中的 finalize
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EnumConstantNotPresentException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 EnumConstantNotPresentException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.EnumConstantNotPresentException
所有已实现的接口：
Serializable
public class EnumConstantNotPresentException
extends RuntimeException

当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
EnumConstantNotPresentException(Class<? extends Enum> enumType, String constantName)
为指定常量构造一个 EnumConstantNotPresentException。
方法摘要
String | constantName() 返回缺少的枚举常量的名称。
Class<? extends Enum> | enumType() 返回缺少的枚举常量的类型。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

EnumConstantNotPresentException

public EnumConstantNotPresentException(Class<? extends Enum> enumType,
                                       String constantName)
为指定常量构造一个 EnumConstantNotPresentException。

参数：
enumType - 缺少的枚举常量的类型
constantName - 缺少的枚举常量的名称
方法详细信息

enumType

public Class<? extends Enum> enumType()
返回缺少的枚举常量的类型。

返回：
缺少的枚举常量的类型

constantName

public String constantName()
返回缺少的枚举常量的名称。

返回：
缺少的枚举常量名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Error (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Error

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
所有已实现的接口：
Serializable
直接已知子类：
AnnotationFormatError, AssertionError, AWTError, CoderMalfunctionError, FactoryConfigurationError, FactoryConfigurationError, IOError, LinkageError, ServiceConfigurationError, ThreadDeath, TransformerFactoryConfigurationError, VirtualMachineError
public class Error
extends Throwable

Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。大多数这样的错误都是异常条件。虽然 ThreadDeath 错误是一个“正规”的条件，但它也是 Error 的子类，因为大多数应用程序都不应该试图捕获它。

在执行该方法期间，无需在其 throws 子句中声明可能抛出但是未能捕获的 Error 的任何子类，因为这些错误可能是再也不会发生的异常条件。

从以下版本开始：
JDK1.0
另请参见：
ThreadDeath, 序列化表格

构造方法摘要
Error()
构造详细消息为 null 的新错误。
Error(String message)
构造带指定详细消息的新错误。
Error(String message, Throwable cause)
构造带指定详细消息和原因的新错误。
Error(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息来构造新的错误（通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Error

public Error()
构造详细消息为 null 的新错误。原因尚未进行初始化，可在以后通过调用 Throwable.initCause(java.lang.Throwable) 对其进行初始化。

Error

public Error(String message)
构造带指定详细消息的新错误。原因尚未进行初始化，可在以后通过调用 Throwable.initCause(java.lang.Throwable) 对其进行初始化。

参数：
message - 详细消息。保存详细消息，以便以后通过 Throwable.getMessage() 方法获取它。

Error

public Error(String message,
             Throwable cause)
构造带指定详细消息和原因的新错误。

注意，与 cause 相关的详细消息不是 自动合并到这个错误的详细消息中的。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。 （允许该参数为 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.4

Error

public Error(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息来构造新的错误（通常包含 cause 的类和详细消息）。对于错误而言，此构造方法与其他 throwable 的包装器一样有用。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。 （允许该参数为 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Exception (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Exception

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
所有已实现的接口：
Serializable
直接已知子类：
AclNotFoundException, ActivationException, AlreadyBoundException, ApplicationException, AWTException, BackingStoreException, BadAttributeValueExpException, BadBinaryOpValueExpException, BadLocationException, BadStringOperationException, BrokenBarrierException, CertificateException, ClassNotFoundException, CloneNotSupportedException, DataFormatException, DatatypeConfigurationException, DestroyFailedException, ExecutionException, ExpandVetoException, FontFormatException, GeneralSecurityException, GSSException, IllegalAccessException, IllegalClassFormatException, InstantiationException, InterruptedException, IntrospectionException, InvalidApplicationException, InvalidMidiDataException, InvalidPreferencesFormatException, InvalidTargetObjectTypeException, InvocationTargetException, IOException, JAXBException, JMException, KeySelectorException, LastOwnerException, LineUnavailableException, MarshalException, MidiUnavailableException, MimeTypeParseException, MimeTypeParseException, NamingException, NoninvertibleTransformException, NoSuchFieldException, NoSuchMethodException, NotBoundException, NotOwnerException, ParseException, ParserConfigurationException, PrinterException, PrintException, PrivilegedActionException, PropertyVetoException, RefreshFailedException, RemarshalException, RuntimeException, SAXException, ScriptException, ServerNotActiveException, SOAPException, SQLException, TimeoutException, TooManyListenersException, TransformerException, TransformException, UnmodifiableClassException, UnsupportedAudioFileException, UnsupportedCallbackException, UnsupportedFlavorException, UnsupportedLookAndFeelException, URIReferenceException, URISyntaxException, UserException, XAException, XMLParseException, XMLSignatureException, XMLStreamException, XPathException
public class Exception
extends Throwable

Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。

从以下版本开始：
JDK1.0
另请参见：
Error, 序列化表格

构造方法摘要
Exception()
构造详细消息为 null 的新异常。
Exception(String message)
构造带指定详细消息的新异常。
Exception(String message, Throwable cause)
构造带指定详细消息和原因的新异常。
Exception(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造新异常（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Exception

public Exception()
构造详细消息为 null 的新异常。原因尚未被初始化，可在以后通过调用 Throwable.initCause(java.lang.Throwable) 对其进行初始化。

Exception

public Exception(String message)
构造带指定详细消息的新异常。原因尚未被初始化，可在以后通过调用 Throwable.initCause(java.lang.Throwable) 对其进行初始化。

参数：
message - 详细消息。保存详细消息，以便以后通过 Throwable.getMessage() 方法获取它。

Exception

public Exception(String message,
                 Throwable cause)
构造带指定详细消息和原因的新异常。

注意，与 cause 相关的详细消息不是 自动合并到这个异常的详细消息中的。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过Throwable.getCause() 方法获取它）。 （允许使用 null 值，指出原因不存在或者是未知的。）
从以下版本开始：
1.4

Exception

public Exception(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造新异常（它通常包含 cause 的类和详细消息）。对于那些与其他可抛出异常（例如，PrivilegedActionException）的包装器相同的异常，此构造方法很有用。

参数：
cause - 原因（保存此原因，以便以后通过Throwable.getCause() 方法获取它）。 （允许使用 null 值，指出原因不存在或者是未知的。）
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExceptionInInitializerError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ExceptionInInitializerError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.ExceptionInInitializerError
所有已实现的接口：
Serializable
public class ExceptionInInitializerError
extends LinkageError

静态初始化程序中发生意外异常的信号。抛出 ExceptionInInitializerError 表明在计算静态初始值或静态变量的初始值期间发生异常。

从版本 1.4 开始，这个异常已经更新过，符合通用异常链机制。“保存的 throwable 对象”可能是在构造的时候提供的，并且可以通过 getException() 方法来访问，这类对象目前被认为是导致异常的原因，可以通过 Throwable.getCause() 方法以及前面提到的“遗留方法”访问它。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
ExceptionInInitializerError()
构造一个 ExceptionInInitializerError，使用 null 作为其详细消息字符串，并且不使用任何保存的 throwable 对象。
ExceptionInInitializerError(String s)
构造带指定详细消息的 ExceptionInInitializerError。
ExceptionInInitializerError(Throwable thrown)
保存对抛出的 Throwable 对象的引用，以便以后通过 getException() 方法对其进行获取，通过这种方式构造一个新的 ExceptionInInitializerError 类。
方法摘要
Throwable | getCause() 返回导致该错误的原因（导致发生此错误的静态初始化期间发生的异常）。
Throwable | getException() 返回静态初始化期间发生的异常，该异常导致发生此错误。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ExceptionInInitializerError

public ExceptionInInitializerError()
构造一个 ExceptionInInitializerError，使用 null 作为其详细消息字符串，并且不使用任何保存的 throwable 对象。详细消息是描述这个特定异常的 String。

ExceptionInInitializerError

public ExceptionInInitializerError(Throwable thrown)
保存对抛出的 Throwable 对象的引用，以便以后通过 getException() 方法对其进行获取，通过这种方式构造一个新的 ExceptionInInitializerError 类。 详细消息字符串被设置为 null。

参数：
thrown - 抛出的异常

ExceptionInInitializerError

public ExceptionInInitializerError(String s)
构造带指定详细消息的 ExceptionInInitializerError。详细消息是描述这个特定异常的 String。保存这个详细消息字符串，以便以后通过 Throwable.getMessage() 方法对其进行获取。没有任何保存的 throwable 对象。

参数：
s - 详细消息
方法详细信息

getException

public Throwable getException()
返回静态初始化期间发生的异常，该异常导致发生此错误。

该方法早于通用异常链设施。 Throwable.getCause() 方法现在首先被用来获得该信息。

返回：
此 ExceptionInInitializerError 的已保存的 throwable 对象；如果此 ExceptionInInitializerError 没有任何已保存的 throwable 对象，则返回 null。

getCause

public Throwable getCause()
返回导致该错误的原因（导致发生此错误的静态初始化期间发生的异常）。

覆盖：
类 Throwable 中的 getCause
返回：
造成该错误的原因；如果原因不存在或是未知的，则返回 null。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Float (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Float

java.lang.Object
    继承者  java.lang.Number
        继承者  java.lang.Float
所有已实现的接口：
Serializable, Comparable<Float>
public final class Float
extends Number
implements Comparable<Float>

Float 类在对象中包装一个基本类型 float 的值。Float 类型的对象包含一个 float 类型的字段。

此外，此类提供了几种方法，可将 float 类型与 String 类型互相转换，还提供了处理 float 类型时非常有用的其他一些常量和方法。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static int | MAX_EXPONENT 有限 float 变量可能具有的最大指数。
static float | MAX_VALUE 保存 float 类型的最大正有限值的常量，即 (2-2-23)·2127。
static int | MIN_EXPONENT 标准化 float 变量可能具有的最小指数。
static float | MIN_NORMAL 保存 float 类型数据的最小正标准值的常量，即 2-126。
static float | MIN_VALUE 保存 float 类型数据的最小正非零值的常量，即 2-149。
static float | NaN 保存 float 类型的非数字 (NaN) 值的常量。
static float | NEGATIVE_INFINITY 保存 float 类型的负无穷大值的常量。
static float | POSITIVE_INFINITY 保存 float 类型的正无穷大值的常量。
static int | SIZE 表示一个 float 值所使用的位数。
static Class<Float> | TYPE 表示 float 基本类型的 Class 实例。
构造方法摘要
Float(double value)
构造一个新分配的 Float 对象，它表示转换为 float 类型的参数。
Float(float value)
构造一个新分配的 Float 对象，它表示基本的 float 参数。
Float(String s)
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。
方法摘要
byte | byteValue() 将此 Float 值以 byte 形式返回（强制转换为 byte）。
static int | compare(float f1, float f2) 比较两个指定的 float 值。
int | compareTo(Float anotherFloat) 比较两个 Float 对象所表示的数值。
double | doubleValue() 返回此 Float 对象的 double 值。
boolean | equals(Object obj) 将此对象与指定对象进行比较。
static int | floatToIntBits(float value) 根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式。
static int | floatToRawIntBits(float value) 根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式，并保留非数字 (NaN) 值。
float | floatValue() 返回此 Float 对象的 float 值。
int | hashCode() 返回此 Float 对象的哈希码。
static float | intBitsToFloat(int bits) 返回对应于给定位表示形式的 float 值。
int | intValue() 将此 Float 值以 int 形式返回（强制转换为 int 类型）。
boolean | isInfinite() 如果此 Float 值的大小是无穷大，则返回 true，否则返回 false。
static boolean | isInfinite(float v) 如果指定数的数值是无穷大，则返回 true，否则返回 false。
boolean | isNaN() 如果此 Float 值是一个非数字 (NaN) 值，则返回 true，否则返回 false。
static boolean | isNaN(float v) 如果指定的数是一个非数字 (NaN) 值，则返回 true，否则返回 false。
long | longValue() 将此 Float 值以 long 形式返回（强制转换为 long 类型）。
static float | parseFloat(String s) 返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。
short | shortValue() 将此 Float 值以 short 形式返回（强制转换为 short）。
static String | toHexString(float f) 返回 float 参数的十六进制字符串表示形式。
String | toString() 返回此 Float 对象的字符串表示形式。
static String | toString(float f) 返回 float 参数的字符串表示形式。
static Float | valueOf(float f) 返回表示指定的 float 值的 Float 实例。
static Float | valueOf(String s) 返回保存用参数字符串 s 表示的 float 值的 Float 对象。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

POSITIVE_INFINITY

public static final float POSITIVE_INFINITY
保存 float 类型的正无穷大值的常量。它等于 Float.intBitsToFloat(0x7f800000) 返回的值。

另请参见：
常量字段值

NEGATIVE_INFINITY

public static final float NEGATIVE_INFINITY
保存 float 类型的负无穷大值的常量。它等于 Float.intBitsToFloat(0xff800000) 返回的值。

另请参见：
常量字段值

NaN

public static final float NaN
保存 float 类型的非数字 (NaN) 值的常量。它等于 Float.intBitsToFloat(0x7fc00000) 返回的值。

另请参见：
常量字段值

MAX_VALUE

public static final float MAX_VALUE
保存 float 类型的最大正有限值的常量，即 (2-2-23)·2127。它等于十六进制的浮点字面值 0x1.fffffeP+127f，也等于 Float.intBitsToFloat(0x7f7fffff)。

另请参见：
常量字段值

MIN_NORMAL

public static final float MIN_NORMAL
保存 float 类型数据的最小正标准值的常量，即 2-126。它等于十六进制的浮点字面值 0x1.0p-126f，也等于 Float.intBitsToFloat(0x00800000)。

从以下版本开始：
1.6
另请参见：
常量字段值

MIN_VALUE

public static final float MIN_VALUE
保存 float 类型数据的最小正非零值的常量，即 2-149。它等于十六进制的浮点字面值 0x0.000002P-126f，也等于 Float.intBitsToFloat(0x1)。

另请参见：
常量字段值

MAX_EXPONENT

public static final int MAX_EXPONENT
有限 float 变量可能具有的最大指数。它等于 Math.getExponent(Float.MAX_VALUE) 返回的值。

从以下版本开始：
1.6
另请参见：
常量字段值

MIN_EXPONENT

public static final int MIN_EXPONENT
标准化 float 变量可能具有的最小指数。它等于 Math.getExponent(Float.MIN_NORMAL) 返回的值。

从以下版本开始：
1.6
另请参见：
常量字段值

SIZE

public static final int SIZE
表示一个 float 值所使用的位数。

从以下版本开始：
1.5
另请参见：
常量字段值

TYPE

public static final Class<Float> TYPE
表示 float 基本类型的 Class 实例。

从以下版本开始：
JDK1.1
构造方法详细信息

Float

public Float(float value)
构造一个新分配的 Float 对象，它表示基本的 float 参数。

参数：
value - 用 Float 表示的值。

Float

public Float(double value)
构造一个新分配的 Float 对象，它表示转换为 float 类型的参数。

参数：
value - 用 Float 表示的值。

Float

public Float(String s)
      throws NumberFormatException
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。字符串将被转换为 float 值，这与 valueOf 方法一样。

参数：
s - 将转换为 Float 值的字符串。
抛出：
NumberFormatException - 如果字符串不包含可解析的数字。
另请参见：
valueOf(java.lang.String)
方法详细信息

toString

public static String toString(float f)
返回 float 参数的字符串表示形式。下面提到的所有字符都是 ASCII 字符。
  • 如果参数是 NaN，那么结果是字符串 "NaN"。
  • 否则，结果是表示参数的符号和数值（绝对值）的字符串。如果符号为负，那么结果的第一个字符是 '-' ('\u002D')；如果符号为正，则结果中不显示符号字符。至于数值 m：
    • 如果 m 为无穷大，则用字符串 "Infinity" 表示；因此，正无穷大生成结果 "Infinity"，负无穷大生成结果 "-Infinity"。
    • 如果 m 为 0，则用字符 "0.0" 表示；因此，负 0 生成结果 "-0.0"，正 0 生成结果 "0.0"。
    • 如果 m 大于等于 10-3，但小于 107，则采用不带前导 0 的十进制形式，用 m 的整数部分表示，后跟 '.' ('\u002E')，再后面是表示 m 小数部分的一个或多个十进制位数。
    • 如果 m 小于 10-3 或大于等于 107，则用所谓的“计算机科学记数法”表示。设 n 为满足 10n <= m < 10n+1 的唯一整数；然后设 a 为 m 与 10n 的精确算术商数值，从而 1 <= a < 10。那么，数值便表示为 a 的整数部分，其形式为：一个十进制位数，后跟 '.' ('apos;)，接着是表示 a 小数部分的十进制位数，再后面是字母 'E' ('\u0045')，最后是用十进制整数形式表示的 n，这与方法 Integer.toString(int) 生成的结果一样。
必须为 m 或 a 的小数部分打印多少位呢？至少必须有一位数来表示小数部分，除此之外，需要更多（但只能和需要的一样多）位数来唯一地区分参数值和 float 类型的邻近值。也就是说，假设 x 是用十进制表示法表示的精确算术值，是通过对有限非 0 参数 f 调用此方法生成的。那么 f 一定是最接近 x 的 float 值，如果有两个 float 值同等地接近于 x，那么 f 必须是这两个值中的一个，并且 f 的最低有效位必须是 0。

要创建浮点值的本地化字符串表示形式，请使用 NumberFormat 的子类。

参数：
f - 要转换的浮点型数据。
返回：
参数的字符串表示形式。

toHexString

public static String toHexString(float f)
返回 float 参数的十六进制字符串表示形式。下面提到的所有字符都是 ASCII 字符。
  • 如果参数为 NaN，那么结果是字符串 "NaN"。
  • 否则，结果是表示参数的符号和数值（绝对值）的字符串。如果符号为负，那么结果的第一个字符是 '-' ('\u002D')；如果符号为正，则结果中不显示符号字符。至于数值 m：
    • 如果 m 为无穷大，则用字符串 "Infinity" 表示；因此，正无穷大生成结果 "Infinity"，负无穷大生成结果 "-Infinity"。
    • 如果 m 为 0，则用字符串 "0x0.0p0" 表示；因此，负 0 生成结果 "-0x0.0p0"，正 0 生成结果 "0x0.0p0"。
    • 如果 m 是具有标准化表示形式的 float 值，则使用子字符串表示有效位数和指数。有效位数用字符串 "0x1." 表示，后跟该有效位数小数部分的小写十六进制表示形式。除非所有位数都为 0，否则移除十六进制表示形式中的尾部 0，在所有位数为 0 的情况下，可以用一个 0 表示。然后用 "p" 表示指数，后跟无偏指数的十进制字符串，该值与对指数值调用 Integer.toString 生成的值相同。
    • 如果 m 是具有 subnormal 表示形式的 float 值，则用字符 "0x0." 表示有效位数，后跟该有效位数小数部分的十六进制表示形式。移除十六进制表示形式中的尾部 0。然后用 "p-126" 表示指数。注意，在 subnormal 有效位数中，至少必须有一个非 0 位数。

示例
浮点值 | 十六进制字符串
1.0 | 0x1.0p0
-1.0 | -0x1.0p0
2.0 | 0x1.0p1
3.0 | 0x1.8p1
0.5 | 0x1.0p-1
0.25 | 0x1.0p-2
Float.MAX_VALUE | 0x1.fffffep127
Minimum Normal Value | 0x1.0p-126
Maximum Subnormal Value | 0x0.fffffep-126
Float.MIN_VALUE | 0x0.000002p-126

参数：
f - 要转换的 float 值。
返回：
参数的十六进制字符串表示形式。
从以下版本开始：
1.5

valueOf

public static Float valueOf(String s)
                     throws NumberFormatException
返回保存用参数字符串 s 表示的 float 值的 Float 对象。

如果 s 为 null，则抛出 NullPointerException 异常。

忽略 s 中的前导空白字符和尾部空白字符。就像调用 String.trim() 方法那样移除空白；也就是说，ASCII 空格和控制字符都要移除。s 的其余部分应该根据词法语法规则描述构成 FloatValue：

FloatValue:
Signopt NaN
Signopt Infinity
Signopt FloatingPointLiteral
Signopt HexFloatingPointLiteral
SignedInteger

HexFloatingPointLiteral:
HexSignificand BinaryExponent FloatTypeSuffixopt

HexSignificand:
HexNumeral
HexNumeral .
0x HexDigitsopt .HexDigits
0X HexDigitsopt .HexDigits

BinaryExponent:
BinaryExponentIndicator SignedInteger

BinaryExponentIndicator:
p
P
其中，Sign、FloatingPointLiteral、HexNumeral、HexDigits、SignedInteger 和 FloatTypeSuffix 与 Java Language Specification 的词法结构部分中的定义相同。如果 s 的表示形式不是 FloatValue，则抛出 NumberFormatException。否则，可以认为 s 表示的是常用“计算机科学记数法”表示的精确十进制值，或者是一个精确的十六进制值；在概念上，这个精确的数值被转换一个“无限精确的”二进制值，然后根据常用 IEEE 754 浮点算法的“舍入为最接近的数”规则将该值舍入为 float 类型，其中包括保留 0 值的符号。最后，返回表示这个 float 值的 Float 对象。

要解释浮点值的本地化字符串表示形式，请使用 NumberFormat 的子类。

注意，尾部格式说明符、确定浮点字面值类型的说明符（1.0f 是一个 float 值；1.0d 是一个 double 值）不会 影响此方法的结果。换句话说，输入字符串的数值被直接转换为目标浮点类型。通常，分两步的转换（先将字符串转换为 double 类型，然后将 double 类型转换为 float 类型）不 同于直接将字符串转换为 float 类型。例如，如果首先转换为中间类型 double，然后再转换为 float 类型，则字符串
"1.00000017881393421514957253748434595763683319091796875001d"
将得到 float 值 1.0000002f；如果直接将字符串转换为 float 值，则结果将是 1.0000001f。

为了避免对无效字符串调用此方法并导致抛出 NumberFormatException，Double.valueOf 的文档中列出了一个正则表达式，可以用该表达式在屏幕上显示输入。

参数：
s - 要解析的字符串。
返回：
保存用 String 参数表示的值的 Float 对象。
抛出：
NumberFormatException - 如果字符串不包含可解析的数字。

valueOf

public static Float valueOf(float f)
返回表示指定的 float 值的 Float 实例。如果不需要新的 Float 实例，则通常应优先使用此方法，而不是构造方法 Float(float)，因为此方法可能通过缓存经常请求的值来显著提高空间和时间性能。

参数：
f - 一个浮点值。
返回：
一个表示 f 的 Float 实例。
从以下版本开始：
1.5

parseFloat

public static float parseFloat(String s)
                        throws NumberFormatException
返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。

参数：
s - 要解析的字符串。
返回：
用字符串参数表示的 float 值。
抛出：
NumberFormatException - 如果字符串不包含可解析的 float 值。
从以下版本开始：
1.2
另请参见：
valueOf(String)

isNaN

public static boolean isNaN(float v)
如果指定的数是一个非数字 (NaN) 值，则返回 true，否则返回 false。

参数：
v - 要测试的值。
返回：
如果参数为 NaN，则返回 true；否则返回 false。

isInfinite

public static boolean isInfinite(float v)
如果指定数的数值是无穷大，则返回 true，否则返回 false。

参数：
v - 要测试的值。
返回：
如果参数是正无穷大或负无穷大，则返回 true；否则返回 false。

isNaN

public boolean isNaN()
如果此 Float 值是一个非数字 (NaN) 值，则返回 true，否则返回 false。

返回：
如果此对象表示的值是 NaN，则返回 true；否则返回 false。

isInfinite

public boolean isInfinite()
如果此 Float 值的大小是无穷大，则返回 true，否则返回 false。

返回：
如果此对象表示的值是正无穷大或负无穷大，则返回 true；否则返回 false。

toString

public String toString()
返回此 Float 对象的字符串表示形式。使用此对象表示的基本 float 值被转换为一个 String，此方法与带一个参数的 toString 方法完全一样。

覆盖：
类 Object 中的 toString
返回：
此对象的 String 表示。
另请参见：
toString(float)

byteValue

public byte byteValue()
将此 Float 值以 byte 形式返回（强制转换为 byte）。

覆盖：
类 Number 中的 byteValue
返回：
此对象表示的 float 值，该值被转换为 byte 类型

shortValue

public short shortValue()
将此 Float 值以 short 形式返回（强制转换为 short）。

覆盖：
类 Number 中的 shortValue
返回：
此对象表示的 float 值，该值被转换为 short 类型
从以下版本开始：
JDK1.1

intValue

public int intValue()
将此 Float 值以 int 形式返回（强制转换为 int 类型）。

指定者：
类 Number 中的 intValue
返回：
此对象表示的 float 值，该值被转换为 int 类型

longValue

public long longValue()
将此 Float 值以 long 形式返回（强制转换为 long 类型）。

指定者：
类 Number 中的 longValue
返回：
此对象表示的 float 值，该值被转换为 long 类型

floatValue

public float floatValue()
返回此 Float 对象的 float 值。

指定者：
类 Number 中的 floatValue
返回：
此对象表示的 float 值。

doubleValue

public double doubleValue()
返回此 Float 对象的 double 值。

指定者：
类 Number 中的 doubleValue
返回：
此对象表示的 float 值被转换为 double 类型，并返回转换的结果。

hashCode

public int hashCode()
返回此 Float 对象的哈希码。结果是此 Float 对象表示的基本 float 值的整数位表示形式，与 floatToIntBits(float) 方法生成的结果完全一样。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象进行比较。当且仅当参数不是 null 而是 Float 对象，且表示的 float 值与此对象表示的 float 值相同时，结果为 true。为此，当且仅当将方法 #floatToLongBits(double) 应用于两个值所返回的 int 值相同时，才认为这两个 float 值相同。

注意，在大多数情况下，对于 Float 类的两个实例 f1 和 f2，当且仅当

f1.floatValue() == f2.floatValue()

的值为 true 时，f1.equals(f2) 的值才为 true。但是，有以下两种例外情况：

  • 如果 f1 和 f2 都表示 Float.NaN，那么即使 Float.NaN==Float.NaN 的值为 false，equals 方法也将返回 true。
  • 如果 f1 表示 +0.0f，而 f2 表示 -0.0f，或相反，那么即使 0.0f==-0.0f 的值为 true，equal 测试也将返回 false。
该定义使得哈希表得以正确操作。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象
返回：
如果对象是相同的，则返回 true；否则返回 false。
另请参见：
floatToIntBits(float)

floatToIntBits

public static int floatToIntBits(float value)
根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式。

第 31 位（掩码 0x80000000 选定的位）表示浮点数的符号。第 30-23 位（掩码 0x7f800000 选定的位）表示指数。第 22-0 位（掩码 0x007fffff 选定的位）表示浮点数的有效位数（有时也称为尾数）。

如果参数为正无穷大，则结果为 0x7f800000。

如果参数为负无穷大，则结果为 0xff800000。

如果参数为 NaN，则结果为 0x7fc00000。

在所有情况下，结果都是一个整数，将其赋予 intBitsToFloat(int) 方法将生成一个浮点值，该浮点值与 floatToIntBits 的参数相同（而所有 NaN 值则会生成一个“规范”NaN 值）。

参数：
value - 一个浮点数。
返回：
表示浮点数的位。

floatToRawIntBits

public static int floatToRawIntBits(float value)
根据 IEEE 754 浮点“单一格式”位布局，返回指定浮点值的表示形式，并保留非数字 (NaN) 值。

第 31 位（掩码 0x80000000 选定的位）表示浮点数的符号。第 30-23 位（掩码 0x7f800000 选定的位）表示指数。第 22-0 位（掩码 0x007fffff 选定的位）表示浮点数的有效位数（有时也称为尾数）。

如果参数为正无穷大，则结果为 0x7f800000。

如果参数为负无穷大，则结果为 0xff800000。

如果参数为 NaN，则结果是表示实际 NaN 值的整数。与 floatToIntBits 方法不同，floatToRawIntBits 不压缩所有将 NaN 编码为一个“规范”NaN 值的位模式。

在所有情况下，结果都是一个整数，将其赋予 intBitsToFloat(int) 方法将生成一个与 floatToRawIntBits 的参数相同的浮点值。

参数：
value - 一个浮点数字。
返回：
表示浮点数字的位。
从以下版本开始：
1.3

intBitsToFloat

public static float intBitsToFloat(int bits)
返回对应于给定位表示形式的 float 值。根据 IEEE 754 浮点“单一格式”位布局，该参数被视为浮点值表示形式。

如果参数为 0x7f800000，则结果为正无穷大。

如果参数为 0xff800000，则结果为负无穷大。

如果参数值在 0x7f800001 到 0x7fffffff 或在 0xff800001 到 0xffffffff 之间，则结果为 NaN。Java 提供的任何 IEEE 754 浮点操作都不能区分具有不同位模式的两个同类型 NaN 值。不同的 NaN 值只能使用 Float.floatToRawIntBits 方法区分。

在所有其他情况下，设 s、e 和 m 为可以通过以下参数进行计算的三个值；

int s = ((bits >> 31) == 0) ? 1 : -1;
int e = ((bits >> 23) & 0xff);
int m = (e == 0) ?
                (bits & 0x7fffff) << 1 :
                (bits & 0x7fffff) | 0x800000;
那么浮点结果等于算术表达式 s·m·2e-150 的值。

注意，此方法不能返回与 int 参数具有完全相同位模式的 float NaN 值。IEEE 754 区分了两种 NaN：quiet NaN 和 signaling NaN。这两种 NaN 之间的差别在 Java 中通常是不可见的。对 signaling NaN 进行的算术运算将它们转换为具有不同（但通常类似）位模式的 quiet NaN。但在某些只复制 signaling NaN 的处理器上也执行这种转换。特别是在复制 signaling NaN 以将其返回给调用方法时，可能会执行这种转换。因此，intBitsToFloat 可能无法返回具有 signaling NaN 位模式的 float 值。所以，对于某些 int 值，floatToRawIntBits(intBitsToFloat(start)) 可能不 等于 start。此外，尽管所有 NaN 位模式（不管是 quiet NaN 还是 signaling NaN）都必须在前面确定的 NaN 范围内，但表示 signaling NaN 的特定位模式是与平台有关。

参数：
bits - 一个整数。
返回：
具有相同位模式的 float 浮点值。

compareTo

public int compareTo(Float anotherFloat)
比较两个 Float 对象所表示的数值。在应用到基本 float 值时，有两种方法可以比较执行此方法产生的值与执行 Java 语言的数字比较运算符（<、<=、== 和 >= >）产生的那些值之间的区别：
  • 此方法认为 Float.NaN 等于其自身，且大于其他所有 float 值（包括 Float.POSITIVE_INFINITY）。
  • 此方法认为 0.0f 大于 -0.0f。
这可以确保受此方法影响的 Float 对象的自然顺序与 equals 一致。

指定者：
接口 Comparable<Float> 中的 compareTo
参数：
anotherFloat - 要比较的 Float 值。
返回：
如果 anotherFloat 在数字上等于此 Float，则返回 0；如果 anotherFloat 在数字上小于此 Float，则返回小于 0 的值；如果 anotherFloat 在数字上大于此 Float，则返回大于 0 的值。
从以下版本开始：
1.2
另请参见：
Comparable.compareTo(Object)

compare

public static int compare(float f1,
                          float f2)
比较两个指定的 float 值。返回整数值的符号与以下调用返回整数的符号相同：
   new Float(f1).compareTo(new Float(f2))

参数：
f1 - 要比较的第一个 float 值。
f1 - 要比较的第二个 float 值。
返回：
如果 f1 在数字上等于此 f2，则返回值为 0；如果 f1 在数字上小于此 f2，则返回小于 0 的值；如果 f1 在数字上大于此 f2，则返回大于 0 的值。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalAccessError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IllegalAccessError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.IncompatibleClassChangeError
                    继承者  java.lang.IllegalAccessError
所有已实现的接口：
Serializable
public class IllegalAccessError
extends IncompatibleClassChangeError

当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。

通常由编译器捕获此错误；如果类定义中存在不兼容的更改，则此错误将只可能发生在运行时。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
IllegalAccessError()
构造不带详细消息的 IllegalAccessError。
IllegalAccessError(String s)
构造带指定详细消息的 IllegalAccessError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalAccessError

public IllegalAccessError()
构造不带详细消息的 IllegalAccessError。

IllegalAccessError

public IllegalAccessError(String s)
构造带指定详细消息的 IllegalAccessError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalAccessException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IllegalAccessException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.IllegalAccessException
所有已实现的接口：
Serializable
public class IllegalAccessException
extends Exception

当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。

从以下版本开始：
JDK1.0
另请参见：
Class.newInstance(),
Field.set(Object, Object),
Field.setBoolean(Object, boolean),
Field.setByte(Object, byte),
Field.setShort(Object, short),
Field.setChar(Object, char),
Field.setInt(Object, int),
Field.setLong(Object, long),
Field.setFloat(Object, float),
Field.setDouble(Object, double),
Field.get(Object),
Field.getBoolean(Object),
Field.getByte(Object),
Field.getShort(Object),
Field.getChar(Object),
Field.getInt(Object),
Field.getLong(Object),
Field.getFloat(Object),
Field.getDouble(Object),
Method.invoke(Object, Object[]),
Constructor.newInstance(Object[]),
序列化表格

构造方法摘要
IllegalAccessException()
构造不带详细消息的 IllegalAccessException 。
IllegalAccessException(String s)
构造带指定详细消息的 IllegalAccessException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalAccessException

public IllegalAccessException()
构造不带详细消息的 IllegalAccessException 。

IllegalAccessException

public IllegalAccessException(String s)
构造带指定详细消息的 IllegalAccessException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalArgumentException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IllegalArgumentException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
所有已实现的接口：
Serializable
直接已知子类：
IllegalCharsetNameException, IllegalFormatException, IllegalSelectorException, IllegalThreadStateException, InvalidKeyException, InvalidOpenTypeException, InvalidParameterException, KeyAlreadyExistsException, NumberFormatException, PatternSyntaxException, UnresolvedAddressException, UnsupportedAddressTypeException, UnsupportedCharsetException
public class IllegalArgumentException
extends RuntimeException

抛出的异常表明向方法传递了一个不合法或不正确的参数。

从以下版本开始：
JDK1.0
另请参见：
Thread.setPriority(int), 序列化表格

构造方法摘要
IllegalArgumentException()
构造不带详细消息的 IllegalArgumentException。
IllegalArgumentException(String s)
构造带指定详细消息的 IllegalArgumentException。
IllegalArgumentException(String message, Throwable cause)
根据指定的详细消息和原因构造一个新异常。
IllegalArgumentException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息构造一个新异常（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalArgumentException

public IllegalArgumentException()
构造不带详细消息的 IllegalArgumentException。

IllegalArgumentException

public IllegalArgumentException(String s)
构造带指定详细消息的 IllegalArgumentException。

参数：
s - 详细消息。

IllegalArgumentException

public IllegalArgumentException(String message,
                                Throwable cause)
根据指定的详细消息和原因构造一个新异常。

注意，与 cause 相关的详细消息不是 自动合并到这个异常的详细消息中的。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

IllegalArgumentException

public IllegalArgumentException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息构造一个新异常（它通常包含 cause 的类和详细消息）。 此构造方法对于那些与其他 throwable（例如，PrivilegedActionException）的包装器相同的异常来说是有用的。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalMonitorStateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IllegalMonitorStateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalMonitorStateException
所有已实现的接口：
Serializable
public class IllegalMonitorStateException
extends RuntimeException

抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。

从以下版本开始：
JDK1.0
另请参见：
Object.notify(),
Object.notifyAll(),
Object.wait(),
Object.wait(long),
Object.wait(long, int),
序列化表格

构造方法摘要
IllegalMonitorStateException()
构造不带详细消息的 IllegalMonitorStateException。
IllegalMonitorStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalMonitorStateException

public IllegalMonitorStateException()
构造不带详细消息的 IllegalMonitorStateException。

IllegalMonitorStateException

public IllegalMonitorStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalStateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IllegalStateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
所有已实现的接口：
Serializable
直接已知子类：
AlreadyConnectedException, CancellationException, CancelledKeyException, ClosedSelectorException, ConnectionPendingException, FormatterClosedException, IllegalBlockingModeException, IllegalComponentStateException, InvalidDnDOperationException, InvalidMarkException, NoConnectionPendingException, NonReadableChannelException, NonWritableChannelException, NotYetBoundException, NotYetConnectedException, OverlappingFileLockException
public class IllegalStateException
extends RuntimeException

在非法或不适当的时间调用方法时产生的信号。换句话说，即 Java 环境或 Java 应用程序没有处于请求操作所要求的适当状态下。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
IllegalStateException()
构造不带详细消息的 IllegalStateException。
IllegalStateException(String s)
构造带指定详细消息的 IllegalStateException。
IllegalStateException(String message, Throwable cause)
构造一个新异常，它带有指定的详细消息和原因。
IllegalStateException(Throwable cause)
构造一个新异常，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalStateException

public IllegalStateException()
构造不带详细消息的 IllegalStateException。详细消息是描述这个特定异常的 String。

IllegalStateException

public IllegalStateException(String s)
构造带指定详细消息的 IllegalStateException。详细消息是描述这个特定异常的 String。

参数：
s - 包含详细消息的 String

IllegalStateException

public IllegalStateException(String message,
                             Throwable cause)
构造一个新异常，它带有指定的详细消息和原因。

注意，与 cause 相关的详细消息不是 自动合并到这个异常的详细消息中的。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值， 指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

IllegalStateException

public IllegalStateException(Throwable cause)
构造一个新异常，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含 cause 的类和详细消息）。此构造方法对于那些与其他 throwable（例如，PrivilegedActionException）的包装器相同的异常是有用的。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalThreadStateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IllegalThreadStateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.lang.IllegalThreadStateException
所有已实现的接口：
Serializable
public class IllegalThreadStateException
extends IllegalArgumentException

指示线程没有处于请求操作所要求的适当状态时抛出的异常。例如，请参见 Thread 类中的 suspend 和 resume 方法。

从以下版本开始：
JDK1.0
另请参见：
Thread.resume(), Thread.suspend(), 序列化表格

构造方法摘要
IllegalThreadStateException()
构造不带详细消息的 IllegalThreadStateException。
IllegalThreadStateException(String s)
构造带指定详细消息的 IllegalThreadStateException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalThreadStateException

public IllegalThreadStateException()
构造不带详细消息的 IllegalThreadStateException。

IllegalThreadStateException

public IllegalThreadStateException(String s)
构造带指定详细消息的 IllegalThreadStateException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IncompatibleClassChangeError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IncompatibleClassChangeError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.IncompatibleClassChangeError
所有已实现的接口：
Serializable
直接已知子类：
AbstractMethodError, IllegalAccessError, InstantiationError, NoSuchFieldError, NoSuchMethodError
public class IncompatibleClassChangeError
extends LinkageError

在某些类定义中出现不兼容的类更改时抛出该异常。某些目前执行的方法所依赖的类定义已发生了变化。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
IncompatibleClassChangeError()
构造不带详细消息的 IncompatibleClassChangeError。
IncompatibleClassChangeError(String s)
构造带指定详细消息的 IncompatibleClassChangeError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IncompatibleClassChangeError

public IncompatibleClassChangeError()
构造不带详细消息的 IncompatibleClassChangeError。

IncompatibleClassChangeError

public IncompatibleClassChangeError(String s)
构造带指定详细消息的 IncompatibleClassChangeError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IndexOutOfBoundsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 IndexOutOfBoundsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IndexOutOfBoundsException
所有已实现的接口：
Serializable
直接已知子类：
ArrayIndexOutOfBoundsException, StringIndexOutOfBoundsException
public class IndexOutOfBoundsException
extends RuntimeException

指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。

应用程序可以为这个类创建子类，以指示类似的异常。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
IndexOutOfBoundsException()
构造不带详细消息的 IndexOutOfBoundsException。
IndexOutOfBoundsException(String s)
构造带指定详细消息的 IndexOutOfBoundsException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IndexOutOfBoundsException

public IndexOutOfBoundsException()
构造不带详细消息的 IndexOutOfBoundsException。

IndexOutOfBoundsException

public IndexOutOfBoundsException(String s)
构造带指定详细消息的 IndexOutOfBoundsException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InheritableThreadLocal (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 InheritableThreadLocal<T>

java.lang.Object
    继承者  java.lang.ThreadLocal<T>
        继承者  java.lang.InheritableThreadLocal<T>

public class InheritableThreadLocal<T>
extends ThreadLocal<T>

该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。通常，子线程的值与父线程的值是一致的；但是，通过重写这个类中的 childValue 方法，子线程的值可以作为父线程值的一个任意函数。

当必须将变量（如用户 ID 和 事务 ID）中维护的每线程属性（per-thread-attribute）自动传送给创建的所有子线程时，应尽可能地采用可继承的线程局部变量，而不是采用普通的线程局部变量。

从以下版本开始：
1.2
另请参见：
ThreadLocal

构造方法摘要
InheritableThreadLocal()
方法摘要
protected  T childValue(T parentValue)
在创建子线程时，计算这个可继承线程局部变量的子线程的初始值，将该值作为父线程值的一个函数。
从类 java.lang.ThreadLocal 继承的方法
get, initialValue, remove, set
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InheritableThreadLocal

public InheritableThreadLocal()
方法详细信息

childValue

protected T childValue(T parentValue)
在创建子线程时，计算这个可继承线程局部变量的子线程的初始值，将该值作为父线程值的一个函数。在启动子线程之前，从父线程内部调用此方法。

该方法仅返回其输入变量，如果所需要的是其他行为，则应该重写此方法。

参数：
parentValue - 父线程的值
返回：
子线程的初始值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InstantiationError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 InstantiationError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.IncompatibleClassChangeError
                    继承者  java.lang.InstantiationError
所有已实现的接口：
Serializable
public class InstantiationError
extends IncompatibleClassChangeError

当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。

通常由编译器捕获此错误；如果类定义中存在不兼容的更改，则此错误将只可能发生在运行时。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
InstantiationError()
构造不带详细消息的 InstantiationError。
InstantiationError(String s)
构造带指定详细消息的 InstantiationError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InstantiationError

public InstantiationError()
构造不带详细消息的 InstantiationError。

InstantiationError

public InstantiationError(String s)
构造带指定详细消息的 InstantiationError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InstantiationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 InstantiationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.InstantiationException
所有已实现的接口：
Serializable
public class InstantiationException
extends Exception

当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。实例化失败有很多原因，包括但不仅限于以下原因：

  • 类对象表示一个抽象类、接口、数组类、基本类型、void
  • 类没有非 null 构造方法

从以下版本开始：
JDK1.0
另请参见：
Class.newInstance(), 序列化表格

构造方法摘要
InstantiationException()
构造不带详细消息的 InstantiationException。
InstantiationException(String s)
构造带指定详细消息的 InstantiationException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InstantiationException

public InstantiationException()
构造不带详细消息的 InstantiationException。

InstantiationException

public InstantiationException(String s)
构造带指定详细消息的 InstantiationException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Integer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Integer

java.lang.Object
    继承者  java.lang.Number
        继承者  java.lang.Integer
所有已实现的接口：
Serializable, Comparable<Integer>
public final class Integer
extends Number
implements Comparable<Integer>

Integer 类在对象中包装了一个基本类型 int 的值。Integer 类型的对象包含一个 int 类型的字段。

此外，该类提供了多个方法，能在 int 类型和 String 类型之间互相转换，还提供了处理 int 类型时非常有用的其他一些常量和方法。

实现注意事项：“bit twiddling”方法（如 highestOneBit 和 numberOfTrailingZeros）的实现基于 Henry S. Warren, Jr.撰写的 Hacker's Delight（Addison Wesley, 2002）中的一些有关材料。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static int | MAX_VALUE 值为 231－1 的常量，它表示 int 类型能够表示的最大值。
static int | MIN_VALUE 值为 －231 的常量，它表示 int 类型能够表示的最小值。
static int | SIZE 用来以二进制补码形式表示 int 值的比特位数。
static Class<Integer> | TYPE 表示基本类型 int 的 Class 实例。
构造方法摘要
Integer(int value)
构造一个新分配的 Integer 对象，它表示指定的 int 值。
Integer(String s)
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。
方法摘要
static int | bitCount(int i) 返回指定 int 值的二进制补码表示形式的 1 位的数量。
byte | byteValue() 以 byte 类型返回该 Integer 的值。
int | compareTo(Integer anotherInteger) 在数字上比较两个 Integer 对象。
static Integer | decode(String nm) 将 String 解码为 Integer。
double | doubleValue() 以 double 类型返回该 Integer 的值。
boolean | equals(Object obj) 比较此对象与指定对象。
float | floatValue() 以 float 类型返回该 Integer 的值。
static Integer | getInteger(String nm) 确定具有指定名称的系统属性的整数值。
static Integer | getInteger(String nm, int val) 确定具有指定名称的系统属性的整数值。
static Integer | getInteger(String nm, Integer val) 返回具有指定名称的系统属性的整数值。
int | hashCode() 返回此 Integer 的哈希码。
static int | highestOneBit(int i) 返回具有至多单个 1 位的 int 值，在指定的 int 值中最高位（最左边）的 1 位的位置。
int | intValue() 以 int 类型返回该 Integer 的值。
long | longValue() 以 long 类型返回该 Integer 的值。
static int | lowestOneBit(int i) 返回具有至多单个 1 位的 int 值，在指定的 int 值中最低位（最右边）的 1 位的位置。
static int | numberOfLeadingZeros(int i) 在指定 int 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。
static int | numberOfTrailingZeros(int i) 返回指定的 int 值的二进制补码表示形式中最低（“最右边”）的为 1 的位后面的零位个数。
static int | parseInt(String s) 将字符串参数作为有符号的十进制整数进行解析。
static int | parseInt(String s, int radix) 使用第二个参数指定的基数，将字符串参数解析为有符号的整数。
static int | reverse(int i) 返回通过反转指定 int 值的二进制补码表示形式中位的顺序而获得的值。
static int | reverseBytes(int i) 返回通过反转指定 int 值的二进制补码表示形式中字节的顺序而获得的值。
static int | rotateLeft(int i, int distance) 返回根据指定的位数循环左移指定的 int 值的二进制补码表示形式而得到的值。
static int | rotateRight(int i, int distance) 返回根据指定的位数循环右移指定的 int 值的二进制补码表示形式而得到的值。
short | shortValue() 以 short 类型返回该 Integer 的值。
static int | signum(int i) 返回指定 int 值的符号函数。
static String | toBinaryString(int i) 以二进制（基数 2）无符号整数形式返回一个整数参数的字符串表示形式。
static String | toHexString(int i) 以十六进制（基数 16）无符号整数形式返回一个整数参数的字符串表示形式。
static String | toOctalString(int i) 以八进制（基数 8）无符号整数形式返回一个整数参数的字符串表示形式。
String | toString() 返回一个表示该 Integer 值的 String 对象。
static String | toString(int i) 返回一个表示指定整数的 String 对象。
static String | toString(int i, int radix) 返回用第二个参数指定基数表示的第一个参数的字符串表示形式。
static Integer | valueOf(int i) 返回一个表示指定的 int 值的 Integer 实例。
static Integer | valueOf(String s) 返回保存指定的 String 的值的 Integer 对象。
static Integer | valueOf(String s, int radix) 返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MIN_VALUE

public static final int MIN_VALUE
值为 －231 的常量，它表示 int 类型能够表示的最小值。

另请参见：
常量字段值

MAX_VALUE

public static final int MAX_VALUE
值为 231－1 的常量，它表示 int 类型能够表示的最大值。

另请参见：
常量字段值

TYPE

public static final Class<Integer> TYPE
表示基本类型 int 的 Class 实例。

从以下版本开始：
JDK1.1

SIZE

public static final int SIZE
用来以二进制补码形式表示 int 值的比特位数。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

Integer

public Integer(int value)
构造一个新分配的 Integer 对象，它表示指定的 int 值。

参数：
value - Integer 对象表示的值。

Integer

public Integer(String s)
        throws NumberFormatException
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。使用与 parseInt 方法（对基数为 10 的值）相同的方式将该字符串转换成 int 值。

参数：
s - 要转换为 Integer 的 String。
抛出：
NumberFormatException - 如果 String 不包含可解析的整数。
另请参见：
parseInt(java.lang.String, int)
方法详细信息

toString

public static String toString(int i,
                              int radix)
返回用第二个参数指定基数表示的第一个参数的字符串表示形式。

如果基数小于 Character.MIN_RADIX 或者大于 Character.MAX_RADIX，则改用基数 10。

如果第一个参数为负，则结果中的第一个元素为 ASCII 的减号 '-' ('\u002D')。如果第一个参数为非负，则没有符号字符出现在结果中。

结果中的剩余字符表示第一个参数的大小。如果大小为零，则用一个零字符 '0' ('\u0030') 表示；否则，大小的表示形式中的第一个字符将不是零字符。用以下 ASCII 字符作为数字：

   0123456789abcdefghijklmnopqrstuvwxyz
其范围是从 '\u0030' 到 '\u0039' 和从 '\u0061' 到 '\u007A'。如果 radix 为 N, 则按照所示顺序，使用这些字符中的前 N 个作为其数字。因此，十六进制（基数为 16）的数字是 0123456789abcdef。如果希望得到大写字母，则可以在结果上调用 String.toUpperCase() 方法：
 Integer.toString(n, 16).toUpperCase()

参数：
i - 要转换成字符串的整数。
radix - 用于字符串表示形式的基数。
返回：
使用指定基数的参数的字符串表示形式。
另请参见：
Character.MAX_RADIX, Character.MIN_RADIX

toHexString

public static String toHexString(int i)
以十六进制（基数 16）无符号整数形式返回一个整数参数的字符串表示形式。

如果参数为负，那么无符号整数值为参数加上 232；否则等于该参数。将该值转换为十六进制（基数 16）的无前导 0 的 ASCII 数字字符串。如果无符号数的大小值为零，则用一个零字符 '0' (’\u0030’) 表示它；否则，无符号数大小的表示形式中的第一个字符将不是零字符。用以下字符作为十六进制数字：

 0123456789abcdef
这些字符的范围是从 '\u0030' 到 '\u0039' 和从 '\u0061' 到 '\u0066'。如果希望得到大写字母，可以在结果上调用 String.toUpperCase() 方法：
 Integer.toHexString(n).toUpperCase()

参数：
i - 要转换成字符串的整数。
返回：
参数的十六进制（基数 16）无符号整数值的字符串表示形式。
从以下版本开始：
JDK1.0.2

toOctalString

public static String toOctalString(int i)
以八进制（基数 8）无符号整数形式返回一个整数参数的字符串表示形式。

如果参数为负，该无符号整数值为参数加上 232；否则等于该参数。该值被转换成八进制（基数 8）ASCII 数字的字符串，且没有附加前导 0。

如果无符号数大小为零，则用一个零字符 '0' ('\u0030') 表示它；否则，无符号数大小的表示形式中的第一个字符将不是零字符。用以下字符作为八进制数字：

01234567
它们是从 '\u0030' 到 '\u0037' 的字符。

参数：
i - 要转换成字符串的整数。
返回：
用八进制参数（基数 8）表示的无符号整数值的字符串表示形式。
从以下版本开始：
JDK1.0.2

toBinaryString

public static String toBinaryString(int i)
以二进制（基数 2）无符号整数形式返回一个整数参数的字符串表示形式。

如果参数为负，该无符号整数值为参数加上 232；否则等于该参数。将该值转换为二进制（基数 2）形式的无前导 0 的 ASCII 数字字符串。如果无符号数的大小为零，则用一个零字符 '0' (’\u0030’) 表示它；否则，无符号数大小的表示形式中的第一个字符将不是零字符。字符 '0' ('\u0030') 和 '1' ('\u0031') 被用作二进制数字。

参数：
i - 要转换为字符串的整数。
返回：
用二进制（基数 2）参数表示的无符号整数值的字符串表示形式。
从以下版本开始：
JDK1.0.2

toString

public static String toString(int i)
返回一个表示指定整数的 String 对象。将该参数转换为有符号的十进制表示形式，以字符串形式返回它，就好像将参数和基数 10 作为参数赋予 toString(int, int) 方法。

参数：
i - 要转换的整数。
返回：
十进制（基数 10）参数的字符串表示形式。

parseInt

public static int parseInt(String s,
                           int radix)
                    throws NumberFormatException
使用第二个参数指定的基数，将字符串参数解析为有符号的整数。除了第一个字符可以是用来表示负值的 ASCII 减号 '-' ('\u002D’)外，字符串中的字符必须都是指定基数的数字（通过 Character.digit(char, int) 是否返回一个负值确定）。返回得到的整数值。

如果发生以下任意一种情况，则抛出一个 NumberFormatException 类型的异常：

  • 第一个参数为 null 或一个长度为零的字符串。
  • 基数小于 Character.MIN_RADIX 或者大于 Character.MAX_RADIX。
  • 假如字符串的长度超过 1，那么除了第一个字符可以是减号 '-' ('u002D’) 外，字符串中存在任意不是由指定基数的数字表示的字符。
  • 字符串表示的值不是 int 类型的值。

示例：

parseInt("0", 10) 返回 0
parseInt("473", 10) 返回 473
parseInt("-0", 10) 返回 0
parseInt("-FF", 16) 返回 -255
parseInt("1100110", 2) 返回 102
parseInt("2147483647", 10) 返回 2147483647
parseInt("-2147483648", 10) 返回 -2147483648
parseInt("2147483648", 10) 抛出 NumberFormatException
parseInt("99", 8) 抛出 NumberFormatException
parseInt("Kona", 10) 抛出 NumberFormatException
parseInt("Kona", 27) 返回 411787

参数：
s - 包含要解析的整数表示形式的 String
radix - 解析 s 时使用的基数。
返回：
使用指定基数的字符串参数表示的整数。
抛出：
NumberFormatException - 如果 String 不包含可解析的 int。

parseInt

public static int parseInt(String s)
                    throws NumberFormatException
将字符串参数作为有符号的十进制整数进行解析。除了第一个字符可以是用来表示负值的 ASCII 减号 '-' ('\u002D') 外，字符串中的字符都必须是十进制数字。返回得到的整数值，就好像将该参数和基数 10 作为参数赋予 parseInt(java.lang.String, int) 方法一样。

参数：
s - 包含要解析的 int 表示形式的 String。
返回：
用十进制参数表示的整数值。
抛出：
NumberFormatException - 如果字符串不包含可解析的整数。

valueOf

public static Integer valueOf(String s,
                              int radix)
                       throws NumberFormatException
返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。将第一个参数解释为用第二个参数指定的基数表示的有符号整数，就好像将这些参数赋予 parseInt(java.lang.String, int) 方法一样。结果是一个表示字符串指定的整数值的 Integer 对象。

换句话说，该方法返回一个等于以下值的 Integer 对象：

new Integer(Integer.parseInt(s, radix))

参数：
s - 要解析的字符串。
radix - 解释 s 时使用的基数。
返回：
一个 Integer 对象，它含有字符串参数（以指定的基数）所表示的数值。
抛出：
NumberFormatException - 如果 String 不包含可解析的 int。

valueOf

public static Integer valueOf(String s)
                       throws NumberFormatException
返回保存指定的 String 的值的 Integer 对象。将该参数解释为表示一个有符号的十进制整数, 就好像将该参数赋予 parseInt(java.lang.String) 方法一样。结果是一个表示字符串指定的整数值的 Integer 对象。

换句话说，该方法返回一个等于以下值的 Integer 对象：

new Integer(Integer.parseInt(s))

参数：
s - 要解析的字符串。
返回：
保存字符串参数表示的值的 Integer 对象。
抛出：
NumberFormatException - 如果字符串不能解析为一个整数。

valueOf

public static Integer valueOf(int i)
返回一个表示指定的 int 值的 Integer 实例。如果不需要新的 Integer 实例，则通常应优先使用该方法，而不是构造方法 Integer(int)，因为该方法有可能通过缓存经常请求的值而显著提高空间和时间性能。

参数：
i - 一个 int 值。
返回：
表示 i 的 Integer 实例。
从以下版本开始：
1.5

byteValue

public byte byteValue()
以 byte 类型返回该 Integer 的值。

覆盖：
类 Number 中的 byteValue
返回：
转换为 byte 类型后该对象表示的数值。

shortValue

public short shortValue()
以 short 类型返回该 Integer 的值。

覆盖：
类 Number 中的 shortValue
返回：
转换为 short 类型后该对象表示的数值。

intValue

public int intValue()
以 int 类型返回该 Integer 的值。

指定者：
类 Number 中的 intValue
返回：
转换为 int 类型后该对象表示的数值。

longValue

public long longValue()
以 long 类型返回该 Integer 的值。

指定者：
类 Number 中的 longValue
返回：
转换为 long 类型后该对象表示的数值。

floatValue

public float floatValue()
以 float 类型返回该 Integer 的值。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 类型后该对象表示的数值。

doubleValue

public double doubleValue()
以 double 类型返回该 Integer 的值。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 类型后该对象表示的数值。

toString

public String toString()
返回一个表示该 Integer 值的 String 对象。将该参数转换为有符号的十进制表示形式，并以字符串的形式返回它，就好像将该整数值作为参数赋予 toString(int) 方法一样。

覆盖：
类 Object 中的 toString
返回：
该对象的值（基数 10）的字符串表示形式。

hashCode

public int hashCode()
返回此 Integer 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
该对象的哈希码值，它的值即为该 Integer 对象表示的基本 int 类型的数值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较此对象与指定对象。当且仅当参数不为 null，并且是一个与该对象包含相同 int 值的 Integer 对象时，结果为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象。
返回：
如果对象相同，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getInteger

public static Integer getInteger(String nm)
确定具有指定名称的系统属性的整数值。

第一个参数被视为系统属性的名称。通过 System.getProperty(java.lang.String) 方法可以访问系统属性。然后，将该属性的字符串值解释为一个整数值，并返回表示该值的 Integer 对象。使用 getProperty 的定义可以找到可能出现的数字格式的详细信息。

如果没有具有指定名称的属性，或者指定名称为空或 null，或者属性的数字格式不正确，则返回 null。

换句话说，该方法返回一个等于以下值的 Integer 对象：

getInteger(nm, null)

参数：
nm - 属性名。
返回：
属性的 Integer 值。
另请参见：
System.getProperty(java.lang.String), System.getProperty(java.lang.String, java.lang.String)

getInteger

public static Integer getInteger(String nm,
                                 int val)
确定具有指定名称的系统属性的整数值。

第一个参数被视为系统属性的名称。通过 System.getProperty(java.lang.String) 方法可以访问系统属性。然后，将该属性的字符串值解释为一个整数值，并返回表示该值的 Integer 对象。使用 getProperty 的定义可以找到可能出现的数字格式的详细信息。

第二个参数是默认值。如果未具有指定名称的属性，或者属性的数字格式不正确，或者指定名称为空或 null，则返回一个表示第二个参数的值的 Integer 对象。

换句话说，该方法返回一个等于以下值的 Integer 对象：

getInteger(nm, new Integer(val))
但在实践中可能会用以下类似方式实现它：
 Integer result = getInteger(nm, null);
 return (result == null) ? new Integer(val) : result;
从而避免在无需默认值时分配不必要的 Integer 对象。

参数：
nm - 属性名。
val - 默认值。
返回：
属性的 Integer 值。
另请参见：
System.getProperty(java.lang.String), System.getProperty(java.lang.String, java.lang.String)

getInteger

public static Integer getInteger(String nm,
                                 Integer val)
返回具有指定名称的系统属性的整数值。第一个参数被视为系统属性的名称。通过 System.getProperty(java.lang.String) 方法可以访问系统属性。然后，根据每个 Integer.decode 方法，将该属性的字符串值解释为一个整数值，并返回一个表示该值的 Integer 对象。

  • 如果属性值以两个 ASCII 字符 0x 或者 ASCII 字符 # 开始，并且后面没有减号，则将它的剩余部分解析为十六进制整数，就好像以 16 为基数调用 valueOf(java.lang.String, int) 方法一样。
  • 如果属性值以 ASCII 字符 0 开始，后面还有其他字符，则将它解析为八进制整数，就好像以 8 为基数调用 valueOf(java.lang.String, int) 方法一样。
  • 否则，将属性值解析为十进制整数，就好像以 10 为基数调用 valueOf(java.lang.String, int) 方法一样。

第二个参数是默认值。如果未具有指定名称的属性，或者属性的数字格式不正确，或者指定名称为空或 null，则返回默认值。

参数：
nm - 属性名。
val - 默认值。
返回：
属性的 Integer 值。
另请参见：
System.getProperty(java.lang.String),
System.getProperty(java.lang.String, java.lang.String),
decode(java.lang.String)

decode

public static Integer decode(String nm)
                      throws NumberFormatException
将 String 解码为 Integer。接受通过以下语法给出的十进制、十六进制和八进制数字：
DecodableString:
Signopt DecimalNumeral
Signopt 0x HexDigits
Signopt 0X HexDigits
Signopt # HexDigits
Signopt 0 OctalDigits

Sign:
-
Java Language Specification 的第 §3.10.1 节中有 DecimalNumeral、HexDigits 和 OctalDigits 的定义。

跟在（可选）负号和/或基数说明符（“0x”、“0X”、“#”或前导零）后面的字符序列是使用指示的基数（10、16 或 8）通过 Integer.parseInt 方法解析的。字符序列必须表示一个正值，否则会抛出 NumberFormatException。如果指定的 String 的第一个字符是减号，则对结果求反。String 中不允许出现空白字符。

参数：
nm - 要解码的 String。
返回：
保存 nm 所表示的 int 值的 Integer 对象。
抛出：
NumberFormatException - 如果 String 不包含可解析整数。
从以下版本开始：
1.2
另请参见：
parseInt(java.lang.String, int)

compareTo

public int compareTo(Integer anotherInteger)
在数字上比较两个 Integer 对象。

指定者：
接口 Comparable<Integer> 中的 compareTo
参数：
anotherInteger - 要比较的 Integer。
返回：
如果该 Integer 等于 Integer 参数，则返回 0 值；如果该 Integer 在数字上小于 Integer 参数，则返回小于 0 的值；如果 Integer 在数字上大于 Integer 参数，则返回大于 0 的值（有符号的比较）。
从以下版本开始：
1.2

highestOneBit

public static int highestOneBit(int i)
返回具有至多单个 1 位的 int 值，在指定的 int 值中最高位（最左边）的 1 位的位置。如果指定的值在其二进制补码表示形式中不具有 1 位，即它等于零，则返回零。

返回：
返回具有单个 1 位的 int 值, 在指定值中最高位的 1 位的位置，否则，如果指定值本身等于零，则返回零。
从以下版本开始：
1.5

lowestOneBit

public static int lowestOneBit(int i)
返回具有至多单个 1 位的 int 值，在指定的 int 值中最低位（最右边）的 1 位的位置。如果指定的值在其二进制补码表示形式中不具有 1 位，即它等于零，则返回零。

返回：
返回具有单个 1 位的 int 值, 在指定值中最低位的 1 位的位置，否则，如果指定值本身等于零，则返回零。
从以下版本开始：
1.5

numberOfLeadingZeros

public static int numberOfLeadingZeros(int i)
在指定 int 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。如果指定值在其二进制补码表示形式中不存在 1 位，换句话说，如果它等于零，则返回 32。

注意，此方法与基数为 2 的对数密切相关。对于所有的正 int 值 x：

  • floor(log2(x)) = 31 - numberOfLeadingZeros(x)
  • ceil(log2(x)) = 32 - numberOfLeadingZeros(x - 1)

返回：
返回在指定 int 值的二进制补码表示形式中最高位（最左边）的 1 位之前的零位的数量；否则，如果该值等于零，则返回 32。
从以下版本开始：
1.5

numberOfTrailingZeros

public static int numberOfTrailingZeros(int i)
返回指定的 int 值的二进制补码表示形式中最低（“最右边”）的为 1 的位后面的零位个数。如果指定值在它的二进制补码表示形式中没有为 1 的位，即它的值为零，则返回 32。

返回：
返回在指定 int 值的二进制补码表示形式中最低位（最右边）的 1 位之后零位的数量；否则，如果该值等于零，则返回 32。
从以下版本开始：
1.5

bitCount

public static int bitCount(int i)
返回指定 int 值的二进制补码表示形式的 1 位的数量。此函数有时用于人口普查。

返回：
返回指定 int 值的二进制补码表示形式的 1 位的数量。
从以下版本开始：
1.5

rotateLeft

public static int rotateLeft(int i,
                             int distance)
返回根据指定的位数循环左移指定的 int 值的二进制补码表示形式而得到的值。（位是从左边（即高位）移出，从右边（即低位）再进入）

注意，使用负距离的左循环等同于右循环：rotateLeft(val, -distance) == rotateRight(val, distance)。还要注意的是，以 32 的任何倍数进行的循环都是无操作指令，因此，即使距离为负，除了最后五位外，其余所有循环距离都可以忽略：rotateLeft(val, distance) == rotateLeft(val, distance & 0x1F)。

返回：
返回根据指定的位数循环左移指定的 int 值的二进制补码表示形式而得到的值。
从以下版本开始：
1.5

rotateRight

public static int rotateRight(int i,
                              int distance)
返回根据指定的位数循环右移指定的 int 值的二进制补码表示形式而得到的值。（位是从右边（即低位）移出，从左边（即高位）再进入）

注意，使用负距离的右循环等同于左循环：rotateRight(val, -distance) == rotateLeft(val, distance)。还要注意的是，以 32 的任何倍数进行的循环都是无操作指令，因此，即使距离为负，除了最后五位外，其余所有循环距离都可以忽略：rotateRight(val, distance) == rotateRight(val, distance & 0x1F)。

返回：
返回根据指定的位数循环右移指定的 int 值的二进制补码表示形式而得到的值。
从以下版本开始：
1.5

reverse

public static int reverse(int i)
返回通过反转指定 int 值的二进制补码表示形式中位的顺序而获得的值。

返回：
返回通过反转指定 int 值中位的顺序而获得的值。
从以下版本开始：
1.5

signum

public static int signum(int i)
返回指定 int 值的符号函数。（如果指定值为负，则返回 －1；如果指定值为零，则返回 0；如果指定的值为正，则返回 1。）

返回：
返回指定 int 值的符号函数。
从以下版本开始：
1.5

reverseBytes

public static int reverseBytes(int i)
返回通过反转指定 int 值的二进制补码表示形式中字节的顺序而获得的值。

返回：
返回通过反转指定 int 值的字节而获得的值。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InternalError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 InternalError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.VirtualMachineError
                继承者  java.lang.InternalError
所有已实现的接口：
Serializable
直接已知子类：
ZipError
public class InternalError
extends VirtualMachineError

该异常指示 Java 虚拟机中出现一些意外的内部错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
InternalError()
构造不带详细消息的 InternalError。
InternalError(String s)
构造带指定详细消息的 InternalError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InternalError

public InternalError()
构造不带详细消息的 InternalError。

InternalError

public InternalError(String s)
构造带指定详细消息的 InternalError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InterruptedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 InterruptedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.InterruptedException
所有已实现的接口：
Serializable
public class InterruptedException
extends Exception

当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。有时候，一种方法可能希望测试当前线程是否已被中断，如果已被中断，则立即抛出此异常。下列代码可以达到这种效果：

  if (Thread.interrupted())  // Clears interrupted status!
      throw new InterruptedException();

从以下版本开始：
JDK1.0
另请参见：
Object.wait(),
Object.wait(long),
Object.wait(long, int),
Thread.sleep(long),
Thread.interrupt(),
Thread.interrupted(),
序列化表格

构造方法摘要
InterruptedException()
构造不带详细消息的 InterruptedException。
InterruptedException(String s)
构造带指定详细消息的 InterruptedException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InterruptedException

public InterruptedException()
构造不带详细消息的 InterruptedException。

InterruptedException

public InterruptedException(String s)
构造带指定详细消息的 InterruptedException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Iterable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 Iterable<T>

所有已知子接口：
BeanContext, BeanContextServices, BlockingDeque<E>, BlockingQueue<E>, Collection<E>, Deque<E>, List<E>, NavigableSet<E>, Queue<E>, Set<E>, SortedSet<E>
所有已知实现类：
AbstractCollection, AbstractList, AbstractQueue, AbstractSequentialList, AbstractSet, ArrayBlockingQueue, ArrayDeque, ArrayList, AttributeList, BatchUpdateException, BeanContextServicesSupport, BeanContextSupport, ConcurrentLinkedQueue, ConcurrentSkipListSet, CopyOnWriteArrayList, CopyOnWriteArraySet, DataTruncation, DelayQueue, EnumSet, HashSet, JobStateReasons, LinkedBlockingDeque, LinkedBlockingQueue, LinkedHashSet, LinkedList, PriorityBlockingQueue, PriorityQueue, RoleList, RoleUnresolvedList, RowSetWarning, SerialException, ServiceLoader, SQLClientInfoException, SQLDataException, SQLException, SQLFeatureNotSupportedException, SQLIntegrityConstraintViolationException, SQLInvalidAuthorizationSpecException, SQLNonTransientConnectionException, SQLNonTransientException, SQLRecoverableException, SQLSyntaxErrorException, SQLTimeoutException, SQLTransactionRollbackException, SQLTransientConnectionException, SQLTransientException, SQLWarning, Stack, SyncFactoryException, SynchronousQueue, SyncProviderException, TreeSet, Vector
public interface Iterable<T>

实现这个接口允许对象成为 "foreach" 语句的目标。

从以下版本开始：
1.5

方法摘要
 Iterator<T> iterator()
返回一个在一组 T 类型的元素上进行迭代的迭代器。

方法详细信息

iterator

Iterator<T> iterator()
返回一个在一组 T 类型的元素上进行迭代的迭代器。

返回：
一个迭代器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkageError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 LinkageError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
所有已实现的接口：
Serializable
直接已知子类：
ClassCircularityError, ClassFormatError, ExceptionInInitializerError, IncompatibleClassChangeError, NoClassDefFoundError, UnsatisfiedLinkError, VerifyError
public class LinkageError
extends Error

LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
LinkageError()
构造不带详细消息的 LinkageError 类。
LinkageError(String s)
构造带指定详细消息的 LinkageError 类。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LinkageError

public LinkageError()
构造不带详细消息的 LinkageError 类。

LinkageError

public LinkageError(String s)
构造带指定详细消息的 LinkageError 类。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Long (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Long

java.lang.Object
    继承者  java.lang.Number
        继承者  java.lang.Long
所有已实现的接口：
Serializable, Comparable<Long>
public final class Long
extends Number
implements Comparable<Long>

Long 类在对象中包装了基本类型 long 的值。每个 Long 类型的对象都包含一个 long 类型的字段。

此外，该类提供了多个方法，可以将 long 转换为 String，将 String 转换为 long，除此之外，还提供了其他一些处理 long 时有用的常量和方法。

实现注意事项："bit twiddling" 方法（如 highestOneBit 和 numberOfTrailingZeros）的实现基于 Henry S. Warren 和 Jr. 撰写的 Hacker's Delight (Addison Wesley, 2002) 一书中的资料。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
static long | MAX_VALUE 保持 long 类型的最大值的常量，该值为 263-1。
static long | MIN_VALUE 保持 long 类型的最小值的常量，该值为 -263。
static int | SIZE 用来以二进制补码形式表示 long 值的位数。
static Class<Long> | TYPE 表示基本类型 long 的 Class 实例。
构造方法摘要
Long(long value)
构造新分配的 Long 对象，表示指定的 long 参数。
Long(String s)
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。
方法摘要
static int | bitCount(long i) 返回指定 long 值的二进制补码表示形式中的 1 位的数量。
byte | byteValue() 以 byte 形式返回此 Long 的值。
int | compareTo(Long anotherLong) 在数字上比较两个 Long 对象。
static Long | decode(String nm) 将 String 解码成 Long。
double | doubleValue() 以 double 形式返回此 Long 的值。
boolean | equals(Object obj) 将此对象与指定对象进行比较。
float | floatValue() 以 float 形式返回此 Long 的值。
static Long | getLong(String nm) 确定具有指定名称的系统属性的 long 值。
static Long | getLong(String nm, long val) 使用指定名称确定系统属性的 long 值。
static Long | getLong(String nm, Long val) 使用指定名称返回系统属性的 long 值。
int | hashCode() 返回 Long 的哈希码。
static long | highestOneBit(long i) 返回至多有一个 1 位的 long 值，在指定的 long 值中最高位（最左边）的 1 位的位置。
int | intValue() 以 int 形式返回此 Long 的值。
long | longValue() 以 long 值的形式返回此 Long 的值。
static long | lowestOneBit(long i) 返回至多有一个 1 位的 long 值，在指定的 long 值中最低位（最右边）的 1 位的位置。
static int | numberOfLeadingZeros(long i) 在指定 long 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。
static int | numberOfTrailingZeros(long i) 返回在指定 long 值的二进制补码表示形式中最低位（最右边）的 1 位之后的零位的数量。
static long | parseLong(String s) 将 string 参数解析为有符号十进制 long。
static long | parseLong(String s, int radix) 将 string 参数解析为有符号的 long，基数由第二个参数指定。
static long | reverse(long i) 返回通过反转指定 long 值的二进制补码表示形式中位的顺序而获得的值。
static long | reverseBytes(long i) 返回通过反转指定 long 值的二进制补码表示形式中字节的顺序而获得的值。
static long | rotateLeft(long i, int distance) 返回根据指定的位数循环左移指定的 long 值的二进制补码表示形式而得到的值。
static long | rotateRight(long i, int distance) 返回根据指定的位数循环右移指定的 long 值的二进制补码表示形式而得到的值。
short | shortValue() 以 short 形式返回此 Long 的值。
static int | signum(long i) 返回指定 long 值的符号函数。
static String | toBinaryString(long i) 以二进制无符号整数形式返回 long 参数的字符串表示形式。
static String | toHexString(long i) 以十六进制无符号整数形式返回 long 参数的字符串表示形式。
static String | toOctalString(long i) 以八进制无符号整数形式返回 long 参数的字符串表示形式。
String | toString() 返回表示 Long 值的 String 对象。
static String | toString(long i) 返回表示指定 long 的 String 对象。
static String | toString(long i, int radix) 返回在使用第二个参数指定的基数时第一个参数的字符串表示形式。
static Long | valueOf(long l) 返回表示指定 long 值的 Long 实例。
static Long | valueOf(String s) 返回保持指定 String 的值的 Long 对象。
static Long | valueOf(String s, int radix) 当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MIN_VALUE

public static final long MIN_VALUE
保持 long 类型的最小值的常量，该值为 -263。

另请参见：
常量字段值

MAX_VALUE

public static final long MAX_VALUE
保持 long 类型的最大值的常量，该值为 263-1。

另请参见：
常量字段值

TYPE

public static final Class<Long> TYPE
表示基本类型 long 的 Class 实例。

从以下版本开始：
JDK1.1

SIZE

public static final int SIZE
用来以二进制补码形式表示 long 值的位数。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

Long

public Long(long value)
构造新分配的 Long 对象，表示指定的 long 参数。

参数：
value - Long 对象表示的值。

Long

public Long(String s)
     throws NumberFormatException
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。该字符串被转换为 long 值，其方式与 radix 参数为 10 的 parseLong 方法所使用的方式一致。

参数：
s - 要转换为 Long 的 String。
抛出：
NumberFormatException - 如果 String 不包含可解析的 long。
另请参见：
parseLong(java.lang.String, int)
方法详细信息

toString

public static String toString(long i,
                              int radix)
返回在使用第二个参数指定的基数时第一个参数的字符串表示形式。

如果该基数小于 Character.MIN_RADIX，或大于 Character.MAX_RADIX，则使用基数 10。

如果第一个参数是负数，则结果的第一个元素是 ASCII 字符的减号 '-' ('\u002d')。如果第一个参数非负，则结果中不会出现符号字符。

结果的其余字符表示第一个参数的大小。如果大小为零，则用单个零字符 '0' 表示它 ('\u0030')；否则大小表示形式中的第一个字符将不是零字符。以下 ASCII 字符均被用作数字：

0123456789abcdefghijklmnopqrstuvwxyz
这些是从 '\u0030' 到 '\u0039' 和从 '\u0061' 到 '\u007a' 的字符。如果 radix 是 N，则这些字符的第一个 N 用作显示顺序中基数 N 的数字。因此，该数字的十六进制（基数 16）表示形式为 0123456789abcdef。如果需要使用大写字母，则可以在结果上调用 String.toUpperCase() 方法：
Long.toString(n, 16).toUpperCase()

参数：
i - 要转换为字符串的 long。
radix - 将在字符串表示形式中使用的基数。
返回：
指定基数中参数的字符串表示形式。
另请参见：
Character.MAX_RADIX, Character.MIN_RADIX

toHexString

public static String toHexString(long i)
以十六进制无符号整数形式返回 long 参数的字符串表示形式。

如果参数为负，则无符号 long 值为该参数加上 264；否则，它等于该参数。此值将被转换为不带附加前导 0 的十六进制（基数 16）ASCII 数字字符串。如果无符号大小为零，则该数字由单个零字符 '0' 表示 ('\u0030')；否则，无符号大小表示形式中的第一个字符将不是零字符。下列字符都被用作十六进制数字：

0123456789abcdef
这些是从 '\u0030' 到 '\u0039' 和从 '\u0061' 到 '\u0066' 的字符。如果需要使用大写字母，则可以在结果上调用 String.toUpperCase() 方法：
Long.toHexString(n).toUpperCase()

参数：
i - 要转换为字符串的 long。
返回：
十六进制（基数 16）参数表示的无符号 long 值的字符串表示形式。
从以下版本开始：
JDK 1.0.2

toOctalString

public static String toOctalString(long i)
以八进制无符号整数形式返回 long 参数的字符串表示形式。

如果参数为负，则无符号 long 值为该参数加上 264；否则，它等于该参数。此值将被转换为不带附加前导 0 的八进制（基数 8）ASCII 数字字符串。

如果无符号大小为零，则该数字用单个零字符 '0' ('\u0030') 表示，否则无符号大小表示形式中的第一个字符将不是零字符。以下字符都用作八进制数字：

 01234567
这些是从 '\u0030' 到 '\u0037' 的字符。

参数：
i - 要转换为字符串的 long。
返回：
八进制（基数 8）参数表示的无符号 long 值的字符串表示形式。
从以下版本开始：
JDK 1.0.2

toBinaryString

public static String toBinaryString(long i)
以二进制无符号整数形式返回 long 参数的字符串表示形式。

如果参数为负数，则无符号 long 值为该参数加上 264；否则，它等于该参数。此值将被转换为不带附加前导 0 的二进制（基数 2）ASCII 数字字符串。如果无符号大小为零，则用单个零字符 '0' 表示它 ('\u0030')；否则，无符号大小表示形式中的第一个字符将不是零字符。字符 '0' ('\u0030') 和 '1' ('\u0031') 被用作二进制位。

参数：
i - 要转换为字符串的 long。
返回：
二进制 (base 2) 参数表示的无符号 long 值的字符串表示形式。
从以下版本开始：
JDK 1.0.2

toString

public static String toString(long i)
返回表示指定 long 的 String 对象。该参数被转换为有符号的十进制表示形式，并作为字符串返回，该字符串与用该参数和基数 10 作为参数的 toString(long, int) 方法所得到的值非常相似。

参数：
i - 要转换的 long。
返回：
十进制参数的字符串表示形式。

parseLong

public static long parseLong(String s,
                             int radix)
                      throws NumberFormatException
将 string 参数解析为有符号的 long，基数由第二个参数指定。字符串中的字符必须为指定基数中的数字（由 Character.digit(char, int) 是否返回一个非负值来确定），除非第一个字符为 ASCII 字符的减号 '-' ('\u002D')，它表示一个负值。返回得到的 long 值。

注意，不允许将字符 L ('\u004C') 和 l ('\u006C') 作为类型指示符出现在字符串的结尾处，而这一点在 Java 编程语言源代码中是允许的——除非 L 或 l 以大于 22 的基数形式出现。

如果出现以下情形之一，则抛出 NumberFormatException 类型的异常：

  • 第一个参数是 null 或零长度的字符串。
  • radix 小于 Character.MIN_RADIX 或者大于 Character.MAX_RADIX。
  • 任何字符串的字符都不是指定基数的数字，除非第一个字符是减号 '-' ('\u002d')，假定字符串的长度大于 1。
  • 字符串表示的值不是 long 类型的值。

示例：

parseLong("0", 10) returns 0L
parseLong("473", 10) returns 473L
parseLong("-0", 10) returns 0L
parseLong("-FF", 16) returns -255L
parseLong("1100110", 2) returns 102L
parseLong("99", 8) returns NumberFormatException
parseLong("Hazelnut", 10) returns NumberFormatException
parseLong("Hazelnut", 36) returns 1356099454469L

参数：
s - 包含要解析的 long 表示形式的 String。
radix - 将在解析 s 时使用的基数。
返回：
由指定基数中的字符串参数表示的 long。
抛出：
NumberFormatException - 如果字符串不包含可解析的 long。

parseLong

public static long parseLong(String s)
                      throws NumberFormatException
将 string 参数解析为有符号十进制 long。字符串中的字符必须都是十进制数字，除非第一个字符是 ASCII 字符的减号 '-' (\u002D')，它表示一个负值。返回得到的 long 值，该值与用该参数和基数 10 作为参数的 parseLong(java.lang.String, int) 方法得到的值非常相似。

注意，不允许将字符 L ('\u004C') 和 l ('\u006C') 作为类型指示符出现在字符串的结尾处，这一点在 Java 编程语言源代码中是允许的。

参数：
s - 包含要解析的 long 表示形式的 String
返回：
十进制参数表示的 long。
抛出：
NumberFormatException - 如果字符串不包含可解析的 long。

valueOf

public static Long valueOf(String s,
                           int radix)
                    throws NumberFormatException
当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。第一个参数被解释为有符号的 long，基数由第二个参数指定，该值与用该参数作为参数的 parseLong(java.lang.String, int) 方法得到的值非常类似。结果是表示字符串指定的 long 值的 Long 对象。

换句话说，此方法返回一个 Long 对象，它的值等于：

new Long(Long.parseLong(s, radix))

参数：
s - 要解析的字符串
radix - 将在解释 s 时使用的基数
返回：
保持由指定基数中的字符串参数表示的值的 Long 对象。
抛出：
NumberFormatException - 如果 String 不包含可解析的 long。

valueOf

public static Long valueOf(String s)
                    throws NumberFormatException
返回保持指定 String 的值的 Long 对象。该参数被解释为表示一个有符号的十进制 long，该值与用该参数作为参数的 parseLong(java.lang.String) 方法得到的值非常相似。结果是表示由字符串指定的整数值的 Long 对象。

换句话说，此方法返回一个 Long 对象，它的值等于：

new Long(Long.parseLong(s))

参数：
s - 要解析的字符串。
返回：
包含由字符串参数表示的值的 Long 对象。
抛出：
NumberFormatException - 如果不能将字符串解析为 long。

valueOf

public static Long valueOf(long l)
返回表示指定 long 值的 Long 实例。如果不需要新的 Long 实例，则通常优先使用此方法，而不是使用构造方法 Long(long)，因为此方法通过缓存频繁请求的值，可以显著提高时间和空间性能。

参数：
l - long 值。
返回：
表示 l 的 Long 实例。
从以下版本开始：
1.5

decode

public static Long decode(String nm)
                   throws NumberFormatException
将 String 解码成 Long。接受通过以下语法给出的十进制、十六进制和八进制数：
DecodableString:
Signopt DecimalNumeral
Signopt 0x HexDigits
Signopt 0X HexDigits
Signopt # HexDigits
Signopt 0 OctalDigits

Sign:
-
DecimalNumeral、HexDigits 和 OctalDigits 在 Java Language Specification 中的§3.10.1 中已经定义。

跟在（可选）负号和/或基数说明符（"0x"、"0X"、"#" 或前导零）后面的字符的顺序由 Long.parseLong 方法通过指示的基数（10、16 或 8）来解析。字符的顺序必须表示为一个正值，否则将抛出 NumberFormatException。如果指定 String 的第一个字符是减号，则结果无效。String 中不允许出现空白字符。

参数：
nm - 要解码的 String。
返回：
保持由 nm 表示的 long 值的 Long 对象
抛出：
NumberFormatException - 如果 String 不包含可解析的 long。
从以下版本开始：
1.2
另请参见：
parseLong(String, int)

byteValue

public byte byteValue()
以 byte 形式返回此 Long 的值。

覆盖：
类 Number 中的 byteValue
返回：
转换为 byte 类型后该对象表示的数值。

shortValue

public short shortValue()
以 short 形式返回此 Long 的值。

覆盖：
类 Number 中的 shortValue
返回：
转换为 short 类型后该对象表示的数值。

intValue

public int intValue()
以 int 形式返回此 Long 的值。

指定者：
类 Number 中的 intValue
返回：
转换为 int 类型后该对象表示的数值。

longValue

public long longValue()
以 long 值的形式返回此 Long 的值。

指定者：
类 Number 中的 longValue
返回：
转换为 long 类型后该对象表示的数值。

floatValue

public float floatValue()
以 float 形式返回此 Long 的值。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 类型后该对象表示的数值。

doubleValue

public double doubleValue()
以 double 形式返回此 Long 的值。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 类型后该对象表示的数值。

toString

public String toString()
返回表示 Long 值的 String 对象。该值被转换为有符号十进制表示形式，并作为字符串返回，该字符串与用 long 值作为参数的 toString(long) 方法得到的字符串非常相似。

覆盖：
类 Object 中的 toString
返回：
十进制对象值的字符串表示形式。

hashCode

public int hashCode()
返回 Long 的哈希码。结果是此 Long 对象保持的基本 long 值的两个部分的异或 (XOR)。也就是说，哈希码就是表达式的值：
(int)(this.longValue()^(this.longValue()>>>32))

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象进行比较。当且仅当该参数不是 null，且 Long 对象与此对象包含相同的 long 值时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之进行比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
Object.hashCode(), Hashtable

getLong

public static Long getLong(String nm)
确定具有指定名称的系统属性的 long 值。

第一个参数被视为系统属性的名称。通过 System.getProperty(java.lang.String) 方法可以访问该系统属性。然后，以 long 值的形式解释此属性的字符串值，并返回表示此值的 Long 对象。在 getProperty 的定义中可以找到可能的数字格式的详细信息。

如果指定名称没有属性，或者指定名称为空或 null，抑或属性不具有正确的数字格式时，则返回 null。

换句话说，此方法返回一个 Long 对象，它的值等于：

getLong(nm, null)

参数：
nm - 属性名。
返回：
属性的 Long 值。
另请参见：
System.getProperty(java.lang.String), System.getProperty(java.lang.String, java.lang.String)

getLong

public static Long getLong(String nm,
                           long val)
使用指定名称确定系统属性的 long 值。

第一个参数被视为系统属性的名称。通过 System.getProperty(java.lang.String) 方法可以访问该系统属性。然后，以 long 值的形式解释此属性的字符串值，并返回表示此值的 Long 对象。在 getProperty 的定义中可以找到可能的数字格式的详细信息。

第二个参数是默认值。如果指定的名称没有属性，或者该属性不具备正确的数字格式，抑或指定名称为空或 null，则返回表示第二个参数的值的 Long 对象。

换句话说，此方法返回一个 Long 对象，它的值等于：

getLong(nm, new Long(val))
但是实际上，它可能通过以下方式实现：
Long result = getLong(nm, null);
return (result == null) ? new Long(val) :result;
这样可以避免不需要默认值时进行的不必要的 Long 对象分配。

参数：
nm - 属性名。
val - 默认值。
返回：
属性的 Long 值。
另请参见：
System.getProperty(java.lang.String), System.getProperty(java.lang.String, java.lang.String)

getLong

public static Long getLong(String nm,
                           Long val)
使用指定名称返回系统属性的 long 值。第一个参数被视为系统属性的名称。通过 System.getProperty(java.lang.String) 方法可以访问该系统属性。然后，以 long 值的形式解释此属性的字符串值，并且按照 Long.decode 方法返回表示此值的 Long 对象。

  • 如果该属性值以两个 ASCII 字符 0x 或 ASCII 字符 # 开头，后面没有跟减号，则将该属性的其余部分解析为一个十六进制整数，该值与调用参数 radix 为 16 的 valueOf(java.lang.String, int) 方法得到的值非常相似。
  • 如果该属性值以 ASCII 字符 0 开头，后跟别的字符，则将它解析为一个八进制整数，该值与调用参数 radix 为 8 的 valueOf(java.lang.String, int) 方法得到的值非常相似。
  • 否则，将属性值解析为一个十进制整数，该值与调用参数 radix 为 10 的 valueOf(java.lang.String, int) 方法得到的值非常相似。

注意，在所有情况下，都不允许将 L ('\u004C') 和 l ('\u006C') 作为类型指示符出现在属性值的结尾处，这一点在 Java 编程语言源代码中是允许的。

第二个参数是默认值。如果指定的名称没有属性，或者属性不具有正确的数字格式，抑或指定名称为空或 null，则返回默认值。

参数：
nm - 属性名。
val - 默认值。
返回：
属性的 Long 值。
另请参见：
System.getProperty(java.lang.String),
System.getProperty(java.lang.String, java.lang.String),
decode(java.lang.String)

compareTo

public int compareTo(Long anotherLong)
在数字上比较两个 Long 对象。

指定者：
接口 Comparable<Long> 中的 compareTo
参数：
anotherLong - 要比较的 Long。
返回：
如果 Long 等于参数 Long，则返回 0 值；如果 Long 在数字上小于参数 Long，则返回小于 0 的值；如果 Long 在数字上大于参数 Long，则返回大于 0 的值（有符号比较）。
从以下版本开始：
1.2

highestOneBit

public static long highestOneBit(long i)
返回至多有一个 1 位的 long 值，在指定的 long 值中最高位（最左边）的 1 位的位置。如果指定值在其二进制补码表示形式中没有 1 位，即等于零，则返回零。

返回：
返回具有单个 1 位的 long 值，在指定值中最高位的 1 位的位置；否则，如果指定值本身等于零，则返回零。
从以下版本开始：
1.5

lowestOneBit

public static long lowestOneBit(long i)
返回至多有一个 1 位的 long 值，在指定的 long 值中最低位（最右边）的 1 位的位置。如果指定值在其二进制补码表示形式中没有 1 位，即等于零，则返回零。

返回：
返回具有单个 1 位的 long 值，在指定值中最低位的 1 位的位置；否则，如果指定值本身等于零，则返回零。
从以下版本开始：
1.5

numberOfLeadingZeros

public static int numberOfLeadingZeros(long i)
在指定 long 值的二进制补码表示形式中最高位（最左边）的 1 位之前，返回零位的数量。如果指定值在其二进制补码表示形式中不存在 1 位，换句话说，如果它等于零，则返回 64。

注意，此方法与二进制对数密切相关。对于所有的正 long 值 x：

  • floor(log2(x)) = 63 - numberOfLeadingZeros(x)
  • ceil(log2(x)) = 64 - numberOfLeadingZeros(x - 1)

返回：
返回在指定 long 值的二进制补码表示形式中最高位（最左边）的 1 位之前的零位的数量；否则，如果该值等于零，则返回 64。
从以下版本开始：
1.5

numberOfTrailingZeros

public static int numberOfTrailingZeros(long i)
返回在指定 long 值的二进制补码表示形式中最低位（最右边）的 1 位之后的零位的数量。如果指定值在其二进制补码表示形式中不存在 1 位，换句话说，如果它等于零，则返回 64。

返回：
返回在指定 long 值的二进制补码表示形式中最低位（最右边）的 1 位之后零位的数量；否则，如果该值等于零，则返回 64。
从以下版本开始：
1.5

bitCount

public static int bitCount(long i)
返回指定 long 值的二进制补码表示形式中的 1 位的数量。此功能有时被称为填充计算。

返回：
返回指定 long 值的二进制补码表示形式的 1 位的数量。
从以下版本开始：
1.5

rotateLeft

public static long rotateLeft(long i,
                              int distance)
返回根据指定的位数循环左移指定的 long 值的二进制补码表示形式而得到的值。（位是从左边（即高位）移出，从右边（即低位）再进入）

注意，使用负距离的左循环等同于右循环：rotateLeft(val, -distance) == rotateRight(val, distance)。另请注意，使用 64 的倍数循环无效，因此除了最后六位，所有循环距离都可以忽略，即使距离是负值：rotateLeft(val, distance) == rotateLeft(val, distance & 0x3F)。

返回：
返回根据指定的位数循环左移指定的 long 值的二进制补码表示形式而得到的值。
从以下版本开始：
1.5

rotateRight

public static long rotateRight(long i,
                               int distance)
返回根据指定的位数循环右移指定的 long 值的二进制补码表示形式而得到的值。（位是从右边（即低位）移出，从左边（即高位）再进入）

注意，使用负距离右循环等于左循环：rotateRight(val, -distance) == rotateLeft(val, distance)。另请注意，使用 64 的倍数循环无效，因此除了最后六位，所有循环距离都可以忽略，即使距离是负值：rotateRight(val, distance) == rotateRight(val, distance & 0x3F)。

返回：
返回根据指定的位数循环右移指定的 long 值的二进制补码表示形式而得到的值。
从以下版本开始：
1.5

reverse

public static long reverse(long i)
返回通过反转指定 long 值的二进制补码表示形式中位的顺序而获得的值。

返回：
返回通过反转指定 long 值中位的顺序而获得的值。
从以下版本开始：
1.5

signum

public static int signum(long i)
返回指定 long 值的符号函数。（如果指定值为负，则返回值 -1；如果指定值为零，则返回 0；如果指定值为正，则返回 1。）

返回：
返回指定 long 值的符号函数。
从以下版本开始：
1.5

reverseBytes

public static long reverseBytes(long i)
返回通过反转指定 long 值的二进制补码表示形式中字节的顺序而获得的值。

返回：
返回通过反转指定 long 值中的字节而获得的值。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Math (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Math

java.lang.Object
    继承者  java.lang.Math

public final class Math
extends Object

Math 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。

与 StrictMath 类的某些数学方法不同，并非 Math 类所有等价函数的实现都定义为返回逐位相同的结果。此类在不需要严格重复的地方可以得到更好的执行。

默认情况下，很多 Math 方法仅调用 StrictMath 中的等价方法来完成它们的实现。建议代码生成器使用特定于平台的本机库或者微处理器指令（可用时）来提供 Math 方法更高性能的实现。这种更高性能的实现仍然必须遵守 Math 的规范。

实现规范的质量涉及到两种属性，即返回结果的准确性和方法的单调性。浮点 Math 方法的准确性根据 ulp（units in the last place，最后一位的进退位）来衡量。对于给定的浮点格式，特定实数值的 ulp 是包括该数值的两个浮点值的差。当作为一个整体而不是针对具体参数讨论方法的准确性时，引入的 ulp 数用于任何参数最差情况下的误差。如果一个方法的误差总是小于 0.5 ulp，那么该方法始终返回最接近准确结果的浮点数；这种方法就是正确舍入。一个正确舍入的方法通常能得到最佳的浮点近似值；然而，对于许多浮点方法，进行正确舍入有些不切实际。相反，对于 Math 类，某些方法允许误差在 1 或 2 ulp 的范围内。非正式地，对于 1 ulp 的误差范围，当准确结果是可表示的数值时，应该按照计算结果返回准确结果；否则，返回包括准确结果的两个浮点值中的一个。对于值很大的准确结果，括号的一端可以是无穷大。除了个别参数的准确性之外，维护不同参数的方法之间的正确关系也很重要。因此，大多数误差大于 0.5 ulp 的方法都要求是半单调的：只要数学函数是非递减的，浮点近似值就是非递减的；同样，只要数学函数是非递增的，浮点近似值就是非递增的。并非所有准确性为 1 ulp 的近似值都能自动满足单调性要求。

从以下版本开始：
JDK1.0

字段摘要
static double | E 比任何其他值都更接近 e（即自然对数的底数）的 double 值。
static double | PI 比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。
方法摘要
static double abs(double a)
返回 double 值的绝对值。
static float abs(float a)
返回 float 值的绝对值。
static int abs(int a)
返回 int 值的绝对值。
static long abs(long a)
返回 long 值的绝对值。
static double acos(double a)
返回一个值的反余弦；返回的角度范围在 0.0 到 pi 之间。
static double asin(double a)
返回一个值的反正弦；返回的角度范围在 -pi/2 到 pi/2 之间。
static double atan(double a)
返回一个值的反正切；返回的角度范围在 -pi/2 到 pi/2 之间。
static double atan2(double y, double x)
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，返回所得角 theta。
static double cbrt(double a)
返回 double 值的立方根。
static double ceil(double a)
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并等于某个整数。
static double copySign(double magnitude, double sign)
返回带有第二个浮点参数符号的第一个浮点参数。
static float copySign(float magnitude, float sign)
返回带有第二个浮点参数符号的第一个浮点参数。
static double cos(double a)
返回角的三角余弦。
static double cosh(double x)
返回 double 值的双曲线余弦。
static double exp(double a)
返回欧拉数 e 的 double 次幂的值。
static double expm1(double x)
返回 ex -1。
static double floor(double a)
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。
static int getExponent(double d)
返回 double 表示形式中使用的无偏指数。
static int getExponent(float f)
返回 float 表示形式中使用的无偏指数。
static double hypot(double x, double y)
返回 sqrt(x2 +y2)，没有中间溢出或下溢。
static double IEEEremainder(double f1, double f2)
按照 IEEE 754 标准的规定，对两个参数进行余数运算。
static double log(double a)
返回 double 值的自然对数（底数是 e）。
static double log10(double a)
返回 double 值的底数为 10 的对数。
static double log1p(double x)
返回参数与 1 之和的自然对数。
static double max(double a, double b)
返回两个 double 值中较大的一个。
static float max(float a, float b)
返回两个 float 值中较大的一个。
static int max(int a, int b)
返回两个 int 值中较大的一个。
static long max(long a, long b)
返回两个 long 值中较大的一个。
static double min(double a, double b)
返回两个 double 值中较小的一个。
static float min(float a, float b)
返回两个 float 值中较小的一个。
static int min(int a, int b)
返回两个 int 值中较小的一个。
static long min(long a, long b)
返回两个 long 值中较小的一个。
static double nextAfter(double start, double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
static float nextAfter(float start, double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
static double nextUp(double d)
返回 d 和正无穷大之间与 d 相邻的浮点值。
static float nextUp(float f)
返回 f 和正无穷大之间与 f 相邻的浮点值。
static double pow(double a, double b)
返回第一个参数的第二个参数次幂的值。
static double random()
返回带正号的 double 值，该值大于等于 0.0 且小于 1.0。
static double rint(double a)
返回最接近参数并等于某一整数的 double 值。
static long round(double a)
返回最接近参数的 long。
static int round(float a)
返回最接近参数的 int。
static double scalb(double d, int scaleFactor)
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 double 值集合中的一个值。
static float scalb(float f, int scaleFactor)
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 float 值集合中的一个值。
static double signum(double d)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
static float signum(float f)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
static double sin(double a)
返回角的三角正弦。
static double sinh(double x)
返回 double 值的双曲线正弦。
static double sqrt(double a)
返回正确舍入的 double 值的正平方根。
static double tan(double a)
返回角的三角正切。
static double tanh(double x)
返回 double 值的双曲线余弦。
static double toDegrees(double angrad)
将用弧度表示的角转换为近似相等的用角度表示的角。
static double toRadians(double angdeg)
将用角度表示的角转换为近似相等的用弧度表示的角。
static double ulp(double d)
返回参数的 ulp 大小。
static float ulp(float f)
返回参数的 ulp 大小。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

E

public static final double E
比任何其他值都更接近 e（即自然对数的底数）的 double 值。

另请参见：
常量字段值

PI

public static final double PI
比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。

另请参见：
常量字段值
方法详细信息

sin

public static double sin(double a)
返回角的三角正弦。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 以弧度表示的角。
返回：
参数的正弦。

cos

public static double cos(double a)
返回角的三角余弦。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 NaN。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 以弧度表示的角。
返回：
参数的余弦。

tan

public static double tan(double a)
返回角的三角正切。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 以弧度表示的角。
返回：
参数的正切。

asin

public static double asin(double a)
返回一个值的反正弦；返回的角度范围在 -pi/2 到 pi/2 之间。特殊情况如下：
  • 如果参数为 NaN 或它的绝对值大于 1，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 要返回其反正弦的值。
返回：
参数的反正弦。

acos

public static double acos(double a)
返回一个值的反余弦；返回的角度范围在 0.0 到 pi 之间。特殊情况如下：
  • 如果参数为 NaN 或它的绝对值大于 1，那么结果为 NaN。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 要返回其反余弦的值。
返回：
参数的反余弦。

atan

public static double atan(double a)
返回一个值的反正切；返回的角度范围在 -pi/2 到 pi/2 之间。特殊情况如下：
  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 要返回其反正切的值。
返回：
参数的反正切。

toRadians

public static double toRadians(double angdeg)
将用角度表示的角转换为近似相等的用弧度表示的角。从角度到弧度的转换通常是不精确的。

参数：
angdeg - 用角度表示的角
返回：
角 angrad 用弧度表示的值。
从以下版本开始：
1.2

toDegrees

public static double toDegrees(double angrad)
将用弧度表示的角转换为近似相等的用角度表示的角。从弧度到角度的转换通常是不精确的；用户不 应该期望 cos(toRadians(90.0)) 与 0.0 完全相等。

参数：
angrad - 用弧度表示的角。
返回：
角 angrad 用角度表示的值。
从以下版本开始：
1.2

exp

public static double exp(double a)
返回欧拉数 e 的 double 次幂的值。特殊情况如下：
  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为负无穷大，那么结果为正 0。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - e 的指数。
返回：
值 ea，其中 e 是自然对数的底数。

log

public static double log(double a)
返回 double 值的自然对数（底数是 e）。特殊情况如下：
  • 如果参数为 NaN 或小于 0，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为负无穷大。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 一个值
返回：
ln a 的值，即 a 的自然对数。

log10

public static double log10(double a)
返回 double 值的底数为 10 的对数。特殊情况如下：
  • 如果参数为 NaN 或小于 0，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为负无穷大。
  • 如果参数等于 10 n（n 为整数），那么结果为 n。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 一个值
返回：
a 的底数为 10 的对数。
从以下版本开始：
1.5

sqrt

public static double sqrt(double a)
返回正确舍入的 double 值的正平方根。特殊情况如下：
  • 如果参数为 NaN 或小于 0，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果与参数相同。
否则，结果为最接近该参数值的实际数学平方根的 double 值。

参数：
a - 一个值。
返回：
a 的正平方根。 如果参数为 NaN 或小于 0，那么结果为 NaN。

cbrt

public static double cbrt(double a)
返回 double 值的立方根。对于正的有限值 x，cbrt(-x) == -cbrt(x)；也就是说，负值的立方根是该值数值的负立方根。特殊情况如下：
  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为无穷大，那么结果为无穷大，符号与参数符号相同。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 1 ulp 范围内。

参数：
a - 一个值。
返回：
a 的立方根。
从以下版本开始：
1.5

IEEEremainder

public static double IEEEremainder(double f1,
                                   double f2)
按照 IEEE 754 标准的规定，对两个参数进行余数运算。余数的算术值等于 f1 - f2 × n，其中 n 是最接近商 f1/f2 准确算术值的整数，如果两个整数都同样接近 f1/f2，那么 n 是其中的偶数。如果余数是 0，那么它的符号与第一个参数的符号相同。特殊情况如下：
  • 如果两个参数都为 NaN，或者第一个参数为无穷大，或者第二个参数为正 0 或负 0，那么结果为 NaN。
  • 如果第一个参数为有限值，第二个参数为无穷大，那么结果与第一个参数相同。

参数：
f1 - 被除数。
f2 - 除数。
返回：
f1 除以 f2 的余数。

ceil

public static double ceil(double a)
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并等于某个整数。特殊情况如下：
  • 如果参数值已经等于某个整数，那么结果与该参数相同。
  • 如果参数为 NaN、无穷大、正 0 或负 0，那么结果与参数相同。
  • 如果参数值小于 0，但是大于 -1.0，那么结果为负 0。
注意，Math.ceil(x) 的值与 -Math.floor(-x) 的值完全相同。

参数：
a - 一个值。
返回：
最小（最接近负无穷大）浮点值，该值大于等于该参数，并等于某个整数。

floor

public static double floor(double a)
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。特殊情况如下：
  • 如果参数值已经等于某个整数，那么结果与该参数相同。
  • 如果参数为 NaN、无穷大、正 0 或负 0，那么结果与参数相同。

参数：
a - 一个值。
返回：
最大（最接近正无穷大）浮点值，该值小于等于该参数，并等于某个整数。

rint

public static double rint(double a)
返回最接近参数并等于某一整数的 double 值。如果两个同为整数的 double 值都同样接近，那么结果取偶数。特殊情况如下：
  • 如果参数值已经是整数，那么结果与参数相同。
  • 如果参数为 NaN、无穷大、正 0 或负 0，那么结果与参数相同。

参数：
a - double 值。
返回：
最接近 a 的整数浮点值。

atan2

public static double atan2(double y,
                           double x)
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，返回所得角 theta。该方法通过计算 y/x 的反正切值来计算相角 theta，范围为从 -pi 到 pi。特殊情况如下：
  • 如果任一参数为 NaN，那么结果为 NaN。
  • 如果第一个参数为正 0，第二个参数为正数；或者第一个参数为正的有限值，第二个参数为正无穷大，那么结果为正 0。
  • 如果第一个参数为负 0，第二个参数为正数；或者第一个参数为负的有限值，第二个参数为正无穷大，那么结果为负 0。
  • 如果第一个参数为正 0，第二个参数为负数；或者第一个参数为正的有限值，第二个参数为负无穷大，那么结果为最接近 pi 的 double 值。
  • 如果第一个参数为负 0，第二个参数为负数；或者第一个参数为负的有限值，第二个参数为负无穷大，那么结果为最接近 pi 的 double 值。
  • 如果第一个参数为正数，第二个参数为正 0 或负 0；或者第一个参数为正无穷大，第二个参数为有限值，那么结果为最接近 pi/2 的 double 值。
  • 如果第一个参数为负数，第二个参数为正 0 或负 0；或者第一个参数为负无穷大，第二个参数为有限值，那么结果为最接近 -pi/2 的 double 值。
  • 如果两个参数都为正无穷大，那么结果为最接近 pi/4 的 double 值。
  • 如果第一个参数为正无穷大，第二个参数为负无穷大，那么结果为最接近 3*pi/4 的 double 值。
  • 如果第一个参数为负无穷大，第二个参数为正无穷大，那么结果为最接近 -pi/4 的 double 值。
  • 如果两个参数都为负无穷大，那么结果为最接近 -3*pi/4 的 double 值。

计算结果必须在准确结果的 2 ulp 范围内。结果必须具有半单调性。

参数：
y - 纵坐标
x - 横坐标
返回：
与笛卡儿坐标中点 (x, y) 对应的极坐标中点 (r, theta) 的 theta 组件。

pow

public static double pow(double a,
                         double b)
返回第一个参数的第二个参数次幂的值。特殊情况如下：
  • 如果第二个参数为正 0 或负 0，那么结果为 1.0。
  • 如果第二个参数为 1.0，那么结果与第一个参数相同。
  • 如果第二个参数为 NaN，那么结果为 NaN。
  • 如果第一个参数为 NaN，第二个参数非 0，那么结果为 NaN。
  • 如果
    • 第一个参数的绝对值大于 1，并且第二个参数为正无穷大，或者
    • 第一个参数的绝对值小于 1，并且第二个参数为负无穷大，
    那么结果为正无穷大。
  • 如果
    • 第一个参数的绝对值大于 1，并且第二个参数为负无穷大，或者
    • 第一个参数的绝对值小于 1，并且第二个参数为正无穷大，
    那么结果为正 0。
  • 如果第一个参数的绝对值等于1，并且第二个参数为无穷大，那么结果为 NaN。
  • 如果
    • 第一个参数为正 0，并且第二个参数大于 0，或者
    • 第一个参数为正无穷大，并且第二个参数小于 0，
    那么结果为正 0。
  • 如果
    • 第一个参数为正 0，并且第二个参数小于 0，或者
    • 第一个参数为正无穷大，并且第二个参数大于 0，
    那么结果为正无穷大。
  • 如果
    • 如果第一个参数为负 0，并且第二个参数大于 0 但不是有限的奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数小于 0 但不是有限的奇数整数，
    那么结果为正 0。
  • 如果
    • 第一个参数为负 0，并且第二个参数为正的有限奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数为负的有限奇数整数，
    那么结果为负 0。
  • 如果
    • 如果第一个参数为负 0，并且第二个参数小于 0 但不是有限的奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数大于 0 但不是有限的奇数整数，
    那么结果为正无穷大。
  • 如果
    • 第一个参数为负 0，并且第二个参数为负的有限奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数为正的有限奇数整数，
    那么结果为负无穷大。
  • 如果第一个参数为小于 0 的有限值，
    • 如果第二个参数为有限的偶数整数，那么结果等于第一个参数绝对值的第二个参数次幂的结果。
    • 如果第二个参数为有限的奇数整数，那么结果等于负的第一个参数绝对值的第二个参数次幂的结果。
    • 如果第二个参数为有限的非整数值，那么结果为 NaN。
  • 如果两个参数都为整数，并且结果恰好可以表示为一个 double 值，那么该结果恰好等于第一个参数的第二个参数次幂的算术结果。

（在前面的描述中，当且仅当浮点数为有限值并且是方法 ceil 的定点数，或者是方法 floor 的定点数时，才可以认为浮点值是整数。当且仅当将某个单参数方法应用到某个值的结果等于该值时，该值才是这个方法的定点值。）

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
a - 底数。
b - 指数。
返回：
值 ab。

round

public static int round(float a)
返回最接近参数的 int。结果将舍入为整数：加上 1/2，对结果调用 floor 并将所得结果强制转换为 int 类型。换句话说，结果等于以下表达式的值：

(int)Math.floor(a + 0.5f)

特殊情况如下：

  • 如果参数为 NaN，那么结果为 0。
  • 如果结果为负无穷大或任何小于等于 Integer.MIN_VALUE 的值，那么结果等于 Integer.MIN_VALUE 的值。
  • 如果参数为正无穷大或任何大于等于 Integer.MAX_VALUE 的值，那么结果等于 Integer.MAX_VALUE 的值。

参数：
a - 要舍入为整数的浮点值。
返回：
舍入为最接近的 int 值的参数值。
另请参见：
Integer.MAX_VALUE, Integer.MIN_VALUE

round

public static long round(double a)
返回最接近参数的 long。结果将舍入为整数：加上 1/2，对结果调用 floor 并将所得结果强制转换为 long 类型。换句话说，结果等于以下表达式的值：

(long)Math.floor(a + 0.5d)

特殊情况如下：

  • 如果参数为 NaN，那么结果为 0。
  • 如果结果为负无穷大或任何小于等于 Long.MIN_VALUE 的值，那么结果等于 Long.MIN_VALUE 的值。
  • 如果参数为正无穷大或任何大于等于 Long.MAX_VALUE 的值，那么结果等于 Long.MAX_VALUE 的值。

参数：
a - 舍入为 long 的浮点值。
返回：
舍入为最接近的 long 值的参数值。
另请参见：
Long.MAX_VALUE, Long.MIN_VALUE

random

public static double random()
返回带正号的 double 值，该值大于等于 0.0 且小于 1.0。返回值是一个伪随机选择的数，在该范围内（近似）均匀分布。

第一次调用该方法时，它将创建一个新的伪随机数生成器，与以下表达式完全相同

new java.util.Random
之后，新的伪随机数生成器可用于此方法的所有调用，但不能用于其他地方。

此方法是完全同步的，可允许多个线程使用而不出现错误。但是，如果许多线程需要以极高的速率生成伪随机数，那么这可能会减少每个线程对拥有自己伪随机数生成器的争用。

返回：
大于等于 0.0 且小于 1.0 的伪随机 double 值。
另请参见：
Random.nextDouble()

abs

public static int abs(int a)
返回 int 值的绝对值。如果参数为非负数，则返回该参数。如果参数为负数，则返回该参数的相反数。

注意，如果参数等于 Integer.MIN_VALUE 的值（即能够表示的最小负 int 值），那么结果与该值相同且为负。

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。
另请参见：
Integer.MIN_VALUE

abs

public static long abs(long a)
返回 long 值的绝对值。如果参数为非负数，则返回该参数。如果参数为负数，则返回该参数的相反数。

注意，如果参数等于 Long.MIN_VALUE 的值（即能够表示的最小负 long 值），则结果与该值相同且为负。

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。
另请参见：
Long.MIN_VALUE

abs

public static float abs(float a)
返回 float 值的绝对值。如果参数为非负数，则返回该参数。如果参数为负数，则返回该参数的相反数。特殊情况如下：
  • 如果参数为正 0 或负 0，那么结果为正 0。
  • 如果参数为无穷大，那么结果为正无穷大。
  • 如果参数为 NaN，那么结果为 NaN。
换句话说，结果等于以下表达式的值：

Float.intBitsToFloat(0x7fffffff & Float.floatToIntBits(a))

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。

abs

public static double abs(double a)
返回 double 值的绝对值。如果参数为非负数，则返回该参数。如果参数为负数，则返回该参数的相反数。特殊情况如下：
  • 如果参数为正 0 或负 0，那么结果为正 0。
  • 如果参数为无穷大，那么结果为正无穷大。
  • 如果参数为 NaN，那么结果为 NaN。
换句话说，结果等于以下表达式的值：

Double.longBitsToDouble((Double.doubleToLongBits(a)<<1)>>>1)

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。

max

public static int max(int a,
                      int b)
返回两个 int 值中较大的一个。也就是说，结果为更接近 Integer.MAX_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较大者。
另请参见：
Long.MAX_VALUE

max

public static long max(long a,
                       long b)
返回两个 long 值中较大的一个。也就是说，结果为更接近 Long.MAX_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较大者。
另请参见：
Long.MAX_VALUE

max

public static float max(float a,
                        float b)
返回两个 float 值中较大的一个。也就是说，结果为更接近正无穷大的参数。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，此方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为正 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较大者。

max

public static double max(double a,
                         double b)
返回两个 double 值中较大的一个。也就是说，结果为更接近正无穷大的参数。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，该方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为正 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较大者。

min

public static int min(int a,
                      int b)
返回两个 int 值中较小的一个。也就是说，结果为更接近 Integer.MIN_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。
另请参见：
Long.MIN_VALUE

min

public static long min(long a,
                       long b)
返回两个 long 值中较小的一个。也就是说，结果为更接近 Long.MIN_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。
另请参见：
Long.MIN_VALUE

min

public static float min(float a,
                        float b)
返回两个 float 值中较小的一个。也就是说，结果为更接近负无穷大的值。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，该方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为负 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。

min

public static double min(double a,
                         double b)
返回两个 double 值中较小的一个。也就是说，结果为更接近负无穷大的值。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，该方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为负 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。

ulp

public static double ulp(double d)
返回参数的 ulp 大小。double 值的 ulp 是此浮点值与下一个数值较大的 double 值之间的正距离。注意，对于非 NaN x，ulp(-x) == ulp(x)。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正的或负的无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为 Double.MIN_VALUE。
  • 如果参数为 ±Double.MAX_VALUE，那么结果等于 2971。

参数：
d - 要返回 ulp 的浮点值
返回：
参数的 ulp 大小
从以下版本开始：
1.5

ulp

public static float ulp(float f)
返回参数的 ulp 大小。float 值的 ulp 是该浮点值与下一个数值较大的 float 值之间的正距离。注意，对于非 NaN x，ulp(-x) == ulp(x)。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正的或负的无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为 Float.MIN_VALUE。
  • 如果参数为 ±Float.MAX_VALUE，那么结果等于 2104。

参数：
f - 要返回 ulp 的浮点值
返回：
参数的 ulp 大小
从以下版本开始：
1.5

signum

public static double signum(double d)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正 0 或负 0，那么结果与参数相同。

参数：
d - 要返回符号函数的浮点值
返回：
参数的符号函数
从以下版本开始：
1.5

signum

public static float signum(float f)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正 0 或负 0，那么结果与参数相同。

参数：
f - 要返回符号函数的浮点值
返回：
参数的符号函数
从以下版本开始：
1.5

sinh

public static double sinh(double x)
返回 double 值的双曲线正弦。x 双曲线正弦的定义是 (ex - e-x)/2，其中 e 是欧拉数。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为无穷大，那么结果为无穷大，符号与参数符号相同。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 2.5 ulp 范围内。

参数：
x - 要返回其双曲线正弦的数字。
返回：
x 的双曲线正弦。
从以下版本开始：
1.5

cosh

public static double cosh(double x)
返回 double 值的双曲线余弦。x 的双曲线余弦的定义是 (ex + e-x)/2，其中 e 是欧拉数。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为无穷大，那么结果为正无穷大。
  • 如果参数为 0，那么结果为 1.0。

计算结果必须在准确结果的 2.5 ulp 范围内。

参数：
x - 要返回其双曲线余弦的数字。
返回：
x 的双曲线余弦。
从以下版本开始：
1.5

tanh

public static double tanh(double x)
返回 double 值的双曲线余弦。x 的双曲线正切的定义是 (ex - e-x)/(ex + e-x)，即 sinh(x)/cosh(x)。注意，准确的 tanh 绝对值始终小于 1。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。
  • 如果参数为正无穷大，那么结果为 +1.0。
  • 如果参数为负无穷大，那么结果为 -1.0。

计算结果必须在准确结果的 2.5 ulp 范围内。任何有限输入值的 tanh 结果的绝对值必定小于等于 1。注意，一旦准确的 tanh 结果在极限值 ±1 的 1/2 ulp 内，则应该返回有正确符号的 ±1.0。

参数：
x - 要返回其双曲线正切的数字。
返回：
x 的双曲线正切。
从以下版本开始：
1.5

hypot

public static double hypot(double x,
                           double y)
返回 sqrt(x2 +y2)，没有中间溢出或下溢。

特殊情况如下：

  • 如果两个参数都为无穷大，那么结果为正无穷大。
  • 如果两个参数都为 NaN 且都不是无穷大，那么结果为 NaN。

计算结果必须在准确结果的 1 ulp 范围内。如果一个参数保持常量，那么在另一个参数中，结果必须具有半单调性。

参数：
x - 一个值
y - 一个值
返回：
没有中间溢出或下溢的 sqrt(x2 +y2)
从以下版本开始：
1.5

expm1

public static double expm1(double x)
返回 ex -1。注意，对于接近 0 的 x 值，expm1(x) + 1 的准确和比 exp(x) 更接近 ex 的真实结果。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为负无穷大，那么结果为 -1.0。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。任何有限输入值的 expm1 的结果一定大于或等于 -1.0。注意，一旦 ex - 1 的准确结果在极限值 -1 的 1/2 ulp 范围内，则应该返回 -1.0。

参数：
x - 在 ex -1 的计算中 e 的指数。
返回：
值 ex - 1。
从以下版本开始：
1.5

log1p

public static double log1p(double x)
返回参数与 1 之和的自然对数。注意，对于小的 x 值，log1p(x) 的结果比 log(1.0+x) 的浮点计算结果更接近 ln(1 + x) 的实际结果。

特殊情况如下：

  • 如果参数为 NaN 或小于 -1，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为负数，那么结果为负无穷大。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

计算结果必须在准确结果的 1 ulp 范围内。结果必须具有半单调性。

参数：
x - 一个值
返回：
值 ln(x + 1)，即 x + 1 的自然对数
从以下版本开始：
1.5

copySign

public static double copySign(double magnitude,
                              double sign)
返回带有第二个浮点参数符号的第一个浮点参数。注意，与 StrictMath.copySign 方法不同，此方法不要求将 NaN sign 参数视为正值；允许实现将某些 NaN 参数视为正，将另一些视为负，以获得更好的性能。

参数：
magnitude - 提供结果数值的参数
sign - 提供结果符号的参数
返回：
一个值，带有 magnitude 的数值，sign 的符号。
从以下版本开始：
1.6

copySign

public static float copySign(float magnitude,
                             float sign)
返回带有第二个浮点参数符号的第一个浮点参数。注意，与 StrictMath.copySign 方法不同，此方法不要求将 NaN sign 参数视为正值；允许实现将某些 NaN 参数视为正，将另一些视为负，以获得更好的性能。

参数：
magnitude - 提供结果数值的参数
sign - 提供结果符号的参数
返回：
一个值，带有 magnitude 的数值，sign 的符号。
从以下版本开始：
1.6

getExponent

public static int getExponent(float f)
返回 float 表示形式中使用的无偏指数。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 Float.MAX_EXPONENT + 1。
  • 如果参数为 0 或 subnormal，那么结果为 Float.MIN_EXPONENT -1。

参数：
f - 一个 float 值
返回：
参数的无偏指数
从以下版本开始：
1.6

getExponent

public static int getExponent(double d)
返回 double 表示形式中使用的无偏指数。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 Double.MAX_EXPONENT + 1。
  • 如果参数为 0 或 subnormal，那么结果为 Double.MIN_EXPONENT -1。

参数：
d - double 值
返回：
参数的无偏指数
从以下版本开始：
1.6

nextAfter

public static double nextAfter(double start,
                               double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。如果两个参数比较起来相等，则返回第二个参数。

特殊情况如下：

  • 如果任一参数为 NaN，则返回 NaN。
  • 如果两个参数都为有符号的 0，则不做更改地返回 direction（根据要求，如果参数比较起来相等，将返回第二个参数）。
  • 如果 start 为 ±Double.MIN_VALUE，而 direction 的值要求结果为一个比 start 小的数值，那么将返回 0，并带有与 start 相同的符号。
  • 如果 start 为无穷大，而 direction 的值要求结果为一个比 start 小的数值，则返回 Double.MAX_VALUE，并带有与 start 相同的符号。
  • 如果 start 等于 ±Double.MAX_VALUE，而 direction 的值要求结果为一个比 start 大的数值，则返回无穷大，并带有与 start 相同的符号。

参数：
start - 起始浮点值。
direction - 一个值，指示应返回 start 的某个邻数还是 start。
返回：
start 和 direction 之间与 start 相邻的浮点数。
从以下版本开始：
1.6

nextAfter

public static float nextAfter(float start,
                              double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。如果两个参数比较起来相等，则返回一个与第二个参数相等的值。

特殊情况如下：

  • 如果任一参数为 NaN，则返回 NaN。
  • 如果两个参数都为有符号的 0，则返回等于 direction 的值。
  • 如果 start 为 ±Float.MIN_VALUE，而 direction 的值要求结果为一个比 start 小的数值，那么将返回 0，并带有与 start 相同的符号。
  • 如果 start 为无穷大，而 direction 的值要求结果为一个比 start 小的数值，则返回 Float.MAX_VALUE，并带有与 start 相同的符号。
  • 如果 start 等于 ±Float.MAX_VALUE，而 direction 的值要求结果为一个比 start 大的数值，则返回无穷大，并带有与 start 相同的符号。

参数：
start - 起始浮点值。
direction - 一个值，指示应返回 start 的某个邻数还是 start。
返回：
start 和 direction 之间与 start 相邻的浮点数。
从以下版本开始：
1.6

nextUp

public static double nextUp(double d)
返回 d 和正无穷大之间与 d 相邻的浮点值。此方法在语义上等同于 nextAfter(d, Double.POSITIVE_INFINITY)；但是，nextUp 实现的返回速度可能比其等价 nextAfter 调用快。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为 0，那么结果为 Double.MIN_VALUE。

参数：
d - 起始浮点值。
返回：
离正无穷大较近的相邻浮点值。
从以下版本开始：
1.6

nextUp

public static float nextUp(float f)
返回 f 和正无穷大之间与 f 相邻的浮点值。此方法在语义上等同于 nextAfter(f, Float.POSITIVE_INFINITY)；但是，nextUp 实现的返回速度可能比其等价 nextAfter 调用快。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为 0，那么结果为 Float.MIN_VALUE

参数：
f - 起始浮点值
返回：
离正无穷大较近的相邻浮点值。
从以下版本开始：
1.6

scalb

public static double scalb(double d,
                           int scaleFactor)
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 double 值集合中的一个值。有关浮点值集合的讨论，请参阅 Java 语言规范。如果结果的指数在 Double.MIN_EXPONENT 和 Double.MAX_EXPONENT 之间，则可以正确地计算答案；如果结果的指数大于 Double.MAX_EXPONENT，则返回无穷大。注意，如果结果为 subnormal，则可能丢失精度；也就是说，scalb(x, n) 为 subnormal 时，scalb(scalb(x, n), -n) 可能不等于 x。结果为非 NaN 时，结果的符号将与 d 相同。

特殊情况如下：

  • 如果第一个参数为 NaN，则返回 NaN。
  • 如果第一个参数为无穷大，则返回带有相同符号的无穷大。
  • 如果第一个参数为 0，则返回带有相同符号的 0。

参数：
d - 要使用 2 的次幂缩放的数。
scaleFactor - 用来缩放 d 的 2 的次幂
返回：
d × 2scaleFactor
从以下版本开始：
1.6

scalb

public static float scalb(float f,
                          int scaleFactor)
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘以 float 值集合中的一个值。有关浮点值集合的讨论，请参阅 Java 语言规范。如果结果的指数在 Float.MIN_EXPONENT 和 Float.MAX_EXPONENT 之间，则可以正确地计算答案；如果结果的指数大于 Float.MAX_EXPONENT，则返回无穷大。注意，如果结果为 subnormal，则可能丢失精度；也就是说，scalb(x, n) 为 subnormal 时，scalb(scalb(x, n), -n) 可能不等于 x。结果为非 NaN 时，结果的符号将与 f 相同。

特殊情况如下：

  • 如果第一个参数为 NaN，则返回 NaN。
  • 如果第一个参数为无穷大，则返回带有相同符号的无穷大。
  • 如果第一个参数为 0，则返回带有相同符号的 0。

参数：
f - 要使用 2 的次幂缩放的数。
scaleFactor - 用来缩放 f 的 2 的次幂
返回：
f × 2scaleFactor
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Number (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Number

java.lang.Object
    继承者  java.lang.Number
所有已实现的接口：
Serializable
直接已知子类：
AtomicInteger, AtomicLong, BigDecimal, BigInteger, Byte, Double, Float, Integer, Long, Short
public abstract class Number
extends Object
implements Serializable

抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。

Number 的子类必须提供将表示的数值转换为 byte、double、float、int、long 和 short 的方法。

从以下版本开始：
JDK1.0
另请参见：
Byte, Double, Float, Integer, Long, Short, 序列化表格

构造方法摘要
Number()
方法摘要
byte | byteValue() 以 byte 形式返回指定的数值。
abstract double | doubleValue() 以 double 形式返回指定的数值。
abstract float | floatValue() 以 float 形式返回指定的数值。
abstract int | intValue() 以 int 形式返回指定的数值。
abstract long | longValue() 以 long 形式返回指定的数值。
short | shortValue() 以 short 形式返回指定的数值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Number

public Number()
方法详细信息

intValue

public abstract int intValue()
以 int 形式返回指定的数值。这可能会涉及到舍入或取整。

返回：
转换为 int 类型后该对象表示的数值。

longValue

public abstract long longValue()
以 long 形式返回指定的数值。这可能涉及到舍入或取整。

返回：
转换为 long 类型后该对象表示的数值。

floatValue

public abstract float floatValue()
以 float 形式返回指定的数值。这可能会涉及到舍入。

返回：
转换为 float 类型后该对象表示的数值。

doubleValue

public abstract double doubleValue()
以 double 形式返回指定的数值。这可能会涉及到舍入。

返回：
转换为 double 类型后该对象表示的数值。

byteValue

public byte byteValue()
以 byte 形式返回指定的数值。这可能会涉及到舍入或取整。

返回：
转换为 byte 类型后该对象表示的数值。
从以下版本开始：
JDK1.1

shortValue

public short shortValue()
以 short 形式返回指定的数值。这可能会涉及到舍入或取整。

返回：
转换为 short 类型后该对象表示的数值。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NegativeArraySizeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NegativeArraySizeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.NegativeArraySizeException
所有已实现的接口：
Serializable
public class NegativeArraySizeException
extends RuntimeException

如果应用程序试图创建大小为负的数组，则抛出该异常。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
NegativeArraySizeException()
构造不带详细消息的 NegativeArraySizeException。
NegativeArraySizeException(String s)
构造带指定详细消息的 NegativeArraySizeException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NegativeArraySizeException

public NegativeArraySizeException()
构造不带详细消息的 NegativeArraySizeException。

NegativeArraySizeException

public NegativeArraySizeException(String s)
构造带指定详细消息的 NegativeArraySizeException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoClassDefFoundError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NoClassDefFoundError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.NoClassDefFoundError
所有已实现的接口：
Serializable
public class NoClassDefFoundError
extends LinkageError

当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。

当前执行的类被编译时，所搜索的类定义存在，但无法再找到该定义。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
NoClassDefFoundError()
构造不带详细消息的 NoClassDefFoundError。
NoClassDefFoundError(String s)
构造带指定详细消息的 NoClassDefFoundError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoClassDefFoundError

public NoClassDefFoundError()
构造不带详细消息的 NoClassDefFoundError。

NoClassDefFoundError

public NoClassDefFoundError(String s)
构造带指定详细消息的 NoClassDefFoundError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchFieldError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NoSuchFieldError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.IncompatibleClassChangeError
                    继承者  java.lang.NoSuchFieldError
所有已实现的接口：
Serializable
public class NoSuchFieldError
extends IncompatibleClassChangeError

如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。

通常由编译器捕获该错误；仅当类定义发生不相容的更改时，在运行时才会发生该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
NoSuchFieldError()
构造不带详细消息的 NoSuchFieldException。
NoSuchFieldError(String s)
构造带指定详细消息的 NoSuchFieldException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchFieldError

public NoSuchFieldError()
构造不带详细消息的 NoSuchFieldException。

NoSuchFieldError

public NoSuchFieldError(String s)
构造带指定详细消息的 NoSuchFieldException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchFieldException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NoSuchFieldException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.NoSuchFieldException
所有已实现的接口：
Serializable
public class NoSuchFieldException
extends Exception

类不包含指定名称的字段时产生的信号。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
NoSuchFieldException()
构造方法。
NoSuchFieldException(String s)
带有详细消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchFieldException

public NoSuchFieldException()
构造方法。

NoSuchFieldException

public NoSuchFieldException(String s)
带有详细消息的构造方法。

参数：
s - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchMethodError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NoSuchMethodError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.IncompatibleClassChangeError
                    继承者  java.lang.NoSuchMethodError
所有已实现的接口：
Serializable
public class NoSuchMethodError
extends IncompatibleClassChangeError

当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。

通常由编译器捕获该错误；仅当类定义发生不相容的更改时，在运行时才会发生该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
NoSuchMethodError()
构造不带详细消息的 NoSuchMethodError。
NoSuchMethodError(String s)
构造带指定详细消息的 NoSuchMethodError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchMethodError

public NoSuchMethodError()
构造不带详细消息的 NoSuchMethodError。

NoSuchMethodError

public NoSuchMethodError(String s)
构造带指定详细消息的 NoSuchMethodError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchMethodException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NoSuchMethodException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.NoSuchMethodException
所有已实现的接口：
Serializable
public class NoSuchMethodException
extends Exception

无法找到某一特定方法时，抛出该异常。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
NoSuchMethodException()
构造不带详细消息的 NoSuchMethodException。
NoSuchMethodException(String s)
构造带指定详细消息的 NoSuchMethodException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchMethodException

public NoSuchMethodException()
构造不带详细消息的 NoSuchMethodException。

NoSuchMethodException

public NoSuchMethodException(String s)
构造带指定详细消息的 NoSuchMethodException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NullPointerException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NullPointerException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.NullPointerException
所有已实现的接口：
Serializable
public class NullPointerException
extends RuntimeException

当应用程序试图在需要对象的地方使用 null 时，抛出该异常。这种情况包括：

  • 调用 null 对象的实例方法。
  • 访问或修改 null 对象的字段。
  • 将 null 作为一个数组，获得其长度。
  • 将 null 作为一个数组，访问或修改其时间片。
  • 将 null 作为 Throwable 值抛出。

应用程序应该抛出该类的实例，指示其他对 null 对象的非法使用。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
NullPointerException()
构造不带详细消息的 NullPointerException。
NullPointerException(String s)
构造带指定详细消息的 NullPointerException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NullPointerException

public NullPointerException()
构造不带详细消息的 NullPointerException。

NullPointerException

public NullPointerException(String s)
构造带指定详细消息的 NullPointerException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 NumberFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.lang.NumberFormatException
所有已实现的接口：
Serializable
public class NumberFormatException
extends IllegalArgumentException

当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。

从以下版本开始：
JDK1.0
另请参见：
Integer.toString(), 序列化表格

构造方法摘要
NumberFormatException()
构造不带详细消息的 NumberFormatException。
NumberFormatException(String s)
构造带指定详细消息的 NumberFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NumberFormatException

public NumberFormatException()
构造不带详细消息的 NumberFormatException。

NumberFormatException

public NumberFormatException(String s)
构造带指定详细消息的 NumberFormatException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Object (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Object

java.lang.Object

public class Object

类 Object 是类层次结构的根类。每个类都使用 Object 作为超类。所有对象（包括数组）都实现这个类的方法。

从以下版本开始：
JDK1.0
另请参见：
Class

构造方法摘要
Object()
方法摘要
protected  Object clone()
创建并返回此对象的一个副本。
 boolean equals(Object obj)
指示其他某个对象是否与此对象“相等”。
protected  void finalize()
当垃圾回收器确定不存在对该对象的更多引用时，由对象的垃圾回收器调用此方法。
 Class<?> getClass()
返回此 Object 的运行时类。
 int hashCode()
返回该对象的哈希码值。
 void notify()
唤醒在此对象监视器上等待的单个线程。
 void notifyAll()
唤醒在此对象监视器上等待的所有线程。
 String toString()
返回该对象的字符串表示。
 void wait()
在其他线程调用此对象的 notify() 方法或 notifyAll() 方法前，导致当前线程等待。
 void wait(long timeout)
在其他线程调用此对象的 notify() 方法或 notifyAll() 方法，或者超过指定的时间量前，导致当前线程等待。
 void wait(long timeout, int nanos)
在其他线程调用此对象的 notify() 方法或 notifyAll() 方法，或者其他某个线程中断当前线程，或者已超过某个实际时间量前，导致当前线程等待。

构造方法详细信息

Object

public Object()
方法详细信息

getClass

public final Class<?> getClass()
返回此 Object 的运行时类。返回的 Class 对象是由所表示类的 static synchronized 方法锁定的对象。

实际结果类型是 Class<? extends |X|>，其中 |X| 表示清除表达式中的静态类型，该表达式调用 getClass。 例如，以下代码片段中不需要强制转换：

Number n = 0;
Class<? extends Number> c = n.getClass();

返回：
表示此对象运行时类的 Class 对象。
另请参见：
The Java Language Specification, Third Edition (15.8.2 Class Literals)

hashCode

public int hashCode()
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

返回：
此对象的一个哈希码值。
另请参见：
equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
指示其他某个对象是否与此对象“相等”。

equals 方法在非空对象引用上实现相等关系：

  • 自反性：对于任何非空引用值 x，x.equals(x) 都应返回 true。
  • 对称性：对于任何非空引用值 x 和 y，当且仅当 y.equals(x) 返回 true 时，x.equals(y) 才应返回 true。
  • 传递性：对于任何非空引用值 x、y 和 z，如果 x.equals(y) 返回 true，并且 y.equals(z) 返回 true，那么 x.equals(z) 应返回 true。
  • 一致性：对于任何非空引用值 x 和 y，多次调用 x.equals(y) 始终返回 true 或始终返回 false，前提是对象上 equals 比较中所用的信息没有被修改。
  • 对于任何非空引用值 x，x.equals(null) 都应返回 false。

Object 类的 equals 方法实现对象上差别可能性最大的相等关系；即，对于任何非空引用值 x 和 y，当且仅当 x 和 y 引用同一个对象时，此方法才返回 true（x == y 具有值 true）。

注意：当此方法被重写时，通常有必要重写 hashCode 方法，以维护 hashCode 方法的常规协定，该协定声明相等对象必须具有相等的哈希码。

参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
hashCode(), Hashtable

clone

protected Object clone()
                throws CloneNotSupportedException
创建并返回此对象的一个副本。“副本”的准确含义可能依赖于对象的类。这样做的目的是，对于任何对象 x，表达式：
x.clone() != x
为 true，表达式：
x.clone().getClass() == x.getClass()
也为 true，但这些并非必须要满足的要求。一般情况下：
x.clone().equals(x)
为 true，但这并非必须要满足的要求。

按照惯例，返回的对象应该通过调用 super.clone 获得。如果一个类及其所有的超类（Object 除外）都遵守此约定，则 x.clone().getClass() == x.getClass()。

按照惯例，此方法返回的对象应该独立于该对象（正被复制的对象）。要获得此独立性，在 super.clone 返回对象之前，有必要对该对象的一个或多个字段进行修改。这通常意味着要复制包含正在被复制对象的内部“深层结构”的所有可变对象，并使用对副本的引用替换对这些对象的引用。如果一个类只包含基本字段或对不变对象的引用，那么通常不需要修改 super.clone 返回的对象中的字段。

Object 类的 clone 方法执行特定的复制操作。首先，如果此对象的类不能实现接口 Cloneable，则会抛出 CloneNotSupportedException。注意，所有的数组都被视为实现接口 Cloneable。否则，此方法会创建此对象的类的一个新实例，并像通过分配那样，严格使用此对象相应字段的内容初始化该对象的所有字段；这些字段的内容没有被自我复制。所以，此方法执行的是该对象的“浅表复制”，而不“深层复制”操作。

Object 类本身不实现接口 Cloneable，所以在类为 Object 的对象上调用 clone 方法将会导致在运行时抛出异常。

返回：
此实例的一个副本。
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable

toString

public String toString()
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

返回：
该对象的字符串表示形式。

notify

public final void notify()
唤醒在此对象监视器上等待的单个线程。如果所有线程都在此对象上等待，则会选择唤醒其中一个线程。选择是任意性的，并在对实现做出决定时发生。线程通过调用其中一个 wait 方法，在对象的监视器上等待。

直到当前线程放弃此对象上的锁定，才能继续执行被唤醒的线程。被唤醒的线程将以常规方式与在该对象上主动同步的其他所有线程进行竞争；例如，唤醒的线程在作为锁定此对象的下一个线程方面没有可靠的特权或劣势。

此方法只应由作为此对象监视器的所有者的线程来调用。通过以下三种方法之一，线程可以成为此对象监视器的所有者：

  • 通过执行此对象的同步实例方法。
  • 通过执行在此对象上进行同步的 synchronized 语句的正文。
  • 对于 Class 类型的对象，可以通过执行该类的同步静态方法。

一次只能有一个线程拥有对象的监视器。

抛出：
IllegalMonitorStateException - 如果当前线程不是此对象监视器的所有者。
另请参见：
notifyAll(), wait()

notifyAll

public final void notifyAll()
唤醒在此对象监视器上等待的所有线程。线程通过调用其中一个 wait 方法，在对象的监视器上等待。

直到当前线程放弃此对象上的锁定，才能继续执行被唤醒的线程。被唤醒的线程将以常规方式与在该对象上主动同步的其他所有线程进行竞争；例如，唤醒的线程在作为锁定此对象的下一个线程方面没有可靠的特权或劣势。

此方法只应由作为此对象监视器的所有者的线程来调用。有关线程能够成为监视器所有者的方法的描述，请参阅 notify 方法。

抛出：
IllegalMonitorStateException - 如果当前线程不是此对象监视器的所有者。
另请参见：
notify(), wait()

wait

public final void wait(long timeout)
                throws InterruptedException
在其他线程调用此对象的 notify() 方法或 notifyAll() 方法，或者超过指定的时间量前，导致当前线程等待。

当前线程必须拥有此对象监视器。

此方法导致当前线程（称之为 T）将其自身放置在对象的等待集中，然后放弃此对象上的所有同步要求。出于线程调度目的，在发生以下四种情况之一前，线程 T 被禁用，且处于休眠状态：

  • 其他某个线程调用此对象的 notify 方法，并且线程 T 碰巧被任选为被唤醒的线程。
  • 其他某个线程调用此对象的 notifyAll 方法。
  • 其他某个线程中断线程 T。
  • 大约已经到达指定的实际时间。但是，如果 timeout 为零，则不考虑实际时间，在获得通知前该线程将一直等待。
然后，从对象的等待集中删除线程 T，并重新进行线程调度。然后，该线程以常规方式与其他线程竞争，以获得在该对象上同步的权利；一旦获得对该对象的控制权，该对象上的所有其同步声明都将被恢复到以前的状态，这就是调用 wait 方法时的情况。然后，线程 T 从 wait 方法的调用中返回。所以，从 wait 方法返回时，该对象和线程 T 的同步状态与调用 wait 方法时的情况完全相同。

在没有被通知、中断或超时的情况下，线程还可以唤醒一个所谓的虚假唤醒 (spurious wakeup)。虽然这种情况在实践中很少发生，但是应用程序必须通过以下方式防止其发生，即对应该导致该线程被提醒的条件进行测试，如果不满足该条件，则继续等待。换句话说，等待应总是发生在循环中，如下面的示例：

synchronized (obj) {
while (<condition does not hold>)
obj.wait(timeout);
... // Perform action appropriate to condition
     }
（有关这一主题的更多信息，请参阅 Doug Lea 撰写的 Concurrent Programming in Java (Second Edition) (Addison-Wesley, 2000) 中的第 3.2.3 节或 Joshua Bloch 撰写的 Effective Java Programming Language Guide (Addison-Wesley, 2001) 中的第 50 项。

如果当前线程在等待之前或在等待时被任何线程中断，则会抛出 InterruptedException。在按上述形式恢复此对象的锁定状态时才会抛出此异常。

注意，由于 wait 方法将当前线程放入了对象的等待集中，所以它只能解除此对象的锁定；可以同步当前线程的任何其他对象在线程等待时仍处于锁定状态。

此方法只应由作为此对象监视器的所有者的线程来调用。有关线程能够成为监视器所有者的方法的描述，请参阅 notify 方法。

参数：
timeout - 要等待的最长时间（以毫秒为单位）。
抛出：
IllegalArgumentException - 如果超时值为负。
IllegalMonitorStateException - 如果当前线程不是此对象监视器的所有者。
InterruptedException - 如果在当前线程等待通知之前或者正在等待通知时，任何线程中断了当前线程。在抛出此异常时，当前线程的中断状态 被清除。
另请参见：
notify(), notifyAll()

wait

public final void wait(long timeout,
                       int nanos)
                throws InterruptedException
在其他线程调用此对象的 notify() 方法或 notifyAll() 方法，或者其他某个线程中断当前线程，或者已超过某个实际时间量前，导致当前线程等待。

此方法类似于一个参数的 wait 方法，但它允许更好地控制在放弃之前等待通知的时间量。用毫微秒度量的实际时间量可以通过以下公式计算出来：

1000000*timeout+nanos

在其他所有方面，此方法执行的操作与带有一个参数的 wait(long) 方法相同。需要特别指出的是，wait(0, 0) 与 wait(0) 相同。

当前线程必须拥有此对象监视器。该线程发布对此监视器的所有权，并等待下面两个条件之一发生：

  • 其他线程通过调用 notify 方法，或 notifyAll 方法通知在此对象的监视器上等待的线程醒来。
  • timeout 毫秒值与 nanos 毫微秒参数值之和指定的超时时间已用完。

然后，该线程等到重新获得对监视器的所有权后才能继续执行。

对于某一个参数的版本，实现中断和虚假唤醒是有可能的，并且此方法应始终在循环中使用：

synchronized (obj) {
while (<condition does not hold>)
obj.wait(timeout, nanos);
... // Perform action appropriate to condition
     }
此方法只应由作为此对象监视器的所有者的线程来调用。有关线程能够成为监视器所有者的方法的描述，请参阅 notify 方法。

参数：
timeout - 要等待的最长时间（以毫秒为单位）。
nanos - 额外时间（以毫微秒为单位，范围是 0-999999）。
抛出：
IllegalArgumentException - 如果超时值是负数，或者毫微秒值不在 0-999999 范围内。
IllegalMonitorStateException - 如果当前线程不是此对象监视器的所有者。
InterruptedException - 如果在当前线程等待通知之前或者正在等待通知时，任何线程中断了当前线程。在抛出此异常时，当前线程的中断状态 被清除。

wait

public final void wait()
                throws InterruptedException
在其他线程调用此对象的 notify() 方法或 notifyAll() 方法前，导致当前线程等待。换句话说，此方法的行为就好像它仅执行 wait(0) 调用一样。

当前线程必须拥有此对象监视器。该线程发布对此监视器的所有权并等待，直到其他线程通过调用 notify 方法，或 notifyAll 方法通知在此对象的监视器上等待的线程醒来。然后该线程将等到重新获得对监视器的所有权后才能继续执行。

对于某一个参数的版本，实现中断和虚假唤醒是可能的，而且此方法应始终在循环中使用：

synchronized (obj) {
while (<condition does not hold>)
obj.wait();
... // Perform action appropriate to condition
     }
此方法只应由作为此对象监视器的所有者的线程来调用。有关线程能够成为监视器所有者的方法的描述，请参阅 notify 方法。

抛出：
IllegalMonitorStateException - 如果当前线程不是此对象监视器的所有者。
InterruptedException - 如果在当前线程等待通知之前或者正在等待通知时，任何线程中断了当前线程。在抛出此异常时，当前线程的中断状态 被清除。
另请参见：
notify(), notifyAll()

finalize

protected void finalize()
                 throws Throwable
当垃圾回收器确定不存在对该对象的更多引用时，由对象的垃圾回收器调用此方法。子类重写 finalize 方法，以配置系统资源或执行其他清除。

finalize 的常规协定是：当 JavaTM 虚拟机已确定尚未终止的任何线程无法再通过任何方法访问此对象时，将调用此方法，除非由于准备终止的其他某个对象或类的终结操作执行了某个操作。finalize 方法可以采取任何操作，其中包括再次使此对象对其他线程可用；不过，finalize 的主要目的是在不可撤消地丢弃对象之前执行清除操作。例如，表示输入/输出连接的对象的 finalize 方法可执行显式 I/O 事务，以便在永久丢弃对象之前中断连接。

Object 类的 finalize 方法执行非特殊性操作；它仅执行一些常规返回。Object 的子类可以重写此定义。

Java 编程语言不保证哪个线程将调用某个给定对象的 finalize 方法。但可以保证在调用 finalize 时，调用 finalize 的线程将不会持有任何用户可见的同步锁定。如果 finalize 方法抛出未捕获的异常，那么该异常将被忽略，并且该对象的终结操作将终止。

在启用某个对象的 finalize 方法后，将不会执行进一步操作，直到 Java 虚拟机再次确定尚未终止的任何线程无法再通过任何方法访问此对象，其中包括由准备终止的其他对象或类执行的可能操作，在执行该操作时，对象可能被丢弃。

对于任何给定对象，Java 虚拟机最多只调用一次 finalize 方法。

finalize 方法抛出的任何异常都会导致此对象的终结操作停止，但可以通过其他方法忽略它。

抛出：
Throwable - 此方法抛出的 Exception
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OutOfMemoryError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 OutOfMemoryError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.VirtualMachineError
                继承者  java.lang.OutOfMemoryError
所有已实现的接口：
Serializable
public class OutOfMemoryError
extends VirtualMachineError

因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
OutOfMemoryError()
构造不带详细消息的 OutOfMemoryError。
OutOfMemoryError(String s)
构造带指定详细消息的 OutOfMemoryError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OutOfMemoryError

public OutOfMemoryError()
构造不带详细消息的 OutOfMemoryError。

OutOfMemoryError

public OutOfMemoryError(String s)
构造带指定详细消息的 OutOfMemoryError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Override (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

java.lang
注释类型 Override

@Target(value=METHOD)
@Retention(value=SOURCE)
public @interface Override

表示一个方法声明打算重写超类中的另一个方法声明。如果方法利用此注释类型进行注解但没有重写超类方法，则编译器会生成一条错误消息。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Package (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Package

java.lang.Object
    继承者  java.lang.Package
所有已实现的接口：
AnnotatedElement
public class Package
extends Object
implements AnnotatedElement

Package 对象包含有关 Java 包的实现和规范的版本信息。通过用于加载类的 ClassLoader 实例，可以获取并获得此版本信息。通常，此信息存储在与类一起分发的清单中。

组成包的类集可以实现一个特定规范，如此一来，就可以通过规范标题、版本号和供应商字符串来标识该规范。应用程序可以询问包是否与特定版本兼容，有关详细信息，请参阅 isCompatibleWith 方法。

规范的版本号使用了一个由句点 "." 分隔的十进制正整数组成的语法，例如 "2.0" 或 "1.2.3.4.5.6.7"。这允许使用可扩展的编号来表示主版本号、次版本号、缩微版本号，等等。版本规范是由下列形式的语法描述的：

SpecificationVersion:
Digits RefinedVersionopt

RefinedVersion:
. Digits
. Digits RefinedVersion

Digits:
Digit
Digits

Digit:
Character.isDigit(char) 会对其返回 true 的任何字符，如 0、1、2 等等。

实现标题、版本和供应商字符串共同标识了一个实现，并且可以很方便地使用它们来支持出现问题时所涉及的包的准确报告。三个实现字符串内容都是特定于供应商的。实现版本字符串没有特定的语法，并且应该只在为了使它们等同于所需的版本标识符时对它们进行比较。

在每一个 ClassLoader 实例中，相同 java 包中的所有类都有相同的 Package 对象。静态方法允许通过名称或当前类加载器已知的所有包的集合来找到包。

另请参见：
ClassLoader.definePackage(java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.lang.String, java.net.URL)

方法摘要
<A extends Annotation>
A
getAnnotation(Class<A> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
 Annotation[] getAnnotations()
返回此元素上存在的所有注释。
 Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。
 String getImplementationTitle()
返回此包的标题。
 String getImplementationVendor()
返回提供该实现的组织、供应商或公司的名称。
 String getImplementationVersion()
返回该实现的版本。
 String getName()
返回此包的名称。
static Package getPackage(String name)
通过调用方的 ClassLoader 实例中的名称找到一个包。
static Package[] getPackages()
获得调用方的 ClassLoader 实例当前已知的所有包。
 String getSpecificationTitle()
返回此包实现的规范标题。
 String getSpecificationVendor()
返回拥有并维护实现此包的类规范的组织、供应商或公司的名称。
 String getSpecificationVersion()
返回此包实现的规范的版本号。
 int hashCode()
返回从包名称计算的哈希码。
 boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。
 boolean isCompatibleWith(String desired)
比较此包的规范版本和所需版本。
 boolean isSealed()
如果此包是密封的，则返回 ture。
 boolean isSealed(URL url)
如果此包对于指定的代码源 url 是密封的，则返回 ture。
 String toString()
返回此 Package 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getName

public String getName()
返回此包的名称。

返回：
根据 Java 语言规范第三版 §6.5.3 中的定义，返回此包的完全限定名，例如 java.lang。

getSpecificationTitle

public String getSpecificationTitle()
返回此包实现的规范标题。

返回：
规范的标题，如果不知道此标题，则返回 null。

getSpecificationVersion

public String getSpecificationVersion()
返回此包实现的规范的版本号。该版本字符串必须是以 "." 分隔的十进制正整数的序列，并可能有前导零。在比较版本字符串时，比较最重要的数字。

返回：
规范版本，如果不知道该版本，则返回 null。

getSpecificationVendor

public String getSpecificationVendor()
返回拥有并维护实现此包的类规范的组织、供应商或公司的名称。

返回：
规范的供应商，如果不知道此供应商，则返回 null。

getImplementationTitle

public String getImplementationTitle()
返回此包的标题。

返回：
实现的标题，如果不知道此标题，则返回 null。

getImplementationVersion

public String getImplementationVersion()
返回该实现的版本。它由该实现的供应商分配的任何字符串组成，并且没有任何由 Java 运行时指定或需要的特定语法。可以对实现的版本进行比较，使其等同于此包的供应商用于该实现的其他包版本字符串。

返回：
实现的版本，如果不知道此版本，则返回 null。

getImplementationVendor

public String getImplementationVendor()
返回提供该实现的组织、供应商或公司的名称。

返回：
实现此包的供应商。

isSealed

public boolean isSealed()
如果此包是密封的，则返回 ture。

返回：
如果包是密封的，则返回 ture，否则返回 false。

isSealed

public boolean isSealed(URL url)
如果此包对于指定的代码源 url 是密封的，则返回 ture。

参数：
url - 代码源 url
返回：
如果此包对于 url 是密封的，则返回 ture

isCompatibleWith

public boolean isCompatibleWith(String desired)
                         throws NumberFormatException
比较此包的规范版本和所需版本。如果此包的规范版本号大于或等于所需版本号，则返回 ture。

通过按顺序比较所需字符串和规范字符串的对应组件，对版本号进行比较。每个组件都被转换为一个十进制整数和比较的值。如果规范值大于所需值，则返回 true。如果小于所需值，则返回 false。如果两个值相等，则跳过这一比较周期，比较下一对组件。

参数：
desired - 所需版本的版本字符串。
返回：
如果此包的版本号大于或等于所需的版本号，则返回 ture。
抛出：
NumberFormatException - 如果所需版本或当前版本的点形式不正确。

getPackage

public static Package getPackage(String name)
通过调用方的 ClassLoader 实例中的名称找到一个包。调用方的 ClassLoader 实例用于找到对应于指定类的包实例。如果调用方的 ClassLoader 实例为 null，则搜索系统的 ClassLoader 实例加载的包集合，以找到指定包。

只有类加载器创建了具有适当属性的包实例，包中才会有规范和版本属性。通常，这些属性定义在随类一起提供的清单中。

参数：
name - 包名称，例如，java.lang。
返回：
具有所请求名称的包。如果不能从存档或基本代码中获得包信息，则可能返回 null。

getPackages

public static Package[] getPackages()
获得调用方的 ClassLoader 实例当前已知的所有包。这些包对应于通过 ClassLoader 实例中的名称加载或访问的类。如果调用方的 ClassLoader 实例是引导程序的 ClassLoader 实例（它在一些实现中可能用 null 表示），则只返回通过引导程序的 ClassLoader 实例加载的类所对应的包。

返回：
调用方的 ClassLoader 实例已知的包的新数组。如果没有已知的包，则返回零长度的数组。

hashCode

public int hashCode()
返回从包名称计算的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
从包名称计算的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 Package 的字符串表示形式。它的值是字符串 "package" 和包名称。如果定义了包的标题，则追加包的标题。如果定义了包的版本，则追加包的版本。

覆盖：
类 Object 中的 toString
返回：
包的字符串表示形式。

getAnnotation

public <A extends Annotation> A getAnnotation(Class<A> annotationClass)
从接口 AnnotatedElement 复制的描述
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

指定者：
接口 AnnotatedElement 中的 getAnnotation
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果该元素的指定注释类型的注释存在于此对象上，则返回这些注释，否则返回 null
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

isAnnotationPresent

public boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
从接口 AnnotatedElement 复制的描述
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。此方法主要是为了便于访问标记注释而设计的。

指定者：
接口 AnnotatedElement 中的 isAnnotationPresent
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果指定注释类型的注释存在于此对象上，则返回 true，否则返回 false
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getAnnotations

public Annotation[] getAnnotations()
从接口 AnnotatedElement 复制的描述
返回此元素上存在的所有注释。（如果此元素没有注释，则返回长度为零的数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getAnnotations
返回：
此元素上存在的所有注释
从以下版本开始：
1.5

getDeclaredAnnotations

public Annotation[] getDeclaredAnnotations()
从接口 AnnotatedElement 复制的描述
返回直接存在于此元素上的所有注释。与此接口中的其他方法不同，该方法将忽略继承的注释。（如果没有注释直接存在于此元素上，则返回长度为零的一个数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getDeclaredAnnotations
返回：
直接存在于此元素上的所有注释
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Process (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Process

java.lang.Object
    继承者  java.lang.Process

public abstract class Process
extends Object

ProcessBuilder.start() 和 Runtime.exec 方法创建一个本机进程，并返回 Process 子类的一个实例，该实例可用来控制进程并获得相关信息。Process 类提供了执行从进程输入、执行输出到进程、等待进程完成、检查进程的退出状态以及销毁（杀掉）进程的方法。

创建进程的方法可能无法针对某些本机平台上的特定进程很好地工作，比如，本机窗口进程，守护进程，Microsoft Windows 上的 Win16/DOS 进程，或者 shell 脚本。创建的子进程没有自己的终端或控制台。它的所有标准 io（即 stdin、stdout 和 stderr）操作都将通过三个流 (getOutputStream()、getInputStream() 和 getErrorStream()) 重定向到父进程。父进程使用这些流来提供到子进程的输入和获得从子进程的输出。因为有些本机平台仅针对标准输入和输出流提供有限的缓冲区大小，如果读写子进程的输出流或输入流迅速出现失败，则可能导致子进程阻塞，甚至产生死锁。

当没有 Process 对象的更多引用时，不是删掉子进程，而是继续异步执行子进程。

对于带有 Process 对象的 Java 进程，没有必要异步或并发执行由 Process 对象表示的进程。

从以下版本开始：
JDK1.0
另请参见：
ProcessBuilder, Runtime.exec(String[], String[], File)

构造方法摘要
Process()
方法摘要
abstract void | destroy() 杀掉子进程。
abstract int | exitValue() 返回子进程的出口值。
abstract InputStream | getErrorStream() 获取子进程的错误流。
abstract InputStream | getInputStream() 获取子进程的输入流。
abstract OutputStream | getOutputStream() 获取子进程的输出流。
abstract int | waitFor() 导致当前线程等待，如有必要，一直要等到由该 Process 对象表示的进程已经终止。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Process

public Process()
方法详细信息

getOutputStream

public abstract OutputStream getOutputStream()
获取子进程的输出流。输出流被传送给由该 Process 对象表示的进程的标准输入流。

实现注意事项：对输出流进行缓冲是一个好主意。

返回：
连接到子进程正常输入的输出流。

getInputStream

public abstract InputStream getInputStream()
获取子进程的输入流。输入流获得由该 Process 对象表示的进程的标准输出流。

实现注意事项：对输入流进行缓冲是一个好主意。

返回：
连接到子进程正常输出的输入流。
另请参见：
ProcessBuilder.redirectErrorStream()

getErrorStream

public abstract InputStream getErrorStream()
获取子进程的错误流。错误流获得由该 Process 对象表示的进程的错误输出流传送的数据。

实现注意事项：对输入流进行缓冲是一个好主意。

返回：
连接到子进程错误流的输入流。
另请参见：
ProcessBuilder.redirectErrorStream()

waitFor

public abstract int waitFor()
                     throws InterruptedException
导致当前线程等待，如有必要，一直要等到由该 Process 对象表示的进程已经终止。如果已终止该子进程，此方法立即返回。如果没有终止该子进程，调用的线程将被阻塞，直到退出子进程。

返回：
进程的出口值。根据惯例，0 表示正常终止。
抛出：
InterruptedException - 如果当前线程在等待时被另一线程中断，则停止等待，抛出 InterruptedException。

exitValue

public abstract int exitValue()
返回子进程的出口值。

返回：
此 Process 对象表示的子进程的出口值。根据惯例，值 0 表示正常终止。
抛出：
IllegalThreadStateException - 如果此 Process 对象表示的子进程尚未终止。

destroy

public abstract void destroy()
杀掉子进程。强制终止此 Process 对象表示的子进程。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProcessBuilder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ProcessBuilder

java.lang.Object
    继承者  java.lang.ProcessBuilder

public final class ProcessBuilder
extends Object

此类用于创建操作系统进程。

每个 ProcessBuilder 实例管理一个进程属性集。start() 方法利用这些属性创建一个新的 Process 实例。start() 方法可以从同一实例重复调用，以利用相同的或相关的属性创建新的子进程。

每个进程生成器管理这些进程属性：

  • 命令 是一个字符串列表，它表示要调用的外部程序文件及其参数（如果有）。在此，表示有效的操作系统命令的字符串列表是依赖于系统的。例如，每一个总体变量，通常都要成为此列表中的元素，但有一些操作系统，希望程序能自己标记命令行字符串——在这种系统中，Java 实现可能需要命令确切地包含这两个元素。
  • 环境 是从变量 到值 的依赖于系统的映射。初始值是当前进程环境的一个副本（请参阅 System.getenv()）。
  • 工作目录。默认值是当前进程的当前工作目录，通常根据系统属性 user.dir 来命名。
  • redirectErrorStream 属性。最初，此属性为 false，意思是子进程的标准输出和错误输出被发送给两个独立的流，这些流可以通过 Process.getInputStream() 和 Process.getErrorStream() 方法来访问。如果将值设置为 true，标准错误将与标准输出合并。这使得关联错误消息和相应的输出变得更容易。在此情况下，合并的数据可从 Process.getInputStream() 返回的流读取，而从 Process.getErrorStream() 返回的流读取将直接到达文件尾。

修改进程构建器的属性将影响后续由该对象的 start() 方法启动的进程，但从不会影响以前启动的进程或 Java 自身的进程。

大多数错误检查由 start() 方法执行。可以修改对象的状态，但这样 start() 将会失败。例如，将命令属性设置为一个空列表将不会抛出异常，除非包含了 start()。

注意，此类不是同步的。如果多个线程同时访问一个 ProcessBuilder，而其中至少一个线程从结构上修改了其中一个属性，它必须 保持外部同步。

很容易启动一个使用默认工作目录和环境的新进程：

 Process p = new ProcessBuilder("myCommand", "myArg").start();

下面是一个利用修改过的工作目录和环境启动进程的例子：

 ProcessBuilder pb = new ProcessBuilder("myCommand", "myArg1", "myArg2");
 Map<String, String> env = pb.environment();
 env.put("VAR1", "myValue");
 env.remove("OTHERVAR");
 env.put("VAR2", env.get("VAR1") + "suffix");
 pb.directory(new File("myDir"));
 Process p = pb.start();

要利用一组明确的环境变量启动进程，在添加环境变量之前，首先调用 Map.clear()。

从以下版本开始：
1.5

构造方法摘要
ProcessBuilder(List<String> command)
利用指定的操作系统程序和参数构造一个进程生成器。
ProcessBuilder(String... command)
利用指定的操作系统程序和参数构造一个进程生成器。
方法摘要
List<String> | command() 返回此进程生成器的操作系统程序和参数。
ProcessBuilder | command(List<String> command) 设置此进程生成器的操作系统程序和参数。
ProcessBuilder | command(String... command) 设置此进程生成器的操作系统程序和参数。
File | directory() 返回此进程生成器的工作目录。
ProcessBuilder | directory(File directory) 设置此进程生成器的工作目录。
Map<String,String> | environment() 返回此进程生成器环境的字符串映射视图。
boolean | redirectErrorStream() 通知进程生成器是否合并标准错误和标准输出。
ProcessBuilder | redirectErrorStream(boolean redirectErrorStream) 设置此进程生成器的 redirectErrorStream 属性。
Process | start() 使用此进程生成器的属性启动一个新进程。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProcessBuilder

public ProcessBuilder(List<String> command)
利用指定的操作系统程序和参数构造一个进程生成器。此构造方法不会 制作一份 command 列表的副本。后续列表更新将在进程生成器的状态中反映出来。不必检查 command 是否为一个有效的操作系统命令。

参数：
command - 包含程序及其参数的列表
抛出：
NullPointerException - 如果参数为 null

ProcessBuilder

public ProcessBuilder(String... command)
利用指定的操作系统程序和参数构造一个进程生成器。这是一个有用的构造方法，它将进程生成器的命令设置为与 command 数组包含相同字符串的字符串列表，且顺序相同。不必检查 command 是否为一个有效的操作系统命令。

参数：
command - 包含程序及其参数的字符串数组
方法详细信息

command

public ProcessBuilder command(List<String> command)
设置此进程生成器的操作系统程序和参数。此方法不会 制作一份 command 列表的副本。后续列表更新将在进程生成器的状态中反映出来。不必检查 command 是否为一个有效的操作系统命令。

参数：
command - 包含程序及其参数的列表
返回：
此进程生成器
抛出：
NullPointerException - 如果参数为 null

command

public ProcessBuilder command(String... command)
设置此进程生成器的操作系统程序和参数。这是一个有用的方法，它将命令设置为与 command 数组包含相同字符串的字符串列表，且顺序相同。不必检查 command 是否为一个有效的操作系统命令。

参数：
command - 包含程序及其参数的字符串数组
返回：
此进程生成器

command

public List<String> command()
返回此进程生成器的操作系统程序和参数。该返回的列表不是 一份副本。后续列表更新将在此进程生成器的状态中反映出来。

返回：
此进程生成器的程序及其参数

environment

public Map<String,String> environment()
返回此进程生成器环境的字符串映射视图。 无论进程生成器何时创建，都需要将环境初始化为一份当前进程环境的副本（请参阅 System.getenv()）。由此对象的 start() 方法启动的后续子进程将使用这一映射作为它们的环境。

可以使用普通的 Map 操作来修改返回的对象。对于通过 start() 方法启动的子进程，这些修改是可见的。两个 ProcessBuilder 实例总是包含独立的进程环境，因此，针对返回的映射的更改从不会在任何其他 ProcessBuilder 实例或由 System.getenv 返回的值中反映出来。

如果系统不支持环境变量，将返回空映射。

返回的映射不允许空键或空值。试图插入空键或空值或者试图查询它们的存在，都将抛出 NullPointerException。试图查询非 String 类型的键或值的存在，都将抛出 ClassCastException。

返回的映射的行为取决于系统。系统可能不允许修改环境变量或禁止某些变量名或变量值。出于此原因，如果不允许操作系统修改的话，试图修改映射可能失败，并抛出 UnsupportedOperationException 或 IllegalArgumentException。

由于环境变量名和值的外部格式取决于系统，在它们与 Java 的 Unicode 字符串之间不可能是一对一映射。此外，映射以这种方式实现：不能由 Java 代码修改的环境变量在子进程中将有一个不可修改的本机表示形式。

返回的映射及其集合视图不能遵守 Object.equals(java.lang.Object) 和 Object.hashCode() 方法的常规协定。

返回的映射通常在所有平台上都是区分大小写的。

如果安全管理器存在，则其 checkPermission 方法通过 RuntimePermission("getenv.*") 权限进行调用。这可能导致抛出 SecurityException。

当将信息传递给 Java 子进程时，系统属性通常优先于环境变量。

返回：
此进程生成器的环境
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许访问进程环境
另请参见：
Runtime.exec(String[],String[],java.io.File), System.getenv()

directory

public File directory()
返回此进程生成器的工作目录。由此对象的 start() 方法启动的后续子进程将使用此目录作为它们的工作目录。返回值可以为 null，这意味着要使用当前 Java 进程的工作目录，通常是由系统属性 user.dir 指定的目录作为子进程的工作目录。

返回：
此进程生成器的工作目录

directory

public ProcessBuilder directory(File directory)
设置此进程生成器的工作目录。 由此对象的 start() 方法启动的后续子进程将使用此目录作为它们的工作目录。参数可以为 null，这意味着要使用当前 Java 进程的工作目录，通常是由系统属性 user.dir 指定的目录作为子进程的工作目录。

参数：
directory - 新的工作目录
返回：
此进程生成器

redirectErrorStream

public boolean redirectErrorStream()
通知进程生成器是否合并标准错误和标准输出。

如果此属性为 true，则任何由通过此对象的 start() 方法启动的后续子进程生成的错误输出都将与标准输出合并，因此两者均可使用 Process.getInputStream() 方法读取。这使得关联错误消息和相应的输出变得更容易。初始值为 false。

返回：
此进程生成器的 redirectErrorStream 属性

redirectErrorStream

public ProcessBuilder redirectErrorStream(boolean redirectErrorStream)
设置此进程生成器的 redirectErrorStream 属性。

如果此属性为 true，则任何由通过此对象的 start() 方法启动的后续子进程生成的错误输出都将与标准输出合并，因此两者均可使用 Process.getInputStream() 方法读取。这使得关联错误消息和相应的输出变得更容易。初始值为 false。

参数：
redirectErrorStream - 新的属性值
返回：
此进程生成器

start

public Process start()
              throws IOException
使用此进程生成器的属性启动一个新进程。

在 directory() 指定的工作目录中，利用 environment() 指定的进程环境，新进程将调用由 command() 给出的命令和参数。

此方法检查命令是否为一条有效的操作系统命令。哪条命令是有效的呢？这取决于系统，但至少命令必须是非空字符串的非空列表。

如果有安全管理器，则用此对象的 command 数组的首个元素作为其参数来调用安全管理器的 checkExec 方法。这可能导致抛出 SecurityException。

启动操作系统进程的方式完全取决于系统。其中有很多方面会导致错误：

  • 未找到操作系统程序文件。
  • 对程序文件的访问被拒绝。
  • 工作目录不存在。

在这些情况中将会抛出一个异常。该异常的具体本质取决于系统，但它总是 IOException 的一个子类。

针对此进程生成器的后续修改将不会影响返回的 Process。

返回：
一个新的 Process 对象，用于管理子进程
抛出：
NullPointerException - 如果命令列表的元素为空
IndexOutOfBoundsException - 如果命令是一个空列表（大小为 0）
SecurityException - 如果安全管理器存在并且其 checkExec 方法不允许创建子进程
IOException - 如果发生 I/O 错误
另请参见：
Runtime.exec(String[], String[], java.io.File), SecurityManager.checkExec(String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Readable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 Readable

所有已知实现类：
BufferedReader, CharArrayReader, CharBuffer, FileReader, FilterReader, InputStreamReader, LineNumberReader, PipedReader, PushbackReader, Reader, StringReader
public interface Readable

Readable 是一个字符源。阅读方法的调用方能够通过 CharBuffer 使用 Readable 中的字符。

从以下版本开始：
1.5

方法摘要
 int read(CharBuffer cb)
试图将字符读入指定的字符缓冲区。

方法详细信息

read

int read(CharBuffer cb)
         throws IOException
试图将字符读入指定的字符缓冲区。缓冲区可用作类似以下字符的存储库：所做的唯一改变是 put 操作的结果。不对缓冲区进行翻转或重绕操作。

参数：
cb - 将要读入字符的缓冲区
返回：
添加到缓冲区的 char 值的数量，如果此字符源位于缓冲区末端，则返回 -1
抛出：
IOException - 如果发生 I/O 错误
NullPointerException - 如果 cb 为空
ReadOnlyBufferException - 如果 cb 是一个只读缓冲区
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Runnable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 Runnable

所有已知子接口：
RunnableFuture<V>, RunnableScheduledFuture<V>
所有已知实现类：
AsyncBoxView.ChildState, FutureTask, RenderableImageProducer, SwingWorker, Thread, TimerTask
public interface Runnable

Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。类必须定义一个称为 run 的无参数方法。

设计该接口的目的是为希望在活动时执行代码的对象提供一个公共协议。例如，Thread 类实现了 Runnable。激活的意思是说某个线程已启动并且尚未停止。

此外，Runnable 为非 Thread 子类的类提供了一种激活方式。通过实例化某个 Thread 实例并将自身作为运行目标，就可以运行实现 Runnable 的类而无需创建 Thread 的子类。大多数情况下，如果只想重写 run() 方法，而不重写其他 Thread 方法，那么应使用 Runnable 接口。这很重要，因为除非程序员打算修改或增强类的基本行为，否则不应为该类创建子类。

从以下版本开始：
JDK1.0
另请参见：
Thread, Callable

方法摘要
 void run()
使用实现接口 Runnable 的对象创建一个线程时，启动该线程将导致在独立执行的线程中调用对象的 run 方法。

方法详细信息

run

void run()
使用实现接口 Runnable 的对象创建一个线程时，启动该线程将导致在独立执行的线程中调用对象的 run 方法。

方法 run 的常规协定是，它可能执行任何所需的动作。

另请参见：
Thread.run()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Runtime (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Runtime

java.lang.Object
    继承者  java.lang.Runtime

public class Runtime
extends Object

每个 Java 应用程序都有一个 Runtime 类实例，使应用程序能够与其运行的环境相连接。可以通过 getRuntime 方法获取当前运行时。

应用程序不能创建自己的 Runtime 类实例。

从以下版本开始：
JDK1.0
另请参见：
getRuntime()

方法摘要
void | addShutdownHook(Thread hook) 注册新的虚拟机来关闭钩子。
int | availableProcessors() 向 Java 虚拟机返回可用处理器的数目。
Process | exec(String command) 在单独的进程中执行指定的字符串命令。
Process | exec(String[] cmdarray) 在单独的进程中执行指定命令和变量。
Process | exec(String[] cmdarray, String[] envp) 在指定环境的独立进程中执行指定命令和变量。
Process | exec(String[] cmdarray, String[] envp, File dir) 在指定环境和工作目录的独立进程中执行指定的命令和变量。
Process | exec(String command, String[] envp) 在指定环境的单独进程中执行指定的字符串命令。
Process | exec(String command, String[] envp, File dir) 在有指定环境和工作目录的独立进程中执行指定的字符串命令。
void | exit(int status) 通过启动虚拟机的关闭序列，终止当前正在运行的 Java 虚拟机。
long | freeMemory() 返回 Java 虚拟机中的空闲内存量。
void | gc() 运行垃圾回收器。
InputStream | getLocalizedInputStream(InputStream in) 已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
OutputStream | getLocalizedOutputStream(OutputStream out) 已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
static Runtime | getRuntime() 返回与当前 Java 应用程序相关的运行时对象。
void | halt(int status) 强行终止目前正在运行的 Java 虚拟机。
void | load(String filename) 加载作为动态库的指定文件名。
void | loadLibrary(String libname) 加载具有指定库名的动态库。
long | maxMemory() 返回 Java 虚拟机试图使用的最大内存量。
boolean | removeShutdownHook(Thread hook) 取消注册某个先前已注册的虚拟机关闭钩子。
void | runFinalization() 运行挂起 finalization 的所有对象的终止方法。
static void | runFinalizersOnExit(boolean value) 已过时。 此方法本身具有不安全性。它可能对正在使用的对象调用终结方法，而其他线程正在操作这些对象，从而导致不正确的行为或死锁。
long | totalMemory() 返回 Java 虚拟机中的内存总量。
void | traceInstructions(boolean on) 启用／禁用指令跟踪。
void | traceMethodCalls(boolean on) 启用／禁用方法调用跟踪。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getRuntime

public static Runtime getRuntime()
返回与当前 Java 应用程序相关的运行时对象。Runtime 类的大多数方法是实例方法，并且必须根据当前的运行时对象对其进行调用。

返回：
与当前 Java 应用程序相关的 Runtime 对象。

exit

public void exit(int status)
通过启动虚拟机的关闭序列，终止当前正在运行的 Java 虚拟机。此方法从不正常返回。可以将变量作为一个状态码；根据惯例，非零的状态码表示非正常终止。

虚拟机的关闭序列包含两个阶段。在第一个阶段中，会以某种未指定的顺序启动所有已注册的关闭钩子 (hook)（如果有的话），并且允许它们同时运行直至结束。在第二个阶段中，如果已启用退出终结，则运行所有未调用的终结方法。一旦完成这个阶段，虚拟机就会暂停。

如果在虚拟机已开始其关闭序列后才调用此方法，那么若正在运行关闭钩子，则将无限期地阻断此方法。如果已经运行完关闭钩子，并且已启用退出终结 (on-exit finalization)，那么此方法将利用给定的状态码（如果状态码是非零值）暂停虚拟机；否则将无限期地阻断虚拟机。

System.exit 方法是调用此方法的一种传统而便捷的方式。

参数：
status - 终止状态。按照惯例，非零的状态码表明非正常终止。
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExit 方法不允许存在指定的状态
另请参见：
SecurityException,
SecurityManager.checkExit(int),
addShutdownHook(java.lang.Thread),
removeShutdownHook(java.lang.Thread),
runFinalizersOnExit(boolean),
halt(int)

addShutdownHook

public void addShutdownHook(Thread hook)
注册新的虚拟机来关闭钩子。

Java 虚拟机会为了响应以下两类事件而关闭：

  • 程序正常退出，这发生在最后的非守护线程退出时，或者在调用 exit（等同于 System.exit）方法时。或者，

  • 为响应用户中断而终止 虚拟机，如键入 ^C；或发生系统事件，比如用户注销或系统关闭。

关闭钩子 只是一个已初始化但尚未启动的线程。虚拟机开始启用其关闭序列时，它会以某种未指定的顺序启动所有已注册的关闭钩子，并让它们同时运行。运行完所有的钩子后，如果已启用退出终结，那么虚拟机接着会运行所有未调用的终结方法。最后，虚拟机会暂停。注意，关闭序列期间会继续运行守护线程，如果通过调用 exit 方法来发起关闭序列，那么也会继续运行非守护线程。

一旦开始了关闭序列，则只能通过调用 halt 方法来停止这个序列，此方法可强行终止虚拟机。

一旦开始了关闭序列，则不可能注册新的关闭钩子或取消注册先前已注册的钩子。尝试执行这些操作会导致抛出 IllegalStateException。

关闭钩子可在虚拟机生命周期中的特定时间运行，因此应保护性地对其进行编码。特别是应将关闭钩子编写为线程安全的，并尽可能地避免死锁。关闭钩子还应该不盲目地依靠某些服务，这些服务可能已注册了自己的关闭钩子，所以其本身可能正处于关闭进程中。例如，试图使用其他基于线程的服务（如 AWT 事件指派线程）可能导致死锁。

关闭钩子应该快速地完成其工作。当程序调用 exit 时，虚拟机应该迅速地关闭并退出。由于用户注销或系统关闭而终止虚拟机时，底层的操作系统可能只允许在固定的时间内关闭并退出。因此在关闭钩子中尝试进行任何用户交互或执行长时间的计算都是不明智的。

与其他所有线程一样，通过调用线程 ThreadGroup 对象的 uncaughtException 方法，可在关闭钩子中处理未捕获的异常。此方法的默认实现是将该异常的堆栈跟踪打印至 System.err 并终止线程；它不会导致虚拟机退出或暂停。

仅在很少的情况下，虚拟机可能会中止，也就是没有完全关闭就停止运行。虚拟机被外部终止时会出现这种现象，比如在 Unix 上使用 SIGKILL 信号或者在 Microsoft Windows 上调用 TerminateProcess。如果由于内部数据结构损坏或试图访问不存在的内存而导致本机方法执行错误，那么可能也会中止虚拟机。如果虚拟机中止，则无法保证是否将运行关闭钩子。

参数：
hook - 一个已初始化但尚未启动的 Thread 对象
抛出：
IllegalArgumentException - 如果指定的钩子已注册，或者可以确定钩子正在运行或者已运行完毕
IllegalStateException - 如果虚拟机已经处于关闭进程中
SecurityException - 如果安全管理器存在并且拒绝 RuntimePermission("shutdownHooks")
从以下版本开始：
1.3
另请参见：
removeShutdownHook(java.lang.Thread), halt(int), exit(int)

removeShutdownHook

public boolean removeShutdownHook(Thread hook)
取消注册某个先前已注册的虚拟机关闭钩子。

参数：
hook - 要删除的钩子
返回：
如果指定的钩子先前已注册并且成功地取消注册，则返回 true，其他情况返回 false。
抛出：
IllegalStateException - 如果虚拟机已经处于关闭进程中
SecurityException - 如果安全管理器存在并且拒绝 RuntimePermission("shutdownHooks")
从以下版本开始：
1.3
另请参见：
addShutdownHook(java.lang.Thread), exit(int)

halt

public void halt(int status)
强行终止目前正在运行的 Java 虚拟机。此方法从不正常返回。

应小心使用此方法。与 exit 方法不同，此方法不会启动关闭钩子，并且如果已启用退出终结，此方法也不会运行未调用的终结方法。如果已经发起关闭序列，那么此方法不会等待所有正在运行的关闭钩子或终结方法完成其工作。

参数：
status - 终止状态。按照惯例，非零的状态码表明非正常终止。如果已经调用了 exit（System.exit 也一样）方法，那么该状态码将重写已传递至此方法的状态码。
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExit 方法不允许具有指定状态时退出
从以下版本开始：
1.3
另请参见：
exit(int), addShutdownHook(java.lang.Thread), removeShutdownHook(java.lang.Thread)

runFinalizersOnExit

@Deprecated
public static void runFinalizersOnExit(boolean value)
已过时。 此方法本身具有不安全性。它可能对正在使用的对象调用终结方法，而其他线程正在操作这些对象，从而导致不正确的行为或死锁。

在退出时启用或禁用终结；这样做可指定拥有未被自动调用终结方法的所有对象的终结方法，并将在退出 Java 运行时前运行此终结方法。默认情况下，禁用退出终结。

如果有安全管理器，则首先使用 0 作为变量来调用其 checkExit 方法，以确保允许退出。这可能会导致 SecurityException。

参数：
value - 如果启用退出时终结，则该参数为 true，如果禁用退出时终结，则该参数为 false
抛出：
SecurityException - 如果安全管理器存在并且其 checkExit 方法不允许退出。
从以下版本开始：
JDK1.1
另请参见：
exit(int), gc(), SecurityManager.checkExit(int)

exec

public Process exec(String command)
             throws IOException
在单独的进程中执行指定的字符串命令。

这是一个很有用的方法。对于 exec(command) 形式的调用而言，其行为与调用 exec(command, null, null) 完全相同。

参数：
command - 一条指定的系统命令。
返回：
一个新的 Process 对象，用于管理子进程
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExec 方法不允许创建子进程
IOException - 如果发生 I/O 错误
NullPointerException - 如果 command 为 null
IllegalArgumentException - 如果 command 为空
另请参见：
exec(String[], String[], File), ProcessBuilder

exec

public Process exec(String command,
                    String[] envp)
             throws IOException
在指定环境的单独进程中执行指定的字符串命令。

这是一个很有用的方法。对于 exec(command, envp) 形式的调用而言，其行为与调用 exec(command, envp, null) 完全相同。

参数：
command - 一条指定的系统命令。
envp - 字符串数组，其中每个元素的环境变量的设置格式为 name=value；如果子进程应该继承当前进程的环境，或该参数为 null。
返回：
一个新的 Process 对象，用于管理子进程
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExec 方法不允许创建子进程
IOException - 如果发生 I/O 错误
NullPointerException - 如果 command 为 null，或 envp 的元素之一为 null
IllegalArgumentException - 如果 command 为空
另请参见：
exec(String[], String[], File), ProcessBuilder

exec

public Process exec(String command,
                    String[] envp,
                    File dir)
             throws IOException
在有指定环境和工作目录的独立进程中执行指定的字符串命令。

这是一个很有用的方法。对于 exec(command, envp, dir) 形式的调用而言，其行为与调用 exec(cmdarray, envp, dir) 完全相同，其中 cmdarray 是 command 中所有标记的数组。

更准确地说，可以使用通过调用 new StringTokenizer(command) 创建的 StringTokenizer 将 command 字符串拆解成标记，调用时不对字符类别做进一步的修改。然后将标记生成器所生成的标记以相同的顺序放入新的字符串数组 cmdarray 中。

参数：
command - 一条指定的系统命令。
envp - 字符串数组，其中每个元素的环境变量的设置格式为 name=value；如果子进程应该继承当前进程的环境，或该参数为 null。
dir - 子进程的工作目录；如果子进程应该继承当前进程的工作目录，则该参数为 null。
返回：
一个新的 Process 对象，用于管理子进程
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExec 方法不允许创建子进程
IOException - 如果发生 I/O 错误
NullPointerException - 如果 command 为 null，或者 envp 的某个元素为 null
IllegalArgumentException - 如果 command 为空
从以下版本开始：
1.3
另请参见：
ProcessBuilder

exec

public Process exec(String[] cmdarray)
             throws IOException
在单独的进程中执行指定命令和变量。

这是一个很有用的方法。对于 exec(cmdarray) 形式的调用而言，其行为与调用 exec(cmdarray, null, null) 完全相同。

参数：
cmdarray - 包含所调用命令及其参数的数组。
返回：
一个新的 Process 对象，用于管理子进程
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExec 方法不允许创建子进程
IOException - 如果发生 I/O 错误
NullPointerException - 如果 cmdarray 为 null，或者 cmdarray 的某个元素为 null
IndexOutOfBoundsException - 如果 cmdarray 是一个空数组（长度为 0）
另请参见：
ProcessBuilder

exec

public Process exec(String[] cmdarray,
                    String[] envp)
             throws IOException
在指定环境的独立进程中执行指定命令和变量。

这是一个很有用的方法。对于 exec(cmdarray, envp) 形式的调用而言，其行为与调用 exec(cmdarray, envp, null) 完全相同。

参数：
cmdarray - 包含所调用命令及其参数的数组。
envp - 字符串数组，其中每个元素的环境变量的设置格式为 name=value；如果子进程应该继承当前进程的环境，或该参数为 null。
返回：
一个新的 Process 对象，用于管理子进程
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExec 方法不允许创建子进程
IOException - 如果发生 I/O 错误
NullPointerException - 如果 cmdarray 为 null，或者 cmdarray 的某个元素为 null，或者 envp 的某个元素为 null
IndexOutOfBoundsException - 如果 cmdarray 是一个空数组（长度为 0）
另请参见：
ProcessBuilder

exec

public Process exec(String[] cmdarray,
                    String[] envp,
                    File dir)
             throws IOException
在指定环境和工作目录的独立进程中执行指定的命令和变量。

给定的字符串数组 cmdarray 表示一个命令行标记，字符串数组 envp 则表示“环境”变量设置，此方法会创建一个新进程，而指定的命令就在这个进程中执行。

此方法检查 cmdarray 是否是一条有效的操作系统命令。哪些命令有效取决于系统，但是该命令至少必须有一个非 null 字符串的非空列表。

如果 envp 为 null，那么子进程会继承当前进程的环境设置。

ProcessBuilder.start() 现在是启用一个具有已修改环境的进程的首选方法。

dir 指定了新子进程的工作目录。如果 dir 为 null，那么子进程会继承当前进程的当前工作目录。

如果安全管理器存在，则用数组 cmdarray 的第一个元素作为变量来调用安全管理器的 checkExec 方法。这可能导致抛出 SecurityException。

启动操作系统进程的方式完全取决于系统。其中有很多方面会导致错误：

  • 未找到操作系统程序文件。
  • 对程序文件的访问被拒绝。
  • 工作目录不存在。

这些情况都会抛出一个异常。该异常的具体特性取决于系统，但它总是 IOException 的一个子类。

参数：
cmdarray - 包含所调用命令及其参数的数组。
envp - 字符串数组，其中每个元素的环境变量的设置格式为 name=value，如果子进程应该继承当前进程的环境，或该参数为 null。
dir - 子进程的工作目录；如果子进程应该继承当前进程的工作目录，则该参数为 null。
返回：
一个新的 Process 对象，用于管理子进程
抛出：
SecurityException - 如果安全管理器存在，并且其 checkExec 方法不允许创建子进程
IOException - 如果发生 I/O 错误
NullPointerException - 如果 cmdarray 为 null，或者 cmdarray 的某个元素为 null，抑或 envp 的某个元素为 null
IndexOutOfBoundsException - 如果 cmdarray 是一个空数组（长度为 0）
从以下版本开始：
1.3
另请参见：
ProcessBuilder

availableProcessors

public int availableProcessors()
向 Java 虚拟机返回可用处理器的数目。

该值在特定的虚拟机调用期间可能发生更改。因此，对可用处理器数目很敏感的应用程序应该不定期地轮询该属性，并相应地调整其资源用法。

返回：
虚拟机可用的最大处理器数目；从不小于 1
从以下版本开始：
1.4

freeMemory

public long freeMemory()
返回 Java 虚拟机中的空闲内存量。调用 gc 方法可能导致 freeMemory 返回值的增加。

返回：
供将来分配对象使用的当前可用内存的近似总量，以字节为单位。

totalMemory

public long totalMemory()
返回 Java 虚拟机中的内存总量。此方法返回的值可能随时间的推移而变化，这取决于主机环境。

注意，保存任意给定类型的一个对象所需的内存量可能取决于实现方法。

返回：
目前为当前和后续对象提供的内存总量，以字节为单位。

maxMemory

public long maxMemory()
返回 Java 虚拟机试图使用的最大内存量。如果内存本身没有限制，则返回值 Long.MAX_VALUE。

返回：
虚拟机试图使用的最大内存量，以字节为单位。
从以下版本开始：
1.4

gc

public void gc()
运行垃圾回收器。调用此方法意味着 Java 虚拟机做了一些努力来回收未用对象，以便能够快速地重用这些对象当前占用的内存。当控制从方法调用中返回时，虚拟机已经尽最大努力回收了所有丢弃的对象。

名称 gc 代表“垃圾回收器”。虚拟机根据需要在单独的线程中自动执行回收过程，甚至不用显式调用 gc 方法。

方法 System.gc() 是调用此方法的一种传统而便捷的方式。

runFinalization

public void runFinalization()
运行挂起 finalization 的所有对象的终止方法。调用此方法意味着 Java 虚拟机做了一些努力运行已被丢弃对象的 finalize 方法，但是这些对象的 finalize 方法还没有运行。当控制从方法调用中返回时，Java 虚拟机已经尽最大努力去完成所有未执行的终止方法。

如果不显式调用 runFinalization 方法，则 Java 虚拟机会根据需要在单独的线程中自动执行此终止过程。

方法 System.runFinalization() 是调用此方法的一种传统而便捷的方式。

另请参见：
Object.finalize()

traceInstructions

public void traceInstructions(boolean on)
启用／禁用指令跟踪。如果 boolean 变量为 true，则执行此方法意味着让 Java 虚拟机发送虚拟机中每条指令执行的调试信息。该信息的格式，以及虚拟机所发送的文件或其他输出流的格式取决于主机的环境。如果虚拟机不支持此功能，则忽略这一请求。跟踪输出的目的地取决于系统。

如果 boolean 变量为 false，则执行此方法时将使 Java 虚拟机停止执行详细的指令跟踪。

参数：
on - 为 true 时启用指令跟踪；为 false 时则禁用此功能。

traceMethodCalls

public void traceMethodCalls(boolean on)
启用／禁用方法调用跟踪。如果 boolean 变量为 true，则执行此方法意味着让 Java 虚拟机发送虚拟机中每个方法的调试信息。该信息的格式，以及虚拟机所发送的文件或其他输出流的格式取决于主机的环境。如果虚拟机不支持此功能，则忽略这一请求。

使用变量 false 调用此方法意味着虚拟机停止发送每个调用的调试信息。

参数：
on - 为 true 时启用指令跟踪；为 false 时则禁用此功能。

load

public void load(String filename)
加载作为动态库的指定文件名。文件名变量必须是一个完整的路径名，（例如 Runtime.getRuntime().load("/home/avh/lib/libX11.so");）。

首先，如果有安全管理器，则用 filename 作为参数调用 checkLink 方法。这可能导致安全异常。

这与 loadLibrary(String) 方法类似，但它接受通用文件名作为变量，而不仅仅是库名，从而能够加载所有的本机代码文件。

方法 System.load(String) 是调用此方法的一种传统而便捷的方式。

参数：
filename - 要加载的文件。
抛出：
SecurityException - 如果安全管理器存在，并且其 checkLink 方法不允许加载指定的动态库
UnsatisfiedLinkError - 如果文件不存在。
NullPointerException - 如果 filename 为 null
另请参见：
getRuntime(), SecurityException, SecurityManager.checkLink(java.lang.String)

loadLibrary

public void loadLibrary(String libname)
加载具有指定库名的动态库。从以前获取库文件的本地文件系统中加载含有本机代码的文件。这一过程的细节取决于实现方法。可以以某种特定于系统的方式完成从库名到特定文件名的映射。

首先，如果有安全管理器，则用 libname 作为参数调用 checkLink 方法。这可能导致安全性异常。

方法 System.loadLibrary(String) 是调用此方法的一种传统而便捷的方式。如果在某个类实现中使用本机方法，则标准的策略是将本机代码放入一个库文件中（称为 LibFile），然后在类声明中放入一个静态的初始值设定项：

static { System.loadLibrary("LibFile"); }
当加载并初始化这个类时，也将加载实现本机方法所需的本机代码。

如果用相同库名多次调用此方法，则忽略第二次及后续的调用。

参数：
libname - 库名。
抛出：
SecurityException - 如果安全管理器存在，并且其 checkLink 方法不允许加载指定的动态库
UnsatisfiedLinkError - 如果库不存在。
NullPointerException - 如果 libname 为 null
另请参见：
SecurityException, SecurityManager.checkLink(java.lang.String)

getLocalizedInputStream

@Deprecated
public InputStream getLocalizedInputStream(InputStream in)
已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。

创建输入流的本地化版本。此方法获取 InputStream，并返回除本地化外其他所有方面都和变量等效的 InputStream，这些方面包括：作为本地字符集中的字符从流中被读取，并将它们从本地字符集自动转换为 Unicode。

如果参数已经是本地化流，则可作为结果返回。

参数：
in - 要本地化的 InputStream
返回：
已本地化的输入流
另请参见：
InputStream, BufferedReader.BufferedReader(java.io.Reader), InputStreamReader.InputStreamReader(java.io.InputStream)

getLocalizedOutputStream

@Deprecated
public OutputStream getLocalizedOutputStream(OutputStream out)
已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。

创建输出流的本地化版本。此方法获取 OutputStream，并返回除本地化外其他所有方面都和变量等效的 OutputStream，这些方面包括：作为 Unicode 字符被写入流中，并被自动转换为本地字符集。

如果参数已经是本地流，则可作为结果返回。

参数：
out - 要本地化的 OutputStream
返回：
已本地化的输出流
另请参见：
OutputStream,
BufferedWriter.BufferedWriter(java.io.Writer),
OutputStreamWriter.OutputStreamWriter(java.io.OutputStream),
PrintWriter.PrintWriter(java.io.OutputStream)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RuntimeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 RuntimeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
所有已实现的接口：
Serializable
直接已知子类：
AnnotationTypeMismatchException, ArithmeticException, ArrayStoreException, BufferOverflowException, BufferUnderflowException, CannotRedoException, CannotUndoException, ClassCastException, CMMException, ConcurrentModificationException, DOMException, EmptyStackException, EnumConstantNotPresentException, EventException, IllegalArgumentException, IllegalMonitorStateException, IllegalPathStateException, IllegalStateException, ImagingOpException, IncompleteAnnotationException, IndexOutOfBoundsException, JMRuntimeException, LSException, MalformedParameterizedTypeException, MirroredTypeException, MirroredTypesException, MissingResourceException, NegativeArraySizeException, NoSuchElementException, NoSuchMechanismException, NullPointerException, ProfileDataException, ProviderException, RasterFormatException, RejectedExecutionException, SecurityException, SystemException, TypeConstraintException, TypeNotPresentException, UndeclaredThrowableException, UnknownAnnotationValueException, UnknownElementException, UnknownTypeException, UnmodifiableSetException, UnsupportedOperationException, WebServiceException
public class RuntimeException
extends Exception

RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。

可能在执行方法期间抛出但未被捕获的 RuntimeException 的任何子类都无需在 throws 子句中进行声明。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
RuntimeException()
用 null 作为其详细消息构造一个新的运行时异常。
RuntimeException(String message)
用指定的详细消息构造一个新的运行时异常。
RuntimeException(String message, Throwable cause)
用指定的详细消息和原因构造一个新的运行时异常。
RuntimeException(Throwable cause)
用指定的原因和详细消息 (cause==null ? null :cause.toString()） 构造一个新的运行时异常（它通常包含类和 cause 的详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RuntimeException

public RuntimeException()
用 null 作为其详细消息构造一个新的运行时异常。原因尚未被初始化，可在以后通过调用 Throwable.initCause(java.lang.Throwable) 对其进行初始化。

RuntimeException

public RuntimeException(String message)
用指定的详细消息构造一个新的运行时异常。原因尚未被初始化，可在以后通过调用 Throwable.initCause(java.lang.Throwable) 对其进行初始化。

参数：
message - 详细消息。保存详细消息以便以后通过 Throwable.getMessage() 方法获取它。

RuntimeException

public RuntimeException(String message,
                        Throwable cause)
用指定的详细消息和原因构造一个新的运行时异常。

注意，与 cause 相关的详细消息不 会自动地合并到此运行时异常的详细消息中。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它)。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，这表明原因不存在或是未知的。）
从以下版本开始：
1.4

RuntimeException

public RuntimeException(Throwable cause)
用指定的原因和详细消息 (cause==null ? null :cause.toString()） 构造一个新的运行时异常（它通常包含类和 cause 的详细消息）。该构造方法对于那些与其他可抛出异常的包装器一样的运行时异常来说很有用。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，这表明原因不存在或是未知的。）
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RuntimePermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 RuntimePermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.lang.RuntimePermission
所有已实现的接口：
Serializable, Guard
public final class RuntimePermission
extends BasicPermission

该类用于运行时权限。RuntimePermission 包含一个名称（也称为“目标名称”），但不包含操作列表；您可以有或没有指定的权限。

目标名称是运行时权限的名称（参见下面内容）。命名约定遵守分层属性命名约定。另外，名称的末尾可能出现一个星号，星号前有一个“.”（也可能只有一个星号），用来表示通配符。例如：“loadLibrary.*”或“*”是有效的，而“*loadLibrary”或“a*b”则是无效的。

下表列出了所有可能的 RuntimePermission 目标名称，并提供了权限所允许的操作的简要说明，还讨论了授予代码该权限的风险。

权限目标名称 | 权限所允许的操作 | 允许此权限所带来的风险
createClassLoader | 创建类加载器 | 授予该权限极其危险。能够实例化自己的类加载器的恶意应用程序可能会在系统中装载自己的恶意类。这些新加载的类可能被类加载器置于任意保护域中，从而自动将该域的权限授予这些类。
getClassLoader | 类加载器的获取（即调用类的类加载器） | 这将授予攻击者得到具体类的加载器的权限。这很危险，由于攻击者能够访问类的类加载器，所以攻击者能够加载其他可用于该类加载器的类。通常攻击者不具备这些类的访问权限。
setContextClassLoader | 线程使用的上下文类加载器的设置 | 在需要查找可能不存在于系统类加载器中的资源时，系统代码和扩展部分会使用上下文类加载器。授予 setContextClassLoader 权限将允许代码改变特定线程（包括系统线程）使用的上下文类加载器。
enableContextClassLoaderOverride | 线程上下文类加载器方法的子类实现 | 在需要查找可能不存在于系统类加载器中的资源时，系统代码和扩展部分会使用上下文类加载器。授予 enableContextClassLoaderOverride 权限将允许线程的子类重写某些方法，这些方法用于得到或设置特定线程的上下文类加载器。
setSecurityManager | 设置安全管理器（可能会替换现有的） | 安全管理器是允许应用程序实现安全策略的类。授予 setSecurityManager 权限将通过安装一个不同的、可能限制更少的安全管理器，来允许代码改变所用的安全管理器，因此可跳过原有安全管理器所强制执行的某些检查。
createSecurityManager | 创建新的安全管理器 | 授予代码对受保护的、敏感方法的访问权，可能会泄露有关其他类或执行堆栈的信息。
getenv.{variable name} | 读取指定环境变量的值 | 此权限允许代码读取特定环境变量的值或确定它是否存在。如果该变量含有机密数据，则这项授权是很危险的。
exitVM.{exit status} | 暂停带有指定退出状态的 Java 虚拟机 | 此权限允许攻击者通过自动强制暂停虚拟机来发起一次拒绝服务攻击。注意：自动为那些从应用程序类路径加载的全部代码授予 "exitVM.*" 权限，从而使这些应用程序能够自行中止。此外，"exitVM" 权限等于 "exitVM.*"。
shutdownHooks | 虚拟机关闭钩子 (hook) 的注册与取消 | 此权限允许攻击者注册一个妨碍虚拟机正常关闭的恶意关闭钩子 (hook)。
setFactory | 设置由 ServerSocket 或 Socket 使用的套接字工厂，或 URL 使用的流处理程序工厂 | 此权限允许代码设置套接字、服务器套接字、流处理程序或 RMI 套接字工厂的实际实现。攻击者可能设置错误的实现，从而破坏数据流。
setIO | System.out、System.in 和 System.err 的设置 | 此权限允许改变标准系统流的值。攻击者可以改变 System.in 来监视和窃取用户输入，或将 System.err 设置为 "null" OutputStream，从而隐藏发送到 System.err 的所有错误信息。
modifyThread | 修改线程，例如通过调用线程的 interrupt、stop、suspend、resume、setDaemon、setPriority、setName 和 setUncaughtExceptionHandler 方法 | 此权限允许攻击者修改系统中任意线程的行为。
stopThread | 通过调用线程的 stop 方法停止线程 | 如果系统已授予代码访问该线程的权限，则此权限允许代码停止系统中的任何线程。此权限会造成一定的危险，因为该代码可能通过中止现有的线程来破坏系统。
modifyThreadGroup | 修改线程组，例如通过调用 ThreadGroup 的 destroy、getParent、resume、setDaemon、setMaxPriority、stop 和 suspend 方法 | 此权限允许攻击者创建线程组并设置它们的运行优先级。
getProtectionDomain | 获取类的 ProtectionDomain | 此权限允许代码获得特定代码源的安全策略信息。虽然获得安全策略信息并不足以危及系统安全，但这确实会给攻击者提供了能够更好地定位攻击目标的其他信息，例如本地文件名称等。
getFileSystemAttributes | 获取文件系统属性 | 此权限允许代码获得文件系统信息（如调用者可用的磁盘使用量或磁盘空间）。这存在潜在危险，因为它泄露了关于系统硬件配置的信息以及一些关于调用者写入文件特权的信息。
readFileDescriptor | 读取文件描述符 | 此权限允许代码读取与文件描述符读取相关的特定文件。如果该文件包含机密数据，则此操作非常危险。
writeFileDescriptor | 写入文件描述符 | 此权限允许代码写入与描述符相关的特定文件。此权限很危险，因为它可能允许恶意代码传播病毒，或者至少也会填满整个磁盘。
loadLibrary.{库名} | 动态链接指定的库 | 允许 applet 具有加载本机代码库的权限是危险的，因为 Java 安全架构并未设计成可以防止恶意行为，并且也无法在本机代码的级别上防止恶意行为。
accessClassInPackage.{包名} | 当类加载器调用 SecurityManager 的checkPackageAccess 方法时，通过类加载器的 loadClass 方法访问指定的包 | 此权限允许代码访问它们通常无法访问的那些包中的类。恶意代码可能利用这些类帮助它们实现破坏系统安全的企图。
defineClassInPackage.{包名} | 当类加载器调用 SecurityManager 的 checkPackageDefinition 方法时，通过类加载器的 defineClass 方法定义指定的包中的类。 | 此权限允许代码在特定包中定义类。这样做很危险，因为具有此权限的恶意代码可能在受信任的包中定义恶意类，比如 java.security 或 java.lang。
accessDeclaredMembers | 访问类的已声明成员 | 此权限允许代码查询类的公共、受保护、默认（包）访问和私有的字段和/或方法。尽管代码可以访问私有和受保护字段和方法名称，但它不能访问私有/受保护字段数据并且不能调用任何私有方法。此外，恶意代码可能使用该信息来更好地定位攻击目标。而且，它可以调用类中的任意公共方法和/或访问公共字段。如果代码不能用这些方法和字段将对象强制转换为类/接口，那么它通常无法调用这些方法和/或访问该字段，而这可能很危险。
queuePrintJob | 打印作业请求的开始 | 这可能向打印机输出敏感信息，或者只是浪费纸张。
getStackTrace | 获取另一个线程的堆栈追踪信息。 | 此权限允许获取另一个线程的堆栈追踪信息。此操作可能允许执行恶意代码监视线程并发现应用程序中的弱点。
setDefaultUncaughtExceptionHandler | 在线程由于未捕获的异常而突然终止时，设置将要使用的默认处理程序 | 此权限允许攻击者注册恶意的未捕获异常处理程序，可能会妨碍线程的终止
Preferences | 表示得到 java.util.prefs.Preferences 的访问权所需的权限。java.util.prefs.Preferences 实现了用户或系统的根，这反过来又允许获取或更新 Preferences 持久内部存储中的操作。 | 如果运行此代码的用户具有足够的读/写内部存储的 OS 特权，则此权限就允许用户读/写优先级内部存储。实际的内部存储可能位于传统的文件系统目录中或注册表中，这取决于平台 OS。

另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
RuntimePermission(String name)
创建具有指定名称的新 RuntimePermission。
RuntimePermission(String name, String actions)
创建具有指定名称的新 RuntimePermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

RuntimePermission

public RuntimePermission(String name)
创建具有指定名称的新 RuntimePermission。此名称是 RuntimePermission 的符号名，比如“exit”、“setFactory”等。名称的末尾可能出现一个星号，星号前有一个“.”（也可能只有一个星号），用来表示通配符。

参数：
name - RuntimePermission 的名称。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

RuntimePermission

public RuntimePermission(String name,
                         String actions)
创建具有指定名称的新 RuntimePermission 对象。此名称是 RuntimePermission 的符号名，而目前没有使用操作 String，所以它应该是 null。

参数：
name - RuntimePermission 的名称。
actions - 应该为 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecurityException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 SecurityException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.SecurityException
所有已实现的接口：
Serializable
直接已知子类：
AccessControlException, RMISecurityException
public class SecurityException
extends RuntimeException

由安全管理器抛出的异常，指示存在安全侵犯。

从以下版本开始：
JDK1.0
另请参见：
SecurityManager, 序列化表格

构造方法摘要
SecurityException()
构造不带详细消息的 SecurityException。
SecurityException(String s)
构造带指定详细消息的 SecurityException。
SecurityException(String message, Throwable cause)
创建带指定详细消息和原因的 SecurityException。
SecurityException(Throwable cause)
创建一个 SecurityException，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含该类和 cause 的详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SecurityException

public SecurityException()
构造不带详细消息的 SecurityException。

SecurityException

public SecurityException(String s)
构造带指定详细消息的 SecurityException。

参数：
s - 详细消息。

SecurityException

public SecurityException(String message,
                         Throwable cause)
创建带指定详细消息和原因的 SecurityException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，这表明原因不存在或是未知的。）
从以下版本开始：
1.5

SecurityException

public SecurityException(Throwable cause)
创建一个 SecurityException，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含该类和 cause 的详细消息）。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，这表明原因不存在或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecurityManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 SecurityManager

java.lang.Object
    继承者  java.lang.SecurityManager
直接已知子类：
RMISecurityManager
public class SecurityManager
extends Object

安全管理器是一个允许应用程序实现安全策略的类。它允许应用程序在执行一个可能不安全或敏感的操作前确定该操作是什么，以及是否是在允许执行该操作的安全上下文中执行它。应用程序可以允许或不允许该操作。

SecurityManager 类包含了很多名称以单词 check 开头的方法。Java 库中的各种方法在执行某些潜在的敏感操作前可以调用这些方法。对 check 方法的典型调用如下：

     SecurityManager security = System.getSecurityManager();
     if (security != null) {
         security.checkXXX(argument,  . . . );
     }

因此，安全管理器通过抛出异常来提供阻止操作完成的机会。如果允许执行该操作，则安全管理器例程只是简单地返回，但如果不允许执行该操作，则抛出一个 SecurityException。该约定的唯一例外是 checkTopLevelWindow，它返回 boolean 值。

当前的安全管理器由 System 类中的 setSecurityManager 方法设置。当前的安全管理器由 getSecurityManager 方法获得。

特殊方法 checkPermission(java.security.Permission) 确定是应该允许还是拒绝由指定权限所指示的访问请求。默认的实现调用

   AccessController.checkPermission(perm);

如果允许访问请求，则安静地返回 checkPermission。如果拒绝访问请求，则抛出 SecurityException。

从 Java 2 SDK v1.2 开始，SecurityManager 中其他所有 check 方法的默认实现都是调用 SecurityManager checkPermission 方法来确定调用线程是否具有执行所请求操作的权限。

注意，只带有单个权限参数的 checkPermission 方法总是在当前执行的线程上下文中执行安全检查。有时，应该在给定上下文中进行的安全检查实际上需要在不同 的上下文（例如，在一个辅助线程中）中进行。Java 为这种情况提供了包含有上下文参数的 getSecurityContext 方法和 checkPermission 方法。getSecurityContext 方法返回当前调用上下文的一个“快照”（默认的实现返回一个 AccessControlContext 对象）。下面是一个示例调用：

   Object context = null;
   SecurityManager sm = System.getSecurityManager();
   if (sm != null) context = sm.getSecurityContext();

checkPermission 方法使用一个上下文对象，以及根据该上下文而不是当前执行线程的上下文作出访问决策的权限。因此另一个上下文中的代码可以调用此方法，传递权限和以前保存的上下文对象。下面是一个示例调用，它使用了以前示例中获得的 SecurityManager sm：

   if (sm != null) sm.checkPermission(permission, context);

权限分为以下类别：文件、套接字、网络、安全性、运行时、属性、AWT、反射和可序列化。管理各种权限类别的类是 java.io.FilePermission、java.net.SocketPermission、java.net.NetPermission、java.security.SecurityPermission、java.lang.RuntimePermission、java.util.PropertyPermission、java.awt.AWTPermission、java.lang.reflect.ReflectPermission 和 java.io.SerializablePermission。

除前两个（FilePermission 和 SocketPermission）类以外的所有类都是 java.security.BasicPermission 的子类，而 java.security.BasicPermission 类又是顶级权限类 java.security.Permission 的抽象子类。BasicPermission 定义了所有权限所需的功能，这些功能的名称遵从分层属性命名惯例（例如“exitVM”、“setFactory”、“queuePrintJob”等等）。在名称的末尾可能出现一个星号，前面是“.”或星号，这表示通配符匹配。例如：“a.*”、“*”是有效的，而“*a”或“a*b”是无效的。

FilePermission 和 SocketPermission 是顶级权限类 (java.security.Permission) 的子类。像这些命名语法比 BasicPermission 所用的语法更为复杂的类都直接是 Permission 的子类，而不是 BasicPermission 的子类。例如，对于 java.io.FilePermission 对象而言，权限名就是文件（或目录）的路径名。

某些权限类具有一个“动作”列表，告知允许对象所执行的动作。例如，对于 java.io.FilePermission 对象，动作列表（如“读、写”）指定了允许对指定文件（或指定目录中的文件）执行哪些动作。

其他权限类是“指定的”权限 - 有名称但没有动作列表的类；您也许有指定的权限，也许没有。

注：还有一个暗指所有权限的 java.security.AllPermission 权限。该权限是为了简化系统管理员的工作而存在的，因为管理员可能需要执行很多需要所有（或许多）权限的任务。

有关权限相关的信息，请参阅 。例如，本文档包括一个列出各种 SecurityManager 的 check 方法和每个方法的默认实现所需的权限表。它还包含了版本 1.2 方法所需权限和每个方法需要哪些权限的表。

有关 JDK 中对 SecurityManager 所作更改的更多信息和关于 1.1 风格安全管理器移植的建议，请参阅 security documentation。

从以下版本开始：
JDK1.0
另请参见：
ClassLoader, SecurityException, checkTopLevelWindow, getSecurityManager, setSecurityManager, AccessController, AccessControlContext, AccessControlException, Permission, BasicPermission, FilePermission, SocketPermission, PropertyPermission, RuntimePermission, AWTPermission, Policy, SecurityPermission, ProtectionDomain

字段摘要
protected  boolean inCheck
已过时。 建议不使用该类型的安全检查。建议使用 checkPermission 调用。
构造方法摘要
SecurityManager()
构造一个新的 SecurityManager。
方法摘要
 void checkAccept(String host, int port)
如果不允许调用线程从指定的主机和端口号接受套接字连接，则抛出 SecurityException。
 void checkAccess(Thread t)
如果不允许调用线程修改 thread 参数，则抛出 SecurityException。
 void checkAccess(ThreadGroup g)
如果不允许调用线程修改线程组参数，则抛出 SecurityException。
 void checkAwtEventQueueAccess()
如果不允许调用线程访问 AWT 事件队列，则抛出 SecurityException。
 void checkConnect(String host, int port)
如果不允许调用线程打开到指定主机和端口号的套接字连接，则抛出 SecurityException。
 void checkConnect(String host, int port, Object context)
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。
 void checkCreateClassLoader()
如果不允许调用线程创建新的类加载器，则抛出 SecurityException。
 void checkDelete(String file)
如果不允许调用线程删除指定的文件，则抛出 SecurityException。
 void checkExec(String cmd)
如果不允许调用线程创建一个子进程，则抛出 SecurityException。
 void checkExit(int status)
如果不允许调用线程使用特定的状态码暂停 Java 虚拟机，则抛出 SecurityException。
 void checkLink(String lib)
如果不允许调用线程动态链接由字符串参数文件指定的库代码，则抛出 SecurityException。
 void checkListen(int port)
如果不允许调用线程等待与指定本地端口号进行连接的请求，则抛出 SecurityException。
 void checkMemberAccess(Class<?> clazz, int which)
如果不允许调用线程访问程序，则抛出 SecurityException。
 void checkMulticast(InetAddress maddr)
如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播，则抛出 SecurityException。
 void checkMulticast(InetAddress maddr, byte ttl)
已过时。 由 #checkPermission(java.security.Permission) 取代
 void checkPackageAccess(String pkg)
如果不允许调用线程访问由参数指定的包，则抛出 SecurityException。
 void checkPackageDefinition(String pkg)
如果不允许调用线程在参数指定的包中定义类，则抛出 SecurityException。
 void checkPermission(Permission perm)
如果基于当前有效的安全策略，不允许执行根据给定权限所指定的请求访问，则抛出 SecurityException。
 void checkPermission(Permission perm, Object context)
如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。
 void checkPrintJobAccess()
如果不允许调用线程发起一个打印作业请求，则抛出 SecurityException。
 void checkPropertiesAccess()
如果不允许调用线程访问或修改系统属性，则抛出 SecurityException。
 void checkPropertyAccess(String key)
如果不允许调用线程访问具有指定的 key 名的系统属性，则抛出 SecurityException。
 void checkRead(FileDescriptor fd)
如果不允许调用线程从指定的文件描述符进行读取，则抛出 SecurityException。
 void checkRead(String file)
如果不允许调用线程读取由字符串参数指定的文件，则抛出 SecurityException。
 void checkRead(String file, Object context)
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。
 void checkSecurityAccess(String target)
确定是应该允许还是拒绝具有指定权限目标名的权限。
 void checkSetFactory()
如果不允许调用线程设置由 ServerSocket 或 Socket 使用的套接字工厂，或者由 URL 使用的流处理程序工厂，则抛出 SecurityException。
 void checkSystemClipboardAccess()
如果不允许调用线程访问系统剪贴板，则抛出 SecurityException。
 boolean checkTopLevelWindow(Object window)
如果不受信任的调用线程调出由 window 参数指出的顶层窗口，则返回 false。
 void checkWrite(FileDescriptor fd)
如果不允许调用线程写入指定的文件描述符，则抛出 SecurityException。
 void checkWrite(String file)
如果不允许调用线程写由字符串参数指定的文件，则抛出 SecurityException。
protected  int classDepth(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  int classLoaderDepth()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  ClassLoader currentClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class<?> currentLoadedClass()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class[] getClassContext()
以类数组的形式返回当前执行堆栈。
 boolean getInCheck()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
 Object getSecurityContext()
创建一个封装当前执行环境的对象。
 ThreadGroup getThreadGroup()
调用此方法时，返回所有新创建的线程实例化后所在的线程组。
protected  boolean inClass(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  boolean inClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

inCheck

@Deprecated
protected boolean inCheck
已过时。 建议不使用该类型的安全检查。建议使用 checkPermission 调用。
如果安全检查正在进行，则该字段为 true；否则为 false。

构造方法详细信息

SecurityManager

public SecurityManager()
构造一个新的 SecurityManager。

如果已经安装了一个安全管理器，则此方法首先用 RuntimePermission("createSecurityManager") 权限调用此安全管理器的 checkPermission 方法，确保调用线程具有创建新安全管理器的权限。这可能导致抛出 SecurityException。

抛出：
SecurityException - 如果安全管理器已存在，并且其 checkPermission 方法不允许创建新安全管理器。
另请参见：
System.getSecurityManager(), checkPermission, RuntimePermission
方法详细信息

getInCheck

@Deprecated
public boolean getInCheck()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

测试安全检查是否正在进行。

返回：
inCheck 字段的值。如果安全检查正在进行，则该字段应该为 true，否则应该为 false。
另请参见：
inCheck

getClassContext

protected Class[] getClassContext()
以类数组的形式返回当前执行堆栈。

数组的长度是执行堆栈中的方法数。索引 0 指定的元素是当前执行方法的类，索引 1 指定的元素是该方法调用方的类，依此类推。

返回：
执行堆栈。

currentClassLoader

@Deprecated
protected ClassLoader currentClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

返回最近执行的、使用非系统类加载器定义的类方法的类加载器。非系统类加载器被定义为一种不同于系统类加载器（由 ClassLoader.getSystemClassLoader() 返回）或其祖先之一的类加载器。

在以下三种情况中，此方法将返回 null：

  1. 执行堆栈中的所有方法都来自于使用系统类加载器或其祖先之一所定义的类。
  2. 在执行堆栈中，直到第一个“特权”调用方（参见 AccessController.doPrivileged(java.security.PrivilegedAction)）为止的所有方法都来自于使用系统类加载器或其祖先之一所定义的类。
  3. 使用 java.security.AllPermission 调用 checkPermission 不会导致 SecurityException。

返回：
最近执行的、使用非系统类加载器定义的类方法堆栈中的类加载器。
另请参见：
getSystemClassLoader, checkPermission

currentLoadedClass

@Deprecated
protected Class<?> currentLoadedClass()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

返回最近执行的、使用非系统类加载器定义的类方法的类。非系统类加载器被定义为一种不同于系统类加载器（由 ClassLoader.getSystemClassLoader() 返回）或其祖先之一的类加载器。

在以下三种情况中，此方法将返回 null：

  1. 执行堆栈中的所有方法都来自于使用系统类加载器或其祖先之一所定义的类。
  2. 在执行堆栈中，直到第一个“特权”调用方（参见 AccessController.doPrivileged(java.security.PrivilegedAction)）为止的所有方法都来自于使用系统类加载器或其祖先之一所定义的类。
  3. 使用 java.security.AllPermission 调用 checkPermission 不会导致 SecurityException。

返回：
最近出现的、使用非系统类加载器定义的类方法堆栈中的类。
另请参见：
getSystemClassLoader, checkPermission

classDepth

@Deprecated
protected int classDepth(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

返回指定类的堆栈深度。

参数：
name - 要查找的类的完全限定名。
返回：
在指定名称的类中第一个方法出现的堆栈帧深度；如未找到这样的帧，则返回 -1。

classLoaderDepth

@Deprecated
protected int classLoaderDepth()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

返回最近执行的、使用非系统类加载器定义的类方法的堆栈深度。非系统类加载器被定义为一种不同于系统类加载器（由 ClassLoader.getSystemClassLoader() 返回）或其祖先之一的类加载器。

在以下三种情况中，此方法将返回 -1：

  1. 执行堆栈中的所有方法都来自于使用系统类加载器或其祖先之一所定义的类。
  2. 在执行堆栈中，直到第一个“特权”调用方（参见 AccessController.doPrivileged(java.security.PrivilegedAction)）为止的所有方法都来自于使用系统类加载器或其祖先之一所定义的类。
  3. 使用 java.security.AllPermission 调用 checkPermission 不会导致 SecurityException。

返回：
最近出现的、使用非系统类加载器定义的类方法的堆栈帧深度。
另请参见：
getSystemClassLoader, checkPermission

inClass

@Deprecated
protected boolean inClass(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

测试具有指定名称的类方法是否处于执行堆栈中。

参数：
name - 该类的完全限定名。
返回：
如果具有指定名称的类方法处于执行堆栈中，则返回 true；否则返回 false。

inClassLoader

@Deprecated
protected boolean inClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

主要是测试某个使用类加载器定义的类方法是否处于执行堆栈中。

返回：
如果调用 currentClassLoader 具有非 null 的返回值，则返回 true。
另请参见：
currentClassLoader

getSecurityContext

public Object getSecurityContext()
创建一个封装当前执行环境的对象。例如，此方法的结果由带有三参数的 checkConnect 方法和带有两参数的 checkRead 方法使用。这些方法是必需的，因为一个受信任的方法可能代表另一方法被调用，以读取一个文件或打开一个套接字。受信任的方法需要确定是否允许另一个方法（可能不受信任）独自执行该操作。

此方法的默认实现是返回 AccessControlContext 对象。

返回：
一个取决于实现的对象，该对象封装了有关当前执行环境的足够信息，这些信息用于稍后执行某些安全检查。
另请参见：
checkConnect, checkRead, AccessControlContext

checkPermission

public void checkPermission(Permission perm)
如果基于当前有效的安全策略，不允许执行根据给定权限所指定的请求访问，则抛出 SecurityException。

此方法使用给定的权限调用 AccessController.checkPermission。

参数：
perm - 请求的权限。
抛出：
SecurityException - 如果根据当前的安全策略不允许进行访问。
NullPointerException - 如果 permission 参数为 null。
从以下版本开始：
1.2

checkPermission

public void checkPermission(Permission perm,
                            Object context)
如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。该上下文必须是一个通过以前调用 getSecurityContext 所返回的安全上下文，并且应该根据为该安全上下文所配置的安全策略来作出访问控制决策。

如果 context 是 AccessControlContext 的一个实例，则用指定的权限调用 AccessControlContext.checkPermission 方法。

如果 context 不是 AccessControlContext 的一个实例，则抛出 SecurityException。

参数：
perm - 指定的权限。
context - 一个取决于系统的安全上下文。
抛出：
SecurityException - 如果指定的安全上下文不是 AccessControlContext 的一个实例（如为 null），或者访问由给定权限所指定的资源时被拒绝。
NullPointerException - 如果权限参数为 null。
从以下版本开始：
1.2
另请参见：
getSecurityContext(), AccessControlContext.checkPermission(java.security.Permission)

checkCreateClassLoader

public void checkCreateClassLoader()
如果不允许调用线程创建新的类加载器，则抛出 SecurityException。

此方法用 RuntimePermission("createClassLoader") 权限调用 checkPermission。

如果重写此方法，那么应该在已重写方法通常将要抛出异常时调用 super.checkCreateClassLoader。

抛出：
SecurityException - 如果调用线程没有创建新类加载器的权限。
另请参见：
ClassLoader.ClassLoader(), checkPermission

checkAccess

public void checkAccess(Thread t)
如果不允许调用线程修改 thread 参数，则抛出 SecurityException。

由 Thread 类的 stop、suspend、resume、setPriority、setName 和 setDaemon 方法为当前的安全管理器调用此方法。

如果 thread 参数是一个系统线程（属于具有一个 null 父线程的线程组），那么此方法使用 RuntimePermission("modifyThread") 权限调用 checkPermission。如果 thread 参数不 是一个系统线程，则此方法不执行任何操作。

希望具有更为严格策略的应用程序应该重写此方法。如果重写此方法，那么重写它的方法应该进行额外的检查，查看调用线程是否具有 RuntimePermission("modifyThread") 权限，如果是，则此方法不执行任何操作。这样做是为了确保允许那些被授予该权限的代码（如 JDK 本身）能够操作所有线程。

如果重写此方法，那么应该由已重写方法中的第一条语句调用 super.checkAccess，或者应该在已重写方法中放入等效的安全检查代码。

参数：
t - 要检查的线程。
抛出：
SecurityException - 如果调用线程没有修改线程的权限。
NullPointerException - 如果线程参数为 null。
另请参见：
resume, setDaemon, setName, setPriority, stop, suspend, checkPermission

checkAccess

public void checkAccess(ThreadGroup g)
如果不允许调用线程修改线程组参数，则抛出 SecurityException。

当创建新的子线程或子线程组时，由 ThreadGroup 类的 setDaemon、setMaxPriority、stop、suspend、resume 和 destroy 方法为当前的安全管理器调用此方法。

如果该线程组是一个系统线程组（具有 null 父线程），那么此方法使用 RuntimePermission("modifyThreadGroup") 权限调用 checkPermission。如果该线程组不 是一个系统线程组，则此方法不执行任何操作。

希望具有更为严格策略的应用程序应该重写此方法。如果重写此方法，那么重写它的方法应该进行额外的检查，查看调用线程是否具有 RuntimePermission("modifyThreadGroup") 权限，如果是，则此方法不执行任何操作。这样做是为了确保允许那些被授予该权限的代码（如 JDK 本身）能够操作所有线程。

如果重写此方法，那么应该由已重写方法中的第一条语句调用 super.checkAccess，或者应该在已重写方法中放入等效的安全检查。

参数：
g - 要检查的线程组。
抛出：
SecurityException - 如果调用线程没有修改线程组的权限。
NullPointerException - 如果线程组参数为 null。
另请参见：
destroy, resume, setDaemon, setMaxPriority, stop, suspend, checkPermission

checkExit

public void checkExit(int status)
如果不允许调用线程使用特定的状态码暂停 Java 虚拟机，则抛出 SecurityException。

由 Runtime 类的 exit 方法为当前的安全管理器调用此方法。状态 0 表示成功，其他值则表示各种错误。

此方法用 RuntimePermission("exitVM."+status) 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkExit。

参数：
status - 退出状态。
抛出：
SecurityException - 如果调用线程没有用指定的状态暂停 Java 虚拟机的权限。
另请参见：
exit, checkPermission

checkExec

public void checkExec(String cmd)
如果不允许调用线程创建一个子进程，则抛出 SecurityException。

由 Runtime 类的 exec 方法为当前的安全管理器调用此方法。

如果 cmd 是绝对路径，那么此方法使用 FilePermission(cmd,"execute") 权限调用 checkPermission，否则用 FilePermission("<<ALL FILES>>","execute") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkExec。

参数：
cmd - 指定的系统命令。
抛出：
SecurityException - 如果调用线程没有创建子进程的权限。
NullPointerException - 如果 cmd 参数为 null。
另请参见：
Runtime.exec(java.lang.String),
Runtime.exec(java.lang.String, java.lang.String[]),
Runtime.exec(java.lang.String[]),
Runtime.exec(java.lang.String[], java.lang.String[]),
checkPermission

checkLink

public void checkLink(String lib)
如果不允许调用线程动态链接由字符串参数文件指定的库代码，则抛出 SecurityException。此方法中的参数可以是一个简单的库名，或者是一个完整的文件名。

由 Runtime 类的 load 和 loadLibrary 方法为当前的安全管理器调用此方法。

此方法用 RuntimePermission("loadLibrary."+lib) 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkLink。

参数：
lib - 库名。
抛出：
SecurityException - 如果调用线程没有动态地链接该库的权限。
NullPointerException - 如果 lib 参数为 null。
另请参见：
Runtime.load(java.lang.String), Runtime.loadLibrary(java.lang.String), checkPermission

checkRead

public void checkRead(FileDescriptor fd)
如果不允许调用线程从指定的文件描述符进行读取，则抛出 SecurityException。

此方法用 RuntimePermission("readFileDescriptor") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkRead。

参数：
fd - 取决于系统的文件描述符。
抛出：
SecurityException - 如果调用线程没有访问指定文件描述符的权限。
NullPointerException - 如果文件描述符参数为 null。
另请参见：
FileDescriptor, checkPermission

checkRead

public void checkRead(String file)
如果不允许调用线程读取由字符串参数指定的文件，则抛出 SecurityException。

此方法用 FilePermission(file,"read") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkRead。

参数：
file - 取决于系统的文件名。
抛出：
SecurityException - 如果调用线程没有访问指定文件的权限。
NullPointerException - 如果 file 参数为 null。
另请参见：
checkPermission

checkRead

public void checkRead(String file,
                      Object context)
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。该上下文必须是以前调用 getSecurityContext 所返回的安全上下文。

如果 context 是 AccessControlContext 的一个实例，则用 FilePermission(file,"read") 权限调用 AccessControlContext.checkPermission 方法。

如果 context 不是 AccessControlContext 的一个实例，则抛出 SecurityException。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkRead。

参数：
file - 取决于系统的文件名。
context - 取决于系统的安全上下文。
抛出：
SecurityException - 如果指定的安全上下文不是 AccessControlContext 的一个实例（如为 null），或者没有读取指定文件的权限。
NullPointerException - 如果 file 参数为 null。
另请参见：
getSecurityContext(), AccessControlContext.checkPermission(java.security.Permission)

checkWrite

public void checkWrite(FileDescriptor fd)
如果不允许调用线程写入指定的文件描述符，则抛出 SecurityException。

此方法用 RuntimePermission("writeFileDescriptor") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkWrite。

参数：
fd - 取决于系统的文件描述符。
抛出：
SecurityException - 如果调用的方法没有访问指定文件描述符的权限。
NullPointerException - 如果文件描述符参数为 null。
另请参见：
FileDescriptor, checkPermission

checkWrite

public void checkWrite(String file)
如果不允许调用线程写由字符串参数指定的文件，则抛出 SecurityException。

此方法用 FilePermission(file,"write") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkWrite。

参数：
file - 取决于系统的文件名。
抛出：
SecurityException - 如果调用线程没有访问指定文件的权限。
NullPointerException - 如果 file 参数为 null。
另请参见：
checkPermission

checkDelete

public void checkDelete(String file)
如果不允许调用线程删除指定的文件，则抛出 SecurityException。

由 File 类的 delete 方法为当前的安全管理器调用此方法。

此方法用 FilePermission(file,"delete") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkDelete。

参数：
file - 取决于系统的文件名。
抛出：
SecurityException - 如果调用线程没有删除文件的权限。
NullPointerException - 如果 file 参数为 null。
另请参见：
File.delete(), checkPermission

checkConnect

public void checkConnect(String host,
                         int port)
如果不允许调用线程打开到指定主机和端口号的套接字连接，则抛出 SecurityException。

端口号 -1 表示调用的方法正在试图确定指定主机名的 IP 地址。

如果端口号不等于 -1，则此方法用 SocketPermission(host+":"+port,"connect") 权限调用 checkPermission。如果端口号等于 -1，则用 SocketPermission(host,"resolve") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkConnect。

参数：
host - 要连接的主机名端口。
port - 要连接的协议端口。
抛出：
SecurityException - 如果不允许调用线程打开与指定 host 和 port 的套接字连接。
NullPointerException - 如果 host 参数为 null。
另请参见：
checkPermission

checkConnect

public void checkConnect(String host,
                         int port,
                         Object context)
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。

端口号 -1 表示调用的方法正试图确定指定主机名的 IP 地址。

如果 context 不是 AccessControlContext 的一个实例，则抛出 SecurityException。

否则就检查端口号。如果端口号不等于 -1，则用 SocketPermission(host+":"+port,"connect") 权限调用 context 的 checkPermission 方法。如果端口号等于 -1，则用 SocketPermission(host,"resolve") 权限调用 context 的 checkPermission 方法。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkConnect。

参数：
host - 要连接的主机名端口。
port - 要连接的协议端口。
context - 取决于系统的安全上下文。
抛出：
SecurityException - 如果指定的安全上下文不是 AccessControlContext的一个实例（如为 null），或者不允许打开与指定 host 和 port 套接字连接。
NullPointerException - 如果 host 参数为 null。
另请参见：
getSecurityContext(), AccessControlContext.checkPermission(java.security.Permission)

checkListen

public void checkListen(int port)
如果不允许调用线程等待与指定本地端口号进行连接的请求，则抛出 SecurityException。

如果端口号不是 0，则此方法用 SocketPermission("localhost:"+port,"listen") 调用 checkPermission。如果端口号是 0，则此方法用 SocketPermission("localhost:1024-","listen") 调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkListen。

参数：
port - 本地端口。
抛出：
SecurityException - 如果调用的方法没有侦听指定端口的权限。
另请参见：
checkPermission

checkAccept

public void checkAccept(String host,
                        int port)
如果不允许调用线程从指定的主机和端口号接受套接字连接，则抛出 SecurityException。

由 ServerSocket 类的 accept 方法为当前的安全管理器调用此方法。

此方法用 SocketPermission(host+":"+port,"accept") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkAccept。

参数：
host - 套接字连接的主机名。
port - 套接字连接的端口号。
抛出：
SecurityException - 如果调用线程没有接受连接的权限。
NullPointerException - 如果 host 参数为 null。
另请参见：
ServerSocket.accept(), checkPermission

checkMulticast

public void checkMulticast(InetAddress maddr)
如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播，则抛出 SecurityException。

此方法使用 java.net.SocketPermission(maddr.getHostAddress(), "accept,connect") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkMulticast。

参数：
maddr - 要使用的 Internet 组地址。
抛出：
SecurityException - 如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播。
NullPointerException - 如果地址参数为 null。
从以下版本开始：
JDK1.1
另请参见：
checkPermission

checkMulticast

@Deprecated
public void checkMulticast(InetAddress maddr,
                                      byte ttl)
已过时。 由 #checkPermission(java.security.Permission) 取代

如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播，则抛出 SecurityException。

此方法用 java.net.SocketPermission(maddr.getHostAddress(), "accept,connect") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkMulticast。

参数：
maddr - 要使用的 Internet 组地址。
ttl - 正在使用的值，如果是用多址广播发送的话。注：此特定实现不使用 ttl 参数。
抛出：
SecurityException - 如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播。
NullPointerException - 如果地址参数为 null。
从以下版本开始：
JDK1.1
另请参见：
checkPermission

checkPropertiesAccess

public void checkPropertiesAccess()
如果不允许调用线程访问或修改系统属性，则抛出 SecurityException。

由 System 类的 getProperties 和 setProperties 方法使用此方法。

此方法用 PropertyPermission("*", "read,write") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkPropertiesAccess。

抛出：
SecurityException - 如果调用线程没有访问或修改系统属性的权限。
另请参见：
System.getProperties(), System.setProperties(java.util.Properties), checkPermission

checkPropertyAccess

public void checkPropertyAccess(String key)
如果不允许调用线程访问具有指定的 key 名的系统属性，则抛出 SecurityException。

由 System 类的 getProperty 方法使用此方法。

此方法用 PropertyPermission(key, "read") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkPropertyAccess。

参数：
key - 系统属性键。
抛出：
SecurityException - 如果调用线程没有访问指定系统属性的权限。
NullPointerException - 如果 key 参数为 null。
IllegalArgumentException - 如果 key 为空。
另请参见：
System.getProperty(java.lang.String), checkPermission

checkTopLevelWindow

public boolean checkTopLevelWindow(Object window)
如果不受信任的调用线程调出由 window 参数指出的顶层窗口，则返回 false。在这种情况下，调用方仍然可以决定显示窗口，但窗口应包括某些可视的警告。如果此方法返回 true，则窗口的显示没有任何特殊的限制。

有关受信任和不受信任窗口的更多信息，请参见 Window 类。

此方法用 AWTPermission("showWindowWithoutWarningBanner") 权限调用 checkPermission，并且如果未抛出 SecurityException，则返回 true，否则返回 false。

如果重写此方法，那么通常应该在已重写方法将要返回 false 时调用 super.checkTopLevelWindow，并且应该返回 super.checkTopLevelWindow 值。

参数：
window - 所创建的新窗口。
返回：
如果信任的调用线程弹出顶层窗口，则返回 true，否则返回 false。
抛出：
NullPointerException - 如果 window 参数为 null。
另请参见：
Window, checkPermission

checkPrintJobAccess

public void checkPrintJobAccess()
如果不允许调用线程发起一个打印作业请求，则抛出 SecurityException。

此方法用 RuntimePermission("queuePrintJob") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkPrintJobAccess。

抛出：
SecurityException - 如果调用线程没有发起打印作业请求的权限。
从以下版本开始：
JDK1.1
另请参见：
checkPermission

checkSystemClipboardAccess

public void checkSystemClipboardAccess()
如果不允许调用线程访问系统剪贴板，则抛出 SecurityException。

此方法用 AWTPermission("accessClipboard") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkSystemClipboardAccess。

抛出：
SecurityException - 如果调用线程没有访问系统剪贴板的权限。
从以下版本开始：
JDK1.1
另请参见：
checkPermission

checkAwtEventQueueAccess

public void checkAwtEventQueueAccess()
如果不允许调用线程访问 AWT 事件队列，则抛出 SecurityException。

此方法用 AWTPermission("accessEventQueue") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkAwtEventQueueAccess。

抛出：
SecurityException - 如果调用线程没有访问 AWT 事件队列的权限。
从以下版本开始：
JDK1.1
另请参见：
checkPermission

checkPackageAccess

public void checkPackageAccess(String pkg)
如果不允许调用线程访问由参数指定的包，则抛出 SecurityException。

由类加载器的 loadClass 方法使用此方法。

此方法首先获取受限制包的列表，方法是从对 java.security.Security.getProperty("package.access") 的调用中获得一个逗号分隔的列表，并查看受限制包是否以 pkg 开头或等于该字符。如果是，则用 RuntimePermission("accessClassInPackage."+pkg) 权限调用 checkPermission。

如果重写了此方法，则应在已重写方法的首行调用 super.checkPackageAccess。

参数：
pkg - 包名。
抛出：
SecurityException - 如果调用线程没有访问指定包的权限。
NullPointerException - 如果包名参数为 null。
另请参见：
loadClass, getProperty, checkPermission

checkPackageDefinition

public void checkPackageDefinition(String pkg)
如果不允许调用线程在参数指定的包中定义类，则抛出 SecurityException。

由类加载器的 loadClass 方法使用此方法。

此方法首先获取受限制包的列表，方法是从对 java.security.Security.getProperty("package.definition") 的调用中获得一个逗号分隔的列表，并查看受限制包是否以 pkg 开头或等于该字符。如果是，则用 RuntimePermission("defineClassInPackage."+pkg) 权限调用 checkPermission。

如果重写了此方法，则应在已重写方法的首行调用 super.checkPackageDefinition。

参数：
pkg - 包名。
抛出：
SecurityException - 如果调用线程没有在指定包中定义类的权限。
另请参见：
ClassLoader.loadClass(java.lang.String, boolean), getProperty, checkPermission

checkSetFactory

public void checkSetFactory()
如果不允许调用线程设置由 ServerSocket 或 Socket 使用的套接字工厂，或者由 URL 使用的流处理程序工厂，则抛出 SecurityException。

此方法用 RuntimePermission("setFactory") 权限调用 checkPermission。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkSetFactory。

抛出：
SecurityException - 如果调用线程没有指定套接字工厂或流处理程序工厂的权限。
另请参见：
setSocketFactory, setSocketImplFactory, setURLStreamHandlerFactory, checkPermission

checkMemberAccess

public void checkMemberAccess(Class<?> clazz,
                              int which)
如果不允许调用线程访问程序，则抛出 SecurityException。

默认的策略是允许访问 PUBLIC 成员，以及访问具有与调用方相同类加载器的类。在所有其他情况下，此方法用 RuntimePermission("accessDeclaredMembers") 权限调用 checkPermission。

如果重写此方法，则不能调用 super.checkMemberAccess，因为 checkMemberAccess 的默认实现依赖于堆栈深度为 4 时检查的代码。

参数：
clazz - 要执行反射的类。
which - 访问类型，PUBLIC 或 DECLARED。
抛出：
SecurityException - 如果调用方没有访问成员的权限。
NullPointerException - 如果 clazz 参数为 null。
从以下版本开始：
JDK1.1
另请参见：
Member, checkPermission

checkSecurityAccess

public void checkSecurityAccess(String target)
确定是应该允许还是拒绝具有指定权限目标名的权限。

如果允许请求的权限，则此方法不执行任何操作。如果拒绝，则引发 SecurityException。

此方法为给定权限的目标名创建一个 SecurityPermission 对象并用该对象调用 checkPermission 。

有关可用权限目标名的列表，请参阅 SecurityPermission 的文档。

如果重写此方法，那么通常应该在已重写方法将要抛出异常时调用 super.checkSecurityAccess。

参数：
target - SecurityPermission 的目标名。
抛出：
SecurityException - 如果调用线程没有所请求访问的权限。
NullPointerException - 如果 target 为 null。
IllegalArgumentException - 如果 target 为空。
从以下版本开始：
JDK1.1
另请参见：
checkPermission

getThreadGroup

public ThreadGroup getThreadGroup()
调用此方法时，返回所有新创建的线程实例化后所在的线程组。默认情况下，返回当前线程所在的线程组。应该由指定的安全管理器重写此方法，以返回适当的线程组。

返回：
ThreadGroup 新线程被实例化后所在的线程组
从以下版本开始：
JDK1.1
另请参见：
ThreadGroup
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Short (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Short

java.lang.Object
    继承者  java.lang.Number
        继承者  java.lang.Short
所有已实现的接口：
Serializable, Comparable<Short>
public final class Short
extends Number
implements Comparable<Short>

Short 类在对象中包装基本类型 short 的值。一个 Short 类型的对象只包含一个 short 类型的字段。

另外，该类提供了多个方法，可以将 short 转换为 String，将 String 转换为 short，同时还提供了其他一些处理 short 时有用的常量和方法。

从以下版本开始：
JDK1.1
另请参见：
Number, 序列化表格

字段摘要
static short | MAX_VALUE 保存 short 可取的最大值的常量，最大值为 215-1。
static short | MIN_VALUE 保存 short 可取的最小值的常量，最小值为 -215。
static int | SIZE 用来以二进制补码形式表示 short 值的位数。
static Class<Short> | TYPE 表示基本类型 short 的 Class 实例。
构造方法摘要
Short(short value)
构造一个新分配的 Short 对象，用来表示指定的 short 值。
Short(String s)
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。
方法摘要
byte | byteValue() 以 byte 形式返回此 Short 的值。
int | compareTo(Short anotherShort) 比较两个 Short 对象所表示的数值。
static Short | decode(String nm) 将 String 解码为 Short。
double | doubleValue() 以 double 形式返回此 Short 的值。
boolean | equals(Object obj) 将此对象与指定对象比较。
float | floatValue() 以 float 形式返回此 Short 的值。
int | hashCode() 返回此 Short 的哈希码。
int | intValue() 以 int 形式返回此 Short 的值。
long | longValue() 以 Long 形式返回此 Short 的值。
static short | parseShort(String s) 将字符串参数解析为有符号的十进制 short。
static short | parseShort(String s, int radix) 将字符串参数解析为由第二个参数指定的基数中的有符号的 short。
static short | reverseBytes(short i) 返回通过反转指定 short 值的二进制补码表示形式中字节的顺序而获得的值。
short | shortValue() 以 short 形式返回此 Short 的值。
String | toString() 返回表示此 Short 的值的 String 对象。
static String | toString(short s) 返回表示指定 short 的一个新 String 对象。
static Short | valueOf(short s) 返回表示指定 short 值的 Short 实例。
static Short | valueOf(String s) 返回一个保持指定 String 所给出的值的 Short 对象。
static Short | valueOf(String s, int radix) 返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MIN_VALUE

public static final short MIN_VALUE
保存 short 可取的最小值的常量，最小值为 -215。

另请参见：
常量字段值

MAX_VALUE

public static final short MAX_VALUE
保存 short 可取的最大值的常量，最大值为 215-1。

另请参见：
常量字段值

TYPE

public static final Class<Short> TYPE
表示基本类型 short 的 Class 实例。

SIZE

public static final int SIZE
用来以二进制补码形式表示 short 值的位数。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

Short

public Short(short value)
构造一个新分配的 Short 对象，用来表示指定的 short 值。

参数：
valueShort - 所表示的值。

Short

public Short(String s)
      throws NumberFormatException
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。将字符串转换为 short 值，转换方式与基数为 10 的 parseShort 方法所用的方式完全相同。

参数：
s - 要转换为 Short 的 String
抛出：
NumberFormatException - 如果 String 不包含可解析的 short。
另请参见：
parseShort(java.lang.String, int)
方法详细信息

toString

public static String toString(short s)
返回表示指定 short 的一个新 String 对象。假定用十进制表示。

参数：
s - 所要转换的 short
返回：
表示指定 short 的字符串
另请参见：
Integer.toString(int)

parseShort

public static short parseShort(String s)
                        throws NumberFormatException
将字符串参数解析为有符号的十进制 short。该字符串中的字符必须都是十进制数字，除非第一个字符是表示负值的 ASCII 符号中的负号 '-' ('\u002D')。返回得到的 short 值，此值与用该参数和基数 10 作为参数的 parseShort(java.lang.String, int) 方法得到的值相同。

参数：
s - 包含要解析的 short 表示形式的 String
返回：
参数（十进制）表示的 short 值。
抛出：
NumberFormatException - 如果该字符串不包含可解析的 short。

parseShort

public static short parseShort(String s,
                               int radix)
                        throws NumberFormatException
将字符串参数解析为由第二个参数指定的基数中的有符号的 short。该字符串中的字符必须都是指定基数（这取决于 Character.digit(char, int) 是否返回非负值）的数字，除非第一个字符是表示负值的 ASCII 符号中的负号 “-” ('\u002D')。返回得到的 byte 值。

如果出现以下情形之一，则抛出 NumberFormatException 类型的异常：

  • 第一个参数是 null 或零长度的字符串。
  • 基数小于 Character.MIN_RADIX 或大于 Character.MAX_RADIX。
  • 除了在字符串长度超过 1 的情况下第一个字符可能是负号 “-” ('\u002D') 之外，字符串的任何字符都不是指定基数的数字。
  • 字符串所表示的值不是 short 类型的值。

参数：
s - 包含要解析的 short 表示形式的 String
radix - 将在解析 s 时使用的基数
返回：
由指定基数中的字符串参数表示的 short。
抛出：
NumberFormatException - 如果 String 不包含可解析的 short。

valueOf

public static Short valueOf(String s,
                            int radix)
                     throws NumberFormatException
返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。第一个参数被解释为表示在使用第二个参数所指定基数时的一个有符号的 short，此值与用该参数作为参数的 parseShort(java.lang.String, int) 方法得到的值相同。结果是一个表示该字符串所指定的 short 值的 Short 对象。

换句话说，此方法返回一个 Short 对象，它的值等于：

new Short(Short.parseShort(s, radix))

参数：
s - 要解析的字符串
radix - 将在解释 s 时使用的基数
返回：
保持指定基数中的字符串参数所表示的值的 Short 对象。
抛出：
NumberFormatException - 如果 String 不包含可解析的 short。

valueOf

public static Short valueOf(String s)
                     throws NumberFormatException
返回一个保持指定 String 所给出的值的 Short 对象。该参数被解释为表示一个有符号的十进制 short，此值与用该参数作为参数的 #parseLong(java.lang.String) 方法得到的值相同。结果是一个表示该字符串所指定的 short 值的 Short 对象。

换句话说，此方法返回一个 Short 对象，它的值等于：

new Short(Short.parseShort(s))

参数：
s - 要解析的字符串
返回：
保持字符串参数所表示的值的 Short 对象
抛出：
NumberFormatException - 如果 String 不包含可解析的 short。

valueOf

public static Short valueOf(short s)
返回表示指定 short 值的 Short 实例。如果不需要新的 Short 实例，则通常应该优先采用此方法，而不是构造方法 Short(short)，因为此方法很可能通过缓存经常请求的值来显著提高空间和时间性能。

参数：
s - 一个 short 值。
返回：
表示 s 的 Short 实例。
从以下版本开始：
1.5

decode

public static Short decode(String nm)
                    throws NumberFormatException
将 String 解码为 Short。接受通过以下语法给出的十进制、十六进制和八进制数：
DecodableString:
Signopt DecimalNumeral
Signopt 0x HexDigits
Signopt 0X HexDigits
Signopt # HexDigits
Signopt 0 OctalDigits

Sign:
-
DecimalNumeral、HexDigits 和 OctalDigits 在 Java Language Specification 的 §3.10.1 中已经定义。

对（可选）负号和/或基数说明符（“0x”、“0X”、“#” 或前导零）后面的字符序列进行解析就如同用 Short.parseByte 方法来解析指定的基数（10、16 或 8）一样。该字符序列必须表示为一个正值，否则将抛出 NumberFormatException。如果指定 String 的第一个字符是减号，则结果无效。String 中不允许出现空白字符。

参数：
nm - 要解码的 String。
返回：
保持 nm 所表示的 short 值的 Short 对象
抛出：
NumberFormatException - 如果 String 不包含可解析的 short。
另请参见：
parseShort(java.lang.String, int)

byteValue

public byte byteValue()
以 byte 形式返回此 Short 的值。

覆盖：
类 Number 中的 byteValue
返回：
转换为 byte 类型后该对象表示的数值。

shortValue

public short shortValue()
以 short 形式返回此 Short 的值。

覆盖：
类 Number 中的 shortValue
返回：
转换为 short 类型后该对象表示的数值。

intValue

public int intValue()
以 int 形式返回此 Short 的值。

指定者：
类 Number 中的 intValue
返回：
转换为 int 类型后该对象表示的数值。

longValue

public long longValue()
以 Long 形式返回此 Short 的值。

指定者：
类 Number 中的 longValue
返回：
转换为 long 类型后该对象表示的数值。

floatValue

public float floatValue()
以 float 形式返回此 Short 的值。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 类型后该对象表示的数值。

doubleValue

public double doubleValue()
以 double 形式返回此 Short 的值。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 类型后该对象表示的数值。

toString

public String toString()
返回表示此 Short 的值的 String 对象。该值被转换成有符号的十进制表示形式，并作为一个字符串返回，正如将 short 值作为一个参数指定给 toString(short) 方法所得到的值那样。

覆盖：
类 Object 中的 toString
返回：
该对象值（十进制）的字符串表示形式。

hashCode

public int hashCode()
返回此 Short 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不是 null，而是一个与该对象一样包含相同 short 值的 Short 对象时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 将与之进行比较的对象。
返回：
如果这些对象相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(Short anotherShort)
比较两个 Short 对象所表示的数值。

指定者：
接口 Comparable<Short> 中的 compareTo
参数：
anotherShort - 要比较的 Short。
返回：
如果该 Short 等于参数 Short，则返回 0；如果该 Short 数值小于参数 Short，则返回小于 0 的值；如果该 Short 数值大于参数 Short，则返回大于 0 的值（有符号比较）。
从以下版本开始：
1.2

reverseBytes

public static short reverseBytes(short i)
返回通过反转指定 short 值的二进制补码表示形式中字节的顺序而获得的值。

返回：
返回通过反转（或者交换，效果相同）指定 short 值中的字节而获得的值。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StackOverflowError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 StackOverflowError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.VirtualMachineError
                继承者  java.lang.StackOverflowError
所有已实现的接口：
Serializable
public class StackOverflowError
extends VirtualMachineError

当应用程序递归太深而发生堆栈溢出时，抛出该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
StackOverflowError()
构造不带详细消息的 StackOverflowError。
StackOverflowError(String s)
构造带指定详细消息的 StackOverflowError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StackOverflowError

public StackOverflowError()
构造不带详细消息的 StackOverflowError。

StackOverflowError

public StackOverflowError(String s)
构造带指定详细消息的 StackOverflowError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StackTraceElement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 StackTraceElement

java.lang.Object
    继承者  java.lang.StackTraceElement
所有已实现的接口：
Serializable
public final class StackTraceElement
extends Object
implements Serializable

堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。每个元素表示单独的一个堆栈帧。所有的堆栈帧（堆栈顶部的那个堆栈帧除外）都表示一个方法调用。堆栈顶部的帧表示生成堆栈跟踪的执行点。通常，这是创建对应于堆栈跟踪的 throwable 的点。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
StackTraceElement(String declaringClass, String methodName, String fileName, int lineNumber)
创建表示指定执行点的堆栈跟踪元素。
方法摘要
boolean | equals(Object obj) 如果指定的对象是另一个 StackTraceElement 实例，并且该对象表示的执行点与该实例的相同，则返回 ture。
String | getClassName() 返回类的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点。
String | getFileName() 返回源文件名，该文件包含由该堆栈跟踪元素所表示的执行点。
int | getLineNumber() 返回源行的行号，该行包含由该堆栈该跟踪元素所表示的执行点。
String | getMethodName() 返回方法名，此方法包含由该堆栈跟踪元素所表示的执行点。
int | hashCode() 返回此堆栈跟踪元素的哈希码值。
boolean | isNativeMethod() 如果包含由该堆栈跟踪元素所表示的执行点的方法是一个本机方法，则返回 true。
String | toString() 返回表示该堆栈跟踪元素的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

StackTraceElement

public StackTraceElement(String declaringClass,
                         String methodName,
                         String fileName,
                         int lineNumber)
创建表示指定执行点的堆栈跟踪元素。

参数：
declaringClass - 类的完全限定名，该类包含由堆栈跟踪元素所表示的执行点
methodName - 方法名，该方法包含由堆栈跟踪元素所表示的执行点
fileName - 文件名，该文件包含由堆栈跟踪元素所表示的执行点；如果该信息不可用，则该参数为 null
lineNumber - 源代码行的行号，该代码行包含由堆栈跟踪元素所表示的执行点；如果此信息不可用，则该参数为负数。值 -2 表示包含执行点的方法是一个本机方法
抛出：
NullPointerException - 如果 declaringClass 或 methodName 为 null
从以下版本开始：
1.5
方法详细信息

getFileName

public String getFileName()
返回源文件名，该文件包含由该堆栈跟踪元素所表示的执行点。通常，这对应于相关 class 文件的 SourceFile 属性（根据 The Java Virtual Machine Specification 中的第 4.7.7 小节）。在某些系统中，该名称可能指的是源代码单元而不是某个文件，如源存储库中的某个项。

返回：
文件名，该文件包含由该堆栈跟踪元素所表示的执行点；如果该信息不可用，则返回 null。

getLineNumber

public int getLineNumber()
返回源行的行号，该行包含由该堆栈该跟踪元素所表示的执行点。通常，该方法派生自相关 class 文件的 LineNumberTable 属性（根据 The Java Virtual Machine Specification 中的第 4.7.8 小节）。

返回：
源代码行的行号，该代码行包含由该堆栈跟踪元素所表示的执行点；如果该信息不可用，则返回负数。

getClassName

public String getClassName()
返回类的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点。

返回：
Class 的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点。

getMethodName

public String getMethodName()
返回方法名，此方法包含由该堆栈跟踪元素所表示的执行点。如果执行点包含在某个实例或类初始化程序中，则此方法将返回适当的特殊方法名：<init> 或 <clinit>（根据 The Java Virtual Machine Specification 中的第 3.9 节）。

返回：
方法名，该方法包含由该堆栈跟踪元素所表示的执行点。

isNativeMethod

public boolean isNativeMethod()
如果包含由该堆栈跟踪元素所表示的执行点的方法是一个本机方法，则返回 true。

返回：
如果包含由该堆栈跟踪元素所表示的执行点的方法是一个本机方法，则返回 true。

toString

public String toString()
返回表示该堆栈跟踪元素的字符串。该字符串的格式取决于实现，但是可将以下示例格式视为典型的格式：
  • "MyClass.mash(MyClass.java:9)" - 其中，"MyClass" 是类的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点；"mash" 是包含执行点的方法的名字；"MyClass.java" 是包含执行点的源文件；"9" 是包含执行点的源行的行号。
  • "MyClass.mash(MyClass.java)" - 同上，但是行号不可用。
  • "MyClass.mash(Unknown Source)" - 同上，但是文件名和行号都不可用。
  • "MyClass.mash(Native Method)" - 同上，但是文件名和行号都不可用，并且已知包含执行点的方法是本机方法。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
另请参见：
Throwable.printStackTrace()

equals

public boolean equals(Object obj)
如果指定的对象是另一个 StackTraceElement 实例，并且该对象表示的执行点与该实例的相同，则返回 ture。当且仅当满足下列条件时，堆栈跟踪元素 a 和 b 相同：
     equals(a.getFileName(), b.getFileName()) &&
     a.getLineNumber() == b.getLineNumber()) &&
     equals(a.getClassName(), b.getClassName()) &&
     equals(a.getMethodName(), b.getMethodName())
其中定义 equals 为：
     static boolean equals(Object a, Object b) {
         return a==b || (a != null && a.equals(b));
     }

覆盖：
类 Object 中的 equals
参数：
obj - 要与该堆栈跟踪元素相比较的对象。
返回：
如果指定的对象是另一个 StackTraceElement 实例，并且该对象表示的执行点与该实例的相同，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此堆栈跟踪元素的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StrictMath (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 StrictMath

java.lang.Object
    继承者  java.lang.StrictMath

public final class StrictMath
extends Object

StrictMath 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。

为了确保 Java 程序的可移植性，此包中的某些数学函数的定义需要与某些已发布的算法生成相同的结果。这些算法可以从众所周知的网络库 netlib 以 fdlibm（“Freely Distributable Math Library，免费发布的数学库”）包的形式获得。这些算法都是用 C 编程语言编写的，在使用所有遵循 Java 浮点算法规则的浮点运算执行时也能够被理解。

Java 数学库是根据 fdlibm 5.3 版定义的。其中 fdlibm 使用“IEEE 754 核心函数”版本（位于名字以字母 e 开头的文件中）为一个函数提供了多个定义（如 acos）。需要 fdlibm 语义的方法有 sin、cos、tan、asin、acos、atan、exp、log、log10、cbrt、atan2、pow、sinh、cosh、tanh、hypot、expm1 和 log1p。

从以下版本开始：
1.3

字段摘要
static double | E 比任何其他值都更接近 e（即自然对数的底数）的 double 值。
static double | PI 比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。
方法摘要
static double abs(double a)
返回 double 值的绝对值。
static float abs(float a)
返回 float 值的绝对值。
static int abs(int a)
返回 int 值的绝对值。
static long abs(long a)
返回 long 值的绝对值。
static double acos(double a)
返回值的反余弦；返回角的范围在 0.0 到 pi 之间。
static double asin(double a)
返回值的反正弦；返回角的范围在 -pi/2 到 pi/2 之间。
static double atan(double a)
返回值的反正切；返回角的范围在 -pi/2 到 pi/2 之间。
static double atan2(double y, double x)
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，并返回角 theta。
static double cbrt(double a)
返回 double 值的立方根。
static double ceil(double a)
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并且等于某个整数。
static double copySign(double magnitude, double sign)
返回带有第二个浮点参数符号的第一个浮点参数。
static float copySign(float magnitude, float sign)
返回带有第二个浮点参数符号的第一个浮点参数。
static double cos(double a)
返回角的三角余弦。
static double cosh(double x)
返回 double 值的双曲线余弦。
static double exp(double a)
返回欧拉数 e 的 double 次幂的值。
static double expm1(double x)
返回 ex -1。
static double floor(double a)
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。
static int getExponent(double d)
返回 double 表示形式中使用的无偏指数。
static int getExponent(float f)
返回 float 表示形式中使用的无偏指数。
static double hypot(double x, double y)
返回 sqrt(x2 +y2)，没有中间溢出或下溢。
static double IEEEremainder(double f1, double f2)
按照 IEEE 754 标准的规定，对两个参数进行余数运算。
static double log(double a)
返回 double 值的自然对数（底数为 e）。
static double log10(double a)
返回 double 值的底数为 10 的对数。
static double log1p(double x)
返回参数与 1 之和的自然对数。
static double max(double a, double b)
返回两个 double 值中较大的一个。
static float max(float a, float b)
返回两个 float 值中较大的一个。
static int max(int a, int b)
返回两个 int 值中较大的一个。
static long max(long a, long b)
返回两个 long 值中较大的一个。
static double min(double a, double b)
返回两个 double 值中较小的一个。
static float min(float a, float b)
返回两个 float 值中较小的一个。
static int min(int a, int b)
返回两个 int 值中较小的一个。
static long min(long a, long b)
返回两个 long 值中较小的一个。
static double nextAfter(double start, double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
static float nextAfter(float start, double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。
static double nextUp(double d)
返回 d 和正无穷大之间与 d 相邻的浮点值。
static float nextUp(float f)
返回 f 和正无穷大之间与 f 相邻的浮点值。
static double pow(double a, double b)
返回第一个参数的第二个参数次幂的值。
static double random()
返回带有正号的 double 值，该值大于等于 0.0 且小于 1.0。
static double rint(double a)
返回最接近参数并等于某一整数的 double 值。
static long round(double a)
返回最接近参数的 long。
static int round(float a)
返回最接近参数的 int。
static double scalb(double d, int scaleFactor)
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 double 值集合中的一个值。
static float scalb(float f, int scaleFactor)
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 float 值集合中的一个值。
static double signum(double d)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。
static float signum(float f)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0f；如果参数小于 0，则返回 -1.0f。
static double sin(double a)
返回角的三角正弦。
static double sinh(double x)
返回 double 值的双曲线正弦。
static double sqrt(double a)
返回正确舍入的 double 值的正平方根。
static double tan(double a)
返回角的三角正切。
static double tanh(double x)
返回 double 值的双曲线正切。
static double toDegrees(double angrad)
将用弧度表示的角转换为近似相等的用角度表示的角。
static double toRadians(double angdeg)
将用角度表示的角转换为近似相等的用弧度表示的角。
static double ulp(double d)
返回参数的 ulp 大小。
static float ulp(float f)
返回参数的 ulp 大小。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

E

public static final double E
比任何其他值都更接近 e（即自然对数的底数）的 double 值。

另请参见：
常量字段值

PI

public static final double PI
比任何其他值都更接近 pi（即圆的周长与直径之比）的 double 值。

另请参见：
常量字段值
方法详细信息

sin

public static double sin(double a)
返回角的三角正弦。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
a - 以弧度表示的角。
返回：
参数的正弦。

cos

public static double cos(double a)
返回角的三角余弦。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 NaN。

参数：
a - 以弧度表示的角。
返回：
参数的余弦。

tan

public static double tan(double a)
返回角的三角正切。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
a - 以弧度表示的角。
返回：
参数的正切。

asin

public static double asin(double a)
返回值的反正弦；返回角的范围在 -pi/2 到 pi/2 之间。特殊情况如下：
  • 如果参数为 NaN 或它的绝对值大于 1，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
a - 要返回其反正弦的值。
返回：
参数的反正弦。

acos

public static double acos(double a)
返回值的反余弦；返回角的范围在 0.0 到 pi 之间。特殊情况如下：
  • 如果参数为 NaN 或它的绝对值大于 1，那么结果为 NaN。

参数：
a - 要返回其反余弦的值。
返回：
参数的反余弦。

atan

public static double atan(double a)
返回值的反正切；返回角的范围在 -pi/2 到 pi/2 之间。特殊情况如下：
  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
a - 要返回其反正切的值。
返回：
参数的反正切。

toRadians

public static double toRadians(double angdeg)
将用角度表示的角转换为近似相等的用弧度表示的角。从角度到弧度的转换通常是不精确的。

参数：
angdeg - 用角度表示的角。
返回：
角 angrad 用弧度表示的值。

toDegrees

public static double toDegrees(double angrad)
将用弧度表示的角转换为近似相等的用角度表示的角。从弧度到角度的转换通常是不精确的；用户不 应该期望 cos(toRadians(90.0)) 与 0.0 精确相等。

参数：
angrad - 用弧度表示的角。
返回：
角 angrad 用角度表示的值。

exp

public static double exp(double a)
返回欧拉数 e 的 double 次幂的值。特殊情况如下：
  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为负无穷大，那么结果为正 0。

参数：
a - e 的指数。
返回：
值 ea，其中 e 是自然对数的底数。

log

public static double log(double a)
返回 double 值的自然对数（底数为 e）。特殊情况如下：
  • 如果参数为 NaN 或小于 0，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为负无穷大。

参数：
a - 一个值。
返回：
ln a 的值，即 a 的自然对数。

log10

public static double log10(double a)
返回 double 值的底数为 10 的对数。特殊情况如下：
  • 如果参数为 NaN 或小于 0，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为负无穷大。
  • 如果参数等于整数 n 的 10 n，那么结果为 n。

参数：
a - 一个值
返回：
a 的底数为 10 的对数。
从以下版本开始：
1.5

sqrt

public static double sqrt(double a)
返回正确舍入的 double 值的正平方根。特殊情况如下：
  • 如果参数为 NaN 或小于 0，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果与参数相同。
否则，结果为最接近该参数值实际数学平方根的 double 值。

参数：
a - 一个值。
返回：
a 的正平方根。

cbrt

public static double cbrt(double a)
返回 double 值的立方根。对于正有限值 x，cbrt(-x) == -cbrt(x)；也就是说，负值的立方根是该值数值的负立方根。特殊情况如下：
  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为无穷大，那么结果为无穷大，且符号与参数符号相同。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
a - 一个值。
返回：
a 的立方根。
从以下版本开始：
1.5

IEEEremainder

public static double IEEEremainder(double f1,
                                   double f2)
按照 IEEE 754 标准的规定，对两个参数进行余数运算。余数的算术值等于 f1 - f2 × n，其中 n 是最接近商 f1/f2 准确算术值的整数，如果两个整数都同样接近 f1/f2，那么 n 是其中的偶数。如果余数是 0，则它的符号与第一个参数的符号相同。特殊情况如下：
  • 如果任一参数为 NaN，或者第一个参数为无穷大，或者第二个参数为正 0 或负 0，那么结果为 NaN。
  • 如果第一个参数为有限值，第二个参数为无穷大，那么结果与第一个参数相同。

参数：
f1 - 被除数。
f2 - 除数。
返回：
f1 除以 f2 的余数。

ceil

public static double ceil(double a)
返回最小的（最接近负无穷大）double 值，该值大于等于参数，并且等于某个整数。特殊情况如下：
  • 如果参数值已经等于某个整数，那么结果为该参数。
  • 如果参数为 NaN 或无穷大或正 0 或负 0，那么结果与参数相同。
  • 如果参数值小于 0，但大于 -1.0，那么结果为负 0。
注意，StrictMath.ceil(x) 的值与 -StrictMath.floor(-x) 的值完全一样。

参数：
a - 一个值。
返回：
最小（最接近负无穷大）浮点值，该值大于等于参数，并且等于某个整数。

floor

public static double floor(double a)
返回最大的（最接近正无穷大）double 值，该值小于等于参数，并等于某个整数。特殊情况如下：
  • 如果参数值已经等于某个整数，那么结果为该参数。
  • 如果参数为 NaN 或无穷大或正 0 或负 0，那么结果与参数相同。

参数：
a - 一个值。
返回：
最大（最接近正无穷大）浮点值，该值小于等于该参数，并且等于某个整数。

rint

public static double rint(double a)
返回最接近参数并等于某一整数的 double 值。如果两个同为整数的 double 值都同样接近，那么结果取偶数。特殊情况如下：
  • 如果参数值已经等于某一整数，那么结果与参数相同。
  • 如果参数为 NaN、无穷大、正 0 或负 0，那么结果与参数相同。

参数：
a - 一个值。
返回：
最接近 a 的整数浮点值。

atan2

public static double atan2(double y,
                           double x)
将矩形坐标 (x, y) 转换成极坐标 (r, theta)，并返回角 theta。该方法通过计算 y/x 的反正切值来计算相角 theta，范围为从 -pi 到 pi。特殊情况如下：
  • 如果任一参数为 NaN，那么结果为 NaN。
  • 如果第一个参数为正 0，第二个参数为正数；或者第一个参数为正有限值，第二个参数为正无穷大，那么结果为正 0。
  • 如果第一个参数为负 0，第二个参数为正数；或者第一个参数为负的有限值，第二个参数为正无穷大，那么结果为负 0。
  • 如果第一个参数为正 0，第二个参数为负数；或者第一个参数为正有限值，第二个参数为负无穷大，那么结果为最接近 pi 的 double 值。
  • 如果第一个参数为负 0，第二个参数为负数；或者第一个参数为负的有限值，第二个参数为负无穷大，那么结果为最接近 -pi 的 double 值。
  • 如果第一个参数为正数，第二个参数为正 0 或负 0；或者第一个参数为正无穷大，第二个参数为有限值，那么结果为最接近 pi/2 的 double 值。
  • 如果第一个参数为负数，第二个参数为正 0 或负 0；或者第一个参数为负无穷大，第二个参数为有限值，那么结果为最接近 -pi/2 的 double 值。
  • 如果两个参数都是正无穷大，那么结果为最接近 pi/4 的 double 值。
  • 如果第一个参数为正无穷大，第二个参数为负无穷大，那么结果为最接近 3*pi/4 的 double 值。
  • 如果第一个参数为负无穷大，第二个参数为正无穷大，那么结果为最接近 -pi/4 的 double 值。
  • 如果两个参数都是负无穷大，那么结果为最接近 -3*pi/4 的 double 值。

参数：
y - 纵坐标
x - 横坐标
返回：
与笛卡儿坐标中点 (x, y) 对应的极坐标中点 (r, theta) 的 theta 组件。

pow

public static double pow(double a,
                         double b)
返回第一个参数的第二个参数次幂的值。特殊情况如下：
  • 如果第二个参数为正 0 或负 0，那么结果为 1.0。
  • 如果第二个参数为 1.0，那么结果与第一个参数相同。
  • 如果第二个参数为 NaN，那么结果为 NaN。
  • 如果第一个参数为 NaN，第二个参数为非 0，那么结果为 NaN。
  • 如果
    • 第一个参数的绝对值大于 1，并且第二个参数为正无穷大，或者
    • 第一个参数的绝对值小于 1，并且第二个参数为负无穷大，
    那么结果为正无穷大。
  • 如果
    • 第一个参数的绝对值大于 1，并且第二个参数为负无穷大，或者
    • 第一个参数的绝对值小于 1，并且第二个参数为正无穷大，
    那么结果为正 0。
  • 如果第一个参数的绝对值等于1，并且第二个参数为无穷大，那么结果为 NaN。
  • 如果
    • 第一个参数为正 0，并且第二个参数大于 0，或者
    • 第一个参数为正无穷大，并且第二个参数小于 0，
    那么结果为正 0。
  • 如果
    • 第一个参数为正 0，并且第二个参数小于 0，或者
    • 第一个参数为正无穷大，并且第二个参数大于 0，
    那么结果为正无穷大。
  • 如果
    • 如果第一个参数为负 0，并且第二个参数大于 0 但不是有限的奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数小于 0 但不是有限的奇数整数，
    那么结果为正 0。
  • 如果
    • 第一个参数为负 0，并且第二个参数为正的有限奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数为负的有限奇数整数，
    那么结果为负 0。
  • 如果
    • 如果第一个参数为负 0，并且第二个参数小于 0 但不是有限的奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数大于 0 但不是有限的奇数整数，
    那么结果为正无穷大。
  • 如果
    • 第一个参数为负 0，并且第二个参数为负的有限奇数整数，或者
    • 第一个参数为负无穷大，并且第二个参数为正的有限奇数整数，
    那么结果为负无穷大。
  • 如果第一个参数为小于 0 的有限值，
    • 并且第二个参数为有限的偶数整数，那么结果等于第一个参数绝对值的第二个参数次幂的结果。
    • 如果第二个参数为有限的奇数整数，那么结果等于负的第一个参数绝对值的第二个参数次幂的结果。
    • 如果第二个参数为有限的非整数值，那么结果为 NaN。
  • 如果两个参数都是整数，并且结果恰好可以表示为一个 double 值，那么该结果恰好等于第一个参数的第二个参数次幂的算术结果。

（在前面的描述中，当且仅当浮点数为有限值并且是方法 ceil 的定点数，或者是方法 floor 的定点数时，才可以认为浮点值是整数。当且仅当将某个单参数方法应用到某个值的结果等于该值时，该值才是这个方法的定点值。）

参数：
a - 底数。
b - 指数。
返回：
值 ab。

round

public static int round(float a)
返回最接近参数的 int。结果将舍入为整数：加上 1/2，对结果调用 floor 并将所得结果强制转换为 int 类型。换句话说，结果等于以下表达式的值：

(int)Math.floor(a + 0.5f)

特殊情况如下：

  • 如果参数为 NaN，那么结果为 0。
  • 如果参数为负无穷大或任何小于等于 Integer.MIN_VALUE 的值，那么结果等于 Integer.MIN_VALUE 的值。
  • 如果参数为正无穷大或任何大于等于 Integer.MAX_VALUE 的值，那么结果等于 Integer.MAX_VALUE 的值。

参数：
a - 要舍入为整数的浮点值。
返回：
舍入为最接近的 int 值的参数值。
另请参见：
Integer.MAX_VALUE, Integer.MIN_VALUE

round

public static long round(double a)
返回最接近参数的 long。结果将舍入为整数：加上 1/2，对结果调用 floor 并将所得结果强制转换为 long 类型。换句话说，结果等于以下表达式的值：

(long)Math.floor(a + 0.5d)

特殊情况如下：

  • 如果参数为 NaN，那么结果为 0。
  • 如果参数为负无穷大或任何小于等于 Long.MIN_VALUE 的值，那么结果等于 Long.MIN_VALUE 的值。
  • 如果参数为正无穷大或任何大于等于 Long.MAX_VALUE 的值，那么结果等于 Long.MAX_VALUE 的值。

参数：
a - 舍入为 long 的浮点值。
返回：
舍入为最接近的 long 值的参数值。
另请参见：
Long.MAX_VALUE, Long.MIN_VALUE

random

public static double random()
返回带有正号的 double 值，该值大于等于 0.0 且小于 1.0。返回值是一个伪随机选择的数，在上述范围内（近似）均匀分布。

第一次调用该方法时，它将创建一个新的伪随机数生成器，与以下表达式完全相同

new java.util.Random
。之后，新的伪随机数生成器可用于此方法的所有调用，但不能用于其他地方。

此方法是完全同步的，可允许多个线程使用而不出现错误。但是，如果许多线程需要以极高的速率生成伪随机数，那么这可能会减少每个线程对拥有自己伪随机数生成器的争用。

返回：
大于等于 0.0 且小于 1.0 的伪随机 double 数。
另请参见：
Random.nextDouble()

abs

public static int abs(int a)
返回 int 值的绝对值。如果参数不是负数，则返回该参数。如果参数为负数，则返回该参数的相反数。

注意，如果参数等于 Integer.MIN_VALUE 的值，即能够表示的最小负 int 值，那么结果与该值相同且为负。

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。
另请参见：
Integer.MIN_VALUE

abs

public static long abs(long a)
返回 long 值的绝对值。如果参数不是负数，则返回该参数。如果参数为负数，则返回该参数的相反数。

注意，如果参数等于 Long.MIN_VALUE 的值，即能够表示的最小负 long 值，那么结果与该值相同且为负。

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。
另请参见：
Long.MIN_VALUE

abs

public static float abs(float a)
返回 float 值的绝对值。如果参数不是负数，则返回该参数。如果参数为负数，则返回该参数的相反数。特殊情况如下：
  • 如果参数为正 0 或负 0，那么结果为正 0。
  • 如果参数为无穷大，那么结果为正无穷大。
  • 如果参数为 NaN，那么结果为 NaN。
换句话说，结果等于以下表达式的值：

Float.intBitsToFloat(0x7fffffff & Float.floatToIntBits(a))

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。

abs

public static double abs(double a)
返回 double 值的绝对值。如果参数不是负数，则返回该参数。如果参数为负数，则返回该参数的相反数。特殊情况如下：
  • 如果参数为正 0 或负 0，那么结果为正 0。
  • 如果参数为无穷大，那么结果为正无穷大。
  • 如果参数为 NaN，那么结果为 NaN。
换句话说，结果等于以下表达式的值：

Double.longBitsToDouble((Double.doubleToLongBits(a)<<1)>>>1)

参数：
a - 要确定绝对值的参数。
返回：
参数的绝对值。

max

public static int max(int a,
                      int b)
返回两个 int 值中较大的一个。也就是说，结果为更接近 Integer.MAX_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中大的较大者。
另请参见：
Long.MAX_VALUE

max

public static long max(long a,
                       long b)
返回两个 long 值中较大的一个。也就是说，结果为更接近 Long.MAX_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较大者。
另请参见：
Long.MAX_VALUE

max

public static float max(float a,
                        float b)
返回两个 float 值中较大的一个。也就是说，结果为更接近正无穷大的参数。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，此方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为正 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较大者。

max

public static double max(double a,
                         double b)
返回两个 double 值中较大的一个。也就是说，结果为更接近正无穷大的参数。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，此方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为正 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较大者。

min

public static int min(int a,
                      int b)
返回两个 int 值中较小的一个。也就是说，结果为更接近 Integer.MIN_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。
另请参见：
Long.MIN_VALUE

min

public static long min(long a,
                       long b)
返回两个 long 值中较小的一个。也就是说，结果为更接近 Long.MIN_VALUE 值的参数。如果参数值相同，那么结果也是同一个值。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。
另请参见：
Long.MIN_VALUE

min

public static float min(float a,
                        float b)
返回两个 float 值中较小的一个。也就是说，结果为更接近负无穷大的值。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，此方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为负 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。

min

public static double min(double a,
                         double b)
返回两个 double 值中较小的一个。也就是说，结果为更接近负无穷大的值。如果参数值相同，那么结果也是同一个值。如果任一值为 NaN，那么结果为 NaN。与数值比较运算不同，此方法认为负 0 严格小于正 0。如果一个参数为正 0，另一个参数为负 0，那么结果为负 0。

参数：
a - 参数。
b - 另一个参数。
返回：
a 和 b 中的较小者。

ulp

public static double ulp(double d)
返回参数的 ulp 大小。double 值的 ulp 是此浮点值与下一个数值较大的 double 值之间的正距离。注意，对于非 NaN x，ulp(-x) == ulp(x)。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正的或负的无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为 Double.MIN_VALUE。
  • 如果参数为 ±Double.MAX_VALUE，那么结果等于 2971。

参数：
d - 要返回其 ulp 的浮点值。
返回：
参数的 ulp 大小。
从以下版本开始：
1.5

ulp

public static float ulp(float f)
返回参数的 ulp 大小。float 值的 ulp 是该浮点值与下一个数值较大的 float 值之间的正距离。注意，对于非 NaN x，ulp(-x) == ulp(x)。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正的或负无穷大，那么结果为正无穷大。
  • 如果参数为正 0 或负 0，那么结果为 Float.MIN_VALUE。
  • 如果参数为 ±Float.MAX_VALUE，那么结果等于 2104。

参数：
d - 要返回其 ulp 的浮点值。
返回：
参数的 ulp 大小。
从以下版本开始：
1.5

signum

public static double signum(double d)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0；如果参数小于 0，则返回 -1.0。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正 0 或负 0，那么结果与参数相同。

参数：
d - 要返回其符号函数的浮点值。
返回：
参数的符号函数。
从以下版本开始：
1.5

signum

public static float signum(float f)
返回参数的符号函数；如果参数为 0，则返回 0；如果参数大于 0，则返回 1.0f；如果参数小于 0，则返回 -1.0f。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正 0 或负 0，那么结果与参数相同。

参数：
d - 要返回其符号函数的浮点值。
返回：
参数的符号函数。
从以下版本开始：
1.5

sinh

public static double sinh(double x)
返回 double 值的双曲线正弦。x 的双曲线正弦的定义是(ex - e-x)/2，其中e 是 欧拉数。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为无穷大，那么结果为无穷大，符号与参数符号相同。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
x - 要返回其双曲线正弦的数。
返回：
x 的双曲线正弦。
从以下版本开始：
1.5

cosh

public static double cosh(double x)
返回 double 值的双曲线余弦。x 的双曲线余弦的定义是 (ex + e-x)/2，其中e 是欧拉数。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为无穷大，那么结果为正无穷大。
  • 如果参数为 0，那么结果为 1.0。

参数：
x - 要返回其双曲线余弦的数。
返回：
x 的双曲线余弦。
从以下版本开始：
1.5

tanh

public static double tanh(double x)
返回 double 值的双曲线正切。x 的双曲线正切的定义是 (ex - e-x)/(ex + e-x)，即 sinh(x)/cosh(x)。注意，准确的双曲正切绝对值始终小于 1。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。
  • 如果参数为正无穷大，那么结果为 +1.0。
  • 如果参数为负无穷大，那么结果为 -1.0。

参数：
x - 要返回其双曲线正切的数。
返回：
x 的双曲线正切。
从以下版本开始：
1.5

hypot

public static double hypot(double x,
                           double y)
返回 sqrt(x2 +y2)，没有中间溢出或下溢。

特殊情况如下：

  • 如果两个参数都是无穷大，那么结果为正无穷大。
  • 如果两个参数都是 NaN 且都不是无穷大，那么结果为 NaN。

参数：
x - 一个值。
y - 一个值。
返回：
sqrt(x2 +y2) ，没有中间溢出或下溢
从以下版本开始：
1.5

expm1

public static double expm1(double x)
返回 ex -1。注意，对于接近 0 的 x 值，expm1(x) + 1 的准确和比 exp(x) 更接近 ex 的真实结果。

特殊情况如下：

  • 如果参数为 NaN，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为负无穷大，那么结果为 -1.0。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
x - 在 ex -1 的计算中 e 的指数。
返回：
值 ex - 1。
从以下版本开始：
1.5

log1p

public static double log1p(double x)
返回参数与 1 之和的自然对数。注意，对于小的 x 值，log1p(x) 的结果比 log(1.0+x) 的浮点计算结果更接近 ln(1 + x) 的实际结果。

特殊情况如下：

  • 如果参数为 NaN 或小于 -1，那么结果为 NaN。
  • 如果参数为正无穷大，那么结果为正无穷大。
  • 如果参数为负数，那么结果为负无穷大。
  • 如果参数为 0，那么结果为 0，符号与参数符号相同。

参数：
x - 一个值。
返回：
值 ln(x + 1)，即 x + 1 的自然对数。
从以下版本开始：
1.5

copySign

public static double copySign(double magnitude,
                              double sign)
返回带有第二个浮点参数符号的第一个浮点参数。对于此方法，总是将 NaN sign 参数视为正。

参数：
magnitude - 提供结果数值的参数
sign - 提供结果符号的参数
返回：
一个值，带有 magnitude 的数值，sign 的符号。
从以下版本开始：
1.6

copySign

public static float copySign(float magnitude,
                             float sign)
返回带有第二个浮点参数符号的第一个浮点参数。对于此方法，总是将 NaN sign 参数视为正。

参数：
magnitude - 提供结果数值的参数
sign - 提供结果符号的参数
返回：
一个值，带有 magnitude 的数值，sign 的符号。
从以下版本开始：
1.6

getExponent

public static int getExponent(float f)
返回 float 表示形式中使用的无偏指数。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 Float.MAX_EXPONENT + 1。
  • 如果参数为 0 或 subnormal，那么结果为 Float.MIN_EXPONENT -1。

参数：
f - 一个 float 值
从以下版本开始：
1.6

getExponent

public static int getExponent(double d)
返回 double 表示形式中使用的无偏指数。特殊情况如下：
  • 如果参数为 NaN 或无穷大，那么结果为 Double.MAX_EXPONENT + 1。
  • 如果参数为 0 或 subnormal，那么结果为 Double.MIN_EXPONENT -1。

参数：
d - 一个 double 值
从以下版本开始：
1.6

nextAfter

public static double nextAfter(double start,
                               double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。如果两个参数比较起来相等，则返回第二个参数。

特殊情况如下：

  • 如果任一参数为 NaN，则返回 NaN。
  • 如果两个参数都是有符号的 0，则不做更改地返回 direction（根据要求，如果参数比较起来相等，将返回第二个参数）。
  • 如果 start 为 ±Double.MIN_VALUE，而 direction 的值要求结果为一个比 start 小的数值，那么将返回 0，并带有与 start 相同的符号。
  • 如果 start 为无穷大，而 direction 的值要求结果为一个比 start 小的数值，则返回 Double.MAX_VALUE，并带有与 start 相同的符号。
  • 如果 start 等于 ±Double.MAX_VALUE，而 direction 的值要求结果为一个比 start 大的数值，则返回无穷大，并带有与 start 相同的符号。

参数：
start - 起始浮点值。
direction - 一个值，指示应返回 start 的某个邻数还是 start。
返回：
start 和 direction 之间与 start 相邻的浮点数。
从以下版本开始：
1.6

nextAfter

public static float nextAfter(float start,
                              double direction)
返回第一个参数和第二个参数之间与第一个参数相邻的浮点数。如果两个参数比较起来相等，则返回一个与第二个参数相等的值。

特殊情况如下：

  • 如果任一参数为 NaN，则返回 NaN。
  • 如果两个参数都是有符号的 0，则返回等于 direction 的值。
  • 如果 start 为 ±Float.MIN_VALUE，而 direction 的值要求结果为一个比 start 小的数值，那么将返回 0，并带有与 start 相同的符号。
  • 如果 start 为无穷大，而 direction 的值要求结果为一个比 start 小的数值，则返回 Float.MAX_VALUE，并带有与 start 相同的符号。
  • 如果 start 等于 ±Float.MAX_VALUE，而 direction 的值要求结果为一个比 start 大的数值，则返回无穷大，并带有与 start 相同的符号。

参数：
start - 起始浮点值
direction - 一个值，指示应返回 start 的某个邻数还是 start。
返回：
start 和 direction 之间与 start 相邻的浮点数。
从以下版本开始：
1.6

nextUp

public static double nextUp(double d)
返回 d 和正无穷大之间与 d 相邻的浮点值。此方法在语义上等同于 nextAfter(d, Double.POSITIVE_INFINITY)；但是，nextUp 实现的返回速度可能比其等价 nextAfter 调用快。

特殊情况如下：

  • 如果参数为 NaN，则结果为 NaN。
  • 如果参数为正无穷大，则结果为正无穷大。
  • 如果参数为 0，则结果为 Double.MIN_VALUE。

参数：
d - 起始浮点值
返回：
离正无穷大较近的相邻浮点值。
从以下版本开始：
1.6

nextUp

public static float nextUp(float f)
返回 f 和正无穷大之间与 f 相邻的浮点值。此方法在语义上等同于 nextAfter(f, Float.POSITIVE_INFINITY)；但是，nextUp 实现的返回速度可能比其等价 nextAfter 调用快。

特殊情况如下：

  • 如果参数为 NaN，则结果为 NaN。
  • 如果参数为正无穷大，则结果为正无穷大。
  • 如果参数为 0，则结果为 Float.MIN_VALUE

参数：
f - 起始浮点值
返回：
离正无穷大较近的相邻浮点值。
从以下版本开始：
1.6

scalb

public static double scalb(double d,
                           int scaleFactor)
返回 d × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 double 值集合中的一个值。有关浮点值集合的讨论，请参阅 Java 语言规范。如果结果的指数在 Double.MIN_EXPONENT 和 Double.MAX_EXPONENT 之间，则可以正确地计算答案；如果结果的指数大于 Double.MAX_EXPONENT，则返回无穷大。注意，如果结果为 subnormal，则可能丢失精度；也就是说，scalb(x, n) 为 subnormal 时，scalb(scalb(x, n), -n) 可能不等于 x。结果为非 NaN 时，结果的符号将与 d 相同。

特殊情况如下：

  • 如果第一个参数为 NaN，则返回 NaN。
  • 如果第一个参数为无穷大，则返回带有相同符号的无穷大。
  • 如果第一个参数为 0，则返回带有相同符号的 0。

参数：
d - 要使用 2 的次幂缩放的数。
scaleFactor - 用来缩放 d 的 2 的次幂
返回：
d × 2scaleFactor
从以下版本开始：
1.6

scalb

public static float scalb(float f,
                          int scaleFactor)
返回 f × 2scaleFactor，其舍入方式如同将一个正确舍入的浮点值乘到 float 值集合中的一个值。有关浮点值集合的讨论，请参阅 Java 语言规范。如果结果的指数在 Float.MIN_EXPONENT 和 Float.MAX_EXPONENT 之间，则可以正确地计算答案；如果结果的指数大于 Float.MAX_EXPONENT，则返回无穷大。注意，如果结果为 subnormal，则可能丢失精度；也就是说，scalb(x, n) 为 subnormal 时，scalb(scalb(x, n), -n) 可能不等于 x。结果为非 NaN 时，结果的符号将与 f 相同。

特殊情况如下：

  • 如果第一个参数为 NaN，则返回 NaN。
  • 如果第一个参数为无穷大，则返回带有相同符号的无穷大。
  • 如果第一个参数为 0，则返回带有相同符号的 0。

参数：
f - 要使用 2 的次幂缩放的数。
scaleFactor - 用来缩放 f 的 2 的次幂
返回：
f × 2scaleFactor
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


String (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 String

java.lang.Object
    继承者  java.lang.String
所有已实现的接口：
Serializable, CharSequence, Comparable<String>
public final class String
extends Object
implements Serializable, Comparable<String>, CharSequence

String 类代表字符串。Java 程序中的所有字符串字面值（如 "abc" ）都作为此类的实例实现。

字符串是常量；它们的值在创建之后不能更改。字符串缓冲区支持可变的字符串。因为 String 对象是不可变的，所以可以共享。例如：

     String str = "abc";

等效于：

     char data[] = {'a', 'b', 'c'};
     String str = new String(data);

下面给出了一些如何使用字符串的更多示例：

     System.out.println("abc");
     String cde = "cde";
     System.out.println("abc" + cde);
     String c = "abc".substring(2,3);
     String d = cde.substring(1, 2);

String 类包括的方法可用于检查序列的单个字符、比较字符串、搜索字符串、提取子字符串、创建字符串副本并将所有字符全部转换为大写或小写。大小写映射基于 Character 类指定的 Unicode 标准版。

Java 语言提供对字符串串联符号（"+"）以及将其他对象转换为字符串的特殊支持。字符串串联是通过 StringBuilder（或 StringBuffer）类及其 append 方法实现的。字符串转换是通过 toString 方法实现的，该方法由 Object 类定义，并可被 Java 中的所有类继承。有关字符串串联和转换的更多信息，请参阅 Gosling、Joy 和 Steele 合著的 The Java Language Specification。

除非另行说明，否则将 null 参数传递给此类中的构造方法或方法将抛出 NullPointerException。

String 表示一个 UTF-16 格式的字符串，其中的增补字符 由代理项对 表示（有关详细信息，请参阅 Character 类中的 Unicode 字符表示形式）。索引值是指 char 代码单元，因此增补字符在 String 中占用两个位置。

String 类提供处理 Unicode 代码点（即字符）和 Unicode 代码单元（即 char 值）的方法。

从以下版本开始：
JDK1.0
另请参见：
Object.toString(), StringBuffer, StringBuilder, Charset, 序列化表格

字段摘要
static Comparator<String> CASE_INSENSITIVE_ORDER
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。
构造方法摘要
String()
初始化一个新创建的 String 对象，使其表示一个空字符序列。
String(byte[] bytes)
通过使用平台的默认字符集解码指定的 byte 数组，构造一个新的 String。
String(byte[] bytes, Charset charset)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(byte[] ascii, int hibyte)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[] bytes, int offset, int length)
通过使用平台的默认字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[] bytes, int offset, int length, Charset charset)
通过使用指定的 charset 解码指定的 byte 子数组，构造一个新的 String。
String(byte[] ascii, int hibyte, int offset, int count)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[] bytes, int offset, int length, String charsetName)
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。
String(byte[] bytes, String charsetName)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(char[] value)
分配一个新的 String，使其表示字符数组参数中当前包含的字符序列。
String(char[] value, int offset, int count)
分配一个新的 String，它包含取自字符数组参数一个子数组的字符。
String(int[] codePoints, int offset, int count)
分配一个新的 String，它包含 Unicode 代码点数组参数一个子数组的字符。
String(String original)
初始化一个新创建的 String 对象，使其表示一个与参数相同的字符序列；换句话说，新创建的字符串是该参数字符串的副本。
String(StringBuffer buffer)
分配一个新的字符串，它包含字符串缓冲区参数中当前包含的字符序列。
String(StringBuilder builder)
分配一个新的字符串，它包含字符串生成器参数中当前包含的字符序列。
方法摘要
 char charAt(int index)
返回指定索引处的 char 值。
 int codePointAt(int index)
返回指定索引处的字符（Unicode 代码点）。
 int codePointBefore(int index)
返回指定索引之前的字符（Unicode 代码点）。
 int codePointCount(int beginIndex, int endIndex)
返回此 String 的指定文本范围中的 Unicode 代码点数。
 int compareTo(String anotherString)
按字典顺序比较两个字符串。
 int compareToIgnoreCase(String str)
按字典顺序比较两个字符串，不考虑大小写。
 String concat(String str)
将指定字符串连接到此字符串的结尾。
 boolean contains(CharSequence s)
当且仅当此字符串包含指定的 char 值序列时，返回 true。
 boolean contentEquals(CharSequence cs)
将此字符串与指定的 CharSequence 比较。
 boolean contentEquals(StringBuffer sb)
将此字符串与指定的 StringBuffer 比较。
static String copyValueOf(char[] data)
返回指定数组中表示该字符序列的 String。
static String copyValueOf(char[] data, int offset, int count)
返回指定数组中表示该字符序列的 String。
 boolean endsWith(String suffix)
测试此字符串是否以指定的后缀结束。
 boolean equals(Object anObject)
将此字符串与指定的对象比较。
 boolean equalsIgnoreCase(String anotherString)
将此 String 与另一个 String 比较，不考虑大小写。
static String format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。
static String format(String format, Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。
 byte[] getBytes()
使用平台的默认字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。
 byte[] getBytes(Charset charset)
使用给定的 charset 将此 String 编码到 byte 序列，并将结果存储到新的 byte 数组。
 void getBytes(int srcBegin, int srcEnd, byte[] dst, int dstBegin)
已过时。 该方法无法将字符正确转换为字节。从 JDK 1.1 起，完成该转换的首选方法是通过 getBytes() 方法，该方法使用平台的默认字符集。
 byte[] getBytes(String charsetName)
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。
 void getChars(int srcBegin, int srcEnd, char[] dst, int dstBegin)
将字符从此字符串复制到目标字符数组。
 int hashCode()
返回此字符串的哈希码。
 int indexOf(int ch)
返回指定字符在此字符串中第一次出现处的索引。
 int indexOf(int ch, int fromIndex)
返回在此字符串中第一次出现指定字符处的索引，从指定的索引开始搜索。
 int indexOf(String str)
返回指定子字符串在此字符串中第一次出现处的索引。
 int indexOf(String str, int fromIndex)
返回指定子字符串在此字符串中第一次出现处的索引，从指定的索引开始。
 String intern()
返回字符串对象的规范化表示形式。
 boolean isEmpty()
当且仅当 length() 为 0 时返回 true。
 int lastIndexOf(int ch)
返回指定字符在此字符串中最后一次出现处的索引。
 int lastIndexOf(int ch, int fromIndex)
返回指定字符在此字符串中最后一次出现处的索引，从指定的索引处开始进行反向搜索。
 int lastIndexOf(String str)
返回指定子字符串在此字符串中最右边出现处的索引。
 int lastIndexOf(String str, int fromIndex)
返回指定子字符串在此字符串中最后一次出现处的索引，从指定的索引开始反向搜索。
 int length()
返回此字符串的长度。
 boolean matches(String regex)
告知此字符串是否匹配给定的正则表达式。
 int offsetByCodePoints(int index, int codePointOffset)
返回此 String 中从给定的 index 处偏移 codePointOffset 个代码点的索引。
 boolean regionMatches(boolean ignoreCase, int toffset, String other, int ooffset, int len)
测试两个字符串区域是否相等。
 boolean regionMatches(int toffset, String other, int ooffset, int len)
测试两个字符串区域是否相等。
 String replace(char oldChar, char newChar)
返回一个新的字符串，它是通过用 newChar 替换此字符串中出现的所有 oldChar 得到的。
 String replace(CharSequence target, CharSequence replacement)
使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。
 String replaceAll(String regex, String replacement)
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。
 String replaceFirst(String regex, String replacement)
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。
 String[] split(String regex)
根据给定正则表达式的匹配拆分此字符串。
 String[] split(String regex, int limit)
根据匹配给定的正则表达式来拆分此字符串。
 boolean startsWith(String prefix)
测试此字符串是否以指定的前缀开始。
 boolean startsWith(String prefix, int toffset)
测试此字符串从指定索引开始的子字符串是否以指定前缀开始。
 CharSequence subSequence(int beginIndex, int endIndex)
返回一个新的字符序列，它是此序列的一个子序列。
 String substring(int beginIndex)
返回一个新的字符串，它是此字符串的一个子字符串。
 String substring(int beginIndex, int endIndex)
返回一个新字符串，它是此字符串的一个子字符串。
 char[] toCharArray()
将此字符串转换为一个新的字符数组。
 String toLowerCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为小写。
 String toLowerCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。
 String toString()
返回此对象本身（它已经是一个字符串！）。
 String toUpperCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为大写。
 String toUpperCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。
 String trim()
返回字符串的副本，忽略前导空白和尾部空白。
static String valueOf(boolean b)
返回 boolean 参数的字符串表示形式。
static String valueOf(char c)
返回 char 参数的字符串表示形式。
static String valueOf(char[] data)
返回 char 数组参数的字符串表示形式。
static String valueOf(char[] data, int offset, int count)
返回 char 数组参数的特定子数组的字符串表示形式。
static String valueOf(double d)
返回 double 参数的字符串表示形式。
static String valueOf(float f)
返回 float 参数的字符串表示形式。
static String valueOf(int i)
返回 int 参数的字符串表示形式。
static String valueOf(long l)
返回 long 参数的字符串表示形式。
static String valueOf(Object obj)
返回 Object 参数的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

CASE_INSENSITIVE_ORDER

public static final Comparator<String> CASE_INSENSITIVE_ORDER
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。此比较器是可序列化的。

注意，Comparator 不 考虑语言环境，因此可能导致在某些语言环境中的排序效果不理想。java.text 包提供 Collator 完成与语言环境有关的排序。

从以下版本开始：
1.2
另请参见：
Collator.compare(String, String)
构造方法详细信息

String

public String()
初始化一个新创建的 String 对象，使其表示一个空字符序列。注意，由于 String 是不可变的，所以无需使用此构造方法。

String

public String(String original)
初始化一个新创建的 String 对象，使其表示一个与参数相同的字符序列；换句话说，新创建的字符串是该参数字符串的副本。由于 String 是不可变的，所以无需使用此构造方法，除非需要 original 的显式副本。

参数：
original - 一个 String。

String

public String(char[] value)
分配一个新的 String，使其表示字符数组参数中当前包含的字符序列。该字符数组的内容已被复制；后续对字符数组的修改不会影响新创建的字符串。

参数：
value - 字符串的初始值

String

public String(char[] value,
              int offset,
              int count)
分配一个新的 String，它包含取自字符数组参数一个子数组的字符。offset 参数是子数组第一个字符的索引，count 参数指定子数组的长度。该子数组的内容已被复制；后续对字符数组的修改不会影响新创建的字符串。

参数：
value - 作为字符源的数组。
offset - 初始偏移量。
count - 长度。
抛出：
IndexOutOfBoundsException - 如果 offset 和 count 参数索引字符超出 value 数组的范围。

String

public String(int[] codePoints,
              int offset,
              int count)
分配一个新的 String，它包含 Unicode 代码点数组参数一个子数组的字符。offset 参数是该子数组第一个代码点的索引，count 参数指定子数组的长度。将该子数组的内容转换为 char；后续对 int 数组的修改不会影响新创建的字符串。

参数：
codePoints - 作为 Unicode 代码点的源的数组。
offset - 初始偏移量。
count - 长度。
抛出：
IllegalArgumentException - 如果在 codePoints 中发现任何无效的 Unicode 代码点
IndexOutOfBoundsException - 如果 offset 和 count 参数索引字符超出 codePoints 数组的范围。
从以下版本开始：
1.5

String

@Deprecated
public String(byte[] ascii,
                         int hibyte,
                         int offset,
                         int count)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。

分配一个新的 String，它是根据一个 8 位整数值数组的子数组构造的。

offset 参数是该子数组的第一个 byte 的索引，count 参数指定子数组的长度。

子数组中的每个 byte 都按照上述方法转换为 char。

参数：
ascii - 要转换为字符的 byte。
hibyte - 每个 16 位 Unicode 代码单元的前 8 位。
offset - 初始偏移量。
count - 长度。
抛出：
IndexOutOfBoundsException - 如果 offset 或 count 参数无效。
另请参见：
String(byte[], int),
String(byte[], int, int, java.lang.String),
String(byte[], int, int, java.nio.charset.Charset),
String(byte[], int, int),
String(byte[], java.lang.String),
String(byte[], java.nio.charset.Charset),
String(byte[])

String

@Deprecated
public String(byte[] ascii,
                         int hibyte)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。

分配一个新的 String，它包含根据一个 8 位整数值数组构造的字符。所得字符串中的每个字符 c 都是根据 byte 数组中的相应组件 b 构造的，如下所示：
     c == (char)(((hibyte & 0xff) << 8)
                         | (b & 0xff))

参数：
ascii - 要转换为字符的 byte。
hibyte - 每个 16 位 Unicode 代码单元的前 8 位。
另请参见：
String(byte[], int, int, java.lang.String),
String(byte[], int, int, java.nio.charset.Charset),
String(byte[], int, int),
String(byte[], java.lang.String),
String(byte[], java.nio.charset.Charset),
String(byte[])

String

public String(byte[] bytes,
              int offset,
              int length,
              String charsetName)
       throws UnsupportedEncodingException
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。新 String 的长度是一个字符集函数，因此可能不等于子数组的长度。

当给定 byte 在给定字符集中无效的情况下，此构造方法的行为没有指定。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

参数：
bytes - 要解码为字符的 byte
offset - 要解码的第一个 byte 的索引
length - 要解码的 byte 数
charsetName - 受支持 charset 的名称
抛出：
UnsupportedEncodingException - 如果指定的字符集不受支持
IndexOutOfBoundsException - 如果 offset 和 length 参数索引字符超出 bytes 数组的范围
从以下版本开始：
JDK1.1

String

public String(byte[] bytes,
              int offset,
              int length,
              Charset charset)
通过使用指定的 charset 解码指定的 byte 子数组，构造一个新的 String。新 String 的长度是字符集的函数，因此可能不等于子数组的长度。

此方法总是使用此字符集的默认替代字符串替代错误输入 (malformed-input) 和不可映射字符 (unmappable-character) 序列。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

参数：
bytes - 要解码为字符的 byte
offset - 要解码的第一个 byte 的索引
length - 要解码的 byte 数
charset - 用来解码 bytes 的 charset
抛出：
IndexOutOfBoundsException - 如果 offset 和 length 参数索引字符超出 bytes 数组的边界
从以下版本开始：
1.6

String

public String(byte[] bytes,
              String charsetName)
       throws UnsupportedEncodingException
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。新 String 的长度是字符集的函数，因此可能不等于 byte 数组的长度。

当给定 byte 在给定字符集中无效的情况下，此构造方法的行为没有指定。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

参数：
bytes - 要解码为字符的 byte
charsetName - 受支持的 charset 的名称
抛出：
UnsupportedEncodingException - 如果指定字符集不受支持
从以下版本开始：
JDK1.1

String

public String(byte[] bytes,
              Charset charset)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。新 String 的长度是字符集的函数，因此可能不等于 byte 数组的长度。

此方法总是使用此字符集的默认替代字符串替代错误输入和不可映射字符序列。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

参数：
bytes - 要解码为字符的 byte
charset - 要用来解码 bytes 的 charset
从以下版本开始：
1.6

String

public String(byte[] bytes,
              int offset,
              int length)
通过使用平台的默认字符集解码指定的 byte 子数组，构造一个新的 String。新 String 的长度是字符集的函数，因此可能不等于该子数组的长度。

当给定 byte 在给定字符集中无效的情况下，此构造方法的行为没有指定。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

参数：
bytes - 要解码为字符的 byte
offset - 要解码的第一个 byte 的索引
length - 要解码的 byte 数
抛出：
IndexOutOfBoundsException - 如果 offset 和 length 参数索引字符超出 bytes 数组的范围
从以下版本开始：
JDK1.1

String

public String(byte[] bytes)
通过使用平台的默认字符集解码指定的 byte 数组，构造一个新的 String。新 String 的长度是字符集的函数，因此可能不等于 byte 数组的长度。

当给定 byte 在给定字符集中无效的情况下，此构造方法的行为没有指定。如果需要对解码过程进行更多控制，则应该使用 CharsetDecoder 类。

参数：
bytes - 要解码为字符的 byte
从以下版本开始：
JDK1.1

String

public String(StringBuffer buffer)
分配一个新的字符串，它包含字符串缓冲区参数中当前包含的字符序列。该字符串缓冲区的内容已被复制，后续对它的修改不会影响新创建的字符串。

参数：
buffer - 一个 StringBuffer

String

public String(StringBuilder builder)
分配一个新的字符串，它包含字符串生成器参数中当前包含的字符序列。该字符串生成器的内容已被复制，后续对它的修改不会影响新创建的字符串。

提供此构造方法是为了简化到 StringBuilder 的迁移。通过 toString 方法从字符串生成器中获取字符串可能运行的更快，因此通常作为首选。

参数：
builder - 一个 StringBuilder
从以下版本开始：
1.5
方法详细信息

length

public int length()
返回此字符串的长度。长度等于字符串中 Unicode 代码单元的数量。

指定者：
接口 CharSequence 中的 length
返回：
此对象表示的字符序列的长度。

isEmpty

public boolean isEmpty()
当且仅当 length() 为 0 时返回 true。

返回：
如果 length() 为 0，则返回 true；否则返回 false。
从以下版本开始：
1.6

charAt

public char charAt(int index)
返回指定索引处的 char 值。索引范围为从 0 到 length() - 1。序列的第一个 char 值位于索引 0 处，第二个位于索引 1 处，依此类推，这类似于数组索引。

如果索引指定的 char 值是代理项，则返回代理项值。

指定者：
接口 CharSequence 中的 charAt
参数：
index - char 值的索引。
返回：
此字符串指定索引处的 char 值。第一个 char 值位于索引 0 处。
抛出：
IndexOutOfBoundsException - 如果 index 参数为负或小于此字符串的长度。

codePointAt

public int codePointAt(int index)
返回指定索引处的字符（Unicode 代码点）。索引引用 char 值（Unicode 代码单元），其范围从 0 到 length() - 1。

如果给定索引指定的 char 值属于高代理项范围，则后续索引小于此 String 的长度；如果后续索引处的 char 值属于低代理项范围，则返回该代理项对相应的增补代码点。否则，返回给定索引处的 char 值。

参数：
index - char 值的索引
返回：
index 处字符的代码点值
抛出：
IndexOutOfBoundsException - 如果 index 参数为负或小于此字符串的长度。
从以下版本开始：
1.5

codePointBefore

public int codePointBefore(int index)
返回指定索引之前的字符（Unicode 代码点）。索引引用 char 值（Unicode 代码单元），其范围从 1 到 length。

如果 (index - 1) 处的 char 值属于低代理项范围，则 (index - 2) 为非负；如果 (index - 2) 处的 char 值属于高低理项范围，则返回该代理项对的增补代码点值。如果 index - 1 处的 char 值是未配对的低（高）代理项，则返回代理项值。

参数：
index - 应返回的代码点之后的索引
返回：
给定索引前面的 Unicode 代码点。
抛出：
IndexOutOfBoundsException - 如果 index 参数小于 1 或大于此字符串的长度。
从以下版本开始：
1.5

codePointCount

public int codePointCount(int beginIndex,
                          int endIndex)
返回此 String 的指定文本范围中的 Unicode 代码点数。文本范围始于指定的 beginIndex，一直到索引 endIndex - 1 处的 char。因此，该文本范围的长度（用 char 表示）是 endIndex-beginIndex。该文本范围内每个未配对的代理项计为一个代码点。

参数：
beginIndex - 文本范围的第一个 char 的索引。
endIndex - 文本范围的最后一个 char 之后的索引。
返回：
指定文本范围中 Unicode 代码点的数量
抛出：
IndexOutOfBoundsException - 如果 beginIndex 为负，或 endIndex 大于此 String 的长度，或 beginIndex 大于 endIndex。
从以下版本开始：
1.5

offsetByCodePoints

public int offsetByCodePoints(int index,
                              int codePointOffset)
返回此 String 中从给定的 index 处偏移 codePointOffset 个代码点的索引。文本范围内由 index 和 codePointOffset 给定的未配对代理项各计为一个代码点。

参数：
index - 要偏移的索引
codePointOffset - 代码点中的偏移量
返回：
String 的索引
抛出：
IndexOutOfBoundsException - 如果 index 为负或大于此 String 的长度；或者 codePointOffset 为正，且以 index 开头子字符串的代码点比 codePointOffset 少；如果 codePointOffset 为负，且 index 前面子字符串的代码点比 codePointOffset 的绝对值少。
从以下版本开始：
1.5

getChars

public void getChars(int srcBegin,
                     int srcEnd,
                     char[] dst,
                     int dstBegin)
将字符从此字符串复制到目标字符数组。

要复制的第一个字符位于索引 srcBegin 处；要复制的最后一个字符位于索引 srcEnd-1 处（因此要复制的字符总数是 srcEnd-srcBegin）。要复制到 dst 子数组的字符从索引 dstBegin 处开始，并结束于索引：

     dstbegin + (srcEnd-srcBegin) - 1

参数：
srcBegin - 字符串中要复制的第一个字符的索引。
srcEnd - 字符串中要复制的最后一个字符之后的索引。
dst - 目标数组。
dstBegin - 目标数组中的起始偏移量。
抛出：
IndexOutOfBoundsException - 如果下列任何一项为 true：
  • srcBegin 为负。
  • srcBegin 大于 srcEnd
  • srcEnd 大于此字符串的长度
  • dstBegin 为负
  • dstBegin+(srcEnd-srcBegin) 大于 dst.length

getBytes

@Deprecated
public void getBytes(int srcBegin,
                                int srcEnd,
                                byte[] dst,
                                int dstBegin)
已过时。 该方法无法将字符正确转换为字节。从 JDK 1.1 起，完成该转换的首选方法是通过 getBytes() 方法，该方法使用平台的默认字符集。

将字符从此字符串复制到目标 byte 数组中。每个 byte 接收相应字符的 8 个低位。不复制每个字符的高位，它们不参与任何方式的转换。

要复制的第一个字符位于索引 srcBegin 处；要复制的最后一个字符位于索引 srcEnd-1 处。要复制的字符总数为 srcEnd-srcBegin。将转换为 byte 的字符复制到 dst 的子数组中，从索引 dstBegin 处开始，并结束于索引：

     dstbegin + (srcEnd-srcBegin) - 1

参数：
srcBegin - 字符串中要复制的第一个字符的索引
srcEnd - 字符串中要复制的最后一个字符之后的索引
dst - 目标数组
dstBegin - 目标数组中的起始偏移量
抛出：
IndexOutOfBoundsException - 如果下列任何一项为 true：
  • srcBegin 为负
  • srcBegin 大于 srcEnd
  • srcEnd 大于此 String 的长度
  • dstBegin 为负
  • dstBegin+(srcEnd-srcBegin) 大于 dst.length

getBytes

public byte[] getBytes(String charsetName)
                throws UnsupportedEncodingException
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。

当此字符串不能使用给定的字符集编码时，此方法的行为没有指定。如果需要对编码过程进行更多控制，则应该使用 CharsetEncoder 类。

参数：
charsetName - 受支持的 charset 名称
返回：
所得 byte 数组
抛出：
UnsupportedEncodingException - 如果指定的字符集不受支持
从以下版本开始：
JDK1.1

getBytes

public byte[] getBytes(Charset charset)
使用给定的 charset 将此 String 编码到 byte 序列，并将结果存储到新的 byte 数组。

此方法总是使用此字符集的默认替代 byte 数组替代错误输入和不可映射字符序列。如果需要对编码过程进行更多控制，则应该使用 CharsetEncoder 类。

参数：
charset - 用于编码 String 的 Charset
返回：
所得 byte 数组
从以下版本开始：
1.6

getBytes

public byte[] getBytes()
使用平台的默认字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。

当此字符串不能使用默认的字符集编码时，此方法的行为没有指定。如果需要对编码过程进行更多控制，则应该使用 CharsetEncoder 类。

返回：
所得 byte 数组
从以下版本开始：
JDK1.1

equals

public boolean equals(Object anObject)
将此字符串与指定的对象比较。当且仅当该参数不为 null，并且是与此对象表示相同字符序列的 String 对象时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
anObject - 与此 String 进行比较的对象。
返回：
如果给定对象表示的 String 与此 String 相等，则返回 true；否则返回 false。
另请参见：
compareTo(String), equalsIgnoreCase(String)

contentEquals

public boolean contentEquals(StringBuffer sb)
将此字符串与指定的 StringBuffer 比较。当且仅当此 String 与指定 StringBuffer 表示相同的字符序列时，结果才为 true。

参数：
sb - 要与此 String 比较的 StringBuffer。
返回：
如果此 String 与指定 StringBuffer 表示相同的字符序列，则返回 true；否则返回 false。
从以下版本开始：
1.4

contentEquals

public boolean contentEquals(CharSequence cs)
将此字符串与指定的 CharSequence 比较。当且仅当此 String 与指定序列表示相同的 char 值序列时，结果才为 true。

参数：
cs - 要与此 String 比较的序列
返回：
如果此 String 与指定序列表示相同的 char 值序列，则返回 true；否则返回 false。
从以下版本开始：
1.5

equalsIgnoreCase

public boolean equalsIgnoreCase(String anotherString)
将此 String 与另一个 String 比较，不考虑大小写。如果两个字符串的长度相同，并且其中的相应字符都相等（忽略大小写），则认为这两个字符串是相等的。

在忽略大小写的情况下，如果下列至少一项为 true，则认为 c1 和 c2 这两个字符相同。

  • 这两个字符相同（使用 == 运算符进行比较）。
  • 对每个字符应用方法 Character.toUpperCase(char) 生成相同的结果。
  • 对每个字符应用方法 Character.toLowerCase(char) 生成相同的结果。

参数：
anotherString - 与此 String 进行比较的 String。
返回：
如果参数不为 null，且这两个 String 相等（忽略大小写），则返回 true；否则返回 false。
另请参见：
equals(Object)

compareTo

public int compareTo(String anotherString)
按字典顺序比较两个字符串。该比较基于字符串中各个字符的 Unicode 值。按字典顺序将此 String 对象表示的字符序列与参数字符串所表示的字符序列进行比较。如果按字典顺序此 String 对象位于参数字符串之前，则比较结果为一个负整数。如果按字典顺序此 String 对象位于参数字符串之后，则比较结果为一个正整数。如果这两个字符串相等，则结果为 0；compareTo 只在方法 equals(Object) 返回 true 时才返回 0。

这是字典排序的定义。如果这两个字符串不同，那么它们要么在某个索引处的字符不同（该索引对二者均为有效索引），要么长度不同，或者同时具备这两种情况。如果它们在一个或多个索引位置上的字符不同，假设 k 是这类索引的最小值；则在位置 k 上具有较小值的那个字符串（使用 < 运算符确定），其字典顺序在其他字符串之前。在这种情况下，compareTo 返回这两个字符串在位置 k 处两个char 值的差，即值：

 this.charAt(k)-anotherString.charAt(k)
如果没有字符不同的索引位置，则较短字符串的字典顺序在较长字符串之前。在这种情况下，compareTo 返回这两个字符串长度的差，即值：
 this.length()-anotherString.length()

指定者：
接口 Comparable<String> 中的 compareTo
参数：
anotherString - 要比较的 String。
返回：
如果参数字符串等于此字符串，则返回值 0；如果此字符串按字典顺序小于字符串参数，则返回一个小于 0 的值；如果此字符串按字典顺序大于字符串参数，则返回一个大于 0 的值。

compareToIgnoreCase

public int compareToIgnoreCase(String str)
按字典顺序比较两个字符串，不考虑大小写。此方法返回一个整数，其符号与使用规范化的字符串调用 compareTo 所得符号相同，规范化字符串的大小写差异已通过对每个字符调用 Character.toLowerCase(Character.toUpperCase(character)) 消除。

注意，此方法不 考虑语言环境，因此可能导致在某些语言环境中的排序效果不理想。java.text 包提供 Collators 完成与语言环境有关的排序。

参数：
str - 要比较的 String。
返回：
根据指定 String 大于、等于还是小于此 String（不考虑大小写），分别返回一个负整数、0 或一个正整数。
从以下版本开始：
1.2
另请参见：
Collator.compare(String, String)

regionMatches

public boolean regionMatches(int toffset,
                             String other,
                             int ooffset,
                             int len)
测试两个字符串区域是否相等。

将此 String 对象的一个子字符串与参数 other 的一个子字符串进行比较。如果这两个子字符串表示相同的字符序列，则结果为 true。要比较的此 String 对象的子字符串从索引 toffset 处开始，长度为 len。要比较的 other 的子字符串从索引 ooffset 处开始，长度为 len。当且仅当下列至少一项为 true 时，结果才为 false ：

  • toffset 为负。
  • ooffset 为负。
  • toffset+len 大于此 String 对象的长度。
  • ooffset+len 大于另一个参数的长度。
  • 存在某个小于 len 的非负整数 k，它满足：this.charAt(toffset+k) != other.charAt(ooffset+k)

参数：
toffset - 字符串中子区域的起始偏移量。
other - 字符串参数。
ooffset - 字符串参数中子区域的起始偏移量。
len - 要比较的字符数。
返回：
如果此字符串的指定子区域完全匹配字符串参数的指定子区域，则返回 true；否则返回 false。

regionMatches

public boolean regionMatches(boolean ignoreCase,
                             int toffset,
                             String other,
                             int ooffset,
                             int len)
测试两个字符串区域是否相等。

将此 String 对象的子字符串与参数 other 的子字符串进行比较。如果这两个子字符串表示相同的字符序列，则结果为 true，当且仅当 ignoreCase 为 true 时忽略大小写。要比较的此 String 对象的子字符串从索引 toffset 处开始，长度为 len。要比较的 other 的子字符串从索引 ooffset 处开始，长度为 len。当且仅当下列至少一项为 true 时，结果才为 false：

  • toffset 为负。
  • ooffset 为负。
  • toffset+len 大于此 String 对象的长度。
  • ooffset+len 大于另一个参数的长度。
  • ignoreCase 为 false，且存在某个小于 len 的非负整数 k，即：
     this.charAt(toffset+k) != other.charAt(ooffset+k)
  • ignoreCase 为 true，且存在某个小于 len 的非负整数 k，即：
     Character.toLowerCase(this.charAt(toffset+k)) !=
               Character.toLowerCase(other.charAt(ooffset+k))
    以及：
     Character.toUpperCase(this.charAt(toffset+k)) !=
         Character.toUpperCase(other.charAt(ooffset+k))

参数：
ignoreCase - 如果为 true，则比较字符时忽略大小写。
toffset - 此字符串中子区域的起始偏移量。
other - 字符串参数。
toffset - 字符串参数中子区域的起始偏移量。
len - 要比较的字符数。
返回：
如果此字符串的指定子区域匹配字符串参数的指定子区域，则返回 true；否则返回 false。是否完全匹配或考虑大小写取决于 ignoreCase 参数。

startsWith

public boolean startsWith(String prefix,
                          int toffset)
测试此字符串从指定索引开始的子字符串是否以指定前缀开始。

参数：
prefix - 前缀。
toffset - 在此字符串中开始查找的位置。
返回：
如果参数表示的字符序列是此对象从索引 toffset 处开始的子字符串前缀，则返回 true；否则返回 false。如果 toffset 为负或大于此 String 对象的长度，则结果为 false；否则结果与以下表达式的结果相同：
          this.substring(toffset).startsWith(prefix)

startsWith

public boolean startsWith(String prefix)
测试此字符串是否以指定的前缀开始。

参数：
prefix - 前缀。
返回：
如果参数表示的字符序列是此字符串表示的字符序列的前缀，则返回 true；否则返回 false。还要注意，如果参数是空字符串，或者等于此 String 对象（用 equals(Object) 方法确定），则返回 true。
从以下版本开始：
1. 0

endsWith

public boolean endsWith(String suffix)
测试此字符串是否以指定的后缀结束。

参数：
suffix - 后缀。
返回：
如果参数表示的字符序列是此对象表示的字符序列的后缀，则返回 true；否则返回 false。注意，如果参数是空字符串，或者等于此 String 对象（用 equals(Object) 方法确定），则结果为 true。

hashCode

public int hashCode()
返回此字符串的哈希码。String 对象的哈希码根据以下公式计算：
 s[0]*31^(n-1) + s[1]*31^(n-2) + ... + s[n-1]
使用 int 算法，这里 s[i] 是字符串的第 i 个字符，n 是字符串的长度，^ 表示求幂。（空字符串的哈希值为 0。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

indexOf

public int indexOf(int ch)
返回指定字符在此字符串中第一次出现处的索引。如果在此 String 对象表示的字符序列中出现值为 ch 的字符，则返回第一次出现该字符的索引（以 Unicode 代码单元表示）。对于 0 到 0xFFFF（包括 0 和 0xFFFF）范围内的 ch 的值，返回值是
 this.charAt(k) == ch
为 true 的最小 k 值。对于其他 ch 值，返回值是
 this.codePointAt(k) == ch
为 true 最小 k 值。无论哪种情况，如果此字符串中没有这样的字符，则返回 -1。

参数：
ch - 一个字符（Unicode 代码点）。
返回：
在此对象表示的字符序列中第一次出现该字符的索引；如果未出现该字符，则返回 -1。

indexOf

public int indexOf(int ch,
                   int fromIndex)
返回在此字符串中第一次出现指定字符处的索引，从指定的索引开始搜索。

在此 String 对象表示的字符序列中，如果带有值 ch 的字符的索引不小于 fromIndex，则返回第一次出现该值的索引。对于 0 到 0xFFFF（包括 0 和 0xFFFF）范围内的 ch 值，返回值是

 (this.charAt(k) == ch) && (k >= fromIndex)
为 true 的最小 k 值。对于其他 ch 值，返回值是
 (this.codePointAt(k) == ch) && (k >= fromIndex)
为 true 的最小 k 值。无论哪种情况，如果此字符串中 fromIndex 或之后的位置没有这样的字符出现，则返回 -1。

fromIndex 的值没有限制。如果它为负，则与它为 0 的效果同样：将搜索整个字符串。如果它大于此字符串的长度，则与它等于此字符串长度的效果相同：返回 -1。

所有索引都在 char 值中指定（Unicode 代码单元）。

参数：
ch - 一个字符（Unicode 代码点）。
fromIndex - 开始搜索的索引。
返回：
在此对象表示的字符序列中第一次出现的大于或等于 fromIndex 的字符的索引；如果未出现该字符，则返回 -1。

lastIndexOf

public int lastIndexOf(int ch)
返回指定字符在此字符串中最后一次出现处的索引。对于 0 到 0xFFFF（包括 0 和 0xFFFF）范围内的 ch 的值，返回的索引（Unicode 代码单元）是
 this.charAt(k) == ch
为 true 最大 k 值。对于其他 ch 值，返回值是
 this.codePointAt(k) == ch
为 true 的最大 k 值。无论哪种情况，如果此字符串中没有这样的字符出现，则返回 -1。从最后一个字符开始反向搜索此 String。

参数：
ch - 一个字符（Unicode 代码点）。
返回：
在此对象表示的字符序列中最后一次出现该字符的索引；如果未出现该字符，则返回 -1。

lastIndexOf

public int lastIndexOf(int ch,
                       int fromIndex)
返回指定字符在此字符串中最后一次出现处的索引，从指定的索引处开始进行反向搜索。对于 0 到 0xFFFF（包括 0 和 0xFFFF）范围内的 ch 值，返回的索引是
 (this.charAt(k) == ch) && (k <= fromIndex)
为 true 的最大 k 值。对于 ch 的其他值，返回值是
 (this.codePointAt(k) == ch) && (k <= fromIndex)
为 true 的最大 k 值。无论哪种情况，如果此字符串中 fromIndex 或之前的位置没有这样的字符出现，则返回 -1。

所有的索引都以 char 值指定（Unicode 代码单元）。

参数：
ch - 一个字符（Unicode 代码点）。
fromIndex - 开始搜索的索引。fromIndex 的值没有限制。如果它大于等于此字符串的长度，则与它小于此字符串长度减 1 的效果相同：将搜索整个字符串。如果它为负，则与它为 -1 的效果相同：返回 -1。
返回：
在此对象表示的字符序列（小于等于 fromIndex）中最后一次出现该字符的索引；如果在该点之前未出现该字符，则返回 -1。

indexOf

public int indexOf(String str)
返回指定子字符串在此字符串中第一次出现处的索引。返回的整数是
 this.startsWith(str, k)
为 true 的最小 k 值。

参数：
str - 任意字符串。
返回：
如果字符串参数作为一个子字符串在此对象中出现，则返回第一个这种子字符串的第一个字符的索引；如果它不作为一个子字符串出现，则返回 -1。

indexOf

public int indexOf(String str,
                   int fromIndex)
返回指定子字符串在此字符串中第一次出现处的索引，从指定的索引开始。返回的整数是满足下式的最小 k 值：
     k >= Math.min(fromIndex, this.length()) && this.startsWith(str, k)
如果不存在这样的 k 值，则返回 -1。

参数：
str - 要搜索的子字符串。
fromIndex - 开始搜索的索引位置。
返回：
指定子字符串在此字符串中第一次出现处的索引，从指定的索引开始。

lastIndexOf

public int lastIndexOf(String str)
返回指定子字符串在此字符串中最右边出现处的索引。将最右边的空字符串 "" 视为出现在索引值 this.length() 处。返回的索引是
 this.startsWith(str, k)
为 true 的最大 k 值。

参数：
str - 要搜索的子字符串。
返回：
如果字符串参数作为一个子字符串在此对象中出现一次或多次，则返回最后一个这种子字符串的第一个字符。如果它不作为一个子字符串出现，则返回 -1。

lastIndexOf

public int lastIndexOf(String str,
                       int fromIndex)
返回指定子字符串在此字符串中最后一次出现处的索引，从指定的索引开始反向搜索。返回的整数是满足下式的最大 k 值：
     k <= Math.min(fromIndex,this.length()) && this.startsWith(str, k)
如果不存在这样的 k 值，则返回 -1。

参数：
str - 要搜索的子字符串。
fromIndex - 开始搜索的索引位置。
返回：
指定子字符串在此字符串中最后一次出现处的索引。

substring

public String substring(int beginIndex)
返回一个新的字符串，它是此字符串的一个子字符串。该子字符串从指定索引处的字符开始，直到此字符串末尾。

示例：

 "unhappy".substring(2) returns "happy"
 "Harbison".substring(3) returns "bison"
 "emptiness".substring(9) returns "" (an empty string)

参数：
beginIndex - 起始索引（包括）。
返回：
指定的子字符串。
抛出：
IndexOutOfBoundsException - 如果 beginIndex 为负或大于此 String 对象的长度。

substring

public String substring(int beginIndex,
                        int endIndex)
返回一个新字符串，它是此字符串的一个子字符串。该子字符串从指定的 beginIndex 处开始，直到索引 endIndex - 1 处的字符。因此，该子字符串的长度为 endIndex-beginIndex。

示例：

 "hamburger".substring(4, 8) returns "urge"
 "smiles".substring(1, 5) returns "mile"

参数：
beginIndex - 起始索引（包括）。
endIndex - 结束索引（不包括）。
返回：
指定的子字符串。
抛出：
IndexOutOfBoundsException - 如果 beginIndex 为负，或 endIndex 大于此 String 对象的长度，或 beginIndex 大于 endIndex。

subSequence

public CharSequence subSequence(int beginIndex,
                                int endIndex)
返回一个新的字符序列，它是此序列的一个子序列。

此方法这种形式的调用：

 str.subSequence(begin, end)
与以下调用的行为完全相同：
 str.substring(begin, end)
定义此方法使 String 类能够实现 CharSequence 接口。

指定者：
接口 CharSequence 中的 subSequence
参数：
beginIndex - 起始索引（包括）。
endIndex - 结束索引（不包括）。
返回：
指定子序列。
抛出：
IndexOutOfBoundsException - 如果 beginIndex 或 endIndex 为负，如果 endIndex 大于 length() 或 beginIndex 大于 startIndex
从以下版本开始：
1.4

concat

public String concat(String str)
将指定字符串连接到此字符串的结尾。

如果参数字符串的长度为 0，则返回此 String 对象。否则，创建一个新的 String 对象，用来表示由此 String 对象表示的字符序列和参数字符串表示的字符序列连接而成的字符序列。

示例：

 "cares".concat("s") returns "caress"
 "to".concat("get").concat("her") returns "together"

参数：
str - 连接到此 String 结尾的 String。
返回：
一个字符串，它表示在此对象字符后连接字符串参数字符而成的字符。

replace

public String replace(char oldChar,
                      char newChar)
返回一个新的字符串，它是通过用 newChar 替换此字符串中出现的所有 oldChar 得到的。

如果 oldChar 在此 String 对象表示的字符序列中没有出现，则返回对此 String 对象的引用。否则，创建一个新的 String 对象，它所表示的字符序列除了所有的 oldChar 都被替换为 newChar 之外，与此 String 对象表示的字符序列相同。

示例：

"mesquite in your cellar".replace('e', 'o')
         returns "mosquito in your collar"
 "the war of baronets".replace('r', 'y')
         returns "the way of bayonets"
 "sparring with a purple porpoise".replace('p', 't')
         returns "starring with a turtle tortoise"
 "JonL".replace('q', 'x') returns "JonL" (no change)

参数：
oldChar - 原字符。
newChar - 新字符。
返回：
一个从此字符串派生的字符串，它将此字符串中的所有 oldChar 替代为 newChar。

matches

public boolean matches(String regex)
告知此字符串是否匹配给定的正则表达式。

调用此方法的 str.matches(regex) 形式与以下表达式产生的结果完全相同：

Pattern.matches(regex, str)

参数：
regex - 用来匹配此字符串的正则表达式
返回：
当且仅当此字符串匹配给定的正则表达式时，返回 true
抛出：
PatternSyntaxException - 如果正则表达式的语法无效
从以下版本开始：
1.4
另请参见：
Pattern

contains

public boolean contains(CharSequence s)
当且仅当此字符串包含指定的 char 值序列时，返回 true。

参数：
s - 要搜索的序列
返回：
如果此字符串包含 s，则返回 true，否则返回 false
抛出：
NullPointerException - 如果 s 为 null
从以下版本开始：
1.5

replaceFirst

public String replaceFirst(String regex,
                           String replacement)
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。

调用此方法的 str.replaceFirst(regex, repl) 形式与以下表达式产生的结果完全相同：

Pattern.compile(regex).matcher(str).replaceFirst(repl)

注意，在替代字符串中使用反斜杠 (\) 和美元符号 ($) 与将其视为字面值替代字符串所得的结果可能不同；请参阅 Matcher.replaceFirst(java.lang.String)。如有需要，可使用 Matcher.quoteReplacement(java.lang.String) 取消这些字符的特殊含义。

参数：
regex - 用来匹配此字符串的正则表达式
replacement - 用来替换第一个匹配项的字符串
返回：
所得 String
抛出：
PatternSyntaxException - 如果正则表达式的语法无效
从以下版本开始：
1.4
另请参见：
Pattern

replaceAll

public String replaceAll(String regex,
                         String replacement)
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。

调用此方法的 str.replaceAll(regex, repl) 形式与以下表达式产生的结果完全相同：

Pattern.compile(regex).matcher(str).replaceAll(repl)

注意，在替代字符串中使用反斜杠 (\) 和美元符号 ($) 与将其视为字面值替代字符串所得的结果可能不同；请参阅 Matcher.replaceAll。如有需要，可使用 Matcher.quoteReplacement(java.lang.String) 取消这些字符的特殊含义。

参数：
regex - 用来匹配此字符串的正则表达式
replacement - 用来替换每个匹配项的字符串
返回：
所得 String
抛出：
PatternSyntaxException - 如果正则表达式的语法无效
从以下版本开始：
1.4
另请参见：
Pattern

replace

public String replace(CharSequence target,
                      CharSequence replacement)
使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。该替换从字符串的开头朝末尾执行，例如，用 "b" 替换字符串 "aaa" 中的 "aa" 将生成 "ba" 而不是 "ab"。

参数：
target - 要被替换的 char 值序列
replacement - char 值的替换序列
返回：
所得 String
抛出：
NullPointerException - 如果 target 或 replacement 为 null。
从以下版本开始：
1.5

split

public String[] split(String regex,
                      int limit)
根据匹配给定的正则表达式来拆分此字符串。

此方法返回的数组包含此字符串的子字符串，每个子字符串都由另一个匹配给定表达式的子字符串终止，或者由此字符串末尾终止。数组中的子字符串按它们在此字符串中出现的顺序排列。如果表达式不匹配输入的任何部分，那么所得数组只具有一个元素，即此字符串。

limit 参数控制模式应用的次数，因此影响所得数组的长度。如果该限制 n 大于 0，则模式将被最多应用 n - 1 次，数组的长度将不会大于 n，而且数组的最后一项将包含所有超出最后匹配的定界符的输入。如果 n 为非正，那么模式将被应用尽可能多的次数，而且数组可以是任何长度。如果 n 为 0，那么模式将被应用尽可能多的次数，数组可以是任何长度，并且结尾空字符串将被丢弃。

例如，字符串 "boo:and:foo" 使用这些参数可生成以下结果：

Regex | Limit | 结果
: 2 { "boo", "and:foo" }
: 5 { "boo", "and", "foo" }
: -2 { "boo", "and", "foo" }
o | 5 | { "b", "", ":and:f", "", "" }
o | -2 | { "b", "", ":and:f", "", "" }
o | 0 | { "b", "", ":and:f" }

调用此方法的 str.split(regex, n) 形式与以下表达式产生的结果完全相同：

Pattern.compile (regex).split (str, n)

参数：
regex - 定界正则表达式
limit - 结果阈值，如上所述
返回：
字符串数组，它是根据给定正则表达式的匹配拆分此字符串确定的
抛出：
PatternSyntaxException - 如果正则表达式的语法无效
从以下版本开始：
1.4
另请参见：
Pattern

split

public String[] split(String regex)
根据给定正则表达式的匹配拆分此字符串。

该方法的作用就像是使用给定的表达式和限制参数 0 来调用两参数 split 方法。因此，所得数组中不包括结尾空字符串。

例如，字符串 "boo:and:foo" 使用这些表达式可生成以下结果：

Regex | 结果
: { "boo", "and", "foo" }
o | { "b", "", ":and:f" }

参数：
regex - 定界正则表达式
返回：
字符串数组，它是根据给定正则表达式的匹配拆分此字符串确定的
抛出：
PatternSyntaxException - 如果正则表达式的语法无效
从以下版本开始：
1.4
另请参见：
Pattern

toLowerCase

public String toLowerCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。大小写映射关系基于 Character 类指定的 Unicode 标准版。由于大小写映射关系并不总是 1:1 的字符映射关系，因此所得 String 的长度可能不同于原 String。

下表中给出了几个小写映射关系的示例：

语言环境的代码 | 大写字母 | 小写字母 | 描述
tr (Turkish) | \u0130 | \u0069 | 大写字母 I，上面有点 -> 小写字母 i
tr (Turkish) | \u0049 | \u0131 | 大写字母 I -> 小写字母 i，无点
(all) | French Fries | french fries | 将字符串中的所有字符都小写
(all) | 将字符串中的所有字符都小写

参数：
locale - 使用此语言环境的大小写转换规则
返回：
要转换为小写的 String。
从以下版本开始：
1.1
另请参见：
toLowerCase(),
toUpperCase(),
toUpperCase(Locale)

toLowerCase

public String toLowerCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为小写。这等效于调用 toLowerCase(Locale.getDefault())。

注： 此方法与语言环境有关，如果用于应独立于语言环境解释的字符串，则可能生成不可预料的结果。 示例有编程语言标识符、协议键、HTML 标记。 例如，"TITLE".toLowerCase() 在 Turkish（土耳其语）语言环境中返回 "t?tle"，其中“?”是 LATIN SMALL LETTER DOTLESS I 字符。 对于与语言环境有关的字符，要获得正确的结果，请使用 toLowerCase(Locale.ENGLISH)。

返回：
要转换为小写的 String。
另请参见：
toLowerCase(Locale)

toUpperCase

public String toUpperCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。大小写映射关系基于 Character 类指定的 Unicode 标准版。由于大小写映射关系并不总是 1:1 的字符映射关系，因此所得 String 的长度可能不同于原 String。

下表中给出了几个与语言环境有关和 1:M 大小写映射关系的一些示例。

语言环境的代码 | 小写 | 大写 | 描述
tr (Turkish) | \u0069 | \u0130 | 小写字母 i -> 大写字母 I，上面有点
tr (Turkish) | \u0131 | \u0049 | 小写字母 i，无点 -> 大写字母 I
(all) | \u00df | \u0053 \u0053 | 小写字母 sharp s -> 两个字母：SS
(all) | Fahrvergnügen | FAHRVERGNÜN

参数：
locale - 使用此语言环境的大小写转换规则
返回：
要转换为大写的 String。
从以下版本开始：
1.1
另请参见：
toUpperCase(),
toLowerCase(),
toLowerCase(Locale)

toUpperCase

public String toUpperCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为大写。此方法等效于 toUpperCase(Locale.getDefault())。

注： 此方法与语言环境有关，如果用于应独立于语言环境解释的字符串，则可能生成不可预料的结果。 示例有编程语言标识符、协议键、HTML 标记。 例如，"title".toUpperCase() 在 Turkish（土耳其语）语言环境中返回 "T?TLE"，其中“?”是 LATIN CAPITAL LETTER I WITH DOT ABOVE 字符。 对于与语言环境有关的字符，要获得正确的结果，请使用 toUpperCase(Locale.ENGLISH)。

返回：
要转换为大写的 String。
另请参见：
toUpperCase(Locale)

trim

public String trim()
返回字符串的副本，忽略前导空白和尾部空白。

如果此 String 对象表示一个空字符序列，或者此 String 对象表示的字符序列的第一个和最后一个字符的代码都大于 '\u0020'（空格字符），则返回对此 String 对象的引用。

否则，若字符串中没有代码大于 '\u0020' 的字符，则创建并返回一个表示空字符串的新 String 对象。

否则，假定 k 为字符串中代码大于 '\u0020' 的第一个字符的索引，m 为字符串中代码大于 '\u0020' 的最后一个字符的索引。创建一个新的 String 对象，它表示此字符串中从索引 k 处的字符开始，到索引 m 处的字符结束的子字符串，即 this.substring(k, m+1) 的结果。

此方法可用于截去字符串开头和末尾的空白（如上所述）。

返回：
此字符串移除了前导和尾部空白的副本；如果没有前导和尾部空白，则返回此字符串。

toString

public String toString()
返回此对象本身（它已经是一个字符串！）。

指定者：
接口 CharSequence 中的 toString
覆盖：
类 Object 中的 toString
返回：
字符串本身。

toCharArray

public char[] toCharArray()
将此字符串转换为一个新的字符数组。

返回：
一个新分配的字符数组，它的长度是此字符串的长度，它的内容被初始化为包含此字符串表示的字符序列。

format

public static String format(String format,
                            Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。

始终使用 Locale.getDefault() 返回的语言环境。

参数：
format - 格式字符串
args - 格式字符串中由格式说明符引用的参数。如果还有格式说明符以外的参数，则忽略这些额外的参数。参数的数目是可变的，可以为 0。参数的最大数目受 Java Virtual Machine Specification 所定义的 Java 数组最大维度的限制。有关 null 参数的行为依赖于转换。
返回：
一个格式化字符串
抛出：
IllegalFormatException - 如果格式字符串中包含非法语法、与给定的参数不兼容的格式说明符，格式字符串给定的参数不够，或者存在其他非法条件。有关所有可能的格式化错误的规范，请参阅 formatter 类规范的详细信息 一节。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5
另请参见：
Formatter

format

public static String format(Locale l,
                            String format,
                            Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。

参数：
l - 格式化过程中要应用的语言环境。如果 l 为 null，则不进行本地化。
format - 格式字符串
args - 格式字符串中由格式说明符引用的参数。如果还有格式说明符以外的参数，则忽略这些额外的参数。参数的数目是可变的，可以为 0。参数的最大数目受 Java Virtual Machine Specification 所定义的 Java 数组最大维度的限制。有关 null 参数的行为依赖于转换。
返回：
一个格式化字符串
抛出：
IllegalFormatException - 如果格式字符串中包含非法语法、与给定参数不兼容的格式说明符，格式字符串给定的参数不够，或存在其他非法条件。有关所有可能的格式化错误的规范，请参阅 formatter 类规范的详细信息 一节。
NullPointerException - 如果 format 为 null
从以下版本开始：
1.5
另请参见：
Formatter

valueOf

public static String valueOf(Object obj)
返回 Object 参数的字符串表示形式。

参数：
obj - 一个 Object。
返回：
如果参数为 null，则字符串等于 "null"；否则，返回 obj.toString() 的值。
另请参见：
Object.toString()

valueOf

public static String valueOf(char[] data)
返回 char 数组参数的字符串表示形式。字符数组的内容已被复制，后续修改不会影响新创建的字符串。

参数：
data - char 数组。
返回：
一个新分配的字符串，它表示包含在字符数组参数中的相同字符序列。

valueOf

public static String valueOf(char[] data,
                             int offset,
                             int count)
返回 char 数组参数的特定子数组的字符串表示形式。

offset 参数是子数组的第一个字符的索引。count 参数指定子数组的长度。字符数组的内容已被复制，后续修改不会影响新创建的字符串。

参数：
data - 字符数组。
offset - String 值的初始偏移量。
count - String 值的长度。
返回：
一个字符串，它表示在字符数组参数的子数组中包含的字符序列。
抛出：
IndexOutOfBoundsException - 如果 offset 为负，count 为负，或者 offset+count 大于 data.length。

copyValueOf

public static String copyValueOf(char[] data,
                                 int offset,
                                 int count)
返回指定数组中表示该字符序列的 String。

参数：
data - 字符数组。
offset - 子数组的初始偏移量。
count - 子数组的长度。
返回：
一个 String，它包含字符数组的指定子数组的字符。

copyValueOf

public static String copyValueOf(char[] data)
返回指定数组中表示该字符序列的 String。

参数：
data - 字符数组。
返回：
一个 String，它包含字符数组的字符。

valueOf

public static String valueOf(boolean b)
返回 boolean 参数的字符串表示形式。

参数：
b - 一个 boolean。
返回：
如果参数为 true，则返回一个等于 "true" 的字符串；否则，返回一个等于 "false" 的字符串。

valueOf

public static String valueOf(char c)
返回 char 参数的字符串表示形式。

参数：
c - 一个 char。
返回：
一个长度为 1 的字符串，它包含参数 c 的单个字符。

valueOf

public static String valueOf(int i)
返回 int 参数的字符串表示形式。

该表示形式恰好是单参数的 Integer.toString 方法返回的结果。

参数：
i - 一个 int。
返回：
int 参数的字符串表示形式。
另请参见：
Integer.toString(int, int)

valueOf

public static String valueOf(long l)
返回 long 参数的字符串表示形式。

该表示形式恰好是单参数的 Long.toString 方法返回的结果。

参数：
l - 一个 long。
返回：
long 参数的字符串表示形式。
另请参见：
Long.toString(long)

valueOf

public static String valueOf(float f)
返回 float 参数的字符串表示形式。

该表示形式恰好是单参数的 Float.toString 方法返回的结果。

参数：
f - 一个 float。
返回：
float 参数的字符串表示形式。
另请参见：
Float.toString(float)

valueOf

public static String valueOf(double d)
返回 double 参数的字符串表示形式。

该表示形式恰好是单参数的 Double.toString 方法返回的结果。

参数：
d - 一个 double。
返回：
double 参数的字符串表示形式。
另请参见：
Double.toString(double)

intern

public String intern()
返回字符串对象的规范化表示形式。

一个初始为空的字符串池，它由类 String 私有地维护。

当调用 intern 方法时，如果池已经包含一个等于此 String 对象的字符串（用 equals(Object) 方法确定），则返回池中的字符串。否则，将此 String 对象添加到池中，并返回此 String 对象的引用。

它遵循以下规则：对于任意两个字符串 s 和 t，当且仅当 s.equals(t) 为 true 时，s.intern() == t.intern() 才为 true。

所有字面值字符串和字符串赋值常量表达式都使用 intern 方法进行操作。字符串字面值在 Java Language Specification 的 §3.10.5 定义。

返回：
一个字符串，内容与此字符串相同，但一定取自具有唯一字符串的池。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 StringBuffer

java.lang.Object
    继承者  java.lang.StringBuffer
所有已实现的接口：
Serializable, Appendable, CharSequence
public final class StringBuffer
extends Object
implements Serializable, CharSequence

线程安全的可变字符序列。一个类似于 String 的字符串缓冲区，但不能修改。虽然在任意时间点上它都包含某种特定的字符序列，但通过某些方法调用可以改变该序列的长度和内容。

可将字符串缓冲区安全地用于多个线程。可以在必要时对这些方法进行同步，因此任意特定实例上的所有操作就好像是以串行顺序发生的，该顺序与所涉及的每个线程进行的方法调用顺序一致。

StringBuffer 上的主要操作是 append 和 insert 方法，可重载这些方法，以接受任意类型的数据。每个方法都能有效地将给定的数据转换成字符串，然后将该字符串的字符添加或插入到字符串缓冲区中。append 方法始终将这些字符添加到缓冲区的末端；而 insert 方法则在指定的点添加字符。

例如，如果 z 引用一个当前内容是“start”的字符串缓冲区对象，则此方法调用 z.append("le") 会使字符串缓冲区包含“startle”，而 z.insert(4, "le") 将更改字符串缓冲区，使之包含“starlet”。

通常，如果 sb 引用 StringBuilder 的一个实例，则 sb.append(x) 和 sb.insert(sb.length(), x) 具有相同的效果。

只要发生有关源序列（如在源序列中添加或插入）的操作，该类就只在执行此操作的字符串缓冲区上而不是在源上实现同步。

每个字符串缓冲区都有一定的容量。只要字符串缓冲区所包含的字符序列的长度没有超出此容量，就无需分配新的内部缓冲区数组。如果内部缓冲区溢出，则此容量自动增大。从 JDK 5 开始，为该类补充了一个单个线程使用的等价类，即 StringBuilder。与该类相比，通常应该优先使用 StringBuilder 类，因为它支持所有相同的操作，但由于它不执行同步，所以速度更快。

从以下版本开始：
JDK1.0
另请参见：
StringBuilder, String, 序列化表格

构造方法摘要
StringBuffer()
构造一个其中不带字符的字符串缓冲区，初始容量为 16 个字符。
StringBuffer(CharSequence seq)
public java.lang.StringBuilder(CharSequence seq) 构造一个字符串缓冲区，它包含与指定的 CharSequence 相同的字符。
StringBuffer(int capacity)
构造一个不带字符，但具有指定初始容量的字符串缓冲区。
StringBuffer(String str)
构造一个字符串缓冲区，并将其内容初始化为指定的字符串内容。
方法摘要
StringBuffer | append(boolean b) Appends the string representation of the boolean argument to the sequence.
StringBuffer | append(char c) Appends the string representation of the char argument to this sequence.
StringBuffer | append(char[] str) Appends the string representation of the char array argument to this sequence.
StringBuffer | append(char[] str, int offset, int len) Appends the string representation of a subarray of the char array argument to this sequence.
StringBuffer | append(CharSequence s) 将指定的 CharSequence 添加到该序列。
StringBuffer | append(CharSequence s, int start, int end) Appends a subsequence of the specified CharSequence to this sequence.
StringBuffer | append(double d) Appends the string representation of the double argument to this sequence.
StringBuffer | append(float f) Appends the string representation of the float argument to this sequence.
StringBuffer | append(int i) Appends the string representation of the int argument to this sequence.
StringBuffer | append(long lng) Appends the string representation of the long argument to this sequence.
StringBuffer | append(Object obj) Appends the string representation of the Object argument.
StringBuffer | append(String str) Appends the specified string to this character sequence.
StringBuffer | append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列中。
StringBuffer | appendCodePoint(int codePoint) Appends the string representation of the codePoint argument to this sequence.
int | capacity() Returns the current capacity.
char | charAt(int index) Returns the char value in this sequence at the specified index.
int | codePointAt(int index) Returns the character (Unicode code point) at the specified index.
int | codePointBefore(int index) Returns the character (Unicode code point) before the specified index.
int | codePointCount(int beginIndex, int endIndex) Returns the number of Unicode code points in the specified text range of this sequence.
StringBuffer | delete(int start, int end) Removes the characters in a substring of this sequence.
StringBuffer | deleteCharAt(int index) Removes the char at the specified position in this sequence.
void | ensureCapacity(int minimumCapacity) Ensures that the capacity is at least equal to the specified minimum.
void | getChars(int srcBegin, int srcEnd, char[] dst, int dstBegin) Characters are copied from this sequence into the destination character array dst.
int | indexOf(String str) Returns the index within this string of the first occurrence of the specified substring.
int | indexOf(String str, int fromIndex) Returns the index within this string of the first occurrence of the specified substring, starting at the specified index.
StringBuffer | insert(int offset, boolean b) Inserts the string representation of the boolean argument into this sequence.
StringBuffer | insert(int offset, char c) Inserts the string representation of the char argument into this sequence.
StringBuffer | insert(int offset, char[] str) Inserts the string representation of the char array argument into this sequence.
StringBuffer | insert(int index, char[] str, int offset, int len) Inserts the string representation of a subarray of the str array argument into this sequence.
StringBuffer | insert(int dstOffset, CharSequence s) Inserts the specified CharSequence into this sequence.
StringBuffer | insert(int dstOffset, CharSequence s, int start, int end) Inserts a subsequence of the specified CharSequence into this sequence.
StringBuffer | insert(int offset, double d) Inserts the string representation of the double argument into this sequence.
StringBuffer | insert(int offset, float f) Inserts the string representation of the float argument into this sequence.
StringBuffer | insert(int offset, int i) Inserts the string representation of the second int argument into this sequence.
StringBuffer | insert(int offset, long l) Inserts the string representation of the long argument into this sequence.
StringBuffer | insert(int offset, Object obj) Inserts the string representation of the Object argument into this character sequence.
StringBuffer | insert(int offset, String str) Inserts the string into this character sequence.
int | lastIndexOf(String str) Returns the index within this string of the rightmost occurrence of the specified substring.
int | lastIndexOf(String str, int fromIndex) Returns the index within this string of the last occurrence of the specified substring.
int | length() Returns the length (character count).
int | offsetByCodePoints(int index, int codePointOffset) Returns the index within this sequence that is offset from the given index by codePointOffset code points.
StringBuffer | replace(int start, int end, String str) Replaces the characters in a substring of this sequence with characters in the specified String.
StringBuffer | reverse() Causes this character sequence to be replaced by the reverse of the sequence.
void | setCharAt(int index, char ch) The character at the specified index is set to ch.
void | setLength(int newLength) Sets the length of the character sequence.
CharSequence | subSequence(int start, int end) Returns a new character sequence that is a subsequence of this sequence.
String | substring(int start) Returns a new String that contains a subsequence of characters currently contained in this character sequence.
String | substring(int start, int end) Returns a new String that contains a subsequence of characters currently contained in this sequence.
String | toString() Returns a string representing the data in this sequence.
void | trimToSize() Attempts to reduce storage used for the character sequence.
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StringBuffer

public StringBuffer()
构造一个其中不带字符的字符串缓冲区，初始容量为 16 个字符。

StringBuffer

public StringBuffer(int capacity)
构造一个不带字符，但具有指定初始容量的字符串缓冲区。

参数：
capacity - 初始容量。
抛出：
NegativeArraySizeException - 如果 capacity 参数小于 0。

StringBuffer

public StringBuffer(String str)
构造一个字符串缓冲区，并将其内容初始化为指定的字符串内容。该字符串的初始容量为 16 加上字符串参数的长度。

参数：
str - 缓冲区的初始内容。
抛出：
NullPointerException - 如果 str 为 null

StringBuffer

public StringBuffer(CharSequence seq)
public java.lang.StringBuilder(CharSequence seq) 构造一个字符串缓冲区，它包含与指定的 CharSequence 相同的字符。该字符串缓冲区的初始容量为 16 加上 CharSequence 参数的长度。

如果指定的 CharSequence 的长度小于或等于 0，则返回容量为 16 的空缓冲区。

参数：
seq - 要复制的序列。
抛出：
NullPointerException - 如果 seq 为 null
从以下版本开始：
1.5
方法详细信息

length

public int length()
Returns the length (character count).

指定者：
接口 CharSequence 中的 length
返回：
the length of the sequence of characters currently represented by this object

capacity

public int capacity()
Returns the current capacity. The capacity is the amount of storage available for newly inserted characters, beyond which an allocation will occur.

返回：
the current capacity

ensureCapacity

public void ensureCapacity(int minimumCapacity)
Ensures that the capacity is at least equal to the specified minimum. If the current capacity is less than the argument, then a new internal array is allocated with greater capacity. The new capacity is the larger of:
  • The minimumCapacity argument.
  • Twice the old capacity, plus 2.
If the minimumCapacity argument is nonpositive, this method takes no action and simply returns.

参数：
minimumCapacity - the minimum desired capacity.

trimToSize

public void trimToSize()
Attempts to reduce storage used for the character sequence. If the buffer is larger than necessary to hold its current sequence of characters, then it may be resized to become more space efficient. Calling this method may, but is not required to, affect the value returned by a subsequent call to the capacity() method.

从以下版本开始：
1.5

setLength

public void setLength(int newLength)
Sets the length of the character sequence. The sequence is changed to a new character sequence whose length is specified by the argument. For every nonnegative index k less than newLength, the character at index k in the new character sequence is the same as the character at index k in the old sequence if k is less than the length of the old character sequence; otherwise, it is the null character '\u0000'. In other words, if the newLength argument is less than the current length, the length is changed to the specified length.

If the newLength argument is greater than or equal to the current length, sufficient null characters ('\u0000') are appended so that length becomes the newLength argument.

The newLength argument must be greater than or equal to 0.

参数：
newLength - the new length
抛出：
IndexOutOfBoundsException - if the newLength argument is negative.
另请参见：
length()

charAt

public char charAt(int index)
Returns the char value in this sequence at the specified index. The first char value is at index 0, the next at index 1, and so on, as in array indexing.

The index argument must be greater than or equal to 0, and less than the length of this sequence.

If the char value specified by the index is a surrogate, the surrogate value is returned.

指定者：
接口 CharSequence 中的 charAt
参数：
index - the index of the desired char value.
返回：
the char value at the specified index.
抛出：
IndexOutOfBoundsException - if index is negative or greater than or equal to length().
另请参见：
length()

codePointAt

public int codePointAt(int index)
Returns the character (Unicode code point) at the specified index. The index refers to char values (Unicode code units) and ranges from 0 to length() - 1.

If the char value specified at the given index is in the high-surrogate range, the following index is less than the length of this sequence, and the char value at the following index is in the low-surrogate range, then the supplementary code point corresponding to this surrogate pair is returned. Otherwise, the char value at the given index is returned.

参数：
index - the index to the char values
返回：
the code point value of the character at the index
从以下版本开始：
1.5

codePointBefore

public int codePointBefore(int index)
Returns the character (Unicode code point) before the specified index. The index refers to char values (Unicode code units) and ranges from 1 to length().

If the char value at (index - 1) is in the low-surrogate range, (index - 2) is not negative, and the char value at (index - 2) is in the high-surrogate range, then the supplementary code point value of the surrogate pair is returned. If the char value at index - 1 is an unpaired low-surrogate or a high-surrogate, the surrogate value is returned.

参数：
index - the index following the code point that should be returned
返回：
the Unicode code point value before the given index.
从以下版本开始：
1.5

codePointCount

public int codePointCount(int beginIndex,
                          int endIndex)
Returns the number of Unicode code points in the specified text range of this sequence. The text range begins at the specified beginIndex and extends to the char at index endIndex - 1. Thus the length (in chars) of the text range is endIndex-beginIndex. Unpaired surrogates within this sequence count as one code point each.

参数：
beginIndex - the index to the first char of the text range.
endIndex - the index after the last char of the text range.
返回：
the number of Unicode code points in the specified text range
从以下版本开始：
1.5

offsetByCodePoints

public int offsetByCodePoints(int index,
                              int codePointOffset)
Returns the index within this sequence that is offset from the given index by codePointOffset code points. Unpaired surrogates within the text range given by index and codePointOffset count as one code point each.

参数：
index - the index to be offset
codePointOffset - the offset in code points
返回：
the index within this sequence
从以下版本开始：
1.5

getChars

public void getChars(int srcBegin,
                     int srcEnd,
                     char[] dst,
                     int dstBegin)
Characters are copied from this sequence into the destination character array dst. The first character to be copied is at index srcBegin; the last character to be copied is at index srcEnd-1. The total number of characters to be copied is srcEnd-srcBegin. The characters are copied into the subarray of dst starting at index dstBegin and ending at index:

 dstbegin + (srcEnd-srcBegin) - 1

参数：
srcBegin - start copying at this offset.
srcEnd - stop copying at this offset.
dst - the array to copy the data into.
dstBegin - offset into dst.
抛出：
NullPointerException - if dst is null.
IndexOutOfBoundsException - if any of the following is true:
  • srcBegin is negative
  • dstBegin is negative
  • the srcBegin argument is greater than the srcEnd argument.
  • srcEnd is greater than this.length().
  • dstBegin+srcEnd-srcBegin is greater than dst.length

setCharAt

public void setCharAt(int index,
                      char ch)
The character at the specified index is set to ch. This sequence is altered to represent a new character sequence that is identical to the old character sequence, except that it contains the character ch at position index.

The index argument must be greater than or equal to 0, and less than the length of this sequence.

参数：
index - the index of the character to modify.
ch - the new character.
抛出：
IndexOutOfBoundsException - if index is negative or greater than or equal to length().
另请参见：
length()

append

public StringBuffer append(Object obj)
Appends the string representation of the Object argument.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
obj - an Object.
返回：
a reference to this object.
另请参见：
String.valueOf(java.lang.Object), append(java.lang.String)

append

public StringBuffer append(String str)
Appends the specified string to this character sequence.

The characters of the String argument are appended, in order, increasing the length of this sequence by the length of the argument. If str is null, then the four characters "null" are appended.

Let n be the length of this character sequence just prior to execution of the append method. Then the character at index k in the new character sequence is equal to the character at index k in the old character sequence, if k is less than n; otherwise, it is equal to the character at index k-n in the argument str.

参数：
str - a string.
返回：
a reference to this object.

append

public StringBuffer append(StringBuffer sb)
将指定的 StringBuffer 添加到此序列中。

按顺序将 StringBuffer 参数中的字符添加到此 StringBuffer 中，并使 StringBuffer 在长度上增加该参数的长度。如果 sb 为 null，则将 4 个 "null" 字符添加到此 StringBuffer 中。

在执行 append 方法前，让 StringBuffer 中包含的原有字符序列的长度为 n。如果 k 小于 n，则新字符序列中索引 k 处的字符等于原有字符序列中索引 k 处的字符；否则它等于参数 sb 中索引 k-n 处的字符。

该方法在 this（目标）对象上实现同步，但不在源上（sb）实现同步。

参数：
sb - 要添加的 StringBuffer。
返回：
该对象的一个引用。
从以下版本开始：
1.4

append

public StringBuffer append(CharSequence s)
将指定的 CharSequence 添加到该序列。

按顺序将 CharSequence 参数中的字符添加到该序列中，使该序列增加该参数的长度。

该方法的结果与调用 this.append(s, 0, s.length()) 完全相同；

该方法在 this（目标）对象上实现同步，但不在源上（s）实现同步。

如果 s 为 null，则添加 4 个 "null" 字符。

指定者：
接口 Appendable 中的 append
参数：
s - 要添加的 CharSequence。
返回：
此对象的一个引用。
从以下版本开始：
1.5

append

public StringBuffer append(CharSequence s,
                           int start,
                           int end)
Appends a subsequence of the specified CharSequence to this sequence.

Characters of the argument s, starting at index start, are appended, in order, to the contents of this sequence up to the (exclusive) index end. The length of this sequence is increased by the value of end - start.

Let n be the length of this character sequence just prior to execution of the append method. Then the character at index k in this character sequence becomes equal to the character at index k in this sequence, if k is less than n; otherwise, it is equal to the character at index k+start-n in the argument s.

If s is null, then this method appends characters as if the s parameter was a sequence containing the four characters "null".

指定者：
接口 Appendable 中的 append
参数：
s - the sequence to append.
start - the starting index of the subsequence to be appended.
end - the end index of the subsequence to be appended.
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if start or end are negative, or start is greater than end or end is greater than s.length()
从以下版本开始：
1.5

append

public StringBuffer append(char[] str)
Appends the string representation of the char array argument to this sequence.

The characters of the array argument are appended, in order, to the contents of this sequence. The length of this sequence increases by the length of the argument.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char[]) and the characters of that string were then appended to this character sequence.

参数：
str - the characters to be appended.
返回：
a reference to this object.

append

public StringBuffer append(char[] str,
                           int offset,
                           int len)
Appends the string representation of a subarray of the char array argument to this sequence.

Characters of the char array str, starting at index offset, are appended, in order, to the contents of this sequence. The length of this sequence increases by the value of len.

The overall effect is exactly as if the arguments were converted to a string by the method String.valueOf(char[],int,int) and the characters of that string were then appended to this character sequence.

参数：
str - the characters to be appended.
offset - the index of the first char to append.
len - the number of chars to append.
返回：
a reference to this object.

append

public StringBuffer append(boolean b)
Appends the string representation of the boolean argument to the sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
b - a boolean.
返回：
a reference to this object.
另请参见：
String.valueOf(boolean), append(java.lang.String)

append

public StringBuffer append(char c)
Appends the string representation of the char argument to this sequence.

The argument is appended to the contents of this sequence. The length of this sequence increases by 1.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char) and the character in that string were then appended to this character sequence.

指定者：
接口 Appendable 中的 append
参数：
c - a char.
返回：
a reference to this object.

append

public StringBuffer append(int i)
Appends the string representation of the int argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
i - an int.
返回：
a reference to this object.
另请参见：
String.valueOf(int), append(java.lang.String)

appendCodePoint

public StringBuffer appendCodePoint(int codePoint)
Appends the string representation of the codePoint argument to this sequence.

The argument is appended to the contents of this sequence. The length of this sequence increases by Character.charCount(codePoint).

The overall effect is exactly as if the argument were converted to a char array by the method Character.toChars(int) and the character in that array were then appended to this character sequence.

参数：
codePoint - a Unicode code point
返回：
a reference to this object.
从以下版本开始：
1.5

append

public StringBuffer append(long lng)
Appends the string representation of the long argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
lng - a long.
返回：
a reference to this object.
另请参见：
String.valueOf(long), append(java.lang.String)

append

public StringBuffer append(float f)
Appends the string representation of the float argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this string sequence.

参数：
f - a float.
返回：
a reference to this object.
另请参见：
String.valueOf(float), append(java.lang.String)

append

public StringBuffer append(double d)
Appends the string representation of the double argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
d - a double.
返回：
a reference to this object.
另请参见：
String.valueOf(double), append(java.lang.String)

delete

public StringBuffer delete(int start,
                           int end)
Removes the characters in a substring of this sequence. The substring begins at the specified start and extends to the character at index end - 1 or to the end of the sequence if no such character exists. If start is equal to end, no changes are made.

参数：
start - The beginning index, inclusive.
end - The ending index, exclusive.
返回：
This object.
抛出：
StringIndexOutOfBoundsException - if start is negative, greater than length(), or greater than end.
从以下版本开始：
1.2

deleteCharAt

public StringBuffer deleteCharAt(int index)
Removes the char at the specified position in this sequence. This sequence is shortened by one char.

Note: If the character at the given index is a supplementary character, this method does not remove the entire character. If correct handling of supplementary characters is required, determine the number of chars to remove by calling Character.charCount(thisSequence.codePointAt(index)), where thisSequence is this sequence.

参数：
index - Index of char to remove
返回：
This object.
抛出：
StringIndexOutOfBoundsException - if the index is negative or greater than or equal to length().
从以下版本开始：
1.2

replace

public StringBuffer replace(int start,
                            int end,
                            String str)
Replaces the characters in a substring of this sequence with characters in the specified String. The substring begins at the specified start and extends to the character at index end - 1 or to the end of the sequence if no such character exists. First the characters in the substring are removed and then the specified String is inserted at start. (This sequence will be lengthened to accommodate the specified String if necessary.)

参数：
start - The beginning index, inclusive.
end - The ending index, exclusive.
str - String that will replace previous contents.
返回：
This object.
抛出：
StringIndexOutOfBoundsException - if start is negative, greater than length(), or greater than end.
从以下版本开始：
1.2

substring

public String substring(int start)
Returns a new String that contains a subsequence of characters currently contained in this character sequence. The substring begins at the specified index and extends to the end of this sequence.

参数：
start - The beginning index, inclusive.
返回：
The new string.
抛出：
StringIndexOutOfBoundsException - if start is less than zero, or greater than the length of this object.
从以下版本开始：
1.2

subSequence

public CharSequence subSequence(int start,
                                int end)
Returns a new character sequence that is a subsequence of this sequence.

An invocation of this method of the form

 sb.subSequence(begin, end)
behaves in exactly the same way as the invocation
 sb.substring(begin, end)
This method is provided so that this class can implement the CharSequence interface.

指定者：
接口 CharSequence 中的 subSequence
参数：
start - the start index, inclusive.
end - the end index, exclusive.
返回：
the specified subsequence.
抛出：
IndexOutOfBoundsException - if start or end are negative, if end is greater than length(), or if start is greater than end
从以下版本开始：
1.4

substring

public String substring(int start,
                        int end)
Returns a new String that contains a subsequence of characters currently contained in this sequence. The substring begins at the specified start and extends to the character at index end - 1.

参数：
start - The beginning index, inclusive.
end - The ending index, exclusive.
返回：
The new string.
抛出：
StringIndexOutOfBoundsException - if start or end are negative or greater than length(), or start is greater than end.
从以下版本开始：
1.2

insert

public StringBuffer insert(int index,
                           char[] str,
                           int offset,
                           int len)
Inserts the string representation of a subarray of the str array argument into this sequence. The subarray begins at the specified offset and extends len chars. The characters of the subarray are inserted into this sequence at the position indicated by index. The length of this sequence increases by len chars.

参数：
index - position at which to insert subarray.
str - A char array.
offset - the index of the first char in subarray to be inserted.
len - the number of chars in the subarray to be inserted.
返回：
This object
抛出：
StringIndexOutOfBoundsException - if index is negative or greater than length(), or offset or len are negative, or (offset+len) is greater than str.length.
从以下版本开始：
1.2

insert

public StringBuffer insert(int offset,
                           Object obj)
Inserts the string representation of the Object argument into this character sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
obj - an Object.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(java.lang.Object),
insert(int, java.lang.String),
length()

insert

public StringBuffer insert(int offset,
                           String str)
Inserts the string into this character sequence.

The characters of the String argument are inserted, in order, into this sequence at the indicated offset, moving up any characters originally above that position and increasing the length of this sequence by the length of the argument. If str is null, then the four characters "null" are inserted into this sequence.

The character at index k in the new character sequence is equal to:

  • the character at index k in the old character sequence, if k is less than offset
  • the character at index k-offset in the argument str, if k is not less than offset but is less than offset+str.length()
  • the character at index k-str.length() in the old character sequence, if k is not less than offset+str.length()

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
str - a string.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
length()

insert

public StringBuffer insert(int offset,
                           char[] str)
Inserts the string representation of the char array argument into this sequence.

The characters of the array argument are inserted into the contents of this sequence at the position indicated by offset. The length of this sequence increases by the length of the argument.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char[]) and the characters of that string were then inserted into this character sequence at the position indicated by offset.

参数：
offset - the offset.
str - a character array.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.

insert

public StringBuffer insert(int dstOffset,
                           CharSequence s)
Inserts the specified CharSequence into this sequence.

The characters of the CharSequence argument are inserted, in order, into this sequence at the indicated offset, moving up any characters originally above that position and increasing the length of this sequence by the length of the argument s.

The result of this method is exactly the same as if it were an invocation of this object's insert(dstOffset, s, 0, s.length()) method.

If s is null, then the four characters "null" are inserted into this sequence.

参数：
dstOffset - the offset.
s - the sequence to be inserted
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if the offset is invalid.
从以下版本开始：
1.5

insert

public StringBuffer insert(int dstOffset,
                           CharSequence s,
                           int start,
                           int end)
Inserts a subsequence of the specified CharSequence into this sequence.

The subsequence of the argument s specified by start and end are inserted, in order, into this sequence at the specified destination offset, moving up any characters originally above that position. The length of this sequence is increased by end - start.

The character at index k in this sequence becomes equal to:

  • the character at index k in this sequence, if k is less than dstOffset
  • the character at index k+start-dstOffset in the argument s, if k is greater than or equal to dstOffset but is less than dstOffset+end-start
  • the character at index k-(end-start) in this sequence, if k is greater than or equal to dstOffset+end-start

The dstOffset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

The start argument must be nonnegative, and not greater than end.

The end argument must be greater than or equal to start, and less than or equal to the length of s.

If s is null, then this method inserts characters as if the s parameter was a sequence containing the four characters "null".

参数：
dstOffset - the offset in this sequence.
s - the sequence to be inserted.
start - the starting index of the subsequence to be inserted.
end - the end index of the subsequence to be inserted.
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if dstOffset is negative or greater than this.length(), or start or end are negative, or start is greater than end or end is greater than s.length()
从以下版本开始：
1.5

insert

public StringBuffer insert(int offset,
                           boolean b)
Inserts the string representation of the boolean argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
b - a boolean.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(boolean),
insert(int, java.lang.String),
length()

insert

public StringBuffer insert(int offset,
                           char c)
Inserts the string representation of the char argument into this sequence.

The second argument is inserted into the contents of this sequence at the position indicated by offset. The length of this sequence increases by one.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char) and the character in that string were then inserted into this character sequence at the position indicated by offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
c - a char.
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if the offset is invalid.
另请参见：
length()

insert

public StringBuffer insert(int offset,
                           int i)
Inserts the string representation of the second int argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
i - an int.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(int),
insert(int, java.lang.String),
length()

insert

public StringBuffer insert(int offset,
                           long l)
Inserts the string representation of the long argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the position indicated by offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
l - a long.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(long),
insert(int, java.lang.String),
length()

insert

public StringBuffer insert(int offset,
                           float f)
Inserts the string representation of the float argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
f - a float.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(float),
insert(int, java.lang.String),
length()

insert

public StringBuffer insert(int offset,
                           double d)
Inserts the string representation of the double argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
d - a double.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(double),
insert(int, java.lang.String),
length()

indexOf

public int indexOf(String str)
Returns the index within this string of the first occurrence of the specified substring. The integer returned is the smallest value k such that:
 this.toString().startsWith(str, k)
is true.

参数：
str - any string.
返回：
if the string argument occurs as a substring within this object, then the index of the first character of the first such substring is returned; if it does not occur as a substring, -1 is returned.
抛出：
NullPointerException - if str is null.
从以下版本开始：
1.4

indexOf

public int indexOf(String str,
                   int fromIndex)
Returns the index within this string of the first occurrence of the specified substring, starting at the specified index. The integer returned is the smallest value k for which:
     k >= Math.min(fromIndex, str.length()) &&
                   this.toString().startsWith(str, k)
If no such value of k exists, then -1 is returned.

参数：
str - the substring for which to search.
fromIndex - the index from which to start the search.
返回：
the index within this string of the first occurrence of the specified substring, starting at the specified index.
抛出：
NullPointerException - if str is null.
从以下版本开始：
1.4

lastIndexOf

public int lastIndexOf(String str)
Returns the index within this string of the rightmost occurrence of the specified substring. The rightmost empty string "" is considered to occur at the index value this.length(). The returned index is the largest value k such that
 this.toString().startsWith(str, k)
is true.

参数：
str - the substring to search for.
返回：
if the string argument occurs one or more times as a substring within this object, then the index of the first character of the last such substring is returned. If it does not occur as a substring, -1 is returned.
抛出：
NullPointerException - if str is null.
从以下版本开始：
1.4

lastIndexOf

public int lastIndexOf(String str,
                       int fromIndex)
Returns the index within this string of the last occurrence of the specified substring. The integer returned is the largest value k such that:
     k <= Math.min(fromIndex, str.length()) &&
                   this.toString().startsWith(str, k)
If no such value of k exists, then -1 is returned.

参数：
str - the substring to search for.
fromIndex - the index to start the search from.
返回：
the index within this sequence of the last occurrence of the specified substring.
抛出：
NullPointerException - if str is null.
从以下版本开始：
1.4

reverse

public StringBuffer reverse()
Causes this character sequence to be replaced by the reverse of the sequence. If there are any surrogate pairs included in the sequence, these are treated as single characters for the reverse operation. Thus, the order of the high-low surrogates is never reversed. Let n be the character length of this character sequence (not the length in char values) just prior to execution of the reverse method. Then the character at index k in the new character sequence is equal to the character at index n-k-1 in the old character sequence.

Note that the reverse operation may result in producing surrogate pairs that were unpaired low-surrogates and high-surrogates before the operation. For example, reversing "\uDC00\uD800" produces "\uD800\uDC00" which is a valid surrogate pair.

返回：
a reference to this object.
从以下版本开始：
JDK1.0.2

toString

public String toString()
Returns a string representing the data in this sequence. A new String object is allocated and initialized to contain the character sequence currently represented by this object. This String is then returned. Subsequent changes to this sequence do not affect the contents of the String.

指定者：
接口 CharSequence 中的 toString
返回：
a string representation of this sequence of characters.
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringBuilder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 StringBuilder

java.lang.Object
    继承者  java.lang.StringBuilder
所有已实现的接口：
Serializable, Appendable, CharSequence
public final class StringBuilder
extends Object
implements Serializable, CharSequence

一个可变的字符序列。此类提供一个与 StringBuffer 兼容的 API，但不保证同步。该类被设计用作 StringBuffer 的一个简易替换，用在字符串缓冲区被单个线程使用的时候（这种情况很普遍）。如果可能，建议优先采用该类，因为在大多数实现中，它比 StringBuffer 要快。

在 StringBuilder 上的主要操作是 append 和 insert 方法，可重载这些方法，以接受任意类型的数据。每个方法都能有效地将给定的数据转换成字符串，然后将该字符串的字符添加或插入到字符串生成器中。append 方法始终将这些字符添加到生成器的末端；而 insert 方法则在指定的点添加字符。

例如，如果 z 引用一个当前内容为“start”的字符串生成器对象，则该方法调用 z.append("le") 将使字符串生成器包含“startle”，而 z.insert(4, "le") 将更改字符串生成器，使之包含“starlet”。

通常，如果 sb 引用 StringBuilder 的实例，则 sb.append(x) 和 sb.insert(sb.length(), x) 具有相同的效果。 每个字符串生成器都有一定的容量。只要字符串生成器所包含的字符序列的长度没有超出此容量，就无需分配新的内部缓冲区。如果内部缓冲区溢出，则此容量自动增大。

将 StringBuilder 的实例用于多个线程是不安全的。如果需要这样的同步，则建议使用 StringBuffer。

从以下版本开始：
1.5
另请参见：
StringBuffer, String, 序列化表格

构造方法摘要
StringBuilder()
构造一个其中不带字符的字符串生成器，初始容量为 16 个字符。
StringBuilder(CharSequence seq)
构造一个字符串生成器，包含与指定的 CharSequence 相同的字符。
StringBuilder(int capacity)
构造一个其中不带字符的字符串生成器，初始容量由 capacity 参数指定。
StringBuilder(String str)
构造一个字符串生成器，并初始化为指定的字符串内容。
方法摘要
StringBuilder | append(boolean b) Appends the string representation of the boolean argument to the sequence.
StringBuilder | append(char c) Appends the string representation of the char argument to this sequence.
StringBuilder | append(char[] str) Appends the string representation of the char array argument to this sequence.
StringBuilder | append(char[] str, int offset, int len) Appends the string representation of a subarray of the char array argument to this sequence.
StringBuilder | append(CharSequence s) 向此 Appendable 添加指定的字符序列。
StringBuilder | append(CharSequence s, int start, int end) Appends a subsequence of the specified CharSequence to this sequence.
StringBuilder | append(double d) Appends the string representation of the double argument to this sequence.
StringBuilder | append(float f) Appends the string representation of the float argument to this sequence.
StringBuilder | append(int i) Appends the string representation of the int argument to this sequence.
StringBuilder | append(long lng) Appends the string representation of the long argument to this sequence.
StringBuilder | append(Object obj) Appends the string representation of the Object argument.
StringBuilder | append(String str) Appends the specified string to this character sequence.
StringBuilder | append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列。
StringBuilder | appendCodePoint(int codePoint) Appends the string representation of the codePoint argument to this sequence.
int | capacity() Returns the current capacity.
char | charAt(int index) Returns the char value in this sequence at the specified index.
int | codePointAt(int index) Returns the character (Unicode code point) at the specified index.
int | codePointBefore(int index) Returns the character (Unicode code point) before the specified index.
int | codePointCount(int beginIndex, int endIndex) Returns the number of Unicode code points in the specified text range of this sequence.
StringBuilder | delete(int start, int end) Removes the characters in a substring of this sequence.
StringBuilder | deleteCharAt(int index) Removes the char at the specified position in this sequence.
void | ensureCapacity(int minimumCapacity) Ensures that the capacity is at least equal to the specified minimum.
void | getChars(int srcBegin, int srcEnd, char[] dst, int dstBegin) Characters are copied from this sequence into the destination character array dst.
int | indexOf(String str) Returns the index within this string of the first occurrence of the specified substring.
int | indexOf(String str, int fromIndex) Returns the index within this string of the first occurrence of the specified substring, starting at the specified index.
StringBuilder | insert(int offset, boolean b) Inserts the string representation of the boolean argument into this sequence.
StringBuilder | insert(int offset, char c) Inserts the string representation of the char argument into this sequence.
StringBuilder | insert(int offset, char[] str) Inserts the string representation of the char array argument into this sequence.
StringBuilder | insert(int index, char[] str, int offset, int len) Inserts the string representation of a subarray of the str array argument into this sequence.
StringBuilder | insert(int dstOffset, CharSequence s) Inserts the specified CharSequence into this sequence.
StringBuilder | insert(int dstOffset, CharSequence s, int start, int end) Inserts a subsequence of the specified CharSequence into this sequence.
StringBuilder | insert(int offset, double d) Inserts the string representation of the double argument into this sequence.
StringBuilder | insert(int offset, float f) Inserts the string representation of the float argument into this sequence.
StringBuilder | insert(int offset, int i) Inserts the string representation of the second int argument into this sequence.
StringBuilder | insert(int offset, long l) Inserts the string representation of the long argument into this sequence.
StringBuilder | insert(int offset, Object obj) Inserts the string representation of the Object argument into this character sequence.
StringBuilder | insert(int offset, String str) Inserts the string into this character sequence.
int | lastIndexOf(String str) Returns the index within this string of the rightmost occurrence of the specified substring.
int | lastIndexOf(String str, int fromIndex) Returns the index within this string of the last occurrence of the specified substring.
int | length() Returns the length (character count).
int | offsetByCodePoints(int index, int codePointOffset) Returns the index within this sequence that is offset from the given index by codePointOffset code points.
StringBuilder | replace(int start, int end, String str) Replaces the characters in a substring of this sequence with characters in the specified String.
StringBuilder | reverse() Causes this character sequence to be replaced by the reverse of the sequence.
void | setCharAt(int index, char ch) The character at the specified index is set to ch.
void | setLength(int newLength) Sets the length of the character sequence.
CharSequence | subSequence(int start, int end) Returns a new character sequence that is a subsequence of this sequence.
String | substring(int start) Returns a new String that contains a subsequence of characters currently contained in this character sequence.
String | substring(int start, int end) Returns a new String that contains a subsequence of characters currently contained in this sequence.
String | toString() Returns a string representing the data in this sequence.
void | trimToSize() Attempts to reduce storage used for the character sequence.
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.lang.CharSequence 继承的方法
charAt, length, subSequence

构造方法详细信息

StringBuilder

public StringBuilder()
构造一个其中不带字符的字符串生成器，初始容量为 16 个字符。

StringBuilder

public StringBuilder(int capacity)
构造一个其中不带字符的字符串生成器，初始容量由 capacity 参数指定。

参数：
capacity - 初始容量。
抛出：
NegativeArraySizeException - 如果 capacity 参数小于 0。

StringBuilder

public StringBuilder(String str)
构造一个字符串生成器，并初始化为指定的字符串内容。该字符串生成器的初始容量为 16 加上字符串参数的长度。

参数：
str - 缓冲区的初始内容。
抛出：
NullPointerException - 如果 str 为 null

StringBuilder

public StringBuilder(CharSequence seq)
构造一个字符串生成器，包含与指定的 CharSequence 相同的字符。该字符串生成器的初始容量为 16 加上 CharSequence 参数的长度。

参数：
seq - 要复制的序列。
抛出：
NullPointerException - 如果 seq 为 null
方法详细信息

append

public StringBuilder append(Object obj)
Appends the string representation of the Object argument.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
obj - an Object.
返回：
a reference to this object.
另请参见：
String.valueOf(java.lang.Object), append(java.lang.String)

append

public StringBuilder append(String str)
Appends the specified string to this character sequence.

The characters of the String argument are appended, in order, increasing the length of this sequence by the length of the argument. If str is null, then the four characters "null" are appended.

Let n be the length of this character sequence just prior to execution of the append method. Then the character at index k in the new character sequence is equal to the character at index k in the old character sequence, if k is less than n; otherwise, it is equal to the character at index k-n in the argument str.

参数：
str - a string.
返回：
a reference to this object.

append

public StringBuilder append(StringBuffer sb)
将指定的 StringBuffer 添加到此序列。

按顺序将 StringBuffer 参数中的字符添加到该序列中，使该序列在长度上增加该参数的长度。如果 sb 为 null，则向该序列中添加 4 个 "null" 字符。

在执行 append 方法前，让此字符序列的长度为 n。如果 k 小于 n，则新字符序列中索引 k 处的字符等于原有序列中索引 k 处的字符；否则它等于参数 sb 中索引 k-n 处的字符。

参数：
sb - 要添加的 StringBuffer。
返回：
此对象的一个引用。

append

public StringBuilder append(CharSequence s)
从接口 Appendable 复制的描述
向此 Appendable 添加指定的字符序列。

有时可能没有添加整个序列，这取决于使用哪个类来实现字符序列 csq。例如，如果 csq 是 CharBuffer 的一个实例，则通过缓冲区的位置和限制来定义要添加的子序列。

指定者：
接口 Appendable 中的 append
参数：
s - 要添加的字符串序列。如果 csq 为 null，则向该 Appendable 添加四个字符 "null"。
返回：
此 Appendable 的引用
抛出：
IndexOutOfBoundsException

append

public StringBuilder append(CharSequence s,
                            int start,
                            int end)
Appends a subsequence of the specified CharSequence to this sequence.

Characters of the argument s, starting at index start, are appended, in order, to the contents of this sequence up to the (exclusive) index end. The length of this sequence is increased by the value of end - start.

Let n be the length of this character sequence just prior to execution of the append method. Then the character at index k in this character sequence becomes equal to the character at index k in this sequence, if k is less than n; otherwise, it is equal to the character at index k+start-n in the argument s.

If s is null, then this method appends characters as if the s parameter was a sequence containing the four characters "null".

指定者：
接口 Appendable 中的 append
参数：
s - the sequence to append.
start - the starting index of the subsequence to be appended.
end - the end index of the subsequence to be appended.
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if start or end are negative, or start is greater than end or end is greater than s.length()

append

public StringBuilder append(char[] str)
Appends the string representation of the char array argument to this sequence.

The characters of the array argument are appended, in order, to the contents of this sequence. The length of this sequence increases by the length of the argument.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char[]) and the characters of that string were then appended to this character sequence.

参数：
str - the characters to be appended.
返回：
a reference to this object.

append

public StringBuilder append(char[] str,
                            int offset,
                            int len)
Appends the string representation of a subarray of the char array argument to this sequence.

Characters of the char array str, starting at index offset, are appended, in order, to the contents of this sequence. The length of this sequence increases by the value of len.

The overall effect is exactly as if the arguments were converted to a string by the method String.valueOf(char[],int,int) and the characters of that string were then appended to this character sequence.

参数：
str - the characters to be appended.
offset - the index of the first char to append.
len - the number of chars to append.
返回：
a reference to this object.

append

public StringBuilder append(boolean b)
Appends the string representation of the boolean argument to the sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
b - a boolean.
返回：
a reference to this object.
另请参见：
String.valueOf(boolean), append(java.lang.String)

append

public StringBuilder append(char c)
Appends the string representation of the char argument to this sequence.

The argument is appended to the contents of this sequence. The length of this sequence increases by 1.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char) and the character in that string were then appended to this character sequence.

指定者：
接口 Appendable 中的 append
参数：
c - a char.
返回：
a reference to this object.

append

public StringBuilder append(int i)
Appends the string representation of the int argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
i - an int.
返回：
a reference to this object.
另请参见：
String.valueOf(int), append(java.lang.String)

append

public StringBuilder append(long lng)
Appends the string representation of the long argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
lng - a long.
返回：
a reference to this object.
另请参见：
String.valueOf(long), append(java.lang.String)

append

public StringBuilder append(float f)
Appends the string representation of the float argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this string sequence.

参数：
f - a float.
返回：
a reference to this object.
另请参见：
String.valueOf(float), append(java.lang.String)

append

public StringBuilder append(double d)
Appends the string representation of the double argument to this sequence.

The argument is converted to a string as if by the method String.valueOf, and the characters of that string are then appended to this sequence.

参数：
d - a double.
返回：
a reference to this object.
另请参见：
String.valueOf(double), append(java.lang.String)

appendCodePoint

public StringBuilder appendCodePoint(int codePoint)
Appends the string representation of the codePoint argument to this sequence.

The argument is appended to the contents of this sequence. The length of this sequence increases by Character.charCount(codePoint).

The overall effect is exactly as if the argument were converted to a char array by the method Character.toChars(int) and the character in that array were then appended to this character sequence.

参数：
codePoint - a Unicode code point
返回：
a reference to this object.
从以下版本开始：
1.5

delete

public StringBuilder delete(int start,
                            int end)
Removes the characters in a substring of this sequence. The substring begins at the specified start and extends to the character at index end - 1 or to the end of the sequence if no such character exists. If start is equal to end, no changes are made.

参数：
start - The beginning index, inclusive.
end - The ending index, exclusive.
返回：
This object.
抛出：
StringIndexOutOfBoundsException - if start is negative, greater than length(), or greater than end.

deleteCharAt

public StringBuilder deleteCharAt(int index)
Removes the char at the specified position in this sequence. This sequence is shortened by one char.

Note: If the character at the given index is a supplementary character, this method does not remove the entire character. If correct handling of supplementary characters is required, determine the number of chars to remove by calling Character.charCount(thisSequence.codePointAt(index)), where thisSequence is this sequence.

参数：
index - Index of char to remove
返回：
This object.
抛出：
StringIndexOutOfBoundsException - if the index is negative or greater than or equal to length().

replace

public StringBuilder replace(int start,
                             int end,
                             String str)
Replaces the characters in a substring of this sequence with characters in the specified String. The substring begins at the specified start and extends to the character at index end - 1 or to the end of the sequence if no such character exists. First the characters in the substring are removed and then the specified String is inserted at start. (This sequence will be lengthened to accommodate the specified String if necessary.)

参数：
start - The beginning index, inclusive.
end - The ending index, exclusive.
str - String that will replace previous contents.
返回：
This object.
抛出：
StringIndexOutOfBoundsException - if start is negative, greater than length(), or greater than end.

insert

public StringBuilder insert(int index,
                            char[] str,
                            int offset,
                            int len)
Inserts the string representation of a subarray of the str array argument into this sequence. The subarray begins at the specified offset and extends len chars. The characters of the subarray are inserted into this sequence at the position indicated by index. The length of this sequence increases by len chars.

参数：
index - position at which to insert subarray.
str - A char array.
offset - the index of the first char in subarray to be inserted.
len - the number of chars in the subarray to be inserted.
返回：
This object
抛出：
StringIndexOutOfBoundsException - if index is negative or greater than length(), or offset or len are negative, or (offset+len) is greater than str.length.

insert

public StringBuilder insert(int offset,
                            Object obj)
Inserts the string representation of the Object argument into this character sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
obj - an Object.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(java.lang.Object),
insert(int, java.lang.String),
length()

insert

public StringBuilder insert(int offset,
                            String str)
Inserts the string into this character sequence.

The characters of the String argument are inserted, in order, into this sequence at the indicated offset, moving up any characters originally above that position and increasing the length of this sequence by the length of the argument. If str is null, then the four characters "null" are inserted into this sequence.

The character at index k in the new character sequence is equal to:

  • the character at index k in the old character sequence, if k is less than offset
  • the character at index k-offset in the argument str, if k is not less than offset but is less than offset+str.length()
  • the character at index k-str.length() in the old character sequence, if k is not less than offset+str.length()

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
str - a string.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
length()

insert

public StringBuilder insert(int offset,
                            char[] str)
Inserts the string representation of the char array argument into this sequence.

The characters of the array argument are inserted into the contents of this sequence at the position indicated by offset. The length of this sequence increases by the length of the argument.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char[]) and the characters of that string were then inserted into this character sequence at the position indicated by offset.

参数：
offset - the offset.
str - a character array.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.

insert

public StringBuilder insert(int dstOffset,
                            CharSequence s)
Inserts the specified CharSequence into this sequence.

The characters of the CharSequence argument are inserted, in order, into this sequence at the indicated offset, moving up any characters originally above that position and increasing the length of this sequence by the length of the argument s.

The result of this method is exactly the same as if it were an invocation of this object's insert(dstOffset, s, 0, s.length()) method.

If s is null, then the four characters "null" are inserted into this sequence.

参数：
dstOffset - the offset.
s - the sequence to be inserted
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if the offset is invalid.

insert

public StringBuilder insert(int dstOffset,
                            CharSequence s,
                            int start,
                            int end)
Inserts a subsequence of the specified CharSequence into this sequence.

The subsequence of the argument s specified by start and end are inserted, in order, into this sequence at the specified destination offset, moving up any characters originally above that position. The length of this sequence is increased by end - start.

The character at index k in this sequence becomes equal to:

  • the character at index k in this sequence, if k is less than dstOffset
  • the character at index k+start-dstOffset in the argument s, if k is greater than or equal to dstOffset but is less than dstOffset+end-start
  • the character at index k-(end-start) in this sequence, if k is greater than or equal to dstOffset+end-start

The dstOffset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

The start argument must be nonnegative, and not greater than end.

The end argument must be greater than or equal to start, and less than or equal to the length of s.

If s is null, then this method inserts characters as if the s parameter was a sequence containing the four characters "null".

参数：
dstOffset - the offset in this sequence.
s - the sequence to be inserted.
start - the starting index of the subsequence to be inserted.
end - the end index of the subsequence to be inserted.
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if dstOffset is negative or greater than this.length(), or start or end are negative, or start is greater than end or end is greater than s.length()

insert

public StringBuilder insert(int offset,
                            boolean b)
Inserts the string representation of the boolean argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
b - a boolean.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(boolean),
insert(int, java.lang.String),
length()

insert

public StringBuilder insert(int offset,
                            char c)
Inserts the string representation of the char argument into this sequence.

The second argument is inserted into the contents of this sequence at the position indicated by offset. The length of this sequence increases by one.

The overall effect is exactly as if the argument were converted to a string by the method String.valueOf(char) and the character in that string were then inserted into this character sequence at the position indicated by offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
c - a char.
返回：
a reference to this object.
抛出：
IndexOutOfBoundsException - if the offset is invalid.
另请参见：
length()

insert

public StringBuilder insert(int offset,
                            int i)
Inserts the string representation of the second int argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
i - an int.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(int),
insert(int, java.lang.String),
length()

insert

public StringBuilder insert(int offset,
                            long l)
Inserts the string representation of the long argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the position indicated by offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
l - a long.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(long),
insert(int, java.lang.String),
length()

insert

public StringBuilder insert(int offset,
                            float f)
Inserts the string representation of the float argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
f - a float.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(float),
insert(int, java.lang.String),
length()

insert

public StringBuilder insert(int offset,
                            double d)
Inserts the string representation of the double argument into this sequence.

The second argument is converted to a string as if by the method String.valueOf, and the characters of that string are then inserted into this sequence at the indicated offset.

The offset argument must be greater than or equal to 0, and less than or equal to the length of this sequence.

参数：
offset - the offset.
d - a double.
返回：
a reference to this object.
抛出：
StringIndexOutOfBoundsException - if the offset is invalid.
另请参见：
String.valueOf(double),
insert(int, java.lang.String),
length()

indexOf

public int indexOf(String str)
Returns the index within this string of the first occurrence of the specified substring. The integer returned is the smallest value k such that:
 this.toString().startsWith(str, k)
is true.

参数：
str - any string.
返回：
if the string argument occurs as a substring within this object, then the index of the first character of the first such substring is returned; if it does not occur as a substring, -1 is returned.
抛出：
NullPointerException - if str is null.

indexOf

public int indexOf(String str,
                   int fromIndex)
Returns the index within this string of the first occurrence of the specified substring, starting at the specified index. The integer returned is the smallest value k for which:
     k >= Math.min(fromIndex, str.length()) &&
                   this.toString().startsWith(str, k)
If no such value of k exists, then -1 is returned.

参数：
str - the substring for which to search.
fromIndex - the index from which to start the search.
返回：
the index within this string of the first occurrence of the specified substring, starting at the specified index.
抛出：
NullPointerException - if str is null.

lastIndexOf

public int lastIndexOf(String str)
Returns the index within this string of the rightmost occurrence of the specified substring. The rightmost empty string "" is considered to occur at the index value this.length(). The returned index is the largest value k such that
 this.toString().startsWith(str, k)
is true.

参数：
str - the substring to search for.
返回：
if the string argument occurs one or more times as a substring within this object, then the index of the first character of the last such substring is returned. If it does not occur as a substring, -1 is returned.
抛出：
NullPointerException - if str is null.

lastIndexOf

public int lastIndexOf(String str,
                       int fromIndex)
Returns the index within this string of the last occurrence of the specified substring. The integer returned is the largest value k such that:
     k <= Math.min(fromIndex, str.length()) &&
                   this.toString().startsWith(str, k)
If no such value of k exists, then -1 is returned.

参数：
str - the substring to search for.
fromIndex - the index to start the search from.
返回：
the index within this sequence of the last occurrence of the specified substring.
抛出：
NullPointerException - if str is null.

reverse

public StringBuilder reverse()
Causes this character sequence to be replaced by the reverse of the sequence. If there are any surrogate pairs included in the sequence, these are treated as single characters for the reverse operation. Thus, the order of the high-low surrogates is never reversed. Let n be the character length of this character sequence (not the length in char values) just prior to execution of the reverse method. Then the character at index k in the new character sequence is equal to the character at index n-k-1 in the old character sequence.

Note that the reverse operation may result in producing surrogate pairs that were unpaired low-surrogates and high-surrogates before the operation. For example, reversing "\uDC00\uD800" produces "\uD800\uDC00" which is a valid surrogate pair.

返回：
a reference to this object.

toString

public String toString()
Returns a string representing the data in this sequence. A new String object is allocated and initialized to contain the character sequence currently represented by this object. This String is then returned. Subsequent changes to this sequence do not affect the contents of the String.

指定者：
接口 CharSequence 中的 toString
返回：
a string representation of this sequence of characters.

length

public int length()
Returns the length (character count).

指定者：
接口 CharSequence 中的 length
返回：
the length of the sequence of characters currently represented by this object

capacity

public int capacity()
Returns the current capacity. The capacity is the amount of storage available for newly inserted characters, beyond which an allocation will occur.

返回：
the current capacity

ensureCapacity

public void ensureCapacity(int minimumCapacity)
Ensures that the capacity is at least equal to the specified minimum. If the current capacity is less than the argument, then a new internal array is allocated with greater capacity. The new capacity is the larger of:
  • The minimumCapacity argument.
  • Twice the old capacity, plus 2.
If the minimumCapacity argument is nonpositive, this method takes no action and simply returns.

参数：
minimumCapacity - the minimum desired capacity.

trimToSize

public void trimToSize()
Attempts to reduce storage used for the character sequence. If the buffer is larger than necessary to hold its current sequence of characters, then it may be resized to become more space efficient. Calling this method may, but is not required to, affect the value returned by a subsequent call to the capacity() method.

setLength

public void setLength(int newLength)
Sets the length of the character sequence. The sequence is changed to a new character sequence whose length is specified by the argument. For every nonnegative index k less than newLength, the character at index k in the new character sequence is the same as the character at index k in the old sequence if k is less than the length of the old character sequence; otherwise, it is the null character '\u0000'. In other words, if the newLength argument is less than the current length, the length is changed to the specified length.

If the newLength argument is greater than or equal to the current length, sufficient null characters ('\u0000') are appended so that length becomes the newLength argument.

The newLength argument must be greater than or equal to 0.

参数：
newLength - the new length
抛出：
IndexOutOfBoundsException - if the newLength argument is negative.

charAt

public char charAt(int index)
Returns the char value in this sequence at the specified index. The first char value is at index 0, the next at index 1, and so on, as in array indexing.

The index argument must be greater than or equal to 0, and less than the length of this sequence.

If the char value specified by the index is a surrogate, the surrogate value is returned.

指定者：
接口 CharSequence 中的 charAt
参数：
index - the index of the desired char value.
返回：
the char value at the specified index.
抛出：
IndexOutOfBoundsException - if index is negative or greater than or equal to length().

codePointAt

public int codePointAt(int index)
Returns the character (Unicode code point) at the specified index. The index refers to char values (Unicode code units) and ranges from 0 to length() - 1.

If the char value specified at the given index is in the high-surrogate range, the following index is less than the length of this sequence, and the char value at the following index is in the low-surrogate range, then the supplementary code point corresponding to this surrogate pair is returned. Otherwise, the char value at the given index is returned.

参数：
index - the index to the char values
返回：
the code point value of the character at the index
抛出：
IndexOutOfBoundsException - if the index argument is negative or not less than the length of this sequence.

codePointBefore

public int codePointBefore(int index)
Returns the character (Unicode code point) before the specified index. The index refers to char values (Unicode code units) and ranges from 1 to length().

If the char value at (index - 1) is in the low-surrogate range, (index - 2) is not negative, and the char value at (index - 2) is in the high-surrogate range, then the supplementary code point value of the surrogate pair is returned. If the char value at index - 1 is an unpaired low-surrogate or a high-surrogate, the surrogate value is returned.

参数：
index - the index following the code point that should be returned
返回：
the Unicode code point value before the given index.
抛出：
IndexOutOfBoundsException - if the index argument is less than 1 or greater than the length of this sequence.

codePointCount

public int codePointCount(int beginIndex,
                          int endIndex)
Returns the number of Unicode code points in the specified text range of this sequence. The text range begins at the specified beginIndex and extends to the char at index endIndex - 1. Thus the length (in chars) of the text range is endIndex-beginIndex. Unpaired surrogates within this sequence count as one code point each.

参数：
beginIndex - the index to the first char of the text range.
endIndex - the index after the last char of the text range.
返回：
the number of Unicode code points in the specified text range
抛出：
IndexOutOfBoundsException - if the beginIndex is negative, or endIndex is larger than the length of this sequence, or beginIndex is larger than endIndex.

offsetByCodePoints

public int offsetByCodePoints(int index,
                              int codePointOffset)
Returns the index within this sequence that is offset from the given index by codePointOffset code points. Unpaired surrogates within the text range given by index and codePointOffset count as one code point each.

参数：
index - the index to be offset
codePointOffset - the offset in code points
返回：
the index within this sequence
抛出：
IndexOutOfBoundsException - if index is negative or larger then the length of this sequence, or if codePointOffset is positive and the subsequence starting with index has fewer than codePointOffset code points, or if codePointOffset is negative and the subsequence before index has fewer than the absolute value of codePointOffset code points.

getChars

public void getChars(int srcBegin,
                     int srcEnd,
                     char[] dst,
                     int dstBegin)
Characters are copied from this sequence into the destination character array dst. The first character to be copied is at index srcBegin; the last character to be copied is at index srcEnd-1. The total number of characters to be copied is srcEnd-srcBegin. The characters are copied into the subarray of dst starting at index dstBegin and ending at index:

 dstbegin + (srcEnd-srcBegin) - 1

参数：
srcBegin - start copying at this offset.
srcEnd - stop copying at this offset.
dst - the array to copy the data into.
dstBegin - offset into dst.
抛出：
NullPointerException - if dst is null.
IndexOutOfBoundsException - if any of the following is true:
  • srcBegin is negative
  • dstBegin is negative
  • the srcBegin argument is greater than the srcEnd argument.
  • srcEnd is greater than this.length().
  • dstBegin+srcEnd-srcBegin is greater than dst.length

setCharAt

public void setCharAt(int index,
                      char ch)
The character at the specified index is set to ch. This sequence is altered to represent a new character sequence that is identical to the old character sequence, except that it contains the character ch at position index.

The index argument must be greater than or equal to 0, and less than the length of this sequence.

参数：
index - the index of the character to modify.
ch - the new character.
抛出：
IndexOutOfBoundsException - if index is negative or greater than or equal to length().

substring

public String substring(int start)
Returns a new String that contains a subsequence of characters currently contained in this character sequence. The substring begins at the specified index and extends to the end of this sequence.

参数：
start - The beginning index, inclusive.
返回：
The new string.
抛出：
StringIndexOutOfBoundsException - if start is less than zero, or greater than the length of this object.

subSequence

public CharSequence subSequence(int start,
                                int end)
Returns a new character sequence that is a subsequence of this sequence.

An invocation of this method of the form

 sb.subSequence(begin, end)
behaves in exactly the same way as the invocation
 sb.substring(begin, end)
This method is provided so that this class can implement the CharSequence interface.

指定者：
接口 CharSequence 中的 subSequence
参数：
start - the start index, inclusive.
end - the end index, exclusive.
返回：
the specified subsequence.
抛出：
IndexOutOfBoundsException - if start or end are negative, if end is greater than length(), or if start is greater than end

substring

public String substring(int start,
                        int end)
Returns a new String that contains a subsequence of characters currently contained in this sequence. The substring begins at the specified start and extends to the character at index end - 1.

参数：
start - The beginning index, inclusive.
end - The ending index, exclusive.
返回：
The new string.
抛出：
StringIndexOutOfBoundsException - if start or end are negative or greater than length(), or start is greater than end.
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringIndexOutOfBoundsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 StringIndexOutOfBoundsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IndexOutOfBoundsException
                    继承者  java.lang.StringIndexOutOfBoundsException
所有已实现的接口：
Serializable
public class StringIndexOutOfBoundsException
extends IndexOutOfBoundsException

此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。对诸如 charAt 的一些方法，当索引等于字符串的大小时，也会抛出该异常。

从以下版本开始：
JDK1.0
另请参见：
String.charAt(int), 序列化表格

构造方法摘要
StringIndexOutOfBoundsException()
构造不带详细消息的 StringIndexOutOfBoundsException。
StringIndexOutOfBoundsException(int index)
构造一个新的 StringIndexOutOfBoundsException 类，该类带有一个指示非法索引的参数。
StringIndexOutOfBoundsException(String s)
构造带指定详细消息的 StringIndexOutOfBoundsException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StringIndexOutOfBoundsException

public StringIndexOutOfBoundsException()
构造不带详细消息的 StringIndexOutOfBoundsException。

从以下版本开始：
JDK1.0

StringIndexOutOfBoundsException

public StringIndexOutOfBoundsException(String s)
构造带指定详细消息的 StringIndexOutOfBoundsException。

参数：
s - 详细消息。

StringIndexOutOfBoundsException

public StringIndexOutOfBoundsException(int index)
构造一个新的 StringIndexOutOfBoundsException 类，该类带有一个指示非法索引的参数。

参数：
index - 非法索引。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SuppressWarnings (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

java.lang
注释类型 SuppressWarnings

@Target(value={TYPE,FIELD,METHOD,PARAMETER,CONSTRUCTOR,LOCAL_VARIABLE})
@Retention(value=SOURCE)
public @interface SuppressWarnings

指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。注意，在给定元素中取消显示的警告集是所有包含元素中取消显示的警告的超集。例如，如果注释一个类来取消显示某个警告，同时注释一个方法来取消显示另一个警告，那么将在此方法中同时取消显示这两个警告。

根据风格不同，程序员应该始终在最里层的嵌套元素上使用此注释，在那里使用才有效。如果要在特定的方法中取消显示某个警告，则应该注释该方法而不是注释它的类。

从以下版本开始：
1.5

必需元素摘要
 String[] value
将由编译器在注释的元素中取消显示的警告集。

元素详细信息

value

public abstract String[] value
将由编译器在注释的元素中取消显示的警告集。允许使用重复的名称。忽略第二个和后面出现的名称。出现未被识别的警告名不是 错误：编译器必须忽略无法识别的所有警告名。但如果某个注释包含未被识别的警告名，那么编译器可以随意发出一个警告。

各编译器供应商应该将它们所支持的警告名连同注释类型一起记录。鼓励各供应商之间相互合作，确保在多个编译器中使用相同的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


System (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 System

java.lang.Object
    继承者  java.lang.System

public final class System
extends Object

System 类包含一些有用的类字段和方法。它不能被实例化。

在 System 类提供的设施中，有标准输入、标准输出和错误输出流；对外部定义的属性和环境变量的访问；加载文件和库的方法；还有快速复制数组的一部分的实用方法。

从以下版本开始：
JDK1.0

字段摘要
static PrintStream | err “标准”错误输出流。
static InputStream | in “标准”输入流。
static PrintStream | out “标准”输出流。
方法摘要
static void | arraycopy(Object src, int srcPos, Object dest, int destPos, int length) 从指定源数组中复制一个数组，复制从指定的位置开始，到目标数组的指定位置结束。
static String | clearProperty(String key) 移除指定键指示的系统属性。
static Console | console() 返回与当前 Java 虚拟机关联的唯一 Console 对象（如果有）。
static long | currentTimeMillis() 返回以毫秒为单位的当前时间。
static void | exit(int status) 终止当前正在运行的 Java 虚拟机。
static void | gc() 运行垃圾回收器。
static Map<String,String> | getenv() 返回一个不能修改的当前系统环境的字符串映射视图。
static String | getenv(String name) 获取指定的环境变量值。
static Properties | getProperties() 确定当前的系统属性。
static String | getProperty(String key) 获取指定键指示的系统属性。
static String | getProperty(String key, String def) 获取用指定键描述的系统属性。
static SecurityManager | getSecurityManager() 获取系统安全接口。
static int | identityHashCode(Object x) 返回给定对象的哈希码，该代码与默认的方法 hashCode() 返回的代码一样，无论给定对象的类是否重写 hashCode()。
static Channel | inheritedChannel() 返回从创建此 Java 虚拟机的实体中继承的信道。
static void | load(String filename) 从作为动态库的本地文件系统中以指定的文件名加载代码文件。
static void | loadLibrary(String libname) 加载由 libname 参数指定的系统库。
static String | mapLibraryName(String libname) 将一个库名称映射到特定于平台的、表示本机库的字符串中。
static long | nanoTime() 返回最准确的可用系统计时器的当前值，以毫微秒为单位。
static void | runFinalization() 运行处于挂起终止状态的所有对象的终止方法。
static void | runFinalizersOnExit(boolean value) 已过时。 该方法具有固有的不安全性。它可能对正在使用的对象调用终结方法，而其他线程同时正在操作这些对象，从而导致不正确的行为或死锁。
static void | setErr(PrintStream err) 重新分配“标准”错误输出流。
static void | setIn(InputStream in) 重新分配“标准”输入流。
static void | setOut(PrintStream out) 重新分配“标准”输出流。
static void | setProperties(Properties props) 将系统属性设置为 Properties 参数。
static String | setProperty(String key, String value) 设置指定键指示的系统属性。
static void | setSecurityManager(SecurityManager s) 设置系统安全性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

in

public static final InputStream in
“标准”输入流。此流已打开并准备提供输入数据。通常，此流对应于键盘输入或者由主机环境或用户指定的另一个输入源。

out

public static final PrintStream out
“标准”输出流。此流已打开并准备接受输出数据。通常，此流对应于显示器输出或者由主机环境或用户指定的另一个输出目标。

对于简单独立的 Java 应用程序，编写一行输出数据的典型方式是：

     System.out.println(data)

请参阅 PrintStream 类中的 println 方法。

另请参见：
PrintStream.println(),
PrintStream.println(boolean),
PrintStream.println(char),
PrintStream.println(char[]),
PrintStream.println(double),
PrintStream.println(float),
PrintStream.println(int),
PrintStream.println(long),
PrintStream.println(java.lang.Object),
PrintStream.println(java.lang.String)

err

public static final PrintStream err
“标准”错误输出流。此流已打开并准备接受输出数据。

通常，此流对应于显示器输出或者由主机环境或用户指定的另一个输出目标。按照惯例，此输出流用于显示错误消息，或者显示那些即使用户输出流（变量 out 的值）已经重定向到通常不被连续监视的某一文件或其他目标，也应该立刻引起用户注意的其他信息。

方法详细信息

setIn

public static void setIn(InputStream in)
重新分配“标准”输入流。

首先，如果有安全管理器，则通过 RuntimePermission("setIO") 权限调用其 checkPermission 方法，查看是否可以重新分配“标准”输入流。

参数：
in - 新的标准输出流。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许重新分配标准输入流。
从以下版本开始：
JDK1.1
另请参见：
SecurityManager.checkPermission(java.security.Permission), RuntimePermission

setOut

public static void setOut(PrintStream out)
重新分配“标准”输出流。

首先，如果有安全管理器，则通过 RuntimePermission("setIO") 权限调用其 checkPermission 方法，查看是否可以重新分配“标准”输出流。

参数：
out - 新的标准输出流
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许重新分配标准输出流。
从以下版本开始：
JDK1.1
另请参见：
SecurityManager.checkPermission(java.security.Permission), RuntimePermission

setErr

public static void setErr(PrintStream err)
重新分配“标准”错误输出流。

首先，如果有安全管理器，则通过 RuntimePermission("setIO") 权限调用其 checkPermission 方法，查看是否可以重新分配“标准”输出流。

参数：
err - 新的标准错误输出流
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许重新分配标准错误输出流。
从以下版本开始：
JDK1.1
另请参见：
SecurityManager.checkPermission(java.security.Permission), RuntimePermission

console

public static Console console()
返回与当前 Java 虚拟机关联的唯一 Console 对象（如果有）。

返回：
系统控制台（如果有），否则返回 null。
从以下版本开始：
1.6

inheritedChannel

public static Channel inheritedChannel()
                                throws IOException
返回从创建此 Java 虚拟机的实体中继承的信道。

此方法返回通过调用系统级默认 SelectorProvider 对象的 inheritedChannel 方法获得的信道。

除了 inheritedChannel 中描述的面向网络的信道之外，此方法以后还可能返回其他种类的信道。

返回：
继承的信道（如果有），否则返回 null。
抛出：
IOException - 如果发生 I/O 错误
SecurityException - 如果安全管理器存在并且它不允许访问信道。
从以下版本开始：
1.5

setSecurityManager

public static void setSecurityManager(SecurityManager s)
设置系统安全性。

如果已经安装了安全管理器，则此方法首先通过 RuntimePermission("setSecurityManager") 权限调用安全管理器的 checkPermission 方法，以确保可以替换现有的安全管理器。这可能导致抛出一个 SecurityException 异常。

否则，将该参数作为当前安全管理器建立。如果参数为 null 并且没有建立安全管理器，则不执行任何操作，并且该方法将自行返回。

参数：
s - 安全管理器。
抛出：
SecurityException - 如果安全管理器已经设置并且其 checkPermission 方法不允许替换该设置。
另请参见：
getSecurityManager(), SecurityManager.checkPermission(java.security.Permission), RuntimePermission

getSecurityManager

public static SecurityManager getSecurityManager()
获取系统安全接口。

返回：
如果已经为当前应用程序建立了安全管理器，则返回此安全管理器；否则，返回 null。
另请参见：
setSecurityManager(java.lang.SecurityManager)

currentTimeMillis

public static long currentTimeMillis()
返回以毫秒为单位的当前时间。注意，当返回值的时间单位是毫秒时，值的粒度取决于底层操作系统，并且粒度可能更大。例如，许多操作系统以几十毫秒为单位测量时间。

请参阅 Date 类的描述，了解可能发生在“计算机时间”和协调世界时（UTC）之间的细微差异的讨论。

返回：
当前时间与协调世界时 1970 年 1 月 1 日午夜之间的时间差（以毫秒为单位测量）。
另请参见：
Date

nanoTime

public static long nanoTime()
返回最准确的可用系统计时器的当前值，以毫微秒为单位。

此方法只能用于测量已过的时间，与系统或钟表时间的其他任何时间概念无关。返回值表示从某一固定但任意的时间算起的毫微秒数（或许从以后算起，所以该值可能为负）。此方法提供毫微秒的精度，但不是必要的毫微秒的准确度。它对于值的更改频率没有作出保证。在取值范围大于约 292 年（263 毫微秒）的连续调用的不同点在于：由于数字溢出，将无法准确计算已过的时间。

例如，测试某些代码执行的时间长度：

   long startTime = System.nanoTime();
   // ... the code being measured ...
   long estimatedTime = System.nanoTime() - startTime;

返回：
系统计时器的当前值，以毫微秒为单位。
从以下版本开始：
1.5

arraycopy

public static void arraycopy(Object src,
                             int srcPos,
                             Object dest,
                             int destPos,
                             int length)
从指定源数组中复制一个数组，复制从指定的位置开始，到目标数组的指定位置结束。从 src 引用的源数组到 dest 引用的目标数组，数组组件的一个子序列被复制下来。被复制的组件的编号等于 length 参数。源数组中位置在 srcPos 到 srcPos+length-1 之间的组件被分别复制到目标数组中的 destPos 到 destPos+length-1 位置。

如果参数 src 和 dest 引用相同的数组对象，则复制的执行过程就好像首先将 srcPos 到 srcPos+length-1 位置的组件复制到一个带有 length 组件的临时数组，然后再将此临时数组的内容复制到目标数组的 destPos 到 destPos+length-1 位置一样。

If 如果 dest 为 null，则抛出 NullPointerException 异常。

如果 src 为 null, 则抛出 NullPointerException 异常，并且不会修改目标数组。

否则，只要下列任何情况为真，则抛出 ArrayStoreException 异常并且不会修改目标数组：

  • src 参数指的是非数组对象。
  • dest 参数指的是非数组对象。
  • src 参数和 dest 参数指的是那些其组件类型为不同基本类型的数组。
  • src 参数指的是具有基本组件类型的数组且 dest 参数指的是具有引用组件类型的数组。
  • src 参数指的是具有引用组件类型的数组且 dest 参数指的是具有基本组件类型的数组。

否则，只要下列任何情况为真，则抛出 IndexOutOfBoundsException 异常，并且不会修改目标数组：

  • srcPos 参数为负。
  • destPos 参数为负。
  • length 参数为负。
  • srcPos+length 大于 src.length，即源数组的长度。
  • destPos+length 大于 dest.length，即目标数组的长度。

否则，如果源数组中 srcPos 到 srcPos+length-1 位置上的实际组件通过分配转换并不能转换成目标数组的组件类型，则抛出 ArrayStoreException 异常。在这种情况下，将 k 设置为比长度小的最小非负整数，这样就无法将 src[srcPos+k] 转换为目标数组的组件类型；当抛出异常时，从 srcPos 到 srcPos+k-1 位置上的源数组组件已经被复制到目标数组中的 destPos 到 destPos+k-1 位置，而目标数组中的其他位置不会被修改。（因为已经详细说明过的那些限制，只能将此段落有效地应用于两个数组都有引用类型的组件类型的情况。）

参数：
src - 源数组。
srcPos - 源数组中的起始位置。
dest - 目标数组。
destPos - 目标数据中的起始位置。
length - 要复制的数组元素的数量。
抛出：
IndexOutOfBoundsException - 如果复制会导致对数组范围以外的数据的访问。
ArrayStoreException - 如果因为类型不匹配而使得无法将 src 数组中的元素存储到 dest 数组中。
NullPointerException - 如果 src 或 dest 为 null。

identityHashCode

public static int identityHashCode(Object x)
返回给定对象的哈希码，该代码与默认的方法 hashCode() 返回的代码一样，无论给定对象的类是否重写 hashCode()。null 引用的哈希码为 0。

参数：
x - 要计算其哈希码的对象
返回：
哈希码
从以下版本开始：
JDK1.1

getProperties

public static Properties getProperties()
确定当前的系统属性。

首先，如果有安全管理器，则不带参数直接调用其 checkPropertiesAccess 方法。这可能导致一个安全性异常。

将 getProperty(String) 方法使用的当前系统属性集合作为 Properties 对象返回。如果没有当前系统属性集合，则先创建并初始化一个系统属性集合。这个系统属性集合总是包含以下键的值：

键 | 相关值的描述
java.version | Java 运行时环境版本
java.vendor | Java 运行时环境供应商
java.vendor.url | Java 供应商的 URL
java.home | Java 安装目录
java.vm.specification.version | Java 虚拟机规范版本
java.vm.specification.vendor | Java 虚拟机规范供应商
java.vm.specification.name | Java 虚拟机规范名称
java.vm.version | Java 虚拟机实现版本
java.vm.vendor | Java 虚拟机实现供应商
java.vm.name | Java 虚拟机实现名称
java.specification.version | Java 运行时环境规范版本
java.specification.vendor | Java 运行时环境规范供应商
java.specification.name | Java 运行时环境规范名称
java.class.version | Java 类格式版本号
java.class.path | Java 类路径
java.library.path | 加载库时搜索的路径列表
java.io.tmpdir | 默认的临时文件路径
java.compiler | 要使用的 JIT 编译器的名称
java.ext.dirs | 一个或多个扩展目录的路径
os.name | 操作系统的名称
os.arch | 操作系统的架构
os.version | 操作系统的版本
file.separator | 文件分隔符（在 UNIX 系统中是“/”）
path.separator | 路径分隔符（在 UNIX 系统中是“:”）
line.separator | 行分隔符（在 UNIX 系统中是“/n”）
user.name | 用户的账户名称
user.home | 用户的主目录
user.dir | 用户的当前工作目录

系统属性值中的多个路径是用平台的路径分隔符分隔的。

注意，即使安全管理器不允许执行 getProperties 操作，它可能也会选择允许执行 getProperty(String) 操作。

返回：
系统属性
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问系统属性。
另请参见：
setProperties(java.util.Properties), SecurityException, SecurityManager.checkPropertiesAccess(), Properties

setProperties

public static void setProperties(Properties props)
将系统属性设置为 Properties 参数。

首先，如果有安全管理器，则不带参数直接调用其 checkPropertiesAccess 方法。这可能导致一个安全性异常。

参数是 getProperty(String) 方法使用的当前系统属性的集合。如果参数为 null，则忽略当前系统属性的集合。

参数：
props - 新的系统属性。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问系统属性。
另请参见：
getProperties(), Properties, SecurityException, SecurityManager.checkPropertiesAccess()

getProperty

public static String getProperty(String key)
获取指定键指示的系统属性。

首先，如果有安全管理器，则用该键作为其参数来调用 checkPropertyAccess 方法。结果可能导致 SecurityException。

如果没有当前系统属性的集合，则首先用与 getProperties 方法相同的方式创建并初始化系统属性的集合。

参数：
key - 系统属性的名称。
返回：
系统属性的字符串值，如果没有带有此键的属性，则返回 null。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertyAccess 方法不允许访问指定的系统属性。
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空。
另请参见：
setProperty(java.lang.String, java.lang.String), SecurityException, SecurityManager.checkPropertyAccess(java.lang.String), getProperties()

getProperty

public static String getProperty(String key,
                                 String def)
获取用指定键描述的系统属性。

首先，如果有安全管理器，则用该 key 作为参数调用 checkPropertyAccess 方法。

如果没有当前系统属性的集合，将用与 getProperties 方法相同的方式首先创建并初始化系统属性的集合。

参数：
key - 系统属性的名称。
def - 默认值。
返回：
系统属性的字符串值，如果没有带有此键的属性，则返回默认值。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertyAccess 方法不允许访问指定的系统属性。
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空。
另请参见：
setProperty(java.lang.String, java.lang.String),
SecurityManager.checkPropertyAccess(java.lang.String),
getProperties()

setProperty

public static String setProperty(String key,
                                 String value)
设置指定键指示的系统属性。

首先，如果安全管理器存在，则通过 PropertyPermission(key, "write") 权限调用其 SecurityManager.checkPermission 方法。这可能导致抛出 SecurityException。如果没有抛出异常，则将指定属性设置为给定值。

参数：
key - 系统属性的名称。
value - 系统属性的值。
返回：
系统属性以前的值，如果没有以前的值，则返回 null。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许设置指定属性。
NullPointerException - 如果 key 或 value 为 null。
IllegalArgumentException - 如果 key 为空。
从以下版本开始：
1.2
另请参见：
getProperty(java.lang.String),
getProperty(java.lang.String),
getProperty(java.lang.String, java.lang.String),
PropertyPermission,
SecurityManager.checkPermission(java.security.Permission)

clearProperty

public static String clearProperty(String key)
移除指定键指示的系统属性。

首先，如果安全管理器存在，则通过 PropertyPermission(key, "write") 权限调用其 SecurityManager.checkPermission 方法。这可能导致抛出 SecurityException。如果没有抛出异常，则移除指定的属性。

参数：
key - 要移除的系统属性的名称。
返回：
系统属性以前的字符串值，如果带有此键的属性不存在，则返回 null。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertyAccess 方法不允许访问指定的系统属性。
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空。
从以下版本开始：
1.5
另请参见：
getProperty(java.lang.String), setProperty(java.lang.String, java.lang.String), Properties, SecurityException, SecurityManager.checkPropertiesAccess()

getenv

public static String getenv(String name)
获取指定的环境变量值。环境变量是一个取决于系统的外部指定的值。

如果安全管理器存在，则通过 RuntimePermission("getenv."+name) 的权限调用其 checkPermission 方法。这可能导致抛出 SecurityException。如果没有抛出异常，则返回变量 name 的值。

从概念上讲，系统属性 和环境变量 都是名称与值之间的映射。两种机制都能用来将用户定义的信息传递给 Java 进程。环境变量产生更多的全局效应，因为它们不仅对紧接着出现的 Java 子进程可见，而且对于定义它们的进程的所有子进程都是可见的。在不同的操作系统上，它们的语义有细微的差别，比如，不区分大小写。因为这些原因，环境变量更可能有意料不到的副作用。最好在可能的地方使用系统属性。环境变量应该在需要全局效应的时候使用，或者在外部系统接口要求使用环境变量时使用（比如 PATH）。

在 UNIX 系统中，name 的字母大小写通常很重要，而在 Microsoft Windows 系统中，这通常不重要。例如，表达式 System.getenv("FOO").equals(System.getenv("foo")) 在 Microsoft Windows 中可能为真。

参数：
name - 环境变量的名称
返回：
变量的字符串值，如果变量不是在系统环境中定义的，则返回 null
抛出：
NullPointerException - 如果 name 为 null
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许访问环境变量 name
另请参见：
getenv(), ProcessBuilder.environment()

getenv

public static Map<String,String> getenv()
返回一个不能修改的当前系统环境的字符串映射视图。该环境是一个取决于系统的从名称到值的映射，它从父进程传递给子进程。

如果系统不支持环境变量，则返回一个空映射。

返回的映射永远不会包含 null 键或 Null 值。如果试图查询 null 键或 Null 值的存在，则会抛出 NullPointerException。如果试图查询不是 String 类型的键或值的存在，则会抛出 ClassCastException。

返回的映射及其集合视图可能没有遵守 Object.equals(java.lang.Object) 和 Object.hashCode() 方法的通用协定。

在所有的平台上，返回的映射通常都是区分大小写的。

如果安全管理器存在，则通过 RuntimePermission("getenv.*") 权限调用 checkPermission 方法。这可能导致抛出 SecurityException。

将信息传递给 Java 子进程时，系统属性一般优先于环境变量。

返回：
作为变量名称到值的映射的环境
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许访问进程环境
从以下版本开始：
1.5
另请参见：
getenv(String), ProcessBuilder.environment()

exit

public static void exit(int status)
终止当前正在运行的 Java 虚拟机。参数用作状态码；根据惯例，非 0 的状态码表示异常终止。

该方法调用 Runtime 类中的 exit 方法。该方法永远不会正常返回。

调用 System.exit(n) 实际上等效于调用：

 Runtime.getRuntime().exit(n)

参数：
status - 退出状态。
抛出：
SecurityException - 如果安全管理器存在并且其 checkExit 方法不允许以指定状态退出。
另请参见：
Runtime.exit(int)

gc

public static void gc()
运行垃圾回收器。

调用 gc 方法暗示着 Java 虚拟机做了一些努力来回收未用对象，以便能够快速地重用这些对象当前占用的内存。当控制权从方法调用中返回时，虚拟机已经尽最大努力从所有丢弃的对象中回收了空间。

调用 System.gc() 实际上等效于调用：

 Runtime.getRuntime().gc()

另请参见：
Runtime.gc()

runFinalization

public static void runFinalization()
运行处于挂起终止状态的所有对象的终止方法。

调用该方法说明 Java 虚拟机做了一些努力运行已被丢弃对象的 finalize 方法，但是这些对象的 finalize 方法至今尚未运行。当控制权从方法调用中返回时，Java 虚拟机已经尽最大努力去完成所有未执行的终止方法。

调用 System.runFinalization() 实际上等效于调用：

 Runtime.getRuntime().runFinalization()

另请参见：
Runtime.runFinalization()

runFinalizersOnExit

@Deprecated
public static void runFinalizersOnExit(boolean value)
已过时。 该方法具有固有的不安全性。它可能对正在使用的对象调用终结方法，而其他线程同时正在操作这些对象，从而导致不正确的行为或死锁。

在退出时启用或禁用终结；这样做可指定，拥有未被自动调用终结方法的所有对象的终结方法在退出 Java 运行库前运行。默认情况下，禁用退出时终结。

如果有安全管理器，则首先使用 0 作为参数来调用其 checkExit 方法，以确保允许退出。这可能导致抛出 SecurityException。

参数：
value - 指示启用或禁用终止操作的值
抛出：
SecurityException - 如果安全管理器存在并且其 checkExit 方法不允许退出。
从以下版本开始：
JDK1.1
另请参见：
Runtime.exit(int),
Runtime.gc(),
SecurityManager.checkExit(int)

load

public static void load(String filename)
从作为动态库的本地文件系统中以指定的文件名加载代码文件。文件名参数必须是完整的路径名。

调用 System.load(name) 实际上等效于调用：

 Runtime.getRuntime().load(name)

参数：
filename - 要加载的文件。
抛出：
SecurityException - 如果安全管理器存在并且其 checkLink 方法不允许加载指定的动态库。
UnsatisfiedLinkError - 如果文件不存在。
NullPointerException - 如果 filename 为 null
另请参见：
Runtime.load(java.lang.String), SecurityManager.checkLink(java.lang.String)

loadLibrary

public static void loadLibrary(String libname)
加载由 libname 参数指定的系统库。将库名映射到实际系统库的方法取决于系统。

调用 System.loadLibrary(name) 实际上等效于调用：

 Runtime.getRuntime().loadLibrary(name)

参数：
libname - 库名。
抛出：
SecurityException - 如果安全管理器存在并且其 checkLink 方法不允许加载指定的动态库。
UnsatisfiedLinkError - 如果库不存在。
NullPointerException - 如果 libname 为 null
另请参见：
Runtime.loadLibrary(java.lang.String), SecurityException, SecurityManager.checkLink(java.lang.String)

mapLibraryName

public static String mapLibraryName(String libname)
将一个库名称映射到特定于平台的、表示本机库的字符串中。

参数：
libname - 库名。
返回：
取决于平台的本机库名称。
抛出：
NullPointerException - 如果 libname 为 null。
从以下版本开始：
1.2
另请参见：
loadLibrary(java.lang.String), ClassLoader.findLibrary(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Thread (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Thread

java.lang.Object
    继承者  java.lang.Thread
所有已实现的接口：
Runnable
public class Thread
extends Object
implements Runnable

线程 是程序中的执行线程。Java 虚拟机允许应用程序并发地运行多个执行线程。

每个线程都有一个优先级，高优先级线程的执行优先于低优先级线程。每个线程都可以或不可以标记为一个守护程序。当某个线程中运行的代码创建一个新 Thread 对象时，该新线程的初始优先级被设定为创建线程的优先级，并且当且仅当创建线程是守护线程时，新线程才是守护程序。

当 Java 虚拟机启动时，通常都会有单个非守护线程（它通常会调用某个指定类的 main 方法）。Java 虚拟机会继续执行线程，直到下列任一情况出现时为止：

  • 调用了 Runtime 类的 exit 方法，并且安全管理器允许退出操作发生。
  • 非守护线程的所有线程都已停止运行，无论是通过从对 run 方法的调用中返回，还是通过抛出一个传播到 run 方法之外的异常。

创建新执行线程有两种方法。一种方法是将类声明为 Thread 的子类。该子类应重写 Thread 类的 run 方法。接下来可以分配并启动该子类的实例。例如，计算大于某一规定值的质数的线程可以写成：

     class PrimeThread extends Thread {
         long minPrime;
         PrimeThread(long minPrime) {
             this.minPrime = minPrime;
         }

         public void run() {
             // compute primes larger than minPrime
              . . .
         }
     }

然后，下列代码会创建并启动一个线程：

     PrimeThread p = new PrimeThread(143);
     p.start();

创建线程的另一种方法是声明实现 Runnable 接口的类。该类然后实现 run 方法。然后可以分配该类的实例，在创建 Thread 时作为一个参数来传递并启动。采用这种风格的同一个例子如下所示：

     class PrimeRun implements Runnable {
         long minPrime;
         PrimeRun(long minPrime) {
             this.minPrime = minPrime;
         }

         public void run() {
             // compute primes larger than minPrime
              . . .
         }
     }

然后，下列代码会创建并启动一个线程：

     PrimeRun p = new PrimeRun(143);
     new Thread(p).start();

每个线程都有一个标识名，多个线程可以同名。如果线程创建时没有指定标识名，就会为其生成一个新名称。

从以下版本开始：
JDK1.0
另请参见：
Runnable,
Runtime.exit(int),
run(),
stop()

嵌套类摘要
static class | Thread.State 线程状态。
static interface | Thread.UncaughtExceptionHandler 当 Thread 因未捕获的异常而突然终止时，调用处理程序的接口。
字段摘要
static int | MAX_PRIORITY 线程可以具有的最高优先级。
static int | MIN_PRIORITY 线程可以具有的最低优先级。
static int | NORM_PRIORITY 分配给线程的默认优先级。
构造方法摘要
Thread()
分配新的 Thread 对象。
Thread(Runnable target)
分配新的 Thread 对象。
Thread(Runnable target, String name)
分配新的 Thread 对象。
Thread(String name)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target, String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。
Thread(ThreadGroup group, Runnable target, String name, long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。
Thread(ThreadGroup group, String name)
分配新的 Thread 对象。
方法摘要
static int activeCount()
返回当前线程的线程组中活动线程的数目。
 void checkAccess()
判定当前运行的线程是否有权修改该线程。
 int countStackFrames()
已过时。 该调用的定义依赖于 suspend()，但它遭到了反对。此外，该调用的结果从来都不是意义明确的。
static Thread currentThread()
返回对当前正在执行的线程对象的引用。
 void destroy()
已过时。 该方法最初用于破坏该线程，但不作任何清除。它所保持的任何监视器都会保持锁定状态。不过，该方法决不会被实现。即使要实现，它也极有可能以 suspend() 方式被死锁。如果目标线程被破坏时保持一个保护关键系统资源的锁，则任何线程在任何时候都无法再次访问该资源。如果另一个线程曾试图锁定该资源，则会出现死锁。这类死锁通常会证明它们自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
static void dumpStack()
将当前线程的堆栈跟踪打印至标准错误流。
static int enumerate(Thread[] tarray)
将当前线程的线程组及其子组中的每一个活动线程复制到指定的数组中。
static Map<Thread,StackTraceElement[]> getAllStackTraces()
返回所有活动线程的堆栈跟踪的一个映射。
 ClassLoader getContextClassLoader()
返回该线程的上下文 ClassLoader。
static Thread.UncaughtExceptionHandler getDefaultUncaughtExceptionHandler()
返回线程由于未捕获到异常而突然终止时调用的默认处理程序。
 long getId()
返回该线程的标识符。
 String getName()
返回该线程的名称。
 int getPriority()
返回线程的优先级。
 StackTraceElement[] getStackTrace()
返回一个表示该线程堆栈转储的堆栈跟踪元素数组。
 Thread.State getState()
返回该线程的状态。
 ThreadGroup getThreadGroup()
返回该线程所属的线程组。
 Thread.UncaughtExceptionHandler getUncaughtExceptionHandler()
返回该线程由于未捕获到异常而突然终止时调用的处理程序。
static boolean holdsLock(Object obj)
当且仅当当前线程在指定的对象上保持监视器锁时，才返回 true。
 void interrupt()
中断线程。
static boolean interrupted()
测试当前线程是否已经中断。
 boolean isAlive()
测试线程是否处于活动状态。
 boolean isDaemon()
测试该线程是否为守护线程。
 boolean isInterrupted()
测试线程是否已经中断。
 void join()
等待该线程终止。
 void join(long millis)
等待该线程终止的时间最长为 millis 毫秒。
 void join(long millis, int nanos)
等待该线程终止的时间最长为 millis 毫秒 + nanos 纳秒。
 void resume()
已过时。 该方法只与 suspend() 一起使用，但 suspend() 已经遭到反对，因为它具有死锁倾向。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void run()
如果该线程是使用独立的 Runnable 运行对象构造的，则调用该 Runnable 对象的 run 方法；否则，该方法不执行任何操作并返回。
 void setContextClassLoader(ClassLoader cl)
设置该线程的上下文 ClassLoader。
 void setDaemon(boolean on)
将该线程标记为守护线程或用户线程。
static void setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh)
设置当线程由于未捕获到异常而突然终止，并且没有为该线程定义其他处理程序时所调用的默认处理程序。
 void setName(String name)
改变线程名称，使之与参数 name 相同。
 void setPriority(int newPriority)
更改线程的优先级。
 void setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh)
设置该线程由于未捕获到异常而突然终止时调用的处理程序。
static void sleep(long millis)
在指定的毫秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
static void sleep(long millis, int nanos)
在指定的毫秒数加指定的纳秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
 void start()
使该线程开始执行；Java 虚拟机调用该线程的 run 方法。
 void stop()
已过时。 该方法具有固有的不安全性。用 Thread.stop 来终止线程将释放它已经锁定的所有监视器（作为沿堆栈向上传播的未检查 ThreadDeath 异常的一个自然后果）。如果以前受这些监视器保护的任何对象都处于一种不一致的状态，则损坏的对象将对其他线程可见，这有可能导致任意的行为。stop 的许多使用都应由只修改某些变量以指示目标线程应该停止运行的代码来取代。目标线程应定期检查该变量，并且如果该变量指示它要停止运行，则从其运行方法依次返回。如果目标线程等待很长时间（例如基于一个条件变量），则应使用 interrupt 方法来中断该等待。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void stop(Throwable obj)
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void suspend()
已过时。 该方法已经遭到反对，因为它具有固有的死锁倾向。如果目标线程挂起时在保护关键系统资源的监视器上保持有锁，则在目标线程重新开始以前任何线程都不能访问该资源。如果重新开始目标线程的线程想在调用 resume 之前锁定该监视器，则会发生死锁。这类死锁通常会证明自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 String toString()
返回该线程的字符串表示形式，包括线程名称、优先级和线程组。
static void yield()
暂停当前正在执行的线程对象，并执行其他线程。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

MIN_PRIORITY

public static final int MIN_PRIORITY
线程可以具有的最低优先级。

另请参见：
常量字段值

NORM_PRIORITY

public static final int NORM_PRIORITY
分配给线程的默认优先级。

另请参见：
常量字段值

MAX_PRIORITY

public static final int MAX_PRIORITY
线程可以具有的最高优先级。

另请参见：
常量字段值
构造方法详细信息

Thread

public Thread()
分配新的 Thread 对象。这种构造方法与 Thread(null, null, gname) 具有相同的作用，其中 gname 是一个新生成的名称。自动生成的名称的形式为 "Thread-"+n，其中的 n 为整数。

另请参见：
Thread(ThreadGroup, Runnable, String)

Thread

public Thread(Runnable target)
分配新的 Thread 对象。这种构造方法与 Thread(null, target,gname) 具有相同的作用，其中的 gname 是一个新生成的名称。自动生成的名称的形式为 “Thread-”+n，其中的 n 为整数。

参数：
target - 其 run 方法被调用的对象。
另请参见：
Thread(ThreadGroup, Runnable, String)

Thread

public Thread(ThreadGroup group,
              Runnable target)
分配新的 Thread 对象。这种构造方法与 Thread(group, target, gname) 具有相同的作用，其中的 gname 是一个新生成的名称。自动生成的名称的形式为 "Thread-"+n ，其中的 n 为整数。

参数：
group - 线程组。
target - 其 run 方法被调用的对象。
抛出：
SecurityException - 如果当前线程无法在指定的线程组中创建线程。
另请参见：
Thread(ThreadGroup, Runnable, String)

Thread

public Thread(String name)
分配新的 Thread 对象。这种构造方法与 Thread(null, null, name) 具有相同的作用。

参数：
name - 新线程的名称。
另请参见：
Thread(ThreadGroup, Runnable, String)

Thread

public Thread(ThreadGroup group,
              String name)
分配新的 Thread 对象。这种构造方法与 Thread(group, null, name) 具有相同的作用。

参数：
group - 线程组。
name - 新线程的名称。
抛出：
SecurityException - 如果当前线程无法在指定的线程组中创建线程。
另请参见：
Thread(ThreadGroup, Runnable, String)

Thread

public Thread(Runnable target,
              String name)
分配新的 Thread 对象。这种构造方法与 Thread(null, target, name) 具有相同的作用。

参数：
target - 其 run 方法被调用的对象。
name - 新线程的名称。
另请参见：
Thread(ThreadGroup, Runnable, String)

Thread

public Thread(ThreadGroup group,
              Runnable target,
              String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。

如果 group 为 null，并且有安全管理器，则该组由安全管理器的 getThreadGroup 方法确定。如果 group 为 null，并且没有安全管理器，或安全管理器的 getThreadGroup 方法返回 null，则该组与创建新线程的线程被设定为相同的 ThreadGroup。

如果有安全管理器，则其 checkAccess 方法通过 ThreadGroup 作为其参数被调用。

此外，当被重写 getContextClassLoader 或 setContextClassLoader 方法的子类构造方法直接或间接调用时，其 checkPermission 方法通过 RuntimePermission("enableContextClassLoaderOverride") 权限调用。其结果可能是 SecurityException。

如果 target 参数不是 null，则 target 的 run 方法在启动该线程时调用。如果 target 参数为 null，则该线程的 run 方法在该线程启动时调用。

新创建线程的优先级被设定为创建该线程的线程的优先级，即当前正在运行的线程的优先级。方法 setPriority 可用于将优先级更改为一个新值。

当且仅当创建新线程的线程当前被标记为守护线程时，新创建的线程才被标记为守护线程。方法 setDaemon 可用于改变线程是否为守护线程。

参数：
group - 线程组。
target - 其 run 方法被调用的对象。
name - 新线程的名称。
抛出：
SecurityException - 如果当前线程无法在指定的线程组中创建线程，或者无法重写上下文类加载器方法。
另请参见：
Runnable.run(), run(), setDaemon(boolean), setPriority(int), ThreadGroup.checkAccess(), SecurityManager.checkAccess(java.lang.Thread)

Thread

public Thread(ThreadGroup group,
              Runnable target,
              String name,
              long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。

除了允许指定线程堆栈大小以外，这种构造方法与 Thread(ThreadGroup,Runnable,String) 完全一样。堆栈大小是虚拟机要为该线程堆栈分配的地址空间的近似字节数。 stackSize 参数（如果有）的作用具有高度的平台依赖性。

在某些平台上，指定一个较高的 stackSize 参数值可能使线程在抛出 StackOverflowError 之前达到较大的递归深度。同样，指定一个较低的值将允许较多的线程并发地存在，且不会抛出 OutOfMemoryError（或其他内部错误）。stackSize 参数的值与最大递归深度和并发程度之间的关系细节与平台有关。在某些平台上，stackSize 参数的值无论如何不会起任何作用。

作为建议，可以让虚拟机自由处理 stackSize 参数。如果指定值对于平台来说过低，则虚拟机可能使用某些特定于平台的最小值；如果指定值过高，则虚拟机可能使用某些特定于平台的最大值。 同样，虚拟机还会视情况自由地舍入指定值（或完全忽略它）。

将 stackSize 参数值指定为零将使这种构造方法与 Thread(ThreadGroup, Runnable, String) 构造方法具有完全相同的作用。

由于这种构造方法的行为具有平台依赖性，因此在使用它时要非常小心。执行特定计算所必需的线程堆栈大小可能会因 JRE 实现的不同而不同。鉴于这种不同，仔细调整堆栈大小参数可能是必需的，而且可能要在支持应用程序运行的 JRE 实现上反复调整。

实现注意事项：鼓励 Java 平台实现者文档化其 stackSize parameter 的实现行为。

参数：
group - 线程组。
target - 其 run 方法被调用的对象。
name - 新线程的名称。
stackSize - 新线程的预期堆栈大小，为零时表示忽略该参数。
抛出：
SecurityException - 如果当前线程无法在指定的线程组中创建线程。
从以下版本开始：
1.4
方法详细信息

currentThread

public static Thread currentThread()
返回对当前正在执行的线程对象的引用。

返回：
当前执行的线程。

yield

public static void yield()
暂停当前正在执行的线程对象，并执行其他线程。

sleep

public static void sleep(long millis)
                  throws InterruptedException
在指定的毫秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。该线程不丢失任何监视器的所属权。

参数：
millis - 以毫秒为单位的休眠时间。
抛出：
InterruptedException - 如果任何线程中断了当前线程。当抛出该异常时，当前线程的中断状态 被清除。
另请参见：
Object.notify()

sleep

public static void sleep(long millis,
                         int nanos)
                  throws InterruptedException
在指定的毫秒数加指定的纳秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。该线程不丢失任何监视器的所属权。

参数：
millis - 以毫秒为单位的休眠时间。
nanos - 要休眠的另外 0-999999 纳秒。
抛出：
IllegalArgumentException - 如果 millis 值为负或 nanos 值不在 0-999999 范围内。
InterruptedException - 如果任何线程中断了当前线程。当抛出该异常时，当前线程的中断状态 被清除。
另请参见：
Object.notify()

start

public void start()
使该线程开始执行；Java 虚拟机调用该线程的 run 方法。

结果是两个线程并发地运行；当前线程（从调用返回给 start 方法）和另一个线程（执行其 run 方法）。

多次启动一个线程是非法的。特别是当线程已经结束执行后，不能再重新启动。

抛出：
IllegalThreadStateException - 如果线程已经启动。
另请参见：
run(), stop()

run

public void run()
如果该线程是使用独立的 Runnable 运行对象构造的，则调用该 Runnable 对象的 run 方法；否则，该方法不执行任何操作并返回。

Thread 的子类应该重写该方法。

指定者：
接口 Runnable 中的 run
另请参见：
start(),
stop(),
Thread(ThreadGroup, Runnable, String)

stop

@Deprecated
public final void stop()
已过时。 该方法具有固有的不安全性。用 Thread.stop 来终止线程将释放它已经锁定的所有监视器（作为沿堆栈向上传播的未检查 ThreadDeath 异常的一个自然后果）。如果以前受这些监视器保护的任何对象都处于一种不一致的状态，则损坏的对象将对其他线程可见，这有可能导致任意的行为。stop 的许多使用都应由只修改某些变量以指示目标线程应该停止运行的代码来取代。目标线程应定期检查该变量，并且如果该变量指示它要停止运行，则从其运行方法依次返回。如果目标线程等待很长时间（例如基于一个条件变量），则应使用 interrupt 方法来中断该等待。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。

强迫线程停止执行。

如果安装了安全管理器，则以 this 作为其参数调用 checkAccess 方法。这可能引发 SecurityException（在当前线程中）。

如果该线程不同于当前线程（即当前线程试图终止除它本身以外的某一线程），则安全管理器的 checkPermission 方法（带有 RuntimePermission("stopThread") 参数）也会被调用。这会再次抛出 SecurityException（在当前线程中）。

无论该线程在做些什么，它所代表的线程都被迫异常停止，并抛出一个新创建的 ThreadDeath 对象，作为异常。

停止一个尚未启动的线程是允许的。 如果最后启动了该线程，它会立即终止。

应用程序通常不应试图捕获 ThreadDeath，除非它必须执行某些异常的清除操作（注意，抛出 ThreadDeath 将导致 try 语句的 finally 子句在线程正式终止前执行）。如果 catch 子句捕获了一个 ThreadDeath 对象，则重新抛出该对象很重要，因为这样该线程才会真正终止。

对其他未捕获的异常作出反应的顶级错误处理程序不会打印输出消息，或者另外通知应用程序未捕获到的异常是否为 ThreadDeath 的一个实例。

抛出：
SecurityException - 如果当前线程不能修改该线程。
另请参见：
interrupt(),
checkAccess(),
run(),
start(),
ThreadDeath,
ThreadGroup.uncaughtException(Thread,Throwable),
SecurityManager.checkAccess(Thread),
SecurityManager.checkPermission(java.security.Permission)

stop

@Deprecated
public final void stop(Throwable obj)
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。

强迫线程停止执行。

如果安装了安全管理器，则调用该线程的 checkAccess 方法，这可能引发 SecurityException（在当前线程中）。

如果该线程不同于当前线程（即当前线程试图终止除它本身以外的某一线程），或者 obj 不是 ThreadDeath 的一个实例，则安全管理器的 checkPermission 方法（带有 RuntimePermission("stopThread") 参数）也会被调用。 此外，这可能抛出 SecurityException（在当前线程中）。

如果参数 obj 为 null，则抛出 NullPointerException（在当前线程中）。

无论该线程在做些什么，它所代表的线程都被迫异常停止，并抛出 Throwable 对象 obj，作为一个异常。这是一种不正常的操作，通常情况下，应使用不带任何参数的 stop 方法。

停止一个尚未启动的线程是允许的。 如果最后启动了该线程，它会立即终止。

参数：
obj - 要抛出的可抛出对象。
抛出：
SecurityException - 如果当前线程不能修改该线程。
NullPointerException - 如果 obj 为 null。
另请参见：
interrupt(),
checkAccess(),
run(),
start(),
stop(),
SecurityManager.checkAccess(Thread),
SecurityManager.checkPermission(java.security.Permission)

interrupt

public void interrupt()
中断线程。

如果当前线程没有中断它自己（这在任何情况下都是允许的），则该线程的 checkAccess 方法就会被调用，这可能抛出 SecurityException。

如果线程在调用 Object 类的 wait()、wait(long) 或 wait(long, int) 方法，或者该类的 join()、join(long)、join(long, int)、sleep(long) 或 sleep(long, int) 方法过程中受阻，则其中断状态将被清除，它还将收到一个 InterruptedException。

如果该线程在可中断的通道上的 I/O 操作中受阻，则该通道将被关闭，该线程的中断状态将被设置并且该线程将收到一个 ClosedByInterruptException。

如果该线程在一个 Selector 中受阻，则该线程的中断状态将被设置，它将立即从选择操作返回，并可能带有一个非零值，就好像调用了选择器的 wakeup 方法一样。

如果以前的条件都没有保存，则该线程的中断状态将被设置。

中断一个不处于活动状态的线程不需要任何作用。

抛出：
SecurityException - 如果当前线程无法修改该线程

interrupted

public static boolean interrupted()
测试当前线程是否已经中断。线程的中断状态 由该方法清除。换句话说，如果连续两次调用该方法，则第二次调用将返回 false（在第一次调用已清除了其中断状态之后，且第二次调用检验完中断状态前，当前线程再次中断的情况除外）。

线程中断被忽略，因为在中断时不处于活动状态的线程将由此返回 false 的方法反映出来。

返回：
如果当前线程已经中断，则返回 true；否则返回 false。
另请参见：
isInterrupted()

isInterrupted

public boolean isInterrupted()
测试线程是否已经中断。线程的中断状态 不受该方法的影响。

线程中断被忽略，因为在中断时不处于活动状态的线程将由此返回 false 的方法反映出来。

返回：
如果该线程已经中断，则返回 true；否则返回 false。
另请参见：
interrupted()

destroy

@Deprecated
public void destroy()
已过时。 该方法最初用于破坏该线程，但不作任何清除。它所保持的任何监视器都会保持锁定状态。不过，该方法决不会被实现。即使要实现，它也极有可能以 suspend() 方式被死锁。如果目标线程被破坏时保持一个保护关键系统资源的锁，则任何线程在任何时候都无法再次访问该资源。如果另一个线程曾试图锁定该资源，则会出现死锁。这类死锁通常会证明它们自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。

抛出 NoSuchMethodError。

抛出：
NoSuchMethodError - 始终

isAlive

public final boolean isAlive()
测试线程是否处于活动状态。如果线程已经启动且尚未终止，则为活动状态。

返回：
如果该线程处于活动状态，则返回 true；否则返回 false。

suspend

@Deprecated
public final void suspend()
已过时。 该方法已经遭到反对，因为它具有固有的死锁倾向。如果目标线程挂起时在保护关键系统资源的监视器上保持有锁，则在目标线程重新开始以前任何线程都不能访问该资源。如果重新开始目标线程的线程想在调用 resume 之前锁定该监视器，则会发生死锁。这类死锁通常会证明自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。

挂起线程。

首先，调用线程的 checkAccess 方法，且不带任何参数。这可能抛出 SecurityException（在当前线程中）。

如果线程处于活动状态则被挂起，且不再有进一步的活动，除非重新开始。

抛出：
SecurityException - 如果当前线程不能修改该线程。
另请参见：
checkAccess()

resume

@Deprecated
public final void resume()
已过时。 该方法只与 suspend() 一起使用，但 suspend() 已经遭到反对，因为它具有死锁倾向。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。

重新开始挂起的进程。

首先，调用线程的 checkAccess 方法，且不带任何参数。这可能抛出 SecurityException（在当前线程中）。

如果线程处于活动状态但被挂起，则它会在执行过程中重新开始并允许继续活动。

抛出：
SecurityException - 如果当前线程不能修改该线程。
另请参见：
checkAccess(), suspend()

setPriority

public final void setPriority(int newPriority)
更改线程的优先级。

首先调用线程的 checkAccess 方法，且不带任何参数。这可能抛出 SecurityException。

在其他情况下，线程优先级被设定为指定的 newPriority 和该线程的线程组的最大允许优先级相比较小的一个。

参数：
newPriority - 要为线程设定的优先级
抛出：
IllegalArgumentException - 如果优先级不在 MIN_PRIORITY 到 MAX_PRIORITY 范围内。
SecurityException - 如果当前线程无法修改该线程。
另请参见：
getPriority(),
checkAccess(),
getThreadGroup(),
MAX_PRIORITY,
MIN_PRIORITY,
ThreadGroup.getMaxPriority()

getPriority

public final int getPriority()
返回线程的优先级。

返回：
该线程的优先级。
另请参见：
setPriority(int)

setName

public final void setName(String name)
改变线程名称，使之与参数 name 相同。

首先调用线程的 checkAccess 方法，且不带任何参数。这可能抛出 SecurityException。

参数：
name - 该线程的新名称。
抛出：
SecurityException - 如果当前线程不能修改该线程。
另请参见：
getName(), checkAccess()

getName

public final String getName()
返回该线程的名称。

返回：
该线程的名称。
另请参见：
setName(String)

getThreadGroup

public final ThreadGroup getThreadGroup()
返回该线程所属的线程组。 如果该线程已经终止（停止运行），该方法则返回 null。

返回：
该线程的线程组。

activeCount

public static int activeCount()
返回当前线程的线程组中活动线程的数目。

返回：
当前线程的线程组中活动线程的数目。

enumerate

public static int enumerate(Thread[] tarray)
将当前线程的线程组及其子组中的每一个活动线程复制到指定的数组中。该方法只调用当前线程的线程组的 enumerate 方法，且带有数组参数。

首先，如果有安全管理器，则 enumerate 方法调用安全管理器的 checkAccess 方法，并将线程组作为其参数。这可能导致抛出 SecurityException。

参数：
tarray - 要复制到的线程对象数组
返回：
放入该数组的线程数
抛出：
SecurityException - 如果安全管理器存在，并且其 checkAccess 方法不允许该操作。
另请参见：
ThreadGroup.enumerate(Thread[]), SecurityManager.checkAccess(ThreadGroup)

countStackFrames

@Deprecated
public int countStackFrames()
已过时。 该调用的定义依赖于 suspend()，但它遭到了反对。此外，该调用的结果从来都不是意义明确的。

计算该线程中的堆栈帧数。线程必须挂起。

返回：
该线程中的堆栈帧数。
抛出：
IllegalThreadStateException - 如果该线程未挂起。

join

public final void join(long millis)
                throws InterruptedException
等待该线程终止的时间最长为 millis 毫秒。超时为 0 意味着要一直等下去。

参数：
millis - 以毫秒为单位的等待时间。
抛出：
InterruptedException - 如果任何线程中断了当前线程。当抛出该异常时，当前线程的中断状态 被清除。

join

public final void join(long millis,
                       int nanos)
                throws InterruptedException
等待该线程终止的时间最长为 millis 毫秒 + nanos 纳秒。

参数：
millis - 以毫秒为单位的等待时间。
nanos - 要等待的 0-999999 附加纳秒。
抛出：
IllegalArgumentException - 如果 millis 值为负，则 nanos 的值不在 0-999999 范围内。
InterruptedException - 如果任何线程中断了当前线程。当抛出该异常时，当前线程的中断状态 被清除。

join

public final void join()
                throws InterruptedException
等待该线程终止。

抛出：
InterruptedException - 如果任何线程中断了当前线程。当抛出该异常时，当前线程的中断状态 被清除。

dumpStack

public static void dumpStack()
将当前线程的堆栈跟踪打印至标准错误流。该方法仅用于调试。

另请参见：
Throwable.printStackTrace()

setDaemon

public final void setDaemon(boolean on)
将该线程标记为守护线程或用户线程。当正在运行的线程都是守护线程时，Java 虚拟机退出。

该方法必须在启动线程前调用。

该方法首先调用该线程的 checkAccess 方法，且不带任何参数。这可能抛出 SecurityException（在当前线程中）。

参数：
on - 如果为 true，则将该线程标记为守护线程。
抛出：
IllegalThreadStateException - 如果该线程处于活动状态。
SecurityException - 如果当前线程无法修改该线程。
另请参见：
isDaemon(), checkAccess()

isDaemon

public final boolean isDaemon()
测试该线程是否为守护线程。

返回：
如果该线程是守护线程，则返回 true；否则返回 false。
另请参见：
setDaemon(boolean)

checkAccess

public final void checkAccess()
判定当前运行的线程是否有权修改该线程。

如果有安全管理器，则调用其 checkAccess 方法，并将该线程作为其参数。这可能导致抛出 SecurityException。

抛出：
SecurityException - 如果不允许当前线程访问该线程。
另请参见：
SecurityManager.checkAccess(Thread)

toString

public String toString()
返回该线程的字符串表示形式，包括线程名称、优先级和线程组。

覆盖：
类 Object 中的 toString
返回：
该线程的字符串表示形式。

getContextClassLoader

public ClassLoader getContextClassLoader()
返回该线程的上下文 ClassLoader。上下文 ClassLoader 由线程创建者提供，供运行于该线程中的代码在加载类和资源时使用。如果未设定，则默认为父线程的 ClassLoader 上下文。原始线程的上下文 ClassLoader 通常设定为用于加载应用程序的类加载器。

首先，如果有安全管理器，并且调用者的类加载器不是 null，也不同于其上下文类加载器正在被请求的线程上下文类加载器的祖先，则通过 RuntimePermission("getClassLoader") 权限调用该安全管理器的 checkPermission 方法，查看是否可以获取上下文 ClassLoader。

返回：
该线程的上下文 ClassLoader
从以下版本开始：
1.2
另请参见：
setContextClassLoader(java.lang.ClassLoader), SecurityManager.checkPermission(java.security.Permission), RuntimePermission

setContextClassLoader

public void setContextClassLoader(ClassLoader cl)
设置该线程的上下文 ClassLoader。上下文 ClassLoader 可以在创建线程设置，并允许创建者在加载类和资源时向该线程中运行的代码提供适当的类加载器。

首先，如果有安全管理器，则通过 RuntimePermission("setContextClassLoader") 权限调用其 checkPermission 方法，查看是否可以设置上下文 ClassLoader。

参数：
cl - 该线程的上下文 ClassLoader
抛出：
SecurityException - 如果当前线程无法设置上下文 ClassLoader。
从以下版本开始：
1.2
另请参见：
getContextClassLoader(), SecurityManager.checkPermission(java.security.Permission), RuntimePermission

holdsLock

public static boolean holdsLock(Object obj)
当且仅当当前线程在指定的对象上保持监视器锁时，才返回 true。

该方法旨在使程序能够断言当前线程已经保持一个指定的锁：

     assert Thread.holdsLock(obj);

参数：
obj - 用于测试锁所属权的对象
返回：
如果当前线程在指定的对象上保持监视器锁，则返回 true。
抛出：
NullPointerException - 如果 obj 为 null
从以下版本开始：
1.4

getStackTrace

public StackTraceElement[] getStackTrace()
返回一个表示该线程堆栈转储的堆栈跟踪元素数组。如果该线程尚未启动或已经终止，则该方法将返回一个零长度数组。如果返回的数组不是零长度的，则其第一个元素代表堆栈顶，它是该序列中最新的方法调用。最后一个元素代表堆栈底，是该序列中最旧的方法调用。

如果有安全管理器，并且该线程不是当前线程，则通过 RuntimePermission("getStackTrace") 权限调用安全管理器的 checkPermission 方法，查看是否可以获取堆栈跟踪。

某些虚拟机在某些情况下可能会从堆栈跟踪中省略一个或多个堆栈帧。在极端情况下，没有该线程堆栈跟踪信息的虚拟机可以从该方法返回一个零长度数组。

返回：
StackTraceElement 数组，每个数组代表一个堆栈帧。
抛出：
SecurityException - 如果安全管理器存在，并且其 checkPermission 方法不允许获取线程的堆栈跟踪。
从以下版本开始：
1.5
另请参见：
SecurityManager.checkPermission(java.security.Permission), RuntimePermission, Throwable.getStackTrace()

getAllStackTraces

public static Map<Thread,StackTraceElement[]> getAllStackTraces()
返回所有活动线程的堆栈跟踪的一个映射。映射键是线程，而每个映射值都是一个 StackTraceElement 数组，该数组表示相应 Thread 的堆栈转储。 返回的堆栈跟踪的格式都是针对 getStackTrace 方法指定的。

在调用该方法的同时，线程可能也在执行。每个线程的堆栈跟踪仅代表一个快照，并且每个堆栈跟踪都可以在不同时间获得。如果虚拟机没有线程的堆栈跟踪信息，则映射值中将返回一个零长度数组。

如果有安全管理器，则通过 RuntimePermission("getStackTrace") 权限和 RuntimePermission("modifyThreadGroup") 权限调用其 checkPermission 方法，查看是否可以获取所有线程的堆栈跟踪。

返回：
从 Thread 到 StackTraceElement 数组的一个 Map，代表相应线程的堆栈跟踪。
抛出：
SecurityException - 如果安全管理器存在，并且其 checkPermission 方法不允许获取线程的堆栈跟踪。
从以下版本开始：
1.5
另请参见：
getStackTrace(), SecurityManager.checkPermission(java.security.Permission), RuntimePermission, Throwable.getStackTrace()

getId

public long getId()
返回该线程的标识符。线程 ID 是一个正的 long 数，在创建该线程时生成。线程 ID 是唯一的，并终生不变。线程终止时，该线程 ID 可以被重新使用。

返回：
该线程的 ID。
从以下版本开始：
1.5

getState

public Thread.State getState()
返回该线程的状态。 该方法用于监视系统状态，不用于同步控制。

返回：
该线程的状态。
从以下版本开始：
1.5

setDefaultUncaughtExceptionHandler

public static void setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh)
设置当线程由于未捕获到异常而突然终止，并且没有为该线程定义其他处理程序时所调用的默认处理程序。

未捕获到的异常处理首先由线程控制，然后由线程的 ThreadGroup 对象控制，最后由未捕获到的默认异常处理程序控制。如果线程不设置明确的未捕获到的异常处理程序，并且该线程的线程组（包括父线程组）未特别指定其 uncaughtException 方法，则将调用默认处理程序的 uncaughtException 方法。

通过设置未捕获到的默认异常处理程序，应用程序可以为那些已经接受系统提供的任何“默认”行为的线程改变未捕获到的异常处理方式（如记录到某一特定设备或文件）。

请注意，未捕获到的默认异常处理程序通常不应顺从该线程的 ThreadGroup 对象，因为这可能导致无限递归。

参数：
eh - 用作未捕获到的默认异常处理程序的对象。 如果为 null，则没有默认处理程序。
抛出：
SecurityException - 如果安全管理器存在并拒绝 RuntimePermission ("setDefaultUncaughtExceptionHandler")
从以下版本开始：
1.5
另请参见：
setUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler),
getUncaughtExceptionHandler(),
ThreadGroup.uncaughtException(java.lang.Thread, java.lang.Throwable)

getDefaultUncaughtExceptionHandler

public static Thread.UncaughtExceptionHandler getDefaultUncaughtExceptionHandler()
返回线程由于未捕获到异常而突然终止时调用的默认处理程序。如果返回值为 null，则没有默认处理程序。

从以下版本开始：
1.5
另请参见：
setDefaultUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler)

getUncaughtExceptionHandler

public Thread.UncaughtExceptionHandler getUncaughtExceptionHandler()
返回该线程由于未捕获到异常而突然终止时调用的处理程序。如果该线程尚未明确设置未捕获到的异常处理程序，则返回该线程的 ThreadGroup 对象，除非该线程已经终止，在这种情况下，将返回 null。

从以下版本开始：
1.5

setUncaughtExceptionHandler

public void setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh)
设置该线程由于未捕获到异常而突然终止时调用的处理程序。

通过明确设置未捕获到的异常处理程序，线程可以完全控制它对未捕获到的异常作出响应的方式。 如果没有设置这样的处理程序，则该线程的 ThreadGroup 对象将充当其处理程序。

参数：
eh - 用作该线程未捕获到的异常处理程序的对象。如果为 null，则该线程没有明确的处理程序。
抛出：
SecurityException - 如果当前线程无权修改该线程。
从以下版本开始：
1.5
另请参见：
setDefaultUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler), ThreadGroup.uncaughtException(java.lang.Thread, java.lang.Throwable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Thread.State (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.lang
枚举 Thread.State

java.lang.Object
    继承者  java.lang.Enum<Thread.State>
        继承者  java.lang.Thread.State
所有已实现的接口：
Serializable, Comparable<Thread.State>
正在封闭类：
Thread
public static enum Thread.State
extends Enum<Thread.State>

线程状态。线程可以处于下列状态之一：

  • NEW
    至今尚未启动的线程处于这种状态。
  • RUNNABLE
    正在 Java 虚拟机中执行的线程处于这种状态。
  • BLOCKED
    受阻塞并等待某个监视器锁的线程处于这种状态。
  • WAITING
    无限期地等待另一个线程来执行某一特定操作的线程处于这种状态。
  • TIMED_WAITING
    等待另一个线程来执行取决于指定等待时间的操作的线程处于这种状态。
  • TERMINATED
    已退出的线程处于这种状态。

在给定时间点上，一个线程只能处于一种状态。这些状态是虚拟机状态，它们并没有反映所有操作系统线程状态。

从以下版本开始：
1.5
另请参见：
Thread.getState()

枚举常量摘要
BLOCKED
受阻塞并且正在等待监视器锁的某一线程的线程状态。
NEW
至今尚未启动的线程的状态。
RUNNABLE
可运行线程的线程状态。
TERMINATED
已终止线程的线程状态。
TIMED_WAITING
具有指定等待时间的某一等待线程的线程状态。
WAITING
某一等待线程的线程状态。
方法摘要
static Thread.State | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Thread.State[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

NEW

public static final Thread.State NEW
至今尚未启动的线程的状态。

RUNNABLE

public static final Thread.State RUNNABLE
可运行线程的线程状态。处于可运行状态的某一线程正在 Java 虚拟机中运行，但它可能正在等待操作系统中的其他资源，比如处理器。

BLOCKED

public static final Thread.State BLOCKED
受阻塞并且正在等待监视器锁的某一线程的线程状态。处于受阻塞状态的某一线程正在等待监视器锁，以便进入一个同步的块/方法，或者在调用 Object.wait 之后再次进入同步的块/方法。

WAITING

public static final Thread.State WAITING
某一等待线程的线程状态。某一线程因为调用下列方法之一而处于等待状态：
  • 不带超时值的 Object.wait
  • 不带超时值的 Thread.join
  • LockSupport.park

处于等待状态的线程正等待另一个线程，以执行特定操作。 例如，已经在某一对象上调用了 Object.wait() 的线程正等待另一个线程，以便在该对象上调用 Object.notify() 或 Object.notifyAll()。已经调用了 Thread.join() 的线程正在等待指定线程终止。

TIMED_WAITING

public static final Thread.State TIMED_WAITING
具有指定等待时间的某一等待线程的线程状态。某一线程因为调用以下带有指定正等待时间的方法之一而处于定时等待状态：
  • Thread.sleep
  • 带有超时值的 Object.wait
  • 带有超时值的 Thread.join
  • LockSupport.parkNanos
  • LockSupport.parkUntil

TERMINATED

public static final Thread.State TERMINATED
已终止线程的线程状态。线程已经结束执行。

方法详细信息

values

public static final Thread.State[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Thread.State c : Thread.State.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Thread.State valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Thread.UncaughtExceptionHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
接口 Thread.UncaughtExceptionHandler

所有已知实现类：
ThreadGroup
正在封闭类：
Thread
public static interface Thread.UncaughtExceptionHandler

当 Thread 因未捕获的异常而突然终止时，调用处理程序的接口。

当某一线程因未捕获的异常而即将终止时，Java 虚拟机将使用 Thread.getUncaughtExceptionHandler() 查询该线程以获得其 UncaughtExceptionHandler 的线程，并调用处理程序的 uncaughtException 方法，将线程和异常作为参数传递。如果某一线程没有明确设置其 UncaughtExceptionHandler，则将它的 ThreadGroup 对象作为其 UncaughtExceptionHandler。如果 ThreadGroup 对象对处理异常没有什么特殊要求，那么它可以将调用转发给默认的未捕获异常处理程序。

从以下版本开始：
1.5
另请参见：
Thread.setDefaultUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler),
Thread.setUncaughtExceptionHandler(java.lang.Thread.UncaughtExceptionHandler),
ThreadGroup.uncaughtException(java.lang.Thread, java.lang.Throwable)

方法摘要
 void uncaughtException(Thread t, Throwable e)
当给定线程因给定的未捕获异常而终止时，调用该方法。

方法详细信息

uncaughtException

void uncaughtException(Thread t,
                       Throwable e)
当给定线程因给定的未捕获异常而终止时，调用该方法。

Java 虚拟机将忽略该方法抛出的任何异常。

参数：
t - 线程
e - 异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadDeath (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ThreadDeath

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.ThreadDeath
所有已实现的接口：
Serializable
public class ThreadDeath
extends Error

调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。

仅当应用程序在被异步终止后必须清除时才应该捕获这个类的实例。如果 ThreadDeath 被一个方法捕获，那么将它重新抛出非常重要，因为这样才能让该线程真正终止。

如果没有捕获 ThreadDeath，则顶级错误处理程序不会输出消息。

虽然 ThreadDeath 类是“正常出现”的，但它只能是 Error 的子类而不是 Exception 的子类，因为许多应用程序捕获所有出现的 Exception，然后又将其放弃。

从以下版本开始：
JDK1.0
另请参见：
Thread.stop(), 序列化表格

构造方法摘要
ThreadDeath()
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ThreadDeath

public ThreadDeath()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadGroup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ThreadGroup

java.lang.Object
    继承者  java.lang.ThreadGroup
所有已实现的接口：
Thread.UncaughtExceptionHandler
public class ThreadGroup
extends Object
implements Thread.UncaughtExceptionHandler

线程组表示一个线程的集合。此外，线程组也可以包含其他线程组。线程组构成一棵树，在树中，除了初始线程组外，每个线程组都有一个父线程组。

允许线程访问有关自己的线程组的信息，但是不允许它访问有关其线程组的父线程组或其他任何线程组的信息。

从以下版本开始：
JDK1.0

构造方法摘要
ThreadGroup(String name)
构造一个新线程组。
ThreadGroup(ThreadGroup parent, String name)
创建一个新线程组。
方法摘要
 int activeCount()
返回此线程组中活动线程的估计数。
 int activeGroupCount()
返回此线程组中活动线程组的估计数。
 boolean allowThreadSuspension(boolean b)
已过时。 此调用的定义取决于 suspend()，它被废弃了。更进一步地说，此调用的行为从不被指定。
 void checkAccess()
确定当前运行的线程是否有权修改此线程组。
 void destroy()
销毁此线程组及其所有子组。
 int enumerate(Thread[] list)
把此线程组及其子组中的所有活动线程复制到指定数组中。
 int enumerate(Thread[] list, boolean recurse)
把此线程组中的所有活动线程复制到指定数组中。
 int enumerate(ThreadGroup[] list)
把对此线程组中的所有活动子组的引用复制到指定数组中。
 int enumerate(ThreadGroup[] list, boolean recurse)
把对此线程组中的所有活动子组的引用复制到指定数组中。
 int getMaxPriority()
返回此线程组的最高优先级。
 String getName()
返回此线程组的名称。
 ThreadGroup getParent()
返回此线程组的父线程组。
 void interrupt()
中断此线程组中的所有线程。
 boolean isDaemon()
测试此线程组是否为一个后台程序线程组。
 boolean isDestroyed()
测试此线程组是否已经被销毁。
 void list()
将有关此线程组的信息打印到标准输出。
 boolean parentOf(ThreadGroup g)
测试此线程组是否为线程组参数或其祖先线程组之一。
 void resume()
已过时。 此方法只用于联合 Thread.suspend 和 ThreadGroup.suspend 时，因为它们所固有的容易导致死锁的特性，所以两者都已废弃。有关详细信息，请参阅 Thread.suspend()。
 void setDaemon(boolean daemon)
更改此线程组的后台程序状态。
 void setMaxPriority(int pri)
设置线程组的最高优先级。
 void stop()
已过时。 此方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。
 void suspend()
已过时。 此方法容易导致死锁。有关详细信息，请参阅 Thread.suspend()。
 String toString()
返回此线程组的字符串表示形式。
 void uncaughtException(Thread t, Throwable e)
当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ThreadGroup

public ThreadGroup(String name)
构造一个新线程组。新线程组的父线程组是目前正在运行线程的线程组。

不使用任何参数调用父线程组的 checkAccess 方法；这可能导致一个安全性异常。

参数：
name - 新线程组的名称。
抛出：
SecurityException - 如果当前线程不能在指定的线程组中创建线程。
从以下版本开始：
JDK1.0
另请参见：
checkAccess()

ThreadGroup

public ThreadGroup(ThreadGroup parent,
                   String name)
创建一个新线程组。新线程组的父线程组是指定的线程组。

不使用任何参数调用父线程组的 checkAccess 方法；这可能导致一个安全性异常。

参数：
parent - 父线程组。
name - 新线程组的名称。
抛出：
NullPointerException - 如果线程组参数为 null。
SecurityException - 如果当前线程不能在指定的线程组中创建线程。
从以下版本开始：
JDK1.0
另请参见：
SecurityException, checkAccess()
方法详细信息

getName

public final String getName()
返回此线程组的名称。

返回：
此线程组的名称。
从以下版本开始：
JDK1.0

getParent

public final ThreadGroup getParent()
返回此线程组的父线程组。

首先，如果父线程组不为 null，则不使用任何参数直接调用父线程组的 checkAccess 方法；这可能导致一个安全性异常。

返回：
线程组的父线程组。顶级线程组仅为那些父线程组为 null 的线程组。
抛出：
SecurityException - 如果当前线程无法修改此线程组。
从以下版本开始：
JDK1.0
另请参见：
checkAccess(), SecurityException, RuntimePermission

getMaxPriority

public final int getMaxPriority()
返回此线程组的最高优先级。作为此线程组一部分的线程不能拥有比最高优先级更高的优先级。

返回：
此线程组中的线程可拥有的最高优先级。
从以下版本开始：
JDK1.0
另请参见：
setMaxPriority(int)

isDaemon

public final boolean isDaemon()
测试此线程组是否为一个后台程序线程组。在停止后台程序线程组的最后一个线程或销毁其最后一个线程组时，自动销毁这个后台程序线程组。

返回：
如果此线程组是一个后台程序线程组，则返回 true；否则返回 false。
从以下版本开始：
JDK1.0

isDestroyed

public boolean isDestroyed()
测试此线程组是否已经被销毁。

返回：
如果此对象被销毁，则返回 true
从以下版本开始：
JDK1.1

setDaemon

public final void setDaemon(boolean daemon)
更改此线程组的后台程序状态。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

在停止后台程序线程组的最后一个线程或销毁其最后一个线程组时，自动销毁此后台程序线程组。

参数：
daemon - 如果为 true，则表示此线程组是一个后台程序线程组；否则，表示此线程组是一个普通线程组。
抛出：
SecurityException - 如果当前线程无法修改此线程组。
从以下版本开始：
JDK1.0
另请参见：
SecurityException, checkAccess()

setMaxPriority

public final void setMaxPriority(int pri)
设置线程组的最高优先级。线程组中已有较高优先级的线程不受影响。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

如果 pri 参数小于 Thread.MIN_PRIORITY 或大于 Thread.MAX_PRIORITY，则线程组的最高优先级保持不变。

否则，此 ThreadGroup 对象的优先级被设置为比指定的 pri 参数更小，所允许的最高优先级是此线程组的父线程组的优先级。（如果此线程组是系统线程组，没有父线程组，那么只需将最高优先级设置为 pri 即可。）然后使用 pri 作为此方法的参数，以递归的方式对属于此线程组的每个线程组调用此方法。

参数：
pri - 线程组的新优先级。
抛出：
SecurityException - 如果当前线程无法修改此线程组。
从以下版本开始：
JDK1.0
另请参见：
getMaxPriority(), SecurityException, checkAccess()

parentOf

public final boolean parentOf(ThreadGroup g)
测试此线程组是否为线程组参数或其祖先线程组之一。

参数：
g - 一个线程组。
返回：
如果此线程组是线程组参数或其祖先线程组之一，则返回 true；否则返回 false。
从以下版本开始：
JDK1.0

checkAccess

public final void checkAccess()
确定当前运行的线程是否有权修改此线程组。

如果有安全管理器，则用此线程组作为其参数调用 checkAccess 方法。结果可能是抛出一个 SecurityException。

抛出：
SecurityException - 如果不允许当前线程访问此线程组。
从以下版本开始：
JDK1.0
另请参见：
SecurityManager.checkAccess(java.lang.ThreadGroup)

activeCount

public int activeCount()
返回此线程组中活动线程的估计数。结果并不能反映并发活动，并且可能受某些系统线程的存在状态的影响。

由于结果所固有的不精确特性，建议只将此方法用于信息目的。

返回：
此线程组和将此线程组作为其祖先的其他线程组中活动线程的估计数。
从以下版本开始：
JDK1.0

enumerate

public int enumerate(Thread[] list)
把此线程组及其子组中的所有活动线程复制到指定数组中。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

应用程序可以使用 activeCount 方法获取数组大小的估计数，但是，如果数组太小而无法保持所有线程，则忽略额外的线程。如果获得此线程组及其子组中的所有活动线程非常重要，则调用方应该验证返回的 int 值是否严格小于 list 的长度。

由于使用此方法所固有的竞争条件，建议只将此方法用于信息目的。

参数：
list - 放置线程列表的数组。
返回：
放入数组中的线程数。
抛出：
SecurityException - 如果不允许当前线程枚举此线程组。
从以下版本开始：
JDK1.0
另请参见：
activeCount(), checkAccess()

enumerate

public int enumerate(Thread[] list,
                     boolean recurse)
把此线程组中的所有活动线程复制到指定数组中。如果 recurse 标志为 true，则还包括对此线程的子组中的所有活动线程的引用。如果数组太小而无法保持所有线程，则忽略额外的线程。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

应用程序可以使用 activeCount 获取数组大小的估计数，但是，如果数组太小而无法保持所有线程，则忽略额外的线程。如果获得此线程组中的所有活动线程非常重要，则调用方应该验证返回的整数值是否确实小于 list 的长度。

由于使用此方法所固有的竞争条件，建议只将此方法用于信息目的。

参数：
list - 放置线程列表的数组。
recurse - 一个标记，指示是否还包括作为此线程组的子组的线程组中的线程。
返回：
放入数组中的线程数。
抛出：
SecurityException - 如果不允许当前线程枚举此线程组。
从以下版本开始：
JDK1.0
另请参见：
activeCount(), checkAccess()

activeGroupCount

public int activeGroupCount()
返回此线程组中活动线程组的估计数。结果并不能反映并发活动。

由于结果所固有的不精确特性，建议只将此方法用于信息目的。

返回：
将此线程组作为祖先线程组的活动线程组的数量。
从以下版本开始：
JDK1.0

enumerate

public int enumerate(ThreadGroup[] list)
把对此线程组中的所有活动子组的引用复制到指定数组中。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

应用程序可以使用 activeGroupCount 获取数组大小的估计数，但是，如果数组太小而无法保持所有线程组，则忽略额外的线程组。如果获得此线程组中的所有活动子组非常重要，则调用方应该验证返回的整数值是否确实小于 list 的长度。

由于使用此方法所固有的竞争条件，建议只将此方法用于信息目的。

参数：
list - 放置线程组列表的数组。
返回：
放入数组中的线程组的数量。
抛出：
SecurityException - 如果不允许当前线程枚举此线程组。
从以下版本开始：
JDK1.0
另请参见：
activeGroupCount(), checkAccess()

enumerate

public int enumerate(ThreadGroup[] list,
                     boolean recurse)
把对此线程组中的所有活动子组的引用复制到指定数组中。如果 recurse 标志为 true，则还包括对子组的所有活动子组的引用，等等。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

应用程序可以使用 activeGroupCount 获取数组大小的估计数，但是，如果数组太小而无法保持所有线程组，则忽略额外的线程组。如果获得此线程组中的所有活动子组非常重要，则调用方应该验证返回的整数值是否确实小于 list 的长度。

由于使用此方法所固有的竞争条件，建议只将此方法用于信息目的。

参数：
list - 放置线程列表的数组。
recurse - 一个标记，指示是否以递归的方式枚举所有已包含的线程组。
返回：
放入数组中的线程组的数量。
抛出：
SecurityException - 如果不允许当前线程枚举此线程组。
从以下版本开始：
JDK1.0
另请参见：
activeGroupCount(), checkAccess()

stop

@Deprecated
public final void stop()
已过时。 此方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。

停止此线程组中的所有线程。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

然后，此方法将对此线程组及其所有子组中的所有线程调用 stop 方法。

抛出：
SecurityException - 如果不允许当前线程访问此线程组或线程组中的任何线程。
从以下版本开始：
JDK1.0
另请参见：
SecurityException, Thread.stop(), checkAccess()

interrupt

public final void interrupt()
中断此线程组中的所有线程。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

然后，此方法将对此线程组及其所有子组中的所有线程调用 interrupt 方法。

抛出：
SecurityException - 如果不允许当前线程访问此线程组或线程组中的任何线程。
从以下版本开始：
1.2
另请参见：
Thread.interrupt(), SecurityException, checkAccess()

suspend

@Deprecated
public final void suspend()
已过时。 此方法容易导致死锁。有关详细信息，请参阅 Thread.suspend()。

挂起此线程组中的所有线程。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

然后，此方法将对该线程组及其所有子组中的所有线程调用 suspend 方法。

抛出：
SecurityException - 如果不允许当前线程访问此线程组或线程组中的任何线程。
从以下版本开始：
JDK1.0
另请参见：
Thread.suspend(), SecurityException, checkAccess()

resume

@Deprecated
public final void resume()
已过时。 此方法只用于联合 Thread.suspend 和 ThreadGroup.suspend 时，因为它们所固有的容易导致死锁的特性，所以两者都已废弃。有关详细信息，请参阅 Thread.suspend()。

继续此线程组中的所有线程。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

然后，此方法将对该线程组及其所有子组中的所有线程调用 resume 方法。

抛出：
SecurityException - 如果不允许当前线程访问此线程组或线程组中的任何线程。
从以下版本开始：
JDK1.0
另请参见：
SecurityException, Thread.resume(), checkAccess()

destroy

public final void destroy()
销毁此线程组及其所有子组。此线程组必须为空，指示此线程组中的所有线程都已停止执行。

首先，不使用任何参数调用此线程组的 checkAccess 方法；这可能导致一个安全性异常。

抛出：
IllegalThreadStateException - 如果线程组不为空，或者线程组已经被销毁。
SecurityException - 如果当前线程不能修改此线程组。
从以下版本开始：
JDK1.0
另请参见：
checkAccess()

list

public void list()
将有关此线程组的信息打印到标准输出。此方法只对调试有用。

从以下版本开始：
JDK1.0

uncaughtException

public void uncaughtException(Thread t,
                              Throwable e)
当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。

ThreadGroup 的 uncaughtException 方法执行以下操作：

  • 如果此线程组有一个父线程组，那么调用此父线程组的 uncaughtException 方法时带有两个相同的参数。
  • 否则，此方法将查看是否安装了默认的未捕获异常处理程序，如果是，则在调用其 uncaughtException 方法时带有两个相同的参数。
  • 否则，此方法将确认 Throwable 参数是否为一个 ThreadDeath 实例。如果是，则不会做任何特殊的操作。否则，在从线程的 getName 方法返回时，会使用 Throwable 的 printStackTrace 方法，将包含线程名称的消息和堆栈跟踪信息输出到标准错误流。

应用程序可以重写 ThreadGroup 的子类中的方法，以提供处理未捕获异常的替代办法。

指定者：
接口 Thread.UncaughtExceptionHandler 中的 uncaughtException
参数：
t - 即将退出的线程。
e - 未捕获的异常。
从以下版本开始：
JDK1.0

allowThreadSuspension

@Deprecated
public boolean allowThreadSuspension(boolean b)
已过时。 此调用的定义取决于 suspend()，它被废弃了。更进一步地说，此调用的行为从不被指定。

由 VM 用于控制内存不足时的隐式挂起。

参数：
b - 允许或不允许挂起时的布尔值
返回：
如果成功，则返回 true
从以下版本开始：
JDK1.1

toString

public String toString()
返回此线程组的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此线程组的字符串表示形式。
从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadLocal (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 ThreadLocal<T>

java.lang.Object
    继承者  java.lang.ThreadLocal<T>
直接已知子类：
InheritableThreadLocal
public class ThreadLocal<T>
extends Object

该类提供了线程局部 (thread-local) 变量。这些变量不同于它们的普通对应物，因为访问某个变量（通过其 get 或 set 方法）的每个线程都有自己的局部变量，它独立于变量的初始化副本。ThreadLocal 实例通常是类中的 private static 字段，它们希望将状态与某一个线程（例如，用户 ID 或事务 ID）相关联。

例如，以下类生成对每个线程唯一的局部标识符。 线程 ID 是在第一次调用 UniqueThreadIdGenerator.getCurrentThreadId() 时分配的，在后续调用中不会更改。

  import java.util.concurrent.atomic.AtomicInteger;

 public class UniqueThreadIdGenerator {

     private static final AtomicInteger uniqueId = new AtomicInteger(0);

     private static final ThreadLocal < Integer > uniqueNum =
         new ThreadLocal < Integer > () {
             @Override protected Integer initialValue() {
                 return uniqueId.getAndIncrement();
         }
     };

     public static int getCurrentThreadId() {
         return uniqueId.get();
     }
 } // UniqueThreadIdGenerator

每个线程都保持对其线程局部变量副本的隐式引用，只要线程是活动的并且 ThreadLocal 实例是可访问的；在线程消失之后，其线程局部实例的所有副本都会被垃圾回收（除非存在对这些副本的其他引用）。

从以下版本开始：
1.2

构造方法摘要
ThreadLocal()
创建一个线程本地变量。
方法摘要
T | get() 返回此线程局部变量的当前线程副本中的值。
protected T | initialValue() 返回此线程局部变量的当前线程的“初始值”。
void | remove() 移除此线程局部变量当前线程的值。
void | set(T value) 将此线程局部变量的当前线程副本中的值设置为指定值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ThreadLocal

public ThreadLocal()
创建一个线程本地变量。

方法详细信息

initialValue

protected T initialValue()
返回此线程局部变量的当前线程的“初始值”。线程第一次使用 get() 方法访问变量时将调用此方法，但如果线程之前调用了 set(T) 方法，则不会对该线程再调用 initialValue 方法。通常，此方法对每个线程最多调用一次，但如果在调用 get() 后又调用了 remove()，则可能再次调用此方法。

该实现返回 null；如果程序员希望线程局部变量具有 null 以外的值，则必须为 ThreadLocal 创建子类，并重写此方法。通常将使用匿名内部类完成此操作。

返回：
返回此线程局部变量的初始值

get

public T get()
返回此线程局部变量的当前线程副本中的值。如果变量没有用于当前线程的值，则先将其初始化为调用 initialValue() 方法返回的值。

返回：
此线程局部变量的当前线程的值

set

public void set(T value)
将此线程局部变量的当前线程副本中的值设置为指定值。大部分子类不需要重写此方法，它们只依靠 initialValue() 方法来设置线程局部变量的值。

参数：
value - 存储在此线程局部变量的当前线程副本中的值。

remove

public void remove()
移除此线程局部变量当前线程的值。如果此线程局部变量随后被当前线程读取，且这期间当前线程没有设置其值，则将调用其 initialValue() 方法重新初始化其值。这将导致在当前线程多次调用 initialValue 方法。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Throwable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Throwable

java.lang.Object
    继承者  java.lang.Throwable
所有已实现的接口：
Serializable
直接已知子类：
Error, Exception
public class Throwable
extends Object
implements Serializable

Throwable 类是 Java 语言中所有错误或异常的超类。只有当对象是此类（或其子类之一）的实例时，才能通过 Java 虚拟机或者 Java throw 语句抛出。类似地，只有此类或其子类之一才可以是 catch 子句中的参数类型。

两个子类的实例，Error 和 Exception，通常用于指示发生了异常情况。通常，这些实例是在异常情况的上下文中新近创建的，因此包含了相关的信息（比如堆栈跟踪数据）。

Throwable 包含了其线程创建时线程执行堆栈的快照。它还包含了给出有关错误更多信息的消息字符串。最后，它还可以包含 cause（原因）：另一个导致此 throwable 抛出的 throwable。此 cause 设施在 1.4 版本中首次出现。它也称为异常链 设施，因为 cause 自身也会有 cause，依此类推，就形成了异常链，每个异常都是由另一个异常引起的。

导致 throwable cause 的一个理由是，抛出它的类构建在低层抽象之中，而高层操作由于低层操作的失败而失败。让低层抛出的 throwable 向外传播是一种糟糕的设计方法，因为它通常与高层提供的抽象不相关。此外，这样做将高层 API 与其实现细节关联起来，假定低层异常是经过检查的异常。抛出“经过包装的异常”（即包含 cause 的异常）允许高层与其调用方交流失败详细信息，而不会招致上述任何一个缺点。这种方式保留了改变高层实现而不改变其 API 的灵活性（尤其是，异常集合通过其方法抛出）。

导致 throwable cause 的另一个 cause 是，抛出它的方法必须符合通用接口，而通用接口不允许方法直接抛出 cause。例如，假定持久集合符合 Collection 接口，而其持久性在 java.io 的基础上实现。假定 add 方法的内部可以抛出 IOException。实现可以与其调用方交流 IOException 的详细消息，同时通过以一种合适的未检查的异常来包装 IOException，使其符合 Collection 接口。（持久集合的规范应该指示它能够抛出这种异常。）

Cause 可以通过两种方式与 throwable 关联起来：通过一个将 cause 看作参数的构造方法；或者通过 initCause(Throwable) 方法。对于那些希望将 cause 与其关联起来的新 throwable 类，应该提供带有 cause 的构造方法，并委托（可能间接）给一个带有 cause 的 Throwable 构造方法。例如：

     try {
         lowLevelOp();
     } catch (LowLevelException le) {
         throw new HighLevelException(le);  // Chaining-aware constructor
     }
因为 initCause 方法是公共的，它允许 cause 与任何 throwable 相关联，甚至包括“遗留 throwable”，它的实现提前将异常链机制的附件应用到 Throwable。例如：
     try {
         lowLevelOp();
     } catch (LowLevelException le) {
         throw (HighLevelException)
                 new HighLevelException().initCause(le);  // Legacy constructor
     }

在版本 1.4 之前，许多 throwable 有自己的非标准异常链机制（ ExceptionInInitializerError、 ClassNotFoundException、 UndeclaredThrowableException、 InvocationTargetException、 WriteAbortedException、 PrivilegedActionException、 PrinterIOException、 RemoteException 和 NamingException）。所有这些 throwable 都已经更新过，可以使用标准异常链机制，同时继续实现其“遗留”链机制，以保持兼容性。

此外，从版本 1.4 开始，许多通用的 Throwable 类（例如，Exception、RuntimeException、Error）都已经更新，具有带 cause 的构造方法。由于有 initCause 方法存在，这不是严格要求的，但它更方便，也更形象地委托给一个带有 cause 的构造方法。

根据惯例，Throwable 类及其子类有两个构造方法，一个不带参数，另一个带有 String 参数，此参数可用于生成详细消息。此外，这些子类很可能有与其相关联的 cause，因此也应有两个构造方法，一个带 Throwable (cause)，一个带 String（详细消息）和 Throwable (cause)。

在版本 1.4 中还引入了 getStackTrace() 方法，它允许通过各种形式的 printStackTrace() 方法编程访问堆栈跟踪信息，这些信息以前只能以文本形式使用。此信息已经添加到该类的序列化表示形式，因此 getStackTrace 和 printStackTrace 将可在反序列化时获得的 throwable 上正确操作。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
Throwable()
构造一个将 null 作为其详细消息的新 throwable。
Throwable(String message)
构造带指定详细消息的新 throwable。
Throwable(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 throwable。
Throwable(Throwable cause)
构造一个带指定 cause 和 (cause==null ? null :cause.toString())（它通常包含类和 cause 的详细消息）的详细消息的新 throwable。
方法摘要
 Throwable fillInStackTrace()
在异常堆栈跟踪中填充。
 Throwable getCause()
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
 String getLocalizedMessage()
创建此 throwable 的本地化描述。
 String getMessage()
返回此 throwable 的详细消息字符串。
 StackTraceElement[] getStackTrace()
提供编程访问由 printStackTrace() 输出的堆栈跟踪信息。
 Throwable initCause(Throwable cause)
将此 throwable 的 cause 初始化为指定值。
 void printStackTrace()
将此 throwable 及其追踪输出至标准错误流。
 void printStackTrace(PrintStream s)
将此 throwable 及其追踪输出到指定的输出流。
 void printStackTrace(PrintWriter s)
将此 throwable 及其追踪输出到指定的 PrintWriter。
 void setStackTrace(StackTraceElement[] stackTrace)
设置将由 getStackTrace() 返回，并由 printStackTrace() 和相关方法输出的堆栈跟踪元素。
 String toString()
返回此 throwable 的简短描述。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Throwable

public Throwable()
构造一个将 null 作为其详细消息的新 throwable。Cause 尚未进行初始化，可在以后通过调用 initCause(java.lang.Throwable) 来初始化。

调用 fillInStackTrace() 方法来初始化新创建的 throwable 中的堆栈跟踪数据。

Throwable

public Throwable(String message)
构造带指定详细消息的新 throwable。Cause 尚未进行初始化，可在以后通过调用 initCause(java.lang.Throwable) 来初始化。

调用 fillInStackTrace() 方法来初始化新创建的 throwable 中的堆栈跟踪数据。

参数：
message - 详细消息。保存这个详细消息，以便以后通过 getMessage() 方法对其进行获取。

Throwable

public Throwable(String message,
                 Throwable cause)
构造一个带指定详细消息和 cause 的新 throwable。

注意，与 cause 相关的详细消息不是 自动合并到这个 throwable 的详细消息中的。

调用 fillInStackTrace() 方法来初始化新创建的 throwable 中的堆栈跟踪数据。

参数：
message - 详细消息（保存此消息，以便以后通过 getMessage() 方法获取它）。
cause - 原因（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许 null 值，指出 cause 是不存在的或是未知的。）
从以下版本开始：
1.4

Throwable

public Throwable(Throwable cause)
构造一个带指定 cause 和 (cause==null ? null :cause.toString())（它通常包含类和 cause 的详细消息）的详细消息的新 throwable。此构造方法对于那些与其他 throwable（例如，PrivilegedActionException）的包装器相同的 throwable 来说是有用的。

调用 fillInStackTrace() 方法来初始化新创建的 throwable 中的堆栈跟踪数据。

参数：
cause - 原因（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许 null 值，指出 cause 是不存在的或是未知的。）
从以下版本开始：
1.4
方法详细信息

getMessage

public String getMessage()
返回此 throwable 的详细消息字符串。

返回：
此 Throwable 实例（可以为 null）的详细消息字符串。

getLocalizedMessage

public String getLocalizedMessage()
创建此 throwable 的本地化描述。子类可以重写此方法，以便生成特定于语言环境的消息。对于不重写此方法的子类，默认实现返回与 getMessage() 相同的结果。

返回：
此 throwable 的本地化描述。
从以下版本开始：
JDK1.1

getCause

public Throwable getCause()
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。（该 Cause 是导致抛出此 throwable 的throwable。）

此实现返回由一个需要 Throwable 的构造方法提供的 cause，或者在创建之后通过 initCause(Throwable) 方法进行设置的 cause。虽然通常不需要重写此方法，但子类可以重写它，以返回一个通过某些其他方式设置的 cause。这适用于在异常链（异常嵌套）机制被加入到 Throwable 之前存在“遗留 Throwable 链机制”的情况。注意，不必 重写任何 PrintStackTrace 方法，所有方法都调用 getCause 方法来确定 throwable 的 cause。

返回：
此 throwable 的 cause，如果 cause 不存在或是未知的，则返回 null。
从以下版本开始：
1.4

initCause

public Throwable initCause(Throwable cause)
将此 throwable 的 cause 初始化为指定值。（该 Cause 是导致抛出此 throwable 的throwable。）

此方法至多可以调用一次。此方法通常从构造方法中调用，或者在创建 throwable 后立即调用。如果此 throwable 通过 Throwable(Throwable) 或 Throwable(String,Throwable) 创建，此方法甚至一次也不能调用。

参数：
cause - 原因（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许 null 值，指出 cause 是不存在的或是未知的。）
返回：
对此 Throwable 实例的引用。
抛出：
IllegalArgumentException - 如果 cause 是此 throwable。（throwable 不能是它自己的 cause。）
IllegalStateException - 如果此 throwable 通过 Throwable(Throwable) 或 Throwable(String,Throwable) 创建，或者此方法已经在此 throwable 上进行调用。
从以下版本开始：
1.4

toString

public String toString()
返回此 throwable 的简短描述。结果是以下字符串的串联：
  • 此对象的类的 name
  • ": "（冒号和一个空格）
  • 调用此对象 getLocalizedMessage() 方法的结果
如果 getLocalizedMessage 返回 null，则只返回类名称。

覆盖：
类 Object 中的 toString
返回：
该 throwable 的字符串表示形式。

printStackTrace

public void printStackTrace()
将此 throwable 及其追踪输出至标准错误流。此方法将此 Throwable 对象的堆栈跟踪输出至错误输出流，作为字段 System.err 的值。输出的第一行包含此对象的 toString() 方法的结果。剩余行表示以前由方法 fillInStackTrace() 记录的数据。此信息的格式取决于实现，但以下示例是最常见的：
 java.lang.NullPointerException
         at MyClass.mash(MyClass.java:9)
         at MyClass.crunch(MyClass.java:6)
         at MyClass.main(MyClass.java:3)
本示例通过运行以下程序生成：
 class MyClass {
     public static void main(String[] args) {
         crunch(null);
     }
     static void crunch(int[] a) {
         mash(a);
     }
     static void mash(int[] b) {
         System.out.println(b[0]);
     }
 }
对于带初始化非空 cause 的 throwable 的追踪，通常应该包括 cause 的追踪。此信息的格式取决于实现，但以下示例是最常见的：
 HighLevelException: MidLevelException: LowLevelException
         at Junk.a(Junk.java:13)
         at Junk.main(Junk.java:4)
 Caused by: MidLevelException: LowLevelException
         at Junk.c(Junk.java:23)
         at Junk.b(Junk.java:17)
         at Junk.a(Junk.java:11)
         ... 1 more
 Caused by: LowLevelException
         at Junk.e(Junk.java:30)
         at Junk.d(Junk.java:27)
         at Junk.c(Junk.java:21)
         ... 3 more
注意，存在包含字符 "..." 的行。这些行指示此异常的椎栈跟踪的其余部分匹配来自异常（由 "enclosing" 异常引起）的堆栈跟踪底部的指定数量的帧。这种简便方法可以大大缩短通常情况下的输出长度，这里抛出了包装的异常，其方法与捕获“作为 cause 的异常”的方法相同。上述示例通过运行以下程序生成：
 public class Junk {
     public static void main(String args[]) {
         try {
             a();
         } catch(HighLevelException e) {
             e.printStackTrace();
         }
     }
     static void a() throws HighLevelException {
         try {
             b();
         } catch(MidLevelException e) {
             throw new HighLevelException(e);
         }
     }
     static void b() throws MidLevelException {
         c();
     }
     static void c() throws MidLevelException {
         try {
             d();
         } catch(LowLevelException e) {
             throw new MidLevelException(e);
         }
     }
     static void d() throws LowLevelException {
        e();
     }
     static void e() throws LowLevelException {
         throw new LowLevelException();
     }
 }

 class HighLevelException extends Exception {
     HighLevelException(Throwable cause) { super(cause); }
 }

 class MidLevelException extends Exception {
     MidLevelException(Throwable cause)  { super(cause); }
 }

 class LowLevelException extends Exception {
 }

printStackTrace

public void printStackTrace(PrintStream s)
将此 throwable 及其追踪输出到指定的输出流。

参数：
s - 用于输出的 PrintStream

printStackTrace

public void printStackTrace(PrintWriter s)
将此 throwable 及其追踪输出到指定的 PrintWriter。

参数：
s - 用于输出的 PrintWriter
从以下版本开始：
JDK1.1

fillInStackTrace

public Throwable fillInStackTrace()
在异常堆栈跟踪中填充。此方法在 Throwable 对象信息中记录有关当前线程堆栈帧的当前状态。

返回：
对此 Throwable 实例的引用。
另请参见：
printStackTrace()

getStackTrace

public StackTraceElement[] getStackTrace()
提供编程访问由 printStackTrace() 输出的堆栈跟踪信息。返回堆栈跟踪元素的数组，每个元素表示一个堆栈帧。数组的第零个元素（假定数据的长度为非零）表示堆栈顶部，它是序列中最后的方法调用。通常，这是创建和抛出该 throwable 的地方。数组的最后元素（假定数据的长度为非零）表示堆栈底部，它是序列中第一个方法调用。

某些虚拟机在某些情况下可能会从堆栈跟踪中省略一个或多个堆栈帧。在极端情况下，没有该 throwable 堆栈跟踪信息的虚拟机可以从该方法返回一个零长度数组。一般说来，由此方法返回的数组将包含由 printStackTrace 输出的每帧的一个元素。

返回：
堆栈跟踪元素的数组，表示与此 throwable 相关的堆栈跟踪。
从以下版本开始：
1.4

setStackTrace

public void setStackTrace(StackTraceElement[] stackTrace)
设置将由 getStackTrace() 返回，并由 printStackTrace() 和相关方法输出的堆栈跟踪元素。 此方法设计用于 RPC 框架和其他高级系统，允许客户端重写默认堆栈跟踪，这些默认堆栈跟踪要么在构造 throwable 时由 fillInStackTrace() 生成，要么在从序列化流读取 throwable 时反序列化。

参数：
stackTrace - 要与此 Throwable 关联的堆栈跟踪元素。指定的数组由此调用复制；在方法调用返回后，指定数组中的改变将不会对此 Throwable 的堆栈跟踪产生影响。
抛出：
NullPointerException - 如果 stackTrace 为 null，或者 stackTrace 中的任何元素为 null
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeNotPresentException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 TypeNotPresentException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.TypeNotPresentException
所有已实现的接口：
Serializable
public class TypeNotPresentException
extends RuntimeException

当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。此异常与 ClassNotFoundException 不同，ClassNotFoundException 是一个经过检查的异常，而此异常是未经检查的。

注意，当访问未定义的类型变量时，以及当加载类型（例如，类、接口或注释类型）时，可以使用此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
TypeNotPresentException(String typeName, Throwable cause)
为指定类型构造一个带指定原因的 TypeNotPresentException。
方法摘要
 String typeName()
返回不可用类型的完全限定名。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TypeNotPresentException

public TypeNotPresentException(String typeName,
                               Throwable cause)
为指定类型构造一个带指定原因的 TypeNotPresentException。

参数：
typeName - 不可用类型的完全限定名
cause - 当系统试图加载指定类型时抛出的异常；如果类型不可用或不适用，则为 null
方法详细信息

typeName

public String typeName()
返回不可用类型的完全限定名。

返回：
不可用类型的完全限定名
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 UnknownError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.VirtualMachineError
                继承者  java.lang.UnknownError
所有已实现的接口：
Serializable
public class UnknownError
extends VirtualMachineError

当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
UnknownError()
构造不带详细消息的 UnknownError。
UnknownError(String s)
构造带指定详细消息的 UnknownError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownError

public UnknownError()
构造不带详细消息的 UnknownError。

UnknownError

public UnknownError(String s)
构造带指定详细消息的 UnknownError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsatisfiedLinkError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 UnsatisfiedLinkError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.UnsatisfiedLinkError
所有已实现的接口：
Serializable
public class UnsatisfiedLinkError
extends LinkageError

当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。

从以下版本开始：
JDK1.0
另请参见：
Runtime, 序列化表格

构造方法摘要
UnsatisfiedLinkError()
构造不带详细消息的 UnsatisfiedLinkError。
UnsatisfiedLinkError(String s)
构造带指定详细消息的 UnsatisfiedLinkError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsatisfiedLinkError

public UnsatisfiedLinkError()
构造不带详细消息的 UnsatisfiedLinkError。

UnsatisfiedLinkError

public UnsatisfiedLinkError(String s)
构造带指定详细消息的 UnsatisfiedLinkError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedClassVersionError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 UnsupportedClassVersionError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.ClassFormatError
                    继承者  java.lang.UnsupportedClassVersionError
所有已实现的接口：
Serializable
public class UnsupportedClassVersionError
extends ClassFormatError

当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
UnsupportedClassVersionError()
构造不带详细消息的 UnsupportedClassVersionError。
UnsupportedClassVersionError(String s)
构造带指定详细消息的 UnsupportedClassVersionError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedClassVersionError

public UnsupportedClassVersionError()
构造不带详细消息的 UnsupportedClassVersionError。

UnsupportedClassVersionError

public UnsupportedClassVersionError(String s)
构造带指定详细消息的 UnsupportedClassVersionError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedOperationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 UnsupportedOperationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.UnsupportedOperationException
所有已实现的接口：
Serializable
直接已知子类：
HeadlessException, ReadOnlyBufferException
public class UnsupportedOperationException
extends RuntimeException

当不支持请求的操作时，抛出该异常。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
UnsupportedOperationException()
构造不带详细消息的 UnsupportedOperationException。
UnsupportedOperationException(String message)
构造带指定详细消息的 UnsupportedOperationException。
UnsupportedOperationException(String message, Throwable cause)
根据指定的详细消息和原因，构造一个新异常。
UnsupportedOperationException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString())（它通常包含了 cause 的类和详细消息）的详细消息，构造一个新异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedOperationException

public UnsupportedOperationException()
构造不带详细消息的 UnsupportedOperationException。

UnsupportedOperationException

public UnsupportedOperationException(String message)
构造带指定详细消息的 UnsupportedOperationException。

参数：
message - 详细消息

UnsupportedOperationException

public UnsupportedOperationException(String message,
                                     Throwable cause)
根据指定的详细消息和原因，构造一个新异常。

注意，与 cause 相关的详细消息不是 自动合并到这个异常的详细消息中的。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

UnsupportedOperationException

public UnsupportedOperationException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString())（它通常包含了 cause 的类和详细消息）的详细消息，构造一个新异常。此构造方法对于那些与其他 throwable（例如，PrivilegedActionException）的包装器相同的异常来说是有用的。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable#ggetCause 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VerifyError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 VerifyError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.VerifyError
所有已实现的接口：
Serializable
public class VerifyError
extends LinkageError

当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
VerifyError()
构造不带详细消息的 VerifyError。
VerifyError(String s)
构造带指定详细消息的 VerifyError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

VerifyError

public VerifyError()
构造不带详细消息的 VerifyError。

VerifyError

public VerifyError(String s)
构造带指定详细消息的 VerifyError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VirtualMachineError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang
类 VirtualMachineError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.VirtualMachineError
所有已实现的接口：
Serializable
直接已知子类：
InternalError, OutOfMemoryError, StackOverflowError, UnknownError
public abstract class VirtualMachineError
extends Error

当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
VirtualMachineError()
构造不带详细消息的 VirtualMachineError。
VirtualMachineError(String s)
构造带指定详细消息的 VirtualMachineError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

VirtualMachineError

public VirtualMachineError()
构造不带详细消息的 VirtualMachineError。

VirtualMachineError

public VirtualMachineError(String s)
构造带指定详细消息的 VirtualMachineError。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Void (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang
类 Void

java.lang.Object
    继承者  java.lang.Void

public final class Void
extends Object

Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。

从以下版本开始：
JDK1.1

字段摘要
static Class<Void> TYPE
表示对应于关键字 void 的伪类型的 Class 对象。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

TYPE

public static final Class<Void> TYPE
表示对应于关键字 void 的伪类型的 Class 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.lang (Java 2 Platform SE 6)

 java.lang
接口
Appendable
CharSequence
Cloneable
Comparable
Iterable
Readable
Runnable
Thread.UncaughtExceptionHandler
类
Boolean
Byte
Character
Character.Subset
Character.UnicodeBlock
Class
ClassLoader
Compiler
Double
Enum
Float
InheritableThreadLocal
Integer
Long
Math
Number
Object
Package
Process
ProcessBuilder
Runtime
RuntimePermission
SecurityManager
Short
StackTraceElement
StrictMath
String
StringBuffer
StringBuilder
System
Thread
ThreadGroup
ThreadLocal
Throwable
Void
枚举
Thread.State
异常
ArithmeticException
ArrayIndexOutOfBoundsException
ArrayStoreException
ClassCastException
ClassNotFoundException
CloneNotSupportedException
EnumConstantNotPresentException
Exception
IllegalAccessException
IllegalArgumentException
IllegalMonitorStateException
IllegalStateException
IllegalThreadStateException
IndexOutOfBoundsException
InstantiationException
InterruptedException
NegativeArraySizeException
NoSuchFieldException
NoSuchMethodException
NullPointerException
NumberFormatException
RuntimeException
SecurityException
StringIndexOutOfBoundsException
TypeNotPresentException
UnsupportedOperationException
错误
AbstractMethodError
AssertionError
ClassCircularityError
ClassFormatError
Error
ExceptionInInitializerError
IllegalAccessError
IncompatibleClassChangeError
InstantiationError
InternalError
LinkageError
NoClassDefFoundError
NoSuchFieldError
NoSuchMethodError
OutOfMemoryError
StackOverflowError
ThreadDeath
UnknownError
UnsatisfiedLinkError
UnsupportedClassVersionError
VerifyError
VirtualMachineError
注释类型
Deprecated
Override
SuppressWarnings


java.lang (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.lang

提供利用 Java 编程语言进行程序设计的基础类。

请参见：
描述

接口摘要
Appendable | 能够被添加 char 序列和值的对象。
CharSequence | CharSequence 是 char 值的一个可读序列。
Cloneable | 此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable<T> | 此接口强行对实现它的每个类的对象进行整体排序。
Iterable<T> | 实现这个接口允许对象成为 "foreach" 语句的目标。
Readable | Readable 是一个字符源。
Runnable | Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
Thread.UncaughtExceptionHandler | 当 Thread 因未捕获的异常而突然终止时，调用处理程序的接口。

类摘要
Boolean | Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Byte | Byte 类将基本类型 byte 的值包装在一个对象中。
Character | Character 类在对象中包装一个基本类型 char 的值。
Character.Subset | 此类的实例表示 Unicode 字符集的特定子集。
Character.UnicodeBlock | 表示 Unicode 规范中字符块的一系列字符子集。
Class<T> | Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader | 类加载器是负责加载类的对象。
Compiler | Compiler 类主要支持 Java 到本机代码的编译器及相关服务。
Double | Double 类在对象中包装一个基本类型 double 的值。
Enum<E extends Enum<E>> | 这是所有 Java 语言枚举类型的公共基本类。
Float | Float 类在对象中包装一个基本类型 float 的值。
InheritableThreadLocal<T> | 该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。
Integer | Integer 类在对象中包装了一个基本类型 int 的值。
Long | Long 类在对象中包装了基本类型 long 的值。
Math | Math 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。
Number | 抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object | 类 Object 是类层次结构的根类。
Package | Package 对象包含有关 Java 包的实现和规范的版本信息。
Process | ProcessBuilder.start() 和 Runtime.exec 方法创建一个本机进程，并返回 Process 子类的一个实例，该实例可用来控制进程并获得相关信息。
ProcessBuilder | 此类用于创建操作系统进程。
Runtime | 每个 Java 应用程序都有一个 Runtime 类实例，使应用程序能够与其运行的环境相连接。
RuntimePermission | 该类用于运行时权限。
SecurityManager | 安全管理器是一个允许应用程序实现安全策略的类。
Short | Short 类在对象中包装基本类型 short 的值。
StackTraceElement | 堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。
StrictMath | StrictMath 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。
String | String 类代表字符串。
StringBuffer | 线程安全的可变字符序列。
StringBuilder | 一个可变的字符序列。
System | System 类包含一些有用的类字段和方法。
Thread | 线程 是程序中的执行线程。
ThreadGroup | 线程组表示一个线程的集合。
ThreadLocal<T> | 该类提供了线程局部 (thread-local) 变量。
Throwable | Throwable 类是 Java 语言中所有错误或异常的超类。
Void | Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。

枚举摘要
Thread.State 线程状态。

异常摘要
ArithmeticException | 当出现异常的运算条件时，抛出此异常。
ArrayIndexOutOfBoundsException | 用非法索引访问数组时抛出的异常。
ArrayStoreException | 试图将错误类型的对象存储到一个对象数组时抛出的异常。
ClassCastException | 当试图将对象强制转换为不是实例的子类时，抛出该异常。
ClassNotFoundException | 当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
CloneNotSupportedException | 当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
EnumConstantNotPresentException | 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
Exception | Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalAccessException | 当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
IllegalArgumentException | 抛出的异常表明向方法传递了一个不合法或不正确的参数。
IllegalMonitorStateException | 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
IllegalStateException | 在非法或不适当的时间调用方法时产生的信号。
IllegalThreadStateException | 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
IndexOutOfBoundsException | 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
InstantiationException | 当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
InterruptedException | 当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
NegativeArraySizeException | 如果应用程序试图创建大小为负的数组，则抛出该异常。
NoSuchFieldException | 类不包含指定名称的字段时产生的信号。
NoSuchMethodException | 无法找到某一特定方法时，抛出该异常。
NullPointerException | 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
NumberFormatException | 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
RuntimeException | RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
SecurityException | 由安全管理器抛出的异常，指示存在安全侵犯。
StringIndexOutOfBoundsException | 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
TypeNotPresentException | 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
UnsupportedOperationException | 当不支持请求的操作时，抛出该异常。

错误摘要
AbstractMethodError | 当应用程序试图调用一个抽象方法时，抛出此错误。
AssertionError | 抛出该异常指示某个断言失败。
ClassCircularityError | 当初始化类时检测到类的循环调用的时候，抛出该错误。
ClassFormatError | 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
Error | Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
ExceptionInInitializerError | 静态初始化程序中发生意外异常的信号。
IllegalAccessError | 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
IncompatibleClassChangeError | 在某些类定义中出现不兼容的类更改时抛出该异常。
InstantiationError | 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
InternalError | 该异常指示 Java 虚拟机中出现一些意外的内部错误。
LinkageError | LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
NoClassDefFoundError | 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
NoSuchFieldError | 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
NoSuchMethodError | 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
OutOfMemoryError | 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
StackOverflowError | 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
ThreadDeath | 调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
UnknownError | 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
UnsatisfiedLinkError | 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
UnsupportedClassVersionError | 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
VerifyError | 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
VirtualMachineError | 当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

注释类型摘要
Deprecated | 用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Override | 表示一个方法声明打算重写超类中的另一个方法声明。
SuppressWarnings | 指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。

软件包 java.lang 的描述

提供利用 Java 编程语言进行程序设计的基础类。最重要的类是 Object（它是类层次结构的根）和 Class（它的实例表示正在运行的应用程序中的类）。

把基本类型的值当成一个对象来表示通常很有必要。包装器类 Boolean、Character、Integer、Long、Float 和 Double 就是用于这个目的。例如，一个 Double 类型的对象包含了一个类型为 double 的字段，这表示如果引用某个值，则可以将该值存储在引用类型的变量中。这些类还提供了大量用于转换基值的方法，并支持一些标准方法，比如 equals 和 hashCode。Void 类是一个非实例化的类，它保持一个对表示基本类型 void 的 Class 对象的引用。

类 Math 提供了常用的数学函数，比如正弦、余弦和平方根。类似地，类 String 和 StringBuffer 提供了常用的字符串操作。

类 ClassLoader、Process、Runtime、SecurityManager 和 System 提供了管理类的动态加载、外部进程创建、主机环境查询（比如时间）和安全策略实施等“系统操作”。

类 Throwable 包含了可能由 throw 语句抛出的对象(§14.16)。Throwable 的子类表示错误和异常。

包规范

字符编码

java.nio.charset.Charset 类的规范描述了字符编码的命名约定，以及每个 Java 平台实现必须支持的标准编码集。

从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.lang 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Boolean (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Character (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Character.Subset
      • java.lang.Character.UnicodeBlock
    • java.lang.Class<T> (implements java.lang.reflect.AnnotatedElement, java.lang.reflect.GenericDeclaration, java.io.Serializable, java.lang.reflect.Type)
    • java.lang.ClassLoader
    • java.lang.Compiler
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.Math
    • java.lang.Number (implements java.io.Serializable)
      • java.lang.Byte (implements java.lang.Comparable<T>)
      • java.lang.Double (implements java.lang.Comparable<T>)
      • java.lang.Float (implements java.lang.Comparable<T>)
      • java.lang.Integer (implements java.lang.Comparable<T>)
      • java.lang.Long (implements java.lang.Comparable<T>)
      • java.lang.Short (implements java.lang.Comparable<T>)
    • java.lang.Package (implements java.lang.reflect.AnnotatedElement)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.lang.RuntimePermission
    • java.lang.Process
    • java.lang.ProcessBuilder
    • java.lang.Runtime
    • java.lang.SecurityManager
    • java.lang.StackTraceElement (implements java.io.Serializable)
    • java.lang.StrictMath
    • java.lang.String (implements java.lang.CharSequence, java.lang.Comparable<T>, java.io.Serializable)
    • java.lang.StringBuffer (implements java.lang.CharSequence, java.io.Serializable)
    • java.lang.StringBuilder (implements java.lang.CharSequence, java.io.Serializable)
    • java.lang.System
    • java.lang.Thread (implements java.lang.Runnable)
    • java.lang.ThreadGroup (implements java.lang.Thread.UncaughtExceptionHandler)
    • java.lang.ThreadLocal<T>
      • java.lang.InheritableThreadLocal<T>
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.AssertionError
        • java.lang.LinkageError
          • java.lang.ClassCircularityError
          • java.lang.ClassFormatError
            • java.lang.UnsupportedClassVersionError
          • java.lang.ExceptionInInitializerError
          • java.lang.IncompatibleClassChangeError
            • java.lang.AbstractMethodError
            • java.lang.IllegalAccessError
            • java.lang.InstantiationError
            • java.lang.NoSuchFieldError
            • java.lang.NoSuchMethodError
          • java.lang.NoClassDefFoundError
          • java.lang.UnsatisfiedLinkError
          • java.lang.VerifyError
        • java.lang.ThreadDeath
        • java.lang.VirtualMachineError
          • java.lang.InternalError
          • java.lang.OutOfMemoryError
          • java.lang.StackOverflowError
          • java.lang.UnknownError
      • java.lang.Exception
        • java.lang.ClassNotFoundException
        • java.lang.CloneNotSupportedException
        • java.lang.IllegalAccessException
        • java.lang.InstantiationException
        • java.lang.InterruptedException
        • java.lang.NoSuchFieldException
        • java.lang.NoSuchMethodException
        • java.lang.RuntimeException
          • java.lang.ArithmeticException
          • java.lang.ArrayStoreException
          • java.lang.ClassCastException
          • java.lang.EnumConstantNotPresentException
          • java.lang.IllegalArgumentException
            • java.lang.IllegalThreadStateException
            • java.lang.NumberFormatException
          • java.lang.IllegalMonitorStateException
          • java.lang.IllegalStateException
          • java.lang.IndexOutOfBoundsException
            • java.lang.ArrayIndexOutOfBoundsException
            • java.lang.StringIndexOutOfBoundsException
          • java.lang.NegativeArraySizeException
          • java.lang.NullPointerException
          • java.lang.SecurityException
          • java.lang.TypeNotPresentException
          • java.lang.UnsupportedOperationException
    • java.lang.Void

接口分层结构

  • java.lang.Appendable
  • java.lang.CharSequence
  • java.lang.Cloneable
  • java.lang.Comparable<T>
  • java.lang.Iterable<T>
  • java.lang.Readable
  • java.lang.Runnable
  • java.lang.Thread.UncaughtExceptionHandler

注释类型分层结构

  • java.lang.Deprecated (implements java.lang.annotation.Annotation)
  • java.lang.Override (implements java.lang.annotation.Annotation)
  • java.lang.SuppressWarnings (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.Thread.State
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.lang 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang
的使用

使用 java.lang 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.ref | 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.spi | java.util 包中类的服务提供者类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.jws |
javax.jws.soap |
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert | 为公钥证书提供类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml | 根据 XML 规范定义核心 XML 常量和功能。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.bind.attachment | 此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.bind.util | 有用的客户端实用工具类。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.dom | 此包实现特定于 DOM 的转换 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。
javax.xml.transform.stax | 提供特定于 StAX 的转换 API。
javax.xml.transform.stream | 此包实现特定于流和 URI 的转换 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CosNaming | 为 Java IDL 提供命名服务。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.Dynamic | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.DynamicAny.DynAnyFactoryPackage | 此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。
org.omg.DynamicAny.DynAnyPackage | 此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。
org.omg.IOP | 此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.Messaging | 此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.omg.PortableServer.ServantLocatorPackage | 提供定位 servant 的类和接口。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.bootstrap |
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.ext | 此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.awt 使用的 java.lang 中的类
Character
Character 类在对象中包装一个基本类型 char 的值。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
IndexOutOfBoundsException
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
NullPointerException
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
NumberFormatException
当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
Object
类 Object 是类层次结构的根类。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。
UnsupportedOperationException
当不支持请求的操作时，抛出该异常。

java.awt.color 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.awt.datatransfer 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.awt.dnd 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.awt.event 使用的 java.lang 中的类
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.awt.font 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Float
Float 类在对象中包装一个基本类型 float 的值。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.awt.geom 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.awt.im 使用的 java.lang 中的类
Character.Subset
此类的实例表示 Unicode 字符集的特定子集。
Object
类 Object 是类层次结构的根类。

java.awt.im.spi 使用的 java.lang 中的类
Character.Subset
此类的实例表示 Unicode 字符集的特定子集。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.awt.image 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.awt.image.renderable 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Object
类 Object 是类层次结构的根类。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
String
String 类代表字符串。

java.awt.print 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IndexOutOfBoundsException
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
NullPointerException
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.beans 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.beans.beancontext 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.io 使用的 java.lang 中的类
Appendable
能够被添加 char 序列和值的对象。
CharSequence
CharSequence 是 char 值的一个可读序列。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
Readable
Readable 是一个字符源。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
StringBuffer
线程安全的可变字符序列。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.lang 使用的 java.lang 中的类
Appendable
能够被添加 char 序列和值的对象。
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Byte
Byte 类将基本类型 byte 的值包装在一个对象中。
Character
Character 类在对象中包装一个基本类型 char 的值。
Character.Subset
此类的实例表示 Unicode 字符集的特定子集。
Character.UnicodeBlock
表示 Unicode 规范中字符块的一系列字符子集。
CharSequence
CharSequence 是 char 值的一个可读序列。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassFormatError
当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Double
Double 类在对象中包装一个基本类型 double 的值。
Enum
这是所有 Java 语言枚举类型的公共基本类。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Float
Float 类在对象中包装一个基本类型 float 的值。
IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IncompatibleClassChangeError
在某些类定义中出现不兼容的类更改时抛出该异常。
IndexOutOfBoundsException
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
LinkageError
LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
Long
Long 类在对象中包装了基本类型 long 的值。
NoSuchFieldException
类不包含指定名称的字段时产生的信号。
NoSuchMethodException
无法找到某一特定方法时，抛出该异常。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
NumberFormatException
当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
Object
类 Object 是类层次结构的根类。
Package
Package 对象包含有关 Java 包的实现和规范的版本信息。
Process
ProcessBuilder.start() 和 Runtime.exec 方法创建一个本机进程，并返回 Process 子类的一个实例，该实例可用来控制进程并获得相关信息。
ProcessBuilder
此类用于创建操作系统进程。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
Runtime
每个 Java 应用程序都有一个 Runtime 类实例，使应用程序能够与其运行的环境相连接。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
SecurityManager
安全管理器是一个允许应用程序实现安全策略的类。
Short
Short 类在对象中包装基本类型 short 的值。
StackTraceElement
堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。
String
String 类代表字符串。
StringBuffer
线程安全的可变字符序列。
StringBuilder
一个可变的字符序列。
Thread
线程 是程序中的执行线程。
Thread.State
线程状态。
Thread.UncaughtExceptionHandler
当 Thread 因未捕获的异常而突然终止时，调用处理程序的接口。
ThreadGroup
线程组表示一个线程的集合。
ThreadLocal
该类提供了线程局部 (thread-local) 变量。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。
VirtualMachineError
当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。
Void
Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。

java.lang.annotation 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.lang.instrument 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.lang.management 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
StackTraceElement
堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。
String
String 类代表字符串。
Thread.State
线程状态。

java.lang.ref 使用的 java.lang 中的类
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
Object
类 Object 是类层次结构的根类。

java.lang.reflect 使用的 java.lang 中的类
ArrayIndexOutOfBoundsException
用非法索引访问数组时抛出的异常。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassFormatError
当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
ClassLoader
类加载器是负责加载类的对象。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
LinkageError
LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
NegativeArraySizeException
如果应用程序试图创建大小为负的数组，则抛出该异常。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.math 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.net 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
Package
Package 对象包含有关 Java 包的实现和规范的版本信息。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.nio 使用的 java.lang 中的类
Appendable
能够被添加 char 序列和值的对象。
CharSequence
CharSequence 是 char 值的一个可读序列。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
Object
类 Object 是类层次结构的根类。
Readable
Readable 是一个字符源。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。
UnsupportedOperationException
当不支持请求的操作时，抛出该异常。

java.nio.channels 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.nio.channels.spi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

java.nio.charset 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.nio.charset.spi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.rmi 使用的 java.lang 中的类
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
SecurityManager
安全管理器是一个允许应用程序实现安全策略的类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.rmi.activation 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.rmi.dgc 使用的 java.lang 中的类
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.rmi.registry 使用的 java.lang 中的类
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.rmi.server 使用的 java.lang 中的类
Appendable
能够被添加 char 序列和值的对象。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.security 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.security.acl 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.security.cert 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.security.spec 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.sql 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.text 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
StringBuffer
线程安全的可变字符序列。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.text.spi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

java.util 使用的 java.lang 中的类
Appendable
能够被添加 char 序列和值的对象。
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Enum
这是所有 Java 语言枚举类型的公共基本类。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
Readable
Readable 是一个字符源。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.util.concurrent 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Thread
线程 是程序中的执行线程。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.util.concurrent.atomic 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.util.concurrent.locks 使用的 java.lang 中的类
InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Thread
线程 是程序中的执行线程。

java.util.jar 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.util.logging 使用的 java.lang 中的类
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.util.prefs 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.util.regex 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
StringBuffer
线程安全的可变字符序列。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

java.util.spi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

java.util.zip 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
InternalError
该异常指示 Java 虚拟机中出现一些意外的内部错误。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。
VirtualMachineError
当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

javax.accessibility 使用的 java.lang 中的类
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.activation 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.activity 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.annotation 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
String
String 类代表字符串。

javax.annotation.processing 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.crypto 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.crypto.spec 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.imageio 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。
UnsupportedOperationException
当不支持请求的操作时，抛出该异常。

javax.imageio.event 使用的 java.lang 中的类
String
String 类代表字符串。

javax.imageio.metadata 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.imageio.plugins.bmp 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

javax.imageio.plugins.jpeg 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.imageio.spi 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.imageio.stream 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.jws 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
String
String 类代表字符串。

javax.jws.soap 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
String
String 类代表字符串。

javax.lang.model 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
String
String 类代表字符串。

javax.lang.model.element 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.lang.model.type 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.lang.model.util 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
Override
表示一个方法声明打算重写超类中的另一个方法声明。
String
String 类代表字符串。

javax.management 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
NullPointerException
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
Override
表示一个方法声明打算重写超类中的另一个方法声明。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
SuppressWarnings
指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.management.loading 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
UnsupportedOperationException
当不支持请求的操作时，抛出该异常。

javax.management.modelmbean 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
Override
表示一个方法声明打算重写超类中的另一个方法声明。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.management.monitor 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.management.openmbean 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Byte
Byte 类将基本类型 byte 的值包装在一个对象中。
Character
Character 类在对象中包装一个基本类型 char 的值。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Double
Double 类在对象中包装一个基本类型 double 的值。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Float
Float 类在对象中包装一个基本类型 float 的值。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Long
Long 类在对象中包装了基本类型 long 的值。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
Short
Short 类在对象中包装基本类型 short 的值。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。
Void
Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。

javax.management.relation 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IndexOutOfBoundsException
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
NoSuchMethodException
无法找到某一特定方法时，抛出该异常。
Object
类 Object 是类层次结构的根类。
Override
表示一个方法声明打算重写超类中的另一个方法声明。
String
String 类代表字符串。
SuppressWarnings
指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.management.remote 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.management.remote.rmi 使用的 java.lang 中的类
ClassLoader
类加载器是负责加载类的对象。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.management.timer 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Long
Long 类在对象中包装了基本类型 long 的值。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.naming 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.naming.directory 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.naming.event 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.naming.ldap 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.naming.spi 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.net 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.net.ssl 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.print 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.print.attribute 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.print.attribute.standard 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.print.event 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.rmi 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassCastException
当试图将对象强制转换为不是实例的子类时，抛出该异常。
Object
类 Object 是类层次结构的根类。

javax.rmi.CORBA 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassCastException
当试图将对象强制转换为不是实例的子类时，抛出该异常。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.rmi.ssl 使用的 java.lang 中的类
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.script 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
NoSuchMethodException
无法找到某一特定方法时，抛出该异常。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.security.auth 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.security.auth.callback 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.security.auth.kerberos 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.security.auth.login 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.security.auth.spi 使用的 java.lang 中的类
String
String 类代表字符串。

javax.security.auth.x500 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.security.cert 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.security.sasl 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.sound.midi 使用的 java.lang 中的类
ArrayIndexOutOfBoundsException
用非法索引访问数组时抛出的异常。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.sound.midi.spi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

javax.sound.sampled 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.sound.sampled.spi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

javax.sql 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.sql.rowset 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.sql.rowset.serial 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.sql.rowset.spi 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.swing 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Character
Character 类在对象中包装一个基本类型 char 的值。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。
String
String 类代表字符串。
SuppressWarnings
指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.swing.border 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.colorchooser 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.event 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.filechooser 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.plaf 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.plaf.basic 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Integer
Integer 类在对象中包装了一个基本类型 int 的值。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.plaf.metal 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.plaf.multi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.plaf.synth 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.table 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.text 使用的 java.lang 中的类
CharSequence
CharSequence 是 char 值的一个可读序列。
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
Runnable
Runnable 接口应该由那些打算通过某一线程执行其实例的类来实现。
String
String 类代表字符串。
Thread
线程 是程序中的执行线程。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.swing.text.html 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.text.html.parser 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
StringBuffer
线程安全的可变字符序列。

javax.swing.text.rtf 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.swing.tree 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.swing.undo 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.tools 使用的 java.lang 中的类
Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。
CharSequence
CharSequence 是 char 值的一个可读序列。
ClassLoader
类加载器是负责加载类的对象。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Iterable
实现这个接口允许对象成为 "foreach" 语句的目标。
Object
类 Object 是类层次结构的根类。
Override
表示一个方法声明打算重写超类中的另一个方法声明。
String
String 类代表字符串。

javax.transaction 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.transaction.xa 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.bind 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
ClassLoader
类加载器是负责加载类的对象。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalStateException
在非法或不适当的时间调用方法时产生的信号。
Object
类 Object 是类层次结构的根类。
Override
表示一个方法声明打算重写超类中的另一个方法声明。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.bind.annotation 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.bind.annotation.adapters 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.bind.attachment 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.bind.helpers 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.bind.util 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

javax.xml.crypto 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.crypto.dom 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.crypto.dsig 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.crypto.dsig.dom 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

javax.xml.crypto.dsig.keyinfo 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.crypto.dsig.spec 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.datatype 使用的 java.lang 中的类
ClassLoader
类加载器是负责加载类的对象。
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.namespace 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.parsers 使用的 java.lang 中的类
ClassLoader
类加载器是负责加载类的对象。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.soap 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。
UnsupportedOperationException
当不支持请求的操作时，抛出该异常。

javax.xml.stream 使用的 java.lang 中的类
ClassLoader
类加载器是负责加载类的对象。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.stream.events 使用的 java.lang 中的类
String
String 类代表字符串。

javax.xml.stream.util 使用的 java.lang 中的类
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.transform 使用的 java.lang 中的类
ClassLoader
类加载器是负责加载类的对象。
Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.transform.dom 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.transform.sax 使用的 java.lang 中的类
IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.transform.stax 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.transform.stream 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.validation 使用的 java.lang 中的类
ClassLoader
类加载器是负责加载类的对象。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.ws 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.ws.handler 使用的 java.lang 中的类
Comparable
此接口强行对实现它的每个类的对象进行整体排序。
String
String 类代表字符串。

javax.xml.ws.handler.soap 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.ws.http 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.ws.soap 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

javax.xml.ws.spi 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

javax.xml.xpath 使用的 java.lang 中的类
ClassLoader
类加载器是负责加载类的对象。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.ietf.jgss 使用的 java.lang 中的类
Cloneable
此类实现了 Cloneable 接口，以指示 Object.clone() 方法可以合法地对该类实例进行按字段复制。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.CORBA 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.CORBA.DynAnyPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.CORBA.ORBPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.CORBA.TypeCodePackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.CORBA.portable 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.CORBA_2_3.portable 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。

org.omg.CosNaming 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.omg.CosNaming.NamingContextExtPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.CosNaming.NamingContextPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.Dynamic 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

org.omg.DynamicAny 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.omg.DynamicAny.DynAnyFactoryPackage 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.omg.DynamicAny.DynAnyPackage 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.omg.IOP 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.omg.IOP.CodecFactoryPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.IOP.CodecPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.Messaging 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.omg.PortableInterceptor 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.PortableInterceptor.ORBInitInfoPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.PortableServer 使用的 java.lang 中的类
Class
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.PortableServer.CurrentPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.PortableServer.POAManagerPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.PortableServer.POAPackage 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.omg.PortableServer.ServantLocatorPackage 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。

org.omg.stub.java.rmi 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.w3c.dom 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.w3c.dom.bootstrap 使用的 java.lang 中的类
ClassCastException
当试图将对象强制转换为不是实例的子类时，抛出该异常。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.w3c.dom.events 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.w3c.dom.ls 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.xml.sax 使用的 java.lang 中的类
Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。
Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

org.xml.sax.ext 使用的 java.lang 中的类
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

org.xml.sax.helpers 使用的 java.lang 中的类
ClassCastException
当试图将对象强制转换为不是实例的子类时，抛出该异常。
ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
NullPointerException
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
Object
类 Object 是类层次结构的根类。
String
String 类代表字符串。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Annotation (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.annotation
接口 Annotation

所有已知实现类：
BindingType, ConstructorProperties, Deprecated, DescriptorKey, Documented, Generated, HandlerChain, Inherited, InitParam, MXBean, Oneway, Override, PostConstruct, PreDestroy, RequestWrapper, Resource, Resources, ResponseWrapper, Retention, ServiceMode, SOAPBinding, SOAPMessageHandler, SOAPMessageHandlers, SupportedAnnotationTypes, SupportedOptions, SupportedSourceVersion, SuppressWarnings, Target, WebEndpoint, WebFault, WebMethod, WebParam, WebResult, WebService, WebServiceClient, WebServiceProvider, WebServiceRef, WebServiceRefs, XmlAccessorOrder, XmlAccessorType, XmlAnyAttribute, XmlAnyElement, XmlAttachmentRef, XmlAttribute, XmlElement, XmlElementDecl, XmlElementRef, XmlElementRefs, XmlElements, XmlElementWrapper, XmlEnum, XmlEnumValue, XmlID, XmlIDREF, XmlInlineBinaryData, XmlJavaTypeAdapter, XmlJavaTypeAdapters, XmlList, XmlMimeType, XmlMixed, XmlNs, XmlRegistry, XmlRootElement, XmlSchema, XmlSchemaType, XmlSchemaTypes, XmlTransient, XmlType, XmlValue
public interface Annotation

所有 annotation 类型都要扩展的公共接口。注意，手动扩展该公共接口的接口不 定义 annotation 类型。还要注意此接口本身不定义 annotation 类型。

从以下版本开始：
1.5

方法摘要
Class<? extends Annotation> | annotationType() 返回此 annotation 的注释类型。
boolean | equals(Object obj) 如果指定的对象表示在逻辑上等效于此接口的注释，则返回 true。
int | hashCode() 返回此 annotation 的哈希码，具体说明如下： 一个 annotation 的哈希码是其成员（包括那些带有默认值的成员）的哈希码的和，具体说明如下： annotation 成员的哈希码是成员值哈希码的 XOR（它是 String.hashCode() 计算得到的成员名哈希码的 127 倍），具体说明如下： 成员值的哈希码取决于其类型： 基值 v 的哈希码等于 WrapperType.valueOf(v).hashCode()，其中 WrapperType 是对应 v 的基本类型的包装器类型（Byte、Character、Double、Float、Integer、Long、Short 或 Boolean）。
String | toString() 返回此 annotation 的字符串表示形式。

方法详细信息

equals

boolean equals(Object obj)
如果指定的对象表示在逻辑上等效于此接口的注释，则返回 true。换句话说，如果指定对象是一个与此实例相同的 annotation 类型的实例，即其所有成员都与此实例中所对应的成员相等，则返回 true，具体说明如下：
  • 如果 x == y，则认为值分别为 x 和 y 的两个对应的基本类型成员相等，除非它们的类型是 float 或 double。
  • 如果 Float.valueOf(x).equals(Float.valueOf(y)) 为真，则认为值分别为 x 和 y 的两个对应的 float 成员相等。（与 == 运算符不同，NaN 被认为等于其自身，并且 0.0f 不等于 -0.0f。）
  • 如果 Double.valueOf(x).equals(Double.valueOf(y)) 为真，则认为值分别为 x 和 y 的两个对应的 double 成员相等。（与 == 运算符不同，NaN 被认为等于其自身，并且 0.0 不等于 -0.0。）
  • 如果 x.equals(y) 为真，则认为值分别为 x 和 y 的两个对应的 String、Class、enum 或 annotation 类型的成员相等。（注意，此定义对于 annotation 类型的成员是递归的。）
  • 对于适当重载的 Arrays.equals(long[], long[])，如果 Arrays.equals(x, y) 为真, 则认为两个对应的数组类型的成员 x 和 y 相等。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果指定的对象表示在逻辑上等效于该接口的 annotation，则返回 true，否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 annotation 的哈希码，具体说明如下：

一个 annotation 的哈希码是其成员（包括那些带有默认值的成员）的哈希码的和，具体说明如下： annotation 成员的哈希码是成员值哈希码的 XOR（它是 String.hashCode() 计算得到的成员名哈希码的 127 倍），具体说明如下：

成员值的哈希码取决于其类型：

  • 基值 v 的哈希码等于 WrapperType.valueOf(v).hashCode()，其中 WrapperType 是对应 v 的基本类型的包装器类型（Byte、Character、Double、Float、Integer、Long、Short 或 Boolean）。
  • string、enum、class 或 annotation 的成员值 I 的哈希码 v 是通过调用 v.hashCode() 来计算的。（对于 annotation 成员值，这是一种递归定义。）
  • 数组成员值的哈希码是通过基于该值调用 Arrays.hashCode 的适当重载来计算的。（各种基本类型和对象引用类型分别对应一个重载。）

覆盖：
类 Object 中的 hashCode
返回：
此 annotation 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 annotation 的字符串表示形式。表示形式的细节取决于实现，但下面的情况是最常见的：
   @com.acme.util.Name(first=Alfred, middle=E., last=Neuman)

覆盖：
类 Object 中的 toString
返回：
此 annotation 的字符串表示形式

annotationType

Class<? extends Annotation> annotationType()
返回此 annotation 的注释类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AnnotationFormatError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.annotation
类 AnnotationFormatError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.annotation.AnnotationFormatError
所有已实现的接口：
Serializable
public class AnnotationFormatError
extends Error

当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AnnotationFormatError(String message)
构造具有指定详细消息的新 AnnotationFormatError。
AnnotationFormatError(String message, Throwable cause)
构造带指定详细消息和原因的新 AnnotationFormatError。
AnnotationFormatError(Throwable cause)
构造带指定原因和详细消息的新 AnnotationFormatError，该消息为 (cause == null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AnnotationFormatError

public AnnotationFormatError(String message)
构造具有指定详细消息的新 AnnotationFormatError。

参数：
message - 详细消息。

AnnotationFormatError

public AnnotationFormatError(String message,
                             Throwable cause)
构造带指定详细消息和原因的新 AnnotationFormatError。注意，与 cause 相关的详细消息不会 自动合并到此错误的详细消息中。

参数：
message - 详细消息
cause - 原因（允许 null 值，它表示原因是不存在的或是未知的。）

AnnotationFormatError

public AnnotationFormatError(Throwable cause)
构造带指定原因和详细消息的新 AnnotationFormatError，该消息为 (cause == null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - 原因（允许 null 值，它表示原因是不存在的或是未知的。）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AnnotationTypeMismatchException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.annotation
类 AnnotationTypeMismatchException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.annotation.AnnotationTypeMismatchException
所有已实现的接口：
Serializable
public class AnnotationTypeMismatchException
extends RuntimeException

若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AnnotationTypeMismatchException(Method element, String foundType)
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。
方法摘要
Method | element() 返回类型不正确的元素的 Method 对象。
String | foundType() 返回在类型不正确的元素中找到的数据类型。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AnnotationTypeMismatchException

public AnnotationTypeMismatchException(Method element,
                                       String foundType)
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。

参数：
element - 注释元素的 Method 对象
foundType - 在注释中找到的数据的（错误）类型。此字符串可以，但不一定包含该值。没有指定字符串的确切格式。
方法详细信息

element

public Method element()
返回类型不正确的元素的 Method 对象。

返回：
类型不正确的元素的 Method 对象。

foundType

public String foundType()
返回在类型不正确的元素中找到的数据类型。返回的字符串可以，但不一定包含该值。字符串的确切格式没有指定。

返回：
在类型不正确的元素中找到的数据类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Documented (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

java.lang.annotation
注释类型 Documented

@Documented
@Retention(value=RUNTIME)
@Target(value=ANNOTATION_TYPE)
public @interface Documented

指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。应使用此类型来注释这些类型的声明：其注释会影响由其客户端注释的元素的使用。如果类型声明是用 Documented 来注释的，则其注释将成为注释元素的公共 API 的一部分。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


ElementType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.lang.annotation
枚举 ElementType

java.lang.Object
    继承者  java.lang.Enum<ElementType>
        继承者  java.lang.annotation.ElementType
所有已实现的接口：
Serializable, Comparable<ElementType>
public enum ElementType
extends Enum<ElementType>

程序元素类型。此枚举类型的常量提供了 Java 程序中声明的元素的简单分类。

这些常量与 Target 元注释类型一起使用，以指定在什么情况下使用注释类型是合法的。

从以下版本开始：
1.5

枚举常量摘要
ANNOTATION_TYPE
注释类型声明
CONSTRUCTOR
构造方法声明
FIELD
字段声明（包括枚举常量）
LOCAL_VARIABLE
局部变量声明
METHOD
方法声明
PACKAGE
包声明
PARAMETER
参数声明
TYPE
类、接口（包括注释类型）或枚举声明
方法摘要
static ElementType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ElementType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

TYPE

public static final ElementType TYPE
类、接口（包括注释类型）或枚举声明

FIELD

public static final ElementType FIELD
字段声明（包括枚举常量）

METHOD

public static final ElementType METHOD
方法声明

PARAMETER

public static final ElementType PARAMETER
参数声明

CONSTRUCTOR

public static final ElementType CONSTRUCTOR
构造方法声明

LOCAL_VARIABLE

public static final ElementType LOCAL_VARIABLE
局部变量声明

ANNOTATION_TYPE

public static final ElementType ANNOTATION_TYPE
注释类型声明

PACKAGE

public static final ElementType PACKAGE
包声明

方法详细信息

values

public static final ElementType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(ElementType c : ElementType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ElementType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


IncompleteAnnotationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.annotation
类 IncompleteAnnotationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.annotation.IncompleteAnnotationException
所有已实现的接口：
Serializable
public class IncompleteAnnotationException
extends RuntimeException

若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。如果新元素有默认值，则不抛出此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
IncompleteAnnotationException(Class<? extends Annotation> annotationType, String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。
方法摘要
Class<? extends Annotation> | annotationType() 返回带有缺少元素的注释类型的 Class 对象。
String | elementName() 返回缺少元素的名称。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IncompleteAnnotationException

public IncompleteAnnotationException(Class<? extends Annotation> annotationType,
                                     String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。

参数：
annotationType - 注释类型的 Class 对象
elementName - 缺少元素的名称
方法详细信息

annotationType

public Class<? extends Annotation> annotationType()
返回带有缺少元素的注释类型的 Class 对象。

返回：
带有缺少元素的注释类型的 Class 对象

elementName

public String elementName()
返回缺少元素的名称。

返回：
缺少元素的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Inherited (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

java.lang.annotation
注释类型 Inherited

@Documented
@Retention(value=RUNTIME)
@Target(value=ANNOTATION_TYPE)
public @interface Inherited

指示注释类型被自动继承。如果在注释类型声明中存在 Inherited 元注释，并且用户在某一类声明中查询该注释类型，同时该类声明中没有此类型的注释，则将在该类的超类中自动查询该注释类型。此过程会重复进行，直到找到此类型的注释或到达了该类层次结构的顶层 (Object) 为止。如果没有超类具有该类型的注释，则查询将指示当前类没有这样的注释。

注意，如果使用注释类型注释类以外的任何事物，此元注释类型都是无效的。还要注意，此元注释仅促成从超类继承注释；对已实现接口的注释无效。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Retention (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

java.lang.annotation
注释类型 Retention

@Documented
@Retention(value=RUNTIME)
@Target(value=ANNOTATION_TYPE)
public @interface Retention

指示注释类型的注释要保留多久。如果注释类型声明中不存在 Retention 注释，则保留策略默认为 RetentionPolicy.CLASS。

只有元注释类型直接用于注释时，Target 元注释才有效。如果元注释类型用作另一种注释类型的成员，则无效。

从以下版本开始：
1.5

必需元素摘要
 RetentionPolicy value

元素详细信息

value

public abstract RetentionPolicy value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


RetentionPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.lang.annotation
枚举 RetentionPolicy

java.lang.Object
    继承者  java.lang.Enum<RetentionPolicy>
        继承者  java.lang.annotation.RetentionPolicy
所有已实现的接口：
Serializable, Comparable<RetentionPolicy>
public enum RetentionPolicy
extends Enum<RetentionPolicy>

注释保留策略。此枚举类型的常量描述保留注释的不同策略。它们与 Retention 元注释类型一起使用，以指定保留多长的注释。

从以下版本开始：
1.5

枚举常量摘要
CLASS
编译器将把注释记录在类文件中，但在运行时 VM 不需要保留注释。
RUNTIME
编译器将把注释记录在类文件中，在运行时 VM 将保留注释，因此可以反射性地读取。
SOURCE
编译器要丢弃的注释。
方法摘要
static RetentionPolicy | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RetentionPolicy[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

SOURCE

public static final RetentionPolicy SOURCE
编译器要丢弃的注释。

CLASS

public static final RetentionPolicy CLASS
编译器将把注释记录在类文件中，但在运行时 VM 不需要保留注释。这是默认的行为。

RUNTIME

public static final RetentionPolicy RUNTIME
编译器将把注释记录在类文件中，在运行时 VM 将保留注释，因此可以反射性地读取。

另请参见：
AnnotatedElement
方法详细信息

values

public static final RetentionPolicy[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(RetentionPolicy c : RetentionPolicy.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static RetentionPolicy valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Target (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

java.lang.annotation
注释类型 Target

@Documented
@Retention(value=RUNTIME)
@Target(value=ANNOTATION_TYPE)
public @interface Target

指示注释类型所适用的程序元素的种类。如果注释类型声明中不存在 Target 元注释，则声明的类型可以用在任一程序元素上。如果存在这样的元注释，则编译器强制实施指定的使用限制。 例如，此元注释指示该声明类型是其自身，即元注释类型。它只能用在注释类型声明上：

    @Target(ElementType.ANNOTATION_TYPE)
    public @interface MetaAnnotationType {
        ...
    }
此元注释指示该声明类型只可作为复杂注释类型声明中的成员类型使用。它不能直接用于注释：
    @Target({})
    public @interface MemberType {
        ...
    }
这是一个编译时错误，它表明一个 ElementType 常量在 Target 注释中出现了不只一次。例如，以下元注释是非法的：
    @Target({ElementType.FIELD, ElementType.METHOD, ElementType.FIELD})
    public @interface Bogus {
        ...
    }

必需元素摘要
 ElementType[] value

元素详细信息

value

public abstract ElementType[] value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


java.lang.annotation (Java 2 Platform SE 6)

 java.lang.annotation
接口
Annotation
枚举
ElementType
RetentionPolicy
异常
AnnotationTypeMismatchException
IncompleteAnnotationException
错误
AnnotationFormatError
注释类型
Documented
Inherited
Retention
Target


java.lang.annotation (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.lang.annotation

为 Java 编程语言注释设施提供库支持。

请参见：
描述

接口摘要
Annotation 所有 annotation 类型都要扩展的公共接口。

枚举摘要
ElementType | 程序元素类型。
RetentionPolicy | 注释保留策略。

异常摘要
AnnotationTypeMismatchException | 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
IncompleteAnnotationException | 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

错误摘要
AnnotationFormatError 当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。

注释类型摘要
Documented | 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
Inherited | 指示注释类型被自动继承。
Retention | 指示注释类型的注释要保留多久。
Target | 指示注释类型所适用的程序元素的种类。

软件包 java.lang.annotation 的描述

为 Java 编程语言注释设施提供库支持。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.lang.annotation 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.annotation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.annotation.AnnotationFormatError
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.annotation.AnnotationTypeMismatchException
          • java.lang.annotation.IncompleteAnnotationException

接口分层结构

  • java.lang.annotation.Annotation

注释类型分层结构

  • java.lang.annotation.Documented (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Inherited (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Retention (implements java.lang.annotation.Annotation)
  • java.lang.annotation.Target (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.annotation.ElementType
      • java.lang.annotation.RetentionPolicy
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.lang.annotation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.annotation
的使用

使用 java.lang.annotation 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Documented
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

java.lang 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Documented
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

java.lang.annotation 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Documented
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
ElementType
程序元素类型。
Retention
指示注释类型的注释要保留多久。
RetentionPolicy
注释保留策略。
Target
指示注释类型所适用的程序元素的种类。

java.lang.reflect 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。

javax.annotation 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Documented
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

javax.annotation.processing 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Documented
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

javax.jws 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

javax.jws.soap 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

javax.lang.model.element 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。

javax.management 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Documented
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

javax.xml.bind.annotation 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Inherited
指示注释类型被自动继承。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

javax.xml.bind.annotation.adapters 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

javax.xml.ws 使用的 java.lang.annotation 中的类
Annotation
所有 annotation 类型都要扩展的公共接口。
Documented
指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
Inherited
指示注释类型被自动继承。
Retention
指示注释类型的注释要保留多久。
Target
指示注释类型所适用的程序元素的种类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.AnnotationFormatError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.AnnotationFormatError
的使用

没有 java.lang.annotation.AnnotationFormatError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.AnnotationTypeMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.AnnotationTypeMismatchException
的使用

没有 java.lang.annotation.AnnotationTypeMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.Documented 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Documented
的使用

使用 Documented 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Documented 的使用

注释类型为 Documented 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Documented 的使用

注释类型为 Documented 的 java.lang 中的类
 interface Deprecated
用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。

java.lang.annotation 中 Documented 的使用

注释类型为 Documented 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

javax.annotation 中 Documented 的使用

注释类型为 Documented 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Documented 的使用

注释类型为 Documented 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

javax.management 中 Documented 的使用

注释类型为 Documented 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.ws 中 Documented 的使用

注释类型为 Documented 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.ElementType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.ElementType
的使用

使用 ElementType 的软件包
java.lang.annotation 为 Java 编程语言注释设施提供库支持。

java.lang.annotation 中 ElementType 的使用

返回 ElementType 的 java.lang.annotation 中的方法
static ElementType | ElementType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ElementType[] | ElementType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.IncompleteAnnotationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.IncompleteAnnotationException
的使用

没有 java.lang.annotation.IncompleteAnnotationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.Inherited 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Inherited
的使用

使用 Inherited 的软件包
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.ws | 此包包含核心 JAX-WS API。

javax.xml.bind.annotation 中 Inherited 的使用

注释类型为 Inherited 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。

javax.xml.ws 中 Inherited 的使用

注释类型为 Inherited 的 javax.xml.ws 中的类
 interface ServiceMode
用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.Retention 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Retention
的使用

使用 Retention 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Retention 的使用

注释类型为 Retention 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Retention 的使用

注释类型为 Retention 的 java.lang 中的类
interface | Deprecated 用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
interface | Override 表示一个方法声明打算重写超类中的另一个方法声明。
interface | SuppressWarnings 指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。

java.lang.annotation 中 Retention 的使用

注释类型为 Retention 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

javax.annotation 中 Retention 的使用

注释类型为 Retention 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resource Resource 注释标记应用程序所需的资源。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Retention 的使用

注释类型为 Retention 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

javax.jws 中 Retention 的使用

注释类型为 Retention 的 javax.jws 中的类
interface | HandlerChain 将 Web Service 与外部定义的处理程序链关联。
interface | Oneway 指示给定 @WebMethod 只有一条输入消息并且没有输出。
interface | WebMethod 定制一个公开为 Web Service 操作的方法。
interface | WebParam 定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
interface | WebResult 定制返回值到 WSDL 部分和 XML 元素的映射关系。
interface | WebService 将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

javax.jws.soap 中 Retention 的使用

注释类型为 Retention 的 javax.jws.soap 中的类
interface | SOAPBinding 指定 Web Service 到 SOAP 消息协议的映射关系。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.management 中 Retention 的使用

注释类型为 Retention 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.bind.annotation 中 Retention 的使用

注释类型为 Retention 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。
interface | XmlAnyAttribute 将 JavaBean 属性映射到通配符属性的映射表中。
interface | XmlAnyElement 将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
interface | XmlAttachmentRef 标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
interface | XmlAttribute 将 JavaBean 属性映射到 XML 属性。
interface | XmlElement 将 JavaBean 属性映射到派生于属性名称的 XML 元素。
interface | XmlElementDecl 将工厂方法映射到 XML 元素。
interface | XmlElementRef 将 JavaBean 属性映射到派生于属性类型的 XML 元素。
interface | XmlElementRefs 标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
interface | XmlElements 多个 @XmlElement 注释的容器。
interface | XmlElementWrapper 生成一个包装 XML 表示形式的包装器元素。
interface | XmlEnum 将枚举类型 Enum 映射到 XML 表示形式。
interface | XmlEnumValue 将 Enum 类型中的枚举常量映射到 XML 表示形式。
interface | XmlID 将 JavaBean 属性映射到 XML ID。
interface | XmlIDREF 将 JavaBean 属性映射到 XML IDREF。
interface | XmlInlineBinaryData 禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
interface | XmlList 用来将属性映射到列表简单类型。
interface | XmlMimeType 关联控制属性 XML 表示形式的 MIME 类型。
interface | XmlMixed 注释 JavaBean 多值属性，以支持混合内容。
interface | XmlNs 关联名称空间前缀与 XML 名称空间 URI。
interface | XmlRegistry 标记具有 XmlElementDecl 的类。
interface | XmlRootElement 将类或枚举类型映射到 XML 元素。
interface | XmlSchema 将包名称映射到 XML 名称空间。
interface | XmlSchemaType 将 Java 类型映射到一个简单的模式内置类型。
interface | XmlSchemaTypes 多个 @XmlSchemaType 注释的容器。
interface | XmlTransient 阻止将 JavaBean 属性映射到 XML 表示形式。
interface | XmlType 将类或枚举类型映射到 XML 模式类型。
interface | XmlValue 支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

javax.xml.bind.annotation.adapters 中 Retention 的使用

注释类型为 Retention 的 javax.xml.bind.annotation.adapters 中的类
interface | XmlJavaTypeAdapter 对自定义编组使用实现 XmlAdapter 的适配器。
interface | XmlJavaTypeAdapters 多个 @XmlJavaTypeAdapter 注释的容器。

javax.xml.ws 中 Retention 的使用

注释类型为 Retention 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.RetentionPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.RetentionPolicy
的使用

使用 RetentionPolicy 的软件包
java.lang.annotation 为 Java 编程语言注释设施提供库支持。

java.lang.annotation 中 RetentionPolicy 的使用

返回 RetentionPolicy 的 java.lang.annotation 中的方法
static RetentionPolicy | RetentionPolicy.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RetentionPolicy[] | RetentionPolicy.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.annotation.Target 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.annotation.Target
的使用

使用 Target 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Target 的使用

注释类型为 Target 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Target 的使用

注释类型为 Target 的 java.lang 中的类
interface | Override 表示一个方法声明打算重写超类中的另一个方法声明。
interface | SuppressWarnings 指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。

java.lang.annotation 中 Target 的使用

注释类型为 Target 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

javax.annotation 中 Target 的使用

注释类型为 Target 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resource Resource 注释标记应用程序所需的资源。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Target 的使用

注释类型为 Target 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

javax.jws 中 Target 的使用

注释类型为 Target 的 javax.jws 中的类
interface | HandlerChain 将 Web Service 与外部定义的处理程序链关联。
interface | Oneway 指示给定 @WebMethod 只有一条输入消息并且没有输出。
interface | WebMethod 定制一个公开为 Web Service 操作的方法。
interface | WebParam 定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
interface | WebResult 定制返回值到 WSDL 部分和 XML 元素的映射关系。
interface | WebService 将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

javax.jws.soap 中 Target 的使用

注释类型为 Target 的 javax.jws.soap 中的类
interface | SOAPBinding 指定 Web Service 到 SOAP 消息协议的映射关系。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.management 中 Target 的使用

注释类型为 Target 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.bind.annotation 中 Target 的使用

注释类型为 Target 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。
interface | XmlAnyAttribute 将 JavaBean 属性映射到通配符属性的映射表中。
interface | XmlAnyElement 将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
interface | XmlAttachmentRef 标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
interface | XmlAttribute 将 JavaBean 属性映射到 XML 属性。
interface | XmlElement 将 JavaBean 属性映射到派生于属性名称的 XML 元素。
interface | XmlElementDecl 将工厂方法映射到 XML 元素。
interface | XmlElementRef 将 JavaBean 属性映射到派生于属性类型的 XML 元素。
interface | XmlElementRefs 标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
interface | XmlElements 多个 @XmlElement 注释的容器。
interface | XmlElementWrapper 生成一个包装 XML 表示形式的包装器元素。
interface | XmlEnum 将枚举类型 Enum 映射到 XML 表示形式。
interface | XmlEnumValue 将 Enum 类型中的枚举常量映射到 XML 表示形式。
interface | XmlID 将 JavaBean 属性映射到 XML ID。
interface | XmlIDREF 将 JavaBean 属性映射到 XML IDREF。
interface | XmlInlineBinaryData 禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
interface | XmlList 用来将属性映射到列表简单类型。
interface | XmlMimeType 关联控制属性 XML 表示形式的 MIME 类型。
interface | XmlMixed 注释 JavaBean 多值属性，以支持混合内容。
interface | XmlNs 关联名称空间前缀与 XML 名称空间 URI。
interface | XmlRegistry 标记具有 XmlElementDecl 的类。
interface | XmlRootElement 将类或枚举类型映射到 XML 元素。
interface | XmlSchema 将包名称映射到 XML 名称空间。
interface | XmlSchemaType 将 Java 类型映射到一个简单的模式内置类型。
interface | XmlSchemaTypes 多个 @XmlSchemaType 注释的容器。
interface | XmlTransient 阻止将 JavaBean 属性映射到 XML 表示形式。
interface | XmlType 将类或枚举类型映射到 XML 模式类型。
interface | XmlValue 支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

javax.xml.bind.annotation.adapters 中 Target 的使用

注释类型为 Target 的 javax.xml.bind.annotation.adapters 中的类
interface | XmlJavaTypeAdapter 对自定义编组使用实现 XmlAdapter 的适配器。
interface | XmlJavaTypeAdapters 多个 @XmlJavaTypeAdapter 注释的容器。

javax.xml.ws 中 Target 的使用

注释类型为 Target 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.annotation.Annotation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.annotation.Annotation
的使用

使用 Annotation 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
javax.annotation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.jws |
javax.jws.soap |
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.beans 中 Annotation 的使用

实现 Annotation 的 java.beans 中的类
 interface ConstructorProperties
关于构造方法的注释，用来说明该构造方法的参数如何与被构造对象的获取方法相对应。

java.lang 中 Annotation 的使用

实现 Annotation 的 java.lang 中的类
interface | Deprecated 用 @Deprecated 注释的程序元素，不鼓励程序员使用这样的元素，通常是因为它很危险或存在更好的选择。
interface | Override 表示一个方法声明打算重写超类中的另一个方法声明。
interface | SuppressWarnings 指示应该在注释元素（以及包含在该注释元素中的所有程序元素）中取消显示指定的编译器警告。

类型参数类型为 Annotation 的 java.lang 中的方法
<A extends Annotation>
A
Package.getAnnotation(Class<A> annotationClass)
<A extends Annotation>
A
Class.getAnnotation(Class<A> annotationClass)

返回 Annotation 的 java.lang 中的方法
Annotation[] | Package.getAnnotations()
Annotation[] | Class.getAnnotations()
Annotation[] | Package.getDeclaredAnnotations()
Annotation[] | Class.getDeclaredAnnotations()

类型变量类型为 Annotation 的 java.lang 中的方法参数
boolean | Package.isAnnotationPresent(Class<? extends Annotation> annotationClass)
boolean | Class.isAnnotationPresent(Class<? extends Annotation> annotationClass)

java.lang.annotation 中 Annotation 的使用

实现 Annotation 的 java.lang.annotation 中的类
interface | Documented 指示某一类型的注释将通过 javadoc 和类似的默认工具进行文档化。
interface | Inherited 指示注释类型被自动继承。
interface | Retention 指示注释类型的注释要保留多久。
interface | Target 指示注释类型所适用的程序元素的种类。

返回变量类型为 Annotation 的类型的 java.lang.annotation 中的方法
Class<? extends Annotation> | IncompleteAnnotationException.annotationType() 返回带有缺少元素的注释类型的 Class 对象。
Class<? extends Annotation> | Annotation.annotationType() 返回此 annotation 的注释类型。

类型变量类型为 Annotation 的 java.lang.annotation 中的构造方法参数
IncompleteAnnotationException(Class<? extends Annotation> annotationType, String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。

java.lang.reflect 中 Annotation 的使用

类型参数类型为 Annotation 的 java.lang.reflect 中的方法
<T extends Annotation>
T
Constructor.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Method.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Field.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AccessibleObject.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AnnotatedElement.getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

返回 Annotation 的 java.lang.reflect 中的方法
Annotation[] | AccessibleObject.getAnnotations()
Annotation[] | AnnotatedElement.getAnnotations() 返回此元素上存在的所有注释。
Annotation[] | Constructor.getDeclaredAnnotations()
Annotation[] | Method.getDeclaredAnnotations()
Annotation[] | Field.getDeclaredAnnotations()
Annotation[] | AccessibleObject.getDeclaredAnnotations()
Annotation[] | AnnotatedElement.getDeclaredAnnotations() 返回直接存在于此元素上的所有注释。
Annotation[][] | Constructor.getParameterAnnotations() 按照声明顺序返回一组数组，这些数组表示通过此 Constructor 对象表示的方法的形参上的注释。
Annotation[][] | Method.getParameterAnnotations() 返回表示按照声明顺序对此 Method 对象所表示方法的形参进行注释的那个数组的数组。

类型变量类型为 Annotation 的 java.lang.reflect 中的方法参数
boolean | AccessibleObject.isAnnotationPresent(Class<? extends Annotation> annotationClass)
boolean | AnnotatedElement.isAnnotationPresent(Class<? extends Annotation> annotationClass) 如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。

javax.annotation 中 Annotation 的使用

实现 Annotation 的 javax.annotation 中的类
interface | Generated Generated 注释用于标记已生成的源代码。
interface | PostConstruct PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
interface | PreDestroy PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
interface | Resource Resource 注释标记应用程序所需的资源。
interface | Resources 此类用于允许多个资源声明。

javax.annotation.processing 中 Annotation 的使用

实现 Annotation 的 javax.annotation.processing 中的类
interface | SupportedAnnotationTypes 用来指示注释处理器支持哪些注释类型的注释。
interface | SupportedOptions 用来指示注释处理器支持哪些选项的注释。
interface | SupportedSourceVersion 用来指示注释处理器所支持的最新源版本的注释。

类型变量类型为 Annotation 的 javax.annotation.processing 中的方法参数
 Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a)
返回使用给定注释类型注释的元素。

javax.jws 中 Annotation 的使用

实现 Annotation 的 javax.jws 中的类
interface | HandlerChain 将 Web Service 与外部定义的处理程序链关联。
interface | Oneway 指示给定 @WebMethod 只有一条输入消息并且没有输出。
interface | WebMethod 定制一个公开为 Web Service 操作的方法。
interface | WebParam 定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
interface | WebResult 定制返回值到 WSDL 部分和 XML 元素的映射关系。
interface | WebService 将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

javax.jws.soap 中 Annotation 的使用

实现 Annotation 的 javax.jws.soap 中的类
interface | InitParam 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPBinding 指定 Web Service 到 SOAP 消息协议的映射关系。
interface | SOAPMessageHandler 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.lang.model.element 中 Annotation 的使用

类型参数类型为 Annotation 的 javax.lang.model.element 中的方法
<A extends Annotation>
A
Element.getAnnotation(Class<A> annotationType)
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。

javax.management 中 Annotation 的使用

实现 Annotation 的 javax.management 中的类
interface | DescriptorKey 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
interface | MXBean 显式地标记某一接口是否为 MXBean 接口的注释。

javax.xml.bind.annotation 中 Annotation 的使用

实现 Annotation 的 javax.xml.bind.annotation 中的类
interface | XmlAccessorOrder 控制类中字段和属性的排序。
interface | XmlAccessorType 控制默认情况下是否对字段或 Javabean 属性进行系列化。
interface | XmlAnyAttribute 将 JavaBean 属性映射到通配符属性的映射表中。
interface | XmlAnyElement 将 JavaBean 属性映射到 XML 信息集表示形式和/或 JAXB 元素。
interface | XmlAttachmentRef 标记字段/属性，其 XML 形式是对 MIME 内容的 URI 引用。
interface | XmlAttribute 将 JavaBean 属性映射到 XML 属性。
interface | XmlElement 将 JavaBean 属性映射到派生于属性名称的 XML 元素。
interface | XmlElementDecl 将工厂方法映射到 XML 元素。
interface | XmlElementRef 将 JavaBean 属性映射到派生于属性类型的 XML 元素。
interface | XmlElementRefs 标记一个属性，该属性引用带有 XmlElement 或 JAXBElement 的类。
interface | XmlElements 多个 @XmlElement 注释的容器。
interface | XmlElementWrapper 生成一个包装 XML 表示形式的包装器元素。
interface | XmlEnum 将枚举类型 Enum 映射到 XML 表示形式。
interface | XmlEnumValue 将 Enum 类型中的枚举常量映射到 XML 表示形式。
interface | XmlID 将 JavaBean 属性映射到 XML ID。
interface | XmlIDREF 将 JavaBean 属性映射到 XML IDREF。
interface | XmlInlineBinaryData 禁止对绑定到 XML 中 base64-encoded 二进制数据的数据类型进行 XOP 编码。
interface | XmlList 用来将属性映射到列表简单类型。
interface | XmlMimeType 关联控制属性 XML 表示形式的 MIME 类型。
interface | XmlMixed 注释 JavaBean 多值属性，以支持混合内容。
interface | XmlNs 关联名称空间前缀与 XML 名称空间 URI。
interface | XmlRegistry 标记具有 XmlElementDecl 的类。
interface | XmlRootElement 将类或枚举类型映射到 XML 元素。
interface | XmlSchema 将包名称映射到 XML 名称空间。
interface | XmlSchemaType 将 Java 类型映射到一个简单的模式内置类型。
interface | XmlSchemaTypes 多个 @XmlSchemaType 注释的容器。
interface | XmlTransient 阻止将 JavaBean 属性映射到 XML 表示形式。
interface | XmlType 将类或枚举类型映射到 XML 模式类型。
interface | XmlValue 支持将类映射到带有 simpleContent 的 XML 模式复杂类型或 XML 模式简单类型。

javax.xml.bind.annotation.adapters 中 Annotation 的使用

实现 Annotation 的 javax.xml.bind.annotation.adapters 中的类
interface | XmlJavaTypeAdapter 对自定义编组使用实现 XmlAdapter 的适配器。
interface | XmlJavaTypeAdapters 多个 @XmlJavaTypeAdapter 注释的容器。

javax.xml.ws 中 Annotation 的使用

实现 Annotation 的 javax.xml.ws 中的类
interface | BindingType BindingType 注释用于指定 Web 服务端点实现类所使用的绑定。
interface | RequestWrapper 此类通过将在运行时使用的请求包装器 bean 注释服务端点接口中的方法。
interface | ResponseWrapper 此类通过将在运行时使用的响应包装器 bean 注释服务端点接口中的方法。
interface | ServiceMode 用于指示 Provider 实现是希望使用整个协议消息还是只使用协议消息负载。
interface | WebEndpoint 此类用来注释所生成服务接口的 getPortName() 方法。
interface | WebFault 此类用来注释特定于服务的异常类，以自定义故障元素的本地名称和名称空间名称以及故障 bean 的名称。
interface | WebServiceClient 此类用来注释生成的服务接口。
interface | WebServiceProvider 此类用来注释 Provider 实现类。
interface | WebServiceRef WebServiceRef 注释用于定义 Web 服务及其（可选）注入目标的引用。
interface | WebServiceRefs WebServiceRefs 注释允许在类级别声明多个 web 服务引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ClassDefinition (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.instrument
类 ClassDefinition

java.lang.Object
    继承者  java.lang.instrument.ClassDefinition

public final class ClassDefinition
extends Object

此类用作 Instrumentation.redefineClasses 方法的参数锁定。用于绑定需要与新的类文件字节一起重定义的 Class。

从以下版本开始：
1.5
另请参见：
Instrumentation.redefineClasses(java.lang.instrument.ClassDefinition...)

构造方法摘要
ClassDefinition(Class<?> theClass, byte[] theClassFile)
使用提供的类和类文件字节创建一个新的 ClassDefinition 绑定。
方法摘要
Class<?> | getDefinitionClass() 返回该类。
byte[] | getDefinitionClassFile() 返回包含新的类文件的 byte 数组。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassDefinition

public ClassDefinition(Class<?> theClass,
                       byte[] theClassFile)
使用提供的类和类文件字节创建一个新的 ClassDefinition 绑定。不复制提供的缓冲区，仅捕获对它的引用。

参数：
theClass - 需要重定义的 Class
theClassFile - 新的类文件字节
抛出：
NullPointerException - 如果提供的类或数组为 null。
方法详细信息

getDefinitionClass

public Class<?> getDefinitionClass()
返回该类。

返回：
引用的 Class 对象。

getDefinitionClassFile

public byte[] getDefinitionClassFile()
返回包含新的类文件的 byte 数组。

返回：
类文件字节。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ClassFileTransformer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.instrument
接口 ClassFileTransformer

public interface ClassFileTransformer

一个提供此接口的实现以转换类文件的代理。转换在 JVM 定义类之前发生。

注意，根据 The Java Virtual Machine Specification 的 The class File Format 一章中的定义使用术语类文件，它指以类文件格式表示的字节序列，无论这些字符是否驻留在文件中。

从以下版本开始：
1.5
另请参见：
Instrumentation, Instrumentation.addTransformer(java.lang.instrument.ClassFileTransformer, boolean), Instrumentation.removeTransformer(java.lang.instrument.ClassFileTransformer)

方法摘要
 byte[] transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

方法详细信息

transform

byte[] transform(ClassLoader loader,
                 String className,
                 Class<?> classBeingRedefined,
                 ProtectionDomain protectionDomain,
                 byte[] classfileBuffer)
                 throws IllegalClassFormatException
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

有两种装换器，由 Instrumentation.addTransformer(ClassFileTransformer,boolean) 的 canRetransform 参数确定：

  • 可重转换 转换器，将 canRetransform 设为 true 可添加这种转换器
  • 不可重转换 转换器，将 canRetransform 设为 false 或者使用 Instrumentation.addTransformer(ClassFileTransformer) 可添加这种转换器

在转换器使用 addTransformer 注册之后，每次定义新类和重定义类时都将调用该转换器。每次重转换类时还将调用可重转换转换器。对新类定义的请求通过 ClassLoader.defineClass 或其本机等价方法进行。对类重定义的请求通过 Instrumentation.redefineClasses 或其本机等价方法进行。对类重转换的请求将通过 Instrumentation.retransformClasses 或其本机等价方法进行。转换器是在验证或应用类文件字节之前的请求处理过程中调用的。 当存在多个转换器时，转换将由 transform 调用链组成。 也就是说，一个 transform 调用返回的 byte 数组将成为下一个调用的输入（通过 classfileBuffer 参数）。

转换将按以下顺序应用：

  • 不可重转换转换器
  • 不可重转换本机转换器
  • 可重转换转换器
  • 可重转换本机转换器

对于重转换，不会调用不可重转换转换器，而是重用前一个转换的结果。对于所有其他情况，调用此方法。在每个这种调用组中，转换器将按照注册的顺序调用。本机转换器由 Java 虚拟机 Tool 接口中的 ClassFileLoadHook 事件提供。

第一个转换器的输入（通过 classfileBuffer 参数）如下：

  • 对于新的类定义，是传递给 ClassLoader.defineClass 的 byte
  • 对于类重定义，是 definitions.getDefinitionClassFile()，其中 definitions 是 Instrumentation.redefineClasses 的参数
  • 对于类重转换，是传递给新类定义的 byte，或者是最后一个重定义（如果有重定义），所有不可转换转换器进行的转换都将自动重新应用并保持不变；有关细节，请参阅 Instrumentation.retransformClasses

如果实现方法确定不需要进行转换，则应返回 null。否则，它将创建一个新的 byte[] 数组，将输入 classfileBuffer 连同所有需要的转换复制到其中，并返回这个新数组。不得修改输入 classfileBuffer。

在重转换和重定义中，转换器必须支持重定义语义：如果转换器在初始定义期间更改的类在以后要重转换或重定义，那么转换器必须确保第二个输出类文件是第一个输出类文件的合法重定义文件。

如果转换器抛出异常（未捕获的异常），后续转换器仍然将被调用并加载，仍然将尝试重定义或重转换。因此，抛出异常与返回 null 的效果相同。若要使用转换器代码在生成未检验异常时防止不希望发生的行为，可以让转换器捕获 Throwable。 如果转换器认为 classFileBuffer 不表示一个有效格式的类文件，则将抛出 IllegalClassFormatException；尽管这与返回 null 的效果相同，但它便于对格式毁坏进行记录或调试。

参数：
loader - 定义要转换的类加载器；如果是引导加载器，则为 null
className - 完全限定类内部形式的类名称和 The Java Virtual Machine Specification 中定义的接口名称。例如，"java/util/List"。
classBeingRedefined - 如果是被重定义或重转换触发，则为重定义或重转换的类；如果是类加载，则为 null
protectionDomain - 要定义或重定义的类的保护域
classfileBuffer - 类文件格式的输入字节缓冲区（不得修改）
返回：
一个格式良好的类文件缓冲区（转换的结果），如果未执行转换,则返回 null。
抛出：
IllegalClassFormatException - 如果输入不表示一个格式良好的类文件
另请参见：
Instrumentation.redefineClasses(java.lang.instrument.ClassDefinition...)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalClassFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.instrument
类 IllegalClassFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.instrument.IllegalClassFormatException
所有已实现的接口：
Serializable
public class IllegalClassFormatException
extends Exception

当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。抛出此异常的原因或者由于初始类文件字节无效，或者由于以前应用的转换损坏了字节。

从以下版本开始：
JDK1.5
另请参见：
ClassFileTransformer.transform(java.lang.ClassLoader, java.lang.String, java.lang.Class, java.security.ProtectionDomain, byte[]), 序列化表格

构造方法摘要
IllegalClassFormatException()
构造不带详细消息的 IllegalClassFormatException。
IllegalClassFormatException(String s)
构造具有指定详细消息的 IllegalClassFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalClassFormatException

public IllegalClassFormatException()
构造不带详细消息的 IllegalClassFormatException。

IllegalClassFormatException

public IllegalClassFormatException(String s)
构造具有指定详细消息的 IllegalClassFormatException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Instrumentation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.instrument
接口 Instrumentation

public interface Instrumentation

此类提供检测 Java 编程语言代码所需的服务。检测是向方法中添加字节码，以搜集各种工具所使用的数据。由于更改完全是进行添加，所以这些工具不修改应用程序的状态或行为。这种无害工具的例子包括镜像代理、分析器、覆盖分析器和事件记录器。

获取 Instrumentation 接口的实例有两种方式：

  1. 当 JVM 以指示一个代理类的方式启动时，将传递给代理类的 premain 方法一个 Instrumentation 实例。

  2. 当 JVM 提供某种机制在 JVM 启动之后某一时刻启动代理时，将传递给代理代码的 agentmain 方法一个 Instrumentation 实例。

这些机制在包规范中描述。

如果某个代理获得了 Instrumentation 实例，它便可以在任何时候调用该实例上的方法。

从以下版本开始：
1.5

方法摘要
void | addTransformer(ClassFileTransformer transformer) 注册提供的转换器。
void | addTransformer(ClassFileTransformer transformer, boolean canRetransform) 注册提供的转换器。
void | appendToBootstrapClassLoaderSearch(JarFile jarfile) 指定 JAR 文件，检测类由引导类加载器定义。
void | appendToSystemClassLoaderSearch(JarFile jarfile) 指定 JAR 文件，检测类由系统类加载器定义。
Class[] | getAllLoadedClasses() 返回 JVM 当前加载的所有类的数组。
Class[] | getInitiatedClasses(ClassLoader loader) 返回所有初始化加载器是 loader 的类的数组。
long | getObjectSize(Object objectToSize) 返回指定对象使用的特定于实现的近似存储量。
boolean | isModifiableClass(Class<?> theClass) 确定一个类是否可以被 retransformation 或 redefinition 修改。
boolean | isNativeMethodPrefixSupported() 返回当前 JVM 配置是否支持设置本机方法前缀。
boolean | isRedefineClassesSupported() 返回当前 JVM 配置是否支持类的重定义。
boolean | isRetransformClassesSupported() 返回当前 JVM 配置是否支持类的重转换。
void | redefineClasses(ClassDefinition... definitions) 使用提供的类文件重定义提供的类集。
boolean | removeTransformer(ClassFileTransformer transformer) 注销提供的转换器。
void | retransformClasses(Class<?>... classes) 重转换提供的类集。
void | setNativeMethodPrefix(ClassFileTransformer transformer, String prefix) 通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。

方法详细信息

addTransformer

void addTransformer(ClassFileTransformer transformer,
                    boolean canRetransform)
注册提供的转换器。所有以后的类定义对于该转换器都是可见的，任何已注册转换器所依赖的类定义除外。 加载类、重定义类时将调用该转换器。如果 canRetransform 为 true，那么重转换类时也将调用该转换器。 有关转换调用的顺序，请参见 ClassFileTransformer.transform。 如果转换器在执行过程中抛出异常，JVM 将仍然按顺序调用其他已注册转换器。可以多次添加相同的转换器，但建议最好创建一个新的转换器类实例来避免这样做。

此方法旨在用于检测，正如类规范所述。

参数：
transformer - 要注册的转换器
canRetransform - 此转换器的转换是否可以重转换
抛出：
NullPointerException - 如果传递了 null 转换器
UnsupportedOperationException - 如果 canRetransform 为 true 但当前 JVM 的配置不允许重转换（isRetransformClassesSupported() 为 false）。
从以下版本开始：
1.6

addTransformer

void addTransformer(ClassFileTransformer transformer)
注册提供的转换器。

与 addTransformer(transformer, false) 相同。

参数：
transformer - 要注册的转换器
抛出：
NullPointerException - 如果传递了一个 null 转换器
另请参见：
addTransformer(ClassFileTransformer,boolean)

removeTransformer

boolean removeTransformer(ClassFileTransformer transformer)
注销提供的转换器。以后的类定义将不再向该转换器显示。移除最新添加的转换器的匹配实例。由于类加载的多线程特性，在调用被移除后，转换器还可能接收调用。所以编写转换器时应防止出现这种情况。

参数：
transformer - 要注销的转换器
返回：
如果找到并移除转换器，则返回 true；如果找不到转换器，则返回 false
抛出：
NullPointerException - 如果传递了一个 null 转换器

isRetransformClassesSupported

boolean isRetransformClassesSupported()
返回当前 JVM 配置是否支持类的重转换。 转换已加载类是 JVM 的一个可选性能。 仅当 Can-Retransform-Classes 清单属性在代理 JAR 文件中设置为 true（如包规范所述），且 JVM 支持此性能时，才支持重转换。 在单个 JVM 的单个实例化过程中，多次调用此方法将总是返回相同的答案。

返回：
如果当前 JVM 配置支持类的重转换，则返回 true；如果不支持，则返回 false。
从以下版本开始：
1.6
另请参见：
retransformClasses(java.lang.Class...)

retransformClasses

void retransformClasses(Class<?>... classes)
                        throws UnmodifiableClassException
重转换提供的类集。

此函数为检测已加载类提供了方便。 当最初加载了类或重定义了类时，初始类文件字节可以使用 ClassFileTransformer 转换。 此函数返回转换进程（以前是否发生过转换）。 此转换按以下步骤进行：

  • 从初始类文件字节开始
  • 对于每个添加时 canRetransform 设为 false 的转换器，上一次类加载或重定义期间 transform 返回的字节将被重新用于转换的输出；注意，这等价于不做更改地重新应用前一个转换；没有调用 transform 的情况除外。
  • 对于每个添加时 canRetransform 设为 true 的转换器，在这些转换器中调用 transform 方法
  • 转换的类文件字节将作为类的新定义安装

转换的顺序在 transform 方法中描述。在自动重新应用不可重转换的转换时，也将使用这一顺序。

最初的类文件字节表示（应用转换前）传递给 ClassLoader.defineClass 或 redefineClasses 的字节，但有可能不完全匹配。常量池的布局或内容可能不同。常量池的条目可能多一些或少一些。常量池条目的顺序可能不同，但是，方法字节码中常量池的索引将是对应的。一些属性可能不存在。在顺序没有意义的地方（例如，方法的顺序），可能不保留顺序。

此方法在一个集合上操作，以便允许同时对多个类进行相互依赖的更改（重转换类 A 要求重转换类 B）。

如果重转换的方法有活动的堆栈帧，那么这些活动的帧将继续运行原方法的字节码。重转换的方法将用于新的调用。

此方法不会引起任何初始化操作，JVM 惯例语义下发生的初始化除外。换句话说，重定义一个类不会引起其初始化方法的运行。静态变量的值将与调用之前的值一样。

重转换类的实例不受影响。

重转换可能会更改方法体、常量池和属性。重转换不得添加、移除、重命名字段或方法；不得更改方法签名、继承关系。在以后的版本中，可能会取消这些限制。在应用转换之前，类文件字节不会被检查、验证和安装。如果结果字节错误，此方法将抛出异常。

如果此方法抛出异常，则不会重转换任何类。

此方法旨在用于检测，正如类规范所述。

参数：
classes - 要转换的类数组； 允许长度为 0 数组，在这种情况下，此方法不执行任何操作
抛出：
UnmodifiableClassException - 如果不能修改指定的类（isModifiableClass(java.lang.Class) 返回 false）
UnsupportedOperationException - 如果 JVM 的当前配置不允许重转换（isRetransformClassesSupported() 为 false），或者重转换试图做出不受支持的更改
ClassFormatError - 如果数据不包含有效的类
NoClassDefFoundError - 如果类文件中的名称不等于类的名称
UnsupportedClassVersionError - 如果类文件版本号不受支持
ClassCircularityError - 如果新类包含循环
LinkageError - 如果发生链接错误
NullPointerException - 如果提供的类数组或其任意组件为 null。
从以下版本开始：
1.6
另请参见：
isRetransformClassesSupported(), addTransformer(java.lang.instrument.ClassFileTransformer, boolean), ClassFileTransformer

isRedefineClassesSupported

boolean isRedefineClassesSupported()
返回当前 JVM 配置是否支持类的重定义。重定义已加载类是 JVM 的一个可选性能。 仅当 Can-Retransform-Classes 清单属性在代理 JAR 文件中设置为 true（如包规范所述），且 JVM 支持此性能时，才支持重转换。 在执行单个 JVM 的单实例化过程中，对此方法的多次调用将始终返回同一应答。

返回：
如果当前 JVM 配置支持类的重定义，则为 true，否则为 false。
另请参见：
redefineClasses(java.lang.instrument.ClassDefinition...)

redefineClasses

void redefineClasses(ClassDefinition... definitions)
                     throws ClassNotFoundException,
                            UnmodifiableClassException
使用提供的类文件重定义提供的类集。

此方法用于替代类的定义，而不引用现有的类文件字节，这与 fix-and-continue 调试过程中重新编译源代码时所做的一样。需要转换现有类文件字节的地方（例如，字节码检测中）应该使用 retransformClasses。

此方法在一个集合上操作，以便允许同时对多个类进行相互依赖的更改（重定义类 A 要求重定义类 B）。

如果重定义的方法有活动的堆栈帧，那么这些活动的帧将继续运行原方法的字节码。将在新的调用上使用此重定义的方法。

此方法不会引起任何初始化操作，JVM 惯例语义下发生的初始化除外。换句话说，重定义一个类不会引起其初始化方法的运行。静态变量的值将与调用之前的值一样。

重定义类的实例不受影响。

重定义可能会更改方法体、常量池和属性。重定义不得添加、移除、重命名字段或方法；不得更改方法签名、继承关系。在以后的版本中，可能会取消这些限制。在应用转换之前，类文件字节不会被检查、验证和安装。如果结果字节错误，此方法将抛出异常。

如果此方法抛出异常，则不会重定义任何类。

此方法旨在用于检测，正如类规范所述。

参数：
definitions - 要使用相应定义来进行重定义的类数组；允许长度为 0 数组，在这种情况下，此方法不执行任何操作
抛出：
UnmodifiableClassException - 如果无法修改指定的类（isModifiableClass(java.lang.Class) 返回 false）
UnsupportedOperationException - 如果 JVM 的当前配置不允许重定义（isRedefineClassesSupported() 为 false）或重定义试图做出不受支持的更改
ClassFormatError - 如果数据不包含有效类
NoClassDefFoundError - 如果类文件中的名称与类名称不相等
UnsupportedClassVersionError - 如果类文件版本号不受支持
ClassCircularityError - 如果新类包含循环
LinkageError - 如果发生链接错误
NullPointerException - 如果提供的定义数组或其任何组件为 null。
ClassNotFoundException - 不会抛出（存在只是为了兼容）
另请参见：
isRedefineClassesSupported(), addTransformer(java.lang.instrument.ClassFileTransformer, boolean), ClassFileTransformer

isModifiableClass

boolean isModifiableClass(Class<?> theClass)
确定一个类是否可以被 retransformation 或 redefinition 修改。 如果类可以被修改，那么此方法返回 true。 如果类不能被修改，那么此方法返回 false。

对于要重转换的类，isRetransformClassesSupported() 也必须为 true。但 isRetransformClassesSupported() 的值不影响此函数返回的值。 对于要重定义的类，isRedefineClassesSupported() 也必须为 true。但 isRedefineClassesSupported() 的值不影响此函数返回的值。

基本类（例如 java.lang.Integer.TYPE）和数组类不可修改。

抛出：
NullPointerException - 如果指定的类为 null。
从以下版本开始：
1.6
另请参见：
retransformClasses(java.lang.Class...),
isRetransformClassesSupported(),
redefineClasses(java.lang.instrument.ClassDefinition...),
isRedefineClassesSupported()

getAllLoadedClasses

Class[] getAllLoadedClasses()
返回 JVM 当前加载的所有类的数组。

返回：
包含 JVM 加载的所有类的数组；如果没有，则返回长度为 0 数组

getInitiatedClasses

Class[] getInitiatedClasses(ClassLoader loader)
返回所有初始化加载器是 loader 的类的数组。如果提供的加载器为 null，则返回由引导类加载器初始化的类。

参数：
loader - 将返回其初始化类列表的加载器
返回：
包含初始化加载器是 loader 的类的数组；如果没有，则返回长度为 0 数组

getObjectSize

long getObjectSize(Object objectToSize)
返回指定对象使用的特定于实现的近似存储量。该结果可能包括对象的部分或全部开销，因此，在一个实现中进行比较时较为有用，但不能用于实现之间的比较。 该估计值在 JVM 的单个调用期间可能发生变化。

参数：
objectToSize - 需要确定大小的对象
返回：
指定对象使用的特定于实现的近似存储量
抛出：
NullPointerException - 如果提供的 Object 为 null。

appendToBootstrapClassLoaderSearch

void appendToBootstrapClassLoaderSearch(JarFile jarfile)
指定 JAR 文件，检测类由引导类加载器定义。

当虚拟机的内置类加载器（称为“引导类加载器”）未能成功搜索到类时，JAR 文件中的条目也将被搜索。

可以多次使用此方法，按照调用此方法的顺序添加多个要搜索的 JAR 文件。

除了需要引导类加载器为检测而定义的类或资源外，代理应该注意确保 JAR 不包含任何其他类或资源。 违反此规定将导致难以诊断的不可预料行为。例如，假设有加载器 L，L 的代理父加载器为引导类加载器。 此外，有一个类 C 的方法，有一个 L 定义的类，引用了非公共存取类 C$1。如果 JAR 文件包含类 C$1，那么引导类加载器的代理将导致 C$1 被引导类加载器定义。此例中将抛出 IllegalAccessError，这可能导致应用程序失败。一个避免这类问题的办法是，对检测类使用唯一的包名称。

Java 虚拟机规范规定，后续尝试解析 Java 虚拟机以前未能成功解析的符号引用将总是失败，并抛出与最初解析尝试失败时相同的错误。因此，如果 JAR 文件包含的某个条目对应于 Java 虚拟机未能成功解析引用的类，那么后续尝试解析该引用将总是失败，并抛出与最初解析尝试失败时相同的错误。

参数：
jarfile - 当引导类加载器未成功搜索到类时要搜索的 JAR 文件。
抛出：
NullPointerException - 如果 jarfile 为 null。
从以下版本开始：
1.6
另请参见：
appendToSystemClassLoaderSearch(java.util.jar.JarFile), ClassLoader, JarFile

appendToSystemClassLoaderSearch

void appendToSystemClassLoaderSearch(JarFile jarfile)
指定 JAR 文件，检测类由系统类加载器定义。 当代理的系统类加载器（参见 getSystemClassLoader()）未能成功搜索到类时，JarFile 中的条目也将被搜索。

可以多次使用此方法，按照调用此方法的顺序添加多个要搜索的 JAR 文件。

除了需要系统类加载器为检测而定义的类或资源外，代理应该注意确保 JAR 不包含任何其他类或资源。 违反此规定将导致难以诊断的不可预料行为。（参见 appendToBootstrapClassLoaderSearch）。

如果实现了名为 appendToClassPathForInstrumentation 的方法（带有一个类型为 java.lang.String 的参数），那么系统类加载器支持添加要搜索的 JAR 文件。不要求该方法具有 public 访问权。JAR 文件名可以通过对 jarfile 调用 getName() 方法获取，并将作为参数提供给 appendtoClassPathForInstrumentation 方法。

Java 虚拟机规范规定，后续尝试解析 Java 虚拟机以前未能成功解析的符号引用将总是失败，并抛出与最初解析尝试失败时相同的错误。因此，如果 JAR 文件包含的某个条目对应于 Java 虚拟机未能成功解析引用的类，那么后续尝试解析该引用将总是失败，并抛出与最初解析尝试失败时相同的错误。

此方法不更改 java.class.path 系统属性的值。

参数：
jarfile - 当系统类加载器未成功搜索到类时要搜索的 JAR 文件。
抛出：
UnsupportedOperationException - 如果系统类加载器不支持添加要搜索的 JAR 文件。
NullPointerException - 如果 jarfile 为 null。
从以下版本开始：
1.6
另请参见：
appendToBootstrapClassLoaderSearch(java.util.jar.JarFile), ClassLoader.getSystemClassLoader(), JarFile

isNativeMethodPrefixSupported

boolean isNativeMethodPrefixSupported()
返回当前 JVM 配置是否支持设置本机方法前缀。 设置本机方法前缀是 JVM 的一个可选性能。 仅当 Can-Set-Native-Method-Prefix 清单属性在代理 JAR 文件中设置为 true（如包规范所述），且 JVM 支持此性能时，才支持设置本机方法前缀。 在单个 JVM 的单个实例化过程中，多次调用此方法将总是返回相同的应答。

返回：
如果当前 JVM 配置支持设置本机方法前缀，则返回 true；否则返回 false。
从以下版本开始：
1.6
另请参见：
setNativeMethodPrefix(java.lang.instrument.ClassFileTransformer, java.lang.String)

setNativeMethodPrefix

void setNativeMethodPrefix(ClassFileTransformer transformer,
                           String prefix)
通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。 当与 ClassFileTransformer 一起使用时，它允许检测本机方法。

由于本机方法不能直接检测（它们没有字节码），因此必须使用可以检测的非本机方法包装它们。例如，如果有：

   native boolean foo(int x);

那么可以转换类文件（在类的初始定义过程中使用 ClassFileTransformer），使之变成：

   boolean foo(int x) {
     ... record entry to foo ...
     return wrapped_foo(x);
   }

   native boolean wrapped_foo(int x);

其中 foo 变为实际本机方法的包装器，并带有附加前缀 "wrapped_"。注意，将 "wrapped_" 作为前缀并不合适，因为它很有可能与现有方法重名，因此 "$$$MyAgentWrapped$$$_" 之类更加合适，但那将减少这些示例的可读性。

包装器将允许在本机方法调用上收集数据，但现在的问题在于如何连接包装的方法与本机实现。 也就是说，方法 wrapped_foo 需要被解析为 foo 的本机实现，即：

   Java_somePackage_someClass_foo(JNIEnv* env, jint x)

此函数允许指定前缀并进行恰当的解析。 明确地说，当标准解析失败时，解析将重新尝试考虑前缀。进行解析有两种方式，使用 JNI 函数 RegisterNatives 的显式解析和常规自动解析。对于 RegisterNatives，JVM 将尝试以下关联：

   method(foo) -> nativeImplementation(foo)

若此操作失败，解析将重试，将指定的前缀添加到方法名，生成校正解析：

   method(wrapped_foo) -> nativeImplementation(foo)

对于自动解析，JVM 将尝试：

   method(wrapped_foo) -> nativeImplementation(wrapped_foo)

若此操作失败，解析将重试，从实现名删除指定的前缀，生成校正解析：

   method(wrapped_foo) -> nativeImplementation(foo)

注意，前缀只在标准解析失败时使用，因此可以有选择地包装本机方法。

每个 ClassFileTransformer 可以执行其本身的字节代码转换，因此可能要应用多个包装器层。所以每个转换器需要其自己的前缀。转换是按顺序应用的，因此前缀（如果应用）也将按相同的顺序应用（参见 addTransformer）。 所以，如果三个转换器应用了包装器，foo 将变为 $trans3_$trans2_$trans1_foo。但是，如果第二个转换器没有对 foo 应用包装器，那么它将是 $trans3_$trans1_foo。要有效的确定前缀序列，仅当其非本机包装器存在时才应用中间前缀。因此，在最后一个示例中，即使 $trans1_foo 不是本机方法，$trans1_ 前缀也将应用，因为 $trans1_foo 存在。

参数：
transformer - 使用此前缀包装的 ClassFileTransformer。
prefix - 已应用到包装的本机方法的前缀。
抛出：
NullPointerException - 如果传入 null 转换器。
UnsupportedOperationException - 如果 JVM 的当前配置不允许设置本机方法前缀（isNativeMethodPrefixSupported() 为 false）。
IllegalArgumentException - 如果转换器没有注册（参见 addTransformer）。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnmodifiableClassException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.instrument
类 UnmodifiableClassException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.instrument.UnmodifiableClassException
所有已实现的接口：
Serializable
public class UnmodifiableClassException
extends Exception

在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

从以下版本开始：
1.5
另请参见：
Instrumentation.redefineClasses(java.lang.instrument.ClassDefinition...), 序列化表格

构造方法摘要
UnmodifiableClassException()
构造不带详细消息的 UnmodifiableClassException。
UnmodifiableClassException(String s)
构造具有指定详细消息的 UnmodifiableClassException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnmodifiableClassException

public UnmodifiableClassException()
构造不带详细消息的 UnmodifiableClassException。

UnmodifiableClassException

public UnmodifiableClassException(String s)
构造具有指定详细消息的 UnmodifiableClassException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.lang.instrument (Java 2 Platform SE 6)

 java.lang.instrument
接口
ClassFileTransformer
Instrumentation
类
ClassDefinition
异常
IllegalClassFormatException
UnmodifiableClassException


java.lang.instrument (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.lang.instrument

提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

请参见：
描述

接口摘要
ClassFileTransformer | 一个提供此接口的实现以转换类文件的代理。
Instrumentation | 此类提供检测 Java 编程语言代码所需的服务。

类摘要
ClassDefinition 此类用作 Instrumentation.redefineClasses 方法的参数锁定。

异常摘要
IllegalClassFormatException | 当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
UnmodifiableClassException | 在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

软件包 java.lang.instrument 的描述

提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。检测机制是对方法的字节码进行修改。

包规范

代理被部署为 JAR 文件。JAR 文件清单中的属性指定将被加载以启动代理的代理类。对于支持命令行接口的实现，可以在命令行指定一个选项来启动代理。实现也支持在 VM 启动后某一时刻启动代理的机制。例如，实现可以提供一种机制，允许某种工具连接 到运行的应用程序，并将该工具代理的加载初启到该应用程序中。如何初启加载的细节与实现有关。

命令行接口

对于使用命令行接口的实现，可以将以下选项添加到命令行来启动代理：

-javaagent:jarpath[=options]
jarpath 是代理 JAR 文件的路径。 options 是代理选项。 此开关可以在同一代码行使用多次，从而创建多个代理。 多个代理可以使用相同的 jarpath。 代理 JAR 文件必须遵守 JAR 文件规范。

代理 JAR 文件的清单必须包含 Premain-Class 属性。此属性的值是代理类 的名称。代理类必须实现公共静态 premain 方法，该方法的原理与 main 应用程序入口点类似。在 Java 虚拟机 (JVM) 初始化后，每个 premain 方法将按照指定代理的顺序调用，然后将调用实际的应用程序 main 方法。每个 premain 方法必须按照依次进行的启动顺序返回。

premain 方法有两种可能的签名。JVM 首先尝试在代理类上调用以下方法：

public static void premain(String agentArgs, Instrumentation inst);

如果代理类没有实现此方法，那么 JVM 将尝试调用：

public static void premain(String agentArgs);

如果代理在 VM 启动之后启动，那么代理类还有一个要使用的 agentmain 方法。如果是使用命令行选项启动代理，那么 agentmain 方法将不会被调用。

代理类将被系统类加载器加载（参见 ClassLoader.getSystemClassLoader）。系统类加载器是通常加载包含应用程序 main 方法的类的类加载器。 premain 方法将在与应用程序 main 方法相同的安全性和类加载器规则下运行。不存在代理 premain 方法可以执行的建模限制。任何应用程序 main 可以执行的事情（包括创建线程）对于 premain 都是合法的。

每个代理通过 agentArgs 参数传递其代理选项。代理选项作为单个字符串传递，任何其他解析应由代理本身执行。

如果该代理不能被解析（例如，由于无法加载代理类，或者代理类没有恰当的 premain 方法），那么 JVM 将中止。如果 premain 方法抛出未捕获的异常，那么 JVM 将中止。

VM 启动后启动代理

实现可以提供一种机制在 VM 启动之后某一时刻启动代理。如何初启的细节是特定于实现的，但通常应用程序已经启动并且其 main 方法已经调用。如果实现支持在 VM 启动之后启动代理，则以下内容适用：

  1. 代理 JAR 的清单必须包含属性 Agent-Class。此属性的值是代理类 的名称。

  2. 代理类必须实现公共静态 agentmain 方法。

  3. 系统类加载器（ClassLoader.getSystemClassLoader）必须支持将代理 JAR 文件添加到系统类路径的机制。

代理 JAR 将被添加到系统类路径。系统类路径是通常加载包含应用程序 main 方法的类的类路径。代理类将被加载，JVM 尝试调用 agentmain 方法。JVM 首先尝试对代理类调用以下方法：

public static void agentmain(String agentArgs, Instrumentation inst);

如果代理类没有实现此方法，那么 JVM 将尝试调用：

public static void agentmain(String agentArgs);

如果代理是使用命令行选项启动的，那么代理类还有一个要使用的 agentmain 方法。如果是在 VM 启动之后启动代理，那么 agentmain 方法将不会被调用。

代理通过 agentArgs 参数传递其代理选项。代理选项作为单个字符串传递，任何其它解析应该由代理本身执行。

agentmain 方法应该执行任何启动代理所需的初始化。启动完成时该方法应返回。如果代理无法启动（例如，由于无法加载代理类，或者代理类没有构造 agentmain 方法），那么 JVM 将中止。如果 agentmain 方法抛出未捕获的异常，那么它将被忽略。

清单属性

以下清单属性是针对代理 JAR 文件定义的：
Premain-Class
如果 JVM 启动时指定了代理，那么此属性指定代理类，即包含 premain 方法的类。如果 JVM 启动时指定了代理，那么此属性是必需的。如果该属性不存在，那么 JVM 将中止。注：此属性是类名，不是文件名或路径。
Agent-Class
如果实现支持 VM 启动之后某一时刻启动代理的机制，那么此属性指定代理类。 即包含 agentmain 方法的类。 此属性是必需的，如果不存在，代理将无法启动。 注：这是类名，而不是文件名或路径。
Boot-Class-Path
由引导类加载器搜索的路径列表。路径表示目录或库（在许多平台上通常作为 JAR 或 zip 库被引用）。查找类的特定于平台的机制失败后，引导类加载器会搜索这些路径。按列出的顺序搜索路径。列表中的路径由一个或多个空格分开。路径使用分层 URI 的路径组件语法。如果该路径以斜杠字符（“/”）开头，则为绝对路径，否则为相对路径。相对路径根据代理 JAR 文件的绝对路径解析。忽略格式不正确的路径和不存在的路径。如果代理是在 VM 启动之后某一时刻启动的，则忽略不表示 JAR 文件的路径。此属性是可选的。
Can-Redefine-Classes
布尔值（true 或 false，与大小写无关）。是否能重定义此代理所需的类。true 以外的值均被视为 false。此属性是可选的，默认值为 false。
Can-Retransform-Classes
布尔值（true 或 false，与大小写无关）。是否能重转换此代理所需的类。true 以外的值均被视为 false。此属性是可选的，默认值为 false。
Can-Set-Native-Method-Prefix
布尔值（true 或 false，与大小写无关）。是否能设置此代理所需的本机方法前缀。true 以外的值均被视为 false。此属性是可选的，默认值为 false。

代理 JAR 文件在清单中可以同时出现 Premain-Class 和 Agent-Class 属性。如果代理是使用 -javaagent 选项在命令行上启动的，那么 Premain-Class 属性指定代理类的名称，Agent-Class 属性将被忽略。类似地，如果代理是在 VM 启动后某一时刻启动的，那么 Agent-Class 属性指定代理类的名称（Premain-Class 属性的值将被忽略）。

相关文档

有关工具文档的信息，请参阅：
  • JDK Tools and Utilities

从以下版本开始：
JDK1.5
概述   软件包  类  使用  树  已过时  索引  帮助
JavaTM 2 Platform
Standard Ed. 6
 上一个软件包   下一个软件包 框架    无框架


java.lang.instrument 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.instrument 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.instrument.ClassDefinition
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.instrument.IllegalClassFormatException
        • java.lang.instrument.UnmodifiableClassException

接口分层结构

  • java.lang.instrument.ClassFileTransformer
  • java.lang.instrument.Instrumentation
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.lang.instrument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.instrument
的使用

使用 java.lang.instrument 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 使用的 java.lang.instrument 中的类
ClassDefinition
此类用作 Instrumentation.redefineClasses 方法的参数锁定。
ClassFileTransformer
一个提供此接口的实现以转换类文件的代理。
IllegalClassFormatException
当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
UnmodifiableClassException
在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.instrument.ClassDefinition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.instrument.ClassDefinition
的使用

使用 ClassDefinition 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 ClassDefinition 的使用

参数类型为 ClassDefinition 的 java.lang.instrument 中的方法
 void Instrumentation.redefineClasses(ClassDefinition... definitions)
使用提供的类文件重定义提供的类集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.instrument.ClassFileTransformer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.instrument.ClassFileTransformer
的使用

使用 ClassFileTransformer 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 ClassFileTransformer 的使用

参数类型为 ClassFileTransformer 的 java.lang.instrument 中的方法
void | Instrumentation.addTransformer(ClassFileTransformer transformer) 注册提供的转换器。
void | Instrumentation.addTransformer(ClassFileTransformer transformer, boolean canRetransform) 注册提供的转换器。
boolean | Instrumentation.removeTransformer(ClassFileTransformer transformer) 注销提供的转换器。
void | Instrumentation.setNativeMethodPrefix(ClassFileTransformer transformer, String prefix) 通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.instrument.IllegalClassFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.instrument.IllegalClassFormatException
的使用

使用 IllegalClassFormatException 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 IllegalClassFormatException 的使用

抛出 IllegalClassFormatException 的 java.lang.instrument 中的方法
 byte[] ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.instrument.Instrumentation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.instrument.Instrumentation
的使用

没有 java.lang.instrument.Instrumentation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.instrument.UnmodifiableClassException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.instrument.UnmodifiableClassException
的使用

使用 UnmodifiableClassException 的软件包
java.lang.instrument 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.instrument 中 UnmodifiableClassException 的使用

抛出 UnmodifiableClassException 的 java.lang.instrument 中的方法
void | Instrumentation.redefineClasses(ClassDefinition... definitions) 使用提供的类文件重定义提供的类集。
void | Instrumentation.retransformClasses(Class<?>... classes) 重转换提供的类集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ClassLoadingMXBean (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 ClassLoadingMXBean

public interface ClassLoadingMXBean

用于 Java 虚拟机的类加载系统的管理接口。

Java 虚拟机具有此接口的实现类的单个实例。实现此接口的实例是一个 MXBean，可以通过调用 ManagementFactory.getClassLoadingMXBean() 方法或从平台 MBeanServer 方法获得。

在 MBeanServer 中唯一标识类加载系统的 MXBean 的 ObjectName 为：

java.lang:type=ClassLoading

从以下版本开始：
1.5
另请参见：
JMX Specification., 访问 MXBeans 的方式

方法摘要
int | getLoadedClassCount() 返回当前加载到 Java 虚拟机中的类的数量。
long | getTotalLoadedClassCount() 返回自 Java 虚拟机开始执行到目前已经加载的类的总数。
long | getUnloadedClassCount() 返回自 Java 虚拟机开始执行到目前已经卸载的类的总数。
boolean | isVerbose() 测试是否已为类加载系统启用了 verbose 输出。
void | setVerbose(boolean value) 为类加载系统启用或禁用 verbose 输出。

方法详细信息

getTotalLoadedClassCount

long getTotalLoadedClassCount()
返回自 Java 虚拟机开始执行到目前已经加载的类的总数。

返回：
已加载类的总数。

getLoadedClassCount

int getLoadedClassCount()
返回当前加载到 Java 虚拟机中的类的数量。

返回：
当前已加载的类的数量。

getUnloadedClassCount

long getUnloadedClassCount()
返回自 Java 虚拟机开始执行到目前已经卸载的类的总数。

返回：
已卸载的类的总数。

isVerbose

boolean isVerbose()
测试是否已为类加载系统启用了 verbose 输出。

返回：
如果为类加载系统启用了 verbose 输出，则返回 true；否则返回 false。

setVerbose

void setVerbose(boolean value)
为类加载系统启用或禁用 verbose 输出。verbose 输出信息和 verbose 信息发送到的输出流都与实现有关。通常，Java 虚拟机实现会在每次加载类文件时打印一条消息。

此方法可以由多个线程同时调用。此方法的每次调用都会全局启用或禁用 verbose 输出。

参数：
value - 为 true 将启用 verbose 输出；为 false 将禁用输出。
抛出：
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("control")。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CompilationMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 CompilationMXBean

public interface CompilationMXBean

用于 Java 虚拟机的编译系统的管理接口。

Java 虚拟机具有此接口的实现类的单个实例。实现此接口的实例是一个 MXBean，可以通过调用 ManagementFactory.getClassLoadingMXBean() 方法或从平台 MBeanServer 方法获得。

在 MBeanServer 中唯一标识编译系统的 MXBean 的 ObjectName 为：

java.lang:type=Compilation

从以下版本开始：
1.5
另请参见：
JMX Specification., 访问 MXBeans 的方式

方法摘要
String | getName() 返回即时 (JIT) 编译器的名称。
long | getTotalCompilationTime() 返回在编译上花费的累积耗费时间的近似值（以毫秒为单位）。
boolean | isCompilationTimeMonitoringSupported() 测试 Java 虚拟机是否支持监视编译时间。

方法详细信息

getName

String getName()
返回即时 (JIT) 编译器的名称。

返回：
JIT 编译器的名称。

isCompilationTimeMonitoringSupported

boolean isCompilationTimeMonitoringSupported()
测试 Java 虚拟机是否支持监视编译时间。

返回：
如果支持监视编译时间，则返回 true；否则返回 false。

getTotalCompilationTime

long getTotalCompilationTime()
返回在编译上花费的累积耗费时间的近似值（以毫秒为单位）。如果编译使用了多个线程，此值将为每个线程在编译上花费的近似时间的总和。

平台对此方法的支持是可选的。Java 虚拟机实现可能不支持编译时间监视。isCompilationTimeMonitoringSupported() 方法可用于确定 Java 虚拟机是否支持此操作。

此值并不能指示 Java 虚拟机的性能水平，不适合用于进行不同虚拟机实现的性能比较。不同的实现可能采用不同的编译时间定义和测量方法。

返回：
编译时间（以毫秒为单位）
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持此操作。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GarbageCollectorMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 GarbageCollectorMXBean

所有超级接口：
MemoryManagerMXBean
public interface GarbageCollectorMXBean
extends MemoryManagerMXBean

用于 Java 虚拟机的垃圾回收的管理接口。垃圾回收是 Java 虚拟机用于查找和回收不可到达对象以释放内存空间的过程。垃圾回收器是一种内存管理器。

Java 虚拟机可能具有此接口的实现类的一个或多个实例。实现此接口的实例是 MXBean，可以通过调用 ManagementFactory.getGarbageCollectorMXBeans() 方法或从平台 MBeanServer 方法获得。

在 MBeanServer 中唯一标识垃圾回收器的 MXBean 的 ObjectName 为：

java.lang:type=GarbageCollector ,name=collector's name
平台通常包含特定于垃圾回收算法（用于进行监视的）的其他平台依赖信息。

从以下版本开始：
1.5
另请参见：
MemoryMXBean, JMX Specification., 访问 MXBeans 的方式

方法摘要
long | getCollectionCount() 返回已发生的回收的总次数。
long | getCollectionTime() 返回近似的累积回收时间（以毫秒为单位）。
从接口 java.lang.management.MemoryManagerMXBean 继承的方法
getMemoryPoolNames, getName, isValid

方法详细信息

getCollectionCount

long getCollectionCount()
返回已发生的回收的总次数。如果未为此回收器定义回收计数，此方法将返回 -1。

返回：
已发生的回收的总次数。

getCollectionTime

long getCollectionTime()
返回近似的累积回收时间（以毫秒为单位）。如果未为此回收器定义回收时间，则此方法将返回 -1。

Java 虚拟机实现可能会使用高精度计时器测量已经过的时间。如果收集时间非常短，则即使回收计数已经增加，此方法仍可能返回相同的值。

返回：
近似累积回收时间（以毫秒为单位）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LockInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
类 LockInfo

java.lang.Object
    继承者  java.lang.management.LockInfo
直接已知子类：
MonitorInfo
public class LockInfo
extends Object

关于锁 的信息。锁可以是内置对象监视器、可拥有同步器 (ownable synchronizer) 或与同步器关联的 Condition 对象。

可拥有同步器是可以由一个线程独占的同步器，使用 AbstractOwnableSynchronizer（或其子类）来实现其同步属性。ReentrantLock 和 ReentrantReadWriteLock 是平台提供的两个可拥有同步器示例。

MXBean 映射

根据 MXBeans 类型映射规则的指定，LockInfo 将被映射到 CompositeData。

从以下版本开始：
1.6
另请参见：
AbstractOwnableSynchronizer, Condition

构造方法摘要
LockInfo(String className, int identityHashCode)
构造一个 LockInfo 对象。
方法摘要
 String getClassName()
返回锁对象的完全限定类名称。
 int getIdentityHashCode()
返回从 System.identityHashCode(java.lang.Object) 方法返回的锁对象的标识哈希码。
 String toString()
返回锁的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LockInfo

@ConstructorProperties(value={"className","identityHashCode"})
public LockInfo(String className,
                                           int identityHashCode)
构造一个 LockInfo 对象。

参数：
className - 锁对象的完全限定类名称。
identityHashCode - 锁对象的标识哈希码。
方法详细信息

getClassName

public String getClassName()
返回锁对象的完全限定类名称。

返回：
锁对象的完全限定类名称。

getIdentityHashCode

public int getIdentityHashCode()
返回从 System.identityHashCode(java.lang.Object) 方法返回的锁对象的标识哈希码。

返回：
锁对象的标识哈希码。

toString

public String toString()
返回锁的字符串表示形式。返回的字符串表示形式由以下内容组成：锁对象的类名称、at 标记字符 '@' 和对象标识 哈希码的十六进制无符号表示形式。此方法返回的字符串等于以下表达式的值：
lock.getClass().getName() + '@' + Integer.toHexString(System.identityHashCode(lock))
其中 lock 为锁对象。

覆盖：
类 Object 中的 toString
返回：
锁的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ManagementFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
类 ManagementFactory

java.lang.Object
    继承者  java.lang.management.ManagementFactory

public class ManagementFactory
extends Object

ManagementFactory 类是一种工厂类，用于获取 Java 平台的管理 Bean。此类由静态方法组成，每种静态方法都会返回一个或多个表示 Java 虚拟机组件的管理接口的平台 MXBean。

应用程序可以采用以下方式访问平台 MXBean：

  • 直接访问 MXBean 接口
    1. 通过静态工厂方法获取 MXBean 实例，从本地访问正在运行的虚拟机的 MXBean。
    2. 构造一个 MXBean 代理实例，以通过调用 newPlatfromMXBeanProxy 将方法调用转发到给定的 MBeanServer。构造代理通常是为了远程访问另一个正在运行的虚拟机的 MXBean。
  • 通过 MBeanServer 间接地访问 MXBean 接口
    1. 通过平台 MBeanServer 本地访问 MXBean 或通过特定的 MBeanServerConnection 远程访问 MXBean。MXBean 的属性和操作仅使用 JMX 开放类型，包括在 OpenType 中定义的基本数据类型 CompositeData 和 TabularData。映射关系在下面指定。

平台 MXBean

平台 MXBean 是一种管理 Bean，它符合 JMX Instrumentation Specification，仅使用以下所描述的一组基本数据类型。有关细节，请参阅 MXBean 规范。JMX 管理应用程序和平台 MBeanServer 可以进行互操作，而无需 MXBean 特定数据类型的类。JMX 连接器服务器和连接器客户机之间传送的数据类型为开放类型，而这就允许不同版本进行互操作。

平台 MXBean 接口仅使用以下数据类型：

  • 基本类型，如 int、long、boolean 等等
  • 基本类型的包装器类（如 Integer、Long、Boolean 等等）和 String
  • Enum 类
  • 仅定义获取方法和具有 CompositeData 参数的静态 from 方法的类，以便将输入的 CompositeData 转换为该类的实例
  • List<E> 其中 E 为基本类型、包装类、枚举类或支持从 CompositeData 转换到此类的类
  • Map<K,V> 其中 K 和 V 为基本类型、包装类、枚举类或支持从 CompositeData 转换到此类的类

当通过 MBeanServer 访问平台 MXBean 的属性或操作时，将按以下方式对数据类型进行映射：

  • 基本类型或包装器类映射到相同的类型。
  • Enum 映射到 String（其值为枚举常数的名称）。
  • 仅定义获取方法和具有 CompositeData 参数的 from 方法的类映射到 CompositeData。
  • Map<K,V> 映射到 TabularData，后者的行类型为 CompositeType，此类型具有两个项，其名称分别为 "key" 和 "value"，项类型分别为 K 和 V 对应的映射类型，"key" 为索引。
  • List<E> 映射到数组，该数组中的元素类型为 E 的映射类型。
  • 元素类型为 E 的数组映射到具有相同维数的数组，该数组的元素类型为 E 的映射类型。
平台 MXBean 的 MBeanInfo 将属性和操作的数据类型描述为上述指定要映射到的基本类型或开放类型。

例如，MemoryMXBean 接口具有以下获取和设置方法：

 public MemoryUsage getHeapMemoryUsage();
 public boolean isVerbose();
 public void setVerbose(boolean value);
MemoryMXBean 的 MBeanInfo 中的这些属性的名称和类型如下：
属性名称 | 类型
HeapMemoryUsage | CompositeData representing MemoryUsage
Verbose | boolean

MXBean 名称

Java 虚拟机的每个平台 MXBean 都具有唯一的 ObjectName，以在平台 MBeanServer 中注册。Java 虚拟机具有以下管理接口的单一实例：
管理接口 对象名称
ClassLoadingMXBean java.lang:type=ClassLoading
MemoryMXBean java.lang:type=Memory
ThreadMXBean java.lang:type=Threading
RuntimeMXBean java.lang:type=Runtime
OperatingSystemMXBean java.lang:type=OperatingSystem

Java 虚拟机具有以下管理接口的零个或一个实例：

管理接口 对象名称
CompilationMXBean java.lang:type=Compilation

Java 虚拟机可能具有以下管理接口的一个或多个实例。

管理接口 | 对象名称
GarbageCollectorMXBean | java.lang:type=GarbageCollector ,name=collector's name
MemoryManagerMXBean | java.lang:type=MemoryManager ,name=manager's name
MemoryPoolMXBean | java.lang:type=MemoryPool ,name=pool's name

从以下版本开始：
1.5
另请参见：
JMX Specification., Access Management Metrics, LoggingMXBean, MXBean

字段摘要
static String | CLASS_LOADING_MXBEAN_NAME ClassLoadingMXBean 的 ObjectName 的字符串表示形式。
static String | COMPILATION_MXBEAN_NAME CompilationMXBean 的 ObjectName 的字符串表示形式。
static String | GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE GarbageCollectorMXBean 的 ObjectName 中的域名和类型键属性。
static String | MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE MemoryManagerMXBean 的 ObjectName 中的域名和类型键属性。
static String | MEMORY_MXBEAN_NAME MemoryMXBean 的 ObjectName 的字符串表示形式。
static String | MEMORY_POOL_MXBEAN_DOMAIN_TYPE MemoryPoolMXBean 的 ObjectName 中的域名和类型键属性。
static String | OPERATING_SYSTEM_MXBEAN_NAME OperatingSystemMXBean 的 ObjectName 的字符串表示形式。
static String | RUNTIME_MXBEAN_NAME RuntimeMXBean 的 ObjectName 的字符串表示形式。
static String | THREAD_MXBEAN_NAME ThreadMXBean 的 ObjectName 的字符串表示形式。
方法摘要
static ClassLoadingMXBean getClassLoadingMXBean()
返回 Java 虚拟机的类加载系统的管理 Bean。
static CompilationMXBean getCompilationMXBean()
返回 Java 虚拟机的编译系统的管理 Bean。
static List<GarbageCollectorMXBean> getGarbageCollectorMXBeans()
返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。
static List<MemoryManagerMXBean> getMemoryManagerMXBeans()
返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。
static MemoryMXBean getMemoryMXBean()
返回 Java 虚拟机的内存系统的管理 Bean。
static List<MemoryPoolMXBean> getMemoryPoolMXBeans()
返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。
static OperatingSystemMXBean getOperatingSystemMXBean()
返回运行 Java 虚拟机的操作系统的管理 Bean。
static MBeanServer getPlatformMBeanServer()
返回平台 MBeanServer。
static RuntimeMXBean getRuntimeMXBean()
返回 Java 虚拟机的运行时系统的管理 Bean。
static ThreadMXBean getThreadMXBean()
返回 Java 虚拟机的线程系统的管理 Bean。
static
<T> T
newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CLASS_LOADING_MXBEAN_NAME

public static final String CLASS_LOADING_MXBEAN_NAME
ClassLoadingMXBean 的 ObjectName 的字符串表示形式。

另请参见：
常量字段值

COMPILATION_MXBEAN_NAME

public static final String COMPILATION_MXBEAN_NAME
CompilationMXBean 的 ObjectName 的字符串表示形式。

另请参见：
常量字段值

MEMORY_MXBEAN_NAME

public static final String MEMORY_MXBEAN_NAME
MemoryMXBean 的 ObjectName 的字符串表示形式。

另请参见：
常量字段值

OPERATING_SYSTEM_MXBEAN_NAME

public static final String OPERATING_SYSTEM_MXBEAN_NAME
OperatingSystemMXBean 的 ObjectName 的字符串表示形式。

另请参见：
常量字段值

RUNTIME_MXBEAN_NAME

public static final String RUNTIME_MXBEAN_NAME
RuntimeMXBean 的 ObjectName 的字符串表示形式。

另请参见：
常量字段值

THREAD_MXBEAN_NAME

public static final String THREAD_MXBEAN_NAME
ThreadMXBean 的 ObjectName 的字符串表示形式。

另请参见：
常量字段值

GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE

public static final String GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE
GarbageCollectorMXBean 的 ObjectName 中的域名和类型键属性。GarbageCollectorMXBean 的唯一 ObjectName 可以通过在此字符串后添加 ",name=collector's name" 形成。

另请参见：
常量字段值

MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE

public static final String MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE
MemoryManagerMXBean 的 ObjectName 中的域名和类型键属性。MemoryManagerMXBean 的唯一 ObjectName 可以通过在此字符串后添加 ",name=manager's name" 形成。

另请参见：
常量字段值

MEMORY_POOL_MXBEAN_DOMAIN_TYPE

public static final String MEMORY_POOL_MXBEAN_DOMAIN_TYPE
MemoryPoolMXBean 的 ObjectName 中的域名和类型键属性。MemoryPoolMXBean 的唯一 ObjectName 可以通过在此字符串后添加 ",name=pool's name" 形成。

另请参见：
常量字段值
方法详细信息

getClassLoadingMXBean

public static ClassLoadingMXBean getClassLoadingMXBean()
返回 Java 虚拟机的类加载系统的管理 Bean。

返回：
Java 虚拟机的 ClassLoadingMXBean 对象。

getMemoryMXBean

public static MemoryMXBean getMemoryMXBean()
返回 Java 虚拟机的内存系统的管理 Bean。

返回：
Java 虚拟机的 MemoryMXBean 对象。

getThreadMXBean

public static ThreadMXBean getThreadMXBean()
返回 Java 虚拟机的线程系统的管理 Bean。

返回：
Java 虚拟机的 ThreadMXBean 对象。

getRuntimeMXBean

public static RuntimeMXBean getRuntimeMXBean()
返回 Java 虚拟机的运行时系统的管理 Bean。

返回：
Java 虚拟机的 RuntimeMXBean 对象。

getCompilationMXBean

public static CompilationMXBean getCompilationMXBean()
返回 Java 虚拟机的编译系统的管理 Bean。如果 Java 虚拟机没有编译系统，此方法将返回 null。

返回：
Java 虚拟机的 CompilationMXBean 对象，或者，如果 Java 虚拟机没有编译系统，则返回 null。

getOperatingSystemMXBean

public static OperatingSystemMXBean getOperatingSystemMXBean()
返回运行 Java 虚拟机的操作系统的管理 Bean。

返回：
Java 虚拟机的 OperatingSystemMXBean 对象。

getMemoryPoolMXBeans

public static List<MemoryPoolMXBean> getMemoryPoolMXBeans()
返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。Java 虚拟机可以有一个或多个内存池。可以在运行期间添加或删除内存池。

返回：
MemoryPoolMXBean 对象列表。

getMemoryManagerMXBeans

public static List<MemoryManagerMXBean> getMemoryManagerMXBeans()
返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。Java 虚拟机可以有一个或多个内存管理器。可以在运行期间添加或删除内存管理器。

返回：
MemoryManagerMXBean 对象列表。

getGarbageCollectorMXBeans

public static List<GarbageCollectorMXBean> getGarbageCollectorMXBeans()
返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。Java 虚拟机可以有一个或多个 GarbageCollectorMXBean 对象。可以在运行期间添加或删除 GarbageCollectorMXBean。

返回：
GarbageCollectorMXBean 对象列表。

getPlatformMBeanServer

public static MBeanServer getPlatformMBeanServer()
返回平台 MBeanServer。第一次调用此方法时，将首先通过调用 MBeanServerFactory.createMBeanServer 方法创建平台 MBeanServer，然后通过使用类描述中定义的 MXBean 名称在此平台 MBeanServer 中注册平台 MXBean。在后续的调用中，此方法将直接返回最初创建的平台 MBeanServer。

动态创建和销毁的 MXBean（如内存池和管理器）将自动注册到平台 MBeanServer 和从中注销。

如果设置了系统属性 javax.management.builder.initial，将由指定的 MBeanServerBuilder 进行平台 MBeanServer 创建。

建议也将此平台用于注册平台 MXBean 之外的其他应用程序管理 Bean。这将允许所有 MBean 通过同一个 MBeanServer 发布，从而能够更方便地进行网络发布和发现。应该避免平台 MXBean 的名称冲突。

返回：
平台 MBeanServer；将在第一次调用此方法时注册到平台 MBeanServer 中的平台 MXBean。
抛出：
SecurityException - 如果安全管理器和调用方不具有 MBeanServerFactory.createMBeanServer() 所需要的权限。
另请参见：
MBeanServerFactory, MBeanServerFactory.createMBeanServer()

newPlatformMXBeanProxy

public static <T> T newPlatformMXBeanProxy(MBeanServerConnection connection,
                                           String mxbeanName,
                                           Class<T> mxbeanInterface)
                                throws IOException
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

此方法等效于：

Proxy.newProxyInstance (mxbeanInterface.getClassLoader(), new Class[] { mxbeanInterface }, handler)
其中 handler 是一个 InvocationHandler，对 MXBean 接口的方法调用将调度到其上。此 handler 会在将 MXBean 数据类型的输入参数转发到 MBeanServer 之前将其转换为其映射的开放类型，并将通过 MBeanServer 的 MXBean 方法调用的返回值由开放类型转换为在 MXBean 接口中声明的对应返回类型。

如果 MXBean 是通知发出者（即它实现了 NotificationEmitter），则 mxbeanInterface 和 NotificationEmitter 都将由此代理实现。

注：

  1. 使用 MXBean 代理可以方便地远程访问正在运行的虚拟机的平台 MXBean。所有对 MXBean 代理的方法调用都被转发到 MBeanServerConnection，当连接器服务器出现通信问题时，可能在其中抛出 IOException。如果使用代理远程访问平台 MXBean 的应用程序要访问 MBeanServerConnector 接口，则应该准备捕获 IOException。
  2. 当客户端应用程序设计为远程访问正在运行的虚拟机（其版本与该应用程序运行其上的虚拟机版本不同）的 MXBean 时，应当准备捕获 InvalidObjectException，当 MXBean 代理接收到一个枚举常数的名称，而该名称客户端应用程序中加载的枚举类又缺少此枚举常数时，将抛出此异常。
  3. MBeanServerInvocationHandler 或其 newProxyInstance 方法不能用于为平台 MXBean 创建代理。MBeanServerInvocationHandler 创建的代理对象不会处理类规范中描述的平台 MXBean 的属性。

参数：
connection - 要转发到的目标 MBeanServerConnection。
mxbeanName - 要转发到的 connection 的平台 MXBean。mxbeanName 的格式必须为 ObjectName 的格式。
mxbeanInterface - 要由代理实现的 MXBean 接口。
抛出：
IllegalArgumentException - 如果
  • mxbeanName 没有采用有效的 ObjectName 格式，或者
  • connection 中指定的 MXBean 不是由平台提供的 MXBean，或者
  • 指定的 MXBean 未在 MBeanServerConnection 中注册，或者
  • 指定的 MXBean 不是给定 mxbeanInterface 的实例
IOException - 如果在访问 MBeanServerConnection 时出现通信问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ManagementPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
类 ManagementPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.lang.management.ManagementPermission
所有已实现的接口：
Serializable, Guard
public final class ManagementPermission
extends BasicPermission

使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

下表提供了权限所允许的操作的简要说明，并讨论了授权代码权限的风险。

权限目标名称 | 权限所允许的操作 | 允许此权限所带来的风险
control | 可以控制 Java 虚拟机的运行时特征，例如，设置 -verbose:gc 和 -verbose:class 标志，设置内存池的阈值，以及启用和禁用线程争用监视支持。 | 这允许攻击者控制 Java 虚拟机的运行时特征，会导致系统行为不正常。
monitor | 可以获取 Java 虚拟机的运行时信息，如线程堆栈跟踪、所有已加载类名称的列表以及 Java 虚拟机的输入参数。 | 这允许恶意代码监视运行时信息，从而发现系统漏洞。

程序员通常不会直接创建 ManagementPermission 对象。这些对象由安全策略代码根据读取的安全策略文件创建。

从以下版本开始：
1.5
另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
ManagementPermission(String name)
构造具有指定名称的 ManagementPermission。
ManagementPermission(String name, String actions)
构造新的 ManagementPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ManagementPermission

public ManagementPermission(String name)
构造具有指定名称的 ManagementPermission。

参数：
name - 权限名称。必须为 "monitor" 或 "control"。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空或无效。

ManagementPermission

public ManagementPermission(String name,
                            String actions)
                     throws IllegalArgumentException
构造新的 ManagementPermission 对象。

参数：
name - 权限名称。必须为 "monitor" 或 "control"。
actions - 必须为 null 或空字符串。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空或者参数无效。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryManagerMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 MemoryManagerMXBean

所有已知子接口：
GarbageCollectorMXBean
public interface MemoryManagerMXBean

内存管理器的管理接口。内存管理器管理 Java 虚拟机的一个或多个内存池。

Java 虚拟机具有一个或多个内存管理器。实现此接口的实例是 MXBean，可以通过调用 ManagementFactory.getMemoryManagerMXBeans() 方法或从平台 MBeanServer 方法获得。

在 MBeanServer 内唯一标识内存管理器的 MXBean 的 ObjectName 为：

java.lang:type=MemoryManager ,name=manager's name

从以下版本开始：
1.5
另请参见：
MemoryMXBean, JMX Specification., 访问 MXBeans 的方式

方法摘要
String[] | getMemoryPoolNames() 返回此内存管理器管理的内存池名称。
String | getName() 返回表示此内存管理器的名称。
boolean | isValid() 测试此内存管理器在 Java 虚拟机中是否有效。

方法详细信息

getName

String getName()
返回表示此内存管理器的名称。

返回：
此内存管理器的名称。

isValid

boolean isValid()
测试此内存管理器在 Java 虚拟机中是否有效。一旦 Java 虚拟机将内存管理器从内存系统移除，该内存管理器就变为无效。

返回：
如果内存管理器在 Java 虚拟机中有效，则返回 true；否则返回 false。

getMemoryPoolNames

String[] getMemoryPoolNames()
返回此内存管理器管理的内存池名称。

返回：
String 对象的数组，其中的每个对象都是此内存管理器管理的内存池的名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 MemoryMXBean

public interface MemoryMXBean

Java 虚拟机内存系统的管理接口。

Java 虚拟机具有此接口的实现类的单一实例。实现此接口的实例是一个 MXBean，可以通过调用 ManagementFactory.getMemoryMXBean() 方法或从平台 MBeanServer 方法获得。

在 MBeanServer 中唯一标识内存系统的 MXBean 的 ObjectName 为：

java.lang:type=Memory

内存

Java 虚拟机的内存系统管理以下类型的内存：

1. 堆

Java 虚拟机具有一个堆，堆是运行时数据区域，所有类实例和数组的内存均从此处分配。堆是在 Java 虚拟机启动时创建的。对象的堆内存由称为垃圾回收器 的自动内存管理系统回收。

堆的大小可以固定，也可以扩大和缩小。堆的内存不需要是连续空间。

2. 非堆内存

Java 虚拟机管理堆之外的内存（称为非堆内存）。

Java 虚拟机具有一个由所有线程共享的方法区。方法区属于非堆内存。它存储每个类结构，如运行时常量池、字段和方法数据，以及方法和构造方法的代码。它是在 Java 虚拟机启动时创建的。

方法区在逻辑上是堆的一部分，但 Java 虚拟机实现可以选择不对其进行回收或压缩。与堆类似，方法区的大小可以固定，也可以扩大和缩小。方法区的内存不需要是连续空间。

除了方法区外，Java 虚拟机实现可能需要用于内部处理或优化的内存，这种内存也是非堆内存。例如，JIT 编译器需要内存来存储从 Java 虚拟机代码转换而来的本机代码，从而获得高性能。

内存池和内存管理器

内存池和内存管理器都是抽象实体，对 Java 虚拟机的内存系统进行监视和管理。

内存池表示 Java 虚拟机管理的内存区域。Java 虚拟机至少有一个内存池，而且可以在执行期间创建或删除内存池。内存池可以是堆内存，也可以是非堆内存。

内存管理器负责管理一个或多个内存池。垃圾回收器就是一种内存管理器，负责回收不可到达对象占用的内存。Java 虚拟机可以有一个或多个内存管理器。可以在运行期间添加或删除内存管理器。一个内存池可以由多个内存管理器进行管理。

内存使用量监视

对于内存系统而言，内存使用量是一个非常重要的监视属性。例如，内存使用量可以指示：
  • 应用程序的内存使用量，
  • 自动内存管理系统上的工作负载，
  • 潜在的内存泄漏。

可以采用三种方式监视内存使用量：

  • 轮询
  • 使用量阈值通知
  • 集合使用量阈值通知
具体细节在 MemoryPoolMXBean 接口中指定。

内存使用量监视机制旨在用于负载平衡或工作负载分布。例如，应用程序在其内存使用量超过特定阈值时，将会停止接收任何新的工作负载。它不适合用于供应用程序进行检测并从低内存情况恢复。

通知

此 MemoryMXBean 是一个 NotificationEmitter，如果任何一个内存池支持使用量阈值或集合使用量阈值（可以通过调用 MemoryPoolMXBean.isUsageThresholdSupported() 和 MemoryPoolMXBean.isCollectionUsageThresholdSupported() 方法确定），它将发出两种类型的通知。

  • 使用量阈值超过通知 - 用于通知内存池的内存使用量增加，已达到或超过其使用量阈值。
  • 集合使用量阈值超过通知 - 用于通知在 Java 虚拟机对内存池中不使用的对象进行了回收工作之后，该内存池的内存使用量已大于或等于其集合使用量阈值。

发出的通知是一个 Notification 实例，其用户数据设置为 CompositeData（表示包含构造该通知时内存池信息的 MemoryNotificationInfo 对象）。CompositeData 包含 MemoryNotificationInfo 中描述的各个属性。

NotificationEmitter

ManagementFactory.getMemoryMXBean() 返回的 MemoryMXBean 对象实现了 NotificationEmitter 接口，该接口允许在 MemoryMXBean 中将侦听器注册为通知侦听器。 以下示例代码将注册 MyListener 以处理 MemoryMXBean 发出的通知。
 class MyListener implements javax.management.NotificationListener {
     public void handleNotification(Notification notif, Object handback) {
         // handle notification
         ....
     }
 }

 MemoryMXBean mbean = ManagementFactory.getMemoryMXBean();
 NotificationEmitter emitter = (NotificationEmitter) mbean;
 MyListener listener = new MyListener();
 emitter.addNotificationListener(listener, null, null);

从以下版本开始：
1.5
另请参见：
JMX Specification., Ways to Access MXBeans

方法摘要
void | gc() 运行垃圾回收器。
MemoryUsage | getHeapMemoryUsage() 返回用于对象分配的堆的当前内存使用量。
MemoryUsage | getNonHeapMemoryUsage() 返回 Java 虚拟机使用的非堆内存的当前内存使用量。
int | getObjectPendingFinalizationCount() 返回其终止被挂起的对象的近似数目。
boolean | isVerbose() 测试内存系统的 verbose 输出是否已启用。
void | setVerbose(boolean value) 启用或禁用内存系统的 verbose 输出。

方法详细信息

getObjectPendingFinalizationCount

int getObjectPendingFinalizationCount()
返回其终止被挂起的对象的近似数目。

返回：
其终止被挂起的对象的近似数目。

getHeapMemoryUsage

MemoryUsage getHeapMemoryUsage()
返回用于对象分配的堆的当前内存使用量。堆由一个或多个内存池组成。返回的内存使用量中的已使用大小和已提交大小为所有堆内存池的对应值的总和，而返回的内存使用量中表示堆内存设置的初始大小和最大大小则可能不等于所有堆内存池对应值的总和。

返回的内存使用量中已使用内存量为活动对象和尚未回收的垃圾对象（如果有）所占用内存的总量。

MBeanServer 访问：
MemoryUsage 的映射类型为 CompositeData，具有 MemoryUsage 中指定的属性。

返回：
表示堆内存使用量的 MemoryUsage 对象。

getNonHeapMemoryUsage

MemoryUsage getNonHeapMemoryUsage()
返回 Java 虚拟机使用的非堆内存的当前内存使用量。非堆内存由一个或多个内存池组成。返回的内存使用量中的已使用大小和已提交大小为所有非堆内存池的对应值的总和，而返回的内存使用量中表示非堆内存设置的初始大小和最大大小则可能不等于所有非堆内存池对应值的总和。

MBeanServer 访问：
MemoryUsage 的映射类型为 CompositeData，具有 MemoryUsage 中指定的属性。

返回：
表示非堆内存使用量的 MemoryUsage 对象。

isVerbose

boolean isVerbose()
测试内存系统的 verbose 输出是否已启用。

返回：
如果启用了内存系统的 verbose 输出，则返回 true；否则返回 false。

setVerbose

void setVerbose(boolean value)
启用或禁用内存系统的 verbose 输出。verbose 输出信息和 verbose 信息发送到的输出流都与实现有关。通常，只要垃圾回收时释放了内存，Java 虚拟机实现就会输出一条消息。

此方法的每次调用都会全局启用或禁用 verbose 输出。

参数：
value - 为 true 将启用 verbose 输出；为 false 将禁用输出。
抛出：
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("control")。

gc

void gc()
运行垃圾回收器。调用 gc() 实际上等同于调用：
 System.gc()

另请参见：
System.gc()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryNotificationInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
类 MemoryNotificationInfo

java.lang.Object
    继承者  java.lang.management.MemoryNotificationInfo

public class MemoryNotificationInfo
extends Object

关于内存通知的信息。

当 Java 虚拟机检测到内存池的内存使用量超过了阈值时，MemoryMXBean 将发出内存通知。发出的通知将包含关于检测到的情况的内存通知信息：

  • 内存池的名称。
  • 构造通知时内存池的内存使用量。
  • 构造通知时，内存使用量超过阈值的次数。对于使用量阈值通知，此计数将为使用量阈值计数。对于集合使用量阈值通知，此计数将为集合使用量阈值计数。

表示 MemoryNotificationInfo 对象的 CompositeData 存储在通知的用户数据中。提供了表单方法将 CompositeData 转换为 MemoryNotificationInfo 对象。例如：

      Notification notif;

      // receive the notification emitted by MemoryMXBean and set to notif
      ...

      String notifType = notif.getType();
      if (notifType.equals(MemoryNotificationInfo.MEMORY_THRESHOLD_EXCEEDED) ||
          notifType.equals(MemoryNotificationInfo.MEMORY_COLLECTION_THRESHOLD_EXCEEDED)) {
          // retrieve the memory notification information
          CompositeData cd = (CompositeData) notif.getUserData();
          MemoryNotificationInfo info = MemoryNotificationInfo.from(cd);
          ....
      }

MemoryMXBean 发出的通知类型为：

  • 使用量阈值超过通知。
    当内存池的内存使用量增加，达到或超过其使用量阈值，将发出此通知。后续的使用量阈值超过情况不会导致更多的通知，一直到内存使用量返回到小于使用量阈值的状态为止。

  • 集合使用量阈值超过通知。
    当 Java 虚拟机对内存池中不使用的对象进行了回收工作之后，内存池的内存使用量大于或等于其集合使用量阈值时，将发出此通知。

从以下版本开始：
1.5

字段摘要
static String | MEMORY_COLLECTION_THRESHOLD_EXCEEDED 表示当 Java 虚拟机对内存池中的不使用的对象进行了回收工作之后，内存池的内存使用量大于或等于其集合使用量阈值的通知类型。
static String | MEMORY_THRESHOLD_EXCEEDED 表示内存池的内存使用量已达到或超过其使用量阈值的通知类型。
构造方法摘要
MemoryNotificationInfo(String poolName, MemoryUsage usage, long count)
构造一个 MemoryNotificationInfo 对象。
方法摘要
static MemoryNotificationInfo | from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。
long | getCount() 返回构造通知时内存使用量超过阈值的次数。
String | getPoolName() 返回触发此通知的内存池的名称。
MemoryUsage | getUsage() 返回构造此通知时内存池的内存使用量。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MEMORY_THRESHOLD_EXCEEDED

public static final String MEMORY_THRESHOLD_EXCEEDED
表示内存池的内存使用量已达到或超过其使用量阈值的通知类型。此通知由 MemoryMXBean 发出。后续的使用量阈值超过情况不会导致更多的通知，一直到内存使用量返回到小于使用量阈值的状态为止。此通知类型的值为 java.management.memory.threshold.exceeded。

另请参见：
常量字段值

MEMORY_COLLECTION_THRESHOLD_EXCEEDED

public static final String MEMORY_COLLECTION_THRESHOLD_EXCEEDED
表示当 Java 虚拟机对内存池中的不使用的对象进行了回收工作之后，内存池的内存使用量大于或等于其集合使用量阈值的通知类型。此通知由 MemoryMXBean 发出。此通知类型的值为 java.management.memory.collection.threshold.exceeded。

另请参见：
常量字段值
构造方法详细信息

MemoryNotificationInfo

public MemoryNotificationInfo(String poolName,
                              MemoryUsage usage,
                              long count)
构造一个 MemoryNotificationInfo 对象。

参数：
poolName - 触发此通知的内存池的名称。
usage - 内存池的内存使用量。
count - 超过阈值的次数计数。
方法详细信息

getPoolName

public String getPoolName()
返回触发此通知的内存池的名称。内存池使用量已经超过阈值。

返回：
触发此通知的内存池的名称。

getUsage

public MemoryUsage getUsage()
返回构造此通知时内存池的内存使用量。

返回：
构造此通知时内存池的内存使用量。

getCount

public long getCount()
返回构造通知时内存使用量超过阈值的次数。对于使用量阈值通知，此计数将为阈值计数。对于集合使用量阈值通知，此计数将为集合使用量阈值计数。

返回：
构造通知时，内存使用量超过阈值的次数。

from

public static MemoryNotificationInfo from(CompositeData cd)
返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。此给定的 CompositeData 必须包含以下属性：
属性名称 | 类型
poolName | java.lang.String
usage | javax.management.openmbean.CompositeData
count | java.lang.Long

参数：
cd - 表示 MemoryNotificationInfo 的 CompositeData
返回：
如果 cd 不为 null，则返回由 cd 表示的 MemoryNotificationInfo 对象；否则，返回 null。
抛出：
IllegalArgumentException - 如果 cd 不表示 MemoryNotificationInfo 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryPoolMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 MemoryPoolMXBean

public interface MemoryPoolMXBean

内存池的管理接口。内存池表示由 Java 虚拟机管理的内存资源，由一个或多个内存管理器对内存池进行管理。

Java 虚拟机具有此接口的实现类的一个或多个实例。实现此接口的实例是 MXBean，可以通过调用 ManagementFactory.getMemoryPoolMXBeans() 方法或从平台 MBeanServer 方法获得。

在 MBeanServer 中惟一标识内存池的 MXBean 的 ObjectName 为：

java.lang:type=MemoryPool ,name=pool's name

内存类型

Java 虚拟机具有一个用于对象分配的堆，还包含用于方法区域和 Java 虚拟机执行的非堆内存。Java 虚拟机可以有一个或多个内存池。每个内存池表示一个内存区域，此内存区域可为以下类型之一：

  • 堆
  • 非堆

内存使用量监视

内存池具有以下属性：
  • 内存使用量
  • 峰值内存使用量
  • 使用量阈值
  • 回收使用量阈值（仅由某些垃圾回收 内存池支持）

1. 内存使用量

getUsage() 方法提供了内存池当前使用量的估计数。对于垃圾回收内存池，已使用的内存包括由池中所有对象（包括可到达 对象和不可达到 对象）占用的内存。

通常，此方法是一个轻量操作，用于获取近似内存使用量。对于某些内存池（例如，当对象未连续打包时），此方法可能成为开销巨大的操作，要求进行计算以确定当前的内存使用量。如果是这样，实现应该加以注释。

2. 峰值内存使用量

Java 虚拟机会维护自虚拟机启动或者峰值重置以来的内存池峰值内存使用量。峰值内存使用量由 getPeakUsage() 方法返回，通过调用 resetPeakUsage() 方法可将其重置。

3. 使用量阈值

每个内存池都有一个可管理的属性，称为使用量阈值，其默认值由 Java 虚拟机提供。此默认值与平台有关。可以通过 setUsageThreshold 方法设置使用量阈值。如果阈值设置为正数，将启用此内存池中的使用量阈值超过检查。如果使用率阈值设置为零，将禁用此内存池的使用量阈值超过检查。isUsageThresholdSupported() 方法可用于确定是否支持此功能。

Java 虚拟机在其最恰当的时候（通常在垃圾回收时）会对内存池逐个进行使用量阈值超过检查。每个内存池均维护一个使用量阈值计数，每次 Java 虚拟机检测到内存池使用量超过阈值，此值都会加 1。

此可管理的使用量阈值属性设计用于以低开销监视内存使用量增加的趋势。使用量阈值可能不适合某些内存池。例如，生存期垃圾回收器是在很多 Java 虚拟机实现中都使用的一种常见的垃圾回收算法，它按照生存时间管理划分为两代或多代的对象。很多对象都分配在最新的一代（称为新生内存池）。新生内存池的设计使其很容易被填满，回收新生内存池将会释放其大部分内存空间，因为这种内存池包含了大多数生存时间短的对象，以及大多数在垃圾回收时不可到达的对象。在这种情况下，新生内存池不支持使用量阈值会更为合适。此外，如果在一个内存池中进行对象分配的开销很小（例如，只是原子指针交换），Java 虚拟机将可能不支持该内存池的使用量阈值，因为使用量阈值的开销比对象分配的开销大。

系统的内存使用量可以通过轮询或阈值通知机制进行监视。

  1. 轮询

    通过调用所有内存池的 getUsage() 方法或调用支持使用量阈值的内存池的 isUsageThresholdExceeded() 方法，应用程序可以持续监视其内存使用量。以下的示例代码具有一个专门用于任务分配和处理的线程。每隔一段时间，它将根据其内存使用量确定是否应当接受和处理新任务。如果内存使用量超过了其使用量阈值，它会将所有未处理的任务重新分配给其他 VM 并停止接受新任务，直到内存使用量低于其使用量阈值。

       // Assume the usage threshold is supported for this pool.
       // Set the threshold to myThreshold above which no new tasks
       // should be taken.
       pool.setUsageThreshold(myThreshold);
       ....

       boolean lowMemory = false;
       while (true) {
          if (pool.isUsageThresholdExceeded()) {
              // potential low memory, so redistribute tasks to other VMs
              lowMemory = true;
              redistributeTasks();
              // stop receiving new tasks
              stopReceivingTasks();
          } else {
              if (lowMemory) {
                  // resume receiving tasks
                  lowMemory = false;
                  resumeReceivingTasks();
              }
              // processing outstanding task
              ...
          }
          // sleep for sometime
          try {
              Thread.sleep(sometime);
          } catch (InterruptedException e) {
              ...
          }
       }
    以上示例并没有对以下两种情况加以区分，即内存使用量临时低于使用量阈值的情况和内存使用量在两次迭代之间保持高于阈值的情况。由 getUsageThresholdCount() 方法返回的使用量阈值计数可用于确定在两次轮询之间返回的内存使用量是否低于阈值。

    以下是另一个示例，该示例在内存池出现内存空间不足时将采取一些操作，并会忽略在操作处理期间的内存使用量变化。

           // Assume the usage threshold is supported for this pool.
       // Set the threshold to myThreshold which determines if
       // the application will take some action under low memory condition.
       pool.setUsageThreshold(myThreshold);

       int prevCrossingCount = 0;
       while (true) {
           // A busy loop to detect when the memory usage
           // has exceeded the threshold.
           while (!pool.isUsageThresholdExceeded() ||
                  pool.getUsageThresholdCount() == prevCrossingCount) {
               try {
                   Thread.sleep(sometime)
               } catch (InterruptException e) {
                   ....
               }
           }

           // Do some processing such as check for memory usage
           // and issue a warning
           ....

           // Gets the current threshold count. The busy loop will then
           // ignore any crossing of threshold happens during the processing.
           prevCrossingCount = pool.getUsageThresholdCount();
       }
  2. 使用量阈值通知

    使用量阈值通知将由 MemoryMXBean 发出。当 Java 虚拟机检测到内存池的内存使用量达到或超过其内存使用量阈值时，虚拟机将触发 MemoryMXBean ，发出使用量阈值超过通知。直到使用量降低到阈值以下，然后再次超过了阈值，才会再次生成使用量阈值超过通知。

    以下示例代码实现了与以上示例相同的逻辑，但使用了使用量阈值通知机制（而非轮询）来检测低内存情况。在此示例代码中，接收到通知时，通知侦听器将通知另一个线程执行实际的操作，如重新分配未处理的任务、停止接受任务，或恢复接受任务等。handleNotification 方法应该设计为完成很少的工作，且无延迟地返回，以避免导致交付后续通知时出现延迟。耗时的操作应该使用独立的线程来执行。通知侦听器可以由多个线程并发调用，因此侦听器执行的任务应该进行适当地同步。

       class MyListener implements javax.management.NotificationListener {
            public void handleNotification(Notification notification, Object handback)  {
                String notifType = notification.getType();
                if (notifType.equals(MemoryNotificationInfo.MEMORY_THRESHOLD_EXCEEDED)) {
                    // potential low memory, notify another thread
                    // to redistribute outstanding tasks to other VMs
                    // and stop receiving new tasks.
                    lowMemory = true;
                    notifyAnotherThread(lowMemory);
                }
            }
       }

       // Register MyListener with MemoryMXBean
       MemoryMXBean mbean = ManagementFactory.getMemoryMXBean();
       NotificationEmitter emitter = (NotificationEmitter) mbean;
       MyListener listener = new MyListener();
       emitter.addNotificationListener(listener, null, null);

       // Assume this pool supports a usage threshold.
       // Set the threshold to myThreshold above which no new tasks
       // should be taken.
       pool.setUsageThreshold(myThreshold);

       // Usage threshold detection is enabled and notification will be
       // handled by MyListener.  Continue for other processing.
       ....

    无法保证 MemoryMXBean 何时发出阈值通知和交付通知。当调用通知侦听器时，内存池的内存使用量可能已经多次超过使用量阈值。MemoryNotificationInfo.getCount() 方法将返回构造通知时内存使用量已超过使用量阈值的次数。可以将此值与 getUsageThresholdCount() 返回的当前使用量阈值计数进行比较，以确定是否出现了此类情况。

4. 回收使用量阈值

回收使用量阈值是一个可管理属性，仅适用于某些垃圾回收内存池。Java 虚拟机通过在垃圾回收时回收内存池中未使用的对象，完成了内存空间的回收工作之后，内存池中某些经过垃圾回收的字节仍在使用。回收使用量阈值允许为此字节数设置一个值，这样在超过该阈值的情况下，将由 MemoryMXBean 发出回收使用量超过通知。此外，回收使用量阈值计数将增加 1。

isCollectionUsageThresholdSupported() 方法可用于确定是否支持此功能。

Java 虚拟机按内存池执行回收使用量阈值检查。如果回收使用量阈值设置为正数，则将启用此检查。如果回收使用量阈值设置为零，将在此内存池上禁用此检查。默认值为零。Java 虚拟机将在垃圾回收时执行回收使用量阈值检查。

某些垃圾回收内存池可能选择不支持回收使用量阈值。例如，仅由持续并发垃圾回收器管理的内存池。在此内存池中，某个线程可以分配对象，而同时不使用的对象将由并发垃圾回收器进行回收。除非有定义良好的垃圾回收时间，该时间是检查内存使用量的最恰当时间，否则就不应该支持回收使用量阈值。

回收使用量阈值设计用于监视 Java 虚拟机进行内存空间回收工作之后的内存使用量。还可以采用与上述监视使用量阈值类似的方法，通过轮询和阈值通知机制监视回收使用量阈值。

从以下版本开始：
1.5
另请参见：
JMX Specification., 访问 MXBeans 的方式

方法摘要
MemoryUsage | getCollectionUsage() 返回 Java 虚拟机最近回收了此内存池中的不使用的对象之后的内存使用量。
long | getCollectionUsageThreshold() 返回此内存池的回收使用量阈值（以字节为单位）。
long | getCollectionUsageThresholdCount() 返回 Java 虚拟机已检测到内存使用量达到或超过回收使用量阈值的次数。
String[] | getMemoryManagerNames() 返回管理此内存池的内存管理器的名称。
String | getName() 返回表示此内存池的名称。
MemoryUsage | getPeakUsage() 返回自 Java 虚拟机启动以来或自峰值重置以来此内存池的峰值内存使用量。
MemoryType | getType() 返回此内存池的类型。
MemoryUsage | getUsage() 返回此内存池的内存使用量的估计数。
long | getUsageThreshold() 返回此内存池的使用量阈值（以字节为单位）。
long | getUsageThresholdCount() 返回内存使用量超过其阈值的次数。
boolean | isCollectionUsageThresholdExceeded() 测试在 Java 虚拟机最近一次回收工作之后，此内存池的内存使用量是否达到或超过了其回收使用量阈值。
boolean | isCollectionUsageThresholdSupported() 测试此内存池是否支持回收使用量阈值。
boolean | isUsageThresholdExceeded() 测试此内存池的使用量是否达到或超过其使用量阈值。
boolean | isUsageThresholdSupported() 测试此内存池是否支持使用量阈值。
boolean | isValid() 测试此内存池在 Java 虚拟机中是否有效。
void | resetPeakUsage() 将此内存池的峰值内存使用量统计重置为当前内存使用量。
void | setCollectionUsageThreshold(long threhsold) 将此内存池的回收使用量阈值设置为给定的 threshold 值。
void | setUsageThreshold(long threshold) 如果此内存池支持使用量阈值，则将此内存池的阈值设置为给定的 threshold 值。

方法详细信息

getName

String getName()
返回表示此内存池的名称。

返回：
此内存池的名称。

getType

MemoryType getType()
返回此内存池的类型。

MBeanServer 访问：
MemoryType 的映射类型为 String，值为 MemoryType 的名称。

返回：
此内存池的类型。

getUsage

MemoryUsage getUsage()
返回此内存池的内存使用量的估计数。如果此内存池无效（即不再存在），此方法将返回 null。

此方法请求 Java 虚拟机对此内存池的当前内存使用量进行最佳估算。对于某些内存池，此方法可能是开销很大的操作，需要进行计算以确定估计数。如果是这种情况，实现应该加以注释。

此方法设计用于监视系统内存使用量和检测低内存情况。

MBeanServer 访问：
MemoryUsage 的映射类型为 CompositeData，具有 MemoryUsage 中指定的那些属性。

返回：
MemoryUsage 对象；或者，如果此内存池无效，则返回 null。

getPeakUsage

MemoryUsage getPeakUsage()
返回自 Java 虚拟机启动以来或自峰值重置以来此内存池的峰值内存使用量。如果此内存池无效（即不再存在），此方法将返回 null。

MBeanServer 访问：
MemoryUsage 的映射类型为 CompositeData，具有 MemoryUsage 中指定的那些属性。

返回：
表示峰值内存使用量的 MemoryUsage 对象；或者，如果此内存池无效，则返回 null。

resetPeakUsage

void resetPeakUsage()
将此内存池的峰值内存使用量统计重置为当前内存使用量。

抛出：
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("control")。

isValid

boolean isValid()
测试此内存池在 Java 虚拟机中是否有效。一旦 Java 虚拟机将内存池从内存系统删除，该内存池就变为无效。

返回：
如果内存池在正在运行的 Java 虚拟机中有效，则返回 true；否则返回 false。

getMemoryManagerNames

String[] getMemoryManagerNames()
返回管理此内存池的内存管理器的名称。每个内存池将由至少一个内存管理器进行管理。

返回：
String 对象的一个数组，其中每个对象都是管理此内存池的内存管理器的名称。

getUsageThreshold

long getUsageThreshold()
返回此内存池的使用量阈值（以字节为单位）。每个内存池都具有一个与平台有关的默认阈值。可以通过 setUsageThreshold 方法更改当前的使用量阈值。

返回：
此内存池的使用量阈值（以字节为单位）。
抛出：
UnsupportedOperationException - 如果此内存池不支持使用量阈值。
另请参见：
isUsageThresholdSupported()

setUsageThreshold

void setUsageThreshold(long threshold)
如果此内存池支持使用量阈值，则将此内存池的阈值设置为给定的 threshold 值。如果阈值设置为正数，将启用此内存池中的使用量阈值超过检查。如果设置为零，则将禁用使用量阈值超过检查。

参数：
threshold - 新阈值（以字节为单位）。必须为非负数。
抛出：
IllegalArgumentException - 如果 threshold 为负或大于此内存池的最大内存量（如果已定义）。
UnsupportedOperationException - 如果此内存池不支持使用量阈值。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("control")。
另请参见：
isUsageThresholdSupported(), 使用量阈值

isUsageThresholdExceeded

boolean isUsageThresholdExceeded()
测试此内存池的使用量是否达到或超过其使用量阈值。

返回：
如果此内存池的使用量达到或超过了阈值，则返回 true；否则返回 false。
抛出：
UnsupportedOperationException - 如果此内存池不支持使用量阈值。

getUsageThresholdCount

long getUsageThresholdCount()
返回内存使用量超过其阈值的次数。

返回：
内存使用量超过其阈值的次数。
抛出：
UnsupportedOperationException - 如果此内存池不支持使用量阈值。

isUsageThresholdSupported

boolean isUsageThresholdSupported()
测试此内存池是否支持使用量阈值。

返回：
如果此内存池支持使用量阈值，则返回 true；否则返回 false。

getCollectionUsageThreshold

long getCollectionUsageThreshold()
返回此内存池的回收使用量阈值（以字节为单位）。默认值为零。可以通过 setCollectionUsageThreshold 方法更改回收使用量阈值。

返回：
此内存池的回收使用量阈值（以字节为单位）。
抛出：
UnsupportedOperationException - 如果此内存池不支持回收使用量阈值。
另请参见：
isCollectionUsageThresholdSupported()

setCollectionUsageThreshold

void setCollectionUsageThreshold(long threhsold)
将此内存池的回收使用量阈值设置为给定的 threshold 值。当此阈值设置为正数时，Java 虚拟机将在对此内存池中不使用的对象进行了回收工作后，在最恰当的时间检查内存使用量。

如果阈值设置为正数，将启用此内存池中的回收使用量阈值超过检查。如果设置为零，则将禁用回收使用量阈值超过检查。

参数：
threhsold - 新的回收使用量阈值（以字节为单位）。必须为非负数。
抛出：
IllegalArgumentException - 如果 threshold 为负或大于此内存池的最大内存量（如果已定义）。
UnsupportedOperationException - 如果此内存池不支持回收使用量阈值。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("control")。
另请参见：
isCollectionUsageThresholdSupported(), 回收使用量阈值

isCollectionUsageThresholdExceeded

boolean isCollectionUsageThresholdExceeded()
测试在 Java 虚拟机最近一次回收工作之后，此内存池的内存使用量是否达到或超过了其回收使用量阈值。此方法不会请求 Java 虚拟机执行其正常自动内存管理之外的任何垃圾回收操作。

返回：
如果在最近的回收操作中，此内存池的使用量达到或超过了回收使用阈值，则返回 true；否则返回 false。
抛出：
UnsupportedOperationException - 如果此内存池不支持使用量阈值。

getCollectionUsageThresholdCount

long getCollectionUsageThresholdCount()
返回 Java 虚拟机已检测到内存使用量达到或超过回收使用量阈值的次数。

返回：
内存使用量达到或超过回收使用量阈值的次数。
抛出：
UnsupportedOperationException - 如果此内存池不支持回收使用量阈值。
另请参见：
isCollectionUsageThresholdSupported()

getCollectionUsage

MemoryUsage getCollectionUsage()
返回 Java 虚拟机最近回收了此内存池中的不使用的对象之后的内存使用量。此方法不会请求 Java 虚拟机执行其正常的自动内存管理之外的任何垃圾回收操作。如果 Java 虚拟机不支持此方法，此方法将返回 null。

MBeanServer 访问：
MemoryUsage 的映射类型为 CompositeData，具有 MemoryUsage 中指定的那些属性。

返回：
表示 Java 虚拟机最近对不使用的对象进行了回收之后此内存池的内存使用量的 MemoryUsage；如果不支持此方法，则返回 null。

isCollectionUsageThresholdSupported

boolean isCollectionUsageThresholdSupported()
测试此内存池是否支持回收使用量阈值。

返回：
如果此内存池支持回收使用量阈值，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.lang.management
枚举 MemoryType

java.lang.Object
    继承者  java.lang.Enum<MemoryType>
        继承者  java.lang.management.MemoryType
所有已实现的接口：
Serializable, Comparable<MemoryType>
public enum MemoryType
extends Enum<MemoryType>

内存池的类型。

从以下版本开始：
1.5

枚举常量摘要
HEAP
堆内存类型。
NON_HEAP
非堆内存类型。
方法摘要
String | toString() 返回该 MemoryType 的字符串表示形式。
static MemoryType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MemoryType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

HEAP

public static final MemoryType HEAP
堆内存类型。

Java 虚拟机具有一个堆，堆是运行时数据区域，所有类实例和数组的内存均从此处分配。

NON_HEAP

public static final MemoryType NON_HEAP
非堆内存类型。

Java 虚拟机管理堆之外的内存（称为非堆内存）。非堆内存包括方法区 和 Java 虚拟机的内部处理或优化所需的内存。它存储每个类结构，如运行时常数池、字段和方法数据，以及方法和构造方法的代码。

方法详细信息

values

public static final MemoryType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(MemoryType c : MemoryType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static MemoryType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

toString

public String toString()
返回该 MemoryType 的字符串表示形式。

覆盖：
类 Enum<MemoryType> 中的 toString
返回：
该 MemoryType 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


MemoryUsage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
类 MemoryUsage

java.lang.Object
    继承者  java.lang.management.MemoryUsage

public class MemoryUsage
extends Object

表示内存使用量快照的 MemoryUsage 对象。MemoryUsage 类的实例通常由某些特定的方法构造，这些方法用于获得关于 Java 虚拟机的单个内存池或 Java 虚拟机的全部堆（或非堆）内存的内存使用量信息。

MemoryUsage 对象包含四个值：

    init | 表示 Java 虚拟机在启动期间从操作系统请求的用于内存管理的初始内存容量（以字节为单位）。Java 虚拟机可能在运行过程中从操作系统请求更多的内存，也可能将内存释放给系统。init 的值可以是不明确的。
used | 表示当前已经使用的内存量（以字节为单位）。
committed | 表示保证可以由 Java 虚拟机使用的内存量（以字节为单位）。已提交的内存量可以随时间而变化（增加或减少）。Java 虚拟机可能会将内存释放给系统，committed 可以小于 init。committed 将始终大于或等于 used。
max | 表示可以用于内存管理的最大内存量（以字节为单位）。可以不定义其值。如果定义了该值，最大内存量可能随时间而更改。已使用的内存量和已提交的内存量将始终小于或等于 max（如果定义了 max）。如果内存分配试图增加满足以下条件的已使用内存将会失败：used > committed，即使 used <= max 仍然为 true（例如，当系统的虚拟内存不足时）。
以下是内存池的示例图：

        +----------------------------------------------+
        +////////////////           |                  +
        +////////////////           |                  +
        +----------------------------------------------+

        |--------|
           init
        |---------------|
               used
        |---------------------------|
                  committed
        |----------------------------------------------|
                            max

MXBean 映射

MemoryUsage 映射到 CompositeData，其具有 from 方法中指定的属性。

从以下版本开始：
1.5

构造方法摘要
MemoryUsage(long init, long used, long committed, long max)
构造一个 MemoryUsage 对象。
方法摘要
static MemoryUsage | from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryUsage 对象。
long | getCommitted() 返回已提交给 Java 虚拟机使用的内存量（以字节为单位）。
long | getInit() 返回 Java 虚拟机最初从操作系统请求用于内存管理的内存量（以字节为单位）。
long | getMax() 返回可以用于内存管理的最大内存量（以字节为单位）。
long | getUsed() 返回已使用的内存量（以字节为单位）。
String | toString() 返回此内存使用量的描述性表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MemoryUsage

public MemoryUsage(long init,
                   long used,
                   long committed,
                   long max)
构造一个 MemoryUsage 对象。

参数：
init - Java 虚拟机分配的初始内存量（以字节为单位）；或者，如果未定义，则为 -1。
used - 已经使用的内存量（以字节为单位）。
committed - 已经提交的内存量（以字节为单位）。
max - 可以使用的最大内存量（以字节为单位）；或者，如果未定义，则为 -1。
抛出：
IllegalArgumentException - 如果
  • init 或 max 的值为负数，但不是 -1；或者
  • used 或 committed 的值为负数；或者
  • used 大于 committed 的值；或者
  • committed 大于 max 的值（如果 max 已定义）。
方法详细信息

getInit

public long getInit()
返回 Java 虚拟机最初从操作系统请求用于内存管理的内存量（以字节为单位）。如果没有定义初始内存大小，此方法将返回 -1。

返回：
内存的初始大小（以字节为单位）；如果未定义，则返回 -1。

getUsed

public long getUsed()
返回已使用的内存量（以字节为单位）。

返回：
已使用的内存量（以字节为单位）。

getCommitted

public long getCommitted()
返回已提交给 Java 虚拟机使用的内存量（以字节为单位）。此内存量保证可供 Java 虚拟机使用。

返回：
已提交的内存量（以字节为单位）。

getMax

public long getMax()
返回可以用于内存管理的最大内存量（以字节为单位）。如果没有定义最大内存大小，此方法将返回 -1。

如果此内存量大于已提交的内存量，则不能保证内存管理能够使用此内存量。即使已使用的内存量没有超过这个最大大小，Java 虚拟机也可能会无法分配内存。

返回：
内存的最大量（以字节为单位）；如果未定义，则返回 -1。

toString

public String toString()
返回此内存使用量的描述性表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

from

public static MemoryUsage from(CompositeData cd)
返回由给定 CompositeData 表示的 MemoryUsage 对象。给定的 CompositeData 必须包含以下属性：

属性名称 | 类型
init | java.lang.Long
used | java.lang.Long
committed | java.lang.Long
max | java.lang.Long

参数：
cd - 表示 MemoryUsage 的 CompositeData
返回：
如果 cd 不为 null，则返回由 cd 表示的 MemoryUsage 对象；否则，返回 null。
抛出：
IllegalArgumentException - 如果 cd 不表示具有上述属性的 MemoryUsage。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MonitorInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
类 MonitorInfo

java.lang.Object
    继承者  java.lang.management.LockInfo
        继承者  java.lang.management.MonitorInfo

public class MonitorInfo
extends LockInfo

关于对象监视器锁的信息。当在该对象上输入一个同步块或方法时，则锁定对象监视器。

MXBean 映射

MonitorInfo 将被映射到 CompositeData，并具有 from 方法中指定的属性。

从以下版本开始：
1.6

构造方法摘要
MonitorInfo(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)
构造一个 MonitorInfo 对象。
方法摘要
static MonitorInfo | from(CompositeData cd) 返回给定 CompositeData 表示的 MonitorInfo 对象。
int | getLockedStackDepth() 返回锁定对象监视器的堆栈跟踪中的深度。
StackTraceElement | getLockedStackFrame() 返回锁定对象监视器的堆栈帧。
从类 java.lang.management.LockInfo 继承的方法
getClassName, getIdentityHashCode, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MonitorInfo

public MonitorInfo(String className,
                   int identityHashCode,
                   int stackDepth,
                   StackTraceElement stackFrame)
构造一个 MonitorInfo 对象。

参数：
className - 锁对象的完全限定类名称。
identityHashCode - 锁对象的标识哈希码。
stackDepth - 锁定对象监视器的堆栈跟踪中的深度。
stackFrame - 锁定对象监视器的堆栈帧。
抛出：
IllegalArgumentException - 如果 stackDepth ≥ 0 但 stackFrame 为 null，或者 stackDepth < 0 但 stackFrame 不为 null。
方法详细信息

getLockedStackDepth

public int getLockedStackDepth()
返回锁定对象监视器的堆栈跟踪中的深度。深度是 ThreadInfo.getStackTrace() 方法中返回的 StackTraceElement 数组的索引。

返回：
锁定对象监视器的堆栈跟踪中的深度；如果不可用，则返回一个负数。

getLockedStackFrame

public StackTraceElement getLockedStackFrame()
返回锁定对象监视器的堆栈帧。

返回：
锁定对象监视器的 StackTraceElement；如果不可用，则返回 null。

from

public static MonitorInfo from(CompositeData cd)
返回给定 CompositeData 表示的 MonitorInfo 对象。给定 CompositeData 必须包含以下属性以及 LockInfo 类映射类型中指定的属性：
属性名称 | 类型
lockedStackFrame | ThreadInfo.from 方法中定义的 stackTrace 属性中指定的 CompositeData。
lockedStackDepth | java.lang.Integer

参数：
cd - 表示 MonitorInfo 的 CompositeData
返回：
如果 cd 不为 null，则返回 cd 所表示的 MonitorInfo 对象；否则，返回 null。
抛出：
IllegalArgumentException - 如果 cd 不表示具有上述属性的 MonitorInfo。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperatingSystemMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 OperatingSystemMXBean

public interface OperatingSystemMXBean

用于操作系统的管理接口，Java 虚拟机在此操作系统上运行。

Java 虚拟机具有此接口的实现类的单一实例。实现此接口的实例是一个 MXBean，可以通过调用 ManagementFactory.getOperatingSystemMXBean() 方法或从平台 MBeanServer 方法获得。

用于在 MBeanServer 中唯一标识操作系统的 MXBean 的 ObjectName 为：

java.lang:type=OperatingSystem

此接口定义了几种便捷方法，可使用这些方法访问关于操作系统（Java 虚拟机在其上运行）的系统属性。

从以下版本开始：
1.5
另请参见：
JMX Specification., 访问 MXBeans 的方式

方法摘要
String | getArch() 返回操作系统的架构。
int | getAvailableProcessors() 返回 Java 虚拟机可以使用的处理器数目。
String | getName() 返回操作系统名称。
double | getSystemLoadAverage() 返回最后一分钟内系统加载平均值。
String | getVersion() 返回操作系统的版本。

方法详细信息

getName

String getName()
返回操作系统名称。此方法等效于 System.getProperty("os.name")。

返回：
操作系统名称。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getArch

String getArch()
返回操作系统的架构。此方法等效于 System.getProperty("os.arch")。

返回：
操作系统的架构。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getVersion

String getVersion()
返回操作系统的版本。此方法等效于 System.getProperty("os.version")。

返回：
操作系统的版本。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getAvailableProcessors

int getAvailableProcessors()
返回 Java 虚拟机可以使用的处理器数目。此方法等效于 Runtime.availableProcessors() 方法。

该值在特定的虚拟机调用期间可能发生更改。

返回：
虚拟机可用的处理器数目；不能小于 1。

getSystemLoadAverage

double getSystemLoadAverage()
返回最后一分钟内系统加载平均值。系统加载平均值是排队到可用处理器的可运行实体数目与可用处理器上可运行实体数目的总和在某一段时间进行平均的结果。计算加载平均值的方式是特定于操作系统的，但通常是衰减的与时间相关的平均值。

如果加载平均值不可用，则返回负值。

设计此方法的目的是提供关于系统加载的提示，还可以频繁地查询此方法。加载平均值在某些平台上可能是不可用的，在这些平台上实现此方法代价太高。

返回：
系统加载平均值；如果加载平均值不可用，则返回负值。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RuntimeMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 RuntimeMXBean

public interface RuntimeMXBean

Java 虚拟机的运行时系统的管理接口。

Java 虚拟机具有此接口的实现类的单一实例。实现此接口的实例是一个 MXBean，它可以通过调用 ManagementFactory.getRuntimeMXBean() 方法或从平台 MBeanServer 方法获得。

在 MBeanServer 中唯一标识运行时系统的 MXBean 的 ObjectName 为：

java.lang:type=Runtime

此接口定义了几种便捷的方法，可用于访问有关 Java 虚拟机的系统属性。

从以下版本开始：
1.5
另请参见：
JMX Specification., 访问 MXBeans 的方式

方法摘要
String | getBootClassPath() 返回由引导类加载器用于搜索类文件的引导类路径。
String | getClassPath() 返回系统类加载器用于搜索类文件的 Java 类路径。
List<String> | getInputArguments() 返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。
String | getLibraryPath() 返回 Java 库路径。
String | getManagementSpecVersion() 返回正在运行的 Java 虚拟机实现的管理接口的规范版本。
String | getName() 返回表示正在运行的 Java 虚拟机的名称。
String | getSpecName() 返回 Java 虚拟机规范名称。
String | getSpecVendor() 返回 Java 虚拟机规范供应商。
String | getSpecVersion() 返回 Java 虚拟机规范版本。
long | getStartTime() 返回 Java 虚拟机的启动时间（以毫秒为单位）。
Map<String,String> | getSystemProperties() 返回所有系统属性的名称和值的映射。
long | getUptime() 返回 Java 虚拟机的正常运行时间（以毫秒为单位）。
String | getVmName() 返回 Java 虚拟机实现名称。
String | getVmVendor() 返回 Java 虚拟机实现供应商。
String | getVmVersion() 返回 Java 虚拟机实现版本。
boolean | isBootClassPathSupported() 测试 Java 虚拟机是否支持由引导类加载器用于搜索类文件的引导类路径机制。

方法详细信息

getName

String getName()
返回表示正在运行的 Java 虚拟机的名称。返回的名称字符串可以为任何任意字符串，Java 虚拟机实现可以选择在返回的名称字符串中嵌入特定于平台的有用信息。每个正在的运行的虚拟机可以具有不同的名称。

返回：
表示正在运行的 Java 虚拟机的名称。

getVmName

String getVmName()
返回 Java 虚拟机实现名称。此方法等效于 System.getProperty("java.vm.name")。

返回：
Java 虚拟机实现名称。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getVmVendor

String getVmVendor()
返回 Java 虚拟机实现供应商。此方法等效于 System.getProperty("java.vm.vendor")。

返回：
Java 虚拟机实现供应商。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getVmVersion

String getVmVersion()
返回 Java 虚拟机实现版本。此方法等效于 System.getProperty("java.vm.version")。

返回：
Java 虚拟机实现版本。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getSpecName

String getSpecName()
返回 Java 虚拟机规范名称。此方法等效于 System.getProperty("java.vm.specification.name")。

返回：
Java 虚拟机规范名称。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getSpecVendor

String getSpecVendor()
返回 Java 虚拟机规范供应商。此方法等效于 System.getProperty("java.vm.specification.vendor")。

返回：
Java 虚拟机规范供应商。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getSpecVersion

String getSpecVersion()
返回 Java 虚拟机规范版本。此方法等效于 System.getProperty("java.vm.specification.version")。

返回：
Java 虚拟机规范版本。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getManagementSpecVersion

String getManagementSpecVersion()
返回正在运行的 Java 虚拟机实现的管理接口的规范版本。

返回：
正在运行的 Java 虚拟机实现的管理接口的规范版本。

getClassPath

String getClassPath()
返回系统类加载器用于搜索类文件的 Java 类路径。此方法等效于 System.getProperty("java.class.path")。

Java 类路径中的多个路径由所监视的 Java 虚拟机平台的路径分隔符字符进行分隔。

返回：
Java 类路径。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

getLibraryPath

String getLibraryPath()
返回 Java 库路径。此方法等效于 System.getProperty("java.library.path")。

Java 库路径中的多个路径由所监视的 Java 虚拟机平台的路径分隔符字符进行分隔。

返回：
Java 库路径。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问此系统属性。
另请参见：
SecurityManager.checkPropertyAccess(java.lang.String), System.getProperty(java.lang.String)

isBootClassPathSupported

boolean isBootClassPathSupported()
测试 Java 虚拟机是否支持由引导类加载器用于搜索类文件的引导类路径机制。

返回：
如果 Java 虚拟机支持此类路径机制，则返回 true；否则返回 false。

getBootClassPath

String getBootClassPath()
返回由引导类加载器用于搜索类文件的引导类路径。

引导类路径中的多个路径由平台（Java 虚拟机在其上运行）的路径分隔符字符进行分隔。

Java 虚拟机实现可能不支持引导类加载器用于搜索类文件的引导类路径机制。isBootClassPathSupported() 方法可用于确定 Java 虚拟机是否支持此方法。

返回：
引导类路径。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持此操作。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。

getInputArguments

List<String> getInputArguments()
返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。如果没有传递给 Java 虚拟机的输入变量，则此方法将返回一个空列表。

有些 Java 虚拟机实现可能从多个不同源获取输入变量：例如，从启动 Java 虚拟机的应用程序传递的变量，如“java”命令、环境变量、配置文件等。

通常，并非所有的“java”命令的命令行选项都会传递给 Java 虚拟机。因此，返回的输入变量中可能不包括所有命令行选项。

MBeanServer 访问：
List 的映射类型为 String[]。

返回：
String 对象列表；每个元素都是传递给 Java 虚拟机的变量。
抛出：
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。

getUptime

long getUptime()
返回 Java 虚拟机的正常运行时间（以毫秒为单位）。

返回：
Java 虚拟机的正常运行时间（以毫秒为单位）。

getStartTime

long getStartTime()
返回 Java 虚拟机的启动时间（以毫秒为单位）。此方法返回 Java 虚拟机启动的近似时间。

返回：
Java 虚拟机的启动时间（以毫秒为单位）。

getSystemProperties

Map<String,String> getSystemProperties()
返回所有系统属性的名称和值的映射。此方法将调用 System.getProperties() 来获取所有系统属性。省略名称或值不为 String 的属性。

MBeanServer 访问：
Map 的映射类型为每行具有两个项的 TabularData，如下所示：

项名称 | 项类型
key | String
value | String

返回：
所有系统属性的名称和值的映射。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPropertiesAccess 方法不允许访问系统属性。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.management
类 ThreadInfo

java.lang.Object
    继承者  java.lang.management.ThreadInfo

public class ThreadInfo
extends Object

线程信息。ThreadInfo 包含有关线程的信息，包括：

常规线程信息

  • 线程 ID。
  • 线程名称。

执行信息

  • 线程状态。
  • 由于以下原因阻塞线程的对象：
    • 等待进入同步块/方法，或者
    • 等待 Object.wait 方法的通知，或者
    • 由于 LockSupport.park 调用而暂停。
  • 拥有阻塞线程对象的线程的 ID。
  • 线程的堆栈跟踪。
  • 线程锁定的对象监视器列表。
  • 线程锁定的可拥有同步器列表。

同步统计数据

  • 由于同步或等待通知而阻塞线程的次数。
  • 从启动线程争用监视开始，由于同步或等待通知而阻塞线程的累计时间。某些 Java 虚拟机实现可能不支持此功能。ThreadMXBean.isThreadContentionMonitoringSupported() 方法可用于确定 Java 虚拟机是否支持此功能。

此线程信息类设计用于监视系统，不用于同步控制。

MXBean 映射

ThreadInfo 映射到一个具有 from 方法中指定属性的 CompositeData。

从以下版本开始：
1.5
另请参见：
ThreadMXBean.getThreadInfo(long), ThreadMXBean.dumpAllThreads(boolean, boolean)

方法摘要
static ThreadInfo | from(CompositeData cd) 返回由给定 CompositeData 表示的 ThreadInfo 对象。
long | getBlockedCount() 返回与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的总次数。
long | getBlockedTime() 返回自从启用线程争用监视以来，与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的近似累计时间（以毫秒为单位）。
MonitorInfo[] | getLockedMonitors() 返回 MonitorInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的对象监视器。
LockInfo[] | getLockedSynchronizers() 返回 LockInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的可拥有同步器。
LockInfo | getLockInfo() 返回对象的 LockInfo，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
String | getLockName() 返回对象的字符串表示形式，与此 ThreadInfo 关联的线程被锁定并等待该对象。
long | getLockOwnerId() 返回拥有对象的线程的 ID，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
String | getLockOwnerName() 返回拥有对象的线程的名称，与此 ThreadInfo 关联的线程被阻塞并等待该对象。
StackTraceElement[] | getStackTrace() 返回与此 ThreadInfo 关联的线程的堆栈跟踪。
long | getThreadId() 返回与此 ThreadInfo 关联的线程的 ID。
String | getThreadName() 返回与此 ThreadInfo 关联的线程的名称。
Thread.State | getThreadState() 返回与此 ThreadInfo 关联的线程的状态。
long | getWaitedCount() 返回与此 ThreadInfo 关联的线程等待通知的总次数。
long | getWaitedTime() 返回自从启用线程争用监视以来,与此 ThreadInfo 关联的线程等待通知的近似累计时间（以毫秒为单位）。
boolean | isInNative() 测试与此 ThreadInfo 关联的线程是否通过 Java 本机接口 (JNI) 执行本机代码。
boolean | isSuspended() 测试与此 ThreadInfo 关联的线程是否被挂起。
String | toString() 返回此线程信息的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getThreadId

public long getThreadId()
返回与此 ThreadInfo 关联的线程的 ID。

返回：
关联线程的 ID。

getThreadName

public String getThreadName()
返回与此 ThreadInfo 关联的线程的名称。

返回：
关联线程的名称。

getThreadState

public Thread.State getThreadState()
返回与此 ThreadInfo 关联的线程的状态。

返回：
关联线程的 Thread.State。

getBlockedTime

public long getBlockedTime()
返回自从启用线程争用监视以来，与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的近似累计时间（以毫秒为单位）。即自从上次启用线程争用监视以来，线程处于 BLOCKED 状态的总累计时间。如果线程争用监视被禁用，此方法将返回 -1。

Java 虚拟机可能会使用高精度计时器测量时间。当重新启用线程争用监视时，将重置这个统计数据。

返回：
线程进入 BLOCKED 状态的近似累计时间（以毫秒为单位）；如果禁用了线程争用监视，则返回 -1。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持此操作。
另请参见：
ThreadMXBean.isThreadContentionMonitoringSupported(), ThreadMXBean.setThreadContentionMonitoringEnabled(boolean)

getBlockedCount

public long getBlockedCount()
返回与此 ThreadInfo 关联的线程被阻塞进入或重进入监视器的总次数。即线程为 BLOCKED 状态的次数。

返回：
线程进入 BLOCKED 状态的总次数。

getWaitedTime

public long getWaitedTime()
返回自从启用线程争用监视以来,与此 ThreadInfo 关联的线程等待通知的近似累计时间（以毫秒为单位）。即自从启用线程争用监视以来，线程处于 WAITING 或 TIMED_WAITING 状态的总累计时间。如果线程争用监视被禁用，此方法将返回 -1。

Java 虚拟机可能会使用高精度计时器测量时间。当重新启用线程争用监视时，将重置这个统计数据。

返回：
线程为 WAITING 或 TIMED_WAITING 状态的近似累计时间（以毫秒为单位）；如果禁用了线程争用监视，则返回 -1。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持此操作。
另请参见：
ThreadMXBean.isThreadContentionMonitoringSupported(), ThreadMXBean.setThreadContentionMonitoringEnabled(boolean)

getWaitedCount

public long getWaitedCount()
返回与此 ThreadInfo 关联的线程等待通知的总次数。即线程处于 WAITING 或 TIMED_WAITING 状态的次数。

返回：
线程处于 WAITING 或 TIMED_WAITING 状态的总次数。

getLockInfo

public LockInfo getLockInfo()
返回对象的 LockInfo，与此 ThreadInfo 关联的线程被阻塞并等待该对象。 线程可以被阻塞并等待以下内容之一：
  • 进入或重进入同步块/方法所需的对象监视器。
    线程处于 BLOCKED 状态，等待进入 synchronized 语句或方法。

  • 被另一个线程通知的对象监视器。
    由于调用 Object.wait 方法，线程处于 WAITING 或 TIMED_WAITING 状态。

  • 导致线程暂停的同步对象。
    由于调用 LockSupport.park 方法，线程处于 WAITING 或 TIMED_WAITING 状态。同步对象是从 LockSupport.getBlocker 方法返回的对象。通常，它是一个可拥有同步器或 Condition。

如果线程不处于以上任何状态之一，那么此方法返回 null。

返回：
对象的 LockInfo，线程将锁定并等待该对象（如果有）；否则返回 null。
从以下版本开始：
1.6

getLockName

public String getLockName()
返回对象的字符串表示形式，与此 ThreadInfo 关联的线程被锁定并等待该对象。此方法等效于调用：
  getLockInfo().toString()

如果此线程没有被阻塞并等待任何对象，或者没有任何线程拥有该对象，那么此方法将返回 null。

返回：
对象的字符串表示形式，线程在该对象上被阻塞（如果有）；否则返回 null。
另请参见：
getLockInfo()

getLockOwnerId

public long getLockOwnerId()
返回拥有对象的线程的 ID，与此 ThreadInfo 关联的线程被阻塞并等待该对象。如果此线程没有被阻塞并等待任何对象，或者没有任何线程拥有该对象，那么此方法将返回 -1。

返回：
对象（此线程在其上阻塞）所有者线程的线程 ID；如果此线程没有被阻塞，或者没有任何线程拥有该对象，则返回 -1。
另请参见：
getLockInfo()

getLockOwnerName

public String getLockOwnerName()
返回拥有对象的线程的名称，与此 ThreadInfo 关联的线程被阻塞并等待该对象。如果此线程没有被阻塞并等待任何对象，或者没有任何线程拥有该对象，那么此方法将返回 null。

返回：
拥有对象（此线程在其上阻塞）的线程的名称；如果此线程没有被阻塞，或者没有任何线程拥有该对象，则返回 null。
另请参见：
getLockInfo()

getStackTrace

public StackTraceElement[] getStackTrace()
返回与此 ThreadInfo 关联的线程的堆栈跟踪。如果没有为此线程信息请求堆栈跟踪，此方法将返回长度为 0 的数组。若返回的数组不是长度为 0 的数组，则其第一个元素代表堆栈顶，它是该序列中最新的方法调用。最后一个元素代表堆栈底，是该序列中最旧的方法调用。

某些 Java 虚拟机在某些情况下可能会从堆栈跟踪中忽略一个或多个堆栈帧。在极端情况下，没有关于此 ThreadInfo 关联线程堆栈跟踪信息的虚拟机可以从此方法返回一个长度为 0 的数组。

返回：
线程的 StackTraceElement 对象数组。

isSuspended

public boolean isSuspended()
测试与此 ThreadInfo 关联的线程是否被挂起。如果已经调用了 Thread.suspend() 方法，此方法将返回 true。

返回：
如果线程被挂起，则返回 true；否则返回 false。

isInNative

public boolean isInNative()
测试与此 ThreadInfo 关联的线程是否通过 Java 本机接口 (JNI) 执行本机代码。JNI 本机代码不包括虚拟机支持代码或由虚拟机生成的已编译本机代码。

返回：
如果线程执行本机代码，则返回 true；否则返回 false。

toString

public String toString()
返回此线程信息的字符串表示形式。此字符串的格式取决于实现。 返回的字符串通常包括线程名、线程 ID、它的状态、堆栈跟踪（如果有）。

覆盖：
类 Object 中的 toString
返回：
此线程信息的字符串表示形式。

from

public static ThreadInfo from(CompositeData cd)
返回由给定 CompositeData 表示的 ThreadInfo 对象。除非上文另行指定，否则给定的 CompositeData 必须包含以下属性：
属性名称 | 类型
threadId | java.lang.Long
threadName | java.lang.String
threadState | java.lang.String
suspended | java.lang.Boolean
inNative | java.lang.Boolean
blockedCount | java.lang.Long
blockedTime | java.lang.Long
waitedCount | java.lang.Long
waitedTime | java.lang.Long
lockInfo javax.management.openmbean.CompositeData - MXBean 类型映射规则中指定的 LockInfo 的映射类型。

如果 cd 不包含此属性，则将根据 lockName 属性的值构造 LockInfo 对象。

lockName | java.lang.String
lockOwnerId | java.lang.Long
lockOwnerName | java.lang.String
stackTrace javax.management.openmbean.CompositeData[]

每个元素都是表示 StackTraceElement 的 CompositeData，包含以下属性：

属性名称 | 类型
className | java.lang.String
methodName | java.lang.String
fileName | java.lang.String
lineNumber | java.lang.Integer
nativeMethod | java.lang.Boolean
lockedMonitors javax.management.openmbean.CompositeData[]，其元素类型是 MonitorInfo 的映射类型，MonitorInfo 在 Monitor.from 方法中指定。

如果 cd 不包含此属性，那么此属性将被设置为空数组。

lockedSynchronizers javax.management.openmbean.CompositeData[]，其元素是 LockInfo 的映射类型，LockInfo 在 MXBean 的类型映射规则中指定。

如果 cd 不包含此属性，那么此属性将被设置为空数组。

参数：
cd - 表示 ThreadInfo 的 CompositeData
返回：
如果 cd 不为 null，则返回由 cd 表示的 ThreadInfo 对象；否则返回 null。
抛出：
IllegalArgumentException - 如果 cd 不表示具有上述属性的 ThreadInfo。

getLockedMonitors

public MonitorInfo[] getLockedMonitors()
返回 MonitorInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的对象监视器。 如果没有为此线程信息请求任何锁定的监视器，或者线程没有锁定任何监视器，那么此方法返回长度为 0 的数组。

返回：
MonitorInfo 对象数组，表示线程锁定的对象监视器。
从以下版本开始：
1.6

getLockedSynchronizers

public LockInfo[] getLockedSynchronizers()
返回 LockInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的可拥有同步器。 如果没有为此线程信息请求任何锁定的同步器，或者线程没有锁定任何同步器，那么此方法返回长度为 0 的数组。

返回：
LockInfo 对象数组，表示线程锁定的可拥有同步器。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadMXBean (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.management
接口 ThreadMXBean

public interface ThreadMXBean

Java 虚拟机线程系统的管理接口。

Java 虚拟机具有此接口的实现类的单一实例。实现此接口的实例是一个 MXBean，可以通过调用 ManagementFactory.getThreadMXBean() 方法或从平台 MBeanServer 方法获得它。

在 MBeanServer 内唯一标识线程系统的 MXBean 的 ObjectName 是：

java.lang:type=Threading

线程 ID

线程 ID 是一个通过调用线程的 Thread.getId() 方法返回的 long 型正值。线程 ID 在其生存期间是唯一的。线程终止时，该线程 ID 可以被重新使用。

此接口中的某些方法将线程 ID 或线程 ID 数组作为输入参数，并返回每个线程的信息。

线程 CPU 时间

Java 虚拟机实现可能支持测量当前线程的 CPU 时间、测量任何线程的 CPU 时间，或者有可能不测量任何线程的 CPU 时间。

isThreadCpuTimeSupported() 方法可用于确定 Java 虚拟机是否支持测量任何线程的 CPU 时间。isCurrentThreadCpuTimeSupported() 方法可用于确定 Java 虚拟机是否支持测量当前线程的 CPU 时间。支持任何线程 CPU 时间测量的 Java 虚拟机实现也支持当前线程的 CPU 时间测量。

此接口提供的 CPU 时间具有毫微秒精度，但并不具有毫微秒的准确性。

Java 虚拟机可能默认禁用 CPU 时间测量。isThreadCpuTimeEnabled() 和 setThreadCpuTimeEnabled(boolean) 方法可用于测试是否启用 CPU 时间测量，并且可以分别启用/禁用此支持。启用线程 CPU 测量在某些 Java 虚拟机实现中可能开销很大。

线程争用监视

某些 Java 虚拟机可能支持线程争用监视。当启用线程争用监视时，将收集由于同步而受阻塞的线程累积时间和等待通知的线程累积时间，并在 ThreadInfo 对象中返回它们。

isThreadContentionMonitoringSupported() 方法可用于确定 Java 虚拟机是否支持线程争用监视。默认情况下，线程争用监视是禁用的。setThreadContentionMonitoringEnabled(boolean) 方法可用于启用线程争用监视。

同步信息和死锁检测

一些 Java 虚拟机可以支持使用对象监视器和使用可拥有同步器的监视。getThreadInfo(long[], boolean, boolean) 和 dumpAllThreads(boolean, boolean) 方法可以用来获取线程堆栈跟踪和同步信息，这些信息包括在获得线程时被哪一个锁阻塞或者正在等待哪一个锁，以及线程当前拥有哪些锁。

ThreadMXBean 接口提供 findMonitorDeadlockedThreads() 和 findDeadlockedThreads() 方法，这些方法用于在运行的应用程序中查找死锁。

从以下版本开始：
1.5
另请参见：
JMX Specification., 访问 MXBeans 的方式

方法摘要
ThreadInfo[] | dumpAllThreads(boolean lockedMonitors, boolean lockedSynchronizers) 返回所有活动线程的线程信息，并带有堆栈跟踪和同步信息。
long[] | findDeadlockedThreads() 查找因为等待获得对象监视器或可拥有同步器而处于死锁状态的线程循环。
long[] | findMonitorDeadlockedThreads() 找到处于死锁状态（等待获取对象监视器）的线程的周期。
long[] | getAllThreadIds() 返回活动线程 ID。
long | getCurrentThreadCpuTime() 返回当前线程的总 CPU 时间（以毫微秒为单位）。
long | getCurrentThreadUserTime() 返回当前线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。
int | getDaemonThreadCount() 返回活动守护线程的当前数目。
int | getPeakThreadCount() 返回自从 Java 虚拟机启动或峰值重置以来峰值活动线程计数。
int | getThreadCount() 返回活动线程的当前数目，包括守护线程和非守护线程。
long | getThreadCpuTime(long id) 返回指定 ID 的线程的总 CPU 时间（以毫微秒为单位）。
ThreadInfo | getThreadInfo(long id) 返回指定 id 的不具有堆栈跟踪的线程的线程信息。
ThreadInfo[] | getThreadInfo(long[] ids) 返回其 ID 在输出数组 ids 中的每个线程的线程信息，这些线程不具有堆栈跟踪。
ThreadInfo[] | getThreadInfo(long[] ids, boolean lockedMonitors, boolean lockedSynchronizers) 返回每个线程的线程信息，线程 ID 位于输入数组 ids 中，带有堆栈跟踪和同步信息。
ThreadInfo[] | getThreadInfo(long[] ids, int maxDepth) 返回其 ID 在输入数组 ids 中的每个线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
ThreadInfo | getThreadInfo(long id, int maxDepth) 返回指定 id 的线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
long | getThreadUserTime(long id) 返回指定 ID 的线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。
long | getTotalStartedThreadCount() 返回自从 Java 虚拟机启动以来创建和启动的线程总数目。
boolean | isCurrentThreadCpuTimeSupported() 测试 Java 虚拟机是否支持当前线程的 CPU 时间测量。
boolean | isObjectMonitorUsageSupported() 测试 Java 虚拟机是否支持使用对象监视器的监视。
boolean | isSynchronizerUsageSupported() 测试 Java 虚拟机是否支持使用 可拥有同步器的监视。
boolean | isThreadContentionMonitoringEnabled() 测试是否启用了线程争用监视。
boolean | isThreadContentionMonitoringSupported() 测试 Java 虚拟机是否支持线程争用监视。
boolean | isThreadCpuTimeEnabled() 测试是否启用了线程 CPU 时间测量。
boolean | isThreadCpuTimeSupported() 测试 Java 虚拟机实现是否支持任何线程的 CPU 时间测量。
void | resetPeakThreadCount() 将峰值线程计数重置为当前活动线程的数量。
void | setThreadContentionMonitoringEnabled(boolean enable) 启用或禁用线程争用监视。
void | setThreadCpuTimeEnabled(boolean enable) 启用或禁用线程 CPU 时间测量。

方法详细信息

getThreadCount

int getThreadCount()
返回活动线程的当前数目，包括守护线程和非守护线程。

返回：
活动线程的当前数目。

getPeakThreadCount

int getPeakThreadCount()
返回自从 Java 虚拟机启动或峰值重置以来峰值活动线程计数。

返回：
峰值活动线程计数。

getTotalStartedThreadCount

long getTotalStartedThreadCount()
返回自从 Java 虚拟机启动以来创建和启动的线程总数目。

返回：
已启动的线程的总数。

getDaemonThreadCount

int getDaemonThreadCount()
返回活动守护线程的当前数目。

返回：
活动守护线程的当前数目。

getAllThreadIds

long[] getAllThreadIds()
返回活动线程 ID。在返回的数组中包含的某些线程可能在此方法返回时已经终止。

返回：
long 数组，每个成员都是线程 ID。
抛出：
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。

getThreadInfo

ThreadInfo getThreadInfo(long id)
返回指定 id 的不具有堆栈跟踪的线程的线程信息。此方法等效于调用：
getThreadInfo(id, 0);

此方法返回表示指定 ID 的线程的线程信息的 ThreadInfo 对象。返回的 ThreadInfo 对象中的堆栈跟踪、锁定的监视器、锁定的同步器将为空。 如果给定 ID 的线程没有处于活动状态，或不存在，则此方法将返回 null。如果线程已经启动且尚未终止，则该线程处于活动状态。

MBeanServer 访问：
ThreadInfo 的映射类型为 CompositeData，并具有 ThreadInfo.from 方法指定的那些属性。

参数：
id - 线程的线程 ID。必须为正数。
返回：
给定 ID 的线程的 ThreadInfo 对象，不带堆栈跟踪、锁定的监视器和同步器信息；如果给定 ID 的线程没有处于活动状态，或不存在，则返回 null。
抛出：
IllegalArgumentException - 如果 id <= 0。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。

getThreadInfo

ThreadInfo[] getThreadInfo(long[] ids)
返回其 ID 在输出数组 ids 中的每个线程的线程信息，这些线程不具有堆栈跟踪。此方法等效于调用：
   getThreadInfo(ids, 0);

此方法返回 ThreadInfo 对象数组。每个 ThreadInfo 对象中的堆栈跟踪、锁定的监视器、锁定的同步器将为空。 如果给定 ID 的线程没有处于活动状态，或不存在，则返回数组中的对应元素将包含 null。如果线程已经启动且尚未终止，则该线程处于活动状态。

MBeanServer 访问：
ThreadInfo 的映射类型为 CompositeData，具有 ThreadInfo.from 方法指定的那些属性。

参数：
ids - 线程 ID 数组。
返回：
一个 ThreadInfo 对象的数组，每个数组元素均包含关于线程的信息，该线程 ID 在 ID 输入数组的对应元素中，不带堆栈跟踪、锁定的监视器和同步器信息。
抛出：
IllegalArgumentException - 如果输入数组 ids 中的任何元素 <= 0。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。

getThreadInfo

ThreadInfo getThreadInfo(long id,
                         int maxDepth)
返回指定 id 的线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。maxDepth 参数指示可从堆栈跟踪获取的 StackTraceElement 的最大数目。如果 maxDepth == Integer.MAX_VALUE，则将转储线程的整个堆栈跟踪。如果 maxDepth == 0，则不转储线程的任何堆栈跟踪。此方法不获取线程的锁定的监视器和锁定同步器。

当 Java 虚拟机没有关于线程的堆栈跟踪信息或 maxDepth == 0 时，ThreadInfo 对象中的堆栈跟踪将为空的 StackTraceElement 数组。

如果给定 ID 的线程没有处于活动状态，或不存在，则此方法将返回 null。如果线程已经启动且尚未终止，则该线程处于活动状态。

MBeanServer 访问：
ThreadInfo 的映射类型为 CompositeData，具有 ThreadInfo.from 方法指定的那些属性。

参数：
id - 线程的线程 ID。必须为正数。
maxDepth - 要转储的堆栈跟踪中的最大项数。Integer.MAX_VALUE 可用于请求将整个堆栈转储。
返回：
给定 ID 的线程的 ThreadInfo，不带锁定的监视器和同步器信息。如果给定 ID 的线程没有处于活动状态，或不存在，则返回 null。
抛出：
IllegalArgumentException - 如果 id <= 0。
IllegalArgumentException - 如果 maxDepth 为负数。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。

getThreadInfo

ThreadInfo[] getThreadInfo(long[] ids,
                           int maxDepth)
返回其 ID 在输入数组 ids 中的每个线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。maxDepth 参数指示可从堆栈跟踪获取的 StackTraceElement 的最大数目。如果 maxDepth == Integer.MAX_VALUE，则将转储线程的整个堆栈跟踪。如果 maxDepth == 0，则不转储线程的任何堆栈跟踪。此方法不获取线程的锁定的监视器和锁定同步器。

当 Java 虚拟机没有关于线程的堆栈跟踪信息或 maxDepth == 0 时，ThreadInfo 对象中的堆栈跟踪将为空的 StackTraceElement 数组。

此方法返回一个 ThreadInfo 对象的数组，其每个成员均为关于线程的线程信息，索引顺序与 ids 数组中索引相同。如果给定 ID 的线程没有处于活动状态，或不存在，则返回数组中的对应元素将设置为 null。如果线程已经启动且尚未终止，则该线程处于活动状态。

MBeanServer 访问：
ThreadInfo 的映射类型为 CompositeData，具有 ThreadInfo.from 方法指定的那些属性。

参数：
ids - 线程 ID 数组
maxDepth - 要转储的堆栈跟踪中的最大项数。Integer.MAX_VALUE 可用于请求将整个堆栈转储。
返回：
一个 ThreadInfo 对象组成的数组，每个数组元素均包含关于线程的信息，该线程 ID 在 ID 输入数组的对应元素中，不带锁定的监视器和同步器信息。
抛出：
IllegalArgumentException - 如果 maxDepth 为负数。
IllegalArgumentException - 如果输入数组 ids 中的任何元素 <= 0。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。

isThreadContentionMonitoringSupported

boolean isThreadContentionMonitoringSupported()
测试 Java 虚拟机是否支持线程争用监视。

返回：
如果 Java 虚拟机支持线程争用监视，则返回 true；否则返回 false。

isThreadContentionMonitoringEnabled

boolean isThreadContentionMonitoringEnabled()
测试是否启用了线程争用监视。

返回：
如果启用了线程争用监视，则返回 true；否则返回 false。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持线程争用监视。
另请参见：
isThreadContentionMonitoringSupported()

setThreadContentionMonitoringEnabled

void setThreadContentionMonitoringEnabled(boolean enable)
启用或禁用线程争用监视。默认情况下，线程争用监视是被禁用的。

参数：
enable - 为 true 则启用；为 false 则禁用。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持线程争用监视。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("control")。
另请参见：
isThreadContentionMonitoringSupported()

getCurrentThreadCpuTime

long getCurrentThreadCpuTime()
返回当前线程的总 CPU 时间（以毫微秒为单位）。返回的值具有毫微秒的精度，但不具有毫微秒的准确度。如果实现对用户模式时间和系统模式时间加以区别，则返回的 CPU 时间为当前线程在用户模式或系统模式中执行的时间总量。

这是一个便于局部管理的方法，等效于调用：

   getThreadCpuTime(Thread.currentThread().getId());

返回：
如果启用了 CPU 时间测量，则返回当前线程的总 CPU 时间；否则返回 -1。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持当前线程的 CPU 时间测量。
另请参见：
getCurrentThreadUserTime(),
isCurrentThreadCpuTimeSupported(),
isThreadCpuTimeEnabled(),
setThreadCpuTimeEnabled(boolean)

getCurrentThreadUserTime

long getCurrentThreadUserTime()
返回当前线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。返回的具有毫微秒的精度，但不具有毫微秒的准确度。

这是一个便于局部管理的方法，等效于调用：

   getThreadUserTime(Thread.currentThread().getId());

返回：
如果启用了 CPU 时间测量，则返回当前线程的用户级 CPU 时间；否则返回 -1。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持当前线程的 CPU 时间测量。
另请参见：
getCurrentThreadCpuTime(),
isCurrentThreadCpuTimeSupported(),
isThreadCpuTimeEnabled(),
setThreadCpuTimeEnabled(boolean)

getThreadCpuTime

long getThreadCpuTime(long id)
返回指定 ID 的线程的总 CPU 时间（以毫微秒为单位）。返回的值具有毫微秒的精度，但不具有毫微秒的准确度。如果实现对用户模式时间和系统模式时间加以区别，返回的 CPU 时间则为线程在用户模式或系统模式中执行的时间总量。

如果指定 ID 的线程没有处于活动状态，或不存在，则此方法将返回 -1。如果 CPU 时间测量，此方法将返回 -1。如果线程已经启动且尚未终止，则该线程处于活动状态。

如果线程启动后启用了 CPU 时间测量，Java 虚拟机实现可能选择任何时间作为启动 CPU 时间测量的时间，包括启用此功能的时间。

参数：
id - 线程的线程 ID
返回：
如果指定的 ID 存在，线程为活动状态，且启用了 CPU 时间测量，则返回指定 ID 的线程的总 CPU 时间；否则返回 -1。
抛出：
IllegalArgumentException - 如果 id <= 0。
UnsupportedOperationException - 如果 Java 虚拟机不支持其他线程的 CPU 时间测定。
另请参见：
getThreadUserTime(long),
isThreadCpuTimeSupported(),
isThreadCpuTimeEnabled(),
setThreadCpuTimeEnabled(boolean)

getThreadUserTime

long getThreadUserTime(long id)
返回指定 ID 的线程在用户模式中执行的 CPU 时间（以毫微秒为单位）。返回的值具有毫微秒的精度，但未必具有毫微秒的准确度。

如果指定 ID 的线程没有处于活动状态，或不存在，则此方法将返回 -1。如果禁用 CPU 时间测量，此方法将返回 -1。如果线程已经启动且尚未终止，则该线程处于活动状态。

如果线程启动后启用了 CPU 时间测量，Java 虚拟机实现可能选择任何时间作为启动 CPU 时间测量的时间，包括启用此功能的时间。

参数：
id - 线程的线程 ID
返回：
如果指定的 ID 存在，线程为活动状态，且启用了 CPU 时间测量，则返回指定 ID 的线程的用户级 CPU 时间；否则返回 -1。
抛出：
IllegalArgumentException - 如果 id <= 0。
UnsupportedOperationException - 如果 Java 虚拟机不支持其他线程的 CPU 时间测定。
另请参见：
getThreadCpuTime(long),
isThreadCpuTimeSupported(),
isThreadCpuTimeEnabled(),
setThreadCpuTimeEnabled(boolean)

isThreadCpuTimeSupported

boolean isThreadCpuTimeSupported()
测试 Java 虚拟机实现是否支持任何线程的 CPU 时间测量。支持任何线程 CPU 时间测定的 Java 虚拟机实现也支持当前线程的 CPU 时间测定。

返回：
如果 Java 虚拟机支持任何线程的 CPU 时间测量，则返回 true；否则返回 false。

isCurrentThreadCpuTimeSupported

boolean isCurrentThreadCpuTimeSupported()
测试 Java 虚拟机是否支持当前线程的 CPU 时间测量。如果 isThreadCpuTimeSupported() 返回 true，此方法将返回 true。

返回：
如果 Java 虚拟机支持当前线程的 CPU 时间测量，则返回 true；否则返回 false。

isThreadCpuTimeEnabled

boolean isThreadCpuTimeEnabled()
测试是否启用了线程 CPU 时间测量。

返回：
如果启用了线程 CPU 时间测量，则返回 true；否则返回 false。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持其他线程或当前线程的 CPU 时间测量。
另请参见：
isThreadCpuTimeSupported(), isCurrentThreadCpuTimeSupported()

setThreadCpuTimeEnabled

void setThreadCpuTimeEnabled(boolean enable)
启用或禁用线程 CPU 时间测量。此默认值与平台有关。

参数：
enable - 为 true 则启用；为 false 则禁用。
抛出：
UnsupportedOperationException - 如果 Java 虚拟机不支持任何线程或当前线程的 CPU 时间测量。
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("control")。
另请参见：
isThreadCpuTimeSupported(), isCurrentThreadCpuTimeSupported()

findMonitorDeadlockedThreads

long[] findMonitorDeadlockedThreads()
找到处于死锁状态（等待获取对象监视器）的线程的周期。即线程被阻塞，等待进入同步块或在 Object.wait 调用后等待重新进入同步块，此时每个线程拥有一个监视器，且同时试图获取已经由周期中的另一个线程拥有的另一个监视器。

更正式地说，如果线程属于某个周期，处于“等待已被占用的对象监视器”的关系中，则该线程处于监视器死锁 状态。在最简单的情况下，线程 A 被阻塞，在等待线程 B 拥有的监视器，而线程 B 也被阻塞，在等待线程 A 拥有的监视器。

此方法设计用于进行故障排除，但不适合进行同步控制。它可能成为开销很大的操作。

此方法只查找涉及对象监视器的死锁。要查找涉及对象监视器和可拥有同步器的死锁，应该使用 findDeadlockedThreads 方法。

返回：
处于监视器死锁状态的线程（如果有）的 ID 数组；否则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission("monitor")。
另请参见：
findDeadlockedThreads()

resetPeakThreadCount

void resetPeakThreadCount()
将峰值线程计数重置为当前活动线程的数量。

抛出：
SecurityException - 如果存在安全管理器，且调用方不具有 ManagementPermission(("control")。
另请参见：
getPeakThreadCount(), getThreadCount()

findDeadlockedThreads

long[] findDeadlockedThreads()
查找因为等待获得对象监视器或可拥有同步器而处于死锁状态的线程循环。如果每个线程拥有一个锁，当试图从另一个处于循环中的线程获取其持有的锁时，线程会在循环中处于死锁 状态，等待这两种锁。

此方法设计用于故障排除，不用于异常控制。它是一个开销很大的操作。

返回：
线程的 ID 数组，该线程处于死锁状态，等待对象监视器或可拥有同步器（如果有）；否则返回 null。
抛出：
SecurityException - 如果安全管理器存在，且调用者没有 ManagementPermission("monitor")。
UnsupportedOperationException - 如果 Java 虚拟机不支持使用可拥有同步器的监视。
从以下版本开始：
1.6
另请参见：
isSynchronizerUsageSupported(), findMonitorDeadlockedThreads()

isObjectMonitorUsageSupported

boolean isObjectMonitorUsageSupported()
测试 Java 虚拟机是否支持使用对象监视器的监视。

返回：
如果 Java 虚拟机支持使用对象监视器的监视，则返回 true；否则返回 false。
从以下版本开始：
1.6
另请参见：
dumpAllThreads(boolean, boolean)

isSynchronizerUsageSupported

boolean isSynchronizerUsageSupported()
测试 Java 虚拟机是否支持使用 可拥有同步器的监视。

返回：
如果 Java 虚拟机支持使用可拥有同步器的监视，则返回 true；否则返回false。
从以下版本开始：
1.6
另请参见：
dumpAllThreads(boolean, boolean)

getThreadInfo

ThreadInfo[] getThreadInfo(long[] ids,
                           boolean lockedMonitors,
                           boolean lockedSynchronizers)
返回每个线程的线程信息，线程 ID 位于输入数组 ids 中，带有堆栈跟踪和同步信息。

此方法获取每个线程的线程信息快照，包括：

  • 整个堆栈跟踪
  • 线程当前锁定的对象监视器（如果 lockedMonitors 为 true）
  • 线程当前锁定的 可拥有同步器（如果 lockedSynchronizers 为 true）

此方法返回 ThreadInfo 对象数组，每个数组元素是关于线程的线程信息，该线程带有与 ids 数组中相同的索引。如果给定 ID 的线程没有处于活动状态，或不存在，则返回数组中的对应元素将被设置为 null。如果一个线程已经启动且尚未关闭，则称该线程是活动的。

如果线程没有锁定任何对象监视器或 lockedMonitors 为 false，那么返回的 ThreadInfo 对象将有一个空 MonitorInfo 数组。类似地，如果线程没有锁定任何同步器或 lockedSynchronizers 为 false，那么返回的 ThreadInfo 对象将有一个空 LockInfo 数组。

当 lockedMonitors 和 lockedSynchronizers 参数均为 false 时，它等效于调用：

     getThreadInfo(ids, Integer.MAX_VALUE)

此方法设计用于故障排除，不用于异常控制。它是一个开销很大的操作。

MBeanServer 访问：
ThreadInfo 的映射类型为 CompositeData，并带有 ThreadInfo.from 方法指定的属性。

参数：
ids - 线程 ID 数组。
lockedMonitors - 如果为 true，则获取所有锁定的监视器。
lockedSynchronizers - 如果为 true，则获取所有锁定的可拥有同步器。
返回：
ThreadInfo 对象数组，每个数组元素包含有关线程的信息，该线程的 ID 在 ID 输入数组的对应元素中。
抛出：
SecurityException - 如果安全管理器存在，且调用者没有 ManagementPermission("monitor")。
UnsupportedOperationException -
  • 如果 lockedMonitors 为 true，但 Java 虚拟机不支持使用对象监视器的监视；或者
  • 如果 lockedSynchronizers 为 true，但 Java 虚拟机不支持 使用可拥有同步器的监视
从以下版本开始：
1.6
另请参见：
isObjectMonitorUsageSupported(), isSynchronizerUsageSupported()

dumpAllThreads

ThreadInfo[] dumpAllThreads(boolean lockedMonitors,
                            boolean lockedSynchronizers)
返回所有活动线程的线程信息，并带有堆栈跟踪和同步信息。 当此方法返回时，返回数组中包含的一些线程可能已经终止。

此方法返回 ThreadInfo 对象数组，ThreadInfo 对象是使用 getThreadInfo(long[], boolean, boolean) 方法指定的。

参数：
lockedMonitors - 如果为 true，则转储所有锁定的监视器。
lockedSynchronizers - 如果为 true，则转储所有锁定的可拥有同步器。
返回：
所有活动线程的 ThreadInfo 数组。
抛出：
SecurityException - 如果安全管理器存在，且调用者没有 ManagementPermission("monitor")。
UnsupportedOperationException -
  • 如果 lockedMonitors 为 true，但 Java 虚拟机不支持使用对象监视器的监视；或者
  • 如果 lockedSynchronizers 为 true，但 Java 虚拟机不支持 使用可拥有同步器的监视
从以下版本开始：
1.6
另请参见：
isObjectMonitorUsageSupported(), isSynchronizerUsageSupported()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.lang.management (Java 2 Platform SE 6)

 java.lang.management
接口
ClassLoadingMXBean
CompilationMXBean
GarbageCollectorMXBean
MemoryManagerMXBean
MemoryMXBean
MemoryPoolMXBean
OperatingSystemMXBean
RuntimeMXBean
ThreadMXBean
类
LockInfo
ManagementFactory
ManagementPermission
MemoryNotificationInfo
MemoryUsage
MonitorInfo
ThreadInfo
枚举
MemoryType


java.lang.management (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.lang.management

提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

请参见：
描述

接口摘要
ClassLoadingMXBean | 用于 Java 虚拟机的类加载系统的管理接口。
CompilationMXBean | 用于 Java 虚拟机的编译系统的管理接口。
GarbageCollectorMXBean | 用于 Java 虚拟机的垃圾回收的管理接口。
MemoryManagerMXBean | 内存管理器的管理接口。
MemoryMXBean | Java 虚拟机内存系统的管理接口。
MemoryPoolMXBean | 内存池的管理接口。
OperatingSystemMXBean | 用于操作系统的管理接口，Java 虚拟机在此操作系统上运行。
RuntimeMXBean | Java 虚拟机的运行时系统的管理接口。
ThreadMXBean | Java 虚拟机线程系统的管理接口。

类摘要
LockInfo | 关于锁 的信息。
ManagementFactory | ManagementFactory 类是一种工厂类，用于获取 Java 平台的管理 Bean。
ManagementPermission | 使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。
MemoryNotificationInfo | 关于内存通知的信息。
MemoryUsage | 表示内存使用量快照的 MemoryUsage 对象。
MonitorInfo | 关于对象监视器锁的信息。
ThreadInfo | 线程信息。

枚举摘要
MemoryType 内存池的类型。

软件包 java.lang.management 的描述

提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。它同时允许从本地和远程对正在运行的 Java 虚拟机进行监视和管理。

平台 MXBean

此包定义以下组件的管理接口：

管理接口

描述
ClassLoadingMXBean | Java 虚拟机的类加载系统。
CompilationMXBean | Java 虚拟机的编译系统。
MemoryMXBean | Java 虚拟机的内存系统。
ThreadMXBean | Java 虚拟机的线程系统。
RuntimeMXBean | Java 虚拟机的运行时系统。
OperatingSystemMXBean | Java 虚拟机在其上运行的操作系统。
GarbageCollectorMXBean | Java 虚拟机中的垃圾回收器。
MemoryManagerMXBean | Java 虚拟机中的内存管理器。
MemoryPoolMXBean | Java 虚拟机中的内存池。

平台 MXBean 是一种管理 Bean，它定义平台一个组件的管理接口，在 ManagementFactory 类中定义。

应用程序可以采用以下方式监视 Java 虚拟机的监测和管理特定的特征：

  • 直接访问 MXBean 接口
    1. 通过静态工厂方法获取 MXBean 实例，从本地访问正在运行的虚拟机的 MXBean 接口。
    2. 构造 MXBean 代理实例，通过调用 ManagementFactory.newPlatformMXBeanProxy 将方法调用转发到给定的 MBeanServer。代理通常构造为远程访问另一个正在运行的虚拟机的 MXBean。
  • 通过 MBeanServer 接口间接访问
    1. 通过 platform MBeanServer 从本地访问 MXBean 或通过特定的 MBeanServerConnection 远程访问 MXBean。MXBean 的属性和操作仅使用 JMX 开放类型，包括在 OpenType 中的定义的基本数据类型、CompositeData 和 TabularData。
以下给出了一些采用不同方式访问 MXBean 的示例。

ManagementFactory

ManagementFactory 类是 Java 平台的管理工厂类。此类提供了一组静态工厂方法，用以获得 Java 平台的 MXBean，从而允许应用程序直接访问 MXBean。

使用 getPlatformMBeanServer 方法可以访问平台 MBeanServer。第一次调用此方法时，它将创建平台 MBeanServer 并注册所有的平台 MXBean，包括在其他包（如 LoggingMXBean）中定义的平台 MXBean。每个平台 MXBean 均使用用于构造 ObjectName 的 ManagementFactory 类中定义的唯一名称进行注册。这是唯一可以由在相同 Java 虚拟机内运行的不同管理组件共享的 MBeanServer。

互操作性

管理应用程序和正在运行的虚拟机的平台 MBeanServer 可以进行互操作，而无需平台 MXBean 接口使用的类。JMX 连接器服务器和连接器客户端之间传送的数据类型为 JMX 开放类型，这就允许跨版本的互操作。

当通过 MBeanServer 接口进行访问时，MXBean 接口使用的数据类型将映射为开放类型。数据类型映射在 ManagementFactory 类中指定。

访问 MXBean 的方法

有三种访问管理接口的方法。

  1. 直接调用同一 Java 虚拟机内的 MXBean 中的方法。
       RuntimeMXBean mxbean = ManagementFactory.getRuntimeMXBean();

   // Get the standard attribute "VmVendor"
   String vendor = mxbean.getVmVendor();
  2. 通过一个连接到正在运行的虚拟机的平台 MBeanServer 的 MBeanServerConnection。
    3.    MBeanServerConnection mbs;

   // Connect to a running JVM (or itself) and get MBeanServerConnection
   // that has the JVM MXBeans registered in it
   ...

   try {
       // Assuming the RuntimeMXBean has been registered in mbs
       ObjectName oname = new ObjectName(ManagementFactory.RUNTIME_MXBEAN_NAME);

       // Get standard attribute "VmVendor"
       String vendor = (String) mbs.getAttribute(oname, "VmVendor");
   } catch (....) {
       // Catch the exceptions thrown by ObjectName constructor
       // and MBeanServer.getAttribute method
       ...
   }
  3. 使用 MXBean 代理。
    4.    MBeanServerConnection mbs;

   // Connect to a running JVM (or itself) and get MBeanServerConnection
   // that has the JVM MBeans registered in it
   ...

   // Get a MBean proxy for RuntimeMXBean interface
   RuntimeMXBean proxy =
       ManagementFactory.newPlatformMXBeanProxy(mbs,
                                                ManagementFactory.RUNTIME_MXBEAN_NAME,
                                                RuntimeMXBean.class);
   // Get standard attribute "VmVendor"
   String vendor = proxy.getVmVendor();

平台扩展

Java 虚拟机实现通过定义与平台有关的接口（它扩展了标准管理接口，以包括特定于平台的规格和管理操作），可以将其平台扩展添加到管理接口。ManagementFactory 类中的静态工厂方法将返回具有平台扩展的 MBean。

建议使用特定于供应商的前缀（如供应商的名称）对特定于平台的属性进行命名，以避免标准管理接口的未来扩展与平台扩展之间的属性名称冲突。如果标准管理接口的未来扩展为管理接口定义了一个新属性，而该属性名称碰巧与某个特定于供应商的属性的名称相同，则必须修改访问该特定于供应商的属性的应用程序，以处理版本控制和兼容性问题。

以下示例演示了如何访问 Sun 的 RuntimeMXBean 实现中的特定于平台的属性。

1) 直接访问特定于 Sun 的 MXBean 接口

   com.sun.management.RuntimeMXBean mxbean =
       (com.sun.management.RuntimeMXBean) ManagementFactory.getRuntimeMXBean();

   // Get the standard attribute "VmVendor"
   String vendor = mxbean.getVmVendor();

   // Get the platform-specific attribute "Bar"
   BarType bar = mxbean.getBar();

2) 通过 MBeanServer 访问特定于 Sun 的 MXBean 接口

   MBeanServerConnection mbs;

   // Connect to a running JVM (or itself) and get MBeanServerConnection
   // that has the JVM MXBeans registered in it
   ...

   try {
       // Assuming the RuntimeMXBean has been registered in mbs
       ObjectName oname = new ObjectName(ManagementFactory.RUNTIME_MXBEAN_NAME);

       // Get standard attribute "VmVendor"
       String vendor = (String) mbs.getAttribute(oname, "VmVendor");

       // Check if this MXBean contains Sun's extension
       if (mbs.isInstanceOf(oname, "com.sun.management.RuntimeMXBean")) {
           // Get platform-specific attribute "Bar"
           BarType bar = (String) mbs.getAttribute(oname, "Bar");
       }
   } catch (....) {
       // Catch the exceptions thrown by ObjectName constructor
       // and MBeanServer methods
       ...
   }

除非另有说明，向此包的任何类或接口中的构造方法或方法传递 null 变量，将会抛出 NullPointerException。

java.lang.management API 是线程安全的。

从以下版本开始：
1.5
另请参见：
JMX 规范。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.lang.management 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.management 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.management.LockInfo
      • java.lang.management.MonitorInfo
    • java.lang.management.ManagementFactory
    • java.lang.management.MemoryNotificationInfo
    • java.lang.management.MemoryUsage
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.lang.management.ManagementPermission
    • java.lang.management.ThreadInfo

接口分层结构

  • java.lang.management.ClassLoadingMXBean
  • java.lang.management.CompilationMXBean
  • java.lang.management.MemoryManagerMXBean
    • java.lang.management.GarbageCollectorMXBean
  • java.lang.management.MemoryMXBean
  • java.lang.management.MemoryPoolMXBean
  • java.lang.management.OperatingSystemMXBean
  • java.lang.management.RuntimeMXBean
  • java.lang.management.ThreadMXBean

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.lang.management.MemoryType
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.lang.management 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.management
的使用

使用 java.lang.management 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 使用的 java.lang.management 中的类
ClassLoadingMXBean
用于 Java 虚拟机的类加载系统的管理接口。
CompilationMXBean
用于 Java 虚拟机的编译系统的管理接口。
GarbageCollectorMXBean
用于 Java 虚拟机的垃圾回收的管理接口。
LockInfo
关于锁 的信息。
MemoryManagerMXBean
内存管理器的管理接口。
MemoryMXBean
Java 虚拟机内存系统的管理接口。
MemoryNotificationInfo
关于内存通知的信息。
MemoryPoolMXBean
内存池的管理接口。
MemoryType
内存池的类型。
MemoryUsage
表示内存使用量快照的 MemoryUsage 对象。
MonitorInfo
关于对象监视器锁的信息。
OperatingSystemMXBean
用于操作系统的管理接口，Java 虚拟机在此操作系统上运行。
RuntimeMXBean
Java 虚拟机的运行时系统的管理接口。
ThreadInfo
线程信息。
ThreadMXBean
Java 虚拟机线程系统的管理接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.ClassLoadingMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.ClassLoadingMXBean
的使用

使用 ClassLoadingMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ClassLoadingMXBean 的使用

返回 ClassLoadingMXBean 的 java.lang.management 中的方法
static ClassLoadingMXBean ManagementFactory.getClassLoadingMXBean()
返回 Java 虚拟机的类加载系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.CompilationMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.CompilationMXBean
的使用

使用 CompilationMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 CompilationMXBean 的使用

返回 CompilationMXBean 的 java.lang.management 中的方法
static CompilationMXBean ManagementFactory.getCompilationMXBean()
返回 Java 虚拟机的编译系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.GarbageCollectorMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.GarbageCollectorMXBean
的使用

使用 GarbageCollectorMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 GarbageCollectorMXBean 的使用

返回变量类型为 GarbageCollectorMXBean 的类型的 java.lang.management 中的方法
static List<GarbageCollectorMXBean> ManagementFactory.getGarbageCollectorMXBeans()
返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.LockInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.LockInfo
的使用

使用 LockInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 LockInfo 的使用

java.lang.management 中 LockInfo 的子类
 class MonitorInfo
关于对象监视器锁的信息。

返回 LockInfo 的 java.lang.management 中的方法
LockInfo[] | ThreadInfo.getLockedSynchronizers() 返回 LockInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的可拥有同步器。
LockInfo | ThreadInfo.getLockInfo() 返回对象的 LockInfo，与此 ThreadInfo 关联的线程被阻塞并等待该对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.ManagementFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.ManagementFactory
的使用

没有 java.lang.management.ManagementFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.ManagementPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.ManagementPermission
的使用

没有 java.lang.management.ManagementPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.MemoryMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.MemoryMXBean
的使用

使用 MemoryMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryMXBean 的使用

返回 MemoryMXBean 的 java.lang.management 中的方法
static MemoryMXBean ManagementFactory.getMemoryMXBean()
返回 Java 虚拟机的内存系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.MemoryManagerMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.MemoryManagerMXBean
的使用

使用 MemoryManagerMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryManagerMXBean 的使用

java.lang.management 中 MemoryManagerMXBean 的子接口
 interface GarbageCollectorMXBean
用于 Java 虚拟机的垃圾回收的管理接口。

返回变量类型为 MemoryManagerMXBean 的类型的 java.lang.management 中的方法
static List<MemoryManagerMXBean> ManagementFactory.getMemoryManagerMXBeans()
返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.MemoryNotificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MemoryNotificationInfo
的使用

使用 MemoryNotificationInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryNotificationInfo 的使用

返回 MemoryNotificationInfo 的 java.lang.management 中的方法
static MemoryNotificationInfo MemoryNotificationInfo.from(CompositeData cd)
返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.MemoryPoolMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.MemoryPoolMXBean
的使用

使用 MemoryPoolMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryPoolMXBean 的使用

返回变量类型为 MemoryPoolMXBean 的类型的 java.lang.management 中的方法
static List<MemoryPoolMXBean> ManagementFactory.getMemoryPoolMXBeans()
返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.MemoryType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MemoryType
的使用

使用 MemoryType 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryType 的使用

返回 MemoryType 的 java.lang.management 中的方法
MemoryType | MemoryPoolMXBean.getType() 返回此内存池的类型。
static MemoryType | MemoryType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static MemoryType[] | MemoryType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.MemoryUsage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MemoryUsage
的使用

使用 MemoryUsage 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MemoryUsage 的使用

返回 MemoryUsage 的 java.lang.management 中的方法
static MemoryUsage | MemoryUsage.from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryUsage 对象。
MemoryUsage | MemoryPoolMXBean.getCollectionUsage() 返回 Java 虚拟机最近回收了此内存池中的不使用的对象之后的内存使用量。
MemoryUsage | MemoryMXBean.getHeapMemoryUsage() 返回用于对象分配的堆的当前内存使用量。
MemoryUsage | MemoryMXBean.getNonHeapMemoryUsage() 返回 Java 虚拟机使用的非堆内存的当前内存使用量。
MemoryUsage | MemoryPoolMXBean.getPeakUsage() 返回自 Java 虚拟机启动以来或自峰值重置以来此内存池的峰值内存使用量。
MemoryUsage | MemoryNotificationInfo.getUsage() 返回构造此通知时内存池的内存使用量。
MemoryUsage | MemoryPoolMXBean.getUsage() 返回此内存池的内存使用量的估计数。

参数类型为 MemoryUsage 的 java.lang.management 中的构造方法
MemoryNotificationInfo(String poolName, MemoryUsage usage, long count)
构造一个 MemoryNotificationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.MonitorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.MonitorInfo
的使用

使用 MonitorInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 MonitorInfo 的使用

返回 MonitorInfo 的 java.lang.management 中的方法
static MonitorInfo | MonitorInfo.from(CompositeData cd) 返回给定 CompositeData 表示的 MonitorInfo 对象。
MonitorInfo[] | ThreadInfo.getLockedMonitors() 返回 MonitorInfo 对象数组，每个数组元素表示关联此 ThreadInfo 的线程当前锁定的对象监视器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.OperatingSystemMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.OperatingSystemMXBean
的使用

使用 OperatingSystemMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 OperatingSystemMXBean 的使用

返回 OperatingSystemMXBean 的 java.lang.management 中的方法
static OperatingSystemMXBean ManagementFactory.getOperatingSystemMXBean()
返回运行 Java 虚拟机的操作系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.RuntimeMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.RuntimeMXBean
的使用

使用 RuntimeMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 RuntimeMXBean 的使用

返回 RuntimeMXBean 的 java.lang.management 中的方法
static RuntimeMXBean ManagementFactory.getRuntimeMXBean()
返回 Java 虚拟机的运行时系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.management.ThreadInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.management.ThreadInfo
的使用

使用 ThreadInfo 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ThreadInfo 的使用

返回 ThreadInfo 的 java.lang.management 中的方法
ThreadInfo[] | ThreadMXBean.dumpAllThreads(boolean lockedMonitors, boolean lockedSynchronizers) 返回所有活动线程的线程信息，并带有堆栈跟踪和同步信息。
static ThreadInfo | ThreadInfo.from(CompositeData cd) 返回由给定 CompositeData 表示的 ThreadInfo 对象。
ThreadInfo | ThreadMXBean.getThreadInfo(long id) 返回指定 id 的不具有堆栈跟踪的线程的线程信息。
ThreadInfo[] | ThreadMXBean.getThreadInfo(long[] ids) 返回其 ID 在输出数组 ids 中的每个线程的线程信息，这些线程不具有堆栈跟踪。
ThreadInfo[] | ThreadMXBean.getThreadInfo(long[] ids, boolean lockedMonitors, boolean lockedSynchronizers) 返回每个线程的线程信息，线程 ID 位于输入数组 ids 中，带有堆栈跟踪和同步信息。
ThreadInfo[] | ThreadMXBean.getThreadInfo(long[] ids, int maxDepth) 返回其 ID 在输入数组 ids 中的每个线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。
ThreadInfo | ThreadMXBean.getThreadInfo(long id, int maxDepth) 返回指定 id 的线程的线程信息，并带有指定堆栈追踪元素数的堆栈追踪。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.management.ThreadMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.management.ThreadMXBean
的使用

使用 ThreadMXBean 的软件包
java.lang.management 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.management 中 ThreadMXBean 的使用

返回 ThreadMXBean 的 java.lang.management 中的方法
static ThreadMXBean ManagementFactory.getThreadMXBean()
返回 Java 虚拟机的线程系统的管理 Bean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


PhantomReference (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.ref
类 PhantomReference<T>

java.lang.Object
    继承者  java.lang.ref.Reference<T>
        继承者  java.lang.ref.PhantomReference<T>

public class PhantomReference<T>
extends Reference<T>

虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。虚引用最常见的用法是以某种可能比使用 Java 终结机制更灵活的方式来指派 pre-mortem 清除动作。

如果垃圾回收器确定在某一特定时间点上虚引用的指示对象是虚可到达对象，那么在那时或者在以后的某一时间，它会将该引用加入队列。

为了确保可回收的对象仍然保持原状，虚引用的指示对象不能被获取：虚引用的 get 方法总是返回 null。

与软引用和弱引用不同，虚引用在加入队列时并没有通过垃圾回收器自动清除。通过虚引用可到达的对象将仍然保持原状，直到所有这类引用都被清除，或者它们都变得不可到达。

从以下版本开始：
1.2

构造方法摘要
PhantomReference(T referent, ReferenceQueue<? super T> q)
创建一个引用给定对象的新的虚引用，并向给定队列注册它。
方法摘要
 T get()
返回此引用对象的指示对象。
从类 java.lang.ref.Reference 继承的方法
clear, enqueue, isEnqueued
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PhantomReference

public PhantomReference(T referent,
                        ReferenceQueue<? super T> q)
创建一个引用给定对象的新的虚引用，并向给定队列注册它。

可能用一个 null 队列创建虚引用，但这样的引用是完全无用的：其 get 方法将总是返回 null，同时，因为它没有队列，所以将永远无法把它加入队列中。

参数：
referent - 新的虚引用将引用的对象
q - 将向其注册引用的队列，如果不需要注册，则返回 null
方法详细信息

get

public T get()
返回此引用对象的指示对象。因为虚引用的指示对象总是不可到达的，所以此方法总是返回 null。

覆盖：
类 Reference<T> 中的 get
返回：
null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Reference (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.ref
类 Reference<T>

java.lang.Object
    继承者  java.lang.ref.Reference<T>
直接已知子类：
PhantomReference, SoftReference, WeakReference
public abstract class Reference<T>
extends Object

引用对象的抽象基类。此类定义了常用于所有引用对象的操作。因为引用对象是通过与垃圾回收器的密切合作来实现的，所以不能直接为此类创建子类。

从以下版本开始：
1.2

方法摘要
void | clear() 清除此引用对象。
boolean | enqueue() 将此引用对象添加到引用对象已向其注册的队列（如果有）。
T | get() 返回此引用对象的指示对象。
boolean | isEnqueued() 由程序或垃圾回收器通知是否已将此引用对象加入队列。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

get

public T get()
返回此引用对象的指示对象。如果此引用对象已经由程序或垃圾回收器清除，则此方法将返回 null。

返回：
此引用所引用的对象；如果此引用对象已经清除，则返回 null。

clear

public void clear()
清除此引用对象。调用此方法不会导致对象被加入队列。

只有 Java 代码才调用此方法；当垃圾回收器清除引用时，可以直接进行操作，无需调用此方法。

isEnqueued

public boolean isEnqueued()
由程序或垃圾回收器通知是否已将此引用对象加入队列。如果创建此引用对象时没有在队列中注册它，则该方法将总是返回 false。

返回：
当且仅当此引用对象已经加入队列时返回 true

enqueue

public boolean enqueue()
将此引用对象添加到引用对象已向其注册的队列（如果有）。

只有 Java 代码才调用此方法；当垃圾回收器将引用加入队列时，可以直接进行操作，无需调用此方法。

返回：
如果成功将此引用对象加入队列中，则返回 true；如果它已经加入队列或者在创建时没有在队列中注册它，则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReferenceQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.ref
类 ReferenceQueue<T>

java.lang.Object
    继承者  java.lang.ref.ReferenceQueue<T>

public class ReferenceQueue<T>
extends Object

引用队列，在检测到适当的可到达性更改后，垃圾回收器将已注册的引用对象添加到该队列中。

从以下版本开始：
1.2

构造方法摘要
ReferenceQueue()
构造一个新的引用对象队列。
方法摘要
Reference<? extends T> | poll() 轮询此队列，查看是否存在可用的引用对象。
Reference<? extends T> | remove() 移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。
Reference<? extends T> | remove(long timeout) 移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ReferenceQueue

public ReferenceQueue()
构造一个新的引用对象队列。

方法详细信息

poll

public Reference<? extends T> poll()
轮询此队列，查看是否存在可用的引用对象。如果存在一个立即可用的对象，则从该队列中移除此对象并返回。否则此方法立即返回 null。

返回：
如果存在一个立即可用的对象，则返回该对象。否则返回 null。

remove

public Reference<? extends T> remove(long timeout)
                              throws IllegalArgumentException,
                                     InterruptedException
移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。

此方法不提供实时保证：它安排了超时时间，就像调用 Object.wait(long) 方法一样。

参数：
timeout - 如果为正，则在等待要在此队列中添加的引用时会阻塞 timeout 毫秒。如果超时值为零，则无限期地阻塞。
返回：
如果在指定的超时期内有一个引用对象可用，则返回该对象；否则返回 null。
抛出：
IllegalArgumentException - 如果超时参数的值为负。
InterruptedException - 如果超时等待被中断

remove

public Reference<? extends T> remove()
                              throws InterruptedException
移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。

返回：
某个引用对象，阻塞到某个对象变得可用为止。
抛出：
InterruptedException - 如果等待被中断
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SoftReference (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.ref
类 SoftReference<T>

java.lang.Object
    继承者  java.lang.ref.Reference<T>
        继承者  java.lang.ref.SoftReference<T>

public class SoftReference<T>
extends Reference<T>

软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。软引用对象最常用于实现内存敏感的缓存。

假定垃圾回收器确定在某一时间点某个对象是软可到达对象。这时，它可以选择自动清除针对该对象的所有软引用，以及通过强引用链，从其可以到达该对象的针对任何其他软可到达对象的所有软引用。在同一时间或晚些时候，它会将那些已经向引用队列注册的新清除的软引用加入队列。

软可到达对象的所有软引用都要保证在虚拟机抛出 OutOfMemoryError 之前已经被清除。否则，清除软引用的时间或者清除不同对象的一组此类引用的顺序将不受任何约束。然而，虚拟机实现不鼓励清除最近访问或使用过的软引用。

此类的直接实例可用于实现简单缓存；该类或其派生的子类还可用于更大型的数据结构，以实现更复杂的缓存。只要软引用的指示对象是强可到达对象，即正在实际使用的对象，就不会清除软引用。例如，通过保持最近使用的项的强指示对象，并由垃圾回收器决定是否放弃剩余的项，复杂的缓存可以防止放弃最近使用的项。

从以下版本开始：
1.2

构造方法摘要
SoftReference(T referent)
创建引用给定对象的新的软引用。
SoftReference(T referent, ReferenceQueue<? super T> q)
创建一个引用给定对象的新的软引用，并向给定队列注册该引用。
方法摘要
 T get()
返回此引用对象的指示对象。
从类 java.lang.ref.Reference 继承的方法
clear, enqueue, isEnqueued
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SoftReference

public SoftReference(T referent)
创建引用给定对象的新的软引用。新的引用没有向任何队列注册。

参数：
referent - 新的软引用将引用的对象

SoftReference

public SoftReference(T referent,
                     ReferenceQueue<? super T> q)
创建一个引用给定对象的新的软引用，并向给定队列注册该引用。

参数：
referent - 新的软引用将引用的对象
q - 该引用向其注册的队列，如果不需要注册，则为 null
方法详细信息

get

public T get()
返回此引用对象的指示对象。如果此引用对象已经由程序或垃圾回收器清除，则此方法将返回 null。

覆盖：
类 Reference<T> 中的 get
返回：
此引用所引用的对象；如果此引用对象已经清除，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WeakReference (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.ref
类 WeakReference<T>

java.lang.Object
    继承者  java.lang.ref.Reference<T>
        继承者  java.lang.ref.WeakReference<T>

public class WeakReference<T>
extends Reference<T>

弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。弱引用最常用于实现规范化的映射。

假定垃圾回收器确定在某一时间点上某个对象是弱可到达对象。这时，它将自动清除针对此对象的所有弱引用，以及通过强引用链和软引用，可以从其到达该对象的针对任何其他弱可到达对象的所有弱引用。同时它将声明所有以前的弱可到达对象为可终结的。在同一时间或晚些时候，它将那些已经向引用队列注册的新清除的弱引用加入队列。

从以下版本开始：
1.2

构造方法摘要
WeakReference(T referent)
创建引用给定对象的新的弱引用。
WeakReference(T referent, ReferenceQueue<? super T> q)
创建引用给定对象的新的弱引用，并向给定队列注册该引用。
方法摘要
从类 java.lang.ref.Reference 继承的方法
clear, enqueue, get, isEnqueued
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

WeakReference

public WeakReference(T referent)
创建引用给定对象的新的弱引用。新的引用没有向任何队列注册。

参数：
referent - 新的弱引用将引用的对象

WeakReference

public WeakReference(T referent,
                     ReferenceQueue<? super T> q)
创建引用给定对象的新的弱引用，并向给定队列注册该引用。

参数：
referent - 新的弱引用将引用的对象
q - 该引用向其注册的队列；如果不需要注册，则为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.lang.ref (Java 2 Platform SE 6)

 java.lang.ref
类
PhantomReference
Reference
ReferenceQueue
SoftReference
WeakReference


java.lang.ref (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.lang.ref

提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

请参见：
描述

类摘要
PhantomReference<T> | 虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。
Reference<T> | 引用对象的抽象基类。
ReferenceQueue<T> | 引用队列，在检测到适当的可到达性更改后，垃圾回收器将已注册的引用对象添加到该队列中。
SoftReference<T> | 软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。
WeakReference<T> | 弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。

软件包 java.lang.ref 的描述

提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。程序可以使用一个引用对象来维持对另外某一对象的引用，所采用的方式是使后者仍然可以被回收器回收。程序还可以安排在回收器确定某一给定对象的可到达性已经更改之后的某个时间得到通知。

包规范

引用对象 封装了对另一个对象的引用，这样就可以像其他任何对象一样检查和操作引用自身。有三种类型的引用对象，按从弱到强依次为：软 引用、弱 引用和虚 引用。正如下面定义的那样，每种类型对应于一个不同的可到达性级别。软引用适用于实现内存敏感的缓存，弱引用适用于实现无法防止其键（或值）被回收的规范化映射，而虚引用则适用于以某种比 Java 终结机制更灵活的方式调度 pre-mortem 清除操作。

每种引用对象类型都是通过抽象的基本 Reference 类的一个子类实现的。其中一个子类的实例封装了对特定对象的引用，该对象名为指示对象。每个引用对象都提供了获取和清除该引用的方法。引用对象是不可变的，因此，除了清除操作之外，没有提供 set 操作。通过添加任何所需的字段和方法，程序可以为这些子类进一步创建子类，或者可以不加更改地使用这些子类。

通知

在创建引用对象时，通过向引用队列注册 一个适当的引用对象，程序可以请求在对象可到达性更改时获得通知。在垃圾回收器确定引用的可到达性已经更改为对应于引用类型的值之后的某一时间，它会将引用添加到相关的队列中。此时，该引用被认为是已加入队列的。通过轮询或阻塞，直到获得了引用，程序才可以从队列中移除引用。引用队列是通过 ReferenceQueue 类实现的。

已注册的引用对象及其队列之间的关系是单向的。也就是说，队列不会追踪那些向它注册的引用。如果一个已注册的引用本身变得不可到达，则永远不会将它加入到队列中。使用引用对象的程序的责任是，确保对象是可达到的，只要程序对其指示对象感兴趣。

虽然某些程序会选择专门使用一个线程从一个或多个队列中移除引用对象并处理它们，但这是绝对没有必要的。一种通常很有用的策略是：在执行另一个相当频繁的操作期间检查引用队列。例如，使用弱引用来实现弱键的哈希表能在每次访问表时轮询其引用队列。这就是 WeakHashMap 类的工作方式。因为 ReferenceQueue.poll 方法仅仅检查内部数据结构，此检查只为哈希表访问方法增加了很小的系统开销。

自动清除引用

在将软引用和弱引用添加到向其注册的队列（如果有）之前，回收器将自动清除这些引用。所以，软引用和弱引用不需要向队列注册即可使用，而虚引用则需要这样做。通过虚引用可到达的对象将仍然保持原状，直到清除所有这类引用或者它们本身变得不可到达。

可到达性

从最强到最弱，不同的可到达性级别反映了对象的生命周期。在操作上，可将它们定义如下：
  • 如果某一线程可以不必遍历所有引用对象而直接到达一个对象，则该对象是强可到达 对象。新创建的对象对于创建它的线程而言是强可到达对象。
  • 如果一个对象不是强可到达对象，但通过遍历某一软引用可以到达它，则该对象是软可到达 对象。
  • 如果一个对象既不是强可到达对象，也不是软可到达对象，但通过遍历弱引用可以到达它，则该对象是弱可到达 对象。当清除对某一弱可到达对象的弱引用时，便可以终止此对象了。
  • 如果一个对象既不是强可到达对象，也不是软可到达对象或弱可到达对象，它已经终止，并且某个虚引用在引用它，则该对象是虚可到达 对象。
  • 最后，当不能以上述任何方法到达某一对象时，该对象是不可到达 对象，因此可以回收此对象。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.lang.ref 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.ref 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.ref.Reference<T>
      • java.lang.ref.PhantomReference<T>
      • java.lang.ref.SoftReference<T>
      • java.lang.ref.WeakReference<T>
    • java.lang.ref.ReferenceQueue<T>
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.lang.ref 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.ref
的使用

使用 java.lang.ref 的软件包
java.lang.ref 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

java.lang.ref 使用的 java.lang.ref 中的类
Reference
引用对象的抽象基类。
ReferenceQueue
引用队列，在检测到适当的可到达性更改后，垃圾回收器将已注册的引用对象添加到该队列中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ref.ReferenceQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.ReferenceQueue
的使用

使用 ReferenceQueue 的软件包
java.lang.ref 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

java.lang.ref 中 ReferenceQueue 的使用

参数类型为 ReferenceQueue 的 java.lang.ref 中的构造方法
PhantomReference(T referent, ReferenceQueue<? super T> q)
创建一个引用给定对象的新的虚引用，并向给定队列注册它。
SoftReference(T referent, ReferenceQueue<? super T> q)
创建一个引用给定对象的新的软引用，并向给定队列注册该引用。
WeakReference(T referent, ReferenceQueue<? super T> q)
创建引用给定对象的新的弱引用，并向给定队列注册该引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ref.PhantomReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.PhantomReference
的使用

没有 java.lang.ref.PhantomReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ref.WeakReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.WeakReference
的使用

没有 java.lang.ref.WeakReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ref.SoftReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.SoftReference
的使用

没有 java.lang.ref.SoftReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ref.Reference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ref.Reference
的使用

使用 Reference 的软件包
java.lang.ref 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

java.lang.ref 中 Reference 的使用

java.lang.ref 中 Reference 的子类
class | PhantomReference<T> 虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。
class | SoftReference<T> 软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。
class | WeakReference<T> 弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。

返回 Reference 的 java.lang.ref 中的方法
Reference<? extends T> | ReferenceQueue.poll() 轮询此队列，查看是否存在可用的引用对象。
Reference<? extends T> | ReferenceQueue.remove() 移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。
Reference<? extends T> | ReferenceQueue.remove(long timeout) 移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AccessibleObject (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 AccessibleObject

java.lang.Object
    继承者  java.lang.reflect.AccessibleObject
所有已实现的接口：
AnnotatedElement
直接已知子类：
Constructor, Field, Method
public class AccessibleObject
extends Object
implements AnnotatedElement

AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。它提供了将反射的对象标记为在使用时取消默认 Java 语言访问控制检查的能力。对于公共成员、默认（打包）访问成员、受保护成员和私有成员，在分别使用 Field、Method 或 Constructor 对象来设置或获取字段、调用方法，或者创建和初始化类的新实例的时候，会执行访问检查。

在反射对象中设置 accessible 标志允许具有足够特权的复杂应用程序（比如 Java Object Serialization 或其他持久性机制）以某种通常禁止使用的方式来操作对象。

从以下版本开始：
1.2
另请参见：
Field, Method, Constructor, ReflectPermission

构造方法摘要
protected AccessibleObject()
构造方法：仅供 Java 虚拟机使用。
方法摘要
<T extends Annotation>
T
getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
 Annotation[] getAnnotations()
返回此元素上存在的所有注释。
 Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。
 boolean isAccessible()
获取此对象的 accessible 标志的值。
 boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。
static void setAccessible(AccessibleObject[] array, boolean flag)
使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。
 void setAccessible(boolean flag)
将此对象的 accessible 标志设置为指示的布尔值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AccessibleObject

protected AccessibleObject()
构造方法：仅供 Java 虚拟机使用。

方法详细信息

setAccessible

public static void setAccessible(AccessibleObject[] array,
                                 boolean flag)
                          throws SecurityException
使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。

首先，如果存在安全管理器，则在 ReflectPermission("suppressAccessChecks") 权限下调用 checkPermission 方法。

如果 flag 为 true，但是不能更改输入 array 的任何元素的可访问性（例如，如果元素对象是 Class 类的 Constructor 对象），则会引发 SecurityException。如果发生 SecurityException，对于少于（不包括）发生异常的元素的数组元素，可以将对象的可访问性设置为 flag；对于超出（包括）引发异常的元素的那些元素，则不更改其可访问性。

参数：
array - AccessibleObjects 的数组
flag - 每个对象中的 accessible 标志的新值
抛出：
SecurityException - 如果请求被拒绝。
另请参见：
SecurityManager.checkPermission(java.security.Permission), RuntimePermission

setAccessible

public void setAccessible(boolean flag)
                   throws SecurityException
将此对象的 accessible 标志设置为指示的布尔值。值为 true 则指示反射的对象在使用时应该取消 Java 语言访问检查。值为 false 则指示反射的对象应该实施 Java 语言访问检查。

首先，如果存在安全管理器，则在 ReflectPermission("suppressAccessChecks") 权限下调用 checkPermission 方法。

如果 flag 为 true，并且不能更改此对象的可访问性（例如，如果此元素对象是 Class 类的 Constructor 对象），则会引发 SecurityException。

如果此对象是 java.lang.Class 类的 Constructor 对象，并且 flag 为 true，则会引发 SecurityException。

参数：
flag - accessible 标志的新值
抛出：
SecurityException - 如果请求被拒绝。
另请参见：
SecurityManager.checkPermission(java.security.Permission), RuntimePermission

isAccessible

public boolean isAccessible()
获取此对象的 accessible 标志的值。

返回：
此对象的 accessible 标志的值。

getAnnotation

public <T extends Annotation> T getAnnotation(Class<T> annotationClass)
从接口 AnnotatedElement 复制的描述
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

指定者：
接口 AnnotatedElement 中的 getAnnotation
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果该元素的指定注释类型的注释存在于此对象上，则返回这些注释，否则返回 null
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

isAnnotationPresent

public boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
从接口 AnnotatedElement 复制的描述
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。此方法主要是为了便于访问标记注释而设计的。

指定者：
接口 AnnotatedElement 中的 isAnnotationPresent
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果指定注释类型的注释存在于此对象上，则返回 true，否则返回 false
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getAnnotations

public Annotation[] getAnnotations()
从接口 AnnotatedElement 复制的描述
返回此元素上存在的所有注释。（如果此元素没有注释，则返回长度为零的数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getAnnotations
返回：
此元素上存在的所有注释
从以下版本开始：
1.5

getDeclaredAnnotations

public Annotation[] getDeclaredAnnotations()
从接口 AnnotatedElement 复制的描述
返回直接存在于此元素上的所有注释。与此接口中的其他方法不同，该方法将忽略继承的注释。（如果没有注释直接存在于此元素上，则返回长度为零的一个数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getDeclaredAnnotations
返回：
直接存在于此元素上的所有注释
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AnnotatedElement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 AnnotatedElement

所有已知实现类：
AccessibleObject, Class, Constructor, Field, Method, Package
public interface AnnotatedElement

表示目前正在此 VM 中运行的程序的一个已注释元素。该接口允许反射性地读取注释。由此接口中的方法返回的所有注释都是不可变并且可序列化的。调用者可以修改已赋值数组枚举成员的访问器返回的数组；这不会对其他调用者返回的数组产生任何影响。

如果此接口中的方法返回的注释（直接或间接地）包含一个已赋值的 Class 成员，该成员引用了一个在此 VM 中不可访问的类，则试图通过在返回的注释上调用相关的类返回的方法来读取该类，将导致一个 TypeNotPresentException。

类似地，如果注释中的枚举常量不再以枚举类型存在，那么试图读取一个已赋值的枚举成员将导致一个 EnumConstantNotPresentException。

最后，阅读其定义已经引起不兼容性的成员将导致 AnnotationTypeMismatchException 或 IncompleteAnnotationException。

从以下版本开始：
1.5

方法摘要
<T extends Annotation>
T
getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
 Annotation[] getAnnotations()
返回此元素上存在的所有注释。
 Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。
 boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。

方法详细信息

isAnnotationPresent

boolean isAnnotationPresent(Class<? extends Annotation> annotationClass)
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。此方法主要是为了便于访问标记注释而设计的。

参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果指定注释类型的注释存在于此对象上，则返回 true，否则返回 false
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getAnnotation

<T extends Annotation> T getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果该元素的指定注释类型的注释存在于此对象上，则返回这些注释，否则返回 null
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getAnnotations

Annotation[] getAnnotations()
返回此元素上存在的所有注释。（如果此元素没有注释，则返回长度为零的数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

返回：
此元素上存在的所有注释
从以下版本开始：
1.5

getDeclaredAnnotations

Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。与此接口中的其他方法不同，该方法将忽略继承的注释。（如果没有注释直接存在于此元素上，则返回长度为零的一个数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

返回：
直接存在于此元素上的所有注释
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Array (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 Array

java.lang.Object
    继承者  java.lang.reflect.Array

public final class Array
extends Object

Array 类提供了动态创建和访问 Java 数组的方法。

Array 允许在执行 get 或 set 操作期间进行扩展转换，但如果发生收缩转换，则抛出 IllegalArgumentException。

方法摘要
static Object | get(Object array, int index) 返回指定数组对象中索引组件的值。
static boolean | getBoolean(Object array, int index) 以 boolean 形式返回指定数组对象中索引组件的值。
static byte | getByte(Object array, int index) 以 byte 形式返回指定数组对象中索引组件的值。
static char | getChar(Object array, int index) 以 char 形式返回指定数组对象中索引组件的值。
static double | getDouble(Object array, int index) 以 double 形式返回指定数组对象中索引组件的值。
static float | getFloat(Object array, int index) 以 float 形式返回指定数组对象中索引组件的值。
static int | getInt(Object array, int index) 以 int 形式返回指定数组对象中索引组件的值。
static int | getLength(Object array) 以 int 形式返回指定数组对象的长度。
static long | getLong(Object array, int index) 以 long 形式返回指定数组对象中索引组件的值。
static short | getShort(Object array, int index) 以 short 形式返回指定数组对象中索引组件的值。
static Object | newInstance(Class<?> componentType, int... dimensions) 创建一个具有指定的组件类型和维度的新数组。
static Object | newInstance(Class<?> componentType, int length) 创建一个具有指定的组件类型和长度的新数组。
static void | set(Object array, int index, Object value) 将指定数组对象中索引组件的值设置为指定的新值。
static void | setBoolean(Object array, int index, boolean z) 将指定数组对象中索引组件的值设置为指定的 boolean 值。
static void | setByte(Object array, int index, byte b) 将指定数组对象中索引组件的值设置为指定的 byte 值。
static void | setChar(Object array, int index, char c) 将指定数组对象中索引组件的值设置为指定的 char 值。
static void | setDouble(Object array, int index, double d) 将指定数组对象中索引组件的值设置为指定的 double 值。
static void | setFloat(Object array, int index, float f) 将指定数组对象中索引组件的值设置为指定的 float 值。
static void | setInt(Object array, int index, int i) 将指定数组对象中索引组件的值设置为指定的 int 值。
static void | setLong(Object array, int index, long l) 将指定数组对象中索引组件的值设置为指定的 long 值。
static void | setShort(Object array, int index, short s) 将指定数组对象中索引组件的值设置为指定的 short 值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

newInstance

public static Object newInstance(Class<?> componentType,
                                 int length)
                          throws NegativeArraySizeException
创建一个具有指定的组件类型和长度的新数组。调用此方法等效于创建如下数组：
 int[] x = {length};
 Array.newInstance(componentType, x);

参数：
componentType - 表示新数组的组件类型的 Class 对象
length - 新数组的长度
返回：
新数组
抛出：
NullPointerException - 如果指定的 componentType 参数为 null
IllegalArgumentException - 如果 componentType 为 Void.TYPE
NegativeArraySizeException - 如果指定的 length 为负

newInstance

public static Object newInstance(Class<?> componentType,
                                 int... dimensions)
                          throws IllegalArgumentException,
                                 NegativeArraySizeException
创建一个具有指定的组件类型和维度的新数组。如果 componentType 表示一个非数组类或接口，则新数组具有 dimensions.length 维度，并且将 componentType 作为其组件类型。如果 componentType 表示一个数组类，则新数组的维数等于 dimensions.length 和 componentType 的维数的总和。在这种情况下，新数组的组件类型为 componentType 的组件类型。

新数组的维数不能超过该实现所支持的数组维数（通常为 255）。

参数：
componentType - 表示新数组的组件类型的 Class 对象
dimensions - 表示新数组维度的 int 数组
返回：
新数组
抛出：
NullPointerException - 如果指定的 componentType 参数为 null
IllegalArgumentException - 如果指定的 dimensions 参数是一个零维度的数组，或者所请求的维数超过了该实现所支持的数组维数的限制（通常为 225），或者度的数组，或者所请求的维数超过了该实现所支持的数组维数的限制（通常为 225），或者 componentType 为 Void.TYPE。
NegativeArraySizeException - 如果指定的 dimensions 参数中的任意组件为负。

getLength

public static int getLength(Object array)
                     throws IllegalArgumentException
以 int 形式返回指定数组对象的长度。

参数：
array - 数组
返回：
数组的长度
抛出：
IllegalArgumentException - 如果对象参数不是一个数组

get

public static Object get(Object array,
                         int index)
                  throws IllegalArgumentException,
                         ArrayIndexOutOfBoundsException
返回指定数组对象中索引组件的值。如果该值是一个基本类型值，则自动将其包装在一个对象中。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的（可能已封装的）值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度

getBoolean

public static boolean getBoolean(Object array,
                                 int index)
                          throws IllegalArgumentException,
                                 ArrayIndexOutOfBoundsException
以 boolean 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

getByte

public static byte getByte(Object array,
                           int index)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
以 byte 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

getChar

public static char getChar(Object array,
                           int index)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
以 char 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

getShort

public static short getShort(Object array,
                             int index)
                      throws IllegalArgumentException,
                             ArrayIndexOutOfBoundsException
以 short 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

getInt

public static int getInt(Object array,
                         int index)
                  throws IllegalArgumentException,
                         ArrayIndexOutOfBoundsException
以 int 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

getLong

public static long getLong(Object array,
                           int index)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
以 long 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

getFloat

public static float getFloat(Object array,
                             int index)
                      throws IllegalArgumentException,
                             ArrayIndexOutOfBoundsException
以 float 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

getDouble

public static double getDouble(Object array,
                               int index)
                        throws IllegalArgumentException,
                               ArrayIndexOutOfBoundsException
以 double 形式返回指定数组对象中索引组件的值。

参数：
array - 数组
index - 索引
返回：
指定数组中索引组件的值
抛出：
NullPointerException - 如果指定对象为 null
IllegalArgumentException - 如果指定对象不是一个数组，或者无法通过一个恒等或扩展转换将索引元素转换为返回类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
get(java.lang.Object, int)

set

public static void set(Object array,
                       int index,
                       Object value)
                throws IllegalArgumentException,
                       ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的新值。如果数组的类型为基本组件类型，则新值第一个被自动解包。

参数：
array - 数组
index - 数组内部的索引
value - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者数组组件类型是基本类型并且解包转换失败
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度

setBoolean

public static void setBoolean(Object array,
                              int index,
                              boolean z)
                       throws IllegalArgumentException,
                              ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 boolean 值。

参数：
array - 数组
index - 数组内部的索引
z - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)

setByte

public static void setByte(Object array,
                           int index,
                           byte b)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 byte 值。

参数：
array - 数组
index - 数组内部的索引
b - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)

setChar

public static void setChar(Object array,
                           int index,
                           char c)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 char 值。

参数：
array - 数组
index - 数组内部的索引
c - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)

setShort

public static void setShort(Object array,
                            int index,
                            short s)
                     throws IllegalArgumentException,
                            ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 short 值。

参数：
array - 数组
index - 数组内部的索引
s - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)

setInt

public static void setInt(Object array,
                          int index,
                          int i)
                   throws IllegalArgumentException,
                          ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 int 值。

参数：
array - 数组
index - 数组内部的索引
i - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)

setLong

public static void setLong(Object array,
                           int index,
                           long l)
                    throws IllegalArgumentException,
                           ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 long 值。

参数：
array - 数组
index - 数组内部的索引
l - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)

setFloat

public static void setFloat(Object array,
                            int index,
                            float f)
                     throws IllegalArgumentException,
                            ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 float 值。

参数：
array - 数组
index - 数组内部的索引
f - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)

setDouble

public static void setDouble(Object array,
                             int index,
                             double d)
                      throws IllegalArgumentException,
                             ArrayIndexOutOfBoundsException
将指定数组对象中索引组件的值设置为指定的 double 值。

参数：
array - 数组
index - 数组内部的索引
d - 索引组件的新值
抛出：
NullPointerException - 如果指定对象参数为 null
IllegalArgumentException - 如果指定对象参数不是一个数组，或者无法通过一个恒等或基本扩展转换将指定值转换为基础数组的指定类型
ArrayIndexOutOfBoundsException - 如果指定的 index 参数为负，或者它大于等于指定数组的长度
另请参见：
set(java.lang.Object, int, java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Constructor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 Constructor<T>

java.lang.Object
    继承者  java.lang.reflect.AccessibleObject
        继承者  java.lang.reflect.Constructor<T>
类型参数：
T - 在其中声明构造方法的类。
所有已实现的接口：
AnnotatedElement, GenericDeclaration, Member
public final class Constructor<T>
extends AccessibleObject
implements GenericDeclaration, Member

Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。

Constructor 允许在将实参与带有底层构造方法的形参的 newInstance() 匹配时进行扩展转换，但是如果发生收缩转换，则抛出 IllegalArgumentException。

另请参见：
Member,
Class,
Class.getConstructors(),
Class.getConstructor(Class[]),
Class.getDeclaredConstructors()

字段摘要
从接口 java.lang.reflect.Member 继承的字段
DECLARED, PUBLIC
方法摘要
 boolean equals(Object obj)
将此 Constructor 对象与指定的对象进行比较。
<T extends Annotation>
T
getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
 Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。
 Class<T> getDeclaringClass()
返回 Class 对象，该对象表示声明由此 Constructor 对象表示的构造方法的类。
 Class<?>[] getExceptionTypes()
返回一组表示声明要抛出的异常类型的 Class 对象，这些异常是由此 Constructor 对象表示的底层构造方法抛出的。
 Type[] getGenericExceptionTypes()
返回一组 Type 对象，这些对象表示声明要由此 Constructor 对象抛出的异常。
 Type[] getGenericParameterTypes()
按照声明顺序返回一组 Type 对象，这些对象表示此 Constructor 对象所表示的方法的形参类型。
 int getModifiers()
以整数形式返回此 Constructor 对象所表示构造方法的 Java 语言修饰符。
 String getName()
以字符串形式返回此构造方法的名称。
 Annotation[][] getParameterAnnotations()
按照声明顺序返回一组数组，这些数组表示通过此 Constructor 对象表示的方法的形参上的注释。
 Class<?>[] getParameterTypes()
按照声明顺序返回一组 Class 对象，这些对象表示此 Constructor 对象所表示构造方法的形参类型。
 TypeVariable<Constructor<T>>[] getTypeParameters()
按照声明顺序返回一组 TypeVariable 对象，这些对象表示通过此 GenericDeclaration 对象所表示的一般声明来声明的类型变量。
 int hashCode()
返回此 Constructor 的哈希码。
 boolean isSynthetic()
如果此构造方法是一个复合构造方法，则返回 true；否则返回 false。
 boolean isVarArgs()
如果声明此构造方法可以带可变数量的参数，则返回 true；否则返回 false。
 T newInstance(Object... initargs)
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。
 String toGenericString()
返回描述此 Constructor 的字符串，其中包括类型参数。
 String toString()
返回描述此 Constructor 的字符串。
从类 java.lang.reflect.AccessibleObject 继承的方法
getAnnotations, isAccessible, isAnnotationPresent, setAccessible, setAccessible
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getDeclaringClass

public Class<T> getDeclaringClass()
返回 Class 对象，该对象表示声明由此 Constructor 对象表示的构造方法的类。

指定者：
接口 Member 中的 getDeclaringClass
返回：
表示声明底层成员的类的对象

getName

public String getName()
以字符串形式返回此构造方法的名称。它总是与构造方法的声明类的简单名称相同。

指定者：
接口 Member 中的 getName
返回：
底层成员的简单名称

getModifiers

public int getModifiers()
以整数形式返回此 Constructor 对象所表示构造方法的 Java 语言修饰符。应该使用 Modifier 类对这些修饰符进行解码。

指定者：
接口 Member 中的 getModifiers
返回：
底层成员的 Java 语言修饰符
另请参见：
Modifier

getTypeParameters

public TypeVariable<Constructor<T>>[] getTypeParameters()
按照声明顺序返回一组 TypeVariable 对象，这些对象表示通过此 GenericDeclaration 对象所表示的一般声明来声明的类型变量。如果底层一般声明未声明任何类型的变量，则返回一个长度为 0 的数组。

指定者：
接口 GenericDeclaration 中的 getTypeParameters
返回：
表示通过此一般声明来声明的类型变量的一组 TypeVariable 对象
抛出：
GenericSignatureFormatError - 如果此一般声明的一般签名不符合 Java Virtual Machine Specification, 3rd edition 指定的格式
从以下版本开始：
1.5

getParameterTypes

public Class<?>[] getParameterTypes()
按照声明顺序返回一组 Class 对象，这些对象表示此 Constructor 对象所表示构造方法的形参类型。如果底层构造方法不带任何参数，则返回一个长度为 0 的数组。

返回：
此对象表示的构造方法的参数类型

getGenericParameterTypes

public Type[] getGenericParameterTypes()
按照声明顺序返回一组 Type 对象，这些对象表示此 Constructor 对象所表示的方法的形参类型。如果底层方法不带任何参数，则返回一个长度为 0 的数组。

如果形参类型是一个参数化类型，那么为它返回的 Type 对象必须准确地反映源代码中使用的实际类型参数。

如果形参类型是一个类型变量或者是一个参数化类型，则创建它。否则将解析它。

返回：
按照声明顺序返回一组 Type 对象，该对象表示底层方法的形参类型
抛出：
GenericSignatureFormatError - 如果这个一般方法的签名不符合 Java Virtual Machine Specification, 3rd edition 指定的格式
TypeNotPresentException - 如果任何底层方法的参数类型引用了不存在的类型声明
MalformedParameterizedTypeException - 如果任何底层方法的参数类型引用了因某种原因而无法实例化的参数化类型
从以下版本开始：
1.5

getExceptionTypes

public Class<?>[] getExceptionTypes()
返回一组表示声明要抛出的异常类型的 Class 对象，这些异常是由此 Constructor 对象表示的底层构造方法抛出的。如果该构造方法声明其 throws 子句中没有任何异常，则返回一个长度为 0 的数组。

返回：
声明由此对象表示的构造方法抛出的异常类型

getGenericExceptionTypes

public Type[] getGenericExceptionTypes()
返回一组 Type 对象，这些对象表示声明要由此 Constructor 对象抛出的异常。如果底层方法声明其 throws 子句中没有任何异常，则返回一个长度为 0 的数组。

如果异常类型是一个参数化类型，那么为它返回的 Type 对象必须准确地反映源代码中使用的实际类型参数。

如果异常的类型是一个类型变量或是一个参数化类型，则创建它。否则将解析它。

返回：
表示底层方法抛出的异常类型的一组 Type 对象
抛出：
GenericSignatureFormatError - 如果一般方法的签名不符合 Java Virtual Machine Specification, 3rd edition 指定的格式
TypeNotPresentException - 如果底层方法的 throws 子句引用了不存在的类型声明
MalformedParameterizedTypeException - 如果底层方法的 throws 子句引用了因某种原因而无法实例化的参数化类型
从以下版本开始：
1.5

equals

public boolean equals(Object obj)
将此 Constructor 对象与指定的对象进行比较。如果对象相同，则返回 true。如果由相同的类声明并且具有相同的形参类型，那么这两个 Constructor 对象是相同的。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 Constructor 的哈希码。该哈希码与底层构造方法的声明类名的哈希码相同。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回描述此 Constructor 的字符串。该字符串是作为构造方法访问修饰符（如果有）格式化的，其后面是声明类的完全限定名，再往后是构造方法形参类型的加括号的、逗号分隔的列表。例如：
    public java.util.Hashtable(int,float)

构造方法唯一可能的修饰符是访问修饰符 public、protected 或 private。这些修饰符只能出现一个，或者一个也不出现（如果构造方法具有默认（包）访问权）。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

toGenericString

public String toGenericString()
返回描述此 Constructor 的字符串，其中包括类型参数。该字符串是作为构造方法访问修饰符（如果有）格式化的，其后面是构造方法的类型参数（如果有）的加尖括号的、逗号分隔的列表，再往后是声明类的完全限定名，再往后是该构造方法的一般形参类型的加括号的、逗号分隔的列表。空格用来分隔访问修饰符与访问修饰符，以及访问修饰符与类型参数或返回值。如果没有类型参数，则省略类型参数列表；如果存在类型参数列表，则用空格分隔列表与类名。如果声明构造方法抛出异常，则参数列表后跟着一个空格，再往后是单词 "throws" ，再往后是用逗号分隔的所抛出异常类型的列表。

构造方法唯一可能的修饰符是访问修饰符 public、protected 或 private。这些修饰符只能出现一个，或者一个也不出现（如果构造方法具有默认（包）访问权）。

返回：
描述此 Constructor 的字符串，其中包括类型参数
从以下版本开始：
1.5

newInstance

public T newInstance(Object... initargs)
              throws InstantiationException,
                     IllegalAccessException,
                     IllegalArgumentException,
                     InvocationTargetException
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。个别参数会自动解包，以匹配基本形参，必要时，基本参数和引用参数都要进行方法调用转换。

如果底层构造方法所需形参数为 0，则所提供的 initargs 数组的长度可能为 0 或 null。

如果构造方法的声明类是非静态上下文的内部类，则构造方法的第一个参数需要是封闭实例；请参阅Java 语言规范 第 15.9.3 节。

如果所需的访问检查和参数检查获得成功并且实例化继续进行，这时构造方法的声明类尚未初始化，则初始化这个类。

如果构造方法正常完成，则返回新创建且已初始化的实例。

参数：
initargs - 将作为变量传递给构造方法调用的对象数组；基本类型的值被包装在适当类型的包装器对象（如 Float 中的 float）中。
返回：
通过调用此对象表示的构造方法来创建的新对象
抛出：
IllegalAccessException - 如果此 Constructor 对象实施 Java 语言访问控制并且底层构造方法是不可访问的。
IllegalArgumentException - 如果实参和形参的数量不同；如果基本参数的解包转换失败；如果在可能的解包后，无法通过方法调用转换将参数值转换为相应的形参类型；如果此构造方法属于枚举类型。
InstantiationException - 如果声明底层构造方法的类表示抽象类。
InvocationTargetException - 如果底层构造方法抛出异常。
ExceptionInInitializerError - 如果此方法引发的初始化失败。

isVarArgs

public boolean isVarArgs()
如果声明此构造方法可以带可变数量的参数，则返回 true；否则返回 false。

返回：
当且仅当声明此构造方法可以带可变数量的参数时才返回 true。
从以下版本开始：
1.5

isSynthetic

public boolean isSynthetic()
如果此构造方法是一个复合构造方法，则返回 true；否则返回 false。

指定者：
接口 Member 中的 isSynthetic
返回：
当且仅当此构造方法是按照 Java Language Specification 定义的复合构造方法时才返回 true。
从以下版本开始：
1.5

getAnnotation

public <T extends Annotation> T getAnnotation(Class<T> annotationClass)
从接口 AnnotatedElement 复制的描述
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

指定者：
接口 AnnotatedElement 中的 getAnnotation
覆盖：
类 AccessibleObject 中的 getAnnotation
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果该元素的指定注释类型的注释存在于此对象上，则返回这些注释，否则返回 null
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getDeclaredAnnotations

public Annotation[] getDeclaredAnnotations()
从接口 AnnotatedElement 复制的描述
返回直接存在于此元素上的所有注释。与此接口中的其他方法不同，该方法将忽略继承的注释。（如果没有注释直接存在于此元素上，则返回长度为零的一个数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getDeclaredAnnotations
覆盖：
类 AccessibleObject 中的 getDeclaredAnnotations
返回：
直接存在于此元素上的所有注释
从以下版本开始：
1.5

getParameterAnnotations

public Annotation[][] getParameterAnnotations()
按照声明顺序返回一组数组，这些数组表示通过此 Constructor 对象表示的方法的形参上的注释。（如果底层方法没有参数，则返回一个长度为零的数组。如果该方法有一个或多个参数，则为每个不带注释的参数返回一个长度为零的嵌套数组。）包含在返回数组中的注释对象是可序列化的。此方法的调用者可以自由地修改返回的数组；它对返回给其他调用者的数组没有影响。

返回：
按照声明顺序返回的一组数组，这些数组表示此 Constructor 对象表示的方法的形参上的注释
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Field (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 Field

java.lang.Object
    继承者  java.lang.reflect.AccessibleObject
        继承者  java.lang.reflect.Field
所有已实现的接口：
AnnotatedElement, Member
public final class Field
extends AccessibleObject
implements Member

Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。反射的字段可能是一个类（静态）字段或实例字段。

Array 允许在执行 get 或 set 访问操作期间进行扩展转换，但如果将发生收缩转换，则抛出一个 IllegalArgumentException。

另请参见：
Member,
Class,
Class.getFields(),
Class.getField(String),
Class.getDeclaredFields(),
Class.getDeclaredField(String)

字段摘要
从接口 java.lang.reflect.Member 继承的字段
DECLARED, PUBLIC
方法摘要
 boolean equals(Object obj)
将此 Field 与指定对象比较。
 Object get(Object obj)
返回指定对象上此 Field 表示的字段的值。
<T extends Annotation>
T
getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
 boolean getBoolean(Object obj)
获取一个静态或实例 boolean 字段的值。
 byte getByte(Object obj)
获取一个静态或实例 byte 字段的值。
 char getChar(Object obj)
获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。
 Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。
 Class<?> getDeclaringClass()
返回表示类或接口的 Class 对象，该类或接口声明由此 Field 对象表示的字段。
 double getDouble(Object obj)
获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。
 float getFloat(Object obj)
获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。
 Type getGenericType()
返回一个 Type 对象，它表示此 Field 对象所表示字段的声明类型。
 int getInt(Object obj)
获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。
 long getLong(Object obj)
获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。
 int getModifiers()
以整数形式返回由此 Field 对象表示的字段的 Java 语言修饰符。
 String getName()
返回此 Field 对象表示的字段的名称。
 short getShort(Object obj)
获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。
 Class<?> getType()
返回一个 Class 对象，它标识了此 Field 对象所表示字段的声明类型。
 int hashCode()
返回该 Field 的哈希码。
 boolean isEnumConstant()
如果此字段表示枚举类型的元素，则返回 true；否则返回 false。
 boolean isSynthetic()
如果此字段是复合字段，则返回 true；否则返回 false。
 void set(Object obj, Object value)
将指定对象变量上此 Field 对象表示的字段设置为指定的新值。
 void setBoolean(Object obj, boolean z)
将字段的值设置为指定对象上的一个 boolean 值。
 void setByte(Object obj, byte b)
将字段的值设置为指定对象上的一个 byte 值。
 void setChar(Object obj, char c)
将字段的值设置为指定对象上的一个 char 值。
 void setDouble(Object obj, double d)
将字段的值设置为指定对象上的一个 double 值。
 void setFloat(Object obj, float f)
将字段的值设置为指定对象上的一个 float 值。
 void setInt(Object obj, int i)
将字段的值设置为指定对象上的一个 int 值。
 void setLong(Object obj, long l)
将字段的值设置为指定对象上的一个 long 值。
 void setShort(Object obj, short s)
将字段的值设置为指定对象上的一个 short 值。
 String toGenericString()
返回一个描述此 Field（包括其一般类型）的字符串。
 String toString()
返回一个描述此 Field 的字符串。
从类 java.lang.reflect.AccessibleObject 继承的方法
getAnnotations, isAccessible, isAnnotationPresent, setAccessible, setAccessible
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getDeclaringClass

public Class<?> getDeclaringClass()
返回表示类或接口的 Class 对象，该类或接口声明由此 Field 对象表示的字段。

指定者：
接口 Member 中的 getDeclaringClass
返回：
表示声明底层成员的类的对象

getName

public String getName()
返回此 Field 对象表示的字段的名称。

指定者：
接口 Member 中的 getName
返回：
底层成员的简单名称

getModifiers

public int getModifiers()
以整数形式返回由此 Field 对象表示的字段的 Java 语言修饰符。应该使用 Modifier 类对这些修饰符进行解码。

指定者：
接口 Member 中的 getModifiers
返回：
底层成员的 Java 语言修饰符
另请参见：
Modifier

isEnumConstant

public boolean isEnumConstant()
如果此字段表示枚举类型的元素，则返回 true；否则返回 false。

返回：
当且仅当此字段表示一个枚举类型的元素时，才返回 true。
从以下版本开始：
1.5

isSynthetic

public boolean isSynthetic()
如果此字段是复合字段，则返回 true；否则返回 false。

指定者：
接口 Member 中的 isSynthetic
返回：
当且仅当此字段是一个按 Java Language Specification 定义的复合字段时，才返回 true。
从以下版本开始：
1.5

getType

public Class<?> getType()
返回一个 Class 对象，它标识了此 Field 对象所表示字段的声明类型。

返回：
标识此对象所表示字段的声明类型的 Class 对象

getGenericType

public Type getGenericType()
返回一个 Type 对象，它表示此 Field 对象所表示字段的声明类型。

如果 Type 是一个参数化类型，则返回的 Type 对象必须准确地反映源代码中使用的实际类型参数。

如果底层字段的类型是一个类型变量或者是一个参数化类型，则创建它。否则将解析它。

返回：
返回表示此 Field 对象所表示字段的声明类型的 Type 对象
抛出：
GenericSignatureFormatError - 如果一般字段签名不符合 Java Virtual Machine Specification, 3rd edition 中指定的格式
TypeNotPresentException - 如果底层字段的一般类型签名引用了不存在的类型声明
MalformedParameterizedTypeException - 如果底层字段的一般签名引用了一个因某种原因而无法实例化的参数化类型
从以下版本开始：
1.5

equals

public boolean equals(Object obj)
将此 Field 与指定对象比较。如果对象是相同的，则返回 true。如果由相同的类声明并且具有相同的名称和类型，那么这两个 Field 对象是相同的。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回该 Field 的哈希码。这作为底层字段的声明类名及其名称的哈希码的异或进行计算。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回一个描述此 Field 的字符串。格式是：该字段（如果存在的话）的访问修饰符，后面跟着字段类型和一个空格，再后面是声明该字段的类的完全限定名，后面跟着一个句点，最后是字段的名称。例如：
    public static final int java.lang.Thread.MIN_PRIORITY
    private int java.io.FileDescriptor.fd

修饰符是按照 "The Java Language Specification" 中指定的规范化顺序放置的。public、protected 或 private 的修饰符放在最前面，然后按以下顺序放置其他修饰符：static、final、transient 和 volatile。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

toGenericString

public String toGenericString()
返回一个描述此 Field（包括其一般类型）的字符串。格式是：该字段（如果存在的话）的访问修饰符，后面跟着一般字段类型和一个空格，再后面是声明该字段的类的完全限定名，后面跟着一个句点，最后是字段的名称。

修饰符是按照 "The Java Language Specification" 中指定的规范化顺序放置的。public、protected 或 private 的修饰符放在最前面，然后按以下顺序放置其他修饰符：static、final、transient 和 volatile。

返回：
描述此 Field（包括其一般类型）的字符串
从以下版本开始：
1.5

get

public Object get(Object obj)
           throws IllegalArgumentException,
                  IllegalAccessException
返回指定对象上此 Field 表示的字段的值。如果该值是一个基本类型值，则自动将其包装在一个对象中。

底层字段的值是按以下方式获得的：

如果底层字段是一个静态字段，则忽略 obj 变量；它可能为 null。

否则，底层字段是一个实例字段。如果指定的 obj 变量为 null，则该方法将抛出一个 NullPointerException。如果指定对象不是声明底层字段的类或接口的实例，则该方法将抛出一个 IllegalArgumentException。

如果此 Field 对象强制实施 Java 语言访问控制，并且底层字段是不可访问的，则该方法将抛出一个 IllegalAccessException。如果底层字段是静态的，并且声明该字段的类尚未初始化，则初始化这个类。

否则，从底层实例字段或静态字段中获取该值。如果该字段是一个基本类型字段，则在返回前将该值包装在一个对象中，否则照原样返回。

如果字段隐藏在 obj 的类型中，则根据前面的规则获得字段的值。

参数：
obj - 从中提取所表示字段的值的对象
返回：
对象 obj 中的所表示字段的值；在返回之前，基值包装在一个适当的对象中
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。

getBoolean

public boolean getBoolean(Object obj)
                   throws IllegalArgumentException,
                          IllegalAccessException
获取一个静态或实例 boolean 字段的值。

参数：
obj - 从中提取 boolean 值的对象
返回：
boolean 字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 boolean 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

getByte

public byte getByte(Object obj)
             throws IllegalArgumentException,
                    IllegalAccessException
获取一个静态或实例 byte 字段的值。

参数：
obj - 从中提取 byte 值的对象
返回：
byte 字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 byte 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

getChar

public char getChar(Object obj)
             throws IllegalArgumentException,
                    IllegalAccessException
获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。

参数：
obj - 从中提取 char 值的对象
返回：
转换为 char 类型的字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 char 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

getShort

public short getShort(Object obj)
               throws IllegalArgumentException,
                      IllegalAccessException
获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。

参数：
obj - 从中提取 short 值的对象
返回：
转换为 short 类型的字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 short 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

getInt

public int getInt(Object obj)
           throws IllegalArgumentException,
                  IllegalAccessException
获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。

参数：
obj - 从中提取 int 值的对象
返回：
转换为 int 类型的字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 int 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

getLong

public long getLong(Object obj)
             throws IllegalArgumentException,
                    IllegalAccessException
获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。

参数：
obj - 从中提取 long 值的对象
返回：
转换为 long 类型的字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 long 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

getFloat

public float getFloat(Object obj)
               throws IllegalArgumentException,
                      IllegalAccessException
获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。

参数：
obj - 从中提取 float 值的对象
返回：
转换为 float 类型的字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 float 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

getDouble

public double getDouble(Object obj)
                 throws IllegalArgumentException,
                        IllegalAccessException
获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。

参数：
obj - 从中提取 double 值的对象
返回：
转换为 double 类型的字段的值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者无法通过扩展转换将字段值转换为 double 类型。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
get(java.lang.Object)

set

public void set(Object obj,
                Object value)
         throws IllegalArgumentException,
                IllegalAccessException
将指定对象变量上此 Field 对象表示的字段设置为指定的新值。如果底层字段的类型为基本类型，则对新值进行自动解包。

进行此操作的方式如下：

如果底层字段是静态字段，则忽略 obj 变量；它可能为 null。

否则底层字段是一个实例字段。如果指定对象变量为 null，则该方法将抛出一个 NullPointerException。如果指定对象变量不是声明底层字段的类或接口的实例，则该方法将抛出一个 IllegalArgumentException。

如果此 Field 对象实施 Java 语言访问控制，并且底层字段是不可访问的，则该方法将抛出一个 IllegalAccessException。

如果底层字段为 final 字段，则该方法将抛出一个 IllegalAccessException，除非 setAccessible(true) 已经继承该字段并且该字段是一个非静态字段。在通过程序的其他部分可以访问类的实例之前，只有使用空白 final 字段反序列化或重构类的实例期间，以这种方式设置 final 字段才有意义。在其他任何上下文中使用该方法都可能会有不可预知的结果，包括程序的其他部分继续使用该字段的原始值的情况。

如果底层字段的类型为某一基本类型，则可以尝试使用解包转换将新值转换为基本类型的值。如果该尝试失败，则此方法将抛出一个 IllegalArgumentException。

如果在进行可能的解包之后，无法通过某一标识或扩展转换将新值转换为底层字段的类型，则此方法将抛出一个 IllegalArgumentException。

如果底层字段是静态的，并且声明该字段的类尚未初始化，则初始化这个类。

字段被设置为可能已解包并扩大的新值。

如果字段隐藏在 obj 的类型中，则根据前面的规则设置字段的值。

参数：
obj - 应该修改其字段的对象
value - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。

setBoolean

public void setBoolean(Object obj,
                       boolean z)
                throws IllegalArgumentException,
                       IllegalAccessException
将字段的值设置为指定对象上的一个 boolean 值。该方法等同于 set(obj, zObj)，其中 zObj 是一个 Boolean 对象，并且 zObj.booleanValue() == z。

参数：
obj - 应该修改其字段的对象
z - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

setByte

public void setByte(Object obj,
                    byte b)
             throws IllegalArgumentException,
                    IllegalAccessException
将字段的值设置为指定对象上的一个 byte 值。该方法等同于 set(obj, bObj)，其中 bObj 是一个 Byte 对象，并且 bObj.byteValue() == b。

参数：
obj - 应该修改其字段的对象
b - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

setChar

public void setChar(Object obj,
                    char c)
             throws IllegalArgumentException,
                    IllegalAccessException
将字段的值设置为指定对象上的一个 char 值。该方法等同于 set(obj, cObj)，其中 cObj 是一个 Character 对象，并且 cObj.charValue() == c。

参数：
obj - 应该修改其字段的对象
c - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

setShort

public void setShort(Object obj,
                     short s)
              throws IllegalArgumentException,
                     IllegalAccessException
将字段的值设置为指定对象上的一个 short 值。该方法等同于 set(obj, sObj)，其中 sObj 是一个 Short 对象，并且 sObj.shortValue() == s。

参数：
obj - 应该修改其字段的对象
s - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

setInt

public void setInt(Object obj,
                   int i)
            throws IllegalArgumentException,
                   IllegalAccessException
将字段的值设置为指定对象上的一个 int 值。该方法等同于 set(obj, iObj)，其中 iObj 是一个 Integer 对象，并且 iObj.intValue() == i。

参数：
obj - 应该修改其字段的对象
i - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

setLong

public void setLong(Object obj,
                    long l)
             throws IllegalArgumentException,
                    IllegalAccessException
将字段的值设置为指定对象上的一个 long 值。该方法等同于 set(obj, lObj)，其中 lObj 是一个 Long 对象，并且 lObj.longValue() == l。

参数：
obj - 应该修改其字段的对象
l - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

setFloat

public void setFloat(Object obj,
                     float f)
              throws IllegalArgumentException,
                     IllegalAccessException
将字段的值设置为指定对象上的一个 float 值。该方法等同于 set(obj, fObj)，其中 fObj 是一个 Float 对象，并且 fObj.floatValue() == f。

参数：
obj - 应该修改其字段的对象
f - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

setDouble

public void setDouble(Object obj,
                      double d)
               throws IllegalArgumentException,
                      IllegalAccessException
将字段的值设置为指定对象上的一个 double 值。该方法等同于 set(obj, dObj)，其中 dObj 是一个 Double 对象，并且 dObj.doubleValue() == d。

参数：
obj - 应该修改其字段的对象
d - 正被修改的 obj 的字段的新值
抛出：
IllegalAccessException - 如果底层字段是不可访问的。
IllegalArgumentException - 如果指定对象不是声明底层字段（或者其子类或实现者）的类或接口的实例，或者解包转换失败。
NullPointerException - 如果指定对象为 null 并且字段是一个实例字段。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
另请参见：
set(java.lang.Object, java.lang.Object)

getAnnotation

public <T extends Annotation> T getAnnotation(Class<T> annotationClass)
从接口 AnnotatedElement 复制的描述
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

指定者：
接口 AnnotatedElement 中的 getAnnotation
覆盖：
类 AccessibleObject 中的 getAnnotation
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果该元素的指定注释类型的注释存在于此对象上，则返回这些注释，否则返回 null
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getDeclaredAnnotations

public Annotation[] getDeclaredAnnotations()
从接口 AnnotatedElement 复制的描述
返回直接存在于此元素上的所有注释。与此接口中的其他方法不同，该方法将忽略继承的注释。（如果没有注释直接存在于此元素上，则返回长度为零的一个数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getDeclaredAnnotations
覆盖：
类 AccessibleObject 中的 getDeclaredAnnotations
返回：
直接存在于此元素上的所有注释
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GenericArrayType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 GenericArrayType

所有超级接口：
Type
public interface GenericArrayType
extends Type

GenericArrayType 表示一种数组类型，其组件类型为参数化类型或类型变量。

从以下版本开始：
1.5

方法摘要
 Type getGenericComponentType()
返回表示此数组的组件类型的 Type 对象。

方法详细信息

getGenericComponentType

Type getGenericComponentType()
返回表示此数组的组件类型的 Type 对象。此方法创建数组的组件类型。请参见 ParameterizedType 的声明获得参数化类型创建过程的语义，参见 TypeVariable 获得创建类型变量的过程。

返回：
表示此数组的组件类型的 Type 对象
抛出：
TypeNotPresentException - 如果基础数组类型的组件类型引用的是不存在的类型声明
MalformedParameterizedTypeException - 如果基础数组类型的组件类型引用的是无论如何无法实例化的参数化类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GenericDeclaration (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 GenericDeclaration

所有已知实现类：
Class, Constructor, Method
public interface GenericDeclaration

声明类型变量的所有实体的公共接口。

从以下版本开始：
1.5

方法摘要
 TypeVariable<?>[] getTypeParameters()
返回声明顺序的 TypeVariable 对象的数组，这些对象表示由此 GenericDeclaration 对象表示的一般声明声明的类型变量。

方法详细信息

getTypeParameters

TypeVariable<?>[] getTypeParameters()
返回声明顺序的 TypeVariable 对象的数组，这些对象表示由此 GenericDeclaration 对象表示的一般声明声明的类型变量。如果底层的一般声明未声明任何类型变量，则返回一个 0 长度的数组。

返回：
表示由此一般声明声明的类型变量的 TypeVariable 对象的数组
抛出：
GenericSignatureFormatError - 如果此一般声明的一般签名不符合 Java Virtual Machine Specification, 3rd edition 指定的格式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GenericSignatureFormatError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 GenericSignatureFormatError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.LinkageError
                继承者  java.lang.ClassFormatError
                    继承者  java.lang.reflect.GenericSignatureFormatError
所有已实现的接口：
Serializable
public class GenericSignatureFormatError
extends ClassFormatError

当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
GenericSignatureFormatError()
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

GenericSignatureFormatError

public GenericSignatureFormatError()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvocationHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 InvocationHandler

所有已知实现类：
CompositeDataInvocationHandler, EventHandler, MBeanServerInvocationHandler, RemoteObjectInvocationHandler
public interface InvocationHandler

InvocationHandler 是代理实例的调用处理程序 实现的接口。

每个代理实例都具有一个关联的调用处理程序。对代理实例调用方法时，将对方法调用进行编码并将其指派到它的调用处理程序的 invoke 方法。

从以下版本开始：
1.3
另请参见：
Proxy

方法摘要
 Object invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

方法详细信息

invoke

Object invoke(Object proxy,
              Method method,
              Object[] args)
              throws Throwable
在代理实例上处理方法调用并返回结果。在与方法关联的代理实例上调用方法时，将在调用处理程序上调用此方法。

参数：
proxy - 在其上调用方法的代理实例
method - 对应于在代理实例上调用的接口方法的 Method 实例。Method 对象的声明类将是在其中声明方法的接口，该接口可以是代理类赖以继承方法的代理接口的超接口。
args - 包含传入代理实例上方法调用的参数值的对象数组，如果接口方法不使用参数，则为 null。基本类型的参数被包装在适当基本包装器类（如 java.lang.Integer 或 java.lang.Boolean）的实例中。
返回：
从代理实例的方法调用返回的值。如果接口方法的声明返回类型是基本类型，则此方法返回的值一定是相应基本包装对象类的实例；否则，它一定是可分配到声明返回类型的类型。如果此方法返回的值为 null 并且接口方法的返回类型是基本类型，则代理实例上的方法调用将抛出 NullPointerException。否则，如果此方法返回的值与上述接口方法的声明返回类型不兼容，则代理实例上的方法调用将抛出 ClassCastException。
抛出：
Throwable - 从代理实例上的方法调用抛出的异常。该异常的类型必须可以分配到在接口方法的 throws 子句中声明的任一异常类型或未经检查的异常类型 java.lang.RuntimeException 或 java.lang.Error。如果此方法抛出经过检查的异常，该异常不可分配到在接口方法的 throws 子句中声明的任一异常类型，代理实例的方法调用将抛出包含此方法曾抛出的异常的 UndeclaredThrowableException。
另请参见：
UndeclaredThrowableException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvocationTargetException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 InvocationTargetException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.reflect.InvocationTargetException
所有已实现的接口：
Serializable
public class InvocationTargetException
extends Exception

InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。

从版本 1.4 开始，此异常已经更新，符合通用异常链机制。“目标异常”是在构造的时候提供的，可以通过 getTargetException() 方法访问，这类对象目前被认为是导致异常的原因，可以通过 Throwable.getCause() 方法以及前面提到的“遗留方法”访问它。

另请参见：
Method, Constructor, 序列化表格

构造方法摘要
protected | InvocationTargetException() 构造以 null 作为目标异常的 InvocationTargetException。
 | InvocationTargetException(Throwable target) 构造带目标异常的 InvocationTargetException。
 | InvocationTargetException(Throwable target, String s) 构造带目标异常和详细消息的 InvocationTargetException。
方法摘要
Throwable | getCause() 返回此异常的原因（抛出的目标异常，可能为 null）。
Throwable | getTargetException() 获取抛出的目标异常。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvocationTargetException

protected InvocationTargetException()
构造以 null 作为目标异常的 InvocationTargetException。

InvocationTargetException

public InvocationTargetException(Throwable target)
构造带目标异常的 InvocationTargetException。

参数：
target - 目标异常

InvocationTargetException

public InvocationTargetException(Throwable target,
                                 String s)
构造带目标异常和详细消息的 InvocationTargetException。

参数：
target - 目标异常
s - 详细消息
方法详细信息

getTargetException

public Throwable getTargetException()
获取抛出的目标异常。

该方法早于通用异常链设施。Throwable.getCause() 方法现在是获得此信息的首选方法。

返回：
抛出的目标异常（此异常的原因）。

getCause

public Throwable getCause()
返回此异常的原因（抛出的目标异常，可能为 null）。

覆盖：
类 Throwable 中的 getCause
返回：
此异常的原因。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MalformedParameterizedTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 MalformedParameterizedTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.reflect.MalformedParameterizedTypeException
所有已实现的接口：
Serializable
public class MalformedParameterizedTypeException
extends RuntimeException

当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。例如，如果参数化类型的类型参数错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MalformedParameterizedTypeException()
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MalformedParameterizedTypeException

public MalformedParameterizedTypeException()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Member (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 Member

所有已知实现类：
Constructor, Field, Method
public interface Member

成员是一种接口，反映有关单个成员（字段或方法）或构造方法的标识信息。

另请参见：
Class, Field, Method, Constructor

字段摘要
static int | DECLARED 标识类或接口的所有已声明成员的集合。
static int | PUBLIC 标识类或接口的所有公共成员（包括继承成员）的集合。
方法摘要
Class<?> | getDeclaringClass() 返回表示声明由此 Member 表示的成员或构造方法的类或接口的 Class 对象。
int | getModifiers() 作为整数返回由此 Member 所表示的成员或构造方法的 Java 语言修饰符。
String | getName() 返回此 Member 表示的底层成员或构造方法的简单名称。
boolean | isSynthetic() 如果此成员是编译器引入的，则返回 true；否则，返回 false。

字段详细信息

PUBLIC

static final int PUBLIC
标识类或接口的所有公共成员（包括继承成员）的集合。

另请参见：
SecurityManager.checkMemberAccess(java.lang.Class, int), 常量字段值

DECLARED

static final int DECLARED
标识类或接口的所有已声明成员的集合。不包括继承成员。

另请参见：
SecurityManager.checkMemberAccess(java.lang.Class, int), 常量字段值
方法详细信息

getDeclaringClass

Class<?> getDeclaringClass()
返回表示声明由此 Member 表示的成员或构造方法的类或接口的 Class 对象。

返回：
表示声明底层成员的类的对象

getName

String getName()
返回此 Member 表示的底层成员或构造方法的简单名称。

返回：
底层成员的简单名称

getModifiers

int getModifiers()
作为整数返回由此 Member 所表示的成员或构造方法的 Java 语言修饰符。应该使用 Modifier 类解码整数中的修饰符。

返回：
底层成员的 Java 语言修饰符
另请参见：
Modifier

isSynthetic

boolean isSynthetic()
如果此成员是编译器引入的，则返回 true；否则，返回 false。

返回：
当且仅当编译器引入此对象时，才返回 true。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Method (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 Method

java.lang.Object
    继承者  java.lang.reflect.AccessibleObject
        继承者  java.lang.reflect.Method
所有已实现的接口：
AnnotatedElement, GenericDeclaration, Member
public final class Method
extends AccessibleObject
implements GenericDeclaration, Member

Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。所反映的方法可能是类方法或实例方法（包括抽象方法）。

Method 允许在匹配要调用的实参与底层方法的形参时进行扩展转换；但如果要进行收缩转换，则会抛出 IllegalArgumentException。

另请参见：
Member,
Class,
Class.getMethods(),
Class.getMethod(String, Class[]),
Class.getDeclaredMethods(),
Class.getDeclaredMethod(String, Class[])

字段摘要
从接口 java.lang.reflect.Member 继承的字段
DECLARED, PUBLIC
方法摘要
 boolean equals(Object obj)
将此 Method 与指定对象进行比较。
<T extends Annotation>
T
getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
 Annotation[] getDeclaredAnnotations()
返回直接存在于此元素上的所有注释。
 Class<?> getDeclaringClass()
返回表示声明由此 Method 对象表示的方法的类或接口的 Class 对象。
 Object getDefaultValue()
返回由此 Method 实例表示的注释成员的默认值。
 Class<?>[] getExceptionTypes()
返回 Class 对象的数组，这些对象描述了声明将此 Method 对象表示的底层方法抛出的异常类型。
 Type[] getGenericExceptionTypes()
返回 Type 对象数组，这些对象描述了声明由此 Method 对象抛出的异常。
 Type[] getGenericParameterTypes()
按照声明顺序返回 Type 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型的。
 Type getGenericReturnType()
返回表示由此 Method 对象所表示方法的正式返回类型的 Type 对象。
 int getModifiers()
以整数形式返回此 Method 对象所表示方法的 Java 语言修饰符。
 String getName()
以 String 形式返回此 Method 对象表示的方法名称。
 Annotation[][] getParameterAnnotations()
返回表示按照声明顺序对此 Method 对象所表示方法的形参进行注释的那个数组的数组。
 Class<?>[] getParameterTypes()
按照声明顺序返回 Class 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型。
 Class<?> getReturnType()
返回一个 Class 对象，该对象描述了此 Method 对象所表示的方法的正式返回类型。
 TypeVariable<Method>[] getTypeParameters()
返回 TypeVariable 对象的数组，这些对象描述了由 GenericDeclaration 对象表示的一般声明按声明顺序来声明的类型变量。
 int hashCode()
返回此 Method 的哈希码。
 Object invoke(Object obj, Object... args)
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
 boolean isBridge()
如果此方法是 bridge 方法，则返回 true；否则，返回 false。
 boolean isSynthetic()
如果此方法为复合方法，则返回 true；否则，返回 false。
 boolean isVarArgs()
如果将此方法声明为带有可变数量的参数，则返回 true；否则，返回 false。
 String toGenericString()
返回描述此 Method 的字符串，包括类型参数。
 String toString()
返回描述此 Method 的字符串。
从类 java.lang.reflect.AccessibleObject 继承的方法
getAnnotations, isAccessible, isAnnotationPresent, setAccessible, setAccessible
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getDeclaringClass

public Class<?> getDeclaringClass()
返回表示声明由此 Method 对象表示的方法的类或接口的 Class 对象。

指定者：
接口 Member 中的 getDeclaringClass
返回：
表示声明底层成员的类的对象

getName

public String getName()
以 String 形式返回此 Method 对象表示的方法名称。

指定者：
接口 Member 中的 getName
返回：
底层成员的简单名称

getModifiers

public int getModifiers()
以整数形式返回此 Method 对象所表示方法的 Java 语言修饰符。应该使用 Modifier 类对修饰符进行解码。

指定者：
接口 Member 中的 getModifiers
返回：
底层成员的 Java 语言修饰符
另请参见：
Modifier

getTypeParameters

public TypeVariable<Method>[] getTypeParameters()
返回 TypeVariable 对象的数组，这些对象描述了由 GenericDeclaration 对象表示的一般声明按声明顺序来声明的类型变量。如果底层一般声明没有声明类型变量，则返回长度为 0 的数组。

指定者：
接口 GenericDeclaration 中的 getTypeParameters
返回：
TypeVariable 对象的数组，这些对象描述了通过一般声明来声明的类型变量
抛出：
GenericSignatureFormatError - 如果此一般声明的一般签名不符合 Java Virtual Machine Specification, 3rd edition 中指定的格式
从以下版本开始：
1.5

getReturnType

public Class<?> getReturnType()
返回一个 Class 对象，该对象描述了此 Method 对象所表示的方法的正式返回类型。

返回：
此对象所表示的方法的返回类型

getGenericReturnType

public Type getGenericReturnType()
返回表示由此 Method 对象所表示方法的正式返回类型的 Type 对象。

如果返回类型是参数化类型，则返回的 Type 对象必须实际反映源代码中所用参数的实际类型。

如果返回类型是类型变量或参数化类型，则创建它。否则将解析它。

返回：
表示底层方法的正式返回类型的 Type 对象
抛出：
GenericSignatureFormatError - 如果一般方法签名不符合 Java Virtual Machine Specification, 3rd edition 中指定的格式
TypeNotPresentException - 如果底层方法的返回类型引用不存在的类型声明
MalformedParameterizedTypeException - 如果底层方法的返回类型引用无论如何都无法实例化的参数化类型
从以下版本开始：
1.5

getParameterTypes

public Class<?>[] getParameterTypes()
按照声明顺序返回 Class 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型。如果底层方法不带参数，则返回长度为 0 的数组。

返回：
此对象所表示的方法的参数类型

getGenericParameterTypes

public Type[] getGenericParameterTypes()
按照声明顺序返回 Type 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型的。如果底层方法不带参数，则返回长度为 0 的数组。

如果形参类型是参数化类型，则为其返回的 Type 对象必须实际反映源代码中使用的实际类型参数。

如果形参类型是类型变量或参数化类型，则创建它。否则将解析它。

返回：
按照声明顺序返回表示底层方法的形参类型的 Type 对象数组
抛出：
GenericSignatureFormatError - 如果一般方法签名不符合 Java Virtual Machine Specification, 3rd edition 中指定的格式
TypeNotPresentException - 如果底层方法的所有参数类型都引用不存在的类型声明
MalformedParameterizedTypeException - 如果所有底层方法的参数类型引用无论如何都无法实例化的参数化类型
从以下版本开始：
1.5

getExceptionTypes

public Class<?>[] getExceptionTypes()
返回 Class 对象的数组，这些对象描述了声明将此 Method 对象表示的底层方法抛出的异常类型。如果此方法没有在其 throws 子句中声明异常，则返回长度为 0 的数组。

返回：
声明由此对象表示的方法抛出的异常类型

getGenericExceptionTypes

public Type[] getGenericExceptionTypes()
返回 Type 对象数组，这些对象描述了声明由此 Method 对象抛出的异常。如果底层方法没有在其 throws 子句中声明异常，则返回长度为 0 的数组。

如果异常类型是参数化的类型，那么为它返回的 Type 对象必须实际反映源代码中所用参数的实际类型。

如果异常类型是类型变量或参数化类型，则创建它。否则将解析它。

返回：
表示由底层方法抛出的异常类型的 Type 数组
抛出：
GenericSignatureFormatError - 如果一般方法签名不符合 Java Virtual Machine Specification, 3rd edition 中指定的格式
TypeNotPresentException - 如果底层方法的 throws 子句引用不存在的类型声明
MalformedParameterizedTypeException - 如果底层方法的 throws 子句引用无论如何都无法实例化的参数化类型
从以下版本开始：
1.5

equals

public boolean equals(Object obj)
将此 Method 与指定对象进行比较。如果对象相同，则返回 true。如果它们由相同的类声明，具有相同的名称、形参类型和返回类型，则两个 Method 相同。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 Method 的哈希码。哈希码按底层方法的声明类名称和方法名称的哈希码的异或计算。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回描述此 Method 的字符串。该字符串被格式化为方法访问修饰符（如果有），后面依次跟着方法返回类型、空格、声明方法的类、句点、方法名、括号以及由逗号分隔的方法的形参类型列表。如果方法抛出检查异常，则参数列表后跟着空格、单词 throws 以及由逗号分隔的抛出异常类型的列表。例如：
    public boolean java.lang.Object.equals(java.lang.Object)

访问修饰符按照由 "The Java Language Specification" 指定的规范化顺序放置。首先是 public，protected 或 private，接着是按以下顺序的其他修饰符：abstract、static、final、synchronized、native。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

toGenericString

public String toGenericString()
返回描述此 Method 的字符串，包括类型参数。该字符串被格式化为方法访问修饰符（如果有），依次后跟用尖括号括起来的由逗号分隔的方法类型参数列表（如果有）、方法的一般返回类型、空格、声明方法的类、句点、方法名、括号以及由逗号分隔的方法的一般形参类型列表。空格用于将访问修饰符和类型参数或返回类型互相分隔开。如果不存在类型参数，则类型参数列表会被省略；如果类型参数列表存在，则用空格将列表与类名分隔开。如果声明方法以抛出异常，则参数列表后跟空格、单词 throws 以及由逗号分隔开的抛出一般异常类型的列表。如果不存在类型参数，则类型参数列表会被省略。

访问修饰符按照 "The Java Language Specification" 指定的规范化顺序放置。首先是 public，protected 或 private，接着是按以下顺序的其他修饰符：abstract、static、final、synchronized native。

返回：
描述此 Method 方法的字符串，包括类型参数
从以下版本开始：
1.5

invoke

public Object invoke(Object obj,
                     Object... args)
              throws IllegalAccessException,
                     IllegalArgumentException,
                     InvocationTargetException
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。个别参数被自动解包，以便与基本形参相匹配，基本参数和引用参数都随需服从方法调用转换。

如果底层方法是静态的，那么可以忽略指定的 obj 参数。该参数可以为 null。

如果底层方法所需的形参数为 0，则所提供的 args 数组长度可以为 0 或 null。

如果底层方法是实例方法，则使用动态方法查找来调用它，这一点记录在 Java Language Specification, Second Edition 的第 15.12.4.4 节中；在发生基于目标对象的运行时类型的重写时更应该这样做。

如果底层方法是静态的，并且尚未初始化声明此方法的类，则会将其初始化。

如果方法正常完成，则将该方法返回的值返回给调用者；如果该值为基本类型，则首先适当地将其包装在对象中。但是，如果该值的类型为一组基本类型，则数组元素不 被包装在对象中；换句话说，将返回基本类型的数组。如果底层方法返回类型为 void，则该调用返回 null。

参数：
obj - 从中调用底层方法的对象
args - 用于方法调用的参数
返回：
使用参数 args 在 obj 上指派该对象所表示方法的结果
抛出：
IllegalAccessException - 如果此 Method 对象强制执行 Java 语言访问控制，并且底层方法是不可访问的。
IllegalArgumentException - 如果该方法是实例方法，且指定对象参数不是声明底层方法的类或接口（或其中的子类或实现程序）的实例；如果实参和形参的数量不相同；如果基本参数的解包转换失败；如果在解包后，无法通过方法调用转换将参数值转换为相应的形参类型。
InvocationTargetException - 如果底层方法抛出异常。
NullPointerException - 如果指定对象为 null，且该方法是一个实例方法。
ExceptionInInitializerError - 如果由此方法引起的初始化失败。

isBridge

public boolean isBridge()
如果此方法是 bridge 方法，则返回 true；否则，返回 false。

返回：
当且仅当此方法是由 Java Language Specification 定义的 bridge 方法时，才返回 true。
从以下版本开始：
1.5

isVarArgs

public boolean isVarArgs()
如果将此方法声明为带有可变数量的参数，则返回 true；否则，返回 false。

返回：
当且仅当将此方法声明为带有可变数量的参数时，才返回 true。
从以下版本开始：
1.5

isSynthetic

public boolean isSynthetic()
如果此方法为复合方法，则返回 true；否则，返回 false。

指定者：
接口 Member 中的 isSynthetic
返回：
当且仅当此方法是由 Java Language Specification 定义的复合方法时，才返回 true。
从以下版本开始：
1.5

getAnnotation

public <T extends Annotation> T getAnnotation(Class<T> annotationClass)
从接口 AnnotatedElement 复制的描述
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。

指定者：
接口 AnnotatedElement 中的 getAnnotation
覆盖：
类 AccessibleObject 中的 getAnnotation
参数：
annotationClass - 对应于注释类型的 Class 对象
返回：
如果该元素的指定注释类型的注释存在于此对象上，则返回这些注释，否则返回 null
抛出：
NullPointerException - 如果给定的注释类为 null
从以下版本开始：
1.5

getDeclaredAnnotations

public Annotation[] getDeclaredAnnotations()
从接口 AnnotatedElement 复制的描述
返回直接存在于此元素上的所有注释。与此接口中的其他方法不同，该方法将忽略继承的注释。（如果没有注释直接存在于此元素上，则返回长度为零的一个数组。）该方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

指定者：
接口 AnnotatedElement 中的 getDeclaredAnnotations
覆盖：
类 AccessibleObject 中的 getDeclaredAnnotations
返回：
直接存在于此元素上的所有注释
从以下版本开始：
1.5

getDefaultValue

public Object getDefaultValue()
返回由此 Method 实例表示的注释成员的默认值。如果该成员为基本类型，则返回相应包装器类型的实例。如果不存在与该成员关联的默认值或者该成员实例不表示注释类型的声明成员，则返回 null。

返回：
由此 Method 实例表示的注释成员的默认值。
抛出：
TypeNotPresentException - 如果注释类型是 Class 且找不到默认类值的定义。
从以下版本开始：
1.5

getParameterAnnotations

public Annotation[][] getParameterAnnotations()
返回表示按照声明顺序对此 Method 对象所表示方法的形参进行注释的那个数组的数组。（如果底层方法没有参数，则返回长度为零的数组。如果该方法有一个或多个参数，则为每个不带注释的参数返回长度为零的嵌套数组。）返回数组中包含的注释对象是可序列化的。此方法的调用者可以随意修改返回的数组；这不会对其他调用者返回的数组产生任何影响。

返回：
表示按声明顺序对此 Method 对象所表示方法的形参进行注释的那个数组的数组
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Modifier (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 Modifier

java.lang.Object
    继承者  java.lang.reflect.Modifier

public class Modifier
extends Object

Modifier 类提供了 static 方法和常量，对类和成员访问修饰符进行解码。修饰符集被表示为整数，用不同的位位置 (bit position) 表示不同的修饰符。表示修饰符的常量值取自于 The JavaTM Virtual Machine Specification, Second edition 的表 4.1、4.4、4.5 和 4.7。

另请参见：
Class.getModifiers(), Member.getModifiers()

字段摘要
static int | ABSTRACT 表示 abstract 修饰符的 int 的值。
static int | FINAL 表示 final 修饰符的 int 值。
static int | INTERFACE 表示 interface 修饰符的 int 的值。
static int | NATIVE 表示 native 修饰符的 int 的值。
static int | PRIVATE 表示 private 修饰符的 int 值。
static int | PROTECTED 表示 protected 修饰符的 int 值。
static int | PUBLIC 表示 public 修饰符的 int 值。
static int | STATIC 表示 static 修饰符的 int 值。
static int | STRICT 表示 strictfp 修饰符的 int 的值。
static int | SYNCHRONIZED 表示 synchronized 修饰符的 int 值。
static int | TRANSIENT 表示 transient 修饰符的 int 的值。
static int | VOLATILE 表示 volatile 修饰符的 int 值。
构造方法摘要
Modifier()
方法摘要
static boolean | isAbstract(int mod) 如果整数参数包括 abstract 修饰符，则返回 true，否则返回 false。
static boolean | isFinal(int mod) 如果整数参数包括 final 修饰符，则返回 true，否则返回 false。
static boolean | isInterface(int mod) 如果整数参数包括 interface 修饰符，则返回 true，否则返回 false。
static boolean | isNative(int mod) 如果整数参数包括 native 修饰符，则返回 true，否则返回 false。
static boolean | isPrivate(int mod) 如果整数参数包括 private 修饰符，则返回 true，否则返回 false。
static boolean | isProtected(int mod) 如果整数参数包括 protected 修饰符，则返回 true，否则返回 false。
static boolean | isPublic(int mod) 如果整数参数包括 public 修饰符，则返回 true，否则返回 false。
static boolean | isStatic(int mod) 如果整数参数包括 static 修饰符，则返回 true，否则返回 false。
static boolean | isStrict(int mod) 如果整数参数包括 strictfp 修饰符，则返回 true，否则返回 false。
static boolean | isSynchronized(int mod) 如果整数参数包括 synchronized 修饰符，则返回 true，否则返回 false。
static boolean | isTransient(int mod) 如果整数参数包括 transient 修饰符，则返回 true，否则返回 false。
static boolean | isVolatile(int mod) 如果整数参数包括 volatile 修饰符，则返回 true，否则返回 false。
static String | toString(int mod) 返回描述指定修饰符中的访问修饰符标志的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PUBLIC

public static final int PUBLIC
表示 public 修饰符的 int 值。

另请参见：
常量字段值

PRIVATE

public static final int PRIVATE
表示 private 修饰符的 int 值。

另请参见：
常量字段值

PROTECTED

public static final int PROTECTED
表示 protected 修饰符的 int 值。

另请参见：
常量字段值

STATIC

public static final int STATIC
表示 static 修饰符的 int 值。

另请参见：
常量字段值

FINAL

public static final int FINAL
表示 final 修饰符的 int 值。

另请参见：
常量字段值

SYNCHRONIZED

public static final int SYNCHRONIZED
表示 synchronized 修饰符的 int 值。

另请参见：
常量字段值

VOLATILE

public static final int VOLATILE
表示 volatile 修饰符的 int 值。

另请参见：
常量字段值

TRANSIENT

public static final int TRANSIENT
表示 transient 修饰符的 int 的值。

另请参见：
常量字段值

NATIVE

public static final int NATIVE
表示 native 修饰符的 int 的值。

另请参见：
常量字段值

INTERFACE

public static final int INTERFACE
表示 interface 修饰符的 int 的值。

另请参见：
常量字段值

ABSTRACT

public static final int ABSTRACT
表示 abstract 修饰符的 int 的值。

另请参见：
常量字段值

STRICT

public static final int STRICT
表示 strictfp 修饰符的 int 的值。

另请参见：
常量字段值
构造方法详细信息

Modifier

public Modifier()
方法详细信息

isPublic

public static boolean isPublic(int mod)
如果整数参数包括 public 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 public 修饰符，则返回 true；否则返回 false。

isPrivate

public static boolean isPrivate(int mod)
如果整数参数包括 private 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 private 修饰符，则返回 true；否则返回 false。

isProtected

public static boolean isProtected(int mod)
如果整数参数包括 protected 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 protected 修饰符，则返回 true；否则返回 false。

isStatic

public static boolean isStatic(int mod)
如果整数参数包括 static 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 static 修饰符，则返回 true；否则返回 false。

isFinal

public static boolean isFinal(int mod)
如果整数参数包括 final 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 final 修饰符，则返回 true；否则返回 false。

isSynchronized

public static boolean isSynchronized(int mod)
如果整数参数包括 synchronized 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 synchronized 修饰符，则返回 true；否则返回 false。

isVolatile

public static boolean isVolatile(int mod)
如果整数参数包括 volatile 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 volatile 修饰符，则返回 true；否则返回 false。

isTransient

public static boolean isTransient(int mod)
如果整数参数包括 transient 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 transient 修饰符，则返回 true；否则返回 false。

isNative

public static boolean isNative(int mod)
如果整数参数包括 native 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 native 修饰符，则返回 true；否则返回 false。

isInterface

public static boolean isInterface(int mod)
如果整数参数包括 interface 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 interface 修饰符，则返回 true；否则返回 false。

isAbstract

public static boolean isAbstract(int mod)
如果整数参数包括 abstract 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 abstract 修饰符，则返回 true；否则返回 false。

isStrict

public static boolean isStrict(int mod)
如果整数参数包括 strictfp 修饰符，则返回 true，否则返回 false。

参数：
mod - 修饰符集
返回：
如果 mod 包括 strictfp 修饰符，则返回 true；否则返回 false。

toString

public static String toString(int mod)
返回描述指定修饰符中的访问修饰符标志的字符串。例如：
    public final synchronized strictfp
返回的修饰符名称的顺序与 The Java Language Specification, Second Edition 的§8.1.1、§8.3.1、§8.4.3、§8.8.3 和 §9.1.1 中给出的建议修饰符排序是一致的。此方法使用的完整修饰符排序是：
public protected private abstract static final transient volatile synchronized native strictfp interface
这个类中讨论的 interface 修饰符不是真正的 Java 语言修饰符，它将出现在此方法列出的其他所有修饰符的后面。此方法可能返回一个不是有效 Java 实体修饰符的修饰符；换句话说，它没有对该输入表示的可能有效的组合修饰符进行检查。

参数：
mod - 修饰符集
返回：
mod 表示的修饰符集的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParameterizedType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 ParameterizedType

所有超级接口：
Type
public interface ParameterizedType
extends Type

ParameterizedType 表示参数化类型，如 Collection<String>。

参数化类型在反射方法首次需要时创建（在此包中指定）。当创建参数化类型 p 时，p 实例化的一般类型声明会被解析，并且按递归方式创建 p 的所有类型参数。有关类型变量创建过程的详细信息，请参阅 TypeVariable。重复创建的参数化类型无效。

实现此接口的类的实例必须实现 equals() 方法，该方法用于比较两个共享相同一般类型声明和具有相同类型参数的任何实例。

从以下版本开始：
1.5

方法摘要
Type[] | getActualTypeArguments() 返回表示此类型实际类型参数的 Type 对象的数组。
Type | getOwnerType() 返回 Type 对象，表示此类型是其成员之一的类型。
Type | getRawType() 返回 Type 对象，表示声明此类型的类或接口。

方法详细信息

getActualTypeArguments

Type[] getActualTypeArguments()
返回表示此类型实际类型参数的 Type 对象的数组。

注意，在某些情况下，返回的数组为空。如果此类型表示嵌套在参数化类型中的非参数化类型，则会发生这种情况。

返回：
表示此类型的实际类型参数的 Type 对象的数组
抛出：
TypeNotPresentException - 如果任何实际类型参数引用不存在的类型声明
MalformedParameterizedTypeException - 如果任何实际类型参数引用参数化类型，该类型出于某种原因无法被实例化
从以下版本开始：
1.5

getRawType

Type getRawType()
返回 Type 对象，表示声明此类型的类或接口。

返回：
Type 对象，表示声明此类型的类或接口
从以下版本开始：
1.5

getOwnerType

Type getOwnerType()
返回 Type 对象，表示此类型是其成员之一的类型。例如，如果此类型为 O<T>.I<S>，则返回 O<T> 的表示形式。

如果此类型为顶层类型，则返回 null。

返回：
Type 对象，表示此类型是其成员之一的类型。如果此类型是顶层类型，则返回 null
抛出：
TypeNotPresentException - 如果所有者类型引用了一个不存在的类型声明
MalformedParameterizedTypeException - 如果所有者类型引用了出于某些原因无法实例化的参数化类型
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Proxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 Proxy

java.lang.Object
    继承者  java.lang.reflect.Proxy
所有已实现的接口：
Serializable
public class Proxy
extends Object
implements Serializable

Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。

创建某一接口 Foo 的代理：

     InvocationHandler handler = new MyInvocationHandler(...);
     Class proxyClass = Proxy.getProxyClass(
         Foo.class.getClassLoader(), new Class[] { Foo.class });
     Foo f = (Foo) proxyClass.
         getConstructor(new Class[] { InvocationHandler.class }).
         newInstance(new Object[] { handler });
或使用以下更简单的方法：
     Foo f = (Foo) Proxy.newProxyInstance(Foo.class.getClassLoader(),
                                          new Class[] { Foo.class },
                                          handler);

动态代理类（以下简称为代理类）是一个实现在创建类时在运行时指定的接口列表的类，该类具有下面描述的行为。 代理接口 是代理类实现的一个接口。 代理实例 是代理类的一个实例。 每个代理实例都有一个关联的调用处理程序 对象，它可以实现接口 InvocationHandler。通过其中一个代理接口的代理实例上的方法调用将被指派到实例的调用处理程序的 Invoke 方法，并传递代理实例、识别调用方法的 java.lang.reflect.Method 对象以及包含参数的 Object 类型的数组。调用处理程序以适当的方式处理编码的方法调用，并且它返回的结果将作为代理实例上方法调用的结果返回。

代理类具用以下属性：

  • 代理类是公共的、最终的，而不是抽象的。
  • 未指定代理类的非限定名称。但是，以字符串 "$Proxy" 开头的类名空间应该为代理类保留。
  • 代理类扩展 java.lang.reflect.Proxy。
  • 代理类会按同一顺序准确地实现其创建时指定的接口。
  • 如果代理类实现了非公共接口，那么它将在与该接口相同的包中定义。否则，代理类的包也是未指定的。注意，包密封将不阻止代理类在运行时在特定包中的成功定义，也不会阻止相同类加载器和带有特定签名的包所定义的类。
  • 由于代理类将实现所有在其创建时指定的接口，所以对其 Class 对象调用 getInterfaces 将返回一个包含相同接口列表的数组（按其创建时指定的顺序），对其 Class 对象调用 getMethods 将返回一个包括这些接口中所有方法的 Method 对象的数组，并且调用 getMethod 将会在代理接口中找到期望的一些方法。
  • 如果 Proxy.isProxyClass 方法传递代理类（由 Proxy.getProxyClass 返回的类，或由 Proxy.newProxyInstance 返回的对象的类），则该方法返回 true，否则返回 false。
  • 代理类的 java.security.ProtectionDomain 与由引导类加载器（如 java.lang.Object）加载的系统类相同，原因是代理类的代码由受信任的系统代码生成。此保护域通常被授予 java.security.AllPermission。
  • 每个代理类都有一个可以带一个参数（接口 InvocationHandler 的实现）的公共构造方法，用于设置代理实例的调用处理程序。并非必须使用反射 API 才能访问公共构造方法，通过调用 Proxy.newInstance 方法（将调用 Proxy.getProxyClass 的操作和调用带有调用处理程序的构造方法结合在一起）也可以创建代理实例。

代理实例具有以下属性：

  • 提供代理实例 proxy 和一个由其代理类 Foo 实现的接口，以下表达式将返回 true：
         proxy instanceof Foo
    并且以下的强制转换操作将会成功（而不抛出 ClassCastException）：
         (Foo) proxy
  • 每个代理实例都有一个关联的调用处理程序，它会被传递到其构造方法中。静态 Proxy.getInvocationHandler 方法将返回与作为其参数传递的代理实例相关的调用处理程序。
  • 代理实例上的接口方法调用将按照该方法的文档描述进行编码，并被指派到调用处理程序的 Invoke 方法。
  • 在代理实例上的 java.lang.Object 中声明的 hashCode、equals 或 toString 方法的调用将按照与编码和指派接口方法调用相同的方式进行编码，并被指派到调用处理程序的 invoke 方法，如上所述。传递到 invoke 的 Method 对象的声明类是 java.lang.Object。代理类不重写从 java.lang.Object 继承的代理实例的其他公共方法，所以这些方法的调用行为与其对 java.lang.Object 实例的操作一样。

在多代理接口中重复的方法

当代理类的两个或多个接口包含一个具有相同名称和参数签名的方法时，代理类的接口顺序变得非常重要。在代理实例上调用重复方法 时，传递到调用处理程序的 Method 对象没有必要成为其声明类可以从接口（通过该接口调用代理方法）的引用类型指派的对象。此限制存在的原因是，生成的代理类中的相应方法实现无法确定它通过哪一个接口调用。因此，在代理实例上调用重复方法时，第一个接口中的方法的 Method 对象包含接口的代理类列表中的方法（直接或通过超级接口继承），该对象会传递到调用处理程序的 invoke 方法，无论该方法调用通过哪一种引用类型发生。

如果代理接口包含某一方法，它的名称和参数签名与 java.lang.Object 的 hashCode、equals 或 toString 方法相同，那么在代理实例上调用这样的方法时，传递到调用处理程序的 Method 对象将使 java.lang.Object 成为其声明类。换句话说，java.lang.Object 公共的非最终方法理论上在所有代理接口之前，以便确定哪一个 Method 对象传递到调用处理程序。

还要注意，当重复方法被指派到调用处理程序时，invoke 方法只可以抛出经过检查的异常类型，该异常类型可以使用所有 代理接口（可以通过它调用）中方法的 throws 子句指派一种异常类型。如果 invoke 方法抛出一个经过检查的异常，该异常没有指派给任何由一个代理接口（可以通过它调用）中的方法声明的异常类型，那么该代理实例上的调用将抛出一个未经检查的 UndeclaredThrowableException。此限制表示并非所有的由传递到 invoke 方法的 Method 对象上调用 getExceptionTypes 返回的异常类型都可以由 invoke 方法成功抛出。

从以下版本开始：
1.3
另请参见：
InvocationHandler, 序列化表格

字段摘要
protected  InvocationHandler h
此代理实例的调用处理程序。
构造方法摘要
protected Proxy(InvocationHandler h)
使用其调用处理程序的指定值从子类（通常为动态代理类）构建新的 Proxy 实例。
方法摘要
static InvocationHandler | getInvocationHandler(Object proxy) 返回指定代理实例的调用处理程序。
static Class<?> | getProxyClass(ClassLoader loader, Class<?>... interfaces) 返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
static boolean | isProxyClass(Class<?> cl) 当且仅当指定的类通过 getProxyClass 方法或 newProxyInstance 方法动态生成为代理类时，返回 true。
static Object | newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h) 返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

h

protected InvocationHandler h
此代理实例的调用处理程序。

构造方法详细信息

Proxy

protected Proxy(InvocationHandler h)
使用其调用处理程序的指定值从子类（通常为动态代理类）构建新的 Proxy 实例。

参数：
h - 此代理实例的调用处理程序
方法详细信息

getProxyClass

public static Class<?> getProxyClass(ClassLoader loader,
                                     Class<?>... interfaces)
                              throws IllegalArgumentException
返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。该代理类将由指定的类加载器定义，并将实现提供的所有接口。如果类加载器已经定义了具有相同排列接口的代理类，那么现有的代理类将被返回；否则，类加载器将动态生成并定义这些接口的代理类。

对可以传递给 Proxy.getProxyClass 的参数有以下几个限制：

  • interfaces 数组中的所有 Class 对象必须表示接口，而不能表示类或基本类型。
  • interfaces 数组中的两个元素不能引用同一 Class 对象。
  • 所有接口类型的名称通过特定的类加载器必须可见。换句话说，对于类加载器 cl 和所有接口 i，以下表达式必须为 true：
         Class.forName(i.getName(), false, cl) == i
  • 所有非公共接口必须位于同一包中；否则，该代理类将不可能实现所有的接口，无论它在哪一个包中定义。
  • 对于有相同签名的指定接口中任何成员方法集：
    • 如果任何方法的返回类型是基本类型或 void，那么所有的方法必须具有与此相同的返回类型。
    • 否则，该方法之一必须是返回类型，它可以指派给该方法其余的所有返回类型。
  • 得到的代理类必须不超过虚拟机在类上施加的任何限制。例如，虚拟机可以限制某一类实现至多 65535 的接口数；在这种情况下，interfaces 数组的大小必须不超过 65535。

如果违反了这些限制，Proxy.getProxyClass 将抛出 IllegalArgumentException。如果 interfaces 数组参数或其任何元素为 null，则将抛出 NullPointerException。

注意，指定的代理接口的顺序非常重要：对接口组合相同但顺序不同的代理类的两个请求会导致两个不同的代理类。

参数：
loader - 定义代理类的类加载器
interfaces - 代理类要实现的接口列表
返回：
用指定的类加载器定义的代理类，它可以实现指定的接口
抛出：
IllegalArgumentException - 如果违反传递到 getProxyClass 的参数上的任何限制
NullPointerException - 如果 interfaces 数组参数或其任何元素为 null

newProxyInstance

public static Object newProxyInstance(ClassLoader loader,
                                      Class<?>[] interfaces,
                                      InvocationHandler h)
                               throws IllegalArgumentException
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。此方法相当于：
     Proxy.getProxyClass(loader, interfaces).
         getConstructor(new Class[] { InvocationHandler.class }).
         newInstance(new Object[] { handler });

Proxy.newProxyInstance 抛出 IllegalArgumentException，原因与 Proxy.getProxyClass 相同。

参数：
loader - 定义代理类的类加载器
interfaces - 代理类要实现的接口列表
h - 指派方法调用的调用处理程序
返回：
一个带有代理类的指定调用处理程序的代理实例，它由指定的类加载器定义，并实现指定的接口
抛出：
IllegalArgumentException - 如果违反传递到 getProxyClass 的参数上的任何限制
NullPointerException - 如果 interfaces 数组参数或其任何元素为 null，或如果调用处理程序 h 为 null

isProxyClass

public static boolean isProxyClass(Class<?> cl)
当且仅当指定的类通过 getProxyClass 方法或 newProxyInstance 方法动态生成为代理类时，返回 true。

此方法的可靠性对于使用它做出安全决策而言非常重要，所以此方法的实现不应仅测试相关的类是否可以扩展 Proxy。

参数：
cl - 要测试的类
返回：
如该类为代理类，则为 true，否则为 false
抛出：
NullPointerException - 如果 cl 为 null

getInvocationHandler

public static InvocationHandler getInvocationHandler(Object proxy)
                                              throws IllegalArgumentException
返回指定代理实例的调用处理程序。

参数：
proxy - 返回调用处理程序的代理实例
返回：
代理实例的调用处理程序
抛出：
IllegalArgumentException - 如果参数不是一个代理实例
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReflectPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 ReflectPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.lang.reflect.ReflectPermission
所有已实现的接口：
Serializable, Guard
public final class ReflectPermission
extends BasicPermission

反射操作的 Permission 类。ReflectPermission 是一种指定权限，没有动作。当前定义的唯一名称是 suppressAccessChecks，它允许取消由反射对象在其使用点上执行的标准 Java 语言访问检查 - 对于 public、default（包）访问、protected、private 成员。

下表提供了允许权限的简要说明，并讨论了授予代码权限的风险。

权限目标名称 | 权限允许的内容 | 允许此权限的风险
suppressAccessChecks | 能够访问类中的字段和调用方法。注意，这不仅包括 public、而且还包括 protected 和 private 字段和方法。 | 存在的风险是，通常不可用的信息（也许是保密信息）和方法可能会接受恶意代码访问。

从以下版本开始：
1.2
另请参见：
Permission, BasicPermission, AccessibleObject, Field.get(java.lang.Object), Field.set(java.lang.Object, java.lang.Object), Method.invoke(java.lang.Object, java.lang.Object...), Constructor.newInstance(java.lang.Object...), 序列化表格

构造方法摘要
ReflectPermission(String name)
构造不带指定名称的 ReflectPermission。
ReflectPermission(String name, String actions)
构造带指定名称和动作的 ReflectPermission。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReflectPermission

public ReflectPermission(String name)
构造不带指定名称的 ReflectPermission。

参数：
name - ReflectPermission 的名称
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空

ReflectPermission

public ReflectPermission(String name,
                         String actions)
构造带指定名称和动作的 ReflectPermission。如果动作为 null，它们将被忽略。

参数：
name - ReflectPermission 的名称
actions - 应该为 null
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 Type

所有已知子接口：
GenericArrayType, ParameterizedType, TypeVariable<D>, WildcardType
所有已知实现类：
Class
public interface Type

Type 是 Java 编程语言中所有类型的公共高级接口。它们包括原始类型、参数化类型、数组类型、类型变量和基本类型。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeVariable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 TypeVariable<D extends GenericDeclaration>

所有超级接口：
Type
public interface TypeVariable<D extends GenericDeclaration>
extends Type

TypeVariable 是各种类型变量的公共高级接口。类型变量在反射方法首次需要时创建（在此包中指定）。如果类型变量 t 由类型（即类、接口或注释类型）T 引用，而且 T 由 T 的第 n 个封闭类声明（请参见 JLS 8.1.2），那么创建 t 需要解析（请参见 JVMS 5）T 的第 i 个封闭类，其中 i = 0 到 n（包含）。创建某个类型变量决不能导致创建其边界。重复创建类型变量没有效果。

可以在运行时将多个对象实例化，以表示一个给定的类型变量。尽管类型变量仅创建一次，这并不意味着任何缓存实例的要求都表示类型变量。不过，表示类型变量的所有实例彼此必须相等 (equal())。因此，使用类型变量的用户决不能依靠实现此接口的类实例的身份。

从以下版本开始：
1.5

方法摘要
Type[] | getBounds() 返回表示此类型变量上边界的 Type 对象的数组。
D | getGenericDeclaration() 返回 GenericDeclaration 对象，该对象表示声明此类型变量的一般声明。
String | getName() 返回此类型变量的名称，它出现在源代码中。

方法详细信息

getBounds

Type[] getBounds()
返回表示此类型变量上边界的 Type 对象的数组。注意，如果未显式声明上边界，则上边界为 Object。

对于每个上边界 B：

  • 如果 B 是一个参数化类型或一个类型变量，则会创建它（请参见 ParameterizedType，了解创建参数化类型过程的详细信息）。
  • 否则，B 将被解析。

返回：
表示此类型变量的上边界的 Type 的数组
抛出：
TypeNotPresentException - 如果任一边界引用不存在的类型声明
MalformedParameterizedTypeException - 如果任一边界引用出于某种原因不能被实例化的参数化类型

getGenericDeclaration

D getGenericDeclaration()
返回 GenericDeclaration 对象，该对象表示声明此类型变量的一般声明。

返回：
为此类型变量声明的一般声明。
从以下版本开始：
1.5

getName

String getName()
返回此类型变量的名称，它出现在源代码中。

返回：
此类型变量的名称，它出现在源代码中
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UndeclaredThrowableException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
类 UndeclaredThrowableException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.reflect.UndeclaredThrowableException
所有已实现的接口：
Serializable
public class UndeclaredThrowableException
extends RuntimeException

如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

UndeclaredThrowableException 实例包含由调用处理程序抛出的经过检查的未声明异常，而且可以使用 getUndeclaredThrowable() 方法获取。UndeclaredThrowableException 扩展了 RuntimeException，因此它是一个包装已检查异常的未经检查的异常。

从版本 1.4 开始，此异常已经更新，符合常用的异常链机制。“由调用处理程序抛出的经过检查的未声明异常”可以在构造的时候提供，并且可以通过 getUndeclaredThrowable() 方法访问，这类对象目前被认为是导致异常的原因，可以通过 Throwable.getCause() 方法以及前面提到的“遗留方法”访问它。

从以下版本开始：
1.3
另请参见：
InvocationHandler, 序列化表格

构造方法摘要
UndeclaredThrowableException(Throwable undeclaredThrowable)
根据指定的 Throwable 构造一个 UndeclaredThrowableException。
UndeclaredThrowableException(Throwable undeclaredThrowable, String s)
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。
方法摘要
Throwable | getCause() 返回此异常的原因（此 UndeclaredThrowableException 中包装的 Throwable 实例，可能为 null）。
Throwable | getUndeclaredThrowable() 返回此 UndeclaredThrowableException 中包装的 Throwable 实例，它可能为 null。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UndeclaredThrowableException

public UndeclaredThrowableException(Throwable undeclaredThrowable)
根据指定的 Throwable 构造一个 UndeclaredThrowableException。

参数：
undeclaredThrowable - 抛出的经过检查的未声明异常

UndeclaredThrowableException

public UndeclaredThrowableException(Throwable undeclaredThrowable,
                                    String s)
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。

参数：
undeclaredThrowable - 抛出的经过检查的未声明异常
s - 详细消息
方法详细信息

getUndeclaredThrowable

public Throwable getUndeclaredThrowable()
返回此 UndeclaredThrowableException 中包装的 Throwable 实例，它可能为 null。

该方法早于通用异常链设施。Throwable.getCause() 方法现在是获得此信息的首选方法。

返回：
抛出的经过检查的未声明异常

getCause

public Throwable getCause()
返回此异常的原因（此 UndeclaredThrowableException 中包装的 Throwable 实例，可能为 null）。

覆盖：
类 Throwable 中的 getCause
返回：
此异常的原因。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WildcardType (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.lang.reflect
接口 WildcardType

所有超级接口：
Type
public interface WildcardType
extends Type

WildcardType 表示一个通配符类型表达式，如 ?、? extends Number 或 ? super Integer。

从以下版本开始：
1.5

方法摘要
Type[] | getLowerBounds() 返回表示此类型变量下边界的 Type 对象的数组。
Type[] | getUpperBounds() 返回表示此类型变量上边界的 Type 对象的数组。

方法详细信息

getUpperBounds

Type[] getUpperBounds()
返回表示此类型变量上边界的 Type 对象的数组。注意，如果不存在显式声明的上边界，则上边界为 Object。

对于每个上边界 B：

  • 如果 B 是一个参数化类型或一个类型变量，则会创建它（有关创建参数化类型过程的详细信息，请参阅 ParameterizedType）。
  • 否则，B 将被解析。

返回：
表示此类型变量上边界的类型的数组
抛出：
TypeNotPresentException - 如果任一边界引用不存在的类型声明
MalformedParameterizedTypeException - 如果任一边界引用出于某种原因不能被实例化的参数化类型

getLowerBounds

Type[] getLowerBounds()
返回表示此类型变量下边界的 Type 对象的数组。注意，如果不存在显式声明的下边界，则下边界为类型 null。在此情况下，将返回长度为零的数组。

对于每个下边界 B：

  • 如果 B 是一个参数化类型或一个类型变量，则会创建它（有关创建参数化类型过程的详细信息，请参阅 ParameterizedType）。
  • 否则，B 将被解析。

返回：
表示此类型变量下边界的类型的数组
抛出：
TypeNotPresentException - 如果任一边界引用不存在的类型声明
MalformedParameterizedTypeException - 如果任一边界引用出于某种原因不能被实例化的参数化类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.lang.reflect (Java 2 Platform SE 6)

 java.lang.reflect
接口
AnnotatedElement
GenericArrayType
GenericDeclaration
InvocationHandler
Member
ParameterizedType
Type
TypeVariable
WildcardType
类
AccessibleObject
Array
Constructor
Field
Method
Modifier
Proxy
ReflectPermission
异常
InvocationTargetException
MalformedParameterizedTypeException
UndeclaredThrowableException
错误
GenericSignatureFormatError


java.lang.reflect (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.lang.reflect

提供类和接口，以获得关于类和对象的反射信息。

请参见：
描述

接口摘要
AnnotatedElement | 表示目前正在此 VM 中运行的程序的一个已注释元素。
GenericArrayType | GenericArrayType 表示一种数组类型，其组件类型为参数化类型或类型变量。
GenericDeclaration | 声明类型变量的所有实体的公共接口。
InvocationHandler | InvocationHandler 是代理实例的调用处理程序 实现的接口。
Member | 成员是一种接口，反映有关单个成员（字段或方法）或构造方法的标识信息。
ParameterizedType | ParameterizedType 表示参数化类型，如 Collection<String>。
Type | Type 是 Java 编程语言中所有类型的公共高级接口。
TypeVariable<D extends GenericDeclaration> | TypeVariable 是各种类型变量的公共高级接口。
WildcardType | WildcardType 表示一个通配符类型表达式，如 ?、? extends Number 或 ? super Integer。

类摘要
AccessibleObject | AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。
Array | Array 类提供了动态创建和访问 Java 数组的方法。
Constructor<T> | Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
Field | Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
Method | Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。
Modifier | Modifier 类提供了 static 方法和常量，对类和成员访问修饰符进行解码。
Proxy | Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。
ReflectPermission | 反射操作的 Permission 类。

异常摘要
InvocationTargetException | InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
MalformedParameterizedTypeException | 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
UndeclaredThrowableException | 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

错误摘要
GenericSignatureFormatError 当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

软件包 java.lang.reflect 的描述

提供类和接口，以获得关于类和对象的反射信息。在安全限制内，反射允许编程访问关于加载类的字段、方法和构造方法的信息，并允许使用反射字段、方法和构造方法对其底层对等项进行操作。

如果必需的 ReflectPermission 可用，则 AccessibleObject 允许抑制访问检查。

Array 提供动态创建和访问数组的静态方法。

此包中的类以及 java.lang.Class 可以适应以下应用程序的需要：调试程序、解释程序、对象检查程序、类浏览程序，以及服务（比如，Object Serialization 和 JavaBean，它们需要访问目标对象（基于其运行时类）的公共成员或给定类声明的成员）。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.lang.reflect 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.reflect 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.reflect.AccessibleObject (implements java.lang.reflect.AnnotatedElement)
      • java.lang.reflect.Constructor<T> (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
      • java.lang.reflect.Field (implements java.lang.reflect.Member)
      • java.lang.reflect.Method (implements java.lang.reflect.GenericDeclaration, java.lang.reflect.Member)
    • java.lang.reflect.Array
    • java.lang.reflect.Modifier
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.lang.reflect.ReflectPermission
    • java.lang.reflect.Proxy (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.LinkageError
          • java.lang.ClassFormatError
            • java.lang.reflect.GenericSignatureFormatError
      • java.lang.Exception
        • java.lang.reflect.InvocationTargetException
        • java.lang.RuntimeException
          • java.lang.reflect.MalformedParameterizedTypeException
          • java.lang.reflect.UndeclaredThrowableException

接口分层结构

  • java.lang.reflect.AnnotatedElement
  • java.lang.reflect.GenericDeclaration
  • java.lang.reflect.InvocationHandler
  • java.lang.reflect.Member
  • java.lang.reflect.Type
    • java.lang.reflect.GenericArrayType
    • java.lang.reflect.ParameterizedType
    • java.lang.reflect.TypeVariable<D>
    • java.lang.reflect.WildcardType
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.lang.reflect 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.lang.reflect
的使用

使用 java.lang.reflect 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 使用的 java.lang.reflect 中的类
InvocationTargetException
InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。

java.beans 使用的 java.lang.reflect 中的类
InvocationHandler
InvocationHandler 是代理实例的调用处理程序 实现的接口。
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

java.lang 使用的 java.lang.reflect 中的类
AnnotatedElement
表示目前正在此 VM 中运行的程序的一个已注释元素。
Constructor
Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
Field
Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
GenericDeclaration
声明类型变量的所有实体的公共接口。
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。
Type
Type 是 Java 编程语言中所有类型的公共高级接口。
TypeVariable
TypeVariable 是各种类型变量的公共高级接口。

java.lang.annotation 使用的 java.lang.reflect 中的类
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

java.lang.reflect 使用的 java.lang.reflect 中的类
AccessibleObject
AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。
AnnotatedElement
表示目前正在此 VM 中运行的程序的一个已注释元素。
GenericDeclaration
声明类型变量的所有实体的公共接口。
InvocationHandler
InvocationHandler 是代理实例的调用处理程序 实现的接口。
InvocationTargetException
InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
Member
成员是一种接口，反映有关单个成员（字段或方法）或构造方法的标识信息。
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。
Type
Type 是 Java 编程语言中所有类型的公共高级接口。
TypeVariable
TypeVariable 是各种类型变量的公共高级接口。

java.rmi.server 使用的 java.lang.reflect 中的类
InvocationHandler
InvocationHandler 是代理实例的调用处理程序 实现的接口。
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

javax.management 使用的 java.lang.reflect 中的类
Constructor
Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
InvocationHandler
InvocationHandler 是代理实例的调用处理程序 实现的接口。
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

javax.management.modelmbean 使用的 java.lang.reflect 中的类
Constructor
Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

javax.management.openmbean 使用的 java.lang.reflect 中的类
InvocationHandler
InvocationHandler 是代理实例的调用处理程序 实现的接口。
Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

javax.sql.rowset.serial 使用的 java.lang.reflect 中的类
Field
Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。

javax.swing 使用的 java.lang.reflect 中的类
InvocationTargetException
InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.GenericArrayType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.GenericArrayType
的使用

没有 java.lang.reflect.GenericArrayType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.GenericSignatureFormatError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.GenericSignatureFormatError
的使用

没有 java.lang.reflect.GenericSignatureFormatError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.MalformedParameterizedTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.MalformedParameterizedTypeException
的使用

没有 java.lang.reflect.MalformedParameterizedTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.ParameterizedType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.ParameterizedType
的使用

没有 java.lang.reflect.ParameterizedType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.TypeVariable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.TypeVariable
的使用

使用 TypeVariable 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 TypeVariable 的使用

返回 TypeVariable 的 java.lang 中的方法
 TypeVariable<Class<T>>[] Class.getTypeParameters()
按声明顺序返回 TypeVariable 对象的一个数组，这些对象表示用此 GenericDeclaration 对象所表示的常规声明来声明的类型变量。

java.lang.reflect 中 TypeVariable 的使用

返回 TypeVariable 的 java.lang.reflect 中的方法
TypeVariable<Constructor<T>>[] | Constructor.getTypeParameters() 按照声明顺序返回一组 TypeVariable 对象，这些对象表示通过此 GenericDeclaration 对象所表示的一般声明来声明的类型变量。
TypeVariable<Method>[] | Method.getTypeParameters() 返回 TypeVariable 对象的数组，这些对象描述了由 GenericDeclaration 对象表示的一般声明按声明顺序来声明的类型变量。
TypeVariable<?>[] | GenericDeclaration.getTypeParameters() 返回声明顺序的 TypeVariable 对象的数组，这些对象表示由此 GenericDeclaration 对象表示的一般声明声明的类型变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.UndeclaredThrowableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.UndeclaredThrowableException
的使用

没有 java.lang.reflect.UndeclaredThrowableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.WildcardType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.WildcardType
的使用

没有 java.lang.reflect.WildcardType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.InvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.InvocationHandler
的使用

使用 InvocationHandler 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.beans 中 InvocationHandler 的使用

实现 InvocationHandler 的 java.beans 中的类
 class EventHandler
EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。

java.lang.reflect 中 InvocationHandler 的使用

声明为 InvocationHandler 的 java.lang.reflect 中的字段
protected  InvocationHandler Proxy.h
此代理实例的调用处理程序。

返回 InvocationHandler 的 java.lang.reflect 中的方法
static InvocationHandler Proxy.getInvocationHandler(Object proxy)
返回指定代理实例的调用处理程序。

参数类型为 InvocationHandler 的 java.lang.reflect 中的方法
static Object Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

参数类型为 InvocationHandler 的 java.lang.reflect 中的构造方法
Proxy(InvocationHandler h)
使用其调用处理程序的指定值从子类（通常为动态代理类）构建新的 Proxy 实例。

java.rmi.server 中 InvocationHandler 的使用

实现 InvocationHandler 的 java.rmi.server 中的类
 class RemoteObjectInvocationHandler
与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。

javax.management 中 InvocationHandler 的使用

实现 InvocationHandler 的 javax.management 中的类
 class MBeanServerInvocationHandler
通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。

javax.management.openmbean 中 InvocationHandler 的使用

实现 InvocationHandler 的 javax.management.openmbean 中的类
 class CompositeDataInvocationHandler
将获取方法转发给 CompositeData 的 InvocationHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.Proxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Proxy
的使用

没有 java.lang.reflect.Proxy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.InvocationTargetException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.InvocationTargetException
的使用

使用 InvocationTargetException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 InvocationTargetException 的使用

抛出 InvocationTargetException 的 java.awt 中的方法
static void EventQueue.invokeAndWait(Runnable runnable)
导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。

java.lang.reflect 中 InvocationTargetException 的使用

抛出 InvocationTargetException 的 java.lang.reflect 中的方法
Object | Method.invoke(Object obj, Object... args) 对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
T | Constructor.newInstance(Object... initargs) 使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。

javax.swing 中 InvocationTargetException 的使用

抛出 InvocationTargetException 的 javax.swing 中的方法
static void SwingUtilities.invokeAndWait(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上同步执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.Array 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Array
的使用

没有 java.lang.reflect.Array 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.Modifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Modifier
的使用

没有 java.lang.reflect.Modifier 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.ReflectPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.ReflectPermission
的使用

没有 java.lang.reflect.ReflectPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.Constructor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Constructor
的使用

使用 Constructor 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

java.lang 中 Constructor 的使用

返回 Constructor 的 java.lang 中的方法
Constructor<T> | Class.getConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
Constructor<?>[] | Class.getConstructors() 返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。
Constructor<T> | Class.getDeclaredConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
Constructor<?>[] | Class.getDeclaredConstructors() 返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。
Constructor<?> | Class.getEnclosingConstructor() 如果该 Class 对象表示构造方法中的一个本地或匿名类，则返回 Constructor 对象，它表示底层类的立即封闭构造方法。

javax.management 中 Constructor 的使用

参数类型为 Constructor 的 javax.management 中的构造方法
MBeanConstructorInfo(String description, Constructor constructor)
构造一个 MBeanConstructorInfo 对象。

javax.management.modelmbean 中 Constructor 的使用

参数类型为 Constructor 的 javax.management.modelmbean 中的构造方法
ModelMBeanConstructorInfo(String description, Constructor constructorMethod)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.Method 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Method
的使用

使用 Method 的软件包
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.beans 中 Method 的使用

返回 Method 的 java.beans 中的方法
Method | EventSetDescriptor.getAddListenerMethod() 获得用来添加事件侦听器的方法。
Method | EventSetDescriptor.getGetListenerMethod() 获得用来访问已注册事件侦听器的方法。
Method | IndexedPropertyDescriptor.getIndexedReadMethod() 获得应该用于读取索引属性值的方法。
Method | IndexedPropertyDescriptor.getIndexedWriteMethod() 获得应该用于写入索引属性值的方法。
Method[] | EventSetDescriptor.getListenerMethods() 获得目标侦听器接口的方法。
Method | MethodDescriptor.getMethod() 获得此 MethodDescriptor 封装的方法。
Method | PropertyDescriptor.getReadMethod() 获得应该用于读取属性值的方法。
Method | EventSetDescriptor.getRemoveListenerMethod() 获得用来移除事件侦听器的方法。
Method | PropertyDescriptor.getWriteMethod() 获得应该用于写入属性值的方法。

参数类型为 Method 的 java.beans 中的方法
Object | EventHandler.invoke(Object proxy, Method method, Object[] arguments) 从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。
void | IndexedPropertyDescriptor.setIndexedReadMethod(Method readMethod) 设置应该用于读取索引属性值的方法。
void | IndexedPropertyDescriptor.setIndexedWriteMethod(Method writeMethod) 设置应该用于写入索引属性值的方法。
void | PropertyDescriptor.setReadMethod(Method readMethod) 设置应该用于读取属性值的方法。
void | PropertyDescriptor.setWriteMethod(Method writeMethod) 设置应该用于写入属性值的方法。

参数类型为 Method 的 java.beans 中的构造方法
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
IndexedPropertyDescriptor(String propertyName, Method readMethod, Method writeMethod, Method indexedReadMethod, Method indexedWriteMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。
MethodDescriptor(Method method)
根据 Method 构造一个 MethodDescriptor。
MethodDescriptor(Method method, ParameterDescriptor[] parameterDescriptors)
根据为每个方法参数提供描述性信息的 Method 构造一个 MethodDescriptor。
PropertyDescriptor(String propertyName, Method readMethod, Method writeMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

java.lang 中 Method 的使用

返回 Method 的 java.lang 中的方法
Method | Class.getDeclaredMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
Method[] | Class.getDeclaredMethods() 返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。
Method | Class.getEnclosingMethod() 如果此 Class 对象表示某一方法中的一个本地或匿名类，则返回 Method 对象，它表示底层类的立即封闭方法。
Method | Class.getMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
Method[] | Class.getMethods() 返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。

java.lang.annotation 中 Method 的使用

返回 Method 的 java.lang.annotation 中的方法
 Method AnnotationTypeMismatchException.element()
返回类型不正确的元素的 Method 对象。

参数类型为 Method 的 java.lang.annotation 中的构造方法
AnnotationTypeMismatchException(Method element, String foundType)
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。

java.lang.reflect 中 Method 的使用

参数类型为 Method 的 java.lang.reflect 中的方法
 Object InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

java.rmi.server 中 Method 的使用

参数类型为 Method 的 java.rmi.server 中的方法
Object | RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args) 处理在封装的代理实例 proxy 上进行的方法调用并返回结果。
Object | RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum) 调用某个方法。

javax.management 中 Method 的使用

参数类型为 Method 的 javax.management 中的方法
 Object MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

参数类型为 Method 的 javax.management 中的构造方法
MBeanAttributeInfo(String name, String description, Method getter, Method setter)
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。
MBeanOperationInfo(String description, Method method)
构造一个 MBeanOperationInfo 对象。

javax.management.modelmbean 中 Method 的使用

参数类型为 Method 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

javax.management.openmbean 中 Method 的使用

参数类型为 Method 的 javax.management.openmbean 中的方法
 Object CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.Field
的使用

使用 Field 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.lang 中 Field 的使用

返回 Field 的 java.lang 中的方法
Field | Class.getDeclaredField(String name) 返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
Field[] | Class.getDeclaredFields() 返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。
Field | Class.getField(String name) 返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。
Field[] | Class.getFields() 返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。

javax.sql.rowset.serial 中 Field 的使用

返回 Field 的 javax.sql.rowset.serial 中的方法
 Field[] SerialJavaObject.getFields()
返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.Member 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.Member
的使用

使用 Member 的软件包
java.lang.reflect 提供类和接口，以获得关于类和对象的反射信息。

java.lang.reflect 中 Member 的使用

实现 Member 的 java.lang.reflect 中的类
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Field Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.reflect.AccessibleObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.reflect.AccessibleObject
的使用

使用 AccessibleObject 的软件包
java.lang.reflect 提供类和接口，以获得关于类和对象的反射信息。

java.lang.reflect 中 AccessibleObject 的使用

java.lang.reflect 中 AccessibleObject 的子类
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Field Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

参数类型为 AccessibleObject 的 java.lang.reflect 中的方法
static void AccessibleObject.setAccessible(AccessibleObject[] array, boolean flag)
使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.AnnotatedElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.AnnotatedElement
的使用

使用 AnnotatedElement 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 AnnotatedElement 的使用

实现 AnnotatedElement 的 java.lang 中的类
class | Class<T> Class 类的实例表示正在运行的 Java 应用程序中的类和接口。
class | Package Package 对象包含有关 Java 包的实现和规范的版本信息。

java.lang.reflect 中 AnnotatedElement 的使用

实现 AnnotatedElement 的 java.lang.reflect 中的类
class | AccessibleObject AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Field Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.Type
的使用

使用 Type 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 Type 的使用

实现 Type 的 java.lang 中的类
 class Class<T>
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。

返回 Type 的 java.lang 中的方法
Type[] | Class.getGenericInterfaces() 返回表示某些接口的 Type，这些接口由此对象所表示的类或接口直接实现。
Type | Class.getGenericSuperclass() 返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的直接超类的 Type。

java.lang.reflect 中 Type 的使用

java.lang.reflect 中 Type 的子接口
interface | GenericArrayType GenericArrayType 表示一种数组类型，其组件类型为参数化类型或类型变量。
interface | ParameterizedType ParameterizedType 表示参数化类型，如 Collection<String>。
interface | TypeVariable<D extends GenericDeclaration> TypeVariable 是各种类型变量的公共高级接口。
interface | WildcardType WildcardType 表示一个通配符类型表达式，如 ?、? extends Number 或 ? super Integer。

返回 Type 的 java.lang.reflect 中的方法
Type[] | ParameterizedType.getActualTypeArguments() 返回表示此类型实际类型参数的 Type 对象的数组。
Type[] | TypeVariable.getBounds() 返回表示此类型变量上边界的 Type 对象的数组。
Type | GenericArrayType.getGenericComponentType() 返回表示此数组的组件类型的 Type 对象。
Type[] | Constructor.getGenericExceptionTypes() 返回一组 Type 对象，这些对象表示声明要由此 Constructor 对象抛出的异常。
Type[] | Method.getGenericExceptionTypes() 返回 Type 对象数组，这些对象描述了声明由此 Method 对象抛出的异常。
Type[] | Constructor.getGenericParameterTypes() 按照声明顺序返回一组 Type 对象，这些对象表示此 Constructor 对象所表示的方法的形参类型。
Type[] | Method.getGenericParameterTypes() 按照声明顺序返回 Type 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型的。
Type | Method.getGenericReturnType() 返回表示由此 Method 对象所表示方法的正式返回类型的 Type 对象。
Type | Field.getGenericType() 返回一个 Type 对象，它表示此 Field 对象所表示字段的声明类型。
Type[] | WildcardType.getLowerBounds() 返回表示此类型变量下边界的 Type 对象的数组。
Type | ParameterizedType.getOwnerType() 返回 Type 对象，表示此类型是其成员之一的类型。
Type | ParameterizedType.getRawType() 返回 Type 对象，表示声明此类型的类或接口。
Type[] | WildcardType.getUpperBounds() 返回表示此类型变量上边界的 Type 对象的数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.reflect.GenericDeclaration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.reflect.GenericDeclaration
的使用

使用 GenericDeclaration 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 GenericDeclaration 的使用

实现 GenericDeclaration 的 java.lang 中的类
 class Class<T>
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。

java.lang.reflect 中 GenericDeclaration 的使用

类型参数类型为 GenericDeclaration 的 java.lang.reflect 中的类
 interface TypeVariable<D extends GenericDeclaration>
TypeVariable 是各种类型变量的公共高级接口。

实现 GenericDeclaration 的 java.lang.reflect 中的类
class | Constructor<T> Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。
class | Method Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.AbstractMethodError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.AbstractMethodError
的使用

没有 java.lang.AbstractMethodError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ClassCircularityError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassCircularityError
的使用

没有 java.lang.ClassCircularityError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Deprecated 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Deprecated
的使用

使用 Deprecated 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.rmi | 提供 RMI 包。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.jws.soap |
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

java.awt 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt 中的字段
static int | Frame.CROSSHAIR_CURSOR 已过时。 由 Cursor.CROSSHAIR_CURSOR 取代。
static int | Frame.DEFAULT_CURSOR 已过时。 由 Cursor.DEFAULT_CURSOR 取代。
static int | Frame.E_RESIZE_CURSOR 已过时。 由 Cursor.E_RESIZE_CURSOR 取代。
static int | Frame.HAND_CURSOR 已过时。 由 Cursor.HAND_CURSOR 取代。
static int | Frame.MOVE_CURSOR 已过时。 由 Cursor.MOVE_CURSOR 取代。
static int | Frame.N_RESIZE_CURSOR 已过时。 由 Cursor.N_RESIZE_CURSOR 取代。
static int | Frame.NE_RESIZE_CURSOR 已过时。 由 Cursor.NE_RESIZE_CURSOR 取代。
static int | Frame.NW_RESIZE_CURSOR 已过时。 由 Cursor.NW_RESIZE_CURSOR 取代。
static int | Frame.S_RESIZE_CURSOR 已过时。 由 Cursor.S_RESIZE_CURSOR 取代。
static int | Frame.SE_RESIZE_CURSOR 已过时。 由 Cursor.SE_RESIZE_CURSOR 取代。
static int | Frame.SW_RESIZE_CURSOR 已过时。 由 Cursor.SW_RESIZE_CURSOR 取代。
static int | Frame.TEXT_CURSOR 已过时。 由 Cursor.TEXT_CURSOR 取代。
static int | Frame.W_RESIZE_CURSOR 已过时。 由 Cursor.W_RESIZE_CURSOR 取代。
static int | Frame.WAIT_CURSOR 已过时。 由 Cursor.WAIT_CURSOR 取代。

注释类型为 Deprecated 的 java.awt 中的方法
 boolean Component.action(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。
 void List.addItem(String item)
已过时。 由 add(String) 取代。
 void List.addItem(String item, int index)
已过时。 由 add(String, int) 取代。
 void CardLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 void BorderLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。
 boolean List.allowsMultipleSelections()
已过时。 从 JDK version 1.1 开始，由 isMultipleMode() 取代。
 void TextArea.appendText(String str)
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。
 void Window.applyResourceBundle(ResourceBundle rb)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
 void Window.applyResourceBundle(String rbName)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
 Rectangle Component.bounds()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 void List.clear()
已过时。 从 JDK version 1.1 开始，由 removeAll() 取代。
 int Container.countComponents()
已过时。 从 JDK version 1.1 开始，用 etComponentCount() 取代。
 int Choice.countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
 int List.countItems()
已过时。 从 JDK version 1.1 开始，由 getItemCount() 取代。
 int Menu.countItems()
已过时。 从 JDK version 1.1 开始，已由 getItemCount() 取代。
 int MenuBar.countMenus()
已过时。 从 JDK version 1.1 开始，由 getMenuCount() 取代。
 void List.delItem(int position)
已过时。 由 remove(String) 和 remove(int) 取代。
 void List.delItems(int start, int end)
已过时。 从 JDK version 1.1 开始，后来不再公开使用。只希望作为包私有方法时保留此方法。
 void Container.deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，用 dispatchEvent(AWTEvent e) 取代
 void Component.deliverEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent e) 取代。
 void MenuItem.disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void Component.disable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void MenuItem.enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void Component.enable()
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void MenuItem.enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 void Component.enable(boolean b)
已过时。 从 JDK version 1.1 开始，由 setEnabled(boolean) 取代。
 Rectangle Polygon.getBoundingBox()
已过时。 从 JDK version 1.1 开始，由 getBounds() 取代。
 Rectangle Graphics.getClipRect()
已过时。 从 JDK version 1.1 开始，由 getClipBounds() 取代。
 Checkbox CheckboxGroup.getCurrent()
已过时。 从 JDK version 1.1 开始，由 getSelectedCheckbox() 取代。
 int Frame.getCursorType()
已过时。 从 JDK version 1.1 开始，由 Component.getCursor() 取代。
abstract  String[] Toolkit.getFontList()
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()
abstract  FontMetrics Toolkit.getFontMetrics(Font font)
已过时。 从 JDK version 1.2 开始，由 Font 方法 getLineMetrics 取代。
protected abstract  java.awt.peer.FontPeer Toolkit.getFontPeer(String name, int style)
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts
 int Scrollbar.getLineIncrement()
已过时。 从 JDK version 1.1 开始，由 getUnitIncrement() 取代。
 int FontMetrics.getMaxDecent()
已过时。 从 JDK version 1.1.1 开始，由 getMaxDescent() 取代。
static ComponentOrientation ComponentOrientation.getOrientation(ResourceBundle bdl)
已过时。 在 J2SE 1.4 中，使用 ComponentOrientation.getOrientation(java.util.Locale)。
 int Scrollbar.getPageIncrement()
已过时。 从 JDK version 1.1 开始，由 getBlockIncrement() 取代。
 java.awt.peer.MenuComponentPeer MenuComponent.getPeer()
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体。
 java.awt.peer.FontPeer Font.getPeer()
已过时。 现在，字体呈现与平台无关。
 java.awt.peer.ComponentPeer Component.getPeer()
已过时。 从 JDK version 1.1 开始，程序不应直接操作同位体；由 boolean isDisplayable() 取代。
 int Scrollbar.getVisible()
已过时。 从 JDK version 1.1 开始，由 getVisibleAmount() 取代。
 boolean Component.gotFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
 boolean Component.handleEvent(Event evt)
已过时。 从 JDK version 1.1 开始，由 processEvent(AWTEvent) 取代。
 void Dialog.hide()
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
 void Window.hide()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
 void Component.hide()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 void TextArea.insertText(String str, int pos)
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。
 Insets Container.insets()
已过时。 从 JDK version 1.1 开始，用 getInsets() 取代。
 boolean Polygon.inside(int x, int y)
已过时。 从 JDK version 1.1 开始, 此函数为 contains(int, int)。
 boolean Rectangle.inside(int X, int Y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
 boolean Component.inside(int x, int y)
已过时。 从 JDK version 1.1 开始，由 contains(int, int) 取代。
 boolean Component.isFocusTraversable()
已过时。 从 1.4 开始，由 isFocusable() 取代。
 boolean List.isSelected(int index)
已过时。 从 JDK version 1.1 开始，由 isIndexSelected(int) 取代。
 boolean Component.keyDown(Event evt, int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
 boolean Component.keyUp(Event evt, int key)
已过时。 从 JDK version 1.1 开始，由 processKeyEvent(KeyEvent) 取代。
 void ScrollPane.layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
 void Container.layout()
已过时。 从 JDK version 1.1，用 doLayout() 取代。
 void Component.layout()
已过时。 从 JDK version 1.1 开始，由 doLayout() 取代。
 Component Container.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，用 getComponentAt(int, int) 取代。
 Component Component.locate(int x, int y)
已过时。 从 JDK version 1.1 开始，由 getComponentAt(int, int) 取代。
 Point Component.location()
已过时。 从 JDK version 1.1 开始，由 getLocation() 取代。
 boolean Component.lostFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。
 Dimension List.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextArea.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension TextField.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension Container.minimumSize()
已过时。 从 JDK version 1.1 开始，用 getMinimumSize() 取代。
 Dimension Component.minimumSize()
已过时。 从 JDK version 1.1 开始，由 getMinimumSize() 取代。
 Dimension List.minimumSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextField.minimumSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int) 取代。
 Dimension TextArea.minimumSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getMinimumSize(int, int) 取代。
 boolean Component.mouseDown(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean Component.mouseDrag(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
 boolean Component.mouseEnter(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean Component.mouseExit(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 boolean Component.mouseMove(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseMotionEvent(MouseEvent) 取代。
 boolean Component.mouseUp(Event evt, int x, int y)
已过时。 从 JDK version 1.1 开始，由 processMouseEvent(MouseEvent) 取代。
 void Rectangle.move(int x, int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
 void Component.move(int x, int y)
已过时。 从 JDK version 1.1 开始，由 setLocation(int, int) 取代。
 void Component.nextFocus()
已过时。 从 JDK version 1.1 开始，由 transferFocus() 取代。
 boolean MenuComponent.postEvent(Event evt)
已过时。 从 JDK version 1.1 开始，已由 dispatchEvent 取代。
 boolean Window.postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
 boolean Component.postEvent(Event e)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
 boolean MenuContainer.postEvent(Event evt)
已过时。 从 JDK version 1.1 开始，由 dispatchEvent(AWTEvent) 取代。
 Dimension List.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextArea.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension TextField.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension Container.preferredSize()
已过时。 从 JDK version 1.1 开始，用 getPreferredSize() 取代。
 Dimension Component.preferredSize()
已过时。 从 JDK version 1.1 开始，由 getPreferredSize() 取代。
 Dimension List.preferredSize(int rows)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextField.preferredSize(int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int) 取代。
 Dimension TextArea.preferredSize(int rows, int columns)
已过时。 从 JDK version 1.1 开始，由 getPreferredSize(int, int) 取代。
 void TextArea.replaceText(String str, int start, int end)
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。
 void Rectangle.reshape(int x, int y, int width, int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
 void Window.reshape(int x, int y, int width, int height)
已过时。 从 JDK 1.1 版开始，由 setBounds(int, int, int, int) 取代。
 void Component.reshape(int x, int y, int width, int height)
已过时。 从 JDK version 1.1 开始，由 setBounds(int, int, int, int) 取代。
 void Component.resize(Dimension d)
已过时。 从 JDK version 1.1 开始，由 setSize(Dimension) 取代。
 void Rectangle.resize(int width, int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
 void Component.resize(int width, int height)
已过时。 从 JDK version 1.1 开始，由 setSize(int, int) 取代。
 void CheckboxGroup.setCurrent(Checkbox box)
已过时。 从 JDK version 1.1 开始，由 setSelectedCheckbox(Checkbox) 取代。
 void Frame.setCursor(int cursorType)
已过时。 从 JDK version 1.1 开始，由 Component.setCursor(Cursor) 取代。
 void TextField.setEchoCharacter(char c)
已过时。 从 JDK version 1.1 开始，由 setEchoChar(char) 取代。
 void Scrollbar.setLineIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setUnitIncrement(int) 取代。
 void List.setMultipleSelections(boolean b)
已过时。 从 JDK version 1.1 开始，由 setMultipleMode(boolean) 取代。
 void Scrollbar.setPageIncrement(int v)
已过时。 从 JDK version 1.1 开始，由 setBlockIncrement() 取代。
 void Dialog.show()
已过时。 从 JDK 版本 1.5 开始，由 setVisible(boolean) 取代。
 void Window.show()
已过时。 从 JDK 1.5 版开始，由 Component.setVisible(boolean) 取代。
 void Component.show()
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 void Component.show(boolean b)
已过时。 从 JDK version 1.1 开始，由 setVisible(boolean) 取代。
 Dimension Component.size()
已过时。 从 JDK version 1.1 开始，由 getSize() 取代。

java.awt.datatransfer 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt.datatransfer 中的字段
static DataFlavor DataFlavor.plainTextFlavor
已过时。 从 1.3 开始。使用 DataFlavor.getReaderForText(Transferable) 代替 Transferable.getTransferData(DataFlavor.plainTextFlavor)。

注释类型为 Deprecated 的 java.awt.datatransfer 中的方法
 boolean DataFlavor.equals(String s)
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。
protected  String DataFlavor.normalizeMimeType(String mimeType)
已过时。
protected  String DataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

java.awt.event 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt.event 中的方法
 void KeyEvent.setModifiers(int modifiers)
已过时。 从 JDK1.1.4 开始

注释类型为 Deprecated 的 java.awt.event 中的构造方法
KeyEvent(Component source, int id, long when, int modifiers, int keyCode)
已过时。 从 JDK1.1 开始

java.awt.image.renderable 中 Deprecated 的使用

注释类型为 Deprecated 的 java.awt.image.renderable 中的方法
void | RenderContext.concetenateTransform(AffineTransform modTransform) 已过时。 由 concatenateTransform(AffineTransform) 所替代。
void | RenderContext.preConcetenateTransform(AffineTransform modTransform) 已过时。 由 preConcatenateTransform(AffineTransform) 所取代。

java.io 中 Deprecated 的使用

注释类型为 Deprecated 的 java.io 中的类
class | LineNumberInputStream 已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。
class | StringBufferInputStream 已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。

注释类型为 Deprecated 的 java.io 中的方法
 String ObjectInputStream.readLine()
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。
 String DataInputStream.readLine()
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
 String ByteArrayOutputStream.toString(int hibyte)
已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。
 URL File.toURL()
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。
abstract  void ObjectOutputStream.PutField.write(ObjectOutput out)
已过时。 此方法不能以正确格式写入 PutField 对象中包含的值，并且可能导致序列化流的损坏。写入 PutField 数据的正确方法是调用 ObjectOutputStream.writeFields() 方法。

注释类型为 Deprecated 的 java.io 中的构造方法
StreamTokenizer(InputStream is)
已过时。 从 JDK 版本 1.1 开始，标记输入流的首选方法是将其转换为一个字符流，例如：
   Reader r = new BufferedReader(new InputStreamReader(is));
   StreamTokenizer st = new StreamTokenizer(r);

java.lang 中 Deprecated 的使用

注释类型为 Deprecated 的 java.lang 中的字段
protected boolean | SecurityManager.inCheck 已过时。 建议不使用该类型的安全检查。建议使用 checkPermission 调用。
static Character.UnicodeBlock | Character.UnicodeBlock.SURROGATES_AREA 已过时。 从 J2SE 5 开始，使用 Character.UnicodeBlock.HIGH_SURROGATES、Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES 和 Character.UnicodeBlock.LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。Character.UnicodeBlock.of(char) 和 Character.UnicodeBlock.of(int) 方法返回新常量，而不是 SURROGATES_AREA。

注释类型为 Deprecated 的 java.lang 中的方法
 boolean ThreadGroup.allowThreadSuspension(boolean b)
已过时。 此调用的定义取决于 ThreadGroup.suspend()，它被废弃了。更进一步地说，此调用的行为从不被指定。
 void SecurityManager.checkMulticast(InetAddress maddr, byte ttl)
已过时。 由 #checkPermission(java.security.Permission) 取代
protected  int SecurityManager.classDepth(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  int SecurityManager.classLoaderDepth()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
 int Thread.countStackFrames()
已过时。 该调用的定义依赖于 Thread.suspend()，但它遭到了反对。此外，该调用的结果从来都不是意义明确的。
protected  ClassLoader SecurityManager.currentClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class<?> SecurityManager.currentLoadedClass()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class<?> ClassLoader.defineClass(byte[] b, int off, int len)
已过时。 由 defineClass(String, byte[], int, int) 取代
 void Thread.destroy()
已过时。 该方法最初用于破坏该线程，但不作任何清除。它所保持的任何监视器都会保持锁定状态。不过，该方法决不会被实现。即使要实现，它也极有可能以 Thread.suspend() 方式被死锁。如果目标线程被破坏时保持一个保护关键系统资源的锁，则任何线程在任何时候都无法再次访问该资源。如果另一个线程曾试图锁定该资源，则会出现死锁。这类死锁通常会证明它们自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void String.getBytes(int srcBegin, int srcEnd, byte[] dst, int dstBegin)
已过时。 该方法无法将字符正确转换为字节。从 JDK 1.1 起，完成该转换的首选方法是通过 String.getBytes() 方法，该方法使用平台的默认字符集。
 boolean SecurityManager.getInCheck()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
 InputStream Runtime.getLocalizedInputStream(InputStream in)
已过时。 从 JDK 1.1 开始，将本地编码字节流转换为 Unicode 字符流的首选方法是使用 InputStreamReader 和 BufferedReader 类。
 OutputStream Runtime.getLocalizedOutputStream(OutputStream out)
已过时。 从 JDK 1.1 开始，将 Unicode 字符流转换为本地编码字节流的首选方法是使用 OutputStreamWriter、BufferedWriter 和 PrintWriter 类。
protected  boolean SecurityManager.inClass(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  boolean SecurityManager.inClassLoader()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
static boolean Character.isJavaLetter(char ch)
已过时。 由 isJavaIdentifierStart(char) 取代。
static boolean Character.isJavaLetterOrDigit(char ch)
已过时。 由 isJavaIdentifierPart(char) 取代。
static boolean Character.isSpace(char ch)
已过时。 由 isWhitespace(char) 取代。
 void ThreadGroup.resume()
已过时。 此方法只用于联合 Thread.suspend 和 ThreadGroup.suspend 时，因为它们所固有的容易导致死锁的特性，所以两者都已废弃。有关详细信息，请参阅 Thread.suspend()。
 void Thread.resume()
已过时。 该方法只与 Thread.suspend() 一起使用，但 Thread.suspend() 已经遭到反对，因为它具有死锁倾向。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
static void Runtime.runFinalizersOnExit(boolean value)
已过时。 此方法本身具有不安全性。它可能对正在使用的对象调用终结方法，而其他线程正在操作这些对象，从而导致不正确的行为或死锁。
static void System.runFinalizersOnExit(boolean value)
已过时。 该方法具有固有的不安全性。它可能对正在使用的对象调用终结方法，而其他线程同时正在操作这些对象，从而导致不正确的行为或死锁。
 void ThreadGroup.stop()
已过时。 此方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。
 void Thread.stop()
已过时。 该方法具有固有的不安全性。用 Thread.stop 来终止线程将释放它已经锁定的所有监视器（作为沿堆栈向上传播的未检查 ThreadDeath 异常的一个自然后果）。如果以前受这些监视器保护的任何对象都处于一种不一致的状态，则损坏的对象将对其他线程可见，这有可能导致任意的行为。stop 的许多使用都应由只修改某些变量以指示目标线程应该停止运行的代码来取代。目标线程应定期检查该变量，并且如果该变量指示它要停止运行，则从其运行方法依次返回。如果目标线程等待很长时间（例如基于一个条件变量），则应使用 interrupt 方法来中断该等待。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void Thread.stop(Throwable obj)
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void ThreadGroup.suspend()
已过时。 此方法容易导致死锁。有关详细信息，请参阅 Thread.suspend()。
 void Thread.suspend()
已过时。 该方法已经遭到反对，因为它具有固有的死锁倾向。如果目标线程挂起时在保护关键系统资源的监视器上保持有锁，则在目标线程重新开始以前任何线程都不能访问该资源。如果重新开始目标线程的线程想在调用 resume 之前锁定该监视器，则会发生死锁。这类死锁通常会证明自己是“冻结”的进程。有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。

注释类型为 Deprecated 的 java.lang 中的构造方法
String(byte[] ascii, int hibyte)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。
String(byte[] ascii, int hibyte, int offset, int count)
已过时。 该方法无法将字节正确地转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是使用带有 Charset、字符集名称，或使用平台默认字符集的 String 构造方法。

java.net 中 Deprecated 的使用

注释类型为 Deprecated 的 java.net 中的字段
static int HttpURLConnection.HTTP_SERVER_ERROR
已过时。 放错了位置，它不应该存在。

注释类型为 Deprecated 的 java.net 中的方法
static String URLDecoder.decode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。
static String URLEncoder.encode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。
static String URLConnection.getDefaultRequestProperty(String key)
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。
protected abstract  byte DatagramSocketImpl.getTTL()
已过时。 使用 getTimeToLive 代替。
 byte MulticastSocket.getTTL()
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
 void MulticastSocket.send(DatagramPacket p, byte ttl)
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
static void URLConnection.setDefaultRequestProperty(String key, String value)
已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。
protected abstract  void DatagramSocketImpl.setTTL(byte ttl)
已过时。 使用 setTimeToLive 代替。
 void MulticastSocket.setTTL(byte ttl)
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
protected  void URLStreamHandler.setURL(URL u, String protocol, String host, int port, String file, String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);

注释类型为 Deprecated 的 java.net 中的构造方法
Socket(InetAddress host, int port, boolean stream)
已过时。 Use DatagramSocket instead for UDP transport.
Socket(String host, int port, boolean stream)
已过时。 使用 DatagramSocket 取代 UDP 传输。

java.rmi 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi 中的类
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerRuntimeException 已过时。 无替换版本

注释类型为 Deprecated 的 java.rmi 中的构造方法
RMISecurityException(String name)
已过时。 无替换版本
RMISecurityException(String name, String arg)
已过时。 无替换版本
ServerRuntimeException(String s, Exception ex)
已过时。 无替换版本

java.rmi.dgc 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi.dgc 中的方法
static boolean VMID.isUnique()
已过时。

java.rmi.registry 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi.registry 中的类
 interface RegistryHandler
已过时。 无替代版本

注释类型为 Deprecated 的 java.rmi.registry 中的方法
Registry | RegistryHandler.registryImpl(int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
Registry | RegistryHandler.registryStub(String host, int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

java.rmi.server 中 Deprecated 的使用

注释类型为 Deprecated 的 java.rmi.server 中的类
interface | LoaderHandler 已过时。 无替代版本
class | LogStream 已过时。 无替代版本
class | Operation 已过时。 无替代版本
interface | RemoteCall 已过时。 无替代版本。
interface | Skeleton 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

注释类型为 Deprecated 的 java.rmi.server 中的方法
 void Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash)
已过时。 无替代版本
 void RemoteCall.done()
已过时。 无替代版本
 void RemoteRef.done(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 void RemoteCall.executeCall()
已过时。 无替代版本
static PrintStream LogStream.getDefaultStream()
已过时。 无替代版本
 ObjectInput RemoteCall.getInputStream()
已过时。 无替代版本
 String Operation.getOperation()
已过时。 无替代版本
 Operation[] Skeleton.getOperations()
已过时。 无替代版本
 OutputStream LogStream.getOutputStream()
已过时。 无替代版本
 ObjectOutput RemoteCall.getOutputStream()
已过时。 无替代版本
 ObjectOutput RemoteCall.getResultStream(boolean success)
已过时。 无替代版本
 Object LoaderHandler.getSecurityContext(ClassLoader loader)
已过时。 无替代版本
static Object RMIClassLoader.getSecurityContext(ClassLoader loader)
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
 void RemoteRef.invoke(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static LogStream LogStream.log(String name)
已过时。 无替代版本
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。
static int LogStream.parseLevel(String s)
已过时。 无替代版本
 void RemoteCall.releaseInputStream()
已过时。 无替代版本
 void RemoteCall.releaseOutputStream()
已过时。 无替代版本
static void LogStream.setDefaultStream(PrintStream newDefault)
已过时。 无替代版本
 void LogStream.setOutputStream(OutputStream out)
已过时。 无替代版本
protected static void RemoteStub.setRef(RemoteStub stub, RemoteRef ref)
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。
 String LogStream.toString()
已过时。 无替代版本
 String Operation.toString()
已过时。 无替代版本
 void LogStream.write(byte[] b, int off, int len)
已过时。 无替代版本
 void LogStream.write(int b)
已过时。 无替代版本

注释类型为 Deprecated 的 java.rmi.server 中的构造方法
Operation(String op)
已过时。 无替代版本
SkeletonMismatchException(String s)
已过时。 无替代版本

java.security 中 Deprecated 的使用

注释类型为 Deprecated 的 java.security 中的类
interface | Certificate 已过时。 在 Java 平台中创建了新的证书处理包。此 Certificate 接口已完全废弃，其仍存在是为了能平稳地过渡到新包。
class | Identity 已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

注释类型为 Deprecated 的 java.security 中的方法
protected abstract Object | SignatureSpi.engineGetParameter(String param) 已过时。
protected abstract void | SignatureSpi.engineSetParameter(String param, Object value) 已过时。 由 engineSetParameter 取代。
static String | Security.getAlgorithmProperty(String algName, String propName) 已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。
Object | Signature.getParameter(String param) 已过时。
void | Signature.setParameter(String param, Object value) 已过时。 使用 setParameter 取代。

java.sql 中 Deprecated 的使用

注释类型为 Deprecated 的 java.sql 中的方法
int | Time.getDate() 已过时。
int | Time.getDay() 已过时。
int | Time.getMonth() 已过时。
int | Time.getYear() 已过时。
void | Time.setDate(int i) 已过时。
void | Time.setMonth(int i) 已过时。
void | Time.setYear(int i) 已过时。

注释类型为 Deprecated 的 java.sql 中的构造方法
Time(int hour, int minute, int second)
已过时。 使用采用毫秒值的构造方法取代此构造方法
Timestamp(int year, int month, int date, int hour, int minute, int second, int nano)
已过时。 使用构造方法 Timestamp(long millis) 来代替

java.util 中 Deprecated 的使用

注释类型为 Deprecated 的 java.util 中的方法
 int Date.getDate()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_MONTH) 取代。
 int Date.getDay()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_WEEK) 取代。
 int Date.getHours()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.HOUR_OF_DAY) 取代。
 int Date.getMinutes()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MINUTE) 取代。
 int Date.getMonth()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MONTH) 取代。
 int Date.getSeconds()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.SECOND) 取代。
 int Date.getTimezoneOffset()
已过时。 从 JDK 1.1 开始，由 -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 取代。
 int Date.getYear()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.YEAR) - 1900 取代。
static long Date.parse(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
 void Properties.save(OutputStream out, String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
 void Date.setDate(int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.DAY_OF_MONTH, int date) 取代。
 void Date.setHours(int hours)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.HOUR_OF_DAY, int hours) 取代。
 void Date.setMinutes(int minutes)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MINUTE, int minutes) 取代。
 void Date.setMonth(int month)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MONTH, int month) 取代。
 void Date.setSeconds(int seconds)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.SECOND, int seconds) 取代。
 void Date.setYear(int year)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.YEAR, year + 1900) 取代。
 String Date.toGMTString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。
 String Date.toLocaleString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。
static long Date.UTC(int year, int month, int date, int hrs, int min, int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代，使用 UTC TimeZone，后跟 Calendar.getTime().getTime()。

注释类型为 Deprecated 的 java.util 中的构造方法
Date(int year, int month, int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date) 或 GregorianCalendar(year + 1900, month, date) 取代。
Date(int year, int month, int date, int hrs, int min)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min) 或 GregorianCalendar(year + 1900, month, date, hrs, min) 取代。
Date(int year, int month, int date, int hrs, int min, int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代。
Date(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

java.util.logging 中 Deprecated 的使用

注释类型为 Deprecated 的 java.util.logging 中的字段
static Logger Logger.global
已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。

javax.accessibility 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.accessibility 中的类
 class AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

javax.jws.soap 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.jws.soap 中的类
interface | InitParam 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPMessageHandler 已过时。 从 JSR-181 2.0 开始，无替代版本。
interface | SOAPMessageHandlers 已过时。 从 JSR-181 2.0 开始，无替代版本。

javax.management 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management 中的类
 class DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。

注释类型为 Deprecated 的 javax.management 中的方法
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。
 void ValueExp.setMBeanServer(MBeanServer s)
已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。

注释类型为 Deprecated 的 javax.management 中的构造方法
AttributeValueExp()
已过时。 在查询中不能使用此构造方法所创建的实例。

javax.management.loading 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management.loading 中的类
 class DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository()} 替代。

javax.management.monitor 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management.monitor 中的字段
protected int | Monitor.alreadyNotified 已过时。 等效于 Monitor.alreadyNotifieds[0]。
protected String | Monitor.dbgTag 已过时。 无替代版本。

注释类型为 Deprecated 的 javax.management.monitor 中的方法
 Number CounterMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGauge(ObjectName) 取代
 Number CounterMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGauge(ObjectName) 取代
 String StringMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGauge(ObjectName) 取代
 String StringMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGauge(ObjectName) 取代
 long CounterMonitor.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
 long CounterMonitorMBean.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
 long GaugeMonitor.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
 long GaugeMonitorMBean.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
 long StringMonitor.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGaugeTimeStamp(ObjectName) 取代
 long StringMonitorMBean.getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName) 取代
 ObjectName Monitor.getObservedObject()
已过时。 从 JMX 1.2 开始，由 Monitor.getObservedObjects() 取代
 ObjectName MonitorMBean.getObservedObject()
已过时。 从 JMX 1.2 开始，由 MonitorMBean.getObservedObjects() 取代
 Number CounterMonitor.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getThreshold(ObjectName) 取代
 Number CounterMonitorMBean.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getThreshold(ObjectName) 取代
 void Monitor.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
 void MonitorMBean.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 MonitorMBean.addObservedObject(javax.management.ObjectName) 取代
 void CounterMonitor.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
 void CounterMonitorMBean.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代

javax.management.openmbean 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.management.openmbean 中的字段
static String[] OpenType.ALLOWED_CLASSNAMES
已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。

javax.security.auth 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.security.auth 中的类
 class Policy
已过时。 从 JDK 1.4 版本开始，由 java.security.Policy 取代。java.security.Policy 有一个方法：
        public PermissionCollection getPermissions
            (java.security.ProtectionDomain pd)
ProtectionDomain 有一个构造方法：
        public ProtectionDomain
            (CodeSource cs,
             PermissionCollection permissions,
             ClassLoader loader,
             Principal[] principals)
这两个 API 为调用者提供向 Policy 查询基于 Principal 的 Permission 条目的方法。

javax.swing 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing 中的字段
protected boolean | JViewport.backingStore 已过时。 从 Java 2 平台 v1.3 开始
protected javax.swing.JRootPane.DefaultAction | JRootPane.defaultPressAction 已过时。 从 Java 2 platform v1.3 开始
protected javax.swing.JRootPane.DefaultAction | JRootPane.defaultReleaseAction 已过时。 从 Java 2 platform v1.3 开始

注释类型为 Deprecated 的 javax.swing 中的方法
static JScrollPane JTable.createScrollPaneForTable(JTable aTable)
已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
 void JComponent.disable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
static void FocusManager.disableSwingFocusManager()
已过时。 从 1.4 开始，由 KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy) 取代
 void JComponent.enable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
static Component SwingUtilities.findFocusOwner(Component c)
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
 Component JPopupMenu.getComponentAtIndex(int i)
已过时。 由 Container.getComponent(int) 取代
 Component JMenuBar.getComponentAtIndex(int i)
已过时。 由 getComponent(int i) 取代
static KeyStroke KeyStroke.getKeyStroke(char keyChar, boolean onKeyRelease)
已过时。 使用 getKeyStroke(char)
 String AbstractButton.getLabel()
已过时。 - 由 getText 取代
 JMenuBar JInternalFrame.getMenuBar()
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
 JMenuBar JRootPane.getMenuBar()
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。
 Component JComponent.getNextFocusableComponent()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。
 String JPasswordField.getText()
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
 String JPasswordField.getText(int offs, int len)
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
 Rectangle ScrollPaneLayout.getViewportBorderBounds(JScrollPane scrollpane)
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
 boolean JViewport.isBackingStoreEnabled()
已过时。 从 Java 2 平台 1.3 版开始，由 getScrollMode() 取代。
static boolean FocusManager.isFocusManagerEnabled()
已过时。 从 1.4 开始，由 KeyboardFocusManager.getDefaultFocusTraversalPolicy() 取代
 boolean JComponent.isManagingFocus()
已过时。 从 1.4 版本开始，由 Component.setFocusTraversalKeys(int, Set) 和 Container.setFocusCycleRoot(boolean) 取代。
 boolean JComponent.requestDefaultFocus()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy.getDefaultComponent(Container).requestFocus() 取代
 void JComponent.reshape(int x, int y, int w, int h)
已过时。 从 JDK 5 开始，由 Component.setBounds(int, int, int, int) 取代。

移动此组件并调整其大小。

 void JViewport.setBackingStoreEnabled(boolean enabled)
已过时。 从 Java 2 平台 1.3 版开始，由 setScrollMode() 取代。
 void AbstractButton.setLabel(String label)
已过时。 - 由 setText(text) 取代
 void JInternalFrame.setMenuBar(JMenuBar m)
已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
 void JRootPane.setMenuBar(JMenuBar menu)
已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。
 void JComponent.setNextFocusableComponent(Component aComponent)
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代
 void JTable.sizeColumnsToFit(boolean lastColumnOnly)
已过时。 从 Swing version 1.0.3 开始，由 doLayout() 取代。

javax.swing.plaf.basic 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.plaf.basic 中的字段
protected KeyStroke | BasicDesktopPaneUI.closeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicSplitPaneUI.dividerResizeToggleKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.downKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.downKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.endKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.homeKey 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardDownRightListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardEndListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardHomeListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardResizeToggleListener 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.keyboardUpLeftListener 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.leftKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.leftKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.maximizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.minimizeKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey 已过时。 从 1.3 开始。
protected KeyStroke | BasicDesktopPaneUI.navigateKey2 已过时。 从 1.3 开始。
protected KeyStroke | BasicInternalFrameUI.openMenuKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.rightKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.rightKey 已过时。 从 Java 2 平台 v1.3 开始。
protected KeyStroke | BasicSplitPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicTabbedPaneUI.upKey 已过时。 从 Java 2 platform v1.3 开始。
protected KeyStroke | BasicToolBarUI.upKey 已过时。 从 Java 2 平台 v1.3 开始。

注释类型为 Deprecated 的 javax.swing.plaf.basic 中的方法
protected ActionListener | BasicSplitPaneUI.createKeyboardDownRightListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardEndListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardHomeListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardResizeToggleListener() 已过时。 从 Java 2 platform v1.3 开始。
protected ActionListener | BasicSplitPaneUI.createKeyboardUpLeftListener() 已过时。 从 Java 2 platform v1.3 开始。
protected int | BasicSplitPaneUI.getDividerBorderSize() 已过时。 从 Java 2 平台 v1.3 开始，由在分隔符上设置边框取代。

javax.swing.plaf.metal 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.plaf.metal 中的类
 class MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

注释类型为 Deprecated 的 javax.swing.plaf.metal 中的方法
protected void | MetalComboBoxUI.editablePropertyChanged(PropertyChangeEvent e) 已过时。 从 Java 2 platform v1.4 开始。
protected void | MetalComboBoxUI.removeListeners() 已过时。 从 Java 2 platform v1.4 开始。

javax.swing.table 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.table 中的字段
protected  int TableColumn.resizedPostingDisableCount
已过时。 从 Java 2 platform v1.3 开始

注释类型为 Deprecated 的 javax.swing.table 中的方法
void | TableColumn.disableResizedPosting() 已过时。 从 Java 2 platform v1.3 开始
void | TableColumn.enableResizedPosting() 已过时。 从 Java 2 platform v1.3 开始

javax.swing.text 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.text 中的类
class | DefaultTextUI 已过时。
class | TableView.TableCell 已过时。 表单元格如今可以是任何 View 实现。

注释类型为 Deprecated 的 javax.swing.text 中的方法
protected TableView.TableCell | TableView.createTableCell(Element elem) 已过时。 现在表单元格可以是任意视图实现并且应该由 ViewFactory 而不是表来产生。
protected FontMetrics | LabelView.getFontMetrics() 已过时。 FontMetrics 不用于在 JDK 中运行时的字形呈现。
Shape | View.modelToView(int pos, Shape a) 已过时。
int | View.viewToModel(float x, float y, Shape a) 已过时。

javax.swing.text.html 中 Deprecated 的使用

注释类型为 Deprecated 的 javax.swing.text.html 中的字段
static String | FormView.RESET 已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值
static String | FormView.SUBMIT 已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值

注释类型为 Deprecated 的 javax.swing.text.html 中的方法
protected  void HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary

org.omg.CORBA 中 Deprecated 的使用

注释类型为 Deprecated 的 org.omg.CORBA 中的类
class | DynamicImplementation 已过时。 org.omg.CORBA.DynamicImplementation
interface | DynAny 已过时。 使用新的 DynAny 替代
interface | DynArray 已过时。 使用新的 DynArray 替代
interface | DynEnum 已过时。 使用新的 DynEnum 替代
interface | DynFixed 已过时。 使用新的 DynFixed 替代
interface | DynSequence 已过时。 使用新的 DynSequence 替代
interface | DynStruct 已过时。 使用新的 DynStruct 替代
interface | DynUnion 已过时。 使用新的 DynUnion 替代
interface | DynValue 已过时。 使用新的 DynValue 替代
class | Principal 已过时。 已由 CORBA 2.2 取代。
class | PrincipalHolder 已过时。 Deprecated by CORBA 2.2.

注释类型为 Deprecated 的 org.omg.CORBA 中的方法
 DynAny ORB.create_basic_dyn_any(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynAny ORB.create_dyn_any(Any value)
已过时。 使用新的 DynAnyFactory API 代替
 DynArray ORB.create_dyn_array(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynEnum ORB.create_dyn_enum(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynSequence ORB.create_dyn_sequence(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynStruct ORB.create_dyn_struct(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
 DynUnion ORB.create_dyn_union(TypeCode type)
已过时。 使用新的 DynAnyFactory API 代替
abstract  TypeCode ORB.create_recursive_sequence_tc(int bound, int offset)
已过时。 使用 create_recursive_tc 和 create_sequence_tc 的组合替代它
 void ServerRequest.except(Any any)
已过时。 使用 set_exception()
 Principal Any.extract_Principal()
已过时。 由 CORBA 2.2 取代。
 Current ORB.get_current()
已过时。 使用 resolve_initial_references。
 void Any.insert_Principal(Principal p)
已过时。 由 CORBA 2.2 取代。
 void DynamicImplementation.invoke(ServerRequest request)
已过时。 由 Portable Object Adapter 取代
 byte[] Principal.name()
已过时。 已由 CORBA 2.2 取代。
 void Principal.name(byte[] value)
已过时。 已由 CORBA 2.2 取代。
 String ServerRequest.op_name()
已过时。 使用 operation()
 void ServerRequest.params(NVList params)
已过时。 使用方法 arguments
 void ServerRequest.result(Any any)
已过时。 使用方法 set_result

注释类型为 Deprecated 的 org.omg.CORBA 中的构造方法
TCKind(int _value)
已过时。 不要使用此构造方法，因为根据 OMG 规范，此方法应该是私有的。使用 TCKind.from_int(int) 代替。

org.omg.CORBA.portable 中 Deprecated 的使用

注释类型为 Deprecated 的 org.omg.CORBA.portable 中的方法
Principal | InputStream.read_Principal() 已过时。 已由 CORBA 2.2 取代。
void | OutputStream.write_Principal(Principal value) 已过时。 已由 CORBA 2.2 取代。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.EnumConstantNotPresentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.EnumConstantNotPresentException
的使用

没有 java.lang.EnumConstantNotPresentException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IllegalThreadStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalThreadStateException
的使用

没有 java.lang.IllegalThreadStateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.InstantiationError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InstantiationError
的使用

没有 java.lang.InstantiationError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NegativeArraySizeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NegativeArraySizeException
的使用

使用 NegativeArraySizeException 的软件包
java.lang.reflect 提供类和接口，以获得关于类和对象的反射信息。

java.lang.reflect 中 NegativeArraySizeException 的使用

抛出 NegativeArraySizeException 的 java.lang.reflect 中的方法
static Object | Array.newInstance(Class<?> componentType, int... dimensions) 创建一个具有指定的组件类型和维度的新数组。
static Object | Array.newInstance(Class<?> componentType, int length) 创建一个具有指定的组件类型和长度的新数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NoSuchFieldError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchFieldError
的使用

没有 java.lang.NoSuchFieldError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Override 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Override
的使用

使用 Override 的软件包
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.lang.model.util 中 Override 的使用

注释类型为 Override 的 javax.lang.model.util 中的方法
R | ElementKindVisitor6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。
R | TypeKindVisitor6.visitNoType(NoType t, P p) 访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。
R | ElementKindVisitor6.visitPackage(PackageElement e, P p) 访问包元素。
R | TypeKindVisitor6.visitPrimitive(PrimitiveType t, P p) 访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。
R | ElementKindVisitor6.visitType(TypeElement e, P p) 访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。
R | ElementKindVisitor6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | ElementKindVisitor6.visitVariable(VariableElement e, P p) 访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。

javax.management 中 Override 的使用

注释类型为 Override 的 javax.management 中的方法
void | AttributeList.add(int index, Object element)
boolean | AttributeList.add(Object o)
boolean | AttributeList.addAll(Collection<?> c)
boolean | AttributeList.addAll(int index, Collection<?> c)
Object | AttributeList.set(int index, Object element)

javax.management.modelmbean 中 Override 的使用

注释类型为 Override 的 javax.management.modelmbean 中的方法
 Descriptor ModelMBeanInfoSupport.getDescriptor()

javax.management.relation 中 Override 的使用

注释类型为 Override 的 javax.management.relation 中的方法
void | RoleList.add(int index, Object element)
void | RoleUnresolvedList.add(int index, Object element)
boolean | RoleList.add(Object o)
boolean | RoleUnresolvedList.add(Object o)
boolean | RoleList.addAll(Collection<?> c)
boolean | RoleUnresolvedList.addAll(Collection<?> c)
boolean | RoleList.addAll(int index, Collection<?> c)
boolean | RoleUnresolvedList.addAll(int index, Collection<?> c)
Object | RoleList.set(int index, Object element)
Object | RoleUnresolvedList.set(int index, Object element)

javax.tools 中 Override 的使用

注释类型为 Override 的 javax.tools 中的方法
 String SimpleJavaFileObject.toString()

javax.xml.bind 中 Override 的使用

注释类型为 Override 的 javax.xml.bind 中的方法
 Throwable JAXBException.getCause()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.SuppressWarnings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.SuppressWarnings
的使用

使用 SuppressWarnings 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.management 中 SuppressWarnings 的使用

注释类型为 SuppressWarnings 的 javax.management 中的类
 class ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

注释类型为 SuppressWarnings 的 javax.management 中的方法
 List<Attribute> AttributeList.asList()
以 List<Attribute> 的形式返回此列表的视图。

javax.management.relation 中 SuppressWarnings 的使用

注释类型为 SuppressWarnings 的 javax.management.relation 中的方法
List<Role> | RoleList.asList() 以 List<Role> 的形式返回此列表的示图。
List<RoleUnresolved> | RoleUnresolvedList.asList() 以 List<RoleUnresolved> 的形式返回此列表的视图。

javax.swing 中 SuppressWarnings 的使用

注释类型为 SuppressWarnings 的 javax.swing 中的类
 class TransferHandler
此类用于处理往返于 Swing 组件的 Transferable 的传输。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.TypeNotPresentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.TypeNotPresentException
的使用

没有 java.lang.TypeNotPresentException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.UnknownError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnknownError
的使用

没有 java.lang.UnknownError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.UnsupportedClassVersionError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnsupportedClassVersionError
的使用

没有 java.lang.UnsupportedClassVersionError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.VerifyError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.VerifyError
的使用

没有 java.lang.VerifyError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.SecurityManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.SecurityManager
的使用

使用 SecurityManager 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi | 提供 RMI 包。

java.lang 中 SecurityManager 的使用

返回 SecurityManager 的 java.lang 中的方法
static SecurityManager System.getSecurityManager()
获取系统安全接口。

参数类型为 SecurityManager 的 java.lang 中的方法
static void System.setSecurityManager(SecurityManager s)
设置系统安全性。

java.rmi 中 SecurityManager 的使用

java.rmi 中 SecurityManager 的子类
 class RMISecurityManager
由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.AssertionError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.AssertionError
的使用

没有 java.lang.AssertionError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ExceptionInInitializerError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ExceptionInInitializerError
的使用

没有 java.lang.ExceptionInInitializerError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ClassFormatError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassFormatError
的使用

使用 ClassFormatError 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 ClassFormatError 的使用

java.lang 中 ClassFormatError 的子类
 class UnsupportedClassVersionError
当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。

抛出 ClassFormatError 的 java.lang 中的方法
protected  Class<?> ClassLoader.defineClass(byte[] b, int off, int len)
已过时。 由 defineClass(String, byte[], int, int) 取代
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len)
将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

java.lang.reflect 中 ClassFormatError 的使用

java.lang.reflect 中 ClassFormatError 的子类
 class GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.UnsatisfiedLinkError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnsatisfiedLinkError
的使用

没有 java.lang.UnsatisfiedLinkError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.CloneNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.CloneNotSupportedException
的使用

使用 CloneNotSupportedException 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.crypto | 为加密操作提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt.datatransfer 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.awt.datatransfer 中的方法
 Object DataFlavor.clone()
返回此 DataFlavor 的副本。

java.lang 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.lang 中的方法
protected Object | Enum.clone() 抛出 CloneNotSupportedException。
protected Object | Object.clone() 创建并返回此对象的一个副本。

java.rmi.server 中 CloneNotSupportedException 的使用

java.rmi.server 中 CloneNotSupportedException 的子类
 class ServerCloneException
如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。

抛出 CloneNotSupportedException 的 java.rmi.server 中的方法
 Object UnicastRemoteObject.clone()
返回与初始对象不同的远程对象的副本。

java.security 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.security 中的方法
Object | Signature.clone() 如果此实现可以复制，则返回副本。
Object | SignatureSpi.clone() 如果此实现可以复制，则返回一个副本。
Object | MessageDigest.clone() 如果实现是可复制的，则返回一个副本。
Object | MessageDigestSpi.clone() 如果实现是可复制的，则返回一个副本。

java.util 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 java.util 中的方法
protected  Object AbstractMap.clone()
返回此 AbstractMap 实例的浅表副本：不复制键和值本身。

javax.crypto 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.crypto 中的方法
Object | Mac.clone() 如果提供者实现可以复制，则返回一个副本。
Object | MacSpi.clone() 如果此实现可以复制，则返回一个副本。

javax.swing 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.swing 中的方法
protected Object | JFormattedTextField.AbstractFormatter.clone() 复制 AbstractFormatter。
protected Object | AbstractAction.clone() 复制抽象操作。
Object | DefaultListSelectionModel.clone() 返回此选择模型的具有相同选择的副本。

javax.swing.text 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.swing.text 中的方法
Object | DefaultFormatter.clone() 创建此 DefaultFormatter 的副本。
Object | InternationalFormatter.clone() 创建该 DefaultFormatter 的一个副本。

javax.swing.tree 中 CloneNotSupportedException 的使用

抛出 CloneNotSupportedException 的 javax.swing.tree 中的方法
 Object DefaultTreeSelectionModel.clone()
返回具有相同 selection 的此对象的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IllegalAccessError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalAccessError
的使用

没有 java.lang.IllegalAccessError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ArrayIndexOutOfBoundsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ArrayIndexOutOfBoundsException
的使用

使用 ArrayIndexOutOfBoundsException 的软件包
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

java.lang.reflect 中 ArrayIndexOutOfBoundsException 的使用

抛出 ArrayIndexOutOfBoundsException 的 java.lang.reflect 中的方法
static Object | Array.get(Object array, int index) 返回指定数组对象中索引组件的值。
static boolean | Array.getBoolean(Object array, int index) 以 boolean 形式返回指定数组对象中索引组件的值。
static byte | Array.getByte(Object array, int index) 以 byte 形式返回指定数组对象中索引组件的值。
static char | Array.getChar(Object array, int index) 以 char 形式返回指定数组对象中索引组件的值。
static double | Array.getDouble(Object array, int index) 以 double 形式返回指定数组对象中索引组件的值。
static float | Array.getFloat(Object array, int index) 以 float 形式返回指定数组对象中索引组件的值。
static int | Array.getInt(Object array, int index) 以 int 形式返回指定数组对象中索引组件的值。
static long | Array.getLong(Object array, int index) 以 long 形式返回指定数组对象中索引组件的值。
static short | Array.getShort(Object array, int index) 以 short 形式返回指定数组对象中索引组件的值。
static void | Array.set(Object array, int index, Object value) 将指定数组对象中索引组件的值设置为指定的新值。
static void | Array.setBoolean(Object array, int index, boolean z) 将指定数组对象中索引组件的值设置为指定的 boolean 值。
static void | Array.setByte(Object array, int index, byte b) 将指定数组对象中索引组件的值设置为指定的 byte 值。
static void | Array.setChar(Object array, int index, char c) 将指定数组对象中索引组件的值设置为指定的 char 值。
static void | Array.setDouble(Object array, int index, double d) 将指定数组对象中索引组件的值设置为指定的 double 值。
static void | Array.setFloat(Object array, int index, float f) 将指定数组对象中索引组件的值设置为指定的 float 值。
static void | Array.setInt(Object array, int index, int i) 将指定数组对象中索引组件的值设置为指定的 int 值。
static void | Array.setLong(Object array, int index, long l) 将指定数组对象中索引组件的值设置为指定的 long 值。
static void | Array.setShort(Object array, int index, short s) 将指定数组对象中索引组件的值设置为指定的 short 值。

javax.sound.midi 中 ArrayIndexOutOfBoundsException 的使用

抛出 ArrayIndexOutOfBoundsException 的 javax.sound.midi 中的方法
 MidiEvent Track.get(int index)
获得位于指定索引处的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.InstantiationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InstantiationException
的使用

使用 InstantiationException 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.lang 中 InstantiationException 的使用

抛出 InstantiationException 的 java.lang 中的方法
 T Class.newInstance()
创建此 Class 对象所表示的类的一个新实例。

java.lang.reflect 中 InstantiationException 的使用

抛出 InstantiationException 的 java.lang.reflect 中的方法
 T Constructor.newInstance(Object... initargs)
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。

java.util 中 InstantiationException 的使用

抛出 InstantiationException 的 java.util 中的方法
 ResourceBundle ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

javax.swing 中 InstantiationException 的使用

抛出 InstantiationException 的 javax.swing 中的方法
static void UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

org.w3c.dom.bootstrap 中 InstantiationException 的使用

抛出 InstantiationException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 InstantiationException 的使用

抛出 InstantiationException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IllegalAccessException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalAccessException
的使用

使用 IllegalAccessException 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.lang 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 java.lang 中的方法
 T Class.newInstance()
创建此 Class 对象所表示的类的一个新实例。

java.lang.reflect 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 java.lang.reflect 中的方法
Object | Field.get(Object obj) 返回指定对象上此 Field 表示的字段的值。
boolean | Field.getBoolean(Object obj) 获取一个静态或实例 boolean 字段的值。
byte | Field.getByte(Object obj) 获取一个静态或实例 byte 字段的值。
char | Field.getChar(Object obj) 获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。
double | Field.getDouble(Object obj) 获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。
float | Field.getFloat(Object obj) 获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。
int | Field.getInt(Object obj) 获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。
long | Field.getLong(Object obj) 获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。
short | Field.getShort(Object obj) 获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。
Object | Method.invoke(Object obj, Object... args) 对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
T | Constructor.newInstance(Object... initargs) 使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。
void | Field.set(Object obj, Object value) 将指定对象变量上此 Field 对象表示的字段设置为指定的新值。
void | Field.setBoolean(Object obj, boolean z) 将字段的值设置为指定对象上的一个 boolean 值。
void | Field.setByte(Object obj, byte b) 将字段的值设置为指定对象上的一个 byte 值。
void | Field.setChar(Object obj, char c) 将字段的值设置为指定对象上的一个 char 值。
void | Field.setDouble(Object obj, double d) 将字段的值设置为指定对象上的一个 double 值。
void | Field.setFloat(Object obj, float f) 将字段的值设置为指定对象上的一个 float 值。
void | Field.setInt(Object obj, int i) 将字段的值设置为指定对象上的一个 int 值。
void | Field.setLong(Object obj, long l) 将字段的值设置为指定对象上的一个 long 值。
void | Field.setShort(Object obj, short s) 将字段的值设置为指定对象上的一个 short 值。

java.util 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 java.util 中的方法
 ResourceBundle ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

javax.swing 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 javax.swing 中的方法
static void UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

org.w3c.dom.bootstrap 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 IllegalAccessException 的使用

抛出 IllegalAccessException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NoSuchFieldException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchFieldException
的使用

使用 NoSuchFieldException 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 NoSuchFieldException 的使用

抛出 NoSuchFieldException 的 java.lang 中的方法
Field | Class.getDeclaredField(String name) 返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
Field | Class.getField(String name) 返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.SecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.SecurityException
的使用

使用 SecurityException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.rmi | 提供 RMI 包。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 SecurityException 的使用

抛出 SecurityException 的 java.awt 中的方法
protected Window | KeyboardFocusManager.getGlobalActiveWindow() 返回活动 Window，即使调用线程处于活动 Window 之外的上下文中。
protected Container | KeyboardFocusManager.getGlobalCurrentFocusCycleRoot() 返回当前焦点循环根，即使调用线程处于当前焦点循环根之外的上下文中。
protected Window | KeyboardFocusManager.getGlobalFocusedWindow() 返回聚焦 Window，即使调用线程处于聚焦 Window 之外的上下文中。
protected Component | KeyboardFocusManager.getGlobalFocusOwner() 返回焦点所有者，即使调用线程处于焦点所有者之外的上下文中。
protected Component | KeyboardFocusManager.getGlobalPermanentFocusOwner() 返回持久焦点所有者，即使调用线程处于该持久焦点所有者之外的上下文中。
void | Window.setAlwaysOnTop(boolean alwaysOnTop) 设置此窗口是否应该始终位于其他窗口上方。
static void | KeyboardFocusManager.setCurrentKeyboardFocusManager(KeyboardFocusManager newManager) 设置调用线程上下文的当前 KeyboardFocusManager 实例。

java.beans 中 SecurityException 的使用

抛出 SecurityException 的 java.beans 中的方法
static void | Beans.setDesignTime(boolean isDesignTime) 用于指示是否正运行在应用程序生成器环境中。
static void | Beans.setGuiAvailable(boolean isGuiAvailable) 用于指示是否正运行在可进行 GUI 交互的环境中。

java.io 中 SecurityException 的使用

抛出 SecurityException 的 java.io 中的方法
protected boolean | ObjectOutputStream.enableReplaceObject(boolean enable) 允许流对流中的对象进行替换。
protected boolean | ObjectInputStream.enableResolveObject(boolean enable) 使流允许从该流读取的对象被替代。

抛出 SecurityException 的 java.io 中的构造方法
ObjectInputStream()
为完全重新实现 ObjectInputStream 的子类提供一种方式，让它不必分配仅由 ObjectInputStream 的实现使用的私有数据。
ObjectOutputStream()
为完全重新实现 ObjectOutputStream 的子类提供一种方法，让它不必分配仅由 ObjectOutputStream 的实现使用的私有数据。

java.lang 中 SecurityException 的使用

抛出 SecurityException 的 java.lang 中的方法
Constructor<T> | Class.getConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
Constructor<?>[] | Class.getConstructors() 返回一个包含某些 Constructor 对象的数组，这些对象反映此 Class 对象所表示的类的所有公共构造方法。
Class<?>[] | Class.getDeclaredClasses() 返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。
Constructor<T> | Class.getDeclaredConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
Constructor<?>[] | Class.getDeclaredConstructors() 返回 Constructor 对象的一个数组，这些对象反映此 Class 对象表示的类声明的所有构造方法。
Field | Class.getDeclaredField(String name) 返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。
Field[] | Class.getDeclaredFields() 返回 Field 对象的一个数组，这些对象反映此 Class 对象所表示的类或接口所声明的所有字段。
Method | Class.getDeclaredMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
Method[] | Class.getDeclaredMethods() 返回 Method 对象的一个数组，这些对象反映此 Class 对象表示的类或接口声明的所有方法，包括公共、保护、默认（包）访问和私有方法，但不包括继承的方法。
Field | Class.getField(String name) 返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。
Field[] | Class.getFields() 返回一个包含某些 Field 对象的数组，这些对象反映此 Class 对象所表示的类或接口的所有可访问公共字段。
Method | Class.getMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
Method[] | Class.getMethods() 返回一个包含某些 Method 对象的数组，这些对象反映此 Class 对象所表示的类或接口（包括那些由该类或接口声明的以及从超类和超接口继承的那些的类或接口）的公共 member 方法。

java.lang.reflect 中 SecurityException 的使用

抛出 SecurityException 的 java.lang.reflect 中的方法
static void | AccessibleObject.setAccessible(AccessibleObject[] array, boolean flag) 使用单一安全性检查（为了提高效率）为一组对象设置 accessible 标志的便捷方法。
void | AccessibleObject.setAccessible(boolean flag) 将此对象的 accessible 标志设置为指示的布尔值。

java.rmi 中 SecurityException 的使用

java.rmi 中 SecurityException 的子类
 class RMISecurityException
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。

java.rmi.server 中 SecurityException 的使用

抛出 SecurityException 的 java.rmi.server 中的方法
static ClassLoader RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。

java.security 中 SecurityException 的使用

java.security 中 SecurityException 的子类
 class AccessControlException
此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。

抛出 SecurityException 的 java.security 中的方法
void | Permission.checkGuard(Object object) 为某权限实现 guard 接口。
void | Guard.checkGuard(Object object) 确定是否允许访问受保护的 object 对象。
Object | GuardedObject.getObject() 获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。

java.util.logging 中 SecurityException 的使用

抛出 SecurityException 的 java.util.logging 中的方法
void | Logger.addHandler(Handler handler) 添加一个日志 Handler 以接收日志记录消息。
void | LogManager.addPropertyChangeListener(PropertyChangeListener l) 添加重读日志属性时调用的事件侦听器。
void | LogManager.checkAccess() 检查使用当前上下文来修改日志配置是否受信任。
void | FileHandler.close() 关闭所有文件。
void | MemoryHandler.close() 关闭 Handler，并释放所有相关的资源。
void | SocketHandler.close() 关闭此输出流。
void | StreamHandler.close() 关闭当前输出流。
abstract void | Handler.close() 关闭 Handler，并释放所有相关的资源。
void | LogManager.readConfiguration() 重新初始化日志属性并重新读取日志配置。
void | LogManager.readConfiguration(InputStream ins) 从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。
void | Logger.removeHandler(Handler handler) 移除一个日志 Handler。
void | LogManager.removePropertyChangeListener(PropertyChangeListener l) 移除属性更改事件的事件侦听器。
void | LogManager.reset() 重置日志配置。
void | StreamHandler.setEncoding(String encoding) 设置（或更改）该 Handler 所用的字符编码。
void | Handler.setEncoding(String encoding) 设置该 Handler 所用的字符编码。
void | Handler.setFilter(Filter newFilter) 设置 Filter，以控制该 Handler 的输出。
void | Logger.setFilter(Filter newFilter) 设置过滤器以控制此 Logger 的输出。
void | Handler.setFormatter(Formatter newFormatter) 设置 Formatter。
void | Handler.setLevel(Level newLevel) 设置日志级别，指定该 Handler 所记录的信息级别。
void | Logger.setLevel(Level newLevel) 设置日志级别，指定此 logger 记录的消息级别。
protected void | StreamHandler.setOutputStream(OutputStream out) 更改输出流。
void | MemoryHandler.setPushLevel(Level newLevel) 设置 pushLevel。

抛出 SecurityException 的 java.util.logging 中的构造方法
FileHandler()
构造一个默认的 FileHandler。
FileHandler(String pattern)
初始化要写入给定文件名的 FileHandler 。
FileHandler(String pattern, boolean append)
初始化要写入给定文件名的 FileHandler（使用可选的 append）。
FileHandler(String pattern, int limit, int count)
初始化要写入文件集的 FileHandler。
FileHandler(String pattern, int limit, int count, boolean append)
初始化要写入文件集的 FileHandler（使用可选的 append）。

javax.swing 中 SecurityException 的使用

抛出 SecurityException 的 javax.swing 中的方法
static void | FocusManager.setCurrentManager(FocusManager aFocusManager) 设置调用线程上下文的当前 KeyboardFocusManager 实例。
static void | UIManager.setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos) 设置可用外观的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.InternalError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InternalError
的使用

使用 InternalError 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 InternalError 的使用

java.util.zip 中 InternalError 的子类
 class ZipError
发生不可恢复的错误时抛出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Process 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Process
的使用

使用 Process 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Process 的使用

返回 Process 的 java.lang 中的方法
Process | Runtime.exec(String command) 在单独的进程中执行指定的字符串命令。
Process | Runtime.exec(String[] cmdarray) 在单独的进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp) 在指定环境的独立进程中执行指定命令和变量。
Process | Runtime.exec(String[] cmdarray, String[] envp, File dir) 在指定环境和工作目录的独立进程中执行指定的命令和变量。
Process | Runtime.exec(String command, String[] envp) 在指定环境的单独进程中执行指定的字符串命令。
Process | Runtime.exec(String command, String[] envp, File dir) 在有指定环境和工作目录的独立进程中执行指定的字符串命令。
Process | ProcessBuilder.start() 使用此进程生成器的属性启动一个新进程。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ProcessBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ProcessBuilder
的使用

使用 ProcessBuilder 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 ProcessBuilder 的使用

返回 ProcessBuilder 的 java.lang 中的方法
ProcessBuilder | ProcessBuilder.command(List<String> command) 设置此进程生成器的操作系统程序和参数。
ProcessBuilder | ProcessBuilder.command(String... command) 设置此进程生成器的操作系统程序和参数。
ProcessBuilder | ProcessBuilder.directory(File directory) 设置此进程生成器的工作目录。
ProcessBuilder | ProcessBuilder.redirectErrorStream(boolean redirectErrorStream) 设置此进程生成器的 redirectErrorStream 属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.InheritableThreadLocal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InheritableThreadLocal
的使用

没有 java.lang.InheritableThreadLocal 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Void 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Void
的使用

使用 Void 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Void 的使用

类型参数类型为 Void 的 java.lang 中的字段
static Class<Void> Void.TYPE
表示对应于关键字 void 的伪类型的 Class 对象。

javax.management.openmbean 中 Void 的使用

类型参数类型为 Void 的 javax.management.openmbean 中的字段
static SimpleType<Void> SimpleType.VOID
SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NumberFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NumberFormatException
的使用

使用 NumberFormatException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。

java.awt 中 NumberFormatException 的使用

抛出 NumberFormatException 的 java.awt 中的方法
static Color Color.decode(String nm)
将 String 转换成整数，并返回指定的不透明 Color。

java.lang 中 NumberFormatException 的使用

抛出 NumberFormatException 的 java.lang 中的方法
static Long | Long.decode(String nm) 将 String 解码成 Long。
static Integer | Integer.decode(String nm) 将 String 解码为 Integer。
static Short | Short.decode(String nm) 将 String 解码为 Short。
static Byte | Byte.decode(String nm) 将 String 解码为 Byte。
boolean | Package.isCompatibleWith(String desired) 比较此包的规范版本和所需版本。
static byte | Byte.parseByte(String s) 将 string 参数解析为有符号的十进制 byte。
static byte | Byte.parseByte(String s, int radix) 将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。
static double | Double.parseDouble(String s) 返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。
static float | Float.parseFloat(String s) 返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。
static int | Integer.parseInt(String s) 将字符串参数作为有符号的十进制整数进行解析。
static int | Integer.parseInt(String s, int radix) 使用第二个参数指定的基数，将字符串参数解析为有符号的整数。
static long | Long.parseLong(String s) 将 string 参数解析为有符号十进制 long。
static long | Long.parseLong(String s, int radix) 将 string 参数解析为有符号的 long，基数由第二个参数指定。
static short | Short.parseShort(String s) 将字符串参数解析为有符号的十进制 short。
static short | Short.parseShort(String s, int radix) 将字符串参数解析为由第二个参数指定的基数中的有符号的 short。
static Long | Long.valueOf(String s) 返回保持指定 String 的值的 Long 对象。
static Integer | Integer.valueOf(String s) 返回保存指定的 String 的值的 Integer 对象。
static Short | Short.valueOf(String s) 返回一个保持指定 String 所给出的值的 Short 对象。
static Byte | Byte.valueOf(String s) 返回一个保持指定 String 所给出的值的 Byte 对象。
static Double | Double.valueOf(String s) 返回保存用参数字符串 s 表示的 double 值的 Double 对象。
static Float | Float.valueOf(String s) 返回保存用参数字符串 s 表示的 float 值的 Float 对象。
static Long | Long.valueOf(String s, int radix) 当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。
static Integer | Integer.valueOf(String s, int radix) 返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。
static Short | Short.valueOf(String s, int radix) 返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。
static Byte | Byte.valueOf(String s, int radix) 返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。

抛出 NumberFormatException 的 java.lang 中的构造方法
Byte(String s)
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。
Double(String s)
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。
Float(String s)
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。
Integer(String s)
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。
Long(String s)
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。
Short(String s)
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IllegalArgumentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalArgumentException
的使用

使用 IllegalArgumentException 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.ref | 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.net.ssl | 提供用于安全套接字包的类。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.stream |
javax.xml.stream.util |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.transform.sax | 此包实现特定于 SAX2 的转换 API。

java.awt.print 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.awt.print 中的方法
 void PageFormat.setOrientation(int orientation)
设置页面方向。

java.beans 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.beans 中的方法
void | PropertyEditor.setAsText(String text) 通过解析给定 String 设置属性值。
void | PropertyEditorSupport.setAsText(String text) 通过解析给定字符串设置属性值。

java.beans.beancontext 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.beans.beancontext 中的方法
 URL BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 InputStream BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

java.lang 中 IllegalArgumentException 的使用

java.lang 中 IllegalArgumentException 的子类
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。

抛出 IllegalArgumentException 的 java.lang 中的方法
protected  Package ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
根据 name 在此 ClassLoader 中定义包。

java.lang.management 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.lang.management 中的构造方法
ManagementPermission(String name, String actions)
构造新的 ManagementPermission 对象。

java.lang.ref 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.lang.ref 中的方法
 Reference<? extends T> ReferenceQueue.remove(long timeout)
移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。

java.lang.reflect 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.lang.reflect 中的方法
Object | Field.get(Object obj) 返回指定对象上此 Field 表示的字段的值。
static Object | Array.get(Object array, int index) 返回指定数组对象中索引组件的值。
boolean | Field.getBoolean(Object obj) 获取一个静态或实例 boolean 字段的值。
static boolean | Array.getBoolean(Object array, int index) 以 boolean 形式返回指定数组对象中索引组件的值。
byte | Field.getByte(Object obj) 获取一个静态或实例 byte 字段的值。
static byte | Array.getByte(Object array, int index) 以 byte 形式返回指定数组对象中索引组件的值。
char | Field.getChar(Object obj) 获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。
static char | Array.getChar(Object array, int index) 以 char 形式返回指定数组对象中索引组件的值。
double | Field.getDouble(Object obj) 获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。
static double | Array.getDouble(Object array, int index) 以 double 形式返回指定数组对象中索引组件的值。
float | Field.getFloat(Object obj) 获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。
static float | Array.getFloat(Object array, int index) 以 float 形式返回指定数组对象中索引组件的值。
int | Field.getInt(Object obj) 获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。
static int | Array.getInt(Object array, int index) 以 int 形式返回指定数组对象中索引组件的值。
static InvocationHandler | Proxy.getInvocationHandler(Object proxy) 返回指定代理实例的调用处理程序。
static int | Array.getLength(Object array) 以 int 形式返回指定数组对象的长度。
long | Field.getLong(Object obj) 获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。
static long | Array.getLong(Object array, int index) 以 long 形式返回指定数组对象中索引组件的值。
static Class<?> | Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces) 返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
short | Field.getShort(Object obj) 获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。
static short | Array.getShort(Object array, int index) 以 short 形式返回指定数组对象中索引组件的值。
Object | Method.invoke(Object obj, Object... args) 对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。
static Object | Array.newInstance(Class<?> componentType, int... dimensions) 创建一个具有指定的组件类型和维度的新数组。
T | Constructor.newInstance(Object... initargs) 使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。
static Object | Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h) 返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。
static void | Array.set(Object array, int index, Object value) 将指定数组对象中索引组件的值设置为指定的新值。
void | Field.set(Object obj, Object value) 将指定对象变量上此 Field 对象表示的字段设置为指定的新值。
void | Field.setBoolean(Object obj, boolean z) 将字段的值设置为指定对象上的一个 boolean 值。
static void | Array.setBoolean(Object array, int index, boolean z) 将指定数组对象中索引组件的值设置为指定的 boolean 值。
void | Field.setByte(Object obj, byte b) 将字段的值设置为指定对象上的一个 byte 值。
static void | Array.setByte(Object array, int index, byte b) 将指定数组对象中索引组件的值设置为指定的 byte 值。
void | Field.setChar(Object obj, char c) 将字段的值设置为指定对象上的一个 char 值。
static void | Array.setChar(Object array, int index, char c) 将指定数组对象中索引组件的值设置为指定的 char 值。
void | Field.setDouble(Object obj, double d) 将字段的值设置为指定对象上的一个 double 值。
static void | Array.setDouble(Object array, int index, double d) 将指定数组对象中索引组件的值设置为指定的 double 值。
void | Field.setFloat(Object obj, float f) 将字段的值设置为指定对象上的一个 float 值。
static void | Array.setFloat(Object array, int index, float f) 将指定数组对象中索引组件的值设置为指定的 float 值。
void | Field.setInt(Object obj, int i) 将字段的值设置为指定对象上的一个 int 值。
static void | Array.setInt(Object array, int index, int i) 将指定数组对象中索引组件的值设置为指定的 int 值。
static void | Array.setLong(Object array, int index, long l) 将指定数组对象中索引组件的值设置为指定的 long 值。
void | Field.setLong(Object obj, long l) 将字段的值设置为指定对象上的一个 long 值。
static void | Array.setShort(Object array, int index, short s) 将指定数组对象中索引组件的值设置为指定的 short 值。
void | Field.setShort(Object obj, short s) 将字段的值设置为指定对象上的一个 short 值。

java.net 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.net 中的方法
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

java.nio.channels 中 IllegalArgumentException 的使用

java.nio.channels 中 IllegalArgumentException 的子类
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 IllegalArgumentException 的使用

java.nio.charset 中 IllegalArgumentException 的子类
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.security 中 IllegalArgumentException 的使用

java.security 中 IllegalArgumentException 的子类
 class InvalidParameterException
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。

java.util 中 IllegalArgumentException 的使用

java.util 中 IllegalArgumentException 的子类
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

java.util.logging 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 java.util.logging 中的方法
static Level Level.parse(String name)
将级别名称字符串解析成 Level。

抛出 IllegalArgumentException 的 java.util.logging 中的构造方法
LoggingPermission(String name, String actions)
创建一个新的 LoggingPermission 对象。

java.util.regex 中 IllegalArgumentException 的使用

java.util.regex 中 IllegalArgumentException 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

javax.management 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management 中的方法
void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
void | AttributeChangeNotificationFilter.enableAttribute(String name) 启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。
void | NotificationFilterSupport.enableType(String prefix) 允许将其类型以指定前缀开始的所有通知发送到该侦听器。
boolean | ObjectName.isPropertyValuePattern(String property) 检查键属性中与值关联的值是否为一个模式。
static String | ObjectName.unquote(String q) 返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

抛出 IllegalArgumentException 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
void | RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。

javax.management.monitor 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.monitor 中的方法
 void Monitor.addObservedObject(ObjectName object)
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。
 void MonitorMBean.addObservedObject(ObjectName object)
将指定的对象添加到所观察的 MBean 集中。
 void Monitor.setGranularityPeriod(long period)
设置粒度周期（以毫秒为单位）。
 void MonitorMBean.setGranularityPeriod(long period)
设置粒度时段（以毫秒为单位）。
 void CounterMonitor.setInitThreshold(Number value)
设置所有观察对象的共同初始阈值。
 void CounterMonitorMBean.setInitThreshold(Number value)
设置所有观察到的 MBeans 的公共初始阈值。
 void CounterMonitor.setModulus(Number value)
设置所有观察到的 MBeans 共同的模值。
 void CounterMonitorMBean.setModulus(Number value)
设置模值。
 void Monitor.setObservedAttribute(String attribute)
设置要观察的属性。
 void Monitor.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
 void CounterMonitor.setOffset(Number value)
设置所有观察到的 MBeans 共同的偏移量值。
 void CounterMonitorMBean.setOffset(Number value)
设置偏移量值。
 void StringMonitor.setStringToCompare(String value)
设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
 void StringMonitorMBean.setStringToCompare(String value)
设置要与 observed 属性进行比较的字符串。
 void CounterMonitor.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
 void CounterMonitorMBean.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代
 void GaugeMonitor.setThresholds(Number highValue, Number lowValue)
设置所有观察到的 MBean 的公共高、低阈值。
 void GaugeMonitorMBean.setThresholds(Number highValue, Number lowValue)
设置高、低阈值。

javax.management.openmbean 中 IllegalArgumentException 的使用

javax.management.openmbean 中 IllegalArgumentException 的子类
class | InvalidKeyException 当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。

javax.management.relation 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.relation 中的方法
void | RoleList.add(int index, Role role) 插入指定为指定位置处的元素的角色。
void | RoleUnresolvedList.add(int index, RoleUnresolved role) 在指定位置处插入指定为元素的未解析角色。
void | RoleList.add(Role role) 添加指定为列表中最后一个元素的 Role。
void | RoleUnresolvedList.add(RoleUnresolved role) 添加指定为列表中最后一个元素的 RoleUnresolved。
boolean | RoleList.addAll(int index, RoleList roleList) 从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(int index, RoleUnresolvedList roleList) 从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
void | RelationServiceMBean.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
protected void | RelationTypeSupport.addRoleInfo(RoleInfo roleInfo) 添加角色信息。
Integer | RelationService.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否以给定类型的关系进行读取。
Integer | RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否在给定类型的关系中读取。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | MBeanServerNotificationFilter.disableObjectName(ObjectName objectName) 禁用与给定 ObjectName 有关的 MBeanServerNotification。
void | MBeanServerNotificationFilter.enableObjectName(ObjectName objectName) 启用与给定 ObjectName 有关的 MBeanServerNotification。
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
List<String> | RelationService.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationServiceMBean.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
String | RelationService.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
String | RelationServiceMBean.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | Relation.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationSupport.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
RoleInfo | RelationType.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
RoleInfo | RelationTypeSupport.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
RoleResult | Relation.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationSupport.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
Boolean | RelationService.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
Boolean | RelationServiceMBean.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
boolean | MBeanServerNotificationFilter.isNotificationEnabled(Notification notif) 向侦听器发送指定通知之前调用。
String | RelationService.isRelation(ObjectName objectName) 如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。
String | RelationServiceMBean.isRelation(ObjectName objectName) 如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。
ObjectName | RelationService.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationServiceMBean.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
void | RelationService.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationServiceMBean.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationService.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | RelationServiceMBean.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
static String | Role.roleValueToString(List<ObjectName> roleValue) 返回给定角色值的字符串。
void | RelationService.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RoleList.set(int index, Role role) 将指定位置处的元素设置为指定角色。
void | RoleUnresolvedList.set(int index, RoleUnresolved role) 将指定位置处的元素设置为指定的未解析角色。
void | RoleUnresolved.setProblemType(int pbType) 设置问题类型。
void | RelationSupport.setRelationServiceManagementFlag(Boolean flag)
void | RelationSupportMBean.setRelationServiceManagementFlag(Boolean flag) 指定此关系是否由 Relation Service 处理。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
void | Role.setRoleName(String roleName) 设置角色名称。
void | RoleUnresolved.setRoleName(String name) 设置角色名称。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。
void | Role.setRoleValue(List<ObjectName> roleValue) 设置角色值。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

抛出 IllegalArgumentException 的 javax.management.relation 中的构造方法
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。
Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。
RoleInfo(RoleInfo roleInfo)
复制构造方法。
RoleInfo(String roleName, String mbeanClassName)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。
RoleList(List<Role> list)
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。
RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。
RoleUnresolvedList(List<RoleUnresolved> list)
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。

javax.management.timer 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.management.timer 中的方法
Integer | Timer.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

javax.net.ssl 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.net.ssl 中的方法
void | SSLSessionContext.setSessionCacheSize(int size) 设置用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
void | SSLSessionContext.setSessionTimeout(int seconds) 设置在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。

javax.rmi.ssl 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.rmi.ssl 中的构造方法
SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

javax.swing 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.swing 中的方法
Popup | PopupFactory.getPopup(Component owner, Component contents, int x, int y) 为包含 Component contents 的 Component owner 创建 Popup。
void | AbstractButton.setDisplayedMnemonicIndex(int index) 提供关于应该装饰文本中哪一个字符来表示助记符的外观提示。
void | JLabel.setDisplayedMnemonicIndex(int index) 关于应该装饰文本中的哪个字符以表示助记符，为外观提供一个提示。

javax.xml.parsers 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.parsers 中的方法
abstract Object | DocumentBuilderFactory.getAttribute(String name) 允许用户在底层实现上检索特定属性。
abstract void | DocumentBuilderFactory.setAttribute(String name, Object value) 允许用户在底层实现上设置特定属性。

javax.xml.stream 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.stream 中的方法
Object | XMLEventReader.getProperty(String name) 从底层实现获取功能/属性值。
abstract Object | XMLInputFactory.getProperty(String name) 从底层实现获取功能/属性的值。
abstract Object | XMLOutputFactory.getProperty(String name) 获取底层实现上的功能/属性
Object | XMLStreamReader.getProperty(String name) 从底层实现获取功能/属性的值
Object | XMLStreamWriter.getProperty(String name) 从底层实现获取功能/属性值
abstract void | XMLInputFactory.setProperty(String name, Object value) 允许用户在底层实现上设置特定功能/属性。
abstract void | XMLOutputFactory.setProperty(String name, Object value) 允许用户在底层实现上设置特定功能/属性。

javax.xml.stream.util 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.stream.util 中的方法
 Object EventReaderDelegate.getProperty(String name)

javax.xml.transform 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.transform 中的方法
abstract String | Transformer.getOutputProperty(String name) 获取对转换器有效的输出属性。
abstract void | Transformer.setErrorListener(ErrorListener listener) 设置转换的实际错误事件侦听器。
abstract void | Transformer.setOutputProperty(String name, String value) 设置转换中实际的输出属性。

javax.xml.transform.sax 中 IllegalArgumentException 的使用

抛出 IllegalArgumentException 的 javax.xml.transform.sax 中的方法
 void TransformerHandler.setResult(Result result)
设置与用于转换的此 TransformerHandler 关联的 Result。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Package 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Package
的使用

使用 Package 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。

java.lang 中 Package 的使用

返回 Package 的 java.lang 中的方法
protected Package | ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase) 根据 name 在此 ClassLoader 中定义包。
Package | Class.getPackage() 获取此类的包。
static Package | Package.getPackage(String name) 通过调用方的 ClassLoader 实例中的名称找到一个包。
protected Package | ClassLoader.getPackage(String name) 返回由此类加载器或其任何祖先所定义的 Package。
static Package[] | Package.getPackages() 获得调用方的 ClassLoader 实例当前已知的所有包。
protected Package[] | ClassLoader.getPackages() 返回此类加载器及其祖先所定义的所有 Package。

java.net 中 Package 的使用

返回 Package 的 java.net 中的方法
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.UnsupportedOperationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.UnsupportedOperationException
的使用

使用 UnsupportedOperationException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
javax.imageio | Java Image I/O API 的主要包。
javax.management.loading | 提供实现高级动态加载的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

java.awt 中 UnsupportedOperationException 的使用

java.awt 中 UnsupportedOperationException 的子类
 class HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。

抛出 UnsupportedOperationException 的 java.awt 中的方法
boolean | Toolkit.getLockingKeyState(int keyCode) 返回键盘上给定锁定键是否处于 "on" 状态。
void | Toolkit.setLockingKeyState(int keyCode, boolean on) 设置键盘上给定锁定键的状态。

java.nio 中 UnsupportedOperationException 的使用

java.nio 中 UnsupportedOperationException 的子类
 class ReadOnlyBufferException
当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

javax.imageio 中 UnsupportedOperationException 的使用

抛出 UnsupportedOperationException 的 javax.imageio 中的方法
 void ImageReadParam.setSourceRenderSize(Dimension size)
如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。

javax.management.loading 中 UnsupportedOperationException 的使用

抛出 UnsupportedOperationException 的 javax.management.loading 中的方法
void | MLet.readExternal(ObjectInput in) 从给定的 ObjectInput 恢复此 MLet 的内容。
void | MLet.writeExternal(ObjectOutput out) 将此 MLet 的内容保存到给定的 ObjectOutput。

javax.xml.soap 中 UnsupportedOperationException 的使用

抛出 UnsupportedOperationException 的 javax.xml.soap 中的方法
static SOAPConnectionFactory SOAPConnectionFactory.newInstance()
创建默认 SOAPConnectionFactory 对象的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.StrictMath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StrictMath
的使用

没有 java.lang.StrictMath 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.StringIndexOutOfBoundsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StringIndexOutOfBoundsException
的使用

没有 java.lang.StringIndexOutOfBoundsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IndexOutOfBoundsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IndexOutOfBoundsException
的使用

使用 IndexOutOfBoundsException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.relation | 提供 Relation Service 的定义。

java.awt 中 IndexOutOfBoundsException 的使用

抛出 IndexOutOfBoundsException 的 java.awt 中的方法
 Cursor Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name)
创建一个新的自定义光标对象。

java.awt.print 中 IndexOutOfBoundsException 的使用

抛出 IndexOutOfBoundsException 的 java.awt.print 中的方法
PageFormat | Book.getPageFormat(int pageIndex) 返回 pageIndex 指定的页面的 PageFormat。
PageFormat | Pageable.getPageFormat(int pageIndex) 返回 pageIndex 指定的页面的 PageFormat。
Printable | Book.getPrintable(int pageIndex) 返回 Printable 实例，该实例负责呈现 pageIndex 指定的页面。
Printable | Pageable.getPrintable(int pageIndex) 返回负责呈现 pageIndex 指定的页面的 Printable 实例。
void | Book.setPage(int pageIndex, Printable painter, PageFormat page) 为指定的页码设置 PageFormat 和 Painter。

java.lang 中 IndexOutOfBoundsException 的使用

java.lang 中 IndexOutOfBoundsException 的子类
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。

javax.management.relation 中 IndexOutOfBoundsException 的使用

抛出 IndexOutOfBoundsException 的 javax.management.relation 中的方法
void | RoleList.add(int index, Role role) 插入指定为指定位置处的元素的角色。
void | RoleUnresolvedList.add(int index, RoleUnresolved role) 在指定位置处插入指定为元素的未解析角色。
boolean | RoleList.addAll(int index, RoleList roleList) 从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(int index, RoleUnresolvedList roleList) 从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
boolean | RoleList.addAll(RoleList roleList) 将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(RoleUnresolvedList roleList) 将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
void | RoleList.set(int index, Role role) 将指定位置处的元素设置为指定角色。
void | RoleUnresolvedList.set(int index, RoleUnresolved role) 将指定位置处的元素设置为指定的未解析角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IllegalStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalStateException
的使用

使用 IllegalStateException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.crypto | 为加密操作提供类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

java.awt 中 IllegalStateException 的使用

java.awt 中 IllegalStateException 的子类
 class IllegalComponentStateException
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

抛出 IllegalStateException 的 java.awt 中的方法
void | SplashScreen.close() 隐藏闪现屏幕、关闭窗口并释放所有相关资源。
Graphics2D | SplashScreen.createGraphics() 创建闪现屏幕叠加图像的图形上下文（Graphics2D 形式），它允许在闪现屏幕上进行绘制。
Rectangle | SplashScreen.getBounds() 以 Rectangle 形式返回闪现屏幕窗口的边界。
URL | SplashScreen.getImageURL() 返回当前闪现屏幕图像。
Dimension | SplashScreen.getSize() 以 Dimension 形式返回闪现屏幕窗口的大小。
void | SplashScreen.setImageURL(URL imageURL) 更改闪现屏幕图像。
void | SplashScreen.update() 用当前叠加图像的上下文来更新闪现屏幕窗口。

java.awt.dnd 中 IllegalStateException 的使用

java.awt.dnd 中 IllegalStateException 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.nio 中 IllegalStateException 的使用

java.nio 中 IllegalStateException 的子类
 class InvalidMarkException
当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。

java.nio.channels 中 IllegalStateException 的使用

java.nio.channels 中 IllegalStateException 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。

java.util 中 IllegalStateException 的使用

java.util 中 IllegalStateException 的子类
 class FormatterClosedException
格式器已关闭时抛出的未经检查的异常。

java.util.concurrent 中 IllegalStateException 的使用

java.util.concurrent 中 IllegalStateException 的子类
 class CancellationException
如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。

javax.crypto 中 IllegalStateException 的使用

抛出 IllegalStateException 的 javax.crypto 中的方法
byte[] | Mac.doFinal() 完成 MAC 操作。
byte[] | Mac.doFinal(byte[] input) 处理给定的 byte 数组并完成 MAC 操作。
void | Mac.doFinal(byte[] output, int outOffset) 完成 MAC 操作。
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected abstract byte[] | KeyAgreementSpi.engineGenerateSecret() 生成共享秘密密钥并在新的缓冲区中返回它。
protected abstract int | KeyAgreementSpi.engineGenerateSecret(byte[] sharedSecret, int offset) 生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
byte[] | KeyAgreement.generateSecret() 生成共享秘密并在新的缓冲区中返回它。
int | KeyAgreement.generateSecret(byte[] sharedSecret, int offset) 生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
byte[] | ExemptionMechanism.genExemptionBlob() 生成豁免机制密钥 blob。
int | ExemptionMechanism.genExemptionBlob(byte[] output) 生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
int | ExemptionMechanism.genExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
int | ExemptionMechanism.getOutputSize(int inputLen) 根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 genExemptionBlob 操作结果所需的输出缓冲区长度（以字节为单位）。
void | Mac.update(byte input) 处理给定的字节。
void | Mac.update(byte[] input) 处理给定的 byte 数组。
void | Mac.update(byte[] input, int offset, int len) 从 offset（包含）开始，处理 input 中的前 len 个字节。

javax.swing 中 IllegalStateException 的使用

抛出 IllegalStateException 的 javax.swing 中的方法
 void TransferHandler.exportToClipboard(JComponent comp, Clipboard clip, int action)
导致从给定组件到给定剪贴板的传输。

javax.xml.bind 中 IllegalStateException 的使用

抛出 IllegalStateException 的 javax.xml.bind 中的方法
 Object UnmarshallerHandler.getResult()
获得解组的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Enum 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Enum
的使用

使用 Enum 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.lang 中 Enum 的使用

类型参数类型为 Enum 的 java.lang 中的类
 class Enum<E extends Enum<E>>
这是所有 Java 语言枚举类型的公共基本类。

类型参数类型为 Enum 的 java.lang 中的方法
static
<T extends Enum<T>>
T
Enum.valueOf(Class<T> enumType, String name)
返回带指定名称的指定枚举类型的枚举常量。

返回变量类型为 Enum 的类型的 java.lang 中的方法
 Class<? extends Enum> EnumConstantNotPresentException.enumType()
返回缺少的枚举常量的类型。

类型变量类型为 Enum 的 java.lang 中的构造方法参数
EnumConstantNotPresentException(Class<? extends Enum> enumType, String constantName)
为指定常量构造一个 EnumConstantNotPresentException。

java.util 中 Enum 的使用

类型参数类型为 Enum 的 java.util 中的类
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。

类型参数类型为 Enum 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E first, E... rest)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4, E e5)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.range(E from, E to)
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。

参数类型为 Enum 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E first, E... rest)
创建一个最初包含指定元素的枚举 set。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NoSuchMethodException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchMethodException
的使用

使用 NoSuchMethodException 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.relation | 提供 Relation Service 的定义。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

java.lang 中 NoSuchMethodException 的使用

抛出 NoSuchMethodException 的 java.lang 中的方法
Constructor<T> | Class.getConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
Constructor<T> | Class.getDeclaredConstructor(Class<?>... parameterTypes) 返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
Method | Class.getDeclaredMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
Method | Class.getMethod(String name, Class<?>... parameterTypes) 返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。

javax.management.relation 中 NoSuchMethodException 的使用

抛出 NoSuchMethodException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

javax.script 中 NoSuchMethodException 的使用

抛出 NoSuchMethodException 的 javax.script 中的方法
Object | Invocable.invokeFunction(String name, Object... args) 用于调用脚本中定义的顶层程序和函数。
Object | Invocable.invokeMethod(Object thiz, String name, Object... args) 对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.InterruptedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.InterruptedException
的使用

使用 InterruptedException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.ref | 提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 InterruptedException 的使用

抛出 InterruptedException 的 java.awt 中的方法
AWTEvent | EventQueue.getNextEvent() 从 EventQueue 中移除一个事件，并返回该事件。
static void | EventQueue.invokeAndWait(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
void | MediaTracker.waitForAll() 开始加载由此媒体跟踪器跟踪的所有图像。
boolean | MediaTracker.waitForAll(long ms) 开始加载由此媒体跟踪器跟踪的所有图像。
void | MediaTracker.waitForID(int id) 开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。
boolean | MediaTracker.waitForID(int id, long ms) 开始加载由此媒体跟踪器跟踪且具有指定标识符的所有图像。

java.awt.image 中 InterruptedException 的使用

抛出 InterruptedException 的 java.awt.image 中的方法
boolean | PixelGrabber.grabPixels() 请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素。
boolean | PixelGrabber.grabPixels(long ms) 请求 Image 或 ImageProducer 开始传递像素，并等待传递完相关矩形中的所有像素，或者等待到用完超时期。

java.lang 中 InterruptedException 的使用

抛出 InterruptedException 的 java.lang 中的方法
 void Thread.join()
等待该线程终止。
 void Thread.join(long millis)
等待该线程终止的时间最长为 millis 毫秒。
 void Thread.join(long millis, int nanos)
等待该线程终止的时间最长为 millis 毫秒 + nanos 纳秒。
static void Thread.sleep(long millis)
在指定的毫秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
static void Thread.sleep(long millis, int nanos)
在指定的毫秒数加指定的纳秒数内让当前正在执行的线程休眠（暂停执行），此操作受到系统计时器和调度程序精度和准确性的影响。
 void Object.wait()
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法前，导致当前线程等待。
 void Object.wait(long timeout)
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者超过指定的时间量前，导致当前线程等待。
 void Object.wait(long timeout, int nanos)
在其他线程调用此对象的 Object.notify() 方法或 Object.notifyAll() 方法，或者其他某个线程中断当前线程，或者已超过某个实际时间量前，导致当前线程等待。
abstract  int Process.waitFor()
导致当前线程等待，如有必要，一直要等到由该 Process 对象表示的进程已经终止。

java.lang.ref 中 InterruptedException 的使用

抛出 InterruptedException 的 java.lang.ref 中的方法
Reference<? extends T> | ReferenceQueue.remove() 移除此队列中的下一个引用对象，阻塞到某个对象变得可用为止。
Reference<? extends T> | ReferenceQueue.remove(long timeout) 移除此队列中的下一个引用对象，阻塞到有一个对象变得可用或者给定的超时期满了为止。

java.util.concurrent 中 InterruptedException 的使用

抛出 InterruptedException 的 java.util.concurrent 中的方法
 void Semaphore.acquire()
从此信号量获取一个许可，在提供一个许可前一直将线程阻塞，否则线程被中断。
 void Semaphore.acquire(int permits)
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞，或者线程已被中断。
 void CountDownLatch.await()
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断。
 int CyclicBarrier.await()
在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。
 boolean CountDownLatch.await(long timeout, TimeUnit unit)
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。
 int CyclicBarrier.await(long timeout, TimeUnit unit)
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
 boolean ExecutorService.awaitTermination(long timeout, TimeUnit unit)
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
 boolean ThreadPoolExecutor.awaitTermination(long timeout, TimeUnit unit)
 V Exchanger.exchange(V x)
等待另一个线程到达此交换点（除非当前线程被中断），然后将给定的对象传送给该线程，并接收该线程的对象。
 V Exchanger.exchange(V x, long timeout, TimeUnit unit)
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
 V Future.get()
如有必要，等待计算完成，然后获取其结果。
 V FutureTask.get()
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
 boolean ArrayBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。
 boolean BlockingDeque.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
 boolean BlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。
 boolean LinkedBlockingDeque.offer(E e, long timeout, TimeUnit unit)
 boolean LinkedBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。
 boolean SynchronousQueue.offer(E o, long timeout, TimeUnit unit)
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。
 boolean BlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
 boolean BlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
 E ArrayBlockingQueue.poll(long timeout, TimeUnit unit)
 E BlockingDeque.poll(long timeout, TimeUnit unit)
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
 E BlockingQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
 Future<V> CompletionService.poll(long timeout, TimeUnit unit)
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
 E DelayQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。
 Future<V> ExecutorCompletionService.poll(long timeout, TimeUnit unit)
 E LinkedBlockingDeque.poll(long timeout, TimeUnit unit)
 E LinkedBlockingQueue.poll(long timeout, TimeUnit unit)
 E PriorityBlockingQueue.poll(long timeout, TimeUnit unit)
 E SynchronousQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。
 E BlockingDeque.pollFirst(long timeout, TimeUnit unit)
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
 E LinkedBlockingDeque.pollFirst(long timeout, TimeUnit unit)
 E BlockingDeque.pollLast(long timeout, TimeUnit unit)
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
 E LinkedBlockingDeque.pollLast(long timeout, TimeUnit unit)
 void ArrayBlockingQueue.put(E e)
将指定的元素插入此队列的尾部，如果该队列已满，则等待可用的空间。
 void BlockingDeque.put(E e)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。
 void BlockingQueue.put(E e)
将指定元素插入此队列中，将等待可用的空间（如果有必要）。
 void LinkedBlockingDeque.put(E e)
 void LinkedBlockingQueue.put(E e)
将指定元素插入到此队列的尾部，如有必要，则等待空间变得可用。
 void SynchronousQueue.put(E o)
将指定元素添加到此队列，如有必要则等待另一个线程接收它。
 void BlockingDeque.putFirst(E e)
将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。
 void LinkedBlockingDeque.putFirst(E e)
 void BlockingDeque.putLast(E e)
将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。
 void LinkedBlockingDeque.putLast(E e)
 void TimeUnit.sleep(long timeout)
使用此单元执行 Thread.sleep.这是将时间参数转换为 Thread.sleep 方法所需格式的便捷方法。
 E ArrayBlockingQueue.take()
 E BlockingDeque.take()
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。
 E BlockingQueue.take()
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
 Future<V> CompletionService.take()
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。
 E DelayQueue.take()
获取并移除此队列的头部，在可从此队列获得到期延迟的元素之前一直等待（如有必要）。
 Future<V> ExecutorCompletionService.take()
 E LinkedBlockingDeque.take()
 E LinkedBlockingQueue.take()
 E PriorityBlockingQueue.take()
 E SynchronousQueue.take()
获取并移除此队列的头，如有必要则等待另一个线程插入它。
 E BlockingDeque.takeFirst()
获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。
 E LinkedBlockingDeque.takeFirst()
 E BlockingDeque.takeLast()
获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。
 E LinkedBlockingDeque.takeLast()
 void TimeUnit.timedJoin(Thread thread, long timeout)
使用此时间单元执行计时的 Thread.join。
 void TimeUnit.timedWait(Object obj, long timeout)
使用此时间单元执行计时的 Object.wait。
 boolean Semaphore.tryAcquire(int permits, long timeout, TimeUnit unit)
如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。
 boolean Semaphore.tryAcquire(long timeout, TimeUnit unit)
如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。

java.util.concurrent.locks 中 InterruptedException 的使用

抛出 InterruptedException 的 java.util.concurrent.locks 中的方法
void | AbstractQueuedSynchronizer.acquireInterruptibly(int arg) 以独占模式获取对象，如果被中断则中止。
void | AbstractQueuedLongSynchronizer.acquireInterruptibly(long arg) 以独占模式获取，如果被中断则中止。
void | AbstractQueuedSynchronizer.acquireSharedInterruptibly(int arg) 以共享模式获取对象，如果被中断则中止。
void | AbstractQueuedLongSynchronizer.acquireSharedInterruptibly(long arg) 以共享模式获取，如果被中断则中止。
void | AbstractQueuedLongSynchronizer.ConditionObject.await() 实现可中断的条件等待。
void | Condition.await() 造成当前线程在接到信号或被中断之前一直处于等待状态。
void | AbstractQueuedSynchronizer.ConditionObject.await() 实现不可中断的条件等待。
boolean | AbstractQueuedLongSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时条件等待。
boolean | Condition.await(long time, TimeUnit unit) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时的条件等待。
long | AbstractQueuedLongSynchronizer.ConditionObject.awaitNanos(long nanosTimeout) 实现定时条件等待。
long | Condition.awaitNanos(long nanosTimeout) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
long | AbstractQueuedSynchronizer.ConditionObject.awaitNanos(long nanosTimeout) 实现定时的条件等待。
boolean | AbstractQueuedLongSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。
boolean | Condition.awaitUntil(Date deadline) 造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。
void | ReentrantReadWriteLock.ReadLock.lockInterruptibly() 获取读取锁，除非当前线程被中断。
void | ReentrantReadWriteLock.WriteLock.lockInterruptibly() 获取写入锁，除非当前线程被中断。
void | ReentrantLock.lockInterruptibly() 如果当前线程未被中断，则获取锁。
void | Lock.lockInterruptibly() 如果当前线程未被中断，则获取锁。
boolean | AbstractQueuedSynchronizer.tryAcquireNanos(int arg, long nanosTimeout) 试图以独占模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
boolean | AbstractQueuedLongSynchronizer.tryAcquireNanos(long arg, long nanosTimeout) 尝试以独占模式获取，如果被中断则中止，如果超过给定超时期则失败。
boolean | AbstractQueuedSynchronizer.tryAcquireSharedNanos(int arg, long nanosTimeout) 试图以共享模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
boolean | AbstractQueuedLongSynchronizer.tryAcquireSharedNanos(long arg, long nanosTimeout) 尝试以共享模式获取，如果被中断则中止，如果超过给定超时期则失败。
boolean | ReentrantReadWriteLock.ReadLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。
boolean | ReentrantReadWriteLock.WriteLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。
boolean | ReentrantLock.tryLock(long timeout, TimeUnit unit) 如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。
boolean | Lock.tryLock(long time, TimeUnit unit) 如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。

javax.swing 中 InterruptedException 的使用

抛出 InterruptedException 的 javax.swing 中的方法
 T SwingWorker.get()
如有必要，等待计算完成，然后获取其结果。
 T SwingWorker.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
static void SwingUtilities.invokeAndWait(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上同步执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NoSuchMethodError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoSuchMethodError
的使用

没有 java.lang.NoSuchMethodError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Compiler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Compiler
的使用

没有 java.lang.Compiler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IncompatibleClassChangeError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IncompatibleClassChangeError
的使用

使用 IncompatibleClassChangeError 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 IncompatibleClassChangeError 的使用

java.lang 中 IncompatibleClassChangeError 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Runtime 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Runtime
的使用

使用 Runtime 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Runtime 的使用

返回 Runtime 的 java.lang 中的方法
static Runtime Runtime.getRuntime()
返回与当前 Java 应用程序相关的运行时对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.Readable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Readable
的使用

使用 Readable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.io 中 Readable 的使用

实现 Readable 的 java.io 中的类
class | BufferedReader 从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。
class | CharArrayReader 此类实现一个可用作字符输入流的字符缓冲区。
class | FileReader 用来读取字符文件的便捷类。
class | FilterReader 用于读取已过滤的字符流的抽象类。
class | InputStreamReader InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。
class | LineNumberReader 跟踪行号的缓冲字符输入流。
class | PipedReader 传送的字符输入流。
class | PushbackReader 允许将字符推回到流的字符流 reader。
class | Reader 用于读取字符流的抽象类。
class | StringReader 其源为一个字符串的字符流。

java.nio 中 Readable 的使用

实现 Readable 的 java.nio 中的类
 class CharBuffer
字符缓冲区。

java.util 中 Readable 的使用

参数类型为 Readable 的 java.util 中的构造方法
Scanner(Readable source)
构造一个新的 Scanner，它生成的值是从指定源扫描的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.StringBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StringBuilder
的使用

使用 StringBuilder 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 StringBuilder 的使用

返回 StringBuilder 的 java.lang 中的方法
StringBuilder | StringBuilder.append(boolean b)
StringBuilder | StringBuilder.append(char c)
StringBuilder | StringBuilder.append(char[] str)
StringBuilder | StringBuilder.append(char[] str, int offset, int len)
StringBuilder | StringBuilder.append(CharSequence s)
StringBuilder | StringBuilder.append(CharSequence s, int start, int end)
StringBuilder | StringBuilder.append(double d)
StringBuilder | StringBuilder.append(float f)
StringBuilder | StringBuilder.append(int i)
StringBuilder | StringBuilder.append(long lng)
StringBuilder | StringBuilder.append(Object obj)
StringBuilder | StringBuilder.append(String str)
StringBuilder | StringBuilder.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列。
StringBuilder | StringBuilder.appendCodePoint(int codePoint)
StringBuilder | StringBuilder.delete(int start, int end)
StringBuilder | StringBuilder.deleteCharAt(int index)
StringBuilder | StringBuilder.insert(int offset, boolean b)
StringBuilder | StringBuilder.insert(int offset, char c)
StringBuilder | StringBuilder.insert(int offset, char[] str)
StringBuilder | StringBuilder.insert(int index, char[] str, int offset, int len)
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s)
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s, int start, int end)
StringBuilder | StringBuilder.insert(int offset, double d)
StringBuilder | StringBuilder.insert(int offset, float f)
StringBuilder | StringBuilder.insert(int offset, int i)
StringBuilder | StringBuilder.insert(int offset, long l)
StringBuilder | StringBuilder.insert(int offset, Object obj)
StringBuilder | StringBuilder.insert(int offset, String str)
StringBuilder | StringBuilder.replace(int start, int end, String str)
StringBuilder | StringBuilder.reverse()

参数类型为 StringBuilder 的 java.lang 中的构造方法
String(StringBuilder builder)
分配一个新的字符串，它包含字符串生成器参数中当前包含的字符序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Math 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Math
的使用

没有 java.lang.Math 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ThreadLocal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ThreadLocal
的使用

使用 ThreadLocal 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 ThreadLocal 的使用

java.lang 中 ThreadLocal 的子类
 class InheritableThreadLocal<T>
该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.RuntimePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.RuntimePermission
的使用

没有 java.lang.RuntimePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ArithmeticException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ArithmeticException
的使用

没有 java.lang.ArithmeticException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NullPointerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NullPointerException
的使用

使用 NullPointerException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.print | 为通用的打印 API 提供类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.awt 中 NullPointerException 的使用

抛出 NullPointerException 的 java.awt 中的方法
 void SplashScreen.setImageURL(URL imageURL)
更改闪现屏幕图像。

java.awt.print 中 NullPointerException 的使用

抛出 NullPointerException 的 java.awt.print 中的方法
abstract  void PrinterJob.setPageable(Pageable document)
查询 document，以获得页面数和 Pageable 实例 document 中保存的每个页面的 PageFormat 和 Printable。

javax.management 中 NullPointerException 的使用

抛出 NullPointerException 的 javax.management 中的方法
 boolean ObjectName.apply(ObjectName name)
测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。
static ObjectName ObjectName.getInstance(ObjectName name)
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
static ObjectName ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。
 String ObjectName.getKeyProperty(String property)
获得与键属性中某个键相关联的值。
 boolean ObjectName.isPropertyValuePattern(String property)
检查键属性中与值关联的值是否为一个模式。
static String ObjectName.quote(String s)
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。
static String ObjectName.unquote(String q)
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

抛出 NullPointerException 的 javax.management 中的构造方法
ObjectName(String name)
根据给定的字符串构造一个对象名。
ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。
ObjectName(String domain, String key, String value)
构造只具有一个键属性的对象名。

org.xml.sax.helpers 中 NullPointerException 的使用

抛出 NullPointerException 的 org.xml.sax.helpers 中的方法
static Parser ParserFactory.makeParser()
已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Long 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Long
的使用

使用 Long 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

java.lang 中 Long 的使用

类型参数类型为 Long 的 java.lang 中的字段
static Class<Long> Long.TYPE
表示基本类型 long 的 Class 实例。

返回 Long 的 java.lang 中的方法
static Long | Long.decode(String nm) 将 String 解码成 Long。
static Long | Long.getLong(String nm) 确定具有指定名称的系统属性的 long 值。
static Long | Long.getLong(String nm, long val) 使用指定名称确定系统属性的 long 值。
static Long | Long.getLong(String nm, Long val) 使用指定名称返回系统属性的 long 值。
static Long | Long.valueOf(long l) 返回表示指定 long 值的 Long 实例。
static Long | Long.valueOf(String s) 返回保持指定 String 的值的 Long 对象。
static Long | Long.valueOf(String s, int radix) 当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。

参数类型为 Long 的 java.lang 中的方法
int | Long.compareTo(Long anotherLong) 在数字上比较两个 Long 对象。
static Long | Long.getLong(String nm, Long val) 使用指定名称返回系统属性的 long 值。

javax.management.openmbean 中 Long 的使用

类型参数类型为 Long 的 javax.management.openmbean 中的字段
static SimpleType<Long> SimpleType.LONG
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。

javax.management.timer 中 Long 的使用

返回 Long 的 javax.management.timer 中的方法
Long | Timer.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Long | TimerMBean.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Long | Timer.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
Long | TimerMBean.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Integer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Integer
的使用

使用 Integer 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

java.awt.font 中 Integer 的使用

声明为 Integer 的 java.awt.font 中的字段
static Integer | TextAttribute.KERNING_ON 请求标准字距调整。
static Integer | TextAttribute.LIGATURES_ON 请求标准可选连字。
static Integer | TextAttribute.SUPERSCRIPT_SUB 标准下标。
static Integer | TextAttribute.SUPERSCRIPT_SUPER 标准上标。
static Integer | TextAttribute.UNDERLINE_LOW_DASHED 单像素虚线低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_DOTTED 单像素点线式低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_GRAY 双像素灰色低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_ONE_PIXEL 单像素实心低下划线。
static Integer | TextAttribute.UNDERLINE_LOW_TWO_PIXEL 双像素实心低下划线。
static Integer | TextAttribute.UNDERLINE_ON 标准下划线。

java.lang 中 Integer 的使用

类型参数类型为 Integer 的 java.lang 中的字段
static Class<Integer> Integer.TYPE
表示基本类型 int 的 Class 实例。

返回 Integer 的 java.lang 中的方法
static Integer | Integer.decode(String nm) 将 String 解码为 Integer。
static Integer | Integer.getInteger(String nm) 确定具有指定名称的系统属性的整数值。
static Integer | Integer.getInteger(String nm, int val) 确定具有指定名称的系统属性的整数值。
static Integer | Integer.getInteger(String nm, Integer val) 返回具有指定名称的系统属性的整数值。
static Integer | Integer.valueOf(int i) 返回一个表示指定的 int 值的 Integer 实例。
static Integer | Integer.valueOf(String s) 返回保存指定的 String 的值的 Integer 对象。
static Integer | Integer.valueOf(String s, int radix) 返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。

参数类型为 Integer 的 java.lang 中的方法
int | Integer.compareTo(Integer anotherInteger) 在数字上比较两个 Integer 对象。
static Integer | Integer.getInteger(String nm, Integer val) 返回具有指定名称的系统属性的整数值。

java.util 中 Integer 的使用

返回变量类型为 Integer 的类型的 java.util 中的方法
 Map<String,Integer> Calendar.getDisplayNames(int field, int style, Locale locale)
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。

javax.management 中 Integer 的使用

返回 Integer 的 javax.management 中的方法
Integer | MBeanServer.getMBeanCount() 返回 MBean 服务器中已注册的 MBean 的数目。
Integer | MBeanServerConnection.getMBeanCount() 返回 MBean 服务器中已注册的 MBean 数目。

javax.management.openmbean 中 Integer 的使用

类型参数类型为 Integer 的 javax.management.openmbean 中的字段
static SimpleType<Integer> SimpleType.INTEGER
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。

javax.management.relation 中 Integer 的使用

返回 Integer 的 javax.management.relation 中的方法
Integer | RelationService.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否以给定类型的关系进行读取。
Integer | RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否在给定类型的关系中读取。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
Integer | Relation.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationSupport.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。

javax.management.remote 中 Integer 的使用

返回 Integer 的 javax.management.remote 中的方法
 Integer TargetedNotification.getListenerID()
此通知所定向的侦听器的 ID。

参数类型为 Integer 的 javax.management.remote 中的构造方法
TargetedNotification(Notification notification, Integer listenerID)
构造一个 TargetedNotification 对象。

javax.management.remote.rmi 中 Integer 的使用

返回 Integer 的 javax.management.remote.rmi 中的方法
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 Integer RMIConnection.getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 Integer RMIConnectionImpl.getMBeanCount(Subject delegationSubject)
 Integer RMIConnectionImpl_Stub.getMBeanCount(Subject $param_Subject_1)

参数类型为 Integer 的 javax.management.remote.rmi 中的方法
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)

javax.management.timer 中 Integer 的使用

返回 Integer 的 javax.management.timer 中的方法
Integer | Timer.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerNotification.getNotificationID() 获取此计时器通知的标识符。

返回变量类型为 Integer 的类型的 javax.management.timer 中的方法
Vector<Integer> | Timer.getAllNotificationIDs() 获得所有在通知列表中注册的计时器通知标识符。
Vector<Integer> | TimerMBean.getAllNotificationIDs() 获得所有在通知的列表中注册的计时器通知标识符。
Vector<Integer> | Timer.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。
Vector<Integer> | TimerMBean.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。

参数类型为 Integer 的 javax.management.timer 中的方法
Date | Timer.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Date | TimerMBean.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Boolean | Timer.getFixedRate(Integer id) 获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
Boolean | TimerMBean.getFixedRate(Integer id) 获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
Long | Timer.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Long | TimerMBean.getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
String | Timer.getNotificationMessage(Integer id) 获得与指定标识符对应的计时器通知的详细消息。
String | TimerMBean.getNotificationMessage(Integer id) 获得与指定的标识符对应的计时器通知的详细消息。
String | Timer.getNotificationType(Integer id) 获得与指定标识符对应的计时器通知类型。
String | TimerMBean.getNotificationType(Integer id) 获得与指定标识符对应的计时器通知类型。
Object | Timer.getNotificationUserData(Integer id) 获得与指定标识符对应的计时器通知用户数据对象。
Object | TimerMBean.getNotificationUserData(Integer id) 获得与指定的标识符对应的计时器通知用户数据对象。
Long | Timer.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
Long | TimerMBean.getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
void | Timer.removeNotification(Integer id) 从通知列表中移除与指定标识符对应的计时器通知。
void | TimerMBean.removeNotification(Integer id) 从通知列表中移除与指定的标识符对应的计时器通知。

参数类型为 Integer 的 javax.management.timer 中的构造方法
TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
创建计时器通知对象。

javax.script 中 Integer 的使用

返回变量类型为 Integer 的类型的 javax.script 中的方法
List<Integer> | ScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。
List<Integer> | SimpleScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。

javax.swing 中 Integer 的使用

声明为 Integer 的 javax.swing 中的字段
static Integer | JLayeredPane.DEFAULT_LAYER 定义 Default 层的便捷对象。
static Integer | JLayeredPane.DRAG_LAYER 定义 Drag 层的便捷对象。
static Integer | JLayeredPane.FRAME_CONTENT_LAYER 定义 Frame Content 层的便捷对象。
static Integer | JLayeredPane.MODAL_LAYER 定义 Modal 层的便捷对象。
static Integer | JLayeredPane.PALETTE_LAYER 定义 Palette 层的便捷对象。
static Integer | JLayeredPane.POPUP_LAYER 定义 Popup 层的便捷对象。

返回 Integer 的 javax.swing 中的方法
protected  Integer JLayeredPane.getObjectForLayer(int layer)
返回与指定层关联的 Integer 对象。

返回变量类型为 Integer 的类型的 javax.swing 中的方法
protected  Hashtable<Component,Integer> JLayeredPane.getComponentToLayer()
返回将组件映射到层的哈希表。

参数类型为 Integer 的 javax.swing 中的方法
 void JInternalFrame.setLayer(Integer layer)
设置此组件 layer 属性的便捷方法。

javax.swing.plaf.basic 中 Integer 的使用

返回 Integer 的 javax.swing.plaf.basic 中的方法
protected Integer | BasicSliderUI.getHighestValue() 返回在标签表中有一个项的最大值。
protected Integer | BasicSliderUI.getLowestValue() 返回在标签表中有一个项的最小值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Short 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Short
的使用

使用 Short 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Short 的使用

类型参数类型为 Short 的 java.lang 中的字段
static Class<Short> Short.TYPE
表示基本类型 short 的 Class 实例。

返回 Short 的 java.lang 中的方法
static Short | Short.decode(String nm) 将 String 解码为 Short。
static Short | Short.valueOf(short s) 返回表示指定 short 值的 Short 实例。
static Short | Short.valueOf(String s) 返回一个保持指定 String 所给出的值的 Short 对象。
static Short | Short.valueOf(String s, int radix) 返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。

参数类型为 Short 的 java.lang 中的方法
 int Short.compareTo(Short anotherShort)
比较两个 Short 对象所表示的数值。

javax.management.openmbean 中 Short 的使用

类型参数类型为 Short 的 javax.management.openmbean 中的字段
static SimpleType<Short> SimpleType.SHORT
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Byte 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Byte
的使用

使用 Byte 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Byte 的使用

类型参数类型为 Byte 的 java.lang 中的字段
static Class<Byte> Byte.TYPE
表示基本类型 byte 的 Class 实例。

返回 Byte 的 java.lang 中的方法
static Byte | Byte.decode(String nm) 将 String 解码为 Byte。
static Byte | Byte.valueOf(byte b) 返回表示指定 byte 值的一个 Byte 实例。
static Byte | Byte.valueOf(String s) 返回一个保持指定 String 所给出的值的 Byte 对象。
static Byte | Byte.valueOf(String s, int radix) 返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。

参数类型为 Byte 的 java.lang 中的方法
 int Byte.compareTo(Byte anotherByte)
在数字上比较两个 Byte 对象。

javax.management.openmbean 中 Byte 的使用

类型参数类型为 Byte 的 javax.management.openmbean 中的字段
static SimpleType<Byte> SimpleType.BYTE
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Double 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Double
的使用

使用 Double 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang 中 Double 的使用

类型参数类型为 Double 的 java.lang 中的字段
static Class<Double> Double.TYPE
表示基本类型 double 的 Class 实例。

返回 Double 的 java.lang 中的方法
static Double | Double.valueOf(double d) 返回表示指定的 double 值的 Double 实例。
static Double | Double.valueOf(String s) 返回保存用参数字符串 s 表示的 double 值的 Double 对象。

参数类型为 Double 的 java.lang 中的方法
 int Double.compareTo(Double anotherDouble)
对两个 Double 对象所表示的数值进行比较。

javax.management.openmbean 中 Double 的使用

类型参数类型为 Double 的 javax.management.openmbean 中的字段
static SimpleType<Double> SimpleType.DOUBLE
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Float 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Float
的使用

使用 Float 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.awt.font 中 Float 的使用

声明为 Float 的 java.awt.font 中的字段
static Float | TextAttribute.JUSTIFICATION_FULL 将线条调整到完整的请求宽度。
static Float | TextAttribute.JUSTIFICATION_NONE 不允许调整线条。
static Float | TextAttribute.POSTURE_OBLIQUE 标准斜体形态。
static Float | TextAttribute.POSTURE_REGULAR 标准直立形态。
static Float | TextAttribute.TRACKING_LOOSE 执行宽松跟踪。
static Float | TextAttribute.TRACKING_TIGHT 执行紧密跟踪。
static Float | TextAttribute.WEIGHT_BOLD 标准的粗体 weight。
static Float | TextAttribute.WEIGHT_DEMIBOLD 比 WEIGHT_BOLD 稍轻的 weight。
static Float | TextAttribute.WEIGHT_DEMILIGHT WEIGHT_LIGHT 和 WEIGHT_STANDARD 之间的中间 weight。
static Float | TextAttribute.WEIGHT_EXTRA_LIGHT 最轻的预定义 weight。
static Float | TextAttribute.WEIGHT_EXTRABOLD 特别重的 weight。
static Float | TextAttribute.WEIGHT_HEAVY 比 WEIGHT_BOLD 稍重的 weight。
static Float | TextAttribute.WEIGHT_LIGHT 标准的轻 weight。
static Float | TextAttribute.WEIGHT_MEDIUM WEIGHT_REGULAR 和 WEIGHT_BOLD 之间的中间 weight。
static Float | TextAttribute.WEIGHT_REGULAR 标准 weight。
static Float | TextAttribute.WEIGHT_SEMIBOLD 比 WEIGHT_REGULAR 稍重的 weight。
static Float | TextAttribute.WEIGHT_ULTRABOLD 最重的预定义 weight。
static Float | TextAttribute.WIDTH_CONDENSED 最精简的预定义 width。
static Float | TextAttribute.WIDTH_EXTENDED 最大扩展的预定义 width。
static Float | TextAttribute.WIDTH_REGULAR 标准 width。
static Float | TextAttribute.WIDTH_SEMI_CONDENSED 适度精简的 width。
static Float | TextAttribute.WIDTH_SEMI_EXTENDED 适度扩展的 width。

java.lang 中 Float 的使用

类型参数类型为 Float 的 java.lang 中的字段
static Class<Float> Float.TYPE
表示 float 基本类型的 Class 实例。

返回 Float 的 java.lang 中的方法
static Float | Float.valueOf(float f) 返回表示指定的 float 值的 Float 实例。
static Float | Float.valueOf(String s) 返回保存用参数字符串 s 表示的 float 值的 Float 对象。

参数类型为 Float 的 java.lang 中的方法
 int Float.compareTo(Float anotherFloat)
比较两个 Float 对象所表示的数值。

javax.management.openmbean 中 Float 的使用

类型参数类型为 Float 的 javax.management.openmbean 中的字段
static SimpleType<Float> SimpleType.FLOAT
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Number 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Number
的使用

使用 Number 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.datatype | XML/Java 类型映射关系。

java.awt 中 Number 的使用

返回 Number 的 java.awt 中的方法
Number | Button.AccessibleAWTButton.getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | Checkbox.AccessibleAWTCheckbox.getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getCurrentAccessibleValue() 获取此对象的值，它是一个 Number。
Number | Scrollbar.AccessibleAWTScrollBar.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | MenuItem.AccessibleAWTMenuItem.getCurrentAccessibleValue() 以数字形式获取此对象的值。
Number | Button.AccessibleAWTButton.getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | Checkbox.AccessibleAWTCheckbox.getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMaximumAccessibleValue() 获取此对象的最大值，它是一个 Number。
Number | Scrollbar.AccessibleAWTScrollBar.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | MenuItem.AccessibleAWTMenuItem.getMaximumAccessibleValue() 以数字形式获取此对象的最大值。
Number | Button.AccessibleAWTButton.getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
Number | Checkbox.AccessibleAWTCheckbox.getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
Number | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getMinimumAccessibleValue() 获取此对象的最小值，它是一个 Number。
Number | Scrollbar.AccessibleAWTScrollBar.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | MenuItem.AccessibleAWTMenuItem.getMinimumAccessibleValue() 以数字形式获取此对象的最小值。

参数类型为 Number 的 java.awt 中的方法
boolean | Button.AccessibleAWTButton.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | Checkbox.AccessibleAWTCheckbox.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | Scrollbar.AccessibleAWTScrollBar.setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
boolean | MenuItem.AccessibleAWTMenuItem.setCurrentAccessibleValue(Number n) 将此对象的值设置为数字。

java.lang 中 Number 的使用

java.lang 中 Number 的子类
class | Byte Byte 类将基本类型 byte 的值包装在一个对象中。
class | Double Double 类在对象中包装一个基本类型 double 的值。
class | Float Float 类在对象中包装一个基本类型 float 的值。
class | Integer Integer 类在对象中包装了一个基本类型 int 的值。
class | Long Long 类在对象中包装了基本类型 long 的值。
class | Short Short 类在对象中包装基本类型 short 的值。

java.math 中 Number 的使用

java.math 中 Number 的子类
class | BigDecimal 不可变的、任意精度的有符号十进制数。
class | BigInteger 不可变的任意精度的整数。

java.text 中 Number 的使用

返回 Number 的 java.text 中的方法
Number | NumberFormat.parse(String source) 解析给定字符串开头的文本，生成一个数值。
Number | ChoiceFormat.parse(String text, ParsePosition status) 解析输入文本中的一个 Number。
Number | DecimalFormat.parse(String text, ParsePosition pos) 解析字符串中的文本，以生成一个 Number。
abstract Number | NumberFormat.parse(String source, ParsePosition parsePosition) 如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。

java.util.concurrent.atomic 中 Number 的使用

java.util.concurrent.atomic 中 Number 的子类
class | AtomicInteger 可以用原子方式更新的 int 值。
class | AtomicLong 可以用原子方式更新的 long 值。

javax.accessibility 中 Number 的使用

返回 Number 的 javax.accessibility 中的方法
Number | AccessibleValue.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | AccessibleValue.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | AccessibleValue.getMinimumAccessibleValue() 以 Number 形式设置此对象的最小值。

参数类型为 Number 的 javax.accessibility 中的方法
 boolean AccessibleValue.setCurrentAccessibleValue(Number n)
以 Number 形式设置此对象的值。

javax.management 中 Number 的使用

参数类型为 Number 的 javax.management 中的方法
static ValueExp Query.value(Number val)
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

javax.management.monitor 中 Number 的使用

返回 Number 的 javax.management.monitor 中的方法
 Number CounterMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getDerivedGauge(ObjectName) 取代
 Number CounterMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitor.getDerivedGauge(ObjectName) 取代
 Number GaugeMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 GaugeMonitorMBean.getDerivedGauge(ObjectName) 取代
 Number CounterMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number CounterMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 Number GaugeMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number GaugeMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 Number GaugeMonitor.getHighThreshold()
获取所有所观察的 MBean 的公共高阈值。
 Number GaugeMonitorMBean.getHighThreshold()
获取高阈值。
 Number CounterMonitor.getInitThreshold()
获取所有观察对象的公共初始阈值。
 Number CounterMonitorMBean.getInitThreshold()
获取所有 observed 对象的公共初始阈值。
 Number GaugeMonitor.getLowThreshold()
获取所有观察到的 MBean 的公共低阈值。
 Number GaugeMonitorMBean.getLowThreshold()
获取低阈值。
 Number CounterMonitor.getModulus()
获取所有观察到的 MBeans 共同的模值。
 Number CounterMonitorMBean.getModulus()
获取模值。
 Number CounterMonitor.getOffset()
获取所有观察到的 MBeans 共同的偏移量值。
 Number CounterMonitorMBean.getOffset()
获取偏移值。
 Number CounterMonitor.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitor.getThreshold(ObjectName) 取代
 Number CounterMonitorMBean.getThreshold()
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.getThreshold(ObjectName) 取代
 Number CounterMonitor.getThreshold(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。
 Number CounterMonitorMBean.getThreshold(ObjectName object)
获取指定 MBean 的阈值。

参数类型为 Number 的 javax.management.monitor 中的方法
 void CounterMonitor.setInitThreshold(Number value)
设置所有观察对象的共同初始阈值。
 void CounterMonitorMBean.setInitThreshold(Number value)
设置所有观察到的 MBeans 的公共初始阈值。
 void CounterMonitor.setModulus(Number value)
设置所有观察到的 MBeans 共同的模值。
 void CounterMonitorMBean.setModulus(Number value)
设置模值。
 void CounterMonitor.setOffset(Number value)
设置所有观察到的 MBeans 共同的偏移量值。
 void CounterMonitorMBean.setOffset(Number value)
设置偏移量值。
 void CounterMonitor.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitor.setInitThreshold(java.lang.Number) 取代
 void CounterMonitorMBean.setThreshold(Number value)
已过时。 从 JMX 1.2 开始，由 CounterMonitorMBean.setInitThreshold(java.lang.Number) 取代
 void GaugeMonitor.setThresholds(Number highValue, Number lowValue)
设置所有观察到的 MBean 的公共高、低阈值。
 void GaugeMonitorMBean.setThresholds(Number highValue, Number lowValue)
设置高、低阈值。

javax.swing 中 Number 的使用

返回 Number 的 javax.swing 中的方法
Number | JSpinner.AccessibleJSpinner.getCurrentAccessibleValue() 获取此对象数字形式的值。
Number | JSlider.AccessibleJSlider.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | JProgressBar.AccessibleJProgressBar.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | JScrollBar.AccessibleJScrollBar.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | JSplitPane.AccessibleJSplitPane.getCurrentAccessibleValue() 获取此对象的可访问值。
Number | AbstractButton.AccessibleAbstractButton.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | JInternalFrame.AccessibleJInternalFrame.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | JSpinner.AccessibleJSpinner.getMaximumAccessibleValue() 获取此对象数字形式的最大值。
Number | JSlider.AccessibleJSlider.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | JProgressBar.AccessibleJProgressBar.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | JScrollBar.AccessibleJScrollBar.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | JSplitPane.AccessibleJSplitPane.getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | AbstractButton.AccessibleAbstractButton.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | JInternalFrame.AccessibleJInternalFrame.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | JSpinner.AccessibleJSpinner.getMinimumAccessibleValue() 获取此对象数字形式的最小值。
Number | JSlider.AccessibleJSlider.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | JProgressBar.AccessibleJProgressBar.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | JScrollBar.AccessibleJScrollBar.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | JSplitPane.AccessibleJSplitPane.getMinimumAccessibleValue() 获取此对象的最小可访问值。
Number | AbstractButton.AccessibleAbstractButton.getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
Number | JInternalFrame.AccessibleJInternalFrame.getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
Number | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
Number | SpinnerNumberModel.getNumber() 返回该序列的当前元素的值。
Number | SpinnerNumberModel.getStepSize() 返回由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。

参数类型为 Number 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。
 boolean JSpinner.AccessibleJSpinner.setCurrentAccessibleValue(Number n)
将此对象的值设置为数字。
 boolean JSlider.AccessibleJSlider.setCurrentAccessibleValue(Number n)
将此对象的值设置为数字。
 boolean JProgressBar.AccessibleJProgressBar.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JScrollBar.AccessibleJScrollBar.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JSplitPane.AccessibleJSplitPane.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean AbstractButton.AccessibleAbstractButton.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JInternalFrame.AccessibleJInternalFrame.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 boolean JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。
 void SpinnerNumberModel.setStepSize(Number stepSize)
更改由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。

参数类型为 Number 的 javax.swing 中的构造方法
SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。

javax.xml.datatype 中 Number 的使用

返回 Number 的 javax.xml.datatype 中的方法
abstract  Number Duration.getField(DatatypeConstants.Field field)
获取字段的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Character 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Character
的使用

使用 Character 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 Character 的使用

参数类型为 Character 的 java.awt 中的方法
static AWTKeyStroke AWTKeyStroke.getAWTKeyStroke(Character keyChar, int modifiers)
返回一个共享的 AWTKeyStroke 实例，它表示针对指定 Character 对象和一组组合键的 KEY_TYPED 事件。

java.lang 中 Character 的使用

类型参数类型为 Character 的 java.lang 中的字段
static Class<Character> Character.TYPE
表示基本类型 char 的 Class 实例。

返回 Character 的 java.lang 中的方法
static Character Character.valueOf(char c)
返回一个表示指定 char 值的 Character 实例。

参数类型为 Character 的 java.lang 中的方法
 int Character.compareTo(Character anotherCharacter)
根据数字比较两个 Character 对象。

javax.management.openmbean 中 Character 的使用

类型参数类型为 Character 的 javax.management.openmbean 中的字段
static SimpleType<Character> SimpleType.CHARACTER
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。

javax.swing 中 Character 的使用

参数类型为 Character 的 javax.swing 中的方法
static KeyStroke KeyStroke.getKeyStroke(Character keyChar, int modifiers)
返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Character.Subset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Character.Subset
的使用

使用 Character.Subset 的软件包
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。

java.awt.im 中 Character.Subset 的使用

java.awt.im 中 Character.Subset 的子类
 class InputSubset
定义输入方法使用的其他 Unicode 子集。

参数类型为 Character.Subset 的 java.awt.im 中的方法
 void InputContext.setCharacterSubsets(Character.Subset[] subsets)
设置此输入上下文的输入方法应允许输入的 Unicode 字符集的子集。

java.awt.im.spi 中 Character.Subset 的使用

参数类型为 Character.Subset 的 java.awt.im.spi 中的方法
 void InputMethod.setCharacterSubsets(Character.Subset[] subsets)
设置允许此输入方法进行输入的 Unicode 字符集的子集。

java.lang 中 Character.Subset 的使用

java.lang 中 Character.Subset 的子类
static class Character.UnicodeBlock
表示 Unicode 规范中字符块的一系列字符子集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Character.UnicodeBlock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Character.UnicodeBlock
的使用

使用 Character.UnicodeBlock 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Character.UnicodeBlock 的使用

声明为 Character.UnicodeBlock 的 java.lang 中的字段
static Character.UnicodeBlock | Character.UnicodeBlock.AEGEAN_NUMBERS “Aegean Numbers”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ALPHABETIC_PRESENTATION_FORMS “Alphabetic Presentation Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARABIC “Arabic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_A “Arabic Presentation Forms-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARABIC_PRESENTATION_FORMS_B “Arabic Presentation Forms-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARMENIAN “Armenian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ARROWS “Arrows”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BASIC_LATIN “Basic Latin”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BENGALI “Bengali”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BLOCK_ELEMENTS “Block Elements”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BOPOMOFO “Bopomofo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BOPOMOFO_EXTENDED “Bopomofo Extended”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BOX_DRAWING “Box Drawing”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BRAILLE_PATTERNS “Braille Patterns”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BUHID “Buhid”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.BYZANTINE_MUSICAL_SYMBOLS “Byzantine Musical Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CHEROKEE “Cherokee”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY “CJK Compatibility”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY_FORMS “CJK Compatibility Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS “CJK Compatibility Ideographs”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_COMPATIBILITY_IDEOGRAPHS_SUPPLEMENT “CJK Compatibility Ideographs Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_RADICALS_SUPPLEMENT “CJK Radicals Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_SYMBOLS_AND_PUNCTUATION “CJK Symbols and Punctuation”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS “CJK Unified Ideographs”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_A “CJK Unified Ideographs Extension A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CJK_UNIFIED_IDEOGRAPHS_EXTENSION_B “CJK Unified Ideographs Extension B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.COMBINING_DIACRITICAL_MARKS “Combining Diacritical Marks”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.COMBINING_HALF_MARKS “Combining Half Marks”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.COMBINING_MARKS_FOR_SYMBOLS “Combining Diacritical Marks for Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CONTROL_PICTURES “Control Pictures”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CURRENCY_SYMBOLS “Currency Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CYPRIOT_SYLLABARY “Cypriot Syllabary”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CYRILLIC “Cyrillic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.CYRILLIC_SUPPLEMENTARY “Cyrillic Supplementary”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.DESERET “Deseret”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.DEVANAGARI “Devanagari”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.DINGBATS “Dingbats”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ENCLOSED_ALPHANUMERICS “Enclosed Alphanumerics”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ENCLOSED_CJK_LETTERS_AND_MONTHS “Enclosed CJK Letters and Months”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ETHIOPIC “Ethiopic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GENERAL_PUNCTUATION “General Punctuation”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GEOMETRIC_SHAPES “Geometric Shapes”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GEORGIAN “Georgian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GOTHIC “Gothic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GREEK “Greek and Coptic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GREEK_EXTENDED “Greek Extended”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GUJARATI “Gujarati”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.GURMUKHI “Gurmukhi”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HALFWIDTH_AND_FULLWIDTH_FORMS “Halfwidth and Fullwidth Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANGUL_COMPATIBILITY_JAMO “Hangul Compatibility Jamo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANGUL_JAMO “Hangul Jamo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANGUL_SYLLABLES “Hangul Syllables”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HANUNOO “Hanunoo”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HEBREW “Hebrew”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HIGH_PRIVATE_USE_SURROGATES “High Private Use Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HIGH_SURROGATES “High Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.HIRAGANA “Hiragana”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.IDEOGRAPHIC_DESCRIPTION_CHARACTERS “Ideographic Description Characters”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.IPA_EXTENSIONS “IPA Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KANBUN “Kanbun”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KANGXI_RADICALS “Kangxi Radicals”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KANNADA “Kannada”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KATAKANA “Katakana”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KATAKANA_PHONETIC_EXTENSIONS “Katakana Phonetic Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KHMER “Khmer”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.KHMER_SYMBOLS “Khmer Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LAO “Lao”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_1_SUPPLEMENT “Latin-1 Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_EXTENDED_A “Latin Extended-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_EXTENDED_ADDITIONAL “Latin Extended Additional”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LATIN_EXTENDED_B “Latin Extended-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LETTERLIKE_SYMBOLS “Letterlike Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LIMBU “Limbu”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LINEAR_B_IDEOGRAMS “Linear B Ideograms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LINEAR_B_SYLLABARY “Linear B Syllabary”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.LOW_SURROGATES “Low Surrogates”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MALAYALAM “Malayalam”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MATHEMATICAL_ALPHANUMERIC_SYMBOLS “Mathematical Alphanumeric Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MATHEMATICAL_OPERATORS “Mathematical Operators”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_MATHEMATICAL_SYMBOLS_A “Miscellaneous Mathematical Symbols-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_MATHEMATICAL_SYMBOLS_B “Miscellaneous Mathematical Symbols-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_SYMBOLS “Miscellaneous Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_SYMBOLS_AND_ARROWS “Miscellaneous Symbols and Arrows”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MISCELLANEOUS_TECHNICAL “Miscellaneous Technical”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MONGOLIAN “Mongolian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MUSICAL_SYMBOLS “Musical Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.MYANMAR “Myanmar”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.NUMBER_FORMS “Number Forms”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OGHAM “Ogham”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OLD_ITALIC “Old Italic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OPTICAL_CHARACTER_RECOGNITION “Optical Character Recognition”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.ORIYA “Oriya”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.OSMANYA “Osmanya”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.PHONETIC_EXTENSIONS “Phonetic Extensions”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.PRIVATE_USE_AREA “Private Use Area”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.RUNIC “Runic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SHAVIAN “Shavian”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SINHALA “Sinhala”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SMALL_FORM_VARIANTS “Small Form Variants”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SPACING_MODIFIER_LETTERS “Spacing Modifier Letters”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SPECIALS “Specials”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPERSCRIPTS_AND_SUBSCRIPTS “Superscripts and Subscripts”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTAL_ARROWS_A “Supplemental Arrows-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTAL_ARROWS_B “Supplemental Arrows-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTAL_MATHEMATICAL_OPERATORS “Supplemental Mathematical Operators”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTARY_PRIVATE_USE_AREA_A “Supplementary Private Use Area-A”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SUPPLEMENTARY_PRIVATE_USE_AREA_B “Supplementary Private Use Area-B”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.SURROGATES_AREA 已过时。 从 J2SE 5 开始，使用 HIGH_SURROGATES、HIGH_PRIVATE_USE_SURROGATES 和 LOW_SURROGATES。这些新常量符合 Unicode 标准的块定义。of(char) 和 of(int) 方法返回新常量，而不是 SURROGATES_AREA。
static Character.UnicodeBlock | Character.UnicodeBlock.SYRIAC “Syriac”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAGALOG “Tagalog”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAGBANWA “Tagbanwa”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAGS “Tags”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAI_LE “Tai Le”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAI_XUAN_JING_SYMBOLS “Tai Xuan Jing Symbols”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TAMIL “Tamil”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TELUGU “Telugu”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.THAANA “Thaana”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.THAI “Thai”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.TIBETAN “Tibetan”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.UGARITIC “Ugaritic”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.UNIFIED_CANADIAN_ABORIGINAL_SYLLABICS “Unified Canadian Aboriginal Syllabics”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.VARIATION_SELECTORS “Variation Selectors”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.VARIATION_SELECTORS_SUPPLEMENT “Variation Selectors Supplement”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.YI_RADICALS “Yi Radicals”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.YI_SYLLABLES “Yi Syllables”Unicode 字符块的常量。
static Character.UnicodeBlock | Character.UnicodeBlock.YIJING_HEXAGRAM_SYMBOLS “Yijing Hexagram Symbols”Unicode 字符块的常量。

返回 Character.UnicodeBlock 的 java.lang 中的方法
static Character.UnicodeBlock | Character.UnicodeBlock.forName(String blockName) 返回带有给定名称的 UnicodeBlock。
static Character.UnicodeBlock | Character.UnicodeBlock.of(char c) 返回表示包含给定字符的 Unicode 块的对象；如果该字符不是某个定义块的成员，则返回 null。
static Character.UnicodeBlock | Character.UnicodeBlock.of(int codePoint) 返回表示包含给定字符（Unicode 代码点）的 Unicode 块的对象；如果该字符不是定义块的成员，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Boolean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Boolean
的使用

使用 Boolean 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.awt.font 中 Boolean 的使用

声明为 Boolean 的 java.awt.font 中的字段
static Boolean | TextAttribute.RUN_DIRECTION_LTR 从左到右的延伸方向。
static Boolean | TextAttribute.RUN_DIRECTION_RTL 从右到左的延伸方向。
static Boolean | TextAttribute.STRIKETHROUGH_ON 单删除线。
static Boolean | TextAttribute.SWAP_COLORS_ON 交换前景和背景。

java.lang 中 Boolean 的使用

声明为 Boolean 的 java.lang 中的字段
static Boolean | Boolean.FALSE 对应基值 false 的 Boolean 对象。
static Boolean | Boolean.TRUE 对应基值 true 的 Boolean 对象。

类型参数类型为 Boolean 的 java.lang 中的字段
static Class<Boolean> Boolean.TYPE
表示基本类型 boolean 的 Class 对象。

返回 Boolean 的 java.lang 中的方法
static Boolean | Boolean.valueOf(boolean b) 返回一个表示指定 boolean 值的 Boolean 实例。
static Boolean | Boolean.valueOf(String s) 返回一个用指定的字符串表示值的 Boolean 值。

参数类型为 Boolean 的 java.lang 中的方法
 int Boolean.compareTo(Boolean b)
将此 Boolean 实例与其他实例进行比较。

java.util 中 Boolean 的使用

类型变量类型为 Boolean 的 java.util 中的方法参数
static
<E> Set<E>
Collections.newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。

javax.management 中 Boolean 的使用

参数类型为 Boolean 的 javax.management 中的方法
void | MBeanRegistration.postRegister(Boolean registrationDone) 允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
void | StandardMBean.postRegister(Boolean registrationDone) 允许 MBean 在已注册到 MBean 服务器之后或注册已失败之后执行任何它所需要的操作。

javax.management.loading 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.loading 中的方法
 void MLet.postRegister(Boolean registrationDone)
允许 m-let 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。

javax.management.modelmbean 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.modelmbean 中的方法
 void RequiredModelMBean.postRegister(Boolean registrationDone)
允许 MBean 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。

javax.management.monitor 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.monitor 中的方法
 void Monitor.postRegister(Boolean registrationDone)
允许在 MBean 服务器中注册监视器 MBean 后或注册失败后执行所需的任何操作。

javax.management.openmbean 中 Boolean 的使用

类型参数类型为 Boolean 的 javax.management.openmbean 中的字段
static SimpleType<Boolean> SimpleType.BOOLEAN
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。

javax.management.relation 中 Boolean 的使用

返回 Boolean 的 javax.management.relation 中的方法
Boolean | RelationService.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
Boolean | RelationServiceMBean.hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
Boolean | RelationSupport.isInRelationService() 返回指定该对象是否仍然由 Relation Service 处理的内部标志。
Boolean | RelationSupportMBean.isInRelationService() 返回指定该对象是否仍然由 Relation Service 处理的内部标志。

参数类型为 Boolean 的 javax.management.relation 中的方法
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.postRegister(Boolean registrationDone)
void | RelationSupport.postRegister(Boolean registrationDone)
void | RelationSupport.setRelationServiceManagementFlag(Boolean flag)
void | RelationSupportMBean.setRelationServiceManagementFlag(Boolean flag) 指定此关系是否由 Relation Service 处理。

javax.management.remote 中 Boolean 的使用

参数类型为 Boolean 的 javax.management.remote 中的方法
 void JMXConnectorServer.postRegister(Boolean registrationDone)

javax.management.timer 中 Boolean 的使用

返回 Boolean 的 javax.management.timer 中的方法
Boolean | Timer.getFixedRate(Integer id) 获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
Boolean | TimerMBean.getFixedRate(Integer id) 获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。

参数类型为 Boolean 的 javax.management.timer 中的方法
 void Timer.postRegister(Boolean registrationDone)
允许计时器 MBean 在 MBean 服务器中注册后或注册失败后执行任何所需的操作。

javax.swing 中 Boolean 的使用

参数类型为 Boolean 的 javax.swing 中的方法
void | GroupLayout.setHonorsVisibility(Component component, Boolean honorsVisibility) 设置确定组件的大小和位置时是否要考虑组件的可见性。
protected void | DefaultDesktopManager.setWasIcon(JInternalFrame f, Boolean value) 设定组件已被图标化并且 desktopIcon 的边界是有效的。

javax.swing.filechooser 中 Boolean 的使用

返回 Boolean 的 javax.swing.filechooser 中的方法
Boolean | FileSystemView.isTraversable(File f) 如果可以访问文件（目录），则返回 true。
Boolean | FileView.isTraversable(File f) 目录是否是可遍历的。

javax.swing.plaf.basic 中 Boolean 的使用

类型参数类型为 Boolean 的 javax.swing.plaf.basic 中的字段
protected  Hashtable<TreePath,Boolean> BasicTreeUI.drawingCache
用于最小化垂直线的绘制。

返回 Boolean 的 javax.swing.plaf.basic 中的方法
 Boolean BasicFileChooserUI.BasicFileView.isHidden(File f)

javax.tools 中 Boolean 的使用

返回 Boolean 的 javax.tools 中的方法
 Boolean JavaCompiler.CompilationTask.call()
执行此编译任务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.StackTraceElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StackTraceElement
的使用

使用 StackTraceElement 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang 中 StackTraceElement 的使用

返回 StackTraceElement 的 java.lang 中的方法
 StackTraceElement[] Thread.getStackTrace()
返回一个表示该线程堆栈转储的堆栈跟踪元素数组。
 StackTraceElement[] Throwable.getStackTrace()
提供编程访问由 Throwable.printStackTrace() 输出的堆栈跟踪信息。

参数类型为 StackTraceElement 的 java.lang 中的方法
 void Throwable.setStackTrace(StackTraceElement[] stackTrace)
设置将由 Throwable.getStackTrace() 返回，并由 Throwable.printStackTrace() 和相关方法输出的堆栈跟踪元素。

java.lang.management 中 StackTraceElement 的使用

返回 StackTraceElement 的 java.lang.management 中的方法
StackTraceElement | MonitorInfo.getLockedStackFrame() 返回锁定对象监视器的堆栈帧。
StackTraceElement[] | ThreadInfo.getStackTrace() 返回与此 ThreadInfo 关联的线程的堆栈跟踪。

参数类型为 StackTraceElement 的 java.lang.management 中的构造方法
MonitorInfo(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)
构造一个 MonitorInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.StringBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StringBuffer
的使用

使用 StringBuffer 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

java.io 中 StringBuffer 的使用

返回 StringBuffer 的 java.io 中的方法
 StringBuffer StringWriter.getBuffer()
返回该字符串缓冲区本身。

java.lang 中 StringBuffer 的使用

返回 StringBuffer 的 java.lang 中的方法
StringBuffer | StringBuffer.append(boolean b)
StringBuffer | StringBuffer.append(char c)
StringBuffer | StringBuffer.append(char[] str)
StringBuffer | StringBuffer.append(char[] str, int offset, int len)
StringBuffer | StringBuffer.append(CharSequence s) 将指定的 CharSequence 添加到该序列。
StringBuffer | StringBuffer.append(CharSequence s, int start, int end)
StringBuffer | StringBuffer.append(double d)
StringBuffer | StringBuffer.append(float f)
StringBuffer | StringBuffer.append(int i)
StringBuffer | StringBuffer.append(long lng)
StringBuffer | StringBuffer.append(Object obj)
StringBuffer | StringBuffer.append(String str)
StringBuffer | StringBuffer.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列中。
StringBuffer | StringBuffer.appendCodePoint(int codePoint)
StringBuffer | StringBuffer.delete(int start, int end)
StringBuffer | StringBuffer.deleteCharAt(int index)
StringBuffer | StringBuffer.insert(int offset, boolean b)
StringBuffer | StringBuffer.insert(int offset, char c)
StringBuffer | StringBuffer.insert(int offset, char[] str)
StringBuffer | StringBuffer.insert(int index, char[] str, int offset, int len)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s, int start, int end)
StringBuffer | StringBuffer.insert(int offset, double d)
StringBuffer | StringBuffer.insert(int offset, float f)
StringBuffer | StringBuffer.insert(int offset, int i)
StringBuffer | StringBuffer.insert(int offset, long l)
StringBuffer | StringBuffer.insert(int offset, Object obj)
StringBuffer | StringBuffer.insert(int offset, String str)
StringBuffer | StringBuffer.replace(int start, int end, String str)
StringBuffer | StringBuffer.reverse()

参数类型为 StringBuffer 的 java.lang 中的方法
StringBuilder | StringBuilder.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列。
StringBuffer | StringBuffer.append(StringBuffer sb) 将指定的 StringBuffer 添加到此序列中。
boolean | String.contentEquals(StringBuffer sb) 将此字符串与指定的 StringBuffer 比较。

参数类型为 StringBuffer 的 java.lang 中的构造方法
String(StringBuffer buffer)
分配一个新的字符串，它包含字符串缓冲区参数中当前包含的字符序列。

java.text 中 StringBuffer 的使用

返回 StringBuffer 的 java.text 中的方法
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | ChoiceFormat.format(double number, StringBuffer toAppendTo, FieldPosition status) 返回带已格式化 double 的模式。
StringBuffer | DecimalFormat.format(double number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 double 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(double number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | ChoiceFormat.format(long number, StringBuffer toAppendTo, FieldPosition status) 特殊格式。
StringBuffer | DecimalFormat.format(long number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 long 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(long number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
StringBuffer | DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数，并将所得文本追加到给定的字符串缓冲区。
StringBuffer | NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数并将所得文本添加到给定字符串缓冲区。
StringBuffer | DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition) 重写 Format。
StringBuffer | MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
abstract StringBuffer | Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos) 格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

参数类型为 StringBuffer 的 java.text 中的方法
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | ChoiceFormat.format(double number, StringBuffer toAppendTo, FieldPosition status) 返回带已格式化 double 的模式。
StringBuffer | DecimalFormat.format(double number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 double 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(double number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | ChoiceFormat.format(long number, StringBuffer toAppendTo, FieldPosition status) 特殊格式。
StringBuffer | DecimalFormat.format(long number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 long 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(long number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
StringBuffer | DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数，并将所得文本追加到给定的字符串缓冲区。
StringBuffer | NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数并将所得文本添加到给定字符串缓冲区。
StringBuffer | DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition) 重写 Format。
StringBuffer | MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
abstract StringBuffer | Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos) 格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

java.util.regex 中 StringBuffer 的使用

返回 StringBuffer 的 java.util.regex 中的方法
 StringBuffer Matcher.appendTail(StringBuffer sb)
实现终端添加和替换步骤。

参数类型为 StringBuffer 的 java.util.regex 中的方法
Matcher | Matcher.appendReplacement(StringBuffer sb, String replacement) 实现非终端添加和替换步骤。
StringBuffer | Matcher.appendTail(StringBuffer sb) 实现终端添加和替换步骤。

javax.swing.text.html.parser 中 StringBuffer 的使用

参数类型为 StringBuffer 的 javax.swing.text.html.parser 中的方法
protected  boolean Parser.parseMarkupDeclarations(StringBuffer strBuff)
解析标记声明。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.Appendable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Appendable
的使用

使用 Appendable 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.io 中 Appendable 的使用

实现 Appendable 的 java.io 中的类
class | BufferedWriter 将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。
class | CharArrayWriter 此类实现一个可用作 Writer 的字符缓冲区。
class | FileWriter 用来写入字符文件的便捷类。
class | FilterWriter 用于写入已过滤的字符流的抽象类。
class | OutputStreamWriter OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。
class | PipedWriter 传送的字符输出流。
class | PrintStream PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。
class | PrintWriter 向文本输出流打印对象的格式化表示形式。
class | StringWriter 一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。
class | Writer 写入字符流的抽象类。

java.lang 中 Appendable 的使用

实现 Appendable 的 java.lang 中的类
class | StringBuffer 线程安全的可变字符序列。
class | StringBuilder 一个可变的字符序列。

返回 Appendable 的 java.lang 中的方法
Appendable | Appendable.append(char c) 向此 Appendable 添加指定字符。
Appendable | Appendable.append(CharSequence csq) 向此 Appendable 添加指定的字符序列。
Appendable | Appendable.append(CharSequence csq, int start, int end) 向此 Appendable 添加指定字符序列的子序列。

java.nio 中 Appendable 的使用

实现 Appendable 的 java.nio 中的类
 class CharBuffer
字符缓冲区。

java.rmi.server 中 Appendable 的使用

实现 Appendable 的 java.rmi.server 中的类
 class LogStream
已过时。 无替代版本

java.util 中 Appendable 的使用

返回 Appendable 的 java.util 中的方法
 Appendable Formatter.out()
返回输出的目标文件。

参数类型为 Appendable 的 java.util 中的构造方法
Formatter(Appendable a)
构造一个带指定目标文件的新 formatter。
Formatter(Appendable a, Locale l)
构造一个带指定目标文件和语言环境的新 formatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.Iterable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Iterable
的使用

使用 Iterable 的软件包
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.beans.beancontext 中 Iterable 的使用

java.beans.beancontext 中 Iterable 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 Iterable 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

java.sql 中 Iterable 的使用

实现 Iterable 的 java.sql 中的类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

java.util 中 Iterable 的使用

java.util 中 Iterable 的子接口
interface | Collection<E> Collection 层次结构 中的根接口。
interface | Deque<E> 一个线性 collection，支持在两端插入和移除元素。
interface | List<E> 有序的 collection（也称为序列）。
interface | NavigableSet<E> 扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
interface | Queue<E> 在处理元素前用于保存元素的 collection。
interface | Set<E> 一个不包含重复元素的 collection。
interface | SortedSet<E> 进一步提供关于元素的总体排序 的 Set。

实现 Iterable 的 java.util 中的类
class | AbstractCollection<E> 此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | ServiceLoader<S> 一个简单的服务提供者加载设施。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 Iterable 的使用

java.util.concurrent 中 Iterable 的子接口
interface | BlockingDeque<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
interface | BlockingQueue<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。

实现 Iterable 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

javax.annotation.processing 中 Iterable 的使用

返回 Iterable 的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。

javax.lang.model.util 中 Iterable 的使用

参数类型为 Iterable 的 javax.lang.model.util 中的方法
static List<ExecutableElement> ElementFilter.constructorsIn(Iterable<? extends Element> elements)
elements 中构造方法的列表。
static List<VariableElement> ElementFilter.fieldsIn(Iterable<? extends Element> elements)
返回 elements 中字段的列表。
static List<ExecutableElement> ElementFilter.methodsIn(Iterable<? extends Element> elements)
返回 elements 中方法的列表。
static List<PackageElement> ElementFilter.packagesIn(Iterable<? extends Element> elements)
返回 elements 中包的列表。
 R ElementScanner6.scan(Iterable<? extends Element> iterable, P p)
迭代给定元素并对每个元素调用 scan(Element, P)。
static List<TypeElement> ElementFilter.typesIn(Iterable<? extends Element> elements)
返回 elements 中类型的列表。

javax.management 中 Iterable 的使用

实现 Iterable 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 Iterable 的使用

实现 Iterable 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.print.attribute.standard 中 Iterable 的使用

实现 Iterable 的 javax.print.attribute.standard 中的类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

javax.sql.rowset 中 Iterable 的使用

实现 Iterable 的 javax.sql.rowset 中的类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Iterable 的使用

实现 Iterable 的 javax.sql.rowset.serial 中的类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

javax.sql.rowset.spi 中 Iterable 的使用

实现 Iterable 的 javax.sql.rowset.spi 中的类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Iterable 的使用

参数类型为 Iterable 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
RowFilter.orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。

javax.tools 中 Iterable 的使用

返回 Iterable 的 javax.tools 中的方法
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(File... files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjects(String... names) 获取表示给定文件名称的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names) 获取表示给定文件名称的文件对象。
Iterable<? extends File> | StandardJavaFileManager.getLocation(JavaFileManager.Location location) 获取与给定位置关联的路径。
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

参数类型为 Iterable 的 javax.tools 中的方法
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromFiles(Iterable<? extends File> files) 获取表示给定文件的文件对象。
Iterable<? extends JavaFileObject> | StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names) 获取表示给定文件名称的文件对象。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
JavaCompiler.CompilationTask | JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits) 使用给定组件和参数创建编译任务的 future。
void | StandardJavaFileManager.setLocation(JavaFileManager.Location location, Iterable<? extends File> path) 将给定路径与给定位置关联。
void | JavaCompiler.CompilationTask.setProcessors(Iterable<? extends Processor> processors) 设置处理器（用于注释处理）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ThreadGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ThreadGroup
的使用

使用 ThreadGroup 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 ThreadGroup 的使用

返回 ThreadGroup 的 java.lang 中的方法
ThreadGroup | ThreadGroup.getParent() 返回此线程组的父线程组。
ThreadGroup | SecurityManager.getThreadGroup() 调用此方法时，返回所有新创建的线程实例化后所在的线程组。
ThreadGroup | Thread.getThreadGroup() 返回该线程所属的线程组。

参数类型为 ThreadGroup 的 java.lang 中的方法
void | SecurityManager.checkAccess(ThreadGroup g) 如果不允许调用线程修改线程组参数，则抛出 SecurityException。
int | ThreadGroup.enumerate(ThreadGroup[] list) 把对此线程组中的所有活动子组的引用复制到指定数组中。
int | ThreadGroup.enumerate(ThreadGroup[] list, boolean recurse) 把对此线程组中的所有活动子组的引用复制到指定数组中。
boolean | ThreadGroup.parentOf(ThreadGroup g) 测试此线程组是否为线程组参数或其祖先线程组之一。

参数类型为 ThreadGroup 的 java.lang 中的构造方法
Thread(ThreadGroup group, Runnable target)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target, String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。
Thread(ThreadGroup group, Runnable target, String name, long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。
Thread(ThreadGroup group, String name)
分配新的 Thread 对象。
ThreadGroup(ThreadGroup parent, String name)
创建一个新线程组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Thread 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Thread
的使用

使用 Thread 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.lang 中 Thread 的使用

返回 Thread 的 java.lang 中的方法
static Thread Thread.currentThread()
返回对当前正在执行的线程对象的引用。

返回变量类型为 Thread 的类型的 java.lang 中的方法
static Map<Thread,StackTraceElement[]> Thread.getAllStackTraces()
返回所有活动线程的堆栈跟踪的一个映射。

参数类型为 Thread 的 java.lang 中的方法
void | Runtime.addShutdownHook(Thread hook) 注册新的虚拟机来关闭钩子。
void | SecurityManager.checkAccess(Thread t) 如果不允许调用线程修改 thread 参数，则抛出 SecurityException。
int | ThreadGroup.enumerate(Thread[] list) 把此线程组及其子组中的所有活动线程复制到指定数组中。
static int | Thread.enumerate(Thread[] tarray) 将当前线程的线程组及其子组中的每一个活动线程复制到指定的数组中。
int | ThreadGroup.enumerate(Thread[] list, boolean recurse) 把此线程组中的所有活动线程复制到指定数组中。
boolean | Runtime.removeShutdownHook(Thread hook) 取消注册某个先前已注册的虚拟机关闭钩子。
void | ThreadGroup.uncaughtException(Thread t, Throwable e) 当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。
void | Thread.UncaughtExceptionHandler.uncaughtException(Thread t, Throwable e) 当给定线程因给定的未捕获异常而终止时，调用该方法。

java.util.concurrent 中 Thread 的使用

返回 Thread 的 java.util.concurrent 中的方法
 Thread ThreadFactory.newThread(Runnable r)
构造一个新 Thread。

返回变量类型为 Thread 的类型的 java.util.concurrent 中的方法
protected  Collection<Thread> Semaphore.getQueuedThreads()
返回一个 collection，包含可能等待获取的线程。

参数类型为 Thread 的 java.util.concurrent 中的方法
protected void | ThreadPoolExecutor.beforeExecute(Thread t, Runnable r) 在执行给定线程中的给定 Runnable 之前调用的方法。
void | TimeUnit.timedJoin(Thread thread, long timeout) 使用此时间单元执行计时的 Thread.join。

java.util.concurrent.locks 中 Thread 的使用

返回 Thread 的 java.util.concurrent.locks 中的方法
protected Thread | AbstractOwnableSynchronizer.getExclusiveOwnerThread() 返回由 setExclusiveOwnerThread 最后设置的线程；如果从未设置，则返回 null。
Thread | AbstractQueuedLongSynchronizer.getFirstQueuedThread() 返回队列中第一个（等待时间最长的）线程；如果当前没有将任何线程加入队列，则返回 null。
Thread | AbstractQueuedSynchronizer.getFirstQueuedThread() 返回队列中第一个（等待时间最长的）线程，如果目前没有将任何线程加入队列，则返回 null. 在此实现中，该操作是以固定时间返回的，但是，如果其他线程目前正在并发修改该队列，则可能出现循环争用。
protected Thread | ReentrantReadWriteLock.getOwner() 返回当前拥有写入锁的线程，如果没有这样的线程，则返回 null。
protected Thread | ReentrantLock.getOwner() 返回目前拥有此锁的线程，如果此锁不被任何线程拥有，则返回 null。

返回变量类型为 Thread 的类型的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedLongSynchronizer.getExclusiveQueuedThreads() 返回一个 collection，该 collection 包含正以独占模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getExclusiveQueuedThreads() 返回包含可能正以独占模式等待获取的线程 collection。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedReaderThreads() 返回一个 collection，它包含可能正在等待获取读取锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getQueuedThreads() 返回一个 collection，该 collection 包含正在等待获取的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedThreads() 返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getQueuedThreads() 返回包含可能正在等待获取的线程 collection。
protected Collection<Thread> | ReentrantLock.getQueuedThreads() 返回一个 collection，它包含可能正等待获取此锁的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedWriterThreads() 返回一个 collection，它包含可能正在等待获取写入锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getSharedQueuedThreads() 返回一个 collection，该 collection 包含正以共享模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getSharedQueuedThreads() 返回包含可能正以共享模式等待获取的线程 collection。
protected Collection<Thread> | AbstractQueuedLongSynchronizer.ConditionObject.getWaitingThreads() 返回一个 collection，该 collection 包含那些正在此条件等待的线程。
protected Collection<Thread> | AbstractQueuedSynchronizer.ConditionObject.getWaitingThreads() 返回包含那些可能正在等待此条件的线程 collection。
Collection<Thread> | AbstractQueuedLongSynchronizer.getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition) 返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
protected Collection<Thread> | ReentrantReadWriteLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
protected Collection<Thread> | ReentrantLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。

参数类型为 Thread 的 java.util.concurrent.locks 中的方法
static Object | LockSupport.getBlocker(Thread t) 返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。
boolean | ReentrantReadWriteLock.hasQueuedThread(Thread thread) 查询是否给定线程正在等待获取读取或写入锁。
boolean | ReentrantLock.hasQueuedThread(Thread thread) 查询给定线程是否正在等待获取此锁。
boolean | AbstractQueuedLongSynchronizer.isQueued(Thread thread) 如果给定线程当前已加入队列，则返回 true。
boolean | AbstractQueuedSynchronizer.isQueued(Thread thread) 如果给定线程的当前已加入队列，则返回 true。
protected void | AbstractOwnableSynchronizer.setExclusiveOwnerThread(Thread t) 设置当前拥有独占访问的线程。
static void | LockSupport.unpark(Thread thread) 如果给定线程的许可尚不可用，则使其可用。

javax.swing.text 中 Thread 的使用

返回 Thread 的 javax.swing.text 中的方法
protected  Thread AbstractDocument.getCurrentWriter()
获取当前的写入线程（如果有的话）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Thread.State 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Thread.State
的使用

使用 Thread.State 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang 中 Thread.State 的使用

返回 Thread.State 的 java.lang 中的方法
Thread.State | Thread.getState() 返回该线程的状态。
static Thread.State | Thread.State.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Thread.State[] | Thread.State.values() Returns an array containing the constants of this enum type, in the order they are declared.

java.lang.management 中 Thread.State 的使用

返回 Thread.State 的 java.lang.management 中的方法
 Thread.State ThreadInfo.getThreadState()
返回与此 ThreadInfo 关联的线程的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.Thread.UncaughtExceptionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Thread.UncaughtExceptionHandler
的使用

使用 Thread.UncaughtExceptionHandler 的软件包
java.lang 提供利用 Java 编程语言进行程序设计的基础类。

java.lang 中 Thread.UncaughtExceptionHandler 的使用

实现 Thread.UncaughtExceptionHandler 的 java.lang 中的类
 class ThreadGroup
线程组表示一个线程的集合。

返回 Thread.UncaughtExceptionHandler 的 java.lang 中的方法
static Thread.UncaughtExceptionHandler | Thread.getDefaultUncaughtExceptionHandler() 返回线程由于未捕获到异常而突然终止时调用的默认处理程序。
Thread.UncaughtExceptionHandler | Thread.getUncaughtExceptionHandler() 返回该线程由于未捕获到异常而突然终止时调用的处理程序。

参数类型为 Thread.UncaughtExceptionHandler 的 java.lang 中的方法
static void | Thread.setDefaultUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh) 设置当线程由于未捕获到异常而突然终止，并且没有为该线程定义其他处理程序时所调用的默认处理程序。
void | Thread.setUncaughtExceptionHandler(Thread.UncaughtExceptionHandler eh) 设置该线程由于未捕获到异常而突然终止时调用的处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.Runnable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Runnable
的使用

使用 Runnable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 Runnable 的使用

参数类型为 Runnable 的 java.awt 中的方法
static void | EventQueue.invokeAndWait(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。
static void | EventQueue.invokeLater(Runnable runnable) 导致 runnable 的 run 方法在 the system EventQueue 的指派线程中被调用。

java.awt.event 中 Runnable 的使用

声明为 Runnable 的 java.awt.event 中的字段
protected  Runnable InvocationEvent.runnable
调用其 run() 方法的 Runnable。

参数类型为 Runnable 的 java.awt.event 中的构造方法
InvocationEvent(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object source, Runnable runnable)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。
InvocationEvent(Object source, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。

java.awt.image.renderable 中 Runnable 的使用

实现 Runnable 的 java.awt.image.renderable 中的类
 class RenderableImageProducer
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。

java.lang 中 Runnable 的使用

实现 Runnable 的 java.lang 中的类
 class Thread
线程 是程序中的执行线程。

参数类型为 Runnable 的 java.lang 中的构造方法
Thread(Runnable target)
分配新的 Thread 对象。
Thread(Runnable target, String name)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target)
分配新的 Thread 对象。
Thread(ThreadGroup group, Runnable target, String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。
Thread(ThreadGroup group, Runnable target, String name, long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。

java.util 中 Runnable 的使用

实现 Runnable 的 java.util 中的类
 class TimerTask
由 Timer 安排为一次执行或重复执行的任务。

java.util.concurrent 中 Runnable 的使用

java.util.concurrent 中 Runnable 的子接口
interface | RunnableFuture<V> 作为 Runnable 的 Future。
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。

实现 Runnable 的 java.util.concurrent 中的类
 class FutureTask<V>
可取消的异步计算。

返回变量类型为 Runnable 的类型的 java.util.concurrent 中的方法
BlockingQueue<Runnable> | ScheduledThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。
BlockingQueue<Runnable> | ThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。
List<Runnable> | ExecutorService.shutdownNow() 试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。
List<Runnable> | ScheduledThreadPoolExecutor.shutdownNow() 尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。
List<Runnable> | ThreadPoolExecutor.shutdownNow() 尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。

参数类型为 Runnable 的 java.util.concurrent 中的方法
protected  void ThreadPoolExecutor.afterExecute(Runnable r, Throwable t)
基于完成执行给定 Runnable 所调用的方法。
protected  void ThreadPoolExecutor.beforeExecute(Thread t, Runnable r)
在执行给定线程中的给定 Runnable 之前调用的方法。
static Callable<Object> Executors.callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。
static
<T> Callable<T>
Executors.callable(Runnable task, T result)
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Runnable runnable, RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。
 void Executor.execute(Runnable command)
在未来某个时间执行给定的命令。
 void ScheduledThreadPoolExecutor.execute(Runnable command)
使用所要求的零延迟执行命令。
 void ThreadPoolExecutor.execute(Runnable command)
在将来某个时间执行给定任务。
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Runnable runnable, T value)
为给定可运行任务和默认值返回一个 RunnableFuture。
 Thread ThreadFactory.newThread(Runnable r)
构造一个新 Thread。
 void RejectedExecutionHandler.rejectedExecution(Runnable r, ThreadPoolExecutor executor)
当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。
 void ThreadPoolExecutor.CallerRunsPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。
 void ThreadPoolExecutor.AbortPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
总是抛出 RejectedExecutionException。
 void ThreadPoolExecutor.DiscardPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
不执行任何操作，在这种情况下将放弃任务 r。
 void ThreadPoolExecutor.DiscardOldestPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e)
获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。
 boolean ScheduledThreadPoolExecutor.remove(Runnable task)
 boolean ThreadPoolExecutor.remove(Runnable task)
从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。
 ScheduledFuture<?> ScheduledExecutorService.schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.schedule(Runnable command, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
 Future<?> AbstractExecutorService.submit(Runnable task)
 Future<?> ExecutorService.submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
 Future<?> ScheduledThreadPoolExecutor.submit(Runnable task)
<T> Future<T>
AbstractExecutorService.submit(Runnable task, T result)
<T> Future<T>
ExecutorService.submit(Runnable task, T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Runnable task, T result)
 Future<V> CompletionService.submit(Runnable task, V result)
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
 Future<V> ExecutorCompletionService.submit(Runnable task, V result)

参数类型为 Runnable 的 java.util.concurrent 中的构造方法
CyclicBarrier(int parties, Runnable barrierAction)
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，并在启动 barrier 时执行给定的屏障操作，该操作由最后一个进入 barrier 的线程执行。
FutureTask(Runnable runnable, V result)
创建一个 FutureTask，一旦运行就执行给定的 Runnable，并安排成功完成时 get 返回给定的结果 。

类型变量类型为 Runnable 的 java.util.concurrent 中的构造方法参数
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

javax.net.ssl 中 Runnable 的使用

返回 Runnable 的 javax.net.ssl 中的方法
abstract  Runnable SSLEngine.getDelegatedTask()
返回此 SSLEngine 的一个委托 Runnable 任务。

javax.swing 中 Runnable 的使用

实现 Runnable 的 javax.swing 中的类
 class SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

参数类型为 Runnable 的 javax.swing 中的方法
static void SwingUtilities.invokeAndWait(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上同步执行。
static void SwingUtilities.invokeLater(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上异步执行。

javax.swing.text 中 Runnable 的使用

实现 Runnable 的 javax.swing.text 中的类
 class AsyncBoxView.ChildState
表示子视图布局状态的记录。

返回 Runnable 的 javax.swing.text 中的方法
protected  Runnable LayoutQueue.waitForWork()
由 worker 线程使用以获取一个要执行的新任务

参数类型为 Runnable 的 javax.swing.text 中的方法
void | LayoutQueue.addTask(Runnable task) 添加一个任务，该任务不必立即执行，原因是其结果可能是不可见的。
void | AbstractDocument.render(Runnable r) 如果模型支持被异步更新，则此方法允许在并发情况下安全地呈现该模型。
void | Document.render(Runnable r) 如果模型支持异步更新，则允许在并发情况下安全呈现模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.IllegalMonitorStateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.IllegalMonitorStateException
的使用

没有 java.lang.IllegalMonitorStateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.StackOverflowError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.StackOverflowError
的使用

没有 java.lang.StackOverflowError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.OutOfMemoryError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.OutOfMemoryError
的使用

没有 java.lang.OutOfMemoryError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.VirtualMachineError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.VirtualMachineError
的使用

使用 VirtualMachineError 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.lang 中 VirtualMachineError 的使用

java.lang 中 VirtualMachineError 的子类
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。

java.util.zip 中 VirtualMachineError 的使用

java.util.zip 中 VirtualMachineError 的子类
 class ZipError
发生不可恢复的错误时抛出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ArrayStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ArrayStoreException
的使用

没有 java.lang.ArrayStoreException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ClassCastException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassCastException
的使用

使用 ClassCastException 的软件包
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

javax.rmi 中 ClassCastException 的使用

抛出 ClassCastException 的 javax.rmi 中的方法
static Object PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

javax.rmi.CORBA 中 ClassCastException 的使用

抛出 ClassCastException 的 javax.rmi.CORBA 中的方法
 Object PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。

org.w3c.dom.bootstrap 中 ClassCastException 的使用

抛出 ClassCastException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 ClassCastException 的使用

抛出 ClassCastException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Error 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Error
的使用

使用 Error 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

java.awt 中 Error 的使用

java.awt 中 Error 的子类
 class AWTError
当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。

java.io 中 Error 的使用

java.io 中 Error 的子类
 class IOError
当发生严重的 I/O 错误时，抛出此错误。

java.lang 中 Error 的使用

java.lang 中 Error 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | AssertionError 抛出该异常指示某个断言失败。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | LinkageError LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | ThreadDeath 调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
class | VirtualMachineError 当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

java.lang.annotation 中 Error 的使用

java.lang.annotation 中 Error 的子类
 class AnnotationFormatError
当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。

java.lang.reflect 中 Error 的使用

java.lang.reflect 中 Error 的子类
 class GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

java.nio.charset 中 Error 的使用

java.nio.charset 中 Error 的子类
 class CoderMalfunctionError
当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。

java.rmi 中 Error 的使用

参数类型为 Error 的 java.rmi 中的构造方法
ServerError(String s, Error err)
构造带指定详细消息和嵌入错误的 ServerError。

java.util 中 Error 的使用

java.util 中 Error 的子类
 class ServiceConfigurationError
在加载服务提供者的过程中出错时抛出的错误。

java.util.zip 中 Error 的使用

java.util.zip 中 Error 的子类
 class ZipError
发生不可恢复的错误时抛出。

javax.management 中 Error 的使用

返回 Error 的 javax.management 中的方法
 Error RuntimeErrorException.getTargetError()
返回抛出的实际 Error。

参数类型为 Error 的 javax.management 中的构造方法
RuntimeErrorException(Error e)
默认的构造方法。
RuntimeErrorException(Error e, String message)
允许指定特定错误消息的构造方法。

javax.management.remote 中 Error 的使用

参数类型为 Error 的 javax.management.remote 中的构造方法
JMXServerErrorException(String s, Error err)
构造带指定详细消息和嵌套错误的 JMXServerErrorException。

javax.xml.parsers 中 Error 的使用

javax.xml.parsers 中 Error 的子类
 class FactoryConfigurationError
当解析器工厂的配置存在问题时抛出该异常。

javax.xml.transform 中 Error 的使用

javax.xml.transform 中 Error 的子类
 class TransformerFactoryConfigurationError
当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.NoClassDefFoundError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.NoClassDefFoundError
的使用

没有 java.lang.NoClassDefFoundError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.LinkageError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.LinkageError
的使用

使用 LinkageError 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。

java.lang 中 LinkageError 的使用

java.lang 中 LinkageError 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。

java.lang.reflect 中 LinkageError 的使用

java.lang.reflect 中 LinkageError 的子类
 class GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ClassNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassNotFoundException
的使用

使用 ClassNotFoundException 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.net | 为实现网络应用程序提供类。
java.rmi | 提供 RMI 包。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.relation | 提供 Relation Service 的定义。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
org.w3c.dom.bootstrap |
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.awt.datatransfer 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.awt.datatransfer 中的方法
static DataFlavor | SystemFlavorMap.decodeDataFlavor(String nat) 解码 String native 以用作 DataFlavor。
void | DataFlavor.readExternal(ObjectInput is) 根据 Serialized 状态还原此 DataFlavor。
protected static Class<?> | DataFlavor.tryToLoadClass(String className, ClassLoader fallback) 试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

抛出 ClassNotFoundException 的 java.awt.datatransfer 中的构造方法
DataFlavor(String mimeType)
根据 mimeType 字符串构造 DataFlavor。
DataFlavor(String mimeType, String humanPresentableName, ClassLoader classLoader)
构造一个表示 MimeType 的 DataFlavor。

java.beans 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.beans 中的方法
static Object | Beans.instantiate(ClassLoader cls, String beanName) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

java.beans.beancontext 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.beans.beancontext 中的方法
protected  void BeanContextServicesSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在反序列化子级之前，从 BeanContextSupport readObject 中调用。
protected  void BeanContextSupport.bcsPreDeserializationHook(ObjectInputStream ois)
在调用 defaultReadObject() 之后，但在反序列化任意子级之前，由 readObject 调用。
protected  void BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll)
readObject 使用此方法来反序列化一个 collection。
 Object BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。
 Object BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。
 void BeanContextSupport.readChildren(ObjectInputStream ois)
在将此类的实例用作 BeanContext 协议（及其子协议）实现的代理时，在反序列化期间存在一个“先有鸡还是先有蛋”的问题。

java.io 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.io 中的方法
void | ObjectInputStream.defaultReadObject() 从此流读取当前类的非静态和非瞬态字段。
protected ObjectStreamClass | ObjectInputStream.readClassDescriptor() 从序列化流读取类描述符。
void | Externalizable.readExternal(ObjectInput in) 对象实现 readExternal 方法来恢复其内容，它通过调用 DataInput 的方法来恢复其基础类型，调用 readObject 来恢复对象、字符串和数组。
ObjectInputStream.GetField | ObjectInputStream.readFields() 按名称从流中读取持久字段并使其可用。
Object | ObjectInputStream.readObject() 从 ObjectInputStream 读取对象。
Object | ObjectInput.readObject() 读取并返回对象。
protected Object | ObjectInputStream.readObjectOverride() 此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。
Object | ObjectInputStream.readUnshared() 从 ObjectInputStream 读取“非共享”对象。
protected Class<?> | ObjectInputStream.resolveClass(ObjectStreamClass desc) 加载指定流类描述的本地等价类。
protected Class<?> | ObjectInputStream.resolveProxyClass(String[] interfaces) 返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。

java.lang 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.lang 中的方法
protected Class<?> | ClassLoader.findClass(String name) 使用指定的二进制名称查找类。
protected Class<?> | ClassLoader.findSystemClass(String name) 查找具有指定的二进制名称的类，必要时加载它。
static Class<?> | Class.forName(String className) 返回与带有给定字符串名的类或接口相关联的 Class 对象。
static Class<?> | Class.forName(String name, boolean initialize, ClassLoader loader) 使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
Class<?> | ClassLoader.loadClass(String name) 使用指定的二进制名称来加载类。
protected Class<?> | ClassLoader.loadClass(String name, boolean resolve) 使用指定的二进制名称来加载类。

java.lang.instrument 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.lang.instrument 中的方法
 void Instrumentation.redefineClasses(ClassDefinition... definitions)
使用提供的类文件重定义提供的类集。

java.net 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.net 中的方法
protected  Class<?> URLClassLoader.findClass(String name)
通过 URL 搜索路径查找并加载具有指定名称的类。

java.rmi 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.rmi 中的方法
 T MarshalledObject.get()
返回所包含的 marshalledobject 的新副本。

java.rmi.server 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.rmi.server 中的方法
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
static Class<?> RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

java.security 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 java.security 中的方法
 Object SignedObject.getObject()
获取已封装的对象。

javax.activation 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.activation 中的方法
Object | CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader) 返回已实例化的 JavaBean 组件。
void | MimeType.readExternal(ObjectInput in) 对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。

javax.crypto 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.crypto 中的方法
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。

javax.management 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.management 中的方法
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

javax.management.loading 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.management.loading 中的方法
protected Class<?> | MLet.findClass(String name) 这是要重新定义的类加载器的主要方法。
Class<?> | ClassLoaderRepository.loadClass(String className) 通过类加载器列表加载给定的类名称。
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
Class<?> | MLet.loadClass(String name, ClassLoaderRepository clr) 如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。
Class<?> | ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className) 通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
Class<?> | ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className) 通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。
void | MLet.readExternal(ObjectInput in) 从给定的 ObjectInput 恢复此 MLet 的内容。

javax.management.relation 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.management.relation 中的构造方法
RoleInfo(String roleName, String mbeanClassName)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

javax.rmi.CORBA 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.rmi.CORBA 中的方法
static Class Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。
 Class UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。

javax.swing 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.swing 中的方法
static void UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

javax.swing.text 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 javax.swing.text 中的方法
void | StyleContext.readAttributes(ObjectInputStream in, MutableAttributeSet a) 读入属性的特定于上下文的处理。
static void | StyleContext.readAttributeSet(ObjectInputStream in, MutableAttributeSet a) 从以前通过 writeAttributeSet 写出的给定对象输入流中读取一个属性集。

org.w3c.dom.bootstrap 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 org.w3c.dom.bootstrap 中的方法
static DOMImplementationRegistry DOMImplementationRegistry.newInstance()
获得 DOMImplementationRegistry 的新实例。

org.xml.sax.helpers 中 ClassNotFoundException 的使用

抛出 ClassNotFoundException 的 org.xml.sax.helpers 中的方法
static Parser | ParserFactory.makeParser() 已过时。 使用 "org.xml.sax.parser" 系统属性创建一个新的 SAX 解析器。
static Parser | ParserFactory.makeParser(String className) 已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.RuntimeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.RuntimeException
的使用

使用 RuntimeException 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |

java.awt 中 RuntimeException 的使用

java.awt 中 RuntimeException 的子类
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

java.awt.color 中 RuntimeException 的使用

java.awt.color 中 RuntimeException 的子类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.dnd 中 RuntimeException 的使用

java.awt.dnd 中 RuntimeException 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.awt.geom 中 RuntimeException 的使用

java.awt.geom 中 RuntimeException 的子类
 class IllegalPathStateException
对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。

java.awt.image 中 RuntimeException 的使用

java.awt.image 中 RuntimeException 的子类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.lang 中 RuntimeException 的使用

java.lang 中 RuntimeException 的子类
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。

java.lang.annotation 中 RuntimeException 的使用

java.lang.annotation 中 RuntimeException 的子类
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

java.lang.reflect 中 RuntimeException 的使用

java.lang.reflect 中 RuntimeException 的子类
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

java.nio 中 RuntimeException 的使用

java.nio 中 RuntimeException 的子类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 RuntimeException 的使用

java.nio.channels 中 RuntimeException 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 RuntimeException 的使用

java.nio.charset 中 RuntimeException 的子类
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.rmi 中 RuntimeException 的使用

java.rmi 中 RuntimeException 的子类
 class RMISecurityException
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。

java.security 中 RuntimeException 的使用

java.security 中 RuntimeException 的子类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。

java.util 中 RuntimeException 的使用

java.util 中 RuntimeException 的子类
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

java.util.concurrent 中 RuntimeException 的使用

java.util.concurrent 中 RuntimeException 的子类
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。

java.util.regex 中 RuntimeException 的使用

java.util.regex 中 RuntimeException 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

javax.lang.model.element 中 RuntimeException 的使用

javax.lang.model.element 中 RuntimeException 的子类
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 RuntimeException 的使用

javax.lang.model.type 中 RuntimeException 的子类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 RuntimeException 的使用

javax.management 中 RuntimeException 的子类
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。

返回 RuntimeException 的 javax.management 中的方法
RuntimeException | RuntimeMBeanException.getTargetException() 返回抛出的实际 RuntimeException。
RuntimeException | RuntimeOperationsException.getTargetException() 返回抛出的实际 RuntimeException。

参数类型为 RuntimeException 的 javax.management 中的构造方法
RuntimeMBeanException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeMBeanException(RuntimeException e, String message)
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeOperationsException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeOperationsException。
RuntimeOperationsException(RuntimeException e, String message)
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。

javax.management.monitor 中 RuntimeException 的使用

javax.management.monitor 中 RuntimeException 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

javax.management.openmbean 中 RuntimeException 的使用

javax.management.openmbean 中 RuntimeException 的子类
class | InvalidKeyException 当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。

javax.print.attribute 中 RuntimeException 的使用

javax.print.attribute 中 RuntimeException 的子类
 class UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

javax.swing.undo 中 RuntimeException 的使用

javax.swing.undo 中 RuntimeException 的子类
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。

javax.xml.bind 中 RuntimeException 的使用

javax.xml.bind 中 RuntimeException 的子类
 class TypeConstraintException
此异常指示已检测到存在违反动态检查的类型约束的情况。

javax.xml.crypto 中 RuntimeException 的使用

javax.xml.crypto 中 RuntimeException 的子类
 class NoSuchMechanismException
当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。

javax.xml.ws 中 RuntimeException 的使用

javax.xml.ws 中 RuntimeException 的子类
class | ProtocolException ProtocolException 类是与特定协议绑定有关的异常的基类。
class | WebServiceException WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

javax.xml.ws.http 中 RuntimeException 的使用

javax.xml.ws.http 中 RuntimeException 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 RuntimeException 的使用

javax.xml.ws.soap 中 RuntimeException 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

org.omg.CORBA 中 RuntimeException 的使用

org.omg.CORBA 中 RuntimeException 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。

org.omg.CORBA.portable 中 RuntimeException 的使用

org.omg.CORBA.portable 中 RuntimeException 的子类
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

org.w3c.dom 中 RuntimeException 的使用

org.w3c.dom 中 RuntimeException 的子类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 RuntimeException 的使用

org.w3c.dom.events 中 RuntimeException 的子类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 RuntimeException 的使用

org.w3c.dom.ls 中 RuntimeException 的子类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Exception 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Exception
的使用

使用 Exception 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.annotation.adapters | XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.awt 中 Exception 的使用

java.awt 中 Exception 的子类
class | AWTException 表示发生了 Absract Window Toolkit 异常。
class | FontFormatException 此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

java.awt.color 中 Exception 的使用

java.awt.color 中 Exception 的子类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.datatransfer 中 Exception 的使用

java.awt.datatransfer 中 Exception 的子类
class | MimeTypeParseException 对分析相关异常的 MimeType 进行封装的类
class | UnsupportedFlavorException 在此 flavor 中不支持所请求的数据的信号。

java.awt.dnd 中 Exception 的使用

java.awt.dnd 中 Exception 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.awt.event 中 Exception 的使用

返回 Exception 的 java.awt.event 中的方法
 Exception InvocationEvent.getException()
返回在执行 Runnable 的 run() 方法时捕获的任何 Exception。

java.awt.geom 中 Exception 的使用

java.awt.geom 中 Exception 的子类
class | IllegalPathStateException 对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
class | NoninvertibleTransformException NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

java.awt.im.spi 中 Exception 的使用

抛出 Exception 的 java.awt.im.spi 中的方法
 InputMethod InputMethodDescriptor.createInputMethod()
创建相应输入方法的新实例。

java.awt.image 中 Exception 的使用

java.awt.image 中 Exception 的子类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.awt.print 中 Exception 的使用

java.awt.print 中 Exception 的子类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterException PrinterException 类及其子类用于指示打印系统中发生的异常情况。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

java.beans 中 Exception 的使用

java.beans 中 Exception 的子类
class | IntrospectionException 在 Introspection 期间发生异常时抛出异常。
class | PropertyVetoException 当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

参数类型为 Exception 的 java.beans 中的方法
 void ExceptionListener.exceptionThrown(Exception e)
此方法在捕获可恢复的异常时调用。

抛出 Exception 的 java.beans 中的方法
void | Statement.execute() 执行方法找到一个与 methodName 属性同名的方法，并在目标上调用该方法。
Object | Expression.getValue() 如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。

java.io 中 Exception 的使用

java.io 中 Exception 的子类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | IOException 当发生某种 I/O 异常时，抛出此异常。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

声明为 Exception 的 java.io 中的字段
 Exception WriteAbortedException.detail
在写入 ObjectStream 时捕获的异常。

参数类型为 Exception 的 java.io 中的构造方法
WriteAbortedException(String s, Exception ex)
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。

java.lang 中 Exception 的使用

java.lang 中 Exception 的子类
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | ClassNotFoundException 当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
class | CloneNotSupportedException 当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | IllegalAccessException 当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | InstantiationException 当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
class | InterruptedException 当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NoSuchFieldException 类不包含指定名称的字段时产生的信号。
class | NoSuchMethodException 无法找到某一特定方法时，抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | RuntimeException RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。

java.lang.annotation 中 Exception 的使用

java.lang.annotation 中 Exception 的子类
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

java.lang.instrument 中 Exception 的使用

java.lang.instrument 中 Exception 的子类
class | IllegalClassFormatException 当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
class | UnmodifiableClassException 在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

java.lang.reflect 中 Exception 的使用

java.lang.reflect 中 Exception 的子类
class | InvocationTargetException InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

java.net 中 Exception 的使用

java.net 中 Exception 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。
class | URISyntaxException 抛出经过检查的指示字符串不能解析为 URI 引用的异常。

java.nio 中 Exception 的使用

java.nio 中 Exception 的子类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 Exception 的使用

java.nio.channels 中 Exception 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 Exception 的使用

java.nio.charset 中 Exception 的子类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

参数类型为 Exception 的 java.nio.charset 中的构造方法
CoderMalfunctionError(Exception cause)
初始化此类的一个实例。

java.rmi 中 Exception 的使用

java.rmi 中 Exception 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | AlreadyBoundException 如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | NotBoundException 如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

参数类型为 Exception 的 java.rmi 中的构造方法
AccessException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 AccessException。
ConnectException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectException。
ConnectIOException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectIOException。
MarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 MarshalException。
ServerException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 ServerException。
ServerRuntimeException(String s, Exception ex)
已过时。 无替换版本
StubNotFoundException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 StubNotFoundException。
UnexpectedException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 UnexpectedException。
UnknownHostException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnknownHostException。
UnmarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnmarshalException。

java.rmi.activation 中 Exception 的使用

java.rmi.activation 中 Exception 的子类
class | ActivateFailedException 在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
class | ActivationException 激活接口所使用的一般异常。
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

参数类型为 Exception 的 java.rmi.activation 中的构造方法
ActivateFailedException(String s, Exception ex)
构造带指定详细消息和嵌套异常的 ActivateFailedException。

java.rmi.server 中 Exception 的使用

java.rmi.server 中 Exception 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | ServerCloneException 如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
class | ServerNotActiveException 如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

声明为 Exception 的 java.rmi.server 中的字段
 Exception ServerCloneException.detail
异常原因。

参数类型为 Exception 的 java.rmi.server 中的方法
 boolean RMIFailureHandler.failure(Exception ex)
在 RMI 运行时无法通过 RMISocketFactory 创建 ServerSocket 时调用该 failure 回调。

抛出 Exception 的 java.rmi.server 中的方法
 void Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash)
已过时。 无替代版本
 void RemoteCall.executeCall()
已过时。 无替代版本
 void RemoteRef.invoke(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 Object RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum)
调用某个方法。

参数类型为 Exception 的 java.rmi.server 中的构造方法
ExportException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ExportException。
ServerCloneException(String s, Exception cause)
构造带指定详细消息和原因的 ServerCloneException。
SkeletonNotFoundException(String s, Exception ex)
已过时。 构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。
SocketSecurityException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。

java.security 中 Exception 的使用

java.security 中 Exception 的子类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | DigestException 此为一般 Message Digest 异常。
class | GeneralSecurityException GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | PrivilegedActionException doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
class | SignatureException 这是一般的签名异常。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。

返回 Exception 的 java.security 中的方法
 Exception PrivilegedActionException.getException()
返回特权计算抛出的异常，该异常导致此 PrivilegedActionException。

抛出 Exception 的 java.security 中的方法
 T PrivilegedExceptionAction.run()
执行计算。

参数类型为 Exception 的 java.security 中的构造方法
PrivilegedActionException(Exception exception)
构造一个新的“包装”指定 Exception 的 PrivilegedActionException。

java.security.acl 中 Exception 的使用

java.security.acl 中 Exception 的子类
class | AclNotFoundException 如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
class | LastOwnerException 如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
class | NotOwnerException 当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

java.security.cert 中 Exception 的使用

java.security.cert 中 Exception 的子类
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。

java.security.spec 中 Exception 的使用

java.security.spec 中 Exception 的子类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

java.sql 中 Exception 的使用

java.sql 中 Exception 的子类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

java.text 中 Exception 的使用

java.text 中 Exception 的子类
 class ParseException
表示解析时出现意外错误。

java.util 中 Exception 的使用

java.util 中 Exception 的子类
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | InvalidPropertiesFormatException 当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | TooManyListenersException TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

java.util.concurrent 中 Exception 的使用

java.util.concurrent 中 Exception 的子类
class | BrokenBarrierException 当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | ExecutionException 当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。
class | TimeoutException 阻塞操作超时时，抛出该异常。

抛出 Exception 的 java.util.concurrent 中的方法
 V Callable.call()
计算结果，如果无法计算结果，则抛出一个异常。

java.util.jar 中 Exception 的使用

java.util.jar 中 Exception 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.logging 中 Exception 的使用

参数类型为 Exception 的 java.util.logging 中的方法
void | ErrorManager.error(String msg, Exception ex, int code) 在发生 Handler 失败时调用 error 方法。
protected void | Handler.reportError(String msg, Exception ex, int code) 用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。

java.util.prefs 中 Exception 的使用

java.util.prefs 中 Exception 的子类
class | BackingStoreException 抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
class | InvalidPreferencesFormatException 抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

java.util.regex 中 Exception 的使用

java.util.regex 中 Exception 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.zip 中 Exception 的使用

java.util.zip 中 Exception 的子类
class | DataFormatException 当数据格式发生错误时，抛出此异常。
class | ZipException 如果某种 ZIP 异常发生，则抛出此错误。

javax.activation 中 Exception 的使用

javax.activation 中 Exception 的子类
 class UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

javax.activity 中 Exception 的使用

javax.activity 中 Exception 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation.processing 中 Exception 的使用

javax.annotation.processing 中 Exception 的子类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Exception 的使用

javax.crypto 中 Exception 的子类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

javax.imageio 中 Exception 的使用

javax.imageio 中 Exception 的子类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

javax.imageio.metadata 中 Exception 的使用

javax.imageio.metadata 中 Exception 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

javax.lang.model.element 中 Exception 的使用

javax.lang.model.element 中 Exception 的子类
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 Exception 的使用

javax.lang.model.type 中 Exception 的子类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 Exception 的使用

javax.management 中 Exception 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | BadAttributeValueExpException 向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
class | BadBinaryOpValueExpException 向构造查询的方法传递无效的表达式时，抛出此异常。
class | BadStringOperationException 向构造查询的方法传递无效的字符串操作时，抛出此异常。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | InvalidApplicationException 试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | JMException 由 JMX 实现所抛出的异常。
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

返回 Exception 的 javax.management 中的方法
Exception | MBeanException.getTargetException() 返回实际抛出的 Exception。
Exception | ReflectionException.getTargetException() 返回抛出的实际 Exception。

抛出 Exception 的 javax.management 中的方法
void | MBeanRegistration.preDeregister() 允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。
void | StandardMBean.preDeregister() 允许 MBean 由 MBean 服务器取消注册前执行任何它所需要的操作。
ObjectName | MBeanRegistration.preRegister(MBeanServer server, ObjectName name) 允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
ObjectName | StandardMBean.preRegister(MBeanServer server, ObjectName name) 允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。

参数类型为 Exception 的 javax.management 中的构造方法
MBeanException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanException。
MBeanException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。
MBeanRegistrationException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException。
MBeanRegistrationException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。
ReflectionException(Exception e)
创建包装实际 java.lang.Exception 的 ReflectionException。
ReflectionException(Exception e, String message)
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。

javax.management.loading 中 Exception 的使用

抛出 Exception 的 javax.management.loading 中的方法
protected URL | MLet.check(String version, URL codebase, String jarfile, MLetContent mlet) 当扩展此服务来支持缓存和版本控制时，要重写此方法。
void | MLet.preDeregister() 允许 m-let 在由 MBean 服务器注销之前执行任何所需要的操作。
ObjectName | MLet.preRegister(MBeanServer server, ObjectName name) 允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

javax.management.modelmbean 中 Exception 的使用

javax.management.modelmbean 中 Exception 的子类
class | InvalidTargetObjectTypeException 当指定了无效的目标对象类型时，抛出此异常。
class | XMLParseException 当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

抛出 Exception 的 javax.management.modelmbean 中的方法
void | RequiredModelMBean.preDeregister() 允许 MBean 在由 MBean 服务器注销之前执行任何所需要的操作。
ObjectName | RequiredModelMBean.preRegister(MBeanServer server, ObjectName name) 允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

参数类型为 Exception 的 javax.management.modelmbean 中的构造方法
InvalidTargetObjectTypeException(Exception e, String s)
带有异常和字符串的构造方法。
XMLParseException(Exception e, String s)
带有字符串和异常的构造方法。

javax.management.monitor 中 Exception 的使用

javax.management.monitor 中 Exception 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

抛出 Exception 的 javax.management.monitor 中的方法
void | Monitor.preDeregister() 允许在 MBean 服务器注销监视器 MBean 之前执行监视器 MBean 所需要的任何操作。
ObjectName | Monitor.preRegister(MBeanServer server, ObjectName name) 允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。

javax.management.openmbean 中 Exception 的使用

javax.management.openmbean 中 Exception 的子类
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
class | OpenDataException 因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

javax.management.relation 中 Exception 的使用

javax.management.relation 中 Exception 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

抛出 Exception 的 javax.management.relation 中的方法
void | RelationService.preDeregister()
void | RelationSupport.preDeregister()
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

javax.management.remote 中 Exception 的使用

javax.management.remote 中 Exception 的子类
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

抛出 Exception 的 javax.management.remote 中的方法
 void JMXConnectorServer.preDeregister()
当此连接器服务器从 MBean 服务器上注销时，由该 MBean 服务器调用此方法。

javax.management.timer 中 Exception 的使用

抛出 Exception 的 javax.management.timer 中的方法
void | Timer.preDeregister() 允许计时器 MBean 在 MBean 服务器注销它之前执行任何所需的操作。
ObjectName | Timer.preRegister(MBeanServer server, ObjectName name) 允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

javax.naming 中 Exception 的使用

javax.naming 中 Exception 的子类
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingException 此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

javax.naming.directory 中 Exception 的使用

javax.naming.directory 中 Exception 的子类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。

javax.naming.ldap 中 Exception 的使用

javax.naming.ldap 中 Exception 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

javax.naming.spi 中 Exception 的使用

抛出 Exception 的 javax.naming.spi 中的方法
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。

javax.net.ssl 中 Exception 的使用

javax.net.ssl 中 Exception 的子类
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

javax.print 中 Exception 的使用

javax.print 中 Exception 的子类
 class PrintException
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

参数类型为 Exception 的 javax.print 中的构造方法
PrintException(Exception e)
构造链接了所提供异常的 print 异常。
PrintException(String s, Exception e)
构造带给定详细消息和链异常的 print 异常。

javax.print.attribute 中 Exception 的使用

javax.print.attribute 中 Exception 的子类
 class UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

javax.script 中 Exception 的使用

javax.script 中 Exception 的子类
 class ScriptException
脚本 API 的一般 Exception 类。

参数类型为 Exception 的 javax.script 中的构造方法
ScriptException(Exception e)
创建一个包装底层解释器抛出的 Exception 的 ScriptException。

javax.security.auth 中 Exception 的使用

javax.security.auth 中 Exception 的子类
class | DestroyFailedException 当 destroy 操作失败时，抛出此异常。
class | RefreshFailedException 当 refresh 操作失败时，抛出此异常。

javax.security.auth.callback 中 Exception 的使用

javax.security.auth.callback 中 Exception 的子类
 class UnsupportedCallbackException
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.login 中 Exception 的使用

javax.security.auth.login 中 Exception 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

javax.security.cert 中 Exception 的使用

javax.security.cert 中 Exception 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题之一。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书不再有效异常。
class | CertificateParsingException 证书解析异常。

javax.security.sasl 中 Exception 的使用

javax.security.sasl 中 Exception 的子类
class | AuthenticationException 此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

javax.sound.midi 中 Exception 的使用

javax.sound.midi 中 Exception 的子类
class | InvalidMidiDataException 一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
class | MidiUnavailableException 当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

javax.sound.sampled 中 Exception 的使用

javax.sound.sampled 中 Exception 的子类
class | LineUnavailableException LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
class | UnsupportedAudioFileException UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

javax.sql.rowset 中 Exception 的使用

javax.sql.rowset 中 Exception 的子类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Exception 的使用

javax.sql.rowset.serial 中 Exception 的子类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

javax.sql.rowset.spi 中 Exception 的使用

javax.sql.rowset.spi 中 Exception 的子类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Exception 的使用

javax.swing 中 Exception 的子类
 class UnsupportedLookAndFeelException
指示在用户系统上不存在请求的外观管理类的异常。

抛出 Exception 的 javax.swing 中的方法
protected abstract  T SwingWorker.doInBackground()
计算结果；如果无法计算结果，则抛出异常。

javax.swing.text 中 Exception 的使用

javax.swing.text 中 Exception 的子类
class | BadLocationException 此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
class | ChangedCharSetException 顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

javax.swing.tree 中 Exception 的使用

javax.swing.tree 中 Exception 的子类
 class ExpandVetoException
用于阻止扩展/折叠发生的异常。

javax.swing.undo 中 Exception 的使用

javax.swing.undo 中 Exception 的子类
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。

javax.transaction 中 Exception 的使用

javax.transaction 中 Exception 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Exception 的使用

javax.transaction.xa 中 Exception 的子类
 class XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml.bind 中 Exception 的使用

javax.xml.bind 中 Exception 的子类
class | JAXBException 这是所有 JAXB 异常的根异常类。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | TypeConstraintException 此异常指示已检测到存在违反动态检查的类型约束的情况。
class | ValidationException 此异常指示在执行验证操作时发生错误。

javax.xml.bind.annotation.adapters 中 Exception 的使用

抛出 Exception 的 javax.xml.bind.annotation.adapters 中的方法
abstract ValueType | XmlAdapter.marshal(BoundType v) 将 bound 类型转换为 value 类型。
abstract BoundType | XmlAdapter.unmarshal(ValueType v) 将 value 类型转换为 bound 类型。

javax.xml.crypto 中 Exception 的使用

javax.xml.crypto 中 Exception 的子类
class | KeySelectorException 指示由 KeySelector 抛出的异常条件。
class | MarshalException 指示 XML 编组或解组过程中发生的异常条件。
class | NoSuchMechanismException 当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
class | URIReferenceException 指示取消引用 URIReference 时抛出的异常条件。

javax.xml.crypto.dsig 中 Exception 的使用

javax.xml.crypto.dsig 中 Exception 的子类
class | TransformException 指示执行转换算法时出现异常的异常条件。
class | XMLSignatureException 指示生成或验证 XML 签名过程中发生的异常条件。

javax.xml.datatype 中 Exception 的使用

javax.xml.datatype 中 Exception 的子类
 class DatatypeConfigurationException
指示严重的配置错误。

javax.xml.parsers 中 Exception 的使用

javax.xml.parsers 中 Exception 的子类
 class ParserConfigurationException
指示一个严重的配置错误。

返回 Exception 的 javax.xml.parsers 中的方法
 Exception FactoryConfigurationError.getException()
返回引发此异常的实际异常（如果有）。

参数类型为 Exception 的 javax.xml.parsers 中的构造方法
FactoryConfigurationError(Exception e)
使用错误的给定 Exception 基本原因创建一个新的 FactoryConfigurationError。
FactoryConfigurationError(Exception e, String msg)
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。

javax.xml.soap 中 Exception 的使用

javax.xml.soap 中 Exception 的子类
 class SOAPException
当发生 SOAP 异常时，抛出此异常。

javax.xml.stream 中 Exception 的使用

javax.xml.stream 中 Exception 的子类
 class XMLStreamException
用于不可预料处理错误的基本异常。

返回 Exception 的 javax.xml.stream 中的方法
 Exception FactoryConfigurationError.getException()
返回嵌套异常（如果有）。

参数类型为 Exception 的 javax.xml.stream 中的构造方法
FactoryConfigurationError(Exception e)
构造具有嵌套内部异常的异常。
FactoryConfigurationError(Exception e, String msg)
构造具有嵌套内部异常和消息的异常。
FactoryConfigurationError(String msg, Exception e)
构造具有嵌套内部异常和消息的异常。

javax.xml.transform 中 Exception 的使用

javax.xml.transform 中 Exception 的子类
class | TransformerConfigurationException 指示严重的配置错误。
class | TransformerException 此类指定了转换过程中发生的异常条件。

返回 Exception 的 javax.xml.transform 中的方法
 Exception TransformerFactoryConfigurationError.getException()
返回引发此异常的实际异常（如果有）。

参数类型为 Exception 的 javax.xml.transform 中的构造方法
TransformerFactoryConfigurationError(Exception e)
创建带有错误的给定 Exception 基本原因的新 TransformerFactoryConfigurationError。
TransformerFactoryConfigurationError(Exception e, String msg)
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。

javax.xml.ws 中 Exception 的使用

javax.xml.ws 中 Exception 的子类
 class WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

javax.xml.ws.http 中 Exception 的使用

javax.xml.ws.http 中 Exception 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Exception 的使用

javax.xml.ws.soap 中 Exception 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.xpath 中 Exception 的使用

javax.xml.xpath 中 Exception 的子类
class | XPathException XPathException 表示通用 XPath 异常。
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

org.ietf.jgss 中 Exception 的使用

org.ietf.jgss 中 Exception 的子类
 class GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

org.omg.CORBA 中 Exception 的使用

org.omg.CORBA 中 Exception 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | PolicyError 发生策略错误时抛出的用户异常。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

返回 Exception 的 org.omg.CORBA 中的方法
abstract  Exception Environment.exception()
检索此 Environment 对象中的异常。

参数类型为 Exception 的 org.omg.CORBA 中的方法
abstract  void Environment.exception(Exception except)
将给定异常插入此 Environment 对象。

org.omg.CORBA.DynAnyPackage 中 Exception 的使用

org.omg.CORBA.DynAnyPackage 中 Exception 的子类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Exception 的使用

org.omg.CORBA.ORBPackage 中 Exception 的子类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Exception 的使用

org.omg.CORBA.portable 中 Exception 的子类
class | ApplicationException 此类用来报告 ORB 和 stub 之间的应用程序级异常。
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | RemarshalException 此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

org.omg.CORBA.TypeCodePackage 中 Exception 的使用

org.omg.CORBA.TypeCodePackage 中 Exception 的子类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming.NamingContextExtPackage 中 Exception 的使用

org.omg.CosNaming.NamingContextExtPackage 中 Exception 的子类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 Exception 的使用

org.omg.CosNaming.NamingContextPackage 中 Exception 的子类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。

org.omg.IOP.CodecFactoryPackage 中 Exception 的使用

org.omg.IOP.CodecFactoryPackage 中 Exception 的子类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 Exception 的使用

org.omg.IOP.CodecPackage 中 Exception 的子类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 Exception 的使用

org.omg.PortableInterceptor 中 Exception 的子类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Exception 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Exception 的子类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 Exception 的使用

org.omg.PortableServer 中 Exception 的子类
 class ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

org.omg.PortableServer.CurrentPackage 中 Exception 的使用

org.omg.PortableServer.CurrentPackage 中 Exception 的子类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 Exception 的使用

org.omg.PortableServer.POAManagerPackage 中 Exception 的子类
 class AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

org.omg.PortableServer.POAPackage 中 Exception 的使用

org.omg.PortableServer.POAPackage 中 Exception 的子类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.w3c.dom 中 Exception 的使用

org.w3c.dom 中 Exception 的子类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 Exception 的使用

org.w3c.dom.events 中 Exception 的子类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Exception 的使用

org.w3c.dom.ls 中 Exception 的子类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Exception 的使用

org.xml.sax 中 Exception 的子类
class | SAXException 封装一般的 SAX 错误或警告。
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

返回 Exception 的 org.xml.sax 中的方法
 Exception SAXException.getException()
返回嵌入的异常（如果有）。

参数类型为 Exception 的 org.xml.sax 中的构造方法
SAXException(Exception e)
创建一个包装现有异常的新的 SAXException。
SAXException(String message, Exception e)
从现有的异常创建新的 SAXException。
SAXParseException(String message, Locator locator, Exception e)
将现有的异常包装在 SAXParseException 中。
SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
创建带有嵌入异常的新 SAXParseException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ThreadDeath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ThreadDeath
的使用

没有 java.lang.ThreadDeath 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Throwable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Throwable
的使用

使用 Throwable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.color | 提供用于颜色空间的类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.print | 为通用的打印 API 提供类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
javax.transaction.xa | 提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.http | 该包定义特定于 HTTP 绑定的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.DynAnyPackage | 提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。
org.omg.CORBA.ORBPackage | 提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.CORBA.TypeCodePackage | 提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。
org.omg.CosNaming.NamingContextExtPackage | 此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。
org.omg.CosNaming.NamingContextPackage | 此包包含 org.omg.CosNaming 包的 Exception 类。
org.omg.IOP.CodecFactoryPackage | 此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。
org.omg.IOP.CodecPackage | 此包根据 IOP::Codec IDL 接口定义生成。
org.omg.PortableInterceptor | 提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。
org.omg.PortableInterceptor.ORBInitInfoPackage | 此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。
org.omg.PortableServer.CurrentPackage | 提供各种方法实现，这些实现能够访问调用方法的对象的身份。
org.omg.PortableServer.POAManagerPackage | 封装 POA 关联的处理状态。
org.omg.PortableServer.POAPackage | 允许程序员构造可在不同 ORB 产品间移植的对象实现。
org.w3c.dom | 为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。
org.w3c.dom.events |
org.w3c.dom.ls |
org.xml.sax | 此包提供了核心 SAX API。

java.awt 中 Throwable 的使用

java.awt 中 Throwable 的子类
class | AWTError 当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。
class | AWTException 表示发生了 Absract Window Toolkit 异常。
class | FontFormatException 此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。
class | HeadlessException 在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。
class | IllegalComponentStateException 当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

抛出 Throwable 的 java.awt 中的方法
protected  void Font.finalize()
移除本机 Font 对象。

java.awt.color 中 Throwable 的使用

java.awt.color 中 Throwable 的子类
class | CMMException 如果本机 CMM 返回一个错误，则抛出此异常。
class | ProfileDataException 当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

java.awt.datatransfer 中 Throwable 的使用

java.awt.datatransfer 中 Throwable 的子类
class | MimeTypeParseException 对分析相关异常的 MimeType 进行封装的类
class | UnsupportedFlavorException 在此 flavor 中不支持所请求的数据的信号。

java.awt.dnd 中 Throwable 的使用

java.awt.dnd 中 Throwable 的子类
 class InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

java.awt.event 中 Throwable 的使用

返回 Throwable 的 java.awt.event 中的方法
 Throwable InvocationEvent.getThrowable()
返回在执行 Runnable 的 run() 方法时捕获的任何 Throwable。

java.awt.geom 中 Throwable 的使用

java.awt.geom 中 Throwable 的子类
class | IllegalPathStateException 对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。
class | NoninvertibleTransformException NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

java.awt.image 中 Throwable 的使用

java.awt.image 中 Throwable 的子类
class | ImagingOpException 如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。
class | RasterFormatException 如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

java.awt.print 中 Throwable 的使用

java.awt.print 中 Throwable 的子类
class | PrinterAbortException PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。
class | PrinterException PrinterException 类及其子类用于指示打印系统中发生的异常情况。
class | PrinterIOException PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

返回 Throwable 的 java.awt.print 中的方法
 Throwable PrinterIOException.getCause()
返回此异常的 cause（终止打印作业的 IOException）。

java.beans 中 Throwable 的使用

java.beans 中 Throwable 的子类
class | IntrospectionException 在 Introspection 期间发生异常时抛出异常。
class | PropertyVetoException 当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

java.io 中 Throwable 的使用

java.io 中 Throwable 的子类
class | CharConversionException 用于字符转换异常的基类。
class | EOFException 当输入过程中意外到达文件或流的末尾时，抛出此异常。
class | FileNotFoundException 当试图打开指定路径名表示的文件失败时，抛出此异常。
class | InterruptedIOException I/O 操作已中断信号，抛出此异常。
class | InvalidClassException 当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。
class | InvalidObjectException 指示一个或多个反序列化对象未通过验证测试。
class | IOError 当发生严重的 I/O 错误时，抛出此错误。
class | IOException 当发生某种 I/O 异常时，抛出此异常。
class | NotActiveException 当序列化和反序列化不活动时，抛出此异常。
class | NotSerializableException 当实例需要具有序列化接口时，抛出此异常。
class | ObjectStreamException 特定于 Object Stream 类的所有异常的超类。
class | OptionalDataException 指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。
class | StreamCorruptedException 当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。
class | SyncFailedException 当 sync 操作失败时，抛出此异常。
class | UnsupportedEncodingException 不支持字符编码。
class | UTFDataFormatException 在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。
class | WriteAbortedException 在写入操作过程中抛出 ObjectStreamException 之一的信号。

返回 Throwable 的 java.io 中的方法
 Throwable WriteAbortedException.getCause()
返回终止操作的异常（即 cause）。

参数类型为 Throwable 的 java.io 中的构造方法
IOError(Throwable cause)
构造带有指定 cause 的新 IOError 实例。
IOException(String message, Throwable cause)
构造带有指定详细消息和 cause 的 IOException。
IOException(Throwable cause)
构造一个 IOException，使其具有指定的 cause 以及详细消息 (cause==null ? null : cause.toString())（通常包含类和 cause 的详细消息）。

java.lang 中 Throwable 的使用

java.lang 中 Throwable 的子类
class | AbstractMethodError 当应用程序试图调用一个抽象方法时，抛出此错误。
class | ArithmeticException 当出现异常的运算条件时，抛出此异常。
class | ArrayIndexOutOfBoundsException 用非法索引访问数组时抛出的异常。
class | ArrayStoreException 试图将错误类型的对象存储到一个对象数组时抛出的异常。
class | AssertionError 抛出该异常指示某个断言失败。
class | ClassCastException 当试图将对象强制转换为不是实例的子类时，抛出该异常。
class | ClassCircularityError 当初始化类时检测到类的循环调用的时候，抛出该错误。
class | ClassFormatError 当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。
class | ClassNotFoundException 当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。
class | CloneNotSupportedException 当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。
class | EnumConstantNotPresentException 当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。
class | Error Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。
class | Exception Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。
class | ExceptionInInitializerError 静态初始化程序中发生意外异常的信号。
class | IllegalAccessError 当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。
class | IllegalAccessException 当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。
class | IllegalArgumentException 抛出的异常表明向方法传递了一个不合法或不正确的参数。
class | IllegalMonitorStateException 抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。
class | IllegalStateException 在非法或不适当的时间调用方法时产生的信号。
class | IllegalThreadStateException 指示线程没有处于请求操作所要求的适当状态时抛出的异常。
class | IncompatibleClassChangeError 在某些类定义中出现不兼容的类更改时抛出该异常。
class | IndexOutOfBoundsException 指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。
class | InstantiationError 当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。
class | InstantiationException 当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。
class | InternalError 该异常指示 Java 虚拟机中出现一些意外的内部错误。
class | InterruptedException 当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。
class | LinkageError LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。
class | NegativeArraySizeException 如果应用程序试图创建大小为负的数组，则抛出该异常。
class | NoClassDefFoundError 当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。
class | NoSuchFieldError 如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。
class | NoSuchFieldException 类不包含指定名称的字段时产生的信号。
class | NoSuchMethodError 当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。
class | NoSuchMethodException 无法找到某一特定方法时，抛出该异常。
class | NullPointerException 当应用程序试图在需要对象的地方使用 null 时，抛出该异常。
class | NumberFormatException 当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。
class | OutOfMemoryError 因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。
class | RuntimeException RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。
class | SecurityException 由安全管理器抛出的异常，指示存在安全侵犯。
class | StackOverflowError 当应用程序递归太深而发生堆栈溢出时，抛出该错误。
class | StringIndexOutOfBoundsException 此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。
class | ThreadDeath 调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。
class | TypeNotPresentException 当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。
class | UnknownError 当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。
class | UnsatisfiedLinkError 当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。
class | UnsupportedClassVersionError 当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。
class | UnsupportedOperationException 当不支持请求的操作时，抛出该异常。
class | VerifyError 当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。
class | VirtualMachineError 当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

返回 Throwable 的 java.lang 中的方法
Throwable | Throwable.fillInStackTrace() 在异常堆栈跟踪中填充。
Throwable | ExceptionInInitializerError.getCause() 返回导致该错误的原因（导致发生此错误的静态初始化期间发生的异常）。
Throwable | ClassNotFoundException.getCause() 返回此异常的原因（尝试加载类时发生错误引发的异常；否则返回 null）。
Throwable | Throwable.getCause() 返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
Throwable | ExceptionInInitializerError.getException() 返回静态初始化期间发生的异常，该异常导致发生此错误。
Throwable | ClassNotFoundException.getException() 返回尝试加载类时发生错误引发的异常。
Throwable | Throwable.initCause(Throwable cause) 将此 throwable 的 cause 初始化为指定值。

参数类型为 Throwable 的 java.lang 中的方法
 Throwable Throwable.initCause(Throwable cause)
将此 throwable 的 cause 初始化为指定值。
 void Thread.stop(Throwable obj)
已过时。 该方法具有固有的不安全性。有关详细信息，请参阅 Thread.stop()。 该方法的附加危险是它可用于生成目标线程未准备处理的异常（包括若没有该方法该线程不太可能抛出的已检查的异常）。 有关更多信息，请参阅为何不赞成使用 Thread.stop、Thread.suspend 和 Thread.resume？。
 void ThreadGroup.uncaughtException(Thread t, Throwable e)
当此线程组中的线程因为一个未捕获的异常而停止，并且线程没有安装特定 Thread.UncaughtExceptionHandler 时，由 Java Virtual Machine 调用此方法。
 void Thread.UncaughtExceptionHandler.uncaughtException(Thread t, Throwable e)
当给定线程因给定的未捕获异常而终止时，调用该方法。

抛出 Throwable 的 java.lang 中的方法
protected  void Object.finalize()
当垃圾回收器确定不存在对该对象的更多引用时，由对象的垃圾回收器调用此方法。

参数类型为 Throwable 的 java.lang 中的构造方法
ClassNotFoundException(String s, Throwable ex)
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。
Error(String message, Throwable cause)
构造带指定详细消息和原因的新错误。
Error(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息来构造新的错误（通常包含 cause 的类和详细消息）。
Exception(String message, Throwable cause)
构造带指定详细消息和原因的新异常。
Exception(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造新异常（它通常包含 cause 的类和详细消息）。
ExceptionInInitializerError(Throwable thrown)
保存对抛出的 Throwable 对象的引用，以便以后通过 ExceptionInInitializerError.getException() 方法对其进行获取，通过这种方式构造一个新的 ExceptionInInitializerError 类。
IllegalArgumentException(String message, Throwable cause)
根据指定的详细消息和原因构造一个新异常。
IllegalArgumentException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString()) 的详细消息构造一个新异常（它通常包含 cause 的类和详细消息）。
IllegalStateException(String message, Throwable cause)
构造一个新异常，它带有指定的详细消息和原因。
IllegalStateException(Throwable cause)
构造一个新异常，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含 cause 的类和详细消息）。
RuntimeException(String message, Throwable cause)
用指定的详细消息和原因构造一个新的运行时异常。
RuntimeException(Throwable cause)
用指定的原因和详细消息 (cause==null ? null :cause.toString()） 构造一个新的运行时异常（它通常包含类和 cause 的详细消息）。
SecurityException(String message, Throwable cause)
创建带指定详细消息和原因的 SecurityException。
SecurityException(Throwable cause)
创建一个 SecurityException，它带有指定的原因和 (cause==null ? null :cause.toString()) 的详细消息（通常包含该类和 cause 的详细消息）。
Throwable(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 throwable。
Throwable(Throwable cause)
构造一个带指定 cause 和 (cause==null ? null :cause.toString())（它通常包含类和 cause 的详细消息）的详细消息的新 throwable。
TypeNotPresentException(String typeName, Throwable cause)
为指定类型构造一个带指定原因的 TypeNotPresentException。
UnsupportedOperationException(String message, Throwable cause)
根据指定的详细消息和原因，构造一个新异常。
UnsupportedOperationException(Throwable cause)
根据指定的原因和 (cause==null ? null :cause.toString())（它通常包含了 cause 的类和详细消息）的详细消息，构造一个新异常。

java.lang.annotation 中 Throwable 的使用

java.lang.annotation 中 Throwable 的子类
class | AnnotationFormatError 当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。
class | AnnotationTypeMismatchException 若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。
class | IncompleteAnnotationException 若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

参数类型为 Throwable 的 java.lang.annotation 中的构造方法
AnnotationFormatError(String message, Throwable cause)
构造带指定详细消息和原因的新 AnnotationFormatError。
AnnotationFormatError(Throwable cause)
构造带指定原因和详细消息的新 AnnotationFormatError，该消息为 (cause == null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

java.lang.instrument 中 Throwable 的使用

java.lang.instrument 中 Throwable 的子类
class | IllegalClassFormatException 当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。
class | UnmodifiableClassException 在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

java.lang.reflect 中 Throwable 的使用

java.lang.reflect 中 Throwable 的子类
class | GenericSignatureFormatError 当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。
class | InvocationTargetException InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。
class | MalformedParameterizedTypeException 当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。
class | UndeclaredThrowableException 如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

返回 Throwable 的 java.lang.reflect 中的方法
Throwable | UndeclaredThrowableException.getCause() 返回此异常的原因（此 UndeclaredThrowableException 中包装的 Throwable 实例，可能为 null）。
Throwable | InvocationTargetException.getCause() 返回此异常的原因（抛出的目标异常，可能为 null）。
Throwable | InvocationTargetException.getTargetException() 获取抛出的目标异常。
Throwable | UndeclaredThrowableException.getUndeclaredThrowable() 返回此 UndeclaredThrowableException 中包装的 Throwable 实例，它可能为 null。

抛出 Throwable 的 java.lang.reflect 中的方法
 Object InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

参数类型为 Throwable 的 java.lang.reflect 中的构造方法
InvocationTargetException(Throwable target)
构造带目标异常的 InvocationTargetException。
InvocationTargetException(Throwable target, String s)
构造带目标异常和详细消息的 InvocationTargetException。
UndeclaredThrowableException(Throwable undeclaredThrowable)
根据指定的 Throwable 构造一个 UndeclaredThrowableException。
UndeclaredThrowableException(Throwable undeclaredThrowable, String s)
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。

java.net 中 Throwable 的使用

java.net 中 Throwable 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | HttpRetryException 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
class | MalformedURLException 抛出这一异常指示出现了错误的 URL。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
class | ProtocolException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketException 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
class | SocketTimeoutException 如果在读取或接受套接字时发生超时，则抛出此异常。
class | UnknownHostException 指示主机 IP 地址无法确定而抛出的异常。
class | UnknownServiceException 抛出这一异常指示出现了未知服务异常。
class | URISyntaxException 抛出经过检查的指示字符串不能解析为 URI 引用的异常。

java.nio 中 Throwable 的使用

java.nio 中 Throwable 的子类
class | BufferOverflowException 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
class | BufferUnderflowException 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
class | InvalidMarkException 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
class | ReadOnlyBufferException 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

java.nio.channels 中 Throwable 的使用

java.nio.channels 中 Throwable 的子类
class | AlreadyConnectedException 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | CancelledKeyException 当试图使用不再有效的选择键时，抛出此未经检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
class | ClosedChannelException 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
class | ClosedSelectorException 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
class | ConnectionPendingException 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
class | FileLockInterruptionException 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
class | IllegalBlockingModeException 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
class | IllegalSelectorException 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
class | NoConnectionPendingException 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
class | NonReadableChannelException 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
class | NonWritableChannelException 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
class | NotYetBoundException 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | NotYetConnectedException 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
class | OverlappingFileLockException 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
class | UnresolvedAddressException 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
class | UnsupportedAddressTypeException 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

java.nio.charset 中 Throwable 的使用

java.nio.charset 中 Throwable 的子类
class | CharacterCodingException 出现字符编码或解码错误时，抛出此经过检查的异常。
class | CoderMalfunctionError 当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。
class | IllegalCharsetNameException 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
class | UnsupportedCharsetException 当不支持请求的 charset 时，抛出此未经检查的异常。

java.rmi 中 Throwable 的使用

java.rmi 中 Throwable 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | AlreadyBoundException 如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | NotBoundException 如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
class | RemoteException RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
class | RMISecurityException 已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

声明为 Throwable 的 java.rmi 中的字段
 Throwable RemoteException.detail
远程异常的原因。

返回 Throwable 的 java.rmi 中的方法
 Throwable RemoteException.getCause()
返回此异常的原因。

参数类型为 Throwable 的 java.rmi 中的构造方法
RemoteException(String s, Throwable cause)
构造带指定详细消息和原因的 RemoteException。

java.rmi.activation 中 Throwable 的使用

java.rmi.activation 中 Throwable 的子类
class | ActivateFailedException 在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
class | ActivationException 激活接口所使用的一般异常。
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

声明为 Throwable 的 java.rmi.activation 中的字段
 Throwable ActivationException.detail
激活异常的原因。

返回 Throwable 的 java.rmi.activation 中的方法
 Throwable ActivationException.getCause()
返回此异常的原因。

参数类型为 Throwable 的 java.rmi.activation 中的构造方法
ActivationException(String s, Throwable cause)
构造带指定详细消息和原因的 ActivationException。

java.rmi.server 中 Throwable 的使用

java.rmi.server 中 Throwable 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | ServerCloneException 如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
class | ServerNotActiveException 如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

返回 Throwable 的 java.rmi.server 中的方法
 Throwable ServerCloneException.getCause()
返回此异常的原因。

抛出 Throwable 的 java.rmi.server 中的方法
 Object RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

java.security 中 Throwable 的使用

java.security 中 Throwable 的子类
class | AccessControlException 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
class | DigestException 此为一般 Message Digest 异常。
class | GeneralSecurityException GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | InvalidParameterException 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | PrivilegedActionException doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
class | ProviderException 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
class | SignatureException 这是一般的签名异常。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。

返回 Throwable 的 java.security 中的方法
 Throwable PrivilegedActionException.getCause()
返回此异常（特权计算抛出的异常，该异常导致此 PrivilegedActionException）的 cause。

参数类型为 Throwable 的 java.security 中的构造方法
DigestException(String message, Throwable cause)
创建带指定详细消息和 cause 的 DigestException。
DigestException(Throwable cause)
创建带指定 cause 和详细消息 DigestException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
GeneralSecurityException(String message, Throwable cause)
创建带指定详细消息和 cause 的 GeneralSecurityException。
GeneralSecurityException(Throwable cause)
用指定的原因和详细消息创建一个 GeneralSecurityException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
InvalidAlgorithmParameterException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidAlgorithmParameterException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
InvalidKeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidKeyException。
InvalidKeyException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidKeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyException。
KeyException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyManagementException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyManagementException。
KeyManagementException(Throwable cause)
创建带指定 cause 和详细消息的 KeyManagementException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
KeyStoreException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 KeyStoreException。
KeyStoreException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
NoSuchAlgorithmException(String message, Throwable cause)
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。
NoSuchAlgorithmException(Throwable cause)
创建带指定 cause 和详细消息的 NoSuchAlgorithmException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
ProviderException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 ProviderException。
ProviderException(Throwable cause)
创建带指定的 cause 和详细消息的 ProviderException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
SignatureException(String message, Throwable cause)
创建带指定详细消息和原因的 SignatureException。
SignatureException(Throwable cause)
创建带指定的原因和详细消息的 SignatureException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

java.security.acl 中 Throwable 的使用

java.security.acl 中 Throwable 的子类
class | AclNotFoundException 如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
class | LastOwnerException 如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
class | NotOwnerException 当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

java.security.cert 中 Throwable 的使用

java.security.cert 中 Throwable 的子类
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。

参数类型为 Throwable 的 java.security.cert 中的构造方法
CertificateEncodingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateEncodingException。
CertificateEncodingException(Throwable cause)
创建带指定原因和详细消息的 CertificateEncodingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateException。
CertificateException(Throwable cause)
创建带指定原因和详细消息的 CertificateException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertificateParsingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateParsingException。
CertificateParsingException(Throwable cause)
创建带指定原因和详细消息的 CertificateParsingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
CertPathBuilderException(String msg, Throwable cause)
创建带指定详细消息和原因的 CertPathBuilderException。
CertPathBuilderException(Throwable cause)
创建包装指定 throwable 的 CertPathBuilderException。
CertPathValidatorException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertPathValidatorException。
CertPathValidatorException(String msg, Throwable cause, CertPath certPath, int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。
CertPathValidatorException(Throwable cause)
创建包装指定 throwable 的 CertPathValidatorException。
CertStoreException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertStoreException。
CertStoreException(Throwable cause)
创建包装指定 throwable 的 CertStoreException。
CRLException(String message, Throwable cause)
创建带指定详细消息和 cause 的 CRLException。
CRLException(Throwable cause)
创建带指定 cause 和详细消息的 CRLException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

java.security.spec 中 Throwable 的使用

java.security.spec 中 Throwable 的子类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

参数类型为 Throwable 的 java.security.spec 中的构造方法
InvalidKeySpecException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 InvalidKeySpecException。
InvalidKeySpecException(Throwable cause)
创建带指定的 cause 和详细消息 (cause==null ? null : cause.toString()) 的 InvalidKeySpecException（它通常包含 cause 的类和详细消息）。

java.sql 中 Throwable 的使用

java.sql 中 Throwable 的子类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLException 提供关于数据库访问错误或其他错误信息的异常。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

返回变量类型为 Throwable 的类型的 java.sql 中的方法
 Iterator<Throwable> SQLException.iterator()
返回在链接的 SQLExceptions 上进行迭代的迭代器。

参数类型为 Throwable 的 java.sql 中的构造方法
BatchUpdateException(int[] updateCounts, Throwable cause)
构造一个使用给定 cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(Throwable cause)
构造一个使用给定 cause 初始化的 BatchUpdateException 对象。
DataTruncation(int index, boolean parameter, boolean read, int dataSize, int transferSize, Throwable cause)
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLDataException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。
SQLDataException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。
SQLDataException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。
SQLDataException(Throwable cause)
构造一个带有给定 cause 的 SQLDataException 对象。
SQLException(String reason, String sqlState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。
SQLException(String reason, String sqlState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。
SQLException(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLException 对象。
SQLException(Throwable cause)
构造一个具有给定 cause 的 SQLException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(Throwable cause)
构造一个带有给定 cause 的 SQLFeatureNotSupportedException 对象。
SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(Throwable cause)
构造一个带有给定 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(Throwable cause)
构造一个带有给定 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientException 对象。
SQLRecoverableException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(Throwable cause)
构造一个带有给定 cause 的 SQLRecoverableException 对象。
SQLSyntaxErrorException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(Throwable cause)
构造一个带有给定 cause 的 SQLSyntaxErrorException 对象。
SQLTimeoutException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(Throwable cause)
构造一个带有给定 cause 的 SQLTimeoutException 对象。
SQLTransactionRollbackException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(Throwable cause)
构造一个带有给定 cause 的 SQLTransactionRollbackException 对象。
SQLTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientConnectionException 对象。
SQLTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。
SQLTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。
SQLTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientException 对象。
SQLWarning(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。
SQLWarning(String reason, String SQLState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。
SQLWarning(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。
SQLWarning(Throwable cause)
构造一个具有给定 cause 的 SQLWarning 对象。

java.text 中 Throwable 的使用

java.text 中 Throwable 的子类
 class ParseException
表示解析时出现意外错误。

java.util 中 Throwable 的使用

java.util 中 Throwable 的子类
class | ConcurrentModificationException 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | EmptyStackException 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | FormatterClosedException 格式器已关闭时抛出的未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatException 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | InputMismatchException 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
class | InvalidPropertiesFormatException 当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | MissingResourceException 缺少资源时抛出此异常。
class | NoSuchElementException 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
class | ServiceConfigurationError 在加载服务提供者的过程中出错时抛出的错误。
class | TooManyListenersException TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

参数类型为 Throwable 的 java.util 中的构造方法
InvalidPropertiesFormatException(Throwable cause)
构造一个带指定原因的 InvalidPropertiesFormatException。
ServiceConfigurationError(String msg, Throwable cause)
构造一个带有指定消息和 cause 的新实例。

java.util.concurrent 中 Throwable 的使用

java.util.concurrent 中 Throwable 的子类
class | BrokenBarrierException 当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
class | CancellationException 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
class | ExecutionException 当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
class | RejectedExecutionException 当无法执行某个任务时,由 Executor 抛出的异常。
class | TimeoutException 阻塞操作超时时，抛出该异常。

参数类型为 Throwable 的 java.util.concurrent 中的方法
protected void | ThreadPoolExecutor.afterExecute(Runnable r, Throwable t) 基于完成执行给定 Runnable 所调用的方法。
protected void | FutureTask.setException(Throwable t) 除非已经设置了此 Future 或已将其取消，否则它将报告一个 ExecutionException，并将给定的 throwable 作为其原因。

参数类型为 Throwable 的 java.util.concurrent 中的构造方法
ExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 ExecutionException。
ExecutionException(Throwable cause)
构造带指定原因的 ExecutionException。
RejectedExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 RejectedExecutionException。
RejectedExecutionException(Throwable cause)
构造带指定原因的 RejectedExecutionException。

java.util.jar 中 Throwable 的使用

java.util.jar 中 Throwable 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.logging 中 Throwable 的使用

返回 Throwable 的 java.util.logging 中的方法
 Throwable LogRecord.getThrown()
获取与日志记录相关联的所有 throwable。

参数类型为 Throwable 的 java.util.logging 中的方法
void | Logger.log(Level level, String msg, Throwable thrown) 记录带有相关的可抛出信息的消息。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown) 记录一条消息，具有指定源类和方法，带有相关的可抛出信息。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown) 记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。
void | LogRecord.setThrown(Throwable thrown) 设置与日志事件相关联的 throwable。
void | Logger.throwing(String sourceClass, String sourceMethod, Throwable thrown) 正抛出异常的记录。

java.util.prefs 中 Throwable 的使用

java.util.prefs 中 Throwable 的子类
class | BackingStoreException 抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
class | InvalidPreferencesFormatException 抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

参数类型为 Throwable 的 java.util.prefs 中的构造方法
BackingStoreException(Throwable cause)
构造带指定原因的 BackingStoreException。
InvalidPreferencesFormatException(String message, Throwable cause)
构造带指定详细消息和原因的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(Throwable cause)
构造带指定原因的 InvalidPreferencesFormatException。

java.util.regex 中 Throwable 的使用

java.util.regex 中 Throwable 的子类
 class PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.zip 中 Throwable 的使用

java.util.zip 中 Throwable 的子类
class | DataFormatException 当数据格式发生错误时，抛出此异常。
class | ZipError 发生不可恢复的错误时抛出。
class | ZipException 如果某种 ZIP 异常发生，则抛出此错误。

javax.activation 中 Throwable 的使用

javax.activation 中 Throwable 的子类
 class UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

javax.activity 中 Throwable 的使用

javax.activity 中 Throwable 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

参数类型为 Throwable 的 javax.activity 中的构造方法
ActivityCompletedException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
ActivityCompletedException(Throwable cause)
构造带有指定 cause 的新 throwable。
ActivityRequiredException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
ActivityRequiredException(Throwable cause)
构造带有指定 cause 的新 throwable。
InvalidActivityException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
InvalidActivityException(Throwable cause)
构造带有指定 cause 的新 throwable。

javax.annotation.processing 中 Throwable 的使用

javax.annotation.processing 中 Throwable 的子类
 class FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Throwable 的使用

javax.crypto 中 Throwable 的子类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

javax.imageio 中 Throwable 的使用

javax.imageio 中 Throwable 的子类
 class IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

参数类型为 Throwable 的 javax.imageio 中的构造方法
IIOException(String message, Throwable cause)
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。

javax.imageio.metadata 中 Throwable 的使用

javax.imageio.metadata 中 Throwable 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

参数类型为 Throwable 的 javax.imageio.metadata 中的构造方法
IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。

javax.imageio.spi 中 Throwable 的使用

抛出 Throwable 的 javax.imageio.spi 中的方法
 void ServiceRegistry.finalize()
在垃圾回收前终止此对象。

javax.imageio.stream 中 Throwable 的使用

抛出 Throwable 的 javax.imageio.stream 中的方法
protected void | FileCacheImageInputStream.finalize() 在垃圾回收前结束此对象。
protected void | FileImageInputStream.finalize() 在垃圾回收前结束此对象。
protected void | FileImageOutputStream.finalize() 在垃圾回收前结束此对象。
protected void | ImageInputStreamImpl.finalize() 在垃圾回收前结束此对象。
protected void | MemoryCacheImageInputStream.finalize() 在垃圾回收前结束此对象。

javax.lang.model.element 中 Throwable 的使用

javax.lang.model.element 中 Throwable 的子类
class | UnknownAnnotationValueException 指示遇到一个未知种类的注释值。
class | UnknownElementException 指示遇到一个未知种类的元素。

javax.lang.model.type 中 Throwable 的使用

javax.lang.model.type 中 Throwable 的子类
class | MirroredTypeException 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
class | MirroredTypesException 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
class | UnknownTypeException 指示遇到未知种类的类型。

javax.management 中 Throwable 的使用

javax.management 中 Throwable 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | BadAttributeValueExpException 向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
class | BadBinaryOpValueExpException 向构造查询的方法传递无效的表达式时，抛出此异常。
class | BadStringOperationException 向构造查询的方法传递无效的字符串操作时，抛出此异常。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | InvalidApplicationException 试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | JMException 由 JMX 实现所抛出的异常。
class | JMRuntimeException 由 JMX 实现所发出的运行时异常。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

返回 Throwable 的 javax.management 中的方法
Throwable | MBeanException.getCause() 返回实际抛出的 Exception。
Throwable | ReflectionException.getCause() 返回抛出的实际 Exception。
Throwable | RuntimeErrorException.getCause() 返回抛出的实际 Error。
Throwable | RuntimeMBeanException.getCause() 返回抛出的实际 RuntimeException。
Throwable | RuntimeOperationsException.getCause() 返回抛出的实际 RuntimeException。

抛出 Throwable 的 javax.management 中的方法
 Object MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

javax.management.modelmbean 中 Throwable 的使用

javax.management.modelmbean 中 Throwable 的子类
class | InvalidTargetObjectTypeException 当指定了无效的目标对象类型时，抛出此异常。
class | XMLParseException 当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

javax.management.monitor 中 Throwable 的使用

javax.management.monitor 中 Throwable 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

javax.management.openmbean 中 Throwable 的使用

javax.management.openmbean 中 Throwable 的子类
class | InvalidOpenTypeException 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
class | KeyAlreadyExistsException 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
class | OpenDataException 因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

抛出 Throwable 的 javax.management.openmbean 中的方法
 Object CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

javax.management.relation 中 Throwable 的使用

javax.management.relation 中 Throwable 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

javax.management.remote 中 Throwable 的使用

javax.management.remote 中 Throwable 的子类
class | JMXProviderException 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
class | JMXServerErrorException 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

返回 Throwable 的 javax.management.remote 中的方法
Throwable | JMXProviderException.getCause()
Throwable | JMXServerErrorException.getCause()

参数类型为 Throwable 的 javax.management.remote 中的构造方法
JMXProviderException(String message, Throwable cause)
构造带指定详细消息和嵌套异常的 JMXProviderException。

javax.naming 中 Throwable 的使用

javax.naming 中 Throwable 的子类
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingException 此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

声明为 Throwable 的 javax.naming 中的字段
protected  Throwable NamingException.rootException
包含导致抛出此 NamingException 的原始异常。

返回 Throwable 的 javax.naming 中的方法
Throwable | NamingException.getCause() 返回此异常的 cause。
Throwable | NamingException.getRootCause() 检索此 NamingException 的根 cause，如果有的话。
Throwable | NamingException.initCause(Throwable cause) 将此异常的 cause 初始化为指定值。

参数类型为 Throwable 的 javax.naming 中的方法
Throwable | NamingException.initCause(Throwable cause) 将此异常的 cause 初始化为指定值。
void | NamingException.setRootCause(Throwable e) 记录此 NamingException 的根 cause。

javax.naming.directory 中 Throwable 的使用

javax.naming.directory 中 Throwable 的子类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。

javax.naming.ldap 中 Throwable 的使用

javax.naming.ldap 中 Throwable 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

javax.net.ssl 中 Throwable 的使用

javax.net.ssl 中 Throwable 的子类
class | SSLException 指示由 SSL 子系统检测到的某类错误。
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

参数类型为 Throwable 的 javax.net.ssl 中的构造方法
SSLException(String message, Throwable cause)
创建带指定详细消息和原因的 SSLException。
SSLException(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造异常 SSLException（它通常包含 cause 的类和详细消息）。

javax.print 中 Throwable 的使用

javax.print 中 Throwable 的子类
 class PrintException
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

javax.print.attribute 中 Throwable 的使用

javax.print.attribute 中 Throwable 的子类
 class UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

javax.rmi.CORBA 中 Throwable 的使用

参数类型为 Throwable 的 javax.rmi.CORBA 中的方法
static RemoteException Util.wrapException(Throwable orig)
包装由实现方法抛出的异常。
 RemoteException UtilDelegate.wrapException(Throwable obj)
Util.wrapException(java.lang.Throwable) 的委托调用。

javax.script 中 Throwable 的使用

javax.script 中 Throwable 的子类
 class ScriptException
脚本 API 的一般 Exception 类。

javax.security.auth 中 Throwable 的使用

javax.security.auth 中 Throwable 的子类
class | DestroyFailedException 当 destroy 操作失败时，抛出此异常。
class | RefreshFailedException 当 refresh 操作失败时，抛出此异常。

javax.security.auth.callback 中 Throwable 的使用

javax.security.auth.callback 中 Throwable 的子类
 class UnsupportedCallbackException
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.login 中 Throwable 的使用

javax.security.auth.login 中 Throwable 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

javax.security.cert 中 Throwable 的使用

javax.security.cert 中 Throwable 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题之一。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书不再有效异常。
class | CertificateParsingException 证书解析异常。

javax.security.sasl 中 Throwable 的使用

javax.security.sasl 中 Throwable 的子类
class | AuthenticationException 此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
class | SaslException 此类表示在使用 SASL 时所发生的错误。

返回 Throwable 的 javax.security.sasl 中的方法
Throwable | SaslException.getCause()
Throwable | SaslException.initCause(Throwable cause)

参数类型为 Throwable 的 javax.security.sasl 中的方法
 Throwable SaslException.initCause(Throwable cause)

参数类型为 Throwable 的 javax.security.sasl 中的构造方法
AuthenticationException(String detail, Throwable ex)
构造带详细消息和根异常的新 AuthenticationException 实例。
SaslException(String detail, Throwable ex)
构造带详细消息和根异常的新 SaslException 实例。

javax.sound.midi 中 Throwable 的使用

javax.sound.midi 中 Throwable 的子类
class | InvalidMidiDataException 一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
class | MidiUnavailableException 当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

javax.sound.sampled 中 Throwable 的使用

javax.sound.sampled 中 Throwable 的子类
class | LineUnavailableException LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
class | UnsupportedAudioFileException UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

javax.sql.rowset 中 Throwable 的使用

javax.sql.rowset 中 Throwable 的子类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

javax.sql.rowset.serial 中 Throwable 的使用

javax.sql.rowset.serial 中 Throwable 的子类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

javax.sql.rowset.spi 中 Throwable 的使用

javax.sql.rowset.spi 中 Throwable 的子类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

javax.swing 中 Throwable 的使用

javax.swing 中 Throwable 的子类
 class UnsupportedLookAndFeelException
指示在用户系统上不存在请求的外观管理类的异常。

javax.swing.text 中 Throwable 的使用

javax.swing.text 中 Throwable 的子类
class | BadLocationException 此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。
class | ChangedCharSetException 顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

javax.swing.tree 中 Throwable 的使用

javax.swing.tree 中 Throwable 的子类
 class ExpandVetoException
用于阻止扩展/折叠发生的异常。

javax.swing.undo 中 Throwable 的使用

javax.swing.undo 中 Throwable 的子类
class | CannotRedoException 当 UndoableEdit 被通知 redo() 但无法执行时抛出。
class | CannotUndoException 当 UndoableEdit 被通知 undo() 但无法执行时抛出。

javax.transaction 中 Throwable 的使用

javax.transaction 中 Throwable 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Throwable 的使用

javax.transaction.xa 中 Throwable 的子类
 class XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml.bind 中 Throwable 的使用

javax.xml.bind 中 Throwable 的子类
class | JAXBException 这是所有 JAXB 异常的根异常类。
class | PropertyException 此异常指示在获取或设置属性时遇到一个错误。
class | TypeConstraintException 此异常指示已检测到存在违反动态检查的类型约束的情况。
class | ValidationException 此异常指示在执行验证操作时发生错误。

返回 Throwable 的 javax.xml.bind 中的方法
Throwable | JAXBException.getCause()
Throwable | JAXBException.getLinkedException() 获取链接的异常。
Throwable | TypeConstraintException.getLinkedException() 获取链接的异常。
Throwable | ValidationEvent.getLinkedException() 检索此警告/错误的链接异常。

参数类型为 Throwable 的 javax.xml.bind 中的方法
void | JAXBException.setLinkedException(Throwable exception) 添加链接的异常。
void | TypeConstraintException.setLinkedException(Throwable exception) 添加一个链接的异常。

参数类型为 Throwable 的 javax.xml.bind 中的构造方法
JAXBException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。
JAXBException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 JAXBException。
JAXBException(Throwable exception)
构造带有一个 linkedException 的 JAXBException。
MarshalException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。
MarshalException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 MarshalException。
MarshalException(Throwable exception)
构造带有一个 linkedException 的 MarshalException。
PropertyException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。
PropertyException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 PropertyException。
PropertyException(Throwable exception)
构造带有一个 linkedException 的 PropertyException。
TypeConstraintException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。
TypeConstraintException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 TypeConstraintException。
TypeConstraintException(Throwable exception)
构造带有一个 linkedException 的 TypeConstraintException。
UnmarshalException(String message, String errorCode, Throwable exception)
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。
UnmarshalException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 UnmarshalException。
UnmarshalException(Throwable exception)
构造带有一个 linkedException 的 UnmarshalException。
ValidationException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。
ValidationException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 ValidationException。
ValidationException(Throwable exception)
构造带有一个 linkedException 的 ValidationException。

javax.xml.bind.helpers 中 Throwable 的使用

返回 Throwable 的 javax.xml.bind.helpers 中的方法
 Throwable ValidationEventImpl.getLinkedException()

参数类型为 Throwable 的 javax.xml.bind.helpers 中的方法
 void ValidationEventImpl.setLinkedException(Throwable _linkedException)
设置此事件的 linked exception 字段。

参数类型为 Throwable 的 javax.xml.bind.helpers 中的构造方法
NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。
ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ParseConversionEventImpl。
PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 PrintConversionEventImpl。
ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ValidationEventImpl。

javax.xml.crypto 中 Throwable 的使用

javax.xml.crypto 中 Throwable 的子类
class | KeySelectorException 指示由 KeySelector 抛出的异常条件。
class | MarshalException 指示 XML 编组或解组过程中发生的异常条件。
class | NoSuchMechanismException 当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。
class | URIReferenceException 指示取消引用 URIReference 时抛出的异常条件。

返回 Throwable 的 javax.xml.crypto 中的方法
Throwable | KeySelectorException.getCause() 返回此 KeySelectorException 的 cause，如果 cause 不存在或未知，则返回 null。
Throwable | MarshalException.getCause() 返回此 MarshalException 的 cause；如果 cause 不存在或未知，则返回 null。
Throwable | NoSuchMechanismException.getCause() 返回此 NoSuchMechanismException 的 cause，如果 cause 不存在或未知，则返回 null。
Throwable | URIReferenceException.getCause() 返回此 URIReferenceException 的 cause，如果 cause 不存在或未知，则返回 null。

参数类型为 Throwable 的 javax.xml.crypto 中的构造方法
KeySelectorException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 KeySelectorException。
KeySelectorException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 KeySelectorException（它通常包含 cause 的类和详细消息）。
MarshalException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 MarshalException。
MarshalException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的 MarshalException（它通常包含 cause 的类和详细消息）。
NoSuchMechanismException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 NoSuchMechanismException。
NoSuchMechanismException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 NoSuchMechanismException（它通常包含 cause 的类和详细消息）。
URIReferenceException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 URIReferenceException。
URIReferenceException(String message, Throwable cause, URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。
URIReferenceException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 URIReferenceException（它通常包含 cause 的类和详细消息）。

javax.xml.crypto.dsig 中 Throwable 的使用

javax.xml.crypto.dsig 中 Throwable 的子类
class | TransformException 指示执行转换算法时出现异常的异常条件。
class | XMLSignatureException 指示生成或验证 XML 签名过程中发生的异常条件。

返回 Throwable 的 javax.xml.crypto.dsig 中的方法
Throwable | TransformException.getCause() 返回此 TransformException 的 cause，如果 cause 不存在或未知，则返回 null。
Throwable | XMLSignatureException.getCause() 返回此 XMLSignatureException 的 cause；如果 cause 不存在或未知，则返回 null。

参数类型为 Throwable 的 javax.xml.crypto.dsig 中的构造方法
TransformException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 TransformException。
TransformException(Throwable cause)
构造带指定的 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 TransformException（它通常包含 cause 的类和详细消息）。
XMLSignatureException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 XMLSignatureException。
XMLSignatureException(Throwable cause)
构造带指定 cause 和详细消息 (cause==null ? null :cause.toString()) 的新 XMLSignatureException（它通常包含 cause 的类和详细消息）。

javax.xml.datatype 中 Throwable 的使用

javax.xml.datatype 中 Throwable 的子类
 class DatatypeConfigurationException
指示严重的配置错误。

参数类型为 Throwable 的 javax.xml.datatype 中的构造方法
DatatypeConfigurationException(String message, Throwable cause)
创建带有指定详细消息和原因的新 DatatypeConfigurationException。
DatatypeConfigurationException(Throwable cause)
使用指定的原因创建一个新的 DatatypeConfigurationException。

javax.xml.parsers 中 Throwable 的使用

javax.xml.parsers 中 Throwable 的子类
class | FactoryConfigurationError 当解析器工厂的配置存在问题时抛出该异常。
class | ParserConfigurationException 指示一个严重的配置错误。

javax.xml.soap 中 Throwable 的使用

javax.xml.soap 中 Throwable 的子类
 class SOAPException
当发生 SOAP 异常时，抛出此异常。

返回 Throwable 的 javax.xml.soap 中的方法
Throwable | SOAPException.getCause() 返回此 SOAPException 中嵌入的 Throwable 对象（如果有）。
Throwable | SOAPException.initCause(Throwable cause) 使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。

参数类型为 Throwable 的 javax.xml.soap 中的方法
 Throwable SOAPException.initCause(Throwable cause)
使用给定的 Throwable 对象初始化此 SOAPException 对象的 cause 字段。

参数类型为 Throwable 的 javax.xml.soap 中的构造方法
SOAPException(String reason, Throwable cause)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。
SOAPException(Throwable cause)
构造使用给定 Throwable 对象初始化的 SOAPException 对象。

javax.xml.stream 中 Throwable 的使用

javax.xml.stream 中 Throwable 的子类
 class XMLStreamException
用于不可预料处理错误的基本异常。

声明为 Throwable 的 javax.xml.stream 中的字段
protected  Throwable XMLStreamException.nested

返回 Throwable 的 javax.xml.stream 中的方法
 Throwable XMLStreamException.getNestedException()
获取嵌套异常。

参数类型为 Throwable 的 javax.xml.stream 中的构造方法
XMLStreamException(String msg, Location location, Throwable th)
构造具有关联消息、异常和位置的异常。
XMLStreamException(String msg, Throwable th)
构造具有关联消息和异常的异常
XMLStreamException(Throwable th)
构造具有关联异常的异常

javax.xml.transform 中 Throwable 的使用

javax.xml.transform 中 Throwable 的子类
class | TransformerConfigurationException 指示严重的配置错误。
class | TransformerException 此类指定了转换过程中发生的异常条件。
class | TransformerFactoryConfigurationError 当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

返回 Throwable 的 javax.xml.transform 中的方法
Throwable | TransformerException.getCause() 返回此抛出对象的原因，如果原因不存在或未知，则返回 null。
Throwable | TransformerException.getException() 此方法检索此异常所包装的异常。
Throwable | TransformerException.initCause(Throwable cause) 将此抛出对象的原因 初始化为指定值。

参数类型为 Throwable 的 javax.xml.transform 中的方法
 Throwable TransformerException.initCause(Throwable cause)
将此抛出对象的原因 初始化为指定值。

参数类型为 Throwable 的 javax.xml.transform 中的构造方法
TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
包装了 TransformerConfigurationException 中的现有异常。
TransformerConfigurationException(String msg, Throwable e)
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。
TransformerConfigurationException(Throwable e)
创建带有错误的给定 Exception 基本原因的新 TransformerConfigurationException。
TransformerException(String message, SourceLocator locator, Throwable e)
包装了 TransformerException 中的现有异常。
TransformerException(String message, Throwable e)
包装 TransformerException 中的一个现有异常。
TransformerException(Throwable e)
创建一个包装了现有异常的新 TransformerException。

javax.xml.ws 中 Throwable 的使用

javax.xml.ws 中 Throwable 的子类
 class WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

参数类型为 Throwable 的 javax.xml.ws 中的构造方法
ProtocolException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新运行时异常。
ProtocolException(Throwable cause)
构造具有指定 cause 和详细消息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新运行时异常。
WebServiceException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新异常。
WebServiceException(Throwable cause)
构造具有指定 cause 和详细信息 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）的新 WebServiceException。

javax.xml.ws.http 中 Throwable 的使用

javax.xml.ws.http 中 Throwable 的子类
 class HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Throwable 的使用

javax.xml.ws.soap 中 Throwable 的子类
 class SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.xpath 中 Throwable 的使用

javax.xml.xpath 中 Throwable 的子类
class | XPathException XPathException 表示通用 XPath 异常。
class | XPathExpressionException XPathExpressionException 表示 XPath 表达式中的错误。
class | XPathFactoryConfigurationException XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。
class | XPathFunctionException XPathFunctionException 表示 XPath 函数的错误。

返回 Throwable 的 javax.xml.xpath 中的方法
 Throwable XPathException.getCause()
获取此 XPathException 的 cause。

参数类型为 Throwable 的 javax.xml.xpath 中的构造方法
XPathException(Throwable cause)
构造带指定 cause 的新 XPathException。
XPathExpressionException(Throwable cause)
构造带指定 cause 的新 XPathExpressionException。
XPathFactoryConfigurationException(Throwable cause)
构造带指定 cause 的新 XPathFactoryConfigurationException。
XPathFunctionException(Throwable cause)
构造带指定 cause 的新 XPathFunctionException。

org.ietf.jgss 中 Throwable 的使用

org.ietf.jgss 中 Throwable 的子类
 class GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

org.omg.CORBA 中 Throwable 的使用

org.omg.CORBA 中 Throwable 的子类
class | ACTIVITY_COMPLETED ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。
class | ACTIVITY_REQUIRED ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。
class | BAD_CONTEXT 当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。
class | BAD_INV_ORDER 此异常指示调用者按错误顺序调用了操作。
class | BAD_OPERATION 当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。
class | BAD_PARAM 当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。
class | BAD_QOS 只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。
class | BAD_TYPECODE 当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。
class | Bounds 当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。
class | CODESET_INCOMPATIBLE 当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。
class | COMM_FAILURE 如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。
class | DATA_CONVERSION 如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。
class | FREE_MEM 当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。
class | IMP_LIMIT 此异常指示在 OBR 运行时超过了某一项实现限制。
class | INITIALIZE ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。
class | INTERNAL 此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。
class | INTF_REPOS 当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。
class | INV_FLAG 在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。
class | INV_IDENT 此异常指示 IDL 标识符在语法上是无效的。
class | INV_OBJREF 此异常指示对象引用存在内部错误。
class | INV_POLICY 当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。
class | INVALID_ACTIVITY 如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。
class | INVALID_TRANSACTION 当请求带有无效的事务上下文时，抛出此异常。
class | MARSHAL 表示网络中传来的请求或应答在结构上无效。
class | NO_IMPLEMENT 此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。
class | NO_MEMORY 如果 ORB 运行时出现内存不足，则抛出此异常。
class | NO_PERMISSION 当因为调用者没有足够的权限而导致调用失败时，抛出此异常。
class | NO_RESOURCES 当 ORB 遇到一些一般资源限制时，抛出此异常。
class | NO_RESPONSE 如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。
class | OBJ_ADAPTER 此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。
class | OBJECT_NOT_EXIST 只要在已删除的对象上执行调用，就会引发此异常。
class | PERSIST_STORE 此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。
class | PolicyError 发生策略错误时抛出的用户异常。
class | REBIND 如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。
class | SystemException 所有 CORBA 标准异常的根类。
class | TIMEOUT 当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。
class | TRANSACTION_MODE 如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。
class | TRANSACTION_REQUIRED 此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。
class | TRANSACTION_ROLLEDBACK 当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。
class | TRANSACTION_UNAVAILABLE 当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。
class | TRANSIENT 当 ORB 试图到达某一对象但失败时，抛出此异常。
class | UNKNOWN 如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。
class | UnknownUserException 包含由服务器返回的用户异常的类。
class | UserException CORBA IDL 定义的用户异常的根类。
class | WrongTransaction CORBA WrongTransaction 用户定义异常。

org.omg.CORBA.DynAnyPackage 中 Throwable 的使用

org.omg.CORBA.DynAnyPackage 中 Throwable 的子类
class | Invalid 动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。
class | InvalidSeq 任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。
class | InvalidValue
class | TypeMismatch 动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Throwable 的使用

org.omg.CORBA.ORBPackage 中 Throwable 的子类
class | InconsistentTypeCode 当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。
class | InvalidName 当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Throwable 的使用

org.omg.CORBA.portable 中 Throwable 的子类
class | ApplicationException 此类用来报告 ORB 和 stub 之间的应用程序级异常。
class | IndirectionException Indirection 异常是一个特定于 Java 的系统异常。
class | RemarshalException 此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。
class | UnknownException org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

声明为 Throwable 的 org.omg.CORBA.portable 中的字段
 Throwable UnknownException.originalEx
一个 throwable 对象，包装在 CORBA UnknownException 中的原始异常。

参数类型为 Throwable 的 org.omg.CORBA.portable 中的构造方法
UnknownException(Throwable ex)
构造一个 UnknownException 对象。

org.omg.CORBA.TypeCodePackage 中 Throwable 的使用

org.omg.CORBA.TypeCodePackage 中 Throwable 的子类
 class BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming.NamingContextExtPackage 中 Throwable 的使用

org.omg.CosNaming.NamingContextExtPackage 中 Throwable 的子类
 class InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

org.omg.CosNaming.NamingContextPackage 中 Throwable 的使用

org.omg.CosNaming.NamingContextPackage 中 Throwable 的子类
class | AlreadyBound org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。
class | CannotProceed org/omg/CosNaming/NamingContextPackage/CannotProceed.java。
class | NotEmpty org/omg/CosNaming/NamingContextPackage/NotEmpty.java。
class | NotFound org/omg/CosNaming/NamingContextPackage/NotFound.java。

org.omg.IOP.CodecFactoryPackage 中 Throwable 的使用

org.omg.IOP.CodecFactoryPackage 中 Throwable 的子类
 class UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

org.omg.IOP.CodecPackage 中 Throwable 的使用

org.omg.IOP.CodecPackage 中 Throwable 的子类
class | FormatMismatch org/omg/IOP/CodecPackage/FormatMismatch.java。
class | InvalidTypeForEncoding org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

org.omg.PortableInterceptor 中 Throwable 的使用

org.omg.PortableInterceptor 中 Throwable 的子类
 class InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Throwable 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Throwable 的子类
 class DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

org.omg.PortableServer 中 Throwable 的使用

org.omg.PortableServer 中 Throwable 的子类
 class ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

org.omg.PortableServer.CurrentPackage 中 Throwable 的使用

org.omg.PortableServer.CurrentPackage 中 Throwable 的子类
 class NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

org.omg.PortableServer.POAManagerPackage 中 Throwable 的使用

org.omg.PortableServer.POAManagerPackage 中 Throwable 的子类
 class AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

org.omg.PortableServer.POAPackage 中 Throwable 的使用

org.omg.PortableServer.POAPackage 中 Throwable 的子类
class | AdapterAlreadyExists org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。
class | AdapterNonExistent org/omg/PortableServer/POAPackage/AdapterNonExistent.java。
class | InvalidPolicy org/omg/PortableServer/POAPackage/InvalidPolicy.java。
class | NoServant org/omg/PortableServer/POAPackage/NoServant.java。
class | ObjectAlreadyActive org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。
class | ObjectNotActive org/omg/PortableServer/POAPackage/ObjectNotActive.java。
class | ServantAlreadyActive org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。
class | ServantNotActive org/omg/PortableServer/POAPackage/ServantNotActive.java。
class | WrongAdapter org/omg/PortableServer/POAPackage/WrongAdapter.java。
class | WrongPolicy org/omg/PortableServer/POAPackage/WrongPolicy.java。

org.w3c.dom 中 Throwable 的使用

org.w3c.dom 中 Throwable 的子类
 class DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

org.w3c.dom.events 中 Throwable 的使用

org.w3c.dom.events 中 Throwable 的子类
 class EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Throwable 的使用

org.w3c.dom.ls 中 Throwable 的子类
 class LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Throwable 的使用

org.xml.sax 中 Throwable 的子类
class | SAXException 封装一般的 SAX 错误或警告。
class | SAXNotRecognizedException 用于未识别的标识符的 Exception 类。
class | SAXNotSupportedException 用于不被支持的操作的 Exception 类。
class | SAXParseException 封装 XML 解析错误或警告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.System 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.System
的使用

没有 java.lang.System 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.ClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.ClassLoader
的使用

使用 ClassLoader 的软件包
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.activation |
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.parsers | 提供允许处理 XML 文档的类。
javax.xml.stream |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt.datatransfer 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.awt.datatransfer 中的方法
protected static Class<?> DataFlavor.tryToLoadClass(String className, ClassLoader fallback)
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

参数类型为 ClassLoader 的 java.awt.datatransfer 中的构造方法
DataFlavor(String mimeType, String humanPresentableName, ClassLoader classLoader)
构造一个表示 MimeType 的 DataFlavor。

java.beans 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.beans 中的方法
static Object | Beans.instantiate(ClassLoader cls, String beanName) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext) 实例化 JavaBean。
static Object | Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer) 实例化 bean。

参数类型为 ClassLoader 的 java.beans 中的构造方法
XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

java.lang 中 ClassLoader 的使用

返回 ClassLoader 的 java.lang 中的方法
protected ClassLoader | SecurityManager.currentClassLoader() 已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
ClassLoader | Class.getClassLoader() 返回该类的类加载器。
ClassLoader | Thread.getContextClassLoader() 返回该线程的上下文 ClassLoader。
ClassLoader | ClassLoader.getParent() 返回委托的父类加载器。
static ClassLoader | ClassLoader.getSystemClassLoader() 返回委托的系统类加载器。

参数类型为 ClassLoader 的 java.lang 中的方法
static Class<?> | Class.forName(String name, boolean initialize, ClassLoader loader) 使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
void | Thread.setContextClassLoader(ClassLoader cl) 设置该线程的上下文 ClassLoader。

参数类型为 ClassLoader 的 java.lang 中的构造方法
ClassLoader(ClassLoader parent)
使用指定的、用于委托操作的父类加载器创建新的类加载器。

java.lang.instrument 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.lang.instrument 中的方法
Class[] | Instrumentation.getInitiatedClasses(ClassLoader loader) 返回所有初始化加载器是 loader 的类的数组。
byte[] | ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer) 此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

java.lang.reflect 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.lang.reflect 中的方法
static Class<?> | Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces) 返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
static Object | Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h) 返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

java.net 中 ClassLoader 的使用

java.net 中 ClassLoader 的子类
 class URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。

参数类型为 ClassLoader 的 java.net 中的方法
static URLClassLoader URLClassLoader.newInstance(URL[] urls, ClassLoader parent)
为指定的 URL 和父类加载器创建新 URLClassLoader 实例。

参数类型为 ClassLoader 的 java.net 中的构造方法
URLClassLoader(URL[] urls, ClassLoader parent)
为给定的 URL 构造新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。

java.rmi.server 中 ClassLoader 的使用

返回 ClassLoader 的 java.rmi.server 中的方法
static ClassLoader RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。
abstract  ClassLoader RMIClassLoaderSpi.getClassLoader(String codebase)
提供 RMIClassLoader.getClassLoader(String) 的实现。

参数类型为 ClassLoader 的 java.rmi.server 中的方法
 Object LoaderHandler.getSecurityContext(ClassLoader loader)
已过时。 无替代版本
static Object RMIClassLoader.getSecurityContext(ClassLoader loader)
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

java.security 中 ClassLoader 的使用

java.security 中 ClassLoader 的子类
 class SecureClassLoader
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。

返回 ClassLoader 的 java.security 中的方法
 ClassLoader ProtectionDomain.getClassLoader()
返回此域的 ClassLoader。

参数类型为 ClassLoader 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。
SecureClassLoader(ClassLoader parent)
使用指定的父类加载器为委托创建新 SecureClassLoader。

java.util 中 ClassLoader 的使用

参数类型为 ClassLoader 的 java.util 中的方法
static void ResourceBundle.clearCache(ClassLoader loader)
从已经使用给定类加载器加载的缓存中移除所有资源包。
static ResourceBundle ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader)
使用指定的基本名称、语言环境和类加载器获取资源包。
static ResourceBundle ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service, ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。
 boolean ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
 ResourceBundle ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

javax.activation 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.activation 中的方法
 Object CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader)
返回已实例化的 JavaBean 组件。

javax.imageio.spi 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.imageio.spi 中的方法
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass, ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。

javax.management 中 ClassLoader 的使用

返回 ClassLoader 的 javax.management 中的方法
ClassLoader | MBeanServer.getClassLoader(ObjectName loaderName) 返回指定的 ClassLoader。
ClassLoader | MBeanServer.getClassLoaderFor(ObjectName mbeanName) 返回用于加载指定 MBean 的类的 ClassLoader。

参数类型为 ClassLoader 的 javax.management 中的方法
static Class DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className)
已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

javax.management.loading 中 ClassLoader 的使用

javax.management.loading 中 ClassLoader 的子类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

参数类型为 ClassLoader 的 javax.management.loading 中的方法
Class<?> | ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className) 通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
Class<?> | ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className) 通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。

参数类型为 ClassLoader 的 javax.management.loading 中的构造方法
MLet(URL[] urls, ClassLoader parent)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
PrivateMLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。

javax.management.remote.rmi 中 ClassLoader 的使用

返回 ClassLoader 的 javax.management.remote.rmi 中的方法
 ClassLoader RMIServerImpl.getDefaultClassLoader()
获得此连接器服务器使用的默认 ClassLoader。

参数类型为 ClassLoader 的 javax.management.remote.rmi 中的方法
 void RMIServerImpl.setDefaultClassLoader(ClassLoader cl)
设置此连接器服务器的默认 ClassLoader。

参数类型为 ClassLoader 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

javax.rmi.CORBA 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.rmi.CORBA 中的方法
static Class Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。
 Class UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。

javax.script 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.script 中的构造方法
ScriptEngineManager(ClassLoader loader)
此构造方法使用服务调用者机制加载对于给定 ClassLoader 可见的 ScriptEngineFactory 实现。

javax.swing 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.swing 中的方法
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader) get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。
static void | JEditorPane.registerEditorKitForContentType(String type, String classname, ClassLoader loader) 建立 type 到 classname 的默认绑定。

javax.tools 中 ClassLoader 的使用

返回 ClassLoader 的 javax.tools 中的方法
ClassLoader | ForwardingJavaFileManager.getClassLoader(JavaFileManager.Location location)
ClassLoader | JavaFileManager.getClassLoader(JavaFileManager.Location location) 获取可从给定位置加载插件的类加载器。
static ClassLoader | ToolProvider.getSystemToolClassLoader() 返回此平台提供的工具的类加载器。

javax.xml.bind 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.bind 中的方法
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties) 获得 JAXBContext 类的新实例。

javax.xml.datatype 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.datatype 中的方法
static DatatypeFactory DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 DatatypeFactory 实例。

javax.xml.parsers 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.parsers 中的方法
static SAXParserFactory | SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 SAXParserFactory 实例。
static DocumentBuilderFactory | DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader) 从类名称中获取新的 DocumentBuilderFactory 实例。

javax.xml.stream 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.stream 中的方法
static XMLEventFactory | XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个新的工厂实例。
static XMLInputFactory | XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader) 创建一个的新工厂实例。

javax.xml.transform 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.transform 中的方法
static TransformerFactory TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 TransformerFactory 实例。

javax.xml.validation 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.validation 中的方法
static SchemaFactory SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 SchemaFactory 实例。

javax.xml.xpath 中 ClassLoader 的使用

参数类型为 ClassLoader 的 javax.xml.xpath 中的方法
static XPathFactory XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
根据工厂类名称获取一个新 XPathFactory 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.Cloneable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Cloneable
的使用

使用 Cloneable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.geom | 提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.awt.print | 为通用的打印 API 提供类和接口。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.crypto | 为加密操作提供类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.rtf | 提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.xml.datatype | XML/Java 类型映射关系。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.awt 中 Cloneable 的使用

实现 Cloneable 的 java.awt 中的类
class | BufferCapabilities 缓冲区的能力和属性。
class | Dimension Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。
class | GridBagConstraints GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。
class | ImageCapabilities 图像的功能和属性。
class | Insets Insets 对象是容器边界的表示形式。
class | JobAttributes 控制打印作业的属性集合。
class | PageAttributes 用来控制打印页面输出的属性集。
class | Point 表示 (x,y) 坐标空间中的位置的点，以整数精度指定。
class | Rectangle Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。
class | RenderingHints RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。

java.awt.datatransfer 中 Cloneable 的使用

实现 Cloneable 的 java.awt.datatransfer 中的类
 class DataFlavor
DataFlavor 提供有关数据的元信息。

java.awt.font 中 Cloneable 的使用

实现 Cloneable 的 java.awt.font 中的类
class | GlyphVector GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。
class | TextLayout TextLayout 是样式字符数据的不可变图形表示形式。
class | TextMeasurer TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。

java.awt.geom 中 Cloneable 的使用

实现 Cloneable 的 java.awt.geom 中的类
class | AffineTransform AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。
class | Arc2D Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。
static class | Arc2D.Double 此类定义以 double 精度指定的弧。
static class | Arc2D.Float 此类定义以 float 精度指定的弧。
class | Area Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。
class | CubicCurve2D CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。
static class | CubicCurve2D.Double 使用 double 坐标指定的三次参数曲线段。
static class | CubicCurve2D.Float 使用 float 坐标指定的三次参数曲线段。
class | Dimension2D Dimension2D 类用于封装宽度和高度尺寸。
class | Ellipse2D Ellipse2D 类描述窗体矩形定义的椭圆。
static class | Ellipse2D.Double Double 类以 double 精度定义椭圆。
static class | Ellipse2D.Float Float 类以 float 精度定义椭圆。
class | GeneralPath GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。
class | Line2D Line2D 表示 (x,y) 坐标空间中的线段。
static class | Line2D.Double 使用 double 坐标指定的线段。
static class | Line2D.Float 使用 float 坐标指定的线段。
class | Path2D Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。
static class | Path2D.Double Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。
static class | Path2D.Float Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。
class | Point2D Point2D 类定义表示 (x,y) 坐标空间中位置的点。
static class | Point2D.Double Double 类以 double 精度定义指定的点。
static class | Point2D.Float Float 类以 float 精度定义指定的点。
class | QuadCurve2D QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。
static class | QuadCurve2D.Double 使用 double 坐标指定的二次参数曲线段。
static class | QuadCurve2D.Float 使用 float 坐标指定的二次参数曲线段。
class | Rectangle2D Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。
static class | Rectangle2D.Double Double 类定义一个在 double 坐标中指定的矩形。
static class | Rectangle2D.Float Float 类定义一个在 float 坐标中指定的矩形。
class | RectangularShape RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。
class | RoundRectangle2D RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。
static class | RoundRectangle2D.Double Double 类定义一个所有圆角都使用 double 坐标指定的矩形。
static class | RoundRectangle2D.Float Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

java.awt.image 中 Cloneable 的使用

实现 Cloneable 的 java.awt.image 中的类
class | AreaAveragingScaleFilter 这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。
class | BufferedImageFilter BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。
class | CropImageFilter 用于裁剪图像的 ImageFilter 类。
class | ImageFilter 此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。
class | Kernel Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。
class | ReplicateScaleFilter 使用最简单的算法缩放图像的 ImageFilter 类。
class | RGBImageFilter 此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

java.awt.image.renderable 中 Cloneable 的使用

实现 Cloneable 的 java.awt.image.renderable 中的类
class | ParameterBlock ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。
class | RenderContext RenderContext 封装从 enderableImage 生成特定呈现所需的信息。

java.awt.print 中 Cloneable 的使用

实现 Cloneable 的 java.awt.print 中的类
class | PageFormat PageFormat 类描述要打印的页面大小和方向。
class | Paper Paper 类描述一张纸的物理特征。

java.net 中 Cloneable 的使用

实现 Cloneable 的 java.net 中的类
 class HttpCookie
HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。

java.security 中 Cloneable 的使用

实现 Cloneable 的 java.security 中的类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.security.acl 中 Cloneable 的使用

java.security.acl 中 Cloneable 的子接口
 interface AclEntry
这是用于表示访问控制列表 (ACL) 中某个项的接口。

java.security.cert 中 Cloneable 的使用

java.security.cert 中 Cloneable 的子接口
interface | CertPathBuilderResult 证书路径生成器算法的结果的规范。
interface | CertPathParameters 证书路径算法参数的规范。
interface | CertPathValidatorResult 证书路径验证器算法的结果的规范。
interface | CertSelector 一个定义了一套选择 Certificate 的标准的选择器。
interface | CertStoreParameters CertStore 参数的规范。
interface | CRLSelector 一个定义了一套选择 CRL 的标准的选择器。

实现 Cloneable 的 java.security.cert 中的类
class | CollectionCertStoreParameters 用作 Collection CertStore 算法输入的参数。
class | LDAPCertStoreParameters 用作 LDAP CertStore 算法的输入的参数。
class | PKIXBuilderParameters 用作 PKIX CertPathBuilder 算法的输入的参数。
class | PKIXCertPathBuilderResult 此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。
class | PKIXCertPathChecker 对 X509Certificate 执行一种或多种检查的抽象类。
class | PKIXCertPathValidatorResult 此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。
class | PKIXParameters 用作 PKIX CertPathValidator 算法的输入的参数。
class | X509CertSelector 选择与所有指定标准匹配的 X509Certificates 的 CertSelector。
class | X509CRLSelector 选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。

java.sql 中 Cloneable 的使用

实现 Cloneable 的 java.sql 中的类
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
class | Timestamp 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。

java.text 中 Cloneable 的使用

java.text 中 Cloneable 的子接口
interface | AttributedCharacterIterator AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
interface | CharacterIterator 此接口定义了对文本进行双向迭代的协议。

实现 Cloneable 的 java.text 中的类
class | BreakIterator BreakIterator 类实现用于查找文本中边界位置的方法。
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | Collator Collator 类执行区分语言环境的 String 比较。
class | DateFormat DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
class | DateFormatSymbols DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
class | DecimalFormatSymbols 此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
class | Format Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
class | MessageFormat MessageFormat 提供了以与语言无关方式生成连接消息的方式。
class | NumberFormat NumberFormat 是所有数值格式的抽象基类。
class | RuleBasedCollator RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。
class | SimpleDateFormat SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。
class | StringCharacterIterator StringCharacterIterator 为 String 实现 CharacterIterater 协议。

java.util 中 Cloneable 的使用

实现 Cloneable 的 java.util 中的类
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | BitSet 此类实现了一个按需增长的位向量。
class | Calendar Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
class | Date 类 Date 表示特定的瞬间，精确到毫秒。
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | GregorianCalendar GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Locale Locale 对象表示了特定的地理、政治和文化地区。
class | Properties Properties 类表示了一个持久的属性集。
class | SimpleTimeZone SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TimeZone TimeZone 表示时区偏移量，也可以计算夏令时。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 Cloneable 的使用

实现 Cloneable 的 java.util.concurrent 中的类
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

java.util.jar 中 Cloneable 的使用

实现 Cloneable 的 java.util.jar 中的类
class | Attributes Attributes 类将 Manifest 属性名称映射到关联的字符串值。
class | JarEntry 此类用于表示 JAR 文件条目。
class | Manifest Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。

java.util.zip 中 Cloneable 的使用

实现 Cloneable 的 java.util.zip 中的类
 class ZipEntry
此类用于表示 ZIP 文件条目。

javax.activation 中 Cloneable 的使用

实现 Cloneable 的 javax.activation 中的类
 class ActivationDataFlavor
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。

javax.crypto 中 Cloneable 的使用

实现 Cloneable 的 javax.crypto 中的类
 class Mac
此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。

javax.management 中 Cloneable 的使用

javax.management 中 Cloneable 的子接口
 interface Descriptor
JMX 元素的附加元数据。

实现 Cloneable 的 javax.management 中的类
class | AttributeList 表示 MBean 属性值的列表。
class | ImmutableDescriptor 不可变的描述符。
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanInfo 描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。

javax.management.modelmbean 中 Cloneable 的使用

实现 Cloneable 的 javax.management.modelmbean 中的类
class | DescriptorSupport 此类表示 ModelMBean 元素的元数据集。
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanInfoSupport 此类表示 ModelMBean 的元数据。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

javax.management.openmbean 中 Cloneable 的使用

实现 Cloneable 的 javax.management.openmbean 中的类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanInfoSupport OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。
class | TabularDataSupport TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

javax.management.relation 中 Cloneable 的使用

实现 Cloneable 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.naming 中 Cloneable 的使用

javax.naming 中 Cloneable 的子接口
 interface Name
Name 接口表示一个一般名称，即一个有序的组件序列。

实现 Cloneable 的 javax.naming 中的类
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。
class | LinkRef 此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。
class | Reference 此类表示对存在于命名/目录系统以外的对象的引用。

javax.naming.directory 中 Cloneable 的使用

javax.naming.directory 中 Cloneable 的子接口
interface | Attribute 此接口表示与命名对象关联的属性。
interface | Attributes 此接口表示属性的集合。

实现 Cloneable 的 javax.naming.directory 中的类
class | BasicAttribute 此类提供 Attribute 接口的基本实现。
class | BasicAttributes 此类提供 Attributes 接口的基本实现。

javax.naming.ldap 中 Cloneable 的使用

实现 Cloneable 的 javax.naming.ldap 中的类
 class LdapName
此类表示 RFC 2253 指定的标识名。

javax.print 中 Cloneable 的使用

实现 Cloneable 的 javax.print 中的类
class | DocFlavor 类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
static class | DocFlavor.BYTE_ARRAY 类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.CHAR_ARRAY 类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.INPUT_STREAM 类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.READER 类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.SERVICE_FORMATTED 类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
static class | DocFlavor.STRING 类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.URL 类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。

javax.print.attribute 中 Cloneable 的使用

实现 Cloneable 的 javax.print.attribute 中的类
class | DateTimeSyntax 类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
class | EnumSyntax 类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
class | IntegerSyntax 类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
class | ResolutionSyntax 类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
class | SetOfIntegerSyntax 类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
class | Size2DSyntax 类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
class | TextSyntax 类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
class | URISyntax 类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

javax.print.attribute.standard 中 Cloneable 的使用

实现 Cloneable 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReason JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
class | JobStateReasons JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaSize MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReason PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterStateReasons PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。
class | ReferenceUriSchemesSupported ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
class | Severity Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

javax.sound.midi 中 Cloneable 的使用

实现 Cloneable 的 javax.sound.midi 中的类
class | MetaMessage MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
class | MidiMessage MidiMessage 是 MIDI 消息的基类。
class | ShortMessage ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
class | SysexMessage 表示 MIDI 系统独占消息 SysexMessage 对象。

javax.sql.rowset 中 Cloneable 的使用

实现 Cloneable 的 javax.sql.rowset 中的类
 class BaseRowSet
提供一个具有基本功能的 RowSet 对象的抽象类。

javax.sql.rowset.serial 中 Cloneable 的使用

实现 Cloneable 的 javax.sql.rowset.serial 中的类
class | SerialArray 序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。
class | SerialBlob SQL BLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialClob SQL CLOB 值在 Java 编程语言中的序列化映射关系。
class | SerialDatalink SQL DATALINK 值在 Java 编程语言中的序列化映射关系。
class | SerialJavaObject SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。
class | SerialRef Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。
class | SerialStruct SQL 结构类型在 Java 编程语言中的序列化映射关系。

javax.swing 中 Cloneable 的使用

实现 Cloneable 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
class | DefaultListSelectionModel 列表选择的默认数据模型。
class | GrayFilter 一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。
static class | JTree.DynamicUtilTreeNode DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
protected static class | JTree.EmptySelectionModel EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
class | UIDefaults Swing 组件的默认值表。

javax.swing.plaf 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.plaf 中的类
class | DimensionUIResource
class | InsetsUIResource

javax.swing.plaf.basic 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.plaf.basic 中的类
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
static class | BasicTextUI.BasicCaret
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

javax.swing.plaf.metal 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.plaf.metal 中的类
protected  class MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

javax.swing.text 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.text 中的类
class | DateFormatter DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。
class | DefaultCaret 插入符的默认实现。
class | DefaultEditorKit 这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
class | DefaultFormatter DefaultFormatter 格式化任意对象。
class | EditorKit 针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。
class | ElementIterator ElementIterator，顾名思义，沿 Element 树进行迭代。
class | GlyphView GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。
class | InternationalFormatter InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。
class | LabelView LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。
class | MaskFormatter MaskFormatter 用于格式化和编辑字符串。
class | NumberFormatter 添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。
class | Segment 表示文本片段的字符数组的 segment。
class | SimpleAttributeSet 使用哈希表的 MutableAttributeSet 的直接实现。
class | StyledEditorKit 这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

javax.swing.text.html 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.text.html 中的类
class | HTMLEditorKit Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
class | InlineView 显示基于 css 属性的 inline element 样式。

javax.swing.text.rtf 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.text.rtf 中的类
 class RTFEditorKit
这是对 RTF 编辑功能的默认实现。

javax.swing.tree 中 Cloneable 的使用

实现 Cloneable 的 javax.swing.tree 中的类
class | DefaultMutableTreeNode DefaultMutableTreeNode 是树数据结构中的通用节点。
class | DefaultTreeSelectionModel TreeSelectionModel 的默认实现。

javax.xml.datatype 中 Cloneable 的使用

实现 Cloneable 的 javax.xml.datatype 中的类
 class XMLGregorianCalendar
W3C XML 模式 1.0 日期/时间数据类型的表示形式。

org.ietf.jgss 中 Cloneable 的使用

org.ietf.jgss 中 Cloneable 的子接口
 interface GSSCredential
此接口将为实体封装 GSS-API 凭据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Class 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.lang.Class
的使用

使用 Class 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent.atomic | 类的小工具包，支持在单个变量上解除锁的线程安全编程。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
javax.activation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.crypto | 为加密操作提供类和接口。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA_2_3.portable | 提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。
org.omg.DynamicAny | 提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。
org.omg.PortableServer | 提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

java.awt 中 Class 的使用

参数类型为 Class 的 java.awt 中的方法
<T extends DragGestureRecognizer>
T
Toolkit.createDragGestureRecognizer(Class<T> abstractRecognizerClass, DragSource ds, Component c, int srcActions, DragGestureListener dgl)
创建所请求的抽象 DragGestureRecognizer 类的具体的、与平台有关的子类，并将它与指定的 DragSource、Component 和 DragGestureListener 关联。
<T extends EventListener>
T[]
Button.getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Checkbox.getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
CheckboxMenuItem.getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Choice.getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
List.getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Scrollbar.getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
TextComponent.getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
TextField.getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
MenuItem.getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Window.getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
Container.getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Component.getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
protected static void AWTKeyStroke.registerSubclass(Class<?> subclass)
注册一个新类，AWTKeyStroke 中的工厂方法在生成 AWTKeyStroke 的新实例时将使用它。

java.awt.datatransfer 中 Class 的使用

返回 Class 的 java.awt.datatransfer 中的方法
Class<?> | DataFlavor.getDefaultRepresentationClass()
Class<?> | DataFlavor.getRepresentationClass() 返回请求此 DataFlavor 时，支持此 DataFlavor 的对象将返回的 Class。
protected static Class<?> | DataFlavor.tryToLoadClass(String className, ClassLoader fallback) 试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

参数类型为 Class 的 java.awt.datatransfer 中的构造方法
DataFlavor(Class<?> representationClass, String humanPresentableName)
构造一个表示 Java 类的 DataFlavor。

java.awt.dnd 中 Class 的使用

参数类型为 Class 的 java.awt.dnd 中的方法
<T extends DragGestureRecognizer>
T
DragSource.createDragGestureRecognizer(Class<T> recognizerAbstractClass, Component c, int actions, DragGestureListener dgl)
创建一个新的 DragGestureRecognizer，实现 DragGestureRecognizer 的指定抽象子类并在新创建的对象上设置指定的 Component 和 DragGestureListener。
<T extends EventListener>
T[]
DragSource.getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。

java.awt.image.renderable 中 Class 的使用

返回 Class 的 java.awt.image.renderable 中的方法
 Class[] ParameterBlock.getParamClasses()
返回描述该参数的 Class 对象的数组。

java.beans 中 Class 的使用

返回 Class 的 java.beans 中的方法
Class<?> | BeanDescriptor.getBeanClass() 获得 bean 的 Class 对象。
Class<?> | BeanDescriptor.getCustomizerClass() 获得 bean 的 customizer 的 Class 对象。
Class<?> | IndexedPropertyDescriptor.getIndexedPropertyType() 获得索引属性类型的 Class 对象。
Class<?> | EventSetDescriptor.getListenerType() 获得目标接口的 Class 对象。
Class<?> | PropertyDescriptor.getPropertyEditorClass() 获得已为此属性注册的任何显式 PropertyEditor Class。
Class<?> | PropertyDescriptor.getPropertyType() 获得属性的 Class 对象。

参数类型为 Class 的 java.beans 中的方法
static
<T> T
EventHandler.create(Class<T> listenerInterface, Object target, String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。
static
<T> T
EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
static
<T> T
EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。
static PropertyEditor PropertyEditorManager.findEditor(Class<?> targetType)
查找给定目标类型的值编辑器。
static void Introspector.flushFromCaches(Class<?> clz)
刷新给定类的 Introspector 的内部缓存信息。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass)
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass)
在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass, Class<?> stopClass)
在给定的“断”点之下，在 Java Bean 上进行内省，了解其所有属性和公开的方法。
static BeanInfo Introspector.getBeanInfo(Class<?> beanClass, int flags)
在 Java Bean 上进行内省，了解其所有属性、公开的方法和事件，并将结果用一些控制标记表示。
static Object Beans.getInstanceOf(Object bean, Class<?> targetType)
从给定 bean 中获得表示源对象的指定类型视图的对象。
 PersistenceDelegate Encoder.getPersistenceDelegate(Class<?> type)
返回给定类型的持久委托。
protected  void DefaultPersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。
protected  void PersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。
static boolean Beans.isInstanceOf(Object bean, Class<?> targetType)
检查是否可以将 bean 视为给定目标类型。
static void PropertyEditorManager.registerEditor(Class<?> targetType, Class<?> editorClass)
注册一个将用来编辑给定目标类的值的编辑器类。
static void PropertyEditorManager.registerEditor(Class<?> targetType, Class<?> editorClass)
注册一个将用来编辑给定目标类的值的编辑器类。
 void Encoder.setPersistenceDelegate(Class<?> type, PersistenceDelegate persistenceDelegate)
将与此 type 相关联的持久委托设置为 persistenceDelegate。
 void PropertyDescriptor.setPropertyEditorClass(Class<?> propertyEditorClass)
通常 PropertyEditor 是使用 PropertyEditorManager 找到的。

参数类型为 Class 的 java.beans 中的构造方法
BeanDescriptor(Class<?> beanClass)
为没有 customizer 的 bean 创建一个 BeanDescriptor。
BeanDescriptor(Class<?> beanClass, Class<?> customizerClass)
为有 customizer 的 bean 创建一个 BeanDescriptor。
BeanDescriptor(Class<?> beanClass, Class<?> customizerClass)
为有 customizer 的 bean 创建一个 BeanDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass)
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。
IndexedPropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。
PropertyDescriptor(String propertyName, Class<?> beanClass)
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。
PropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。

java.beans.beancontext 中 Class 的使用

声明为 Class 的 java.beans.beancontext 中的字段
protected Class | BeanContextServiceAvailableEvent.serviceClass 新近可用服务的 Class 引用
protected Class | BeanContextServiceRevokedEvent.serviceClass 将被取消服务的 Class 引用。

返回 Class 的 java.beans.beancontext 中的方法
Class | BeanContextServiceAvailableEvent.getServiceClass() 获得作为此通知主题的服务类。
Class | BeanContextServiceRevokedEvent.getServiceClass() 获得作为此通知主题的服务类

参数类型为 Class 的 java.beans.beancontext 中的方法
 boolean BeanContextServices.addService(Class serviceClass, BeanContextServiceProvider serviceProvider)
向此 BeanContext 添加服务。
 boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp)
添加服务。
protected  boolean BeanContextServicesSupport.addService(Class serviceClass, BeanContextServiceProvider bcsp, boolean fireEvent)
添加服务。
protected static boolean BeanContextSupport.classEquals(Class first, Class second)
测试以查看两个类对象或其名称是否相等。
protected static boolean BeanContextSupport.classEquals(Class first, Class second)
测试以查看两个类对象或其名称是否相等。
protected  BeanContextServicesSupport.BCSSServiceProvider BeanContextServicesSupport.createBCSSServiceProvider(Class sc, BeanContextServiceProvider bcsp)
子类可以重写此方法来创建 BCSSServiceProvider 的新子类，而不必为了实例化而重写 addService()。
protected  void BeanContextServicesSupport.fireServiceAdded(Class serviceClass)
触发一个通知新服务的 BeanContextServiceEvent。
protected  void BeanContextServicesSupport.fireServiceRevoked(Class serviceClass, boolean revokeNow)
触发一个指示某一特定服务不再可用的 BeanContextServiceRevokedEvent。
 Iterator BeanContextServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
 Iterator BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
 Iterator BeanContextServices.getCurrentServiceSelectors(Class serviceClass)
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
 Iterator BeanContextServicesSupport.getCurrentServiceSelectors(Class serviceClass)
 Object BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
 Object BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。
 Object BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。
 Object BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
 boolean BeanContextServices.hasService(Class serviceClass)
报告是否可以从此上下文中得到给定服务。
 boolean BeanContextServicesSupport.hasService(Class serviceClass)
具有一个可被委托的服务。
 boolean BeanContextServiceRevokedEvent.isServiceClass(Class service)
检查此事件，以确定将被取消的服务是否属于某个特定类。
 void BeanContextServices.revokeService(Class serviceClass, BeanContextServiceProvider serviceProvider, boolean revokeCurrentServicesNow)
希望从此上下文中移除当前已注册服务的 BeanContextServiceProvider 可以通过调用此方法实现移除。
 void BeanContextServicesSupport.revokeService(Class serviceClass, BeanContextServiceProvider bcsp, boolean revokeCurrentServicesNow)
移除服务。

参数类型为 Class 的 java.beans.beancontext 中的构造方法
BeanContextServiceAvailableEvent(BeanContextServices bcs, Class sc)
构造一个 BeanContextAvailableServiceEvent。
BeanContextServiceRevokedEvent(BeanContextServices bcs, Class sc, boolean invalidate)
构造一个 BeanContextServiceEvent。

java.io 中 Class 的使用

返回 Class 的 java.io 中的方法
Class<?> | ObjectStreamClass.forClass() 返回此版本所映射的本地 VM 中的类。
Class<?> | ObjectStreamField.getType() 获取字段的类型。
protected Class<?> | ObjectInputStream.resolveClass(ObjectStreamClass desc) 加载指定流类描述的本地等价类。
protected Class<?> | ObjectInputStream.resolveProxyClass(String[] interfaces) 返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。

参数类型为 Class 的 java.io 中的方法
protected void | ObjectOutputStream.annotateClass(Class<?> cl) 子类可以实现此方法，从而允许在流中存储类数据。
protected void | ObjectOutputStream.annotateProxyClass(Class<?> cl) 子类可以实现此方法，从而在流中存储定制数据和动态代理类的描述符。
static ObjectStreamClass | ObjectStreamClass.lookup(Class<?> cl) 查找可序列化类的描述符。
static ObjectStreamClass | ObjectStreamClass.lookupAny(Class<?> cl) 返回任意类的描述符，不考虑它是否实现 Serializable。

参数类型为 Class 的 java.io 中的构造方法
ObjectStreamField(String name, Class<?> type)
创建具有指定类型的 Serializable 字段。
ObjectStreamField(String name, Class<?> type, boolean unshared)
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。

java.lang 中 Class 的使用

声明为 Class 的 java.lang 中的字段
static Class<Void> | Void.TYPE 表示对应于关键字 void 的伪类型的 Class 对象。
static Class<Long> | Long.TYPE 表示基本类型 long 的 Class 实例。
static Class<Integer> | Integer.TYPE 表示基本类型 int 的 Class 实例。
static Class<Short> | Short.TYPE 表示基本类型 short 的 Class 实例。
static Class<Byte> | Byte.TYPE 表示基本类型 byte 的 Class 实例。
static Class<Double> | Double.TYPE 表示基本类型 double 的 Class 实例。
static Class<Float> | Float.TYPE 表示 float 基本类型的 Class 实例。
static Class<Character> | Character.TYPE 表示基本类型 char 的 Class 实例。
static Class<Boolean> | Boolean.TYPE 表示基本类型 boolean 的 Class 对象。

返回 Class 的 java.lang 中的方法
<U> Class<? extends U>
Class.asSubclass(Class<U> clazz)
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。
protected  Class<?> SecurityManager.currentLoadedClass()
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。
protected  Class<?> ClassLoader.defineClass(byte[] b, int off, int len)
已过时。 由 defineClass(String, byte[], int, int) 取代
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len)
将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
protected  Class<?> ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。
 Class<? extends Enum> EnumConstantNotPresentException.enumType()
返回缺少的枚举常量的类型。
protected  Class<?> ClassLoader.findClass(String name)
使用指定的二进制名称查找类。
protected  Class<?> ClassLoader.findLoadedClass(String name)
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。
protected  Class<?> ClassLoader.findSystemClass(String name)
查找具有指定的二进制名称的类，必要时加载它。
static Class<?> Class.forName(String className)
返回与带有给定字符串名的类或接口相关联的 Class 对象。
static Class<?> Class.forName(String name, boolean initialize, ClassLoader loader)
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。
 Class<?> Object.getClass()
返回此 Object 的运行时类。
protected  Class[] SecurityManager.getClassContext()
以类数组的形式返回当前执行堆栈。
 Class<?>[] Class.getClasses()
返回一个包含某些 Class 对象的数组，这些对象表示属于此 Class 对象所表示的类的成员的所有公共类和接口。
 Class<?> Class.getComponentType()
返回表示数组组件类型的 Class。
 Class<?>[] Class.getDeclaredClasses()
返回 Class 对象的一个数组，这些对象反映声明为此 Class 对象所表示的类的成员的所有类和接口。
 Class<E> Enum.getDeclaringClass()
返回与此枚举常量的枚举类型相对应的 Class 对象。
 Class<?> Class.getDeclaringClass()
如果此 Class 对象所表示的类或接口是另一个类的成员，则返回的 Class 对象表示该对象的声明类。
 Class<?> Class.getEnclosingClass()
返回底层类的立即封闭类。
 Class<?>[] Class.getInterfaces()
确定此对象所表示的类或接口实现的接口。
 Class<? super T> Class.getSuperclass()
返回表示此 Class 所表示的实体（类、接口、基本类型或 void）的超类的 Class。
 Class<?> ClassLoader.loadClass(String name)
使用指定的二进制名称来加载类。
protected  Class<?> ClassLoader.loadClass(String name, boolean resolve)
使用指定的二进制名称来加载类。

参数类型为 Class 的 java.lang 中的方法
<U> Class<? extends U>
Class.asSubclass(Class<U> clazz)
强制转换该 Class 对象，以表示指定的 class 对象所表示的类的一个子类。
 void SecurityManager.checkMemberAccess(Class<?> clazz, int which)
如果不允许调用线程访问程序，则抛出 SecurityException。
static boolean Compiler.compileClass(Class<?> clazz)
编译指定的类。
<A extends Annotation>
A
Package.getAnnotation(Class<A> annotationClass)
<A extends Annotation>
A
Class.getAnnotation(Class<A> annotationClass)
 Constructor<T> Class.getConstructor(Class<?>... parameterTypes)
返回一个 Constructor 对象，它反映此 Class 对象所表示的类的指定公共构造方法。
 Constructor<T> Class.getDeclaredConstructor(Class<?>... parameterTypes)
返回一个 Constructor 对象，该对象反映此 Class 对象所表示的类或接口的指定构造方法。
 Method Class.getDeclaredMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。
 Method Class.getMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。
 boolean Package.isAnnotationPresent(Class<? extends Annotation> annotationClass)
 boolean Class.isAnnotationPresent(Class<? extends Annotation> annotationClass)
 boolean Class.isAssignableFrom(Class<?> cls)
判定此 Class 对象所表示的类或接口与指定的 Class 参数所表示的类或接口是否相同，或是否是其超类或超接口。
protected  void ClassLoader.resolveClass(Class<?> c)
链接指定的类。
protected  void ClassLoader.setSigners(Class<?> c, Object[] signers)
设置类的签署者。
static
<T extends Enum<T>>
T
Enum.valueOf(Class<T> enumType, String name)
返回带指定名称的指定枚举类型的枚举常量。

参数类型为 Class 的 java.lang 中的构造方法
EnumConstantNotPresentException(Class<? extends Enum> enumType, String constantName)
为指定常量构造一个 EnumConstantNotPresentException。

java.lang.annotation 中 Class 的使用

返回 Class 的 java.lang.annotation 中的方法
Class<? extends Annotation> | IncompleteAnnotationException.annotationType() 返回带有缺少元素的注释类型的 Class 对象。
Class<? extends Annotation> | Annotation.annotationType() 返回此 annotation 的注释类型。

参数类型为 Class 的 java.lang.annotation 中的构造方法
IncompleteAnnotationException(Class<? extends Annotation> annotationType, String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。

java.lang.instrument 中 Class 的使用

返回 Class 的 java.lang.instrument 中的方法
Class[] | Instrumentation.getAllLoadedClasses() 返回 JVM 当前加载的所有类的数组。
Class<?> | ClassDefinition.getDefinitionClass() 返回该类。
Class[] | Instrumentation.getInitiatedClasses(ClassLoader loader) 返回所有初始化加载器是 loader 的类的数组。

参数类型为 Class 的 java.lang.instrument 中的方法
boolean | Instrumentation.isModifiableClass(Class<?> theClass) 确定一个类是否可以被 retransformation 或 redefinition 修改。
void | Instrumentation.retransformClasses(Class<?>... classes) 重转换提供的类集。
byte[] | ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer) 此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

参数类型为 Class 的 java.lang.instrument 中的构造方法
ClassDefinition(Class<?> theClass, byte[] theClassFile)
使用提供的类和类文件字节创建一个新的 ClassDefinition 绑定。

java.lang.management 中 Class 的使用

参数类型为 Class 的 java.lang.management 中的方法
static
<T> T
ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

java.lang.reflect 中 Class 的使用

返回 Class 的 java.lang.reflect 中的方法
Class<T> | Constructor.getDeclaringClass() 返回 Class 对象，该对象表示声明由此 Constructor 对象表示的构造方法的类。
Class<?> | Method.getDeclaringClass() 返回表示声明由此 Method 对象表示的方法的类或接口的 Class 对象。
Class<?> | Field.getDeclaringClass() 返回表示类或接口的 Class 对象，该类或接口声明由此 Field 对象表示的字段。
Class<?> | Member.getDeclaringClass() 返回表示声明由此 Member 表示的成员或构造方法的类或接口的 Class 对象。
Class<?>[] | Constructor.getExceptionTypes() 返回一组表示声明要抛出的异常类型的 Class 对象，这些异常是由此 Constructor 对象表示的底层构造方法抛出的。
Class<?>[] | Method.getExceptionTypes() 返回 Class 对象的数组，这些对象描述了声明将此 Method 对象表示的底层方法抛出的异常类型。
Class<?>[] | Constructor.getParameterTypes() 按照声明顺序返回一组 Class 对象，这些对象表示此 Constructor 对象所表示构造方法的形参类型。
Class<?>[] | Method.getParameterTypes() 按照声明顺序返回 Class 对象的数组，这些对象描述了此 Method 对象所表示的方法的形参类型。
static Class<?> | Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces) 返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
Class<?> | Method.getReturnType() 返回一个 Class 对象，该对象描述了此 Method 对象所表示的方法的正式返回类型。
Class<?> | Field.getType() 返回一个 Class 对象，它标识了此 Field 对象所表示字段的声明类型。

参数类型为 Class 的 java.lang.reflect 中的方法
<T extends Annotation>
T
Constructor.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Method.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
Field.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AccessibleObject.getAnnotation(Class<T> annotationClass)
<T extends Annotation>
T
AnnotatedElement.getAnnotation(Class<T> annotationClass)
如果存在该元素的指定类型的注释，则返回这些注释，否则返回 null。
static Class<?> Proxy.getProxyClass(ClassLoader loader, Class<?>... interfaces)
返回代理类的 java.lang.Class 对象，并向其提供类加载器和接口数组。
 boolean AccessibleObject.isAnnotationPresent(Class<? extends Annotation> annotationClass)
 boolean AnnotatedElement.isAnnotationPresent(Class<? extends Annotation> annotationClass)
如果指定类型的注释存在于此元素上，则返回 true，否则返回 false。
static boolean Proxy.isProxyClass(Class<?> cl)
当且仅当指定的类通过 getProxyClass 方法或 newProxyInstance 方法动态生成为代理类时，返回 true。
static Object Array.newInstance(Class<?> componentType, int... dimensions)
创建一个具有指定的组件类型和维度的新数组。
static Object Array.newInstance(Class<?> componentType, int length)
创建一个具有指定的组件类型和长度的新数组。
static Object Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

java.net 中 Class 的使用

返回 Class 的 java.net 中的方法
protected  Class<?> URLClassLoader.findClass(String name)
通过 URL 搜索路径查找并加载具有指定名称的类。

参数类型为 Class 的 java.net 中的方法
Object | URLConnection.getContent(Class[] classes) 获取此 URL 连接的内容。
Object | URL.getContent(Class[] classes) 获取此 URL 的内容。
Object | ContentHandler.getContent(URLConnection urlc, Class[] classes) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。

java.rmi.server 中 Class 的使用

返回 Class 的 java.rmi.server 中的方法
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
static Class<?> RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

参数类型为 Class 的 java.rmi.server 中的方法
static String RMIClassLoader.getClassAnnotation(Class<?> cl)
返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。
abstract  String RMIClassLoaderSpi.getClassAnnotation(Class<?> cl)
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。

java.security 中 Class 的使用

返回 Class 的 java.security 中的方法
protected Class<?> | SecureClassLoader.defineClass(String name, byte[] b, int off, int len, CodeSource cs) 使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。
protected Class<?> | SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs) 使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。

参数类型为 Class 的 java.security 中的方法
 boolean KeyStoreSpi.engineEntryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
protected abstract
<T extends AlgorithmParameterSpec>
T
AlgorithmParametersSpi.engineGetParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
 boolean KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
<T extends AlgorithmParameterSpec>
T
AlgorithmParameters.getParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。

java.sql 中 Class 的使用

返回变量类型为 Class 的类型的 java.sql 中的方法
 Map<String,Class<?>> Connection.getTypeMap()
获取与此 Connection 对象关联的 Map 对象。

参数类型为 Class 的 java.sql 中的方法
<T extends Source>
T
SQLXML.getSource(Class<T> sourceClass)
返回读取此 SQLXML 实例指定的 XML 值的 Source。
 boolean Wrapper.isWrapperFor(Class<?> iface)
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。
<T extends Result>
T
SQLXML.setResult(Class<T> resultClass)
返回设置此 SQLXML 实例指定的 XML 值的 Result。
<T> T
Wrapper.unwrap(Class<T> iface)
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。

类型变量类型为 Class 的 java.sql 中的方法参数
Object | Array.getArray(long index, int count, Map<String,Class<?>> map) 获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
Object | Array.getArray(Map<String,Class<?>> map) 获取由此 Array 对象指定的 SQL ARRAY 值的内容。
Object[] | Struct.getAttributes(Map<String,Class<?>> map) 生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
Object | CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(int columnIndex, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | Ref.getObject(Map<String,Class<?>> map) 获取引用对象并使用给定类型映射表将其映射到 Java 类型。
Object | CallableStatement.getObject(String parameterName, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(String columnLabel, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
ResultSet | Array.getResultSet(long index, int count, Map<String,Class<?>> map) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(Map<String,Class<?>> map) 获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
void | Connection.setTypeMap(Map<String,Class<?>> map) 将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。

java.util 中 Class 的使用

返回 Class 的 java.util 中的方法
 Class<?> IllegalFormatConversionException.getArgumentClass()
返回不匹配参数的类。

参数类型为 Class 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。
static
<E> Collection<E>
Collections.checkedCollection(Collection<E> c, Class<E> type)
返回指定 collection 的一个动态类型安全视图。
static
<E> List<E>
Collections.checkedList(List<E> list, Class<E> type)
返回指定列表的一个动态类型安全视图。
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<E> Set<E>
Collections.checkedSet(Set<E> s, Class<E> type)
返回指定 set 的一个动态类型安全视图。
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
static
<E> SortedSet<E>
Collections.checkedSortedSet(SortedSet<E> s, Class<E> type)
返回指定有序 set 的一个动态类型安全视图。
static
<T,U> T[]
Arrays.copyOf(U[] original, int newLength, Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
static
<T,U> T[]
Arrays.copyOfRange(U[] original, int from, int to, Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service)
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service, ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。
static
<S> ServiceLoader<S>
ServiceLoader.loadInstalled(Class<S> service)
针对给定服务类型创建新的服务加载器，使用扩展类加载器。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。

参数类型为 Class 的 java.util 中的构造方法
EnumMap(Class<K> keyType)
创建一个具有指定键类型的空枚举映射。
IllegalFormatConversionException(char c, Class<?> arg)
使用不匹配转换和相应参数类构造此类的实例。

java.util.concurrent.atomic 中 Class 的使用

参数类型为 Class 的 java.util.concurrent.atomic 中的方法
static
<U,W> AtomicReferenceFieldUpdater<U,W>
AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。
static
<U,W> AtomicReferenceFieldUpdater<U,W>
AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。
static
<U> AtomicIntegerFieldUpdater<U>
AtomicIntegerFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
使用给定字段为对象创建和返回一个更新器。
static
<U> AtomicLongFieldUpdater<U>
AtomicLongFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
为对象创建并返回一个具有给定字段的更新器。

java.util.prefs 中 Class 的使用

参数类型为 Class 的 java.util.prefs 中的方法
static Preferences | Preferences.systemNodeForPackage(Class<?> c) 从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences | Preferences.userNodeForPackage(Class<?> c) 从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。

javax.activation 中 Class 的使用

返回 Class 的 javax.activation 中的方法
 Class ActivationDataFlavor.getRepresentationClass()
返回表示形式类。

参数类型为 Class 的 javax.activation 中的构造方法
ActivationDataFlavor(Class representationClass, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。
ActivationDataFlavor(Class representationClass, String mimeType, String humanPresentableName)
构造一个表示任意 Java 对象的 DataFlavor。

javax.annotation.processing 中 Class 的使用

参数类型为 Class 的 javax.annotation.processing 中的方法
 Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a)
返回使用给定注释类型注释的元素。

javax.crypto 中 Class 的使用

参数类型为 Class 的 javax.crypto 中的方法
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。

javax.imageio.metadata 中 Class 的使用

返回 Class 的 javax.imageio.metadata 中的方法
Class<?> | IIOMetadataFormat.getObjectClass(String elementName) 返回存储在元素中的 Class 类型的 Object 引用。
Class<?> | IIOMetadataFormatImpl.getObjectClass(String elementName)

参数类型为 Class 的 javax.imageio.metadata 中的方法
protected  void IIOMetadataFormatImpl.addObjectValue(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T> void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T> void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

javax.imageio.spi 中 Class 的使用

声明为 Class 的 javax.imageio.spi 中的字段
protected Class<?> | ImageInputStreamSpi.inputClass 指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
protected Class[] | ImageReaderSpi.inputTypes 将从 getInputTypes 返回的 Class 对象数组，该数组最初为 null。
protected Class<?> | ImageOutputStreamSpi.outputClass 指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
protected Class[] | ImageWriterSpi.outputTypes 将从 getOutputTypes 返回的 Class 对象的数组，该数组最初为 null。
static Class[] | ImageReaderSpi.STANDARD_INPUT_TYPE 将从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
static Class[] | ImageWriterSpi.STANDARD_OUTPUT_TYPE 从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。

返回 Class 的 javax.imageio.spi 中的方法
Class<?> | ImageInputStreamSpi.getInputClass() 返回表示必须由输入源实现（以便使用 createInputStreamInstance 方法在 ImageInputStream 中“包装”）的类或接口的类型的 Class 对象。
Class[] | ImageReaderSpi.getInputTypes() 返回 Class 对象数组，指示可用作 reader 的 setInput 方法参数的对象类型。
Class<?> | ImageOutputStreamSpi.getOutputClass() 返回表示必须由输出目标位置实现（以便使用 createOutputStreamInstance 方法在 ImageOutputStream 中“包装”）的类或接口的类型的 Class 对象。
Class[] | ImageWriterSpi.getOutputTypes() 返回 Class 对象数组，指示可用作 setOutput 方法参数的对象类型。

返回变量类型为 Class 的类型的 javax.imageio.spi 中的方法
 Iterator<Class<?>> ServiceRegistry.getCategories()
返回指示当前类别集的 Class 对象的 Iterator。

参数类型为 Class 的 javax.imageio.spi 中的方法
 void ServiceRegistry.deregisterAll(Class<?> category)
注销给定类别下当前注册的所有服务提供者对象。
<T> boolean
ServiceRegistry.deregisterServiceProvider(T provider, Class<T> category)
从给定的类别中移除服务提供者对象。
<T> T
ServiceRegistry.getServiceProviderByClass(Class<T> providerClass)
返回当前注册的属于给定类类型的服务提供者对象。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, boolean useOrdering)
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass)
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass, ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。
 void IIOServiceProvider.onDeregistration(ServiceRegistry registry, Class<?> category)
Spi 类一从 ServiceRegistry 中注销即执行的回调。
 void RegisterableService.onDeregistration(ServiceRegistry registry, Class<?> category)
将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。
 void IIOServiceProvider.onRegistration(ServiceRegistry registry, Class<?> category)
在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。
 void RegisterableService.onRegistration(ServiceRegistry registry, Class<?> category)
将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。
<T> boolean
ServiceRegistry.registerServiceProvider(T provider, Class<T> category)
将一个服务提供者对象添加到注册表。
<T> boolean
ServiceRegistry.setOrdering(Class<T> category, T firstProvider, T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。
<T> boolean
ServiceRegistry.unsetOrdering(Class<T> category, T firstProvider, T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。

参数类型为 Class 的 javax.imageio.spi 中的构造方法
ImageInputStreamSpi(String vendorName, String version, Class<?> inputClass)
用给定的一组值构造 ImageInputStreamSpi。
ImageOutputStreamSpi(String vendorName, String version, Class<?> outputClass)
用给定的一组值构造 ImageOutputStreamSpi。
ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。
ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

类型变量类型为 Class 的 javax.imageio.spi 中的构造方法参数
ServiceRegistry(Iterator<Class<?>> categories)
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。

javax.lang.model.element 中 Class 的使用

参数类型为 Class 的 javax.lang.model.element 中的方法
<A extends Annotation>
A
Element.getAnnotation(Class<A> annotationType)
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。

javax.management 中 Class 的使用

返回 Class 的 javax.management 中的方法
Class<?> | StandardMBean.getImplementationClass() 获取此 Standard MBean（或 MXBean）的实现类。
Class<?> | StandardMBean.getMBeanInterface() 获取此 Standard MBean（或 MXBean）的管理接口。
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

参数类型为 Class 的 javax.management 中的方法
static boolean JMX.isMXBeanInterface(Class<?> interfaceClass)
测试某接口是否是 MXBean 接口。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。

参数类型为 Class 的 javax.management 中的构造方法
StandardEmitterMBean(Class<?> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardMBean(Class<?> mbeanInterface)
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(Class<?> mbeanInterface, boolean isMXBean)
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(T implementation, Class<T> mbeanInterface)
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
StandardMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean)
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。

javax.management.loading 中 Class 的使用

返回 Class 的 javax.management.loading 中的方法
protected Class<?> | MLet.findClass(String name) 这是要重新定义的类加载器的主要方法。
Class<?> | ClassLoaderRepository.loadClass(String className) 通过类加载器列表加载给定的类名称。
static Class | DefaultLoaderRepository.loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
Class<?> | MLet.loadClass(String name, ClassLoaderRepository clr) 如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。
Class<?> | ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className) 通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
Class<?> | ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className) 通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。
static Class | DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。

javax.management.openmbean 中 Class 的使用

参数类型为 Class 的 javax.management.openmbean 中的方法
static
<T> ArrayType<T>
ArrayType.getPrimitiveArrayType(Class<T> arrayClass)
以类型安全的方式创建一个 ArrayType 实例。

javax.naming.spi 中 Class 的使用

参数类型为 Class 的 javax.naming.spi 中的方法
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。

javax.print 中 Class 的使用

返回 Class 的 javax.print 中的方法
Class<?>[] | PrintService.getSupportedAttributeCategories() 确定客户端在设置此 PrintService 的作业时，可以指定的打印属性类别。
Class[] | AttributeException.getUnsupportedAttributes() 返回其 PrintService 实例根本不支持该属性的打印属性类数组，如果没有这种属性，则返回 null。

参数类型为 Class 的 javax.print 中的方法
<T extends PrintServiceAttribute>
T
PrintService.getAttribute(Class<T> category)
获取单个指定服务属性的值。
 Object PrintService.getDefaultAttributeValue(Class<? extends Attribute> category)
确定给定类别中此 PrintService 的默认打印属性值。
 Object PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
 boolean PrintService.isAttributeCategorySupported(Class<? extends Attribute> category)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。

javax.print.attribute 中 Class 的使用

返回 Class 的 javax.print.attribute 中的方法
Class<? extends Attribute> | Attribute.getCategory() 将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。
static Class<?> | AttributeSetUtilities.verifyAttributeCategory(Object object, Class<?> interfaceName) 验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。

参数类型为 Class 的 javax.print.attribute 中的方法
boolean | AttributeSet.containsKey(Class<?> category) 如果此属性集包含指定类别的一个属性，则返回 true。
boolean | HashAttributeSet.containsKey(Class<?> category) 如果此属性集包含指定类别的属性，则返回 true。
Attribute | AttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
Attribute | HashAttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
boolean | AttributeSet.remove(Class<?> category) 从此属性集移除此类别的任何属性（如果存在）。
boolean | HashAttributeSet.remove(Class<?> category) 从此属性集移除此类别的任何属性（如果存在）。
static Class<?> | AttributeSetUtilities.verifyAttributeCategory(Object object, Class<?> interfaceName) 验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。
static Attribute | AttributeSetUtilities.verifyAttributeValue(Object object, Class<?> interfaceName) 验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。
static void | AttributeSetUtilities.verifyCategoryForValue(Class<?> category, Attribute attribute) 验证给定的属性类别对象是否等于给定属性值对象的类别。

参数类型为 Class 的 javax.print.attribute 中的构造方法
HashAttributeSet(Attribute[] attributes, Class<?> interfaceName)
构造一个新的属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute attribute, Class<?> interfaceName)
构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(AttributeSet attributes, Class<?> interfaceName)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Class<?> interfaceName)
构造一个新的空属性集，其中该属性集的成员限于给定的接口。

javax.print.attribute.standard 中 Class 的使用

返回 Class 的 javax.print.attribute.standard 中的方法
Class<? extends Attribute> | Chromaticity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ColorSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Compression.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Copies.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | CopiesSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCreation.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtProcessing.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Destination.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DocumentName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Fidelity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Finishings.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobHoldUntil.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressions.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsCompleted.getCategory() 获取被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsProcessed.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMessageFromOperator.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobOriginatingUserName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPriority.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPrioritySupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobState.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReason.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReasons.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Media.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaPrintableArea.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaSize.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MultipleDocumentHandling.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfDocuments.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfInterveningJobs.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUp.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUpSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OrientationRequested.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OutputDeviceAssigned.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PDLOverrideSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PageRanges.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinute.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinuteColor.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PresentationDirection.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrintQuality.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterIsAcceptingJobs.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterLocation.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMakeAndModel.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMessageFromOperator.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfoManufacturer.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterResolution.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterState.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReason.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReasons.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterURI.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | QueuedJobCount.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ReferenceUriSchemesSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | RequestingUserName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Severity.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | SheetCollate.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Sides.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。

javax.rmi 中 Class 的使用

参数类型为 Class 的 javax.rmi 中的方法
static Object PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

javax.rmi.CORBA 中 Class 的使用

返回 Class 的 javax.rmi.CORBA 中的方法
static Class Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。
 Class UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。

参数类型为 Class 的 javax.rmi.CORBA 中的方法
static String Util.getCodebase(Class clz)
返回给定类的代码基（如果存在）。
 String UtilDelegate.getCodebase(Class clz)
Util.getCodebase(java.lang.Class) 的委托调用。
 String ValueHandler.getRMIRepositoryID(Class clz)
返回给定 Java 类的 CORBA RepositoryId。
 boolean ValueHandler.isCustomMarshaled(Class clz)
指示给定的类是执行自定义编组还是默认编组。
 Object PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。
 Serializable ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

javax.script 中 Class 的使用

参数类型为 Class 的 javax.script 中的方法
<T> T
Invocable.getInterface(Class<T> clasz)
返回一个接口的实现，该接口使用解释器中编译的函数。
<T> T
Invocable.getInterface(Object thiz, Class<T> clasz)
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。

javax.security.auth 中 Class 的使用

参数类型为 Class 的 javax.security.auth 中的方法
<T extends Principal>
Set<T>
Subject.getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。
<T> Set<T>
Subject.getPrivateCredentials(Class<T> c)
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。
<T> Set<T>
Subject.getPublicCredentials(Class<T> c)
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。

javax.sound.midi 中 Class 的使用

返回 Class 的 javax.sound.midi 中的方法
 Class<?> SoundbankResource.getDataClass()
获得此采样所使用的表示其数据的类。

参数类型为 Class 的 javax.sound.midi 中的构造方法
Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。
SoundbankResource(Soundbank soundBank, String name, Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。

javax.sound.sampled 中 Class 的使用

返回 Class 的 javax.sound.sampled 中的方法
 Class<?> Line.Info.getLineClass()
获得此 Line.Info 对象所描述的行的类。

参数类型为 Class 的 javax.sound.sampled 中的构造方法
DataLine.Info(Class<?> lineClass, AudioFormat format)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。
DataLine.Info(Class<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。
DataLine.Info(Class<?> lineClass, AudioFormat format, int bufferSize)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。
Line.Info(Class<?> lineClass)
构造描述指定类的行的 info 对象。
Port.Info(Class<?> lineClass, String name, boolean isSource)
根据给定的信息构造端口的 info 对象。

javax.sql 中 Class 的使用

返回变量类型为 Class 的类型的 javax.sql 中的方法
 Map<String,Class<?>> RowSet.getTypeMap()
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。

类型变量类型为 Class 的 javax.sql 中的方法参数
 void RowSet.setTypeMap(Map<String,Class<?>> map)
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。

javax.sql.rowset 中 Class 的使用

返回变量类型为 Class 的类型的 javax.sql.rowset 中的方法
 Map<String,Class<?>> BaseRowSet.getTypeMap()
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 Class 的 javax.sql.rowset 中的方法
 boolean RowSetMetaDataImpl.isWrapperFor(Class<?> interfaces)
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。
<T> T
RowSetMetaDataImpl.unwrap(Class<T> iface)
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。

类型变量类型为 Class 的 javax.sql.rowset 中的方法参数
 void BaseRowSet.setTypeMap(Map<String,Class<?>> map)
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。

javax.sql.rowset.serial 中 Class 的使用

类型变量类型为 Class 的 javax.sql.rowset.serial 中的方法参数
Object | SerialArray.getArray(long index, int count, Map<String,Class<?>> map) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(Map<String,Class<?>> map) 返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
Object[] | SerialStruct.getAttributes(Map<String,Class<?>> map) 获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
Object | SerialRef.getObject(Map<String,Class<?>> map) 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

类型变量类型为 Class 的 javax.sql.rowset.serial 中的构造方法参数
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。
SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。

javax.swing 中 Class 的使用

返回 Class 的 javax.swing 中的方法
Class<?> | JTable.getColumnClass(int column) 返回出现在视图中 column 列位置处的列类型。
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID) 返回呈现此组件的 L&F 类。
Class<? extends ComponentUI> | UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader) get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。

参数类型为 Class 的 javax.swing 中的方法
static Container SwingUtilities.getAncestorOfClass(Class<?> c, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
 TableCellEditor JTable.getDefaultEditor(Class<?> columnClass)
尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。
 TableCellRenderer JTable.getDefaultRenderer(Class<?> columnClass)
尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。
<T extends EventListener>
T[]
AbstractSpinnerModel.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
DefaultListSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractListModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultBoundedRangeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultSingleSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultButtonModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Timer.getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
JComponent.getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。
static Object LookAndFeel.makeIcon(Class<?> baseClass, String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。
 void JTable.setDefaultEditor(Class<?> columnClass, TableCellEditor editor)
如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。
 void JTable.setDefaultRenderer(Class<?> columnClass, TableCellRenderer renderer)
如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。

javax.swing.event 中 Class 的使用

参数类型为 Class 的 javax.swing.event 中的方法
<T extends EventListener>
void
EventListenerList.add(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行添加。
 int EventListenerList.getListenerCount(Class<?> t)
返回此侦听器列表中所提供类型的侦听器的总数。
<T extends EventListener>
T[]
EventListenerList.getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。
<T extends EventListener>
void
EventListenerList.remove(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行移除。

javax.swing.plaf.synth 中 Class 的使用

参数类型为 Class 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(InputStream input, Class<?> resourceBase)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.table 中 Class 的使用

返回 Class 的 javax.swing.table 中的方法
Class<?> | AbstractTableModel.getColumnClass(int columnIndex) 返回 Object.class 而不管 columnIndex 是多少。
Class<?> | TableModel.getColumnClass(int columnIndex) 针对列中所有的单元格值，返回最具体的超类。

参数类型为 Class 的 javax.swing.table 中的方法
<T extends EventListener>
T[]
DefaultTableColumnModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractTableModel.getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。

javax.swing.text 中 Class 的使用

返回 Class 的 javax.swing.text 中的方法
 Class<?> DefaultFormatter.getValueClass()
返回用于创建新 Objects 的类。

参数类型为 Class 的 javax.swing.text 中的方法
<T extends EventListener>
T[]
DefaultCaret.getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
StyleContext.NamedStyle.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
AbstractDocument.getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。
 void DefaultFormatter.setValueClass(Class<?> valueClass)
设置用于创建新 Objects 的类。

javax.swing.tree 中 Class 的使用

参数类型为 Class 的 javax.swing.tree 中的方法
<T extends EventListener>
T[]
DefaultTreeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultTreeSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。

javax.xml.bind 中 Class 的使用

声明为 Class 的 javax.xml.bind 中的字段
protected Class<T> | JAXBElement.declaredType xml 元素声明类型的 Java 数据类型绑定。
protected Class | JAXBElement.scope 表示此 xml 元素实例的 xml 元素声明的作用域。

返回 Class 的 javax.xml.bind 中的方法
Class<T> | JAXBElement.getDeclaredType() 返回 xml 元素声明的类型属性的 Java 绑定。
Class | JAXBElement.getScope() 返回 xml 元素声明的作用域。

参数类型为 Class 的 javax.xml.bind 中的方法
<T> Binder<T>
JAXBContext.createBinder(Class<T> domType)
创建一个可用于关联/原地解组/编组操作的 Binder 对象。
<A extends XmlAdapter>
A
Marshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
<A extends XmlAdapter>
A
Unmarshaller.getAdapter(Class<A> type)
获取与指定类型关联的适配器。
static JAXBContext JAXBContext.newInstance(Class... classesToBeBound)
获得 JAXBContext 类的新实例。
static JAXBContext JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
获得 JAXBContext 类的新实例。
<A extends XmlAdapter>
void
Marshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 marshaller 关联。
<A extends XmlAdapter>
void
Unmarshaller.setAdapter(Class<A> type, A adapter)
将已配置的 XmlAdapter 实例与此 unmarshaller 关联。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Node node, Class<T> declaredType)
通过 JAXB 映射的 declaredType 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(Source source, Class<T> declaredType)
从 declaredType 指定的 XML Source 解组 XML 数据并返回得到的内容树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLEventReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。
abstract
<T> JAXBElement<T>
Binder.unmarshal(XmlNode xmlNode, Class<T> declaredType)
根据提供的 declaredType 将 XML 根元素解组为 JAXB 对象树。
<T> JAXBElement<T>
Unmarshaller.unmarshal(XMLStreamReader reader, Class<T> declaredType)
将根元素解组到 JAXB 映射的 declaredType 并返回得到的内容树。

参数类型为 Class 的 javax.xml.bind 中的构造方法
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
构造一个 xml 元素实例。
JAXBElement(QName name, Class<T> declaredType, Class scope, T value)
构造一个 xml 元素实例。
JAXBElement(QName name, Class<T> declaredType, T value)
构造一个 xml 元素实例。

javax.xml.bind.helpers 中 Class 的使用

参数类型为 Class 的 javax.xml.bind.helpers 中的方法
<A extends XmlAdapter>
A
AbstractMarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
A
AbstractUnmarshallerImpl.getAdapter(Class<A> type)
<A extends XmlAdapter>
void
AbstractMarshallerImpl.setAdapter(Class<A> type, A adapter)
<A extends XmlAdapter>
void
AbstractUnmarshallerImpl.setAdapter(Class<A> type, A adapter)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Node node, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(Source source, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader, Class<T> expectedType)
<T> JAXBElement<T>
AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader, Class<T> expectedType)

javax.xml.ws 中 Class 的使用

参数类型为 Class 的 javax.xml.ws 中的方法
<T> Dispatch<T>
Service.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
<T> T
Service.getPort(Class<T> serviceEndpointInterface)
getPort 返回 stub。
<T> T
Service.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回 stub。

javax.xml.ws.spi 中 Class 的使用

参数类型为 Class 的 javax.xml.ws.spi 中的方法
abstract
<T> Dispatch<T>
ServiceDelegate.createDispatch(QName portName, Class<T> type, Service.Mode mode)
创建与用户选择的对象一起使用的 Dispatch 实例。
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。
abstract
<T> T
ServiceDelegate.getPort(Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块。
abstract
<T> T
ServiceDelegate.getPort(QName portName, Class<T> serviceEndpointInterface)
getPort 方法返回一个桩模块 (stub)。

org.omg.CORBA 中 Class 的使用

参数类型为 Class 的 org.omg.CORBA 中的方法
 ServantObject LocalObject._servant_preinvoke(String operation, Class expectedType)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

org.omg.CORBA_2_3.portable 中 Class 的使用

参数类型为 Class 的 org.omg.CORBA_2_3.portable 中的方法
Object | InputStream.read_abstract_interface(Class clz) 解组与传递类型相对应的类对象或 stub 类。
Serializable | InputStream.read_value(Class clz) 从输入流解组值类型。
void | OutputStream.write_value(Serializable value, Class clz) 将值类型编组到输出流中。

org.omg.CORBA.portable 中 Class 的使用

参数类型为 Class 的 org.omg.CORBA.portable 中的方法
ServantObject | ObjectImpl._servant_preinvoke(String operation, Class expectedType) 返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。
Object | InputStream.read_Object(Class clz) 取消对象的编组并返回一个 CORBA Object，该对象是作为参数传递的类的实例。
ServantObject | Delegate.servant_preinvoke(Object self, String operation, Class expectedType) 返回对应该用作此请求的 servant 的 Java 引用。

org.omg.DynamicAny 中 Class 的使用

声明为 Class 的 org.omg.DynamicAny 中的字段
static Class | _DynAnyFactoryStub._opsClass
static Class | _DynAnyStub._opsClass
static Class | _DynArrayStub._opsClass
static Class | _DynEnumStub._opsClass
static Class | _DynFixedStub._opsClass
static Class | _DynSequenceStub._opsClass
static Class | _DynStructStub._opsClass
static Class | _DynUnionStub._opsClass
static Class | _DynValueStub._opsClass

org.omg.PortableServer 中 Class 的使用

声明为 Class 的 org.omg.PortableServer 中的字段
static Class | _ServantActivatorStub._opsClass
static Class | _ServantLocatorStub._opsClass

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.String 的使用 (Java 2 Platform SE 6)

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架

类 java.lang.String
的使用

使用 String 的软件包

java.applet

提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.awt

包含用于创建用户界面和绘制图形图像的所有类。

java.awt.color

提供用于颜色空间的类。

java.awt.datatransfer

提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.dnd

Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.event

提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt.font

提供与字体相关的类和接口。

java.awt.geom

提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.im.spi

提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.image

提供创建和修改图像的各种类。

java.awt.image.renderable

提供用于生成与呈现无关的图像的类和接口。

java.awt.print

为通用的打印 API 提供类和接口。

java.beans

包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans.beancontext

提供与 bean 上下文有关的类和接口。

java.io

通过数据流、序列化和文件系统提供系统输入和输出。

java.lang

提供利用 Java 编程语言进行程序设计的基础类。

java.lang.annotation

为 Java 编程语言注释设施提供库支持。

java.lang.instrument

提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.management

提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.reflect

提供类和接口，以获得关于类和对象的反射信息。

java.math

提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。

java.net

为实现网络应用程序提供类。

java.nio

定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio.channels

定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.charset

定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset.spi

java.nio.charset 包的服务提供者类。

java.rmi

提供 RMI 包。

java.rmi.activation

为 RMI 对象激活提供支持。

java.rmi.dgc

为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.registry

提供 RMI 注册表的一个类和两个接口。

java.rmi.server

提供支持服务器端 RMI 的类和接口。

java.security

为安全框架提供类和接口。

java.security.acl

此包中的类和接口已经被 java.security 包中的类取代。

java.security.cert

提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.spec

提供密钥规范和算法参数规范的类和接口。

java.sql

提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.text

提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.util

包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util.concurrent

在并发编程中很常用的实用工具类。

java.util.concurrent.atomic

类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.locks

为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.jar

提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.logging

提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.prefs

此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.regex

用于匹配字符序列与正则表达式指定模式的类。

java.util.spi

java.util 包中类的服务提供者类。

java.util.zip

提供用于读写标准 ZIP 和 GZIP 文件格式的类。

javax.accessibility

定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.activation

javax.activity

包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。

javax.annotation

javax.annotation.processing

用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.crypto

为加密操作提供类和接口。

javax.crypto.spec

为密钥规范和算法参数规范提供类和接口。

javax.imageio

Java Image I/O API 的主要包。

javax.imageio.event

Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。

javax.imageio.metadata

用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.plugins.jpeg

支持内置 JPEG 插件的类。

javax.imageio.spi

包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.stream

Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.jws

javax.jws.soap

javax.lang.model

用来为 Java 编程语言建立模型的包的类和层次结构。

javax.lang.model.element

用于 Java 编程语言的模型元素的接口。

javax.lang.model.type

用来为 Java 编程语言类型建立模型的接口。

javax.lang.model.util

用来帮助处理程序元素和类型的实用工具。

javax.management

提供 Java Management Extensions 的核心类。

javax.management.loading

提供实现高级动态加载的类。

javax.management.modelmbean

提供了 ModelMBean 类的定义。

javax.management.monitor

提供 monitor 类的定义。

javax.management.openmbean

提供开放数据类型和 Open MBean 描述符类。

javax.management.relation

提供 Relation Service 的定义。

javax.management.remote

对 JMX MBean 服务器进行远程访问使用的接口。

javax.management.remote.rmi

RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.timer

提供对 Timer MBean（计时器 MBean）的定义。

javax.naming

为访问命名服务提供类和接口。

javax.naming.directory

扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.event

在访问命名和目录服务时提供对事件通知的支持。

javax.naming.ldap

提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.spi

提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.net

提供用于网络应用程序的类。

javax.net.ssl

提供用于安全套接字包的类。

javax.print

为 JavaTM Print Service API 提供了主要类和接口。

javax.print.attribute

提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print.attribute.standard

包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.event

包 javax.print.event 包含事件类和侦听器接口。

javax.rmi.CORBA

包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.ssl

通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

javax.script

脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.security.auth

此包提供用于进行验证和授权的框架。

javax.security.auth.callback

此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

javax.security.auth.kerberos

此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.login

此包提供可插入的验证框架。

javax.security.auth.spi

此包提供用于实现可插入验证模块的接口。

javax.security.auth.x500

此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

javax.security.cert

为公钥证书提供类。

javax.security.sasl

包含用于支持 SASL 的类和接口。

javax.sound.midi

提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.sampled

提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sql

为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql.rowset

JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset.serial

提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

javax.sql.rowset.spi

第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.swing

提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing.border

提供围绕 Swing 组件绘制特殊边框的类和接口。

javax.swing.colorchooser

包含供 JColorChooser 组件使用的类和接口。

javax.swing.event

供 Swing 组件触发的事件使用。

javax.swing.filechooser

包含 JFileChooser 组件使用的类和接口。

javax.swing.plaf

提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf.basic

提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.metal

提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.multi

提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf.synth

Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.table

提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.text

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html.parser

提供默认的 HTML 解析器以及支持类。

javax.swing.text.rtf

提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing.tree

提供处理 javax.swing.JTree 的类和接口。

javax.swing.undo

允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.tools

为能够从程序（例如，编译器）中调用的工具提供接口。

javax.transaction

包含解组期间通过 ORB 机制抛出的三个异常。

javax.transaction.xa

提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.xml

根据 XML 规范定义核心 XML 常量和功能。

javax.xml.bind

为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind.annotation

定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation.adapters

XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。

javax.xml.bind.attachment

此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。

javax.xml.bind.helpers

仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.crypto

用于 XML 加密的通用类。

javax.xml.crypto.dom

javax.xml.crypto 包的特定于 DOM 的类。

javax.xml.crypto.dsig

用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig.keyinfo

用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.spec

XML 数字签名的参数类。

javax.xml.datatype

XML/Java 类型映射关系。

javax.xml.namespace

XML 名称空间处理。

javax.xml.parsers

提供允许处理 XML 文档的类。

javax.xml.soap

提供用于创建和构建 SOAP 消息的 API。

javax.xml.stream

javax.xml.stream.events

javax.xml.stream.util

javax.xml.transform

此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform.dom

此包实现特定于 DOM 的转换 API。

javax.xml.transform.sax

此包实现特定于 SAX2 的转换 API。

javax.xml.transform.stax

提供特定于 StAX 的转换 API。

javax.xml.transform.stream

此包实现特定于流和 URI 的转换 API。

javax.xml.validation

此包提供了用于 XML 文档验证的 API。

javax.xml.ws

此包包含核心 JAX-WS API。

javax.xml.ws.handler

该包定义用于消息处理程序的 API。

javax.xml.ws.handler.soap

该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws.http

该包定义特定于 HTTP 绑定的 API。

javax.xml.ws.soap

该包定义特定于 SOAP 绑定的 API。

javax.xml.ws.spi

该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.xpath

此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

org.ietf.jgss

此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.omg.CORBA

提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA_2_3

CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA_2_3.portable

提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

org.omg.CORBA.DynAnyPackage

提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。

org.omg.CORBA.ORBPackage

提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。

org.omg.CORBA.portable

提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.TypeCodePackage

提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。

org.omg.CosNaming

为 Java IDL 提供命名服务。

org.omg.CosNaming.NamingContextExtPackage

此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

org.omg.CosNaming.NamingContextPackage

此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.DynamicAny

提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny.DynAnyFactoryPackage

此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

org.omg.DynamicAny.DynAnyPackage

此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.IOP

此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP.CodecFactoryPackage

此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

org.omg.IOP.CodecPackage

此包根据 IOP::Codec IDL 接口定义生成。

org.omg.Messaging

此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。

org.omg.PortableInterceptor

提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor.ORBInitInfoPackage

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableServer

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer.CurrentPackage

提供各种方法实现，这些实现能够访问调用方法的对象的身份。

org.omg.PortableServer.POAManagerPackage

封装 POA 关联的处理状态。

org.omg.PortableServer.POAPackage

允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer.portable

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.stub.java.rmi

包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

org.w3c.dom

为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom.bootstrap

org.w3c.dom.events

org.w3c.dom.ls

org.xml.sax

此包提供了核心 SAX API。

org.xml.sax.ext

此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.helpers

此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 String 的使用

返回 String 的 java.applet 中的方法

String

Applet.getAppletInfo()
返回有关此 applet 的信息。

String

AppletStub.getParameter(String name)
返回 HTML 标记中命名参数的值。

String

Applet.getParameter(String name)
返回 HTML 标记中指定参数的值。

String[][]

Applet.getParameterInfo()
返回此 applet 理解的关于参数的信息。

返回变量类型为 String 的类型的 java.applet 中的方法

Iterator<String>

AppletContext.getStreamKeys()
找到此 applet 上下文中所有流对应的键。

参数类型为 String 的 java.applet 中的方法

Applet

AppletContext.getApplet(String name)
通过给定名称找到并返回此 applet 上下文表示的文档中的 applet。

AudioClip

Applet.getAudioClip(URL url, String name)
返回 URL 和 name 参数指定的 AudioClip 对象。

Image

Applet.getImage(URL url, String name)
返回能被绘制到屏幕上的 Image 对象。

String

AppletStub.getParameter(String name)
返回 HTML 标记中命名参数的值。

String

Applet.getParameter(String name)
返回 HTML 标记中指定参数的值。

InputStream

AppletContext.getStream(String key)
返回此 applet 上下文中指定键所关联的流。

void

Applet.play(URL url, String name)
播放音频剪辑，给定了 URL 及与之相对的说明符。

void

AppletContext.setStream(String key, InputStream stream)
在此 applet 上下文中用指定的键关联指定的流。

void

AppletContext.showDocument(URL url, String target)
请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。

void

AppletContext.showStatus(String status)
请求参数字符串显示在“状态窗口”中。

void

Applet.showStatus(String msg)
请求将参数字符串显示在“状态窗口”中。

java.awt 中 String 的使用

声明为 String 的 java.awt 中的字段

static String

BorderLayout.AFTER_LAST_LINE
与 PAGE_END 同义。

static String

BorderLayout.AFTER_LINE_ENDS
与 LINE_END 同义。

static String

BorderLayout.BEFORE_FIRST_LINE
与 PAGE_START 同义。

static String

BorderLayout.BEFORE_LINE_BEGINS
与 LINE_START 同义。

static String

BorderLayout.CENTER
中间区域的布局约束（容器中央）。

static String

Font.DIALOG
逻辑字体 "Dialog" 的规范系列名称的 String 常量。

static String

Font.DIALOG_INPUT
逻辑字体 "DialogInput" 的规范系列名称的 String 常量。

static String

BorderLayout.EAST
东区域的布局约束（容器右边）。

static String

BorderLayout.LINE_END
组件出现在布局的行方向的结尾处。

static String

BorderLayout.LINE_START
组件出现在布局的行方向的开始处。

static String

Font.MONOSPACED
逻辑字体 "Monospaced" 的规范系列名称的 String 常量。

protected  String

Font.name
Font 的逻辑名称，它被传递到构造方法中。

protected  String

Cursor.name
光标的用户可视名称。

static String

BorderLayout.NORTH
北区域的布局约束（容器顶部）。

static String

BorderLayout.PAGE_END
组件出现在最后一行布局内容之后。

static String

BorderLayout.PAGE_START
组件出现在第一行布局内容之前。

static String

Font.SANS_SERIF
逻辑字体 "SansSerif" 的规范系列名称的 String 常量。

static String

Font.SERIF
逻辑字体 "Serif" 的规范系列名称的 String 常量。

static String

BorderLayout.SOUTH
南区域的布局约束（容器底部）。

static String

BorderLayout.WEST
西区域的布局约束（容器左边）。

类型参数类型为 String 的 java.awt 中的字段

protected  Map<String,Object>

Toolkit.desktopProperties

返回 String 的 java.awt 中的方法

String

Button.AccessibleAWTButton.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

Checkbox.AccessibleAWTCheckbox.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

Choice.AccessibleAWTChoice.getAccessibleActionDescription(int i)
返回对象指定操作的描述。

String

MenuItem.AccessibleAWTMenuItem.getAccessibleActionDescription(int i)
返回对该对象指定操作的描述。

String

MenuComponent.AccessibleAWTMenuComponent.getAccessibleDescription()
获取此对象的可访问的描述。

String

Component.AccessibleAWTComponent.getAccessibleDescription()
获取此对象的可访问描述。

String

Button.AccessibleAWTButton.getAccessibleName()
获取此对象的可访问名称。

String

MenuItem.AccessibleAWTMenuItem.getAccessibleName()
获取此对象的可访问名称。

String

MenuComponent.AccessibleAWTMenuComponent.getAccessibleName()
获取此对象的可访问的名称。

String

Label.AccessibleAWTLabel.getAccessibleName()
获取此对象的可访问名称。

String

Component.AccessibleAWTComponent.getAccessibleName()
获取此对象的可访问名称。

String

Button.getActionCommand()
返回此按钮激发的动作事件的命令名称。

String

TrayIcon.getActionCommand()
返回由此托盘图标触发的动作事件的命令名。

String

MenuItem.getActionCommand()
获取由此菜单项引发的动作事件的命令名。

String

TextComponent.AccessibleAWTTextComponent.getAfterIndex(int part, int index)
返回给定索引后面的 String。

String

TextComponent.AccessibleAWTTextComponent.getAtIndex(int part, int index)
返回给定索引处的 String。

abstract  String[]

GraphicsEnvironment.getAvailableFontFamilyNames()
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，它针对默认语言环境进行了本地化，由 Locale.getDefault() 返回。

abstract  String[]

GraphicsEnvironment.getAvailableFontFamilyNames(Locale l)
返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。

String

TextComponent.AccessibleAWTTextComponent.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

FileDialog.getDirectory()
获取此文件对话框的目录。

String

Font.getFamily()
返回此 Font 的系列名称。

String

Font.getFamily(Locale l)
返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。

String

FileDialog.getFile()
获取此文件对话框的选定文件。

String

JobAttributes.getFileName()
指定使用这些属性的作业的输出文件的文件名。

abstract  String[]

Toolkit.getFontList()
已过时。 请参阅 GraphicsEnvironment.getAvailableFontFamilyNames()

String

Font.getFontName()
返回此 Font 的字体外观名称。

String

Font.getFontName(Locale l)
返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。

abstract  String

GraphicsDevice.getIDstring()
返回与此 GraphicsDevice 关联的标识字符串。

String

Choice.getItem(int index)
获取此 Choice 菜单中指定索引上的字符串。

String

List.getItem(int index)
获取与指定索引关联的项。

String[]

List.getItems()
获取列表中的项。

String

Button.getLabel()
获取此按钮的标签。

String

Checkbox.getLabel()
获取此复选框的标签。

String

MenuItem.getLabel()
获取此菜单项的标签。

String

HeadlessException.getMessage()

String

MenuComponent.getName()
获取该菜单组件的名称。

String

Font.getName()
返回此 Font 的逻辑名称。

String

Cursor.getName()
返回此光标的名称。

String

Component.getName()
获取组件的名称。

String

JobAttributes.getPrinter()
为使用这些属性的作业返回目标打印机。

static String

Toolkit.getProperty(String key, String defaultValue)
获取具有指定键和默认值的属性。

String

Font.getPSName()
返回此 Font 的 postscript 名称。

String

Choice.getSelectedItem()
获取当前选择的字符串表示形式。

String

List.getSelectedItem()
获取此滚动列表中选中的项。

String[]

List.getSelectedItems()
获取此滚动列表中选中的项。

String

TextComponent.getSelectedText()
返回此文本组件所表示文本的选定文本。

String

TextComponent.AccessibleAWTTextComponent.getSelectedText()
返回选定文本的一部分。

String

TextComponent.getText()
返回此文本组件表示的文本。

String

Label.getText()
获取此标签的文本。

String

Dialog.getTitle()
获取 dialog 的标题。

String

Frame.getTitle()
获得窗体的标题。

String

TrayIcon.getToolTip()
返回与此 TrayIcon 关联的工具提示字符串。

String

Window.getWarningString()
获取此窗口中显示的警告字符串。

protected  String

Button.paramString()
返回此 Button 状态的字符串表示形式。

protected  String

Checkbox.paramString()
返回表示此 Checkbox 的状态的字符串。

String

CheckboxMenuItem.paramString()
返回表示此 CheckBoxMenuItem 状态的字符串。

protected  String

Choice.paramString()
返回表示此 Choice 菜单的状态的字符串。

protected  String

FileDialog.paramString()
返回表示此 FileDialog 窗口状态的字符串。

protected  String

List.paramString()
返回表示此滚动列表状态的参数字符串。

String

ScrollPane.paramString()
返回表示此 ScrollPane 的状态的字符串。

String

ScrollPaneAdjustable.paramString()
返回表示此滚动条的状态的字符串。

protected  String

Scrollbar.paramString()
返回表示此 Scrollbar 当前状态的字符串表示形式。

protected  String

TextArea.paramString()
返回表示此 TextArea 状态的字符串。

protected  String

TextComponent.paramString()
返回表示此 TextComponent 状态的字符串。

protected  String

TextField.paramString()
返回表示此 TextField 状态的字符串。

protected  String

MenuShortcut.paramString()
返回表示此 MenuShortcut 状态的参数字符串。

protected  String

Event.paramString()
注：Event 类已废弃，只可用于向后兼容。

String

Menu.paramString()
返回表示此 Menu 状态的字符串。

String

MenuItem.paramString()
返回表示此 MenuItem 状态的字符串。

protected  String

MenuComponent.paramString()
返回表示此 MenuComponent 状态的字符串。

protected  String

Dialog.paramString()
返回表示此 dialog 状态的字符串。

String

AWTEvent.paramString()
返回表示此 Event 状态的字符串。

protected  String

Label.paramString()
返回一个表示此 Label 状态的字符串。

protected  String

Frame.paramString()
返回表示此 Frame 状态的字符串。

protected  String

Container.paramString()
返回表示此 Container 的状态的字符串。

protected  String

Component.paramString()
返回此组件状态的字符串表示形式。

String

CheckboxGroup.toString()
返回此复选框组的字符串表示形式，包含当前选中复选框的值。

String

GridBagLayout.toString()
返回此网格包布局的值的字符串表示形式。

String

JobAttributes.toString()
返回此 JobAttributes 的字符串表示形式。

String

PageAttributes.toString()
返回此 PageAttributes 的字符串表示形式。

String

Robot.toString()
返回此 Robot 的字符串表示形式。

String

ScrollPaneAdjustable.toString()
返回此滚动条及其值的字符串表示形式。

String

MenuShortcut.toString()
返回此菜单快捷方式的国际化描述。

String

GridLayout.toString()
返回此网格布局的值的字符串表示形式。

String

CardLayout.toString()
返回此卡片布局状态的字符串表示形式。

String

FlowLayout.toString()
返回此 FlowLayout 对象及其值的字符串表示形式。

String

FontMetrics.toString()
返回此 FontMetrics 对象的值的 String 表示形式。

String

Event.toString()
注：Event 类已废弃，只可用于向后兼容。

String

MenuComponent.toString()
返回此菜单组件的表示形式。

String

Point.toString()
返回此点的字符串表示形式及其在 (x,y) 坐标空间中的位置。

String

SystemColor.toString()
返回此 Color 值的字符串表示形式。

String

AWTKeyStroke.toString()
返回一个显示并标识此对象属性的字符串。

String

Insets.toString()
返回此 Insets 对象的字符串表示形式。

String

Rectangle.toString()
返回表示此 Rectangle 及其值的 String。

String

BorderLayout.toString()
返回此边框布局的状态的字符串表示形式。

String

Color.toString()
返回此 Color 的字符串表示形式。

String

Graphics.toString()
返回表示此 Graphics 对象值的 String 对象。

String

RenderingHints.toString()
返回 hashmap 的一个相当长的字符串表示形式，该 hashmap 包含此 RenderingHints 对象的键或值的映射关系。

String

Font.toString()
将此 Font 对象转换为 String 表示形式。

String

Cursor.toString()
返回此光标的字符串表示形式。

String

Dimension.toString()
返回此 Dimension 对象的 height 和 width 字段的字符串表示形式。

String

AWTEvent.toString()
返回此对象的字符串表示形式。

String

Component.toString()
返回此组件及其值的字符串表示形式。

参数类型为 String 的 java.awt 中的方法

void

Choice.add(String item)
将一个项添加到此 Choice 菜单中。

void

List.add(String item)
向滚动列表的末尾添加指定的项。

void

Menu.add(String label)
将带有指定标签的项添加到此菜单。

Component

Container.add(String name, Component comp)
将指定组件添加到此容器中。

void

List.add(String item, int index)
向滚动列表中索引指示的位置添加指定的项。

void

Choice.addItem(String item)
如果对于 Java 2 platform v1.1 已过时，请使用 add 方法替换。

void

List.addItem(String item)
已过时。 由 add(String) 取代。

void

List.addItem(String item, int index)
已过时。 由 add(String, int) 取代。

void

GridBagLayout.addLayoutComponent(String name, Component comp)
无效，因为此布局管理器不使用每组件字符串。

void

GridLayout.addLayoutComponent(String name, Component comp)
将具有指定名称的指定组件添加到布局。

void

CardLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。

void

FlowLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。

void

BorderLayout.addLayoutComponent(String name, Component comp)
已过时。 由 addLayoutComponent(Component, Object) 取代。

void

LayoutManager.addLayoutComponent(String name, Component comp)
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

void

SystemTray.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 添加到特定属性的侦听器列表中。

void

KeyboardFocusManager.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 添加到特定属性的侦听器列表。

void

Toolkit.addPropertyChangeListener(String name, PropertyChangeListener pcl)
为指定的桌面属性添加指定的属性更改侦听器。

void

Window.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 添加到某个特定属性的侦听器列表。

void

Container.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到某个指定属性的侦听器列表中。

void

Component.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
向指定属性的侦听器列表添加一个 PropertyChangeListener。

void

KeyboardFocusManager.addVetoableChangeListener(String propertyName, VetoableChangeListener listener)
将 VetoableChangeListener 添加到特定属性的侦听器列表。

void

TextArea.append(String str)
将给定文本追加到文本区的当前文本。

void

TextArea.appendText(String str)
已过时。 从 JDK version 1.1 开始，由 append(String) 取代。

void

Window.applyResourceBundle(String rbName)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。

int

Font.canDisplayUpTo(String str)
指示此 Font 是否可以显示指定的 String。

Cursor

Toolkit.createCustomCursor(Image cursor, Point hotSpot, String name)
创建一个新的自定义光标对象。

GlyphVector

Font.createGlyphVector(FontRenderContext frc, String str)
根据此 Font 中的 Unicode cmap 将字符一一映射到字形，从而创建一个 GlyphVector。

abstract  Image

Toolkit.createImage(String filename)
返回从指定文件获取像素数据的图像。

static Color

Color.decode(String nm)
将 String 转换成整数，并返回指定的不透明 Color。

static Font

Font.decode(String str)
返回 str 参数所描述的 Font。

void

TrayIcon.displayMessage(String caption, String text, TrayIcon.MessageType messageType)
在托盘图标附近显示弹出消息。

abstract  void

Graphics2D.drawString(String str, float x, float y)
使用 Graphics2D 上下文中当前文本属性状态呈现由指定 String 指定的文本。

abstract  void

Graphics2D.drawString(String str, int x, int y)
使用 Graphics2D 上下文中的当前文本属性状态呈现指定的 String 的文本。

abstract  void

Graphics.drawString(String str, int x, int y)
使用此图形上下文的当前字体和颜色绘制由指定 string 给定的文本。

protected  void

Component.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
支持报告布尔属性的绑定属性改变。

void

Component.firePropertyChange(String propertyName, byte oldValue, byte newValue)
报告绑定属性的改变。

void

Component.firePropertyChange(String propertyName, char oldValue, char newValue)
报告绑定属性的改变。

void

Component.firePropertyChange(String propertyName, double oldValue, double newValue)
报告绑定属性的改变。

void

Component.firePropertyChange(String propertyName, float oldValue, float newValue)
报告绑定属性的改变。

protected  void

Component.firePropertyChange(String propertyName, int oldValue, int newValue)
支持报告整数属性的绑定属性改变。

void

Component.firePropertyChange(String propertyName, long oldValue, long newValue)
报告绑定属性的改变。

protected  void

KeyboardFocusManager.firePropertyChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应绑定属性中的更改。

protected  void

Component.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 Object 属性的绑定属性改变。

void

Component.firePropertyChange(String propertyName, short oldValue, short newValue)
报告绑定属性的改变。

protected  void

KeyboardFocusManager.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应可否决属性中的更改。

static AWTKeyStroke

AWTKeyStroke.getAWTKeyStroke(String s)
分析字符串并返回一个 AWTKeyStroke。

static Color

Color.getColor(String nm)
查找系统属性中的一种颜色。

static Color

Color.getColor(String nm, Color v)
查找系统属性中的一种颜色。

static Color

Color.getColor(String nm, int v)
查找系统属性中的一种颜色。

Object

Toolkit.getDesktopProperty(String propertyName)
获取指定桌面属性的值。

static Font

Font.getFont(String nm)
从系统属性列表返回一个 Font 对象。

static Font

Font.getFont(String nm, Font font)
从系统属性列表获取指定的 Font。

protected abstract  java.awt.peer.FontPeer

Toolkit.getFontPeer(String name, int style)
已过时。 请参阅 java.awt.GraphicsEnvironment#getAllFonts

abstract  Image

Toolkit.getImage(String filename)
返回一幅图像，该图像从指定文件中获取像素数据，图像格式可以是 GIF、JPEG 或 PNG。

LineMetrics

Font.getLineMetrics(String str, FontRenderContext frc)
返回一个使用指定 String 和 FontRenderContext 创建的 LineMetrics 对象。

LineMetrics

FontMetrics.getLineMetrics(String str, Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

LineMetrics

Font.getLineMetrics(String str, int beginIndex, int limit, FontRenderContext frc)
返回使用指定参数创建的 LineMetrics 对象。

LineMetrics

FontMetrics.getLineMetrics(String str, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定 String 的 LineMetrics 对象。

PrintJob

Toolkit.getPrintJob(Frame frame, String jobtitle, JobAttributes jobAttributes, PageAttributes pageAttributes)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

abstract  PrintJob

Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

abstract  Object

Image.getProperty(String name, ImageObserver observer)
通过名称获取此图像的属性。

static String

Toolkit.getProperty(String key, String defaultValue)
获取具有指定键和默认值的属性。

PropertyChangeListener[]

SystemTray.getPropertyChangeListeners(String propertyName)
返回与指定属性关联的所有侦听器的数组。

PropertyChangeListener[]

KeyboardFocusManager.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有 PropertyChangeListener 组成的数组。

PropertyChangeListener[]

Toolkit.getPropertyChangeListeners(String propertyName)
返回与指定属性关联的所有 PropertyChangeListener 所组成的数组。

PropertyChangeListener[]

Component.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的数组。

Rectangle2D

Font.getStringBounds(String str, FontRenderContext frc)
返回指定 FontRenderContext 中指定 String 的逻辑边界。

Rectangle2D

FontMetrics.getStringBounds(String str, Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。

Rectangle2D

Font.getStringBounds(String str, int beginIndex, int limit, FontRenderContext frc)
返回指定 FontRenderContext 中指定 String 的逻辑边界。

Rectangle2D

FontMetrics.getStringBounds(String str, int beginIndex, int limit, Graphics context)
返回指定 Graphics 上下文中指定 String 的边界。

static Cursor

Cursor.getSystemCustomCursor(String name)
返回与指定名称匹配的特定于系统的定制光标对象。

VetoableChangeListener[]

KeyboardFocusManager.getVetoableChangeListeners(String propertyName)
返回与指定属性相关联的所有 VetoableChangeListener 组成的数组。

void

Choice.insert(String item, int index)
将菜单项插入此选择的指定位置上。

void

TextArea.insert(String str, int pos)
在此文本区的指定位置插入指定文本。

void

Menu.insert(String label, int index)
将带有指定标签的菜单项插入到此菜单的指定位置。

void

TextArea.insertText(String str, int pos)
已过时。 从 JDK version 1.1 开始，由 insert(String, int) 取代。

protected  Object

Toolkit.lazilyLoadDesktopProperty(String name)
一个对桌面属性值延迟计算的机会。

void

Choice.remove(String item)
移除 Choice 菜单中第一个出现的 item。

void

List.remove(String item)
从列表中移除项的第一次出现。

void

SystemTray.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
从特定属性的侦听器列表中移除 PropertyChangeListener。

void

KeyboardFocusManager.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
从特定属性的侦听器列表移除 PropertyChangeListener。

void

Toolkit.removePropertyChangeListener(String name, PropertyChangeListener pcl)
为指定的桌面属性移除指定的属性更改侦听器。

void

Component.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
从指定属性的侦听器列表中移除一个 PropertyChangeListener。

void

KeyboardFocusManager.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener)
从特定属性的侦听器列表移除 VetoableChangeListener。

void

List.replaceItem(String newValue, int index)
使用新字符串替换滚动列表中指定索引处的项。

void

TextArea.replaceRange(String str, int start, int end)
用指定替换文本替换指定开始位置与结束位置之间的文本。

void

TextArea.replaceText(String str, int start, int end)
已过时。 从 JDK version 1.1 开始，由 replaceRange(String, int, int) 取代。

protected static void

AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)

protected  void

AWTEventMulticaster.saveInternal(ObjectOutputStream s, String k)

void

Choice.select(String str)
将此 Choice 菜单中的选定项设置为其名称等于指定字符串的项。

void

Button.setActionCommand(String command)
设置此按钮激发的动作事件的命令名称。

void

TrayIcon.setActionCommand(String command)
设置由此托盘图标触发的动作事件的命令名。

void

MenuItem.setActionCommand(String command)
设置由此菜单项引发的动作事件的命令名。

protected  void

Toolkit.setDesktopProperty(String name, Object newValue)
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。

void

FileDialog.setDirectory(String dir)
将此文件对话框窗口的目录设置为指定目录。

void

FileDialog.setFile(String file)
将此文件对话框窗口的选定文件设置为指定文件。

void

JobAttributes.setFileName(String fileName)
指定使用这些属性的作业的输出文件的文件名。

void

Button.setLabel(String label)
将按钮的标签设置为指定的字符串。

void

Checkbox.setLabel(String label)
将此复选框的标签设置为字符串参数。

void

MenuItem.setLabel(String label)
将此菜单项的标签设置为指定标签。

void

MenuComponent.setName(String name)
将该组件的名称设置为指定字符串。

void

Component.setName(String name)
将组件的名称设置为指定的字符串。

void

JobAttributes.setPrinter(String printer)
为使用这些属性的作业指定目标打印机。

void

TextComponent.setText(String t)
将此文本组件显示的文本设置为指定文本。

void

TextField.setText(String t)
将此文本组件显示的文本设置为指定文本。

void

Label.setText(String text)
将此标签的文本设置为指定的文本。

void

Dialog.setTitle(String title)
设置 Dialog 的标题。

void

Frame.setTitle(String title)
将此窗体的标题设置为指定的字符串。

void

TrayIcon.setToolTip(String tooltip)
设置此 TrayIcon 的工具提示字符串。

void

CardLayout.show(Container parent, String name)
翻转到使用 addLayoutComponent 添加到此布局的具有指定 name 的组件。

int

FontMetrics.stringWidth(String str)
返回此 Font 中指定 String 的总 advance width。

static Desktop.Action

Desktop.Action.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static MultipleGradientPaint.CycleMethod

MultipleGradientPaint.CycleMethod.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static MultipleGradientPaint.ColorSpaceType

MultipleGradientPaint.ColorSpaceType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static TrayIcon.MessageType

TrayIcon.MessageType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Dialog.ModalityType

Dialog.ModalityType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Dialog.ModalExclusionType

Dialog.ModalExclusionType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Component.BaselineResizeBehavior

Component.BaselineResizeBehavior.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.awt 中的构造方法

AWTError(String msg)
构造带指定详细消息的 AWTError 的实例。

AWTException(String msg)
构造带指定详细消息的 AWTException 实例。

AWTPermission(String name)
创建具有指定名称的新 AWTPermission。

AWTPermission(String name, String actions)
创建具有指定名称的新 AWTPermission 对象。

Button(String label)
构造一个带指定标签的按钮。

Checkbox(String label)
使用指定标签创建一个复选框。

Checkbox(String label, boolean state)
使用指定标签创建一个复选框，并将它设置为指定状态。

Checkbox(String label, boolean state, CheckboxGroup group)
构造具有指定标签的 Checkbox，并将它设置为指定状态，使它处于指定复选框组中。

Checkbox(String label, CheckboxGroup group, boolean state)
创建具有指定标签的 Checkbox，并使它处于指定复选框组内，将它设置为指定状态。

CheckboxMenuItem(String label)
创建具有指定标签的复选框菜单项。

CheckboxMenuItem(String label, boolean state)
创建 具有指定标签和状态的复选框菜单项。

Cursor(String name)
用指定名称创建一个新的定制光标对象。

Dialog(Dialog owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Dialog 和标题。

Dialog(Dialog owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题和模式。

Dialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Dialog、标题、模式和 GraphicsConfiguration。

Dialog(Frame owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Frame 和标题。

Dialog(Frame owner, String title, boolean modal)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题和模式。

Dialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Frame、标题、模式和 GraphicsConfiguration。

Dialog(Window owner, String title)
构造一个最初不可见的、无模式的 Dialog，它带有指定的所有者 Window 和标题。

Dialog(Window owner, String title, Dialog.ModalityType modalityType)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题和模式。

Dialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
构造一个最初不可见的 Dialog，它带有指定的所有者 Window、标题、模式和 GraphicsConfiguration。

FileDialog(Dialog parent, String title)
创建一个具有指定标题的文件对话框，用于加载文件。

FileDialog(Dialog parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

FileDialog(Frame parent, String title)
创建一个具有指定标题的文件对话框窗口，用于加载文件。

FileDialog(Frame parent, String title, int mode)
创建一个具有指定标题的文件对话框窗口，用于加载或保存文件。

Font(String name, int style, int size)
根据指定名称、样式和磅值大小，创建一个新 Font。

FontFormatException(String reason)
报告一个指定了原因的 FontFormatException。

Frame(String title)
构造一个新的、最初不可见的、具有指定标题的 Frame 对象。

Frame(String title, GraphicsConfiguration gc)
构造一个新的、初始不可见的、具有指定标题和 GraphicsConfiguration 的 Frame 对象。

HeadlessException(String msg)

IllegalComponentStateException(String s)
构造带指定详细消息的 IllegalComponentStateException。

JobAttributes(int copies, JobAttributes.DefaultSelectionType defaultSelection, JobAttributes.DestinationType destination, JobAttributes.DialogType dialog, String fileName, int maxPage, int minPage, JobAttributes.MultipleDocumentHandlingType multipleDocumentHandling, int[][] pageRanges, String printer, JobAttributes.SidesType sides)
构造一个具有每个属性指定值的 JobAttributes 实例。

Label(String text)
使用指定的文本字符串构造一个新的标签，其文本对齐方式为左对齐。

Label(String text, int alignment)
构造一个显示指定的文本字符串的新标签，其文本对齐方式为指定的方式。

Menu(String label)
构造具有指定标签的新菜单。

Menu(String label, boolean tearOff)
构造具有指定标签的新菜单，指示该菜单是否可以分离。

MenuItem(String label)
构造具有指定的标签且没有键盘快捷方式的新菜单项。

MenuItem(String label, MenuShortcut s)
创建具有关联的键盘快捷方式的菜单项。

PopupMenu(String label)
创建具有指定名称的新弹出式菜单。

TextArea(String text)
构造具有指定文本的新文本区。

TextArea(String text, int rows, int columns)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数和列数。

TextArea(String text, int rows, int columns, int scrollbars)
构造一个新文本区，该文本区具有指定的文本，以及指定的行数、列数和滚动条可见性。

TextField(String text)
构造使用指定文本初始化的新文本字段。

TextField(String text, int columns)
构造使用要显示的指定文本初始化的新文本字段，宽度足够容纳指定列数。

TrayIcon(Image image, String tooltip)
创建带有指定图像和工具提示文本的 TrayIcon。

TrayIcon(Image image, String tooltip, PopupMenu popup)
创建带指定图像、工具提示和弹出菜单的 TrayIcon。

java.awt.color 中 String 的使用

返回 String 的 java.awt.color 中的方法

String

ColorSpace.getName(int idx)
返回给定分量索引处的分量名称。

参数类型为 String 的 java.awt.color 中的方法

static ICC_Profile

ICC_Profile.getInstance(String fileName)
构造一个与文件中的数据相对应的 ICC_Profile。

void

ICC_Profile.write(String fileName)
将此 ICC_Profile 写入一个文件。

参数类型为 String 的 java.awt.color 中的构造方法

CMMException(String s)
构造带指定详细消息的 CMMException。

ProfileDataException(String s)
构造带指定详细消息的 ProfileDataException。

java.awt.datatransfer 中 String 的使用

声明为 String 的 java.awt.datatransfer 中的字段

static String

DataFlavor.javaJVMLocalObjectMimeType
要将一个引用传输到不具有关联 MIME Content 类型的任意 Java 对象引用（跨越同一 JVM 中的 Transferable 接口），需要使用具有此类型/子类型的 DataFlavor，其中 representationClass 等于跨越 Transferable 传递的类/接口的类型。

static String

DataFlavor.javaRemoteObjectMimeType
为了通过拖放 ACTION_LINK 操作将活动链接传递到 Remote 对象，应该使用 Mime Content 类型的 application/x-java-remote-object，其中 DataFlavor 的表示形式类表示要传输的 Remote 接口的类型。

static String

DataFlavor.javaSerializedObjectMimeType
MIME Content 类型的 application/x-java-serialized-object 表示已变得持久的 Java 对象的图形。

返回 String 的 java.awt.datatransfer 中的方法

static String

SystemFlavorMap.decodeJavaMIMEType(String nat)
解码 String native 以用作 Java MIME 类型。

static String

SystemFlavorMap.encodeDataFlavor(DataFlavor flav)
编码 DataFlavor 以用作 String native。

static String

SystemFlavorMap.encodeJavaMIMEType(String mimeType)
编码 MIME 类型以用作 String native。

String

DataFlavor.getDefaultRepresentationClassAsString()

String

DataFlavor.getHumanPresentableName()
返回此 DataFlavor 表示的数据格式的得体的名称。

String

DataFlavor.getMimeType()
返回此 DataFlavor 的 MIME 类型字符串。

String

Clipboard.getName()
返回此剪贴板对象的名称。

String

DataFlavor.getParameter(String paramName)
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。

String

DataFlavor.getPrimaryType()
返回此 DataFlavor 的基本 MIME 类型。

String

DataFlavor.getSubType()
返回此 DataFlavor 的子 MIME 类型。

protected  String

DataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

DataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

String

DataFlavor.toString()
此 DataFlavor 及其参数的字符串表示形式。

返回变量类型为 String 的类型的 java.awt.datatransfer 中的方法

Map<String,DataFlavor>

SystemFlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其大多数首选 DataFlavor 的 Map。

Map<String,DataFlavor>

FlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其相应 DataFlavor 的 Map。

List<String>

SystemFlavorMap.getNativesForFlavor(DataFlavor flav)
返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。

List<String>

FlavorTable.getNativesForFlavor(DataFlavor flav)
返回与指定 DataFlavor 对应的 String native 的 List。

Map<DataFlavor,String>

SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors)
返回指定 DataFlavor 到其大多数首选的 String native 的 Map。

Map<DataFlavor,String>

FlavorMap.getNativesForFlavors(DataFlavor[] flavors)
返回指定 DataFlavor 到其对应的 String native 的 Map。

参数类型为 String 的 java.awt.datatransfer 中的方法

void

SystemFlavorMap.addFlavorForUnencodedNative(String nat, DataFlavor flav)
添加从单个 String native 到单个 DataFlavor 的映射。

void

SystemFlavorMap.addUnencodedNativeForFlavor(DataFlavor flav, String nat)
添加从指定的 DataFlavor（和等于指定 DataFlavor 的所有 DataFlavor）到指定 String native 的映射。

static DataFlavor

SystemFlavorMap.decodeDataFlavor(String nat)
解码 String native 以用作 DataFlavor。

static String

SystemFlavorMap.decodeJavaMIMEType(String nat)
解码 String native 以用作 Java MIME 类型。

static String

SystemFlavorMap.encodeJavaMIMEType(String mimeType)
编码 MIME 类型以用作 String native。

boolean

DataFlavor.equals(String s)
已过时。 与 hashCode() 协定不一致，使用 isMimeTypeEqual(String) 代替。

List<DataFlavor>

SystemFlavorMap.getFlavorsForNative(String nat)
返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。

List<DataFlavor>

FlavorTable.getFlavorsForNative(String nat)
返回与指定 String 对应的 DataFlavor 的 List。

Map<String,DataFlavor>

SystemFlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其大多数首选 DataFlavor 的 Map。

Map<String,DataFlavor>

FlavorMap.getFlavorsForNatives(String[] natives)
返回指定 String native 到其相应 DataFlavor 的 Map。

String

DataFlavor.getParameter(String paramName)
如果 paramName 等于 "humanPresentableName"，则返回此 DataFlavor 的得体的名称。

static boolean

SystemFlavorMap.isJavaMIMEType(String str)
返回指定的 String 是否为编码的 Java MIME 类型。

boolean

DataFlavor.isMimeTypeEqual(String mimeType)
返回传入的 MIME 类型的字符串表示形式是否等于此 DataFlavor 的 MIME 类型。

protected  String

DataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

DataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

void

SystemFlavorMap.setFlavorsForNative(String nat, DataFlavor[] flavors)
放弃指定 String native 的当前映射，而创建指定 DataFlavor 的新映射。

void

DataFlavor.setHumanPresentableName(String humanPresentableName)
设置此 DataFlavor 表示的数据格式的得体的名称。

void

SystemFlavorMap.setNativesForFlavor(DataFlavor flav, String[] natives)
放弃指定 DataFlavor 和等于指定 DataFlavor 的所有 DataFlavor 的当前映射，并创建到指定 String native 的新映射。

protected static Class<?>

DataFlavor.tryToLoadClass(String className, ClassLoader fallback)
试图从以下位置加载类：引导加载器、系统加载器、上下文加载器（如果存在）和指定的最终加载器。

参数类型为 String 的 java.awt.datatransfer 中的构造方法

Clipboard(String name)
创建剪贴板对象。

DataFlavor(Class<?> representationClass, String humanPresentableName)
构造一个表示 Java 类的 DataFlavor。

DataFlavor(String mimeType)
根据 mimeType 字符串构造 DataFlavor。

DataFlavor(String mimeType, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

DataFlavor(String mimeType, String humanPresentableName, ClassLoader classLoader)
构造一个表示 MimeType 的 DataFlavor。

MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。

StringSelection(String data)
创建能传输指定 String 的 Transferable。

java.awt.dnd 中 String 的使用

参数类型为 String 的 java.awt.dnd 中的构造方法

InvalidDnDOperationException(String msg)
创建一个带有其自身描述性消息的异常。

java.awt.event 中 String 的使用

返回 String 的 java.awt.event 中的方法

String

ActionEvent.getActionCommand()
返回与此动作相关的命令字符串。

static String

KeyEvent.getKeyModifiersText(int modifiers)
返回描述修改键的 String，如 "Shift" 或 "Ctrl+Shift"。

static String

KeyEvent.getKeyText(int keyCode)
返回描述 keyCode 的 String，如 "HOME"、"F1" 或 "A"。

static String

InputEvent.getModifiersExText(int modifiers)
返回描述扩展修改键和鼠标按钮（例如 "Shift"、"Button1" 或 "Ctrl+Shift"）的 String。

static String

MouseEvent.getMouseModifiersText(int modifiers)
返回一个描述事件期间所按下的修改键和鼠标按键（如“Shift”或“Ctrl+Shift”）的 String。

String

TextEvent.paramString()
返回标识此文本事件的参数字符串。

String

ItemEvent.paramString()
返回标识此项事件的参数字符串。

String

AdjustmentEvent.paramString()

String

ContainerEvent.paramString()
返回标识此事件的参数字符串。

String

ActionEvent.paramString()
返回标识此动作事件的参数字符串。

String

WindowEvent.paramString()
返回标识此事件的参数字符串。

String

InputMethodEvent.paramString()
返回标识此事件的参数字符串。

String

HierarchyEvent.paramString()
返回标识此事件的参数字符串。

String

FocusEvent.paramString()
返回标识此事件的参数字符串。

String

MouseWheelEvent.paramString()
返回标识此事件的参数字符串。

String

InvocationEvent.paramString()
返回标识此事件的参数字符串。

String

PaintEvent.paramString()

String

MouseEvent.paramString()
返回标识此事件的参数字符串。

String

KeyEvent.paramString()
返回标识此事件的参数字符串。

String

ComponentEvent.paramString()
返回标识此事件的参数字符串。

参数类型为 String 的 java.awt.event 中的构造方法

ActionEvent(Object source, int id, String command)
构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, int modifiers)
使用修改键构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, long when, int modifiers)
使用指定修改键和时间戳构造一个 ActionEvent 对象。

java.awt.font 中 String 的使用

返回 String 的 java.awt.font 中的方法

String[]

MultipleMaster.getDesignAxisNames()
返回每个设计轴的名称。

String

NumericShaper.toString()
返回描述此成形器的 String。

String

TextHitInfo.toString()
返回表示此 TextHitInfo 的 String，只用于调试目的。

String

TextLayout.toString()
返回此 TextLayout 的调试信息。

参数类型为 String 的 java.awt.font 中的方法

byte[]

OpenType.getFontTable(String strSfntTag)
返回作为指定标签字节数组的表。

byte[]

OpenType.getFontTable(String strSfntTag, int offset, int count)
返回作为指定标签字节数组的表的子集。

int

OpenType.getFontTableSize(String strSfntTag)
返回指定标签的表的大小。

参数类型为 String 的 java.awt.font 中的构造方法

TextAttribute(String name)
构造一个具有指定名称的 TextAttribute。

TextLayout(String string, Font font, FontRenderContext frc)
根据 String 和 Font 构造一个 TextLayout。

TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。

java.awt.geom 中 String 的使用

返回 String 的 java.awt.geom 中的方法

String

Rectangle2D.Float.toString()
返回此 Rectangle2D 的 String 表示形式。

String

Rectangle2D.Double.toString()
返回此 Rectangle2D 的 String 表示形式。

String

Point2D.Float.toString()
返回表示此 Point2D 值的 String。

String

Point2D.Double.toString()
返回表示此 Point2D 值的 String。

String

AffineTransform.toString()
返回表示此 Object 值的 String。

参数类型为 String 的 java.awt.geom 中的构造方法

IllegalPathStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。

NoninvertibleTransformException(String s)
构造具有指定详细消息的 NoninvertibleTransformException 的实例。

java.awt.im.spi 中 String 的使用

返回 String 的 java.awt.im.spi 中的方法

String

InputMethodDescriptor.getInputMethodDisplayName(Locale inputLocale, Locale displayLanguage)
用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。

参数类型为 String 的 java.awt.im.spi 中的方法

JFrame

InputMethodContext.createInputMethodJFrame(String title, boolean attachToInputContext)
创建输入方法使用的顶层 Swing JFrame。

Window

InputMethodContext.createInputMethodWindow(String title, boolean attachToInputContext)
创建输入方法使用的顶层窗口。

java.awt.image 中 String 的使用

返回 String 的 java.awt.image 中的方法

String[]

BufferedImage.getPropertyNames()
返回由 getProperty(String) 识别的名称数组；如果没有识别出属性名，则返回 null。

String[]

RenderedImage.getPropertyNames()
返回由 getProperty(String) 识别的名称的数组，如果没有属性名被识别，则返回 null。

String

BufferedImage.toString()
返回此 BufferedImage 对象及其值的 String 表示形式。

String

IndexColorModel.toString()
返回此 ColorModel 对象内容的 String 表示形式。

String

DirectColorModel.toString()
返回表示此 DirectColorModel 的 String。

String

ColorModel.toString()
返回此 ColorModel 对象的内容的 String 表示形式。

参数类型为 String 的 java.awt.image 中的方法

Object

BufferedImage.getProperty(String name)
按名称返回图像的属性。

Object

RenderedImage.getProperty(String name)
从此图像的属性设置中获取一个属性。

Object

BufferedImage.getProperty(String name, ImageObserver observer)
按名称返回图像的属性。

参数类型为 String 的 java.awt.image 中的构造方法

ImagingOpException(String s)
构造带指定消息的 ImagingOpException 对象。

RasterFormatException(String s)
构造带指定消息的新 RasterFormatException。

java.awt.image.renderable 中 String 的使用

声明为 String 的 java.awt.image.renderable 中的字段

static String

RenderableImage.HINTS_OBSERVED
可以用于在通过 createRendering 或 createScaledRendering 方法获取的 RenderedImage 上标识属性的字符串常量。

返回 String 的 java.awt.image.renderable 中的方法

String[]

ContextualRenderedImageFactory.getPropertyNames()
返回由 getProperty 识别的名称列表。

String[]

RenderableImage.getPropertyNames()
返回由 getProperty 识别的名称列表。

String[]

RenderableImageOp.getPropertyNames()
返回由 getProperty 识别的名称列表。

参数类型为 String 的 java.awt.image.renderable 中的方法

Object

ContextualRenderedImageFactory.getProperty(ParameterBlock paramBlock, String name)
获取由 name 参数指定的属性的适当实例。

Object

RenderableImage.getProperty(String name)
从此图像的属性集中获取某个属性。

Object

RenderableImageOp.getProperty(String name)
从此图像的属性集中获取某个属性。

java.awt.print 中 String 的使用

返回 String 的 java.awt.print 中的方法

abstract  String

PrinterJob.getJobName()
获取要打印的文档名称。

abstract  String

PrinterJob.getUserName()
获取打印用户的名称。

参数类型为 String 的 java.awt.print 中的方法

static StreamPrintServiceFactory[]

PrinterJob.lookupStreamPrintServices(String mimeType)
定位可以成像 2D 图形的流打印服务工厂的便捷方法。

abstract  void

PrinterJob.setJobName(String jobName)
设置要打印的文档名称。

参数类型为 String 的 java.awt.print 中的构造方法

PrinterAbortException(String msg)
构造带指定详细信息的新 PrinterAbortException。

PrinterException(String msg)
构造带指定详细信息的新 PrinterException 对象。

java.beans 中 String 的使用

声明为 String 的 java.beans 中的字段

static String

DesignMode.PROPERTYNAME
从 BeanContext 或 PropertyChangeEvent 的其他源激发的 propertyName 的标准值。

返回 String 的 java.beans 中的方法

static String

Introspector.decapitalize(String name)
获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。

String

EventHandler.getAction()
返回此事件处理程序将设置的目标的可写属性名称，或者此事件处理程序将在目标上调用的方法名称。

String

PropertyEditor.getAsText()
以文本形式获得属性值。

String

PropertyEditorSupport.getAsText()
获得人类可编辑的适当字符串表示形式的属性值。

static String[]

Introspector.getBeanInfoSearchPath()
获得将用来查找 BeanInfo 类的包名称的列表。

String

FeatureDescriptor.getDisplayName()
获得此特性的本地化显示名称。

static String[]

PropertyEditorManager.getEditorSearchPath()
获得用来搜索属性编辑器的包名称。

String

EventHandler.getEventPropertyName()
返回应该在应用于目标的动作中使用的事件属性。

String

PropertyEditor.getJavaInitializationString()
返回一部分 Java 代码，可以使用这部分代码来设置某个属性，以匹配编辑器当前状态。

String

PropertyEditorSupport.getJavaInitializationString()
生成 Java 代码来设置属性值时使用此方法。

String

EventHandler.getListenerMethodName()
返回将触发动作的属性名称。

String

Statement.getMethodName()
返回方法名称。

String

FeatureDescriptor.getName()
获得此特性的编程名称。

String

VetoableChangeListenerProxy.getPropertyName()
返回与侦听器有关联的指定属性的名称。

String

PropertyChangeListenerProxy.getPropertyName()
返回与侦听器相关联的指定属性的名称。

String

PropertyChangeEvent.getPropertyName()
获取已更改属性的编程名称。

String

FeatureDescriptor.getShortDescription()
获得此特性的简短描述。

String[]

PropertyEditor.getTags()
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记数组。

String[]

PropertyEditorSupport.getTags()
如果属性值必须是一组已知的加标记值之一，则此方法应该返回一个标记值数组。

String

Expression.toString()
使用 Java 风格的语法打印此表达式的值。

String

Statement.toString()
使用 Java 风格的语法打印此语句的值。

返回变量类型为 String 的类型的 java.beans 中的方法

Enumeration<String>

FeatureDescriptor.attributeNames()
获得与语言环境无关的此特性名称的枚举。

参数类型为 String 的 java.beans 中的方法

void

PropertyChangeSupport.addPropertyChangeListener(String propertyName, PropertyChangeListener listener)
为指定的属性向侦听器列表中添加一个 PropertyChangeListener。

void

VetoableChangeSupport.addVetoableChangeListener(String propertyName, VetoableChangeListener listener)
为特定属性添加一个 VetoableChangeListener。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

static String

Introspector.decapitalize(String name)
获得一个字符串并将它转换成普通 Java 变量名称大写形式的实用工具方法。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, boolean oldValue, boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定索引属性更新。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, int oldValue, int newValue)
以 int 值形式报告所有已注册侦听器的绑定索引属性更新。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
以 boolean 值形式报告所有已注册侦听器的绑定属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, int oldValue, int newValue)
以 int 值形式报告所有已注册侦听器的绑定属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, boolean oldValue, boolean newValue)
向所有已注册的侦听器报告一个 boolean vetoable 属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, int oldValue, int newValue)
向所有已注册的侦听器报告一个 int vetoable 属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

PropertyChangeListener[]

PropertyChangeSupport.getPropertyChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器的列表。

Object

FeatureDescriptor.getValue(String attributeName)
利用此特性检索指定属性。

VetoableChangeListener[]

VetoableChangeSupport.getVetoableChangeListeners(String propertyName)
返回与指定属性相关联的所有侦听器组成的数组。

boolean

VetoableChangeSupport.hasListeners(String propertyName)
检查是否存在特定属性的侦听器，包括那些已在所有属性上注册的侦听器。

boolean

PropertyChangeSupport.hasListeners(String propertyName)
检查是否存在特定属性的任何侦听器，包括那些已在所有属性上注册的侦听器。

static Object

Beans.instantiate(ClassLoader cls, String beanName)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
实例化 bean。

Image

SimpleBeanInfo.loadImage(String resourceName)
这是帮助加载图标图像的实用工具方法。

void

PropertyChangeSupport.removePropertyChangeListener(String propertyName, PropertyChangeListener listener)
为特定属性移除一个 PropertyChangeListener。

void

VetoableChangeSupport.removeVetoableChangeListener(String propertyName, VetoableChangeListener listener)
为特定属性移除一个 VetoableChangeListener。

void

PropertyEditor.setAsText(String text)
通过解析给定 String 设置属性值。

void

PropertyEditorSupport.setAsText(String text)
通过解析给定字符串设置属性值。

static void

Introspector.setBeanInfoSearchPath(String[] path)
更改将用来查找 BeanInfo 类的包名称的列表。

void

FeatureDescriptor.setDisplayName(String displayName)
设置此特性的本地化显示名称。

static void

PropertyEditorManager.setEditorSearchPath(String[] path)
更改将用来查找属性编辑器的包名称的列表。

void

FeatureDescriptor.setName(String name)
设置此特性的编程名称。

void

FeatureDescriptor.setShortDescription(String text)
可以将简短描述性字符串与某一特性相关联。

void

FeatureDescriptor.setValue(String attributeName, Object value)
将某一指定属性与此特性相关联。

参数类型为 String 的 java.beans 中的构造方法

DefaultPersistenceDelegate(String[] constructorPropertyNames)
为其构造方法的参数是属性名称值（由 constructorPropertyNames 指定）的类创建默认持久委托。

EventHandler(Object target, String action, String eventPropertyName, String listenerMethodName)
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String listenerMethodName)
假定按照最简单的标准设计模式创建 EventSetDescriptor，其中指定事件 "fred" 是 (1) 作为接口 FredListener 的单个方法上的调用传递的；(2) 它有一个 FredEvent 类型的参数；(3) 其中 FredListener 可以通过调用源组件的 addFredListener 方法注册，并通过调用 removeFredListener 方法移除。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName)
使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(Class<?> sourceClass, String eventSetName, Class<?> listenerType, String[] listenerMethodNames, String addListenerMethodName, String removeListenerMethodName, String getListenerMethodName)
此构造方法使用字符串名称从头开始创建 EventSetDescriptor。

EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

EventSetDescriptor(String eventSetName, Class<?> listenerType, Method[] listenerMethods, Method addListenerMethod, Method removeListenerMethod, Method getListenerMethod)
此构造方法使用 java.lang.reflect.Method 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

EventSetDescriptor(String eventSetName, Class<?> listenerType, MethodDescriptor[] listenerMethodDescriptors, Method addListenerMethod, Method removeListenerMethod)
使用 java.lang.reflect.MethodDescriptor 和 java.lang.Class 对象从头开始创建 EventSetDescriptor。

Expression(Object value, Object target, String methodName, Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。

Expression(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

IndexedPropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue, int index)
构造一个新的 IndexedPropertyChangeEvent 对象。

IndexedPropertyDescriptor(String propertyName, Class<?> beanClass)
此构造方法通过 getFoo 和 setFoo 存取方法为符合标准 Java 约定的属性构造 IndexedPropertyDescriptor，将其用于索引访问和数组访问。

IndexedPropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName, String indexedReadMethodName, String indexedWriteMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称，它们都是带索引的或不带索引的。

IndexedPropertyDescriptor(String propertyName, Method readMethod, Method writeMethod, Method indexedReadMethod, Method indexedWriteMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

IntrospectionException(String mess)
构造带详细消息的 IntrospectionException。

PropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue)
构造一个新的 PropertyChangeEvent。

PropertyChangeListenerProxy(String propertyName, PropertyChangeListener listener)
将 PropertyChangeListener 绑定到特定属性的构造方法。

PropertyDescriptor(String propertyName, Class<?> beanClass)
通过调用 getFoo 和 setFoo 存取方法，为符合标准 Java 约定的属性构造一个 PropertyDescriptor。

PropertyDescriptor(String propertyName, Class<?> beanClass, String readMethodName, String writeMethodName)
此构造方法带有一个简单属性的名称和用于读写属性的方法名称。

PropertyDescriptor(String propertyName, Method readMethod, Method writeMethod)
此构造方法带有某一简单属性的名称，以及用来读取和写入属性的 Method 对象。

PropertyVetoException(String mess, PropertyChangeEvent evt)
构造带详细消息的 PropertyVetoException。

Statement(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

VetoableChangeListenerProxy(String propertyName, VetoableChangeListener listener)

java.beans.beancontext 中 String 的使用

参数类型为 String 的 java.beans.beancontext 中的方法

void

BeanContextChild.addPropertyChangeListener(String name, PropertyChangeListener pcl)
将一个 PropertyChangeListener 添加到此 BeanContextChild 中，以便无论指定属性何时发生更改都可以接收一个 PropertyChangeEvent。

void

BeanContextChildSupport.addPropertyChangeListener(String name, PropertyChangeListener pcl)
为特定属性添加一个 PropertyChangeListener。

void

BeanContextChild.addVetoableChangeListener(String name, VetoableChangeListener vcl)
将一个 VetoableChangeListener 添加到此 BeanContextChild，以便无论指定属性何时发生更改都可以接收事件。

void

BeanContextChildSupport.addVetoableChangeListener(String name, VetoableChangeListener vcl)
为特定属性添加一个 VetoableChangeListener。

void

BeanContextChildSupport.firePropertyChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定 (bound) 属性更新。

void

BeanContextChildSupport.fireVetoableChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

URL

BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

URL

BeanContextSupport.getResource(String name, BeanContextChild bcc)

InputStream

BeanContext.getResourceAsStream(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResourceAsStream() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。

InputStream

BeanContextSupport.getResourceAsStream(String name, BeanContextChild bcc)

Object

BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。

Object

BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。

void

BeanContextChild.removePropertyChangeListener(String name, PropertyChangeListener pcl)
从此 BeanContextChild 中移除一个 PropertyChangeListener，以便指定属性发生更改时不再接收 PropertyChangeEvent。

void

BeanContextChildSupport.removePropertyChangeListener(String name, PropertyChangeListener pcl)
为特定属性移除一个 PropertyChangeListener。

void

BeanContextChild.removeVetoableChangeListener(String name, VetoableChangeListener vcl)
从此 BeanContextChild 中移除一个 VetoableChangeListener，以便指定属性发生更改时不再接收事件。

void

BeanContextChildSupport.removeVetoableChangeListener(String name, VetoableChangeListener vcl)
移除一个 VetoableChangeListener。

java.io 中 String 的使用

声明为 String 的 java.io 中的字段

protected  String

StringBufferInputStream.buffer
已过时。 从中读取字节的字符串。

String

InvalidClassException.classname
无效类的名称。

static String

File.pathSeparator
与系统有关的路径分隔符，为了方便，它被表示为一个字符串。

static String

File.separator
与系统有关的默认名称分隔符，为了方便，它被表示为一个字符串。

String

StreamTokenizer.sval
如果当前标记是一个文字标记，则此字段包含一个给出该文字标记的字符的字符串。

返回 String 的 java.io 中的方法

String

File.getAbsolutePath()
返回此抽象路径名的绝对路径名字符串。

String

FilePermission.getActions()
返回操作的“规范化字符串表示形式”。

String

File.getCanonicalPath()
返回此抽象路径名的规范路径名字符串。

String

InputStreamReader.getEncoding()
返回此流使用的字符编码的名称。

String

OutputStreamWriter.getEncoding()
返回此流使用的字符编码的名称。

String

WriteAbortedException.getMessage()
生成此消息并包括嵌入异常的消息（如果有）。

String

InvalidClassException.getMessage()
生成消息并包括类名称（如果存在）。

String

ObjectStreamClass.getName()
返回由此描述符描述的类的名称。

String

File.getName()
返回由此抽象路径名表示的文件或目录的名称。

String

ObjectStreamField.getName()
获取此字段的名称。

String

File.getParent()
返回此抽象路径名父目录的路径名字符串；如果此路径名没有指定父目录，则返回 null。

String

File.getPath()
将此抽象路径名转换为一个路径名字符串。

String

ObjectStreamField.getTypeString()
返回 JVM 类型签名。

String[]

File.list()
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中的文件和目录。

String[]

File.list(FilenameFilter filter)
返回一个字符串数组，这些字符串指定此抽象路径名表示的目录中满足指定过滤器的文件和目录。

String

Console.readLine()
从控制台读取单行文本。

String

LineNumberReader.readLine()
读取文本行。

String

RandomAccessFile.readLine()
从此文件读取文本的下一行。

String

ObjectInputStream.readLine()
已过时。 此方法不能正确地将字节转换为字符。请参见 DataInputStream 以获取详细信息和替代方法。

String

DataInputStream.readLine()
已过时。 该方法无法将字节正确转换为字符。从 JDK 1.1 开始，读取文本行的首选方法是使用 BufferedReader.readLine() 方法。使用 DataInputStream 类读取文本行的程序可以改为使用 BufferedReader 类，只要将以下形式的代码：
     DataInputStream d = new DataInputStream(in);
替换为：
     BufferedReader d
          = new BufferedReader(new InputStreamReader(in));
String

DataInput.readLine()
从输入流中读取下一文本行。

String

BufferedReader.readLine()
读取一个文本行。

String

Console.readLine(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取单行文本。

String

RandomAccessFile.readUTF()
从此文件读取一个字符串。

String

ObjectInputStream.readUTF()
读取 UTF-8 修改版格式的 String。

String

DataInputStream.readUTF()
参见 DataInput 的 readUTF 方法的常规协定。

String

DataInput.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。

static String

DataInputStream.readUTF(DataInput in)
从流 in 中读取用 UTF-8 修改版格式编码的 Unicode 字符格式的字符串；然后以 String 形式返回此字符串。

String

CharArrayWriter.toString()
将输入数据转换为字符串。

String

StreamTokenizer.toString()
返回当前流标记和在其上发生的行号的字符串表示形式。

String

StringWriter.toString()
以字符串的形式返回该缓冲区的当前值。

String

ByteArrayOutputStream.toString()
使用平台默认的字符集，通过解码字节将缓冲区内容转换为字符串。

String

ObjectStreamClass.toString()
返回描述此 ObjectStreamClass 的字符串。

String

File.toString()
返回此抽象路径名的路径名字符串。

String

ObjectStreamField.toString()
返回描述此字段的字符串。

String

ByteArrayOutputStream.toString(int hibyte)
已过时。 此方法无法将字节正确转换为字符。从 JDK 1.1 开始，完成该转换的首选方法是通过 toString(String enc) 方法（使用一个编码名称参数），或 toString() 方法（使用平台的默认字符编码）。

String

ByteArrayOutputStream.toString(String charsetName)
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。

参数类型为 String 的 java.io 中的方法

boolean

FilenameFilter.accept(File dir, String name)
测试指定文件是否应该包含在某一文件列表中。

static File

File.createTempFile(String prefix, String suffix)
在默认临时文件目录中创建一个空文件，使用给定前缀和后缀生成其名称。

static File

File.createTempFile(String prefix, String suffix, File directory)
在指定目录中创建一个新的空文件，使用给定的前缀和后缀字符串生成其名称。

abstract  boolean

ObjectInputStream.GetField.defaulted(String name)
如果指定的字段是默认字段并且在此流中不存在任何值，则返回 true。

PrintWriter

PrintWriter.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

Console

Console.format(String fmt, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。

PrintWriter

PrintWriter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

abstract  boolean

ObjectInputStream.GetField.get(String name, boolean val)
从持久字段获取指定的 boolean 字段值。

abstract  byte

ObjectInputStream.GetField.get(String name, byte val)
从持久字段获取指定字节字段的值。

abstract  char

ObjectInputStream.GetField.get(String name, char val)
从持久字段获取指定 char 字段的值。

abstract  double

ObjectInputStream.GetField.get(String name, double val)
从持久字段获取指定 double 字段的值。

abstract  float

ObjectInputStream.GetField.get(String name, float val)
从持久字段获取指定 float 字段的值。

abstract  int

ObjectInputStream.GetField.get(String name, int val)
从持久字段获取指定的 int 字段值。

abstract  long

ObjectInputStream.GetField.get(String name, long val)
从持久字段获取指定 long 字段的值。

abstract  Object

ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。

abstract  short

ObjectInputStream.GetField.get(String name, short val)
从持久字段获取指定的 short 字段值。

ObjectStreamField

ObjectStreamClass.getField(String name)
按名称获取此类的字段。

void

PrintWriter.print(String s)
打印字符串。

void

PrintStream.print(String s)
打印字符串。

PrintWriter

PrintWriter.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

Console

Console.printf(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。

PrintWriter

PrintWriter.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

void

PrintWriter.println(String x)
打印 String，然后终止该行。

void

PrintStream.println(String x)
打印 String，然后终止该行。

abstract  void

ObjectOutputStream.PutField.put(String name, boolean val)
将指定的 boolean 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, byte val)
将指定的 byte 字段值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, char val)
将指定的 char 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, double val)
将指定的 double 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, float val)
将指定的 float 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, int val)
将指定的 int 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, long val)
将指定的 long 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, Object val)
将指定的 Object 字段的值置于持久字段中。

abstract  void

ObjectOutputStream.PutField.put(String name, short val)
将指定的 short 字段的值置于持久字段中。

String

Console.readLine(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取单行文本。

char[]

Console.readPassword(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取密码，禁用回显。

protected  Class<?>

ObjectInputStream.resolveProxyClass(String[] interfaces)
返回一个代理类，该类实现在代理类描述符中命名的接口；子类可以实现此方法，以便从流及动态代理类的描述符中读取自定义数据，允许它们使用接口和代理类的替换加载机制。

String

ByteArrayOutputStream.toString(String charsetName)
使用指定的 charsetName，通过解码字节将缓冲区内容转换为字符串。

void

StringWriter.write(String str)
写入一个字符串。

void

PrintWriter.write(String s)
写入字符串。

void

Writer.write(String str)
写入字符串。

void

CharArrayWriter.write(String str, int off, int len)
将字符串的某一部分写入缓冲区。

void

FilterWriter.write(String str, int off, int len)
写入一部分字符串。

void

StringWriter.write(String str, int off, int len)
写入字符串的某一部分。

void

PrintWriter.write(String s, int off, int len)
写入字符串的某一部分。

void

BufferedWriter.write(String s, int off, int len)
写入字符串的某一部分。

void

OutputStreamWriter.write(String str, int off, int len)
写入字符串的某一部分。

void

Writer.write(String str, int off, int len)
写入字符串的某一部分。

void

DataOutputStream.writeBytes(String s)
将字符串按字节顺序写出到基础输出流中。

void

RandomAccessFile.writeBytes(String s)
按字节序列将该字符串写入该文件。

void

ObjectOutputStream.writeBytes(String str)
以字节序列形式写入一个 String。

void

DataOutput.writeBytes(String s)
将一个字符串写入输出流。

void

DataOutputStream.writeChars(String s)
将字符串按字符顺序写入基础输出流。

void

RandomAccessFile.writeChars(String s)
按字符序列将一个字符串写入该文件。

void

ObjectOutputStream.writeChars(String str)
以 char 序列形式写入一个 String。

void

DataOutput.writeChars(String s)
将字符串 s 中的所有字符按顺序写入输出流，每个字符用两个字节表示。

void

DataOutputStream.writeUTF(String str)
以与机器无关方式使用 UTF-8 修改版编码将一个字符串写入基础输出流。

void

RandomAccessFile.writeUTF(String str)
使用 modified UTF-8 编码以与机器无关的方式将一个字符串写入该文件。

void

ObjectOutputStream.writeUTF(String str)
以 UTF-8 修改版格式写入此 String 的基本数据。

void

DataOutput.writeUTF(String s)
将表示长度信息的两个字节写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。

参数类型为 String 的 java.io 中的构造方法

CharConversionException(String s)
此异常提供详细消息。

EOFException(String s)
构造带有指定详细消息的 EOFException。

File(File parent, String child)
根据 parent 抽象路径名和 child 路径名字符串创建一个新 File 实例。

File(String pathname)
通过将给定路径名字符串转换为抽象路径名来创建一个新 File 实例。

File(String parent, String child)
根据 parent 路径名字符串和 child 路径名字符串创建一个新 File 实例。

FileInputStream(String name)
通过打开一个到实际文件的连接来创建一个 FileInputStream，该文件通过文件系统中的路径名 name 指定。

FileNotFoundException(String s)
构造带有指定详细消息的 FileNotFoundException。

FileOutputStream(String name)
创建一个向具有指定名称的文件中写入数据的输出文件流。

FileOutputStream(String name, boolean append)
创建一个向具有指定 name 的文件中写入数据的输出文件流。

FilePermission(String path, String actions)
创建具有指定操作的新 FilePermission 对象，path 是文件或目录的路径名，actions 包含对文件或目录授予的所需操作的列表，该列表由逗号分隔。

FileReader(String fileName)
在给定从中读取数据的文件名的情况下创建一个新 FileReader。

FileWriter(String fileName)
根据给定的文件名构造一个 FileWriter 对象。

FileWriter(String fileName, boolean append)
根据给定的文件名以及指示是否附加写入数据的 boolean 值来构造 FileWriter 对象。

InputStreamReader(InputStream in, String charsetName)
创建使用指定字符集的 InputStreamReader。

InterruptedIOException(String s)
构造带指定详细消息的 InterruptedIOException。

InvalidClassException(String reason)
报告指定了原因的 InvalidClassException。

InvalidClassException(String cname, String reason)
构造一个 InvalidClassException 对象。

InvalidObjectException(String reason)
构造一个 InvalidObjectException。

IOException(String message)
构造带指定详细消息的 IOException。

IOException(String message, Throwable cause)
构造带有指定详细消息和 cause 的 IOException。

NotActiveException(String reason)
创建带给定原因的新 NotActiveException 的构造方法。

NotSerializableException(String classname)
构造带消息字符串的 NotSerializableException 对象。

ObjectStreamException(String classname)
创建具有指定参数的 ObjectStreamException。

ObjectStreamField(String name, Class<?> type)
创建具有指定类型的 Serializable 字段。

ObjectStreamField(String name, Class<?> type, boolean unshared)
创建一个 ObjectStreamField，表示给定名称和类型的可序列化字段。

OutputStreamWriter(OutputStream out, String charsetName)
创建使用指定字符集的 OutputStreamWriter。

PrintStream(File file, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。

PrintStream(OutputStream out, boolean autoFlush, String encoding)
创建新的打印流。

PrintStream(String fileName)
创建具有指定文件名称且不带自动行刷新的新打印流。

PrintStream(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新打印流。

PrintWriter(File file, String csn)
创建具有指定文件和字符集且不带自动刷行新的新 PrintWriter。

PrintWriter(String fileName)
创建具有指定文件名称且不带自动行刷新的新 PrintWriter。

PrintWriter(String fileName, String csn)
创建具有指定文件名称和字符集且不带自动行刷新的新 PrintWriter。

RandomAccessFile(File file, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件由 File 参数指定。

RandomAccessFile(String name, String mode)
创建从中读取和向其中写入（可选）的随机访问文件流，该文件具有指定名称。

SerializablePermission(String name)
创建具有指定名称的新 SerializablePermission。

SerializablePermission(String name, String actions)
创建具有指定名称的新 SerializablePermission 对象。

StreamCorruptedException(String reason)
创建一个 StreamCorruptedException 并列出抛出异常的一个原因。

StringBufferInputStream(String s)
已过时。 创建一个字符串输入流，以从指定字符串读取数据。

StringReader(String s)
创建一个新字符串 reader。

SyncFailedException(String desc)
构造一个带详细消息的 SyncFailedException。

UnsupportedEncodingException(String s)
构造带详细消息的 UnsupportedEncodingException。

UTFDataFormatException(String s)
构造带有指定详细消息的 UTFDataFormatException。

WriteAbortedException(String s, Exception ex)
使用描述该异常的字符串和导致中止的异常构造一个 WriteAbortedException。

java.lang 中 String 的使用

类型参数类型为 String 的 java.lang 中的字段

static Comparator<String>

String.CASE_INSENSITIVE_ORDER
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。

返回 String 的 java.lang 中的方法

static String

System.clearProperty(String key)
移除指定键指示的系统属性。

String

String.concat(String str)
将指定字符串连接到此字符串的结尾。

String

EnumConstantNotPresentException.constantName()
返回缺少的枚举常量的名称。

static String

String.copyValueOf(char[] data)
返回指定数组中表示该字符序列的 String。

static String

String.copyValueOf(char[] data, int offset, int count)
返回指定数组中表示该字符序列的 String。

protected  String

ClassLoader.findLibrary(String libname)
返回本机库的绝对路径名。

static String

String.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。

static String

String.format(String format, Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。

String

Class.getCanonicalName()
返回 Java Language Specification 中所定义的底层类的规范化名称。

String

StackTraceElement.getClassName()
返回类的完全限定名，该类包含由该堆栈跟踪元素所表示的执行点。

static String

System.getenv(String name)
获取指定的环境变量值。

String

StackTraceElement.getFileName()
返回源文件名，该文件包含由该堆栈跟踪元素所表示的执行点。

String

Package.getImplementationTitle()
返回此包的标题。

String

Package.getImplementationVendor()
返回提供该实现的组织、供应商或公司的名称。

String

Package.getImplementationVersion()
返回该实现的版本。

String

Throwable.getLocalizedMessage()
创建此 throwable 的本地化描述。

String

Throwable.getMessage()
返回此 throwable 的详细消息字符串。

String

StackTraceElement.getMethodName()
返回方法名，此方法包含由该堆栈跟踪元素所表示的执行点。

String

Package.getName()
返回此包的名称。

String

ThreadGroup.getName()
返回此线程组的名称。

String

Thread.getName()
返回该线程的名称。

String

Class.getName()
以 String 的形式返回此 Class 对象所表示的实体（类、接口、数组类、基本类型或 void）名称。

static String

System.getProperty(String key)
获取指定键指示的系统属性。

static String

System.getProperty(String key, String def)
获取用指定键描述的系统属性。

String

Class.getSimpleName()
返回源代码中给出的底层类的简称。

String

Package.getSpecificationTitle()
返回此包实现的规范标题。

String

Package.getSpecificationVendor()
返回拥有并维护实现此包的类规范的组织、供应商或公司的名称。

String

Package.getSpecificationVersion()
返回此包实现的规范的版本号。

String

String.intern()
返回字符串对象的规范化表示形式。

static String

System.mapLibraryName(String libname)
将一个库名称映射到特定于平台的、表示本机库的字符串中。

String

Enum.name()
返回此枚举常量的名称，在其枚举声明中对其进行声明。

String

String.replace(char oldChar, char newChar)
返回一个新的字符串，它是通过用 newChar 替换此字符串中出现的所有 oldChar 得到的。

String

String.replace(CharSequence target, CharSequence replacement)
使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。

String

String.replaceAll(String regex, String replacement)
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。

String

String.replaceFirst(String regex, String replacement)
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。

static String

System.setProperty(String key, String value)
设置指定键指示的系统属性。

String[]

String.split(String regex)
根据给定正则表达式的匹配拆分此字符串。

String[]

String.split(String regex, int limit)
根据匹配给定的正则表达式来拆分此字符串。

String

StringBuffer.substring(int start)

String

String.substring(int beginIndex)
返回一个新的字符串，它是此字符串的一个子字符串。

String

StringBuffer.substring(int start, int end)

String

String.substring(int beginIndex, int endIndex)
返回一个新字符串，它是此字符串的一个子字符串。

static String

Integer.toBinaryString(int i)
以二进制（基数 2）无符号整数形式返回一个整数参数的字符串表示形式。

static String

Long.toBinaryString(long i)
以二进制无符号整数形式返回 long 参数的字符串表示形式。

static String

Double.toHexString(double d)
返回 double 参数的十六进制字符串表示形式。

static String

Float.toHexString(float f)
返回 float 参数的十六进制字符串表示形式。

static String

Integer.toHexString(int i)
以十六进制（基数 16）无符号整数形式返回一个整数参数的字符串表示形式。

static String

Long.toHexString(long i)
以十六进制无符号整数形式返回 long 参数的字符串表示形式。

String

String.toLowerCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为小写。

String

String.toLowerCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。

static String

Integer.toOctalString(int i)
以八进制（基数 8）无符号整数形式返回一个整数参数的字符串表示形式。

static String

Long.toOctalString(long i)
以八进制无符号整数形式返回 long 参数的字符串表示形式。

String

Package.toString()
返回此 Package 的字符串表示形式。

String

Enum.toString()
返回枚举常量的名称，它包含在声明中。

String

StringBuilder.toString()

String

Long.toString()
返回表示 Long 值的 String 对象。

String

Integer.toString()
返回一个表示该 Integer 值的 String 对象。

String

Short.toString()
返回表示此 Short 的值的 String 对象。

String

Byte.toString()
返回表示此 Byte 的值的 String 对象。

String

Double.toString()
返回此 Double 对象的字符串表示形式。

String

Float.toString()
返回此 Float 对象的字符串表示形式。

String

Character.toString()
返回表示此 Character 值的 String 对象。

String

Character.Subset.toString()
返回该子集的名称。

String

Boolean.toString()
返回表示该布尔值的 String 对象。

String

StackTraceElement.toString()
返回表示该堆栈跟踪元素的字符串。

String

StringBuffer.toString()

String

ThreadGroup.toString()
返回此线程组的字符串表示形式。

String

Thread.toString()
返回该线程的字符串表示形式，包括线程名称、优先级和线程组。

String

Throwable.toString()
返回此 throwable 的简短描述。

String

Class.toString()
将对象转换为字符串。

String

String.toString()
返回此对象本身（它已经是一个字符串！）。

String

CharSequence.toString()
返回一个包含此序列中字符的字符串，该字符串与此序列的顺序相同。

String

Object.toString()
返回该对象的字符串表示。

static String

Boolean.toString(boolean b)
返回一个表示指定布尔值的 String 对象。

static String

Byte.toString(byte b)
返回表示指定 byte 的一个新 String 对象。

static String

Character.toString(char c)
返回一个表示指定 char 值的 String 对象。

static String

Double.toString(double d)
返回 double 参数的字符串表示形式。

static String

Float.toString(float f)
返回 float 参数的字符串表示形式。

static String

Integer.toString(int i)
返回一个表示指定整数的 String 对象。

static String

Integer.toString(int i, int radix)
返回用第二个参数指定基数表示的第一个参数的字符串表示形式。

static String

Long.toString(long i)
返回表示指定 long 的 String 对象。

static String

Long.toString(long i, int radix)
返回在使用第二个参数指定的基数时第一个参数的字符串表示形式。

static String

Short.toString(short s)
返回表示指定 short 的一个新 String 对象。

String

String.toUpperCase()
使用默认语言环境的规则将此 String 中的所有字符都转换为大写。

String

String.toUpperCase(Locale locale)
使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。

String

String.trim()
返回字符串的副本，忽略前导空白和尾部空白。

String

TypeNotPresentException.typeName()
返回不可用类型的完全限定名。

static String

String.valueOf(boolean b)
返回 boolean 参数的字符串表示形式。

static String

String.valueOf(char c)
返回 char 参数的字符串表示形式。

static String

String.valueOf(char[] data)
返回 char 数组参数的字符串表示形式。

static String

String.valueOf(char[] data, int offset, int count)
返回 char 数组参数的特定子数组的字符串表示形式。

static String

String.valueOf(double d)
返回 double 参数的字符串表示形式。

static String

String.valueOf(float f)
返回 float 参数的字符串表示形式。

static String

String.valueOf(int i)
返回 int 参数的字符串表示形式。

static String

String.valueOf(long l)
返回 long 参数的字符串表示形式。

static String

String.valueOf(Object obj)
返回 Object 参数的字符串表示形式。

返回变量类型为 String 的类型的 java.lang 中的方法

List<String>

ProcessBuilder.command()
返回此进程生成器的操作系统程序和参数。

Map<String,String>

ProcessBuilder.environment()
返回此进程生成器环境的字符串映射视图。

Map<String,String>

ProcessBuilder.environment()
返回此进程生成器环境的字符串映射视图。

static Map<String,String>

System.getenv()
返回一个不能修改的当前系统环境的字符串映射视图。

static Map<String,String>

System.getenv()
返回一个不能修改的当前系统环境的字符串映射视图。

参数类型为 String 的 java.lang 中的方法

StringBuilder

StringBuilder.append(String str)

StringBuffer

StringBuffer.append(String str)

void

SecurityManager.checkAccept(String host, int port)
如果不允许调用线程从指定的主机和端口号接受套接字连接，则抛出 SecurityException。

void

SecurityManager.checkConnect(String host, int port)
如果不允许调用线程打开到指定主机和端口号的套接字连接，则抛出 SecurityException。

void

SecurityManager.checkConnect(String host, int port, Object context)
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。

void

SecurityManager.checkDelete(String file)
如果不允许调用线程删除指定的文件，则抛出 SecurityException。

void

SecurityManager.checkExec(String cmd)
如果不允许调用线程创建一个子进程，则抛出 SecurityException。

void

SecurityManager.checkLink(String lib)
如果不允许调用线程动态链接由字符串参数文件指定的库代码，则抛出 SecurityException。

void

SecurityManager.checkPackageAccess(String pkg)
如果不允许调用线程访问由参数指定的包，则抛出 SecurityException。

void

SecurityManager.checkPackageDefinition(String pkg)
如果不允许调用线程在参数指定的包中定义类，则抛出 SecurityException。

void

SecurityManager.checkPropertyAccess(String key)
如果不允许调用线程访问具有指定的 key 名的系统属性，则抛出 SecurityException。

void

SecurityManager.checkRead(String file)
如果不允许调用线程读取由字符串参数指定的文件，则抛出 SecurityException。

void

SecurityManager.checkRead(String file, Object context)
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。

void

SecurityManager.checkSecurityAccess(String target)
确定是应该允许还是拒绝具有指定权限目标名的权限。

void

SecurityManager.checkWrite(String file)
如果不允许调用线程写由字符串参数指定的文件，则抛出 SecurityException。

protected  int

SecurityManager.classDepth(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

static String

System.clearProperty(String key)
移除指定键指示的系统属性。

ProcessBuilder

ProcessBuilder.command(String... command)
设置此进程生成器的操作系统程序和参数。

int

String.compareTo(String anotherString)
按字典顺序比较两个字符串。

int

String.compareToIgnoreCase(String str)
按字典顺序比较两个字符串，不考虑大小写。

static boolean

Compiler.compileClasses(String string)
编译那些名称与指定字符串相匹配的所有类。

String

String.concat(String str)
将指定字符串连接到此字符串的结尾。

static Long

Long.decode(String nm)
将 String 解码成 Long。

static Integer

Integer.decode(String nm)
将 String 解码为 Integer。

static Short

Short.decode(String nm)
将 String 解码为 Short。

static Byte

Byte.decode(String nm)
将 String 解码为 Byte。

protected  Class<?>

ClassLoader.defineClass(String name, byte[] b, int off, int len)
将一个 byte 数组转换为 Class 类的实例。

protected  Class<?>

ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。

protected  Class<?>

ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

protected  Package

ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase)
根据 name 在此 ClassLoader 中定义包。

boolean

String.endsWith(String suffix)
测试此字符串是否以指定的后缀结束。

boolean

String.equalsIgnoreCase(String anotherString)
将此 String 与另一个 String 比较，不考虑大小写。

Process

Runtime.exec(String command)
在单独的进程中执行指定的字符串命令。

Process

Runtime.exec(String[] cmdarray)
在单独的进程中执行指定命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp)
在指定环境的独立进程中执行指定命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp)
在指定环境的独立进程中执行指定命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp, File dir)
在指定环境和工作目录的独立进程中执行指定的命令和变量。

Process

Runtime.exec(String[] cmdarray, String[] envp, File dir)
在指定环境和工作目录的独立进程中执行指定的命令和变量。

Process

Runtime.exec(String command, String[] envp)
在指定环境的单独进程中执行指定的字符串命令。

Process

Runtime.exec(String command, String[] envp)
在指定环境的单独进程中执行指定的字符串命令。

Process

Runtime.exec(String command, String[] envp, File dir)
在有指定环境和工作目录的独立进程中执行指定的字符串命令。

Process

Runtime.exec(String command, String[] envp, File dir)
在有指定环境和工作目录的独立进程中执行指定的字符串命令。

protected  Class<?>

ClassLoader.findClass(String name)
使用指定的二进制名称查找类。

protected  String

ClassLoader.findLibrary(String libname)
返回本机库的绝对路径名。

protected  Class<?>

ClassLoader.findLoadedClass(String name)
如果 Java 虚拟机已将此加载器记录为具有给定二进制名称的某个类的启动加载器，则返回该二进制名称的类。

protected  URL

ClassLoader.findResource(String name)
查找具有给定名称的资源。

protected  Enumeration<URL>

ClassLoader.findResources(String name)
返回表示所有具有给定名称的资源的 URL 对象的枚举。

protected  Class<?>

ClassLoader.findSystemClass(String name)
查找具有指定的二进制名称的类，必要时加载它。

static String

String.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。

static String

String.format(String format, Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。

static Character.UnicodeBlock

Character.UnicodeBlock.forName(String blockName)
返回带有给定名称的 UnicodeBlock。

static Class<?>

Class.forName(String className)
返回与带有给定字符串名的类或接口相关联的 Class 对象。

static Class<?>

Class.forName(String name, boolean initialize, ClassLoader loader)
使用给定的类加载器，返回与带有给定字符串名的类或接口相关联的 Class 对象。

static boolean

Boolean.getBoolean(String name)
当且仅当以参数命名的系统属性存在，且等于 "true" 字符串时，才返回 true。

byte[]

String.getBytes(String charsetName)
使用指定的字符集将此 String 编码为 byte 序列，并将结果存储到一个新的 byte 数组中。

Field

Class.getDeclaredField(String name)
返回一个 Field 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明字段。

Method

Class.getDeclaredMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，该对象反映此 Class 对象所表示的类或接口的指定已声明方法。

static String

System.getenv(String name)
获取指定的环境变量值。

Field

Class.getField(String name)
返回一个 Field 对象，它反映此 Class 对象所表示的类或接口的指定公共成员字段。

static Integer

Integer.getInteger(String nm)
确定具有指定名称的系统属性的整数值。

static Integer

Integer.getInteger(String nm, int val)
确定具有指定名称的系统属性的整数值。

static Integer

Integer.getInteger(String nm, Integer val)
返回具有指定名称的系统属性的整数值。

static Long

Long.getLong(String nm)
确定具有指定名称的系统属性的 long 值。

static Long

Long.getLong(String nm, long val)
使用指定名称确定系统属性的 long 值。

static Long

Long.getLong(String nm, Long val)
使用指定名称返回系统属性的 long 值。

Method

Class.getMethod(String name, Class<?>... parameterTypes)
返回一个 Method 对象，它反映此 Class 对象所表示的类或接口的指定公共成员方法。

static Package

Package.getPackage(String name)
通过调用方的 ClassLoader 实例中的名称找到一个包。

protected  Package

ClassLoader.getPackage(String name)
返回由此类加载器或其任何祖先所定义的 Package。

static String

System.getProperty(String key)
获取指定键指示的系统属性。

static String

System.getProperty(String key, String def)
获取用指定键描述的系统属性。

URL

ClassLoader.getResource(String name)
查找具有给定名称的资源。

URL

Class.getResource(String name)
查找带有给定名称的资源。

InputStream

ClassLoader.getResourceAsStream(String name)
返回读取指定资源的输入流。

InputStream

Class.getResourceAsStream(String name)
查找具有给定名称的资源。

Enumeration<URL>

ClassLoader.getResources(String name)
查找所有给定名称的资源。

static URL

ClassLoader.getSystemResource(String name)
从用来加载类的搜索路径中查找具有指定名称的资源。

static InputStream

ClassLoader.getSystemResourceAsStream(String name)
从用来加载类的搜索路径打开具有指定名称的资源，以读取该资源。

static Enumeration<URL>

ClassLoader.getSystemResources(String name)
从用来加载类的搜索路径中查找所有具有指定名称的资源。

protected  boolean

SecurityManager.inClass(String name)
已过时。 建议不使用该类安全检查。建议使用 checkPermission 调用。

int

StringBuilder.indexOf(String str)

int

StringBuffer.indexOf(String str)

int

String.indexOf(String str)
返回指定子字符串在此字符串中第一次出现处的索引。

int

StringBuilder.indexOf(String str, int fromIndex)

int

StringBuffer.indexOf(String str, int fromIndex)

int

String.indexOf(String str, int fromIndex)
返回指定子字符串在此字符串中第一次出现处的索引，从指定的索引开始。

StringBuilder

StringBuilder.insert(int offset, String str)

StringBuffer

StringBuffer.insert(int offset, String str)

boolean

Package.isCompatibleWith(String desired)
比较此包的规范版本和所需版本。

int

StringBuilder.lastIndexOf(String str)

int

StringBuffer.lastIndexOf(String str)

int

String.lastIndexOf(String str)
返回指定子字符串在此字符串中最右边出现处的索引。

int

StringBuilder.lastIndexOf(String str, int fromIndex)

int

StringBuffer.lastIndexOf(String str, int fromIndex)

int

String.lastIndexOf(String str, int fromIndex)
返回指定子字符串在此字符串中最后一次出现处的索引，从指定的索引开始反向搜索。

void

Runtime.load(String filename)
加载作为动态库的指定文件名。

static void

System.load(String filename)
从作为动态库的本地文件系统中以指定的文件名加载代码文件。

Class<?>

ClassLoader.loadClass(String name)
使用指定的二进制名称来加载类。

protected  Class<?>

ClassLoader.loadClass(String name, boolean resolve)
使用指定的二进制名称来加载类。

void

Runtime.loadLibrary(String libname)
加载具有指定库名的动态库。

static void

System.loadLibrary(String libname)
加载由 libname 参数指定的系统库。

static String

System.mapLibraryName(String libname)
将一个库名称映射到特定于平台的、表示本机库的字符串中。

boolean

String.matches(String regex)
告知此字符串是否匹配给定的正则表达式。

static boolean

Boolean.parseBoolean(String s)
将字符串参数解析为 boolean 值。

static byte

Byte.parseByte(String s)
将 string 参数解析为有符号的十进制 byte。

static byte

Byte.parseByte(String s, int radix)
将 string 参数解析为一个有符号的 byte，其基数由第二个参数指定。

static double

Double.parseDouble(String s)
返回一个新的 double 值，该值被初始化为用指定 String 表示的值，这与 Double 类的 valueOf 方法一样。

static float

Float.parseFloat(String s)
返回一个新的 float 值，该值被初始化为用指定 String 表示的值，这与 Float 类的 valueOf 方法一样。

static int

Integer.parseInt(String s)
将字符串参数作为有符号的十进制整数进行解析。

static int

Integer.parseInt(String s, int radix)
使用第二个参数指定的基数，将字符串参数解析为有符号的整数。

static long

Long.parseLong(String s)
将 string 参数解析为有符号十进制 long。

static long

Long.parseLong(String s, int radix)
将 string 参数解析为有符号的 long，基数由第二个参数指定。

static short

Short.parseShort(String s)
将字符串参数解析为有符号的十进制 short。

static short

Short.parseShort(String s, int radix)
将字符串参数解析为由第二个参数指定的基数中的有符号的 short。

boolean

String.regionMatches(boolean ignoreCase, int toffset, String other, int ooffset, int len)
测试两个字符串区域是否相等。

boolean

String.regionMatches(int toffset, String other, int ooffset, int len)
测试两个字符串区域是否相等。

StringBuilder

StringBuilder.replace(int start, int end, String str)

StringBuffer

StringBuffer.replace(int start, int end, String str)

String

String.replaceAll(String regex, String replacement)
使用给定的 replacement 替换此字符串所有匹配给定的正则表达式的子字符串。

String

String.replaceFirst(String regex, String replacement)
使用给定的 replacement 替换此字符串匹配给定的正则表达式的第一个子字符串。

void

ClassLoader.setClassAssertionStatus(String className, boolean enabled)
设置在此类加载器及其包含的嵌套类中指定的最高层类所需的断言状态。

void

Thread.setName(String name)
改变线程名称，使之与参数 name 相同。

void

ClassLoader.setPackageAssertionStatus(String packageName, boolean enabled)
为指定包设置默认断言状态。

static String

System.setProperty(String key, String value)
设置指定键指示的系统属性。

String[]

String.split(String regex)
根据给定正则表达式的匹配拆分此字符串。

String[]

String.split(String regex, int limit)
根据匹配给定的正则表达式来拆分此字符串。

boolean

String.startsWith(String prefix)
测试此字符串是否以指定的前缀开始。

boolean

String.startsWith(String prefix, int toffset)
测试此字符串从指定索引开始的子字符串是否以指定前缀开始。

static

<T extends Enum<T>>
T

Enum.valueOf(Class<T> enumType, String name)
返回带指定名称的指定枚举类型的枚举常量。

static Long

Long.valueOf(String s)
返回保持指定 String 的值的 Long 对象。

static Integer

Integer.valueOf(String s)
返回保存指定的 String 的值的 Integer 对象。

static Short

Short.valueOf(String s)
返回一个保持指定 String 所给出的值的 Short 对象。

static Byte

Byte.valueOf(String s)
返回一个保持指定 String 所给出的值的 Byte 对象。

static Double

Double.valueOf(String s)
返回保存用参数字符串 s 表示的 double 值的 Double 对象。

static Float

Float.valueOf(String s)
返回保存用参数字符串 s 表示的 float 值的 Float 对象。

static Boolean

Boolean.valueOf(String s)
返回一个用指定的字符串表示值的 Boolean 值。

static Thread.State

Thread.State.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Long

Long.valueOf(String s, int radix)
当使用第二个参数给出的基数进行解析时，返回保持从指定 String 中提取的值的 Long 对象。

static Integer

Integer.valueOf(String s, int radix)
返回一个 Integer 对象，该对象中保存了用第二个参数提供的基数进行解析时从指定的 String 中提取的值。

static Short

Short.valueOf(String s, int radix)
返回一个 Short 对象，该对象保持从指定的 String 中提取的值，该值是在使用第二个参数给出的基数对指定字符串进行解析时提取的。

static Byte

Byte.valueOf(String s, int radix)
返回一个 Byte 对象，该对象保持从指定的 String 中提取的值，该值是在用第二个参数所给定的基数对指定字符串进行解析时提取的。

类型变量类型为 String 的 java.lang 中的方法参数

ProcessBuilder

ProcessBuilder.command(List<String> command)
设置此进程生成器的操作系统程序和参数。

参数类型为 String 的 java.lang 中的构造方法

AbstractMethodError(String s)
构造带指定详细消息的 AbstractMethodError。

ArithmeticException(String s)
构造具有指定详细消息的 ArithmeticException。

ArrayIndexOutOfBoundsException(String s)
构造具有指定详细消息的 ArrayIndexOutOfBoundsException 类。

ArrayStoreException(String s)
构造具有指定详细消息的 ArrayStoreException。

Boolean(String s)
如果 String 参数不为 null 且在忽略大小写时等于 "true"，则分配一个表示 true 值的 Boolean 对象。

Byte(String s)
构造一个新分配的 Byte 对象，以表示 String 参数所指示的 byte 值。

Character.Subset(String name)
构造一个新的 Subset 实例。

ClassCastException(String s)
构造带指定详细消息的 ClassCastException。

ClassCircularityError(String s)
构造带指定详细消息的 ClassCircularityError。

ClassFormatError(String s)
构造带指定详细消息的 ClassFormatError。

ClassNotFoundException(String s)
构造带指定详细消息的 ClassNotFoundException。

ClassNotFoundException(String s, Throwable ex)
构造一个 ClassNotFoundException，它带有指定详细消息和加载类时引发的可选异常。

CloneNotSupportedException(String s)
构造带指定详细消息的 CloneNotSupportedException。

Double(String s)
构造一个新分配的 Double 对象，表示用字符串表示的 double 类型的浮点值。

Enum(String name, int ordinal)
单独的构造方法。

EnumConstantNotPresentException(Class<? extends Enum> enumType, String constantName)
为指定常量构造一个 EnumConstantNotPresentException。

Error(String message)
构造带指定详细消息的新错误。

Error(String message, Throwable cause)
构造带指定详细消息和原因的新错误。

Exception(String message)
构造带指定详细消息的新异常。

Exception(String message, Throwable cause)
构造带指定详细消息和原因的新异常。

ExceptionInInitializerError(String s)
构造带指定详细消息的 ExceptionInInitializerError。

Float(String s)
构造一个新分配的 Float 对象，它表示用字符串表示的 float 类型的浮点值。

IllegalAccessError(String s)
构造带指定详细消息的 IllegalAccessError。

IllegalAccessException(String s)
构造带指定详细消息的 IllegalAccessException。

IllegalArgumentException(String s)
构造带指定详细消息的 IllegalArgumentException。

IllegalArgumentException(String message, Throwable cause)
根据指定的详细消息和原因构造一个新异常。

IllegalMonitorStateException(String s)
构造带指定详细消息的 IllegalMonitorStateException。

IllegalStateException(String s)
构造带指定详细消息的 IllegalStateException。

IllegalStateException(String message, Throwable cause)
构造一个新异常，它带有指定的详细消息和原因。

IllegalThreadStateException(String s)
构造带指定详细消息的 IllegalThreadStateException。

IncompatibleClassChangeError(String s)
构造带指定详细消息的 IncompatibleClassChangeError。

IndexOutOfBoundsException(String s)
构造带指定详细消息的 IndexOutOfBoundsException。

InstantiationError(String s)
构造带指定详细消息的 InstantiationError。

InstantiationException(String s)
构造带指定详细消息的 InstantiationException。

Integer(String s)
构造一个新分配的 Integer 对象，它表示 String 参数所指示的 int 值。

InternalError(String s)
构造带指定详细消息的 InternalError。

InterruptedException(String s)
构造带指定详细消息的 InterruptedException。

LinkageError(String s)
构造带指定详细消息的 LinkageError 类。

Long(String s)
构造新分配的 Long 对象，表示由 String 参数指示的 long 值。

NegativeArraySizeException(String s)
构造带指定详细消息的 NegativeArraySizeException。

NoClassDefFoundError(String s)
构造带指定详细消息的 NoClassDefFoundError。

NoSuchFieldError(String s)
构造带指定详细消息的 NoSuchFieldException。

NoSuchFieldException(String s)
带有详细消息的构造方法。

NoSuchMethodError(String s)
构造带指定详细消息的 NoSuchMethodError。

NoSuchMethodException(String s)
构造带指定详细消息的 NoSuchMethodException。

NullPointerException(String s)
构造带指定详细消息的 NullPointerException。

NumberFormatException(String s)
构造带指定详细消息的 NumberFormatException。

OutOfMemoryError(String s)
构造带指定详细消息的 OutOfMemoryError。

ProcessBuilder(String... command)
利用指定的操作系统程序和参数构造一个进程生成器。

RuntimeException(String message)
用指定的详细消息构造一个新的运行时异常。

RuntimeException(String message, Throwable cause)
用指定的详细消息和原因构造一个新的运行时异常。

RuntimePermission(String name)
创建具有指定名称的新 RuntimePermission。

RuntimePermission(String name, String actions)
创建具有指定名称的新 RuntimePermission 对象。

SecurityException(String s)
构造带指定详细消息的 SecurityException。

SecurityException(String message, Throwable cause)
创建带指定详细消息和原因的 SecurityException。

Short(String s)
构造一个新分配的 Short 对象，用来表示 String 参数所指示的 short 值。

StackOverflowError(String s)
构造带指定详细消息的 StackOverflowError。

StackTraceElement(String declaringClass, String methodName, String fileName, int lineNumber)
创建表示指定执行点的堆栈跟踪元素。

String(byte[] bytes, int offset, int length, String charsetName)
通过使用指定的字符集解码指定的 byte 子数组，构造一个新的 String。

String(byte[] bytes, String charsetName)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。

String(String original)
初始化一个新创建的 String 对象，使其表示一个与参数相同的字符序列；换句话说，新创建的字符串是该参数字符串的副本。

StringBuffer(String str)
构造一个字符串缓冲区，并将其内容初始化为指定的字符串内容。

StringBuilder(String str)
构造一个字符串生成器，并初始化为指定的字符串内容。

StringIndexOutOfBoundsException(String s)
构造带指定详细消息的 StringIndexOutOfBoundsException。

Thread(Runnable target, String name)
分配新的 Thread 对象。

Thread(String name)
分配新的 Thread 对象。

Thread(ThreadGroup group, Runnable target, String name)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，并作为 group 所引用的线程组的一员。

Thread(ThreadGroup group, Runnable target, String name, long stackSize)
分配新的 Thread 对象，以便将 target 作为其运行对象，将指定的 name 作为其名称，作为 group 所引用的线程组的一员，并具有指定的堆栈大小。

Thread(ThreadGroup group, String name)
分配新的 Thread 对象。

ThreadGroup(String name)
构造一个新线程组。

ThreadGroup(ThreadGroup parent, String name)
创建一个新线程组。

Throwable(String message)
构造带指定详细消息的新 throwable。

Throwable(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 throwable。

TypeNotPresentException(String typeName, Throwable cause)
为指定类型构造一个带指定原因的 TypeNotPresentException。

UnknownError(String s)
构造带指定详细消息的 UnknownError。

UnsatisfiedLinkError(String s)
构造带指定详细消息的 UnsatisfiedLinkError。

UnsupportedClassVersionError(String s)
构造带指定详细消息的 UnsupportedClassVersionError。

UnsupportedOperationException(String message)
构造带指定详细消息的 UnsupportedOperationException。

UnsupportedOperationException(String message, Throwable cause)
根据指定的详细消息和原因，构造一个新异常。

VerifyError(String s)
构造带指定详细消息的 VerifyError。

VirtualMachineError(String s)
构造带指定详细消息的 VirtualMachineError。

类型变量类型为 String 的 java.lang 中的构造方法参数

ProcessBuilder(List<String> command)
利用指定的操作系统程序和参数构造一个进程生成器。

java.lang.annotation 中 String 的使用

返回 String 的 java.lang.annotation 中的方法

String

IncompleteAnnotationException.elementName()
返回缺少元素的名称。

String

AnnotationTypeMismatchException.foundType()
返回在类型不正确的元素中找到的数据类型。

String

Annotation.toString()
返回此 annotation 的字符串表示形式。

参数类型为 String 的 java.lang.annotation 中的方法

static ElementType

ElementType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static RetentionPolicy

RetentionPolicy.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.lang.annotation 中的构造方法

AnnotationFormatError(String message)
构造具有指定详细消息的新 AnnotationFormatError。

AnnotationFormatError(String message, Throwable cause)
构造带指定详细消息和原因的新 AnnotationFormatError。

AnnotationTypeMismatchException(Method element, String foundType)
构造针对指定的注释类型元素和找到的数据类型的 AnnotationTypeMismatchException。

IncompleteAnnotationException(Class<? extends Annotation> annotationType, String elementName)
构造一个指示指定注释类型中缺少指定元素的 IncompleteAnnotationException。

java.lang.instrument 中 String 的使用

参数类型为 String 的 java.lang.instrument 中的方法

void

Instrumentation.setNativeMethodPrefix(ClassFileTransformer transformer, String prefix)
通过允许重试，将前缀应用到名称，此方法修改本机方法解析的失败处理。

byte[]

ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

参数类型为 String 的 java.lang.instrument 中的构造方法

IllegalClassFormatException(String s)
构造具有指定详细消息的 IllegalClassFormatException。

UnmodifiableClassException(String s)
构造具有指定详细消息的 UnmodifiableClassException。

java.lang.management 中 String 的使用

声明为 String 的 java.lang.management 中的字段

static String

ManagementFactory.CLASS_LOADING_MXBEAN_NAME
ClassLoadingMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.COMPILATION_MXBEAN_NAME
CompilationMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.GARBAGE_COLLECTOR_MXBEAN_DOMAIN_TYPE
GarbageCollectorMXBean 的 ObjectName 中的域名和类型键属性。

static String

MemoryNotificationInfo.MEMORY_COLLECTION_THRESHOLD_EXCEEDED
表示当 Java 虚拟机对内存池中的不使用的对象进行了回收工作之后，内存池的内存使用量大于或等于其集合使用量阈值的通知类型。

static String

ManagementFactory.MEMORY_MANAGER_MXBEAN_DOMAIN_TYPE
MemoryManagerMXBean 的 ObjectName 中的域名和类型键属性。

static String

ManagementFactory.MEMORY_MXBEAN_NAME
MemoryMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.MEMORY_POOL_MXBEAN_DOMAIN_TYPE
MemoryPoolMXBean 的 ObjectName 中的域名和类型键属性。

static String

MemoryNotificationInfo.MEMORY_THRESHOLD_EXCEEDED
表示内存池的内存使用量已达到或超过其使用量阈值的通知类型。

static String

ManagementFactory.OPERATING_SYSTEM_MXBEAN_NAME
OperatingSystemMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.RUNTIME_MXBEAN_NAME
RuntimeMXBean 的 ObjectName 的字符串表示形式。

static String

ManagementFactory.THREAD_MXBEAN_NAME
ThreadMXBean 的 ObjectName 的字符串表示形式。

返回 String 的 java.lang.management 中的方法

String

OperatingSystemMXBean.getArch()
返回操作系统的架构。

String

RuntimeMXBean.getBootClassPath()
返回由引导类加载器用于搜索类文件的引导类路径。

String

LockInfo.getClassName()
返回锁对象的完全限定类名称。

String

RuntimeMXBean.getClassPath()
返回系统类加载器用于搜索类文件的 Java 类路径。

String

RuntimeMXBean.getLibraryPath()
返回 Java 库路径。

String

ThreadInfo.getLockName()
返回对象的字符串表示形式，与此 ThreadInfo 关联的线程被锁定并等待该对象。

String

ThreadInfo.getLockOwnerName()
返回拥有对象的线程的名称，与此 ThreadInfo 关联的线程被阻塞并等待该对象。

String

RuntimeMXBean.getManagementSpecVersion()
返回正在运行的 Java 虚拟机实现的管理接口的规范版本。

String[]

MemoryPoolMXBean.getMemoryManagerNames()
返回管理此内存池的内存管理器的名称。

String[]

MemoryManagerMXBean.getMemoryPoolNames()
返回此内存管理器管理的内存池名称。

String

CompilationMXBean.getName()
返回即时 (JIT) 编译器的名称。

String

MemoryManagerMXBean.getName()
返回表示此内存管理器的名称。

String

MemoryPoolMXBean.getName()
返回表示此内存池的名称。

String

OperatingSystemMXBean.getName()
返回操作系统名称。

String

RuntimeMXBean.getName()
返回表示正在运行的 Java 虚拟机的名称。

String

MemoryNotificationInfo.getPoolName()
返回触发此通知的内存池的名称。

String

RuntimeMXBean.getSpecName()
返回 Java 虚拟机规范名称。

String

RuntimeMXBean.getSpecVendor()
返回 Java 虚拟机规范供应商。

String

RuntimeMXBean.getSpecVersion()
返回 Java 虚拟机规范版本。

String

ThreadInfo.getThreadName()
返回与此 ThreadInfo 关联的线程的名称。

String

OperatingSystemMXBean.getVersion()
返回操作系统的版本。

String

RuntimeMXBean.getVmName()
返回 Java 虚拟机实现名称。

String

RuntimeMXBean.getVmVendor()
返回 Java 虚拟机实现供应商。

String

RuntimeMXBean.getVmVersion()
返回 Java 虚拟机实现版本。

String

LockInfo.toString()
返回锁的字符串表示形式。

String

MemoryType.toString()
返回该 MemoryType 的字符串表示形式。

String

MemoryUsage.toString()
返回此内存使用量的描述性表示形式。

String

ThreadInfo.toString()
返回此线程信息的字符串表示形式。

返回变量类型为 String 的类型的 java.lang.management 中的方法

List<String>

RuntimeMXBean.getInputArguments()
返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。

Map<String,String>

RuntimeMXBean.getSystemProperties()
返回所有系统属性的名称和值的映射。

Map<String,String>

RuntimeMXBean.getSystemProperties()
返回所有系统属性的名称和值的映射。

参数类型为 String 的 java.lang.management 中的方法

static

<T> T

ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

static MemoryType

MemoryType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.lang.management 中的构造方法

LockInfo(String className, int identityHashCode)
构造一个 LockInfo 对象。

ManagementPermission(String name)
构造具有指定名称的 ManagementPermission。

ManagementPermission(String name, String actions)
构造新的 ManagementPermission 对象。

MemoryNotificationInfo(String poolName, MemoryUsage usage, long count)
构造一个 MemoryNotificationInfo 对象。

MonitorInfo(String className, int identityHashCode, int stackDepth, StackTraceElement stackFrame)
构造一个 MonitorInfo 对象。

java.lang.reflect 中 String 的使用

返回 String 的 java.lang.reflect 中的方法

String

TypeVariable.getName()
返回此类型变量的名称，它出现在源代码中。

String

Constructor.getName()
以字符串形式返回此构造方法的名称。

String

Method.getName()
以 String 形式返回此 Method 对象表示的方法名称。

String

Field.getName()
返回此 Field 对象表示的字段的名称。

String

Member.getName()
返回此 Member 表示的底层成员或构造方法的简单名称。

String

Constructor.toGenericString()
返回描述此 Constructor 的字符串，其中包括类型参数。

String

Method.toGenericString()
返回描述此 Method 的字符串，包括类型参数。

String

Field.toGenericString()
返回一个描述此 Field（包括其一般类型）的字符串。

String

Constructor.toString()
返回描述此 Constructor 的字符串。

String

Method.toString()
返回描述此 Method 的字符串。

String

Field.toString()
返回一个描述此 Field 的字符串。

static String

Modifier.toString(int mod)
返回描述指定修饰符中的访问修饰符标志的字符串。

参数类型为 String 的 java.lang.reflect 中的构造方法

InvocationTargetException(Throwable target, String s)
构造带目标异常和详细消息的 InvocationTargetException。

ReflectPermission(String name)
构造不带指定名称的 ReflectPermission。

ReflectPermission(String name, String actions)
构造带指定名称和动作的 ReflectPermission。

UndeclaredThrowableException(Throwable undeclaredThrowable, String s)
根据指定的 Throwable 和详细消息构造 UndeclaredThrowableException。

java.math 中 String 的使用

返回 String 的 java.math 中的方法

String

BigDecimal.toEngineeringString()
返回此 BigDecimal 的字符串表示形式，需要指数时，则使用工程计数法。

String

BigDecimal.toPlainString()
返回不带指数字段的此 BigDecimal 的字符串表示形式。

String

BigDecimal.toString()
返回此 BigDecimal 的字符串表示形式，如果需要指数，则使用科学记数法。

String

MathContext.toString()
返回此 MathContext 的字符串表示形式。

String

BigInteger.toString()
返回此 BigInteger 的十进制字符串表示形式。

String

BigInteger.toString(int radix)
返回此 BigInteger 的给定基数的字符串表示形式。

参数类型为 String 的 java.math 中的方法

static RoundingMode

RoundingMode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.math 中的构造方法

BigDecimal(String val)
将 BigDecimal 的字符串表示形式转换为 BigDecimal。

BigDecimal(String val, MathContext mc)
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。

BigInteger(String val)
将 BigInteger 的十进制字符串表示形式转换为 BigInteger。

BigInteger(String val, int radix)
将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger。

MathContext(String val)
根据字符串构造一个新的 MathContext。

java.net 中 String 的使用

声明为 String 的 java.net 中的字段

protected  String

HttpURLConnection.method
HTTP 方法（GET、POST、PUT 等）。

protected  String

HttpURLConnection.responseMessage
HTTP 响应消息。

返回 String 的 java.net 中的方法

static String

URLDecoder.decode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。

static String

URLDecoder.decode(String s, String enc)
使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。

static String

URLEncoder.encode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。

static String

URLEncoder.encode(String s, String enc)
使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。

String

SocketPermission.getActions()
返回动作的规范化字符串表示形式。

String

URI.getAuthority()
返回此 URI 的已解码的授权组成部分。

String

URL.getAuthority()
获取此 URL 的授权部分。

String

InetAddress.getCanonicalHostName()
获取此 IP 地址的完全限定域名。

abstract  String

SecureCacheResponse.getCipherSuite()
返回正在获得了网络资源的初始连接上使用的密码套件。

String

HttpCookie.getComment()
返回描述此 cookie 用途的注释；如果该 cookie 没有注释，则返回 null。

String

HttpCookie.getCommentURL()
返回描述此 cookie 用途的注释 URL；如果 cookie 没有注释 URL，则返回 null。

String

URLConnection.getContentEncoding()
返回 content-encoding 头字段的值。

String

URLConnection.getContentType()
返回 content-type 头字段的值。

String

FileNameMap.getContentTypeFor(String fileName)
获取指定文件名的 MIME 类型。

static String

URLConnection.getDefaultRequestProperty(String key)
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。

String

NetworkInterface.getDisplayName()
获取此网络接口的显示名称。

String

HttpCookie.getDomain()
返回为此 cookie 设置的域名。

String

JarURLConnection.getEntryName()
返回此连接的条目名称。

String

URL.getFile()
获取此 URL 的文件名。

String

URI.getFragment()
返回此 URI 的已解码的片段组成部分。

String

HttpURLConnection.getHeaderField(int n)
返回 nth 头字段的值。

String

URLConnection.getHeaderField(int n)
返回第 n 个头字段的值。

String

URLConnection.getHeaderField(String name)
返回指定的头字段的值。

String

HttpURLConnection.getHeaderFieldKey(int n)
返回 nth 头字段的键。

String

URLConnection.getHeaderFieldKey(int n)
返回第 n 个头字段的键。

String

URI.getHost()
返回此 URI 的主机组成部分。

String

URL.getHost()
获取此 URL 的主机名（如果适用）。

String

Inet6Address.getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

String

Inet4Address.getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

String

InetAddress.getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

String

InetSocketAddress.getHostName()
获取 hostname。

String

InetAddress.getHostName()
获取此 IP 地址的主机名。

String

URISyntaxException.getInput()
返回输入字符串。

String

HttpRetryException.getLocation()
如果重定向产生错误，则返回 Location 头字段的值。

String

URISyntaxException.getMessage()
返回描述解析错误的字符串。

String

HttpCookie.getName()
返回 cookie 的名称。

String

NetworkInterface.getName()
获取此网络接口的名称。

String

HttpCookie.getPath()
返回浏览器将此 cookie 返回到的服务器上的路径。

String

URI.getPath()
返回此 URI 的已解码的路径组成部分。

String

URL.getPath()
获取此 URL 的路径部分。

String

HttpCookie.getPortlist()
返回 cookie 的端口列表属性

String

URL.getProtocol()
获取此 URL 的协议名称。

String

URI.getQuery()
返回此 URI 的已解码的查询组成部分。

String

URL.getQuery()
获取此 URL 的查询部分。

String

URI.getRawAuthority()
返回此 URI 的原始授权组成部分。

String

URI.getRawFragment()
返回此 URI 的原始片段组成部分。

String

URI.getRawPath()
返回此 URI 的原始路径组成部分。

String

URI.getRawQuery()
返回此 URI 的原始查询组成部分。

String

URI.getRawSchemeSpecificPart()
返回此 URI 原始的、特定于方案的部分。

String

URI.getRawUserInfo()
返回此 URI 的原始用户信息组成部分。

String

HttpRetryException.getReason()
返回解释不能重试 http 请求的原因的字符串。

String

URISyntaxException.getReason()
返回一个字符串，解释输入字符串不能解析的原因。

String

URL.getRef()
获取此 URL 的锚点（也称为“引用”）。

protected  String

Authenticator.getRequestingHost()
获取请求验证的站点或代理的 hostname；如果不可用，则为 null。

protected  String

Authenticator.getRequestingPrompt()
获取请求方给出的提示字符串。

protected  String

Authenticator.getRequestingProtocol()
给出正在请求连接的协议。

protected  String

Authenticator.getRequestingScheme()
获取请求方的方案（例如，HTTP 防火墙的 HTTP 方案）。

String

HttpURLConnection.getRequestMethod()
获取请求方法。

String

URLConnection.getRequestProperty(String key)
返回此连接指定的一般请求属性值。

String

HttpURLConnection.getResponseMessage()
获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。

String

URI.getScheme()
返回此 URI 的方案组成部分。

String

URI.getSchemeSpecificPart()
返回此 URI 的特定于方案的解码部分。

String

URI.getUserInfo()
返回此 URI 的已解码的用户信息组成部分。

String

URL.getUserInfo()
获取此 URL 的 userInfo 部分。

String

PasswordAuthentication.getUserName()
返回用户名。

String

HttpCookie.getValue()
返回 cookie 的值。

static String

URLConnection.guessContentTypeFromName(String fname)
根据 URL 的指定 "file" 部分尝试确定对象的内容类型。

static String

URLConnection.guessContentTypeFromStream(InputStream is)
根据输入流的开始字符尝试确定输入流的类型。

static String

IDN.toASCII(String input)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

static String

IDN.toASCII(String input, int flag)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

String

URI.toASCIIString()
以 US-ASCII 字符串形式返回此 URI 的内容。

String

URL.toExternalForm()
构造此 URL 的字符串表示形式。

protected  String

URLStreamHandler.toExternalForm(URL u)
将特定协议的 URL 转换为 String。

String

HttpCookie.toString()
构造此 cookie 的一个 cookie 头字符串表示形式，其格式为对应的 cookie 规范定义的格式，但没有前导 "Cookie:" 标记。

String

InterfaceAddress.toString()
将此接口地址转换为 String。

String

NetworkInterface.toString()

String

ServerSocket.toString()
作为 String 返回此套接字的实现地址和实现端口。

String

Proxy.toString()
构造此代理的字符串表示形式。

String

URI.toString()
以字符串形式返回此 URI 的内容。

String

SocketImpl.toString()
以 String 的形式返回此套接字的地址和端口。

String

InetSocketAddress.toString()
构造此 InetSocketAddress 的字符串表示形式。

String

InetAddress.toString()
将此 IP 地址转换为 String。

String

Socket.toString()
将此套接字转换为 String。

String

URLConnection.toString()
返回此 URL 连接的 String 表示形式。

String

URL.toString()
构造此 URL 的字符串表示形式。

static String

IDN.toUnicode(String input)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。

static String

IDN.toUnicode(String input, int flag)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。

返回变量类型为 String 的类型的 java.net 中的方法

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

URLConnection.getHeaderFields()
返回头字段的不可修改的 Map。

Map<String,List<String>>

URLConnection.getHeaderFields()
返回头字段的不可修改的 Map。

abstract  Map<String,List<String>>

CacheResponse.getHeaders()
以 Map 的形式返回响应头。

abstract  Map<String,List<String>>

CacheResponse.getHeaders()
以 Map 的形式返回响应头。

Map<String,List<String>>

URLConnection.getRequestProperties()
返回一个由此连接的一般请求属性构成的不可修改的 Map。

Map<String,List<String>>

URLConnection.getRequestProperties()
返回一个由此连接的一般请求属性构成的不可修改的 Map。

参数类型为 String 的 java.net 中的方法

void

URLConnection.addRequestProperty(String key, String value)
添加由键值对指定的一般请求属性。

protected abstract  void

SocketImpl.connect(String host, int port)
将此套接字连接到指定主机上的指定端口。

static URI

URI.create(String str)
通过解析给定的字符串创建 URI。

ContentHandler

ContentHandlerFactory.createContentHandler(String mimetype)
创建从 URLStreamHandler 读取对象的新 ContentHandler。

static InetSocketAddress

InetSocketAddress.createUnresolved(String host, int port)
根据主机名和端口号创建未解析的套接字地址。

URLStreamHandler

URLStreamHandlerFactory.createURLStreamHandler(String protocol)
创建具有指定协议的新 URLStreamHandler 实例。

static String

URLDecoder.decode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。

static String

URLDecoder.decode(String s, String enc)
使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。

protected  Package

URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

static boolean

HttpCookie.domainMatches(String domain, String host)
检查主机名是否在域中的实用方法。

static String

URLEncoder.encode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。

static String

URLEncoder.encode(String s, String enc)
使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。

protected  Class<?>

URLClassLoader.findClass(String name)
通过 URL 搜索路径查找并加载具有指定名称的类。

URL

URLClassLoader.findResource(String name)
在 URL 搜索路径中查找具有指定名称的资源。

Enumeration<URL>

URLClassLoader.findResources(String name)
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。

abstract  CacheResponse

ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

static InetAddress[]

InetAddress.getAllByName(String host)
在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。

static InetAddress

InetAddress.getByAddress(String host, byte[] addr)
根据提供的主机名和 IP 地址创建 InetAddress。

static Inet6Address

Inet6Address.getByAddress(String host, byte[] addr, int scope_id)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。

static Inet6Address

Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。

static NetworkInterface

NetworkInterface.getByName(String name)
搜索具有指定名称的网络接口。

static InetAddress

InetAddress.getByName(String host)
在给定主机名的情况下确定主机的 IP 地址。

String

FileNameMap.getContentTypeFor(String fileName)
获取指定文件名的 MIME 类型。

static String

URLConnection.getDefaultRequestProperty(String key)
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。

String

URLConnection.getHeaderField(String name)
返回指定的头字段的值。

long

HttpURLConnection.getHeaderFieldDate(String name, long Default)

long

URLConnection.getHeaderFieldDate(String name, long Default)
返回解析为日期的指定字段的值。

int

URLConnection.getHeaderFieldInt(String name, int Default)
返回解析为数字的指定字段的值。

String

URLConnection.getRequestProperty(String key)
返回此连接指定的一般请求属性值。

static String

URLConnection.guessContentTypeFromName(String fname)
根据 URL 的指定 "file" 部分尝试确定对象的内容类型。

static List<HttpCookie>

HttpCookie.parse(String header)
根据 set-cookie 或 set-cookie2 头字符串构造 cookie。

protected  void

URLStreamHandler.parseURL(URL u, String spec, int start, int limit)
将 URL 的字符表示形式解析为 URL 对象。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String scheme)
要求已经向系统注册的 authenticator 提供密码。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme)
要求已经向系统注册的 authenticator 提供密码。

static PasswordAuthentication

Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
要求已经向系统注册的 authenticator 提供密码。

URI

URI.resolve(String str)
解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。

protected  void

URL.set(String protocol, String host, int port, String file, String ref)
设置 URL 的字段。

protected  void

URL.set(String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
设置 URL 的指定的 8 个字段。

void

HttpCookie.setComment(String purpose)
指定一个描述 cookie 用途的注释。

void

HttpCookie.setCommentURL(String purpose)
指定一个描述 cookie 用途的注释 URL。

static void

URLConnection.setDefaultRequestProperty(String key, String value)
已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。

void

HttpCookie.setDomain(String pattern)
指定应在其中显示此 cookie 的域。

void

HttpCookie.setPath(String uri)
指定客户机应该返回 cookie 的路径。

void

HttpCookie.setPortlist(String ports)
指定 cookie 的端口列表，该列表在 Cookie 头中限制可能将 cookie 发送回的端口。

void

HttpURLConnection.setRequestMethod(String method)
设置 URL 请求的方法， GET POST HEAD OPTIONS PUT DELETE TRACE 以上方法之一是合法的，具体取决于协议的限制。

void

URLConnection.setRequestProperty(String key, String value)
设置一般请求属性。

protected  void

URLStreamHandler.setURL(URL u, String protocol, String host, int port, String file, String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);

protected  void

URLStreamHandler.setURL(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
将 URL 参数的字段设置为指示的值。

void

HttpCookie.setValue(String newValue)
在创建 cookie 之后将新值分配给 cookie。

static String

IDN.toASCII(String input)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

static String

IDN.toASCII(String input, int flag)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

static String

IDN.toUnicode(String input)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。

static String

IDN.toUnicode(String input, int flag)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。

static Proxy.Type

Proxy.Type.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Authenticator.RequestorType

Authenticator.RequestorType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 java.net 中的方法参数

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

abstract  Map<String,List<String>>

CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders)
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

Map<String,List<String>>

CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)

abstract  CacheResponse

ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

abstract  CacheResponse

ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

abstract  void

CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders)
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。

abstract  void

CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders)
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。

void

CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

void

CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

参数类型为 String 的 java.net 中的构造方法

BindException(String msg)
构造一个新的 BindException，使其具有关于绑定错误产生原因的指定详细消息。

ConnectException(String msg)
构造一个新的 ConnectException，使其具有关于连接错误产生原因的指定详细消息。

HttpCookie(String name, String value)
构造带有指定名称和值的 cookie。

HttpRetryException(String detail, int code)
根据指定的响应代码和异常详细消息构造新 HttpRetryException。

HttpRetryException(String detail, int code, String location)
构造一个新 HttpRetryException，使其具有详细消息 responseCode 和 Location 响应头字段的内容。

InetSocketAddress(String hostname, int port)
根据主机名和端口号创建套接字地址。

MalformedURLException(String msg)
构造带指定详细消息的 MalformedURLException。

NetPermission(String name)
创建具有指定名称的新 NetPermission。

NetPermission(String name, String actions)
创建带指定名称的新 NetPermission。

NoRouteToHostException(String msg)
构造一个新的 NoRouteToHostException，使其具有关于无法到达远程主机的原因的指定详细消息。

PasswordAuthentication(String userName, char[] password)
根据给定用户名和密码创建新的 PasswordAuthentication 对象。

PortUnreachableException(String msg)
构造带详细消息的新 PortUnreachableException。

ProtocolException(String host)
构造带指定详细消息的新 ProtocolException。

Socket(String host, int port)
创建一个流套接字并将其连接到指定主机上的指定端口号。

Socket(String host, int port, boolean stream)
已过时。 使用 DatagramSocket 取代 UDP 传输。

Socket(String host, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程主机上的指定远程端口。

SocketException(String msg)
构造带指定详细消息的新 SocketException。

SocketPermission(String host, String action)
创建带指定动作的新 SocketPermission 对象。

SocketTimeoutException(String msg)
构造带详细消息的新 SocketTimeoutException。

UnknownHostException(String host)
构造带有指定详细消息的新 UnknownHostException。

UnknownServiceException(String msg)
构造带指定详细消息的新 UnknownServiceException。

URI(String str)
通过解析给定的字符串构造一个 URI。

URI(String scheme, String ssp, String fragment)
根据给定的组成部分构造 URI。

URI(String scheme, String userInfo, String host, int port, String path, String query, String fragment)
根据给定的组成部分构造一个分层 URI。

URI(String scheme, String host, String path, String fragment)
根据给定的组成部分构造分层 URI。

URI(String scheme, String authority, String path, String query, String fragment)
根据给定的组成部分构造分层 URI。

URISyntaxException(String input, String reason)
根据给定的输入字符串和原因构造一个实例。

URISyntaxException(String input, String reason, int index)
根据给定的输入字符串、原因和错误索引构造一个实例。

URL(String spec)
根据 String 表示形式创建 URL 对象。

URL(String protocol, String host, int port, String file)
根据指定 protocol、host、port 号和 file 创建 URL 对象。

URL(String protocol, String host, int port, String file, URLStreamHandler handler)
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。

URL(String protocol, String host, String file)
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。

URL(URL context, String spec)
通过在指定的上下文中对给定的 spec 进行解析创建 URL。

URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。

java.nio 中 String 的使用

返回 String 的 java.nio 中的方法

String

DoubleBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

FloatBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

LongBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

ShortBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

IntBuffer.toString()
返回总结了此缓冲区状态的字符串。

String

CharBuffer.toString()
返回包含此缓冲区中字符的字符串。

String

ByteOrder.toString()
构造描述此对象的字符串。

String

ByteBuffer.toString()
返回汇总了此缓冲区状态的字符串。

参数类型为 String 的 java.nio 中的方法

CharBuffer

CharBuffer.put(String src)
相对批量 put 方法（可选操作）。

CharBuffer

CharBuffer.put(String src, int start, int end)
相对批量 put 方法（可选操作）。

java.nio.channels 中 String 的使用

返回 String 的 java.nio.channels 中的方法

String

FileLock.toString()
返回描述此锁定的范围、类型和有效性的字符串。

String

FileChannel.MapMode.toString()
返回描述此文件映射模式的字符串。

参数类型为 String 的 java.nio.channels 中的方法

static Reader

Channels.newReader(ReadableByteChannel ch, String csName)
构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。

static Writer

Channels.newWriter(WritableByteChannel ch, String csName)
构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。

java.nio.charset 中 String 的使用

返回 String 的 java.nio.charset 中的方法

String

Charset.displayName()
返回此 charset 用于默认语言环境的可读名称。

String

Charset.displayName(Locale locale)
返回此 charset 用于给定语言环境的可读名称。

String

IllegalCharsetNameException.getCharsetName()
获取非法的 charset 名称。

String

UnsupportedCharsetException.getCharsetName()
获取不受支持的 charset 的名称。

String

MalformedInputException.getMessage()

String

UnmappableCharacterException.getMessage()

String

Charset.name()
返回此 charset 的规范名称。

String

CharsetDecoder.replacement()
返回此解码器的替换值。

String

CoderResult.toString()
返回描述此 CoderResult 的字符串。

String

CodingErrorAction.toString()
返回描述此操作的字符串。

String

Charset.toString()
返回描述此 charset 的字符串。

返回变量类型为 String 的类型的 java.nio.charset 中的方法

Set<String>

Charset.aliases()
返回包含此 charset 各个别名的集合。

static SortedMap<String,Charset>

Charset.availableCharsets()
构造从规范 charset 名称到 charset 对象的有序映射。

参数类型为 String 的 java.nio.charset 中的方法

ByteBuffer

Charset.encode(String str)
将此 charset 中的字符串编码成字节的便捷方法。

static Charset

Charset.forName(String charsetName)
返回指定 charset 的 charset 对象。

protected  void

CharsetDecoder.implReplaceWith(String newReplacement)
报告此解码器替换值的更改。

static boolean

Charset.isSupported(String charsetName)
通知是否支持指定的 charset。

CharsetDecoder

CharsetDecoder.replaceWith(String newReplacement)
更改此解码器的替换值。

参数类型为 String 的 java.nio.charset 中的构造方法

Charset(String canonicalName, String[] aliases)
使用给定的规范名称和别名集合初始化新 charset。

Charset(String canonicalName, String[] aliases)
使用给定的规范名称和别名集合初始化新 charset。

IllegalCharsetNameException(String charsetName)
构造此类的一个实例。

UnsupportedCharsetException(String charsetName)
构造此类的一个实例。

java.nio.charset.spi 中 String 的使用

参数类型为 String 的 java.nio.charset.spi 中的方法

abstract  Charset

CharsetProvider.charsetForName(String charsetName)
用给定的 charset 名称获取 charset。

java.rmi 中 String 的使用

返回 String 的 java.rmi 中的方法

String

RemoteException.getMessage()
返回此异常的详细消息，包括来自原因（如果有）方面的消息。

static String[]

Naming.list(String name)
返回在注册表中绑定的名称所组成的数组。

参数类型为 String 的 java.rmi 中的方法

static void

Naming.bind(String name, Remote obj)
将指定 name 绑定到远程对象。

static String[]

Naming.list(String name)
返回在注册表中绑定的名称所组成的数组。

static Remote

Naming.lookup(String name)
返回与指定 name 关联的远程对象的引用（一个 stub）。

static void

Naming.rebind(String name, Remote obj)
将指定名称重新绑定到一个新的远程对象。

static void

Naming.unbind(String name)
销毁与远程对象关联的指定名称的绑定。

参数类型为 String 的 java.rmi 中的构造方法

AccessException(String s)
构造带指定详细消息的 AccessException。

AccessException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 AccessException。

AlreadyBoundException(String s)
构造带指定详细消息的 AlreadyBoundException。

ConnectException(String s)
构造带指定详细消息的 ConnectException。

ConnectException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectException。

ConnectIOException(String s)
构造带指定详细消息的 ConnectIOException。

ConnectIOException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectIOException。

MarshalException(String s)
构造带有指定详细消息的 MarshalException。

MarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 MarshalException。

NoSuchObjectException(String s)
构造带指定详细消息的 NoSuchObjectException。

NotBoundException(String s)
构造带指定详细消息的 NotBoundException。

RemoteException(String s)
构造带指定详细消息的 RemoteException。

RemoteException(String s, Throwable cause)
构造带指定详细消息和原因的 RemoteException。

RMISecurityException(String name)
已过时。 无替换版本

RMISecurityException(String name, String arg)
已过时。 无替换版本

ServerError(String s, Error err)
构造带指定详细消息和嵌入错误的 ServerError。

ServerException(String s)
构造带指定详细消息的 ServerException。

ServerException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 ServerException。

ServerRuntimeException(String s, Exception ex)
已过时。 无替换版本

StubNotFoundException(String s)
构造带指定详细消息的 StubNotFoundException。

StubNotFoundException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 StubNotFoundException。

UnexpectedException(String s)
构造带指定详细消息的 UnexpectedException。

UnexpectedException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 UnexpectedException。

UnknownHostException(String s)
构造带指定详细消息的 UnknownHostException。

UnknownHostException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnknownHostException。

UnmarshalException(String s)
构造带指定详细消息的 UnmarshalException。

UnmarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnmarshalException。

java.rmi.activation 中 String 的使用

返回 String 的 java.rmi.activation 中的方法

String

ActivationDesc.getClassName()
返回此描述符指定的对象的类名。

String

ActivationGroupDesc.getClassName()
返回组的类名（可能为 null）。

String[]

ActivationGroupDesc.CommandEnvironment.getCommandOptions()
取得配置的 java 命令选项。

String

ActivationGroupDesc.CommandEnvironment.getCommandPath()
取得配置的限定路径的 java 命令名称。

String

ActivationDesc.getLocation()
返回此描述符指定的对象的代码基。

String

ActivationGroupDesc.getLocation()
返回组的代码基。

String

ActivationException.getMessage()
返回包含来自此异常的原因（如果有）的消息的详细消息。

参数类型为 String 的 java.rmi.activation 中的方法

static ActivationID

Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port)
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。

static ActivationID

Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 String 的 java.rmi.activation 中的构造方法

Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。

Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

ActivateFailedException(String s)
构造带指定详细消息的 ActivateFailedException。

ActivateFailedException(String s, Exception ex)
构造带指定详细消息和嵌套异常的 ActivateFailedException。

ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。

ActivationDesc(String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

ActivationDesc(String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

ActivationException(String s)
构造带指定详细消息的 ActivationException。

ActivationException(String s, Throwable cause)
构造带指定详细消息和原因的 ActivationException。

ActivationGroupDesc.CommandEnvironment(String cmdpath, String[] argv)
用所有必要的信息创建一个 CommandEnvironment。

ActivationGroupDesc.CommandEnvironment(String cmdpath, String[] argv)
用所有必要的信息创建一个 CommandEnvironment。

ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

UnknownGroupException(String s)
构造带指定详细消息的 UnknownGroupException。

UnknownObjectException(String s)
构造带指定详细消息的 UnknownObjectException。

java.rmi.dgc 中 String 的使用

返回 String 的 java.rmi.dgc 中的方法

String

VMID.toString()
返回此 VMID 的字符串表示形式。

java.rmi.registry 中 String 的使用

返回 String 的 java.rmi.registry 中的方法

String[]

Registry.list()
返回在此注册表中绑定的名称的数组。

参数类型为 String 的 java.rmi.registry 中的方法

void

Registry.bind(String name, Remote obj)
绑定对此注册表中指定 name 的远程引用。

static Registry

LocateRegistry.getRegistry(String host)
返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。

static Registry

LocateRegistry.getRegistry(String host, int port)
返回指定的 host 和 port 上对远程对象 Registry 的引用。

static Registry

LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf)
返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。

Remote

Registry.lookup(String name)
返回注册表中绑定到指定 name 的远程引用。

void

Registry.rebind(String name, Remote obj)
用提供的远程引用替换此注册表中指定的 name 绑定。

Registry

RegistryHandler.registryStub(String host, int port)
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

void

Registry.unbind(String name)
移除此注册表中指定的 name 绑定。

java.rmi.server 中 String 的使用

声明为 String 的 java.rmi.server 中的字段

static String

LoaderHandler.packagePrefix
已过时。 系统 LoaderHandler 实现的包。

static String

RemoteRef.packagePrefix
初始化服务器包的前缀：假定服务器 ref 类（如 UnicastRef、UnicastServerRef）的实现位于由前缀定义的包中。

返回 String 的 java.rmi.server 中的方法

static String

RMIClassLoader.getClassAnnotation(Class<?> cl)
返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。

abstract  String

RMIClassLoaderSpi.getClassAnnotation(Class<?> cl)
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。

static String

RemoteServer.getClientHost()
返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。

String

ServerRef.getClientHost()
返回当前客户机的主机名。

String

ServerCloneException.getMessage()
返回此异常的详细信息，包括原因的消息（如果有）。

String

Operation.getOperation()
已过时。 无替代版本

String

RemoteRef.getRefClass(ObjectOutput out)
返回要在流 'out' 上序列化的 ref 类型的类名称。

String

RemoteRef.remoteToString()
返回表示此远程对象的引用的 String。

String

LogStream.toString()
已过时。 无替代版本

String

ObjID.toString()
返回此对象标识符的字符串表示形式。

String

Operation.toString()
已过时。 无替代版本

String

RemoteObject.toString()
返回表示此远程对象的值的 String。

String

UID.toString()
返回此 UID 的字符串表示形式。

参数类型为 String 的 java.rmi.server 中的方法

Socket

RMIClientSocketFactory.createSocket(String host, int port)
创建连接到指定主机和端口的客户机套接字。

abstract  Socket

RMISocketFactory.createSocket(String host, int port)
创建连接到指定主机和端口的客户机套接字。

static ClassLoader

RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。

abstract  ClassLoader

RMIClassLoaderSpi.getClassLoader(String codebase)
提供 RMIClassLoader.getClassLoader(String) 的实现。

Class<?>

LoaderHandler.loadClass(String name)
已过时。 无替代版本

static Class<?>

RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代

static Class<?>

RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。

static Class<?>

RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。

abstract  Class<?>

RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。

Class<?>

LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本

static Class<?>

RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。

static Class<?>

RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。

static Class<?>

RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。

abstract  Class<?>

RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

abstract  Class<?>

RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

static LogStream

LogStream.log(String name)
已过时。 无替代版本

static int

LogStream.parseLevel(String s)
已过时。 无替代版本

参数类型为 String 的 java.rmi.server 中的构造方法

ExportException(String s)
构造带指定详细消息的 ExportException。

ExportException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ExportException。

Operation(String op)
已过时。 无替代版本

ServerCloneException(String s)
构造带指定详细消息的 ServerCloneException。

ServerCloneException(String s, Exception cause)
构造带指定详细消息和原因的 ServerCloneException。

ServerNotActiveException(String s)
构造带指定详细消息的 ServerNotActiveException。

SkeletonMismatchException(String s)
已过时。 无替代版本

SkeletonNotFoundException(String s)
已过时。 构造带指定详细消息的 SkeletonNotFoundException。

SkeletonNotFoundException(String s, Exception ex)
已过时。 构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。

SocketSecurityException(String s)
构造带指定详细消息的 SocketSecurityException。

SocketSecurityException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。

java.security 中 String 的使用

返回 String 的 java.security 中的方法

abstract  String

KeyStoreSpi.engineGetCertificateAlias(Certificate cert)
返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。

protected abstract  String

AlgorithmParametersSpi.engineToString()
返回描述参数的格式化字符串。

String

UnresolvedPermission.getActions()
返回这些操作的规范的字符串表示形式，该字符串当前为空字符串 ""，原因是没有针对 UnresolvedPermission 的操作。

String

AllPermission.getActions()
返回操作的规范化字符串表示形式。

String

BasicPermission.getActions()
返回操作的规范化字符串表示形式，该表示形式当前为空字符串 ""，因为不存在 BasicPermission 的操作。

abstract  String

Permission.getActions()
以 String 的形式返回操作。

String

AlgorithmParameterGenerator.getAlgorithm()
返回与此参数生成器关联的算法的标准名称。

String

KeyPairGenerator.getAlgorithm()
返回此密钥对生成器算法的标准名称。

String

SecureRandom.getAlgorithm()
返回此 SecureRandom 对象实现的算法的名称。

String

SignedObject.getAlgorithm()
获取签名算法的名称。

String

Signature.getAlgorithm()
返回此签名对象的算法名称。

String

AlgorithmParameters.getAlgorithm()
返回与此参数对象关联的算法的名称。

String

KeyFactory.getAlgorithm()
获取与此 KeyFactory 关联的算法的名称。

String

Key.getAlgorithm()
返回此密钥的标准算法名称。

String

MessageDigest.getAlgorithm()
返回标识算法的独立于实现细节的字符串。

String

Provider.Service.getAlgorithm()
返回此服务的算法的名称。

static String

Security.getAlgorithmProperty(String algName, String propName)
已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。

String

Provider.Service.getAttribute(String name)
返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。

String

KeyStore.getCertificateAlias(Certificate cert)
返回证书与给定证书匹配的第一个 keystore 条目的别名。

String

Provider.Service.getClassName()
返回实现此服务的类的名称。

static String

KeyStore.getDefaultType()
返回 Java 安全属性文件中指定的默认 keystore 类型；如果不存在此类属性，则返回字符串 "jks"（"Java keystore" 的首字母缩写）。

String

Certificate.getFormat()
已过时。 返回编码格式的名称。

String

Key.getFormat()
返回此密钥的基本编码格式，如果此密钥不支持编码，则返回 null。

String

Identity.getInfo()
已过时。 返回以前为此 Identity 指定的常规信息字符串。

String

Provider.getInfo()
返回 provider 及其服务的人可读 (human-readable) 的描述。

String

Identity.getName()
已过时。 返回此 Identity 的名称。

String

Provider.getName()
返回此 provider 的名称。

String

Principal.getName()
返回此主体的名称。

String

Permission.getName()
返回此 Permission 的名称。

static String

Security.getProperty(String key)
获取安全属性值。

String

Provider.getProperty(String key)

String

KeyStore.getType()
返回此 keystore 的类型。

String

Provider.Service.getType()
获取此服务的类型。

String

Policy.getType()
返回此 Policy 的类型。

String

UnresolvedPermission.getUnresolvedActions()
获取尚未解析的基础权限的操作。

String

UnresolvedPermission.getUnresolvedName()
获取尚未解析的基础权限的目标名称。

String

UnresolvedPermission.getUnresolvedType()
获取尚未解析的基础权限的类型（类名称）。

String

DigestInputStream.toString()
打印此摘要输入流及其关联的消息摘要对象的字符串表示形式。

String

DigestOutputStream.toString()
打印此摘要输出流及其关联的消息摘要对象的字符串表示形式。

String

Identity.toString()
已过时。 返回描述此 Identity 的短字符串，说明其名称和作用域（如果有的话）。

String

IdentityScope.toString()
已过时。 返回此身份作用域的字符串表示形式，包括其名称、作用域名称和此身份作用域中身份的数目。

String

KeyStore.PrivateKeyEntry.toString()
返回此 PrivateKeyEntry 的字符串表示形式。

String

KeyStore.SecretKeyEntry.toString()
返回此 SecretKeyEntry 的字符串表示形式。

String

KeyStore.TrustedCertificateEntry.toString()
返回此 TrustedCertificateEntry 的字符串表示形式。

String

Signer.toString()
已过时。 返回有关该 signer 信息的字符串。

String

Timestamp.toString()
返回描述此时间戳的字符串。

String

CodeSigner.toString()
返回描述此代码签名者的字符串。

String

Signature.toString()
返回此签名对象的字符串表示形式，以提供包括对象状态和所用算法名称在内的信息。

String

AlgorithmParameters.toString()
返回描述参数的格式化字符串。

String

MessageDigest.toString()
返回此信息摘要对象的字符串表示形式。

String

Provider.toString()
返回具有此 provider 名称和版本号的字符串。

String

Provider.Service.toString()
返回此服务的字符串表示形式。

String

Principal.toString()
返回此主体的字符串表示形式。

String

UnresolvedPermission.toString()
返回描述此 UnresolvedPermission 的字符串。

String

PermissionCollection.toString()
返回描述此 PermissionCollection 对象的字符串，提供该对象中包含的关于所有权限的信息。

String

CodeSource.toString()
返回描述此 CodeSource 的字符串，告知其 URL 和证书。

String

PrivilegedActionException.toString()

String

Permission.toString()
返回描述此 Permission 的字符串。

String

ProtectionDomain.toString()
将 ProtectionDomain 转换成为 String。

String

Certificate.toString(boolean detailed)
已过时。 返回表示证书内容的字符串。

String

Identity.toString(boolean detailed)
已过时。 返回此 Identity 的字符串表示形式，可以选择比不带任何参数的 toString 方法带有更多的详细信息。

返回变量类型为 String 的类型的 java.security 中的方法

Enumeration<String>

KeyStore.aliases()
列出此 keystore 的所有别名。

abstract  Enumeration<String>

KeyStoreSpi.engineAliases()
列出此 keystore 的所有别名。

static Set<String>

Security.getAlgorithms(String serviceName)
返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。

参数类型为 String 的 java.security 中的方法

boolean

KeyStore.containsAlias(String alias)
检查给定别名是否存在于此 keystore 中。

protected  Class<?>

SecureClassLoader.defineClass(String name, byte[] b, int off, int len, CodeSource cs)
使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。

protected  Class<?>

SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs)
使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。

void

KeyStore.deleteEntry(String alias)
删除此 keystore 中给定别名标识的条目。

abstract  boolean

KeyStoreSpi.engineContainsAlias(String alias)
检查给定别名是否存在于此 keystore 中。

abstract  void

KeyStoreSpi.engineDeleteEntry(String alias)
删除由此 keystore 中给定的别名标识的项。

boolean

KeyStoreSpi.engineEntryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

abstract  Certificate

KeyStoreSpi.engineGetCertificate(String alias)
返回与给定别名关联的证书。

abstract  Certificate[]

KeyStoreSpi.engineGetCertificateChain(String alias)
返回与给定别名关联的证书链。

abstract  Date

KeyStoreSpi.engineGetCreationDate(String alias)
返回该别名标识的项的创建日期。

protected abstract  byte[]

AlgorithmParametersSpi.engineGetEncoded(String format)
返回以指定格式编码的参数。

KeyStore.Entry

KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam)
使用指定保护参数获取指定别名的 KeyStore.Entry。

abstract  Key

KeyStoreSpi.engineGetKey(String alias, char[] password)
返回与给定别名关联的密钥，使用给定密码恢复它。

protected abstract  Object

SignatureSpi.engineGetParameter(String param)
已过时。

protected abstract  void

AlgorithmParametersSpi.engineInit(byte[] params, String format)
根据指定的解码格式从 params 导入参数并对其解码。

abstract  boolean

KeyStoreSpi.engineIsCertificateEntry(String alias)
如果给定别名标识的项是通过调用 setCertificateEntry 或者调用使用 TrustedCertificateEntry 作为参数的 setEntry 来创建的，则返回 true。

abstract  boolean

KeyStoreSpi.engineIsKeyEntry(String alias)
如果给定别名标识的项是通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 或 SecretKeyEntry 作为参数的 setEntry 创建的，则返回 true。

abstract  void

KeyStoreSpi.engineSetCertificateEntry(String alias, Certificate cert)
将给定证书分配给给定别名。

void

KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
用指定别名保存 KeyStore.Entry。

abstract  void

KeyStoreSpi.engineSetKeyEntry(String alias, byte[] key, Certificate[] chain)
将给定密钥（已经被保护）分配给给定别名。

abstract  void

KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，用给定的密码保护它。

protected abstract  void

SignatureSpi.engineSetParameter(String param, Object value)
已过时。 由 engineSetParameter 取代。

boolean

KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

static String

Security.getAlgorithmProperty(String algName, String propName)
已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。

static Set<String>

Security.getAlgorithms(String serviceName)
返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。

String

Provider.Service.getAttribute(String name)
返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。

Certificate

KeyStore.getCertificate(String alias)
返回与给定别名关联的证书。

Certificate[]

KeyStore.getCertificateChain(String alias)
返回与给定别名关联的证书链。

Date

KeyStore.getCreationDate(String alias)
返回给定别名标识的条目的创建日期。

byte[]

AlgorithmParameters.getEncoded(String format)
返回以指定方案编码的参数。

KeyStore.Entry

KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam)
使用指定保护参数获取指定别名的 keystore Entry。

abstract  Identity

IdentityScope.getIdentity(String name)
已过时。 返回此作用域内具有指定名称的身份（如果有的话）。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance(String algorithm)
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

static KeyPairGenerator

KeyPairGenerator.getInstance(String algorithm)
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

static KeyStore

KeyStore.getInstance(String type)
返回指定类型的 keystore 对象。

static SecureRandom

SecureRandom.getInstance(String algorithm)
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

static Signature

Signature.getInstance(String algorithm)
返回实现指定签名算法的 Signature 对象。

static AlgorithmParameters

AlgorithmParameters.getInstance(String algorithm)
返回指定算法的参数对象。

static KeyFactory

KeyFactory.getInstance(String algorithm)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

static MessageDigest

MessageDigest.getInstance(String algorithm)
返回实现指定摘要算法的 MessageDigest 对象。

static Policy

Policy.getInstance(String type, Policy.Parameters params)
返回指定类型的 Policy 对象。

static Policy

Policy.getInstance(String type, Policy.Parameters params, Provider provider)
返回指定类型的 Policy 对象。

static Policy

Policy.getInstance(String type, Policy.Parameters params, String provider)
返回指定类型的 Policy 对象。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider)
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

static KeyPairGenerator

KeyPairGenerator.getInstance(String algorithm, Provider provider)
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

static KeyStore

KeyStore.getInstance(String type, Provider provider)
返回指定类型的 keystore 对象。

static SecureRandom

SecureRandom.getInstance(String algorithm, Provider provider)
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

static Signature

Signature.getInstance(String algorithm, Provider provider)
返回实现指定签名算法的 Signature 对象。

static AlgorithmParameters

AlgorithmParameters.getInstance(String algorithm, Provider provider)
返回指定算法的参数对象。

static KeyFactory

KeyFactory.getInstance(String algorithm, Provider provider)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

static MessageDigest

MessageDigest.getInstance(String algorithm, Provider provider)
返回实现指定摘要算法的 MessageDigest 对象。

static AlgorithmParameterGenerator

AlgorithmParameterGenerator.getInstance(String algorithm, String provider)
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

static KeyPairGenerator

KeyPairGenerator.getInstance(String algorithm, String provider)
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

static KeyStore

KeyStore.getInstance(String type, String provider)
返回指定类型的 keystore 对象。

static SecureRandom

SecureRandom.getInstance(String algorithm, String provider)
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

static Signature

Signature.getInstance(String algorithm, String provider)
返回实现指定签名算法的 Signature 对象。

static AlgorithmParameters

AlgorithmParameters.getInstance(String algorithm, String provider)
返回指定算法的参数对象。

static KeyFactory

KeyFactory.getInstance(String algorithm, String provider)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

static MessageDigest

MessageDigest.getInstance(String algorithm, String provider)
返回实现指定摘要算法的 MessageDigest 对象。

Key

KeyStore.getKey(String alias, char[] password)
返回与给定别名关联的密钥，并用给定密码来恢复它。

Object

Signature.getParameter(String param)
已过时。

static String

Security.getProperty(String key)
获取安全属性值。

String

Provider.getProperty(String key)

abstract  KeyStore.ProtectionParameter

KeyStore.Builder.getProtectionParameter(String alias)
返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。

static Provider

Security.getProvider(String name)
返回使用指定的名称安装的提供者（如果有）。

static Provider[]

Security.getProviders(String filter)
返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

Provider.Service

Provider.getService(String type, String algorithm)
获取描述此算法或别名的指定类型的此 Provider 实现的服务。

void

AlgorithmParameters.init(byte[] params, String format)
根据指定的解码方案从 params 导入参数并对其解码。

boolean

KeyStore.isCertificateEntry(String alias)
如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。

boolean

KeyStore.isKeyEntry(String alias)
如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。

static KeyStore.Builder

KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

static KeyStore.Builder

KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

static void

Security.removeProvider(String name)
移除带有指定名称的提供者。

void

KeyStore.setCertificateEntry(String alias, Certificate cert)
将给定可信证书分配给给定别名。

void

KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam)
用指定别名保存 keystore Entry。

void

Identity.setInfo(String info)
已过时。 为此 Identity 指定一个常规信息字符串。

void

KeyStore.setKeyEntry(String alias, byte[] key, Certificate[] chain)
将给定密钥（已经被保护）分配给给定别名。

void

KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，并用给定密码保护它。

void

Signature.setParameter(String param, Object value)
已过时。 使用 setParameter 取代。

static void

Security.setProperty(String key, String datum)
设置安全属性值。

static KeyRep.Type

KeyRep.Type.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 java.security 中的方法参数

static Provider[]

Security.getProviders(Map<String,String> filter)
返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

static Provider[]

Security.getProviders(Map<String,String> filter)
返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

参数类型为 String 的 java.security 中的构造方法

AccessControlException(String s)
构造带指定详细消息的 AccessControlException。

AccessControlException(String s, Permission p)
构造带指定详细消息和导致异常的请求权限的 AccessControlException。

AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameterGenerator 对象。

AlgorithmParameters(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameters 对象。

AllPermission(String name, String actions)
创建新的 AllPermission 对象。

AuthProvider(String name, double version, String info)
构造具有指定名称、版本号和信息的 provider。

BasicPermission(String name)
创建具有指定名称的新 BasicPermission。

BasicPermission(String name, String actions)
创建具有指定名称的新 BasicPermission 对象。

DigestException(String msg)
构造带指定详细消息的 DigestException。

DigestException(String message, Throwable cause)
创建带指定详细消息和 cause 的 DigestException。

GeneralSecurityException(String msg)
构造带指定详细消息的 GeneralSecurityException。

GeneralSecurityException(String message, Throwable cause)
创建带指定详细消息和 cause 的 GeneralSecurityException。

Identity(String name)
已过时。 构造一个具有指定名称且没有作用域的 Identity。

Identity(String name, IdentityScope scope)
已过时。 构造一个具有指定名称和作用域的 Identity。

IdentityScope(String name)
已过时。 构造具有指定名称的新身份作用域。

IdentityScope(String name, IdentityScope scope)
已过时。 构造具有指定名称和作用域的新身份作用域。

InvalidAlgorithmParameterException(String msg)
构造带指定详细消息的 InvalidAlgorithmParameterException。

InvalidAlgorithmParameterException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。

InvalidKeyException(String msg)
构造带指定详细消息的 InvalidKeyException。

InvalidKeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidKeyException。

InvalidParameterException(String msg)
构造带指定详细消息的 InvalidParameterException。

KeyException(String msg)
构造带指定详细消息的 KeyException。

KeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyException。

KeyFactory(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 KeyFactory 对象。

KeyManagementException(String msg)
构造带指定详细消息的 KeyManagementException。

KeyManagementException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyManagementException。

KeyPairGenerator(String algorithm)
为指定的算法创建 KeyPairGenerator 对象。

KeyRep(KeyRep.Type type, String algorithm, String format, byte[] encoded)
构造替换的 Key 类。

KeyStore(KeyStoreSpi keyStoreSpi, Provider provider, String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。

KeyStoreException(String msg)
构造带指定详细消息的 KeyStoreException。

KeyStoreException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 KeyStoreException。

MessageDigest(String algorithm)
创建具有指定算法名称的信息摘要。

NoSuchAlgorithmException(String msg)
构造带指定详细消息的 NoSuchAlgorithmException。

NoSuchAlgorithmException(String message, Throwable cause)
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。

NoSuchProviderException(String msg)
构造带指定详细消息的 NoSuchProviderException。

Permission(String name)
构造具有指定名称的权限。

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

Provider(String name, double version, String info)
用指定的名称、版本号和信息构造一个 provider。

ProviderException(String s)
构造带指定详细消息的 ProviderException。

ProviderException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 ProviderException。

SecurityPermission(String name)
创建具有指定名称的新 SecurityPermission。

SecurityPermission(String name, String actions)
创建具有指定名称的新 SecurityPermission 对象。

Signature(String algorithm)
创建指定算法的 Signature 对象。

SignatureException(String msg)
构造带指定详细消息的 SignatureException。

SignatureException(String message, Throwable cause)
创建带指定详细消息和原因的 SignatureException。

Signer(String name)
已过时。 创建带有指定标识名称的 signer。

Signer(String name, IdentityScope scope)
已过时。 创建带有指定标识名称和范围的 signer。

UnrecoverableEntryException(String msg)
构造具有指定详细消息的 UnrecoverableEntryException，其提供了有关为什么抛出此异常的更多信息。

UnrecoverableKeyException(String msg)
构造具有指定详细消息的 UnrecoverableKeyException，其提供了有关为什么抛出此异常的更多信息。

UnresolvedPermission(String type, String name, String actions, Certificate[] certs)
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。

类型变量类型为 String 的 java.security 中的构造方法参数

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

java.security.acl 中 String 的使用

返回 String 的 java.security.acl 中的方法

String

Acl.getName()
返回此 ACL 的名称。

String

Acl.toString()
返回 ACL 内容的字符串表示形式。

String

AclEntry.toString()
返回此 ACL 项内容的字符串表示形式。

String

Permission.toString()
打印此权限的字符串表示形式。

参数类型为 String 的 java.security.acl 中的方法

void

Acl.setName(Principal caller, String name)
设置此 ACL 的名称。

java.security.cert 中 String 的使用

返回 String 的 java.security.cert 中的方法

String

CertPathBuilder.getAlgorithm()
返回此 CertPathBuilder 的算法名称。

String

CertPathValidator.getAlgorithm()
返回此 CertPathValidator 的算法名称。

String

TrustAnchor.getCAName()
以 RFC 2253 String 格式返回最受信任的 CA 的名称。

static String

CertPathBuilder.getDefaultType()
返回 Java 安全属性文件中所指定的默认 CertPathBuilder 类型，如果没有此属性，则返回字符串 "PKIX"。

static String

CertPathValidator.getDefaultType()
返回 Java 安全属性文件中所指定的默认 CertPathValidator 类型，如果没有此属性，则返回字符串 "PKIX"。

static String

CertStore.getDefaultType()
返回 Java 安全属性文件中指定的默认 CertStore 类型；如果没有此属性，则返回字符串 "LDAP"。

String

X509CertSelector.getIssuerAsString()
已过时，使用 X509CertSelector.getIssuer() 或 X509CertSelector.getIssuerAsBytes() 替代。

String

PolicyQualifierInfo.getPolicyQualifierId()
返回此 PolicyQualifierInfo 的 policyQualifierId 字段。

String

LDAPCertStoreParameters.getServerName()
返回 LDAP 服务器的 DNS 名称。

abstract  String

X509CRL.getSigAlgName()
获取 CRL 签名算法的签名算法名。

abstract  String

X509Certificate.getSigAlgName()
获取证书签名算法的签名算法名。

abstract  String

X509CRL.getSigAlgOID()
获取 CRL 的签名算法 OID 字符串。

abstract  String

X509Certificate.getSigAlgOID()
获取证书的签名算法 OID 字符串。

String

PKIXParameters.getSigProvider()
返回签名提供者的名称，如果未设置，则返回 null。

String

X509CertSelector.getSubjectAsString()
已过时，使用 X509CertSelector.getSubject() 或 X509CertSelector.getSubjectAsBytes() 替代。

String

X509CertSelector.getSubjectPublicKeyAlgID()
返回 subjectPublicKeyAlgID 标准。

String

CRL.getType()
返回此 CRL 的类型。

String

CertStore.getType()
返回此 CertStore 的类型。

String

CertPath.getType()
返回此证书路径中的 Certificate 类型。

String

CertificateFactory.getType()
返回与此 CertificateFactory 关联的证书类型的名称。

String

Certificate.getType()
返回此证书的类型。

String

PolicyNode.getValidPolicy()
返回此节点所表示的有效策略。

abstract  String

CRL.toString()
返回此 CRL 的字符串表示形式。

String

CollectionCertStoreParameters.toString()
返回描述该参数的格式化字符串。

String

LDAPCertStoreParameters.toString()
返回描述该参数的格式化字符串。

String

PKIXBuilderParameters.toString()
返回描述该参数的格式化字符串。

String

PKIXCertPathBuilderResult.toString()
返回此 PKIXCertPathBuilderResult 的可打印表示形式。

String

PKIXCertPathValidatorResult.toString()
返回此 PKIXCertPathValidatorResult 的可打印表示形式。

String

PKIXParameters.toString()
返回描述该参数的格式化字符串。

String

PolicyQualifierInfo.toString()
返回此 PolicyQualifierInfo 的可打印表示形式。

String

TrustAnchor.toString()
返回描述此 TrustAnchor 的格式化字符串。

abstract  String

X509CRLEntry.toString()
返回此 CRL 项的字符串表示形式。

String

X509CRLSelector.toString()
返回该 X509CRLSelector 的可打印表示形式。

String

X509CertSelector.toString()
返回该 CertSelector 的可打印表示形式。

String

CertPath.toString()
返回此证书路径的字符串表示形式。

abstract  String

Certificate.toString()
返回此证书的字符串表示形式。

返回变量类型为 String 的类型的 java.security.cert 中的方法

Iterator<String>

CertificateFactorySpi.engineGetCertPathEncodings()
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。

Iterator<String>

CertificateFactory.getCertPathEncodings()
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。

Set<String>

X509Extension.getCriticalExtensionOIDs()
获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。

abstract  Iterator<String>

CertPath.getEncodings()
返回此证书路径支持的编码的迭代，默认编码方式优先。

Set<String>

PolicyNode.getExpectedPolicies()
返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。

Set<String>

X509CertSelector.getExtendedKeyUsage()
返回 extendedKeyUsage 标准。

List<String>

X509Certificate.getExtendedKeyUsage()
获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。

Set<String>

PKIXParameters.getInitialPolicies()
返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。

Set<String>

X509Extension.getNonCriticalExtensionOIDs()
获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。

Set<String>

X509CertSelector.getPolicy()
返回策略标准。

abstract  Set<String>

PKIXCertPathChecker.getSupportedExtensions()
返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。

参数类型为 String 的 java.security.cert 中的方法

void

X509CRLSelector.addIssuerName(String name)
已过时，使用 X509CRLSelector.addIssuer(X500Principal) 或 X509CRLSelector.addIssuerName(byte[]) 替代。

void

X509CertSelector.addPathToName(int type, String name)
向 pathToNames 标准中添加一个名称。

void

X509CertSelector.addSubjectAlternativeName(int type, String name)
向 subjectAlternativeNames 标准中添加一个名称。

CertPath

CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding)
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。

CertPath

CertificateFactory.generateCertPath(InputStream inStream, String encoding)
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。

abstract  byte[]

CertPath.getEncoded(String encoding)
返回此证书路径的编码形式，使用指定的编码。

byte[]

X509Extension.getExtensionValue(String oid)
获取扩展值 (extnValue) 的 DER 编码 OCTET 字符串，该扩展值由传入的 oid String 标识。

static CertPathBuilder

CertPathBuilder.getInstance(String algorithm)
返回实现了指定算法的 CertPathBuilder 对象。

static CertPathValidator

CertPathValidator.getInstance(String algorithm)
返回实现了指定算法的 CertPathValidator 对象。

static CertificateFactory

CertificateFactory.getInstance(String type)
返回实现指定证书类型的 CertificateFactory 对象。

static CertStore

CertStore.getInstance(String type, CertStoreParameters params)
返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。

static CertStore

CertStore.getInstance(String type, CertStoreParameters params, Provider provider)
返回一个实现指定 CertStore 类型的 CertStore 对象。

static CertStore

CertStore.getInstance(String type, CertStoreParameters params, String provider)
返回一个实现指定 CertStore 类型的 CertStore 对象。

static CertPathBuilder

CertPathBuilder.getInstance(String algorithm, Provider provider)
返回实现了指定算法的 CertPathBuilder 对象。

static CertPathValidator

CertPathValidator.getInstance(String algorithm, Provider provider)
返回实现指定算法的 CertPathValidator 对象。

static CertificateFactory

CertificateFactory.getInstance(String type, Provider provider)
返回指定证书类型的 CertificateFactory 对象。

static CertPathBuilder

CertPathBuilder.getInstance(String algorithm, String provider)
返回实现了指定算法的 CertPathBuilder 对象。

static CertPathValidator

CertPathValidator.getInstance(String algorithm, String provider)
返回实现指定算法的 CertPathValidator 对象。

static CertificateFactory

CertificateFactory.getInstance(String type, String provider)
返回指定证书类型的 CertificateFactory 对象。

void

X509CertSelector.setIssuer(String issuerDN)
已过时，使用 X509CertSelector.setIssuer(X500Principal) 或 X509CertSelector.setIssuer(byte[]) 替代。

void

PKIXParameters.setSigProvider(String sigProvider)
设置签名提供者的名称。

void

X509CertSelector.setSubject(String subjectDN)
已过时，使用 X509CertSelector.setSubject(X500Principal) 或 X509CertSelector.setSubject(byte[]) 替代。

void

X509CertSelector.setSubjectPublicKeyAlgID(String oid)
设置 subjectPublicKeyAlgID 标准。

abstract  void

X509CRL.verify(PublicKey key, String sigProvider)
验证是否已使用与给定公钥相应的私钥签署了此 CRL。

abstract  void

Certificate.verify(PublicKey key, String sigProvider)
验证是否已使用与指定公钥相应的私钥签署了此证书。

类型变量类型为 String 的 java.security.cert 中的方法参数

abstract  void

PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts)
使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。

void

X509CertSelector.setExtendedKeyUsage(Set<String> keyPurposeSet)
设置 extendedKeyUsage 标准。

void

PKIXParameters.setInitialPolicies(Set<String> initialPolicies)
设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。

void

X509CertSelector.setPolicy(Set<String> certPolicySet)
设置策略限制。

参数类型为 String 的 java.security.cert 中的构造方法

Certificate.CertificateRep(String type, byte[] data)
构造带有 Certificate 类型和 Certificate 编码字节的替代 Certificate 类。

Certificate(String type)
创建指定类型的证书。

CertificateEncodingException(String message)
构造带指定详细消息的 CertificateEncodingException。

CertificateEncodingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateEncodingException。

CertificateException(String msg)
构造带给定详细消息的 Certificate 异常。

CertificateException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateException。

CertificateExpiredException(String message)
构造带指定详细消息的 CertificateExpiredException。

CertificateFactory(CertificateFactorySpi certFacSpi, Provider provider, String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。

CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。

CertificateParsingException(String message)
构造带指定详细消息的 CertificateParsingException。

CertificateParsingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateParsingException。

CertPath.CertPathRep(String type, byte[] data)
创建具有指定证书路径类型和编码形式的 CertPathRep。

CertPath(String type)
创建指定类型的 CertPath。

CertPathBuilder(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。

CertPathBuilderException(String msg)
创建带给定详细消息的 CertPathBuilderException。

CertPathBuilderException(String msg, Throwable cause)
创建带指定详细消息和原因的 CertPathBuilderException。

CertPathValidator(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。

CertPathValidatorException(String msg)
创建带给定详细消息的 CertPathValidatorException。

CertPathValidatorException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertPathValidatorException。

CertPathValidatorException(String msg, Throwable cause, CertPath certPath, int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。

CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。

CertStoreException(String msg)
创建带指定详细消息的 CertStoreException。

CertStoreException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertStoreException。

CRL(String type)
创建指定类型的 CRL。

CRLException(String message)
构造带指定详细消息的 CRLException。

CRLException(String message, Throwable cause)
创建带指定详细消息和 cause 的 CRLException。

LDAPCertStoreParameters(String serverName)
创建具有指定服务器名称和默认端口 389 的 LDAPCertStoreParameters 的实例。

LDAPCertStoreParameters(String serverName, int port)
创建具有指定参数值的 LDAPCertStoreParameters 的实例。

TrustAnchor(String caName, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。

java.security.spec 中 String 的使用

返回 String 的 java.security.spec 中的方法

String

MGF1ParameterSpec.getDigestAlgorithm()
返回掩码生成函数使用的消息摘要的算法名称。

String

PSSParameterSpec.getDigestAlgorithm()
返回消息摘要算法名称。

String

PKCS8EncodedKeySpec.getFormat()
返回与此密钥规范关联的编码格式的名称。

String

X509EncodedKeySpec.getFormat()
返回与此密钥规范关联的编码格式的名称。

abstract  String

EncodedKeySpec.getFormat()
返回与此密钥规范关联的编码格式的名称。

String

PSSParameterSpec.getMGFAlgorithm()
返回掩码生成函数算法名称。

String

ECGenParameterSpec.getName()
返回要生成的 EC 域参数的标准名称或预定义名称。

参数类型为 String 的 java.security.spec 中的构造方法

ECGenParameterSpec(String stdName)
使用标准的（或预定义的）名称 stdName 创建用于 EC 参数生成的参数规范，以便生成相应的（预计算的）椭圆曲线域参数。

InvalidKeySpecException(String msg)
构造带指定详细消息的 InvalidKeySpecException。

InvalidKeySpecException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 InvalidKeySpecException。

InvalidParameterSpecException(String msg)
构造带指定详细消息的 InvalidParameterSpecException。

MGF1ParameterSpec(String mdName)
构造如 PKCS #1 标准中所定义的掩码生成函数 MGF1 的参数集。

PSSParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。

java.sql 中 String 的使用

声明为 String 的 java.sql 中的字段

String[]

DriverPropertyInfo.choices
如果可以从特定一组值中选择 DriverPropertyInfo.value 字段的值，则返回可能值组成的数组；否则返回 null。

String

DriverPropertyInfo.description
属性的简要描述，可能为 null。

String

DriverPropertyInfo.name
属性的名称。

String

DriverPropertyInfo.value
value 字段通过综合为 getPropertyInfo 方法提供的信息、Java 环境和驱动程序提供的默认值来指定当前属性值。

返回 String 的 java.sql 中的方法

String

Array.getBaseTypeName()
在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。

String

Ref.getBaseTypeName()
获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。

String

Connection.getCatalog()
获取此 Connection 对象的当前目录名称。

String

ResultSetMetaData.getCatalogName(int column)
获取指定列的表目录名称。

String

DatabaseMetaData.getCatalogSeparator()
获取此数据库用作类别和表名之间的分隔符的 String。

String

DatabaseMetaData.getCatalogTerm()
获取数据库供应商用于 "catalog" 的首选术语。

String

Connection.getClientInfo(String name)
返回通过名称指定的客户端信息属性的值。

String

ResultSetMetaData.getColumnClassName(int column)
如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。

String

ResultSetMetaData.getColumnLabel(int column)
获取用于打印输出和显示的指定列的建议标题。

String

ResultSetMetaData.getColumnName(int column)
获取指定列的名称。

String

ResultSetMetaData.getColumnTypeName(int column)
获取指定列的数据库特定的类型名称。

String

ResultSet.getCursorName()
获取此 ResultSet 对象使用的 SQL 光标的名称。

String

DatabaseMetaData.getDatabaseProductName()
获取此数据库产品的名称。

String

DatabaseMetaData.getDatabaseProductVersion()
获取此数据库产品的版本号。

String

DatabaseMetaData.getDriverName()
获取此 JDBC 驱动程序的名称。

String

DatabaseMetaData.getDriverVersion()
获取此 JDBC 驱动程序的 String 形式的版本号。

String

DatabaseMetaData.getExtraNameCharacters()
获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。

String

DatabaseMetaData.getIdentifierQuoteString()
获取用于引用 SQL 标识符的字符串。

String

CallableStatement.getNString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

String

ResultSet.getNString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getNString(String parameterName)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

String

ResultSet.getNString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

DatabaseMetaData.getNumericFunctions()
获取可用于此数据库的数学函数的逗号分隔列表。

String

ParameterMetaData.getParameterClassName(int param)
获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。

String

ParameterMetaData.getParameterTypeName(int param)
获取指定参数的特定于数据库的类型名称。

String

DatabaseMetaData.getProcedureTerm()
获取数据库供应商用于 "procedure" 的首选术语。

String

Savepoint.getSavepointName()
获取此 Savepoint 对象表示的保存点的名称。

String

ResultSetMetaData.getSchemaName(int column)
获取指定列的表模式。

String

DatabaseMetaData.getSchemaTerm()
获取数据库供应商用于 "schema" 的首选术语。

String

DatabaseMetaData.getSearchStringEscape()
获取可用于转义通配符的字符串。

String

DatabaseMetaData.getSQLKeywords()
获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。

String

SQLException.getSQLState()
获取此 SQLException 对象的 SQLState。

String

SQLData.getSQLTypeName()
返回此对象表示的 SQL 用户定义类型的完全限定名。

String

Struct.getSQLTypeName()
获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。

String

SQLXML.getString()
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。

String

CallableStatement.getString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

String

ResultSet.getString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getString(String parameterName)
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

String

ResultSet.getString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

String

DatabaseMetaData.getStringFunctions()
获取可用于此数据库的字符串函数的逗号分隔列表。

String

Clob.getSubString(long pos, int length)
获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。

String

DatabaseMetaData.getSystemFunctions()
获取可用于此数据库的系统函数的逗号分隔列表。

String

ResultSetMetaData.getTableName(int column)
获取指定列的名称。

String

DatabaseMetaData.getTimeDateFunctions()
获取可用于此数据库的时间和日期函数的逗号分隔列表。

String

DatabaseMetaData.getURL()
获取此 DBMS 的 URL。

String

DatabaseMetaData.getUserName()
获取此数据库的已知的用户名称。

String

Connection.nativeSQL(String sql)
将给定的 SQL 语句转换成系统本机 SQL 语法。

String

SQLInput.readNString()
读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。

String

SQLInput.readString()
读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。

String

Date.toString()
格式化日期转义形式 yyyy-mm-dd 的日期。

String

RowId.toString()
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 String。

String

Time.toString()
使用 JDBC 时间转义格式对时间进行格式化。

String

Timestamp.toString()
使用 JDBC 时间戳转义格式编排时间戳。

返回变量类型为 String 的类型的 java.sql 中的方法

Map<String,ClientInfoStatus>

SQLClientInfoException.getFailedProperties()
返回无法设置的客户端信息属性列表。

Map<String,Class<?>>

Connection.getTypeMap()
获取与此 Connection 对象关联的 Map 对象。

参数类型为 String 的 java.sql 中的方法

boolean

Driver.acceptsURL(String url)
查询驱动程序是否认为它可以打开到给定 URL 的连接。

void

Statement.addBatch(String sql)
将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。

Connection

Driver.connect(String url, Properties info)
试图创建一个到给定 URL 的数据库连接。

Array

Connection.createArrayOf(String typeName, Object[] elements)
创建 Array 对象的工厂方法。

Struct

Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。

boolean

Statement.execute(String sql)
执行给定的 SQL 语句，该语句可能返回多个结果。

boolean

Statement.execute(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。

boolean

Statement.execute(String sql, int[] columnIndexes)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

boolean

Statement.execute(String sql, String[] columnNames)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

boolean

Statement.execute(String sql, String[] columnNames)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

ResultSet

Statement.executeQuery(String sql)
执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。

int

Statement.executeUpdate(String sql)
执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。

int

Statement.executeUpdate(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。

int

Statement.executeUpdate(String sql, int[] columnIndexes)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

int

Statement.executeUpdate(String sql, String[] columnNames)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

int

Statement.executeUpdate(String sql, String[] columnNames)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。

int

ResultSet.findColumn(String columnLabel)
将给定的 ResultSet 列标签映射到其 ResultSet 列索引。

Array

CallableStatement.getArray(String parameterName)
以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。

Array

ResultSet.getArray(String columnLabel)
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

InputStream

ResultSet.getAsciiStream(String columnLabel)
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getAttributes(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)
获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。

ResultSet

DatabaseMetaData.getBestRowIdentifier(String catalog, String schema, String table, int scope, boolean nullable)
获取唯一标识行的表的最佳列集合的描述。

BigDecimal

CallableStatement.getBigDecimal(String parameterName)
以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。

BigDecimal

ResultSet.getBigDecimal(String columnLabel)
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。

BigDecimal

ResultSet.getBigDecimal(String columnLabel, int scale)
已过时。

InputStream

ResultSet.getBinaryStream(String columnLabel)
以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。

Blob

CallableStatement.getBlob(String parameterName)
以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。

Blob

ResultSet.getBlob(String columnLabel)
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

boolean

CallableStatement.getBoolean(String parameterName)
以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。

boolean

ResultSet.getBoolean(String columnLabel)
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。

byte

CallableStatement.getByte(String parameterName)
以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。

byte

ResultSet.getByte(String columnLabel)
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。

byte[]

CallableStatement.getBytes(String parameterName)
以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。

byte[]

ResultSet.getBytes(String columnLabel)
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。

Reader

CallableStatement.getCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。

Reader

ResultSet.getCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

String

Connection.getClientInfo(String name)
返回通过名称指定的客户端信息属性的值。

Clob

CallableStatement.getClob(String parameterName)
以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。

Clob

ResultSet.getClob(String columnLabel)
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getColumnPrivileges(String catalog, String schema, String table, String columnNamePattern)
获取用于表列的访问权的描述。

ResultSet

DatabaseMetaData.getColumns(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
获取可在指定类别中使用的表列的描述。

static Connection

DriverManager.getConnection(String url)
试图建立到给定数据库 URL 的连接。

static Connection

DriverManager.getConnection(String url, Properties info)
试图建立到给定数据库 URL 的连接。

static Connection

DriverManager.getConnection(String url, String user, String password)
试图建立到给定数据库 URL 的连接。

ResultSet

DatabaseMetaData.getCrossReference(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)
获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。

Date

CallableStatement.getDate(String parameterName)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。

Date

ResultSet.getDate(String columnLabel)
以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Date

CallableStatement.getDate(String parameterName, Calendar cal)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。

Date

ResultSet.getDate(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

double

CallableStatement.getDouble(String parameterName)
以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。

double

ResultSet.getDouble(String columnLabel)
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。

static Driver

DriverManager.getDriver(String url)
试图查找能理解给定 URL 的驱动程序。

ResultSet

DatabaseMetaData.getExportedKeys(String catalog, String schema, String table)
获取引用给定表的主键列（表导入的外键）的外键列的描述。

float

CallableStatement.getFloat(String parameterName)
以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。

float

ResultSet.getFloat(String columnLabel)
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getFunctionColumns(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)
获取给定类别的系统或用户函数参数和返回类型的描述。

ResultSet

DatabaseMetaData.getFunctions(String catalog, String schemaPattern, String functionNamePattern)
获取给定类别中可用的系统和用户函数的描述。

ResultSet

DatabaseMetaData.getImportedKeys(String catalog, String schema, String table)
获取由给定表的外键列（表导入的主键）引用的主键列的描述。

ResultSet

DatabaseMetaData.getIndexInfo(String catalog, String schema, String table, boolean unique, boolean approximate)
获取给定表的索引和统计信息的描述。

int

CallableStatement.getInt(String parameterName)
以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。

int

ResultSet.getInt(String columnLabel)
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。

long

CallableStatement.getLong(String parameterName)
以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。

long

ResultSet.getLong(String columnLabel)
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。

Reader

CallableStatement.getNCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。

Reader

ResultSet.getNCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

NClob

CallableStatement.getNClob(String parameterName)
以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。

NClob

ResultSet.getNClob(String columnLabel)
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getNString(String parameterName)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

String

ResultSet.getNString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(String parameterName)
以 Java 编程语言中 Object 的形式获取参数的值。

Object

ResultSet.getObject(String columnLabel)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getPrimaryKeys(String catalog, String schema, String table)
获取对给定表的主键列的描述。

ResultSet

DatabaseMetaData.getProcedureColumns(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)
获取给定类别的存储过程参数和结果列的描述。

ResultSet

DatabaseMetaData.getProcedures(String catalog, String schemaPattern, String procedureNamePattern)
获取可在给定类别中使用的存储过程的描述。

DriverPropertyInfo[]

Driver.getPropertyInfo(String url, Properties info)
获得此驱动程序的可能属性信息。

Ref

CallableStatement.getRef(String parameterName)
以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。

Ref

ResultSet.getRef(String columnLabel)
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

RowId

CallableStatement.getRowId(String parameterName)
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。

RowId

ResultSet.getRowId(String columnLabel)
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getSchemas(String catalog, String schemaPattern)
获取此数据库中可用的模式名称。

short

CallableStatement.getShort(String parameterName)
以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。

short

ResultSet.getShort(String columnLabel)
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。

SQLXML

CallableStatement.getSQLXML(String parameterName)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。

SQLXML

ResultSet.getSQLXML(String columnLabel)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

String

CallableStatement.getString(String parameterName)
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

String

ResultSet.getString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getSuperTables(String catalog, String schemaPattern, String tableNamePattern)
获取在此数据库的特定模式中定义的表分层结构的描述。

ResultSet

DatabaseMetaData.getSuperTypes(String catalog, String schemaPattern, String typeNamePattern)
获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。

ResultSet

DatabaseMetaData.getTablePrivileges(String catalog, String schemaPattern, String tableNamePattern)
获取可在类别中使用的每个表的访问权的描述。

ResultSet

DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types)
获取可在给定类别中使用的表的描述。

ResultSet

DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types)
获取可在给定类别中使用的表的描述。

Time

CallableStatement.getTime(String parameterName)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。

Time

ResultSet.getTime(String columnLabel)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Time

CallableStatement.getTime(String parameterName, Calendar cal)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。

Time

ResultSet.getTime(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Timestamp

CallableStatement.getTimestamp(String parameterName)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。

Timestamp

ResultSet.getTimestamp(String columnLabel)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

Timestamp

CallableStatement.getTimestamp(String parameterName, Calendar cal)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。

Timestamp

ResultSet.getTimestamp(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getUDTs(String catalog, String schemaPattern, String typeNamePattern, int[] types)
获取在特定模式中定义的用户定义类型 (UDT) 的描述。

InputStream

ResultSet.getUnicodeStream(String columnLabel)
已过时。 使用 getCharacterStream 代替

URL

CallableStatement.getURL(String parameterName)
以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。

URL

ResultSet.getURL(String columnLabel)
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

DatabaseMetaData.getVersionColumns(String catalog, String schema, String table)
获取在更新行中的任意值时自动更新的表列的描述。

String

Connection.nativeSQL(String sql)
将给定的 SQL 语句转换成系统本机 SQL 语法。

long

Clob.position(String searchstr, long start)
获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。

CallableStatement

Connection.prepareCall(String sql)
创建一个 CallableStatement 对象来调用数据库存储过程。

CallableStatement

Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

CallableStatement

Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

PreparedStatement

Connection.prepareStatement(String sql)
创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。

PreparedStatement

Connection.prepareStatement(String sql, int autoGeneratedKeys)
创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。

PreparedStatement

Connection.prepareStatement(String sql, int[] columnIndexes)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

PreparedStatement

Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

PreparedStatement

Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。

PreparedStatement

Connection.prepareStatement(String sql, String[] columnNames)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

PreparedStatement

Connection.prepareStatement(String sql, String[] columnNames)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

static void

DriverManager.println(String message)
将一条消息打印到当前 JDBC 日志流中。

void

SQLData.readSQL(SQLInput stream, String typeName)
用从数据库读取的数据填充此对象。

void

CallableStatement.registerOutParameter(int parameterIndex, int sqlType, String typeName)
注册指定的输出参数。

void

CallableStatement.registerOutParameter(String parameterName, int sqlType)
将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。

void

CallableStatement.registerOutParameter(String parameterName, int sqlType, int scale)
将名为 parameterName 的参数注册为 JDBC 类型 sqlType。

void

CallableStatement.registerOutParameter(String parameterName, int sqlType, String typeName)
注册指定的输出参数。

void

CallableStatement.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

CallableStatement.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。

void

CallableStatement.setAsciiStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。

void

CallableStatement.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定 java.math.BigDecimal 值。

void

CallableStatement.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

CallableStatement.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。

void

CallableStatement.setBinaryStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。

void

CallableStatement.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。

void

CallableStatement.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。

void

CallableStatement.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。

void

CallableStatement.setBoolean(String parameterName, boolean x)
将指定参数设置为给定 Java boolean 值。

void

CallableStatement.setByte(String parameterName, byte x)
将指定参数设置为给定 Java byte 值。

void

CallableStatement.setBytes(String parameterName, byte[] x)
将指定参数设置为给定 Java byte 数组。

void

Connection.setCatalog(String catalog)
设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。

void

CallableStatement.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。

void

CallableStatement.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。

void

CallableStatement.setCharacterStream(String parameterName, Reader reader, long length)
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。

void

Connection.setClientInfo(String name, String value)
将 name 指定的客户端信息属性的值设置为 value 指定的值。

void

CallableStatement.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。

void

CallableStatement.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

CallableStatement.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

Statement.setCursorName(String name)
将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。

void

CallableStatement.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。

void

CallableStatement.setDate(String parameterName, Date x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。

void

CallableStatement.setDouble(String parameterName, double x)
将指定参数设置为给定 Java double 值。

void

CallableStatement.setFloat(String parameterName, float x)
将指定参数设置为给定 Java float 值。

void

CallableStatement.setInt(String parameterName, int x)
将指定参数设置为给定 Java int 值。

void

CallableStatement.setLong(String parameterName, long x)
将指定参数设置为给定 Java long 值。

void

CallableStatement.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。

void

CallableStatement.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。

void

CallableStatement.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。

void

CallableStatement.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

CallableStatement.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

PreparedStatement.setNString(int parameterIndex, String value)
将指定参数设置为给定 String 对象。

void

CallableStatement.setNString(String parameterName, String value)
将指定参数设置为给定 String 对象。

void

PreparedStatement.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

CallableStatement.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。

void

CallableStatement.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

CallableStatement.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

CallableStatement.setRowId(String parameterName, RowId x)
将指定参数设置为给定 java.sql.RowId 对象。

Savepoint

Connection.setSavepoint(String name)
在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。

void

CallableStatement.setShort(String parameterName, short x)
将指定参数设置为给定 Java short 值。

void

CallableStatement.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。

void

PreparedStatement.setString(int parameterIndex, String x)
将指定参数设置为给定 Java String 值。

int

Clob.setString(long pos, String str)
在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。

int

Clob.setString(long pos, String str, int offset, int len)
将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。

void

SQLXML.setString(String value)
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。

void

CallableStatement.setString(String parameterName, String x)
将指定参数设置为给定 Java String 值。

void

CallableStatement.setTime(String parameterName, Time x)
将指定参数设置为给定 java.sql.Time 值。

void

CallableStatement.setTime(String parameterName, Time x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。

void

CallableStatement.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定 java.sql.Timestamp 值。

void

CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。

void

CallableStatement.setURL(String parameterName, URL val)
将指定参数设置为给定 java.net.URL 对象。

void

ResultSet.updateArray(String columnLabel, Array x)
用 java.sql.Array 值更新指定列。

void

ResultSet.updateAsciiStream(String columnLabel, InputStream x)
用 ascii 流值更新指定列。

void

ResultSet.updateAsciiStream(String columnLabel, InputStream x, int length)
用 ascii 流值更新指定列，该列具有指定的字节数。

void

ResultSet.updateAsciiStream(String columnLabel, InputStream x, long length)
用 ascii 流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateBigDecimal(String columnLabel, BigDecimal x)
用 java.sql.BigDecimal 值更新指定列。

void

ResultSet.updateBinaryStream(String columnLabel, InputStream x)
用二进制流值更新指定列。

void

ResultSet.updateBinaryStream(String columnLabel, InputStream x, int length)
用二进制流值更新指定列，该列具有指定的字节数。

void

ResultSet.updateBinaryStream(String columnLabel, InputStream x, long length)
用二进制流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateBlob(String columnLabel, Blob x)
用 java.sql.Blob 值更新指定列。

void

ResultSet.updateBlob(String columnLabel, InputStream inputStream)
使用给定输入流值更新指定列。

void

ResultSet.updateBlob(String columnLabel, InputStream inputStream, long length)
使用给定输入流更新指定列，该流将具有指定的字节数。

void

ResultSet.updateBoolean(String columnLabel, boolean x)
用 boolean 值更新指定列。

void

ResultSet.updateByte(String columnLabel, byte x)
用 byte 值更新指定列。

void

ResultSet.updateBytes(String columnLabel, byte[] x)
用字节数组值更新指定列。

void

ResultSet.updateCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定列。

void

ResultSet.updateCharacterStream(String columnLabel, Reader reader, int length)
用字符流值更新指定列，该列具有指定的字节数。

void

ResultSet.updateCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateClob(String columnLabel, Clob x)
用 java.sql.Clob 值更新指定列。

void

ResultSet.updateClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。

void

ResultSet.updateClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。

void

ResultSet.updateDate(String columnLabel, Date x)
用 java.sql.Date 值更新指定列。

void

ResultSet.updateDouble(String columnLabel, double x)
用 double 值更新指定列。

void

ResultSet.updateFloat(String columnLabel, float x)
用 float 值更新指定列。

void

ResultSet.updateInt(String columnLabel, int x)
用 int 值更新指定列。

void

ResultSet.updateLong(String columnLabel, long x)
用 long 值更新指定列。

void

ResultSet.updateNCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定的列。

void

ResultSet.updateNCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。

void

ResultSet.updateNClob(String columnLabel, NClob nClob)
用 java.sql.NClob 值更新指定的列。

void

ResultSet.updateNClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。

void

ResultSet.updateNClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。

void

ResultSet.updateNString(int columnIndex, String nString)
用 String 值更新指定的列。

void

ResultSet.updateNString(String columnLabel, String nString)
用 String 值更新指定的列。

void

ResultSet.updateNull(String columnLabel)
用 null 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x)
用 Object 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x, int scaleOrLength)
用 Object 值更新指定列。

void

ResultSet.updateRef(String columnLabel, Ref x)
用 java.sql.Ref 值更新指定列。

void

ResultSet.updateRowId(String columnLabel, RowId x)
用 RowId 值更新指定的列。

void

ResultSet.updateShort(String columnLabel, short x)
用 short 值更新指定列。

void

ResultSet.updateSQLXML(String columnLabel, SQLXML xmlObject)
用 java.sql.SQLXML 值更新指定的列。

void

ResultSet.updateString(int columnIndex, String x)
用 String 值更新指定列。

void

ResultSet.updateString(String columnLabel, String x)
用 String 值更新指定列。

void

ResultSet.updateTime(String columnLabel, Time x)
用 java.sql.Time 值更新指定列。

void

ResultSet.updateTimestamp(String columnLabel, Timestamp x)
用 java.sql.Timestamp 值更新指定列。

static ClientInfoStatus

ClientInfoStatus.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Date

Date.valueOf(String s)
将 JDBC 日期转义形式的字符串转换成 Date 值。

static RowIdLifetime

RowIdLifetime.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Time

Time.valueOf(String s)
将使用 JDBC 时间转义格式的字符串转换为 Time 值。

static Timestamp

Timestamp.valueOf(String s)
将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。

void

SQLOutput.writeNString(String x)
将下一个属性以 Java 编程语言中 String 的形式写入流中。

void

SQLOutput.writeString(String x)
将下一个属性作为 Java 编程语言中的 String 写入流中。

类型变量类型为 String 的 java.sql 中的方法参数

Object

Array.getArray(long index, int count, Map<String,Class<?>> map)
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。

Object

Array.getArray(Map<String,Class<?>> map)
获取由此 Array 对象指定的 SQL ARRAY 值的内容。

Object[]

Struct.getAttributes(Map<String,Class<?>> map)
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。

Object

CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(int columnIndex, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

Ref.getObject(Map<String,Class<?>> map)
获取引用对象并使用给定类型映射表将其映射到 Java 类型。

Object

CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

ResultSet

Array.getResultSet(long index, int count, Map<String,Class<?>> map)
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。

ResultSet

Array.getResultSet(Map<String,Class<?>> map)
获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。

void

Connection.setTypeMap(Map<String,Class<?>> map)
将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。

参数类型为 String 的 java.sql 中的构造方法

BatchUpdateException(String reason, int[] updateCounts)
构造一个使用给定 reason 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int[] updateCounts)
构造一个使用给定 reason、SQLState 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts)
构造一个使用给定 reason、SQLState、vendorCode 和 updateCounts 初始化的 BatchUpdateException 对象。

BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。

DriverPropertyInfo(String name, String value)
构造一个带有给定名称和值的 DriverPropertyInfo 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLDataException(String reason)
构造一个带有给定 reason 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。

SQLDataException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。

SQLDataException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。

SQLException(String reason)
构造一个具有给定 reason 的 SQLException 对象。

SQLException(String reason, String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLException 对象。

SQLException(String reason, String SQLState, int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLException 对象。

SQLException(String reason, String sqlState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。

SQLException(String reason, String sqlState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。

SQLException(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLException 对象。

SQLFeatureNotSupportedException(String reason)
构造一个带有给定 reason 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。

SQLFeatureNotSupportedException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。

SQLIntegrityConstraintViolationException(String reason)
构造一个带有给定 reason 的 SQLIntegrityConstraintViolationException。

SQLIntegrityConstraintViolationException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。

SQLIntegrityConstraintViolationException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。

SQLInvalidAuthorizationSpecException(String reason)
构造一个带有给定 reason 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。

SQLInvalidAuthorizationSpecException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。

SQLNonTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。

SQLNonTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。

SQLNonTransientException(String reason)
构造一个带有给定 reason 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。

SQLNonTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。

SQLPermission(String name)
创建具有指定名称的新 SQLPermission 对象。

SQLPermission(String name, String actions)
创建具有指定名称的新 SQLPermission 对象。

SQLRecoverableException(String reason)
构造一个带有给定 reason 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。

SQLRecoverableException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。

SQLSyntaxErrorException(String reason)
构造一个带有给定 reason 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。

SQLSyntaxErrorException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。

SQLTimeoutException(String reason)
构造一个带有给定 reason 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。

SQLTimeoutException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。

SQLTransactionRollbackException(String reason)
构造一个带有给定 reason 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。

SQLTransactionRollbackException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。

SQLTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。

SQLTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。

SQLTransientException(String reason)
构造一个带有给定 reason 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。

SQLTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。

SQLTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。

SQLWarning(String reason)
构造一个具有给定 reason 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState, int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。

SQLWarning(String reason, String SQLState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。

SQLWarning(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。

类型变量类型为 String 的 java.sql 中的构造方法参数

SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。

SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

java.text 中 String 的使用

返回 String 的 java.text 中的方法

String

DateFormat.format(Date date)
将一个 Date 格式化为日期/时间字符串。

String

NumberFormat.format(double number)
格式规范。

String

NumberFormat.format(long number)
格式规范。

String

Format.format(Object obj)
格式化一个对象以生成一个字符串。

static String

MessageFormat.format(String pattern, Object... arguments)
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。

String[]

DateFormatSymbols.getAmPmStrings()
获取 ampm 字符串。

String

DecimalFormatSymbols.getCurrencySymbol()
返回这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。

String[]

DateFormatSymbols.getEras()
获取年代字符串。

String

DecimalFormatSymbols.getExponentSeparator()
返回用于分隔尾数和指数的字符串。

String

DecimalFormatSymbols.getInfinity()
获得用于表示无穷大的字符串。

String

DecimalFormatSymbols.getInternationalCurrencySymbol()
返回这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。

String

DateFormatSymbols.getLocalPatternChars()
获取本地化的日期-时间模式字符。

String[]

DateFormatSymbols.getMonths()
获取月份字符串。

protected  String

AttributedCharacterIterator.Attribute.getName()
返回此属性的名称。

String

DecimalFormatSymbols.getNaN()
获得用于表示“非数字”的字符串。

String

DecimalFormat.getNegativePrefix()
获取负数前缀。

String

DecimalFormat.getNegativeSuffix()
获取负数后缀。

String

DecimalFormat.getPositivePrefix()
获取正数前缀。

String

DecimalFormat.getPositiveSuffix()
获取正数后缀。

String

RuleBasedCollator.getRules()
获取 collation 对象的基于表的规则。

String[]

DateFormatSymbols.getShortMonths()
获取简短形式的月份字符串。

String[]

DateFormatSymbols.getShortWeekdays()
获取简短形式的星期字符串。

String

CollationKey.getSourceString()
返回此 CollationKey 表示的 String。

String[]

DateFormatSymbols.getWeekdays()
获取星期字符串。

String[][]

DateFormatSymbols.getZoneStrings()
获取时区字符串。

static String

Normalizer.normalize(CharSequence src, Normalizer.Form form)
标准化 char 值序列。

String

DecimalFormat.toLocalizedPattern()
合成一个表示此 Format 对象当前状态的、已本地化的模式字符串。

String

SimpleDateFormat.toLocalizedPattern()
返回描述此日期格式的本地化模式字符串。

String

ChoiceFormat.toPattern()
获取模式。

String

DecimalFormat.toPattern()
合成一个表示此 Format 对象当前状态的模式字符串。

String

SimpleDateFormat.toPattern()
返回描述此日期格式的模式字符串。

String

MessageFormat.toPattern()
返回表示消息格式当前状态的模式。

String

Annotation.toString()
返回此 Annotation 的 String 表示形式。

String

AttributedCharacterIterator.Attribute.toString()
返回该对象的字符串表示形式。

String

Bidi.toString()
用于调试时显示双向算法的内部状态。

String

ParsePosition.toString()
返回此 ParsePosition 的字符串表示形式。

String

FieldPosition.toString()
返回此 FieldPosition 的字符串表示形式。

参数类型为 String 的 java.text 中的方法

void

DecimalFormat.applyLocalizedPattern(String pattern)
将给定的模式应用于此 Format 对象。

void

SimpleDateFormat.applyLocalizedPattern(String pattern)
将给定的本地化模式字符串应用于此日期格式。

void

ChoiceFormat.applyPattern(String newPattern)
设置模式。

void

DecimalFormat.applyPattern(String pattern)
将给定的模式应用于此 Format 对象。

void

SimpleDateFormat.applyPattern(String pattern)
将给定模式字符串应用于此日期格式。

void

MessageFormat.applyPattern(String pattern)
设置此消息格式所使用的模式。

int

RuleBasedCollator.compare(String source, String target)
根据表规则比较存储在两个不同字符串中的字符数据。

abstract  int

Collator.compare(String source, String target)
根据此 Collator 的整理规则来比较源字符串和目标字符串。

boolean

Collator.equals(String source, String target)
根据此 Collator 的整理规则比较两个字符串是否相等的便捷方法。

static String

MessageFormat.format(String pattern, Object... arguments)
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。

CollationElementIterator

RuleBasedCollator.getCollationElementIterator(String source)
返回给定 String 的 CollationElementIterator。

CollationKey

RuleBasedCollator.getCollationKey(String source)
将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。

abstract  CollationKey

Collator.getCollationKey(String source)
将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。

Number

NumberFormat.parse(String source)
解析给定字符串开头的文本，生成一个数值。

Date

DateFormat.parse(String source)
从给定字符串的开始解析文本，以生成一个日期。

Object[]

MessageFormat.parse(String source)
从给定字符串的开始位置解析文本，以生成一个对象数组。

Number

ChoiceFormat.parse(String text, ParsePosition status)
解析输入文本中的一个 Number。

Number

DecimalFormat.parse(String text, ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

abstract  Number

NumberFormat.parse(String source, ParsePosition parsePosition)
如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。

Date

SimpleDateFormat.parse(String text, ParsePosition pos)
解析字符串的文本，生成 Date。

abstract  Date

DateFormat.parse(String source, ParsePosition pos)
根据给定的解析位置开始解析日期/时间字符串。

Object[]

MessageFormat.parse(String source, ParsePosition pos)
解析字符串。

Object

Format.parseObject(String source)
从给定字符串的开始处解析文本以生成一个对象。

Object

NumberFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

Object

DateFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Date。

Object

MessageFormat.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象数组。

abstract  Object

Format.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象。

void

DateFormatSymbols.setAmPmStrings(String[] newAmpms)
设置 ampm 字符串。

void

ChoiceFormat.setChoices(double[] limits, String[] formats)
设置要在格式化中使用的 choice。

void

DecimalFormatSymbols.setCurrencySymbol(String currency)
设置这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。

void

DateFormatSymbols.setEras(String[] newEras)
设置年代字符串。

void

DecimalFormatSymbols.setExponentSeparator(String exp)
设置用于分隔尾数和指数的字符串。

void

DecimalFormatSymbols.setInfinity(String infinity)
设置用于表示无穷大的字符串。

void

DecimalFormatSymbols.setInternationalCurrencySymbol(String currencyCode)
设置这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。

void

DateFormatSymbols.setLocalPatternChars(String newLocalPatternChars)
设置本地化的日期-时间模式字符。

void

DateFormatSymbols.setMonths(String[] newMonths)
设置月份字符串。

void

DecimalFormatSymbols.setNaN(String NaN)
设置用于表示“非数字”的字符串。

void

DecimalFormat.setNegativePrefix(String newValue)
设置负数前缀。

void

DecimalFormat.setNegativeSuffix(String newValue)
设置负数后缀。

void

DecimalFormat.setPositivePrefix(String newValue)
设置正数前缀。

void

DecimalFormat.setPositiveSuffix(String newValue)
设置正数后缀。

void

DateFormatSymbols.setShortMonths(String[] newShortMonths)
设置简短形式的月份字符串。

void

DateFormatSymbols.setShortWeekdays(String[] newShortWeekdays)
设置简短形式的星期字符串。

void

BreakIterator.setText(String newText)
设置要被扫描的新文本字符串。

void

CollationElementIterator.setText(String source)
设置一个要迭代的新字符串。

void

StringCharacterIterator.setText(String text)
将此迭代器重置为指向一个新的字符串。

void

DateFormatSymbols.setWeekdays(String[] newWeekdays)
设置星期字符串。

void

DateFormatSymbols.setZoneStrings(String[][] newZoneStrings)
设置时区字符串。

static Normalizer.Form

Normalizer.Form.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.text 中的构造方法

AttributedCharacterIterator.Attribute(String name)
构造具有给定名称的 Attribute。

AttributedString(String text)
构造带给定文本的 AttributedString 实例。

AttributedString(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。

Bidi(String paragraph, int flags)
由给定的文本段和基本方向构造 Bidi。

ChoiceFormat(double[] limits, String[] formats)
根据 limit 和相应的 format 构造。

ChoiceFormat(String newPattern)
根据 limit 和相应的 format（基于模式）构造。

CollationKey(String source)
CollationKey 构造方法。

DateFormat.Field(String name, int calendarField)
创建一个 Field。

DecimalFormat(String pattern)
使用给定的模式和默认语言环境的符号创建一个 DecimalFormat。

DecimalFormat(String pattern, DecimalFormatSymbols symbols)
使用给定的模式和符号创建一个 DecimalFormat。

Format.Field(String name)
创建具有指定名称的 Field。

MessageFormat.Field(String name)
创建具有指定名称的 Field。

MessageFormat(String pattern)
构造默认语言环境和指定模式的 MessageFormat。

MessageFormat(String pattern, Locale locale)
构造指定语言环境和模式的 MessageFormat。

NumberFormat.Field(String name)
创建具有指定名称的 Field 实例。

ParseException(String s, int errorOffset)
构造带指定详细消息和偏移量的 ParseException。

RuleBasedCollator(String rules)
RuleBasedCollator 构造方法。

SimpleDateFormat(String pattern)
用给定的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。

SimpleDateFormat(String pattern, DateFormatSymbols formatSymbols)
用给定的模式和日期符号构造 SimpleDateFormat。

SimpleDateFormat(String pattern, Locale locale)
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。

StringCharacterIterator(String text)
构造初始索引为 0 的迭代器。

StringCharacterIterator(String text, int pos)
构造具有指定的初始索引的迭代器。

StringCharacterIterator(String text, int begin, int end, int pos)
构造对给定字符串的给定范围进行迭代的迭代器（其索引设置为指定位置）。

java.util 中 String 的使用

类型参数类型为 String 的 java.util 中的字段

static List<String>

ResourceBundle.Control.FORMAT_CLASS
包含 "java.class" 的纯类 (class-only) 格式 List。

static List<String>

ResourceBundle.Control.FORMAT_DEFAULT
默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。

static List<String>

ResourceBundle.Control.FORMAT_PROPERTIES
包含 "java.properties" 的纯属性 (properties-only) 格式 List。

返回 String 的 java.util 中的方法

static String

Arrays.deepToString(Object[] a)
返回指定数组“深层内容”的字符串表示形式。

String

Scanner.findInLine(Pattern pattern)
试图在忽略分隔符的情况下查找下一个指定模式。

String

Scanner.findInLine(String pattern)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

String

Scanner.findWithinHorizon(Pattern pattern, int horizon)
试图查找下一个指定模式。

String

Scanner.findWithinHorizon(String pattern, int horizon)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

String

PropertyPermission.getActions()
返回动作的“规范化字符串表示形式”。

static String[]

TimeZone.getAvailableIDs()
获取受支持的所有可用 ID。

static String[]

TimeZone.getAvailableIDs(int rawOffset)
根据给定的时区偏移量（以毫秒为单位）获取可用的 ID。

String

MissingResourceException.getClassName()
获得构造方法所传递的参数。

String

UnknownFormatConversionException.getConversion()
返回未知的转换。

String

Locale.getCountry()
返回此语言环境的国家/地区代码，将为空字符串或大写的 ISO 3166 两字母代码。

String

Currency.getCurrencyCode()
获取此货币的 ISO 4217 货币代码。

String

Locale.getDisplayCountry()
返回适合向用户显示的语言环境国家/地区名。

String

Locale.getDisplayCountry(Locale inLocale)
返回适合向用户显示的语言环境国家/地区名。

String

Locale.getDisplayLanguage()
返回适合向用户显示的语言环境语言名。

String

Locale.getDisplayLanguage(Locale inLocale)
返回适合向用户显示的语言环境语言名。

String

TimeZone.getDisplayName()
返回适合于展示给默认区域的用户的时区名称。

String

Locale.getDisplayName()
返回适合向用户显示的语言环境名。

String

TimeZone.getDisplayName(boolean daylight, int style)
返回适合于展示给默认区域的用户的时区名称。

String

TimeZone.getDisplayName(boolean daylight, int style, Locale locale)
返回适合于展示给指定区域的用户的时区名称。

String

Calendar.getDisplayName(int field, int style, Locale locale)
返回给定 style 和 locale 下的日历 field 值的字符串表示形式。

String

TimeZone.getDisplayName(Locale locale)
返回适合于展示给指定区域的用户的时区名称。

String

Locale.getDisplayName(Locale inLocale)
返回适合向用户显示的语言环境名。

String

Locale.getDisplayVariant()
返回适合向用户显示的语言环境变量代码名。

String

Locale.getDisplayVariant(Locale inLocale)
返回适合向用户显示的语言环境变量代码名。

String

DuplicateFormatFlagsException.getFlags()
返回包含重复标志的一组标志。

String

FormatFlagsConversionMismatchException.getFlags()
返回不兼容的标志。

String

IllegalFormatFlagsException.getFlags()
返回包含非法组合的标志的集合。

String

UnknownFormatFlagsException.getFlags()
返回包含未知标志的标志集。

String

MissingFormatArgumentException.getFormatSpecifier()
返回不匹配的格式说明符。

String

MissingFormatWidthException.getFormatSpecifier()
返回没有宽度的格式说明符。

String

TimeZone.getID()
获取此时区的 ID。

String

Locale.getISO3Country()
返回此语言环境国家/地区的三字母缩写。

String

Locale.getISO3Language()
返回此语言环境语言的三字母缩写。

static String[]

Locale.getISOCountries()
返回 ISO 3166 中所定义的所有两字母国家/地区代码。

static String[]

Locale.getISOLanguages()
返回 ISO 639 中所定义的所有两字母语言代码。

String

MissingResourceException.getKey()
获得构造方法所传递的参数。

String

Locale.getLanguage()
返回此语言环境的语言代码，可以是空字符串或小写的 ISO 639 代码。

String

DuplicateFormatFlagsException.getMessage()

String

FormatFlagsConversionMismatchException.getMessage()

String

IllegalFormatCodePointException.getMessage()

String

IllegalFormatConversionException.getMessage()

String

IllegalFormatFlagsException.getMessage()

String

IllegalFormatPrecisionException.getMessage()

String

IllegalFormatWidthException.getMessage()

String

MissingFormatArgumentException.getMessage()

String

MissingFormatWidthException.getMessage()

String

UnknownFormatConversionException.getMessage()

String

UnknownFormatFlagsException.getMessage()

String

Properties.getProperty(String key)
用指定的键在此属性列表中搜索属性。

String

Properties.getProperty(String key, String defaultValue)
用指定的键在属性列表中搜索属性。

String

ResourceBundle.getString(String key)
从此资源包或它的某个父包中获取给定键的字符串。

String[]

ResourceBundle.getStringArray(String key)
从此资源包或它的某个父包中获取给定键的字符串数组。

String

Currency.getSymbol()
获取默认语言环境的货币符号。

String

Currency.getSymbol(Locale locale)
获取指定语言环境的货币符号。

String

Locale.getVariant()
返回此语言环境的变量代码。

String

Scanner.next()
查找并返回来自此扫描器的下一个完整标记。

String

Scanner.next(Pattern pattern)
如果下一个标记与指定模式匹配，则返回下一个标记。

String

Scanner.next(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。

String

Scanner.nextLine()
此扫描器执行当前行，并返回跳过的输入信息。

String

StringTokenizer.nextToken()
返回此 string tokenizer 的下一个标记。

String

StringTokenizer.nextToken(String delim)
返回此 string tokenizer 的字符串中的下一个标记。

String

ResourceBundle.Control.toBundleName(String baseName, Locale locale)
将给定 baseName 和 locale 转换为包名称。

String

Date.toGMTString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。

String

Date.toLocaleString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。

String

ResourceBundle.Control.toResourceName(String bundleName, String suffix)
将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。

String

Formatter.toString()
返回对输出的目标文件调用 toString() 的结果。

String

Scanner.toString()
返回此 Scanner 的字符串表示形式。

String

ServiceLoader.toString()
返回一个描述此服务的字符串。

String

SimpleTimeZone.toString()
返回此时区的字符串表示形式。

String

UUID.toString()
返回表示此 UUID 的 String 对象。

String

Currency.toString()
返回此货币的 ISO 4217 货币代码。

String

Calendar.toString()
返回此日历的字符串表示形式。

String

Date.toString()
把此 Date 对象转换为以下形式的 String： dow mon dd hh:mm:ss zzz yyyy 其中： dow 是一周中的某一天 (Sun, Mon, Tue, Wed, Thu, Fri, Sat)。

String

EventObject.toString()
返回此 EventObject 的 String 表示形式。

String

Locale.toString()
使用由下划线分隔的语言、国家/地区和变量来获取整个语言环境的编程名称。

String

BitSet.toString()
返回此位 set 的字符串表示形式。

String

AbstractMap.toString()
返回此映射的字符串表示形式。

String

AbstractMap.SimpleEntry.toString()
返回此映射项的 String 表示形式。

String

AbstractMap.SimpleImmutableEntry.toString()
返回此映射项的 String 表示形式。

String

Vector.toString()
返回此向量的字符串表示形式，其中包含每个元素的 String 表示形式。

String

AbstractCollection.toString()
返回此 collection 的字符串表示形式。

String

Hashtable.toString()
返回此 Hashtable 对象的字符串表示形式，其形式为 ASCII 字符 ", " （逗号加空格）分隔开的、括在括号中的一组条目。

static String

Arrays.toString(boolean[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(byte[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(char[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(double[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(float[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(int[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(long[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(Object[] a)
返回指定数组内容的字符串表示形式。

static String

Arrays.toString(short[] a)
返回指定数组内容的字符串表示形式。

返回变量类型为 String 的类型的 java.util 中的方法

Map<String,Integer>

Calendar.getDisplayNames(int field, int style, Locale locale)
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。

List<String>

ResourceBundle.Control.getFormats(String baseName)
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。

Enumeration<String>

PropertyResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。

Enumeration<String>

ListResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。

abstract  Enumeration<String>

ResourceBundle.getKeys()
返回键的枚举。

protected  Set<String>

PropertyResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

protected  Set<String>

ListResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

protected  Set<String>

ResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

Set<String>

ResourceBundle.keySet()
返回此 ResourceBundle 及其父包中包含的所有键的 Set。

Set<String>

Properties.stringPropertyNames()
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。

参数类型为 String 的 java.util 中的方法

boolean

ResourceBundle.containsKey(String key)
确定给定 key 是否包含在此 ResourceBundle 及其父包中。

String

Scanner.findInLine(String pattern)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

String

Scanner.findWithinHorizon(String pattern, int horizon)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

Formatter

Formatter.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。

Formatter

Formatter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。

static UUID

UUID.fromString(String name)
根据 UUID.toString() 方法中描述的字符串标准表示形式创建 UUID。

static ResourceBundle

ResourceBundle.getBundle(String baseName)
使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale locale)
使用指定的基本名称、语言环境和调用者的类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader)
使用指定的基本名称、语言环境和类加载器获取资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control)
使用指定基本名称、目标语言环境、类加载器和控件返回资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control)
使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。

static ResourceBundle

ResourceBundle.getBundle(String baseName, ResourceBundle.Control control)
使用指定基本名称、默认语言环境和指定控件返回一个资源包。

List<Locale>

ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale)
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。

Locale

ResourceBundle.Control.getFallbackLocale(String baseName, Locale locale)
返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。

List<String>

ResourceBundle.Control.getFormats(String baseName)
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。

static Currency

Currency.getInstance(String currencyCode)
返回给定货币代码的 Currency 实例。

Object

ResourceBundle.getObject(String key)
从此资源包或它的某个父包中获取给定键的对象。

String

Properties.getProperty(String key)
用指定的键在此属性列表中搜索属性。

String

Properties.getProperty(String key, String defaultValue)
用指定的键在属性列表中搜索属性。

String

ResourceBundle.getString(String key)
从此资源包或它的某个父包中获取给定键的字符串。

String[]

ResourceBundle.getStringArray(String key)
从此资源包或它的某个父包中获取给定键的字符串数组。

long

ResourceBundle.Control.getTimeToLive(String baseName, Locale locale)
返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。

static TimeZone

TimeZone.getTimeZone(String ID)
获取给定 ID 的 TimeZone。

Object

PropertyResourceBundle.handleGetObject(String key)

Object

ListResourceBundle.handleGetObject(String key)

protected abstract  Object

ResourceBundle.handleGetObject(String key)
从此资源包中获取给定键的对象。

boolean

Scanner.hasNext(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回 true。

boolean

ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime)
确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。

ResourceBundle

ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload)
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

String

Scanner.next(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。

String

StringTokenizer.nextToken(String delim)
返回此 string tokenizer 的字符串中的下一个标记。

static long

Date.parse(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

void

Properties.save(OutputStream out, String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。

void

TimeZone.setID(String ID)
设置时区 ID。

Object

Properties.setProperty(String key, String value)
调用 Hashtable 的方法 put。

Scanner

Scanner.skip(String pattern)
跳过与从指定字符串构造的模式匹配的输入信息。

void

Properties.store(OutputStream out, String comments)
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。

void

Properties.store(Writer writer, String comments)
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。

void

Properties.storeToXML(OutputStream os, String comment)
发出一个表示此表中包含的所有属性的 XML 文档。

void

Properties.storeToXML(OutputStream os, String comment, String encoding)
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。

String

ResourceBundle.Control.toBundleName(String baseName, Locale locale)
将给定 baseName 和 locale 转换为包名称。

String

ResourceBundle.Control.toResourceName(String bundleName, String suffix)
将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。

Scanner

Scanner.useDelimiter(String pattern)
将此扫描器的分隔模式设置为从指定 String 构造的模式。

static Formatter.BigDecimalLayoutForm

Formatter.BigDecimalLayoutForm.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 java.util 中的方法参数

static ResourceBundle.Control

ResourceBundle.Control.getControl(List<String> formats)
返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。

static ResourceBundle.Control

ResourceBundle.Control.getNoFallbackControl(List<String> formats)
返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。

参数类型为 String 的 java.util 中的构造方法

ConcurrentModificationException(String message)
构造带指定详细消息的 ConcurrentModificationException。

Date(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

DuplicateFormatFlagsException(String f)
构造带指定标志的此类的一个实例。

FormatFlagsConversionMismatchException(String f, char c)
构造带指定标志和转换的此类的一个实例。

Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。

Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。

Formatter(OutputStream os, String csn)
构造一个带指定输出流和字符集的新 formatter。

Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。

Formatter(String fileName)
构造一个带指定文件名的新 formatter。

Formatter(String fileName, String csn)
构造一个带指定文件名和字符集的新 formatter。

Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。

IllegalFormatFlagsException(String f)
构造带有指定标志的此类的一个实例。

InputMismatchException(String s)
构造 InputMismatchException，将引用保存到错误消息字符串 s 中，以便将来由 getMessage 方法获取。

InvalidPropertiesFormatException(String message)
构造一个带指定详细消息的 InvalidPropertiesFormatException。

Locale(String language)
根据语言代码构造一个语言环境。

Locale(String language, String country)
根据语言和国家/地区构造一个语言环境。

Locale(String language, String country, String variant)
根据语言、国家/地区和变量构造一个语言环境。

MissingFormatArgumentException(String s)
构造带有不匹配的格式说明符的此类的一个实例。

MissingFormatWidthException(String s)
构造带有指定格式说明符的此类的一个实例。

MissingResourceException(String s, String className, String key)
构造带有指定信息的 MissingResourceException。

NoSuchElementException(String s)
构造一个 NoSuchElementException，保存对错误消息字符串 s 的引用，以便将来通过 getMessage 方法进行获取。

PropertyPermission(String name, String actions)
创建带指定名称的新 PropertyPermission 对象。

Scanner(File source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。

Scanner(InputStream source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。

Scanner(ReadableByteChannel source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。

Scanner(String source)
构造一个新的 Scanner，它生成的值是从指定字符串扫描的。

ServiceConfigurationError(String msg)
构造一个带有指定消息的新实例。

ServiceConfigurationError(String msg, Throwable cause)
构造一个带有指定消息和 cause 的新实例。

SimpleTimeZone(int rawOffset, String ID)
使用给定的相对于 GMT 的基准时区偏移量和不带夏令时安排的时区 ID 构造一个 SimpleTimeZone。

SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。

SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime, int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。

SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int startTimeMode, int endMonth, int endDay, int endDayOfWeek, int endTime, int endTimeMode, int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。

StringTokenizer(String str)
为指定字符串构造一个 string tokenizer。

StringTokenizer(String str, String delim)
为指定字符串构造一个 string tokenizer。

StringTokenizer(String str, String delim, boolean returnDelims)
为指定字符串构造一个 string tokenizer。

Timer(String name)
创建一个新计时器，其相关的线程具有指定的名称。

Timer(String name, boolean isDaemon)
创建一个新计时器，其相关的线程具有指定的名称，并且可以指定作为守护程序运行。

TooManyListenersException(String s)
构造带指定详细消息的 TooManyListenersException。

UnknownFormatConversionException(String s)
使用未知的转换构造此类的实例。

UnknownFormatFlagsException(String f)
使用指定的标志构造此类的实例。

java.util.concurrent 中 String 的使用

返回 String 的 java.util.concurrent 中的方法

String

ArrayBlockingQueue.toString()

String

CopyOnWriteArrayList.toString()
返回此列表的字符串表示形式。

String

CountDownLatch.toString()
返回标识此锁存器及其状态的字符串。

String

LinkedBlockingDeque.toString()

String

LinkedBlockingQueue.toString()

String

PriorityBlockingQueue.toString()

String

Semaphore.toString()
返回标识此信号量的字符串，以及信号量的状态。

参数类型为 String 的 java.util.concurrent 中的方法

static TimeUnit

TimeUnit.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 java.util.concurrent 中的构造方法

BrokenBarrierException(String message)
构造带指定详细消息的 BrokenBarrierException。

CancellationException(String message)
构造带指定详细消息的 CancellationException。

ExecutionException(String message)
构造带指定详细消息的 ExecutionException。

ExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 ExecutionException。

RejectedExecutionException(String message)
构造带指定详细消息的 RejectedExecutionException。

RejectedExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 RejectedExecutionException。

TimeoutException(String message)
构造带指定详细消息的 TimeoutException。

java.util.concurrent.atomic 中 String 的使用

返回 String 的 java.util.concurrent.atomic 中的方法

String

AtomicIntegerArray.toString()
返回数组当前值的字符串表示形式。

String

AtomicLongArray.toString()
返回数组当前值的字符串表示形式。

String

AtomicReference.toString()
返回当前值的字符串表示形式。

String

AtomicReferenceArray.toString()
返回数组当前值的字符串表示形式。

String

AtomicInteger.toString()
返回当前值的字符串表示形式。

String

AtomicLong.toString()
返回当前值的字符串表示形式。

String

AtomicBoolean.toString()
返回当前值的字符串表示形式。

参数类型为 String 的 java.util.concurrent.atomic 中的方法

static

<U,W> AtomicReferenceFieldUpdater<U,W>

AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。

static

<U> AtomicIntegerFieldUpdater<U>

AtomicIntegerFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
使用给定字段为对象创建和返回一个更新器。

static

<U> AtomicLongFieldUpdater<U>

AtomicLongFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
为对象创建并返回一个具有给定字段的更新器。

java.util.concurrent.locks 中 String 的使用

返回 String 的 java.util.concurrent.locks 中的方法

String

AbstractQueuedLongSynchronizer.toString()
返回标识此同步器及其状态的字符串。

String

ReentrantReadWriteLock.toString()
返回标识此锁及其锁状态的字符串。

String

ReentrantReadWriteLock.ReadLock.toString()
返回标识此锁及其锁状态的字符串。

String

ReentrantReadWriteLock.WriteLock.toString()
返回标识此锁及其锁状态的字符串。

String

AbstractQueuedSynchronizer.toString()
返回标识此同步器及其状态的字符串。

String

ReentrantLock.toString()
返回标识此锁及其锁定状态的字符串。

java.util.jar 中 String 的使用

声明为 String 的 java.util.jar 中的字段

static String

Pack200.Packer.CLASS_ATTRIBUTE_PFX
当与类属性名称连在一起时，使用 JSR 200 规范中指定的布局语言指出该属性的格式。

static String

Pack200.Packer.CODE_ATTRIBUTE_PFX
当与代码属性名称连在一起时，指出该属性的格式。

static String

Pack200.Packer.DEFLATE_HINT
如果将此属性设置为 Pack200.Packer.TRUE 或 Pack200.Packer.FALSE，则打包器将在输出存档中设置相应的压缩提示，并且不传输存档元素的单个压缩提示。

static String

Pack200.Unpacker.DEFLATE_HINT
此属性指示解包器应该忽略 DEFLATE_HINT 的所有已传输的值，并用给定值 Pack200.Unpacker.TRUE 或 Pack200.Unpacker.FALSE 替换它们。

static String

Pack200.Packer.EFFORT
如果将此属性设置为单个十进制数字，则打包器将在压缩存档时使用指定压缩级别。

static String

Pack200.Packer.ERROR
字符串 "error"，某些属性的可能值。

static String

Pack200.Packer.FALSE
字符串 "false"，某些属性的可能值。

static String

Pack200.Unpacker.FALSE
字符串 "false"，某些属性的可能值。

static String

Pack200.Packer.FIELD_ATTRIBUTE_PFX
当与字段属性名称连在一起时，指出该属性的格式。

static String

Pack200.Packer.KEEP
字符串 "keep"，某些属性的可能值。

static String

Pack200.Unpacker.KEEP
字符串 "keep"，某些属性的可能值。

static String

Pack200.Packer.KEEP_FILE_ORDER
如果将此属性设置为 Pack200.Packer.TRUE，则打包器将按它们在源存档中的原始顺序传输所有元素。

static String

Pack200.Packer.LATEST
字符串 "latest"，某些属性的可能值。

static String

JarFile.MANIFEST_NAME
JAR 清单文件名称。

static String

Pack200.Packer.METHOD_ATTRIBUTE_PFX
当与方法属性名称连在一起时，指出该属性的格式。

static String

Pack200.Packer.MODIFICATION_TIME
如果将此属性设置为特殊的字符串 Pack200.Packer.LATEST，则打包器将尝试在原始存档中的所有可用条目中确定最后修改时间，或者确定每个段中所有可用条目的最后修改时间。

static String

Pack200.Packer.PASS
字符串 "pass"，某些属性的可能值。

static String

Pack200.Packer.PASS_FILE_PFX
指出文件应该按字节传递（无压缩）。

static String

Pack200.Packer.PROGRESS
解包器的百分比进度，由解包器定期更新。

static String

Pack200.Unpacker.PROGRESS
解包器的百分比进度，由解包器定期更新。

static String

Pack200.Packer.SEGMENT_LIMIT
此属性是一个数字，给出了每个存档段的估计目标大小 N（以字节为单位）。

static String

Pack200.Packer.STRIP
字符串 "strip"，某些属性的可能值。

static String

Pack200.Packer.TRUE
字符串 "true"，某些属性的可能值。

static String

Pack200.Unpacker.TRUE
字符串 "true"，某些属性的可能值。

static String

Pack200.Packer.UNKNOWN_ATTRIBUTE
指出遇到包含有未知属性的类文件时所采取的行动。

返回 String 的 java.util.jar 中的方法

String

Attributes.getValue(Attributes.Name name)
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。

String

Attributes.getValue(String name)
返回指定属性名称的值，如果未找到，则返回 null。

String

Attributes.putValue(String name, String value)
将指定的值作为一个 String 关联到指定的属性名称。

String

Attributes.Name.toString()
返回字符串形式的属性名称。

返回变量类型为 String 的类型的 java.util.jar 中的方法

Map<String,Attributes>

Manifest.getEntries()
返回此 Manifest 中所包含条目的 Map。

SortedMap<String,String>

Pack200.Packer.properties()
获取此引擎属性集。

SortedMap<String,String>

Pack200.Packer.properties()
获取此引擎属性集。

SortedMap<String,String>

Pack200.Unpacker.properties()
获取此引擎属性集。

SortedMap<String,String>

Pack200.Unpacker.properties()
获取此引擎属性集。

参数类型为 String 的 java.util.jar 中的方法

protected  ZipEntry

JarInputStream.createZipEntry(String name)
为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。

Attributes

Manifest.getAttributes(String name)
返回指定条目名称的 Attributes。

ZipEntry

JarFile.getEntry(String name)
返回给定条目名称的 ZipEntry；如果未找到，则返回 null。

JarEntry

JarFile.getJarEntry(String name)
返回给定条目名称的 JarEntry；如果未找到，则返回 null。

String

Attributes.getValue(String name)
返回指定属性名称的值，如果未找到，则返回 null。

String

Attributes.putValue(String name, String value)
将指定的值作为一个 String 关联到指定的属性名称。

参数类型为 String 的 java.util.jar 中的构造方法

Attributes.Name(String name)
用给定字符串名称构造一个新的属性名称。

JarEntry(String name)
为指定的 JAR 文件条目名称创建新的 JarEntry。

JarException(String s)
构造带指定详细消息的 JarException。

JarFile(String name)
创建一个要从指定的文件 name 读取的新的 JarFile。

JarFile(String name, boolean verify)
创建一个要从指定的文件 name 读取的新的 JarFile。

java.util.logging 中 String 的使用

声明为 String 的 java.util.logging 中的字段

static String

Logger.GLOBAL_LOGGER_NAME
GLOBAL_LOGGER_NAME 是全局 logger 的一个名称。

static String

LogManager.LOGGING_MXBEAN_NAME
LoggingMXBean 的 ObjectName 的字符串表示形式。

返回 String 的 java.util.logging 中的方法

abstract  String

Formatter.format(LogRecord record)
格式化给定的日志记录，并返回格式化后的字符串。

String

SimpleFormatter.format(LogRecord record)
格式化给定的 LogRecord。

String

XMLFormatter.format(LogRecord record)
将给定消息格式化为 XML。

String

Formatter.formatMessage(LogRecord record)
本地化和格式化来自日志记录的消息字符串。

String

Handler.getEncoding()
返回该 Handler 的字符编码。

String

Formatter.getHead(Handler h)
返回一组格式化记录的头部字符串。

String

XMLFormatter.getHead(Handler h)
返回一组 XML 格式记录的头部字符串。

String

Level.getLocalizedName()
返回当前默认语言环境的 Level 的本地化字符串名称。

String

LoggingMXBean.getLoggerLevel(String loggerName)
获取与指定 logger 相关的日志级别名称。

String

LogRecord.getLoggerName()
获取源 Logger 名称

String

LogRecord.getMessage()
获取本地化或格式化之前的“原始”日志消息。

String

Level.getName()
返回 Level 的非本地化字符串名称。

String

Logger.getName()
获取此 logger 的名称。

String

LoggingMXBean.getParentLoggerName(String loggerName)
返回指定 logger 的父 logger 名称。

String

LogManager.getProperty(String name)
获取日志属性的值。

String

LogRecord.getResourceBundleName()
获取本地化资源包名称。

String

Level.getResourceBundleName()
返回级别的本地化资源包名称；如果没有定义本地化包，则返回 null。

String

Logger.getResourceBundleName()
获取此 logger 的本地化资源包名称。

String

LogRecord.getSourceClassName()
获取发出日志请求的类的名称。

String

LogRecord.getSourceMethodName()
获取（可能）发出日志请求的方法的名称。

String

Formatter.getTail(Handler h)
返回一组格式化记录的尾部字符串。

String

XMLFormatter.getTail(Handler h)
返回一组 XML 格式记录的尾部字符串。

String

Level.toString()

返回变量类型为 String 的类型的 java.util.logging 中的方法

List<String>

LoggingMXBean.getLoggerNames()
返回当前已注册的 logger 列表。

Enumeration<String>

LogManager.getLoggerNames()
获取已知 logger 名称的枚举。

参数类型为 String 的 java.util.logging 中的方法

void

Logger.config(String msg)
记录一条 CONFIG 消息。

void

Logger.entering(String sourceClass, String sourceMethod)
记录一个方法条目。

void

Logger.entering(String sourceClass, String sourceMethod, Object param1)
记录一个方法条目，带有一个参数。

void

Logger.entering(String sourceClass, String sourceMethod, Object[] params)
记录一个方法条目，带有一组参数。

void

ErrorManager.error(String msg, Exception ex, int code)
在发生 Handler 失败时调用 error 方法。

void

Logger.exiting(String sourceClass, String sourceMethod)
记录一个方法返回。

void

Logger.exiting(String sourceClass, String sourceMethod, Object result)
记录一个方法返回，带有结果对象。

void

Logger.fine(String msg)
记录一条 FINE 消息。

void

Logger.finer(String msg)
记录一条 FINER 消息。

void

Logger.finest(String msg)
记录一条 FINEST 消息。

static Logger

Logger.getAnonymousLogger(String resourceBundleName)
创建一个匿名的 Logger。

Logger

LogManager.getLogger(String name)
查找指定 logger 的方法。

static Logger

Logger.getLogger(String name)
为指定子系统查找或创建一个 logger。

static Logger

Logger.getLogger(String name, String resourceBundleName)
为指定子系统查找或创建一个 logger。

String

LoggingMXBean.getLoggerLevel(String loggerName)
获取与指定 logger 相关的日志级别名称。

String

LoggingMXBean.getParentLoggerName(String loggerName)
返回指定 logger 的父 logger 名称。

String

LogManager.getProperty(String name)
获取日志属性的值。

void

Logger.info(String msg)
记录一条 INFO 消息。

void

Logger.log(Level level, String msg)
记录一条不带参数的消息。

void

Logger.log(Level level, String msg, Object param1)
记录带有一个对象参数的消息。

void

Logger.log(Level level, String msg, Object[] params)
记录带有一组对象参数的消息。

void

Logger.log(Level level, String msg, Throwable thrown)
记录带有相关的可抛出信息的消息。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg)
记录一条消息，具有指定的源类和方法，不带参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object param1)
记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)
记录一条消息，具有指定的源类和方法，带有一组对象参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown)
记录一条消息，具有指定源类和方法，带有相关的可抛出信息。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg)
记录一条消息，具有指定的源类、方法和资源包名，不带参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)
记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)
记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown)
记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。

static Level

Level.parse(String name)
将级别名称字符串解析成 Level。

protected  void

Handler.reportError(String msg, Exception ex, int code)
用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。

void

StreamHandler.setEncoding(String encoding)
设置（或更改）该 Handler 所用的字符编码。

void

Handler.setEncoding(String encoding)
设置该 Handler 所用的字符编码。

void

LoggingMXBean.setLoggerLevel(String loggerName, String levelName)
将指定 logger 设置为指定的新级别。

void

LogRecord.setLoggerName(String name)
设置源 Logger 名称。

void

LogRecord.setMessage(String message)
设置本地化或格式化之前的“原始”日志消息。

void

LogRecord.setResourceBundleName(String name)
设置本地化资源包名称。

void

LogRecord.setSourceClassName(String sourceClassName)
设置（可能）发出日志请求的类的名称。

void

LogRecord.setSourceMethodName(String sourceMethodName)
设置（可能）发出日志请求的方法的名称。

void

Logger.severe(String msg)
记录一条 SEVERE 消息。

void

Logger.throwing(String sourceClass, String sourceMethod, Throwable thrown)
正抛出异常的记录。

void

Logger.warning(String msg)
记录一条 WARNING 消息。

参数类型为 String 的 java.util.logging 中的构造方法

FileHandler(String pattern)
初始化要写入给定文件名的 FileHandler 。

FileHandler(String pattern, boolean append)
初始化要写入给定文件名的 FileHandler（使用可选的 append）。

FileHandler(String pattern, int limit, int count)
初始化要写入文件集的 FileHandler。

FileHandler(String pattern, int limit, int count, boolean append)
初始化要写入文件集的 FileHandler（使用可选的 append）。

Level(String name, int value)
使用给定的整数值创建一个指定的 Level。

Level(String name, int value, String resourceBundleName)
使用给定的整数值和给定的本地化资源名称创建一个指定的 Level。

Logger(String name, String resourceBundleName)
受保护的方法，它用于为一个指定子系统的构造 logger。

LoggingPermission(String name, String actions)
创建一个新的 LoggingPermission 对象。

LogRecord(Level level, String msg)
用给定级别和消息值构造 LogRecord。

SocketHandler(String host, int port)
构造一个带有指定主机和端口的 SocketHandler。

java.util.prefs 中 String 的使用

返回 String 的 java.util.prefs 中的方法

String

AbstractPreferences.absolutePath()
根据 Preferences.absolutePath() 中的规范实现 absolutePath 方法。

abstract  String

Preferences.absolutePath()
返回此首选项节点的绝对路径名。

String[]

AbstractPreferences.childrenNames()
根据 Preferences.childrenNames() 中的规范实现 children 方法。

abstract  String[]

Preferences.childrenNames()
返回此首选项节点相对于此节点的子节点名称。

protected abstract  String[]

AbstractPreferences.childrenNamesSpi()
返回此首选项节点的子节点名称。

String

AbstractPreferences.get(String key, String def)
根据 Preferences.get(String,String) 中的规范实现 get 方法。

abstract  String

Preferences.get(String key, String def)
返回与此首选项节点中指定键相关联的值。

String

PreferenceChangeEvent.getKey()
返回已更改首选项的键。

String

PreferenceChangeEvent.getNewValue()
返回首选项的新值。

protected abstract  String

AbstractPreferences.getSpi(String key)
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。

String[]

AbstractPreferences.keys()
根据 Preferences.keys() 中的规范实现 keys 方法。

abstract  String[]

Preferences.keys()
返回在此首选项节点中具有关联值的所有键。

protected abstract  String[]

AbstractPreferences.keysSpi()
返回在此首选项节点中具有关联值的所有键。

String

AbstractPreferences.name()
根据 Preferences.name() 中的规范实现 name 方法。

abstract  String

Preferences.name()
返回此首选项节点相对于父节点的名称。

String

AbstractPreferences.toString()
返回此首选项节点的绝对路径名称。

abstract  String

Preferences.toString()
返回此首选项节点的字符串表示形式，与通过表达式：(this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 计算的结果一样。

参数类型为 String 的 java.util.prefs 中的方法

protected abstract  AbstractPreferences

AbstractPreferences.childSpi(String name)
返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。

String

AbstractPreferences.get(String key, String def)
根据 Preferences.get(String,String) 中的规范实现 get 方法。

abstract  String

Preferences.get(String key, String def)
返回与此首选项节点中指定键相关联的值。

boolean

AbstractPreferences.getBoolean(String key, boolean def)
根据 Preferences.getBoolean(String,boolean) 中的规范实现 getBoolean 方法。

abstract  boolean

Preferences.getBoolean(String key, boolean def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 boolean 值。

byte[]

AbstractPreferences.getByteArray(String key, byte[] def)
根据 Preferences.getByteArray(String,byte[]) 中的规范实现 getByteArray 方法。

abstract  byte[]

Preferences.getByteArray(String key, byte[] def)
返回与此首选项节点中指定键相关联的、由字符串表示的字节数组。

protected  AbstractPreferences

AbstractPreferences.getChild(String nodeName)
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。

double

AbstractPreferences.getDouble(String key, double def)
根据 Preferences.getDouble(String,double) 中的规范实现 getDouble 方法。

abstract  double

Preferences.getDouble(String key, double def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 double 值。

float

AbstractPreferences.getFloat(String key, float def)
根据 Preferences.getFloat(String,float) 中的规范实现 getFloat 方法。

abstract  float

Preferences.getFloat(String key, float def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 float 值。

int

AbstractPreferences.getInt(String key, int def)
根据 Preferences.getInt(String,int) 中的规范实现 getInt 方法。

abstract  int

Preferences.getInt(String key, int def)
返回与此首选项节点中与指定键相关联的、由字符串表示的 int 值。

long

AbstractPreferences.getLong(String key, long def)
根据 Preferences.getLong(String,long) 中的规范实现 getLong 方法。

abstract  long

Preferences.getLong(String key, long def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 long 值。

protected abstract  String

AbstractPreferences.getSpi(String key)
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。

Preferences

AbstractPreferences.node(String path)
根据 Preferences.node(String) 中的规范实现 node 方法。

abstract  Preferences

Preferences.node(String pathName)
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。

boolean

AbstractPreferences.nodeExists(String path)
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。

abstract  boolean

Preferences.nodeExists(String pathName)
如果此节点所在的树中存在指定首选项节点，则返回 true。

void

AbstractPreferences.put(String key, String value)
根据 Preferences.put(String,String) 中的规范实现 put 方法。

abstract  void

Preferences.put(String key, String value)
将指定值与此首选项节点中的指定键相关联。

void

AbstractPreferences.putBoolean(String key, boolean value)
根据 Preferences.putBoolean(String,boolean) 中的规范实现 putBoolean 方法。

abstract  void

Preferences.putBoolean(String key, boolean value)
将表示指定 boolean 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putByteArray(String key, byte[] value)
根据 Preferences.putByteArray(String,byte[]) 中的规范实现 putByteArray 方法。

abstract  void

Preferences.putByteArray(String key, byte[] value)
将表示指定字节数组的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putDouble(String key, double value)
根据 Preferences.putDouble(String,double) 中的规范实现 putDouble 方法。

abstract  void

Preferences.putDouble(String key, double value)
将表示指定 double 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putFloat(String key, float value)
根据 Preferences.putFloat(String,float) 中的规范实现 putFloat 方法。

abstract  void

Preferences.putFloat(String key, float value)
将表示指定 float 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putInt(String key, int value)
根据 Preferences.putInt(String,int) 中的规范实现 putInt 方法。

abstract  void

Preferences.putInt(String key, int value)
将表示指定 int 值的字符串与此首选项节点中的指定键相关联。

void

AbstractPreferences.putLong(String key, long value)
根据 Preferences.putLong(String,long) 中的规范实现 putLong 方法。

abstract  void

Preferences.putLong(String key, long value)
将表示指定 long 值的字符串与此首选项节点中的指定键相关联。

protected abstract  void

AbstractPreferences.putSpi(String key, String value)
将给定的键-值关联置于此首选项节点中。

void

AbstractPreferences.remove(String key)
根据 Preferences.remove(String) 中的规范实现 remove(String) 方法。

abstract  void

Preferences.remove(String key)
移除与此首选项节点中与指定键相关联的值（如果有）。

protected abstract  void

AbstractPreferences.removeSpi(String key)
移除此首选项节点上指定键的关联值（如果有）。

参数类型为 String 的 java.util.prefs 中的构造方法

AbstractPreferences(AbstractPreferences parent, String name)
用指定的父节点和与其父节点相关的指定名称创建首选项节点。

BackingStoreException(String s)
构造带指定详细消息的 BackingStoreException。

InvalidPreferencesFormatException(String message)
构造带指定详细消息的 InvalidPreferencesFormatException。

InvalidPreferencesFormatException(String message, Throwable cause)
构造带指定详细消息和原因的 InvalidPreferencesFormatException。

PreferenceChangeEvent(Preferences node, String key, String newValue)
构造新的 PreferenceChangeEvent 实例。

java.util.regex 中 String 的使用

返回 String 的 java.util.regex 中的方法

String

PatternSyntaxException.getDescription()
获取错误的描述。

String

PatternSyntaxException.getMessage()
返回多行字符串，包含语法错误及其索引的描述、错误的正则表达式模式和模式中错误索引的可视化指示。

String

PatternSyntaxException.getPattern()
获取错误的正则表达式模式。

String

Matcher.group()
返回由以前匹配操作所匹配的输入子序列。

String

MatchResult.group()
返回由以前匹配所匹配的输入子序列。

String

Matcher.group(int group)
返回在以前匹配操作期间由给定组捕获的输入子序列。

String

MatchResult.group(int group)
返回在以前匹配操作期间由给定组捕获的输入子序列。

String

Pattern.pattern()
返回在其中编译过此模式的正则表达式。

static String

Pattern.quote(String s)
返回指定 String 的字面值模式 String。

static String

Matcher.quoteReplacement(String s)
返回指定 String 的字面值替换 String。

String

Matcher.replaceAll(String replacement)
替换模式与给定替换字符串相匹配的输入序列的每个子序列。

String

Matcher.replaceFirst(String replacement)
替换模式与给定替换字符串匹配的输入序列的第一个子序列。

String[]

Pattern.split(CharSequence input)
围绕此模式的匹配拆分给定输入序列。

String[]

Pattern.split(CharSequence input, int limit)
围绕此模式的匹配拆分给定输入序列。

String

Matcher.toString()
返回匹配器的字符串表示形式。

String

Pattern.toString()
返回此模式的字符串表示形式。

参数类型为 String 的 java.util.regex 中的方法

Matcher

Matcher.appendReplacement(StringBuffer sb, String replacement)
实现非终端添加和替换步骤。

static Pattern

Pattern.compile(String regex)
将给定的正则表达式编译到模式中。

static Pattern

Pattern.compile(String regex, int flags)
将给定的正则表达式编译到具有给定标志的模式中。

static boolean

Pattern.matches(String regex, CharSequence input)
编译给定正则表达式并尝试将给定输入与其匹配。

static String

Pattern.quote(String s)
返回指定 String 的字面值模式 String。

static String

Matcher.quoteReplacement(String s)
返回指定 String 的字面值替换 String。

String

Matcher.replaceAll(String replacement)
替换模式与给定替换字符串相匹配的输入序列的每个子序列。

String

Matcher.replaceFirst(String replacement)
替换模式与给定替换字符串匹配的输入序列的第一个子序列。

参数类型为 String 的 java.util.regex 中的构造方法

PatternSyntaxException(String desc, String regex, int index)
构造此类的新实例。

java.util.spi 中 String 的使用

返回 String 的 java.util.spi 中的方法

abstract  String

LocaleNameProvider.getDisplayCountry(String countryCode, Locale locale)
返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。

abstract  String

LocaleNameProvider.getDisplayLanguage(String languageCode, Locale locale)
返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。

abstract  String

TimeZoneNameProvider.getDisplayName(String ID, boolean daylight, int style, Locale locale)
返回适于展示给指定语言环境用户的给定时区 ID 名称。

abstract  String

LocaleNameProvider.getDisplayVariant(String variant, Locale locale)
返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。

abstract  String

CurrencyNameProvider.getSymbol(String currencyCode, Locale locale)
获取指定语言环境的给定货币代码的符号。

参数类型为 String 的 java.util.spi 中的方法

abstract  String

LocaleNameProvider.getDisplayCountry(String countryCode, Locale locale)
返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。

abstract  String

LocaleNameProvider.getDisplayLanguage(String languageCode, Locale locale)
返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。

abstract  String

TimeZoneNameProvider.getDisplayName(String ID, boolean daylight, int style, Locale locale)
返回适于展示给指定语言环境用户的给定时区 ID 名称。

abstract  String

LocaleNameProvider.getDisplayVariant(String variant, Locale locale)
返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。

abstract  String

CurrencyNameProvider.getSymbol(String currencyCode, Locale locale)
获取指定语言环境的给定货币代码的符号。

java.util.zip 中 String 的使用

返回 String 的 java.util.zip 中的方法

String

ZipEntry.getComment()
返回条目的注释字符串；如果没有，则返回 null。

String

ZipEntry.getName()
返回条目名称。

String

ZipFile.getName()
返回 ZIP 文件的路径名。

String

ZipEntry.toString()
返回 ZIP 条目的字符串表示形式。

参数类型为 String 的 java.util.zip 中的方法

protected  ZipEntry

ZipInputStream.createZipEntry(String name)
为指定条目名称创建一个新的 ZipEntry 对象。

ZipEntry

ZipFile.getEntry(String name)
返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。

void

ZipOutputStream.setComment(String comment)
设置 ZIP 文件注释。

void

ZipEntry.setComment(String comment)
为条目设置可选的注释字符串。

参数类型为 String 的 java.util.zip 中的构造方法

DataFormatException(String s)
构造带指定详细消息的 DataFormatException。

ZipEntry(String name)
使用指定名称创建新的 ZIP 条目。

ZipError(String s)
构造带有给定详细消息的 ZipError。

ZipException(String s)
构建带指定详细消息的 ZipException。

ZipFile(String name)
打开 ZIP 文件进行阅读。

javax.accessibility 中 String 的使用

声明为 String 的 javax.accessibility 中的字段

static String

AccessibleContext.ACCESSIBLE_ACTION_PROPERTY
用于指示支持的动作集已更改的常量。

static String

AccessibleContext.ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY
用于确定组件的活动子级已更改的常量。

static String

AccessibleContext.ACCESSIBLE_CARET_PROPERTY
用于确定 accessibleText 插入符已更改的常量。

static String

AccessibleContext.ACCESSIBLE_CHILD_PROPERTY
用于确定何时向对象添加或从对象移除 Accessible 子级的常量。

static String

AccessibleContext.ACCESSIBLE_COMPONENT_BOUNDS_CHANGED
指示组件边界已更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY
用于确定 accessibleDescription 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_HYPERTEXT_OFFSET
用于指示超文本元素已收到焦点的常量。

static String

AccessibleContext.ACCESSIBLE_INVALIDATE_CHILDREN
指示某个组件（例如树或文本）的子级已发生重要更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_NAME_PROPERTY
用于确定 accessibleName 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY
用于确定 accessibleSelection 已更改的常量。

static String

AccessibleContext.ACCESSIBLE_STATE_PROPERTY
用于确定 accessibleStateSet 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_CAPTION_CHANGED
用于指示表标题已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED
用于指示列描述已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED
用于指示列标题已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_MODEL_CHANGED
用于指示表数据已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED
用于指示行描述已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_ROW_HEADER_CHANGED
用于指示行标题已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TABLE_SUMMARY_CHANGED
用于指示表摘要已更改的常量。

static String

AccessibleContext.ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED
指示文本属性已更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_TEXT_PROPERTY
指示文本已更改的 PropertyChangeEvent。

static String

AccessibleContext.ACCESSIBLE_VALUE_PROPERTY
用于确定 accessibleValue 属性已更改的常量。

static String

AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY
用于确定对象的可见外观已更改的常量。

protected  String

AccessibleContext.accessibleDescription
包含对象描述的本地化 String。

protected  String

AccessibleContext.accessibleName
包含对象名称的本地化 String。

static String

AccessibleRelation.CHILD_NODE_OF
指示某个对象是一个或多个对象的子节点。

static String

AccessibleRelation.CHILD_NODE_OF_PROPERTY
指示两个或多个对象之间的 CHILD_NODE_OF 关系已更改。

static String

AccessibleAction.CLICK
导致某个组件执行其默认动作的动作。

static String

AccessibleRelation.CONTROLLED_BY
指示某个对象由一个或多个目标对象控制。

static String

AccessibleRelation.CONTROLLED_BY_PROPERTY
标识正在进行控制操作的目标对象已更改

static String

AccessibleRelation.CONTROLLER_FOR
指示某个对象是一个或多个目标对象的控制器。

static String

AccessibleRelation.CONTROLLER_FOR_PROPERTY
标识目标对象的控制器已更改

static String

AccessibleAction.DECREMENT
减少某个值的动作。

static String

AccessibleRelation.EMBEDDED_BY
指示某个对象嵌入一个或多个对象。

static String

AccessibleRelation.EMBEDDED_BY_PROPERTY
指示两个或多个对象之间的 EMBEDDED_BY 关系已更改。

static String

AccessibleRelation.EMBEDS
指示某个对象具有一个或多个嵌入它的对象。

static String

AccessibleRelation.EMBEDS_PROPERTY
指示两个或多个对象之间的 EMBEDS 关系已更改。

static String

AccessibleRelation.FLOWS_FROM
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象出现在该对象前面。

static String

AccessibleRelation.FLOWS_FROM_PROPERTY
指示两个对象之间的 FLOWS_FROM 关系已更改。

static String

AccessibleRelation.FLOWS_TO
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象在该对象后面出现。

static String

AccessibleRelation.FLOWS_TO_PROPERTY
指示两个对象之间的 FLOWS_TO 关系已更改。

static String

AccessibleAction.INCREMENT
增加某个值的动作。

protected  String

AccessibleBundle.key
与语言环境无关的状态名称。

static String

AccessibleRelation.LABEL_FOR
指示某个对象是一个或多个目标对象的标签。

static String

AccessibleRelation.LABEL_FOR_PROPERTY
标识某个标签的目标组已更改

static String

AccessibleRelation.LABELED_BY
指示一个或多个目标对象作为某个对象的标签。

static String

AccessibleRelation.LABELED_BY_PROPERTY
标识正在进行标签操作的对象已更改

static String

AccessibleRelation.MEMBER_OF
指示某个对象是一个或多个目标对象集合的成员。

static String

AccessibleRelation.MEMBER_OF_PROPERTY
标识组成员已更改。

static String

AccessibleRelation.PARENT_WINDOW_OF
指示某个对象是一个或多个对象的父窗口。

static String

AccessibleRelation.PARENT_WINDOW_OF_PROPERTY
指示两个或多个对象之间的 PARENT_WINDOW_OF 关系已更改。

static String

AccessibleRelation.SUBWINDOW_OF
指示某个对象是一个或多个对象的子窗口。

static String

AccessibleRelation.SUBWINDOW_OF_PROPERTY
指示两个或多个对象之间的 SUBWINDOW_OF 关系已更改。

String

AccessibleTextSequence.text
文本

static String

AccessibleAction.TOGGLE_EXPAND
如果树节点是展开的，则此动作将折叠它，如果是折叠的则展开它。

static String

AccessibleAction.TOGGLE_POPUP
如果某个弹出菜单是隐藏的，则此动作将使其可见，如果是可见的则将其隐藏。

返回 String 的 javax.accessibility 中的方法

abstract  String

AccessibleHyperlink.getAccessibleActionDescription(int i)
返回此特定链接动作的 String 描述。

String

AccessibleAction.getAccessibleActionDescription(int i)
返回对对象指定动作的描述。

String

AccessibleContext.getAccessibleDescription()
获取此对象的 accessibleDescription 属性。

String

AccessibleIcon.getAccessibleIconDescription()
获取此图标的描述。

String

AccessibleContext.getAccessibleName()
获取此对象的 accessibleName 属性。

String

AccessibleText.getAfterIndex(int part, int index)
返回给定索引后面的 String。

String

AccessibleText.getAtIndex(int part, int index)
返回给定索引处的 String。

String

AccessibleText.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

AccessibleRelation.getKey()
返回此关系的键

String

AccessibleText.getSelectedText()
返回选定的部分文本。

String

AccessibleEditableText.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本字符串。

String

AccessibleExtendedText.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本。

String

AccessibleExtendedComponent.getTitledBorderText()
返回有标题的边框文本

String

AccessibleExtendedComponent.getToolTipText()
返回工具提示文本

String

AccessibleBundle.toDisplayString()
获取使用默认语言环境来描述键的本地化字符串。

String

AccessibleBundle.toDisplayString(Locale locale)
获取本地化字符串形式的键。

protected  String

AccessibleBundle.toDisplayString(String resourceBundleName, Locale locale)
获取本地化字符串形式的键。

String

AccessibleBundle.toString()
获取使用默认语言环境来描述键的本地化字符串。

String

AccessibleRelationSet.toString()
使用默认语言环境创建表示关系集中所有关系的本地化 String。

String

AccessibleStateSet.toString()
使用默认语言环境创建表示状态集中所有状态的本地化 String。

参数类型为 String 的 javax.accessibility 中的方法

boolean

AccessibleRelationSet.contains(String key)
返回关系集是否包含与指定键匹配的关系。

void

AccessibleContext.firePropertyChange(String propertyName, Object oldValue, Object newValue)
对报告 bound 属性更改的支持。

AccessibleRelation

AccessibleRelationSet.get(String key)
返回与指定键匹配的关系。

void

AccessibleEditableText.insertTextAtIndex(int index, String s)
在给定索引处插入指定的字符串。

void

AccessibleEditableText.replaceText(int startIndex, int endIndex, String s)
用指定的字符串替换两个索引之间的文本。

void

AccessibleContext.setAccessibleDescription(String s)
设置此对象的可访问描述。

void

AccessibleIcon.setAccessibleIconDescription(String description)
设置图标的描述。

void

AccessibleContext.setAccessibleName(String s)
设置此对象的可访问的本地化名称。

void

AccessibleEditableText.setTextContents(String s)
将文本内容设置为指定字符串。

protected  String

AccessibleBundle.toDisplayString(String resourceBundleName, Locale locale)
获取本地化字符串形式的键。

参数类型为 String 的 javax.accessibility 中的构造方法

AccessibleRelation(String key)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRelation(String key, Object target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRelation(String key, Object[] target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRole(String key)
使用与语言环境无关的给定键创建新的 AccessibleRole。

AccessibleState(String key)
使用给定的与语言环境无关的键创建新的 AccessibleState。

AccessibleTextSequence(int start, int end, String txt)
构造带有给定参数的 AccessibleTextSequence。

javax.activation 中 String 的使用

返回 String 的 javax.activation 中的方法

String

MimeTypeParameterList.get(String name)
获取与给定名称关联的值；如果不存在当前关联，则返回 null。

String

MimeType.getBaseType()
返回此对象的 String 表示形式，不带参数列表。

String

CommandInfo.getCommandClass()
返回命令的类名。

String

CommandInfo.getCommandName()
返回命令动词。

String

DataHandler.getContentType()
返回从源对象中获取的此对象的 MIME 类型。

String

DataSource.getContentType()
此方法以字符串形式返回数据的 MIME 类型。

String

FileDataSource.getContentType()
此方法以字符串形式返回数据的 MIME 类型。

String

URLDataSource.getContentType()
返回 URL 内容-类型 (content-type) 头字段的值。

abstract  String

FileTypeMap.getContentType(File file)
返回文件对象的类型。

String

MimetypesFileTypeMap.getContentType(File f)
返回该文件对象的 MIME 类型。

abstract  String

FileTypeMap.getContentType(String filename)
返回传入文件的类型。

String

MimetypesFileTypeMap.getContentType(String filename)
返回基于指定文件名的 MIME 类型。

String

ActivationDataFlavor.getHumanPresentableName()
返回得体的名称。

String

ActivationDataFlavor.getMimeType()
返回此 DataFlavor 的 MIME 类型。

String[]

CommandMap.getMimeTypes()
获取此命令映射已知的所有 MIME 类型。

String[]

MailcapCommandMap.getMimeTypes()
获取此命令映射已知的所有 MIME 类型。

String

DataHandler.getName()
返回数据对象的名称。

String

DataSource.getName()
返回此对象的名称，其中对象的名称依赖于底层对象的特性。

String

FileDataSource.getName()
返回此对象的名称。

String

URLDataSource.getName()
调用用于实例化对象的 URL 的 getFile 方法。

String[]

MailcapCommandMap.getNativeCommands(String mimeType)
获取给定 MIME 类型的本地命令。

String

MimeType.getParameter(String name)
获取与给定名称关联的值；如果没有当前关联，则返回 null。

String

MimeType.getPrimaryType()
获取此对象的基本类型。

String

MimeType.getSubType()
获取此对象的子类型。

protected  String

ActivationDataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

ActivationDataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

String

MimeType.toString()
返回此对象的 String 表示形式。

String

MimeTypeParameterList.toString()
返回此对象的字符串表示形式。

参数类型为 String 的 javax.activation 中的方法

void

MailcapCommandMap.addMailcap(String mail_cap)
将条目添加到注册表。

void

MimetypesFileTypeMap.addMimeTypes(String mime_types)
将 MIME 类型值预先添加到注册表。

abstract  DataContentHandler

CommandMap.createDataContentHandler(String mimeType)
查找与 MIME 类型对应的 DataContentHandler。

DataContentHandler

DataContentHandlerFactory.createDataContentHandler(String mimeType)
针对 MIME 类型创建一个新的 DataContentHandler 对象。

DataContentHandler

MailcapCommandMap.createDataContentHandler(String mimeType)
返回指定 MIME 类型的 DataContentHandler。

DataContentHandler

CommandMap.createDataContentHandler(String mimeType, DataSource ds)
查找与 MIME 类型对应的 DataContentHandler。

String

MimeTypeParameterList.get(String name)
获取与给定名称关联的值；如果不存在当前关联，则返回 null。

abstract  CommandInfo[]

CommandMap.getAllCommands(String mimeType)
获取此类型的所有可用命令。

CommandInfo[]

MailcapCommandMap.getAllCommands(String mimeType)
针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。

CommandInfo[]

CommandMap.getAllCommands(String mimeType, DataSource ds)
获取此类型的所有可用命令。

CommandInfo

DataHandler.getCommand(String cmdName)
获取命令 cmdName。

abstract  CommandInfo

CommandMap.getCommand(String mimeType, String cmdName)
获取与 MIME 类型对应的默认命令。

CommandInfo

MailcapCommandMap.getCommand(String mimeType, String cmdName)
针对 MIME 类型获取与 cmdName 对应的命令。

CommandInfo

CommandMap.getCommand(String mimeType, String cmdName, DataSource ds)
获取与 MIME 类型对应的默认命令。

abstract  String

FileTypeMap.getContentType(String filename)
返回传入文件的类型。

String

MimetypesFileTypeMap.getContentType(String filename)
返回基于指定文件名的 MIME 类型。

String[]

MailcapCommandMap.getNativeCommands(String mimeType)
获取给定 MIME 类型的本地命令。

String

MimeType.getParameter(String name)
获取与给定名称关联的值；如果没有当前关联，则返回 null。

abstract  CommandInfo[]

CommandMap.getPreferredCommands(String mimeType)
从 MIME 类型获取首选命令表。

CommandInfo[]

MailcapCommandMap.getPreferredCommands(String mimeType)
获取 MIME 类型的首选命令列表。

CommandInfo[]

CommandMap.getPreferredCommands(String mimeType, DataSource ds)
从 MIME 类型获取首选命令表。

boolean

ActivationDataFlavor.isMimeTypeEqual(String mimeType)
传入的 MIME 类型的字符串表示形式是否等效于此 DataFlavor 的 MIME 类型。

boolean

MimeType.match(String rawdata)
确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。

protected  String

ActivationDataFlavor.normalizeMimeType(String mimeType)
已过时。

protected  String

ActivationDataFlavor.normalizeMimeTypeParameter(String parameterName, String parameterValue)
已过时。

protected  void

MimeTypeParameterList.parse(String parameterList)
将参数列表从一个 String 解析出来的例程。

void

MimeTypeParameterList.remove(String name)
移除与给定名称关联的所有值。

void

MimeType.removeParameter(String name)
移除与给定名称关联的所有值。

void

MimeTypeParameterList.set(String name, String value)
将值设置为与给定名称关联，替换以前的任何关联。

void

CommandObject.setCommandContext(String verb, DataHandler dh)
用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。

void

ActivationDataFlavor.setHumanPresentableName(String humanPresentableName)
设置得体的名称。

void

MimeType.setParameter(String name, String value)
将值设置为与给定的名称关联，替换以前的任何关联。

void

MimeType.setPrimaryType(String primary)
将此对象的基本类型设置为给定的 String。

void

MimeType.setSubType(String sub)
将此对象的子类型设置为给定的 String。

void

DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os)
将对象转换为指定 MIME 类型的字节流，并将其写入输出流。

参数类型为 String 的 javax.activation 中的构造方法

ActivationDataFlavor(Class representationClass, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

ActivationDataFlavor(Class representationClass, String mimeType, String humanPresentableName)
构造一个表示任意 Java 对象的 DataFlavor。

ActivationDataFlavor(String mimeType, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

CommandInfo(String verb, String className)
CommandInfo 的构造方法。

DataHandler(Object obj, String mimeType)
创建表示此 MIME 类型对象的 DataHandler 实例。

FileDataSource(String name)
根据指定的路径名创建 FileDataSource。

MailcapCommandMap(String fileName)
允许调用者指定 mailcap 文件路径的构造方法。

MimeType(String rawdata)
根据 String 构建 MimeType 的构造方法。

MimeType(String primary, String sub)
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。

MimeTypeParameterList(String parameterList)
用传入的数据构造新的 MimeTypeParameterList。

MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。

MimetypesFileTypeMap(String mimeTypeFileName)
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。

UnsupportedDataTypeException(String s)
构造带指定消息的 UnsupportedDataTypeException。

javax.activity 中 String 的使用

参数类型为 String 的 javax.activity 中的构造方法

ActivityCompletedException(String message)
构造带有指定详细消息的新实例。

ActivityCompletedException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

ActivityRequiredException(String message)
构造带有指定详细消息的新实例。

ActivityRequiredException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

InvalidActivityException(String message)
构造带有指定详细消息的新实例。

InvalidActivityException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

javax.annotation 中 String 的使用

参数类型为 String 的 javax.annotation 中的方法

static Resource.AuthenticationType

Resource.AuthenticationType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.annotation.processing 中 String 的使用

返回 String 的 javax.annotation.processing 中的方法

String

Completion.getMessage()
返回包含许多有关 completion 信息的消息。

String

Completion.getValue()
返回建议 completion 的文本。

返回变量类型为 String 的类型的 javax.annotation.processing 中的方法

Map<String,String>

ProcessingEnvironment.getOptions()
返回传递给注释处理工具的特定于 processor 的选项。

Map<String,String>

ProcessingEnvironment.getOptions()
返回传递给注释处理工具的特定于 processor 的选项。

Set<String>

AbstractProcessor.getSupportedAnnotationTypes()
如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。

Set<String>

Processor.getSupportedAnnotationTypes()
返回此 Processor 支持的注释类型的名称。

Set<String>

AbstractProcessor.getSupportedOptions()
如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。

Set<String>

Processor.getSupportedOptions()
返回此 Processor 识别的选项。

参数类型为 String 的 javax.annotation.processing 中的方法

Iterable<? extends Completion>

AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
返回一个空的 completion 迭代。

Iterable<? extends Completion>

Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText)
向工具框架返回某一注释的建议 completion 迭代。

static Completion

Completions.of(String value)
返回值和空消息的 completion。

static Completion

Completions.of(String value, String message)
返回值和消息的 completion。

参数类型为 String 的 javax.annotation.processing 中的构造方法

FilerException(String s)
构造带指定详细消息的异常。

javax.crypto 中 String 的使用

返回 String 的 javax.crypto 中的方法

String

EncryptedPrivateKeyInfo.getAlgName()
返回加密算法。

String

Cipher.getAlgorithm()
返回此 Cipher 对象的算法名称。

String

KeyAgreement.getAlgorithm()
返回此 KeyAgreement 对象的算法名称。

String

KeyGenerator.getAlgorithm()
返回此 KeyGenerator 对象的算法名称。

String

Mac.getAlgorithm()
返回此 Mac 对象的算法名称。

String

SecretKeyFactory.getAlgorithm()
返回此 SecretKeyFactory 对象的算法名称。

String

SealedObject.getAlgorithm()
返回用于密封此对象的算法。

String

ExemptionMechanism.getName()
返回此 ExemptionMechanism 对象的豁免机制名称。

参数类型为 String 的 javax.crypto 中的方法

protected abstract  SecretKey

KeyAgreementSpi.engineGenerateSecret(String algorithm)
创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。

protected abstract  void

CipherSpi.engineSetMode(String mode)
设置此 cipher 的模式。

protected abstract  void

CipherSpi.engineSetPadding(String padding)
设置此 cipher 的填充机制。

protected  Key

CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
打开一个以前包装的密钥。

SecretKey

KeyAgreement.generateSecret(String algorithm)
创建共享秘密并将其作为指定算法的 SecretKey 对象返回。

static Cipher

Cipher.getInstance(String transformation)
返回实现指定转换的 Cipher 对象。

static ExemptionMechanism

ExemptionMechanism.getInstance(String algorithm)
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

static KeyAgreement

KeyAgreement.getInstance(String algorithm)
返回实现指定密钥协定算法的 KeyAgreement 对象。

static KeyGenerator

KeyGenerator.getInstance(String algorithm)
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

static Mac

Mac.getInstance(String algorithm)
返回实现指定 MAC 算法的 Mac 对象。

static SecretKeyFactory

SecretKeyFactory.getInstance(String algorithm)
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

static Cipher

Cipher.getInstance(String transformation, Provider provider)
返回实现指定转换的 Cipher 对象。

static ExemptionMechanism

ExemptionMechanism.getInstance(String algorithm, Provider provider)
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

static KeyAgreement

KeyAgreement.getInstance(String algorithm, Provider provider)
返回实现指定密钥协定算法的 KeyAgreement 对象。

static KeyGenerator

KeyGenerator.getInstance(String algorithm, Provider provider)
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

static Mac

Mac.getInstance(String algorithm, Provider provider)
返回实现指定 MAC 算法的 Mac 对象。

static SecretKeyFactory

SecretKeyFactory.getInstance(String algorithm, Provider provider)
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

static Cipher

Cipher.getInstance(String transformation, String provider)
返回实现指定转换的 Cipher 对象。

static ExemptionMechanism

ExemptionMechanism.getInstance(String algorithm, String provider)
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

static KeyAgreement

KeyAgreement.getInstance(String algorithm, String provider)
返回实现指定密钥协定算法的 KeyAgreement 对象。

static KeyGenerator

KeyGenerator.getInstance(String algorithm, String provider)
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

static Mac

Mac.getInstance(String algorithm, String provider)
返回实现指定 MAC 算法的 Mac 对象。

static SecretKeyFactory

SecretKeyFactory.getInstance(String algorithm, String provider)
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

PKCS8EncodedKeySpec

EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName)
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

static int

Cipher.getMaxAllowedKeyLength(String transformation)
根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。

static AlgorithmParameterSpec

Cipher.getMaxAllowedParameterSpec(String transformation)
根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。

Object

SealedObject.getObject(Key key, String provider)
获取原始（封装的）对象。

Key

Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType)
解包一个以前包装的密钥。

参数类型为 String 的 javax.crypto 中的构造方法

BadPaddingException(String msg)
构造带指定详细消息的 BadPaddingException。

Cipher(CipherSpi cipherSpi, Provider provider, String transformation)
创建 Cipher 对象。

EncryptedPrivateKeyInfo(String algName, byte[] encryptedData)
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。

ExemptionMechanism(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
创建 ExemptionMechanism 对象。

ExemptionMechanismException(String msg)
构造带指定详细消息的 ExemptionMechanismException。

IllegalBlockSizeException(String msg)
构造带指定详细信息的 IllegalBlockSizeException。

KeyAgreement(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
创建一个 KeyAgreement 对象。

KeyGenerator(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
创建一个 KeyGenerator 对象。

Mac(MacSpi macSpi, Provider provider, String algorithm)
创建一个 MAC 对象。

NoSuchPaddingException(String msg)
构造带指定详细消息的 NoSuchPaddingException。

SecretKeyFactory(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 SecretKeyFactory 对象。

ShortBufferException(String msg)
构造带指定详细信息的 ShortBufferException。

javax.crypto.spec 中 String 的使用

返回 String 的 javax.crypto.spec 中的方法

String

SecretKeySpec.getAlgorithm()
返回与此密钥关联的算法的名称。

String

PSource.getAlgorithm()
返回 PSource 算法名称。

String

OAEPParameterSpec.getDigestAlgorithm()
返回信息摘要算法名称。

String

SecretKeySpec.getFormat()
返回此密钥编码格式的名称。

String

OAEPParameterSpec.getMGFAlgorithm()
返回掩码生成函数算法名称。

参数类型为 String 的 javax.crypto.spec 中的构造方法

OAEPParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。

PSource(String pSrcName)
使用指定的 PSource 算法为 PKCS #1 标准中定义的 OAEP 冗余构造一个编码输入 P 的源。

SecretKeySpec(byte[] key, int offset, int len, String algorithm)
根据给定的字节数组构造一个密钥，使用 key 中的始于且包含 offset 的前 len 个字节。

SecretKeySpec(byte[] key, String algorithm)
根据给定的字节数组构造一个密钥。

javax.imageio 中 String 的使用

声明为 String 的 javax.imageio 中的字段

protected  String

ImageWriteParam.compressionType
包含当前压缩类型名称的 String，如果没有设置压缩类型，则返回 null。

protected  String[]

ImageWriteParam.compressionTypes
包含可用压缩类型名称的 String 数组。

返回 String 的 javax.imageio 中的方法

String[]

ImageWriteParam.getCompressionQualityDescriptions()
返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。

String

ImageWriteParam.getCompressionType()
返回当前设置的压缩类型，如果没有设置任何压缩类型，则返回 null。

String[]

ImageWriteParam.getCompressionTypes()
以数组或 String 形式返回可用压缩类型的列表，如果不能使用这些接口选择压缩类型，则返回 null。

String

ImageReader.getFormatName()
返回一个标识输入源格式的 String。

String

ImageWriteParam.getLocalizedCompressionTypeName()
返回当前压缩类型的本地化名称，使用 getLocale 返回的 Locale。

static String[]

ImageIO.getReaderFileSuffixes()
返回一个 String 数组，该数组列出与当前已注册 reader 集合所理解的格式关联的所有文件后缀。

static String[]

ImageIO.getReaderFormatNames()
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有非正式格式名称。

static String[]

ImageIO.getReaderMIMETypes()
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有 MIME 类型。

static String[]

ImageIO.getWriterFileSuffixes()
返回一个 String 数组，该数组列出与当前已注册 writer 集合所理解的格式关联的所有文件后缀。

static String[]

ImageIO.getWriterFormatNames()
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有非正式格式名称。

static String[]

ImageIO.getWriterMIMETypes()
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有 MIME 类型。

参数类型为 String 的 javax.imageio 中的方法

IIOMetadata

ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames)
返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。

static Iterator<ImageReader>

ImageIO.getImageReadersByFormatName(String formatName)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。

static Iterator<ImageReader>

ImageIO.getImageReadersByMIMEType(String MIMEType)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。

static Iterator<ImageReader>

ImageIO.getImageReadersBySuffix(String fileSuffix)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。

static Iterator<ImageWriter>

ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。

static Iterator<ImageWriter>

ImageIO.getImageWritersByFormatName(String formatName)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。

static Iterator<ImageWriter>

ImageIO.getImageWritersByMIMEType(String MIMEType)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。

static Iterator<ImageWriter>

ImageIO.getImageWritersBySuffix(String fileSuffix)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。

IIOMetadata

ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames)
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

protected  void

ImageWriter.processWarningOccurred(int imageIndex, String warning)
通过调用 warningOccurred 方法向所有已注册 IIOWriteWarningListener 广播一条警告消息。

protected  void

ImageWriter.processWarningOccurred(int imageIndex, String baseName, String keyword)
通过使用取自 ResourceBundle 的字符串调用 warningOccurred 方法来向所有已注册 IIOWriteWarningListener 广播一条本地化警告消息。

protected  void

ImageReader.processWarningOccurred(String warning)
通过调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播警告消息。

protected  void

ImageReader.processWarningOccurred(String baseName, String keyword)
通过使用取自 ResourceBundle 的字符串调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播本地化警告消息。

void

ImageWriteParam.setCompressionType(String compressionType)
将压缩类型设置为 getCompressionTypes 指示的值之一。

static boolean

ImageIO.write(RenderedImage im, String formatName, File output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 File。

static boolean

ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。

static boolean

ImageIO.write(RenderedImage im, String formatName, OutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。

类型变量类型为 String 的 javax.imageio 中的方法参数

IIOMetadata

ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames)
返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。

IIOMetadata

ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames)
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

参数类型为 String 的 javax.imageio 中的构造方法

IIOException(String message)
构造带有给定消息 String 的 IIOException。

IIOException(String message, Throwable cause)
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。

javax.imageio.event 中 String 的使用

参数类型为 String 的 javax.imageio.event 中的方法

void

IIOReadWarningListener.warningOccurred(ImageReader source, String warning)
报告在解码中发生非严重错误。

void

IIOWriteWarningListener.warningOccurred(ImageWriter source, int imageIndex, String warning)
报告在编码中发生非严重错误。

javax.imageio.metadata 中 String 的使用

声明为 String 的 javax.imageio.metadata 中的字段

protected  String[]

IIOMetadata.extraMetadataFormatClassNames
实现 IIOMetadataFormat 和表示此插件支持的元数据格式（标准格式和本机格式除外）的类的名称所组成的数组，初始化为 null，通过构造方法设置。

protected  String[]

IIOMetadata.extraMetadataFormatNames
此插件支持的格式（标准格式和本机格式除外）的名称所组成的数组，初始化为 null，通过构造方法设置。

protected  String

IIOMetadata.nativeMetadataFormatClassName
实现 IIOMetadataFormat 和表示本机元数据格式的类的名称，初始化为 null，通过构造方法设置。

protected  String

IIOMetadata.nativeMetadataFormatName
此对象本机元数据格式的名称，初始化为 null，通过构造方法设置。

static String

IIOMetadataFormatImpl.standardMetadataFormatName
包含标准格式名称 "javax_imageio_1.0" 的 String 常量。

返回 String 的 javax.imageio.metadata 中的方法

String

IIOMetadataNode.getAttribute(String name)

String

IIOMetadataFormat.getAttributeDefaultValue(String elementName, String attrName)
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。

String

IIOMetadataFormatImpl.getAttributeDefaultValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String[]

IIOMetadataFormat.getAttributeEnumerations(String elementName, String attrName)
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。

String[]

IIOMetadataFormatImpl.getAttributeEnumerations(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMaxValue(String elementName, String attrName)
返回属性的最大合法值。

String

IIOMetadataFormatImpl.getAttributeMaxValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMinValue(String elementName, String attrName)
返回属性的最小合法值。

String

IIOMetadataFormatImpl.getAttributeMinValue(String elementName, String attrName)

String[]

IIOMetadataFormat.getAttributeNames(String elementName)
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。

String[]

IIOMetadataFormatImpl.getAttributeNames(String elementName)

String

IIOMetadataNode.getAttributeNS(String namespaceURI, String localName)
等效于 getAttribute(localName)。

String

IIOMetadataNode.getBaseURI()

String[]

IIOMetadataFormat.getChildNames(String elementName)
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。

String[]

IIOMetadataFormatImpl.getChildNames(String elementName)

String

IIOMetadataFormat.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

String[]

IIOMetadata.getExtraMetadataFormatNames()
返回一个 String 数组，包含此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的其他元数据格式（本机格式和标准格式除外）的名称。

String

IIOMetadataNode.getLocalName()
等效于 getNodeName。

String[]

IIOMetadata.getMetadataFormatNames()
返回一个 String 数组，包含包括此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的所有元数据格式（包括本机格式和标准格式）的名称。

String

IIOMetadataNode.getNamespaceURI()
返回 null，因为不支持名称空间。

String

IIOMetadata.getNativeMetadataFormatName()
返回此插件的“本机”元数据格式的名称，该格式通常允许无损失地编码和传输以此插件处理的格式存储的元数据。

String

IIOMetadataNode.getNodeName()
返回与此节点关联的节点名称。

String

IIOMetadataNode.getNodeValue()

String

IIOMetadataNode.getPrefix()
返回 null，因为不支持名称空间。

protected  String

IIOMetadataFormatImpl.getResourceBaseName()
返回当前设置的用于查找 ResourceBundle 的基本名称。

String

IIOMetadataFormat.getRootName()
返回格式的根元素的名称。

String

IIOMetadataFormatImpl.getRootName()

String

IIOMetadataNode.getTagName()

String

IIOMetadataNode.getTextContent()

String

IIOMetadataNode.lookupNamespaceURI(String prefix)

String

IIOMetadataNode.lookupPrefix(String namespaceURI)

参数类型为 String 的 javax.imageio.metadata 中的方法

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, int listMinLength, int listMaxLength)
将新属性添加到以前定义的元素中，该元素将由值的列表定义。

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue)
将新属性添加到以前定义的可以被设置为任意值的元素中。

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, String minValue, String maxValue, boolean minInclusive, boolean maxInclusive)
将新属性添加到以前定义的元素中，该元素将由一系列值定义。

protected  void

IIOMetadataFormatImpl.addBooleanAttribute(String elementName, String attrName, boolean hasDefaultValue, boolean defaultValue)
将新属性添加到以前定义的元素中，该元素将由枚举值 TRUE 和 FALSE 定义，数据类型为 DATATYPE_BOOLEAN。

protected  void

IIOMetadataFormatImpl.addChildElement(String elementName, String parentName)
将现有元素添加到给定父节点类型的合法子节点的列表中。

protected  void

IIOMetadataFormatImpl.addElement(String elementName, String parentName, int childPolicy)
使用某个子策略（CHILD_POLICY_REPEAT 除外）将新元素类型添加到此元数据文档格式中。

protected  void

IIOMetadataFormatImpl.addElement(String elementName, String parentName, int minChildren, int maxChildren)
使用子策略 CHILD_POLICY_REPEAT 将新元素类型添加到此元数据文档格式中。

protected  void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

protected

<T> void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

protected

<T> void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

protected

<T extends Object & Comparable<? super T>>
void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

boolean

IIOMetadataFormat.canNodeAppear(String elementName, ImageTypeSpecifier imageType)
如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。

abstract  boolean

IIOMetadataFormatImpl.canNodeAppear(String elementName, ImageTypeSpecifier imageType)

abstract  Node

IIOMetadata.getAsTree(String formatName)
返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。

String

IIOMetadataNode.getAttribute(String name)

int

IIOMetadataFormat.getAttributeDataType(String elementName, String attrName)
返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。

int

IIOMetadataFormatImpl.getAttributeDataType(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDefaultValue(String elementName, String attrName)
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。

String

IIOMetadataFormatImpl.getAttributeDefaultValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。

String[]

IIOMetadataFormat.getAttributeEnumerations(String elementName, String attrName)
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。

String[]

IIOMetadataFormatImpl.getAttributeEnumerations(String elementName, String attrName)

int

IIOMetadataFormat.getAttributeListMaxLength(String elementName, String attrName)
返回可用于定义此属性的最大列表项数。

int

IIOMetadataFormatImpl.getAttributeListMaxLength(String elementName, String attrName)

int

IIOMetadataFormat.getAttributeListMinLength(String elementName, String attrName)
返回可用于定义此属性的最小列表项数。

int

IIOMetadataFormatImpl.getAttributeListMinLength(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMaxValue(String elementName, String attrName)
返回属性的最大合法值。

String

IIOMetadataFormatImpl.getAttributeMaxValue(String elementName, String attrName)

String

IIOMetadataFormat.getAttributeMinValue(String elementName, String attrName)
返回属性的最小合法值。

String

IIOMetadataFormatImpl.getAttributeMinValue(String elementName, String attrName)

String[]

IIOMetadataFormat.getAttributeNames(String elementName)
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。

String[]

IIOMetadataFormatImpl.getAttributeNames(String elementName)

Attr

IIOMetadataNode.getAttributeNode(String name)

Attr

IIOMetadataNode.getAttributeNodeNS(String namespaceURI, String localName)
等效于 getAttributeNode(localName)。

String

IIOMetadataNode.getAttributeNS(String namespaceURI, String localName)
等效于 getAttribute(localName)。

int

IIOMetadataFormat.getAttributeValueType(String elementName, String attrName)
返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。

int

IIOMetadataFormatImpl.getAttributeValueType(String elementName, String attrName)

String[]

IIOMetadataFormat.getChildNames(String elementName)
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。

String[]

IIOMetadataFormatImpl.getChildNames(String elementName)

int

IIOMetadataFormat.getChildPolicy(String elementName)
返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。

int

IIOMetadataFormatImpl.getChildPolicy(String elementName)

String

IIOMetadataFormat.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

String

IIOMetadataFormatImpl.getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。

int

IIOMetadataFormat.getElementMaxChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。

int

IIOMetadataFormatImpl.getElementMaxChildren(String elementName)

int

IIOMetadataFormat.getElementMinChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。

int

IIOMetadataFormatImpl.getElementMinChildren(String elementName)

NodeList

IIOMetadataNode.getElementsByTagName(String name)

NodeList

IIOMetadataNode.getElementsByTagNameNS(String namespaceURI, String localName)
等效于 getElementsByTagName(localName)。

Object

IIOMetadataNode.getFeature(String feature, String version)

IIOMetadataFormat

IIOMetadata.getMetadataFormat(String formatName)
返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

int

IIOMetadataFormat.getObjectArrayMaxLength(String elementName)
返回指定元素中可用于定义 Object 引用的最大数组元素数。

int

IIOMetadataFormatImpl.getObjectArrayMaxLength(String elementName)

int

IIOMetadataFormat.getObjectArrayMinLength(String elementName)
返回指定元素中可用于定义 Object 引用的最小数组元素数。

int

IIOMetadataFormatImpl.getObjectArrayMinLength(String elementName)

Class<?>

IIOMetadataFormat.getObjectClass(String elementName)
返回存储在元素中的 Class 类型的 Object 引用。

Class<?>

IIOMetadataFormatImpl.getObjectClass(String elementName)

Object

IIOMetadataFormat.getObjectDefaultValue(String elementName)
返回包含指定元素中 Object 引用的默认值的 Object。

Object

IIOMetadataFormatImpl.getObjectDefaultValue(String elementName)

Object[]

IIOMetadataFormat.getObjectEnumerations(String elementName)
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。

Object[]

IIOMetadataFormatImpl.getObjectEnumerations(String elementName)

Comparable<?>

IIOMetadataFormat.getObjectMaxValue(String elementName)
返回指定元素中 Object 引用的最大合法值。

Comparable<?>

IIOMetadataFormatImpl.getObjectMaxValue(String elementName)

Comparable<?>

IIOMetadataFormat.getObjectMinValue(String elementName)
返回指定元素中 Object 引用的最小合法值。

Comparable<?>

IIOMetadataFormatImpl.getObjectMinValue(String elementName)

int

IIOMetadataFormat.getObjectValueType(String elementName)
返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。

int

IIOMetadataFormatImpl.getObjectValueType(String elementName)

Object

IIOMetadataNode.getUserData(String key)

boolean

IIOMetadataNode.hasAttribute(String name)

boolean

IIOMetadataNode.hasAttributeNS(String namespaceURI, String localName)
等效于 hasAttribute(localName)。

boolean

IIOMetadataFormat.isAttributeRequired(String elementName, String attrName)
如果指定属性必须在指定元素中存在，则返回 true。

boolean

IIOMetadataFormatImpl.isAttributeRequired(String elementName, String attrName)

boolean

IIOMetadataNode.isDefaultNamespace(String namespaceURI)

boolean

IIOMetadataNode.isSupported(String feature, String version)
返回 false，因为不支持 DOM 功能。

String

IIOMetadataNode.lookupNamespaceURI(String prefix)

String

IIOMetadataNode.lookupPrefix(String namespaceURI)

abstract  void

IIOMetadata.mergeTree(String formatName, Node root)
根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。

void

IIOMetadataNode.removeAttribute(String name)

protected  void

IIOMetadataFormatImpl.removeAttribute(String elementName, String attrName)
从以前定义的元素中移除属性。

void

IIOMetadataNode.removeAttributeNS(String namespaceURI, String localName)
等效于 removeAttribute(localName)。

protected  void

IIOMetadataFormatImpl.removeElement(String elementName)
从格式中移除元素。

protected  void

IIOMetadataFormatImpl.removeObjectValue(String elementName)
禁止将 Object 引用存储在实现指定元素的节点中。

void

IIOMetadataNode.setAttribute(String name, String value)

void

IIOMetadataNode.setAttributeNS(String namespaceURI, String qualifiedName, String value)
等效于 setAttribute(qualifiedName, value)。

void

IIOMetadata.setFromTree(String formatName, Node root)
根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。

void

IIOMetadataNode.setIdAttribute(String name, boolean isId)

void

IIOMetadataNode.setIdAttributeNS(String namespaceURI, String localName, boolean isId)

void

IIOMetadataNode.setNodeValue(String nodeValue)

void

IIOMetadataNode.setPrefix(String prefix)
不执行任何操作，因为不支持名称空间。

protected  void

IIOMetadataFormatImpl.setResourceBaseName(String resourceBaseName)
设置用于查找包含此格式的元素和属性描述的 ResourceBundle 新基本名称。

void

IIOMetadataNode.setTextContent(String textContent)

Object

IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

类型变量类型为 String 的 javax.imageio.metadata 中的方法参数

protected  void

IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。

参数类型为 String 的 javax.imageio.metadata 中的构造方法

IIOInvalidTreeException(String message, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。

IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。

IIOMetadata(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。

IIOMetadata(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。

IIOMetadata(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames)
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。

IIOMetadataFormatImpl(String rootName, int childPolicy)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略（CHILD_POLICY_REPEAT 除外）。

IIOMetadataFormatImpl(String rootName, int minChildren, int maxChildren)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略 CHILD_POLICY_REPEAT。

IIOMetadataNode(String nodeName)
构造一个具有给定节点名称的 IIOMetadataNode。

javax.imageio.plugins.jpeg 中 String 的使用

返回 String 的 javax.imageio.plugins.jpeg 中的方法

String[]

JPEGImageWriteParam.getCompressionQualityDescriptions()

String

JPEGHuffmanTable.toString()

String

JPEGQTable.toString()

javax.imageio.spi 中 String 的使用

声明为 String 的 javax.imageio.spi 中的字段

protected  String[]

ImageReaderWriterSpi.extraImageMetadataFormatClassNames
包含此插件支持的其他任何图像元数据格式的类名称的 String 数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.extraImageMetadataFormatNames
包含此插件支持的其他任何图像元数据格式的名称的 String 数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.extraStreamMetadataFormatClassNames
包含此插件支持的其他任何流元数据格式的类名称的 String 数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.extraStreamMetadataFormatNames
包含此插件支持的其他任何流元数据格式的名称的 String 数组，该字符串最初为 null。

protected  String[]

ImageReaderWriterSpi.MIMETypes
从 getMIMETypes 返回的字符串数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.names
从 getFormatNames 返回的字符串数组，该数组最初为 null。

protected  String

ImageReaderWriterSpi.nativeImageMetadataFormatClassName
包含此插件支持的本地流元数据格式的类名称的 String，该字符串最初为 null。

protected  String

ImageReaderWriterSpi.nativeImageMetadataFormatName
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。

protected  String

ImageReaderWriterSpi.nativeStreamMetadataFormatClassName
包含此插件支持的本地流元数据格式的类名称的 String，初始为 null。

protected  String

ImageReaderWriterSpi.nativeStreamMetadataFormatName
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。

protected  String

ImageReaderWriterSpi.pluginClassName
包含关联的插件类名称的 String，该字符串最初为 null。

protected  String[]

ImageWriterSpi.readerSpiNames
将从 getImageReaderSpiNames 返回的字符串数组，该数组最初为 null。

protected  String[]

ImageReaderWriterSpi.suffixes
从 getFileSuffixes 返回的字符串数组，该数组最初为 null。

protected  String

IIOServiceProvider.vendorName
将从 getVendorName 返回的一个 String，初始值为 null。

protected  String

IIOServiceProvider.version
将从 getVersion 返回的一个 String，初始值为 null。

protected  String[]

ImageReaderSpi.writerSpiNames
将从 getImageWriterSpiNames 返回的字符串数组，该数组最初为 null。

返回 String 的 javax.imageio.spi 中的方法

abstract  String

IIOServiceProvider.getDescription(Locale locale)
返回此服务提供者及其相关实现的一个简明的可读描述。

String[]

ImageReaderWriterSpi.getExtraImageMetadataFormatNames()
返回包含其他文档格式名称，而不是此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。

String[]

ImageReaderWriterSpi.getExtraStreamMetadataFormatNames()
返回包含其他文档格式名称，而不是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。

String[]

ImageReaderWriterSpi.getFileSuffixes()
返回一个包含通常可由与此服务提供者关联的 ImageReader 或 ImageWriter 实现所用格式所关联文件后缀列表的 String 数组。

String[]

ImageReaderWriterSpi.getFormatNames()
返回一个 String 数组，该数组包含通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的那些格式的可读名称。

String[]

ImageWriterSpi.getImageReaderSpiNames()
返回一个 String 数组，该数组包含所有能够理解由与此服务提供者关联的 ImageWriter 使用的内部元数据表示形式的 ImageReaderSpi 类的完全限定名。

String[]

ImageReaderSpi.getImageWriterSpiNames()
返回一个 String 数组，其包含所有能够理解由与此服务提供者关联的 ImageReader 使用的内部元数据表示形式的 ImageWriterSpi 类的完全限定名。

String[]

ImageReaderWriterSpi.getMIMETypes()
返回一个 String 数组，该数组包含与通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的格式有关的 MIME 类型的列表。

String

ImageReaderWriterSpi.getNativeImageMetadataFormatName()
返回此插件的“本地”图像元数据格式的名称，它通常允许无损失地编码或传输按照由此插件处理的格式存储的图像元数据。

String

ImageReaderWriterSpi.getNativeStreamMetadataFormatName()
返回此插件的“本地”流元数据格式的名称，它通常允许无损失地编码和传输按照由此插件处理的格式存储的流元数据。

String

ImageReaderWriterSpi.getPluginClassName()
返回与此服务提供者关联的 ImageReader 或 ImageWriter 插件的完全限定类名称。

abstract  String

ImageTranscoderSpi.getReaderServiceProviderName()
返回 ImageReaderSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。

String

IIOServiceProvider.getVendorName()
返回负责创建此服务提供者及其相关实现的供应商名称。

String

IIOServiceProvider.getVersion()
返回描述此服务提供者版本号及其相关实现的字符串。

abstract  String

ImageTranscoderSpi.getWriterServiceProviderName()
返回 ImageWriterSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。

参数类型为 String 的 javax.imageio.spi 中的方法

IIOMetadataFormat

ImageReaderWriterSpi.getImageMetadataFormat(String formatName)
返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

IIOMetadataFormat

ImageReaderWriterSpi.getStreamMetadataFormat(String formatName)
返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

参数类型为 String 的 javax.imageio.spi 中的构造方法

IIOServiceProvider(String vendorName, String version)
构造一个具有给定供应商名称和版本标识符的 IIOServiceProvider。

ImageInputStreamSpi(String vendorName, String version, Class<?> inputClass)
用给定的一组值构造 ImageInputStreamSpi。

ImageOutputStreamSpi(String vendorName, String version, Class<?> outputClass)
用给定的一组值构造 ImageOutputStreamSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

ImageTranscoderSpi(String vendorName, String version)
用给定的一组值构造 ImageTranscoderSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

javax.imageio.stream 中 String 的使用

返回 String 的 javax.imageio.stream 中的方法

String

ImageInputStream.readLine()
从输入流中读取文本的下一行。

String

ImageInputStreamImpl.readLine()

String

ImageInputStream.readUTF()
读入一个已使用 UTF-8 修改版格式编码的字符串。

String

ImageInputStreamImpl.readUTF()

参数类型为 String 的 javax.imageio.stream 中的方法

void

ImageOutputStream.writeBytes(String s)
将一个字符串写入输出流。

void

ImageOutputStreamImpl.writeBytes(String s)

void

ImageOutputStream.writeChars(String s)
将一个字符串写入输出流。

void

ImageOutputStreamImpl.writeChars(String s)

void

ImageOutputStream.writeUTF(String s)
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。

void

ImageOutputStreamImpl.writeUTF(String s)

javax.jws 中 String 的使用

参数类型为 String 的 javax.jws 中的方法

static WebParam.Mode

WebParam.Mode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.jws.soap 中 String 的使用

参数类型为 String 的 javax.jws.soap 中的方法

static SOAPBinding.Style

SOAPBinding.Style.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SOAPBinding.Use

SOAPBinding.Use.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SOAPBinding.ParameterStyle

SOAPBinding.ParameterStyle.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.lang.model 中 String 的使用

参数类型为 String 的 javax.lang.model 中的方法

static SourceVersion

SourceVersion.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.lang.model.element 中 String 的使用

返回 String 的 javax.lang.model.element 中的方法

String

AnnotationValue.toString()
返回此值的字符串表示形式。

String

Modifier.toString()
返回此修饰符的小写名称。

参数类型为 String 的 javax.lang.model.element 中的方法

static ElementKind

ElementKind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Modifier

Modifier.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static NestingKind

NestingKind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

R

AnnotationValueVisitor.visitString(String s, P p)
访问注释中的 string 值。

javax.lang.model.type 中 String 的使用

返回 String 的 javax.lang.model.type 中的方法

String

TypeMirror.toString()
返回包含此类型许多信息的字符串表示形式。

参数类型为 String 的 javax.lang.model.type 中的方法

static TypeKind

TypeKind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.lang.model.util 中 String 的使用

返回 String 的 javax.lang.model.util 中的方法

String

Elements.getConstantExpression(Object value)
返回表示基本值或字符串的常量表达式 文本。

String

Elements.getDocComment(Element e)
返回元素的文档（"Javadoc"）注释文本。

参数类型为 String 的 javax.lang.model.util 中的方法

R

SimpleAnnotationValueVisitor6.visitString(String s, P p)
访问注释中的 string 值。

javax.management 中 String 的使用

声明为 String 的 javax.management 中的字段

static String

AttributeChangeNotification.ATTRIBUTE_CHANGE
通知类型，指示所观察的 MBean 属性值已更改。

static String

JMX.DEFAULT_VALUE_FIELD
defaultValue 字段的名称。

protected  String

MBeanFeatureInfo.description
该功能的可读描述。

static String

JMX.IMMUTABLE_INFO_FIELD
immutableInfo 字段的名称。

static String

JMX.INTERFACE_CLASS_NAME_FIELD
interfaceClassName 字段的名称。

static String

JMX.LEGAL_VALUES_FIELD
legalValues 字段的名称。

static String

JMX.MAX_VALUE_FIELD
maxValue 字段的名称。

static String

JMX.MIN_VALUE_FIELD
minValue 字段的名称。

static String

JMX.MXBEAN_FIELD
mxbean 字段的名称。

protected  String

MBeanFeatureInfo.name
该功能的名称。

static String

JMX.OPEN_TYPE_FIELD
openType 字段的名称。

static String

JMX.ORIGINAL_TYPE_FIELD
originalType 字段的名称。

static String

MBeanServerNotification.REGISTRATION_NOTIFICATION
表示已注册该 MBean 的通知类型。

static String

MBeanServerNotification.UNREGISTRATION_NOTIFICATION
表示已注销该 MBean 的通知类型。

返回 String 的 javax.management 中的方法

String

MBeanPermission.getActions()
返回操作的“规范化字符串表示形式”。

String

AttributeChangeNotification.getAttributeName()
获得已更改属性的名称。

String

AttributeValueExp.getAttributeName()
返回该属性名称的字符串表示形式。

String

AttributeChangeNotification.getAttributeType()
获得已更改属性的类型。

String

ObjectName.getCanonicalKeyPropertyListString()
返回键属性列表的字符串表示形式，其中键属性按词汇顺序排序。

String

ObjectName.getCanonicalName()
返回该名称的规范形式；也就是说，一种字符串表示形式，其中属性按词汇顺序排序。

String

MBeanInfo.getClassName()
返回此 MBeanInfo 描述的 MBean 的 Java 类名。

String

ObjectInstance.getClassName()
返回类部分。

protected  String

StandardMBean.getClassName(MBeanInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。

String

MBeanServer.getDefaultDomain()

String

MBeanServerConnection.getDefaultDomain()
返回对 MBean 命名时使用的默认域。

String

MBeanFeatureInfo.getDescription()
返回该功能的可读描述。

String

MBeanInfo.getDescription()
返回该 MBean 的可读描述。

protected  String

StandardMBean.getDescription(MBeanAttributeInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanConstructorInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。

protected  String

StandardMBean.getDescription(MBeanFeatureInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanOperationInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。

protected  String

StandardMBean.getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。

String

ObjectName.getDomain()
返回域部分。

String[]

MBeanServer.getDomains()

String[]

MBeanServerConnection.getDomains()
返回其中所有 MBean 当前已注册的域的列表。

String[]

Descriptor.getFieldNames()
返回描述符中的所有字段名。

String[]

ImmutableDescriptor.getFieldNames()

String[]

Descriptor.getFields()
以 string 数组的形式返回此 descriptor 中所包含的所有字段。

String[]

ImmutableDescriptor.getFields()

String

MBeanServerDelegate.getImplementationName()
返回 JMX 实现的名称（此产品的名称）。

String

MBeanServerDelegateMBean.getImplementationName()
返回 JMX 实现名（此产品的名称）。

String

MBeanServerDelegate.getImplementationVendor()
返回 JMX 实现供应商（此产品的供应商）。

String

MBeanServerDelegateMBean.getImplementationVendor()
返回 JMX 实现供应商（此产品的供应商）。

String

MBeanServerDelegate.getImplementationVersion()
返回 JMX 实现的版本（此产品的版本）。

String

MBeanServerDelegateMBean.getImplementationVersion()
返回 JMX 实现版本（此产品的版本）。

String

ObjectName.getKeyProperty(String property)
获得与键属性中某个键相关联的值。

String

ObjectName.getKeyPropertyListString()
返回创建时指定的键属性列表的字符串表示形式。

String

MBeanServerDelegate.getMBeanServerId()
返回 MBean 服务器代理标识。

String

MBeanServerDelegateMBean.getMBeanServerId()
返回 MBean 服务器代理标识。

String

Notification.getMessage()
获得通知消息。

String

Attribute.getName()
返回包含该 Attribute 的名称的 String。

String

MBeanFeatureInfo.getName()
返回该功能的名称。

String[]

MBeanNotificationInfo.getNotifTypes()
返回包含 MBean 可发出的通知类型的字符串数组（用点表示）。

protected  String

StandardMBean.getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。

protected  String

StandardMBean.getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。

String

MBeanOperationInfo.getReturnType()
返回该方法的返回值的类型。

String

MBeanServerDelegate.getSpecificationName()
返回此产品实现的 JMX 规范的全名。

String

MBeanServerDelegateMBean.getSpecificationName()
返回此产品实现的 JMX 规范的全名。

String

MBeanServerDelegate.getSpecificationVendor()
返回此产品实现的 JMX 规范的供应商。

String

MBeanServerDelegateMBean.getSpecificationVendor()
返回此产品实现的 JMX 规范的供应商。

String

MBeanServerDelegate.getSpecificationVersion()
返回此产品实现的 JMX 规范的版本。

String

MBeanServerDelegateMBean.getSpecificationVersion()
返回此产品实现的 JMX 规范的版本。

String

MBeanAttributeInfo.getType()
返回该属性的类名。

String

MBeanParameterInfo.getType()
返回该数据的类型或类名。

String

Notification.getType()
获得通知类型。

String

StringValueExp.getValue()
返回由 StringValueExp 实例表示的字符串。

static String

ObjectName.quote(String s)
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。

String

Attribute.toString()
返回一个表示此 Attribute 值 String 对象。

String

AttributeValueExp.toString()
返回表示其值的字符串。

String

BadAttributeValueExpException.toString()
返回该对象的字符串表示形式。

String

BadBinaryOpValueExpException.toString()
返回该对象的字符串表示形式。

String

BadStringOperationException.toString()
返回该对象的字符串表示形式。

String

ImmutableDescriptor.toString()

String

MBeanAttributeInfo.toString()

String

MBeanConstructorInfo.toString()

String

MBeanInfo.toString()

String

MBeanNotificationInfo.toString()

String

MBeanOperationInfo.toString()

String

MBeanParameterInfo.toString()

String

Notification.toString()
返回此通知的字符串表示形式。

String

ObjectInstance.toString()
返回表示此 ObjectInstance 对象字符串。

String

ObjectName.toString()
返回该对象名的字符串表示形式。

String

StringValueExp.toString()
返回表示对象的字符串。

static String

ObjectName.unquote(String q)
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

返回变量类型为 String 的类型的 javax.management 中的方法

Vector<String>

AttributeChangeNotificationFilter.getEnabledAttributes()
获得此过滤器的所有已启用属性名称。

Vector<String>

NotificationFilterSupport.getEnabledTypes()
获得此过滤器的所有允许通知类型。

Hashtable<String,String>

ObjectName.getKeyPropertyList()
以哈希表的形式返回键属性。

Hashtable<String,String>

ObjectName.getKeyPropertyList()
以哈希表的形式返回键属性。

参数类型为 String 的 javax.management 中的方法

static AttributeValueExp

Query.attr(String name)
返回新的属性表达式。

static AttributeValueExp

Query.attr(String className, String name)
返回新的限定属性表达式。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

static MBeanServer

MBeanServerFactory.createMBeanServer(String domain)
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。

ObjectInputStream

MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。

ObjectInputStream

MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。

void

AttributeChangeNotificationFilter.disableAttribute(String name)
禁用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定属性名称。

void

NotificationFilterSupport.disableType(String prefix)
从前缀列表中移除给定的前缀。

void

AttributeChangeNotificationFilter.enableAttribute(String name)
启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。

void

NotificationFilterSupport.enableType(String prefix)
允许将其类型以指定前缀开始的所有通知发送到该侦听器。

static ArrayList<MBeanServer>

MBeanServerFactory.findMBeanServer(String agentId)
返回已注册 MBeanServer 对象的列表。

Object

MBeanServer.getAttribute(ObjectName name, String attribute)

Object

MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。

Object

DynamicMBean.getAttribute(String attribute)
获得 Dynamic MBean 的特定属性的值。

Object

StandardMBean.getAttribute(String attribute)

AttributeList

MBeanServer.getAttributes(ObjectName name, String[] attributes)

AttributeList

MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
获得指定 MBean 的多个属性值。

AttributeList

DynamicMBean.getAttributes(String[] attributes)
获得 Dynamic MBean 多个属性的值。

AttributeList

StandardMBean.getAttributes(String[] attributes)

Object

Descriptor.getFieldValue(String fieldName)
返回指定字段名的值，如果该名称不存在任何值，则返回 null。

Object

ImmutableDescriptor.getFieldValue(String fieldName)

Object[]

Descriptor.getFieldValues(String... fieldNames)
以 Object 数组的形式返回该 descriptor 中的所有字段值。

Object[]

ImmutableDescriptor.getFieldValues(String... fieldNames)

static ObjectName

ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。

static ObjectName

ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

static ObjectName

ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。

String

ObjectName.getKeyProperty(String property)
获得与键属性中某个键相关联的值。

Object

MBeanServer.instantiate(String className)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

boolean

MBeanServer.isInstanceOf(ObjectName name, String className)

boolean

MBeanServerConnection.isInstanceOf(ObjectName name, String className)
如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。

boolean

ObjectName.isPropertyValuePattern(String property)
检查键属性中与值关联的值是否为一个模式。

static Class

DefaultLoaderRepository.loadClass(String className)
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。

static Class

DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className)
已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。

static MBeanServer

MBeanServerFactory.newMBeanServer(String domain)
返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。

MBeanServer

MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
此方法创建一个新的 MBeanServer 实现对象。

static String

ObjectName.quote(String s)
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。

void

Descriptor.removeField(String fieldName)
从该 descriptor 中删除字段。

void

ImmutableDescriptor.removeField(String fieldName)
从描述符移除字段。

void

Descriptor.setField(String fieldName, Object fieldValue)
设置特定字段名的值。

void

ImmutableDescriptor.setField(String fieldName, Object fieldValue)
因为此类不可变，所以不支持此操作。

void

Descriptor.setFields(String[] fieldNames, Object[] fieldValues)
将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。

void

ImmutableDescriptor.setFields(String[] fieldNames, Object[] fieldValues)
因为此类不可变，所以不支持此操作。

static String

ObjectName.unquote(String q)
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。

static StringValueExp

Query.value(String val)
返回一个新的字符串表达式。

类型变量类型为 String 的 javax.management 中的方法参数

static ObjectName

ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

static ObjectName

ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

参数类型为 String 的 javax.management 中的构造方法

Attribute(String name, Object value)
构造将给定的属性名与给定值相关联的 Attribute 对象。

AttributeChangeNotification(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)
构造一个 AttributeChangeNotification 对象。

AttributeNotFoundException(String message)
允许指定具体错误消息的构造方法。

AttributeValueExp(String attr)
创建一个表示指定对象属性 attr 的新 AttributeValueExp。

BadStringOperationException(String message)
构造带指定详细消息的 BadStringOperationException。

ImmutableDescriptor(String... fields)
构造包含给定字段的描述符。

ImmutableDescriptor(String[] fieldNames, Object[] fieldValues)
构造包含给定字段和值的描述符。

InstanceAlreadyExistsException(String message)
允许指定特定错误消息的构造方法。

InstanceNotFoundException(String message)
允许指定特定错误消息的构造方法。

IntrospectionException(String message)
允许指定特定错误消息的构造方法。

InvalidAttributeValueException(String message)
允许指定特定错误消息的构造方法。

JMException(String msg)
允许指定特定错误消息的构造方法。

JMRuntimeException(String message)
允许指定特定错误消息的构造方法。

ListenerNotFoundException(String message)
允许指定特定错误消息的构造方法。

MalformedObjectNameException(String message)
允许指定特定错误消息的构造方法。

MBeanAttributeInfo(String name, String description, Method getter, Method setter)
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。

MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 MBeanAttributeInfo 对象。

MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 MBeanAttributeInfo 对象。

MBeanConstructorInfo(String description, Constructor constructor)
构造一个 MBeanConstructorInfo 对象。

MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造一个 MBeanConstructorInfo 对象。

MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。

MBeanException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。

MBeanFeatureInfo(String name, String description)
构造一个 MBeanFeatureInfo 对象。

MBeanFeatureInfo(String name, String description, Descriptor descriptor)
构造一个 MBeanFeatureInfo 对象。

MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。

MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

MBeanNotificationInfo(String[] notifTypes, String name, String description)
构造一个 MBeanNotificationInfo 对象。

MBeanNotificationInfo(String[] notifTypes, String name, String description)
构造一个 MBeanNotificationInfo 对象。

MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。

MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。

MBeanOperationInfo(String description, Method method)
构造一个 MBeanOperationInfo 对象。

MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造一个 MBeanOperationInfo 对象。

MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。

MBeanParameterInfo(String name, String type, String description)
构造一个 MBeanParameterInfo 对象。

MBeanParameterInfo(String name, String type, String description, Descriptor descriptor)
构造一个 MBeanParameterInfo 对象。

MBeanPermission(String name, String actions)
创建具有指定目标名称和操作的新 MBeanPermission 对象。

MBeanPermission(String className, String member, ObjectName objectName, String actions)
创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。

MBeanRegistrationException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。

MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。

MBeanServerPermission(String name)
创建具有给定名称的新 MBeanServerPermission。

MBeanServerPermission(String name, String actions)
创建具有给定名称的新 MBeanServerPermission。

MBeanTrustPermission(String name)
创建具有给定名称的新 MBeanTrustPermission。

MBeanTrustPermission(String name, String actions)
创建具有给定名称的新 MBeanTrustPermission。

NotCompliantMBeanException(String message)
允许指定具体错误消息的构造方法。

Notification(String type, Object source, long sequenceNumber)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp, String message)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, String message)
创建一个 Notification 对象。

ObjectInstance(ObjectName objectName, String className)
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。

ObjectInstance(String objectName, String className)
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。

ObjectName(String name)
根据给定的字符串构造一个对象名。

ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

ObjectName(String domain, String key, String value)
构造只具有一个键属性的对象名。

OperationsException(String message)
允许指定具体错误消息的构造方法。

ReflectionException(Exception e, String message)
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。

RuntimeErrorException(Error e, String message)
允许指定特定错误消息的构造方法。

RuntimeMBeanException(RuntimeException e, String message)
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。

RuntimeOperationsException(RuntimeException e, String message)
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。

ServiceNotFoundException(String message)
允许指定特定错误消息的构造方法。

StringValueExp(String val)
创建表示给定字符串的新 StringValueExp。

类型变量类型为 String 的 javax.management 中的构造方法参数

ImmutableDescriptor(Map<String,?> fields)
构造一个描述符，其中字段名称和值是给定 Map 的键和值。

ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

javax.management.loading 中 String 的使用

返回 String 的 javax.management.loading 中的方法

protected  String

MLet.findLibrary(String libname)
返回本机库的绝对路径名称。

String

MLetContent.getCode()
获取 MLET 标记的 CODE 属性的值。

String

MLetContent.getJarFiles()
获取由 MLET 标记的 ARCHIVE 属性指定的 .jar 文件的列表。

String

MLet.getLibraryDirectory()
获取库加载器在将本机库加载到内存中之前用于存储这些本机库的当前目录。

String

MLetMBean.getLibraryDirectory()
获取在将本机库加载到内存中之前库加载器用来存储这些本机库的当前目录。

String

MLetContent.getName()
获取 MLET 标记的 NAME 属性的值。

String

MLetContent.getSerializedObject()
获取 MLET 标记的 OBJECT 属性的值。

String

MLetContent.getVersion()
获取 MLET 标记的 VERSION 属性的值。

返回变量类型为 String 的类型的 javax.management.loading 中的方法

Map<String,String>

MLetContent.getAttributes()
获取 MLET 标记的属性。

Map<String,String>

MLetContent.getAttributes()
获取 MLET 标记的属性。

List<String>

MLetContent.getParameterTypes()
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。

List<String>

MLetContent.getParameterValues()
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。

参数类型为 String 的 javax.management.loading 中的方法

void

MLet.addURL(String url)
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

void

MLetMBean.addURL(String url)
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

protected  URL

MLet.check(String version, URL codebase, String jarfile, MLetContent mlet)
当扩展此服务来支持缓存和版本控制时，要重写此方法。

protected  Class<?>

MLet.findClass(String name)
这是要重新定义的类加载器的主要方法。

protected  String

MLet.findLibrary(String libname)
返回本机库的绝对路径名称。

Set<Object>

MLet.getMBeansFromURL(String url)
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLetMBean.getMBeansFromURL(String url)
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

URL

MLetMBean.getResource(String name)
查找具有给定名称的资源。

InputStream

MLetMBean.getResourceAsStream(String name)
返回读取指定资源的输入流。

Enumeration<URL>

MLetMBean.getResources(String name)
查找所有具有给定名称的资源。

Class<?>

ClassLoaderRepository.loadClass(String className)
通过类加载器列表加载给定的类名称。

static Class

DefaultLoaderRepository.loadClass(String className)
已过时。 仔细检查类加载器列表，并尝试加载所请求的类。

Class<?>

MLet.loadClass(String name, ClassLoaderRepository clr)
如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。

Class<?>

ClassLoaderRepository.loadClassBefore(ClassLoader stop, String className)
通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。

Class<?>

ClassLoaderRepository.loadClassWithout(ClassLoader exclude, String className)
通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。

static Class

DefaultLoaderRepository.loadClassWithout(ClassLoader loader, String className)
已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。

void

MLet.setLibraryDirectory(String libdir)
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。

void

MLetMBean.setLibraryDirectory(String libdir)
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。

类型变量类型为 String 的 javax.management.loading 中的构造方法参数

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

javax.management.modelmbean 中 String 的使用

返回 String 的 javax.management.modelmbean 中的方法

String

ModelMBeanInfo.getClassName()
返回此 MBeanInfo 所描述的 MBean 的 Java 类名称。

String

ModelMBeanInfo.getDescription()
返回 MBean 的可读描述。

String[]

DescriptorSupport.getFieldNames()

String[]

DescriptorSupport.getFields()

String

DescriptorSupport.toString()
返回表示描述符的可读字符串。

String

ModelMBeanAttributeInfo.toString()
返回 ModelMBeanAttributeInfo 实例的可读版本。

String

ModelMBeanConstructorInfo.toString()
以可读形式返回包含 ModelMBeanConstructorInfo 全部内容的字符串。

String

ModelMBeanNotificationInfo.toString()
返回包含 ModelMBeanNotificationInfo 的可读字符串。

String

ModelMBeanOperationInfo.toString()
以可读形式返回包含 ModelMBeanOperationInfo 全部内容的字符串。

String

DescriptorSupport.toXMLString()
返回表示描述符的 XML 字符串。

参数类型为 String 的 javax.management.modelmbean 中的方法

void

ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback)
注册一个将 NotificationListener 接口实现为侦听器的对象。

void

RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)

ModelMBeanAttributeInfo

ModelMBeanInfo.getAttribute(String inName)
返回通过名称请求的 ModelMBeanAttributeInfo。

ModelMBeanAttributeInfo

ModelMBeanInfoSupport.getAttribute(String inName)

Object

RequiredModelMBean.getAttribute(String attrName)
返回为此 ModelMBean 定义的指定属性的值。

AttributeList

RequiredModelMBean.getAttributes(String[] attrNames)
返回 ModelMBean 中几个属性的值。

ModelMBeanConstructorInfo

ModelMBeanInfoSupport.getConstructor(String inName)
返回通过名称请求的 ModelMBeanConstructorInfo。

Descriptor

ModelMBeanInfoSupport.getDescriptor(String inDescriptorName)
返回通过名称请求的 Descriptor。

Descriptor

ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType)
返回通过 name 和 descriptorType 请求的 Descriptor。

Descriptor

ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)

Descriptor[]

ModelMBeanInfo.getDescriptors(String inDescriptorType)
返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。

Descriptor[]

ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)

Object

DescriptorSupport.getFieldValue(String fieldName)

Object[]

DescriptorSupport.getFieldValues(String... fieldNames)

ModelMBeanNotificationInfo

ModelMBeanInfo.getNotification(String inName)
返回通过名称请求的 ModelMBeanNotificationInfo。

ModelMBeanNotificationInfo

ModelMBeanInfoSupport.getNotification(String inName)

ModelMBeanOperationInfo

ModelMBeanInfo.getOperation(String inName)
返回通过名称请求的 ModelMBeanOperationInfo。

ModelMBeanOperationInfo

ModelMBeanInfoSupport.getOperation(String inName)

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

void

ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName)
从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。

void

RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)

void

DescriptorSupport.removeField(String fieldName)

void

ModelMBeanNotificationBroadcaster.sendNotification(String ntfyText)
将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。

void

RequiredModelMBean.sendNotification(String ntfyText)

void

ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。

void

ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)

void

DescriptorSupport.setField(String fieldName, Object fieldValue)

void

DescriptorSupport.setFields(String[] fieldNames, Object[] fieldValues)

void

ModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。

void

RequiredModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。

参数类型为 String 的 javax.management.modelmbean 中的构造方法

DescriptorSupport(String... fields)
带有 fieldName=fieldValue 格式的字段的构造方法。

DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。

DescriptorSupport(String[] fieldNames, Object[] fieldValues)
带有字段名称和字段值的构造方法。

InvalidTargetObjectTypeException(Exception e, String s)
带有异常和字符串的构造方法。

InvalidTargetObjectTypeException(String s)
根据字符串进行构造的构造方法。

ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。

ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

ModelMBeanConstructorInfo(String description, Constructor constructorMethod)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。

ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。

ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。

ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。

ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。

ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description)
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description)
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。

ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。

ModelMBeanOperationInfo(String description, Method operationMethod)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。

ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。

ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

XMLParseException(Exception e, String s)
带有字符串和异常的构造方法。

XMLParseException(String s)
带有字符串的构造方法。

javax.management.monitor 中 String 的使用

声明为 String 的 javax.management.monitor 中的字段

protected  String

Monitor.dbgTag
已过时。 无替代版本。

static String

MonitorNotification.OBSERVED_ATTRIBUTE_ERROR
表示被观察属性未包含在被观察对象中的通知类型。

static String

MonitorNotification.OBSERVED_ATTRIBUTE_TYPE_ERROR
表示被观察属性的类型不正确的通知类型。

static String

MonitorNotification.OBSERVED_OBJECT_ERROR
表示被观察对象未在 MBean 服务器中注册的通知类型。

static String

MonitorNotification.RUNTIME_ERROR
表示在尝试获取被观察属性的值时发生未预定义的错误类型的通知类型。

static String

MonitorNotification.STRING_TO_COMPARE_VALUE_DIFFERED
表示被观察属性与“要比较的字符串”值不同的通知类型。

static String

MonitorNotification.STRING_TO_COMPARE_VALUE_MATCHED
表示被观察属性与“要比较的字符串”值匹配的通知类型。

static String

MonitorNotification.THRESHOLD_ERROR
表示阈值类型、偏移量或模不正确的通知类型。

static String

MonitorNotification.THRESHOLD_HIGH_VALUE_EXCEEDED
表示被观察属性已超出高阈值的通知类型。

static String

MonitorNotification.THRESHOLD_LOW_VALUE_EXCEEDED
表示被观察属性已超出低阈值的通知类型。

static String

MonitorNotification.THRESHOLD_VALUE_EXCEEDED
表示被观察属性已达到阈值的通知类型。

返回 String 的 javax.management.monitor 中的方法

String

StringMonitor.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitor.getDerivedGauge(ObjectName) 取代

String

StringMonitorMBean.getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 StringMonitorMBean.getDerivedGauge(ObjectName) 取代

String

StringMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。

String

StringMonitorMBean.getDerivedGauge(ObjectName object)
获取指定 MBean 的派生尺度。

String

Monitor.getObservedAttribute()
获取要观察的属性。

String

MonitorMBean.getObservedAttribute()
获取要观察的属性。

String

MonitorNotification.getObservedAttribute()
获取此监视器通知的被观察属性。

String

StringMonitor.getStringToCompare()
获取要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。

String

StringMonitorMBean.getStringToCompare()
获取要与 observed 属性进行比较的字符串。

参数类型为 String 的 javax.management.monitor 中的方法

void

Monitor.setObservedAttribute(String attribute)
设置要观察的属性。

void

MonitorMBean.setObservedAttribute(String attribute)
设置要观察的属性。

void

StringMonitor.setStringToCompare(String value)
设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。

void

StringMonitorMBean.setStringToCompare(String value)
设置要与 observed 属性进行比较的字符串。

参数类型为 String 的 javax.management.monitor 中的构造方法

MonitorSettingException(String message)
允许指定错误消息的构造方法。

javax.management.openmbean 中 String 的使用

声明为 String 的 javax.management.openmbean 中的字段

static String[]

OpenType.ALLOWED_CLASSNAMES
已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。

类型参数类型为 String 的 javax.management.openmbean 中的字段

static List<String>

OpenType.ALLOWED_CLASSNAMES_LIST
开放数据值允许的 Java 类的完全限定名称的列表。

static SimpleType<String>

SimpleType.STRING
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。

返回 String 的 javax.management.openmbean 中的方法

String

OpenMBeanInfo.getClassName()
返回此 OpenMBeanInfo 描述的 open MBean 实例的完全限定的 Java 类名。

String

OpenType.getClassName()
返回此开放类型描述的开放数据值的完全限定的 Java 类名。

String

OpenMBeanConstructorInfo.getDescription()
返回此 OpenMBeanConstructorInfo 实例描述的构造方法的可读描述。

String

OpenMBeanInfo.getDescription()
返回此 OpenMBeanInfo 描述的 open MBean 实例的类型的可读描述。

String

OpenMBeanOperationInfo.getDescription()
返回此 OpenMBeanOperationInfo 实例描述的操作的可读描述。

String

OpenMBeanParameterInfo.getDescription()
返回此 OpenMBeanParameterInfo 实例描述的参数的可读描述。

String

OpenType.getDescription()
返回此 OpenType 实例的文本描述。

String

CompositeType.getDescription(String itemName)
返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

String

OpenMBeanConstructorInfo.getName()
返回此 OpenMBeanConstructorInfo 实例描述的构造方法名称。

String

OpenMBeanOperationInfo.getName()
返回此 OpenMBeanOperationInfo 实例描述的操作名称。

String

OpenMBeanParameterInfo.getName()
返回此 OpenMBeanParameterInfo 实例描述的参数名称。

String

OpenMBeanOperationInfo.getReturnType()
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的完全限定的 Java 类名。

String

OpenType.getTypeName()
返回此 OpenType 实例的名称。

String

ArrayType.toString()
返回此 ArrayType 实例的字符串表示形式。

String

CompositeData.toString()
返回此 CompositeData 实例的字符串表示形式。

String

CompositeDataSupport.toString()
返回此 CompositeDataSupport 实例的字符串表示形式。

String

CompositeType.toString()
返回此 CompositeType 实例的字符串表示形式。

String

OpenMBeanAttributeInfo.toString()
返回此 OpenMBeanAttributeInfo 实例的字符串表示形式。

String

OpenMBeanAttributeInfoSupport.toString()
返回此 OpenMBeanAttributeInfoSupport 实例的字符串表示形式。

String

OpenMBeanConstructorInfo.toString()
返回此 OpenMBeanConstructorInfo 实例的字符串表示形式。

String

OpenMBeanConstructorInfoSupport.toString()
返回此 OpenMBeanConstructorInfoSupport 实例的字符串表示形式。

String

OpenMBeanInfo.toString()
返回此 OpenMBeanInfo 实例的字符串表示形式。

String

OpenMBeanInfoSupport.toString()
返回此 OpenMBeanInfoSupport 实例的字符串表示形式。

String

OpenMBeanOperationInfo.toString()
返回此 OpenMBeanOperationInfo 实例的字符串表示形式。

String

OpenMBeanOperationInfoSupport.toString()
返回此 OpenMBeanOperationInfoSupport 实例的字符串表示形式。

String

OpenMBeanParameterInfo.toString()
返回此 OpenMBeanParameterInfo 实例的字符串表示形式。

String

OpenMBeanParameterInfoSupport.toString()
返回此 OpenMBeanParameterInfoSupport 实例的字符串表示形式。

abstract  String

OpenType.toString()
返回此开放类型实例的字符串表示形式。

String

SimpleType.toString()
返回此 SimpleType 实例的字符串表示形式。

String

TabularData.toString()
返回此 TabularData 实例的字符串表示形式。

String

TabularDataSupport.toString()
返回此 TabularDataSupport 实例的字符串表示形式。

String

TabularType.toString()
返回此 TabularType 实例的字符串表示形式。

返回变量类型为 String 的类型的 javax.management.openmbean 中的方法

List<String>

TabularType.getIndexNames()
按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。

Set<String>

CompositeType.keySet()
返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。

参数类型为 String 的 javax.management.openmbean 中的方法

boolean

CompositeData.containsKey(String key)
当且仅当此 CompositeData 实例包含名称为 key 的项时，返回 true。

boolean

CompositeDataSupport.containsKey(String key)
当且仅当此 CompositeData 实例包含名称是 key 的项时，才返回 true。

boolean

CompositeType.containsKey(String itemName)
如果此 CompositeType 实例定义了名称为 itemName 的项，则返回 true。

Object

CompositeData.get(String key)
返回名称为 key 的项的值。

Object

CompositeDataSupport.get(String key)
返回其名称是 key 的项的值。

Object[]

CompositeData.getAll(String[] keys)
返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。

Object[]

CompositeDataSupport.getAll(String[] keys)
返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。

String

CompositeType.getDescription(String itemName)
返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

OpenType<?>

CompositeType.getType(String itemName)
返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

参数类型为 String 的 javax.management.openmbean 中的构造方法

CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。

CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。

CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。

CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。

InvalidKeyException(String msg)
带详细消息的 InvalidKeyException。

InvalidOpenTypeException(String msg)
带详细消息的 InvalidOpenTypeException。

KeyAlreadyExistsException(String msg)
带详细消息的 KeyAlreadyExistsException。

OpenDataException(String msg)
带详细消息的 OpenDataException。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。

OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。

OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。

OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。

OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。

OpenType(String className, String typeName, String description)
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。

TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

类型变量类型为 String 的 javax.management.openmbean 中的构造方法参数

CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。

javax.management.relation 中 String 的使用

声明为 String 的 javax.management.relation 中的字段

static String

RelationNotification.RELATION_BASIC_CREATION
内部关系的创建类型。

static String

RelationNotification.RELATION_BASIC_REMOVAL
从内部关系的 Relation Service 中移除的类型。

static String

RelationNotification.RELATION_BASIC_UPDATE
内部关系的更新类型。

static String

RelationNotification.RELATION_MBEAN_CREATION
添加到 Relation Service 中的关系 MBean 的类型。

static String

RelationNotification.RELATION_MBEAN_REMOVAL
从关系 MBean 的 Relation Service 中移除的类型。

static String

RelationNotification.RELATION_MBEAN_UPDATE
关系 MBean 的更新类型。

返回 String 的 javax.management.relation 中的方法

String

RoleInfo.getDescription()
返回角色的描述文本。

String

RoleInfo.getName()
返回角色名称。

String

RoleInfo.getRefMBeanClassName()
返回期望在相应角色中引用的 MBean 的类型名称。

String

Relation.getRelationId()
返回关系标识符（用于唯一标识 Relation Service 内的关系）。

String

RelationNotification.getRelationId()
返回创建/移除/更新的关系的关系标识符。

String

RelationSupport.getRelationId()
返回关系标识符（用于唯一标识 Relation Service 中的关系）。

String

Relation.getRelationTypeName()
返回相关关系类型的名称。

String

RelationNotification.getRelationTypeName()
返回创建/移除/更新的关系的关系类型名称。

String

RelationSupport.getRelationTypeName()
返回相关关系类型的名称。

String

RelationType.getRelationTypeName()
返回关系类型名称。

String

RelationTypeSupport.getRelationTypeName()
返回关系类型名称。

String

RelationService.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

String

RelationServiceMBean.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

String

RelationNotification.getRoleName()
返回更新关系的更新角色的名称（仅限于角色更新）。

String

Role.getRoleName()
检索角色名称。

String

RoleUnresolved.getRoleName()
检索角色名称。

String

RelationService.isRelation(ObjectName objectName)
如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。

String

RelationServiceMBean.isRelation(ObjectName objectName)
如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。

static String

Role.roleValueToString(List<ObjectName> roleValue)
返回给定角色值的字符串。

String

Role.toString()
返回描述角色的字符串。

String

RoleInfo.toString()
返回描述角色信息的字符串。

String

RoleUnresolved.toString()
返回描述此对象的字符串。

返回变量类型为 String 的类型的 javax.management.relation 中的方法

Map<ObjectName,List<String>>

RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<String,List<String>>

RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在引用给定 MBean 的引用关系。

Map<String,List<String>>

RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在引用给定 MBean 的引用关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在其中引用给定 MBean 的关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在其中引用给定 MBean 的关系。

List<String>

RelationService.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

List<String>

RelationServiceMBean.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

List<String>

RelationService.getAllRelationIds()
返回由 Relation Service 处理的所有关系的所有关系 id。

List<String>

RelationServiceMBean.getAllRelationIds()
返回由 Relation Service 处理的所有关系的所有关系 id。

List<String>

RelationService.getAllRelationTypeNames()
检索所有已知关系类型的名称。

List<String>

RelationServiceMBean.getAllRelationTypeNames()
检索所有已知关系类型的名称。

Map<ObjectName,List<String>>

Relation.getReferencedMBeans()
检索在该关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationSupport.getReferencedMBeans()
检索在该关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationService.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

参数类型为 String 的 javax.management.relation 中的方法

Integer

RelationService.checkRoleReading(String roleName, String relationTypeName)
检查给定 Role 能否以给定类型的关系进行读取。

Integer

RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName)
检查给定 Role 能否在给定类型的关系中读取。

Integer

RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
检查给定 Role 能否以给定类型的关系进行设置。

Integer

RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag)
检查给定 Role 能否在给定类型的关系中设置。

void

RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList)
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

void

RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList)
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

void

RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

void

RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray)
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

Map<ObjectName,List<String>>

RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName)
检索与关系中给定关系相关的 MBean。

Map<String,List<String>>

RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在引用给定 MBean 的引用关系。

Map<String,List<String>>

RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName)
检索在其中引用给定 MBean 的关系。

List<String>

RelationService.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

List<String>

RelationServiceMBean.findRelationsOfType(String relationTypeName)
返回给定类型的关系的关系 id。

RoleResult

RelationService.getAllRoles(String relationId)
返回关系中存在的所有角色。

RoleResult

RelationServiceMBean.getAllRoles(String relationId)
返回关系中存在的所有角色。

Map<ObjectName,List<String>>

RelationService.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

Map<ObjectName,List<String>>

RelationServiceMBean.getReferencedMBeans(String relationId)
检索关系的各种角色中引用的 MBean。

String

RelationService.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

String

RelationServiceMBean.getRelationTypeName(String relationId)
返回给定关系的相关关系类型的名称。

List<ObjectName>

Relation.getRole(String roleName)
检索给定角色名称的角色值。

List<ObjectName>

RelationSupport.getRole(String roleName)
检索给定角色名称的角色值。

List<ObjectName>

RelationService.getRole(String relationId, String roleName)
检索给定关系中给定角色名称的角色值。

List<ObjectName>

RelationServiceMBean.getRole(String relationId, String roleName)
检索给定关系中给定角色名称的角色值。

Integer

Relation.getRoleCardinality(String roleName)
返回当前在给定角色中引用的 MBean 数。

Integer

RelationSupport.getRoleCardinality(String roleName)
返回当前在给定角色中引用的 MBean 数。

Integer

RelationService.getRoleCardinality(String relationId, String roleName)
检索给定角色中当前引用的 MBean 数。

Integer

RelationServiceMBean.getRoleCardinality(String relationId, String roleName)
检索给定角色中当前引用的 MBean 数。

RoleInfo

RelationType.getRoleInfo(String roleInfoName)
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。

RoleInfo

RelationTypeSupport.getRoleInfo(String roleInfoName)
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。

RoleInfo

RelationService.getRoleInfo(String relationTypeName, String roleInfoName)
检索给定关系类型的给定角色名称的角色信息。

RoleInfo

RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName)
检索给定关系类型的给定角色的角色信息。

List<RoleInfo>

RelationService.getRoleInfos(String relationTypeName)
检索给定关系类型的角色信息（RoleInfo 对象）的列表。

List<RoleInfo>

RelationServiceMBean.getRoleInfos(String relationTypeName)
检索给定关系类型的角色信息（RoleInfo 对象）的列表。

RoleResult

Relation.getRoles(String[] roleNameArray)
检索具有给定名称的角色值。

RoleResult

RelationSupport.getRoles(String[] roleNameArray)
检索具有给定名称的角色值。

RoleResult

RelationService.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

RoleResult

RelationService.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

RoleResult

RelationServiceMBean.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

RoleResult

RelationServiceMBean.getRoles(String relationId, String[] roleNameArray)
检索给定关系中具有给定名称的角色值。

void

Relation.handleMBeanUnregistration(ObjectName objectName, String roleName)
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。

void

RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName)
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。

Boolean

RelationService.hasRelation(String relationId)
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。

Boolean

RelationServiceMBean.hasRelation(String relationId)
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。

ObjectName

RelationService.isRelationMBean(String relationId)
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。

ObjectName

RelationServiceMBean.isRelationMBean(String relationId)
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。

void

RelationService.removeRelation(String relationId)
从 Relation Service 移除给定的关系。

void

RelationServiceMBean.removeRelation(String relationId)
从 Relation Service 移除给定的关系。

void

RelationService.removeRelationType(String relationTypeName)
从 Relation Service 中移除给定的关系类型。

void

RelationServiceMBean.removeRelationType(String relationTypeName)
从 Relation Service 中移除给定的关系类型。

void

RelationService.sendRelationCreationNotification(String relationId)
发送关系创建通知 (RelationNotification)。

void

RelationServiceMBean.sendRelationCreationNotification(String relationId)
发送关系创建通知 (RelationNotification)。

void

RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
发送关系移除通知 (RelationNotification)。

void

RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList)
发送关系移除通知 (RelationNotification)。

void

RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue)
发送给定关系中的角色更新通知 (RelationNotification)。

void

RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue)
发送给定关系中的角色更新通知 (RelationNotification)。

void

RelationService.setRole(String relationId, Role role)
设置给定关系中的给定角色。

void

RelationServiceMBean.setRole(String relationId, Role role)
以给定关系设置给定角色。

void

Role.setRoleName(String roleName)
设置角色名称。

void

RoleUnresolved.setRoleName(String name)
设置角色名称。

RoleResult

RelationService.setRoles(String relationId, RoleList roleList)
设置给定关系中的给定角色。

RoleResult

RelationServiceMBean.setRoles(String relationId, RoleList roleList)
以给定关系设置给定角色。

void

RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue)
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

void

RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue)
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

参数类型为 String 的 javax.management.relation 中的构造方法

InvalidRelationIdException(String message)
异常中放置了给定消息的构造方法。

InvalidRelationServiceException(String message)
异常中放置了给定消息的构造方法。

InvalidRelationTypeException(String message)
异常中放置了给定消息的构造方法。

InvalidRoleInfoException(String message)
异常中放置了给定消息的构造方法。

InvalidRoleValueException(String message)
异常中放置了给定消息的构造方法。

RelationException(String message)
异常中放置了给定消息的构造方法。

RelationNotFoundException(String message)
异常中放置了给定消息的构造方法。

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。

RelationServiceNotRegisteredException(String message)
异常中放置了给定消息的构造方法。

RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

RelationTypeNotFoundException(String message)
异常中放置了给定消息的构造方法。

RelationTypeSupport(String relationTypeName)
用于子类的构造方法。

RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。

Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。

RoleInfo(String roleName, String mbeanClassName)
构造方法。

RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。

RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

RoleInfoNotFoundException(String message)
异常中放置了给定消息的构造方法。

RoleNotFoundException(String message)
异常中放置了给定消息的构造方法。

RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。

javax.management.remote 中 String 的使用

声明为 String 的 javax.management.remote 中的字段

static String

JMXConnectorServer.AUTHENTICATOR
为连接器服务器指定经验证的属性名称。

static String

JMXConnectionNotification.CLOSED
关闭连接通知的通知类型字符串。

static String

JMXConnector.CREDENTIALS
属性的名称，它指定了连接过程中发送给连接器服务器的凭据。

static String

JMXConnectorFactory.DEFAULT_CLASS_LOADER
指定默认的类加载器的属性名称。

static String

JMXConnectorServerFactory.DEFAULT_CLASS_LOADER
指定默认的类加载器的属性名称。

static String

JMXConnectorServerFactory.DEFAULT_CLASS_LOADER_NAME
指定默认的类加载器 MBean 名称的属性名称。

static String

JMXConnectionNotification.FAILED
连接失败通知的通知类型字符串。

static String

JMXConnectionNotification.NOTIFS_LOST
可能已丢失通知的连接的通知类型字符串。

static String

JMXConnectionNotification.OPENED
打开连接通知的通知类型字符串。

static String

JMXConnectorFactory.PROTOCOL_PROVIDER_CLASS_LOADER
指定用于加载协议提供者的类加载器的属性名称。

static String

JMXConnectorServerFactory.PROTOCOL_PROVIDER_CLASS_LOADER
指定用于加载协议提供者的类加载器的属性名称。

static String

JMXConnectorFactory.PROTOCOL_PROVIDER_PACKAGES
指定查找协议的处理程序时需参考的提供者包的属性名称。

static String

JMXConnectorServerFactory.PROTOCOL_PROVIDER_PACKAGES
指定查找协议的处理程序时需参考的提供者包的属性名称。

返回 String 的 javax.management.remote 中的方法

String

JMXConnectionNotification.getConnectionId()
该通知所属连接的连接 ID。

String

JMXConnector.getConnectionId()
获得来自连接器服务器的连接 ID。

String[]

JMXConnectorServer.getConnectionIds()

String[]

JMXConnectorServerMBean.getConnectionIds()
当前打开的到此连接器服务器的连接 ID 列表。

String

JMXServiceURL.getHost()
Service URL 的主机部分。

String

JMXPrincipal.getName()
返回此 principal 的名称。

String

JMXServiceURL.getProtocol()
Service URL 的协议部分。

String

JMXServiceURL.getURLPath()
Service URL 的 URL Path 部分。

String

JMXPrincipal.toString()
返回此 JMXPrincipal 的字符串表示形式。

String

JMXServiceURL.toString()
此 Service URL 的字符串表示形式。

String

NotificationResult.toString()
返回该对象的字符串表示形式。

String

TargetedNotification.toString()
返回此定向通知的一个文本表示形式。

返回变量类型为 String 的类型的 javax.management.remote 中的方法

Map<String,?>

JMXConnectorServerMBean.getAttributes()
此连接器服务器的属性。

参数类型为 String 的 javax.management.remote 中的方法

protected  void

JMXConnectorServer.connectionClosed(String connectionId, String message, Object userData)
正常关闭客户端连接时由子类调用。

protected  void

JMXConnectorServer.connectionFailed(String connectionId, String message, Object userData)
客户端连接失败时由子类调用。

protected  void

JMXConnectorServer.connectionOpened(String connectionId, String message, Object userData)
打开新的客户端连接时由子类调用。

类型变量类型为 String 的 javax.management.remote 中的方法参数

static JMXConnector

JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment)
创建到位于给定地址的连接器服务器的连接。

void

JMXConnector.connect(Map<String,?> env)
建立到连接器服务器的连接。

static JMXConnector

JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
为位于给定地址的连接器服务器创建一个连接器客户端。

JMXConnector

JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。

static JMXConnectorServer

JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
创建位于给定地址的连接器服务器。

JMXConnectorServer

JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
创建位于给定地址的新连接器服务器。

JMXConnector

JMXConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

JMXConnector

JMXConnectorServerMBean.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

参数类型为 String 的 javax.management.remote 中的构造方法

JMXConnectionNotification(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)
构造一个新的连接通知。

JMXPrincipal(String name)
为给定的身份创建一个 JMXPrincipal。

JMXProviderException(String message)
构造带指定详细消息的 JMXProviderException。

JMXProviderException(String message, Throwable cause)
构造带指定详细消息和嵌套异常的 JMXProviderException。

JMXServerErrorException(String s, Error err)
构造带指定详细消息和嵌套错误的 JMXServerErrorException。

JMXServiceURL(String serviceURL)
通过解析 Service URL 字符串来构造 JMXServiceURL。

JMXServiceURL(String protocol, String host, int port)
构造具有给定协议、主机和端口的 JMXServiceURL。

JMXServiceURL(String protocol, String host, int port, String urlPath)
构造具有给定部分的 JMXServiceURL。

SubjectDelegationPermission(String name)
创建具有指定名称的新 SubjectDelegationPermission。

SubjectDelegationPermission(String name, String actions)
创建带指定名称的新 SubjectDelegationPermission 对象。

javax.management.remote.rmi 中 String 的使用

声明为 String 的 javax.management.remote.rmi 中的字段

static String

RMIConnectorServer.JNDI_REBIND_ATTRIBUTE
属性名称，它指定代表 RMI 连接器服务器的 RMIServer stub 是否应重写位于同一地址的现有 stub。

static String

RMIConnectorServer.RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIClientSocketFactory。

static String

RMIConnectorServer.RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE
属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIServerSocketFactory。

返回 String 的 javax.management.remote.rmi 中的方法

String

RMIConnection.getConnectionId()
返回连接 ID。

String

RMIConnectionImpl.getConnectionId()

String

RMIConnectionImpl_Stub.getConnectionId()

String

RMIConnector.getConnectionId()

String

RMIConnection.getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。

String

RMIConnectionImpl.getDefaultDomain(Subject delegationSubject)

String

RMIConnectionImpl_Stub.getDefaultDomain(Subject $param_Subject_1)

String[]

RMIConnection.getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。

String[]

RMIConnectionImpl.getDomains(Subject delegationSubject)

String[]

RMIConnectionImpl_Stub.getDomains(Subject $param_Subject_1)

protected  String

RMIIIOPServerImpl.getProtocol()

protected  String

RMIJRMPServerImpl.getProtocol()

protected abstract  String

RMIServerImpl.getProtocol()
返回该对象的协议字符串。

String

RMIServer.getVersion()
此连接器服务器能识别的 RMI 连接协议版本。

String

RMIServerImpl.getVersion()

String

RMIServerImpl_Stub.getVersion()

String

RMIConnectionImpl.toString()
返回此对象的字符串表示形式。

String

RMIConnector.toString()
返回此对象的字符串表示形式。

返回变量类型为 String 的类型的 javax.management.remote.rmi 中的方法

Map<String,?>

RMIConnectorServer.getAttributes()

参数类型为 String 的 javax.management.remote.rmi 中的方法

protected  void

RMIConnectorServer.connectionClosed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionFailed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionOpened(String connectionId, String message, Object userData)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)

ObjectInstance

RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。

ObjectInstance

RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)

ObjectInstance

RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)

Object

RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。

Object

RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

AttributeList

RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。

AttributeList

RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)

AttributeList

RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)

Object

RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。

Object

RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。

Object

RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

Object

RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

Object

RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

boolean

RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。

boolean

RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)

boolean

RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

protected  RMIConnection

RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。

protected  RMIConnection

RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。

protected abstract  RMIConnection

RMIServerImpl.makeClient(String connectionId, Subject subject)
创建一个新的客户端连接。

类型变量类型为 String 的 javax.management.remote.rmi 中的方法参数

void

RMIConnector.connect(Map<String,?> environment)

JMXConnector

RMIConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

参数类型为 String 的 javax.management.remote.rmi 中的构造方法

RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

类型变量类型为 String 的 javax.management.remote.rmi 中的构造方法参数

RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

RMIConnector(JMXServiceURL url, Map<String,?> environment)
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。

RMIConnector(RMIServer rmiServer, Map<String,?> environment)
用给定的 RMI stub 构造一个 RMIConnector。

RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。

RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

RMIIIOPServerImpl(Map<String,?> env)
创建新的 RMIServerImpl。

RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

RMIServerImpl(Map<String,?> env)
构造一个新的 RMIServerImpl。

javax.management.timer 中 String 的使用

返回 String 的 javax.management.timer 中的方法

String

Timer.getNotificationMessage(Integer id)
获得与指定标识符对应的计时器通知的详细消息。

String

TimerMBean.getNotificationMessage(Integer id)
获得与指定的标识符对应的计时器通知的详细消息。

String

Timer.getNotificationType(Integer id)
获得与指定标识符对应的计时器通知类型。

String

TimerMBean.getNotificationType(Integer id)
获得与指定标识符对应的计时器通知类型。

参数类型为 String 的 javax.management.timer 中的方法

Integer

Timer.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Vector<Integer>

Timer.getNotificationIDs(String type)
获得所有与指定类型对应的计时器通知的标识符。

Vector<Integer>

TimerMBean.getNotificationIDs(String type)
获得所有与指定类型对应的计时器通知的标识符。

void

Timer.removeNotifications(String type)
从通知列表中移除与指定类型对应的所有计时器通知。

void

TimerMBean.removeNotifications(String type)
从通知列表中移除与指定的类型对应的所有计时器通知。

参数类型为 String 的 javax.management.timer 中的构造方法

TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
创建计时器通知对象。

javax.naming 中 String 的使用

声明为 String 的 javax.naming 中的字段

protected  String

RefAddr.addrType
包含此地址的类型。

static String

Context.APPLET
该常量保存用来指定搜索其他属性时将使用的初始上下文构造方法的 applet 的环境属性名称。

static String

Context.AUTHORITATIVE
该常量保存用来指定所请求服务的权威性的环境属性名称。

static String

Context.BATCHSIZE
该常量保存用来指定通过服务协议返回数据时要使用的批处理量 (batch size) 的环境属性名称。

protected  String

Reference.classFactory
包含用来创建此 Reference 所引用的对象实例的工厂类名称。

protected  String

Reference.classFactoryLocation
包含工厂类的位置。

protected  String

Reference.className
包含此 Reference 所引用的对象类的完全限定名称。

static String

Context.DNS_URL
该常量保存用来指定用于 JNDI URL 上下文的 DNS 主机名和域名（例如 "dns://somehost/wiz.com"）的环境属性名称。

static String

Context.INITIAL_CONTEXT_FACTORY
该常量保存用来指定要使用的初始上下文工厂的环境属性名称。

static String

Context.LANGUAGE
该常量保存用来指定用于服务的首选语言的环境属性名称。

protected  String

LinkException.linkExplanation
包含链接解析失败原因的异常。

static String

Context.OBJECT_FACTORIES
该常量保存用来指定要使用的对象工厂列表的环境属性名称。

static String

Context.PROVIDER_URL
该常量保存用来指定要使用的服务提供者配置信息的环境属性名称。

static String

Context.REFERRAL
该常量保存用来指定将如何处理服务提供者遇到的引用的环境属性名称。

static String

Context.SECURITY_AUTHENTICATION
该常量保存用来指定将使用的安全级别的环境属性名称。

static String

Context.SECURITY_CREDENTIALS
该常量保存用来指定用于验证服务调用者主体证书的环境属性名称。

static String

Context.SECURITY_PRINCIPAL
该常量保存用来指定用于验证服务调用者主体身份的环境属性名称。

static String

Context.SECURITY_PROTOCOL
该常量保存用来指定将使用的安全协议的环境属性名称。

static String

Context.STATE_FACTORIES
该常量保存用来指定要使用的状态工厂列表的环境属性名称。

static String

Context.URL_PKG_PREFIXES
该常量保存用来指定加载 URL 上下文工厂时要使用的包前缀列表的环境属性名称。

返回 String 的 javax.naming 中的方法

String

Context.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

String

InitialContext.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

String

CompositeName.get(int posn)
检索此复合名称的组件。

String

CompoundName.get(int posn)
检索此组合名称的组件。

String

Name.get(int posn)
检索此名称的组件。

String

Binding.getClassName()
检索绑定到此绑定名称的对象的类名称。

String

NameClassPair.getClassName()
检索绑定到此绑定名称的对象的类名称。

String

Reference.getClassName()
检索此引用所引用对象的类名称。

String

NamingException.getExplanation()
检索与此异常关联的解释。

String

Reference.getFactoryClassLocation()
检索此引用所引用对象的工厂的位置。

String

Reference.getFactoryClassName()
检索此引用所引用对象的工厂的类名称。

String

LinkException.getLinkExplanation()
检索与解析某一链接时遇到的问题关联的解释。

String

LinkRef.getLinkName()
检索此链接的名称。

String

NameClassPair.getName()
检索此绑定的名称。

String

Context.getNameInNamespace()
在此上下文自己的名称空间中检索其完全名称。

String

InitialContext.getNameInNamespace()

String

NameClassPair.getNameInNamespace()
检索此绑定的完全名称。

String

RefAddr.getType()
检索此地址的地址类型。

String

BinaryRefAddr.toString()
生成此地址的字符串表示形式。

String

Binding.toString()
生成此绑定的字符串表示形式。

String

CompositeName.toString()
生成此复合名称的字符串表示形式。

String

CompoundName.toString()
使用组合名称的语法规则生成此组合名称的字符串表示形式。

String

LinkException.toString()
生成此异常的字符串表示形式。

String

NameClassPair.toString()
生成此名称/类对的字符串表示形式。

String

NamingException.toString()
生成此异常的字符串表示形式。

String

RefAddr.toString()
生成此地址的字符串表示形式。

String

Reference.toString()
生成此引用的字符串表示形式。

String

LinkException.toString(boolean detail)
生成此异常的字符串表示形式。

String

NamingException.toString(boolean detail)
生成更详细的字符串表示形式。

返回变量类型为 String 的类型的 javax.naming 中的方法

Enumeration<String>

CompositeName.getAll()
以字符串枚举的形式检索此复合名称的组件。

Enumeration<String>

CompoundName.getAll()
以字符串枚举的形式检索此组合名称的组件。

Enumeration<String>

Name.getAll()
以字符串枚举的形式检索此名称的组件。

参数类型为 String 的 javax.naming 中的方法

Name

CompositeName.add(int posn, String comp)
在此复合名称中的指定位置添加单个组件。

Name

CompoundName.add(int posn, String comp)
在此组合名称中的指定位置添加单个组件。

Name

Name.add(int posn, String comp)
在此名称中的指定位置添加单个组件。

Name

CompositeName.add(String comp)
将单个组件添加到此复合名称的末尾。

Name

CompoundName.add(String comp)
将单个组件添加到此组合名称的末尾。

Name

Name.add(String comp)
将单个组件添加到此名称的末尾。

Object

Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。

Object

InitialContext.addToEnvironment(String propName, Object propVal)

void

NamingException.appendRemainingComponent(String name)
将 name 作为剩余名称中最后的组件添加。

void

Context.bind(String name, Object obj)
将名称绑定到对象。

void

InitialContext.bind(String name, Object obj)

String

Context.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

String

InitialContext.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。

Context

Context.createSubcontext(String name)
创建并绑定一个新上下文。

Context

InitialContext.createSubcontext(String name)

void

Context.destroySubcontext(String name)
销毁指定上下文，并将它从名称空间中移除。

void

InitialContext.destroySubcontext(String name)

static

<T> T

InitialContext.doLookup(String name)
获取指定对象的静态方法。

RefAddr

Reference.get(String addrType)
检索地址类型为 'addrType' 的第一个地址。

NameParser

Context.getNameParser(String name)
检索与指定上下文关联的解析器。

NameParser

InitialContext.getNameParser(String name)

protected  Context

InitialContext.getURLOrDefaultInitCtx(String name)
获取用来解析字符串名称 name 的上下文。

NamingEnumeration<NameClassPair>

Context.list(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。

NamingEnumeration<NameClassPair>

InitialContext.list(String name)

NamingEnumeration<Binding>

Context.listBindings(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。

NamingEnumeration<Binding>

InitialContext.listBindings(String name)

Object

Context.lookup(String name)
检索指定的对象。

Object

InitialContext.lookup(String name)

Object

Context.lookupLink(String name)
按照除名称的最终原子组件以外的链接检索指定对象。

Object

InitialContext.lookupLink(String name)

Name

NameParser.parse(String name)
将某一名称解析成其组件。

void

Context.rebind(String name, Object obj)
将名称绑定到对象，重写所有现有绑定。

void

InitialContext.rebind(String name, Object obj)

Object

Context.removeFromEnvironment(String propName)
从此上下文的环境中移除一个环境属性。

Object

InitialContext.removeFromEnvironment(String propName)

void

Context.rename(String oldName, String newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。

void

InitialContext.rename(String oldName, String newName)

void

NameClassPair.setClassName(String name)
设置此绑定的类名称。

void

LinkException.setLinkExplanation(String msg)
设置与解析某一链接时所遇问题关联的解释。

void

NameClassPair.setName(String name)
设置此绑定的名称。

void

NameClassPair.setNameInNamespace(String fullName)
设置此绑定的完全名称。

void

Context.unbind(String name)
取消对指定对象的绑定。

void

InitialContext.unbind(String name)

参数类型为 String 的 javax.naming 中的构造方法

AuthenticationException(String explanation)
使用所提供的解释构造一个新的 AuthenticationException 实例。

AuthenticationNotSupportedException(String explanation)
使用解释构造一个新的 AuthenticationNotSupportedException 实例。

BinaryRefAddr(String addrType, byte[] src)
使用地址类型和用于内容的字节数组构造一个新的 BinaryRefAddr 实例。

BinaryRefAddr(String addrType, byte[] src, int offset, int count)
使用地址类型和用于内容的字节数组区域构造一个新的 BinaryRefAddr 实例。

Binding(String name, Object obj)
在给定其名称和对象的情况下构造一个 Binding 实例。

Binding(String name, Object obj, boolean isRelative)
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj)
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj, boolean isRelative)
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

CannotProceedException(String explanation)
使用解释构造一个新的 CannotProceedException 实例。

CommunicationException(String explanation)
使用所提供的参数构造一个新的 CommunicationException 实例。

CompositeName(String n)
通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。

CompoundName(String n, Properties syntax)
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。

ConfigurationException(String explanation)
使用解释构造一个新的 ConfigurationException 实例。

ContextNotEmptyException(String explanation)
使用解释构造一个新的 ContextNotEmptyException 实例。

InsufficientResourcesException(String explanation)
使用解释构造一个新的 InsufficientResourcesException 实例。

InterruptedNamingException(String explanation)
使用问题的解释构造一个 InterruptedNamingException 实例。

InvalidNameException(String explanation)
使用问题的解释构造一个 InvalidNameException 实例。

LimitExceededException(String explanation)
使用解释构造一个新的 LimitExceededException 实例。

LinkException(String explanation)
使用解释构造一个新的 LinkException 实例，其他所有字段都初始化为 null。

LinkLoopException(String explanation)
使用解释构造一个新的 LinkLoopException 实例，其他所有字段都被初始化为 null。

LinkRef(String linkName)
为某一字符串名称构造一个 LinkRef。

MalformedLinkException(String explanation)
使用解释构造一个新的 MalformedLinkException 实例，其他所有字段都被初始化为 null。

NameAlreadyBoundException(String explanation)
使用所提供的解释构造一个新的 NameAlreadyBoundException 实例。

NameClassPair(String name, String className)
在给定名称和类名称的情况下构造一个 NameClassPair 实例。

NameClassPair(String name, String className, boolean isRelative)
在给定其名称、类名称以及该名称是否相对于列表上下文的情况下构造一个 NameClassPair 实例。

NameNotFoundException(String explanation)
使用所提供的解释构造一个新的 NameNotFoundException 实例。

NamingException(String explanation)
使用解释构造一个新的 NamingException。

NamingSecurityException(String explanation)
使用所提供的解释构造一个新的 NamingSecurityException 实例。

NoInitialContextException(String explanation)
使用解释构造一个 NoInitialContextException 实例。

NoPermissionException(String explanation)
使用解释构造一个新的 NoPermissionException 实例。

NotContextException(String explanation)
使用解释构造一个新的 NotContextException 实例。

OperationNotSupportedException(String explanation)
使用解释构造一个新的 OperationNotSupportedException 实例。

PartialResultException(String explanation)
使用指定的解释消息构造一个新的异常实例。

RefAddr(String addrType)
使用地址类型构造一个新的 RefAddr 实例。

Reference(String className)
使用类名称 'className' 构造对某个对象的新引用。

Reference(String className, RefAddr addr)
使用类名称 'className' 和一个地址构造对某个对象的新引用。

Reference(String className, RefAddr addr, String factory, String factoryLocation)
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。

Reference(String className, String factory, String factoryLocation)
使用类名称 'className' 以及对象工厂的类名称和位置创建对某个对象的新引用。

ReferralException(String explanation)
使用所提供的解释构造一个新的 ReferralException 实例。

ServiceUnavailableException(String explanation)
使用解释构造一个新的 ServiceUnavailableException 实例。

SizeLimitExceededException(String explanation)
使用解释构造一个新的 SizeLimitExceededException 实例。

StringRefAddr(String addrType, String addr)
使用地址类型和内容构造一个新的 StringRefAddr 实例。

TimeLimitExceededException(String explanation)
使用所提供的参数构造一个新的 TimeLimitExceededException 实例。

类型变量类型为 String 的 javax.naming 中的构造方法参数

CompositeName(Enumeration<String> comps)
使用由 'comps' 指定的组件构造一个新的复合名称实例。

CompoundName(Enumeration<String> comps, Properties syntax)
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。

javax.naming.directory 中 String 的使用

声明为 String 的 javax.naming.directory 中的字段

protected  String

BasicAttribute.attrID
保存属性的 id。

返回 String 的 javax.naming.directory 中的方法

String

Attribute.getID()
检索此属性的 id。

String

BasicAttribute.getID()

String[]

SearchControls.getReturningAttributes()
检索将作为搜索的一部分返回的属性。

String

AttributeModificationException.toString()
此异常的字符串表示形式由关于发生错误的位置信息和第一个未执行的修改组成。

String

BasicAttribute.toString()
生成此属性的字符串表示形式。

String

BasicAttributes.toString()
生成此属性集的字符串表示形式。

String

ModificationItem.toString()
生成此修改项的字符串表示形式，该表示形式由修改操作及其相关属性组成。

String

SearchResult.toString()
生成此 SearchResult 的字符串表示形式。

返回变量类型为 String 的类型的 javax.naming.directory 中的方法

NamingEnumeration<String>

Attributes.getIDs()
检索属性集中属性的 id 的枚举。

NamingEnumeration<String>

BasicAttributes.getIDs()

参数类型为 String 的 javax.naming.directory 中的方法

void

DirContext.bind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象。

void

InitialDirContext.bind(String name, Object obj, Attributes attrs)

DirContext

DirContext.createSubcontext(String name, Attributes attrs)
创建并绑定新的上下文及关联的属性。

DirContext

InitialDirContext.createSubcontext(String name, Attributes attrs)

Attribute

Attributes.get(String attrID)
利用属性集中的给定属性 id 检索属性。

Attribute

BasicAttributes.get(String attrID)

Attributes

DirContext.getAttributes(Name name, String[] attrIds)
检索与命名对象关联的选定属性。

Attributes

InitialDirContext.getAttributes(Name name, String[] attrIds)

Attributes

DirContext.getAttributes(String name)
检索所有与命名对象关联的属性。

Attributes

InitialDirContext.getAttributes(String name)

Attributes

DirContext.getAttributes(String name, String[] attrIds)
检索与命名对象关联的选定属性。

Attributes

DirContext.getAttributes(String name, String[] attrIds)
检索与命名对象关联的选定属性。

Attributes

InitialDirContext.getAttributes(String name, String[] attrIds)

Attributes

InitialDirContext.getAttributes(String name, String[] attrIds)

DirContext

DirContext.getSchema(String name)
检索与命名对象关联的模式。

DirContext

InitialDirContext.getSchema(String name)

DirContext

DirContext.getSchemaClassDefinition(String name)
检索包含命名对象类定义的模式对象的上下文。

DirContext

InitialDirContext.getSchemaClassDefinition(String name)

void

DirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
修改与命名对象关联的属性。

void

InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)

void

DirContext.modifyAttributes(String name, ModificationItem[] mods)
使用有序的修改列表修改与命名对象关联的属性。

void

InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)

Attribute

Attributes.put(String attrID, Object val)
向属性集中添加新属性。

Attribute

BasicAttributes.put(String attrID, Object val)

void

DirContext.rebind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。

void

InitialDirContext.rebind(String name, Object obj, Attributes attrs)

Attribute

Attributes.remove(String attrID)
从属性集中移除属性 id 为 'attrID' 的属性。

Attribute

BasicAttributes.remove(String attrID)

NamingEnumeration<SearchResult>

DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)

NamingEnumeration<SearchResult>

DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(Name name, String filter, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, String filter, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(String name, Attributes matchingAttributes)
在单个上下文中搜索包含指定属性集的对象。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, Attributes matchingAttributes)

NamingEnumeration<SearchResult>

DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。

NamingEnumeration<SearchResult>

DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)

NamingEnumeration<SearchResult>

DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(String name, String filter, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, String filter, SearchControls cons)

void

SearchControls.setReturningAttributes(String[] attrs)
指定将作为搜索的一部分返回的属性。

参数类型为 String 的 javax.naming.directory 中的构造方法

AttributeInUseException(String explanation)
使用解释构造一个新的 AttributeInUseException 实例。

AttributeModificationException(String explanation)
使用解释构造一个新的 AttributeModificationException 实例。

BasicAttribute(String id)
构造一个不带值无序属性的新实例。

BasicAttribute(String id, boolean ordered)
构造一个不带值的可能为有序属性的新实例。

BasicAttribute(String id, Object value)
构造一个带有单个值的无序属性的新实例。

BasicAttribute(String id, Object value, boolean ordered)
构造一个带有单个值的可能为有序属性的新实例。

BasicAttributes(String attrID, Object val)
构造带有一个属性的新 Attributes 实例。

BasicAttributes(String attrID, Object val, boolean ignoreCase)
构造带有一个属性的新 Attributes 实例。

InvalidAttributeIdentifierException(String explanation)
使用所提供的解释构造一个新的 InvalidAttributeIdentifierException 实例。

InvalidAttributesException(String explanation)
使用解释构造一个新的 InvalidAttributesException 实例。

InvalidAttributeValueException(String explanation)
使用解释构造一个新的 InvalidAttributeValueException 实例。

InvalidSearchControlsException(String msg)
使用解释构造一个新的 InvalidSearchControlsException 实例。

InvalidSearchFilterException(String msg)
使用解释构造一个新的 InvalidSearchFilterException 实例。

NoSuchAttributeException(String explanation)
使用解释构造一个新的 NoSuchAttributeException 实例。

SchemaViolationException(String explanation)
使用所提供的解释构造一个新的 SchemaViolationException 实例。

SearchControls(int scope, long countlim, int timelim, String[] attrs, boolean retobj, boolean deref)
使用参数构造搜索约束。

SearchResult(String name, Object obj, Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

javax.naming.event 中 String 的使用

参数类型为 String 的 javax.naming.event 中的方法

void

EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

void

EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。

void

EventContext.addNamingListener(String target, int scope, NamingListener l)
添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。

void

EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

void

EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。

javax.naming.ldap 中 String 的使用

声明为 String 的 javax.naming.ldap 中的字段

static String

LdapContext.CONTROL_FACTORIES
该常量保存用来指定要使用的控件工厂列表的环境属性名称。

protected  String

BasicControl.id
控件的对象标识符字符串。

static String

ManageReferralControl.OID
ManageReferral 控件的分配对象标识符为 2.16.840.1.113730.3.4.2。

static String

PagedResultsControl.OID
分页结果控件的分配对象标识符为 1.2.840.113556.1.4.319。

static String

PagedResultsResponseControl.OID
分页结果响应控件的分配对象标识符为 1.2.840.113556.1.4.319。

static String

SortControl.OID
服务器端排序控件的分配对象标识符为 1.2.840.113556.1.4.473。

static String

SortResponseControl.OID
服务器端排序响应控件的分配对象标识符为 1.2.840.113556.1.4.474。

static String

StartTlsRequest.OID
StartTLS 扩展请求的分配对象标识符为 1.3.6.1.4.1.1466.20037。

static String

StartTlsResponse.OID
StartTLS 扩展响应的分配对象标识符为 1.3.6.1.4.1.1466.20037。

返回 String 的 javax.naming.ldap 中的方法

static String

Rdn.escapeValue(Object val)
在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。

String

LdapName.get(int posn)
以字符串形式检索此 LDAP 名称的组件。

String

SortKey.getAttributeID()
检索排序键的属性 ID。

String

SortResponseControl.getAttributeID()
检索导致排序失败的属性的 ID。

String

BasicControl.getID()
检索控件的对象标识符字符串。

String

Control.getID()
检索为 LDAP 控件分配的对象标识符。

String

ExtendedRequest.getID()
检索请求的对象标识符。

String

ExtendedResponse.getID()
检索响应的对象标识符。

String

StartTlsRequest.getID()
检索 StartTLS 请求的对象标识符字符串。

String

StartTlsResponse.getID()
检索 StartTLS 响应的对象标识符字符串。

String

SortKey.getMatchingRuleID()
检索用于排序属性值的匹配规则 ID。

String[]

UnsolicitedNotification.getReferrals()
检索服务器发送的引用。

String

Rdn.getType()
检索一个此 Rdn 的类型。

String

LdapName.toString()
返回一个此 LDAP 名称的字符串表示形式，该表示形式使用 RFC 2253 定义并在类描述中描述的格式。

String

Rdn.toString()
以字符串形式返回此 Rdn，该字符串使用由 RFC 2253 定义并在 LdapName 类描述中描述的格式表示。

返回变量类型为 String 的类型的 javax.naming.ldap 中的方法

Enumeration<String>

LdapName.getAll()
以字符串枚举的形式检索此名称的组件。

参数类型为 String 的 javax.naming.ldap 中的方法

Name

LdapName.add(int posn, String comp)
将单个组件添加到此 LDAP 名称中的指定位置。

Name

LdapName.add(String comp)
将单个组件添加到此 LDAP 名称的末尾。

ExtendedResponse

ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
创建与此请求对应的响应对象。

ExtendedResponse

StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length)
创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。

abstract  void

StartTlsResponse.setEnabledCipherSuites(String[] suites)
重写在 TLS 连接上启用的密码套件的默认列表。

static Object

Rdn.unescapeValue(String val)
在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。

参数类型为 String 的 javax.naming.ldap 中的构造方法

BasicControl(String id)
构造一个非关键控件。

BasicControl(String id, boolean criticality, byte[] value)
使用提供的参数构造控件。

LdapName(String name)
根据给定标识名构造 LDAP 名称。

LdapReferralException(String explanation)
使用所提供的解释构造一个新的 LdapReferralException 实例。

PagedResultsResponseControl(String id, boolean criticality, byte[] value)
构造分页结果响应控件。

Rdn(String rdnString)
根据给定字符串构造 Rdn。

Rdn(String type, Object value)
根据给定属性类型和值构造 Rdn。

SortControl(String[] sortBy, boolean criticality)
构造一个控件来按升序对属性列表进行排序。

SortControl(String sortBy, boolean criticality)
构造一个控件来按升序对单个属性进行排序。

SortKey(String attrID)
创建属性的默认排序键。

SortKey(String attrID, boolean ascendingOrder, String matchingRuleID)
创建属性的排序键。

SortResponseControl(String id, boolean criticality, byte[] value)
构造一个控件来指示排序请求的结果。

javax.naming.spi 中 String 的使用

声明为 String 的 javax.naming.spi 中的字段

static String

NamingManager.CPE
保存环境属性名称的常量，getContinuationContext() 将其 CannotProceedException 参数的值保存在该环境属性中。

参数类型为 String 的 javax.naming.spi 中的方法

void

ResolveResult.appendRemainingComponent(String name)
将单个组件添加到剩余名称末尾。

static Context

NamingManager.getURLContext(String scheme, Hashtable<?,?> environment)
为给定的 URL 方案 id 创建一个上下文。

ResolveResult

Resolver.resolveToClass(String name, Class<? extends Context> contextType)
部分解析某一名称。

参数类型为 String 的 javax.naming.spi 中的构造方法

ResolveResult(Object robj, String rcomp)
构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。

javax.net 中 String 的使用

参数类型为 String 的 javax.net 中的方法

abstract  Socket

SocketFactory.createSocket(String host, int port)
创建一个套接字并把它连接到指定远程主机上的指定远程端口。

abstract  Socket

SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort)
创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 String 的使用

返回 String 的 javax.net.ssl 中的方法

String

X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。

String

X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。

String

KeyManagerFactory.getAlgorithm()
返回此 KeyManagerFactory 对象的算法名称。

String

TrustManagerFactory.getAlgorithm()
返回此 TrustManagerFactory 对象的算法名称。

String

HandshakeCompletedEvent.getCipherSuite()
返回由握手产生的会话所使用的密码套件。

String

SSLSession.getCipherSuite()
返回会话中的所有连接所使用的 SSL 密码套件的名称。

abstract  String

HttpsURLConnection.getCipherSuite()
返回在此连接上使用的密码套件。

String[]

SSLParameters.getCipherSuites()
返回密码套件数组的副本；如果未设置，则返回 null。

String[]

X509KeyManager.getClientAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。

static String

KeyManagerFactory.getDefaultAlgorithm()
获取默认的 KeyManagerFactory 算法名称。

static String

TrustManagerFactory.getDefaultAlgorithm()
获取默认的 TrustManagerFactory 算法名称。

abstract  String[]

SSLSocketFactory.getDefaultCipherSuites()
返回默认情况下启用的密码套件的列表。

abstract  String[]

SSLServerSocketFactory.getDefaultCipherSuites()
返回默认情况下启用的密码套件的列表。

abstract  String[]

SSLSocket.getEnabledCipherSuites()
返回当前启用以供此连接使用的 SSL 密码套件的名称。

abstract  String[]

SSLEngine.getEnabledCipherSuites()
返回为了在此引擎上使用而当前已启用的 SSL 密码套件名称。

abstract  String[]

SSLServerSocket.getEnabledCipherSuites()
返回当前被启用以供新接受的连接使用的密码套件列表。

abstract  String[]

SSLSocket.getEnabledProtocols()
返回当前启用以供此连接使用的协议版本的名称。

abstract  String[]

SSLEngine.getEnabledProtocols()
返回当前已启用的，以便让 SSLEngine 使用的协议版本的名称。

abstract  String[]

SSLServerSocket.getEnabledProtocols()
返回当前新接受的连接启用的协议的名称。

String

SSLSessionBindingEvent.getName()
返回将对象绑定到或从其解除绑定的名称。

String

SSLSession.getPeerHost()
返回此会话中同位体的主机名称。

String

SSLEngine.getPeerHost()
返回同位体的主机名。

String

SSLSession.getProtocol()
返回会话中的所有连接使用的协议的标准名称。

String

SSLContext.getProtocol()
返回此 SSLContext 对象的协议名称。

String[]

SSLParameters.getProtocols()
返回协议数组的副本；如果未设置，则返回 null。

String[]

X509KeyManager.getServerAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

abstract  String[]

SSLSocket.getSupportedCipherSuites()
返回可以启用以供此连接使用的密码套件的名称。

abstract  String[]

SSLSocketFactory.getSupportedCipherSuites()
返回可以在 SSL 连接上启用的密码套件的名称。

abstract  String[]

SSLServerSocketFactory.getSupportedCipherSuites()
返回可以在由此工厂创建的 SSL 连接上启用的密码套件的名称。

abstract  String[]

SSLEngine.getSupportedCipherSuites()
返回为了在此引擎上使用而可以启用的密码套件名称。

abstract  String[]

SSLServerSocket.getSupportedCipherSuites()
返回可以启用以供 SSL 连接使用的密码套件的名称。

abstract  String[]

SSLSocket.getSupportedProtocols()
返回能够被启用以供 SSL 连接使用的协议的名称。

abstract  String[]

SSLEngine.getSupportedProtocols()
返回能够被启用，以便让 SSLEngine 可使用的协议的名称。

abstract  String[]

SSLServerSocket.getSupportedProtocols()
返回可以启用的协议的名称。

String[]

SSLSession.getValueNames()
返回绑定到会话中的所有应用层数据对象的名称组成的数组。

String

SSLEngineResult.toString()
返回此对象的字符串表示形式。

参数类型为 String 的 javax.net.ssl 中的方法

void

X509TrustManager.checkClientTrusted(X509Certificate[] chain, String authType)
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。

void

X509TrustManager.checkServerTrusted(X509Certificate[] chain, String authType)
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。

String

X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。

String

X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。

String

X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。

abstract  Socket

SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose)
返回在连接到指定主机的给定端口的现有套接字上分层的套接字。

SSLEngine

SSLContext.createSSLEngine(String peerHost, int peerPort)
使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。

protected abstract  SSLEngine

SSLContextSpi.engineCreateSSLEngine(String host, int port)
使用此上下文创建 SSLEngine。

X509Certificate[]

X509KeyManager.getCertificateChain(String alias)
返回与给定别名关联的证书链。

String[]

X509KeyManager.getClientAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。

static KeyManagerFactory

KeyManagerFactory.getInstance(String algorithm)
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

static SSLContext

SSLContext.getInstance(String protocol)
返回实现指定安全套接字协议的 SSLContext 对象。

static TrustManagerFactory

TrustManagerFactory.getInstance(String algorithm)
返回充当信任管理器工厂的 TrustManagerFactory 对象。

static KeyManagerFactory

KeyManagerFactory.getInstance(String algorithm, Provider provider)
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

static SSLContext

SSLContext.getInstance(String protocol, Provider provider)
返回实现指定安全套接字协议的 SSLContext 对象。

static TrustManagerFactory

TrustManagerFactory.getInstance(String algorithm, Provider provider)
返回充当信任管理器工厂的 TrustManagerFactory 对象。

static KeyManagerFactory

KeyManagerFactory.getInstance(String algorithm, String provider)
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

static SSLContext

SSLContext.getInstance(String protocol, String provider)
返回实现指定安全套接字协议的 SSLContext 对象。

static TrustManagerFactory

TrustManagerFactory.getInstance(String algorithm, String provider)
返回充当信任管理器工厂的 TrustManagerFactory 对象。

PrivateKey

X509KeyManager.getPrivateKey(String alias)
返回与给定别名关联的密钥。

String[]

X509KeyManager.getServerAliases(String keyType, Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

Object

SSLSession.getValue(String name)
返回会话的应用层数据中的绑定到给定名称的对象。

void

SSLSession.putValue(String name, Object value)
使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。

void

SSLSession.removeValue(String name)
移除会话的应用层数据中绑定到给定名称的对象。

void

SSLParameters.setCipherSuites(String[] cipherSuites)
设置密码套件数组。

abstract  void

SSLSocket.setEnabledCipherSuites(String[] suites)
将密码套件设置为启用以供此连接使用。

abstract  void

SSLEngine.setEnabledCipherSuites(String[] suites)
设置密码套件为启用，以便在此引擎上使用。

abstract  void

SSLServerSocket.setEnabledCipherSuites(String[] suites)
把密码套件设置为启用的以供接受的连接使用。

abstract  void

SSLSocket.setEnabledProtocols(String[] protocols)
设置启用以供此连接使用的协议版本。

abstract  void

SSLEngine.setEnabledProtocols(String[] protocols)
设置为了在此引擎上使用而启用的协议版本。

abstract  void

SSLServerSocket.setEnabledProtocols(String[] protocols)
控制启用哪些特定的协议以供接受的连接使用。

void

SSLParameters.setProtocols(String[] protocols)
设置协议数组。

static SSLEngineResult.Status

SSLEngineResult.Status.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SSLEngineResult.HandshakeStatus

SSLEngineResult.HandshakeStatus.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

boolean

HostnameVerifier.verify(String hostname, SSLSession session)
验证主机名和服务器验证方案的匹配是可接受的。

参数类型为 String 的 javax.net.ssl 中的构造方法

KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 KeyManagerFactory 对象。

SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
创建 SSLContext 对象。

SSLEngine(String peerHost, int peerPort)
SSLEngine 的构造方法。

SSLException(String reason)
构造一个异常，该异常报告由 SSL 子系统发现的错误。

SSLException(String message, Throwable cause)
创建带指定详细消息和原因的 SSLException。

SSLHandshakeException(String reason)
构造一个报告由 SSL 子系统在握手期间发现的错误的异常。

SSLKeyException(String reason)
构造一个报告由 SSL 子系统发现的密钥管理错误的异常。

SSLParameters(String[] cipherSuites)
根据指定的密码套件数组构造 SSLParameters。

SSLParameters(String[] cipherSuites, String[] protocols)
根据指定的密码套件数组和协议数组构造 SSLParameters。

SSLParameters(String[] cipherSuites, String[] protocols)
根据指定的密码套件数组和协议数组构造 SSLParameters。

SSLPeerUnverifiedException(String reason)
构造一个报告还没有验证 SSL 同位体的身份的异常。

SSLPermission(String name)
用指定的名称创建一个新的 SSLPermission。

SSLPermission(String name, String actions)
用指定的名称创建一个新的 SSLPermission 对象。

SSLProtocolException(String reason)
构造一个报告由 SSL 子系统检测到的 SSL 协议错误的异常。

SSLSessionBindingEvent(SSLSession session, String name)
构造一个新的 SSLSessionBindingEvent。

SSLSocket(String host, int port)
仅供子类使用。

SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 TrustManagerFactory 对象。

javax.print 中 String 的使用

声明为 String 的 javax.print 中的字段

static String

ServiceUIFactory.DIALOG_UI
表示一个作为 AWT 对话框实现的 UI。

static String

DocFlavor.hostEncoding
表示主机操作系统编码的 String。

static String

ServiceUIFactory.JCOMPONENT_UI
表示一个作为 Swing 组件实现的 UI。

static String

ServiceUIFactory.JDIALOG_UI
表示一个作为 Swing 对话框实现的 UI。

static String

ServiceUIFactory.PANEL_UI
表示一个作为 AWT 面板实现的 UI。

返回 String 的 javax.print 中的方法

String

DocFlavor.getMediaSubtype()
返回此 DocFlavor 对象的媒体子类型（根据 MIME 类型）。

String

DocFlavor.getMediaType()
返回此 DocFlavor 对象的媒体类型（根据 MIME 类型）。

String

DocFlavor.getMimeType()
根据 MIME 类型的规范形式返回此 DocFlavor 对象的 MIME 类型字符串。

String

PrintService.getName()
返回此 PrintService 的 String 名称，应用程序可以使用该名称来请求特定的 PrintService。

abstract  String

StreamPrintService.getOutputFormat()
返回此 PrintService 所发出的文档格式。

abstract  String

StreamPrintServiceFactory.getOutputFormat()
查询该工厂，了解从此工厂获得的打印机所发出的文档的格式。

String

DocFlavor.getParameter(String paramName)
返回表示 MIME 参数的 String。

String

DocFlavor.getRepresentationClassName()
返回此 DocFlavor 对象的表示形式类名。

abstract  String[]

ServiceUIFactory.getUIClassNamesForRole(int role)
给定从此工厂获取的 UI 角色，获取实现此角色的此工厂可提供的 UI 类型。

String

DocFlavor.toString()
将此 DocFlavor 转换为字符串。

参数类型为 String 的 javax.print 中的方法

String

DocFlavor.getParameter(String paramName)
返回表示 MIME 参数的 String。

abstract  Object

ServiceUIFactory.getUI(int role, String ui)
获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。

static StreamPrintServiceFactory[]

StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType)
查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。

参数类型为 String 的 javax.print 中的构造方法

DocFlavor.BYTE_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[B"（byte 数组）的新 DocFlavor。

DocFlavor.CHAR_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[C"（字符数组）的新 DocFlavor。

DocFlavor.INPUT_STREAM(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.InputStream"（byte 流）的新 DocFlavor。

DocFlavor.READER(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.Reader"（字符流）的新 DocFlavor。

DocFlavor.SERVICE_FORMATTED(String className)
构造具有 "application/x-java-jvm-local-objectref" MIME 类型（指示服务格式化打印数据）和给定打印数据表示形式类名的新 DocFlavor。

DocFlavor.STRING(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.lang.String" 的新 DocFlavor。

DocFlavor.URL(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.net.URL" 的新 DocFlavor。

DocFlavor(String mimeType, String className)
根据给定的 MIME 类型和表示形式类名构造新的 DocFlavor 对象。

PrintException(String s)
构造带给定详细消息的 print 异常。

PrintException(String s, Exception e)
构造带给定详细消息和链异常的 print 异常。

javax.print.attribute 中 String 的使用

返回 String 的 javax.print.attribute 中的方法

String

Attribute.getName()
获取类别的名称,此属性值是该类别的一个实例。

protected  String[]

EnumSyntax.getStringTable()
返回此枚举值的枚举类的字符串表。

String

TextSyntax.getValue()
返回此文本属性的文本字符串。

String

DateTimeSyntax.toString()
返回对应于此日期-时间属性的字符串值。

String

EnumSyntax.toString()
返回对应于此枚举值的字符串值。

String

IntegerSyntax.toString()
返回对应于此整数属性的字符串值。

String

ResolutionSyntax.toString()
返回此分辨率属性的字符串版本。

String

SetOfIntegerSyntax.toString()
返回对应于此整数集属性的字符串值。

String

Size2DSyntax.toString()
返回此二维大小属性的字符串版本。

String

TextSyntax.toString()
返回标识此文本属性的字符串。

String

URISyntax.toString()
返回标识此 URI 属性的字符串。

String

ResolutionSyntax.toString(int units, String unitsName)
返回给定单位的此分辨率属性的字符串版本。

String

Size2DSyntax.toString(int units, String unitsName)
返回给定单位的此二维大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute 中的方法

String

ResolutionSyntax.toString(int units, String unitsName)
返回给定单位的此分辨率属性的字符串版本。

String

Size2DSyntax.toString(int units, String unitsName)
返回给定单位的此二维大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute 中的构造方法

SetOfIntegerSyntax(String members)
使用以字符串形式给定的成员构造一个新的整数集属性。

TextSyntax(String value, Locale locale)
使用指定的字符串和语言环境构造 TextAttribute。

UnmodifiableSetException(String message)
构造带指定详细消息的 UnmodifiableSetException。

javax.print.attribute.standard 中 String 的使用

返回 String 的 javax.print.attribute.standard 中的方法

String

Chromaticity.getName()
获取类别名称，这里此属性值是该类别的实例。

String

ColorSupported.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Compression.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Copies.getName()
获取类别名称，这里此属性值是该类别的实例。

String

CopiesSupported.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DateTimeAtCompleted.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DateTimeAtCreation.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DateTimeAtProcessing.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Destination.getName()
获取类别名称，这里此属性值是该类别的实例。

String

DocumentName.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Fidelity.getName()
获取类别名称，这里此属性值是该类别的实例。

String

Finishings.getName()
获取类别名称，此属性值为该类别的实例。

String

JobHoldUntil.getName()
获取类别名称，此属性值为该类别的实例。

String

JobImpressions.getName()
获取类别名称，此属性值为该类别的实例。

String

JobImpressionsCompleted.getName()
获取类别名称，此属性值为该类别的实例。

String

JobImpressionsSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobKOctets.getName()
获取类别名称，此属性值为该类别的实例。

String

JobKOctetsProcessed.getName()
获取类别名称，此属性值为该类别的实例。

String

JobKOctetsSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobMediaSheets.getName()
获取类别名称，此属性值为该类别的实例。

String

JobMediaSheetsCompleted.getName()
获取类别名称，此属性值是该类别的实例。

String

JobMediaSheetsSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobMessageFromOperator.getName()
获取类别名称，此属性值为该类别的实例。

String

JobName.getName()
获取类别名称，此属性值为该类别的实例。

String

JobOriginatingUserName.getName()
获取类别名称，此属性值为该类别的实例。

String

JobPriority.getName()
获取类别名称，此属性值为该类别的实例。

String

JobPrioritySupported.getName()
获取类别名称，此属性值为该类别的实例。

String

JobSheets.getName()
获取类别名称，此属性值为该类别的实例。

String

JobState.getName()
获取类别名称，此属性值为该类别的实例。

String

JobStateReason.getName()
获取类别名称，此属性值为该类别的实例。

String

JobStateReasons.getName()
获取类别名称，此属性值为该类别的实例。

String

Media.getName()
获取类别名称，此属性值为该类别的实例。

String

MediaPrintableArea.getName()
获取类别名称，此属性值为该类别的实例。

String

MediaSize.getName()
获取类别名称，此属性值为该类别的实例。

String

MultipleDocumentHandling.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberOfDocuments.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberOfInterveningJobs.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberUp.getName()
获取类别名称，此属性值为该类别的实例。

String

NumberUpSupported.getName()
获取类别名称，此属性值为该类别的实例。

String

OrientationRequested.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

OutputDeviceAssigned.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PDLOverrideSupported.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PageRanges.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PagesPerMinute.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PagesPerMinuteColor.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PresentationDirection.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrintQuality.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterInfo.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterIsAcceptingJobs.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterLocation.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMakeAndModel.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMessageFromOperator.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMoreInfo.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterMoreInfoManufacturer.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterName.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterResolution.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterState.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterStateReason.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterStateReasons.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

PrinterURI.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

QueuedJobCount.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

ReferenceUriSchemesSupported.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

RequestingUserName.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

Severity.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

SheetCollate.getName()
获取类别的名称，此属性值是该类别的一个实例。

String

Sides.getName()
获取类别的名称，此属性值是该类别的一个实例。

protected  String[]

Chromaticity.getStringTable()
返回 Chromaticity 类的字符串表。

protected  String[]

ColorSupported.getStringTable()
返回 ColorSupported 类的字符串表。

protected  String[]

Compression.getStringTable()
返回 Compression 类的字符串表。

protected  String[]

Fidelity.getStringTable()
返回 Fidelity 类的字符串表。

protected  String[]

Finishings.getStringTable()
返回 Finishings 类的字符串表。

protected  String[]

JobSheets.getStringTable()
返回 JobSheets 类的字符串表。

protected  String[]

JobState.getStringTable()
返回 JobState 类的字符串表。

protected  String[]

JobStateReason.getStringTable()
返回 JobStateReason 类的字符串表。

protected  String[]

MediaName.getStringTable()
返回 MediaTray 类的字符串表。

protected  String[]

MediaSizeName.getStringTable()
返回 MediaSizeName 类的字符串表。

protected  String[]

MediaTray.getStringTable()
返回 MediaTray 类字符串表。

protected  String[]

MultipleDocumentHandling.getStringTable()
返回 MultipleDocumentHandling 类的字符串表。

protected  String[]

OrientationRequested.getStringTable()
返回类 OrientationRequested 的字符串表。

protected  String[]

PDLOverrideSupported.getStringTable()
返回类 PDLOverrideSupported 的字符串表。

protected  String[]

PresentationDirection.getStringTable()
返回类 PresentationDirection 的字符串表。

protected  String[]

PrintQuality.getStringTable()
返回类 PrintQuality 的字符串表。

protected  String[]

PrinterIsAcceptingJobs.getStringTable()
返回类 PrinterIsAcceptingJobs 的字符串表。

protected  String[]

PrinterState.getStringTable()
返回类 PrinterState 的字符串表。

protected  String[]

PrinterStateReason.getStringTable()
返回类 PrinterStateReason 的字符串表。

protected  String[]

ReferenceUriSchemesSupported.getStringTable()
返回类 ReferenceUriSchemesSupported 的字符串表。

protected  String[]

Severity.getStringTable()
返回类 Severity 的字符串表。

protected  String[]

SheetCollate.getStringTable()
返回类 SheetCollate 的字符串表。

protected  String[]

Sides.getStringTable()
返回类 Sides 的字符串表。

String

MediaPrintableArea.toString()
以 mm 为单位返回此矩形大小属性的字符串版本。

String

MediaPrintableArea.toString(int units, String unitsName)
以给定单位返回此矩形大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute.standard 中的方法

String

MediaPrintableArea.toString(int units, String unitsName)
以给定单位返回此矩形大小属性的字符串版本。

参数类型为 String 的 javax.print.attribute.standard 中的构造方法

DocumentName(String documentName, Locale locale)
构造具有给定文档名称和语言环境的新文档名称属性。

JobMessageFromOperator(String message, Locale locale)
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。

JobName(String jobName, Locale locale)
构造具有给定作业名称和语言环境的新JobName属性。

JobOriginatingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。

OutputDeviceAssigned(String deviceName, Locale locale)
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。

PageRanges(String members)
构造具有给定成员（字符串形式）的新 PageRanges 属性。

PrinterInfo(String info, Locale locale)
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。

PrinterLocation(String location, Locale locale)
构造具有给定位置和语言环境的新 PrinterLocation 属性。

PrinterMakeAndModel(String makeAndModel, Locale locale)
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。

PrinterMessageFromOperator(String message, Locale locale)
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。

PrinterName(String printerName, Locale locale)
构造具有给定名称和语言环境的新 PrinterName 属性。

RequestingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。

javax.print.event 中 String 的使用

返回 String 的 javax.print.event 中的方法

String

PrintEvent.toString()

javax.rmi.CORBA 中 String 的使用

返回 String 的 javax.rmi.CORBA 中的方法

static String

Util.getCodebase(Class clz)
返回给定类的代码基（如果存在）。

String

UtilDelegate.getCodebase(Class clz)
Util.getCodebase(java.lang.Class) 的委托调用。

String

ValueHandler.getRMIRepositoryID(Class clz)
返回给定 Java 类的 CORBA RepositoryId。

String

Stub.toString()
返回此 stub 的字符串表示形式。

String

StubDelegate.toString(Stub self)
Stub.toString() 的委托调用。

参数类型为 String 的 javax.rmi.CORBA 中的方法

static Class

Util.loadClass(String className, String remoteCodebase, ClassLoader loader)
为指定的类返回一个类实例。

Class

UtilDelegate.loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。

Serializable

ValueHandler.readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender)
使用 Java 语义从流中读取一个值。

javax.rmi.ssl 中 String 的使用

返回 String 的 javax.rmi.ssl 中的方法

String[]

SslRMIServerSocketFactory.getEnabledCipherSuites()
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则返回 null。

String[]

SslRMIServerSocketFactory.getEnabledProtocols()
返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则返回 null。

参数类型为 String 的 javax.rmi.ssl 中的方法

Socket

SslRMIClientSocketFactory.createSocket(String host, int port)
创建一个 SSL 套接字。

参数类型为 String 的 javax.rmi.ssl 中的构造方法

SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

javax.script 中 String 的使用

声明为 String 的 javax.script 中的字段

static String

ScriptEngine.ARGV
指定值的保留键，它将一个位置参数数组传递给某一脚本。

static String

ScriptEngine.ENGINE
指定值的保留键，它是 ScriptEngine 实现的名称。

static String

ScriptEngine.ENGINE_VERSION
指定值的保留键，它标识 ScriptEngine 实现的版本。

static String

ScriptEngine.FILENAME
指定值的保留键，它是将被执行的文件的名称。

static String

ScriptEngine.LANGUAGE
指定值的保留键，它是受实现支持的 Scripting Language 的完全名称。

static String

ScriptEngine.LANGUAGE_VERSION
指定值的保留键，它标识受实现支持的脚本语言的版本。

static String

ScriptEngine.NAME
指定值的保留键，它标识脚本语言的短名称。

返回 String 的 javax.script 中的方法

String

ScriptEngineFactory.getEngineName()
返回 ScriptEngine 的完全名称。

String

ScriptEngineFactory.getEngineVersion()
返回 ScriptEngine 的版本。

String

ScriptException.getFileName()
获取导致错误的脚本的源。

String

ScriptEngineFactory.getLanguageName()
返回此 ScriptEngine 支持的脚本语言的名称。

String

ScriptEngineFactory.getLanguageVersion()
返回此 ScriptEngine 支持的脚本语言的版本。

String

ScriptException.getMessage()
返回一条消息，该消息包含传递给构造方法的 String，以及行号、列号和文件名（如果它们已知）。

String

ScriptEngineFactory.getMethodCallSyntax(String obj, String m, String... args)
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。

String

ScriptEngineFactory.getOutputStatement(String toDisplay)
返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。

String

ScriptEngineFactory.getProgram(String... statements)
返回一个包含给定语句的有效脚本语言的可执行程序。

返回变量类型为 String 的类型的 javax.script 中的方法

Set<Map.Entry<String,Object>>

SimpleBindings.entrySet()
返回此映射中包含的映射关系的 Set 视图。

List<String>

ScriptEngineFactory.getExtensions()
返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。

List<String>

ScriptEngineFactory.getMimeTypes()
返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。

List<String>

ScriptEngineFactory.getNames()
返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。

Set<String>

SimpleBindings.keySet()
返回此映射中包含的键的 Set 视图。

参数类型为 String 的 javax.script 中的方法

CompiledScript

Compilable.compile(String script)
编译脚本（以 String 形式表示的源），以便以后执行。

Object

AbstractScriptEngine.eval(String script)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。

Object

ScriptEngine.eval(String script)
执行指定的脚本。

Object

AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。

Object

ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。

Object

ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。

Object

AbstractScriptEngine.get(String key)
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。

Object

ScriptEngine.get(String key)
获取在此引擎的状态中设置的值。

Object

ScriptEngineManager.get(String key)
获取 Global Scope 中指定键的值。

Object

ScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

SimpleScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

ScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

Object

SimpleScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

int

ScriptContext.getAttributesScope(String name)
获取定义了某个属性的最小范围。

int

SimpleScriptContext.getAttributesScope(String name)
获取用来定义属性的最小范围。

ScriptEngine

ScriptEngineManager.getEngineByExtension(String extension)
查找并创建一个给定扩展的 ScriptEngine。

ScriptEngine

ScriptEngineManager.getEngineByMimeType(String mimeType)
查找并创建一个给定 mime 类型的 ScriptEngine。

ScriptEngine

ScriptEngineManager.getEngineByName(String shortName)
查找并创建一个给定名称的 ScriptEngine。

String

ScriptEngineFactory.getMethodCallSyntax(String obj, String m, String... args)
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。

String

ScriptEngineFactory.getMethodCallSyntax(String obj, String m, String... args)
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。

String

ScriptEngineFactory.getOutputStatement(String toDisplay)
返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。

Object

ScriptEngineFactory.getParameter(String key)
返回属性值，该属性的含义可能是特定于实现的。

String

ScriptEngineFactory.getProgram(String... statements)
返回一个包含给定语句的有效脚本语言的可执行程序。

Object

Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

void

AbstractScriptEngine.put(String key, Object value)
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。

Object

Bindings.put(String name, Object value)
设置指定的值。

void

ScriptEngine.put(String key, Object value)
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。

void

ScriptEngineManager.put(String key, Object value)
设置 Global Scope 中指定的键/值对。

Object

SimpleBindings.put(String name, Object value)
设置底层 map 字段中的指定键/值。

void

ScriptEngineManager.registerEngineExtension(String extension, ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理扩展。

void

ScriptEngineManager.registerEngineMimeType(String type, ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理 mime 类型。

void

ScriptEngineManager.registerEngineName(String name, ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理语言名称。

Object

ScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

Object

SimpleScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

void

ScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

void

SimpleScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

类型变量类型为 String 的 javax.script 中的方法参数

void

Bindings.putAll(Map<? extends String,? extends Object> toMerge)
将给定 Map 中的所有映射关系添加到此 Bindings 中。

void

SimpleBindings.putAll(Map<? extends String,? extends Object> toMerge)
putAll 是使用 Map.putAll 实现的。

参数类型为 String 的 javax.script 中的构造方法

ScriptException(String s)
使用将在其消息中使用的 String 创建一个 ScriptException。

ScriptException(String message, String fileName, int lineNumber)
使用将在错误消息中使用的消息、文件名和行号创建一个 ScriptException。

ScriptException(String message, String fileName, int lineNumber, int columnNumber)
指定消息、文件名、行号和列号的 ScriptException 构造方法。

类型变量类型为 String 的 javax.script 中的构造方法参数

SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。

javax.security.auth 中 String 的使用

返回 String 的 javax.security.auth 中的方法

String

PrivateCredentialPermission.getActions()
返回操作的“规范的字符串表示形式”。

String

PrivateCredentialPermission.getCredentialClass()
返回与此 PrivateCredentialPermission 相关联的 Credential 的 Class 名称。

String[][]

PrivateCredentialPermission.getPrincipals()
返回与此 PrivateCredentialPermission 相关联的 Principal 类和名称。

String

Subject.toString()
返回此 Subject 的字符串表示形式。

参数类型为 String 的 javax.security.auth 中的构造方法

AuthPermission(String name)
创建具有指定名称的新 AuthPermission。

AuthPermission(String name, String actions)
创建具有指定名称的新 AuthPermission 对象。

DestroyFailedException(String msg)
构造带指定详细消息的 DestroyFailedException。

PrivateCredentialPermission(String name, String actions)
创建具有指定 name 的新 PrivateCredentialPermission。

RefreshFailedException(String msg)
构造带指定详细消息的 RefreshFailedException。

javax.security.auth.callback 中 String 的使用

返回 String 的 javax.security.auth.callback 中的方法

String[]

ChoiceCallback.getChoices()
获取选项列表。

String

NameCallback.getDefaultName()
获取默认名称。

String

TextInputCallback.getDefaultText()
获取默认文本。

String

TextOutputCallback.getMessage()
获取将要显示的消息。

String

NameCallback.getName()
获取检索到的名称。

String[]

ConfirmationCallback.getOptions()
获取确认选项。

String

ChoiceCallback.getPrompt()
获取提示。

String

ConfirmationCallback.getPrompt()
获取提示。

String

NameCallback.getPrompt()
获取提示。

String

PasswordCallback.getPrompt()
获取提示。

String

TextInputCallback.getPrompt()
获取提示。

String

TextInputCallback.getText()
获取检索到的文本。

参数类型为 String 的 javax.security.auth.callback 中的方法

void

NameCallback.setName(String name)
设置检索到的名称。

void

TextInputCallback.setText(String text)
设置获取到的文本。

参数类型为 String 的 javax.security.auth.callback 中的构造方法

ChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multipleSelectionsAllowed)
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。

ChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multipleSelectionsAllowed)
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。

ConfirmationCallback(int messageType, String[] options, int defaultOption)
构造一个带有消息类型、选项列表和默认选项的 ConfirmationCallback。

ConfirmationCallback(String prompt, int messageType, int optionType, int defaultOption)
构造一个带有提示、消息类型、选项类型和默认选项的 ConfirmationCallback。

ConfirmationCallback(String prompt, int messageType, String[] options, int defaultOption)
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。

ConfirmationCallback(String prompt, int messageType, String[] options, int defaultOption)
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。

NameCallback(String prompt)
构造一个带提示的 NameCallback。

NameCallback(String prompt, String defaultName)
构造一个带提示和默认名称的 NameCallback。

PasswordCallback(String prompt, boolean echoOn)
构造带提示和布尔值的 PasswordCallback，该布尔值指定键入密码时是否应该显示该密码。

TextInputCallback(String prompt)
构造一个带提示的 TextInputCallback。

TextInputCallback(String prompt, String defaultText)
构造一个带提示和默认输入值的 TextInputCallback。

TextOutputCallback(int messageType, String message)
构造一个带消息类型和将要显示的消息的 TextOutputCallback。

UnsupportedCallbackException(Callback callback, String msg)
构造带指定详细消息的 UnsupportedCallbackException。

javax.security.auth.kerberos 中 String 的使用

返回 String 的 javax.security.auth.kerberos 中的方法

String

ServicePermission.getActions()
返回动作的规范化字符串表示形式。

String

KerberosKey.getAlgorithm()
返回此密钥的标准算法名称。

String

KerberosKey.getFormat()
返回此秘密密钥的编码格式的名称。

String

KerberosPrincipal.getName()
返回的字符串对应于 Kerberos Principal 名称的 single-string 表示形式，RFC 1964 的 2.1 小节中指定了这种表示形式。

String

KerberosPrincipal.getRealm()
返回此 Kerberos 主体的域组件。

String

KerberosKey.toString()

String

KerberosPrincipal.toString()

String

KerberosTicket.toString()

参数类型为 String 的 javax.security.auth.kerberos 中的构造方法

DelegationPermission(String principals)
创建带有指定从属主体和目标主体的新 DelegationPermission。

DelegationPermission(String principals, String actions)
创建带有指定从属主体和目标主体的新 DelegationPermission。

KerberosKey(KerberosPrincipal principal, char[] password, String algorithm)
根据主体的密码构造 KerberosKey。

KerberosPrincipal(String name)
根据提供的字符串输入构造 KerberosPrincipal。

KerberosPrincipal(String name, int nameType)
根据提供的字符串和名称类型输入构造 KerberosPrincipal。

ServicePermission(String servicePrincipal, String action)
创建带指定的 servicePrincipal 和 action 的新 ServicePermission。

javax.security.auth.login 中 String 的使用

返回 String 的 javax.security.auth.login 中的方法

String

AppConfigurationEntry.getLoginModuleName()
获取所配置的 LoginModule 的类名称。

String

Configuration.getType()
返回此 Configuration 的类型。

String

AppConfigurationEntry.LoginModuleControlFlag.toString()
返回此 controlFlag 的字符串表示形式。

返回变量类型为 String 的类型的 javax.security.auth.login 中的方法

Map<String,?>

AppConfigurationEntry.getOptions()
获取为此 LoginModule 配置的选项。

参数类型为 String 的 javax.security.auth.login 中的方法

protected abstract  AppConfigurationEntry[]

ConfigurationSpi.engineGetAppConfigurationEntry(String name)
获取指定 name 的 AppConfigurationEntry。

abstract  AppConfigurationEntry[]

Configuration.getAppConfigurationEntry(String name)
获取此 Configuration 中指定 name 的 AppConfigurationEntry。

static Configuration

Configuration.getInstance(String type, Configuration.Parameters params)
返回指定类型的 Configuration 对象。

static Configuration

Configuration.getInstance(String type, Configuration.Parameters params, Provider provider)
返回指定类型的 Configuration 对象。

static Configuration

Configuration.getInstance(String type, Configuration.Parameters params, String provider)
返回指定类型的 Configuration 对象。

参数类型为 String 的 javax.security.auth.login 中的构造方法

AccountException(String msg)
构造带指定详细消息的 AccountException。

AccountExpiredException(String msg)
构造带指定详细消息的 AccountExpiredException。

AccountLockedException(String msg)
构造带指定详细消息的 AccountLockedException。

AccountNotFoundException(String msg)
构造带指定详细消息的 AccountNotFoundException。

AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

CredentialException(String msg)
构造带指定详细消息的 CredentialException。

CredentialExpiredException(String msg)
构造带指定详细消息的 CredentialExpiredException。

CredentialNotFoundException(String msg)
构造带指定详细消息的 CredentialNotFoundException。

FailedLoginException(String msg)
构造带指定详细消息的 FailedLoginException。

LoginContext(String name)
使用 name 实例化一个新 LoginContext 对象。

LoginContext(String name, CallbackHandler callbackHandler)
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。

LoginContext(String name, Subject subject)
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。

LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。

LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

LoginException(String msg)
构造带指定详细消息的 LoginException。

类型变量类型为 String 的 javax.security.auth.login 中的构造方法参数

AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

javax.security.auth.spi 中 String 的使用

类型变量类型为 String 的 javax.security.auth.spi 中的方法参数

void

LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

void

LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

javax.security.auth.x500 中 String 的使用

声明为 String 的 javax.security.auth.x500 中的字段

static String

X500Principal.CANONICAL
标识名的规范化字符串格式。

static String

X500Principal.RFC1779
标识名的 RFC 1779 字符串格式。

static String

X500Principal.RFC2253
标识名的 RFC 2253 字符串格式。

返回 String 的 javax.security.auth.x500 中的方法

String

X500PrivateCredential.getAlias()
返回 KeyStore 别名。

String

X500Principal.getName()
返回使用 RFC 2253 中所定义格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.toString()
返回此 X500Principal 的用户友好的字符串表示形式。

参数类型为 String 的 javax.security.auth.x500 中的方法

String

X500Principal.getName(String format)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

类型变量类型为 String 的 javax.security.auth.x500 中的方法参数

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

String

X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

参数类型为 String 的 javax.security.auth.x500 中的构造方法

X500Principal(String name)
根据 X.500 标识名（例："CN=Duke、 OU=JavaSoft、 O=Sun Microsystems、 C=US"）的字符串表示形式创建 X500Principal。

X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

类型变量类型为 String 的 javax.security.auth.x500 中的构造方法参数

X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

javax.security.cert 中 String 的使用

返回 String 的 javax.security.cert 中的方法

abstract  String

X509Certificate.getSigAlgName()
获取用于该证书签名算法的名称。

abstract  String

X509Certificate.getSigAlgOID()
获取证书的签名算法 OID 字符串。

abstract  String

Certificate.toString()
返回此证书的字符串表示形式。

参数类型为 String 的 javax.security.cert 中的方法

abstract  void

Certificate.verify(PublicKey key, String sigProvider)
验证是否已使用与指定公钥相对应的私钥签署了此证书。

参数类型为 String 的 javax.security.cert 中的构造方法

CertificateEncodingException(String message)
构造带指定详细信息的 CertificateEncodingException。

CertificateException(String msg)
构造带给定详细消息的 CertificateException。

CertificateExpiredException(String message)
构造带指定详细信息的 CertificateExpiredException。

CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。

CertificateParsingException(String message)
构造带指定详细信息的 CertificateParsingException。

javax.security.sasl 中 String 的使用

声明为 String 的 javax.security.sasl 中的字段

static String

Sasl.CREDENTIALS
属性的名称，它指定要使用的证书。

static String

Sasl.MAX_BUFFER
属性名，指定 SaslClient/SaslServer 接收缓冲区的最大大小（以字节为单位）。

static String

Sasl.POLICY_FORWARD_SECRECY
属性名，指定是否需要在会话间实现了转发安全性的机制。

static String

Sasl.POLICY_NOACTIVE
属性名，指定是否允许易受主动式攻击（非字典）的机制。

static String

Sasl.POLICY_NOANONYMOUS
属性名，指定是否允许接受匿名登录的机制。

static String

Sasl.POLICY_NODICTIONARY
属性名，指定是否允许易受被动式字典攻击的机制。

static String

Sasl.POLICY_NOPLAINTEXT
属性名，指定是否允许易受简单被动式攻击（例如 "PLAIN"）的机制。

static String

Sasl.POLICY_PASS_CREDENTIALS
属性名，指定是否需要传递客户端证书的机制。

static String

Sasl.QOP
属性名，指定要使用的保护级别。

static String

Sasl.RAW_SEND_SIZE
属性名，指定 SaslClient/SaslServer 初始发送缓冲区的最大大小（以字节为单位）。

static String

Sasl.REUSE
属性名，指定是否重用以前已验证过的会话信息。

static String

Sasl.SERVER_AUTH
属性名，指定服务器是否必须验证客户端。

static String

Sasl.STRENGTH
属性名，指定要使用的密码强度。

返回 String 的 javax.security.sasl 中的方法

String

AuthorizeCallback.getAuthenticationID()
返回要检查的验证 id。

String

AuthorizeCallback.getAuthorizationID()
返回要检查的授权 id。

String

SaslServer.getAuthorizationID()
报告此会话客户端的有效授权 ID。

String

AuthorizeCallback.getAuthorizedID()
返回已授权用户的 id。

String

SaslClient.getMechanismName()
返回此 SASL 客户端的 IANA 注册机制名。

String

SaslServer.getMechanismName()
返回此 SASL 服务器的 IANA 注册机制名。

String[]

SaslClientFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

String[]

SaslServerFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

String

SaslException.toString()
返回此异常的字符串表示形式。

参数类型为 String 的 javax.security.sasl 中的方法

static SaslClient

Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

static SaslClient

Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

SaslClient

SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

SaslClient

SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

static SaslServer

Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
为指定机制创建一个 SaslServer。

SaslServer

SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslServer。

Object

SaslClient.getNegotiatedProperty(String propName)
获取已协商的属性。

Object

SaslServer.getNegotiatedProperty(String propName)
获取已协商的属性。

void

AuthorizeCallback.setAuthorizedID(String id)
设置已授权实体的 id。

类型变量类型为 String 的 javax.security.sasl 中的方法参数

static SaslClient

Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

SaslClient

SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslClient。

static SaslServer

Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
为指定机制创建一个 SaslServer。

SaslServer

SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh)
使用提供的参数创建 SaslServer。

String[]

SaslClientFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

String[]

SaslServerFactory.getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

参数类型为 String 的 javax.security.sasl 中的构造方法

AuthenticationException(String detail)
构造带详细消息的新 AuthenticationException 实例。

AuthenticationException(String detail, Throwable ex)
构造带详细消息和根异常的新 AuthenticationException 实例。

AuthorizeCallback(String authnID, String authzID)
构造 AuthorizeCallback 的实例。

RealmCallback(String prompt)
构造带提示的 RealmCallback。

RealmCallback(String prompt, String defaultRealmInfo)
构造带提示和默认领域信息的 RealmCallback。

RealmChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multiple)
构造带提示、选项列表和默认选项的 RealmChoiceCallback。

RealmChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multiple)
构造带提示、选项列表和默认选项的 RealmChoiceCallback。

SaslException(String detail)
构造带详细消息的新 SaslException 实例。

SaslException(String detail, Throwable ex)
构造带详细消息和根异常的新 SaslException 实例。

javax.sound.midi 中 String 的使用

返回 String 的 javax.sound.midi 中的方法

String

MidiDevice.Info.getDescription()
获得关于设备的描述。

String

Soundbank.getDescription()
获得音库适于显示的文本描述。

String

MidiDevice.Info.getName()
获得设备的名称。

String

Soundbank.getName()
获得音库的名称。

String

SoundbankResource.getName()
获得资源的名称。

String

MidiDevice.Info.getVendor()
获得提供设备的公司名称。

String

Soundbank.getVendor()
获得命名提供此音库的公司的 string

String

MidiDevice.Info.getVersion()
获得设备的版本。

String

Soundbank.getVersion()
获得音库的版本字符串。

String

MidiDevice.Info.toString()
提供设备信息的字符串表示形式。

String

Sequencer.SyncMode.toString()
以模式的字符串表示形式提供此同步模式的名称。

返回变量类型为 String 的类型的 javax.sound.midi 中的方法

Map<String,Object>

MidiFileFormat.properties()
获得属性的一个不可修改的映射。

参数类型为 String 的 javax.sound.midi 中的方法

Object

MidiFileFormat.getProperty(String key)
获得由键指定的属性值。

参数类型为 String 的 javax.sound.midi 中的构造方法

Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。

InvalidMidiDataException(String message)
构造带指定详细消息的 InvalidMidiDataException。

MidiDevice.Info(String name, String vendor, String description, String version)
构造一个设备 info 对象。

MidiUnavailableException(String message)
构造带指定详细消息的 MidiUnavailableException。

Sequencer.SyncMode(String name)
构造一个同步模式。

SoundbankResource(Soundbank soundBank, String name, Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。

类型变量类型为 String 的 javax.sound.midi 中的构造方法参数

MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。

javax.sound.sampled 中 String 的使用

返回 String 的 javax.sound.sampled 中的方法

String

Mixer.Info.getDescription()
获得混频器的描述。

String

AudioFileFormat.Type.getExtension()
获得此文件类型的常见文件扩展名。

String

FloatControl.getMaxLabel()
获得最大值的标签，如 "Right" 或 "Full"。

String

FloatControl.getMidLabel()
获得中点值的标签，如 "Center" 或 "Default"。

String

FloatControl.getMinLabel()
获得最小值的标签，如 "Left" 或 "Off"。

String

Mixer.Info.getName()
获得混频器的名称。

String

Port.Info.getName()
获得端口的名称。

String

ReverbType.getName()
获得此回响类型的名称。

String

BooleanControl.getStateLabel(boolean state)
获得指定状态的标签。

String

FloatControl.getUnits()
获得表示控件值的单位标签，如 "dB" 或 "frames per second"。

String

Mixer.Info.getVendor()
获得混频器的供应商。

String

Mixer.Info.getVersion()
获得混频器的版本。

String

AudioFileFormat.toString()
提供文件格式的字符串表示形式。

String

AudioFileFormat.Type.toString()
按文件类型的 String 表示形式提供文件类型的名称。

String

AudioFormat.toString()
返回描述格式的字符串，如："PCM SIGNED 22050 Hz 16 bit mono big-endian"。

String

AudioFormat.Encoding.toString()
提供编码的 String 表示形式。

String

BooleanControl.toString()
提供控件的字符串表示形式

String

CompoundControl.toString()
提供控件的字符串表示形式

String

Control.toString()
获得描述控件类型及其当前状态的 String。

String

Control.Type.toString()
提供控件类型的 String 表示形式。

String

EnumControl.toString()
提供该控件的字符串表示形式。

String

FloatControl.toString()
提供控件的字符串表示形式

String

LineEvent.toString()
获得事件的字符串表示形式。

String

LineEvent.Type.toString()
以字符串形式返回类型名称。

String

Mixer.Info.toString()
提供混频器信息的字符串表示形式。

String

Port.Info.toString()
提供该端口的 String 表示形式。

String

ReverbType.toString()
提供回响类型的 String 表示形式，包括其名称和其参数设置。

String

DataLine.Info.toString()
获得数据行信息的文本描述。

String

Line.Info.toString()
获得行信息的文本描述。

返回变量类型为 String 的类型的 javax.sound.sampled 中的方法

Map<String,Object>

AudioFileFormat.properties()
获得不可修改的属性映射。

Map<String,Object>

AudioFormat.properties()
获取不可修改的属性映射。

参数类型为 String 的 javax.sound.sampled 中的方法

Object

AudioFileFormat.getProperty(String key)
获得键指定的属性值。

Object

AudioFormat.getProperty(String key)
获取键指定的属性值。

参数类型为 String 的 javax.sound.sampled 中的构造方法

AudioFileFormat.Type(String name, String extension)
构造文件类型。

AudioFormat.Encoding(String name)
构造一个新编码。

AudioPermission(String name)
创建具有指定符号名（如 "play" 或 "record"）的 AudioPermission 对象。

AudioPermission(String name, String actions)
创建具有指定符号名（"play" 或 "record"）的 AudioPermission 对象。

BooleanControl.Type(String name)
构造新的 boolean 控件类型。

BooleanControl(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel)
构造一个具有给定参数的新 boolean 控件对象。

CompoundControl.Type(String name)
构造一个新的组合控件类型。

Control.Type(String name)
构造具有指定名称的新控件类型。

EnumControl.Type(String name)
构造一个新的枚举控件类型。

FloatControl.Type(String name)
构造新的 float 控件类型。

FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units)
构造具有给定参数的新 float 控件对象。

FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel)
构造具有给定参数的新 float 控件对象

LineEvent.Type(String name)
构造新的事件类型。

LineUnavailableException(String message)
构造具有指定详细消息的 LineUnavailableException。

Mixer.Info(String name, String vendor, String description, String version)
构造混频器的 info 对象，并向它传递给定的文本信息。

Port.Info(Class<?> lineClass, String name, boolean isSource)
根据给定的信息构造端口的 info 对象。

ReverbType(String name, int earlyReflectionDelay, float earlyReflectionIntensity, int lateReflectionDelay, float lateReflectionIntensity, int decayTime)
构造具有指定回响参数值的新回响类型。

UnsupportedAudioFileException(String message)
构造具有指定详细消息的 UnsupportedAudioFileException。

类型变量类型为 String 的 javax.sound.sampled 中的构造方法参数

AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。

AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sql 中 String 的使用

返回 String 的 javax.sql 中的方法

String

RowSet.getCommand()
获取此 RowSet 对象的命令属性。

String

RowSet.getDataSourceName()
获取标识此 RowSet 对象的数据源的逻辑名称。

String

RowSet.getPassword()
获取用于创建数据库连接的密码。

String

RowSet.getUrl()
如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。

String

RowSet.getUsername()
获取用于创建此 RowSet 对象的数据库连接的用户名。

返回变量类型为 String 的类型的 javax.sql 中的方法

Map<String,Class<?>>

RowSet.getTypeMap()
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。

参数类型为 String 的 javax.sql 中的方法

Connection

DataSource.getConnection(String username, String password)
尝试建立与此 DataSource 对象所表示的数据源的连接。

PooledConnection

ConnectionPoolDataSource.getPooledConnection(String user, String password)
尝试建立可用作入池连接的物理数据库连接。

XAConnection

XADataSource.getXAConnection(String user, String password)
使用给定的用户名和密码，尝试建立一个物理数据库连接。

void

RowSet.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

RowSet.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。

void

RowSet.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定的 java.math.BigDecimal 值。

void

RowSet.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

RowSet.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有给定字节数。

void

RowSet.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。

void

RowSet.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。

void

RowSet.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。

void

RowSet.setBoolean(String parameterName, boolean x)
将指定参数设置为给定的 Java boolean 值。

void

RowSet.setByte(String parameterName, byte x)
将指定参数设置为给定的 Java byte 值。

void

RowSet.setBytes(String parameterName, byte[] x)
将指定参数设置为给定的 Java byte 数组。

void

RowSetMetaData.setCatalogName(int columnIndex, String catalogName)
将指定列的表的类别名称（如果有）设置为给定的 String。

void

RowSet.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。

void

RowSet.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。

void

RowSet.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。

void

RowSet.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

RowSet.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

RowSetMetaData.setColumnLabel(int columnIndex, String label)
将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。

void

RowSetMetaData.setColumnName(int columnIndex, String columnName)
将指定列的名称设置为给定的 String。

void

RowSetMetaData.setColumnTypeName(int columnIndex, String typeName)
将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。

void

RowSet.setCommand(String cmd)
将此 RowSet 对象的命令属性设置为给定的 SQL 查询。

void

RowSet.setDataSourceName(String name)
将此 RowSet 对象的数据源名称属性设置为给定的 String。

void

RowSet.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。

void

RowSet.setDate(String parameterName, Date x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

void

RowSet.setDouble(String parameterName, double x)
将指定参数设置为给定的 Java double 值。

void

RowSet.setFloat(String parameterName, float x)
将指定参数设置为给定的 Java float 值。

void

RowSet.setInt(String parameterName, int x)
将指定参数设置为给定的 Java int 值。

void

RowSet.setLong(String parameterName, long x)
将指定参数设置为给定的 Java long 值。

void

RowSet.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。

void

RowSet.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。

void

RowSet.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。

void

RowSet.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

RowSet.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

RowSet.setNString(int parameterIndex, String value)
将指定参数设置为给定的 String 对象。

void

RowSet.setNString(String parameterName, String value)
将指定参数设置为给定的 String 对象。

void

RowSet.setNull(int paramIndex, int sqlType, String typeName)
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。

void

RowSet.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。

void

RowSet.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

RowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

RowSet.setPassword(String password)
将此 RowSet 对象的数据库密码设置为给定的 String。

void

RowSet.setRowId(String parameterName, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。

void

RowSetMetaData.setSchemaName(int columnIndex, String schemaName)
将指定列的表模式的名称（如果有）设置为给定的 String。

void

RowSet.setShort(String parameterName, short x)
将指定参数设置为给定的 Java short 值。

void

RowSet.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定的 java.sql.SQLXML 对象。

void

RowSet.setString(int parameterIndex, String x)
将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。

void

RowSet.setString(String parameterName, String x)
将指定参数设置为给定的 Java String 值。

void

RowSetMetaData.setTableName(int columnIndex, String tableName)
将指定列的表名称（如果有）设置为给定的 String。

void

RowSet.setTime(String parameterName, Time x)
将指定参数设置为给定的 java.sql.Time 值。

void

RowSet.setTime(String parameterName, Time x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

void

RowSet.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。

void

RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

void

RowSet.setUrl(String url)
设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。

void

RowSet.setUsername(String name)
将此 RowSet 对象的用户名属性设置为给定的 String。

类型变量类型为 String 的 javax.sql 中的方法参数

void

RowSet.setTypeMap(Map<String,Class<?>> map)
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。

javax.sql.rowset 中 String 的使用

声明为 String 的 javax.sql.rowset 中的字段

static String

WebRowSet.PUBLIC_XML_SCHEMA
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的公共标识符。

static String

WebRowSet.SCHEMA_SYSTEM_ID
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的 URL。

返回 String 的 javax.sql.rowset 中的方法

String

RowSetMetaDataImpl.getCatalogName(int columnIndex)
获取派生指定列中值的表的类别名称。

String

RowSetMetaDataImpl.getColumnClassName(int columnIndex)
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。

String

RowSetMetaDataImpl.getColumnLabel(int columnIndex)
获取用于打印输出和显示的指定列的建议列标题。

String

RowSetMetaDataImpl.getColumnName(int columnIndex)
获取指定列的名称。

String

RowSetMetaDataImpl.getColumnTypeName(int columnIndex)
获取存储在指定列中值的特定于 DBMS 的类型名称。

String

BaseRowSet.getCommand()
获取作为此 RowSet 对象的命令的 SQL 查询。

String

BaseRowSet.getDataSourceName()
返回向使用 Java Naming and Directory Interface (JNDI) API 的命名服务所提供的逻辑名，这将获得 javax.sql.DataSource 对象。

String[]

Joinable.getMatchColumnNames()
获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。

String

BaseRowSet.getPassword()
返回用于创建此 RowSet 对象的数据库连接的密码。

String[]

JoinRowSet.getRowSetNames()
返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。

String

RowSetMetaDataImpl.getSchemaName(int columnIndex)
获取派生指定列中值的表的模式名称。

String

CachedRowSet.getTableName()
返回创建此 CachedRowSet 对象时所用对象（表）的标识符。

String

RowSetMetaDataImpl.getTableName(int columnIndex)
获取派生指定列中值的表名称。

String

BaseRowSet.getUrl()
获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。

String

BaseRowSet.getUsername()
返回用于创建数据库连接的用户名。

String

JoinRowSet.getWhereClause()
返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。

返回变量类型为 String 的类型的 javax.sql.rowset 中的方法

Map<String,Class<?>>

BaseRowSet.getTypeMap()
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 String 的 javax.sql.rowset 中的方法

void

JoinRowSet.addRowSet(RowSet[] rowset, String[] columnName)
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。

void

JoinRowSet.addRowSet(RowSet rowset, String columnName)
将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。

boolean

CachedRowSet.columnUpdated(String columnName)
指示此 CachedRowSet 对象当前行中的指定列是否已更新。

boolean

Predicate.evaluate(Object value, String columnName)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。

void

BaseRowSet.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定的输入流。

void

BaseRowSet.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。

void

BaseRowSet.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定的 java.math.BigDecimal 值。

void

BaseRowSet.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。

void

BaseRowSet.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。

void

BaseRowSet.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。

void

BaseRowSet.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。

void

BaseRowSet.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。

void

BaseRowSet.setBoolean(String parameterName, boolean x)
将指定参数设置为给定的 Java boolean 值。

void

BaseRowSet.setByte(String parameterName, byte x)
将指定参数设置为给定的 Java byte 值。

void

BaseRowSet.setBytes(String parameterName, byte[] x)
将指定参数设置为给定的 Java byte 数组。

void

RowSetMetaDataImpl.setCatalogName(int columnIndex, String catalogName)
将派生指定列的表名称设置为 catalogName。

void

BaseRowSet.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。

void

BaseRowSet.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。

void

BaseRowSet.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。

void

BaseRowSet.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

RowSetMetaDataImpl.setColumnLabel(int columnIndex, String label)
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。

void

RowSetMetaDataImpl.setColumnName(int columnIndex, String columnName)
将指定列的列名称设置为给定的名称。

void

RowSetMetaDataImpl.setColumnTypeName(int columnIndex, String typeName)
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。

void

BaseRowSet.setCommand(String cmd)
将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。

void

BaseRowSet.setDataSourceName(String name)
将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。

void

BaseRowSet.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。

void

BaseRowSet.setDate(String parameterName, Date x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

void

BaseRowSet.setDouble(String parameterName, double x)
将指定参数设置为给定的 Java double 值。

void

BaseRowSet.setFloat(String parameterName, float x)
将指定参数设置为给定的 Java float 值。

void

BaseRowSet.setInt(String parameterName, int x)
将指定参数设置为给定的 Java int 值。

void

BaseRowSet.setLong(String parameterName, long x)
将指定参数设置为给定的 Java long 值。

void

Joinable.setMatchColumn(String columnName)
将指定的列设置为此 RowSet 对象的匹配列。

void

Joinable.setMatchColumn(String[] columnNames)
将指定的列设置为此 RowSet 对象的匹配列。

void

BaseRowSet.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。

void

BaseRowSet.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。

void

BaseRowSet.setNString(int parameterIndex, String value)
将指定参数设置为给定的 String 对象。

void

BaseRowSet.setNString(String parameterName, String value)
将指定参数设置为给定的 String 对象。

void

BaseRowSet.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

BaseRowSet.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。

void

BaseRowSet.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。

void

BaseRowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

BaseRowSet.setPassword(String pass)
将用于创建此 RowSet 对象的数据库连接的密码设置为给定的 String 对象。

void

BaseRowSet.setRowId(String parameterName, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。

void

RowSetMetaDataImpl.setSchemaName(int columnIndex, String schemaName)
将指定列的表的模式名称（如果有）设置为 schemaName。

void

BaseRowSet.setShort(String parameterName, short x)
将指定参数设置为给定的 Java short 值。

void

BaseRowSet.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定的 java.sql.SQLXML 对象。

void

BaseRowSet.setString(int parameterIndex, String x)
将指定参数设置为给定的 String 值。

void

BaseRowSet.setString(String parameterName, String x)
将指定参数设置为给定的 Java String 值。

void

CachedRowSet.setSyncProvider(String provider)
将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。

void

RowSetMetaDataImpl.setTableName(int columnIndex, String tableName)
将派生指定列的表名称设置为给定的表名称。

void

CachedRowSet.setTableName(String tabName)
将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。

void

BaseRowSet.setTime(String parameterName, Time x)
将指定参数设置为给定的 java.sql.Time 值。

void

BaseRowSet.setTime(String parameterName, Time x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

void

BaseRowSet.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。

void

BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

void

BaseRowSet.setUrl(String url)
将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。

void

BaseRowSet.setUsername(String name)
将此 RowSet 对象的 username 属性设置为给定的用户名。

Collection<?>

CachedRowSet.toCollection(String column)
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。

void

Joinable.unsetMatchColumn(String columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。

void

Joinable.unsetMatchColumn(String[] columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。

类型变量类型为 String 的 javax.sql.rowset 中的方法参数

void

BaseRowSet.setTypeMap(Map<String,Class<?>> map)
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 String 的 javax.sql.rowset 中的构造方法

RowSetWarning(String reason)
用给定的 reason 值构造 RowSetWarning 对象；SQLState 默认为 null，vendorCode 默认为 0。

RowSetWarning(String reason, String SQLState)
构造一个 RowSetWarning 对象，并使用给定的 reason 和 SQLState 值进行初始化。

RowSetWarning(String reason, String SQLState, int vendorCode)
构造一个完全指定的 RowSetWarning 对象，并使用给定的 reason、SQLState 和 vendorCode 值进行初始化。

javax.sql.rowset.serial 中 String 的使用

返回 String 的 javax.sql.rowset.serial 中的方法

String

SerialArray.getBaseTypeName()
获取此 SerialArray 对象元素特定于 DBMS 的类型名称。

String

SerialRef.getBaseTypeName()
返回描述 Ref 的基本类型名称的字符串。

String

SerialStruct.getSQLTypeName()
获取此 SerialStruct 对象的 SQL 类型名称。

String

SerialClob.getSubString(long pos, int length)
返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。

String

SQLInputImpl.readNString()
读取流中下一个属性并以 Java 编程语言中 String 的形式返回。

String

SQLInputImpl.readString()
以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 String 的 javax.sql.rowset.serial 中的方法

long

SerialClob.position(String searchStr, long start)
返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。

int

SerialClob.setString(long pos, String str)
在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。

int

SerialClob.setString(long pos, String str, int offset, int length)
将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。

void

SQLOutputImpl.writeNString(String x)
将下一个属性以 Java 编程语言中 String 的形式写入流中。

void

SQLOutputImpl.writeString(String x)
将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。

类型变量类型为 String 的 javax.sql.rowset.serial 中的方法参数

Object

SerialArray.getArray(long index, int count, Map<String,Class<?>> map)
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

Object

SerialArray.getArray(Map<String,Class<?>> map)
返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。

Object[]

SerialStruct.getAttributes(Map<String,Class<?>> map)
获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。

Object

SerialRef.getObject(Map<String,Class<?>> map)
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。

ResultSet

SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map)
获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。

ResultSet

SerialArray.getResultSet(Map<String,Class<?>> map)
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

参数类型为 String 的 javax.sql.rowset.serial 中的构造方法

SerialException(String msg)
创建带有指定消息的新 SerialException。

类型变量类型为 String 的 javax.sql.rowset.serial 中的构造方法参数

SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。

SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。

SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。

SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。

SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.sql.rowset.spi 中 String 的使用

声明为 String 的 javax.sql.rowset.spi 中的字段

static String

SyncFactory.ROWSET_SYNC_PROVIDER
用于同步提供者实现名称的标准属性 id。

static String

SyncFactory.ROWSET_SYNC_PROVIDER_VERSION
用于同步提供者实现版本标记的标准属性 id。

static String

SyncFactory.ROWSET_SYNC_VENDOR
用于同步提供者实现供应商名称的标准属性 id。

返回 String 的 javax.sql.rowset.spi 中的方法

abstract  String

SyncProvider.getProviderID()
返回此 SyncProvider 对象的唯一标识符。

abstract  String

SyncProvider.getVendor()
返回此 SyncProvider 实例的供应商名称

abstract  String

SyncProvider.getVersion()
返回此 SyncProvider 实例的发行版本。

参数类型为 String 的 javax.sql.rowset.spi 中的方法

Object

SyncResolver.getConflictValue(String columnName)
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

static SyncProvider

SyncFactory.getInstance(String providerID)
返回 providerID 标识的 SyncProvider 实例。

static void

SyncFactory.registerProvider(String providerID)
将给定的同步提供者添加到工厂注册器。

void

SyncResolver.setResolvedValue(String columnName, Object obj)
将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。

static void

SyncFactory.unregisterProvider(String providerID)
从工厂 SPI 注册器移除指派的当前已注册同步提供者。

参数类型为 String 的 javax.sql.rowset.spi 中的构造方法

SyncFactoryException(String msg)
构造带指定详细消息的 SyncFactoryException。

SyncProviderException(String msg)
构造带指定详细消息的 SyncProviderException 对象。

javax.swing 中 String 的使用

声明为 String 的 javax.swing 中的字段

static String

Action.ACCELERATOR_KEY
用来存储将用作动作加速器的 KeyStroke 的键。

static String

JFileChooser.ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY
标识是否使用 AcceptAllFileFilter。

static String

JFileChooser.ACCESSORY_CHANGED_PROPERTY
声明正在使用不同的 accessory 组件（例如预览文件）。

static String

Action.ACTION_COMMAND_KEY
用来确定 ActionEvent 的命令 String 的键，ActionEvent 是在 Action 因驻留在与 JComponent 关联的 Keymap 中而被通知时所创建的。

protected  String

JComboBox.actionCommand
此受保护字段是特定于实现的。

protected  String

DefaultButtonModel.actionCommand
按钮所触发的动作命令字符串。

static String

JTree.ANCHOR_SELECTION_PATH_PROPERTY
定位选择路径的绑定属性名称。

static String

JFileChooser.APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY
标识用于确认（yes、ok）按钮的助记符的更改。

static String

JFileChooser.APPROVE_BUTTON_TEXT_CHANGED_PROPERTY
标识确认（yes、ok）按钮上的文本更改。

static String

JFileChooser.APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY
标识用于确认（yes、ok）按钮的工具提示文本的更改。

static String

JFileChooser.APPROVE_SELECTION
指示确认当前的选择（与按下 yes 或 ok 相同）。

static String

SpringLayout.BASELINE
指定组件的基线。

static String

AbstractButton.BORDER_PAINTED_CHANGED_PROPERTY
标识是否绘制边框的更改。

static String

JCheckBox.BORDER_PAINTED_FLAT_CHANGED_PROPERTY
标识 flat 属性的更改。

static String

JSplitPane.BOTTOM
用于添加一个 Component 到另一个 Component 的下面。

static String

JFileChooser.CANCEL_SELECTION
指示取消当前的选择。

static String

JTree.CELL_EDITOR_PROPERTY
cellEditor 的绑定属性名称。

static String

JTree.CELL_RENDERER_PROPERTY
cellRenderer 的绑定属性名称。

static String

JFileChooser.CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY
标识预定义文件过滤器列表的更改，用户可从该列表中进行选择。

static String

JColorChooser.CHOOSER_PANELS_PROPERTY
chooserPanel 数组属性名。

static String

ScrollPaneConstants.COLUMN_HEADER
标识视口顶部左上角和右上角之间的区域。

static String

AbstractButton.CONTENT_AREA_FILLED_CHANGED_PROPERTY
标识对按钮绘制的内容区域的更改。

static String

JInternalFrame.CONTENT_PANE_PROPERTY
绑定属性名。

static String

JSplitPane.CONTINUOUS_LAYOUT_PROPERTY
绑定 continuousLayout 属性名称。

static String

JFileChooser.CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY
指示显示控制按钮。

static String

Action.DEFAULT
当前未使用。

static String

JFileChooser.DIALOG_TITLE_CHANGED_PROPERTY
标识对话框标题的更改。

static String

JFileChooser.DIALOG_TYPE_CHANGED_PROPERTY
标识显示文件类型的更改（仅显示文件、仅显示目录或显示文件和目录）。

static String

JFileChooser.DIRECTORY_CHANGED_PROPERTY
标识用户的目录更改。

static String

AbstractButton.DISABLED_ICON_CHANGED_PROPERTY
标识禁用按钮时使用的图标的更改。

static String

AbstractButton.DISABLED_SELECTED_ICON_CHANGED_PROPERTY
标识禁用并选定按钮时使用的图标的更改。

static String

Action.DISPLAYED_MNEMONIC_INDEX_KEY
用来存储对应于文本（由 NAME 属性标识）索引的 Integer 值的键，助记符的装饰应在该文本中呈现。

static String

JSplitPane.DIVIDER
用于添加一个表示分隔条的 Component。

static String

JSplitPane.DIVIDER_LOCATION_PROPERTY
绑定 dividerLocation 属性。

static String

JSplitPane.DIVIDER_SIZE_PROPERTY
绑定 border 属性名称。

static String

SpringLayout.EAST
指定组件的边界矩形的右边。

static String

JTree.EDITABLE_PROPERTY
editable 的绑定属性名称。

static String

JTree.EXPANDS_SELECTED_PATHS_PROPERTY
展开选择路径属性的绑定属性名称

static String

JFileChooser.FILE_FILTER_CHANGED_PROPERTY
用户更改要显示的文件种类。

static String

JFileChooser.FILE_HIDING_CHANGED_PROPERTY
标识在显示隐藏文件属性中的更改。

static String

JFileChooser.FILE_SELECTION_MODE_CHANGED_PROPERTY
标识在选择种类（选择单个、多个等等）方面的更改。

static String

JFileChooser.FILE_SYSTEM_VIEW_CHANGED_PROPERTY
声明使用其他对象在系统上查找可用的驱动器。

static String

JFileChooser.FILE_VIEW_CHANGED_PROPERTY
声明使用其他对象检索文件信息。

static String

FocusManager.FOCUS_MANAGER_CLASS_PROPERTY
该字段已被废弃，不鼓励使用它，因为它的规范与 1.4 focus API 不兼容。

static String

AbstractButton.FOCUS_PAINTED_CHANGED_PROPERTY
标识是否在边框拥有焦点时高亮显示。

static String

JInternalFrame.FRAME_ICON_PROPERTY
绑定属性名。

static String

JInternalFrame.GLASS_PANE_PROPERTY
绑定属性名。

static String

SpringLayout.HEIGHT
指定组件边界矩形的高度。

static String

JEditorPane.HONOR_DISPLAY_PROPERTIES
用于客户机属性的关键字，指示如果在样式化文本中未指定字体或前景色，那么是否使用该组件的默认字体和前景色。

static String

AbstractButton.HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY
标识按钮的水平对齐方式的更改。

static String

SpringLayout.HORIZONTAL_CENTER
指定组件边界矩形的水平中央位置。

static String

ScrollPaneConstants.HORIZONTAL_SCROLLBAR
标识水平滚动条。

static String

ScrollPaneConstants.HORIZONTAL_SCROLLBAR_POLICY
标识水平滚动条策略属性。

static String

AbstractButton.HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY
标识按钮的水平文本位置的更改。

static String

AbstractButton.ICON_CHANGED_PROPERTY
标识对表示该按钮的图标的更改。

static String

JOptionPane.ICON_PROPERTY
icon 的绑定属性名。

static String

JOptionPane.INITIAL_SELECTION_VALUE_PROPERTY
initialSelectionValue 的绑定属性名。

static String

JOptionPane.INITIAL_VALUE_PROPERTY
initialValue 的绑定属性名。

static String

JOptionPane.INPUT_VALUE_PROPERTY
inputValue 的绑定属性名。

static String

JTree.INVOKES_STOP_CELL_EDITING_PROPERTY
messagesStopCellEditing 的绑定属性名称。

static String

JInternalFrame.IS_CLOSED_PROPERTY
约束属性名，指示该内部窗体已关闭。

static String

JInternalFrame.IS_ICON_PROPERTY
约束属性名，指示该内部窗体已图标化。

static String

JInternalFrame.IS_MAXIMUM_PROPERTY
约束属性名，指示该内部窗体已最大化。

static String

JInternalFrame.IS_SELECTED_PROPERTY
约束属性名，指示此窗体具有选定状态。

static String

Action.LARGE_ICON_KEY
用来存储 Icon 的键。

static String

JTree.LARGE_MODEL_PROPERTY
largeModel 的绑定属性名称。

static String

JSplitPane.LAST_DIVIDER_LOCATION_PROPERTY
绑定 lastLocation 属性。

static String

JLayeredPane.LAYER_PROPERTY
绑定属性

static String

JInternalFrame.LAYERED_PANE_PROPERTY
绑定属性名。

static String

JTree.LEAD_SELECTION_PATH_PROPERTY
leadSelectionPath 的绑定属性名称。

static String

JSplitPane.LEFT
用于添加一个 Component 到另一个 Component 的左边。

static String

Action.LONG_DESCRIPTION
用来存储动作的较长 String 描述的键，用于上下文相关的帮助文件。

static String

ScrollPaneConstants.LOWER_LEADING_CORNER
标识视口的底端开始边角。

static String

ScrollPaneConstants.LOWER_LEFT_CORNER
标识视口的左下角。

static String

ScrollPaneConstants.LOWER_RIGHT_CORNER
标识视口的右下角。

static String

ScrollPaneConstants.LOWER_TRAILING_CORNER
标识视口的底端结束边角。

static String

AbstractButton.MARGIN_CHANGED_PROPERTY
标识按钮的边界空白的更改。

static String

JInternalFrame.MENU_BAR_PROPERTY
绑定属性名。

static String

JOptionPane.MESSAGE_PROPERTY
message 的绑定属性名。

static String

JOptionPane.MESSAGE_TYPE_PROPERTY
type 的绑定属性名。

static String

AbstractButton.MNEMONIC_CHANGED_PROPERTY
标识按钮的助记符中的更改。

static String

Action.MNEMONIC_KEY
用来存储对应于一个 KeyEvent 键代码的 Integer 值的键。

static String

AbstractButton.MODEL_CHANGED_PROPERTY
标识按钮模型中的更改。

static String

JFileChooser.MULTI_SELECTION_ENABLED_CHANGED_PROPERTY
允许选择多个文件。

static String

Action.NAME
用来存储动作的 String 名称的键，用于菜单或按钮。

static String

SpringLayout.NORTH
指定组件的边界矩形的顶边。

static String

JTextField.notifyAction
发送通知（已接收字段内容）的动作名称。

static String

JSplitPane.ONE_TOUCH_EXPANDABLE_PROPERTY
绑定 oneTouchExpandable 属性。

static String

JOptionPane.OPTION_TYPE_PROPERTY
optionType 的绑定属性名。

static String

JOptionPane.OPTIONS_PROPERTY
option 的绑定属性名。

static String

JSplitPane.ORIENTATION_PROPERTY
绑定 orientation（水平或者垂直）属性名称。

static String

AbstractButton.PRESSED_ICON_CHANGED_PROPERTY
标识对按下按钮时使用的图标的更改。

static String

JColorChooser.PREVIEW_PANEL_PROPERTY
预览面板属性名。

protected  String

JProgressBar.progressString
可以在进度条上显示的可选字符串。

static String

JSplitPane.RESIZE_WEIGHT_PROPERTY
绑定 weight 属性。

static String

JSplitPane.RIGHT
用于添加一个 Component 到另一个 Component 的右边。

static String

AbstractButton.ROLLOVER_ENABLED_CHANGED_PROPERTY
标识从启用翻转到禁用翻转或者从禁用翻转到启用翻转的更改。

static String

AbstractButton.ROLLOVER_ICON_CHANGED_PROPERTY
标识对光标移动到按钮上时使用的图标的更改。

static String

AbstractButton.ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY
标识对光标移动到按钮上并选定该按钮时使用的图标的更改。

static String

JInternalFrame.ROOT_PANE_PROPERTY
绑定属性名。

static String

JTree.ROOT_VISIBLE_PROPERTY
rootVisible 的绑定属性名称。

static String

ScrollPaneConstants.ROW_HEADER
标识沿视口左边左上角和左下角之间的区域。

static String

JTree.ROW_HEIGHT_PROPERTY
rowHeight 的绑定属性名称。

static String

JTree.SCROLLS_ON_EXPAND_PROPERTY
scrollsOnExpand 的绑定属性名称。

static String

JFileChooser.SELECTED_FILE_CHANGED_PROPERTY
标识用户单个文件选择的更改。

static String

JFileChooser.SELECTED_FILES_CHANGED_PROPERTY
标识用户多个文件选择的更改。

static String

AbstractButton.SELECTED_ICON_CHANGED_PROPERTY
标识对选定按钮时使用的图标的更改。

static String

Action.SELECTED_KEY
用来存储对应于选定状态的 Boolean 值的键。

static String

JColorChooser.SELECTION_MODEL_PROPERTY
选择模型属性名。

static String

JTree.SELECTION_MODEL_PROPERTY
selectionModel 的绑定属性名称。

static String

JOptionPane.SELECTION_VALUES_PROPERTY
selectionValues 的绑定属性名。

static String

Action.SHORT_DESCRIPTION
用来存储动作的简短 String 描述的键，用于工具提示文本。

static String

JTree.SHOWS_ROOT_HANDLES_PROPERTY
showsRootHandles 的绑定属性名称。

static String

Action.SMALL_ICON
用来存储小型 Icon（比如 ImageIcon）的键。

static String

SpringLayout.SOUTH
指定组件的边界矩形的底边。

static String

AbstractButton.TEXT_CHANGED_PROPERTY
标识按钮的文本中的更改。

protected  String

JInternalFrame.title
此内部窗体标题栏中所显示的标题。

static String

JInternalFrame.TITLE_PROPERTY
绑定属性名。

static String

JTree.TOGGLE_CLICK_COUNT_PROPERTY
toggleClickCount 的绑定属性名称。

static String

JComponent.TOOL_TIP_TEXT_KEY
光标位于组件上方时显示的注释，也称为“值提示”、“相交提示 (flyover help)”或“相交标签 (flyover label)”。

static String

JSplitPane.TOP
用于添加一个 Component 到另一个 Component 的上面。

static String

JTree.TREE_MODEL_PROPERTY
treeModel 的绑定属性名称。

static String

ScrollPaneConstants.UPPER_LEADING_CORNER
标识视口的顶端开始边角。

static String

ScrollPaneConstants.UPPER_LEFT_CORNER
标识视口的左上角。

static String

ScrollPaneConstants.UPPER_RIGHT_CORNER
标识视口的右上角。

static String

ScrollPaneConstants.UPPER_TRAILING_CORNER
标识视口的顶端结束边角。

static String

JOptionPane.VALUE_PROPERTY
value 的绑定属性名。

static String

AbstractButton.VERTICAL_ALIGNMENT_CHANGED_PROPERTY
标识按钮的垂直对齐方式的更改。

static String

SpringLayout.VERTICAL_CENTER
指定组件的边界矩形的垂直中央位置。

static String

ScrollPaneConstants.VERTICAL_SCROLLBAR
标识垂直滚动条。

static String

ScrollPaneConstants.VERTICAL_SCROLLBAR_POLICY
标识垂直滚动条策略属性。

static String

AbstractButton.VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
标识按钮的垂直文本位置的更改。

static String

ScrollPaneConstants.VIEWPORT
标识一个“视口”或显示区域，在这个范围内能看到滚动的内容。

static String

JTree.VISIBLE_ROW_COUNT_PROPERTY
visibleRowCount 的绑定属性名称。

static String

JEditorPane.W3C_LENGTH_UNITS
用于客户机属性的关键字，指示是否为 html 呈现使用 w3c 兼容的长度单位。

static String

JOptionPane.WANTS_INPUT_PROPERTY
wantsInput 的绑定属性名。

static String

SpringLayout.WEST
指定组件的边界矩形的左边。

static String

SpringLayout.WIDTH
指定组件边界矩形的宽度。

返回 String 的 javax.swing 中的方法

String

JTree.convertValueToText(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
通过渲染器调用以将指定值转换为文本。

String

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionDescription(int i)
返回此特定链接操作的 String 描述。

String

JSpinner.AccessibleJSpinner.getAccessibleActionDescription(int i)
返回此对象指定操作的描述。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleActionDescription(int i)
返回该树节点的指定操作的描述。

String

JComboBox.AccessibleJComboBox.getAccessibleActionDescription(int i)
返回该对象的指定操作的描述。

String

AbstractButton.AccessibleAbstractButton.getAccessibleActionDescription(int i)
返回对该对象的指定操作的描述。

String

JEditorPane.AccessibleJEditorPane.getAccessibleDescription()
获得此对象的 accessibleDescription 属性。

String

ProgressMonitor.AccessibleProgressMonitor.getAccessibleDescription()
获取对象的 accessibleDescription 属性。

String

JToolTip.AccessibleJToolTip.getAccessibleDescription()
获取此对象的可访问的描述。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleDescription()
获取此对象的可访问的描述。

String

JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleDescription()
获取此对象的可访问的描述。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleDescription()

String

JComponent.AccessibleJComponent.getAccessibleDescription()
获取此对象的可访问描述。

String

ImageIcon.AccessibleImageIcon.getAccessibleIconDescription()
获得此图标的描述。

String

ProgressMonitor.AccessibleProgressMonitor.getAccessibleName()
获取此对象的 accessibleName 属性。

String

JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleName()
获取此对象的可访问名称。

String

JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleName()
获取此对象的可访问的名称。

String

JTabbedPane.AccessibleJTabbedPane.getAccessibleName()
返回此对象的可访问名称；如果没有可访问名称，则返回 null。

String

JList.AccessibleJList.AccessibleJListChild.getAccessibleName()

String

JDialog.AccessibleJDialog.getAccessibleName()
获取此对象的可访问名称。

String

AbstractButton.AccessibleAbstractButton.getAccessibleName()
返回此对象的可访问名称。

String

JInternalFrame.AccessibleJInternalFrame.getAccessibleName()
获取此对象的可访问名称。

String

JLabel.AccessibleJLabel.getAccessibleName()
获取此对象的可访问名称。

String

JComponent.AccessibleJComponent.getAccessibleName()
获取此对象的可访问名称。

String

JFrame.AccessibleJFrame.getAccessibleName()
获得此对象的可访问名称。

String

JComboBox.getActionCommand()
返回发送到动作侦听器的事件中包括的动作命令。

String

DefaultButtonModel.getActionCommand()
返回该按钮的动作命令字符串。

String

ButtonModel.getActionCommand()
返回该按钮的动作命令字符串。

String

Timer.getActionCommand()
返回将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。

String

AbstractButton.getActionCommand()
返回此按钮的动作命令。

String

JPasswordField.AccessibleJPasswordField.getAfterIndex(int part, int index)
返回给定 index 之后的 String。

String

JSpinner.AccessibleJSpinner.getAfterIndex(int part, int index)
返回给定索引后的 String。

String

ProgressMonitor.AccessibleProgressMonitor.getAfterIndex(int part, int index)
返回给定索引后面的 String。

String

AbstractButton.AccessibleAbstractButton.getAfterIndex(int part, int index)
返回给定索引之后的 String。

String

JLabel.AccessibleJLabel.getAfterIndex(int part, int index)
返回给定索引后的 String。

String

JFileChooser.getApproveButtonText()
返回 ApproveButton 中的 FileChooserUI 内使用的文本。

String

JFileChooser.getApproveButtonToolTipText()
返回 ApproveButton 中使用的工具提示文本。

String

JPasswordField.AccessibleJPasswordField.getAtIndex(int part, int index)
返回给定 index 处的 String。

String

JSpinner.AccessibleJSpinner.getAtIndex(int part, int index)
返回给定索引处的 String。

String

ProgressMonitor.AccessibleProgressMonitor.getAtIndex(int part, int index)
返回给定索引处的 String。

String

AbstractButton.AccessibleAbstractButton.getAtIndex(int part, int index)
返回给定索引处的 String。

String

JLabel.AccessibleJLabel.getAtIndex(int part, int index)
返回给定索引处的 String。

String

JPasswordField.AccessibleJPasswordField.getBeforeIndex(int part, int index)
返回给定 index 之前的 String。

String

JSpinner.AccessibleJSpinner.getBeforeIndex(int part, int index)
返回给定索引前的 String。

String

ProgressMonitor.AccessibleProgressMonitor.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

AbstractButton.AccessibleAbstractButton.getBeforeIndex(int part, int index)
返回给定索引前面的 String。

String

JLabel.AccessibleJLabel.getBeforeIndex(int part, int index)
返回给定索引前的 String。

protected  String

JComponent.AccessibleJComponent.getBorderTitle(Border b)
在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。

String

UIManager.LookAndFeelInfo.getClassName()
返回实现此外观的类名称。

String

JTable.getColumnName(int column)
返回出现在视图中 column 列位置处的列名称。

String

JEditorPane.getContentType()
获得设置此编辑器当前要处理的内容类型。

static String

UIManager.getCrossPlatformLookAndFeelClassName()
返回实现默认的跨平台外观 -- Java Look and Feel (JLF) -- 的 LookAndFeel 类的名称。

String

ImageIcon.getDescription()
获得图像的描述。

abstract  String

LookAndFeel.getDescription()
返回对此外观实现的单行描述，例如，"The CDE/Motif Look and Feel"。

String

JFileChooser.getDescription(File f)
返回文件描述。

String

JFileChooser.getDialogTitle()
获得 JFileChooser 的标题栏中所显示的字符串。

static String

JEditorPane.getEditorKitClassNameForContentType(String type)
返回当前向类型 type 所注册的 EditorKit 类名。

abstract  String

LookAndFeel.getID()
返回标识此外观的字符串。

String

JPopupMenu.getLabel()
返回弹出菜单的标签。

String

AbstractButton.getLabel()
已过时。 - 由 getText 取代

String

JEditorPane.JEditorPaneAccessibleHypertextSupport.getLinkText(int linkIndex)
返回文档中与此超链接关联的连续文本。

abstract  String

LookAndFeel.getName()
返回标识此外观的短字符串，例如 "CDE/Motif"。

String

UIManager.LookAndFeelInfo.getName()
以适合菜单或其他展示的形式返回外观的名称

String

JFileChooser.getName(File f)
返回文件名。

String

ProgressMonitor.getNote()
指定随进度消息一起显示的其他注释。

String

JSpinner.AccessibleJSpinner.getSelectedText()
返回选中的部分文本。

String

ProgressMonitor.AccessibleProgressMonitor.getSelectedText()
返回选择的一部分文本。

String

AbstractButton.AccessibleAbstractButton.getSelectedText()
返回选定文本的一部分。

String

JLabel.AccessibleJLabel.getSelectedText()
返回选定的部分文本。

String

JProgressBar.getString()
返回当前进度的 String 表示形式。

String

UIDefaults.getString(Object key)
如果 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key)
从默认值中返回一个字符串。

String

UIDefaults.getString(Object key, Locale l)
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key, Locale l)
从适合给定语言环境的默认值中返回一个字符串。

String

RowFilter.Entry.getStringValue(int index)
返回指定索引处的字符串值。

String

DefaultRowSorter.ModelWrapper.getStringValueAt(int row, int column)
以 String 的形式返回指定索引处的值。

static String

UIManager.getSystemLookAndFeelClassName()
如果有实现本机系统外观的 LookAndFeel 类的名称，则返回该名称；否则返回默认的跨平台 LookAndFeel 类的名称。

String

JEditorPane.getText()
根据此编辑器的内容类型返回此 TextComponent 中所包含的文本。

String

JPasswordField.getText()
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

String

AbstractButton.getText()
返回按钮的文本。

String

JLabel.getText()
返回该标签所显示的文本字符串。

String

JPasswordField.getText(int offs, int len)
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

String

JPasswordField.AccessibleJPasswordField.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本。

String

JSpinner.AccessibleJSpinner.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本字符串。

String

JToolTip.getTipText()
返回显示工具提示时所显示的文本。

String

JInternalFrame.getTitle()
返回 JInternalFrame 的标题。

String

JTabbedPane.getTitleAt(int index)
返回 index 位置的选项卡标题。

String

AbstractButton.AccessibleAbstractButton.getTitledBorderText()
返回加标题的边界文本

String

JLabel.AccessibleJLabel.getTitledBorderText()
返回有标题边框的文本

String

JComponent.AccessibleJComponent.getTitledBorderText()
返回有标题边界的文本

String

AbstractButton.AccessibleAbstractButton.getToolTipText()
返回工具提示文本

String

JLabel.AccessibleJLabel.getToolTipText()
返回工具提示文本

String

JComponent.getToolTipText()
返回通过 setToolTipText 所设置的工具提示字符串。

String

JComponent.AccessibleJComponent.getToolTipText()
返回工具提示文本

String

JTree.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。

String

JTable.getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。

String

JTabbedPane.getToolTipText(MouseEvent event)
返回由鼠标事件位置确定的组件的工具提示文本。

String

JList.getToolTipText(MouseEvent event)
返回用于给定事件的工具提示文本。

String

JComponent.getToolTipText(MouseEvent event)
返回用作 event 工具提示的字符串。

String

JTabbedPane.getToolTipTextAt(int index)
返回 index 位置的选项卡工具提示文本。

String

JFileChooser.getTypeDescription(File f)
返回文件类型。

String

JColorChooser.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JDesktopPane.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JEditorPane.getUIClassID()
获得该 UI 的类 ID。

String

JFileChooser.getUIClassID()
返回一个指示 L&F 类名的字符串，该类负责呈现此组件。

String

JFormattedTextField.getUIClassID()
获得 UI 的类 ID。

String

JOptionPane.getUIClassID()
返回实现此组件 L&F 的 UI 类的名称。

String

JPasswordField.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JSpinner.getUIClassID()
返回用于构造呈现此组件外观 (L&F) 类的名称的后缀。

String

JTextPane.getUIClassID()
返回 UI 的类 ID。

String

JRadioButtonMenuItem.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JSlider.getUIClassID()
返回呈现此组件的 L&F 的类名。

String

JToolTip.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JTree.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JTable.getUIClassID()
返回用于构造呈现此组件时所用 L&F 类名称的后缀。

String

JProgressBar.getUIClassID()
返回呈现此组件的外观类的名称。

String

JCheckBox.getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

String

JTabbedPane.getUIClassID()
返回实现此组件的 L&F 的 UI 类的名称。

String

JRadioButton.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JTextArea.getUIClassID()
返回 UI 的类 ID。

String

JTextField.getUIClassID()
获取 UI 的类 ID。

String

JViewport.getUIClassID()
返回指定呈现此组件的 L&F 类名称的字符串。

String

JScrollPane.getUIClassID()
返回用于构造呈现此组件时所用 L&F 类的名称的后缀。

String

JList.getUIClassID()
返回 "ListUI"，它是用于查找定义此组件外观的 javax.swing.plaf.ListUI 类名称的 UIDefaults 键。

String

JScrollBar.getUIClassID()
返回此组件的 LookAndFeel 类的名称。

String

JComboBox.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JSeparator.getUIClassID()
返回呈现此组件的 L&F 的类名。

String

JPopupMenu.getUIClassID()
返回用于呈现此组件的 L&F 类名。

String

JPopupMenu.Separator.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JMenuBar.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JToggleButton.getUIClassID()
返回指定了 l&f 类名称的字符串，其中 l&f 类呈现此组件。

String

JSplitPane.getUIClassID()
返回呈现此组件的 L&F 类名。

String

JToolBar.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JToolBar.Separator.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JButton.getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

String

JCheckBoxMenuItem.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JMenu.getUIClassID()
返回呈现此组件的 L&F 类的名称。

String

JMenuItem.getUIClassID()
返回用于构造呈现此组件时使用的 L&F 类名称的后缀。

String

JInternalFrame.getUIClassID()
返回呈现此组件的外观类名。

String

JInternalFrame.JDesktopIcon.getUIClassID()
返回呈现此组件的外观类名。

String

JPanel.getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

String

JRootPane.getUIClassID()
返回一个指定呈现此组件的 L&F 类名称的字符串。

String

JLabel.getUIClassID()
返回一个指定 L&F 类名称的字符串，该类呈现此组件。

String

JComponent.getUIClassID()
返回用于查找 wing.plaf.ComponentUI 类（定义了此组件的外观）名的 UIDefaults 键。

String

JInternalFrame.getWarningString()
获取此内部窗体中显示的警告字符串。

static String

SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

static String

SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

protected  String

JColorChooser.paramString()
返回此 JColorChooser 的字符串表示形式。

protected  String

JDesktopPane.paramString()
返回此 JDesktopPane 的字符串表示形式。

protected  String

JEditorPane.paramString()
返回此 JEditorPane 的字符串表示形式。

protected  String

JFileChooser.paramString()
返回此 JFileChooser 的字符串表示形式。

protected  String

JOptionPane.paramString()
返回此 JOptionPane 的字符串表示形式。

protected  String

JPasswordField.paramString()
返回此 JPasswordField 的字符串表示形式。

protected  String

JTextPane.paramString()
返回此 JTextPane 的字符串表示形式。

protected  String

JApplet.paramString()
返回此 JApplet 的字符串表示形式。

protected  String

JRadioButtonMenuItem.paramString()
返回此 JRadioButtonMenuItem 的字符串表示形式。

protected  String

JSlider.paramString()
返回此 JSlider 的字符串表示形式。

protected  String

JToolTip.paramString()
返回此 JToolTip 的字符串表示形式。

protected  String

JTree.paramString()
返回此 JTree 的字符串表示形式。

protected  String

JTable.paramString()
返回此表的字符串表示形式。

protected  String

JProgressBar.paramString()
返回此 JProgressBar 的字符串表示形式。

protected  String

JCheckBox.paramString()
返回此 JCheckBox 的字符串表示形式。

protected  String

JTabbedPane.paramString()
返回此 JTabbedPane 的字符串表示。

protected  String

JRadioButton.paramString()
返回此 JRadioButton 的字符串表示形式。

protected  String

JWindow.paramString()
返回此 JWindow 的字符串表示形式。

protected  String

JTextArea.paramString()
返回此 JTextArea 的字符串表示形式。

protected  String

JTextField.paramString()
返回此 JTextField 的字符串表示形式。

protected  String

JViewport.paramString()
返回此 JViewport 的字符串表示形式。

protected  String

JScrollPane.paramString()
返回此 JScrollPane 的字符串表示形式。

protected  String

JList.paramString()
返回此 JList 的 String 表示形式。

protected  String

JScrollBar.paramString()
返回此 JScrollBar 的字符串表示形式。

protected  String

JComboBox.paramString()
返回此 JComboBox 的字符串表示形式。

protected  String

JSeparator.paramString()
返回表示此 JSeparator 的一个字符串。

protected  String

JPopupMenu.paramString()
返回此 JPopupMenu 的字符串表示形式。

protected  String

JMenuBar.paramString()
返回此 JMenuBar 的字符串表示形式。

protected  String

JToggleButton.paramString()
返回此 JToggleButton 的字符串表示形式。

protected  String

JSplitPane.paramString()
返回此 JSplitPane 的字符串表示形式。

protected  String

JToolBar.paramString()
返回此 JToolBar 的字符串表示形式。

protected  String

JDialog.paramString()
返回此 JDialog 的字符串表示形式。

protected  String

JButton.paramString()
返回此 JButton 的字符串表示形式。

protected  String

JCheckBoxMenuItem.paramString()
返回此 JCheckBoxMenuItem 的字符串表示形式。

protected  String

JMenu.paramString()
返回此 JMenu 的字符串表示形式。

protected  String

JMenuItem.paramString()
返回此 JMenuItem 的字符串表示形式。

protected  String

AbstractButton.paramString()
返回此 AbstractButton 的字符串表示形式。

protected  String

JInternalFrame.paramString()
返回此 JInternalFrame 的字符串表示形式。

protected  String

JLayeredPane.paramString()
返回此 JLayeredPane 的字符串表示形式。

protected  String

JPanel.paramString()
返回此 JPanel 的字符串表示形式。

protected  String

JRootPane.paramString()
返回此 JRootPane 的字符串表示形式。

protected  String

JLabel.paramString()
返回此 JLabel 的字符串表示形式。

protected  String

JComponent.paramString()
返回此 JComponent 的字符串表示形式。

protected  String

JFrame.paramString()
返回此 JFrame 的字符串表示形式。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, Object initialSelectionValue)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。

static String

JOptionPane.showInputDialog(Object message)
显示请求用户输入的问题消息对话框。

static String

JOptionPane.showInputDialog(Object message, Object initialSelectionValue)
显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。

String

GroupLayout.toString()
返回此 GroupLayout 的字符串表示形式。

String

DefaultListModel.toString()
返回显示并标识此对象的属性的字符串。

String

JTree.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

JTable.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

SizeRequirements.toString()
返回一个描述最小、首选和最大大小以及对齐方式要求的字符串。

String

TransferHandler.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

DefaultListSelectionModel.toString()
返回显示并标识此对象的属性的字符串。

String

JList.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

DefaultBoundedRangeModel.toString()
返回显示所有 BoundedRangeModel 属性的字符串。

String

ImageIcon.toString()
返回此图像的字符串表示形式。

String

RepaintManager.toString()
返回一个显示并标记此对象属性的字符串。

String

LookAndFeel.toString()
返回显示和标识此对象属性的字符串。

String

UIManager.LookAndFeelInfo.toString()
返回一个显示并标识此对象属性的字符串。

abstract  String

JFormattedTextField.AbstractFormatter.valueToString(Object value)
返回为 value 显示的 string 值。

参数类型为 String 的 javax.swing 中的方法

protected  void

JTextField.actionPropertyChanged(Action action, String propertyName)
更新文本字段的状态以响应关联动作中的属性更改。

protected  void

JComboBox.actionPropertyChanged(Action action, String propertyName)
更新组合框的状态以响应关联动作中的属性更改。

protected  void

JMenuItem.actionPropertyChanged(Action action, String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。

protected  void

AbstractButton.actionPropertyChanged(Action action, String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。

JMenuItem

JPopupMenu.add(String s)
创建具有指定文本的菜单项，并将其添加到此菜单的末尾。

JMenuItem

JMenu.add(String s)
创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。

Component

JTabbedPane.add(String title, Component component)
添加具有指定选项卡标题的 component。

void

GroupLayout.addLayoutComponent(String name, Component component)
已将 Component 添加到父容器的通知。

void

JSpinner.DefaultEditor.addLayoutComponent(String name, Component child)
此 LayoutManager 方法不执行任何操作。

void

OverlayLayout.addLayoutComponent(String name, Component comp)
将指定的组件添加到布局中。

void

SpringLayout.addLayoutComponent(String name, Component c)
无效，因为此布局管理器不使用每组件字符串。

void

ViewportLayout.addLayoutComponent(String name, Component c)
将指定的组件添加到布局中。

void

ScrollPaneLayout.addLayoutComponent(String s, Component c)
将指定的组件添加到布局中。

void

BoxLayout.addLayoutComponent(String name, Component comp)
此类不使用。

void

JRootPane.RootLayout.addLayoutComponent(String name, Component comp)

void

UIDefaults.addResourceBundle(String bundleName)
将一个资源包添加到从中搜索本地化值的资源包的列表中。

Style

JTextPane.addStyle(String nm, Style parent)
将一个新样式添加到逻辑样式层次结构中。

void

JTabbedPane.addTab(String title, Component component)
添加一个由 title 表示，且没有图标的 component。

void

JTabbedPane.addTab(String title, Icon icon, Component component)
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。

void

JTabbedPane.addTab(String title, Icon icon, Component component, String tip)
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。

void

JTextArea.append(String str)
将给定文本追加到文档结尾。

protected  int

AbstractButton.checkHorizontalKey(int key, String exception)
验证 key 参数是否为 horizontalAlignment 和 horizontalTextPosition 属性的合法值。

protected  int

JLabel.checkHorizontalKey(int key, String message)
验证该键是否为 horizontalAlignment 属性的合法值。

protected  int

AbstractButton.checkVerticalKey(int key, String exception)
验证 key 参数是否为垂直属性的合法值。

protected  int

JLabel.checkVerticalKey(int key, String message)
验证该键是否为 verticalAlignment 或 verticalTextPosition 属性的合法值。

static int

SwingUtilities.computeStringWidth(FontMetrics fm, String str)
使用具有指定“规格”（大小）的字体计算字符串的宽度。

JDialog

JOptionPane.createDialog(Component parentComponent, String title)
创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。

static JDialog

JColorChooser.createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener)
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。

JDialog

JOptionPane.createDialog(String title)
创建并返回一个新的带有指定标题的无父 JDialog。

static EditorKit

JEditorPane.createEditorKitForContentType(String type)
根据默认的编辑器工具包注册表为给定的类型创建处理程序。

JInternalFrame

JOptionPane.createInternalFrame(Component parentComponent, String title)
创建并返回 JInternalFrame 的实例。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title)
向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition)
向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。

static TitledBorder

BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
向现有边框添加一个标题，使其具有指定的位置、字体和颜色。

static TitledBorder

BorderFactory.createTitledBorder(String title)
创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

void

DebugGraphics.drawString(String aString, int x, int y)
重写 Graphics.drawString。

protected  void

JFileChooser.fireActionPerformed(String command)
通知对此事件类型感兴趣的所有侦听器。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
因为性能原因而被重写。

void

JComponent.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
支持报告 boolean 属性的绑定属性更改。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, byte oldValue, byte newValue)
因为性能原因而被重写。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, char oldValue, char newValue)
因为性能原因而被重写。

void

JComponent.firePropertyChange(String propertyName, char oldValue, char newValue)

void

DefaultListCellRenderer.firePropertyChange(String propertyName, double oldValue, double newValue)
因为性能原因而被重写。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, float oldValue, float newValue)
因为性能原因而被重写。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, int oldValue, int newValue)
因为性能原因而被重写。

void

JComponent.firePropertyChange(String propertyName, int oldValue, int newValue)
支持报告整数属性的绑定属性更改。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, long oldValue, long newValue)
因为性能原因而被重写。

void

SwingWorker.firePropertyChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定属性更新。

protected  void

AbstractAction.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定 (bound) 属性的改变。

protected  void

JViewport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
通知侦听器发生的属性更改。

protected  void

DefaultListCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

protected  void

UIDefaults.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定属性更改。

void

DefaultListCellRenderer.firePropertyChange(String propertyName, short oldValue, short newValue)
因为性能原因而被重写。

protected  void

JComponent.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
支持报告约束 (constrained) 属性的更改。

static Container

SwingUtilities.getAncestorNamed(String name, Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。

Spring

SpringLayout.Constraints.getConstraint(String edgeName)
返回指定边的值，它可以为一个派生值，甚至可以为 null。

Spring

SpringLayout.getConstraint(String edgeName, Component c)
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。

Component

ScrollPaneLayout.getCorner(String key)
返回位于指定角的 Component。

Component

JScrollPane.getCorner(String key)
返回位于指定角的组件。

static Object

LookAndFeel.getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。

static String

JEditorPane.getEditorKitClassNameForContentType(String type)
返回当前向类型 type 所注册的 EditorKit 类名。

EditorKit

JEditorPane.getEditorKitForContentType(String type)
获取用于给定内容类型的编辑器工具包。

static KeyStroke

KeyStroke.getKeyStroke(String s)
分析字符串并返回 KeyStroke。

TreePath

JTree.getNextMatch(String prefix, int startingRow, Position.Bias bias)
将 TreePath 返回到以一个前缀开头的下一个树元素。

int

JList.getNextMatch(String prefix, int startIndex, Position.Bias bias)
返回其 toString 值以给定前缀开头的下一个列表元素。

Style

JTextPane.getStyle(String nm)
获取以前添加的已命名的非 null 样式。

Class<? extends ComponentUI>

UIDefaults.getUIClass(String uiClassID)
返回呈现此组件的 L&F 类。

Class<? extends ComponentUI>

UIDefaults.getUIClass(String uiClassID, ClassLoader uiClassLoader)
get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。

protected  void

UIDefaults.getUIError(String msg)
如果由于某种原因导致 getUI() 失败，则它会在返回 null 之前调用此方法。

Object

AbstractAction.getValue(String key)
获得与指定键关联的 Object。

Object

Action.getValue(String key)
使用关联的键获取此对象的一个属性。

int

JTabbedPane.indexOfTab(String title)
返回具有给定 title 的第一个选项卡索引，如果没有具有此标题的选项卡，则返回 -1。

protected  void

JMenuItem.init(String text, Icon icon)
利用指定文本和图标初始化菜单项。

protected  void

AbstractButton.init(String text, Icon icon)

void

JTextArea.insert(String str, int pos)
将指定文本插入指定位置。

void

JMenu.insert(String s, int pos)
在给定位置插入具有指定文本的新菜单项。

void

JTabbedPane.insertTab(String title, Icon icon, Component component, String tip, int index)
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。

void

JSpinner.AccessibleJSpinner.insertTextAtIndex(int index, String s)
在给定索引处插入指定的字符串。

static void

LookAndFeel.installBorder(JComponent c, String defaultBorderName)
使用默认的值设置组件边框属性的便捷方法。

static void

LookAndFeel.installColors(JComponent c, String defaultBgName, String defaultFgName)
使用默认的值设置组件的前景和背景颜色属性的便捷方法。

static void

LookAndFeel.installColorsAndFont(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)
使用默认的值设置组件的前景、背景和字体属性的便捷方法。

static void

UIManager.installLookAndFeel(String name, String className)
将指定的外观添加到可用外观的集合中。

static void

LookAndFeel.installProperty(JComponent c, String propertyName, Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。

static String

SwingUtilities.layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

static String

SwingUtilities.layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。

static Object

LookAndFeel.makeIcon(Class<?> baseClass, String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。

void

SpringLayout.putConstraint(String e1, Component c1, int pad, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。

void

SpringLayout.putConstraint(String e1, Component c1, Spring s, String e2, Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2。

void

AbstractAction.putValue(String key, Object newValue)
设置与指定键关联的 Value。

void

Action.putValue(String key, Object value)
使用关联的键设置此对象的一个属性。

static

<M,I> RowFilter<M,I>

RowFilter.regexFilter(String regex, int... indices)
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。

static void

JEditorPane.registerEditorKitForContentType(String type, String classname)
建立 type 到 classname 的默认绑定。

static void

JEditorPane.registerEditorKitForContentType(String type, String classname, ClassLoader loader)
建立 type 到 classname 的默认绑定。

void

JComponent.registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。

void

UIDefaults.removeResourceBundle(String bundleName)
从在其中搜索本地化默认的资源包列表中移除一个资源包。

void

JTextPane.removeStyle(String nm)
移除以前添加到文档中的已命名的非 null 样式。

void

JTextArea.replaceRange(String str, int start, int end)
用给定的新文本替换从指示的起始位置到结尾位置的文本。

void

JEditorPane.replaceSelection(String content)
用由给定字符串表示的新内容替换当前选中的内容。

void

JTextPane.replaceSelection(String content)
用给定字符串所表示的新内容替换当前选择的内容。

void

JSpinner.AccessibleJSpinner.replaceText(int startIndex, int endIndex, String s)
用指定的字符串替换两个索引之间的文本。

void

JEditorPane.scrollToReference(String reference)
将视图滚动到给定的参考位置（也就是正在显示的 URL 的 UL.getRef 方法所返回的值）。

void

JTree.AccessibleJTree.AccessibleJTreeNode.setAccessibleDescription(String s)
设置此对象的可访问描述。

void

JTable.AccessibleJTable.AccessibleJTableCell.setAccessibleDescription(String s)
设置此对象的可访问的描述。

void

JList.AccessibleJList.AccessibleJListChild.setAccessibleDescription(String s)

void

ImageIcon.AccessibleImageIcon.setAccessibleIconDescription(String description)
设置图标的描述。

void

JTree.AccessibleJTree.AccessibleJTreeNode.setAccessibleName(String s)
设置此对象的本地化可访问名称。

void

JTable.AccessibleJTable.AccessibleJTableCell.setAccessibleName(String s)
获取此对象的可访问的本地化名称。

void

JList.AccessibleJList.AccessibleJListChild.setAccessibleName(String s)

void

JTextField.setActionCommand(String command)
设置用于操作事件的命令字符串。

void

JComboBox.setActionCommand(String aCommand)
设置发送到动作侦听器的事件中应该包括的动作命令。

void

DefaultButtonModel.setActionCommand(String actionCommand)
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。

void

ButtonModel.setActionCommand(String s)
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。

void

Timer.setActionCommand(String command)
设置将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。

void

AbstractButton.setActionCommand(String actionCommand)
设置此按钮的动作命令。

void

JFileChooser.setApproveButtonText(String approveButtonText)
设置 FileChooserUI 中的 ApproveButton 内使用的文本。

void

JFileChooser.setApproveButtonToolTipText(String toolTipText)
设置 ApproveButton 中使用的工具提示文本。

void

SpringLayout.Constraints.setConstraint(String edgeName, Spring s)
设置控制指定边的 spring。

void

JEditorPane.setContentType(String type)
设置此编辑器所处理的内容类型。

void

JScrollPane.setCorner(String key, Component corner)
添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。

void

ImageIcon.setDescription(String description)
设置图像的描述。

void

JFileChooser.setDialogTitle(String dialogTitle)
设置显示在 JFileChooser 窗口标题栏的字符串。

void

JEditorPane.setEditorKitForContentType(String type, EditorKit k)
直接设置用于给定类型的编辑器工具包。

void

JPopupMenu.setLabel(String label)
设置弹出菜单的标签。

void

AbstractButton.setLabel(String label)
已过时。 - 由 setText(text) 取代

static void

UIManager.setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

void

ProgressMonitor.setNote(String note)
指定与进度消息一起显示的其他注释。

void

JEditorPane.setPage(String url)
设置当前要显示的 URL。

void

JProgressBar.setString(String s)
设置进度字符串的值。

void

JEditorPane.setText(String t)
将此 TextComponent 的文本设置为指定内容，预期以此编辑器的内容类型格式提供该内容。

void

AbstractButton.setText(String text)
设置按钮的文本。

void

JLabel.setText(String text)
定义此组件将要显示的单行文本。

void

JSpinner.AccessibleJSpinner.setTextContents(String s)
将文本内容设置为指定字符串。

void

JToolTip.setTipText(String tipText)
设置显示工具提示时要显示的文本。

void

JInternalFrame.setTitle(String title)
设置 JInternalFrame 的标题。

void

JTabbedPane.setTitleAt(int index, String title)
将 index 位置的标题设置为 title，它可以为 null。

void

JComponent.setToolTipText(String text)
注册要在工具提示中显示的文本。

void

JTabbedPane.setToolTipTextAt(int index, String toolTipText)
将 index 位置的工具提示文本设置为 toolTipText，它可以为 null。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的对话框。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。

int

JFileChooser.showDialog(Component parent, String approveButtonText)
弹出具有自定义 approve 按钮的自定义文件选择器对话框。

static Color

JColorChooser.showDialog(Component component, String title, Color initialColor)
显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。

static int

JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。

static int

JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

abstract  Object

JFormattedTextField.AbstractFormatter.stringToValue(String text)
分析 text，返回任意 Object。

static GroupLayout.Alignment

GroupLayout.Alignment.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static LayoutStyle.ComponentPlacement

LayoutStyle.ComponentPlacement.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static RowFilter.ComparisonType

RowFilter.ComparisonType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SortOrder

SortOrder.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static SwingWorker.StateValue

SwingWorker.StateValue.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static JTable.PrintMode

JTable.PrintMode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static DropMode

DropMode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 javax.swing 中的构造方法

AbstractAction(String name)
用指定描述字符串和默认图标定义一个 Action 对象。

AbstractAction(String name, Icon icon)
用指定描述字符串和指定图标定义一个 Action 对象。

ImageIcon(byte[] imageData, String description)
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。

ImageIcon(Image image, String description)
根据图像创建一个 ImageIcon。

ImageIcon(String filename)
根据指定的文件创建一个 ImageIcon。

ImageIcon(String filename, String description)
根据指定的文件创建一个 ImageIcon。

ImageIcon(URL location, String description)
根据指定的 URL 创建一个 ImageIcon。

JButton(String text)
创建一个带文本的按钮。

JButton(String text, Icon icon)
创建一个带初始文本和图标的按钮。

JCheckBox(String text)
创建一个带文本的、最初未被选定的复选框。

JCheckBox(String text, boolean selected)
创建一个带文本的复选框，并指定其最初是否处于选定状态。

JCheckBox(String text, Icon icon)
创建带有指定文本和图标的、最初未选定的复选框。

JCheckBox(String text, Icon icon, boolean selected)
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。

JCheckBoxMenuItem(String text)
创建一个带文本的、最初未被选定的复选框菜单项。

JCheckBoxMenuItem(String text, boolean b)
创建带有指定文本和选择状态的复选框菜单项。

JCheckBoxMenuItem(String text, Icon icon)
创建带有指定文本和图标的、最初未被选定的复选框菜单项。

JCheckBoxMenuItem(String text, Icon icon, boolean b)
创建带有指定文本、图标和选择状态的复选框菜单项。

JDialog(Dialog owner, String title)
创建一个具有指定标题和指定所有者对话框的无模式对话框。

JDialog(Dialog owner, String title, boolean modal)
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。

JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。

JDialog(Frame owner, String title)
创建一个具有指定标题和指定所有者窗体的无模式对话框。

JDialog(Frame owner, String title, boolean modal)
创建一个具有指定标题、所有者 Frame 和模式的对话框。

JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。

JDialog(Window owner, String title)
创建一个具有指定标题和所有者 Window 的无模式对话框。

JDialog(Window owner, String title, Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。

JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。

JEditorPane(String url)
根据包含 URL 规范的字符串创建一个 JEditorPane。

JEditorPane(String type, String text)
创建一个已初始化为给定文件的 JEditorPane。

JFileChooser(String currentDirectoryPath)
构造一个使用给定路径的 JFileChooser。

JFileChooser(String currentDirectoryPath, FileSystemView fsv)
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。

JFrame(String title)
创建一个新的、初始不可见的、具有指定标题的 Frame。

JFrame(String title, GraphicsConfiguration gc)
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。

JInternalFrame(String title)
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、具有指定标题的 JInternalFrame。

JInternalFrame(String title, boolean resizable)
创建不可关闭的、不可最大化的、不可图标化的，以及具有指定标题和可调整大小的 JInternalFrame。

JInternalFrame(String title, boolean resizable, boolean closable)
创建不可最大化的、不可图标化的，以及具有指定标题、可调整大小和可关闭的 JInternalFrame。

JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable)
创建不可图标化的，但具有指定标题、可调整大小、可关闭和可最大化的 JInternalFrame。

JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable, boolean iconifiable)
创建具有指定标题、可调整、可关闭、可最大化和可图标化的 JInternalFrame。

JLabel(String text)
创建具有指定文本的 JLabel 实例。

JLabel(String text, Icon icon, int horizontalAlignment)
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。

JLabel(String text, int horizontalAlignment)
创建具有指定文本和水平对齐方式的 JLabel 实例。

JMenu(String s)
构造一个新 JMenu，用提供的字符串作为其文本。

JMenu(String s, boolean b)
构造一个新 JMenu，用提供的字符串作为其文本并指定其是否为分离式 (tear-off) 菜单。

JMenuItem(String text)
创建带有指定文本的 JMenuItem。

JMenuItem(String text, Icon icon)
创建带有指定文本和图标的 JMenuItem。

JMenuItem(String text, int mnemonic)
创建带有指定文本和键盘助记符的 JMenuItem。

JPasswordField(Document doc, String txt, int columns)
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。

JPasswordField(String text)
构造一个利用指定文本初始化的新 JPasswordField。

JPasswordField(String text, int columns)
构造一个利用指定文本和列初始化的新 JPasswordField。

JPopupMenu(String label)
构造一个具有指定标题的 JPopupMenu。

JRadioButton(String text)
创建一个具有指定文本的状态为未选择的单选按钮。

JRadioButton(String text, boolean selected)
创建一个具有指定文本和选择状态的单选按钮。

JRadioButton(String text, Icon icon)
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。

JRadioButton(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮。

JRadioButtonMenuItem(String text)
创建一个带文本的 JRadioButtonMenuItem。

JRadioButtonMenuItem(String text, boolean selected)
创建一个具有指定文本和选择状态的单选按钮菜单项。

JRadioButtonMenuItem(String text, Icon icon)
创建一个具有指定文本和 Icon 的单选按钮菜单项。

JRadioButtonMenuItem(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。

JSpinner.DateEditor(JSpinner spinner, String dateFormatPattern)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。

JSpinner.NumberEditor(JSpinner spinner, String decimalFormatPattern)
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。

JTextArea(Document doc, String text, int rows, int columns)
构造具有指定行数和列数以及给定模型的新的 JTextArea。

JTextArea(String text)
构造显示指定文本的新的 TextArea。

JTextArea(String text, int rows, int columns)
构造具有指定文本、行数和列数的新的 TextArea。

JTextField(Document doc, String text, int columns)
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。

JTextField(String text)
构造一个用指定文本初始化的新 TextField。

JTextField(String text, int columns)
构造一个用指定文本和列初始化的新 TextField。

JToggleButton(String text)
创建具有指定文本的未选定的切换按钮。

JToggleButton(String text, boolean selected)
创建具有指定文本和选择状态的切换按钮。

JToggleButton(String text, Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。

JToggleButton(String text, Icon icon, boolean selected)
创建具有指定文本、图像和选择状态的切换按钮。

JToolBar(String name)
创建一个具有指定 name 的新工具栏。

JToolBar(String name, int orientation)
创建一个具有指定 name 和 orientation 的新工具栏。

ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。

TransferHandler(String property)
构造一个通过剪贴板或拖放操作可以将 Java Bean 属性从一个组件传输到另一个组件的传输处理程序。

UIDefaults.ProxyLazyValue(String c)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, String m)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, String m, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIManager.LookAndFeelInfo(String name, String className)
构造一个 UIManager LookAndFeelInfo 对象。

UnsupportedLookAndFeelException(String s)
构造一个 UnsupportedLookAndFeelException 对象。

javax.swing.border 中 String 的使用

声明为 String 的 javax.swing.border 中的字段

protected  String

TitledBorder.title

返回 String 的 javax.swing.border 中的方法

String

TitledBorder.getTitle()
返回带标题边框的标题。

参数类型为 String 的 javax.swing.border 中的方法

void

TitledBorder.setTitle(String title)
设置带标题边框的标题。

参数类型为 String 的 javax.swing.border 中的构造方法

TitledBorder(Border border, String title)
创建具有指定边框和标题的 TitledBorder 实例。

TitledBorder(Border border, String title, int titleJustification, int titlePosition)
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。

TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。

TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

TitledBorder(String title)
创建 TitledBorder 实例。

javax.swing.colorchooser 中 String 的使用

返回 String 的 javax.swing.colorchooser 中的方法

abstract  String

AbstractColorChooserPanel.getDisplayName()
返回一个包含面板显示名称的字符串。

javax.swing.event 中 String 的使用

返回 String 的 javax.swing.event 中的方法

String

HyperlinkEvent.getDescription()
获得链接描述的字符串表示形式。

String

InternalFrameEvent.paramString()
返回标识此事件的参数字符串。

String

HyperlinkEvent.EventType.toString()
将类型转换成一个字符串。

String

ListDataEvent.toString()
返回此 ListDataEvent 的字符串表示形式。

String

TreeModelEvent.toString()
返回显示和标识此对象属性的字符串。

String

ListSelectionEvent.toString()
返回显示并标识此对象的属性的 String。

String

DocumentEvent.EventType.toString()
将类型转换成一个字符串。

String

EventListenerList.toString()
返回此 EventListenerList 的字符串表示形式。

参数类型为 String 的 javax.swing.event 中的方法

static RowSorterEvent.Type

RowSorterEvent.Type.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

参数类型为 String 的 javax.swing.event 中的构造方法

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.filechooser 中 String 的使用

返回 String 的 javax.swing.filechooser 中的方法

String

FileNameExtensionFilter.getDescription()
此过滤器的描述。

abstract  String

FileFilter.getDescription()
此过滤器的描述。

String

FileView.getDescription(File f)
文件的可读描述。

String[]

FileNameExtensionFilter.getExtensions()
返回要测试文件的文件扩展名集合。

String

FileView.getName(File f)
文件名称。

String

FileSystemView.getSystemDisplayName(File f)
在系统文件浏览器中显示的文件、目录或文件夹名。

String

FileSystemView.getSystemTypeDescription(File f)
在系统文件浏览器中显示的文件、目录或文件夹类型描述。

String

FileView.getTypeDescription(File f)
文件类型的可读描述。

String

FileNameExtensionFilter.toString()
返回 FileNameExtensionFilter 的字符串表示形式。

参数类型为 String 的 javax.swing.filechooser 中的方法

File

FileSystemView.createFileObject(File dir, String filename)
返回根据给定的 filename 在 dir 中构造的 File 对象。

File

FileSystemView.createFileObject(String path)
返回根据给定路径字符串构造的 File 对象。

File

FileSystemView.getChild(File parent, String fileName)

参数类型为 String 的 javax.swing.filechooser 中的构造方法

FileNameExtensionFilter(String description, String... extensions)
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。

FileNameExtensionFilter(String description, String... extensions)
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。

javax.swing.plaf 中 String 的使用

返回 String 的 javax.swing.plaf 中的方法

abstract  String

FileChooserUI.getApproveButtonText(JFileChooser fc)

abstract  String

FileChooserUI.getDialogTitle(JFileChooser fc)

String

TextUI.getToolTipText(JTextComponent t, Point pt)
返回在传入位置上用作工具提示的字符串。

参数类型为 String 的 javax.swing.plaf 中的构造方法

BorderUIResource.TitledBorderUIResource(Border border, String title)

BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition)

BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)

BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)

BorderUIResource.TitledBorderUIResource(String title)

FontUIResource(String name, int style, int size)

javax.swing.plaf.basic 中 String 的使用

声明为 String 的 javax.swing.plaf.basic 中的字段

protected  String

BasicFileChooserUI.cancelButtonText

protected  String

BasicFileChooserUI.cancelButtonToolTipText

protected static String

BasicInternalFrameTitlePane.CLOSE_CMD

protected  String

BasicToolBarUI.constraintBeforeFloating

protected  String

BasicFileChooserUI.directoryOpenButtonText
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的标签文本。

protected  String

BasicFileChooserUI.directoryOpenButtonToolTipText
选择了目录且当前选择模式是 FILES_ONLY 时在确认按钮上显示的工具提示文本。

static String

BasicHTML.documentBaseKey
存储为客户端属性以指示用作解析相关引用的基址的键。

protected  String

BasicFileChooserUI.helpButtonText

protected  String

BasicFileChooserUI.helpButtonToolTipText

protected static String

BasicInternalFrameTitlePane.ICONIFY_CMD

protected static String

BasicInternalFrameTitlePane.MAXIMIZE_CMD

protected static String

BasicInternalFrameTitlePane.MOVE_CMD

protected static String

BasicSplitPaneUI.NON_CONTINUOUS_DIVIDER
用于非连续布局的分隔符通过此对象添加到拆分窗格。

protected  String

BasicFileChooserUI.openButtonText

protected  String

BasicFileChooserUI.openButtonToolTipText

static String

BasicHTML.propertyKey
存储为 JComponent 的客户端属性时用于 html 渲染器的键。

protected static String

BasicInternalFrameTitlePane.RESTORE_CMD

protected  String

BasicFileChooserUI.saveButtonText

protected  String

BasicFileChooserUI.saveButtonToolTipText

protected static String

BasicInternalFrameTitlePane.SIZE_CMD

protected  String

BasicFileChooserUI.updateButtonText

protected  String

BasicFileChooserUI.updateButtonToolTipText

返回 String 的 javax.swing.plaf.basic 中的方法

String

BasicFileChooserUI.getApproveButtonText(JFileChooser fc)

String

BasicFileChooserUI.getApproveButtonToolTipText(JFileChooser fc)

String

BasicFileChooserUI.AcceptAllFileFilter.getDescription()

String

BasicFileChooserUI.BasicFileView.getDescription(File f)

String

BasicFileChooserUI.getDialogTitle(JFileChooser fc)
返回此对话框的标题

String

BasicFileChooserUI.getDirectoryName()

String

BasicFileChooserUI.getFileName()

protected  String

BasicTextUI.getKeymapName()
获取默认情况下为此 UI 安装或用于此 UI 的 keymap 的名称。

String

BasicFileChooserUI.BasicFileView.getName(File f)

String

BasicCheckBoxUI.getPropertyPrefix()

protected  String

BasicEditorPaneUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicFormattedTextFieldUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicPasswordFieldUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicTextPaneUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicRadioButtonMenuItemUI.getPropertyPrefix()

protected  String

BasicCheckBoxMenuItemUI.getPropertyPrefix()

protected  String

BasicTextAreaUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected  String

BasicRadioButtonUI.getPropertyPrefix()

protected  String

BasicTextFieldUI.getPropertyPrefix()
获取用作键以通过 UIManager 查找属性的名称。

protected abstract  String

BasicTextUI.getPropertyPrefix()
获取通过 UIManager 查找属性时用作键的名称。

protected  String

BasicMenuUI.getPropertyPrefix()

protected  String

BasicMenuItemUI.getPropertyPrefix()

protected  String

BasicToggleButtonUI.getPropertyPrefix()

protected  String

BasicButtonUI.getPropertyPrefix()

protected  String

BasicInternalFrameTitlePane.getTitle(String text, FontMetrics fm, int availTextWidth)

String

BasicTextUI.getToolTipText(JTextComponent t, Point pt)
返回在传入位置上用作工具提示的字符串。

String

BasicFileChooserUI.BasicFileView.getTypeDescription(File f)

protected  String

BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。

参数类型为 String 的 javax.swing.plaf.basic 中的方法

void

BasicInternalFrameTitlePane.TitlePaneLayout.addLayoutComponent(String name, Component c)

void

BasicInternalFrameUI.InternalFrameLayout.addLayoutComponent(String name, Component c)

void

BasicOptionPaneUI.ButtonAreaLayout.addLayoutComponent(String string, Component comp)

void

BasicSplitPaneDivider.DividerLayout.addLayoutComponent(String string, Component c)

void

BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(String place, Component component)
在 place 位置添加组件。

void

BasicTabbedPaneUI.TabbedPaneLayout.addLayoutComponent(String name, Component comp)

void

BasicComboBoxUI.ComboBoxLayoutManager.addLayoutComponent(String name, Component comp)

void

BasicScrollBarUI.addLayoutComponent(String name, Component child)

protected  void

BasicOptionPaneUI.burstStringInto(Container c, String d, int maxll)
递归式创建表示 d 的新 JLabel 实例每个 JLabel 实例都将被添加到 c。

static View

BasicHTML.createHTMLView(JComponent c, String html)
创建给定组件和 html 字符串的 html 渲染器。

static void

BasicGraphicsUtils.drawString(Graphics g, String text, int underlinedChar, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x,y) 绘制字符串。

static void

BasicGraphicsUtils.drawStringUnderlineCharAt(Graphics g, String text, int underlinedIndex, int x, int y)
像 g.drawString 那样利用图形 g 在位置 (x, y) 绘制字符串。

protected  void

BasicDirectoryModel.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 boolean 属性的绑定属性的改变。

protected  Point

BasicProgressBarUI.getStringPlacement(Graphics g, String progressString, int x, int y, int width, int height)
指定将绘制进度字符串的位置。

protected  String

BasicInternalFrameTitlePane.getTitle(String text, FontMetrics fm, int availTextWidth)

static boolean

BasicHTML.isHTMLString(String s)
检查给定字符串以查看它是否应该在支持 html 呈现的非文本组件中触发 html 呈现逻辑。

protected  String

BasicLabelUI.layoutCL(JLabel label, FontMetrics fontMetrics, String text, Icon icon, Rectangle viewR, Rectangle iconR, Rectangle textR)
将调用转发到 SwingUtilities.layoutCompoundLabel()。

protected  void

BasicTabbedPaneUI.layoutLabel(int tabPlacement, FontMetrics metrics, int tabIndex, String title, Icon icon, Rectangle tabRect, Rectangle iconRect, Rectangle textRect, boolean isSelected)

protected  void

BasicLookAndFeel.loadSystemColors(UIDefaults table, String[] systemColors, boolean useNative)
用 systemColors 中的 name-color 对填充 table。

protected  void

BasicLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用 background.lighter() 将 clippedText 绘制在 textX、textY 处，然后利用 background.darker() 向右下移动一个像素。

protected  void

BasicLabelUI.paintEnabledText(JLabel l, Graphics g, String s, int textX, int textY)
利用标签的前景色将 clippedText 绘制在 textX、textY 处。

protected  void

BasicButtonUI.paintText(Graphics g, AbstractButton b, Rectangle textRect, String text)
呈现当前按钮文本的方法。

protected  void

BasicTabbedPaneUI.paintText(Graphics g, int tabPlacement, Font font, FontMetrics metrics, int tabIndex, String title, Rectangle textRect, boolean isSelected)

protected  void

BasicButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)
从 Java 2 平台 v 1.4 开始，不应再使用或重写此方法。

protected  void

BasicMenuItemUI.paintText(Graphics g, JMenuItem menuItem, Rectangle textRect, String text)
呈现当前菜单项的文本。

void

BasicFileChooserUI.setDirectoryName(String dirname)

void

BasicFileChooserUI.setFileName(String filename)

static void

BasicHTML.updateRenderer(JComponent c, String text)
将给定文本的 HTML 渲染器隐藏在给定 JComponent 的客户端属性中。

参数类型为 String 的 javax.swing.plaf.basic 中的构造方法

BasicTreeUI.TreeCancelEditingAction(String name)

BasicTreeUI.TreeHomeAction(int direction, String name)

BasicTreeUI.TreeIncrementAction(int direction, String name)

BasicTreeUI.TreePageAction(int direction, String name)

BasicTreeUI.TreeToggleAction(String name)

BasicTreeUI.TreeTraverseAction(int direction, String name)

javax.swing.plaf.metal 中 String 的使用

声明为 String 的 javax.swing.plaf.metal 中的字段

static String

MetalScrollBarUI.FREE_STANDING_PROP

protected static String

MetalInternalFrameUI.IS_PALETTE

protected  String

MetalSliderUI.SLIDER_FILL

返回 String 的 javax.swing.plaf.metal 中的方法

String

MetalToolTipUI.getAcceleratorString()

String

MetalLookAndFeel.getDescription()
返回此外观的简短描述。

String

MetalFileChooserUI.getDirectoryName()

String

MetalFileChooserUI.getFileName()

String

MetalLookAndFeel.getID()
此外观的标识符。

String

OceanTheme.getName()
返回此主题的名称，即 "Ocean"。

String

DefaultMetalTheme.getName()
返回此主题的名称。

abstract  String

MetalTheme.getName()
返回此主题的名称。

String

MetalLookAndFeel.getName()
返回此外观的名称。

String

MetalCheckBoxUI.getPropertyPrefix()

参数类型为 String 的 javax.swing.plaf.metal 中的方法

protected  void

MetalLabelUI.paintDisabledText(JLabel l, Graphics g, String s, int textX, int textY)
只绘制文本灰度 (Label.disabledForeground)，而不是使用标签前景色。

protected  void

MetalToggleButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)

protected  void

MetalButtonUI.paintText(Graphics g, JComponent c, Rectangle textRect, String text)

void

MetalFileChooserUI.setDirectoryName(String dirname)

void

MetalFileChooserUI.setFileName(String filename)

javax.swing.plaf.multi 中 String 的使用

返回 String 的 javax.swing.plaf.multi 中的方法

String

MultiFileChooserUI.getApproveButtonText(JFileChooser a)
在由此对象处理的每个 UI 上调用 getApproveButtonText 方法。

String

MultiLookAndFeel.getDescription()
返回对此外观的一行描述。

String

MultiFileChooserUI.getDialogTitle(JFileChooser a)
在由此对象处理的每个 UI 上调用 getDialogTitle 方法。

String

MultiLookAndFeel.getID()
返回适合应用程序/服务使用、标识此外观的 string。

String

MultiLookAndFeel.getName()
返回适合在菜单中使用、标识此外观的 string。

String

MultiTextUI.getToolTipText(JTextComponent a, Point b)
在由此对象处理的每个 UI 上调用 getToolTipText 方法。

javax.swing.plaf.synth 中 String 的使用

返回 String 的 javax.swing.plaf.synth 中的方法

String

SynthLookAndFeel.getDescription()
返回 SynthLookAndFeel 的文本描述。

String

SynthLookAndFeel.getID()
返回一个标识此外观的短字符串。

String

Region.getName()
返回 region 的名称。

String

SynthLookAndFeel.getName()
返回一个标识此外观的短字符串。

String

SynthStyle.getString(SynthContext context, Object key, String defaultValue)
获得其值是一个 String 值的特定样式属性的便捷方法。

String

SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
根据通过引用返回的放置图标和文本的位置，布局文本和图标。

String

ColorType.toString()
返回此 ColorType 的文本描述。

String

Region.toString()
返回 Region 的名称。

参数类型为 String 的 javax.swing.plaf.synth 中的方法

int

SynthGraphicsUtils.computeStringWidth(SynthContext ss, Font font, FontMetrics metrics, String text)
返回传入字符串的大小。

Dimension

SynthGraphicsUtils.getMaximumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
返回正确呈现图标和文本所需的最大大小。

Dimension

SynthGraphicsUtils.getMinimumSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
返回正确呈现图标和文本所需的最小大小。

Dimension

SynthGraphicsUtils.getPreferredSize(SynthContext ss, Font font, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex)
返回正确呈现图标和文本所需的首选大小。

String

SynthStyle.getString(SynthContext context, Object key, String defaultValue)
获得其值是一个 String 值的特定样式属性的便捷方法。

String

SynthGraphicsUtils.layoutText(SynthContext ss, FontMetrics fm, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int iconTextGap)
根据通过引用返回的放置图标和文本的位置，布局文本和图标。

void

SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Icon icon, int hAlign, int vAlign, int hTextPosition, int vTextPosition, int iconTextGap, int mnemonicIndex, int textOffset)
绘制图标和文本。

void

SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, int x, int y, int mnemonicIndex)
在指定位置上绘制文本。

void

SynthGraphicsUtils.paintText(SynthContext ss, Graphics g, String text, Rectangle bounds, int mnemonicIndex)
在指定位置上绘制文本。

参数类型为 String 的 javax.swing.plaf.synth 中的构造方法

ColorType(String description)
创建一个具有指定描述的 ColorType。

Region(String name, String ui, boolean subregion)
创建具有指定名称的 Region。

javax.swing.table 中 String 的使用

声明为 String 的 javax.swing.table 中的字段

static String

TableColumn.CELL_RENDERER_PROPERTY
从 Java 2 platform v1.3 开始已过时。

static String

TableColumn.COLUMN_WIDTH_PROPERTY
从 Java 2 platform v1.3 开始已过时。

static String

TableColumn.HEADER_RENDERER_PROPERTY
从 Java 2 platform v1.3 开始已过时。

static String

TableColumn.HEADER_VALUE_PROPERTY
从 Java 2 platform v1.3 开始已过时。

返回 String 的 javax.swing.table 中的方法

String

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleDescription()

String

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleName()

String

DefaultTableModel.getColumnName(int column)
返回列名称。

String

AbstractTableModel.getColumnName(int column)
返回列默认名称，其中列使用以下工作表约定：A、B、C……Z、AA、AB 等等。

String

TableModel.getColumnName(int columnIndex)
返回 columnIndex 位置的列的名称。

String

JTableHeader.getToolTipText(MouseEvent event)
如果设置了提示文本，则允许使用渲染器的提示。

String

JTableHeader.getUIClassID()
返回用于构造外观 (L&F) 类名称的后缀，该类用于渲染此组件。

protected  String

JTableHeader.paramString()
返回此 JTableHeader 的字符串表示形式。

abstract  String

TableStringConverter.toString(TableModel model, int row, int column)
返回指定位置处值的字符串表示形式。

参数类型为 String 的 javax.swing.table 中的方法

int

AbstractTableModel.findColumn(String columnName)
返回具有给定名称的列。

void

DefaultTableCellRenderer.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
因为性能原因而被重写。

protected  void

DefaultTableCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

void

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setAccessibleDescription(String s)

void

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.setAccessibleName(String s)

javax.swing.text 中 String 的使用

声明为 String 的 javax.swing.text 中的字段

String

JTextComponent.KeyBinding.actionName
键的操作名称。

static String

DefaultEditorKit.backwardAction
用于将插入符在逻辑上向后移动一个位置的动作名称。

protected static String

AbstractDocument.BAD_LOCATION
指示位置错误的错误消息。

static String

DefaultEditorKit.beepAction
用于创建蜂鸣声的动作名称。

static String

DefaultEditorKit.beginAction
用于将插入符移动到文档开头的 Action 名称。

static String

DefaultEditorKit.beginLineAction
用于将插入符移动到行首的 Action 名称。

static String

DefaultEditorKit.beginParagraphAction
用于将插入符移动到段落开头的 Action 名称。

static String

DefaultEditorKit.beginWordAction
用于将插入符移动到字首的 Action 名称。

static String

AbstractDocument.BidiElementName
用于保存单向操作的元素名。

static String

StyleConstants.ComponentElementName
用于表示组件的元素名称。

static String

AbstractDocument.ContentElementName
用于表示内容的元素名

static String

DefaultEditorKit.copyAction
复制选定区域并将其内容置于剪贴板中的动作名称。

static String

DefaultEditorKit.cutAction
剪切选定区域并将其内容置于剪贴板中的动作名称。

static String

JTextComponent.DEFAULT_KEYMAP
将由所有 JTextComponent 实例共享的默认 keymap，除非这些实例已有另一个 keymap 集合。

static String

StyleContext.DEFAULT_STYLE
赋予与段落相关的默认逻辑样式的名称。

static String

DefaultEditorKit.defaultKeyTypedAction
在接收到键输入事件 并且无 keymap 输入时默认执行的动作名称。

static String

DefaultEditorKit.deleteNextCharAction
删除当前插入符位置之后字符内容的动作名称。

static String

DefaultEditorKit.deleteNextWordAction
删除选择开始位置之后单词的动作名称。

static String

DefaultEditorKit.deletePrevCharAction
删除当前插入符位置之前字符内容的动作名称。

static String

DefaultEditorKit.deletePrevWordAction
删除选择开始位置之前单词的动作名称。

static String

DefaultEditorKit.downAction
用于将插入符在逻辑上向下移动一个位置的动作名称。

static String

AbstractDocument.ElementNameAttribute
用于指定元素名的属性名。

static String

DefaultEditorKit.endAction
用于将插入符移动到文档末尾的 Action 名称。

static String

DefaultEditorKit.endLineAction
用于将插入符移动到行尾的 Action 名称。

static String

DefaultEditorKit.EndOfLineStringProperty
在读取文档时，如果遇到 CRLF，将添加具有此名称的一个属性，属性值为 "\r\n"。

static String

DefaultEditorKit.endParagraphAction
用于将插入符移动到段落末尾的 Action 名称。

static String

DefaultEditorKit.endWordAction
用于将插入符移动到字尾的动作名称。

static String

JTextComponent.FOCUS_ACCELERATOR_KEY
焦点加速键的绑定 (bound) 属性名称。

static String

DefaultEditorKit.forwardAction
用于将插入符逻辑向前移动一个位置的动作名称。

static String

StyleConstants.IconElementName
用于表示图标的元素名称。

static String

DefaultEditorKit.insertBreakAction
向文档放置行/段中断的动作名称。

static String

DefaultEditorKit.insertContentAction
将内容置于关联文档中的动作名称。

static String

DefaultEditorKit.insertTabAction
将制表符置于文档中的动作名称。

static String

PlainDocument.lineLimitAttribute
指定行的最大长度的属性名称（如果有最大长度）。

static String

DefaultEditorKit.nextWordAction
用于将插入符移动到下一个字开头的 Action 名称。

static String

DefaultEditorKit.pageDownAction
垂直向下翻页的动作名称。

static String

DefaultEditorKit.pageUpAction
垂直向上翻页的动作名称。

static String

AbstractDocument.ParagraphElementName
用于表示段落的元素名

static String

DefaultEditorKit.pasteAction
将系统剪贴板内容粘贴到选定区域、如果未选中任何内容，则粘贴到插入符之前的动作名称。

static String

DefaultEditorKit.previousWordAction
用于将插入符移动到前一个字开头的 Action 名称。

static String

DefaultEditorKit.readOnlyAction
将编辑器设置为只读模式的动作名称。

static String

AbstractDocument.SectionElementName
用于保存各节（行/段落）的元素名。

static String

DefaultEditorKit.selectAllAction
用于选中整个文档的动作名称

static String

DefaultEditorKit.selectionBackwardAction
通过将插入符在逻辑上向后移动一个位置来扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionBeginAction
用于将插入符移动到文档开头的 Action 名称。

static String

DefaultEditorKit.selectionBeginLineAction
用于将插入符移动到行首并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionBeginParagraphAction
用于将插入符移动到段落开头并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionBeginWordAction
用于将插入符移动到字首并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionDownAction
用于将插入符在逻辑上向下移动一个位置并扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionEndAction
用于将插入符移动到文档末尾的 Action 名称。

static String

DefaultEditorKit.selectionEndLineAction
用于将插入符移动到行尾并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionEndParagraphAction
用于将插入符移动到段落末尾并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionEndWordAction
用于将插入符移动到字尾并扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionForwardAction
通过将插入符在逻辑上向前移动一个位置来扩展选定内容的动作名称。

static String

DefaultEditorKit.selectionNextWordAction
用于将选定内容移动到下一个字的开头并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionPreviousWordAction
用于将选定内容移动到前一个字的开头并扩展选定内容的 Action 名称。

static String

DefaultEditorKit.selectionUpAction
用于将插入符在逻辑上向上移动一个位置并扩展选定内容的动作名称。

static String

DefaultEditorKit.selectLineAction
用于选中围绕插入符的某一行的 Action 名称。

static String

DefaultEditorKit.selectParagraphAction
用于选中围绕插入符的一个段落的动作名称。

static String

DefaultEditorKit.selectWordAction
用于选中围绕插入符的某个字的 Action 名称。

static String

Document.StreamDescriptionProperty
用于描述初始化文档的流的属性名。

static String

PlainDocument.tabSizeAttribute
指定内容中包含的制表符大小的属性名称。

static String

Document.TitleProperty
文档标题的属性名（如果有）。

static String

DefaultEditorKit.upAction
用于将插入符在逻辑上向上移动一个位置的动作名称。

static String

DefaultEditorKit.writableAction
将编辑器设置为可写入模式的动作名称。

返回 String 的 javax.swing.text 中的方法

String

JTextComponent.AccessibleJTextComponent.getAccessibleActionDescription(int i)
返回对该对象的指定操作的描述。

String

JTextComponent.AccessibleJTextComponent.getAfterIndex(int part, int index)
返回给定索引之后的 String。

String

JTextComponent.AccessibleJTextComponent.getAtIndex(int part, int index)
返回给定索引处的 String。

String

JTextComponent.AccessibleJTextComponent.getBeforeIndex(int part, int index)
返回给定索引之前的 String。

String

ChangedCharSetException.getCharSetSpec()

String

DefaultEditorKit.getContentType()
获取此工具包声明支持的数据的 MIME 类型。

abstract  String

EditorKit.getContentType()
获得此工具包声明支持的数据的 MIME 类型。

static String

StyleConstants.getFontFamily(AttributeSet a)
从属性列表中获取字体系列设置。

String

MaskFormatter.getInvalidCharacters()
返回输入无效的字符。

String

AbstractWriter.getLineSeparator()
返回用于表示换行的 String。

String

MaskFormatter.getMask()
返回格式化掩码。

String

DefaultStyledDocument.SectionElement.getName()
获得元素的名称。

String

Keymap.getName()
获取键绑定集合的名称。

String

Style.getName()
获取样式名称。

String

StyleContext.NamedStyle.getName()
获取样式的名称。

String

AbstractDocument.AbstractElement.getName()
获取该元素的名称。

String

AbstractDocument.BranchElement.getName()
获得元素名。

String

AbstractDocument.LeafElement.getName()
获得元素名。

String

Element.getName()
获取元素的名称。

String

MaskFormatter.getPlaceholder()
如果值未完全填充掩码，则返回要使用的 String。

String

AbstractDocument.DefaultDocumentEvent.getPresentationName()
提供此次编辑的已本地化的、可读的描述，比如，适合于在更改日志中使用的。

String

AbstractDocument.DefaultDocumentEvent.getRedoPresentationName()
提供此次编辑可重复执行形式的、已本地化的、可读的描述，例如用作 Redo 菜单项。

String

JTextComponent.getSelectedText()
返回此 TextComponent 中包含的选定文本。

String

JTextComponent.AccessibleJTextComponent.getSelectedText()
返回选定文本的某一部分。

String

StringContent.getString(int where, int len)
检索内容的某一部分，where ＋ len 必须 <= length()。

String

GapContent.getString(int where, int len)
检索部分内容。

String

AbstractDocument.Content.getString(int where, int len)
获取序列中包含的字符串。

String

JTextComponent.getText()
返回此 TextComponent 中包含的文本。

protected  String

AbstractWriter.getText(Element elem)
返回与该元素关联的文本。

String

JTextComponent.getText(int offs, int len)
获取由组件表示的文本部分。

String

AbstractDocument.getText(int offset, int length)
从文档中获得文本序列。

String

Document.getText(int offset, int length)
获取文档中给定部分包含的文本。

String

JTextComponent.AccessibleJTextComponent.getTextRange(int startIndex, int endIndex)
返回两个索引之间的文本字符串。

String

View.getToolTipText(float x, float y, Shape allocation)
返回提定位置的工具提示文本。

String

JTextComponent.getToolTipText(MouseEvent event)
返回用作 event 的工具提示的字符串。

String

AbstractDocument.DefaultDocumentEvent.getUndoPresentationName()
提供此次编辑可撤消形式的、已本地化的、可读的描述，例如，用作 Undo 菜单项。

String

MaskFormatter.getValidCharacters()
返回可以输入的有效字符。

protected  String

JTextComponent.paramString()
返回此 JTextComponent 的字符串表示形式。

String

DefaultStyledDocument.ElementSpec.toString()
将元素转换为字符串。

String

TabSet.toString()
返回此 tab 集合的字符串表示形式。

String

TabStop.toString()

String

DefaultCaret.toString()

String

JTextComponent.DropLocation.toString()
返回此放置位置的字符串表示形式。

String

Segment.toString()
将 segment 转换为 String。

String

Position.Bias.toString()
字符串表示形式

String

SimpleAttributeSet.toString()
将属性集转换为 String。

String

StyleConstants.toString()
返回字符串表示形式。

String

StyleContext.toString()
将 StyleContext 转换成为 String。

String

StyleContext.SmallAttributeSet.toString()
返回表示键/值对的字符串

String

StyleContext.NamedStyle.toString()
将样式转换成为字符串。

String

AbstractDocument.BranchElement.toString()
将该元素转换为字符串。

String

AbstractDocument.LeafElement.toString()
将该元素转换为字符串。

String

AbstractDocument.DefaultDocumentEvent.toString()
返回更改事件的字符串表示形式。

String

DefaultFormatter.valueToString(Object value)
使用 toString 方法将传入的 Object 转换为 String。

String

InternationalFormatter.valueToString(Object value)
返回 Object value 的 String 表示形式。

String

MaskFormatter.valueToString(Object value)
返回基于掩码的 Object value 的 String 表示形式。

参数类型为 String 的 javax.swing.text 中的方法

static Keymap

JTextComponent.addKeymap(String nm, Keymap parent)
将一个新 keymap 添加到 keymap 层次结构。

Style

DefaultStyledDocument.addStyle(String nm, Style parent)
向逻辑样式层次结构中添加新样式。

Style

StyledDocument.addStyle(String nm, Style parent)
向逻辑样式层次中添加新样式。

Style

StyleContext.addStyle(String nm, Style parent)
将新的样式添加到样式层次中。

Font

StyleContext.getFont(String family, int style, int size)
获取新字体。

static Keymap

JTextComponent.getKeymap(String nm)
获取以前添加到文档中的已命名 keymap。

Style

DefaultStyledDocument.getStyle(String nm)
获取以前添加的已命名的样式。

Style

StyledDocument.getStyle(String nm)
获取以前添加的指定样式。

Style

StyleContext.getStyle(String nm)
获取以前添加到文档中的已命名样式

void

DocumentFilter.insertString(DocumentFilter.FilterBypass fb, int offset, String string, AttributeSet attr)
将文本插入指定的 Document 之前调用。

UndoableEdit

StringContent.insertString(int where, String str)
将字符串插入到内容中。

UndoableEdit

GapContent.insertString(int where, String str)
在内容中插入字符串。

UndoableEdit

AbstractDocument.Content.insertString(int where, String str)
向序列中插入一个字符串。

abstract  void

DocumentFilter.FilterBypass.insertString(int offset, String string, AttributeSet attr)
插入指定的文本，绕过 DocumentFilter。

void

PlainDocument.insertString(int offs, String str, AttributeSet a)
向文档中插入某些内容。

void

AbstractDocument.insertString(int offs, String str, AttributeSet a)
将某些内容插入文档。

void

Document.insertString(int offset, String str, AttributeSet a)
插入内容字符串。

void

JTextComponent.AccessibleJTextComponent.insertTextAtIndex(int index, String s)
在给定索引处插入指定字符串

static Keymap

JTextComponent.removeKeymap(String nm)
移除以前添加到文档中的已命名 keymap。

void

DefaultStyledDocument.removeStyle(String nm)
移除以前添加到文档中的已命名样式。

void

StyledDocument.removeStyle(String nm)
移除以前添加到文档中的指定样式。

void

StyleContext.removeStyle(String nm)
移除以前添加到文档中的已命名样式。

void

DocumentFilter.replace(DocumentFilter.FilterBypass fb, int offset, int length, String text, AttributeSet attrs)
在替换指定的 Document 中的文本区域之前调用。

abstract  void

DocumentFilter.FilterBypass.replace(int offset, int length, String string, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换。

void

AbstractDocument.replace(int offset, int length, String text, AttributeSet attrs)
删除从 offset 到 offset + length 的文本区域，并用 text 替换它。

void

JTextComponent.replaceSelection(String content)
用给定字符串所表示的新内容替换当前选定的内容。

void

JTextComponent.AccessibleJTextComponent.replaceText(int startIndex, int endIndex, String s)
使用指定字符串替换两个索引之间的文本。

static void

StyleConstants.setFontFamily(MutableAttributeSet a, String fam)
设置字体属性。

void

MaskFormatter.setInvalidCharacters(String invalidCharacters)
允许进一步限制可以输入的字符。

void

AbstractWriter.setLineSeparator(String value)
设置用于表示换行的 String。

void

MaskFormatter.setMask(String mask)
设置指示合法字符的掩码。

void

StyleContext.NamedStyle.setName(String name)
更改样式的名称。

void

MaskFormatter.setPlaceholder(String placeholder)
设置值未完全填充掩码时要使用的字符串。

void

JTextComponent.setText(String t)
将此 TextComponent 文本设置为指定文本。

void

JTextComponent.AccessibleJTextComponent.setTextContents(String s)
将文本内容设置为指定字符串。

void

MaskFormatter.setValidCharacters(String validCharacters)
允许进一步限制可以输入的字符。

Object

DefaultFormatter.stringToValue(String string)
通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。

Object

InternationalFormatter.stringToValue(String text)
返回 String text 的 Object 表示形式。

Object

MaskFormatter.stringToValue(String value)
解析文本，返回 String value 的适当 Object 表示形式。

protected  void

AbstractWriter.write(String content)
写出字符串。

参数类型为 String 的 javax.swing.text 中的构造方法

BadLocationException(String s, int offs)
创建新的 BadLocationException 对象。

ChangedCharSetException(String charSetSpec, boolean charSetKey)

JTextComponent.KeyBinding(KeyStroke key, String actionName)
创建新的键绑定。

MaskFormatter(String mask)
创建具有指定掩码的 MaskFormatter。

StyleContext.NamedStyle(String name, Style parent)
创建新的命名样式。

StyledEditorKit.AlignmentAction(String nm, int a)
创建新的 AlignmentAction。

StyledEditorKit.FontFamilyAction(String nm, String family)
创建新的 FontFamilyAction。

StyledEditorKit.FontSizeAction(String nm, int size)
创建新 FontSizeAction。

StyledEditorKit.ForegroundAction(String nm, Color fg)
创建新的 ForegroundAction。

StyledEditorKit.StyledTextAction(String nm)
通过字符串操作名称创建新的 StyledTextAction。

TextAction(String name)
创建一个新的 JTextAction 对象。

javax.swing.text.html 中 String 的使用

声明为 String 的 javax.swing.text.html 中的字段

static String

HTMLDocument.AdditionalComments
文档属性键值。

static String

HTMLEditorKit.BOLD_ACTION
粗体动作标识符

static String

HTMLEditorKit.COLOR_ACTION
Color 选择动作标识符（颜色作为参数传递）

static String

HTMLEditorKit.DEFAULT_CSS
用于设置标记视图的默认级联样式表 (Cascading Style Sheet) 文件。

static String

HTMLEditorKit.FONT_CHANGE_BIGGER
字体大小增大到下一个值的动作标识符

static String

HTMLEditorKit.FONT_CHANGE_SMALLER
字体大小减小到下一个值的动作标识符

protected  String

HTMLEditorKit.InsertHTMLTextAction.html
要插入的 HTML。

static String

HTMLEditorKit.IMG_ALIGN_BOTTOM
将图像底部对齐。

static String

HTMLEditorKit.IMG_ALIGN_MIDDLE
将图像居中对齐。

static String

HTMLEditorKit.IMG_ALIGN_TOP
将图像顶部对齐。

static String

HTMLEditorKit.IMG_BORDER
将图像对齐到边框。

static String

HTMLEditorKit.ITALIC_ACTION
斜体动作标识符

static String

HTMLEditorKit.LOGICAL_STYLE_ACTION
逻辑样式选择动作标识符（逻辑样式作为参数传递）

static String

HTML.NULL_ATTRIBUTE_VALUE

static String

HTMLEditorKit.PARA_INDENT_LEFT
段落左缩进动作标识符

static String

HTMLEditorKit.PARA_INDENT_RIGHT
段落右缩进动作标识符

static String

FormView.RESET
已过时。 从 1.3 开始，将使用来自 UIManager UIManager property FormView.resetButtonText 的值

static String

FormView.SUBMIT
已过时。 从 1.3 开始，将使用来自 UIManager property FormView.submitButtonText 的值

返回 String 的 javax.swing.text.html 中的方法

String

ImageView.getAltText()
如果不能加载图像，则返回要显示的文本。

String

HTMLEditorKit.getContentType()
获取此工具包支持的 MIME 类型的数据。

String

FormSubmitEvent.getData()
获取表单提交数据。

String

CSS.Attribute.getDefaultValue()
获取属性的默认值。

String

Option.getLabel()
获取与该选项相关的标签。

String

HTMLDocument.RunElement.getName()
获取元素名称。

String

HTMLDocument.BlockElement.getName()
获取元素名称。

String

HTMLFrameHyperlinkEvent.getTarget()
返回链接的目标。

String

ImageView.getToolTipText(float x, float y, Shape allocation)
对于图像，工具提示文本来自于 ALT 属性指定的文本。

String

Option.getValue()
返回与 value 属性相关的字符串的便捷方法。

String

CSS.Attribute.toString()
属性的字符串表示形式。

String

HTML.Tag.toString()
返回该标记的字符串表示形式。

String

HTML.Attribute.toString()
返回此属性的字符串表示形式。

String

Option.toString()
String 的表示形式为 label。

参数类型为 String 的 javax.swing.text.html 中的方法

void

StyleSheet.addCSSAttribute(MutableAttributeSet attr, CSS.Attribute key, String value)
将 CSS 属性添加到给定的集合。

boolean

StyleSheet.addCSSAttributeFromHTML(MutableAttributeSet attr, CSS.Attribute key, String value)
将 CSS 属性添加到给定的集合。

void

StyleSheet.addRule(String rule)
向 sheet 添加规则集合。

static CSS.Attribute

CSS.getAttribute(String name)
将字符串转换为 CSS.Attribute 对象。

static HTML.Attribute

HTML.getAttributeKey(String attName)
获取已知属性名称的属性常量（即集合 {FACE, COMMENT, SIZE, COLOR, CLEAR, BACKGROUND, BGCOLOR, TEXT, LINK, VLINK, ALINK, WIDTH, HEIGHT, ALIGN, NAME, HREF, REL, REV, TITLE, TARGET, SHAPE, COORDS, ISMAP, NOHREF, ALT, ID, SRC, HSPACE, VSPACE, USEMAP, LOWSRC, CODEBASE, CODE, ARCHIVE, VALUE, VALUETYPE, TYPE, CLASS, STYLE, LANG, DIR, DECLARE, CLASSID, DATA, CODETYPE, STANDBY, BORDER, SHAPES, NOSHADE, COMPACT, START, ACTION, METHOD, ENCTYPE, CHECKED, MAXLENGTH, MULTIPLE, SELECTED, ROWS, COLS, DUMMY, CELLSPACING, CELLPADDING, VALIGN, HALIGN, NOWRAP, ROWSPAN, COLSPAN, PROMPT, HTTPEQUIV, CONTENT, LANGUAGE, VERSION, N, FRAMEBORDER, MARGINWIDTH, MARGINHEIGHT, SCROLLING, NORESIZE, MEDIA, ENDTAG} 中的某个属性）。

AttributeSet

StyleSheet.getDeclaration(String decl)
将 CSS 声明转换为表示 CSS 声明的 AttributeSet。

Element

HTMLDocument.getElement(String id)
返回具有给定 id Attribute 的元素。

float

StyleSheet.getPointSize(String size)
如果给定字符串（如 "+2"、"-2" 或 "2"），则返回点大小值。

Style

StyleSheet.getRule(String selector)
获取最能匹配以字符串形式表示的选择器的规则。

static HTML.Tag

HTML.getTag(String tagName)
获取已知标记名称的标记常量（即集合 {A, ADDRESS, APPLET, AREA, B, BASE, BASEFONT, BIG, BLOCKQUOTE, BODY, BR, CAPTION, CENTER, CITE, CODE, DD, DFN, DIR, DIV, DL, DT, EM, FONT, FORM, FRAME, FRAMESET, H1, H2, H3, H4, H5, H6, HEAD, HR, HTML, I, IMG, INPUT, ISINDEX, KBD, LI, LINK, MAP, MENU, META, NOBR, NOFRAMES, OBJECT, OL, OPTION, P, PARAM, PRE, SAMP, SCRIPT, SELECT, SMALL, SPAN, STRIKE, S, STRONG, STYLE, SUB, SUP, TABLE, TD, TEXTAREA, TH, TITLE, TR, TT, U, UL, VAR} 中的某个标记）。

void

HTMLDocument.HTMLReader.handleEndOfLineString(String eol)
它的调用是在完成流的解析之后且在调用 flush 之前。

void

HTMLEditorKit.ParserCallback.handleEndOfLineString(String eol)
它的调用是在完成流的解析之后且在调用 flush 之前。

void

HTMLEditorKit.ParserCallback.handleError(String errorMsg, int pos)

protected  void

FormView.imageSubmit(String imageData)
调用此方法来提交表单，以响应在图像上的单击，此图像是类型为 "image" 的 <INPUT> 表单元素。

void

HTMLDocument.insertAfterEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之后。

void

HTMLDocument.insertAfterStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的起始处。

protected  void

HTMLEditorKit.InsertHTMLTextAction.insertAtBoundary(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
当在边界上插入时调用。

protected  void

HTMLEditorKit.InsertHTMLTextAction.insertAtBoundry(JEditorPane editor, HTMLDocument doc, int offset, Element insertElement, String html, HTML.Tag parentTag, HTML.Tag addTag)
已过时。 从 Java 2 平台 v1.3 开始，使用 insertAtBoundary

void

HTMLDocument.insertBeforeEnd(Element elem, String htmlText)
将指定为字符串的 HTML 插入元素的结尾处。

void

HTMLDocument.insertBeforeStart(Element elem, String htmlText)
将指定为字符串的 HTML 插入给定元素的起始处之前。

void

HTMLEditorKit.insertHTML(HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag insertTag)
将 HTML 插入现有文档。

protected  void

HTMLEditorKit.InsertHTMLTextAction.insertHTML(JEditorPane editor, HTMLDocument doc, int offset, String html, int popDepth, int pushDepth, HTML.Tag addTag)
HTMLEditorKit.insertHTML 的一个覆盖。

void

StyleSheet.removeStyle(String nm)
移除以前添加到该文档中的指定样式。

void

StyleSheet.setBaseFontSize(String size)
根据传入的 String 设置基本字体大小。

void

HTMLDocument.setInnerHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换给定元素的子元素。

void

Option.setLabel(String label)
设置该选项使用的标签。

void

HTMLDocument.setOuterHTML(Element elem, String htmlText)
用指定为 HTML 字符串的内容替换父元素中的给定元素。

protected  void

MinimalHTMLWriter.startFontTag(String style)
此方法已不再使用，而用写出 <span> 来替换。

Color

StyleSheet.stringToColor(String string)
将颜色字符串（如 "RED" 或 "#NNNNNN"）转换为 Color。

protected  void

FormView.submitData(String data)
此方法负责提交表单数据。

static FormSubmitEvent.MethodType

FormSubmitEvent.MethodType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

protected  void

MinimalHTMLWriter.writeEndTag(String endTag)
写出适当缩进的结束标记。

protected  void

MinimalHTMLWriter.writeStartTag(String tag)
写出适当缩进的开始标记。

参数类型为 String 的 javax.swing.text.html 中的构造方法

HTML.Tag(String id)
创建具有指定 id 的新 Tag，且 causesBreak 和 isBlock 设置为 false。

HTML.Tag(String id, boolean causesBreak, boolean isBlock)
创建具有指定 id 的新 Tag；causesBreak 和 isBlock 由用户定义。

HTML.UnknownTag(String id)
创建具有指定 id 的新 UnknownTag。

HTMLEditorKit.HTMLTextAction(String name)

HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag)

HTMLEditorKit.InsertHTMLTextAction(String name, String html, HTML.Tag parentTag, HTML.Tag addTag, HTML.Tag alternateParentTag, HTML.Tag alternateAddTag)

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

javax.swing.text.html.parser 中 String 的使用

声明为 String 的 javax.swing.text.html.parser 中的字段

String

AttributeList.name

String

DTD.name

String

Element.name

String

Entity.name

String

AttributeList.value

类型参数类型为 String 的 javax.swing.text.html.parser 中的字段

Hashtable<String,Element>

DTD.elementHash

返回 String 的 javax.swing.text.html.parser 中的方法

String

AttributeList.getName()

String

DTD.getName()
获取 DTD 的名称。

String

Element.getName()
获取元素的名称。

String

Entity.getName()
获取实体的名称。

String

Entity.getString()
返回以 String 表示的数据。

String

AttributeList.getValue()

String

Parser.parseDTDMarkup()
解析 Document Type Declaration 标记声明。

String

AttributeList.toString()

String

ContentModel.toString()
转换为字符串。

String

DTD.toString()
返回此 DTD 的字符串表示形式。

String

Element.toString()
转换为字符串。

static String

AttributeList.type2name(int tp)

参数类型为 String 的 javax.swing.text.html.parser 中的方法

protected static DTD

ParserDelegator.createDTD(DTD dtd, String name)

protected  AttributeList

DTD.defAttributeList(String name, int type, int modifier, String value, String values, AttributeList atts)
创建并返回一个 AttributeList。

protected  Element

DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
创建并返回一个 Element。

protected  Element

DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
创建并返回一个 Element。

protected  Element

DTD.defElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, String[] exclusions, String[] inclusions, AttributeList atts)
创建并返回一个 Element。

Entity

DTD.defEntity(String name, int type, int ch)
创建并返回一个字符 Entity。

protected  Entity

DTD.defEntity(String name, int type, String str)
创建并返回一个 Entity。

void

DTD.defineAttributes(String name, AttributeList atts)
定义 Element 的属性。

Element

DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
返回与指定参数匹配的 Element。

Entity

DTD.defineEntity(String name, int type, char[] data)
定义一个实体。

protected  void

Parser.error(String err)

protected  void

Parser.error(String err, String arg1)

protected  void

Parser.error(String err, String arg1, String arg2)

protected  void

Parser.error(String err, String arg1, String arg2, String arg3)
调用错误处理程序。

AttributeList

Element.getAttribute(String name)
按名称获取一个元素。

AttributeList

Element.getAttributeByValue(String name)
按值获取一个属性。

static DTD

DTD.getDTD(String name)
返回具有指定 name 的 DTD。

Element

DTD.getElement(String name)
按名称获取一个元素。

Entity

DTD.getEntity(String name)
按名称获取一个实体。

protected  void

DocumentParser.handleError(int ln, String errorMsg)

protected  void

Parser.handleError(int ln, String msg)
发生了一个错误。

static int

AttributeList.name2type(String nm)

static int

Element.name2type(String nm)

static int

Entity.name2type(String nm)
将 nm 字符串转换为相应的实体类型。

static void

DTD.putDTDHash(String name, DTD dtd)

参数类型为 String 的 javax.swing.text.html.parser 中的构造方法

AttributeList(String name)
创建一个属性列表元素。

AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
创建一个属性列表元素。

DTD(String name)
创建具有指定名称的新 DTD。

Entity(String name, int type, char[] data)
创建一个实体。

javax.swing.text.rtf 中 String 的使用

返回 String 的 javax.swing.text.rtf 中的方法

String

RTFEditorKit.getContentType()
获取此工具包支持的 MIME 类型的数据。

javax.swing.tree 中 String 的使用

声明为 String 的 javax.swing.tree 中的字段

static String

DefaultTreeSelectionModel.SELECTION_MODE_PROPERTY
selectionMode 的属性名称。

返回 String 的 javax.swing.tree 中的方法

String

DefaultMutableTreeNode.toString()
返回将 toString() 发送到此节点的用户对象的结果，如果此节点没有用户对象，则返回 null。

String

TreePath.toString()
返回一个显示并标识此对象属性的字符串。

String

DefaultTreeSelectionModel.toString()
返回显示并标识此对象属性的字符串。

参数类型为 String 的 javax.swing.tree 中的方法

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, byte oldValue, byte newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, char oldValue, char newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, double oldValue, double newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, float oldValue, float newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, int oldValue, int newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, long oldValue, long newValue)
因为性能原因而被重写。

protected  void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, short oldValue, short newValue)
因为性能原因而被重写。

参数类型为 String 的 javax.swing.tree 中的构造方法

ExpandVetoException(TreeExpansionEvent event, String message)
构造带指定消息的 ExpandVetoException 对象。

javax.swing.undo 中 String 的使用

声明为 String 的 javax.swing.undo 中的字段

protected static String

StateEdit.RCSID

static String

StateEditable.RCSID
此类的资源 ID。

protected static String

AbstractUndoableEdit.RedoName
由 getRedoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此段落。

protected static String

AbstractUndoableEdit.UndoName
由 getUndoPresentationName 返回的字符串；从 Java 2 平台 v1.3.1 开始，不再使用此字段。

protected  String

StateEdit.undoRedoName
撤消/恢复的表示名称

返回 String 的 javax.swing.undo 中的方法

String

StateEdit.getPresentationName()
获取此编辑的表示名称

String

CompoundEdit.getPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getPresentationName。

String

AbstractUndoableEdit.getPresentationName()
此默认实现返回 ""。

String

UndoableEdit.getPresentationName()
返回此编辑的本地化可读描述，例如，适于在更改日志中使用。

String

UndoManager.getRedoPresentationName()
返回此编辑可恢复形式的描述。

String

CompoundEdit.getRedoPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getRedoPresentationName。

String

AbstractUndoableEdit.getRedoPresentationName()
检索默认表中 AbstractUndoableEdit.redoText 键的值，并返回该值，后跟一个空格和 getPresentationName。

String

UndoableEdit.getRedoPresentationName()
返回此编辑可恢复形式的本地化可读描述，例如，适于用作 “Redo” 菜单项。

String

UndoManager.getUndoOrRedoPresentationName()
一个便捷方法，它返回 getUndoPresentationName 或 getRedoPresentationName。

String

UndoManager.getUndoPresentationName()
返回此编辑可撤消形式的描述。

String

CompoundEdit.getUndoPresentationName()
从添加到 edits 的最后 UndoableEdit 返回 getUndoPresentationName。

String

AbstractUndoableEdit.getUndoPresentationName()
检索默认表中 AbstractUndoableEdit.undoText 键的值，并返回该值，后跟一个空格和 getPresentationName。

String

UndoableEdit.getUndoPresentationName()
返回此编辑可撤消形式的本地化可读描述，例如，适于用作 “Undo” 菜单项。

String

UndoManager.toString()
返回显示和标识此对象属性的字符串。

String

UndoableEditSupport.toString()
返回显示和标识此对象属性的字符串。

String

CompoundEdit.toString()
返回一个显示并标识此对象属性的字符串。

String

AbstractUndoableEdit.toString()
返回显示和标识此对象属性的字符串。

参数类型为 String 的 javax.swing.undo 中的方法

protected  void

StateEdit.init(StateEditable anObject, String name)

参数类型为 String 的 javax.swing.undo 中的构造方法

StateEdit(StateEditable anObject, String name)
创建并返回具有表示名称的新 StateEdit。

javax.tools 中 String 的使用

声明为 String 的 javax.tools 中的字段

String

JavaFileObject.Kind.extension
通常用于此类文件对象的扩展名（按照约定）。

返回 String 的 javax.tools 中的方法

String

Diagnostic.getCode()
获取指示诊断类型的诊断代码。

String

Diagnostic.getMessage(Locale locale)
获取给定语言环境的本地化消息。

String

StandardLocation.getName()

String

FileObject.getName()
获取此文件对象的用户友好 (user-friendly) 的名称。

String

ForwardingFileObject.getName()

String

JavaFileManager.Location.getName()
获取此位置的名称。

String

SimpleJavaFileObject.getName()

String

ForwardingJavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)

String

JavaFileManager.inferBinaryName(JavaFileManager.Location location, JavaFileObject file)
根据位置推断文件对象的二进制名称。

String

SimpleJavaFileObject.toString()

参数类型为 String 的 javax.tools 中的方法

FileObject

ForwardingJavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)

FileObject

JavaFileManager.getFileForInput(JavaFileManager.Location location, String packageName, String relativeName)
获取输入的文件对象，它表示给定位置处指定包中的指定相对名称。

FileObject

ForwardingJavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)

FileObject

JavaFileManager.getFileForOutput(JavaFileManager.Location location, String packageName, String relativeName, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定包中的指定相对名称。

JavaFileObject

ForwardingJavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)

JavaFileObject

JavaFileManager.getJavaFileForInput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind)
获取输入的文件对象，它表示给定位置处指定类型的指定类。

JavaFileObject

ForwardingJavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)

JavaFileObject

JavaFileManager.getJavaFileForOutput(JavaFileManager.Location location, String className, JavaFileObject.Kind kind, FileObject sibling)
获取输出的文件对象，它表示给定位置处指定类型的指定类。

Iterable<? extends JavaFileObject>

StandardJavaFileManager.getJavaFileObjects(String... names)
获取表示给定文件名称的文件对象。

boolean

ForwardingJavaFileManager.handleOption(String current, Iterator<String> remaining)

boolean

JavaFileManager.handleOption(String current, Iterator<String> remaining)
处理一个选项。

boolean

ForwardingJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)

boolean

JavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
检查此文件对象是否与指定的简单名称和种类兼容。

boolean

SimpleJavaFileObject.isNameCompatible(String simpleName, JavaFileObject.Kind kind)
此实现对其 URI 路径和给定简单名称进行比较。

int

ForwardingJavaFileManager.isSupportedOption(String option)

int

OptionChecker.isSupportedOption(String option)
确定是否支持给定选项，如果支持，则返回该选项所使用的参数数量。

Iterable<JavaFileObject>

ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)

Iterable<JavaFileObject>

JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
列出给定位置处符合给定标准的所有文件对象。

static JavaFileManager.Location

StandardLocation.locationFor(String name)
使用给定名称获取位置对象。

int

Tool.run(InputStream in, OutputStream out, OutputStream err, String... arguments)
使用给定 I/O 通道和参数运行工具。

static StandardLocation

StandardLocation.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static Diagnostic.Kind

Diagnostic.Kind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static JavaFileObject.Kind

JavaFileObject.Kind.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 javax.tools 中的方法参数

Iterable<? extends JavaFileObject>

StandardJavaFileManager.getJavaFileObjectsFromStrings(Iterable<String> names)
获取表示给定文件名称的文件对象。

JavaCompiler.CompilationTask

JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

JavaCompiler.CompilationTask

JavaCompiler.getTask(Writer out, JavaFileManager fileManager, DiagnosticListener<? super JavaFileObject> diagnosticListener, Iterable<String> options, Iterable<String> classes, Iterable<? extends JavaFileObject> compilationUnits)
使用给定组件和参数创建编译任务的 future。

boolean

ForwardingJavaFileManager.handleOption(String current, Iterator<String> remaining)

boolean

JavaFileManager.handleOption(String current, Iterator<String> remaining)
处理一个选项。

javax.transaction 中 String 的使用

参数类型为 String 的 javax.transaction 中的构造方法

InvalidTransactionException(String msg)

TransactionRequiredException(String msg)

TransactionRolledbackException(String msg)

javax.transaction.xa 中 String 的使用

参数类型为 String 的 javax.transaction.xa 中的构造方法

XAException(String s)
创建一个具有给定字符串的 XAException。

javax.xml 中 String 的使用

声明为 String 的 javax.xml 中的字段

static String

XMLConstants.DEFAULT_NS_PREFIX
用于表示默认 XML 名称空间的前缀。

static String

XMLConstants.FEATURE_SECURE_PROCESSING
用于安全处理的功能。

static String

XMLConstants.NULL_NS_URI
用于表示不存在名称空间的名称空间 URI。

static String

XMLConstants.RELAXNG_NS_URI
RELAX NG Namespace URI. 被定义为 "http://relaxng.org/ns/structure/1.0"。

static String

XMLConstants.W3C_XML_SCHEMA_INSTANCE_NS_URI
W3C XML Schema Instance Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。

static String

XMLConstants.W3C_XML_SCHEMA_NS_URI
W3C XML Schema Namespace URI. 被定义为 "http://www.w3.org/2001/XMLSchema"。

static String

XMLConstants.W3C_XPATH_DATATYPE_NS_URI
W3C XPath Datatype Namespace URI. 被定义为 "http://www.w3.org/2003/11/xpath-datatypes"。

static String

XMLConstants.XML_DTD_NS_URI
作为属性值的 XML 文档类型声明名称空间 URI。

static String

XMLConstants.XML_NS_PREFIX
正式的 XML 名称空间前缀。

static String

XMLConstants.XML_NS_URI
正式的 XML 名称空间名称 URI。

static String

XMLConstants.XMLNS_ATTRIBUTE
用于指定 XML 名称空间声明的正式 XML 属性。

static String

XMLConstants.XMLNS_ATTRIBUTE_NS_URI
用于指定 XML 名称空间声明、XMLConstants.XMLNS_ATTRIBUTE、名称空间名称 URI 的正式 XML 属性。

javax.xml.bind 中 String 的使用

声明为 String 的 javax.xml.bind 中的字段

static String

JAXBContext.JAXB_CONTEXT_FACTORY
属性名称，它包含能够创建新的 JAXBContext 对象的类名称。

static String

Marshaller.JAXB_ENCODING
用来指定已编组 XML 数据中输出编码的属性名称。

static String

Marshaller.JAXB_FORMATTED_OUTPUT
用来指定是否使用换行和缩排对已编组 XML 数据进行格式化的属性名称。

static String

Marshaller.JAXB_FRAGMENT
用来指定 marshaller 是否将生成文档级事件（即调用 startDocument 或 endDocument）的属性名称。

static String

Marshaller.JAXB_NO_NAMESPACE_SCHEMA_LOCATION
用来指定将放置在已编组 XML 输出中的 xsi:noNamespaceSchemaLocation 属性值的属性名称。

static String

Marshaller.JAXB_SCHEMA_LOCATION
用来指定将放置在已编组 XML 输出中的 xsi:schemaLocation 属性值的属性名称。

返回 String 的 javax.xml.bind 中的方法

String

JAXBException.getErrorCode()
获取特定于供应商的错误代码。

String

TypeConstraintException.getErrorCode()
获取特定于供应商的错误代码。

String

ValidationEvent.getMessage()
检索此警告/错误的文本消息。

static String

DatatypeConverter.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

String

DatatypeConverterInterface.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

static String

DatatypeConverter.parseString(String lexicalXSDString)
将词汇 XSD 字符串参数转换为一个 String 值。

String

DatatypeConverterInterface.parseString(String lexicalXSDString)
将字符串参数转换为一个字符串。

static String

DatatypeConverter.printAnySimpleType(String val)
将字符串值转换为一个字符串。

String

DatatypeConverterInterface.printAnySimpleType(String val)
将字符串值转换为一个字符串。

static String

DatatypeConverter.printBase64Binary(byte[] val)
将字节数组转换为一个字符串。

String

DatatypeConverterInterface.printBase64Binary(byte[] val)
将字节数组转换为一个字符串。

static String

DatatypeConverter.printBoolean(boolean val)
将 boolean 值转换为一个字符串。

String

DatatypeConverterInterface.printBoolean(boolean val)
将 boolean 值转换为一个字符串。

static String

DatatypeConverter.printByte(byte val)
将 byte 值转换为一个字符串。

String

DatatypeConverterInterface.printByte(byte val)
将 byte 值转换为一个字符串。

static String

DatatypeConverter.printDate(Calendar val)
将 Calendar 值转换为一个字符串。

String

DatatypeConverterInterface.printDate(Calendar val)
将 Calendar 值转换为一个字符串。

static String

DatatypeConverter.printDateTime(Calendar val)
将 Calendar 值转换为一个字符串。

String

DatatypeConverterInterface.printDateTime(Calendar val)
将 Calendar 值转换为一个字符串。

static String

DatatypeConverter.printDecimal(BigDecimal val)
将 BigDecimal 值转换为一个字符串。

String

DatatypeConverterInterface.printDecimal(BigDecimal val)
将 BigDecimal 值转换为一个字符串。

static String

DatatypeConverter.printDouble(double val)
将 double 值转换为一个字符串。

String

DatatypeConverterInterface.printDouble(double val)
将 double 值转换为一个字符串。

static String

DatatypeConverter.printFloat(float val)
将 float 值转换为一个字符串。

String

DatatypeConverterInterface.printFloat(float val)
将 float 值转换为一个字符串。

static String

DatatypeConverter.printHexBinary(byte[] val)
将字节数组转换为一个字符串。

String

DatatypeConverterInterface.printHexBinary(byte[] val)
将字节数组转换为一个字符串。

static String

DatatypeConverter.printInt(int val)
将 int 值转换为一个字符串。

String

DatatypeConverterInterface.printInt(int val)
将 int 值转换为一个字符串。

static String

DatatypeConverter.printInteger(BigInteger val)
将 BigInteger 值转换为一个字符串。

String

DatatypeConverterInterface.printInteger(BigInteger val)
将 BigInteger 值转换为一个字符串。

static String

DatatypeConverter.printLong(long val)
将 long 值转换为一个字符串。

String

DatatypeConverterInterface.printLong(long val)
将 long 值转换为一个字符串。

static String

DatatypeConverter.printQName(QName val, NamespaceContext nsc)
将 QName 实例转换为一个字符串。

String

DatatypeConverterInterface.printQName(QName val, NamespaceContext nsc)
将 QName 实例转换为一个字符串。

static String

DatatypeConverter.printShort(short val)
将 short 值转换为一个字符串。

String

DatatypeConverterInterface.printShort(short val)
将 short 值转换为一个字符串。

static String

DatatypeConverter.printString(String val)
将字符串参数转换为一个字符串。

String

DatatypeConverterInterface.printString(String val)
将字符串参数转换为一个字符串。

static String

DatatypeConverter.printTime(Calendar val)
将 Calendar 值转换为一个字符串。

String

DatatypeConverterInterface.printTime(Calendar val)
将 Calendar 值转换为一个字符串。

static String

DatatypeConverter.printUnsignedInt(long val)
将 long 值转换为一个字符串。

String

DatatypeConverterInterface.printUnsignedInt(long val)
将 long 值转换为一个字符串。

static String

DatatypeConverter.printUnsignedShort(int val)
将 int 值转换为一个字符串。

String

DatatypeConverterInterface.printUnsignedShort(int val)
将 int 值转换为一个字符串。

String

JAXBException.toString()
返回此 JAXBException 的简短描述。

String

TypeConstraintException.toString()
返回此 TypeConstraintException 的简短描述。

参数类型为 String 的 javax.xml.bind 中的方法

abstract  Result

SchemaOutputResolver.createOutput(String namespaceUri, String suggestedFileName)
确定写入模式文件（由给定名称空间 URI 指定）的位置，并以 Result 对象的形式返回它。

abstract  Object

Binder.getProperty(String name)
获取 Binder 的基础实现中的特定属性。

Object

Marshaller.getProperty(String name)
获取 Marshaller 底层实现中的特定属性。

Object

Unmarshaller.getProperty(String name)
获取 Unmarshaller 底层实现中的特定属性。

Object

Validator.getProperty(String name)
已过时。 从 JAXB2.0 开始

static JAXBContext

JAXBContext.newInstance(String contextPath)
获得 JAXBContext 类的新实例。

static JAXBContext

JAXBContext.newInstance(String contextPath, ClassLoader classLoader)
获得 JAXBContext 类的新实例。

static JAXBContext

JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
获得 JAXBContext 类的新实例。

static String

DatatypeConverter.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

String

DatatypeConverterInterface.parseAnySimpleType(String lexicalXSDAnySimpleType)
返回包含简单类型的词汇表示形式的字符串。

static byte[]

DatatypeConverter.parseBase64Binary(String lexicalXSDBase64Binary)
将字符串参数转换为一个字节数组。

byte[]

DatatypeConverterInterface.parseBase64Binary(String lexicalXSDBase64Binary)
将字符串参数转换为一个字节数组。

static boolean

DatatypeConverter.parseBoolean(String lexicalXSDBoolean)
将字符串参数转换为一个 boolean 值。

boolean

DatatypeConverterInterface.parseBoolean(String lexicalXSDBoolean)
将字符串参数转换为一个 boolean 值。

static byte

DatatypeConverter.parseByte(String lexicalXSDByte)
将字符串参数转换为一个 byte 值。

byte

DatatypeConverterInterface.parseByte(String lexicalXSDByte)
将字符串参数转换为一个 byte 值。

static Calendar

DatatypeConverter.parseDate(String lexicalXSDDate)
将字符串参数转换为一个 Calendar 值。

Calendar

DatatypeConverterInterface.parseDate(String lexicalXSDDate)
将字符串参数转换为一个 Calendar 值。

static Calendar

DatatypeConverter.parseDateTime(String lexicalXSDDateTime)
将字符串参数转换为一个 Calendar 值。

Calendar

DatatypeConverterInterface.parseDateTime(String lexicalXSDDateTime)
将字符串参数转换为一个 Calendar 值。

static BigDecimal

DatatypeConverter.parseDecimal(String lexicalXSDDecimal)
将字符串参数转换为一个 BigDecimal 值。

BigDecimal

DatatypeConverterInterface.parseDecimal(String lexicalXSDDecimal)
将字符串参数转换为一个 BigDecimal 值。

static double

DatatypeConverter.parseDouble(String lexicalXSDDouble)
将字符串参数转换为一个 double 值。

double

DatatypeConverterInterface.parseDouble(String lexicalXSDDouble)
将字符串参数转换为一个 double 值。

static float

DatatypeConverter.parseFloat(String lexicalXSDFloat)
将字符串参数转换为一个 float 值。

float

DatatypeConverterInterface.parseFloat(String lexicalXSDFloat)
将字符串参数转换为一个 float 值。

static byte[]

DatatypeConverter.parseHexBinary(String lexicalXSDHexBinary)
将字符串参数转换为一个字节数组。

byte[]

DatatypeConverterInterface.parseHexBinary(String lexicalXSDHexBinary)
将字符串参数转换为一个字节数组。

static int

DatatypeConverter.parseInt(String lexicalXSDInt)
将字符串参数转换为一个 int 值。

int

DatatypeConverterInterface.parseInt(String lexicalXSDInt)
将字符串参数转换为一个 int 值。

static BigInteger

DatatypeConverter.parseInteger(String lexicalXSDInteger)
将字符串参数转换为一个 BigInteger 值。

BigInteger

DatatypeConverterInterface.parseInteger(String lexicalXSDInteger)
将字符串参数转换为一个 BigInteger 值。

static long

DatatypeConverter.parseLong(String lexicalXSDLong)
将字符串参数转换为一个 long 值。

long

DatatypeConverterInterface.parseLong(String lexicalXSDLong)
将字符串参数转换为一个 long 值。

static QName

DatatypeConverter.parseQName(String lexicalXSDQName, NamespaceContext nsc)
将字符串参数转换为一个 byte 值。

QName

DatatypeConverterInterface.parseQName(String lexicalXSDQName, NamespaceContext nsc)
将字符串参数转换为一个 QName 值。

static short

DatatypeConverter.parseShort(String lexicalXSDShort)
将字符串参数转换为一个 short 值。

short

DatatypeConverterInterface.parseShort(String lexicalXSDShort)
将字符串参数转换为一个 short 值。

static String

DatatypeConverter.parseString(String lexicalXSDString)
将词汇 XSD 字符串参数转换为一个 String 值。

String

DatatypeConverterInterface.parseString(String lexicalXSDString)
将字符串参数转换为一个字符串。

static Calendar

DatatypeConverter.parseTime(String lexicalXSDTime)
将字符串参数转换为一个 Calendar 值。

Calendar

DatatypeConverterInterface.parseTime(String lexicalXSDTime)
将字符串参数转换为一个 Calendar 值。

static long

DatatypeConverter.parseUnsignedInt(String lexicalXSDUnsignedInt)
将字符串参数转换为一个 long 值。

long

DatatypeConverterInterface.parseUnsignedInt(String lexicalXSDUnsignedInt)
将字符串参数转换为一个 long 值。

static int

DatatypeConverter.parseUnsignedShort(String lexicalXSDUnsignedShort)
将字符串参数转换为一个 int 值。

int

DatatypeConverterInterface.parseUnsignedShort(String lexicalXSDUnsignedShort)
将字符串参数转换为一个 int 值。

static String

DatatypeConverter.printAnySimpleType(String val)
将字符串值转换为一个字符串。

String

DatatypeConverterInterface.printAnySimpleType(String val)
将字符串值转换为一个字符串。

static String

DatatypeConverter.printString(String val)
将字符串参数转换为一个字符串。

String

DatatypeConverterInterface.printString(String val)
将字符串参数转换为一个字符串。

abstract  void

Binder.setProperty(String name, Object value)
设置 Binder 的基础实现中的特定属性。

void

Marshaller.setProperty(String name, Object value)
设置 Marshaller 底层实现中的特定属性。

void

Unmarshaller.setProperty(String name, Object value)
设置 Unmarshaller 底层实现中的特定属性。

void

Validator.setProperty(String name, Object value)
已过时。 从 JAXB2.0 开始

类型变量类型为 String 的 javax.xml.bind 中的方法参数

static JAXBContext

JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties)
获得 JAXBContext 类的新实例。

static JAXBContext

JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties)
获得 JAXBContext 类的新实例。

参数类型为 String 的 javax.xml.bind 中的构造方法

JAXBException(String message)
构造带指定详细消息的 JAXBException。

JAXBException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 JAXBException。

JAXBException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 JAXBException。

JAXBException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 JAXBException。

MarshalException(String message)
构造带指定详细消息的 MarshalException。

MarshalException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 MarshalException。

MarshalException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 MarshalException。

MarshalException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 MarshalException。

PropertyException(String message)
构造带指定详细消息的 PropertyException。

PropertyException(String name, Object value)
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。

PropertyException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 PropertyException。

PropertyException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 PropertyException。

PropertyException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 PropertyException。

TypeConstraintException(String message)
构造带指定详细消息的 TypeConstraintException。

TypeConstraintException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 TypeConstraintException。

TypeConstraintException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 TypeConstraintException。

TypeConstraintException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 TypeConstraintException。

UnmarshalException(String message)
构造带指定详细消息的 UnmarshalException。

UnmarshalException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 UnmarshalException。

UnmarshalException(String message, String errorCode, Throwable exception)
构造带指定详细消息、特定于供应商的 errorCode 和 linkedException 的 UnmarshalException。

UnmarshalException(String message, Throwable exception)
构造带指定详细消息和 linkedException 的 UnmarshalException。

ValidationException(String message)
构造带指定详细消息的 ValidationException。

ValidationException(String message, String errorCode)
构造带指定详细消息和特定于供应商的 errorCode 的 ValidationException。

ValidationException(String message, String errorCode, Throwable exception)
构造带指定的详细消息、特定于供应商的 errorCode 和 linkedException 的 ValidationException。

ValidationException(String message, Throwable exception)
构造带指定的详细消息和 linkedException 的 ValidationException。

javax.xml.bind.annotation 中 String 的使用

参数类型为 String 的 javax.xml.bind.annotation 中的方法

static XmlAccessOrder

XmlAccessOrder.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static XmlAccessType

XmlAccessType.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

static XmlNsForm

XmlNsForm.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.xml.bind.annotation.adapters 中 String 的使用

返回 String 的 javax.xml.bind.annotation.adapters 中的方法

String

HexBinaryAdapter.marshal(byte[] bytes)

String

CollapsedStringAdapter.marshal(String s)
无任何操作。

String

NormalizedStringAdapter.marshal(String s)
无任何操作。

String

CollapsedStringAdapter.unmarshal(String text)
移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。

String

NormalizedStringAdapter.unmarshal(String text)
移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。

参数类型为 String 的 javax.xml.bind.annotation.adapters 中的方法

String

CollapsedStringAdapter.marshal(String s)
无任何操作。

String

NormalizedStringAdapter.marshal(String s)
无任何操作。

String

CollapsedStringAdapter.unmarshal(String text)
移除作为参数提供的字符串的前导空白和尾部空白，然后用单个空白字符“ ”截断任何制表符、CR、LF 和 SP 序列。

byte[]

HexBinaryAdapter.unmarshal(String s)

String

NormalizedStringAdapter.unmarshal(String text)
移除作为参数给定的字符串的前导空白和尾部空白，然后用单个空白字符“ ”替换所有制表符、CR 和 LF。

javax.xml.bind.attachment 中 String 的使用

返回 String 的 javax.xml.bind.attachment 中的方法

abstract  String

AttachmentMarshaller.addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)
将用于优化二进制存储的二进制 data 作为附件。

abstract  String

AttachmentMarshaller.addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName)
将用于优化二进制存储的 MIME 内容 data 作为附件。

abstract  String

AttachmentMarshaller.addSwaRefAttachment(DataHandler data)
将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。

参数类型为 String 的 javax.xml.bind.attachment 中的方法

abstract  String

AttachmentMarshaller.addMtomAttachment(byte[] data, int offset, int length, String mimeType, String elementNamespace, String elementLocalName)
将用于优化二进制存储的二进制 data 作为附件。

abstract  String

AttachmentMarshaller.addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName)
将用于优化二进制存储的 MIME 内容 data 作为附件。

abstract  byte[]

AttachmentUnmarshaller.getAttachmentAsByteArray(String cid)
以 byte[] 形式检索由内容 id（即 cid）标识的附件。

abstract  DataHandler

AttachmentUnmarshaller.getAttachmentAsDataHandler(String cid)
通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。

javax.xml.bind.helpers 中 String 的使用

返回 String 的 javax.xml.bind.helpers 中的方法

protected  String

AbstractMarshallerImpl.getEncoding()
获取当前输出编码的便捷方法。

protected  String

AbstractMarshallerImpl.getJavaEncoding(String encoding)
从 IANA 名称获取相应的 Java 编码名称。

String

ValidationEventImpl.getMessage()

protected  String

AbstractMarshallerImpl.getNoNSSchemaLocation()
获取当前 noNamespaceSchemaLocation 的便捷方法。

protected  String

AbstractMarshallerImpl.getSchemaLocation()
获取当前 schemaLocation 的便捷方法。

String

ValidationEventImpl.toString()
以有助于调试的格式返回此对象的字符串表示形式。

String

ValidationEventLocatorImpl.toString()
以有助于调试的格式返回此对象的字符串表示形式。

参数类型为 String 的 javax.xml.bind.helpers 中的方法

protected  String

AbstractMarshallerImpl.getJavaEncoding(String encoding)
从 IANA 名称获取相应的 Java 编码名称。

Object

AbstractMarshallerImpl.getProperty(String name)
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

Object

AbstractUnmarshallerImpl.getProperty(String name)
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。

protected  void

AbstractMarshallerImpl.setEncoding(String encoding)
设置输出编码的便捷方法。

void

ValidationEventImpl.setMessage(String _message)
设置此事件的 message 字段。

protected  void

AbstractMarshallerImpl.setNoNSSchemaLocation(String location)
设置 noNamespaceSchemaLocation 的便捷方法。

void

AbstractMarshallerImpl.setProperty(String name, Object value)
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

void

AbstractUnmarshallerImpl.setProperty(String name, Object value)
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。

protected  void

AbstractMarshallerImpl.setSchemaLocation(String location)
设置 schemaLocation 的便捷方法。

参数类型为 String 的 javax.xml.bind.helpers 中的构造方法

NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 NotIdentifiableEventImpl。

NotIdentifiableEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 NotIdentifiableEventImpl。

ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ParseConversionEventImpl。

ParseConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ParseConversionEventImpl。

PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 PrintConversionEventImpl。

PrintConversionEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 PrintConversionEventImpl。

ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator)
创建新的 ValidationEventImpl。

ValidationEventImpl(int _severity, String _message, ValidationEventLocator _locator, Throwable _linkedException)
创建新的 ValidationEventImpl。

javax.xml.crypto 中 String 的使用

返回 String 的 javax.xml.crypto 中的方法

String

AlgorithmMethod.getAlgorithm()
返回此 AlgorithmMethod 的算法 URI。

String

XMLCryptoContext.getBaseURI()
返回基本 URI。

String

XMLCryptoContext.getDefaultNamespacePrefix()
返回默认名称空间前缀。

String

OctetStreamData.getMimeType()
返回与由此 OctetStreamData 表示的数据对象关联的 MIME 类型。

String

XMLCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
返回与指定的名称空间 URI 关联的名称空间前缀。

String

URIReference.getType()
返回通过此 URI 引用的数据类型。

String

OctetStreamData.getURI()
返回用来标识由此 OctetStreamData 表示的数据对象的 URI String。

String

URIReference.getURI()
返回所引用数据对象的 URI。

String

XMLCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
将指定的名称空间 URI 映射到指定的前缀。

String

KeySelector.Purpose.toString()
返回此用途的字符串表示形式（“sign”、“verify”、“encrypt”或“decrypt”）。

参数类型为 String 的 javax.xml.crypto 中的方法

String

XMLCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
返回与指定的名称空间 URI 关联的名称空间前缀。

Object

XMLCryptoContext.getProperty(String name)
返回指定属性的值。

boolean

XMLStructure.isFeatureSupported(String feature)
指示是否支持指定的功能。

String

XMLCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
将指定的名称空间 URI 映射到指定的前缀。

void

XMLCryptoContext.setBaseURI(String baseURI)
设置基本 URI。

void

XMLCryptoContext.setDefaultNamespacePrefix(String defaultPrefix)
设置默认的名称空间前缀。

Object

XMLCryptoContext.setProperty(String name, Object value)
设置指定的属性。

参数类型为 String 的 javax.xml.crypto 中的构造方法

KeySelectorException(String message)
构造带指定详细信息的新 KeySelectorException。

KeySelectorException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 KeySelectorException。

MarshalException(String message)
构造带指定详细消息的新 MarshalException。

MarshalException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 MarshalException。

NoSuchMechanismException(String message)
构造带指定详细消息的新 NoSuchMechanismException。

NoSuchMechanismException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 NoSuchMechanismException。

OctetStreamData(InputStream octetStream, String uri, String mimeType)
创建新的 OctetStreamData。

URIReferenceException(String message)
构造带指定详细消息的新 URIReferenceException。

URIReferenceException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 URIReferenceException。

URIReferenceException(String message, Throwable cause, URIReference uriReference)
构造带指定详细消息、cause 和 URIReference 的新 URIReferenceException。

javax.xml.crypto.dom 中 String 的使用

返回 String 的 javax.xml.crypto.dom 中的方法

String

DOMCryptoContext.getBaseURI()

String

DOMCryptoContext.getDefaultNamespacePrefix()

String

DOMCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。

String

DOMCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
此实现使用内部 HashMap 将 URI 映射到指定的前缀。

参数类型为 String 的 javax.xml.crypto.dom 中的方法

Element

DOMCryptoContext.getElementById(String idValue)
返回具有指定 ID 属性值的 Element。

String

DOMCryptoContext.getNamespacePrefix(String namespaceURI, String defaultPrefix)
此实现使用内部 HashMap 来获取指定 URI 所映射的前缀。

Object

DOMCryptoContext.getProperty(String name)
此实现使用内部 HashMap 获取指定名称所映射的对象。

boolean

DOMStructure.isFeatureSupported(String feature)

String

DOMCryptoContext.putNamespacePrefix(String namespaceURI, String prefix)
此实现使用内部 HashMap 将 URI 映射到指定的前缀。

void

DOMCryptoContext.setBaseURI(String baseURI)

void

DOMCryptoContext.setDefaultNamespacePrefix(String defaultPrefix)

void

DOMCryptoContext.setIdAttributeNS(Element element, String namespaceURI, String localName)
将名称空间 URI 和本地名称指定的元素属性注册为类型 ID。

Object

DOMCryptoContext.setProperty(String name, Object value)
此实现使用内部 HashMap 将名称映射到指定对象。

javax.xml.crypto.dsig 中 String 的使用

声明为 String 的 javax.xml.crypto.dsig 中的字段

static String

Transform.BASE64
Base64 转换算法 URI。

static String

SignatureMethod.DSA_SHA1
DSAwithSHA1 (DSS) 签名方法的算法 URI。

static String

Transform.ENVELOPED
Enveloped Signature 转换算法 URI。

static String

CanonicalizationMethod.EXCLUSIVE
Exclusive Canonical XML（不带注释）规范化方法的算法 URI。

static String

CanonicalizationMethod.EXCLUSIVE_WITH_COMMENTS
带注释的 Exclusive Canonical XML 规范化方法的算法 URI。

static String

SignatureMethod.HMAC_SHA1
HMAC-SHA1 MAC 签名方法的算法 URI。

static String

CanonicalizationMethod.INCLUSIVE
Canonical XML（不带注释）的规范化方法的算法 URI。

static String

CanonicalizationMethod.INCLUSIVE_WITH_COMMENTS
带注释的 Canonical XML 的规范化方法的算法 URI。

static String

DigestMethod.RIPEMD160
RIPEMD-160 摘要方法的算法 URI。

static String

SignatureMethod.RSA_SHA1
RSAwithSHA1 (PKCS #1) 签名方法的算法 URI。

static String

DigestMethod.SHA1
SHA1 摘要方法的算法 URI。

static String

DigestMethod.SHA256
SHA256 摘要方法的算法 URI。

static String

DigestMethod.SHA512
SHA512 摘要方法的算法 URI。

static String

Manifest.TYPE
标识 Manifest 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

static String

SignatureProperties.TYPE
标识 SignatureProperties 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

static String

XMLObject.TYPE
标识 Object 元素的 URI（可以将其指定为 Reference 类的 type 参数值，以标识引用的类型）。

static String

XMLSignature.XMLNS
W3C Recommendation for XML-Signature Syntax and Processing 的 XML 名称空间 URI。

static String

Transform.XPATH
XPath 转换算法 URI。

static String

Transform.XPATH2
XPath Filter 2 转换算法 URI。

static String

Transform.XSLT
XSLT 转换算法 URI。

返回 String 的 javax.xml.crypto.dsig 中的方法

String

TransformService.getAlgorithm()
返回此 TransformService 支持的算法 URI。

String

XMLObject.getEncoding()
返回此 XMLObject 的编码 URI。

String

Manifest.getId()
返回此 Manifest 的 Id。

String

Reference.getId()
返回此 Reference 的可选 Id 属性，该属性允许从其他地方引用此 Reference。

String

SignatureProperties.getId()
返回此 SignatureProperties 的 Id。

String

SignatureProperty.getId()
返回此 SignatureProperty 的 Id。

String

SignedInfo.getId()
返回此 SignedInfo 的可选 Id 属性。

String

XMLObject.getId()
返回此 XMLObject 的 Id。

String

XMLSignature.getId()
返回此 XMLSignature 的可选 Id。

String

XMLSignature.SignatureValue.getId()
返回此 SignatureValue 的可选 Id 属性，该属性允许从其他地方引用此元素。

String

TransformService.getMechanismType()
返回此 TransformService 支持的机制类型。

String

XMLSignatureFactory.getMechanismType()
返回此 XMLSignatureFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。

String

XMLObject.getMimeType()
返回此 XMLObject 的 MIME 类型。

String

SignatureProperty.getTarget()
返回此 SignatureProperty 的目标 URI。

参数类型为 String 的 javax.xml.crypto.dsig 中的方法

static XMLSignatureFactory

XMLSignatureFactory.getInstance(String mechanismType)
返回 XMLSignatureFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。

static XMLSignatureFactory

XMLSignatureFactory.getInstance(String mechanismType, Provider provider)
返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。

static TransformService

TransformService.getInstance(String algorithm, String mechanismType)
返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。

static XMLSignatureFactory

XMLSignatureFactory.getInstance(String mechanismType, String provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。

static TransformService

TransformService.getInstance(String algorithm, String mechanismType, Provider provider)
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

static TransformService

TransformService.getInstance(String algorithm, String mechanismType, String provider)
返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

abstract  boolean

XMLSignatureFactory.isFeatureSupported(String feature)
指示是否支持指定的功能。

abstract  CanonicalizationMethod

XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params)
针对指定的算法 URI 和参数创建 CanonicalizationMethod。

abstract  CanonicalizationMethod

XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params)
针对指定的算法 URI 和参数创建 CanonicalizationMethod。

abstract  DigestMethod

XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params)
针对指定的算法 URI 和参数创建 DigestMethod。

abstract  Manifest

XMLSignatureFactory.newManifest(List references, String id)
创建包含指定的 Reference 列表和可选 id 的 Manifest。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm)
创建带指定 URI 和摘要方法的 Reference。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id)
创建带指定参数的 Reference。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id)
创建带指定参数的 Reference。

abstract  Reference

XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue)
创建带指定参数和预计算的摘要值的 Reference。

abstract  SignatureMethod

XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params)
针对指定的算法 URI 和参数创建 SignatureMethod。

abstract  SignatureProperties

XMLSignatureFactory.newSignatureProperties(List properties, String id)
创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。

abstract  SignatureProperty

XMLSignatureFactory.newSignatureProperty(List content, String target, String id)
创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。

abstract  SignedInfo

XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id)
创建带指定参数的 SignedInfo。

abstract  Transform

XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params)
针对指定的算法 URI 和参数创建 Transform。

abstract  Transform

XMLSignatureFactory.newTransform(String algorithm, XMLStructure params)
针对指定的算法 URI 和参数创建 Transform。

abstract  XMLObject

XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding)
根据指定参数创建 XMLObject。

abstract  XMLSignature

XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId)
创建一个 XMLSignature，并使用指定的参数对其进行初始化。

参数类型为 String 的 javax.xml.crypto.dsig 中的构造方法

TransformException(String message)
构造带有指定详细消息的新 TransformException。

TransformException(String message, Throwable cause)
构造带指定详细消息和 cause 的新 TransformException。

XMLSignatureException(String message)
构造带指定详细消息的新 XMLSignatureException。

XMLSignatureException(String message, Throwable cause)
构造一个带指定详细消息和 cause 的新 XMLSignatureException。

javax.xml.crypto.dsig.keyinfo 中 String 的使用

声明为 String 的 javax.xml.crypto.dsig.keyinfo 中的字段

static String

KeyValue.DSA_TYPE
标识 DSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#DSAKeyValue。

static String

X509Data.RAW_X509_CERTIFICATE_TYPE
标识二进制 (ASN.1 DER) X.509 Certificate KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#rawX509Certificate。

static String

KeyValue.RSA_TYPE
标识 RSA KeyValue KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#RSAKeyValue。

static String

PGPData.TYPE
标识 PGPData KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#PGPData.可以将其指定为 RetrievalMethod 类的 type 参数值，以描述远程 PGPData 结构。

static String

X509Data.TYPE
标识 X509Data KeyInfo 类型的 URI：http://www.w3.org/2000/09/xmldsig#X509Data。

返回 String 的 javax.xml.crypto.dsig.keyinfo 中的方法

String

KeyInfo.getId()
返回此 KeyInfo 的可选 Id 属性，这对于从其他 XML 结构引用此 KeyInfo 可能很有用。

String

X509IssuerSerial.getIssuerName()
返回 RFC 2253 String 格式的此 X509IssuerSerial 的 X.500 标识名。

String

KeyInfoFactory.getMechanismType()
返回此 KeyInfoFactory 支持的 XML 处理机制类型和表示形式类型（比如：“DOM”）。

String

KeyName.getName()
返回此 KeyName 的名称。

String

RetrievalMethod.getURI()
返回已引用的 KeyInfo 信息的 URI。

参数类型为 String 的 javax.xml.crypto.dsig.keyinfo 中的方法

static KeyInfoFactory

KeyInfoFactory.getInstance(String mechanismType)
返回 KeyInfoFactory，它支持指定的 XML 处理机制和表示形式类型（比如：“DOM”）。

static KeyInfoFactory

KeyInfoFactory.getInstance(String mechanismType, Provider provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

static KeyInfoFactory

KeyInfoFactory.getInstance(String mechanismType, String provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

abstract  boolean

KeyInfoFactory.isFeatureSupported(String feature)
指示是否支持指定的功能。

abstract  KeyInfo

KeyInfoFactory.newKeyInfo(List content, String id)
创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。

abstract  KeyName

KeyInfoFactory.newKeyName(String name)
根据指定的名称创建 KeyName。

abstract  RetrievalMethod

KeyInfoFactory.newRetrievalMethod(String uri)
根据指定的 URI 创建 RetrievalMethod。

abstract  RetrievalMethod

KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms)
根据指定的参数创建 RetrievalMethod。

abstract  X509IssuerSerial

KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。

javax.xml.crypto.dsig.spec 中 String 的使用

声明为 String 的 javax.xml.crypto.dsig.spec 中的字段

static String

ExcC14NParameterSpec.DEFAULT
指示默认名称空间（“#default”）。

返回 String 的 javax.xml.crypto.dsig.spec 中的方法

String

XPathType.getExpression()
返回要计算的 XPath 表达式。

String

XPathFilterParameterSpec.getXPath()
返回要计算的 XPath 表达式。

String

XPathType.Filter.toString()
返回操作的字符串形式。

参数类型为 String 的 javax.xml.crypto.dsig.spec 中的构造方法

XPathFilterParameterSpec(String xPath)
创建带有指定 XPath 表达式的 XPathFilterParameterSpec。

XPathFilterParameterSpec(String xPath, Map namespaceMap)
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。

XPathType(String expression, XPathType.Filter filter)
创建带有指定 XPath 表达式和过滤器的 XPathType 实例。

XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。

javax.xml.datatype 中 String 的使用

声明为 String 的 javax.xml.datatype 中的字段

static String

DatatypeFactory.DATATYPEFACTORY_IMPLEMENTATION_CLASS
JSR 206: Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。

static String

DatatypeFactory.DATATYPEFACTORY_PROPERTY
JSR 206:Java(TM) API for XML Processing (JAXP) 1.3 中定义的默认实现类名称。

返回 String 的 javax.xml.datatype 中的方法

String

DatatypeConstants.Field.toString()
以英文返回字段名称。

String

Duration.toString()
返回此 Duration Object 的 String 表示形式。

String

XMLGregorianCalendar.toString()
返回此 XMLGregorianCalendar Object 的 String 表示形式。

abstract  String

XMLGregorianCalendar.toXMLFormat()
返回 this 实例的词汇表示形式。

参数类型为 String 的 javax.xml.datatype 中的方法

abstract  Duration

DatatypeFactory.newDuration(String lexicalRepresentation)
获取新的 Duration 实例，它根据 XML 模式 1.0 第 3.2.6.1 节中的定义将 Duration 指定为其字符串表示形式 "PnYnMnDTnHnMnS"。

Duration

DatatypeFactory.newDurationDayTime(String lexicalRepresentation)
通过解析其 String 表示形式 "PnDTnHnMnS"（XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration）创建类型为 xdt:dayTimeDuration 的 Duration。

Duration

DatatypeFactory.newDurationYearMonth(String lexicalRepresentation)
通过解析其 String 表示形式 "PnYnM"（XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration）创建类型为 xdt:yearMonthDuration 的 Duration。

static DatatypeFactory

DatatypeFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 DatatypeFactory 实例。

abstract  XMLGregorianCalendar

DatatypeFactory.newXMLGregorianCalendar(String lexicalRepresentation)
通过将字符串解析为词汇表示形式，创建新的 XMLGregorianCalendar。

参数类型为 String 的 javax.xml.datatype 中的构造方法

DatatypeConfigurationException(String message)
创建带指定详细消息的新 DatatypeConfigurationException。

DatatypeConfigurationException(String message, Throwable cause)
创建带有指定详细消息和原因的新 DatatypeConfigurationException。

javax.xml.namespace 中 String 的使用

返回 String 的 javax.xml.namespace 中的方法

String

QName.getLocalPart()
获取此 QName 的本地部分。

String

QName.getNamespaceURI()
获取此 QName 的名称空间 URI。

String

NamespaceContext.getNamespaceURI(String prefix)
获取绑定到当前范围中的前缀的名称空间 URI。

String

QName.getPrefix()
获取此 QName 的前缀。

String

NamespaceContext.getPrefix(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的前缀。

String

QName.toString()
此 QName 的 String 表示形式。

参数类型为 String 的 javax.xml.namespace 中的方法

String

NamespaceContext.getNamespaceURI(String prefix)
获取绑定到当前范围中的前缀的名称空间 URI。

String

NamespaceContext.getPrefix(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的前缀。

Iterator

NamespaceContext.getPrefixes(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的所有前缀。

static QName

QName.valueOf(String qNameAsString)
从解析格式化 String 中派生的 QName。

参数类型为 String 的 javax.xml.namespace 中的构造方法

QName(String localPart)
指定本地部分的 QName 构造方法。

QName(String namespaceURI, String localPart)
指定名称空间 URI 和本地部分的 QName 构造方法。

QName(String namespaceURI, String localPart, String prefix)
指定名称空间 URI、本地部分和前缀的 QName 构造方法。

javax.xml.parsers 中 String 的使用

返回 String 的 javax.xml.parsers 中的方法

String

FactoryConfigurationError.getMessage()
返回此错误的消息（如果有）。

参数类型为 String 的 javax.xml.parsers 中的方法

abstract  Object

DocumentBuilderFactory.getAttribute(String name)
允许用户在底层实现上检索特定属性。

abstract  boolean

SAXParserFactory.getFeature(String name)
返回 org.xml.sax.XMLReader 的底层实现中请求的特定属性。

abstract  boolean

DocumentBuilderFactory.getFeature(String name)
获取指定功能的状态。

abstract  Object

SAXParser.getProperty(String name)
返回 XMLReader 的底层实现中请求的特定属性。

static SAXParserFactory

SAXParserFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 SAXParserFactory 实例。

static DocumentBuilderFactory

DocumentBuilderFactory.newInstance(String factoryClassName, ClassLoader classLoader)
从类名称中获取新的 DocumentBuilderFactory 实例。

void

SAXParser.parse(InputStream is, DefaultHandler dh, String systemId)
使用指定的 DefaultHandler 将给定的 InputStream 实例的内容解析为 XML。

void

SAXParser.parse(InputStream is, HandlerBase hb, String systemId)
使用指定的 HandlerBase 将给定的 InputStream 实例的内容解析为 XML。

Document

DocumentBuilder.parse(InputStream is, String systemId)
将给定 InputStream 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

Document

DocumentBuilder.parse(String uri)
将给定 URI 的内容解析为一个 XML 文档，并且返回一个新的 DOM Document 对象。

void

SAXParser.parse(String uri, DefaultHandler dh)
使用指定的 DefaultHandler 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

void

SAXParser.parse(String uri, HandlerBase hb)
使用指定的 HandlerBase 将给定统一资源标识符 (URI) 描述的内容解析为 XML。

abstract  void

DocumentBuilderFactory.setAttribute(String name, Object value)
允许用户在底层实现上设置特定属性。

abstract  void

SAXParserFactory.setFeature(String name, boolean value)
在 org.xml.sax.XMLReader 的底层实现中设置特定的功能。

abstract  void

DocumentBuilderFactory.setFeature(String name, boolean value)
设置由此工厂创建的此 DocumentBuilderFactory 和 DocumentBuilder 的功能。

abstract  void

SAXParser.setProperty(String name, Object value)
设置 XMLReader 的底层实现中的特定属性。

参数类型为 String 的 javax.xml.parsers 中的构造方法

FactoryConfigurationError(Exception e, String msg)
使用给定 Exception 的基本原因和详细消息创建一个新的 FactoryConfigurationError。

FactoryConfigurationError(String msg)
创建一个新的 FactoryConfigurationError，并将 String 指定为一个错误消息。

ParserConfigurationException(String msg)
创建一个新的 ParserConfigurationException，并将 String 指定为一个错误消息。

javax.xml.soap 中 String 的使用

声明为 String 的 javax.xml.soap 中的字段

static String

SOAPMessage.CHARACTER_SET_ENCODING
指定 SOAP Message 的字符类型编码。

static String

SOAPConstants.DEFAULT_SOAP_PROTOCOL
默认协议：向后兼容的 SOAP 1.1。

static String

SOAPConstants.DYNAMIC_SOAP_PROTOCOL
用于创建 MessageFactory 实例，该实例可创建 SOAPMessages，SOAPMessages 的具体类型取决于传递给 createMessage 方法的 Content-Type MIME 头。

static String

SOAPConstants.SOAP_1_1_CONTENT_TYPE
SOAP 1.1 中 Content-Type MIME 头的媒体类型。

static String

SOAPConstants.SOAP_1_1_PROTOCOL
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.1 规范的 SOAPMessages。

static String

SOAPConstants.SOAP_1_2_CONTENT_TYPE
SOAP 1.2 中 Content-Type MIME 头的媒体类型。

static String

SOAPConstants.SOAP_1_2_PROTOCOL
用于创建 MessageFactory 实例，该实例创建其行为支持 SOAP 1.2 规范的 SOAPMessages

static String

SOAPConstants.SOAP_ENV_PREFIX
http://www.w3.org/2003/05/soap-envelope 的默认名称空间前缀。

static String

SOAPConstants.URI_NS_SOAP_1_1_ENVELOPE
SOAP 1.1 信封的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_1_2_ENCODING
SOAP 1.2 编码的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_1_2_ENVELOPE
SOAP 1.2 信封的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_ENCODING
SOAP 1.1 编码的名称空间标识符。

static String

SOAPConstants.URI_NS_SOAP_ENVELOPE
SOAP 1.1 信封的名称空间标识符，此名称空间中的所有 SOAPElements 是由 SOAP 1.1 规范定义的。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_NEXT
该 URI 标识将 SOAP 请求处理为 SOAP 1.2 头条目预定角色 (intended role) 的下一个应用程序（请参阅 SOAP 1.2 规范第 1 部分第 2.2 节）。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_NONE
该 URI 指定 SOAP 1.2 中的角色 None。

static String

SOAPConstants.URI_SOAP_1_2_ROLE_ULTIMATE_RECEIVER
该 URI 标识 SOAP 1.2 消息的最终接收者。

static String

SOAPConstants.URI_SOAP_ACTOR_NEXT
该 URI 标识将 SOAP 请求处理为 SOAP 1.1 头条目预定参与者的下一个应用程序（请参阅 SOAP 1.1 规范的第 4.2.2 节）。

static String

SOAPMessage.WRITE_XML_DECLARATION
指定 SOAP Message 在发送时是否包含 XML 声明。

返回 String 的 javax.xml.soap 中的方法

String

SOAPHeaderElement.getActor()
返回此 SOAPHeaderElement actor 属性的 URL。

String

SOAPElement.getAttributeValue(Name name)
返回带有指定名称的属性值。

String

SOAPElement.getAttributeValue(QName qname)
返回带有指定 qname 的属性值。

abstract  String

SOAPMessage.getContentDescription()
检索此 SOAPMessage 对象内容的描述。

String

AttachmentPart.getContentId()
获取名为 "Content-ID" 的 MIME 头的值。

String

SOAPPart.getContentId()
检索名为 "Content-Id" 的 MIME 头的值。

String

AttachmentPart.getContentLocation()
获取名为 "Content-Location" 的 MIME 头的值。

String

SOAPPart.getContentLocation()
检索名为 "Content-Location" 的 MIME 头的值。

String

AttachmentPart.getContentType()
获取名为 "Content-Type" 的 MIME 头的值。

String

SOAPElement.getEncodingStyle()
返回此 SOAPElement 对象的编码样式。

String

SOAPFault.getFaultActor()
获取此 SOAPFault 对象的错误参与者。

String

SOAPFault.getFaultCode()
获取此 SOAPFault 对象的错误代码。

String

SOAPFault.getFaultNode()
返回此 SOAPFault 对象的可选 Node 元素值。

String

SOAPFault.getFaultReasonText(Locale locale)
返回与给定 Locale 关联的 Reason Text。

String

SOAPFault.getFaultRole()
返回此 SOAPFault 对象的可选 Role 元素值。

String

SOAPFault.getFaultString()
获取此 SOAPFault 对象的错误字符串。

String[]

MimeHeaders.getHeader(String name)
以 String 对象数组的形式返回指定头的所有值。

String

Name.getLocalName()
获取此 Name 对象表示的 XML 名称的本地名称部分。

String

SOAPException.getMessage()
返回此 SOAPException 对象的详细消息。

abstract  String[]

AttachmentPart.getMimeHeader(String name)
获取给定 String 所标识的头的所有值。

abstract  String[]

SOAPPart.getMimeHeader(String name)
获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。

String

MimeHeader.getName()
返回此 MimeHeader 对象的名称。

String

SOAPElement.getNamespaceURI(String prefix)
返回带有给定前缀的名称空间的 URI。

String

Name.getPrefix()
返回初始化此 Name 对象时指定的前缀。

String

Name.getQualifiedName()
获取此 Name 对象表示的 XML 名称限定于命名空间的名称。

String

SOAPHeaderElement.getRole()
返回此 SOAPHeaderElement Role 属性的值。

String

Name.getURI()
返回此 Name 对象表示的 XML 名称命名空间的 URI。

String

MimeHeader.getValue()
返回此 MimeHeader 对象的值。

String

Node.getValue()
如果这是一个 Text 节点，则返回此节点的值，否则返回此节点的直接子节点值。

参数类型为 String 的 javax.xml.soap 中的方法

SOAPElement

SOAPElement.addAttribute(Name name, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addAttribute(QName qname, String value)
将带有指定名称和值的属性添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addChildElement(String localName)
创建使用指定本地名称初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addChildElement(String localName, String prefix)
创建使用指定本地名称和前缀初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addChildElement(String localName, String prefix, String uri)
创建使用指定本地名称、前缀和 URI 初始化的新 SOAPElement 对象，并将该新元素添加到此 SOAPElement 对象。

SOAPFault

SOAPBody.addFault(Name faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

SOAPFault

SOAPBody.addFault(Name faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

SOAPFault

SOAPBody.addFault(QName faultCode, String faultString)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

SOAPFault

SOAPBody.addFault(QName faultCode, String faultString, Locale locale)
创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。

void

SOAPFault.addFaultReasonText(String text, Locale locale)
追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。

void

MimeHeaders.addHeader(String name, String value)
将带有指定名称和值的 MimeHeader 对象添加到此 MimeHeaders 对象的头列表。

abstract  void

AttachmentPart.addMimeHeader(String name, String value)
将带有指定名称和值的 MIME 头添加到此 AttachmentPart 对象。

abstract  void

SOAPPart.addMimeHeader(String name, String value)
使用指定名称和值创建 MimeHeader 对象，并将其添加到此 SOAPPart 对象。

SOAPElement

SOAPElement.addNamespaceDeclaration(String prefix, String uri)
将带有指定前缀和 URI 的名称空间声明添加到此 SOAPElement 对象。

SOAPElement

SOAPElement.addTextNode(String text)
创建使用给定 String 初始化的新 Text 对象，并将其添加到此 SOAPElement 对象。

SOAPHeaderElement

SOAPHeader.addUpgradeHeaderElement(String supportedSoapUri)
创建使用指定受支持 SOAP URI 初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

SOAPHeaderElement

SOAPHeader.addUpgradeHeaderElement(String[] supportedSoapUris)
创建使用指定 SOAP URI 支持数组初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

SOAPElement

SOAPElementFactory.create(String localName)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName) 替换

SOAPElement

SOAPElementFactory.create(String localName, String prefix, String uri)
已过时。 使用 javax.xml.soap.SOAPFactory.createElement(String localName, String prefix, String uri) 替换

AttachmentPart

SOAPMessage.createAttachmentPart(Object content, String contentType)
创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。

abstract  SOAPElement

SOAPFactory.createElement(String localName)
创建使用给定本地名称初始化的 SOAPElement 对象。

abstract  SOAPElement

SOAPFactory.createElement(String localName, String prefix, String uri)
使用本地名称、前缀和 URI 创建新的 SOAPElement 对象。

abstract  SOAPFault

SOAPFactory.createFault(String reasonText, QName faultCode)
创建使用给定 reasonText 和 faultCode 初始化的新 SOAPFault 对象

Name

SOAPEnvelope.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。

abstract  Name

SOAPFactory.createName(String localName)
创建使用给定本地名称初始化的新 Name 对象。

Name

SOAPEnvelope.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URL 初始化的新 Name 对象。

abstract  Name

SOAPFactory.createName(String localName, String prefix, String uri)
创建使用给定本地名称、名称空间前缀和名称空间 URI 初始化的新 Name 对象。

QName

SOAPElement.createQName(String localName, String prefix)
创建一个 QName，其名称空间 URI 应与此 SOAPElement 上下文中的参数、prefix 相关联。

Iterator

SOAPHeader.examineHeaderElements(String actor)
返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。

Iterator

SOAPHeader.examineMustUnderstandHeaderElements(String actor)
返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。

Iterator

SOAPHeader.extractHeaderElements(String actor)
返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。

String[]

MimeHeaders.getHeader(String name)
以 String 对象数组的形式返回指定头的所有值。

Iterator

MimeHeaders.getMatchingHeaders(String[] names)
返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。

abstract  Iterator

AttachmentPart.getMatchingMimeHeaders(String[] names)
检索匹配给定数组中名称的所有 MimeHeader 对象。

abstract  Iterator

SOAPPart.getMatchingMimeHeaders(String[] names)
检索与给定数组中的名称匹配的所有 MimeHeader 对象。

abstract  String[]

AttachmentPart.getMimeHeader(String name)
获取给定 String 所标识的头的所有值。

abstract  String[]

SOAPPart.getMimeHeader(String name)
获取此 SOAPPart 对象中所有由给定 String 标识的 MimeHeader 对象的值。

String

SOAPElement.getNamespaceURI(String prefix)
返回带有给定前缀的名称空间的 URI。

Iterator

MimeHeaders.getNonMatchingHeaders(String[] names)
返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。

abstract  Iterator

AttachmentPart.getNonMatchingMimeHeaders(String[] names)
检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。

abstract  Iterator

SOAPPart.getNonMatchingMimeHeaders(String[] names)
检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。

Object

SOAPMessage.getProperty(String property)
检索指定属性的值。

static MessageFactory

MessageFactory.newInstance(String protocol)
创建新的 MessageFactory 对象，该对象是指定实现的实例。

static SOAPFactory

SOAPFactory.newInstance(String protocol)
创建新的 SOAPFactory 对象，该对象是指定实现的实例，此方法使用 SAAJMetaFactory 来定位实现类并创建 SOAPFactory 实例。

protected abstract  MessageFactory

SAAJMetaFactory.newMessageFactory(String protocol)
创建给定 String 协议的 MessageFactory 对象。

protected abstract  SOAPFactory

SAAJMetaFactory.newSOAPFactory(String protocol)
创建给定 String 协议的 SOAPFactory 对象。

void

MimeHeaders.removeHeader(String name)
移除其名称与给定名称匹配的所有 MimeHeader 对象。

abstract  void

AttachmentPart.removeMimeHeader(String header)
移除匹配给定名称的所有 MIME 头。

abstract  void

SOAPPart.removeMimeHeader(String header)
移除所有与给定名称匹配的 MIME 头。

boolean

SOAPElement.removeNamespaceDeclaration(String prefix)
移除对应于给定前缀的名称空间声明。

void

SOAPHeaderElement.setActor(String actorURI)
将与此 SOAPHeaderElement 对象关联的 actor 设置为指定 actor。

abstract  void

AttachmentPart.setBase64Content(InputStream content, String contentType)
根据 Base64 源 InputStream 设置此附件部分的内容，并将 Content-Type 头的值设置为 contentType 中包含的值，此方法将首先对 base64 输入流进行解码，然后将得到的原始字节写入附件。

abstract  void

AttachmentPart.setContent(Object object, String contentType)
将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。

abstract  void

SOAPMessage.setContentDescription(String description)
使用给定描述设置此 SOAPMessage 对象内容的描述。

void

AttachmentPart.setContentId(String contentId)
使用给定值设置名为 "Content-ID" 的 MIME 头。

void

SOAPPart.setContentId(String contentId)
将名为 "Content-Id" 的 MIME 头的值设置为给定 String。

void

AttachmentPart.setContentLocation(String contentLocation)
使用给定值设置名为 "Content-Location" 的 MIME 头。

void

SOAPPart.setContentLocation(String contentLocation)
将 MIME 头 "Content-Location" 的值设置为给定 String。

void

AttachmentPart.setContentType(String contentType)
使用给定值设置名为 "Content-Type" 的 MIME 头。

void

SOAPElement.setEncodingStyle(String encodingStyle)
将此 SOAPElement 对象的编码样式设置为指定样式。

void

SOAPFault.setFaultActor(String faultActor)
使用给定的错误参与者 (actor) 设置此 SOAPFault 对象。

void

SOAPFault.setFaultCode(String faultCode)
使用给定的错误代码设置此 SOAPFault 对象。

void

SOAPFault.setFaultNode(String uri)
创建或替换此 SOAPFault 对象的任何现有 Node 元素。

void

SOAPFault.setFaultRole(String uri)
创建或替换此 SOAPFault 对象的任何现有 Role 元素。

void

SOAPFault.setFaultString(String faultString)
将此 SOAPFault 对象的错误字符串设定为给定字符串。

void

SOAPFault.setFaultString(String faultString, Locale locale)
将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。

void

MimeHeaders.setHeader(String name, String value)
将其名称与给定名称匹配的第一个头条目的当前值替换为给定值，如果现有的头名称都不匹配，则添加一个新的头。

abstract  void

AttachmentPart.setMimeHeader(String name, String value)
将匹配给定名称的第一个头条目的值更改为给定值，如果现有的头都不匹配，则添加一个新的头。

abstract  void

SOAPPart.setMimeHeader(String name, String value)
将与给定头名称匹配的第一个头条目的值更改为给定值，如果现有头都不匹配，则添加一个带有给定名称和值的新头。

void

SOAPMessage.setProperty(String property, Object value)
将指定值与指定属性关联。

abstract  void

AttachmentPart.setRawContent(InputStream content, String contentType)
将此附件部分的内容设置为 InputStream content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

abstract  void

AttachmentPart.setRawContentBytes(byte[] content, int offset, int len, String contentType)
将此附件部分的内容设置为 byte[] 数组 content 所包含的内容，并将 Content-Type 头的值设置为 contentType 中包含的值。

void

SOAPHeaderElement.setRole(String uri)
将与此 SOAPHeaderElement 对象关联的 Role 设置为指定 Role。

void

Node.setValue(String value)
如果这是一个 Text 节点，则此方法会设置它的值，否则该方法设置此节点的直接 (Text) 子节点值。

参数类型为 String 的 javax.xml.soap 中的构造方法

MimeHeader(String name, String value)
构造使用给定的名称和值初始化的 MimeHeader 对象。

SAAJResult(String protocol)
创建一个 SAAJResult，它将以支持指定协议的 SAAJ 树的形式显示结果。

SOAPException(String reason)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因。

SOAPException(String reason, Throwable cause)
构造一个 SOAPException 对象，使用给定 String 作为抛出异常的原因，使用给定 Throwable 对象作为嵌入的异常。

javax.xml.stream 中 String 的使用

声明为 String 的 javax.xml.stream 中的字段

static String

XMLInputFactory.ALLOCATOR
用于设置/获取分配器实现的属性。

static String

XMLInputFactory.IS_COALESCING
要求解析器组合相邻字符数据部分的属性。

static String

XMLInputFactory.IS_NAMESPACE_AWARE
用于开启/关闭名称空间支持的属性，该属性用于支持 XML 1.0 文档，只有 true 设置是必须受支持的。

static String

XMLOutputFactory.IS_REPAIRING_NAMESPACES
用于设置输出端上默认前缀的属性。

static String

XMLInputFactory.IS_REPLACING_ENTITY_REFERENCES
要求解析器用它们的替换文本替换内部实体引用并将它们报告为字符。

static String

XMLInputFactory.IS_SUPPORTING_EXTERNAL_ENTITIES
要求解析器解析外部解析实体的属性。

static String

XMLInputFactory.IS_VALIDATING
用于开启/关闭特定于实现的验证的属性。

static String

XMLInputFactory.REPORTER
用于设置/获取 XMLReporter 接口实现的属性。

static String

XMLInputFactory.RESOLVER
用于设置/获取 XMLResolver 实现的属性。

static String

XMLInputFactory.SUPPORT_DTD
要求解析器支持 DTD 的属性。

返回 String 的 javax.xml.stream 中的方法

String

XMLStreamReader.getAttributeLocalName(int index)
返回所提供索引处的属性的 localName

String

XMLStreamReader.getAttributeNamespace(int index)
返回所提供索引处的属性的名称空间

String

XMLStreamReader.getAttributePrefix(int index)
返回所提供索引处的属性的前缀

String

XMLStreamReader.getAttributeType(int index)
返回所提供索引处的属性的 XML 类型

String

XMLStreamReader.getAttributeValue(int index)
返回 index 处的属性值

String

XMLStreamReader.getAttributeValue(String namespaceURI, String localName)
返回带有名称空间和 localName 的属性的规范化属性值。

String

XMLStreamReader.getCharacterEncodingScheme()
返回 xml 声明中声明的字符编码。

String

XMLEventReader.getElementText()
读取纯文本元素的内容。

String

XMLStreamReader.getElementText()
读取纯文本元素的内容，如果不是纯文本元素，则抛出异常。

String

XMLStreamReader.getEncoding()
如果输入编码已知，则返回输入编码；如果未知，则返回 null。

String

XMLStreamReader.getLocalName()
返回当前事件的（本地）名称。

String

FactoryConfigurationError.getMessage()
报告与此错误关联的消息。

String

XMLStreamReader.getNamespacePrefix(int index)
返回在 index 处声明的名称空间前缀。

String

XMLStreamReader.getNamespaceURI()
如果当前事件是 START_ELEMENT 或 END_ELEMENT，则此方法返回前缀的 URI 或默认名称空间。

String

XMLStreamReader.getNamespaceURI(int index)
返回在 index 处声明的名称空间 URI。

String

XMLStreamReader.getNamespaceURI(String prefix)
返回给定前缀的 URI。

String

XMLStreamReader.getPIData()
获取处理指令的数据节

String

XMLStreamReader.getPITarget()
获取处理指令的目标

String

XMLStreamReader.getPrefix()
返回当前事件的前缀，如果事件没有前缀，则返回 null

String

XMLEventWriter.getPrefix(String uri)
获取绑定 URI 的前缀。

String

XMLStreamWriter.getPrefix(String uri)
获取绑定 URI 的前缀

String

Location.getPublicId()
返回 XML 的公共 ID

String

Location.getSystemId()
返回 XML 的系统 ID

String

XMLStreamReader.getText()
以字符串的形式返回解析事件的当前值，此方法返回 CHARACTERS 事件的字符串值，返回 COMMENT 的值、ENTITY_REFERENCE 的替代值、CDATA 节的字符串值、SPACE 事件的字符串值、DTD 内部子集的字符串值。

String

XMLStreamReader.getVersion()
获取在 xml 声明中声明的 xml 版本，如果没有声明版本，则返回 null

参数类型为 String 的 javax.xml.stream 中的方法

abstract  Attribute

XMLEventFactory.createAttribute(QName name, String value)
创建一个新 Attribute。

abstract  Attribute

XMLEventFactory.createAttribute(String localName, String value)
创建一个新 Attribute。

abstract  Attribute

XMLEventFactory.createAttribute(String prefix, String namespaceURI, String localName, String value)
创建一个新 Attribute。

abstract  Characters

XMLEventFactory.createCData(String content)
创建一个 CData 标记设置为 true 的 Character 事件。

abstract  Characters

XMLEventFactory.createCharacters(String content)
创建一个 Character 事件，此方法不检查内容是否全部为空白。

abstract  Comment

XMLEventFactory.createComment(String text)
创建一个注释。

abstract  DTD

XMLEventFactory.createDTD(String dtd)
创建一个文档类型定义事件。

abstract  EndElement

XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName)
创建一个新 EndElement。

abstract  EndElement

XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces)
创建一个新 EndElement。

abstract  EntityReference

XMLEventFactory.createEntityReference(String name, EntityDeclaration declaration)
创建一个 EntityReference 事件的新实例。

abstract  Characters

XMLEventFactory.createIgnorableSpace(String content)
创建一个可忽略的空间。

abstract  Namespace

XMLEventFactory.createNamespace(String namespaceURI)
创建一个新的默认 Namespace。

abstract  Namespace

XMLEventFactory.createNamespace(String prefix, String namespaceUri)
创建一个新的 Namespace。

abstract  ProcessingInstruction

XMLEventFactory.createProcessingInstruction(String target, String data)
创建一个处理指令。

abstract  Characters

XMLEventFactory.createSpace(String content)
创建一个 isSpace 标记设置为 true 的 Character 事件。

abstract  StartDocument

XMLEventFactory.createStartDocument(String encoding)
创建一个 StartDocument 事件的新实例。

abstract  StartDocument

XMLEventFactory.createStartDocument(String encoding, String version)
创建一个 StartDocument 事件的新实例。

abstract  StartDocument

XMLEventFactory.createStartDocument(String encoding, String version, boolean standalone)
创建一个 StartDocument 事件的新实例。

abstract  StartElement

XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName)
创建一个新 StartElement。

abstract  StartElement

XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces)
创建一个新 StartElement。

abstract  StartElement

XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context)
创建一个新 StartElement。

abstract  XMLEventReader

XMLInputFactory.createXMLEventReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLEventReader。

abstract  XMLEventReader

XMLInputFactory.createXMLEventReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLEventReader。

abstract  XMLEventReader

XMLInputFactory.createXMLEventReader(String systemId, Reader reader)
根据 reader 创建一个新 XMLEventReader。

abstract  XMLEventWriter

XMLOutputFactory.createXMLEventWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLEventWriter。

abstract  XMLStreamReader

XMLInputFactory.createXMLStreamReader(InputStream stream, String encoding)
根据 java.io.InputStream 创建一个新 XMLStreamReader。

abstract  XMLStreamReader

XMLInputFactory.createXMLStreamReader(String systemId, InputStream stream)
根据 java.io.InputStream 创建一个新 XMLStreamReader。

abstract  XMLStreamReader

XMLInputFactory.createXMLStreamReader(String systemId, Reader reader)
根据 java.io.InputStream 创建一个新 XMLStreamReader。

abstract  XMLStreamWriter

XMLOutputFactory.createXMLStreamWriter(OutputStream stream, String encoding)
创建一个写入到流的新 XMLStreamWriter。

String

XMLStreamReader.getAttributeValue(String namespaceURI, String localName)
返回带有名称空间和 localName 的属性的规范化属性值。

String

XMLStreamReader.getNamespaceURI(String prefix)
返回给定前缀的 URI。

String

XMLEventWriter.getPrefix(String uri)
获取绑定 URI 的前缀。

String

XMLStreamWriter.getPrefix(String uri)
获取绑定 URI 的前缀

Object

XMLEventReader.getProperty(String name)
从底层实现获取功能/属性值。

abstract  Object

XMLInputFactory.getProperty(String name)
从底层实现获取功能/属性的值。

abstract  Object

XMLOutputFactory.getProperty(String name)
获取底层实现上的功能/属性

Object

XMLStreamReader.getProperty(String name)
从底层实现获取功能/属性的值

Object

XMLStreamWriter.getProperty(String name)
从底层实现获取功能/属性值

abstract  boolean

XMLInputFactory.isPropertySupported(String name)
查询此工厂支持的属性集合。

abstract  boolean

XMLOutputFactory.isPropertySupported(String name)
查询此工厂支持的属性集合。

static XMLEventFactory

XMLEventFactory.newInstance(String factoryId, ClassLoader classLoader)
创建一个新的工厂实例。

static XMLInputFactory

XMLInputFactory.newInstance(String factoryId, ClassLoader classLoader)
创建一个新的工厂实例。

static XMLInputFactory

XMLOutputFactory.newInstance(String factoryId, ClassLoader classLoader)
创建一个的新工厂实例。

void

XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
以特定于应用程序的格式报告所需消息。

void

XMLStreamReader.require(int type, String namespaceURI, String localName)
测试当前事件是否属于给定的类型，以及名称空间和名称是否与当前事件的当前名称空间和名称相匹配。

Object

XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
检索资源。

void

XMLEventWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。

void

XMLStreamWriter.setDefaultNamespace(String uri)
将 URI 绑定到默认名称空间。

void

XMLEventWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。

void

XMLStreamWriter.setPrefix(String prefix, String uri)
设置绑定 URI 的前缀。

abstract  void

XMLInputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

abstract  void

XMLOutputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

void

XMLStreamWriter.writeAttribute(String localName, String value)
向输出流写入一个不带前缀的属性。

void

XMLStreamWriter.writeAttribute(String namespaceURI, String localName, String value)
向输出流写入一个属性

void

XMLStreamWriter.writeAttribute(String prefix, String namespaceURI, String localName, String value)
向输出流写入一个属性

void

XMLStreamWriter.writeCData(String data)
编写 CData 节

void

XMLStreamWriter.writeCharacters(String text)
向输出写入文本

void

XMLStreamWriter.writeComment(String data)
编写一个包含数据的 XML 注释

void

XMLStreamWriter.writeDefaultNamespace(String namespaceURI)
向流写入默认名称空间

void

XMLStreamWriter.writeDTD(String dtd)
编写 DTD 节。

void

XMLStreamWriter.writeEmptyElement(String localName)
向输出写入一个空元素标记

void

XMLStreamWriter.writeEmptyElement(String namespaceURI, String localName)
向输出写入一个空元素标记

void

XMLStreamWriter.writeEmptyElement(String prefix, String localName, String namespaceURI)
向输出写入一个空元素标记

void

XMLStreamWriter.writeEntityRef(String name)
编写一个实体引用

void

XMLStreamWriter.writeNamespace(String prefix, String namespaceURI)
向输出流写入一个名称空间。

void

XMLStreamWriter.writeProcessingInstruction(String target)
编写一条处理指令

void

XMLStreamWriter.writeProcessingInstruction(String target, String data)
编写一条处理指令

void

XMLStreamWriter.writeStartDocument(String version)
编写 XML 声明。

void

XMLStreamWriter.writeStartDocument(String encoding, String version)
编写 XML 声明。

void

XMLStreamWriter.writeStartElement(String localName)
向输出写入一个开始标记。

void

XMLStreamWriter.writeStartElement(String namespaceURI, String localName)
向输出写入一个开始标记

void

XMLStreamWriter.writeStartElement(String prefix, String localName, String namespaceURI)
向输出写入一个开始标记

参数类型为 String 的 javax.xml.stream 中的构造方法

FactoryConfigurationError(Exception e, String msg)
构造具有嵌套内部异常和消息的异常。

FactoryConfigurationError(String msg)
构造具有关联消息的异常。

FactoryConfigurationError(String msg, Exception e)
构造具有嵌套内部异常和消息的异常。

XMLStreamException(String msg)
构造具有关联消息的异常。

XMLStreamException(String msg, Location location)
构造具有关联消息、异常和位置的异常。

XMLStreamException(String msg, Location location, Throwable th)
构造具有关联消息、异常和位置的异常。

XMLStreamException(String msg, Throwable th)
构造具有关联消息和异常的异常

javax.xml.stream.events 中 String 的使用

返回 String 的 javax.xml.stream.events 中的方法

String

EntityDeclaration.getBaseURI()
获取此引用的基准 URI，如果此信息不可用，则获得 null

String

StartDocument.getCharacterEncodingScheme()
返回 XML 数据的编码样式

String

Characters.getData()
获取此事件的字符数据。

String

ProcessingInstruction.getData()
处理指令的数据部分。

String

DTD.getDocumentTypeDeclaration()
以字符串形式返回完整文档类型声明，其中包括内部 DTD 子集。

String

Attribute.getDTDType()
获取此属性的类型，默认值是字符串 "CDATA"，

String

EntityDeclaration.getName()
实体的名称

String

EntityReference.getName()
实体的名称

String

NotationDeclaration.getName()
注释的名称。

String

Namespace.getNamespaceURI()
获取绑定到此名称空间的前缀的 URI。

String

StartElement.getNamespaceURI(String prefix)
获取绑定在此元素上下文中的前缀的值。

String

EntityDeclaration.getNotationName()
关联的注释的名称。

String

Namespace.getPrefix()
获取前缀，如果它是默认名称空间声明，则返回 ""。

String

EntityDeclaration.getPublicId()
实体的公共标识符，如果未给定该标识符，则为 null

String

NotationDeclaration.getPublicId()
注释的公共标识符，如果未提供该标识符，则为 null。

String

EntityDeclaration.getReplacementText()
实体的替换文本。

String

EntityDeclaration.getSystemId()
实体的系统标识符。

String

NotationDeclaration.getSystemId()
注释的系统标识符，如果未提供该标识符，则为 null。

String

StartDocument.getSystemId()
返回 XML 数据的系统 ID

String

ProcessingInstruction.getTarget()
处理指令的目标部分。

String

Comment.getText()
返回注释的字符串数据，如果不存在这样的数据，则返回空字符串。

String

Attribute.getValue()
获取此属性的标准化值。

String

StartDocument.getVersion()
返回此 XML 流的 XML 版本

参数类型为 String 的 javax.xml.stream.events 中的方法

String

StartElement.getNamespaceURI(String prefix)
获取绑定在此元素上下文中的前缀的值。

javax.xml.stream.util 中 String 的使用

返回 String 的 javax.xml.stream.util 中的方法

String

StreamReaderDelegate.getAttributeLocalName(int index)

String

StreamReaderDelegate.getAttributeNamespace(int index)

String

StreamReaderDelegate.getAttributePrefix(int index)

String

StreamReaderDelegate.getAttributeType(int index)

String

StreamReaderDelegate.getAttributeValue(int index)

String

StreamReaderDelegate.getAttributeValue(String namespaceUri, String localName)

String

StreamReaderDelegate.getCharacterEncodingScheme()

String

EventReaderDelegate.getElementText()

String

StreamReaderDelegate.getElementText()

String

StreamReaderDelegate.getEncoding()

String

StreamReaderDelegate.getLocalName()

String

StreamReaderDelegate.getNamespacePrefix(int index)

String

StreamReaderDelegate.getNamespaceURI()

String

StreamReaderDelegate.getNamespaceURI(int index)

String

StreamReaderDelegate.getNamespaceURI(String prefix)

String

StreamReaderDelegate.getPIData()

String

StreamReaderDelegate.getPITarget()

String

StreamReaderDelegate.getPrefix()

String

StreamReaderDelegate.getText()

String

StreamReaderDelegate.getVersion()

参数类型为 String 的 javax.xml.stream.util 中的方法

String

StreamReaderDelegate.getAttributeValue(String namespaceUri, String localName)

String

StreamReaderDelegate.getNamespaceURI(String prefix)

Object

EventReaderDelegate.getProperty(String name)

Object

StreamReaderDelegate.getProperty(String name)

void

StreamReaderDelegate.require(int type, String namespaceURI, String localName)

javax.xml.transform 中 String 的使用

声明为 String 的 javax.xml.transform 中的字段

static String

OutputKeys.CDATA_SECTION_ELEMENTS
cdata-section-elements = expanded names. cdata-section-elements 指定了由空白分隔的元素名称列表，其中的文本节点子级应使用 CDATA 部分来输出。

static String

OutputKeys.DOCTYPE_PUBLIC
doctype-public = string. 有关关键值应为何值的描述，请参阅 OutputKeys.DOCTYPE_SYSTEM 属性文档。

static String

OutputKeys.DOCTYPE_SYSTEM
doctype-system = string. doctype-system 指定了要在文档类型声明中使用的系统标识符。

static String

OutputKeys.ENCODING
encoding = string. encoding 指定了首选的字符编码，Transformer 应使用此编码将字符序列编码作为字节序列进行编码。

static String

OutputKeys.INDENT
indent = "yes" | "no". indent 指定了当输出结果树时，Transformer 是否可以添加额外的空白；其值必须为 yes 或 no。

static String

OutputKeys.MEDIA_TYPE
media-type = string. media-type 指定了输出结果树得到的数据的介质类型（MIME 内容类型）。

static String

OutputKeys.METHOD
method = "xml" | "html" | "text" | expanded name。

static String

OutputKeys.OMIT_XML_DECLARATION
omit-xml-declaration = "yes" | "no". omit-xml-declaration 指定了 XSLT 处理器是否应输出 XML 声明，其值必须为 yes 或 no。

static String

Result.PI_DISABLE_OUTPUT_ESCAPING
如果结果树禁用了输出转义，则为发送处理指令的名称。

static String

Result.PI_ENABLE_OUTPUT_ESCAPING
如果结果树在已接收 PI_DISABLE_OUTPUT_ESCAPING 处理指令后的某时刻启用了输出转义，则发送处理指令的名称。

static String

OutputKeys.STANDALONE
standalone = "yes" | "no". standalone 指定了 Transformer 是否应输出单独的文档声明，其值必须为 yes 或 no。

static String

OutputKeys.VERSION
version = nmtoken. version 指定了输出方法的版本。

返回 String 的 javax.xml.transform 中的方法

String

TransformerException.getLocationAsString()
获取字符串形式的位置信息。

String

TransformerFactoryConfigurationError.getMessage()
返回针对此错误的消息（如果有）。

String

TransformerException.getMessageAndLocation()
获取带有追加的位置信息的错误消息。

abstract  String

Transformer.getOutputProperty(String name)
获取对转换器有效的输出属性。

String

SourceLocator.getPublicId()
返回当前文档事件的公共标识符。

String

Result.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

Source.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

SourceLocator.getSystemId()
返回当前文档事件的系统标识符。

参数类型为 String 的 javax.xml.transform 中的方法

abstract  Source

TransformerFactory.getAssociatedStylesheet(Source source, String media, String title, String charset)
通过与给定标准匹配的 xml 样式表的处理指令 获取与 XML Source 文档关联的样式表规范（或多个规范）。

abstract  Object

TransformerFactory.getAttribute(String name)
允许用户在底层实现上检索指定属性。

abstract  boolean

TransformerFactory.getFeature(String name)
查找功能值。

abstract  String

Transformer.getOutputProperty(String name)
获取对转换器有效的输出属性。

abstract  Object

Transformer.getParameter(String name)
获取通过 setParameter 显式设置的参数。

static TransformerFactory

TransformerFactory.newInstance(String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 TransformerFactory 实例。

Source

URIResolver.resolve(String href, String base)
当遇到 xsl:include、xsl:import 或 document() 函数时，由处理器调用此方法。

abstract  void

TransformerFactory.setAttribute(String name, Object value)
允许用户设置底层实现上的指定属性。

abstract  void

TransformerFactory.setFeature(String name, boolean value)
设置通过此工厂创建的此 TransformerFactory 和 Transformer 或 Template 的功能。

abstract  void

Transformer.setOutputProperty(String name, String value)
设置转换中实际的输出属性。

abstract  void

Transformer.setParameter(String name, Object value)
添加一个转换参数。

void

Result.setSystemId(String systemId)
设置此 Result 的系统标识符。

void

Source.setSystemId(String systemId)
设置此 Source 的系统标识符。

参数类型为 String 的 javax.xml.transform 中的构造方法

TransformerConfigurationException(String msg)
创建带有指定为错误消息的 String 的新 TransformerConfigurationException。

TransformerConfigurationException(String message, SourceLocator locator)
从消息和 Locator 创建新 TransformerConfigurationException。

TransformerConfigurationException(String message, SourceLocator locator, Throwable e)
包装了 TransformerConfigurationException 中的现有异常。

TransformerConfigurationException(String msg, Throwable e)
创建带有给定 Exception 基本原因和详细消息的新 TransformerConfigurationException。

TransformerException(String message)
创建一个新的 TransformerException。

TransformerException(String message, SourceLocator locator)
从消息和 Locator 创建一个新 TransformerException。

TransformerException(String message, SourceLocator locator, Throwable e)
包装了 TransformerException 中的现有异常。

TransformerException(String message, Throwable e)
包装 TransformerException 中的一个现有异常。

TransformerFactoryConfigurationError(Exception e, String msg)
创建带有给定 Exception 基本原因和详细消息的新 TransformerFactoryConfigurationError。

TransformerFactoryConfigurationError(String msg)
创建带有指定为错误消息的 String 的新 TransformerFactoryConfigurationError。

javax.xml.transform.dom 中 String 的使用

声明为 String 的 javax.xml.transform.dom 中的字段

static String

DOMResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

DOMSource.FEATURE
当将此值作为参数传递时如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。

返回 String 的 javax.xml.transform.dom 中的方法

String

DOMResult.getSystemId()
获取系统标识符。

String

DOMSource.getSystemId()
获取将从其解析 URL 的基本 ID（URL 或系统 ID）。

参数类型为 String 的 javax.xml.transform.dom 中的方法

void

DOMResult.setSystemId(String systemId)
设置可与此节点联合使用的 systemId。

void

DOMSource.setSystemId(String systemID)
设置将从其解析 URL 的基本 ID（URL 或系统 ID）。

参数类型为 String 的 javax.xml.transform.dom 中的构造方法

DOMResult(Node node, Node nextSibling, String systemId)
使用 DOM 节点创建新输出目标，此目标指定了子节点，其中结果节点为指定 System ID 且应该插入到该子节点之前。

DOMResult(Node node, String systemId)
使用 DOM 节点创建带有指定 System ID 的新输出目标。

DOMSource(Node node, String systemID)
创建带有 DOM 节点的新输入源，系统 ID 也作为基本 URI 被传入。

javax.xml.transform.sax 中 String 的使用

声明为 String 的 javax.xml.transform.sax 中的字段

static String

SAXResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

SAXSource.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source 输入。

static String

SAXTransformerFactory.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则从 TransformerFactory.newInstance() 返回的 TransformerFactory 可以安全地被转换为 SAXTransformerFactory。

static String

SAXTransformerFactory.FEATURE_XMLFILTER
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 SAXTransformerFactory.newXMLFilter(Source src) 和 SAXTransformerFactory.newXMLFilter(Templates templates) 方法是受支持的。

返回 String 的 javax.xml.transform.sax 中的方法

String

SAXResult.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

SAXSource.getSystemId()
获取要从其解析 URI 的基本 ID（URI 或系统 ID）。

String

TemplatesHandler.getSystemId()
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

String

TransformerHandler.getSystemId()
获取要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

参数类型为 String 的 javax.xml.transform.sax 中的方法

void

SAXResult.setSystemId(String systemId)
setSystemId 方法设置可与 ContentHandler 关联使用的 systemID。

void

SAXSource.setSystemId(String systemId)
设置此 Source 的系统标识符。

void

TemplatesHandler.setSystemId(String systemID)
设置此生成器所创建的 Templates 对象的基本 ID（URI 或系统 ID）。

void

TransformerHandler.setSystemId(String systemID)
设置要从其解析相对 URL 的基本 ID（URI 或系统 ID）。

javax.xml.transform.stax 中 String 的使用

声明为 String 的 javax.xml.transform.stax 中的字段

static String

StAXResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

StAXSource.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(String name) 返回 true，则 Transformer 支持此类型的 Source 输入。

返回 String 的 javax.xml.transform.stax 中的方法

String

StAXResult.getSystemId()
返回的系统标识符始终为 null。

String

StAXSource.getSystemId()
获取此 StAXSource 使用的系统标识符。

参数类型为 String 的 javax.xml.transform.stax 中的方法

void

StAXResult.setSystemId(String systemId)
在 StAXResult 的上下文中，它不适合显示设置系统标识符。

void

StAXSource.setSystemId(String systemId)
在 StAXSource 的上下文中，它不适合显示设置系统标识符。

javax.xml.transform.stream 中 String 的使用

声明为 String 的 javax.xml.transform.stream 中的字段

static String

StreamResult.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Result 输出。

static String

StreamSource.FEATURE
当将此值作为参数传递时，如果 TransformerFactory.getFeature(java.lang.String) 返回 true，则 Transformer 支持此类型的 Source。

返回 String 的 javax.xml.transform.stream 中的方法

String

StreamSource.getPublicId()
获取通过 setPublicId 设置的公共标识符。

String

StreamResult.getSystemId()
获取通过 setSystemId 设置的系统标识符。

String

StreamSource.getSystemId()
获取通过 setSystemId 设置的系统标识符。

参数类型为 String 的 javax.xml.transform.stream 中的方法

void

StreamSource.setPublicId(String publicId)
设置此 Source 的公共标识符。

void

StreamResult.setSystemId(String systemId)
设置可以与字节流或字符流关联使用的 systemID，如果未设置，则使用此值作为 writeable URI（可能是文件名）。

void

StreamSource.setSystemId(String systemId)
设置此 Source 的系统标识符。

参数类型为 String 的 javax.xml.transform.stream 中的构造方法

StreamResult(String systemId)
从 URL 构造 StreamResult。

StreamSource(InputStream inputStream, String systemId)
从字节流构造 StreamSource。

StreamSource(Reader reader, String systemId)
从字符 reader 构造 StreamSource。

StreamSource(String systemId)
从 URL 构造 StreamSource。

javax.xml.validation 中 String 的使用

参数类型为 String 的 javax.xml.validation 中的方法

boolean

SchemaFactory.getFeature(String name)
查找功能标志的值。

boolean

Validator.getFeature(String name)
查找功能标志的值。

boolean

ValidatorHandler.getFeature(String name)
查找特性标志的值。

Object

SchemaFactory.getProperty(String name)
查找属性值。

Object

Validator.getProperty(String name)
查找属性值。

Object

ValidatorHandler.getProperty(String name)
查找属性值。

abstract  boolean

SchemaFactory.isSchemaLanguageSupported(String schemaLanguage)
此 SchemaFactory 支持指定的模式吗？

abstract  SchemaFactory

SchemaFactoryLoader.newFactory(String schemaLanguage)
创建指定模式语言的新 SchemaFactory 对象。

static SchemaFactory

SchemaFactory.newInstance(String schemaLanguage)
查找支持指定模式语言的 SchemaFactory 的实现并返回它。

static SchemaFactory

SchemaFactory.newInstance(String schemaLanguage, String factoryClassName, ClassLoader classLoader)
根据类名称获得一个新 SchemaFactory 实例。

void

SchemaFactory.setFeature(String name, boolean value)
设置此 SchemaFactory 的特性，Schema 由此工厂创建，更进一步说，Validator 和 ValidatorHandler 由这些 Schema 创建。

void

Validator.setFeature(String name, boolean value)
设置功能标志的值。

void

ValidatorHandler.setFeature(String name, boolean value)
设置此 ValidatorHandler 的特性。

void

SchemaFactory.setProperty(String name, Object object)
设置属性值。

void

Validator.setProperty(String name, Object object)
设置属性值。

void

ValidatorHandler.setProperty(String name, Object object)
设置属性值。

javax.xml.ws 中 String 的使用

声明为 String 的 javax.xml.ws 中的字段

static String

BindingProvider.ENDPOINT_ADDRESS_PROPERTY
标准属性：目标服务端点地址。

static String

BindingProvider.PASSWORD_PROPERTY
标准属性：用于验证的密码。

static String

BindingProvider.SESSION_MAINTAIN_PROPERTY
标准属性：服务客户端使用此 boolean 属性指示它是否希望参与与服务端点的会话。

static String

BindingProvider.SOAPACTION_URI_PROPERTY
SOAPAction 的标准属性。

static String

BindingProvider.SOAPACTION_USE_PROPERTY
SOAPAction 的标准属性。

static String

BindingProvider.USERNAME_PROPERTY
标准属性：用于验证的用户名。

static String

Endpoint.WSDL_PORT
标准属性：WSDL 端口的名称。

static String

Endpoint.WSDL_SERVICE
标准属性：WSDL 服务的名称。

返回变量类型为 String 的类型的 javax.xml.ws 中的方法

Map<String,Object>

Response.getContext()
获取所含的响应上下文。

abstract  Map<String,Object>

Endpoint.getProperties()
返回此 Endpoint 实例的属性包。

Map<String,Object>

BindingProvider.getRequestContext()
获取用于初始化请求消息的消息上下文的上下文。

Map<String,Object>

BindingProvider.getResponseContext()
获取处理响应消息所得的上下文。

参数类型为 String 的 javax.xml.ws 中的方法

void

Service.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。

static Endpoint

Endpoint.create(String bindingId, Object implementor)
创建具有指定绑定类型和实现者对象的端点。

boolean

WebServiceContext.isUserInRole(String role)
返回一个布尔值，指示指定的逻辑角色中是否包含经过验证的用户。

abstract  void

Endpoint.publish(String address)
在给定地址处发布此端点。

static Endpoint

Endpoint.publish(String address, Object implementor)
在给定地址处针对指定的实现者对象创建并发布端点。

static Service.Mode

Service.Mode.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

类型变量类型为 String 的 javax.xml.ws 中的方法参数

abstract  void

Endpoint.setProperties(Map<String,Object> properties)
设置此 Endpoint 实例的属性包。

参数类型为 String 的 javax.xml.ws 中的构造方法

ProtocolException(String message)
构造一个具有指定详细消息的新协议异常。

ProtocolException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新运行时异常。

WebServiceException(String message)
构造具有指定详细消息的新异常。

WebServiceException(String message, Throwable cause)
构造一个具有指定详细消息和 cause 的新异常。

WebServicePermission(String name)
创建具有指定名称的新权限。

WebServicePermission(String name, String actions)
创建具有指定名称和操作的新权限。

javax.xml.ws.handler 中 String 的使用

声明为 String 的 javax.xml.ws.handler 中的字段

static String

MessageContext.HTTP_REQUEST_HEADERS
标准属性：HTTP 请求头。

static String

MessageContext.HTTP_REQUEST_METHOD
标准属性：HTTP 请求方法。

static String

MessageContext.HTTP_RESPONSE_CODE
标准属性：HTTP 响应状态代码。

static String

MessageContext.HTTP_RESPONSE_HEADERS
标准属性：HTTP 响应头。

static String

MessageContext.INBOUND_MESSAGE_ATTACHMENTS
标准属性：用于入站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。

static String

MessageContext.MESSAGE_OUTBOUND_PROPERTY
标准属性：消息方向，对于出站消息为 true，对于入站消息为 false。

static String

MessageContext.OUTBOUND_MESSAGE_ATTACHMENTS
标准属性: 用于出站消息的消息附件的映射，键为 MIME Content-ID，值为 DataHandler。

static String

MessageContext.PATH_INFO
标准属性：请求路径信息

static String

MessageContext.QUERY_STRING
标准属性：请求的查询字符串。

static String

MessageContext.SERVLET_CONTEXT
标准属性：servlet 上下文对象

static String

MessageContext.SERVLET_REQUEST
标准属性：servlet 请求对象。

static String

MessageContext.SERVLET_RESPONSE
标准属性：servlet 响应对象。

static String

MessageContext.WSDL_DESCRIPTION
标准属性：WSDL 文档的输入源。

static String

MessageContext.WSDL_INTERFACE
标准属性：wsdl 接口 (2.0) 或端口类型 (1.1) 的名称。

static String

MessageContext.WSDL_OPERATION
标准属性：WSDL 操作的名称。

static String

MessageContext.WSDL_PORT
标准属性：WSDL 端口的名称。

static String

MessageContext.WSDL_SERVICE
标准属性：WSDL 服务的名称。

返回 String 的 javax.xml.ws.handler 中的方法

String

PortInfo.getBindingID()
获取标识正由被访问的端口所用绑定的 URI。

参数类型为 String 的 javax.xml.ws.handler 中的方法

MessageContext.Scope

MessageContext.getScope(String name)
获得属性的作用域。

void

MessageContext.setScope(String name, MessageContext.Scope scope)
设置属性的作用域。

static MessageContext.Scope

MessageContext.Scope.valueOf(String name)
返回带有指定名称的该类型的枚举常量。

javax.xml.ws.handler.soap 中 String 的使用

返回变量类型为 String 的类型的 javax.xml.ws.handler.soap 中的方法

Set<String>

SOAPMessageContext.getRoles()
获取与执行处理程序链关联的 SOAP 参与者角色。

javax.xml.ws.http 中 String 的使用

声明为 String 的 javax.xml.ws.http 中的字段

static String

HTTPBinding.HTTP_BINDING
表示 XML/HTTP 绑定标识的常量。

javax.xml.ws.soap 中 String 的使用

声明为 String 的 javax.xml.ws.soap 中的字段

static String

SOAPBinding.SOAP11HTTP_BINDING
表示 HTTP 绑定上的 SOAP 1.1 标识的常量。

static String

SOAPBinding.SOAP11HTTP_MTOM_BINDING
表示 HTTP 绑定上的 SOAP 1.1 标识，且默认启用 MTOM 的常量。

static String

SOAPBinding.SOAP12HTTP_BINDING
表示 HTTP 绑定上的 SOAP 1.2 标识的常量。

static String

SOAPBinding.SOAP12HTTP_MTOM_BINDING
表示 HTTP 绑定上的 SOAP 1.2 标识，且默认启用 MTOM 的常量。

返回变量类型为 String 的类型的 javax.xml.ws.soap 中的方法

Set<String>

SOAPBinding.getRoles()
获取 SOAP 绑定实例所扮演的角色。

类型变量类型为 String 的 javax.xml.ws.soap 中的方法参数

void

SOAPBinding.setRoles(Set<String> roles)
设置由 SOAP 绑定实例扮演的角色。

javax.xml.ws.spi 中 String 的使用

声明为 String 的 javax.xml.ws.spi 中的字段

static String

Provider.JAXWSPROVIDER_PROPERTY
表示用于查找 Provider 实现类名称的属性的常量。

参数类型为 String 的 javax.xml.ws.spi 中的方法

abstract  void

ServiceDelegate.addPort(QName portName, String bindingId, String endpointAddress)
为服务创建新的端口。

abstract  Endpoint

Provider.createAndPublishEndpoint(String address, Object implementor)
创建和发布具有指定地址和实现对象的端点对象。

abstract  Endpoint

Provider.createEndpoint(String bindingId, Object implementor)
创建具有提供的绑定和实现对象的端点对象。

javax.xml.xpath 中 String 的使用

声明为 String 的 javax.xml.xpath 中的字段

static String

XPathFactory.DEFAULT_OBJECT_MODEL_URI
默认 Object Model URI。

static String

XPathFactory.DEFAULT_PROPERTY_NAME
遵守 JAXP 规范的默认属性名称。

static String

XPathConstants.DOM_OBJECT_MODEL
DOM 对象模型的 URI，"http://java.sun.com/jaxp/xpath/dom"。

返回 String 的 javax.xml.xpath 中的方法

String

XPathExpression.evaluate(InputSource source)
计算指定 InputSource 上下文中编译后的 XPath 表达式并以 String 形式返回结果。

String

XPathExpression.evaluate(Object item)
计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。

String

XPath.evaluate(String expression, InputSource source)
计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。

String

XPath.evaluate(String expression, Object item)
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。

参数类型为 String 的 javax.xml.xpath 中的方法

XPathExpression

XPath.compile(String expression)
编译 XPath 表达式供以后计算使用。

String

XPath.evaluate(String expression, InputSource source)
计算指定 InputSource 上下文中的 XPath 表达式并返回 String 形式的结果。

Object

XPath.evaluate(String expression, InputSource source, QName returnType)
计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。

String

XPath.evaluate(String expression, Object item)
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。

Object

XPath.evaluate(String expression, Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

abstract  boolean

XPathFactory.getFeature(String name)
获取指定功能的状态。

abstract  boolean

XPathFactory.isObjectModelSupported(String objectModel)
此 XPathFactory 是否支持指定的对象模型

static XPathFactory

XPathFactory.newInstance(String uri)
获取使用指定对象模型的新 XPathFactory 实例。

static XPathFactory

XPathFactory.newInstance(String uri, String factoryClassName, ClassLoader classLoader)
根据工厂类名称获取一个新 XPathFactory 实例。

abstract  void

XPathFactory.setFeature(String name, boolean value)
设置此工厂所创建的此 XPathFactory 和 XPath 的功能。

参数类型为 String 的 javax.xml.xpath 中的构造方法

XPathException(String message)
构造带指定详细 message 的新 XPathException。

XPathExpressionException(String message)
构造带指定详细 message 的新 XPathExpressionException。

XPathFactoryConfigurationException(String message)
构造带指定详细 message 的新 XPathFactoryConfigurationException。

XPathFunctionException(String message)
构造带指定详细 message 的新 XPathFunctionException。

org.ietf.jgss 中 String 的使用

返回 String 的 org.ietf.jgss 中的方法

String

GSSException.getMajorString()
返回一个字符串，解释在此异常中 GSS-API 级的主要错误代码。

String

GSSException.getMessage()
返回主要和次要状态码的文本表示形式。

String

GSSException.getMinorString()
返回解释特定于机制的错误代码的字符串。

String

MessageProp.getMinorString()
检索解释次要状态码的字符串。

String

GSSException.toString()
返回主要和次要状态码的文本表示形式。

String

GSSName.toString()
返回 GSSName 对象的文本表示形式。

String

Oid.toString()
返回 oid 用句点符号分隔的整数组件的字符串表示形式。

参数类型为 String 的 org.ietf.jgss 中的方法

abstract  GSSName

GSSManager.createName(String nameStr, Oid nameType)
将字符串名称从指定的名称空间转换到 GSSName 对象的 Factory 方法。

abstract  GSSName

GSSManager.createName(String nameStr, Oid nameType, Oid mech)
将字符串名称从指定的名称空间转换到 GSSName 对象并同时针对机制对其进行规范化的 Factory 方法。

void

GSSException.setMinor(int minorCode, String message)
由异常抛出器使用，以设置机制级的次要错误代码及其字符串解释。

void

MessageProp.setSupplementaryStates(boolean duplicate, boolean old, boolean unseq, boolean gap, int minorStatus, String minorString)
此方法将设置 MessageProp 中的增补信息标记的状态和次要状态。

参数类型为 String 的 org.ietf.jgss 中的构造方法

GSSException(int majorCode, int minorCode, String minorString)
使用指定的主要代码、次要代码和次要代码文本性解释，创建一个 GSSException 对象。

Oid(String strOid)
从其整数组件的字符串表示形式中构建 Oid 对象。

org.omg.CORBA 中 String 的使用

声明为 String 的 org.omg.CORBA 中的字段

String

ValueMember.defined_in
用来定义此成员的 value 的存储库 ID。

String

NameValuePair.id
将通过此 NameValuePair 对象与某一值关联的名称。

String

ValueMember.id
此 ValueMember 对象所描述的 value 成员的存储库 ID

String

StructMember.name
此 StructMember 对象所描述的 struct 成员的名称。

String

UnionMember.name
此 UnionMember 对象所描述的 union 成员的名称。

String

ValueMember.name
此 ValueMember 对象所描述的 value 成员的名称。

String

StringHolder.value
此 StringHolder 对象保存的 String 值。

String[]

StringSeqHolder.value

String[]

WStringSeqHolder.value

String

ValueMember.version
用来定义此成员的 value 的版本。

返回 String 的 org.omg.CORBA 中的方法

String[]

DynamicImplementation._ids()
已过时。

String[]

_IDLTypeStub._ids()

String[]

_PolicyStub._ids()

abstract  String

Context.context_name()
检索此 Context 对象的名称。

String

DynStruct.current_member_name()
已过时。 在遍历期间返回当前成员的名称。

String

DynValue.current_member_name()
已过时。 在遍历表示某个 Value 对象的 DynAny 对象时，返回当前成员的名称。

abstract  String

Any.extract_string()
提取此 Any 对象 value 字段中的 String 对象。

abstract  String

Any.extract_wstring()
提取此 Any 对象 value 字段中的 String 对象。

static String

FieldNameHelper.extract(Any a)

static String

IdentifierHelper.extract(Any a)

static String

RepositoryIdHelper.extract(Any a)

static String[]

StringSeqHelper.extract(Any a)

static String

StringValueHelper.extract(Any a)

static String

VersionSpecHelper.extract(Any a)

static String[]

WStringSeqHelper.extract(Any a)

static String

WStringValueHelper.extract(Any a)

String

StringValueHelper.get_id()

String

WStringValueHelper.get_id()

String

DynAny.get_string()
已过时。 检索此 DynAny 对象中包含的 String。

String

DynAny.get_wstring()
已过时。 检索此 DynAny 对象中包含的 String。

static String

AnySeqHelper.id()

static String

BooleanSeqHelper.id()

static String

CharSeqHelper.id()

static String

CompletionStatusHelper.id()

static String

CurrentHelper.id()

static String

DefinitionKindHelper.id()

static String

DoubleSeqHelper.id()

static String

FieldNameHelper.id()

static String

FloatSeqHelper.id()

static String

IDLTypeHelper.id()

static String

IdentifierHelper.id()

static String

LongLongSeqHelper.id()

static String

LongSeqHelper.id()

static String

NameValuePairHelper.id()

static String

ObjectHelper.id()

static String

OctetSeqHelper.id()

static String

ParameterModeHelper.id()

static String

PolicyErrorCodeHelper.id()

static String

PolicyErrorHelper.id()

static String

PolicyHelper.id()

static String

PolicyListHelper.id()

static String

PolicyTypeHelper.id()

static String

RepositoryIdHelper.id()

static String

ServiceDetailHelper.id()

static String

ServiceInformationHelper.id()

static String

SetOverrideTypeHelper.id()

static String

ShortSeqHelper.id()

static String

StringSeqHelper.id()

static String

StringValueHelper.id()

static String

StructMemberHelper.id()

abstract  String

TypeCode.id()
检索全局标识此 TypeCode 对象类型的 RepositoryId。

static String

ULongLongSeqHelper.id()

static String

ULongSeqHelper.id()

static String

UShortSeqHelper.id()

static String

UnionMemberHelper.id()

static String

UnknownUserExceptionHelper.id()

static String

ValueBaseHelper.id()

static String

ValueMemberHelper.id()

static String

VersionSpecHelper.id()

static String

VisibilityHelper.id()

static String

WCharSeqHelper.id()

static String

WStringSeqHelper.id()

static String

WStringValueHelper.id()

static String

WrongTransactionHelper.id()

abstract  String

ContextList.item(int index)
返回位于给定索引的 String 对象。

abstract  String[]

ORB.list_initial_services()
返回最初可用 CORBA 对象引用（比如 "NameService" 和 "InterfaceRepository"）的列表。

String

DynUnion.member_name()
已过时。 允许在没有检查鉴别符值的情况下检测此 union 成员的名称。

abstract  String

TypeCode.member_name(int index)
检索给定索引标识的成员的简单名称。

abstract  String

NamedValue.name()
检索此 NamedValue 对象的名称。

abstract  String

TypeCode.name()
在 TypeCode 对象的封闭作用域内检索标识此对象的简单名称。

abstract  String

ORB.object_to_string(Object obj)
将给定 CORBA 对象引用转换为字符串。

String

ServerRequest.op_name()
已过时。 使用 operation()

abstract  String

Request.operation()
检索将被调用的方法的名称。

String

ServerRequest.operation()
抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

String

DataInputStream.read_string()
从输入流读取 IDL 字符串值。

String

DataInputStream.read_wstring()
从输入流读取 IDL 宽字符串值。

static String

FieldNameHelper.read(InputStream istream)

static String

IdentifierHelper.read(InputStream istream)

static String

RepositoryIdHelper.read(InputStream istream)

static String[]

StringSeqHelper.read(InputStream istream)

static String

StringValueHelper.read(InputStream istream)

static String

VersionSpecHelper.read(InputStream istream)

static String[]

WStringSeqHelper.read(InputStream istream)

static String

WStringValueHelper.read(InputStream istream)

String

SystemException.toString()
将此异常转换成有代表性的字符串。

String

DynEnum.value_as_string()
已过时。 以字符串形式返回此 DynEnum 中存储的 IDL enum 的值。

参数类型为 String 的 org.omg.CORBA 中的方法

Request

LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

Request

Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表和用于该方法返回值的容器进行初始化。

Request

LocalObject._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

Request

Object._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
创建一个 Request 实例，并使用给定上下文、方法名称、参数列表、用于该方法返回值的容器、可能的异常列表以及需要被解析的上下文字符串所组成的列表进行初始化。

boolean

LocalObject._is_a(String repository_id)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

boolean

Object._is_a(String repositoryIdentifier)
检查此对象是否是实现给定接口的类的实例。

Request

LocalObject._request(String operation)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

Request

Object._request(String operation)
创建一个在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

OutputStream

LocalObject._request(String operation, boolean responseExpected)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

ServantObject

LocalObject._servant_preinvoke(String operation, Class expectedType)
抛出 org.omg.CORBA.NO_IMPLEMENT 异常，并带有消息 "This is a locally constrained object"。

abstract  NamedValue

NVList.add_item(String item_name, int flags)
创建一个新的 NamedValue 对象，使用给定名称和标志初始化该对象，并将它添加到此 NVList 对象的末尾。

abstract  Any

Request.add_named_in_arg(String name)
使用给定名称创建一个输入参数，并将它添加到此 Request 对象中。

abstract  Any

Request.add_named_inout_arg(String name)
将具有给定名称的输入/输出参数添加到此 Request 对象中。

abstract  Any

Request.add_named_out_arg(String name)
将具有给定名称的输出参数添加到此 Request 对象中。

abstract  NamedValue

NVList.add_value(String item_name, Any val, int flags)
创建一个新的 NamedValue 对象，使用给定名称、值和标志初始化该对象，并将它添加到此 NVList 对象的末尾。

abstract  void

ContextList.add(String ctx)
将 String 对象添加到此 ContextList 对象中。

TypeCode

ORB.create_abstract_interface_tc(String id, String name)
为 IDL 抽象接口创建一个 TypeCode 对象。

abstract  TypeCode

ORB.create_alias_tc(String id, String name, TypeCode original_type)
创建一个表示 IDL alias 的 TypeCode 对象 (typedef)。

abstract  Context

Context.create_child(String child_ctx_name)
创建一个 Context 对象，使用给定字符串作为其名称，并将此 Context 对象设置为其父对象。

abstract  TypeCode

ORB.create_enum_tc(String id, String name, String[] members)
创建一个表示 IDL enum 的 TypeCode 对象。

abstract  TypeCode

ORB.create_enum_tc(String id, String name, String[] members)
创建一个表示 IDL enum 的 TypeCode 对象。

abstract  TypeCode

ORB.create_exception_tc(String id, String name, StructMember[] members)
创建一个表示 IDL exception 的 TypeCode 对象。

abstract  TypeCode

ORB.create_interface_tc(String id, String name)
创建一个表示 IDL interface 的 TypeCode 对象。

abstract  NamedValue

ORB.create_named_value(String s, Any any, int flags)
使用给定名称、值和参数模式标志创建一个 NamedValue 对象。

TypeCode

ORB.create_native_tc(String id, String name)
为 IDL native 类型创建一个 TypeCode 对象。

TypeCode

ORB.create_recursive_tc(String id)
创建一个递归 TypeCode 对象，在创建包含递归的 TypeCodes 期间，该对象充当具体 TypeCode 的占位符。

abstract  TypeCode

ORB.create_struct_tc(String id, String name, StructMember[] members)
创建一个表示 IDL struct 的 TypeCode 对象。

abstract  TypeCode

ORB.create_union_tc(String id, String name, TypeCode discriminator_type, UnionMember[] members)
创建一个表示 IDL union 的 TypeCode 对象。

TypeCode

ORB.create_value_box_tc(String id, String name, TypeCode boxed_type)
为 IDL value box 类型创建一个 TypeCode 对象。

TypeCode

ORB.create_value_tc(String id, String name, short type_modifier, TypeCode concrete_base, ValueMember[] members)
为 IDL value 类型创建一个 TypeCode 对象。

abstract  void

Context.delete_values(String propname)
从此 Context 对象中删除 name 字段与给定属性名称匹配的 NamedValue 对象。

abstract  NVList

Context.get_values(String start_scope, int op_flags, String pattern)
检索 name 字段与给定名称或名称模式匹配的 NamedValue 对象。

static ORB

ORB.init(String[] args, Properties props)
为独立的应用程序创建一个新的 ORB 实例。

abstract  void

Any.insert_string(String s)
将给定 String 对象插入此 Any 对象的 value 字段。

void

DynAny.insert_string(String value)
已过时。 插入给定 String 对象作为此 DynAny 对象的值。

abstract  void

Any.insert_wstring(String s)
将给定 String 对象插入此 Any 对象的 value 字段。

void

DynAny.insert_wstring(String value)
已过时。 插入给定 String 作为此 DynAny 对象的值。

static void

FieldNameHelper.insert(Any a, String that)

static void

IdentifierHelper.insert(Any a, String that)

static void

RepositoryIdHelper.insert(Any a, String that)

static void

StringValueHelper.insert(Any a, String that)

static void

VersionSpecHelper.insert(Any a, String that)

static void

WStringValueHelper.insert(Any a, String that)

static void

StringSeqHelper.insert(Any a, String[] that)

static void

WStringSeqHelper.insert(Any a, String[] that)

void

DynUnion.member_name(String arg)
已过时。 允许分配此 union 成员的名称。

abstract  Object

ORB.resolve_initial_references(String object_name)
根据可用初始服务名称集解析特定对象引用。

abstract  void

Context.set_one_value(String propname, Any propvalue)
创建一个 NamedValue 对象，并将它添加到此 Context 对象中。

protected abstract  void

ORB.set_parameters(String[] args, Properties props)
允许使用给定的参数和属性初始化 ORB 实现。

abstract  Object

ORB.string_to_object(String str)
将方法 object_to_string 生成的字符串转换回 CORBA 对象引用。

void

DynEnum.value_as_string(String arg)
已过时。 设置此 DynEnum 中的特定 enum。

void

DataOutputStream.write_string(String value)
将 IDL string 值写入输出流。

void

DataOutputStream.write_wstring(String value)
将 IDL 宽字符串值（以 Java String 的形式表示）写入输出流。

static void

FieldNameHelper.write(OutputStream ostream, String value)

static void

IdentifierHelper.write(OutputStream ostream, String value)

static void

RepositoryIdHelper.write(OutputStream ostream, String value)

static void

StringValueHelper.write(OutputStream ostream, String value)

static void

VersionSpecHelper.write(OutputStream ostream, String value)

static void

WStringValueHelper.write(OutputStream ostream, String value)

static void

StringSeqHelper.write(OutputStream ostream, String[] value)

static void

WStringSeqHelper.write(OutputStream ostream, String[] value)

参数类型为 String 的 org.omg.CORBA 中的构造方法

ACTIVITY_COMPLETED(String detailMessage)
使用指定消息构造 ACTIVITY_COMPLETED 异常。

ACTIVITY_COMPLETED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_COMPLETED 异常。

ACTIVITY_REQUIRED(String detailMessage)
使用指定消息构造一个 ACTIVITY_REQUIRED 异常。

ACTIVITY_REQUIRED(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造 ACTIVITY_REQUIRED 异常。

BAD_CONTEXT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_CONTEXT 异常。

BAD_CONTEXT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_CONTEXT 异常。

BAD_INV_ORDER(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_INV_ORDER 异常。

BAD_INV_ORDER(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_INV_ORDER 异常。

BAD_OPERATION(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_OPERATION 异常。

BAD_OPERATION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_OPERATION 异常。

BAD_PARAM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_PARAM 异常。

BAD_PARAM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_PARAM 异常。

BAD_QOS(String detailMessage)
使用指定消息构造一个 BAD_QOS 异常。

BAD_QOS(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 BAD_QOS 异常。

BAD_TYPECODE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 BAD_TYPECODE 异常。

BAD_TYPECODE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 BAD_TYPECODE 异常。

Bounds(String reason)
构造带指定详细消息的 Bounds。

CODESET_INCOMPATIBLE(String detailMessage)
使用指定消息构造一个 CODESET_INCOMPATIBLE 异常。

CODESET_INCOMPATIBLE(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 CODESET_INCOMPATIBLE 异常。

COMM_FAILURE(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 COMM_FAILURE 异常。

COMM_FAILURE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 COMM_FAILURE 异常。

DATA_CONVERSION(String s)
使用指定详细消息构造一个 DATA_CONVERSION 异常。

DATA_CONVERSION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 DATA_CONVERSION 异常。

FREE_MEM(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 FREE_MEM 异常。

FREE_MEM(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 FREE_MEM 异常。

IMP_LIMIT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 IMP_LIMIT 异常。

IMP_LIMIT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 IMP_LIMIT 异常。

INITIALIZE(String s)
使用指定详细消息、次要代码 0 和完成状态 CompletionStatus.COMPLETED_NO 构造一个 INITIALIZE 异常。

INITIALIZE(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INITIALIZE 异常。

INTERNAL(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INTERNAL 异常。

INTERNAL(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTERNAL 异常。

INTF_REPOS(String s)
使用指定详细消息构造一个 INTF_REPOS 异常。

INTF_REPOS(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INTF_REPOS 异常。

INV_FLAG(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_FLAG 异常。

INV_FLAG(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_FLAG 异常。

INV_IDENT(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_IDENT 异常。

INV_IDENT(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_IDENT 异常。

INV_OBJREF(String s)
使用指定详细消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_OBJREF 异常。

INV_OBJREF(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INV_OBJREF 异常。

INV_POLICY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 INV_POLICY 异常。

INV_POLICY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 INV_POLICY 异常。

INVALID_ACTIVITY(String detailMessage)
使用指定消息构造一个 INVALID_ACTIVITY 异常。

INVALID_ACTIVITY(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 INVALID_ACTIVITY 异常。

INVALID_TRANSACTION(String s)
使用指定消息构造一个 INVALID_TRANSACTION 异常。

INVALID_TRANSACTION(String s, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 INVALID_TRANSACTION 异常。

MARSHAL(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 MARSHAL 异常。

MARSHAL(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 MARSHAL 异常。

NameValuePair(String __id, Any __value)
构造一个 NameValuePair 对象，该对象将给定名称与给定 org.omg.CORBA.Any 对象关联。

NO_IMPLEMENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_IMPLEMENT 异常。

NO_IMPLEMENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_IMPLEMENT 异常。

NO_MEMORY(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_MEMORY 异常。

NO_MEMORY(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_MEMORY 异常。

NO_PERMISSION(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_PERMISSION 异常。

NO_PERMISSION(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_PERMISSION 异常。

NO_RESOURCES(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESOURCES 异常。

NO_RESOURCES(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESOURCES 异常。

NO_RESPONSE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 NO_RESPONSE 异常。

NO_RESPONSE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 NO_RESPONSE 异常。

OBJ_ADAPTER(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJ_ADAPTER 异常。

OBJ_ADAPTER(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJ_ADAPTER 异常。

OBJECT_NOT_EXIST(String s)
使用指定描述、次要代码 0 和完成状态 COMPLETED_NO 构造一个 OBJECT_NOT_EXIST 异常。

OBJECT_NOT_EXIST(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 OBJECT_NOT_EXIST 异常。

PERSIST_STORE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 PERSIST_STORE 异常。

PERSIST_STORE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 PERSIST_STORE 异常。

PolicyError(String reason_string, short __reason)
构造一个 PolicyError 用户异常，并使用给定原因详细消息和原因代码初始化。

REBIND(String detailMessage)
使用指定消息构造一个 REBIND 异常。

REBIND(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 REBIND 异常。

StringHolder(String initial)
构造一个新的 StringHolder 对象，并使用给定 String 初始化其 value 字段。

StringSeqHolder(String[] initialValue)

StructMember(String __name, TypeCode __type, IDLType __type_def)
构造一个 StructMember 对象，并使用给定值进行初始化。

SystemException(String reason, int minor, CompletionStatus completed)
使用指定详细消息、次要代码和完成状态构造一个 SystemException 异常。

TIMEOUT(String detailMessage)
使用指定消息构造一个 TIMEOUT 异常。

TIMEOUT(String detailMessage, int minorCode, CompletionStatus completionStatus)
使用指定消息、次要代码和完成状态构造一个 TIMEOUT 异常。

TRANSACTION_MODE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_MODE 异常。

TRANSACTION_MODE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_MODE 异常。

TRANSACTION_REQUIRED(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_REQUIRED 异常。

TRANSACTION_REQUIRED(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_REQUIRED 异常。

TRANSACTION_ROLLEDBACK(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_ROLLEDBACK 异常。

TRANSACTION_ROLLEDBACK(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_ROLLEDBACK 异常。

TRANSACTION_UNAVAILABLE(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSACTION_UNAVAILABLE 异常。

TRANSACTION_UNAVAILABLE(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSACTION_UNAVAILABLE 异常。

TRANSIENT(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 TRANSIENT 异常。

TRANSIENT(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 TRANSIENT 异常。

UnionMember(String __name, Any __label, TypeCode __type, IDLType __type_def)
构造一个新的 UnionMember 对象，将其字段初始化为给定值。

UNKNOWN(String s)
使用指定描述消息、次要代码 0 和完成状态 COMPLETED_NO 构造一个 UNKNOWN 异常。

UNKNOWN(String s, int minor, CompletionStatus completed)
使用指定描述消息、次要代码和完成状态构造一个 UNKNOWN 异常。

UserException(String reason)
构造带详细消息的 UserException 对象。

ValueMember(String __name, String __id, String __defined_in, String __version, TypeCode __type, IDLType __type_def, short __access)
构造一个 ValueMember 对象，使用给定值进行初始化。

WrongTransaction(String reason)
使用给定详细消息构造一个 WrongTransaction 对象。

WStringSeqHolder(String[] initialValue)

org.omg.CORBA_2_3 中 String 的使用

参数类型为 String 的 org.omg.CORBA_2_3 中的方法

Object

ORB.get_value_def(String repid)

ValueFactory

ORB.lookup_value_factory(String id)

ValueFactory

ORB.register_value_factory(String id, ValueFactory factory)

void

ORB.unregister_value_factory(String id)

org.omg.CORBA_2_3.portable 中 String 的使用

返回 String 的 org.omg.CORBA_2_3.portable 中的方法

String

ObjectImpl._get_codebase()
返回此对象引用的代码基。

String

Delegate.get_codebase(Object self)
返回提供的对象引用的代码基。

参数类型为 String 的 org.omg.CORBA_2_3.portable 中的方法

Serializable

InputStream.read_value(String rep_id)
从输入流解组值类型。

void

OutputStream.write_value(Serializable value, String repository_id)
将值类型编组到输出流中。

org.omg.CORBA.DynAnyPackage 中 String 的使用

参数类型为 String 的 org.omg.CORBA.DynAnyPackage 中的构造方法

Invalid(String reason)
构造一个 Invalid 对象。

InvalidSeq(String reason)
构造一个 InvalidSeq 对象。

InvalidValue(String reason)
构造一个 InvalidValue 对象。

TypeMismatch(String reason)
构造一个 TypeMismatch 对象。

org.omg.CORBA.ORBPackage 中 String 的使用

参数类型为 String 的 org.omg.CORBA.ORBPackage 中的构造方法

InconsistentTypeCode(String reason)
构造一个带有指定原因信息的 InconsistentTypeCode 用户异常。

InvalidName(String reason)
构造一个带有指定原因消息的 InvalidName 异常。

org.omg.CORBA.portable 中 String 的使用

返回 String 的 org.omg.CORBA.portable 中的方法

abstract  String[]

ObjectImpl._ids()
获得包含此 ObjectImpl 对象所支持的存储库标识符的字符串数组。

String[]

ValueBase._truncatable_ids()
提供可截断的存储库 id。

String

BoxedValueHelper.get_id()

String

ApplicationException.getId()
返回异常的 CORBA 存储库 ID 而不会将其从异常输入流中移除。

abstract  String

InputStream.read_string()
从此输入流中读取一个 string 值。

abstract  String

InputStream.read_wstring()
从此输入流中读取一个 wide string 值。

String

ObjectImpl.toString()
返回表示此 ObjectImpl 对象的 String 对象。

String

Delegate.toString(Object self)
提供重写委托 CORBA 对象的 toString() 方法的实现。

参数类型为 String 的 org.omg.CORBA.portable 中的方法

Request

ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result)
创建一个 Request 对象，使其包含给定上下文、方法、参数列表，以及用于结果的容器。

Request

ObjectImpl._create_request(Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exceptions, ContextList contexts)
创建一个 Request 对象，使其包含给定的上下文、方法、参数列表、结果容器、异常，以及解析上下文字符串时将使用的属性名列表。

OutputStream

InvokeHandler._invoke(String method, InputStream input, ResponseHandler handler)
由 ORB 调用来调度对 servant 的请求。

boolean

ObjectImpl._is_a(String repository_id)
检查给定存储库标识符标识的对象是否是 ObjectImpl 对象。

Request

ObjectImpl._request(String operation)
创建一个 Request 对象，使其包含可用于动态调用接口 (Dynamic Invocation Interface) 的给定方法。

OutputStream

ObjectImpl._request(String operation, boolean responseExpected)
返回一个 OutputStream 对象，该对象用于编组给定方法的参数。

ServantObject

ObjectImpl._servant_preinvoke(String operation, Class expectedType)
返回对本地 servant 的 Java 引用，该引用应该被用来发送对指定方法的请求。

abstract  Request

Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result)
创建在动态调用接口中使用的 Request 实例。

abstract  Request

Delegate.create_request(Object obj, Context ctx, String operation, NVList arg_list, NamedValue result, ExceptionList exclist, ContextList ctxlist)
创建在动态调用接口中使用的 Request 实例。

abstract  boolean

Delegate.is_a(Object obj, String repository_id)
检查对象引用是否是给定接口的实例。

abstract  Request

Delegate.request(Object obj, String operation)
创建在动态调用接口 (Dynamic Invocation Interface) 中使用的 Request 实例。

OutputStream

Delegate.request(Object self, String operation, boolean responseExpected)
request 由 stub 调用，以获取用于编组参数的 OutputStream。

ServantObject

Delegate.servant_preinvoke(Object self, String operation, Class expectedType)
返回对应该用作此请求的 servant 的 Java 引用。

void

ValueOutputStream.start_value(String rep_id)
start_value 方法结束任何当前开启的程序块，写入嵌套自定义 valuetype 的 valuetype 头（使用 null 代码基和指定的存储库 ID），并将 valuetype 嵌套层次加 1。

abstract  void

OutputStream.write_string(String value)
将一个 string 值写入此流。

abstract  void

OutputStream.write_wstring(String value)
将一个 wide string 值写入此流。

参数类型为 String 的 org.omg.CORBA.portable 中的构造方法

ApplicationException(String id, InputStream ins)
根据异常的 CORBA 存储库 ID 和一个输入流（可从中读取异常数据作为其参数）构造 ApplicationException。

org.omg.CORBA.TypeCodePackage 中 String 的使用

参数类型为 String 的 org.omg.CORBA.TypeCodePackage 中的构造方法

BadKind(String reason)
构造一个带有指定原因消息的 BadKind 异常。

Bounds(String reason)
构造一个带有指定原因信息的 Bounds 异常。

org.omg.CosNaming 中 String 的使用

声明为 String 的 org.omg.CosNaming 中的字段

String

NameComponent.id

String

NameComponent.kind

返回 String 的 org.omg.CosNaming 中的方法

String[]

BindingIteratorPOA._all_interfaces(POA poa, byte[] objectId)

String[]

NamingContextExtPOA._all_interfaces(POA poa, byte[] objectId)

String[]

NamingContextPOA._all_interfaces(POA poa, byte[] objectId)

String[]

_BindingIteratorImplBase._ids()

String[]

_BindingIteratorStub._ids()

String[]

_NamingContextExtStub._ids()

String[]

_NamingContextImplBase._ids()

String[]

_NamingContextStub._ids()

static String

IstringHelper.extract(Any a)

static String

BindingHelper.id()

static String

BindingIteratorHelper.id()

static String

BindingListHelper.id()

static String

BindingTypeHelper.id()

static String

IstringHelper.id()

static String

NameComponentHelper.id()

static String

NameHelper.id()

static String

NamingContextExtHelper.id()

static String

NamingContextHelper.id()

static String

IstringHelper.read(InputStream istream)

String

NamingContextExtOperations.to_string(NameComponent[] n)
此操作根据 Name 组件数组创建字符串化的名称。

String

_NamingContextExtStub.to_string(NameComponent[] n)
此操作从 Name 组件数组创建字符串化的名称。

String

NamingContextExtOperations.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

String

_NamingContextExtStub.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

参数类型为 String 的 org.omg.CosNaming 中的方法

OutputStream

BindingIteratorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

OutputStream

NamingContextExtPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

OutputStream

NamingContextPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

static void

IstringHelper.insert(Any a, String that)

Object

NamingContextExtOperations.resolve_str(String sn)
此操作将“字符串化的”名称解析为对象引用。

Object

_NamingContextExtStub.resolve_str(String sn)
此操作将“字符串化的”名称解析为对象引用。

NameComponent[]

NamingContextExtOperations.to_name(String sn)
此操作将“字符串化的名称”转换为等效的“名称组件”数组。

NameComponent[]

_NamingContextExtStub.to_name(String sn)
此操作将“字符串化的名称”转换为等效的“名称组件”数组。

String

NamingContextExtOperations.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

String

_NamingContextExtStub.to_url(String addr, String sn)
此操作根据对象的“字符串化的名称”创建基于 URL 的 "iiopname://" 格式的名称。

static void

IstringHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.CosNaming 中的构造方法

NameComponent(String _id, String _kind)

org.omg.CosNaming.NamingContextExtPackage 中 String 的使用

返回 String 的 org.omg.CosNaming.NamingContextExtPackage 中的方法

static String

AddressHelper.extract(Any a)

static String

StringNameHelper.extract(Any a)

static String

URLStringHelper.extract(Any a)

static String

AddressHelper.id()

static String

InvalidAddressHelper.id()

static String

StringNameHelper.id()

static String

URLStringHelper.id()

static String

AddressHelper.read(InputStream istream)

static String

StringNameHelper.read(InputStream istream)

static String

URLStringHelper.read(InputStream istream)

参数类型为 String 的 org.omg.CosNaming.NamingContextExtPackage 中的方法

static void

AddressHelper.insert(Any a, String that)

static void

StringNameHelper.insert(Any a, String that)

static void

URLStringHelper.insert(Any a, String that)

static void

AddressHelper.write(OutputStream ostream, String value)

static void

StringNameHelper.write(OutputStream ostream, String value)

static void

URLStringHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.CosNaming.NamingContextExtPackage 中的构造方法

InvalidAddress(String $reason)

org.omg.CosNaming.NamingContextPackage 中 String 的使用

返回 String 的 org.omg.CosNaming.NamingContextPackage 中的方法

static String

AlreadyBoundHelper.id()

static String

CannotProceedHelper.id()

static String

InvalidNameHelper.id()

static String

NotEmptyHelper.id()

static String

NotFoundHelper.id()

static String

NotFoundReasonHelper.id()

参数类型为 String 的 org.omg.CosNaming.NamingContextPackage 中的构造方法

AlreadyBound(String $reason)

CannotProceed(String $reason, NamingContext _cxt, NameComponent[] _rest_of_name)

InvalidName(String $reason)

NotEmpty(String $reason)

NotFound(String $reason, NotFoundReason _why, NameComponent[] _rest_of_name)

org.omg.DynamicAny 中 String 的使用

声明为 String 的 org.omg.DynamicAny 中的字段

String

NameDynAnyPair.id
与 DynAny 关联的名称。

String

NameValuePair.id
与 Any 有关联的名称。

返回 String 的 org.omg.DynamicAny 中的方法

String[]

_DynAnyFactoryStub._ids()

String[]

_DynAnyStub._ids()

String[]

_DynArrayStub._ids()

String[]

_DynEnumStub._ids()

String[]

_DynFixedStub._ids()

String[]

_DynSequenceStub._ids()

String[]

_DynStructStub._ids()

String[]

_DynUnionStub._ids()

String[]

_DynValueStub._ids()

String

DynStructOperations.current_member_name()
返回当前位置的成员的名称。

String

DynValueOperations.current_member_name()
返回当前位置上的成员的名称。

String

_DynStructStub.current_member_name()
返回当前位置上的成员的名称。

String

_DynValueStub.current_member_name()
返回当前位置上成员的名称。

static String

FieldNameHelper.extract(Any a)

String

DynEnumOperations.get_as_string()
以 IDL 标识符的形式返回 DynEnum 的值。

String

_DynEnumStub.get_as_string()
以 IDL 标识符的形式返回 DynEnum 的值。

String

DynAnyOperations.get_string()
从此 DynAny 中提取 string 值。

String

_DynAnyStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynArrayStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynEnumStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynFixedStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynSequenceStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynStructStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynUnionStub.get_string()
从此 DynAny 中提取 string 值。

String

_DynValueStub.get_string()
从此 DynAny 中提取 string 值。

String

DynFixedOperations.get_value()
返回 DynFixed 的值。

String

_DynFixedStub.get_value()
返回 DynFixed 的值。

String

DynAnyOperations.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynAnyStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynArrayStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynEnumStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynFixedStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynSequenceStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynStructStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynUnionStub.get_wstring()
从此 DynAny 中提取 string 值。

String

_DynValueStub.get_wstring()
从此 DynAny 中提取 string 值。

static String

AnySeqHelper.id()

static String

DynAnyFactoryHelper.id()

static String

DynAnyHelper.id()

static String

DynAnySeqHelper.id()

static String

DynArrayHelper.id()

static String

DynEnumHelper.id()

static String

DynFixedHelper.id()

static String

DynSequenceHelper.id()

static String

DynStructHelper.id()

static String

DynUnionHelper.id()

static String

DynValueHelper.id()

static String

FieldNameHelper.id()

static String

NameDynAnyPairHelper.id()

static String

NameDynAnyPairSeqHelper.id()

static String

NameValuePairHelper.id()

static String

NameValuePairSeqHelper.id()

String

DynUnionOperations.member_name()
返回当前活动成员的名称。

String

_DynUnionStub.member_name()
返回当前活动成员的名称。

static String

FieldNameHelper.read(InputStream istream)

参数类型为 String 的 org.omg.DynamicAny 中的方法

void

DynAnyOperations.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynAnyStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynArrayStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynEnumStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynFixedStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynSequenceStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynStructStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynUnionStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

_DynValueStub.insert_string(String value)
将 string 值插入 DynAny 中。

void

DynAnyOperations.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynAnyStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynArrayStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynEnumStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynFixedStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynSequenceStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynStructStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynUnionStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

void

_DynValueStub.insert_wstring(String value)
将 string 值插入 DynAny 中。

static void

FieldNameHelper.insert(Any a, String that)

void

DynEnumOperations.set_as_string(String value)
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。

void

_DynEnumStub.set_as_string(String value)
将 DynEnum 的值设置为枚举的值，该枚举值的 IDL 标识符已使用值参数传入。

boolean

DynFixedOperations.set_value(String val)
设置 DynFixed 的值。

boolean

_DynFixedStub.set_value(String val)
设置 DynFixed 的值。

static void

FieldNameHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.DynamicAny 中的构造方法

NameDynAnyPair(String _id, DynAny _value)

NameValuePair(String _id, Any _value)

org.omg.DynamicAny.DynAnyFactoryPackage 中 String 的使用

返回 String 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的方法

static String

InconsistentTypeCodeHelper.id()

参数类型为 String 的 org.omg.DynamicAny.DynAnyFactoryPackage 中的构造方法

InconsistentTypeCode(String $reason)

org.omg.DynamicAny.DynAnyPackage 中 String 的使用

返回 String 的 org.omg.DynamicAny.DynAnyPackage 中的方法

static String

InvalidValueHelper.id()

static String

TypeMismatchHelper.id()

参数类型为 String 的 org.omg.DynamicAny.DynAnyPackage 中的构造方法

InvalidValue(String $reason)

TypeMismatch(String $reason)

org.omg.IOP 中 String 的使用

声明为 String 的 org.omg.IOP 中的字段

String

IOR.type_id
以 String 形式表示的类型 id。

返回 String 的 org.omg.IOP 中的方法

static String

CodecFactoryHelper.id()

static String

ComponentIdHelper.id()

static String

IORHelper.id()

static String

MultipleComponentProfileHelper.id()

static String

ProfileIdHelper.id()

static String

ServiceContextHelper.id()

static String

ServiceContextListHelper.id()

static String

ServiceIdHelper.id()

static String

TaggedComponentHelper.id()

static String

TaggedProfileHelper.id()

参数类型为 String 的 org.omg.IOP 中的构造方法

IOR(String _type_id, TaggedProfile[] _profiles)

org.omg.IOP.CodecFactoryPackage 中 String 的使用

返回 String 的 org.omg.IOP.CodecFactoryPackage 中的方法

static String

UnknownEncodingHelper.id()

参数类型为 String 的 org.omg.IOP.CodecFactoryPackage 中的构造方法

UnknownEncoding(String $reason)

org.omg.IOP.CodecPackage 中 String 的使用

返回 String 的 org.omg.IOP.CodecPackage 中的方法

static String

FormatMismatchHelper.id()

static String

InvalidTypeForEncodingHelper.id()

static String

TypeMismatchHelper.id()

参数类型为 String 的 org.omg.IOP.CodecPackage 中的构造方法

FormatMismatch(String $reason)

InvalidTypeForEncoding(String $reason)

TypeMismatch(String $reason)

org.omg.Messaging 中 String 的使用

返回 String 的 org.omg.Messaging 中的方法

static String

SyncScopeHelper.id()

org.omg.PortableInterceptor 中 String 的使用

返回 String 的 org.omg.PortableInterceptor 中的方法

String[]

ObjectReferenceTemplate.adapter_name()

String[]

ServerRequestInfoOperations.adapter_name()
返回字符串序列，这些字符串标识正处理此请求的对象适配器实例。

String[]

ORBInitInfoOperations.arguments()
返回传递给 ORB.init 的参数。

String[]

RequestInfoOperations.contexts()
返回一个 String 对象数组，这些对象描述可以在此操作调用上传递的上下文。

static String[]

AdapterNameHelper.extract(Any a)

static String

ORBIdHelper.extract(Any a)

static String

ServerIdHelper.extract(Any a)

static String

AdapterManagerIdHelper.id()

static String

AdapterNameHelper.id()

static String

AdapterStateHelper.id()

static String

CurrentHelper.id()

static String

ForwardRequestHelper.id()

static String

IORInterceptor_3_0Helper.id()

static String

InvalidSlotHelper.id()

static String

ORBIdHelper.id()

static String

ObjectIdHelper.id()

static String

ObjectReferenceFactoryHelper.id()

static String

ObjectReferenceTemplateHelper.id()

static String

ObjectReferenceTemplateSeqHelper.id()

static String

ServerIdHelper.id()

String

InterceptorOperations.name()
返回 interceptor 的名称。

String[]

RequestInfoOperations.operation_context()
返回一个 String 对象数组，这些对象包含将在请求上发送上下文。

String

RequestInfoOperations.operation()
返回将被调用的操作的名称。

String

ORBInitInfoOperations.orb_id()
返回将被初始化的 ORB 的 ID。

String

ObjectReferenceTemplate.orb_id()

String

ServerRequestInfoOperations.orb_id()
返回用于创建 ORB 的 ID。

static String[]

AdapterNameHelper.read(InputStream istream)

static String

ORBIdHelper.read(InputStream istream)

static String

ServerIdHelper.read(InputStream istream)

String

ClientRequestInfoOperations.received_exception_id()
返回将向客户端返回的异常的存储库 id。

String

ObjectReferenceTemplate.server_id()

String

ServerRequestInfoOperations.server_id()
返回使用 -ORBServerId 参数的 ORB::init 上指定的服务器 ID。

String

ServerRequestInfoOperations.target_most_derived_interface()
返回 servant 最终派生接口的存储库 id。

参数类型为 String 的 org.omg.PortableInterceptor 中的方法

static void

ORBIdHelper.insert(Any a, String that)

static void

ServerIdHelper.insert(Any a, String that)

static void

AdapterNameHelper.insert(Any a, String[] that)

Object

ObjectReferenceFactory.make_object(String repositoryId, byte[] object_id)
make_object 根据此模板中的数据，使用给定的存储库 ID 和对象 ID 创建 CORBA 对象引用。

void

ORBInitInfoOperations.register_initial_reference(String id, Object obj)
等同于 ORB.register_initial_reference。

Object

ORBInitInfoOperations.resolve_initial_references(String id)
等同于 ORB.resolve_initial_references。

boolean

ServerRequestInfoOperations.target_is_a(String id)
如果 servant 是给定的存储库 id，则返回 true；若不是则返回 false。

static void

ORBIdHelper.write(OutputStream ostream, String value)

static void

ServerIdHelper.write(OutputStream ostream, String value)

static void

AdapterNameHelper.write(OutputStream ostream, String[] value)

参数类型为 String 的 org.omg.PortableInterceptor 中的构造方法

ForwardRequest(String $reason, Object _forward)

InvalidSlot(String $reason)

org.omg.PortableInterceptor.ORBInitInfoPackage 中 String 的使用

声明为 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的字段

String

DuplicateName.name
已为其注册了 interceptor 的名称。

返回 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法

static String

ObjectIdHelper.extract(Any a)

static String

DuplicateNameHelper.id()

static String

InvalidNameHelper.id()

static String

ObjectIdHelper.id()

static String

ObjectIdHelper.read(InputStream istream)

参数类型为 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的方法

static void

ObjectIdHelper.insert(Any a, String that)

static void

ObjectIdHelper.write(OutputStream ostream, String value)

参数类型为 String 的 org.omg.PortableInterceptor.ORBInitInfoPackage 中的构造方法

DuplicateName(String _name)

DuplicateName(String $reason, String _name)

InvalidName(String $reason)

org.omg.PortableServer 中 String 的使用

返回 String 的 org.omg.PortableServer 中的方法

abstract  String[]

Servant._all_interfaces(POA poa, byte[] objectId)
ORB 使用此操作从 servant 获取完整的类型信息。

String[]

ServantActivatorPOA._all_interfaces(POA poa, byte[] objectId)

String[]

ServantLocatorPOA._all_interfaces(POA poa, byte[] objectId)

String[]

_ServantActivatorStub._ids()

String[]

_ServantLocatorStub._ids()

static String

CurrentHelper.id()

static String

ForwardRequestHelper.id()

static String

POAHelper.id()

static String

ServantActivatorHelper.id()

static String

ServantLocatorHelper.id()

String

POAOperations.the_name()
此属性标识相对于其父 POA 的 POA。

参数类型为 String 的 org.omg.PortableServer 中的方法

OutputStream

ServantActivatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

OutputStream

ServantLocatorPOA._invoke(String $method, InputStream in, ResponseHandler $rh)

boolean

Servant._is_a(String repository_id)
查看指定的 repository_id 是否存在于 _all_interfaces() 返回的列表，或者其是否是一般 CORBA 对象的 repository_id。

POA

POAOperations.create_POA(String adapter_name, POAManager a_POAManager, Policy[] policies)
此操作创建一个新的 POA 作为目标 POA 的子 POA。

Object

POAOperations.create_reference_with_id(byte[] oid, String intf)
此操作创建一个对象引用，该引用封装指定的 Object Id 和接口存储库 Id 值。

Object

POAOperations.create_reference(String intf)
此操作创建一个对象引用，该引用封装 POA 生成的 Object Id 值和指定的接口存储库 id。

POA

POAOperations.find_POA(String adapter_name, boolean activate_it)
如果目标 POA 是具有指定名称的子 POA（相对于目标 POA）的父 POA，则返回该子 POA。

void

ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

void

_ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

Servant

ServantLocatorOperations.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
此操作用来获取一个 servant，该 servant 将用来处理导致预调用 preinvoke 的请求。

Servant

_ServantLocatorStub.preinvoke(byte[] oid, POA adapter, String operation, CookieHolder the_cookie)
此操作用来获取一个 servant，该 servant 将用来处理导致调用 preinvoke 的请求。

boolean

AdapterActivatorOperations.unknown_adapter(POA parent, String name)
在 ORB 接收对象引用的请求时，如果该对象引用定义不存在的目标 POA，则将调用此操作。

参数类型为 String 的 org.omg.PortableServer 中的构造方法

ForwardRequest(String $reason, Object _forward_reference)

org.omg.PortableServer.CurrentPackage 中 String 的使用

返回 String 的 org.omg.PortableServer.CurrentPackage 中的方法

static String

NoContextHelper.id()

参数类型为 String 的 org.omg.PortableServer.CurrentPackage 中的构造方法

NoContext(String $reason)

org.omg.PortableServer.POAManagerPackage 中 String 的使用

返回 String 的 org.omg.PortableServer.POAManagerPackage 中的方法

static String

AdapterInactiveHelper.id()

参数类型为 String 的 org.omg.PortableServer.POAManagerPackage 中的构造方法

AdapterInactive(String $reason)

org.omg.PortableServer.POAPackage 中 String 的使用

返回 String 的 org.omg.PortableServer.POAPackage 中的方法

static String

AdapterAlreadyExistsHelper.id()

static String

AdapterNonExistentHelper.id()

static String

InvalidPolicyHelper.id()

static String

NoServantHelper.id()

static String

ObjectAlreadyActiveHelper.id()

static String

ObjectNotActiveHelper.id()

static String

ServantAlreadyActiveHelper.id()

static String

ServantNotActiveHelper.id()

static String

WrongAdapterHelper.id()

static String

WrongPolicyHelper.id()

参数类型为 String 的 org.omg.PortableServer.POAPackage 中的构造方法

AdapterAlreadyExists(String $reason)

AdapterNonExistent(String $reason)

InvalidPolicy(String $reason, short _index)

NoServant(String $reason)

ObjectAlreadyActive(String $reason)

ObjectNotActive(String $reason)

ServantAlreadyActive(String $reason)

ServantNotActive(String $reason)

WrongAdapter(String $reason)

WrongPolicy(String $reason)

org.omg.PortableServer.portable 中 String 的使用

参数类型为 String 的 org.omg.PortableServer.portable 中的方法

boolean

Delegate.is_a(Servant Self, String Repository_Id)
此方法查看指定的 repid 是否存在于 _all_interfaces() 返回的列表上，或者该 repid 是否是通用 CORBA 对象的存储库 id。

org.omg.stub.java.rmi 中 String 的使用

返回 String 的 org.omg.stub.java.rmi 中的方法

String[]

_Remote_Stub._ids()
返回对象实现的存储库 id 数组。

org.w3c.dom 中 String 的使用

返回 String 的 org.w3c.dom 中的方法

String

Element.getAttribute(String name)
通过名称获得属性值。

String

Element.getAttributeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 获得属性值。

String

Node.getBaseURI()
此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。

String

ProcessingInstruction.getData()
此处理指令的内容。

String

CharacterData.getData()
实现此接口的节点的字符数据。

String

Document.getDocumentURI()
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。

String

Entity.getInputEncoding()
当实体为外部解析实体时，它是在解析时用于此实体的指定编码的属性。

String

Document.getInputEncoding()
指定解析时此文档使用的编码的属性。

String

DocumentType.getInternalSubset()
以字符串表示的内部子集，如果没有内部子集，则为 null。

String

Node.getLocalName()
返回此节点限定名称的本地部分。

String

DOMError.getMessage()
描述所发生错误的特定于实现的字符串。

String

DocumentType.getName()
DTD 的名称；即紧跟在 DOCTYPE 关键字后面的名称。

String

Attr.getName()
返回此属性的名称。

String

NameList.getName(int index)
返回集合中的第 index 个名称项。

String

Node.getNamespaceURI()
此节点的名称空间 URI；如果它未被指定，则返回 null（参见）。

String

NameList.getNamespaceURI(int index)
返回集合中的第 index 个 namespaceURI 项。

String

Node.getNodeName()
此节点的名称，取决于其类型；参见上表。

String

Node.getNodeValue()
此节点的值，取决于其类型；参见上表。

String

Entity.getNotationName()
对于未解析实体，则为该实体的表示法名称。

String

Node.getPrefix()
此节点的名称空间前缀；如果它未被指定，则为 null。

String

Notation.getPublicId()
此表示法的公共标识符。

String

DocumentType.getPublicId()
外部子集的公共标识符。

String

Entity.getPublicId()
如果已指定，则为与实体相关的公共标识符；否则为 null。

String

Notation.getSystemId()
此表示法的系统标识符。

String

DocumentType.getSystemId()
外部子集的系统标识符。

String

Entity.getSystemId()
如果已指定，则为与实体相关的系统标识符；否则为 null。

String

Element.getTagName()
元素的名称。

String

ProcessingInstruction.getTarget()
此处理指令的目标。

String

Node.getTextContent()
此属性返回此节点及其后代的文本内容。

String

DOMError.getType()
DOMString，指示在 relatedData 中哪个相关数据是所期望的。

String

TypeInfo.getTypeName()
为相关元素或属性声明的类型的名称；如果未知，则为 null。

String

TypeInfo.getTypeNamespace()
为相关元素或属性声明的类型的名称空间；如果该元素没有声明或如果没有名称空间信息可用，则为 null。

String

DOMLocator.getUri()
此定位器指向的 URI；如果没有可用的 URI，则为 null。

String

Attr.getValue()
检索时，该属性值以字符串形式返回。

String

Text.getWholeText()
返回 Text 节点（逻辑上与此节点相邻的节点）的以文档顺序串接的所有文本。

String

Entity.getXmlEncoding()
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体的编码的属性。

String

Document.getXmlEncoding()
作为 XML 声明的一部分，指定此文档编码的属性。

String

Entity.getXmlVersion()
当实体为外部解析实体时，它是作为文本声明的一部分指定此实体版本号的属性。

String

Document.getXmlVersion()
作为 XML 声明 的一部分指定此文档版本号的属性。

String

DOMStringList.item(int index)
返回集合中的第 index 个项。

String

Node.lookupNamespaceURI(String prefix)
从此节点开始，查找与给定前缀相关的名称空间 URI。

String

Node.lookupPrefix(String namespaceURI)
从此节点开始，查找与给定名称空间 URI 相关的前缀。

String

CharacterData.substringData(int offset, int count)
从该节点提取某个范围的数据。

参数类型为 String 的 org.w3c.dom 中的方法

void

CharacterData.appendData(String arg)
将字符串追加到节点的字符数据的结尾。

boolean

DOMConfiguration.canSetParameter(String name, Object value)
检查是否支持将参数设置为特定值。

boolean

DOMStringList.contains(String str)
测试一个字符串是否是此 DOMStringList 的一部分。

boolean

NameList.contains(String str)
测试名称是否是此 NameList 中的一部分。

boolean

NameList.containsNS(String namespaceURI, String name)
测试 namespaceURI/name 对是否是此 NameList 中的一部分。

Attr

Document.createAttribute(String name)
创建给定名称的 Attr。

Attr

Document.createAttributeNS(String namespaceURI, String qualifiedName)
创建给定的限定名称和名称空间 URI 的属性。

CDATASection

Document.createCDATASection(String data)
创建其值为指定字符串的 CDATASection 节点。

Comment

Document.createComment(String data)
创建给定指定字符串的 Comment 节点。

Document

DOMImplementation.createDocument(String namespaceURI, String qualifiedName, DocumentType doctype)
创建具有文档元素的指定类型的 DOM Document 对象。

DocumentType

DOMImplementation.createDocumentType(String qualifiedName, String publicId, String systemId)
创建空 DocumentType 节点。

Element

Document.createElement(String tagName)
创建指定类型的元素。

Element

Document.createElementNS(String namespaceURI, String qualifiedName)
创建给定的限定名称和名称空间 URI 的元素。

EntityReference

Document.createEntityReference(String name)
创建 EntityReference 对象。

ProcessingInstruction

Document.createProcessingInstruction(String target, String data)
创建给定指定名称和数据字符串的 ProcessingInstruction 节点。

Text

Document.createTextNode(String data)
创建给定指定字符串的 Text 节点。

String

Element.getAttribute(String name)
通过名称获得属性值。

Attr

Element.getAttributeNode(String name)
通过名称获得属性节点。

Attr

Element.getAttributeNodeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 获得 Attr 节点。

String

Element.getAttributeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 获得属性值。

DOMImplementation

DOMImplementationSource.getDOMImplementation(String features)
请求支持指定的功能的第一个 DOM 实现的方法。

DOMImplementationList

DOMImplementationSource.getDOMImplementationList(String features)
请求支持指定功能和版本的 DOM 实现的列表的方法，如下所述。

Element

Document.getElementById(String elementId)
返回具有带给定值的 ID 属性的 Element。

NodeList

Element.getElementsByTagName(String name)
以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。

NodeList

Document.getElementsByTagName(String tagname)
按文档顺序返回包含在文档中且具有给定标记名称的所有 Element 的 NodeList。

NodeList

Element.getElementsByTagNameNS(String namespaceURI, String localName)
以文档顺序返回具有给定本地名称和名称空间 URI 的所有后代 Elements 的 NodeList。

NodeList

Document.getElementsByTagNameNS(String namespaceURI, String localName)
以文档顺序返回具有给定本地名称和名称空间 URI 的所有 Elements 的 NodeList。

Object

DOMImplementation.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。

Object

Node.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。

Node

NamedNodeMap.getNamedItem(String name)
检索通过名称指定的节点。

Node

NamedNodeMap.getNamedItemNS(String namespaceURI, String localName)
检索通过本地名称和名称空间 URI 指定的节点。

Object

DOMConfiguration.getParameter(String name)
如果已知，则返回参数的值。

Object

Node.getUserData(String key)
检索与此节点上的某个键相关联的对象。

void

UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst)
每当导入或克隆为其注册此处理程序的节点时，调用此方法。

boolean

Element.hasAttribute(String name)
当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。

boolean

Element.hasAttributeNS(String namespaceURI, String localName)
当具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。

boolean

DOMImplementation.hasFeature(String feature, String version)
测试 DOM 实现是否实现在 DOM Features 中指定的特定特性和版本。

void

CharacterData.insertData(int offset, String arg)
在指定的 16 位单元偏移量位置插入一个字符串。

boolean

Node.isDefaultNamespace(String namespaceURI)
此方法检查指定的 namespaceURI 是否是默认名称空间。

boolean

TypeInfo.isDerivedFrom(String typeNamespaceArg, String typeNameArg, int derivationMethod)
此方法返回引用类型定义（即在其上调用该方法的 TypeInfo）和其他类型定义（即作为参数传递的类型定义）之间是否存在派生。

boolean

Node.isSupported(String feature, String version)
测试 DOM 实现是否实现特定功能，且该功能是否受此节点支持，如下所述。

String

Node.lookupNamespaceURI(String prefix)
从此节点开始，查找与给定前缀相关的名称空间 URI。

String

Node.lookupPrefix(String namespaceURI)
从此节点开始，查找与给定名称空间 URI 相关的前缀。

void

Element.removeAttribute(String name)
通过名称移除一个属性。

void

Element.removeAttributeNS(String namespaceURI, String localName)
通过本地名称和名称空间 URI 移除属性值。

Node

NamedNodeMap.removeNamedItem(String name)
移除通过名称指定的节点。

Node

NamedNodeMap.removeNamedItemNS(String namespaceURI, String localName)
移除通过本地名称和名称空间 URI 指定的节点。

Node

Document.renameNode(Node n, String namespaceURI, String qualifiedName)
重命名 ELEMENT_NODE 或 ATTRIBUTE_NODE 类型的现有节点。

void

CharacterData.replaceData(int offset, int count, String arg)
用指定的字符串替换从指定 16 位单元偏移量起始的字符。

Text

Text.replaceWholeText(String content)
将当前节点和所有逻辑上相邻的文本节点的文本替换为指定的文本。

void

Element.setAttribute(String name, String value)
添加一个新属性。

void

Element.setAttributeNS(String namespaceURI, String qualifiedName, String value)
添加新属性。

void

ProcessingInstruction.setData(String data)
此处理指令的内容。

void

CharacterData.setData(String data)
实现此接口的节点的字符数据。

void

Document.setDocumentURI(String documentURI)
文档的位置，如果未定义或 Document 是使用 DOMImplementation.createDocument 创建的，则为 null。

void

Element.setIdAttribute(String name, boolean isId)
如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。

void

Element.setIdAttributeNS(String namespaceURI, String localName, boolean isId)
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。

void

Node.setNodeValue(String nodeValue)
此节点的值，取决于其类型；参见上表。

void

DOMConfiguration.setParameter(String name, Object value)
设置参数的值。

void

Node.setPrefix(String prefix)
此节点的名称空间前缀；如果未指定，则为 null。

void

Node.setTextContent(String textContent)
此属性返回此节点及其后代的文本内容。

Object

Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

void

Attr.setValue(String value)
检索时，该属性值以字符串形式返回。

void

Document.setXmlVersion(String xmlVersion)
作为 XML 声明 的一部分指定此文档版本号的属性。

参数类型为 String 的 org.w3c.dom 中的构造方法

DOMException(short code, String message)

org.w3c.dom.bootstrap 中 String 的使用

声明为 String 的 org.w3c.dom.bootstrap 中的字段

static String

DOMImplementationRegistry.PROPERTY
指定 DOMImplementationSource 类名称的系统属性。

参数类型为 String 的 org.w3c.dom.bootstrap 中的方法

DOMImplementation

DOMImplementationRegistry.getDOMImplementation(String features)
返回第一个具有所需功能的实现；如果找不到具有所需功能的任何实现，则返回 null。

DOMImplementationList

DOMImplementationRegistry.getDOMImplementationList(String features)
返回支持所需功能的实现列表。

org.w3c.dom.events 中 String 的使用

返回 String 的 org.w3c.dom.events 中的方法

String

MutationEvent.getAttrName()
attrName 指示 DOMAttrModified 事件中已更改的 Attr 节点的名称。

String

MutationEvent.getNewValue()
newValue 指示 DOMAttrModified 事件中 Attr 节点的新值，以及 DOMCharacterDataModified 中 CharacterData 节点的新值。

String

MutationEvent.getPrevValue()
prevValue 指示 DOMAttrModified 事件中 Attr 节点以前的值，以及 DOMCharacterDataModified 事件中 CharacterData 节点以前的值。

String

Event.getType()
事件的名称（不区分大小写）。

参数类型为 String 的 org.w3c.dom.events 中的方法

void

EventTarget.addEventListener(String type, EventListener listener, boolean useCapture)
此方法允许在事件目标上注册事件侦听器。

Event

DocumentEvent.createEvent(String eventType)

void

Event.initEvent(String eventTypeArg, boolean canBubbleArg, boolean cancelableArg)
initEvent 方法用于初始化通过 DocumentEvent 接口创建的 Event 的值。

void

MouseEvent.initMouseEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg, int screenXArg, int screenYArg, int clientXArg, int clientYArg, boolean ctrlKeyArg, boolean altKeyArg, boolean shiftKeyArg, boolean metaKeyArg, short buttonArg, EventTarget relatedTargetArg)
initMouseEvent 方法用于初始化通过 DocumentEvent 接口创建的 MouseEvent 的值。

void

MutationEvent.initMutationEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, Node relatedNodeArg, String prevValueArg, String newValueArg, String attrNameArg, short attrChangeArg)
该 initMutationEvent 方法用于初始化通过 DocumentEvent 接口创建的 MutationEvent 的值。

void

UIEvent.initUIEvent(String typeArg, boolean canBubbleArg, boolean cancelableArg, org.w3c.dom.views.AbstractView viewArg, int detailArg)
initUIEvent 方法用于初始化通过 DocumentEvent 接口创建的 UIEvent 的值。

void

EventTarget.removeEventListener(String type, EventListener listener, boolean useCapture)
此方法允许从事件目标移除事件侦听器。

参数类型为 String 的 org.w3c.dom.events 中的构造方法

EventException(short code, String message)

org.w3c.dom.ls 中 String 的使用

返回 String 的 org.w3c.dom.ls 中的方法

String

LSInput.getBaseURI()
基 URI（请参阅 [IETF RFC 2396]中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。

String

LSInput.getEncoding()
字符编码（如果已知）。

String

LSOutput.getEncoding()
用于输出的字符编码。

String

LSSerializer.getNewLine()
在所写出的 XML 中使用的字符的行尾序列。

String

LSInput.getPublicId()
此输入源的公共标识符。

String

LSInput.getStringData()
要解析的字符串数据。

String

LSInput.getSystemId()
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。

String

LSOutput.getSystemId()
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。

String

LSSerializer.writeToString(Node nodeArg)
像前面对 LSSerializer 接口的一般介绍中所描述的那样序列化指定的节点。

参数类型为 String 的 org.w3c.dom.ls 中的方法

LSParser

DOMImplementationLS.createLSParser(short mode, String schemaType)
创建一个新的 LSParser。

Document

LSParser.parseURI(String uri)
从 URI 引用 [IETF RFC 2396] 标识的位置解析 XML 文档。

LSInput

LSResourceResolver.resolveResource(String type, String namespaceURI, String publicId, String systemId, String baseURI)
允许应用程序解析外部资源。

void

LSInput.setBaseURI(String baseURI)
基 URI（请参阅 [IETF RFC 2396])中的 5.1.4 节），它用来解析绝对 URI 的相对 systemId。

void

LSInput.setEncoding(String encoding)
字符串编码（如果已知）。

void

LSOutput.setEncoding(String encoding)
用于输出的字符编码。

void

LSSerializer.setNewLine(String newLine)
在所写出的 XML 中使用的字符的行尾序列。

void

LSInput.setPublicId(String publicId)
此输入源的公共标识符。

void

LSInput.setStringData(String stringData)
要解析的字符串数据。

void

LSInput.setSystemId(String systemId)
系统标识符，它是此输入源的 URI 引用 [IETF RFC 2396]。

void

LSOutput.setSystemId(String systemId)
系统标识符，它是此输出目标的 URI 引用 [IETF RFC 2396]。

boolean

LSSerializer.writeToURI(Node nodeArg, String uri)
这是一种简便方法，其作用就像使用没有指定编码的 LSOutput 调用 LSSerializer.write，并且 LSOutput.systemId 被设置为 uri 参数。

参数类型为 String 的 org.w3c.dom.ls 中的构造方法

LSException(short code, String message)

org.xml.sax 中 String 的使用

返回 String 的 org.xml.sax 中的方法

String

InputSource.getEncoding()
获取字节流或 URI 的字符编码。

String

Attributes.getLocalName(int index)
通过索引查找属性的本地名称。

String

SAXException.getMessage()
返回此异常的详细消息。

String

AttributeList.getName(int i)
已过时。 返回此列表中属性的名称（根据位置）。

String

SAXParseException.getPublicId()
获取发生异常的实体的公共标识符。

String

Locator.getPublicId()
返回当前文档事件的公共标识符。

String

InputSource.getPublicId()
获取此输入源的公共标识符。

String

Attributes.getQName(int index)
通过索引查找属性的 XML 限定（前缀）名。

String

SAXParseException.getSystemId()
获取发生异常的实体的系统标识符。

String

Locator.getSystemId()
返回当前文档事件的系统标识符。

String

InputSource.getSystemId()
获取此输入源的系统标识符。

String

Attributes.getType(int index)
通过索引查找属性的类型。

String

AttributeList.getType(int i)
已过时。 返回列表中属性的类型（根据位置）。

String

Attributes.getType(String qName)
通过 XML 限定（前缀）名查找属性的类型。

String

AttributeList.getType(String name)
已过时。 返回列表中属性的类型（根据名称）。

String

Attributes.getType(String uri, String localName)
根据名称空间的名称查找属性的类型。

String

Attributes.getURI(int index)
通过索引查找属性的名称空间 URI。

String

Attributes.getValue(int index)
通过索引查找属性的值。

String

AttributeList.getValue(int i)
已过时。 返回列表中属性的值（根据位置）。

String

Attributes.getValue(String qName)
通过 XML 限定（前缀）名查找属性的值。

String

AttributeList.getValue(String name)
已过时。 返回列表中属性的值（根据名称）。

String

Attributes.getValue(String uri, String localName)
根据名称空间的名称查找属性的值。

String

SAXException.toString()
重写 toString 以获取任何嵌入的异常。

参数类型为 String 的 org.xml.sax 中的方法

void

DocumentHandler.endElement(String name)
已过时。 接收元素结束的通知。

void

HandlerBase.endElement(String name)
已过时。 接收元素结束的通知。

void

ContentHandler.endElement(String uri, String localName, String qName)
接收元素结束的通知。

void

ContentHandler.endPrefixMapping(String prefix)
结束前缀 URI 范围的映射。

boolean

XMLReader.getFeature(String name)
查找功能标志的值。

int

Attributes.getIndex(String qName)
通过 XML 限定（前缀）名查找属性的索引。

int

Attributes.getIndex(String uri, String localName)
通过名称空间的名称查找属性的索引。

Object

XMLReader.getProperty(String name)
查找属性的值。

String

Attributes.getType(String qName)
通过 XML 限定（前缀）名查找属性的类型。

String

AttributeList.getType(String name)
已过时。 返回列表中属性的类型（根据名称）。

String

Attributes.getType(String uri, String localName)
根据名称空间的名称查找属性的类型。

String

Attributes.getValue(String qName)
通过 XML 限定（前缀）名查找属性的值。

String

AttributeList.getValue(String name)
已过时。 返回列表中属性的值（根据名称）。

String

Attributes.getValue(String uri, String localName)
根据名称空间的名称查找属性的值。

void

DTDHandler.notationDecl(String name, String publicId, String systemId)
接收注释声明事件的通知。

void

HandlerBase.notationDecl(String name, String publicId, String systemId)
已过时。 接收注释声明的通知。

void

Parser.parse(String systemId)
已过时。 从系统标识符 (URI) 解析 XML 文档。

void

XMLReader.parse(String systemId)
从系统标识符 (URI) 解析 XML 文档。

void

ContentHandler.processingInstruction(String target, String data)
接收处理指令的通知。

void

DocumentHandler.processingInstruction(String target, String data)
已过时。 接收处理指令的通知。

void

HandlerBase.processingInstruction(String target, String data)
已过时。 接收处理指令的通知。

InputSource

HandlerBase.resolveEntity(String publicId, String systemId)
已过时。 解析外部实体。

InputSource

EntityResolver.resolveEntity(String publicId, String systemId)
允许应用程序解析外部实体。

void

InputSource.setEncoding(String encoding)
设置字符编码（如果已知）。

void

XMLReader.setFeature(String name, boolean value)
设置功能标志的值。

void

XMLReader.setProperty(String name, Object value)
设置属性的值。

void

InputSource.setPublicId(String publicId)
设置此输入源的公共标识符。

void

InputSource.setSystemId(String systemId)
设置此输入源的系统标识符。

void

ContentHandler.skippedEntity(String name)
接收跳过的实体的通知。

void

DocumentHandler.startElement(String name, AttributeList atts)
已过时。 接收元素开始的通知。

void

HandlerBase.startElement(String name, AttributeList attributes)
已过时。 接收元素开始的通知。

void

ContentHandler.startElement(String uri, String localName, String qName, Attributes atts)
接收元素开始的通知。

void

ContentHandler.startPrefixMapping(String prefix, String uri)
开始前缀 URI 名称空间范围映射。

void

DTDHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
接收未解析的实体声明事件的通知。

void

HandlerBase.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
已过时。 接收未解析的实体声明的通知。

参数类型为 String 的 org.xml.sax 中的构造方法

InputSource(String systemId)
使用系统标识符创建新的输入源。

SAXException(String message)
创建一个新的 SAXException。

SAXException(String message, Exception e)
从现有的异常创建新的 SAXException。

SAXNotRecognizedException(String message)
构造带指定的消息的新的异常。

SAXNotSupportedException(String message)
构造带指定消息的新的异常。

SAXParseException(String message, Locator locator)
从消息和 Locator 创建新的 SAXParseException。

SAXParseException(String message, Locator locator, Exception e)
将现有的异常包装在 SAXParseException 中。

SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber)
创建新的 SAXParseException。

SAXParseException(String message, String publicId, String systemId, int lineNumber, int columnNumber, Exception e)
创建带有嵌入异常的新 SAXParseException。

org.xml.sax.ext 中 String 的使用

返回 String 的 org.xml.sax.ext 中的方法

String

Locator2.getEncoding()
返回实体的字符编码的名称。

String

Locator2Impl.getEncoding()
返回编码属性的当前值。

String

Locator2.getXMLVersion()
返回用于该实体的 XML 的版本。

String

Locator2Impl.getXMLVersion()
返回版本属性的当前值。

参数类型为 String 的 org.xml.sax.ext 中的方法

void

Attributes2Impl.addAttribute(String uri, String localName, String qName, String type, String value)
将属性添回到列表的末尾，将其“指定的”标志设置为 true。

void

DeclHandler.attributeDecl(String eName, String aName, String type, String mode, String value)
报告属性类型声明。

void

DefaultHandler2.attributeDecl(String eName, String aName, String type, String mode, String value)

void

DeclHandler.elementDecl(String name, String model)
报告元素类型声明。

void

DefaultHandler2.elementDecl(String name, String model)

void

DefaultHandler2.endEntity(String name)

void

LexicalHandler.endEntity(String name)
报告实体的结束。

void

DeclHandler.externalEntityDecl(String name, String publicId, String systemId)
报告解析的外部实体声明。

void

DefaultHandler2.externalEntityDecl(String name, String publicId, String systemId)

InputSource

DefaultHandler2.getExternalSubset(String name, String baseURI)
告知解析器如果在文档文本中没有声明任何外部子集，则不应使用任何外部子集。

InputSource

EntityResolver2.getExternalSubset(String name, String baseURI)
允许应用程序为不能显式定义外部子集的文档提供外部子集。

void

DeclHandler.internalEntityDecl(String name, String value)
报告内部实体声明。

void

DefaultHandler2.internalEntityDecl(String name, String value)

boolean

Attributes2.isDeclared(String qName)
返回 false，除非在 DTD 中声明该属性。

boolean

Attributes2Impl.isDeclared(String qName)
返回属性的“声明的”标志的当前值。

boolean

Attributes2.isDeclared(String uri, String localName)
返回 false，除非在 DTD 中声明属性。

boolean

Attributes2Impl.isDeclared(String uri, String localName)
返回属性的“声明的”标志的当前值。

boolean

Attributes2.isSpecified(String qName)
返回 true，除非由 DTD 默认提供属性值。

boolean

Attributes2Impl.isSpecified(String qName)
返回属性的“指定的”标志的当前值。

boolean

Attributes2.isSpecified(String uri, String localName)
返回 true，除非由 DTD 默认提供属性值。

boolean

Attributes2Impl.isSpecified(String uri, String localName)
返回属性的“指定的”标志的当前值。

InputSource

DefaultHandler2.resolveEntity(String publicId, String systemId)
使用 null 实体名称和基 URI 调用 EntityResolver2.resolveEntity()。

InputSource

DefaultHandler2.resolveEntity(String name, String publicId, String baseURI, String systemId)
告知解析器根据 baseURI 解析 systemId，并从产生的绝对 URI 读取实体文本。

InputSource

EntityResolver2.resolveEntity(String name, String publicId, String baseURI, String systemId)
允许应用程序把对外部实体的引用映射到输入源，或告知解析器它应使用常规 URI 解析。

void

Locator2Impl.setEncoding(String encoding)
分配编码属性的当前值。

void

Locator2Impl.setXMLVersion(String version)
分配版本属性的当前值。

void

DefaultHandler2.startDTD(String name, String publicId, String systemId)

void

LexicalHandler.startDTD(String name, String publicId, String systemId)
报告 DTD 声明的开始（如果存在）。

void

DefaultHandler2.startEntity(String name)

void

LexicalHandler.startEntity(String name)
报告一些内部和外部 XML 实体的开始。

org.xml.sax.helpers 中 String 的使用

声明为 String 的 org.xml.sax.helpers 中的字段

static String

NamespaceSupport.NSDECL
作为常量的名称空间声明 URI。

static String

NamespaceSupport.XMLNS
作为常量的 XML 名称空间 URI。

返回 String 的 org.xml.sax.helpers 中的方法

String

AttributesImpl.getLocalName(int index)
返回属性的本地名称。

String

AttributeListImpl.getName(int i)
已过时。 获取属性名称（按位置）。

String

NamespaceSupport.getPrefix(String uri)
返回映射到名称空间 URI 的前缀之一。

String

LocatorImpl.getPublicId()
返回保存的公开标识符。

String

AttributesImpl.getQName(int index)
返回属性的限定（加前缀的）名称。

String

LocatorImpl.getSystemId()
返回保存的系统标识符。

String

AttributeListImpl.getType(int i)
已过时。 获取属性的类型（按位置）。

String

AttributesImpl.getType(int index)
通过索引返回属性的类型。

String

AttributeListImpl.getType(String name)
已过时。 获取属性的类型（按名称）。

String

AttributesImpl.getType(String qName)
通过限定（加前缀的）名称查找属性的类型。

String

AttributesImpl.getType(String uri, String localName)
通过限定名称空间的名称查找属性的类型。

String

AttributesImpl.getURI(int index)
返回属性的名称空间 URI。

String

NamespaceSupport.getURI(String prefix)
查找前缀，并获取当前映射的名称空间 URI。

String

AttributeListImpl.getValue(int i)
已过时。 获取属性的值（按位置）。

String

AttributesImpl.getValue(int index)
通过索引返回属性的值。

String

AttributeListImpl.getValue(String name)
已过时。 获取属性的值（按名称）。

String

AttributesImpl.getValue(String qName)
通过限定（加前缀的）名称查找属性的值。

String

AttributesImpl.getValue(String uri, String localName)
通过限定名称空间的名称查找属性的值。

String[]

NamespaceSupport.processName(String qName, String[] parts, boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。

参数类型为 String 的 org.xml.sax.helpers 中的方法

void

AttributeListImpl.addAttribute(String name, String type, String value)
已过时。 向属性列表添加属性。

void

AttributesImpl.addAttribute(String uri, String localName, String qName, String type, String value)
将属性添加到列表的末尾。

static XMLReader

XMLReaderFactory.createXMLReader(String className)
尝试从类名称创建一个 XML 阅读器。

boolean

NamespaceSupport.declarePrefix(String prefix, String uri)
声明名称空间前缀。

void

ParserAdapter.endElement(String qName)
适配器实现方法；不调用。

void

DefaultHandler.endElement(String uri, String localName, String qName)
接收元素结束的通知。

void

XMLFilterImpl.endElement(String uri, String localName, String qName)
过滤一个结束元素事件。

void

XMLReaderAdapter.endElement(String uri, String localName, String qName)
适配 SAX2 结束元素事件。

void

DefaultHandler.endPrefixMapping(String prefix)
接收名称空间映射结束的通知。

void

XMLFilterImpl.endPrefixMapping(String prefix)
过滤一个结束名称空间前缀映射事件。

void

XMLReaderAdapter.endPrefixMapping(String prefix)
适配 SAX2 结束前缀映射事件。

boolean

ParserAdapter.getFeature(String name)
检查解析器功能标志。

boolean

XMLFilterImpl.getFeature(String name)
查找功能值。

int

AttributesImpl.getIndex(String qName)
通过限定（加前缀的）名称查找属性的索引。

int

AttributesImpl.getIndex(String uri, String localName)
通过名称空间名称查找属性的索引。

String

NamespaceSupport.getPrefix(String uri)
返回映射到名称空间 URI 的前缀之一。

Enumeration

NamespaceSupport.getPrefixes(String uri)
返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。

Object

ParserAdapter.getProperty(String name)
获取解析器属性。

Object

XMLFilterImpl.getProperty(String name)
查找属性值。

String

AttributeListImpl.getType(String name)
已过时。 获取属性的类型（按名称）。

String

AttributesImpl.getType(String qName)
通过限定（加前缀的）名称查找属性的类型。

String

AttributesImpl.getType(String uri, String localName)
通过限定名称空间的名称查找属性的类型。

String

NamespaceSupport.getURI(String prefix)
查找前缀，并获取当前映射的名称空间 URI。

String

AttributeListImpl.getValue(String name)
已过时。 获取属性的值（按名称）。

String

AttributesImpl.getValue(String qName)
通过限定（加前缀的）名称查找属性的值。

String

AttributesImpl.getValue(String uri, String localName)
通过限定名称空间的名称查找属性的值。

static Parser

ParserFactory.makeParser(String className)
已过时。 使用提供的类名创建一个新的 SAX 解析器对象。

void

DefaultHandler.notationDecl(String name, String publicId, String systemId)
接收注释声明的通知。

void

XMLFilterImpl.notationDecl(String name, String publicId, String systemId)
过滤一个注释声明事件。

void

ParserAdapter.parse(String systemId)
解析 XML 文档。

void

XMLFilterImpl.parse(String systemId)
解析一个文档。

void

XMLReaderAdapter.parse(String systemId)
解析文档。

void

DefaultHandler.processingInstruction(String target, String data)
接收处理指令的通知。

void

ParserAdapter.processingInstruction(String target, String data)
适配器实现方法；不调用。

void

XMLFilterImpl.processingInstruction(String target, String data)
过滤一个处理指令事件。

void

XMLReaderAdapter.processingInstruction(String target, String data)
适配 SAX2 处理指令事件。

String[]

NamespaceSupport.processName(String qName, String[] parts, boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。

String[]

NamespaceSupport.processName(String qName, String[] parts, boolean isAttribute)
declarePrefix() 处理完当前上下文中的所有声明之后，处理原始 XML 限定名称。

void

AttributeListImpl.removeAttribute(String name)
已过时。 从列表移除属性。

InputSource

DefaultHandler.resolveEntity(String publicId, String systemId)
解析外部实体。

InputSource

XMLFilterImpl.resolveEntity(String publicId, String systemId)
过滤一个外部实体解析。

void

AttributesImpl.setAttribute(int index, String uri, String localName, String qName, String type, String value)
在列表中设置属性。

void

ParserAdapter.setFeature(String name, boolean value)
为解析器设置功能标志。

void

XMLFilterImpl.setFeature(String name, boolean value)
设置功能的值。

void

AttributesImpl.setLocalName(int index, String localName)
设置特定属性的本地名称。

void

ParserAdapter.setProperty(String name, Object value)
设置解析器属性。

void

XMLFilterImpl.setProperty(String name, Object value)
设置属性值。

void

LocatorImpl.setPublicId(String publicId)
设置此定位器的公开标识符。

void

AttributesImpl.setQName(int index, String qName)
设置特定属性的限定名称。

void

LocatorImpl.setSystemId(String systemId)
设置此定位器的系统标识符。

void

AttributesImpl.setType(int index, String type)
设置特定属性的类型。

void

AttributesImpl.setURI(int index, String uri)
设置特定属性的名称空间 URI。

void

AttributesImpl.setValue(int index, String value)
设置特定属性的值。

void

DefaultHandler.skippedEntity(String name)
接收跳过的实体的通知。

void

XMLFilterImpl.skippedEntity(String name)
过滤一个跳过的实体事件。

void

XMLReaderAdapter.skippedEntity(String name)
适配 SAX2 跳过的实体事件。

void

ParserAdapter.startElement(String qName, AttributeList qAtts)
适配器实现方法；不调用。

void

DefaultHandler.startElement(String uri, String localName, String qName, Attributes attributes)
接收元素开始的通知。

void

XMLFilterImpl.startElement(String uri, String localName, String qName, Attributes atts)
过滤一个开始元素事件。

void

XMLReaderAdapter.startElement(String uri, String localName, String qName, Attributes atts)
适配 SAX2 开始元素事件。

void

DefaultHandler.startPrefixMapping(String prefix, String uri)
接收名称空间映射开始的通知。

void

XMLFilterImpl.startPrefixMapping(String prefix, String uri)
过滤一个开始名称空间前缀映射事件。

void

XMLReaderAdapter.startPrefixMapping(String prefix, String uri)
适配 SAX2 开始前缀映射事件。

void

DefaultHandler.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
接收未解析实体声明的通知。

void

XMLFilterImpl.unparsedEntityDecl(String name, String publicId, String systemId, String notationName)
过滤一个未解析实体声明事件。

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架


接口 java.lang.CharSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.CharSequence
的使用

使用 CharSequence 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 CharSequence 的使用

参数类型为 CharSequence 的 java.io 中的方法
CharArrayWriter | CharArrayWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq) 将指定的字符序列添加到此 writer。
Writer | Writer.append(CharSequence csq) 将指定字符序列添加到此 writer。
PrintStream | PrintStream.append(CharSequence csq) 将指定字符序列添加到此输出流。
CharArrayWriter | CharArrayWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
StringWriter | StringWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
PrintWriter | PrintWriter.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer。
Writer | Writer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此 writer.Appendable。
PrintStream | PrintStream.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此输出流。

java.lang 中 CharSequence 的使用

实现 CharSequence 的 java.lang 中的类
class | String String 类代表字符串。
class | StringBuffer 线程安全的可变字符序列。
class | StringBuilder 一个可变的字符序列。

返回 CharSequence 的 java.lang 中的方法
CharSequence | StringBuffer.subSequence(int start, int end)
CharSequence | String.subSequence(int beginIndex, int endIndex) 返回一个新的字符序列，它是此序列的一个子序列。
CharSequence | CharSequence.subSequence(int start, int end) 返回一个新的 CharSequence，它是此序列的子序列。

参数类型为 CharSequence 的 java.lang 中的方法
StringBuilder | StringBuilder.append(CharSequence s)
StringBuffer | StringBuffer.append(CharSequence s) 将指定的 CharSequence 添加到该序列。
Appendable | Appendable.append(CharSequence csq) 向此 Appendable 添加指定的字符序列。
StringBuilder | StringBuilder.append(CharSequence s, int start, int end)
StringBuffer | StringBuffer.append(CharSequence s, int start, int end)
Appendable | Appendable.append(CharSequence csq, int start, int end) 向此 Appendable 添加指定字符序列的子序列。
static int | Character.codePointAt(CharSequence seq, int index) 返回 CharSequence 的给定索引上的代码点。
static int | Character.codePointBefore(CharSequence seq, int index) 返回 CharSequence 的给定索引前面的代码点。
static int | Character.codePointCount(CharSequence seq, int beginIndex, int endIndex) 返回指定字符序列的文本范围内的 Unicode 代码点数量。
boolean | String.contains(CharSequence s) 当且仅当此字符串包含指定的 char 值序列时，返回 true。
boolean | String.contentEquals(CharSequence cs) 将此字符串与指定的 CharSequence 比较。
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s)
StringBuilder | StringBuilder.insert(int dstOffset, CharSequence s, int start, int end)
StringBuffer | StringBuffer.insert(int dstOffset, CharSequence s, int start, int end)
static int | Character.offsetByCodePoints(CharSequence seq, int index, int codePointOffset) 返回给定字符序列中的索引，它是从给定 index 到 codePointOffset 代码点的偏移量。
String | String.replace(CharSequence target, CharSequence replacement) 使用指定的字面值替换序列替换此字符串所有匹配字面值目标序列的子字符串。

参数类型为 CharSequence 的 java.lang 中的构造方法
StringBuffer(CharSequence seq)
public java.lang.StringBuilder(CharSequence seq) 构造一个字符串缓冲区，它包含与指定的 CharSequence 相同的字符。
StringBuilder(CharSequence seq)
构造一个字符串生成器，包含与指定的 CharSequence 相同的字符。

java.nio 中 CharSequence 的使用

实现 CharSequence 的 java.nio 中的类
 class CharBuffer
字符缓冲区。

返回 CharSequence 的 java.nio 中的方法
abstract  CharSequence CharBuffer.subSequence(int start, int end)
创建表示此缓冲区的指定序列、相对于当前位置的新字符缓冲区。

参数类型为 CharSequence 的 java.nio 中的方法
CharBuffer | CharBuffer.append(CharSequence csq) 将指定的字符序列添加到此缓冲区（可选操作）。
CharBuffer | CharBuffer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此缓冲区（可选操作）。
static CharBuffer | CharBuffer.wrap(CharSequence csq) 将字符序列包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(CharSequence csq, int start, int end) 将字符序列包装到缓冲区中。

java.nio.charset 中 CharSequence 的使用

参数类型为 CharSequence 的 java.nio.charset 中的方法
 boolean CharsetEncoder.canEncode(CharSequence cs)
通过此编码器是否能够编码给定的字符序列。

java.text 中 CharSequence 的使用

参数类型为 CharSequence 的 java.text 中的方法
static boolean | Normalizer.isNormalized(CharSequence src, Normalizer.Form form) 确定给定的 char 值序列是否被标准化。
static String | Normalizer.normalize(CharSequence src, Normalizer.Form form) 标准化 char 值序列。

java.util.regex 中 CharSequence 的使用

参数类型为 CharSequence 的 java.util.regex 中的方法
Matcher | Pattern.matcher(CharSequence input) 创建匹配给定输入与此模式的匹配器。
static boolean | Pattern.matches(String regex, CharSequence input) 编译给定正则表达式并尝试将给定输入与其匹配。
Matcher | Matcher.reset(CharSequence input) 重置此具有新输入序列的匹配器。
String[] | Pattern.split(CharSequence input) 围绕此模式的匹配拆分给定输入序列。
String[] | Pattern.split(CharSequence input, int limit) 围绕此模式的匹配拆分给定输入序列。

javax.annotation.processing 中 CharSequence 的使用

参数类型为 CharSequence 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。
FileObject | Filer.getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg) 打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e) 在元素的位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model 中 CharSequence 的使用

参数类型为 CharSequence 的 javax.lang.model 中的方法
static boolean | SourceVersion.isIdentifier(CharSequence name) 返回 name 是否是语法上有效的标识符（简单名称）或最新源版本中的关键字。
static boolean | SourceVersion.isKeyword(CharSequence s) 返回 s 是否是最新源版本中的关键字或字面值。
static boolean | SourceVersion.isName(CharSequence name) 返回 name 是否是最新源版本中语法上有效的限定名称。

javax.lang.model.element 中 CharSequence 的使用

javax.lang.model.element 中 CharSequence 的子接口
 interface Name
字符的不可变序列。

参数类型为 CharSequence 的 javax.lang.model.element 中的方法
 boolean Name.contentEquals(CharSequence cs)
将此名称与指定的 CharSequence 进行比较。

javax.lang.model.util 中 CharSequence 的使用

参数类型为 CharSequence 的 javax.lang.model.util 中的方法
Name | Elements.getName(CharSequence cs) 返回与参数具有相同字符序列的名称。
PackageElement | Elements.getPackageElement(CharSequence name) 返回已给出其完全限定名称的包。
TypeElement | Elements.getTypeElement(CharSequence name) 返回已给出其规范名称的类型元素。

javax.swing.text 中 CharSequence 的使用

实现 CharSequence 的 javax.swing.text 中的类
 class Segment
表示文本片段的字符数组的 segment。

返回 CharSequence 的 javax.swing.text 中的方法
 CharSequence Segment.subSequence(int start, int end)
返回一个新的 CharSequence，它是此序列的子序列。

javax.tools 中 CharSequence 的使用

返回 CharSequence 的 javax.tools 中的方法
CharSequence | FileObject.getCharContent(boolean ignoreEncodingErrors) 返回此文件对象的字符内容（如果有）。
CharSequence | ForwardingFileObject.getCharContent(boolean ignoreEncodingErrors)
CharSequence | SimpleJavaFileObject.getCharContent(boolean ignoreEncodingErrors) 此实现总是抛出 UnsupportedOperationException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.lang.Comparable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.lang.Comparable
的使用

使用 Comparable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.annotation | 为 Java 编程语言注释设施提供库支持。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.annotation |
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.jws |
javax.jws.soap |
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind.annotation | 定义将 Java 程序元素定制成 XML 模式映射的注释。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。

java.awt 中 Comparable 的使用

实现 Comparable 的 java.awt 中的类
static class | Component.BaselineResizeBehavior 常见方式的枚举，指示组件的基线可以随大小的更改而更改。
static class | Desktop.Action 表示动作类型。
static class | Dialog.ModalExclusionType 任何顶层窗口都可以标记为不受模式对话框阻塞。
static class | Dialog.ModalityType 模式对话框阻塞对某些顶层窗口的所有输入。
static class | MultipleGradientPaint.ColorSpaceType 在其中执行渐变插值操作的颜色空间。
static class | MultipleGradientPaint.CycleMethod 在渐变边界以外进行绘制时使用的方法。
static class | TrayIcon.MessageType MessageType 确定哪个图标将显示在消息标题中，以及消息根据显示生成的可能的系统声音。

java.io 中 Comparable 的使用

实现 Comparable 的 java.io 中的类
class | File 文件和目录路径名的抽象表示形式。
class | ObjectStreamField Serializable 类中 Serializable 字段的描述。

java.lang 中 Comparable 的使用

实现 Comparable 的 java.lang 中的类
class | Boolean Boolean 类将基本类型为 boolean 的值包装在一个对象中。
class | Byte Byte 类将基本类型 byte 的值包装在一个对象中。
class | Character Character 类在对象中包装一个基本类型 char 的值。
class | Double Double 类在对象中包装一个基本类型 double 的值。
class | Enum<E extends Enum<E>> 这是所有 Java 语言枚举类型的公共基本类。
class | Float Float 类在对象中包装一个基本类型 float 的值。
class | Integer Integer 类在对象中包装了一个基本类型 int 的值。
class | Long Long 类在对象中包装了基本类型 long 的值。
class | Short Short 类在对象中包装基本类型 short 的值。
class | String String 类代表字符串。
static class | Thread.State 线程状态。

java.lang.annotation 中 Comparable 的使用

实现 Comparable 的 java.lang.annotation 中的类
class | ElementType 程序元素类型。
class | RetentionPolicy 注释保留策略。

java.lang.management 中 Comparable 的使用

实现 Comparable 的 java.lang.management 中的类
 class MemoryType
内存池的类型。

java.math 中 Comparable 的使用

实现 Comparable 的 java.math 中的类
class | BigDecimal 不可变的、任意精度的有符号十进制数。
class | BigInteger 不可变的任意精度的整数。
class | RoundingMode 为可能丢弃精度的数值操作指定一种舍入行为。

java.net 中 Comparable 的使用

实现 Comparable 的 java.net 中的类
static class | Authenticator.RequestorType 请求验证的实体的类型。
static class | Proxy.Type 表示代理类型。
class | URI 表示一个统一资源标识符 (URI) 引用。

java.nio 中 Comparable 的使用

实现 Comparable 的 java.nio 中的类
class | ByteBuffer 字节缓冲区。
class | CharBuffer 字符缓冲区。
class | DoubleBuffer double 缓冲区。
class | FloatBuffer float 缓冲区。
class | IntBuffer int 缓冲区。
class | LongBuffer long 缓冲区。
class | MappedByteBuffer 直接字节缓冲区，其内容是文件的内存映射区域。
class | ShortBuffer short 缓冲区。

java.nio.charset 中 Comparable 的使用

实现 Comparable 的 java.nio.charset 中的类
 class Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。

java.security 中 Comparable 的使用

实现 Comparable 的 java.security 中的类
static class KeyRep.Type
Key 类型。

java.sql 中 Comparable 的使用

实现 Comparable 的 java.sql 中的类
class | ClientInfoStatus 无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
class | RowIdLifetime RowId 生存期值的枚举。
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
class | Timestamp 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。

java.text 中 Comparable 的使用

实现 Comparable 的 java.text 中的类
class | CollationKey CollationKey 表示遵守特定 Collator 对象规则的 String。
static class | Normalizer.Form 此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。

java.util 中 Comparable 的使用

实现 Comparable 的 java.util 中的类
class | Calendar Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
class | Date 类 Date 表示特定的瞬间，精确到毫秒。
static class | Formatter.BigDecimalLayoutForm
class | GregorianCalendar GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
class | UUID 表示通用唯一标识符 (UUID) 的类。

类型参数类型为 Comparable 的 java.util 中的方法
static
<T extends Object & Comparable<? super T>>
T
Collections.max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。
static
<T extends Object & Comparable<? super T>>
T
Collections.min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。
static
<T extends Comparable<? super T>>
void
Collections.sort(List<T> list)
根据元素的自然顺序 对指定列表按升序进行排序。

类型变量类型为 Comparable 的 java.util 中的方法参数
static
<T> int
Collections.binarySearch(List<? extends Comparable<? super T>> list, T key)
使用二分搜索法搜索指定列表，以获得指定对象。

java.util.concurrent 中 Comparable 的使用

java.util.concurrent 中 Comparable 的子接口
interface | Delayed 一种混合风格的接口，用来标记那些应该在给定延迟时间之后执行的对象。
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。
interface | ScheduledFuture<V> 一个延迟的、结果可接受的操作，可将其取消。

实现 Comparable 的 java.util.concurrent 中的类
 class TimeUnit
TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

javax.annotation 中 Comparable 的使用

实现 Comparable 的 javax.annotation 中的类
static class Resource.AuthenticationType
资源的两种可能验证类型。

javax.imageio.metadata 中 Comparable 的使用

类型参数类型为 Comparable 的 javax.imageio.metadata 中的方法
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

返回 Comparable 的 javax.imageio.metadata 中的方法
Comparable<?> | IIOMetadataFormat.getObjectMaxValue(String elementName) 返回指定元素中 Object 引用的最大合法值。
Comparable<?> | IIOMetadataFormatImpl.getObjectMaxValue(String elementName)
Comparable<?> | IIOMetadataFormat.getObjectMinValue(String elementName) 返回指定元素中 Object 引用的最小合法值。
Comparable<?> | IIOMetadataFormatImpl.getObjectMinValue(String elementName)

参数类型为 Comparable 的 javax.imageio.metadata 中的方法
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T extends Object & Comparable<? super T>>
void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

javax.jws 中 Comparable 的使用

实现 Comparable 的 javax.jws 中的类
static class WebParam.Mode
参数的流向。

javax.jws.soap 中 Comparable 的使用

实现 Comparable 的 javax.jws.soap 中的类
static class | SOAPBinding.ParameterStyle 参数到 SOAP 消息的映射关系的样式。
static class | SOAPBinding.Style SOAP 绑定样式。
static class | SOAPBinding.Use SOAP 绑定的使用。

javax.lang.model 中 Comparable 的使用

实现 Comparable 的 javax.lang.model 中的类
 class SourceVersion
Java™ 编程语言的源版本。

javax.lang.model.element 中 Comparable 的使用

实现 Comparable 的 javax.lang.model.element 中的类
class | ElementKind 元素的 kind。
class | Modifier 表示程序元素（如类、方法或字段）上的修饰符。
class | NestingKind 某一类型元素的嵌套种类 (nesting kind)。

javax.lang.model.type 中 Comparable 的使用

实现 Comparable 的 javax.lang.model.type 中的类
 class TypeKind
类型镜像的种类。

javax.management 中 Comparable 的使用

实现 Comparable 的 javax.management 中的类
 class ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

javax.management.openmbean 中 Comparable 的使用

返回 Comparable 的 javax.management.openmbean 中的方法
Comparable<?> | OpenMBeanAttributeInfoSupport.getMaxValue() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最大值（如果已指定），否则返回 null。
Comparable<?> | OpenMBeanParameterInfo.getMaxValue() 返回此参数的最大值（如果存在），否则返回 null。
Comparable<?> | OpenMBeanParameterInfoSupport.getMaxValue() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最大值（如果指定），否则返回 null。
Comparable<?> | OpenMBeanAttributeInfoSupport.getMinValue() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最小值（如果已指定），否则返回 null。
Comparable<?> | OpenMBeanParameterInfo.getMinValue() 返回此参数的最小值（如果存在），否则返回 null。
Comparable<?> | OpenMBeanParameterInfoSupport.getMinValue() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最小值（如果指定），否则返回 null。

参数类型为 Comparable 的 javax.management.openmbean 中的构造方法
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

javax.naming 中 Comparable 的使用

javax.naming 中 Comparable 的子接口
 interface Name
Name 接口表示一个一般名称，即一个有序的组件序列。

实现 Comparable 的 javax.naming 中的类
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。

javax.naming.ldap 中 Comparable 的使用

实现 Comparable 的 javax.naming.ldap 中的类
class | LdapName 此类表示 RFC 2253 指定的标识名。
class | Rdn 此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。

javax.net.ssl 中 Comparable 的使用

实现 Comparable 的 javax.net.ssl 中的类
static class | SSLEngineResult.HandshakeStatus 描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
static class | SSLEngineResult.Status 描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。

javax.swing 中 Comparable 的使用

实现 Comparable 的 javax.swing 中的类
class | DropMode 放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
static class | GroupLayout.Alignment ParallelGroup 能够对齐其子元素的可能方式的枚举。
static class | JTable.PrintMode 用于打印 JTable 的打印模式。
static class | LayoutStyle.ComponentPlacement ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
static class | RowFilter.ComparisonType 由某些默认 RowFilter 支持的可能比较值的枚举。
class | SortOrder SortOrder 是可能排序顺序的枚举。
static class | SwingWorker.StateValue state 绑定 (bound) 属性的值。

返回 Comparable 的 javax.swing 中的方法
Comparable | SpinnerDateModel.getEnd() 返回序列中的最后一个 Date。
Comparable | SpinnerNumberModel.getMaximum() 返回该序列中的最后一个数字。
Comparable | SpinnerNumberModel.getMinimum() 返回此序列中的第一个数字。
Comparable | SpinnerDateModel.getStart() 返回序列中的第一个 Date。

参数类型为 Comparable 的 javax.swing 中的方法
void | SpinnerDateModel.setEnd(Comparable end) 更改此序列中 Date 的上限。
void | SpinnerNumberModel.setMaximum(Comparable maximum) 更改此序列中数字的上边界。
void | SpinnerNumberModel.setMinimum(Comparable minimum) 更改此序列中数字的下边界。
void | SpinnerDateModel.setStart(Comparable start) 更改此序列中的日期下限。

参数类型为 Comparable 的 javax.swing 中的构造方法
SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。
SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。
SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。
SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。

javax.swing.event 中 Comparable 的使用

实现 Comparable 的 javax.swing.event 中的类
static class RowSorterEvent.Type
RowSorterEvent 类型的枚举。

javax.swing.text 中 Comparable 的使用

返回 Comparable 的 javax.swing.text 中的方法
Comparable | InternationalFormatter.getMaximum() 返回最大允许值。
Comparable | InternationalFormatter.getMinimum() 返回最小允许值。

参数类型为 Comparable 的 javax.swing.text 中的方法
void | InternationalFormatter.setMaximum(Comparable max) 设置最大允许值。
void | InternationalFormatter.setMinimum(Comparable minimum) 设置最小允许值。

javax.swing.text.html 中 Comparable 的使用

实现 Comparable 的 javax.swing.text.html 中的类
static class FormSubmitEvent.MethodType
表示 HTML 表单方法类型。

javax.tools 中 Comparable 的使用

实现 Comparable 的 javax.tools 中的类
static class | Diagnostic.Kind 诊断的种类，例如，错误或者警告。
static class | JavaFileObject.Kind JavaFileObject 的种类。
class | StandardLocation 文件对象的标准位置。

javax.xml.bind.annotation 中 Comparable 的使用

实现 Comparable 的 javax.xml.bind.annotation 中的类
class | XmlAccessOrder 由 XmlAccessorOrder 使用，用于控制 JAXB 绑定类中属性和字段的排序。
class | XmlAccessType 由 XmlAccessorType 使用，用于控制字段或属性的序列化。
class | XmlNsForm XML 模式名称空间限定的枚举。

javax.xml.ws 中 Comparable 的使用

实现 Comparable 的 javax.xml.ws 中的类
static class Service.Mode
动态客户端或服务的方向。

javax.xml.ws.handler 中 Comparable 的使用

实现 Comparable 的 javax.xml.ws.handler 中的类
static class MessageContext.Scope
属性作用域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.lang.Object 的使用 (Java 2 Platform SE 6)

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架

类 java.lang.Object
的使用

使用 Object 的软件包

java.applet

提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。

java.awt

包含用于创建用户界面和绘制图形图像的所有类。

java.awt.color

提供用于颜色空间的类。

java.awt.datatransfer

提供在应用程序之间和在应用程序内部传输数据的接口和类。

java.awt.dnd

Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。

java.awt.event

提供处理由 AWT 组件所激发的各类事件的接口和类。

java.awt.font

提供与字体相关的类和接口。

java.awt.geom

提供用于在与二维几何形状相关的对象上定义和执行操作的 Java 2D 类。

java.awt.im

提供输入方法框架所需的类和接口。

java.awt.im.spi

提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。

java.awt.image

提供创建和修改图像的各种类。

java.awt.image.renderable

提供用于生成与呈现无关的图像的类和接口。

java.awt.print

为通用的打印 API 提供类和接口。

java.beans

包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.beans.beancontext

提供与 bean 上下文有关的类和接口。

java.io

通过数据流、序列化和文件系统提供系统输入和输出。

java.lang

提供利用 Java 编程语言进行程序设计的基础类。

java.lang.annotation

为 Java 编程语言注释设施提供库支持。

java.lang.instrument

提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。

java.lang.management

提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。

java.lang.ref

提供了引用对象类，支持在某种程度上与垃圾回收器之间的交互。

java.lang.reflect

提供类和接口，以获得关于类和对象的反射信息。

java.math

提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。

java.net

为实现网络应用程序提供类。

java.nio

定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio.channels

定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels.spi

用于 java.nio.channels 包的服务提供者类。

java.nio.charset

定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset.spi

java.nio.charset 包的服务提供者类。

java.rmi

提供 RMI 包。

java.rmi.activation

为 RMI 对象激活提供支持。

java.rmi.dgc

为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.registry

提供 RMI 注册表的一个类和两个接口。

java.rmi.server

提供支持服务器端 RMI 的类和接口。

java.security

为安全框架提供类和接口。

java.security.acl

此包中的类和接口已经被 java.security 包中的类取代。

java.security.cert

提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.spec

提供密钥规范和算法参数规范的类和接口。

java.sql

提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.text

提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text.spi

java.text 包中类的服务提供者类。

java.util

包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util.concurrent

在并发编程中很常用的实用工具类。

java.util.concurrent.atomic

类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.locks

为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.jar

提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.logging

提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.prefs

此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.regex

用于匹配字符序列与正则表达式指定模式的类。

java.util.spi

java.util 包中类的服务提供者类。

java.util.zip

提供用于读写标准 ZIP 和 GZIP 文件格式的类。

javax.accessibility

定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.activation

javax.activity

包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。

javax.annotation.processing

用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.crypto

为加密操作提供类和接口。

javax.crypto.spec

为密钥规范和算法参数规范提供类和接口。

javax.imageio

Java Image I/O API 的主要包。

javax.imageio.metadata

用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.plugins.bmp

包含供内置 BMP 插件使用的公共类的包。

javax.imageio.plugins.jpeg

支持内置 JPEG 插件的类。

javax.imageio.spi

包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.stream

Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.lang.model.element

用于 Java 编程语言的模型元素的接口。

javax.lang.model.type

用来为 Java 编程语言类型建立模型的接口。

javax.lang.model.util

用来帮助处理程序元素和类型的实用工具。

javax.management

提供 Java Management Extensions 的核心类。

javax.management.loading

提供实现高级动态加载的类。

javax.management.modelmbean

提供了 ModelMBean 类的定义。

javax.management.monitor

提供 monitor 类的定义。

javax.management.openmbean

提供开放数据类型和 Open MBean 描述符类。

javax.management.relation

提供 Relation Service 的定义。

javax.management.remote

对 JMX MBean 服务器进行远程访问使用的接口。

javax.management.remote.rmi

RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.timer

提供对 Timer MBean（计时器 MBean）的定义。

javax.naming

为访问命名服务提供类和接口。

javax.naming.directory

扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.event

在访问命名和目录服务时提供对事件通知的支持。

javax.naming.ldap

提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.spi

提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.net

提供用于网络应用程序的类。

javax.net.ssl

提供用于安全套接字包的类。

javax.print

为 JavaTM Print Service API 提供了主要类和接口。

javax.print.attribute

提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print.attribute.standard

包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.event

包 javax.print.event 包含事件类和侦听器接口。

javax.rmi

包含 RMI-IIOP 的用户 API。

javax.rmi.CORBA

包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.ssl

通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

javax.script

脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.security.auth

此包提供用于进行验证和授权的框架。

javax.security.auth.callback

此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

javax.security.auth.kerberos

此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.login

此包提供可插入的验证框架。

javax.security.auth.x500

此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

javax.security.cert

为公钥证书提供类。

javax.security.sasl

包含用于支持 SASL 的类和接口。

javax.sound.midi

提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi.spi

在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.sampled

提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled.spi

在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sql

为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql.rowset

JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset.serial

提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

javax.sql.rowset.spi

第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.swing

提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing.border

提供围绕 Swing 组件绘制特殊边框的类和接口。

javax.swing.colorchooser

包含供 JColorChooser 组件使用的类和接口。

javax.swing.event

供 Swing 组件触发的事件使用。

javax.swing.filechooser

包含 JFileChooser 组件使用的类和接口。

javax.swing.plaf

提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf.basic

提供了根据基本外观构建的用户界面对象。

javax.swing.plaf.metal

提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.plaf.multi

提供了组合两个或多个外观的用户界面对象。

javax.swing.plaf.synth

Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。

javax.swing.table

提供用于处理 javax.swing.JTable 的类和接口。

javax.swing.text

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html

提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.text.html.parser

提供默认的 HTML 解析器以及支持类。

javax.swing.text.rtf

提供一个类 (RTFEditorKit)，用于创建富文本格式（Rich-Text-Format）的文本编辑器。

javax.swing.tree

提供处理 javax.swing.JTree 的类和接口。

javax.swing.undo

允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.tools

为能够从程序（例如，编译器）中调用的工具提供接口。

javax.transaction

包含解组期间通过 ORB 机制抛出的三个异常。

javax.transaction.xa

提供定义事务管理器和资源管理器之间的协定的 API，它允许事务管理器添加或删除 JTA 事务中的资源对象（由资源管理器驱动程序提供）。

javax.xml

根据 XML 规范定义核心 XML 常量和功能。

javax.xml.bind

为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。

javax.xml.bind.annotation

定义将 Java 程序元素定制成 XML 模式映射的注释。

javax.xml.bind.annotation.adapters

XmlAdapter 及其规范定义的子类允许任意 Java 类与 JAXB 一起使用。

javax.xml.bind.attachment

此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。

javax.xml.bind.helpers

仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。

javax.xml.bind.util

有用的客户端实用工具类。

javax.xml.crypto

用于 XML 加密的通用类。

javax.xml.crypto.dom

javax.xml.crypto 包的特定于 DOM 的类。

javax.xml.crypto.dsig

用于生成和验证 XML 数字签名的类。

javax.xml.crypto.dsig.dom

javax.xml.crypto.dsig 包特定于 DOM 的类。

javax.xml.crypto.dsig.keyinfo

用来解析和处理 KeyInfo 元素和结构的类。

javax.xml.crypto.dsig.spec

XML 数字签名的参数类。

javax.xml.datatype

XML/Java 类型映射关系。

javax.xml.namespace

XML 名称空间处理。

javax.xml.parsers

提供允许处理 XML 文档的类。

javax.xml.soap

提供用于创建和构建 SOAP 消息的 API。

javax.xml.stream

javax.xml.stream.events

javax.xml.stream.util

javax.xml.transform

此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。

javax.xml.transform.dom

此包实现特定于 DOM 的转换 API。

javax.xml.transform.sax

此包实现特定于 SAX2 的转换 API。

javax.xml.transform.stax

提供特定于 StAX 的转换 API。

javax.xml.transform.stream

此包实现特定于流和 URI 的转换 API。

javax.xml.validation

此包提供了用于 XML 文档验证的 API。

javax.xml.ws

此包包含核心 JAX-WS API。

javax.xml.ws.handler.soap

该包定义用于 SOAP 消息处理程序的 API。

javax.xml.ws.http

该包定义特定于 HTTP 绑定的 API。

javax.xml.ws.soap

该包定义特定于 SOAP 绑定的 API。

javax.xml.ws.spi

该包定义用于 JAX-WS 2.0 的 SPI。

javax.xml.xpath

此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

org.ietf.jgss

此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

org.omg.CORBA

提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

org.omg.CORBA_2_3

CORBA_2_3 包定义对 Java[tm] Standard Edition 6 中现有 CORBA 接口所进行的添加。

org.omg.CORBA_2_3.portable

提供输入和输出值类型的各种方法，并包含 org/omg/CORBA/portable 包的其他更新。

org.omg.CORBA.DynAnyPackage

提供与 DynAny 接口一起使用的异常（InvalidValue、Invalid、InvalidSeq 和 TypeMismatch）。

org.omg.CORBA.ORBPackage

提供由 ORB.resolve_initial_references 方法抛出的异常 InvalidName，以及由 ORB 类中的动态 Any 创建方法抛出的异常 InconsistentTypeCode。

org.omg.CORBA.portable

提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

org.omg.CORBA.TypeCodePackage

提供用户定义的异常 BadKind 和 Bounds，它们将由 TypeCode 类中的方法抛出。

org.omg.CosNaming

为 Java IDL 提供命名服务。

org.omg.CosNaming.NamingContextExtPackage

此包包含以下在 org.omg.CosNaming.NamingContextExt 中使用的类： AddressHelper StringNameHelper URLStringHelper InvalidAddress 包规范 有关 Java[tm] Platform, Standard Edition 6 ORB 遵守的官方规范的受支持部分的明确列表，请参阅 Official Specifications for CORBA support in Java[tm] SE 6。

org.omg.CosNaming.NamingContextPackage

此包包含 org.omg.CosNaming 包的 Exception 类。

org.omg.Dynamic

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.9 小节中指定的 Dynamic 模块。

org.omg.DynamicAny

提供一些类和接口使得在运行时能够遍历与 any 有关联的数据值，并提取数据值的基本成分。

org.omg.DynamicAny.DynAnyFactoryPackage

此包包含 DynamicAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2.2 小节中指定。

org.omg.DynamicAny.DynAnyPackage

此包包含 DynAny 模块的 DynAnyFactory 接口中的类和异常，该模块在 OMG The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的第 9.2 小节中指定。

org.omg.IOP

此包包含在 OMG 文档 The Common Object Request Broker: Architecture and Specification http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 的 13.6.小节中指定的 IOP 模块。

org.omg.IOP.CodecFactoryPackage

此包包含 IOP::CodeFactory 接口中指定的异常（作为 Portable Interceptor 规范的一部分）。

org.omg.IOP.CodecPackage

此包根据 IOP::Codec IDL 接口定义生成。

org.omg.Messaging

此包包含 OMG Messaging Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?formal/99-10-07 中指定的 Messaging 模块。

org.omg.PortableInterceptor

提供一个注册 ORB 钩子 (hook) 的机制，通过这些钩子 ORB 服务可以截取执行 ORB 的正常流。

org.omg.PortableInterceptor.ORBInitInfoPackage

此包包含 OMG Portable Interceptor 规范 http://cgi.omg.org/cgi-bin/doc?ptc/2000-08-06 的第 21.7.2 小节中指定的 PortableInterceptor 模块的 ORBInitInfo 本地接口中的异常和 typedef。

org.omg.PortableServer

提供一些类和接口，用来生成跨多个供应商 ORB 的可移植应用程序的服务器端。

org.omg.PortableServer.CurrentPackage

提供各种方法实现，这些实现能够访问调用方法的对象的身份。

org.omg.PortableServer.POAManagerPackage

封装 POA 关联的处理状态。

org.omg.PortableServer.POAPackage

允许程序员构造可在不同 ORB 产品间移植的对象实现。

org.omg.PortableServer.ServantLocatorPackage

提供定位 servant 的类和接口。

org.omg.stub.java.rmi

包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

org.w3c.dom

为文档对象模型 (DOM) 提供接口，该模型是 Java API for XML Processing 的组件 API。

org.w3c.dom.bootstrap

org.w3c.dom.events

org.w3c.dom.ls

org.xml.sax

此包提供了核心 SAX API。

org.xml.sax.ext

此包包含适合的 SAX 驱动程序不一定支持的 SAX2 设施的接口。

org.xml.sax.helpers

此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 Object 的使用

java.applet 中 Object 的子类

class

Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

protected  class

Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 Object 的使用

java.awt 中 Object 的子类

class

AlphaComposite
AlphaComposite 类实现一些基本的 alpha 合成规则，将源色与目标色组合，在图形和图像中实现混合和透明效果。

class

AWTError
当发生严重的 Abstract Window Toolkit 错误时，抛出此错误。

class

AWTEvent
所有 AWT 事件的根事件类。

class

AWTEventMulticaster
AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。

class

AWTException
表示发生了 Absract Window Toolkit 异常。

class

AWTKeyStroke
AWTKeyStroke 表示键盘（或等效输入设备）上的键操作。

class

AWTPermission
此类用于 AWT 权限。

class

BasicStroke
BasicStroke 类定义针对图形图元轮廓呈现属性的一个基本集合，这些图元使用 Graphics2D 对象呈现，而该对象的 Stroke 属性设置为此 BasicStroke。

class

BorderLayout
这是一个布置容器的边框布局，它可以对容器组件进行安排，并调整其大小，使其符合下列五个区域：北、南、东、西、中。

class

BufferCapabilities
缓冲区的能力和属性。

static class

BufferCapabilities.FlipContents
页面翻转后可能的后台缓冲区内容的一个类型安全的枚举

class

Button
此类创建一个标签按钮。

protected  class

Button.AccessibleAWTButton
此类实现对 Button 类的可访问性支持。

class

Canvas
Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。

protected  class

Canvas.AccessibleAWTCanvas
此类实现对 Canvas 类的可访问性支持。

class

CardLayout
CardLayout 对象是容器的布局管理器。

class

Checkbox
复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。

protected  class

Checkbox.AccessibleAWTCheckbox
此类实现对 Checkbox 类的可访问性支持。

class

CheckboxGroup
CheckboxGroup 类用于集合 Checkbox 按钮集。

class

CheckboxMenuItem
此类表示一个可包括在菜单中的复选框。

protected  class

CheckboxMenuItem.AccessibleAWTCheckboxMenuItem
用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。

class

Choice
Choice 类表示一个弹出式选择菜单。

protected  class

Choice.AccessibleAWTChoice
此类实现对 Choice 类的可访问性支持。

class

Color
Color 类用于封装默认 sRGB 颜色空间中的颜色，或者用于封装由 ColorSpace 标识的任意颜色空间中的颜色。

class

Component
component 是一个具有图形表示能力的对象，可在屏幕上显示，并可与用户进行交互。

protected  class

Component.AccessibleAWTComponent
用来为可访问性提供默认支持的 Component 的内部类。

protected  class

Component.AccessibleAWTComponent.AccessibleAWTComponentHandler
当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）

protected  class

Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）

protected  class

Component.BltBufferStrategy
用于将屏幕外的画面以位图传输方式传输到一个组件的内部类。

protected  class

Component.FlipBufferStrategy
在组件上翻转缓冲区的内部类。

class

ComponentOrientation
ComponentOrientation 类封装语言敏感的方向，用于排序组件或文本内容。

class

Container
一般的 Abstract Window Toolkit(AWT) 容器对象是一个可包含其他 AWT 组件的组件。

protected  class

Container.AccessibleAWTContainer
用于对可访问性提供默认支持的 Container 内部类。

protected  class

Container.AccessibleAWTContainer.AccessibleContainerHandler
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

class

ContainerOrderFocusTraversalPolicy
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

class

Cursor
封装鼠标光标的位图表示形式的类。

class

DefaultFocusTraversalPolicy
根据 Container 中的子 Component 的顺序确定遍历顺序的 FocusTraversalPolicy。

class

DefaultKeyboardFocusManager
AWT 应用程序的默认 KeyboardFocusManager。

class

Desktop
Desktop 类允许 Java 应用程序启动已在本机桌面上注册的关联应用程序，以处理 URI 或文件。

class

Dialog
Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。

protected  class

Dialog.AccessibleAWTDialog
此类实现对 Dialog 类的可访问性支持。

class

Dimension
Dimension 类封装单个对象中组件的宽度和高度（精确到整数）。

class

DisplayMode
DisplayMode 类封装 GraphicsDevice 的位深、高度、宽度和刷新率。

class

Event
注：Event 类已废弃，只可用于向后兼容。

class

EventQueue
EventQueue 是一个与平台无关的类，它将来自于底层同位体类和受信任的应用程序类的事件列入队列。

class

FileDialog
FileDialog 类显示一个对话框窗口，用户可以从中选择文件。

class

FlowLayout
流布局用于安排有向流中的组件，这非常类似于段落中的文本行。

class

FocusTraversalPolicy
FocusTraversalPolicy 定义一种顺序，按此顺序遍历具有特定焦点循环根的 Component。

class

Font
Font 类表示字体，可以使用它以可见方式呈现文本。

class

FontFormatException
此异常由 Font 类中的 createFont 方法抛出，以指示指定的字体很糟糕。

class

FontMetrics
FontMetrics 类定义字体规格对象，该对象封装将在特定屏幕上呈现特定字体的有关信息。

class

Frame
Frame 是带有标题和边框的顶层窗口。

protected  class

Frame.AccessibleAWTFrame
此类实现对 Frame 类的可访问性支持。

class

GradientPaint
GradientPaint 类提供了使用线性颜色渐变模式填充 Shape 的方法。

class

Graphics
Graphics 类是所有图形上下文的抽象基类，允许应用程序在组件（已经在各种设备上实现）以及闭屏图像上进行绘制。

class

Graphics2D
此 Graphics2D 类扩展 Graphics 类，以提供对几何形状、坐标转换、颜色管理和文本布局更为复杂的控制。

class

GraphicsConfigTemplate
GraphicsConfigTemplate 类用于获得有效的 GraphicsConfiguration。

class

GraphicsConfiguration
GraphicsConfiguration 类描述图形目标（如打印机或监视器）的特征。

class

GraphicsDevice
GraphicsDevice 类描述可以在特定图形环境中使用的图形设备。

class

GraphicsEnvironment
GraphicsEnvironment 类描述了 Java(tm) 应用程序在特定平台上可用的 GraphicsDevice 对象和 Font 对象的集合。

class

GridBagConstraints
GridBagConstraints 类指定使用 GridBagLayout 类布置的组件的约束。

class

GridBagLayout
GridBagLayout 类是一个灵活的布局管理器，它不要求组件的大小相同便可以将组件垂直、水平或沿它们的基线对齐。

class

GridBagLayoutInfo
GridBagLayoutInfo 是 GridBagLayout 布局管理器的一个实用工具类。

class

GridLayout
GridLayout 类是一个布局处理器，它以矩形网格形式对容器的组件进行布置。

class

HeadlessException
在不支持键盘、显示器或鼠标的环境中调用与键盘、显示器或鼠标有关的代码时，被抛出的异常。

class

IllegalComponentStateException
当 AWT 组件未处于所请求操作的适当状态时，抛出该异常。

class

Image
抽象类 Image 是表示图形图像的所有类的超类。

class

ImageCapabilities
图像的功能和属性。

class

Insets
Insets 对象是容器边界的表示形式。

class

JobAttributes
控制打印作业的属性集合。

static class

JobAttributes.DefaultSelectionType
可能的默认选择状态的类型安全的枚举。

static class

JobAttributes.DestinationType
可能的作业目标的类型安全枚举。

static class

JobAttributes.DialogType
显示给用户的可能对话框的类型安全枚举。

static class

JobAttributes.MultipleDocumentHandlingType
可能的多副本处理状态的类型安全枚举。

static class

JobAttributes.SidesType
可能的多页整版的类型安全枚举。

class

KeyboardFocusManager
KeyboardFocusManager 负责管理激活状态的聚焦 Window 和当前焦点所有者。

class

Label
Label 对象是一个可在容器中放置文本的组件。

protected  class

Label.AccessibleAWTLabel
此类实现对 Label 类的可访问性支持。

class

LinearGradientPaint
LinearGradientPaint 类提供利用线性颜色渐变模式填充 Shape 的方式。

class

List
List 组件为用户提供了一个可滚动的文本项列表。

protected  class

List.AccessibleAWTList
此类实现 List 类的可访问性支持。

protected  class

List.AccessibleAWTList.AccessibleAWTListChild
此类实现 List 子级的可访问性支持。

class

MediaTracker
MediaTracker 类是一个跟踪多种媒体对象状态的实用工具类。

class

Menu
Menu 对象是从菜单栏部署的下拉式菜单组件。

protected  class

Menu.AccessibleAWTMenu
菜单的内部类，用于为可访问性提供默认支持。

class

MenuBar
MenuBar 类封装绑定到框架的菜单栏的平台概念。

protected  class

MenuBar.AccessibleAWTMenuBar
菜单栏的内部类，用于为可访问性提供默认支持。

class

MenuComponent
抽象类 MenuComponent 是所有与菜单相关的组件的超类。

protected  class

MenuComponent.AccessibleAWTMenuComponent
用于为可访问性提供默认支持的 MenuComponent 的内部类。

class

MenuItem
菜单中的所有项必须属于类 MenuItem 或其子类之一。

protected  class

MenuItem.AccessibleAWTMenuItem
用于为可访问性提供默认支持的 MenuItem 的内部类。

class

MenuShortcut
表示 MenuItem 键盘加速器的 MenuShortcut 类。

class

MouseInfo
MouseInfo 提供获取有关鼠标信息的方法，如鼠标指针位置和鼠标按钮数。

class

MultipleGradientPaint
这是 Paints 的超类，它使用多个颜色渐变来填充它们的光栅。

class

PageAttributes
用来控制打印页面输出的属性集。

static class

PageAttributes.ColorType
可能颜色状态的类型安全的枚举。

static class

PageAttributes.MediaType
可能的纸张大小的类型安全的枚举。

static class

PageAttributes.OrientationRequestedType
可能打印方向的类型安全的枚举。

static class

PageAttributes.OriginType
可能原点的类型安全的枚举。

static class

PageAttributes.PrintQualityType
可能的打印质量的类型安全的枚举。

class

Panel
Panel 是最简单的容器类。

protected  class

Panel.AccessibleAWTPanel
此类实现 Panel 类的可访问性支持。

class

Point
表示 (x,y) 坐标空间中的位置的点，以整数精度指定。

class

PointerInfo
描述指针位置的类。

class

Polygon
Polygon 类封装了坐标空间中封闭的二维区域的描述。

class

PopupMenu
此类实现能够在组件中的指定位置上动态弹出的菜单。

protected  class

PopupMenu.AccessibleAWTPopupMenu
用于为可访问性提供默认支持的 PopupMenu 的内部类。

class

PrintJob
启动并执行打印作业的抽象类。

class

RadialGradientPaint
RadialGradientPaint 类提供使用圆形辐射颜色渐变模式填充某一形状的方式。

class

Rectangle
Rectangle 指定坐标空间中的一个区域，通过坐标空间中 Rectangle 对象左上方的点 (x,y)、宽度和高度可以定义这个区域。

class

RenderingHints
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。

static class

RenderingHints.Key
定义与 RenderingHints 一起使用的、用来控制呈现和图像管线中各种算法选择的所有键的基本类型。

class

Robot
此类用于为测试自动化、自运行演示程序和其他需要控制鼠标和键盘的应用程序生成本机系统输入事件。

class

Scrollbar
Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。

protected  class

Scrollbar.AccessibleAWTScrollBar
此类实现 Scrollbar 类的可访问性支持。

class

ScrollPane
实现用于单个子组件的自动水平和/或垂直滚动的容器类。

protected  class

ScrollPane.AccessibleAWTScrollPane
此类实现 ScrollPane 类的可访问性支持。

class

ScrollPaneAdjustable
此类表示 ScrollPane 的水平或垂直滚动条的状态。

class

SplashScreen
在 Java 虚拟机 (JVM) 启动之前，可以在应用程序启动时创建闪现屏幕。

class

SystemColor
封装表示系统中本机 GUI 对象颜色的象征性颜色的类。

class

SystemTray
SystemTray 类表示桌面的系统托盘。

class

TextArea
TextArea 对象是显示文本的多行区域。

protected  class

TextArea.AccessibleAWTTextArea
此类实现 TextArea 类的可访问性支持。

class

TextComponent
TextComponent 类是所有允许编辑文本的组件的超类。

protected  class

TextComponent.AccessibleAWTTextComponent
此类实现对 TextComponent 类的可访问性支持。

class

TextField
TextField 对象是允许编辑单行文本的文本组件。

protected  class

TextField.AccessibleAWTTextField
此类实现 TextField 类的可访问性支持。

class

TexturePaint
TexturePaint 类提供一种用被指定为 BufferedImage 的纹理填充 Shape 的方式。

class

Toolkit
此类是所有 Abstract Window Toolkit 实际实现的抽象超类。

class

TrayIcon
TrayIcon 对象表示可以添加到系统托盘的托盘图标。

class

Window
Window 对象是一个没有边界和菜单栏的顶层窗口。

protected  class

Window.AccessibleAWTWindow
此类实现对 Window 类的可访问性支持。

声明为 Object 的 java.awt 中的字段

Object

Event.arg
事件的任意参数。

Object

Event.target
目标组件。

static Object

Image.UndefinedProperty
每当获得某个不是为特定图像定义的属性时，应返回 UndefinedProperty 对象。

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_DEFAULT
Alpha 插值提示值——由实现选择对性能和质量进行良好权衡的 alpha 混合算法

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_QUALITY
Alpha 插值提示值——选择偏重于精确度和视觉质量的 alpha 混合算法。

static Object

RenderingHints.VALUE_ALPHA_INTERPOLATION_SPEED
Alpha 插值提示值——选择偏重于计算速度的 alpha 混合算法。

static Object

RenderingHints.VALUE_ANTIALIAS_DEFAULT
抗锯齿提示值——使用由实现选择的默认抗锯齿模式完成呈现。

static Object

RenderingHints.VALUE_ANTIALIAS_OFF
抗锯齿提示值——在不使用抗锯齿模式的情况下完成呈现。

static Object

RenderingHints.VALUE_ANTIALIAS_ON
抗锯齿提示值——使用抗锯齿模式完成呈现。

static Object

RenderingHints.VALUE_COLOR_RENDER_DEFAULT
颜色呈现提示值——根据实现的选择执行颜色转换计算，以表示可用的性能和精确度之间的最佳权衡。

static Object

RenderingHints.VALUE_COLOR_RENDER_QUALITY
颜色呈现提示值——用最高的精确度和视觉质量执行颜色转换计算。

static Object

RenderingHints.VALUE_COLOR_RENDER_SPEED
颜色呈现提示值——最快地执行输出设备格式的颜色转换。

static Object

RenderingHints.VALUE_DITHER_DEFAULT
抖动提示值——对该实现选择的抖动使用默认值。

static Object

RenderingHints.VALUE_DITHER_DISABLE
抖动提示值——呈现几何形状时不抖动。

static Object

RenderingHints.VALUE_DITHER_ENABLE
抖动提示值——如果需要，在呈现几何形状时抖动。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_DEFAULT
字体小数规格提示值——用实现选择的精度定位字符字形。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_OFF
字体小数规格提示值——用舍入为像素边界的 advance width 定位字符字形。

static Object

RenderingHints.VALUE_FRACTIONALMETRICS_ON
字体小数规格提示值——用子像素精确度定位字符字形。

static Object

RenderingHints.VALUE_INTERPOLATION_BICUBIC
插值提示值—— 使用 X 和 Y 中的立方函数插入图像中整数坐标附近的 9 个样本，以生成一个颜色样本。

static Object

RenderingHints.VALUE_INTERPOLATION_BILINEAR
插值提示值——图像中最接近整数坐标样本的 4 种颜色样本被线性地插入，以生成一个颜色样本。

static Object

RenderingHints.VALUE_INTERPOLATION_NEAREST_NEIGHBOR
插值提示值——使用图像中最接近整数坐标样本的颜色样本。

static Object

RenderingHints.VALUE_RENDER_DEFAULT
呈现提示值——由实现选择对性能和质量进行良好权衡的呈现算法。

static Object

RenderingHints.VALUE_RENDER_QUALITY
呈现提示值——选择偏重输出质量的呈现算法。

static Object

RenderingHints.VALUE_RENDER_SPEED
呈现提示值——选择偏重输出速度的呈现算法。

static Object

RenderingHints.VALUE_STROKE_DEFAULT
笔划规范化控制提示值——根据给定实现的权衡，可以修改几何形状或保留原来的几何形状。

static Object

RenderingHints.VALUE_STROKE_NORMALIZE
笔划规范化控制提示值——几何形状应当规范化，以提高均匀性或直线间隔和整体美观。

static Object

RenderingHints.VALUE_STROKE_PURE
笔划规范化控制提示值——几何形状应该保持不变并使用子像素精确度呈现。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_DEFAULT
文本抗锯齿提示值——根据 RenderingHints.KEY_ANTIALIASING 提示或由实现选择的默认值完成文本呈现。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_GASP
文本抗锯齿提示值——文本呈现需要使用字体资源中的信息，这些信息指定了每个点大小是否适合应用 RenderingHints.VALUE_TEXT_ANTIALIAS_ON 或 RenderingHints.VALUE_TEXT_ANTIALIAS_OFF。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_HBGR
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素按从左到右为 B、G、R 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HBGR) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_HRGB
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，该 LCD 显示器子像素按从左到右为 R、G、B 的顺序显示，从而使水平子像素分辨率是全部水平像素分辨率 (HRGB) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_VBGR
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VBGR) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_LCD_VRGB
文本抗锯齿提示值——要求针对 LCD 显示器优化文本显示，子像素组织按从顶部到底部为 R、G、B 的顺序显示，从而使垂直子像素分辨率是全部垂直像素分辨率 (VRGB) 的三倍。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_OFF
文本抗锯齿提示值——不使用任何抗锯齿形式完成文本呈现。

static Object

RenderingHints.VALUE_TEXT_ANTIALIAS_ON
文本抗锯齿提示值——使用某种抗锯齿形式完成文本呈现。

类型参数类型为 Object 的 java.awt 中的字段

protected  Map<String,Object>

Toolkit.desktopProperties

返回 Object 的 java.awt 中的方法

Object

GridBagConstraints.clone()
创建此网格包约束（grid bag constraint）的副本。

Object

JobAttributes.clone()
创建并返回此 JobAttributes 的一个副本。

Object

PageAttributes.clone()
创建并返回此 PageAttributes 的一个副本。

Object

BufferCapabilities.clone()

Object

Insets.clone()
创建此对象的副本。

Object

ImageCapabilities.clone()

Object

RenderingHints.clone()
创建此 RenderingHints 对象的一个副本，它与此 RenderingHints 对象具有相同的内容。

Object

RenderingHints.get(Object key)
返回指定键所映射的值。

Object

BorderLayout.getConstraints(Component comp)
获取指定组件的约束

Object

Toolkit.getDesktopProperty(String propertyName)
获取指定桌面属性的值。

Object[]

MediaTracker.getErrorsAny()
返回所有出错媒体的列表。

Object[]

MediaTracker.getErrorsID(int id)
返回具有出错的指定 ID 的媒体列表。

abstract  Object

Image.getProperty(String name, ImageObserver observer)
通过名称获取此图像的属性。

abstract  Object

Graphics2D.getRenderingHint(RenderingHints.Key hintKey)
返回呈现算法的单个首选项的值。

Object[]

Checkbox.getSelectedObjects()
返回包含复选框标签的数组 (length 1)，如果没有选定复选框，则返回 null。

Object[]

CheckboxMenuItem.getSelectedObjects()
返回一个数组（长度为 1)，它包含复选框菜单项的标签，如果没有选中复选框，则返回 null。

Object[]

Choice.getSelectedObjects()
返回包含当前选定项的数组（长度为 1）。

Object[]

List.getSelectedObjects()
获取对象数组中此滚动列表的选中项。

Object[]

ItemSelectable.getSelectedObjects()
返回选定项；如果没有选定的项，则返回 null。

protected  Object

MenuComponent.getTreeLock()
获取此组件的锁定对象（拥有该线程同步监视器的对象），该对象可用于 AWT 组件树和布局操作。

Object

Component.getTreeLock()
获取此组件用于 AWT 组件树和布局操作的锁定对象（拥有线程同步监视器的对象）。

protected  Object

Toolkit.lazilyLoadDesktopProperty(String name)
一个对桌面属性值延迟计算的机会。

Object

RenderingHints.put(Object key, Object value)
将指定 key 映射到此 RenderingHints 对象中指定的 value。

protected  Object

AWTKeyStroke.readResolve()
返回 AWTKeyStroke 的一个缓存实例（或 AWTKeyStroke 的子类），它与此实例相等。

Object

RenderingHints.remove(Object key)
从此 RenderingHints 对象中移除键和它所对应的值。

返回变量类型为 Object 的类型的 java.awt 中的方法

Set<Map.Entry<Object,Object>>

RenderingHints.entrySet()
返回此 RenderingHints 中所包含映射关系的 Set 视图。

Set<Map.Entry<Object,Object>>

RenderingHints.entrySet()
返回此 RenderingHints 中所包含映射关系的 Set 视图。

Set<Object>

RenderingHints.keySet()
返回此 RenderingHints 中所包含键的 Set 视图。

Collection<Object>

RenderingHints.values()
返回此 RenderinHints 中所包含键的 Collection 视图。

参数类型为 Object 的 java.awt 中的方法

boolean

Component.action(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，应该将此组件作为组件（激发动作事件）上的 ActionListener 来注册。

void

Container.add(Component comp, Object constraints)
将指定的组件添加到此容器的尾部。

void

Container.add(Component comp, Object constraints, int index)
使用指定约束，将指定组件添加到此容器的指定索引所在的位置上。

protected  void

ScrollPane.addImpl(Component comp, Object constraints, int index)
将指定的组件添加到此滚动窗格容器。

protected  void

Container.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。

void

GridBagLayout.addLayoutComponent(Component comp, Object constraints)
使用指定 constraints 对象将指定组件添加到布局中。

void

CardLayout.addLayoutComponent(Component comp, Object constraints)
将指定的组件添加到此卡片布局的内部名称表。

void

BorderLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。

void

LayoutManager2.addLayoutComponent(Component comp, Object constraints)
使用指定约束对象，将指定组件添加到布局。

boolean

RenderingHints.containsKey(Object key)
如果此 RenderingHints 包含指定键的映射关系，则返回 true。

boolean

RenderingHints.containsValue(Object value)
如果此 RenderingHints 将一个或多个键映射到指定值，则返回 true。

boolean

DisplayMode.equals(Object dm)
指示其他某个对象是否与此对象“相等”。

boolean

JobAttributes.equals(Object obj)
确定两个 JobAttributes 是否相等。

boolean

PageAttributes.equals(Object obj)
确定两个 PageAttributes 是否相等。

boolean

MenuShortcut.equals(Object obj)
返回此菜单快捷方式是否与另一个相同：定义相等性意味着两个菜单快捷方式使用相同的键，而且两者或者使用或者不使用 SHIFT 键。

boolean

Point.equals(Object obj)
确定两个点是否相等。

boolean

AWTKeyStroke.equals(Object anObject)
如果此对象与指定对象相同，则返回 true。

boolean

Insets.equals(Object obj)
检查两个 insets 对象是否等价。

boolean

Rectangle.equals(Object obj)
检查两个矩形是否相等。

boolean

BasicStroke.equals(Object obj)
测试指定对象与此 BasicStroke 是否相等，首先测试指定对象是否是一个 BasicStroke，然后将其宽度、连接、cap、斜接限制、虚线和虚线相位属性与 BasicStroke 的那些属性进行比较。

boolean

AlphaComposite.equals(Object obj)
确定指定的对象是否等于此 AlphaComposite。

boolean

Color.equals(Object obj)
确定另一个对象是否与此 Color 相同。

boolean

RenderingHints.equals(Object o)
对指定的 Object 与此 RenderingHints 进行相等性比较。

boolean

RenderingHints.Key.equals(Object o)
用于所有 Key 对象的 equals 方法将返回与等号运算符 '==' 相同的结果。

boolean

Font.equals(Object obj)
将此 Font 对象与指定 Object 进行比较。

boolean

Dimension.equals(Object obj)
检查两个 dimension 对象是否具有相同的值。

protected  void

KeyboardFocusManager.firePropertyChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应绑定属性中的更改。

protected  void

Component.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 Object 属性的绑定属性改变。

protected  void

KeyboardFocusManager.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
激发 PropertyChangeEvent 以响应可否决属性中的更改。

Object

RenderingHints.get(Object key)
返回指定键所映射的值。

Component

BorderLayout.getLayoutComponent(Container target, Object constraints)
基于目标 Container 的组件方向，返回给定约束位置对应的组件。

Component

BorderLayout.getLayoutComponent(Object constraints)
获取使用给定约束添加的组件。

boolean

Component.gotFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。

abstract  boolean

RenderingHints.Key.isCompatibleValue(Object val)
如果指定对象是此 Key 的有效值，则返回 true。

boolean

Component.lostFocus(Event evt, Object what)
已过时。 从 JDK version 1.1 开始，由 processFocusEvent(FocusEvent) 取代。

Object

RenderingHints.put(Object key, Object value)
将指定 key 映射到此 RenderingHints 对象中指定的 value。

Object

RenderingHints.remove(Object key)
从此 RenderingHints 对象中移除键和它所对应的值。

protected  void

Toolkit.setDesktopProperty(String name, Object newValue)
将指定桌面属性设置为指定值，并触发一个属性更改事件，以通知所有侦听器该值已更改。

abstract  void

Graphics2D.setRenderingHint(RenderingHints.Key hintKey, Object hintValue)
为呈现算法设置单个首选项的值。

void

AWTEvent.setSource(Object newSource)
将事件的目标更改为新的源。

参数类型为 Object 的 java.awt 中的构造方法

AWTEvent(Object source, int id)
使用指定的源对象和类型构造一个 AWTEvent 对象。

Event(Object target, int id, Object arg)
注：Event 类已废弃，只可用于向后兼容。

Event(Object target, long when, int id, int x, int y, int key, int modifiers)
注：Event 类已废弃，只可用于向后兼容。

Event(Object target, long when, int id, int x, int y, int key, int modifiers, Object arg)
注：Event 类已废弃，只可用于向后兼容。

RenderingHints(RenderingHints.Key key, Object value)
构造一个具有指定键/值对的新对象。

java.awt.color 中 Object 的使用

java.awt.color 中 Object 的子类

class

CMMException
如果本机 CMM 返回一个错误，则抛出此异常。

class

ColorSpace
此抽象类用做一个颜色空间标记，标识 Color 对象的特定颜色空间，或者通过 ColorModel 对象标识 Image、BufferedImage 或 GraphicsDevice 的特定颜色空间。

class

ICC_ColorSpace
ICC_ColorSpace 类是抽象 ColorSpace 类的实现。

class

ICC_Profile
与设备无关和设备相关颜色空间的颜色配置文件数据表示形式，该表示形式基于国际色彩联盟规范 ICC.1:2001-12，颜色配置文件的文件格式（请参阅 http://www.color.org）。

class

ICC_ProfileGray
ICC_Profile 类的子类，表示满足以下标准的配置文件：配置文件的颜色空间类型是 TYPE_GRAY，并且配置文件包括 grayTRCTag 和 mediaWhitePointTag 标记。

class

ICC_ProfileRGB
ICC_ProfileRGB 类是 ICC_Profile 类的子类，它表示满足以下标准的配置文件： 配置文件的颜色空间类型是 RGB。

class

ProfileDataException
当访问或处理 ICC_Profile 对象出现错误时，抛出此异常。

返回 Object 的 java.awt.color 中的方法

protected  Object

ICC_Profile.readResolve()
解析将被反序列化为用 CMM 注册的实例的实例。

java.awt.datatransfer 中 Object 的使用

java.awt.datatransfer 中 Object 的子类

class

Clipboard
此类实现一种使用剪切/复制/粘贴操作传输数据的机制。

class

DataFlavor
DataFlavor 提供有关数据的元信息。

class

FlavorEvent
FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。

class

MimeTypeParseException
对分析相关异常的 MimeType 进行封装的类

class

StringSelection
实现传输 String 所需能力的 Transferable。

class

SystemFlavorMap
SystemFlavorMap 是 "native" (String)（对应于特定于平台的数据格式）和 "flavor" (DataFlavor)（对应于与平台无关的 MIME 类型）之间的可配置映射。

class

UnsupportedFlavorException
在此 flavor 中不支持所请求的数据的信号。

返回 Object 的 java.awt.datatransfer 中的方法

Object

DataFlavor.clone()
返回此 DataFlavor 的副本。

Object

Clipboard.getData(DataFlavor flavor)
返回一个对象，表示此剪贴板中指定 DataFlavor 类型的当前内容。

Object

StringSelection.getTransferData(DataFlavor flavor)
如果可能，则使用请求的 DataFlavor 返回 Transferable 的数据。

Object

Transferable.getTransferData(DataFlavor flavor)
返回一个对象，该对象表示将要被传输的数据。

参数类型为 Object 的 java.awt.datatransfer 中的方法

boolean

DataFlavor.equals(Object o)
测试任意 Object 与此 DataFlavor 的相等性。

Transferable

Clipboard.getContents(Object requestor)
返回表示剪贴板当前内容的 transferable 对象。

java.awt.dnd 中 Object 的使用

java.awt.dnd 中 Object 的子类

class

DnDConstants
此类包含了表示 Drag 和 Drop 操作所执行的操作类型的常量值。

class

DragGestureEvent
当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。

class

DragGestureRecognizer
DragGestureRecognizer 是一个针对与平台相关的侦听器规范的抽象基类，它可以与特定 Component 关联以标识与平台相关的拖动开始动作。

class

DragSource
DragSource 是负责开始 Drag 和 Drop 操作的实体，可以用在如下场景中： JVM 生命周期中每个 JVM 的一个默认实例。

class

DragSourceAdapter
用于接收拖动源事件的抽象适配器类。

class

DragSourceContext
DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。

class

DragSourceDragEvent
通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。

class

DragSourceDropEvent
通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。

class

DragSourceEvent
此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。

class

DropTarget
在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。

protected static class

DropTarget.DropTargetAutoScroller
此受保护的嵌套类实现自动滚动

class

DropTargetAdapter
接收放置目标事件的抽象适配器类。

class

DropTargetContext
每当与 Drag 和 Drop 操作相关的逻辑光标和与 DropTarget 相关的 Component 的可见几何结构重合时，就创建一个 DropTargetContext。

protected  class

DropTargetContext.TransferableProxy
TransferableProxy 是一个帮助器内部类，它实现 Transferable 接口，并用作另一个表示特定 drag-n-drop（拖放）操作数据转换的 Transferable 对象的代理。

class

DropTargetDragEvent
通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。

class

DropTargetDropEvent
通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。

class

DropTargetEvent
DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。

class

InvalidDnDOperationException
java.awt.dnd 包中的各种方法都会抛出此异常。

class

MouseDragGestureRecognizer
DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

返回 Object 的 java.awt.dnd 中的方法

Object

DropTargetContext.TransferableProxy.getTransferData(DataFlavor df)
返回一个对象，该对象表示数据是由封装的 transferable 为所请求的数据 flavor 提供的。

Object[]

DragGestureEvent.toArray()
返回组成拖动动作的事件 Object 数组。

Object[]

DragGestureEvent.toArray(Object[] array)
返回组成拖动动作的事件数组。

参数类型为 Object 的 java.awt.dnd 中的方法

Object[]

DragGestureEvent.toArray(Object[] array)
返回组成拖动动作的事件数组。

java.awt.event 中 Object 的使用

java.awt.event 中 Object 的子类

class

ActionEvent
指示发生了组件定义的动作的语义事件。

class

AdjustmentEvent
由 Adjustable 对象所发出的调整事件。

class

AWTEventListenerProxy
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。

class

ComponentAdapter
用于接收组件事件的抽象适配器类。

class

ComponentEvent
指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。

class

ContainerAdapter
用于接收容器事件的抽象适配器类。

class

ContainerEvent
指示容器内容因为添加或移除组件而更改的低级别事件。

class

FocusAdapter
用于接收键盘焦点事件的抽象适配器类。

class

FocusEvent
指示 Component 已获得或失去输入焦点的低级别事件。

class

HierarchyBoundsAdapter
用于接收祖先的移动和大小重调事件的抽象适配器类。

class

HierarchyEvent
指示 Component 所属的 Component 层次结构发生更改的事件。

class

InputEvent
所有组件级别输入事件的根事件类。

class

InputMethodEvent
输入方法事件包含有关使用输入方法进行撰写的文本的信息。

class

InvocationEvent
当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。

class

ItemEvent
指示项被选定或取消选定的语义事件。

class

KeyAdapter
接收键盘事件的抽象适配器类。

class

KeyEvent
表示组件中发生键击的事件。

class

MouseAdapter
接收鼠标事件的抽象适配器类。

class

MouseEvent
指示组件中发生鼠标动作的事件。

class

MouseMotionAdapter
接收鼠标移动事件的抽象适配器类。

class

MouseWheelEvent
表示鼠标滚轮在组件中滚动的事件。

class

PaintEvent
组件级绘制事件。

class

TextEvent
指示对象文本已改变的语义事件。

class

WindowAdapter
接收窗口事件的抽象适配器类。

class

WindowEvent
指示窗口状态改变的低级别事件。

声明为 Object 的 java.awt.event 中的字段

protected  Object

InvocationEvent.notifier
在 Runnable.run() 方法返回之后立即调用其 notifyAll() 方法的对象（可能为 null）。

返回 Object 的 java.awt.event 中的方法

Object

ItemEvent.getItem()
返回受事件影响的项。

参数类型为 Object 的 java.awt.event 中的构造方法

ActionEvent(Object source, int id, String command)
构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, int modifiers)
使用修改键构造一个 ActionEvent 对象。

ActionEvent(Object source, int id, String command, long when, int modifiers)
使用指定修改键和时间戳构造一个 ActionEvent 对象。

InvocationEvent(Object source, int id, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源和 ID 的 InvocationEvent，此源和 ID 将在被指派时执行 runnable 的 run 方法。

InvocationEvent(Object source, Runnable runnable)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。

InvocationEvent(Object source, Runnable runnable, Object notifier, boolean catchThrowables)
构造一个具有指定源的 InvocationEvent，此源将在被指派时执行 runnable 的 run 方法。

ItemEvent(ItemSelectable source, int id, Object item, int stateChange)
构造一个 ItemEvent 对象。

TextEvent(Object source, int id)
构造一个 TextEvent 对象。

java.awt.font 中 Object 的使用

java.awt.font 中 Object 的子类

class

FontRenderContext
FontRenderContext 类是正确测量文本所需的信息容器。

class

GlyphJustificationInfo
GlyphJustificationInfo 类表示关于字形调整属性的信息。

class

GlyphMetrics
GlyphMetrics 类表示单个字形的信息。

class

GlyphVector
GlyphVector 对象是一个字形的集合，包含在转换坐标空间中放置每个字形的几何信息，该坐标空间对应于最终要显示 GlyphVector 的设备。

class

GraphicAttribute
此类与 CHAR_REPLACEMENT 属性一起使用。

class

ImageGraphicAttribute
ImageGraphicAttribute 类是在 TextLayout 中绘制图像的 GraphicAttribute 实现。

class

LayoutPath
LayoutPath 提供相对于基线的位置与用户空间中的点之间的映射。

class

LineBreakMeasurer
LineBreakMeasurer 类允许将样式化的文本断为行（或段），以符合特定的可视 advance。

class

LineMetrics
LineMetrics 类允许访问沿着一行布局字符和多行布局所需要的规格。

class

NumericShaper
NumericShaper 类用于将 Latin-1（欧洲语）数字转换成其他 Unicode 十进制数字。

class

ShapeGraphicAttribute
ShapeGraphicAttribute 类是以 TextLayout 形式绘制形状的 GraphicAttribute 的实现。

class

TextAttribute
TextAttribute 类定义用于呈现文本的属性键和属性值。

class

TextHitInfo
TextHitInfo 类表示文本模型中的字符位置以及字符的斜线或“边”。

class

TextLayout
TextLayout 是样式字符数据的不可变图形表示形式。

static class

TextLayout.CaretPolicy
定义确定强插入符位置的策略。

class

TextMeasurer
TextMeasurer 类提供换行所需的基本操作：测量到给定的 advance，确定字符范围的 advance，并为字符范围生成一个 TextLayout。

class

TransformAttribute
TransformAttribute 类为转换提供一个不可变的包装器，使其可以安全地作为属性使用。

返回 Object 的 java.awt.font 中的方法

protected  Object

TextLayout.clone()
创建此 TextLayout 的副本。

protected  Object

TextMeasurer.clone()

Object

FontRenderContext.getAntiAliasingHint()
返回此 FontRenderContext 中使用的文本 anti-aliasing 呈现模式提示。

Object

FontRenderContext.getFractionalMetricsHint()
返回此 FontRenderContext 中使用的文本 fractional metrics 呈现模式提示。

protected  Object

TextAttribute.readResolve()
将反序列化的实例解析为预定义常量。

参数类型为 Object 的 java.awt.font 中的方法

boolean

ImageGraphicAttribute.equals(Object rhs)
比较此 ImageGraphicAttribute 与指定的 Object。

boolean

NumericShaper.equals(Object o)
如果指定的对象是 NumericShaper 的一个实例，并且完全一致地成形到此实例，则返回 true。

boolean

ShapeGraphicAttribute.equals(Object rhs)
将此 ShapeGraphicAttribute 与指定的 Object 进行比较。

boolean

TextHitInfo.equals(Object obj)
如果指定的 Object 是一个 TextHitInfo 并且等于此 TextHitInfo，则返回 true。

boolean

TextLayout.equals(Object obj)
如果指定 Object 是一个 TextLayout 对象，且指定的 Object 等于此 TextLayout，则返回 true。

boolean

TransformAttribute.equals(Object rhs)
如果 rhs 是一个变换等效于此 TransformAttribute 变换的 TransformAttribute，则返回 true。

boolean

FontRenderContext.equals(Object obj)
如果 obj 是 FontRenderContext 的一个实例，并且具有与此 FontRenderContext 相同的转换、antialiasing 和 fractional metrics 值，则返回 true。

参数类型为 Object 的 java.awt.font 中的构造方法

FontRenderContext(AffineTransform tx, Object aaHint, Object fmHint)
根据一个可选 AffineTransform 和两个 Object 值构造一个 FontRenderContext 对象，这两个值决定了新创建的对象是具有 anti-aliasing 属性，还是具有 fractional metrics 属性。

java.awt.geom 中 Object 的使用

java.awt.geom 中 Object 的子类

class

AffineTransform
AffineTransform 类表示 2D 仿射变换，它执行从 2D 坐标到其他 2D 坐标的线性映射，保留了线的“直线性”和“平行性”。

class

Arc2D
Arc2D 是所有存储 2D 弧度的对象的抽象超类，其中 2D 弧度由窗体矩形、起始角度、角跨越（弧的长度）和闭合类型（OPEN、CHORD 或 PIE）定义。

static class

Arc2D.Double
此类定义以 double 精度指定的弧。

static class

Arc2D.Float
此类定义以 float 精度指定的弧。

class

Area
Area 对象存储和操作 2 维空间封闭区域的与解析无关的描述。

class

CubicCurve2D
CubicCurve2D 类定义 (x,y) 坐标空间内的三次参数曲线段。

static class

CubicCurve2D.Double
使用 double 坐标指定的三次参数曲线段。

static class

CubicCurve2D.Float
使用 float 坐标指定的三次参数曲线段。

class

Dimension2D
Dimension2D 类用于封装宽度和高度尺寸。

class

Ellipse2D
Ellipse2D 类描述窗体矩形定义的椭圆。

static class

Ellipse2D.Double
Double 类以 double 精度定义椭圆。

static class

Ellipse2D.Float
Float 类以 float 精度定义椭圆。

class

FlatteningPathIterator
FlatteningPathIterator 类返回另一个 PathIterator 对象的变平视图。

class

GeneralPath
GeneralPath 类表示根据直线、二次曲线和三次 (Bézier) 曲线构造的几何路径。

class

IllegalPathStateException
对于正在执行的特定操作而言（如将路径段追加到不具有初始 moveto 的 GeneralPath），如果操作在处于非法状态的路径上执行，则 IllegalPathStateException 表示抛出的异常。

class

Line2D
Line2D 表示 (x,y) 坐标空间中的线段。

static class

Line2D.Double
使用 double 坐标指定的线段。

static class

Line2D.Float
使用 float 坐标指定的线段。

class

NoninvertibleTransformException
NoninvertibleTransformException 类表示在执行的操作要求 AffineTransform 对象可逆但 AffineTransform 处于不可逆状态时抛出的异常。

class

Path2D
Path2D 类提供一个表示任意几何形状路径的简单而又灵活的形状。

static class

Path2D.Double
Double 类定义了一条几何路径，它具有以双精度浮点值形式存储的坐标。

static class

Path2D.Float
Float 类定义了一条几何路径，它具有以单精度浮点值形式存储的坐标。

class

Point2D
Point2D 类定义表示 (x,y) 坐标空间中位置的点。

static class

Point2D.Double
Double 类以 double 精度定义指定的点。

static class

Point2D.Float
Float 类以 float 精度定义指定的点。

class

QuadCurve2D
QuadCurve2D 类定义 (x,y) 坐标空间内的二次参数曲线段。

static class

QuadCurve2D.Double
使用 double 坐标指定的二次参数曲线段。

static class

QuadCurve2D.Float
使用 float 坐标指定的二次参数曲线段。

class

Rectangle2D
Rectangle2D 类描述通过位置 (x,y) 和尺寸 (w x h) 定义的矩形。

static class

Rectangle2D.Double
Double 类定义一个在 double 坐标中指定的矩形。

static class

Rectangle2D.Float
Float 类定义一个在 float 坐标中指定的矩形。

class

RectangularShape
RectangularShape 是许多 Shape 对象的基类，这些对象的几何形状由矩形窗体定义。

class

RoundRectangle2D
RoundRectangle2D 类定义一个矩形，该矩形具有由位置 (x,y)、维度 (w x h) 以及圆角弧的宽度和高度定义的圆角。

static class

RoundRectangle2D.Double
Double 类定义一个所有圆角都使用 double 坐标指定的矩形。

static class

RoundRectangle2D.Float
Float 类定义一个所有圆角都使用 float 坐标指定的矩形。

返回 Object 的 java.awt.geom 中的方法

Object

Area.clone()
返回此 Area 对象的精确副本。

Object

CubicCurve2D.clone()
创建一个与此对象具有相同类的新对象。

Object

Line2D.clone()
创建一个与此对象具有相同类的新对象。

abstract  Object

Path2D.clone()
创建一个与此对象具有相同类的新对象。

Object

Path2D.Float.clone()
创建一个与此对象具有相同类的新对象。

Object

Path2D.Double.clone()
创建一个与此对象具有相同类的新对象。

Object

QuadCurve2D.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

RectangularShape.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

Point2D.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

AffineTransform.clone()
返回此 AffineTransform 对象的副本。

Object

Dimension2D.clone()
创建一个与此对象具有相同类的新对象。

参数类型为 Object 的 java.awt.geom 中的方法

boolean

Arc2D.equals(Object obj)
确定指定的 Object 是否与此 Arc2D 相等。

boolean

Ellipse2D.equals(Object obj)
确定指定的 Object 是否与此 Ellipse2D 相等。

boolean

RoundRectangle2D.equals(Object obj)
确定指定的 Object 是否与此 RoundRectangle2D 相等。

boolean

Rectangle2D.equals(Object obj)
确定指定的 Object 是否与此 Rectangle2D 相等。

boolean

Point2D.equals(Object obj)
确定两个点是否相等。

boolean

AffineTransform.equals(Object obj)
如果此 AffineTransform 表示与指定参数相同的仿射坐标变换，则返回 true。

java.awt.im 中 Object 的使用

java.awt.im 中 Object 的子类

class

InputContext
提供控制诸如输入方法和键盘布局之类的文本输入设施的方法。

class

InputMethodHighlight
InputMethodHighlight 用于描述正在撰写的文本的高亮显示属性。

class

InputSubset
定义输入方法使用的其他 Unicode 子集。

返回 Object 的 java.awt.im 中的方法

Object

InputContext.getInputMethodControlObject()
返回当前输入方法中的一个控制对象，或 null。

java.awt.im.spi 中 Object 的使用

返回 Object 的 java.awt.im.spi 中的方法

Object

InputMethod.getControlObject()
从此输入方法返回一个控制对象，或 null。

java.awt.image 中 Object 的使用

java.awt.image 中 Object 的子类

class

AffineTransformOp
此类使用仿射转换来执行从源图像或 Raster 中 2D 坐标到目标图像或 Raster 中 2D 坐标的线性映射。

class

AreaAveragingScaleFilter
这是一个 ImageFilter 类，它使用一个简单的区域平均算法来进行图像缩放，该算法产生比其最相近算法更平滑的结果。

class

BandCombineOp
此类使用一个指定矩阵对 Raster 中的 band 进行任意线性组合。

class

BandedSampleModel
此类表示以 band 交错方式存储的图像数据，像素的每个样本都占用 DataBuffer 的一个数据元素。

class

BufferedImage
BufferedImage 子类描述具有可访问图像数据缓冲区的 Image。

class

BufferedImageFilter
BufferedImageFilter 类是 ImageFilter 的子类，提供一种使用单一源图像/单一目标图像操作符 (BufferedImageOp) 的简单方式来过滤 Image Producer/Consumer/Observerto 范例中的 BufferedImage。

class

BufferStrategy
BufferStrategy 类表示用来在特定的 Canvas 或 Window 上组织复杂内存的机制。

class

ByteLookupTable
此类定义一个 lookup table 对象。

class

ColorConvertOp
此类对源图像中的数据执行逐像素的颜色转换。

class

ColorModel
此 ColorModel 抽象类封装了将像素值转换为颜色分量（例如，红色、绿色和蓝色）和 alpha 分量的方法。

class

ComponentColorModel
使用像素值将颜色和 alpha 信息表示为独立样本的 ColorModel 类，该类以独立的数据元素存储每个样本。

class

ComponentSampleModel
此类表示按每个像素样本占用 DataBuffer 中一个数据元素的方式存储的图像数据。

class

ConvolveOp
此类实现从源到目标的卷积。

class

CropImageFilter
用于裁剪图像的 ImageFilter 类。

class

DataBuffer
此类用于包装一个或多个数据数组。

class

DataBufferByte
此类扩展了 DataBuffer，并在内部按字节存储数据。

class

DataBufferDouble
此类扩展了 DataBuffer，并在内部以 double 形式存储数据。

class

DataBufferFloat
此类扩展了 DataBuffer，并在内部以 float 形式存储数据。

class

DataBufferInt
此类扩展了 DataBuffer，并在内部以整数形式存储数据。

class

DataBufferShort
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。

class

DataBufferUShort
此类扩展了 DataBuffer，并在内部以 short 类型存储数据。

class

DirectColorModel
DirectColorModel 类是使用像素值的 ColorModel 类，像素值以单独样本的形式表示 RGB 颜色和 alpha 信息，并将单个像素的所有样本打包成单个 int、short 或 byte 量。

class

FilteredImageSource
此类是 ImageProducer 接口的一个实现，该接口使用现有的图像和过滤器对象作为参数，并使用它们为原图像的新过滤版本产生图像数据。

class

ImageFilter
此类为用于从 ImageProducer 向 ImageConsumer 传递数据的接口方法集合实现了一个过滤器。

class

ImagingOpException
如果某个 BufferedImageOp 或 RasterOp 过滤器方法无法处理图像，则抛出 ImagingOpException。

class

IndexColorModel
IndexColorModel 类是一个 ColorModel 类，它使用由单个样本组成的像素值，这些像素值是默认 sRGB 颜色空间中固定 colormap 中的索引。

class

Kernel
Kernel 类定义了一个矩阵，描述指定的像素及其周围像素如何影响过滤操作输出图像中像素位置的计算值。

class

LookupOp
此类实现从源到目标的查找操作。

class

LookupTable
此抽象类定义了一个查找表对象。

class

MemoryImageSource
此类是 ImageProducer 接口的一个实现，该接口使用一个数组为 Image 生成像素值。

class

MultiPixelPackedSampleModel
MultiPixelPackedSampleModel 类表示单 band 图像，能够将多个单样本像素打包到一个数据元素中。

class

PackedColorModel
PackedColorModel 类是一个抽象 ColorModel 类，它使用的像素值以单独采样表示颜色和 alpha 信息，并将单个像素的所有采样打包到单个 int、short 或 byte 量中。

class

PixelGrabber
PixelGrabber 类实现可以附加在 Image 或 ImageProducer 对象上获得图像像素子集的 ImageConsumer。

class

PixelInterleavedSampleModel
此类表示以像素交替方式存储的图像数据，其中像素的每个采样占用 DataBuffer 的一个数据元素。

class

Raster
表示像素矩形数组的类。

class

RasterFormatException
如果 Raster 中存在无效的布局信息，则抛出 RasterFormatException。

class

ReplicateScaleFilter
使用最简单的算法缩放图像的 ImageFilter 类。

class

RescaleOp
通过将每个像素的样本值乘以一个缩放因子，然后加上一个偏移量，此类对源图像中数据进行逐像素重缩放。

class

RGBImageFilter
此类提供一种便捷方式创建 ImageFilter，创建的 ImageFilter 可修改使用默认 RGB ColorModel 图像的像素。

class

SampleModel
此抽象类定义一个提取图像像素样本的接口。

class

ShortLookupTable
此类定义了一个查找表对象。

class

SinglePixelPackedSampleModel
此类表示压缩的像素数据：将 N 个样本组成的单个像素存储在单个数据数组元素中，每个数据数组元素只保存一个像素的样本。

class

VolatileImage
VolatileImage 是一种图像，它可以在不受应用程序控制的情形下（例如，由操作系统或其他应用程序引起的情况）随时丢失其内容。

class

WritableRaster
此类扩展了 Raster 以提供像素写入功能。

声明为 Object 的 java.awt.image 中的字段

protected  Object

ReplicateScaleFilter.outpixbuf
使用 ReplicateScaleFilter.destWidth 的大小初始化的 byte 数组，用于将像素数据行传递给 ImageConsumer。

返回 Object 的 java.awt.image 中的方法

Object

Kernel.clone()
复制此对象。

Object

ImageFilter.clone()
复制此对象。

Object

ComponentColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ComponentColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

IndexColorModel.getDataElements(int[] components, int offset, Object pixel)
在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。

Object

DirectColorModel.getDataElements(int[] components, int offset, Object obj)
在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

Raster.getDataElements(int x, int y, int w, int h, Object outData)
以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。

Object

SampleModel.getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回指定像素矩形的像素数据。

Object

Raster.getDataElements(int x, int y, Object outData)
以 TransferType 类型的基本数组形式返回单个像素的数据。

Object

BandedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回单个像素的数据。

Object

MultiPixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

SinglePixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

ComponentSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
以 TransferType 类型基本数组形式返回单个像素的数据。

abstract  Object

SampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型的基本数组中返回单个像素的数据。

Object

ComponentColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

IndexColorModel.getDataElements(int rgb, Object pixel)
根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

DirectColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

ColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

PixelGrabber.getPixels()
获取像素缓冲区。

Object

BufferedImage.getProperty(String name)
按名称返回图像的属性。

Object

RenderedImage.getProperty(String name)
从此图像的属性设置中获取一个属性。

Object

BufferedImage.getProperty(String name, ImageObserver observer)
按名称返回图像的属性。

参数类型为 Object 的 java.awt.image 中的方法

boolean

ComponentColorModel.equals(Object obj)
将此颜色模型与其他模型进行相等性比较。

boolean

MultiPixelPackedSampleModel.equals(Object o)

boolean

SinglePixelPackedSampleModel.equals(Object o)

boolean

ComponentSampleModel.equals(Object o)

boolean

PackedColorModel.equals(Object obj)
测试指定的 Object 是否为 PackedColorModel 的一个实例并且等于此 PackedColorModel。

boolean

ColorModel.equals(Object obj)
测试指定的 Object 是否是 ColorModel 的实例，以及它是否等于此 ColorModel。

int

ComponentColorModel.getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。

int

DirectColorModel.getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。

int

ColorModel.getAlpha(Object inData)
返回指定像素（在 0 到 255 之间缩放）的 alpha 分量。

int

ComponentColorModel.getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

DirectColorModel.getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ColorModel.getBlue(Object inData)
返回指定像素的蓝颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int[]

ComponentColorModel.getComponents(Object pixel, int[] components, int offset)
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。

int[]

IndexColorModel.getComponents(Object pixel, int[] components, int offset)
返回此 ColorModel 中指定像素的非标准化颜色/alpha 分量数组。

int[]

DirectColorModel.getComponents(Object pixel, int[] components, int offset)
返回在 ColorModel 中已给定像素的未标准化颜色/alpha 分量。

int[]

ColorModel.getComponents(Object pixel, int[] components, int offset)
返回在此 ColorModel 中已给定像素的非标准化颜色/alpha 分量的数组。

Object

ComponentColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(float[] normComponents, int normOffset, Object obj)
在已给定标准化颜色/alpha 分量的数组的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

ComponentColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

IndexColorModel.getDataElements(int[] components, int offset, Object pixel)
在给定非标准化颜色/alpha 分量数组的情况下，返回表示此 ColorModel 中像素的数据元素数组。

Object

DirectColorModel.getDataElements(int[] components, int offset, Object obj)
在给定未标准化的颜色/alpha 分量的数组的情况下，返回此 ColorModel 中的像素的数据元素数组表示形式。

Object

ColorModel.getDataElements(int[] components, int offset, Object obj)
在已给定非标准化颜色/alpha 分量的情况下，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

Raster.getDataElements(int x, int y, int w, int h, Object outData)
以 TransferType 类型基本数组形式返回指定像素矩形的像素数据。

Object

SampleModel.getDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回指定像素矩形的像素数据。

Object

Raster.getDataElements(int x, int y, Object outData)
以 TransferType 类型的基本数组形式返回单个像素的数据。

Object

BandedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型基本数组中返回单个像素的数据。

Object

MultiPixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

SinglePixelPackedSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
返回 TransferType 类型基本数组中单个像素的数据。

Object

ComponentSampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
以 TransferType 类型基本数组形式返回单个像素的数据。

abstract  Object

SampleModel.getDataElements(int x, int y, Object obj, DataBuffer data)
在 TransferType 类型的基本数组中返回单个像素的数据。

Object

ComponentColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

IndexColorModel.getDataElements(int rgb, Object pixel)
根据默认 RGB 颜色模型中的整数像素表示形式，返回此 ColorModel 中像素的数据元素数组表示形式。

Object

DirectColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

Object

ColorModel.getDataElements(int rgb, Object pixel)
在默认 RGB 颜色模型中给定整数像素的表示形式的情况下，返回此 ColorModel 中像素的数据元素数组的表示形式。

int

ComponentColorModel.getGreen(Object inData)
返回指定像素的绿色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

DirectColorModel.getGreen(Object inData)
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ColorModel.getGreen(Object inData)
返回指定像素的绿色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255）。

float[]

ComponentColorModel.getNormalizedComponents(Object pixel, float[] normComponents, int normOffset)
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。

float[]

ColorModel.getNormalizedComponents(Object pixel, float[] normComponents, int normOffset)
返回已在 ColorModel 中给定了像素的标准化形式颜色/alpha 分量的数组。

int

ComponentColorModel.getRed(Object inData)
返回指定像素的红色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

DirectColorModel.getRed(Object inData)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ColorModel.getRed(Object inData)
返回指定像素的红色颜色分量，指定像素在默认的 RGB ColorSpace（即 sRGB）中缩放范围是 0 到 255。

int

ComponentColorModel.getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。

int

DirectColorModel.getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。

int

ColorModel.getRGB(Object inData)
返回默认的 RGB 颜色模型格式中的像素的颜色/alpha 分量。

void

WritableRaster.setDataElements(int x, int y, int w, int h, Object inData)
为类型 TransferType 基本数组中的像素矩形设置数据。

void

SampleModel.setDataElements(int x, int y, int w, int h, Object obj, DataBuffer data)
根据 TransferType 类型的基本数组设置指定 DataBuffer 中像素矩形的数据。

void

WritableRaster.setDataElements(int x, int y, Object inData)
为类型 TransferType 基本数组中的单个像素设置数据。

void

BandedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

void

MultiPixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

void

SinglePixelPackedSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型的基本数组设置指定 DataBuffer 中单个像素的数据。

void

ComponentSampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

abstract  void

SampleModel.setDataElements(int x, int y, Object obj, DataBuffer data)
根据 TransferType 类型基本数组设置指定 DataBuffer 中单个像素的数据。

java.awt.image.renderable 中 Object 的使用

java.awt.image.renderable 中 Object 的子类

class

ParameterBlock
ParameterBlock 封装有关 RenderableImageOp 所需的源和参数 (Object) 的所有信息，或者其他处理图像的类。

class

RenderableImageOp
此类借助其相关的 ContextualRenderedImageFactory 实例处理某个操作的可呈现方面。

class

RenderableImageProducer
实现 ImageProducer 以允许异步生成 RenderableImage 的适配器类。

class

RenderContext
RenderContext 封装从 enderableImage 生成特定呈现所需的信息。

类型参数类型为 Object 的 java.awt.image.renderable 中的字段

protected  Vector<Object>

ParameterBlock.parameters
一个非源参数的 Vector，存储为任意 Object。

protected  Vector<Object>

ParameterBlock.sources
源的 Vector，存储为任意 Objects。

返回 Object 的 java.awt.image.renderable 中的方法

Object

ParameterBlock.clone()
创建 ParameterBlock 的一个副本。

Object

RenderContext.clone()
对 RenderContext 进行复制。

Object

ParameterBlock.getObjectParameter(int index)
获取作为对象的参数。

Object

ContextualRenderedImageFactory.getProperty(ParameterBlock paramBlock, String name)
获取由 name 参数指定的属性的适当实例。

Object

RenderableImage.getProperty(String name)
从此图像的属性集中获取某个属性。

Object

RenderableImageOp.getProperty(String name)
从此图像的属性集中获取某个属性。

Object

ParameterBlock.getSource(int index)
返回作为通用 Object 的源。

Object

ParameterBlock.shallowClone()
创建 ParameterBlock 的一个浅表副本。

返回变量类型为 Object 的类型的 java.awt.image.renderable 中的方法

Vector<Object>

ParameterBlock.getParameters()
返回参数的整个 Vector。

Vector<Object>

ParameterBlock.getSources()
返回源的整个 Vector。

参数类型为 Object 的 java.awt.image.renderable 中的方法

ParameterBlock

ParameterBlock.add(Object obj)
将一个 Object 添加到此参数列表。

ParameterBlock

ParameterBlock.addSource(Object source)
将一个图像添加到源列表的末尾。

ParameterBlock

ParameterBlock.set(Object obj, int index)
替换此参数列表中的一个 Object。

ParameterBlock

ParameterBlock.setSource(Object source, int index)
将源列表中的某个项替换为一个新源。

类型变量类型为 Object 的 java.awt.image.renderable 中的方法参数

void

ParameterBlock.setParameters(Vector<Object> parameters)
将参数的整个 Vector 设置为给定 Vector。

void

ParameterBlock.setSources(Vector<Object> sources)
将源的整个 Vector 设置为给定 Vector。

类型变量类型为 Object 的 java.awt.image.renderable 中的构造方法参数

ParameterBlock(Vector<Object> sources)
使用源的给定 Vector 构造一个 ParameterBlock。

ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。

ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。

java.awt.print 中 Object 的使用

java.awt.print 中 Object 的子类

class

Book
Book 类提供文档的表示形式，该文档的页面可以使用不同的页面格式和页面 painter。

class

PageFormat
PageFormat 类描述要打印的页面大小和方向。

class

Paper
Paper 类描述一张纸的物理特征。

class

PrinterAbortException
PrinterAbortException 类是 PrinterException 的子类，用于指示用户或应用程序在打印过程中终止打印作业。

class

PrinterException
PrinterException 类及其子类用于指示打印系统中发生的异常情况。

class

PrinterIOException
PrinterIOException 类是 PrinterException 的子类，用于指示在打印过程中发生了某种 IO 错误。

class

PrinterJob
PrinterJob 类是控制打印的主要类。

返回 Object 的 java.awt.print 中的方法

Object

PageFormat.clone()
制作此 PageFormat 的副本，使它与此 PageFormat 具有相同的内容。

Object

Paper.clone()
创建此 Paper 的一个副本，内容与此 Paper 相同。

java.beans 中 Object 的使用

java.beans 中 Object 的子类

class

BeanDescriptor
BeanDescriptor 提供有关 "bean" 的全局信息，其中包括其 Java 类、其 displayName 等等。

class

Beans
此类提供一些通用的 bean 控制方法。

class

DefaultPersistenceDelegate
DefaultPersistenceDelegate 是 PersistenceDelegate 抽象类的具体实现，是没有关于其可用信息的类在默认情况下使用的委托。

class

Encoder
Encoder 是这样的类，它可用于创建根据其公共 API 对 JavaBeans 集合状态进行编码的文件或流。

class

EventHandler
EventHandler 类为动态生成事件侦听器提供支持，这些侦听器的方法执行一条涉及传入事件对象和目标对象的简单语句。

class

EventSetDescriptor
描述给定 Java bean 激发的一组事件的 EventSetDescriptor。

class

Expression
Expression 对象表示基本表达式，其中将单个方法应用于某一目标和一组参数，以返回结果，与在 "a.getFoo()" 中一样。

class

FeatureDescriptor
FeatureDescriptor 类是 PropertyDescriptor、EventSetDescriptor 和 MethodDescriptor 等的公共基类。

class

IndexedPropertyChangeEvent
无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。

class

IndexedPropertyDescriptor
IndexedPropertyDescriptor 描述了类似数组行为的属性，且有一种访问数组特定元素的索引读和/或索引写方法。

class

IntrospectionException
在 Introspection 期间发生异常时抛出异常。

class

Introspector
Introspector 类为通过工具学习有关受目标 Java Bean 支持的属性、事件和方法的知识提供了一个标准方法。

class

MethodDescriptor
MethodDescriptor 描述了一种特殊方法，即 Java Bean 支持从其他组件对其进行外部访问。

class

ParameterDescriptor
ParameterDescriptor 类允许 bean 实现者提供除 java.lang.reflect.Method 类提供的低级别信息之外的关于其每个参数的额外信息。

class

PersistenceDelegate
PersistenceDelegate 类负责根据类的公共 API 中的方法表示给定类的实例状态。

class

PropertyChangeEvent
无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。

class

PropertyChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。

class

PropertyChangeSupport
这是一个实用工具类，支持绑定 (bound) 属性的 bean 可以使用该类。

class

PropertyDescriptor
PropertyDescriptor 描述 Java Bean 通过一对存储器方法导出的一个属性。

class

PropertyEditorManager
PropertyEditorManager 可用于查找任何给定类型名称的属性编辑器。

class

PropertyEditorSupport
这是一个帮助构建属性编辑器的支持类。

class

PropertyVetoException
当某一属性的提议更改表示一个不可接受的值时，将抛出 PropertyVetoException。

class

SimpleBeanInfo
这是一个使得用户提供 BeanInfo 类更容易的支持类。

class

Statement
Statement 对象表示基本语句，其中将单个方法应用于某一目标和一组参数，以返回结果，比如 "a.setFoo(b)"。

class

VetoableChangeListenerProxy
扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

class

VetoableChangeSupport
这是一个实用工具类，支持约束 (constrained) 属性的 bean 可以使用此类。

class

XMLDecoder
XMLDecoder 类用于读取使用 XMLEncoder 创建的 XML 文档，用途类似于 ObjectInputStream。

class

XMLEncoder
XMLEncoder 类是 ObjectOutputStream 的互补替换，可用于生成 JavaBean 的文本表示形式，所使用方式与用 ObjectOutputStream 创建 Serializable 对象的二进制表示形式的方式相同。

返回 Object 的 java.beans 中的方法

Object

Encoder.get(Object oldInstance)
在由此流创建的环境中返回 oldInstance 的一个实验值。

Object[]

Statement.getArguments()
返回此语句的参数。

static Object

Beans.getInstanceOf(Object bean, Class<?> targetType)
从给定 bean 中获得表示源对象的指定类型视图的对象。

Object

PropertyChangeEvent.getNewValue()
获取属性的新值，以 Object 的形式表示。

Object

PropertyChangeEvent.getOldValue()
获取属性的旧值，以 Object 的形式表示。

Object

XMLDecoder.getOwner()
获得此解码器的所有者。

Object

XMLEncoder.getOwner()
获得此编码器的所有者。

Object

PropertyChangeEvent.getPropagationId()
保留 "propagationId" 字段以供将来使用。

Object

PropertyEditorSupport.getSource()
返回用作事件源的 bean。

Object

EventHandler.getTarget()
返回此事件处理程序将为其发送消息的对象。

Object

Statement.getTarget()
返回此语句的目标。

Object

Expression.getValue()
如果此实例的 value 属性尚未设置，则此方法利用这些参数，在此目标上动态查找具有指定 methodName 的方法，并调用该方法。

Object

PropertyEditor.getValue()
获取属性值。

Object

PropertyEditorSupport.getValue()
获得属性值。

Object

FeatureDescriptor.getValue(String attributeName)
利用此特性检索指定属性。

static Object

Beans.instantiate(ClassLoader cls, String beanName)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext)
实例化 JavaBean。

static Object

Beans.instantiate(ClassLoader cls, String beanName, BeanContext beanContext, AppletInitializer initializer)
实例化 bean。

Object

EventHandler.invoke(Object proxy, Method method, Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。

Object

XMLDecoder.readObject()
从基础输入流中读取下一个对象。

Object

Encoder.remove(Object oldInstance)
移除此实例的条目，返回旧条目。

参数类型为 Object 的 java.beans 中的方法

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action)
创建 listenerInterface 的实现，在该实现中，侦听器接口中的所有 方法都会将处理程序的 action 应用到 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName)
创建 listenerInterface 的实现，在该实现中，所有 方法都会将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

static

<T> T

EventHandler.create(Class<T> listenerInterface, Object target, String action, String eventPropertyName, String listenerMethodName)
创建 listenerInterface 的实现，在该实现中，名为 listenerMethodName 的方法将事件表达式的值 eventPropertyName 传递给语句中的最终方法 action，后者被应用于 target。

PropertyEditor

PropertyDescriptor.createPropertyEditor(Object bean)
使用当前属性编辑器类构造一个属性编辑器实例。

boolean

IndexedPropertyDescriptor.equals(Object obj)
将此 PropertyDescriptor 与指定对象比较。

boolean

PropertyDescriptor.equals(Object obj)
将此 PropertyDescriptor 与指定对象进行比较。

void

PropertyChangeSupport.fireIndexedPropertyChange(String propertyName, int index, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定 (bound) 索引 (indexed) 属性更新。

void

PropertyChangeSupport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
报告所有已注册侦听器的绑定属性更新。

void

VetoableChangeSupport.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

Object

Encoder.get(Object oldInstance)
在由此流创建的环境中返回 oldInstance 的一个实验值。

static Object

Beans.getInstanceOf(Object bean, Class<?> targetType)
从给定 bean 中获得表示源对象的指定类型视图的对象。

protected  void

DefaultPersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
initialize 方法的此默认实现假设保存在此类型对象中的所有状态都是通过匹配 "setter" 和 "getter" 方法对来公开的，公开的顺序是 Introspector 返回它们的顺序。

protected  void

PersistenceDelegate.initialize(Class<?> type, Object oldInstance, Object newInstance, Encoder out)
产生一系列对 newInstance 有副作用的语句，使得新实例等于 oldInstance。

protected  Expression

DefaultPersistenceDelegate.instantiate(Object oldInstance, Encoder out)
instantiate 方法的此默认实现返回一个表达式，该表达式包含预先定义的方法名称 "new"，该名称表示调用带有参数（在 DefaultPersistenceDelegate 的构造方法中指定）的构造方法。

protected abstract  Expression

PersistenceDelegate.instantiate(Object oldInstance, Encoder out)
返回其值为 oldInstance 的表达式。

Object

EventHandler.invoke(Object proxy, Method method, Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。

Object

EventHandler.invoke(Object proxy, Method method, Object[] arguments)
从事件中提取适当属性值，并将其传递到与此 EventHandler 相关联的动作。

static boolean

Beans.isInstanceOf(Object bean, Class<?> targetType)
检查是否可以将 bean 视为给定目标类型。

protected  boolean

DefaultPersistenceDelegate.mutatesTo(Object oldInstance, Object newInstance)
如果指定构造方法中的参数数量不为零，且 oldInstance 的类显式声明了一个 "equals" 方法，则此方法返回 oldInstance.equals(newInstance) 的值。

protected  boolean

PersistenceDelegate.mutatesTo(Object oldInstance, Object newInstance)
如果 oldInstance 的等效 副本可以可以通过应用 newInstance 的一系列语句来创建，则返回 true。

Object

Encoder.remove(Object oldInstance)
移除此实例的条目，返回旧条目。

void

Customizer.setObject(Object bean)
设置将要自定义的对象。

void

XMLDecoder.setOwner(Object owner)
将此解码器的所有者设置为 owner。

void

XMLEncoder.setOwner(Object owner)
将此编码器的所有者设置为 owner。

void

PropertyChangeEvent.setPropagationId(Object propagationId)
设置事件的 propagationId 对象。

void

PropertyEditorSupport.setSource(Object source)
设置源 bean。

void

Expression.setValue(Object value)
将此表达式的值设置为 value。

void

PropertyEditor.setValue(Object value)
设置（或更改）将编辑的对象。

void

PropertyEditorSupport.setValue(Object value)
设置（或更改）将被编辑的对象。

void

FeatureDescriptor.setValue(String attributeName, Object value)
将某一指定属性与此特性相关联。

protected  void

Encoder.writeObject(Object o)
将指定对象写入输出流中。

void

XMLEncoder.writeObject(Object o)
将指定对象的 XML 表示形式写入输出中。

void

PersistenceDelegate.writeObject(Object oldInstance, Encoder out)
writeObject 是持久性的一个入口点，由传统委托模式中的 Encoder 使用。

参数类型为 Object 的 java.beans 中的构造方法

EventHandler(Object target, String action, String eventPropertyName, String listenerMethodName)
创建一个新的 EventHandler 对象；通常使用 create 方法之一，而不是直接调用此构造方法。

Expression(Object value, Object target, String methodName, Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。

Expression(Object value, Object target, String methodName, Object[] arguments)
为某个返回结果的方法创建一个新的 Expression 对象。

Expression(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

Expression(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

IndexedPropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue, int index)
构造一个新的 IndexedPropertyChangeEvent 对象。

PropertyChangeEvent(Object source, String propertyName, Object oldValue, Object newValue)
构造一个新的 PropertyChangeEvent。

PropertyChangeSupport(Object sourceBean)
构造一个 PropertyChangeSupport 对象。

PropertyEditorSupport(Object source)
构造一个 PropertyEditorSupport 对象。

Statement(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

Statement(Object target, String methodName, Object[] arguments)
按照所给参数创建一个新的 Statement 对象，使其具有 target、methodName 和 arguments。

VetoableChangeSupport(Object sourceBean)
构造一个 VetoableChangeSupport 对象。

XMLDecoder(InputStream in, Object owner)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

XMLDecoder(InputStream in, Object owner, ExceptionListener exceptionListener, ClassLoader cl)
创建一个新的输入流，以读取由 XMLEncoder 类创建的档案。

java.beans.beancontext 中 Object 的使用

java.beans.beancontext 中 Object 的子类

class

BeanContextChildSupport
这是一个为实现 BeanContextChild 协议提供支持的一般支持类。

class

BeanContextEvent
BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。

class

BeanContextMembershipEvent
BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。

class

BeanContextServiceAvailableEvent
BeanContextServicesListener 使用此事件类型来标识将被注册的服务。

class

BeanContextServiceRevokedEvent
BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。

class

BeanContextServicesSupport
此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。

protected  class

BeanContextServicesSupport.BCSSChild

protected  class

BeanContextServicesSupport.BCSSProxyServiceProvider

protected static class

BeanContextServicesSupport.BCSSServiceProvider
子类可以为此嵌套类创建子类，以便为每个 BeanContextServicesProvider 添加行为。

class

BeanContextSupport
此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

protected  class

BeanContextSupport.BCSChild

protected static class

BeanContextSupport.BCSIterator
受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。

声明为 Object 的 java.beans.beancontext 中的字段

static Object

BeanContext.globalHierarchyLock
BeanContext 和 BeanContextServices 实现者均使用此全局锁定来序列化 BeanContext 中的更改和所有服务请求等。

返回 Object 的 java.beans.beancontext 中的方法

protected  Object[]

BeanContextSupport.copyChildren()
获得此 BeanContext 子级的副本。

Object

BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。

Object

BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。

Object

BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。

Object

BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)

Object

BeanContext.instantiateChild(String beanName)
实例化指定为此 BeanContext 的一个子级的 javaBean。

Object

BeanContextSupport.instantiateChild(String beanName)
instantiateChild 方法是 BeanContext 中的便捷钩子 (hook)，用来简化将嵌套的 Bean 实例化为 BeanContext 这项任务。

Object

BeanContextSupport.BCSIterator.next()

Object[]

BeanContextMembershipEvent.toArray()
获得受此事件影响的子级的数组。

Object[]

BeanContextSupport.toArray()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。

Object[]

BeanContextSupport.toArray(Object[] arry)
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。

参数类型为 Object 的 java.beans.beancontext 中的方法

boolean

BeanContextSupport.add(Object targetChild)
在此 BeanContext 中添加/嵌套一个子级。

protected  void

BeanContextSupport.childDeserializedHook(Object child, BeanContextSupport.BCSChild bcsc)
由 readObject 利用新近反序列化的子级和 BCSChild 调用。

protected  void

BeanContextSupport.childJustAddedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经添加子对象之后，且在发生事件通知之前，只扩展 add() 语义。

protected  void

BeanContextServicesSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
在已成功移除子级之后，从超类的子级移除操作中调用。

protected  void

BeanContextSupport.childJustRemovedHook(Object child, BeanContextSupport.BCSChild bcsc)
子类可以重写此方法，以便在已经移除子对象之后，且在发生事件通知之前，只扩展 remove() 语义。

boolean

BeanContextMembershipEvent.contains(Object child)
指定子级受事件影响吗？

boolean

BeanContextSupport.contains(Object o)
确定指定对象当前是否是此 BeanContext 的子级。

boolean

BeanContextSupport.containsKey(Object o)
确定指定对象当前是否是此 BeanContext 的子级。

protected  BeanContextSupport.BCSChild

BeanContextServicesSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

protected  BeanContextSupport.BCSChild

BeanContextSupport.createBCSChild(Object targetChild, Object peer)
子类可以重写此方法来插入自己的 Child 的子类，而不必重写 add() 或其他将子级添加到集合中的 Collection 方法。

void

BeanContextChildSupport.firePropertyChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定 (bound) 属性更新。

void

BeanContextChildSupport.fireVetoableChange(String name, Object oldValue, Object newValue)
向所有已注册的侦听器报告 vetoable 属性更新。

protected static BeanContextChild

BeanContextSupport.getChildBeanContextChild(Object child)
与指定 Child 相关联的 BeanContextChild（如果有）。

protected static BeanContextMembershipListener

BeanContextSupport.getChildBeanContextMembershipListener(Object child)
与指定 Child 相关联的 BeanContextMembershipListener（如果有）。

protected static BeanContextServicesListener

BeanContextServicesSupport.getChildBeanContextServicesListener(Object child)
获得指定子级的 BeanContextServicesListener（如果有）。

protected static PropertyChangeListener

BeanContextSupport.getChildPropertyChangeListener(Object child)
与指定 Child 相关联的 PropertyChangeListener（如果有）

protected static Serializable

BeanContextSupport.getChildSerializable(Object child)
获得与指定 Child 相关联的 Serializable（如果有）

protected static VetoableChangeListener

BeanContextSupport.getChildVetoableChangeListener(Object child)
与指定 Child 相关联的 VetoableChangeListener（如果有）。

protected static Visibility

BeanContextSupport.getChildVisibility(Object child)
获得与指定子级相关联的 Component（如果有）。

Object

BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。

Object

BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl)
获得一个可被委托的服务。

Object

BeanContextServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)
由 BeanContextServices 调用，此方法请求来自此 BeanContextServiceProvider 服务的一个实例。

Object

BeanContextServicesSupport.BCSSProxyServiceProvider.getService(BeanContextServices bcs, Object requestor, Class serviceClass, Object serviceSelector)

void

BeanContextServices.releaseService(BeanContextChild child, Object requestor, Object service)
通过在基础 BeanContextServiceProvider 上调用 releaseService() 释放 BeanContextChild（或与 BeanContextChild 关联的任意对象）对指定服务的引用。

void

BeanContextServicesSupport.releaseService(BeanContextChild child, Object requestor, Object service)
释放服务。

void

BeanContextServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service)
由 BeanContextServices 调用，此方法释放一个对特定服务的嵌套 BeanContextChild（或与 BeanContextChild 关联的任意对象）的引用。

void

BeanContextServicesSupport.BCSSProxyServiceProvider.releaseService(BeanContextServices bcs, Object requestor, Object service)

boolean

BeanContextSupport.remove(Object targetChild)
从此 BeanContext 中移除一个子对象。

protected  boolean

BeanContextSupport.remove(Object targetChild, boolean callChildSetBC)
当由意外的 setBeanContext 或 remove() 调用导致移除时使用的内部移除方法。

Object[]

BeanContextSupport.toArray(Object[] arry)
获得包含与数组中所包含类型匹配的此 BeanContext 的所有子级的数组。

protected  boolean

BeanContextSupport.validatePendingAdd(Object targetChild)
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象添加到 BeanContext 之前立即检查它们。

protected  boolean

BeanContextSupport.validatePendingRemove(Object targetChild)
此类的子类可以重写或封装此方法，以便为 BeanContext 添加有效行为，从而能在将子对象从 BeanContext 中移除之前立即检查它们。

参数类型为 Object 的 java.beans.beancontext 中的构造方法

BeanContextMembershipEvent(BeanContext bc, Object[] changes)
构造一个 BeanContextMembershipEvent

java.io 中 Object 的使用

java.io 中 Object 的子类

class

BufferedInputStream
BufferedInputStream 为另一个输入流添加一些功能，即缓冲输入以及支持 mark 和 reset 方法的能力。

class

BufferedOutputStream
该类实现缓冲的输出流。

class

BufferedReader
从字符输入流中读取文本，缓冲各个字符，从而实现字符、数组和行的高效读取。

class

BufferedWriter
将文本写入字符输出流，缓冲各个字符，从而提供单个字符、数组和字符串的高效写入。

class

ByteArrayInputStream
ByteArrayInputStream 包含一个内部缓冲区，该缓冲区包含从流中读取的字节。

class

ByteArrayOutputStream
此类实现了一个输出流，其中的数据被写入一个 byte 数组。

class

CharArrayReader
此类实现一个可用作字符输入流的字符缓冲区。

class

CharArrayWriter
此类实现一个可用作 Writer 的字符缓冲区。

class

CharConversionException
用于字符转换异常的基类。

class

Console
此类包含多个方法，可访问与当前 Java 虚拟机关联的基于字符的控制台设备（如果有）。

class

DataInputStream
数据输入流允许应用程序以与机器无关方式从底层输入流中读取基本 Java 数据类型。

class

DataOutputStream
数据输出流允许应用程序以适当方式将基本 Java 数据类型写入输出流中。

class

EOFException
当输入过程中意外到达文件或流的末尾时，抛出此异常。

class

File
文件和目录路径名的抽象表示形式。

class

FileDescriptor
文件描述符类的实例用作与基础机器有关的某种结构的不透明句柄，该结构表示开放文件、开放套接字或者字节的另一个源或接收者。

class

FileInputStream
FileInputStream 从文件系统中的某个文件中获得输入字节。

class

FileNotFoundException
当试图打开指定路径名表示的文件失败时，抛出此异常。

class

FileOutputStream
文件输出流是用于将数据写入 File 或 FileDescriptor 的输出流。

class

FilePermission
此类表示对文件和目录的访问。

class

FileReader
用来读取字符文件的便捷类。

class

FileWriter
用来写入字符文件的便捷类。

class

FilterInputStream
FilterInputStream 包含其他一些输入流，它将这些流用作其基本数据源，它可以直接传输数据或提供一些额外的功能。

class

FilterOutputStream
此类是过滤输出流的所有类的超类。

class

FilterReader
用于读取已过滤的字符流的抽象类。

class

FilterWriter
用于写入已过滤的字符流的抽象类。

class

InputStream
此抽象类是表示字节输入流的所有类的超类。

class

InputStreamReader
InputStreamReader 是字节流通向字符流的桥梁：它使用指定的 charset 读取字节并将其解码为字符。

class

InterruptedIOException
I/O 操作已中断信号，抛出此异常。

class

InvalidClassException
当 Serialization 运行时检测到某个类具有以下问题之一时，抛出此异常。

class

InvalidObjectException
指示一个或多个反序列化对象未通过验证测试。

class

IOError
当发生严重的 I/O 错误时，抛出此错误。

class

IOException
当发生某种 I/O 异常时，抛出此异常。

class

LineNumberInputStream
已过时。 此类错误假定字节能充分表示字符。从 JDK 1.1 开始，对字符流操作的首选方法是通过新字符流类（其中包括计算行号的类）进行操作。

class

LineNumberReader
跟踪行号的缓冲字符输入流。

class

NotActiveException
当序列化和反序列化不活动时，抛出此异常。

class

NotSerializableException
当实例需要具有序列化接口时，抛出此异常。

class

ObjectInputStream
ObjectInputStream 对以前使用 ObjectOutputStream 写入的基本数据和对象进行反序列化。

static class

ObjectInputStream.GetField
提供对从输入流读取的持久字段的访问权限。

class

ObjectOutputStream
ObjectOutputStream 将 Java 对象的基本数据类型和图形写入 OutputStream。

static class

ObjectOutputStream.PutField
提供对要写入 ObjectOutput 的持久字段的编程访问。

class

ObjectStreamClass
类的序列化描述符。

class

ObjectStreamException
特定于 Object Stream 类的所有异常的超类。

class

ObjectStreamField
Serializable 类中 Serializable 字段的描述。

class

OptionalDataException
指示对象读取操作失败的异常，原因是无法读取流中的基本数据或已序列化对象的数据末尾。

class

OutputStream
此抽象类是表示输出字节流的所有类的超类。

class

OutputStreamWriter
OutputStreamWriter 是字符流通向字节流的桥梁：可使用指定的 charset 将要写入流中的字符编码成字节。

class

PipedInputStream
管道输入流应该连接到管道输出流；管道输入流提供要写入管道输出流的所有数据字节。

class

PipedOutputStream
可以将管道输出流连接到管道输入流来创建通信管道。

class

PipedReader
传送的字符输入流。

class

PipedWriter
传送的字符输出流。

class

PrintStream
PrintStream 为其他输出流添加了功能，使它们能够方便地打印各种数据值表示形式。

class

PrintWriter
向文本输出流打印对象的格式化表示形式。

class

PushbackInputStream
PushbackInputStream 为另一个输入流添加性能，即“推回 (push back)”或“取消读取 (unread)”一个字节的能力。

class

PushbackReader
允许将字符推回到流的字符流 reader。

class

RandomAccessFile
此类的实例支持对随机访问文件的读取和写入。

class

Reader
用于读取字符流的抽象类。

class

SequenceInputStream
SequenceInputStream 表示其他输入流的逻辑串联。

class

SerializablePermission
此类用于可序列化权限。

class

StreamCorruptedException
当从对象流中读取的控制信息与内部一致性检查相冲突时，抛出此异常。

class

StreamTokenizer
StreamTokenizer 类获取输入流并将其解析为“标记”，允许一次读取一个标记。

class

StringBufferInputStream
已过时。 此类未能正确地将字符转换为字节。从 JDK 1.1 开始，从字符串创建流的首选方法是通过 StringReader 类进行创建。

class

StringReader
其源为一个字符串的字符流。

class

StringWriter
一个字符流，可以用其回收在字符串缓冲区中的输出来构造字符串。

class

SyncFailedException
当 sync 操作失败时，抛出此异常。

class

UnsupportedEncodingException
不支持字符编码。

class

UTFDataFormatException
在数据输入流中或由实现该数据输入接口的任何类中以 UTF-8 修改版格式读取错误字符串时，抛出此异常。

class

WriteAbortedException
在写入操作过程中抛出 ObjectStreamException 之一的信号。

class

Writer
写入字符流的抽象类。

声明为 Object 的 java.io 中的字段

protected  Object

Reader.lock
用于同步针对此流的操作的对象。

protected  Object

Writer.lock
用于同步针对此流的操作的对象。

返回 Object 的 java.io 中的方法

abstract  Object

ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。

Object

ObjectInputStream.readObject()
从 ObjectInputStream 读取对象。

Object

ObjectInput.readObject()
读取并返回对象。

protected  Object

ObjectInputStream.readObjectOverride()
此方法由 ObjectOutputStream 的受信任子类调用，这些子类使用受保护的无参数构造方法构造 ObjectOutputStream。

Object

ObjectInputStream.readUnshared()
从 ObjectInputStream 读取“非共享”对象。

protected  Object

ObjectOutputStream.replaceObject(Object obj)
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。

protected  Object

ObjectInputStream.resolveObject(Object obj)
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。

参数类型为 Object 的 java.io 中的方法

int

ObjectStreamField.compareTo(Object obj)
将此字段与另一个 ObjectStreamField 进行比较。

boolean

FilePermission.equals(Object obj)
检查两个 FilePermission 对象是否相等。

boolean

File.equals(Object obj)
测试此抽象路径名与给定对象是否相等。

PrintWriter

PrintWriter.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

Console

Console.format(String fmt, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台的输出流中。

PrintWriter

PrintWriter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。

PrintStream

PrintStream.format(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此输出流中。

abstract  Object

ObjectInputStream.GetField.get(String name, Object val)
从持久字段获取指定 Object 字段的值。

void

PrintWriter.print(Object obj)
打印对象。

void

PrintStream.print(Object obj)
打印对象。

PrintWriter

PrintWriter.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(Locale l, String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

Console

Console.printf(String format, Object... args)
使用指定格式字符串和参数将格式化字符串写入此控制台输出流的便捷方法。

PrintWriter

PrintWriter.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。

PrintStream

PrintStream.printf(String format, Object... args)
使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

void

PrintWriter.println(Object x)
打印 Object，然后终止该行。

void

PrintStream.println(Object x)
打印 Object，然后终止该行。

abstract  void

ObjectOutputStream.PutField.put(String name, Object val)
将指定的 Object 字段的值置于持久字段中。

String

Console.readLine(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取单行文本。

char[]

Console.readPassword(String fmt, Object... args)
提供一个格式化提示，然后从控制台读取密码，禁用回显。

protected  Object

ObjectOutputStream.replaceObject(Object obj)
在序列化期间，此方法允许 ObjectOutputStream 的受信任子类使用一个对象替代另一个对象。

protected  Object

ObjectInputStream.resolveObject(Object obj)
在反序列化期间，此方法允许 ObjectInputStream 的受信任子类使用一个对象替代另一个。

void

ObjectOutputStream.writeObject(Object obj)
将指定的对象写入 ObjectOutputStream。

void

ObjectOutput.writeObject(Object obj)
将对象写入底层存储或流。

protected  void

ObjectOutputStream.writeObjectOverride(Object obj)
子类用于重写默认 writeObject 方法的方法。

void

ObjectOutputStream.writeUnshared(Object obj)
将“未共享”对象写入 ObjectOutputStream。

参数类型为 Object 的 java.io 中的构造方法

Reader(Object lock)
创建一个新的字符流 reader，其重要部分将同步给定的对象。

Writer(Object lock)
创建一个新的字符流 writer，其关键部分将同步给定的对象。

java.lang 中 Object 的使用

java.lang 中 Object 的子类

class

AbstractMethodError
当应用程序试图调用一个抽象方法时，抛出此错误。

class

ArithmeticException
当出现异常的运算条件时，抛出此异常。

class

ArrayIndexOutOfBoundsException
用非法索引访问数组时抛出的异常。

class

ArrayStoreException
试图将错误类型的对象存储到一个对象数组时抛出的异常。

class

AssertionError
抛出该异常指示某个断言失败。

class

Boolean
Boolean 类将基本类型为 boolean 的值包装在一个对象中。

class

Byte
Byte 类将基本类型 byte 的值包装在一个对象中。

class

Character
Character 类在对象中包装一个基本类型 char 的值。

static class

Character.Subset
此类的实例表示 Unicode 字符集的特定子集。

static class

Character.UnicodeBlock
表示 Unicode 规范中字符块的一系列字符子集。

class

Class<T>
Class 类的实例表示正在运行的 Java 应用程序中的类和接口。

class

ClassCastException
当试图将对象强制转换为不是实例的子类时，抛出该异常。

class

ClassCircularityError
当初始化类时检测到类的循环调用的时候，抛出该错误。

class

ClassFormatError
当 Java 虚拟机试图读取类文件并确定该文件存在格式错误或无法解释为类文件时，抛出该错误。

class

ClassLoader
类加载器是负责加载类的对象。

class

ClassNotFoundException
当应用程序试图使用以下方法通过字符串名加载类时，抛出该异常： Class 类中的 forName 方法。

class

CloneNotSupportedException
当调用 Object 类中的 clone 方法复制对象，但该对象的类无法实现 Cloneable 接口时，抛出该异常。

class

Compiler
Compiler 类主要支持 Java 到本机代码的编译器及相关服务。

class

Double
Double 类在对象中包装一个基本类型 double 的值。

class

Enum<E extends Enum<E>>
这是所有 Java 语言枚举类型的公共基本类。

class

EnumConstantNotPresentException
当应用程序试图通过名称和枚举类型访问那些不包含具有指定名称的常量的枚举常量时，抛出该异常。

class

Error
Error 是 Throwable 的子类，用于指示合理的应用程序不应该试图捕获的严重问题。

class

Exception
Exception 类及其子类是 Throwable 的一种形式，它指出了合理的应用程序想要捕获的条件。

class

ExceptionInInitializerError
静态初始化程序中发生意外异常的信号。

class

Float
Float 类在对象中包装一个基本类型 float 的值。

class

IllegalAccessError
当应用程序试图访问或修改它不能访问的字段，或调用它不能访问的方法时，抛出该异常。

class

IllegalAccessException
当应用程序试图反射性地创建一个实例（而不是数组）、设置或获取一个字段，或者调用一个方法，但当前正在执行的方法无法访问指定类、字段、方法或构造方法的定义时，抛出 IllegalAccessException。

class

IllegalArgumentException
抛出的异常表明向方法传递了一个不合法或不正确的参数。

class

IllegalMonitorStateException
抛出的异常表明某一线程已经试图等待对象的监视器，或者试图通知其他正在等待对象的监视器而本身没有指定监视器的线程。

class

IllegalStateException
在非法或不适当的时间调用方法时产生的信号。

class

IllegalThreadStateException
指示线程没有处于请求操作所要求的适当状态时抛出的异常。

class

IncompatibleClassChangeError
在某些类定义中出现不兼容的类更改时抛出该异常。

class

IndexOutOfBoundsException
指示某排序索引（例如对数组、字符串或向量的排序）超出范围时抛出。

class

InheritableThreadLocal<T>
该类扩展了 ThreadLocal，为子线程提供从父线程那里继承的值：在创建子线程时，子线程会接收所有可继承的线程局部变量的初始值，以获得父线程所具有的值。

class

InstantiationError
当应用程序试图使用 Java 的 new 结构来实例化一个抽象类或一个接口时，抛出该异常。

class

InstantiationException
当应用程序试图使用 Class 类中的 newInstance 方法创建一个类的实例，而指定的类对象无法被实例化时，抛出该异常。

class

Integer
Integer 类在对象中包装了一个基本类型 int 的值。

class

InternalError
该异常指示 Java 虚拟机中出现一些意外的内部错误。

class

InterruptedException
当线程在活动之前或活动期间处于正在等待、休眠或占用状态且该线程被中断时，抛出该异常。

class

LinkageError
LinkageError 的子类指示一个类在一定程度上依赖于另一个类；但是，在编译前一个类之后，后一个类发生了不相容的改变。

class

Long
Long 类在对象中包装了基本类型 long 的值。

class

Math
Math 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。

class

NegativeArraySizeException
如果应用程序试图创建大小为负的数组，则抛出该异常。

class

NoClassDefFoundError
当 Java 虚拟机或 ClassLoader 实例试图在类的定义中加载（作为通常方法调用的一部分或者作为使用 new 表达式创建的新实例的一部分），但无法找到该类的定义时，抛出此异常。

class

NoSuchFieldError
如果应用程序试图访问或修改一个指定的对象字段，而该对象不再包含该字段时，抛出该异常。

class

NoSuchFieldException
类不包含指定名称的字段时产生的信号。

class

NoSuchMethodError
当应用程序试图调用类（静态或实例）的指定方法，而该类已不再具有该方法的定义时，抛出该异常。

class

NoSuchMethodException
无法找到某一特定方法时，抛出该异常。

class

NullPointerException
当应用程序试图在需要对象的地方使用 null 时，抛出该异常。

class

Number
抽象类 Number 是 BigDecimal、BigInteger、Byte、Double、Float、Integer、Long 和 Short 类的超类。

class

NumberFormatException
当应用程序试图将字符串转换成一种数值类型，但该字符串不能转换为适当格式时，抛出该异常。

class

OutOfMemoryError
因为内存溢出或没有可用的内存提供给垃圾回收器时，Java 虚拟机无法分配一个对象，这时抛出该异常。

class

Package
Package 对象包含有关 Java 包的实现和规范的版本信息。

class

Process
ProcessBuilder.start() 和 Runtime.exec 方法创建一个本机进程，并返回 Process 子类的一个实例，该实例可用来控制进程并获得相关信息。

class

ProcessBuilder
此类用于创建操作系统进程。

class

Runtime
每个 Java 应用程序都有一个 Runtime 类实例，使应用程序能够与其运行的环境相连接。

class

RuntimeException
RuntimeException 是那些可能在 Java 虚拟机正常运行期间抛出的异常的超类。

class

RuntimePermission
该类用于运行时权限。

class

SecurityException
由安全管理器抛出的异常，指示存在安全侵犯。

class

SecurityManager
安全管理器是一个允许应用程序实现安全策略的类。

class

Short
Short 类在对象中包装基本类型 short 的值。

class

StackOverflowError
当应用程序递归太深而发生堆栈溢出时，抛出该错误。

class

StackTraceElement
堆栈跟踪中的元素，它由 Throwable.getStackTrace() 返回。

class

StrictMath
StrictMath 类包含用于执行基本数学运算的方法，如初等指数、对数、平方根和三角函数。

class

String
String 类代表字符串。

class

StringBuffer
线程安全的可变字符序列。

class

StringBuilder
一个可变的字符序列。

class

StringIndexOutOfBoundsException
此异常由 String 方法抛出，指示索引或者为负，或者超出字符串的大小。

class

System
System 类包含一些有用的类字段和方法。

class

Thread
线程 是程序中的执行线程。

class

ThreadDeath
调用 Thread 类中带有零参数的 stop 方法时，受害线程将抛出一个 ThreadDeath 实例。

class

ThreadGroup
线程组表示一个线程的集合。

class

ThreadLocal<T>
该类提供了线程局部 (thread-local) 变量。

class

Throwable
Throwable 类是 Java 语言中所有错误或异常的超类。

class

TypeNotPresentException
当应用程序试图使用表示类型名称的字符串对类型进行访问，但无法找到带有指定名称的类型定义时，抛出该异常。

class

UnknownError
当 Java 虚拟机中出现一个未知但严重的异常时，抛出该错误。

class

UnsatisfiedLinkError
当 Java 虚拟机无法找到声明为 native 的方法的适当本地语言定义时，抛出该错误。

class

UnsupportedClassVersionError
当 Java 虚拟机试图读取一个类文件，并确定文件的主辅版本号不受支持时，抛出该错误。

class

UnsupportedOperationException
当不支持请求的操作时，抛出该异常。

class

VerifyError
当“校验器”检测到一个类文件虽然格式正确，但包含着一些内部不一致性或安全性问题时，抛出该错误。

class

VirtualMachineError
当 Java 虚拟机崩溃或用尽了它继续操作所需的资源时，抛出该错误。

class

Void
Void 类是一个不可实例化的占位符类，它持有对表示 Java 关键字 void 的 Class 对象的引用。

返回 Object 的 java.lang 中的方法

protected  Object

Enum.clone()
抛出 CloneNotSupportedException。

protected  Object

Object.clone()
创建并返回此对象的一个副本。

static Object

Compiler.command(Object any)
检查参数类型及其字段，并执行一些文档操作。

T[]

Class.getEnumConstants()
如果此 Class 对象不表示枚举类型，则返回枚举类的元素或 null。

Object

SecurityManager.getSecurityContext()
创建一个封装当前执行环境的对象。

Object[]

Class.getSigners()
获取此类的标记。

参数类型为 Object 的 java.lang 中的方法

StringBuilder

StringBuilder.append(Object obj)

StringBuffer

StringBuffer.append(Object obj)

static void

System.arraycopy(Object src, int srcPos, Object dest, int destPos, int length)
从指定源数组中复制一个数组，复制从指定的位置开始，到目标数组的指定位置结束。

T

Class.cast(Object obj)
将一个对象强制转换成此 Class 对象所表示的类或接口。

void

SecurityManager.checkConnect(String host, int port, Object context)
如果不允许指定的安全上下文打开与指定主机和端口号的套接字连接，则抛出 SecurityException。

void

SecurityManager.checkPermission(Permission perm, Object context)
如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。

void

SecurityManager.checkRead(String file, Object context)
如果不允许指定的安全上下文读取由字符串参数所指定的文件，则抛出 SecurityException。

boolean

SecurityManager.checkTopLevelWindow(Object window)
如果不受信任的调用线程调出由 window 参数指出的顶层窗口，则返回 false。

static Object

Compiler.command(Object any)
检查参数类型及其字段，并执行一些文档操作。

boolean

Enum.equals(Object other)
当指定对象等于此枚举常量时，返回 true。

boolean

Long.equals(Object obj)
将此对象与指定对象进行比较。

boolean

Integer.equals(Object obj)
比较此对象与指定对象。

boolean

Short.equals(Object obj)
将此对象与指定对象比较。

boolean

Byte.equals(Object obj)
将此对象与指定对象比较。

boolean

Double.equals(Object obj)
将此对象与指定对象比较。

boolean

Float.equals(Object obj)
将此对象与指定对象进行比较。

boolean

Character.equals(Object obj)
将此对象与指定对象比较。

boolean

Character.Subset.equals(Object obj)
比较两个 Subset 对象的相等性。

boolean

Boolean.equals(Object obj)
当且仅当参数不是 null，而是一个与此对象一样，都表示同一个 Boolean 值的 boolean 对象时，才返回 true。

boolean

StackTraceElement.equals(Object obj)
如果指定的对象是另一个 StackTraceElement 实例，并且该对象表示的执行点与该实例的相同，则返回 ture。

boolean

String.equals(Object anObject)
将此字符串与指定的对象比较。

boolean

Object.equals(Object obj)
指示其他某个对象是否与此对象“相等”。

static String

String.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数返回一个格式化字符串。

static String

String.format(String format, Object... args)
使用指定的格式字符串和参数返回一个格式化字符串。

static boolean

Thread.holdsLock(Object obj)
当且仅当当前线程在指定的对象上保持监视器锁时，才返回 true。

static int

System.identityHashCode(Object x)
返回给定对象的哈希码，该代码与默认的方法 hashCode() 返回的代码一样，无论给定对象的类是否重写 hashCode()。

StringBuilder

StringBuilder.insert(int offset, Object obj)

StringBuffer

StringBuffer.insert(int offset, Object obj)

boolean

Class.isInstance(Object obj)
判定指定的 Object 是否与此 Class 所表示的对象赋值兼容。

protected  void

ClassLoader.setSigners(Class<?> c, Object[] signers)
设置类的签署者。

static String

String.valueOf(Object obj)
返回 Object 参数的字符串表示形式。

参数类型为 Object 的 java.lang 中的构造方法

AssertionError(Object detailMessage)
构造一个 AssertionError，其详细消息派生于指定的对象，该对象将根据 The Java Language Specification 第二版 第 15.18.1.1 节中的定义转换为一个字符串。

java.lang.annotation 中 Object 的使用

java.lang.annotation 中 Object 的子类

class

AnnotationFormatError
当注释解析器试图从类文件读取注释并确定注释出现异常时，抛出该错误。

class

AnnotationTypeMismatchException
若某个注释的类型在对该注释进行编译（或序列化）后发生了更改，而程序试图访问该注释的元素时，抛出此异常。

class

IncompleteAnnotationException
若某个注释在编译（或序列化）后将某个注释类型添加到其类型定义中，而程序试图该注释类型的元素时，抛出此异常。

参数类型为 Object 的 java.lang.annotation 中的方法

boolean

Annotation.equals(Object obj)
如果指定的对象表示在逻辑上等效于此接口的注释，则返回 true。

java.lang.instrument 中 Object 的使用

java.lang.instrument 中 Object 的子类

class

ClassDefinition
此类用作 Instrumentation.redefineClasses 方法的参数锁定。

class

IllegalClassFormatException
当其输入参数无效时，由 ClassFileTransformer.transform 的实现抛出该异常。

class

UnmodifiableClassException
在无法修改指定类之一时，由 Instrumentation.redefineClasses 的实现抛出此异常。

参数类型为 Object 的 java.lang.instrument 中的方法

long

Instrumentation.getObjectSize(Object objectToSize)
返回指定对象使用的特定于实现的近似存储量。

java.lang.management 中 Object 的使用

java.lang.management 中 Object 的子类

class

LockInfo
关于锁 的信息。

class

ManagementFactory
ManagementFactory 类是一种工厂类，用于获取 Java 平台的管理 Bean。

class

ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

class

MemoryNotificationInfo
关于内存通知的信息。

class

MemoryUsage
表示内存使用量快照的 MemoryUsage 对象。

class

MonitorInfo
关于对象监视器锁的信息。

class

ThreadInfo
线程信息。

java.lang.ref 中 Object 的使用

java.lang.ref 中 Object 的子类

class

PhantomReference<T>
虚引用对象，在回收器确定其指示对象可另外回收之后，被加入队列。

class

Reference<T>
引用对象的抽象基类。

class

ReferenceQueue<T>
引用队列，在检测到适当的可到达性更改后，垃圾回收器将已注册的引用对象添加到该队列中。

class

SoftReference<T>
软引用对象，在响应内存需要时，由垃圾回收器决定是否清除此对象。

class

WeakReference<T>
弱引用对象，它们并不禁止其指示对象变得可终结，并被终结，然后被回收。

java.lang.reflect 中 Object 的使用

java.lang.reflect 中 Object 的子类

class

AccessibleObject
AccessibleObject 类是 Field、Method 和 Constructor 对象的基类。

class

Array
Array 类提供了动态创建和访问 Java 数组的方法。

class

Constructor<T>
Constructor 提供关于类的单个构造方法的信息以及对它的访问权限。

class

Field
Field 提供有关类或接口的单个字段的信息，以及对它的动态访问权限。

class

GenericSignatureFormatError
当需要解释类型、方法或构造方法的一般签名信息的反射方法遇到语法错误的签名属性时，抛出该错误。

class

InvocationTargetException
InvocationTargetException 是一种包装由调用方法或构造方法所抛出异常的经过检查的异常。

class

MalformedParameterizedTypeException
当反射方法遇到语义错误的参数化类型，而反射方法需要实例化该类型时，抛出该异常。

class

Method
Method 提供关于类或接口上单独某个方法（以及如何访问该方法）的信息。

class

Modifier
Modifier 类提供了 static 方法和常量，对类和成员访问修饰符进行解码。

class

Proxy
Proxy 提供用于创建动态代理类和实例的静态方法，它还是由这些方法创建的所有动态代理类的超类。

class

ReflectPermission
反射操作的 Permission 类。

class

UndeclaredThrowableException
如果代理实例的调用处理程序的 invoke 方法抛出一个经过检查的异常（不可分配给 RuntimeException 或 Error 的 Throwable），且该异常不可分配给该方法（在代理实例上调用该方法，并将其指派到调用处理程序）的 throws 子句中声明的任何异常类，则由代理实例上的方法调用抛出此异常。

返回 Object 的 java.lang.reflect 中的方法

Object

Field.get(Object obj)
返回指定对象上此 Field 表示的字段的值。

static Object

Array.get(Object array, int index)
返回指定数组对象中索引组件的值。

Object

Method.getDefaultValue()
返回由此 Method 实例表示的注释成员的默认值。

Object

InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

Object

Method.invoke(Object obj, Object... args)
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。

static Object

Array.newInstance(Class<?> componentType, int... dimensions)
创建一个具有指定的组件类型和维度的新数组。

static Object

Array.newInstance(Class<?> componentType, int length)
创建一个具有指定的组件类型和长度的新数组。

static Object

Proxy.newProxyInstance(ClassLoader loader, Class<?>[] interfaces, InvocationHandler h)
返回一个指定接口的代理类实例，该接口可以将方法调用指派到指定的调用处理程序。

参数类型为 Object 的 java.lang.reflect 中的方法

boolean

Constructor.equals(Object obj)
将此 Constructor 对象与指定的对象进行比较。

boolean

Method.equals(Object obj)
将此 Method 与指定对象进行比较。

boolean

Field.equals(Object obj)
将此 Field 与指定对象比较。

Object

Field.get(Object obj)
返回指定对象上此 Field 表示的字段的值。

static Object

Array.get(Object array, int index)
返回指定数组对象中索引组件的值。

boolean

Field.getBoolean(Object obj)
获取一个静态或实例 boolean 字段的值。

static boolean

Array.getBoolean(Object array, int index)
以 boolean 形式返回指定数组对象中索引组件的值。

byte

Field.getByte(Object obj)
获取一个静态或实例 byte 字段的值。

static byte

Array.getByte(Object array, int index)
以 byte 形式返回指定数组对象中索引组件的值。

char

Field.getChar(Object obj)
获取 char 类型或另一个通过扩展转换可以转换为 char 类型的基本类型的静态或实例字段的值。

static char

Array.getChar(Object array, int index)
以 char 形式返回指定数组对象中索引组件的值。

double

Field.getDouble(Object obj)
获取 double 类型或另一个通过扩展转换可以转换为 double 类型的基本类型的静态或实例字段的值。

static double

Array.getDouble(Object array, int index)
以 double 形式返回指定数组对象中索引组件的值。

float

Field.getFloat(Object obj)
获取 float 类型或另一个通过扩展转换可以转换为 float 类型的基本类型的静态或实例字段的值。

static float

Array.getFloat(Object array, int index)
以 float 形式返回指定数组对象中索引组件的值。

int

Field.getInt(Object obj)
获取 int 类型或另一个通过扩展转换可以转换为 int 类型的基本类型的静态或实例字段的值。

static int

Array.getInt(Object array, int index)
以 int 形式返回指定数组对象中索引组件的值。

static InvocationHandler

Proxy.getInvocationHandler(Object proxy)
返回指定代理实例的调用处理程序。

static int

Array.getLength(Object array)
以 int 形式返回指定数组对象的长度。

long

Field.getLong(Object obj)
获取 long 类型或另一个通过扩展转换可以转换为 long 类型的基本类型的静态或实例字段的值。

static long

Array.getLong(Object array, int index)
以 long 形式返回指定数组对象中索引组件的值。

short

Field.getShort(Object obj)
获取 short 类型或另一个通过扩展转换可以转换为 short 类型的基本类型的静态或实例字段的值。

static short

Array.getShort(Object array, int index)
以 short 形式返回指定数组对象中索引组件的值。

Object

InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

Object

InvocationHandler.invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。

Object

Method.invoke(Object obj, Object... args)
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。

Object

Method.invoke(Object obj, Object... args)
对带有指定参数的指定对象调用由此 Method 对象表示的底层方法。

T

Constructor.newInstance(Object... initargs)
使用此 Constructor 对象表示的构造方法来创建该构造方法的声明类的新实例，并用指定的初始化参数初始化该实例。

static void

Array.set(Object array, int index, Object value)
将指定数组对象中索引组件的值设置为指定的新值。

void

Field.set(Object obj, Object value)
将指定对象变量上此 Field 对象表示的字段设置为指定的新值。

void

Field.setBoolean(Object obj, boolean z)
将字段的值设置为指定对象上的一个 boolean 值。

static void

Array.setBoolean(Object array, int index, boolean z)
将指定数组对象中索引组件的值设置为指定的 boolean 值。

void

Field.setByte(Object obj, byte b)
将字段的值设置为指定对象上的一个 byte 值。

static void

Array.setByte(Object array, int index, byte b)
将指定数组对象中索引组件的值设置为指定的 byte 值。

void

Field.setChar(Object obj, char c)
将字段的值设置为指定对象上的一个 char 值。

static void

Array.setChar(Object array, int index, char c)
将指定数组对象中索引组件的值设置为指定的 char 值。

void

Field.setDouble(Object obj, double d)
将字段的值设置为指定对象上的一个 double 值。

static void

Array.setDouble(Object array, int index, double d)
将指定数组对象中索引组件的值设置为指定的 double 值。

void

Field.setFloat(Object obj, float f)
将字段的值设置为指定对象上的一个 float 值。

static void

Array.setFloat(Object array, int index, float f)
将指定数组对象中索引组件的值设置为指定的 float 值。

void

Field.setInt(Object obj, int i)
将字段的值设置为指定对象上的一个 int 值。

static void

Array.setInt(Object array, int index, int i)
将指定数组对象中索引组件的值设置为指定的 int 值。

static void

Array.setLong(Object array, int index, long l)
将指定数组对象中索引组件的值设置为指定的 long 值。

void

Field.setLong(Object obj, long l)
将字段的值设置为指定对象上的一个 long 值。

static void

Array.setShort(Object array, int index, short s)
将指定数组对象中索引组件的值设置为指定的 short 值。

void

Field.setShort(Object obj, short s)
将字段的值设置为指定对象上的一个 short 值。

java.math 中 Object 的使用

java.math 中 Object 的子类

class

BigDecimal
不可变的、任意精度的有符号十进制数。

class

BigInteger
不可变的任意精度的整数。

class

MathContext
该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。

参数类型为 Object 的 java.math 中的方法

boolean

BigDecimal.equals(Object x)
比较此 BigDecimal 与指定的 Object 的相等性。

boolean

MathContext.equals(Object x)
将此 MathContext 与指定的 Object 进行相等性比较。

boolean

BigInteger.equals(Object x)
比较此 BigInteger 与指定的 Object 的相等性。

java.net 中 Object 的使用

java.net 中 Object 的子类

class

Authenticator
Authenticator 类表示懂得如何获得网络连接验证的对象。

class

BindException
试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。

class

CacheRequest
表示在 ResponseCache 中存储资源的通道。

class

CacheResponse
表示从 ResponseCache 获取资源的通道。

class

ContentHandler
抽象类 ContentHandler 是从 URLConnection 读取 Object 的所有类的超类。

class

CookieHandler
CookieHandler 对象提供一种回调机制以将 HTTP 状态管理策略实现挂钩到 HTTP 协议处理程序。

class

CookieManager
CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。

class

DatagramPacket
此类表示数据报包。

class

DatagramSocket
此类表示用来发送和接收数据报包的套接字。

class

DatagramSocketImpl
数据报和多播套接字实现的抽象基类。

class

HttpCookie
HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。

class

HttpRetryException
抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。

class

HttpURLConnection
支持 HTTP 特定功能的 URLConnection。

class

IDN
提供在普通 Unicode 表示形式和 ASCII 兼容性编码 (ACE) 表示形式之间进行国际化域名 (IDN) 转换的方法。

class

Inet4Address
此类表示 Internet Protocol version 4 (IPv4) 地址。

class

Inet6Address
此类表示互联网协议第 6 版 (IPv6) 地址。

class

InetAddress
此类表示互联网协议 (IP) 地址。

class

InetSocketAddress
此类实现 IP 套接字地址（IP 地址 + 端口号）。

class

InterfaceAddress
此类表示网络接口地址。

class

JarURLConnection
连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。

class

MalformedURLException
抛出这一异常指示出现了错误的 URL。

class

MulticastSocket
多播数据报套接字类用于发送和接收 IP 多播包。

class

NetPermission
此类可用于各种网络权限。

class

NetworkInterface
此类表示一个由名称和分配给此接口的 IP 地址列表组成的网络接口。

class

NoRouteToHostException
试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。

class

PasswordAuthentication
PasswordAuthentication 类是供 Authenticator 使用的数据持有者。

class

PortUnreachableException
在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。

class

ProtocolException
抛出此异常指示在底层协议中存在错误，如 TCP 错误。

class

ProxySelector
连接到 URL 引用的网络资源时选择要使用的代理服务器（如果有）。

class

ResponseCache
表示 URLConnection 缓存的实现。

class

SecureCacheResponse
表示最初通过安全方法（如 TLS）获得的缓存响应。

class

ServerSocket
此类实现服务器套接字。

class

Socket
此类实现客户端套接字（也可以就叫“套接字”）。

class

SocketAddress
此类表示不带任何协议附件的 Socket Address。

class

SocketException
抛出此异常指示在底层协议中存在错误，如 TCP 错误。

class

SocketImpl
抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。

class

SocketPermission
此类表示通过套接字对网络的访问。

class

SocketTimeoutException
如果在读取或接受套接字时发生超时，则抛出此异常。

class

UnknownHostException
指示主机 IP 地址无法确定而抛出的异常。

class

UnknownServiceException
抛出这一异常指示出现了未知服务异常。

class

URI
表示一个统一资源标识符 (URI) 引用。

class

URISyntaxException
抛出经过检查的指示字符串不能解析为 URI 引用的异常。

class

URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

class

URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。

class

URLConnection
抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。

class

URLDecoder
HTML 格式解码的实用工具类。

class

URLEncoder
HTML 格式编码的实用工具类。

class

URLStreamHandler
抽象类 URLStreamHandler 是所有流协议处理程序的通用超类。

返回 Object 的 java.net 中的方法

Object

HttpCookie.clone()
创建并返回此对象的一个副本。

Object

URLConnection.getContent()
获取此 URL 连接的内容。

Object

URL.getContent()
获取此 URL 的内容。

Object

URLConnection.getContent(Class[] classes)
获取此 URL 连接的内容。

Object

URL.getContent(Class[] classes)
获取此 URL 的内容。

abstract  Object

ContentHandler.getContent(URLConnection urlc)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。

Object

ContentHandler.getContent(URLConnection urlc, Class[] classes)
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。

Object

SocketOptions.getOption(int optID)
获取选项的值。

参数类型为 Object 的 java.net 中的方法

boolean

HttpCookie.equals(Object obj)
测试两个 http cookie 的相等性。

boolean

SocketPermission.equals(Object obj)
检查两个 SocketPermission 对象的相等性。

boolean

InterfaceAddress.equals(Object obj)
将此对象与指定对象比较。

boolean

NetworkInterface.equals(Object obj)
将此对象与指定对象比较。

boolean

Proxy.equals(Object obj)
将此对象与指定对象比较。

boolean

URI.equals(Object ob)
测试此 URI 与另一对象的相等性。

boolean

Inet6Address.equals(Object obj)
将此对象与指定对象比较。

boolean

InetSocketAddress.equals(Object obj)
将此对象与指定对象比较。

boolean

Inet4Address.equals(Object obj)
将此对象与指定对象比较。

boolean

InetAddress.equals(Object obj)
将此对象与指定对象比较。

boolean

URL.equals(Object obj)
比较此 URL 是否等于另一个对象。

void

SocketOptions.setOption(int optID, Object value)
启用/禁用 optID 指定的选项。

java.nio 中 Object 的使用

java.nio 中 Object 的子类

class

Buffer
一个用于特定基本类型数据的容器。

class

BufferOverflowException
当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。

class

BufferUnderflowException
当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。

class

ByteBuffer
字节缓冲区。

class

ByteOrder
字节顺序的类型安全枚举。

class

CharBuffer
字符缓冲区。

class

DoubleBuffer
double 缓冲区。

class

FloatBuffer
float 缓冲区。

class

IntBuffer
int 缓冲区。

class

InvalidMarkException
当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。

class

LongBuffer
long 缓冲区。

class

MappedByteBuffer
直接字节缓冲区，其内容是文件的内存映射区域。

class

ReadOnlyBufferException
当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

class

ShortBuffer
short 缓冲区。

返回 Object 的 java.nio 中的方法

abstract  Object

Buffer.array()
返回此缓冲区的底层实现数组（可选操作）。

参数类型为 Object 的 java.nio 中的方法

boolean

DoubleBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

FloatBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

LongBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

ShortBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

IntBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

CharBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

boolean

ByteBuffer.equals(Object ob)
判断此缓冲区是否与另一个对象相同。

java.nio.channels 中 Object 的使用

java.nio.channels 中 Object 的子类

class

AlreadyConnectedException
试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。

class

AsynchronousCloseException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。

class

CancelledKeyException
当试图使用不再有效的选择键时，抛出此未经检查的异常。

class

Channels
针对信道和流的实用工具方法。

class

ClosedByInterruptException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。

class

ClosedChannelException
当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。

class

ClosedSelectorException
试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。

class

ConnectionPendingException
试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。

class

DatagramChannel
针对面向数据报套接字的可选择通道。

class

FileChannel
用于读取、写入、映射和操作文件的通道。

static class

FileChannel.MapMode
文件映射模式的类型安全的枚举。

class

FileLock
表示文件区域锁定的标记。

class

FileLockInterruptionException
当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。

class

IllegalBlockingModeException
当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。

class

IllegalSelectorException
试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。

class

NoConnectionPendingException
在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。

class

NonReadableChannelException
试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。

class

NonWritableChannelException
试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。

class

NotYetBoundException
试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。

class

NotYetConnectedException
试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。

class

OverlappingFileLockException
试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。

class

Pipe
实现单向管道传送的通道对。

static class

Pipe.SinkChannel
表示 Pipe 的可写入结尾的通道。

static class

Pipe.SourceChannel
表示 Pipe 的可读取结尾的通道。

class

SelectableChannel
可通过 Selector 实现多路复用的通道。

class

SelectionKey
表示 SelectableChannel 在 Selector 中的注册的标记。

class

Selector
SelectableChannel 对象的多路复用器。

class

ServerSocketChannel
针对面向流的侦听套接字的可选择通道。

class

SocketChannel
针对面向流的连接套接字的可选择通道。

class

UnresolvedAddressException
试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。

class

UnsupportedAddressTypeException
试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

返回 Object 的 java.nio.channels 中的方法

Object

SelectionKey.attach(Object ob)
将给定的对象附加到此键。

Object

SelectionKey.attachment()
获取当前的附加对象。

abstract  Object

SelectableChannel.blockingLock()
获取其 configureBlocking 和 register 方法实现同步的对象。

参数类型为 Object 的 java.nio.channels 中的方法

Object

SelectionKey.attach(Object ob)
将给定的对象附加到此键。

abstract  SelectionKey

SelectableChannel.register(Selector sel, int ops, Object att)
向给定的选择器注册此通道，返回一个选择键。

java.nio.channels.spi 中 Object 的使用

java.nio.channels.spi 中 Object 的子类

class

AbstractInterruptibleChannel
可中断通道的基本实现类。

class

AbstractSelectableChannel
可选择通道的基本实现类。

class

AbstractSelectionKey
选择键的基本实现类。

class

AbstractSelector
选择器的基本实现类。

class

SelectorProvider
用于选择器和可选择通道的服务提供者类。

返回 Object 的 java.nio.channels.spi 中的方法

Object

AbstractSelectableChannel.blockingLock()

参数类型为 Object 的 java.nio.channels.spi 中的方法

protected abstract  SelectionKey

AbstractSelector.register(AbstractSelectableChannel ch, int ops, Object att)
向此选择器注册给定的通道。

SelectionKey

AbstractSelectableChannel.register(Selector sel, int ops, Object att)
向给定的选择器注册此通道，返回一个选择键。

java.nio.charset 中 Object 的使用

java.nio.charset 中 Object 的子类

class

CharacterCodingException
出现字符编码或解码错误时，抛出此经过检查的异常。

class

Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。

class

CharsetDecoder
能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。

class

CharsetEncoder
能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。

class

CoderMalfunctionError
当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。

class

CoderResult
coder 结果状态的描述。

class

CodingErrorAction
编码错误操作的类型安全的枚举。

class

IllegalCharsetNameException
将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。

class

MalformedInputException
当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。

class

UnmappableCharacterException
当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。

class

UnsupportedCharsetException
当不支持请求的 charset 时，抛出此未经检查的异常。

参数类型为 Object 的 java.nio.charset 中的方法

boolean

Charset.equals(Object ob)
通知此对象是否和其他对象相等。

java.nio.charset.spi 中 Object 的使用

java.nio.charset.spi 中 Object 的子类

class

CharsetProvider
Charset 服务提供者类。

java.rmi 中 Object 的使用

java.rmi 中 Object 的子类

class

AccessException
AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。

class

AlreadyBoundException
如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。

class

ConnectException
如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。

class

ConnectIOException
如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。

class

MarshalledObject<T>
MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。

class

Naming
Naming 类提供在对象注册表中存储和获得远程对远程对象引用的方法。

class

NoSuchObjectException
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。

class

NotBoundException
如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。

class

RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

class

RMISecurityException
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。

class

RMISecurityManager
由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。

class

ServerError
当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。

class

ServerException
在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。

class

ServerRuntimeException
已过时。 无替换版本

class

StubNotFoundException
如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。

class

UnexpectedException
如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。

class

UnmarshalException
在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

参数类型为 Object 的 java.rmi 中的方法

boolean

MarshalledObject.equals(Object obj)
将此 MarshalledObject 与另一对象进行比较。

java.rmi.activation 中 Object 的使用

java.rmi.activation 中 Object 的子类

class

Activatable
Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。

class

ActivateFailedException
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。

class

ActivationDesc
激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。

class

ActivationException
激活接口所使用的一般异常。

class

ActivationGroup
ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。

class

ActivationGroup_Stub
ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

class

ActivationGroupDesc
激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。

static class

ActivationGroupDesc.CommandEnvironment
ActivationGroup 实现的启动选项。

class

ActivationGroupID
针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。

class

ActivationID
激活利用特定的标识符来表示远程对象，对象能随着时间被激活。

class

UnknownGroupException
当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。

class

UnknownObjectException
当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

参数类型为 Object 的 java.rmi.activation 中的方法

boolean

ActivationDesc.equals(Object obj)
比较两个激活描述符的内容相等性。

boolean

ActivationGroupDesc.equals(Object obj)
比较两个激活组描述符的内容相等性。

boolean

ActivationGroupDesc.CommandEnvironment.equals(Object obj)
比较两个命令环境的内容相等性。

boolean

ActivationGroupID.equals(Object obj)
比较两个组标识符的内容相等性。

boolean

ActivationID.equals(Object obj)
比较两个激活 id 的内容相等性。

java.rmi.dgc 中 Object 的使用

java.rmi.dgc 中 Object 的子类

class

Lease
一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。

class

VMID
VMID 是跨所有 Java 虚拟机都唯一的标识符。

参数类型为 Object 的 java.rmi.dgc 中的方法

boolean

VMID.equals(Object obj)
将此 VMID 与另一个进行比较，如果它们是同一标识符，则返回 true。

java.rmi.registry 中 Object 的使用

java.rmi.registry 中 Object 的子类

class

LocateRegistry
LocateRegistry 用于获得对特定主机（包括本地主机）上引导远程对象注册表的引用，或用于创建一个接受对特定端口调用的远程对象注册表。

java.rmi.server 中 Object 的使用

java.rmi.server 中 Object 的子类

class

ExportException
ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。

class

LogStream
已过时。 无替代版本

class

ObjID
ObjID 是用于标识导出到 RMI 运行时的远程对象。

class

Operation
已过时。 无替代版本

class

RemoteObject
该 RemoteObject 类实现远程对象的 java.lang.Object 行为。

class

RemoteObjectInvocationHandler
与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。

class

RemoteServer
该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。

class

RemoteStub
该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。

class

RMIClassLoader
RMIClassLoader 包含支持用 RMI 进行动态类加载的静态方法。

class

RMIClassLoaderSpi
RMIClassLoaderSpi 是 RMIClassLoader 的服务提供者接口。

class

RMISocketFactory
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。

class

ServerCloneException
如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。

class

ServerNotActiveException
如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。

class

SkeletonMismatchException
已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

class

SkeletonNotFoundException
已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

class

SocketSecurityException
已废弃的 ExportException 的子类。

class

UID
UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。

class

UnicastRemoteObject
用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

返回 Object 的 java.rmi.server 中的方法

Object

UnicastRemoteObject.clone()
返回与初始对象不同的远程对象的副本。

Object

LoaderHandler.getSecurityContext(ClassLoader loader)
已过时。 无替代版本

static Object

RMIClassLoader.getSecurityContext(ClassLoader loader)
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。

Object

RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

Object

RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum)
调用某个方法。

参数类型为 Object 的 java.rmi.server 中的方法

boolean

ObjID.equals(Object obj)
比较指定对象与此 ObjID 是否相等。

boolean

RemoteObject.equals(Object obj)
比较两个远程对象是否相等。

boolean

UID.equals(Object obj)
比较给定对象与此 UID 的相等性。

RemoteStub

ServerRef.exportObject(Remote obj, Object data)
为提供的 Remote 对象创建客户机 stub 对象。

Object

RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

Object

RemoteObjectInvocationHandler.invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

Object

RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum)
调用某个方法。

java.security 中 Object 的使用

java.security 中 Object 的子类

class

AccessControlContext
AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。

class

AccessControlException
此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。

class

AccessController
AccessController 类用于与访问控制相关的操作和决定。

class

AlgorithmParameterGenerator
AlgorithmParameterGenerator 类用于生成将在某个特定算法中使用的参数集合。

class

AlgorithmParameterGeneratorSpi
此类为 AlgorithmParameterGenerator 类定义服务提供者接口 (SPI)，AlgorithmParameterGenerator 类用于生成在某个特定算法中使用的参数集合。

class

AlgorithmParameters
此类用作密码参数的不透明表示形式。

class

AlgorithmParametersSpi
此类为 AlgorithmParameters 类定义服务提供者接口 (SPI)，AlgorithmParameters 类用于管理算法参数。

class

AllPermission
AllPermission 是暗含所有其他权限的权限。

class

AuthProvider
此类定义 provider 的登录和注销方法。

class

BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。

class

CodeSigner
此类封装关于代码签名者的信息。

class

CodeSource
此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。

class

DigestException
此为一般 Message Digest 异常。

class

DigestInputStream
使用通过流的位更新关联消息摘要的透明流。

class

DigestOutputStream
使用通过流的位更新关联消息摘要的透明流。

class

GeneralSecurityException
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。

class

GuardedObject
GuardedObject 是一个用来保护对另一个对象的访问的对象。

class

Identity
已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。

class

IdentityScope
已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。

class

InvalidAlgorithmParameterException
用于无效或不合适的算法参数的异常。

class

InvalidKeyException
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。

class

InvalidParameterException
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。

class

KeyException
此异常是基本的密钥异常。

class

KeyFactory
密钥工厂用于将密钥（Key 类型的不透明加密密钥）转换成密钥规范（底层密钥材料的透明表示），反之亦然。

class

KeyFactorySpi
此类为 KeyFactory 类定义服务提供者接口 (SPI)。

class

KeyManagementException
此异常是用于所有处理密钥管理的操作的通用密钥管理异常。

class

KeyPair
此类是简单的密钥对（公钥和私钥）持有者。

class

KeyPairGenerator
KeyPairGenerator 类用于生成公钥和私钥对。

class

KeyPairGeneratorSpi
此类为用来生成公钥和私钥的 KeyPairGenerator 类定义了服务提供者接口 (SPI)。

class

KeyRep
已序列化的 Key 对象的标准表示形式。

class

KeyStore
此类表示密钥和证书的存储设施。

static class

KeyStore.Builder
将被实例化的 KeyStore 对象的描述。

static class

KeyStore.CallbackHandlerProtection
封装 CallbackHandler 的 ProtectionParameter。

static class

KeyStore.PasswordProtection
ProtectionParameter 的一个基于密码的实现。

static class

KeyStore.PrivateKeyEntry
保存 PrivateKey 和相应证书链的 KeyStore 项。

static class

KeyStore.SecretKeyEntry
保存 SecretKey 的 KeyStore 项。

static class

KeyStore.TrustedCertificateEntry
保存可信的 Certificate 的 KeyStore 项。

class

KeyStoreException
这是一般的 KeyStore 异常。

class

KeyStoreSpi
此类为 KeyStore 类定义服务提供者接口 (SPI)。

class

MessageDigest
此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。

class

MessageDigestSpi
此类为 MessageDigest 类定义服务提供者接口 (SPI)，MessageDigest 类提供信息摘要算法的功能，如 MD5 或 SHA。

class

NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。

class

NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。

class

Permission
表示访问系统资源的抽象类。

class

PermissionCollection
表示 Permission 对象集合的抽象类。

class

Permissions
此类表示一个不同种类的 Permission 集合。

class

Policy
Policy 对象负责确定在 Java 运行时环境中执行的代码是否有权执行安全敏感的操作。

class

PolicySpi
此类为 Policy 类定义服务提供者接口 (SPI)。

class

PrivilegedActionException
doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。

class

ProtectionDomain
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。

static class

Provider.Service
安全服务的描述。

class

ProviderException
用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。

class

SecureClassLoader
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。

class

SecureRandom
此类提供强加密随机数生成器 (RNG)。

class

SecureRandomSpi
此类为 SecureRandom 类定义了服务提供者接口 (SPI)。

class

Security
此类集中了所有的安全属性和常见的安全方法。

class

SecurityPermission
此类用于安全权限。

class

Signature
此 Signature 类用来为应用程序提供数字签名算法功能。

class

SignatureException
这是一般的签名异常。

class

SignatureSpi
此类为 Signature 类定义了服务提供者接口 (SPI)，可用来提供数字签名算法功能。

class

SignedObject
SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。

class

Signer
已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

class

Timestamp
此类封装有关签署时间戳的信息。

class

UnrecoverableEntryException
如果 keystore 中的某项无法恢复，则抛出此异常。

class

UnrecoverableKeyException
如果 keystore 中的密钥无法恢复，则抛出此异常。

class

UnresolvedPermission
UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

class

URIParameter
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

返回 Object 的 java.security 中的方法

Object

Signature.clone()
如果此实现可以复制，则返回副本。

Object

SignatureSpi.clone()
如果此实现可以复制，则返回一个副本。

Object

MessageDigest.clone()
如果实现是可复制的，则返回一个副本。

Object

MessageDigestSpi.clone()
如果实现是可复制的，则返回一个副本。

protected abstract  Object

SignatureSpi.engineGetParameter(String param)
已过时。

Object

Provider.get(Object key)

Object

GuardedObject.getObject()
获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。

Object

SignedObject.getObject()
获取已封装的对象。

Object

Signature.getParameter(String param)
已过时。

Object

Provider.Service.newInstance(Object constructorParameter)
返回此服务描述的实现的新实例。

Object

Provider.put(Object key, Object value)
设置 key 属性，使其具有指定的 value。

protected  Object

KeyRep.readResolve()
解析 Key 对象。

Object

Provider.remove(Object key)
移除 key 属性（及其相应的 value）。

返回变量类型为 Object 的类型的 java.security 中的方法

Enumeration<Object>

Provider.elements()

Set<Map.Entry<Object,Object>>

Provider.entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。

Set<Map.Entry<Object,Object>>

Provider.entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。

Enumeration<Object>

Provider.keys()

Set<Object>

Provider.keySet()
返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。

Collection<Object>

Provider.values()
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。

参数类型为 Object 的 java.security 中的方法

void

Permission.checkGuard(Object object)
为某权限实现 guard 接口。

void

Guard.checkGuard(Object object)
确定是否允许访问受保护的 object 对象。

protected abstract  void

SignatureSpi.engineSetParameter(String param, Object value)
已过时。 由 engineSetParameter 取代。

boolean

Identity.equals(Object identity)
已过时。 测试指定对象与此 Identity 的相等性。

boolean

Timestamp.equals(Object obj)
比较指定的对象和此时间戳之间的相同性。

boolean

CodeSigner.equals(Object obj)
测试指定对象与此代码签名者之间是否相等。

boolean

Principal.equals(Object another)
将此主体与指定对象比较。

boolean

UnresolvedPermission.equals(Object obj)
检查两个 UnresolvedPermission 对象的相等性。

boolean

AllPermission.equals(Object obj)
检查两个 AllPermission 对象是否相等。

boolean

CodeSource.equals(Object obj)
测试指定对象与此对象之间的相等性。

boolean

BasicPermission.equals(Object obj)
检查两个 BasicPermission 对象是否相等。

abstract  boolean

Permission.equals(Object obj)
检查两个 Permission 对象是否相等。

boolean

AccessControlContext.equals(Object obj)
检查两个 AccessControlContext 对象是否相等。

Object

Provider.get(Object key)

Object

Provider.Service.newInstance(Object constructorParameter)
返回此服务描述的实现的新实例。

Object

Provider.put(Object key, Object value)
设置 key 属性，使其具有指定的 value。

Object

Provider.remove(Object key)
移除 key 属性（及其相应的 value）。

void

Signature.setParameter(String param, Object value)
已过时。 使用 setParameter 取代。

boolean

Provider.Service.supportsParameter(Object parameter)
测试此 Service 是否能使用指定的参数。

参数类型为 Object 的 java.security 中的构造方法

GuardedObject(Object object, Guard guard)
使用指定的对象和 guard 构造 GuardedObject。

java.security.acl 中 Object 的使用

java.security.acl 中 Object 的子类

class

AclNotFoundException
如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。

class

LastOwnerException
如果试图删除访问控制列表的最后一个所有者，则抛出此异常。

class

NotOwnerException
当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

返回 Object 的 java.security.acl 中的方法

Object

AclEntry.clone()
复制此 ACL 项。

参数类型为 Object 的 java.security.acl 中的方法

boolean

Permission.equals(Object another)
如果传递的对象与此接口中所表示的权限相匹配，则返回 true。

java.security.cert 中 Object 的使用

java.security.cert 中 Object 的子类

class

Certificate
管理各种身份证书的抽象类。

protected static class

Certificate.CertificateRep
用于序列化的替换 Certificate 类。

class

CertificateFactory
此类定义了用于从相关的编码中生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象的 CertificateFactory 功能。

class

CertificateFactorySpi
此类定义了 CertificateFactory 类的服务提供者接口 (SPI)。

class

CertPath
不可变的证书序列（证书路径）。

protected static class

CertPath.CertPathRep
用于序列化的替换 CertPath 类。

class

CertPathBuilder
构建证书路径（也称为证书链）的类。

class

CertPathBuilderException
指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。

class

CertPathBuilderSpi
CertPathBuilder 类的服务提供者接口 (SPI)。

class

CertPathValidator
验证证书路径（也称为证书链）的类。

class

CertPathValidatorException
指示在验证一个证书路径时遇到了某种问题的异常。

class

CertPathValidatorSpi
CertPathValidator 类的服务提供者接口 (SPI)。

class

CertStore
用于从存储库中获取 Certificate 和 CRL 的类。

class

CertStoreException
指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。

class

CertStoreSpi
CertStore 类的服务提供者接口 (SPI)。

class

CollectionCertStoreParameters
用作 Collection CertStore 算法输入的参数。

class

CRL
此类是具有不同格式但很常用的证书撤消列表 (CRL) 的抽象。

class

CRLException
CRL（证书撤消列表）异常。

class

LDAPCertStoreParameters
用作 LDAP CertStore 算法的输入的参数。

class

PKIXBuilderParameters
用作 PKIX CertPathBuilder 算法的输入的参数。

class

PKIXCertPathBuilderResult
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。

class

PKIXCertPathChecker
对 X509Certificate 执行一种或多种检查的抽象类。

class

PKIXCertPathValidatorResult
此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。

class

PKIXParameters
用作 PKIX CertPathValidator 算法的输入的参数。

class

PolicyQualifierInfo
由 ASN.1 PolicyQualifierInfo 结构所表示的、不可变的策略限定符。

class

TrustAnchor
一个信任定位点或最受信任的证书颁发机构 (CA)。

class

X509Certificate
X.509 证书的抽象类。

class

X509CertSelector
选择与所有指定标准匹配的 X509Certificates 的 CertSelector。

class

X509CRL
X.509 证书撤消列表 (CRL) 的抽象类。

class

X509CRLEntry
用于 CRL（证书撤消列表）中已撤消证书的抽象类。

class

X509CRLSelector
选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。

返回 Object 的 java.security.cert 中的方法

Object

CRLSelector.clone()
对此 CRLSelector 进行复制。

Object

CertPathBuilderResult.clone()
对此 CertPathBuilderResult 进行复制。

Object

CertPathParameters.clone()
对此 CertPathParameters 进行复制。

Object

CertPathValidatorResult.clone()
对此 CertPathValidatorResult 进行复制。

Object

CertSelector.clone()
对此 CertSelector 进行复制。

Object

CertStoreParameters.clone()
对此 CertStoreParameters 进行复制。

Object

CollectionCertStoreParameters.clone()
返回此对象的副本。

Object

LDAPCertStoreParameters.clone()
返回此对象的副本。

Object

PKIXCertPathChecker.clone()
返回此对象的副本。

Object

PKIXCertPathValidatorResult.clone()
返回此对象的副本。

Object

PKIXParameters.clone()
对此 PKIXParameters 对象进行复制。

Object

X509CRLSelector.clone()
返回此对象的副本。

Object

X509CertSelector.clone()
返回此对象的副本。

protected  Object

CertPath.CertPathRep.readResolve()
返回根据类型和数据所构造的 CertPath。

protected  Object

Certificate.CertificateRep.readResolve()
解析该 Certificate 对象。

protected  Object

CertPath.writeReplace()
使用 CertPathRep 对象替换要被序列化的 CertPath。

protected  Object

Certificate.writeReplace()
替换要被序列化的 Certificate。

返回变量类型为 Object 的类型的 java.security.cert 中的方法

Collection<Object>

X509CRLSelector.getIssuerNames()
返回该 issuerNames 标准的一个副本。

参数类型为 Object 的 java.security.cert 中的方法

boolean

X509CRL.equals(Object other)
比较此 CRL 与给定对象的相等性。

boolean

X509CRLEntry.equals(Object other)
比较此 CRL 项与给定对象的相等性。

boolean

CertPath.equals(Object other)
比较此证书路径与指定对象的相等性。

boolean

Certificate.equals(Object other)
比较此证书与指定对象的相等性。

java.security.spec 中 Object 的使用

java.security.spec 中 Object 的子类

class

DSAParameterSpec
此类指定用于 DSA 算法的参数的集合。

class

DSAPrivateKeySpec
此类指定带关联参数的 DSA 专用密钥。

class

DSAPublicKeySpec
此类指定带关联参数的 DSA 公用密钥。

class

ECFieldF2m
此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。

class

ECFieldFp
此不可变类定义椭圆曲线 (EC) 素数的有限字段。

class

ECGenParameterSpec
此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。

class

ECParameterSpec
此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。

class

ECPoint
此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。

class

ECPrivateKeySpec
此不可变类指定带关联参数的椭圆曲线专用密钥。

class

ECPublicKeySpec
此不可变类指定带关联参数的椭圆曲线公用密钥。

class

EllipticCurve
此不可变类持有表示椭圆曲线所必需的值。

class

EncodedKeySpec
此类用编码格式表示公用密钥或专用密钥。

class

InvalidKeySpecException
这是针对无效密钥规范的异常。

class

InvalidParameterSpecException
这是针对无效参数规范的异常。

class

MGF1ParameterSpec
此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。

class

PKCS8EncodedKeySpec
此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。

class

PSSParameterSpec
此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。

class

RSAKeyGenParameterSpec
此类指定用于生成 RSA 密钥对的参数集。

class

RSAMultiPrimePrivateCrtKeySpec
如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。

class

RSAOtherPrimeInfo
此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。

class

RSAPrivateCrtKeySpec
为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。

class

RSAPrivateKeySpec
此类指定 RSA 专用密钥。

class

RSAPublicKeySpec
此类指定 RSA 公用密钥。

class

X509EncodedKeySpec
此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。

参数类型为 Object 的 java.security.spec 中的方法

boolean

ECFieldF2m.equals(Object obj)
比较此有限字段与指定对象的相等性。

boolean

ECFieldFp.equals(Object obj)
比较此素数有限字段与指定对象的相等性。

boolean

ECPoint.equals(Object obj)
比较此椭圆曲线点与指定对象的相等性。

boolean

EllipticCurve.equals(Object obj)
比较此椭圆曲线与指定对象的相等性。

java.sql 中 Object 的使用

java.sql 中 Object 的子类

class

BatchUpdateException
进行批量更新操作期间发生错误时抛出的 SQLException 子类。

class

DataTruncation
以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。

class

DriverManager
管理一组 JDBC 驱动程序的基本服务。

class

DriverPropertyInfo
用于建立连接的驱动程序属性。

class

SQLClientInfoException
当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。

class

SQLDataException
当 SQLState 类值为“22”时抛出的 SQLException 子类。

class

SQLException
提供关于数据库访问错误或其他错误信息的异常。

class

SQLFeatureNotSupportedException
当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。

class

SQLIntegrityConstraintViolationException
当 SQLState 类值为“23”时抛出的 SQLException 子类。

class

SQLInvalidAuthorizationSpecException
当 SQLState 类值为“28”时抛出的 SQLException 子类。

class

SQLNonTransientConnectionException
SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。

class

SQLNonTransientException
重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。

class

SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

class

SQLRecoverableException
应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。

class

SQLSyntaxErrorException
当 SQLState 类值为“42”时抛出的 SQLException 子类。

class

SQLTimeoutException
Statement 指定的超时已到期时抛出的 SQLException 子类。

class

SQLTransactionRollbackException
当 SQLState 类值为“40”时，抛出此 SQLException 的子类。

class

SQLTransientConnectionException
SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。

class

SQLTransientException
没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。

class

SQLWarning
提供关于数据库访问警告信息的异常。

class

Time
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。

class

Types
定义用于标识一般 SQL 类型（称为 JDBC 类型）的常量的类。

返回 Object 的 java.sql 中的方法

Object

Array.getArray()
以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。

Object

Array.getArray(long index, int count)
获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。

Object

Array.getArray(long index, int count, Map<String,Class<?>> map)
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。

Object

Array.getArray(Map<String,Class<?>> map)
获取由此 Array 对象指定的 SQL ARRAY 值的内容。

Object[]

Struct.getAttributes()
生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。

Object[]

Struct.getAttributes(Map<String,Class<?>> map)
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。

Object

Ref.getObject()
获取此 Ref 对象引用的 SQL 结构类型实例。

Object

CallableStatement.getObject(int parameterIndex)
以 Java 编程语言中 Object 的形式获取指定参数的值。

Object

ResultSet.getObject(int columnIndex)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(int columnIndex, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

Ref.getObject(Map<String,Class<?>> map)
获取引用对象并使用给定类型映射表将其映射到 Java 类型。

Object

CallableStatement.getObject(String parameterName)
以 Java 编程语言中 Object 的形式获取参数的值。

Object

ResultSet.getObject(String columnLabel)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。

Object

ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

Object

SQLInput.readObject()
读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。

参数类型为 Object 的 java.sql 中的方法

Array

Connection.createArrayOf(String typeName, Object[] elements)
创建 Array 对象的工厂方法。

Struct

Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。

boolean

RowId.equals(Object obj)
将此 RowId 与指定对象比较。

boolean

Timestamp.equals(Object ts)
测试此对象是否等于给定的 Timestamp 对象。

void

PreparedStatement.setObject(int parameterIndex, Object x)
使用给定对象设置指定参数的值。

void

PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
使用给定对象设置指定参数的值。

void

Ref.setObject(Object value)
将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。

void

CallableStatement.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

CallableStatement.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

void

ResultSet.updateObject(int columnIndex, Object x)
用 Object 值更新指定列。

void

ResultSet.updateObject(int columnIndex, Object x, int scaleOrLength)
用 Object 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x)
用 Object 值更新指定列。

void

ResultSet.updateObject(String columnLabel, Object x, int scaleOrLength)
用 Object 值更新指定列。

java.text 中 Object 的使用

java.text 中 Object 的子类

class

Annotation
如果文本属性具有 annotation 特征，则 Annotation 对象用作文本属性值的包装器。

static class

AttributedCharacterIterator.Attribute
定义用于标识文本属性的属性键。

class

AttributedString
AttributedString 保存文本及相关属性信息。

class

Bidi
此类实现了 Unicode 双向算法 (Unicode Bidirectional Algorithm)。

class

BreakIterator
BreakIterator 类实现用于查找文本中边界位置的方法。

class

ChoiceFormat
ChoiceFormat 允许将格式应用到某个范围的数。

class

CollationElementIterator
CollationElementIterator 类用作一个迭代器，以遍历国际化字符串的每个字符。

class

CollationKey
CollationKey 表示遵守特定 Collator 对象规则的 String。

class

Collator
Collator 类执行区分语言环境的 String 比较。

class

DateFormat
DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。

static class

DateFormat.Field
定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。

class

DateFormatSymbols
DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。

class

DecimalFormat
DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。

class

DecimalFormatSymbols
此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。

class

FieldPosition
FieldPosition 是 Format 及其子类用于在格式输出中标识字段的简单类。

class

Format
Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。

static class

Format.Field
定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。

class

MessageFormat
MessageFormat 提供了以与语言无关方式生成连接消息的方式。

static class

MessageFormat.Field
在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。

class

Normalizer
此类提供 normalize 方法，它把 Unicode 文本转换为等效的组合或分解形式，允许对文本进行更方便地分类和搜索。

class

NumberFormat
NumberFormat 是所有数值格式的抽象基类。

static class

NumberFormat.Field
定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。

class

ParseException
表示解析时出现意外错误。

class

ParsePosition
ParsePosition 是 Format 及其子类所使用的简单类，用来在解析过程中跟踪当前位置。

class

RuleBasedCollator
RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。

class

SimpleDateFormat
SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

class

StringCharacterIterator
StringCharacterIterator 为 String 实现 CharacterIterater 协议。

返回 Object 的 java.text 中的方法

Object

BreakIterator.clone()
创建此迭代器的副本。

Object

ChoiceFormat.clone()
重写 Cloneable

Object

StringCharacterIterator.clone()
创建此迭代器的副本。

Object

RuleBasedCollator.clone()
标准重写，无语义变化。

Object

Collator.clone()
重写 Cloneable

Object

DecimalFormat.clone()
标准重写；没有语义上的变化。

Object

DecimalFormatSymbols.clone()
标准重写。

Object

NumberFormat.clone()
重写 Cloneable

Object

DateFormatSymbols.clone()
重写 Cloneable。

Object

SimpleDateFormat.clone()
创建此 SimpleDateFormat 的一个副本。

Object

DateFormat.clone()
重写 Cloneable

Object

MessageFormat.clone()
创建并返回此对象的一个副本。

Object

Format.clone()
创建并返回此对象的一个副本。

Object

CharacterIterator.clone()
创建此迭代器的一个副本

Object

AttributedCharacterIterator.getAttribute(AttributedCharacterIterator.Attribute attribute)
返回当前字符的命名属性的值。

Object[]

ChoiceFormat.getFormats()
获取传入构造方法的 format。

Object

Annotation.getValue()
返回属性值，可能为 null。

Object[]

MessageFormat.parse(String source)
从给定字符串的开始位置解析文本，以生成一个对象数组。

Object[]

MessageFormat.parse(String source, ParsePosition pos)
解析字符串。

Object

Format.parseObject(String source)
从给定字符串的开始处解析文本以生成一个对象。

Object

NumberFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

Object

DateFormat.parseObject(String source, ParsePosition pos)
解析字符串中的文本，以生成一个 Date。

Object

MessageFormat.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象数组。

abstract  Object

Format.parseObject(String source, ParsePosition pos)
解析字符串文本，生成一个对象。

protected  Object

AttributedCharacterIterator.Attribute.readResolve()
解析将被反序列化为预定义常量的实例。

protected  Object

NumberFormat.Field.readResolve()
将正被反序列化的实例解析为预定义的常量。

protected  Object

DateFormat.Field.readResolve()
将反序列化的实例解析成预定义的常量。

protected  Object

MessageFormat.Field.readResolve()
把正被反序列化的实例解析为预定义的常量。

返回变量类型为 Object 的类型的 java.text 中的方法

Map<AttributedCharacterIterator.Attribute,Object>

AttributedCharacterIterator.getAttributes()
返回具有定义于当前字符上的多个属性的映射。

参数类型为 Object 的 java.text 中的方法

void

AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value)
将一个属性添加到整个字符串中。

void

AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex)
将一个属性添加到字符串的子范围。

int

Collator.compare(Object o1, Object o2)
比较此方法两个参数的顺序。

boolean

AttributedCharacterIterator.Attribute.equals(Object obj)
比较两个对象的相等性。

boolean

ChoiceFormat.equals(Object obj)
两个对象之间的相等性比较。

boolean

ParsePosition.equals(Object obj)
重写 equals

boolean

StringCharacterIterator.equals(Object obj)
比较两个 StringCharacterIterator 对象的相等性。

boolean

RuleBasedCollator.equals(Object obj)
比较两个 collation 对象的相等性。

boolean

Collator.equals(Object that)
比较两个 Collator 的相等性。

boolean

DecimalFormat.equals(Object obj)
重写 equals

boolean

DecimalFormatSymbols.equals(Object obj)
重写 equals。

boolean

NumberFormat.equals(Object obj)
重写 equals

boolean

DateFormatSymbols.equals(Object obj)
重写 equals。

boolean

SimpleDateFormat.equals(Object obj)
比较给定对象与此 SimpleDateFormat 的相等性。

boolean

DateFormat.equals(Object obj)
重写 equals

boolean

FieldPosition.equals(Object obj)
重写 equals

boolean

MessageFormat.equals(Object obj)
两个消息格式对象之间的相等性比较

String

Format.format(Object obj)
格式化一个对象以生成一个字符串。

StringBuffer

MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos)
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。

StringBuffer

DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos)
格式化一个数，并将所得文本追加到给定的字符串缓冲区。

StringBuffer

NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos)
格式化一个数并将所得文本添加到给定字符串缓冲区。

StringBuffer

DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition)
重写 Format。

StringBuffer

MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos)
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。

abstract  StringBuffer

Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos)
格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

static String

MessageFormat.format(String pattern, Object... arguments)
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。

AttributedCharacterIterator

DecimalFormat.formatToCharacterIterator(Object obj)
格式化一个 Object，以生成一个 AttributedCharacterIterator。

AttributedCharacterIterator

SimpleDateFormat.formatToCharacterIterator(Object obj)
格式化生成 AttributedCharacterIterator 的对象。

AttributedCharacterIterator

MessageFormat.formatToCharacterIterator(Object arguments)
格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。

AttributedCharacterIterator

Format.formatToCharacterIterator(Object obj)
格式化一个对象，生成一个 AttributedCharacterIterator。

static void

Bidi.reorderVisually(byte[] levels, int levelStart, Object[] objects, int objectStart, int count)
根据对象的层次，在数组中将对象重新排序为可视顺序。

参数类型为 Object 的 java.text 中的构造方法

Annotation(Object value)
构造一条具有给定值（可能为 null）的 annotation 记录。

java.text.spi 中 Object 的使用

java.text.spi 中 Object 的子类

class

BreakIteratorProvider
提供 BreakIterator 类具体实现的服务提供者的抽象类。

class

CollatorProvider
提供 Collator 类具体实现的服务提供者的抽象类。

class

DateFormatProvider
提供 DateFormat 类具体实现的服务提供者的抽象类。

class

DateFormatSymbolsProvider
提供 DateFormatSymbols 类实例的服务提供者的抽象类。

class

DecimalFormatSymbolsProvider
提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。

class

NumberFormatProvider
提供 NumberFormat 类具体实现的服务提供者的抽象类。

java.util 中 Object 的使用

java.util 中 Object 的子类

class

AbstractCollection<E>
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。

class

AbstractList<E>
此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。

class

AbstractMap<K,V>
此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。

static class

AbstractMap.SimpleEntry<K,V>
维护键和值的 Entry。

static class

AbstractMap.SimpleImmutableEntry<K,V>
维护不可变的键和值的 Entry。

class

AbstractQueue<E>
此类提供某些 Queue 操作的骨干实现。

class

AbstractSequentialList<E>
此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。

class

AbstractSet<E>
此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。

class

ArrayDeque<E>
Deque 接口的大小可变数组的实现。

class

ArrayList<E>
List 接口的大小可变数组的实现。

class

Arrays
此类包含用来操作数组（比如排序和搜索）的各种方法。

class

BitSet
此类实现了一个按需增长的位向量。

class

Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。

class

Collections
此类完全由在 collection 上进行操作或返回 collection 的静态方法组成。

class

ConcurrentModificationException
当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。

class

Currency
表示货币。

class

Date
类 Date 表示特定的瞬间，精确到毫秒。

class

Dictionary<K,V>
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。

class

DuplicateFormatFlagsException
格式说明符中提供重复标志时抛出的未经检查的异常。

class

EmptyStackException
该异常由 Stack 类中的方法抛出，以表明堆栈为空。

class

EnumMap<K extends Enum<K>,V>
与枚举类型键一起使用的专用 Map 实现。

class

EnumSet<E extends Enum<E>>
与枚举类型一起使用的专用 Set 实现。

class

EventListenerProxy
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。

class

EventObject
所有事件状态对象都将从其派生的根类。

class

FormatFlagsConversionMismatchException
转换与标志不兼容时抛出未经检查的异常。

class

FormattableFlags
将 FomattableFlags 传递给 Formattable.formatTo() 方法，并修改 Formattables 的输出格式。

class

Formatter
printf 风格的格式字符串的解释程序。

class

FormatterClosedException
格式器已关闭时抛出的未经检查的异常。

class

GregorianCalendar
GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。

class

HashMap<K,V>
基于哈希表的 Map 接口的实现。

class

HashSet<E>
此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。

class

Hashtable<K,V>
此类实现一个哈希表，该哈希表将键映射到相应的值。

class

IdentityHashMap<K,V>
此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。

class

IllegalFormatCodePointException
将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。

class

IllegalFormatConversionException
当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。

class

IllegalFormatException
当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。

class

IllegalFormatFlagsException
当给出非法组合标志时，抛出未经检查的异常。

class

IllegalFormatPrecisionException
当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。

class

IllegalFormatWidthException
当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。

class

InputMismatchException
由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。

class

InvalidPropertiesFormatException
当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。

class

LinkedHashMap<K,V>
Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。

class

LinkedHashSet<E>
具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。

class

LinkedList<E>
List 接口的链接列表实现。

class

ListResourceBundle
ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。

class

Locale
Locale 对象表示了特定的地理、政治和文化地区。

class

MissingFormatArgumentException
如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。

class

MissingFormatWidthException
请求格式宽度时抛出未经检查的异常。

class

MissingResourceException
缺少资源时抛出此异常。

class

NoSuchElementException
由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。

class

Observable
此类表示模型视图范例中的 observable 对象，或者说“数据”。

class

PriorityQueue<E>
一个基于优先级堆的无界优先级队列。

class

Properties
Properties 类表示了一个持久的属性集。

class

PropertyPermission
此类用于属性权限。

class

PropertyResourceBundle
PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。

class

Random
此类的实例用于生成伪随机数流。

class

ResourceBundle
资源包包含特定于语言环境的对象。

static class

ResourceBundle.Control
ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。

class

Scanner
一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。

class

ServiceConfigurationError
在加载服务提供者的过程中出错时抛出的错误。

class

ServiceLoader<S>
一个简单的服务提供者加载设施。

class

SimpleTimeZone
SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。

class

Stack<E>
Stack 类表示后进先出（LIFO）的对象堆栈。

class

StringTokenizer
string tokenizer 类允许应用程序将字符串分解为标记。

class

Timer
一种工具，线程用其安排以后在后台线程中执行的任务。

class

TimerTask
由 Timer 安排为一次执行或重复执行的任务。

class

TimeZone
TimeZone 表示时区偏移量，也可以计算夏令时。

class

TooManyListenersException
TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。

class

TreeMap<K,V>
基于红黑树（Red-Black tree）的 NavigableMap 实现。

class

TreeSet<E>
基于 TreeMap 的 NavigableSet 实现。

class

UnknownFormatConversionException
给定未知的转换时所抛出的未经检查的异常。

class

UnknownFormatFlagsException
给定未知标志时所抛出的未经检查的异常。

class

UUID
表示通用唯一标识符 (UUID) 的类。

class

Vector<E>
Vector 类可以实现可增长的对象数组。

class

WeakHashMap<K,V>
以弱键 实现的基于哈希表的 Map。

声明为 Object 的 java.util 中的字段

protected  Object[]

Vector.elementData
存储向量组件的数组缓冲区。

protected  Object

EventObject.source
最初发生 Event 的对象。

类型参数类型为 Object 的 java.util 中的方法

static

<T extends Object & Comparable<? super T>>
T

Collections.max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。

static

<T extends Object & Comparable<? super T>>
T

Collections.min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。

返回 Object 的 java.util 中的方法

Object

SimpleTimeZone.clone()
返回此 SimpleTimeZone 实例的一个副本。

Object

GregorianCalendar.clone()

Object

Calendar.clone()
创建并返回此对象的一个副本。

Object

TreeSet.clone()
返回 TreeSet 实例的浅表副本。

Object

TimeZone.clone()
创建此 TimeZone 的一个副本。

Object

Date.clone()
返回此对象的副本。

Object

IdentityHashMap.clone()
返回此标识哈希映射的浅表副本：不复制键和值本身。

Object

LinkedList.clone()
返回此 LinkedList 的浅表副本。

Object

TreeMap.clone()
返回此 TreeMap 实例的浅表副本。

Object

HashSet.clone()
返回此 HashSet 实例的浅表副本：并没有复制这些元素本身。

Object

Locale.clone()
重写 Cloneable。

Object

BitSet.clone()
复制此 BitSet，生成一个与之相等的新 BitSet。

Object

ArrayList.clone()
返回此 ArrayList 实例的浅表副本。

Object

HashMap.clone()
返回此 HashMap 实例的浅表副本：并不复制键和值本身。

protected  Object

AbstractMap.clone()
返回此 AbstractMap 实例的浅表副本：不复制键和值本身。

Object

Vector.clone()
返回向量的一个副本。

Object

Hashtable.clone()
创建此哈希表的浅表副本。

static

<T> T[]

Arrays.copyOf(T[] original, int newLength)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T,U> T[]

Arrays.copyOf(U[] original, int newLength, Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T> T[]

Arrays.copyOfRange(T[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。

static

<T,U> T[]

Arrays.copyOfRange(U[] original, int from, int to, Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。

protected abstract  Object[][]

ListResourceBundle.getContents()
返回一个数组，其中 Object 数组中的每个项都是一个对象对。

Object

ResourceBundle.getObject(String key)
从此资源包或它的某个父包中获取给定键的对象。

Object

EventObject.getSource()
最初发生 Event 的对象。

Object

PropertyResourceBundle.handleGetObject(String key)

Object

ListResourceBundle.handleGetObject(String key)

protected abstract  Object

ResourceBundle.handleGetObject(String key)
从此资源包中获取给定键的对象。

Object

StringTokenizer.nextElement()
除了其声明返回值是 Object 而不是 String 之外，它返回与 nextToken 方法相同的值。

Object

Properties.setProperty(String key, String value)
调用 Hashtable 的方法 put。

Object[]

ArrayDeque.toArray()
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）。

Object[]

PriorityQueue.toArray()
返回一个包含此队列所有元素的数组。

Object[]

LinkedList.toArray()
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。

Object[]

ArrayList.toArray()
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组。

Object[]

Set.toArray()
返回一个包含 set 中所有元素的数组。

Object[]

Vector.toArray()
返回一个数组，包含此向量中以恰当顺序存放的所有元素。

Object[]

AbstractCollection.toArray()
返回包含此 collection 中所有元素的数组。

Object[]

List.toArray()
返回按适当顺序包含列表中的所有元素的数组（从第一个元素到最后一个元素）。

Object[]

Collection.toArray()
返回包含此 collection 中所有元素的数组。

<T> T[]

ArrayDeque.toArray(T[] a)
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedList.toArray(T[] a)
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。

<T> T[]

ArrayList.toArray(T[] a)
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Set.toArray(T[] a)
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

Vector.toArray(T[] a)
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。

<T> T[]

AbstractCollection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

<T> T[]

List.toArray(T[] a)
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Collection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

参数类型为 Object 的 java.util 中的方法

static

<T> boolean

Collections.addAll(Collection<? super T> c, T... elements)
将所有指定元素添加到指定 collection 中。

boolean

Calendar.after(Object when)
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之后，返回判断结果。

static

<T> List<T>

Arrays.asList(T... a)
返回一个受指定数组支持的固定大小的列表。

boolean

Calendar.before(Object when)
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之前，返回判断结果。

static int

Arrays.binarySearch(Object[] a, int fromIndex, int toIndex, Object key)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。

static int

Arrays.binarySearch(Object[] a, int fromIndex, int toIndex, Object key)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。

static int

Arrays.binarySearch(Object[] a, Object key)
使用二分搜索法来搜索指定数组，以获得指定对象。

static int

Arrays.binarySearch(Object[] a, Object key)
使用二分搜索法来搜索指定数组，以获得指定对象。

static

<T> int

Arrays.binarySearch(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。

static

<T> int

Arrays.binarySearch(T[] a, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组，以获得指定对象。

boolean

ArrayDeque.contains(Object o)
如果此双端队列包含指定元素，则返回 true。

boolean

PriorityQueue.contains(Object o)
如果此队列包含指定的元素，则返回 true。

boolean

TreeSet.contains(Object o)
如果此 set 包含指定的元素，则返回 true。

boolean

LinkedList.contains(Object o)
如果此列表包含指定元素，则返回 true。

boolean

Deque.contains(Object o)
如果此双端队列包含指定元素，则返回 true。

boolean

HashSet.contains(Object o)
如果此 set 包含指定元素，则返回 true。

boolean

ArrayList.contains(Object o)
如果此列表中包含指定的元素，则返回 true。

boolean

Set.contains(Object o)
如果 set 包含指定的元素，则返回 true。

boolean

Vector.contains(Object o)
如果此向量包含指定的元素，则返回 true。

boolean

AbstractCollection.contains(Object o)
如果此 collection 包含指定的元素，则返回 true。

boolean

List.contains(Object o)
如果列表包含指定的元素，则返回 true。

boolean

Collection.contains(Object o)
如果此 collection 包含指定的元素，则返回 true。

boolean

Hashtable.contains(Object value)
测试此映射表中是否存在与指定值关联的键。

boolean

EnumMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

IdentityHashMap.containsKey(Object key)
测试指定的对象引用是否为此标识哈希映射中的键。

boolean

TreeMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

WeakHashMap.containsKey(Object key)
如果此映射对于指定的键包含映射关系，则返回 true。

boolean

HashMap.containsKey(Object key)
如果此映射包含对于指定键的映射关系，则返回 true。

boolean

AbstractMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

Hashtable.containsKey(Object key)
测试指定对象是否为此哈希表中的键。

boolean

Map.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

EnumMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

IdentityHashMap.containsValue(Object value)
测试指定的对象引用是否为此标识哈希映射中的值。

boolean

TreeMap.containsValue(Object value)
如果此映射为指定值映射一个或多个键，则返回 true。

boolean

WeakHashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

LinkedHashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

HashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

AbstractMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

Hashtable.containsValue(Object value)
如果此 Hashtable 将一个或多个键映射到此值，则返回 true。

boolean

Map.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

void

Vector.copyInto(Object[] anArray)
将此向量的组件复制到指定的数组中。

static

<T> T[]

Arrays.copyOf(T[] original, int newLength)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T,U> T[]

Arrays.copyOf(U[] original, int newLength, Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。

static

<T> T[]

Arrays.copyOfRange(T[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。

static

<T,U> T[]

Arrays.copyOfRange(U[] original, int from, int to, Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。

static boolean

Arrays.deepEquals(Object[] a1, Object[] a2)
如果两个指定数组彼此是深层相等 的，则返回 true。

static boolean

Arrays.deepEquals(Object[] a1, Object[] a2)
如果两个指定数组彼此是深层相等 的，则返回 true。

static int

Arrays.deepHashCode(Object[] a)
基于指定数组的“深层内容”返回哈希码。

static String

Arrays.deepToString(Object[] a)
返回指定数组“深层内容”的字符串表示形式。

boolean

EnumMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

SimpleTimeZone.equals(Object obj)
比较两个 SimpleTimeZone 对象的相等性。

boolean

UUID.equals(Object obj)
将此对象与指定对象比较。

boolean

PropertyPermission.equals(Object obj)
检查两个 PropertyPermission 对象是否相等。

boolean

GregorianCalendar.equals(Object obj)
比较此 GregorianCalendar 与指定的 Object。

boolean

Calendar.equals(Object obj)
将此 Calendar 与指定 Object 比较。

boolean

Date.equals(Object obj)
比较两个日期的相等性。

boolean

IdentityHashMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

Locale.equals(Object obj)
如果该 Locale 等于另一个对象，则返回 true。

boolean

BitSet.equals(Object obj)
将此对象与指定的对象进行比较。

boolean

AbstractSet.equals(Object o)
比较指定对象与此 set 的相等性。

boolean

Set.equals(Object o)
比较指定对象与此 set 的相等性。

boolean

AbstractMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

AbstractMap.SimpleEntry.equals(Object o)
比较指定对象与此项的相等性。

boolean

AbstractMap.SimpleImmutableEntry.equals(Object o)
比较指定对象与此项的相等性。

boolean

Comparator.equals(Object obj)
指示某个其他对象是否“等于”此 Comparator。

boolean

Vector.equals(Object o)
比较指定对象与此向量的相等性。

boolean

AbstractList.equals(Object o)
将指定的对象与此列表进行相等性比较。

boolean

List.equals(Object o)
比较指定的对象与列表是否相等。

boolean

Collection.equals(Object o)
比较此 collection 与指定对象是否相等。

boolean

Hashtable.equals(Object o)
按照 Map 接口的定义，比较指定 Object 与此 Map 是否相等。

boolean

Map.equals(Object o)
比较指定的对象与此映射是否相等。

boolean

Map.Entry.equals(Object o)
比较指定对象与此项的相等性。

static boolean

Arrays.equals(Object[] a, Object[] a2)
如果两个指定的 Objects 数组彼此相等，则返回 true。

static boolean

Arrays.equals(Object[] a, Object[] a2)
如果两个指定的 Objects 数组彼此相等，则返回 true。

static void

Arrays.fill(Object[] a, int fromIndex, int toIndex, Object val)
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。

static void

Arrays.fill(Object[] a, int fromIndex, int toIndex, Object val)
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。

static void

Arrays.fill(Object[] a, Object val)
将指定的 Object 引用分配给指定 Object 数组的每个元素。

static void

Arrays.fill(Object[] a, Object val)
将指定的 Object 引用分配给指定 Object 数组的每个元素。

Formatter

Formatter.format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。

Formatter

Formatter.format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。

static int

Collections.frequency(Collection<?> c, Object o)
返回指定 collection 中等于指定对象的元素数。

V

EnumMap.get(Object key)
返回指定键所映射的值，如果此映射不包含此键的映射关系，则返回 null。

V

IdentityHashMap.get(Object key)
返回指定键映射的值；如果映射不包含此键的任何映射关系，则返回 null。

V

TreeMap.get(Object key)
返回指定键所映射的值，如果对于该键而言，此映射不包含任何映射关系，则返回 null。

V

WeakHashMap.get(Object key)
返回指定键所映射的值，如果对于该键来说，此映射不包含任何映射关系，则返回 null。

V

LinkedHashMap.get(Object key)
返回此映射到指定键的值。

V

HashMap.get(Object key)
返回指定键所映射的值；如果对于该键来说，此映射不包含任何映射关系，则返回 null。

V

AbstractMap.get(Object key)
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。

V

Hashtable.get(Object key)
返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null. 更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。

abstract  V

Dictionary.get(Object key)
返回此 dictionary 中该键所映射到的值。

V

Map.get(Object key)
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。

static int

Arrays.hashCode(Object[] a)
基于指定数组的内容返回哈希码。

int

LinkedList.indexOf(Object o)
返回此列表中首次出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。

int

ArrayList.indexOf(Object o)
返回此列表中首次出现的指定元素的索引，或如果此列表不包含元素，则返回 -1。

int

Vector.indexOf(Object o)
返回此向量中第一次出现的指定元素的索引，如果此向量不包含该元素，则返回 -1。

int

AbstractList.indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。

int

List.indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。

int

Vector.indexOf(Object o, int index)
返回此向量中第一次出现的指定元素的索引，从 index 处正向搜索，如果未找到该元素，则返回 -1。

int

LinkedList.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。

int

ArrayList.lastIndexOf(Object o)
返回此列表中最后一次出现的指定元素的索引，或如果此列表不包含索引，则返回 -1。

int

Vector.lastIndexOf(Object o)
返回此向量中最后一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1。

int

AbstractList.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。

int

List.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。

int

Vector.lastIndexOf(Object o, int index)
返回此向量中最后一次出现的指定元素的索引，从 index 处逆向搜索，如果未找到该元素，则返回 -1。

void

Observable.notifyObservers(Object arg)
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。

boolean

ArrayDeque.remove(Object o)
从此双端队列中移除指定元素的单个实例。

V

EnumMap.remove(Object key)
从此映射中移除该键的映射关系（如果存在）。

boolean

PriorityQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。

boolean

TreeSet.remove(Object o)
将指定的元素从 set 中移除（如果该元素存在于此 set 中）。

V

IdentityHashMap.remove(Object key)
移除映射中此键的映射关系（如果存在的话）。

boolean

LinkedList.remove(Object o)
从此列表中移除首次出现的指定元素（如果存在）。

boolean

Deque.remove(Object o)
从此双端队列中移除第一次出现的指定元素。

V

TreeMap.remove(Object key)
如果此 TreeMap 中存在该键的映射关系，则将其删除。

V

WeakHashMap.remove(Object key)
从此弱哈希映射中移除键的映射关系（如果存在）。

boolean

HashSet.remove(Object o)
如果指定元素存在于此 set 中，则将其移除。

boolean

ArrayList.remove(Object o)
移除此列表中首次出现的指定元素（如果存在）。

boolean

Set.remove(Object o)
如果 set 中存在指定的元素，则将其移除（可选操作）。

V

HashMap.remove(Object key)
从此映射中移除指定键的映射关系（如果存在）。

V

AbstractMap.remove(Object key)
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。

boolean

Vector.remove(Object o)
移除此向量中指定元素的第一个匹配项，如果向量不包含该元素，则元素保持不变。

boolean

AbstractCollection.remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。

boolean

List.remove(Object o)
从此列表中移除第一次出现的指定元素（如果存在）（可选操作）。

boolean

Collection.remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。

V

Hashtable.remove(Object key)
从哈希表中移除该键及其相应的值。

abstract  V

Dictionary.remove(Object key)
从此 dictionary 中移除 key （及其相应的 value）。

V

Map.remove(Object key)
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。

boolean

Vector.removeElement(Object obj)
从此向量中移除变量的第一个（索引最小的）匹配项。

boolean

ArrayDeque.removeFirstOccurrence(Object o)
移除此双端队列中第一次出现的指定元素（当从头部到尾部遍历双端队列时）。

boolean

LinkedList.removeFirstOccurrence(Object o)
从此列表中移除第一次出现的指定元素（从头部到尾部遍历列表时）。

boolean

Deque.removeFirstOccurrence(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

ArrayDeque.removeLastOccurrence(Object o)
移除此双端队列中最后一次出现的指定元素（当从头部到尾部遍历双端队列时）。

boolean

LinkedList.removeLastOccurrence(Object o)
从此列表中移除最后一次出现的指定元素（从头部到尾部遍历列表时）。

boolean

Deque.removeLastOccurrence(Object o)
从此双端队列移除最后一次出现的指定元素。

int

Stack.search(Object o)
返回对象在堆栈中的位置，以 1 为基数。

static void

Arrays.sort(Object[] a)
根据元素的自然顺序对指定对象数组按升序进行排序。

static void

Arrays.sort(Object[] a, int fromIndex, int toIndex)
根据元素的自然顺序对指定对象数组的指定范围按升序进行排序。

static

<T> void

Arrays.sort(T[] a, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组进行排序。

static

<T> void

Arrays.sort(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。

<T> T[]

ArrayDeque.toArray(T[] a)
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedList.toArray(T[] a)
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。

<T> T[]

ArrayList.toArray(T[] a)
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Set.toArray(T[] a)
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

Vector.toArray(T[] a)
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。

<T> T[]

AbstractCollection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

<T> T[]

List.toArray(T[] a)
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

Collection.toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

static String

Arrays.toString(Object[] a)
返回指定数组内容的字符串表示形式。

void

Observer.update(Observable o, Object arg)
只要改变了 observable 对象就调用此方法。

参数类型为 Object 的 java.util 中的构造方法

EventObject(Object source)
构造一个原型 Event。

java.util.concurrent 中 Object 的使用

java.util.concurrent 中 Object 的子类

class

AbstractExecutorService
提供 ExecutorService 执行方法的默认实现。

class

ArrayBlockingQueue<E>
一个由数组支持的有界阻塞队列。

class

BrokenBarrierException
当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。

class

CancellationException
如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。

class

ConcurrentHashMap<K,V>
支持获取的完全并发和更新的所期望可调整并发的哈希表。

class

ConcurrentLinkedQueue<E>
一个基于链接节点的无界线程安全队列。

class

ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

class

ConcurrentSkipListSet<E>
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。

class

CopyOnWriteArrayList<E>
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

class

CopyOnWriteArraySet<E>
对其所有操作使用内部 CopyOnWriteArrayList 的 Set。

class

CountDownLatch
一个同步辅助类，在完成一组正在其他线程中执行的操作之前，它允许一个或多个线程一直等待。

class

CyclicBarrier
一个同步辅助类，它允许一组线程互相等待，直到到达某个公共屏障点 (common barrier point)。

class

DelayQueue<E extends Delayed>
Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。

class

Exchanger<V>
可以在对中对元素进行配对和交换的线程的同步点。

class

ExecutionException
当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。

class

ExecutorCompletionService<V>
使用提供的 Executor 来执行任务的 CompletionService。

class

Executors
此包中所定义的 Executor、ExecutorService、ScheduledExecutorService、ThreadFactory 和 Callable 类的工厂和实用方法。

class

FutureTask<V>
可取消的异步计算。

class

LinkedBlockingDeque<E>
一个基于已链接节点的、任选范围的阻塞双端队列。

class

LinkedBlockingQueue<E>
一个基于已链接节点的、范围任意的 blocking queue。

class

PriorityBlockingQueue<E>
一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。

class

RejectedExecutionException
当无法执行某个任务时,由 Executor 抛出的异常。

class

ScheduledThreadPoolExecutor
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。

class

Semaphore
一个计数信号量。

class

SynchronousQueue<E>
一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

class

ThreadPoolExecutor
一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

static class

ThreadPoolExecutor.AbortPolicy
用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.

static class

ThreadPoolExecutor.CallerRunsPolicy
用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。

static class

ThreadPoolExecutor.DiscardOldestPolicy
用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。

static class

ThreadPoolExecutor.DiscardPolicy
用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。

class

TimeoutException
阻塞操作超时时，抛出该异常。

返回 Object 的 java.util.concurrent 中的方法

Object

CopyOnWriteArrayList.clone()
返回此列表的浅表副本。

Object[]

ArrayBlockingQueue.toArray()
返回一个按适当顺序包含此队列中所有元素的数组。

Object[]

ConcurrentLinkedQueue.toArray()
返回以恰当顺序包含此队列所有元素的数组。

Object[]

CopyOnWriteArrayList.toArray()
返回一个按恰当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。

Object[]

CopyOnWriteArraySet.toArray()
返回一个包含此 set 所有元素的数组。

Object[]

DelayQueue.toArray()
返回包含此队列所有元素的数组。

Object[]

LinkedBlockingDeque.toArray()
返回以恰当顺序（从第一个元素到最后一个元素）包含此双端队列所有元素的数组。

Object[]

LinkedBlockingQueue.toArray()
返回按适当顺序包含此队列中所有元素的数组。

Object[]

PriorityBlockingQueue.toArray()
返回包含此队列所有元素的数组。

Object[]

SynchronousQueue.toArray()
返回一个 0 长度的数组。

<T> T[]

ArrayBlockingQueue.toArray(T[] a)
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

ConcurrentLinkedQueue.toArray(T[] a)
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArrayList.toArray(T[] a)
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArraySet.toArray(T[] a)
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

DelayQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedBlockingDeque.toArray(T[] a)
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedBlockingQueue.toArray(T[] a)
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityBlockingQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

SynchronousQueue.toArray(T[] a)
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。

返回变量类型为 Object 的类型的 java.util.concurrent 中的方法

static Callable<Object>

Executors.callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。

static Callable<Object>

Executors.callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。

static Callable<Object>

Executors.callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。

参数类型为 Object 的 java.util.concurrent 中的方法

boolean

ArrayBlockingQueue.contains(Object o)
如果此队列包含指定的元素，则返回 true。

boolean

BlockingDeque.contains(Object o)
如果此双端队列包含指定的元素，则返回 true。

boolean

BlockingQueue.contains(Object o)
如果此队列包含指定元素，则返回 true。

boolean

ConcurrentLinkedQueue.contains(Object o)
如果此队列包含指定元素，则返回 true。

boolean

ConcurrentSkipListSet.contains(Object o)
如果此 set 包含指定的元素，则返回 true。

boolean

CopyOnWriteArrayList.contains(Object o)
如果此列表包含指定的元素，则返回 true。

boolean

CopyOnWriteArraySet.contains(Object o)
如果此 set 包含指定元素，则返回 true。

boolean

LinkedBlockingDeque.contains(Object o)
如果此双端队列包含指定的元素，则返回 true。

boolean

PriorityBlockingQueue.contains(Object o)
如果队列包含指定的元素，则返回 true。

boolean

SynchronousQueue.contains(Object o)
始终返回 false。

boolean

ConcurrentHashMap.contains(Object value)
一种遗留方法，测试此表中是否有一些与指定值存在映射关系的键。

boolean

ConcurrentSkipListMap.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

ConcurrentHashMap.containsKey(Object key)
测试指定对象是否为此表中的键。

boolean

ConcurrentSkipListMap.containsValue(Object value)
如果此映射为指定值映射一个或多个键，则返回 true。

boolean

ConcurrentHashMap.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

boolean

ConcurrentSkipListMap.equals(Object o)
比较指定对象与此映射的相等性。

boolean

ConcurrentSkipListSet.equals(Object o)
比较指定对象与此 set 的相等性。

boolean

CopyOnWriteArrayList.equals(Object o)
比较指定对象与此列表的相等性。

boolean

CopyOnWriteArraySet.equals(Object o)
比较指定对象与此 set 的相等性。

V

ConcurrentSkipListMap.get(Object key)
返回指定键所映射到的值；如果此映射不包含该键的映射关系，则返回 null。

V

ConcurrentHashMap.get(Object key)
返回指定键所映射到的值，如果此映射不包含该键的映射关系，则返回 null。

int

CopyOnWriteArrayList.indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。

int

CopyOnWriteArrayList.lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。

boolean

ArrayBlockingQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。

boolean

BlockingDeque.remove(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

BlockingQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。

boolean

ConcurrentLinkedQueue.remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。

V

ConcurrentSkipListMap.remove(Object key)
从此映射中移除指定键的映射关系（如果存在）。

boolean

ConcurrentSkipListSet.remove(Object o)
如果此 set 中存在指定的元素，则将其移除。

boolean

CopyOnWriteArrayList.remove(Object o)
从此列表移除第一次出现的指定元素（如果存在）。

boolean

CopyOnWriteArraySet.remove(Object o)
如果指定元素存在于此 set 中，则将其移除。

boolean

DelayQueue.remove(Object o)
从此队列中移除指定元素的单个实例（如果存在），无论它是否到期。

boolean

LinkedBlockingDeque.remove(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

LinkedBlockingQueue.remove(Object o)
从此队列移除指定元素的单个实例（如果存在）。

boolean

PriorityBlockingQueue.remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。

boolean

SynchronousQueue.remove(Object o)
始终返回 false。

V

ConcurrentHashMap.remove(Object key)
从此映射中移除键（及其相应的值）。

boolean

ConcurrentSkipListMap.remove(Object key, Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。

boolean

ConcurrentHashMap.remove(Object key, Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。

boolean

ConcurrentMap.remove(Object key, Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。

boolean

BlockingDeque.removeFirstOccurrence(Object o)
从此双端队列移除第一次出现的指定元素。

boolean

LinkedBlockingDeque.removeFirstOccurrence(Object o)

boolean

BlockingDeque.removeLastOccurrence(Object o)
从此双端队列移除最后一次出现的指定元素。

boolean

LinkedBlockingDeque.removeLastOccurrence(Object o)

void

TimeUnit.timedWait(Object obj, long timeout)
使用此时间单元执行计时的 Object.wait。

<T> T[]

ArrayBlockingQueue.toArray(T[] a)
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

ConcurrentLinkedQueue.toArray(T[] a)
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArrayList.toArray(T[] a)
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

CopyOnWriteArraySet.toArray(T[] a)
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

DelayQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

LinkedBlockingDeque.toArray(T[] a)
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

LinkedBlockingQueue.toArray(T[] a)
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

<T> T[]

PriorityBlockingQueue.toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。

<T> T[]

SynchronousQueue.toArray(T[] a)
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。

参数类型为 Object 的 java.util.concurrent 中的构造方法

CopyOnWriteArrayList(E[] toCopyIn)
创建一个保存给定数组的副本的列表。

java.util.concurrent.atomic 中 Object 的使用

java.util.concurrent.atomic 中 Object 的子类

class

AtomicBoolean
可以用原子方式更新的 boolean 值。

class

AtomicInteger
可以用原子方式更新的 int 值。

class

AtomicIntegerArray
可以用原子方式更新其元素的 int 数组。

class

AtomicIntegerFieldUpdater<T>
基于反射的实用工具，可以对指定类的指定 volatile int 字段进行原子更新。

class

AtomicLong
可以用原子方式更新的 long 值。

class

AtomicLongArray
可以用原子方式更新其元素的 long 数组。

class

AtomicLongFieldUpdater<T>
基于反射的实用工具，可以对指定类的指定 volatile long 字段进行原子更新。

class

AtomicMarkableReference<V>
AtomicMarkableReference 维护带有标记位的对象引用，可以原子方式对其进行更新。

class

AtomicReference<V>
可以用原子方式更新的对象引用。

class

AtomicReferenceArray<E>
可以用原子方式更新其元素的对象引用数组。

class

AtomicReferenceFieldUpdater<T,V>
基于反射的实用工具，可以对指定类的指定 volatile 字段进行原子更新。

class

AtomicStampedReference<V>
AtomicStampedReference 维护带有整数“标志”的对象引用，可以用原子方式对其进行更新。

参数类型为 Object 的 java.util.concurrent.atomic 中的构造方法

AtomicReferenceArray(E[] array)
创建与给定数组具有相同长度的新 AtomicReferenceArray，并从给定数组复制其所有元素。

java.util.concurrent.locks 中 Object 的使用

java.util.concurrent.locks 中 Object 的子类

class

AbstractOwnableSynchronizer
可以由线程以独占方式拥有的同步器。

class

AbstractQueuedLongSynchronizer
以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。

class

AbstractQueuedLongSynchronizer.ConditionObject
作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。

class

AbstractQueuedSynchronizer
为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。

class

AbstractQueuedSynchronizer.ConditionObject
AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。

class

LockSupport
用来创建锁和其他同步类的基本线程阻塞原语。

class

ReentrantLock
一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。

class

ReentrantReadWriteLock
支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。

static class

ReentrantReadWriteLock.ReadLock
ReentrantReadWriteLock.readLock() 方法返回的锁。

static class

ReentrantReadWriteLock.WriteLock
ReentrantReadWriteLock.writeLock() 方法返回的锁。

返回 Object 的 java.util.concurrent.locks 中的方法

static Object

LockSupport.getBlocker(Thread t)
返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。

参数类型为 Object 的 java.util.concurrent.locks 中的方法

static void

LockSupport.park(Object blocker)
为了线程调度，在许可可用之前禁用当前线程。

static void

LockSupport.parkNanos(Object blocker, long nanos)
为了线程调度，在许可可用前禁用当前线程，并最多等待指定的等待时间。

static void

LockSupport.parkUntil(Object blocker, long deadline)
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。

java.util.jar 中 Object 的使用

java.util.jar 中 Object 的子类

class

Attributes
Attributes 类将 Manifest 属性名称映射到关联的字符串值。

static class

Attributes.Name
Attributes.Name 类表示存储在此 Map 中的一个属性名称。

class

JarEntry
此类用于表示 JAR 文件条目。

class

JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

class

JarFile
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。

class

JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

class

JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

class

Manifest
Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。

class

Pack200
以 Pack200 格式在 JAR 文件和打包的流之间进行转换。

类型参数类型为 Object 的 java.util.jar 中的字段

protected  Map<Object,Object>

Attributes.map
属性名称-值映射关系。

protected  Map<Object,Object>

Attributes.map
属性名称-值映射关系。

返回 Object 的 java.util.jar 中的方法

Object

Attributes.clone()
返回 Attributes 的副本，实现方法如下: public Object clone() { return new Attributes(this); } 由于属性名称和值本身不可变，因此可以安全地修改返回的 Attributes，而不会影响原始值。

Object

Manifest.clone()
返回 Manifest 的浅表副本。

Object

Attributes.get(Object name)
返回指定的属性名称的值，如果未找到属性名称，则返回 null。

Object

Attributes.put(Object name, Object value)
在此 Map 中将指定的值关联到指定的属性名称（键）。

Object

Attributes.remove(Object name)
从此 Map 中移除具有指定名称（键）的属性。

返回变量类型为 Object 的类型的 java.util.jar 中的方法

Set<Map.Entry<Object,Object>>

Attributes.entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。

Set<Map.Entry<Object,Object>>

Attributes.entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。

Set<Object>

Attributes.keySet()
返回此 Map 所包含的属性名称（键）的 Set 视图。

Collection<Object>

Attributes.values()
返回此 Map 所包含的属性值的 Collection 视图。

参数类型为 Object 的 java.util.jar 中的方法

boolean

Attributes.containsKey(Object name)
如果此 Map 包含指定的属性名称（键），则返回 true。

boolean

Attributes.containsValue(Object value)
如果此 Map 将一个或多个属性名称（键）映射到指定值，则返回 true。

boolean

Attributes.equals(Object o)
将指定的 Attributes 对象与此 Map 进行相等性比较。

boolean

Attributes.Name.equals(Object o)
将此属性名称与另一个属性名称进行相等性比较。

boolean

Manifest.equals(Object o)
如果指定的 Object 也是一个 Manifest，并且具有相同的主 Attributes 和条目，则返回 true。

Object

Attributes.get(Object name)
返回指定的属性名称的值，如果未找到属性名称，则返回 null。

Object

Attributes.put(Object name, Object value)
在此 Map 中将指定的值关联到指定的属性名称（键）。

Object

Attributes.remove(Object name)
从此 Map 中移除具有指定名称（键）的属性。

java.util.logging 中 Object 的使用

java.util.logging 中 Object 的子类

class

ConsoleHandler
此 Handler 向 System.err 发布日志记录。

class

ErrorManager
可将 ErrorManager 对象附加到 Handler，以便处理日志记录过程中 Handler 上所发生的错误。

class

FileHandler
简单的文件日志记录 Handler。

class

Handler
Handler 对象从 Logger 中获取日志信息，并将这些信息导出。

class

Level
Level 类定义了一组可用来控制日志输出的标准日志级别。

class

Logger
Logger 对象用来记录特定系统或应用程序组件的日志消息。

class

LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

class

LogManager
存在一个单一的全局 LogManager 对象，它可用于维护 Logger 和日志服务的一组共享状态。

class

LogRecord
LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。

class

MemoryHandler
Handler 在内存中的循环缓冲区中对请求进行缓冲处理。

class

SimpleFormatter
以可读格式输出 LogRecord 的简单摘要。

class

SocketHandler
简单的网络日志 Handler。

class

StreamHandler
基于流的日志 Handler。

class

XMLFormatter
将 LogRecord 格式化为标准 XML 格式。

返回 Object 的 java.util.logging 中的方法

Object[]

LogRecord.getParameters()
获取日志消息的参数。

参数类型为 Object 的 java.util.logging 中的方法

void

Logger.entering(String sourceClass, String sourceMethod, Object param1)
记录一个方法条目，带有一个参数。

void

Logger.entering(String sourceClass, String sourceMethod, Object[] params)
记录一个方法条目，带有一组参数。

boolean

Level.equals(Object ox)
比较两个对象值的相等性。

void

Logger.exiting(String sourceClass, String sourceMethod, Object result)
记录一个方法返回，带有结果对象。

void

Logger.log(Level level, String msg, Object param1)
记录带有一个对象参数的消息。

void

Logger.log(Level level, String msg, Object[] params)
记录带有一组对象参数的消息。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object param1)
记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。

void

Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object[] params)
记录一条消息，具有指定的源类和方法，带有一组对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1)
记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。

void

Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params)
记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。

void

LogRecord.setParameters(Object[] parameters)
设置日志消息的参数。

java.util.prefs 中 Object 的使用

java.util.prefs 中 Object 的子类

class

AbstractPreferences
此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。

class

BackingStoreException
抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。

class

InvalidPreferencesFormatException
抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

class

NodeChangeEvent
Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。

class

PreferenceChangeEvent
Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。

class

Preferences
首选项数据的层次结构 collection 中的节点。

声明为 Object 的 java.util.prefs 中的字段

protected  Object

AbstractPreferences.lock
使用其监视器锁定此节点的对象。

java.util.regex 中 Object 的使用

java.util.regex 中 Object 的子类

class

Matcher
通过解释 Pattern 对 character sequence 执行匹配操作的引擎。

class

Pattern
正则表达式的编译表示形式。

class

PatternSyntaxException
抛出未经检查的异常，表明正则表达式模式中的语法错误。

java.util.spi 中 Object 的使用

java.util.spi 中 Object 的子类

class

CurrencyNameProvider
为 Currency 类提供本地化货币符号的服务提供者的抽象类。

class

LocaleNameProvider
为 Locale 类提供本地化名称的服务提供者的一个抽象类。

class

LocaleServiceProvider
此类是所有与语言环境有关的服务提供者接口（SPI）的超类。

class

TimeZoneNameProvider
为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。

java.util.zip 中 Object 的使用

java.util.zip 中 Object 的子类

class

Adler32
可用于计算数据流的 Adler-32 校验和的类。

class

CheckedInputStream
需要维护所读取数据校验和的输入流。

class

CheckedOutputStream
需要维护写入数据校验和的输出流。

class

CRC32
可用于计算数据流的 CRC-32 的类。

class

DataFormatException
当数据格式发生错误时，抛出此异常。

class

Deflater
此类使用流行的 ZLIB 压缩程序库为通用压缩提供支持。

class

DeflaterInputStream
为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。

class

DeflaterOutputStream
此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。

class

GZIPInputStream
此类为读取 GZIP 文件格式的压缩数据实现流过滤器。

class

GZIPOutputStream
此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。

class

Inflater
此类使用流行的 ZLIB 压缩程序库为通用解压缩提供支持。

class

InflaterInputStream
此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。

class

InflaterOutputStream
为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。

class

ZipEntry
此类用于表示 ZIP 文件条目。

class

ZipError
发生不可恢复的错误时抛出。

class

ZipException
如果某种 ZIP 异常发生，则抛出此错误。

class

ZipFile
此类用于从 ZIP 文件读取条目。

class

ZipInputStream
此类为读取 ZIP 文件格式的文件实现输入流过滤器。

class

ZipOutputStream
此类为以 ZIP 文件格式写入文件实现输出流过滤器。

返回 Object 的 java.util.zip 中的方法

Object

ZipEntry.clone()
返回此条目的副本。

javax.accessibility 中 Object 的使用

javax.accessibility 中 Object 的子类

class

AccessibleAttributeSequence
此类汇集共享相同连续属性集的文本的跨度，以及该属性集。

class

AccessibleBundle
用于维护强类型枚举的基类。

class

AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。

class

AccessibleHyperlink
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。

class

AccessibleRelation
AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。

class

AccessibleRelationSet
AccessibleRelationSet 类确定了组件的关系集。

class

AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

class

AccessibleRole
AccessibleRole 类确定组件的职责。

class

AccessibleState
AccessibleState 类描述了组件的特殊状态。

class

AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。

class

AccessibleTextSequence
此类汇集文本区域的关键细节。

返回 Object 的 javax.accessibility 中的方法

abstract  Object

AccessibleHyperlink.getAccessibleActionAnchor(int i)
返回表示适合于该链接的链接锚点的对象。

abstract  Object

AccessibleHyperlink.getAccessibleActionObject(int i)
返回表示适合于该链接的链接动作的对象。

Object

AccessibleKeyBinding.getAccessibleKeyBinding(int i)
返回此对象的键绑定。

Object[][]

AccessibleResourceBundle.getContents()
已过时。 返回编程键和本地化显示字符串之间的映射关系。

Object[]

AccessibleRelation.getTarget()
返回此关系的目标对象

参数类型为 Object 的 javax.accessibility 中的方法

void

AccessibleContext.firePropertyChange(String propertyName, Object oldValue, Object newValue)
对报告 bound 属性更改的支持。

void

AccessibleRelation.setTarget(Object target)
设置此关系的目标对象

void

AccessibleRelation.setTarget(Object[] target)
设置此关系的目标对象

参数类型为 Object 的 javax.accessibility 中的构造方法

AccessibleRelation(String key, Object target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

AccessibleRelation(String key, Object[] target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。

javax.activation 中 Object 的使用

javax.activation 中 Object 的子类

class

ActivationDataFlavor
ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。

class

CommandInfo
CommandMap 实现使用 CommandInfo 类描述命令请求的结果。

class

CommandMap
CommandMap 类为系统中可用的命令对象注册表提供接口。

class

DataHandler
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。

class

FileDataSource
FileDataSource 类实现一个封装文件的简单 DataSource 对象。

class

FileTypeMap
FileTypeMap 是一个抽象类，它为文件提供数据分类接口。

class

MailcapCommandMap
MailcapCommandMap 扩展 CommandMap 抽象类。

class

MimeType
RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。

class

MimeTypeParameterList
RFC 2045 和 2046 中定义的 MimeType 参数列表。

class

MimetypesFileTypeMap
此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。

class

UnsupportedDataTypeException
当请求操作不支持请求的数据类型时，抛出此异常。

class

URLDataSource
URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。

返回 Object 的 javax.activation 中的方法

Object

DataHandler.getBean(CommandInfo cmdinfo)
一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。

Object

CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader)
返回已实例化的 JavaBean 组件。

Object

DataHandler.getContent()
以其首选 Object 的形式返回数据。

Object

DataContentHandler.getContent(DataSource ds)
返回一个对象，该对象表示其首选形式的数据。

Object

DataHandler.getTransferData(DataFlavor flavor)
返回一个对象，该对象表示要传输的数据。

Object

DataContentHandler.getTransferData(DataFlavor df, DataSource ds)
返回一个对象，该对象表示将要传输的数据。

参数类型为 Object 的 javax.activation 中的方法

void

DataContentHandler.writeTo(Object obj, String mimeType, OutputStream os)
将对象转换为指定 MIME 类型的字节流，并将其写入输出流。

参数类型为 Object 的 javax.activation 中的构造方法

DataHandler(Object obj, String mimeType)
创建表示此 MIME 类型对象的 DataHandler 实例。

javax.activity 中 Object 的使用

javax.activity 中 Object 的子类

class

ActivityCompletedException
任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。

class

ActivityRequiredException
如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。

class

InvalidActivityException
任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.annotation.processing 中 Object 的使用

javax.annotation.processing 中 Object 的子类

class

AbstractProcessor
旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。

class

Completions
用来组合 Completion 对象的实用工具类。

class

FilerException
指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

javax.crypto 中 Object 的使用

javax.crypto 中 Object 的子类

class

BadPaddingException
当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。

class

Cipher
此类为加密和解密提供密码功能。

class

CipherInputStream
CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。

class

CipherOutputStream
CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。

class

CipherSpi
此类为 Cipher 类定义了服务提供者接口 (SPI)。

class

EncryptedPrivateKeyInfo
此类实现 EncryptedPrivateKeyInfo 类型，如在 PKCS #8 中定义的那样。

class

ExemptionMechanism
此类提供了豁免 (exemption) 机制的功能，例如，密钥恢复、密钥唤醒 和密钥托管。

class

ExemptionMechanismException
此为一般 ExemptionMechanism 异常。

class

ExemptionMechanismSpi
此类为 ExemptionMechanism 类定义了服务提供者接口 (SPI)。

class

IllegalBlockSizeException
如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。

class

KeyAgreement
此类提供密钥协定（或密钥交换）协议的功能。

class

KeyAgreementSpi
此类为 KeyAgreement 类定义了服务提供者接口 (SPI)。

class

KeyGenerator
此类提供（对称）密钥生成器的功能。

class

KeyGeneratorSpi
此类为 KeyGenerator 类定义了服务提供者接口 (SPI)。

class

Mac
此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。

class

MacSpi
此类为 Mac 类定义服务提供者接口 (SPI)。

class

NoSuchPaddingException
当请求特定填充机制但该环境中未提供时，抛出此异常。

class

NullCipher
NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。

class

SealedObject
此类使程序员能够用加密算法创建对象并保护其机密性。

class

SecretKeyFactory
此类表示秘密密钥的工厂。

class

SecretKeyFactorySpi
此类定义 SecretKeyFactory 类的服务提供者接口 (SPI)。

class

ShortBufferException
当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

返回 Object 的 javax.crypto 中的方法

Object

Mac.clone()
如果提供者实现可以复制，则返回一个副本。

Object

MacSpi.clone()
如果此实现可以复制，则返回一个副本。

Object

SealedObject.getObject(Cipher c)
获取原始（封装的）对象。

Object

SealedObject.getObject(Key key)
获取原始（封装的）对象。

Object

SealedObject.getObject(Key key, String provider)
获取原始（封装的）对象。

javax.crypto.spec 中 Object 的使用

javax.crypto.spec 中 Object 的子类

class

DESedeKeySpec
此类指定一个 DES-EDE ("triple-DES") 密钥。

class

DESKeySpec
此类指定一个 DES 密钥。

class

DHGenParameterSpec
此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。

class

DHParameterSpec
此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。

class

DHPrivateKeySpec
此类使用其关联的参数指定一个 Diffie-Hellman 私钥。

class

DHPublicKeySpec
此类使用关联的参数指定一个 Diffie-Hellman 公钥。

class

IvParameterSpec
此类指定一个初始化向量 (IV)。

class

OAEPParameterSpec
此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。

class

PBEKeySpec
可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。

class

PBEParameterSpec
此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。

class

PSource
此类为在 OAEP 冗余中的编码输入 P 指定源，OAEP 冗余在 PKCS #1 标准中定义。

static class

PSource.PSpecified
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。

class

RC2ParameterSpec
此类指定随同 RC2 算法使用的参数。

class

RC5ParameterSpec
此类指定随同 RC5 算法使用的参数。

class

SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

参数类型为 Object 的 javax.crypto.spec 中的方法

boolean

RC2ParameterSpec.equals(Object obj)
测试给定对象与此对象的相等性。

boolean

RC5ParameterSpec.equals(Object obj)
测试给定对象与此对象的相等性。

boolean

SecretKeySpec.equals(Object obj)
测试给定对象与此对象的相等性。

javax.imageio 中 Object 的使用

javax.imageio 中 Object 的子类

class

IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。

class

IIOImage
一个聚集图像、缩略（预览）图像集和表示与图像关联的元数据的对象的简单容器类。

class

IIOParam
所有描述应该如何对流进行编码和解码的类的超类。

class

ImageIO
该类包含一些用来查找 ImageReader 和 ImageWriter 以及执行简单编码和解码的静态便捷方法。

class

ImageReader
用来解析和解码图像的抽象超类。

class

ImageReadParam
描述如何对流进行解码的类。

class

ImageTypeSpecifier
允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。

class

ImageWriteParam
描述如何对流进行编码的类。

class

ImageWriter
用来编码和写入图像的抽象超类。

声明为 Object 的 javax.imageio 中的字段

protected  Object

ImageReader.input
由 setInput 设置并由 getInput 获取的 ImageInputStream 或其他 Object。

protected  Object

ImageWriter.output
由 setOutput 设置并由 getOutput 获取的 ImageOutputStream 或其他 Object。

返回 Object 的 javax.imageio 中的方法

Object

ImageReader.getInput()
返回以前设置为输入源的 ImageInputStream 或其他 Object。

Object

ImageWriter.getOutput()
返回 ImageOutputStream 或最近一次调用 setOutput 方法设置的其他 Object如果没有设置目标，则返回 null。

参数类型为 Object 的 javax.imageio 中的方法

static ImageInputStream

ImageIO.createImageInputStream(Object input)
返回一个 ImageInputStream，它将从给定 Object 中获取输入。

static ImageOutputStream

ImageIO.createImageOutputStream(Object output)
返回一个 ImageOutputStream，它将其输出发送到给定 Object。

boolean

ImageTypeSpecifier.equals(Object o)
如果给定 Object 是一个 ImageTypeSpecifier 并且具有与此对象相同的 SampleModel 和 ColorModel，则返回 true。

static Iterator<ImageReader>

ImageIO.getImageReaders(Object input)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。

void

ImageReader.setInput(Object input)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。

void

ImageReader.setInput(Object input, boolean seekForwardOnly)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。

void

ImageReader.setInput(Object input, boolean seekForwardOnly, boolean ignoreMetadata)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。

void

ImageWriter.setOutput(Object output)
将目标设置为给定 ImageOutputStream 或其他 Object。

javax.imageio.metadata 中 Object 的使用

javax.imageio.metadata 中 Object 的子类

class

IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

class

IIOMetadata
将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。

class

IIOMetadataFormatImpl
提供 IIOMetadataFormat 接口的可重用实现的具体类。

class

IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

类型参数类型为 Object 的 javax.imageio.metadata 中的方法

protected

<T extends Object & Comparable<? super T>>
void

IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

返回 Object 的 javax.imageio.metadata 中的方法

Object

IIOMetadataNode.getFeature(String feature, String version)

Object

IIOMetadataFormat.getObjectDefaultValue(String elementName)
返回包含指定元素中 Object 引用的默认值的 Object。

Object

IIOMetadataFormatImpl.getObjectDefaultValue(String elementName)

Object[]

IIOMetadataFormat.getObjectEnumerations(String elementName)
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。

Object[]

IIOMetadataFormatImpl.getObjectEnumerations(String elementName)

Object

IIOMetadataNode.getUserData(String key)

Object

IIOMetadataNode.getUserObject()
返回与此节点关联的 Object 值。

Object

IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

参数类型为 Object 的 javax.imageio.metadata 中的方法

Object

IIOMetadataNode.setUserData(String key, Object data, UserDataHandler handler)

void

IIOMetadataNode.setUserObject(Object userObject)
设置与此节点关联的值。

javax.imageio.plugins.bmp 中 Object 的使用

javax.imageio.plugins.bmp 中 Object 的子类

class

BMPImageWriteParam
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

javax.imageio.plugins.jpeg 中 Object 的使用

javax.imageio.plugins.jpeg 中 Object 的子类

class

JPEGHuffmanTable
封装单个 JPEG Huffman 表的类。

class

JPEGImageReadParam
此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。

class

JPEGImageWriteParam
此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。

class

JPEGQTable
封装单个 JPEG 量化表的类。

javax.imageio.spi 中 Object 的使用

javax.imageio.spi 中 Object 的子类

class

IIORegistry
用于服务提供者实例的注册表。

class

IIOServiceProvider
一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。

class

ImageInputStreamSpi
用于 ImageInputStream 的服务提供者接口 (SPI)。

class

ImageOutputStreamSpi
用于 ImageOutputStream 的服务提供者接口 (SPI)。

class

ImageReaderSpi
用于 ImageReader 的服务提供者接口 (SPI)。

class

ImageReaderWriterSpi
包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。

class

ImageTranscoderSpi
用于 ImageTranscoder 的服务提供者接口 (SPI)。

class

ImageWriterSpi
用于 ImageWriter 的服务提供者接口 (SPI)。

class

ServiceRegistry
用于服务提供者实例的注册表。

参数类型为 Object 的 javax.imageio.spi 中的方法

abstract  boolean

ImageReaderSpi.canDecodeInput(Object source)
如果给定的源对象看起来是此 reader 支持的格式，则返回 true。

boolean

ServiceRegistry.contains(Object provider)
如果当前注册了 provider，则返回 true。

ImageInputStream

ImageInputStreamSpi.createInputStreamInstance(Object input)
返回与此服务提供者关联的 ImageInputStream 实现的实例。

abstract  ImageInputStream

ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir)
返回与此服务提供者关联的 ImageInputStream 实现的实例。

ImageOutputStream

ImageOutputStreamSpi.createOutputStreamInstance(Object output)
返回与此服务提供者关联的 ImageOutputStream 实现的实例。

abstract  ImageOutputStream

ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir)
返回与此服务提供者关联的 ImageOutputStream 实现的实例。

abstract  ImageReader

ImageReaderSpi.createReaderInstance(Object extension)
返回与此服务提供者关联的 ImageReader 实现的实例。

abstract  ImageWriter

ImageWriterSpi.createWriterInstance(Object extension)
返回与此服务提供者关联的 ImageWriter 实现的实例。

void

ServiceRegistry.deregisterServiceProvider(Object provider)
从包含它的所有类别中移除服务提供者对象。

boolean

ServiceRegistry.Filter.filter(Object provider)
如果给定的 provider 对象与由此 Filter 定义的条件匹配，则返回 true。

void

ServiceRegistry.registerServiceProvider(Object provider)
将一个服务提供者对象添加到注册表。

javax.imageio.stream 中 Object 的使用

javax.imageio.stream 中 Object 的子类

class

FileCacheImageInputStream
从常规 InputStream 获取其输入的 ImageInputStream 的实现。

class

FileCacheImageOutputStream
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

class

FileImageInputStream
从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。

class

FileImageOutputStream
将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。

class

IIOByteBuffer
表示对某个字节数组及该数组中偏移量和长度的可变引用的类。

class

ImageInputStreamImpl
实现 ImageInputStream 接口的抽象类。

class

ImageOutputStreamImpl
实现 ImageOutputStream 接口的抽象类。

class

MemoryCacheImageInputStream
从常规 InputStream 获取输入的 ImageInputStream 的实现。

class

MemoryCacheImageOutputStream
将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

javax.lang.model.element 中 Object 的使用

javax.lang.model.element 中 Object 的子类

class

UnknownAnnotationValueException
指示遇到一个未知种类的注释值。

class

UnknownElementException
指示遇到一个未知种类的元素。

返回 Object 的 javax.lang.model.element 中的方法

Object

UnknownAnnotationValueException.getArgument()
返回附加参数。

Object

UnknownElementException.getArgument()
返回附加参数。

Object

VariableElement.getConstantValue()
如果此变量是一个被初始化为编译时常量的 static final 字段，则返回此变量的值。

Object

AnnotationValue.getValue()
返回值。

参数类型为 Object 的 javax.lang.model.element 中的方法

boolean

Name.equals(Object obj)
如果参数表示与 this 相同的名称，则返回 true，否则返回 false。

boolean

Element.equals(Object obj)
如果参数表示与此元素相同的元素，则返回 true；否则返回 false。

参数类型为 Object 的 javax.lang.model.element 中的构造方法

UnknownAnnotationValueException(AnnotationValue av, Object p)
创建一个新的 UnknownAnnotationValueException。

UnknownElementException(Element e, Object p)
创建一个新的 UnknownElementException。

javax.lang.model.type 中 Object 的使用

javax.lang.model.type 中 Object 的子类

class

MirroredTypeException
当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。

class

MirroredTypesException
当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。

class

UnknownTypeException
指示遇到未知种类的类型。

返回 Object 的 javax.lang.model.type 中的方法

Object

UnknownTypeException.getArgument()
返回附加参数。

参数类型为 Object 的 javax.lang.model.type 中的方法

boolean

TypeMirror.equals(Object obj)
遵守 Object.equals 的常规协定。

参数类型为 Object 的 javax.lang.model.type 中的构造方法

UnknownTypeException(TypeMirror t, Object p)
创建一个新的 UnknownTypeException。

javax.lang.model.util 中 Object 的使用

javax.lang.model.util 中 Object 的子类

class

AbstractAnnotationValueVisitor6<R,P>
注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

AbstractElementVisitor6<R,P>
程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

AbstractTypeVisitor6<R,P>
类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。

class

ElementFilter
用来从元素集合中只选择所需元素的过滤器。

class

ElementKindVisitor6<R,P>
基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

ElementScanner6<R,P>
程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

SimpleAnnotationValueVisitor6<R,P>
注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

SimpleElementVisitor6<R,P>
程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

SimpleTypeVisitor6<R,P>
类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

class

TypeKindVisitor6<R,P>
基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

声明为 Object 的 javax.lang.model.util 中的字段

protected  R

ElementScanner6.DEFAULT_VALUE
指定的默认值。

protected  R

SimpleAnnotationValueVisitor6.DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

protected  R

SimpleElementVisitor6.DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

protected  R

SimpleTypeVisitor6.DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

参数类型为 Object 的 javax.lang.model.util 中的方法

protected  R

SimpleAnnotationValueVisitor6.defaultAction(Object o, P p)
visit 方法的默认动作。

String

Elements.getConstantExpression(Object value)
返回表示基本值或字符串的常量表达式 文本。

javax.management 中 Object 的使用

javax.management 中 Object 的子类

class

Attribute
通过将 MBean 属性名与其值相关联来表示 MBean 属性。

class

AttributeChangeNotification
提供 MBean 所发送的属性更改通知的定义。

class

AttributeChangeNotificationFilter
此类实现 attribute change notification 的 NotificationFilter 接口。

class

AttributeNotFoundException
指定的属性不存在或无法检索。

class

AttributeValueExp
表示用作关系约束参数的属性。

class

BadAttributeValueExpException
向构造的查询方法传递无效的 MBean 属性时，抛出此异常。

class

BadBinaryOpValueExpException
向构造查询的方法传递无效的表达式时，抛出此异常。

class

BadStringOperationException
向构造查询的方法传递无效的字符串操作时，抛出此异常。

class

DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。

class

ImmutableDescriptor
不可变的描述符。

class

InstanceAlreadyExistsException
已经在存储库中注册了 MBean。

class

InstanceNotFoundException
存储库中不存在指定的 MBean。

class

InvalidApplicationException
试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。

class

InvalidAttributeValueException
指定的值对该属性无效。

class

JMException
由 JMX 实现所抛出的异常。

class

JMRuntimeException
由 JMX 实现所发出的运行时异常。

class

JMX
JMX API 提供的静态方法。

class

ListenerNotFoundException
存储库中不存在指定的 MBean 侦听器。

class

MalformedObjectNameException
字符串的格式不对应于有效的 ObjectName。

class

MBeanAttributeInfo
描述出于管理目的而公开的 MBean 属性。

class

MBeanConstructorInfo
描述 MBean 所公开的构造方法。

class

MBeanException
表示由代理的 MBean 方法所抛出的“用户定义的”异常。

class

MBeanFeatureInfo
提供 MBean 描述符对象的常规信息。

class

MBeanInfo
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。

class

MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。

class

MBeanOperationInfo
描述由 MBean 公开的管理操作。

class

MBeanParameterInfo
描述由 MBean 公开的操作的参数。

class

MBeanPermission
权限控制对 MBeanServer 操作的访问。

class

MBeanRegistrationException
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。

class

MBeanServerBuilder
此类表示创建默认 MBeanServer 实现的生成器。

class

MBeanServerDelegate
从管理的角度表示 MBean 服务器。

class

MBeanServerFactory
提供 MBean 服务器引用。

class

MBeanServerInvocationHandler
通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。

class

MBeanServerNotification
表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。

class

MBeanServerPermission
执行与 MBeanServer 关联的操作的 Permission。

class

MBeanTrustPermission
此权限表示“信任”签名者或代码基。

class

NotCompliantMBeanException
尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。

class

Notification
Notification 类表示 MBean 所发出的通知。

class

NotificationBroadcasterSupport
提供 NotificationEmitter 接口的实现。

class

NotificationFilterSupport
提供 NotificationFilter 接口的实现。

class

ObjectInstance
用于表示 MBean 对象名及其类名。

class

ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

class

OperationsException
表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。

class

Query
构造查询对象约束。

class

QueryEval
允许在特定的 MBean 服务器上下文中执行查询。

class

ReflectionException
表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。

class

RuntimeErrorException
当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。

class

RuntimeMBeanException
表示由代理中的 MBean 方法抛出的运行时异常。

class

RuntimeOperationsException
表示在 MBean 上执行操作时代理中抛出的运行时异常。

class

ServiceNotFoundException
表示请求的服务不受支持时引发的异常。

class

StandardEmitterMBean
一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

class

StandardMBean
一个管理接口由 Java 接口上的反射确定的 MBean。

class

StringValueExp
表示作为关系约束变量的字符串。

声明为 Object 的 javax.management 中的字段

protected  Object

Notification.source
此域隐藏了父类中的 EventObject.source 域，使其成为非 transient 的，并因此成为序列化形式的一部分。

返回 Object 的 javax.management 中的方法

Object

Descriptor.clone()
返回一个与此描述符相等的描述符。

Object

MBeanAttributeInfo.clone()
返回此实例的浅表副本。

Object

MBeanConstructorInfo.clone()
返回此实例的浅表副本。

Object

MBeanInfo.clone()
返回此实例的浅表副本。

Object

MBeanNotificationInfo.clone()
返回此实例的浅表副本。

Object

MBeanOperationInfo.clone()
返回此实例的浅表副本。

Object

MBeanParameterInfo.clone()
返回此实例的浅表副本。

protected  Object

AttributeValueExp.getAttribute(ObjectName name)
返回指定的 MBean 中给定属性的值。

Object

MBeanServer.getAttribute(ObjectName name, String attribute)

Object

MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。

Object

DynamicMBean.getAttribute(String attribute)
获得 Dynamic MBean 的特定属性的值。

Object

StandardMBean.getAttribute(String attribute)

Object

Descriptor.getFieldValue(String fieldName)
返回指定字段名的值，如果该名称不存在任何值，则返回 null。

Object

ImmutableDescriptor.getFieldValue(String fieldName)

Object[]

Descriptor.getFieldValues(String... fieldNames)
以 Object 数组的形式返回该 descriptor 中的所有字段值。

Object[]

ImmutableDescriptor.getFieldValues(String... fieldNames)

Object

StandardMBean.getImplementation()
获取此 Standard MBean（或 MXBean）的实现。

Object

AttributeChangeNotification.getNewValue()
获得已更改属性的新值。

Object

AttributeChangeNotification.getOldValue()
获得已更改属性的旧值。

Object

Notification.getUserData()
获得用户数据。

Object

Attribute.getValue()
返回此 Attribute 值的 Object。

Object

MBeanServer.instantiate(String className)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

Object

AttributeList.set(int index, Object element)

参数类型为 Object 的 javax.management 中的方法

void

AttributeList.add(int index, Object element)

boolean

AttributeList.add(Object o)

void

MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
在此 MBean 中添加一个侦听器。

void

NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
添加一个侦听器。

void

StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。

void

MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

ObjectInstance

MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)

ObjectInstance

MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。

boolean

Attribute.equals(Object object)
比较当前的 Attribute Object 与另一个 Attribute Object。

boolean

Descriptor.equals(Object obj)
将此描述符与给定对象比较。

boolean

ImmutableDescriptor.equals(Object o)
将此描述符与给定对象进行比较。

boolean

MBeanAttributeInfo.equals(Object o)
比较此 MBeanAttributeInfo 与另一个 MBeanAttributeInfo。

boolean

MBeanConstructorInfo.equals(Object o)
比较此 MBeanConstructorInfo 与另一个 MBeanConstructorInfo。

boolean

MBeanFeatureInfo.equals(Object o)
比较此 MBeanFeatureInfo 与另一个 MBeanFeatureInfo。

boolean

MBeanInfo.equals(Object o)
比较此 MBeanInfo 与另一个 MBeanInfo。

boolean

MBeanNotificationInfo.equals(Object o)
把此 MBeanNotificationInfo 与另一个 MBeanNotificationInfo 进行比较。

boolean

MBeanOperationInfo.equals(Object o)
比较此 MBeanOperationInfo 与另一个 MBeanOperationInfo。

boolean

MBeanParameterInfo.equals(Object o)
比较此 MBeanParameterInfo 与另一个 MBeanParameterInfo。

boolean

MBeanPermission.equals(Object obj)
检查两个 MBeanPermission 对象的相等性。

boolean

MBeanServerPermission.equals(Object obj)
检查两个 MBeanServerPermission 对象的相等性。

boolean

ObjectInstance.equals(Object object)
比较当前的 ObjectInstance 与另一个 ObjectInstance 是否相等。

boolean

ObjectName.equals(Object object)
比较当前的对象名与另一个对象名是否相等。

protected  MBeanConstructorInfo[]

StandardMBean.getConstructors(MBeanConstructorInfo[] ctors, Object impl)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。

protected  void

NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback)
为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。

void

NotificationListener.handleNotification(Notification notification, Object handback)
出现 JMX 通知时调用。

Object

MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。

Object

MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。

Object

MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

MBeanServerInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)

Object

MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。

Object

DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。

Object

StandardMBean.invoke(String actionName, Object[] params, String[] signature)

ObjectInstance

MBeanServer.registerMBean(Object object, ObjectName name)
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。

void

MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
从此 MBean 移除一个侦听器。

void

StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。

void

MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)

void

MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。

Object

AttributeList.set(int index, Object element)

void

Descriptor.setField(String fieldName, Object fieldValue)
设置特定字段名的值。

void

ImmutableDescriptor.setField(String fieldName, Object fieldValue)
因为此类不可变，所以不支持此操作。

void

Descriptor.setFields(String[] fieldNames, Object[] fieldValues)
将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。

void

ImmutableDescriptor.setFields(String[] fieldNames, Object[] fieldValues)
因为此类不可变，所以不支持此操作。

void

StandardMBean.setImplementation(Object implementation)
替换包装在此对象中的实现对象。

void

Notification.setSource(Object source)
设置源。

void

Notification.setUserData(Object userData)
设置用户数据。

参数类型为 Object 的 javax.management 中的构造方法

Attribute(String name, Object value)
构造将给定的属性名与给定值相关联的 Attribute 对象。

AttributeChangeNotification(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)
构造一个 AttributeChangeNotification 对象。

BadAttributeValueExpException(Object val)
构造带指定 Object 的 BadAttributeValueExpException。

ImmutableDescriptor(String[] fieldNames, Object[] fieldValues)
构造包含给定字段和值的描述符。

InvalidApplicationException(Object val)
构造具有指定 Object 的 InvalidApplicationException。

MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。

Notification(String type, Object source, long sequenceNumber)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, long timeStamp, String message)
创建一个 Notification 对象。

Notification(String type, Object source, long sequenceNumber, String message)
创建一个 Notification 对象。

javax.management.loading 中 Object 的使用

javax.management.loading 中 Object 的子类

class

MLet
允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。

class

MLetContent
此类表示 MLET 标记的内容。

class

PrivateMLet
不添加到 ClassLoaderRepository 的 MLet。

返回变量类型为 Object 的类型的 javax.management.loading 中的方法

Set<Object>

MLet.getMBeansFromURL(String url)
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLetMBean.getMBeansFromURL(String url)
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLet.getMBeansFromURL(URL url)
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

Set<Object>

MLetMBean.getMBeansFromURL(URL url)
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

javax.management.modelmbean 中 Object 的使用

javax.management.modelmbean 中 Object 的子类

class

DescriptorSupport
此类表示 ModelMBean 元素的元数据集。

class

InvalidTargetObjectTypeException
当指定了无效的目标对象类型时，抛出此异常。

class

ModelMBeanAttributeInfo
ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。

class

ModelMBeanConstructorInfo
ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。

class

ModelMBeanInfoSupport
此类表示 ModelMBean 的元数据。

class

ModelMBeanNotificationInfo
ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。

class

ModelMBeanOperationInfo
ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

class

RequiredModelMBean
此类是 ModelMBean 的实现。

class

XMLParseException
当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

返回 Object 的 javax.management.modelmbean 中的方法

Object

DescriptorSupport.clone()
返回作为 Descriptor 副本的新 Descriptor。

Object

ModelMBeanAttributeInfo.clone()
创建并返回新的 ModelMBeanAttributeInfo，它是此 ModelMBeanAttributeInfo 的副本。

Object

ModelMBeanConstructorInfo.clone()
创建并返回新 ModelMBeanConstructorInfo，它是此 ModelMBeanConstructorInfo 的副本。

Object

ModelMBeanInfo.clone()
创建并返回此对象的一个副本。

Object

ModelMBeanInfoSupport.clone()
返回此实例的浅表复制。

Object

ModelMBeanNotificationInfo.clone()
创建并返回新 ModelMBeanNotificationInfo，它是此 ModelMBeanNotificationInfo 的副本。

Object

ModelMBeanOperationInfo.clone()
创建并返回新的 ModelMBeanOperationInfo，它是此 ModelMBeanOperationInfo 的副本。

Object

RequiredModelMBean.getAttribute(String attrName)
返回为此 ModelMBean 定义的指定属性的值。

Object

DescriptorSupport.getFieldValue(String fieldName)

Object[]

DescriptorSupport.getFieldValues(String... fieldNames)

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

参数类型为 Object 的 javax.management.modelmbean 中的方法

void

ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback)
注册一个将 NotificationListener 接口实现为侦听器的对象。

void

RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)

void

RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
注册一个将 NotificationListener 接口实现为侦听器的对象。

boolean

DescriptorSupport.equals(Object o)
将此描述符与给定对象比较。

Object

RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig)
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

void

RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

void

DescriptorSupport.setField(String fieldName, Object fieldValue)

void

DescriptorSupport.setFields(String[] fieldNames, Object[] fieldValues)

void

ModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。

void

RequiredModelMBean.setManagedResource(Object mr, String mr_type)
设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。

参数类型为 Object 的 javax.management.modelmbean 中的构造方法

DescriptorSupport(String[] fieldNames, Object[] fieldValues)
带有字段名称和字段值的构造方法。

javax.management.monitor 中 Object 的使用

javax.management.monitor 中 Object 的子类

class

CounterMonitor
定义专门用来观察计数器属性值的监视器 MBean。

class

GaugeMonitor
定义专门用来观察尺度属性值的监视器 MBean。

class

Monitor
定义所有监视器 MBean 的公共部分。

class

MonitorNotification
提供对监视器 MBean 发送的通知的定义。

class

MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

class

StringMonitor
定义设计用于观察字符串属性值的监视器 MBean。

返回 Object 的 javax.management.monitor 中的方法

Object

MonitorNotification.getDerivedGauge()
获取此监视器通知的派生尺度。

Object

MonitorNotification.getTrigger()
获取触发此监视器通知的阈值/字符串（取决于监视器类型）。

javax.management.openmbean 中 Object 的使用

javax.management.openmbean 中 Object 的子类

class

ArrayType<T>
ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。

class

CompositeDataInvocationHandler
将获取方法转发给 CompositeData 的 InvocationHandler。

class

CompositeDataSupport
CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。

class

CompositeType
CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。

class

InvalidOpenTypeException
当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。

class

KeyAlreadyExistsException
当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。

class

OpenDataException
因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

class

OpenMBeanAttributeInfoSupport
描述 open MBean 的一个属性。

class

OpenMBeanConstructorInfoSupport
描述 Open MBean 的构造方法。

class

OpenMBeanInfoSupport
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。

class

OpenMBeanOperationInfoSupport
描述 Open MBean 的一个操作。

class

OpenMBeanParameterInfoSupport
描述用于 open MBean 的一个或多个操作或构造方法的参数。

class

OpenType<T>
OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。

class

SimpleType<T>
SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。

class

TabularDataSupport
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

class

TabularType
TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

返回 Object 的 javax.management.openmbean 中的方法

Object[]

TabularData.calculateIndex(CompositeData value)
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。

Object[]

TabularDataSupport.calculateIndex(CompositeData value)
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。

Object

TabularDataSupport.clone()
返回此 TabularDataSupport 实例的一个副本：通过调用 super.clone()，然后副本此基础映射，即可得到该副本。

Object

TabularDataSupport.get(Object key)
此方法仅调用 get((Object[]) key)。

Object

CompositeData.get(String key)
返回名称为 key 的项的值。

Object

CompositeDataSupport.get(String key)
返回其名称是 key 的项的值。

Object[]

CompositeData.getAll(String[] keys)
返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。

Object[]

CompositeDataSupport.getAll(String[] keys)
返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。

Object

OpenMBeanAttributeInfoSupport.getDefaultValue()
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的默认值（如果已指定），否则返回 null。

Object

OpenMBeanParameterInfo.getDefaultValue()
返回此参数的默认值（如果存在），否则返回 null。

Object

OpenMBeanParameterInfoSupport.getDefaultValue()
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的默认值（如果指定），否则返回 null。

Object

CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

TabularDataSupport.put(Object key, Object value)
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。

Object

SimpleType.readResolve()
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。

Object

TabularDataSupport.remove(Object key)
此方法仅调用 remove((Object[]) key)。

返回变量类型为 Object 的类型的 javax.management.openmbean 中的方法

Set<Map.Entry<Object,Object>>

TabularDataSupport.entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。

Set<Map.Entry<Object,Object>>

TabularDataSupport.entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。

Set<Object>

TabularDataSupport.keySet()
返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。

Collection<Object>

TabularDataSupport.values()
返回包含在此 TabularDataSupport 实例中的行的 collection 视图。

参数类型为 Object 的 javax.management.openmbean 中的方法

boolean

TabularDataSupport.containsKey(Object key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。

boolean

TabularData.containsKey(Object[] key)
当且仅当此 TabularData 实例包含其索引为指定 key 的 CompositeData 值（即行）时，才返回 true。

boolean

TabularDataSupport.containsKey(Object[] key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。

boolean

CompositeData.containsValue(Object value)
当且仅当此 CompositeData 实例包含值为 value 的项时，返回 true。

boolean

CompositeDataSupport.containsValue(Object value)
当且仅当此 CompositeData 实例包含其值是 value 的项时，返回 true。

boolean

TabularDataSupport.containsValue(Object value)
当且仅当此 TabularData 实例包含指定的值时，才返回 true。

boolean

ArrayType.equals(Object obj)
比较指定的 obj 参数与此 ArrayType 实例的相等性。

boolean

CompositeData.equals(Object obj)
比较指定 obj 参数与此 CompositeData 实例的相等性。

boolean

CompositeDataSupport.equals(Object obj)
比较指定的 obj 参数与此 CompositeDataSupport 实例的相等性。

boolean

CompositeType.equals(Object obj)
比较指定的 obj 参数与此 CompositeType 实例的相等性。

boolean

OpenMBeanAttributeInfo.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanAttributeInfo 实例的相等性。

boolean

OpenMBeanAttributeInfoSupport.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanAttributeInfoSupport 实例的相等性。

boolean

OpenMBeanConstructorInfo.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanConstructorInfo 实例的相等性。

boolean

OpenMBeanConstructorInfoSupport.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanConstructorInfoSupport 实例的相等性。

boolean

OpenMBeanInfo.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanInfo 实例的相等性。

boolean

OpenMBeanInfoSupport.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanInfoSupport 实例的相等性。

boolean

OpenMBeanOperationInfo.equals(Object obj)
比较指定 obj 参数与此 OpenMBeanOperationInfo 实例的相等性。

boolean

OpenMBeanOperationInfoSupport.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanOperationInfoSupport 实例的相等性。

boolean

OpenMBeanParameterInfo.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanParameterInfo 实例的相等性。

boolean

OpenMBeanParameterInfoSupport.equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanParameterInfoSupport 实例的相等性。

abstract  boolean

OpenType.equals(Object obj)
比较指定的 obj 参数与此开放类型实例的相等性。

boolean

SimpleType.equals(Object obj)
比较指定 obj 参数与此 SimpleType 实例的相等性。

boolean

TabularData.equals(Object obj)
比较指定的 obj 参数与此 TabularData 实例的相等性。

boolean

TabularDataSupport.equals(Object obj)
比较指定的 obj 参数与此 TabularDataSupport 实例的相等性。

boolean

TabularType.equals(Object obj)
比较指定的 obj 参数与此 TabularType 实例的相等性。

Object

TabularDataSupport.get(Object key)
此方法仅调用 get((Object[]) key)。

CompositeData

TabularData.get(Object[] key)
返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。

CompositeData

TabularDataSupport.get(Object[] key)
返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。

Object

CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

Object

CompositeDataInvocationHandler.invoke(Object proxy, Method method, Object[] args)

boolean

ArrayType.isValue(Object obj)
测试 obj 是否为此 ArrayType 实例的值。

boolean

CompositeType.isValue(Object obj)
测试 obj 是否为此 CompositeType 实例可以描述的值。

boolean

OpenMBeanAttributeInfoSupport.isValue(Object obj)
测试 obj 是否为此 OpenMBeanAttributeInfoSupport 实例描述的属性的有效值。

boolean

OpenMBeanParameterInfo.isValue(Object obj)
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。

boolean

OpenMBeanParameterInfoSupport.isValue(Object obj)
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。

abstract  boolean

OpenType.isValue(Object obj)
测试 obj 是否为此开放类型的值。

boolean

SimpleType.isValue(Object obj)
测试 obj 是否为此 SimpleType 实例的值。

boolean

TabularType.isValue(Object obj)
测试 obj 是否为此 TabularType 实例可以描述的值。

Object

TabularDataSupport.put(Object key, Object value)
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。

Object

TabularDataSupport.remove(Object key)
此方法仅调用 remove((Object[]) key)。

CompositeData

TabularData.remove(Object[] key)
从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。

CompositeData

TabularDataSupport.remove(Object[] key)
从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。

参数类型为 Object 的 javax.management.openmbean 中的构造方法

CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。

OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。

OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。

javax.management.relation 中 Object 的使用

javax.management.relation 中 Object 的子类

class

InvalidRelationIdException
为关系提供的关系 id 已使用时引发此异常。

class

InvalidRelationServiceException
提供无效 Relation Service（关系服务）时引发此异常。

class

InvalidRelationTypeException
无效的关系类型。

class

InvalidRoleInfoException
在角色信息中，其最小程度大于其最大程度时，引发此异常。

class

InvalidRoleValueException
角色值无效。

class

MBeanServerNotificationFilter
MBeanServerNotification 的过滤器。

class

RelationException
此类是关系管理过程中引发的任何异常的超类。

class

RelationNotFoundException
Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。

class

RelationNotification
Relation Service（关系服务）中的更改通知。

class

RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

class

RelationServiceNotRegisteredException
在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。

class

RelationSupport
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

class

RelationTypeNotFoundException
Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。

class

RelationTypeSupport
RelationTypeSupport 对象实现 RelationType 接口。

class

Role
表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。

class

RoleInfo
RoleInfo 概括介绍关系类型中的角色。

class

RoleInfoNotFoundException
给定的关系类型中不存在带指定名称的角色信息时引发此异常。

class

RoleList
RoleList 表示角色（Role 对象）的列表。

class

RoleNotFoundException
关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

class

RoleResult
表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。

class

RoleStatus
此类描述访问某个角色时可能遇到的各种问题。

class

RoleUnresolved
表示未解析的角色：由于存在问题而无法从关系中检索到的角色。

class

RoleUnresolvedList
RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

返回 Object 的 javax.management.relation 中的方法

Object

Role.clone()
复制角色对象。

Object

RoleUnresolved.clone()
复制此对象。

Object

RoleList.set(int index, Object element)

Object

RoleUnresolvedList.set(int index, Object element)

参数类型为 Object 的 javax.management.relation 中的方法

void

RoleList.add(int index, Object element)

void

RoleUnresolvedList.add(int index, Object element)

boolean

RoleList.add(Object o)

boolean

RoleUnresolvedList.add(Object o)

void

RelationService.handleNotification(Notification notif, Object handback)
出现 JMX 通知时调用。

Object

RoleList.set(int index, Object element)

Object

RoleUnresolvedList.set(int index, Object element)

参数类型为 Object 的 javax.management.relation 中的构造方法

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。

RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。

javax.management.remote 中 Object 的使用

javax.management.remote 中 Object 的子类

class

JMXConnectionNotification
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。

class

JMXConnectorFactory
用于创建 JMX API 连接器客户端的工厂。

class

JMXConnectorServer
每个连接器服务器的超类。

class

JMXConnectorServerFactory
用于创建 JMX API 连接器服务器的工厂。

class

JMXPrincipal
JMX Remote API 的远程客户端的身份。

class

JMXProviderException
当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。

class

JMXServerErrorException
在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

class

JMXServiceURL
JMX API 连接器服务器的地址。

class

NotificationResult
缓存的通知的查询结果。

class

SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

class

TargetedNotification
一个 (Notification, Listener ID) 对。

参数类型为 Object 的 javax.management.remote 中的方法

void

JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
添加一个接收连接状态改变的侦听器。

Subject

JMXAuthenticator.authenticate(Object credentials)
用给定的客户端凭据验证 MBeanServerConnection 客户端。

protected  void

JMXConnectorServer.connectionClosed(String connectionId, String message, Object userData)
正常关闭客户端连接时由子类调用。

protected  void

JMXConnectorServer.connectionFailed(String connectionId, String message, Object userData)
客户端连接失败时由子类调用。

protected  void

JMXConnectorServer.connectionOpened(String connectionId, String message, Object userData)
打开新的客户端连接时由子类调用。

boolean

JMXPrincipal.equals(Object o)
比较指定的 Object 与此 JMXPrincipal 是否相等。

boolean

JMXServiceURL.equals(Object obj)
指示是否有其他的对象等于此对象。

void

JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback)
将一个用于接收状态更改通知的侦听器从列表中移除。

参数类型为 Object 的 javax.management.remote 中的构造方法

JMXConnectionNotification(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)
构造一个新的连接通知。

javax.management.remote.rmi 中 Object 的使用

javax.management.remote.rmi 中 Object 的子类

class

RMIConnectionImpl
RMIConnection 接口的实现。

class

RMIConnectionImpl_Stub

class

RMIConnector
一个到远程 RMI 连接器的连接。

class

RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

class

RMIIIOPServerImpl
一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。

class

RMIJRMPServerImpl
一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。

class

RMIServerImpl
表示连接器服务器的 RMI 对象。

class

RMIServerImpl_Stub

返回 Object 的 javax.management.remote.rmi 中的方法

Object

RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。

Object

RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)

Object

RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。

Object

RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)

Object

RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)

参数类型为 Object 的 javax.management.remote.rmi 中的方法

void

RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

protected  void

RMIConnectorServer.connectionClosed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionFailed(String connectionId, String message, Object userData)

protected  void

RMIConnectorServer.connectionOpened(String connectionId, String message, Object userData)

RMIConnection

RMIServer.newClient(Object credentials)
建立一个使用该 RMI 连接器的新连接。

RMIConnection

RMIServerImpl.newClient(Object credentials)
创建一个新的客户端连接。

RMIConnection

RMIServerImpl_Stub.newClient(Object $param_Object_1)

void

RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.timer 中 Object 的使用

javax.management.timer 中 Object 的子类

class

TimerNotification
此类定义了由计时器 MBean 发送的通知。

返回 Object 的 javax.management.timer 中的方法

Object

Timer.getNotificationUserData(Integer id)
获得与指定标识符对应的计时器通知用户数据对象。

Object

TimerMBean.getNotificationUserData(Integer id)
获得与指定的标识符对应的计时器通知用户数据对象。

参数类型为 Object 的 javax.management.timer 中的方法

Integer

Timer.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

Integer

TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate)
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

参数类型为 Object 的 javax.management.timer 中的构造方法

TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
创建计时器通知对象。

javax.naming 中 Object 的使用

javax.naming 中 Object 的子类

class

AuthenticationNotSupportedException
当所请求验证的特定 flavor 不受支持时，抛出此异常。

class

BinaryRefAddr
此类表示通信终端地址的二进制形式。

class

CannotProceedException
抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。

class

CommunicationException
当客户端无法与目录或命名服务通信时，抛出此异常。

class

CompositeName
此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。

class

CompoundName
此类表示一个组合名称，即一个取自层次名称空间的名称。

class

ConfigurationException
当存在配置问题时，抛出此异常。

class

ContextNotEmptyException
当试图销毁一个不为空的上下文时，抛出此异常。

class

InitialContext
此类是执行命名操作的初始上下文。

class

InsufficientResourcesException
当无法使用资源完成所请求的操作时，抛出此异常。

class

InterruptedNamingException
当正被调用的命名操作已经被中断时，抛出此异常。

class

InvalidNameException
此异常指示被指定的名称不符合命名系统的命名语法。

class

LimitExceededException
当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。

class

LinkException
此异常用于描述解析链接时遇到的问题。

class

LinkLoopException
当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。

class

LinkRef
此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。

class

MalformedLinkException
如果在解析或构造链接时遇到错误链接，则抛出此异常。

class

NameAlreadyBoundException
一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。

class

NameClassPair
此类表示存在于上下文中的某一绑定的对象名称和类名称对。

class

NameNotFoundException
当名称的组件由于没有被绑定而无法解析时，抛出此异常。

class

NamingException
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。

class

NamingSecurityException
此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。

class

NoInitialContextException
当不能创建任何初始上下文实现时，抛出此异常。

class

NoPermissionException
当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。

class

NotContextException
当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。

class

OperationNotSupportedException
当上下文实现不支持将调用的操作时，抛出此异常。

class

PartialResultException
抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。

class

RefAddr
此类表示通信端点的地址。

class

ReferralException
此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。

class

ServiceUnavailableException
当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。

class

SizeLimitExceededException
当某一方法生成的结果超出与大小有关的限制时，抛出此异常。

class

StringRefAddr
此类表示通信终端地址的字符串形式。

class

TimeLimitExceededException
当某一方法没有在指定的时间限制内终止时，抛出此异常。

声明为 Object 的 javax.naming 中的字段

protected  Object

LinkException.linkResolvedObj
包含一个对象，已成功解析的链接部分一直到达该对象。

protected  Object

NamingException.resolvedObj
包含一个对象，已成功解析的名称部分进行到该对象。

类型参数类型为 Object 的 javax.naming 中的字段

protected  Hashtable<Object,Object>

InitialContext.myProps
与此 InitialContext 关联的环境。

protected  Hashtable<Object,Object>

InitialContext.myProps
与此 InitialContext 关联的环境。

返回 Object 的 javax.naming 中的方法

Object

Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。

Object

InitialContext.addToEnvironment(String propName, Object propVal)

Object

CompositeName.clone()
生成此复合名称的副本。

Object

CompoundName.clone()
创建此组合名称的副本。

Object

Name.clone()
生成此名称的新副本。

Object

Reference.clone()
使用地址的类名称列表、类工厂名称和类工厂位置创建此引用的副本。

Object

BinaryRefAddr.getContent()
以 Object 形式检索此地址的内容。

abstract  Object

RefAddr.getContent()
检索此地址的内容。

Object

StringRefAddr.getContent()
检索此地址的内容。

Object

LinkException.getLinkResolvedObj()
检索已成功解析成的对象。

Object

Binding.getObject()
检索绑定到此绑定名称的对象。

abstract  Object

ReferralException.getReferralInfo()
检索与此引用有关的信息（比如 URL）。

Object

NamingException.getResolvedObj()
检索已成功解析成的对象。

Object

Context.lookup(Name name)
检索指定的对象。

Object

InitialContext.lookup(Name name)

Object

Context.lookup(String name)
检索指定的对象。

Object

InitialContext.lookup(String name)

Object

Context.lookupLink(Name name)
按照除名称的最终原子组件以外的链接检索指定对象。

Object

InitialContext.lookupLink(Name name)

Object

Context.lookupLink(String name)
按照除名称的最终原子组件以外的链接检索指定对象。

Object

InitialContext.lookupLink(String name)

Object

CompositeName.remove(int posn)
从此复合名称中删除一个组件。

Object

CompoundName.remove(int posn)
从此组合名称中删除一个组件。

Object

Name.remove(int posn)
从此名称中移除一个组件。

Object

Reference.remove(int posn)
从地址列表中删除索引 posn 处的地址。

Object

Context.removeFromEnvironment(String propName)
从此上下文的环境中移除一个环境属性。

Object

InitialContext.removeFromEnvironment(String propName)

参数类型为 Object 的 javax.naming 中的方法

Object

Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。

Object

InitialContext.addToEnvironment(String propName, Object propVal)

void

Context.bind(Name name, Object obj)
将名称绑定到对象。

void

InitialContext.bind(Name name, Object obj)

void

Context.bind(String name, Object obj)
将名称绑定到对象。

void

InitialContext.bind(String name, Object obj)

int

CompositeName.compareTo(Object obj)
比较此 CompositeName 与指定 Object 的顺序。

int

CompoundName.compareTo(Object obj)
比较此 CompoundName 与指定 Object 的顺序。

int

Name.compareTo(Object obj)
比较此名称与另一个名称的顺序。

boolean

BinaryRefAddr.equals(Object obj)
确定 obj 是否等于此地址。

boolean

CompositeName.equals(Object obj)
确定两个复合名称是否相等。

boolean

CompoundName.equals(Object obj)
确定 obj 在语法上是否等同于此组合名称。

boolean

RefAddr.equals(Object obj)
确定 obj 是否等于此 RefAddr。

boolean

Reference.equals(Object obj)
确定 obj 是否是一个与此引用具有相同地址（按相同顺序）的引用。

void

Context.rebind(Name name, Object obj)
将名称绑定到对象，重写任何现有绑定。

void

InitialContext.rebind(Name name, Object obj)

void

Context.rebind(String name, Object obj)
将名称绑定到对象，重写所有现有绑定。

void

InitialContext.rebind(String name, Object obj)

void

LinkException.setLinkResolvedObj(Object obj)
设置此异常的已解析链接对象字段。

void

Binding.setObject(Object obj)
设置与此绑定关联的对象。

void

NamingException.setResolvedObj(Object obj)
设置此异常的已解析对象字段。

参数类型为 Object 的 javax.naming 中的构造方法

Binding(String name, Object obj)
在给定其名称和对象的情况下构造一个 Binding 实例。

Binding(String name, Object obj, boolean isRelative)
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj)
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。

Binding(String name, String className, Object obj, boolean isRelative)
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

javax.naming.directory 中 Object 的使用

javax.naming.directory 中 Object 的子类

class

AttributeInUseException
当操作试图添加已经存在的属性时抛出此异常。

class

AttributeModificationException
当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。

class

BasicAttribute
此类提供 Attribute 接口的基本实现。

class

BasicAttributes
此类提供 Attributes 接口的基本实现。

class

InitialDirContext
此类是执行目录操作的初始上下文。

class

InvalidAttributeIdentifierException
在试图用无效的属性标识符创建属性时，抛出此异常。

class

InvalidAttributesException
在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。

class

InvalidSearchControlsException
在为搜索操作指定的 SearchControls 无效时，抛出此异常。

class

InvalidSearchFilterException
当指定的搜索过滤器无效时，抛出此异常。

class

ModificationItem
此类表示修改项。

class

NoSuchAttributeException
尝试访问不存在的属性时，抛出此异常。

class

SchemaViolationException
当方法在某些方面违反模式时，抛出此异常。

class

SearchControls
此类封装确定搜索范围和搜索返回结果的因子。

class

SearchResult
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

类型参数类型为 Object 的 javax.naming.directory 中的字段

protected  Vector<Object>

BasicAttribute.values
保存属性的值。

返回 Object 的 javax.naming.directory 中的方法

Object

Attribute.clone()
对属性进行复制。

Object

Attributes.clone()
对属性集进行复制。

Object

BasicAttribute.clone()

Object

BasicAttributes.clone()

Object

Attribute.get()
检索此属性的其中一个值。

Object

BasicAttribute.get()
检索此属性的其中一个值。

Object

Attribute.get(int ix)
从属性值的有序列表中检索属性值。

Object

BasicAttribute.get(int ix)

Object

Attribute.remove(int ix)
从属性值的有序列表中移除属性值。

Object

BasicAttribute.remove(int ix)

Object

Attribute.set(int ix, Object attrVal)
设置属性值的有序列表中的属性值。

Object

BasicAttribute.set(int ix, Object attrVal)

参数类型为 Object 的 javax.naming.directory 中的方法

void

Attribute.add(int ix, Object attrVal)
将属性值添加到属性值的有序列表中。

void

BasicAttribute.add(int ix, Object attrVal)

boolean

Attribute.add(Object attrVal)
向属性添加新值。

boolean

BasicAttribute.add(Object attrVal)
向此属性添加新值。

void

DirContext.bind(Name name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象。

void

InitialDirContext.bind(Name name, Object obj, Attributes attrs)

void

DirContext.bind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象。

void

InitialDirContext.bind(String name, Object obj, Attributes attrs)

boolean

Attribute.contains(Object attrVal)
确定某个值是否在属性中。

boolean

BasicAttribute.contains(Object attrVal)
确定值是否在此属性中。

boolean

BasicAttribute.equals(Object obj)
确定 obj 是否等于此属性。

boolean

BasicAttributes.equals(Object obj)
确定此 BasicAttributes 是否等于另一个 Attributes。

Attribute

Attributes.put(String attrID, Object val)
向属性集中添加新属性。

Attribute

BasicAttributes.put(String attrID, Object val)

void

DirContext.rebind(Name name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。

void

InitialDirContext.rebind(Name name, Object obj, Attributes attrs)

void

DirContext.rebind(String name, Object obj, Attributes attrs)
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。

void

InitialDirContext.rebind(String name, Object obj, Attributes attrs)

boolean

Attribute.remove(Object attrval)
从属性中移除指定值。

boolean

BasicAttribute.remove(Object attrval)
从此属性中移除指定值。

NamingEnumeration<SearchResult>

DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)

NamingEnumeration<SearchResult>

DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
在命名上下文或对象中搜索符合给定搜索过滤器的项。

NamingEnumeration<SearchResult>

InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)

Object

Attribute.set(int ix, Object attrVal)
设置属性值的有序列表中的属性值。

Object

BasicAttribute.set(int ix, Object attrVal)

参数类型为 Object 的 javax.naming.directory 中的构造方法

BasicAttribute(String id, Object value)
构造一个带有单个值的无序属性的新实例。

BasicAttribute(String id, Object value, boolean ordered)
构造一个带有单个值的可能为有序属性的新实例。

BasicAttributes(String attrID, Object val)
构造带有一个属性的新 Attributes 实例。

BasicAttributes(String attrID, Object val, boolean ignoreCase)
构造带有一个属性的新 Attributes 实例。

SearchResult(String name, Object obj, Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。

SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

javax.naming.event 中 Object 的使用

javax.naming.event 中 Object 的子类

class

NamingEvent
此类表示命名/目录服务触发的事件。

class

NamingExceptionEvent
此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。

声明为 Object 的 javax.naming.event 中的字段

protected  Object

NamingEvent.changeInfo
包含关于生成此事件的更改的信息。

返回 Object 的 javax.naming.event 中的方法

Object

NamingEvent.getChangeInfo()
检索此事件的更改信息。

参数类型为 Object 的 javax.naming.event 中的方法

void

EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

void

EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。

参数类型为 Object 的 javax.naming.event 中的构造方法

NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
构造一个 NamingEvent 的实例。

javax.naming.ldap 中 Object 的使用

javax.naming.ldap 中 Object 的子类

class

BasicControl
此类提供 Control 接口的基本实现。

class

ControlFactory
此抽象类表示用于创建 LDAPv3 控件的工厂。

class

InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

class

LdapName
此类表示 RFC 2253 指定的标识名。

class

LdapReferralException
此抽象类用于表示 LDAP 引用异常。

class

ManageReferralControl
将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。

class

PagedResultsControl
请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。

class

PagedResultsResponseControl
指示一批搜索结果的末尾。

class

Rdn
此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。

class

SortControl
请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。

class

SortKey
排序键及其关联的排序参数。

class

SortResponseControl
指示搜索结果的请求排序是否成功。

class

StartTlsRequest
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。

class

StartTlsResponse
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。

class

UnsolicitedNotificationEvent
此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

返回 Object 的 javax.naming.ldap 中的方法

Object

LdapName.clone()
生成此名称的新副本。

Object

Rdn.getValue()
检索一个此 Rdn 的值。

Object

LdapName.remove(int posn)
从此 LDAP 名称中移除一个组件。

static Object

Rdn.unescapeValue(String val)
在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。

参数类型为 Object 的 javax.naming.ldap 中的方法

int

LdapName.compareTo(Object obj)
比较此 LdapName 与指定 Object 的顺序。

int

Rdn.compareTo(Object obj)
比较此 Rdn 与指定 Object 的顺序。

boolean

LdapName.equals(Object obj)
确定两个 LDAP 名称是否相等。

boolean

Rdn.equals(Object obj)
比较指定 Object 与此 Rdn 的相等性。

static String

Rdn.escapeValue(Object val)
在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。

参数类型为 Object 的 javax.naming.ldap 中的构造方法

Rdn(String type, Object value)
根据给定属性类型和值构造 Rdn。

UnsolicitedNotificationEvent(Object src, UnsolicitedNotification notice)
构造一个新的 UnsolicitedNotificationEvent 实例。

javax.naming.spi 中 Object 的使用

javax.naming.spi 中 Object 的子类

class

DirectoryManager
此类包含支持 DirContext 实现的方法。

static class

DirStateFactory.Result
用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。

class

NamingManager
此类包含一些方法来创建上下文对象以及通过命名或目录服务中的信息引用的对象。

class

ResolveResult
此类表示解析某一名称的结果。

声明为 Object 的 javax.naming.spi 中的字段

protected  Object

ResolveResult.resolvedObj
该字段包含已成功解析成的 Object。

返回 Object 的 javax.naming.spi 中的方法

Object

DirStateFactory.Result.getObject()
检索要绑定的对象。

static Object

NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
为指定对象和环境创建一个对象实例。

Object

ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
使用指定的位置或引用信息创建一个对象。

Object

DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
使用位置或引用信息以及指定的属性创建一个对象。

static Object

DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
为指定对象、属性和环境创建一个对象实例。

Object

ResolveResult.getResolvedObj()
检索已成功解析成的 Object。

static Object

NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象的状态。

Object

StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象状态。

参数类型为 Object 的 javax.naming.spi 中的方法

ObjectFactory

ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment)
使用所提供的环境创建一个新对象工厂。

static Object

NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment)
为指定对象和环境创建一个对象实例。

Object

ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
使用指定的位置或引用信息创建一个对象。

Object

DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
使用位置或引用信息以及指定的属性创建一个对象。

static Object

DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
为指定对象、属性和环境创建一个对象实例。

static Object

NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象的状态。

Object

StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象状态。

DirStateFactory.Result

DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。

static DirStateFactory.Result

DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
在给定初始对象及其属性时，检索用于绑定的对象的状态。

void

ResolveResult.setResolvedObj(Object obj)
将此结果的已解析 Object 字段设置为 obj。

参数类型为 Object 的 javax.naming.spi 中的构造方法

DirStateFactory.Result(Object obj, Attributes outAttrs)
构造一个 Result 实例。

ResolveResult(Object robj, Name rname)
构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。

ResolveResult(Object robj, String rcomp)
构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。

javax.net 中 Object 的使用

javax.net 中 Object 的子类

class

ServerSocketFactory
此类创建服务器套接字。

class

SocketFactory
此类创建套接字。

javax.net.ssl 中 Object 的使用

javax.net.ssl 中 Object 的子类

class

CertPathTrustManagerParameters
CertPathParameters 的包装器。

class

HandshakeCompletedEvent
此事件指示在给定的 SSL 连接上 SSL 握手结束。

class

HttpsURLConnection
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。

class

KeyManagerFactory
此类充当基于密钥内容源的密钥管理器的工厂。

class

KeyManagerFactorySpi
此类为 KeyManagerFactory 类定义了服务提供者接口 (SPI)。

class

KeyStoreBuilderParameters
封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。

class

SSLContext
此类的实例表示安全套接字协议的实现，它充当用于安全套接字工厂或 SSLEngine 的工厂。

class

SSLContextSpi
此类为 SSLContext 类定义了服务提供者接口 (SPI)。

class

SSLEngine
此类允许使用安全套接字层 (SSL) 或 IETF RFC 2246 "Transport Layer Security" (TLS) 协议进行安全通信，但它与传输无关。

class

SSLEngineResult
SSLEngine I/O 调用所生成的结果状态的封装。

class

SSLException
指示由 SSL 子系统检测到的某类错误。

class

SSLHandshakeException
指示客户端和服务器不能就所需安全级别进行协商。

class

SSLKeyException
报告错误的 SSL 密钥。

class

SSLParameters
封装 SSL/TLS 连接的参数。

class

SSLPeerUnverifiedException
指示还没有验证同位体的身份。

class

SSLPermission
此类用于各种网络权限。

class

SSLProtocolException
报告在 SSL 协议的操作中的错误。

class

SSLServerSocket
此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。

class

SSLServerSocketFactory
SSLServerSocketFactory 创建 SSLServerSocket。

class

SSLSessionBindingEvent
此事件向 SSLSessionBindingListener 传播。

class

SSLSocket
此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。

class

SSLSocketFactory
SSLSocketFactory 创建 SSLSocket。

class

TrustManagerFactory
此类充当基于信任材料源的信任管理器的工厂。

class

TrustManagerFactorySpi
此类为 TrustManagerFactory 类定义了服务提供者接口 (SPI)。

class

X509ExtendedKeyManager
提供 X509KeyManager 接口的扩展的抽象类。

返回 Object 的 javax.net.ssl 中的方法

Object

SSLSession.getValue(String name)
返回会话的应用层数据中的绑定到给定名称的对象。

参数类型为 Object 的 javax.net.ssl 中的方法

void

SSLSession.putValue(String name, Object value)
使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。

javax.print 中 Object 的使用

javax.print 中 Object 的子类

class

DocFlavor
类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。

static class

DocFlavor.BYTE_ARRAY
类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.CHAR_ARRAY
类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.INPUT_STREAM
类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.READER
类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.SERVICE_FORMATTED
类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。

static class

DocFlavor.STRING
类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。

static class

DocFlavor.URL
类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。

class

PrintException
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

class

PrintServiceLookup
此类的实现为特定类型的 PrintService（通常等效于打印机）提供查找服务。

class

ServiceUI
此类是各种 UI 便捷方法的集合，这些方法为浏览那些通过 Java Print Service API 所查找的 PrintService 提供了图形用户对话框。

class

ServiceUIFactory
服务可以可选地提供 UI，这些 UI 允许以不同的角色进行不同风格的交互。

class

SimpleDoc
此类是接口 Doc 的实现，可用于很多常见的打印请求中。

class

StreamPrintService
此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。

class

StreamPrintServiceFactory
StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。

返回 Object 的 javax.print 中的方法

Object

PrintService.getDefaultAttributeValue(Class<? extends Attribute> category)
确定给定类别中此 PrintService 的默认打印属性值。

Object

Doc.getPrintData()
获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。

Object

SimpleDoc.getPrintData()

Object

PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。

abstract  Object

ServiceUIFactory.getUI(int role, String ui)
获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。

参数类型为 Object 的 javax.print 中的方法

boolean

DocFlavor.equals(Object obj)
确定此 DocFlavor 对象是否等于给定的对象。

boolean

PrintService.equals(Object obj)
确定两个服务是否引用相同的底层服务。

参数类型为 Object 的 javax.print 中的构造方法

SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。

javax.print.attribute 中 Object 的使用

javax.print.attribute 中 Object 的子类

class

AttributeSetUtilities
类 AttributeSetUtilities 为操作 AttributeSets 提供静态方法。

class

DateTimeSyntax
类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。

class

EnumSyntax
类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。

class

HashAttributeSet
类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。

class

HashDocAttributeSet
类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。

class

HashPrintJobAttributeSet
类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。

class

HashPrintRequestAttributeSet
类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。

class

HashPrintServiceAttributeSet
类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

class

IntegerSyntax
类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。

class

ResolutionSyntax
类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。

class

SetOfIntegerSyntax
类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。

class

Size2DSyntax
类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。

class

TextSyntax
类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。

class

UnmodifiableSetException
当由于设置不可修改而无法执行请求的操作时，抛出该异常。

class

URISyntax
类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

返回 Object 的 javax.print.attribute 中的方法

Object

EnumSyntax.clone()
返回此枚举值的一个副本，该副本保留了枚举值的语义，它是与此枚举值相同的对象。

protected  Object

EnumSyntax.readResolve()
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。

参数类型为 Object 的 javax.print.attribute 中的方法

boolean

AttributeSet.equals(Object object)
比较指定的对象与此属性集的相等性。

boolean

DateTimeSyntax.equals(Object object)
返回此日期-时间属性是否等效于传入的对象。

boolean

HashAttributeSet.equals(Object object)
比较指定的对象与此属性集的相等性。

boolean

IntegerSyntax.equals(Object object)
返回此整数属性是否等效于传入的对象。

boolean

ResolutionSyntax.equals(Object object)
返回此分辨率属性是否等效于传入的对象。

boolean

SetOfIntegerSyntax.equals(Object object)
返回此整数集属性是否等效于传入的对象。

boolean

Size2DSyntax.equals(Object object)
返回此二维大小属性是否等效于传入的对象。

boolean

TextSyntax.equals(Object object)
返回此文本属性是否等效于传入的对象。

boolean

URISyntax.equals(Object object)
返回此 URI 属性是否等效于传入的对象。

static Class<?>

AttributeSetUtilities.verifyAttributeCategory(Object object, Class<?> interfaceName)
验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。

static Attribute

AttributeSetUtilities.verifyAttributeValue(Object object, Class<?> interfaceName)
验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。

javax.print.attribute.standard 中 Object 的使用

javax.print.attribute.standard 中 Object 的子类

class

Chromaticity
Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。

class

ColorSupported
ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。

class

Compression
Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。

class

Copies
Copies 类是整数值形式的打印属性类，它指定了要打印的份数。

class

CopiesSupported
CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。

class

DateTimeAtCompleted
DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。

class

DateTimeAtCreation
DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。

class

DateTimeAtProcessing
DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。

class

Destination
Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。

class

DocumentName
DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。

class

Fidelity
Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。

class

Finishings
Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。

class

JobHoldUntil
JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。

class

JobImpressions
JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。

class

JobImpressionsCompleted
JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。

class

JobImpressionsSupported
JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。

class

JobKOctets
JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。

class

JobKOctetsProcessed
JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。

class

JobKOctetsSupported
JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。

class

JobMediaSheets
JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。

class

JobMediaSheetsCompleted
JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。

class

JobMediaSheetsSupported
Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。

class

JobMessageFromOperator
JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。

class

JobName
JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。

class

JobOriginatingUserName
JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。

class

JobPriority
JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。

class

JobPrioritySupported
JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。

class

JobSheets
JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。

class

JobState
JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。

class

JobStateReason
JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。

class

JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

class

Media
Media 类是打印属性类，它指定了要在其上打印的介质。

class

MediaName
MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。

class

MediaPrintableArea
MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。

class

MediaSize
MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。

static class

MediaSize.Engineering
MediaSize.Engineering 类包括 engineering 介质的 MediaSize 值。

static class

MediaSize.ISO
MediaSize.ISO 类包括 ISO 介质的 MediaSize 值。

static class

MediaSize.JIS
MediaSize.JIS 类包括 JIS (Japanese) 介质的 MediaSize 值。

static class

MediaSize.NA
MediaSize.NA 类包括 North American 介质的 MediaSize 值。

static class

MediaSize.Other
MediaSize.Other 类包括其他介质的 MediaSize 值。

class

MediaSizeName
MediaSizeName 类是 Media 的子类。

class

MediaTray
MediaTray 类是 Media 的子类。

class

MultipleDocumentHandling
MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。

class

NumberOfDocuments
NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。

class

NumberOfInterveningJobs
NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。

class

NumberUp
NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。

class

NumberUpSupported
NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。

class

OrientationRequested
OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。

class

OutputDeviceAssigned
OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。

class

PageRanges
PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。

class

PagesPerMinute
PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。

class

PagesPerMinuteColor
PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。

class

PDLOverrideSupported
PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。

class

PresentationDirection
PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。

class

PrinterInfo
PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。

class

PrinterIsAcceptingJobs
PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。

class

PrinterLocation
PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。

class

PrinterMakeAndModel
PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。

class

PrinterMessageFromOperator
PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。

class

PrinterMoreInfo
PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。

class

PrinterMoreInfoManufacturer
PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。

class

PrinterName
PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。

class

PrinterResolution
PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。

class

PrinterState
PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。

class

PrinterStateReason
PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

class

PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

class

PrinterURI
PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。

class

PrintQuality
PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。

class

QueuedJobCount
QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。

class

ReferenceUriSchemesSupported
ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。

class

RequestingUserName
RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。

class

Severity
Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。

class

SheetCollate
SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。

class

Sides
Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

参数类型为 Object 的 javax.print.attribute.standard 中的方法

boolean

Copies.equals(Object object)
返回此副本属性是否等效于传入的对象。

boolean

CopiesSupported.equals(Object object)
返回支持副本的此属性是否等于传入的对象。

boolean

DateTimeAtCompleted.equals(Object object)
返回此 DateTimeAtCompleted 属性是否等效于传入的对象。

boolean

DateTimeAtCreation.equals(Object object)
返回此 DateTimeAtCreation 属性是否等效于传入的对象。

boolean

DateTimeAtProcessing.equals(Object object)
返回此 DateTimeAtProcessing 属性是否等效于传入的对象。

boolean

Destination.equals(Object object)
返回此目标属性是否等效于传入的对象。

boolean

DocumentName.equals(Object object)
返回此文档名称属性是否等效于传入的对象。

boolean

JobHoldUntil.equals(Object object)
返回此 JobHoldUntil 属性是否等效于传入的对象。

boolean

JobImpressions.equals(Object object)
返回此作业印张属性是否等效于传入的对象。

boolean

JobImpressionsCompleted.equals(Object object)
返回此 JobImpressionsCompleted 属性是否等效于传入的对象。

boolean

JobImpressionsSupported.equals(Object object)
返回此 JobImpressionsSupported 属性是否等效于传入的对象。

boolean

JobKOctets.equals(Object object)
返回此 JobKOctets 属性是否等效于传入的对象。

boolean

JobKOctetsProcessed.equals(Object object)
返回此 JobKOctetsProcessed 属性是否等效于传入的对象。

boolean

JobKOctetsSupported.equals(Object object)
返回此 JobKOctetsSupported 属性是否等效于传入的对象。

boolean

JobMediaSheets.equals(Object object)
返回此 JobMediaSheets 属性是否等效于传入的对象。

boolean

JobMediaSheetsCompleted.equals(Object object)
返回此 JobMediaSheetsCompleted 属性是否等效于传入的对象。

boolean

JobMediaSheetsSupported.equals(Object object)
返回支持的此 JobMediaSheetsSupported 属性是否等效于传入的对象。

boolean

JobMessageFromOperator.equals(Object object)
返回 Operator 属性传来的此作业消息是否等效于传入的对象。

boolean

JobName.equals(Object object)
返回此作业名称属性是否等效于传入的对象。

boolean

JobOriginatingUserName.equals(Object object)
返回此 JobOriginatingUserName 属性是否等效于传入的对象。

boolean

JobPriority.equals(Object object)
返回此作业优先级属性是否等效于传入的对象。

boolean

JobPrioritySupported.equals(Object object)
返回支持的此作业优先级属性是否等效于传入的对象。

boolean

Media.equals(Object object)
返回此介质属性是否等效于传入的对象。

boolean

MediaPrintableArea.equals(Object object)
返回此介质页边距属性是否等效于传入的对象。

boolean

MediaSize.equals(Object object)
返回此介质尺寸属性是否等效于传入的对象。

boolean

NumberOfDocuments.equals(Object object)
返回此文档数属性是否等效于传入的对象。

boolean

NumberOfInterveningJobs.equals(Object object)
返回此 NumberOfInterveningJobs 属性是否等效于传入的对象。

boolean

NumberUp.equals(Object object)
返回此计数属性是否等效于传入的对象。

boolean

NumberUpSupported.equals(Object object)
返回此 NumberUpSupported 属性是否等效于传入的对象。

boolean

OutputDeviceAssigned.equals(Object object)
返回此 OutputDeviceAssigned 属性是否等效于传入的对象。

boolean

PageRanges.equals(Object object)
返回此 PageRanges 属性是否等效于传入的对象。

boolean

PagesPerMinute.equals(Object object)
返回此 PagesPerMinute 属性是否等效于传入的对象。

boolean

PagesPerMinuteColor.equals(Object object)
返回此 PagesPerMinuteColor 属性是否等效于传入的对象。

boolean

PrinterInfo.equals(Object object)
返回此 PrinterInfo 属性是否等效于传入的对象。

boolean

PrinterLocation.equals(Object object)
返回此 PrinterLocation 属性是否等效于传入的对象。

boolean

PrinterMakeAndModel.equals(Object object)
返回此 PrinterMakeAndModel 属性是否等效于传入的对象。

boolean

PrinterMessageFromOperator.equals(Object object)
返回此 PrinterMessageFromOperator 属性是否等效于传入的对象。

boolean

PrinterMoreInfo.equals(Object object)
返回此 PrinterMoreInfo 属性是否等效于传入的对象。

boolean

PrinterMoreInfoManufacturer.equals(Object object)
返回此 PrinterMoreInfoManufacturer 属性是否等效于传入的对象。

boolean

PrinterName.equals(Object object)
返回此 PrinterName 属性是否等效于传入的对象。

boolean

PrinterResolution.equals(Object object)
返回此 PrinterResolution 属性是否等效于传入的对象。

boolean

PrinterURI.equals(Object object)
返回此打印机名称属性是否等效于传入的对象。

boolean

QueuedJobCount.equals(Object object)
返回此 QueuedJobCount 属性是否等效于传入的对象。

boolean

RequestingUserName.equals(Object object)
返回此 RequestingUserName 属性是否等效于传入的对象。

javax.print.event 中 Object 的使用

javax.print.event 中 Object 的子类

class

PrintEvent
类 PrintEvent 是所有 Print Service API 事件的超类。

class

PrintJobAdapter
接收打印作业事件的抽象适配器类。

class

PrintJobAttributeEvent
类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。

class

PrintJobEvent
类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。

class

PrintServiceAttributeEvent
类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

参数类型为 Object 的 javax.print.event 中的构造方法

PrintEvent(Object source)
构造一个 PrintEvent 对象。

javax.rmi 中 Object 的使用

javax.rmi 中 Object 的子类

class

PortableRemoteObject
服务器实现对象可以从 javax.rmi.PortableRemoteObject 继承，也可以实现一个远程接口，然后使用 exportObject 方法将其本身注册为服务器对象。

返回 Object 的 javax.rmi 中的方法

static Object

PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

参数类型为 Object 的 javax.rmi 中的方法

static Object

PortableRemoteObject.narrow(Object narrowFrom, Class narrowTo)
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

javax.rmi.CORBA 中 Object 的使用

javax.rmi.CORBA 中 Object 的子类

class

ClassDesc
此类用于对 IIOP 上的 java.lang.Class 对象进行编组。

class

Stub
必须从其继承所有 RMI-IIOP stub 的基类。

class

Util
提供可以由 stub 和 tie 用于执行公共操作的实用方法。

返回 Object 的 javax.rmi.CORBA 中的方法

static Object

Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。

Object

UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。

static Object[]

Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。

Object[]

UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。

Object

PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。

static Object

Util.readAny(InputStream in)
将 java.lang.Object 作为 CORBA any 读取。

Object

UtilDelegate.readAny(InputStream in)
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。

参数类型为 Object 的 javax.rmi.CORBA 中的方法

static Object

Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。

Object

UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。

static Object[]

Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。

Object[]

UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。

boolean

Stub.equals(Object obj)
比较两个 stub 的相等性。

boolean

StubDelegate.equals(Stub self, Object obj)
Stub.equals(java.lang.Object) 的委托调用。

Object

PortableRemoteObjectDelegate.narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。

static void

Util.writeAbstractObject(OutputStream out, Object obj)
将 java.lang.Object 作为一个值或 CORBA Object 写入。

void

UtilDelegate.writeAbstractObject(OutputStream out, Object obj)
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

static void

Util.writeAny(OutputStream out, Object obj)
将 any java.lang.Object 作为 CORBA any 写入。

void

UtilDelegate.writeAny(OutputStream out, Object obj)
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

static void

Util.writeRemoteObject(OutputStream out, Object obj)
将 java.lang.Object 作为 CORBA Object 写入。

void

UtilDelegate.writeRemoteObject(OutputStream out, Object obj)
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

javax.rmi.ssl 中 Object 的使用

javax.rmi.ssl 中 Object 的子类

class

SslRMIClientSocketFactory
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。

class

SslRMIServerSocketFactory
SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。

参数类型为 Object 的 javax.rmi.ssl 中的方法

boolean

SslRMIClientSocketFactory.equals(Object obj)
指示某个其他对象是否“等于”此对象。

boolean

SslRMIServerSocketFactory.equals(Object obj)
指示某个其他对象是否“等于”此对象。

javax.script 中 Object 的使用

javax.script 中 Object 的子类

class

AbstractScriptEngine
为几个 eval 方法的变体提供标准实现。

class

CompiledScript
存储编译结果的类扩展自此类。

class

ScriptEngineManager
ScriptEngineManager 为 ScriptEngine 类实现一个发现和实例化机制，还维护一个键/值对集合来存储所有 Manager 创建的引擎所共享的状态。

class

ScriptException
脚本 API 的一般 Exception 类。

class

SimpleBindings
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。

class

SimpleScriptContext
ScriptContext 的简单实现。

返回 Object 的 javax.script 中的方法

Object

CompiledScript.eval()
执行存储在 CompiledScript 对象中的程序。

Object

CompiledScript.eval(Bindings bindings)
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。

Object

AbstractScriptEngine.eval(Reader reader)
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。

Object

ScriptEngine.eval(Reader reader)
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。

Object

AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。

Object

ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。

Object

ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。

abstract  Object

CompiledScript.eval(ScriptContext context)
执行存储在此 CompiledScript 对象中的程序。

Object

AbstractScriptEngine.eval(String script)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。

Object

ScriptEngine.eval(String script)
执行指定的脚本。

Object

AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。

Object

ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。

Object

ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。

Object

Bindings.get(Object key)
返回此映射将指定键所映射的值。

Object

SimpleBindings.get(Object key)
返回此映射将指定键所映射到的值。

Object

AbstractScriptEngine.get(String key)
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。

Object

ScriptEngine.get(String key)
获取在此引擎的状态中设置的值。

Object

ScriptEngineManager.get(String key)
获取 Global Scope 中指定键的值。

Object

ScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

SimpleScriptContext.getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。

Object

ScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

Object

SimpleScriptContext.getAttribute(String name, int scope)
获取给定范围中某一属性的值。

Object

ScriptEngineFactory.getParameter(String key)
返回属性值，该属性的含义可能是特定于实现的。

Object

Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

Object

Bindings.put(String name, Object value)
设置指定的值。

Object

SimpleBindings.put(String name, Object value)
设置底层 map 字段中的指定键/值。

Object

Bindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

Object

SimpleBindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

Object

ScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

Object

SimpleScriptContext.removeAttribute(String name, int scope)
移除给定范围中的某一属性。

返回变量类型为 Object 的类型的 javax.script 中的方法

Set<Map.Entry<String,Object>>

SimpleBindings.entrySet()
返回此映射中包含的映射关系的 Set 视图。

Collection<Object>

SimpleBindings.values()
返回此映射中包含的值的 Collection 视图。

参数类型为 Object 的 javax.script 中的方法

boolean

Bindings.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

SimpleBindings.containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

boolean

SimpleBindings.containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

Object

Bindings.get(Object key)
返回此映射将指定键所映射的值。

Object

SimpleBindings.get(Object key)
返回此映射将指定键所映射到的值。

<T> T

Invocable.getInterface(Object thiz, Class<T> clasz)
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。

Object

Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

Object

Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

void

AbstractScriptEngine.put(String key, Object value)
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。

Object

Bindings.put(String name, Object value)
设置指定的值。

void

ScriptEngine.put(String key, Object value)
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。

void

ScriptEngineManager.put(String key, Object value)
设置 Global Scope 中指定的键/值对。

Object

SimpleBindings.put(String name, Object value)
设置底层 map 字段中的指定键/值。

Object

Bindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

Object

SimpleBindings.remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。

void

ScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

void

SimpleScriptContext.setAttribute(String name, Object value, int scope)
设置给定范围中某一属性的值。

类型变量类型为 Object 的 javax.script 中的方法参数

void

Bindings.putAll(Map<? extends String,? extends Object> toMerge)
将给定 Map 中的所有映射关系添加到此 Bindings 中。

void

SimpleBindings.putAll(Map<? extends String,? extends Object> toMerge)
putAll 是使用 Map.putAll 实现的。

类型变量类型为 Object 的 javax.script 中的构造方法参数

SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。

javax.security.auth 中 Object 的使用

javax.security.auth 中 Object 的子类

class

AuthPermission
此类用于验证权限。

class

DestroyFailedException
当 destroy 操作失败时，抛出此异常。

class

PrivateCredentialPermission
此类用来保护对属于特定 Subject 的私有 Credential 的访问。

class

RefreshFailedException
当 refresh 操作失败时，抛出此异常。

class

Subject
Subject 表示某一项（如一个人）的一组相关信息。

class

SubjectDomainCombiner
SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。

返回变量类型为 Object 的类型的 javax.security.auth 中的方法

Set<Object>

Subject.getPrivateCredentials()
返回此 Subject 中包含的私有证书 Set。

Set<Object>

Subject.getPublicCredentials()
返回此 Subject 中包含的公开证书 Set。

参数类型为 Object 的 javax.security.auth 中的方法

boolean

PrivateCredentialPermission.equals(Object obj)
检查两个 PrivateCredentialPermission 对象是否相等。

boolean

Subject.equals(Object o)
比较指定对象与此 Subject 的相等性。

javax.security.auth.callback 中 Object 的使用

javax.security.auth.callback 中 Object 的子类

class

ChoiceCallback
底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。

class

ConfirmationCallback
底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。

class

LanguageCallback
底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。

class

NameCallback
底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。

class

PasswordCallback
底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。

class

TextInputCallback
底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。

class

TextOutputCallback
底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。

class

UnsupportedCallbackException
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.kerberos 中 Object 的使用

javax.security.auth.kerberos 中 Object 的子类

class

DelegationPermission
此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。

class

KerberosKey
此类为 Kerberos 主体封装一个长期秘密密钥。

class

KerberosPrincipal
此类封装 Kerberos 主体。

class

KerberosTicket
此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。

class

ServicePermission
此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

参数类型为 Object 的 javax.security.auth.kerberos 中的方法

boolean

DelegationPermission.equals(Object obj)
检查两个 DelegationPermission 对象是否相等。

boolean

KerberosKey.equals(Object other)
比较指定 Object 与此 KerberosKey 的相等性。

boolean

KerberosPrincipal.equals(Object other)
比较指定的对象与此 Principal 是否相等。

boolean

KerberosTicket.equals(Object other)
比较给定 Object 与此 KerberosTicket 的相等性。

boolean

ServicePermission.equals(Object obj)
检查两个 ServicePermission 对象是否相等。

javax.security.auth.login 中 Object 的使用

javax.security.auth.login 中 Object 的子类

class

AccountException
一般的帐户异常。

class

AccountExpiredException
当用户帐户到期时抛出此异常。

class

AccountLockedException
帐户被锁定时抛出此异常。

class

AccountNotFoundException
未找到帐户时抛出此异常。

class

AppConfigurationEntry
此类表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。

static class

AppConfigurationEntry.LoginModuleControlFlag
此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。

class

Configuration
Configuration 对象负责指定应该将哪一个 LoginModule 用于某一特定应用程序，以及应该以什么样的顺序调用 LoginModule。

class

ConfigurationSpi
此类为 Configuration 类定义服务提供者接口（SPI）。

class

CredentialException
一般证书异常。

class

CredentialExpiredException
当 Credential 到期时抛出此异常。

class

CredentialNotFoundException
找不到证书时抛出此异常。

class

FailedLoginException
当用户验证失败时抛出此异常。

class

LoginContext
LoginContext 类描述用于验证 Subjects 的基本方法和提供开发与底层验证技术无关的应用程序的方法。

class

LoginException
此异常是基本的登录异常。

javax.security.auth.x500 中 Object 的使用

javax.security.auth.x500 中 Object 的子类

class

X500Principal
此类表示一个 X.500 Principal。

class

X500PrivateCredential
此类表示一个 X500PrivateCredential。

参数类型为 Object 的 javax.security.auth.x500 中的方法

boolean

X500Principal.equals(Object o)
比较指定的 Object 与此 X500Principal 的相等性。

javax.security.cert 中 Object 的使用

javax.security.cert 中 Object 的子类

class

CertificateEncodingException
证书编码异常。

class

CertificateException
此异常指示各种证书问题之一。

class

CertificateExpiredException
证书过期异常。

class

CertificateNotYetValidException
证书不再有效异常。

class

CertificateParsingException
证书解析异常。

参数类型为 Object 的 javax.security.cert 中的方法

boolean

Certificate.equals(Object other)
比较此证书是否与指定对象相等。

javax.security.sasl 中 Object 的使用

javax.security.sasl 中 Object 的子类

class

AuthenticationException
此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。

class

AuthorizeCallback
此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。

class

RealmCallback
SaslClient 和 SaslServer 使用此回调来获取领域信息。

class

RealmChoiceCallback
SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。

class

Sasl
用于创建 SASL 客户端和服务器的静态类。

class

SaslException
此类表示在使用 SASL 时所发生的错误。

返回 Object 的 javax.security.sasl 中的方法

Object

SaslClient.getNegotiatedProperty(String propName)
获取已协商的属性。

Object

SaslServer.getNegotiatedProperty(String propName)
获取已协商的属性。

javax.sound.midi 中 Object 的使用

javax.sound.midi 中 Object 的子类

class

Instrument
乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。

class

InvalidMidiDataException
一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。

class

MetaMessage
MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。

static class

MidiDevice.Info
一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。

class

MidiEvent
MIDI 事件包含一个 MIDI 消息和一个相应的用刻度表示的时间戳，可代表存储在 MIDI 文件或 Sequence 对象中的 MIDI 事件信息。

class

MidiFileFormat
MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。

class

MidiMessage
MidiMessage 是 MIDI 消息的基类。

class

MidiSystem
MidiSystem 类提供了对已安装的 MIDI 系统资源的访问，包括诸如 synthesizer、sequencer 和 MIDI 输入和输出端口等设备。

class

MidiUnavailableException
当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

class

Patch
一个 Patch 对象，用于表示 MIDI 合成器上的某个位置，其中存储（加载）了单个乐器。

class

Sequence
Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。

static class

Sequencer.SyncMode
SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。

class

ShortMessage
ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。

class

SoundbankResource
SoundbankResource 表示存储在 Soundbank 中的任何音频资源。

class

SysexMessage
表示 MIDI 系统独占消息 SysexMessage 对象。

class

Track
MIDI 音轨是一个可随其他音轨存储在标准 MIDI 文件中的独立的 MIDI 事件流（带时间戳的 MIDI 数据）。

class

VoiceStatus
VoiceStatus 对象包含有关由 Synthesizer 生成的某个声音当前状态的信息。

返回 Object 的 javax.sound.midi 中的方法

Object

MetaMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

abstract  Object

MidiMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

ShortMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

Object

SysexMessage.clone()
创建一个与此对象具有相同类和相同内容的新对象。

abstract  Object

SoundbankResource.getData()
获得存储在此 SoundbankResource 中的采样音频。

Object

MidiFileFormat.getProperty(String key)
获得由键指定的属性值。

返回变量类型为 Object 的类型的 javax.sound.midi 中的方法

Map<String,Object>

MidiFileFormat.properties()
获得属性的一个不可修改的映射。

参数类型为 Object 的 javax.sound.midi 中的方法

boolean

MidiDevice.Info.equals(Object obj)
报告两个对象是否相等。

boolean

Sequencer.SyncMode.equals(Object obj)
确定两个对象是否等价。

类型变量类型为 Object 的 javax.sound.midi 中的构造方法参数

MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。

javax.sound.midi.spi 中 Object 的使用

javax.sound.midi.spi 中 Object 的子类

class

MidiDeviceProvider
MidiDeviceProvider 是特定类型的 MIDI 设备的工厂或提供者。

class

MidiFileReader
MidiFileReader 提供 MIDI 文件读取服务。

class

MidiFileWriter
MidiFileWriter 提供 MIDI 文件写入服务。

class

SoundbankReader
SoundbankReader 提供音库文件读取服务。

javax.sound.sampled 中 Object 的使用

javax.sound.sampled 中 Object 的子类

class

AudioFileFormat
AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。

static class

AudioFileFormat.Type
Type 类的实例表示音频文件的标准类型之一。

class

AudioFormat
AudioFormat 是在声音流中指定特定数据安排的类。

static class

AudioFormat.Encoding
Encoding 类命名用于音频流的数据表示形式的特定类型。

class

AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。

class

AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

class

AudioSystem
AudioSystem 类充当取样音频系统资源的入口点。

class

BooleanControl
BooleanControl 能够在影响行音频的两个可能的设置之间切换。

static class

BooleanControl.Type
BooleanControl.Type 类的实例标识一种 boolean 控件。

class

CompoundControl
CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。

static class

CompoundControl.Type
CompoundControl.Type 内部类的实例标识一种组合控件。

class

Control
Line 常常具有一个控件（如 gain 和 pan）集合，这些控件都会影响通过行传递的音频信号。

static class

Control.Type
Type 类的实例表示控件的类型。

static class

DataLine.Info
除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。

class

EnumControl
EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。

static class

EnumControl.Type
EnumControl.Type 内部类的实例标识了某种枚举控件。

class

FloatControl
FloatControl 对象提供对浮点值范围的控制。

static class

FloatControl.Type
FloatControl.Type 内部类的实例标识了某种 float 控件。

static class

Line.Info
Line.Info 对象包含关于行的信息。

class

LineEvent
LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。

static class

LineEvent.Type
该 LineEvent.Type 内部类标识行上所发生事件的种类。

class

LineUnavailableException
LineUnavailableException 是指示某一行因为不可用而无法打开的异常。

static class

Mixer.Info
Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。

static class

Port.Info
该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。

class

ReverbType
ReverbType 类提供用于访问应用于音频信号的各种回响设置的方法。

class

UnsupportedAudioFileException
UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

返回 Object 的 javax.sound.sampled 中的方法

Object

AudioFileFormat.getProperty(String key)
获得键指定的属性值。

Object

AudioFormat.getProperty(String key)
获取键指定的属性值。

Object

EnumControl.getValue()
获得此控件的当前值。

Object[]

EnumControl.getValues()
返回此控件的可能值的集合。

返回变量类型为 Object 的类型的 javax.sound.sampled 中的方法

Map<String,Object>

AudioFileFormat.properties()
获得不可修改的属性映射。

Map<String,Object>

AudioFormat.properties()
获取不可修改的属性映射。

参数类型为 Object 的 javax.sound.sampled 中的方法

boolean

AudioFileFormat.Type.equals(Object obj)
终止 equals 方法

boolean

AudioFormat.Encoding.equals(Object obj)
终止 equals 方法

boolean

Control.Type.equals(Object obj)
终止 equals 方法

boolean

LineEvent.Type.equals(Object obj)
指示指定对象是否等于此事件类型，如果对象是相同的，则返回 true。

boolean

Mixer.Info.equals(Object obj)
指示两个 info 对象是否相等；如果相等，则返回 true。

boolean

Port.Info.equals(Object obj)
终止 equals 方法

boolean

ReverbType.equals(Object obj)
指示指定对象是否等于此回响类型，如果对象相同，则返回 true。

void

EnumControl.setValue(Object value)
设置控件的当前值。

参数类型为 Object 的 javax.sound.sampled 中的构造方法

EnumControl(EnumControl.Type type, Object[] values, Object value)
构造一个具有给定参数的新枚举控件对象。

EnumControl(EnumControl.Type type, Object[] values, Object value)
构造一个具有给定参数的新枚举控件对象。

类型变量类型为 Object 的 javax.sound.sampled 中的构造方法参数

AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。

AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sound.sampled.spi 中 Object 的使用

javax.sound.sampled.spi 中 Object 的子类

class

AudioFileReader
音频文件读取服务的提供者。

class

AudioFileWriter
音频文件写入服务的提供者。

class

FormatConversionProvider
格式转换提供者提供从一种或多种输入格式到一种或多种输出格式的格式转换服务。

class

MixerProvider
特定的混频器类型的提供者和工厂。

javax.sql 中 Object 的使用

javax.sql 中 Object 的子类

class

ConnectionEvent
提供关于连接相关事件的源信息的 Event 对象。

class

RowSetEvent
RowSet 对象发生事件时生成的 Event 对象。

class

StatementEvent
StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。

返回 Object 的 javax.sql 中的方法

Object[]

RowSetInternal.getParams()
获取已为此 RowSet 对象的命令设置的参数。

参数类型为 Object 的 javax.sql 中的方法

void

RowSet.setObject(int parameterIndex, Object x)
使用 Java Object 设置此 RowSet 对象命令中的指定参数。

void

RowSet.setObject(int parameterIndex, Object x, int targetSqlType)
使用 Java Object 设置此 RowSet 对象命令中的指定参数。

void

RowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。

void

RowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

RowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

javax.sql.rowset 中 Object 的使用

javax.sql.rowset 中 Object 的子类

class

BaseRowSet
提供一个具有基本功能的 RowSet 对象的抽象类。

class

RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

class

RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

返回 Object 的 javax.sql.rowset 中的方法

Object[]

BaseRowSet.getParams()
获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。

参数类型为 Object 的 javax.sql.rowset 中的方法

boolean

Predicate.evaluate(Object value, int column)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。

boolean

Predicate.evaluate(Object value, String columnName)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。

void

BaseRowSet.setObject(int parameterIndex, Object x)
将指定参数设置为 Java 编程语言中的 Object。

void

BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定 Object 值设置指定参数的值。

void

BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scale)
将指定参数设置为 Java 编程语言中的 Object。

void

BaseRowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。

void

BaseRowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。

javax.sql.rowset.serial 中 Object 的使用

javax.sql.rowset.serial 中 Object 的子类

class

SerialArray
序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。

class

SerialBlob
SQL BLOB 值在 Java 编程语言中的序列化映射关系。

class

SerialClob
SQL CLOB 值在 Java 编程语言中的序列化映射关系。

class

SerialDatalink
SQL DATALINK 值在 Java 编程语言中的序列化映射关系。

class

SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

class

SerialJavaObject
SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。

class

SerialRef
Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。

class

SerialStruct
SQL 结构类型在 Java 编程语言中的序列化映射关系。

class

SQLInputImpl
用于自定义映射用户定义类型 (UDT) 的输入流。

class

SQLOutputImpl
用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。

返回 Object 的 javax.sql.rowset.serial 中的方法

Object

SerialArray.getArray()
返回一个新数组，它是此 SerialArray 对象的副本。

Object

SerialArray.getArray(long index, int count)
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

Object

SerialArray.getArray(long index, int count, Map<String,Class<?>> map)
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

Object

SerialArray.getArray(Map<String,Class<?>> map)
返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。

Object[]

SerialStruct.getAttributes()
获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。

Object[]

SerialStruct.getAttributes(Map<String,Class<?>> map)
获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。

Object

SerialJavaObject.getObject()
返回一个 Object，它是此 SerialJavaObject 对象的副本。

Object

SerialRef.getObject()
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。

Object

SerialRef.getObject(Map<String,Class<?>> map)
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。

Object

SQLInputImpl.readObject()
以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。

参数类型为 Object 的 javax.sql.rowset.serial 中的方法

void

SerialRef.setObject(Object obj)
将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。

参数类型为 Object 的 javax.sql.rowset.serial 中的构造方法

SerialJavaObject(Object obj)
SerialJavaObject 帮助器类的构造方法。

SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。

javax.sql.rowset.spi 中 Object 的使用

javax.sql.rowset.spi 中 Object 的子类

class

SyncFactory
该服务提供者接口 (SPI) 机制可以生成由非连接 RowSet 对象使用的 SyncProvider 实例。

class

SyncFactoryException
指示 SyncFactory 机制发生的错误。

class

SyncProvider
为非连接 RowSet 对象提供 reader/writer 功能的同步机制。

class

SyncProviderException
指示 SyncProvider 机制发生的错误。

返回 Object 的 javax.sql.rowset.spi 中的方法

Object

SyncResolver.getConflictValue(int index)
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

Object

SyncResolver.getConflictValue(String columnName)
获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

参数类型为 Object 的 javax.sql.rowset.spi 中的方法

void

SyncResolver.setResolvedValue(int index, Object obj)
将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。

void

SyncResolver.setResolvedValue(String columnName, Object obj)
将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。

javax.swing 中 Object 的使用

javax.swing 中 Object 的子类

class

AbstractAction
此类提供 JFC Action 接口的默认实现。

class

AbstractButton
定义按钮和菜单项的一般行为。

protected  class

AbstractButton.AccessibleAbstractButton
此类实现对 AbstractButton 类的可访问性支持。

protected  class

AbstractButton.ButtonChangeListener
将 ChangeListener 扩展为可序列化的。

class

AbstractCellEditor

class

AbstractListModel
该数据模型的抽象定义提供一个带内容的 List。

class

AbstractSpinnerModel
此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。

class

ActionMap
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。

class

BorderFactory
提供标准 Border 对象的工厂类。

class

Box
使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。

protected  class

Box.AccessibleBox
此类实现 Box 类的可访问性支持。

static class

Box.Filler
参与布局但没有视图的轻量级组件的实现。

protected  class

Box.Filler.AccessibleBoxFiller
此类实现 Box.Filler 类的可访问性支持。

class

BoxLayout
允许垂直或水平布置多个组件的布局管理器。

class

ButtonGroup
此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。

class

CellRendererPane
此类被插入在单元格渲染器与使用它们的组件之间。

protected  class

CellRendererPane.AccessibleCellRendererPane
此类实现 Panel 类的可访问性支持。

class

ComponentInputMap
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。

class

DebugGraphics
支持图形调试的图形子类。

class

DefaultBoundedRangeModel
BoundedRangeModel 的一般实现。

class

DefaultButtonModel
Button 组件的数据模型的默认实现。

class

DefaultCellEditor
表单元格和树单元格的默认编辑器。

protected  class

DefaultCellEditor.EditorDelegate
受保护的 (protected) EditorDelegate 类。

class

DefaultComboBoxModel
组合框的默认模型。

class

DefaultDesktopManager
此类是 DesktopManager 的实现。

class

DefaultFocusManager
此类已被废弃，用 1.4 focus API 取代。

class

DefaultListCellRenderer
呈现列表中的一个项。

static class

DefaultListCellRenderer.UIResource
实现 UIResource 的 DefaultListCellRenderer 的子类。

class

DefaultListModel
此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。

class

DefaultListSelectionModel
列表选择的默认数据模型。

class

DefaultRowSorter<M,I>
RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。

protected static class

DefaultRowSorter.ModelWrapper<M,I>
DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。

class

DefaultSingleSelectionModel
SingleSelectionModel 的一般实现。

class

FocusManager
从 1.4 focus API 开始，此类已被废弃。

class

GrayFilter
一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。

class

GroupLayout
GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。

class

GroupLayout.Group
Group 为 GroupLayout 所支持的以下两种操作提供基础：一个接一个地布置组件（SequentialGroup）或对齐组件（ParallelGroup）。

class

GroupLayout.ParallelGroup
一个 Group，它对齐其子元素并确定其大小。

class

GroupLayout.SequentialGroup
一个 Group，它按顺序一个接一个地确定其元素的位置和大小。

class

ImageIcon
一个 Icon 接口的实现，它根据 Image 绘制 Icon。

protected  class

ImageIcon.AccessibleImageIcon
此类实现 ImageIcon 类的可访问性支持。

class

InputMap
InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。

class

InputVerifier
此类的用途是通过带文本字段的 GUI 帮助客户端支持流畅的焦点导航。

class

InternalFrameFocusTraversalPolicy
该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。

class

JApplet
java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。

protected  class

JApplet.AccessibleJApplet
此类实现对 JApplet 类的可访问性支持。

class

JButton
"push" 按钮的实现。

protected  class

JButton.AccessibleJButton
此类实现对 JButton 类的可访问性支持。

class

JCheckBox
复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。

protected  class

JCheckBox.AccessibleJCheckBox
此类实现对 JCheckBox 类的可访问性支持。

class

JCheckBoxMenuItem
可以被选定或取消选定的菜单项。

protected  class

JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
此类实现对 JCheckBoxMenuItem 类的可访问性支持。

class

JColorChooser
JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。

protected  class

JColorChooser.AccessibleJColorChooser
此类实现对 JColorChooser 类的可访问性支持。

class

JComboBox
将按钮或可编辑字段与下拉列表组合的组件。

protected  class

JComboBox.AccessibleJComboBox
此类实现 JComboBox 类的可访问性支持。

class

JComponent
该类是除顶层容器外所有 Swing 组件的基类。

class

JComponent.AccessibleJComponent
用于为可访问性提供默认支持的 JComponent 内部类。

protected  class

JComponent.AccessibleJComponent.AccessibleContainerHandler
添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

protected  class

JComponent.AccessibleJComponent.AccessibleFocusHandler
发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

class

JDesktopPane
用于创建多文档界面或虚拟桌面的容器。

protected  class

JDesktopPane.AccessibleJDesktopPane
此类实现对 JDesktopPane 类的可访问性支持。

class

JDialog
创建对话框窗口的主要类。

protected  class

JDialog.AccessibleJDialog
此类实现对 JDialog 类的可访问性支持。

class

JEditorPane
可编辑各种内容的文本组件。

protected  class

JEditorPane.AccessibleJEditorPane
此类实现对 JEditorPane 类的可访问性支持。

protected  class

JEditorPane.AccessibleJEditorPaneHTML
此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。

protected  class

JEditorPane.JEditorPaneAccessibleHypertextSupport
AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。

class

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

class

JFileChooser
JFileChooser 为用户选择文件提供了一种简单的机制。

protected  class

JFileChooser.AccessibleJFileChooser
此类实现对 JFileChooser 类的可访问性支持。

class

JFormattedTextField
JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。

static class

JFormattedTextField.AbstractFormatter
JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。

static class

JFormattedTextField.AbstractFormatterFactory
JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。

class

JFrame
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。

protected  class

JFrame.AccessibleJFrame
此类实现对 JFrame 类的可访问性支持。

class

JInternalFrame
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。

protected  class

JInternalFrame.AccessibleJInternalFrame
此类实现对 JInternalFrame 类的可访问性支持。

static class

JInternalFrame.JDesktopIcon
此组件表示 JInternalFrame 的图标化版本。

protected  class

JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。

class

JLabel
用于短文本字符串或图像或二者的显示区。

protected  class

JLabel.AccessibleJLabel
该类用于获得此对象的可访问性职责。

class

JLayeredPane
JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。

protected  class

JLayeredPane.AccessibleJLayeredPane
此类实现对 JLayeredPane 类的可访问性支持。

class

JList
显示对象列表并且允许用户选择一个或多个项的组件。

protected  class

JList.AccessibleJList
此类实现 JList 类的可访问性支持。

protected  class

JList.AccessibleJList.AccessibleJListChild
此类实现供 List 子级使用的可访问性支持。

static class

JList.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。

class

JMenu
菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。

protected  class

JMenu.AccessibleJMenu
此类实现 JMenu 类的可访问性支持。

protected  class

JMenu.WinListener
观察弹出窗口关闭的侦听器类。

class

JMenuBar
菜单栏的实现。

protected  class

JMenuBar.AccessibleJMenuBar
此类实现 JMenuBar 类的可访问性支持。

class

JMenuItem
菜单中的项的实现。

protected  class

JMenuItem.AccessibleJMenuItem
此类实现 JMenuItem 类的可访问性支持。

class

JOptionPane
JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。

protected  class

JOptionPane.AccessibleJOptionPane
此类实现对 JOptionPane 类的可访问性支持。

class

JPanel
JPanel 是一般轻量级容器。

protected  class

JPanel.AccessibleJPanel
此类实现对 JPanel 类的可访问性支持。

class

JPasswordField
JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。

protected  class

JPasswordField.AccessibleJPasswordField
此类实现对 JPasswordField 类的可访问性支持。

class

JPopupMenu
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。

protected  class

JPopupMenu.AccessibleJPopupMenu
此类实现 JPopupMenu 类的可访问性支持。

static class

JPopupMenu.Separator
弹出与菜单有关的分隔符。

class

JProgressBar
以可视化形式显示某些任务进度的组件。

protected  class

JProgressBar.AccessibleJProgressBar
此类实现 JProgressBar 类的可访问性支持。

class

JRadioButton
实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。

protected  class

JRadioButton.AccessibleJRadioButton
此类实现对 JRadioButton 类的可访问性支持。

class

JRadioButtonMenuItem
一个单选按钮菜单项的实现。

protected  class

JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
此类实现对 JRadioButtonMenuItem 类的可访问性支持。

class

JRootPane
该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。

protected  class

JRootPane.AccessibleJRootPane
此类实现对 JRootPane 类的可访问性支持。

protected  class

JRootPane.RootLayout
该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。

class

JScrollBar
滚动条的实现。

protected  class

JScrollBar.AccessibleJScrollBar
此类实现 JScrollBar 类的可访问性支持。

class

JScrollPane
提供轻量级组件的 scrollable 视图。

protected  class

JScrollPane.AccessibleJScrollPane
此类实现 JScrollPane 类的可访问性支持。

protected  class

JScrollPane.ScrollBar
默认情况下，JScrollPane 创建的滚动条为此类的实例。

class

JSeparator
JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。

protected  class

JSeparator.AccessibleJSeparator
此类实现 JSeparator 类的可访问性支持。

class

JSlider
一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。

protected  class

JSlider.AccessibleJSlider
此类实现 JSlider 类的可访问性支持。

class

JSpinner
让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。

protected  class

JSpinner.AccessibleJSpinner
AccessibleJSpinner 实现 JSpinner 类的可访问性支持。

static class

JSpinner.DateEditor
其模型为 SpinnerDateModel 的 JSpinner 编辑器。

static class

JSpinner.DefaultEditor
一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。

static class

JSpinner.ListEditor
其模型为 SpinnerListModel 的 JSpinner 编辑器。

static class

JSpinner.NumberEditor
其模型为 SpinnerNumberModel 的 JSpinner 编辑器。

class

JSplitPane
JSplitPane 用于分隔两个（只能两个）Component。

protected  class

JSplitPane.AccessibleJSplitPane
此类实现 JSplitPane 类的可访问性支持。

class

JTabbedPane
一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。

protected  class

JTabbedPane.AccessibleJTabbedPane
此类实现对 JTabbedPane 类的可访问性支持。

protected  class

JTabbedPane.ModelListener
将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。

class

JTable
JTable 用来显示和编辑常规二维单元表。

protected  class

JTable.AccessibleJTable
此类实现对 JTable 类的可访问性支持。

protected  class

JTable.AccessibleJTable.AccessibleJTableCell
此类提供了适用于表单元格的 Java Accessibility API 实现。

protected  class

JTable.AccessibleJTable.AccessibleJTableModelChange

static class

JTable.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。

class

JTextArea
JTextArea 是一个显示纯文本的多行区域。

protected  class

JTextArea.AccessibleJTextArea
此类实现对 JTextArea 类的可访问性支持。

class

JTextField
JTextField 是一个轻量级组件，它允许编辑单行文本。

protected  class

JTextField.AccessibleJTextField
此类实现对 JTextField 类的可访问性支持。

class

JTextPane
可以用以图形方式表示的属性来标记的文本组件。

class

JToggleButton
具有两个状态的（two-state）按钮的实现。

protected  class

JToggleButton.AccessibleJToggleButton
此类实现对 JToggleButton 类的可访问性支持。

static class

JToggleButton.ToggleButtonModel
ToggleButton 模型。

class

JToolBar
JToolBar 提供了一个用来显示常用的 Action 或控件的组件。

protected  class

JToolBar.AccessibleJToolBar
此类实现对 JToolBar 类的可访问性支持。

static class

JToolBar.Separator
一个特定于工具栏的分隔符。

class

JToolTip
用来显示 Component 的“提示”。

protected  class

JToolTip.AccessibleJToolTip
此类实现对 JToolTip 类的可访问性支持。

class

JTree
将分层数据集显示为轮廓的控件。

protected  class

JTree.AccessibleJTree
此类实现 JTree 类的可访问性支持。

protected  class

JTree.AccessibleJTree.AccessibleJTreeNode
此类实现 JTree 子类的可访问性支持。

static class

JTree.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。

static class

JTree.DynamicUtilTreeNode
DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。

protected static class

JTree.EmptySelectionModel
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。

protected  class

JTree.TreeModelHandler
在移除或更改节点时，监听模型并相应地更新 expandedState。

protected  class

JTree.TreeSelectionRedirector
使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。

class

JViewport
用于查看底层信息的“视口”或“观察孔”。

protected  class

JViewport.AccessibleJViewport
此类实现对 JViewport 类的可访问性支持。

protected  class

JViewport.ViewListener
视图的侦听器。

class

JWindow
JWindow 是一个容器，可以显示在用户桌面上的任何位置。

protected  class

JWindow.AccessibleJWindow
此类实现对 JWindow 类的可访问性支持。

class

KeyStroke
表示键盘或等效输入设置上的键操作的 KeyStroke。

class

LayoutFocusTraversalPolicy
根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。

class

LayoutStyle
LayoutStyle 提供有关如何确定组件位置的信息。

class

LookAndFeel
顾名思义，LookAndFeel 封装了一个外观。

class

MenuSelectionManager
MenuSelectionManager 拥有菜单层次结构中的选项。

class

OverlayLayout
要在彼此顶部安排组件的布局管理器。

class

Popup
Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。

class

PopupFactory
顾名思义，PopupFactory 用于获取 Popup 的实例。

class

ProgressMonitor
监视某个操作的进度的类。

protected  class

ProgressMonitor.AccessibleProgressMonitor
AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

class

ProgressMonitorInputStream
监视读取某些 InputStream 的进度。

class

RepaintManager
此类管理重绘请求，以最大限度地降低重绘次数。

class

RowFilter<M,I>
RowFilter 用于从模型中过滤条目，使得这些条目不会在视图中显示。

static class

RowFilter.Entry<M,I>
一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。

class

RowSorter<M>
RowSorter 提供排序和过滤的基础。

static class

RowSorter.SortKey
SortKey 描述特定列的排序顺序。

class

ScrollPaneLayout
JScrollPane 使用的布局管理器。

static class

ScrollPaneLayout.UIResource
ScrollPaneLayout 的 UI 资源版本。

class

SizeRequirements
为方便布局管理器，计算组件的有关大小和位置信息。

class

SizeSequence
一个 SizeSequence 对象，它有效地维护一个包含大小和相应位置的顺序列表。

class

SortingFocusTraversalPolicy
通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。

class

SpinnerDateModel
Date 序列的一个 SpinnerModel。

class

SpinnerListModel
其值由数组或 List 定义的 SpinnerModel 的简单实现。

class

SpinnerNumberModel
用于数字序列的 SpinnerModel。

class

Spring
该 Spring 类的实例将存储以下三个表示其行为特征的属性：minimum、preferred 和 maximum 值。

class

SpringLayout
SpringLayout 根据一组约束布置其相关容器的子组件。

static class

SpringLayout.Constraints
Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。

class

SwingUtilities
Swing 实用方法的集合。

class

SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

class

ToolTipManager
管理系统中的所有 ToolTips。

protected  class

ToolTipManager.insideTimerAction

protected  class

ToolTipManager.outsideTimerAction

protected  class

ToolTipManager.stillInsideTimerAction

class

TransferHandler
此类用于处理往返于 Swing 组件的 Transferable 的传输。

static class

TransferHandler.DropLocation
表示放置的数据 (dropped data) 应该插入的位置。

static class

TransferHandler.TransferSupport
此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。

class

UIDefaults
Swing 组件的默认值表。

static class

UIDefaults.LazyInputMap
LazyInputMap 将在其 createValue 方法中创建一个 InputMap。

static class

UIDefaults.ProxyLazyValue
此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。

class

UIManager
UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。

static class

UIManager.LookAndFeelInfo
为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。

class

UnsupportedLookAndFeelException
指示在用户系统上不存在请求的外观管理类的异常。

class

ViewportLayout
JViewport 的默认布局管理器。

声明为 Object 的 javax.swing 中的字段

protected  Object

JTree.DynamicUtilTreeNode.childValue
用于创建子节点的值。

protected  Object

JOptionPane.initialSelectionValue
要在 selectionValues 中选择的初始值。

protected  Object

JOptionPane.initialValue
应该在 options 中最初选择的值。

protected  Object

JOptionPane.inputValue
用户已输入的值。

protected  Object

JOptionPane.message
要显示的消息。

protected  Object[]

JOptionPane.options
要向用户显示的选项。

protected  Object

JComboBox.selectedItemReminder
此受保护字段是特定于实现的。

protected  Object[]

JOptionPane.selectionValues
用户可以从中选择值的数组。

static Object

JOptionPane.UNINITIALIZED_VALUE
指示用户尚未选择值。

protected  Object

JOptionPane.value
当前选择的值，该值将为有效选项或者 UNINITIALIZED_VALUE 或 null。

protected  Object

DefaultCellEditor.EditorDelegate.value
此单元格的值。

返回 Object 的 javax.swing 中的方法

Object[]

ActionMap.allKeys()
返回在此 ActionMap 及其父级中定义的键所组成的数组。

protected  Object

JFormattedTextField.AbstractFormatter.clone()
复制 AbstractFormatter。

protected  Object

AbstractAction.clone()
复制抽象操作。

Object

DefaultListSelectionModel.clone()
返回此选择模型的具有相同选择的副本。

Object

UIDefaults.LazyValue.createValue(UIDefaults table)
创建从 UIDefaults 表中检索的实际值。

Object

UIDefaults.ActiveValue.createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。

Object

UIDefaults.ProxyLazyValue.createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。

Object

UIDefaults.LazyInputMap.createValue(UIDefaults table)
使用传入的绑定创建一个 InputMap。

Object

DefaultListModel.elementAt(int index)
返回指定索引处的组件。

Object

DefaultListModel.firstElement()
返回此列表中的第一个组件。

Object

DefaultListModel.get(int index)
返回列表中指定位置处的元素。

Object

InputMap.get(KeyStroke keyStroke)
返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。

Object

UIDefaults.get(Object key)
返回键的值。

static Object

UIManager.get(Object key)
从默认值中返回一个对象。

Object

UIDefaults.get(Object key, Locale l)
返回与给定语言环境相关的那些键的值。

static Object

UIManager.get(Object key, Locale l)
从适合给定语言环境的默认值中返回一个对象。

Object

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionAnchor(int i)
返回表示适合于该链接的链接锚点的对象。

Object

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink.getAccessibleActionObject(int i)
返回表示该链接的 URL 对象。

Object

DefaultCellEditor.getCellEditorValue()
将消息从 CellEditor 转发到 delegate。

Object

DefaultCellEditor.EditorDelegate.getCellEditorValue()
返回此单元格的值。

Object

CellEditor.getCellEditorValue()
返回编辑器中包含的值。

Object

JComponent.getClientProperty(Object key)
返回具有指定键的属性的值。

static Object

LookAndFeel.getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。

Object

DefaultListModel.getElementAt(int index)
返回指定索引处的组件。

Object

DefaultComboBoxModel.getElementAt(int index)

Object

ListModel.getElementAt(int index)
返回指定索引处的值。

Object

JOptionPane.getInitialSelectionValue()
返回（根据最初选择）向用户显示的输入值。

Object

JOptionPane.getInitialValue()
返回初始值。

Object

JOptionPane.getInputValue()
如果 wantsInput 为 true，则返回用户已输入的值。

Object

ComboBoxEditor.getItem()
返回已编辑项。

Object

JComboBox.getItemAt(int index)
返回指定索引处的列表项。

Object[]

AbstractAction.getKeys()
返回 Object 的数组，这些对象是一些已经为其设置此 AbstractAction 值的键，如果没有已经设置该值的键，则返回 null。

Object

JTree.getLastSelectedPathComponent()
返回当前选择的第一个节点中的最后一个路径组件。

Object

JOptionPane.getMessage()
返回此窗格显示的消息对象。

Object

JSpinner.getNextValue()
返回序列中由 getValue() 所返回的对象之后的对象。

Object

SpinnerDateModel.getNextValue()
返回序列中的下一个 Date，如果下一个日期在 end 之后，则返回 null。

Object

SpinnerListModel.getNextValue()
返回基础序列的下一个合法值，如果值已经是最后一个元素，则返回 null。

Object

SpinnerModel.getNextValue()
返回该序列中出现在 getValue() 返回的对象之后的对象。

Object

SpinnerNumberModel.getNextValue()
返回该序列中的下一个数字。

Object[]

JOptionPane.getOptions()
返回用户可以作出的选择。

Object

JSpinner.getPreviousValue()
返回序列中由 getValue() 所返回对象之前的对象。

Object

SpinnerDateModel.getPreviousValue()
返回序列中上一个 Date，如果上一个日期是在 start 之前，则返回 null。

Object

SpinnerListModel.getPreviousValue()
返回该基础序列的前一个元素，如果值已经是第一个元素，则返回 null。

Object

SpinnerModel.getPreviousValue()
返回该序列中出现在 getValue() 返回的对象之前的对象。

Object

SpinnerNumberModel.getPreviousValue()
返回该序列中的上一个数字。

Object

JList.getPrototypeCellValue()
返回“原型的”单元值，即用于计算单元的固定宽度和高度的值。

Object

JComboBox.getPrototypeDisplayValue()
返回“原型显示”值，即用于计算显示高度和宽度的 Object。

Object

DefaultComboBoxModel.getSelectedItem()

Object

ComboBoxModel.getSelectedItem()
返回选择的项

Object

JComboBox.getSelectedItem()
返回当前所选项。

Object[]

JComboBox.getSelectedObjects()
返回包含所选项的数组。

Object[]

DefaultButtonModel.getSelectedObjects()
重写以返回 null。

Object[]

JCheckBoxMenuItem.getSelectedObjects()
返回包含复选框菜单项标签的数组 (length 1)，如果没有选定复选框，则返回 null。

Object[]

AbstractButton.getSelectedObjects()
返回包含标签的数组（长度为 1），如果没有选择按钮，则返回 null。

Object

JList.getSelectedValue()
返回最小的选择单元索引的值；只选择了列表中单个项时，返回所选值。

Object[]

JList.getSelectedValues()
返回所有选择值的数组，根据其列表中的索引顺序按升序排序。

Object[]

JOptionPane.getSelectionValues()
返回输入选择值。

Object

JFormattedTextField.getValue()
返回最后一个有效值。

Object

JOptionPane.getValue()
返回用户所选值。

Object

JSpinner.getValue()
返回模型的当前值，通常此值是 editor 所显示的值。

Object

SpinnerDateModel.getValue()
返回此 Date 序列中的当前元素。

Object

SpinnerListModel.getValue()
返回该序列的当前元素。

Object

SpinnerModel.getValue()
该序列的当前元素。

Object

SpinnerNumberModel.getValue()
返回该序列的当前元素的值。

abstract  Object

RowFilter.Entry.getValue(int index)
返回指定索引处的值。

Object

AbstractAction.getValue(String key)
获得与指定键关联的 Object。

Object

Action.getValue(String key)
使用关联的键获取此对象的一个属性。

abstract  Object

DefaultRowSorter.ModelWrapper.getValueAt(int row, int column)
返回指定索引处的值。

Object

JTable.getValueAt(int row, int column)
返回 row 和 column 位置的单元格值。

Object[]

ActionMap.keys()
返回此 ActionMap 中绑定的 Action 名称。

Object

DefaultListModel.lastElement()
返回列表的最后一个组件。

static Object

LookAndFeel.makeIcon(Class<?> baseClass, String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。

Object

UIDefaults.put(Object key, Object value)
将 key 值设置为所有语言环境的 value。

static Object

UIManager.put(Object key, Object value)
在开发人员默认值中存储一个对象。

Object

DefaultListModel.remove(int index)
移除此列表中指定位置处的元素。

Object

DefaultListModel.set(int index, Object element)
使用指定元素替换此列表中指定位置上的元素。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

abstract  Object

JFormattedTextField.AbstractFormatter.stringToValue(String text)
分析 text，返回任意 Object。

Object[]

DefaultListModel.toArray()
以正确顺序返回包含此列表中所有元素的数组。

参数类型为 Object 的 javax.swing 中的方法

void

JTabbedPane.add(Component component, Object constraints)
将一个 component 添加到选项卡窗格中。

void

JTabbedPane.add(Component component, Object constraints, int index)
在指定的选项卡索引位置添加一个 component。

void

DefaultListModel.add(int index, Object element)
在此列表的指定位置处插入指定元素。

void

DefaultListModel.addElement(Object obj)
将指定组件添加到此类表的末尾。

void

DefaultComboBoxModel.addElement(Object anObject)

void

MutableComboBoxModel.addElement(Object obj)
在模型的末尾添加项。

protected  void

JDesktopPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上。

protected  void

JApplet.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

JWindow.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

JViewport.addImpl(Component child, Object constraints, int index)
设置 JViewport 的轻量子对象，可以为 null。

protected  void

CellRendererPane.addImpl(Component x, Object constraints, int index)
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。

protected  void

JSplitPane.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此分隔窗格。

protected  void

JToolBar.addImpl(Component comp, Object constraints, int index)
在添加 JButton 时，它最初被设置为 disabled。

protected  void

JDialog.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

AbstractButton.addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。

protected  void

JInternalFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

protected  void

JLayeredPane.addImpl(Component comp, Object constraints, int index)

protected  void

JRootPane.addImpl(Component comp, Object constraints, int index)
重写以便将玻璃组件的位置强行设置成零位子级。

protected  void

JFrame.addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。

void

JComboBox.addItem(Object anObject)
为项列表添加项。

void

GroupLayout.addLayoutComponent(Component component, Object constraints)
已将 Component 添加到父容器的通知。

void

OverlayLayout.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。

void

SpringLayout.addLayoutComponent(Component component, Object constraints)
如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。

void

BoxLayout.addLayoutComponent(Component comp, Object constraints)
此类不使用。

void

JRootPane.RootLayout.addLayoutComponent(Component comp, Object constraints)

void

JComboBox.configureEditor(ComboBoxEditor anEditor, Object anItem)
利用指定项初始化编辑器。

boolean

DefaultListModel.contains(Object elem)
测试指定对象是否为此类表中的组件。

String

JTree.convertValueToText(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
通过渲染器调用以将指定值转换为文本。

void

DefaultListModel.copyInto(Object[] anArray)
将此列表的组件复制到指定数组中。

static void

JTree.DynamicUtilTreeNode.createChildren(DefaultMutableTreeNode parent, Object children)
将 children 中的所有子节点添加到父节点。

protected static TreeModel

JTree.createTreeModel(Object value)
返回一个 TreeModel，它包装指定的对象。

boolean

RowSorter.SortKey.equals(Object o)
如果此对象与指定对象相等，则返回 true。

protected  void

AbstractListModel.fireContentsChanged(Object source, int index0, int index1)
AbstractListModel 子类必须在列表的一个或多个元素发生更改之后调用此方法。

protected  void

AbstractListModel.fireIntervalAdded(Object source, int index0, int index1)
AbstractListModel 子类必须在将一个或多个元素添加到模型中之后调用此方法。

protected  void

AbstractListModel.fireIntervalRemoved(Object source, int index0, int index1)
AbstractListModel 子类必须在从模型中移除一个或多个元素之后调用此方法。

void

SwingWorker.firePropertyChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定属性更新。

protected  void

AbstractAction.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定 (bound) 属性的改变。

protected  void

JViewport.firePropertyChange(String propertyName, Object oldValue, Object newValue)
通知侦听器发生的属性更改。

protected  void

DefaultListCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

protected  void

UIDefaults.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定属性更改。

protected  void

JComponent.fireVetoableChange(String propertyName, Object oldValue, Object newValue)
支持报告约束 (constrained) 属性的更改。

Action

ActionMap.get(Object key)
返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。

Object

UIDefaults.get(Object key)
返回键的值。

static Object

UIManager.get(Object key)
从默认值中返回一个对象。

Object

UIDefaults.get(Object key, Locale l)
返回与给定语言环境相关的那些键的值。

static Object

UIManager.get(Object key, Locale l)
从适合给定语言环境的默认值中返回一个对象。

boolean

UIDefaults.getBoolean(Object key)
如果 key 是 boolean 值，则返回该 boolean 值，否则返回 false。

static boolean

UIManager.getBoolean(Object key)
从与键值相关的默认值中返回一个布尔变量。

boolean

UIDefaults.getBoolean(Object key, Locale l)
如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。

static boolean

UIManager.getBoolean(Object key, Locale l)
从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。

Border

UIDefaults.getBorder(Object key)
如果 key 值为一个 Border，则返回该 Border，否则返回 null。

static Border

UIManager.getBorder(Object key)
从默认值中返回一个边框。

Border

UIDefaults.getBorder(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。

static Border

UIManager.getBorder(Object key, Locale l)
从适合给定语言环境的默认值中返回一个边框。

Object

JComponent.getClientProperty(Object key)
返回具有指定键的属性的值。

Color

UIDefaults.getColor(Object key)
如果 key 值为一个 Color，则返回它，否则返回 null。

static Color

UIManager.getColor(Object key)
从默认值返回一种颜色。

Color

UIDefaults.getColor(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。

static Color

UIManager.getColor(Object key, Locale l)
从适合给定语言环境的默认值中返回一种颜色。

TableColumn

JTable.getColumn(Object identifier)
返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。

static Object

LookAndFeel.getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。

Dimension

UIDefaults.getDimension(Object key)
如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。

static Dimension

UIManager.getDimension(Object key)
从默认值中返回一个维数。

Dimension

UIDefaults.getDimension(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。

static Dimension

UIManager.getDimension(Object key, Locale l)
从适合给定语言环境的默认值中返回一个维数。

Font

UIDefaults.getFont(Object key)
如果 key 值为一个 Font，则返回该 Font，否则返回 null。

static Font

UIManager.getFont(Object key)
从默认值返回一种字体。

Font

UIDefaults.getFont(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。

static Font

UIManager.getFont(Object key, Locale l)
从适合给定语言环境的默认值中返回一种字体。

Icon

UIDefaults.getIcon(Object key)
如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。

static Icon

UIManager.getIcon(Object key)
从默认值中返回一个 Icon。

Icon

UIDefaults.getIcon(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。

static Icon

UIManager.getIcon(Object key, Locale l)
从适合给定语言环境的默认值中返回一个 Icon。

int

DefaultComboBoxModel.getIndexOf(Object anObject)
返回指定对象在列表中的索引位置。

Insets

UIDefaults.getInsets(Object key)
如果 key 值为一个 Insets，则返回它，否则返回 null。

static Insets

UIManager.getInsets(Object key)
从默认值中返回一个 Insets 对象。

Insets

UIDefaults.getInsets(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。

static Insets

UIManager.getInsets(Object key, Locale l)
从适合给定语言环境的默认值中返回一个 Insets 对象。

int

UIDefaults.getInt(Object key)
如果 key 值为一个 Integer，则返回该整数值，否则返回 0。

static int

UIManager.getInt(Object key)
从默认值中返回一个整数。

int

UIDefaults.getInt(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。

static int

UIManager.getInt(Object key, Locale l)
从适合给定语言环境的默认值中返回一个整数。

Component

DefaultListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

Component

ListCellRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
返回已配置用于显示指定值的组件。

String

UIDefaults.getString(Object key)
如果 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key)
从默认值中返回一个字符串。

String

UIDefaults.getString(Object key, Locale l)
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。

static String

UIManager.getString(Object key, Locale l)
从适合给定语言环境的默认值中返回一个字符串。

Component

DefaultCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
实现 TableCellEditor 接口。

Component

DefaultCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
实现 TreeCellEditor 接口。

int

DefaultListModel.indexOf(Object elem)
搜索 elem 的第一次出现。

int

DefaultListModel.indexOf(Object elem, int index)
从 index 开始搜索 elem 的第一次出现。

void

DefaultListModel.insertElementAt(Object obj, int index)
将指定对象作为此列表中的组件插入到指定的 index 处。

void

DefaultComboBoxModel.insertElementAt(Object anObject, int index)

void

MutableComboBoxModel.insertElementAt(Object obj, int index)
在指定索引处添加项。

void

JComboBox.insertItemAt(Object anObject, int index)
在项列表中的给定索引处插入项。

static void

LookAndFeel.installProperty(JComponent c, String propertyName, Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。

int

DefaultListModel.lastIndexOf(Object elem)
返回 elem 最后一次出现处的索引。

int

DefaultListModel.lastIndexOf(Object elem, int index)
从指定的索引处开始反向搜索 elem，并返回该对象的索引。

static void

LookAndFeel.loadKeyBindings(InputMap retMap, Object[] keys)
使用指定绑定填充 InputMap。

static ComponentInputMap

LookAndFeel.makeComponentInputMap(JComponent c, Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。

static InputMap

LookAndFeel.makeInputMap(Object[] keys)
根据 keys 创建一个 InputMapUIResource。

static JTextComponent.KeyBinding[]

LookAndFeel.makeKeyBindings(Object[] keyBindingList)
构建一个 KeyBinding 数组的便捷方法。

static boolean

SwingUtilities.notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers)
如果启用 action（且为非 null），则调用 action 上的 actionPerformed。

protected  void

SwingWorker.publish(V... chunks)
将数据块发送给 SwingWorker.process(java.util.List) 方法。

void

ComponentInputMap.put(KeyStroke keyStroke, Object actionMapKey)
将一个 keyStroke 的绑定添加到 actionMapKey。

void

InputMap.put(KeyStroke keyStroke, Object actionMapKey)
将 keyStroke 的一个绑定添加到 actionMapKey。

void

ActionMap.put(Object key, Action action)
添加一个 key 到 action 的绑定。

Object

UIDefaults.put(Object key, Object value)
将 key 值设置为所有语言环境的 value。

static Object

UIManager.put(Object key, Object value)
在开发人员默认值中存储一个对象。

void

JComponent.putClientProperty(Object key, Object value)
向此组件添加任意的键/值“客户端属性”。

void

UIDefaults.putDefaults(Object[] keyValueList)
将所有键/值对放入数据库中，并无条件地生成一个 PropertyChangeEvent。

void

AbstractAction.putValue(String key, Object newValue)
设置与指定键关联的 Value。

void

Action.putValue(String key, Object value)
使用关联的键设置此对象的一个属性。

void

JEditorPane.read(InputStream in, Object desc)
此方法根据流进行初始化。

void

ActionMap.remove(Object key)
从此 ActionMap 中移除 key 的绑定。

boolean

DefaultListModel.removeElement(Object obj)
从此列表中移除参数的第一个（索引最小的）匹配项。

void

DefaultComboBoxModel.removeElement(Object anObject)

void

MutableComboBoxModel.removeElement(Object obj)
从模型中移除项。

void

JComboBox.removeItem(Object anObject)
从项列表中移除项。

Object

DefaultListModel.set(int index, Object element)
使用指定元素替换此列表中指定位置上的元素。

void

DefaultListModel.setElementAt(Object obj, int index)
将此列表指定 index 处的组件设置为指定的对象。

void

JOptionPane.setInitialSelectionValue(Object newValue)
设置（根据选择）最初向用户显示的输入值。

void

JOptionPane.setInitialValue(Object newInitialValue)
设置要启用的初始值，即最初显示窗格时处于焦点状态的 Component。

void

JOptionPane.setInputValue(Object newValue)
设置由用户选择或输入的输入值。

void

ComboBoxEditor.setItem(Object anObject)
设置应该编辑的项。

void

JList.setListData(Object[] listData)
根据一个对象数组构造只读 ListModel，然后对此模型调用 setModel。

void

JOptionPane.setMessage(Object newMessage)
设置选项窗格的消息对象。

void

JOptionPane.setOptions(Object[] newOptions)
设置此窗格显示的选项。

void

JList.setPrototypeCellValue(Object prototypeCellValue)
设置 prototypeCellValue 属性，然后（如果新值为非 null）计算 fixedCellWidth 和 fixedCellHeight 属性：请求单元渲染器组件提供单元渲染器的给定值（及索引 0），并使用该组件的首选大小。

void

JComboBox.setPrototypeDisplayValue(Object prototypeDisplayValue)
设置用于计算 UI 部分的显示大小的原型显示值。

void

DefaultComboBoxModel.setSelectedItem(Object anObject)
设置选择项的值。

void

ComboBoxModel.setSelectedItem(Object anItem)
设置选择项。

void

JComboBox.setSelectedItem(Object anObject)
将组合框显示区域中所选项设置为参数中的对象。

void

JList.setSelectedValue(Object anObject, boolean shouldScroll)
从列表中选择指定的对象。

void

JOptionPane.setSelectionValues(Object[] newValues)
设置窗格的输入选择值，该窗格向用户提供可以从中进行选择的项列表。

void

JFormattedTextField.setValue(Object value)
设置值，该值由从当前 AbstractFormatterFactory 获得的 AbstractFormatter 进行格式化。

void

JOptionPane.setValue(Object newValue)
设置用户所选值。

void

JSpinner.setValue(Object value)
更改模型的当前值，通常此值是 editor 所显示的值。

void

SpinnerDateModel.setValue(Object value)
设置此序列的当前 Date。

void

SpinnerListModel.setValue(Object elt)
改变该序列的当前元素并通知 ChangeListeners。

void

SpinnerModel.setValue(Object value)
改变该模型的当前值，通常此值由 JSpinner 的 editor 部分显示。

void

SpinnerNumberModel.setValue(Object value)
设置此序列的当前元素。

void

DefaultCellEditor.EditorDelegate.setValue(Object value)
设置此单元格的值。

void

Renderer.setValue(Object aValue, boolean isSelected)
指定要显示的值和是否应将该值描绘为“当前选定”。

void

JTable.setValueAt(Object aValue, int row, int column)
设置表模型中 row 和 column 位置的单元格值。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的对话框。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。

static int

JOptionPane.showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, Object initialSelectionValue)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static Object

JOptionPane.showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。

static String

JOptionPane.showInputDialog(Object message)
显示请求用户输入的问题消息对话框。

static String

JOptionPane.showInputDialog(Object message, Object initialSelectionValue)
显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message)
调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。

static int

JOptionPane.showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message)
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。

static String

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

static Object

JOptionPane.showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message)
调出内部确认对话框面板。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。

static void

JOptionPane.showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。

static int

JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static int

JOptionPane.showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message)
调出标题为 "Message" 的信息消息对话框。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType)
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。

static void

JOptionPane.showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon)
调出一个显示信息的对话框，为其指定了所有参数。

static int

JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

static int

JOptionPane.showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue)
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

abstract  String

JFormattedTextField.AbstractFormatter.valueToString(Object value)
返回为 value 显示的 string 值。

参数类型为 Object 的 javax.swing 中的构造方法

DefaultComboBoxModel(Object[] items)
构造一个用对象数组初始化的 DefaultComboBoxModel 对象。

JComboBox(Object[] items)
创建包含指定数组中的元素的 JComboBox。

JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。

JFormattedTextField(Object value)
创建一个具有指定值的 JFormattedTextField。

JList(Object[] listData)
构造一个 JList，使其显示指定数组中的元素。

JOptionPane(Object message)
创建一个显示消息的 JOptionPane 的实例，使其使用 UI 提供的普通消息消息类型和默认选项。

JOptionPane(Object message, int messageType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和默认选项。

JOptionPane(Object message, int messageType, int optionType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

JTable(Object[][] rowData, Object[] columnNames)
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。

JTable(Object[][] rowData, Object[] columnNames)
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。

JTree.DynamicUtilTreeNode(Object value, Object children)
使用指定的对象作为其值并使用指定的子节点创建一个节点。

JTree(Object[] value)
返回 JTree，指定数组的每个元素作为不被显示的新根节点的子节点。

ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。

ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
构造一个对象，以监视输入流的进度。

SpinnerListModel(Object[] values)
构造一个由指定数组定义其值序列的 SpinnerModel。

UIDefaults.LazyInputMap(Object[] bindings)

UIDefaults.ProxyLazyValue(String c, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults.ProxyLazyValue(String c, String m, Object[] o)
创建一个将在请求时构造实例的 LazyValue。

UIDefaults(Object[] keyValueList)
创建一个使用指定键/值对初始化的默认值表。

javax.swing.border 中 Object 的使用

javax.swing.border 中 Object 的子类

class

AbstractBorder
实现无大小限制的空边框类。

class

BevelBorder
该类实现简单的双线斜面边框。

class

CompoundBorder
一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。

class

EmptyBorder
该类提供了一个占用空间但不执行绘制的空透明边框。

class

EtchedBorder
该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。

class

LineBorder
实现单色、任意厚度线边框的类。

class

MatteBorder
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。

class

SoftBevelBorder
实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。

class

TitledBorder
该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.colorchooser 中 Object 的使用

javax.swing.colorchooser 中 Object 的子类

class

AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

class

ColorChooserComponentFactory
旨在生成要插入到颜色选取器中的预先配置的“访问器”对象的类。

class

DefaultColorSelectionModel
ColorSelectionModel 的一般实现。

javax.swing.event 中 Object 的使用

javax.swing.event 中 Object 的子类

class

AncestorEvent
报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。

class

CaretEvent
CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。

class

ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。

static class

DocumentEvent.EventType
文档事件类型的枚举

class

EventListenerList
保存 EventListener 列表的类。

class

HyperlinkEvent
HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。

static class

HyperlinkEvent.EventType
定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。

class

InternalFrameAdapter
用于接收内部窗体事件的抽象适配器类。

class

InternalFrameEvent
以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。

class

ListDataEvent
定义一个封装列表更改的事件。

class

ListSelectionEvent
表现选择中更改的特征的事件。

class

MenuDragMouseEvent
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。

class

MenuEvent
MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。

class

MenuKeyEvent
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

class

MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

class

PopupMenuEvent
PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

class

RowSorterEvent
RowSorterEvent 提供 RowSorter 的更改通知。

class

SwingPropertyChangeSupport
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。

class

TableColumnModelEvent
TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。

class

TableModelEvent
TableModelEvent 用于通知侦听器某一表模型已发生更改。

class

TreeExpansionEvent
用于标识树中的单个路径的事件。

class

TreeModelEvent
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。

class

TreeSelectionEvent
描述当前选择中的更改的事件。

class

UndoableEditEvent
指示发生了可撤消操作的事件。

声明为 Object 的 javax.swing.event 中的字段

protected  Object[]

TreeModelEvent.children
已被移除的子节点。

protected  Object[]

EventListenerList.listenerList

返回 Object 的 javax.swing.event 中的方法

Object

TreeSelectionEvent.cloneWithSource(Object newSource)
返回接收方的副本，但带有将成为 newSource 的源。

Object[]

TreeModelEvent.getChildren()
返回位于 getChildIndices 指定位置处的、作为 getPath 所标识节点的子节点的对象。

Object[]

EventListenerList.getListenerList()
将事件侦听器列表以 ListenerType 侦听器对数组的形式传回。

Object[]

TreeModelEvent.getPath()
从此事件包装的 TreePath 实例中获得对象数组的便捷方法。

参数类型为 Object 的 javax.swing.event 中的方法

Object

TreeSelectionEvent.cloneWithSource(Object newSource)
返回接收方的副本，但带有将成为 newSource 的源。

参数类型为 Object 的 javax.swing.event 中的构造方法

CaretEvent(Object source)
创建一个新的 CaretEvent 对象。

ChangeEvent(Object source)
构造一个 ChangeEvent 对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
创建一个表示超文本链接事件的新对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。

HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

ListDataEvent(Object source, int type, int index0, int index1)
构造一个 ListDataEvent 对象。

ListSelectionEvent(Object source, int firstIndex, int lastIndex, boolean isAdjusting)
表示 firstIndex 与 lastIndex（包括两者）范围内的选择状态的更改。

MenuEvent(Object source)
构造一个 MenuEvent 对象。

PopupMenuEvent(Object source)
构造一个 PopupMenuEvent 对象。

SwingPropertyChangeSupport(Object sourceBean)
构造一个 SwingPropertyChangeSupport 对象。

SwingPropertyChangeSupport(Object sourceBean, boolean notifyOnEDT)
构造一个 SwingPropertyChangeSupport 对象。

TreeExpansionEvent(Object source, TreePath path)
构造一个 TreeExpansionEvent 对象。

TreeModelEvent(Object source, Object[] path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。

TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。

TreeModelEvent(Object source, TreePath path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。

TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。

TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。

TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。

TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。

UndoableEditEvent(Object source, UndoableEdit edit)
构造一个 UndoableEditEvent 对象。

javax.swing.filechooser 中 Object 的使用

javax.swing.filechooser 中 Object 的子类

class

FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。

class

FileNameExtensionFilter
FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。

class

FileSystemView
FileSystemView 是 JFileChooser 的文件系统网关。

class

FileView
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。

javax.swing.plaf 中 Object 的使用

javax.swing.plaf 中 Object 的子类

class

ActionMapUIResource
实现 UIResource 的 javax.swing.ActionMap 的子类。

class

BorderUIResource

static class

BorderUIResource.BevelBorderUIResource

static class

BorderUIResource.CompoundBorderUIResource

static class

BorderUIResource.EmptyBorderUIResource

static class

BorderUIResource.EtchedBorderUIResource

static class

BorderUIResource.LineBorderUIResource

static class

BorderUIResource.MatteBorderUIResource

static class

BorderUIResource.TitledBorderUIResource

class

ButtonUI
JButton 的可插入外观界面。

class

ColorChooserUI
JColorChooser 的可插入外观界面。

class

ColorUIResource

class

ComboBoxUI
JComboBox 的可插入外观界面。

class

ComponentInputMapUIResource
实现 UIResource 的 javax.swing.ComponentInputMap 的子类。

class

ComponentUI
用于 Swing 可插入外观架构中所有 UI 委托对象的基本类。

class

DesktopIconUI
JDesktopIcon 的可插入外观界面。

class

DesktopPaneUI
JDesktopPane 的可插入外观界面。

class

DimensionUIResource

class

FileChooserUI
JFileChooser 的可插入外观界面。

class

FontUIResource
实现 UIResource 的 java.awt.Font 的子类。

class

IconUIResource
实现 UIResource 的 Icon 包装类。

class

InputMapUIResource
实现 UIResource 的 javax.swing.InputMap 的子类。

class

InsetsUIResource

class

InternalFrameUI
JInternalFrame 的可插入外观界面。

class

LabelUI
JLabel 的可插入外观界面。

class

ListUI
JList 的可插入外观代理。

class

MenuBarUI
JMenuBar 的可插入外观界面。

class

MenuItemUI
JMenuItem 的可插入外观界面。

class

OptionPaneUI
JOptionPane 的可插入外观界面。

class

PanelUI
Panel 的可插入外观界面。

class

PopupMenuUI
JPopupMenu 的可插入外观界面。

class

ProgressBarUI
JProgressBar 的可插入外观界面。

class

RootPaneUI
JRootPane 的可插入外观界面。

class

ScrollBarUI
JScrollBar 的可插入外观界面。

class

ScrollPaneUI
JScrollPane 的可插入外观界面。

class

SeparatorUI
JSeparator 的可插入外观界面。

class

SliderUI
JSlider 的可插入外观界面。

class

SpinnerUI
JSpinner 的可插入外观界面

class

SplitPaneUI
JSplitPane 的可插入外观界面。

class

TabbedPaneUI
JTabbedPane 的可插入外观界面。

class

TableHeaderUI
JTableHeader 的可插入外观界面。

class

TableUI
JTable 的可插入外观界面。

class

TextUI
文本编辑器用户界面

class

ToolBarUI
JToolBar 的可插入外观界面。

class

ToolTipUI
JToolTip 的可插入外观界面。

class

TreeUI
JTree 的可插入外观界面。

class

ViewportUI
JViewport 的可插入外观界面。

javax.swing.plaf.basic 中 Object 的使用

javax.swing.plaf.basic 中 Object 的子类

class

BasicArrowButton
一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。

class

BasicBorders
可以提供适合基本 L&F 的 Border 的工厂对象。

static class

BasicBorders.ButtonBorder

static class

BasicBorders.FieldBorder

static class

BasicBorders.MarginBorder

static class

BasicBorders.MenuBarBorder

static class

BasicBorders.RadioButtonBorder

static class

BasicBorders.RolloverButtonBorder
用于翻转工具栏按钮的特殊细边框。

static class

BasicBorders.SplitPaneBorder
绘制围绕拆分窗格的边框。

static class

BasicBorders.ToggleButtonBorder

class

BasicButtonListener
按钮侦听器。

class

BasicButtonUI
BasicButton 实现

class

BasicCheckBoxMenuItemUI
BasicCheckboxMenuItem 实现

class

BasicCheckBoxUI
BasicCheckboxUI 的 CheckboxUI 实现 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

class

BasicColorChooserUI
为 JColorChooser 提供基本外观。

class

BasicColorChooserUI.PropertyHandler
因编译器故障而被标记为 "public" 的内部类。

class

BasicComboBoxEditor
用于可编辑组合框的默认编辑器。

static class

BasicComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的子类。

class

BasicComboBoxRenderer
ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

static class

BasicComboBoxRenderer.UIResource
实现 UIResource 的 BasicComboBoxRenderer 的子类。

class

BasicComboBoxUI
JComboBox 的基本 UI 实现。

class

BasicComboBoxUI.ComboBoxLayoutManager
此布局管理器处理组合框的“标准”布局。

class

BasicComboBoxUI.FocusHandler
失去焦点时，此侦听器将隐藏弹出部分。

class

BasicComboBoxUI.ItemHandler
此侦听器观察组合框中选择的更改。

class

BasicComboBoxUI.KeyHandler
此侦听器检查键事件是否不是导航键。

class

BasicComboBoxUI.ListDataHandler
此侦听器观察 ComboBoxModel 中的更改。

class

BasicComboBoxUI.PropertyChangeHandler
此侦听器观察在组合框中发生更改的绑定 (bound) 属性。

class

BasicComboPopup
此为 ComboPopup 接口的基本实现。

class

BasicComboPopup.InvocationKeyHandler
从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。

protected  class

BasicComboPopup.InvocationMouseHandler
要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。

protected  class

BasicComboPopup.InvocationMouseMotionHandler
此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。

protected  class

BasicComboPopup.ItemHandler
此侦听器观察组合框中选择的更改。

class

BasicComboPopup.ListDataHandler
从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。

protected  class

BasicComboPopup.ListMouseHandler
在列表中释放鼠标时，此侦听器隐藏弹出部分。

protected  class

BasicComboPopup.ListMouseMotionHandler
在列表上移动鼠标时，此侦听器更改所选项。

protected  class

BasicComboPopup.ListSelectionHandler
从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。

protected  class

BasicComboPopup.PropertyChangeHandler
此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。

class

BasicDesktopIconUI
用于桌面最小化窗口的 L&F。

class

BasicDesktopIconUI.MouseInputHandler
侦听鼠标移动及对其操作。

class

BasicDesktopPaneUI
桌面的基本 L&F。

protected  class

BasicDesktopPaneUI.CloseAction
处理关闭一个内部窗体。

protected  class

BasicDesktopPaneUI.MaximizeAction
处理最大化一个内部窗体。

protected  class

BasicDesktopPaneUI.MinimizeAction
处理最小化一个内部窗体。

protected  class

BasicDesktopPaneUI.NavigateAction
处理导航到下一个内部窗体。

protected  class

BasicDesktopPaneUI.OpenAction
处理恢复一个最小化或最大化的内部窗体。

class

BasicDirectoryModel
文件列表的基本实现。

class

BasicEditorPaneUI
为 JEditorPane 提供外观。

class

BasicFileChooserUI
FileChooser 的基本 L&F 实现。

protected  class

BasicFileChooserUI.AcceptAllFileFilter

protected  class

BasicFileChooserUI.ApproveSelectionAction
响应 Open 或 Save 请求

protected  class

BasicFileChooserUI.BasicFileView

protected  class

BasicFileChooserUI.CancelSelectionAction
响应取消请求。

protected  class

BasicFileChooserUI.ChangeToParentDirectoryAction

protected  class

BasicFileChooserUI.DoubleClickListener

protected  class

BasicFileChooserUI.GoHomeAction
基于“Home”键事件或等效事件的动作。

protected  class

BasicFileChooserUI.NewFolderAction
创建新文件夹。

protected  class

BasicFileChooserUI.SelectionListener

protected  class

BasicFileChooserUI.UpdateAction
重新扫描当前目录中的文件。

class

BasicFormattedTextFieldUI
提供 JFormattedTextField 的外观实现。

class

BasicGraphicsUtils

class

BasicHTML
支持为 swing 组件提供 html 视图。

class

BasicIconFactory
提供适于基本 L & F 使用的 Icon 的工厂对象。

class

BasicInternalFrameTitlePane
管理基本标题栏的类 警告：此类的序列化对象将与以后的 Swing 版本不兼容。

class

BasicInternalFrameTitlePane.CloseAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.IconifyAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.MaximizeAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.MoveAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.PropertyChangeHandler
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.RestoreAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.SizeAction
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.SystemMenuBar
此类应视为“受保护”内部类。

class

BasicInternalFrameTitlePane.TitlePaneLayout
此类应视为“受保护”内部类。

class

BasicInternalFrameUI
JInternalFrame 的基本 L&F 实现。

protected  class

BasicInternalFrameUI.BasicInternalFrameListener

protected  class

BasicInternalFrameUI.BorderListener
侦听边框调整。

protected  class

BasicInternalFrameUI.ComponentHandler

protected  class

BasicInternalFrameUI.GlassPaneDispatcher

class

BasicInternalFrameUI.InternalFrameLayout

class

BasicInternalFrameUI.InternalFramePropertyChangeListener

class

BasicLabelUI
LabelUI 的 Windows L&F 实现。

class

BasicListUI
ListUI 的可扩展实现。

class

BasicListUI.FocusHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicListUI.ListDataHandler
在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。

class

BasicListUI.ListSelectionHandler
在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。

class

BasicListUI.MouseInputHandler
鼠标输入和 JList 的焦点处理。

class

BasicListUI.PropertyChangeHandler
在 installUI 时添加到 JList 的 PropertyChangeListener。

class

BasicLookAndFeel
为 Swing 创建外观时要使用的基类。

class

BasicMenuBarUI
MenuBarUI 的默认 L&F 实现。

class

BasicMenuItemUI
BasicMenuItem 实现

protected  class

BasicMenuItemUI.MouseInputHandler

class

BasicMenuUI
MenuUI 的默认 L&F 实现。

class

BasicMenuUI.ChangeHandler
从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。

protected  class

BasicMenuUI.MouseInputHandler
实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。

class

BasicOptionPaneUI
为 JOptionPane 提供基本外观。

class

BasicOptionPaneUI.ButtonActionListener
此内部类因编译器故障而被标记为“公开”。

static class

BasicOptionPaneUI.ButtonAreaLayout
ButtonAreaLayout 的行为方式类似于 FlowLayout。

class

BasicOptionPaneUI.PropertyChangeHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicPanelUI
BasicPanel 实现

class

BasicPasswordFieldUI
为密码字段提供 Windows 外观。

class

BasicPopupMenuSeparatorUI
PopupMenuSeparatorUI 的基本 L&F 实现。

class

BasicPopupMenuUI
PopupMenuUI 的 Windows L&F 实现。

class

BasicProgressBarUI
ProgressBarUI 的基本 L&F 实现。

class

BasicProgressBarUI.ChangeHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicRadioButtonMenuItemUI
BasicRadioButtonMenuItem 实现

class

BasicRadioButtonUI
BasicRadioButtonUI 的 RadioButtonUI 实现

class

BasicRootPaneUI
RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。

class

BasicScrollBarUI
基本外观的 ScrollBarUI 的实现

protected  class

BasicScrollBarUI.ArrowButtonListener
光标键的侦听器。

protected  class

BasicScrollBarUI.ModelListener
侦听模型更改的侦听器。

class

BasicScrollBarUI.PropertyChangeHandler

protected  class

BasicScrollBarUI.ScrollListener
在 ScrollPane 中发起的滚动事件的侦听器。

protected  class

BasicScrollBarUI.TrackListener
跟踪鼠标拖动。

class

BasicScrollPaneUI
ScrollPaneUI 的默认 L&F 实现。

class

BasicScrollPaneUI.HSBChangeListener
水平滚动条侦听器。

protected  class

BasicScrollPaneUI.MouseWheelHandler
MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。

class

BasicScrollPaneUI.PropertyChangeHandler

class

BasicScrollPaneUI.ViewportChangeHandler
视口事件的侦听器。

class

BasicScrollPaneUI.VSBChangeListener
垂直滚动条侦听器。

class

BasicSeparatorUI
SeparatorUI 的基本 L&F 实现。

class

BasicSliderUI
SliderUI 的基本 L&F 实现。

class

BasicSliderUI.ActionScroller
从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。

class

BasicSliderUI.ChangeHandler
数据模型侦听器。

class

BasicSliderUI.ComponentHandler
调整事件大小的侦听器。

class

BasicSliderUI.FocusHandler
焦点更改侦听器。

class

BasicSliderUI.PropertyChangeHandler

class

BasicSliderUI.ScrollListener
滚动事件侦听器。

class

BasicSliderUI.TrackListener
跟踪鼠标移动。

class

BasicSpinnerUI
默认 Spinner UI 委托。

class

BasicSplitPaneDivider
BasicSplitPaneUI 使用的分隔符。

protected  class

BasicSplitPaneDivider.DividerLayout
用于布置 BasicSplitPaneDivider。

protected  class

BasicSplitPaneDivider.DragController
在面向 HORIZONTAL_SPLIT 的拆分窗格的拖动会话期间处理事件。

protected  class

BasicSplitPaneDivider.MouseHandler
MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。

protected  class

BasicSplitPaneDivider.VerticalDragController
在面向 VERTICAL_SPLIT 的拆分窗格的拖动会话期间处理事件。

class

BasicSplitPaneUI
SplitPaneUI 的基本 L&F 实现。

class

BasicSplitPaneUI.BasicHorizontalLayoutManager
具有 HORIZONTAL_SPLIT 方向的 JSplitPane 的 LayoutManager。

class

BasicSplitPaneUI.BasicVerticalLayoutManager
用于具有 VERTICAL_SPLIT 的方向的 JSplitPane 的 LayoutManager。

class

BasicSplitPaneUI.FocusHandler
JSplitPane UI 使用的 FocusListener 的实现。

class

BasicSplitPaneUI.KeyboardDownRightHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardEndHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardHomeHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardResizeToggleHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.KeyboardUpLeftHandler
ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。

class

BasicSplitPaneUI.PropertyHandler
JSplitPane UI 使用的 PropertyChangeListener 的实现。

class

BasicTabbedPaneUI
TabbedPaneUI 的基本 L&F 实现。

class

BasicTabbedPaneUI.FocusHandler
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.MouseHandler
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.PropertyChangeHandler
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.TabbedPaneLayout
此类应视为“受保护”内部类。

class

BasicTabbedPaneUI.TabSelectionHandler
此类应视为“受保护”内部类。

class

BasicTableHeaderUI
BasicTableHeaderUI 实现

class

BasicTableHeaderUI.MouseInputHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTableUI
BasicTableUI 实现

class

BasicTableUI.FocusHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTableUI.KeyHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTableUI.MouseInputHandler
此内部类因编译器故障而被标记为“公开”。

class

BasicTextAreaUI
为纯文本编辑器提供外观。

class

BasicTextFieldUI
JTextField 的外观的基础。

class

BasicTextPaneUI
为样式化文本编辑器提供外观。

class

BasicTextUI
此类是文本组件外观的基础。

static class

BasicTextUI.BasicCaret

static class

BasicTextUI.BasicHighlighter

class

BasicToggleButtonUI
BasicToggleButton 实现

class

BasicToolBarSeparatorUI
ToolBarSeparatorUI 的基本 L&F 实现。

class

BasicToolBarUI
ToolBarUI 的基本 L&F 实现。

class

BasicToolBarUI.DockingListener
此类应视为“受保护”内部类。

protected  class

BasicToolBarUI.DragWindow

protected  class

BasicToolBarUI.FrameListener

protected  class

BasicToolBarUI.PropertyListener

protected  class

BasicToolBarUI.ToolBarContListener

protected  class

BasicToolBarUI.ToolBarFocusListener

class

BasicToolTipUI
标准工具提示 L&F。

class

BasicTreeUI
层次数据结构的基本 L&F。

class

BasicTreeUI.CellEditorHandler
侦听器负责获取单元格编辑事件并相应地更新树。

class

BasicTreeUI.ComponentHandler
滚动时更新首选大小（如果需要）。

class

BasicTreeUI.FocusHandler
失去/获得焦点时重绘前导选择行。

class

BasicTreeUI.KeyHandler
用于获取多个按键事件以适当生成事件。

class

BasicTreeUI.MouseHandler
TreeMouseListener 负责基于鼠标事件更新选择。

class

BasicTreeUI.MouseInputHandler
在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。

class

BasicTreeUI.NodeDimensionsHandler
负责获取节点大小的类，其方法被转发到 BasicTreeUI 方法。

class

BasicTreeUI.PropertyChangeHandler
树的 PropertyChangeListener。

class

BasicTreeUI.SelectionModelPropertyChangeHandler
TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。

class

BasicTreeUI.TreeCancelEditingAction
执行操作时调用 cancelEditing 的 ActionListener。

class

BasicTreeUI.TreeExpansionHandler
更新 TreeState 以响应节点的展开/折叠。

class

BasicTreeUI.TreeHomeAction
TreeHomeAction 用于处理 end/home 动作。

class

BasicTreeUI.TreeIncrementAction
TreeIncrementAction 用于处理向上/向下操作。

class

BasicTreeUI.TreeModelHandler
将所有 TreeModel 事件转发到 TreeState。

class

BasicTreeUI.TreePageAction
TreePageAction 处理向上翻页和向下翻页事件。

class

BasicTreeUI.TreeSelectionHandler
侦听选择模型中的更改并相应地更新显示。

class

BasicTreeUI.TreeToggleAction
对于第一个选定行展开将被切换。

class

BasicTreeUI.TreeTraverseAction
TreeTraverseAction 是用于向左/向右方向键的动作。

class

BasicViewportUI
BasicViewport 实现

class

DefaultMenuLayout
Popup 菜单和菜单栏的默认布局管理器。

返回 Object 的 javax.swing.plaf.basic 中的方法

protected  Object[]

BasicOptionPaneUI.getButtons()
返回从接收者为其提供外观的 JOptionPane 显示的按钮。

Object

BasicDirectoryModel.getElementAt(int index)

Object

BasicComboBoxEditor.getItem()

protected  Object

BasicOptionPaneUI.getMessage()
返回从接收者为其提供外观的 JOptionPane 显示的消息。

参数类型为 Object 的 javax.swing.plaf.basic 中的方法

protected  void

BasicOptionPaneUI.addButtonComponents(Container container, Object[] buttons, int initialIndex)
创建表示 buttons 中每个对象的适当对象并将其添加到 container。

void

BasicSplitPaneUI.BasicHorizontalLayoutManager.addLayoutComponent(Component comp, Object constraints)
使用指定的约束对象将指定组件添加到布局中。

protected  void

BasicOptionPaneUI.addMessageComponents(Container container, GridBagConstraints cons, Object msg, int maxll, boolean internallyCreated)
创建表示 msg 的适当对象并将其置于 container 中。

boolean

BasicDirectoryModel.contains(Object o)

protected  Action

BasicLookAndFeel.createAudioAction(Object key)
创建并返回用于播放音频的 Action。

protected  void

BasicDirectoryModel.firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告 boolean 属性的绑定属性的改变。

Component

BasicComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

Rectangle

BasicTreeUI.NodeDimensionsHandler.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle size)
负责获取特定节点的大小。

int

BasicDirectoryModel.indexOf(Object o)

void

BasicComboBoxEditor.setItem(Object anObject)
设置应该编辑的项。

javax.swing.plaf.metal 中 Object 的使用

javax.swing.plaf.metal 中 Object 的子类

class

DefaultMetalTheme
提供 Java 外观原型的 MetalTheme 的一个具体实现，代码名称为“Steel”。

class

MetalBorders
可以提供适用于 metal L & F 的 Border 的工厂对象。

static class

MetalBorders.ButtonBorder

static class

MetalBorders.Flush3DBorder

static class

MetalBorders.InternalFrameBorder

static class

MetalBorders.MenuBarBorder

static class

MetalBorders.MenuItemBorder

static class

MetalBorders.OptionDialogBorder

static class

MetalBorders.PaletteBorder
Palette 的边框。

static class

MetalBorders.PopupMenuBorder

static class

MetalBorders.RolloverButtonBorder

static class

MetalBorders.ScrollPaneBorder

static class

MetalBorders.TableHeaderBorder
Table Header 的边框

static class

MetalBorders.TextFieldBorder

static class

MetalBorders.ToggleButtonBorder

static class

MetalBorders.ToolBarBorder

class

MetalButtonUI
MetalButtonUI 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。

class

MetalCheckBoxIcon
OrganicCheckBoxUI 的 CheckboxIcon 实现 警告：此类的序列化对象与以后的 Swing 版本不兼容。

class

MetalCheckBoxUI
MetalCheckboxUI 的 CheckboxUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalComboBoxButton
协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalComboBoxEditor
Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalComboBoxEditor.UIResource
实现 UIResource 的 BasicComboBoxEditor 的一个子类。

class

MetalComboBoxIcon
此实用工具类绘制指示 MetalComboBox 的水平条

class

MetalComboBoxUI
JComboBox 的 Metal UI 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalComboBoxUI.MetalComboBoxLayoutManager
此内部类因编译器故障而被标记为 "public"。

class

MetalComboBoxUI.MetalComboPopup
已过时。 从 Java 2 platform v1.4 开始。

class

MetalComboBoxUI.MetalPropertyChangeListener
此内部类由于编译器故障而被标记为 "public"。

class

MetalDesktopIconUI
Metal 桌面图标。

class

MetalFileChooserUI
FileChooser 的 Metal L&F 实现。

protected  class

MetalFileChooserUI.DirectoryComboBoxAction
当 DirectoryComboBox 已更改所选项时调用。

protected  class

MetalFileChooserUI.DirectoryComboBoxModel
字体选择组合框的数据模型。

protected  class

MetalFileChooserUI.FileRenderer

protected  class

MetalFileChooserUI.FilterComboBoxModel
字体选择组合框的数据模型。

class

MetalFileChooserUI.FilterComboBoxRenderer
呈现不同的类型大小和风格。

protected  class

MetalFileChooserUI.SingleClickListener

class

MetalIconFactory
为 JavaTM 外观 (Metal) 提供 Icon 的工厂对象。

static class

MetalIconFactory.FileIcon16
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.FolderIcon16
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.PaletteCloseIcon
定义一个用于 Palette 关闭的图标

static class

MetalIconFactory.TreeControlIcon
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.TreeFolderIcon
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

MetalIconFactory.TreeLeafIcon

class

MetalInternalFrameTitlePane
管理 JLF 标题栏的类

class

MetalInternalFrameUI
JInternalFrame 的 Metal 实现。

class

MetalLabelUI
LabelUI 的 Windows L&F 实现。

class

MetalLookAndFeel
Java 外观，也称为 Metal。

class

MetalMenuBarUI
MenuBarUI 的 Metal 实现。

class

MetalPopupMenuSeparatorUI
PopupMenuSeparatorUI 的 Metal L&F 实现。

class

MetalProgressBarUI
ProgressBarUI 的 Metal 实现。

class

MetalRadioButtonUI
MetalRadioButtonUI 的 RadioButtonUI 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalRootPaneUI
提供 RootPaneUI 的 metal 外观实现。

class

MetalScrollBarUI
ScrollBarUI 的 Metal 外观实现

class

MetalScrollButton
Metal 滚动条箭头的 JButton 对象。

class

MetalScrollPaneUI
ScrollPaneUI 的 Metal L&F 实现。

class

MetalSeparatorUI
SeparatorUI 的 Metal L&F 实现。

class

MetalSliderUI
SliderUI 的 Java L&F 实现。

protected  class

MetalSliderUI.MetalPropertyListener

class

MetalSplitPaneUI
Metal 分隔窗格。

class

MetalTabbedPaneUI
BasicTabbedPaneUI 的 Metal 子类。

class

MetalTabbedPaneUI.TabbedPaneLayout
此内部类由于编译器故障而被标记为 "public"。

class

MetalTextFieldUI
JTextField 外观的基础。

class

MetalTheme
MetalTheme 提供 Java 外观所使用的调色板和字体。

class

MetalToggleButtonUI
MetalToggleButton 实现 警告：此类的已序列化对象与以后的 Swing 版本不兼容。

class

MetalToolBarUI
ToolBarUI 的 Metal 外观实现。

protected  class

MetalToolBarUI.MetalContainerListener

protected  class

MetalToolBarUI.MetalDockingListener

protected  class

MetalToolBarUI.MetalRolloverListener

class

MetalToolTipUI
BasicToolTipUI 的 Metal L&F 扩展。

class

MetalTreeUI
TreeUI 的 metal 外观实现。

class

OceanTheme
MetalLookAndFeel 的默认主题。

返回 Object 的 javax.swing.plaf.metal 中的方法

Object

MetalFileChooserUI.DirectoryComboBoxModel.getElementAt(int index)

Object

MetalFileChooserUI.FilterComboBoxModel.getElementAt(int index)

Object

MetalFileChooserUI.DirectoryComboBoxModel.getSelectedItem()

Object

MetalFileChooserUI.FilterComboBoxModel.getSelectedItem()

参数类型为 Object 的 javax.swing.plaf.metal 中的方法

protected  void

MetalTreeUI.decodeLineStyle(Object lineStyleFlag)
此方法进行传入客户端属性中的字符串和内部表示形式（当前的并且用 int 值表示）之间的转换

Component

MetalFileChooserUI.FilterComboBoxRenderer.getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)

void

MetalFileChooserUI.DirectoryComboBoxModel.setSelectedItem(Object selectedDirectory)

void

MetalFileChooserUI.FilterComboBoxModel.setSelectedItem(Object filter)

javax.swing.plaf.multi 中 Object 的使用

javax.swing.plaf.multi 中 Object 的子类

class

MultiButtonUI
用于组合 ButtonUI 的多路 UI。

class

MultiColorChooserUI
用于组合 ColorChooserUI 的多路 UI。

class

MultiComboBoxUI
用于组合 ComboBoxUI 的多路 UI。

class

MultiDesktopIconUI
用于组合 DesktopIconUI 的多路 UI。

class

MultiDesktopPaneUI
用于组合 DesktopPaneUI 的多路 UI。

class

MultiFileChooserUI
用于组合 FileChooserUI 的多路 UI。

class

MultiInternalFrameUI
用于组合 InternalFrameUI 的多路 UI。

class

MultiLabelUI
用于组合 LabelUI 的多路 UI。

class

MultiListUI
用于组合 ListUI 的多路 UI。

class

MultiLookAndFeel
多路外观允许同时将多个 UI 与一个组件相关联。

class

MultiMenuBarUI
用于组合 MenuBarUI 的多路 UI。

class

MultiMenuItemUI
用于组合 MenuItemUI 的多路 UI。

class

MultiOptionPaneUI
用于组合 OptionPaneUI 的多路 UI。

class

MultiPanelUI
用于组合 PanelUI 的多路 UI。

class

MultiPopupMenuUI
用于组合 PopupMenuUI 的多路 UI。

class

MultiProgressBarUI
用于组合 ProgressBarUI 的多路 UI。

class

MultiRootPaneUI
用于组合 RootPaneUI 的多路 UI。

class

MultiScrollBarUI
用于组合 ScrollBarUI 的多路 UI。

class

MultiScrollPaneUI
用于组合 ScrollPaneUI 的多路 UI。

class

MultiSeparatorUI
用于组合 SeparatorUI 的多路 UI。

class

MultiSliderUI
用于组合 SliderUI 的多路 UI。

class

MultiSpinnerUI
用于组合 SpinnerUI 的多路 UI。

class

MultiSplitPaneUI
用于组合 SplitPaneUI 的多路 UI。

class

MultiTabbedPaneUI
用于组合 TabbedPaneUI 的多路 UI。

class

MultiTableHeaderUI
用于组合 TableHeaderUI 的多路 UI。

class

MultiTableUI
用于组合 TableUI 的多路 UI。

class

MultiTextUI
用于组合 TextUI 的多路 UI。

class

MultiToolBarUI
用于组合 ToolBarUI 的多路 UI。

class

MultiToolTipUI
用于组合 ToolTipUI 的多路 UI。

class

MultiTreeUI
用于组合 TreeUI 的多路 UI。

class

MultiViewportUI
用于组合 ViewportUI 的多路 UI。

javax.swing.plaf.synth 中 Object 的使用

javax.swing.plaf.synth 中 Object 的子类

class

ColorType
可从某种风格中获取的一些颜色的类型安全枚举。

class

Region
Swing 组件的独特呈现区域。

class

SynthContext
一个不可变的瞬态对象，它包含有关 Region 的上下文信息。

class

SynthGraphicsUtils
用于基本图形调用的包装器。

class

SynthLookAndFeel
SynthLookAndFeel 提供创建定制外观的基础。

class

SynthPainter
SynthPainter 用于绘制 JComponent 的某些部分。

class

SynthStyle
SynthStyle 是一个样式属性集。

class

SynthStyleFactory
用于获得 SynthStyle 的工厂。

返回 Object 的 javax.swing.plaf.synth 中的方法

Object

SynthStyle.get(SynthContext context, Object key)
某个 region 特定样式属性的获取器。

参数类型为 Object 的 javax.swing.plaf.synth 中的方法

void

SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2)
在两个端点之间绘制一条线。

void

SynthGraphicsUtils.drawLine(SynthContext context, Object paintKey, Graphics g, int x1, int y1, int x2, int y2, Object styleKey)
在两个端点之间绘制一条线。

Object

SynthStyle.get(SynthContext context, Object key)
某个 region 特定样式属性的获取器。

boolean

SynthStyle.getBoolean(SynthContext context, Object key, boolean defaultValue)
获得其值是一个 Boolean 值的特定样式属性的便捷方法。

Icon

SynthStyle.getIcon(SynthContext context, Object key)
获得其值是一个 Icon 的特定样式属性的便捷方法。

int

SynthStyle.getInt(SynthContext context, Object key, int defaultValue)
获得值为 Number 的一个特定样式属性的便捷方法。

String

SynthStyle.getString(SynthContext context, Object key, String defaultValue)
获得其值是一个 String 值的特定样式属性的便捷方法。

javax.swing.table 中 Object 的使用

javax.swing.table 中 Object 的子类

class

AbstractTableModel
此抽象类为 TableModel 接口中的大多数方法提供默认实现。

class

DefaultTableCellRenderer
呈现（显示） JTable 中每个单元格的标准类。

static class

DefaultTableCellRenderer.UIResource
DefaultTableCellRenderer 的一个子类，它实现 UIResource。

class

DefaultTableColumnModel
JTable 的标准列处理程序。

class

DefaultTableModel
这是 TableModel 的一个实现，它使用一个 Vector 来存储单元格的值对象，该 Vector 由多个 Vector 组成。

class

JTableHeader
这是管理 JTable 的头的对象。

protected  class

JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

protected  class

JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry
此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

class

TableColumn
TableColumn 表示 JTable 中列的所有属性，如宽度、大小可调整性、最小和最大宽度。

class

TableRowSorter<M extends TableModel>
RowSorter 的一个实现，它使用 TableModel 提供排序和过滤操作。

class

TableStringConverter
TableStringConverter 用于将对象从模型转换为字符串。

声明为 Object 的 javax.swing.table 中的字段

protected  Object

TableColumn.headerValue
列的标题值。

protected  Object

TableColumn.identifier
根据 JTable 的绘制机制，此对象不会在内部使用；可在 TableColumn 中设置标识符，并将其作为标记和定位表列的可选方式。

返回 Object 的 javax.swing.table 中的方法

Object

TableColumn.getHeaderValue()
返回用作标题渲染器值的 Object。

Object

TableColumn.getIdentifier()
返回此列的 identifier 对象。

Object

DefaultTableModel.getValueAt(int row, int column)
返回 row 和 column 处单元格的属性值。

Object

TableModel.getValueAt(int rowIndex, int columnIndex)
返回 columnIndex 和 rowIndex 位置的单元格值。

参数类型为 Object 的 javax.swing.table 中的方法

void

DefaultTableModel.addColumn(Object columnName)
将一列添加到模型中。

void

DefaultTableModel.addColumn(Object columnName, Object[] columnData)
将一列添加到模型中。

void

DefaultTableModel.addColumn(Object columnName, Object[] columnData)
将一列添加到模型中。

void

DefaultTableModel.addColumn(Object columnName, Vector columnData)
将一列添加到模型中。

void

DefaultTableModel.addRow(Object[] rowData)
添加一行到模型的结尾。

protected static Vector

DefaultTableModel.convertToVector(Object[] anArray)
返回一个包含与该数组相同的对象的向量。

protected static Vector

DefaultTableModel.convertToVector(Object[][] anArray)
返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。

protected  void

DefaultTableCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

int

DefaultTableColumnModel.getColumnIndex(Object identifier)
返回 tableColumns 数组中第一列的索引，当使用 equals 进行比较时，该列的标识符等于 identifier。

int

TableColumnModel.getColumnIndex(Object columnIdentifier)
返回该表中首列的索引，使用 equals 进行比较时，该列的标识符等于 identifier。

Component

TableCellEditor.getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column)
为编辑器设置初始 value。

Component

DefaultTableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
返回默认的表单元格渲染器。

Component

TableCellRenderer.getTableCellRendererComponent(JTable table, Object value, boolean isSelected, boolean hasFocus, int row, int column)
返回用于绘制单元格的组件。

void

DefaultTableModel.insertRow(int row, Object[] rowData)
在模型中的 row 位置插入一行。

void

DefaultTableModel.setColumnIdentifiers(Object[] newIdentifiers)
替换模型中的列标识符。

void

DefaultTableModel.setDataVector(Object[][] dataVector, Object[] columnIdentifiers)
用数组 dataVector 中的值替换 dataVector 实例变量中的值。

void

DefaultTableModel.setDataVector(Object[][] dataVector, Object[] columnIdentifiers)
用数组 dataVector 中的值替换 dataVector 实例变量中的值。

void

TableColumn.setHeaderValue(Object headerValue)
设置 Object，将使用其字符串表示形式作为 headerRenderer 的值。

void

TableColumn.setIdentifier(Object identifier)
将 TableColumn 的标识符设置为 anIdentifier。

protected  void

DefaultTableCellRenderer.setValue(Object value)
将要呈现的单元格的 String 对象设置为 value。

void

DefaultTableModel.setValueAt(Object aValue, int row, int column)
设置 column 和 row 处单元格的对象值。

void

AbstractTableModel.setValueAt(Object aValue, int rowIndex, int columnIndex)
由于提供了此空实现，因此，如果用户的数据模型是不可编辑的，则他们不必实现此方法。

void

TableModel.setValueAt(Object aValue, int rowIndex, int columnIndex)
将 columnIndex 和 rowIndex 位置的单元格中的值设置为 aValue。

参数类型为 Object 的 javax.swing.table 中的构造方法

DefaultTableModel(Object[][] data, Object[] columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。

DefaultTableModel(Object[][] data, Object[] columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。

DefaultTableModel(Object[] columnNames, int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。

javax.swing.text 中 Object 的使用

javax.swing.text 中 Object 的子类

class

AbstractDocument
文档接口的实现，可作为实现各种文档的基础。

class

AbstractDocument.AbstractElement
实现元素的抽象部分。

class

AbstractDocument.BranchElement
实现一个包含其他元素的复合元素。

class

AbstractDocument.DefaultDocumentEvent
存储修改文档时发生的文档更改。

static class

AbstractDocument.ElementEdit
一个 ElementChange 实现，可将其添加到文档事件中。

class

AbstractDocument.LeafElement
实现可直接表示某类内容的元素。

class

AbstractWriter
AbstractWriter 是一个抽象类，它实际执行元素树（包括属性）的写出工作。

class

AsyncBoxView
异步执行布局处理的框。

class

AsyncBoxView.ChildLocator
该类在本地化区域发生更改时，管理该本地化区域中子视图的有效位置。

class

AsyncBoxView.ChildState
表示子视图布局状态的记录。

class

BadLocationException
此异常的目的是报告文档模型中的损坏位置（即试图引用一个不存在的位置）。

class

BoxView
一个视图，它通过沿某轴平铺将其子级排列到框形状中。

class

ChangedCharSetException
顾名思义，ChangedCharSetException 是字符集改变时抛出的异常。

class

ComponentView
实现视图接口的组件装饰器。

class

CompositeView
CompositeView 是一个管理着一个或多个子视图的抽象 View 实现。

class

DateFormatter
DateFormatter 是一个 InternationalFormatter，它使用 java.text.DateFormat 的一个实例进行格式处理。

class

DefaultCaret
插入符的默认实现。

class

DefaultEditorKit
这是文本组件使编辑器对某些类型 的文本文档合理发挥其作用所需的实现集合。

static class

DefaultEditorKit.BeepAction
创建蜂鸣声。

static class

DefaultEditorKit.CopyAction
复制选定的区域并将其内容放入系统剪贴板中。

static class

DefaultEditorKit.CutAction
剪切选定的区域并将其内容放入系统剪贴板中。

static class

DefaultEditorKit.DefaultKeyTypedAction
如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。

static class

DefaultEditorKit.InsertBreakAction
在文档中放置行/段落中断。

static class

DefaultEditorKit.InsertContentAction
将内容置于关联的文档中。

static class

DefaultEditorKit.InsertTabAction
将一个制表符置于文档中。

static class

DefaultEditorKit.PasteAction
将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。

class

DefaultFormatter
DefaultFormatter 格式化任意对象。

class

DefaultFormatterFactory
JFormattedTextField.AbstractFormatterFactory 的一个实现。

class

DefaultHighlighter
实现 Highlighter 接口。

static class

DefaultHighlighter.DefaultHighlightPainter
只高亮显示用纯色填充高亮显示区域的 painter。

class

DefaultStyledDocument
能够以类似富文本格式 (Rich Text Format) 的方式对其字符和段落样式进行标记的文档。

static class

DefaultStyledDocument.AttributeUndoableEdit
用于记住 AttributeSet 对 Element 更改的一个 UndoableEdit。

class

DefaultStyledDocument.ElementBuffer
管理对元素层次结构更改的类。

static class

DefaultStyledDocument.ElementSpec
构建元素的规范。

protected  class

DefaultStyledDocument.SectionElement
文档的默认根元素... 与所包含的段落/行对应。

class

DefaultTextUI
已过时。

class

DocumentFilter
DocumentFilter，顾名思义，它是 Document 改变方法的一个过滤器。

static class

DocumentFilter.FilterBypass
充当避开回调 Document 进行更改的方法。

class

EditorKit
针对某些类型 的文本内容，建立能够合理发挥编辑器功能的文本组件所需的实现集合。

class

ElementIterator
ElementIterator，顾名思义，沿 Element 树进行迭代。

class

FieldView
扩展多行纯文本视图，使其适合单行编辑器视图。

class

FlowView
试图将其子级流入某个部分受约束的空间的视图。

static class

FlowView.FlowStrategy
维护流的物理形式的策略。

class

GapContent
AbstractDocument.Content 接口的一个实现，使用类似于 emacs 使用的间隙缓冲区来实现。

class

GlyphView
GlyphView 是一个样式化文本存储块，它表示在文本模型中的元素上映射的视图。

static class

GlyphView.GlyphPainter
执行字形呈现的类。

class

IconView
实现视图接口的图标修饰符。

class

InternationalFormatter
InternationalFormatter 扩展 DefaultFormatter，使用 java.text.Format 的实例处理往返于 String 的转换。

class

JTextComponent
JTextComponent 是 swing 文本组件的基类。

class

JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

static class

JTextComponent.DropLocation
表示 JTextComponent 的放置位置 (drop location)。

static class

JTextComponent.KeyBinding
用于创建键绑定的绑定记录。

class

LabelView
LabelView 是一个样式化文本存储块，它表示映射文本模型中某个元素的视图。

class

LayeredHighlighter

static class

LayeredHighlighter.LayerPainter
分层的高亮显示渲染器。

class

LayoutQueue
文本布局任务的队列。

class

MaskFormatter
MaskFormatter 用于格式化和编辑字符串。

class

NavigationFilter
NavigationFilter 可用于限制光标的定位。

static class

NavigationFilter.FilterBypass
用作防止回调插入符以定位光标的方式。

class

NumberFormatter
添加数字特殊行为的 InternationalFormatter 的子类 NumberFormatter。

class

ParagraphView
存在简单换行的段落的视图，其支持多种字体、颜色、组件、图标等。

class

PasswordView
实现适用于 JPasswordField UI 实现的视图。

class

PlainDocument
维护无任何字符属性的普通文档。

class

PlainView
实现简单的多行文本视图的 View 接口，该文本视图的文本只有一种字体和颜色。

static class

Position.Bias
用来指示模型中位置偏差的类型安全的枚举。

class

Segment
表示文本片段的字符数组的 segment。

class

SimpleAttributeSet
使用哈希表的 MutableAttributeSet 的直接实现。

class

StringContent
AbstractDocument.Content 接口的一个实现，这是一个对相对于较小的文档和/或调试很有用的强制实现。

class

StyleConstants
一个已知的 或常见的属性键和方法的集合，可通过应用 AttributeSet 或 MutableAttributeSet 方法以类型安全的方式获取/设置属性。

static class

StyleConstants.CharacterConstants
这是一个类型安全的已知 属性的枚举，它用于字符样式。

static class

StyleConstants.ColorConstants
这是一个类型安全的已知 属性的枚举，它用于颜色样式。

static class

StyleConstants.FontConstants
这是一个类型安全的已知 属性的枚举，它用于字体样式。

static class

StyleConstants.ParagraphConstants
这是一个类型安全的已知 属性的枚举，它用于段落样式。

class

StyleContext
样式池及其关联的资源。

class

StyleContext.NamedStyle
通常用于表示字符和段落样式的属性集合。

class

StyleContext.SmallAttributeSet
此类可在数组中存储少量的属性。

class

StyledEditorKit
这是文本组件针对某些类型 的文本文档要成为合理发挥编辑器功能所需的实现集合。

static class

StyledEditorKit.AlignmentAction
设置段落对齐的操作。

static class

StyledEditorKit.BoldAction
切换粗体属性的操作。

static class

StyledEditorKit.FontFamilyAction
在相关的 JEditorPane 中设置字体系列的操作。

static class

StyledEditorKit.FontSizeAction
设置关联的 JEditorPane 中字体大小的操作。

static class

StyledEditorKit.ForegroundAction
设置前景色的操作。

static class

StyledEditorKit.ItalicAction
切换斜体属性的一种操作。

static class

StyledEditorKit.StyledTextAction
假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。

static class

StyledEditorKit.UnderlineAction
切换下划线属性的操作。

class

TableView
为某个表实现 View 接口，这由一个元素结构组成，其中此视图负责的元素的子元素表示行，而行元素的子元素为单元格。

class

TableView.TableCell
已过时。 表单元格如今可以是任何 View 实现。

class

TableView.TableRow
以行为中心的表格中的行视图。

class

TabSet
由许多 TabStop 组成的一个 TabSet。

class

TabStop
此类封装单个制表位 (tab stop)（基本上是由 RTF 认定的制表位）。

class

TextAction
用于跨多个不同文本组件共享的键绑定的 Action 实现。

class

Utilities
处理各种文本相关活动的方法集合。

class

View
View 类是 text 包极为重要的一部分。

class

WrappedPlainView
进行换行的纯文本（仅有一种字体和颜色的文本）视图。

class

ZoneView
ZoneView 是一个创建分区的 View 实现，该分区中在需要子视图来显示或进行模型/视图转换之前不会创建或存储子视图。

声明为 Object 的 javax.swing.text 中的字段

static Object

StyleConstants.Alignment
段落的对齐方式。

static Object

StyleConstants.Background
背景色属性的名称。

static Object

StyleConstants.BidiLevel
由 Unicode bidi 算法指派的字符双向级别。

static Object

StyleConstants.Bold
粗体属性的名称。

static Object

StyleConstants.ComponentAttribute
组件属性的名称。

static Object

StyleConstants.ComposedTextAttribute
撰写文本的输入法属性的名称。

static Object

StyleConstants.Family
字体系列的名称。

static Object

StyleConstants.FirstLineIndent
段落第一行要缩进的空间量。

static Object

StyleConstants.FontFamily
字体系列的名称。

static Object

StyleConstants.FontSize
字体大小的名称。

static Object

StyleConstants.Foreground
前景色属性的名称。

static Object

StyleConstants.IconAttribute
图标属性的名称。

static Object

StyleConstants.Italic
斜体属性的名称。

static Object

StyleConstants.LeftIndent
段落左边的缩进量。

static Object

StyleConstants.LineSpacing
段落的行之间的空间量。

static Object

StyleConstants.ModelAttribute
用来标识嵌入了对象的模型的属性，这些嵌入的对象具有分开的模型视图。

static Object

AttributeSet.NameAttribute
用于命名属性集合的属性名。

static Object

StyleConstants.NameAttribute
用于命名属性集合的属性名称。

static Object

StyleConstants.Orientation
段落的方向。

static Object

AttributeSet.ResolveAttribute
用于标识解析父集合属性集（如果已定义）的属性名。

static Object

StyleConstants.ResolveAttribute
用来标识属性的解析父集的属性名（如果定义了属性的解析父集）。

static Object

StyleConstants.RightIndent
段落右边的缩进量。

static Object

StyleConstants.Size
字体大小的名称。

static Object

StyleConstants.SpaceAbove
段落上方的空间量。

static Object

StyleConstants.SpaceBelow
段落下方的空间量。

static Object

StyleConstants.StrikeThrough
删除线属性的名称。

static Object

StyleConstants.Subscript
下标属性的名称。

static Object

StyleConstants.Superscript
上标属性的名称。

static Object

StyleConstants.TabSet
段落的 TabSet，类型为包含了 TabStop 的 TabSet。

static Object

StyleConstants.Underline
下划线属性的名称。

返回 Object 的 javax.swing.text 中的方法

Object

DefaultHighlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。

Object

Highlighter.addHighlight(int p0, int p1, Highlighter.HighlightPainter p)
向视图添加高亮显示。

protected  Object

GapContent.allocateArray(int len)
分配一个存储适当类型项的数组（由子类确定）。

Object

DefaultFormatter.clone()
创建此 DefaultFormatter 的副本。

Object

ElementIterator.clone()
复制 ElementIterator。

protected  Object

GlyphView.clone()
创建一个浅表复制。

Object

InternationalFormatter.clone()
创建该 DefaultFormatter 的一个副本。

Object

StyledEditorKit.clone()
创建此编辑器工具包的一个副本。

Object

EditorKit.clone()
创建此编辑器工具包的副本。

Object

Segment.clone()
创建一个浅表副本。

Object

SimpleAttributeSet.clone()
复制属性集。

Object

StyleContext.SmallAttributeSet.clone()
复制属性集。

Object

SimpleAttributeSet.getAttribute(Object name)
获取属性的值。

Object

AttributeSet.getAttribute(Object key)
获取给定属性的值。

Object

StyleContext.SmallAttributeSet.getAttribute(Object key)
获取属性的值。

Object

StyleContext.NamedStyle.getAttribute(Object attrName)
获取属性的值。

Object

AbstractDocument.AbstractElement.getAttribute(Object attrName)
获取属性值。

Object

AbstractDocument.getProperty(Object key)
查找属性值的便捷方法。

Object

Document.getProperty(Object key)
获得与文档关联的属性。

static Object

StyleContext.getStaticAttribute(Object key)
返回以前用 registerStaticAttributeKey 注册的对象。

static Object

StyleContext.getStaticAttributeKey(Object key)
返回其 key 将要注册的 String

Object

DefaultFormatter.stringToValue(String string)
通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。

Object

InternationalFormatter.stringToValue(String text)
返回 String text 的 Object 表示形式。

Object

MaskFormatter.stringToValue(String value)
解析文本，返回 String value 的适当 Object 表示形式。

返回变量类型为 Object 的类型的 javax.swing.text 中的方法

Dictionary<Object,Object>

AbstractDocument.getDocumentProperties()
支持管理属性集。

Dictionary<Object,Object>

AbstractDocument.getDocumentProperties()
支持管理属性集。

参数类型为 Object 的 javax.swing.text 中的方法

AttributeSet

StyleContext.addAttribute(AttributeSet old, Object name, Object value)
向给定的集合中添加属性，并返回新的有代表性的集合。

AttributeSet

AbstractDocument.AttributeContext.addAttribute(AttributeSet old, Object name, Object value)
向给定属性集中添加一个属性，并返回新的有代表性的属性集。

void

SimpleAttributeSet.addAttribute(Object name, Object value)
向列表添加属性。

void

MutableAttributeSet.addAttribute(Object name, Object value)
创建一个与此属性集类似的新属性集，不同之处在于它包含具有给定名称和值的属性。

void

StyleContext.NamedStyle.addAttribute(Object name, Object value)
添加属性。

void

AbstractDocument.AbstractElement.addAttribute(Object name, Object value)
向该元素添加一个属性。

void

DefaultHighlighter.changeHighlight(Object tag, int p0, int p1)
更改高亮显示。

void

Highlighter.changeHighlight(Object tag, int p0, int p1)
更改给定的高亮显示，以使其横跨文档的不同部分。

boolean

SimpleAttributeSet.containsAttribute(Object name, Object value)
检查属性列表中是否包含了指定的属性名称/值对。

boolean

AttributeSet.containsAttribute(Object name, Object value)
如果此集合用相同的名称和相等值定义一个属性，则返回 true 。

boolean

StyleContext.SmallAttributeSet.containsAttribute(Object name, Object value)
检查给定的属性名称/值是否已定义。

boolean

StyleContext.NamedStyle.containsAttribute(Object name, Object value)
确定给定的属性名称/值是否已定义。

boolean

AbstractDocument.AbstractElement.containsAttribute(Object name, Object value)
检查是否定义了给定的属性名称/值。

boolean

TabSet.equals(Object o)
指示此 TabSet 是否与另一个相等。

boolean

TabStop.equals(Object other)
如果制表符相等，则返回 true。

boolean

DefaultCaret.equals(Object obj)
将此对象与指定的对象进行比较。

boolean

SimpleAttributeSet.equals(Object obj)
将该对象与指定对象比较。

boolean

StyleContext.SmallAttributeSet.equals(Object obj)
将此对象与指定对象比较。

Object

SimpleAttributeSet.getAttribute(Object name)
获取属性的值。

Object

AttributeSet.getAttribute(Object key)
获取给定属性的值。

Object

StyleContext.SmallAttributeSet.getAttribute(Object key)
获取属性的值。

Object

StyleContext.NamedStyle.getAttribute(Object attrName)
获取属性的值。

Object

AbstractDocument.AbstractElement.getAttribute(Object attrName)
获取属性值。

Object

AbstractDocument.getProperty(Object key)
查找属性值的便捷方法。

Object

Document.getProperty(Object key)
获得与文档关联的属性。

static Object

StyleContext.getStaticAttribute(Object key)
返回以前用 registerStaticAttributeKey 注册的对象。

static Object

StyleContext.getStaticAttributeKey(Object key)
返回其 key 将要注册的 String

boolean

SimpleAttributeSet.isDefined(Object attrName)
告知是否定义了给定的属性。

boolean

AttributeSet.isDefined(Object attrName)
检查指定属性是否具有该属性集中指定的值，而无需通过其他属性集进行解析。

boolean

StyleContext.SmallAttributeSet.isDefined(Object key)
检查给定属性是否已定义。

boolean

StyleContext.NamedStyle.isDefined(Object attrName)
确定给定属性是否已定义。

boolean

AbstractDocument.AbstractElement.isDefined(Object attrName)
检查是否定义了给定的属性。

void

AbstractDocument.putProperty(Object key, Object value)
存储属性值的便捷方法。

void

Document.putProperty(Object key, Object value)
将属性与文档关联。

void

JTextComponent.read(Reader in, Object desc)
根据流进行初始化。

static void

StyleContext.registerStaticAttributeKey(Object key)
将一个对象注册为用作属性集中的一个键的静态对象。

AttributeSet

StyleContext.removeAttribute(AttributeSet old, Object name)
从集合中移除一个属性。

AttributeSet

AbstractDocument.AttributeContext.removeAttribute(AttributeSet old, Object name)
从属性集中移除某个属性。

void

SimpleAttributeSet.removeAttribute(Object name)
从列表中移除属性。

void

MutableAttributeSet.removeAttribute(Object name)
移除具有给定 name 的属性。

void

StyleContext.NamedStyle.removeAttribute(Object name)
从集合中移除属性。

void

AbstractDocument.AbstractElement.removeAttribute(Object name)
从该集合中移除一个属性。

void

DefaultHighlighter.removeHighlight(Object tag)
从视图中移除高亮显示。

void

Highlighter.removeHighlight(Object tag)
从视图中移除高亮显示。

String

DefaultFormatter.valueToString(Object value)
使用 toString 方法将传入的 Object 转换为 String。

String

InternationalFormatter.valueToString(Object value)
返回 Object value 的 String 表示形式。

String

MaskFormatter.valueToString(Object value)
返回基于掩码的 Object value 的 String 表示形式。

类型变量类型为 Object 的 javax.swing.text 中的方法参数

void

AbstractDocument.setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。

void

AbstractDocument.setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。

参数类型为 Object 的 javax.swing.text 中的构造方法

StyleContext.SmallAttributeSet(Object[] attributes)

javax.swing.text.html 中 Object 的使用

javax.swing.text.html 中 Object 的子类

class

BlockView
用来显示具有 CSS 规范的块（作为一个框）的视图实现。

class

CSS
将 CSS attributes 集定义为类型安全的枚举。

static class

CSS.Attribute
用作 AttributeSet 的键的定义，此属性集可存储 CSS 属性。

class

FormSubmitEvent
FormSubmitEvent 用于通知提交表单所需的参与者。

class

FormView
实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。

protected  class

FormView.MouseEventListener
当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。

class

HTML
HTMLDocument 中使用的常量。

static class

HTML.Attribute
表示 HTML 属性的类型安全的枚举。

static class

HTML.Tag
HTML 标记的类型安全的枚举。

static class

HTML.UnknownTag

class

HTMLDocument
对 HTML 进行建模的文档。

class

HTMLDocument.BlockElement
表示结构性 HTML 块 的元素。

class

HTMLDocument.HTMLReader
一个 HTML reader，用来加载具有 HTML 元素结构的 HTML 文档。

class

HTMLDocument.HTMLReader.BlockAction

class

HTMLDocument.HTMLReader.CharacterAction

class

HTMLDocument.HTMLReader.FormAction
此动作通过构建所有用于表示表单控件的元素来支持表单。

class

HTMLDocument.HTMLReader.HiddenAction

class

HTMLDocument.HTMLReader.IsindexAction

class

HTMLDocument.HTMLReader.ParagraphAction

class

HTMLDocument.HTMLReader.PreAction

class

HTMLDocument.HTMLReader.SpecialAction

class

HTMLDocument.HTMLReader.TagAction
为响应对标记的解析而执行的动作。

static class

HTMLDocument.Iterator
对特定类型的标记进行迭代的迭代器。

class

HTMLDocument.RunElement
表示文本块的元素，该文本块具有一个分配给它的 HTML 字符级的属性集。

class

HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

static class

HTMLEditorKit.HTMLFactory
用于构建 HTML 视图的工厂。

static class

HTMLEditorKit.HTMLTextAction
提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。

static class

HTMLEditorKit.InsertHTMLTextAction
InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。

static class

HTMLEditorKit.LinkController
此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

static class

HTMLEditorKit.Parser
解析器要支持的接口。

static class

HTMLEditorKit.ParserCallback
解析结果驱动这些回调方法。

class

HTMLFrameHyperlinkEvent
HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。

class

HTMLWriter
这是用于 HTMLDocuments 的 writer。

class

ImageView
图像视图，用于支持 HTML <IMG> 标记。

class

InlineView
显示基于 css 属性的 inline element 样式。

class

ListView
用于显示 html 列表的视图实现。

class

MinimalHTMLWriter
MinimalHTMLWriter 是一个回退 writer，HTMLEditorKit 使用它为非 EditorKit 生成的文档写出 HTML。

class

ObjectView
实现 <object> 元素视图接口的组件装饰符。

class

Option
用来表示 <option> 元素的 ListModel 值。

class

StyleSheet
支持定义要呈现的 HTML 视图的可视化特征。

static class

StyleSheet.BoxPainter
可以执行某些 CSS 格式化任务的类。

static class

StyleSheet.ListPainter
要执行某些 CSS 列表格式化任务的类。

声明为 Object 的 javax.swing.text.html 中的字段

static Object

HTMLEditorKit.ParserCallback.IMPLIED
这是作为属性集中的一个属性来传递的，用来指示元素是隐含的，例如字符串 '<>foo<\t>' 包含隐含的 html 元素和隐含的正文元素。

返回 Object 的 javax.swing.text.html 中的方法

Object

HTMLEditorKit.clone()
创建编辑器工具包的一个副本。

参数类型为 Object 的 javax.swing.text.html 中的方法

AttributeSet

StyleSheet.addAttribute(AttributeSet old, Object key, Object value)
向给定集合添加属性，并返回新的表示方式的集合。

boolean

HTML.UnknownTag.equals(Object obj)
将此对象与指定对象进行比较。

Element

HTMLDocument.getElement(Element e, Object attribute, Object value)
返回 e（它包含具有值 value 的属性 attribute）的子元素，如果未找到，则返回 null。

AttributeSet

StyleSheet.removeAttribute(AttributeSet old, Object key)
从集合中移除属性。

参数类型为 Object 的 javax.swing.text.html 中的构造方法

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。

HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

javax.swing.text.html.parser 中 Object 的使用

javax.swing.text.html.parser 中 Object 的子类

class

AttributeList
此类使用 ATTLIST 构造定义 DTD 中描述的 SGML 元素的属性。

class

ContentModel
内容模式的表示形式。

class

DocumentParser
HTML 文档的解析器 (Parser)（实际上，您可以指定一个 DTD，但实际上仅应将此类与 swing 中的 html dtd 一起使用）。

class

DTD
SGML DTD 的表示形式。

class

Element
使用 ELEMENT 构造在 DTD 中描述的一个元素。

class

Entity
使用 ENTITY 构造在 DTD 中描述了一个实体。

class

Parser
一个简单的 DTD 驱动的 HTML 解析器。

class

ParserDelegator
负责每次在调用其 parse 方法时启动一个新的 DocumentParser。

class

TagElement
一般的 HTML TagElement 类。

声明为 Object 的 javax.swing.text.html.parser 中的字段

Object

ContentModel.content
内容。

Object

Element.data
存储用户数据的字段。

类型参数类型为 Object 的 javax.swing.text.html.parser 中的字段

Hashtable<Object,Entity>

DTD.entityHash

参数类型为 Object 的 javax.swing.text.html.parser 中的方法

protected  ContentModel

DTD.defContentModel(int type, Object obj, ContentModel next)
创建并返回一个新的内容模式。

boolean

ContentModel.first(Object token)
如果标记可能为输入流中第一个标记，则返回 true。

参数类型为 Object 的 javax.swing.text.html.parser 中的构造方法

ContentModel(int type, Object content, ContentModel next)
创建一个特定类型的内容模式。

javax.swing.text.rtf 中 Object 的使用

javax.swing.text.rtf 中 Object 的子类

class

RTFEditorKit
这是对 RTF 编辑功能的默认实现。

javax.swing.tree 中 Object 的使用

javax.swing.tree 中 Object 的子类

class

AbstractLayoutCache
警告：此类的已序列化对象与以后的 Swing 版本不兼容。

static class

AbstractLayoutCache.NodeDimensions
由 AbstractLayoutCache 使用，用于确定特定节点的大小和 x 原点。

class

DefaultMutableTreeNode
DefaultMutableTreeNode 是树数据结构中的通用节点。

class

DefaultTreeCellEditor
TreeCellEditor。

class

DefaultTreeCellEditor.DefaultTextField
不提供任何编辑器时所使用的 TextField。

class

DefaultTreeCellEditor.EditorContainer
负责存放 editingComponent 的容器。

class

DefaultTreeCellRenderer
显示树中的条目。

class

DefaultTreeModel
使用 TreeNodes 的简单树数据模型。

class

DefaultTreeSelectionModel
TreeSelectionModel 的默认实现。

class

ExpandVetoException
用于阻止扩展/折叠发生的异常。

class

FixedHeightLayoutCache
注：在以后的版本中，这将变得更加开放。

class

TreePath
表示节点的路径。

class

VariableHeightLayoutCache
注：在以后的版本中，此类将变得更加开放。

声明为 Object 的 javax.swing.tree 中的字段

protected  Object

DefaultMutableTreeNode.userObject
可选用户对象

返回 Object 的 javax.swing.tree 中的方法

Object

DefaultMutableTreeNode.clone()
重写以复制 public。

Object

DefaultTreeSelectionModel.clone()
返回具有相同 selection 的此对象的副本。

Object

DefaultTreeCellEditor.getCellEditorValue()
返回当前正在编辑的值。

Object

DefaultTreeModel.getChild(Object parent, int index)
返回父节点的子节点数组中索引 index 处的 parent 的子节点。

Object

TreeModel.getChild(Object parent, int index)
返回父节点的子数组中索引 index 位置的 parent 的子节点。

Object

TreePath.getLastPathComponent()
返回此路径的最后一个组件。

Object[]

TreePath.getPath()
返回有序的 Objects 数组，它包含此 TreePath 的组件。

Object

TreePath.getPathComponent(int element)
返回指定索引位置的路径组件。

Object

DefaultTreeModel.getRoot()
返回树的根。

Object

TreeModel.getRoot()
返回树的根。

Object

DefaultMutableTreeNode.getUserObject()
返回此节点的用户对象。

Object[]

DefaultMutableTreeNode.getUserObjectPath()
返回从根到达此节点的路径。

参数类型为 Object 的 javax.swing.tree 中的方法

protected  void

DefaultTreeCellEditor.determineOffset(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)

boolean

TreePath.equals(Object o)
通过检查路径中每个元素的相等性，测试两个 TreePaths 的相等性。

protected  void

DefaultTreeCellRenderer.firePropertyChange(String propertyName, Object oldValue, Object newValue)
因为性能原因而被重写。

protected  void

DefaultTreeModel.fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesInserted(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeNodesRemoved(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

protected  void

DefaultTreeModel.fireTreeStructureChanged(Object source, Object[] path, int[] childIndices, Object[] children)
通知所有需要此事件类型的通知的已注册侦听器。

Object

DefaultTreeModel.getChild(Object parent, int index)
返回父节点的子节点数组中索引 index 处的 parent 的子节点。

Object

TreeModel.getChild(Object parent, int index)
返回父节点的子数组中索引 index 位置的 parent 的子节点。

int

DefaultTreeModel.getChildCount(Object parent)
返回 parent 的子节点数。

int

TreeModel.getChildCount(Object parent)
返回 parent 的子节点数。

int

DefaultTreeModel.getIndexOfChild(Object parent, Object child)
返回父节点中子节点的索引。

int

TreeModel.getIndexOfChild(Object parent, Object child)
返回父节点中子节点的索引。

protected  Rectangle

AbstractLayoutCache.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle placeIn)
返回通过 placeIn 中的引用，表示 value 所需的大小。

abstract  Rectangle

AbstractLayoutCache.NodeDimensions.getNodeDimensions(Object value, int row, int depth, boolean expanded, Rectangle bounds)
通过对 bounds 的引用，返回用于保存值的节点的大小和其在 x 轴上的起点。

Component

DefaultTreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
配置编辑器。

Component

TreeCellEditor.getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row)
设置编辑器的初始值。

Component

DefaultTreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean sel, boolean expanded, boolean leaf, int row, boolean hasFocus)
配置基于传入组件的渲染器。

Component

TreeCellRenderer.getTreeCellRendererComponent(JTree tree, Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
将当前树单元格的值设置为 value。

boolean

DefaultTreeModel.isLeaf(Object node)
返回指定的节点是否为叶节点。

boolean

TreeModel.isLeaf(Object node)
如果 node 为叶节点，则返回 true。

void

DefaultTreeModel.nodesWereRemoved(TreeNode node, int[] childIndices, Object[] removedChildren)
从节点移除一些 TreeNodes 之后，调用此方法。

TreePath

TreePath.pathByAddingChild(Object child)
返回包含此对象的所有元素加上 child 的新路径。

void

DefaultMutableTreeNode.setUserObject(Object userObject)
将此节点的用户对象设置为 userObject。

void

MutableTreeNode.setUserObject(Object object)
将接收者的用户对象重新设置为 object。

void

DefaultTreeModel.valueForPathChanged(TreePath path, Object newValue)
此方法设置由路径标识的 TreeNode 的用户对象，并发送更改的节点。

void

TreeModel.valueForPathChanged(TreePath path, Object newValue)
用户已将 path 标识的项的值更改为 newValue 时，进行通知。

参数类型为 Object 的 javax.swing.tree 中的构造方法

DefaultMutableTreeNode(Object userObject)
创建没有父节点和子节点、但允许有子节点的树节点，并使用指定的用户对象对它进行初始化。

DefaultMutableTreeNode(Object userObject, boolean allowsChildren)
创建没有父节点和子节点的树节点，使用指定的用户对象对它进行初始化，仅在指定时才允许有子节点。

TreePath(Object singlePath)
构造仅包含单个元素的 TreePath。

TreePath(Object[] path)
根据 Objects 的数组构造路径，并根据树的数据模型的返回情况，唯一地标识树的根到指定节点的路径。

TreePath(Object[] path, int length)
构造一个具有长度为 length 的标识路径组件的新 TreePath。

TreePath(TreePath parent, Object lastElement)
构造一个新的 TreePath，它是以 lastElement 结束的 parent 标识的路径。

javax.swing.undo 中 Object 的使用

javax.swing.undo 中 Object 的子类

class

AbstractUndoableEdit
UndoableEdit 的抽象实现，实现对该接口中所有布尔方法的简单响应。

class

CannotRedoException
当 UndoableEdit 被通知 redo() 但无法执行时抛出。

class

CannotUndoException
当 UndoableEdit 被通知 undo() 但无法执行时抛出。

class

CompoundEdit
AbstractUndoableEdit 的具体子类，用于将一些小的 UndoableEdit 组合到一个大的 UndoableEdit 之中。

class

StateEdit
StateEdit 是更改状态的对象的通用编辑。

class

UndoableEditSupport
用于管理 UndoableEdit 侦听器的支持类。

class

UndoManager
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

声明为 Object 的 javax.swing.undo 中的字段

protected  Object

UndoableEditSupport.realSource

类型参数类型为 Object 的 javax.swing.undo 中的字段

protected  Hashtable<Object,Object>

StateEdit.postState
编辑之后的状态信息

protected  Hashtable<Object,Object>

StateEdit.postState
编辑之后的状态信息

protected  Hashtable<Object,Object>

StateEdit.preState
编辑之前的状态信息

protected  Hashtable<Object,Object>

StateEdit.preState
编辑之前的状态信息

类型变量类型为 Object 的 javax.swing.undo 中的方法参数

void

StateEditable.storeState(Hashtable<Object,Object> state)
收到此消息时，接收者应把任何相关状态放置到 state 中。

void

StateEditable.storeState(Hashtable<Object,Object> state)
收到此消息时，接收者应把任何相关状态放置到 state 中。

参数类型为 Object 的 javax.swing.undo 中的构造方法

UndoableEditSupport(Object r)
构造一个 UndoableEditSupport 对象。

javax.tools 中 Object 的使用

javax.tools 中 Object 的子类

class

DiagnosticCollector<S>
提供将诊断收集到一个列表中的简单方法。

class

ForwardingFileObject<F extends FileObject>
将调用转发到给定的文件对象。

class

ForwardingJavaFileManager<M extends JavaFileManager>
将调用转发到给定的文件管理器。

class

ForwardingJavaFileObject<F extends JavaFileObject>
将调用转发到给定的文件对象。

class

SimpleJavaFileObject
为 JavaFileObject 中的大多数方法提供简单实现。

class

ToolProvider
为查找工具提供者提供方法，例如，编译器的提供者。

javax.transaction 中 Object 的使用

javax.transaction 中 Object 的子类

class

InvalidTransactionException
此异常指示该请求带来了无效的事务上下文。

class

TransactionRequiredException
此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。

class

TransactionRolledbackException
此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

javax.transaction.xa 中 Object 的使用

javax.transaction.xa 中 Object 的子类

class

XAException
资源管理器 (RM) 抛出 XAException，以通知事务管理器涉及的事务遇到错误。

javax.xml 中 Object 的使用

javax.xml 中 Object 的子类

class

XMLConstants
包含基本 XML 值作为常量的实用工具类。

javax.xml.bind 中 Object 的使用

javax.xml.bind 中 Object 的子类

class

Binder<XmlNode>
在 XML 信息集节点和表示相同 XML 文档的 JAXB 对象之间启用同步。

class

DatatypeConverter
可以使用 javaType 绑定声明来自定义 XML 模式数据类型到 Java 数据类型的绑定。

class

JAXBContext
JAXBContext 类提供到 JAXB API 的客户端入口点。

class

JAXBElement<T>
Xml 元素的 JAXB 表示形式。

static class

JAXBElement.GlobalScope
为 xml 元素指定全局作用域。

class

JAXBException
这是所有 JAXB 异常的根异常类。

class

JAXBIntrospector
提供对 JAXB 对象的 JAXB xml 绑定数据的访问。

static class

Marshaller.Listener

向 Marshaller 注册此类的一个实现的实例，以从外部侦听编组事件。

class

PropertyException
此异常指示在获取或设置属性时遇到一个错误。

class

SchemaOutputResolver
控制 JAXB 实现放置生成的模式文件的位置。

class

TypeConstraintException
此异常指示已检测到存在违反动态检查的类型约束的情况。

static class

Unmarshaller.Listener

向 Unmarshaller 注册此类的一个实现的实例，以便外部侦听解组事件。

class

ValidationException
此异常指示在执行验证操作时发生错误。

声明为 Object 的 javax.xml.bind 中的字段

protected  T

JAXBElement.value
xml 元素值。

返回 Object 的 javax.xml.bind 中的方法

abstract  Object

Binder.getJAXBNode(XmlNode xmlNode)
获取与给定 XML 元素关联的 JAXB 对象。

Object

ValidationEventLocator.getObject()
返回对 Java 内容树中对象的引用（如果可用）。

abstract  Object

Binder.getProperty(String name)
获取 Binder 的基础实现中的特定属性。

Object

Marshaller.getProperty(String name)
获取 Marshaller 底层实现中的特定属性。

Object

Unmarshaller.getProperty(String name)
获取 Unmarshaller 底层实现中的特定属性。

Object

Validator.getProperty(String name)
已过时。 从 JAXB2.0 开始

Object

UnmarshallerHandler.getResult()
获得解组的结果。

static Object

JAXBIntrospector.getValue(Object jaxbElement)
获取 JAXB 元素的元素值。

Object

Unmarshaller.unmarshal(File f)
从指定的文件解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(InputSource source)
从指定的 SAX InputSource 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(InputStream is)
从指定的 InputStream 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(Node node)
从指定的 DOM 树解组全局 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(Reader reader)
从指定的 Reader 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(Source source)
从指定的 XML Source 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。

Object

Unmarshaller.unmarshal(XMLEventReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

abstract  Object

Binder.unmarshal(XmlNode xmlNode)
将 XML 信息集视图解组为 JAXB 对象树。

Object

Unmarshaller.unmarshal(XMLStreamReader reader)
从指定的 pull 解析器解组 XML 数据并返回得到的内容树。

abstract  Object

Binder.updateJAXB(XmlNode xmlNode)
取一个 XML 节点，并更新与其关联的 JAXB 对象和该对象的子级。

参数类型为 Object 的 javax.xml.bind 中的方法

void

Marshaller.Listener.afterMarshal(Object source)

将 source 编组到 XML 之后调用的回调方法。

void

Unmarshaller.Listener.afterUnmarshal(Object target, Object parent)

将 XML 数据解组到 target 之后调用的回调方法。

void

Marshaller.Listener.beforeMarshal(Object source)

从 source 编组到 XML 之前调用的回调方法。

void

Unmarshaller.Listener.beforeUnmarshal(Object target, Object parent)

在解组到 target 之前调用的回调方法。

abstract  QName

JAXBIntrospector.getElementName(Object jaxbElement)
获取 jaxbElement 的 xml 元素 qname。

Node

Marshaller.getNode(Object contentTree)
获取内容树的 DOM 树视图（可选）。

static Object

JAXBIntrospector.getValue(Object jaxbElement)
获取 JAXB 元素的元素值。

abstract  XmlNode

Binder.getXMLNode(Object jaxbObject)
获取与给定 JAXB 对象关联的 XML 元素。

abstract  boolean

JAXBIntrospector.isElement(Object object)
如果 object 表示一个 JAXB 元素，则返回 true。

void

Marshaller.marshal(Object jaxbElement, ContentHandler handler)
将以 jaxbElement 为根的内容树编组到 SAX2 事件中。

void

Marshaller.marshal(Object jaxbElement, Node node)
将以 jaxbElement 为根的内容树编组到 DOM 树中。

void

Marshaller.marshal(Object jaxbElement, OutputStream os)
将以 jaxbElement 为根的内容树编组到输出流中。

void

Marshaller.marshal(Object jaxbElement, Result result)
将以 jaxbElement 为根的内容树编组到指定的 javax.xml.transform.Result 中。

void

Marshaller.marshal(Object jaxbElement, Writer writer)
将以 jaxbElement 为根的内容树编组到 Writer 中。

void

Marshaller.marshal(Object jaxbElement, XMLEventWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLEventWriter 中。

abstract  void

Binder.marshal(Object jaxbObject, XmlNode xmlNode)
将 JAXB 对象树编组为新的 XML 文档。

void

Marshaller.marshal(Object jaxbElement, XMLStreamWriter writer)
将以 jaxbElement 为根的内容树编组到 XMLStreamWriter 中。

abstract  void

Binder.setProperty(String name, Object value)
设置 Binder 的基础实现中的特定属性。

void

Marshaller.setProperty(String name, Object value)
设置 Marshaller 底层实现中的特定属性。

void

Unmarshaller.setProperty(String name, Object value)
设置 Unmarshaller 底层实现中的特定属性。

void

Validator.setProperty(String name, Object value)
已过时。 从 JAXB2.0 开始

abstract  XmlNode

Binder.updateXML(Object jaxbObject)
取一个 JAXB 对象，并更新与其关联的 XML 节点和该节点的子级。

abstract  XmlNode

Binder.updateXML(Object jaxbObject, XmlNode xmlNode)
JAXB 对象树中所做的更改在与其关联的 XML 解析树中得到更新。

boolean

Validator.validate(Object subrootObj)
已过时。 从 JAXB2.0 开始

boolean

Validator.validateRoot(Object rootObj)
已过时。 从 JAXB2.0 开始

参数类型为 Object 的 javax.xml.bind 中的构造方法

PropertyException(String name, Object value)
构造一个基于属性名称和 value.toString() 设置其消息字段的 PropertyException。

javax.xml.bind.annotation 中 Object 的使用

javax.xml.bind.annotation 中 Object 的子类

class

W3CDomHandler
W3C DOM（org.w3c.dom 包）的 DomHandler 实现。

static class

XmlElement.DEFAULT
在 XmlElement.type() 中使用，用于表示根据属性签名推断出来的类型。

static class

XmlElementDecl.GLOBAL
在 XmlElementDecl.scope() 中使用，指示声明是全局范围的。

static class

XmlElementRef.DEFAULT
在 XmlElementRef.type() 中使用，用于表示根据属性签名推断出来的类型。

static class

XmlSchemaType.DEFAULT
在 XmlSchemaType.type() 中使用，用于表示根据属性签名推断出来的类型。

static class

XmlType.DEFAULT
在 XmlType.factoryClass() 中使用，指示工厂方法未被使用或者在具有此 XmlType 的类中。

javax.xml.bind.annotation.adapters 中 Object 的使用

javax.xml.bind.annotation.adapters 中 Object 的子类

class

CollapsedStringAdapter
用来处理 xs:token 及其派生类型的内置 XmlAdapter。

class

HexBinaryAdapter
xs:hexBinary 的 XmlAdapter。

class

NormalizedStringAdapter
处理 xs:normalizedString 的 XmlAdapter。

class

XmlAdapter<ValueType,BoundType>
修改 Java 类型以适应自定义编组。

static class

XmlJavaTypeAdapter.DEFAULT
此类在 XmlJavaTypeAdapter.type() 中使用，用来表示从字段、属性、参数或类的签名推导出的类型。

javax.xml.bind.attachment 中 Object 的使用

javax.xml.bind.attachment 中 Object 的子类

class

AttachmentMarshaller
启用 JAXB 编组来优化二进制数据存储。

class

AttachmentUnmarshaller
启用包含优化的二进制数据格式的根文档的 JAXB 解组。

javax.xml.bind.helpers 中 Object 的使用

javax.xml.bind.helpers 中 Object 的子类

class

AbstractMarshallerImpl
部分默认 Marshaller 实现。

class

AbstractUnmarshallerImpl
部分默认 Unmarshaller 实现。

class

DefaultValidationEventHandler
唯一的 JAXB 1.0 默认验证事件处理程序。

class

NotIdentifiableEventImpl
NotIdentifiableEvent 接口的默认实现。

class

ParseConversionEventImpl
ParseConversionEvent 接口的默认实现。

class

PrintConversionEventImpl
PrintConversionEvent 接口的默认实现。

class

ValidationEventImpl
ValidationEvent 接口的默认实现。

class

ValidationEventLocatorImpl
ValidationEventLocator 接口的默认实现。

返回 Object 的 javax.xml.bind.helpers 中的方法

Object

ValidationEventLocatorImpl.getObject()

Object

AbstractMarshallerImpl.getProperty(String name)
getProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

Object

AbstractUnmarshallerImpl.getProperty(String name)
由于没有必需的属性，getProperty 方法的默认实现总是抛出 PropertyException。

Object

AbstractUnmarshallerImpl.unmarshal(File f)

Object

AbstractUnmarshallerImpl.unmarshal(InputSource source)

Object

AbstractUnmarshallerImpl.unmarshal(InputStream is)

Object

AbstractUnmarshallerImpl.unmarshal(Reader reader)

Object

AbstractUnmarshallerImpl.unmarshal(Source source)

Object

AbstractUnmarshallerImpl.unmarshal(URL url)

Object

AbstractUnmarshallerImpl.unmarshal(XMLEventReader reader)

protected abstract  Object

AbstractUnmarshallerImpl.unmarshal(XMLReader reader, InputSource source)
使用指定的 XMLReader 和 InputSource 解组对象。

Object

AbstractUnmarshallerImpl.unmarshal(XMLStreamReader reader)

参数类型为 Object 的 javax.xml.bind.helpers 中的方法

Node

AbstractMarshallerImpl.getNode(Object obj)
默认情况下，getNode 方法不受支持并抛出 UnsupportedOperationException。

void

AbstractMarshallerImpl.marshal(Object obj, ContentHandler handler)

void

AbstractMarshallerImpl.marshal(Object obj, Node node)

void

AbstractMarshallerImpl.marshal(Object obj, OutputStream os)

void

AbstractMarshallerImpl.marshal(Object obj, Writer w)

void

AbstractMarshallerImpl.marshal(Object obj, XMLEventWriter writer)

void

AbstractMarshallerImpl.marshal(Object obj, XMLStreamWriter writer)

void

ValidationEventLocatorImpl.setObject(Object _object)
在此事件定位符上设置 Object 字段。

void

AbstractMarshallerImpl.setProperty(String name, Object value)
setProperty 方法的默认实现处理 Marshaller 中 4 个已定义的属性。

void

AbstractUnmarshallerImpl.setProperty(String name, Object value)
由于没有必需的属性，setProperty 方法的默认实现总是抛出 PropertyException。

参数类型为 Object 的 javax.xml.bind.helpers 中的构造方法

ValidationEventLocatorImpl(Object _object)
构造一个指向 JAXB 内容对象的对象。

javax.xml.bind.util 中 Object 的使用

javax.xml.bind.util 中 Object 的子类

class

JAXBResult
解组 JAXB 对象的 JAXP Result 实现。

class

JAXBSource
编组 JAXB 生成的对象的 JAXP Source 实现。

class

ValidationEventCollector
收集所有事件的 ValidationEventHandler 实现。

返回 Object 的 javax.xml.bind.util 中的方法

Object

JAXBResult.getResult()
获取通过转换创建的已解组对象。

参数类型为 Object 的 javax.xml.bind.util 中的构造方法

JAXBSource(JAXBContext context, Object contentObject)
针对给定的内容对象创建一个新 Source。

JAXBSource(Marshaller marshaller, Object contentObject)
针对给定的内容对象创建一个新 Source。

javax.xml.crypto 中 Object 的使用

javax.xml.crypto 中 Object 的子类

class

KeySelector
一个选择器，可使用 KeyInfo 对象中包含的数据查找并返回某个密钥。

static class

KeySelector.Purpose
将被选中的密钥的用途。

class

KeySelectorException
指示由 KeySelector 抛出的异常条件。

class

MarshalException
指示 XML 编组或解组过程中发生的异常条件。

class

NoSuchMechanismException
当请求特定 XML 机制但该机制在环境中不可用时，抛出此异常。

class

OctetStreamData
包含一个八位组流的 Data 类型的表示形式。

class

URIReferenceException
指示取消引用 URIReference 时抛出的异常条件。

返回 Object 的 javax.xml.crypto 中的方法

Object

XMLCryptoContext.get(Object key)
返回此上下文将指定键映射到的值。

Object

XMLCryptoContext.getProperty(String name)
返回指定属性的值。

Object

XMLCryptoContext.put(Object key, Object value)
将指定值与此上下文中的指定键关联。

Object

XMLCryptoContext.setProperty(String name, Object value)
设置指定的属性。

参数类型为 Object 的 javax.xml.crypto 中的方法

Object

XMLCryptoContext.get(Object key)
返回此上下文将指定键映射到的值。

Object

XMLCryptoContext.put(Object key, Object value)
将指定值与此上下文中的指定键关联。

Object

XMLCryptoContext.setProperty(String name, Object value)
设置指定的属性。

javax.xml.crypto.dom 中 Object 的使用

javax.xml.crypto.dom 中 Object 的子类

class

DOMCryptoContext
此类提供 XMLCryptoContext 接口特定于 DOM 的实现。

class

DOMStructure
特定于 DOM 的 XMLStructure。

返回 Object 的 javax.xml.crypto.dom 中的方法

Object

DOMCryptoContext.get(Object key)
此实现使用内部 HashMap 获取指定键所映射的对象。

Object

DOMCryptoContext.getProperty(String name)
此实现使用内部 HashMap 获取指定名称所映射的对象。

Object

DOMCryptoContext.put(Object key, Object value)
此实现使用内部 HashMap 将键映射到指定的对象。

Object

DOMCryptoContext.setProperty(String name, Object value)
此实现使用内部 HashMap 将名称映射到指定对象。

参数类型为 Object 的 javax.xml.crypto.dom 中的方法

Object

DOMCryptoContext.get(Object key)
此实现使用内部 HashMap 获取指定键所映射的对象。

Object

DOMCryptoContext.put(Object key, Object value)
此实现使用内部 HashMap 将键映射到指定的对象。

Object

DOMCryptoContext.setProperty(String name, Object value)
此实现使用内部 HashMap 将名称映射到指定对象。

javax.xml.crypto.dsig 中 Object 的使用

javax.xml.crypto.dsig 中 Object 的子类

class

TransformException
指示执行转换算法时出现异常的异常条件。

class

TransformService
转换算法和规范算法的服务提供者接口。

class

XMLSignatureException
指示生成或验证 XML 签名过程中发生的异常条件。

class

XMLSignatureFactory
用于从头创建 XMLSignature 对象或从相应的 XML 表示形式解组 XMLSignature 对象的工厂。

javax.xml.crypto.dsig.dom 中 Object 的使用

javax.xml.crypto.dsig.dom 中 Object 的子类

class

DOMSignContext
特定于 DOM 的 XMLSignContext。

class

DOMValidateContext
特定于 DOM 的 XMLValidateContext。

javax.xml.crypto.dsig.keyinfo 中 Object 的使用

javax.xml.crypto.dsig.keyinfo 中 Object 的子类

class

KeyInfoFactory
用于从头创建 KeyInfo 对象或从相应的 XML 表示形式解组 KeyInfo 对象的工厂。

javax.xml.crypto.dsig.spec 中 Object 的使用

javax.xml.crypto.dsig.spec 中 Object 的子类

class

ExcC14NParameterSpec
W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。

class

HMACParameterSpec
XML Signature HMAC Algorithm 的参数。

class

XPathFilter2ParameterSpec
W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。

class

XPathFilterParameterSpec
XPath Filtering Transform Algorithm 的参数。

class

XPathType
W3C Recommendation for XML-Signature XPath Filter 2.0 中所定义的 XPath 元素的 XML 模式定义：

static class

XPathType.Filter
表示过滤器设置操作。

class

XSLTTransformParameterSpec
XSLT Transform Algorithm 的参数。

javax.xml.datatype 中 Object 的使用

javax.xml.datatype 中 Object 的子类

class

DatatypeConfigurationException
指示严重的配置错误。

class

DatatypeConstants
包含基本 Datatype 值作为常量的实用工具类。

static class

DatatypeConstants.Field
类型安全的枚举类，它表示 Duration 类的六个字段。

class

DatatypeFactory
创建新 javax.xml.datatype Object 的工厂，创建的对象可提供 XML 和 Java Object 之间的映射。

class

Duration
W3C XML 模式 1.0 规范中定义的时间范围的不可变表示形式。

class

XMLGregorianCalendar
W3C XML 模式 1.0 日期/时间数据类型的表示形式。

返回 Object 的 javax.xml.datatype 中的方法

abstract  Object

XMLGregorianCalendar.clone()
创建并返回此对象的一个副本。

参数类型为 Object 的 javax.xml.datatype 中的方法

boolean

Duration.equals(Object duration)
检查此持续时间对象是否与另一个 Duration 对象具有相同的持续时间。

boolean

XMLGregorianCalendar.equals(Object obj)
将此日历与指定的对象进行比较。

javax.xml.namespace 中 Object 的使用

javax.xml.namespace 中 Object 的子类

class

QName
QName 表示 XML 规范中定义的限定名称：XML 模式第二部分：Datatypes specification、Namespaces in XML、Namespaces in XML 勘误表。

参数类型为 Object 的 javax.xml.namespace 中的方法

boolean

QName.equals(Object objectToTest)
测试此 QName 与另一个 Object 的相等性。

javax.xml.parsers 中 Object 的使用

javax.xml.parsers 中 Object 的子类

class

DocumentBuilder
定义 API， 使其从 XML 文档获取 DOM 文档实例。

class

DocumentBuilderFactory
定义工厂 API，使应用程序能够从 XML 文档获取生成 DOM 对象树的解析器。

class

FactoryConfigurationError
当解析器工厂的配置存在问题时抛出该异常。

class

ParserConfigurationException
指示一个严重的配置错误。

class

SAXParser
定义包装 XMLReader 实现类的 API。

class

SAXParserFactory
定义工厂 API，使应用程序能够配置和获取基于 SAX 的解析器以解析 XML 文档。

返回 Object 的 javax.xml.parsers 中的方法

abstract  Object

DocumentBuilderFactory.getAttribute(String name)
允许用户在底层实现上检索特定属性。

abstract  Object

SAXParser.getProperty(String name)
返回 XMLReader 的底层实现中请求的特定属性。

参数类型为 Object 的 javax.xml.parsers 中的方法

abstract  void

DocumentBuilderFactory.setAttribute(String name, Object value)
允许用户在底层实现上设置特定属性。

abstract  void

SAXParser.setProperty(String name, Object value)
设置 XMLReader 的底层实现中的特定属性。

javax.xml.soap 中 Object 的使用

javax.xml.soap 中 Object 的子类

class

AttachmentPart
SOAPMessage 对象的一个附件。

class

MessageFactory
创建 SOAPMessage 对象的工厂。

class

MimeHeader
存储 MIME 头名称及其值的对象。

class

MimeHeaders
MimeHeader 对象的容器，这些对象表示出现在消息的 MIME 部分的 MIME 头。

class

SAAJMetaFactory
SAAJ API 中定义的工厂实现类的访问点。

class

SAAJResult
以 SAAJ 树的形式，充当 JAXP 转换或 JAXB 编组结果的持有者。

class

SOAPConnection
客户端可以用于直接将消息发送到（例如，用 URL 表示的）远程方的点对点连接。

class

SOAPConnectionFactory
创建 SOAPConnection 对象的工厂。

class

SOAPElementFactory
已过时。 - 使用 javax.xml.soap.SOAPFactory 创建 SOAPElements。

class

SOAPException
当发生 SOAP 异常时，抛出此异常。

class

SOAPFactory
SOAPFactory 是用来创建存在于 SOAP XML 树中的各种对象的工厂。

class

SOAPMessage
所有 SOAP 消息的根类。

class

SOAPPart
SOAPMessage 对象中特定于 SOAP 部分的容器。

返回 Object 的 javax.xml.soap 中的方法

abstract  Object

AttachmentPart.getContent()
以 Java 对象的形式获取此 AttachmentPart 对象的内容。

Object

SOAPMessage.getProperty(String property)
检索指定属性的值。

参数类型为 Object 的 javax.xml.soap 中的方法

abstract  SOAPMessage

SOAPConnection.call(SOAPMessage request, Object to)
将给定消息发送到指定端点，在返回应答前将一直阻塞。

AttachmentPart

SOAPMessage.createAttachmentPart(Object content, String contentType)
创建 AttachmentPart 对象并使用指定内容类型的指定数据填充。

SOAPMessage

SOAPConnection.get(Object to)
从特定端点获取消息，在收到消息前将一直阻塞。

abstract  void

AttachmentPart.setContent(Object object, String contentType)
将此附件部分的内容设置为给定 Object 的内容，并将 Content-Type 头的值设置为给定类型。

void

SOAPMessage.setProperty(String property, Object value)
将指定值与指定属性关联。

javax.xml.stream 中 Object 的使用

javax.xml.stream 中 Object 的子类

class

XMLEventFactory
此接口定义一个创建 XMLEvent 实例的实用工具类。

class

XMLInputFactory
定义用于获取流的工厂的抽象实现。

class

XMLOutputFactory
定义用于获取 XMLEventWriter 和 XMLStreamWriter 的工厂抽象实现。

class

XMLStreamException
用于不可预料处理错误的基本异常。

返回 Object 的 javax.xml.stream 中的方法

Object

XMLEventReader.getProperty(String name)
从底层实现获取功能/属性值。

abstract  Object

XMLInputFactory.getProperty(String name)
从底层实现获取功能/属性的值。

abstract  Object

XMLOutputFactory.getProperty(String name)
获取底层实现上的功能/属性

Object

XMLStreamReader.getProperty(String name)
从底层实现获取功能/属性的值

Object

XMLStreamWriter.getProperty(String name)
从底层实现获取功能/属性值

Object

XMLResolver.resolveEntity(String publicID, String systemID, String baseURI, String namespace)
检索资源。

参数类型为 Object 的 javax.xml.stream 中的方法

void

XMLReporter.report(String message, String errorType, Object relatedInformation, Location location)
以特定于应用程序的格式报告所需消息。

abstract  void

XMLInputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

abstract  void

XMLOutputFactory.setProperty(String name, Object value)
允许用户在底层实现上设置特定功能/属性。

javax.xml.stream.events 中 Object 的使用

返回 Object 的 javax.xml.stream.events 中的方法

Object

DTD.getProcessedDTD()
返回定义 DTD 表示形式的实现。

javax.xml.stream.util 中 Object 的使用

javax.xml.stream.util 中 Object 的子类

class

EventReaderDelegate
该类是用于派生 XMLEventReader 过滤器的基类。

class

StreamReaderDelegate
该类是用于派生 XMLStreamReader 过滤器的基类。

返回 Object 的 javax.xml.stream.util 中的方法

Object

EventReaderDelegate.getProperty(String name)

Object

StreamReaderDelegate.getProperty(String name)

Object

EventReaderDelegate.next()

javax.xml.transform 中 Object 的使用

javax.xml.transform 中 Object 的子类

class

OutputKeys
提供可用于设置 Transformer 的输出属性或从 Transformer 或 Templates 对象检索输出属性的字符串常量。

class

Transformer
此抽象类的实例能够将源树转换为结果树。

class

TransformerConfigurationException
指示严重的配置错误。

class

TransformerException
此类指定了转换过程中发生的异常条件。

class

TransformerFactory
TransformerFactory 实例可用于创建 Transformer 和 Templates 对象。

class

TransformerFactoryConfigurationError
当通过 Transformer Factories 进行的配置存在问题时抛出此异常。

返回 Object 的 javax.xml.transform 中的方法

abstract  Object

TransformerFactory.getAttribute(String name)
允许用户在底层实现上检索指定属性。

abstract  Object

Transformer.getParameter(String name)
获取通过 setParameter 显式设置的参数。

参数类型为 Object 的 javax.xml.transform 中的方法

abstract  void

TransformerFactory.setAttribute(String name, Object value)
允许用户设置底层实现上的指定属性。

abstract  void

Transformer.setParameter(String name, Object value)
添加一个转换参数。

javax.xml.transform.dom 中 Object 的使用

javax.xml.transform.dom 中 Object 的子类

class

DOMResult
以 Document Object Model（DOM）树的形式充当转换结果树的持有者。

class

DOMSource
以 Document Object Model（DOM）树的形式充当转换 Source 树的持有者。

javax.xml.transform.sax 中 Object 的使用

javax.xml.transform.sax 中 Object 的子类

class

SAXResult
充当转换 Result 的持有者。

class

SAXSource
充当 SAX 样式 Source 的持有者。

class

SAXTransformerFactory
此类扩展了 TransformerFactory 以提供特定于 SAX 的工厂方法。

javax.xml.transform.stax 中 Object 的使用

javax.xml.transform.stax 中 Object 的子类

class

StAXResult
以 StAX writer 的形式（即 XMLStreamWriter 或 XMLEventWriter）充当 XML Result 的持有者。

class

StAXSource
以 StAX reader 的形式（即 XMLStreamReader 或 XMLEventReader）充当 XML Source 的持有者。

javax.xml.transform.stream 中 Object 的使用

javax.xml.transform.stream 中 Object 的子类

class

StreamResult
充当转换结果的持有者，可以为 XML、纯文本、HTML 或某些其他格式的标记。

class

StreamSource
以 XML 标记流的形式充当转换 Source 的持有者。

javax.xml.validation 中 Object 的使用

javax.xml.validation 中 Object 的子类

class

Schema
不可变的语法存储表示形式。

class

SchemaFactory
创建 Schema 对象的工厂。

class

SchemaFactoryLoader
创建 SchemaFactory 的工厂。

class

TypeInfoProvider
此类提供了对 ValidatorHandler 所确定的类型信息的访问。

class

Validator
根据 Schema 检查 XML 文档的处理器。

class

ValidatorHandler
处理 SAX 流的流验证器。

返回 Object 的 javax.xml.validation 中的方法

Object

SchemaFactory.getProperty(String name)
查找属性值。

Object

Validator.getProperty(String name)
查找属性值。

Object

ValidatorHandler.getProperty(String name)
查找属性值。

参数类型为 Object 的 javax.xml.validation 中的方法

void

SchemaFactory.setProperty(String name, Object object)
设置属性值。

void

Validator.setProperty(String name, Object object)
设置属性值。

void

ValidatorHandler.setProperty(String name, Object object)
设置属性值。

javax.xml.ws 中 Object 的使用

javax.xml.ws 中 Object 的子类

class

Endpoint
Web 服务端点。

class

Holder<T>
包含类型为 T 的值。

class

Service
Service 对象提供 Web 服务的客户端视图。

class

WebServiceException
WebServiceException 类是所有 JAX-WS API 运行时异常的基本异常类。

class

WebServicePermission
此类定义 Web 服务权限。

声明为 Object 的 javax.xml.ws 中的字段

T

Holder.value
持有者中包含的值。

返回 Object 的 javax.xml.ws 中的方法

abstract  Object

Endpoint.getImplementor()
返回此端点的实现对象。

Object

LogicalMessage.getPayload(JAXBContext context)
以 JAXB 对象的形式获取消息负载。

返回变量类型为 Object 的类型的 javax.xml.ws 中的方法

Dispatch<Object>

Service.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与生成的 JAXB 对象一起使用的 Dispatch 实例。

Map<String,Object>

Response.getContext()
获取所含的响应上下文。

abstract  Map<String,Object>

Endpoint.getProperties()
返回此 Endpoint 实例的属性包。

Map<String,Object>

BindingProvider.getRequestContext()
获取用于初始化请求消息的消息上下文的上下文。

Map<String,Object>

BindingProvider.getResponseContext()
获取处理响应消息所得的上下文。

参数类型为 Object 的 javax.xml.ws 中的方法

static Endpoint

Endpoint.create(Object implementor)
创建具有指定实现者对象的端点。

static Endpoint

Endpoint.create(String bindingId, Object implementor)
创建具有指定绑定类型和实现者对象的端点。

abstract  void

Endpoint.publish(Object serverContext)
在提供的服务器上下文中发布此端点。

static Endpoint

Endpoint.publish(String address, Object implementor)
在给定地址处针对指定的实现者对象创建并发布端点。

void

LogicalMessage.setPayload(Object payload, JAXBContext context)
设置消息负载

类型变量类型为 Object 的 javax.xml.ws 中的方法参数

abstract  void

Endpoint.setProperties(Map<String,Object> properties)
设置此 Endpoint 实例的属性包。

javax.xml.ws.handler.soap 中 Object 的使用

返回 Object 的 javax.xml.ws.handler.soap 中的方法

Object[]

SOAPMessageContext.getHeaders(QName header, JAXBContext context, boolean allRoles)
从消息上下文的消息中获得具有特定限定名的头。

javax.xml.ws.http 中 Object 的使用

javax.xml.ws.http 中 Object 的子类

class

HTTPException
HTTPException 异常表示一个 XML/HTTP 故障。

javax.xml.ws.soap 中 Object 的使用

javax.xml.ws.soap 中 Object 的子类

class

SOAPFaultException
SOAPFaultException 异常表示一个 SOAP 1.1 或 1.2 故障。

javax.xml.ws.spi 中 Object 的使用

javax.xml.ws.spi 中 Object 的子类

class

Provider
ServiceDelegate 和 Endpoint 对象的服务提供者。

class

ServiceDelegate
服务委托由 Service 对象内部使用，以允许插入 JAX-WS 实现。

返回变量类型为 Object 的类型的 javax.xml.ws.spi 中的方法

abstract  Dispatch<Object>

ServiceDelegate.createDispatch(QName portName, JAXBContext context, Service.Mode mode)
创建与 JAXB 生成的对象一起使用的 Dispatch 实例。

参数类型为 Object 的 javax.xml.ws.spi 中的方法

abstract  Endpoint

Provider.createAndPublishEndpoint(String address, Object implementor)
创建和发布具有指定地址和实现对象的端点对象。

abstract  Endpoint

Provider.createEndpoint(String bindingId, Object implementor)
创建具有提供的绑定和实现对象的端点对象。

javax.xml.xpath 中 Object 的使用

javax.xml.xpath 中 Object 的子类

class

XPathConstants
XPath 常量。

class

XPathException
XPathException 表示通用 XPath 异常。

class

XPathExpressionException
XPathExpressionException 表示 XPath 表达式中的错误。

class

XPathFactory
XPathFactory 实例可用于创建 XPath 对象。

class

XPathFactoryConfigurationException
XPathFactoryConfigurationException 表示 XPathFactory 环境中的配置错误。

class

XPathFunctionException
XPathFunctionException 表示 XPath 函数的错误。

返回 Object 的 javax.xml.xpath 中的方法

Object

XPathExpression.evaluate(InputSource source, QName returnType)
计算指定 InputSource 上下文中编译后的 XPath 表达式并返回指定类型的结果。

Object

XPathFunction.evaluate(List args)
计算带指定参数的函数。

Object

XPathExpression.evaluate(Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

Object

XPath.evaluate(String expression, InputSource source, QName returnType)
计算指定 InputSource 上下文中的 XPath 表达式并返回指定类型的结果。

Object

XPath.evaluate(String expression, Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

Object

XPathVariableResolver.resolveVariable(QName variableName)
在可用的变量集中查找变量。

参数类型为 Object 的 javax.xml.xpath 中的方法

String

XPathExpression.evaluate(Object item)
计算指定上下文中编译后的 XPath 表达式并以 String 形式返回结果。

Object

XPathExpression.evaluate(Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

String

XPath.evaluate(String expression, Object item)
计算指定上下文中的 XPath 表达式并返回 String 形式的结果。

Object

XPath.evaluate(String expression, Object item, QName returnType)
计算指定上下文中的 XPath 表达式并返回指定类型的结果。

org.ietf.jgss 中 Object 的使用

org.ietf.jgss 中 Object 的子类

class

ChannelBinding
此类封装关于调用者提供的通道绑定信息的概念。

class

GSSException
每当发生 GSS-API 错误（包括任何特定于机制的错误）时，都会抛出此异常。

class

GSSManager
此类作为其他重要 GSS-API 类的工厂，并且还提供有关受支持的机制的信息。

class

MessageProp
这是一个在 per-message GSSContext 方法中使用的、用来传送 per-message 属性的实用工具类。

class

Oid
此类表示 Universal Object Identifiers（通用对象标识符，即 Oid）及其相关的操作。

参数类型为 Object 的 org.ietf.jgss 中的方法

boolean

ChannelBinding.equals(Object obj)
比较 ChannelBinding 的两个实例。

boolean

GSSCredential.equals(Object another)
进行测试，看此 GSSCredential 是否具有与提供的对象相同的实体。

boolean

GSSName.equals(Object another)
将此 GSSName 对象与可能是 GSSName 的另一个对象进行比较。

boolean

Oid.equals(Object other)
测试两个 Oid 对象是否表示相同的 Object 标识符值。

org.omg.CORBA 中 Object 的使用

org.omg.CORBA 中 Object 的子类

class

_IDLTypeStub
IDLType 的 Stub。

class

_PolicyStub
Policy 的 Stub。

class

ACTIVITY_COMPLETED
ACTIVITY_COMPLETED 系统异常可以在任何访问 Activity 上下文的方法上引发。

class

ACTIVITY_REQUIRED
ACTIVITY_REQUIRED 系统异常可以在任何需要 Activity 上下文的方法上引发。

class

Any
充当可用 IDL 描述的任何数据或任何 IDL 基本类型的容器。

class

AnyHolder
Any 的 Holder。

class

AnySeqHelper
AnySeq 的 Helper。

class

AnySeqHolder
AnySeq 的 Holder。

class

BAD_CONTEXT
当客户端调用某一操作，但传递的上下文中不包含该操作所需的上下文值时，抛出该异常。

class

BAD_INV_ORDER
此异常指示调用者按错误顺序调用了操作。

class

BAD_OPERATION
当对象引用表示某一现有对象，但该对象并不支持调用的操作时，抛出该异常。

class

BAD_PARAM
当传递给某一调用的参数超出范围或被认为不合法时，抛出该异常。

class

BAD_QOS
只要对象无法支持调用参数（具有与之关联的服务质量语义的参数）所需的服务质量，就会引发 BAD_QOS 异常。

class

BAD_TYPECODE
当 ORB 遇到错误的类型代码（例如，具有无效 TCKind 值的类型代码）时，抛出该异常。

class

BooleanHolder
Boolean 的 Holder。

class

BooleanSeqHelper
BooleanSeq 的 Helper。

class

BooleanSeqHolder
BooleanSeq 的 Holder。

class

Bounds
当参数不在某一方法试图访问的对象的合法范围内时，抛出该用户异常。

class

ByteHolder
Byte 的 Holder。

class

CharHolder
Char 的 Holder。

class

CharSeqHelper
CharSeq 的 Helper。

class

CharSeqHolder
CharSeq 的 Holder。

class

CODESET_INCOMPATIBLE
当客户端和服务器本机代码集之间不能进行有意义的通信时，抛出此异常。

class

COMM_FAILURE
如果某一操作正在进行时失去通信，此时客户端已经发送了请求，但服务器的应答尚未返回到客户端，则引发此异常。

class

CompletionStatus
指示某一方法抛出 SystemException 时是否已结束运行的对象。

class

CompletionStatusHelper
CompletionStatus 的 Helper。

class

Context
用于在 Request 操作中指定上下文对象的对象，上下文字符串在与请求调用一起被发送之前，必须在该指定的上下文对象中进行解析。

class

ContextList
一个对象，它包含表示属性名称的 String 对象所组成的可修改列表。

class

CurrentHelper
Current 的 Helper。

class

CurrentHolder
Current 的 Holder。

class

DATA_CONVERSION
如果 ORB 无法将已编组数据的表示形式转换成其本机表示形式，则引发此异常，反之亦然。

class

DefinitionKind
该类提供用来标识接口存储库 (Interface Repository) 对象类型的常量。

class

DefinitionKindHelper
DefinitionKind 的 Helper。

class

DoubleHolder
Double 的 Holder。

class

DoubleSeqHelper
DoubleSeq 的 Helper。

class

DoubleSeqHolder
DoubleSeq 的 Holder。

class

DynamicImplementation
已过时。 org.omg.CORBA.DynamicImplementation

class

Environment
用于 Request 操作的异常的容器 (holder)，使异常可用于客户端。

class

ExceptionList
Request 操作中使用的对象，用于描述可由某一方法抛出的异常。

class

FieldNameHelper
FieldName 的 Helper。

class

FixedHolder
Fixed 的 Holder。

class

FloatHolder
Float 的 Holder。

class

FloatSeqHelper
FloatSeq 的 Helper。

class

FloatSeqHolder
FloatSeq 的 Holder。

class

FREE_MEM
当 ORB 试图释放动态内存但却因为某些原因（例如因为堆损坏或内存块被锁定）而失败时，抛出此异常。

class

IdentifierHelper
Identifier 的 Helper。

class

IDLTypeHelper
IDLType 的 Helper。

class

IMP_LIMIT
此异常指示在 OBR 运行时超过了某一项实现限制。

class

INITIALIZE
ORB 在其初始化期间出错（例如无法获得网络资源或检测配置错误）时，抛出此异常。

class

INTERNAL
此异常指示 ORB 中存在内部错误，例如，在 ORB 检测到其内部数据结构被损坏时将抛出此异常。

class

INTF_REPOS
当 ORB 无法到达接口存储库，或者检测到其他与接口存储库相关的错误时，引发此异常。

class

IntHolder
Int 的 Holder。

class

INV_FLAG
在将无效标志传递给某项操作时（例如，在创建 DII 请求时），抛出此异常。

class

INV_IDENT
此异常指示 IDL 标识符在语法上是无效的。

class

INV_OBJREF
此异常指示对象引用存在内部错误。

class

INV_POLICY
当应用于特定调用的 Policy 重写之间不兼容而导致无法进行调用时，抛出此标准异常。

class

INVALID_ACTIVITY
如果在不同于其处于挂起状态时所在的上下文中恢复事务或 Activity，则在该 Activity 或 Transaction 服务的恢复方法上引发 INVALID_ACTIVITY 系统异常。

class

INVALID_TRANSACTION
当请求带有无效的事务上下文时，抛出此异常。

class

LocalObject
用作 Java 语言映射中的本地 IDL 接口实现的基本类。

class

LongHolder
Long 值的 Holder。

class

LongLongSeqHelper
LongLongSeq 的 Helper。

class

LongLongSeqHolder
LongLongSeq 的 Holder。

class

LongSeqHelper
LongSeqHelper 的 Helper。

class

LongSeqHolder
LongSeq 的 Holder。

class

MARSHAL
表示网络中传来的请求或应答在结构上无效。

class

NamedValue
在 DII 和 DSI 中用来描述参数和返回值的对象。

class

NameValuePair
将某一名称与一个属性为 IDL struct 的值关联，并在 DynStruct API 中使用。

class

NameValuePairHelper
NameValuePair 的 Helper。

class

NO_IMPLEMENT
此异常指示，尽管被调用的操作存在（它有一个 IDL 定义），但不存在该操作的实现。

class

NO_MEMORY
如果 ORB 运行时出现内存不足，则抛出此异常。

class

NO_PERMISSION
当因为调用者没有足够的权限而导致调用失败时，抛出此异常。

class

NO_RESOURCES
当 ORB 遇到一些一般资源限制时，抛出此异常。

class

NO_RESPONSE
如果某客户端试图检索延迟同步调用的结果，但请求的响应尚不可用，则抛出此异常。

class

NVList
包含 NamedValue 对象所组成的可修改列表。

class

OBJ_ADAPTER
此异常通常指示管理方面的不匹配，例如，某台服务器可能试图在实现存储库中使用已经在使用或存储库未知的名称注册它自身。

class

OBJECT_NOT_EXIST
只要在已删除的对象上执行调用，就会引发此异常。

class

ObjectHelper

class

ObjectHolder
Object 的 Holder。

class

OctetSeqHelper
OctetSeq 的 Helper。

class

OctetSeqHolder
OctetSeq 的 Holder。

class

ORB
为 CORBA 对象请求代理 (Object Request Broker) 特性提供 API 的类。

class

ParameterMode
Parameter 参数模式的枚举。

class

ParameterModeHelper
Parameter 参数模式的枚举。

class

ParameterModeHolder
Parameter 参数模式的枚举。

class

PERSIST_STORE
此异常指示一个持久存储错误，例如，无法建立数据库连接或者某个数据库损坏。

class

PolicyError
发生策略错误时抛出的用户异常。

class

PolicyErrorCodeHelper
封装 Policy 无效的原因。

class

PolicyErrorHelper
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。

class

PolicyErrorHolder
抛出 PolicyError 指示传递给 ORB.create_policy 操作的参数值存在问题。

class

PolicyHelper
Policy 的 Helper。

class

PolicyHolder
Policy 的 Holder。

class

PolicyListHelper
PolicyList 的 Helper。

class

PolicyListHolder
PolicyList 的 Holder。

class

PolicyTypeHelper
PolicyType 的 Helper。

class

Principal
已过时。 已由 CORBA 2.2 取代。

class

PrincipalHolder
已过时。 Deprecated by CORBA 2.2.

class

REBIND
如果当前有效 RebindPolicy 具有 NO_REBIND 或 NO_RECONNECT 值，且对绑定的对象引用执行调用时生成状态为 OBJECT_FORWARD 的 LocateReply 消息或状态为 LOCATION_FORWARD 的 Reply 消息，则将引发 REBIND。

class

RepositoryIdHelper
RepositoryId 的 Helper。

class

Request
包含调用某一方法所必需的信息的对象。

class

ServerRequest
捕获对动态框架接口（Dynamic Skeleton Interface，DSI）请求的显式状态的对象。

class

ServiceDetail
表示 ORB 服务的对象：其 service_detail_type 字段包含 ORB 服务的类型，其 service_detail 字段包含 ORB 服务的描述。

class

ServiceDetailHelper

class

ServiceInformation
CORBA 模块中的 IDL struct，用于存储关于 ORB 实现中可用 CORBA 服务的信息，可使用 ORB.get_service_information 方法获取。

class

ServiceInformationHelper

class

ServiceInformationHolder
ServiceInformation 的 Holder。

class

SetOverrideType
标记 SET_OVERRIDE 和 ADD_OVERRIDE 的 CORBA enum 的映射，它指示这些策略是应该替换 Object 的现有策略还是应该被添加到现有策略中。

class

SetOverrideTypeHelper
SetOverrideType 的 Helper。

class

ShortHolder
Short 的 Holder。

class

ShortSeqHelper
ShortSeqHelper 的 Helper。

class

ShortSeqHolder
ShortSeq 的 Holder。

class

StringHolder
String 的 Holder。

class

StringSeqHelper
String 数组

class

StringSeqHolder
String 数组

class

StringValueHelper
StringValue 的 Helper。

class

StructMember
描述接口存储库 (Interface Repository) 中一个 IDL struct 成员，包括该 struct 成员的名称、该 struct 成员的类型以及表示该 struct 成员（被描述为 struct 成员对象）IDL 类型的 typedef。

class

StructMemberHelper
StructMember 的 Helper。

class

SystemException
所有 CORBA 标准异常的根类。

class

TCKind
IDL enum TCKind 的 Java 映射，TCKind 指定 TypeCode 对象的种类。

class

TIMEOUT
当已超过指定生存时间却没有做出任何交付时，引发 TIMEOUT 异常。

class

TRANSACTION_MODE
如果客户端 ORB 检测到 IOR 中的 InvocationPolicy 与选中的调用路径（即直接或路由调用）不匹配，则它将抛出 CORBA TRANSACTION_MODE 异常。

class

TRANSACTION_REQUIRED
此异常指示请求带有一个 null 事务上下文，但需要的是激活的事务。

class

TRANSACTION_ROLLEDBACK
当与请求处理关联的事务已回滚或已标记为回滚时，抛出此异常。

class

TRANSACTION_UNAVAILABLE
当由于到事务服务 (Transaction Service) 的连接已异常终止而无法处理事务服务上下文时，由 ORB 抛出 CORBA TRANSACTION_UNAVAILABLE 异常。

class

TRANSIENT
当 ORB 试图到达某一对象但失败时，抛出此异常。

class

TypeCode
用于有关特定 CORBA 数据类型的信息的容器。

class

TypeCodeHolder
TypeCode 的 Holder。

class

ULongLongSeqHelper
ULongLongSeq 的 Helper。

class

ULongLongSeqHolder
ULongLongSeq 的 Holder。

class

ULongSeqHelper
ULongSeq 的 Helper。

class

ULongSeqHolder
ULongSeq 的 Holder。

class

UnionMember
接口存储库 (Interface Repository) 中关于 IDL union 成员的描述。

class

UnionMemberHelper
UnionMember 的 Helper。

class

UNKNOWN
如果操作实现抛出一个非 CORBA 异常（比如特定于该实现编程语言的异常），或者某一操作引发没有出现在该操作引发表达式中的用户异常，则将引发此异常。

class

UnknownUserException
包含由服务器返回的用户异常的类。

class

UnknownUserExceptionHelper
UnknownUserException 的 Helper。

class

UnknownUserExceptionHolder
UnknownUserException 的 Holder。

class

UserException
CORBA IDL 定义的用户异常的根类。

class

UShortSeqHelper
UShortSeq 的 Helper。

class

UShortSeqHolder
UShortSeq 的 Holder。

class

ValueBaseHelper

class

ValueBaseHolder
ValueBase 的 Holder。

class

ValueMember
接口存储库 (Interface Repository) 中关于 value 对象成员的描述。

class

ValueMemberHelper
ValueMember 的 Helper。

class

VersionSpecHelper
VersionSpec 的 Helper。

class

VisibilityHelper
Visibility 的 Helper。

class

WCharSeqHelper
WCharSeq 的 Helper。

class

WCharSeqHolder
WCharSeq 的 Holder。

class

WrongTransaction
CORBA WrongTransaction 用户定义异常。

class

WrongTransactionHelper
WrongTransaction 的 Helper。

class

WrongTransactionHolder
WrongTransaction 的 Holder。

class

WStringSeqHelper
WString 数组

class

WStringSeqHolder
WString 数组

class

WStringValueHelper
org/omg/CORBA/WStringValueHelper.java 由 "3.0" 版的 IDL-to-Java 编译器（可移植）从 orb.idl 中生成，生成时间为 1999 年 5 月 31 日 22:27:30 (GMT+00:00) 类定义已经修改，以遵守以下 OMG 规范： 由 CORBA 2.3.1 定义的 ORB 核心 (formal/99-10-07) ptc/00-01-08 中定义的 IDL/Java 语言映射

返回 Object 的 org.omg.CORBA 中的方法

Object

DataInputStream.read_Abstract()
从输入流读取 IDL Abstract 接口。

参数类型为 Object 的 org.omg.CORBA 中的方法

void

DataOutputStream.write_Abstract(Object value)
将 IDL Abstract 接口类型写入输出流。

org.omg.CORBA_2_3 中 Object 的使用

参数类型为 Object 的 org.omg.CORBA_2_3 中的方法

void

ORB.set_delegate(Object wrapper)

org.omg.CORBA_2_3.portable 中 Object 的使用

返回 Object 的 org.omg.CORBA_2_3.portable 中的方法

Object

InputStream.read_abstract_interface()
解组值对象或适当的 stub 对象。

Object

InputStream.read_abstract_interface(Class clz)
解组与传递类型相对应的类对象或 stub 类。

参数类型为 Object 的 org.omg.CORBA_2_3.portable 中的方法

void

OutputStream.write_abstract_interface(Object obj)
编组值对象或 stub 对象。

org.omg.CORBA.DynAnyPackage 中 Object 的使用

org.omg.CORBA.DynAnyPackage 中 Object 的子类

class

Invalid
动态 any 操作在传递无效的 DynAny 或 Any 作为其参数时抛出 Invalid。

class

InvalidSeq
任何有关动态 any 并使用序列（Java 数组）作为参数的操作在该序列无效时抛出 InvalidSeq 异常。

class

InvalidValue

class

TypeMismatch
动态 any 的访问器方法在实际内容的类型与要试图访问的类型不匹配时抛出 TypeMismatch。

org.omg.CORBA.ORBPackage 中 Object 的使用

org.omg.CORBA.ORBPackage 中 Object 的子类

class

InconsistentTypeCode
当试图使用与特定的 DynAny 子类不匹配的类型代码创建动态 any 时将抛出 InconsistentTypeCode。

class

InvalidName
当向 ORB.resolve_initial_references 传递一个没有初始引用的名称时将引发 InvalidName 异常。

org.omg.CORBA.portable 中 Object 的使用

org.omg.CORBA.portable 中 Object 的子类

class

ApplicationException
此类用来报告 ORB 和 stub 之间的应用程序级异常。

class

Delegate
为 org.omg.CORBA.Object 方法特定于供应商的 ORB 实现指定一个可移植的 API。

class

IndirectionException
Indirection 异常是一个特定于 Java 的系统异常。

class

ObjectImpl
所有 stub 类的公共基类；提供 org.omg.CORBA.Object 方法的默认实现。

class

RemarshalException
此类用来报告本地转发异常，以及发回 ORB 的对象转发 GIOP 信息。

class

ServantObject
此类是本地 stub API 的一部分，其目的是为配置的客户端和服务器（即驻留在同一 Java VM 上的客户端和服务器）提供高性能的调用。

class

UnknownException
org.omg.CORBA.portable.UnknownException 用来报告 tie 和 ORB 以及 ORB 和 stub 之间的未知异常。

声明为 Object 的 org.omg.CORBA.portable 中的字段

Object

ServantObject.servant
实际的 servant。

参数类型为 Object 的 org.omg.CORBA.portable 中的方法

boolean

ObjectImpl.equals(Object obj)
比较此 ObjectImpl 对象与给定对象是否相等。

boolean

Delegate.equals(Object self, Object obj)
提供重写委托 CORBA 对象方法 equals(java.lang.Object obj) 的实现。

org.omg.CORBA.TypeCodePackage 中 Object 的使用

org.omg.CORBA.TypeCodePackage 中 Object 的子类

class

BadKind
当对 TypeCode 对象调用不恰当的操作时将抛出 BadKind 异常。

org.omg.CosNaming 中 Object 的使用

org.omg.CosNaming 中 Object 的子类

class

_BindingIteratorImplBase

class

_BindingIteratorStub
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作在绑定上进行迭代。

class

_NamingContextExtStub
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

_NamingContextImplBase

class

_NamingContextStub
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

class

Binding
org/omg/CosNaming/Binding.java。

class

BindingHelper
org/omg/CosNaming/BindingHelper.java。

class

BindingHolder
org/omg/CosNaming/BindingHolder.java。

class

BindingIteratorHelper
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

class

BindingIteratorHolder
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

class

BindingIteratorPOA
BindingIterator 接口允许客户端使用 next_one 或 next_n 操作迭代绑定。

class

BindingListHelper
绑定列表。

class

BindingListHolder
绑定列表。

class

BindingType
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。

class

BindingTypeHelper
指定给定的绑定对应于对象（非命名上下文的对象）还是命名上下文。

class

BindingTypeHolder
指定给定的绑定是对象（非命名上下文的对象）的还是命名上下文的。

class

IstringHelper
org/omg/CosNaming/IstringHelper.java。

class

NameComponent
org/omg/CosNaming/NameComponent.java。

class

NameComponentHelper
org/omg/CosNaming/NameComponentHelper.java。

class

NameComponentHolder
org/omg/CosNaming/NameComponentHolder.java。

class

NameHelper
名称是名称组件的序列。

class

NameHolder
名称是名称组件的序列。

class

NamingContextExtHelper
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

NamingContextExtHolder
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

NamingContextExtPOA
NamingContextExt 是 NamingContext（它包含一组名称绑定，在这些名称绑定中，每个名称都是唯一的）的扩展，并且是互操作命名服务 (Interoperable Naming Service) 的一部分。

class

NamingContextHelper
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

class

NamingContextHolder
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

class

NamingContextPOA
命名上下文是包含一组名称绑定的对象，在这些名称绑定中，每个名称都是唯一的。

org.omg.CosNaming.NamingContextExtPackage 中 Object 的使用

org.omg.CosNaming.NamingContextExtPackage 中 Object 的子类

class

AddressHelper
地址是以 String 形式表示的主机和端口信息。

class

InvalidAddress
org/omg/CosNaming/NamingContextExtPackage/InvalidAddress.java。

class

InvalidAddressHelper
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHelper.java。

class

InvalidAddressHolder
org/omg/CosNaming/NamingContextExtPackage/InvalidAddressHolder.java。

class

StringNameHelper
StringName 是以 String 形式表示的“字符串化的名称”和“名称组件数组”。

class

URLStringHelper
URLString 是以 String 形式表示的 URL 地址（corbaloc: 或 corbaname:）。

org.omg.CosNaming.NamingContextPackage 中 Object 的使用

org.omg.CosNaming.NamingContextPackage 中 Object 的子类

class

AlreadyBound
org/omg/CosNaming/NamingContextPackage/AlreadyBound.java。

class

AlreadyBoundHelper
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHelper.java。

class

AlreadyBoundHolder
org/omg/CosNaming/NamingContextPackage/AlreadyBoundHolder.java。

class

CannotProceed
org/omg/CosNaming/NamingContextPackage/CannotProceed.java。

class

CannotProceedHelper
org/omg/CosNaming/NamingContextPackage/CannotProceedHelper.java。

class

CannotProceedHolder
org/omg/CosNaming/NamingContextPackage/CannotProceedHolder.java。

class

InvalidNameHelper
org/omg/CosNaming/NamingContextPackage/InvalidNameHelper.java。

class

InvalidNameHolder
org/omg/CosNaming/NamingContextPackage/InvalidNameHolder.java。

class

NotEmpty
org/omg/CosNaming/NamingContextPackage/NotEmpty.java。

class

NotEmptyHelper
org/omg/CosNaming/NamingContextPackage/NotEmptyHelper.java。

class

NotEmptyHolder
org/omg/CosNaming/NamingContextPackage/NotEmptyHolder.java。

class

NotFound
org/omg/CosNaming/NamingContextPackage/NotFound.java。

class

NotFoundHelper
org/omg/CosNaming/NamingContextPackage/NotFoundHelper.java。

class

NotFoundHolder
org/omg/CosNaming/NamingContextPackage/NotFoundHolder.java。

class

NotFoundReason
指示未能解析的原因。

class

NotFoundReasonHelper
指示未能解析的原因。

class

NotFoundReasonHolder
指示未能解析的原因。

org.omg.Dynamic 中 Object 的使用

org.omg.Dynamic 中 Object 的子类

class

Parameter
org/omg/Dynamic/Parameter.java。

org.omg.DynamicAny 中 Object 的使用

org.omg.DynamicAny 中 Object 的子类

class

_DynAnyFactoryStub
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

class

_DynAnyStub
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。

class

_DynArrayStub
DynArray 对象支持对 IDL 数组 (array) 的操作。

class

_DynEnumStub
DynEnum 对象支持对 IDL 枚举 (enumerated) 值的操作。

class

_DynFixedStub
DynEnum 对象支持对 IDL 定值 (fixed value) 的操作。

class

_DynSequenceStub
DynSequence 对象支持对 IDL 序列 (sequence) 的操作。

class

_DynStructStub
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

class

_DynUnionStub
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

class

_DynValueStub
DynValue 对象支持 IDL non-boxed value 类型的操作。

class

DynAnyFactoryHelper
DynAny 对象可以通过调用 DynAnyFactory 对象上的操作来创建。

class

DynAnyHelper
通过 DynAny 对象可以动态解释（遍历）和构造 Any 值。

class

DynAnySeqHelper
org/omg/DynamicAny/DynAnySeqHelper.java。

class

DynArrayHelper
DynArray 对象支持对 IDL 数组的操作。

class

DynEnumHelper
DynEnum 对象支持对 IDL 枚举值的操作。

class

DynFixedHelper
DynFixed 对象支持对 IDL 定值 (fixed value) 的操作。

class

DynSequenceHelper
DynSequence 对象支持对 IDL 序列的操作。

class

DynStructHelper
DynStruct 对象支持对 IDL 结构数据 (struct) 和异常值的操作。

class

DynUnionHelper
DynUnion 对象支持对 IDL 联合数据 (union) 的操作。

class

DynValueHelper
DynValue 对象支持对 IDL 非装箱 (non-boxed) 值类型的操作。

class

NameDynAnyPair
org/omg/DynamicAny/NameDynAnyPair.java。

class

NameDynAnyPairHelper
org/omg/DynamicAny/NameDynAnyPairHelper.java。

class

NameDynAnyPairSeqHelper
org/omg/DynamicAny/NameDynAnyPairSeqHelper.java。

class

NameValuePairSeqHelper
org/omg/DynamicAny/NameValuePairSeqHelper.java。

org.omg.DynamicAny.DynAnyFactoryPackage 中 Object 的使用

org.omg.DynamicAny.DynAnyFactoryPackage 中 Object 的子类

class

InconsistentTypeCodeHelper
org/omg/DynamicAny/DynAnyFactoryPackage/InconsistentTypeCodeHelper.java。

org.omg.DynamicAny.DynAnyPackage 中 Object 的使用

org.omg.DynamicAny.DynAnyPackage 中 Object 的子类

class

InvalidValueHelper
org/omg/DynamicAny/DynAnyPackage/InvalidValueHelper.java。

org.omg.IOP 中 Object 的使用

org.omg.IOP 中 Object 的子类

class

CodecFactoryHelper
Codec 可从 CodecFactory 中获得。

class

ComponentIdHelper
表示多组件配置文件的标准方式。

class

Encoding
org/omg/IOP/Encoding.java。

class

IOR
org/omg/IOP/IOR.java。

class

IORHelper
org/omg/IOP/IORHelper.java。

class

IORHolder
org/omg/IOP/IORHolder.java。

class

MultipleComponentProfileHelper
形成多组件配置文件的一组加标记的组件。

class

MultipleComponentProfileHolder
形成多组件配置文件的一组加标记的组件。

class

ProfileIdHelper
配置文件 ID

class

ServiceContext
org/omg/IOP/ServiceContext.java。

class

ServiceContextHelper
org/omg/IOP/ServiceContextHelper.java。

class

ServiceContextHolder
org/omg/IOP/ServiceContextHolder.java。

class

ServiceContextListHelper
形成服务上下文列表的一组服务上下文。

class

ServiceContextListHolder
形成服务上下文列表的一组服务上下文。

class

ServiceIdHelper
以 int 形式表示的服务 id

class

TaggedComponent
org/omg/IOP/TaggedComponent.java。

class

TaggedComponentHelper
org/omg/IOP/TaggedComponentHelper.java。

class

TaggedComponentHolder
org/omg/IOP/TaggedComponentHolder.java。

class

TaggedProfile
org/omg/IOP/TaggedProfile.java。

class

TaggedProfileHelper
org/omg/IOP/TaggedProfileHelper.java。

class

TaggedProfileHolder
org/omg/IOP/TaggedProfileHolder.java。

org.omg.IOP.CodecFactoryPackage 中 Object 的使用

org.omg.IOP.CodecFactoryPackage 中 Object 的子类

class

UnknownEncoding
org/omg/IOP/CodecFactoryPackage/UnknownEncoding.java。

class

UnknownEncodingHelper
org/omg/IOP/CodecFactoryPackage/UnknownEncodingHelper.java。

org.omg.IOP.CodecPackage 中 Object 的使用

org.omg.IOP.CodecPackage 中 Object 的子类

class

FormatMismatch
org/omg/IOP/CodecPackage/FormatMismatch.java。

class

FormatMismatchHelper
org/omg/IOP/CodecPackage/FormatMismatchHelper.java。

class

InvalidTypeForEncoding
org/omg/IOP/CodecPackage/InvalidTypeForEncoding.java。

class

InvalidTypeForEncodingHelper
org/omg/IOP/CodecPackage/InvalidTypeForEncodingHelper.java。

class

TypeMismatchHelper
org/omg/IOP/CodecPackage/TypeMismatchHelper.java。

org.omg.Messaging 中 Object 的使用

org.omg.Messaging 中 Object 的子类

class

SyncScopeHelper
Synchronization 作用域

org.omg.PortableInterceptor 中 Object 的使用

org.omg.PortableInterceptor 中 Object 的子类

class

AdapterManagerIdHelper
适配器管理器标识符。

class

AdapterNameHelper
对象适配器的名称。

class

AdapterStateHelper
对象适配器状态的类型。

class

InvalidSlot
org/omg/PortableInterceptor/InvalidSlot.java。

class

InvalidSlotHelper
org/omg/PortableInterceptor/InvalidSlotHelper.java。

class

IORInterceptor_3_0Helper
org/omg/PortableInterceptor/IORInterceptor_3_0Helper.java。

class

IORInterceptor_3_0Holder
org/omg/PortableInterceptor/IORInterceptor_3_0Holder.java。

class

ObjectIdHelper
对象 id 类型。

class

ObjectReferenceFactoryHelper
对象引用工厂。

class

ObjectReferenceFactoryHolder
对象引用工厂。

class

ObjectReferenceTemplateHelper
对象引用模板。

class

ObjectReferenceTemplateHolder
对象引用模板。

class

ObjectReferenceTemplateSeqHelper
对象引用模板序列用来报告不发生在适配器管理器的状态更改。

class

ObjectReferenceTemplateSeqHolder
对象引用模板序列用来报告不发生在适配器管理器的状态更改。

class

ORBIdHelper
org/omg/PortableInterceptor/ORBIdHelper.java。

class

ServerIdHelper
org/omg/PortableInterceptor/ServerIdHelper.java。

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Object 的使用

org.omg.PortableInterceptor.ORBInitInfoPackage 中 Object 的子类

class

DuplicateName
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateName.java。

class

DuplicateNameHelper
org/omg/PortableInterceptor/ORBInitInfoPackage/DuplicateNameHelper.java。

org.omg.PortableServer 中 Object 的使用

org.omg.PortableServer 中 Object 的子类

class

_ServantActivatorStub
当 POA 具有 RETAIN 策略时，它使用 ServantActivator 这种 servant 管理器。

class

_ServantLocatorStub
POA 具有 NON_RETAIN 策略时将使用 ServantLocator 这种 servant 管理器。

class

ForwardRequest
org/omg/PortableServer/ForwardRequest.java。

class

ForwardRequestHelper
org/omg/PortableServer/ForwardRequestHelper.java。

class

IdAssignmentPolicyValue
IdAssignmentPolicyValue 可以具有以下值。

class

IdUniquenessPolicyValue
IdUniquenessPolicyValue 可以具有以下值。

class

ImplicitActivationPolicyValue
ImplicitActivationPolicyValue 具有以下语义。

class

LifespanPolicyValue
LifespanPolicyValue 可以具有以下值。

class

POAHelper
POA 对象管理对象集合的实现。

class

RequestProcessingPolicyValue
RequestProcessingPolicyValue 可以具有以下值。

class

Servant
定义本机 Servant 类型。

class

ServantActivatorHelper
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

class

ServantActivatorPOA
POA 具有 RETAIN 策略时使用 ServantActivator 这种 servant 管理器。

class

ServantLocatorHelper
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

class

ServantLocatorPOA
POA 具有 NON_RETAIN 策略时使用 ServantLocator 这种 servant 管理器。

class

ServantRetentionPolicyValue
ServantRetentionPolicyValue 可以具有以下值。

class

ThreadPolicyValue
ThreadPolicyValue 可以具有以下值。

参数类型为 Object 的 org.omg.PortableServer 中的方法

void

ServantLocatorOperations.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

void

_ServantLocatorStub.postinvoke(byte[] oid, POA adapter, String operation, Object the_cookie, Servant the_servant)
servant 完成请求时都将调用此操作。

org.omg.PortableServer.CurrentPackage 中 Object 的使用

org.omg.PortableServer.CurrentPackage 中 Object 的子类

class

NoContext
org/omg/PortableServer/CurrentPackage/NoContext.java。

class

NoContextHelper
org/omg/PortableServer/CurrentPackage/NoContextHelper.java。

org.omg.PortableServer.POAManagerPackage 中 Object 的使用

org.omg.PortableServer.POAManagerPackage 中 Object 的子类

class

AdapterInactive
org/omg/PortableServer/POAManagerPackage/AdapterInactive.java。

class

AdapterInactiveHelper
org/omg/PortableServer/POAManagerPackage/AdapterInactiveHelper.java。

class

State
指定 POAManager 的状态。

org.omg.PortableServer.POAPackage 中 Object 的使用

org.omg.PortableServer.POAPackage 中 Object 的子类

class

AdapterAlreadyExists
org/omg/PortableServer/POAPackage/AdapterAlreadyExists.java。

class

AdapterAlreadyExistsHelper
org/omg/PortableServer/POAPackage/AdapterAlreadyExistsHelper.java。

class

AdapterNonExistent
org/omg/PortableServer/POAPackage/AdapterNonExistent.java。

class

AdapterNonExistentHelper
org/omg/PortableServer/POAPackage/AdapterNonExistentHelper.java。

class

InvalidPolicy
org/omg/PortableServer/POAPackage/InvalidPolicy.java。

class

InvalidPolicyHelper
org/omg/PortableServer/POAPackage/InvalidPolicyHelper.java。

class

NoServant
org/omg/PortableServer/POAPackage/NoServant.java。

class

NoServantHelper
org/omg/PortableServer/POAPackage/NoServantHelper.java。

class

ObjectAlreadyActive
org/omg/PortableServer/POAPackage/ObjectAlreadyActive.java。

class

ObjectAlreadyActiveHelper
org/omg/PortableServer/POAPackage/ObjectAlreadyActiveHelper.java。

class

ObjectNotActive
org/omg/PortableServer/POAPackage/ObjectNotActive.java。

class

ObjectNotActiveHelper
org/omg/PortableServer/POAPackage/ObjectNotActiveHelper.java。

class

ServantAlreadyActive
org/omg/PortableServer/POAPackage/ServantAlreadyActive.java。

class

ServantAlreadyActiveHelper
org/omg/PortableServer/POAPackage/ServantAlreadyActiveHelper.java。

class

ServantNotActive
org/omg/PortableServer/POAPackage/ServantNotActive.java。

class

ServantNotActiveHelper
org/omg/PortableServer/POAPackage/ServantNotActiveHelper.java。

class

WrongAdapter
org/omg/PortableServer/POAPackage/WrongAdapter.java。

class

WrongAdapterHelper
org/omg/PortableServer/POAPackage/WrongAdapterHelper.java。

class

WrongPolicy
org/omg/PortableServer/POAPackage/WrongPolicy.java。

class

WrongPolicyHelper
org/omg/PortableServer/POAPackage/WrongPolicyHelper.java。

org.omg.PortableServer.ServantLocatorPackage 中 Object 的使用

org.omg.PortableServer.ServantLocatorPackage 中 Object 的子类

class

CookieHolder
native 类型 PortableServer::ServantLocator::Cookie 被映射到 java.lang.Object。

声明为 Object 的 org.omg.PortableServer.ServantLocatorPackage 中的字段

Object

CookieHolder.value

参数类型为 Object 的 org.omg.PortableServer.ServantLocatorPackage 中的构造方法

CookieHolder(Object initial)

org.omg.stub.java.rmi 中 Object 的使用

org.omg.stub.java.rmi 中 Object 的子类

class

_Remote_Stub
此类为 Remote 类型提供 Stub。

org.w3c.dom 中 Object 的使用

org.w3c.dom 中 Object 的子类

class

DOMException
DOM 操作只在 "exceptional" 情况下引发异常，即不能执行操作时（由于逻辑原因，因为丢失数据或因为实现变得不稳定）。

返回 Object 的 org.w3c.dom 中的方法

Object

DOMImplementation.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现了 DOM Features 中所指定的特定特性或版本的特殊 API。

Object

Node.getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。

Object

DOMConfiguration.getParameter(String name)
如果已知，则返回参数的值。

Object

DOMError.getRelatedData()
相关的与 DOMError.type 有关的数据（如果有）。

Object

DOMError.getRelatedException()
相关的与相关平台有关的异常（如果有）。

Object

Node.getUserData(String key)
检索与此节点上的某个键相关联的对象。

Object

Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

参数类型为 Object 的 org.w3c.dom 中的方法

boolean

DOMConfiguration.canSetParameter(String name, Object value)
检查是否支持将参数设置为特定值。

void

UserDataHandler.handle(short operation, String key, Object data, Node src, Node dst)
每当导入或克隆为其注册此处理程序的节点时，调用此方法。

void

DOMConfiguration.setParameter(String name, Object value)
设置参数的值。

Object

Node.setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。

org.w3c.dom.bootstrap 中 Object 的使用

org.w3c.dom.bootstrap 中 Object 的子类

class

DOMImplementationRegistry
启用应用程序来获得 DOMImplementation 实例的工厂。

org.w3c.dom.events 中 Object 的使用

org.w3c.dom.events 中 Object 的子类

class

EventException
事件操作可以像在其方法描述中指定的那样抛出 EventException。

org.w3c.dom.ls 中 Object 的使用

org.w3c.dom.ls 中 Object 的子类

class

LSException
如果处理停止，解析或写操作可以抛出 LSException。

org.xml.sax 中 Object 的使用

org.xml.sax 中 Object 的子类

class

HandlerBase
已过时。 此类可可以与不推荐使用的 DocumentHandler 接口一起工作。它已经被 SAX2 DefaultHandler 类所取代。

class

InputSource
XML 实体的单一输入源。

class

SAXException
封装一般的 SAX 错误或警告。

class

SAXNotRecognizedException
用于未识别的标识符的 Exception 类。

class

SAXNotSupportedException
用于不被支持的操作的 Exception 类。

class

SAXParseException
封装 XML 解析错误或警告。

返回 Object 的 org.xml.sax 中的方法

Object

XMLReader.getProperty(String name)
查找属性的值。

参数类型为 Object 的 org.xml.sax 中的方法

void

XMLReader.setProperty(String name, Object value)
设置属性的值。

org.xml.sax.ext 中 Object 的使用

org.xml.sax.ext 中 Object 的子类

class

Attributes2Impl
用于附加的 Attributes 信息的、实现 Attributes2 接口的 SAX2 扩展帮助器。

class

DefaultHandler2
此类扩展 SAX2 基本处理程序类，以支持 SAX2 LexicalHandler、DeclHandler 和 EntityResolver2 扩展。

class

Locator2Impl
用于保存附加 Entity 信息、实现 Locator2 接口的 SAX2 扩展帮助器。

org.xml.sax.helpers 中 Object 的使用

org.xml.sax.helpers 中 Object 的子类

class

AttributeListImpl
已过时。 此类实现不推荐使用的接口 AttributeList；该接口已被 AttributesImpl 帮助器类中实现的 Attributes 取代。

class

AttributesImpl
Attributes 接口的默认实现。

class

DefaultHandler
SAX2 事件处理程序的默认基类。

class

LocatorImpl
提供 Locator 的可选的有用实现。

class

NamespaceSupport
封装名称空间逻辑，以便由使用 SAX 的应用程序使用，或由 SAX 驱动程序内部使用。

class

ParserAdapter
将 SAX1 Parser 适配为 SAX2 XMLReader。

class

ParserFactory
已过时。 此类与不推荐使用的 Parser 接口一起使用。

class

XMLFilterImpl
派生 XML 过滤器的基类。

class

XMLReaderAdapter
将 SAX2 XMLReader 适配为 SAX1 解析器。

class

XMLReaderFactory
创建 XML 阅读器的工厂。

返回 Object 的 org.xml.sax.helpers 中的方法

Object

ParserAdapter.getProperty(String name)
获取解析器属性。

Object

XMLFilterImpl.getProperty(String name)
查找属性值。

参数类型为 Object 的 org.xml.sax.helpers 中的方法

void

ParserAdapter.setProperty(String name, Object value)
设置解析器属性。

void

XMLFilterImpl.setProperty(String name, Object value)
设置属性值。

概述

软件包

类

使用

树

已过时

索引

帮助

JavaTM 2 Platform
Standard Ed. 6

上一个 下一个

框架 无框架


BigDecimal (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.math
类 BigDecimal

java.lang.Object
    继承者  java.lang.Number
        继承者  java.math.BigDecimal
所有已实现的接口：
Serializable, Comparable<BigDecimal>
public class BigDecimal
extends Number
implements Comparable<BigDecimal>

不可变的、任意精度的有符号十进制数。BigDecimal 由任意精度的整数非标度值 和 32 位的整数标度 (scale) 组成。如果为零或正数，则标度是小数点后的位数。如果为负数，则将该数的非标度值乘以 10 的负 scale 次幂。因此，BigDecimal 表示的数值是 (unscaledValue × 10-scale)。

BigDecimal 类提供以下操作：算术、标度操作、舍入、比较、哈希算法和格式转换。toString() 方法提供 BigDecimal 的规范表示形式。

BigDecimal 类使用户能完全控制舍入行为。如果未指定舍入模式，并且无法表示准确结果，则抛出一个异常；否则，通过向该操作提供适当的 MathContext 对象，可以对已选择的精度和舍入模式执行计算。在任何情况下，可以为舍入控制提供八种舍入模式。使用此类（例如，ROUND_HALF_UP）中的整数字段来表示舍入模式已过时；应改为使用 RoundingMode enum（例如，RoundingMode.HALF_UP）的枚举值。

当为 MathContext 对象提供 0 的精度设置（例如，MathContext.UNLIMITED）时，算术运算是准确的，它们是不采用任何 MathContext 对象的算术方法。（这是第 5 版之前的版本支持的唯一行为。）为了计算准确结果，不使用附带 0 精度设置的 MathContext 对象的舍入模式设置，因此与该对象无关。在除法中，准确的商可能是一个无限长的十进制扩展；例如，1 除以 3 所得的商。如果商具有无穷的十进制扩展，但是指定了该操作返回准确结果，则抛出 ArithmeticException。否则，像其他操作那样，返回除法运算的准确结果。

当精度设置不为 0 时，BigDecimal 算法的规则完全符合 ANSI X3.274-1996 和 ANSI X3.274-1996/AM 1-2000（ 7.4 节）中定义的算法的可选操作模式。与上述标准不同，BigDecimal 包括多种舍入模式，它们对于版本 5 以前的 BigDecimal 版本中的除法是强制性的。这些 ANSI 标准和 BigDecimal 规范之间的任何冲突都按照有利于 BigDecimal 的方式进行解决。

由于同一数值可以有不同的表示形式（具有不同的标度），因此运算和舍入的规则必须同时指定数值结果和结果表示形式中所用的标度。

一般情况下，当准确结果（在除法中，可能有无限多位）比返回的数值具有更多位数时，舍入模式和精度设置确定操作如何返回具有有限位数的结果。 首先，MathContext 的 precision 设置指定要返回的总位数；这确定了结果的精度。位数计数从准确结果的最左边的非零数字开始。舍入模式确定丢弃的尾部位数如何影响返回的结果。

对于所有算术运算符，运算的执行方式是，首先计算准确的中间结果，然后，使用选择的舍入模式将其舍入为精度设置（如有必要）指定的位数。如果不返回准确结果，则将丢弃准确结果的某些数位。当舍入增加了返回结果的大小时，前导数字“9”的进位传播可能会创建新的数位。例如，将值 999.9 舍入为三位数字，则在数值上等于一千，表示为 100×101。在这种情况下，新的 "1" 是返回结果的前导数位。

除了逻辑的准确结果外，每种算术运算都有一个表示结果的首选标度。下表列出了每个运算的首选标度。

算术运算结果的首选标度

运算 | 结果的首选标度
加 | max(addend.scale(), augend.scale())
减 | max(minuend.scale(), subtrahend.scale())
乘 | multiplier.scale() + multiplicand.scale()
除 | dividend.scale() - divisor.scale()
这些标度是返回准确算术结果的方法使用的标度；准确相除可能必须使用较大的标度除外，因为准确的结果可能有较多的位数。例如，1/32 得到 0.03125。

舍入之前，逻辑的准确中间结果的标度是该运算的首选标度。如果用 precision 位数无法表示准确的数值结果，则舍入会选择要返回的一组数字，并将该结果的标度从中间结果的标度减小到可以表示实际返回的 precision 位数的最小标度。如果准确结果可以使用最多 precision 个数字表示，则返回具有最接近首选标度的标度的结果表示形式。尤其是，通过移除结尾零并减少标度，可以用少于 precision 个数字来表示准确的可表示的商。例如，使用 floor 舍入模式将结果舍入为三个数字，
19/100 = 0.19 // integer=19, scale=2
但是
21/110 = 0.190 // integer=190, scale=3

注意，对于加、减和乘，标度的缩减量将等于丢弃的准确结果的数字位置数。如果舍入导致进位传播创建一个新的高位，则当未创建新的数位时，会丢弃该结果的附加数字。

其他方法可能与舍入语义稍微不同。例如，使用指定的算法的 pow 方法得到的结果可能偶尔不同于舍入得到的算术结果，如最后一位有多个单位（ulp）。

可以通过两种类型的操作来处理 BigDecimal 的标度：标度/舍入操作和小数点移动操作。标度/舍入操作（setScale 和 round）返回 BigDecimal，其值近似地（或精确地）等于操作数的值，但是其标度或精度是指定的值；即：它们会增加或减少对其值具有最小影响的存储数的精度。小数点移动操作（movePointLeft 和 movePointRight）返回从操作数创建的 BigDecimal，创建的方法是按指定方向将小数点移动一个指定距离。

为了简洁明了起见，整个 BigDecimal 方法的描述中都使用了伪代码。伪代码表达式 (i + j) 是“其值为 BigDecimal i 加 BigDecimal j 的 BigDecimal”的简写。伪代码表达式 (i == j) 是“当且仅当 BigDecimal i 表示与 BigDecimal j 相同的值时，则为 true”的简写。可以类似地解释其他伪代码表达式。方括号用于表示特定的 BigInteger 和定义 BigDecimal 值的标度对；例如，[19, 2] 表示 BigDecimal 在数值上等于 0.19，标度是 2。

注：如果 BigDecimal 对象用作 SortedMap 中的键或 SortedSet 中的元素，则应特别小心，因为 BigDecimal 的自然排序与 equals 方法不一致。有关更多信息，请参见 Comparable、SortedMap 或 SortedSet。

当为任何输入参数传递 null 对象引用时，此类的所有方法和构造方法都将抛出 NullPointerException。

另请参见：
BigInteger, MathContext, RoundingMode, SortedMap, SortedSet, 序列化表格

字段摘要
static BigDecimal | ONE 值为 1，标度为 0。
static int | ROUND_CEILING 接近正无穷大的舍入模式。
static int | ROUND_DOWN 接近零的舍入模式。
static int | ROUND_FLOOR 接近负无穷大的舍入模式。
static int | ROUND_HALF_DOWN 向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为上舍入的舍入模式。
static int | ROUND_HALF_EVEN 向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则向相邻的偶数舍入。
static int | ROUND_HALF_UP 向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为向上舍入的舍入模式。
static int | ROUND_UNNECESSARY 断言请求的操作具有精确的结果，因此不需要舍入。
static int | ROUND_UP 舍入远离零的舍入模式。
static BigDecimal | TEN 值为 10，标度为 0。
static BigDecimal | ZERO 值为 0，标度为 0。
构造方法摘要
BigDecimal(BigInteger val)
将 BigInteger 转换为 BigDecimal。
BigDecimal(BigInteger unscaledVal, int scale)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal。
BigDecimal(BigInteger unscaledVal, int scale, MathContext mc)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger val, MathContext mc)
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(char[] in)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列。
BigDecimal(char[] in, int offset, int len)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组。
BigDecimal(char[] in, int offset, int len, MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组，并根据上下文设置进行舍入。
BigDecimal(char[] in, MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列（根据上下文设置进行舍入）。
BigDecimal(double val)
将 double 转换为 BigDecimal，后者是 double 的二进制浮点值准确的十进制表示形式。
BigDecimal(double val, MathContext mc)
将 double 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(int val)
将 int 转换为 BigDecimal。
BigDecimal(int val, MathContext mc)
将 int 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(long val)
将 long 转换为 BigDecimal。
BigDecimal(long val, MathContext mc)
将 long 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(String val)
将 BigDecimal 的字符串表示形式转换为 BigDecimal。
BigDecimal(String val, MathContext mc)
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。
方法摘要
 BigDecimal abs()
返回 BigDecimal，其值为此 BigDecimal 的绝对值，其标度为 this.scale()。
 BigDecimal abs(MathContext mc)
返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal add(BigDecimal augend)
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。
 BigDecimal add(BigDecimal augend, MathContext mc)
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
 byte byteValueExact()
将此 BigDecimal 转换为 byte，以检查丢失的信息。
 int compareTo(BigDecimal val)
将此 BigDecimal 与指定的 BigDecimal 比较。
 BigDecimal divide(BigDecimal divisor)
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。
 BigDecimal divide(BigDecimal divisor, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal divide(BigDecimal divisor, int scale, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal divide(BigDecimal divisor, int scale, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal divide(BigDecimal divisor, MathContext mc)
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal divide(BigDecimal divisor, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal[] divideAndRemainder(BigDecimal divisor)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。
 BigDecimal[] divideAndRemainder(BigDecimal divisor, MathContext mc)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
 BigDecimal divideToIntegralValue(BigDecimal divisor)
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。
 BigDecimal divideToIntegralValue(BigDecimal divisor, MathContext mc)
返回 BigDecimal，其值为 (this / divisor) 的整数部分。
 double doubleValue()
将此 BigDecimal 转换为 double。
 boolean equals(Object x)
比较此 BigDecimal 与指定的 Object 的相等性。
 float floatValue()
将此 BigDecimal 转换为 float。
 int hashCode()
返回此 BigDecimal 的哈希码。
 int intValue()
将此 BigDecimal 转换为 int。
 int intValueExact()
将此 BigDecimal 转换为 int，以检查丢失的信息。
 long longValue()
将此 BigDecimal 转换为 long。
 long longValueExact()
将此 BigDecimal 转换为 long，以检查丢失的信息。
 BigDecimal max(BigDecimal val)
返回此 BigDecimal 和 val 的最大值。
 BigDecimal min(BigDecimal val)
返回此 BigDecimal 和 val 的最小值。
 BigDecimal movePointLeft(int n)
返回一个 BigDecimal，它等效于将该值的小数点向左移动 n 位。
 BigDecimal movePointRight(int n)
返回一个 BigDecimal，它等效于将该值的小数点向右移动 n 位。
 BigDecimal multiply(BigDecimal multiplicand)
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。
 BigDecimal multiply(BigDecimal multiplicand, MathContext mc)
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal negate()
返回 BigDecimal，其值为 (-this)，其标度为 this.scale()。
 BigDecimal negate(MathContext mc)
返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal plus()
返回 BigDecimal，其值为 (+this)，其标度为 this.scale()。
 BigDecimal plus(MathContext mc)
返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal pow(int n)
返回其值为 (thisn) 的 BigDecimal，准确计算该幂，使其具有无限精度。
 BigDecimal pow(int n, MathContext mc)
返回其值为 (thisn) 的 BigDecimal。
 int precision()
返回此 BigDecimal 的精度。
 BigDecimal remainder(BigDecimal divisor)
返回其值为 (this % divisor) 的 BigDecimal。
 BigDecimal remainder(BigDecimal divisor, MathContext mc)
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal round(MathContext mc)
返回根据 MathContext 设置进行舍入后的 BigDecimal。
 int scale()
返回此 BigDecimal 的标度。
 BigDecimal scaleByPowerOfTen(int n)
返回其数值等于 (this * 10n) 的 BigDecimal。
 BigDecimal setScale(int newScale)
返回一个 BigDecimal，其标度为指定值，其值在数值上等于此 BigDecimal 的值。
 BigDecimal setScale(int newScale, int roundingMode)
返回一个 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
 BigDecimal setScale(int newScale, RoundingMode roundingMode)
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
 short shortValueExact()
将此 BigDecimal 转换为 short，以检查丢失的信息。
 int signum()
返回此 BigDecimal 的正负号函数。
 BigDecimal stripTrailingZeros()
返回数值上等于此小数，但从该表示形式移除所有尾部零的 BigDecimal。
 BigDecimal subtract(BigDecimal subtrahend)
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。
 BigDecimal subtract(BigDecimal subtrahend, MathContext mc)
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。
 BigInteger toBigInteger()
将此 BigDecimal 转换为 BigInteger。
 BigInteger toBigIntegerExact()
将此 BigDecimal 转换为 BigInteger，以检查丢失的信息。
 String toEngineeringString()
返回此 BigDecimal 的字符串表示形式，需要指数时，则使用工程计数法。
 String toPlainString()
返回不带指数字段的此 BigDecimal 的字符串表示形式。
 String toString()
返回此 BigDecimal 的字符串表示形式，如果需要指数，则使用科学记数法。
 BigDecimal ulp()
返回此 BigDecimal 的 ulp（最后一位的单位）的大小。
 BigInteger unscaledValue()
返回其值为此 BigDecimal 的非标度值 的 BigInteger。
static BigDecimal valueOf(double val)
使用 Double.toString(double) 方法提供的 double 规范的字符串表示形式将 double 转换为 BigDecimal。
static BigDecimal valueOf(long val)
将 long 值转换为具有零标度的 BigDecimal。
static BigDecimal valueOf(long unscaledVal, int scale)
将 long 非标度值和 int 标度转换为 BigDecimal。
从类 java.lang.Number 继承的方法
byteValue, shortValue
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ZERO

public static final BigDecimal ZERO
值为 0，标度为 0。

从以下版本开始：
1.5

ONE

public static final BigDecimal ONE
值为 1，标度为 0。

从以下版本开始：
1.5

TEN

public static final BigDecimal TEN
值为 10，标度为 0。

从以下版本开始：
1.5

ROUND_UP

public static final int ROUND_UP
舍入远离零的舍入模式。在丢弃非零部分之前始终增加数字。注意，此舍入模式始终不会减少计算值的大小。

另请参见：
常量字段值

ROUND_DOWN

public static final int ROUND_DOWN
接近零的舍入模式。在丢弃某部分之前始终不增加数字（即截短）。注意，此舍入模式始终不会增加计算值的大小。

另请参见：
常量字段值

ROUND_CEILING

public static final int ROUND_CEILING
接近正无穷大的舍入模式。如果 BigDecimal 为正，则舍入行为与 ROUND_UP 相同；如果为负，则舍入行为与 ROUND_DOWN 相同。注意，此舍入模式始终不会减少计算值。

另请参见：
常量字段值

ROUND_FLOOR

public static final int ROUND_FLOOR
接近负无穷大的舍入模式。如果 BigDecimal 为正，则舍入行为与 ROUND_DOWN 相同；如果为负，则舍入行为与 ROUND_UP 相同。注意，此舍入模式始终不会增加计算值。

另请参见：
常量字段值

ROUND_HALF_UP

public static final int ROUND_HALF_UP
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为向上舍入的舍入模式。如果舍弃部分 >= 0.5，则舍入行为与 ROUND_UP 相同；否则舍入行为与 ROUND_DOWN 相同。注意，这是我们大多数人在小学时就学过的舍入模式。

另请参见：
常量字段值

ROUND_HALF_DOWN

public static final int ROUND_HALF_DOWN
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则为上舍入的舍入模式。如果舍弃部分 > 0.5，则舍入行为与 ROUND_UP 相同；否则舍入行为与 ROUND_DOWN 相同。

另请参见：
常量字段值

ROUND_HALF_EVEN

public static final int ROUND_HALF_EVEN
向“最接近的”数字舍入，如果与两个相邻数字的距离相等，则向相邻的偶数舍入。如果舍弃部分左边的数字为奇数，则舍入行为与 ROUND_HALF_UP 相同；如果为偶数，则舍入行为与 ROUND_HALF_DOWN 相同。注意，在重复进行一系列计算时，此舍入模式可以将累加错误减到最小。

另请参见：
常量字段值

ROUND_UNNECESSARY

public static final int ROUND_UNNECESSARY
断言请求的操作具有精确的结果，因此不需要舍入。如果对获得精确结果的操作指定此舍入模式，则抛出 ArithmeticException。

另请参见：
常量字段值
构造方法详细信息

BigDecimal

public BigDecimal(char[] in,
                  int offset,
                  int len)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组。

注意，如果字符数组中已经提供字符的序列，则使用此构造方法要比将 char 数组转换为字符串并使用 BigDecimal(String) 构造方法更快。

参数：
in - 作为源字符的 char 数组。
offset - 要检查的数组中的第一个字符。
len - 要考虑的字符数。
抛出：
NumberFormatException - 如果 in 不是 BigDecimal 的有效表示形式，或者定义的子数组不完全在 in 中。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(char[] in,
                  int offset,
                  int len,
                  MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组，并根据上下文设置进行舍入。

注意，如果字符数组中已经提供字符的序列，则使用此构造方法要比将 char 数组转换为字符串并使用 BigDecimal(String) 构造方法更快。

参数：
in - 作为源字符的 char 数组。
offset - 要检查的数组中的第一个字符。
len - 要考虑的字符数。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，且舍入模式为 UNNECESSARY。
NumberFormatException - 如果 in 不是 BigDecimal 的有效表示形式，或者定义的子数组不完全在 in 中。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(char[] in)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列。

注意，如果字符序列已经可以作为一个字符数组使用，则使用此构造方法要比将 char 数组转换为字符串并使用 BigDecimal(String) 构造方法更快。

参数：
in - 作为源字符的 char 数组。
抛出：
NumberFormatException - 如果 in 不是 BigDecimal 的有效表示形式。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(char[] in,
                  MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符序列（根据上下文设置进行舍入）。

注意，如果字符序列已经可以作为一个字符数组使用，则使用此构造方法要比将 char 数组转换为字符串并使用 BigDecimal(String) 构造方法更快。

参数：
in - 作为源字符的 char 数组。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，且舍入模式为 UNNECESSARY。
NumberFormatException - 如果 in 不是 BigDecimal 的有效表示形式。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(String val)
将 BigDecimal 的字符串表示形式转换为 BigDecimal。字符串表示形式由可选符号 '+' ('\u002B') 或 '-' ('\u002D') 组成，后跟零或多个十进制数字（“整数”）的序列，可以选择后跟一个小数，也可以选择后跟一个指数。

该小数由小数点以及后跟的零或更多十进制数字组成。字符串必须至少包含整数或小数部分中的一个数字。由符号、整数和小数部分组成的数字称为有效位数。

指数由字符 'e'（'\u0065') 或 'E' ('\u0045') 以及后跟的一个或多个十进制数字组成。指数的值必须位于 Integer.MAX_VALUE (Integer.MIN_VALUE+1) 和 Integer.MAX_VALUE（包括）之间。

更正式地说，以下语法描述了此构造方法接受的字符串：

BigDecimalString:
Signopt Significand Exponentopt

Sign:
+
-

Significand:
IntegerPart .FractionPartopt
. FractionPart
IntegerPart

IntegerPart:
Digits

FractionPart:
Digits

Exponent:
ExponentIndicator SignedInteger

ExponentIndicator:
e
E

SignedInteger:
Signopt Digits

Digits:
Digit
Digits Digit

Digit:
Character.isDigit(char) 对其返回 true 的任何字符，如 0、1、2……

返回的 BigDecimal 的标度将是小数部分中的数字位数，如果该字符串不包含小数点，则标度为零，这取决于对指数的调整；如果字符串包含一个指数，则从标度减去该指数。得到的标度值必须位于 Integer.MIN_VALUE 和 Integer.MAX_VALUE（包括）之间。

Character.digit(char, int) 集提供从字符到数字的映射，以转换成基数 10。该字符串不能包含任何额外字符（例如，空白）。

示例：
返回的 BigDecimal 的值等于有效位数 × 10 指数。对于左边的每个字符串，得到的表示形式 [BigInteger, scale] 显示在右边。

 "0"            [0,0]
 "0.00"         [0,2]
 "123"          [123,0]
 "-123"         [-123,0]
 "1.23E3"       [123,-1]
 "1.23E+3"      [123,-1]
 "12.3E+7"      [123,-6]
 "12.0"         [120,1]
 "12.3"         [123,1]
 "0.00123"      [123,5]
 "-1.23E-12"    [-123,14]
 "1234.5E-4"    [12345,5]
 "0E+7"         [0,-7]
 "-0"           [0,0]

注：对于不是 float、double NaN 和 ±Infinity 的值，此构造方法与 Float.toString(float) 和 Double.toString(double) 返回的值兼容。这通常是将 float 或 double 转换为 BigDecimal 的首选方法，因为它不会遇到 BigDecimal(double) 构造方法的不可预知问题。

参数：
val - BigDecimal 的字符串表示形式。
抛出：
NumberFormatException - 如果 val 不是 BigDecimal 的有效表示形式。

BigDecimal

public BigDecimal(String val,
                  MathContext mc)
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。

参数：
val - BigDecimal 的字符串表示形式。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，且舍入模式为 UNNECESSARY。
NumberFormatException - 如果 val 不是 BigDecimal 的有效表示形式。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(double val)
将 double 转换为 BigDecimal，后者是 double 的二进制浮点值准确的十进制表示形式。返回的 BigDecimal 的标度是使 (10scale × val) 为整数的最小值。

注：

  1. 此构造方法的结果有一定的不可预知性。有人可能认为在 Java 中写入 new BigDecimal(0.1) 所创建的 BigDecimal 正好等于 0.1（非标度值 1，其标度为 1），但是它实际上等于 0.1000000000000000055511151231257827021181583404541015625。这是因为 0.1 无法准确地表示为 double（或者说对于该情况，不能表示为任何有限长度的二进制小数）。这样，传入 到构造方法的值不会正好等于 0.1（虽然表面上等于该值）。
  2. 另一方面，String 构造方法是完全可预知的：写入 new BigDecimal("0.1") 将创建一个 BigDecimal，它正好 等于预期的 0.1。因此，比较而言，通常建议优先使用 String 构造方法。
  3. 当 double 必须用作 BigDecimal 的源时，请注意，此构造方法提供了一个准确转换；它不提供与以下操作相同的结果：先使用 Double.toString(double) 方法，然后使用 BigDecimal(String) 构造方法，将 double 转换为 String。要获取该结果，请使用 static valueOf(double) 方法。

参数：
val - 要转换为 BigDecimal 的 double 值。
抛出：
NumberFormatException - 如果 val 为无穷大或 NaN。

BigDecimal

public BigDecimal(double val,
                  MathContext mc)
将 double 转换为 BigDecimal（根据上下文设置进行舍入）。BigDecimal 的标度是使 (10scale × val) 为整数的最小值。

此构造方法的结果有一定的不可预知性，通常不建议使用它，请参见 BigDecimal(double) 构造方法下面的注释。

参数：
val - 要转换为 BigDecimal 的 double 值。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，但是 RoundingMode 为 UNNECESSARY。
NumberFormatException - 如果 val 为无穷大或 NaN。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(BigInteger val)
将 BigInteger 转换为 BigDecimal。BigDecimal 的标度是零。

参数：
val - 要转换为 BigDecimal 的 BigInteger 值。

BigDecimal

public BigDecimal(BigInteger val,
                  MathContext mc)
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。BigDecimal 的标度为零。

参数：
val - 要转换为 BigDecimal 的 BigInteger 值。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(BigInteger unscaledVal,
                  int scale)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal。BigDecimal 的值为 (unscaledVal × 10-scale)。

参数：
unscaledVal - BigDecimal 的非标度值。
scale - BigDecimal 的标度。

BigDecimal

public BigDecimal(BigInteger unscaledVal,
                  int scale,
                  MathContext mc)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。BigDecimal 的值为 (unscaledVal × 10-scale)，它是根据 precision 和舍入模式设置进行舍入的。

参数：
unscaledVal - BigDecimal 的非标度值。
scale - BigDecimal 的标度。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(int val)
将 int 转换为 BigDecimal。BigDecimal 的标度为零。

参数：
val - 要转换为 BigDecimal 的 int 值。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(int val,
                  MathContext mc)
将 int 转换为 BigDecimal（根据上下文设置进行舍入）。在进行任何舍入之前，BigDecimal 的标度为零。

参数：
val - 要转换为 BigDecimal 的 int 值。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(long val)
将 long 转换为 BigDecimal。BigDecimal 的标度为零。

参数：
val - 要转换为 BigDecimal 的 long 值。
从以下版本开始：
1.5

BigDecimal

public BigDecimal(long val,
                  MathContext mc)
将 long 转换为 BigDecimal（根据上下文设置进行舍入）。在进行任何舍入之前，BigDecimal 的标度为零。

参数：
val - 要转换为 BigDecimal 的 long 值。
mc - 要使用的上下文。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5
方法详细信息

valueOf

public static BigDecimal valueOf(long unscaledVal,
                                 int scale)
将 long 非标度值和 int 标度转换为 BigDecimal。提供的此“静态工厂方法”优先于 (long, int) 构造方法，因为前者允许重用经常使用的 BigDecimal 值。

参数：
unscaledVal - BigDecimal 的非标度值。
scale - BigDecimal 的标度。
返回：
其值为 (unscaledVal × 10-scale) 的 BigDecimal。

valueOf

public static BigDecimal valueOf(long val)
将 long 值转换为具有零标度的 BigDecimal。提供的此“静态工厂方法”优先于 (long) 构造方法，因为前者允许重用经常使用的 BigDecimal 值。

参数：
val - BigDecimal 的值。
返回：
其值为 val 的 BigDecimal。

valueOf

public static BigDecimal valueOf(double val)
使用 Double.toString(double) 方法提供的 double 规范的字符串表示形式将 double 转换为 BigDecimal。

注：这通常是将 double（或 float）转化为 BigDecimal 的首选方法，因为返回的值等于从构造 BigDecimal（使用 Double.toString(double) 得到的结果）得到的值。

参数：
val - 要转换为 BigDecimal 的 double。
返回：
其值等于或约等于 val 值的 BigDecimal。
抛出：
NumberFormatException - 如果 val 为无穷大或 NaN。
从以下版本开始：
1.5

add

public BigDecimal add(BigDecimal augend)
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。

参数：
augend - 将添加到此 BigDecimal 中的值。
返回：
this + augend

add

public BigDecimal add(BigDecimal augend,
                      MathContext mc)
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。 如果任一数字为零，并且精度设置为非零，则其他数字（必要时进行舍入）可以作为结果。

参数：
augend - 将添加到此 BigDecimal 中的值。
mc - 要使用的上下文。
返回：
this + augend，必要时进行舍入。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

subtract

public BigDecimal subtract(BigDecimal subtrahend)
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。

参数：
subtrahend - 从此 BigDecimal 减去的值。
返回：
this - subtrahend

subtract

public BigDecimal subtract(BigDecimal subtrahend,
                           MathContext mc)
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。 如果 subtrahend 为零，则将其（必要时进行舍入）作为结果。如果为零，则该结果是 subtrahend.negate(mc)。

参数：
subtrahend - 从此 BigDecimal 减去的值。
mc - 要使用的上下文。
返回：
this - subtrahend，必要时进行舍入。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

multiply

public BigDecimal multiply(BigDecimal multiplicand)
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。

参数：
multiplicand - 乘以此 BigDecimal 的值。
返回：
this * multiplicand

multiply

public BigDecimal multiply(BigDecimal multiplicand,
                           MathContext mc)
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。

参数：
multiplicand - 乘以此 BigDecimal 的值。
mc - 要使用的上下文。
返回：
必要时舍入的 this * multiplicand。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

divide

public BigDecimal divide(BigDecimal divisor,
                         int scale,
                         int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。如果必须执行舍入，以生成具有指定标度的结果，则应用指定的舍入模式。

相对于此遗留方法，应优先使用新的 divide(BigDecimal, int, RoundingMode) 方法。

参数：
divisor - 此 BigDecimal 要除以的值。
scale - 要返回的 BigDecimal 商的标度。
roundingMode - 要应用的舍入模式。
返回：
this / divisor
抛出：
ArithmeticException - 如果 divisor 为零，则 roundingMode==ROUND_UNNECESSARY 和指定的标度不足以准确地表示相除的结果。
IllegalArgumentException - 如果 roundingMode 不表示一个有效的舍入模式。
另请参见：
ROUND_UP, ROUND_DOWN, ROUND_CEILING, ROUND_FLOOR, ROUND_HALF_UP, ROUND_HALF_DOWN, ROUND_HALF_EVEN, ROUND_UNNECESSARY

divide

public BigDecimal divide(BigDecimal divisor,
                         int scale,
                         RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。如果必须执行舍入，以生成具有指定标度的结果，则应用指定的舍入模式。

参数：
divisor - 此 BigDecimal 要除以的值。
scale - 要返回的 BigDecimal 商的标度。
roundingMode - 要应用的舍入模式。
返回：
this / divisor
抛出：
ArithmeticException - 如果 divisor 为零，则 roundingMode==RoundingMode.UNNECESSARY 和指定的标度不足以准确地表示相除的结果。
从以下版本开始：
1.5

divide

public BigDecimal divide(BigDecimal divisor,
                         int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。如果必须执行舍入，以生成具有给定标度的结果，则应用指定的舍入模式。

相对于此遗留方法，应优先使用新的 divide(BigDecimal, RoundingMode) 方法。

参数：
divisor - 此 BigDecimal 要除以的值。
roundingMode - 要应用的舍入模式。
返回：
this / divisor
抛出：
ArithmeticException - 如果 divisor==0 或者 roundingMode==ROUND_UNNECESSARY 和 this.scale() 不足以准确地表示相除的结果。
IllegalArgumentException - 如果 roundingMode 不表示一个有效的舍入模式。
另请参见：
ROUND_UP, ROUND_DOWN, ROUND_CEILING, ROUND_FLOOR, ROUND_HALF_UP, ROUND_HALF_DOWN, ROUND_HALF_EVEN, ROUND_UNNECESSARY

divide

public BigDecimal divide(BigDecimal divisor,
                         RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。如果必须执行舍入，以生成具有给定标度的结果，则应用指定的舍入模式。

参数：
divisor - 此 BigDecimal 要除以的值。
roundingMode - 要应用的舍入模式。
返回：
this / divisor
抛出：
ArithmeticException - 如果 divisor==0 或者 roundingMode==RoundingMode.UNNECESSARY 和 this.scale() 不足以准确地表示相除的结果。
从以下版本开始：
1.5

divide

public BigDecimal divide(BigDecimal divisor)
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。

参数：
divisor - 此 BigDecimal 要相除的值。
返回：
this / divisor
抛出：
ArithmeticException - 如果准确的商值没有无穷的十进制扩展
从以下版本开始：
1.5

divide

public BigDecimal divide(BigDecimal divisor,
                         MathContext mc)
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。

参数：
divisor - 此 BigDecimal 要除以的值。
mc - 要使用的上下文。
返回：
this / divisor，必要时进行舍入。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY 或 mc.precision == 0，并且商值具有无穷的十进制扩展。
从以下版本开始：
1.5

divideToIntegralValue

public BigDecimal divideToIntegralValue(BigDecimal divisor)
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。该结果的首选标度为 (this.scale() - divisor.scale())。

参数：
divisor - 此 BigDecimal 要除以的值。
返回：
this / divisor 的整数部分。
抛出：
ArithmeticException - 如果 divisor==0
从以下版本开始：
1.5

divideToIntegralValue

public BigDecimal divideToIntegralValue(BigDecimal divisor,
                                        MathContext mc)
返回 BigDecimal，其值为 (this / divisor) 的整数部分。因为准确商值的整数部分与舍入模式无关，所以舍入模式不影响此方法返回的值。该结果的首选标度是 (this.scale() - divisor.scale())。如果准确商值的整数部分需要的位数多于 mc.precision，则抛出 ArithmeticException。

参数：
divisor - 此 BigDecimal 要相除的值。
mc - 要使用的上下文。
返回：
this / divisor 的整数部分。
抛出：
ArithmeticException - 如果 divisor==0
ArithmeticException - 如果 mc.precision > 0，并且该结果需要的精度大于 mc.precision。
从以下版本开始：
1.5

remainder

public BigDecimal remainder(BigDecimal divisor)
返回其值为 (this % divisor) 的 BigDecimal。

余数由 this.subtract(this.divideToIntegralValue(divisor).multiply(divisor)) 给出。注意，这不是模操作（结果可以为负）。

参数：
divisor - 此 BigDecimal 要除以的值。
返回：
this % divisor。
抛出：
ArithmeticException - 如果 divisor==0
从以下版本开始：
1.5

remainder

public BigDecimal remainder(BigDecimal divisor,
                            MathContext mc)
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。MathContext 设置会影响用于计算余数的隐式除法。余数计算本身要进行准确的定义。因此，余数包含的数字个数可能多于 mc.getPrecision()。

余数由 this.subtract(this.divideToIntegralValue(divisor, mc).multiply(divisor)) 给出。注意，这不是模操作（结果可以为负）。

参数：
divisor - 此 BigDecimal 要相除的值。
mc - 要使用的上下文。
返回：
this % divisor，必要时进行舍入。
抛出：
ArithmeticException - 如果 divisor==0
ArithmeticException - 如果结果不准确，但舍入模式为 UNNECESSARY，或者 mc.precision > 0，并且 this.divideToIntgralValue(divisor) 的结果要求的精度大于 mc.precision。
从以下版本开始：
1.5
另请参见：
divideToIntegralValue(java.math.BigDecimal, java.math.MathContext)

divideAndRemainder

public BigDecimal[] divideAndRemainder(BigDecimal divisor)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。

注意，如果同时需要整数商和余数，则此方法比分别使用 divideToIntegralValue 和 remainder 方法更快速，因为相除仅需执行一次。

参数：
divisor - 此 BigDecimal 要相除的值和计算的余数。
返回：
由两个元素组成的 BigDecimal 数组：商值（divideToIntegralValue 的结果）是初始元素，余数是最终元素。
抛出：
ArithmeticException - 如果 divisor==0
从以下版本开始：
1.5
另请参见：
divideToIntegralValue(java.math.BigDecimal, java.math.MathContext), remainder(java.math.BigDecimal, java.math.MathContext)

divideAndRemainder

public BigDecimal[] divideAndRemainder(BigDecimal divisor,
                                       MathContext mc)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。

注意，如果同时需要整数商和余数，则此方法比分别使用 divideToIntegralValue 和 remainder 方法更快速，因为相除仅需执行一次。

参数：
divisor - 此 BigDecimal 要相除的值和计算的余数。
mc - 要使用的上下文。
返回：
由两个元素组成的 BigDecimal 数组：商值（divideToIntegralValue 的结果）是初始元素，余数是最终元素。
抛出：
ArithmeticException - 如果 divisor==0
ArithmeticException - 如果结果不准确，但舍入模式为 UNNECESSARY，或者 mc.precision > 0，并且 this.divideToIntgralValue(divisor) 的结果要求的精度大于 mc.precision。
从以下版本开始：
1.5
另请参见：
divideToIntegralValue(java.math.BigDecimal, java.math.MathContext), remainder(java.math.BigDecimal, java.math.MathContext)

pow

public BigDecimal pow(int n)
返回其值为 (thisn) 的 BigDecimal，准确计算该幂，使其具有无限精度。

参数 n 必须在 0 到 999999999（包括）之间。ZERO.pow(0) 返回 ONE。 注意，未来版本可能会扩展此方法允许的指数范围。

参数：
n - 此 BigDecimal 的幂。
返回：
thisn
抛出：
ArithmeticException - 如果 n 超出范围。
从以下版本开始：
1.5

pow

public BigDecimal pow(int n,
                      MathContext mc)
返回其值为 (thisn) 的 BigDecimal。当前实现使用的是 ANSI 标准 X3.274-1996 中定义的核心算法（根据上下文设置进行舍入）。一般情况下，返回的数值在具有选择精度的精确数值的两个 ulp 中。注意，未来版本可以使用不同的算法，以减少允许的错误范围，并增加允许的指数范围。

X3.274-1996 算法为：

  • 如果出现以下情况，则抛出 ArithmeticException 异常
    • abs(n) > 999999999
    • mc.precision == 0 且 n < 0
    • mc.precision > 0 且 n 大于 mc.precision
  • 如果 n 为零，则返回 ONE（即使 this 为零），否则
    • 如果 n 为正数，则通过重复的平方技术将此结果计算到一个累加器中。每个附带累加器的乘法都使用与 mc 中相同的数学上下文设置，增加到 mc.precision + elength + 1 的精度除外，其中 elength 表示 n 中的十进制数字的个数。
    • 如果 n 为负数，则将 n 视为正数计算其结果；然后使用上面指定的工作精度，用一除以此值。
    • 然后将正数或负数的最终值舍入为目标精度。

参数：
n - 此 BigDecimal 的幂。
mc - 要使用的上下文。
返回：
使用 ANSI 标准 X3.274-1996 算法的 thisn
抛出：
ArithmeticException - 如果该结果不准确，但是舍入模式为 UNNECESSARY，或者 n 超出范围。
从以下版本开始：
1.5

abs

public BigDecimal abs()
返回 BigDecimal，其值为此 BigDecimal 的绝对值，其标度为 this.scale()。

返回：
abs(this)

abs

public BigDecimal abs(MathContext mc)
返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。

参数：
mc - 要使用的上下文。
返回：
abs(this)，必要时进行舍入。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

negate

public BigDecimal negate()
返回 BigDecimal，其值为 (-this)，其标度为 this.scale()。

返回：
-this。

negate

public BigDecimal negate(MathContext mc)
返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。

参数：
mc - 要使用的上下文。
返回：
abs(this)，必要时进行舍入。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5

plus

public BigDecimal plus()
返回 BigDecimal，其值为 (+this)，其标度为 this.scale()。

此方法仅返回此 BigDecimal，该方法与一元减方法 negate() 对称。

返回：
this。
从以下版本开始：
1.5
另请参见：
negate()

plus

public BigDecimal plus(MathContext mc)
返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。

此方法的效果与 round(MathContext) 方法的效果相同。

参数：
mc - 要使用的上下文。
返回：
this，必要时进行舍入。零结果具有的标度为 0。
抛出：
ArithmeticException - 如果结果不准确，但是舍入模式为 UNNECESSARY。
从以下版本开始：
1.5
另请参见：
round(MathContext)

signum

public int signum()
返回此 BigDecimal 的正负号函数。

返回：
当此 BigDecimal 的值为负、零或正时，返回 -1、0 或 1。

scale

public int scale()
返回此 BigDecimal 的标度。如果为零或正数，则标度是小数点后的位数。如果为负数，则将该数的非标度值乘以 10 的负 scale 次幂。例如，-3 标度是指非标度值乘以 1000。

返回：
此 BigDecimal 的标度。

precision

public int precision()
返回此 BigDecimal 的精度。（精度是非标度值的数字个数。）

零值的精度是 1。

返回：
此 BigDecimal 的精度。
从以下版本开始：
1.5

unscaledValue

public BigInteger unscaledValue()
返回其值为此 BigDecimal 的非标度值 的 BigInteger。（计算 (this * 10this.scale())。）

返回：
此 BigDecimal 的非标度值。
从以下版本开始：
1.2

round

public BigDecimal round(MathContext mc)
返回根据 MathContext 设置进行舍入后的 BigDecimal。如果精度设置为 0，则不进行任何舍入操作。

此方法的效果与 plus(MathContext) 方法的效果相同。

参数：
mc - 要使用的上下文。
返回：
根据 MathContext 设置舍入后的 BigDecimal。
抛出：
ArithmeticException - 如果舍入模式为 UNNECESSARY，并且 BigDecimal 操作要求进行舍入。
从以下版本开始：
1.5
另请参见：
plus(MathContext)

setScale

public BigDecimal setScale(int newScale,
                           RoundingMode roundingMode)
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。如果该操作减少标度，则非标度值必须被除（而不是乘），并且该值可以更改；在这种情况下，将指定的舍入模式应用到除法中。

参数：
newScale - 要返回的 BigDecimal 值的标度。
roundingMode - 要应用的舍入模式。
返回：
一个 BigDecimal，其标度为指定值，其非标度值可以通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
抛出：
ArithmeticException - 如果 roundingMode==UNNECESSARY，并且指定的标度操作要求进行舍入。
从以下版本开始：
1.5
另请参见：
RoundingMode

setScale

public BigDecimal setScale(int newScale,
                           int roundingMode)
返回一个 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。如果该操作减少标度，则非标度值必须被除（而不是乘），并且该值可以更改；在这种情况下，将指定的舍入模式应用到除法中。

注意，由于 BigDecimal 对象是不可变的，此方法的调用不会 导致初始对象被修改，这与使用名为 setX 变异字段 X 方法的常规约定相反。相反，setScale 返回具有适当标度的对象；返回的对象不一定是新分配的。

相对于此遗留方法，应优先使用新的 setScale(int, RoundingMode) 方法。

参数：
newScale - 要返回的 BigDecimal 值的标度。
roundingMode - 要应用的舍入模式。
返回：
一个 BigDecimal，其标度为指定值，其非标度值可以通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定。
抛出：
ArithmeticException - 如果 roundingMode==ROUND_UNNECESSARY，并且指定的标度操作要求进行舍入。
IllegalArgumentException - 如果 roundingMode 不表示一个有效的舍入模式。
另请参见：
ROUND_UP, ROUND_DOWN, ROUND_CEILING, ROUND_FLOOR, ROUND_HALF_UP, ROUND_HALF_DOWN, ROUND_HALF_EVEN, ROUND_UNNECESSARY

setScale

public BigDecimal setScale(int newScale)
返回一个 BigDecimal，其标度为指定值，其值在数值上等于此 BigDecimal 的值。如果这不可能，则抛出 ArithmeticException。

此调用通常用于增加标度，在这种情况下，可以保证存在指定标度和正确值的 BigDecimal。如果调用方知道 BigDecimal在其小数部分的结尾有足够多的零（即其整数值中的十的因子），则该调用也可用于减少标度，以允许重新标度，而不更改其值。

此方法返回与 setScale 的两个参数版本相同的结果，但是，为调用方省去了指定舍入模式的麻烦（舍入模式不影响结果）。

注意，由于 BigDecimal 对象是不可变的，因此此方法的调用不会 导致初始对象被修改，这与使用名为 setX 变异字段 X 方法的常规约定相反。相反，setScale 返回具有适当标度的对象；返回的对象不一定是新分配的。

参数：
newScale - 要返回的 BigDecimal 值的标度。
返回：
一个 BigDecimal，其标度为指定值，其非标度值可以通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
抛出：
ArithmeticException - 如果指定的标度操作要求进行舍入。
另请参见：
setScale(int, int), setScale(int, RoundingMode)

movePointLeft

public BigDecimal movePointLeft(int n)
返回一个 BigDecimal，它等效于将该值的小数点向左移动 n 位。如果 n 为非负数，则调用仅将 n 添加到该标度。如果 n 为负数，则该调用等效于 movePointRight(-n)。此调用返回的 BigDecimal 的值为 (this × 10-n)，标度为 max(this.scale()+n, 0)。

参数：
n - 将小数点向左移动的位数。
返回：
一个 BigDecimal，它等效于将该值的小数点向左移动 n 位。
抛出：
ArithmeticException - 如果标度溢出。

movePointRight

public BigDecimal movePointRight(int n)
返回一个 BigDecimal，它等效于将该值的小数点向右移动 n 位。如果 n 为非负数，则该调用仅从该标度减去 n。如果 n 为负，则该调用等效于 movePointLeft(-n)。此调用返回的 BigDecimal 的值为 (this × 10n)，标度为 max(this.scale()-n, 0)。

参数：
n - 将小数点向右移动的位数。
返回：
一个 BigDecimal，它等效于将该值的小数点向右移动 n 位。
抛出：
ArithmeticException - 如果标度溢出。

scaleByPowerOfTen

public BigDecimal scaleByPowerOfTen(int n)
返回其数值等于 (this * 10n) 的 BigDecimal。该结果的标度为 (this.scale() - n)。

抛出：
ArithmeticException - 如果该标度的范围超出 32 位整数的范围。
从以下版本开始：
1.5

stripTrailingZeros

public BigDecimal stripTrailingZeros()
返回数值上等于此小数，但从该表示形式移除所有尾部零的 BigDecimal。例如，从 BigDecimal 值 600.0 中移除尾部零，该值具有的 [BigInteger, scale] 组件等于 [6000, 1]，使用 [BigInteger, scale] 组件生成的 6E2 等于 [6, -2]

返回：
数值上等于移除所有尾部零的 BigDecimal。
从以下版本开始：
1.5

compareTo

public int compareTo(BigDecimal val)
将此 BigDecimal 与指定的 BigDecimal 比较。根据此方法，值相等但具有不同标度的两个 BigDecimal 对象（如，2.0 和 2.00）被认为是相等的。相对六个 boolean 比较运算符 (<, ==, >, >=, !=, <=) 中每一个运算符的各个方法，优先提供此方法。建议使用以下语句执行上述比较：(x.compareTo(y) <op> 0)，其中 <op> 是六个比较运算符之一。

指定者：
接口 Comparable<BigDecimal> 中的 compareTo
参数：
val - 将此 BigDecimal 与之比较的 BigDecimal。
返回：
当此 BigDecimal 在数字上小于、等于或大于 val 时，返回 -1、0 或 1。

equals

public boolean equals(Object x)
比较此 BigDecimal 与指定的 Object 的相等性。与 compareTo 不同，仅当两个 BigDecimal 对象的值和标度都相等时，此方法才认为它们相等（因此通过此方法进行比较时，2.0 不等于 2.00）。

覆盖：
类 Object 中的 equals
参数：
x - 将与此 BigDecimal 进行比较的 Object。
返回：
当且仅当指定的 Object 为 BigDecimal，并且其值和标度都等于此 BigDecimal 的值和标度时，返回 true。
另请参见：
compareTo(java.math.BigDecimal), hashCode()

min

public BigDecimal min(BigDecimal val)
返回此 BigDecimal 和 val 的最小值。

参数：
val - 要计算最小值的值。
返回：
其值为 BigDecimal 和 val 中较小值的 BigDecimal。根据 compareTo 方法的定义，如果它们相等，则返回 this。
另请参见：
compareTo(java.math.BigDecimal)

max

public BigDecimal max(BigDecimal val)
返回此 BigDecimal 和 val 的最大值。

参数：
val - 要计算最大值的值。
返回：
其值为此 BigDecimal 和 val 中较大值的 BigDecimal。根据 compareTo 方法的定义，如果它们相等，则返回 this。
另请参见：
compareTo(java.math.BigDecimal)

hashCode

public int hashCode()
返回此 BigDecimal 的哈希码。注意，数值上相等但标度不同的两个 BigDecimal 对象（如，2.0 和 2.00）通常没有 相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 BigDecimal 的哈希码。
另请参见：
equals(Object)

toString

public String toString()
返回此 BigDecimal 的字符串表示形式，如果需要指数，则使用科学记数法。

根据以下步骤可创建 BigDecimal 的标准的规范化字符串形式：首先，使用不带前导零的字符 '0' 至 '9'（如果其值为零，则使用单个 '0' 字符）将 BigDecimal 的非标度值的绝对值转换为以十为基数的字符串。

其次，计算调整的指数；这是无效的标度，加上转换的非标度值中的字符数减 1。即：-scale+(ulength-1)，其中 ulength 是十进制数字中非标度值的绝对值的长度（其精度）。

如果该标度大于或等于零，并且调整的指数大于或等于 -6，则在不使用指数记数法的情况下将该数转换为字符形式。在这种情况下，如果标度为零，则不添加小数点，如果标度为正数，则插入小数点，且标度指定了小数点右边的字符个数。必要时，将字符 '0' 添加到转换的非标度值的左边。如果插入后小数点前面没有字符，则以传统字符 '0' 为前缀。

否则（即：如果标度为负数，或者调整的指数小于 -6），使用指数记数法将该数转换为字符形式。在这种情况下，如果转换后的 BigInteger 多于一位数，则小数点插入在第一个数字之后。然后，将字符形式的指数作为转换的非标度值（也许具有插入的小数点）的后缀；这包含字母 'E' 和直接跟在其后的转换为字符形式的调整指数。后者的基数为十，使用的字符是 '0' 到 '9'，没有前导零，并且，如果调整的指数为负数，则总是以符号字符 '-' ('\u002D') 为前缀，否则以 '+' ('\u002B') 为前缀。

最后，如果非标度值小于零，则整个字符串以减号 '-' ('\u002D') 为前缀。如果非标度值为零或正数，则不使用符号字符作为前缀。

示例：

对于左边的每个表示形式 [unscaled value, scale]，得到的字符串显示在右边。

 [123,0]      "123"
 [-123,0]     "-123"
 [123,-1]     "1.23E+3"
 [123,-3]     "1.23E+5"
 [123,1]      "12.3"
 [123,5]      "0.00123"
 [123,10]     "1.23E-8"
 [-123,12]    "-1.23E-10"
注：
  1. 可区分的 BigDecimal 值和此转换的结果之间存在一对一的映射关系。即：每个可区分的 BigDecimal 值（非标度值和标度）都有唯一的字符串表示形式，作为使用 toString 的结果。如果使用 BigDecimal(String) 构造方法将该字符串表示形式转换为 BigDecimal，则将恢复初始值。
  2. 给定的数产生的字符串总是相同的；它不受语言环境的影响。这意味着它可以用作交换十进制数据的规范化字符串表示形式，或用作 Hashtable 的关键字等等。NumberFormat 类及其子类可以处理区分语言环境的数的格式化和分析。
  3. toEngineeringString() 方法可用于在工程计数法中表示带有指数的数。setScale 方法可用于对 BigDecimal 进行舍入，使其小数点后的位数为已知位数。
  4. 使用 Character.forDigit 提供的数字到字符的映射关系。

覆盖：
类 Object 中的 toString
返回：
此 BigDecimal 的字符串表示形式。
另请参见：
Character.forDigit(int, int), BigDecimal(java.lang.String)

toEngineeringString

public String toEngineeringString()
返回此 BigDecimal 的字符串表示形式，需要指数时，则使用工程计数法。

返回如 toString() 方法中所描述的表示 BigDecimal 的字符串，不包括使用指数记数法的情况，将十的幂调整为三的倍数（工程记数法），这样，非零值的整数部分的范围是 1 到 999。如果对零值使用指数记数法，则使用小数点和小数的一（或二）个零数字，以便保留零值的标度。注意，与 toString() 的输出不同，如果使用 string constructor 将输出字符串转换为 BigDecimal，则此方法的输出不 保证恢复此 BigDecimal 的相同 [integer, scale] 对。此方法满足以下较弱约束，即产生的结果在数值上始终等于将字符串构造方法应用到方法的输出得到的结果。

返回：
此 BigDecimal 的字符串表示形式，如果需要指数，则使用工程记数法。
从以下版本开始：
1.5

toPlainString

public String toPlainString()
返回不带指数字段的此 BigDecimal 的字符串表示形式。对于具有正标度的值，小数点右边的数字个数用于指示标度。对于具有零或负标度的值，生成得到的字符串，好像将该值转换为在数值上等于具有零标度的值一样，并且好像零标度值的所有尾部零都出现在该结果中。 如果非标度值小于零，则整个字符串以减号 '-' ('\u002D') 为前缀。如果非标度值为零或正数，则没有任何符号字符作为前缀。 注意，如果将此方法的结果传递到 string constructor，则只需要恢复此 BigDecimal 的数值；新的 BigDecimal 的表示形式可以有不同的标度。尤其是，如果此 BigDecimal 具有负标度，则在由字符串构造方法进行处理时，此方法产生的字符串将具有零标度。 （此方法的作用类似于 1.4 和更早版本中的 toString 方法。）

返回：
不带指数字段的此 BigDecimal 的字符串表示形式。
从以下版本开始：
1.5
另请参见：
toString(), toEngineeringString()

toBigInteger

public BigInteger toBigInteger()
将此 BigDecimal 转换为 BigInteger。此转换类似于 Java Language Specification 中定义的从 double 到 long 的基本收缩转换：将丢弃此 BigDecimal 的小数部分。注意，此转换会丢失关于 BigDecimal 值的精度信息。

要在转换不准确时（即当丢弃非零小数部分时）抛出异常，请使用 toBigIntegerExact() 方法。

返回：
转换为 BigInteger 的此 BigDecimal。

toBigIntegerExact

public BigInteger toBigIntegerExact()
将此 BigDecimal 转换为 BigInteger，以检查丢失的信息。如果此 BigDecimal 具有非零小数部分，则抛出一个异常。

返回：
转换为 BigInteger 的此 BigDecimal。
抛出：
ArithmeticException - 如果 this 具有非零小数部分。
从以下版本开始：
1.5

longValue

public long longValue()
将此 BigDecimal 转换为 long。此转换类似于 Java Language Specification 中定义的从 double 到 short 的基本收缩转换：将丢弃此 BigDecimal 的小数部分，并且如果生成的 "BigInteger" 太大而不适合用 long 表示，则仅返回 64 位低位字节。注意，此转换会丢失关于此 BigDecimal 值的总大小和精度的信息，并返回带有相反符号的结果。

指定者：
类 Number 中的 longValue
返回：
转换为 long 的此 BigDecimal。

longValueExact

public long longValueExact()
将此 BigDecimal 转换为 long，以检查丢失的信息。如果此 BigDecimal 具有非零小数部分，或者超出 long 结果的可能范围，则抛出 ArithmeticException。

返回：
转换为 long 的此 BigDecimal。
抛出：
ArithmeticException - 如果 this 具有非零小数部分，或者不适合用 long 表示。
从以下版本开始：
1.5

intValue

public int intValue()
将此 BigDecimal 转换为 int。此转换类似于 Java Language Specification 中定义的从 double 到 short 的基本收缩转换：将丢弃此 BigDecimal 的所有小数部分，并且如果生成的 "BigInteger" 太大而不适合用 int 表示，则仅返回 32 位低位字节。注意，此转换会丢失关于此 BigDecimal 值的总大小和精度的信息，并返回带有相反符号的结果。

指定者：
类 Number 中的 intValue
返回：
转换为 int 的此 BigDecimal。

intValueExact

public int intValueExact()
将此 BigDecimal 转换为 int，以检查丢失的信息。如果此 BigDecimal 具有非零小数部分，或者超出 int 结果的可能范围，则抛出 ArithmeticException。

返回：
转换为 int 的此 BigDecimal。
抛出：
ArithmeticException - 如果 this 具有非零小数部分，或者不适合用 int 表示。
从以下版本开始：
1.5

shortValueExact

public short shortValueExact()
将此 BigDecimal 转换为 short，以检查丢失的信息。如果此 BigDecimal 具有非零小数部分，或者超出 short 结果的可能范围，则抛出 ArithmeticException。

返回：
转换为 short 的此 BigDecimal。
抛出：
ArithmeticException - 如果 this 具有非零小数部分，或者不适合用 short 表示。
从以下版本开始：
1.5

byteValueExact

public byte byteValueExact()
将此 BigDecimal 转换为 byte，以检查丢失的信息。如果此 BigDecimal 具有非零小数部分，或者超出 byte 结果的可能范围，则抛出 ArithmeticException。

返回：
转换为 byte 的此 BigDecimal。
抛出：
ArithmeticException - 如果 this 具有非零小数部分，或者不适合用 byte 表示。
从以下版本开始：
1.5

floatValue

public float floatValue()
将此 BigDecimal 转换为 float。此转换类似于 Java Language Specification 中定义的从 double 到 float 的基本收缩转换：如此 BigDecimal 的值太大而不能表示为 float，则将其适当地转换为 Float.NEGATIVE_INFINITY 或 Float.POSITIVE_INFINITY。注意，即使在返回值为有限值的情况下，此转换也可能丢失关于 BigDecimal 值精度的信息。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 的此 BigDecimal。

doubleValue

public double doubleValue()
将此 BigDecimal 转换为 double。此转换类似于 Java Language Specification 中定义的从 double 到 float 的 基本收缩转换：如果此 BigDecimal 的数量太大而不能表示为 double，则将其适当地转换为 Double.NEGATIVE_INFINITY 或 Double.POSITIVE_INFINITY。注意，即使在返回值为有限值的情况下，此转换也可能丢失关于 BigDecimal 值精度的信息。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 的此 BigDecimal。

ulp

public BigDecimal ulp()
返回此 BigDecimal 的 ulp（最后一位的单位）的大小。非零 BigDecimal 值的 ulp 是此值与下一个具有相同位数的较大 BigDecimal 值之间的正距离。零值的 ulp 在数值上等于具有 this 标度的 1。使用与 this 相同的标度存储该结果，这样，零和非零值的结果等于 [1, this.scale()]。

返回：
this 的 ulp 的大小
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BigInteger (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.math
类 BigInteger

java.lang.Object
    继承者  java.lang.Number
        继承者  java.math.BigInteger
所有已实现的接口：
Serializable, Comparable<BigInteger>
public class BigInteger
extends Number
implements Comparable<BigInteger>

不可变的任意精度的整数。所有操作中，都以二进制补码形式表示 BigInteger（如 Java 的基本整数类型）。BigInteger 提供所有 Java 的基本整数操作符的对应物，并提供 java.lang.Math 的所有相关方法。另外，BigInteger 还提供以下运算：模算术、GCD 计算、质数测试、素数生成、位操作以及一些其他操作。

算术运算的语义完全模仿 Java 整数算术运算符的语义，如 The Java Language Specification 中所定义的。例如，以零作为除数的除法抛出 ArithmeticException，而负数除以正数的除法则产生一个负（或零）的余数。Spec 中关于溢出的细节都被忽略了，因为 BigIntegers 所设置的实际大小能适应操作结果的需要。

位移操作的语义扩展了 Java 的位移操作符的语义以允许产生负位移距离。带有负位移距离的右移操作会导致左移操作，反之亦然。忽略无符号的右位移运算符（>>>），因为该操作与由此类提供的“无穷大的词大小”抽象结合使用时毫无意义。

逐位逻辑运算的语义完全模仿 Java 的逐位整数运算符的语义。在执行操作之前，二进制运算符（and、or、xor）对两个操作数中的较短操作数隐式执行符号扩展。

比较操作执行有符号的整数比较，类似于 Java 的关系运算符和相等性运算符执行的比较。

提供的模算术操作用来计算余数、求幂和乘法可逆元。这些方法始终返回非负结果，范围在 0 和 (modulus - 1)（包括）之间。

位操作对其操作数的二进制补码表示形式的单个位进行操作。如有必要，操作数会通过扩展符号来包含指定的位。单一位操作不能产生与正在被操作的 BigInteger 符号不同的 BigInteger，因为它们仅仅影响单个位，并且此类提供的“无穷大词大小”抽象可保证在每个 BigInteger 前存在无穷多的“虚拟符号位”数。

为了简洁明了，在整个 BigInteger 方法的描述中都使用了伪代码。伪代码表达式 (i + j) 是“其值为 BigInteger i 加 BigInteger j 的 BigInteger”的简写。伪代码表达式 (i == j) 是“当且仅当 BigInteger i 表示与 BigInteger j 相同的值时，才为 true”的简写。可以类似地解释其他伪代码表达式。

当为任何输入参数传递 null 对象引用时，此类中的所有方法和构造方法都将抛出 NullPointerException。

从以下版本开始：
JDK1.1
另请参见：
BigDecimal, 序列化表格

字段摘要
static BigInteger | ONE BigInteger 的常量 1。
static BigInteger | TEN BigInteger 的常量 10。
static BigInteger | ZERO BigInteger 的常量 0。
构造方法摘要
BigInteger(byte[] val)
将包含 BigInteger 的二进制补码表示形式的 byte 数组转换为 BigInteger。
BigInteger(int signum, byte[] magnitude)
将 BigInteger 的符号-数量表示形式转换为 BigInteger。
BigInteger(int bitLength, int certainty, Random rnd)
构造一个随机生成的正 BigInteger，它可能是一个具有指定 bitLength 的素数。
BigInteger(int numBits, Random rnd)
构造一个随机生成的 BigInteger，它是在 0 到 (2numBits - 1)（包括）范围内均匀分布的值。
BigInteger(String val)
将 BigInteger 的十进制字符串表示形式转换为 BigInteger。
BigInteger(String val, int radix)
将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger。
方法摘要
BigInteger | abs() 返回其值是此 BigInteger 的绝对值的 BigInteger。
BigInteger | add(BigInteger val) 返回其值为 (this + val) 的 BigInteger。
BigInteger | and(BigInteger val) 返回其值为 (this & val) 的 BigInteger。
BigInteger | andNot(BigInteger val) 返回其值为 (this & ~val) 的 BigInteger。
int | bitCount() 返回此 BigInteger 的二进制补码表示形式中与符号不同的位的数量。
int | bitLength() 返回此 BigInteger 的最小的二进制补码表示形式的位数，不包括 符号位。
BigInteger | clearBit(int n) 返回其值与清除了指定位的此 BigInteger 等效的 BigInteger。
int | compareTo(BigInteger val) 将此 BigInteger 与指定的 BigInteger 进行比较。
BigInteger | divide(BigInteger val) 返回其值为 (this / val) 的 BigInteger。
BigInteger[] | divideAndRemainder(BigInteger val) 返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。
double | doubleValue() 将此 BigInteger 转换为 double。
boolean | equals(Object x) 比较此 BigInteger 与指定的 Object 的相等性。
BigInteger | flipBit(int n) 返回其值与对此 BigInteger 进行指定位翻转后的值等效的 BigInteger。
float | floatValue() 将此 BigInteger 转换为 float。
BigInteger | gcd(BigInteger val) 返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。
int | getLowestSetBit() 返回此 BigInteger 最右端（最低位）1 比特的索引（即从此字节的右端开始到本字节中最右端 1 比特之间的 0 比特的位数）。
int | hashCode() 返回此 BigInteger 的哈希码。
int | intValue() 将此 BigInteger 转换为 int。
boolean | isProbablePrime(int certainty) 如果此 BigInteger 可能为素数，则返回 true，如果它一定为合数，则返回 false。
long | longValue() 将此 BigInteger 转换为 long。
BigInteger | max(BigInteger val) 返回此 BigInteger 和 val 的最大值。
BigInteger | min(BigInteger val) 返回此 BigInteger 和 val 的最小值。
BigInteger | mod(BigInteger m) 返回其值为 (this mod m) 的 BigInteger。
BigInteger | modInverse(BigInteger m) 返回其值为 (this-1 mod m) 的 BigInteger。
BigInteger | modPow(BigInteger exponent, BigInteger m) 返回其值为 (thisexponent mod m) 的 BigInteger。
BigInteger | multiply(BigInteger val) 返回其值为 (this * val) 的 BigInteger。
BigInteger | negate() 返回其值是 (-this) 的 BigInteger。
BigInteger | nextProbablePrime() 返回大于此 BigInteger 的可能为素数的第一个整数。
BigInteger | not() 返回其值为 (~this) 的 BigInteger。
BigInteger | or(BigInteger val) 返回其值为 (this | val) 的 BigInteger。
BigInteger | pow(int exponent) 返回其值为 (thisexponent) 的 BigInteger。
static BigInteger | probablePrime(int bitLength, Random rnd) 返回有可能是素数的、具有指定长度的正 BigInteger。
BigInteger | remainder(BigInteger val) 返回其值为 (this % val) 的 BigInteger。
BigInteger | setBit(int n) 返回其值与设置了指定位的此 BigInteger 等效的 BigInteger。
BigInteger | shiftLeft(int n) 返回其值为 (this << n) 的 BigInteger。
BigInteger | shiftRight(int n) 返回其值为 (this >> n) 的 BigInteger。
int | signum() 返回此 BigInteger 的正负号函数。
BigInteger | subtract(BigInteger val) 返回其值为 (this - val) 的 BigInteger。
boolean | testBit(int n) 当且仅当设置了指定的位时，返回 true。
byte[] | toByteArray() 返回一个 byte 数组，该数组包含此 BigInteger 的二进制补码表示形式。
String | toString() 返回此 BigInteger 的十进制字符串表示形式。
String | toString(int radix) 返回此 BigInteger 的给定基数的字符串表示形式。
static BigInteger | valueOf(long val) 返回其值等于指定 long 的值的 BigInteger。
BigInteger | xor(BigInteger val) 返回其值为 (this ^ val) 的 BigInteger。
从类 java.lang.Number 继承的方法
byteValue, shortValue
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ZERO

public static final BigInteger ZERO
BigInteger 的常量 0。

从以下版本开始：
1.2

ONE

public static final BigInteger ONE
BigInteger 的常量 1。

从以下版本开始：
1.2

TEN

public static final BigInteger TEN
BigInteger 的常量 10。

从以下版本开始：
1.5
构造方法详细信息

BigInteger

public BigInteger(byte[] val)
将包含 BigInteger 的二进制补码表示形式的 byte 数组转换为 BigInteger。输入数组假定为 big-endian 字节顺序：最高有效字节在第零个元素中。

参数：
val - BigInteger 的 big-endian 二进制补码表示形式。
抛出：
NumberFormatException - val 为零字节长。

BigInteger

public BigInteger(int signum,
                  byte[] magnitude)
将 BigInteger 的符号-数量表示形式转换为 BigInteger。该符号表示为一个正负号整数值：-1 表示负，0 表示零，1 表示正。该大小是一个 big-endian 字节顺序的 byte 数组：最高有效字节在第零个元素中。允许零长度数量数组，这会导致 BigInteger 的值为 0，无论其正负号是 -1、0 还是 1。

参数：
signum - 该数的正负号（-1 表示负，0 表示零，1 表示正）。
magnitude - 该数的大小的 big-endian 二进制表示形式。
抛出：
NumberFormatException - signum 不是三个合法值之一（-1、0 和 1），或者 signum 是 0 并且 magnitude 包含一个或多个非零字节。

BigInteger

public BigInteger(String val,
                  int radix)
将指定基数的 BigInteger 的字符串表示形式转换为 BigInteger。该字符串表示形式包括一个可选的减号，后跟一个或多个指定基数的数字。字符到数字的映射由 Character.digit 提供。该字符串不能包含任何其他字符（例如，空格）。

参数：
val - BigInteger 的字符串表示形式。
radix - 要在解释 val 时使用的基数。
抛出：
NumberFormatException - val 不是指定基数的 BigInteger 的有效表示形式，或者 radix 超出从 Character.MIN_RADIX 到 Character.MAX_RADIX（包括）的范围。
另请参见：
Character.digit(char, int)

BigInteger

public BigInteger(String val)
将 BigInteger 的十进制字符串表示形式转换为 BigInteger。该字符串表示形式包括一个可选的减号，后跟一个或多个十进制数字序列。字符到数字的映射由 Character.digit 提供。该字符串不能包含任何其他字符（例如，空格）。

参数：
val - BigInteger 的十进制字符串表示形式。
抛出：
NumberFormatException - val 不是 BigInteger 的有效表示形式。
另请参见：
Character.digit(char, int)

BigInteger

public BigInteger(int numBits,
                  Random rnd)
构造一个随机生成的 BigInteger，它是在 0 到 (2numBits - 1)（包括）范围内均匀分布的值。该分布的均匀性假定 rnd 中提供了一个随机位的公平源 (fair source)。注意，此构造方法始终构造一个非负 BigInteger。

参数：
numBits - 新 BigInteger 的最大 bitLength。
rnd - 计算新 BigInteger 时使用的随机源。
抛出：
IllegalArgumentException - 如果 numBits 为负。
另请参见：
bitLength()

BigInteger

public BigInteger(int bitLength,
                  int certainty,
                  Random rnd)
构造一个随机生成的正 BigInteger，它可能是一个具有指定 bitLength 的素数。

相对于此构造方法，建议优先使用 probablePrime 方法，必须指定一个确定数的情况除外。

参数：
bitLength - 返回的 BigInteger 的 bitLength。
certainty - 调用方允许的不确定性的度量。新的 BigInteger 表示素数的概率超出 (1 - 1/2certainty)。此构造方法的执行时间与此参数的值是成比例的。
rnd - 随机比特源，用这些随机比特选择用来进行质数测试的候选数。
抛出：
ArithmeticException - bitLength < 2。
另请参见：
bitLength()
方法详细信息

probablePrime

public static BigInteger probablePrime(int bitLength,
                                       Random rnd)
返回有可能是素数的、具有指定长度的正 BigInteger。此方法返回的 BigInteger 是合数的概率不超出 2-100。

参数：
bitLength - 返回的 BigInteger 的 bitLength。
rnd - 随机比特源，用这些随机比特选择用来进行质数测试的候选数。
返回：
可能是素数的 bitLength 个位的 BigInteger
抛出：
ArithmeticException - bitLength < 2。
从以下版本开始：
1.4
另请参见：
bitLength()

nextProbablePrime

public BigInteger nextProbablePrime()
返回大于此 BigInteger 的可能为素数的第一个整数。此方法返回的数是合数的概率不超出 2-100。此方法在执行以下搜索时将始终不会跳过素数：如果它返回 p，则不存在 this < q < p 的素数 q。

返回：
返回大于此 BigInteger 的可能为素数的第一个整数。
抛出：
ArithmeticException - this < 0。
从以下版本开始：
1.5

valueOf

public static BigInteger valueOf(long val)
返回其值等于指定 long 的值的 BigInteger。提供的此“静态工厂方法”优先于 (long) 构造方法，因为前者允许重用经常使用的 BigInteger。

参数：
val - 要返回的 BigInteger 的值。
返回：
具有指定值的 BigInteger。

add

public BigInteger add(BigInteger val)
返回其值为 (this + val) 的 BigInteger。

参数：
val - 将添加到此 BigInteger 中的值。
返回：
this + val

subtract

public BigInteger subtract(BigInteger val)
返回其值为 (this - val) 的 BigInteger。

参数：
val - 从此 BigInteger 中减去的值。
返回：
this - val

multiply

public BigInteger multiply(BigInteger val)
返回其值为 (this * val) 的 BigInteger。

参数：
val - 要乘以此 BigInteger 的值。
返回：
this * val

divide

public BigInteger divide(BigInteger val)
返回其值为 (this / val) 的 BigInteger。

参数：
val - 此 BigInteger 要除以的值。
返回：
this / val
抛出：
ArithmeticException - val==0

divideAndRemainder

public BigInteger[] divideAndRemainder(BigInteger val)
返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。

参数：
val - 此 BigInteger 要除以的值和计算所得的余数。
返回：
两个 BigInteger 的数组：商 (this / val) 是初始元素，余数 (this % val) 是最终元素。
抛出：
ArithmeticException - val==0

remainder

public BigInteger remainder(BigInteger val)
返回其值为 (this % val) 的 BigInteger。

参数：
val - 此 BigInteger 要除以的值和计算所得的余数。
返回：
this % val
抛出：
ArithmeticException - val==0

pow

public BigInteger pow(int exponent)
返回其值为 (thisexponent) 的 BigInteger。注意，exponent 是一个整数而不是 BigInteger。

参数：
exponent - 此 BigInteger 的指数。
返回：
thisexponent
抛出：
ArithmeticException - exponent 为负。（这会导致该运算产生一个非整数值。）

gcd

public BigInteger gcd(BigInteger val)
返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。如果 this==0 && val==0，则返回 0 。

参数：
val - 要一起计算最大公约数的值。
返回：
GCD(abs(this), abs(val))

abs

public BigInteger abs()
返回其值是此 BigInteger 的绝对值的 BigInteger。

返回：
abs(this)

negate

public BigInteger negate()
返回其值是 (-this) 的 BigInteger。

返回：
-this

signum

public int signum()
返回此 BigInteger 的正负号函数。

返回：
当此 BigInteger 的值为负、零或正时，返回 -1、0 或 1。

mod

public BigInteger mod(BigInteger m)
返回其值为 (this mod m) 的 BigInteger。此方法不同于 remainder，因为它始终返回一个 非负 BigInteger。

参数：
m - 模数。
返回：
this mod m
抛出：
ArithmeticException - m <= 0
另请参见：
remainder(java.math.BigInteger)

modPow

public BigInteger modPow(BigInteger exponent,
                         BigInteger m)
返回其值为 (thisexponent mod m) 的 BigInteger。（与 pow 不同，此方法允许使用负指数。）

参数：
exponent - 该指数。
m - 模数。
返回：
thisexponent mod m
抛出：
ArithmeticException - m <= 0
另请参见：
modInverse(java.math.BigInteger)

modInverse

public BigInteger modInverse(BigInteger m)
返回其值为 (this-1 mod m) 的 BigInteger。

参数：
m - 模数。
返回：
this-1 mod m.
抛出：
ArithmeticException - m <= 0，或者此 BigInteger 没有乘法可逆元 mod m（即此 BigInteger 不是 m 的相对素数）。

shiftLeft

public BigInteger shiftLeft(int n)
返回其值为 (this << n) 的 BigInteger。位移距离 n 可以为负，在此情况下，此方法执行右移操作。（计算 floor(this * 2n)。）

参数：
n - 以位为单位的位移距离。
返回：
this << n
另请参见：
shiftRight(int)

shiftRight

public BigInteger shiftRight(int n)
返回其值为 (this >> n) 的 BigInteger。执行符号扩展。位移距离 n 可以为负，在此情况下，此方法执行左移操作。（计算 floor(this / 2n)。）

参数：
n - 以位为单位的位移距离。
返回：
this >> n
另请参见：
shiftLeft(int)

and

public BigInteger and(BigInteger val)
返回其值为 (this & val) 的 BigInteger。（当且仅当 this 和 val 同时为负时，此方法返回一个负 BigInteger。）

参数：
val - 要与此 BigInteger 执行 AND（与）运算的值。
返回：
this & val

or

public BigInteger or(BigInteger val)
返回其值为 (this | val) 的 BigInteger。（当且仅当 this 和 val 之一为负时，此方法返回一个负 BigInteger。）

参数：
val - 要与此 BigInteger 执行或运算的值。
返回：
this | val

xor

public BigInteger xor(BigInteger val)
返回其值为 (this ^ val) 的 BigInteger。（当且仅当 this 和 val 中只有一个为负时，此方法返回一个负 BigInteger。）

参数：
val - 要与此 BigInteger 执行异或运算的值。
返回：
this ^ val

not

public BigInteger not()
返回其值为 (~this) 的 BigInteger。（当且仅当此 BigInteger 为非负时，此方法返回一个负值。）

返回：
~this

andNot

public BigInteger andNot(BigInteger val)
返回其值为 (this & ~val) 的 BigInteger。此方法等效于 and(val.not())，提供此方法是为了更方便地进行屏蔽操作。（当且仅当 this 为负且 val 为正时，此方法返回一个负 BigInteger。）

参数：
val - 要进行求补且与此 BigInteger 执行与运算的值。
返回：
this & ~val

testBit

public boolean testBit(int n)
当且仅当设置了指定的位时，返回 true。（计算 ((this & (1<<n)) != 0)。）

参数：
n - 要测试的位的索引。
返回：
当且仅当设置了指定的位时，返回 true。
抛出：
ArithmeticException - n 为负。

setBit

public BigInteger setBit(int n)
返回其值与设置了指定位的此 BigInteger 等效的 BigInteger。（计算 (this | (1<<n))。）

参数：
n - 要设置的位的索引。
返回：
this | (1<<n)
抛出：
ArithmeticException - n 为负。

clearBit

public BigInteger clearBit(int n)
返回其值与清除了指定位的此 BigInteger 等效的 BigInteger。（计算 (this & ~(1<<n))。）

参数：
n - 要清除的位的索引。
返回：
this & ~(1<<n)
抛出：
ArithmeticException - n 为负。

flipBit

public BigInteger flipBit(int n)
返回其值与对此 BigInteger 进行指定位翻转后的值等效的 BigInteger。（计算 (this ^ (1<<n))。）

参数：
n - 要翻转的位的索引。
返回：
this ^ (1<<n)
抛出：
ArithmeticException - n 为负。

getLowestSetBit

public int getLowestSetBit()
返回此 BigInteger 最右端（最低位）1 比特的索引（即从此字节的右端开始到本字节中最右端 1 比特之间的 0 比特的位数）。如果此 BigInteger 不包含一位，则返回 -1。（计算 (this==0? -1 : log2(this & -this))。)

返回：
此 BigInteger 中最右端的一比特位的索引。

bitLength

public int bitLength()
返回此 BigInteger 的最小的二进制补码表示形式的位数，不包括 符号位。对于正 BigInteger，这等于常规二进制表示形式中的位数。（计算 (ceil(log2(this < 0 ? -this : this+1)))。)

返回：
返回此 BigInteger 的最小的二进制补码表示形式中的位数，不包括 符号位。

bitCount

public int bitCount()
返回此 BigInteger 的二进制补码表示形式中与符号不同的位的数量。此方法在实现 BigInteger 上的位向量样式设置时非常有用。

返回：
返回此 BigInteger 的二进制补码表示形式中与符号位不同的位的数量。

isProbablePrime

public boolean isProbablePrime(int certainty)
如果此 BigInteger 可能为素数，则返回 true，如果它一定为合数，则返回 false。如果 certainty <= 0，则返回 true。

参数：
certainty - 调用方允许的不确定性的度量。如果该调用返回 true，则此 BigInteger 是素数的概率超出 (1 - 1/2certainty)。此方法的执行时间与此参数的值是成比例的。
返回：
如果此 BigInteger 可能为素数，则返回 true，如果它一定为合数，则返回 false。

compareTo

public int compareTo(BigInteger val)
将此 BigInteger 与指定的 BigInteger 进行比较。对于针对六个布尔比较运算符 (<, ==, >, >=, !=, <=) 中的每一个运算符的各个方法，优先提供此方法。执行这些比较的建议语句是：(x.compareTo(y) <op> 0)，其中 <op> 是六个比较运算符之一。

指定者：
接口 Comparable<BigInteger> 中的 compareTo
参数：
val - 将此 BigInteger 与之比较的 BigInteger。
返回：
当此 BigInteger 在数值上小于、等于或大于 val 时，返回 -1，0，或 1。

equals

public boolean equals(Object x)
比较此 BigInteger 与指定的 Object 的相等性。

覆盖：
类 Object 中的 equals
参数：
x - 将此 BigInteger 与之比较的 Object。
返回：
当且仅当指定的 Object 是一个其值在数字上等于此 BigInteger 的 BigInteger 时，返回 true。
另请参见：
Object.hashCode(), Hashtable

min

public BigInteger min(BigInteger val)
返回此 BigInteger 和 val 的最小值。

参数：
val - 要计算最小值的值。
返回：
其值为此 BigInteger 和 val 中的较小值的 BigInteger。如果它们相等，可能返回其中之一。

max

public BigInteger max(BigInteger val)
返回此 BigInteger 和 val 的最大值。

参数：
val - 要计算最大值的值。
返回：
其值为此 BigInteger 和 val 中较大值的 BigInteger。如果它们相等，可能返回其中之一。

hashCode

public int hashCode()
返回此 BigInteger 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 BigInteger 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString(int radix)
返回此 BigInteger 的给定基数的字符串表示形式。如果该基数超出从 Character.MIN_RADIX 到 Character.MAX_RADIX（包括）这一范围，则其默认值为 10（Integer.toString 就是这种情况）。使用由 Character.forDigit 提供的从数字到字符的映射，并在需要时在前面加一个负号。（此表示形式与 (String, int) 构造方法兼容。）

参数：
radix - 字符串表示形式的基数。
返回：
此 BigInteger 给定基数的字符串表示形式。
另请参见：
Integer.toString(int, int),
Character.forDigit(int, int),
BigInteger(java.lang.String, int)

toString

public String toString()
返回此 BigInteger 的十进制字符串表示形式。使用由 Character.forDigit 提供的从数字到字符的映射，并在需要时在前面加一个负号。（此表示形式与 (String) 构造方法兼容，并允许使用 Java 的 + 运算符将字符串连接。）

覆盖：
类 Object 中的 toString
返回：
此 BigInteger 的十进制字符串表示形式。
另请参见：
Character.forDigit(int, int), BigInteger(java.lang.String)

toByteArray

public byte[] toByteArray()
返回一个 byte 数组，该数组包含此 BigInteger 的二进制补码表示形式。该 byte 数组将为 big-endian 字节顺序：最高有效字节在第零个元素中。此数组将包含表示此 BigInteger 所需的最小数量的字节，至少包括一个符号位，即 (ceil((this.bitLength() + 1)/8))。（此表示形式与 (byte[]) 构造方法兼容。）

返回：
一个包含此 BigInteger 的二进制补码表示形式的 byte 数组。
另请参见：
BigInteger(byte[])

intValue

public int intValue()
将此 BigInteger 转换为 int。此转换类似于 Java Language Specification 中定义的从 long 到 int 的基本收缩转换：如果此 BigInteger 太长而不适合用 int 表示，则仅返回 32 位的低位字节。注意，此转换会丢失关于该 BigInteger 值的总大小的信息，并返回带有相反符号的结果。

指定者：
类 Number 中的 intValue
返回：
转换为 int 的此 BigInteger。

longValue

public long longValue()
将此 BigInteger 转换为 long。此转换类似于 Java Language Specification 中定义的从 long 到 int 的基本收缩转换：如果此 BigInteger 太长而不适合用 long 表示，则仅返回 64 位的低位字节。注意，此转换会丢失关于该 BigInteger 值的总大小的信息，并返回带有相反符号的结果。

指定者：
类 Number 中的 longValue
返回：
转换为 long 的此 BigInteger。

floatValue

public float floatValue()
将此 BigInteger 转换为 float。此转换类似于 Java Language Specification 中定义的从 double 到 float 的基本收缩转换：如果此 BigInteger 的数量太大，不能表示为 float，则将其适当地转换为 Float.NEGATIVE_INFINITY 或 Float.POSITIVE_INFINITY。注意，即使在返回值是有限的情况下，此转换也可以丢失关于 BigInteger 值的精度的信息。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 的此 BigInteger。

doubleValue

public double doubleValue()
将此 BigInteger 转换为 double。此转换类似于 Java Language Specification 中定义的从 double 到 float 的基本收缩转换：如果此 BigInteger 的数量太大，不能表示为 double，则将其适当地转换为 Double.NEGATIVE_INFINITY 或 Double.POSITIVE_INFINITY。注意，即使在返回值是有限的情况下，此转换也可以丢失关于 BigInteger 值的精度的信息。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 的此 BigInteger。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MathContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.math
类 MathContext

java.lang.Object
    继承者  java.math.MathContext
所有已实现的接口：
Serializable
public final class MathContext
extends Object
implements Serializable

该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。

基本独立设置为：

  1. precision：某个操作使用的数字个数；结果舍入到此精度
  2. roundingMode：一个 RoundingMode 对象，该对象指定舍入使用的算法。

从以下版本开始：
1.5
另请参见：
BigDecimal, RoundingMode, 序列化表格

字段摘要
static MathContext | DECIMAL128 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal128 格式（即 34 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | DECIMAL32 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal32 格式（即 7 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | DECIMAL64 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal64 格式（即 16 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | UNLIMITED 其设置具有无限精度算法所需值的 MathContext 对象。
构造方法摘要
MathContext(int setPrecision)
构造一个新的 MathContext，它具有指定的精度和 HALF_UP 舍入模式。
MathContext(int setPrecision, RoundingMode setRoundingMode)
构造一个新的 MathContext，它具有指定的精度和舍入模式。
MathContext(String val)
根据字符串构造一个新的 MathContext。
方法摘要
boolean | equals(Object x) 将此 MathContext 与指定的 Object 进行相等性比较。
int | getPrecision() 返回 precision 设置。
RoundingMode | getRoundingMode() 返回 roundingMode 设置。
int | hashCode() 返回此 MathContext 的哈希码。
String | toString() 返回此 MathContext 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

UNLIMITED

public static final MathContext UNLIMITED
其设置具有无限精度算法所需值的 MathContext 对象。该设置的值为：precision=0 roundingMode=HALF_UP

DECIMAL32

public static final MathContext DECIMAL32
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal32 格式（即 7 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。

DECIMAL64

public static final MathContext DECIMAL64
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal64 格式（即 16 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。

DECIMAL128

public static final MathContext DECIMAL128
一个 MathContext 对象，其精度设置与 IEEE 754R Decimal128 格式（即 34 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。

构造方法详细信息

MathContext

public MathContext(int setPrecision)
构造一个新的 MathContext，它具有指定的精度和 HALF_UP 舍入模式。

参数：
setPrecision - 非负 int 精度设置。
抛出：
IllegalArgumentException - 如果 setPrecision 参数小于零。

MathContext

public MathContext(int setPrecision,
                   RoundingMode setRoundingMode)
构造一个新的 MathContext，它具有指定的精度和舍入模式。

参数：
setPrecision - 非负 int 精度设置。
setRoundingMode - 要使用的舍入模式。
抛出：
IllegalArgumentException - 如果 setPrecision 参数小于零。
NullPointerException - 如果舍入模式参数为 null

MathContext

public MathContext(String val)
根据字符串构造一个新的 MathContext。 该字符串的格式必须与 toString() 方法生成的字符串的格式相同。

如果字符串的精度部分超出范围 (< 0)，或者字符串的格式不是 toString() 方法创建的格式，则抛出 IllegalArgumentException。

参数：
val - 要解析的字符串
抛出：
IllegalArgumentException - 如果精度部分超出范围或者格式不正确
NullPointerException - 如果参数为 null
方法详细信息

getPrecision

public int getPrecision()
返回 precision 设置。此值始终为非负数。

返回：
一个 int，它是 precision 设置的值

getRoundingMode

public RoundingMode getRoundingMode()
返回 roundingMode 设置。它将是 RoundingMode.CEILING、RoundingMode.DOWN、RoundingMode.FLOOR、RoundingMode.HALF_DOWN、RoundingMode.HALF_EVEN、RoundingMode.HALF_UP、RoundingMode.UNNECESSARY 或 RoundingMode.UP 之一。

返回：
一个 RoundingMode 对象，它是 roundingMode 设置的值

equals

public boolean equals(Object x)
将此 MathContext 与指定的 Object 进行相等性比较。

覆盖：
类 Object 中的 equals
参数：
x - 将与 MathContext 相比较的 Object。
返回：
当且仅当指定的 Object 是一个 MathContext 对象，并且它与此对象具有完全相同的设置，才返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 MathContext 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 MathContext 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 MathContext 的字符串表示形式。返回的 String 表示 MathContext 对象的设置，表示为两个由空格分开的单词（由单个空格字符 '\u0020' 分隔，且没有前导空格和后缀空格），如下所示：
  1. 字符串 "precision=" 后面紧跟以数字字符串形式表示的精度设置的值，该字符串像是由 Integer.toString 方法生成的。
  2. 字符串 "roundingMode=" 后面紧跟以单词表示的 roundingMode 设置的值。此单词与 RoundingMode 枚举中对应的公共常量的名称相同。

例如：

 precision=9 roundingMode=HALF_UP
如果向此类添加了多个属性，则以后可以将其他单词添加到 toString 的结果中。

覆盖：
类 Object 中的 toString
返回：
表示上下文设置的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoundingMode (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 | 详细信息： 枚举常量 | 字段 | 方法

java.math
枚举 RoundingMode

java.lang.Object
    继承者  java.lang.Enum<RoundingMode>
        继承者  java.math.RoundingMode
所有已实现的接口：
Serializable, Comparable<RoundingMode>
public enum RoundingMode
extends Enum<RoundingMode>

为可能丢弃精度的数值操作指定一种舍入行为。每种舍入模式都指示如何计算返回舍入结果位数的最低有效位。如果返回的位数比表示精确数值结果所需的位数少，则舍弃的位数称为舍弃部分，而不管这些位数对数值的作用如何。换句话说，假设是一个数值，舍弃部分的绝对值可能大于 1。

每种舍入模式的描述包括一个表，列出如何在相关的舍入模式下将不同的两位十进制数舍入为一位十进制数。表中的结果栏可以通过以下方式获得：使用指定的值创建一个 BigDecimal 数字，形成一个具有适当设置（precision 设置为 1，roundingMode 设置为相关的舍入模式）的 MathContext 对象，并使用适当的 MathContext 对此数字调用 round。下面是一个汇总表，该表显示了在所有舍入模式下这些舍入操作的结果。

不同舍入模式下的舍入操作汇总
根据给定的舍入模式将输入数字舍入为一位数的结果
输入数字 | UP | DOWN | CEILING | FLOOR | HALF_UP | HALF_DOWN | HALF_EVEN | UNNECESSARY
5.5 | 6 | 5 | 6 | 5 | 6 | 5 | 6 | 抛出 ArithmeticException
2.5 | 3 | 2 | 3 | 2 | 3 | 2 | 2 | 抛出 ArithmeticException
1.6 | 2 | 1 | 2 | 1 | 2 | 2 | 2 | 抛出 ArithmeticException
1.1 | 2 | 1 | 2 | 1 | 1 | 1 | 1 | 抛出 ArithmeticException
1.0 | 1 | 1 | 1 | 1 | 1 | 1 | 1 | 1
-1.0 | -1 | -1 | -1 | -1 | -1 | -1 | -1 | -1
-1.1 | -2 | -1 | -1 | -2 | -1 | -1 | -1 | 抛出 ArithmeticException
-1.6 | -2 | -1 | -1 | -2 | -2 | -2 | -2 | 抛出 ArithmeticException
-2.5 | -3 | -2 | -2 | -3 | -3 | -2 | -2 | 抛出 ArithmeticException
-5.5 | -6 | -5 | -5 | -6 | -6 | -5 | -6 | 抛出 ArithmeticException

此 enum 拟用于取代 BigDecimal（BigDecimal.ROUND_UP、BigDecimal.ROUND_DOWN 等）中舍入模式常量的基于整数的枚举。

从以下版本开始：
1.5
另请参见：
BigDecimal, MathContext

枚举常量摘要
CEILING
向正无限大方向舍入的舍入模式。
DOWN
向零方向舍入的舍入模式。
FLOOR
向负无限大方向舍入的舍入模式。
HALF_DOWN
向最接近数字方向舍入的舍入模式，如果与两个相邻数字的距离相等，则向下舍入。
HALF_EVEN
向最接近数字方向舍入的舍入模式，如果与两个相邻数字的距离相等，则向相邻的偶数舍入。
HALF_UP
向最接近数字方向舍入的舍入模式，如果与两个相邻数字的距离相等，则向上舍入。
UNNECESSARY
用于断言请求的操作具有精确结果的舍入模式，因此不需要舍入。
UP
远离零方向舍入的舍入模式。
方法摘要
static RoundingMode | valueOf(int rm) 返回与 BigDecimal 中遗留整数舍入模式常量对应的 RoundingMode 对象。
static RoundingMode | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RoundingMode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

UP

public static final RoundingMode UP
远离零方向舍入的舍入模式。始终对非零舍弃部分前面的数字加 1。注意，此舍入模式始终不会减少计算值的绝对值。

示例：

输入数字 使用 UP 舍入模式
将输入数字舍入为一位数
5.5 | 6
2.5 | 3
1.6 | 2
1.1 | 2
1.0 | 1
-1.0 | -1
-1.1 | -2
-1.6 | -2
-2.5 | -3
-5.5 | -6

DOWN

public static final RoundingMode DOWN
向零方向舍入的舍入模式。从不对舍弃部分前面的数字加 1（即截尾）。注意，此舍入模式始终不会增加计算值的绝对值。

示例：

输入数字 使用 DOWN 舍入模式
将输入数字舍入为一位数
5.5 | 5
2.5 | 2
1.6 | 1
1.1 | 1
1.0 | 1
-1.0 | -1
-1.1 | -1
-1.6 | -1
-2.5 | -2
-5.5 | -5

CEILING

public static final RoundingMode CEILING
向正无限大方向舍入的舍入模式。如果结果为正，则舍入行为类似于 RoundingMode.UP；如果结果为负，则舍入行为类似于 RoundingMode.DOWN。注意，此舍入模式始终不会减少计算值。

示例：

输入数字 使用 CEILING 舍入模式
将输入数字舍入为一位数
5.5 | 6
2.5 | 3
1.6 | 2
1.1 | 2
1.0 | 1
-1.0 | -1
-1.1 | -1
-1.6 | -1
-2.5 | -2
-5.5 | -5

FLOOR

public static final RoundingMode FLOOR
向负无限大方向舍入的舍入模式。如果结果为正，则舍入行为类似于 RoundingMode.DOWN；如果结果为负，则舍入行为类似于 RoundingMode.UP。注意，此舍入模式始终不会增加计算值。

示例：

输入数字 使用 FLOOR 舍入模式
将输入数字舍入为一位数
5.5 | 5
2.5 | 2
1.6 | 1
1.1 | 1
1.0 | 1
-1.0 | -1
-1.1 | -2
-1.6 | -2
-2.5 | -3
-5.5 | -6

HALF_UP

public static final RoundingMode HALF_UP
向最接近数字方向舍入的舍入模式，如果与两个相邻数字的距离相等，则向上舍入。如果被舍弃部分 >= 0.5，则舍入行为同 RoundingMode.UP；否则舍入行为同 RoundingMode.DOWN。注意，此舍入模式就是通常学校里讲的四舍五入。

示例：

输入数字 使用 HALF_UP 舍入模式
将输入数字舍入为一位数
5.5 | 6
2.5 | 3
1.6 | 2
1.1 | 1
1.0 | 1
-1.0 | -1
-1.1 | -1
-1.6 | -2
-2.5 | -3
-5.5 | -6

HALF_DOWN

public static final RoundingMode HALF_DOWN
向最接近数字方向舍入的舍入模式，如果与两个相邻数字的距离相等，则向下舍入。如果被舍弃部分 > 0.5，则舍入行为同 RoundingMode.UP；否则舍入行为同 RoundingMode.DOWN。

示例：

输入数字 使用 HALF_DOWN 舍入模式
将输入数字舍入为一位数
5.5 | 5
2.5 | 2
1.6 | 2
1.1 | 1
1.0 | 1
-1.0 | -1
-1.1 | -1
-1.6 | -2
-2.5 | -2
-5.5 | -5

HALF_EVEN

public static final RoundingMode HALF_EVEN
向最接近数字方向舍入的舍入模式，如果与两个相邻数字的距离相等，则向相邻的偶数舍入。如果舍弃部分左边的数字为奇数，则舍入行为同 RoundingMode.HALF_UP；如果为偶数，则舍入行为同 RoundingMode.HALF_DOWN。注意，在重复进行一系列计算时，此舍入模式可以在统计上将累加错误减到最小。此舍入模式也称为“银行家舍入法”，主要在美国使用。此舍入模式类似于 Java 中对 float 和 double 算法使用的舍入策略。

示例：

输入数字 使用 HALF_EVEN 舍入模式
将输入数字舍入为一位数
5.5 | 6
2.5 | 2
1.6 | 2
1.1 | 1
1.0 | 1
-1.0 | -1
-1.1 | -1
-1.6 | -2
-2.5 | -2
-5.5 | -6

UNNECESSARY

public static final RoundingMode UNNECESSARY
用于断言请求的操作具有精确结果的舍入模式，因此不需要舍入。如果对生成精确结果的操作指定此舍入模式，则抛出 ArithmeticException。

示例：

输入数字 使用 UNNECESSARY 舍入模式
将输入数字舍入为一位数
5.5 | 抛出 ArithmeticException
2.5 | 抛出 ArithmeticException
1.6 | 抛出 ArithmeticException
1.1 | 抛出 ArithmeticException
1.0 | 1
-1.0 | -1
-1.1 | 抛出 ArithmeticException
-1.6 | 抛出 ArithmeticException
-2.5 | 抛出 ArithmeticException
-5.5 | 抛出 ArithmeticException

方法详细信息

values

public static final RoundingMode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(RoundingMode c : RoundingMode.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static RoundingMode valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

valueOf

public static RoundingMode valueOf(int rm)
返回与 BigDecimal 中遗留整数舍入模式常量对应的 RoundingMode 对象。

参数：
rm - 要转换的遗留整数舍入模式
返回：
与给定整数对应的 RoundingMode。
抛出：
IllegalArgumentException - 整数超出范围
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 | 详细信息： 枚举常量 | 字段 | 方法


java.math (Java 2 Platform SE 6)

 java.math
类
BigDecimal
BigInteger
MathContext
枚举
RoundingMode


java.math (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.math

提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。

请参见：
描述

类摘要
BigDecimal | 不可变的、任意精度的有符号十进制数。
BigInteger | 不可变的任意精度的整数。
MathContext | 该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。

枚举摘要
RoundingMode 为可能丢弃精度的数值操作指定一种舍入行为。

软件包 java.math 的描述

提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。BigInteger 除提供任意精度之外，它类似于 Java 的基本整数类型，因此在 BigInteger 上执行的操作不产生溢出，也不会丢失精度。除标准算法操作外，BigInteger 还提供模 (modular) 算法、GCD 计算、基本 (primality) 测试、素数生成、位处理以及一些其他操作。 BigDecimal 提供适用于货币计算和类似计算的任意精度的有符号十进制数字。BigDecimal 允许用户对舍入行为进行完全控制，并允许用户选择所有八个舍入模式。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.math 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.math 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.math.MathContext (implements java.io.Serializable)
    • java.lang.Number (implements java.io.Serializable)
      • java.math.BigDecimal (implements java.lang.Comparable<T>)
      • java.math.BigInteger (implements java.lang.Comparable<T>)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.math.RoundingMode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.math 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.math
的使用

使用 java.math 的软件包
java.awt.image | 提供创建和修改图像的各种类。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.datatype | XML/Java 类型映射关系。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

java.awt.image 使用的 java.math 中的类
BigInteger
不可变的任意精度的整数。

java.math 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。
BigInteger
不可变的任意精度的整数。
MathContext
该对象是封装上下文设置的不可变对象，它描述数字运算符的某些规则，例如由 BigDecimal 类实现的规则。
RoundingMode
为可能丢弃精度的数值操作指定一种舍入行为。

java.security.cert 使用的 java.math 中的类
BigInteger
不可变的任意精度的整数。

java.security.interfaces 使用的 java.math 中的类
BigInteger
不可变的任意精度的整数。

java.security.spec 使用的 java.math 中的类
BigInteger
不可变的任意精度的整数。

java.sql 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。

java.text 使用的 java.math 中的类
RoundingMode
为可能丢弃精度的数值操作指定一种舍入行为。

java.util 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。
BigInteger
不可变的任意精度的整数。

javax.crypto.interfaces 使用的 java.math 中的类
BigInteger
不可变的任意精度的整数。

javax.crypto.spec 使用的 java.math 中的类
BigInteger
不可变的任意精度的整数。

javax.management.openmbean 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。
BigInteger
不可变的任意精度的整数。

javax.sql 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。

javax.sql.rowset 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。

javax.sql.rowset.serial 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。

javax.xml.bind 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。
BigInteger
不可变的任意精度的整数。

javax.xml.crypto.dsig.keyinfo 使用的 java.math 中的类
BigInteger
不可变的任意精度的整数。

javax.xml.datatype 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。
BigInteger
不可变的任意精度的整数。

org.omg.CORBA 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。

org.omg.CORBA.portable 使用的 java.math 中的类
BigDecimal
不可变的、任意精度的有符号十进制数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.math.BigDecimal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.BigDecimal
的使用

使用 BigDecimal 的软件包
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.omg.CORBA.portable | 提供可移植性层，即可以使一个供应商生成的代码运行在另一个供应商 ORB 上的 ORB API 集合。

java.math 中 BigDecimal 的使用

声明为 BigDecimal 的 java.math 中的字段
static BigDecimal | BigDecimal.ONE 值为 1，标度为 0。
static BigDecimal | BigDecimal.TEN 值为 10，标度为 0。
static BigDecimal | BigDecimal.ZERO 值为 0，标度为 0。

返回 BigDecimal 的 java.math 中的方法
 BigDecimal BigDecimal.abs()
返回 BigDecimal，其值为此 BigDecimal 的绝对值，其标度为 this.scale()。
 BigDecimal BigDecimal.abs(MathContext mc)
返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.add(BigDecimal augend)
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。
 BigDecimal BigDecimal.add(BigDecimal augend, MathContext mc)
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.divide(BigDecimal divisor)
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, MathContext mc)
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.divide(BigDecimal divisor, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor, MathContext mc)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor)
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor, MathContext mc)
返回 BigDecimal，其值为 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.max(BigDecimal val)
返回此 BigDecimal 和 val 的最大值。
 BigDecimal BigDecimal.min(BigDecimal val)
返回此 BigDecimal 和 val 的最小值。
 BigDecimal BigDecimal.movePointLeft(int n)
返回一个 BigDecimal，它等效于将该值的小数点向左移动 n 位。
 BigDecimal BigDecimal.movePointRight(int n)
返回一个 BigDecimal，它等效于将该值的小数点向右移动 n 位。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand)
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand, MathContext mc)
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.negate()
返回 BigDecimal，其值为 (-this)，其标度为 this.scale()。
 BigDecimal BigDecimal.negate(MathContext mc)
返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.plus()
返回 BigDecimal，其值为 (+this)，其标度为 this.scale()。
 BigDecimal BigDecimal.plus(MathContext mc)
返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.pow(int n)
返回其值为 (thisn) 的 BigDecimal，准确计算该幂，使其具有无限精度。
 BigDecimal BigDecimal.pow(int n, MathContext mc)
返回其值为 (thisn) 的 BigDecimal。
 BigDecimal BigDecimal.remainder(BigDecimal divisor)
返回其值为 (this % divisor) 的 BigDecimal。
 BigDecimal BigDecimal.remainder(BigDecimal divisor, MathContext mc)
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.round(MathContext mc)
返回根据 MathContext 设置进行舍入后的 BigDecimal。
 BigDecimal BigDecimal.scaleByPowerOfTen(int n)
返回其数值等于 (this * 10n) 的 BigDecimal。
 BigDecimal BigDecimal.setScale(int newScale)
返回一个 BigDecimal，其标度为指定值，其值在数值上等于此 BigDecimal 的值。
 BigDecimal BigDecimal.setScale(int newScale, int roundingMode)
返回一个 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
 BigDecimal BigDecimal.setScale(int newScale, RoundingMode roundingMode)
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。
 BigDecimal BigDecimal.stripTrailingZeros()
返回数值上等于此小数，但从该表示形式移除所有尾部零的 BigDecimal。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend)
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend, MathContext mc)
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.ulp()
返回此 BigDecimal 的 ulp（最后一位的单位）的大小。
static BigDecimal BigDecimal.valueOf(double val)
使用 Double.toString(double) 方法提供的 double 规范的字符串表示形式将 double 转换为 BigDecimal。
static BigDecimal BigDecimal.valueOf(long val)
将 long 值转换为具有零标度的 BigDecimal。
static BigDecimal BigDecimal.valueOf(long unscaledVal, int scale)
将 long 非标度值和 int 标度转换为 BigDecimal。

参数类型为 BigDecimal 的 java.math 中的方法
 BigDecimal BigDecimal.add(BigDecimal augend)
返回一个 BigDecimal，其值为 (this + augend)，其标度为 max(this.scale(), augend.scale())。
 BigDecimal BigDecimal.add(BigDecimal augend, MathContext mc)
返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
 int BigDecimal.compareTo(BigDecimal val)
将此 BigDecimal 与指定的 BigDecimal 比较。
 BigDecimal BigDecimal.divide(BigDecimal divisor)
返回一个 BigDecimal，其值为 (this / divisor)，其首选标度为 (this.scale() - divisor.scale())；如果无法表示准确的商值（因为它有无穷的十进制扩展），则抛出 ArithmeticException。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, int roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, MathContext mc)
返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.divide(BigDecimal divisor, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟对两个操作数计算所得到的 remainder。
 BigDecimal[] BigDecimal.divideAndRemainder(BigDecimal divisor, MathContext mc)
返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor)
返回 BigDecimal，其值为向下舍入所得商值 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.divideToIntegralValue(BigDecimal divisor, MathContext mc)
返回 BigDecimal，其值为 (this / divisor) 的整数部分。
 BigDecimal BigDecimal.max(BigDecimal val)
返回此 BigDecimal 和 val 的最大值。
 BigDecimal BigDecimal.min(BigDecimal val)
返回此 BigDecimal 和 val 的最小值。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand)
返回一个 BigDecimal，其值为 (this × multiplicand)，其标度为 (this.scale() + multiplicand.scale())。
 BigDecimal BigDecimal.multiply(BigDecimal multiplicand, MathContext mc)
返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.remainder(BigDecimal divisor)
返回其值为 (this % divisor) 的 BigDecimal。
 BigDecimal BigDecimal.remainder(BigDecimal divisor, MathContext mc)
返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend)
返回一个 BigDecimal，其值为 (this - subtrahend)，其标度为 max(this.scale(), subtrahend.scale())。
 BigDecimal BigDecimal.subtract(BigDecimal subtrahend, MathContext mc)
返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。

java.sql 中 BigDecimal 的使用

返回 BigDecimal 的 java.sql 中的方法
BigDecimal | CallableStatement.getBigDecimal(int parameterIndex) 以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
BigDecimal | ResultSet.getBigDecimal(int columnIndex) 以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
BigDecimal | CallableStatement.getBigDecimal(int parameterIndex, int scale) 已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
BigDecimal | ResultSet.getBigDecimal(int columnIndex, int scale) 已过时。
BigDecimal | CallableStatement.getBigDecimal(String parameterName) 以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
BigDecimal | ResultSet.getBigDecimal(String columnLabel) 以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
BigDecimal | ResultSet.getBigDecimal(String columnLabel, int scale) 已过时。
BigDecimal | SQLInput.readBigDecimal() 读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。

参数类型为 BigDecimal 的 java.sql 中的方法
void | PreparedStatement.setBigDecimal(int parameterIndex, BigDecimal x) 将指定参数设置为给定 java.math.BigDecimal 值。
void | CallableStatement.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定 java.math.BigDecimal 值。
void | ResultSet.updateBigDecimal(int columnIndex, BigDecimal x) 用 java.math.BigDecimal 值更新指定列。
void | ResultSet.updateBigDecimal(String columnLabel, BigDecimal x) 用 java.sql.BigDecimal 值更新指定列。
void | SQLOutput.writeBigDecimal(BigDecimal x) 将下一个属性作为 java.math.BigDecimal 对象写入流中。

java.util 中 BigDecimal 的使用

返回 BigDecimal 的 java.util 中的方法
 BigDecimal Scanner.nextBigDecimal()
将输入信息的下一个标记扫描为一个 BigDecimal。

javax.management.openmbean 中 BigDecimal 的使用

类型参数类型为 BigDecimal 的 javax.management.openmbean 中的字段
static SimpleType<BigDecimal> SimpleType.BIGDECIMAL
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。

javax.sql 中 BigDecimal 的使用

参数类型为 BigDecimal 的 javax.sql 中的方法
void | RowSet.setBigDecimal(int parameterIndex, BigDecimal x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。
void | RowSet.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。

javax.sql.rowset 中 BigDecimal 的使用

参数类型为 BigDecimal 的 javax.sql.rowset 中的方法
void | BaseRowSet.setBigDecimal(int parameterIndex, BigDecimal x) 将指定参数设置为给定的 java.lang.BigDecimal 值。
void | BaseRowSet.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。

javax.sql.rowset.serial 中 BigDecimal 的使用

返回 BigDecimal 的 javax.sql.rowset.serial 中的方法
 BigDecimal SQLInputImpl.readBigDecimal()
以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 BigDecimal 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeBigDecimal(BigDecimal x)
将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。

javax.xml.bind 中 BigDecimal 的使用

返回 BigDecimal 的 javax.xml.bind 中的方法
static BigDecimal | DatatypeConverter.parseDecimal(String lexicalXSDDecimal) 将字符串参数转换为一个 BigDecimal 值。
BigDecimal | DatatypeConverterInterface.parseDecimal(String lexicalXSDDecimal) 将字符串参数转换为一个 BigDecimal 值。

参数类型为 BigDecimal 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printDecimal(BigDecimal val) 将 BigDecimal 值转换为一个字符串。
String | DatatypeConverterInterface.printDecimal(BigDecimal val) 将 BigDecimal 值转换为一个字符串。

javax.xml.datatype 中 BigDecimal 的使用

返回 BigDecimal 的 javax.xml.datatype 中的方法
abstract  BigDecimal XMLGregorianCalendar.getFractionalSecond()
返回小数秒。

参数类型为 BigDecimal 的 javax.xml.datatype 中的方法
abstract Duration | Duration.multiply(BigDecimal factor) 计算新的持续时间，其值是此持续时间值的 factor 倍。
abstract Duration | DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone) W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendarTime(int hours, int minutes, int seconds, BigDecimal fractionalSecond, int timezone) 创建 XML 模式内置数据类型 time 的 Java 实例。
abstract void | XMLGregorianCalendar.setFractionalSecond(BigDecimal fractional) 设置小数秒。
void | XMLGregorianCalendar.setTime(int hour, int minute, int second, BigDecimal fractional) 将时间设置为一个单元，包括可选无限精度小数秒。

org.omg.CORBA 中 BigDecimal 的使用

声明为 BigDecimal 的 org.omg.CORBA 中的字段
 BigDecimal FixedHolder.value
FixedHolder 保存的值。

返回 BigDecimal 的 org.omg.CORBA 中的方法
 BigDecimal Any.extract_fixed()
提取此 Any 对象 value 字段中的 java.math.BigDecimal 对象。

参数类型为 BigDecimal 的 org.omg.CORBA 中的方法
void | Any.insert_fixed(BigDecimal value) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。
void | Any.insert_fixed(BigDecimal value, TypeCode type) 抛出 org.omg.CORBA.NO_IMPLEMENT 异常。

参数类型为 BigDecimal 的 org.omg.CORBA 中的构造方法
FixedHolder(BigDecimal initial)
构造 FixedHolder，并使用给定值初始化。

org.omg.CORBA.portable 中 BigDecimal 的使用

返回 BigDecimal 的 org.omg.CORBA.portable 中的方法
 BigDecimal InputStream.read_fixed()
读取一个 BigDecimal 数。

参数类型为 BigDecimal 的 org.omg.CORBA.portable 中的方法
 void OutputStream.write_fixed(BigDecimal value)
写入一个 BigDecimal 数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.math.MathContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.MathContext
的使用

使用 MathContext 的软件包
java.math 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。

java.math 中 MathContext 的使用

声明为 MathContext 的 java.math 中的字段
static MathContext | MathContext.DECIMAL128 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal128 格式（即 34 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | MathContext.DECIMAL32 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal32 格式（即 7 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | MathContext.DECIMAL64 一个 MathContext 对象，其精度设置与 IEEE 754R Decimal64 格式（即 16 个数字）匹配，舍入模式为 HALF_EVEN，这是 IEEE 754R 的默认舍入模式。
static MathContext | MathContext.UNLIMITED 其设置具有无限精度算法所需值的 MathContext 对象。

参数类型为 MathContext 的 java.math 中的方法
BigDecimal | BigDecimal.abs(MathContext mc) 返回其值为此 BigDecimal 绝对值的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.add(BigDecimal augend, MathContext mc) 返回其值为 (this + augend) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.divide(BigDecimal divisor, MathContext mc) 返回其值为 (this / divisor) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal[] | BigDecimal.divideAndRemainder(BigDecimal divisor, MathContext mc) 返回由两个元素组成的 BigDecimal 数组，该数组包含 divideToIntegralValue 的结果，后跟根据上下文设置对两个操作数进行舍入计算所得到的 remainder 的结果。
BigDecimal | BigDecimal.divideToIntegralValue(BigDecimal divisor, MathContext mc) 返回 BigDecimal，其值为 (this / divisor) 的整数部分。
BigDecimal | BigDecimal.multiply(BigDecimal multiplicand, MathContext mc) 返回其值为 (this × multiplicand) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.negate(MathContext mc) 返回其值为 (-this) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.plus(MathContext mc) 返回其值为 (+this) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.pow(int n, MathContext mc) 返回其值为 (thisn) 的 BigDecimal。
BigDecimal | BigDecimal.remainder(BigDecimal divisor, MathContext mc) 返回其值为 (this % divisor) 的 BigDecimal（根据上下文设置进行舍入）。
BigDecimal | BigDecimal.round(MathContext mc) 返回根据 MathContext 设置进行舍入后的 BigDecimal。
BigDecimal | BigDecimal.subtract(BigDecimal subtrahend, MathContext mc) 返回其值为 (this - subtrahend) 的 BigDecimal（根据上下文设置进行舍入）。

参数类型为 MathContext 的 java.math 中的构造方法
BigDecimal(BigInteger unscaledVal, int scale, MathContext mc)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger val, MathContext mc)
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(char[] in, int offset, int len, MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列，同时允许指定子数组，并根据上下文设置进行舍入。
BigDecimal(char[] in, MathContext mc)
将 BigDecimal 的字符数组表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符序列（根据上下文设置进行舍入）。
BigDecimal(double val, MathContext mc)
将 double 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(int val, MathContext mc)
将 int 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(long val, MathContext mc)
将 long 转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(String val, MathContext mc)
将 BigDecimal 的字符串表示形式转换为 BigDecimal，接受与 BigDecimal.BigDecimal(String) 构造方法相同的字符串（按照上下文设置进行舍入）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.math.BigInteger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.BigInteger
的使用

使用 BigInteger 的软件包
java.awt.image | 提供创建和修改图像的各种类。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.security.cert | 为公钥证书提供类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.datatype | XML/Java 类型映射关系。

java.awt.image 中 BigInteger 的使用

返回 BigInteger 的 java.awt.image 中的方法
 BigInteger IndexColorModel.getValidPixels()
返回一个指示 colormap 中有效/无效像素的 BigInteger。

参数类型为 BigInteger 的 java.awt.image 中的构造方法
IndexColorModel(int bits, int size, int[] cmap, int start, int transferType, BigInteger validBits)
根据一个 int 数组构造一个 IndexColorModel，该数组中的每个 int 值都由默认 RGB 颜色模型格式的红色、绿色、蓝色和 alpha 分量构成。

java.math 中 BigInteger 的使用

声明为 BigInteger 的 java.math 中的字段
static BigInteger | BigInteger.ONE BigInteger 的常量 1。
static BigInteger | BigInteger.TEN BigInteger 的常量 10。
static BigInteger | BigInteger.ZERO BigInteger 的常量 0。

返回 BigInteger 的 java.math 中的方法
BigInteger | BigInteger.abs() 返回其值是此 BigInteger 的绝对值的 BigInteger。
BigInteger | BigInteger.add(BigInteger val) 返回其值为 (this + val) 的 BigInteger。
BigInteger | BigInteger.and(BigInteger val) 返回其值为 (this & val) 的 BigInteger。
BigInteger | BigInteger.andNot(BigInteger val) 返回其值为 (this & ~val) 的 BigInteger。
BigInteger | BigInteger.clearBit(int n) 返回其值与清除了指定位的此 BigInteger 等效的 BigInteger。
BigInteger | BigInteger.divide(BigInteger val) 返回其值为 (this / val) 的 BigInteger。
BigInteger[] | BigInteger.divideAndRemainder(BigInteger val) 返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。
BigInteger | BigInteger.flipBit(int n) 返回其值与对此 BigInteger 进行指定位翻转后的值等效的 BigInteger。
BigInteger | BigInteger.gcd(BigInteger val) 返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。
BigInteger | BigInteger.max(BigInteger val) 返回此 BigInteger 和 val 的最大值。
BigInteger | BigInteger.min(BigInteger val) 返回此 BigInteger 和 val 的最小值。
BigInteger | BigInteger.mod(BigInteger m) 返回其值为 (this mod m) 的 BigInteger。
BigInteger | BigInteger.modInverse(BigInteger m) 返回其值为 (this-1 mod m) 的 BigInteger。
BigInteger | BigInteger.modPow(BigInteger exponent, BigInteger m) 返回其值为 (thisexponent mod m) 的 BigInteger。
BigInteger | BigInteger.multiply(BigInteger val) 返回其值为 (this * val) 的 BigInteger。
BigInteger | BigInteger.negate() 返回其值是 (-this) 的 BigInteger。
BigInteger | BigInteger.nextProbablePrime() 返回大于此 BigInteger 的可能为素数的第一个整数。
BigInteger | BigInteger.not() 返回其值为 (~this) 的 BigInteger。
BigInteger | BigInteger.or(BigInteger val) 返回其值为 (this | val) 的 BigInteger。
BigInteger | BigInteger.pow(int exponent) 返回其值为 (thisexponent) 的 BigInteger。
static BigInteger | BigInteger.probablePrime(int bitLength, Random rnd) 返回有可能是素数的、具有指定长度的正 BigInteger。
BigInteger | BigInteger.remainder(BigInteger val) 返回其值为 (this % val) 的 BigInteger。
BigInteger | BigInteger.setBit(int n) 返回其值与设置了指定位的此 BigInteger 等效的 BigInteger。
BigInteger | BigInteger.shiftLeft(int n) 返回其值为 (this << n) 的 BigInteger。
BigInteger | BigInteger.shiftRight(int n) 返回其值为 (this >> n) 的 BigInteger。
BigInteger | BigInteger.subtract(BigInteger val) 返回其值为 (this - val) 的 BigInteger。
BigInteger | BigDecimal.toBigInteger() 将此 BigDecimal 转换为 BigInteger。
BigInteger | BigDecimal.toBigIntegerExact() 将此 BigDecimal 转换为 BigInteger，以检查丢失的信息。
BigInteger | BigDecimal.unscaledValue() 返回其值为此 BigDecimal 的非标度值 的 BigInteger。
static BigInteger | BigInteger.valueOf(long val) 返回其值等于指定 long 的值的 BigInteger。
BigInteger | BigInteger.xor(BigInteger val) 返回其值为 (this ^ val) 的 BigInteger。

参数类型为 BigInteger 的 java.math 中的方法
BigInteger | BigInteger.add(BigInteger val) 返回其值为 (this + val) 的 BigInteger。
BigInteger | BigInteger.and(BigInteger val) 返回其值为 (this & val) 的 BigInteger。
BigInteger | BigInteger.andNot(BigInteger val) 返回其值为 (this & ~val) 的 BigInteger。
int | BigInteger.compareTo(BigInteger val) 将此 BigInteger 与指定的 BigInteger 进行比较。
BigInteger | BigInteger.divide(BigInteger val) 返回其值为 (this / val) 的 BigInteger。
BigInteger[] | BigInteger.divideAndRemainder(BigInteger val) 返回包含 (this / val) 后跟 (this % val) 的两个 BigInteger 的数组。
BigInteger | BigInteger.gcd(BigInteger val) 返回一个 BigInteger，其值是 abs(this) 和 abs(val) 的最大公约数。
BigInteger | BigInteger.max(BigInteger val) 返回此 BigInteger 和 val 的最大值。
BigInteger | BigInteger.min(BigInteger val) 返回此 BigInteger 和 val 的最小值。
BigInteger | BigInteger.mod(BigInteger m) 返回其值为 (this mod m) 的 BigInteger。
BigInteger | BigInteger.modInverse(BigInteger m) 返回其值为 (this-1 mod m) 的 BigInteger。
BigInteger | BigInteger.modPow(BigInteger exponent, BigInteger m) 返回其值为 (thisexponent mod m) 的 BigInteger。
BigInteger | BigInteger.multiply(BigInteger val) 返回其值为 (this * val) 的 BigInteger。
BigInteger | BigInteger.or(BigInteger val) 返回其值为 (this | val) 的 BigInteger。
BigInteger | BigInteger.remainder(BigInteger val) 返回其值为 (this % val) 的 BigInteger。
BigInteger | BigInteger.subtract(BigInteger val) 返回其值为 (this - val) 的 BigInteger。
BigInteger | BigInteger.xor(BigInteger val) 返回其值为 (this ^ val) 的 BigInteger。

参数类型为 BigInteger 的 java.math 中的构造方法
BigDecimal(BigInteger val)
将 BigInteger 转换为 BigDecimal。
BigDecimal(BigInteger unscaledVal, int scale)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal。
BigDecimal(BigInteger unscaledVal, int scale, MathContext mc)
将 BigInteger 非标度值和 int 标度转换为 BigDecimal（根据上下文设置进行舍入）。
BigDecimal(BigInteger val, MathContext mc)
将 BigInteger 转换为 BigDecimal（根据上下文设置进行舍入）。

java.security.cert 中 BigInteger 的使用

返回 BigInteger 的 java.security.cert 中的方法
BigInteger | X509CRLSelector.getMaxCRL() 返回 maxCRLNumber 标准。
BigInteger | X509CRLSelector.getMinCRL() 返回 minCRLNumber 标准。
abstract BigInteger | X509CRLEntry.getSerialNumber() 获取此 X509CRLEntry 的序列号 userCertificate。
BigInteger | X509CertSelector.getSerialNumber() 返回 serialNumber 标准。
abstract BigInteger | X509Certificate.getSerialNumber() 获取证书的 serialNumber 值。

参数类型为 BigInteger 的 java.security.cert 中的方法
abstract X509CRLEntry | X509CRL.getRevokedCertificate(BigInteger serialNumber) 获取具有给定证书 serialNumber 的 CRL 项（如果有）。
void | X509CRLSelector.setMaxCRLNumber(BigInteger maxCRL) 设置 maxCRLNumber 标准。
void | X509CRLSelector.setMinCRLNumber(BigInteger minCRL) 设置 minCRLNumber 标准。
void | X509CertSelector.setSerialNumber(BigInteger serial) 设置 serialNumber 标准。

java.security.interfaces 中 BigInteger 的使用

返回 BigInteger 的 java.security.interfaces 中的方法
BigInteger | RSAMultiPrimePrivateCrtKey.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | RSAPrivateCrtKey.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | DSAParams.getG() 返回基数 g。
BigInteger | RSAKey.getModulus() 返回该系数。
BigInteger | DSAParams.getP() 返回素数 p。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAPrivateCrtKey.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAPrivateCrtKey.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeP() 返回 primeP。
BigInteger | RSAPrivateCrtKey.getPrimeP() 返回 primeP。
BigInteger | RSAMultiPrimePrivateCrtKey.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateCrtKey.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateKey.getPrivateExponent() 返回专用指数。
BigInteger | RSAMultiPrimePrivateCrtKey.getPublicExponent() 返回公用指数。
BigInteger | RSAPrivateCrtKey.getPublicExponent() 返回公用指数。
BigInteger | RSAPublicKey.getPublicExponent() 返回该公用指数。
BigInteger | DSAParams.getQ() 返回子素数 q。
BigInteger | ECPrivateKey.getS() 返回专用密钥值 S。
BigInteger | DSAPrivateKey.getX() 返回专用密钥值 x。
BigInteger | DSAPublicKey.getY() 返回公用密钥值 y。

java.security.spec 中 BigInteger 的使用

声明为 BigInteger 的 java.security.spec 中的字段
static BigInteger | RSAKeyGenParameterSpec.F0 公用指数值 F0 = 3。
static BigInteger | RSAKeyGenParameterSpec.F4 公用指数值 F4 = 65537。

返回 BigInteger 的 java.security.spec 中的方法
BigInteger | EllipticCurve.getA() 返回椭圆曲线的第一个系数 a。
BigInteger | ECPoint.getAffineX() 返回仿射 x 坐标 x。
BigInteger | ECPoint.getAffineY() 返回仿射 y 坐标 y。
BigInteger | EllipticCurve.getB() 返回椭圆曲线的第二个系数 b。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | RSAOtherPrimeInfo.getCrtCoefficient() 返回素数的 crtCoefficient。
BigInteger | RSAPrivateCrtKeySpec.getCrtCoefficient() 返回 crtCoefficient。
BigInteger | RSAOtherPrimeInfo.getExponent() 返回素数的指数。
BigInteger | DSAPrivateKeySpec.getG() 返回基数 g。
BigInteger | DSAParameterSpec.getG() 返回基数 g。
BigInteger | DSAPublicKeySpec.getG() 返回基数 g。
BigInteger | RSAPrivateKeySpec.getModulus() 返回系数。
BigInteger | RSAPublicKeySpec.getModulus() 返回该系数。
BigInteger | ECParameterSpec.getOrder() 返回生成器的顺序。
BigInteger | DSAPrivateKeySpec.getP() 返回素数 p。
BigInteger | ECFieldFp.getP() 返回此素数有限字段的素数 p。
BigInteger | DSAParameterSpec.getP() 返回素数 p。
BigInteger | DSAPublicKeySpec.getP() 返回素数 p。
BigInteger | RSAOtherPrimeInfo.getPrime() 返回素数。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAPrivateCrtKeySpec.getPrimeExponentP() 返回 primeExponentP。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAPrivateCrtKeySpec.getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeP() 返回 primeP。
BigInteger | RSAPrivateCrtKeySpec.getPrimeP() 返回 primeP。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateCrtKeySpec.getPrimeQ() 返回 primeQ。
BigInteger | RSAPrivateKeySpec.getPrivateExponent() 返回专用指数。
BigInteger | RSAKeyGenParameterSpec.getPublicExponent() 返回公用指数值。
BigInteger | RSAMultiPrimePrivateCrtKeySpec.getPublicExponent() 返回公用指数。
BigInteger | RSAPrivateCrtKeySpec.getPublicExponent() 返回公用指数。
BigInteger | RSAPublicKeySpec.getPublicExponent() 返回该公用指数。
BigInteger | DSAPrivateKeySpec.getQ() 返回子素数 q。
BigInteger | DSAParameterSpec.getQ() 返回子素数 q。
BigInteger | DSAPublicKeySpec.getQ() 返回子素数 q。
BigInteger | ECFieldF2m.getReductionPolynomial() 对于多项式方法，返回一个 BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数，对于常规方法，返回 null。
BigInteger | ECPrivateKeySpec.getS() 返回专用值 S。
BigInteger | DSAPrivateKeySpec.getX() 返回专用密钥 x。
BigInteger | DSAPublicKeySpec.getY() 返回公用密钥 y。

参数类型为 BigInteger 的 java.security.spec 中的构造方法
DSAParameterSpec(BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新的 DSAParameterSpec。
DSAPrivateKeySpec(BigInteger x, BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新 DSAPrivateKeySpec。
DSAPublicKeySpec(BigInteger y, BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新 DSAPublicKeySpec。
ECFieldF2m(int m, BigInteger rp)
使用多项式方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldFp(BigInteger p)
根据指定的素数 p 创建一个椭圆曲线素数的有限字段。
ECParameterSpec(EllipticCurve curve, ECPoint g, BigInteger n, int h)
创建基于指定值的椭圆曲线域参数。
ECPoint(BigInteger x, BigInteger y)
根据指定的仿射 x 坐标 x 和仿射 y 坐标 y 创建 ECPoint。
ECPrivateKeySpec(BigInteger s, ECParameterSpec params)
使用指定的参数值创建一个新的 ECPrivateKeySpec。
EllipticCurve(ECField field, BigInteger a, BigInteger b)
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。
EllipticCurve(ECField field, BigInteger a, BigInteger b, byte[] seed)
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。
RSAKeyGenParameterSpec(int keysize, BigInteger publicExponent)
构造一个具有给定密钥大小和公用指数值的新的 RSAParameterSpec 对象。
RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。
RSAOtherPrimeInfo(BigInteger prime, BigInteger primeExponent, BigInteger crtCoefficient)
给定如 PKCS#1 中所定义的素数、primeExponent 和 crtCoefficient，创建一个新的 RSAOtherPrimeInfo。
RSAPrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient)
给定在 PKCS#1 v2.1 中所定义的系数、publicExponent、privateExponent、 primeP、primeQ、primeExponentP、primeExponentQ 和 crtCoefficient，创建一个新的 RSAPrivateCrtKeySpec。
RSAPrivateKeySpec(BigInteger modulus, BigInteger privateExponent)
创建一个新的 RSAPrivateKeySpec。
RSAPublicKeySpec(BigInteger modulus, BigInteger publicExponent)
创建一个新的 RSAPublicKeySpec。

java.util 中 BigInteger 的使用

返回 BigInteger 的 java.util 中的方法
BigInteger | Scanner.nextBigInteger() 将输入信息的下一个标记扫描为一个 BigInteger。
BigInteger | Scanner.nextBigInteger(int radix) 将输入信息的下一个标记扫描为一个 BigInteger。

javax.crypto.interfaces 中 BigInteger 的使用

返回 BigInteger 的 javax.crypto.interfaces 中的方法
BigInteger | DHPrivateKey.getX() 返回私钥值 x。
BigInteger | DHPublicKey.getY() 返回公钥值 y。

javax.crypto.spec 中 BigInteger 的使用

返回 BigInteger 的 javax.crypto.spec 中的方法
BigInteger | DHParameterSpec.getG() 返回基生成器 g。
BigInteger | DHPrivateKeySpec.getG() 返回基生成器 g。
BigInteger | DHPublicKeySpec.getG() 返回基生成器 g。
BigInteger | DHParameterSpec.getP() 返回质数模数 p。
BigInteger | DHPrivateKeySpec.getP() 返回质数模数 p。
BigInteger | DHPublicKeySpec.getP() 返回质数模数 p。
BigInteger | DHPrivateKeySpec.getX() 返回私有值 x。
BigInteger | DHPublicKeySpec.getY() 返回公有值 y。

参数类型为 BigInteger 的 javax.crypto.spec 中的构造方法
DHParameterSpec(BigInteger p, BigInteger g)
使用质数模数 p 和基生成器 g 为 Diffie-Hellman 构造一个参数集。
DHParameterSpec(BigInteger p, BigInteger g, int l)
使用质数模数 p、基生成器 g 以及以位为单位的随机指数大小 l（私有值）为 Diffie-Hellman 构造一个参数集。
DHPrivateKeySpec(BigInteger x, BigInteger p, BigInteger g)
带有一个私有值 x、一个质数模数 p 以及一个基生成器 g 的构造方法。
DHPublicKeySpec(BigInteger y, BigInteger p, BigInteger g)
带有一个公有值 y、一个质数模数 p 以及一个基生成器 g 的构造方法。

javax.management.openmbean 中 BigInteger 的使用

类型参数类型为 BigInteger 的 javax.management.openmbean 中的字段
static SimpleType<BigInteger> SimpleType.BIGINTEGER
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。

javax.security.cert 中 BigInteger 的使用

返回 BigInteger 的 javax.security.cert 中的方法
abstract  BigInteger X509Certificate.getSerialNumber()
获取证书的 serialNumber 值。

javax.xml.bind 中 BigInteger 的使用

返回 BigInteger 的 javax.xml.bind 中的方法
static BigInteger | DatatypeConverter.parseInteger(String lexicalXSDInteger) 将字符串参数转换为一个 BigInteger 值。
BigInteger | DatatypeConverterInterface.parseInteger(String lexicalXSDInteger) 将字符串参数转换为一个 BigInteger 值。

参数类型为 BigInteger 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printInteger(BigInteger val) 将 BigInteger 值转换为一个字符串。
String | DatatypeConverterInterface.printInteger(BigInteger val) 将 BigInteger 值转换为一个字符串。

javax.xml.crypto.dsig.keyinfo 中 BigInteger 的使用

返回 BigInteger 的 javax.xml.crypto.dsig.keyinfo 中的方法
 BigInteger X509IssuerSerial.getSerialNumber()
返回此 X509IssuerSerial 的序列号。

参数类型为 BigInteger 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  X509IssuerSerial KeyInfoFactory.newX509IssuerSerial(String issuerName, BigInteger serialNumber)
根据指定的 X.500 发布方标识名和序列号创建 X509IssuerSerial。

javax.xml.datatype 中 BigInteger 的使用

返回 BigInteger 的 javax.xml.datatype 中的方法
abstract BigInteger | XMLGregorianCalendar.getEon() 返回 year XML 模式 1.0 日期时间数据类型字段的高顺序组件。
abstract BigInteger | XMLGregorianCalendar.getEonAndYear() 返回 year XML 模式 1.0 的日期时间数据类型字段。

参数类型为 BigInteger 的 javax.xml.datatype 中的方法
abstract Duration | DatatypeFactory.newDuration(boolean isPositive, BigInteger years, BigInteger months, BigInteger days, BigInteger hours, BigInteger minutes, BigDecimal seconds) 获取 Duration 的新实例，该 Duration 根据 isPositive、years、months、days、hours、minutes、seconds 的值确定。
Duration | DatatypeFactory.newDurationDayTime(boolean isPositive, BigInteger day, BigInteger hour, BigInteger minute, BigInteger second) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:dayTimeDuration 中的定义，使用指定 day、hour、minute 和 second 创建类型为 xdt:dayTimeDuration 的 Duration。
Duration | DatatypeFactory.newDurationYearMonth(boolean isPositive, BigInteger year, BigInteger month) 根据 XQuery 1.0 and XPath 2.0 Data Model, xdt:yearMonthDuration 中的定义，使用指定 year 和 month 创建类型为 xdt:yearMonthDuration 的 Duration。
abstract XMLGregorianCalendar | DatatypeFactory.newXMLGregorianCalendar(BigInteger year, int month, int day, int hour, int minute, int second, BigDecimal fractionalSecond, int timezone) W3C XML 模式 1.0 推荐考虑完整值空间的构造方法，该方法用于 xsd:dateTime 和相关的内置数据类型。
abstract void | XMLGregorianCalendar.setYear(BigInteger year) 设置 XSD dateTime year 字段的低和高顺序组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.math.RoundingMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.math.RoundingMode
的使用

使用 RoundingMode 的软件包
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.math 中 RoundingMode 的使用

返回 RoundingMode 的 java.math 中的方法
RoundingMode | MathContext.getRoundingMode() 返回 roundingMode 设置。
static RoundingMode | RoundingMode.valueOf(int rm) 返回与 BigDecimal 中遗留整数舍入模式常量对应的 RoundingMode 对象。
static RoundingMode | RoundingMode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RoundingMode[] | RoundingMode.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 RoundingMode 的 java.math 中的方法
 BigDecimal BigDecimal.divide(BigDecimal divisor, int scale, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为指定标度。
 BigDecimal BigDecimal.divide(BigDecimal divisor, RoundingMode roundingMode)
返回一个 BigDecimal，其值为 (this / divisor)，其标度为 this.scale()。
 BigDecimal BigDecimal.setScale(int newScale, RoundingMode roundingMode)
返回 BigDecimal，其标度为指定值，其非标度值通过此 BigDecimal 的非标度值乘以或除以十的适当次幂来确定，以维护其总值。

参数类型为 RoundingMode 的 java.math 中的构造方法
MathContext(int setPrecision, RoundingMode setRoundingMode)
构造一个新的 MathContext，它具有指定的精度和舍入模式。

java.text 中 RoundingMode 的使用

返回 RoundingMode 的 java.text 中的方法
RoundingMode | DecimalFormat.getRoundingMode() 获取在此 DecimalFormat 中使用的 RoundingMode。
RoundingMode | NumberFormat.getRoundingMode() 获取在此 NumberFormat 中使用的 RoundingMode。

参数类型为 RoundingMode 的 java.text 中的方法
void | DecimalFormat.setRoundingMode(RoundingMode roundingMode) 设置在此 DecimalFormat 中使用的 RoundingMode。
void | NumberFormat.setRoundingMode(RoundingMode roundingMode) 设置在此 NumberFormat 中使用的 RoundingMode。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Authenticator (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.net
类 Authenticator

java.lang.Object
    继承者  java.net.Authenticator

public abstract class Authenticator
extends Object

Authenticator 类表示懂得如何获得网络连接验证的对象。通常，它通过提示用户输入信息来完成此操作。

应用程序通过重写子类中的 getPasswordAuthentication() 使用此类。此方法通常使用各种 getXXX() 访问器方法获取关于请求验证的实体的信息。然后，它必须通过与用户交互或者某些其他非交互手段获取用户名和密码。之后凭据将以 PasswordAuthentication 返回值的形式返回。

接下来通过调用 setDefault(Authenticator) 向系统注册此具体子类的实例。需要进行验证时，系统将调用其中一个 requestPasswordAuthentication() 方法，这些方法将依次调用注册对象的 getPasswordAuthentication() 方法。

请求验证的所有方法都有一个失败的默认实现。

从以下版本开始：
1.2
另请参见：
setDefault(java.net.Authenticator), getPasswordAuthentication()

嵌套类摘要
static class Authenticator.RequestorType
请求验证的实体的类型。
构造方法摘要
Authenticator()
方法摘要
protected PasswordAuthentication | getPasswordAuthentication() 需要密码授权时调用。
protected String | getRequestingHost() 获取请求验证的站点或代理的 hostname；如果不可用，则为 null。
protected int | getRequestingPort() 获取所请求的连接的端口号。
protected String | getRequestingPrompt() 获取请求方给出的提示字符串。
protected String | getRequestingProtocol() 给出正在请求连接的协议。
protected String | getRequestingScheme() 获取请求方的方案（例如，HTTP 防火墙的 HTTP 方案）。
protected InetAddress | getRequestingSite() 获取请求授权的站点的 InetAddress；如果不可用，则为 null。
protected URL | getRequestingURL() 返回导致请求验证的 URL。
protected Authenticator.RequestorType | getRequestorType() 返回请求方是代理还是服务器。
static PasswordAuthentication | requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType) 要求已经向系统注册的 authenticator 提供密码。
static void | setDefault(Authenticator a) 设置在代理或 HTTP 服务器请求验证时连网密码使用的 authenticator。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Authenticator

public Authenticator()
方法详细信息

setDefault

public static void setDefault(Authenticator a)
设置在代理或 HTTP 服务器请求验证时连网密码使用的 authenticator。

首先，如果存在安全管理器，则在 NetPermission("setDefaultAuthenticator") 权限下调用 checkPermission 方法。这可能导致 java.lang.SecurityException。

参数：
a - 要设置的 authenticator。如果 a 为 null，则移除以前设置的所有 authenticator。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许设置默认 authenticator。
另请参见：
SecurityManager.checkPermission(java.security.Permission), NetPermission

requestPasswordAuthentication

public static PasswordAuthentication requestPasswordAuthentication(InetAddress addr,
                                                                   int port,
                                                                   String protocol,
                                                                   String prompt,
                                                                   String scheme)
要求已经向系统注册的 authenticator 提供密码。

首先，如果存在安全管理器，则在 NetPermission("requestPasswordAuthentication") 权限下调用 checkPermission 方法。这可能导致 java.lang.SecurityException。

参数：
addr - 请求授权的站点的 InetAddress；如果未知则为 null。
port - 所请求的连接的端口
protocol - 正在请求连接的协议 (getRequestingProtocol())
prompt - 用户的提示字符串
scheme - 验证方案
返回：
用户名/密码；或者无法得到，则返回 null。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许密码验证请求。
另请参见：
SecurityManager.checkPermission(java.security.Permission), NetPermission

requestPasswordAuthentication

public static PasswordAuthentication requestPasswordAuthentication(String host,
                                                                   InetAddress addr,
                                                                   int port,
                                                                   String protocol,
                                                                   String prompt,
                                                                   String scheme)
要求已经向系统注册的 authenticator 提供密码。此方法为请求密码的首选方法，因为在InetAddress 不可用时可以提供主机名。

首先，如果存在安全管理器，则在 NetPermission("requestPasswordAuthentication") 权限下调用 checkPermission 方法。这可能导致 java.lang.SecurityException。

参数：
host - 请求验证的站点的主机名。
addr - 请求授权的站点的 InetAddress；如果未知则为 null。
port - 所请求的连接的端口。
protocol - 请求连接的协议 (getRequestingProtocol())
prompt - 标识验证域 (authentication realm) 的用户的提示字符串。
scheme - 验证方案
返回：
用户名/密码；或者无法得到，则返回 null。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许密码验证请求。
从以下版本开始：
1.4
另请参见：
SecurityManager.checkPermission(java.security.Permission), NetPermission

requestPasswordAuthentication

public static PasswordAuthentication requestPasswordAuthentication(String host,
                                                                   InetAddress addr,
                                                                   int port,
                                                                   String protocol,
                                                                   String prompt,
                                                                   String scheme,
                                                                   URL url,
                                                                   Authenticator.RequestorType reqType)
要求已经向系统注册的 authenticator 提供密码。

首先，如果存在安全管理器，则在 NetPermission("requestPasswordAuthentication") 权限下调用 checkPermission 方法。这可能导致 java.lang.SecurityException。

参数：
host - 请求验证的站点的主机名。
addr - 请求授权的站点的 InetAddress；或者未知则为 null。
port - 所请求的连接的端口
protocol - 请求连接的协议 (getRequestingProtocol())
prompt - 用户的提示字符串
scheme - 验证方案
url - 导致验证的请求 URL
reqType - 请求验证的实体的类型（服务器或代理）。
返回：
用户名/密码；或者无法得到，则返回 null。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许密码验证请求。
从以下版本开始：
1.5
另请参见：
SecurityManager.checkPermission(java.security.Permission), NetPermission

getRequestingHost

protected final String getRequestingHost()
获取请求验证的站点或代理的 hostname；如果不可用，则为 null。

返回：
需要验证的连接的主机名；如果不可用，则返回 null。
从以下版本开始：
1.4

getRequestingSite

protected final InetAddress getRequestingSite()
获取请求授权的站点的 InetAddress；如果不可用，则为 null。

返回：
请求授权的站点的 InetAddress；如果不可用，则返回 null。

getRequestingPort

protected final int getRequestingPort()
获取所请求的连接的端口号。

返回：
指示所请求连接的端口的 int。

getRequestingProtocol

protected final String getRequestingProtocol()
给出正在请求连接的协议。此协议往往基于 URL，但在以后的 JDK 中，它可能是（举例来说）用于密码保护的 SOCKS5 防火墙的 "SOCKS"。

返回：
协议，可以选择是否后跟 "/version"，其中 version 指的是版本号。
另请参见：
URL.getProtocol()

getRequestingPrompt

protected final String getRequestingPrompt()
获取请求方给出的提示字符串。

返回：
请求方给出的提示字符串（对于 http 请求就是验证域）

getRequestingScheme

protected final String getRequestingScheme()
获取请求方的方案（例如，HTTP 防火墙的 HTTP 方案）。

返回：
请求方的方案

getPasswordAuthentication

protected PasswordAuthentication getPasswordAuthentication()
需要密码授权时调用。子类应该重写默认实现，默认实现返回 null。

返回：
从用户收集的 PasswordAuthentication；如果一个也没有提供，则返回 null。

getRequestingURL

protected URL getRequestingURL()
返回导致请求验证的 URL。

返回：
请求 URL
从以下版本开始：
1.5

getRequestorType

protected Authenticator.RequestorType getRequestorType()
返回请求方是代理还是服务器。

返回：
请求方的验证类型
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Authenticator.RequestorType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.net
枚举 Authenticator.RequestorType

java.lang.Object
    继承者  java.lang.Enum<Authenticator.RequestorType>
        继承者  java.net.Authenticator.RequestorType
所有已实现的接口：
Serializable, Comparable<Authenticator.RequestorType>
正在封闭类：
Authenticator
public static enum Authenticator.RequestorType
extends Enum<Authenticator.RequestorType>

请求验证的实体的类型。

从以下版本开始：
1.5

枚举常量摘要
PROXY
请求验证的实体为 HTTP 代理服务器。
SERVER
请求验证的实体为 HTTP 原始服务器。
方法摘要
static Authenticator.RequestorType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Authenticator.RequestorType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

PROXY

public static final Authenticator.RequestorType PROXY
请求验证的实体为 HTTP 代理服务器。

SERVER

public static final Authenticator.RequestorType SERVER
请求验证的实体为 HTTP 原始服务器。

方法详细信息

values

public static final Authenticator.RequestorType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Authenticator.RequestorType c : Authenticator.RequestorType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Authenticator.RequestorType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


BindException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 BindException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.SocketException
                    继承者  java.net.BindException
所有已实现的接口：
Serializable
public class BindException
extends SocketException

试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。这些错误通常发生在端口正在使用中或无法分配所请求的本地地址时。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
BindException()
构造不带详细消息的新 BindException。
BindException(String msg)
构造一个新的 BindException，使其具有关于绑定错误产生原因的指定详细消息。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BindException

public BindException(String msg)
构造一个新的 BindException，使其具有关于绑定错误产生原因的指定详细消息。详细消息指的是一个具体描述此错误的 String。

参数：
msg - 详细消息

BindException

public BindException()
构造不带详细消息的新 BindException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CacheRequest (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 CacheRequest

java.lang.Object
    继承者  java.net.CacheRequest

public abstract class CacheRequest
extends Object

表示在 ResponseCache 中存储资源的通道。这种类的实例提供一个 OutputStream 对象，协议处理程序可以调用该对象来将资源数据存储到缓存中；另外还提供一个 abort() 方法，该方法允许中断和放弃缓存存储操作。如果从缓存读取响应或将响应写入缓存时遇到 IOException，则将中止当前缓存存储操作。

从以下版本开始：
1.5

构造方法摘要
CacheRequest()
方法摘要
abstract void | abort() 中止缓存响应的尝试。
abstract OutputStream | getBody() 返回可以将响应正文写入其中的 OutputStream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CacheRequest

public CacheRequest()
方法详细信息

getBody

public abstract OutputStream getBody()
                              throws IOException
返回可以将响应正文写入其中的 OutputStream。

返回：
可以将响应正文写入的 OutputStream
抛出：
IOException - 如果写入响应正文时发生 I/O 错误

abort

public abstract void abort()
中止缓存响应的尝试。如果从缓存读取响应或将响应写入缓存时遇到 IOException，则放弃当前缓存存储操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CacheResponse (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 CacheResponse

java.lang.Object
    继承者  java.net.CacheResponse
直接已知子类：
SecureCacheResponse
public abstract class CacheResponse
extends Object

表示从 ResponseCache 获取资源的通道。这种类的实例提供返回实体正文的 InputStream，同时提供一个返回关联响应头的 getHeaders() 方法。

从以下版本开始：
1.5

构造方法摘要
CacheResponse()
方法摘要
abstract InputStream | getBody() 以 InputStream 的形式返回响应正文。
abstract Map<String,List<String>> | getHeaders() 以 Map 的形式返回响应头。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CacheResponse

public CacheResponse()
方法详细信息

getHeaders

public abstract Map<String,List<String>> getHeaders()
                                             throws IOException
以 Map 的形式返回响应头。

返回：
一个不可变的 Map，其将响应头字段名称映射到字段值列表。状态行以 null 作为其字段名称。
抛出：
IOException - 如果在获取响应头时发生 I/O 错误。

getBody

public abstract InputStream getBody()
                             throws IOException
以 InputStream 的形式返回响应正文。

返回：
可以从中访问响应正文的 InputStream
抛出：
IOException - 如果获取响应正文时发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConnectException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 ConnectException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.SocketException
                    继承者  java.net.ConnectException
所有已实现的接口：
Serializable
public class ConnectException
extends SocketException

试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。这些错误通常发生在拒绝远程连接时（例如，没有任何进程在远程地址/端口上进行侦听）。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
ConnectException()
构造不带详细信息的新 ConnectException。
ConnectException(String msg)
构造一个新的 ConnectException，使其具有关于连接错误产生原因的指定详细消息。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConnectException

public ConnectException(String msg)
构造一个新的 ConnectException，使其具有关于连接错误产生原因的指定详细消息。详细消息指的是一个具体描述此错误的 String。

参数：
msg - 详细消息

ConnectException

public ConnectException()
构造不带详细信息的新 ConnectException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 ContentHandler

java.lang.Object
    继承者  java.net.ContentHandler

public abstract class ContentHandler
extends Object

抽象类 ContentHandler 是从 URLConnection 读取 Object 的所有类的超类。

应用程序一般不直接调用此类中的 getContent 方法。而是调用 URL 或 URLConnection 类中的 getContent 方法。应用程序的内容处理程序工厂（实现 ContentHandlerFactory 接口的类的实例，该接口通过调用 setContentHandler 设置）通过某个 String 来调用，该 String 给出将在套接字上接收的对象的 MIME 类型。工厂返回 ContentHandler 的子类的实例，并调用其 getContent 方法创建对象。

如果找不到任何内容处理程序，则 URLConnection 将在用户自定义的地点集合中查找内容处理程序。默认情况下，它在 sun.net.www.content 中查找，但是用户可以定义一个以垂线分隔的类前缀集合，也可以通过定义 java.content.handler.pkgs 属性以供搜索。类名称必须具有以下形式：

     {package-prefix}.{major}.{minor}
例如，
     YoyoDyne.experimental.text.plain
如果由调用方委托链外部的加载器执行内容处理程序类的加载，则 JVM 需要 RuntimePermission "getClassLoader"。

从以下版本开始：
JDK1.0
另请参见：
getContent(java.net.URLConnection), ContentHandlerFactory, URL.getContent(), URLConnection, URLConnection.getContent(), URLConnection.setContentHandlerFactory(java.net.ContentHandlerFactory)

构造方法摘要
ContentHandler()
方法摘要
abstract Object | getContent(URLConnection urlc) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。
Object | getContent(URLConnection urlc, Class[] classes) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ContentHandler

public ContentHandler()
方法详细信息

getContent

public abstract Object getContent(URLConnection urlc)
                           throws IOException
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。

参数：
urlc - URL 连接。
返回：
ContentHandler 读取的对象。
抛出：
IOException - 如果读取该对象时发生 I/O 错误。

getContent

public Object getContent(URLConnection urlc,
                         Class[] classes)
                  throws IOException
如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。 此方法的默认实现应该调用 getContent() 并在屏幕上显示建议类型的匹配项的返回类型。

参数：
urlc - URL 连接。
classes - 请求类型的数组
返回：
由 ContentHandler 读取的对象，其为建议类型的第一个匹配项。如果所有请求类型都不受支持，则返回 null。
抛出：
IOException - 如果读取该对象时发生 I/O 错误。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContentHandlerFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
接口 ContentHandlerFactory

public interface ContentHandlerFactory

此接口定义内容处理程序的工厂。此接口的实现应该将 MIME 类型映射到 ContentHandler 的实例中。

URLStreamHandler 类使用此接口创建 MIME 类型的 ContentHandler。

从以下版本开始：
JDK1.0
另请参见：
ContentHandler, URLStreamHandler

方法摘要
 ContentHandler createContentHandler(String mimetype)
创建从 URLStreamHandler 读取对象的新 ContentHandler。

方法详细信息

createContentHandler

ContentHandler createContentHandler(String mimetype)
创建从 URLStreamHandler 读取对象的新 ContentHandler。

参数：
mimetype - 需要内容处理程序的 MIME 类型。
返回：
从 URLStreamHandler 读取对象的新 ContentHandler。
另请参见：
ContentHandler, URLStreamHandler
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CookieHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 CookieHandler

java.lang.Object
    继承者  java.net.CookieHandler
直接已知子类：
CookieManager
public abstract class CookieHandler
extends Object

CookieHandler 对象提供一种回调机制以将 HTTP 状态管理策略实现挂钩到 HTTP 协议处理程序。HTTP 状态管理机制利用 HTTP 请求和响应指定创建有状态的会话的方式。

可以通过执行 CookieHandler.setDefault(CookieHandler) 来注册 HTTP 协议处理程序要使用的系统级 CookieHandler。调用 CookieHandler.getDefault() 可以获取当前注册的 CookieHandler。 有关 HTTP 状态管理的更多信息，请参见 RFC 2965: HTTP 状态管理机制

从以下版本开始：
1.5

构造方法摘要
CookieHandler()
方法摘要
abstract Map<String,List<String>> | get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
static CookieHandler | getDefault() 获取系统级 cookie 处理程序。
abstract void | put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
static void | setDefault(CookieHandler cHandler) 设置（或取消设置）系统级 cookie 处理程序。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CookieHandler

public CookieHandler()
方法详细信息

getDefault

public static CookieHandler getDefault()
获取系统级 cookie 处理程序。

返回：
系统级 cookie 处理程序；返回 null 表示当前没有设置任何系统级 cookie 处理程序。
抛出：
SecurityException - 如果安装了安全管理器并且它拒绝 NetPermission<tt>("getCookieHandler")</tt>
另请参见：
setDefault(CookieHandler)

setDefault

public static void setDefault(CookieHandler cHandler)
设置（或取消设置）系统级 cookie 处理程序。 注：非标准 http 协议处理程序可能忽略此设置。

参数：
cHandler - HTTP cookie 处理程序；或者 <code>null</code>，表示取消设置。
抛出：
SecurityException - 如果安装了安全管理器并且它拒绝 NetPermission<tt>("setCookieHandler")</tt>
另请参见：
getDefault()

get

public abstract Map<String,List<String>> get(URI uri,
                                             Map<String,List<String>> requestHeaders)
                                      throws IOException
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。 HTTP 协议实现程序应该确保在添加所有与选择 cookie 相关的请求头之后且在发送请求之前调用此方法。

参数：
uri - 作为请求中 cookie 发送目标的 <code>URI</code>
requestHeaders - 从请求头字段名到表示当前请求头的字段值列表的 Map
返回：
从字段名为 "Cookie" 或 "Cookie2" 的状态管理头到包含状态信息的 cookie 列表的映射
抛出：
IOException - 如果发生 I/O * 错误
IllegalArgumentException - 如果其中任意一个参数为 null
另请参见：
put(URI, Map)

put

public abstract void put(URI uri,
                         Map<String,List<String>> responseHeaders)
                  throws IOException
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。

参数：
uri - <code>URI</code>，cookie 来自其中
responseHeaders - 从字段名到表示返回的响应头字段的字段值列表的不可变映射
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果其中任意一个参数为 null
另请参见：
get(URI, Map)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CookieManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 CookieManager

java.lang.Object
    继承者  java.net.CookieHandler
        继承者  java.net.CookieManager

public class CookieManager
extends CookieHandler

CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。使用管理存储的 CookieStore 以及做出 cookie 接受/拒绝决策的 CookiePolicy 对象来初始化 CookieManager。

java.net 包中的 HTTP cookie 管理如下所示：

use
CookieHandler <------- HttpURLConnection
       ^
| impl
|         use
CookieManager -------> CookiePolicy
|   use
|--------> HttpCookie
             |              ^
|              | use
|   use        |
|--------> CookieStore
                            ^
| impl
                            |
Internal in-memory implementation
  • CookieHandler 是 cookie 管理的核心所在。用户可以调用 CookieHandler.setDefault 设置要使用的具体 CookieHanlder 实现。
  • CookieManager.put 调用 CookiePolicy.shouldAccept 以查看 cookie 是否应该被接受并放入 cookie 存储区。用户可以使用三种预定义 CookiePolicy（即 ACCEPT_ALL、ACCEPT_NONE 和 ACCEPT_ORIGINAL_SERVER）中的任何一种，或者定义自己的 CookiePolicy 实现并告知 CookieManager 使用该策略。
  • CookieStore 是存储任何已接受 HTTP cookie 的地方。如果创建时未指定，那么 CookieManager 实例将使用内部内存实现。用户也可以实现一个 CookieStore 并告知 CookieManager 使用该存储区。
  • 当前，CookieManager 只能使用 CookieStore.add(URI, HttpCookie) 和 CookieStore.get(URI)。其他方法是出于完整性考虑，也可能是更复杂 CookieStore 实现（例如 NetscapeCookieSotre）的需要。

用户可以用各种方式“钩住”自己的 HTTP cookie 管理行为，例如：

  • 使用 CookieHandler.setDefault 设置全新的 CookieHandler 实现
  • 让 CookieManager 成为默认 CookieHandler 实现，但实现用户自己的 CookieStore 和 CookiePolicy， 并告知默认 CookieManager 使用它们：
    // this should be done at the beginning of an HTTP session
CookieHandler.setDefault(new CookieManager(new MyCookieStore(), new MyCookiePolicy()));
  • 让 CookieManager 成为默认 CookieHandler 实现，但使用自定义 CookiePolicy：
    // this should be done at the beginning of an HTTP session
CookieHandler.setDefault(new CookieManager());
// this can be done at any point of an HTTP session
((CookieManager)CookieHandler.getDefault()).setCookiePolicy(new MyCookiePolicy());

该实现遵守 RFC 2965 的第 3.3 节。

从以下版本开始：
1.6

构造方法摘要
CookieManager()
创建一个新 cookie 管理器。
CookieManager(CookieStore store, CookiePolicy cookiePolicy)
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。
方法摘要
Map<String,List<String>> | get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
CookieStore | getCookieStore() 获取当前 cookie 存储区。
void | put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
void | setCookiePolicy(CookiePolicy cookiePolicy) 设置此 cookie 管理器的 cookie 策略。
从类 java.net.CookieHandler 继承的方法
getDefault, setDefault
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CookieManager

public CookieManager()
创建一个新 cookie 管理器。

此构造方法将使用默认 cookie 存储区和接受策略创建新的 cookie 管理器。效果与 CookieManager(null, null) 相同。

CookieManager

public CookieManager(CookieStore store,
                     CookiePolicy cookiePolicy)
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。

参数：
store - cookie 管理器要使用的 CookieStore。如果为 null，则 cookie 管理器将使用默认存储区，即一个内存 CookieStore 实现。
cookiePolicy - cookie 管理器用作策略回调的 CookiePolicy 实例。如果为 null，则使用 ACCEPT_ORIGINAL_SERVER。
方法详细信息

setCookiePolicy

public void setCookiePolicy(CookiePolicy cookiePolicy)
设置此 cookie 管理器的 cookie 策略。

默认情况下，CookieManager 实例具有 cookie 策略 ACCEPT_ORIGINAL_SERVER。用户总是可以调用此方法来设置另一种 cookie 策略。

参数：
cookiePolicy - cookie 策略。可以为 null，表示对当前 cookie 策略没有影响。

getCookieStore

public CookieStore getCookieStore()
获取当前 cookie 存储区。

返回：
cookie 管理器当前使用的 cookie 存储区。

get

public Map<String,List<String>> get(URI uri,
                                    Map<String,List<String>> requestHeaders)
                             throws IOException
从类 CookieHandler 复制的描述
从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。 HTTP 协议实现程序应该确保在添加所有与选择 cookie 相关的请求头之后且在发送请求之前调用此方法。

指定者：
类 CookieHandler 中的 get
参数：
uri - 作为请求中 cookie 发送目标的 <code>URI</code>
requestHeaders - 从请求头字段名到表示当前请求头的字段值列表的 Map
返回：
从字段名为 "Cookie" 或 "Cookie2" 的状态管理头到包含状态信息的 cookie 列表的映射
抛出：
IOException - 如果发生 I/O * 错误
另请参见：
CookieHandler.put(URI, Map)

put

public void put(URI uri,
                Map<String,List<String>> responseHeaders)
         throws IOException
从类 CookieHandler 复制的描述
将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。

指定者：
类 CookieHandler 中的 put
参数：
uri - <code>URI</code>，cookie 来自其中
responseHeaders - 从字段名到表示返回的响应头字段的字段值列表的不可变映射
抛出：
IOException - 如果发生 I/O 错误
另请参见：
CookieHandler.get(URI, Map)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CookiePolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
接口 CookiePolicy

public interface CookiePolicy

CookiePolicy 实现决定应该接受哪个 cookie 以及应该拒绝哪个 cookie。提供了三种预定义的策略实现，即 ACCEPT_ALL、ACCEPT_NONE 和 ACCEPT_ORIGINAL_SERVER。

有关更多详细信息，请参阅 RFC 2965 第 3.3 节和第 7 节。

从以下版本开始：
1.6

字段摘要
static CookiePolicy | ACCEPT_ALL 一种预定义策略，表示接受所有 cookie。
static CookiePolicy | ACCEPT_NONE 一种预定义策略，表示不接受任何 cookie。
static CookiePolicy | ACCEPT_ORIGINAL_SERVER 一种预定义策略，表示只接受来自原始服务器的 cookie。
方法摘要
 boolean shouldAccept(URI uri, HttpCookie cookie)
调用此方法查看此 cookie 是否应该被接受。

字段详细信息

ACCEPT_ALL

static final CookiePolicy ACCEPT_ALL
一种预定义策略，表示接受所有 cookie。

ACCEPT_NONE

static final CookiePolicy ACCEPT_NONE
一种预定义策略，表示不接受任何 cookie。

ACCEPT_ORIGINAL_SERVER

static final CookiePolicy ACCEPT_ORIGINAL_SERVER
一种预定义策略，表示只接受来自原始服务器的 cookie。

方法详细信息

shouldAccept

boolean shouldAccept(URI uri,
                     HttpCookie cookie)
调用此方法查看此 cookie 是否应该被接受。

参数：
uri - 要查询接受策略的 URI
cookie - 相关的 HttpCookie 对象
返回：
如果此 cookie 应该被接受，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CookieStore (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
接口 CookieStore

public interface CookieStore

表示 cookie 存储区的 CookieStore 对象。可以存储和获取 cookie。

CookieManager 将调用 CookieStore.add 为每个传入的 HTTP 响应保存 cookie，调用 CookieStore.get 为每个传出的 HTTP 请求获取 cookie。CookieStore 负责移除已过期的 HttpCookie 实例。

从以下版本开始：
1.6

方法摘要
void | add(URI uri, HttpCookie cookie) 将一个 HTTP cookie 添加到存储区中。
List<HttpCookie> | get(URI uri) 获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
List<HttpCookie> | getCookies() 获取 cookie 存储区中所有未过期的 cookie。
List<URI> | getURIs() 获取所有标识此 cookie 存储区中 cookie 的 URI。
boolean | remove(URI uri, HttpCookie cookie) 从存储区中移除 cookie。
boolean | removeAll() 移除此 cookie 存储区中的所有 cookie。

方法详细信息

add

void add(URI uri,
         HttpCookie cookie)
将一个 HTTP cookie 添加到存储区中。为每个传入的 HTTP 响应调用此方法。

要存储的 cookie 可能关联 URI，也可能不关联 URI。如果它不关联 URI，那么 cookie 的域和路径属性将指示其出处。如果它关联 URI，则不指定它的域和路径属性，给定 URI 将指示此 cookie 的出处。

如果对应于给定 URI 的 cookie 已经存在，则使用新的 cookie 替换它。

参数：
uri - 此 cookie 关联的 uri。如果为 null，则此 cookie 不关联 URI
cookie - 要存储的 cookie
抛出：
NullPointerException - 如果 cookie 为 null
另请参见：
get(java.net.URI)

get

List<HttpCookie> get(URI uri)
获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。只返回未过期的 cookie。为每个传出的 HTTP 请求调用此方法。

返回：
HttpCookie 的不可变列表；如果没有与给定 URI 匹配的 cookie，则返回空列表
抛出：
NullPointerException - 如果 uri 为 null
另请参见：
add(java.net.URI, java.net.HttpCookie)

getCookies

List<HttpCookie> getCookies()
获取 cookie 存储区中所有未过期的 cookie。

返回：
http cookie 的不可变列表；如果存储区中没有 http cookie，则返回空列表

getURIs

List<URI> getURIs()
获取所有标识此 cookie 存储区中 cookie 的 URI。

返回：
URI 的不可变列表；如果此 cookie 存储区中的 cookie 都不关联 URI，则返回空列表

remove

boolean remove(URI uri,
               HttpCookie cookie)
从存储区中移除 cookie。

参数：
uri - 此 cookie 关联的 uri。如果为 null，则添加时要移除的 cookie 不关联 URI；如果不为 null，则添加时要移除的 cookie 与给定的 URI 关联。
cookie - 要移除的 cookie
返回：
如果此存储区包含指定的 cookie，则返回 true
抛出：
NullPointerException - 如果 cookie 为 null

removeAll

boolean removeAll()
移除此 cookie 存储区中的所有 cookie。

返回：
如果此存储区由于调用而更改，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatagramPacket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 DatagramPacket

java.lang.Object
    继承者  java.net.DatagramPacket

public final class DatagramPacket
extends Object

此类表示数据报包。

数据报包用来实现无连接包投递服务。每条报文仅根据该包中包含的信息从一台机器路由到另一台机器。从一台机器发送到另一台机器的多个包可能选择不同的路由，也可能按不同的顺序到达。不对包投递做出保证。

从以下版本开始：
JDK1.0

构造方法摘要
DatagramPacket(byte[] buf, int length)
构造 DatagramPacket，用来接收长度为 length 的数据包。
DatagramPacket(byte[] buf, int length, InetAddress address, int port)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int offset, int length)
构造 DatagramPacket，用来接收长度为 length 的包，在缓冲区中指定了偏移量。
DatagramPacket(byte[] buf, int offset, int length, InetAddress address, int port)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int offset, int length, SocketAddress address)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int length, SocketAddress address)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
方法摘要
InetAddress | getAddress() 返回某台机器的 IP 地址，此数据报将要发往该机器或者是从该机器接收到的。
byte[] | getData() 返回数据缓冲区。
int | getLength() 返回将要发送或接收到的数据的长度。
int | getOffset() 返回将要发送或接收到的数据的偏移量。
int | getPort() 返回某台远程主机的端口号，此数据报将要发往该主机或者是从该主机接收到的。
SocketAddress | getSocketAddress() 获取要将此包发送到的或发出此数据报的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。
void | setAddress(InetAddress iaddr) 设置要将此数据报发往的那台机器的 IP 地址。
void | setData(byte[] buf) 为此包设置数据缓冲区。
void | setData(byte[] buf, int offset, int length) 为此包设置数据缓冲区。
void | setLength(int length) 为此包设置长度。
void | setPort(int iport) 设置要将此数据报发往的远程主机上的端口号。
void | setSocketAddress(SocketAddress address) 设置要将此数据报发往的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DatagramPacket

public DatagramPacket(byte[] buf,
                      int offset,
                      int length)
构造 DatagramPacket，用来接收长度为 length 的包，在缓冲区中指定了偏移量。

length 参数必须小于等于 buf.length。

参数：
buf - 保存传入数据报的缓冲区。
offset - 缓冲区的偏移量
length - 读取的字节数。
从以下版本开始：
1.2

DatagramPacket

public DatagramPacket(byte[] buf,
                      int length)
构造 DatagramPacket，用来接收长度为 length 的数据包。

length 参数必须小于等于 buf.length。

参数：
buf - 保存传入数据报的缓冲区。
len - 要读取的字节数。

DatagramPacket

public DatagramPacket(byte[] buf,
                      int offset,
                      int length,
                      InetAddress address,
                      int port)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。length 参数必须小于等于 buf.length。

参数：
buf - 包数据。
offset - 包数据偏移量。
length - 包数据长度。
address - 目的地址。
port - 目的端口号。
从以下版本开始：
1.2
另请参见：
InetAddress

DatagramPacket

public DatagramPacket(byte[] buf,
                      int offset,
                      int length,
                      SocketAddress address)
               throws SocketException
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。length 参数必须小于等于 buf.length。

参数：
buf - 包数据。
offset - 包数据偏移量。
length - 包数据长度。
address - 目的套接字地址。
抛出：
IllegalArgumentException - 如果地址类型不受支持
SocketException
从以下版本开始：
1.4
另请参见：
InetAddress

DatagramPacket

public DatagramPacket(byte[] buf,
                      int length,
                      InetAddress address,
                      int port)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。length 参数必须小于等于 buf.length。

参数：
buf - 包数据。
length - 包长度。
address - 目的地址。
port - 目的端口号。
另请参见：
InetAddress

DatagramPacket

public DatagramPacket(byte[] buf,
                      int length,
                      SocketAddress address)
               throws SocketException
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。length 参数必须小于等于 buf.length。

参数：
buf - 包数据。
length - 包长度。
address - 目的地址。
抛出：
IllegalArgumentException - 如果地址类型不受支持
SocketException
从以下版本开始：
1.4
另请参见：
InetAddress
方法详细信息

getAddress

public InetAddress getAddress()
返回某台机器的 IP 地址，此数据报将要发往该机器或者是从该机器接收到的。

返回：
某台机器的 IP 地址，此数据报将要发往该机器或者是从该机器接收到的。
另请参见：
InetAddress, setAddress(java.net.InetAddress)

getPort

public int getPort()
返回某台远程主机的端口号，此数据报将要发往该主机或者是从该主机接收到的。

返回：
返回某台远程主机的端口号，此数据报将要发往该主机或者是从该主机接收到的。
另请参见：
setPort(int)

getData

public byte[] getData()
返回数据缓冲区。接收到的或将要发送的数据从缓冲区中的偏移量 offset 处开始，持续 length 长度。

返回：
用来接收或发送数据的缓冲区
另请参见：
setData(byte[], int, int)

getOffset

public int getOffset()
返回将要发送或接收到的数据的偏移量。

返回：
将要发送或接收到的数据的偏移量。
从以下版本开始：
1.2

getLength

public int getLength()
返回将要发送或接收到的数据的长度。

返回：
将要发送或接收到的数据的长度。
另请参见：
setLength(int)

setData

public void setData(byte[] buf,
                    int offset,
                    int length)
为此包设置数据缓冲区。此方法设置包的数据、长度和偏移量。

参数：
buf - 要为此包设置的缓冲区。
offset - 数据中的偏移量
length - 数据的长度和/或用来接收数据的缓冲区长度。
抛出：
NullPointerException - 如果参数为 null。
从以下版本开始：
1.2
另请参见：
getData(),
getOffset(),
getLength()

setAddress

public void setAddress(InetAddress iaddr)
设置要将此数据报发往的那台机器的 IP 地址。

参数：
iaddr - InetAddress
从以下版本开始：
JDK1.1
另请参见：
getAddress()

setPort

public void setPort(int iport)
设置要将此数据报发往的远程主机上的端口号。

参数：
iport - 端口号
从以下版本开始：
JDK1.1
另请参见：
getPort()

setSocketAddress

public void setSocketAddress(SocketAddress address)
设置要将此数据报发往的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。

参数：
address - SocketAddress
抛出：
IllegalArgumentException - 如果地址为 null 或为不受此套接字支持的 SocketAddress 子类。
从以下版本开始：
1.4
另请参见：
getSocketAddress()

getSocketAddress

public SocketAddress getSocketAddress()
获取要将此包发送到的或发出此数据报的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。

返回：
SocketAddress
从以下版本开始：
1.4
另请参见：
setSocketAddress(java.net.SocketAddress)

setData

public void setData(byte[] buf)
为此包设置数据缓冲区。将此 DatagramPacket 的偏移量设置为 0，长度设置为 buf 的长度。

参数：
buf - 要为此包设置的缓冲区。
抛出：
NullPointerException - 如果参数为 null。
从以下版本开始：
JDK1.1
另请参见：
getLength(), getData()

setLength

public void setLength(int length)
为此包设置长度。包的长度是指包数据缓冲区中将要发送的字节数，或用来接收数据的包数据缓冲区的字节数。长度必须小于等于偏移量与包缓冲区长度之和。

参数：
length - 要为此包设置的长度。
抛出：
IllegalArgumentException - 如果长度为负或大于包数据缓冲区长度。
从以下版本开始：
JDK1.1
另请参见：
getLength(), setData(byte[], int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatagramSocket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 DatagramSocket

java.lang.Object
    继承者  java.net.DatagramSocket
直接已知子类：
MulticastSocket
public class DatagramSocket
extends Object

此类表示用来发送和接收数据报包的套接字。

数据报套接字是包投递服务的发送或接收点。每个在数据报套接字上发送或接收的包都是单独编址和路由的。从一台机器发送到另一台机器的多个包可能选择不同的路由，也可能按不同的顺序到达。

在 DatagramSocket 上总是启用 UDP 广播发送。为了接收广播包，应该将 DatagramSocket 绑定到通配符地址。在某些实现中，将 DatagramSocket 绑定到一个更加具体的地址时广播包也可以被接收。

示例：DatagramSocket s = new DatagramSocket(null); s.bind(new InetSocketAddress(8888)); 这等价于：DatagramSocket s = new DatagramSocket(8888); 两个例子都能创建能够在 UDP 8888 端口上接收广播的 DatagramSocket。

从以下版本开始：
JDK1.0
另请参见：
DatagramPacket, DatagramChannel

构造方法摘要
 | DatagramSocket() 构造数据报套接字并将其绑定到本地主机上任何可用的端口。
protected | DatagramSocket(DatagramSocketImpl impl) 创建带有指定 DatagramSocketImpl 的未绑定数据报套接字。
 | DatagramSocket(int port) 创建数据报套接字并将其绑定到本地主机上的指定端口。
 | DatagramSocket(int port, InetAddress laddr) 创建数据报套接字，将其绑定到指定的本地地址。
 | DatagramSocket(SocketAddress bindaddr) 创建数据报套接字，将其绑定到指定的本地套接字地址。
方法摘要
void | bind(SocketAddress addr) 将此 DatagramSocket 绑定到特定的地址和端口。
void | close() 关闭此数据报套接字。
void | connect(InetAddress address, int port) 将套接字连接到此套接字的远程地址。
void | connect(SocketAddress addr) 将此套接字连接到远程套接字地址（IP 地址 + 端口号）。
void | disconnect() 断开套接字的连接。
boolean | getBroadcast() 检测是否启用了 SO_BROADCAST。
DatagramChannel | getChannel() 返回与此数据报套接字关联的唯一 DatagramChannel 对象（如果有）。
InetAddress | getInetAddress() 返回此套接字连接的地址。
InetAddress | getLocalAddress() 获取套接字绑定的本地地址。
int | getLocalPort() 返回此套接字绑定的本地主机上的端口号。
SocketAddress | getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
int | getPort() 返回此套接字的端口。
int | getReceiveBufferSize() 获取此 DatagramSocket 的 SO_RCVBUF 选项的值，该值是平台在 DatagramSocket 上输入时使用的缓冲区大小。
SocketAddress | getRemoteSocketAddress() 返回此套接字连接的端点的地址，如果未连接则返回 null。
boolean | getReuseAddress() 检测是否启用了 SO_REUSEADDR。
int | getSendBufferSize() 获取此 DatagramSocket 的 SO_SNDBUF 选项的值，该值是平台在 DatagramSocket 上输出时使用的缓冲区大小。
int | getSoTimeout() 获取 SO_TIMEOUT 的设置。
int | getTrafficClass() 为从此 DatagramSocket 上发送的包获取 IP 数据报头中的流量类别或服务类型。
boolean | isBound() 返回套接字的绑定状态。
boolean | isClosed() 返回是否关闭了套接字。
boolean | isConnected() 返回套接字的连接状态。
void | receive(DatagramPacket p) 从此套接字接收数据报包。
void | send(DatagramPacket p) 从此套接字发送数据报包。
void | setBroadcast(boolean on) 启用/禁用 SO_BROADCAST。
static void | setDatagramSocketImplFactory(DatagramSocketImplFactory fac) 为应用程序设置数据报套接字实现工厂。
void | setReceiveBufferSize(int size) 将此 DatagramSocket 的 SO_RCVBUF 选项设置为指定的值。
void | setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | setSendBufferSize(int size) 将此 DatagramSocket 的 SO_SNDBUF 选项设置为指定的值。
void | setSoTimeout(int timeout) 启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
void | setTrafficClass(int tc) 为从此 DatagramSocket 上发送的数据报在 IP 数据报头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DatagramSocket

public DatagramSocket()
               throws SocketException
构造数据报套接字并将其绑定到本地主机上任何可用的端口。套接字将被绑定到通配符地址，IP 地址由内核来选择。

如果有安全管理器，则首先使用 0 作为变量来调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

抛出：
SocketException - 如果套接字不能被打开，或不能将其绑定到指定的本地端口。
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
另请参见：
SecurityManager.checkListen(int)

DatagramSocket

protected DatagramSocket(DatagramSocketImpl impl)
创建带有指定 DatagramSocketImpl 的未绑定数据报套接字。

参数：
impl - 子类希望在 DatagramSocket 上使用的 DatagramSocketImpl 的实例。
从以下版本开始：
1.4

DatagramSocket

public DatagramSocket(SocketAddress bindaddr)
               throws SocketException
创建数据报套接字，将其绑定到指定的本地套接字地址。

如果地址为 null，创建未绑定的套接字。

如果有安全管理器，则首先使用套接字中的端口作为变量来调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

参数：
bindaddr - 要绑定的本地套接字地址，对于未绑定的套接字为 null。
抛出：
SocketException - 如果套接字不能被打开，或不能将其绑定到指定的本地端口。
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
从以下版本开始：
1.4
另请参见：
SecurityManager.checkListen(int)

DatagramSocket

public DatagramSocket(int port)
               throws SocketException
创建数据报套接字并将其绑定到本地主机上的指定端口。套接字将被绑定到通配符地址，IP 地址由内核来选择。

如果存在安全管理器，则首先使用 port 参数作为参数调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

参数：
port - 要使用的端口。
抛出：
SocketException - 如果套接字不能被打开，或不能将其绑定到指定的本地端口。
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
另请参见：
SecurityManager.checkListen(int)

DatagramSocket

public DatagramSocket(int port,
                      InetAddress laddr)
               throws SocketException
创建数据报套接字，将其绑定到指定的本地地址。本地端口必须在 0 到 65535 之间（包括两者）。如果 IP 地址为 0.0.0.0，套接字将被绑定到通配符地址，IP 地址由内核选择。

如果存在安全管理器，则首先使用 port 参数作为参数调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

参数：
port - 要使用的本地端口
laddr - 要绑定的本地地址
抛出：
SocketException - 如果套接字不能被打开，或不能将其绑定到指定的本地端口。
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
从以下版本开始：
JDK1.1
另请参见：
SecurityManager.checkListen(int)
方法详细信息

bind

public void bind(SocketAddress addr)
          throws SocketException
将此 DatagramSocket 绑定到特定的地址和端口。

如果地址为 null，则系统将挑选一个临时端口和一个有效本地地址来绑定套接字。

参数：
addr - 要绑定的地址和端口。
抛出：
SocketException - 如果绑定过程中发生错误，或者套接字已经被绑定。
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
IllegalArgumentException - 如果 addr 是不受此套接字支持的 SocketAddress 子类。
从以下版本开始：
1.4

connect

public void connect(InetAddress address,
                    int port)
将套接字连接到此套接字的远程地址。当套接字连接到远程地址时，包就只能从该地址发送或接收。默认情况下不连接数据报套接字。

如果套接字要连接的远程目标不存在或不可到达，并且收到了该地址的目标不可达 ICMP 包，那么后续发送和接收的调用可能会抛出 PortUnreachableException。注意，不能保证一定抛出该异常。

在连接时检查调用者对给定主机和端口的发送和接收数据报权限。当连接建立起来后，接收和发送除了对包和套接字的地址和端口进行匹配外，对传入和传出的包将不再执行任何安全性检查。对于发送操作，如果设置了包的地址并且包的地址和套接字的地址不匹配，则将抛出 IllegalArgumentException。连接到多播地址的套接字只能用于发送包。

参数：
address - 套接字的远程地址。
port - 套接字的远程端口。
抛出：
IllegalArgumentException - 如果地址为 null，或端口超出了范围。
SecurityException - 如果不允许调用者向此地址和端口发送也不允许从此地址接收数据报。
另请参见：
disconnect(),
send(java.net.DatagramPacket),
receive(java.net.DatagramPacket)

connect

public void connect(SocketAddress addr)
             throws SocketException
将此套接字连接到远程套接字地址（IP 地址 + 端口号）。

参数：
addr - 远程地址。
抛出：
SocketException - 如果连接失败
IllegalArgumentException - 如果 addr 为 null 或者 addr 是不受此套接字支持的 SocketAddress 子类。
从以下版本开始：
1.4
另请参见：
connect(java.net.InetAddress, int)

disconnect

public void disconnect()
断开套接字的连接。如果套接字没有连接，则此方法不执行任何操作。

另请参见：
connect(java.net.InetAddress, int)

isBound

public boolean isBound()
返回套接字的绑定状态。

返回：
如果将套接字成功地绑定到一个地址，则返回 true
从以下版本开始：
1.4

isConnected

public boolean isConnected()
返回套接字的连接状态。

返回：
如果将套接字成功地连接到服务器，则为 true。
从以下版本开始：
1.4

getInetAddress

public InetAddress getInetAddress()
返回此套接字连接的地址。如果套接字未连接，则返回 null。

返回：
此套接字连接的地址。

getPort

public int getPort()
返回此套接字的端口。如果套接字未连接，则返回 -1。

返回：
此套接字连接的端口。

getRemoteSocketAddress

public SocketAddress getRemoteSocketAddress()
返回此套接字连接的端点的地址，如果未连接则返回 null。

返回：
表示此套接字远程端点的 SocketAddress，如果尚未连接则返回 null。
从以下版本开始：
1.4
另请参见：
getInetAddress(),
getPort(),
connect(SocketAddress)

getLocalSocketAddress

public SocketAddress getLocalSocketAddress()
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。

返回：
表示此套接字的本地端点的 SocketAddress，如果尚未绑定则返回 null。
从以下版本开始：
1.4
另请参见：
getLocalAddress(),
getLocalPort(),
bind(SocketAddress)

send

public void send(DatagramPacket p)
          throws IOException
从此套接字发送数据报包。DatagramPacket 包含的信息指示：将要发送的数据、其长度、远程主机的 IP 地址和远程主机的端口号。

如果存在安全管理器，且套接字当前没有连接到远程地址，则此方法首先执行某些安全性检查。首先，如果 p.getAddress().isMulticastAddress() 为 true，则此方法以 p.getAddress() 作为参数调用安全管理器的 checkMulticast 方法。如果该表达式的值为 false，此方法改为调用安全管理器的以 p.getAddress().getHostAddress() 和 p.getPort() 为参数的 checkConnect 方法。如果不允许该操作，则每次调用安全管理器方法都会导致 SecurityException。

参数：
p - 将要发送的 DatagramPacket。
抛出：
IOException - 如果发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkMulticast 或 checkConnect 方法不允许进行发送。
PortUnreachableException - 套接字连接到当前不可达的目标时可能抛出。注意，不能保证一定抛出该异常。
IllegalBlockingModeException - 如果此套接字具有相关联的通道，且通道处于非阻塞模式。
另请参见：
DatagramPacket, SecurityManager.checkMulticast(InetAddress), SecurityManager.checkConnect(java.lang.String, int)

receive

public void receive(DatagramPacket p)
             throws IOException
从此套接字接收数据报包。当此方法返回时，DatagramPacket 的缓冲区填充了接收的数据。数据报包也包含发送方的 IP 地址和发送方机器上的端口号。

此方法在接收到数据报前一直阻塞。数据报包对象的 length 字段包含所接收信息的长度。如果信息比包的长度长，该信息将被截短。

如果存在安全管理器，而安全管理器的 checkAccept 方法不允许接收操作，则包不能被接收。

参数：
p - 要放置传入数据的 DatagramPacket。
抛出：
IOException - 如果发生 I/O 错误。
SocketTimeoutException - 如果先前调用了 setSoTimeout 且超时值已过。
PortUnreachableException - 套接字连接到当前不可达的目标时可能抛出。注意，不能保证一定抛出该异常。
IllegalBlockingModeException - 如果此套接字具有相关联的通道，且通道处于非阻塞模式。
另请参见：
DatagramPacket, DatagramSocket

getLocalAddress

public InetAddress getLocalAddress()
获取套接字绑定的本地地址。

如果存在安全管理器，则首先使用主机地址和 -1 作为参数调用其 checkConnect 方法，以查看是否允许该操作。

返回：
套接字绑定的本地地址，如果套接字没有绑定或安全管理器的 checkConnect 方法不允许该操作，则返回表示任何本地地址的 InetAddress。
另请参见：
SecurityManager.checkConnect(java.lang.String, int)

getLocalPort

public int getLocalPort()
返回此套接字绑定的本地主机上的端口号。

返回：
此套接字绑定的本地主机上的端口。

setSoTimeout

public void setSoTimeout(int timeout)
                  throws SocketException
启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。将此选项设为非零的超时值时，对此 DatagramSocket 调用 receive() 将只阻塞此时间长度。如果超过超时值，将引发 java.net.SocketTimeoutException，虽然 DatagramSocket 仍旧有效。选项必须在进入阻塞操作前被启用才能生效。超时值必须是 > 0 的数。超时值为 0 被解释为无穷大超时值。

参数：
timeout - 指定的以毫秒为单位的超时值。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
从以下版本开始：
JDK1.1
另请参见：
getSoTimeout()

getSoTimeout

public int getSoTimeout()
                 throws SocketException
获取 SO_TIMEOUT 的设置。返回 0 意味着禁用了选项（即无穷大的超时值）。

返回：
SO_TIMEOUT 的设置。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
从以下版本开始：
JDK1.1
另请参见：
setSoTimeout(int)

setSendBufferSize

public void setSendBufferSize(int size)
                       throws SocketException
将此 DatagramSocket 的 SO_SNDBUF 选项设置为指定的值。网络实现使用 SO_SNDBUF 选项作为设置底层网络 I/O 缓冲区大小的提示。网络实现也可以使用 SO_SNDBUF 设置来决定在此套接字上可以传送的包的最大大小。

由于 SO_SNDBUF 是一种提示，想要验证缓冲区大小的应用程序应该调用 getSendBufferSize()。

当发送率很高时，增大缓冲区的大小可以允许网络实现对多个传出包进行排队。

注：如果使用 send(DatagramPacket) 来发送比 SO_SNDBUF 设置大的 DatagramPacket，包是被发送还是被丢弃是特定于实现的。

参数：
size - 将设置的发送缓冲区大小。此值必须大于 0。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
IllegalArgumentException - 如果值为 0 或负。
另请参见：
getSendBufferSize()

getSendBufferSize

public int getSendBufferSize()
                      throws SocketException
获取此 DatagramSocket 的 SO_SNDBUF 选项的值，该值是平台在 DatagramSocket 上输出时使用的缓冲区大小。

返回：
此 DatagramSocket 的 SO_SNDBUF 选项的值。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
另请参见：
setSendBufferSize(int)

setReceiveBufferSize

public void setReceiveBufferSize(int size)
                          throws SocketException
将此 DatagramSocket 的 SO_RCVBUF 选项设置为指定的值。网络实现使用 SO_RCVBUF 选项作为设置底层网络 I/O 缓冲区大小的提示。网络实现也可以使用 SO_RCVBUF 设置来决定在此套接字上可以接收的包的最大大小。

由于 SO_RCVBUF 是一种提示，想要验证缓冲区设置大小的应用程序应该调用 getReceiveBufferSize()。

当包到达的速度快于使用 receive(DatagramPacket) 接收包的速度时，增大 SO_RCVBUF 可以允许网络实现缓存多个包。

注：是否能接收大于 SO_RCVBUF 的包是特定于实现的。

参数：
size - 要设置的接收缓冲区大小。此值必须大于 0。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
IllegalArgumentException - 如果值为 0 或负。
另请参见：
getReceiveBufferSize()

getReceiveBufferSize

public int getReceiveBufferSize()
                         throws SocketException
获取此 DatagramSocket 的 SO_RCVBUF 选项的值，该值是平台在 DatagramSocket 上输入时使用的缓冲区大小。

返回：
此 DatagramSocket 的 SO_RCVBUF 选项的值。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
另请参见：
setReceiveBufferSize(int)

setReuseAddress

public void setReuseAddress(boolean on)
                     throws SocketException
启用/禁用 SO_REUSEADDR 套接字选项。

对于 UDP 套接字可能有必要把超过一个的套接字绑定到相同的套接字地址。这样做的目的通常是为了接收多播包。（请参阅 MulticastSocket）。如果在使用 bind(SocketAddress) 绑定套接字之前启用 SO_REUSEADDR 套接字选项，则 SO_REUSEADDR 套接字选项允许将多个套接字绑定到相同的套结字地址。

注意：所有现有平台都不支持此功能，因此不管是否将忽略此选项，它都是特定于实现的。但是，如果此功能不受支持，则 getReuseAddress() 将始终返回 false。

当创建 DatagramSocket 时，禁用 SO_REUSEADDR 的初始设置。

在绑定套接字（请参阅 isBound()）后启用或禁用 SO_REUSEADDR 时的行为是不确定的。

参数：
on - 是否启用 SO_REUSEADDR 套接字选项
抛出：
如果启用或禁用 - SO_RESUEADDR 套接字选项时发生错误，或者关闭了套接字。
SocketException
从以下版本开始：
1.4
另请参见：
getReuseAddress(), bind(SocketAddress), isBound(), isClosed()

getReuseAddress

public boolean getReuseAddress()
                        throws SocketException
检测是否启用了 SO_REUSEADDR。

返回：
指示是否启用 SO_REUSEADDR 的 boolean 值。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
从以下版本开始：
1.4
另请参见：
setReuseAddress(boolean)

setBroadcast

public void setBroadcast(boolean on)
                  throws SocketException
启用/禁用 SO_BROADCAST。

参数：
on - 是否开启广播。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
从以下版本开始：
1.4
另请参见：
getBroadcast()

getBroadcast

public boolean getBroadcast()
                     throws SocketException
检测是否启用了 SO_BROADCAST。

返回：
指示是否启用 SO_BROADCAST 的 boolean 值。
抛出：
SocketException - 如果底层协议出现错误，例如 UDP 错误。
从以下版本开始：
1.4
另请参见：
setBroadcast(boolean)

setTrafficClass

public void setTrafficClass(int tc)
                     throws SocketException
为从此 DatagramSocket 上发送的数据报在 IP 数据报头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。由于底层网络实现可能忽略此值，应用程序应该将其视为一种提示。

tc 的值必须在 0 <= tc <= 255 范围内，否则将抛出 IllegalArgumentException。

注：

对于 Internet Protocol v4 该值由包含优先级和 TOS 字段的八位组组成，这在 RFC 1349 中有详细叙述。TOS 字段是由以下逐位或所得值创建的位集：

  • IPTOS_LOWCOST (0x02)
  • IPTOS_RELIABILITY (0x04)
  • IPTOS_THROUGHPUT (0x08)
  • IPTOS_LOWDELAY (0x10)
末尾的最低位常常被忽略，因为该位对应于 MBZ（必须为 0）位。

设置优先级字段中的位可能导致 SocketException，指示不允许该操作。

对于 Internet Protocol v6 tc 是将被放置到 IP 头部的 sin6_flowinfo 字段中的值。

参数：
tc - 此位集的 int 值。
抛出：
SocketException - 如果设置流量类别或服务类型时出现错误
从以下版本开始：
1.4
另请参见：
getTrafficClass()

getTrafficClass

public int getTrafficClass()
                    throws SocketException
为从此 DatagramSocket 上发送的包获取 IP 数据报头中的流量类别或服务类型。

由于底层网络实现可能忽略使用 setTrafficClass(int) 设置的流量类别或服务类型，因而此方法可能返回一个不同于以前用 setTrafficClass(int) 在此 DatagramSocket 上设置的值。

返回：
已经设置的流量类别或服务类型
抛出：
SocketException - 如果获得流量类别或服务类型值时出现错误。
从以下版本开始：
1.4
另请参见：
setTrafficClass(int)

close

public void close()
关闭此数据报套接字。

在此套接字上 receive(java.net.DatagramPacket) 中所有当前阻塞的线程将会抛出 SocketException。

如果此套接字有一个与之关联的通道，则关闭该通道。

isClosed

public boolean isClosed()
返回是否关闭了套接字。

返回：
如果已经关闭了套接字，则返回 true
从以下版本开始：
1.4

getChannel

public DatagramChannel getChannel()
返回与此数据报套接字关联的唯一 DatagramChannel 对象（如果有）。

当且仅当通过 DatagramChannel.open 方法创建了通道本身时，数据报套接字才具有一个通道。

返回：
与此数据报套接字关联的数据报通道，如果没有为通道创建套接字，则返回 null。
从以下版本开始：
1.4

setDatagramSocketImplFactory

public static void setDatagramSocketImplFactory(DatagramSocketImplFactory fac)
                                         throws IOException
为应用程序设置数据报套接字实现工厂。工厂只能指定一次。

当应用程序创建新的数据报套接字时，调用套接字实现工厂的 createDatagramSocketImpl 方法创建实际的数据报套接字实现。

除非已经设置了工厂，否则向该方法传递 null 是无操作。

如果存在安全管理器，此方法首先调用安全管理器的 checkSetFactory 方法，确保允许该操作。这可能会导致 SecurityException 异常。

参数：
fac - 所需的工厂。
抛出：
IOException - 如果设置数据报套接字工厂时发生 I/O 错误。
SocketException - 如果已经定义该工厂。
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行该操作。
从以下版本开始：
1.3
另请参见：
DatagramSocketImplFactory.createDatagramSocketImpl(), SecurityManager.checkSetFactory()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatagramSocketImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 DatagramSocketImpl

java.lang.Object
    继承者  java.net.DatagramSocketImpl
所有已实现的接口：
SocketOptions
public abstract class DatagramSocketImpl
extends Object
implements SocketOptions

数据报和多播套接字实现的抽象基类。

从以下版本开始：
JDK1.1

字段摘要
protected FileDescriptor | fd 文件描述符对象。
protected int | localPort 本地端口号。
从接口 java.net.SocketOptions 继承的字段
IP_MULTICAST_IF, IP_MULTICAST_IF2, IP_MULTICAST_LOOP, IP_TOS, SO_BINDADDR, SO_BROADCAST, SO_KEEPALIVE, SO_LINGER, SO_OOBINLINE, SO_RCVBUF, SO_REUSEADDR, SO_SNDBUF, SO_TIMEOUT, TCP_NODELAY
构造方法摘要
DatagramSocketImpl()
方法摘要
protected abstract void | bind(int lport, InetAddress laddr) 将数据报套接字绑定到本地端口和地址。
protected abstract void | close() 关闭套接字。
protected void | connect(InetAddress address, int port) 将数据报套接字连接到远程目标。
protected abstract void | create() 创建数据报套接字。
protected void | disconnect() 断开数据报套接字和远程目标的连接。
protected FileDescriptor | getFileDescriptor() 获取数据报套接字文件描述符。
protected int | getLocalPort() 获取本地端口。
protected abstract int | getTimeToLive() 获取 TTL （生存时间）选项。
protected abstract byte | getTTL() 已过时。 使用 getTimeToLive 代替。
protected abstract void | join(InetAddress inetaddr) 加入多播组。
protected abstract void | joinGroup(SocketAddress mcastaddr, NetworkInterface netIf) 加入多播组。
protected abstract void | leave(InetAddress inetaddr) 退出多播组。
protected abstract void | leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf) 退出多播组。
protected abstract int | peek(InetAddress i) 查看包来自哪里。
protected abstract int | peekData(DatagramPacket p) 查看包来自哪里。
protected abstract void | receive(DatagramPacket p) 接收数据报包。
protected abstract void | send(DatagramPacket p) 发送数据报包。
protected abstract void | setTimeToLive(int ttl) 设置 TTL （生存时间）选项。
protected abstract void | setTTL(byte ttl) 已过时。 使用 setTimeToLive 代替。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.net.SocketOptions 继承的方法
getOption, setOption

字段详细信息

localPort

protected int localPort
本地端口号。

fd

protected FileDescriptor fd
文件描述符对象。

构造方法详细信息

DatagramSocketImpl

public DatagramSocketImpl()
方法详细信息

create

protected abstract void create()
                        throws SocketException
创建数据报套接字。

抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。

bind

protected abstract void bind(int lport,
                             InetAddress laddr)
                      throws SocketException
将数据报套接字绑定到本地端口和地址。

参数：
lport - 本地端口
laddr - 本地地址
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。

send

protected abstract void send(DatagramPacket p)
                      throws IOException
发送数据报包。包包含数据和要将包发往的目的地址。

参数：
p - 将发送的包。
抛出：
IOException - 如果发送数据报包时出现 I/O 异常。
PortUnreachableException - 套接字连接到当前不可达的目标时可能抛出。注意，不能保证一定抛出该异常。

connect

protected void connect(InetAddress address,
                       int port)
                throws SocketException
将数据报套接字连接到远程目标。此方法使本地套接字和远程地址相关联，从而数据报只能被发送到此目标并只能从此目标被接收。可以重写此方法来调用本机系统连接。

如果套接字要连接的远程目标不存在或不可到达，并且收到了该地址的目标不可达 ICMP 包，那么后续发送和接收的调用可能会抛出 PortUnreachableException。注意，不能保证一定抛出该异常。

参数：
address - 要连接的远程 InetAddress
port - 远程端口号
抛出：
SocketException - 套接字不能连接到远程目标时可能抛出
从以下版本开始：
1.4

disconnect

protected void disconnect()
断开数据报套接字和远程目标的连接。

从以下版本开始：
1.4

peek

protected abstract int peek(InetAddress i)
                     throws IOException
查看包来自哪里。将指定的 InetAddress 更新为发送包的地址。

参数：
i - InetAddress 对象
返回：
发送包的端口号。
抛出：
IOException - 如果发生 /O 异常
PortUnreachableException - 套接字连接到当前不可到达的目标时可能抛出。注意，不能保证一定抛出该异常。

peekData

protected abstract int peekData(DatagramPacket p)
                         throws IOException
查看包来自哪里。数据被复制到指定的 DatagramPacket。数据返回，但不用掉，以便后续 peekData/receive 操作能看到相同的数据。

参数：
p - 收到的包。
返回：
发送包的端口号。
抛出：
IOException - 如果出现 /O 异常
PortUnreachableException - 套接字连接到当前不可到达的目标时可能抛出。注意，不能保证一定抛出该异常。
从以下版本开始：
1.4

receive

protected abstract void receive(DatagramPacket p)
                         throws IOException
接收数据报包。

参数：
p - 收到的包。
抛出：
IOException - 如果接收数据报包时发生 I/O 异常。
PortUnreachableException - 套接字连接到当前不可达的目标时可能抛出。注意，不能保证一定抛出该异常。

setTTL

@Deprecated
protected abstract void setTTL(byte ttl)
                        throws IOException
已过时。 使用 setTimeToLive 代替。

设置 TTL（生存时间）选项。

参数：
ttl - 指定 TTL 值的 byte。
抛出：
IOException - 如果设置生存时间选项时发生 I/O 异常。
另请参见：
getTTL()

getTTL

@Deprecated
protected abstract byte getTTL()
                        throws IOException
已过时。 使用 getTimeToLive 代替。

获取 TTL（生存时间）选项。

返回：
表示 TTL 值的字节
抛出：
IOException - 如果获取生存时间选项时发生 I/O 异常
另请参见：
setTTL(byte)

setTimeToLive

protected abstract void setTimeToLive(int ttl)
                               throws IOException
设置 TTL （生存时间）选项。

参数：
ttl - 指定生存时间的 int 值
抛出：
IOException - 如果设置生存时间选项时发生 I/O 异常。
另请参见：
getTimeToLive()

getTimeToLive

protected abstract int getTimeToLive()
                              throws IOException
获取 TTL （生存时间）选项。

返回：
表示生存时间的 int 值
抛出：
IOException - 如果获取生存时间选项时发生 I/O 异常。
另请参见：
setTimeToLive(int)

join

protected abstract void join(InetAddress inetaddr)
                      throws IOException
加入多播组。

参数：
inetaddr - 要加入的多播地址。
抛出：
IOException - 如果加入多播组时发生 I/O 异常。

leave

protected abstract void leave(InetAddress inetaddr)
                       throws IOException
退出多播组。

参数：
inetaddr - 要退出的多播地址。
抛出：
IOException - 如果退出多播组时出现 I/O 异常。

joinGroup

protected abstract void joinGroup(SocketAddress mcastaddr,
                                  NetworkInterface netIf)
                           throws IOException
加入多播组。

参数：
mcastaddr - 要加入的地址。
netIf - 指定接收多播数据报包的本地接口
抛出：
IOException - 如果加入多播组时出现 I/O 异常
从以下版本开始：
1.4

leaveGroup

protected abstract void leaveGroup(SocketAddress mcastaddr,
                                   NetworkInterface netIf)
                            throws IOException
退出多播组。

参数：
mcastaddr - 要退出的地址。
netIf - 指定的退出组的本地接口 throws IOException 如果退出多播组时出现 I/O 异常
抛出：
IOException
从以下版本开始：
1.4

close

protected abstract void close()
关闭套接字。

getLocalPort

protected int getLocalPort()
获取本地端口。

返回：
表示本地端口值的 int 值。

getFileDescriptor

protected FileDescriptor getFileDescriptor()
获取数据报套接字文件描述符。

返回：
表示数据报套接字文件描述符的 FileDescriptor 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileNameMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
接口 FileNameMap

public interface FileNameMap

提供在文件名和 MIME 类型字符串之间进行映射的机制的简单接口。

从以下版本开始：
JDK1.1

方法摘要
 String getContentTypeFor(String fileName)
获取指定文件名的 MIME 类型。

方法详细信息

getContentTypeFor

String getContentTypeFor(String fileName)
获取指定文件名的 MIME 类型。

参数：
fileName - 指定文件名
返回：
指示指定文件名的 MIME 类型的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatagramSocketImplFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
接口 DatagramSocketImplFactory

public interface DatagramSocketImplFactory

此接口定义用于数据报套接字实现的工厂。DatagramSocket 类使用它来创建实际的套接字实现。

从以下版本开始：
1.3
另请参见：
DatagramSocket

方法摘要
 DatagramSocketImpl createDatagramSocketImpl()
创建新的 DatagramSocketImpl 实例。

方法详细信息

createDatagramSocketImpl

DatagramSocketImpl createDatagramSocketImpl()
创建新的 DatagramSocketImpl 实例。

返回：
新的 DatagramSocketImpl 实例。
另请参见：
DatagramSocketImpl
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HttpCookie (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 HttpCookie

java.lang.Object
    继承者  java.net.HttpCookie
所有已实现的接口：
Cloneable
public final class HttpCookie
extends Object
implements Cloneable

HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。广泛采用 Cookie 来创建有状态 (stateful) 会话。

有 3 种 http cookie 规范：

Netscape 草案
RFC 2109 - http://www.ietf.org/rfc/rfc2109.txt
RFC 2965 - http://www.ietf.org/rfc/rfc2965.txt

HttpCookie 类可以接受所有这 3 种语法形式。

从以下版本开始：
1.6

构造方法摘要
HttpCookie(String name, String value)
构造带有指定名称和值的 cookie。
方法摘要
Object | clone() 创建并返回此对象的一个副本。
static boolean | domainMatches(String domain, String host) 检查主机名是否在域中的实用方法。
boolean | equals(Object obj) 测试两个 http cookie 的相等性。
String | getComment() 返回描述此 cookie 用途的注释；如果该 cookie 没有注释，则返回 null。
String | getCommentURL() 返回描述此 cookie 用途的注释 URL；如果 cookie 没有注释 URL，则返回 null。
boolean | getDiscard() 返回 cookie 的丢弃属性
String | getDomain() 返回为此 cookie 设置的域名。
long | getMaxAge() 返回以秒为单位指定的 cookie 最大生存时间。
String | getName() 返回 cookie 的名称。
String | getPath() 返回浏览器将此 cookie 返回到的服务器上的路径。
String | getPortlist() 返回 cookie 的端口列表属性
boolean | getSecure() 如果浏览器仅通过安全协议发送 cookie，则返回 true；如果浏览器可以使用任何协议发送 cookie，则返回 false。
String | getValue() 返回 cookie 的值。
int | getVersion() 返回此 cookie 遵守的协议版本。
boolean | hasExpired() 报告此 http cookie 是否已过期。
int | hashCode() 返回此 http cookie 的哈希码。
static List<HttpCookie> | parse(String header) 根据 set-cookie 或 set-cookie2 头字符串构造 cookie。
void | setComment(String purpose) 指定一个描述 cookie 用途的注释。
void | setCommentURL(String purpose) 指定一个描述 cookie 用途的注释 URL。
void | setDiscard(boolean discard) 指定用户代理是否应该无条件丢弃 cookie。
void | setDomain(String pattern) 指定应在其中显示此 cookie 的域。
void | setMaxAge(long expiry) 设置 cookie 的最大生存时间，以秒为单位。
void | setPath(String uri) 指定客户机应该返回 cookie 的路径。
void | setPortlist(String ports) 指定 cookie 的端口列表，该列表在 Cookie 头中限制可能将 cookie 发送回的端口。
void | setSecure(boolean flag) 指示浏览器是否只能使用安全协议（如 HTTPS 或 SSL）发送 cookie。
void | setValue(String newValue) 在创建 cookie 之后将新值分配给 cookie。
void | setVersion(int v) 设置此 cookie 遵守的 cookie 协议版本。
String | toString() 构造此 cookie 的一个 cookie 头字符串表示形式，其格式为对应的 cookie 规范定义的格式，但没有前导 "Cookie:" 标记。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

HttpCookie

public HttpCookie(String name,
                  String value)
构造带有指定名称和值的 cookie。

名称必须遵守 RFC 2965。这意味着它只能包含 ASCII 字母数字字符，不能包含逗号、分号或空格，也不能以 $ 字符开头。cookie 的名称在创建之后不得更改。

该值可以是服务器选择发送的任何值。可能只有该服务器需要其值。cookie 的值在使用 setValue 方法创建后可以更改。

默认情况下，根据 RFC 2965 cookie 规范创建 cookie。可以使用 setVersion 方法更改版本。

参数：
name - 指定 cookie 名称的 String
value - 指定 cookie 值的 String
抛出：
IllegalArgumentException - 如果 cookie 名称包含非法字符，或者它是保留给 cookie 协议使用的标记之一
NullPointerException - 如果 name 为 null
另请参见：
setValue(java.lang.String), setVersion(int)
方法详细信息

parse

public static List<HttpCookie> parse(String header)
根据 set-cookie 或 set-cookie2 头字符串构造 cookie。RFC 2965 第 3.2.2 节 set-cookie2 语法指出，一个头行可以包含多个 cookie 定义，因此这是一个静态实用方法，而不是另一个构造方法。

参数：
header - 指定 set-cookie 头的 String。头应该以 "set-cookie" 或 "set-cookie2" 标记开始；或者它不应有任何前导标记。
返回：
从头行字符串解析的 cookie 列表
抛出：
IllegalArgumentException - 如果头字符串违反 cookie 规范的语法；或者 cookie 名称包含非法字符；或者 cookie 名称是保留给 cookie 协议使用的标记之一
NullPointerException - 如果头字符串为 null

hasExpired

public boolean hasExpired()
报告此 http cookie 是否已过期。

返回：
如果此 http cookie 已过期，则返回 true；否则返回 false

setComment

public void setComment(String purpose)
指定一个描述 cookie 用途的注释。如果浏览器向用户显示 cookie，则注释很有用。Netscape Version 0 cookie 不支持注释。

参数：
purpose - 一个 String，指定要显示给用户的注释
另请参见：
getComment()

getComment

public String getComment()
返回描述此 cookie 用途的注释；如果该 cookie 没有注释，则返回 null。

返回：
包含注释的 String；如果没有注释，则返回 null
另请参见：
setComment(java.lang.String)

setCommentURL

public void setCommentURL(String purpose)
指定一个描述 cookie 用途的注释 URL。如果浏览器向用户显示 cookie，则注释 URL 很有用。只有 RFC 2965 支持注释 URL。

参数：
purpose - 一个 String，指定要显示给用户的注释 URL
另请参见：
getCommentURL()

getCommentURL

public String getCommentURL()
返回描述此 cookie 用途的注释 URL；如果 cookie 没有注释 URL，则返回 null。

返回：
包含注释 URL 的 String；如果没有，则返回 null
另请参见：
setCommentURL(java.lang.String)

setDiscard

public void setDiscard(boolean discard)
指定用户代理是否应该无条件丢弃 cookie。只有 RFC 2965 支持此属性。

参数：
discard - true 表示无条件丢弃 cookie
另请参见：
getDiscard()

getDiscard

public boolean getDiscard()
返回 cookie 的丢弃属性

返回：
表示此 cookie 丢弃属性的 boolean 值。
另请参见：
setDiscard(boolean)

setPortlist

public void setPortlist(String ports)
指定 cookie 的端口列表，该列表在 Cookie 头中限制可能将 cookie 发送回的端口。

参数：
ports - 指定端口列表的 String，它是以逗号分隔的数字序列
另请参见：
getPortlist()

getPortlist

public String getPortlist()
返回 cookie 的端口列表属性

返回：
包含端口列表的 String；如果没有，则返回 null
另请参见：
setPortlist(java.lang.String)

setDomain

public void setDomain(String pattern)
指定应在其中显示此 cookie 的域。

RFC 2965 指定了域名的形式。域名以点 (.foo.com) 开头，意味着在指定域名系统（Domain Name System，DNS）区域中（例如，www.foo.com，但不是 a.b.foo.com）cookie 对于服务器是可见的。默认情况下，cookie 只返回给发送它们的服务器。

参数：
pattern - 包含域名（在其中此 cookie 可见）的 String；域名形式符合 RFC 2965
另请参见：
getDomain()

getDomain

public String getDomain()
返回为此 cookie 设置的域名。域名的形式根据 RFC 2965 设置。

返回：
包含域名的 String
另请参见：
setDomain(java.lang.String)

setMaxAge

public void setMaxAge(long expiry)
设置 cookie 的最大生存时间，以秒为单位。

正值表示 cookie 将在经过该值表示的秒数后过期。注意，该值是 cookie 过期的最大 生存时间，不是 cookie 的当前生存时间。

负值意味着 cookie 不会被持久存储，将在 Web 浏览器退出时删除。0 值会导致删除 cookie。

参数：
expiry - 指定 cookie 最大生存时间的整数，以秒为单位；如果为 0，则应立即丢弃 cookie；否则，cookie 的最大生存时间没有指定。
另请参见：
getMaxAge()

getMaxAge

public long getMaxAge()
返回以秒为单位指定的 cookie 最大生存时间。默认情况下，-1 表示 cookie 将保留到浏览器关闭为止。

返回：
指定 cookie 最大生存时间的整数，以秒为单位
另请参见：
setMaxAge(long)

setPath

public void setPath(String uri)
指定客户机应该返回 cookie 的路径。

cookie 对于指定目录中的所有页面及该目录子目录中的所有页面都是可见的。cookie 的路径必须包括设置 cookie 的 servlet，例如 /catalog，它使 cookie 对于服务器上 /catalog 下的所有目录都是可见的。

有关设置 cookie 路径名称的更多信息，请参考 RFC 2965（可从 Internet 上获得）。

参数：
uri - 指定路径的 String
另请参见：
getPath()

getPath

public String getPath()
返回浏览器将此 cookie 返回到的服务器上的路径。cookie 对于服务器上的所有子路径都是可见的。

返回：
指定包含 servlet 名称的路径的 String，例如 /catalog
另请参见：
setPath(java.lang.String)

setSecure

public void setSecure(boolean flag)
指示浏览器是否只能使用安全协议（如 HTTPS 或 SSL）发送 cookie。

默认值为 false。

参数：
flag - 如果为 true，则仅在使用安全协议时将 cookie 从浏览器发送到使用的服务器；如果为 false，则在任何协议上都可以发送
另请参见：
getSecure()

getSecure

public boolean getSecure()
如果浏览器仅通过安全协议发送 cookie，则返回 true；如果浏览器可以使用任何协议发送 cookie，则返回 false。

返回：
如果浏览器可以使用任何标准协议，则返回 true；否则返回 false
另请参见：
setSecure(boolean)

getName

public String getName()
返回 cookie 的名称。名称在创建之后不得更改。

返回：
指定 cookie 名称的 String

setValue

public void setValue(String newValue)
在创建 cookie 之后将新值分配给 cookie。如果使用二进制值，则可能需要使用 BASE64 编码。

对于 Version 0 cookie，值不应包含空格、方括号、圆括号、等号、逗号、双引号、斜杠、问号、at 符号、冒号和分号。空值在所有浏览器上的行为不一定相同。

参数：
newValue - 指定新值的 String
另请参见：
getValue()

getValue

public String getValue()
返回 cookie 的值。

返回：
包含 cookie 当前值的 String
另请参见：
setValue(java.lang.String)

getVersion

public int getVersion()
返回此 cookie 遵守的协议版本。版本 1 遵守 RFC 2965/2109，版本 0 遵守 Netscape 起草的原始 cookie 规范。浏览器提供的 cookie 使用并标识该浏览器的 cookie 版本。

返回：
如果 cookie 遵守原始 Netscape 规范，则返回 0；如果 cookie 遵守 RFC 2965/2109，则返回 1
另请参见：
setVersion(int)

setVersion

public void setVersion(int v)
设置此 cookie 遵守的 cookie 协议版本。版本 0 遵守原始 Netscape cookie 规范。版本 1 遵守 RFC 2965/2109。

参数：
v - 如果 cookie 应该遵守原始 Netscape 规范，则 v 为 0；如果 cookie 应该遵守 RFC 2965/2109，则 v 为 1
抛出：
IllegalArgumentException - 如果 v 既不为 0，也不为 1
另请参见：
getVersion()

domainMatches

public static boolean domainMatches(String domain,
                                    String host)
检查主机名是否在域中的实用方法。

cookie 规范中描述了这个概念。要理解该概念，首先需要定义一些术语：

有效主机名 = hostname（如果主机名包含圆点）
或者 = hostname.local（如果主机名不包含圆点）

如果符合以下条件，则主机 A 的名称在域上匹配主机 B 的名称：

  • 它们的主机名字符串在字符串上的比较是相同的；或者
  • A 是一个 HDN 字符串，且形式为 NB，其中 N 是一个非空名称字符串，B 的形式为 .B'，B'是一个 HDN 字符串。（因此，x.y.com 在域上匹配 .Y.com，但不匹配 Y.com。）

如果符合以下条件，则主机不在域中（RFC 2965 第 3.3.2 节）：

  • Domain 属性的值不包含嵌入的圆点，且该值不是 .local。
  • 派生于请求主机的有效主机名在域上不匹配 Domain 属性。
  • 请求主机是一个 HDN（而非 IP 地址）且形式为 HD，其中 D 是 Domain 属性的值，H 是包含一个或多个圆点的字符串。

示例：

  • 对于 Domain=.foo.com，来自请求主机 y.x.foo.com 的 Set-Cookie2 将被拒绝，因为 H 是 y.x，包含一个圆点。
  • 对于 Domain=.foo.com，来自请求主机 x.foo.com 的 Set-Cookie2 将被接受。
  • 带有 Domain=.com 或 Domain=.com. 的 Set-Cookie2 将始终被拒绝，因为没有嵌入的圆点。
  • 带有 Domain=ajax.com 的 Set-Cookie2 将被接受，Domain 的值将被赋予 .ajax.com，因为在值前面加了一个圆点。
  • 对于 Domain=.local，来自请求主机示例的 Set-Cookie2 将被接受，因为请求主机的有效主机名是 example.local，example.local 在域上匹配 .local。

参数：
domain - 要用于检查主机名的域名
host - 相关主机名
返回：
如果它们在域上匹配，则返回 true；如果不匹配，则返回 false

toString

public String toString()
构造此 cookie 的一个 cookie 头字符串表示形式，其格式为对应的 cookie 规范定义的格式，但没有前导 "Cookie:" 标记。

覆盖：
类 Object 中的 toString
返回：
cookie 的字符串形式。该字符串具有定义的格式

equals

public boolean equals(Object obj)
测试两个 http cookie 的相等性。

仅当两个 cookie 来自相同域（不区分大小写）、具有相同名称（不区分大小写）并具有相同路径（区分大小写）时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果两个 http cookie 彼此相等，则返回 true；否则，返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 http cookie 的哈希码。结果是此 cookie 以下三个重要部分的哈希码值之和：名称 (name)、域 (domain) 和路径 (path)。也就是说，哈希码就是以下表达式的值：
getName().toLowerCase().hashCode()
+ getDomain().toLowerCase().hashCode()
+ getPath().hashCode()

覆盖：
类 Object 中的 hashCode
返回：
此 http cookie 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

clone

public Object clone()
创建并返回此对象的一个副本。

覆盖：
类 Object 中的 clone
返回：
此 http cookie 的一个副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HttpRetryException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 HttpRetryException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.HttpRetryException
所有已实现的接口：
Serializable
public class HttpRetryException
extends IOException

抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
HttpRetryException(String detail, int code)
根据指定的响应代码和异常详细消息构造新 HttpRetryException。
HttpRetryException(String detail, int code, String location)
构造一个新 HttpRetryException，使其具有详细消息 responseCode 和 Location 响应头字段的内容。
方法摘要
String | getLocation() 如果重定向产生错误，则返回 Location 头字段的值。
String | getReason() 返回解释不能重试 http 请求的原因的字符串。
int | responseCode() 返回 http 响应代码
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HttpRetryException

public HttpRetryException(String detail,
                          int code)
根据指定的响应代码和异常详细消息构造新 HttpRetryException。

参数：
detail - 详细消息。
code - 发自服务器的 HTTP 响应代码。

HttpRetryException

public HttpRetryException(String detail,
                          int code,
                          String location)
构造一个新 HttpRetryException，使其具有详细消息 responseCode 和 Location 响应头字段的内容。

参数：
detail - 详细消息。
code - 发自服务器的 HTTP 响应代码。
location - 作为重定向目标的 URL
方法详细信息

responseCode

public int responseCode()
返回 http 响应代码

返回：
http 响应代码。

getReason

public String getReason()
返回解释不能重试 http 请求的原因的字符串。

返回：
原因字符串

getLocation

public String getLocation()
如果重定向产生错误，则返回 Location 头字段的值。

返回：
位置字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HttpURLConnection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 HttpURLConnection

java.lang.Object
    继承者  java.net.URLConnection
        继承者  java.net.HttpURLConnection
直接已知子类：
HttpsURLConnection
public abstract class HttpURLConnection
extends URLConnection

支持 HTTP 特定功能的 URLConnection。有关详细信息，请参阅 the spec 。

每个 HttpURLConnection 实例都可用于生成单个请求，但是其他实例可以透明地共享连接到 HTTP 服务器的基础网络。请求后在 HttpURLConnection 的 InputStream 或 OutputStream 上调用 close() 方法可以释放与此实例关联的网络资源，但对共享的持久连接没有任何影响。如果在调用 disconnect() 时持久连接空闲，则可能关闭基础套接字。

从以下版本开始：
JDK1.1
另请参见：
disconnect()

字段摘要
protected int | chunkLength 使用存储块编码流模式进行输出时的存储块长度。
protected int | fixedContentLength 使用固定长度流模式时的固定内容长度。
static int | HTTP_ACCEPTED HTTP 状态码 202：Accepted。
static int | HTTP_BAD_GATEWAY HTTP 状态码 502：Bad Gateway。
static int | HTTP_BAD_METHOD HTTP 状态码 405：Method Not Allowed。
static int | HTTP_BAD_REQUEST HTTP 状态码 400：Bad Request。
static int | HTTP_CLIENT_TIMEOUT HTTP 状态码 408：Request Time-Out。
static int | HTTP_CONFLICT HTTP 状态码 409：Conflict。
static int | HTTP_CREATED HTTP 状态码 201：Created。
static int | HTTP_ENTITY_TOO_LARGE HTTP 状态码 413：Request Entity Too Large。
static int | HTTP_FORBIDDEN HTTP 状态码 403：Forbidden。
static int | HTTP_GATEWAY_TIMEOUT HTTP 状态码 504：Gateway Timeout。
static int | HTTP_GONE HTTP 状态码 410：Gone。
static int | HTTP_INTERNAL_ERROR HTTP 状态码 500：Internal Server Error。
static int | HTTP_LENGTH_REQUIRED HTTP 状态码 411：Length Required。
static int | HTTP_MOVED_PERM HTTP 状态码 301：Moved Permanently。
static int | HTTP_MOVED_TEMP HTTP 状态码 302：Temporary Redirect。
static int | HTTP_MULT_CHOICE HTTP 状态码 300：Multiple Choices。
static int | HTTP_NO_CONTENT HTTP 状态码 204：No Content。
static int | HTTP_NOT_ACCEPTABLE HTTP 状态码 406：Not Acceptable。
static int | HTTP_NOT_AUTHORITATIVE HTTP 状态码 203：Non-Authoritative Information。
static int | HTTP_NOT_FOUND HTTP 状态码 404：Not Found。
static int | HTTP_NOT_IMPLEMENTED HTTP 状态码 501：Not Implemented。
static int | HTTP_NOT_MODIFIED HTTP 状态码 304：Not Modified。
static int | HTTP_OK HTTP 状态码 200：OK。
static int | HTTP_PARTIAL HTTP 状态码 206：Partial Content。
static int | HTTP_PAYMENT_REQUIRED HTTP 状态码 402：Payment Required。
static int | HTTP_PRECON_FAILED HTTP 状态码 412：Precondition Failed。
static int | HTTP_PROXY_AUTH HTTP 状态码 407：Proxy Authentication Required。
static int | HTTP_REQ_TOO_LONG HTTP 状态码 414：Request-URI Too Large。
static int | HTTP_RESET HTTP 状态码 205：Reset Content。
static int | HTTP_SEE_OTHER HTTP 状态码 303：See Other。
static int | HTTP_SERVER_ERROR 已过时。 放错了位置，它不应该存在。
static int | HTTP_UNAUTHORIZED HTTP 状态码 401：Unauthorized。
static int | HTTP_UNAVAILABLE HTTP 状态码 503：Service Unavailable。
static int | HTTP_UNSUPPORTED_TYPE HTTP 状态码 415：Unsupported Media Type。
static int | HTTP_USE_PROXY HTTP 状态码 305：Use Proxy。
static int | HTTP_VERSION HTTP 状态码 505：HTTP Version Not Supported。
protected boolean | instanceFollowRedirects 如果为 true，则协议自动执行重定向。
protected String | method HTTP 方法（GET、POST、PUT 等）。
protected int | responseCode 表示三位字数的 HTTP 状态码 (Status-Code) 的 int。
protected String | responseMessage HTTP 响应消息。
从类 java.net.URLConnection 继承的字段
allowUserInteraction, connected, doInput, doOutput, ifModifiedSince, url, useCaches
构造方法摘要
protected HttpURLConnection(URL u)
HttpURLConnection 的构造方法。
方法摘要
abstract void | disconnect() 指示近期服务器不太可能有其他请求。
InputStream | getErrorStream() 如果连接失败但服务器仍然发送了有用数据，则返回错误流。
static boolean | getFollowRedirects() 返回指示是否应该自动执行 HTTP 重定向 (3xx) 的 boolean 值。
String | getHeaderField(int n) 返回 nth 头字段的值。
long | getHeaderFieldDate(String name, long Default) 返回解析为日期的指定字段的值。
String | getHeaderFieldKey(int n) 返回 nth 头字段的键。
boolean | getInstanceFollowRedirects() 返回此 HttpURLConnection 的 instanceFollowRedirects 字段的值。
Permission | getPermission() 返回一个权限对象，其代表建立此对象表示的连接所需的权限。
String | getRequestMethod() 获取请求方法。
int | getResponseCode() 从 HTTP 响应消息获取状态码。
String | getResponseMessage() 获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。
void | setChunkedStreamingMode(int chunklen) 此方法用于在预先不知道内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。
void | setFixedLengthStreamingMode(int contentLength) 此方法用于在预先已知内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。
static void | setFollowRedirects(boolean set) 设置此类是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。
void | setInstanceFollowRedirects(boolean followRedirects) 设置此 HttpURLConnection 实例是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。
void | setRequestMethod(String method) 设置 URL 请求的方法， GET POST HEAD OPTIONS PUT DELETE TRACE 以上方法之一是合法的，具体取决于协议的限制。
abstract boolean | usingProxy() 指示连接是否通过代理。
从类 java.net.URLConnection 继承的方法
addRequestProperty, connect, getAllowUserInteraction, getConnectTimeout, getContent, getContent, getContentEncoding, getContentLength, getContentType, getDate, getDefaultAllowUserInteraction, getDefaultRequestProperty, getDefaultUseCaches, getDoInput, getDoOutput, getExpiration, getFileNameMap, getHeaderField, getHeaderFieldInt, getHeaderFields, getIfModifiedSince, getInputStream, getLastModified, getOutputStream, getReadTimeout, getRequestProperties, getRequestProperty, getURL, getUseCaches, guessContentTypeFromName, guessContentTypeFromStream, setAllowUserInteraction, setConnectTimeout, setContentHandlerFactory, setDefaultAllowUserInteraction, setDefaultRequestProperty, setDefaultUseCaches, setDoInput, setDoOutput, setFileNameMap, setIfModifiedSince, setReadTimeout, setRequestProperty, setUseCaches, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

method

protected String method
HTTP 方法（GET、POST、PUT 等）。

chunkLength

protected int chunkLength
使用存储块编码流模式进行输出时的存储块长度。值 -1 表示对输出禁用存储块编码。

从以下版本开始：
1.5

fixedContentLength

protected int fixedContentLength
使用固定长度流模式时的固定内容长度。值 -1 表示对输出禁用固定长度流模式。

从以下版本开始：
1.5

responseCode

protected int responseCode
表示三位字数的 HTTP 状态码 (Status-Code) 的 int。
  • 1xx:Informational
  • 2xx:Success
  • 3xx:Redirection
  • 4xx:Client Error
  • 5xx:Server Error

responseMessage

protected String responseMessage
HTTP 响应消息。

instanceFollowRedirects

protected boolean instanceFollowRedirects
如果为 true，则协议自动执行重定向。如果为 false，则协议不会自动执行重定向。

此字段由 setInstanceFollowRedirects 方法设置。其值由 getInstanceFollowRedirects 方法返回。

其默认值基于构造 HttpURLConnection 时静态 followRedirects 的值。

另请参见：
setInstanceFollowRedirects(boolean), getInstanceFollowRedirects(), setFollowRedirects(boolean)

HTTP_OK

public static final int HTTP_OK
HTTP 状态码 200：OK。

另请参见：
常量字段值

HTTP_CREATED

public static final int HTTP_CREATED
HTTP 状态码 201：Created。

另请参见：
常量字段值

HTTP_ACCEPTED

public static final int HTTP_ACCEPTED
HTTP 状态码 202：Accepted。

另请参见：
常量字段值

HTTP_NOT_AUTHORITATIVE

public static final int HTTP_NOT_AUTHORITATIVE
HTTP 状态码 203：Non-Authoritative Information。

另请参见：
常量字段值

HTTP_NO_CONTENT

public static final int HTTP_NO_CONTENT
HTTP 状态码 204：No Content。

另请参见：
常量字段值

HTTP_RESET

public static final int HTTP_RESET
HTTP 状态码 205：Reset Content。

另请参见：
常量字段值

HTTP_PARTIAL

public static final int HTTP_PARTIAL
HTTP 状态码 206：Partial Content。

另请参见：
常量字段值

HTTP_MULT_CHOICE

public static final int HTTP_MULT_CHOICE
HTTP 状态码 300：Multiple Choices。

另请参见：
常量字段值

HTTP_MOVED_PERM

public static final int HTTP_MOVED_PERM
HTTP 状态码 301：Moved Permanently。

另请参见：
常量字段值

HTTP_MOVED_TEMP

public static final int HTTP_MOVED_TEMP
HTTP 状态码 302：Temporary Redirect。

另请参见：
常量字段值

HTTP_SEE_OTHER

public static final int HTTP_SEE_OTHER
HTTP 状态码 303：See Other。

另请参见：
常量字段值

HTTP_NOT_MODIFIED

public static final int HTTP_NOT_MODIFIED
HTTP 状态码 304：Not Modified。

另请参见：
常量字段值

HTTP_USE_PROXY

public static final int HTTP_USE_PROXY
HTTP 状态码 305：Use Proxy。

另请参见：
常量字段值

HTTP_BAD_REQUEST

public static final int HTTP_BAD_REQUEST
HTTP 状态码 400：Bad Request。

另请参见：
常量字段值

HTTP_UNAUTHORIZED

public static final int HTTP_UNAUTHORIZED
HTTP 状态码 401：Unauthorized。

另请参见：
常量字段值

HTTP_PAYMENT_REQUIRED

public static final int HTTP_PAYMENT_REQUIRED
HTTP 状态码 402：Payment Required。

另请参见：
常量字段值

HTTP_FORBIDDEN

public static final int HTTP_FORBIDDEN
HTTP 状态码 403：Forbidden。

另请参见：
常量字段值

HTTP_NOT_FOUND

public static final int HTTP_NOT_FOUND
HTTP 状态码 404：Not Found。

另请参见：
常量字段值

HTTP_BAD_METHOD

public static final int HTTP_BAD_METHOD
HTTP 状态码 405：Method Not Allowed。

另请参见：
常量字段值

HTTP_NOT_ACCEPTABLE

public static final int HTTP_NOT_ACCEPTABLE
HTTP 状态码 406：Not Acceptable。

另请参见：
常量字段值

HTTP_PROXY_AUTH

public static final int HTTP_PROXY_AUTH
HTTP 状态码 407：Proxy Authentication Required。

另请参见：
常量字段值

HTTP_CLIENT_TIMEOUT

public static final int HTTP_CLIENT_TIMEOUT
HTTP 状态码 408：Request Time-Out。

另请参见：
常量字段值

HTTP_CONFLICT

public static final int HTTP_CONFLICT
HTTP 状态码 409：Conflict。

另请参见：
常量字段值

HTTP_GONE

public static final int HTTP_GONE
HTTP 状态码 410：Gone。

另请参见：
常量字段值

HTTP_LENGTH_REQUIRED

public static final int HTTP_LENGTH_REQUIRED
HTTP 状态码 411：Length Required。

另请参见：
常量字段值

HTTP_PRECON_FAILED

public static final int HTTP_PRECON_FAILED
HTTP 状态码 412：Precondition Failed。

另请参见：
常量字段值

HTTP_ENTITY_TOO_LARGE

public static final int HTTP_ENTITY_TOO_LARGE
HTTP 状态码 413：Request Entity Too Large。

另请参见：
常量字段值

HTTP_REQ_TOO_LONG

public static final int HTTP_REQ_TOO_LONG
HTTP 状态码 414：Request-URI Too Large。

另请参见：
常量字段值

HTTP_UNSUPPORTED_TYPE

public static final int HTTP_UNSUPPORTED_TYPE
HTTP 状态码 415：Unsupported Media Type。

另请参见：
常量字段值

HTTP_SERVER_ERROR

@Deprecated
public static final int HTTP_SERVER_ERROR
已过时。 放错了位置，它不应该存在。
HTTP 状态码 500：Internal Server Error。

另请参见：
常量字段值

HTTP_INTERNAL_ERROR

public static final int HTTP_INTERNAL_ERROR
HTTP 状态码 500：Internal Server Error。

另请参见：
常量字段值

HTTP_NOT_IMPLEMENTED

public static final int HTTP_NOT_IMPLEMENTED
HTTP 状态码 501：Not Implemented。

另请参见：
常量字段值

HTTP_BAD_GATEWAY

public static final int HTTP_BAD_GATEWAY
HTTP 状态码 502：Bad Gateway。

另请参见：
常量字段值

HTTP_UNAVAILABLE

public static final int HTTP_UNAVAILABLE
HTTP 状态码 503：Service Unavailable。

另请参见：
常量字段值

HTTP_GATEWAY_TIMEOUT

public static final int HTTP_GATEWAY_TIMEOUT
HTTP 状态码 504：Gateway Timeout。

另请参见：
常量字段值

HTTP_VERSION

public static final int HTTP_VERSION
HTTP 状态码 505：HTTP Version Not Supported。

另请参见：
常量字段值
构造方法详细信息

HttpURLConnection

protected HttpURLConnection(URL u)
HttpURLConnection 的构造方法。

参数：
u - URL
方法详细信息

getHeaderFieldKey

public String getHeaderFieldKey(int n)
返回 nth 头字段的键。有些实现可能将 0th 头字段视为特殊状态行，即由 HTTP 服务器返回的状态行。在此情况下，getHeaderField(0) 返回状态行，而 getHeaderFieldKey(0) 返回 null。

覆盖：
类 URLConnection 中的 getHeaderFieldKey
参数：
n - 索引，其中 n >=0。
返回：
nth 头字段的键；如果键不存在，则返回 null。

setFixedLengthStreamingMode

public void setFixedLengthStreamingMode(int contentLength)
此方法用于在预先已知内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。

如果应用程序尝试写入的数据多于指示的内容长度，或者应用程序在写入指示的内容长度前关闭了 OutputStream，将抛出异常。

启用输出流时，不能自动处理验证和重定向。如果需要验证和重定向，则在读取响应时将抛出 HttpRetryException。可以查询此异常以获取错误的详细信息。

该方法必须在连接 URLConnection 前调用。

参数：
contentLength - 将写入 OutputStream 的字节数。
抛出：
IllegalStateException - 如果已连接 URLConnection 或者已启用另外的流模式。
IllegalArgumentException - 如果指定的内容长度小于零。
从以下版本开始：
1.5
另请参见：
setChunkedStreamingMode(int)

setChunkedStreamingMode

public void setChunkedStreamingMode(int chunklen)
此方法用于在预先不知道内容长度时启用没有进行内部缓冲的 HTTP 请求正文的流。在此模式下，使用存储块传输编码发送请求正文。注意，并非所有 HTTP 服务器都支持此模式。

启用输出流时，不能自动处理验证和重定向。如果需要验证和重定向，则在读取响应时将抛出 HttpRetryException。可以查询此异常以获取错误的详细信息。

该方法必须在连接 URLConnection 前调用。

参数：
chunklen - 要写入每个存储块的字节数。如果 chunklen 小于或等于零，则使用默认值。
抛出：
IllegalStateException - 如果已连接 URLConnection 或者已启用其他流模式。
从以下版本开始：
1.5
另请参见：
setFixedLengthStreamingMode(int)

getHeaderField

public String getHeaderField(int n)
返回 nth 头字段的值。有些实现可能将 0th 头字段视为特殊状态行，即由 HTTP 服务器返回的状态行。

此方法可以与 getHeaderFieldKey 方法一起使用来迭代消息中的所有头。

覆盖：
类 URLConnection 中的 getHeaderField
参数：
n - 索引，其中 n>=0。
返回：
nth 头字段的值；如果值不存在，则返回 null。
另请参见：
getHeaderFieldKey(int)

setFollowRedirects

public static void setFollowRedirects(boolean set)
设置此类是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。默认情况下为 true。Applet 不能更改此变量。

如果存在安全管理器，则此方法首先调用安全管理器的 checkSetFactory 方法来确保允许操作。这可能会导致 SecurityException 异常。

参数：
set - 指示是否进行 HTTP 重定向的 boolean 值。
抛出：
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行此操作。
另请参见：
SecurityManager.checkSetFactory(), getFollowRedirects()

getFollowRedirects

public static boolean getFollowRedirects()
返回指示是否应该自动执行 HTTP 重定向 (3xx) 的 boolean 值。

返回：
如果应该自动执行 HTTP 重定向，则返回 true；否则返回 false。
另请参见：
setFollowRedirects(boolean)

setInstanceFollowRedirects

public void setInstanceFollowRedirects(boolean followRedirects)
设置此 HttpURLConnection 实例是否应该自动执行 HTTP 重定向（响应代码为 3xx 的请求）。

默认值来自 followRedirects，其默认情况下为 true。

参数：
followRedirects - 指示是否执行 HTTP 重定向的 boolean 值。
从以下版本开始：
1.3
另请参见：
instanceFollowRedirects, getInstanceFollowRedirects()

getInstanceFollowRedirects

public boolean getInstanceFollowRedirects()
返回此 HttpURLConnection 的 instanceFollowRedirects 字段的值。

返回：
此 HttpURLConnection 的 instanceFollowRedirects 字段的值。
从以下版本开始：
1.3
另请参见：
instanceFollowRedirects, setInstanceFollowRedirects(boolean)

setRequestMethod

public void setRequestMethod(String method)
                      throws ProtocolException
设置 URL 请求的方法，
  • GET
  • POST
  • HEAD
  • OPTIONS
  • PUT
  • DELETE
  • TRACE
以上方法之一是合法的，具体取决于协议的限制。默认方法为 GET。

参数：
method - HTTP 方法
抛出：
ProtocolException - 如果无法重置方法或者请求的方法对 HTTP 无效。
另请参见：
getRequestMethod()

getRequestMethod

public String getRequestMethod()
获取请求方法。

返回：
HTTP 请求方法
另请参见：
setRequestMethod(java.lang.String)

getResponseCode

public int getResponseCode()
                    throws IOException
从 HTTP 响应消息获取状态码。例如，就以下状态行来说：
 HTTP/1.0 200 OK
 HTTP/1.0 401 Unauthorized
将分别返回 200 和 401。如果无法从响应中识别任何代码（即响应不是有效的 HTTP），则返回 -1。

返回：
HTTP 状态码或 -1
抛出：
IOException - 如果连接到服务器时发生错误。

getResponseMessage

public String getResponseMessage()
                          throws IOException
获取与来自服务器的响应代码一起返回的 HTTP 响应消息（如果有）。对于如下响应：
 HTTP/1.0 200 OK
 HTTP/1.0 404 Not Found
分别提取 String "OK" 和 "Not Found"。如果无法从响应识别任何字符（结果不是有效的 HTTP），则返回 null。

返回：
HTTP 响应消息或 null
抛出：
IOException - 如果连接到服务器时发生错误。

getHeaderFieldDate

public long getHeaderFieldDate(String name,
                               long Default)
从类 URLConnection 复制的描述
返回解析为日期的指定字段的值。结果为指定字段表示的距离格林威治标准时间 1970 年 1 月 1 日的毫秒数。

有些连接类型（例如 http-ng）具有预解析头，所以存在这种形式的 getHeaderField。用于该类型的连接可重写此方法和缩短解析过程。

覆盖：
类 URLConnection 中的 getHeaderFieldDate
参数：
name - 头字段的名称。
Default - 默认值。
返回：
字段的值，解析为日期。如果该字段缺少或有错误，则返回 Default 参数的值。

disconnect

public abstract void disconnect()
指示近期服务器不太可能有其他请求。调用 disconnect() 并不意味着可以对其他请求重用此 HttpURLConnection 实例。

usingProxy

public abstract boolean usingProxy()
指示连接是否通过代理。

返回：
指示连接是否使用代理的 boolean 值。

getPermission

public Permission getPermission()
                         throws IOException
从类 URLConnection 复制的描述
返回一个权限对象，其代表建立此对象表示的连接所需的权限。如果建立连接不需要任何权限，则此方法返回 null。默认情况下，此方法返回 java.security.AllPermission。子类应重写此方法并返回一个权限对象，该对象最能代表用于建立到 URL 的连接所需的权限。例如表示 file:URL 的 URLConnection 将返回 java.io.FilePermission 对象。

返回的权限可能取决于连接的状态。例如，连接之前的权限可能不同于连接之后的权限。例如，一个 HTTP 服务器（如 foo.com）可能将连接重定向到一台不同的主机（如 bar.com）。在连接之前，连接返回的权限将代表连接到 foo.com 所需的权限，而连接之后返回的权限将是连接到 bar.com 所需的权限。

使用权限通常有两个目的：保护通过 URLConnection 获取的对象的缓存；检查接收方的权限以了解特定的 URL。第一种情况下，应在获取对象之后 再获取权限。例如，在一个 HTTP 连接中，这将代表连接到最终将从该主机获取数据的主机的权限。第二种情况下，应在连接之前 对权限进行获取和检查。

覆盖：
类 URLConnection 中的 getPermission
返回：
代表建立此 URLConnection 表示的连接所需的权限的权限对象。
抛出：
IOException - 如果计算权限需要网络或文件 I/O 并且在计算过程中出现异常。

getErrorStream

public InputStream getErrorStream()
如果连接失败但服务器仍然发送了有用数据，则返回错误流。典型示例是，当 HTTP 服务器使用 404 响应时，将导致在连接中抛出 FileNotFoundException，但是服务器同时还会发送建议如何操作的 HTML 帮助页。

此方法不会导致启用连接。如果没有建立连接，或者在连接时服务器没有发生错误，或服务器出错但没有发送错误数据，则此方法返回 null。这是默认设置。

返回：
错误流（如果存在）；如果没有发生错误、没有建立连接或服务器没有发送有用数据，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IDN (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 IDN

java.lang.Object
    继承者  java.net.IDN

public final class IDN
extends Object

提供在普通 Unicode 表示形式和 ASCII 兼容性编码 (ACE) 表示形式之间进行国际化域名 (IDN) 转换的方法。国际化域名可以使用整个 Unicode 范围内的字符，而传统域名只限于 ASCII 字符。ACE 是只使用 ASCII 字符的 Unicode 字符串编码方式，能够与只识别传统域名的软件（如 Domain Name System）一起使用。

国际化域名在 RFC 3490 中定义。RFC 3490 定义了两种操作：ToASCII 和 ToUnicode。这两种操作使用 Nameprep 算法（Stringprep 的配置文件）和 Punycode 算法来回地转换域名字符串。

上述转换处理的行为可以用各种标志进行调整：

  • 如果使用 ALLOW_UNASSIGNED 标志，则要转换的域名字符串可以包含 Unicode 3.2（IDN 转换所依据的 Unicode 版本）中未分配的代码点。如果未使用该标志，那么存在这种未分配的代码点将被视为一个错误。
  • 如果使用 USE_STD3_ASCII_RULES 标志，则根据 RFC 1122 和 RFC 1123 检查 ASCII 字符串。如果它们不符合要求，则是一个错误。
这些标志在逻辑上可以“或”运算为一个整体。

有关国际化域名支持的安全考虑至关重要。例如，英文域名可能被拼写成同形异义词，即故意用非 Latin 字母替代而错拼的词。Unicode Technical Report #36 讨论了 IDN 支持的安全问题以及可能的解决方案。在使用国际域名时应用程序负责采取足够的安全措施。

从以下版本开始：
1.6

字段摘要
static int | ALLOW_UNASSIGNED 允许处理未分配代码点的标志。
static int | USE_STD3_ASCII_RULES 根据 STD-3 ASCII 规则执行检查的标志。
方法摘要
static String | toASCII(String input) 根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。
static String | toASCII(String input, int flag) 根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。
static String | toUnicode(String input) 根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。
static String | toUnicode(String input, int flag) 根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ALLOW_UNASSIGNED

public static final int ALLOW_UNASSIGNED
允许处理未分配代码点的标志。

另请参见：
常量字段值

USE_STD3_ASCII_RULES

public static final int USE_STD3_ASCII_RULES
根据 STD-3 ASCII 规则执行检查的标志。

另请参见：
常量字段值
方法详细信息

toASCII

public static String toASCII(String input,
                             int flag)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

ToASCII 操作可能失败。如果其任何步骤失败，则 ToASCII 失败。如果 ToASCII 操作失败，则抛出 IllegalArgumentException。在这种情况下，输入字符串不应在国际化域名中使用。

标签是域名的单独部分。根据 RFC 3490 中的定义，初始 ToASCII 操作只在单个标签上运行。通过假定域名中的标签始终用点分隔，此方法可以处理标签和整个域名。以下字符被识别为点：\u002E（句点）、\u3002（表意句点）、\uFF0E（全角句点）和 \uFF61（半角表意句点）。如果点被用作标签分隔符，则此方法在输出转换字符串中将它们全部更改为 \u002E（句点）。

参数：
input - 要处理的字符串
flag - 处理标志；可以为 0 或任何可能标志的逻辑或
返回：
已转换的 String
抛出：
IllegalArgumentException - 如果输入字符串未遵守 RFC 3490 规范

toASCII

public static String toASCII(String input)
根据 RFC 3490 的 ToASCII 操作中的定义，将字符串从 Unicode 转换为 ASCII 兼容性编码 (ACE)。

此便捷方法的工作方式类似于调用带两个参数的对应方法，如下所示：

toASCII(input, 0);

参数：
input - 要处理的字符串
返回：
已转换的 String
抛出：
IllegalArgumentException - 如果输入字符串未遵守 RFC 3490 规范

toUnicode

public static String toUnicode(String input,
                               int flag)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 (ACE) 转换为 Unicode。

ToUnicode 永远不会失败。出现任何错误时，返回的输入字符串保持不变。

标签是域名的单独部分。根据 RFC 3490 中的定义，初始 ToUnicode 操作只在单个标签上运行。通过假定域名中的标签始终用点分隔，此方法可以处理标签和整个域名。以下字符被识别为点：\u002E（句点）、\u3002（表意句点）、\uFF0E（全角句点）和 \uFF61（半角表意句点）。

参数：
input - 要处理的字符串
flag - 处理标志；可以为 0 或任何可能标志的逻辑或
返回：
已转换的 String

toUnicode

public static String toUnicode(String input)
根据 RFC 3490 的 ToUnicode 操作中的定义，将字符串从 ASCII 兼容性编码 ACE) 转换为 Unicode。

此便捷方法的工作方式类似于调用带两个参数的对应方法，如下所示：

toUnicode(input, 0);

参数：
input - 要处理的字符串
返回：
已转换的 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Inet4Address (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 Inet4Address

java.lang.Object
    继承者  java.net.InetAddress
        继承者  java.net.Inet4Address
所有已实现的接口：
Serializable
public final class Inet4Address
extends InetAddress

此类表示 Internet Protocol version 4 (IPv4) 地址。此类是由 RFC 790:Assigned Numbers、RFC 1918:Address Allocation for Private Internets 和 RFC 2365:Administratively Scoped IP Multicast 定义的。

IP 地址的文本表示形式

用作方法输入的 IPv4 地址的文本表示形式采取以下形式之一：
d.d.d.d
d.d.d
d.d
d

当指定四个部分时，将每个部分解释为一个数据字节，并从左到右分配给 IPv4 地址的四个字节。

当指定三部分地址时，将最后一个部分解释为 16 位量，并放置在网络地址的最右边两个字节。这使得三部分地址格式便于将 Class B 网络地址指定为 128.net.host。

当提供两部分地址时，将最后一个部分解释为 24 位量，并放置在网络地址的最右边三个字节。这使得两部分地址格式便于将 Class A 网络地址指定为 net.host。

当仅给出一个部分时，值被直接存储在网络地址中，无需进行字节重排。

对于将文本表示形式作为输出值返回的方法而言，使用第一种形式，即使用以点分隔的四个字符串。

多播地址的范围

在历史上，IP 头中的 IPv4 生存时间 (Time To Live, TTL) 字段已作为多播范围字段增大了一倍：TTL 为 0 表示节点本地 (node-local)，1 表示链接本地 (link-local)，32 表示站点本地 (site-local)，64 表示地区本地 (region-local)，128 表示大陆本地 (continent-local)，255 表示全球。但是，首选范围是行政管理范围 (administrative scoping）。请参阅 RFC 2365:Administratively Scoped IP Multicast

从以下版本开始：
1.4
另请参见：
序列化表格

方法摘要
boolean | equals(Object obj) 将此对象与指定对象比较。
byte[] | getAddress() 返回此 InetAddress 对象的原始 IP 地址。
String | getHostAddress() 返回 IP 地址字符串（以文本表现形式）。
int | hashCode() 返回此 IP 地址的哈希码。
boolean | isAnyLocalAddress() 检查 InetAddress 是否是通配符地址的实用例行程序。
boolean | isLinkLocalAddress() 检查 InetAddress 是否是链接本地地址的实用例行程序。
boolean | isLoopbackAddress() 检查 InetAddress 是否是回送地址的实用例行程序。
boolean | isMCGlobal() 检查多播地址是否具有全局范围的实用例行程序。
boolean | isMCLinkLocal() 检查多播地址是否具有链接范围的实用例行程序。
boolean | isMCNodeLocal() 检查多播地址是否具有节点范围的实用例行程序。
boolean | isMCOrgLocal() 检查多播地址是否具有组织范围的实用例程。
boolean | isMCSiteLocal() 检查多播地址是否具有站点范围的实用例行程序。
boolean | isMulticastAddress() 检查 InetAddress 是否是 IP 多播地址的实用例行程序。
boolean | isSiteLocalAddress() 检查 InetAddress 是否是站点本地地址的实用例行程序。
从类 java.net.InetAddress 继承的方法
getAllByName, getByAddress, getByAddress, getByName, getCanonicalHostName, getHostName, getLocalHost, isReachable, isReachable, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

isMulticastAddress

public boolean isMulticastAddress()
检查 InetAddress 是否是 IP 多播地址的实用例行程序。IP 多播地址是 Class D 地址，也就是说，第一个四位地址为 1110。

覆盖：
类 InetAddress 中的 isMulticastAddress
返回：
指示 InetAddress 是否是 IP 多播地址的 boolean 值
从以下版本开始：
JDK1.1

isAnyLocalAddress

public boolean isAnyLocalAddress()
检查 InetAddress 是否是通配符地址的实用例行程序。

覆盖：
类 InetAddress 中的 isAnyLocalAddress
返回：
指示 Inetaddress 是否是通配符地址的 boolean 值
从以下版本开始：
1.4

isLoopbackAddress

public boolean isLoopbackAddress()
从类 InetAddress 复制的描述
检查 InetAddress 是否是回送地址的实用例行程序。

覆盖：
类 InetAddress 中的 isLoopbackAddress
返回：
指示 InetAddress 是否是回送地址的 boolean 值；否则返回 false。

isLinkLocalAddress

public boolean isLinkLocalAddress()
检查 InetAddress 是否是链接本地地址的实用例行程序。

覆盖：
类 InetAddress 中的 isLinkLocalAddress
返回：
指示 InetAddress 是否是本地链接地址的 boolean 值；如果地址不是链接本地单播地址，则返回 false。
从以下版本开始：
1.4

isSiteLocalAddress

public boolean isSiteLocalAddress()
检查 InetAddress 是否是站点本地地址的实用例行程序。

覆盖：
类 InetAddress 中的 isSiteLocalAddress
返回：
指示 InetAddress 是否是站点本地地址的 boolean 值；如果地址不是站点本地单播地址，则返回 false。
从以下版本开始：
1.4

isMCGlobal

public boolean isMCGlobal()
检查多播地址是否具有全局范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCGlobal
返回：
指示地址是否是全局范围多播地址的 boolean 值；如果它不是全局范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCNodeLocal

public boolean isMCNodeLocal()
检查多播地址是否具有节点范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCNodeLocal
返回：
指示地址是否是节点本地范围多播地址的 boolean 值；如果它不是节点本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCLinkLocal

public boolean isMCLinkLocal()
检查多播地址是否具有链接范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCLinkLocal
返回：
指示地址是否是链接本地范围多播地址的 boolean 值；如果它不是链接本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCSiteLocal

public boolean isMCSiteLocal()
检查多播地址是否具有站点范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCSiteLocal
返回：
指示地址是否是站点本地范围多播地址的 boolean；如果它不是站点本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCOrgLocal

public boolean isMCOrgLocal()
检查多播地址是否具有组织范围的实用例程。

覆盖：
类 InetAddress 中的 isMCOrgLocal
返回：
指示地址是否是组织本地范围多播地址的 boolean；如果它不是组织本地范围或多播地址，则返回 false
从以下版本开始：
1.4

getAddress

public byte[] getAddress()
返回此 InetAddress 对象的原始 IP 地址。结果按网络字节顺序：地址的高位字节位于 getAddress()[0] 中。

覆盖：
类 InetAddress 中的 getAddress
返回：
此对象的原始 IP 地址。

getHostAddress

public String getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

覆盖：
类 InetAddress 中的 getHostAddress
返回：
字符串格式的原始 IP 地址。
从以下版本开始：
JDK1.0.2

hashCode

public int hashCode()
返回此 IP 地址的哈希码。

覆盖：
类 InetAddress 中的 hashCode
返回：
此 IP 地址的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，并且它表示与此对象相同的 IP 地址时，结果才为 true。

如果 getAddress 对两个 InetAddress 返回的 byte 数组长度相同并且 byte 数组的每个数组元素也都相同，则这两个 InetAddress 的实例表示相同的 IP 地址。

覆盖：
类 InetAddress 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
InetAddress.getAddress()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Inet6Address (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 Inet6Address

java.lang.Object
    继承者  java.net.InetAddress
        继承者  java.net.Inet6Address
所有已实现的接口：
Serializable
public final class Inet6Address
extends InetAddress

此类表示互联网协议第 6 版 (IPv6) 地址。此类由 RFC 2373:IP Version 6 Addressing Architecture 定义。

IP 地址的文本表示形式

用作方法输入的 IPv6 地址的文本表示形式采取以下形式之一：

  1. 首选形式为 x:x:x:x:x:x:x:x，其中这些 'x' 是八个 16 位地址段的十六进制值。这是完整形式。例如，

    1080:0:0:0:8:800:200C:417A

    注意，在个别字段中不必写出前导零。但是，在每个字段中至少必须存在一个数字，以下描述的情况除外。

  2. 由于某些分配确定的 IPv6 地址样式的方法，地址经常包含零位的长字符串。为了更方便地写入包含零位的地址，可以使用特殊语法压缩这些零位。使用 "::"指示多个零的 16 位组。"::"只能在地址中出现一次。"::" 还可用于压缩地址中的前导和/或尾部零。例如，

    1080::8:800:200C:417A

  3. 处理 IPv4 和 IPv6 节点的混合环境时，有一种有时更为方便的替换形式是 x:x:x:x:x:x:d.d.d.d ，其中 'x' 为六个高位 16 位地址段的十六进制值，'d' 为四个低位 8 位标准 IPv4 表示形式地址段的十进制值，例如，

    ::FFFF:129.144.52.38
    ::129.144.52.38

    其中，"::FFFF:d.d.d.d" 和 "::d.d.d.d" 分别为映射 IPv4 的 IPv6 地址 (IPv4-mapped IPv6 address) 和与 IPv4 兼容的 IPv6 地址 (IPv4-compatible IPv6 address) 的一般形式。注意，IPv4 部分必须为 "d.d.d.d" 形式。以下形式是无效的：

    ::FFFF:d.d.d
    ::FFFF:d.d
    ::d.d.d
    ::d.d

    以下形式：

    ::FFFF:d

    有效，不过它是与 IPv4 兼容的 IPv6 地址的非传统表示形式：

    ::255.255.0.d

    在 "::d" 对应于一般 IPv6 地址 "0:0:0:0:0:0:0:d" 时。

对于以输出值形式返回文本表示形式作的方法，使用完整形式。Inet6Address 将返回完整形式，因为在与其他文本数据组合时它是明确的。

特殊 IPv6 地址

映射 IPv4 的地址 其形式为 ::ffff:w.x.y.z，此 IPv6 地址用于表示 IPv4 地址。与 IPv4 和 IPv6 节点通信时，它允许本机程序使用相同的地址数据结构和相同的套接字。

在 InetAddress 和 Inet6Address 中，它用于内部表示形式；没有任何功能职责。Java 永远不返回映射 IPv4 的地址。这些类可以使用映射 IPv4 的地址，作为 byte 数组和文本表示形式的输入。但是，它将被转换为 IPv4 地址。

IPv6 范围地址的文本表示形式

可以扩展上述 IPv6 地址的文本表示形式来指定 IPv6 范围的地址。在 [draft-ietf-ipngwg-scoping-arch-04.txt] 中描述了这种对基本地址体系结构的扩展。

因为链接本地和站点本地地址都是非全球的，所以不同的主机可能具有相同的目标地址并且可能通过相同始发系统上的不同接口到达。在此情况下，视为将始发系统连接到同一范围的多个时区。为了确定哪一个才是真正意义上的目标时区，可以将时区标识符（或 scope_id）添加到 IPv6 地址上。

指定 scope_id 的一般格式如下所示：

IPv6-address%scope_id

IPv6 地址就是上述字面值 IPv6 地址。scope_id 指的是本地系统上的接口，它可以使用两种方式指定。

  1. 作为数字标识符。 它必须是一个系统理解的指定特定接口和范围的正整数。通常，可以通过系统上的管理工具确定这些数字值。每个接口可能具有多个值，每个范围一个。如果没有指定范围，则使用的默认值为零。

  2. 作为字符串。 它必须是相关特定接口的 NetworkInterface.getName() 所返回的确切字符串。如果以此方式创建 Inet6Address，则数字 scope-id 在创建该对象时通过查询相关 NetworkInterface 来确定。

另外注意，可以从 NetworkInterface 类返回的 Inet6Address 实例获取数字 scope_id。这一点可用于找出在系统上配置的当前范围 id。

从以下版本开始：
1.4
另请参见：
序列化表格

方法摘要
 boolean equals(Object obj)
将此对象与指定对象比较。
 byte[] getAddress()
返回此 InetAddress 对象的原始 IP 地址。
static Inet6Address getByAddress(String host, byte[] addr, int scope_id)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。
static Inet6Address getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。
 String getHostAddress()
返回 IP 地址字符串（以文本表现形式）。
 NetworkInterface getScopedInterface()
如果此实例是使用范围接口创建的，则返回范围接口。
 int getScopeId()
如果此实例与接口关联，则返回数字 scoped_id。
 int hashCode()
返回此 IP 地址的哈希码。
 boolean isAnyLocalAddress()
检查 InetAddress 是否是通配符地址的实用例行程序。
 boolean isIPv4CompatibleAddress()
检查 InetAddress 是否是与 IPv4 兼容的 IPv6 地址的实用例行程序。
 boolean isLinkLocalAddress()
检查 InetAddress 是否是链接本地地址的实用例行程序。
 boolean isLoopbackAddress()
检查 InetAddress 是否是回送地址中的实用例行程序。
 boolean isMCGlobal()
检查多播地址是否具有全球范围的实用例行程序。
 boolean isMCLinkLocal()
检查多播地址是否具有链接范围的实用例行程序。
 boolean isMCNodeLocal()
检查多播地址是否具有节点范围的实用例行程序。
 boolean isMCOrgLocal()
检查多播地址是否具有组织范围的实用例行程序。
 boolean isMCSiteLocal()
检查多播地址是否具有站点范围的实用例行程序。
 boolean isMulticastAddress()
检查 InetAddress 是否 IP 多播地址的实用例行程序。
 boolean isSiteLocalAddress()
检查 InetAddress 是否是站点本地地址的实用例行程序。
从类 java.net.InetAddress 继承的方法
getAllByName, getByAddress, getByAddress, getByName, getCanonicalHostName, getHostName, getLocalHost, isReachable, isReachable, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getByAddress

public static Inet6Address getByAddress(String host,
                                        byte[] addr,
                                        NetworkInterface nif)
                                 throws UnknownHostException
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。如果给定接口不具有为给定地址类型（例如，链接本地或站点本地）分配的数字 scope_id，则调用将失败并抛出 UnknownHostException。有关 IPv6 范围地址的描述，请参见这里。

参数：
host - 指定主机
addr - 网络字节顺序的原始 IP 地址
nif - 必须与此地址关联的接口。
返回：
根据原始 IP 地址创建的 Inet6Address 对象。
抛出：
UnknownHostException - 如果 IP 地址的长度非法或者接口不具有为给定地址类型分配的数字 scope_id。
从以下版本开始：
1.5

getByAddress

public static Inet6Address getByAddress(String host,
                                        byte[] addr,
                                        int scope_id)
                                 throws UnknownHostException
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。不会检查 scope_id 以确定其是否与系统上的任何接口相对应。有关 IPv6 范围地址的描述，请参见这里。

参数：
host - 指定主机
addr - 网络字节顺序的原始 IP 地址
scope_id - 地址的数字 scope_id。
返回：
根据原始 IP 地址创建的 Inet6Address 对象。
抛出：
UnknownHostException - 如果 IP 地址的长度非法。
从以下版本开始：
1.5

isMulticastAddress

public boolean isMulticastAddress()
检查 InetAddress 是否 IP 多播地址的实用例行程序。地址开头的 11111111 标识着该地址是一个多播地址。

覆盖：
类 InetAddress 中的 isMulticastAddress
返回：
指示 InetAddress 是否是 IP 多播地址的 boolean 值
从以下版本开始：
JDK1.1

isAnyLocalAddress

public boolean isAnyLocalAddress()
检查 InetAddress 是否是通配符地址的实用例行程序。

覆盖：
类 InetAddress 中的 isAnyLocalAddress
返回：
指示 Inetaddress 是否是通配符地址的 boolean 值
从以下版本开始：
1.4

isLoopbackAddress

public boolean isLoopbackAddress()
检查 InetAddress 是否是回送地址中的实用例行程序。

覆盖：
类 InetAddress 中的 isLoopbackAddress
返回：
指示 InetAddress 是否是回送地址的 boolean 值；否则返回 false。
从以下版本开始：
1.4

isLinkLocalAddress

public boolean isLinkLocalAddress()
检查 InetAddress 是否是链接本地地址的实用例行程序。

覆盖：
类 InetAddress 中的 isLinkLocalAddress
返回：
指示 InetAddress 是否是本地链接地址的 boolean 值；如果地址不是链接本地单播地址，则返回 false。
从以下版本开始：
1.4

isSiteLocalAddress

public boolean isSiteLocalAddress()
检查 InetAddress 是否是站点本地地址的实用例行程序。

覆盖：
类 InetAddress 中的 isSiteLocalAddress
返回：
指示 InetAddress 是否是站点本地地址的 boolean 值；如果地址不是站点本地单播地址，则返回 false。
从以下版本开始：
1.4

isMCGlobal

public boolean isMCGlobal()
检查多播地址是否具有全球范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCGlobal
返回：
指示地址是否是全球范围多播地址的 boolean 值；如果它不是全球范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCNodeLocal

public boolean isMCNodeLocal()
检查多播地址是否具有节点范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCNodeLocal
返回：
指示地址是否是节点本地范围多播地址的 boolean 值；如果它不是节点本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCLinkLocal

public boolean isMCLinkLocal()
检查多播地址是否具有链接范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCLinkLocal
返回：
指示地址是否是链接本地范围多播地址的 boolean 值；如果它不是链接本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCSiteLocal

public boolean isMCSiteLocal()
检查多播地址是否具有站点范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCSiteLocal
返回：
指示地址是否是站点本地范围多播地址的 boolean 值；如果它不是站点本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCOrgLocal

public boolean isMCOrgLocal()
检查多播地址是否具有组织范围的实用例行程序。

覆盖：
类 InetAddress 中的 isMCOrgLocal
返回：
指示地址是否是组织本地范围多播地址的 boolean 值；如果它不是组织本地范围或多播地址，则返回 false
从以下版本开始：
1.4

getAddress

public byte[] getAddress()
返回此 InetAddress 对象的原始 IP 地址。结果按网络字节顺序：地址的高位字节位于 getAddress()[0] 中。

覆盖：
类 InetAddress 中的 getAddress
返回：
此对象的原始 IP 地址。

getScopeId

public int getScopeId()
如果此实例与接口关联，则返回数字 scoped_id。如果没有设置任何 scoped_id，则返回值为零。

返回：
scopeId；如果没有设置，则返回零。
从以下版本开始：
1.5

getScopedInterface

public NetworkInterface getScopedInterface()
如果此实例是使用范围接口创建的，则返回范围接口。

返回：
范围接口；如果没有设置，则返回 null。
从以下版本开始：
1.5

getHostAddress

public String getHostAddress()
返回 IP 地址字符串（以文本表现形式）。如果创建的实例指定了范围标识符，则将一个前带 "%"（百分比）符号的范围 id 添加到 IP 地址上。它可以是数字值，也可以是字符串，具体取决于创建实例使用的是哪一种。

覆盖：
类 InetAddress 中的 getHostAddress
返回：
字符串格式的原始 IP 地址。

hashCode

public int hashCode()
返回此 IP 地址的哈希码。

覆盖：
类 InetAddress 中的 hashCode
返回：
此 IP 地址的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，并且它表示与此对象相同的 IP 地址时，结果才为 true。

如果 getAddress 对两个 InetAddress 返回的 byte 数组长度相同并且 byte 数组的每个数组元素也都相同，则这两个 InetAddress 的实例表示相同的 IP 地址。

覆盖：
类 InetAddress 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
InetAddress.getAddress()

isIPv4CompatibleAddress

public boolean isIPv4CompatibleAddress()
检查 InetAddress 是否是与 IPv4 兼容的 IPv6 地址的实用例行程序。

返回：
指示 InetAddress 是否是与 IPv4 兼容的 IPv6 地址的 boolean 值；如果地址为 IPv4 地址，则返回 false。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InetAddress (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 InetAddress

java.lang.Object
    继承者  java.net.InetAddress
所有已实现的接口：
Serializable
直接已知子类：
Inet4Address, Inet6Address
public class InetAddress
extends Object
implements Serializable

此类表示互联网协议 (IP) 地址。

IP 地址是 IP 使用的 32 位或 128 位无符号数字，它是一种低级协议，UDP 和 TCP 协议都是在它的基础上构建的。IP 地址的体系结构是由 RFC 790:Assigned Numbers、 RFC 1918:Address Allocation for Private Internets、RFC 2365:Administratively Scoped IP Multicast 和 RFC 2373:IP Version 6 Addressing Architecture 定义的。InetAddress 的实例包含 IP 地址，还可能包含相应的主机名（取决于它是否用主机名构造或者是否已执行反向主机名解析）。

地址类型

单播 单个接口的标识符。发送到单播地址的数据包被交付给由该地址标识的接口。

多播地址：也称为 anylocal 地址或通配符地址。一定不能将其分配给任何节点。它指示缺少地址。它的一个使用示例是可以作为绑定的目标，这允许服务器在服务器主机有多个接口的情况下接收任何接口上的客户端连接。

未指定 地址一定不能用作 IP 数据包的目标地址。

回送 地址：它是分配给回送接口的地址。发送到此 IP 地址的任何内容都将返回并作为本地主机上的 IP 输入。此地址常常在测试客户机时使用。

多播 一组接口（通常属于不同的节点）的标识符。发送到多播地址的数据包被交付给由该地址标识的所有接口。

IP 地址范围

链接本地 地址设计用于在单个链接上寻址以解决诸如自动地址配置、邻居发现 (neighbor discovery) 或没有路由器时的问题。

站点本地 地址设计用于在不需要全局前缀时站点内部寻址。

全局 地址在 Internet 中是唯一的。

IP 地址的文本表示形式

IP 地址的文本表示形式是特定于地址系列的。

有关 IPv4 地址格式，请参阅 Inet4Address#format，有关 IPv6 地址格式，请参阅 Inet6Address#format。

主机名解析

主机名到 IP 地址的解析 通过使用本地机器配置信息和网络命名服务（如域名系统（Domain Name System，DNS）和网络信息服务（Network Information Service，NIS））来实现。要使用的特定命名服务默认情况下是本地机器配置的那个。对于任何主机名称，都返回其相应的 IP 地址。

反向名称解析 意味着对于任何 IP 地址，都返回与 IP 地址关联的主机。

InetAddress 类提供将主机名解析为其 IP 地址（或反之）的方法。

InetAddress 缓存

InetAddress 类具有一个缓存，用于存储成功及不成功的主机名解析。

默认情况下，当为了防止 DNS 哄骗攻击安装了安全管理器时，正主机名解析的结果会永远缓存。当未安装安全管理器时，默认行为将缓存一段有限（与实现相关）时间的条目。不成功主机名解析的结果缓存非常短的时间（10 秒）以提高性能。

如果不需要默认行为，则可以将 Java 安全属性设置为另外的 Time-to-live (TTL) 值来进行正缓存。类似地，系统管理员在需要时可以配置另外的负缓存 TTL 值。

两个 Java 安全属性控制着用于正负主机名解析缓存的 TTL 值：

networkaddress.cache.ttl
指示从名称服务进行成功名称查找的缓存策略。该值被指定为整数，指示缓存成功查找的秒数。默认设置将在某个特定于实现的时间内缓存。

值 -1 指示“永远缓存”。

networkaddress.cache.negative.ttl（默认值：10）
指示从名称服务进行不成功名称查找的缓存策略。该值被指定为整数，指示缓存不成功查找故障的秒数。

值 0 指示“永远不缓存”。值 -1 指示“永远缓存”。

从以下版本开始：
JDK1.0
另请参见：
getByAddress(byte[]),
getByAddress(java.lang.String, byte[]),
getAllByName(java.lang.String),
getByName(java.lang.String),
getLocalHost(),
序列化表格

方法摘要
boolean | equals(Object obj) 将此对象与指定对象比较。
byte[] | getAddress() 返回此 InetAddress 对象的原始 IP 地址。
static InetAddress[] | getAllByName(String host) 在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。
static InetAddress | getByAddress(byte[] addr) 在给定原始 IP 地址的情况下，返回 InetAddress 对象。
static InetAddress | getByAddress(String host, byte[] addr) 根据提供的主机名和 IP 地址创建 InetAddress。
static InetAddress | getByName(String host) 在给定主机名的情况下确定主机的 IP 地址。
String | getCanonicalHostName() 获取此 IP 地址的完全限定域名。
String | getHostAddress() 返回 IP 地址字符串（以文本表现形式）。
String | getHostName() 获取此 IP 地址的主机名。
static InetAddress | getLocalHost() 返回本地主机。
int | hashCode() 返回此 IP 地址的哈希码。
boolean | isAnyLocalAddress() 检查 InetAddress 是否是通配符地址的实用例行程序。
boolean | isLinkLocalAddress() 检查 InetAddress 是否是链接本地地址的实用例行程序。
boolean | isLoopbackAddress() 检查 InetAddress 是否是回送地址的实用例行程序。
boolean | isMCGlobal() 检查多播地址是否具有全局域的实用例行程序。
boolean | isMCLinkLocal() 检查多播地址是否具有链接范围的实用例行程序。
boolean | isMCNodeLocal() 检查多播地址是否具有节点范围的实用例行程序。
boolean | isMCOrgLocal() 检查多播地址是否具有组织范围的实用例行程序。
boolean | isMCSiteLocal() 检查多播地址是否具有站点范围的实用例行程序。
boolean | isMulticastAddress() 检查 InetAddress 是否是 IP 多播地址的实用例行程序。
boolean | isReachable(int timeout) 测试是否可以达到该地址。
boolean | isReachable(NetworkInterface netif, int ttl, int timeout) 测试是否可以达到该地址。
boolean | isSiteLocalAddress() 检查 InetAddress 是否是站点本地地址的实用例行程序。
String | toString() 将此 IP 地址转换为 String。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

isMulticastAddress

public boolean isMulticastAddress()
检查 InetAddress 是否是 IP 多播地址的实用例行程序。

返回：
指示 InetAddress 是否是 IP 多播地址的 boolean 值
从以下版本开始：
JDK1.1

isAnyLocalAddress

public boolean isAnyLocalAddress()
检查 InetAddress 是否是通配符地址的实用例行程序。

返回：
指示 Inetaddress 是否是通配符地址的 boolean 值
从以下版本开始：
1.4

isLoopbackAddress

public boolean isLoopbackAddress()
检查 InetAddress 是否是回送地址的实用例行程序。

返回：
指示 InetAddress 是否是回送地址的 boolean 值；否则返回 false。
从以下版本开始：
1.4

isLinkLocalAddress

public boolean isLinkLocalAddress()
检查 InetAddress 是否是链接本地地址的实用例行程序。

返回：
指示 InetAddress 是否是本地链接地址的 boolean 值；如果地址不是链接本地单播地址，则返回 false。
从以下版本开始：
1.4

isSiteLocalAddress

public boolean isSiteLocalAddress()
检查 InetAddress 是否是站点本地地址的实用例行程序。

返回：
指示 InetAddress 是否是站点本地地址的 boolean 值；如果地址不是站点本地单播地址，则返回 false。
从以下版本开始：
1.4

isMCGlobal

public boolean isMCGlobal()
检查多播地址是否具有全局域的实用例行程序。

返回：
指示地址是否是全局域多播地址的 boolean 值；如果它不是全局域或多播地址，则返回 false
从以下版本开始：
1.4

isMCNodeLocal

public boolean isMCNodeLocal()
检查多播地址是否具有节点范围的实用例行程序。

返回：
指示地址是否是节点本地范围多播地址的 boolean 值；如果它不是节点本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCLinkLocal

public boolean isMCLinkLocal()
检查多播地址是否具有链接范围的实用例行程序。

返回：
指示地址是否是链接本地范围多播地址的 boolean 值；如果它不是链接本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCSiteLocal

public boolean isMCSiteLocal()
检查多播地址是否具有站点范围的实用例行程序。

返回：
指示地址是否是站点本地范围多播地址的 boolean；如果它不是站点本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isMCOrgLocal

public boolean isMCOrgLocal()
检查多播地址是否具有组织范围的实用例行程序。

返回：
指示地址是否是组织本地范围多播地址的 boolean 值；如果它不是组织本地范围或多播地址，则返回 false
从以下版本开始：
1.4

isReachable

public boolean isReachable(int timeout)
                    throws IOException
测试是否可以达到该地址。实现尽最大努力试图到达主机，但防火墙和服务器配置可能阻塞请求，使其在某些特定的端口可以访问时处于不可到达状态。如果可以获得权限，则典型实现将使用 ICMP ECHO REQUEST；否则它将试图在目标主机的端口 7 (Echo) 上建立 TCP 连接。

超时值（以毫秒为单位）指示尝试应该使用的最大时间量。如果在获取应答前操作超时了，则视为主机不可到达。负值将导致抛出 IllegalArgumentException。

参数：
timeout - 调用中止前的时间（以毫秒为单位）
返回：
指示地址是否可到达的 boolean 值。
抛出：
IOException - 如果发生网络错误
IllegalArgumentException - 如果 timeout 为负。
从以下版本开始：
1.5

isReachable

public boolean isReachable(NetworkInterface netif,
                           int ttl,
                           int timeout)
                    throws IOException
测试是否可以达到该地址。实现尽最大努力试图到达主机，但防火墙和服务器配置可能阻塞请求，使其在某些特定的端口可以访问时处于不可到达状态。如果可以获得权限，则典型实现将使用 ICMP ECHO REQUEST；否则它将试图在目标主机的端口 7 (Echo) 上建立 TCP 连接。

network interface 和 ttl 参数允许调用方指定测试将遍历的网络接口和数据包将遍历的最大跳数。ttl 为负值将导致抛出 IllegalArgumentException。

超时值（以毫秒为单位）指示尝试应该使用的最大时间量。如果在获取应答前操作超时了，则视为主机不可到达。负值将导致抛出 IllegalArgumentException。

参数：
netif - 将用于完成测试的 NetworkInterface；或者用于任何接口的 null
ttl - 要尝试的最大跳数或默认值 0
timeout - 调用中止前的时间（以毫秒为单位）
返回：
指示地址是否可到达的 boolean 值。
抛出：
IllegalArgumentException - 如果 timeout 或 ttl 为负。
IOException - 如果发生网络错误
从以下版本开始：
1.5

getHostName

public String getHostName()
获取此 IP 地址的主机名。

如果此 InetAddress 是用主机名创建的，则记忆并返回主机名；否则，将执行反向名称查找并基于系统配置的名称查找服务返回结果。如果需要查找名称服务，则调用 getCanonicalHostName。

如果有安全管理器，则首先使用主机名和 -1 作为参数来调用其 checkConnect 方法，以查看是否允许该操作。如果不允许该操作，则其返回 IP 地址的文本表示形式。

返回：
此 IP 地址的主机名；如果安全检查不允许操作，则返回 IP 地址的文本表示形式。
另请参见：
getCanonicalHostName(), SecurityManager.checkConnect(java.lang.String, int)

getCanonicalHostName

public String getCanonicalHostName()
获取此 IP 地址的完全限定域名。最大努力方法，意味着根据底层系统配置可能不能返回 FQDN。

如果有安全管理器，则此方法首先使用主机名和 -1 作为参数调用其 checkConnect 方法，来查看是否允许调用代码知道此 IP 地址的主机名（即是否允许连接到该主机）。如果不允许该操作，则其返回 IP 地址的文本表示形式。

返回：
此 IP 地址的安全限定域名；如果安全检查不允许操作，则返回 IP 地址的文本表示形式。
从以下版本开始：
1.4
另请参见：
SecurityManager.checkConnect(java.lang.String, int)

getAddress

public byte[] getAddress()
返回此 InetAddress 对象的原始 IP 地址。结果按网络字节顺序：地址的高位字节位于 getAddress()[0] 中。

返回：
此对象的原始 IP 地址。

getHostAddress

public String getHostAddress()
返回 IP 地址字符串（以文本表现形式）。

返回：
字符串格式的原始 IP 地址。
从以下版本开始：
JDK1.0.2

hashCode

public int hashCode()
返回此 IP 地址的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 IP 地址的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，并且它表示与此对象相同的 IP 地址时，结果才为 true。

如果 getAddress 对两个 InetAddress 返回的 byte 数组长度相同并且 byte 数组的每个数组元素也都相同，则这两个 InetAddress 的实例表示相同的 IP 地址。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
getAddress()

toString

public String toString()
将此 IP 地址转换为 String。返回的字符串具有以下形式：主机名/字面值 IP 地址。 如果主机名是未解析的，则不执行反向名称服务查找。主机名部分将由一个空字符串表示。

覆盖：
类 Object 中的 toString
返回：
此 IP 地址的字符串表示形式。

getByAddress

public static InetAddress getByAddress(String host,
                                       byte[] addr)
                                throws UnknownHostException
根据提供的主机名和 IP 地址创建 InetAddress。不检查名称服务的地址有效性。

主机名可以是机器名（如 "java.sun.com"），也可以是其 IP 地址的文本表示形式。

也不在主机名上执行有效性检查。

如果 addr 指定 IPv4 地址，则返回 Inet4Address 的实例；否则将返回 Inet6Address 的实例。

IPv4 地址 byte 数组的长度必须为 4 个字节，IPv6 byte 数组的长度必须为 16 个字节

参数：
host - 指定主机
addr - 网络字节顺序的原始 IP 地址
返回：
根据原始 IP 地址创建的 InetAddress 对象。
抛出：
UnknownHostException - 如果 IP 地址的长度非法
从以下版本开始：
1.4

getByName

public static InetAddress getByName(String host)
                             throws UnknownHostException
在给定主机名的情况下确定主机的 IP 地址。

主机名可以是机器名（如 "java.sun.com"），也可以是其 IP 地址的文本表示形式。如果提供字面值 IP 地址，则仅检查地址格式的有效性。

对于以字面值 IPv6 地址指定的 host，在 RFC 2732 中定义的形式或在 RFC 2373 中定义的字面值 IPv6 地址格式都可以接受。IPv6 范围地址也受支持。有关 IPv6 范围地址的描述，请参见这里。

如果主机为 null，则返回表示回送接口地址的 InetAddress。请参阅 RFC 3330 的第 2 节和 RFC 2373 的第 2.5.3 节。

参数：
host - 指定的主机，或 null。
返回：
给定主机名的 IP 地址。
抛出：
UnknownHostException - 如果找不到 host 的 IP 地址，或者 scope_id 是为全局 IPv6 地址指定的。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作

getAllByName

public static InetAddress[] getAllByName(String host)
                                  throws UnknownHostException
在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。

主机名可以是机器名（如 "java.sun.com"），也可以是其 IP 地址的文本表示形式。如果提供字面值 IP 地址，则仅检查地址格式的有效性。

对于以字面值 IPv6 地址 指定的 host，在 RFC 2732 中定义的形式或在 RFC 2373 中定义的字面值 IPv6 地址格式都可以接受。字面值 IPv6 地址还可以通过追加范围时区标识符或 scope_id 来限定。scope_id 的语法和用法在这里描述。

如果主机为 null，则返回表示回送接口地址的 InetAddress。请参阅 RFC 3330 的第 2 节和 RFC 2373 的第 2.5.3 节。

如果有安全管理器，并且 host 非 null，host.length() 不等于零，则使用主机名和 -1 作为参数调用安全管理器的 checkConnect 方法，来查看是否允许该操作。

参数：
host - 主机名，或 null。
返回：
给定主机名的所有 IP 地址所组成的数组。
抛出：
UnknownHostException - 如果找不到 host 的 IP 地址，或者 scope_id 是为全局 IPv6 地址指定的。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作。
另请参见：
SecurityManager.checkConnect(java.lang.String, int)

getByAddress

public static InetAddress getByAddress(byte[] addr)
                                throws UnknownHostException
在给定原始 IP 地址的情况下，返回 InetAddress 对象。参数按网络字节顺序：地址的高位字节位于 getAddress()[0] 中。

此方法不会阻塞，即不执行任何反向名称服务查找操作。

IPv4 地址 byte 数组的长度必须为 4 个字节，IPv6 byte 数组的长度必须为 16 个字节

参数：
addr - 网络字节顺序的原始 IP 地址
返回：
根据原始 IP 地址创建的 InetAddress 对象。
抛出：
UnknownHostException - 如果 IP 地址的长度非法
从以下版本开始：
1.4

getLocalHost

public static InetAddress getLocalHost()
                                throws UnknownHostException
返回本地主机。

如果有安全管理器，则使用本地主机名和 -1 作为参数来调用其 checkConnect 方法，以查看是否允许该操作。如果不允许该操作，则返回表示回送地址的 InetAddress。

返回：
本地主机的 IP 地址。
抛出：
UnknownHostException - 如果找不到 host 的任何 IP 地址。
另请参见：
SecurityManager.checkConnect(java.lang.String, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InetSocketAddress (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 InetSocketAddress

java.lang.Object
    继承者  java.net.SocketAddress
        继承者  java.net.InetSocketAddress
所有已实现的接口：
Serializable
public class InetSocketAddress
extends SocketAddress

此类实现 IP 套接字地址（IP 地址 + 端口号）。它还可以是一个对（主机名 + 端口号），在此情况下，将尝试解析主机名。如果解析失败，则该地址将被视为未解析 地址，但是其在某些情形下仍然可以使用，比如通过代理连接。

它提供不可变对象，供套接字用于绑定、连接或用作返回值。

通配符 是一个特殊的本地 IP 地址。它通常表示“任何”，只能用于 bind 操作。

从以下版本开始：
1.4
另请参见：
Socket, ServerSocket, 序列化表格

构造方法摘要
InetSocketAddress(InetAddress addr, int port)
根据 IP 地址和端口号创建套接字地址。
InetSocketAddress(int port)
创建套接字地址，其中 IP 地址为通配符地址，端口号为指定值。
InetSocketAddress(String hostname, int port)
根据主机名和端口号创建套接字地址。
方法摘要
static InetSocketAddress | createUnresolved(String host, int port) 根据主机名和端口号创建未解析的套接字地址。
boolean | equals(Object obj) 将此对象与指定对象比较。
InetAddress | getAddress() 获取 InetAddress。
String | getHostName() 获取 hostname。
int | getPort() 获取端口号。
int | hashCode() 返回此套接字地址的哈希码。
boolean | isUnresolved() 检查是否已解析地址。
String | toString() 构造此 InetSocketAddress 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

InetSocketAddress

public InetSocketAddress(int port)
创建套接字地址，其中 IP 地址为通配符地址，端口号为指定值。

有效端口值介于 0 和 65535 之间。端口号 zero 允许系统在 bind 操作中挑选暂时的端口。

参数：
port - 端口号
抛出：
IllegalArgumentException - 如果 port 参数超出有效端口值的指定范围。

InetSocketAddress

public InetSocketAddress(InetAddress addr,
                         int port)
根据 IP 地址和端口号创建套接字地址。

有效端口值介于 0 和 65535 之间。端口号 zero 允许系统在 bind 操作中挑选暂时的端口。

null 地址将分配通配符 地址。

参数：
addr - IP 地址
port - 端口号
抛出：
IllegalArgumentException - 如果 port 参数超出有效端口值的指定范围。

InetSocketAddress

public InetSocketAddress(String hostname,
                         int port)
根据主机名和端口号创建套接字地址。

尝试将主机名解析为 InetAddress。如果尝试失败，则将地址标记为未解析。

如果存在安全管理器，则将主机名用作参数调用其 checkConnect 方法，以检查解析它的权限。这可能会导致 SecurityException 异常。

有效端口值介于 0 和 65535 之间。端口号 zero 允许系统在 bind 操作中挑选暂时的端口。

参数：
hostname - 主机名
port - 端口号
抛出：
IllegalArgumentException - 如果 port 参数超出有效端口值的范围，或者主机名参数为 null。
SecurityException - 如果存在安全管理器，但拒绝解析主机名的权限。
另请参见：
isUnresolved()
方法详细信息

createUnresolved

public static InetSocketAddress createUnresolved(String host,
                                                 int port)
根据主机名和端口号创建未解析的套接字地址。

不会尝试将主机名解析为 InetAddress。将地址标记为未解析。

有效端口值介于 0 和 65535 之间。端口号 zero 允许系统在 bind 操作中挑选暂时的端口。

参数：
host - 主机名
port - 端口号
返回：
表示未解析套接字地址的 InetSocketAddress
抛出：
IllegalArgumentException - 如果 port 参数超出有效端口值的范围，或者主机名参数为 null。
从以下版本开始：
1.5
另请参见：
isUnresolved()

getPort

public final int getPort()
获取端口号。

返回：
端口号。

getAddress

public final InetAddress getAddress()
获取 InetAddress。

返回：
InetAdress；如果未解析，则返回 null。

getHostName

public final String getHostName()
获取 hostname。

返回：
地址的主机名部分。

isUnresolved

public final boolean isUnresolved()
检查是否已解析地址。

返回：
如果无法将主机名解析为 InetAddress，则返回 true。

toString

public String toString()
构造此 InetSocketAddress 的字符串表示形式。此 String 通过在 InetAddress 上调用 toString() 并连接端口号（使用冒号）来构造。如果未解析地址，则冒号之前的部分将仅包含主机名。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。

equals

public final boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，并且它表示与此对象相同的地址时，结果才为 true。

如果 InetSocketAddress 的两个实例的 InetAddress（或主机名，如果未解析的话）和端口号都相等，则它们表示同一个地址。如果两个地址都未解析，则比较主机名和端口号。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
InetAddress.equals(java.lang.Object)

hashCode

public final int hashCode()
返回此套接字地址的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此套接字地址的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InterfaceAddress (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 InterfaceAddress

java.lang.Object
    继承者  java.net.InterfaceAddress

public class InterfaceAddress
extends Object

此类表示网络接口地址。简言之，对于 IPv4 地址，是指 IP 地址、子网掩码和广播地址。对于 IPv6 地址，是指 IP 地址和网络前缀长度。

从以下版本开始：
1.6
另请参见：
NetworkInterface

方法摘要
boolean | equals(Object obj) 将此对象与指定对象比较。
InetAddress | getAddress() 返回此地址的 InetAddress。
InetAddress | getBroadcast() 返回此 InterfaceAddress 广播地址的 InetAddress。
short | getNetworkPrefixLength() 返回此地址的网络前缀长度。
int | hashCode() 返回此接口地址的哈希码。
String | toString() 将此接口地址转换为 String。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getAddress

public InetAddress getAddress()
返回此地址的 InetAddress。

返回：
此地址的 InetAddress。

getBroadcast

public InetAddress getBroadcast()
返回此 InterfaceAddress 广播地址的 InetAddress。

只有 IPv4 网络具有广播地址，因此对于 IPv6 网络将返回 null。

返回：
表示广播地址的 InetAddress；如果没有广播地址，则返回 null。

getNetworkPrefixLength

public short getNetworkPrefixLength()
返回此地址的网络前缀长度。网络前缀长度在 IPv4 地址上下文中也称为子网掩码。典型的 IPv4 值是 8 (255.0.0.0)、16 (255.255.0.0) 或 24 (255.255.255.0)。

典型的 IPv6 值是 128 (::1/128) 或 10 (fe80::203:baff:fe27:1243/10)

返回：
表示该地址子网前缀长度的 short。

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，并且它表示与此对象相同的接口地址时，结果才为 true。

如果 InterfaceAddress 两个实例的 InetAddress、前缀长度和广播地址都相同，则它们表示相同的地址。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
hashCode()

hashCode

public int hashCode()
返回此接口地址的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此接口地址的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
将此接口地址转换为 String。返回的字符串具有以下形式：InetAddress /前缀长度[广播地址]。

覆盖：
类 Object 中的 toString
返回：
此接口地址的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JarURLConnection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 JarURLConnection

java.lang.Object
    继承者  java.net.URLConnection
        继承者  java.net.JarURLConnection

public abstract class JarURLConnection
extends URLConnection

连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。

JAR URL 的语法为：

 jar:<url>!/{entry}

例如：

jar:http://www.foo.com/bar/baz.jar!/COM/foo/Quux.class

应该使用 Jar URL 来引用 JAR 文件或 JAR 文件中的条目。上述示例是一个引用 JAR 条目的 JAR URL。如果省略条目名，则 URL 引用整个 JAR 文件： jar:http://www.foo.com/bar/baz.jar!/

当用户知道他们创建的 URL 为 JAR URL 并且需要特定于 JAR 的功能时，应该将一般 URLConnection 强制转换为 JarURLConnection。例如：

 URL url = new URL("jar:file:/home/duke/duke.jar!/");
 JarURLConnection jarConnection = (JarURLConnection)url.openConnection();
 Manifest manifest = jarConnection.getManifest();

JarURLConnection 实例只能用于从 JAR 文件读取内容。使用此类获取 OutputStream 从而修改或写入基础 JAR 文件是不可能的。

示例：

Jar 条目
jar:http://www.foo.com/bar/baz.jar!/COM/foo/Quux.class
Jar 文件
jar:http://www.foo.com/bar/baz.jar!/
Jar 目录
jar:http://www.foo.com/bar/baz.jar!/COM/foo/

!/ 被视为分隔符。

通过 new URL(context, spec) 构造 JAR url 时，将应用以下规则：

  • 如果不存在任何上下文 URL 并且传入 URL 构造方法的规范不包含分隔符，则 URL 被视为引用一个 JarFile。
  • 如果存在上下文 URL，则假定该上下文 URL 引用 JAR 文件或 Jar 目录。
  • 如果规范以 '/' 开头，则忽略 Jar 目录，并认为 spec 位于 Jar 文件的根。

    示例：

    上下文：jar:http://www.foo.com/bar/jar.jar!/, spec:baz/entry.txt
    url: jar：http://www.foo.com/bar/jar.jar!/baz/entry.txt
    上下文：jar:http://www.foo.com/bar/jar.jar!/baz, spec:entry.txt
    url：jar:http://www.foo.com/bar/jar.jar!/baz/entry.txt
    上下文：jar:http://www.foo.com/bar/jar.jar!/baz, spec:/entry.txt
    url：jar:http://www.foo.com/bar/jar.jar!/entry.txt

从以下版本开始：
1.2
另请参见：
URL, URLConnection, JarFile, JarInputStream, Manifest, ZipEntry

字段摘要
protected  URLConnection jarFileURLConnection
到 JAR 文件 URL 的连接，如果已启动连接。
从类 java.net.URLConnection 继承的字段
allowUserInteraction, connected, doInput, doOutput, ifModifiedSince, url, useCaches
构造方法摘要
protected JarURLConnection(URL url)
创建到指定 URL 的新 JarURLConnection。
方法摘要
Attributes | getAttributes() 如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
Certificate[] | getCertificates() 如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。
String | getEntryName() 返回此连接的条目名称。
JarEntry | getJarEntry() 返回此连接的 JAR 条目对象（如果有）。
abstract JarFile | getJarFile() 返回此连接的 JAR 文件。
URL | getJarFileURL() 返回此连接的 Jar 文件的 URL。
Attributes | getMainAttributes() 返回此连接的 JAR 文件的主要 Attribute。
Manifest | getManifest() 返回此连接的 Manifest；如果没有，则返回 null。
从类 java.net.URLConnection 继承的方法
addRequestProperty, connect, getAllowUserInteraction, getConnectTimeout, getContent, getContent, getContentEncoding, getContentLength, getContentType, getDate, getDefaultAllowUserInteraction, getDefaultRequestProperty, getDefaultUseCaches, getDoInput, getDoOutput, getExpiration, getFileNameMap, getHeaderField, getHeaderField, getHeaderFieldDate, getHeaderFieldInt, getHeaderFieldKey, getHeaderFields, getIfModifiedSince, getInputStream, getLastModified, getOutputStream, getPermission, getReadTimeout, getRequestProperties, getRequestProperty, getURL, getUseCaches, guessContentTypeFromName, guessContentTypeFromStream, setAllowUserInteraction, setConnectTimeout, setContentHandlerFactory, setDefaultAllowUserInteraction, setDefaultRequestProperty, setDefaultUseCaches, setDoInput, setDoOutput, setFileNameMap, setIfModifiedSince, setReadTimeout, setRequestProperty, setUseCaches, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

jarFileURLConnection

protected URLConnection jarFileURLConnection
到 JAR 文件 URL 的连接，如果已启动连接。此方法应该由连接设置。

构造方法详细信息

JarURLConnection

protected JarURLConnection(URL url)
                    throws MalformedURLException
创建到指定 URL 的新 JarURLConnection。

参数：
url - URL
抛出：
MalformedURLException - 如果在规范字符串中找不到合法协议或者无法解析该字符串。
方法详细信息

getJarFileURL

public URL getJarFileURL()
返回此连接的 Jar 文件的 URL。

返回：
此连接的 Jar 文件的 URL。

getEntryName

public String getEntryName()
返回此连接的条目名称。如果对应于此连接的 JAR 文件 URL 指向 JAR 文件而不是 JAR 文件条目，则此方法返回 null。

返回：
此连接的条目名称（如果有）。

getJarFile

public abstract JarFile getJarFile()
                            throws IOException
返回此连接的 JAR 文件。

返回：
此连接的 JAR 文件。如果连接是到 JAR 文件的条目的连接，则返回 JAR 文件对象
抛出：
IOException - 如果在试图连接到此连接的 JAR 文件时发生 IOException。
另请参见：
URLConnection.connect()

getManifest

public Manifest getManifest()
                     throws IOException
返回此连接的 Manifest；如果没有，则返回 null。

返回：
与此连接的 JAR 文件对象相对应的清单对象。
抛出：
IOException - 如果获取此连接的 JAR 文件导致抛出 IOException。
另请参见：
getJarFile()

getJarEntry

public JarEntry getJarEntry()
                     throws IOException
返回此连接的 JAR 条目对象（如果有）。如果对应于此连接的 JAR 文件 URL 指向 JAR 文件而不是 JAR 文件条目，则此方法返回 null。

返回：
此连接的 JAR 条目对象；如果此连接的 JAR URL 指向 JAR 文件，则返回 null。
抛出：
IOException - 如果获取此连接的 JAR 文件导致抛出 IOException。
另请参见：
getJarFile(), getJarEntry()

getAttributes

public Attributes getAttributes()
                         throws IOException
如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。

返回：
如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
抛出：
IOException - 如果获取 JAR 条目导致抛出 IOException。
另请参见：
getJarEntry()

getMainAttributes

public Attributes getMainAttributes()
                             throws IOException
返回此连接的 JAR 文件的主要 Attribute。

返回：
此连接的 JAR 文件的主要 Attribute。
抛出：
IOException - 如果获取清单导致抛出 IOException。
另请参见：
getJarFile(), getManifest()

getCertificates

public Certificate[] getCertificates()
                              throws IOException
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。只有通过从条目输入流一直读取到流末尾的方式完全验证了连接之后，才能调用此方法。否则，此方法将返回 null。

返回：
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。
抛出：
IOException - 如果获取 JAR 条目导致抛出 IOException。
另请参见：
getJarEntry()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MalformedURLException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 MalformedURLException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.MalformedURLException
所有已实现的接口：
Serializable
public class MalformedURLException
extends IOException

抛出这一异常指示出现了错误的 URL。或者在规范字符串中找不到任何合法协议，或者无法解析字符串。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
MalformedURLException()
构造不带详细消息的 MalformedURLException。
MalformedURLException(String msg)
构造带指定详细消息的 MalformedURLException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MalformedURLException

public MalformedURLException()
构造不带详细消息的 MalformedURLException。

MalformedURLException

public MalformedURLException(String msg)
构造带指定详细消息的 MalformedURLException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MulticastSocket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 MulticastSocket

java.lang.Object
    继承者  java.net.DatagramSocket
        继承者  java.net.MulticastSocket

public class MulticastSocket
extends DatagramSocket

多播数据报套接字类用于发送和接收 IP 多播包。MulticastSocket 是一种 (UDP) DatagramSocket，它具有加入 Internet 上其他多播主机的“组”的附加功能。

多播组通过 D 类 IP 地址和标准 UDP 端口号指定。D 类 IP 地址在 224.0.0.0 和 239.255.255.255 的范围内（包括两者）。地址 224.0.0.0 被保留，不应使用。

可以通过首先使用所需端口创建 MulticastSocket，然后调用 joinGroup(InetAddress groupAddr) 方法来加入多播组：

 // join a Multicast group and send the group salutations
 ...
 String msg = "Hello";
 InetAddress group = InetAddress.getByName("228.5.6.7");
 MulticastSocket s = new MulticastSocket(6789);
 s.joinGroup(group);
 DatagramPacket hi = new DatagramPacket(msg.getBytes(), msg.length(),
                             group, 6789);
 s.send(hi);
 // get their responses!
byte[] buf = new byte[1000];
 DatagramPacket recv = new DatagramPacket(buf, buf.length);
 s.receive(recv);
 ...
 // OK, I'm done talking - leave the group...
 s.leaveGroup(group);
将消息发送到多播组时，该主机和端口的所有预定接收者都将接收到消息（在数据包的生存时间范围内，请参阅下文）。套接字不必成为多播组的成员即可向其发送消息。

当套接字预定多播组/端口时，它将接收由该组/端口的其他主机发送的数据报，像该组和端口的所有其他成员一样。套接字通过 leaveGroup(InetAddress addr) 方法放弃组中的成员资格。多个 MulticastSocket 可以同时预定多播组和端口，并且都会接收到组数据报。

同时，不允许 applet 使用多播套接字。

从以下版本开始：
JDK1.1

构造方法摘要
MulticastSocket()
创建多播套接字。
MulticastSocket(int port)
创建多播套接字并将其绑定到特定端口。
MulticastSocket(SocketAddress bindaddr)
创建绑定到指定套接字地址的 MulticastSocket。
方法摘要
 InetAddress getInterface()
获取用于多播数据包的网络接口的地址。
 boolean getLoopbackMode()
获取多播数据报的本地回送的设置。
 NetworkInterface getNetworkInterface()
获取多播网络接口集合。
 int getTimeToLive()
获取在套接字上发出的多播数据包的默认生存时间。
 byte getTTL()
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。
 void joinGroup(InetAddress mcastaddr)
加入多播组。
 void joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入指定接口上的指定多播组。
 void leaveGroup(InetAddress mcastaddr)
离开多播组。
 void leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
离开指定本地接口上的多播组。
 void send(DatagramPacket p, byte ttl)
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......
 void setInterface(InetAddress inf)
设置多播网络接口，供其行为将受网络接口值影响的方法使用。
 void setLoopbackMode(boolean disable)
启用/禁用多播数据报的本地回送。
 void setNetworkInterface(NetworkInterface netIf)
指定在此套接字上发送的输出多播数据报的网络接口。
 void setTimeToLive(int ttl)
设置在此 MulticastSocket 上发出的多播数据包的默认生存时间，以便控制多播的范围。
 void setTTL(byte ttl)
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。
从类 java.net.DatagramSocket 继承的方法
bind, close, connect, connect, disconnect, getBroadcast, getChannel, getInetAddress, getLocalAddress, getLocalPort, getLocalSocketAddress, getPort, getReceiveBufferSize, getRemoteSocketAddress, getReuseAddress, getSendBufferSize, getSoTimeout, getTrafficClass, isBound, isClosed, isConnected, receive, send, setBroadcast, setDatagramSocketImplFactory, setReceiveBufferSize, setReuseAddress, setSendBufferSize, setSoTimeout, setTrafficClass
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MulticastSocket

public MulticastSocket()
                throws IOException
创建多播套接字。

如果有安全管理器，则首先使用 0 作为变量来调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

创建套接字时，将调用 DatagramSocket.setReuseAddress(boolean) 方法来启用 SO_REUSEADDR 套接字选项。

抛出：
IOException - 如果在创建 MulticastSocket 时发生 I/O 异常
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
另请参见：
SecurityManager.checkListen(int), DatagramSocket.setReuseAddress(boolean)

MulticastSocket

public MulticastSocket(int port)
                throws IOException
创建多播套接字并将其绑定到特定端口。

如果存在安全管理器，则首先使用 port 参数作为参数调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

创建套接字时，将调用 DatagramSocket.setReuseAddress(boolean) 方法来启用 SO_REUSEADDR 套接字选项。

参数：
port - 要使用的端口
抛出：
IOException - 如果在创建 MulticastSocket 时发生 I/O 异常
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
另请参见：
SecurityManager.checkListen(int), DatagramSocket.setReuseAddress(boolean)

MulticastSocket

public MulticastSocket(SocketAddress bindaddr)
                throws IOException
创建绑定到指定套接字地址的 MulticastSocket。

或者，如果地址为 null，则创建未绑定套接字。

如果有安全管理器，则首先使用 SocketAddress 端口作为参数来调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

创建套接字时，将调用 DatagramSocket.setReuseAddress(boolean) 方法来启用 SO_REUSEADDR 套接字选项。

参数：
bindaddr - 要绑定到的套接字地址；或者为 null，它表示非绑定套接字。
抛出：
IOException - 如果在创建 MulticastSocket 时发生 I/O 异常
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
从以下版本开始：
1.4
另请参见：
SecurityManager.checkListen(int), DatagramSocket.setReuseAddress(boolean)
方法详细信息

setTTL

@Deprecated
public void setTTL(byte ttl)
            throws IOException
已过时。 使用 setTimeToLive 方法来代替，该方法使用 int（而不用 byte）作为 ttl 的类型。

设置在此 MulticastSocket 上发出的多播数据包的默认生存时间，以便控制多播的范围。

ttl 为无符号 8 位量，所以其必须在 0 <= ttl <= 0xFF 范围内。

参数：
ttl - 生存时间
抛出：
IOException - 如果在设置默认生存时间值时发生 I/O 异常
另请参见：
getTTL()

setTimeToLive

public void setTimeToLive(int ttl)
                   throws IOException
设置在此 MulticastSocket 上发出的多播数据包的默认生存时间，以便控制多播的范围。

ttl 必须在 0 <= ttl <= 255 范围内，否则将抛出 IllegalArgumentException。

参数：
ttl - 生存时间
抛出：
IOException - 如果在设置默认生存时间值时发生 I/O 异常
另请参见：
getTimeToLive()

getTTL

@Deprecated
public byte getTTL()
            throws IOException
已过时。 使用 getTimeToLive 方法来代替，该方法返回 int（而不是 byte）。

获取在套接字上发出的多播数据包的默认生存时间。

返回：
默认生存时间值
抛出：
IOException - 如果在获取默认生存时间值时发生 I/O 异常
另请参见：
setTTL(byte)

getTimeToLive

public int getTimeToLive()
                  throws IOException
获取在套接字上发出的多播数据包的默认生存时间。

返回：
默认生存时间值
抛出：
IOException - 如果在获取默认生存时间值时发生 I/O 异常
另请参见：
setTimeToLive(int)

joinGroup

public void joinGroup(InetAddress mcastaddr)
               throws IOException
加入多播组。其行为可能受到 setInterface 或 setNetworkInterface 的影响。

如果有安全管理器，则此方法首先使用 mcastaddr 作为参数来调用其 checkMulticast 方法。

参数：
mcastaddr - 要加入的多播地址
抛出：
IOException - 如果存在错误加入或者当地址不是多播地址时。
SecurityException - 如果安全管理器存在并且其 checkMulticast 方法不允许加入。
另请参见：
SecurityManager.checkMulticast(InetAddress)

leaveGroup

public void leaveGroup(InetAddress mcastaddr)
                throws IOException
离开多播组。其行为可能受到 setInterface 或 setNetworkInterface 的影响。

如果有安全管理器，则此方法首先使用 mcastaddr 作为参数来调用其 checkMulticast 方法。

参数：
mcastaddr - 要离开的多播地址
抛出：
IOException - 如果存在错误离开或者当地址不是多播地址时。
SecurityException - 如果安全管理器存在并且其 checkMulticast 方法不允许进行该操作。
另请参见：
SecurityManager.checkMulticast(InetAddress)

joinGroup

public void joinGroup(SocketAddress mcastaddr,
                      NetworkInterface netIf)
               throws IOException
加入指定接口上的指定多播组。

如果有安全管理器，则此方法首先使用 mcastaddr 作为参数来调用其 checkMulticast 方法。

参数：
mcastaddr - 要加入的多播地址
netIf - 指定要接收多播数据报包的本地接口；或者为 null，表示由 setInterface(InetAddress) 或 setNetworkInterface(NetworkInterface) 设置的接口
抛出：
IOException - 如果存在错误加入或者当地址不是多播地址时。
SecurityException - 如果安全管理器存在并且其 checkMulticast 方法不允许加入。
IllegalArgumentException - 如果 mcastaddr 为 null 或者为此套接字不支持的 SocketAddress 子类。
从以下版本开始：
1.4
另请参见：
SecurityManager.checkMulticast(InetAddress)

leaveGroup

public void leaveGroup(SocketAddress mcastaddr,
                       NetworkInterface netIf)
                throws IOException
离开指定本地接口上的多播组。

如果有安全管理器，则此方法首先使用 mcastaddr 作为参数来调用其 checkMulticast 方法。

参数：
mcastaddr - 要离开的多播地址
netIf - 指定本地接口；或者为 null，表示由 setInterface(InetAddress) 或 setNetworkInterface(NetworkInterface) 设置的接口
抛出：
IOException - 如果存在错误离开或者当地址不是多播地址时。
SecurityException - 如果安全管理器存在并且其 checkMulticast 方法不允许进行该操作。
IllegalArgumentException - 如果 mcastaddr 为 null 或者为此套接字不支持的 SocketAddress 子类。
从以下版本开始：
1.4
另请参见：
SecurityManager.checkMulticast(InetAddress)

setInterface

public void setInterface(InetAddress inf)
                  throws SocketException
设置多播网络接口，供其行为将受网络接口值影响的方法使用。对多宿主机 (multihomed host) 很有用。

参数：
inf - InetAddress
抛出：
SocketException - 如果在底层协议中存在错误，如 TCP 错误。
另请参见：
getInterface()

getInterface

public InetAddress getInterface()
                         throws SocketException
获取用于多播数据包的网络接口的地址。

返回：
表示用于多播数据包的网络接口地址的 InetAddress。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
另请参见：
setInterface(java.net.InetAddress)

setNetworkInterface

public void setNetworkInterface(NetworkInterface netIf)
                         throws SocketException
指定在此套接字上发送的输出多播数据报的网络接口。

参数：
netIf - 接口
抛出：
SocketException - 如果在底层协议中存在错误，如 TCP 错误。
从以下版本开始：
1.4
另请参见：
getNetworkInterface()

getNetworkInterface

public NetworkInterface getNetworkInterface()
                                     throws SocketException
获取多播网络接口集合。

返回：
当前设置的多播 NetworkInterface
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.4
另请参见：
setNetworkInterface(NetworkInterface)

setLoopbackMode

public void setLoopbackMode(boolean disable)
                     throws SocketException
启用/禁用多播数据报的本地回送。平台的网络代码将该选项用作设置是否将多播数据回送到本地套接字的提示。

因为此选项是一个提示，所以要验证回送的设置模式的应用程序应该调用 getLoopbackMode()

参数：
disable - 为 true 表示禁用 LoopbackMode
抛出：
SocketException - 如果在设置值时发生错误
从以下版本开始：
1.4
另请参见：
getLoopbackMode()

getLoopbackMode

public boolean getLoopbackMode()
                        throws SocketException
获取多播数据报的本地回送的设置。

返回：
如果已禁用 LoopbackMode，则返回 true
抛出：
SocketException - 如果在获取值时发生错误
从以下版本开始：
1.4
另请参见：
setLoopbackMode(boolean)

send

@Deprecated
public void send(DatagramPacket p,
                            byte ttl)
          throws IOException
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......

利用套接字的默认值之外的 TTL（生存时间）将数据报包发送到目的地。只有在需要特定 TTL 的实例中才需要使用此方法；否则，优先考虑在套接字上设置一次 TTL 并将该默认 TTL 用于所有数据包。此方法不改变套接字的默认 TTL。其行为可能受到 setInterface 的影响。

如果存在安全管理器，则此方法首先执行某些安全检查。首先，如果 p.getAddress().isMulticastAddress() 为 true，则此方法将使用 p.getAddress() 和 ttl 作为参数调用安全管理器的 checkMulticast 方法。如果该表达式的计算为 false，则此方法改为调用安全管理器的以 p.getAddress().getHostAddress() 和 p.getPort() 为参数的 checkConnect 方法。如果不允许该操作，则每次调用安全管理器方法都会导致 SecurityException。

参数：
p - 要发送的数据包。数据包应该包含目标多播 ip 地址和要发送的数据。不必成为组成员即可将数据包发送到目标多播地址。
ttl - 多播数据包的可选生存时间。默认的 ttl 为 1。
抛出：
IOException - 如果发生错误（即设置 ttl 时出错）则引发该异常。
SecurityException - 如果安全管理器存在并且其 checkMulticast 或 checkConnect 方法不允许发送。
另请参见：
DatagramSocket.send(java.net.DatagramPacket),
DatagramSocket.receive(java.net.DatagramPacket),
SecurityManager.checkMulticast(java.net.InetAddress, byte),
SecurityManager.checkConnect(java.lang.String, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NetPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 NetPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.net.NetPermission
所有已实现的接口：
Serializable, Guard
public final class NetPermission
extends BasicPermission

此类可用于各种网络权限。NetPermission 包含一个名称（也称为“目标名称”），但没有动作列表；可能有指定的权限，也可能没有。

目标名称是网络权限的名称（参见以下内容）。命名约定遵守层次结构属性命名约定。另外，名称的末尾可能有一个星号，星号前有一个 "."，用来表示通配符。例如："foo.*" 或 "*" 是有效的，而 "*foo" 或 "a*b" 则无效。

下表列出了所有可能的 NetPermission 目标名称，并提供了权限所允许的操作的简要说明，还讨论了授予代码该权限的风险。

权限目标名称 | 权限所允许的操作 | 允许此权限所带来的风险
setDefaultAuthenticator | 设置代理或 HTTP 服务器请求验证时获取验证信息的方式的能力 | 恶意代码可以设置一个 authenticator，在获取用户输入时能监控和盗取用户的验证输入。
requestPasswordAuthentication | 要求在系统中注册的 authenticator 提供密码的能力 | 恶意代码可能盗取此密码。
specifyStreamHandler | 在构造 URL 时指定流处理程序的能力 | 恶意代码可能利用它通常不可访问的资源（如 file:/foo/fum/）创建 URL，指定从它可以访问的某个位置获取实际代码的流处理程序。因此，它也许能欺骗系统，使其创建类事件的 ProtectionDomain/CodeSource，尽管该类实际上并非源于该位置。
setProxySelector | 设置用于决定要在建立网络连接时使用的代理的代理选择器的能力。 | 恶意代码可以设置一个 ProxySelector，将网络流量定向到任意网络主机。
getProxySelector | 获取用于决定要在建立网络连接时使用的代理的代理选择器的能力。 | 恶意代码可以获取 ProxySelector 以发现内部网络中的代理主机和端口，从而其可能成为攻击的目标。
setCookieHandler | 设置用于为 Http 会话处理高度安全性敏感 cookie 的 cookie 处理程序的能力。 | 恶意代码可以设置 cookie 处理程序以达到对高度安全性敏感 cookie 信息的访问。有些 Web 服务器使用 cookie 来保存用户私有信息（如访问控制信息）或者跟踪用户浏览习惯。
getCookieHandler | 获取用于为 Http 会话处理高度安全性敏感 cookie 的 cookie 处理程序的能力。 | 恶意代码可以获得 cookie 处理程序以达到对高度安全性敏感 cookie 信息的访问。有些 Web 服务器使用 cookie 来保存用户私有信息（如访问控制信息）或者跟踪用户浏览习惯。
setResponseCache | 设置提供本地响应缓存的访问权限的响应缓存的能力。 | 获取本地响应缓存的访问权限的恶意代码可以访问安全性敏感信息，也可以在响应缓存中创建 false 条目。
getResponseCache | 获取提供本地响应缓存的访问权限的响应缓存的能力。 | 获取本地响应缓存的访问权限的恶意代码可以访问安全性敏感信息。

另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
NetPermission(String name)
创建具有指定名称的新 NetPermission。
NetPermission(String name, String actions)
创建带指定名称的新 NetPermission。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

NetPermission

public NetPermission(String name)
创建具有指定名称的新 NetPermission。此名称是 NetPermission 的符号名，比如“setDefaultAuthenticator”等等。名称的末尾可能出现一个星号来表示通配符，其前面有一个“.”（也可能没有）。

参数：
name - NetPermission 的名称。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

NetPermission

public NetPermission(String name,
                     String actions)
创建带指定名称的新 NetPermission。此名称是 NetPermission 的符号名，而当前不使用动作 String，该字符串应该为 null。

参数：
name - NetPermission 的名称。
actions - 应该为 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NetworkInterface (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 NetworkInterface

java.lang.Object
    继承者  java.net.NetworkInterface

public final class NetworkInterface
extends Object

此类表示一个由名称和分配给此接口的 IP 地址列表组成的网络接口。它用于标识加入多播组的本地接口。 接口通常是按名称（如 "le0"）区分的。

从以下版本开始：
1.4

方法摘要
boolean | equals(Object obj) 将此对象与指定对象比较。
static NetworkInterface | getByInetAddress(InetAddress addr) 一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
static NetworkInterface | getByName(String name) 搜索具有指定名称的网络接口。
String | getDisplayName() 获取此网络接口的显示名称。
byte[] | getHardwareAddress() 如果存在硬件地址并可以使用给定的当前权限访问，则返回该硬件地址（通常是 MAC）。
Enumeration<InetAddress> | getInetAddresses() 一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。
List<InterfaceAddress> | getInterfaceAddresses() 获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。
int | getMTU() 返回此接口的最大传输单元（Maximum Transmission Unit，MTU）。
String | getName() 获取此网络接口的名称。
static Enumeration<NetworkInterface> | getNetworkInterfaces() 返回此机器上的所有接口。
NetworkInterface | getParent() 如果此接口是子接口，则返回它的父 NetworkInterface；如果它是物理（非虚拟）接口或没有父接口，则返回 null。
Enumeration<NetworkInterface> | getSubInterfaces() 获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。
int | hashCode() 返回该对象的哈希码值。
boolean | isLoopback() 返回网络接口是否是回送接口。
boolean | isPointToPoint() 返回网络接口是否是点对点接口。
boolean | isUp() 返回网络接口是否已经开启并运行。
boolean | isVirtual() 返回此接口是否是虚拟接口（也称为子接口）。
boolean | supportsMulticast() 返回网络接口是否支持多址广播。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getName

public String getName()
获取此网络接口的名称。

返回：
此网络接口的名称

getInetAddresses

public Enumeration<InetAddress> getInetAddresses()
一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。

如果存在安全管理器，则对每个 InetAddress 调用其 checkConnect 方法。只有 checkConnect 不抛出 SecurityException 的 InetAddress 才会在 Enumeration 中返回。

返回：
一个 Enumeration 对象，具有绑定到此网络接口的全部或部分 InetAddress

getInterfaceAddresses

public List<InterfaceAddress> getInterfaceAddresses()
获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。

如果存在安全管理器，则使用 InetAddress 对每个 InterfaceAddress 调用其 checkConnect 方法。只有 checkConnect 不抛出 SecurityException 的 InterfaceAddresses 才会在列表中返回。

返回：
一个 List 对象，具有此网络接口的全部或部分 InterfaceAddresss
从以下版本开始：
1.6

getSubInterfaces

public Enumeration<NetworkInterface> getSubInterfaces()
获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。

例如，eth0:1 是 eth0 的子接口。

返回：
一个 Enumeration 对象，具有此网络接口的所有子接口。
从以下版本开始：
1.6

getParent

public NetworkInterface getParent()
如果此接口是子接口，则返回它的父 NetworkInterface；如果它是物理（非虚拟）接口或没有父接口，则返回 null。

返回：
此接口连接到的 NetworkInterface。
从以下版本开始：
1.6

getDisplayName

public String getDisplayName()
获取此网络接口的显示名称。显示名称是描述网络设备的可读字符串。

返回：
此网络接口的显示名称；如果不存在可用的显示名称，则返回 null。

getByName

public static NetworkInterface getByName(String name)
                                  throws SocketException
搜索具有指定名称的网络接口。

参数：
name - 网络接口的名称。
返回：
具有指定名称的 NetworkInterface；如果不存在具有指定名称的网络接口，则返回 null。
抛出：
SocketException - 如果发生 I/O 错误。
NullPointerException - 如果指定的名称为 null。

getByInetAddress

public static NetworkInterface getByInetAddress(InetAddress addr)
                                         throws SocketException
一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。

如果指定的 IP 地址被绑定到多个网络接口，则返回哪个网络接口是不确定的。

参数：
addr - 用于搜索的 InetAddress。
返回：
NetworkInterface；如果不存在具有指定 IP 地址的网络接口，则返回 null。
抛出：
SocketException - 如果发生 I/O 错误。
NullPointerException - 如果指定的地址为 null。

getNetworkInterfaces

public static Enumeration<NetworkInterface> getNetworkInterfaces()
                                                          throws SocketException
返回此机器上的所有接口。如果在此机器上找不到任何网络接口，则返回 null。 注：可以使用 getNetworkInterfaces()+getInetAddresses() 来获取此节点的所有 IP 地址。

返回：
此机器上的 NetworkInterface 的 Enumeration
抛出：
SocketException - 如果发生 I/O 错误。

isUp

public boolean isUp()
             throws SocketException
返回网络接口是否已经开启并运行。

返回：
如果接口已经开启并运行，则返回 true。
抛出：
SocketException - 如果发生 I/O 错误。
从以下版本开始：
1.6

isLoopback

public boolean isLoopback()
                   throws SocketException
返回网络接口是否是回送接口。

返回：
如果接口是回送接口，则返回 true。
抛出：
SocketException - 如果发生 I/O 错误。
从以下版本开始：
1.6

isPointToPoint

public boolean isPointToPoint()
                       throws SocketException
返回网络接口是否是点对点接口。典型的点对点接口是通过调制解调器进行 PPP 连接的。

返回：
如果接口是点对点接口，则返回 true。
抛出：
SocketException - 如果发生 I/O 错误。
从以下版本开始：
1.6

supportsMulticast

public boolean supportsMulticast()
                          throws SocketException
返回网络接口是否支持多址广播。

返回：
如果接口支持多址广播，则返回 true。
抛出：
SocketException - 如果发生 I/O 错误。
从以下版本开始：
1.6

getHardwareAddress

public byte[] getHardwareAddress()
                          throws SocketException
如果存在硬件地址并可以使用给定的当前权限访问，则返回该硬件地址（通常是 MAC）。

返回：
包含硬件地址的 byte 数组；如果地址不存在或不可访问，则返回 null。
抛出：
SocketException - 如果发生 I/O 错误。
从以下版本开始：
1.6

getMTU

public int getMTU()
           throws SocketException
返回此接口的最大传输单元（Maximum Transmission Unit，MTU）。

返回：
该接口的 MTU 值。
抛出：
SocketException - 如果发生 I/O 错误。
从以下版本开始：
1.6

isVirtual

public boolean isVirtual()
返回此接口是否是虚拟接口（也称为子接口）。 在某些系统上，虚拟接口作为物理接口的子接口创建，并给予不同的设置（如地址或 MTU）。通常，接口的名称将是父接口的名称加上冒号 (:)，再加上标识该子接口的编号，因为一个物理接口可以存在多个虚拟接口。

返回：
如果此接口是虚拟接口，则返回 true。
从以下版本开始：
1.6

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，并且它表示与此对象相同的 NetworkInterface 时，结果才为 true。

如果 NetworkInterface 两个实例的名称和地址都相同，则它们表示相同的 NetworkInterface。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
InetAddress.getAddress()

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoRouteToHostException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 NoRouteToHostException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.SocketException
                    继承者  java.net.NoRouteToHostException
所有已实现的接口：
Serializable
public class NoRouteToHostException
extends SocketException

试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。通常为无法到达远程主机，原因是防火墙干扰或者中间路由器停机。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
NoRouteToHostException()
构造不带详细信息的新 NoRouteToHostException。
NoRouteToHostException(String msg)
构造一个新的 NoRouteToHostException，使其具有关于无法到达远程主机的原因的指定详细消息。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoRouteToHostException

public NoRouteToHostException(String msg)
构造一个新的 NoRouteToHostException，使其具有关于无法到达远程主机的原因的指定详细消息。详细消息指的是一个具体描述此错误的 String。

参数：
msg - 详细消息

NoRouteToHostException

public NoRouteToHostException()
构造不带详细信息的新 NoRouteToHostException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Proxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 Proxy

java.lang.Object
    继承者  java.net.Proxy

public class Proxy
extends Object

此类表示代理设置，通常为类型（http、socks）和套接字地址。Proxy 是不可变对象。

从以下版本开始：
1.5
另请参见：
ProxySelector

嵌套类摘要
static class Proxy.Type
表示代理类型。
字段摘要
static Proxy NO_PROXY
表示 DIRECT 连接的代理设置，主要通知协议处理程序不使用任何代理。
构造方法摘要
Proxy(Proxy.Type type, SocketAddress sa)
创建表示 PROXY 连接的条目。
方法摘要
SocketAddress | address() 返回代理的套接字地址，如果其为直接连接，则返回 null。
boolean | equals(Object obj) 将此对象与指定对象比较。
int | hashCode() 返回此代理的哈希码。
String | toString() 构造此代理的字符串表示形式。
Proxy.Type | type() 返回代理类型。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

NO_PROXY

public static final Proxy NO_PROXY
表示 DIRECT 连接的代理设置，主要通知协议处理程序不使用任何代理。例如，用于创建绕过所有其他全局代理设置（如 SOCKS）的套接字：

Socket s = new Socket(Proxy.NO_PROXY);

构造方法详细信息

Proxy

public Proxy(Proxy.Type type,
             SocketAddress sa)
创建表示 PROXY 连接的条目。某些组合是非法的。例如，对于类型 Http 和 Socks，必须提供 SocketAddress。

使用 Proxy.NO_PROXY 常量表示直接连接。

参数：
type - 代理的 Type
sa - 该代理的 SocketAddress
抛出：
IllegalArgumentException - 当类型和地址不兼容时
方法详细信息

type

public Proxy.Type type()
返回代理类型。

返回：
表示代理类型的类型

address

public SocketAddress address()
返回代理的套接字地址，如果其为直接连接，则返回 null。

返回：
表示代理的套接字端点的 SocketAddress

toString

public String toString()
构造此代理的字符串表示形式。如果其类型不为 DIRECT，那么此 String 是通过在其类型上调用 toString()，并连接 "@" 和从其地址产生的 toString() 构造。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。

equals

public final boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null，并且它表示与此对象相同的代理时，结果才为 true。

如果 Proxy 的两个实例的 SocketAddress 和类型都相等，则它们表示同一个地址。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
InetSocketAddress.equals(java.lang.Object)

hashCode

public final int hashCode()
返回此代理的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此代理的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PasswordAuthentication (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 PasswordAuthentication

java.lang.Object
    继承者  java.net.PasswordAuthentication

public final class PasswordAuthentication
extends Object

PasswordAuthentication 类是供 Authenticator 使用的数据持有者。它只是用户名和密码的存储库。

从以下版本开始：
1.2
另请参见：
Authenticator, Authenticator.getPasswordAuthentication()

构造方法摘要
PasswordAuthentication(String userName, char[] password)
根据给定用户名和密码创建新的 PasswordAuthentication 对象。
方法摘要
char[] | getPassword() 返回用户密码。
String | getUserName() 返回用户名。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PasswordAuthentication

public PasswordAuthentication(String userName,
                              char[] password)
根据给定用户名和密码创建新的 PasswordAuthentication 对象。

注意，要在将给定用户密码存储在新的 PasswordAuthentication 对象中之前复制该密码。

参数：
userName - 用户名
password - 用户密码
方法详细信息

getUserName

public String getUserName()
返回用户名。

返回：
用户名

getPassword

public char[] getPassword()
返回用户密码。

注意，此方法返回到密码的引用。不再需要密码信息后，调用方负责将其归零。

返回：
密码
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PortUnreachableException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 PortUnreachableException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.SocketException
                    继承者  java.net.PortUnreachableException
所有已实现的接口：
Serializable
public class PortUnreachableException
extends SocketException

在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
PortUnreachableException()
构造不带详细消息的新 PortUnreachableException。
PortUnreachableException(String msg)
构造带详细消息的新 PortUnreachableException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PortUnreachableException

public PortUnreachableException(String msg)
构造带详细消息的新 PortUnreachableException。

参数：
msg - 详细消息

PortUnreachableException

public PortUnreachableException()
构造不带详细消息的新 PortUnreachableException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProtocolException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 ProtocolException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.ProtocolException
所有已实现的接口：
Serializable
public class ProtocolException
extends IOException

抛出此异常指示在底层协议中存在错误，如 TCP 错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
ProtocolException()
构造不带详细消息的新 ProtocolException。
ProtocolException(String host)
构造带指定详细消息的新 ProtocolException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ProtocolException

public ProtocolException(String host)
构造带指定详细消息的新 ProtocolException。

参数：
host - 详细消息。

ProtocolException

public ProtocolException()
构造不带详细消息的新 ProtocolException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Proxy.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.net
枚举 Proxy.Type

java.lang.Object
    继承者  java.lang.Enum<Proxy.Type>
        继承者  java.net.Proxy.Type
所有已实现的接口：
Serializable, Comparable<Proxy.Type>
正在封闭类：
Proxy
public static enum Proxy.Type
extends Enum<Proxy.Type>

表示代理类型。

从以下版本开始：
1.5

枚举常量摘要
DIRECT
表示直接连接或缺少代理。
HTTP
表示高级协议的代理，如 HTTP 或 FTP。
SOCKS
表示 SOCKS（V4 或 V5）代理。
方法摘要
static Proxy.Type | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Proxy.Type[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

DIRECT

public static final Proxy.Type DIRECT
表示直接连接或缺少代理。

HTTP

public static final Proxy.Type HTTP
表示高级协议的代理，如 HTTP 或 FTP。

SOCKS

public static final Proxy.Type SOCKS
表示 SOCKS（V4 或 V5）代理。

方法详细信息

values

public static final Proxy.Type[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Proxy.Type c : Proxy.Type.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Proxy.Type valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


ProxySelector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 ProxySelector

java.lang.Object
    继承者  java.net.ProxySelector

public abstract class ProxySelector
extends Object

连接到 URL 引用的网络资源时选择要使用的代理服务器（如果有）。代理选择器是此类的具体子类，通过调用 setDefault 方法注册。当前注册的代理选择器可以通过调用 getDefault 方法获得。

例如，注册代理选择器时，URLConnection 类的子类应该调用每个 URL 请求的 select 方法，这样代理选择器便可以决定应该使用直接连接还是代理连接。select 方法返回使用首选连接方法的连接上的迭代器。

如果无法建立到代理（PROXY 或 SOCKS）服务器的连接，则调用方应该调用代理选择器的 connectFailed 方法来通知代理选择器，代理服务器不可用。

从以下版本开始：
1.5

构造方法摘要
ProxySelector()
方法摘要
abstract void | connectFailed(URI uri, SocketAddress sa, IOException ioe) 调用此方法来指示无法建立到代理/socks 服务器的连接。
static ProxySelector | getDefault() 获取系统级代理选择器。
abstract List<Proxy> | select(URI uri) 基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。
static void | setDefault(ProxySelector ps) 设置（或取消设置）系统级代理选择器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProxySelector

public ProxySelector()
方法详细信息

getDefault

public static ProxySelector getDefault()
获取系统级代理选择器。

返回：
系统级 ProxySelector
抛出：
SecurityException - 如果已安装安全管理器并且它拒绝 NetPermission ("getProxySelector")
从以下版本开始：
1.5
另请参见：
setDefault(ProxySelector)

setDefault

public static void setDefault(ProxySelector ps)
设置（或取消设置）系统级代理选择器。 注：非标准协议处理程序可能忽略此设置。

参数：
ps - HTTP 代理选择器，或者为 null，表示取消设置代理选择器。
抛出：
SecurityException - 如果已安装安全管理器并且它拒绝 NetPermission ("setProxySelector")
从以下版本开始：
1.5
另请参见：
getDefault()

select

public abstract List<Proxy> select(URI uri)
基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。URI 的格式定义如下：
  • http URI 用于 http 连接
  • https URI 用于 https 连接
  • ftp URI 用于 ftp 连接
  • socket://host:port
    用于 tcp 客户端套接字连接

参数：
uri - 所需连接的 URI
返回：
代理列表。列表中的所有元素都是 Proxy 类型；当不存在可用代理时，列表将包含一个 Proxy 类型的元素，该元素表示直接连接。
抛出：
IllegalArgumentException - 如果任何一个参数为 null

connectFailed

public abstract void connectFailed(URI uri,
                                   SocketAddress sa,
                                   IOException ioe)
调用此方法来指示无法建立到代理/socks 服务器的连接。此方法的实现可以使用给定的地址和 IOException 的种类暂时移除或重新排序 select(String, String) 所返回的代理序列。

参数：
uri - 位于 sa 的代理未能提供服务的 URI。
sa - 代理/SOCKS 服务器的套接字地址
ioe - 连接失败时抛出的 I/O 异常。
抛出：
IllegalArgumentException - 如果任何一个参数为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResponseCache (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 ResponseCache

java.lang.Object
    继承者  java.net.ResponseCache

public abstract class ResponseCache
extends Object

表示 URLConnection 缓存的实现。这种类的实例可以通过执行 ResponseCache.setDefault(ResponseCache) 向系统注册，系统将调用此对象以便：

  • 将从外部源获得的资源数据存储到缓存中
  • 试图获取可能存储在缓存中的请求资源
ResponseCache 实现决定应该缓存的资源和缓存它们的时间。如果无法从缓存获得请求资源，则协议处理程序将从其初始位置获取该资料。 URLConnection#useCaches 的设置控制着是否允许协议使用缓存的响应。 有关 HTTP 缓存的更多信息，请参见 RFC 2616: Hypertext Transfer Protocol -- HTTP/1.1。

从以下版本开始：
1.5

构造方法摘要
ResponseCache()
方法摘要
abstract CacheResponse | get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders) 根据请求的 uri、请求方法和请求头获取缓存的响应。
static ResponseCache | getDefault() 获取系统级响应缓存。
abstract CacheRequest | put(URI uri, URLConnection conn) 协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。
static void | setDefault(ResponseCache responseCache) 设置（或取消设置）系统级缓存。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ResponseCache

public ResponseCache()
方法详细信息

getDefault

public static ResponseCache getDefault()
获取系统级响应缓存。

返回：
系统级 ResponseCache
抛出：
SecurityException - 如果安装了安全管理器并且它拒绝 NetPermission ("getResponseCache")
从以下版本开始：
1.5
另请参见：
setDefault(ResponseCache)

setDefault

public static void setDefault(ResponseCache responseCache)
设置（或取消设置）系统级缓存。 注：非标准协议处理程序可能忽略此设置。

参数：
responseCache - 响应缓存，或者为 null，表示取消设置缓存。
抛出：
SecurityException - 如果安装了安全管理器并且它拒绝 NetPermission ("setResponseCache")
从以下版本开始：
1.5
另请参见：
getDefault()

get

public abstract CacheResponse get(URI uri,
                                  String rqstMethod,
                                  Map<String,List<String>> rqstHeaders)
                           throws IOException
根据请求的 uri、请求方法和请求头获取缓存的响应。通常，此方法由协议处理程序在发出获取网络资源的请求之前调用。如果返回缓存的响应，则改为使用该资源。

参数：
uri - 用于引用所请求的网络资源的 URI
rqstMethod - 表示请求方法的 String
rqstHeaders - 从请求头字段名称到表示当前请求头的字段值列表的映射
返回：
CacheResponse 实例，如果可从缓存中得到；否则返回 null
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果参数中的任何一个为 null
另请参见：
URLConnection.setUseCaches(boolean),
URLConnection.getUseCaches(),
URLConnection.setDefaultUseCaches(boolean),
URLConnection.getDefaultUseCaches()

put

public abstract CacheRequest put(URI uri,
                                 URLConnection conn)
                          throws IOException
协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。如果缓存资源，则 put() 必须返回 CacheRequest 对象，该对象包含协议处理程序用来将资源写入缓存的 WriteableByteChannel。如果不缓存资源，则 put 必须返回 null。

参数：
uri - 用于引用所请求的网络资源的 URI
conn - 用于获取要缓存的响应的 URLConnection 实例
返回：
用于记录要缓存的响应的 CacheRequest。返回 null 指示调用方不打算缓存响应。
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果参数中的任何一个为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecureCacheResponse (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 SecureCacheResponse

java.lang.Object
    继承者  java.net.CacheResponse
        继承者  java.net.SecureCacheResponse

public abstract class SecureCacheResponse
extends CacheResponse

表示最初通过安全方法（如 TLS）获得的缓存响应。

从以下版本开始：
1.5

构造方法摘要
SecureCacheResponse()
方法摘要
abstract String | getCipherSuite() 返回正在获得了网络资源的初始连接上使用的密码套件。
abstract List<Certificate> | getLocalCertificateChain() 返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。
abstract Principal | getLocalPrincipal() 返回在获得了网络资源的初始连接中的联络期间发送到服务器的主体。
abstract Principal | getPeerPrincipal() 返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。
abstract List<Certificate> | getServerCertificateChain() 从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。
从类 java.net.CacheResponse 继承的方法
getBody, getHeaders
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecureCacheResponse

public SecureCacheResponse()
方法详细信息

getCipherSuite

public abstract String getCipherSuite()
返回正在获得了网络资源的初始连接上使用的密码套件。

返回：
表示密码套件的字符串

getLocalCertificateChain

public abstract List<Certificate> getLocalCertificateChain()
返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。注：仅当使用基于证书的密码套件时此方法才有用。

返回：
表示发送到服务器的证书链的不可变证书列表。如果没有发送任何证书链，则返回 null。
另请参见：
getLocalPrincipal()

getServerCertificateChain

public abstract List<Certificate> getServerCertificateChain()
                                                     throws SSLPeerUnverifiedException
从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。注：仅当使用基于证书的密码套件时才可以使用此方法；将它与非基于证书的密码套件（如 Kerberos）一起使用将抛出 SSLPeerUnverifiedException。

返回：
表示服务器的证书链的不可变证书列表。
抛出：
SSLPeerUnverifiedException - 如果没有验证同位体。
另请参见：
getPeerPrincipal()

getPeerPrincipal

public abstract Principal getPeerPrincipal()
                                    throws SSLPeerUnverifiedException
返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。

返回：
服务器的主体。返回基于 X509 的密码套件的最终实体证书的 X500Principal，以及 Kerberos 的密码套件的 KerberosPrincipal。
抛出：
SSLPeerUnverifiedException - 如果没有验证同位体。
另请参见：
getServerCertificateChain(), getLocalPrincipal()

getLocalPrincipal

public abstract Principal getLocalPrincipal()
返回在获得了网络资源的初始连接中的联络期间发送到服务器的主体。

返回：
发送到服务器的主体。返回基于 X509 的密码套件的最终实体证书的 X500Principal，以及 Kerberos 的密码套件的 KerberosPrincipal。如果没有发送任何主体，则返回 null。
另请参见：
getLocalCertificateChain(), getPeerPrincipal()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerSocket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 ServerSocket

java.lang.Object
    继承者  java.net.ServerSocket
直接已知子类：
SSLServerSocket
public class ServerSocket
extends Object

此类实现服务器套接字。服务器套接字等待请求通过网络传入。它基于该请求执行某些操作，然后可能向请求者返回结果。

服务器套接字的实际工作由 SocketImpl 类的实例执行。应用程序可以更改创建套接字实现的套接字工厂来配置它自身，从而创建适合本地防火墙的套接字。

从以下版本开始：
JDK1.0
另请参见：
SocketImpl, setSocketFactory(java.net.SocketImplFactory), ServerSocketChannel

构造方法摘要
ServerSocket()
创建非绑定服务器套接字。
ServerSocket(int port)
创建绑定到特定端口的服务器套接字。
ServerSocket(int port, int backlog)
利用指定的 backlog 创建服务器套接字并将其绑定到指定的本地端口号。
ServerSocket(int port, int backlog, InetAddress bindAddr)
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。
方法摘要
Socket | accept() 侦听并接受到此套接字的连接。
void | bind(SocketAddress endpoint) 将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
void | bind(SocketAddress endpoint, int backlog) 将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
void | close() 关闭此套接字。
ServerSocketChannel | getChannel() 返回与此套接字关联的唯一 ServerSocketChannel 对象（如果有）。
InetAddress | getInetAddress() 返回此服务器套接字的本地地址。
int | getLocalPort() 返回此套接字在其上侦听的端口。
SocketAddress | getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
int | getReceiveBufferSize() 获取此 ServerSocket 的 SO_RCVBUF 选项的值，该值是将用于从此 ServerSocket 接受的套接字的建议缓冲区大小。
boolean | getReuseAddress() 测试是否启用 SO_REUSEADDR。
int | getSoTimeout() 获取 SO_TIMEOUT 的设置。
protected void | implAccept(Socket s) ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。
boolean | isBound() 返回 ServerSocket 的绑定状态。
boolean | isClosed() 返回 ServerSocket 的关闭状态。
void | setPerformancePreferences(int connectionTime, int latency, int bandwidth) 设置此 ServerSocket 的性能首选项。
void | setReceiveBufferSize(int size) 为从此 ServerSocket 接受的套接字的 SO_RCVBUF 选项设置默认建议值。
void | setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
static void | setSocketFactory(SocketImplFactory fac) 为应用程序设置服务器套接字实现工厂。
void | setSoTimeout(int timeout) 通过指定超时值启用/禁用 SO_TIMEOUT，以毫秒为单位。
String | toString() 作为 String 返回此套接字的实现地址和实现端口。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServerSocket

public ServerSocket()
             throws IOException
创建非绑定服务器套接字。

抛出：
IOException - 如果打开套接字时发生 IO 错误。

ServerSocket

public ServerSocket(int port)
             throws IOException
创建绑定到特定端口的服务器套接字。端口 0 在所有空闲端口上创建套接字。

传入连接指示（对连接的请求）的最大队列长度被设置为 50。如果队列满时收到连接指示，则拒绝该连接。

如果应用程序已指定服务器套接字工厂，则调用该工厂的 createSocketImpl 方法来创建实际套接字实现。否则创建“普通”套接字。

如果存在安全管理器，则首先使用 port 参数作为参数调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

参数：
port - 端口号；或者为 0，表示使用任何空闲端口。
抛出：
IOException - 如果打开套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
另请参见：
SocketImpl,
SocketImplFactory.createSocketImpl(),
setSocketFactory(java.net.SocketImplFactory),
SecurityManager.checkListen(int)

ServerSocket

public ServerSocket(int port,
                    int backlog)
             throws IOException
利用指定的 backlog 创建服务器套接字并将其绑定到指定的本地端口号。端口号 0 在所有空闲端口上创建套接字。

传入连接指示（对连接的请求）的最大队列长度被设置为 backlog 参数。如果队列满时收到连接指示，则拒绝该连接。

如果应用程序已指定服务器套接字工厂，则调用该工厂的 createSocketImpl 方法来创建实际套接字实现。否则创建“普通”套接字。

如果存在安全管理器，则首先使用 port 参数作为参数调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

backlog 参数必须是大于 0 的正值。如果传递的值等于或小于 0，则使用默认值。

参数：
port - 指定的端口；或者为 0，表示使用任何空闲端口。
backlog - 队列的最大长度。
抛出：
IOException - 如果打开套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
另请参见：
SocketImpl,
SocketImplFactory.createSocketImpl(),
setSocketFactory(java.net.SocketImplFactory),
SecurityManager.checkListen(int)

ServerSocket

public ServerSocket(int port,
                    int backlog,
                    InetAddress bindAddr)
             throws IOException
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。bindAddr 参数可以在 ServerSocket 的多宿主主机 (multi-homed host) 上使用，ServerSocket 仅接受对其地址之一的连接请求。如果 bindAddr 为 null，则默认接受任何/所有本地地址上的连接。端口必须在 0 到 65535 之间（包括两者）。

如果存在安全管理器，则此方法使用 port 作为参数调用其 checkListen 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

backlog 参数必须是大于 0 的正值。如果传递的值等于或小于 0，则使用默认值。

参数：
port - 本地 TCP 端口
backlog - 侦听 backlog
bindAddr - 要将服务器绑定到的 InetAddress
抛出：
SecurityException - 如果安全管理器存在并且其 checkListen 方法不允许进行该操作。
IOException - 如果打开套接字时发生 I/O 错误。
从以下版本开始：
JDK1.1
另请参见：
SocketOptions, SocketImpl, SecurityManager.checkListen(int)
方法详细信息

bind

public void bind(SocketAddress endpoint)
          throws IOException
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。

如果地址为 null，则系统将挑选一个临时端口和一个有效本地地址来绑定套接字。

参数：
endpoint - 要绑定的 IP 地址和端口号。
抛出：
IOException - 如果绑定操作失败或者已经绑定了套接字。
SecurityException - 如果 SecurityManager 存在并且其 checkListen 方法不允许该操作。
IllegalArgumentException - 如果端点是不受此套接字支持的 SocketAddress 子类
从以下版本开始：
1.4

bind

public void bind(SocketAddress endpoint,
                 int backlog)
          throws IOException
将 ServerSocket 绑定到特定地址（IP 地址和端口号）。

如果地址为 null，则系统将挑选一个临时端口和一个有效本地地址来绑定套接字。

backlog 参数必须是大于 0 的正值。如果传递的值等于或小于 0，则使用默认值。

参数：
endpoint - 要绑定的 IP 地址和端口号。
backlog - 侦听 backlog 长度。
抛出：
IOException - 如果绑定操作失败或者已经绑定了套接字。
SecurityException - 如果 SecurityManager 存在并且其 checkListen 方法不允许该操作。
IllegalArgumentException - 如果端点是不受此套接字支持的 SocketAddress 子类
从以下版本开始：
1.4

getInetAddress

public InetAddress getInetAddress()
返回此服务器套接字的本地地址。

返回：
将此套接字绑定到的地址；如果套接字是未绑定的，则返回 null。

getLocalPort

public int getLocalPort()
返回此套接字在其上侦听的端口。

返回：
此套接字侦听的端口号；如果尚未绑定套接字，则返回 -1。

getLocalSocketAddress

public SocketAddress getLocalSocketAddress()
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。

返回：
表示此套接字的本地端点的 SocketAddress，如果尚未绑定则返回 null。
从以下版本开始：
1.4
另请参见：
getInetAddress(),
getLocalPort(),
bind(SocketAddress)

accept

public Socket accept()
              throws IOException
侦听并接受到此套接字的连接。此方法在连接传入之前一直阻塞。

创建新套接字 s，如果存在安全管理器，则使用 s.getInetAddress().getHostAddress() 和 s.getPort() 作为参数调用安全管理器的 checkAccept 方法，以确保允许该操作。这可能会导致 SecurityException 异常。

返回：
新套接字
抛出：
IOException - 如果等待连接时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkAccept 方法不允许进行该操作。
SocketTimeoutException - 如果以前使用 setSoTimeout 设置了超时并且已到达超时值。
IllegalBlockingModeException - 如果此套接字具有关联的通道、通道处于非阻塞模式并且不存在准备接受的连接
另请参见：
SecurityManager.checkAccept(java.lang.String, int)

implAccept

protected final void implAccept(Socket s)
                         throws IOException
ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。因此，FooServerSocket 通常传递给此方法一个空 FooSocket。从 implAccept 返回时，FooSocket 将连接到客户端。

参数：
s - Socket
抛出：
IllegalBlockingModeException - 如果此套接字具有关联通道并且通道处于非阻塞模式
IOException - 如果在等待连接时发生 I/O 错误。
从以下版本开始：
JDK1.1

close

public void close()
           throws IOException
关闭此套接字。 在 accept() 中所有当前阻塞的线程都将会抛出 SocketException。

如果此套接字有一个与之关联的通道，则关闭该通道。

抛出：
IOException - 如果关闭套接字时发生 I/O 错误。

getChannel

public ServerSocketChannel getChannel()
返回与此套接字关联的唯一 ServerSocketChannel 对象（如果有）。

当且仅当通过 ServerSocketChannel.open 方法创建了通道本身时，服务器套接字才具有一个通道。

返回：
与此套接字关联的服务器套接字通道，如果没有为通道创建套接字，则返回 null。
从以下版本开始：
1.4

isBound

public boolean isBound()
返回 ServerSocket 的绑定状态。

返回：
如果将 ServerSocket 成功地绑定到一个地址，则返回 true
从以下版本开始：
1.4

isClosed

public boolean isClosed()
返回 ServerSocket 的关闭状态。

返回：
如果已经关闭了套接字，则返回 true
从以下版本开始：
1.4

setSoTimeout

public void setSoTimeout(int timeout)
                  throws SocketException
通过指定超时值启用/禁用 SO_TIMEOUT，以毫秒为单位。将此选项设为非零的超时值时，对此 ServerSocket 调用 accept() 将只阻塞此时间长度。如果超过超时值，将引发 java.net.SocketTimeoutException，虽然 ServerSocket 仍旧有效。选项必须在进入阻塞操作前被启用才能生效。超时值必须是 > 0 的数。超时值为 0 被解释为无穷大超时值。

参数：
timeout - 指定的超时（以毫秒为单位）
抛出：
SocketException - 如果在底层协议中存在错误，如 TCP 错误。
从以下版本开始：
JDK1.1
另请参见：
getSoTimeout()

getSoTimeout

public int getSoTimeout()
                 throws IOException
获取 SO_TIMEOUT 的设置。返回 0 意味着禁用了选项（即无穷大的超时值）。

返回：
SO_TIMEOUT 值
抛出：
IOException - 如果发生 I/O 错误
从以下版本开始：
JDK1.1
另请参见：
setSoTimeout(int)

setReuseAddress

public void setReuseAddress(boolean on)
                     throws SocketException
启用/禁用 SO_REUSEADDR 套接字选项。

关闭 TCP 连接时，该连接可能在关闭后的一段时间内保持超时状态（通常称为 TIME_WAIT 状态或 2MSL 等待状态）。对于使用已知套接字地址或端口的应用程序而言，如果存在处于超时状态的连接（包括地址和端口），可能不能将套接字绑定到所需的 SocketAddress。

在使用 bind(SocketAddress) 绑定套接字前启用 SO_REUSEADDR 可允许上一个连接处于超时状态时绑定套接字。

当创建 ServerSocket 时，SO_REUSEADDR 的初始设置是不确定的。应用程序可以使用 getReuseAddress() 来确定 SO_REUSEADDR 的初始设置。

在绑定套接字（请参阅 isBound()）后启用或禁用 SO_REUSEADDR 时的行为是不确定的。

参数：
on - 是否启用 SO_REUSEADDR 套接字选项
抛出：
SocketException - 如果启用或禁用 SO_RESUEADDR 套接字选项时发生错误，或者关闭了套接字。
从以下版本开始：
1.4
另请参见：
getReuseAddress(), bind(SocketAddress), isBound(), isClosed()

getReuseAddress

public boolean getReuseAddress()
                        throws SocketException
测试是否启用 SO_REUSEADDR。

返回：
指示是否启用 SO_REUSEADDR 的 boolean 值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.4
另请参见：
setReuseAddress(boolean)

toString

public String toString()
作为 String 返回此套接字的实现地址和实现端口。

覆盖：
类 Object 中的 toString
返回：
此套接字的字符串表示形式。

setSocketFactory

public static void setSocketFactory(SocketImplFactory fac)
                             throws IOException
为应用程序设置服务器套接字实现工厂。工厂只能指定一次。

当应用程序创建新的服务器套接字时，调用套接字实现工厂的 createSocketImpl 方法创建实际的套接字实现。

除非已经设置了工厂，否则向该方法传递 null 是无操作。

如果有安全管理器，则此方法首先调用安全管理器的 checkSetFactory 方法，以确保允许进行此操作。这可能会导致 SecurityException 异常。

参数：
fac - 所需的工厂。
抛出：
IOException - 如果设置套接字工厂时发生 I/O 错误。
SocketException - 如果已经定义该工厂。
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行该操作。
另请参见：
SocketImplFactory.createSocketImpl(), SecurityManager.checkSetFactory()

setReceiveBufferSize

public void setReceiveBufferSize(int size)
                          throws SocketException
为从此 ServerSocket 接受的套接字的 SO_RCVBUF 选项设置默认建议值。在接受的套接字中实际设置的值必须在 accept() 返回套接字后通过调用 Socket.getReceiveBufferSize() 确定。

SO_RCVBUF 的值用于设置内部套接字接收缓冲区的大小和设置公布到远程同位体的 TCP 接收窗口的大小。

随后可以通过调用 Socket.setReceiveBufferSize(int) 更改该值。但是，如果应用程序希望允许大于 RFC1323 中定义的 64K 字节的接收窗口，则在将 ServerSocket 绑定到本地地址之前必须在其中设置建议值。这意味着，必须用无参数构造方法创建 ServerSocket，然后必须调用 setReceiveBufferSize()，最后通过调用 bind() 将 ServerSocket 绑定到地址。

未能执行此操作不会导致错误，缓冲区大小可能被设置为所请求的值，但是从此 ServerSocket 中接受的套接字中的 TCP 接收窗口将不再大于 64K 字节。

参数：
size - 要设置的接收缓冲区大小。此值必须大于 0。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
IllegalArgumentException - 如果值为 0 或负。
从以下版本开始：
1.4
另请参见：
getReceiveBufferSize()

getReceiveBufferSize

public int getReceiveBufferSize()
                         throws SocketException
获取此 ServerSocket 的 SO_RCVBUF 选项的值，该值是将用于从此 ServerSocket 接受的套接字的建议缓冲区大小。

注意，在接受的套接字中实际设置的值通过调用 Socket.getReceiveBufferSize() 来确定。

返回：
此 Socket 的 SO_RCVBUF 选项的值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.4
另请参见：
setReceiveBufferSize(int)

setPerformancePreferences

public void setPerformancePreferences(int connectionTime,
                                      int latency,
                                      int bandwidth)
设置此 ServerSocket 的性能首选项。

默认情况下套接字使用 TCP/IP 协议。有些实现可能提供与 TCP/IP 具有不同性能特征的替代协议。此方法允许应用程序在实现从可用协议中作出选择时表明它自己关于应该如何进行折衷的首选项。

性能首选项由三个整数描述，它们的值分别指示短连接时间、低延迟和高带宽的相对重要性。这些整数的绝对值没有意义；为了选择协议，需要简单地比较它们的值，较大的值指示更强的首选项。例如，如果应用程序相对于低延迟和高带宽更希望短连接时间，则其可以使用值 (1, 0, 0) 调用此方法。如果应用程序相对于低延迟更希望高带宽，且相对于短连接时间更希望低延迟，则其可以使用值 (0, 1, 2) 调用此方法。

在绑定套接字后调用此方法无效。这意味着，需要利用无参数构造方法创建套接字才能使用此功能。

参数：
connectionTime - 表明短连接时间的相对重要性的 int
latency - 表明低延迟的相对重要性的 int
bandwidth - 表明高带宽的相对重要性的 int
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Socket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 Socket

java.lang.Object
    继承者  java.net.Socket
直接已知子类：
SSLSocket
public class Socket
extends Object

此类实现客户端套接字（也可以就叫“套接字”）。套接字是两台机器间通信的端点。

套接字的实际工作由 SocketImpl 类的实例执行。应用程序通过更改创建套接字实现的套接字工厂可以配置它自身，以创建适合本地防火墙的套接字。

从以下版本开始：
JDK1.0
另请参见：
setSocketImplFactory(java.net.SocketImplFactory), SocketImpl, SocketChannel

构造方法摘要
 | Socket() 通过系统默认类型的 SocketImpl 创建未连接套接字
 | Socket(InetAddress address, int port) 创建一个流套接字并将其连接到指定 IP 地址的指定端口号。
 | Socket(InetAddress host, int port, boolean stream) 已过时。 Use DatagramSocket instead for UDP transport.
 | Socket(InetAddress address, int port, InetAddress localAddr, int localPort) 创建一个套接字并将其连接到指定远程地址上的指定远程端口。
 | Socket(Proxy proxy) 创建一个未连接的套接字并指定代理类型（如果有），该代理不管其他设置如何都应被使用。
protected | Socket(SocketImpl impl) 使用用户指定的 SocketImpl 创建一个未连接 Socket。
 | Socket(String host, int port) 创建一个流套接字并将其连接到指定主机上的指定端口号。
 | Socket(String host, int port, boolean stream) 已过时。 使用 DatagramSocket 取代 UDP 传输。
 | Socket(String host, int port, InetAddress localAddr, int localPort) 创建一个套接字并将其连接到指定远程主机上的指定远程端口。
方法摘要
void | bind(SocketAddress bindpoint) 将套接字绑定到本地地址。
void | close() 关闭此套接字。
void | connect(SocketAddress endpoint) 将此套接字连接到服务器。
void | connect(SocketAddress endpoint, int timeout) 将此套接字连接到服务器，并指定一个超时值。
SocketChannel | getChannel() 返回与此数据报套接字关联的唯一 SocketChannel 对象（如果有）。
InetAddress | getInetAddress() 返回套接字连接的地址。
InputStream | getInputStream() 返回此套接字的输入流。
boolean | getKeepAlive() 测试是否启用 SO_KEEPALIVE。
InetAddress | getLocalAddress() 获取套接字绑定的本地地址。
int | getLocalPort() 返回此套接字绑定到的本地端口。
SocketAddress | getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
boolean | getOOBInline() 测试是否启用 OOBINLINE。
OutputStream | getOutputStream() 返回此套接字的输出流。
int | getPort() 返回此套接字连接到的远程端口。
int | getReceiveBufferSize() 获取此 Socket 的 SO_RCVBUF 选项的值，该值是平台在 Socket 上输入时使用的缓冲区大小。
SocketAddress | getRemoteSocketAddress() 返回此套接字连接的端点的地址，如果未连接则返回 null。
boolean | getReuseAddress() 测试是否启用 SO_REUSEADDR。
int | getSendBufferSize() 获取此 Socket 的 SO_SNDBUF 选项的值，该值是平台在 Socket 上输出时使用的缓冲区大小。
int | getSoLinger() 返回 SO_LINGER 的设置。
int | getSoTimeout() 返回 SO_TIMEOUT 的设置。
boolean | getTcpNoDelay() 测试是否启用 TCP_NODELAY。
int | getTrafficClass() 为从此 Socket 上发送的包获取 IP 头中的流量类别或服务类型。
boolean | isBound() 返回套接字的绑定状态。
boolean | isClosed() 返回套接字的关闭状态。
boolean | isConnected() 返回套接字的连接状态。
boolean | isInputShutdown() 返回是否关闭套接字连接的半读状态 (read-half)。
boolean | isOutputShutdown() 返回是否关闭套接字连接的半写状态 (write-half)。
void | sendUrgentData(int data) 在套接字上发送一个紧急数据字节。
void | setKeepAlive(boolean on) 启用/禁用 SO_KEEPALIVE。
void | setOOBInline(boolean on) 启用/禁用 OOBINLINE（TCP 紧急数据的接收者） 默认情况下，此选项是禁用的，即在套接字上接收的 TCP 紧急数据被静默丢弃。
void | setPerformancePreferences(int connectionTime, int latency, int bandwidth) 设置此套接字的性能偏好。
void | setReceiveBufferSize(int size) 将此 Socket 的 SO_RCVBUF 选项设置为指定的值。
void | setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | setSendBufferSize(int size) 将此 Socket 的 SO_SNDBUF 选项设置为指定的值。
static void | setSocketImplFactory(SocketImplFactory fac) 为应用程序设置客户端套接字实现工厂。
void | setSoLinger(boolean on, int linger) 启用/禁用具有指定逗留时间（以秒为单位）的 SO_LINGER。
void | setSoTimeout(int timeout) 启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
void | setTcpNoDelay(boolean on) 启用/禁用 TCP_NODELAY（启用/禁用 Nagle 算法）。
void | setTrafficClass(int tc) 为从此 Socket 上发送的包在 IP 头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
void | shutdownInput() 此套接字的输入流置于“流的末尾”。
void | shutdownOutput() 禁用此套接字的输出流。
String | toString() 将此套接字转换为 String。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Socket

public Socket()
通过系统默认类型的 SocketImpl 创建未连接套接字

从以下版本开始：
JDK1.1

Socket

public Socket(Proxy proxy)
创建一个未连接的套接字并指定代理类型（如果有），该代理不管其他设置如何都应被使用。

如果有安全管理器，则使用代理主机地址和端口号作为参数调用其 checkConnect 方法。这可能会导致 SecurityException 异常。

示例：

  • Socket s = new Socket(Proxy.NO_PROXY); 将创建忽略任何其他代理配置的普通套接字。
  • Socket s = new Socket(new Proxy(Proxy.Type.SOCKS, new InetSocketAddress("socks.mydom.com", 1080))); 将创建通过指定的 SOCKS 代理服务器进行连接的套接字。

参数：
proxy - 指定应使用的代理种类的 Proxy 对象。
抛出：
IllegalArgumentException - 如果代理的类型无效或者为 null。
SecurityException - 如果存在安全管理器，但拒绝连接到代理的权限。
从以下版本开始：
1.5
另请参见：
ProxySelector, Proxy

Socket

protected Socket(SocketImpl impl)
          throws SocketException
使用用户指定的 SocketImpl 创建一个未连接 Socket。

参数：
impl - 子类希望在 Socket 上使用的 SocketImpl 的实例。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
JDK1.1

Socket

public Socket(String host,
              int port)
       throws UnknownHostException,
              IOException
创建一个流套接字并将其连接到指定主机上的指定端口号。

如果指定的主机为 null，则等效于指定与 InetAddress.getByName(null) 相同的地址。换句话话，等效于指定回送接口的地址。

如果应用程序已指定服务器套接字工厂，则调用该工厂的 createSocketImpl 方法来创建实际套接字实现。否则创建“普通”套接字。

如果有安全管理器，则使用主机地址和 port 作为参数调用其 checkConnect 方法。这可能会导致 SecurityException 异常。

参数：
host - 主机名，或者为 null，表示回送地址。
port - 端口号。
抛出：
UnknownHostException - 如果无法确定主机的 IP 地址。
IOException - 如果创建套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作。
另请参见：
setSocketImplFactory(java.net.SocketImplFactory), SocketImpl, SocketImplFactory.createSocketImpl(), SecurityManager.checkConnect(java.lang.String, int)

Socket

public Socket(InetAddress address,
              int port)
       throws IOException
创建一个流套接字并将其连接到指定 IP 地址的指定端口号。

如果应用程序已指定套接字工厂，则调用该工厂的 createSocketImpl 方法来创建实际套接字实现。否则创建“普通”套接字。

如果有安全管理器，则使用主机地址和 port 作为参数调用其 checkConnect 方法。这可能会导致 SecurityException 异常。

参数：
address - IP 地址。
port - 端口号。
抛出：
IOException - 如果创建套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作。
另请参见：
setSocketImplFactory(java.net.SocketImplFactory), SocketImpl, SocketImplFactory.createSocketImpl(), SecurityManager.checkConnect(java.lang.String, int)

Socket

public Socket(String host,
              int port,
              InetAddress localAddr,
              int localPort)
       throws IOException
创建一个套接字并将其连接到指定远程主机上的指定远程端口。socket 会通过调用 bind() 函数来绑定提供的本地地址及端口。

如果指定的主机为 null，则等效于指定与 InetAddress.getByName(null) 相同的地址。换句话话，等效于指定回送接口的地址。

如果有安全管理器，则使用主机地址和 port 作为参数调用其 checkConnect 方法。这可能会导致 SecurityException 异常。

参数：
host - 远程主机名，或者为 null，表示回送地址。
port - 远程端口
localAddr - 要将套接字绑定到的本地地址
localPort - 要将套接字绑定到的本地端口
抛出：
IOException - 如果在创建套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作。
从以下版本开始：
JDK1.1
另请参见：
SecurityManager.checkConnect(java.lang.String, int)

Socket

public Socket(InetAddress address,
              int port,
              InetAddress localAddr,
              int localPort)
       throws IOException
创建一个套接字并将其连接到指定远程地址上的指定远程端口。socket 会通过调用 bind() 函数来绑定提供的本地地址及端口。

如果有安全管理器，则使用主机地址和 port 作为参数调用其 checkConnect 方法。这可能会导致 SecurityException 异常。

参数：
address - 远程地址
port - 远程端口
localAddr - 要将套接字绑定到的本地地址
localPort - 要将套接字绑定到的本地端口
抛出：
IOException - 如果在创建套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作。
从以下版本开始：
JDK1.1
另请参见：
SecurityManager.checkConnect(java.lang.String, int)

Socket

@Deprecated
public Socket(String host,
                         int port,
                         boolean stream)
       throws IOException
已过时。 使用 DatagramSocket 取代 UDP 传输。

创建一个流套接字并将其连接到指定主机上的指定端口号。

如果指定的主机为 null，则等效于指定与 InetAddress.getByName(null) 相同的地址。换句话话，等效于指定回送接口的地址。

如果流参数为 true，则创建流套接字。如果流参数为 false，则创建数据报套接字。

如果应用程序已指定服务器套接字工厂，则调用该工厂的 createSocketImpl 方法来创建实际套接字实现。否则创建“普通”套接字。

如果有安全管理器，则使用主机地址和 port 作为参数调用其 checkConnect 方法。这可能会导致 SecurityException 异常。

如果使用 UDP 套接字，则不应用与 TCP/IP 相关的套接字选项。

参数：
host - 主机名，或者为 null，表示回送地址。
port - 端口号。
stream - 指示此为流套接字还是数据报套接字的 boolean。
抛出：
IOException - 如果创建套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作。
另请参见：
setSocketImplFactory(java.net.SocketImplFactory), SocketImpl, SocketImplFactory.createSocketImpl(), SecurityManager.checkConnect(java.lang.String, int)

Socket

@Deprecated
public Socket(InetAddress host,
                         int port,
                         boolean stream)
       throws IOException
已过时。 Use DatagramSocket instead for UDP transport.

创建一个套接字并将其连接到指定 IP 地址的指定端口号。

如果流参数为 true，则创建流套接字。如果流参数为 false，则创建数据报套接字。

如果应用程序已指定服务器套接字工厂，则调用该工厂的 createSocketImpl 方法来创建实际套接字实现。否则创建“普通”套接字。

如果有安全管理器，则使用 host.getHostAddress() 和 port 作为参数调用其 checkConnect 方法。这可能会导致 SecurityException 异常。

如果使用 UDP 套接字，则不应用与 TCP/IP 相关的套接字选项。

参数：
host - IP 地址。
port - 端口号。
stream - 如果为 true，则创建流套接字；否则创建数据报套接字。
抛出：
IOException - 如果创建套接字时发生 I/O 错误。
SecurityException - 如果安全管理器存在并且其 checkConnect 方法不允许进行该操作。
另请参见：
setSocketImplFactory(java.net.SocketImplFactory), SocketImpl, SocketImplFactory.createSocketImpl(), SecurityManager.checkConnect(java.lang.String, int)
方法详细信息

connect

public void connect(SocketAddress endpoint)
             throws IOException
将此套接字连接到服务器。

参数：
endpoint - SocketAddress
抛出：
IOException - 如果在连接期间发生错误
IllegalBlockingModeException - 如果此套接字具有关联的通道并且该通道处于非阻塞模式
IllegalArgumentException - 如果端点为 null 或者此套接字不支持 SocketAddress 子类
从以下版本开始：
1.4

connect

public void connect(SocketAddress endpoint,
                    int timeout)
             throws IOException
将此套接字连接到服务器，并指定一个超时值。超时值零被解释为无限超时。在建立连接或者发生错误之前，连接一直处于阻塞状态。

参数：
endpoint - SocketAddress
timeout - 要使用的超时值（以毫秒为单位）。
抛出：
IOException - 如果在连接期间发生错误
SocketTimeoutException - 如果在连接之前超时期满
IllegalBlockingModeException - 如果此套接字具有关联的通道并且该通道处于非阻塞模式
IllegalArgumentException - 如果端点为 null 或者此套接字不支持 SocketAddress 子类
从以下版本开始：
1.4

bind

public void bind(SocketAddress bindpoint)
          throws IOException
将套接字绑定到本地地址。

如果地址为 null，则系统将挑选一个临时端口和一个有效本地地址来绑定套接字。

参数：
bindpoint - 要绑定到的 SocketAddress
抛出：
IOException - 如果绑定操作失败或者已经绑定了套接字。
IllegalArgumentException - 如果 bindpoint 是不受此套接字支持的 SocketAddress 子类。
从以下版本开始：
1.4
另请参见：
isBound()

getInetAddress

public InetAddress getInetAddress()
返回套接字连接的地址。

返回：
此套接字连接到的远程 IP 地址；如果套接字是未连接的，则返回 null。

getLocalAddress

public InetAddress getLocalAddress()
获取套接字绑定的本地地址。

返回：
将套接字绑定到的本地地址；如果尚未绑定套接字，则返回 InetAddress.anyLocalAddress()。
从以下版本开始：
JDK1.1

getPort

public int getPort()
返回此套接字连接到的远程端口。

返回：
此套接字连接到的远程端口号；如果尚未连接套接字，则返回 0。

getLocalPort

public int getLocalPort()
返回此套接字绑定到的本地端口。

返回：
此套接字绑定到的本地端口号；如果尚未绑定套接字，则返回 -1。

getRemoteSocketAddress

public SocketAddress getRemoteSocketAddress()
返回此套接字连接的端点的地址，如果未连接则返回 null。

返回：
表示此套接字远程端点的 SocketAddress，如果尚未连接则返回 null。
从以下版本开始：
1.4
另请参见：
getInetAddress(),
getPort(),
connect(SocketAddress, int),
connect(SocketAddress)

getLocalSocketAddress

public SocketAddress getLocalSocketAddress()
返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。

返回：
表示此套接字的本地端点的 SocketAddress，如果尚未绑定则返回 null。
从以下版本开始：
1.4
另请参见：
getLocalAddress(),
getLocalPort(),
bind(SocketAddress)

getChannel

public SocketChannel getChannel()
返回与此数据报套接字关联的唯一 SocketChannel 对象（如果有）。

当且仅当通过 SocketChannel.open 或 ServerSocketChannel.accept 方法创建了通道本身时，套接字才具有一个通道。

返回：
与此套接字关联的套接字通道，如果没有为通道创建套接字，则返回 null。
从以下版本开始：
1.4

getInputStream

public InputStream getInputStream()
                           throws IOException
返回此套接字的输入流。

如果此套接字具有关联的通道，则所得的输入流会将其所有操作委托给通道。如果通道为非阻塞模式，则输入流的 read 操作将抛出 IllegalBlockingModeException。

在非正常条件下，底层连接可能被远程主机或网络软件中断（例如，TCP 连接情况下的连接重置）。当网络软件检测到中断的连接时，将对返回的输入流应用以下操作：

  • 网络软件可能丢弃经过套接字缓冲的字节。网络软件没有丢弃的字节可以使用 read 读取。

  • 如果没有任何字节在套接字上缓冲，或者 read 已经消耗了所有缓冲的字节，则对 read 的所有后续调用都将抛出 IOException。

  • 如果没有任何字节在套接字上缓冲，并且没有使用 close 关闭套接字，则 available 将返回 0。

关闭返回的 InputStream 将关闭关联套接字。

返回：
从此套接字读取字节的输入流。
抛出：
IOException - 如果在创建输入流时发生 I/O 错误、没有关闭套接字、没有连接套接字或者使用 shutdownInput() 关闭了套接字输入

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
返回此套接字的输出流。

如果此套接字具有关联的通道，则得到的输出流会将其所有操作委托给通道。如果通道为非阻塞模式，则输出流的 write 操作将抛出 IllegalBlockingModeException。

关闭返回的 OutputStream 将关闭关联套接字。

返回：
将字节写入此套接字的输出流。
抛出：
IOException - 如果创建输出流时发生 I/O 错误或者没有连接套接字。

setTcpNoDelay

public void setTcpNoDelay(boolean on)
                   throws SocketException
启用/禁用 TCP_NODELAY（启用/禁用 Nagle 算法）。

参数：
on - 为 true 表示启用 TCP_NODELAY；为 false 表示禁用。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
JDK1.1
另请参见：
getTcpNoDelay()

getTcpNoDelay

public boolean getTcpNoDelay()
                      throws SocketException
测试是否启用 TCP_NODELAY。

返回：
指示是否启用 TCP_NODELAY 的 boolean 值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
JDK1.1
另请参见：
setTcpNoDelay(boolean)

setSoLinger

public void setSoLinger(boolean on,
                        int linger)
                 throws SocketException
启用/禁用具有指定逗留时间（以秒为单位）的 SO_LINGER。最大超时值是特定于平台的。 该设置仅影响套接字关闭。

参数：
on - 是否逗留。
linger - 逗留时间，如果 on 为 true。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
IllegalArgumentException - 如果逗留值为负。
从以下版本开始：
JDK1.1
另请参见：
getSoLinger()

getSoLinger

public int getSoLinger()
                throws SocketException
返回 SO_LINGER 的设置。返回 -1 意味着禁用该选项。 该设置仅影响套接字关闭。

返回：
SO_LINGER 的设置。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
JDK1.1
另请参见：
setSoLinger(boolean, int)

sendUrgentData

public void sendUrgentData(int data)
                    throws IOException
在套接字上发送一个紧急数据字节。要发送的字节是数据参数的八个最低位。紧急字节在对套接字 OutputStream 的所有预先写入之后但在任何以后写入之前发送。

参数：
data - 要发送的数据字节
抛出：
IOException - 如果发送数据时发生错误。
从以下版本开始：
1.4

setOOBInline

public void setOOBInline(boolean on)
                  throws SocketException
启用/禁用 OOBINLINE（TCP 紧急数据的接收者） 默认情况下，此选项是禁用的，即在套接字上接收的 TCP 紧急数据被静默丢弃。如果用户希望接收到紧急数据，则必须启用此选项。启用时，可以将紧急数据内嵌在普通数据中接收

注意，仅为处理传入紧急数据提供有限支持。特别要指出的是，不提供传入紧急数据的任何通知并且不存在区分普通数据和紧急数据的功能（除非更高级别的协议提供）。

参数：
on - true 表示启用 OOBINLINE；false 表示禁用。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.4
另请参见：
getOOBInline()

getOOBInline

public boolean getOOBInline()
                     throws SocketException
测试是否启用 OOBINLINE。

返回：
指示是否启用 OOBINLINE 的 boolean 值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.4
另请参见：
setOOBInline(boolean)

setSoTimeout

public void setSoTimeout(int timeout)
                  throws SocketException
启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。将此选项设为非零的超时值时，在与此 Socket 关联的 InputStream 上调用 read() 将只阻塞此时间长度。如果超过超时值，将引发 java.net.SocketTimeoutException，虽然 Socket 仍旧有效。选项必须在进入阻塞操作前被启用才能生效。超时值必须是 > 0 的数。超时值为 0 被解释为无穷大超时值。

参数：
timeout - 指定的以毫秒为单位的超时值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
JDK 1.1
另请参见：
getSoTimeout()

getSoTimeout

public int getSoTimeout()
                 throws SocketException
返回 SO_TIMEOUT 的设置。返回 0 意味着禁用了选项（即无穷大的超时值）。

返回：
SO_TIMEOUT 的设置。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
JDK1.1
另请参见：
setSoTimeout(int)

setSendBufferSize

public void setSendBufferSize(int size)
                       throws SocketException
将此 Socket 的 SO_SNDBUF 选项设置为指定的值。平台的网络连接代码将 SO_SNDBUF 选项用作设置底层网络 I/O 缓存的大小的提示。

由于 SO_SNDBUF 是一种提示，想要验证缓冲区设置大小的应用程序应该调用 getSendBufferSize()。

参数：
size - 将设置的发送缓冲区大小。此值必须大于 0。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
IllegalArgumentException - 如果值为 0 或负。
从以下版本开始：
1.2
另请参见：
getSendBufferSize()

getSendBufferSize

public int getSendBufferSize()
                      throws SocketException
获取此 Socket 的 SO_SNDBUF 选项的值，该值是平台在 Socket 上输出时使用的缓冲区大小。

返回：
此 Socket 的 SO_SNDBUF 选项的值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.2
另请参见：
setSendBufferSize(int)

setReceiveBufferSize

public void setReceiveBufferSize(int size)
                          throws SocketException
将此 Socket 的 SO_RCVBUF 选项设置为指定的值。平台的网络连接代码将 SO_RCVBUF 选项用作设置底层网络 I/O 缓存的大小的提示。

增大接收缓存大小可以增大大量连接的网络 I/O 的性能，而减小它有助于减少传入数据的 backlog。

由于 SO_RCVBUF 是一种提示，想要验证缓冲区设置大小的应用程序应该调用 getReceiveBufferSize()。

SO_RCVBUF 的值还用于设置公布到远程同位体的 TCP 接收窗口。一般情况下，当连接套接字时，可以在任意时间更改窗口大小。然而，如果需要的接收窗口大于 64K，则必须在将套接字连接到远程同位体之前请求。下面是需要知道的两种情况：

  1. 对于从 ServerSocket 接受的套接字，必须在将 ServerSocket 绑定到本地地址前通过调用 ServerSocket.setReceiveBufferSize(int) 执行此操作。

  2. 对于客户端套接字，则必须在将套接字连接到其远程同位体前调用 setReceiveBufferSize()。

参数：
size - 要设置的接收缓冲区大小。此值必须大于 0。
抛出：
IllegalArgumentException - 如果值为 0 或负。
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.2
另请参见：
getReceiveBufferSize(), ServerSocket.setReceiveBufferSize(int)

getReceiveBufferSize

public int getReceiveBufferSize()
                         throws SocketException
获取此 Socket 的 SO_RCVBUF 选项的值，该值是平台在 Socket 上输入时使用的缓冲区大小。

返回：
此 Socket 的 SO_RCVBUF 选项的值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.2
另请参见：
setReceiveBufferSize(int)

setKeepAlive

public void setKeepAlive(boolean on)
                  throws SocketException
启用/禁用 SO_KEEPALIVE。

参数：
on - 是否开启保持活动状态的套接字。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.3
另请参见：
getKeepAlive()

getKeepAlive

public boolean getKeepAlive()
                     throws SocketException
测试是否启用 SO_KEEPALIVE。

返回：
指示是否启用 SO_KEEPALIVE 的 boolean 值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.3
另请参见：
setKeepAlive(boolean)

setTrafficClass

public void setTrafficClass(int tc)
                     throws SocketException
为从此 Socket 上发送的包在 IP 头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。由于底层网络实现可能忽略此值，应用程序应该将其视为一种提示。

tc 的值必须在 0 <= tc <= 255 范围内，否则将抛出 IllegalArgumentException。

注：

对于 Internet Protocol v4 该值由包含优先级和 TOS 字段的八位组组成，这在 RFC 1349 中有详细叙述。TOS 字段是由以下逐位或所得值创建的位集：

  • IPTOS_LOWCOST (0x02)
  • IPTOS_RELIABILITY (0x04)
  • IPTOS_THROUGHPUT (0x08)
  • IPTOS_LOWDELAY (0x10)
末尾的最低位常常被忽略，因为该位对应于 MBZ（必须为 0）位。

设置优先级字段中的位可能导致 SocketException，指示不允许该操作。

根据 RFC 1122 第 4.2.4.2 节中的指示，兼容的 TCP 实现应该（但不是必须）让应用程序在连接的生命周期中改变 TOS 字段。因此，type-of-service（服务类型）字段在已建立 TCP 连接之后能否更改取决于底层平台的实现。应用程序不应假定它们在连接之后能够改变 TOS 字段。

对于 Internet Protocol v6 tc 是将被放置到 IP 头部的 sin6_flowinfo 字段中的值。

参数：
tc - 此位集的 int 值。
抛出：
SocketException - 如果设置流量类别或服务类型时出现错误
从以下版本开始：
1.4
另请参见：
getTrafficClass()

getTrafficClass

public int getTrafficClass()
                    throws SocketException
为从此 Socket 上发送的包获取 IP 头中的流量类别或服务类型。

由于底层网络实现可能忽略使用 setTrafficClass(int) 设置的流量类别或服务类型，因而此方法可能返回一个不同于以前用 setTrafficClass(int) 在此 Socket 上设置的值。

返回：
已经设置的流量类别或服务类型
抛出：
SocketException - 如果获取流量类别或服务类型值时出现错误。
从以下版本开始：
1.4
另请参见：
setTrafficClass(int)

setReuseAddress

public void setReuseAddress(boolean on)
                     throws SocketException
启用/禁用 SO_REUSEADDR 套接字选项。

关闭 TCP 连接时，该连接可能在关闭后的一段时间内保持超时状态（通常称为 TIME_WAIT 状态或 2MSL 等待状态）。对于使用已知套接字地址或端口的应用程序而言，如果存在处于超时状态的连接（包括地址和端口），可能不能将套接字绑定到所需的 SocketAddress 上。

使用 bind(SocketAddress) 绑定套接字前启用 SO_REUSEADDR 允许在上一个连接处于超时状态时绑定套接字。

当创建 Socket 时，禁用 SO_REUSEADDR 的初始设置。

在绑定套接字（请参阅 isBound()）后启用或禁用 SO_REUSEADDR 时的行为是不确定的。

参数：
on - 是否启用 SO_REUSEADDR 套接字选项
抛出：
SocketException - 如果启用或禁用 SO_RESUEADDR 套接字选项时发生错误，或者关闭了套接字。
从以下版本开始：
1.4
另请参见：
getReuseAddress(), bind(SocketAddress), isClosed(), isBound()

getReuseAddress

public boolean getReuseAddress()
                        throws SocketException
测试是否启用 SO_REUSEADDR。

返回：
指示是否启用 SO_REUSEADDR 的 boolean 值。
抛出：
SocketException - 如果底层协议出现错误，例如 TCP 错误。
从以下版本开始：
1.4
另请参见：
setReuseAddress(boolean)

close

public void close()
           throws IOException
关闭此套接字。

所有当前阻塞于此套接字上的 I/O 操作中的线程都将抛出 SocketException。

套接字被关闭后，便不可在以后的网络连接中使用（即无法重新连接或重新绑定）。需要创建新的套接字。

关闭此套接字也将会关闭该套接字的 InputStream 和 OutputStream。

如果此套接字有一个与之关联的通道，则关闭该通道。

抛出：
IOException - 如果关闭此套接字时发生 I/O 错误。
另请参见：
isClosed()

shutdownInput

public void shutdownInput()
                   throws IOException
此套接字的输入流置于“流的末尾”。发送到套接字的输入流端的任何数据都将被确认然后被静默丢弃。

如果在套接字上调用 shutdownInput() 后从套接字输入流读取内容，则流将返回 EOF（文件结束符）。

抛出：
IOException - 如果关闭此套接字时发生 I/O 错误。
从以下版本开始：
1.3
另请参见：
shutdownOutput(),
close(),
setSoLinger(boolean, int),
isInputShutdown()

shutdownOutput

public void shutdownOutput()
                    throws IOException
禁用此套接字的输出流。对于 TCP 套接字，任何以前写入的数据都将被发送，并且后跟 TCP 的正常连接终止序列。 如果在套接字上调用 shutdownOutput() 后写入套接字输出流，则该流将抛出 IOException。

抛出：
IOException - 如果关闭此套接字时发生 I/O 错误。
从以下版本开始：
1.3
另请参见：
shutdownInput(),
close(),
setSoLinger(boolean, int),
isOutputShutdown()

toString

public String toString()
将此套接字转换为 String。

覆盖：
类 Object 中的 toString
返回：
此套接字的字符串表示形式。

isConnected

public boolean isConnected()
返回套接字的连接状态。

返回：
如果将套接字成功地连接到服务器，则为 true。
从以下版本开始：
1.4

isBound

public boolean isBound()
返回套接字的绑定状态。

返回：
如果将套接字成功地绑定到一个地址，则返回 true
从以下版本开始：
1.4
另请参见：
bind(java.net.SocketAddress)

isClosed

public boolean isClosed()
返回套接字的关闭状态。

返回：
如果已经关闭了套接字，则返回 true
从以下版本开始：
1.4
另请参见：
close()

isInputShutdown

public boolean isInputShutdown()
返回是否关闭套接字连接的半读状态 (read-half)。

返回：
如果已关闭套接字的输入，则返回 true
从以下版本开始：
1.4
另请参见：
shutdownInput()

isOutputShutdown

public boolean isOutputShutdown()
返回是否关闭套接字连接的半写状态 (write-half)。

返回：
如果已关闭套接字的输出，则返回 true
从以下版本开始：
1.4
另请参见：
shutdownOutput()

setSocketImplFactory

public static void setSocketImplFactory(SocketImplFactory fac)
                                 throws IOException
为应用程序设置客户端套接字实现工厂。工厂只能指定一次。

当应用程序创建新的客户端套接字时，调用套接字实现工厂的 createSocketImpl 方法创建实际的套接字实现。

除非已经设置了工厂，否则向该方法传递 null 是无操作。

如果有安全管理器，则此方法首先调用安全管理器的 checkSetFactory 方法，以确保允许进行该操作。这可能会导致 SecurityException 异常。

参数：
fac - 所需的工厂。
抛出：
IOException - 如果设置套接字工厂时发生 I/O 错误。
SocketException - 如果已经定义该工厂。
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行该操作。
另请参见：
SocketImplFactory.createSocketImpl(), SecurityManager.checkSetFactory()

setPerformancePreferences

public void setPerformancePreferences(int connectionTime,
                                      int latency,
                                      int bandwidth)
设置此套接字的性能偏好。

默认情况下套接字使用 TCP/IP 协议。有些实现可能提供与 TCP/IP 具有不同性能特征的替换协议。此方法允许应用程序在实现从可用协议中作出选择时表达它自己关于应该如何进行折衷的偏好。

性能偏好由三个整数描述，它们的值分别指示短连接时间、低延迟和高带宽的相对重要性。这些整数的绝对值没有意义；为了选择协议，需要简单比较它们的值，较大的值指示更强的偏好。负值表示的优先级低于正值。例如，如果应用程序相对于低延迟和高带宽更偏好短连接时间，则其可以使用值 (1, 0, 0) 调用此方法。如果应用程序相对于低延迟更偏好高带宽，而相对于短连接时间更偏好低延迟，则其可以使用值 (0, 1, 2) 调用此方法。

在连接套接字后调用此方法无效。

参数：
connectionTime - 表达短连接时间的相对重要性的 int
latency - 表达低延迟的相对重要性的 int
bandwidth - 表达高带宽的相对重要性的 int
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketAddress (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 SocketAddress

java.lang.Object
    继承者  java.net.SocketAddress
所有已实现的接口：
Serializable
直接已知子类：
InetSocketAddress
public abstract class SocketAddress
extends Object
implements Serializable

此类表示不带任何协议附件的 Socket Address。作为一个抽象类，应通过特定的、协议相关的实现为其创建子类。

它提供不可变对象，供套接字用于绑定、连接或用作返回值。

从以下版本开始：
1.4
另请参见：
Socket, ServerSocket, 序列化表格

构造方法摘要
SocketAddress()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SocketAddress

public SocketAddress()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 SocketException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.SocketException
所有已实现的接口：
Serializable
直接已知子类：
BindException, ConnectException, NoRouteToHostException, PortUnreachableException
public class SocketException
extends IOException

抛出此异常指示在底层协议中存在错误，如 TCP 错误。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
SocketException()
构造不带详细消息的新 SocketException。
SocketException(String msg)
构造带指定详细消息的新 SocketException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SocketException

public SocketException(String msg)
构造带指定详细消息的新 SocketException。

参数：
msg - 详细消息。

SocketException

public SocketException()
构造不带详细消息的新 SocketException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 SocketImpl

java.lang.Object
    继承者  java.net.SocketImpl
所有已实现的接口：
SocketOptions
public abstract class SocketImpl
extends Object
implements SocketOptions

抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。创建客户端和服务器套接字都可以使用它。

“普通”套接字严格按描述实现这些方法，无需尝试通过防火墙或代理。

从以下版本开始：
JDK1.0

字段摘要
protected InetAddress | address 此套接字的远程端点的 IP 地址。
protected FileDescriptor | fd 此套接字的文件描述符对象。
protected int | localport 此套接字连接到的本地端口号。
protected int | port 此套接字连接到的远程主机的端口号。
从接口 java.net.SocketOptions 继承的字段
IP_MULTICAST_IF, IP_MULTICAST_IF2, IP_MULTICAST_LOOP, IP_TOS, SO_BINDADDR, SO_BROADCAST, SO_KEEPALIVE, SO_LINGER, SO_OOBINLINE, SO_RCVBUF, SO_REUSEADDR, SO_SNDBUF, SO_TIMEOUT, TCP_NODELAY
构造方法摘要
SocketImpl()
方法摘要
protected abstract void | accept(SocketImpl s) 接受连接。
protected abstract int | available() 返回可以不受阻塞地从此套接字中读取的字节数。
protected abstract void | bind(InetAddress host, int port) 将此套接字绑定到指定的本地 IP 地址和端口号。
protected abstract void | close() 关闭此套接字。
protected abstract void | connect(InetAddress address, int port) 将此套接字连接到指定主机上的指定端口号。
protected abstract void | connect(SocketAddress address, int timeout) 将此套接字连接到指定主机上的指定端口号。
protected abstract void | connect(String host, int port) 将此套接字连接到指定主机上的指定端口。
protected abstract void | create(boolean stream) 创建一个流或数据报套接字。
protected FileDescriptor | getFileDescriptor() 返回此套接字的 fd 字段的值。
protected InetAddress | getInetAddress() 返回此套接字的 address 字段的值。
protected abstract InputStream | getInputStream() 返回此套接字的输入流。
protected int | getLocalPort() 返回此套接字的 localport 字段的值。
protected abstract OutputStream | getOutputStream() 返回此套接字的输出流。
protected int | getPort() 返回此套接字的 port 字段的值。
protected abstract void | listen(int backlog) 将传入连接指示（连接请求）的最大队列长度设置为 count 参数。
protected abstract void | sendUrgentData(int data) 在套接字上发送一个紧急数据字节。
protected void | setPerformancePreferences(int connectionTime, int latency, int bandwidth) 设置此套接字的性能偏好 (performance preferences)。
protected void | shutdownInput() 将此套接字的输入流置于“流的末尾”。
protected void | shutdownOutput() 禁用此套接字的输出流。
protected boolean | supportsUrgentData() 返回此 SocketImpl 是否支持发送紧急数据。
String | toString() 以 String 的形式返回此套接字的地址和端口。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.net.SocketOptions 继承的方法
getOption, setOption

字段详细信息

fd

protected FileDescriptor fd
此套接字的文件描述符对象。

address

protected InetAddress address
此套接字的远程端点的 IP 地址。

port

protected int port
此套接字连接到的远程主机的端口号。

localport

protected int localport
此套接字连接到的本地端口号。

构造方法详细信息

SocketImpl

public SocketImpl()
方法详细信息

create

protected abstract void create(boolean stream)
                        throws IOException
创建一个流或数据报套接字。

参数：
stream - 如果为 true，则创建流套接字；否则创建数据报套接字。
抛出：
IOException - 如果创建套接字时发生 I/O 错误。

connect

protected abstract void connect(String host,
                                int port)
                         throws IOException
将此套接字连接到指定主机上的指定端口。

参数：
host - 远程主机名。
port - 端口号。
抛出：
IOException - 如果连接到远程主机时发生 I/O 错误。

connect

protected abstract void connect(InetAddress address,
                                int port)
                         throws IOException
将此套接字连接到指定主机上的指定端口号。

参数：
address - 远程主机的 IP 地址。
port - 端口号。
抛出：
IOException - 如果尝试连接时发生 I/O 错误。

connect

protected abstract void connect(SocketAddress address,
                                int timeout)
                         throws IOException
将此套接字连接到指定主机上的指定端口号。超时值零被解释为无限超时。在建立连接或者发生错误之前，连接一直处于阻塞状态。

参数：
address - 远程主机的 Socket 地址。
timeout - 以毫秒为单位的超时值；或者为零，表示没有超时值。
抛出：
IOException - 如果尝试连接时发生 I/O 错误。
从以下版本开始：
1.4

bind

protected abstract void bind(InetAddress host,
                             int port)
                      throws IOException
将此套接字绑定到指定的本地 IP 地址和端口号。

参数：
host - 属于本地接口的 IP 地址。
port - 端口号。
抛出：
IOException - 如果绑定此套接字时发生 I/O 错误。

listen

protected abstract void listen(int backlog)
                        throws IOException
将传入连接指示（连接请求）的最大队列长度设置为 count 参数。如果队列满时收到连接指示，则拒绝该连接。

参数：
backlog - 队列的最大长度。
抛出：
IOException - 如果创建队列时发生 I/O 错误。

accept

protected abstract void accept(SocketImpl s)
                        throws IOException
接受连接。

参数：
s - 接受的连接。
抛出：
IOException - 如果接受连接时发生 I/O 错误。

getInputStream

protected abstract InputStream getInputStream()
                                       throws IOException
返回此套接字的输入流。

返回：
从此套接字读取内容的流。
抛出：
IOException - 如果创建输入流时发生 I/O 错误。

getOutputStream

protected abstract OutputStream getOutputStream()
                                         throws IOException
返回此套接字的输出流。

返回：
写入此套接字的输出流。
抛出：
IOException - 如果创建输出流时发生 I/O 错误。

available

protected abstract int available()
                          throws IOException
返回可以不受阻塞地从此套接字中读取的字节数。

返回：
不受阻塞地从此套接字读取的字节数。
抛出：
IOException - 如果确定可用字节数时发生 I/O 错误。

close

protected abstract void close()
                       throws IOException
关闭此套接字。

抛出：
IOException - 如果关闭此套接字时发生 I/O 错误。

shutdownInput

protected void shutdownInput()
                      throws IOException
将此套接字的输入流置于“流的末尾”。发送到此套接字的任何数据都会被接收到然后悄悄被丢弃。 如果在套接字上调用 shutdownInput() 后从套接字输入流读取内容，则流将返回 EOF（文件结束符）。

抛出：
IOException - 如果关闭此套接字时发生 I/O 错误。
从以下版本开始：
1.3
另请参见：
Socket.shutdownOutput(),
Socket.close(),
Socket.setSoLinger(boolean, int)

shutdownOutput

protected void shutdownOutput()
                       throws IOException
禁用此套接字的输出流。对于 TCP 套接字，任何以前写入的数据都将被发送，并且后跟 TCP 的正常连接终止序列。 如果在套接字上调用 shutdownOutput() 后写入套接字输出流，则该流将抛出 IOException。

抛出：
IOException - 如果关闭此套接字时发生 I/O 错误。
从以下版本开始：
1.3
另请参见：
Socket.shutdownInput(),
Socket.close(),
Socket.setSoLinger(boolean, int)

getFileDescriptor

protected FileDescriptor getFileDescriptor()
返回此套接字的 fd 字段的值。

返回：
此套接字的 fd 字段的值。
另请参见：
fd

getInetAddress

protected InetAddress getInetAddress()
返回此套接字的 address 字段的值。

返回：
此套接字的 address 字段的值。
另请参见：
address

getPort

protected int getPort()
返回此套接字的 port 字段的值。

返回：
此套接字的 port 字段的值。
另请参见：
port

supportsUrgentData

protected boolean supportsUrgentData()
返回此 SocketImpl 是否支持发送紧急数据。默认情况下返回 false，除非在子类中重写了该方法。

返回：
如果紧急数据受支持，则返回 true
从以下版本开始：
1.4
另请参见：
address

sendUrgentData

protected abstract void sendUrgentData(int data)
                                throws IOException
在套接字上发送一个紧急数据字节。要发送的字节是参数的八个低位

参数：
data - 要发送的数据的字节
抛出：
IOException - 如果在发送数据时发生错误。
从以下版本开始：
1.4

getLocalPort

protected int getLocalPort()
返回此套接字的 localport 字段的值。

返回：
此套接字的 localport 字段的值。
另请参见：
localport

toString

public String toString()
以 String 的形式返回此套接字的地址和端口。

覆盖：
类 Object 中的 toString
返回：
此套接字的字符串表示形式。

setPerformancePreferences

protected void setPerformancePreferences(int connectionTime,
                                         int latency,
                                         int bandwidth)
设置此套接字的性能偏好 (performance preferences)。

默认情况下套接字使用 TCP/IP 协议。有些实现可能提供与 TCP/IP 具有不同性能特征的替换协议。此方法允许应用程序在实现从可用协议中作出选择时表达它自己关于应该如何进行折衷的偏好。

性能偏好由三个整数描述，它们的值分别指示短连接时间、低延迟和高带宽的相对重要性。这些整数的绝对值没有意义；为了选择协议，需要简单比较它们的值，较大的值指示更强的偏好。负值表示的优先级低于正值。例如，如果应用程序相对于低延迟和高带宽更偏好短连接时间，则其可以使用值 (1, 0, 0) 调用此方法。如果应用程序相对于低延迟更偏好高带宽，而相对于短连接时间更偏好低延迟，则其可以使用值 (0, 1, 2) 调用此方法。 默认情况下此方法不执行任何操作，除非在子类中重写该方法。

参数：
connectionTime - 表达短连接时间的相对重要性的 int
latency - 表达低延迟的相对重要性的 int
bandwidth - 表达高带宽的相对重要性的 int
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketImplFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
接口 SocketImplFactory

public interface SocketImplFactory

此接口定义用于套接字实现的工厂。Socket 和 ServerSocket 类使用它来创建实际的套接字实现。

从以下版本开始：
JDK1.0
另请参见：
Socket, ServerSocket

方法摘要
 SocketImpl createSocketImpl()
创建新的 SocketImpl 实例。

方法详细信息

createSocketImpl

SocketImpl createSocketImpl()
创建新的 SocketImpl 实例。

返回：
新的 SocketImpl 实例。
另请参见：
SocketImpl
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketOptions (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
接口 SocketOptions

所有已知实现类：
DatagramSocketImpl, SocketImpl
public interface SocketOptions

获取/设置套接字选项的方法的接口。此接口由 SocketImpl 和 DatagramSocketImpl 实现。它们的子类应该重写此接口的方法来支持它们自己的选项。

在此接口中指定选项的方法和常量仅用于实现目的。如果不为 SocketImpl 或 DatagramSocketImpl 创建子类，就不要直接使用它们。在 Socket、ServerSocket、DatagramSocket 和 MulticastSocket 中，存在获取/设置所有这些选项的类型安全的方法。

字段摘要
static int | IP_MULTICAST_IF 设置用于发送多播包的传出接口。
static int | IP_MULTICAST_IF2 同上。
static int | IP_MULTICAST_LOOP 此选项启用或禁用多播数据报的本地回送。
static int | IP_TOS 此选项为 TCP 或 UDP 套接字在 IP 地址头中设置服务类型或流量类字段。
static int | SO_BINDADDR 获取绑定套接字的本地地址（不能仅将此选项“设置”为“得到”，因为套接字是在创建时绑定的，所以本地绑定的地址不可更改）。
static int | SO_BROADCAST 为套接字设置 SO_BROADCAST。
static int | SO_KEEPALIVE 为 TCP 套接字设置 keepalive 选项时，如果在 2 个小时（注：实际值与实现有关）内在任意方向上都没有跨越套接字交换数据，则 TCP 会自动将 keepalive 探头发送到同位体。
static int | SO_LINGER 指定关闭时逗留的超时值。
static int | SO_OOBINLINE 设置 OOBINLINE 选项时，在套接字上接收的所有 TCP 紧急数据都将通过套接字输入流接收。
static int | SO_RCVBUF 设置传入网络 I/O 的平台所使用基础缓冲区的大小的提示。
static int | SO_REUSEADDR 设置套接字的 SO_REUSEADDR。
static int | SO_SNDBUF 设置传出网络 I/O 的平台所使用的基础缓冲区大小的提示。
static int | SO_TIMEOUT 设置阻塞 Socket 操作的超时值： ServerSocket.accept(); SocketInputStream.read(); DatagramSocket.receive(); 选项必须在进入阻塞操作前设置才能生效。
static int | TCP_NODELAY 对此连接禁用 Nagle 算法。
方法摘要
Object | getOption(int optID) 获取选项的值。
void | setOption(int optID, Object value) 启用/禁用 optID 指定的选项。

字段详细信息

TCP_NODELAY

static final int TCP_NODELAY
对此连接禁用 Nagle 算法。在确认以前的写入数据之前不会缓冲写入网络的数据。

仅对 TCP (SocketImpl) 有效。

另请参见：
Socket.setTcpNoDelay(boolean), Socket.getTcpNoDelay(), 常量字段值

SO_BINDADDR

static final int SO_BINDADDR
获取绑定套接字的本地地址（不能仅将此选项“设置”为“得到”，因为套接字是在创建时绑定的，所以本地绑定的地址不可更改）。套接字的默认本地地址为 INADDR_ANY，表示多宿主机 (multi-homed host) 上的任何本地地址。多宿主机可以使用此选项接受仅到其地址的连接（在使用 ServerSocket 或 DatagramSocket 的情况下），或者将其返回地址指定到同位体（对于 Socket 或 DatagramSocket）。此选项的参数为 InetAddress。

此选项必须在构造方法中指定。

对 SocketImpl、DatagramSocketImpl 有效。

另请参见：
Socket.getLocalAddress(), DatagramSocket.getLocalAddress(), 常量字段值

SO_REUSEADDR

static final int SO_REUSEADDR
设置套接字的 SO_REUSEADDR。在 java 中，它仅用于 MulticastSocket，默认情况下为 MulticastSocket 设置此选项。

对 DatagramSocketImpl 有效。

另请参见：
常量字段值

SO_BROADCAST

static final int SO_BROADCAST
为套接字设置 SO_BROADCAST。此选项启用和禁用发送广播消息的处理能力。它仅用于数据报套接字和支持广播消息概念的网络上（例如，以太网、令牌网等），默认情况下为 DatagramSocket 设置此选项。

从以下版本开始：
1.4
另请参见：
常量字段值

IP_MULTICAST_IF

static final int IP_MULTICAST_IF
设置用于发送多播包的传出接口。可以在具有多个网络接口的主机上使用，在此类主机上应用程序可能希望使用系统默认值之外的接口。获取/返回 InetAddress。

对多播（DatagramSocketImpl）有效。

另请参见：
MulticastSocket.setInterface(InetAddress), MulticastSocket.getInterface(), 常量字段值

IP_MULTICAST_IF2

static final int IP_MULTICAST_IF2
同上。引入这一选项后，使用 IP_MULTICAST_IF 的行为与以前一样，而新选项可以支持利用 IPv4 和 IPv6 地址设置传出接口。 注：确保不发生与此选项的冲突

从以下版本开始：
1.4
另请参见：
MulticastSocket.setNetworkInterface(NetworkInterface), MulticastSocket.getNetworkInterface(), 常量字段值

IP_MULTICAST_LOOP

static final int IP_MULTICAST_LOOP
此选项启用或禁用多播数据报的本地回送。默认情况下，为 Multicast Socket 启用此选项。

从以下版本开始：
1.4
另请参见：
常量字段值

IP_TOS

static final int IP_TOS
此选项为 TCP 或 UDP 套接字在 IP 地址头中设置服务类型或流量类字段。

从以下版本开始：
1.4
另请参见：
常量字段值

SO_LINGER

static final int SO_LINGER
指定关闭时逗留的超时值。此选项启用/禁用从 TCP Socket 的 close() 立即返回。启用具有非零 Integer 超时值 的此选项意味着 close() 在传输和确认写入到同位体的所有数据前将一直阻塞，在那时套接字将从容地 关闭。到达逗留超时值时，套接字将通过 TCP RST 强制性 关闭。启用超时值为零的选项将立即强制关闭。如果指定的超时值大于 65,535，则其将被减少到 65,535。

仅对 TCP（SocketImpl）有效。

另请参见：
Socket.setSoLinger(boolean, int), Socket.getSoLinger(), 常量字段值

SO_TIMEOUT

static final int SO_TIMEOUT
设置阻塞 Socket 操作的超时值：
 ServerSocket.accept();
 SocketInputStream.read();
 DatagramSocket.receive();

选项必须在进入阻塞操作前设置才能生效。如果超过超时值，操作将继续阻塞，将引发 java.io.InterruptedIOException。在此情况下，将不关闭 Socket。

对所有套接字（SocketImpl、DatagramSocketImpl）都有效。

另请参见：
Socket.setSoTimeout(int),
ServerSocket.setSoTimeout(int),
DatagramSocket.setSoTimeout(int),
常量字段值

SO_SNDBUF

static final int SO_SNDBUF
设置传出网络 I/O 的平台所使用的基础缓冲区大小的提示。在设置方法中使用时，这是一个对应用程序内核的建议，关于通过套接字发送数据时使用的缓冲区大小。在获取方法中使用时，它必须返回在此套接字上发送数据时平台实际使用的缓冲区大小。 对所有套接字（SocketImpl、DatagramSocketImpl）都有效。

另请参见：
Socket.setSendBufferSize(int),
Socket.getSendBufferSize(),
DatagramSocket.setSendBufferSize(int),
DatagramSocket.getSendBufferSize(),
常量字段值

SO_RCVBUF

static final int SO_RCVBUF
设置传入网络 I/O 的平台所使用基础缓冲区的大小的提示。在设置方法中使用时，这是一个对应用程序内核的建议，关于通过套接字接收数据时使用的缓冲区大小。在获取方法中使用时，它必须返回在此套接字上接收数据时平台实际使用的缓冲区大小。 对所有套接字（SocketImpl、DatagramSocketImpl）都有效。

另请参见：
Socket.setReceiveBufferSize(int),
Socket.getReceiveBufferSize(),
DatagramSocket.setReceiveBufferSize(int),
DatagramSocket.getReceiveBufferSize(),
常量字段值

SO_KEEPALIVE

static final int SO_KEEPALIVE
为 TCP 套接字设置 keepalive 选项时，如果在 2 个小时（注：实际值与实现有关）内在任意方向上都没有跨越套接字交换数据，则 TCP 会自动将 keepalive 探头发送到同位体。此探头是同位体必须响应的 TCP 段。期望的响应为以下三种之一：1. 同位体通过期望的 ACK 响应。不通知应用程序（因为一切正常）。在另一个 2 小时的不活动时间过后，TCP 将发送另一个探头。2. 同位体通过 RST 响应，通知本地 TCP 同位体主机已崩溃并重新启动。套接字被关闭。3. 同位体没有响应。套接字被关闭。 此选项的目的是检测同位体主机是否崩溃。 仅对 TCP 套接字（SocketImpl）有效。

另请参见：
Socket.setKeepAlive(boolean), Socket.getKeepAlive(), 常量字段值

SO_OOBINLINE

static final int SO_OOBINLINE
设置 OOBINLINE 选项时，在套接字上接收的所有 TCP 紧急数据都将通过套接字输入流接收。禁用该选项时（默认），将悄悄丢弃紧急数据。

另请参见：
Socket.setOOBInline(boolean), Socket.getOOBInline(), 常量字段值
方法详细信息

setOption

void setOption(int optID,
               Object value)
               throws SocketException
启用/禁用 optID 指定的选项。如果将启用选项，并且它采用选定于选项的 "value"，则将其传入 value。值的实际类型是特定于选项的，传递非期望类型的内容将发生错误：
 SocketImpl s;
 ...
s.setOption(SO_LINGER, new Integer(10));
    // OK - set SO_LINGER w/ timeout of 10 sec.
 s.setOption(SO_LINGER, new Double(10));
    // ERROR - expects java.lang.Integer
如果请求的选项是二进制的，则其可以由 java.lang.Boolean 使用此方法设置：
 s.setOption(TCP_NODELAY, new Boolean(true));
    // OK - enables TCP_NODELAY, a binary option

使用带有 Boolean(false) 的此方法可以禁用任何选项：
 s.setOption(TCP_NODELAY, new Boolean(false));
    // OK - disables TCP_NODELAY
 s.setOption(SO_LINGER, new Boolean(false));
    // OK - disables SO_LINGER

对于具有打开和关闭概念并且需要非 boolean 参数的选项，将其值设置为 Boolean(false) 之外的任何内容都会隐式地启用该选项。
如果未识别选项、套接字被关闭或者发生某种低级别的错误，则抛出 SocketException

参数：
optID - 标识选项
value - 套接字选项的参数
抛出：
SocketException - 如果未识别选项、套接字被关闭或者发生某种低级别的错误
另请参见：
getOption(int)

getOption

Object getOption(int optID)
                 throws SocketException
获取选项的值。启用时，二进制选项将返回 java.lang.Boolean(true)；禁用时返回 java.lang.Boolean(false)，例如：
 SocketImpl s;
 ...
 Boolean noDelay = (Boolean)(s.getOption(TCP_NODELAY));
 if (noDelay.booleanValue()) {
     // true if TCP_NODELAY is enabled...
 ...
 }

对于将特定类型用作参数的选项，getOption(int) 将返回参数的值，另外返回 java.lang.Boolean(false)：

 Object o = s.getOption(SO_LINGER);
 if (o instanceof Integer) {
     System.out.print("Linger time is " + ((Integer)o).intValue());
 } else {
   // the true type of o is java.lang.Boolean(false);
 }

参数：
optID - 标识要获取的选项的 int
返回：
选项的值
抛出：
SocketException - 如果套接字被关闭
SocketException - 如果 optID 根据协议堆栈（包括 SocketImpl）是未知的
另请参见：
setOption(int, java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 SocketPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.net.SocketPermission
所有已实现的接口：
Serializable, Guard
public final class SocketPermission
extends Permission
implements Serializable

此类表示通过套接字对网络的访问。SocketPermission 由主机规范和一组指定到该主机的连接方式的“动作”组成。主机被指定为

    host = (hostname | IPv4address | iPv6reference) [:portrange]
    portrange = portnumber | -portnumber | portnumber-[portnumber]
主机被表达为 DNS 名称、数字 IP 地址或“本地主机”（对于本地机器而言）。在 DNS 名称主机规范中，可能包括通配符 "*"。如果包括，则其必须位于最左边的位置，如 "*.sun.com"。

IPv6reference 的格式应该按照 RFC 2732:Format for Literal IPv6 Addresses in URLs 中指定的格式：

    ipv6reference = "[" IPv6address "]"
例如，可以按照以下代码构造 SocketPermission 实例：
    String hostAddress = inetaddress.getHostAddress();
    if (inetaddress instanceof Inet6Address) {
        sp = new SocketPermission("[" + hostAddress + "]:" + port, action);
    } else {
        sp = new SocketPermission(hostAddress + ":" + port, action);
    }
或者
    String host = url.getHost();
    sp = new SocketPermission(host + ":" + port, action);

IPv6 字面值地址的完全未压缩形式也有效。

端口或端口范围是可选的。"N-" 形式的端口规范（其中 N 为端口号）表示端口号为 N 及以上的所有端口；而 "-N" 形式的端口规范则指示端口号为 N 及以下的所有端口。

连接到主机的可能方式为

 accept
 connect
 listen
 resolve
“侦听”动作仅在与“本地主机”一起使用时才有意义。任何其他动作出现时，都会暗含“解析”动作。“解析”动作指的是主机/ip 名称服务查找。

作为 SocketPermission 的创建和含义的示例，注意如果将以下权限：

   p1 = new SocketPermission("puffin.eng.sun.com:7777", "connect,accept");
授予某个代码，则其允许该代码连接到 puffin.eng.sun.com 上的 7777 端口，并接受该端口上的连接。

类似地，如果将以下权限：

   p1 = new SocketPermission("puffin.eng.sun.com:7777", "connect,accept");
   p2 = new SocketPermission("localhost:1024-", "accept,connect,listen");
授予某个代码，则其允许该代码接受本地机器上 1024 和 65535 之间任何端口上的连接、连接到这些端口或者在这些端口上进行侦听。

注：授予代码接受远程主机上的连接或连接到远程主机的权限可能是危险的，因为恶意代码可以更加容易地在对保密数据不具访问权限的各方中传输和共享保密数据。

另请参见：
Permissions, SocketPermission

构造方法摘要
SocketPermission(String host, String action)
创建带指定动作的新 SocketPermission 对象。
方法摘要
boolean | equals(Object obj) 检查两个 SocketPermission 对象的相等性。
String | getActions() 返回动作的规范化字符串表示形式。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此套接字权限对象是否“暗含”指定的权限。
PermissionCollection | newPermissionCollection() 用于存储 SocketPermission 对象的新 PermissionCollection 对象。
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

SocketPermission

public SocketPermission(String host,
                        String action)
创建带指定动作的新 SocketPermission 对象。主机被表达为 DNS 名称或数字 IP 地址。可以选择支持端口还是端口范围（用冒号分隔 DNS 名称或 IP 地址）。

要支持本地机器，请使用“本地主机”作为 host。还要注意：空的 host String ("") 等效于“本地主机”。

action 参数包含指定主机（和端口）获准的以逗号分隔的动作列表。可能的动作为“连接”、“侦听”、“接受”、“解析”或这些动作的任意组合。当指定了其他三个动作时，会自动添加“解析”。

以下是 SocketPermission 实例化的示例：

    nr = new SocketPermission("www.catalog.com", "connect");
    nr = new SocketPermission("www.sun.com:80", "connect");
    nr = new SocketPermission("*.sun.com", "connect");
    nr = new SocketPermission("*.edu", "resolve");
    nr = new SocketPermission("204.160.241.0", "connect");
    nr = new SocketPermission("localhost:1024-65535", "listen");
    nr = new SocketPermission("204.160.241.0:1024-65535", "connect");

参数：
host - 计算机的主机名或 IP 地址，可以选择是否包括后跟端口或端口范围的冒号。
actions - 动作字符串。
方法详细信息

implies

public boolean implies(Permission p)
检查此套接字权限对象是否“暗含”指定的权限。

更明确地说，此方法首先确保以下情况全部为 true（如果其中任意一项不为 true，则返回 false）：

  • p 是 SocketPermission 的一个实例，

  • p 的动作是此对象的动作的一个真子集，并且

  • p 的端口范围包括在此端口范围中。注：当 p 仅包含动作“解析”时，将忽略端口范围。

然后 implies 将按顺序检查以下每一项，如果所述条件为 true，则为每一项返回 true：

  • 如果此对象是使用单个 IP 地址初始化的，p 的其中一个 IP 地址等于此对象的 IP 地址。

  • 如果此对象为通配符域（如 *.sun.com），并且 p 的规范名称（不带任何前置 * 的名称）以此对象的规范主机名结尾。例如，*.sun.com 暗指 *.eng.sun.com。

  • 如果此对象不是使用单个 IP 地址初始化的，并且此对象的其中一个 IP 地址等于其中一个 p 的 IP 地址。

  • 如果此规范名称等于 p 的规范名称。

如果上述条件都不为 true，则 implies 返回 false。

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果对象隐含指定的权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 SocketPermission 对象的相等性。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 为 SocketPermission，并且此 SocketPermission 对象具有相同的主机名、端口范围和动作，则返回 true。但是，如果 obj 仅包含动作“解析”，则比较中将忽略端口范围。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回动作的规范化字符串表示形式。返回始终按以下顺序显示动作：连接、侦听、接受、解析。

指定者：
类 Permission 中的 getActions
返回：
动作的规范化字符串表示形式。

newPermissionCollection

public PermissionCollection newPermissionCollection()
用于存储 SocketPermission 对象的新 PermissionCollection 对象。

SocketPermission 对象必须以允许将它们按任意顺序插入集合的方式来存储，但同时也允许以有效（并一致）的方式实现 PermissionCollection 的 implies 方法。

覆盖：
类 Permission 中的 newPermissionCollection
返回：
适合存储 PropertyPermissions 的新 SocketPermissions 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketTimeoutException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 SocketTimeoutException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.io.InterruptedIOException
                    继承者  java.net.SocketTimeoutException
所有已实现的接口：
Serializable
public class SocketTimeoutException
extends InterruptedIOException

如果在读取或接受套接字时发生超时，则抛出此异常。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
从类 java.io.InterruptedIOException 继承的字段
bytesTransferred
构造方法摘要
SocketTimeoutException()
构造不带详细信息的新 SocketTimeoutException。
SocketTimeoutException(String msg)
构造带详细消息的新 SocketTimeoutException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SocketTimeoutException

public SocketTimeoutException(String msg)
构造带详细消息的新 SocketTimeoutException。

参数：
msg - 详细消息

SocketTimeoutException

public SocketTimeoutException()
构造不带详细信息的新 SocketTimeoutException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URI (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URI

java.lang.Object
    继承者  java.net.URI
所有已实现的接口：
Serializable, Comparable<URI>
public final class URI
extends Object
implements Comparable<URI>, Serializable

表示一个统一资源标识符 (URI) 引用。

除了以下提到的一些细微不同之处外，此类的实例代表一个 URI 引用，这在以下文档中定义：RFC 2396: Uniform Resource Identifiers (URI):Generic Syntax；在此文件中对其内容又进行了修正：RFC 2732:Format for Literal IPv6 Addresses in URLs。字面值 IPv6 地址格式还支持 scope_ids。scope_ids 的语法和用法在此处描述。此类提供了用于从其组成部分或通过解析其字符串形式创建 URI 实例的构造方法、用于访问实例的各个不同组成部分的方法，以及用于对 URI 实例进行规范化、解析和相对化的方法。此类的实例不可变。

URI 语法和组成部分

在最高级别上，字符串形式的 URI 引用（以下简写为 "URI"）语法如下
[scheme:]scheme-specific-part[#fragment]
其中，方括号 [...] 用于描述可选组成部分，字符 : 和 # 代表它们自身。

绝对 URI 指定了方案 (scheme)；非绝对的 URI 称为相对 URI。URI 还可以根据其是否为不透明的 或分层的 进行分类。

不透明 URI 为绝对 URI，其特定于方案的部分不是以斜线字符 ('/') 开始。不透明 URI 无法进行进一步解析。下面是不透明 URI 的一些示例：

mailto:java-net@java.sun.com
news:comp.lang.java
urn:isbn:096139210x

分层 URI 或者为绝对 URI（其特定于方案的部分以斜线字符开始），或者为相对 URI，即不指定方案的 URI。下面是分层 URI 的一些示例：

http://java.sun.com/j2se/1.3/
docs/guide/collections/designfaq.html#28
../../../demo/jfc/SwingSet2/src/SwingSet2.java
file:///~/calendar

分层 URI 还要按照下面的语法进行进一步的解析

[scheme:][//authority][path][?query][#fragment]
其中，:、/、? 和 # 代表它们自身。分层 URI 的特定于方案的部分包含方案和片段部分之间的字符。

分层 URI 的授权组成部分（如果指定）为基于服务器的 或基于注册表的。基于服务器的授权按照如下众所周知的语法进行解析：

[user-info@]host[:port]
其中，字符 @ 和 : 代表它们自身。几乎当前使用的所有 URI 方案都是基于服务器的。不能采用这种方式解析的授权组成部分被视为基于注册表的。

如果分层 URI 的路径组成部分以斜线字符 ('/') 开始，则称此 URI 本身为绝对的；否则它为相对的。分层 URI 或者为绝对的，或者指定了授权的路径，它始终为绝对的。

如上所述，URI 实例具有以下九个组成部分：

组成部分 | 类型
方案 | String
特定于方案的部分 | String
授权 | String
用户信息 | String
主机 | String
端口 | int
路径 | String
查询 | String
片段 | String
在给定实例中，任何特殊组成部分都或者为未定义的，或者为已定义的，并且有不同的值。未定义的字符串组成部分由 null 表示，未定义的整数组成部分由 -1 表示。已定义的字符串组成部分的值可以为空字符串；这与未定义的组成部分不等效。

实例中特定的组成部分是已定义的还是未定义的取决于所代表的 URI 类型。绝对 URI 具有方案组成部分。不透明的 URI 具有一个方案、一个特定于方案的部分，以及可能会有一个片段，但是没有其他组成部分。分层 URI 总是有一个路径（尽管可能为空）和一个特定于方案的部分（它至少包含一个路径），还可以包含任何其他组成部分。如果有授权组成部分且它又是基于服务器的，则主机组成部分将被定义，也有可能定义用户信息和端口组成部分。

针对 URI 实例的运算

此类支持的主要运算有规范化、解析 和相对化 运算。

规范化 是将分层 URI 的路径组成部分中的不必要的 "." 和 ".." 部分移除的过程。每个 "." 部分都将被移除。".." 部分也被移除，除非它前面有一个非 ".." 部分。规范化对不透明 URI 不产生任何效果。

解析 是根据另一个基本 URI 解析某个 URI 的过程。得到的 URI 由两个 URI 组成部分构造，构造方式由 RFC 2396 指定，从基本 URI 取出原始 URI 中未指定的组成部分。对于分层 URI，原始的路径根据基本路径进行解析，然后进行规范化。例如，解析以下 URI

docs/guide/collections/designfaq.html#28          (1)
根据基本 URI http://java.sun.com/j2se/1.3/ 解析，结果为 URI
http://java.sun.com/j2se/1.3/docs/guide/collections/designfaq.html#28
解析相对 URI
../../../demo/jfc/SwingSet2/src/SwingSet2.java    (2)
根据此结果应生成
http://java.sun.com/j2se/1.3/demo/jfc/SwingSet2/src/SwingSet2.java
支持对绝对和相对 URI，以及分层 URI 的绝对和相对路径的解析。根据任何其他 URI 对 URI file:///~calendar 进行解析只能生成原始的 URI，因为它是绝对路径。根据相对基础 URI (1) 解析相对 URI (2) 将生成规范的但依然是相对的 URI
demo/jfc/SwingSet2/src/SwingSet2.java

最后，相对化 是解析的逆过程：对于任何两个规范的 URI u 和 v，

u.relativize(u.resolve(v)).equals(v) 和
u.resolve(u.relativize(v)).equals(v)。
此运算在下面的场合非常有用：构造一个包含 URI 的文档，该 URI 必须尽可能是根据文档的基本 URI 建立的相对 URI。例如，相对化 URI
http://java.sun.com/j2se/1.3/docs/guide/index.html
根据基本 URI
http://java.sun.com/j2se/1.3
生成了相对 URI docs/guide/index.html。

字符分类

RFC 2396 精确指出 URI 引用中的各个不同组成部分允许使用的字符。以下分类大部分取自该规范，这些约束的用法描述如下：
alpha | US-ASCII 字母字符，'A' 到 'Z' 以及 'a' 到 'z'
digit | US-ASCII 十进制数字符，'0' 到 '9'
alphanum | 所有 alpha 和 digit 字符
unreserved | 所有 alphanum 字符及字符串 "_-!.~'()*" 中包含的字符
punct | 字符串 ",;:$&+=" 中包含的字符
reserved | 所有 punct 字符及字符串 "?/[]@" 中包含的字符
escaped | 转义八位组，即三部分组合：百分号 ('%') 后跟两个十六进制数（'0'-'9'、'A'-'F' 和 'a'-'f'）
other | 未包含在 US-ASCII 字符集中的 Unicode 字符不是控制字符（根据 Character.isISOControl 方法），并且不是空格字符（根据 Character.isSpaceChar 方法）（与 RFC 2396 有些出入，RFC 2396 限制为 US-ASCII）

全部合法 URI 字符集包含 unreserved、reserved、escaped 和 other 字符。

转义八位组、引用、编码和解码

RFC 2396 允许用户信息、路径、查询和片段组成部分中包含转义八位组。转义在 URI 中实现两个目的：

  • 当要求 URI 不能包含任何 other 字符以严格遵守 RFC 2396 时，需要对非 US-ASCII 字符进行编码。

  • 要引用 组成部分中的非法字符。用户信息、路径、查询和片段组成部分在判断哪些字符合法哪些字符非法上稍有不同。

在此类中由三个相关的运算实现了这两个目的：

  • 字符的编码 方式是，用代表该字符在 UTF-8 字符集中的字符的转义八位组序列取代该字符。例如，欧元符号 ('\u20AC') 编码后为 "%E2%82%AC"。（与 RFC 2396 有些出入，RFC 2396 未指定任何特殊字符集）。

  • 非法字符通过简单地对它进行编码来引用。例如，空格字符，用 "%20" 取代它来进行引用。UTF-8 包含 US-ASCII，因此对于 US-ASCII 字符，此转换具有的效果与 RFC 2396 的要求相同。

  • 对转义八位组序列进行解码 的方法是，用它所代表的 UTF-8 字符集中的字符的序列将它取代。UTF-8 包含 US-ASCII，因此解码具有对引用的任何 US-ASCII 字符取消引用的效果，以及对任何编码的非 US-ASCII 字符进行解码的效果。如果在对转义八位组进行解码时出现解码错误，则出错的八位组用 Unicode 替换字符 '\uFFFD' 取代。

这些运算在此类的构造方法和方法中公开，如下所示：

  • 单参数构造方法要求对参数中的任何非法字符都必须引用，并保留出现的任何转义八位组和 other 字符。

  • 多参数构造方法根据其中出现的组成部分的需要对非法字符进行引用。百分号字符 ('%') 始终通过这些构造方法引用。任何 other 字符都将被保留。

  • getRawUserInfo、getRawPath、getRawQuery、getRawFragment、getRawAuthority 和 getRawSchemeSpecificPart 方法以原始形式返回它们的相应组成部分的值，不解释任何转义八位组。由这些方法返回的字符串有可能包含转义八位组和 other 字符，但不包含任何非法字符。

  • getUserInfo、getPath、getQuery、getFragment、getAuthority 和 getSchemeSpecificPart 方法解码相应的组成部分中的任何转义八位组。由这些方法返回的字符串有可能包含 other 字符和非法字符，但不包含任何转义八位组。

  • toString 返回带所有必要引用的 URI 字符串，但它可能包含 other 字符。

  • toASCIIString 方法返回不包含任何 other 字符的、完全引用的和经过编码的 URI 字符串。

标识

对于任何 URI u，下面的标识有效
new URI(u.toString()).equals(u) .
对于不包含冗余语法的任何 URI u，比如在一个空授权前面有两根斜线（如 file:///tmp/）和主机名后面跟一个冒号但没有端口（如 http://java.sun.com:），以及除必须引用的字符之外不对字符编码的情况，下面的标识也有效：
new URI(u.getScheme()、
        u.getSchemeSpecificPart()、
        u.getFragment())
.equals(u)
在所有情况下，以下标识有效
new URI(u.getScheme()、
        u.getUserInfo()、 u.getAuthority()、
        u.getPath()、 u.getQuery()、
        u.getFragment())
.equals(u)
如果 u 为分层的，则以下标识有效
new URI(u.getScheme()、
        u.getUserInfo()、 u.getHost()、 u.getPort()、
        u.getPath()、 u.getQuery()、
        u.getFragment())
.equals(u)
如果 u 为分层的并且没有授权或没有基于服务器的授权。

URI、URL 和 URN

URI 是统一资源标识符，而 URL 是统一资源定位符。因此，笼统地说，每个 URL 都是 URI，但不一定每个 URI 都是 URL。这是因为 URI 还包括一个子类，即统一资源名称 (URN)，它命名资源但不指定如何定位资源。上面的 mailto、news 和 isbn URI 都是 URN 的示例。

URI 和 URL 概念上的不同反映在此类和 URL 类的不同中。

此类的实例代表由 RFC 2396 定义的语法意义上的一个 URI 引用。URI 可以是绝对的，也可以是相对的。对 URI 字符串按照一般语法进行解析，不考虑它所指定的方案（如果有）不对主机（如果有）执行查找，也不构造依赖于方案的流处理程序。相等性、哈希计算以及比较都严格地根据实例的字符内容进行定义。换句话说，一个 URI 实例和一个支持语法意义上的、依赖于方案的比较、规范化、解析和相对化计算的结构化字符串差不多。

作为对照，URL 类的实例代表了 URL 的语法组成部分以及访问它描述的资源所需的信息。URL 必须是绝对的，即它必须始终指定一个方案。URL 字符串按照其方案进行解析。通常会为 URL 建立一个流处理程序，实际上无法为未提供处理程序的方案创建一个 URL 实例。相等性和哈希计算依赖于方案和主机的 Internet 地址（如果有）；没有定义比较。换句话说，URL 是一个结构化字符串，它支持解析的语法运算以及查找主机和打开到指定资源的连接之类的网络 I/O 操作。

从以下版本开始：
1.4
另请参见：
RFC 2279: UTF-8, a transformation format of ISO 10646,
RFC 2373: IPv6 Addressing Architecture,
RFC 2396: Uniform Resource Identifiers (URI): Generic Syntax,
RFC 2732: Format for Literal IPv6 Addresses in URLs,
URISyntaxException, 序列化表格

构造方法摘要
URI(String str)
通过解析给定的字符串构造一个 URI。
URI(String scheme, String ssp, String fragment)
根据给定的组成部分构造 URI。
URI(String scheme, String userInfo, String host, int port, String path, String query, String fragment)
根据给定的组成部分构造一个分层 URI。
URI(String scheme, String host, String path, String fragment)
根据给定的组成部分构造分层 URI。
URI(String scheme, String authority, String path, String query, String fragment)
根据给定的组成部分构造分层 URI。
方法摘要
int | compareTo(URI that) 将此 URI 与另一个对象（也必须是 URI）进行比较。
static URI | create(String str) 通过解析给定的字符串创建 URI。
boolean | equals(Object ob) 测试此 URI 与另一对象的相等性。
String | getAuthority() 返回此 URI 的已解码的授权组成部分。
String | getFragment() 返回此 URI 的已解码的片段组成部分。
String | getHost() 返回此 URI 的主机组成部分。
String | getPath() 返回此 URI 的已解码的路径组成部分。
int | getPort() 返回此 URI 的端口号。
String | getQuery() 返回此 URI 的已解码的查询组成部分。
String | getRawAuthority() 返回此 URI 的原始授权组成部分。
String | getRawFragment() 返回此 URI 的原始片段组成部分。
String | getRawPath() 返回此 URI 的原始路径组成部分。
String | getRawQuery() 返回此 URI 的原始查询组成部分。
String | getRawSchemeSpecificPart() 返回此 URI 原始的、特定于方案的部分。
String | getRawUserInfo() 返回此 URI 的原始用户信息组成部分。
String | getScheme() 返回此 URI 的方案组成部分。
String | getSchemeSpecificPart() 返回此 URI 的特定于方案的解码部分。
String | getUserInfo() 返回此 URI 的已解码的用户信息组成部分。
int | hashCode() 返回此 URI 的哈希码值。
boolean | isAbsolute() 判断此 URI 是否为绝对的。
boolean | isOpaque() 判断此 URI 是否为不透明的。
URI | normalize() 规范化此 URI 的路径。
URI | parseServerAuthority() 尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。
URI | relativize(URI uri) 根据此 URI 将给定 URI 相对化。
URI | resolve(String str) 解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。
URI | resolve(URI uri) 根据此 URI 解析给定的 URI。
String | toASCIIString() 以 US-ASCII 字符串形式返回此 URI 的内容。
String | toString() 以字符串形式返回此 URI 的内容。
URL | toURL() 根据此 URI 构造一个 URL。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

URI

public URI(String str)
    throws URISyntaxException
通过解析给定的字符串构造一个 URI。

此构造方法解析给定字符串的方式与 RFC 2396 的附录 A 中指定的语法非常相似，除了以下细微不同：

  • 只要空的授权组成部分后面带一个非空路径、一个查询组成部分，或一个片段组成部分，就允许使用该空授权组成部分。这样就可以对类似 "file:///foo/bar" 的 URI 进行解析，这样做似乎是 RFC 2396 的意愿，尽管其语法不允许这样。如果授权组成部分为空，则用户信息、主机和端口组成部分都是未定义的。

  • 允许空的相对路径；这似乎是 RFC 2396 的意愿，尽管语法不允许这样。此细微不同带来的主要后果是，单独的片段（如 "#foo"）将作为带空路径和给定片段的相对 URI 进行解析，并可根据基本 URI 进行有效的解析。

  • 对主机组成部分中的 IPv4 地址进行严格的解析，正如 RFC 2732 指定的一样：点号分隔的由四部分组成的地址的每个元素都必须包含不超过三个十进制数字。每个元素被约束为值不能大于 255。

  • 主机组成部分中的主机名如果只包含一个单独的域标签，则允许其以 alphanum 字符开始。这似乎是 RFC 2396 的 3.2.2 节的意愿，尽管其语法不允许这样。此细微不同带来的结果是，分层 URI 的授权组成部分（比如 s://123）将作为基于服务器的授权进行解析。

  • 主机组成部分允许使用 IPv6 地址。IPv6 地址必须括在方括号 ('[' 和 ']') 中，正如 RFC 2732 指定的一样。IPv6 地址本身必须按照 RFC 2373 进行解析。IPv6 地址进一步约束为只能描述不超过十六个字节的地址信息，该约束在 RFC 2373 隐式给出，没有在语法中明确说明。

  • 只要 RFC 2396 允许转义八位组，就允许使用其他类别中的字符，即用户信息、路径、查询和片段组成部分以及授权组成部分（如果授权是基于注册表的）中的内容。这样，除了 US-ASCII 字符集中的字符，URI 中还可以包含 Unicode 字符。

参数：
str - 要解析为 URI 的字符串
抛出：
NullPointerException - 如果 str 为 null
URISyntaxException - 如果给定字符串违背 RFC 2396，正如上述细微不同的补充

URI

public URI(String scheme,
           String userInfo,
           String host,
           int port,
           String path,
           String query,
           String fragment)
    throws URISyntaxException
根据给定的组成部分构造一个分层 URI。

如果给定了方案，则路径（如果也给定）必须为空或以斜线字符 ('/') 开始。否则通过为相应的参数传入 null，或者在 port 参数的情况下，传入 -1，新 URI 的组成部分可能保留为未定义。

此构造方法首先根据 RFC 2396 中的 5.2 节的步骤 7 指定的规则从给定的组成部分构建一个 URI 字符串：

  1. 起初，结果字符串为空。

  2. 如果给定了方案，则将方案添加到结果后面，后面再加一个冒号 (':') 字符。

  3. 如果给定了用户信息、主机或端口，则添加 "//" 字符串。

  4. 如果给定了用户信息，则添加该信息，之后是“商用 at”字符 ('@')。任何不属于 unreserved、punct、escaped 或 other 类别的字符都应该进行 引用。

  5. 如果给定了主机，则添加该主机。如果主机为字面值 IPv6 地址但未括在方括号 ('[' 和 ']') 中，则添加方括号。

  6. 如果给定了端口名，则添加一个冒号字符 (':')，之后是十进制形式的端口号。

  7. 如果给定了路径，则添加该路径。任何不属于 unreserved、punct、escaped 或 other 类别的字符，以及不等于斜线字符 ('/') 或“商用 at”字符 ('@') 的字符都应该进行引用。

  8. 如果给定了查询，则添加一个问号字符 ('?')，之后是查询。任何不是合法 URI 字符的字符都应该进行引用。

  9. 最后，如果给定了片段，则添加一个井字符 ('#')，之后是片段。任何非法的 URI 字符都应该进行引用。

然后对得到的 URI 字符串进行解析，正如调用 URI(String) 构造方法一样，然后根据结果情况调用 parseServerAuthority()；这可能导致抛出 URISyntaxException。

参数：
scheme - 方案名
userInfo - 用户信息和授权信息
host - 主机名
port - 端口名
path - 路径
query - 查询
fragment - 片段
抛出：
URISyntaxException - 如果方案和路径都已给出但路径为相对的，如果从给定组成部分构造的 URI 字符串违背 RFC 2396，或者如果字符串的授权组成部分存在但无法解析为基于服务器的授权

URI

public URI(String scheme,
           String authority,
           String path,
           String query,
           String fragment)
    throws URISyntaxException
根据给定的组成部分构造分层 URI。

如果给定了方案，则路径（如果也给定）必须为空或以斜线字符 ('/') 开始。否则，通过为相应的参数传入 null，新 URI 的组成部分可能保留为未定义。

该构造方法首先根据 RFC 2396 的 5.2 节的步骤 7 指定的规则从给定组成部分构建一个 URI 字符串：

  1. 起初，结果字符串为空。

  2. 如果给定了方案，则将方案添加到结果后面，后面再加一个冒号 (':')字符。

  3. 如果给定了授权，则添加 "//" 字符串，之后是授权。如果授权包含一个字面值 IPv6 地址，则该地址必须括在方括号 ('[' 和 ']') 中。任何不属于 unreserved、punct、escaped 或 other 类别的字符，以及不等于“商用 at”字符 ('@') 的字符都应该进行引用。

  4. 如果给定了路径，则添加该路径。任何不属于 unreserved、punct、escaped 或 other 类别的字符，以及不等于斜线字符 ('/') 或“商用 at”字符 ('@') 的字符都应该进行引用。

  5. 如果给定了查询，则添加一个问号字符 ('?')，之后是查询。任何不是合法 URI 字符的字符都应该进行引用。

  6. 最后，如果给定了片段，则添加一个井字符 ('#')，之后是片段。任何非法的 URI 字符都应该进行引用。

然后对得到的 URI 字符串进行解析，正如调用 URI(String) 构造方法一样，然后根据结果情况调用 parseServerAuthority()；这可能导致抛出 URISyntaxException。

参数：
scheme - 方案名
authority - 授权
path - 路径
query - 查询
fragment - 片段
抛出：
URISyntaxException - 如果方案和路径都已给出但路径为相对的，如果从给定组成部分构造的 URI 字符串违背 RFC 2396，或者如果字符串的授权组成部分存在但无法解析为基于服务器的授权

URI

public URI(String scheme,
           String host,
           String path,
           String fragment)
    throws URISyntaxException
根据给定的组成部分构造分层 URI。

通过传入 null，组成部分可保留未定义。

此便捷构造方法的工作方式类似于调用带七个参数的构造方法，如下所示：

new URI(scheme, null, host, -1, path, null, fragment);

参数：
scheme - 方案名
host - 主机名
path - 路径
fragment - 片段
抛出：
URISyntaxException - 如果根据给定的组成部分构造的 URI 字符串违背 RFC 2396

URI

public URI(String scheme,
           String ssp,
           String fragment)
    throws URISyntaxException
根据给定的组成部分构造 URI。

通过传入 null，组成部分可保留未定义。

该构造方法首先利用给定组成部分构建一个字符串形式的 URI，具体如下：

  1. 起初，结果字符串为空。

  2. 如果给定了方案，则将方案添加到结果后面，后面再加一个冒号 (':')字符。

  3. 如果给定了特定于方案的部分，则添加该部分。任何不是合法 URI 字符的字符都应该进行引用。

  4. 最后，如果给定了片段，则在字符串后面添加一个井字符 ('#')，之后是片段。任何非法的 URI 字符都应该进行引用。

然后解析得到的 URI 字符串以便创建新的 URI 实例，正如调用 URI(String) 构造方法一样；这可能导致抛出 URISyntaxException。

参数：
scheme - 方案名
ssp - 特定于方案的部分
fragment - 片段
抛出：
URISyntaxException - 如果根据给定的组成部分构造的 URI 字符串违背 RFC 2396
方法详细信息

create

public static URI create(String str)
通过解析给定的字符串创建 URI。

此便捷工厂方法的工作方式类似于调用 URI(String) 构造方法；由该构造方法抛出的任何 URISyntaxException 都被捕获，并包装到一个新的 IllegalArgumentException 对象中，然后抛出此对象。

此方法的使用场合是：已知给定的字符串是合法的 URI（例如，程序中声明的 URI 常量），该字符串无法这样解析时将被视为编程错误。当 URI 从用户输入或从其他易于引起错误的源构造时，应该使用直接抛出 URISyntaxException 的构造方法。

参数：
str - 要解析为 URI 的字符串
返回：
新的 URI
抛出：
NullPointerException - 如果 str 为 null
IllegalArgumentException - 如果给定的字符串违背 RFC 2396

parseServerAuthority

public URI parseServerAuthority()
                         throws URISyntaxException
尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。

如果此 URI 的授权组成部分已识别为基于服务器的，则可断定它已经被解析为用户信息、主机和端口组成部分。在这种情况下，或者如果此 URI 无任何授权组成部分，此方法只返回此 URI。

否则，此方法会多次尝试将授权组成部分解析为用户信息、主机、端口组成部分，并抛出一个描述授权组成部分为何无法用此方法解析的异常。

提供此方法是因为 RFC 2396 中指定的常规 URI 语法无法区分非法的基于服务器的授权和合法的基于注册表的授权。因此，必须把前者的某些实例看作后者的实例。例如，URI 字符串 "//foo:bar" 中的授权组成部分，并不是一个合法的基于服务器的授权，但却是一个合法的基于注册表的授权。

在许多一般情况下，例如，当已知正常的 URI 为 URN 或 URL 时，所使用的分层 URI 总是基于服务器的。因此，它们要么同样被解析，要么同样被视为错误。在这种情况下，类似如下语句

URI u = new URI(str).parseServerAuthority();

可用于确保 u 在以下情况始终引用一个 URI：它有一个授权组成部分、一个基于服务器的授权以及适当的用户信息、主机和端口组成部分。调用此方法还可确保授权无法用相应的方法解析时，能够根据抛出的异常发出适当的诊断消息。

返回：
其授权字段已作为基于服务器的授权解析的 URI
抛出：
URISyntaxException - 如果此 URI 的授权部分已定义，但是按照 RFC2396 不能解析为基于服务器的授权

normalize

public URI normalize()
规范化此 URI 的路径。

如果此 URI 为不透明的，或者其路径已经是规范形式，则返回此 URI。否则，将构造一个新的 URI，它与此 URI 基本相同，只有路径是通过规范化此 URI 的路径计算得出的，规范化的方式与 RFC 2396 的 5.2 节的步骤 6 的子步骤 c 到 f 一致；即：

  1. 移除所有 "." 部分。

  2. 如果 ".." 部分的前面有一个非 ".." 部分，则这两个部分都被移除。重复此步骤，直至不适合以上条件。

  3. 如果路径为相对的，并且如果它的第一个部分包含一个冒号字符 (':')，则预先考虑一个 "." 部分。这防止具有诸如 "a:b/c/d" 这样的路径的相对 URI 在后续被重新解析为具有方案 "a" 和特定于方案的部分 "b/c/d" 的不透明 URI。（与 RFC 2396 有些出入)

如果 ".." 前面没有足够的非 ".." 部分以允许移除 ".."，则规范化路径将以一个或多个 ".." 部分开头。如果已按照上述步骤 3 插入了一个路径，规范化路径将以一个 "." 部分开头。否则，规范化路径将不包含任何 "." 或 ".." 部分。

返回：
一个与此 URI 相等的 URI，但其路径为规范形式

resolve

public URI resolve(URI uri)
根据此 URI 解析给定的 URI。

如果给定的 URI 已经是绝对的，或如果此 URI 是不透明的，则返回给定的 URI。

如果给定 URI 的片段组成部分已定义，其路径组成部分为空，并且其方案、授权及查询组成部分未定义，则返回一个 URL，它是由一个给定的片段及本 URL 的所有其他组成部分构成。这允许表示单独片段引用的 URI（比如 "#foo"）根据基本 URI 进行有效的解析。

否则，此方法以与 RFC 2396 的 5.2 节一致的方式构造新的分层 URI；即：

  1. 用此 URI 的方案和给定 URI 的查询和片段组成部分构造新的 URI。

  2. 如果给定 URI 有一个授权组成部分，则新 URI 的授权和路径都取自给定 URI。

  3. 否则，新 URI 的授权组成部分从此 URI 复制，其路径按如下方式计算：

    1. 如果给定 URI 的路径是绝对的，则新的 URI 路径取自给定 URI。

    2. 否则，给定 URI 的路径是相对的，新的 URI 路径根据此 URI 的路径对给定 URI 的路径进行解析而计算得出。方法为：除去此 URI 的路径的最后一部分（如果有），将此 URI 路径的其他所有部分与给定 URI 的路径串联起来，然后将得到的结果规范化（正如调用 normalize 方法一样）。

当且仅当此 URI 为绝对的或者给定 URI 为绝对的，此方法的结果才是绝对的。

参数：
uri - 要根据此 URI 解析的 URI
返回：
结果 URI
抛出：
NullPointerException - 如果 uri 为 null

resolve

public URI resolve(String str)
解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。

此方法工作便捷，并与进行 resolve(URI.create(str)) 作用相同。

参数：
str - 要解析为 URI 的字符串
返回：
得到的 URI
抛出：
NullPointerException - 如果 str 为 null
IllegalArgumentException - 如果给定字符串违背 RFC 2396

relativize

public URI relativize(URI uri)
根据此 URI 将给定 URI 相对化。

根据此 URI 将给定的 URI 相对化按以下方式计算：

  1. 如果此 URI 或给定 URI 是不透明的，或者如果两个 URI 的方案和授权组成部分不相同，或者如果此 URI 的路径不是给定 URI 的路径前缀，则返回给定的 URI。

  2. 否则，使用从给定 URI 获取的查询和片段组成部分，以及通过把此 URI 的路径从给定 URL 的路径开头处移除而得到的路径组成部分，构造新的相对分层 URL。

参数：
uri - 要根据此 URI 进行相对化的 URI
返回：
得到的 URI
抛出：
NullPointerException - 如果 uri 为 null

toURL

public URL toURL()
          throws MalformedURLException
根据此 URI 构造一个 URL。

首先检查得知此 URI 为绝对路径后，此便捷方法的工作方式就好像调用它与对表达式 new URL(this.toString()) 进行计算是等效的。

返回：
根据此 URI 构造的 URL
抛出：
IllegalArgumentException - 如果此 URL 不是绝对的
MalformedURLException - 如果无法找到 URL 的协议处理程序，或者如果在构造 URL 时发生其他错误

getScheme

public String getScheme()
返回此 URI 的方案组成部分。

URI 的方案组成部分（如果定义了）只包含 alphanum 类别和字符串 "-.+" 中的字符。方案始终以 alpha 字符开始。

URI 的方案组成部分不能包含转义八位组，因此此方法不执行任何解码操作。

返回：
此 URI 的方案组成部分，或者如果方案未定义，则返回 null

isAbsolute

public boolean isAbsolute()
判断此 URI 是否为绝对的。

当且仅当 URI 具有方案组成部分时，它才是绝对的。

返回：
当且仅当此 URI 是绝对的，才返回 true

isOpaque

public boolean isOpaque()
判断此 URI 是否为不透明的。

当且仅当 URI 是绝对的且其特定于方案的部分不是以斜线字符 ('/') 开始时，此 URI 才是不透明的。不透明的 URI 具有一个方案、一个特定于方案的部分，以及可能会有的一个片段；所有其他组成部分都是未定义的。

返回：
当且仅当此 URI 是不透明的，才返回 true

getRawSchemeSpecificPart

public String getRawSchemeSpecificPart()
返回此 URI 原始的、特定于方案的部分。特定于方案的部分永远不会是未定义的，但它可能为空。

URI 的特定于方案的部分只包含合法的 URI 字符。

返回：
此 URI 的特定于方案的原始部分（从不为 null）

getSchemeSpecificPart

public String getSchemeSpecificPart()
返回此 URI 的特定于方案的解码部分。

除了转义八位组的所有序列都已解码之外，此方法返回的字符串与 getRawSchemeSpecificPart 方法返回的字符串相等。

返回：
此 URI 的特定于方案的解码部分（从不为 null）

getRawAuthority

public String getRawAuthority()
返回此 URI 的原始授权组成部分。

URI 的授权组成部分（如果定义了）只包含“商用 at”字符 ('@') 和 unreserved、punct、escaped 和 other 类别中的字符。如果授权是基于服务器的，则它被进一步约束为具有有效的用户信息、主机和端口组成部分。

返回：
此 URI 的原始授权组成部分，如果授权未定义，则返回 null

getAuthority

public String getAuthority()
返回此 URI 的已解码的授权组成部分。

除了转义八位组的所有序列都已解码之外，此方法返回的字符串与 getRawAuthority 方法返回的字符串相等。

返回：
此 URI 的已解码的授权组成部分，如果授权未定义，则返回 null

getRawUserInfo

public String getRawUserInfo()
返回此 URI 的原始用户信息组成部分。

URI 的用户信息组成部分（如果定义了）只包含 unreserved、punct、escaped 和 other 类别中的字符。

返回：
此 URI 的原始用户信息组成部分，如果用户信息未定义，则返回 null

getUserInfo

public String getUserInfo()
返回此 URI 的已解码的用户信息组成部分。

除了转义八位组的所有序列都已解码之外，此方法返回的字符串与 getRawUserInfo 方法返回的字符串相等。

返回：
此 URI 的已解码的用户信息组成部分，如果用户信息未定义，则返回 null

getHost

public String getHost()
返回此 URI 的主机组成部分。

URI 的主机组成部分（如果定义了）将具有以下形式之一：

  • 由一个或多个由句点字符 ('.') 分隔的标签 组成的域名，后面可以跟随一个句点字符。每个标签由 alphanum 字符及连字符 ('-') 组成，但是连字符从不会出现在标签的第一个或最后一个字符位置。由两个或多个标签组成的域名中最右边的标签以 alpha 字符开始。

  • 点号分隔的由四部分组成的 IPv4 地址，其形式为数字+.数字+.数字+.数字+，其中，数字 序列不超过三个字符，任何序列都不能大于 255。

  • 包含在方括号 ('[' 和 ']') 中的 IPv6 地址，由十六进制数、冒号字符 (':') 和可能会有的一个嵌入式 IPv4 地址组成。IPv6 地址的完整语法在 RFC 2373:IPv6 Addressing Architecture 中指定。

URI 的主机组成部分不能包含转义八位组，因此此方法不执行任何解码操作。

返回：
此 URI 的主机组成部分，如果主机未定义，则返回 null

getPort

public int getPort()
返回此 URI 的端口号。

URI 的端口组成部分（如果定义了）是一个非负整数。

返回：
此 URI 的端口组成部分，如果端口未定义，则返回 -1

getRawPath

public String getRawPath()
返回此 URI 的原始路径组成部分。

URI 的路径组成部分（如果定义了）只包含斜线字符 ('/')、“商用 at”字符 ('@') 以及 unreserved、punct、escaped 和 other 类别中的字符。

返回：
此 URI 的路径组成部分，如果路径未定义，则返回 null

getPath

public String getPath()
返回此 URI 的已解码的路径组成部分。

除了转义八位组的所有序列都已解码之外，此方法返回的字符串与 getRawPath 方法返回的字符串相等。

返回：
此 URI 的已解码的路径组成部分，如果路径未定义，则返回 null

getRawQuery

public String getRawQuery()
返回此 URI 的原始查询组成部分。

URI 的查询组成部分（如果定义了）只包含合法的 URI 字符。

返回：
此 URI 的原始查询组成部分，如果查询未定义，则返回 null

getQuery

public String getQuery()
返回此 URI 的已解码的查询组成部分。

除了转义八位组的所有序列都已解码之外，此方法返回的字符串与 getRawQuery 方法返回的字符串相等。

返回：
此 URI 的解码查询组成部分，如果查询未定义，则返回 null

getRawFragment

public String getRawFragment()
返回此 URI 的原始片段组成部分。

URI 的片段组成部分（如果定义了）只包含合法的 URI 字符。

返回：
此 URI 的原始片段组成部分，如果片段未定义，则返回 null

getFragment

public String getFragment()
返回此 URI 的已解码的片段组成部分。

除了转义八位组的所有序列都已解码之外，此方法返回的字符串与 getRawFragment 方法返回的字符串相等。

返回：
此 URI 的已解码的片段组成部分，如果片段未定义，则返回 null

equals

public boolean equals(Object ob)
测试此 URI 与另一对象的相等性。

如果给定的对象不是一个 URI，则此方法立即返回 false。

如果要使两个 URI 相等，则要求两者都是不透明的或都是分层的。两者的方案必须都是未定义的或相等（不区分大小写）。两者的片段必须都是未定义的或相等。

如果要使两个不透明的 URI 相等，则其特定于方案的部分必须相等。

如果要使两个分层 URI 相等，则其路径必须相等，并且其查询必须都是未定义的或相等。两者的授权必须都是未定义的，或者都是基于注册表的，或者都是基于服务器的。如果其授权是定义的且都是基于注册表的，则它们一定是相等的。如果其授权是定义的且都是基于服务器的，则其主机一定是相等的（不区分大小写），其端口号一定是相等的，并且其用户信息组成部分也一定相等。

测试两个 URI 的用户信息、路径、查询、片段、授权或特定于方案的部分是否相等时，比较的是这些组成部分的原始形式，而不是编码后的形式，并且在比较转义八位组的十六进制数字时，不区分大小写。

此方法满足 Object.equals 方法的常规协定。

覆盖：
类 Object 中的 equals
参数：
ob - 此对象将与之比较的对象
返回：
当且仅当给定的对象是一个与此 URI 相同的 URI 时，返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 URI 的哈希码值。哈希码基于所有的 URI 组成部分，且满足 Object.hashCode 方法的常规协定。

覆盖：
类 Object 中的 hashCode
返回：
此 URI 的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

compareTo

public int compareTo(URI that)
将此 URI 与另一个对象（也必须是 URI）进行比较。

比较两个 URI 的相应组成部分时，如果其中一个组成部分是未定义的，而另一个是定义的，则认为第一个小于第二个。除非另外说明，字符串组成部分按照其自然的、区分大小写的顺序进行排序，正如在 String.compareTo 方法中定义的一样。比较经过编码的字符串组成部分时，应按照其原始形式进行比较，而不是经过编码的形式。

URI 的排序定义如下：

  • 两个具有不同方案的 URI 按照其方案的顺序进行排序，不区分大小写。

  • 分层 URI 视为小于具有相同方案的不透明 URI。

  • 两个具有相同方案的不透明 URI 按照其特定于方案的部分的顺序进行排序。

  • 两个具有相同方案和特定于方案的部分的不透明 URI 按照其段的顺序进行排序。

  • 两个具有相同方案的分层 URI 按照其授权组成部分的顺序进行排序：

    • 如果两个授权组成部分都是基于服务器的，则 URI 按其用户信息组成部分进行排序；如果这些组成部分都相同，则 URI 按其主机的顺序进行排序，不区分大小写；如果主机相同，则 URI 按其端口的顺序进行排序。

    • 如果授权组成部分中有一个或两个都是基于注册表的，则 URI 按照其授权组成部分的顺序进行排序。

  • 最后，具有相同方案和授权组成部分的两个分层 URI 按照其路径的顺序进行排序；如果其路径相同，则按照其查询的顺序进行排序；如果查询相同，则按照其段的顺序进行排序。

此方法满足 Comparable.compareTo 方法的常规协定。

指定者：
接口 Comparable<URI> 中的 compareTo
参数：
that - 此 URI 将与之比较的对象
返回：
当此 URI 小于、等于或大于给定 URI 时，返回负整数、零或正整数
抛出：
ClassCastException - 如果给定对象不是一个 URI

toString

public String toString()
以字符串形式返回此 URI 的内容。

如果此 URI 通过调用此类的构造方法之一创建，则视情况返回一个与原始输入字符串，或与从原始给定组成部分计算得出的字符串相等的字符串。否则，将通过规范化、解析或相对化创建此 URI，并根据 RFC 2396 的 5.2 节第 7 步指定的规则从此 URI 组成部分构造一个字符串。

覆盖：
类 Object 中的 toString
返回：
此 URI 的字符串形式

toASCIIString

public String toASCIIString()
以 US-ASCII 字符串形式返回此 URI 的内容。

如果此 URI 未包含 other 类别的任何字符，则调用此方法将返回的值与调用 toString 方法返回的值相同。否则，此方法的工作方式类似于调用该方法，然后对结果进行编码。

返回：
此 URI 的字符串形式，根据需要进行编码以保证它只包含 US-ASCII 字符集中的字符
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownHostException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 UnknownHostException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.UnknownHostException
所有已实现的接口：
Serializable
public class UnknownHostException
extends IOException

指示主机 IP 地址无法确定而抛出的异常。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
UnknownHostException()
构造不带详细消息的新 UnknownHostException。
UnknownHostException(String host)
构造带有指定详细消息的新 UnknownHostException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownHostException

public UnknownHostException(String host)
构造带有指定详细消息的新 UnknownHostException。

参数：
host - 详细消息。

UnknownHostException

public UnknownHostException()
构造不带详细消息的新 UnknownHostException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownServiceException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 UnknownServiceException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.net.UnknownServiceException
所有已实现的接口：
Serializable
public class UnknownServiceException
extends IOException

抛出这一异常指示出现了未知服务异常。可能是 URL 连接返回的 MIME 类型无意义，或者应用程序试图进行对只读的 URL 连接写入。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
UnknownServiceException()
构造不带详细消息的新 UnknownServiceException。
UnknownServiceException(String msg)
构造带指定详细消息的新 UnknownServiceException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownServiceException

public UnknownServiceException()
构造不带详细消息的新 UnknownServiceException。

UnknownServiceException

public UnknownServiceException(String msg)
构造带指定详细消息的新 UnknownServiceException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URISyntaxException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URISyntaxException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.net.URISyntaxException
所有已实现的接口：
Serializable
public class URISyntaxException
extends Exception

抛出经过检查的指示字符串不能解析为 URI 引用的异常。

从以下版本开始：
1.4
另请参见：
URI, 序列化表格

构造方法摘要
URISyntaxException(String input, String reason)
根据给定的输入字符串和原因构造一个实例。
URISyntaxException(String input, String reason, int index)
根据给定的输入字符串、原因和错误索引构造一个实例。
方法摘要
int | getIndex() 返回输入字符串中出现解析错误的位置的索引，或者如果该位置为未知，则返回 -1。
String | getInput() 返回输入字符串。
String | getMessage() 返回描述解析错误的字符串。
String | getReason() 返回一个字符串，解释输入字符串不能解析的原因。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

URISyntaxException

public URISyntaxException(String input,
                          String reason,
                          int index)
根据给定的输入字符串、原因和错误索引构造一个实例。

参数：
input - 输入字符串
reason - 解释输入不能解析的原因的字符串
index - 出现解析错误的位置的索引，或者如果索引为未知，则为 -1
抛出：
NullPointerException - 如果输入或原因字符串之一为 null
IllegalArgumentException - 如果错误索引小于 -1

URISyntaxException

public URISyntaxException(String input,
                          String reason)
根据给定的输入字符串和原因构造一个实例。得到的对象将有一个错误索引 -1。

参数：
input - 输入字符串
reason - 解释输入不能解析的原因的字符串
抛出：
NullPointerException - 如果输入或原因字符串之一为 null
方法详细信息

getInput

public String getInput()
返回输入字符串。

返回：
输入字符串

getReason

public String getReason()
返回一个字符串，解释输入字符串不能解析的原因。

返回：
原因字符串

getIndex

public int getIndex()
返回输入字符串中出现解析错误的位置的索引，或者如果该位置为未知，则返回 -1。

返回：
错误索引

getMessage

public String getMessage()
返回描述解析错误的字符串。得到的字符串包含原因字符串，其后为一个冒号字符 (':')，一个空格，然后是输入字符串。如果定义了错误索引，则字符串 " at index "（后跟十进制索引）将插入到原因字符串之后和冒号字符之前。

覆盖：
类 Throwable 中的 getMessage
返回：
A 描述解析错误的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URL (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URL

java.lang.Object
    继承者  java.net.URL
所有已实现的接口：
Serializable
public final class URL
extends Object
implements Serializable

类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。资源可以是简单的文件或目录，也可以是对更为复杂的对象的引用，例如对数据库或搜索引擎的查询。有关 URL 的类型和格式的更多信息，可从以下位置找到：

http://www.socs.uts.edu.au/MosaicDocs-old/url-primer.html

通常，URL 可分成几个部分。上面的 URL 示例指示使用的协议为 http （超文本传输协议）并且该信息驻留在一台名为 www.socs.uts.edu.au 的主机上。主机上的信息名称为 /MosaicDocs-old/url-primer.html。主机上此名称的准确含义取决于协议和主机。该信息一般存储在文件中，但可以随时生成。该 URL 的这一部分称为路径 部分。

URL 可选择指定一个“端口”，它是用于建立到远程主机 TCP 连接的端口号。如果未指定该端口号，则使用协议默认的端口。例如，http 协议的默认端口为 80。还可以指定一个备用端口，如下所示：

     http://www.socs.uts.edu.au:80/MosaicDocs-old/url-primer.html

URL 的语法由此文档定义：RFC 2396:Uniform Resource Identifiers (URI):Generic Syntax；在此文件中对其内容又进行了修正：RFC 2732:Format for Literal IPv6 Addresses in URLs。字面值 IPv6 地址格式还支持 scope_id。scope_id 的语法和用法在此处进行了描述。

URL 后面可能还跟有一个“片段”，也称为“引用”。该片段由井字符 "#" 指示，后面跟有更多的字符。例如，

     http://java.sun.com/index.html#chapter1

从技术角度来讲，URL 并不需要包含此片段。但是，使用此片段的目的在于表明，在获取到指定的资源后，应用程序需要使用文档中附加有 chapter1 标记的部分。标记的含义特定于资源。

应用程序也可以指定一个“相对 URL”，它只包含到达相对于另一个 URL 的资源的足够信息。HTML 页面中经常使用相对 URL。例如，假设 URL 的内容是：

     http://java.sun.com/index.html
其中包含的相对 URL：
     FAQ.html
为以下形式的缩写：
     http://java.sun.com/FAQ.html

相对 URL 不需要指定 URL 的所有组成部分。如果缺少协议、主机名称或端口号，这些值将从完整指定的 URL 中继承。但是，必须指定文件部分。可选的片段部分不继承。

URL 类自身并不根据 RFC2396 中定义的转义机制编码或解码任何 URL 部分。由调用方对任何需要在调用 URL 前进行转义的字段进行编码，并对从 URL 返回的任何经过转义的字段进行解码。进一步而言，由于 URL 不懂 URL 转义，所以它不会识别同一 URL 的对等编码和解码形式。例如，对于这两个 URL：

    http://foo.com/hello world/ 和 http://foo.com/hello%20world
将被视为互不相等。

注意，URI 类在某些特定情况下对其组成字段执行转义。建议使用 URI 管理 URL 的编码和解码，并使用 toURI() 和 URI.toURL() 实现这两个类之间的转换。

也可以使用 URLEncoder 和 URLDecoder 类，但是只适用于 HTML 形式的编码，它与 RFC2396 中定义的编码机制不同。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
URL(String spec)
根据 String 表示形式创建 URL 对象。
URL(String protocol, String host, int port, String file)
根据指定 protocol、host、port 号和 file 创建 URL 对象。
URL(String protocol, String host, int port, String file, URLStreamHandler handler)
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。
URL(String protocol, String host, String file)
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。
URL(URL context, String spec)
通过在指定的上下文中对给定的 spec 进行解析创建 URL。
URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。
方法摘要
boolean | equals(Object obj) 比较此 URL 是否等于另一个对象。
String | getAuthority() 获取此 URL 的授权部分。
Object | getContent() 获取此 URL 的内容。
Object | getContent(Class[] classes) 获取此 URL 的内容。
int | getDefaultPort() 获取与此 URL 关联协议的默认端口号。
String | getFile() 获取此 URL 的文件名。
String | getHost() 获取此 URL 的主机名（如果适用）。
String | getPath() 获取此 URL 的路径部分。
int | getPort() 获取此 URL 的端口号。
String | getProtocol() 获取此 URL 的协议名称。
String | getQuery() 获取此 URL 的查询部分。
String | getRef() 获取此 URL 的锚点（也称为“引用”）。
String | getUserInfo() 获取此 URL 的 userInfo 部分。
int | hashCode() 创建一个适合哈希表索引的整数。
URLConnection | openConnection() 返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。
URLConnection | openConnection(Proxy proxy) 与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
InputStream | openStream() 打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。
boolean | sameFile(URL other) 比较两个 URL，不包括片段部分。
protected void | set(String protocol, String host, int port, String file, String ref) 设置 URL 的字段。
protected void | set(String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref) 设置 URL 的指定的 8 个字段。
static void | setURLStreamHandlerFactory(URLStreamHandlerFactory fac) 设置应用程序的 URLStreamHandlerFactory。
String | toExternalForm() 构造此 URL 的字符串表示形式。
String | toString() 构造此 URL 的字符串表示形式。
URI | toURI() 返回与此 URL 等效的 URI。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

URL

public URL(String protocol,
           String host,
           int port,
           String file)
    throws MalformedURLException
根据指定 protocol、host、port 号和 file 创建 URL 对象。

host 可用主机名或字面值 IP 地址表示。如果使用 IPv6 字面值地址，则应将其括在方括号（'[' 和 ']'）中，如 RFC 2732 中指定的那样；但是，在以下文档中定义的字面值 IPv6 地址格式也可以接受：RFC 2373:IP Version 6 Addressing Architecture。

指定 port 号为 -1 指示 URL 应使用协议的默认端口。

如果这是用指定协议创建的第一个 URL 对象，则还会为该协议创建一个流协议处理程序 对象（类 URLStreamHandler 的一个实例）：

  1. 如果该应用程序已经预先设置了一个 URLStreamHandlerFactory 的实例作为流处理程序工厂，则将调用该实例的 createURLStreamHandler 方法（协议字符串为其中的一个参数）以创建流协议处理程序。
  2. 如果尚未建立 URLStreamHandlerFactory，或者该工厂的 createURLStreamHandler 方法返回 null，则该构造方法将查找如下系统属性的值：
             java.protocol.handler.pkgs
    如果该系统属性的值为非 null，则它被转换为一个由垂直线字符 '|'分隔的包列表。构造方法尝试加载如下名称的类：
             <package>.<protocol>.Handler
    其中，<package> 用包的名称替换，<protocol> 用协议的名称替换。如果不存在此类，或者此类存在但它不是 URLStreamHandler 的子类，则尝试列表中的下一个包。
  3. 如果上面的步骤中未找到协议处理程序，则构造方法将尝试从系统默认包加载。
             <system default package>.<protocol>.Handler
    如果不存在此类，或者该类存在但它不是 URLStreamHandler 的子类，则抛出 MalformedURLException。

应确保搜索路径中包含以下协议的协议处理程序：

http、https、ftp、file 和 jar
还可以有其他协议的协议处理程序。

此构造方法不执行对输入的验证。

参数：
protocol - 要使用的协议名称。
host - 主机名称。
port - 主机端口号。
file - 主机上的文件
抛出：
MalformedURLException - 如果指定了未知协议。
另请参见：
System.getProperty(java.lang.String), setURLStreamHandlerFactory( java.net.URLStreamHandlerFactory), URLStreamHandler, URLStreamHandlerFactory.createURLStreamHandler( java.lang.String)

URL

public URL(String protocol,
           String host,
           String file)
    throws MalformedURLException
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。使用指定协议的默认端口。

此方法等同于调用带四个参数的构造方法，四个参数为 protocol、host、-1 和 file。 此构造方法不执行对输入的验证。

参数：
protocol - 要使用的协议名称。
host - 主机名称。
file - 主机上的文件。
抛出：
MalformedURLException - 如果指定了未知协议。
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String)

URL

public URL(String protocol,
           String host,
           int port,
           String file,
           URLStreamHandler handler)
    throws MalformedURLException
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。指定 port 号为 -1 指示 URL 应使用协议的默认端口。指定 handler 为 null 指示 URL 应使用协议的默认流处理程序，大致如下：java.net.URL#URL(java.lang.String, java.lang.String, int, java.lang.String)

如果处理程序为非 null，并且有安全管理器，则使用 NetPermission("specifyStreamHandler") 权限调用安全管理器的 checkPermission 方法。结果可能是一个 SecurityException 异常。 此构造方法不执行对输入的验证。

参数：
protocol - 要使用的协议名称。
host - 主机名称。
port - 主机端口号。
file - 主机上的文件
handler - URL 的流处理程序。
抛出：
MalformedURLException - 如果指定了未知协议。
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许显式指定流处理程序。
另请参见：
System.getProperty(java.lang.String), setURLStreamHandlerFactory( java.net.URLStreamHandlerFactory), URLStreamHandler, URLStreamHandlerFactory.createURLStreamHandler( java.lang.String), SecurityManager.checkPermission(java.security.Permission), NetPermission

URL

public URL(String spec)
    throws MalformedURLException
根据 String 表示形式创建 URL 对象。

此构造方法等同于调用两个参数的构造方法，其中，第一个参数为 null。

参数：
spec - 将作为 URL 解析的 String。
抛出：
MalformedURLException - 如果字符串指定未知协议。
另请参见：
URL(java.net.URL, java.lang.String)

URL

public URL(URL context,
           String spec)
    throws MalformedURLException
通过在指定的上下文中对给定的 spec 进行解析创建 URL。 新的 URL 从给定的上下文 URL 和 spec 参数创建，这在以下文档中进行了描述：RFC2396 "Uniform Resource Identifiers : Generic * Syntax":
          <scheme>://<authority><path>?<query>#<fragment>
该引用被解析为方案、授权、路径、查询和片段部分。如果路径部分为空，方案、授权和查询部分未定义，则新的 URL 为对当前文档的引用。否则，新的 URL 中将使用 spec 中出现的片段和查询部分。

如果给定的 spec 中定义了方案部分，但与上下文的方案不匹配，则只根据 spec 创建新的绝对 URL。否则，方案部分从上下文 URL 继承。

如果 spec 中有授权部分，则将该 spec 视为绝对的，并用 spec 的授权和路径替换上下文授权和路径。如果 spec 中没有授权部分，则新的 URL 的授权将从上下文继承。

如果 spec 的路径部分以斜线字符 "/" 开始，则将该路径视为绝对的，并用 spec 的路径替换上下文路径。

否则，如 RFC2396 中所述，该路径将被视为相对路径，并被添加到上下文路径中。此外，在这种情况下，还将通过删除由 ".." 和 "." 产生的目录更改对路径进行规范化处理。

有关 URL 解析的更详细的描述，请参考 RFC2396。

参数：
context - 要在其中解析规范的上下文。
spec - 将作为 URL 解析的 String。
抛出：
MalformedURLException - 如果未指定任何协议，或者找到了未知协议。
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String), URLStreamHandler, URLStreamHandler.parseURL(java.net.URL, java.lang.String, int, int)

URL

public URL(URL context,
           String spec,
           URLStreamHandler handler)
    throws MalformedURLException
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。如果处理程序为 null，则使用两参数构造方法进行解析。

参数：
context - 要在其中解析规范的上下文。
spec - 将作为 URL 解析的 String。
handler - URL 的流处理程序。
抛出：
MalformedURLException - 如果未指定任何协议，或者找到了未知协议。
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许指定流处理程序。
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String), URLStreamHandler, URLStreamHandler.parseURL(java.net.URL, java.lang.String, int, int)
方法详细信息

set

protected void set(String protocol,
                   String host,
                   int port,
                   String file,
                   String ref)
设置 URL 的字段。这不是一个公共方法，所以只有 URLStreamHandler 才能修改 URL 字段。其他情况下，URL 为常量。

参数：
protocol - 要使用的协议名称
host - 主机名称
port - 主机端口号
file - 主机上的文件
ref - URL 中的内部引用

set

protected void set(String protocol,
                   String host,
                   int port,
                   String authority,
                   String userInfo,
                   String path,
                   String query,
                   String ref)
设置 URL 的指定的 8 个字段。这不是一个公共方法，所以只有 URLStreamHandler 才能修改 URL 字段。其他情况下，URL 为常量。

参数：
protocol - 要使用的协议名称
host - 主机名称
port - 主机上的端口号
authority - url 的授权部分
userInfo - 用户名和密码
path - 主机上的文件
ref - URL 中的内部引用
query - 此 URL 的查询部分
从以下版本开始：
1.3

getQuery

public String getQuery()
获取此 URL 的查询部分。

返回：
此 URL 的查询，如果没有查询，则返回 null
从以下版本开始：
1.3

getPath

public String getPath()
获取此 URL 的路径部分。

返回：
此 URL 的路径部分，如果没有路径，则返回一个空字符串
从以下版本开始：
1.3

getUserInfo

public String getUserInfo()
获取此 URL 的 userInfo 部分。

返回：
此 URL 的 userInfo 部分，如果没有用户信息，则返回 null
从以下版本开始：
1.3

getAuthority

public String getAuthority()
获取此 URL 的授权部分。

返回：
此 URL 的授权部分
从以下版本开始：
1.3

getPort

public int getPort()
获取此 URL 的端口号。

返回：
端口号，如果未设置端口号，则返回 -1

getDefaultPort

public int getDefaultPort()
获取与此 URL 关联协议的默认端口号。如果 URL 方案或 URL 的 URLStreamHandler 未定义默认的端口号，则返回 -1。

返回：
端口号
从以下版本开始：
1.4

getProtocol

public String getProtocol()
获取此 URL 的协议名称。

返回：
此 URL 的协议。

getHost

public String getHost()
获取此 URL 的主机名（如果适用）。主机的格式遵守 RFC 2732，即对于一个字面值 IPv6 地址，该方法将返回括在方括号 ('[' 和 ']') 中的 IPv6 地址。

返回：
此 URL 的主机名称。

getFile

public String getFile()
获取此 URL 的文件名。返回的文件部分将与 getPath() 相同，再加上 getQuery() 值的规范化形式（如果有）。如果没有查询部分，此方法和 getPath() 将返回相同的结果。

返回：
此 URL 的文件名，如果没有文件名，则返回一个空字符串

getRef

public String getRef()
获取此 URL 的锚点（也称为“引用”）。

返回：
此 URL 的锚点（也称为“引用”），如果没有锚点，则返回 null

equals

public boolean equals(Object obj)
比较此 URL 是否等于另一个对象。

如果给定的对象不是一个 URL，则此方法立即返回 false。

如果两个 URL 具有相同的协议，引用相同的主机，主机上具有相同的端口号，文件相同，片段也都相同，则这两个 URL 对象相等。

如果两个主机名可解析为同一 IP 地址，则认为两个主机相同；如果有一个主机名无法解析，但两个主机名相等（不区分大小写），或者两个主机名都为 null，则也认为这两个主机相同。

由于主机比较需要进行名称解析，所以此操作为阻塞操作。

注：equals 定义的行为已知与 HTTP 的虚拟主机行为不一致。

覆盖：
类 Object 中的 equals
参数：
obj - 要与其比较的 URL。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
创建一个适合哈希表索引的整数。

哈希码基于所有与 URL 比较相关的 URL 部分。因此，此操作为阻塞操作。

覆盖：
类 Object 中的 hashCode
返回：
此 URL 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

sameFile

public boolean sameFile(URL other)
比较两个 URL，不包括片段部分。

如果此 URL 和 other 参数相等，则返回 true，不考虑片段部分。

参数：
other - 要与其比较的 URL。
返回：
如果它们引用相同的远程对象，则返回 true；否则返回 false。

toString

public String toString()
构造此 URL 的字符串表示形式。字符串是通过调用此对象的流协议处理程序的 toExternalForm 方法创建的。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String), URLStreamHandler.toExternalForm(java.net.URL)

toExternalForm

public String toExternalForm()
构造此 URL 的字符串表示形式。字符串是通过调用此对象的流协议处理程序的 toExternalForm 方法创建的。

返回：
此对象的字符串表示形式。
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String), URLStreamHandler.toExternalForm(java.net.URL)

toURI

public URI toURI()
          throws URISyntaxException
返回与此 URL 等效的 URI。此方法的作用与 new URI (this.toString()) 相同。

注意，任何 URL 实例只要遵守 RFC 2396 就可以转化为 URI。但是，有些未严格遵守该规则的 URL 将无法转化为 URI。

返回：
与此 URL 等效的 URI 实例。
抛出：
URISyntaxException - 如果由于该 URL 格式未严格遵守 RFC2396 而无法转化为 URI。
从以下版本开始：
1.5

openConnection

public URLConnection openConnection()
                             throws IOException
返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。

每次调用此 URL 的协议处理程序的 openConnection 方法都打开一个新的连接。

如果 URL 的协议（例如，HTTP 或 JAR）存在属于以下包或其子包之一的公共、专用 URLConnection 子类：java.lang、java.io、java.util、java.net，返回的连接将为该子类的类型。例如，对于 HTTP，将返回 HttpURLConnection，对于 JAR，将返回 JarURLConnection。

返回：
到该 URL 的 URLConnection。
抛出：
IOException - 如果发生 I/O 异常。
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String), URLConnection, URLStreamHandler.openConnection(java.net.URL)

openConnection

public URLConnection openConnection(Proxy proxy)
                             throws IOException
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。 调用此方法会提示系统的默认 ProxySelector 设置。

参数：
proxy - 进行此连接所需的代理。如果希望使用直接连接，则应指定 Proxy.NO_PROXY。
返回：
到该 URL 的 URLConnection。
抛出：
IOException - 如果发生 I/O 异常。
SecurityException - 如果有安全管理器并且调用方没有连接到代理的权限。
IllegalArgumentException - 如果代理为 null，或代理的类型错误
UnsupportedOperationException - 如果实现该协议处理程序的子类不支持此方法。
从以下版本开始：
1.5
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String), URLConnection, URLStreamHandler.openConnection(java.net.URL, java.net.Proxy)

openStream

public final InputStream openStream()
                             throws IOException
打开到此 URL 的连接并返回一个用于从该连接读入的 InputStream。此方法是下面方法的缩写：
     openConnection().getInputStream()

返回：
从 URL 连接读入的输入流。
抛出：
IOException - 如果发生 I/O 异常。
另请参见：
openConnection(), URLConnection.getInputStream()

getContent

public final Object getContent()
                        throws IOException
获取此 URL 的内容。此方法是下面方法的缩写：
     openConnection().getContent()

返回：
此 URL 的内容。
抛出：
IOException - 如果发生 I/O 异常。
另请参见：
URLConnection.getContent()

getContent

public final Object getContent(Class[] classes)
                        throws IOException
获取此 URL 的内容。此方法是下面方法的缩写：
     openConnection().getContent(Class[])

参数：
classes - Java 类型的数组
返回：
此 URL 的内容对象，它为 classes 数组中指定的类型的第一个匹配项。如果所有请求类型都不受支持，则返回 null。
抛出：
IOException - 如果发生 I/O 异常。
从以下版本开始：
1.3
另请参见：
URLConnection.getContent(Class[])

setURLStreamHandlerFactory

public static void setURLStreamHandlerFactory(URLStreamHandlerFactory fac)
设置应用程序的 URLStreamHandlerFactory。在一个给定的 Java 虚拟机中，此方法最多只能调用一次。

URLStreamHandlerFactory 实例用于从协议名称构造流协议处理程序。

如果有安全管理器，此方法首先调用安全管理器的 checkSetFactory 方法以确保允许该操作。这可能会导致 SecurityException 异常。

参数：
fac - 需要的工厂。
抛出：
Error - 如果应用程序已经设置了工厂。
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行此操作。
另请参见：
URL(java.lang.String, java.lang.String, int, java.lang.String), URLStreamHandlerFactory, SecurityManager.checkSetFactory()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLClassLoader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URLClassLoader

java.lang.Object
    继承者  java.lang.ClassLoader
        继承者  java.security.SecureClassLoader
            继承者  java.net.URLClassLoader
直接已知子类：
MLet
public class URLClassLoader
extends SecureClassLoader

该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。这里假定任何以 '/' 结束的 URL 都是指向目录的。如果不是以该字符结束，则认为该 URL 指向一个将根据需要打开的 JAR 文件。

创建 URLClassLoader 实例的 AccessControlContext 线程将在后续加载类和资源时使用。

为加载的类默认授予只能访问 URLClassLoader 创建时指定的 URL 的权限。

从以下版本开始：
1.2

构造方法摘要
URLClassLoader(URL[] urls)
使用默认的委托父 ClassLoader 为指定的 URL 构造一个新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent)
为给定的 URL 构造新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。
方法摘要
protected void | addURL(URL url) 将指定的 URL 添加到 URL 列表中，以便搜索类和资源。
protected Package | definePackage(String name, Manifest man, URL url) 用该 ClassLoader 中的名称定义一个新包。
protected Class<?> | findClass(String name) 通过 URL 搜索路径查找并加载具有指定名称的类。
URL | findResource(String name) 在 URL 搜索路径中查找具有指定名称的资源。
Enumeration<URL> | findResources(String name) 返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。
protected PermissionCollection | getPermissions(CodeSource codesource) 返回给定 codesource 对象的权限。
URL[] | getURLs() 返回用于加载类和资源的 URL 搜索路径。
static URLClassLoader | newInstance(URL[] urls) 为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。
static URLClassLoader | newInstance(URL[] urls, ClassLoader parent) 为指定的 URL 和父类加载器创建新 URLClassLoader 实例。
从类 java.security.SecureClassLoader 继承的方法
defineClass, defineClass
从类 java.lang.ClassLoader 继承的方法
clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findLibrary, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

URLClassLoader

public URLClassLoader(URL[] urls,
                      ClassLoader parent)
为给定的 URL 构造新 URLClassLoader。首先在指定的父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。这里假定任何以 '/' 结束的 URL 都是指向目录的。如果不是以该字符结束，则认为该 URL 指向一个将根据需要下载和打开的 JAR 文件。

如果有安全管理器，该方法首先调用安全管理器的 checkCreateClassLoader 方法以确保允许创建类加载器。

参数：
urls - 从其位置加载类和资源的 UR
parent - 用于委托的父类加载器
抛出：
SecurityException - 如果存在安全管理器，且其 checkCreateClassLoader 方法不允许创建类加载器。
另请参见：
SecurityManager.checkCreateClassLoader()

URLClassLoader

public URLClassLoader(URL[] urls)
使用默认的委托父 ClassLoader 为指定的 URL 构造一个新 URLClassLoader。首先在父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。这里假定任何以 '/' 结束的 URL 都是指向目录的。如果不是以该字符结束，则认为该 URL 指向一个将根据需要下载和打开的 JAR 文件。

如果有安全管理器，该方法首先调用安全管理器的 checkCreateClassLoader 方法以确保允许创建类加载器。

参数：
urls - 从其位置加载类和资源的 URL
抛出：
SecurityException - 如果安全管理器存在并且其 checkCreateClassLoader 方法不允许创建类加载器。
另请参见：
SecurityManager.checkCreateClassLoader()

URLClassLoader

public URLClassLoader(URL[] urls,
                      ClassLoader parent,
                      URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。该父参数将充当委托的父类加载器。该工厂参数将充当创建新 jar URL 时获取协议处理程序的流处理程序工厂。

如果有安全管理器，该方法首先调用安全管理器的 checkCreateClassLoader 方法以确保允许创建类加载器。

参数：
urls - 从其位置加载类和资源的 URL
parent - 用于委托的父类加载器
factory - 创建 URL 时使用的 URLStreamHandlerFactory
抛出：
SecurityException - 如果安全管理器存在并且其 checkCreateClassLoader 方法不允许创建类加载器。
另请参见：
SecurityManager.checkCreateClassLoader()
方法详细信息

addURL

protected void addURL(URL url)
将指定的 URL 添加到 URL 列表中，以便搜索类和资源。

参数：
url - 将添加到 URL 搜索路径中的 URL

getURLs

public URL[] getURLs()
返回用于加载类和资源的 URL 搜索路径。这包括为构造方法指定的原始 URL 列表，以及由 addURL() 方法后续添加的 URL。

返回：
用于加载类和资源的 URL 搜索路径。

findClass

protected Class<?> findClass(String name)
                      throws ClassNotFoundException
通过 URL 搜索路径查找并加载具有指定名称的类。只有在找到该类后，才能根据需要加载和打开任何指向 JAR 文件的 URL。

覆盖：
类 ClassLoader 中的 findClass
参数：
name - 类的名称
返回：
结果类
抛出：
ClassNotFoundException - 如果无法找到该类

definePackage

protected Package definePackage(String name,
                                Manifest man,
                                URL url)
                         throws IllegalArgumentException
用该 ClassLoader 中的名称定义一个新包。该指定的 Manifest 中包含的属性将用于包含包版本和密封信息。对于密封的包，此附加 URL 从加载该包的 URL 指定代码源 URL。

参数：
name - 包的名称
man - 包含包的版本和密封信息的 Manifest
url - 包的代码源 url，或者如果没有，则为 null
返回：
新定义的 Package 对象
抛出：
IllegalArgumentException - 如果包的名称与该类加载器或其祖先之一中现有的包重名

findResource

public URL findResource(String name)
在 URL 搜索路径中查找具有指定名称的资源。

覆盖：
类 ClassLoader 中的 findResource
参数：
name - 资源的名称
返回：
资源的 URL，或者如果无法找到该资源，则返回 null。

findResources

public Enumeration<URL> findResources(String name)
                               throws IOException
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。

覆盖：
类 ClassLoader 中的 findResources
参数：
name - 资源名称
返回：
URL 的枚举
抛出：
IOException - 如果发生 I/O 异常

getPermissions

protected PermissionCollection getPermissions(CodeSource codesource)
返回给定 codesource 对象的权限。该方法的实现首先调用 super.getPermissions，然后基于 codesource 的 URL 添加权限。

如果此 URL 的协议为 "jar"，那么授予的权限将基于 Jar 文件 URL 所请求的权限。

如果协议为 "file"，并且路径指定了某个文件，则要授予对该文件的读权限。如果协议为 "file"，并且路径是一个目录，则要授予该目录中的所有文件及其（递归）子目录中包含的所有文件读权限。

如果协议不是 "file"，则允许连接到和接收来自 URL 主机的连接。

覆盖：
类 SecureClassLoader 中的 getPermissions
参数：
codesource - codesource
返回：
授予 codesource 的权限

newInstance

public static URLClassLoader newInstance(URL[] urls,
                                         ClassLoader parent)
为指定的 URL 和父类加载器创建新 URLClassLoader 实例。如果安装了安全管理器，该方法返回的 URLClassLoader 的 loadClass 方法将在加载该类之前调用 SecurityManager.checkPackageAccess 方法。

参数：
urls - 用于搜索类和资源的 URL
parent - 用于委托的父类加载器
返回：
结果类加载器

newInstance

public static URLClassLoader newInstance(URL[] urls)
为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。如果安装了安全管理器，该方法返回的 URLClassLoader 的 loadClass 方法将在加载该类之前调用 SecurityManager.checkPackageAccess。

参数：
urls - 用于搜索类和资源的 URL
返回：
结果类加载器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLConnection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URLConnection

java.lang.Object
    继承者  java.net.URLConnection
直接已知子类：
HttpURLConnection, JarURLConnection
public abstract class URLConnection
extends Object

抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。此类的实例可用于读取和写入此 URL 引用的资源。通常，创建一个到 URL 的连接需要几个步骤：

openConnection() | connect()
对影响到远程资源连接的参数进行操作。 | 与资源交互；查询头字段和内容。
---------------------------->
时间
  1. 通过在 URL 上调用 openConnection 方法创建连接对象。
  2. 处理设置参数和一般请求属性。
  3. 使用 connect 方法建立到远程对象的实际连接。
  4. 远程对象变为可用。远程对象的头字段和内容变为可访问。

使用以下方法修改设置参数：

  • setAllowUserInteraction
  • setDoInput
  • setDoOutput
  • setIfModifiedSince
  • setUseCaches

使用以下方法修改一般请求属性：

  • setRequestProperty

使用 setDefaultAllowUserInteraction 和 setDefaultUseCaches 可设置 AllowUserInteraction 和 UseCaches 参数的默认值。

上面每个 set 方法都有一个用于获取参数值或一般请求属性值的对应 get 方法。适用的具体参数和一般请求属性取决于协议。

在建立到远程对象的连接后，以下方法用于访问头字段和内容：

  • getContent
  • getHeaderField
  • getInputStream
  • getOutputStream

某些头字段需要经常访问。以下方法：

  • getContentEncoding
  • getContentLength
  • getContentType
  • getDate
  • getExpiration
  • getLastModifed

提供对这些字段的便捷访问。getContent 方法使用 getContentType 方法以确定远程对象类型；子类重写 getContentType 方法很容易。

一般情况下，所有的预连接参数和一般请求属性都可忽略：预连接参数和一般请求属性默认为敏感值。对于此接口的大多数客户端而言，只有两个需要的方法：getInputStream 和 getContent，它们通过便捷方法镜像到 URL 类中。

有关 http 连接的请求属性和头字段的更多信息，可从以下位置找到：

 http://www.ietf.org/rfc/rfc2068.txt
有关 fileNameMap 的注意事项：在 JDK 1.1.6 以前的版本中，URLConnection 的 fileNameMap 字段是公共的。在 JDK 1.1.6 及以后的版本中，fileNameMap 字段是私有的；对其添加了 accessor 方法和 mutator 方法 getFileNameMap 及 setFileNameMap 以便访问。Compatibility 页中也对此更改进行了介绍。 完成请求后，在一个 URLConnection 的 InputStream 或 OutputStream 上调用 close() 方法可以释放与此实例相关的网络资源，除非特定的协议规范为其指定了其他行为。

从以下版本开始：
JDK1.0
另请参见：
URL.openConnection(),
connect(),
getContent(),
getContentEncoding(),
getContentLength(),
getContentType(),
getDate(),
getExpiration(),
getHeaderField(int),
getHeaderField(java.lang.String),
getInputStream(),
getLastModified(),
getOutputStream(),
setAllowUserInteraction(boolean),
setDefaultUseCaches(boolean),
setDoInput(boolean),
setDoOutput(boolean),
setIfModifiedSince(long),
setRequestProperty(java.lang.String, java.lang.String),
setUseCaches(boolean)

字段摘要
protected boolean | allowUserInteraction 如果为 true，则在允许用户交互（例如弹出一个验证对话框）的上下文中对此 URL 进行检查。
protected boolean | connected 如果为 false，则此连接对象尚未创建到指定 URL 的通信链接。
protected boolean | doInput 此变量由 setDoInput 方法设置。
protected boolean | doOutput 此变量由 setDoOutput 方法设置。
protected long | ifModifiedSince 有些协议支持跳过对象获取，除非该对象在某个特定时间点之后又进行了修改。
protected URL | url URL 表示此连接要在互联网上打开的远程对象。
protected boolean | useCaches 如果为 true，则只要有条件就允许协议使用缓存。
构造方法摘要
protected URLConnection(URL url)
构造一个到指定 URL 的 URL 连接。
方法摘要
void | addRequestProperty(String key, String value) 添加由键值对指定的一般请求属性。
abstract void | connect() 打开到此 URL 引用的资源的通信链接（如果尚未建立这样的连接）。
boolean | getAllowUserInteraction() 返回此对象的 allowUserInteraction 字段的值。
int | getConnectTimeout() 返回连接超时设置。
Object | getContent() 获取此 URL 连接的内容。
Object | getContent(Class[] classes) 获取此 URL 连接的内容。
String | getContentEncoding() 返回 content-encoding 头字段的值。
int | getContentLength() 返回 content-length 头字段的值。
String | getContentType() 返回 content-type 头字段的值。
long | getDate() 返回 date 头字段的值。
static boolean | getDefaultAllowUserInteraction() 返回 allowUserInteraction 字段的默认值。
static String | getDefaultRequestProperty(String key) 已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。
boolean | getDefaultUseCaches() 返回 URLConnection 的 useCaches 标志的默认值。
boolean | getDoInput() 返回此 URLConnection 的 doInput 标志的值。
boolean | getDoOutput() 返回此 URLConnection 的 doOutput 标志的值。
long | getExpiration() 返回 expires 头字段的值。
static FileNameMap | getFileNameMap() 从数据文件加载文件名映射（一个 mimetable）。
String | getHeaderField(int n) 返回第 n 个头字段的值。
String | getHeaderField(String name) 返回指定的头字段的值。
long | getHeaderFieldDate(String name, long Default) 返回解析为日期的指定字段的值。
int | getHeaderFieldInt(String name, int Default) 返回解析为数字的指定字段的值。
String | getHeaderFieldKey(int n) 返回第 n 个头字段的键。
Map<String,List<String>> | getHeaderFields() 返回头字段的不可修改的 Map。
long | getIfModifiedSince() 返回此对象的 ifModifiedSince 字段的值。
InputStream | getInputStream() 返回从此打开的连接读取的输入流。
long | getLastModified() 返回 last-modified 头字段的值。
OutputStream | getOutputStream() 返回写入到此连接的输出流。
Permission | getPermission() 返回一个权限对象，其代表建立此对象表示的连接所需的权限。
int | getReadTimeout() 返回读入超时设置。
Map<String,List<String>> | getRequestProperties() 返回一个由此连接的一般请求属性构成的不可修改的 Map。
String | getRequestProperty(String key) 返回此连接指定的一般请求属性值。
URL | getURL() 返回此 URLConnection 的 URL 字段的值。
boolean | getUseCaches() 返回此 URLConnection 的 useCaches 字段的值。
static String | guessContentTypeFromName(String fname) 根据 URL 的指定 "file" 部分尝试确定对象的内容类型。
static String | guessContentTypeFromStream(InputStream is) 根据输入流的开始字符尝试确定输入流的类型。
void | setAllowUserInteraction(boolean allowuserinteraction) 设置此 URLConnection 的 allowUserInteraction 字段的值。
void | setConnectTimeout(int timeout) 设置一个指定的超时值（以毫秒为单位），该值将在打开到此 URLConnection 引用的资源的通信链接时使用。
static void | setContentHandlerFactory(ContentHandlerFactory fac) 设置应用程序的 ContentHandlerFactory。
static void | setDefaultAllowUserInteraction(boolean defaultallowuserinteraction) 将未来的所有 URLConnection 对象的 allowUserInteraction 字段的默认值设置为指定的值。
static void | setDefaultRequestProperty(String key, String value) 已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。
void | setDefaultUseCaches(boolean defaultusecaches) 将 useCaches 字段的默认值设置为指定的值。
void | setDoInput(boolean doinput) 将此 URLConnection 的 doInput 字段的值设置为指定的值。
void | setDoOutput(boolean dooutput) 将此 URLConnection 的 doOutput 字段的值设置为指定的值。
static void | setFileNameMap(FileNameMap map) 设置 FileNameMap。
void | setIfModifiedSince(long ifmodifiedsince) 将此 URLConnection 的 ifModifiedSince 字段的值设置为指定的值。
void | setReadTimeout(int timeout) 将读超时设置为指定的超时值，以毫秒为单位。
void | setRequestProperty(String key, String value) 设置一般请求属性。
void | setUseCaches(boolean usecaches) 将此 URLConnection 的 useCaches 字段的值设置为指定的值。
String | toString() 返回此 URL 连接的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

url

protected URL url
URL 表示此连接要在互联网上打开的远程对象。

使用 getURL 方法可访问此字段的值。

此变量的默认值为 URLConnection 构造方法中的 URL 参数的值。

另请参见：
getURL(), url

doInput

protected boolean doInput
此变量由 setDoInput 方法设置。其值由 getDoInput 方法返回。

URL 连接可用于输入和/或输出。将 doInput 标志设置为 true，指示应用程序要从 URL 连接读取数据。

此字段的默认值为 true。

另请参见：
getDoInput(), setDoInput(boolean)

doOutput

protected boolean doOutput
此变量由 setDoOutput 方法设置。其值由 getDoOutput 方法返回。

URL 连接可用于输入和/或输出。将 doOutput 标志设置为 true，指示应用程序要将数据写入 URL 连接。

此字段的默认值为 false。

另请参见：
getDoOutput(), setDoOutput(boolean)

allowUserInteraction

protected boolean allowUserInteraction
如果为 true，则在允许用户交互（例如弹出一个验证对话框）的上下文中对此 URL 进行检查。如果为 false，则不允许有任何用户交互。

使用 setAllowUserInteraction 方法可对此字段的值进行设置。其值由 getAllowUserInteraction 方法返回。其默认值为上一次调用 setDefaultAllowUserInteraction 方法所用的参数的值。

另请参见：
getAllowUserInteraction(), setAllowUserInteraction(boolean), setDefaultAllowUserInteraction(boolean)

useCaches

protected boolean useCaches
如果为 true，则只要有条件就允许协议使用缓存。如果为 false，则该协议始终必须获得此对象的新副本。

此字段由 setUseCaches 方法设置。其值由 getUseCaches 方法返回。

其默认值为上一次调用 setDefaultUseCaches 方法时给定的值。

另请参见：
setUseCaches(boolean), getUseCaches(), setDefaultUseCaches(boolean)

ifModifiedSince

protected long ifModifiedSince
有些协议支持跳过对象获取，除非该对象在某个特定时间点之后又进行了修改。

一个非零值给定一个时间，它表示距离格林威治标准时间 1970 年 1 月 1 日的毫秒数。只有在该时间之后又进行了修改时，才获取该对象。

此变量由 setIfModifiedSince 方法设置。其值由 getIfModifiedSince 方法返回。

此字段的默认值为 0，表示必须一直进行获取。

另请参见：
getIfModifiedSince(), setIfModifiedSince(long)

connected

protected boolean connected
如果为 false，则此连接对象尚未创建到指定 URL 的通信链接。如果为 true，则已经建立了通信链接。

构造方法详细信息

URLConnection

protected URLConnection(URL url)
构造一个到指定 URL 的 URL 连接。不会创建到 URL 所引用的对象的连接。

参数：
url - 指定的 URL。
方法详细信息

getFileNameMap

public static FileNameMap getFileNameMap()
从数据文件加载文件名映射（一个 mimetable）。它首先尝试加载由 "content.types.user.table" 属性定义的特定于用户的表。如果加载失败，它会尝试加载位于 java 主目录下的 lib/content-types.properties 中的默认内置表。

返回：
FileNameMap
从以下版本开始：
1.2
另请参见：
setFileNameMap(java.net.FileNameMap)

setFileNameMap

public static void setFileNameMap(FileNameMap map)
设置 FileNameMap。

如果有安全管理器，此方法首先调用安全管理器的 checkSetFactory 方法以确保允许该操作。这可能会导致抛出 SecurityException 异常。

参数：
map - 要设置的 FileNameMap
抛出：
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行此操作。
从以下版本开始：
1.2
另请参见：
SecurityManager.checkSetFactory(), getFileNameMap()

connect

public abstract void connect()
                      throws IOException
打开到此 URL 引用的资源的通信链接（如果尚未建立这样的连接）。

如果在已打开连接（此时 connected 字段的值为 true）的情况下调用 connect 方法，则忽略该调用。

URLConnection 对象经历两个阶段：首先创建对象，然后建立连接。在创建对象之后，建立连接之前，可指定各种选项（例如，doInput 和 UseCaches）。连接后再进行设置就会发生错误。连接后才能进行的操作（例如 getContentLength），如有必要，将隐式执行连接。

抛出：
SocketTimeoutException - 如果在建立连接之前超时期满
IOException - 如果打开连接时发生 I/O 错误。
另请参见：
connected, getConnectTimeout(), setConnectTimeout(int)

setConnectTimeout

public void setConnectTimeout(int timeout)
设置一个指定的超时值（以毫秒为单位），该值将在打开到此 URLConnection 引用的资源的通信链接时使用。如果在建立连接之前超时期满，则会引发一个 java.net.SocketTimeoutException。超时时间为零表示无穷大超时。

此方法的一些非标准实现可能忽略指定的超时。要查看连接超时设置，请调用 getConnectTimeout()。

参数：
timeout - 一个指定连接超时值的 int，以毫秒为单位
抛出：
IllegalArgumentException - 如果超时参数为负
从以下版本开始：
1.5
另请参见：
getConnectTimeout(), connect()

getConnectTimeout

public int getConnectTimeout()
返回连接超时设置。

返回 0 表明该选项被禁用（即超时为无穷大）。

返回：
一个指示连接超时值的 int，以毫秒为单位
从以下版本开始：
1.5
另请参见：
setConnectTimeout(int), connect()

setReadTimeout

public void setReadTimeout(int timeout)
将读超时设置为指定的超时值，以毫秒为单位。用一个非零值指定在建立到资源的连接后从 Input 流读入时的超时时间。如果在数据可读取之前超时期满，则会引发一个 java.net.SocketTimeoutException。超时时间为零表示无穷大超时。

此方法的一些非标准实现会忽略指定的超时。要查看读入超时设置，请调用 getReadTimeout()。

参数：
timeout - 一个指定要使用的超时值的 int，以毫秒为单位
抛出：
IllegalArgumentException - 如果超时参数为负
从以下版本开始：
1.5
另请参见：
getReadTimeout(), InputStream.read()

getReadTimeout

public int getReadTimeout()
返回读入超时设置。返回 0 表明该选项被禁用（即超时为无穷大）。

返回：
一个指示读入超时值的 int，以毫秒为单位
从以下版本开始：
1.5
另请参见：
setReadTimeout(int), InputStream.read()

getURL

public URL getURL()
返回此 URLConnection 的 URL 字段的值。

返回：
此 URLConnection 的 URL 字段的值。
另请参见：
url

getContentLength

public int getContentLength()
返回 content-length 头字段的值。

返回：
此连接的 URL 引用的资源的内容长度，或者如果内容长度未知，则返回 -1。

getContentType

public String getContentType()
返回 content-type 头字段的值。

返回：
该 URL 引用的资源的内容类型，或者如果类型为未知，则返回 null。
另请参见：
getHeaderField(java.lang.String)

getContentEncoding

public String getContentEncoding()
返回 content-encoding 头字段的值。

返回：
该 URL 引用的资源的内容编码，或者如果编码为未知，则返回 null。
另请参见：
getHeaderField(java.lang.String)

getExpiration

public long getExpiration()
返回 expires 头字段的值。

返回：
此 URL 引用的资源的期满日期，或者如果为未知，则返回 0。该值为距离格林威治标准时间 1970 年 1 月 1 日的毫秒数。
另请参见：
getHeaderField(java.lang.String)

getDate

public long getDate()
返回 date 头字段的值。

返回：
该 URL 引用的资源的发送日期，或者如果为未知，则返回 0。返回的值为距离格林威治标准时间 1970 年 1 月 1 日的毫秒数。
另请参见：
getHeaderField(java.lang.String)

getLastModified

public long getLastModified()
返回 last-modified 头字段的值。结果为距离格林威治标准时间 1970 年 1 月 1 日的毫秒数。

返回：
此 URLConnection 引用的资源的上次修改日期，或者如果为未知，则返回 0。
另请参见：
getHeaderField(java.lang.String)

getHeaderField

public String getHeaderField(String name)
返回指定的头字段的值。

如果调用的连接多次使用不同的值设置了头字段，则只返回最后一次设置的值。

参数：
name - 头字段的名称。
返回：
指定的头字段的值，或者如果头中没有这样一个字段，则返回 null。

getHeaderFields

public Map<String,List<String>> getHeaderFields()
返回头字段的不可修改的 Map。Map 键是表示 response-header 字段名称的 String。每个 Map 值为一个不可修改的 String 的列表，它们代表相应的字段值。

返回：
头字段的 Map
从以下版本开始：
1.4

getHeaderFieldInt

public int getHeaderFieldInt(String name,
                             int Default)
返回解析为数字的指定字段的值。

有些连接类型（例如 http-ng）具有预解析头，所以存在这种形式的 getHeaderField。用于这种连接类型的类可重写此方法从而缩短解析过程。

参数：
name - 头字段的名称。
Default - 默认值。
返回：
指定字段的值，解析为整数。如果该字段缺少或有错误，则返回 Default 值。

getHeaderFieldDate

public long getHeaderFieldDate(String name,
                               long Default)
返回解析为日期的指定字段的值。结果为指定字段表示的距离格林威治标准时间 1970 年 1 月 1 日的毫秒数。

有些连接类型（例如 http-ng）具有预解析头，所以存在这种形式的 getHeaderField。用于该类型的连接可重写此方法和缩短解析过程。

参数：
name - 头字段的名称。
Default - 默认值。
返回：
字段的值，解析为日期。如果该字段缺少或有错误，则返回 Default 参数的值。

getHeaderFieldKey

public String getHeaderFieldKey(int n)
返回第 n 个头字段的键。如果少于 n+1 个字段，则返回 null。

参数：
n - 一个索引，n>=0
返回：
对应第 n 个头字段的键，或者如果少于 n+1 个字段，则返回 null。

getHeaderField

public String getHeaderField(int n)
返回第 n 个头字段的值。如果少于 n+1 个字段，则返回 null。

此方法可与 getHeaderFieldKey 方法配合使用，以迭代消息中的所有头。

参数：
n - 一个索引，n>=0
返回：
第 n 个头字段的值，或者如果少于 n+1 个字段，则返回 null
另请参见：
getHeaderFieldKey(int)

getContent

public Object getContent()
                  throws IOException
获取此 URL 连接的内容。

此方法首先通过调用 getContentType 方法确定对象的内容类型。如果这是该应用程序第一次遇到的特定内容类型，则会创建适用于该类型的内容处理程序：

  1. 如果该应用程序已使用 setContentHandlerFactory 方法建立了内容处理程序工厂实例，则调用此实例的 createContentHandler 方法，内容类型为其中的一个参数；结果为该内容类型的内容处理程序。
  2. 如果尚未建立任何内容处理程序工厂，或者如果工厂的 createContentHandler 方法返回 null，则应用程序会加载以下名称的类：
             sun.net.www.content.<contentType>
    其中，<contentType> 取自 content-type 字符串，将所有的斜杠字符用句点 ('.')替换，所有其他非字母数字字符用下划线 '_'替换。字母数字字符特指 26 个大写 ASCII 字母 'A' 到 'Z'，26 个小写 ASCII 字母 'a' 到 'z'以及 10 个 ASCII 数字 '0' 到 '9'。如果指定的类不存在，或者不是 ContentHandler 的子类，则抛出一个 UnknownServiceException。

返回：
获取的对象。应使用 instanceof 运算符来确定返回的对象的具体类型。
抛出：
IOException - 如果获取内容时发生 I/O 错误。
UnknownServiceException - 如果协议不支持内容类型。
另请参见：
ContentHandlerFactory.createContentHandler(java.lang.String),
getContentType(),
setContentHandlerFactory(java.net.ContentHandlerFactory)

getContent

public Object getContent(Class[] classes)
                  throws IOException
获取此 URL 连接的内容。

参数：
classes - 指示请求的类型的 Class 数组
返回：
获取的第一个与类数组中指定的类型相匹配的对象。如果请求的类型都不支持，则返回 null。应使用 instanceof 运算符来确定返回的对象的具体类型。
抛出：
IOException - 如果获取内容时发生 I/O 错误。
UnknownServiceException - 如果协议不支持内容类型。
从以下版本开始：
1.3
另请参见：
getContent(),
ContentHandlerFactory.createContentHandler(java.lang.String),
getContent(java.lang.Class[]),
setContentHandlerFactory(java.net.ContentHandlerFactory)

getPermission

public Permission getPermission()
                         throws IOException
返回一个权限对象，其代表建立此对象表示的连接所需的权限。如果建立连接不需要任何权限，则此方法返回 null。默认情况下，此方法返回 java.security.AllPermission。子类应重写此方法并返回一个权限对象，该对象最能代表用于建立到 URL 的连接所需的权限。例如表示 file:URL 的 URLConnection 将返回 java.io.FilePermission 对象。

返回的权限可能取决于连接的状态。例如，连接之前的权限可能不同于连接之后的权限。例如，一个 HTTP 服务器（如 foo.com）可能将连接重定向到一台不同的主机（如 bar.com）。在连接之前，连接返回的权限将代表连接到 foo.com 所需的权限，而连接之后返回的权限将是连接到 bar.com 所需的权限。

使用权限通常有两个目的：保护通过 URLConnection 获取的对象的缓存；检查接收方的权限以了解特定的 URL。第一种情况下，应在获取对象之后 再获取权限。例如，在一个 HTTP 连接中，这将代表连接到最终将从该主机获取数据的主机的权限。第二种情况下，应在连接之前 对权限进行获取和检查。

返回：
代表建立此 URLConnection 表示的连接所需的权限的权限对象。
抛出：
IOException - 如果计算权限需要网络或文件 I/O 并且在计算过程中出现异常。

getInputStream

public InputStream getInputStream()
                           throws IOException
返回从此打开的连接读取的输入流。 在读取返回的输入流时，如果在数据可供读取之前达到读入超时时间，则会抛出 SocketTimeoutException。

返回：
从此打开的连接读入的输入流。
抛出：
IOException - 如果在创建输入流时发生 I/O 错误。
UnknownServiceException - 如果协议不支持输入。
另请参见：
setReadTimeout(int), getReadTimeout()

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
返回写入到此连接的输出流。

返回：
写入到此连接的输出流。
抛出：
IOException - 如果在创建输出流时发生 I/O 错误。
UnknownServiceException - 如果协议不支持输出。

toString

public String toString()
返回此 URL 连接的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
此 URLConnection 的字符串表示形式。

setDoInput

public void setDoInput(boolean doinput)
将此 URLConnection 的 doInput 字段的值设置为指定的值。

URL 连接可用于输入和/或输出。如果打算使用 URL 连接进行输入，则将 DoInput 标志设置为 true；如果不打算使用，则设置为 false。默认值为 true。

参数：
doinput - 新值。
抛出：
IllegalStateException - 如果已连接
另请参见：
doInput, getDoInput()

getDoInput

public boolean getDoInput()
返回此 URLConnection 的 doInput 标志的值。

返回：
此 URLConnection 的 doInput 标志的值。
另请参见：
setDoInput(boolean)

setDoOutput

public void setDoOutput(boolean dooutput)
将此 URLConnection 的 doOutput 字段的值设置为指定的值。

URL 连接可用于输入和/或输出。如果打算使用 URL 连接进行输出，则将 DoOutput 标志设置为 true；如果不打算使用，则设置为 false。默认值为 false。

参数：
dooutput - 新值。
抛出：
IllegalStateException - 如果已连接
另请参见：
getDoOutput()

getDoOutput

public boolean getDoOutput()
返回此 URLConnection 的 doOutput 标志的值。

返回：
此 URLConnection 的 doOutput 标志的值。
另请参见：
setDoOutput(boolean)

setAllowUserInteraction

public void setAllowUserInteraction(boolean allowuserinteraction)
设置此 URLConnection 的 allowUserInteraction 字段的值。

参数：
allowuserinteraction - 新值。
抛出：
IllegalStateException - 如果已连接
另请参见：
getAllowUserInteraction()

getAllowUserInteraction

public boolean getAllowUserInteraction()
返回此对象的 allowUserInteraction 字段的值。

返回：
此对象的 allowUserInteraction 字段的值。
另请参见：
setAllowUserInteraction(boolean)

setDefaultAllowUserInteraction

public static void setDefaultAllowUserInteraction(boolean defaultallowuserinteraction)
将未来的所有 URLConnection 对象的 allowUserInteraction 字段的默认值设置为指定的值。

参数：
defaultallowuserinteraction - 新值。
另请参见：
getDefaultAllowUserInteraction()

getDefaultAllowUserInteraction

public static boolean getDefaultAllowUserInteraction()
返回 allowUserInteraction 字段的默认值。

默认值为 "sticky"，它是所有 URLConnection 的其中一种静态状态。此标志适用于下一个及后续创建的所有 URLConnection。

返回：
allowUserInteraction 字段的默认值。
另请参见：
setDefaultAllowUserInteraction(boolean)

setUseCaches

public void setUseCaches(boolean usecaches)
将此 URLConnection 的 useCaches 字段的值设置为指定的值。

有些协议用于文档缓存。有时候能够进行“直通”并忽略缓存尤其重要，例如浏览器中的“重新加载”按钮。如果连接中的 UseCaches 标志为 true，则允许连接使用任何可用的缓存。如果为 false，则忽略缓存。默认值来自 DefaultUseCaches，它默认为 true。

参数：
usecaches - 一个指示是否允许缓存的 boolean 值
抛出：
IllegalStateException - 如果已连接
另请参见：
getUseCaches()

getUseCaches

public boolean getUseCaches()
返回此 URLConnection 的 useCaches 字段的值。

返回：
此 URLConnection 的 useCaches 字段的值。
另请参见：
setUseCaches(boolean)

setIfModifiedSince

public void setIfModifiedSince(long ifmodifiedsince)
将此 URLConnection 的 ifModifiedSince 字段的值设置为指定的值。

参数：
ifmodifiedsince - 新值。
抛出：
IllegalStateException - 如果已连接
另请参见：
getIfModifiedSince()

getIfModifiedSince

public long getIfModifiedSince()
返回此对象的 ifModifiedSince 字段的值。

返回：
此对象的 ifModifiedSince 字段的值。
另请参见：
setIfModifiedSince(long)

getDefaultUseCaches

public boolean getDefaultUseCaches()
返回 URLConnection 的 useCaches 标志的默认值。

默认值为 "sticky"，它是所有 URLConnection 的一个静态状态。此标志适用于下一个及后续创建的所有 URLConnection。

返回：
URLConnection 的 useCaches 标志的默认值。
另请参见：
setDefaultUseCaches(boolean)

setDefaultUseCaches

public void setDefaultUseCaches(boolean defaultusecaches)
将 useCaches 字段的默认值设置为指定的值。

参数：
defaultusecaches - 新值。
另请参见：
getDefaultUseCaches()

setRequestProperty

public void setRequestProperty(String key,
                               String value)
设置一般请求属性。如果已存在具有该关键字的属性，则用新值改写其值。

注：HTTP 要求所有能够合法拥有多个具有相同键的实例的请求属性，使用以逗号分隔的列表语法，这样可实现将多个属性添加到一个属性中。

参数：
key - 用于识别请求的关键字（例如，"accept"）。
value - 与该键关联的值。
抛出：
IllegalStateException - 如果已连接
NullPointerException - 如果键为 null
另请参见：
getRequestProperty(java.lang.String)

addRequestProperty

public void addRequestProperty(String key,
                               String value)
添加由键值对指定的一般请求属性。此方法不会改写与相同键关联的现有值。

参数：
key - 用于识别请求的关键字（例如，"accept"）。
value - 与该键关联的值。
抛出：
IllegalStateException - 如果已连接
NullPointerException - 如果键为 null
从以下版本开始：
1.4
另请参见：
getRequestProperties()

getRequestProperty

public String getRequestProperty(String key)
返回此连接指定的一般请求属性值。

参数：
key - 用于识别请求的关键字（例如，"accept"）。
返回：
此连接指定的一般请求属性值。如果键为 null，则返回 null。
抛出：
IllegalStateException - 如果已连接
另请参见：
setRequestProperty(java.lang.String, java.lang.String)

getRequestProperties

public Map<String,List<String>> getRequestProperties()
返回一个由此连接的一般请求属性构成的不可修改的 Map。Map 键是一些表示 request-header 字段名称的 String。每个 Map 值为一个不可修改的 String 的列表，它代表相应的字段值。

返回：
此连接的一般请求属性的 Map。
抛出：
IllegalStateException - 如果已连接
从以下版本开始：
1.4

setDefaultRequestProperty

@Deprecated
public static void setDefaultRequestProperty(String key,
                                                        String value)
已过时。 应在获得 URLConnection 的适当实例后使用特定 setRequestProperty 方法的实例。调用此方法没有任何作用。

设置一般请求属性的默认值。创建 URLConnection 时，用这些属性进行初始化。

参数：
key - 用于识别请求的关键字（例如，"accept"）。
value - 与该键关联的值。
另请参见：
setRequestProperty(java.lang.String,java.lang.String), getDefaultRequestProperty(java.lang.String)

getDefaultRequestProperty

@Deprecated
public static String getDefaultRequestProperty(String key)
已过时。 应在获得 URLConnection 的适当实例后使用特定 getRequestProperty 方法的实例。

返回默认请求属性的值。为每个连接都设置了默认请求属性。

参数：
key - 用于识别请求的关键字（例如，"accept"）。
返回：
指定的键的默认请求属性的值。
另请参见：
getRequestProperty(java.lang.String), setDefaultRequestProperty(java.lang.String, java.lang.String)

setContentHandlerFactory

public static void setContentHandlerFactory(ContentHandlerFactory fac)
设置应用程序的 ContentHandlerFactory。一个应用程序最多只能调用一次该方法。

ContentHandlerFactory 实例用于根据内容类型构造内容处理程序。

如果有安全管理器，此方法首先调用安全管理器的 checkSetFactory 方法以确保允许该操作。这可能会导致 SecurityException 异常。

参数：
fac - 需要的工厂。
抛出：
Error - 如果已经定义了工厂。
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行此操作。
另请参见：
ContentHandlerFactory, getContent(), SecurityManager.checkSetFactory()

guessContentTypeFromName

public static String guessContentTypeFromName(String fname)
根据 URL 的指定 "file" 部分尝试确定对象的内容类型。重写 getContentType 方法的子类可使用该便捷方法。

参数：
fname - 文件名。
返回：
基于文件名对对象的内容类型的猜测。
另请参见：
getContentType()

guessContentTypeFromStream

public static String guessContentTypeFromStream(InputStream is)
                                         throws IOException
根据输入流的开始字符尝试确定输入流的类型。此方法可供重写 getContentType 方法的子类使用。

理想情况下，将不需要此例程。但是许多 http 服务器返回不正确的内容类型；另外，还存在许多非标准扩展。通过对字节直接观察来确定内容类型比相信 http 服务器声明的内容类型更准确。

参数：
is - 支持标记的输入流。
返回：
对内容类型的猜测，如果无法确定，则返回 null。
抛出：
IOException - 如果在读取输入流时发生 I/O 错误。
另请参见：
InputStream.mark(int),
InputStream.markSupported(),
getContentType()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLDecoder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URLDecoder

java.lang.Object
    继承者  java.net.URLDecoder

public class URLDecoder
extends Object

HTML 格式解码的实用工具类。该类包含了将 String 从 application/x-www-form-urlencoded MIME 格式解码的静态方法。

该转换过程正好与 URLEncoder 类使用的过程相反。假定已编码的字符串中的所有字符为下列之一："a" 到 "z"、"A" 到 "Z"、"0" 到 "9" 和 "-"、"_"、"." 以及 "*"。允许有 "%" 字符，但是将它解释为特殊转义序列的开始。

转换中使用以下规则：

  • 字母数字字符 "a" 到 "z"、"A" 到 "Z" 和 "0" 到 "9" 保持不变。
  • 特殊字符 "."、"-"、"*" 和 "_" 保持不变。
  • 加号 "+" 转换为空格字符 " "。
  • 将把 "%xy" 格式序列视为一个字节，其中 xy 为 8 位的两位十六进制表示形式。然后，所有连续包含一个或多个这些字节序列的子字符串，将被其编码可生成这些连续字节的字符所代替。可以指定对这些字符进行解码的编码机制，或者如果未指定的话，则使用平台的默认编码机制。

该解码器处理非法字符串有两种可能的方法。一种方法是不管该非法字符，另一种方法是抛出 IllegalArgumentException 异常。解码器具体采用哪种方法取决于实现。

从以下版本开始：
1.2

构造方法摘要
URLDecoder()
方法摘要
static String | decode(String s) 已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。
static String | decode(String s, String enc) 使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

URLDecoder

public URLDecoder()
方法详细信息

decode

@Deprecated
public static String decode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 decode(String,String) 方法指定编码。

对 x-www-form-urlencoded 字符串解码。平台的默认编码用于确定任何 "%xy" 格式的连续序列表示的字符。

参数：
s - 要解码的 String
返回：
新解码的 String

decode

public static String decode(String s,
                            String enc)
                     throws UnsupportedEncodingException
使用指定的编码机制对 application/x-www-form-urlencoded 字符串解码。给定的编码用于确定任何 "%xy" 格式的连续序列表示的字符。

注： World Wide Web Consortium Recommendation 声明应使用 UTF-8。如果不使用该编码，可能造成不兼容性。

参数：
s - 要解码的 String
enc - 所支持的字符编码的名称。
返回：
新解码的 String
抛出：
UnsupportedEncodingException - 如果需要参考字符编码，而指定的字符编码不被支持
从以下版本开始：
1.4
另请参见：
URLEncoder.encode(java.lang.String, java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLEncoder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URLEncoder

java.lang.Object
    继承者  java.net.URLEncoder

public class URLEncoder
extends Object

HTML 格式编码的实用工具类。该类包含了将 String 转换为 application/x-www-form-urlencoded MIME 格式的静态方法。有关 HTML 格式编码的更多信息，请参阅 HTML 规范。

对 String 编码时，使用以下规则：

  • 字母数字字符 "a" 到 "z"、"A" 到 "Z" 和 "0" 到 "9" 保持不变。
  • 特殊字符 "."、"-"、"*" 和 "_" 保持不变。
  • 空格字符 " " 转换为一个加号 "+"。
  • 所有其他字符都是不安全的，因此首先使用一些编码机制将它们转换为一个或多个字节。然后每个字节用一个包含 3 个字符的字符串 "%xy" 表示，其中 xy 为该字节的两位十六进制表示形式。推荐的编码机制是 UTF-8。但是，出于兼容性考虑，如果未指定一种编码，则使用相应平台的默认编码。

例如，使用 UTF-8 编码机制，字符串 "The string ü@foo-bar" 将转换为 "The+string+%C3%BC%40foo-bar"，因为在 UTF-8 中，字符 ü 编码为两个字节，C3 （十六进制）和 BC （十六进制），字符 @ 编码为一个字节 40 （十六进制）。

从以下版本开始：
JDK1.0

方法摘要
static String | encode(String s) 已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。
static String | encode(String s, String enc) 使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

encode

@Deprecated
public static String encode(String s)
已过时。 结果字符串可能因平台默认编码不同而不同。因此，改用 encode(String,String) 方法指定编码。

将字符串转换为 x-www-form-urlencoded 格式。该方法使用相应平台的默认编码作为编码机制以获取不安全字符的字节。

参数：
s - 要转换的 String。
返回：
转换好的 String。

encode

public static String encode(String s,
                            String enc)
                     throws UnsupportedEncodingException
使用指定的编码机制将字符串转换为 application/x-www-form-urlencoded 格式。该方法使用提供的编码机制获取不安全字符的字节。

注： World Wide Web Consortium Recommendation 声明应使用 UTF-8。如果不使用该编码，可能造成不兼容性。

参数：
s - 要转换的 String。
enc - 所支持的字符编码名称。
返回：
已转换的 String。
抛出：
UnsupportedEncodingException - 如果不支持指定的编码
从以下版本开始：
1.4
另请参见：
URLDecoder.decode(java.lang.String, java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLStreamHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.net
类 URLStreamHandler

java.lang.Object
    继承者  java.net.URLStreamHandler

public abstract class URLStreamHandler
extends Object

抽象类 URLStreamHandler 是所有流协议处理程序的通用超类。流协议处理程序知道如何为特定的协议类型，如 http、ftp 或 gopher 进行连接。

在大多数情况下，URLStreamHandler 子类的实例都不是由应用程序直接创建的。而是在构造 URL 过程中第一次遇到协议名称时，自动加载适当的流协议处理程序。

从以下版本开始：
JDK1.0
另请参见：
URL.URL(java.lang.String, java.lang.String, int, java.lang.String)

构造方法摘要
URLStreamHandler()
方法摘要
protected  boolean equals(URL u1, URL u2)
提供默认的 equals 计算。
protected  int getDefaultPort()
返回由该处理程序解析的 URL 的默认端口。
protected  InetAddress getHostAddress(URL u)
获取主机的 IP 地址。
protected  int hashCode(URL u)
提供默认的哈希计算。
protected  boolean hostsEqual(URL u1, URL u2)
比较两个 URL 的主机组件。
protected abstract  URLConnection openConnection(URL u)
打开一个到 URL 参数引用的对象的连接。
protected  URLConnection openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。
protected  void parseURL(URL u, String spec, int start, int limit)
将 URL 的字符表示形式解析为 URL 对象。
protected  boolean sameFile(URL u1, URL u2)
比较两个 url 以确定它们是否引用相同的文件（即具有相同的协议、主机、端口和路径）。
protected  void setURL(URL u, String protocol, String host, int port, String file, String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);
protected  void setURL(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
将 URL 参数的字段设置为指示的值。
protected  String toExternalForm(URL u)
将特定协议的 URL 转换为 String。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

URLStreamHandler

public URLStreamHandler()
方法详细信息

openConnection

protected abstract URLConnection openConnection(URL u)
                                         throws IOException
打开一个到 URL 参数引用的对象的连接。此方法应该由子类重写。

如果对应处理程序的协议（例如，HTTP 或 JAR）存在属于以下包或其子包之一的公共、专用 URLConnection 子类：java.lang、java.io、java.util、java.net，返回的连接将为该子类的类型。例如，对于 HTTP，将返回 HttpURLConnection，对于 JAR，将返回 JarURLConnection。

参数：
u - 所连接的 URL。
返回：
对应于 URL 的 URLConnection 对象。
抛出：
IOException - 如果打开连接时发生 I/O 错误。

openConnection

protected URLConnection openConnection(URL u,
                                       Proxy p)
                                throws IOException
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。 调用该方法会提示系统的默认 ProxySelector 设置。

参数：
u - 所连接的 URL。
p - 进行连接所通过的代理。如果希望使用直接连接，则应指定 Proxy.NO_PROXY。
返回：
对应于 URL 的 URLConnection 对象。
抛出：
IOException - 如果打开连接时发生 I/O 错误。
IllegalArgumentException - 如果 u 或 p 为 null，或者 p 包含错误的类型。
UnsupportedOperationException - 如果实现该协议的子类不支持该方法。
从以下版本开始：
1.5

parseURL

protected void parseURL(URL u,
                        String spec,
                        int start,
                        int limit)
将 URL 的字符表示形式解析为 URL 对象。

如果有任何继承的上下文，则已将其复制到 URL 参数中。

URLStreamHandler 的 parseURL 方法按照 http 规范解析该字符串表示形式。多数 URL 协议家族的解析都很相似。具有不同语法的协议的流协议处理程序必须重写该例程。

参数：
u - 用于接收解析规范的结果的 URL。
spec - 代表必须解析的 URL 的 String。
start - 解析开始处的字符索引。其只传递 ':'（如果有一个），用来指定确定的协议名称。
limit - 停止解析的字符位置。这是字符串的结束或 "#" 字符位置（如果有）。井号之后的所有信息都指示一个定位点。

getDefaultPort

protected int getDefaultPort()
返回由该处理程序解析的 URL 的默认端口。具有默认端口号的处理程序应重写此方法。

返回：
由该处理程序解析的 URL 的默认端口。
从以下版本开始：
1.3

equals

protected boolean equals(URL u1,
                         URL u2)
提供默认的 equals 计算。它可能由其他协议所用的处理程序重写，这些协议对 equals() 有不同要求。该方法要求所有参数都不为 null。因为它只能由 java.net.URL 类调用，所以参数都不为 null，这一点可以得到保证。

参数：
u1 - URL 对象
u2 - URL 对象
返回：
如果两个 url 被视为相等（即它们引用的是同一文件中的相同片段），则返回 true。
从以下版本开始：
1.3

hashCode

protected int hashCode(URL u)
提供默认的哈希计算。它可能由其他协议所用的处理程序重写，这些协议对 hashCode 计算有不同要求。

参数：
u - URL 对象
返回：
适用于哈希表索引的 int
从以下版本开始：
1.3

sameFile

protected boolean sameFile(URL u1,
                           URL u2)
比较两个 url 以确定它们是否引用相同的文件（即具有相同的协议、主机、端口和路径）。该方法要求所有参数都不为 null。因为它只能由 java.net.URL 类间接调用，所以参数都不为 null，这一点可以得到保证。

参数：
u1 - URL 对象
u2 - URL 对象
返回：
如果 u1 和 u2 引用的是同一文件，则返回 true
从以下版本开始：
1.3

getHostAddress

protected InetAddress getHostAddress(URL u)
获取主机的 IP 地址。如果主机字段为空或出现 DNS 错误，则会返回 null。

参数：
u - URL 对象
返回：
表示主机 IP 地址的 InetAddress。
从以下版本开始：
1.3

hostsEqual

protected boolean hostsEqual(URL u1,
                             URL u2)
比较两个 URL 的主机组件。

参数：
u1 - 要比较的第一个主机的 URL
u2 - 要比较的第二个主机的 URL
返回：
当且仅当它们相等时，返回 true，否则返回 false。
从以下版本开始：
1.3

toExternalForm

protected String toExternalForm(URL u)
将特定协议的 URL 转换为 String。

参数：
u - URL
返回：
URL 参数的字符串表示形式。

setURL

protected void setURL(URL u,
                      String protocol,
                      String host,
                      int port,
                      String authority,
                      String userInfo,
                      String path,
                      String query,
                      String ref)
将 URL 参数的字段设置为指示的值。只有从 URLStreamHandler 派生的类才能够在 URL 上调用 set 方法。

参数：
u - 要修改的 URL。
protocol - 协议名称。
host - 对应 URL 的远程主机值。
port - 远程机器上的端口。
authority - URL 的授权部分。
userInfo - URL 的 userInfo 部分。
path - URL 的 path 部分。
query - URL 的 query 部分。
ref - 引用。
抛出：
SecurityException - 如果该 URL 的协议处理程序与这一个不同
从以下版本开始：
1.3
另请参见：
URL.set(java.lang.String, java.lang.String, int, java.lang.String, java.lang.String)

setURL

@Deprecated
protected void setURL(URL u,
                                 String protocol,
                                 String host,
                                 int port,
                                 String file,
                                 String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);

将 URL 参数的字段设置为指示的值。只有从 URLStreamHandler 派生的类才能够在 URL 上调用 set 方法。

参数：
u - 要修改的 URL。
protocol - 协议名称。从 1.2 开始，忽略了该值。
host - 对应 URL 的远程主机值。
port - 远程机器上的端口。
file - 文件。
ref - 引用。
抛出：
SecurityException - 如果该 URL 的协议处理程序与这一个不同
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLStreamHandlerFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.net
接口 URLStreamHandlerFactory

public interface URLStreamHandlerFactory

该接口为 URL 流协议处理程序定义一个工厂。

URL 类使用它可为特定的协议创建 URLStreamHandler。

从以下版本开始：
JDK1.0
另请参见：
URL, URLStreamHandler

方法摘要
 URLStreamHandler createURLStreamHandler(String protocol)
创建具有指定协议的新 URLStreamHandler 实例。

方法详细信息

createURLStreamHandler

URLStreamHandler createURLStreamHandler(String protocol)
创建具有指定协议的新 URLStreamHandler 实例。

参数：
protocol - 协议（"ftp"、"http" 和 "nntp" 等）。
返回：
特定协议的 URLStreamHandler。
另请参见：
URLStreamHandler
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.net (Java 2 Platform SE 6)

 java.net
接口
ContentHandlerFactory
CookiePolicy
CookieStore
DatagramSocketImplFactory
FileNameMap
SocketImplFactory
SocketOptions
URLStreamHandlerFactory
类
Authenticator
CacheRequest
CacheResponse
ContentHandler
CookieHandler
CookieManager
DatagramPacket
DatagramSocket
DatagramSocketImpl
HttpCookie
HttpURLConnection
IDN
Inet4Address
Inet6Address
InetAddress
InetSocketAddress
InterfaceAddress
JarURLConnection
MulticastSocket
NetPermission
NetworkInterface
PasswordAuthentication
Proxy
ProxySelector
ResponseCache
SecureCacheResponse
ServerSocket
Socket
SocketAddress
SocketImpl
SocketPermission
URI
URL
URLClassLoader
URLConnection
URLDecoder
URLEncoder
URLStreamHandler
枚举
Authenticator.RequestorType
Proxy.Type
异常
BindException
ConnectException
HttpRetryException
MalformedURLException
NoRouteToHostException
PortUnreachableException
ProtocolException
SocketException
SocketTimeoutException
UnknownHostException
UnknownServiceException
URISyntaxException


java.net (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.net

为实现网络应用程序提供类。

请参见：
描述

接口摘要
ContentHandlerFactory | 此接口定义内容处理程序的工厂。
CookiePolicy | CookiePolicy 实现决定应该接受哪个 cookie 以及应该拒绝哪个 cookie。
CookieStore | 表示 cookie 存储区的 CookieStore 对象。
DatagramSocketImplFactory | 此接口定义用于数据报套接字实现的工厂。
FileNameMap | 提供在文件名和 MIME 类型字符串之间进行映射的机制的简单接口。
SocketImplFactory | 此接口定义用于套接字实现的工厂。
SocketOptions | 获取/设置套接字选项的方法的接口。
URLStreamHandlerFactory | 该接口为 URL 流协议处理程序定义一个工厂。

类摘要
Authenticator | Authenticator 类表示懂得如何获得网络连接验证的对象。
CacheRequest | 表示在 ResponseCache 中存储资源的通道。
CacheResponse | 表示从 ResponseCache 获取资源的通道。
ContentHandler | 抽象类 ContentHandler 是从 URLConnection 读取 Object 的所有类的超类。
CookieHandler | CookieHandler 对象提供一种回调机制以将 HTTP 状态管理策略实现挂钩到 HTTP 协议处理程序。
CookieManager | CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。
DatagramPacket | 此类表示数据报包。
DatagramSocket | 此类表示用来发送和接收数据报包的套接字。
DatagramSocketImpl | 数据报和多播套接字实现的抽象基类。
HttpCookie | HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。
HttpURLConnection | 支持 HTTP 特定功能的 URLConnection。
IDN | 提供在普通 Unicode 表示形式和 ASCII 兼容性编码 (ACE) 表示形式之间进行国际化域名 (IDN) 转换的方法。
Inet4Address | 此类表示 Internet Protocol version 4 (IPv4) 地址。
Inet6Address | 此类表示互联网协议第 6 版 (IPv6) 地址。
InetAddress | 此类表示互联网协议 (IP) 地址。
InetSocketAddress | 此类实现 IP 套接字地址（IP 地址 + 端口号）。
InterfaceAddress | 此类表示网络接口地址。
JarURLConnection | 连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。
MulticastSocket | 多播数据报套接字类用于发送和接收 IP 多播包。
NetPermission | 此类可用于各种网络权限。
NetworkInterface | 此类表示一个由名称和分配给此接口的 IP 地址列表组成的网络接口。
PasswordAuthentication | PasswordAuthentication 类是供 Authenticator 使用的数据持有者。
Proxy | 此类表示代理设置，通常为类型（http、socks）和套接字地址。
ProxySelector | 连接到 URL 引用的网络资源时选择要使用的代理服务器（如果有）。
ResponseCache | 表示 URLConnection 缓存的实现。
SecureCacheResponse | 表示最初通过安全方法（如 TLS）获得的缓存响应。
ServerSocket | 此类实现服务器套接字。
Socket | 此类实现客户端套接字（也可以就叫“套接字”）。
SocketAddress | 此类表示不带任何协议附件的 Socket Address。
SocketImpl | 抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。
SocketPermission | 此类表示通过套接字对网络的访问。
URI | 表示一个统一资源标识符 (URI) 引用。
URL | 类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。
URLClassLoader | 该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。
URLConnection | 抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。
URLDecoder | HTML 格式解码的实用工具类。
URLEncoder | HTML 格式编码的实用工具类。
URLStreamHandler | 抽象类 URLStreamHandler 是所有流协议处理程序的通用超类。

枚举摘要
Authenticator.RequestorType | 请求验证的实体的类型。
Proxy.Type | 表示代理类型。

异常摘要
BindException | 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
ConnectException | 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
HttpRetryException | 抛出此异常指示 HTTP 请求需要重试，但由于启用了流模式而无法自动重试。
MalformedURLException | 抛出这一异常指示出现了错误的 URL。
NoRouteToHostException | 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
PortUnreachableException | 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。
ProtocolException | 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
SocketException | 抛出此异常指示在底层协议中存在错误，如 TCP 错误。
SocketTimeoutException | 如果在读取或接受套接字时发生超时，则抛出此异常。
UnknownHostException | 指示主机 IP 地址无法确定而抛出的异常。
UnknownServiceException | 抛出这一异常指示出现了未知服务异常。
URISyntaxException | 抛出经过检查的指示字符串不能解析为 URI 引用的异常。

软件包 java.net 的描述

为实现网络应用程序提供类。

java.net 包可以大致分为两个部分：

  • 低级 API，用于处理以下抽象：

    • 地址，也就是网络标识符，如 IP 地址。

    • 套接字，也就是基本双向数据通信机制。

    • 接口，用于描述网络接口。

  • 高级 API，用于处理以下抽象：

    • URI，表示统一资源标识符。

    • URL，表示统一资源定位符。

    • 连接，表示到 URL 所指向资源的连接。

地址

在整个 java.net API 中，地址或者用作主机标识符或者用作套接字端点标识符。

InetAddress 类是表示 IP（Internet 协议）地址的抽象。它拥有两个子类：

  • 用于 IPv4 地址的 Inet4Address。
  • 用于 IPv6 地址的 Inet6Address。

但是，在大多数情况下，不必直接处理子类，因为 InetAddress 抽象应该覆盖大多数必需的功能。

关于 IPv6

并非所有系统都支持 IPv6 协议，而当 Java 网络连接堆栈尝试检测它并在可用时透明地使用它时，还可以利用系统属性禁用它。在 IPv6 不可用或被显式禁用的情况下，Inet6Address 对大多数网络连接操作都不再是有效参数。虽然可以保证在查找主机名时 java.net.InetAddress.getByName 之类的方法不返回 Inet6Address，但仍然可能通过传递字面值来创建此类对象。在此情况下，大多数方法在使用 Inet6Address 调用时都将抛出异常。

套接字

套接字是在网络上建立机器之间的通信链接的方法。java.net 包提供 4 种套接字：

  • Socket 是 TCP 客户端 API，通常用于连接远程主机。
  • ServerSocket 是 TCP 服务器 API，通常接受源于客户端套接字的连接。
  • DatagramSocket 是 UDP 端点 API，用于发送和接收 数据包
  • MulticastSocket 是 DatagramSocket 的子类，在处理多播组时使用。

使用 TCP 套接字的发送和接收操作需要借助 InputStream 和 OutputStream 来完成，这两者是通过 Socket.getInputStream() 和 Socket.getOutputStream() 方法获取的。

接口

NetworkInterface 类提供 API 以浏览和查询本地机器的所有网络接口（例如，以太网连接或 PPP 端点）。只有通过该类才可以检查是否将所有本地接口都配置为支持 IPv6。

高级 API

java.net 包中的许多类可以提供更加高级的抽象，允许方便地访问网络上的资源。这些类为：

  • URI 是表示在 RFC 2396 中指定的统一资料标识符的类。顾名思义，它只是一个标识符，不直接提供访问资源的方法。
  • URL 是表示统一资源定位符的类，它既是 URI 的旧式概念又是访问资源的方法。
  • URLConnection 是根据 URL 创建的，是用于访问 URL 所指向资源的通信链接。此抽象类将大多数工作委托给底层协议处理程序，如 http 或 ftp。
  • HttpURLConnection 是 URLConnection 的子类，提供一些特定于 HTTP 协议的附加功能。

建议的用法是使用 URI 指定资源，然后在访问资源时将其转换为 URL。从该 URL 可以获取 URLConnection 以进行良好控制，也可以直接获取 InputStream。

下面是一个示例：

URI uri = new URI("http://java.sun.com/");
URL url = uri.toURL();
InputStream in = url.openStream();

协议处理程序

如上所述，URL 和 URLConnection 都依赖于协议处理程序，所以协议处理程序必须存在；否则将抛出异常。此为与 URI 的主要不同点，URI 仅标识资源，所以不必访问协议处理程序。因此，尽管可能利用任何种类的协议方案（例如，myproto://myhost.mydomain/resource/）创建 URI，但类似的 URL 仍将试图实例化指定协议的处理程序；如果指定协议的处理程序不存在，则抛出异常。

默认情况下，协议处理程序从默认位置动态加载。但是，通过设置 java.protocol.handler.pkgs 系统属性也可能增加搜索路径。例如，如果将其设置为 myapp.protocols，则 URL 代码将首先尝试（对于 http 而言）加载 myapp.protocols.http.Handler，然后，如果失败，则尝试从默认位置加载 http.Handler。

注意，处理程序类必须为抽象类 URLStreamHandler 的子类。

从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.net 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.net 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.net.Authenticator
    • java.net.CacheRequest
    • java.net.CacheResponse
      • java.net.SecureCacheResponse
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader
    • java.net.ContentHandler
    • java.net.CookieHandler
      • java.net.CookieManager
    • java.net.DatagramPacket
    • java.net.DatagramSocket
      • java.net.MulticastSocket
    • java.net.DatagramSocketImpl (implements java.net.SocketOptions)
    • java.net.HttpCookie (implements java.lang.Cloneable)
    • java.net.IDN
    • java.net.InetAddress (implements java.io.Serializable)
      • java.net.Inet4Address
      • java.net.Inet6Address
    • java.net.InterfaceAddress
    • java.net.NetworkInterface
    • java.net.PasswordAuthentication
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.net.NetPermission
      • java.net.SocketPermission (implements java.io.Serializable)
    • java.net.Proxy
    • java.net.ProxySelector
    • java.net.ResponseCache
    • java.net.ServerSocket
    • java.net.Socket
    • java.net.SocketAddress (implements java.io.Serializable)
      • java.net.InetSocketAddress
    • java.net.SocketImpl (implements java.net.SocketOptions)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • java.net.HttpRetryException
          • java.io.InterruptedIOException
            • java.net.SocketTimeoutException
          • java.net.MalformedURLException
          • java.net.ProtocolException
          • java.net.SocketException
            • java.net.BindException
            • java.net.ConnectException
            • java.net.NoRouteToHostException
            • java.net.PortUnreachableException
          • java.net.UnknownHostException
          • java.net.UnknownServiceException
        • java.net.URISyntaxException
    • java.net.URI (implements java.lang.Comparable<T>, java.io.Serializable)
    • java.net.URL (implements java.io.Serializable)
    • java.net.URLConnection
      • java.net.HttpURLConnection
      • java.net.JarURLConnection
    • java.net.URLDecoder
    • java.net.URLEncoder
    • java.net.URLStreamHandler

接口分层结构

  • java.net.ContentHandlerFactory
  • java.net.CookiePolicy
  • java.net.CookieStore
  • java.net.DatagramSocketImplFactory
  • java.net.FileNameMap
  • java.net.SocketImplFactory
  • java.net.SocketOptions
  • java.net.URLStreamHandlerFactory

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.net.Proxy.Type
      • java.net.Authenticator.RequestorType
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.net 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.net
的使用

使用 java.net 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.rmi | 提供 RMI 包。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.activation |
javax.imageio | Java Image I/O API 的主要包。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.applet 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.awt 使用的 java.net 中的类
URI
表示一个统一资源标识符 (URI) 引用。
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.beans.beancontext 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.io 使用的 java.net 中的类
MalformedURLException
抛出这一异常指示出现了错误的 URL。
URI
表示一个统一资源标识符 (URI) 引用。
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.lang 使用的 java.net 中的类
InetAddress
此类表示互联网协议 (IP) 地址。
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.net 使用的 java.net 中的类
Authenticator
Authenticator 类表示懂得如何获得网络连接验证的对象。
Authenticator.RequestorType
请求验证的实体的类型。
CacheRequest
表示在 ResponseCache 中存储资源的通道。
CacheResponse
表示从 ResponseCache 获取资源的通道。
ContentHandler
抽象类 ContentHandler 是从 URLConnection 读取 Object 的所有类的超类。
ContentHandlerFactory
此接口定义内容处理程序的工厂。
CookieHandler
CookieHandler 对象提供一种回调机制以将 HTTP 状态管理策略实现挂钩到 HTTP 协议处理程序。
CookiePolicy
CookiePolicy 实现决定应该接受哪个 cookie 以及应该拒绝哪个 cookie。
CookieStore
表示 cookie 存储区的 CookieStore 对象。
DatagramPacket
此类表示数据报包。
DatagramSocket
此类表示用来发送和接收数据报包的套接字。
DatagramSocketImpl
数据报和多播套接字实现的抽象基类。
DatagramSocketImplFactory
此接口定义用于数据报套接字实现的工厂。
FileNameMap
提供在文件名和 MIME 类型字符串之间进行映射的机制的简单接口。
HttpCookie
HttpCookie 对象表示一个 http cookie，该 cookie 带有服务器和用户代理之间的状态信息。
Inet6Address
此类表示互联网协议第 6 版 (IPv6) 地址。
InetAddress
此类表示互联网协议 (IP) 地址。
InetSocketAddress
此类实现 IP 套接字地址（IP 地址 + 端口号）。
InterfaceAddress
此类表示网络接口地址。
MalformedURLException
抛出这一异常指示出现了错误的 URL。
NetworkInterface
此类表示一个由名称和分配给此接口的 IP 地址列表组成的网络接口。
PasswordAuthentication
PasswordAuthentication 类是供 Authenticator 使用的数据持有者。
ProtocolException
抛出此异常指示在底层协议中存在错误，如 TCP 错误。
Proxy
此类表示代理设置，通常为类型（http、socks）和套接字地址。
Proxy.Type
表示代理类型。
ProxySelector
连接到 URL 引用的网络资源时选择要使用的代理服务器（如果有）。
ResponseCache
表示 URLConnection 缓存的实现。
Socket
此类实现客户端套接字（也可以就叫“套接字”）。
SocketAddress
此类表示不带任何协议附件的 Socket Address。
SocketException
抛出此异常指示在底层协议中存在错误，如 TCP 错误。
SocketImpl
抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。
SocketImplFactory
此接口定义用于套接字实现的工厂。
SocketOptions
获取/设置套接字选项的方法的接口。
UnknownHostException
指示主机 IP 地址无法确定而抛出的异常。
URI
表示一个统一资源标识符 (URI) 引用。
URISyntaxException
抛出经过检查的指示字符串不能解析为 URI 引用的异常。
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。
URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。
URLConnection
抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。
URLStreamHandler
抽象类 URLStreamHandler 是所有流协议处理程序的通用超类。
URLStreamHandlerFactory
该接口为 URL 流协议处理程序定义一个工厂。

java.nio.channels 使用的 java.net 中的类
DatagramSocket
此类表示用来发送和接收数据报包的套接字。
ServerSocket
此类实现服务器套接字。
Socket
此类实现客户端套接字（也可以就叫“套接字”）。
SocketAddress
此类表示不带任何协议附件的 Socket Address。

java.rmi 使用的 java.net 中的类
MalformedURLException
抛出这一异常指示出现了错误的 URL。

java.rmi.server 使用的 java.net 中的类
MalformedURLException
抛出这一异常指示出现了错误的 URL。
ServerSocket
此类实现服务器套接字。
Socket
此类实现客户端套接字（也可以就叫“套接字”）。
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.security 使用的 java.net 中的类
URI
表示一个统一资源标识符 (URI) 引用。
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

java.sql 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.activation 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.imageio 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.management.loading 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。
URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。
URLStreamHandlerFactory
该接口为 URL 流协议处理程序定义一个工厂。

javax.management.remote 使用的 java.net 中的类
MalformedURLException
抛出这一异常指示出现了错误的 URL。

javax.net 使用的 java.net 中的类
InetAddress
此类表示互联网协议 (IP) 地址。
ServerSocket
此类实现服务器套接字。
Socket
此类实现客户端套接字（也可以就叫“套接字”）。
UnknownHostException
指示主机 IP 地址无法确定而抛出的异常。

javax.net.ssl 使用的 java.net 中的类
HttpURLConnection
支持 HTTP 特定功能的 URLConnection。
InetAddress
此类表示互联网协议 (IP) 地址。
ServerSocket
此类实现服务器套接字。
Socket
此类实现客户端套接字（也可以就叫“套接字”）。
UnknownHostException
指示主机 IP 地址无法确定而抛出的异常。
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。
URLConnection
抽象类 URLConnection 是所有类的超类，它代表应用程序和 URL 之间的通信链接。

javax.print 使用的 java.net 中的类
URI
表示一个统一资源标识符 (URI) 引用。

javax.print.attribute 使用的 java.net 中的类
URI
表示一个统一资源标识符 (URI) 引用。

javax.print.attribute.standard 使用的 java.net 中的类
URI
表示一个统一资源标识符 (URI) 引用。

javax.rmi.ssl 使用的 java.net 中的类
ServerSocket
此类实现服务器套接字。
Socket
此类实现客户端套接字（也可以就叫“套接字”）。

javax.security.auth.kerberos 使用的 java.net 中的类
InetAddress
此类表示互联网协议 (IP) 地址。

javax.sound.midi 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.sound.midi.spi 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.sound.sampled 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.sound.sampled.spi 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.sql 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.sql.rowset 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.sql.rowset.serial 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.swing 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.swing.event 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.swing.plaf.synth 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.swing.text.html 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.tools 使用的 java.net 中的类
URI
表示一个统一资源标识符 (URI) 引用。

javax.xml.bind 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.xml.bind.helpers 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.xml.validation 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.xml.ws 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

javax.xml.ws.spi 使用的 java.net 中的类
URL
类 URL 代表一个统一资源定位符，它是指向互联网“资源”的指针。

org.ietf.jgss 使用的 java.net 中的类
InetAddress
此类表示互联网协议 (IP) 地址。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.CacheRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CacheRequest
的使用

使用 CacheRequest 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CacheRequest 的使用

返回 CacheRequest 的 java.net 中的方法
abstract  CacheRequest ResponseCache.put(URI uri, URLConnection conn)
协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.CacheResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CacheResponse
的使用

使用 CacheResponse 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CacheResponse 的使用

java.net 中 CacheResponse 的子类
 class SecureCacheResponse
表示最初通过安全方法（如 TLS）获得的缓存响应。

返回 CacheResponse 的 java.net 中的方法
abstract  CacheResponse ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders)
根据请求的 uri、请求方法和请求头获取缓存的响应。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.ContentHandlerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.ContentHandlerFactory
的使用

使用 ContentHandlerFactory 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ContentHandlerFactory 的使用

参数类型为 ContentHandlerFactory 的 java.net 中的方法
static void URLConnection.setContentHandlerFactory(ContentHandlerFactory fac)
设置应用程序的 ContentHandlerFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.CookieHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CookieHandler
的使用

使用 CookieHandler 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CookieHandler 的使用

java.net 中 CookieHandler 的子类
 class CookieManager
CookieManager 提供 CookieHandler 的具体实现，它将 cookie 的存储区与围绕接受和拒绝 cookie 的策略分离开来。

返回 CookieHandler 的 java.net 中的方法
static CookieHandler CookieHandler.getDefault()
获取系统级 cookie 处理程序。

参数类型为 CookieHandler 的 java.net 中的方法
static void CookieHandler.setDefault(CookieHandler cHandler)
设置（或取消设置）系统级 cookie 处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.CookieManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.CookieManager
的使用

没有 java.net.CookieManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.CookiePolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.CookiePolicy
的使用

使用 CookiePolicy 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CookiePolicy 的使用

声明为 CookiePolicy 的 java.net 中的字段
static CookiePolicy | CookiePolicy.ACCEPT_ALL 一种预定义策略，表示接受所有 cookie。
static CookiePolicy | CookiePolicy.ACCEPT_NONE 一种预定义策略，表示不接受任何 cookie。
static CookiePolicy | CookiePolicy.ACCEPT_ORIGINAL_SERVER 一种预定义策略，表示只接受来自原始服务器的 cookie。

参数类型为 CookiePolicy 的 java.net 中的方法
 void CookieManager.setCookiePolicy(CookiePolicy cookiePolicy)
设置此 cookie 管理器的 cookie 策略。

参数类型为 CookiePolicy 的 java.net 中的构造方法
CookieManager(CookieStore store, CookiePolicy cookiePolicy)
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.CookieStore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.CookieStore
的使用

使用 CookieStore 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 CookieStore 的使用

返回 CookieStore 的 java.net 中的方法
 CookieStore CookieManager.getCookieStore()
获取当前 cookie 存储区。

参数类型为 CookieStore 的 java.net 中的构造方法
CookieManager(CookieStore store, CookiePolicy cookiePolicy)
使用指定 cookie 存储区和 cookie 策略创建一个新 cookie 管理器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.DatagramSocketImplFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.DatagramSocketImplFactory
的使用

使用 DatagramSocketImplFactory 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 DatagramSocketImplFactory 的使用

参数类型为 DatagramSocketImplFactory 的 java.net 中的方法
static void DatagramSocket.setDatagramSocketImplFactory(DatagramSocketImplFactory fac)
为应用程序设置数据报套接字实现工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.HttpCookie 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.HttpCookie
的使用

使用 HttpCookie 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 HttpCookie 的使用

返回变量类型为 HttpCookie 的类型的 java.net 中的方法
List<HttpCookie> | CookieStore.get(URI uri) 获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
List<HttpCookie> | CookieStore.getCookies() 获取 cookie 存储区中所有未过期的 cookie。
static List<HttpCookie> | HttpCookie.parse(String header) 根据 set-cookie 或 set-cookie2 头字符串构造 cookie。

参数类型为 HttpCookie 的 java.net 中的方法
void | CookieStore.add(URI uri, HttpCookie cookie) 将一个 HTTP cookie 添加到存储区中。
boolean | CookieStore.remove(URI uri, HttpCookie cookie) 从存储区中移除 cookie。
boolean | CookiePolicy.shouldAccept(URI uri, HttpCookie cookie) 调用此方法查看此 cookie 是否应该被接受。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.HttpRetryException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.HttpRetryException
的使用

没有 java.net.HttpRetryException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.IDN 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.IDN
的使用

没有 java.net.IDN 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.PasswordAuthentication 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.PasswordAuthentication
的使用

使用 PasswordAuthentication 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 PasswordAuthentication 的使用

返回 PasswordAuthentication 的 java.net 中的方法
protected PasswordAuthentication | Authenticator.getPasswordAuthentication() 需要密码授权时调用。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType) 要求已经向系统注册的 authenticator 提供密码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.PortUnreachableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.PortUnreachableException
的使用

没有 java.net.PortUnreachableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.ProtocolException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ProtocolException
的使用

使用 ProtocolException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ProtocolException 的使用

抛出 ProtocolException 的 java.net 中的方法
 void HttpURLConnection.setRequestMethod(String method)
设置 URL 请求的方法， GET POST HEAD OPTIONS PUT DELETE TRACE 以上方法之一是合法的，具体取决于协议的限制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.ResponseCache 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ResponseCache
的使用

使用 ResponseCache 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ResponseCache 的使用

返回 ResponseCache 的 java.net 中的方法
static ResponseCache ResponseCache.getDefault()
获取系统级响应缓存。

参数类型为 ResponseCache 的 java.net 中的方法
static void ResponseCache.setDefault(ResponseCache responseCache)
设置（或取消设置）系统级缓存。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URISyntaxException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URISyntaxException
的使用

使用 URISyntaxException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 URISyntaxException 的使用

抛出 URISyntaxException 的 java.net 中的方法
URI | URI.parseServerAuthority() 尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。
URI | URL.toURI() 返回与此 URL 等效的 URI。

抛出 URISyntaxException 的 java.net 中的构造方法
URI(String str)
通过解析给定的字符串构造一个 URI。
URI(String scheme, String ssp, String fragment)
根据给定的组成部分构造 URI。
URI(String scheme, String userInfo, String host, int port, String path, String query, String fragment)
根据给定的组成部分构造一个分层 URI。
URI(String scheme, String host, String path, String fragment)
根据给定的组成部分构造分层 URI。
URI(String scheme, String authority, String path, String query, String fragment)
根据给定的组成部分构造分层 URI。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.SecureCacheResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SecureCacheResponse
的使用

没有 java.net.SecureCacheResponse 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.SocketTimeoutException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketTimeoutException
的使用

没有 java.net.SocketTimeoutException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URLDecoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLDecoder
的使用

没有 java.net.URLDecoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URLEncoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLEncoder
的使用

没有 java.net.URLEncoder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.UnknownServiceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.UnknownServiceException
的使用

没有 java.net.UnknownServiceException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.HttpURLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.HttpURLConnection
的使用

使用 HttpURLConnection 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 HttpURLConnection 的使用

javax.net.ssl 中 HttpURLConnection 的子类
 class HttpsURLConnection
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.SocketPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketPermission
的使用

没有 java.net.SocketPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.NetPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.NetPermission
的使用

没有 java.net.NetPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.InterfaceAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.InterfaceAddress
的使用

使用 InterfaceAddress 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 InterfaceAddress 的使用

返回变量类型为 InterfaceAddress 的类型的 java.net 中的方法
 List<InterfaceAddress> NetworkInterface.getInterfaceAddresses()
获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.NetworkInterface 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.NetworkInterface
的使用

使用 NetworkInterface 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 NetworkInterface 的使用

返回 NetworkInterface 的 java.net 中的方法
static NetworkInterface | NetworkInterface.getByInetAddress(InetAddress addr) 一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
static NetworkInterface | NetworkInterface.getByName(String name) 搜索具有指定名称的网络接口。
NetworkInterface | MulticastSocket.getNetworkInterface() 获取多播网络接口集合。
NetworkInterface | NetworkInterface.getParent() 如果此接口是子接口，则返回它的父 NetworkInterface；如果它是物理（非虚拟）接口或没有父接口，则返回 null。
NetworkInterface | Inet6Address.getScopedInterface() 如果此实例是使用范围接口创建的，则返回范围接口。

返回变量类型为 NetworkInterface 的类型的 java.net 中的方法
static Enumeration<NetworkInterface> | NetworkInterface.getNetworkInterfaces() 返回此机器上的所有接口。
Enumeration<NetworkInterface> | NetworkInterface.getSubInterfaces() 获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。

参数类型为 NetworkInterface 的 java.net 中的方法
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。
 boolean InetAddress.isReachable(NetworkInterface netif, int ttl, int timeout)
测试是否可以达到该地址。
protected abstract  void DatagramSocketImpl.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入多播组。
 void MulticastSocket.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf)
加入指定接口上的指定多播组。
protected abstract  void DatagramSocketImpl.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
退出多播组。
 void MulticastSocket.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf)
离开指定本地接口上的多播组。
 void MulticastSocket.setNetworkInterface(NetworkInterface netIf)
指定在此套接字上发送的输出多播数据报的网络接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.DatagramSocketImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.DatagramSocketImpl
的使用

使用 DatagramSocketImpl 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 DatagramSocketImpl 的使用

返回 DatagramSocketImpl 的 java.net 中的方法
 DatagramSocketImpl DatagramSocketImplFactory.createDatagramSocketImpl()
创建新的 DatagramSocketImpl 实例。

参数类型为 DatagramSocketImpl 的 java.net 中的构造方法
DatagramSocket(DatagramSocketImpl impl)
创建带有指定 DatagramSocketImpl 的未绑定数据报套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.DatagramPacket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.DatagramPacket
的使用

使用 DatagramPacket 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 DatagramPacket 的使用

参数类型为 DatagramPacket 的 java.net 中的方法
protected abstract  int DatagramSocketImpl.peekData(DatagramPacket p)
查看包来自哪里。
protected abstract  void DatagramSocketImpl.receive(DatagramPacket p)
接收数据报包。
 void DatagramSocket.receive(DatagramPacket p)
从此套接字接收数据报包。
protected abstract  void DatagramSocketImpl.send(DatagramPacket p)
发送数据报包。
 void DatagramSocket.send(DatagramPacket p)
从此套接字发送数据报包。
 void MulticastSocket.send(DatagramPacket p, byte ttl)
已过时。 使用以下代码或其等效代码：...... int ttl = mcastSocket.getTimeToLive(); mcastSocket.setTimeToLive(newttl); mcastSocket.send(p); mcastSocket.setTimeToLive(ttl); ......

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.MulticastSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.MulticastSocket
的使用

没有 java.net.MulticastSocket 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.DatagramSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.DatagramSocket
的使用

使用 DatagramSocket 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.net 中 DatagramSocket 的使用

java.net 中 DatagramSocket 的子类
 class MulticastSocket
多播数据报套接字类用于发送和接收 IP 多播包。

java.nio.channels 中 DatagramSocket 的使用

返回 DatagramSocket 的 java.nio.channels 中的方法
abstract  DatagramSocket DatagramChannel.socket()
获取与此通道关联的数据报套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.BindException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.BindException
的使用

没有 java.net.BindException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.NoRouteToHostException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.NoRouteToHostException
的使用

没有 java.net.NoRouteToHostException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.FileNameMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.FileNameMap
的使用

使用 FileNameMap 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 FileNameMap 的使用

返回 FileNameMap 的 java.net 中的方法
static FileNameMap URLConnection.getFileNameMap()
从数据文件加载文件名映射（一个 mimetable）。

参数类型为 FileNameMap 的 java.net 中的方法
static void URLConnection.setFileNameMap(FileNameMap map)
设置 FileNameMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.SocketImplFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.SocketImplFactory
的使用

使用 SocketImplFactory 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketImplFactory 的使用

参数类型为 SocketImplFactory 的 java.net 中的方法
static void | ServerSocket.setSocketFactory(SocketImplFactory fac) 为应用程序设置服务器套接字实现工厂。
static void | Socket.setSocketImplFactory(SocketImplFactory fac) 为应用程序设置客户端套接字实现工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.UnknownHostException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.UnknownHostException
的使用

使用 UnknownHostException 的软件包
java.net | 为实现网络应用程序提供类。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 UnknownHostException 的使用

抛出 UnknownHostException 的 java.net 中的方法
static InetAddress[] InetAddress.getAllByName(String host)
在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。
static InetAddress InetAddress.getByAddress(byte[] addr)
在给定原始 IP 地址的情况下，返回 InetAddress 对象。
static InetAddress InetAddress.getByAddress(String host, byte[] addr)
根据提供的主机名和 IP 地址创建 InetAddress。
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, int scope_id)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。
static InetAddress InetAddress.getByName(String host)
在给定主机名的情况下确定主机的 IP 地址。
static InetAddress InetAddress.getLocalHost()
返回本地主机。

抛出 UnknownHostException 的 java.net 中的构造方法
Socket(String host, int port)
创建一个流套接字并将其连接到指定主机上的指定端口号。

javax.net 中 UnknownHostException 的使用

抛出 UnknownHostException 的 javax.net 中的方法
abstract Socket | SocketFactory.createSocket(String host, int port) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 UnknownHostException 的使用

抛出 UnknownHostException 的 javax.net.ssl 中的构造方法
SSLSocket(String host, int port)
仅供子类使用。
SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.ServerSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ServerSocket
的使用

使用 ServerSocket 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.nio.channels 中 ServerSocket 的使用

返回 ServerSocket 的 java.nio.channels 中的方法
abstract  ServerSocket ServerSocketChannel.socket()
获取与此通道关联的服务器套接字。

java.rmi.server 中 ServerSocket 的使用

返回 ServerSocket 的 java.rmi.server 中的方法
ServerSocket | RMIServerSocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
abstract ServerSocket | RMISocketFactory.createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。

javax.net 中 ServerSocket 的使用

返回 ServerSocket 的 javax.net 中的方法
ServerSocket | ServerSocketFactory.createServerSocket() 返回未绑定的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port) 返回绑定到指定端口的服务器套接字。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog) 返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog, InetAddress ifAddress) 返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。

javax.net.ssl 中 ServerSocket 的使用

javax.net.ssl 中 ServerSocket 的子类
 class SSLServerSocket
此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。

javax.rmi.ssl 中 ServerSocket 的使用

返回 ServerSocket 的 javax.rmi.ssl 中的方法
 ServerSocket SslRMIServerSocketFactory.createServerSocket(int port)
创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.JarURLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.JarURLConnection
的使用

没有 java.net.JarURLConnection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.ConnectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ConnectException
的使用

没有 java.net.ConnectException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.Proxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Proxy
的使用

使用 Proxy 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Proxy 的使用

声明为 Proxy 的 java.net 中的字段
static Proxy Proxy.NO_PROXY
表示 DIRECT 连接的代理设置，主要通知协议处理程序不使用任何代理。

返回变量类型为 Proxy 的类型的 java.net 中的方法
abstract  List<Proxy> ProxySelector.select(URI uri)
基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。

参数类型为 Proxy 的 java.net 中的方法
 URLConnection URL.openConnection(Proxy proxy)
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。

参数类型为 Proxy 的 java.net 中的构造方法
Socket(Proxy proxy)
创建一个未连接的套接字并指定代理类型（如果有），该代理不管其他设置如何都应被使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.Proxy.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Proxy.Type
的使用

使用 Proxy.Type 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Proxy.Type 的使用

返回 Proxy.Type 的 java.net 中的方法
Proxy.Type | Proxy.type() 返回代理类型。
static Proxy.Type | Proxy.Type.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Proxy.Type[] | Proxy.Type.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Proxy.Type 的 java.net 中的构造方法
Proxy(Proxy.Type type, SocketAddress sa)
创建表示 PROXY 连接的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URI
的使用

使用 URI 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.awt 中 URI 的使用

参数类型为 URI 的 java.awt 中的方法
void | Desktop.browse(URI uri) 启动默认浏览器来显示 URI。
void | Desktop.mail(URI mailtoURI) 启动用户默认邮件客户端的邮件组合窗口，填充由 mailto: URI 指定的消息字段。

java.io 中 URI 的使用

返回 URI 的 java.io 中的方法
 URI File.toURI()
构造一个表示此抽象路径名的 file: URI。

参数类型为 URI 的 java.io 中的构造方法
File(URI uri)
通过将给定的 file: URI 转换为一个抽象路径名来创建一个新的 File 实例。

java.net 中 URI 的使用

返回 URI 的 java.net 中的方法
static URI | URI.create(String str) 通过解析给定的字符串创建 URI。
URI | URI.normalize() 规范化此 URI 的路径。
URI | URI.parseServerAuthority() 尝试将此 URI 的授权组成部分（如果已定义）解析为用户信息、主机和端口组成部分。
URI | URI.relativize(URI uri) 根据此 URI 将给定 URI 相对化。
URI | URI.resolve(String str) 解析给定的字符串，然后在此 URI 的基础上构造一个新的 URI。
URI | URI.resolve(URI uri) 根据此 URI 解析给定的 URI。
URI | URL.toURI() 返回与此 URL 等效的 URI。

返回变量类型为 URI 的类型的 java.net 中的方法
 List<URI> CookieStore.getURIs()
获取所有标识此 cookie 存储区中 cookie 的 URI。

参数类型为 URI 的 java.net 中的方法
void | CookieStore.add(URI uri, HttpCookie cookie) 将一个 HTTP cookie 添加到存储区中。
int | URI.compareTo(URI that) 将此 URI 与另一个对象（也必须是 URI）进行比较。
abstract void | ProxySelector.connectFailed(URI uri, SocketAddress sa, IOException ioe) 调用此方法来指示无法建立到代理/socks 服务器的连接。
List<HttpCookie> | CookieStore.get(URI uri) 获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract CacheResponse | ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders) 根据请求的 uri、请求方法和请求头获取缓存的响应。
abstract void | CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
void | CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)
abstract CacheRequest | ResponseCache.put(URI uri, URLConnection conn) 协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。
URI | URI.relativize(URI uri) 根据此 URI 将给定 URI 相对化。
boolean | CookieStore.remove(URI uri, HttpCookie cookie) 从存储区中移除 cookie。
URI | URI.resolve(URI uri) 根据此 URI 解析给定的 URI。
abstract List<Proxy> | ProxySelector.select(URI uri) 基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。
boolean | CookiePolicy.shouldAccept(URI uri, HttpCookie cookie) 调用此方法查看此 cookie 是否应该被接受。

java.security 中 URI 的使用

返回 URI 的 java.security 中的方法
 URI URIParameter.getURI()
返回 URI。

参数类型为 URI 的 java.security 中的构造方法
URIParameter(URI uri)
使用指向数据的 URI 构造一个 URIParameter，指向的数据用于 SPI 实现。

javax.print 中 URI 的使用

返回 URI 的 javax.print 中的方法
 URI URIException.getUnsupportedURI()
返回 URI。

javax.print.attribute 中 URI 的使用

返回 URI 的 javax.print.attribute 中的方法
 URI URISyntax.getURI()
返回此 URI 属性的 URI 值。

参数类型为 URI 的 javax.print.attribute 中的构造方法
URISyntax(URI uri)
构造带有指定 URI 的 URI 属性。

javax.print.attribute.standard 中 URI 的使用

参数类型为 URI 的 javax.print.attribute.standard 中的构造方法
Destination(URI uri)
构造具有给定 URI 的新目标属性。
PrinterMoreInfo(URI uri)
构造具有指定 URI 的新 PrinterMoreInfo 属性。
PrinterMoreInfoManufacturer(URI uri)
构造具有指定 URI 的新 PrinterMoreInfoManufacturer 属性。
PrinterURI(URI uri)
构建具有指定 URI 的新 PrinterURI 属性。

javax.tools 中 URI 的使用

声明为 URI 的 javax.tools 中的字段
protected  URI SimpleJavaFileObject.uri
此文件对象的 URI。

返回 URI 的 javax.tools 中的方法
URI | FileObject.toUri() 返回标识此文件对象的 URI。
URI | ForwardingFileObject.toUri()
URI | SimpleJavaFileObject.toUri()

参数类型为 URI 的 javax.tools 中的构造方法
SimpleJavaFileObject(URI uri, JavaFileObject.Kind kind)
使用给定 URI 构建给定种类的 SimpleJavaFileObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.Inet6Address 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Inet6Address
的使用

使用 Inet6Address 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Inet6Address 的使用

返回 Inet6Address 的 java.net 中的方法
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, int scope_id)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为给定的数字值。
static Inet6Address Inet6Address.getByAddress(String host, byte[] addr, NetworkInterface nif)
完全按照 InetAddress.getByAddress(String,byte[]) 的方式创建 Inet6Address，唯一的不同是将 IPv6 scope_id 设置为与在 addr 中指定地址类型的给定接口相对应的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.ProxySelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ProxySelector
的使用

使用 ProxySelector 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ProxySelector 的使用

返回 ProxySelector 的 java.net 中的方法
static ProxySelector ProxySelector.getDefault()
获取系统级代理选择器。

参数类型为 ProxySelector 的 java.net 中的方法
static void ProxySelector.setDefault(ProxySelector ps)
设置（或取消设置）系统级代理选择器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.SocketException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketException
的使用

使用 SocketException 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketException 的使用

java.net 中 SocketException 的子类
class | BindException 试图将套接字绑定到本地地址和端口时发生错误的情况下，抛出此异常。
class | ConnectException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | NoRouteToHostException 试图将套接字连接到远程地址和端口时发生错误的情况下，抛出此异常。
class | PortUnreachableException 在连接的数据报上已接收到 ICMP Port Unreachable 消息时，抛出该异常。

抛出 SocketException 的 java.net 中的方法
protected abstract void | DatagramSocketImpl.bind(int lport, InetAddress laddr) 将数据报套接字绑定到本地端口和地址。
void | DatagramSocket.bind(SocketAddress addr) 将此 DatagramSocket 绑定到特定的地址和端口。
protected void | DatagramSocketImpl.connect(InetAddress address, int port) 将数据报套接字连接到远程目标。
void | DatagramSocket.connect(SocketAddress addr) 将此套接字连接到远程套接字地址（IP 地址 + 端口号）。
protected abstract void | DatagramSocketImpl.create() 创建数据报套接字。
boolean | DatagramSocket.getBroadcast() 检测是否启用了 SO_BROADCAST。
static NetworkInterface | NetworkInterface.getByInetAddress(InetAddress addr) 一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
static NetworkInterface | NetworkInterface.getByName(String name) 搜索具有指定名称的网络接口。
byte[] | NetworkInterface.getHardwareAddress() 如果存在硬件地址并可以使用给定的当前权限访问，则返回该硬件地址（通常是 MAC）。
InetAddress | MulticastSocket.getInterface() 获取用于多播数据包的网络接口的地址。
boolean | Socket.getKeepAlive() 测试是否启用 SO_KEEPALIVE。
boolean | MulticastSocket.getLoopbackMode() 获取多播数据报的本地回送的设置。
int | NetworkInterface.getMTU() 返回此接口的最大传输单元（Maximum Transmission Unit，MTU）。
NetworkInterface | MulticastSocket.getNetworkInterface() 获取多播网络接口集合。
static Enumeration<NetworkInterface> | NetworkInterface.getNetworkInterfaces() 返回此机器上的所有接口。
boolean | Socket.getOOBInline() 测试是否启用 OOBINLINE。
Object | SocketOptions.getOption(int optID) 获取选项的值。
int | DatagramSocket.getReceiveBufferSize() 获取此 DatagramSocket 的 SO_RCVBUF 选项的值，该值是平台在 DatagramSocket 上输入时使用的缓冲区大小。
int | ServerSocket.getReceiveBufferSize() 获取此 ServerSocket 的 SO_RCVBUF 选项的值，该值是将用于从此 ServerSocket 接受的套接字的建议缓冲区大小。
int | Socket.getReceiveBufferSize() 获取此 Socket 的 SO_RCVBUF 选项的值，该值是平台在 Socket 上输入时使用的缓冲区大小。
boolean | DatagramSocket.getReuseAddress() 检测是否启用了 SO_REUSEADDR。
boolean | ServerSocket.getReuseAddress() 测试是否启用 SO_REUSEADDR。
boolean | Socket.getReuseAddress() 测试是否启用 SO_REUSEADDR。
int | DatagramSocket.getSendBufferSize() 获取此 DatagramSocket 的 SO_SNDBUF 选项的值，该值是平台在 DatagramSocket 上输出时使用的缓冲区大小。
int | Socket.getSendBufferSize() 获取此 Socket 的 SO_SNDBUF 选项的值，该值是平台在 Socket 上输出时使用的缓冲区大小。
int | Socket.getSoLinger() 返回 SO_LINGER 的设置。
int | DatagramSocket.getSoTimeout() 获取 SO_TIMEOUT 的设置。
int | Socket.getSoTimeout() 返回 SO_TIMEOUT 的设置。
boolean | Socket.getTcpNoDelay() 测试是否启用 TCP_NODELAY。
int | DatagramSocket.getTrafficClass() 为从此 DatagramSocket 上发送的包获取 IP 数据报头中的流量类别或服务类型。
int | Socket.getTrafficClass() 为从此 Socket 上发送的包获取 IP 头中的流量类别或服务类型。
boolean | NetworkInterface.isLoopback() 返回网络接口是否是回送接口。
boolean | NetworkInterface.isPointToPoint() 返回网络接口是否是点对点接口。
boolean | NetworkInterface.isUp() 返回网络接口是否已经开启并运行。
void | DatagramSocket.setBroadcast(boolean on) 启用/禁用 SO_BROADCAST。
void | MulticastSocket.setInterface(InetAddress inf) 设置多播网络接口，供其行为将受网络接口值影响的方法使用。
void | Socket.setKeepAlive(boolean on) 启用/禁用 SO_KEEPALIVE。
void | MulticastSocket.setLoopbackMode(boolean disable) 启用/禁用多播数据报的本地回送。
void | MulticastSocket.setNetworkInterface(NetworkInterface netIf) 指定在此套接字上发送的输出多播数据报的网络接口。
void | Socket.setOOBInline(boolean on) 启用/禁用 OOBINLINE（TCP 紧急数据的接收者） 默认情况下，此选项是禁用的，即在套接字上接收的 TCP 紧急数据被静默丢弃。
void | SocketOptions.setOption(int optID, Object value) 启用/禁用 optID 指定的选项。
void | DatagramSocket.setReceiveBufferSize(int size) 将此 DatagramSocket 的 SO_RCVBUF 选项设置为指定的值。
void | ServerSocket.setReceiveBufferSize(int size) 为从此 ServerSocket 接受的套接字的 SO_RCVBUF 选项设置默认建议值。
void | Socket.setReceiveBufferSize(int size) 将此 Socket 的 SO_RCVBUF 选项设置为指定的值。
void | DatagramSocket.setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | ServerSocket.setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | Socket.setReuseAddress(boolean on) 启用/禁用 SO_REUSEADDR 套接字选项。
void | DatagramSocket.setSendBufferSize(int size) 将此 DatagramSocket 的 SO_SNDBUF 选项设置为指定的值。
void | Socket.setSendBufferSize(int size) 将此 Socket 的 SO_SNDBUF 选项设置为指定的值。
void | Socket.setSoLinger(boolean on, int linger) 启用/禁用具有指定逗留时间（以秒为单位）的 SO_LINGER。
void | DatagramSocket.setSoTimeout(int timeout) 启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
void | ServerSocket.setSoTimeout(int timeout) 通过指定超时值启用/禁用 SO_TIMEOUT，以毫秒为单位。
void | Socket.setSoTimeout(int timeout) 启用/禁用带有指定超时值的 SO_TIMEOUT，以毫秒为单位。
void | Socket.setTcpNoDelay(boolean on) 启用/禁用 TCP_NODELAY（启用/禁用 Nagle 算法）。
void | DatagramSocket.setTrafficClass(int tc) 为从此 DatagramSocket 上发送的数据报在 IP 数据报头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
void | Socket.setTrafficClass(int tc) 为从此 Socket 上发送的包在 IP 头中设置流量类别 (traffic class) 或服务类型八位组 (type-of-service octet)。
boolean | NetworkInterface.supportsMulticast() 返回网络接口是否支持多址广播。

抛出 SocketException 的 java.net 中的构造方法
DatagramPacket(byte[] buf, int offset, int length, SocketAddress address)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int length, SocketAddress address)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramSocket()
构造数据报套接字并将其绑定到本地主机上任何可用的端口。
DatagramSocket(int port)
创建数据报套接字并将其绑定到本地主机上的指定端口。
DatagramSocket(int port, InetAddress laddr)
创建数据报套接字，将其绑定到指定的本地地址。
DatagramSocket(SocketAddress bindaddr)
创建数据报套接字，将其绑定到指定的本地套接字地址。
Socket(SocketImpl impl)
使用用户指定的 SocketImpl 创建一个未连接 Socket。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.SocketImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketImpl
的使用

使用 SocketImpl 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketImpl 的使用

返回 SocketImpl 的 java.net 中的方法
 SocketImpl SocketImplFactory.createSocketImpl()
创建新的 SocketImpl 实例。

参数类型为 SocketImpl 的 java.net 中的方法
protected abstract  void SocketImpl.accept(SocketImpl s)
接受连接。

参数类型为 SocketImpl 的 java.net 中的构造方法
Socket(SocketImpl impl)
使用用户指定的 SocketImpl 创建一个未连接 Socket。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.SocketOptions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.SocketOptions
的使用

使用 SocketOptions 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 SocketOptions 的使用

实现 SocketOptions 的 java.net 中的类
class | DatagramSocketImpl 数据报和多播套接字实现的抽象基类。
class | SocketImpl 抽象类 SocketImpl 是实际实现套接字的所有类的通用超类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.InetSocketAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.InetSocketAddress
的使用

使用 InetSocketAddress 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 InetSocketAddress 的使用

返回 InetSocketAddress 的 java.net 中的方法
static InetSocketAddress InetSocketAddress.createUnresolved(String host, int port)
根据主机名和端口号创建未解析的套接字地址。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.SocketAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.SocketAddress
的使用

使用 SocketAddress 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.net 中 SocketAddress 的使用

java.net 中 SocketAddress 的子类
 class InetSocketAddress
此类实现 IP 套接字地址（IP 地址 + 端口号）。

返回 SocketAddress 的 java.net 中的方法
SocketAddress | Proxy.address() 返回代理的套接字地址，如果其为直接连接，则返回 null。
SocketAddress | DatagramSocket.getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
SocketAddress | ServerSocket.getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
SocketAddress | Socket.getLocalSocketAddress() 返回此套接字绑定的端点的地址，如果尚未绑定则返回 null。
SocketAddress | DatagramSocket.getRemoteSocketAddress() 返回此套接字连接的端点的地址，如果未连接则返回 null。
SocketAddress | Socket.getRemoteSocketAddress() 返回此套接字连接的端点的地址，如果未连接则返回 null。
SocketAddress | DatagramPacket.getSocketAddress() 获取要将此包发送到的或发出此数据报的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。

参数类型为 SocketAddress 的 java.net 中的方法
void | DatagramSocket.bind(SocketAddress addr) 将此 DatagramSocket 绑定到特定的地址和端口。
void | ServerSocket.bind(SocketAddress endpoint) 将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
void | Socket.bind(SocketAddress bindpoint) 将套接字绑定到本地地址。
void | ServerSocket.bind(SocketAddress endpoint, int backlog) 将 ServerSocket 绑定到特定地址（IP 地址和端口号）。
void | DatagramSocket.connect(SocketAddress addr) 将此套接字连接到远程套接字地址（IP 地址 + 端口号）。
void | Socket.connect(SocketAddress endpoint) 将此套接字连接到服务器。
protected abstract void | SocketImpl.connect(SocketAddress address, int timeout) 将此套接字连接到指定主机上的指定端口号。
void | Socket.connect(SocketAddress endpoint, int timeout) 将此套接字连接到服务器，并指定一个超时值。
abstract void | ProxySelector.connectFailed(URI uri, SocketAddress sa, IOException ioe) 调用此方法来指示无法建立到代理/socks 服务器的连接。
protected abstract void | DatagramSocketImpl.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf) 加入多播组。
void | MulticastSocket.joinGroup(SocketAddress mcastaddr, NetworkInterface netIf) 加入指定接口上的指定多播组。
protected abstract void | DatagramSocketImpl.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf) 退出多播组。
void | MulticastSocket.leaveGroup(SocketAddress mcastaddr, NetworkInterface netIf) 离开指定本地接口上的多播组。
void | DatagramPacket.setSocketAddress(SocketAddress address) 设置要将此数据报发往的远程主机的 SocketAddress（通常为 IP 地址 + 端口号）。

参数类型为 SocketAddress 的 java.net 中的构造方法
DatagramPacket(byte[] buf, int offset, int length, SocketAddress address)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int length, SocketAddress address)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramSocket(SocketAddress bindaddr)
创建数据报套接字，将其绑定到指定的本地套接字地址。
MulticastSocket(SocketAddress bindaddr)
创建绑定到指定套接字地址的 MulticastSocket。
Proxy(Proxy.Type type, SocketAddress sa)
创建表示 PROXY 连接的条目。

java.nio.channels 中 SocketAddress 的使用

返回 SocketAddress 的 java.nio.channels 中的方法
abstract  SocketAddress DatagramChannel.receive(ByteBuffer dst)
通过此通道接收数据报。

参数类型为 SocketAddress 的 java.nio.channels 中的方法
abstract DatagramChannel | DatagramChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract boolean | SocketChannel.connect(SocketAddress remote) 连接此通道的套接字。
static SocketChannel | SocketChannel.open(SocketAddress remote) 打开套接字通道并将其连接到远程地址。
abstract int | DatagramChannel.send(ByteBuffer src, SocketAddress target) 通过此通道发送数据报。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.Inet4Address 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Inet4Address
的使用

没有 java.net.Inet4Address 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.InetAddress 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.InetAddress
的使用

使用 InetAddress 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.lang 中 InetAddress 的使用

参数类型为 InetAddress 的 java.lang 中的方法
 void SecurityManager.checkMulticast(InetAddress maddr)
如果不允许调用线程使用（加入/离开/发送/接收）IP 多址广播，则抛出 SecurityException。
 void SecurityManager.checkMulticast(InetAddress maddr, byte ttl)
已过时。 由 #checkPermission(java.security.Permission) 取代

java.net 中 InetAddress 的使用

java.net 中 InetAddress 的子类
class | Inet4Address 此类表示 Internet Protocol version 4 (IPv4) 地址。
class | Inet6Address 此类表示互联网协议第 6 版 (IPv6) 地址。

声明为 InetAddress 的 java.net 中的字段
protected  InetAddress SocketImpl.address
此套接字的远程端点的 IP 地址。

返回 InetAddress 的 java.net 中的方法
InetAddress | InterfaceAddress.getAddress() 返回此地址的 InetAddress。
InetAddress | DatagramPacket.getAddress() 返回某台机器的 IP 地址，此数据报将要发往该机器或者是从该机器接收到的。
InetAddress | InetSocketAddress.getAddress() 获取 InetAddress。
static InetAddress[] | InetAddress.getAllByName(String host) 在给定主机名的情况下，根据系统上配置的名称服务返回其 IP 地址所组成的数组。
InetAddress | InterfaceAddress.getBroadcast() 返回此 InterfaceAddress 广播地址的 InetAddress。
static InetAddress | InetAddress.getByAddress(byte[] addr) 在给定原始 IP 地址的情况下，返回 InetAddress 对象。
static InetAddress | InetAddress.getByAddress(String host, byte[] addr) 根据提供的主机名和 IP 地址创建 InetAddress。
static InetAddress | InetAddress.getByName(String host) 在给定主机名的情况下确定主机的 IP 地址。
protected InetAddress | URLStreamHandler.getHostAddress(URL u) 获取主机的 IP 地址。
InetAddress | DatagramSocket.getInetAddress() 返回此套接字连接的地址。
InetAddress | ServerSocket.getInetAddress() 返回此服务器套接字的本地地址。
protected InetAddress | SocketImpl.getInetAddress() 返回此套接字的 address 字段的值。
InetAddress | Socket.getInetAddress() 返回套接字连接的地址。
InetAddress | MulticastSocket.getInterface() 获取用于多播数据包的网络接口的地址。
InetAddress | DatagramSocket.getLocalAddress() 获取套接字绑定的本地地址。
InetAddress | Socket.getLocalAddress() 获取套接字绑定的本地地址。
static InetAddress | InetAddress.getLocalHost() 返回本地主机。
protected InetAddress | Authenticator.getRequestingSite() 获取请求授权的站点的 InetAddress；如果不可用，则为 null。

返回变量类型为 InetAddress 的类型的 java.net 中的方法
 Enumeration<InetAddress> NetworkInterface.getInetAddresses()
一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。

参数类型为 InetAddress 的 java.net 中的方法
protected abstract void | SocketImpl.bind(InetAddress host, int port) 将此套接字绑定到指定的本地 IP 地址和端口号。
protected abstract void | DatagramSocketImpl.bind(int lport, InetAddress laddr) 将数据报套接字绑定到本地端口和地址。
protected void | DatagramSocketImpl.connect(InetAddress address, int port) 将数据报套接字连接到远程目标。
void | DatagramSocket.connect(InetAddress address, int port) 将套接字连接到此套接字的远程地址。
protected abstract void | SocketImpl.connect(InetAddress address, int port) 将此套接字连接到指定主机上的指定端口号。
static NetworkInterface | NetworkInterface.getByInetAddress(InetAddress addr) 一个便捷方法，搜索绑定了指定 Internet 协议 (IP) 地址的网络接口。
protected abstract void | DatagramSocketImpl.join(InetAddress inetaddr) 加入多播组。
void | MulticastSocket.joinGroup(InetAddress mcastaddr) 加入多播组。
protected abstract void | DatagramSocketImpl.leave(InetAddress inetaddr) 退出多播组。
void | MulticastSocket.leaveGroup(InetAddress mcastaddr) 离开多播组。
protected abstract int | DatagramSocketImpl.peek(InetAddress i) 查看包来自哪里。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme) 要求已经向系统注册的 authenticator 提供密码。
static PasswordAuthentication | Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType) 要求已经向系统注册的 authenticator 提供密码。
void | DatagramPacket.setAddress(InetAddress iaddr) 设置要将此数据报发往的那台机器的 IP 地址。
void | MulticastSocket.setInterface(InetAddress inf) 设置多播网络接口，供其行为将受网络接口值影响的方法使用。

参数类型为 InetAddress 的 java.net 中的构造方法
DatagramPacket(byte[] buf, int length, InetAddress address, int port)
构造数据报包，用来将长度为 length 的包发送到指定主机上的指定端口号。
DatagramPacket(byte[] buf, int offset, int length, InetAddress address, int port)
构造数据报包，用来将长度为 length 偏移量为 offset 的包发送到指定主机上的指定端口号。
DatagramSocket(int port, InetAddress laddr)
创建数据报套接字，将其绑定到指定的本地地址。
InetSocketAddress(InetAddress addr, int port)
根据 IP 地址和端口号创建套接字地址。
ServerSocket(int port, int backlog, InetAddress bindAddr)
使用指定的端口、侦听 backlog 和要绑定到的本地 IP 地址创建服务器。
Socket(InetAddress address, int port)
创建一个流套接字并将其连接到指定 IP 地址的指定端口号。
Socket(InetAddress host, int port, boolean stream)
已过时。 Use DatagramSocket instead for UDP transport.
Socket(InetAddress address, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程地址上的指定远程端口。
Socket(String host, int port, InetAddress localAddr, int localPort)
创建一个套接字并将其连接到指定远程主机上的指定远程端口。

javax.net 中 InetAddress 的使用

参数类型为 InetAddress 的 javax.net 中的方法
abstract ServerSocket | ServerSocketFactory.createServerSocket(int port, int backlog, InetAddress ifAddress) 返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。
abstract Socket | SocketFactory.createSocket(InetAddress host, int port) 创建一个套接字并把它连接到指定地址上的指定端口号。
abstract Socket | SocketFactory.createSocket(InetAddress address, int port, InetAddress localAddress, int localPort) 创建一个套接字并把它连接到指定远程端口上的指定远程地址。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 InetAddress 的使用

参数类型为 InetAddress 的 javax.net.ssl 中的构造方法
SSLServerSocket(int port, int backlog, InetAddress address)
仅供子类使用。
SSLSocket(InetAddress address, int port)
仅供子类使用。
SSLSocket(InetAddress address, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。
SSLSocket(String host, int port, InetAddress clientAddress, int clientPort)
仅供子类使用。

javax.security.auth.kerberos 中 InetAddress 的使用

返回 InetAddress 的 javax.security.auth.kerberos 中的方法
 InetAddress[] KerberosTicket.getClientAddresses()
返回可从其所指位置使用票据的地址列表。

参数类型为 InetAddress 的 javax.security.auth.kerberos 中的构造方法
KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。

org.ietf.jgss 中 InetAddress 的使用

返回 InetAddress 的 org.ietf.jgss 中的方法
InetAddress | ChannelBinding.getAcceptorAddress() 获得此通道绑定的接受端的地址。
InetAddress | ChannelBinding.getInitiatorAddress() 获得此通道绑定的初始端地址。

参数类型为 InetAddress 的 org.ietf.jgss 中的构造方法
ChannelBinding(InetAddress initAddr, InetAddress acceptAddr, byte[] appData)
使用用户提供的地址信息和数据创建 ChannelBinding 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.Socket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Socket
的使用

使用 Socket 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.net 中 Socket 的使用

返回 Socket 的 java.net 中的方法
 Socket ServerSocket.accept()
侦听并接受到此套接字的连接。

参数类型为 Socket 的 java.net 中的方法
protected  void ServerSocket.implAccept(Socket s)
ServerSocket 的子类使用此方法重写 accept() 以返回它们自己的套接字子类。

java.nio.channels 中 Socket 的使用

返回 Socket 的 java.nio.channels 中的方法
abstract  Socket SocketChannel.socket()
获取与此通道关联的套接字。

java.rmi.server 中 Socket 的使用

返回 Socket 的 java.rmi.server 中的方法
Socket | RMIClientSocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。
abstract Socket | RMISocketFactory.createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。

javax.net 中 Socket 的使用

返回 Socket 的 javax.net 中的方法
Socket | SocketFactory.createSocket() 创建一个未连接的套接字。
abstract Socket | SocketFactory.createSocket(InetAddress host, int port) 创建一个套接字并把它连接到指定地址上的指定端口号。
abstract Socket | SocketFactory.createSocket(InetAddress address, int port, InetAddress localAddress, int localPort) 创建一个套接字并把它连接到指定远程端口上的指定远程地址。
abstract Socket | SocketFactory.createSocket(String host, int port) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
abstract Socket | SocketFactory.createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。

javax.net.ssl 中 Socket 的使用

javax.net.ssl 中 Socket 的子类
 class SSLSocket
此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。

返回 Socket 的 javax.net.ssl 中的方法
abstract  Socket SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose)
返回在连接到指定主机的给定端口的现有套接字上分层的套接字。

参数类型为 Socket 的 javax.net.ssl 中的方法
String | X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。
String | X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。
abstract Socket | SSLSocketFactory.createSocket(Socket s, String host, int port, boolean autoClose) 返回在连接到指定主机的给定端口的现有套接字上分层的套接字。

javax.rmi.ssl 中 Socket 的使用

返回 Socket 的 javax.rmi.ssl 中的方法
 Socket SslRMIClientSocketFactory.createSocket(String host, int port)
创建一个 SSL 套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.MalformedURLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.MalformedURLException
的使用

使用 MalformedURLException 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.net | 为实现网络应用程序提供类。
java.rmi | 提供 RMI 包。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。

java.io 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.io 中的方法
 URL File.toURL()
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。

java.net 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.net 中的方法
 URL URI.toURL()
根据此 URI 构造一个 URL。

抛出 MalformedURLException 的 java.net 中的构造方法
JarURLConnection(URL url)
创建到指定 URL 的新 JarURLConnection。
URL(String spec)
根据 String 表示形式创建 URL 对象。
URL(String protocol, String host, int port, String file)
根据指定 protocol、host、port 号和 file 创建 URL 对象。
URL(String protocol, String host, int port, String file, URLStreamHandler handler)
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。
URL(String protocol, String host, String file)
根据指定的 protocol 名称、host 名称和 file 名称创建 URL。
URL(URL context, String spec)
通过在指定的上下文中对给定的 spec 进行解析创建 URL。
URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。

java.rmi 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.rmi 中的方法
static void | Naming.bind(String name, Remote obj) 将指定 name 绑定到远程对象。
static String[] | Naming.list(String name) 返回在注册表中绑定的名称所组成的数组。
static Remote | Naming.lookup(String name) 返回与指定 name 关联的远程对象的引用（一个 stub）。
static void | Naming.rebind(String name, Remote obj) 将指定名称重新绑定到一个新的远程对象。
static void | Naming.unbind(String name) 销毁与远程对象关联的指定名称的绑定。

java.rmi.server 中 MalformedURLException 的使用

抛出 MalformedURLException 的 java.rmi.server 中的方法
static ClassLoader RMIClassLoader.getClassLoader(String codebase)
返回从给定的基本代码 URL 路径加载类的类加载器。
abstract  ClassLoader RMIClassLoaderSpi.getClassLoader(String codebase)
提供 RMIClassLoader.getClassLoader(String) 的实现。
 Class<?> LoaderHandler.loadClass(String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(String name)
已过时。 由 loadClass(String,String) 方法取代
static Class<?> RMIClassLoader.loadClass(String codebase, String name)
从基本代码 URL 路径加载类。
static Class<?> RMIClassLoader.loadClass(String codebase, String name, ClassLoader defaultLoader)
有选择地使用提供的加载器从基本代码 URL 路径加载类。
abstract  Class<?> RMIClassLoaderSpi.loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
 Class<?> LoaderHandler.loadClass(URL codebase, String name)
已过时。 无替代版本
static Class<?> RMIClassLoader.loadClass(URL codebase, String name)
从基本代码 URL 加载类。
static Class<?> RMIClassLoader.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
abstract  Class<?> RMIClassLoaderSpi.loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。

javax.management.remote 中 MalformedURLException 的使用

抛出 MalformedURLException 的 javax.management.remote 中的构造方法
JMXServiceURL(String serviceURL)
通过解析 Service URL 字符串来构造 JMXServiceURL。
JMXServiceURL(String protocol, String host, int port)
构造具有给定协议、主机和端口的 JMXServiceURL。
JMXServiceURL(String protocol, String host, int port, String urlPath)
构造具有给定部分的 JMXServiceURL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.Authenticator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Authenticator
的使用

使用 Authenticator 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Authenticator 的使用

参数类型为 Authenticator 的 java.net 中的方法
static void Authenticator.setDefault(Authenticator a)
设置在代理或 HTTP 服务器请求验证时连网密码使用的 authenticator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.Authenticator.RequestorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.Authenticator.RequestorType
的使用

使用 Authenticator.RequestorType 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 Authenticator.RequestorType 的使用

返回 Authenticator.RequestorType 的 java.net 中的方法
protected Authenticator.RequestorType | Authenticator.getRequestorType() 返回请求方是代理还是服务器。
static Authenticator.RequestorType | Authenticator.RequestorType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Authenticator.RequestorType[] | Authenticator.RequestorType.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Authenticator.RequestorType 的 java.net 中的方法
static PasswordAuthentication Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
要求已经向系统注册的 authenticator 提供密码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.ContentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.ContentHandler
的使用

使用 ContentHandler 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 ContentHandler 的使用

返回 ContentHandler 的 java.net 中的方法
 ContentHandler ContentHandlerFactory.createContentHandler(String mimetype)
创建从 URLStreamHandler 读取对象的新 ContentHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLConnection
的使用

使用 URLConnection 的软件包
java.net | 为实现网络应用程序提供类。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 URLConnection 的使用

java.net 中 URLConnection 的子类
class | HttpURLConnection 支持 HTTP 特定功能的 URLConnection。
class | JarURLConnection 连接到 Java ARchive (JAR) 文件或 JAR 文件中条目的 URL Connection。

声明为 URLConnection 的 java.net 中的字段
protected  URLConnection JarURLConnection.jarFileURLConnection
到 JAR 文件 URL 的连接，如果已启动连接。

返回 URLConnection 的 java.net 中的方法
 URLConnection URL.openConnection()
返回一个 URLConnection 对象，它表示到 URL 所引用的远程对象的连接。
 URLConnection URL.openConnection(Proxy proxy)
与 openConnection() 类似，所不同是连接通过指定的代理建立；不支持代理方式的协议处理程序将忽略该代理参数并建立正常的连接。
protected abstract  URLConnection URLStreamHandler.openConnection(URL u)
打开一个到 URL 参数引用的对象的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。

参数类型为 URLConnection 的 java.net 中的方法
abstract Object | ContentHandler.getContent(URLConnection urlc) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并根据其创建对象。
Object | ContentHandler.getContent(URLConnection urlc, Class[] classes) 如果给出位于对象表示形式开头的 URL 连接流，则此方法读取该流并创建与给定类型之一匹配的对象。
abstract CacheRequest | ResponseCache.put(URI uri, URLConnection conn) 协议处理程序在获得资源后调用此方法，ResponseCache 必须决定是否在其缓存中存储资源。

javax.net.ssl 中 URLConnection 的使用

javax.net.ssl 中 URLConnection 的子类
 class HttpsURLConnection
HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URLStreamHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLStreamHandler
的使用

使用 URLStreamHandler 的软件包
java.net 为实现网络应用程序提供类。

java.net 中 URLStreamHandler 的使用

返回 URLStreamHandler 的 java.net 中的方法
 URLStreamHandler URLStreamHandlerFactory.createURLStreamHandler(String protocol)
创建具有指定协议的新 URLStreamHandler 实例。

参数类型为 URLStreamHandler 的 java.net 中的构造方法
URL(String protocol, String host, int port, String file, URLStreamHandler handler)
根据指定的 protocol、host、port 号、file 和 handler 创建 URL 对象。
URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URL
的使用

使用 URL 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.activation |
javax.imageio | Java Image I/O API 的主要包。
javax.management.loading | 提供实现高级动态加载的类。
javax.net.ssl | 提供用于安全套接字包的类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.bind.helpers | 仅由 JAXB 提供者用于： 提供某些 javax.xml.bind 接口的部分默认实现。
javax.xml.validation | 此包提供了用于 XML 文档验证的 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

java.applet 中 URL 的使用

返回 URL 的 java.applet 中的方法
URL | AppletStub.getCodeBase() 获取基 URL。
URL | Applet.getCodeBase() 获得基 URL。
URL | AppletStub.getDocumentBase() 获取嵌入 applet 的文档的 URL。
URL | Applet.getDocumentBase() 获取嵌入此 applet 的文档的 URL。

参数类型为 URL 的 java.applet 中的方法
AudioClip | AppletContext.getAudioClip(URL url) 创建音频剪辑。
AudioClip | Applet.getAudioClip(URL url) 返回 URL 参数指定的 AudioClip 对象。
AudioClip | Applet.getAudioClip(URL url, String name) 返回 URL 和 name 参数指定的 AudioClip 对象。
Image | AppletContext.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url) 返回能被绘制到屏幕上的 Image 对象。
Image | Applet.getImage(URL url, String name) 返回能被绘制到屏幕上的 Image 对象。
static AudioClip | Applet.newAudioClip(URL url) 从给定 URL 处获取音频剪辑。
void | Applet.play(URL url) 播放指定绝对 URL 处的音频剪辑。
void | Applet.play(URL url, String name) 播放音频剪辑，给定了 URL 及与之相对的说明符。
void | AppletContext.showDocument(URL url) 请求浏览器或 applet viewer 显示 url 参数指示的 Web 页面。
void | AppletContext.showDocument(URL url, String target) 请求浏览器或 applet viewer 显示由 url 参数所指示的 Web 页。

java.awt 中 URL 的使用

返回 URL 的 java.awt 中的方法
 URL SplashScreen.getImageURL()
返回当前闪现屏幕图像。

参数类型为 URL 的 java.awt 中的方法
abstract Image | Toolkit.createImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
abstract Image | Toolkit.getImage(URL url) 返回一幅图像，该图像从指定 URL 获取像素数据。
void | SplashScreen.setImageURL(URL imageURL) 更改闪现屏幕图像。

java.beans.beancontext 中 URL 的使用

返回 URL 的 java.beans.beancontext 中的方法
 URL BeanContext.getResource(String name, BeanContextChild bcc)
与 java.lang.ClassLoader.getResource() 类似，此方法允许 BeanContext 实现协调子 Component 和基础 ClassLoader 之间的行为。
 URL BeanContextSupport.getResource(String name, BeanContextChild bcc)

java.io 中 URL 的使用

返回 URL 的 java.io 中的方法
 URL File.toURL()
已过时。 此方法不会自动转义 URL 中的非法字符。建议新的代码使用以下方式将抽象路径名转换为 URL：首先通过 toURI 方法将其转换为 URI，然后通过 URI.toURL 方法将 URI 装换为 URL。

java.lang 中 URL 的使用

返回 URL 的 java.lang 中的方法
protected URL | ClassLoader.findResource(String name) 查找具有给定名称的资源。
URL | ClassLoader.getResource(String name) 查找具有给定名称的资源。
URL | Class.getResource(String name) 查找带有给定名称的资源。
static URL | ClassLoader.getSystemResource(String name) 从用来加载类的搜索路径中查找具有指定名称的资源。

返回变量类型为 URL 的类型的 java.lang 中的方法
protected Enumeration<URL> | ClassLoader.findResources(String name) 返回表示所有具有给定名称的资源的 URL 对象的枚举。
Enumeration<URL> | ClassLoader.getResources(String name) 查找所有给定名称的资源。
static Enumeration<URL> | ClassLoader.getSystemResources(String name) 从用来加载类的搜索路径中查找所有具有指定名称的资源。

参数类型为 URL 的 java.lang 中的方法
protected Package | ClassLoader.definePackage(String name, String specTitle, String specVersion, String specVendor, String implTitle, String implVersion, String implVendor, URL sealBase) 根据 name 在此 ClassLoader 中定义包。
boolean | Package.isSealed(URL url) 如果此包对于指定的代码源 url 是密封的，则返回 ture。

java.net 中 URL 的使用

声明为 URL 的 java.net 中的字段
protected  URL URLConnection.url
URL 表示此连接要在互联网上打开的远程对象。

返回 URL 的 java.net 中的方法
URL | URLClassLoader.findResource(String name) 在 URL 搜索路径中查找具有指定名称的资源。
URL | JarURLConnection.getJarFileURL() 返回此连接的 Jar 文件的 URL。
protected URL | Authenticator.getRequestingURL() 返回导致请求验证的 URL。
URL | URLConnection.getURL() 返回此 URLConnection 的 URL 字段的值。
URL[] | URLClassLoader.getURLs() 返回用于加载类和资源的 URL 搜索路径。
URL | URI.toURL() 根据此 URI 构造一个 URL。

返回变量类型为 URL 的类型的 java.net 中的方法
 Enumeration<URL> URLClassLoader.findResources(String name)
返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。

参数类型为 URL 的 java.net 中的方法
protected  void URLClassLoader.addURL(URL url)
将指定的 URL 添加到 URL 列表中，以便搜索类和资源。
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。
protected  boolean URLStreamHandler.equals(URL u1, URL u2)
提供默认的 equals 计算。
protected  InetAddress URLStreamHandler.getHostAddress(URL u)
获取主机的 IP 地址。
protected  int URLStreamHandler.hashCode(URL u)
提供默认的哈希计算。
protected  boolean URLStreamHandler.hostsEqual(URL u1, URL u2)
比较两个 URL 的主机组件。
static URLClassLoader URLClassLoader.newInstance(URL[] urls)
为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。
static URLClassLoader URLClassLoader.newInstance(URL[] urls, ClassLoader parent)
为指定的 URL 和父类加载器创建新 URLClassLoader 实例。
protected abstract  URLConnection URLStreamHandler.openConnection(URL u)
打开一个到 URL 参数引用的对象的连接。
protected  URLConnection URLStreamHandler.openConnection(URL u, Proxy p)
与 openConnection(URL) 相同，不同点在于：通过指定的代理进行连接；不支持代理方式的协议处理程序将忽略该代理参数并进行正常的连接。
protected  void URLStreamHandler.parseURL(URL u, String spec, int start, int limit)
将 URL 的字符表示形式解析为 URL 对象。
static PasswordAuthentication Authenticator.requestPasswordAuthentication(String host, InetAddress addr, int port, String protocol, String prompt, String scheme, URL url, Authenticator.RequestorType reqType)
要求已经向系统注册的 authenticator 提供密码。
 boolean URL.sameFile(URL other)
比较两个 URL，不包括片段部分。
protected  boolean URLStreamHandler.sameFile(URL u1, URL u2)
比较两个 url 以确定它们是否引用相同的文件（即具有相同的协议、主机、端口和路径）。
protected  void URLStreamHandler.setURL(URL u, String protocol, String host, int port, String file, String ref)
已过时。 使用 setURL(URL, String, String, int, String, String, String, String);
protected  void URLStreamHandler.setURL(URL u, String protocol, String host, int port, String authority, String userInfo, String path, String query, String ref)
将 URL 参数的字段设置为指示的值。
protected  String URLStreamHandler.toExternalForm(URL u)
将特定协议的 URL 转换为 String。

参数类型为 URL 的 java.net 中的构造方法
HttpURLConnection(URL u)
HttpURLConnection 的构造方法。
JarURLConnection(URL url)
创建到指定 URL 的新 JarURLConnection。
URL(URL context, String spec)
通过在指定的上下文中对给定的 spec 进行解析创建 URL。
URL(URL context, String spec, URLStreamHandler handler)
通过在指定的上下文中用指定的处理程序对给定的 spec 进行解析来创建 URL。
URLClassLoader(URL[] urls)
使用默认的委托父 ClassLoader 为指定的 URL 构造一个新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent)
为给定的 URL 构造新 URLClassLoader。
URLClassLoader(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。
URLConnection(URL url)
构造一个到指定 URL 的 URL 连接。

java.rmi.server 中 URL 的使用

参数类型为 URL 的 java.rmi.server 中的方法
Class<?> | LoaderHandler.loadClass(URL codebase, String name) 已过时。 无替代版本
static Class<?> | RMIClassLoader.loadClass(URL codebase, String name) 从基本代码 URL 加载类。

java.security 中 URL 的使用

返回 URL 的 java.security 中的方法
 URL CodeSource.getLocation()
返回与此 CodeSource 关联的位置。

参数类型为 URL 的 java.security 中的构造方法
CodeSource(URL url, Certificate[] certs)
构造一个 CodeSource 并将其与指定位置和证书集合相关联。
CodeSource(URL url, CodeSigner[] signers)
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。

java.sql 中 URL 的使用

返回 URL 的 java.sql 中的方法
URL | CallableStatement.getURL(int parameterIndex) 以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。
URL | ResultSet.getURL(int columnIndex) 以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
URL | CallableStatement.getURL(String parameterName) 以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。
URL | ResultSet.getURL(String columnLabel) 以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
URL | SQLInput.readURL() 从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。

参数类型为 URL 的 java.sql 中的方法
void | PreparedStatement.setURL(int parameterIndex, URL x) 将指定参数设置为给定 java.net.URL 值。
void | CallableStatement.setURL(String parameterName, URL val) 将指定参数设置为给定 java.net.URL 对象。
void | SQLOutput.writeURL(URL x) 将 SQL DATALINK 值写入流中。

javax.activation 中 URL 的使用

返回 URL 的 javax.activation 中的方法
 URL URLDataSource.getURL()
返回用于创建此 DataSource 的 URL。

参数类型为 URL 的 javax.activation 中的构造方法
DataHandler(URL url)
创建引用 URL 的 DataHandler 实例。
URLDataSource(URL url)
URLDataSource 构造方法。

javax.imageio 中 URL 的使用

参数类型为 URL 的 javax.imageio 中的方法
static BufferedImage ImageIO.read(URL input)
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。

javax.management.loading 中 URL 的使用

返回 URL 的 javax.management.loading 中的方法
protected URL | MLet.check(String version, URL codebase, String jarfile, MLetContent mlet) 当扩展此服务来支持缓存和版本控制时，要重写此方法。
URL | MLetContent.getCodeBase() 获取代码基 URL。
URL | MLetContent.getDocumentBase() 获取 MLet 文本文件的基本 URL。
URL | MLetMBean.getResource(String name) 查找具有给定名称的资源。
URL[] | MLet.getURLs() 返回用于加载类和资源的 URL 搜索路径。
URL[] | MLetMBean.getURLs() 返回用于加载类和资源的 URL 搜索路径。

返回变量类型为 URL 的类型的 javax.management.loading 中的方法
 Enumeration<URL> MLetMBean.getResources(String name)
查找所有具有给定名称的资源。

参数类型为 URL 的 javax.management.loading 中的方法
void | MLet.addURL(URL url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
void | MLetMBean.addURL(URL url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
protected URL | MLet.check(String version, URL codebase, String jarfile, MLetContent mlet) 当扩展此服务来支持缓存和版本控制时，要重写此方法。
Set<Object> | MLet.getMBeansFromURL(URL url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(URL url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

参数类型为 URL 的 javax.management.loading 中的构造方法
MLet(URL[] urls)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[] urls, boolean delegateToCLR)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。
PrivateMLet(URL[] urls, boolean delegateToCLR)
使用默认的委托父 ClassLoader 为指定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。

javax.net.ssl 中 URL 的使用

参数类型为 URL 的 javax.net.ssl 中的构造方法
HttpsURLConnection(URL url)
使用指定的 URL 创建 HttpsURLConnection。

javax.sound.midi 中 URL 的使用

参数类型为 URL 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。

javax.sound.midi.spi 中 URL 的使用

参数类型为 URL 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。

javax.sound.sampled 中 URL 的使用

参数类型为 URL 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。

javax.sound.sampled.spi 中 URL 的使用

参数类型为 URL 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。

javax.sql 中 URL 的使用

参数类型为 URL 的 javax.sql 中的方法
 void RowSet.setURL(int parameterIndex, URL x)
将指定参数设置为给定的 java.net.URL 值。

javax.sql.rowset 中 URL 的使用

参数类型为 URL 的 javax.sql.rowset 中的方法
 void BaseRowSet.setURL(int parameterIndex, URL x)
将指定参数设置为给定的 java.net.URL 值。

javax.sql.rowset.serial 中 URL 的使用

返回 URL 的 javax.sql.rowset.serial 中的方法
URL | SerialDatalink.getDatalink() 返回一个新 URL，它是此 SerialDatalink 对象的副本。
URL | SQLInputImpl.readURL() 从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。

参数类型为 URL 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeURL(URL url)
将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。

参数类型为 URL 的 javax.sql.rowset.serial 中的构造方法
SerialDatalink(URL url)
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。

javax.swing 中 URL 的使用

返回 URL 的 javax.swing 中的方法
 URL JEditorPane.getPage()
获得当前正在显示的 URL。

参数类型为 URL 的 javax.swing 中的方法
protected InputStream | JEditorPane.getStream(URL page) 获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。
void | JEditorPane.setPage(URL page) 设置当前要显示的 URL。

参数类型为 URL 的 javax.swing 中的构造方法
ImageIcon(URL location)
根据指定的 URL 创建一个 ImageIcon。
ImageIcon(URL location, String description)
根据指定的 URL 创建一个 ImageIcon。
JEditorPane(URL initialPage)
根据用作输入的指定 URL 创建一个 JEditorPane。

javax.swing.event 中 URL 的使用

返回 URL 的 javax.swing.event 中的方法
 URL HyperlinkEvent.getURL()
获得链接引用的 URL。

参数类型为 URL 的 javax.swing.event 中的构造方法
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.plaf.synth 中 URL 的使用

参数类型为 URL 的 javax.swing.plaf.synth 中的方法
 void SynthLookAndFeel.load(URL url)
加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text.html 中 URL 的使用

返回 URL 的 javax.swing.text.html 中的方法
URL | HTMLDocument.getBase() 返回解析相对 URL 所根据的位置。
URL | StyleSheet.getBase() 返回 base。
URL | ImageView.getImageURL() 返回图像源的 URL，如果不能确定图像源，则返回 null。

参数类型为 URL 的 javax.swing.text.html 中的方法
void | StyleSheet.importStyleSheet(URL url) 从 url 导入样式表。
void | StyleSheet.loadRules(Reader in, URL ref) 加载 CSS1 语法中指定的规则集合。
void | HTMLDocument.setBase(URL u) 设置解析相对 URL 所根据的位置。
void | StyleSheet.setBase(URL base) 设置 base。

参数类型为 URL 的 javax.swing.text.html 中的构造方法
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

javax.xml.bind 中 URL 的使用

返回 URL 的 javax.xml.bind 中的方法
 URL ValidationEventLocator.getURL()
返回 URL 形式的 XML 源名称（如果可用）。

参数类型为 URL 的 javax.xml.bind 中的方法
 Object Unmarshaller.unmarshal(URL url)
从指定的 URL 解组 XML 数据并返回得到的内容树。

javax.xml.bind.helpers 中 URL 的使用

返回 URL 的 javax.xml.bind.helpers 中的方法
 URL ValidationEventLocatorImpl.getURL()

参数类型为 URL 的 javax.xml.bind.helpers 中的方法
void | ValidationEventLocatorImpl.setURL(URL _url) 在此事件定位符上设置 URL 字段。
Object | AbstractUnmarshallerImpl.unmarshal(URL url)

javax.xml.validation 中 URL 的使用

参数类型为 URL 的 javax.xml.validation 中的方法
 Schema SchemaFactory.newSchema(URL schema)
解析作为模式的指定 URL 并以 Schema 形式返回它。

javax.xml.ws 中 URL 的使用

返回 URL 的 javax.xml.ws 中的方法
 URL Service.getWSDLDocumentLocation()
获取此 Service 的 WSDL 文档的位置。

参数类型为 URL 的 javax.xml.ws 中的方法
static Service Service.create(URL wsdlDocumentLocation, QName serviceName)
创建 Service 实例。

参数类型为 URL 的 javax.xml.ws 中的构造方法
Service(URL wsdlDocumentLocation, QName serviceName)

javax.xml.ws.spi 中 URL 的使用

返回 URL 的 javax.xml.ws.spi 中的方法
abstract  URL ServiceDelegate.getWSDLDocumentLocation()
获取此服务的 WSDL 文档的位置。

参数类型为 URL 的 javax.xml.ws.spi 中的方法
abstract  ServiceDelegate Provider.createServiceDelegate(URL wsdlDocumentLocation, QName serviceName, Class serviceClass)
创建一个服务委托对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.net.URLClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.net.URLClassLoader
的使用

使用 URLClassLoader 的软件包
java.net | 为实现网络应用程序提供类。
javax.management.loading | 提供实现高级动态加载的类。

java.net 中 URLClassLoader 的使用

返回 URLClassLoader 的 java.net 中的方法
static URLClassLoader | URLClassLoader.newInstance(URL[] urls) 为指定的 URL 和默认的父类加载器创建新 URLClassLoader 实例。
static URLClassLoader | URLClassLoader.newInstance(URL[] urls, ClassLoader parent) 为指定的 URL 和父类加载器创建新 URLClassLoader 实例。

javax.management.loading 中 URLClassLoader 的使用

javax.management.loading 中 URLClassLoader 的子类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.net.URLStreamHandlerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.net.URLStreamHandlerFactory
的使用

使用 URLStreamHandlerFactory 的软件包
java.net | 为实现网络应用程序提供类。
javax.management.loading | 提供实现高级动态加载的类。

java.net 中 URLStreamHandlerFactory 的使用

参数类型为 URLStreamHandlerFactory 的 java.net 中的方法
static void URL.setURLStreamHandlerFactory(URLStreamHandlerFactory fac)
设置应用程序的 URLStreamHandlerFactory。

参数类型为 URLStreamHandlerFactory 的 java.net 中的构造方法
URLClassLoader(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 创建新 URLClassLoader。

javax.management.loading 中 URLStreamHandlerFactory 的使用

参数类型为 URLStreamHandlerFactory 的 javax.management.loading 中的构造方法
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Buffer (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio
类 Buffer

java.lang.Object
    继承者  java.nio.Buffer
直接已知子类：
ByteBuffer, CharBuffer, DoubleBuffer, FloatBuffer, IntBuffer, LongBuffer, ShortBuffer
public abstract class Buffer
extends Object

一个用于特定基本类型数据的容器。

缓冲区是特定基本类型元素的线性有限序列。除内容外，缓冲区的基本属性还包括容量、限制和位置：

缓冲区的容量 是它所包含的元素的数量。缓冲区的容量不能为负并且不能更改。

缓冲区的限制 是第一个不应该读取或写入的元素的索引。缓冲区的限制不能为负，并且不能大于其容量。

缓冲区的位置 是下一个要读取或写入的元素的索引。缓冲区的位置不能为负，并且不能大于其限制。

对于每个非 boolean 基本类型，此类都有一个子类与之对应。

传输数据

此类的每个子类都定义了两种获取 和放置 操作：

相对 操作读取或写入一个或多个元素，它从当前位置开始，然后将位置增加所传输的元素数。如果请求的传输超出限制，则相对获取 操作将抛出 BufferUnderflowException，相对放置 操作将抛出 BufferOverflowException；这两种情况下，都没有数据被传输。

绝对 操作采用显式元素索引，该操作不影响位置。如果索引参数超出限制，绝对获取 操作和放置 操作将抛出 IndexOutOfBoundsException。

当然，通过适当通道的 I/O 操作（通常与当前位置有关）也可以将数据传输到缓冲区或从缓冲区传出数据。

做标记和重置

缓冲区的标记 是一个索引，在调用 reset 方法时会将缓冲区的位置重置为该索引。并非总是需要定义标记，但在定义标记时，不能将其定义为负数，并且不能让它大于位置。如果定义了标记，则在将位置或限制调整为小于该标记的值时，该标记将被丢弃。如果未定义标记，那么调用 reset 方法将导致抛出 InvalidMarkException。

不变式

标记、位置、限制和容量值遵守以下不变式：

0 <= 标记 <= 位置 <= 限制 <= 容量

新创建的缓冲区总有一个 0 位置和一个未定义的标记。初始限制可以为 0，也可以为其他值，这取决于缓冲区类型及其构建方式。一般情况下，缓冲区的初始内容是未定义的。

清除、反转和重绕

除了访问位置、限制、容量值的方法以及做标记和重置的方法外，此类还定义了以下可对缓冲区进行的操作：

  • clear() 使缓冲区为一系列新的通道读取或相对放置 操作做好准备：它将限制设置为容量大小，将位置设置为 0。

  • flip() 使缓冲区为一系列新的通道写入或相对获取 操作做好准备：它将限制设置为当前位置，然后将位置设置为 0。

  • rewind() 使缓冲区为重新读取已包含的数据做好准备：它使限制保持不变，将位置设置为 0。

只读缓冲区

每个缓冲区都是可读取的，但并非每个缓冲区都是可写入的。每个缓冲区类的转变方法都被指定为可选操作，当对只读缓冲区调用时，将抛出 ReadOnlyBufferException。只读缓冲区不允许更改其内容，但其标记、位置和限制值是可变的。可以调用其 isReadOnly 方法确定缓冲区是否为只读。

线程安全

多个当前线程使用缓冲区是不安全的。如果一个缓冲区由不止一个线程使用，则应该通过适当的同步来控制对该缓冲区的访问。

调用链

指定此类中的方法返回调用它们的缓冲区（否则它们不会返回任何值）。此操作允许将方法调用组成一个链；例如，语句序列

 b.flip();
 b.position(23);
 b.limit(42);
可以由以下更紧凑的一个语句代替
 b.flip().position(23).limit(42);

从以下版本开始：
1.4

方法摘要
abstract Object | array() 返回此缓冲区的底层实现数组（可选操作）。
abstract int | arrayOffset() 返回此缓冲区的底层实现数组中第一个缓冲区元素的偏移量（可选操作）。
int | capacity() 返回此缓冲区的容量。
Buffer | clear() 清除此缓冲区。
Buffer | flip() 反转此缓冲区。
abstract boolean | hasArray() 告知此缓冲区是否具有可访问的底层实现数组。
boolean | hasRemaining() 告知在当前位置和限制之间是否有元素。
abstract boolean | isDirect() 告知此缓冲区是否为直接缓冲区。
abstract boolean | isReadOnly() 告知此缓冲区是否为只读缓冲区。
int | limit() 返回此缓冲区的限制。
Buffer | limit(int newLimit) 设置此缓冲区的限制。
Buffer | mark() 在此缓冲区的位置设置标记。
int | position() 返回此缓冲区的位置。
Buffer | position(int newPosition) 设置此缓冲区的位置。
int | remaining() 返回当前位置与限制之间的元素数。
Buffer | reset() 将此缓冲区的位置重置为以前标记的位置。
Buffer | rewind() 重绕此缓冲区。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

capacity

public final int capacity()
返回此缓冲区的容量。

返回：
此缓冲区的容量

position

public final int position()
返回此缓冲区的位置。

返回：
此缓冲区的位置

position

public final Buffer position(int newPosition)
设置此缓冲区的位置。如果标记已定义且大于新的位置，则丢弃该标记。

参数：
newPosition - 新位置值；必须为非负且不大于当前限制
返回：
此缓冲区
抛出：
IllegalArgumentException - 如果 newPosition 不满足先决条件

limit

public final int limit()
返回此缓冲区的限制。

返回：
此缓冲区的限制

limit

public final Buffer limit(int newLimit)
设置此缓冲区的限制。如果位置大于新的限制，则将它设置为新限制。如果标记已定义且大于新限制，则丢弃该标记。

参数：
newLimit - 新限制值；必须为非负且不大于此缓冲区的容量
返回：
此缓冲区
抛出：
IllegalArgumentException - 如果 newLimit 不满足先决条件

mark

public final Buffer mark()
在此缓冲区的位置设置标记。

返回：
此缓冲区

reset

public final Buffer reset()
将此缓冲区的位置重置为以前标记的位置。

调用此方法不更改也不丢弃标记的值。

返回：
此缓冲区
抛出：
InvalidMarkException - 如果尚未设置标记

clear

public final Buffer clear()
清除此缓冲区。将位置设置为 0，将限制设置为容量，并丢弃标记。

在使用一系列通道读取或放置 操作填充此缓冲区之前调用此方法。例如：

 buf.clear();     // Prepare buffer for reading
 in.read(buf);    // Read data

此方法不能实际清除缓冲区中的数据，但从名称来看它似乎能够这样做，这样命名是因为它多数情况下确实是在清除数据时使用。

返回：
此缓冲区

flip

public final Buffer flip()
反转此缓冲区。首先将限制设置为当前位置，然后将位置设置为 0。如果已定义了标记，则丢弃该标记。

在一系列通道读取或放置 操作之后，调用此方法为一系列通道写入或相对获取 操作做好准备。例如：

 buf.put(magic);    // Prepend header
 in.read(buf);      // Read data into rest of buffer
 buf.flip();        // Flip buffer
 out.write(buf);    // Write header + data to channel

当将数据从一个地方传输到另一个地方时，经常将此方法与 compact 方法一起使用。

返回：
此缓冲区

rewind

public final Buffer rewind()
重绕此缓冲区。将位置设置为 0 并丢弃标记。

在一系列通道写入或获取 操作之前调用此方法（假定已经适当设置了限制）。例如：

 out.write(buf);    // Write remaining data
 buf.rewind();      // Rewind buffer
 buf.get(array);    // Copy data into array

返回：
此缓冲区

remaining

public final int remaining()
返回当前位置与限制之间的元素数。

返回：
此缓冲区中的剩余元素数

hasRemaining

public final boolean hasRemaining()
告知在当前位置和限制之间是否有元素。

返回：
当且仅当此缓冲区中至少还有一个元素时返回 true

isReadOnly

public abstract boolean isReadOnly()
告知此缓冲区是否为只读缓冲区。

返回：
当且仅当此缓冲区为只读缓冲区时返回 true

hasArray

public abstract boolean hasArray()
告知此缓冲区是否具有可访问的底层实现数组。

如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

返回：
当且仅当此缓冲区有非只读的底层实现数组时返回 true。
从以下版本开始：
1.6

array

public abstract Object array()
返回此缓冲区的底层实现数组（可选操作）。

此方法旨在使具有底层实现数组的缓冲区能更有效地传递给本机代码。具体子类为此方法提供更强类型的返回值。

对此缓冲区内容进行修改将导致返回数组的内容被修改，反之亦然。

调用此方法前应调用 hasArray 方法，以确保此缓冲区存在可访问的底层实现数组。

返回：
此缓冲区的底层实现数组
抛出：
ReadOnlyBufferException - 如果此缓冲区存在底层实现数组，但它是只读的
UnsupportedOperationException - 如果此缓冲区不存在可访问的底层实现数组
从以下版本开始：
1.6

arrayOffset

public abstract int arrayOffset()
返回此缓冲区的底层实现数组中第一个缓冲区元素的偏移量（可选操作）。

如果此缓冲区存在底层实现数组，那么缓冲区位置 p 对应于数组索引 p + arrayOffset()。

调用此方法前应调用 hasArray 方法，以确保此缓冲区存在可访问的底层实现数组。

返回：
此缓冲区数组中第一个缓冲区元素的偏移量
抛出：
ReadOnlyBufferException - 如果此缓冲区存在底层实现数组，但它是只读的
UnsupportedOperationException - 如果此缓冲区不存在可访问的底层实现数组
从以下版本开始：
1.6

isDirect

public abstract boolean isDirect()
告知此缓冲区是否为直接缓冲区。

返回：
当且仅当此缓冲区为直接缓冲区时返回 true。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BufferOverflowException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 BufferOverflowException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.nio.BufferOverflowException
所有已实现的接口：
Serializable
public class BufferOverflowException
extends RuntimeException

当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
BufferOverflowException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BufferOverflowException

public BufferOverflowException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BufferUnderflowException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 BufferUnderflowException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.nio.BufferUnderflowException
所有已实现的接口：
Serializable
public class BufferUnderflowException
extends RuntimeException

当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
BufferUnderflowException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BufferUnderflowException

public BufferUnderflowException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ByteBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 ByteBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.ByteBuffer
所有已实现的接口：
Comparable<ByteBuffer>
直接已知子类：
MappedByteBuffer
public abstract class ByteBuffer
extends Buffer
implements Comparable<ByteBuffer>

字节缓冲区。

此类针对字节缓冲区定义了以下六类操作：

  • 读写单个字节的绝对和相对 get 和 put 方法；

  • 将此缓冲区的连续字节序列传输到数组中的相对批量 get 方法；

  • 将 byte 数组或其他字节缓冲区中的连续字节序列传输到此缓冲区的相对批量 put 方法；

  • 读写其他基本类型值，并按照特定的字节顺序在字节序列之间转换这些值的绝对和相对 get 和 put 方法；

  • 创建视图缓冲区 的方法，这些方法允许将字节缓冲区视为包含其他基本类型值的缓冲区；

  • 对字节缓冲区进行 compacting、duplicating 和 slicing 的方法。

字节缓冲区可以通过 allocation 方法创建，此方法为该缓冲区的内容分配空间，或通过 wrapping 方法将现有的 byte 数组包装到缓冲区中来创建。

直接与 非直接缓冲区

字节缓冲区要么是直接的，要么是非直接的。如果为直接字节缓冲区，则 Java 虚拟机会尽最大努力直接在此缓冲区上执行本机 I/O 操作。也就是说，在每次调用基础操作系统的一个本机 I/O 操作之前（或之后），虚拟机都会尽量避免将缓冲区的内容复制到中间缓冲区中（或从中间缓冲区中复制内容）。

直接字节缓冲区可以通过调用此类的 allocateDirect 工厂方法来创建。此方法返回的缓冲区进行分配和取消分配所需成本通常高于非直接缓冲区。直接缓冲区的内容可以驻留在常规的垃圾回收堆之外，因此，它们对应用程序的内存需求量造成的影响可能并不明显。所以，建议将直接缓冲区主要分配给那些易受基础系统的本机 I/O 操作影响的大型、持久的缓冲区。一般情况下，最好仅在直接缓冲区能在程序性能方面带来明显好处时分配它们。

直接字节缓冲区还可以通过 mapping 将文件区域直接映射到内存中来创建。Java 平台的实现有助于通过 JNI 从本机代码创建直接字节缓冲区。如果以上这些缓冲区中的某个缓冲区实例指的是不可访问的内存区域，则试图访问该区域不会更改该缓冲区的内容，并且将会在访问期间或稍后的某个时间导致抛出不确定的异常。

字节缓冲区是直接缓冲区还是非直接缓冲区可通过调用其 isDirect 方法来确定。提供此方法是为了能够在性能关键型代码中执行显式缓冲区管理。

访问二进制数据

此类定义了除 boolean 之外，读写所有其他基本类型值的方法。这些基本值可以根据缓冲区的当前字节顺序与字节序列互相进行转换，并可以通过 order 方法获取和修改。特定的字节顺序由 ByteOrder 类的实例表示。字节缓冲区的初始顺序始终是 BIG_ENDIAN。

为了访问异类二进制数据（即其他类型的值的序列），此类还针对每种类型定义了一系列绝对和相对的 get 和 put 方法。例如，对于 32 位浮点值，此类定义了以下方法：

 float  getFloat()
 float  getFloat(int index)
  void  putFloat(float f)
  void  putFloat(int index, float f)

并针对 char、short、int、long 和 double 等类型定义了相应的方法。绝对 get 和 put 方法的 index 参数是根据字节定义的，而不是根据所读写的类型定义的。

为了访问同类二进制数据（即相同类型的值的序列），此类还定义了可以为指定类型的缓冲区创建视图 的方法。视图缓冲区 只是其内容受该字节缓冲区支持的另一种缓冲区。字节缓冲区内容的更改在视图缓冲区中是可见的，反之亦然；这两种缓冲区的位置、限制和标记值都是独立的。例如，asFloatBuffer 方法将创建 FloatBuffer 类的一个实例，该类受在其上调用该方法的字节缓冲区的支持。该类将为 char、short、int、long 和 double 等类型定义相应的视图创建方法。

与上述特定于类型的 get 和 put 方法系列相比，视图缓冲区有以下三大主要优势：

  • 视图缓冲区不是根据字节进行索引，而是根据其特定于类型的值的大小进行索引；

  • 视图缓冲区提供了相对批量 get 和 put 方法，这些方法可在缓冲区和数组或相同类型的其他缓冲区之间传输值的连续序列；

  • 视图缓冲区可能更高效，这是因为，当且仅当其支持的字节缓冲区为直接缓冲区时它才是直接缓冲区。

视图缓冲区的字节顺序固定为创建该视图时其字节缓冲区的字节顺序。

调用的链接

指定此类中的方法（它们不返回其他值），以返回这些方法被调用时所在的缓冲区。这允许对方法调用进行链接。 例如，语句序列

 bb.putInt(0xCAFEBABE);
 bb.putShort(3);
 bb.putShort(45);
可以由以下单个语句替换
 bb.putInt(0xCAFEBABE).putShort(3).putShort(45);

从以下版本开始：
1.4

方法摘要
static ByteBuffer | allocate(int capacity) 分配一个新的字节缓冲区。
static ByteBuffer | allocateDirect(int capacity) 分配新的直接字节缓冲区。
byte[] | array() 返回实现此缓冲区的 byte 数组（可选操作）。
int | arrayOffset() 返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
abstract CharBuffer | asCharBuffer() 创建此字节缓冲区的视图，作为 char 缓冲区。
abstract DoubleBuffer | asDoubleBuffer() 创建此字节缓冲区的视图，作为 double 缓冲区。
abstract FloatBuffer | asFloatBuffer() 创建此字节缓冲区的视图，作为 float 缓冲区。
abstract IntBuffer | asIntBuffer() 创建此字节缓冲区的视图，作为 int 缓冲区。
abstract LongBuffer | asLongBuffer() 创建此字节缓冲区的视图，作为 long 缓冲区。
abstract ByteBuffer | asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读字节缓冲区。
abstract ShortBuffer | asShortBuffer() 创建此字节缓冲区的视图，作为 short 缓冲区。
abstract ByteBuffer | compact() 压缩此缓冲区（可选操作）。
int | compareTo(ByteBuffer that) 将此缓冲区与另一个缓冲区进行比较。
abstract ByteBuffer | duplicate() 创建共享此缓冲区内容的新的字节缓冲区。
boolean | equals(Object ob) 判断此缓冲区是否与另一个对象相同。
abstract byte | get() 相对 get 方法。
ByteBuffer | get(byte[] dst) 相对批量 get 方法。
ByteBuffer | get(byte[] dst, int offset, int length) 相对批量 get 方法。
abstract byte | get(int index) 绝对 get 方法。
abstract char | getChar() 用于读取 char 值的相对 get 方法。
abstract char | getChar(int index) 用于读取 char 值的绝对 get 方法。
abstract double | getDouble() 用于读取 double 值的相对 get 方法。
abstract double | getDouble(int index) 用于读取 double 值的绝对 get 方法。
abstract float | getFloat() 用于读取 float 值的相对 get 方法。
abstract float | getFloat(int index) 用于读取 float 值的绝对 get 方法。
abstract int | getInt() 用于读取 int 值的相对 get 方法。
abstract int | getInt(int index) 用于读取 int 值的绝对 get 方法。
abstract long | getLong() 用于读取 long 值的相对 get 方法。
abstract long | getLong(int index) 用于读取 long 值的绝对 get 方法。
abstract short | getShort() 用于读取 short 值的相对 get 方法。
abstract short | getShort(int index) 用于读取 short 值的绝对 get 方法。
boolean | hasArray() 判断是否可通过一个可访问的 byte 数组实现此缓冲区。
int | hashCode() 返回此缓冲区的当前哈希码。
abstract boolean | isDirect() 判断此字节缓冲区是否为直接的。
ByteOrder | order() 获取此缓冲区的字节顺序。
ByteBuffer | order(ByteOrder bo) 修改此缓冲区的字节顺序。
abstract ByteBuffer | put(byte b) 相对 put 方法（可选操作）。
ByteBuffer | put(byte[] src) 相对批量 put 方法（可选操作）。
ByteBuffer | put(byte[] src, int offset, int length) 相对批量 put 方法（可选操作）。
ByteBuffer | put(ByteBuffer src) 相对批量 put 方法（可选操作）。
abstract ByteBuffer | put(int index, byte b) 绝对 put 方法（可选操作）。
abstract ByteBuffer | putChar(char value) 用来写入 char 值的相对 put 方法（可选操作）。
abstract ByteBuffer | putChar(int index, char value) 用于写入 char 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | putDouble(double value) 用于写入 double 值的相对 put 方法（可选操作）。
abstract ByteBuffer | putDouble(int index, double value) 用于写入 double 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | putFloat(float value) 用于写入 float 值的相对 put 方法（可选操作）。
abstract ByteBuffer | putFloat(int index, float value) 用于写入 float 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | putInt(int value) 用于写入 int 值的相对 put 方法（可选操作）。
abstract ByteBuffer | putInt(int index, int value) 用于写入 int 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | putLong(int index, long value) 用于写入 long 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | putLong(long value) 用于写入 long 值（可先操作） 的相对 put 方法。
abstract ByteBuffer | putShort(int index, short value) 用于写入 short 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | putShort(short value) 用于写入 short 值的相对 put 方法（可选操作）。
abstract ByteBuffer | slice() 创建新的字节缓冲区，其内容是此缓冲区内容的共享子序列。
String | toString() 返回汇总了此缓冲区状态的字符串。
static ByteBuffer | wrap(byte[] array) 将 byte 数组包装到缓冲区中。
static ByteBuffer | wrap(byte[] array, int offset, int length) 将 byte 数组包装到缓冲区中。
从类 java.nio.Buffer 继承的方法
capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

allocateDirect

public static ByteBuffer allocateDirect(int capacity)
分配新的直接字节缓冲区。

新缓冲区的位置将为零，其界限将为其容量，其标记是不确定的。无论它是否具有底层实现数组，其标记都是不确定的。

参数：
capacity - 新缓冲区的容量，以字节为单位
返回：
新的字节缓冲区
抛出：
IllegalArgumentException - 如果 capacity 为负整数

allocate

public static ByteBuffer allocate(int capacity)
分配一个新的字节缓冲区。

新缓冲区的位置将为零，其界限将为其容量，其标记是不确定的。它将具有一个底层实现数组，且其 数组偏移量将为零。

参数：
capacity - 新缓冲区的容量，以字节为单位
返回：
新的字节缓冲区
抛出：
IllegalArgumentException - 如果 capacity 为负整数

wrap

public static ByteBuffer wrap(byte[] array,
                              int offset,
                              int length)
将 byte 数组包装到缓冲区中。

新的缓冲区将由给定的 byte 数组支持；也就是说，缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量将为 array.length，其位置将为 offset，其界限将为 offset + length，其标记是不确定的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 支持新缓冲区的数组
offset - 要使用的子数组的偏移量；必须为非负且不大于 array.length。将新缓冲区的位置设置为此值。
length - 要使用的子数组的长度；必须为非负且不大于 array.length - offset。将新缓冲区的界限设置为 offset + length。
返回：
新的字节缓冲区
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

wrap

public static ByteBuffer wrap(byte[] array)
将 byte 数组包装到缓冲区中。

新的缓冲区将由给定的 byte 数组支持；也就是说，缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量和界限将为 array.length，其位置将为零，其标记是不确定的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 实现此缓冲区的数组
返回：
新的字节缓冲区

slice

public abstract ByteBuffer slice()
创建新的字节缓冲区，其内容是此缓冲区内容的共享子序列。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的字节数量，其标记是不确定的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的字节缓冲区

duplicate

public abstract ByteBuffer duplicate()
创建共享此缓冲区内容的新的字节缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的字节缓冲区

asReadOnlyBuffer

public abstract ByteBuffer asReadOnlyBuffer()
创建共享此缓冲区内容的新的只读字节缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，但新缓冲区将是只读的并且不允许修改共享内容。两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。

如果此缓冲区本身是只读的，则此方法与 duplicate 方法完全相同。

返回：
新的只读字节缓冲区

get

public abstract byte get()
相对 get 方法。读取此缓冲区当前位置的字节，然后该位置递增。

返回：
缓冲区当前位置的字节
抛出：
BufferUnderflowException - 如果该缓冲区的当前位置不小于其界限

put

public abstract ByteBuffer put(byte b)
相对 put 方法（可选操作）。

将给定的字节写入此缓冲区的当前位置，然后该位置递增。

参数：
b - 要写入的字节
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区的当前位置不小于其界限
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

get

public abstract byte get(int index)
绝对 get 方法。读取指定索引处的字节。

参数：
index - 将从中读取该字节的索引
返回：
给定索引处的字节
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限

put

public abstract ByteBuffer put(int index,
                               byte b)
绝对 put 方法（可选操作）。

将给定字节写入此缓冲区的给定索引处。

参数：
index - 将在该位置写入字节的索引
b - 要写入的字节值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

get

public ByteBuffer get(byte[] dst,
                      int offset,
                      int length)
相对批量 get 方法。

此方法将此缓冲区的字节传输到给定的目标数组中。如果此缓冲中剩余的字节少于满足请求所需的字节（即如果 length > remaining()），则不传输字节且抛出 BufferUnderflowException。

否则，此方法将此缓冲区中的 length 个字节复制到给定数组中，从此缓冲区的当前位置和数组中的给定偏移量位置开始复制。然后此缓冲区的位置将增加 length。

换句话说，调用此方法的形式为 src.get(dst, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst[i] = src.get();
区别在于它首先检查此缓冲区中是否具有足够的字节，这样可能效率更高。

参数：
dst - 向其中写入字节的数组
offset - 要写入的第一个字节在数组中的偏移量；必须为非负且不大于 dst.length
length - 要写入到给定数组中的字节的最大数量；必须为非负且不大于 dst.length - offset
返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节少于 length
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

get

public ByteBuffer get(byte[] dst)
相对批量 get 方法。

此方法将此缓冲区的字节传输到给定的目标数组中。调用此方法的形式为 src.get(a)，该调用与以下调用完全相同：

     src.get(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节少于 length

put

public ByteBuffer put(ByteBuffer src)
相对批量 put 方法（可选操作）。

此方法将给定源缓冲区中的剩余字节传输到此缓冲区中。如果源缓冲区中的剩余字节多于此缓冲区中的剩余字节，即如果 src.remaining() > remaining()，则不传输字节且抛出 BufferOverflowException。

否则，此方法将给定缓冲区中的 n = src.remaining() 个字节复制到此缓冲区中，从每个缓冲区的当前位置开始复制。然后这两个缓冲区的位置都增加 n。

换句话说，调用此方法的形式为 dst.put(src)，效果与以下循环语句完全相同：

     while (src.hasRemaining())
         dst.put(src.get());
区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

参数：
src - 要从中读取字节的源缓冲区；不能为此缓冲区
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够的空间来容纳源缓冲区中剩余的字节
IllegalArgumentException - 如果源缓冲区是此缓冲区
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

put

public ByteBuffer put(byte[] src,
                      int offset,
                      int length)
相对批量 put 方法（可选操作）。

此方法将把给定源数组中的字节字传输到此缓冲区中。如果要从该数组中复制的字节多于此缓冲区中的剩余字节，即如果 length > remaining()），则不传输字节且将抛出 BufferOverflowException。

否则，此方法将给定数组中的 length 个字节复制到此缓冲区中，从数组中给定偏移量位置和此缓冲区的当前位置开始复制。然后此缓冲区的位置将增加 length。

换句话说，调用此方法的形式为 dst.put(src, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst.put(a[i]);
区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

参数：
src - 要从中读取字节的数组
offset - 要读取的第一个字节在数组中的偏移量；必须为非负且不大于 array.length
length - 要从给定数组读取的字节的数量；必须为非负且不大于 array.length - offset
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

put

public final ByteBuffer put(byte[] src)
相对批量 put 方法（可选操作）。

此方法将给定的源 byte 数组的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(a)，该调用与以下调用完全相同：

     dst.put(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

hasArray

public final boolean hasArray()
判断是否可通过一个可访问的 byte 数组实现此缓冲区。

如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

指定者：
类 Buffer 中的 hasArray
返回：
当且仅当存在实现此缓冲区的数组，并且此缓冲区不是只读缓冲区时，返回 true

array

public final byte[] array()
返回实现此缓冲区的 byte 数组（可选操作）。

此缓冲区的内容修改将导致返回的数组内容修改，反之亦然。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 array
返回：
实现此缓冲区的数组
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

arrayOffset

public final int arrayOffset()
返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。

如果存在实现此缓冲区的数组，则缓冲区位置 p 对应于数组索引 p + arrayOffset()。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 arrayOffset
返回：
此缓冲区的第一个元素在缓冲区数组中的偏移量
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

compact

public abstract ByteBuffer compact()
压缩此缓冲区（可选操作）。

将缓冲区的当前位置和界限之间的字节（如果有）复制到缓冲区的开始处。即将索引 p = position() 处的字节复制到索引 0 处，将索引 p + 1 处的字节复制到索引 1 处，依此类推，直到将索引 limit() - 1 处的字节复制到索引 n = limit() - 1 - p 处。然后将缓冲区的位置设置为 n+1，并将其界限设置为其容量。如果已定义了标记，则丢弃它。

将缓冲区的位置设置为复制的字节数，而不是零，以便调用此方法后可以紧接着调用另一个相对 put 方法。

从缓冲区写入数据之后调用此方法，以防写入不完整。例如，以下循环语句通过 buf 缓冲区将字节从一个信道复制到另一个信道：

 buf.clear();          // Prepare buffer for use
  while (in.read(buf) >= 0 || buf.position != 0) {
     buf.flip();
     out.write(buf);
     buf.compact();    // In case of partial write
 }

返回：
此缓冲区
抛出：
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

isDirect

public abstract boolean isDirect()
判断此字节缓冲区是否为直接的。

指定者：
类 Buffer 中的 isDirect
返回：
当且仅当此缓冲区为直接时，返回 true

toString

public String toString()
返回汇总了此缓冲区状态的字符串。

覆盖：
类 Object 中的 toString
返回：
一个汇总字符串

hashCode

public int hashCode()
返回此缓冲区的当前哈希码。

字节缓冲区的哈希码仅取决于其中剩余的元素；也就是说，取决于从 position() 开始一直到（包括）limit() - 1 处的元素。

因为缓冲区哈希码与内容有关，因此建议不要在哈希映射或其他类似数据结构中将缓冲区用作键，除非知道其内容不会发生更改。

覆盖：
类 Object 中的 hashCode
返回：
此缓冲区的当前哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object ob)
判断此缓冲区是否与另一个对象相同。

当且仅当满足以下条件时两个字节缓冲区相同：

  1. 它们具有相同的元素类型，

  2. 它们具有相同数量的剩余元素，并且

  3. 两个剩余元素序列（与它们的起始位置无关）逐点相同。

字节缓冲区与任何其他类型的对象都不同。

覆盖：
类 Object 中的 equals
参数：
ob - 此缓冲区要比较的对象
返回：
当且仅当此缓冲区与给定对象相同时，返回 true
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(ByteBuffer that)
将此缓冲区与另一个缓冲区进行比较。

比较两个字节缓冲区的方法是按字典顺序比较它们的剩余元素序列，而不考虑每个序列在其对应缓冲区中的起始位置。

字节缓冲区不能与任何其他类型的对象进行比较。

指定者：
接口 Comparable<ByteBuffer> 中的 compareTo
参数：
that - 要比较的对象。
返回：
当此缓冲区小于、等于或大于给定缓冲区时，返回负整数、零或正整数

order

public final ByteOrder order()
获取此缓冲区的字节顺序。

在读写多字节值以及为此字节缓冲区创建视图时使用该字节顺序。新创建的字节缓冲区的顺序始终为 BIG_ENDIAN。

返回：
此缓冲区的字节顺序

order

public final ByteBuffer order(ByteOrder bo)
修改此缓冲区的字节顺序。

参数：
bo - 新的字节顺序，要么是 BIG_ENDIAN，要么是 LITTLE_ENDIAN
返回：
此缓冲区

getChar

public abstract char getChar()
用于读取 char 值的相对 get 方法。

读取此缓冲区的当前位置之后的两个字节，根据当前的字节顺序将它们组成 char 值，然后将该位置增加 2。

返回：
缓冲区当前位置的 char 值
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节数少于 2

putChar

public abstract ByteBuffer putChar(char value)
用来写入 char 值的相对 put 方法（可选操作）。

将两个包含指定 char 值的字节按照当前的字节顺序写入到此缓冲区的当前位置，然后将该位置增加 2。

参数：
value - 要写入的 char 值
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区中的剩余字节数少于 2
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

getChar

public abstract char getChar(int index)
用于读取 char 值的绝对 get 方法。

读取给定索引处的两个字节，并根据当前的字节顺序将它们组成 char 值。

参数：
index - 将从该位置读取字节的索引
返回：
给定索引处的 char 值
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 1 所得的值

putChar

public abstract ByteBuffer putChar(int index,
                                   char value)
用于写入 char 值的绝对 put 方法（可选操作）。

将两个包含给定 char 值的字节按照当前的字节顺序写入到此缓冲区的给定索引处。

参数：
index - 将在该位置写入字节的索引
value - 要写入的 char 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 1 所得的值
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

asCharBuffer

public abstract CharBuffer asCharBuffer()
创建此字节缓冲区的视图，作为 char 缓冲区。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的字节数的二分之一，其标记是不确定的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 char 缓冲区

getShort

public abstract short getShort()
用于读取 short 值的相对 get 方法。

读取此缓冲区的当前位置之后的两个字节，根据当前的字节顺序将它们组成 short 值，然后将该位置增加 2。

返回：
缓冲区当前位置的 short 值
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节数少于 2

putShort

public abstract ByteBuffer putShort(short value)
用于写入 short 值的相对 put 方法（可选操作）。

将两个包含指定 short 值的字节按照当前的字节顺序写入到此缓冲区的当前位置，然后将该位置增加 2。

参数：
value - 要写入的 short 值
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区中的剩余字节数少于 2
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

getShort

public abstract short getShort(int index)
用于读取 short 值的绝对 get 方法。

读取给定索引处的两个字节，根据当前的字节顺序将它们组成 short 值。

参数：
index - 将从该位置读取字节的索引
返回：
给定索引处的 short 值
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 1 所得的值

putShort

public abstract ByteBuffer putShort(int index,
                                    short value)
用于写入 short 值的绝对 put 方法（可选操作）。

将两个包含给定 short 值的字节按照当前的字节顺序写入到此缓冲区的给定索引处。

参数：
index - 将在该位置写入字节的索引
value - 要写入的 short 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 1 所得的值
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

asShortBuffer

public abstract ShortBuffer asShortBuffer()
创建此字节缓冲区的视图，作为 short 缓冲区。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的字节数的二分之一，其标记是不确定的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 short 缓冲区

getInt

public abstract int getInt()
用于读取 int 值的相对 get 方法。

读取此缓冲区的当前位置之后的 4 个字节，根据当前的字节顺序将它们组成 int 值，然后将该位置增加 4。

返回：
缓冲区当前位置的 int 值
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节数少于 4

putInt

public abstract ByteBuffer putInt(int value)
用于写入 int 值的相对 put 方法（可选操作）。

将 4 个包含给定 int 值的字节按照当前的字节顺序写入到此缓冲区的当前位置，然后将该位置增加 4。

参数：
value - 要写入的 int 值
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区中的剩余字节数少于 4
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

getInt

public abstract int getInt(int index)
用于读取 int 值的绝对 get 方法。

读取给定索引处的 4 个字节，根据当前的字节顺序将它们组成 int 值。

参数：
index - 将从该位置读取字节的索引
返回：
给定索引处的 int 值
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 3 所得的值

putInt

public abstract ByteBuffer putInt(int index,
                                  int value)
用于写入 int 值的绝对 put 方法（可选操作）。

将 4 个包含给定 int 值的字节按照当前的字节顺序写入到此缓冲区的给定索引处。

参数：
index - 将在该位置写入字节的索引
value - 要写入的 int 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 3 所得的值
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

asIntBuffer

public abstract IntBuffer asIntBuffer()
创建此字节缓冲区的视图，作为 int 缓冲区。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的字节数的四分之一，其标记是不确定的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 int 缓冲区

getLong

public abstract long getLong()
用于读取 long 值的相对 get 方法。

读取此缓冲区的当前位置之后的 8 个字节，根据当前的字节顺序将它们组成 long 值，然后将该位置增加 8。

返回：
缓冲区当前位置的 long 值
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节数少于 8

putLong

public abstract ByteBuffer putLong(long value)
用于写入 long 值（可先操作） 的相对 put 方法。

将 8 个包含给定 long 值的字节按照当前的字节顺序写入到此缓冲区的当前位置，然后将该位置增加 8。

参数：
value - 要写入的 long 值
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区中的剩余字节数少于 8
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

getLong

public abstract long getLong(int index)
用于读取 long 值的绝对 get 方法。

读取给定索引处的 8 个字节，根据当前的字节顺序将它们组成 long 值。

参数：
index - 将从该位置读取字节的索引
返回：
给定索引处的 long 值
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 7 所得的值

putLong

public abstract ByteBuffer putLong(int index,
                                   long value)
用于写入 long 值的绝对 put 方法（可选操作）。

将 8 个包含给定 long 值的字节按照当前的字节顺序写入到此缓冲区的给定索引处。

参数：
index - 将在该位置写入字节的索引
value - 要写入的 long 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 7 所得的值
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

asLongBuffer

public abstract LongBuffer asLongBuffer()
创建此字节缓冲区的视图，作为 long 缓冲区。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的字节数的八分之一，其标记是不确定的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 long 缓冲区

getFloat

public abstract float getFloat()
用于读取 float 值的相对 get 方法。

读取此缓冲区的当前位置之后的 4 个字节，根据当前的字节顺序将它们组成 float 值，然后将该位置增加 4。

返回：
缓冲区当前位置的 float 值
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节数少于 4

putFloat

public abstract ByteBuffer putFloat(float value)
用于写入 float 值的相对 put 方法（可选操作）。

将 4 个包含给定 float 值的字节按照当前的字节顺序写入到此缓冲区的当前位置，然后然后将该位置增加 4。

参数：
value - 要写入的 float 值
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区中的剩余字节数少于 4
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

getFloat

public abstract float getFloat(int index)
用于读取 float 值的绝对 get 方法。

读取给定索引处的 4 个字节，根据当前的字节顺序将它们组成 float 值。

参数：
index - 将从该位置读取字节的索引
返回：
给定索引处的 float 值
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 3 所得的值

putFloat

public abstract ByteBuffer putFloat(int index,
                                    float value)
用于写入 float 值的绝对 put 方法（可选操作）。

将 4 个包含给定 float 值的字节按照当前的字节顺序写入到此缓冲区的给定索引处。

参数：
index - 将在该位置写入字节的索引
value - 要写入的 float 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 3 所得的值
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

asFloatBuffer

public abstract FloatBuffer asFloatBuffer()
创建此字节缓冲区的视图，作为 float 缓冲区。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和其界限将为此缓冲区中剩余字节数的四分之一，其标记是不确定的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 float 缓冲区

getDouble

public abstract double getDouble()
用于读取 double 值的相对 get 方法。

读取此缓冲区的当前位置之后的 8 个字节，根据当前的字节顺序将它们组成 double 值，然后将该位置增加 8。

返回：
缓冲区当前位置的 double 值
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字节数少于 8

putDouble

public abstract ByteBuffer putDouble(double value)
用于写入 double 值的相对 put 方法（可选操作）。

将 8 个包含给定 double 值的字节按照当前的字节顺序写入到此缓冲区的当前位置，然后将该位置增加 8。

参数：
value - 要写入的 double 值
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区中的剩余字节数少于 8
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

getDouble

public abstract double getDouble(int index)
用于读取 double 值的绝对 get 方法。

读取给定索引处的 8 个字节，根据当前的字节顺序将它们组成 double 值。

参数：
index - 将从该位置读取字节的索引
返回：
给定索引处的 double 值
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 7 所得的值

putDouble

public abstract ByteBuffer putDouble(int index,
                                     double value)
用于写入 double 值的绝对 put 方法（可选操作）。

将 8 个包含给定 double 值的字节按照当前的字节顺序写入到此缓冲区的给定索引处。

参数：
index - 将在该位置写入字节的索引
value - 要写入的 double 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负数，或者不小于该缓冲区的界限 - 7 所得的值
ReadOnlyBufferException - 如果此缓冲区是只读缓冲区

asDoubleBuffer

public abstract DoubleBuffer asDoubleBuffer()
创建此字节缓冲区的视图，作为 double 缓冲区。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的字节数的八分之一，其标记是不确定的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 double 缓冲区
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ByteOrder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 ByteOrder

java.lang.Object
    继承者  java.nio.ByteOrder

public final class ByteOrder
extends Object

字节顺序的类型安全枚举。

从以下版本开始：
1.4

字段摘要
static ByteOrder | BIG_ENDIAN 表示 big-endian 字节顺序的常量。
static ByteOrder | LITTLE_ENDIAN 表示 little-endian 字节顺序的常量。
方法摘要
static ByteOrder | nativeOrder() 获取底层平台的本机字节顺序。
String | toString() 构造描述此对象的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

BIG_ENDIAN

public static final ByteOrder BIG_ENDIAN
表示 big-endian 字节顺序的常量。按照此顺序，多字节值的字节顺序是从最高有效位到最低有效位的。

LITTLE_ENDIAN

public static final ByteOrder LITTLE_ENDIAN
表示 little-endian 字节顺序的常量。按照此顺序，多字节值的字节顺序是从最低有效位到最高有效位的。

方法详细信息

nativeOrder

public static ByteOrder nativeOrder()
获取底层平台的本机字节顺序。

此方法的定义使得对性能敏感的 Java 代码能分配字节顺序与硬件相同的直接缓冲区。本机代码库通常在使用此类缓冲区时更为高效。

返回：
此 Java 虚拟机在其上运行的硬件的本机字节顺序

toString

public String toString()
构造描述此对象的字符串。

对于 BIG_ENDIAN，此方法返回字符串 "BIG_ENDIAN"，对于 LITTLE_ENDIAN 则返回字符串 "LITTLE_ENDIAN"。

覆盖：
类 Object 中的 toString
返回：
指定的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 CharBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.CharBuffer
所有已实现的接口：
Appendable, CharSequence, Comparable<CharBuffer>, Readable
public abstract class CharBuffer
extends Buffer
implements Comparable<CharBuffer>, Appendable, CharSequence, Readable

字符缓冲区。

此类定义了字符缓冲区上的四类操作：

  • 读写单个字符的绝对和相对 get 和 put 方法；

  • 将此缓冲区中的连续字符序列传输到数组中的相对批量 get 方法；

  • 将字符数组、字符串或其他字符缓冲区中的连续字符序列传输到此缓冲区的相对批量 put 方法；以及

  • 字符缓冲区的 compacting、duplicating 和 slicing 方法。

字符缓冲区可以通过 allocation 方法创建，此方法通过 wrapping 将一个现有字符数组或字符串包装到缓冲区中来为缓冲区内容分配空间，或者通过创建现有字节缓冲区的视图来创建。

像字节缓冲区一样，字符缓冲区要么是直接的，要么是非直接的。通过此类的 wrap 方法创建的字符缓冲区将是非直接的。当且仅当字节缓冲区本身为直接时，作为字节缓冲区的视图创建的字符缓冲区才是直接的。通过调用 isDirect 方法可以确定字符缓冲区是否为直接的。

此类实现 CharSequence 接口，以便字符缓冲区可以用于任何接受字符序列的地方，例如，在正则表达式包 java.util.regex 中。

指定此类中不返回其他值的那些方法返回它们被调用时所在的缓冲区。这允许对方法调用进行链接。 例如，语句序列

 cb.put("text/");
 cb.put(subtype);
 cb.put("; charset=");
 cb.put(enc);
可以由以下单个语句替换
 cb.put("text/").put(subtype).put("; charset=").put(enc);

从以下版本开始：
1.4

方法摘要
static CharBuffer | allocate(int capacity) 分配新的字符缓冲区。
CharBuffer | append(char c) 将指定字符添加到此缓冲区（可选操作）。
CharBuffer | append(CharSequence csq) 将指定的字符序列添加到此缓冲区（可选操作）。
CharBuffer | append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此缓冲区（可选操作）。
char[] | array() 返回实现此缓冲区的字符数组（可选操作）。
int | arrayOffset() 返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
abstract CharBuffer | asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读字符缓冲区。
char | charAt(int index) 读取相对于当前位置的给定索引处的字符。
abstract CharBuffer | compact() 压缩此缓冲区（可选操作）。
int | compareTo(CharBuffer that) 将此缓冲区与另一个缓冲区进行比较。
abstract CharBuffer | duplicate() 创建共享此缓冲区内容的新的字符缓冲区。
boolean | equals(Object ob) 判断此缓冲区是否与另一个对象相同。
abstract char | get() 相对 get 方法。
CharBuffer | get(char[] dst) 相对批量 get 方法。
CharBuffer | get(char[] dst, int offset, int length) 相对批量 get 方法。
abstract char | get(int index) 绝对 get 方法。
boolean | hasArray() 判断该缓冲区是否可通过一个可访问的字符数组实现。
int | hashCode() 返回此缓冲区的当前哈希码。
abstract boolean | isDirect() 判断此字符缓冲区是否为直接的。
int | length() 返回此字符缓冲区的长度。
abstract ByteOrder | order() 获取此缓冲区的字节顺序。
abstract CharBuffer | put(char c) 相对 put 方法（可选操作）。
CharBuffer | put(char[] src) 相对批量 put 方法（可选操作）。
CharBuffer | put(char[] src, int offset, int length) 相对批量 put 方法（可选操作）。
CharBuffer | put(CharBuffer src) 相对批量 put 方法（可选操作）。
abstract CharBuffer | put(int index, char c) 绝对 put 方法（可选操作）。
CharBuffer | put(String src) 相对批量 put 方法（可选操作）。
CharBuffer | put(String src, int start, int end) 相对批量 put 方法（可选操作）。
int | read(CharBuffer target) 试图将字符读入指定的字符缓冲区。
abstract CharBuffer | slice() 创建新的字符缓冲区，其内容为此缓冲区内容的共享子序列。
abstract CharSequence | subSequence(int start, int end) 创建表示此缓冲区的指定序列、相对于当前位置的新字符缓冲区。
String | toString() 返回包含此缓冲区中字符的字符串。
static CharBuffer | wrap(char[] array) 将字符数组包装到缓冲区中。
static CharBuffer | wrap(char[] array, int offset, int length) 将字符数组包装到缓冲区中。
static CharBuffer | wrap(CharSequence csq) 将字符序列包装到缓冲区中。
static CharBuffer | wrap(CharSequence csq, int start, int end) 将字符序列包装到缓冲区中。
从类 java.nio.Buffer 继承的方法
capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

allocate

public static CharBuffer allocate(int capacity)
分配新的字符缓冲区。

新缓冲区的位置将为零，其界限将为其容量，其标记是未定义的。它将具有一个底层实现数组，且其数组偏移量将为零。

参数：
capacity - 新缓冲区的容量，以字符为单位
返回：
新的字符缓冲区
抛出：
IllegalArgumentException - 如果 capacity 为负整数

wrap

public static CharBuffer wrap(char[] array,
                              int offset,
                              int length)
将字符数组包装到缓冲区中。

给定的字符数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量将为 array.length，其位置将为 offset，其界限将为 offset + length，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 支持新缓冲区的数组
offset - 要使用的子数组的偏移量；必须为非负且不大于 array.length。将新缓冲区的位置设置为此值。
length - 要使用的子数组的长度；必须为非负且不大于 array.length - offset。新缓冲区的界限将被设置为 offset + length。
返回：
新的字符缓冲区
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

wrap

public static CharBuffer wrap(char[] array)
将字符数组包装到缓冲区中。

给定的字符数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量和界限将为 array.length，其位置将为零，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 实现此缓冲区的数组
返回：
新的字符缓冲区

read

public int read(CharBuffer target)
         throws IOException
试图将字符读入指定的字符缓冲区。缓冲区可照原样用作字符的存储库：所做的唯一更改是 put 操作的结果。不对缓冲区执行翻转或重绕操作。

指定者：
接口 Readable 中的 read
参数：
target - 要将字符读入的缓冲区
返回：
添加到缓冲区的字符数量，如果此字符源位于缓冲区末端，则返回 -1
抛出：
IOException - 如果发生 I/O 错误
NullPointerException - 如果目标为空
ReadOnlyBufferException - 如果目标是一个只读缓冲区
从以下版本开始：
1.5

wrap

public static CharBuffer wrap(CharSequence csq,
                              int start,
                              int end)
将字符序列包装到缓冲区中。

新的只读缓冲区的内容将为给定字符序列的内容。缓冲区的容量将为 csq.length()，其位置将为 start，其界限将为 end，其标记是未定义的。

参数：
csq - 字符序列，新的字符缓冲区将从中创建
start - 要使用的第一个字符的索引；必须为非负且不大于 csq.length()。新缓冲区的位置将被设置为此值。
end - 要使用的最后一个字符后面的字符的索引；必须不小于 start 且不大于 csq.length()。将新缓冲区的界限设置为此值。
返回：
新的字符缓冲区
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

wrap

public static CharBuffer wrap(CharSequence csq)
将字符序列包装到缓冲区中。

新的只读缓冲区的内容将为给定字符序列的内容。新缓冲区的容量和界限将为 csq.length()，其位置将为零，其标记是未定义的。

参数：
csq - 新的字符缓冲区要从其创建的字符序列
返回：
新的字符缓冲区

slice

public abstract CharBuffer slice()
创建新的字符缓冲区，其内容为此缓冲区内容的共享子序列。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的字符数量，其标记是未定义的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的字符缓冲区

duplicate

public abstract CharBuffer duplicate()
创建共享此缓冲区内容的新的字符缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的字符缓冲区

asReadOnlyBuffer

public abstract CharBuffer asReadOnlyBuffer()
创建共享此缓冲区内容的新的只读字符缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区的更改在新缓冲区中是可见的，但新缓冲区将是只读的并且不允许修改共享内容。两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。

如果此缓冲区本身是只读的，则此方法与 duplicate 方法完全相同。

返回：
新的只读字符缓冲区

get

public abstract char get()
相对 get 方法。读取此缓冲区当前位置的字符，然后该位置递增。

返回：
缓冲区当前位置的字符
抛出：
BufferUnderflowException - 如果缓冲区当前位置不小于其界限

put

public abstract CharBuffer put(char c)
相对 put 方法（可选操作）。

将给定字符写入此缓冲区的当前位置，然后该位置递增。

参数：
c - 要写入的字符
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区的当前位置不小于界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public abstract char get(int index)
绝对 get 方法。读取给定索引处的字符。

参数：
index - 将读取字符的位置的索引
返回：
给定索引处的字符
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限

put

public abstract CharBuffer put(int index,
                               char c)
绝对 put 方法（可选操作）。

将给定字符写入此缓冲区的给定索引处。

参数：
index - 将在该位置写入字符
c - 要写入的字符值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public CharBuffer get(char[] dst,
                      int offset,
                      int length)
相对批量 get 方法。

此方法将此缓冲区中的字符传输到给定的目标数组中。如果缓冲区中剩余的字符少于满足请求所需的字符，即如果 length > remaining()，则不传输字符且抛出 BufferUnderflowException。

否则，此方法将此缓冲区中的 length 个字符复制到给定数组中，从此缓冲区的当前位置和数组中的给定偏移量位置开始复制。然后此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 src.get(dst, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst[i] = src.get();
区别在于它首先检查此缓冲区中是否具有足够的字符，这样可能效率更高。

参数：
dst - 要写入字符的数组
offset - 要写入的第一个字符在数组中的偏移量；必须为非负且不大于 dst.length
length - 要写入给定数组中的字符的最大数量；必须为非负且不大于 dst.length - offset
返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字符少于 length
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

get

public CharBuffer get(char[] dst)
相对批量 get 方法。

此方法将此缓冲区的字符传输到给定的目标数组中。调用此方法的形式为 src.get(a)，该调用与以下调用完全相同：

     src.get(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余字符少于 length

put

public CharBuffer put(CharBuffer src)
相对批量 put 方法（可选操作）。

此方法将给定源缓冲区中的剩余字符传输到此缓冲区中。如果源缓冲区中的剩余字符多于此缓冲区的剩余字符空间，即 src.remaining() > remaining()，则不传输字符且抛出 BufferOverflowException。

否则，此方法将给定缓冲区中的 n = src.remaining() 个字符复制到此缓冲区中，从每个缓冲区的当前位置开始复制。然后这两个缓冲区的位置均递增 n。

换句话说，调用此方法的形式为 dst.put(src)，效果与以下循环语句完全相同：

     while (src.hasRemaining())
         dst.put(src.get());
区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

参数：
src - 要从中读取字符的源缓冲区；不能为此缓冲区
返回：
此缓冲区
抛出：
BufferOverflowException - 如果对于源缓冲区中剩余的字符，此缓冲区没有足够空间
IllegalArgumentException - 如果源缓冲区为此缓冲区
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public CharBuffer put(char[] src,
                      int offset,
                      int length)
相对批量 put 方法（可选操作）。

此方法将给定源数组中的字符传输到此缓冲区中。如果要从数组复制的字符多于此缓冲区中的剩余字符空间，即如果 length > remaining()，则不传输字符且抛出 BufferOverflowException。

否则，此方法将给定数组中的 length 个字符复制到此缓冲区中，从数组中给定偏移量位置和此缓冲区的当前位置开始复制。然后此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 dst.put(src, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst.put(a[i]);
区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

参数：
src - 要从中读取字符的数组
offset - 要读取的第一个字符在数组中的偏移量；必须为非负且不大于 array.length
length - 要从给定数组读取的字符数量；必须为非负且不大于 array.length - offset
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public final CharBuffer put(char[] src)
相对批量 put 方法（可选操作）。

此方法将给定源字符数组的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(a)，该调用与以下调用完全相同：

     dst.put(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public CharBuffer put(String src,
                      int start,
                      int end)
相对批量 put 方法（可选操作）。

此方法将给定字符串中的字符传输到此缓冲区中。如果要从字符串复制的字符多于此缓冲区中的剩余字符空间，即如果 end - start > remaining()，则不传输字符且抛出 BufferOverflowException。

否则，此方法将给定字符串的 n = end - start 个字符复制到此缓冲区中，从给定的 start 索引处和此缓冲区的当前位置开始复制。然后此缓冲区的位置递增 n。

换句话说，调用此方法的形式为 dst.put(src, start, end)，效果与以下循环语句完全相同：

     for (int i = start; i < end; i++)
         dst.put(src.charAt(i));
区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

参数：
src - 要从中读取字符的字符串
start - 要读取的第一个字符在字符串中的偏移量；必须为非负且不大于 string.length()
end - 要读取的最后一个字符在字符串中的偏移量加上 1；必须为非负且不大于 string.length()
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
IndexOutOfBoundsException - 如果关于 start 和 end 参数的前提不成立
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public final CharBuffer put(String src)
相对批量 put 方法（可选操作）。

此方法将给定源字符串中的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(s)，该调用与以下调用完全相同：

     dst.put(s, 0, s.length())

返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读的

hasArray

public final boolean hasArray()
判断该缓冲区是否可通过一个可访问的字符数组实现。

如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

指定者：
类 Buffer 中的 hasArray
返回：
当且仅当存在实现此缓冲区的数组，并且此缓冲区不是只读缓冲区时，返回 true

array

public final char[] array()
返回实现此缓冲区的字符数组（可选操作）。

此缓冲区的内容修改将导致返回的数组内容修改，反之亦然。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 array
返回：
实现此缓冲区的数组
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

arrayOffset

public final int arrayOffset()
返回此缓冲区中的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。

如果存在实现此缓冲区的数组，则缓冲区位置 p 对应于数组索引 p + arrayOffset()。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 arrayOffset
返回：
此缓冲区的第一个元素在缓冲区数组中的偏移量
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

compact

public abstract CharBuffer compact()
压缩此缓冲区（可选操作）。

将缓冲区当前位置和界限之间的字符（如果有）复制到缓冲区的开始处。即将索引 p = position() 处的字符复制到索引 0 处，将索引 p + 1 处的字符复制到索引 1 处，依此类推，直到将索引 limit() - 1 处的字符复制到索引 n = limit() - 1 - p 处。然后将缓冲区的位置设置为 n+1，并将其界限设置为其容量。如果已定义了标记，则丢弃它。

将缓冲区的位置设置为复制的字符数，而不是零，以便调用此方法后可以紧接着调用另一个相对 put 方法。

返回：
此缓冲区
抛出：
ReadOnlyBufferException - 如果此缓冲区是只读的

isDirect

public abstract boolean isDirect()
判断此字符缓冲区是否为直接的。

指定者：
类 Buffer 中的 isDirect
返回：
当且仅当此缓冲区为直接时，返回 true

hashCode

public int hashCode()
返回此缓冲区的当前哈希码。

字符缓冲区的哈希码只取决于其剩余元素；即取决于从 position() 开始一直到（包括） limit() - 1 处的元素。

因为缓冲区哈希码与内容有关，因此建议不要在哈希映射或其他类似数据结构中将缓冲区用作键，除非知道其内容不会发生更改。

覆盖：
类 Object 中的 hashCode
返回：
此缓冲区的当前哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object ob)
判断此缓冲区是否与另一个对象相同。

两个字符缓冲区是相同的，当且仅当：

  1. 它们具有相同的元素类型，

  2. 它们具有相同数量的剩余元素，并且

  3. 两个剩余元素序列（与它们的起始位置无关）逐点相同。

字符缓冲区与任何其他类型的对象都不同。

覆盖：
类 Object 中的 equals
参数：
ob - 此缓冲区要比较的对象
返回：
当且仅当此缓冲区与给定对象相同时，返回 true
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(CharBuffer that)
将此缓冲区与另一个缓冲区进行比较。

比较两个字符缓冲区的方法是按字典顺序比较它们的剩余元素序列，而不考虑每个序列在其对应缓冲区中的起始位置。

字符缓冲区不能与任何其他类型的对象进行比较。

指定者：
接口 Comparable<CharBuffer> 中的 compareTo
参数：
that - 要比较的对象。
返回：
如果此缓冲区小于、等于或大于给定缓冲区，则相应返回负整数、零或正整数

toString

public String toString()
返回包含此缓冲区中字符的字符串。

所得字符串的第一个字符将为此缓冲区位置处的字符，最后一个字符将为索引 limit() - 1 处的字符。调用此方法不更改缓冲区的位置。

指定者：
接口 CharSequence 中的 toString
覆盖：
类 Object 中的 toString
返回：
指定的字符串

length

public final int length()
返回此字符缓冲区的长度。

当将字符缓冲区视为字符序列时，长度只是该位置（包括）和界限（不包括）之间的字符数；即长度等效于 remaining()。

指定者：
接口 CharSequence 中的 length
返回：
此字符缓冲区的长度

charAt

public final char charAt(int index)
读取相对于当前位置的给定索引处的字符。

指定者：
接口 CharSequence 中的 charAt
参数：
index - 要读取的相对于该位置的字符的索引；必须为非负且小于 remaining()
返回：
索引 position() + index 处的字符
抛出：
IndexOutOfBoundsException - 如果关于 index 的前提不成立

subSequence

public abstract CharSequence subSequence(int start,
                                         int end)
创建表示此缓冲区的指定序列、相对于当前位置的新字符缓冲区。

新缓冲区将共享此缓冲区的内容；即如果此缓冲区的内容是可变的，则修改一个缓冲区将导致另一个缓冲区被修改。新缓冲区的容量将为此缓冲区的容量，其位置将为 position() + start，其界限将为 position() + end。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

指定者：
接口 CharSequence 中的 subSequence
参数：
start - 子序列中第一个字符相对于当前位置的索引；必须为非负且不大于 remaining()
end - 子序列中最后一个字符后面的字符相对于当前位置的索引；必须不小于 start 且不大于 remaining()
返回：
新的字符序列
抛出：
IndexOutOfBoundsException - 如果关于 start 和 end 的前提不成立

append

public CharBuffer append(CharSequence csq)
将指定的字符序列添加到此缓冲区（可选操作）。

调用此方法的形式为 dst.append(csq)，该调用与以下调用完全相同：

     dst.put(csq.toString())

可能没有添加整个序列，这取决于针对字符序列 csq 的 toString 规范。例如，调用字符缓冲区的 toString 方法将返回一个子序列，其内容取决于缓冲区的位置和界限。

指定者：
接口 Appendable 中的 append
参数：
csq - 要添加的字符序列。如果 csq 为 null，则向此字符缓冲区添加四个字符 "null"。
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读的
从以下版本开始：
1.5

append

public CharBuffer append(CharSequence csq,
                         int start,
                         int end)
将指定字符序列的子序列添加到此缓冲区（可选操作）。

当 csq 不为 null 时，调用此方法的形式为 dst.append(csq, start, end)，该调用与以下调用完全相同：

     dst.put(csq.subSequence(start, end).toString())

指定者：
接口 Appendable 中的 append
参数：
csq - 要添加其子序列的字符序列。如果 csq 为 null，则按 csq 包含四个字符 "null" 的方式添加这些字符。
start - 子序列中第一个字符的索引
end - 紧随子序列中最后一个字符的字符的索引
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
IndexOutOfBoundsException - 如果 start 或 end 为负，而 start 大于 end 或者 end 大于 csq.length()
ReadOnlyBufferException - 如果此缓冲区是只读的
从以下版本开始：
1.5

append

public CharBuffer append(char c)
将指定字符添加到此缓冲区（可选操作）。

调用此方法的形式为 dst.append(c)，该调用与以下调用完全相同：

     dst.put(c)

指定者：
接口 Appendable 中的 append
参数：
c - 要添加的 16 位字符
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读的
从以下版本开始：
1.5

order

public abstract ByteOrder order()
获取此缓冲区的字节顺序。

通过分配或通过包装现有 char 数组而创建的字符缓冲区的字节顺序是底层硬件的 native order。作为字节缓冲区的视图而创建的字符缓冲区的字节顺序是创建视图时字节缓冲区的字节顺序。

返回：
此缓冲区的字节顺序
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DoubleBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 DoubleBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.DoubleBuffer
所有已实现的接口：
Comparable<DoubleBuffer>
public abstract class DoubleBuffer
extends Buffer
implements Comparable<DoubleBuffer>

double 缓冲区。

此类定义了 double 缓冲区上的四类操作：

  • 读写单个 double 的绝对和相对 get 方法和 put 方法。

  • 将此缓冲区的连续 double 序列传输到数组中的相对批量 get 方法；

  • 将 double 数组或其他 double 缓冲区中的连续 double 序列传输到此缓冲区的相对批量 put 方法；以及

  • double 缓冲区的 compacting、duplicating 和 #sliceslicing 方法。

double 缓冲区可以通过 allocation 创建，此方法通过 wrapping 将一个现有 double 数组包装到缓冲区中来为缓冲区内容分配空间，或者通过创建现有字节缓冲区的视图来创建。

像字节缓冲区一样，double 缓冲区要么是直接的，要么是非直接的。通过此类的 wrap 方法创建的 double 缓冲区将是非直接的。当且仅当字节缓冲区本身为直接时，作为字节缓冲区的视图创建的 double 缓冲区才是直接的。通过调用 isDirect 方法可以确定 double 缓冲区是否为直接的。

指定此类中的方法（它们不返回其他值），以返回这些方法被调用时所在的缓冲区。这允许对方法调用进行链接。

从以下版本开始：
1.4

方法摘要
static DoubleBuffer | allocate(int capacity) 分配新的 double 缓冲区。
double[] | array() 返回实现此缓冲区的 double 数组（可选操作）。
int | arrayOffset() 返回此缓冲区中的第一个 double 元素在缓冲区的底层实现数组中的偏移量（可选操作）。
abstract DoubleBuffer | asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 double 缓冲区。
abstract DoubleBuffer | compact() 压缩此缓冲区（可选操作）。
int | compareTo(DoubleBuffer that) 将此缓冲区与另一个缓冲区进行比较。
abstract DoubleBuffer | duplicate() 创建共享此缓冲区内容的新的 double 缓冲区。
boolean | equals(Object ob) 判断此缓冲区是否与另一个对象相同。
abstract double | get() 相对 get 方法。
DoubleBuffer | get(double[] dst) 相对批量 get 方法。
DoubleBuffer | get(double[] dst, int offset, int length) 相对批量 get 方法。
abstract double | get(int index) 绝对 get 方法。
boolean | hasArray() 判断是否可通过一个可访问的 double 数组实现此缓冲区。
int | hashCode() 返回此缓冲区的当前哈希码。
abstract boolean | isDirect() 判断此 double 缓冲区是否为直接的。
abstract ByteOrder | order() 获取此缓冲区的字节顺序。
abstract DoubleBuffer | put(double d) 相对 put 方法（可选操作）。
DoubleBuffer | put(double[] src) 相对批量 put 方法（可选操作）。
DoubleBuffer | put(double[] src, int offset, int length) 相对批量 put 方法（可选操作）。
DoubleBuffer | put(DoubleBuffer src) 相对批量 put 方法（可选操作）。
abstract DoubleBuffer | put(int index, double d) 绝对 put 方法（可选操作）。
abstract DoubleBuffer | slice() 创建新的 double 缓冲区，其内容是此缓冲区内容的共享子序列。
String | toString() 返回总结了此缓冲区状态的字符串。
static DoubleBuffer | wrap(double[] array) 将 double 数组包装到缓冲区中。
static DoubleBuffer | wrap(double[] array, int offset, int length) 将 double 数组包装到缓冲区中。
从类 java.nio.Buffer 继承的方法
capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

allocate

public static DoubleBuffer allocate(int capacity)
分配新的 double 缓冲区。

新缓冲区的位置将为零，其界限将为其容量，其标记是未定义的。它将具有一个底层实现数组，且其数组偏移量将为零。

参数：
capacity - 新缓冲区的容量，以 double 为单位
返回：
新的 double 缓冲区
抛出：
IllegalArgumentException - 如果 capacity 为负整数

wrap

public static DoubleBuffer wrap(double[] array,
                                int offset,
                                int length)
将 double 数组包装到缓冲区中。

新缓冲区将受给定 double 数组的支持；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量将为 array.length，其位置将为 offset，其界限将为 offset + length，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 支持新缓冲区的数组
offset - 要使用的子数组的偏移量；必须为非负且不大于 array.length。将新缓冲区的位置设置为此值。
length - 要使用的子数组的长度；必须为非负且不大于 array.length - offset。将新缓冲区的界限设置为 offset + length。
返回：
新的 double 缓冲区
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

wrap

public static DoubleBuffer wrap(double[] array)
将 double 数组包装到缓冲区中。

新缓冲区将受给定 double 数组的支持；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量和界限将为 array.length，其位置将为零，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 实现此缓冲区的数组
返回：
新的 double 缓冲区

slice

public abstract DoubleBuffer slice()
创建新的 double 缓冲区，其内容是此缓冲区内容的共享子序列。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的 double 数量，其标记是未定义的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，并且当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 double 缓冲区

duplicate

public abstract DoubleBuffer duplicate()
创建共享此缓冲区内容的新的 double 缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 double 缓冲区

asReadOnlyBuffer

public abstract DoubleBuffer asReadOnlyBuffer()
创建共享此缓冲区内容的新的只读 double 缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，但新缓冲区将是只读的并且不允许修改共享内容。两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。

如果此缓冲区本身是只读的，则此方法与 duplicate 方法完全相同。

返回：
新的只读 double 缓冲区

get

public abstract double get()
相对 get 方法。读取此缓冲区当前位置的 double，然后该位置递增。

返回：
缓冲区当前位置的 double
抛出：
BufferUnderflowException - 如果缓冲区当前位置不小于其界限

put

public abstract DoubleBuffer put(double d)
相对 put 方法（可选操作）。

将给定 double 写入此缓冲区的当前位置，然后将位置递增。

参数：
d - 要写入的 double。
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区的当前位置不小于界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public abstract double get(int index)
绝对 get 方法。读取给定索引处的 double。

参数：
index - 将读取 double 的位置的索引
返回：
给定索引处的 double
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限

put

public abstract DoubleBuffer put(int index,
                                 double d)
绝对 put 方法（可选操作）。

将给定 double 写入此缓冲区的给定索引处。

参数：
index - 将在该位置写入 double
d - 要写入的 double 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public DoubleBuffer get(double[] dst,
                        int offset,
                        int length)
相对批量 get 方法。

此方法将此缓冲区的 double 传输到给定的目标数组中。如果缓冲区中剩余的 double 少于满足请求所需的 double，即如果 length > remaining()，则不传输 double 并抛出 BufferUnderflowException。

否则，此方法将此缓冲区中的 length 个 double 复制到给定数组中，从此缓冲区的当前位置和数组中的给定偏移量位置开始复制。然后将此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 src.get(dst, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst[i] = src.get();
区别在于它首先检查此缓冲区中是否具有足够的 double，这样可能效率更高。

参数：
dst - 写入 double 的数组
offset - 要写入的第一个 double 在数组中的偏移量；必须为非负且不大于 dst.length
length - 要写入给定数组中的 double 的最大数量；必须为非负且不大于 dst.length - offset
返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余 double 少于 length
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

get

public DoubleBuffer get(double[] dst)
相对批量 get 方法。

此方法将此缓冲区的 double 传输到给定的目标数组中。对此方法的调用形式为 src.get(a)，该调用与以下调用完全相同：

     src.get(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余 double 少于 length

put

public DoubleBuffer put(DoubleBuffer src)
相对批量 put 方法（可选操作）。

此方法将给定源缓冲区中的剩余 double 传输到此缓冲区中。如果源缓冲区中的剩余 double 多于此缓冲区中的剩余 double 空间，即 src.remaining() > remaining()，则不传输 double 且抛出 BufferOverflowException。

否则，此方法将给定缓冲区中的 n = src.remaining() 个 double 复制到此缓冲区中，从每个缓冲区的当前位置开始复制。然后这两个缓冲区的位置均递增 n。

换句话说，调用此方法的形式为 dst.put(src)，效果与以下循环语句完全相同：

     while (src.hasRemaining())
         dst.put(src.get());
区别在于它首先检查此缓冲区中是否具有足够的空间，这样可能效率更高。

参数：
src - 要从中读取 double 的源缓冲区；不能为此缓冲区
返回：
此缓冲区
抛出：
BufferOverflowException - 如果对于源缓冲区中剩余的 double，此缓冲区没有足够空间
IllegalArgumentException - 如果源缓冲区为此缓冲区
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public DoubleBuffer put(double[] src,
                        int offset,
                        int length)
相对批量 put 方法（可选操作）。

此方法将给定源数组中的 double 传输到此缓冲区中。如果要从数组复制的 double 多于此缓冲区中的剩余 double，即如果 length > remaining()，则不传输 double 且抛出 BufferOverflowException。

否则，此方法将给定数组中的 length 个 double 复制到此缓冲区中，从数组中给定偏移量位置和此缓冲区的当前位置开始复制。然后此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 dst.put(src, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst.put(a[i]);
区别在于它首先检查此缓冲区中是否具有足够的空间，这样可能效率更高。

参数：
src - 要从中读取 double 的数组
offset - 要读取的第一个 double 在数组中的偏移量；必须为非负且不大于 array.length
length - 要从给定数组读取的 double 数量；必须为非负且不大于 array.length - offset
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public final DoubleBuffer put(double[] src)
相对批量 put 方法（可选操作）。

此方法将给定源 double 数组中的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(a)，该调用与以下调用完全相同：

     dst.put(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读的

hasArray

public final boolean hasArray()
判断是否可通过一个可访问的 double 数组实现此缓冲区。

如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

指定者：
类 Buffer 中的 hasArray
返回：
当且仅当存在实现此缓冲区的数组，并且此缓冲区不是只读缓冲区时，返回 true

array

public final double[] array()
返回实现此缓冲区的 double 数组（可选操作）。

此缓冲区的内容修改将导致返回的数组内容修改，反之亦然。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 array
返回：
实现此缓冲区的数组
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

arrayOffset

public final int arrayOffset()
返回此缓冲区中的第一个 double 元素在缓冲区的底层实现数组中的偏移量（可选操作）。

如果存在实现此缓冲区的数组，则缓冲区位置 p 对应于数组索引 p + arrayOffset()。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 arrayOffset
返回：
此缓冲区的第一个元素在缓冲区数组中的偏移量
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

compact

public abstract DoubleBuffer compact()
压缩此缓冲区（可选操作）。

将缓冲区当前位置和界限之间的 double（如果有）复制到缓冲区的开始处。即将索引 p = position() 处的 double 复制到索引 0 处，将索引 p + 1 处的 MinimalHTMLWriter.htm.ttx 复制到索引 1 处，依此类推，直到将索引 limit() - 1 处的 double 复制到索引 n = limit() - 1 - p 处。然后将缓冲区的位置设置为 n+1，并将其界限设置为其容量。如果已定义了标记，则丢弃它。

将缓冲区的位置设置为复制的 double 的数量，而不是零，以便调用此方法后可以紧接着调用另一个相对 put 方法。

返回：
此缓冲区
抛出：
ReadOnlyBufferException - 如果此缓冲区是只读的

isDirect

public abstract boolean isDirect()
判断此 double 缓冲区是否为直接的。

指定者：
类 Buffer 中的 isDirect
返回：
当且仅当此缓冲区为直接时，返回 true

toString

public String toString()
返回总结了此缓冲区状态的字符串。

覆盖：
类 Object 中的 toString
返回：
一个总结字符串

hashCode

public int hashCode()
返回此缓冲区的当前哈希码。

double 缓冲区的哈希码只取决于其剩余元素；即取决于从 position() 开始一直到（包括）limit() - 1 处的元素。

因为缓冲区哈希码与内容有关，因此建议不要在哈希映射或类似数据结构中将缓冲区用作键，除非知道它们的内容不会发生更改。

覆盖：
类 Object 中的 hashCode
返回：
此缓冲区的当前哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object ob)
判断此缓冲区是否与另一个对象相同。

两个 double 缓冲区是相同的，当且仅当：

  1. 它们具有相同的元素类型，

  2. 它们具有相同数量的剩余元素，并且

  3. 两个剩余元素序列（与它们的起始位置无关）逐点相同。

double 缓冲区与任何其他类型的对象都不同的。

覆盖：
类 Object 中的 equals
参数：
ob - 此缓冲区要比较的对象
返回：
当且仅当此缓冲区与给定对象相同时，返回 true
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(DoubleBuffer that)
将此缓冲区与另一个缓冲区进行比较。

比较两个 double 缓冲区的方法是按字典顺序比较它们的剩余元素序列，而不考虑每个序列在其对应缓冲区中的起始位置。

double 缓冲区不能与任何其他类型的对象进行比较。

指定者：
接口 Comparable<DoubleBuffer> 中的 compareTo
参数：
that - 要比较的对象。
返回：
如果此缓冲区小于、等于或大于给定缓冲区，则相应返回负整数、零或正整数

order

public abstract ByteOrder order()
获取此缓冲区的字节顺序。

通过分配或通过包装现有 double 数组而创建的 double 缓冲区的字节顺序是底层硬件的本机顺序。作为字节缓冲区的视图而创建的 double 缓冲区的字节顺序是创建视图时字节缓冲区的字节顺序。

返回：
此缓冲区的字节顺序
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FloatBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 FloatBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.FloatBuffer
所有已实现的接口：
Comparable<FloatBuffer>
public abstract class FloatBuffer
extends Buffer
implements Comparable<FloatBuffer>

float 缓冲区。

此类定义了 float 缓冲区上的四类操作：

  • 读写单个 float 的绝对和相对 get 和 put 方法；

  • 将此缓冲区中的连续 float 序列传输到数组中的相对批量 get 方法；

  • 将 float 数组或其他 float 缓冲区中的连续 float 序列传输到此缓冲区的相对批量 put 方法；以及

  • float 缓冲区的 compacting、duplicating 和 slicing 方法。

float 缓冲区可以通过 allocation 创建，此方法通过 wrapping 将一个现有 float 数组包装到缓冲区中来为缓冲区内容分配空间,或者通过创建现有字节缓冲区的视图来创建

像字节缓冲区一样，float 缓冲区要么是直接的，要么是非直接的。通过此类的 wrap 方法创建的 float 缓冲区将是非直接的。当且仅当字节缓冲区本身为直接时，作为字节缓冲区的视图创建的 float 缓冲区才是直接的。通过调用 isDirect 方法可以确定 float 缓冲区是否为直接的。

指定此类中的方法（它们不返回其他值）以返回这些方法被调用时所在的缓冲区。这允许对方法调用进行链接。

从以下版本开始：
1.4

方法摘要
static FloatBuffer | allocate(int capacity) 分配新的 float 缓冲区。
float[] | array() 返回实现此缓冲区的 float 数组（可选操作）。
int | arrayOffset() 返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
abstract FloatBuffer | asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 float 缓冲区。
abstract FloatBuffer | compact() 压缩此缓冲区（可选操作）。
int | compareTo(FloatBuffer that) 将此缓冲区与另一个缓冲区进行比较。
abstract FloatBuffer | duplicate() 创建共享此缓冲区内容的新的 float 缓冲区。
boolean | equals(Object ob) 判断此缓冲区是否与另一个对象相同。
abstract float | get() 相对 get 方法。
FloatBuffer | get(float[] dst) 相对批量 get 方法。
FloatBuffer | get(float[] dst, int offset, int length) 相对批量 get 方法。
abstract float | get(int index) 绝对 get 方法。
boolean | hasArray() 判断是否可通过一个可访问的 float 数组实现此缓冲区。
int | hashCode() 返回此缓冲区的哈希码。
abstract boolean | isDirect() 判断此 float 缓冲区是否为直接的。
abstract ByteOrder | order() 获取此缓冲区的字节顺序。
abstract FloatBuffer | put(float f) 相对 put 方法（可选操作）。
FloatBuffer | put(float[] src) 相对批量 put 方法（可选操作）。
FloatBuffer | put(float[] src, int offset, int length) 相对批量 put 方法（可选操作）。
FloatBuffer | put(FloatBuffer src) 相对批量 put 方法（可选操作）。
abstract FloatBuffer | put(int index, float f) 绝对 put 方法（可选操作）。
abstract FloatBuffer | slice() 创建新的 float 缓冲区，其内容是此缓冲区内容的共享子序列。
String | toString() 返回总结了此缓冲区状态的字符串。
static FloatBuffer | wrap(float[] array) 将 float 数组包装到缓冲区中。
static FloatBuffer | wrap(float[] array, int offset, int length) 将 float 数组包装到缓冲区中。
从类 java.nio.Buffer 继承的方法
capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

allocate

public static FloatBuffer allocate(int capacity)
分配新的 float 缓冲区。

新缓冲区的位置将为零，其界限将为其容量，其标记是未定义的。它将具有一个底层实现数组，且其数组偏移量将为零。

参数：
capacity - 新缓冲区的容量，以 float 为单位
返回：
新的 float 缓冲区
抛出：
IllegalArgumentException - 如果 capacity 为负整数

wrap

public static FloatBuffer wrap(float[] array,
                               int offset,
                               int length)
将 float 数组包装到缓冲区中。

给定 float 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量将为 array.length，其位置将为 offset，其界限将为 offset + length，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 支持新缓冲区的数组
offset - 要使用的子数组的偏移量；必须为非负且不大于 array.length。将新缓冲区的位置设置为此值。
length - 要使用的子数组的长度；必须为非负且不大于 array.length - offset。将新缓冲区的界限设置为 offset + length。
返回：
新的 float 缓冲区
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

wrap

public static FloatBuffer wrap(float[] array)
将 float 数组包装到缓冲区中。

给定 float 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量和界限将为 array.length，其位置将为零，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 实现此缓冲区的数组
返回：
新的 float 缓冲区

slice

public abstract FloatBuffer slice()
创建新的 float 缓冲区，其内容是此缓冲区内容的共享子序列。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的 float 数量，其标记是未定义的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 float 缓冲区

duplicate

public abstract FloatBuffer duplicate()
创建共享此缓冲区内容的新的 float 缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 float 缓冲区

asReadOnlyBuffer

public abstract FloatBuffer asReadOnlyBuffer()
创建共享此缓冲区内容的新的只读 float 缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区的更改在新缓冲区中是可见的，但新缓冲区将是只读的并且不允许修改共享内容。两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。

如果此缓冲区本身是只读的，则此方法与 duplicate 方法完全相同。

返回：
新的只读 float 缓冲区

get

public abstract float get()
相对 get 方法。读取此缓冲区当前位置的 float，然后该位置递增。

返回：
缓冲区当前位置的 float
抛出：
BufferUnderflowException - 如果缓冲区当前位置不小于其界限

put

public abstract FloatBuffer put(float f)
相对 put 方法（可选操作）。

将给定 float 写入此缓冲区的当前位置，然后该位置递增。

参数：
f - 要写入的 float
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区的当前位置不小于界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public abstract float get(int index)
绝对 get 方法。读取给定位置处的 float。

参数：
index - 将读取 float 的位置的索引
返回：
给定索引处的 float
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限

put

public abstract FloatBuffer put(int index,
                                float f)
绝对 put 方法（可选操作）。

将给定 float 写入此缓冲区的给定索引处。

参数：
index - 将在该位置写入 float
f - 要写入的 float 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public FloatBuffer get(float[] dst,
                       int offset,
                       int length)
相对批量 get 方法。

此方法将此缓冲区的 float 传输到给定的目标数组中。如果缓冲区中剩余的 float 少于满足请求所需的 float，即如果 length > remaining()，则不传输 float 且抛出 BufferUnderflowException。

否则，此方法此缓冲区中的 length 个 float 复制到给定数组中，从此缓冲区的当前位置和数组中的给定偏移量位置开始复制。然后此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 src.get(dst, off, len)，该调用与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst[i] = src.get();
区别在于它首先检查此缓冲区中是否具有足够的 float，这样可能效率更高。

参数：
dst - 写入 float 的数组
offset - 要写入的第一个 float 在数组中的偏移量；必须为非负且不大于 dst.length
length - 要写入给定数组中的 float 的最大数量；必须为非负且不大于 dst.length - offset
返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余 float 少于 length
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

get

public FloatBuffer get(float[] dst)
相对批量 get 方法。

此方法将此缓冲区的 float 传输到给定的目标数组中。调用此方法的形式为 src.get(a)，该调用与以下调用完全相同：

     src.get(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余 float 少于 length

put

public FloatBuffer put(FloatBuffer src)
相对批量 put 方法（可选操作）。

此方法将给定源缓冲区中的剩余 float 传输到此缓冲区中。如果源缓冲区中的剩余 float 多于此缓冲区中的剩余 float 空间，即 src.remaining() > remaining()，则不传输 float 且抛出 BufferOverflowException。

否则，此方法将给定缓冲区中的 n = src.remaining() 个 float 复制到此缓冲区中，从每个缓冲区的当前位置开始复制。然后这两个缓冲区的位置均递增 n。

换句话说，调用此方法的形式为 dst.put(src)，效果与以下循环语句完全相同：

     while (src.hasRemaining())
         dst.put(src.get());
区别在于它首先检查此缓冲区中是否具有足够的空间，这样可能效率更高。

参数：
src - 要从中读取 float 的源缓冲区；不能为此缓冲区
返回：
此缓冲区
抛出：
BufferOverflowException - 如果对于源缓冲区中剩余的 float，此缓冲区没有足够空间
IllegalArgumentException - 如果源缓冲区是此缓冲区
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public FloatBuffer put(float[] src,
                       int offset,
                       int length)
相对批量 put 方法（可选操作）。

此方法将给定源数组中的 float 传输此缓冲区中。如果要从数组复制的 float 多于此缓冲区中的剩余 float 空间，即如果 length > remaining()，则不传输 float 且抛出 BufferOverflowException。

否则，此方法将给定数组中的 length 个 float 复制到此缓冲区中，从数组中给定偏移量位置和此缓冲区的当前位置开始复制。然后此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 dst.put(src, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst.put(a[i]);
区别在于它首先检查此缓冲区中是否具有足够的空间，这样可能效率更高。

参数：
src - 要从中读取 float 的数组
offset - 要读取的第一个 float 在数组中的偏移量；必须为非负且不大于 array.length
length - 要从给定数组读取的 float 数量；必须为非负且不大于 array.length - offset
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public final FloatBuffer put(float[] src)
相对批量 put 方法（可选操作）。

此方法将给定源 float 数组中的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(a)，该调用与以下调用完全相同：

     dst.put(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读的

hasArray

public final boolean hasArray()
判断是否可通过一个可访问的 float 数组实现此缓冲区。

如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

指定者：
类 Buffer 中的 hasArray
返回：
当且仅当存在实现此缓冲区的数组，并且此缓冲区不是只读缓冲区时，返回 true

array

public final float[] array()
返回实现此缓冲区的 float 数组（可选操作）。

此缓冲区的内容修改将导致返回的数组内容修改，反之亦然。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 array
返回：
实现此缓冲区的数组
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

arrayOffset

public final int arrayOffset()
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。

如果存在实现此缓冲区的数组，则缓冲区位置 p 对应于数组索引 p + arrayOffset()。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 arrayOffset
返回：
此缓冲区的第一个元素在缓冲区数组中的偏移量
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

compact

public abstract FloatBuffer compact()
压缩此缓冲区（可选操作）。

将缓冲区当前位置和界限之间的 float（如果有）复制到缓冲区的开始处。即将索引 p = position() 处的 float 复制到索引 0 处，将索引 p + 1 处的 float 复制到索引 1 处，依此类推，直到将索引 limit() - 1 处的 float 复制到索引 n = limit() - 1 - p 处。然后将缓冲区的位置设置为 n+1，并将其界限设置为其容量。如果已定义了标记，则丢弃它。

将缓冲区的位置设置为复制的 float 的数量，而不是零，以便调用此方法后可以紧接着调用另一个相对 put 方法。

返回：
此缓冲区
抛出：
ReadOnlyBufferException - 如果此缓冲区是只读的

isDirect

public abstract boolean isDirect()
判断此 float 缓冲区是否为直接的。

指定者：
类 Buffer 中的 isDirect
返回：
当且仅当此缓冲区为直接时，返回 true

toString

public String toString()
返回总结了此缓冲区状态的字符串。

覆盖：
类 Object 中的 toString
返回：
一个总结字符串

hashCode

public int hashCode()
返回此缓冲区的哈希码。

float 缓冲区的哈希码只取决于其剩余元素；即取决于从 position() 开始一直到（包括） limit() - 1 处的元素。

因为缓冲区哈希码与内容有关，因此建议不要在哈希映射或类似数据结构中将缓冲区用作键，除非知道它们的内容不会发生更改。

覆盖：
类 Object 中的 hashCode
返回：
此缓冲区的当前哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object ob)
判断此缓冲区是否与另一个对象相同。

两个 float 缓冲区是相同的，当且仅当：

  1. 它们具有相同的元素类型，

  2. 它们具有相同数量的剩余元素，并且

  3. 两个剩余元素序列（与它们的起始位置无关）逐点相同。

float 缓冲区与任何其他类型的对象都不同。

覆盖：
类 Object 中的 equals
参数：
ob - 此缓冲区要比较的对象
返回：
当且仅当此缓冲区与给定对象相同时，返回 true
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(FloatBuffer that)
将此缓冲区与另一个缓冲区进行比较。

比较两个 float 缓冲区的方法是按字典顺序比较它们的剩余元素序列，而不考虑每个序列在其对应缓冲区中的起始位置。

float 缓冲区不能与任何其他类型的对象进行比较。

指定者：
接口 Comparable<FloatBuffer> 中的 compareTo
参数：
that - 要比较的对象。
返回：
如果此缓冲区小于、等于或大于给定缓冲区，则相应返回负整数、零或正整数

order

public abstract ByteOrder order()
获取此缓冲区的字节顺序。

通过分配或通过包装现有 float 型数组而创建的 float 缓冲区的字节顺序是底层硬件的本机顺序。作为字节缓冲区的视图而创建的 float 缓冲区的字节顺序是创建视图时字节缓冲区的字节顺序。

返回：
此缓冲区的字节顺序
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IntBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 IntBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.IntBuffer
所有已实现的接口：
Comparable<IntBuffer>
public abstract class IntBuffer
extends Buffer
implements Comparable<IntBuffer>

int 缓冲区。

此类定义了 int 缓冲区上的四类操作：

  • 读写单个 int 的绝对和相对 get 和 put 方法。

  • 将此缓冲区的连续 int 序列传输到数组中的相对批量 get 方法；

  • 将 int 数组或其他 int 缓冲区中的连续 int 序列传输到此缓冲区的相对批量 put 方法；以及

  • int 缓冲区的 compacting、duplicating 和 #sliceslicing 方法。

int 缓冲区可以通过 allocation 创建，此方法通过 wrapping 将一个现有 int 数组包装到缓冲区中来为缓冲区内容分配空间，或者通过创建现有字节缓冲区的视图 来创建

像字节缓冲区一样，int 缓冲区要么是直接的，要么是非直接的。通过此类的 wrap 方法创建的 int 缓冲区将是非直接的。当且仅当字节缓冲区本身为直接时，作为字节缓冲区的视图创建的 int 缓冲区才是直接的。通过调用 isDirect 方法可以确定 int 缓冲区是否为直接的。

指定此类中的方法（它们不返回其他值），以返回这些方法被调用时所在的缓冲区。这允许对方法调用进行链接。

从以下版本开始：
1.4

方法摘要
static IntBuffer | allocate(int capacity) 分配新的 int 缓冲区。
int[] | array() 返回实现此缓冲区的 int 数组（可选操作）。
int | arrayOffset() 返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
abstract IntBuffer | asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 int 缓冲区。
abstract IntBuffer | compact() 压缩此缓冲区（可选操作）。
int | compareTo(IntBuffer that) 将此缓冲区与另一个缓冲区进行比较。
abstract IntBuffer | duplicate() 创建共享此缓冲区内容的新的 int 缓冲区。
boolean | equals(Object ob) 判断此缓冲区是否与另一个对象相同。
abstract int | get() 相对 get 方法。
abstract int | get(int index) 绝对 get 方法。
IntBuffer | get(int[] dst) 相对批量 get 方法。
IntBuffer | get(int[] dst, int offset, int length) 相对批量 get 方法。
boolean | hasArray() 判断是否可通过一个可访问的 int 数组实现此缓冲区。
int | hashCode() 返回此缓冲区的当前哈希码。
abstract boolean | isDirect() 判断此 int 缓冲区是否为直接的。
abstract ByteOrder | order() 获取此缓冲区的字节顺序。
abstract IntBuffer | put(int i) 相对 put 方法（可选操作）。
IntBuffer | put(int[] src) 相对批量 put 方法（可选操作）。
IntBuffer | put(int[] src, int offset, int length) 相对批量 put 方法（可选操作）。
IntBuffer | put(IntBuffer src) 相对批量 put 方法（可选操作）。
abstract IntBuffer | put(int index, int i) 绝对 put 方法（可选操作）。
abstract IntBuffer | slice() 创建新的 int 数组，其内容是此缓冲区内容的共享子序列。
String | toString() 返回总结了此缓冲区状态的字符串。
static IntBuffer | wrap(int[] array) 将 int 数组包装到缓冲区中。
static IntBuffer | wrap(int[] array, int offset, int length) 将 int 数组包装到缓冲区中。
从类 java.nio.Buffer 继承的方法
capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

allocate

public static IntBuffer allocate(int capacity)
分配新的 int 缓冲区。

新缓冲区的位置将为零，其界限将为其容量，其标记是未定义的。它将具有一个底层实现数组，且其数组偏移量将为零。

参数：
capacity - 新缓冲区的容量，以 int 为单位
返回：
新的 int 缓冲区
抛出：
IllegalArgumentException - 如果 capacity 为负整数

wrap

public static IntBuffer wrap(int[] array,
                             int offset,
                             int length)
将 int 数组包装到缓冲区中。

给定 int 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量将为 array.length，其位置将为 offset，其界限将为 offset + length，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 支持新缓冲区的数组
offset - 要使用的子数组的偏移量；必须为非负且不大于 array.length。将新缓冲区的位置设置为此值。
length - 要使用的子数组的长度；必须为非负且不大于 array.length - offset。将新缓冲区的界限设置为 offset + length。
返回：
新的 int 缓冲区
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

wrap

public static IntBuffer wrap(int[] array)
将 int 数组包装到缓冲区中。

给定 int 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量和界限将为 array.length，其位置将为零，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

参数：
array - 实现此缓冲区的数组
返回：
新的 int 缓冲区

slice

public abstract IntBuffer slice()
创建新的 int 数组，其内容是此缓冲区内容的共享子序列。

新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的 int 数量，其标记是未定义的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 int 缓冲区

duplicate

public abstract IntBuffer duplicate()
创建共享此缓冲区内容的新的 int 缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

返回：
新的 int 缓冲区

asReadOnlyBuffer

public abstract IntBuffer asReadOnlyBuffer()
创建共享此缓冲区内容的新的只读 int 缓冲区。

新缓冲区的内容将为此缓冲区的内容。此缓冲区的更改在新缓冲区中是可见的，但新缓冲区将是只读的并且不允许修改共享内容。两个缓冲区的位置、界限和标记值是相互独立的。

新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。

如果此缓冲区本身是只读的，则此方法与 duplicate 方法完全相同。

返回：
新的只读 int 缓冲区

get

public abstract int get()
相对 get 方法。读取此缓冲区当前位置的 int，然后该位置递增。

返回：
缓冲区当前位置的 int
抛出：
BufferUnderflowException - 如果缓冲区当前位置不小于其界限

put

public abstract IntBuffer put(int i)
相对 put 方法（可选操作）。

将给定 int 写入此缓冲区的当前位置，然后该位置递增。

参数：
i - 要写入的 int
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区的当前位置不小于界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public abstract int get(int index)
绝对 get 方法。读取给定索引处的 int。

参数：
index - 将从中读取 int 的索引
返回：
给定索引处的 int
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限

put

public abstract IntBuffer put(int index,
                              int i)
绝对 put 方法（可选操作）。

将给定 int 写入此缓冲区的给定索引处。

参数：
index - int 将被写入位置的索引
i - 要写入的 int 值
返回：
此缓冲区
抛出：
IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限
ReadOnlyBufferException - 如果此缓冲区是只读的

get

public IntBuffer get(int[] dst,
                     int offset,
                     int length)
相对批量 get 方法。

此方法将此缓冲区的 int 传输到给定的目标数组中。如果缓冲区中剩余的 int 少于满足请求所需的 int，即如果 length > remaining()，则不传输 int 且抛出 BufferUnderflowException。

否则，此方法此缓冲区中的 length 个 int 复制到给定数组中，从此缓冲区的当前位置和数组中的给定偏移量位置开始复制。然后此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 src.get(dst, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst[i] = src.get();
区别在于它首先检查此缓冲区中是否具有足够的 int，这样可能效率更高。

参数：
dst - 写入 int 的数组
offset - 要写入的第一个 int 在数组中的偏移量；必须为非负且不大于 dst.length
length - 要写入给定数组中的 int 的最大数量；必须为非负且不大于 dst.length - offset
返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余 int 少于 length
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

get

public IntBuffer get(int[] dst)
相对批量 get 方法。

此方法将此缓冲区的 int 传输到给定的目标数组中。调用此方法的形式为 src.get(a)，该调用与以下调用完全相同：

     src.get(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferUnderflowException - 如果此缓冲区中的剩余 int 少于 length

put

public IntBuffer put(IntBuffer src)
相对批量 put 方法（可选操作）。

此方法将给定源缓冲区中的剩余 int 传输到此缓冲区中。如果源缓冲区中的剩余 int 多于此缓冲区中的剩余 int 空间，即 src.remaining() > remaining()，则不传输 int 且抛出 BufferOverflowException。

否则，此方法将给定缓冲区中的 n = src.remaining() 个 int 复制到此缓冲区中，从每个缓冲区的当前位置开始复制。然后这两个缓冲区的位置均递增 n。

换句话说，调用此方法的形式为 dst.put(src)，效果与以下循环语句完全相同：

     while (src.hasRemaining())
         dst.put(src.get());
区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

参数：
src - 要从中读取 int 的源缓冲区；不能为此缓冲区
返回：
此缓冲区
抛出：
BufferOverflowException - 如果对于源缓冲区中剩余的 int，此缓冲区没有足够空间
IllegalArgumentException - 如果源缓冲区是此缓冲区
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public IntBuffer put(int[] src,
                     int offset,
                     int length)
相对批量 put 方法（可选操作）。

此方法将给定源数组中的 int 传输到此缓冲区中。如果要从数组复制的 int 多于此缓冲区中的剩余空间，即如果 length > remaining()，则不传输 int 且抛出 BufferOverflowException。

否则，此方法将给定数组中的 length 个 int 复制到此缓冲区中，从数组中给定偏移量位置和此缓冲区的当前位置开始复制。然后此缓冲区的位置递增 length。

换句话说，调用此方法的形式为 dst.put(src, off, len)，效果与以下循环语句完全相同：

     for (int i = off; i < off + len; i++)
         dst.put(a[i]);
区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

参数：
src - 要从中读取 int 的数组
offset - 要读取的第一个 int 在数组中的偏移量；必须为非负且不大于 array.length
length - 要从给定数组读取的 int 数量；必须为非负且不大于 array.length - offset
返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
ReadOnlyBufferException - 如果此缓冲区是只读的

put

public final IntBuffer put(int[] src)
相对批量 put 方法（可选操作）。

此方法将给定源 int 数组中的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(a)，行为与以下调用完全相同：

     dst.put(a, 0, a.length)

返回：
此缓冲区
抛出：
BufferOverflowException - 如果此缓冲区没有足够空间
ReadOnlyBufferException - 如果此缓冲区是只读的

hasArray

public final boolean hasArray()
判断是否可通过一个可访问的 int 数组实现此缓冲区。

如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

指定者：
类 Buffer 中的 hasArray
返回：
当且仅当存在实现此缓冲区的数组，并且此缓冲区不是只读缓冲区时，返回 true

array

public final int[] array()
返回实现此缓冲区的 int 数组（可选操作）。

此缓冲区的内容修改将导致返回的数组内容修改，反之亦然。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 array
返回：
实现此缓冲区的数组
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

arrayOffset

public final int arrayOffset()
返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。

如果存在实现此缓冲区的数组，则缓冲区位置 p 对应于数组索引 p + arrayOffset()。

调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

指定者：
类 Buffer 中的 arrayOffset
返回：
此缓冲区的第一个元素在缓冲区数组中的偏移量
抛出：
ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

compact

public abstract IntBuffer compact()
压缩此缓冲区（可选操作）。

将缓冲区当前位置和界限之间的 int（如果有）复制到缓冲区的开始处。即将索引 p = position() 处的 int 复制到索引 0 处，将索引 p + 1 处的 int 复制到索引 1 处，依此类推，直到将索引 limit() - 1 处的 int 复制到索引 n = limit() - 1 - p 处。然后将缓冲区的位置设置为 n+1，并将其界限设置为其容量。如果已定义了标记，则丢弃它。

将缓冲区的位置设置为复制的 int 的 数量，而不是零，以便调用此方法后可以紧接着调用另一个相对 put 方法。

返回：
此缓冲区
抛出：
ReadOnlyBufferException - 如果此缓冲区是只读的

isDirect

public abstract boolean isDirect()
判断此 int 缓冲区是否为直接的。

指定者：
类 Buffer 中的 isDirect
返回：
当且仅当此缓冲区为直接时，返回 true

toString

public String toString()
返回总结了此缓冲区状态的字符串。

覆盖：
类 Object 中的 toString
返回：
一个总结字符串

hashCode

public int hashCode()
返回此缓冲区的当前哈希码。

int 缓冲区的哈希码只取决于其剩余元素；即取决于从 position() 开始一直到（包括） limit() - 1 处的元素。

因为缓冲区哈希码与内容有关，因此建议不要在哈希映射或类似数据结构中将缓冲区用作键，除非知道它们的内容不会发生更改。

覆盖：
类 Object 中的 hashCode
返回：
此缓冲区的当前哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object ob)
判断此缓冲区是否与另一个对象相同。

两个 int 缓冲区是相同的，当且仅当：

  1. 它们具有相同的元素类型，

  2. 它们具有相同数量的剩余元素，并且

  3. 两个剩余元素序列（与它们的起始位置无关）逐点相同。

int 缓冲区与任何其他类型的对象都不同。

覆盖：
类 Object 中的 equals
参数：
ob - 此缓冲区要比较的对象
返回：
当且仅当此缓冲区与给定对象相同时，返回 true
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(IntBuffer that)
将此缓冲区与另一个缓冲区进行比较。

比较两个 int 缓冲区的方法是按字典顺序比较它们的剩余元素序列，而不考虑每个序列在其对应缓冲区中的起始位置。

int 缓冲区不能与任何其他类型的对象进行比较

指定者：
接口 Comparable<IntBuffer> 中的 compareTo
参数：
that - 要比较的对象。
返回：
如果此缓冲区小于、等于或大于给定缓冲区，则相应返回负整数、零或正整数

order

public abstract ByteOrder order()
获取此缓冲区的字节顺序。

通过分配或通过包装现有 int 数组而创建的 int 缓冲区的字节顺序是底层硬件的本机顺序。作为字节缓冲区的视图而创建的 int 缓冲区的字节顺序是创建视图时字节缓冲区的字节顺序。

返回：
此缓冲区的字节顺序
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidMarkException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 InvalidMarkException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.InvalidMarkException
所有已实现的接口：
Serializable
public class InvalidMarkException
extends IllegalStateException

当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
InvalidMarkException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidMarkException

public InvalidMarkException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LongBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 LongBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.LongBuffer
所有已实现的接口：
Comparable<LongBuffer>
public abstract class LongBuffer
extends Buffer
implements Comparable<LongBuffer>

long 缓冲区。

此类定义了 long 缓冲区上的四类操作：

  • 读写单个 long 的绝对和相对 get 和 put 方法；

  • 将此缓冲区的连续 long 序列传输到数组中的相对批量 get 方法；

  • 将 long 数组或其他 long 缓冲区中的连续 long 序列传输到此缓冲区的相对批量 put 方法；以及

  • long 缓冲区的 compacting、duplicating 和 slicing 方法。

    • long 缓冲区可以通过 allocation 创建，此方法通过 wrapping 将一个现有 long 数组包装到缓冲区中来为缓冲区内容分配空间，或者通过创建现有字节缓冲区的视图 来创建。

    像字节缓冲区一样，long 缓冲区要么是直接的，要么是非直接的。通过此类的 wrap 方法创建的 long 缓冲区将是非直接的。当且仅当字节缓冲区本身为直接时，作为字节缓冲区的视图创建的 long 缓冲区才是直接的。通过调用 isDirect 方法可以确定 long 缓冲区是否为直接的。

    指定此类中的方法（它们不返回其他值），以返回这些方法被调用时所在的缓冲区。这允许对方法调用进行链接。

    从以下版本开始：
    1.4

    方法摘要
static LongBuffer | allocate(int capacity) 分配新的 long 缓冲区。
long[] | array() 返回实现此缓冲区的 long 数组（可选操作）。
int | arrayOffset() 返回此缓冲区中第一个元素在缓冲区的支持数组中的偏移量（可选操作）。
abstract LongBuffer | asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 long 缓冲区。
abstract LongBuffer | compact() 压缩此缓冲区（可选操作）。
int | compareTo(LongBuffer that) 将此缓冲区与另一个缓冲区进行比较。
abstract LongBuffer | duplicate() 创建共享此缓冲区内容的新的 long 缓冲区。
boolean | equals(Object ob) 判断此缓冲区是否与另一个对象相同。
abstract long | get() 相对 get 方法。
abstract long | get(int index) 绝对 get 方法。
LongBuffer | get(long[] dst) 相对批量 get 方法。
LongBuffer | get(long[] dst, int offset, int length) 相对批量 get 方法。
boolean | hasArray() 判断是否可通过一个可访问的 long 数组实现此缓冲区。
int | hashCode() 返回此缓冲区的当前哈希码。
abstract boolean | isDirect() 判断此 long 缓冲区是否为直接的。
abstract ByteOrder | order() 获取此缓冲区的字节顺序。
abstract LongBuffer | put(int index, long l) 绝对 put 方法（可选操作）。
abstract LongBuffer | put(long l) 相对 put 方法（可选操作）。
LongBuffer | put(long[] src) 相对批量 put 方法（可选操作）。
LongBuffer | put(long[] src, int offset, int length) 相对批量 put 方法（可选操作）。
LongBuffer | put(LongBuffer src) 相对批量 put 方法（可选操作）。
abstract LongBuffer | slice() 创建新的 long 缓冲区，其内容是此缓冲区内容的共享子序列。
String | toString() 返回总结了此缓冲区状态的字符串。
static LongBuffer | wrap(long[] array) 将 long 数组包装到缓冲区中。
static LongBuffer | wrap(long[] array, int offset, int length) 将 long 数组包装到缓冲区中。
    从类 java.nio.Buffer 继承的方法
    capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
    从类 java.lang.Object 继承的方法
    clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    方法详细信息

    allocate

    public static LongBuffer allocate(int capacity)
    分配新的 long 缓冲区。

    新缓冲区的位置将为零，其界限将为其容量，其标记是未定义的。它将具有一个底层实现数组，且其数组偏移量将为零。

    参数：
    capacity - 新缓冲区的容量，以 long 为单位
    返回：
    新的 long 缓冲区
    抛出：
    IllegalArgumentException - 如果 capacity 为负整数

    wrap

    public static LongBuffer wrap(long[] array,
                              int offset,
                              int length)
    将 long 数组包装到缓冲区中。

    给定 long 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量将为 array.length，其位置将为 offset，其界限将为 offset + length，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

    参数：
    array - 支持新缓冲区的数组
    offset - 要使用的子数组的偏移量；必须为非负且不大于 array.length。将新缓冲区的位置设置为此值。
    length - 要使用的子数组的长度；必须为非负且不大于 array.length - offset。将新缓冲区的界限设置为 offset + length。
    返回：
    新的 long 缓冲区
    抛出：
    IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

    wrap

    public static LongBuffer wrap(long[] array)
    将 long 数组包装到缓冲区中。

    给定 long 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量和界限将为 array.length，其位置将为零，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

    参数：
    array - 实现此缓冲区的数组
    返回：
    新的 long 缓冲区

    slice

    public abstract LongBuffer slice()
    创建新的 long 缓冲区，其内容是此缓冲区内容的共享子序列。

    新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

    新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的 long 数量，其标记是未定义的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

    返回：
    新的 long 缓冲区

    duplicate

    public abstract LongBuffer duplicate()
    创建共享此缓冲区内容的新的 long 缓冲区。

    新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

    新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

    返回：
    新的 long 缓冲区

    asReadOnlyBuffer

    public abstract LongBuffer asReadOnlyBuffer()
    创建共享此缓冲区内容的新的只读 long 缓冲区。

    新缓冲区的内容将为此缓冲区的内容。此缓冲区的更改在新缓冲区中是可见的，但新缓冲区将是只读的并且不允许修改共享内容。两个缓冲区的位置、界限和标记值是相互独立的。

    新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。

    如果此缓冲区本身是只读的，则此方法与 duplicate 方法完全相同。

    返回：
    新的只读 long 缓冲区

    get

    public abstract long get()
    相对 get 方法。读取此缓冲区当前位置的 long，然后该位置递增。

    返回：
    缓冲区当前位置的 long
    抛出：
    BufferUnderflowException - 如果缓冲区当前位置不小于其界限

    put

    public abstract LongBuffer put(long l)
    相对 put 方法（可选操作）。

    将给定 long 写入此缓冲区的当前位置，然后该位置递增。

    参数：
    l - 要写入的 long
    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果此缓冲区的当前位置不小于界限
    ReadOnlyBufferException - 如果此缓冲区是只读的

    get

    public abstract long get(int index)
    绝对 get 方法。读取给定索引处的 long。

    参数：
    index - 将读取 long 的位置的索引
    返回：
    给定索引处的 long
    抛出：
    IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限

    put

    public abstract LongBuffer put(int index,
                               long l)
    绝对 put 方法（可选操作）。

    将给定 long 写入此缓冲区的给定索引处。

    参数：
    index - 将在该位置写入 long
    l - 要写入的 long 值
    返回：
    此缓冲区
    抛出：
    IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限
    ReadOnlyBufferException - 如果此缓冲区是只读的

    get

    public LongBuffer get(long[] dst,
                      int offset,
                      int length)
    相对批量 get 方法。

    此方法将此缓冲区的 long 传输到给定的目标数组中。如果缓冲区中剩余的 long 少于满足请求所需的 long，即如果 length > remaining()，则不传输 long 且抛出 BufferUnderflowException。

    否则，此方法此缓冲区中的 length 个 long 复制到给定数组中，从此缓冲区的当前位置和数组中的给定偏移量位置开始复制。然后此缓冲区的位置递增 length。

    换句话说，调用此方法的形式为 src.get(dst, off, len)，效果与以下循环语句完全相同：

         for (int i = off; i < off + len; i++)
         dst[i] = src.get();
    区别在于它首先检查此缓冲区中是否具有足够的 long，这样可能效率更高。

    参数：
    dst - 将写入 long 的数组
    offset - 要写入的第一个 long 在数组中的偏移量；必须为非负且不大于 dst.length
    length - 要写入给定数组中的 long 的最大数量；必须为非负且不大于 dst.length - offset
    返回：
    此缓冲区
    抛出：
    BufferUnderflowException - 如果此缓冲区中的剩余 long 少于 length
    IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

    get

    public LongBuffer get(long[] dst)
    相对批量 get 方法。

    此方法将此缓冲区的 long 传输到给定的目标数组中。调用此方法的形式为 src.get(a)，该调用与以下调用完全相同：

         src.get(a, 0, a.length)

    返回：
    此缓冲区
    抛出：
    BufferUnderflowException - 如果此缓冲区中的剩余 long 少于 length

    put

    public LongBuffer put(LongBuffer src)
    相对批量 put 方法（可选操作）。

    此方法将给定源缓冲区中的剩余 long 传输到此缓冲区中。如果源缓冲区中的剩余 long 多于此缓冲区中的剩余 long 空间，即 src.remaining() > remaining()，则不传输 long 且抛出 BufferOverflowException。

    否则，此方法将给定缓冲区中的 n = src.remaining() 个 long 复制到此缓冲区中，从每个缓冲区的当前位置开始复制。然后这两个缓冲区的位置均递增 n。

    换句话说，调用此方法的形式为 dst.put(src)，效果与以下循环语句完全相同：

         while (src.hasRemaining())
         dst.put(src.get());
    区别在于它首先检查此缓冲区中是否具有足够的空间，这样可能效率更高。

    参数：
    src - 要从中读取 long 的源缓冲区；不能为此缓冲区
    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果对于源缓冲区中剩余的 long，此缓冲区没有足够空间
    IllegalArgumentException - 如果源缓冲区是此缓冲区
    ReadOnlyBufferException - 如果此缓冲区是只读的

    put

    public LongBuffer put(long[] src,
                      int offset,
                      int length)
    相对批量 put 方法（可选操作）。

    此方法将给定源数组中的 long 传输到此缓冲区中。如果要从数组复制的 long 多于此缓冲区中的剩余 long 空间，即如果 length > remaining()，则不传输 long 且抛出 BufferOverflowException。

    否则，此方法将给定数组中的 length 个 long 复制到此缓冲区中，从数组中给定偏移量位置和此缓冲区的当前位置开始复制。然后此缓冲区的位置递增 length。

    换句话说，调用此方法的形式为 dst.put(src, off, len)，效果与以下循环语句完全相同：

         for (int i = off; i < off + len; i++)
         dst.put(a[i]);
    区别在于它首先检查此缓冲区中是否具有足够的空间，这样可能效率更高。

    参数：
    src - 要从中读取 long 的数组
    offset - 要读取的第一个 long 在数组中的偏移量；必须为非负且不大于 array.length
    length - 要从给定数组读取的 long 数量；必须为非负且不大于 array.length - offset
    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果此缓冲区没有足够空间
    IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
    ReadOnlyBufferException - 如果此缓冲区是只读的

    put

    public final LongBuffer put(long[] src)
    相对批量 put 方法（可选操作）。

    此方法将给定源 long 数组中的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(a)，该调用与以下调用完全相同：

         dst.put(a, 0, a.length)

    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果此缓冲区没有足够空间
    ReadOnlyBufferException - 如果此缓冲区是只读的

    hasArray

    public final boolean hasArray()
    判断是否可通过一个可访问的 long 数组实现此缓冲区。

    如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

    指定者：
    类 Buffer 中的 hasArray
    返回：
    当且仅当存在实现此缓冲区的数组，并且此缓冲区不是只读缓冲区时，返回 true

    array

    public final long[] array()
    返回实现此缓冲区的 long 数组（可选操作）。

    此缓冲区的内容修改将导致返回的数组内容修改，反之亦然。

    调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

    指定者：
    类 Buffer 中的 array
    返回：
    实现此缓冲区的数组
    抛出：
    ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
    UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

    arrayOffset

    public final int arrayOffset()
    返回此缓冲区中第一个元素在缓冲区的支持数组中的偏移量（可选操作）。

    如果存在实现此缓冲区的数组，则缓冲区位置 p 对应于数组索引 p + arrayOffset()。

    调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

    指定者：
    类 Buffer 中的 arrayOffset
    返回：
    此缓冲区的第一个元素在缓冲区数组中的偏移量
    抛出：
    ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
    UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

    compact

    public abstract LongBuffer compact()
    压缩此缓冲区（可选操作）。

    将缓冲区当前位置和界限之间的 long（如果有）复制到缓冲区的开始处。即将索引 p = position() 处的 long 复制到索引 0 处，将索引 p + 1 处的 long 复制到索引 1 处，依此类推，直到将索引 limit() - 1 处的 long 复制到索引 n = limit() - 1 - p 处。然后将缓冲区的位置设置为 n+1，并将其界限设置为其容量。如果已定义了标记，则丢弃它。

    将缓冲区的位置设置为复制的 long 的数量，而不是零，以便调用此方法后可以紧接着调用另一个相对 put 方法。

    返回：
    此缓冲区
    抛出：
    ReadOnlyBufferException - 如果此缓冲区是只读的

    isDirect

    public abstract boolean isDirect()
    判断此 long 缓冲区是否为直接的。

    指定者：
    类 Buffer 中的 isDirect
    返回：
    当且仅当此缓冲区为直接时，返回 true

    toString

    public String toString()
    返回总结了此缓冲区状态的字符串。

    覆盖：
    类 Object 中的 toString
    返回：
    一个总结字符串

    hashCode

    public int hashCode()
    返回此缓冲区的当前哈希码。

    long 缓冲区的哈希码只取决于其剩余元素；即取决于从 position() 开始一直到（包括）limit() - 1 处的元素。

    因为缓冲区哈希码与内容有关，因此建议不要在哈希映射或类似数据结构中将缓冲区用作键，除非知道它们的内容不会发生更改。

    覆盖：
    类 Object 中的 hashCode
    返回：
    此缓冲区的当前哈希码
    另请参见：
    Object.equals(java.lang.Object), Hashtable

    equals

    public boolean equals(Object ob)
    判断此缓冲区是否与另一个对象相同。

    两个 long 缓冲区是相同的，当且仅当：

    1. 它们具有相同的元素类型，

    2. 它们具有相同数量的剩余元素，并且

    3. 两个剩余元素序列（与它们的起始位置无关）逐点相同。

    long 缓冲区与任何其他类型的对象都不同。

    覆盖：
    类 Object 中的 equals
    参数：
    ob - 此缓冲区要比较的对象
    返回：
    当且仅当此缓冲区与给定对象相同时，返回 true
    另请参见：
    Object.hashCode(), Hashtable

    compareTo

    public int compareTo(LongBuffer that)
    将此缓冲区与另一个缓冲区进行比较。

    比较两个 long 缓冲区的方法是按字典顺序比较它们的剩余元素序列，而不考虑每个序列在其对应缓冲区中的起始位置。

    long 缓冲区不能与其他类型的对象进行比较。

    指定者：
    接口 Comparable<LongBuffer> 中的 compareTo
    参数：
    that - 要比较的对象。
    返回：
    如果此缓冲区小于、等于或大于给定缓冲区，则相应返回负整数、零或正整数

    order

    public abstract ByteOrder order()
    获取此缓冲区的字节顺序。

    通过分配或通过包装现有 long 数组而创建的 long 缓冲区的字节顺序是底层硬件的本机顺序。作为字节缓冲区的视图而创建的 long 缓冲区的字节顺序是创建视图时字节缓冲区的字节顺序。

    返回：
    此缓冲区的字节顺序
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MappedByteBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 MappedByteBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.ByteBuffer
            继承者  java.nio.MappedByteBuffer
所有已实现的接口：
Comparable<ByteBuffer>
public abstract class MappedByteBuffer
extends ByteBuffer

直接字节缓冲区，其内容是文件的内存映射区域。

映射的字节缓冲区是通过 FileChannel.map 方法创建的。此类用特定于内存映射文件区域的操作扩展 ByteBuffer 类。

映射的字节缓冲区和它所表示的文件映射关系在该缓冲区本身成为垃圾回收缓冲区之前一直保持有效。

映射的字节缓冲区的内容可以随时更改，例如，在此程序或另一个程序更改了对应的映射文件区域的内容的情况下。这些更改是否发生（以及何时发生）与操作系统无关，因此是未指定的。

全部或部分映射的字节缓冲区可能随时成为不可访问的，例如，如果我们截取映射的文件。试图访问映射的字节缓冲区的不可访问区域将不会更改缓冲区的内容，并导致在访问时或访问后的某个时刻抛出未指定的异常。因此强烈推荐采取适当的预防措施，以避免此程序或另一个同时运行的程序对映射的文件执行操作（读写文件内容除外）。

除此之外，映射的字节缓冲区的功能与普通的直接字节缓冲区完全相同。

从以下版本开始：
1.4

方法摘要
MappedByteBuffer | force() 将此缓冲区所做的内容更改强制写入包含映射文件的存储设备中。
boolean | isLoaded() 判断此缓冲区的内容是否位于物理内存中。
MappedByteBuffer | load() 将此缓冲区内容加载到物理内存中。
从类 java.nio.ByteBuffer 继承的方法
allocate, allocateDirect, array, arrayOffset, asCharBuffer, asDoubleBuffer, asFloatBuffer, asIntBuffer, asLongBuffer, asReadOnlyBuffer, asShortBuffer, compact, compareTo, duplicate, equals, get, get, get, get, getChar, getChar, getDouble, getDouble, getFloat, getFloat, getInt, getInt, getLong, getLong, getShort, getShort, hasArray, hashCode, isDirect, order, order, put, put, put, put, put, putChar, putChar, putDouble, putDouble, putFloat, putFloat, putInt, putInt, putLong, putLong, putShort, putShort, slice, toString, wrap, wrap
从类 java.nio.Buffer 继承的方法
capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

isLoaded

public final boolean isLoaded()
判断此缓冲区的内容是否位于物理内存中。

返回值为 true 意味着此缓冲区中所有数据极有可能都位于物理内存中，因此是可访问的，不会导致任何虚拟内存页错误，也无需任何 I/O 操作。返回值为 false 不一定意味着缓冲区的内容不位于物理内存中。

返回值是一个提示，而不是保证，因为在此方法的调用返回之前，底层操作系统可能已经移出某些缓冲区数据。

返回：
如果此缓冲区内容可能位于物理内存中，则返回 true

load

public final MappedByteBuffer load()
将此缓冲区内容加载到物理内存中。

此方法最大限度地确保在它返回时此缓冲区内容位于物理内存中。调用此方法可能导致一些页面错误，并导致发生 I/O 操作。

返回：
此缓冲区

force

public final MappedByteBuffer force()
将此缓冲区所做的内容更改强制写入包含映射文件的存储设备中。

如果映射到此缓冲区中的文件位于本地存储设备上，那么当此方法返回时，可以保证自此缓冲区创建以来，或自最后一次调用此方法以来，已经将对缓冲区所做的所有更改写入到该设备。

如果文件不在本地设备上，则无法作出这样的保证。

如果此缓冲区不是以读/写模式 (FileChannel.MapMode.READ_WRITE) 映射的，则调用此方法无效。

返回：
此缓冲区
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReadOnlyBufferException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio
类 ReadOnlyBufferException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.UnsupportedOperationException
                    继承者  java.nio.ReadOnlyBufferException
所有已实现的接口：
Serializable
public class ReadOnlyBufferException
extends UnsupportedOperationException

当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ReadOnlyBufferException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReadOnlyBufferException

public ReadOnlyBufferException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShortBuffer (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio
类 ShortBuffer

java.lang.Object
    继承者  java.nio.Buffer
        继承者  java.nio.ShortBuffer
所有已实现的接口：
Comparable<ShortBuffer>
public abstract class ShortBuffer
extends Buffer
implements Comparable<ShortBuffer>

short 缓冲区。

此类定义了 short 缓冲区上的四类操作：

  • 读写单个 short 的绝对和相对 get 和 put 方法。

  • 将此缓冲区的连续 short 序列传输到数组中的相对批量 get 方法；

  • 将 short 数组或其他 short 缓冲区中的连续 short 序列传输到此缓冲区的相对批量 put 方法；以及

  • short 缓冲区的 compacting、duplicating 和 slicing 方法。

    • short 缓冲区可以通过 allocation 创建，此方法通过 wrapping 将一个现有 short 数组包装到缓冲区中来为缓冲区内容分配空间，或者通过创建现有字节缓冲区的视图来创建。

    像字节缓冲区一样，short 缓冲区要么是直接的，要么是非直接的。通过此类的 wrap 方法创建的 short 缓冲区将是非直接的。当且仅当字节缓冲区本身为直接时，作为字节缓冲区的视图创建的 short 缓冲区才是直接的。通过调用 isDirect 方法可以确定 short 缓冲区是否为直接的。

    指定此类中的方法（它们不返回其他值），以返回这些方法被调用时所在的缓冲区。这允许对方法调用进行链接。

    从以下版本开始：
    1.4

    方法摘要
static ShortBuffer | allocate(int capacity) 分配新的 short 缓冲区。
short[] | array() 返回实现此缓冲区的 short 数组（可选操作）。
int | arrayOffset() 返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。
abstract ShortBuffer | asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 short 缓冲区。
abstract ShortBuffer | compact() 压缩此缓冲区（可选操作）。
int | compareTo(ShortBuffer that) 将此缓冲区与另一个缓冲区进行比较。
abstract ShortBuffer | duplicate() 创建共享此缓冲区内容的新的 short 缓冲区。
boolean | equals(Object ob) 判断此缓冲区是否与另一个对象相同。
abstract short | get() 相对 get 方法。
abstract short | get(int index) 绝对 get 方法。
ShortBuffer | get(short[] dst) 相对批量 get 方法。
ShortBuffer | get(short[] dst, int offset, int length) 相对批量 get 方法。
boolean | hasArray() 判断是否可通过一个可访问的 short 数组实现此缓冲区。
int | hashCode() 返回此缓冲区的当前哈希码。
abstract boolean | isDirect() 判断此 short 缓冲区是否为直接的。
abstract ByteOrder | order() 获取此缓冲区的字节顺序。
abstract ShortBuffer | put(int index, short s) 绝对 put 方法（可选操作）。
abstract ShortBuffer | put(short s) 相对 put 方法（可选操作）。
ShortBuffer | put(short[] src) 相对批量 put 方法（可选操作）。
ShortBuffer | put(short[] src, int offset, int length) 相对批量 put 方法（可选操作）。
ShortBuffer | put(ShortBuffer src) 相对批量 put 方法（可选操作）。
abstract ShortBuffer | slice() 创建新的 short 缓冲区，其内容是此缓冲区内容的共享子序列。
String | toString() 返回总结了此缓冲区状态的字符串。
static ShortBuffer | wrap(short[] array) 将 short 数组包装到缓冲区中。
static ShortBuffer | wrap(short[] array, int offset, int length) 将 short 数组包装到缓冲区中。
    从类 java.nio.Buffer 继承的方法
    capacity, clear, flip, hasRemaining, isReadOnly, limit, limit, mark, position, position, remaining, reset, rewind
    从类 java.lang.Object 继承的方法
    clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    方法详细信息

    allocate

    public static ShortBuffer allocate(int capacity)
    分配新的 short 缓冲区。

    新缓冲区的位置将为零，其界限将为其容量，其标记是未定义的。它将具有一个底层实现数组，且其数组偏移量将为零。

    参数：
    capacity - 新缓冲区的容量，以 short 为单位
    返回：
    新的 short 缓冲区
    抛出：
    IllegalArgumentException - 如果 capacity 为负整数

    wrap

    public static ShortBuffer wrap(short[] array,
                               int offset,
                               int length)
    将 short 数组包装到缓冲区中。

    给定的 short 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量将为 array.length，其位置将为 offset，其界限将为 offset + length，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

    参数：
    array - 支持新缓冲区的数组
    offset - 要使用的子数组的偏移量；必须为非负且不大于 array.length。将新缓冲区的位置设置为此值。
    length - 要使用的子数组的长度；必须为非负且不大于 array.length - offset。将新缓冲区的界限设置为 offset + length。
    返回：
    新的 short 缓冲区
    抛出：
    IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

    wrap

    public static ShortBuffer wrap(short[] array)
    将 short 数组包装到缓冲区中。

    给定的 short 数组将支持新缓冲区；即缓冲区修改将导致数组修改，反之亦然。新缓冲区的容量和界限将为 array.length，其位置将为零，其标记是未定义的。其底层实现数组将为给定数组，并且其数组偏移量将为零。

    参数：
    array - 实现此缓冲区的数组
    返回：
    新的 short 缓冲区

    slice

    public abstract ShortBuffer slice()
    创建新的 short 缓冲区，其内容是此缓冲区内容的共享子序列。

    新缓冲区的内容将从此缓冲区的当前位置开始。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

    新缓冲区的位置将为零，其容量和界限将为此缓冲区中所剩余的 short 数量，其标记是未定义的。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

    返回：
    新的 short 缓冲区

    duplicate

    public abstract ShortBuffer duplicate()
    创建共享此缓冲区内容的新的 short 缓冲区。

    新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，反之亦然；这两个缓冲区的位置、界限和标记值是相互独立的。

    新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。当且仅当此缓冲区为直接时，新缓冲区才是直接的，当且仅当此缓冲区为只读时，新缓冲区才是只读的。

    返回：
    新的 short 缓冲区

    asReadOnlyBuffer

    public abstract ShortBuffer asReadOnlyBuffer()
    创建共享此缓冲区内容的新的只读 short 缓冲区。

    新缓冲区的内容将为此缓冲区的内容。此缓冲区内容的更改在新缓冲区中是可见的，但新缓冲区将是只读的并且不允许修改共享内容。两个缓冲区的位置、界限和标记值是相互独立的。

    新缓冲区的容量、界限、位置和标记值将与此缓冲区相同。

    如果此缓冲区本身是只读的，则此方法与 duplicate 方法完全相同。

    返回：
    新的只读 short 缓冲区

    get

    public abstract short get()
    相对 get 方法。读取此缓冲区当前位置的 short，然后该位置递增。

    返回：
    缓冲区当前位置的 short
    抛出：
    BufferUnderflowException - 如果缓冲区当前位置不小于其界限

    put

    public abstract ShortBuffer put(short s)
    相对 put 方法（可选操作）。

    将给定 short 写入此缓冲区的当前位置，然后该位置递增。

    参数：
    s - 要写入的 short
    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果此缓冲区的当前位置不小于界限
    ReadOnlyBufferException - 如果此缓冲区是只读的

    get

    public abstract short get(int index)
    绝对 get 方法。读取给定索引处的 short。

    参数：
    index - 将读取 short 的位置的索引
    返回：
    给定索引处的 short
    抛出：
    IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限

    put

    public abstract ShortBuffer put(int index,
                                short s)
    绝对 put 方法（可选操作）。

    将给定 short 写入此缓冲区的给定索引处。

    参数：
    index - 将在该位置写入 short
    s - 要写入的 short 值
    返回：
    此缓冲区
    抛出：
    IndexOutOfBoundsException - 如果 index 为负或不小于缓冲区界限
    ReadOnlyBufferException - 如果此缓冲区是只读的

    get

    public ShortBuffer get(short[] dst,
                       int offset,
                       int length)
    相对批量 get 方法。

    此方法将此缓冲区的 short 传输到给定的目标数组中。如果缓冲区中剩余的 short 少于满足请求所需的 short，即如果 length > remaining()，则不传输 short 且抛出 BufferUnderflowException。

    否则，此方法将此缓冲区中的 length 个 short 复制到给定数组中，从此缓冲区的当前位置和数组中的给定偏移量位置开始复制。然后此缓冲区的位置递增 length。

    换句话说，调用此方法的形式为 src.get(dst, off, len)，效果与以下循环语句完全相同：

         for (int i = off; i < off + len; i++)
         dst[i] = src.get();
    区别在于它首先检查此缓冲区中是否具有足够的 short，这样可能效率更高。

    参数：
    dst - 要写入 short 的数组
    offset - 要写入的第一个 short 在数组中的偏移量；必须为非负且不大于 dst.length
    length - 要写入给定数组中的 short 的最大数量；必须为非负且不大于 dst.length - offset
    返回：
    此缓冲区
    抛出：
    BufferUnderflowException - 如果此缓冲区中的剩余 short 少于 length
    IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立

    get

    public ShortBuffer get(short[] dst)
    相对批量 get 方法。

    此方法将此缓冲区的 short 传输到给定的目标数组中。调用此方法的形式为 src.get(a)，该调用与以下调用完全相同：

         src.get(a, 0, a.length)

    返回：
    此缓冲区
    抛出：
    BufferUnderflowException - 如果此缓冲区中的剩余 short 少于 length

    put

    public ShortBuffer put(ShortBuffer src)
    相对批量 put 方法（可选操作）。

    此方法将给定源缓冲区中的剩余 short 传输到此缓冲区中。如果源缓冲区中的剩余 short 多于此缓冲区中的剩余 short 空间，即 src.remaining() > remaining()，则不传输 short 且抛出 BufferOverflowException。

    否则，此方法将给定缓冲区中的 n = src.remaining() 个 short 复制到此缓冲区中，从每个缓冲区的当前位置开始复制。然后这两个缓冲区的位置均递增 n。

    换句话说，调用此方法的形式为 dst.put(src)，效果与以下循环语句完全相同：

         while (src.hasRemaining())
         dst.put(src.get());
    区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

    参数：
    src - 要从中读取 short 的源缓冲区；不能为此缓冲区
    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果对于源缓冲区中剩余的 short，此缓冲区没有足够空间
    IllegalArgumentException - 如果源缓冲区是此缓冲区
    ReadOnlyBufferException - 如果此缓冲区是只读的

    put

    public ShortBuffer put(short[] src,
                       int offset,
                       int length)
    相对批量 put 方法（可选操作）。

    此方法将给定源数组中的 short 传输到此缓冲区中。如果要从数组复制的 short 多于此缓冲区中的剩余 short 空间，即如果 length > remaining()，则不传输 short 且抛出 BufferOverflowException。

    否则，此方法将给定数组中的 length 个 short 复制到此缓冲区中，从数组中给定偏移量位置和此缓冲区的当前位置开始复制。然后此缓冲区的位置递增 length。

    换句话说，调用此方法的形式为 dst.put(src, off, len)，效果与以下循环语句完全相同：

         for (int i = off; i < off + len; i++)
         dst.put(a[i]);
    区别在于它首先检查此缓冲区中是否有足够空间，这样可能效率更高。

    参数：
    src - 要从中读取 short 的数组
    offset - 要读取的第一个 short 在数组中的偏移量；必须为非负且不大于 array.length
    length - 要从给定数组读取的 short 数量；必须为非负且不大于 array.length - offset
    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果此缓冲区没有足够空间
    IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
    ReadOnlyBufferException - 如果此缓冲区是只读的

    put

    public final ShortBuffer put(short[] src)
    相对批量 put 方法（可选操作）。

    此方法将给定源 short 数组中的所有内容传输到此缓冲区中。调用此方法的形式为 dst.put(a)，该调用与以下调用完全相同：

         dst.put(a, 0, a.length)

    返回：
    此缓冲区
    抛出：
    BufferOverflowException - 如果此缓冲区没有足够空间
    ReadOnlyBufferException - 如果此缓冲区是只读的

    hasArray

    public final boolean hasArray()
    判断是否可通过一个可访问的 short 数组实现此缓冲区。

    如果此方法返回 true，则可以安全地调用 array 和 arrayOffset 方法。

    指定者：
    类 Buffer 中的 hasArray
    返回：
    当且仅当存在实现此缓冲区的数组，并且此缓冲区不是只读缓冲区时，返回 true

    array

    public final short[] array()
    返回实现此缓冲区的 short 数组（可选操作）。

    此缓冲区的内容修改将导致返回的数组内容修改，反之亦然。

    调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

    指定者：
    类 Buffer 中的 array
    返回：
    实现此缓冲区的数组
    抛出：
    ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
    UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

    arrayOffset

    public final int arrayOffset()
    返回此缓冲区的第一个元素在缓冲区的底层实现数组中的偏移量（可选操作）。

    如果存在实现此缓冲区的数组，则缓冲区位置 p 对应于数组索引 p + arrayOffset()。

    调用此方法之前要调用 hasArray 方法，以确保此缓冲区具有可访问的底层实现数组。

    指定者：
    类 Buffer 中的 arrayOffset
    返回：
    此缓冲区的第一个元素在缓冲区数组中的偏移量
    抛出：
    ReadOnlyBufferException - 如果存在实现此缓冲区的数组，但缓冲区是只读的
    UnsupportedOperationException - 如果不存在某个可访问的数组实现此缓冲区

    compact

    public abstract ShortBuffer compact()
    压缩此缓冲区（可选操作）。

    将缓冲区当前位置和界限之间的 short（如果有）复制到缓冲区的开始处。即将索引 p = position() 处的 short 复制到索引 0 处，将索引 p + 1 处的 short 复制到索引 1 处，依此类推，直到将索引 limit() - 1 处的 short 复制到索引 n = limit() - 1 - p 处。然后将缓冲区的位置设置为 n+1，并将其界限设置为其容量。如果已定义了标记，则丢弃它。

    将缓冲区的位置设置为复制的 short 的数量，而不是零，以便调用此方法后可以紧接着调用另一个相对 put 方法。

    返回：
    此缓冲区
    抛出：
    ReadOnlyBufferException - 如果此缓冲区是只读的

    isDirect

    public abstract boolean isDirect()
    判断此 short 缓冲区是否为直接的。

    指定者：
    类 Buffer 中的 isDirect
    返回：
    当且仅当此缓冲区为直接时，返回 true

    toString

    public String toString()
    返回总结了此缓冲区状态的字符串。

    覆盖：
    类 Object 中的 toString
    返回：
    一个总结字符串

    hashCode

    public int hashCode()
    返回此缓冲区的当前哈希码。

    short 缓冲区的哈希码只取决于其剩余元素；即取决于从 position() 开始一直到（包括） limit() - 1 处的元素。

    因为缓冲区哈希码与内容有关，因此建议不要在哈希映射或类似数据结构中将缓冲区用作键，除非知道它们的内容不会发生更改。

    覆盖：
    类 Object 中的 hashCode
    返回：
    此缓冲区的当前哈希码
    另请参见：
    Object.equals(java.lang.Object), Hashtable

    equals

    public boolean equals(Object ob)
    判断此缓冲区是否与另一个对象相同。

    两个 short 缓冲区是相同的，当且仅当：

    1. 它们具有相同的元素类型，

    2. 它们具有相同数量的剩余元素，并且

    3. 两个剩余元素序列（与它们的起始位置无关）逐点相同。

    short 缓冲区与任何其他类型的对象都不同。

    覆盖：
    类 Object 中的 equals
    参数：
    ob - 此缓冲区要比较的对象
    返回：
    当且仅当此缓冲区与给定对象相同时，返回 true
    另请参见：
    Object.hashCode(), Hashtable

    compareTo

    public int compareTo(ShortBuffer that)
    将此缓冲区与另一个缓冲区进行比较。

    比较两个 short 缓冲区的方法是按字典顺序比较它们的剩余元素序列，而不考虑每个序列在其对应缓冲区中的起始位置。

    short 缓冲区不能与任何其他类型的对象进行比较。

    指定者：
    接口 Comparable<ShortBuffer> 中的 compareTo
    参数：
    that - 要比较的对象。
    返回：
    如果此缓冲区小于、等于或大于给定缓冲区，则相应返回负整数、零或正整数

    order

    public abstract ByteOrder order()
    获取此缓冲区的字节顺序。

    通过分配或通过包装现有 short 数组而创建的 short 缓冲区的字节顺序是底层硬件的本机顺序。作为字节缓冲区的视图而创建的 short 缓冲区的字节顺序是创建视图时字节缓冲区的字节顺序。

    返回：
    此缓冲区的字节顺序
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个类 下一个类 | 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.nio (Java 2 Platform SE 6)

 java.nio
类
Buffer
ByteBuffer
ByteOrder
CharBuffer
DoubleBuffer
FloatBuffer
IntBuffer
LongBuffer
MappedByteBuffer
ShortBuffer
异常
BufferOverflowException
BufferUnderflowException
InvalidMarkException
ReadOnlyBufferException


java.nio (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.nio

定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

请参见：
描述

类摘要
Buffer | 一个用于特定基本类型数据的容器。
ByteBuffer | 字节缓冲区。
ByteOrder | 字节顺序的类型安全枚举。
CharBuffer | 字符缓冲区。
DoubleBuffer | double 缓冲区。
FloatBuffer | float 缓冲区。
IntBuffer | int 缓冲区。
LongBuffer | long 缓冲区。
MappedByteBuffer | 直接字节缓冲区，其内容是文件的内存映射区域。
ShortBuffer | short 缓冲区。

异常摘要
BufferOverflowException | 当相关 put 操作达到目标缓冲区限制时，抛出此未经检查的异常。
BufferUnderflowException | 当相关 get 操作达到源缓冲区限制时，抛出此未经检查的异常。
InvalidMarkException | 当试图重置一个尚未定义其标记的缓冲区时，抛出此未检查的异常。
ReadOnlyBufferException | 当在只读缓冲区上调用内容可变（content-mutation）的方法（例如 put 或 compact 方法）时，抛出此未经检查的异常。

软件包 java.nio 的描述

定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

NIO API 的集中抽象为：

  • 缓冲区，它们是数据容器；

  • 字符集 及其相关解码器 和编码器，
    它们在字节和 Unicode 字符之间进行转换；

  • 各种类型的通道，它们表示到能够执行 IO 操作的
    实体的连接；以及选择器 和选择键，它们与
    可选择信道 一起定义了多路的、无阻塞的
    I/O     设施。

java.nio 包定义了缓冲区类，这些类用于所有 NIO API。java.nio.charset 包中定义了字符集 API，java.nio.channels 包中定义了信道和选择器 API。每个子包都具有自己的服务提供者接口 (SPI) 子包，SPI 子包的内容可用于扩展平台的默认实现或构造替代实现。

缓冲区

描述

  Buffer 位置，界限和容量；
清除，反转，重绕和标记/重置
  ByteBuffer | Get/put，压缩，查看；分配，包装
  MappedByteBuffer   | 映射到文件的字节缓冲区
  CharBuffer | Get/put，压缩；分配，包装
  DoubleBuffer ' '
  FloatBuffer ' '
  IntBuffer ' '
  LongBuffer ' '
  ShortBuffer ' '
  ByteOrder | 字节顺序的类型安全的枚举

缓冲区 是一个固定数据量的指定基本类型的数据容器。除内容之外，缓冲区还具有位置 和界限，其中位置是要读写的下一个元素的索引，界限是第一个应该读写的元素的索引。基本 Buffer 类定义了这些属性以及清除、反转 和重绕 方法，用以标记 当前位置，以及将当前位置重置 为前一个标记处。

每个非布尔基本类型都有一个缓冲区类。每个类定义了一系列用于将数据移出或移入缓冲区的 get 和 put 方法，用于压缩、复制 和切片 缓冲区的方法，以及用于分配 新缓冲区和将现有数组包装 到缓冲区中的静态方法。

因为字节缓冲区可以用作 I/O 操作的源缓冲区和目标缓冲区，所以可以对它们加以区分。它们还支持其他缓冲区类所没有的几个特性：

  • 可以将字节缓冲区分配为一个直接 缓冲区，在这种情况下，Java 虚拟机将最大限度地直接在缓冲区上执行本机 I/O 操作。

  • 可以通过 mapping 将文件区域直接包装到内存中来创建字节缓冲区，在这种情况下，可以使用 MappedByteBuffer 类中定义的几个其他文件相关的操作。

  • 字节缓冲区提供了对其内容的访问（其内容作为任何非布尔基本类型的异类或同类二进制数据序列），访问要么是以 big-endian 字节顺序进行，要么是以 little-endian 字节顺序进行。

除非另有说明，否则向此包的任何类或接口中的构造方法或方法传递 null 变量，都会抛出 NullPointerException。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.nio 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.nio.Buffer
      • java.nio.ByteBuffer (implements java.lang.Comparable<T>)
        • java.nio.MappedByteBuffer
      • java.nio.CharBuffer (implements java.lang.Appendable, java.lang.CharSequence, java.lang.Comparable<T>, java.lang.Readable)
      • java.nio.DoubleBuffer (implements java.lang.Comparable<T>)
      • java.nio.FloatBuffer (implements java.lang.Comparable<T>)
      • java.nio.IntBuffer (implements java.lang.Comparable<T>)
      • java.nio.LongBuffer (implements java.lang.Comparable<T>)
      • java.nio.ShortBuffer (implements java.lang.Comparable<T>)
    • java.nio.ByteOrder
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.nio.BufferOverflowException
          • java.nio.BufferUnderflowException
          • java.lang.IllegalStateException
            • java.nio.InvalidMarkException
          • java.lang.UnsupportedOperationException
            • java.nio.ReadOnlyBufferException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.nio 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio
的使用

使用 java.nio 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。
javax.net.ssl | 提供用于安全套接字包的类。

java.io 使用的 java.nio 中的类
CharBuffer
字符缓冲区。

java.lang 使用的 java.nio 中的类
ByteBuffer
字节缓冲区。
CharBuffer
字符缓冲区。

java.nio 使用的 java.nio 中的类
Buffer
一个用于特定基本类型数据的容器。
ByteBuffer
字节缓冲区。
ByteOrder
字节顺序的类型安全枚举。
CharBuffer
字符缓冲区。
DoubleBuffer
double 缓冲区。
FloatBuffer
float 缓冲区。
IntBuffer
int 缓冲区。
LongBuffer
long 缓冲区。
MappedByteBuffer
直接字节缓冲区，其内容是文件的内存映射区域。
ShortBuffer
short 缓冲区。

java.nio.channels 使用的 java.nio 中的类
ByteBuffer
字节缓冲区。
MappedByteBuffer
直接字节缓冲区，其内容是文件的内存映射区域。

java.nio.charset 使用的 java.nio 中的类
ByteBuffer
字节缓冲区。
CharBuffer
字符缓冲区。

java.security 使用的 java.nio 中的类
ByteBuffer
字节缓冲区。

javax.crypto 使用的 java.nio 中的类
ByteBuffer
字节缓冲区。

javax.imageio.stream 使用的 java.nio 中的类
ByteOrder
字节顺序的类型安全枚举。

javax.net.ssl 使用的 java.nio 中的类
ByteBuffer
字节缓冲区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AlreadyConnectedException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 AlreadyConnectedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.AlreadyConnectedException
所有已实现的接口：
Serializable
public class AlreadyConnectedException
extends IllegalStateException

试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
AlreadyConnectedException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AlreadyConnectedException

public AlreadyConnectedException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AsynchronousCloseException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 AsynchronousCloseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.nio.channels.ClosedChannelException
                    继承者  java.nio.channels.AsynchronousCloseException
所有已实现的接口：
Serializable
直接已知子类：
ClosedByInterruptException
public class AsynchronousCloseException
extends ClosedChannelException

当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
AsynchronousCloseException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AsynchronousCloseException

public AsynchronousCloseException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ByteChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
接口 ByteChannel

所有超级接口：
Channel, Closeable, ReadableByteChannel, WritableByteChannel
所有已知实现类：
DatagramChannel, FileChannel, SocketChannel
public interface ByteChannel
extends ReadableByteChannel, WritableByteChannel

可读取和写入字节的信道。此接口只是统一了 ReadableByteChannel 和 WritableByteChannel；它没有指定任何新操作。

从以下版本开始：
1.4

方法摘要
从接口 java.nio.channels.ReadableByteChannel 继承的方法
read
从接口 java.nio.channels.WritableByteChannel 继承的方法
write
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CancelledKeyException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 CancelledKeyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.CancelledKeyException
所有已实现的接口：
Serializable
public class CancelledKeyException
extends IllegalStateException

当试图使用不再有效的选择键时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
CancelledKeyException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CancelledKeyException

public CancelledKeyException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Channel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
接口 Channel

所有超级接口：
Closeable
所有已知子接口：
ByteChannel, GatheringByteChannel, InterruptibleChannel, ReadableByteChannel, ScatteringByteChannel, WritableByteChannel
所有已知实现类：
AbstractInterruptibleChannel, AbstractSelectableChannel, DatagramChannel, FileChannel, Pipe.SinkChannel, Pipe.SourceChannel, SelectableChannel, ServerSocketChannel, SocketChannel
public interface Channel
extends Closeable

用于 I/O 操作的连接。

通道表示到实体，如硬件设备、文件、网络套接字或可以执行一个或多个不同 I/O 操作（如读取或写入）的程序组件的开放的连接。

通道可处于打开或关闭状态。创建通道时它处于打开状态，一旦将其关闭，则保持关闭状态。一旦关闭了某个通道，试图对其调用 I/O 操作就会导致 ClosedChannelException 被抛出。通过调用通道的 isOpen 方法可测试通道是否处于打开状态。

正如扩展和实现此接口的各个接口和类规范中所描述的，一般情况下通道对于多线程的访问是安全的。

从以下版本开始：
1.4

方法摘要
void | close() 关闭此通道。
boolean | isOpen() 判断此通道是否处于打开状态。

方法详细信息

isOpen

boolean isOpen()
判断此通道是否处于打开状态。

返回：
当且仅当此通道处于打开状态时才返回 true

close

void close()
           throws IOException
关闭此通道。

关闭某个通道后，试图对其调用 I/O 操作就会导致 ClosedChannelException 被抛出。

如果此通道已经关闭，则调用此方法无效。

可在任意时间调用此方法。但是如果其他某个线程已调用此方法，那么在第一个调用完成前另一个调用将被阻塞，之后该方法将返回，不受任何影响。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Channels (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 Channels

java.lang.Object
    继承者  java.nio.channels.Channels

public final class Channels
extends Object

针对信道和流的实用工具方法。

此类定义了支持 java.io 包中的流类与此包中的信道类之间进行互操作的静态方法。

从以下版本开始：
1.4

方法摘要
static ReadableByteChannel | newChannel(InputStream in) 构造从给定流读取字节的信道。
static WritableByteChannel | newChannel(OutputStream out) 构造向给定流写入字节的信道。
static InputStream | newInputStream(ReadableByteChannel ch) 构造从给定信道读取字节的流。
static OutputStream | newOutputStream(WritableByteChannel ch) 构造向给定信道写入字节的流。
static Reader | newReader(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap) 构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。
static Reader | newReader(ReadableByteChannel ch, String csName) 构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。
static Writer | newWriter(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap) 构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。
static Writer | newWriter(WritableByteChannel ch, String csName) 构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

newInputStream

public static InputStream newInputStream(ReadableByteChannel ch)
构造从给定信道读取字节的流。

如果在底层信道处于非阻塞模式的同时调用所得流的 read 方法，则会抛出 IllegalBlockingModeException。不对该流进行缓冲，并且它不支持 mark 或 reset 方法。多个并发线程访问该流是安全的。关闭流依次会导致信道被关闭。

参数：
ch - 将从中读取字节的信道
返回：
新的输入流

newOutputStream

public static OutputStream newOutputStream(WritableByteChannel ch)
构造向给定信道写入字节的流。

如果在底层信道处于非阻塞模式的同时调用所得流的 write 方法，则会抛出 IllegalBlockingModeException。不对该流进行缓冲。多个并发线程访问该流是安全的。关闭流依次会导致信道被关闭。

参数：
ch - 将向其写入字节的信道
返回：
新的输出流

newChannel

public static ReadableByteChannel newChannel(InputStream in)
构造从给定流读取字节的信道。

不对所得的信道进行缓冲；只是将其 I/O 操作重定向到给定的流。关闭流会依次导致信道被关闭。

参数：
in - 从中读取字节的流
返回：
新的可读字节信道

newChannel

public static WritableByteChannel newChannel(OutputStream out)
构造向给定流写入字节的信道。

不对所得的信道进行缓冲；只是将其 I/O 操作重定向到给定的流。关闭流会依次导致信道被关闭。

参数：
out - 将向其写入字节的流
返回：
新的可写字节信道

newReader

public static Reader newReader(ReadableByteChannel ch,
                               CharsetDecoder dec,
                               int minBufferCap)
构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。

所得的流将包含一个内部输入缓冲区，其大小至少为 minBufferCap 个字节。该流的 read 方法会根据需要填充该缓冲区，方法是从底层信道读取字节；如果要读取字节时该信道处于非阻塞模式，则抛出 IllegalBlockingModeException。否则不对所得的流进行缓冲，并且也不支持 mark 或 reset 方法。关闭流依次会导致信道被关闭。

参数：
ch - 将从中读取字节的信道
dec - 要使用的 charset 解码器
minBufferCap - 内部字节缓冲区的最小容量，如果使用取决于实现的默认容量，则为 -1
返回：
新的 reader

newReader

public static Reader newReader(ReadableByteChannel ch,
                               String csName)
构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。

调用该方法的形式为：

 Channels.newReader(ch, csname)
与下列表达式的作用完全相同
 Channels.newReader(ch,
                    Charset.forName(csName)
                        .newDecoder(),
                    -1);

参数：
ch - 将从中读取字节的信道
csName - 要使用的 charset 的名称
返回：
新的 reader
抛出：
UnsupportedCharsetException - 如果在此 Java 虚拟机的实例中不提供对指定 charset 的支持

newWriter

public static Writer newWriter(WritableByteChannel ch,
                               CharsetEncoder enc,
                               int minBufferCap)
构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。

所得的流将包含一个内部输出缓冲区，其大小至少为 minBufferCap 字节。该流的 write 方法会根据需要刷新该缓冲区，方法是向底层信道写入字节；如果要写入字节时该信道处于非阻塞模式，则抛出 IllegalBlockingModeException。不另外对所得的流进行缓冲。关闭流依次会导致信道被关闭。

参数：
ch - 将向其写入字节的信道
enc - 要使用的 charset 编码器
minBufferCap - 内部字节缓冲区的最小容量，如果使用取决于实现的默认容量，则为 -1
返回：
新的 writer

newWriter

public static Writer newWriter(WritableByteChannel ch,
                               String csName)
构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。

调用该方法的形式为：

 Channels.newWriter(ch, csname)
与下列表达式的作用完全相同
 Channels.newWriter(ch,
                    Charset.forName(csName)
                        .newEncoder(),
                    -1);

参数：
ch - 将向其写入字节的信道
csName - 所使用的 charset 的名称
返回：
新的 writer
抛出：
UnsupportedCharsetException - 如果在此 Java 虚拟机的实例中不提供对指定 charset 的支持
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClosedByInterruptException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 ClosedByInterruptException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.nio.channels.ClosedChannelException
                    继承者  java.nio.channels.AsynchronousCloseException
                        继承者  java.nio.channels.ClosedByInterruptException
所有已实现的接口：
Serializable
public class ClosedByInterruptException
extends AsynchronousCloseException

当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。抛出此异常前将关闭该信道，并设置先前处于阻塞状态的线程的中断状态。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ClosedByInterruptException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClosedByInterruptException

public ClosedByInterruptException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClosedChannelException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 ClosedChannelException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.nio.channels.ClosedChannelException
所有已实现的接口：
Serializable
直接已知子类：
AsynchronousCloseException
public class ClosedChannelException
extends IOException

当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。抛出此异常未必意味着该信道已完全关闭。例如，对写入操作已关闭的套接字信道，可能对读取操作仍处于打开状态。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ClosedChannelException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClosedChannelException

public ClosedChannelException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClosedSelectorException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 ClosedSelectorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.ClosedSelectorException
所有已实现的接口：
Serializable
public class ClosedSelectorException
extends IllegalStateException

试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ClosedSelectorException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ClosedSelectorException

public ClosedSelectorException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConnectionPendingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 ConnectionPendingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.ConnectionPendingException
所有已实现的接口：
Serializable
public class ConnectionPendingException
extends IllegalStateException

试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ConnectionPendingException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConnectionPendingException

public ConnectionPendingException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatagramChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 DatagramChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.SelectableChannel
            继承者  java.nio.channels.spi.AbstractSelectableChannel
                继承者  java.nio.channels.DatagramChannel
所有已实现的接口：
Closeable, ByteChannel, Channel, GatheringByteChannel, InterruptibleChannel, ReadableByteChannel, ScatteringByteChannel, WritableByteChannel
public abstract class DatagramChannel
extends AbstractSelectableChannel
implements ByteChannel, ScatteringByteChannel, GatheringByteChannel

针对面向数据报套接字的可选择通道。

数据报通道不是网络数据报套接字的完整抽象。必须通过调用 socket 所获得的关联 DatagramSocket 对象来完成套接字选项的绑定和操作。不可能为任意的已有数据报套接字创建通道，也不可能指定与数据报通道关联的数据报套接字所使用的 DatagramSocketImpl 对象。

通过调用此类的 open 方法创建数据报通道。新创建的数据报通道已打开，但尚未连接。为了使用 send 和 receive 方法，无需连接数据报通道。但是如果为了避免作为每次发送和接收操作的一部分而执行的安全检查开销，也可以通过调用数据报通道的 connect 方法来建立数据报通道连接。为了使用 read 和 write 方法，必须建立数据报通道连接，因为这些方法不接受或返回套接字地址。

一旦建立了连接，在断开数据报通道的连接或将其关闭之前，该数据报通道保持连接状态。可通过调用数据报通道的 isConnected 方法来确定它是否已连接。

多个并发线程可安全地使用数据报通道。尽管在任意给定时刻最多只能有一个线程进行读取和写入操作，但数据报通道支持并发的读写。

从以下版本开始：
1.4

构造方法摘要
protected DatagramChannel(SelectorProvider provider)
初始化此类的一个新实例。
方法摘要
abstract DatagramChannel | connect(SocketAddress remote) 连接此通道的套接字。
abstract DatagramChannel | disconnect() 断开此通道套接字的连接。
abstract boolean | isConnected() 判断是否已连接此通道的套接字。
static DatagramChannel | open() 打开数据报通道。
abstract int | read(ByteBuffer dst) 从此通道读取数据报。
long | read(ByteBuffer[] dsts) 从此通道读取数据报。
abstract long | read(ByteBuffer[] dsts, int offset, int length) 从此通道读取数据报。
abstract SocketAddress | receive(ByteBuffer dst) 通过此通道接收数据报。
abstract int | send(ByteBuffer src, SocketAddress target) 通过此通道发送数据报。
abstract DatagramSocket | socket() 获取与此通道关联的数据报套接字。
int | validOps() 返回一个操作集，标识此通道所支持的操作。
abstract int | write(ByteBuffer src) 将数据报写入此通道。
long | write(ByteBuffer[] srcs) 将数据报写入此通道。
abstract long | write(ByteBuffer[] srcs, int offset, int length) 将数据报写入此通道。
从类 java.nio.channels.spi.AbstractSelectableChannel 继承的方法
blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register
从类 java.nio.channels.SelectableChannel 继承的方法
register
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

DatagramChannel

protected DatagramChannel(SelectorProvider provider)
初始化此类的一个新实例。

方法详细信息

open

public static DatagramChannel open()
                            throws IOException
打开数据报通道。

通过调用系统级默认 SelectorProvider 对象的 openDatagramChannel 方法来创建新的通道。该通道不会被连接。

返回：
新的数据报通道
抛出：
IOException - 如果发生 I/O 错误

validOps

public final int validOps()
返回一个操作集，标识此通道所支持的操作。

数据报通道支持读取和写入操作，所以此方法返回 ( SelectionKey.OP_READ | SelectionKey.OP_WRITE )。

指定者：
类 SelectableChannel 中的 validOps
返回：
有效操作集

socket

public abstract DatagramSocket socket()
获取与此通道关联的数据报套接字。

返回的对象不会声明任何在 DatagramSocket 类中未声明的公共方法。

返回：
与此通道关联的数据报套接字

isConnected

public abstract boolean isConnected()
判断是否已连接此通道的套接字。

返回：
当且仅当已连接此通道的套接字时才返回 true

connect

public abstract DatagramChannel connect(SocketAddress remote)
                                 throws IOException
连接此通道的套接字。

配置该通道的套接字，以便该套接字仅和给定的远程同位体 地址进行数据报的接收和发送。一旦连接后，就无法和任何其他地址进行数据报的接收或发送。在显式地断开数据报套接字的连接或将其关闭之前，该套接字始终保持连接状态。

此方法执行的安全检查与 DatagramSocket 类的 connect 方法执行的安全检查完全相同。也就是说，如果已安装了安全管理器，则此方法验证其 checkAccept 和 checkConnect 方法是否分别允许接收来自给定远程地址的数据报和向其发送数据报。

可在任意时间调用此方法。此方法对调用它时正在进行的读取或写入操作没有任何影响。

参数：
remote - 与此通道连接的远程地址
返回：
此数据报通道
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行连接操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行连接操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
SecurityException - 如果已安装安全管理器并且它不允许对给定远程地址进行访问
IOException - 如果发生其他 I/O 错误

disconnect

public abstract DatagramChannel disconnect()
                                    throws IOException
断开此通道套接字的连接。

配置该通道的套接字，只要安全管理器允许（如果已安装），该套接字就可和任何远程地址进行数据报的接收和发送。

可在任意时间调用此方法。此方法对调用它时正在进行的读取或写入操作没有任何影响。

如果未连接此通道的套接字，或者通道已关闭，则调用此方法无效。

返回：
此数据报通道
抛出：
IOException - 如果发生其他 I/O 错误

receive

public abstract SocketAddress receive(ByteBuffer dst)
                               throws IOException
通过此通道接收数据报。

如果数据报直接可用，并且此通道处于阻塞模式但最终会变得可用，则将数据报复制到给定的字节缓冲区中并返回数据报的源地址。如果此通道处于非阻塞模式并且没有直接可用的数据报，则此方法直接返回 null。

该数据报被传输到给定的字节缓冲区中，并从缓冲区的当前位置开始存储，如同正规的 read 操作一样。如果缓冲区中的剩余字节空间小于保存数据报所需的空间，则丢弃余下的数据报。

此方法执行的安全检查与 DatagramSocket 类的 receive 方法执行的安全检查完全相同。也就是说，如果该套接字未连接到特定的远程地址，并且已安装了安全管理器，则对于接收到的每个数据报，此方法都会验证安全管理器的 checkAccept 方法是否允许使用该数据报的源地址和端口号。避免此项安全检查开销的方法是首先通过 connect 方法连接该套接字。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个读取操作，则在该操作完成前此方法的调用被阻塞。

参数：
dst - 要向其中传输数据报的缓冲区
返回：
数据报的源地址，或者如果此通道处于非阻塞模式并且没有直接可用的数据报，则返回 null
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
SecurityException - 如果已安装安全管理器并且它不允许接受该数据报发送者所发送的数据报
IOException - 如果发生其他 I/O 错误

send

public abstract int send(ByteBuffer src,
                         SocketAddress target)
                  throws IOException
通过此通道发送数据报。

如果此通道处于非阻塞模式并且底层输出缓冲区中没有足够的空间，或者如果此通道处于阻塞模式并且缓冲区中有足够的空间，则将给定缓冲区中的剩余字节以单个数据报的形式传送到给定的目标地址。

从字节缓冲区传输数据报如同通过正规的 write 操作一样。

此方法执行的安全检查与 DatagramSocket 类的 send 方法执行的安全检查完全相同。也就是说，如果该套接字未连接到指定的远程地址，并且已安装了安全管理器，则对于每个发送的数据报，此方法都会验证安全管理器的 checkConnect 方法是否允许使用该数据报的目标地址和端口号。避免此项安全检查开销的方法是首先通过 connect 方法连接该套接字。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个写入操作，则在该操作完成前此方法的调用被阻塞。

参数：
src - 包含要发送的数据报的缓冲区
target - 要将数据报发送到的地址
返回：
发送的字节数，可能是调用此方法时源缓冲区中剩余的字节数，或者如果此通道处于非阻塞模式并且底层输出缓冲区中没有足够的空间供数据报使用，则可能为零
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
SecurityException - 如果已安装安全管理器并且它不允许将数据报发送到给定地址
IOException - 如果发生其他 I/O 错误

read

public abstract int read(ByteBuffer dst)
                  throws IOException
从此通道读取数据报。

仅在此通道的套接字已连接时才调用此方法，并且此方法仅接受来自该套接字同位体的数据报。如果数据报中的字节数大于给定缓冲区中的剩余空间，则丢弃余下的数据报。否则此方法的行为与 ReadableByteChannel 接口中指定的行为完全相同。

指定者：
接口 ReadableByteChannel 中的 read
参数：
dst - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NotYetConnectedException - 如果未连接此通道的套接字
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

public abstract long read(ByteBuffer[] dsts,
                          int offset,
                          int length)
                   throws IOException
从此通道读取数据报。

仅在此通道的套接字已连接时才调用此方法，并且此方法仅接受来自该套接字同位体的数据报。如果数据报中的字节数大于给定缓冲区中的剩余空间，则丢弃余下的数据报。否则此方法的行为与 ScatteringByteChannel 接口中指定的行为完全相同。

指定者：
接口 ScatteringByteChannel 中的 read
参数：
dsts - 要向其中传输字节的缓冲区
offset - 第一个缓冲区（字节传输到该缓冲区中）在缓冲区数组中的偏移量；必须为非负数并且不能大于 dsts.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 dsts.length - offset
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NotYetConnectedException - 如果未连接此通道的套接字
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

public final long read(ByteBuffer[] dsts)
                throws IOException
从此通道读取数据报。

仅在此通道的套接字已连接时才调用此方法，并且此方法仅接受来自该套接字同位体的数据报。如果数据报中的字节数大于给定缓冲区中的剩余空间，则丢弃余下的数据报。否则此方法的行为与 ScatteringByteChannel 接口中指定的行为完全相同。

指定者：
接口 ScatteringByteChannel 中的 read
参数：
dsts - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NotYetConnectedException - 如果未连接此通道的套接字
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

write

public abstract int write(ByteBuffer src)
                   throws IOException
将数据报写入此通道。

仅在此通道的套接字已连接时才调用此方法，在这种情况下，此方法将数据报直接发送到套接字的同位体。否则此方法的行为与 WritableByteChannel 接口中指定的行为完全相同。

指定者：
接口 WritableByteChannel 中的 write
参数：
src - 要从中获取字节的缓冲区
返回：
写入的字节数，可能为零
抛出：
NotYetConnectedException - 如果未连接此通道的套接字
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

write

public abstract long write(ByteBuffer[] srcs,
                           int offset,
                           int length)
                    throws IOException
将数据报写入此通道。

仅在此通道的套接字已连接时才调用此方法，在这种情况下，此方法将数据报直接发送到套接字的同位体。否则此方法的行为与 GatheringByteChannel 接口中指定的行为完全相同。

指定者：
接口 GatheringByteChannel 中的 write
offset - 第一个缓冲区（要获取该缓冲区中的字节）在缓冲区数组中的偏移量；必须为非负数并且不能大于 srcs.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 srcs.length - offset
返回：
发送的字节数，可能是调用此方法时源缓冲区中剩余的字节数，或者如果此通道处于非阻塞模式并且底层输出缓冲区中没有足够的空间供数据报使用，则可能为零
抛出：
NotYetConnectedException - 如果未连接此通道的套接字
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

write

public final long write(ByteBuffer[] srcs)
                 throws IOException
将数据报写入此通道。

仅在此通道的套接字已连接时才调用此方法，在这种情况下，此方法将数据报直接发送到套接字的同位体。否则此方法的行为与 GatheringByteChannel 接口中指定的行为完全相同。

指定者：
接口 GatheringByteChannel 中的 write
返回：
发送的字节数，可能是调用此方法时源缓冲区中剩余的字节数，或者如果此通道处于非阻塞模式并且底层输出缓冲区中没有足够的空间供数据报使用，则可能为零
抛出：
NotYetConnectedException - 如果未连接此通道的套接字
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 FileChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.FileChannel
所有已实现的接口：
Closeable, ByteChannel, Channel, GatheringByteChannel, InterruptibleChannel, ReadableByteChannel, ScatteringByteChannel, WritableByteChannel
public abstract class FileChannel
extends AbstractInterruptibleChannel
implements ByteChannel, GatheringByteChannel, ScatteringByteChannel

用于读取、写入、映射和操作文件的通道。

文件通道在其文件中有一个当前 position，可对其进行查询和修改。该文件本身包含一个可读写的长度可变的字节序列，并且可以查询该文件的当前大小。写入的字节超出文件的当前大小时，则增加文件的大小；截取 该文件时，则减小文件的大小。文件可能还有某个相关联的元数据，如访问权限、内容类型和最后的修改时间；此类未定义访问元数据的方法。

除了字节通道中常见的读取、写入和关闭操作外，此类还定义了下列特定于文件的操作：

  • 以不影响通道当前位置的方式，对文件中绝对位置的字节进行读取或写入。

  • 将文件中的某个区域直接映射到内存中；对于较大的文件，这通常比调用普通的 read 或 write 方法更为高效。

  • 强制对底层存储设备进行文件的更新，确保在系统崩溃时不丢失数据。

  • 以一种可被很多操作系统优化为直接向文件系统缓存发送或从中读取的高速传输方法，将字节从文件传输到某个其他通道中，反之亦然。

  • 可以锁定某个文件区域，以阻止其他程序对其进行访问。

多个并发线程可安全地使用文件通道。可随时调用关闭方法，正如 Channel 接口中所指定的。对于涉及通道位置或者可以更改其文件大小的操作，在任意给定时间只能进行一个这样的操作；如果尝试在第一个操作仍在进行时发起第二个操作，则会导致在第一个操作完成之前阻塞第二个操作。可以并发处理其他操作，特别是那些采用显式位置的操作；但是否并发处理则取决于基础实现，因此是未指定的。

确保此类的实例所提供的文件视图与同一程序中其他实例所提供的相同文件视图是一致的。但是，此类的实例所提供的视图不一定与其他并发运行的程序所看到的视图一致，这取决于底层操作系统所执行的缓冲策略和各种网络文件系统协议所引入的延迟。不管其他程序是以何种语言编写的，而且也不管是运行在相同机器还是不同机器上都是如此。此种不一致的确切性质取决于系统，因此是未指定的。

此类没有定义打开现有文件或创建新文件的方法，以后的版本中可能添加这些方法。在此版本中，可从现有的 FileInputStream、FileOutputStream 或 RandomAccessFile 对象获得文件通道，方法是调用该对象的 getChannel 方法，这会返回一个连接到相同底层文件的文件通道。

文件通道的状态与其 getChannel 返回该通道的对象密切相关。显式或者通过读取或写入字节来更改通道的位置将更改发起对象的文件位置，反之亦然。通过文件通道更改此文件的长度将更改通过发起对象看到的长度，反之亦然。通过写入字节更改此文件的内容将更改发起对象所看到的内容，反之亦然。

此类在各种情况下指定要求“允许读取操作”、“允许写入操作”或“允许读取和写入操作”的某个实例。通过 FileInputStream 实例的 getChannel 方法所获得的通道将允许进行读取操作。通过 FileOutputStream 实例的 getChannel 方法所获得的通道将允许进行写入操作。最后，如果使用模式 "r" 创建 RandomAccessFile 实例，则通过该实例的 getChannel 方法所获得的通道将允许进行读取操作，如果使用模式 "rw" 创建实例，则获得的通道将允许进行读取和写入操作。

如果从文件输出流中获得了允许进行写入操作的文件通道，并且该输出流是通过调用 FileOutputStream(File,boolean) 构造方法且为第二个参数传入 true 来创建的，则该文件通道可能处于添加模式。在此模式中，每次调用相关的写入操作都会首先将位置移到文件的末尾，然后再写入请求的数据。在单个原子操作中是否移动位置和写入数据是与系统相关的，因此是未指定的。

从以下版本开始：
1.4
另请参见：
FileInputStream.getChannel(),
FileOutputStream.getChannel(),
RandomAccessFile.getChannel()

嵌套类摘要
static class FileChannel.MapMode
文件映射模式的类型安全的枚举。
构造方法摘要
protected FileChannel()
初始化此类的一个新实例。
方法摘要
abstract void | force(boolean metaData) 强制将所有对此通道的文件更新写入包含该文件的存储设备中。
FileLock | lock() 获取对此通道的文件的独占锁定。
abstract FileLock | lock(long position, long size, boolean shared) 获取此通道的文件给定区域上的锁定。
abstract MappedByteBuffer | map(FileChannel.MapMode mode, long position, long size) 将此通道的文件区域直接映射到内存中。
abstract long | position() 返回此通道的文件位置。
abstract FileChannel | position(long newPosition) 设置此通道的文件位置。
abstract int | read(ByteBuffer dst) 将字节序列从此通道读入给定的缓冲区。
long | read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
abstract long | read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
abstract int | read(ByteBuffer dst, long position) 从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。
abstract long | size() 返回此通道的文件的当前大小。
abstract long | transferFrom(ReadableByteChannel src, long position, long count) 将字节从给定的可读取字节通道传输到此通道的文件中。
abstract long | transferTo(long position, long count, WritableByteChannel target) 将字节从此通道的文件传输到给定的可写入字节通道。
abstract FileChannel | truncate(long size) 将此通道的文件截取为给定大小。
FileLock | tryLock() 试图获取对此通道的文件的独占锁定。
abstract FileLock | tryLock(long position, long size, boolean shared) 试图获取对此通道的文件给定区域的锁定。
abstract int | write(ByteBuffer src) 将字节序列从给定的缓冲区写入此通道。
long | write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
abstract long | write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
abstract int | write(ByteBuffer src, long position) 从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, implCloseChannel, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

FileChannel

protected FileChannel()
初始化此类的一个新实例。

方法详细信息

read

public abstract int read(ByteBuffer dst)
                  throws IOException
将字节序列从此通道读入给定的缓冲区。

从此通道的当前文件位置开始读取字节，然后使用实际读取的字节数更新该文件位置。否则此方法的行为与 ReadableByteChannel 接口中指定的行为完全相同。

指定者：
接口 ReadableByteChannel 中的 read
参数：
dst - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

public abstract long read(ByteBuffer[] dsts,
                          int offset,
                          int length)
                   throws IOException
将字节序列从此通道读入给定缓冲区的子序列中。

从此通道的当前文件位置开始读取字节，然后使用实际读取的字节数更新该文件位置。否则此方法的行为与 ScatteringByteChannel 接口中指定的行为完全相同。

指定者：
接口 ScatteringByteChannel 中的 read
参数：
dsts - 要向其中传输字节的缓冲区
offset - 第一个缓冲区（字节传输到该缓冲区中）在缓冲区数组中的偏移量；必须为非负数并且不能大于 dsts.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 dsts.length - offset
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

public final long read(ByteBuffer[] dsts)
                throws IOException
将字节序列从此通道读入给定的缓冲区。

从此通道的当前文件位置开始读取字节，然后使用实际读取的字节数更新该文件位置。否则此方法的行为与 ScatteringByteChannel 接口中指定的行为完全相同。

指定者：
接口 ScatteringByteChannel 中的 read
参数：
dsts - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

write

public abstract int write(ByteBuffer src)
                   throws IOException
将字节序列从给定的缓冲区写入此通道。

从此通道的当前文件位置开始写入字节，但是如果该通道处于添加模式，则首先将该位置移到文件的末尾。如有必要，可以扩大文件以容纳写入的字节，然后使用实际写入的字节数更新该文件位置。否则此方法的行为与 WritableByteChannel 接口所指定的行为完全相同。

指定者：
接口 WritableByteChannel 中的 write
参数：
src - 要从中获取字节的缓冲区
返回：
写入的字节数，可能为零
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

write

public abstract long write(ByteBuffer[] srcs,
                           int offset,
                           int length)
                    throws IOException
将字节序列从给定缓冲区的子序列写入此通道。

从此通道的当前文件位置开始写入字节，但是如果该通道处于添加模式，则首先将位置移到文件的末尾。如有必要，可以扩大文件以容纳写入的字节，然后使用实际写入的字节数更新该文件位置。否则此方法的行为与 GatheringByteChannel 接口中指定的行为完全相同。

指定者：
接口 GatheringByteChannel 中的 write
offset - 第一个缓冲区（要获取该缓冲区中的字节）在缓冲区数组中的偏移量；必须为非负数并且不能大于 srcs.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 srcs.length - offset
返回：
写入的字节数，可能为零
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

write

public final long write(ByteBuffer[] srcs)
                 throws IOException
将字节序列从给定的缓冲区写入此通道。

从此通道的当前文件位置开始写入字节，但是如果该通道处于添加模式，则首先将位置移到文件的末尾。如有必要，可以扩大文件以容纳写入的字节，然后使用实际写入的字节数更新该文件位置。否则此方法的行为与 GatheringByteChannel 接口中指定的行为完全相同。

指定者：
接口 GatheringByteChannel 中的 write
返回：
写入的字节数，可能为零
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

position

public abstract long position()
                       throws IOException
返回此通道的文件位置。

返回：
此通道的文件位置，这是一个非负整数，它计算从文件的开始到当前位置之间的字节数
抛出：
ClosedChannelException - 如果此通道已关闭
IOException - 如果发生其他 I/O 错误

position

public abstract FileChannel position(long newPosition)
                              throws IOException
设置此通道的文件位置。

将该位置设置为大于文件当前大小的值是合法的，但这不会更改文件的大小。稍后试图在这样的位置读取字节将立即返回已到达文件末尾的指示。稍后试图在这种位置写入字节将导致文件扩大，以容纳新的字节；在以前文件末尾和新写入字节之间的字节值是未指定的。

参数：
newPosition - 新位置，这是一个非负整数，它计算从文件开始的字节数
返回：
此文件通道
抛出：
ClosedChannelException - 如果此通道已关闭
IllegalArgumentException - 如果 newPosition 为负
IOException - 如果发生其他 I/O 错误

size

public abstract long size()
                   throws IOException
返回此通道的文件的当前大小。

返回：
此通道的文件的当前大小，以字节为单位
抛出：
ClosedChannelException - 如果此通道已关闭
IOException - 如果发生其他 I/O 错误

truncate

public abstract FileChannel truncate(long size)
                              throws IOException
将此通道的文件截取为给定大小。

如果给定大小小于该文件的当前大小，则截取该文件，丢弃文件新末尾后面的所有字节。如果给定大小大于等于该文件的当前大小，则不修改文件。无论是哪种情况，如果此通道的文件位置大于给定大小，则将位置设置为该大小。

参数：
size - 新的大小，非负的字节计数
返回：
此文件通道
抛出：
NonWritableChannelException - 如果不允许对此通道进行写入操作
ClosedChannelException - 如果此通道已关闭
IllegalArgumentException - 如果新的 size 为负
IOException - 如果发生其他 I/O 错误

force

public abstract void force(boolean metaData)
                    throws IOException
强制将所有对此通道的文件更新写入包含该文件的存储设备中。

如果此通道的文件驻留在本地存储设备上，则此方法返回时可保证：在此通道创建后或在最后一次调用此方法后对该文件进行的所有更改都已写入该设备中。这对确保在系统崩溃时不会丢失重要信息特别有用。

如果该文件不在本地设备上，则无法提供这样的保证。

metaData 参数可用于限制此方法必需执行的 I/O 操作数量。为此参数传入 false 指示只需将对文件内容的更新写入存储设备；传入 true 则指示必须写入对文件内容和元数据的更新，这通常需要一个以上的 I/O 操作。此参数是否实际有效取决于底层操作系统，因此是未指定的。

调用此方法可能导致发生 I/O 操作，即使该通道仅允许进行读取操作时也是如此。例如，某些操作系统将最后一次访问的时间作为元数据的一部分进行维护，每当读取文件时就更新此时间。实际是否执行操作是与操作系统相关的，因此是未指定的。

此方法只保证强制进行通过此类中已定义的方法对此通道的文件所进行的更改。此方法不一定强制进行那些通过修改已映射字节缓冲区（通过调用 map 方法获得）的内容所进行的更改。调用已映射字节缓冲区的 force 方法将强行对要写入缓冲区的内容进行更改。

参数：
metaData - 如果为 true，则需要此方法强制对要写入存储设备的文件内容和元数据进行更改；否则只需强行写入内容更改
抛出：
ClosedChannelException - 如果此通道已关闭
IOException - 如果发生其他 I/O 错误

transferTo

public abstract long transferTo(long position,
                                long count,
                                WritableByteChannel target)
                         throws IOException
将字节从此通道的文件传输到给定的可写入字节通道。

试图读取从此通道的文件中给定 position 处开始的 count 个字节，并将其写入目标通道。此方法的调用不一定传输所有请求的字节；是否传输取决于通道的性质和状态。如果此通道的文件从给定的 position 处开始所包含的字节数小于 count 个字节，或者如果目标通道是非阻塞的并且其输出缓冲区中的自由空间少于 count 个字节，则所传输的字节数要小于请求的字节数。

此方法不修改此通道的位置。如果给定的位置大于该文件的当前大小，则不传输任何字节。如果目标通道中有该位置，则从该位置开始写入各字节，然后将该位置增加写入的字节数。

与从此通道读取并将内容写入目标通道的简单循环语句相比，此方法可能高效得多。很多操作系统可将字节直接从文件系统缓存传输到目标通道，而无需实际复制各字节。

参数：
position - 文件中的位置，从此位置开始传输；必须为非负数
count - 要传输的最大字节数；必须为非负数
target - 目标通道
返回：
实际已传输的字节数，可能为零
抛出：
IllegalArgumentException - 如果关于参数的前提不成立
NonReadableChannelException - 如果不允许从此通道进行读取操作
NonWritableChannelException - 如果目标通道不允许进行写入操作
ClosedChannelException - 如果此通道或目标通道已关闭
AsynchronousCloseException - 如果正在进行传输时另一个线程关闭了任一通道
ClosedByInterruptException - 如果正在进行传输时另一个线程中断了当前线程，因此关闭了两个通道并将当前线程设置为中断
IOException - 如果发生其他 I/O 错误

transferFrom

public abstract long transferFrom(ReadableByteChannel src,
                                  long position,
                                  long count)
                           throws IOException
将字节从给定的可读取字节通道传输到此通道的文件中。

试着从源通道中最多读取 count 个字节，并将其写入到此通道的文件中从给定 position 处开始的位置。此方法的调用不一定传输所有请求的字节；是否传输取决于通道的性质和状态。如果源通道的剩余空间小于 count 个字节，或者如果源通道是非阻塞的并且其输入缓冲区中直接可用的空间小于 count 个字节，则所传输的字节数要小于请求的字节数。

此方法不修改此通道的位置。如果给定的位置大于该文件的当前大小，则不传输任何字节。如果该位置在源通道中，则从该位置开始读取各字节，然后将该位置增加读取的字节数。

与从源通道读取并将内容写入此通道的简单循环语句相比，此方法可能高效得多。很多操作系统可将字节直接从源通道传输到文件系统缓存，而无需实际复制各字节。

参数：
src - 源通道
position - 文件中的位置，从此位置开始传输；必须为非负数
count - 要传输的最大字节数；必须为非负数
返回：
实际已传输的字节数，可能为零
抛出：
IllegalArgumentException - 如果关于参数的前提不成立
NonReadableChannelException - 如果不允许从源通道进行读取操作
NonWritableChannelException - 如果不允许对此通道进行写入操作
ClosedChannelException - 如果此通道或源通道已关闭
AsynchronousCloseException - 如果正在进行传输时另一个线程关闭了任一通道
ClosedByInterruptException - 如果正在进行传输时另一个线程中断了当前线程，因此关闭了两个通道并将当前线程设置为中断
IOException - 如果发生其他 I/O 错误

read

public abstract int read(ByteBuffer dst,
                         long position)
                  throws IOException
从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。

除了从给定的文件位置开始读取各字节，而不是从该通道的当前位置外，此方法的执行方式与 read(ByteBuffer) 方法相同。此方法不修改此通道的位置。如果给定的位置大于该文件的当前大小，则不读取任何字节。

参数：
dst - 要向其中传输字节的缓冲区
position - 开始传输的文件位置；必须为非负数
返回：
读取的字节数，可能为零，如果给定的位置大于等于该文件的当前大小，则返回 -1
抛出：
IllegalArgumentException - 如果 position 为负
NonReadableChannelException - 如果不允许从此通道进行读取操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

write

public abstract int write(ByteBuffer src,
                          long position)
                   throws IOException
从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。

除了从给定的文件位置开始写入各字节，而不是从该通道的当前位置外，此方法的执行方式与 write(ByteBuffer) 方法相同。此方法不修改此通道的位置。如果给定的位置大于该文件的当前大小，则该文件将扩大以容纳新的字节；在以前文件末尾和新写入字节之间的字节值是未指定的。

参数：
src - 要传输其中字节的缓冲区
position - 开始传输的文件位置；必须为非负数
返回：
写入的字节数，可能为零
抛出：
IllegalArgumentException - 如果 position 为负
NonWritableChannelException - 如果不允许对此通道进行写入操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

map

public abstract MappedByteBuffer map(FileChannel.MapMode mode,
                                     long position,
                                     long size)
                              throws IOException
将此通道的文件区域直接映射到内存中。

可以通过下列三种模式将文件区域映射到内存中：

  • 只读： 试图修改得到的缓冲区将导致抛出 ReadOnlyBufferException。(MapMode.READ_ONLY)

  • 读/写： 对得到的缓冲区的更改最终将传播到文件；该更改对映射到同一文件的其他程序不一定是可见的。 (MapMode.READ_WRITE)

  • 专用： 对得到的缓冲区的更改不会传播到文件，并且该更改对映射到同一文件的其他程序也不是可见的；相反，会创建缓冲区已修改部分的专用副本。 (MapMode.PRIVATE)

对于只读映射关系，此通道必须可以进行读取操作；对于读取/写入或专用映射关系，此通道必须可以进行读取和写入操作。

此方法返回的已映射字节缓冲区具有的位置为零，限制和容量为 size；其标记是不确定的。在缓冲区本身被作为垃圾回收之前，该缓冲区及其表示的映射关系都是有效的。

映射关系一经创建，就不再依赖于创建它时所用的文件通道。特别是关闭该通道对映射关系的有效性没有任何影响。

很多内存映射文件的细节从根本上是取决于底层操作系统的，因此是未指定的。当所请求的区域没有完全包含在此通道的文件中时，此方法的行为是未指定的。未指定是否将此程序或另一个程序对底层文件的内容或大小所进行的更改传播到缓冲区。未指定将对缓冲区的更改传播到文件的频率。

对于大多数操作系统而言，与通过普通的 read 和 write 方法读取或写入数千字节的数据相比，将文件映射到内存中开销更大。从性能的观点来看，通常将相对较大的文件映射到内存中才是值得的。

参数：
mode - 根据是按只读、读取/写入或专用（写入时拷贝）来映射文件，分别为 FileChannel.MapMode 类中所定义的 READ_ONLY、READ_WRITE 或 PRIVATE 之一
position - 文件中的位置，映射区域从此位置开始；必须为非负数
size - 要映射的区域大小；必须为非负数且不大于 Integer.MAX_VALUE
抛出：
NonReadableChannelException - 如果 mode 是 READ_ONLY，但是不允许对此通道进行读取操作
NonWritableChannelException - 如果 mode 是 READ_WRITE 或 PRIVATE，但是不允许此通道进行读取和写入操作
IllegalArgumentException - 如果关于参数的前提不成立
IOException - 如果发生其他 I/O 错误
另请参见：
FileChannel.MapMode, MappedByteBuffer

lock

public abstract FileLock lock(long position,
                              long size,
                              boolean shared)
                       throws IOException
获取此通道的文件给定区域上的锁定。

在可以锁定该区域、已关闭此通道或者已中断调用线程（以先到者为准）之前，将阻塞此方法的调用。

如果在此方法调用期间另一个线程关闭了此通道，则抛出 AsynchronousCloseException。

如果在等待获取锁定的同时中断了调用线程，则将状态设置为中断并抛出 FileLockInterruptionException。如果调用此方法时已设置调用方的中断状态，则立即抛出该异常；不更改该线程的中断状态。

由 position 和 size 参数所指定的区域无需包含在实际的底层文件中，甚至无需与文件重叠。锁定区域的大小是固定的；如果某个已锁定区域最初包含整个文件，并且文件因扩大而超出了该区域，则该锁定不覆盖此文件的新部分。如果期望文件大小扩大并且要求锁定整个文件，则应该锁定从零开始，到不小于期望最大文件大小的区域。零参数的 lock() 方法只是锁定大小为 Long.MAX_VALUE 的区域。

某些操作系统不支持共享锁定，在这种情况下，自动将对共享锁定的请求转换为对独占锁定的请求。可通过调用所得锁定对象的 isShared 方法来测试新获取的锁定是共享的还是独占的。

文件锁定是以整个 Java 虚拟机来保持的。但它们不适用于控制同一虚拟机内多个线程对文件的访问。

参数：
position - 锁定区域开始的位置；必须为非负数
size - 锁定区域的大小；必须为非负数，并且 position + size 的和必须为非负数
shared - 要请求共享锁定，则为 true，在这种情况下此通道必须允许进行读取（可能是写入）操作；要请求独占锁定，则为 false，在这种情况下此通道必须允许进行写入（可能是读取）操作
返回：
一个锁定对象，表示新获取的锁定
抛出：
IllegalArgumentException - 如果关于参数的前提不成立
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果调用线程阻塞于此方法中时另一个线程关闭了此通道
FileLockInterruptionException - 如果调用线程阻塞于此方法中时被中断
OverlappingFileLockException - 如果此 Java 虚拟机已经持有与所请求区域重叠的锁定，或者如果另一个线程已阻塞于此方法中并且正在试图锁定一个重叠区域
NonReadableChannelException - 如果 shared 为 true，但此通道不允许进行读取操作
NonWritableChannelException - 如果 shared 为 false，但此通道不允许进行写入操作
IOException - 如果发生其他 I/O 错误
另请参见：
lock(),
tryLock(),
tryLock(long,long,boolean)

lock

public final FileLock lock()
                    throws IOException
获取对此通道的文件的独占锁定。

调用此方法的形式为 fc.lock(), 该调用与以下调用完全相同：

     fc.lock(0L, Long.MAX_VALUE, false)

返回：
一个锁定对象，表示新获取的锁定
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果调用线程阻塞于此方法中时另一个线程关闭了此通道
FileLockInterruptionException - 如果调用线程阻塞于此方法中时被中断
OverlappingFileLockException - 如果此 Java 虚拟机已经持有与所请求区域重叠的锁定，或者如果另一个线程已阻塞在此方法中并且正在试图锁定同一文件的重叠区域
NonWritableChannelException - 如果没有为写入打开此通道
IOException - 如果发生其他 I/O 错误
另请参见：
lock(long,long,boolean),
tryLock(),
tryLock(long,long,boolean)

tryLock

public abstract FileLock tryLock(long position,
                                 long size,
                                 boolean shared)
                          throws IOException
试图获取对此通道的文件给定区域的锁定。

此方法不会阻塞。无论是否已成功地获得请求区域上的锁定，调用总是立即返回。如果由于另一个程序保持着一个重叠锁定而无法获取锁定，则此方法返回 null。如果由于任何其他原因而无法获取锁定，则抛出相应的异常。

由 position 和 size 参数所指定的区域无需包含在实际的底层文件中，甚至无需与文件重叠。锁定区域的大小是固定的；如果某个已锁定区域最初包含整个文件，但文件因扩大而超出了该区域，则该锁定不覆盖此文件的新部分。如果期望文件大小扩大并且要求锁定整个文件，则应该锁定从零开始，到不小于期望最大文件大小为止的区域。零参数的 tryLock() 方法只是锁定大小为 Long.MAX_VALUE 的区域。

某些操作系统不支持共享锁定，在这种情况下，自动将对共享锁定的请求转换为对独占锁定的请求。可通过调用所得锁定对象的 isShared 方法来测试新获取的锁定是共享的还是独占的。

文件锁定以整个 Java 虚拟机来保持。但它们不适用于控制同一虚拟机内多个线程对文件的访问。

参数：
position - 锁定区域开始的位置；必须为非负数
size - 锁定区域的大小；必须为非负数，并且 position + size 的和必须为非负数
shared - 要请求共享锁定，则为 true，要请求独占锁定，则为 false
返回：
一个锁定对象，表示新获取的锁定，如果由于另一个程序保持着一个重叠锁定而无法获取锁定，则返回 null
抛出：
IllegalArgumentException - 如果关于参数的前提不成立
ClosedChannelException - 如果此通道已关闭
OverlappingFileLockException - 如果此 Java 虚拟机已经持有与所请求区域重叠的锁定，或者如果另一个线程已阻塞在此方法中并且正在试图锁定同一文件的重叠区域
IOException - 如果发生其他 I/O 错误
另请参见：
lock(),
lock(long,long,boolean),
tryLock()

tryLock

public final FileLock tryLock()
                       throws IOException
试图获取对此通道的文件的独占锁定。

调用此方法的形式为 fc.tryLock(), 该调用与以下调用完全相同：

     fc.tryLock(0L, Long.MAX_VALUE, false)

返回：
一个锁定对象，表示新获取的锁定，如果由于另一个程序保持着一个重叠锁定而无法获取锁定，则返回 null
抛出：
ClosedChannelException - 如果此通道已关闭
OverlappingFileLockException - 如果此 Java 虚拟机已经持有与所请求区域重叠的锁定，或者如果另一个线程已阻塞于此方法中并且正在试图锁定一个重叠区域
IOException - 如果发生其他 I/O 错误
另请参见：
lock(),
lock(long,long,boolean),
tryLock(long,long,boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileChannel.MapMode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 FileChannel.MapMode

java.lang.Object
    继承者  java.nio.channels.FileChannel.MapMode
正在封闭类：
FileChannel
public static class FileChannel.MapMode
extends Object

文件映射模式的类型安全的枚举。

从以下版本开始：
1.4
另请参见：
FileChannel.map(java.nio.channels.FileChannel.MapMode, long, long)

字段摘要
static FileChannel.MapMode | PRIVATE 专用（写入时拷贝）映射模式。
static FileChannel.MapMode | READ_ONLY 只读映射模式。
static FileChannel.MapMode | READ_WRITE 读取/写入映射模式。
方法摘要
 String toString()
返回描述此文件映射模式的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

READ_ONLY

public static final FileChannel.MapMode READ_ONLY
只读映射模式。

READ_WRITE

public static final FileChannel.MapMode READ_WRITE
读取/写入映射模式。

PRIVATE

public static final FileChannel.MapMode PRIVATE
专用（写入时拷贝）映射模式。

方法详细信息

toString

public String toString()
返回描述此文件映射模式的字符串。

覆盖：
类 Object 中的 toString
返回：
一个描述性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileLock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 FileLock

java.lang.Object
    继承者  java.nio.channels.FileLock

public abstract class FileLock
extends Object

表示文件区域锁定的标记。

每次通过 FileChannel 类的 lock 或 tryLock 方法获取文件上的锁定时，就会创建一个文件锁定对象。

文件锁定对象最初是有效的。通过调用 release 方法、关闭用于获取该锁定的通道，或者终止 Java 虚拟机（以先到者为准）来释放锁定之前，该对象一直是有效的。可通过调用锁定的 isValid 方法来测试锁定的有效性。

文件锁定要么是独占的，要么是共享的。共享锁定可阻止其他并发运行的程序获取重叠的独占锁定，但是允许该程序获取重叠的共享锁定。独占锁定则阻止其他程序获取任一类型的重叠锁定。一旦释放某个锁定后，它就不会再对其他程序所获取的锁定产生任何影响。

可通过调用某个锁定的 isShared 方法来确定它是独占的还是共享的。某些平台不支持共享锁定，在这种情况下，对共享锁定的请求被自动转换为对独占锁定的请求。

单个 Java 虚拟机在某个特定文件上所保持的锁定是不重叠的。要测试某个候选锁定范围是否与现有锁定重叠，可使用 overlaps 方法。

文件锁定对象记录了在其文件上保持锁定的文件通道、该锁定的类型和有效性，以及锁定区域的位置和大小。只有锁定的有效性是随时间而更改的；锁定状态的所有其他方面都是不可变的。

文件锁定以整个 Java 虚拟机来保持。但它们不适用于控制同一虚拟机内多个线程对文件的访问。

多个并发线程可安全地使用文件锁定对象。

平台依赖性

此文件锁定 API 直接映射到底层操作系统的本机锁定设施。因此，无论程序是用何种语言编写的，某个文件上所保持的锁定对于所有访问该文件的程序来说都应该是可见的。

某个锁定是否实际阻止另一个程序访问该锁定区域的内容是与系统相关的，因此是未指定的。有些系统的本机文件锁定设施只是劝告的，意味着为了保证数据的完整性，各个程序必须遵守已知的锁定协议。其他系统本机文件锁定是强制的，意味着如果某个程序锁定了某个文件区域，则实际上阻止其他程序以违反该锁定的方式访问该区域。但在其他系统上，本机文件锁定是劝告的还是强制的可以以每个文件为基础进行配置。为确保平台间的一致性和正确性，强烈建议将此 API 提供的锁定作为劝告锁定来使用。

在有些系统上，在某个文件区域上获取强制锁定会阻止该区域被 java.nio.channels.FileChannel#map映射到内存，反之亦然。组合锁定和映射的程序应该为此组合的失败做好准备。

在有些系统上，关闭某个通道会释放 Java 虚拟机在底层文件上所保持的所有锁定，而不管该锁定是通过该通道获取的，还是通过同一文件上打开的另一个通道获取的。强烈建议在某个程序内使用唯一的通道来获取任意给定文件上的所有锁定。

有些网络文件系统仅在锁定区域是页对齐的并且是多个底层硬件的总的页大小时，才允许文件锁定与内存映射文件一起使用。有些网络文件系统不对扩展超出某个位置（通常是 230 或 231）的区域实现文件锁定。通常，对驻留在网络文件系统上的文件进行锁定时应该极其小心。

从以下版本开始：
1.4

构造方法摘要
protected FileLock(FileChannel channel, long position, long size, boolean shared)
初始化此类的一个新实例。
方法摘要
FileChannel | channel() 返回文件通道，此锁定保持在该通道的文件上。
boolean | isShared() 判断此锁定是否为共享的。
abstract boolean | isValid() 判断此锁定是否有效。
boolean | overlaps(long position, long size) 判断此锁定是否与给定的锁定区域重叠。
long | position() 返回文件内锁定区域中第一个字节的位置。
abstract void | release() 释放此锁定。
long | size() 返回锁定区域的大小，以字节为单位。
String | toString() 返回描述此锁定的范围、类型和有效性的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FileLock

protected FileLock(FileChannel channel,
                   long position,
                   long size,
                   boolean shared)
初始化此类的一个新实例。

参数：
channel - 文件通道，此锁定保持在该通道的文件上
position - 文件中的位置，锁定区域从此位置开始；必须为非负数
size - 锁定区域的大小；必须为非负数，并且 position + size 的和必须为非负数
shared - 如果此锁定是共享的，则为 true，如果是独占的，则为 false
抛出：
IllegalArgumentException - 如果关于参数的前提不成立
方法详细信息

channel

public final FileChannel channel()
返回文件通道，此锁定保持在该通道的文件上。

返回：
文件通道

position

public final long position()
返回文件内锁定区域中第一个字节的位置。

锁定区域不必包含在实际的底层文件中，甚至不必与其重叠，所以此方法返回的值可能超出文件的当前大小。

返回：
位置

size

public final long size()
返回锁定区域的大小，以字节为单位。

锁定区域不必包含在实际的底层文件中，甚至不必与其重叠，所以此方法返回的值可能超出文件的当前大小。

返回：
锁定区域的大小

isShared

public final boolean isShared()
判断此锁定是否为共享的。

返回：
如果是共享的，则返回 true，如果是独占的，则返回 false

overlaps

public final boolean overlaps(long position,
                              long size)
判断此锁定是否与给定的锁定区域重叠。

返回：
当且仅当此锁定与给定的锁定区域至少重叠一个字节时才返回 true

isValid

public abstract boolean isValid()
判断此锁定是否有效。

在释放锁定对象或关闭与其关联的文件通道（以先到者为准）之前，该锁定对象保持有效。

返回：
当且仅当此锁定为有效时才返回 true

release

public abstract void release()
                      throws IOException
释放此锁定。

如果此锁定对象是有效的，则调用此方法会释放该锁定并使该对象无效。如果此锁定对象是无效的，则调用此方法无效。

抛出：
ClosedChannelException - 如果用于获取此锁定的通道不再处于打开状态
IOException - 如果发生 I/O 错误

toString

public final String toString()
返回描述此锁定的范围、类型和有效性的字符串。

覆盖：
类 Object 中的 toString
返回：
一个描述性的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Pipe (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 Pipe

java.lang.Object
    继承者  java.nio.channels.Pipe

public abstract class Pipe
extends Object

实现单向管道传送的通道对。

管道由一对通道组成：一个可写入的 sink 通道和一个可读取的 source 通道。一旦将某些字节写入接收器通道，就可以按照与写入时完全相同的顺序从源通道中读取这些字节。

在另一个线程从管道中读取这些字节或先前已写入的字节之前，是否阻塞将该字节写入管道的线程是与系统相关的，因此是未指定的。很多管道实现都对接收器和源通道之间一定数量的字节进行缓冲，但是不应假定会进行这种缓冲。

从以下版本开始：
1.4

嵌套类摘要
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
构造方法摘要
protected Pipe()
初始化此类的一个新实例。
方法摘要
static Pipe | open() 打开一个管道。
abstract Pipe.SinkChannel | sink() 返回此管道的接收器通道。
abstract Pipe.SourceChannel | source() 返回此管道的源通道。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Pipe

protected Pipe()
初始化此类的一个新实例。

方法详细信息

source

public abstract Pipe.SourceChannel source()
返回此管道的源通道。

返回：
此管道的源通道

sink

public abstract Pipe.SinkChannel sink()
返回此管道的接收器通道。

返回：
此管道的接收器通道

open

public static Pipe open()
                 throws IOException
打开一个管道。

通过调用系统级默认 SelectorProvider 对象的 openPipe 方法来创建新管道。

返回：
新管道
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileLockInterruptionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 FileLockInterruptionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.nio.channels.FileLockInterruptionException
所有已实现的接口：
Serializable
public class FileLockInterruptionException
extends IOException

当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。抛出此异常之前，将设置以前被阻塞的线程的中断状态。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
FileLockInterruptionException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FileLockInterruptionException

public FileLockInterruptionException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GatheringByteChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
接口 GatheringByteChannel

所有超级接口：
Channel, Closeable, WritableByteChannel
所有已知实现类：
DatagramChannel, FileChannel, Pipe.SinkChannel, SocketChannel
public interface GatheringByteChannel
extends WritableByteChannel

可从缓冲区序列写入字节的通道。

集中 写入操作可在单个调用中写入来自一个或多个给定缓冲区序列的字节序列。集中写入通常在实现网络协议或文件格式时很有用，例如将数据分组放入段中（这些段由一个或多个长度固定的头，后跟长度可变的正文组成）。在 ScatteringByteChannel 接口中定义了类似的分散 读取操作。

从以下版本开始：
1.4

方法摘要
long | write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
long | write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
从接口 java.nio.channels.WritableByteChannel 继承的方法
write
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

方法详细信息

write

long write(ByteBuffer[] srcs,
           int offset,
           int length)
           throws IOException
将字节序列从给定缓冲区的子序列写入此通道。

尝试最多向此通道中写入 r 个字节，其中 r 是给定缓冲区数组的指定子序列中剩余的字节数，也就是

 srcs[offset].remaining()
     + srcs[offset+1].remaining()
     + ... + srcs[offset+length-1].remaining()

假定写入长度为 n 的字节序列，其中 0 <= n <= r。从缓冲区 srcs[offset] 中写入此序列的前 srcs[offset].remaining() 个字节，然后从缓冲区 srcs[offset+1] 中写入后面的 srcs[offset+1].remaining() 个字节，依此类推，直到写入整个字节序列。从每个缓冲区中写入尽可能多的字节，因为要保证每个已更新缓冲区（最后一个已更新缓冲区除外）的最终位置等于该缓冲区的限制。

除非另行指定，否则仅在写入所有请求的 r 个字节后 write 操作才会返回。有些类型的通道（取决于它们的状态）可能仅写入某些字节或者可能根本不写入。例如，处于非阻塞模式的套接字通道无法写入超出该套接字输出缓冲区剩余空间的字节。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个写入操作，则在该操作完成前此方法的调用被阻塞。

参数：
src - 要获取其中字节的缓冲区
offset - 第一个缓冲区（要获取该缓冲区中的字节）在缓冲区数组中的偏移量；必须为非负数并且不能大于 srcs.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 srcs.length - offset
返回：
写入的字节数，可能为零
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
NonWritableChannelException - 如果不允许对此通道进行写入操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

write

long write(ByteBuffer[] srcs)
           throws IOException
将字节序列从给定的缓冲区写入此通道。

调用此方法的形式为 c.write(srcs) ，该调用与以下调用完全相同：

 c.write(srcs, 0, srcs.length);

参数：
src - 要获取其中字节的缓冲区
返回：
写入的字节数，可能为零
抛出：
NonWritableChannelException - 如果不允许对此通道进行写入操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalBlockingModeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 IllegalBlockingModeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.IllegalBlockingModeException
所有已实现的接口：
Serializable
public class IllegalBlockingModeException
extends IllegalStateException

当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
IllegalBlockingModeException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalBlockingModeException

public IllegalBlockingModeException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalSelectorException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 IllegalSelectorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.nio.channels.IllegalSelectorException
所有已实现的接口：
Serializable
public class IllegalSelectorException
extends IllegalArgumentException

试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
IllegalSelectorException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalSelectorException

public IllegalSelectorException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InterruptibleChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
接口 InterruptibleChannel

所有超级接口：
Channel, Closeable
所有已知实现类：
AbstractInterruptibleChannel, AbstractSelectableChannel, DatagramChannel, FileChannel, Pipe.SinkChannel, Pipe.SourceChannel, SelectableChannel, ServerSocketChannel, SocketChannel
public interface InterruptibleChannel
extends Channel

可被异步关闭和中断的通道。

实现此接口的通道是可异步关闭的：如果某个线程阻塞于可中断通道上的 I/O 操作中，则另一个线程可调用该通道的 close 方法。这将导致已阻塞线程接收到 AsynchronousCloseException。

实现此接口的通道也是可中断的：如果某个线程阻塞于可中断通道上的 I/O 操作中，则另一个线程可调用该阻塞线程的 interrupt 方法。这将导致该通道被关闭，已阻塞线程接收到 ClosedByInterruptException，并且设置已阻塞线程的中断状态。

如果已设置某个线程的中断状态并且它在通道上调用某个阻塞的 I/O 操作，则该通道将关闭并且该线程立即接收到 ClosedByInterruptException；并仍然设置其中断状态。

当且仅当某个通道实现此接口时，该通道才支持异步关闭和中断。如有必要，可在运行时通过 instanceof 操作符进行测试。

从以下版本开始：
1.4

方法摘要
 void close()
关闭此通道。
从接口 java.nio.channels.Channel 继承的方法
isOpen

方法详细信息

close

void close()
           throws IOException
关闭此通道。

所有当前阻塞于此通道上的 I/O 操作中的线程都将接收到 AsynchronousCloseException。

此方法的行为与 Channel 接口所指定的行为完全相同。

指定者：
接口 Channel 中的 close
指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoConnectionPendingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 NoConnectionPendingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.NoConnectionPendingException
所有已实现的接口：
Serializable
public class NoConnectionPendingException
extends IllegalStateException

在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
NoConnectionPendingException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoConnectionPendingException

public NoConnectionPendingException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NonReadableChannelException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 NonReadableChannelException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.NonReadableChannelException
所有已实现的接口：
Serializable
public class NonReadableChannelException
extends IllegalStateException

试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
NonReadableChannelException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NonReadableChannelException

public NonReadableChannelException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NonWritableChannelException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 NonWritableChannelException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.NonWritableChannelException
所有已实现的接口：
Serializable
public class NonWritableChannelException
extends IllegalStateException

试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
NonWritableChannelException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NonWritableChannelException

public NonWritableChannelException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotYetBoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 NotYetBoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.NotYetBoundException
所有已实现的接口：
Serializable
public class NotYetBoundException
extends IllegalStateException

试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
NotYetBoundException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotYetBoundException

public NotYetBoundException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotYetConnectedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 NotYetConnectedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.NotYetConnectedException
所有已实现的接口：
Serializable
public class NotYetConnectedException
extends IllegalStateException

试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
NotYetConnectedException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotYetConnectedException

public NotYetConnectedException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OverlappingFileLockException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 OverlappingFileLockException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.nio.channels.OverlappingFileLockException
所有已实现的接口：
Serializable
public class OverlappingFileLockException
extends IllegalStateException

试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
OverlappingFileLockException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OverlappingFileLockException

public OverlappingFileLockException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Pipe.SinkChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 Pipe.SinkChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.SelectableChannel
            继承者  java.nio.channels.spi.AbstractSelectableChannel
                继承者  java.nio.channels.Pipe.SinkChannel
所有已实现的接口：
Closeable, Channel, GatheringByteChannel, InterruptibleChannel, WritableByteChannel
正在封闭类：
Pipe
public abstract static class Pipe.SinkChannel
extends AbstractSelectableChannel
implements WritableByteChannel, GatheringByteChannel

表示 Pipe 的可写入结尾的通道。

从以下版本开始：
1.4

构造方法摘要
protected Pipe.SinkChannel(SelectorProvider provider)
初始化此类的一个新实例。
方法摘要
 int validOps()
返回一个操作集，标识此通道所支持的操作。
从类 java.nio.channels.spi.AbstractSelectableChannel 继承的方法
blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register
从类 java.nio.channels.SelectableChannel 继承的方法
register
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.GatheringByteChannel 继承的方法
write, write
从接口 java.nio.channels.WritableByteChannel 继承的方法
write
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

Pipe.SinkChannel

protected Pipe.SinkChannel(SelectorProvider provider)
初始化此类的一个新实例。

方法详细信息

validOps

public final int validOps()
返回一个操作集，标识此通道所支持的操作。

Pipe 的 SinkChannel 仅支持写入操作，所以此方法返回 SelectionKey.OP_WRITE。

指定者：
类 SelectableChannel 中的 validOps
返回：
有效操作集
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SelectionKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 SelectionKey

java.lang.Object
    继承者  java.nio.channels.SelectionKey
直接已知子类：
AbstractSelectionKey
public abstract class SelectionKey
extends Object

表示 SelectableChannel 在 Selector 中的注册的标记。

每次向选择器注册通道时就会创建一个选择键。通过调用某个键的 cancel 方法、关闭其通道，或者通过关闭其选择器来取消 该键之前，它一直保持有效。取消某个键不会立即从其选择器中移除它；相反，会将该键添加到选择器的已取消键集，以便在下一次进行选择操作时移除它。可通过调用某个键的 isValid 方法来测试其有效性。

选择键包含两个表示为整数值的操作集。操作集的每一位都表示该键的通道所支持的一类可选择操作。

  • interest 集合 确定了下一次调用某个选择器的选择方法时，将测试哪类操作的准备就绪信息。创建该键时使用给定的值初始化 interest 集合；之后可通过 interestOps(int) 方法对其进行更改。

  • ready 集合 标识了这样一类操作，即某个键的选择器检测到该键的通道已为此类操作准备就绪。创建该键时 ready 集合被初始化为零；可以在之后的选择操作中通过选择器对其进行更新，但不能直接更新它。

选择键的 ready 集合指示，其通道对某个操作类别已准备就绪，该指示只是一个提示，并不保证线程可执行此类别中的操作而不导致被阻塞。ready 集合很可能一完成选择操作就是准确的。ready 集合可能由于外部事件和在相应通道上调用的 I/O 操作而变得不准确。

此类定义了所有已知的操作集位 (operation-set bit)，但是给定的通道具体支持哪些位则取决于该通道的类型。SelectableChannel 的每个子类都定义了 validOps() 方法，该方法返回的集合恰好标识该通道支持的操作。试图设置或测试某个键的通道所不支持的操作集位将导致抛出相应的运行时异常。

通常必须将某个特定于应用程序的数据与某个选择键相关联，例如表示高级协议状态的对象和为了实现该协议而处理准备就绪通知的对象。因此，选择键支持将单个任意对象附加 到某个键的操作。可通过 attach 方法附加对象，然后通过 attachment 方法获取该对象。

多个并发线程可安全地使用选择键。一般情况下，读取和写入 interest 集合的操作将与选择器的某些操作保持同步。具体如何执行该同步与实现有关：在一般实现中，如果正在进行某个选择操作，那么读取或写入 interest 集合可能会无限期地阻塞；在高性能的实现中，可能只会暂时阻塞。无论在哪种情况下，选择操作将始终使用该操作开始时当前的 interest 集合值。

从以下版本开始：
1.4
另请参见：
SelectableChannel, Selector

字段摘要
static int | OP_ACCEPT 用于套接字接受操作的操作集位。
static int | OP_CONNECT 用于套接字连接操作的操作集位。
static int | OP_READ 用于读取操作的操作集位。
static int | OP_WRITE 用于写入操作的操作集位。
构造方法摘要
protected SelectionKey()
构造此类的一个实例。
方法摘要
Object | attach(Object ob) 将给定的对象附加到此键。
Object | attachment() 获取当前的附加对象。
abstract void | cancel() 请求取消此键的通道到其选择器的注册。
abstract SelectableChannel | channel() 返回为之创建此键的通道。
abstract int | interestOps() 获取此键的 interest 集合。
abstract SelectionKey | interestOps(int ops) 将此键的 interest 集合设置为给定值。
boolean | isAcceptable() 测试此键的通道是否已准备好接受新的套接字连接。
boolean | isConnectable() 测试此键的通道是否已完成其套接字连接操作。
boolean | isReadable() 测试此键的通道是否已准备好进行读取。
abstract boolean | isValid() 告知此键是否有效。
boolean | isWritable() 测试此键的通道是否已准备好进行写入。
abstract int | readyOps() 获取此键的 ready 操作集合。
abstract Selector | selector() 返回为此选择器创建的键。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OP_READ

public static final int OP_READ
用于读取操作的操作集位。

假定在选择操作开始时，选择键的 interest 集合中已包含 OP_READ。如果选择器检测到相应的通道已为读取准备就绪、已经到达流的末尾、已经被远程关闭而无法进行进一步的读取，或者有一个挂起的错误，那么它会向该键的 ready 集合中添加 OP_READ，并将该键添加到已选择键集中。

另请参见：
常量字段值

OP_WRITE

public static final int OP_WRITE
用于写入操作的操作集位。

假定在选择操作开始时，选择键的 interest 集合中已包含 OP_WRITE。如果选择器检测到相应的通道已为写入准备就绪、已经被远程关闭而无法进行进一步的写入，或者有一个挂起的错误，那么它会向该键的 ready 集合中添加 OP_WRITE，并将该键添加到已选择键集中。

另请参见：
常量字段值

OP_CONNECT

public static final int OP_CONNECT
用于套接字连接操作的操作集位。

假定在选择操作开始时，选择键的 interest 集合中已包含 OP_CONNECT。如果选择器检测到相应的套接字通道已为完成其连接序列而准备就绪，或者有一个挂起的错误，那么它会向该键的 ready 集合中添加 OP_CONNECT，并将该键添加到已选择键集中。

另请参见：
常量字段值

OP_ACCEPT

public static final int OP_ACCEPT
用于套接字接受操作的操作集位。

假定在选择操作开始时，选择键的 interest 集合中已包含 OP_ACCEPT。如果选择器检测到相应的服务器套接字通道已为接受另一个连接而准备就绪，或者有一个挂起的错误，那么它会向该键的 ready 集合中添加 OP_ACCEPT，并将该键添加到已选择键集中。

另请参见：
常量字段值
构造方法详细信息

SelectionKey

protected SelectionKey()
构造此类的一个实例。

方法详细信息

channel

public abstract SelectableChannel channel()
返回为之创建此键的通道。即使已取消该键，此方法仍继续返回通道。

返回：
此键的通道

selector

public abstract Selector selector()
返回为此选择器创建的键。即使已取消该键后，此方法仍将继续返回选择器。

返回：
此键的选择器

isValid

public abstract boolean isValid()
告知此键是否有效。

键在创建时是有效的，并在被取消、其通道已关闭或者其选择器已关闭之前保持有效。

返回：
当且仅当此键有效时才返回 true

cancel

public abstract void cancel()
请求取消此键的通道到其选择器的注册。一旦返回，该键就是无效的，并且将被添加到其选择器的已取消键集中。在进行下一次选择操作时，将从所有选择器的键集中移除该键。

如果已取消了此键，则调用此方法无效。一旦取消某个键，该键会一直保持无效。

可在任意时间调用此方法。此方法与选择器的已取消键集保持同步，因此如果通过涉及同一选择器的取消或选择操作并发调用它，则它可能会暂时受阻塞。

interestOps

public abstract int interestOps()
获取此键的 interest 集合。

可保证返回的集合仅包含对于此键的通道而言有效的操作位。

可在任意时间调用此方法。是否受阻塞，以及阻塞时间长短都是与实现相关的。

返回：
此键的 interest 集合
抛出：
CancelledKeyException - 如果已取消此键

interestOps

public abstract SelectionKey interestOps(int ops)
将此键的 interest 集合设置为给定值。

可在任意时间调用此方法。是否受阻塞，以及阻塞时间长短都是与实现相关的。

参数：
ops - 新的 interest 集合
返回：
此选择键
抛出：
IllegalArgumentException - 如果集合中的某个位与此键的通道所支持的某个操作不对应，也就是说，如果 set & ~(channel().validOps()) != 0
CancelledKeyException - 如果已取消此键

readyOps

public abstract int readyOps()
获取此键的 ready 操作集合。

可保证返回的集合仅包含对于此键的通道而言有效的操作位。

返回：
此键的 ready 操作集合
抛出：
CancelledKeyException - 如果已取消此键

isReadable

public final boolean isReadable()
测试此键的通道是否已准备好进行读取。

调用此方法的形式为 k.isReadable() ，该调用与以下调用的作用完全相同：

 k.readyOps() & OP_READ != 0

如果此键的通道不支持读取操作，则此方法始终返回 false。

返回：
当且仅当 readyOps() & OP_READ 为非零值时才返回 true
抛出：
CancelledKeyException - 如果已取消此键

isWritable

public final boolean isWritable()
测试此键的通道是否已准备好进行写入。

调用此方法的形式为 k.isWritable() ，该调用与以下调用的作用完全相同：

 k.readyOps() & OP_WRITE != 0

如果此键的通道不支持写入操作，则此方法始终返回 false。

返回：
当且仅当 readyOps() & OP_WRITE 为非零值时才返回 true
抛出：
CancelledKeyException - 如果已取消此键

isConnectable

public final boolean isConnectable()
测试此键的通道是否已完成其套接字连接操作。

调用此方法的形式为 k.isConnectable() ，该调用与以下调用的作用完全相同：

 k.readyOps() & OP_CONNECT != 0

如果此键的通道不支持套接字连接操作，则此方法始终返回 false。

返回：
当且仅当 readyOps() & OP_CONNECT 为非零值时才返回 true
抛出：
CancelledKeyException - 如果已取消此键

isAcceptable

public final boolean isAcceptable()
测试此键的通道是否已准备好接受新的套接字连接。

调用此方法的形式为 k.isAcceptable() 形式，该调用与以下调用的作用完全相同：

 k.readyOps() & OP_ACCEPT != 0

如果此键的通道不支持套接字接受操作，则此方法始终返回 false。

返回：
当且仅当 readyOps() & OP_ACCEPT 为非零值时才返回 true
抛出：
CancelledKeyException - 如果已取消此键

attach

public final Object attach(Object ob)
将给定的对象附加到此键。

之后可通过 attachment 方法获取已附加的对象。一次只能附加一个对象；调用此方法会导致丢弃所有以前的附加对象。通过附加 null 可丢弃当前的附加对象。

参数：
ob - 要附加的对象，可以为 null
返回：
先前已附加的对象（如果有），否则返回 null

attachment

public final Object attachment()
获取当前的附加对象。

返回：
当前已附加到此键的对象，如果没有附加对象，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Pipe.SourceChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 Pipe.SourceChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.SelectableChannel
            继承者  java.nio.channels.spi.AbstractSelectableChannel
                继承者  java.nio.channels.Pipe.SourceChannel
所有已实现的接口：
Closeable, Channel, InterruptibleChannel, ReadableByteChannel, ScatteringByteChannel
正在封闭类：
Pipe
public abstract static class Pipe.SourceChannel
extends AbstractSelectableChannel
implements ReadableByteChannel, ScatteringByteChannel

表示 Pipe 的可读取结尾的通道。

从以下版本开始：
1.4

构造方法摘要
protected Pipe.SourceChannel(SelectorProvider provider)
构造此类的一个新实例。
方法摘要
 int validOps()
返回一个操作集，标识此通道所支持的操作。
从类 java.nio.channels.spi.AbstractSelectableChannel 继承的方法
blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register
从类 java.nio.channels.SelectableChannel 继承的方法
register
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.ScatteringByteChannel 继承的方法
read, read
从接口 java.nio.channels.ReadableByteChannel 继承的方法
read
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

Pipe.SourceChannel

protected Pipe.SourceChannel(SelectorProvider provider)
构造此类的一个新实例。

方法详细信息

validOps

public final int validOps()
返回一个操作集，标识此通道所支持的操作。

Pipe 的 SourceChannel 仅支持读取操作，所以此方法返回 SelectionKey.OP_READ。

指定者：
类 SelectableChannel 中的 validOps
返回：
有效操作集
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReadableByteChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
接口 ReadableByteChannel

所有超级接口：
Channel, Closeable
所有已知子接口：
ByteChannel, ScatteringByteChannel
所有已知实现类：
DatagramChannel, FileChannel, Pipe.SourceChannel, SocketChannel
public interface ReadableByteChannel
extends Channel

可读取字节的通道。

在任意给定时刻，一个可读取通道上只能进行一个读取操作。如果某个线程在通道上发起读取操作，那么在第一个操作完成之前，将阻塞其他所有试图发起另一个读取操作的线程。其他种类的 I/O 操作是否继续与读取操作并发执行取决于该通道的类型。

从以下版本开始：
1.4

方法摘要
 int read(ByteBuffer dst)
将字节序列从此通道中读入给定的缓冲区。
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

方法详细信息

read

int read(ByteBuffer dst)
         throws IOException
将字节序列从此通道中读入给定的缓冲区。

尝试最多从该通道中读取 r 个字节，其中 r 是调用此方法时缓冲区中剩余的字节数，即 dst.remaining()。

假定读取的字节序列长度为 n，其中 0 <= n <= r。此字节序列将被传输到缓冲区中，序列中的第一个字节位于索引 p 处，最后一个字节则位于索引 p + n - 1 处，其中 p 是调用此方法时缓冲区的位置。返回时，该缓冲区的位置将等于 p + n；其限制不会更改。

读取操作可能不填充缓冲区，实际上它可能根本不读取任何字节。是否如此执行取决于通道的性质和状态。例如，处于非阻塞模式的套接字通道只能从该套接字的输入缓冲区中读取立即可用的字节；类似地，文件通道只能读取文件中剩余的字节。但是可以保证，如果某个通道处于阻塞模式，并且缓冲区中至少剩余一个字节，则在读取至少一个字节之前将阻塞此方法。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个读取操作，则在该操作完成前此方法的调用被阻塞。

参数：
dst - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NonReadableChannelException - 如果不允许从此通道进行读取操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScatteringByteChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
接口 ScatteringByteChannel

所有超级接口：
Channel, Closeable, ReadableByteChannel
所有已知实现类：
DatagramChannel, FileChannel, Pipe.SourceChannel, SocketChannel
public interface ScatteringByteChannel
extends ReadableByteChannel

可将字节读入缓冲区序列的通道。

分散 读取操作可在单个调用中将一个字节序列读入一个或多个给定的缓冲区序列。分散读取通常在实现网络协议或文件格式时很有用，例如将数据分组放入段中（这些段由一个或多个长度固定的头，后跟长度可变的正文组成）。在 GatheringByteChannel 接口中定义了类似的集中 写入操作。

从以下版本开始：
1.4

方法摘要
long | read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
long | read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
从接口 java.nio.channels.ReadableByteChannel 继承的方法
read
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

方法详细信息

read

long read(ByteBuffer[] dsts,
          int offset,
          int length)
          throws IOException
将字节序列从此通道读入给定缓冲区的子序列中。

调用此方法会尝试最多从此通道读取 r 个字节，其中 r 是给定缓冲区数组的指定子序列中剩余的字节数，也就是

 dsts[offset].remaining()
     + dsts[offset+1].remaining()
     + ... + dsts[offset+length-1].remaining()

假定读取的字节序列长度为 n，其中 0 <= n <= r。将此序列的前 dsts[offset].remaining() 个字节传输到缓冲区 dsts[offset] 中，然后将后面的 dsts[offset+1].remaining() 个字节传输到缓冲区 dsts[offset+1] 中，依此类推，直到将整个字节序列传输到给定缓冲区中。向每个缓冲区中传输尽可能多的字节，因为要保证每个已更新缓冲区（最后一个已更新缓冲区除外）的最终位置等于该缓冲区的限制。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个读取操作，则在该操作完成前此方法的调用被阻塞。

参数：
dsts - 要向其中传输字节的缓冲区
offset - 第一个缓冲区（字节传输到该缓冲区中）在缓冲区数组中的偏移量；必须为非负数并且不能大于 dsts.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 dsts.length - offset
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立
NonReadableChannelException - 如果不允许从此通道进行读取操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

long read(ByteBuffer[] dsts)
          throws IOException
将字节序列从此通道读入给定的缓冲区。

调用此方法的形式为 c.read(dsts)，该调用与以下调用完全相同：

 c.read(dsts, 0,dsts.length);

参数：
dsts - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NonReadableChannelException - 如果不允许从此通道进行读取操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SelectableChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 SelectableChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.SelectableChannel
所有已实现的接口：
Closeable, Channel, InterruptibleChannel
直接已知子类：
AbstractSelectableChannel
public abstract class SelectableChannel
extends AbstractInterruptibleChannel
implements Channel

可通过 Selector 实现多路复用的通道。

为了与选择器一起使用，此类的实例必须首先通过 register 方法进行注册。此方法返回一个表示该通道已向选择器注册的新 SelectionKey 对象。

向选择器注册后，通道在注销 之前将保持注册状态。注销涉及释放选择器已分配给该通道的所有资源。

不能直接注销通道；相反，必须取消 表示通道注册的键。取消某个键要求在选择器的下一个选择操作期间注销通道。可通过调用某个键的 cancel 方法显式地取消该键。无论是通过调用通道的 close 方法，还是中断阻塞于该通道上 I/O 操作中的线程来关闭该通道，都会隐式地取消该通道的所有键。

如果选择器本身已关闭，则将注销该通道，并且表示其注册的键将立即无效。

一个通道至多只能在任意特定选择器上注册一次。

可通过调用 isRegistered 方法来确定是否向一个或多个选择器注册了某个通道。

多个并发线程可安全地使用可选择的通道。

阻塞模式

可选择的通道要么处于阻塞 模式，要么处于非阻塞 模式。在阻塞模式中，每一个 I/O 操作完成之前都会阻塞在其通道上调用的其他 I/O 操作。在非阻塞模式中，永远不会阻塞 I/O 操作，并且传输的字节可能少于请求的数量，或者可能根本不传输字节。可通过调用可选择通道的 isBlocking 方法来确定其阻塞模式。

新创建的可选择通道总是处于阻塞模式。在结合使用基于选择器的多路复用时，非阻塞模式是最有用的。向选择器注册某个通道前，必须将该通道置于非阻塞模式，并且在注销之前可能无法返回到阻塞模式。

从以下版本开始：
1.4
另请参见：
SelectionKey, Selector

构造方法摘要
protected SelectableChannel()
初始化此类的一个新实例。
方法摘要
abstract Object | blockingLock() 获取其 configureBlocking 和 register 方法实现同步的对象。
abstract SelectableChannel | configureBlocking(boolean block) 调整此通道的阻塞模式。
abstract boolean | isBlocking() 判断此通道上的每个 I/O 操作在完成前是否被阻塞。
abstract boolean | isRegistered() 判断此通道当前是否已向任何选择器注册。
abstract SelectionKey | keyFor(Selector sel) 获取表示通道向给定选择器注册的键。
abstract SelectorProvider | provider() 返回创建此通道的提供者。
SelectionKey | register(Selector sel, int ops) 向给定的选择器注册此通道，返回一个选择键。
abstract SelectionKey | register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。
abstract int | validOps() 返回一个操作集，标识此通道所支持的操作。
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, implCloseChannel, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

SelectableChannel

protected SelectableChannel()
初始化此类的一个新实例。

方法详细信息

provider

public abstract SelectorProvider provider()
返回创建此通道的提供者。

返回：
创建此通道的提供者

validOps

public abstract int validOps()
返回一个操作集，标识此通道所支持的操作。此整数值中设置的各位正好表示对此通道有效的操作。对于给定的具体通道类，此方法始终返回相同的值。

返回：
有效操作集

isRegistered

public abstract boolean isRegistered()
判断此通道当前是否已向任何选择器注册。新创建的通道总是未注册的。

由于键取消和通道注销之间固有的延迟，所以在已取消某个通道的所有键后，该通道可能在一定时间内还会保持已注册状态。关闭通道后，该通道可能在一定时间内还会保持已注册状态。

返回：
当且仅当此通道为已注册时才返回 true

keyFor

public abstract SelectionKey keyFor(Selector sel)
获取表示通道向给定选择器注册的键。

返回：
当此通道是向给定选择器注册的最后一个通道时返回该键，如果此通道当前未向该选择器注册，则返回 null

register

public abstract SelectionKey register(Selector sel,
                                      int ops,
                                      Object att)
                               throws ClosedChannelException
向给定的选择器注册此通道，返回一个选择键。

如果当前已向给定的选择器注册了此通道，则返回表示该注册的选择键。该键的相关操作集将更改为 ops，就像调用 interestOps(int) 方法一样。如果 att 参数不为 null，则将该键的附件设置为该值。如果已取消该键，则抛出 CancelledKeyException。

如果尚未向给定的选择器注册此通道，则注册该通道并返回得到的新键。该键的初始可用操作集是 ops，并且其附件是 att。

可在任意时间调用此方法。如果调用此方法的同时正在进行另一个此方法或 configureBlocking 方法的调用，则在另一个操作完成前将首先阻塞该调用。然后此方法将在选择器的键集上实现同步，因此如果调用此方法时并发地调用了涉及同一选择器的另一个注册或选择操作，则可能阻塞此方法的调用。

如果正在进行此操作时关闭了此通道，则此方法返回的键是已取消的，因此返回键无效。

参数：
sel - 要向其注册此通道的选择器
ops - 所得键的可用操作集
att - 所得键的附件，可能为 null
返回：
表示此通道向给定选择器注册的键
抛出：
ClosedChannelException - 如果此通道已关闭
IllegalBlockingModeException - 如果此通道处于阻塞模式
IllegalSelectorException - 如果此通道与给定的选择器不是由相同的提供者创建的
CancelledKeyException - 如果此通道当前已向给定的选择器注册，但是相应的键已经被取消
IllegalArgumentException - 如果 ops 集的某个位不对应于此通道所支持的某个操作，也就是说，如果 set & ~validOps() != 0

register

public final SelectionKey register(Selector sel,
                                   int ops)
                            throws ClosedChannelException
向给定的选择器注册此通道，返回一个选择键。

调用此便捷方法的形式为

sc.register(sel, ops)
与下列方法调用完全相同：
sc.register(sel, ops, null)

参数：
sel - 要向其注册此通道的选择器
ops - 所得键的可用操作集
返回：
表示此通道向给定选择器注册的键
抛出：
ClosedChannelException - 如果此通道已关闭
IllegalBlockingModeException - 如果此通道处于阻塞模式
IllegalSelectorException - 如果此通道与给定的选择器不是由相同的提供者创建的
CancelledKeyException - 如果此通道当前已向给定的选择器注册，但是相应的键已经被取消
IllegalArgumentException - 如果 ops 集的某个位不对应于此通道所支持的某个操作，也就是说，如果 set & ~validOps() != 0

configureBlocking

public abstract SelectableChannel configureBlocking(boolean block)
                                             throws IOException
调整此通道的阻塞模式。

如果向一个或多个选择器注册了此通道，则尝试将此通道置于阻塞模式将导致抛出 IllegalBlockingModeException。

可在任意时间调用此方法。新的阻塞模式仅影响在此方法返回后发起的 I/O 操作。对于某些实现而言，这可能需要在所有挂起的 I/O 操作完成之前阻塞其他操作。

如果调用此方法的同时正在进行另一个此方法或 register 方法的调用，则在另一个操作完成前将首先阻塞该调用。

参数：
block - 如果为 true，则此通道将被置于阻塞模式；如果为 false，则此通道将被置于非阻塞模式
返回：
此可选择通道
抛出：
ClosedChannelException - 如果此通道已关闭
IllegalBlockingModeException - 如果 block 为 true 并且此通道已向一个或多个选择器注册
IOException - 如果发生 I/O 错误

isBlocking

public abstract boolean isBlocking()
判断此通道上的每个 I/O 操作在完成前是否被阻塞。新创建的通道总是处于阻塞模式。

如果此通道已关闭，则此方法返回的值是未指定的。

返回：
当且仅当此通道处于阻塞模式时才返回 true

blockingLock

public abstract Object blockingLock()
获取其 configureBlocking 和 register 方法实现同步的对象。在要求在短时间内维持特定阻塞模式的适配器实现中，这通常是很有用的。

返回：
阻塞模式锁定对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Selector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 Selector

java.lang.Object
    继承者  java.nio.channels.Selector
直接已知子类：
AbstractSelector
public abstract class Selector
extends Object

SelectableChannel 对象的多路复用器。

可通过调用此类的 open 方法创建选择器，该方法将使用系统的默认选择器提供者创建新的选择器。也可通过调用自定义选择器提供者的 openSelector 方法来创建选择器。通过选择器的 close 方法关闭选择器之前，它一直保持打开状态。

通过 SelectionKey 对象来表示可选择通道到选择器的注册。选择器维护了三种选择键集：

  • 键集 包含的键表示当前通道到此选择器的注册。此集合由 keys 方法返回。

  • 已选择键集 是这样一种键的集合，即在前一次选择操作期间，检测每个键的通道是否已经至少为该键的相关操作集所标识的一个操作准备就绪。此集合由 selectedKeys 方法返回。已选择键集始终是键集的一个子集。

  • 已取消键集 是已被取消但其通道尚未注销的键的集合。不可直接访问此集合。已取消键集始终是键集的一个子集。

在新创建的选择器中，这三个集合都是空集合。

通过某个通道的 register 方法注册该通道时，所带来的副作用是向选择器的键集中添加了一个键。在选择操作期间从键集中移除已取消的键。键集本身是不可直接修改的。

不管是通过关闭某个键的通道还是调用该键的 cancel 方法来取消键，该键都被添加到其选择器的已取消键集中。取消某个键会导致在下一次选择操作期间注销该键的通道，而在注销时将从所有选择器的键集中移除该键。

通过选择操作将键添加到已选择键集中。可通过调用已选择键集的 remove 方法，或者通过调用从该键集获得的 iterator 的 remove 方法直接移除某个键。通过任何其他方式从不会将键从已选择键集中移除；特别是，它们不会因为影响选择操作而被移除。不能将键直接添加到已选择键集中。

选择

在每次选择操作期间，都可以将键添加到选择器的已选择键集以及从中将其移除，并且可以从其键集和已取消键集中将其移除。选择是由 select()、select(long) 和 selectNow() 方法执行的，执行涉及三个步骤：

  1. 将已取消键集中的每个键从所有键集中移除（如果该键是键集的成员），并注销其通道。此步骤使已取消键集成为空集。

  2. 在开始进行选择操作时，应查询基础操作系统来更新每个剩余通道的准备就绪信息，以执行由其键的相关集合所标识的任意操作。对于已为至少一个这样的操作准备就绪的通道，执行以下两种操作之一：

    1. 如果该通道的键尚未在已选择键集中，则将其添加到该集合中，并修改其准备就绪操作集，以准确地标识那些通道现在已报告为之准备就绪的操作。丢弃准备就绪操作集中以前记录的所有准备就绪信息。

    2. 如果该通道的键已经在已选择键集中，则修改其准备就绪操作集，以准确地标识所有通道已报告为之准备就绪的新操作。保留准备就绪操作集以前记录的所有准备就绪信息；换句话说，基础系统所返回的准备就绪操作集是和该键的当前准备就绪操作集按位分开 (bitwise-disjoined) 的。

    3. 如果在此步骤开始时键集中的所有键都有空的相关集合，则不会更新已选择键集和任意键的准备就绪操作集。

  3. 如果在步骤 (2) 的执行过程中要将任意键添加到已取消键集中，则处理过程如步骤 (1)。

是否阻塞选择操作以等待一个或多个通道准备就绪，如果这样做的话，要等待多久，这是三种选择方法之间的唯一本质差别。

并发性

选择器自身可由多个并发线程安全使用，但是其键集并非如此。

选择操作在选择器本身上、在键集上和在已选择键集上是同步的，顺序也与此顺序相同。在执行上面的步骤 (1) 和 (3) 时，它们在已取消键集上也是同步的。

在执行选择操作的过程中，更改选择器键的相关集合对该操作没有影响；进行下一次选择操作才会看到此更改。

可在任意时间取消键和关闭通道。因此，在一个或多个选择器的键集中出现某个键并不意味着该键是有效的，也不意味着其通道处于打开状态。如果存在另一个线程取消某个键或关闭某个通道的可能性，那么应用程序代码进行同步时应该小心，并且必要时应该检查这些条件。

阻塞在 select() 或 select(long) 方法之一中的某个线程可能被其他线程以下列三种方式之一中断：

  • 通过调用选择器的 wakeup 方法，

  • 通过调用选择器的 close 方法，或者

  • 在通过调用已阻塞线程的 interrupt 方法的情况下，将设置其中断状态并且将调用该选择器的 wakeup 方法。

close 方法在选择器上是同步的，并且所有三个键集都与选择操作中的顺序相同。

一般情况下，选择器的键和已选择键集由多个并发线程使用是不安全的。如果这样的线程可以直接修改这些键集之一，那么应该通过对该键集本身进行同步来控制访问。这些键集的 iterator 方法所返回的迭代器是快速失败 的：如果在创建迭代器后以任何方式（调用迭代器自身的 remove 方法除外）修改键集，则会抛出 ConcurrentModificationException。

从以下版本开始：
1.4
另请参见：
SelectableChannel, SelectionKey

构造方法摘要
protected Selector()
初始化此类的一个新实例。
方法摘要
abstract void | close() 关闭此选择器。
abstract boolean | isOpen() 告知此选择器是否已打开。
abstract Set<SelectionKey> | keys() 返回此选择器的键集。
static Selector | open() 打开一个选择器。
abstract SelectorProvider | provider() 返回创建此通道的提供者。
abstract int | select() 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract int | select(long timeout) 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract Set<SelectionKey> | selectedKeys() 返回此选择器的已选择键集。
abstract int | selectNow() 选择一组键，其相应的通道已为 I/O 操作准备就绪。
abstract Selector | wakeup() 使尚未返回的第一个选择操作立即返回。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Selector

protected Selector()
初始化此类的一个新实例。

方法详细信息

open

public static Selector open()
                     throws IOException
打开一个选择器。

通过调用系统级默认 SelectorProvider 对象的 openSelector 方法来创建新的选择器。

返回：
新的选择器
抛出：
IOException - 如果发生 I/O 错误

isOpen

public abstract boolean isOpen()
告知此选择器是否已打开。

返回：
当且仅当此选择器已打开时才返回 true

provider

public abstract SelectorProvider provider()
返回创建此通道的提供者。

返回：
创建此通道的提供者

keys

public abstract Set<SelectionKey> keys()
返回此选择器的键集。

不可直接修改键集。仅在已取消某个键并且已注销其通道后才移除该键。试图修改键集会导致抛出 UnsupportedOperationException。

键集是非线程安全的。

返回：
此选择器的键集
抛出：
ClosedSelectorException - 如果此选择器已关闭

selectedKeys

public abstract Set<SelectionKey> selectedKeys()
返回此选择器的已选择键集。

可从已选择键集中移除键，但是无法直接添加键。试图向该键集中添加对象会导致抛出 UnsupportedOperationException。

已选择键集是非线程安全的。

返回：
此选择器的已选择键集
抛出：
ClosedSelectorException - 如果此选择器已关闭

selectNow

public abstract int selectNow()
                       throws IOException
选择一组键，其相应的通道已为 I/O 操作准备就绪。

此方法执行非阻塞的选择操作。如果自从前一次选择操作后，没有通道变成可选择的，则此方法直接返回零。

调用此方法会清除所有以前调用 wakeup 方法所得的结果。

返回：
由选择操作更新其准备就绪操作集的键的数目，该数目可能为零
抛出：
IOException - 如果发生 I/O 错误
ClosedSelectorException - 如果此选择器已关闭

select

public abstract int select(long timeout)
                    throws IOException
选择一组键，其相应的通道已为 I/O 操作准备就绪。

此方法执行处于阻塞模式的选择操作。仅在至少选择一个通道、调用此选择器的 wakeup 方法、当前的线程已中断，或者给定的超时期满（以先到者为准）后此方法才返回。

此方法不提供实时保证：它安排了超时时间，就像调用 Object.wait(long) 方法一样。

参数：
timeout - 如果为正，则在等待某个通道准备就绪时最多阻塞 timeout 毫秒；如果为零，则无限期地阻塞；必须为非负数
返回：
已更新其准备就绪操作集的键的数目，该数目可能为零
抛出：
IOException - 如果发生 I/O 错误
ClosedSelectorException - 如果此选择器已关闭
IllegalArgumentException - 如果 timeout 参数的值为负

select

public abstract int select()
                    throws IOException
选择一组键，其相应的通道已为 I/O 操作准备就绪。

此方法执行处于阻塞模式的选择操作。仅在至少选择一个通道、调用此选择器的 wakeup 方法，或者当前的线程已中断（以先到者为准）后此方法才返回。

返回：
已更新其准备就绪操作集的键的数目，该数目可能为零
抛出：
IOException - 如果发生 I/O 错误
ClosedSelectorException - 如果此选择器已关闭

wakeup

public abstract Selector wakeup()
使尚未返回的第一个选择操作立即返回。

如果另一个线程目前正阻塞在 select() 或 select(long) 方法的调用中，则该调用将立即返回。如果当前未进行选择操作，那么在没有同时调用 selectNow() 方法的情况下，对上述方法的下一次调用将立即返回。在任一情况下，该调用返回的值可能是非零的。如果未同时再次调用此方法，则照常阻塞 select() 或 select(long) 方法的后续调用。

在两个连续的选择操作之间多次调用此方法与只调用一次的效果相同。

返回：
此选择器

close

public abstract void close()
                    throws IOException
关闭此选择器。

如果某个线程目前正阻塞在此选择器的某个选择方法中，则中断该线程，如同调用该选择器的 wakeup 方法那样。

所有仍与此选择器关联的未取消键已无效、其通道已注销，并且与此选择器关联的所有其他资源已释放。

如果此选择器已经关闭，则调用此方法无效。

关闭选择器后，除了调用此方法或 wakeup 方法外，以任何其他方式继续使用它都将导致抛出 ClosedSelectorException。

抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerSocketChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 ServerSocketChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.SelectableChannel
            继承者  java.nio.channels.spi.AbstractSelectableChannel
                继承者  java.nio.channels.ServerSocketChannel
所有已实现的接口：
Closeable, Channel, InterruptibleChannel
public abstract class ServerSocketChannel
extends AbstractSelectableChannel

针对面向流的侦听套接字的可选择通道。

服务器套接字通道不是侦听网络套接字的完整抽象。必须通过调用 socket 方法所获得的关联 ServerSocket 对象来完成对套接字选项的绑定和操作。不可能为任意的已有服务器套接字创建通道，也不可能指定与服务器套接字通道关联的服务器套接字所使用的 SocketImpl 对象。

通过调用此类的 open 方法创建服务器套接字通道。新创建的服务器套接字通道已打开，但尚未绑定。试图调用未绑定的服务器套接字通道的 accept 方法会导致抛出 NotYetBoundException。可通过调用相关服务器套接字的某个 bind 方法来绑定服务器套接字通道。

多个并发线程可安全地使用服务器套接字通道。

从以下版本开始：
1.4

构造方法摘要
protected ServerSocketChannel(SelectorProvider provider)
初始化此类的一个新实例。
方法摘要
abstract SocketChannel | accept() 接受到此通道套接字的连接。
static ServerSocketChannel | open() 打开服务器套接字通道。
abstract ServerSocket | socket() 获取与此通道关联的服务器套接字。
int | validOps() 返回一个操作集，标识此通道所支持的操作。
从类 java.nio.channels.spi.AbstractSelectableChannel 继承的方法
blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register
从类 java.nio.channels.SelectableChannel 继承的方法
register
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

ServerSocketChannel

protected ServerSocketChannel(SelectorProvider provider)
初始化此类的一个新实例。

方法详细信息

open

public static ServerSocketChannel open()
                                throws IOException
打开服务器套接字通道。

通过调用系统级默认 SelectorProvider 对象的 openServerSocketChannel 方法来创建新的通道。

新通道的套接字最初是未绑定的；可以接受连接之前，必须通过它的某个套接字的 bind 方法将其绑定到具体的地址。

返回：
新的套接字通道
抛出：
IOException - 如果发生 I/O 错误

validOps

public final int validOps()
返回一个操作集，标识此通道所支持的操作。

服务器套接字通道仅支持接受新的连接，所以此方法返回 SelectionKey.OP_ACCEPT。

指定者：
类 SelectableChannel 中的 validOps
返回：
有效操作集

socket

public abstract ServerSocket socket()
获取与此通道关联的服务器套接字。

返回的对象不会声明任何在 ServerSocket 类中未声明的公共方法。

返回：
与此通道关联的服务器套接字

accept

public abstract SocketChannel accept()
                              throws IOException
接受到此通道套接字的连接。

如果此通道处于非阻塞模式，那么在不存在挂起的连接时，此方法将直接返回 null。否则，在新的连接可用或者发生 I/O 错误之前会无限期地阻塞它。

不管此通道的阻塞模式如何，此方法返回的套接字通道（如果有）将处于阻塞模式。

此方法执行的安全检查与 ServerSocket 类的 accept 方法执行的安全检查完全相同。也就是说，如果已安装了安全管理器，则对于每个新的连接，此方法都会验证安全管理器的 checkAccept 方法是否允许使用该连接的远程端点的地址和端口号。

返回：
用于新连接的套接字通道，或者如果此通道处于非阻塞模式并且没有要接受的可用连接，则返回 null
抛出：
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行接受操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行接受操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
NotYetBoundException - 如果尚未绑定此通道的套接字
SecurityException - 如果已安装安全管理器并且它不允许对新连接的远程端点进行访问
IOException - 如果发生其他 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 SocketChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.SelectableChannel
            继承者  java.nio.channels.spi.AbstractSelectableChannel
                继承者  java.nio.channels.SocketChannel
所有已实现的接口：
Closeable, ByteChannel, Channel, GatheringByteChannel, InterruptibleChannel, ReadableByteChannel, ScatteringByteChannel, WritableByteChannel
public abstract class SocketChannel
extends AbstractSelectableChannel
implements ByteChannel, ScatteringByteChannel, GatheringByteChannel

针对面向流的连接套接字的可选择通道。

套接字通道不是连接网络套接字的完整抽象。必须通过调用 socket 方法所获得的关联 Socket 对象来完成对套接字选项的绑定、关闭和操作。不可能为任意的已有套接字创建通道，也不可能指定与套接字通道关联的套接字所使用的 SocketImpl 对象。

通过调用此类的某个 open 方法创建套接字通道。新创建的套接字通道已打开，但尚未连接。试图在未连接的通道上调用 I/O 操作将导致抛出 NotYetConnectedException。可通过调用套接字通道的 connect 方法连接该通道；一旦连接后，关闭套接字通道之前它会一直保持已连接状态。可通过调用套接字通道的 isConnected 方法来确定套接字通道是否已连接。

套接字通道支持非阻塞连接：可创建一个套接字通道，并且通过 connect 方法可以发起到远程套接字的连接，之后通过 finishConnect 方法完成该连接。可通过调用 isConnectionPending 方法来确定是否正在进行连接操作。

可单独地关闭 套接字通道的输入端和输出端，而无需实际关闭该通道。调用关联套接字对象的 shutdownInput 方法来关闭某个通道的输入端将导致该通道上的后续读取操作返回 -1（指示流的末尾）。调用关联套接字对象的 shutdownOutput 方法来关闭通道的输出端将导致该通道上的后续写入操作抛出 ClosedChannelException。

套接字通道支持异步关闭，这与 Channel 类中所指定的异步 close 操作类似。如果一个线程关闭了某个套接字的输入端，而同时另一个线程被阻塞在该套接字通道上的读取操作中，那么处于阻塞线程中的读取操作将完成，而不读取任何字节且返回 -1。I如果一个线程关闭了某个套接字的输出端，而同时另一个线程被阻塞在该套接字通道上的写入操作中，那么阻塞线程将收到 AsynchronousCloseException。

多个并发线程可安全地使用套接字通道。尽管在任意给定时刻最多只能有一个线程进行读取和写入操作，但数据报通道支持并发的读写。connect 和 finishConnect 方法是相互同步的，如果正在调用其中某个方法的同时试图发起读取或写入操作，则在该调用完成之前该操作被阻塞。

从以下版本开始：
1.4

构造方法摘要
protected SocketChannel(SelectorProvider provider)
初始化此类的一个新实例。
方法摘要
abstract boolean | connect(SocketAddress remote) 连接此通道的套接字。
abstract boolean | finishConnect() 完成套接字通道的连接过程。
abstract boolean | isConnected() 判断是否已连接此通道的网络套接字。
abstract boolean | isConnectionPending() 判断此通道上是否正在进行连接操作。
static SocketChannel | open() 打开套接字通道。
static SocketChannel | open(SocketAddress remote) 打开套接字通道并将其连接到远程地址。
abstract int | read(ByteBuffer dst) 将字节序列从此通道中读入给定的缓冲区。
long | read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
abstract long | read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
abstract Socket | socket() 获取与此通道关联的套接字。
int | validOps() 返回一个操作集，标识此通道所支持的操作。
abstract int | write(ByteBuffer src) 将字节序列从给定的缓冲区中写入此通道。
long | write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
abstract long | write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
从类 java.nio.channels.spi.AbstractSelectableChannel 继承的方法
blockingLock, configureBlocking, implCloseChannel, implCloseSelectableChannel, implConfigureBlocking, isBlocking, isRegistered, keyFor, provider, register
从类 java.nio.channels.SelectableChannel 继承的方法
register
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

SocketChannel

protected SocketChannel(SelectorProvider provider)
初始化此类的一个新实例。

方法详细信息

open

public static SocketChannel open()
                          throws IOException
打开套接字通道。

通过调用系统级默认 SelectorProvider 对象的 openSocketChannel 方法来创建新的通道。

返回：
新的套接字通道
抛出：
IOException - 如果发生 I/O 错误

open

public static SocketChannel open(SocketAddress remote)
                          throws IOException
打开套接字通道并将其连接到远程地址。

这种便捷方法的工作方式就像以下过程一样：调用 open() 方法、在得到的套接字通道上调用 connect 方法、向其传递 remote，然后返回该通道。

参数：
remote - 与新通道连接的远程地址
抛出：
AsynchronousCloseException - 如果正在进行连接操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行连接操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
UnresolvedAddressException - 如果无法完全解析给定的远程地址
UnsupportedAddressTypeException - 如果不支持给定的远程地址类型
SecurityException - 如果已安装安全管理器并且它不允许对给定远程端点进行访问
IOException - 如果发生其他 I/O 错误

validOps

public final int validOps()
返回一个操作集，标识此通道所支持的操作。

套接字通道支持连接、读取和写入，所以此方法返回 ( SelectionKey.OP_CONNECT | SelectionKey.OP_READ | SelectionKey.OP_WRITE )。

指定者：
类 SelectableChannel 中的 validOps
返回：
有效操作集

socket

public abstract Socket socket()
获取与此通道关联的套接字。

返回的对象不会声明任何在 Socket 类中未声明的公共方法。

返回：
与此通道关联的套接字

isConnected

public abstract boolean isConnected()
判断是否已连接此通道的网络套接字。

返回：
当且仅当已连接此通道的网络套接字时才返回 true

isConnectionPending

public abstract boolean isConnectionPending()
判断此通道上是否正在进行连接操作。

返回：
当且仅当已在此通道上发起连接操作，但是尚未通过调用 finishConnect 方法完成连接时才返回 true

connect

public abstract boolean connect(SocketAddress remote)
                         throws IOException
连接此通道的套接字。

如果此通道处于非阻塞模式，则调用此方法会发起一个非阻塞连接操作。如果立即建立连接（使用本地连接时就是如此），则此方法返回 true。否则此方法返回 false，并且必须在以后通过调用 finishConnect 方法来完成该连接操作。

如果此通道处于阻塞模式，则在建立连接或发生 I/O 错误之前将阻塞此方法的调用。

此方法执行与 Socket 类完全相同的安全检查。也就是说，如果已安装了安全管理器，则此方法验证其 checkConnect 方法是否允许连接到给定远程端点的地址和端口号。

可在任意时间调用此方法。如果正在调用此方法时在此通道上调用读取或写入操作，则在此调用完成前将首先阻塞该操作。如果试图发起连接但失败了，也就是说如果调用此方法抛出经过检查的异常，则关闭此通道。

参数：
remote - 与此通道连接的远程地址
返回：
如果已建立连接，则返回 true，如果此通道处于非阻塞模式并且正在进行连接操作，则返回 false
抛出：
AlreadyConnectedException - 如果已连接此通道
ConnectionPendingException - 如果已在此通道上进行非阻塞连接操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行连接操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行连接操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
UnresolvedAddressException - 如果没有完全解析给定的远程地址
UnsupportedAddressTypeException - 如果不支持给定的远程地址类型
SecurityException - 如果已安装安全管理器并且它不允许对给定远程端点进行访问
IOException - 如果发生其他 I/O 错误

finishConnect

public abstract boolean finishConnect()
                               throws IOException
完成套接字通道的连接过程。

通过将套接字通道置于非阻塞模式，然后调用其 connect 方法来发起非阻塞连接操作。一旦建立了连接，或者尝试已失败，该套接字通道就变为可连接的，并且可调用此方法完成连接序列。如果连接操作失败，则调用此方法将导致抛出合适的 IOException。

如果已连接了此通道，则不阻塞此方法并且立即返回 true。如果此通道处于非阻塞模式，那么当连接过程尚未完成时，此方法将返回 false。如果此通道处于阻塞模式，则在连接完成或失败之前将阻塞此方法，并且总是返回 true 或抛出描述该失败的、经过检查的异常。

可在任意时间调用此方法。如果正在调用此方法时在此通道上调用读取或写入操作，则在此调用完成前将首先阻塞该操作。如果试图发起连接但失败了，也就是说如果调用此方法导致抛出经过检查的异常，则关闭此通道。

返回：
当且仅当已连接此通道的套接字时才返回 true
抛出：
NoConnectionPendingException - 如果未连接此通道并且尚未发起连接操作
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行连接操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行连接操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

public abstract int read(ByteBuffer dst)
                  throws IOException
从接口 ReadableByteChannel 复制的描述
将字节序列从此通道中读入给定的缓冲区。

尝试最多从该通道中读取 r 个字节，其中 r 是调用此方法时缓冲区中剩余的字节数，即 dst.remaining()。

假定读取的字节序列长度为 n，其中 0 <= n <= r。此字节序列将被传输到缓冲区中，序列中的第一个字节位于索引 p 处，最后一个字节则位于索引 p + n - 1 处，其中 p 是调用此方法时缓冲区的位置。返回时，该缓冲区的位置将等于 p + n；其限制不会更改。

读取操作可能不填充缓冲区，实际上它可能根本不读取任何字节。是否如此执行取决于通道的性质和状态。例如，处于非阻塞模式的套接字通道只能从该套接字的输入缓冲区中读取立即可用的字节；类似地，文件通道只能读取文件中剩余的字节。但是可以保证，如果某个通道处于阻塞模式，并且缓冲区中至少剩余一个字节，则在读取至少一个字节之前将阻塞此方法。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个读取操作，则在该操作完成前此方法的调用被阻塞。

指定者：
接口 ReadableByteChannel 中的 read
参数：
dst - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NotYetConnectedException - 如果尚未连接此通道
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

public abstract long read(ByteBuffer[] dsts,
                          int offset,
                          int length)
                   throws IOException
从接口 ScatteringByteChannel 复制的描述
将字节序列从此通道读入给定缓冲区的子序列中。

调用此方法会尝试最多从此通道读取 r 个字节，其中 r 是给定缓冲区数组的指定子序列中剩余的字节数，也就是

 dsts[offset].remaining()
     + dsts[offset+1].remaining()
     + ... + dsts[offset+length-1].remaining()

假定读取的字节序列长度为 n，其中 0 <= n <= r。将此序列的前 dsts[offset].remaining() 个字节传输到缓冲区 dsts[offset] 中，然后将后面的 dsts[offset+1].remaining() 个字节传输到缓冲区 dsts[offset+1] 中，依此类推，直到将整个字节序列传输到给定缓冲区中。向每个缓冲区中传输尽可能多的字节，因为要保证每个已更新缓冲区（最后一个已更新缓冲区除外）的最终位置等于该缓冲区的限制。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个读取操作，则在该操作完成前此方法的调用被阻塞。

指定者：
接口 ScatteringByteChannel 中的 read
参数：
dsts - 要向其中传输字节的缓冲区
offset - 第一个缓冲区（字节传输到该缓冲区中）在缓冲区数组中的偏移量；必须为非负数并且不能大于 dsts.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 dsts.length - offset
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NotYetConnectedException - 如果尚未连接此通道
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

read

public final long read(ByteBuffer[] dsts)
                throws IOException
从接口 ScatteringByteChannel 复制的描述
将字节序列从此通道读入给定的缓冲区。

调用此方法的形式为 c.read(dsts)，该调用与以下调用完全相同：

 c.read(dsts, 0,dsts.length);

指定者：
接口 ScatteringByteChannel 中的 read
参数：
dsts - 要向其中传输字节的缓冲区
返回：
读取的字节数，可能为零，如果该通道已到达流的末尾，则返回 -1
抛出：
NotYetConnectedException - 如果尚未连接此通道
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行读取操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行读取操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程设置为中断状态
IOException - 如果发生其他 I/O 错误

write

public abstract int write(ByteBuffer src)
                   throws IOException
从接口 WritableByteChannel 复制的描述
将字节序列从给定的缓冲区中写入此通道。

尝试最多向该通道中写入 r 个字节，其中 r 是调用此方法时缓冲区中剩余的字节数，即 src.remaining()。

假定写入长度为 n 的字节序列，其中 0 <= n <= r。从缓冲区的索引 p 处开始传输该字节，其中 p 是调用此方法时该缓冲区的位置；最后写入的字节索引是 p + n - 1。返回时，该缓冲区的位置将等于 p + n；其限制不会更改。

除非另行指定，否则仅在写入所有请求的 r 个字节后 write 操作才会返回。有些类型的通道（取决于它们的状态）可能仅写入某些字节或者可能根本不写入。例如，处于非阻塞模式的套接字通道只能写入该套接字输出缓冲区中的字节。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个写入操作，则在该操作完成前此方法的调用被阻塞。

指定者：
接口 WritableByteChannel 中的 write
参数：
src - 要从中获取字节的缓冲区
返回：
写入的字节数，可能为零
抛出：
NotYetConnectedException - 如果尚未连接此通道
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

write

public abstract long write(ByteBuffer[] srcs,
                           int offset,
                           int length)
                    throws IOException
从接口 GatheringByteChannel 复制的描述
将字节序列从给定缓冲区的子序列写入此通道。

尝试最多向此通道中写入 r 个字节，其中 r 是给定缓冲区数组的指定子序列中剩余的字节数，也就是

 srcs[offset].remaining()
     + srcs[offset+1].remaining()
     + ... + srcs[offset+length-1].remaining()

假定写入长度为 n 的字节序列，其中 0 <= n <= r。从缓冲区 srcs[offset] 中写入此序列的前 srcs[offset].remaining() 个字节，然后从缓冲区 srcs[offset+1] 中写入后面的 srcs[offset+1].remaining() 个字节，依此类推，直到写入整个字节序列。从每个缓冲区中写入尽可能多的字节，因为要保证每个已更新缓冲区（最后一个已更新缓冲区除外）的最终位置等于该缓冲区的限制。

除非另行指定，否则仅在写入所有请求的 r 个字节后 write 操作才会返回。有些类型的通道（取决于它们的状态）可能仅写入某些字节或者可能根本不写入。例如，处于非阻塞模式的套接字通道无法写入超出该套接字输出缓冲区剩余空间的字节。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个写入操作，则在该操作完成前此方法的调用被阻塞。

指定者：
接口 GatheringByteChannel 中的 write
offset - 第一个缓冲区（要获取该缓冲区中的字节）在缓冲区数组中的偏移量；必须为非负数并且不能大于 srcs.length
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 srcs.length - offset
返回：
写入的字节数，可能为零
抛出：
NotYetConnectedException - 如果尚未连接此通道
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误

write

public final long write(ByteBuffer[] srcs)
                 throws IOException
从接口 GatheringByteChannel 复制的描述
将字节序列从给定的缓冲区写入此通道。

调用此方法的形式为 c.write(srcs) ，该调用与以下调用完全相同：

 c.write(srcs, 0, srcs.length);

指定者：
接口 GatheringByteChannel 中的 write
返回：
写入的字节数，可能为零
抛出：
NotYetConnectedException - 如果尚未连接此通道
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnresolvedAddressException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 UnresolvedAddressException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.nio.channels.UnresolvedAddressException
所有已实现的接口：
Serializable
public class UnresolvedAddressException
extends IllegalArgumentException

试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
UnresolvedAddressException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnresolvedAddressException

public UnresolvedAddressException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedAddressTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
类 UnsupportedAddressTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.nio.channels.UnsupportedAddressTypeException
所有已实现的接口：
Serializable
public class UnsupportedAddressTypeException
extends IllegalArgumentException

试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
UnsupportedAddressTypeException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedAddressTypeException

public UnsupportedAddressTypeException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WritableByteChannel (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio.channels
接口 WritableByteChannel

所有超级接口：
Channel, Closeable
所有已知子接口：
ByteChannel, GatheringByteChannel
所有已知实现类：
DatagramChannel, FileChannel, Pipe.SinkChannel, SocketChannel
public interface WritableByteChannel
extends Channel

可写入字节的通道。

在任意给定时刻，一个可写入通道上只能进行一个写入操作。如果某个线程在通道上发起写入操作，那么在第一个操作完成之前，将阻塞其他所有试图发起另一个写入操作的线程。其他种类的 I/O 操作是否继续与写入操作并发执行则取决于该通道的类型。

从以下版本开始：
1.4

方法摘要
 int write(ByteBuffer src)
将字节序列从给定的缓冲区中写入此通道。
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

方法详细信息

write

int write(ByteBuffer src)
          throws IOException
将字节序列从给定的缓冲区中写入此通道。

尝试最多向该通道中写入 r 个字节，其中 r 是调用此方法时缓冲区中剩余的字节数，即 src.remaining()。

假定写入长度为 n 的字节序列，其中 0 <= n <= r。从缓冲区的索引 p 处开始传输该字节，其中 p 是调用此方法时该缓冲区的位置；最后写入的字节索引是 p + n - 1。返回时，该缓冲区的位置将等于 p + n；其限制不会更改。

除非另行指定，否则仅在写入所有请求的 r 个字节后 write 操作才会返回。有些类型的通道（取决于它们的状态）可能仅写入某些字节或者可能根本不写入。例如，处于非阻塞模式的套接字通道只能写入该套接字输出缓冲区中的字节。

可在任意时间调用此方法。但是如果另一个线程已经在此通道上发起了一个写入操作，则在该操作完成前此方法的调用被阻塞。

参数：
src - 要从中获取字节的缓冲区
返回：
写入的字节数，可能为零
抛出：
NonWritableChannelException - 如果此通道未对写入打开
ClosedChannelException - 如果此通道已关闭
AsynchronousCloseException - 如果正在进行写入操作时另一个线程关闭了此通道
ClosedByInterruptException - 如果正在进行写入操作时另一个线程中断了当前线程，因此关闭了该通道并将当前线程的状态设置为中断
IOException - 如果发生其他 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.nio.channels (Java 2 Platform SE 6)

 java.nio.channels
接口
ByteChannel
Channel
GatheringByteChannel
InterruptibleChannel
ReadableByteChannel
ScatteringByteChannel
WritableByteChannel
类
Channels
DatagramChannel
FileChannel
FileChannel.MapMode
FileLock
Pipe
Pipe.SinkChannel
Pipe.SourceChannel
SelectableChannel
SelectionKey
Selector
ServerSocketChannel
SocketChannel
异常
AlreadyConnectedException
AsynchronousCloseException
CancelledKeyException
ClosedByInterruptException
ClosedChannelException
ClosedSelectorException
ConnectionPendingException
FileLockInterruptionException
IllegalBlockingModeException
IllegalSelectorException
NoConnectionPendingException
NonReadableChannelException
NonWritableChannelException
NotYetBoundException
NotYetConnectedException
OverlappingFileLockException
UnresolvedAddressException
UnsupportedAddressTypeException


java.nio.channels (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.nio.channels

定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

请参见：
描述

接口摘要
ByteChannel | 可读取和写入字节的信道。
Channel | 用于 I/O 操作的连接。
GatheringByteChannel | 可从缓冲区序列写入字节的通道。
InterruptibleChannel | 可被异步关闭和中断的通道。
ReadableByteChannel | 可读取字节的通道。
ScatteringByteChannel | 可将字节读入缓冲区序列的通道。
WritableByteChannel | 可写入字节的通道。

类摘要
Channels | 针对信道和流的实用工具方法。
DatagramChannel | 针对面向数据报套接字的可选择通道。
FileChannel | 用于读取、写入、映射和操作文件的通道。
FileChannel.MapMode | 文件映射模式的类型安全的枚举。
FileLock | 表示文件区域锁定的标记。
Pipe | 实现单向管道传送的通道对。
Pipe.SinkChannel | 表示 Pipe 的可写入结尾的通道。
Pipe.SourceChannel | 表示 Pipe 的可读取结尾的通道。
SelectableChannel | 可通过 Selector 实现多路复用的通道。
SelectionKey | 表示 SelectableChannel 在 Selector 中的注册的标记。
Selector | SelectableChannel 对象的多路复用器。
ServerSocketChannel | 针对面向流的侦听套接字的可选择通道。
SocketChannel | 针对面向流的连接套接字的可选择通道。

异常摘要
AlreadyConnectedException | 试图对已经连接的 SocketChannel 进行连接时抛出的未经检查的异常。
AsynchronousCloseException | 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
CancelledKeyException | 当试图使用不再有效的选择键时，抛出此未经检查的异常。
ClosedByInterruptException | 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。
ClosedChannelException | 当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
ClosedSelectorException | 试图在已关闭的选择器上调用 I/O 操作时抛出的未经检查的异常。
ConnectionPendingException | 试图连接一个正在进行非阻塞连接操作的 SocketChannel 时抛出的未经检查的异常。
FileLockInterruptionException | 当某个线程正在等待获取文件锁定时被另一个线程中断，则由该线程接收此经过检查的异常。
IllegalBlockingModeException | 当以错误的阻塞模式调用特定于某个阻塞模式的操作时，抛出此未经检查的异常。
IllegalSelectorException | 试图将一个通道注册到一个不是由创建该通道的提供者所创建的选择器时，抛出此未经检查的异常。
NoConnectionPendingException | 在没有首先成功调用 connect 方法的情况下调用 SocketChannel 的 finishConnect 方法时，抛出此未经检查的异常。
NonReadableChannelException | 试图对一个最初未允许对其进行读取操作的通道进行读取时，抛出此未经检查的异常。
NonWritableChannelException | 试图对一个最初未允许对其进行写入操作的通道进行写入时，抛出此未经检查的异常。
NotYetBoundException | 试图在尚未绑定的服务器套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
NotYetConnectedException | 试图在尚未连接的套接字通道上调用 I/O 操作时，抛出此未经检查的异常。
OverlappingFileLockException | 试图获取某个文件区域上的锁定，而该区域与同一 Java 虚拟机已锁定的某个区域重叠时，或者当另一个线程已经等待锁定同一文件的重叠区域时，抛出此未经检查的异常。
UnresolvedAddressException | 试图对未解析的套接字地址调用网络操作时，抛出此未经检查的异常。
UnsupportedAddressTypeException | 试图绑定或连接到一个其类型不受支持的套接字地址时，抛出此未经检查的异常。

软件包 java.nio.channels 的描述

定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

通道

描述

Channel | 用于 I/O 操作的连接
  ReadableByteChannel | 可以将内容读入缓冲区
    ScatteringByteChannel   | 可以将内容读入缓冲区序列
  WritableByteChannel | 可以从缓冲区中写入内容
    GatheringByteChannel | 可以从缓冲区序列中写入内容
  ByteChannel | 可以从缓冲区读取内容或向其写入内容
Channels | 用于通道/流进行互操作的实用工具方法

通道 表示到实体（如硬件设备、文件、网络套接字或者可以执行一个或多个诸如读取或写入之类的不同 I/O 操作的程序组件）的开放连接。正如在 Channel 接口中所指定的，通道可以处于打开或关闭状态，并且它们既是可异步关闭的，又是可中断的。

多个其他接口扩展了 Channel 接口，这些接口都指定了新的 I/O 操作。

ReadableByteChannel 接口指定了 read 方法，可将字节从通道读取到缓冲区；类似地，WritableByteChannel 接口指定了 write 方法，可将字节从缓冲区写入通道。ByteChannel 接口为可读取和写入字节的常见通道统一了这两个接口。

ScatteringByteChannel 和 GatheringByteChannel 接口分别扩展了 ReadableByteChannel 和 WritableByteChannel 接口，添加的 read 和 write 方法采用的是缓冲区序列，而不只是单个缓冲区。

Channels 实用工具类定义了各种静态方法，这些方法支持 java.io 包的流类和此包通道类的互操作。可根据 InputStream 或 OutputStream 构造合适的通道，反之可根据通道构造 InputStream 或 OutputStream。可构造 Reader 来使用给定的字符集对取自给定可读取字节通道的字节进行解码，反之可构造 Writer 来使用给定的字符集将字符编码到字节中，并将该字节写入给定的可写入字节通道。

文件通道

描述

FileChannel | 读取、写入、映射和操作文件
FileLock | 对文件（文件区域）的锁定
MappedByteBuffer   | 映射到文件区域的直接字节缓冲区

FileChannel 类支持从连接到文件的通道读取字节或向其写入字节，以及查询和修改当前的文件位置和将文件截取为指定大小等常见操作。它定义了在整个文件或具体文件区域上获取锁定的方法；这些方法返回 FileLock 类的实例。最后，它定义了对要写入到存储设备的文件进行强行更新的方法、在文件和其他通道之间高效传输字节的方法，以及将文件区域直接映射到内存中的方法。最后一个操作创建 MappedByteBuffer 类的实例，该实例扩展了 ByteBuffer 类，具有多种文件相关的操作。

已经向 java.io 包的每个 FileInputStream、FileOutputStream 和 RandomAccessFile 类添加了 getChannel 方法。在这些类的某个类的实例上调用此方法将返回一个连接到底层文件的文件通道。

多路复用，非阻塞 I/O

描述

SelectableChannel | 可实现多路复用的通道
  DatagramChannel | java.net.DatagramSocket 通道
  Pipe.SinkChannel | 对管道的写入结束
  Pipe.SourceChannel | 对管道的读取结束
  ServerSocketChannel   | java.net.ServerSocket 通道
  SocketChannel | java.net.Socket 通道
Selector | 可选择通道的多路复用器
SelectionKey 表示通道注册到选择器的标记
Pipe | 形成单向管道的两个通道

多路复用的非阻塞 I/O 比面向线程的阻塞 I/O 的可伸缩性更好，由选择器、可选择通道 和选择键 提供。

选择器 是可选择通道 的多路复用器，它是可被置于非阻塞模式 的特殊类型的通道。要执行多路复用的 I/O 操作，首先要创建一个或多个可选择通道、将其置于非阻塞模式，并将注册 到选择器注册一个通道会指定一组由选择器测试其是否准备就绪的 I/O 操作，并返回一个表示该注册的选择键。

一旦已经向选择器注册了通道，就可执行选择操作 以发现哪些通道（如果有）已经准备好执行先前已声明感兴趣的一个或多个操作。如果某个通道已准备就绪，则将注册时所返回的键添加到该选择器的已选择键集中。为了确定每个通道已准备好执行哪些操作，可以检查该键集和其中的键。为了执行所需的任何 I/O 操作，可根据每个键获取相应的通道。

指示其通道对某个操作已准备就绪的选择键只是一个提示，并不保证线程执行此种操作而不导致被阻塞。为了在这些提示证明不正确时忽略这些提示，则要强制写入负责执行多路复用 I/O 操作的代码。

此包定义了与 java.net 包中定义的 DatagramSocket、ServerSocket 和 Socket 类相对应的可选择通道类。为了支持与通道相关的套接字，已经对这些类进行了较小的更改。此包还定义了实现单向管道的简单类。在所有情况下，都是通过调用相应类的静态 open 方法来创建新的可选择通道。如果某个通道需要一个关联的套接字，则此操作同时也创建一个套接字。

可通过“插入”一个在 java.nio.channels.spi 包中定义的 SelectorProvider 类的替代定义或实例来替换选择器、可选通道和选择键的实现。并不期望很多开发人员都会实际使用这些设施；提供它的主要目的是为了在需要极高的性能时，能够让经验丰富的用户能充分利用特定于操作系统的 I/O 多路复用机制。

实现多路复用 I/O 抽象所要求的很多簿记和同步任务由 java.nio.channels.spi 包中的 AbstractInterruptibleChannel、AbstractSelectableChannel、AbstractSelectionKey 和 AbstractSelector 类来执行。在定义一个自定义的选择器提供者时，应该只直接扩展 AbstractSelector 和 AbstractSelectionKey 类；自定义通道类应该扩展此包中定义的适当 SelectableChannel 子类。

除非另行说明，否则将 null 参数传递给此包中任何类或接口的构造方法或方法将会导致抛出 NullPointerException。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.nio.channels 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.channels 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.FileChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
          • java.nio.channels.DatagramChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.Pipe.SinkChannel (implements java.nio.channels.GatheringByteChannel, java.nio.channels.WritableByteChannel)
          • java.nio.channels.Pipe.SourceChannel (implements java.nio.channels.ReadableByteChannel, java.nio.channels.ScatteringByteChannel)
          • java.nio.channels.ServerSocketChannel
          • java.nio.channels.SocketChannel (implements java.nio.channels.ByteChannel, java.nio.channels.GatheringByteChannel, java.nio.channels.ScatteringByteChannel)
    • java.nio.channels.Channels
    • java.nio.channels.FileChannel.MapMode
    • java.nio.channels.FileLock
    • java.nio.channels.Pipe
    • java.nio.channels.SelectionKey
    • java.nio.channels.Selector
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • java.nio.channels.ClosedChannelException
            • java.nio.channels.AsynchronousCloseException
              • java.nio.channels.ClosedByInterruptException
          • java.nio.channels.FileLockInterruptionException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.channels.IllegalSelectorException
            • java.nio.channels.UnresolvedAddressException
            • java.nio.channels.UnsupportedAddressTypeException
          • java.lang.IllegalStateException
            • java.nio.channels.AlreadyConnectedException
            • java.nio.channels.CancelledKeyException
            • java.nio.channels.ClosedSelectorException
            • java.nio.channels.ConnectionPendingException
            • java.nio.channels.IllegalBlockingModeException
            • java.nio.channels.NoConnectionPendingException
            • java.nio.channels.NonReadableChannelException
            • java.nio.channels.NonWritableChannelException
            • java.nio.channels.NotYetBoundException
            • java.nio.channels.NotYetConnectedException
            • java.nio.channels.OverlappingFileLockException

接口分层结构

  • java.io.Closeable
    • java.nio.channels.Channel
      • java.nio.channels.InterruptibleChannel
      • java.nio.channels.ReadableByteChannel
        • java.nio.channels.ByteChannel (并 extends java.nio.channels.WritableByteChannel)
        • java.nio.channels.ScatteringByteChannel
      • java.nio.channels.WritableByteChannel
        • java.nio.channels.ByteChannel (并 extends java.nio.channels.ReadableByteChannel)
        • java.nio.channels.GatheringByteChannel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.nio.channels 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.channels
的使用

使用 java.nio.channels 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.io 使用的 java.nio.channels 中的类
FileChannel
用于读取、写入、映射和操作文件的通道。

java.lang 使用的 java.nio.channels 中的类
Channel
用于 I/O 操作的连接。

java.net 使用的 java.nio.channels 中的类
DatagramChannel
针对面向数据报套接字的可选择通道。
ServerSocketChannel
针对面向流的侦听套接字的可选择通道。
SocketChannel
针对面向流的连接套接字的可选择通道。

java.nio.channels 使用的 java.nio.channels 中的类
AsynchronousCloseException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
ByteChannel
可读取和写入字节的信道。
Channel
用于 I/O 操作的连接。
ClosedChannelException
当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
DatagramChannel
针对面向数据报套接字的可选择通道。
FileChannel
用于读取、写入、映射和操作文件的通道。
FileChannel.MapMode
文件映射模式的类型安全的枚举。
FileLock
表示文件区域锁定的标记。
GatheringByteChannel
可从缓冲区序列写入字节的通道。
InterruptibleChannel
可被异步关闭和中断的通道。
Pipe
实现单向管道传送的通道对。
Pipe.SinkChannel
表示 Pipe 的可写入结尾的通道。
Pipe.SourceChannel
表示 Pipe 的可读取结尾的通道。
ReadableByteChannel
可读取字节的通道。
ScatteringByteChannel
可将字节读入缓冲区序列的通道。
SelectableChannel
可通过 Selector 实现多路复用的通道。
SelectionKey
表示 SelectableChannel 在 Selector 中的注册的标记。
Selector
SelectableChannel 对象的多路复用器。
ServerSocketChannel
针对面向流的侦听套接字的可选择通道。
SocketChannel
针对面向流的连接套接字的可选择通道。
WritableByteChannel
可写入字节的通道。

java.nio.channels.spi 使用的 java.nio.channels 中的类
AsynchronousCloseException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
Channel
用于 I/O 操作的连接。
ClosedChannelException
当试图对已关闭的、或者至少对某个 I/O 操作已关闭的信道上调用或完成该操作时，抛出此经过检查的异常。
DatagramChannel
针对面向数据报套接字的可选择通道。
InterruptibleChannel
可被异步关闭和中断的通道。
Pipe
实现单向管道传送的通道对。
SelectableChannel
可通过 Selector 实现多路复用的通道。
SelectionKey
表示 SelectableChannel 在 Selector 中的注册的标记。
Selector
SelectableChannel 对象的多路复用器。
ServerSocketChannel
针对面向流的侦听套接字的可选择通道。
SocketChannel
针对面向流的连接套接字的可选择通道。

java.util 使用的 java.nio.channels 中的类
ReadableByteChannel
可读取字节的通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractInterruptibleChannel (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio.channels.spi
类 AbstractInterruptibleChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
所有已实现的接口：
Closeable, Channel, InterruptibleChannel
直接已知子类：
FileChannel, SelectableChannel
public abstract class AbstractInterruptibleChannel
extends Object
implements Channel, InterruptibleChannel

可中断通道的基本实现类。

此类封装了实现通道异步关闭和中断所需的低级别机制。在调用可能无限期阻塞的 I/O 操作之前和之后，具体的通道类必须分别调用 begin 和 end 方法。为了确保始终能够调用 end 方法，应该在 try ... finally 块中使用这些方法：

 boolean completed = false;
 try {
     begin();
     completed = ...;    // Perform blocking I/O operation
return ...;         // Return result
 } finally {
     end(completed);
 }

end 方法的 completed 参数告知 I/O 操作实际是否已完成，也就是说它是否有任何对调用者可见的效果。例如，在读取字节的操作中，当且仅当确实将某些字节传输到调用者的目标缓冲区时此参数才应该为 true。

具体的通道类还必须实现 implCloseChannel 方法，其方式为：如果调用此方法的同时，另一个线程阻塞在该通道上的本机 I/O 操作中，则该操作将立即返回，要么抛出异常，要么正常返回。如果某个线程被中断，或者异步地关闭了阻塞线程所处的通道，则该通道的 end 方法会抛出相应的异常。

此类执行实现 Channel 规范所需的同步。implCloseChannel 方法的实现不必与其他可能试图关闭通道的线程同步。

从以下版本开始：
1.4

构造方法摘要
protected AbstractInterruptibleChannel()
初始化此类的一个新实例。
方法摘要
protected void | begin() 标记可能无限期阻塞的 I/O 操作的开始。
void | close() 关闭此通道。
protected void | end(boolean completed) 标记可能无限期阻塞的 I/O 操作的结尾。
protected abstract void | implCloseChannel() 关闭此通道。
boolean | isOpen() 判断此通道是否处于打开状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractInterruptibleChannel

protected AbstractInterruptibleChannel()
初始化此类的一个新实例。

方法详细信息

close

public final void close()
                 throws IOException
关闭此通道。

如果已关闭该通道，则此方法立即返回。否则它会将该通道标记为已关闭，然后调用 implCloseChannel 方法以完成关闭操作。

指定者：
接口 Closeable 中的 close
指定者：
接口 Channel 中的 close
指定者：
接口 InterruptibleChannel 中的 close
抛出：
IOException - 如果发生 I/O 错误

implCloseChannel

protected abstract void implCloseChannel()
                                  throws IOException
关闭此通道。

为了实际关闭此通道，由 close 方法调用此方法。仅在此通道尚未关闭时才能调用此方法，并且只能调用一次。

此方法的实现必须安排阻塞于此通道上 I/O 操作中的所有其他线程立即返回，要么抛出异常，要么正常返回。

抛出：
IOException - 如果关闭通道的同时发生 I/O 错误

isOpen

public final boolean isOpen()
从接口 Channel 复制的描述
判断此通道是否处于打开状态。

指定者：
接口 Channel 中的 isOpen
返回：
当且仅当此通道处于打开状态时才返回 true

begin

protected final void begin()
标记可能无限期阻塞的 I/O 操作的开始。

为了实现此通道的异步关闭和中断，应该使用上面所示的 try ... finally 块先后调用此方法和 end 方法。

end

protected final void end(boolean completed)
                  throws AsynchronousCloseException
标记可能无限期阻塞的 I/O 操作的结尾。

为了实现此通道的异步关闭和中断，应该使用上面所示的 try ... finally 块先后调用此方法和 begin 方法。

参数：
completed - 当且仅当 I/O 操作成功完成（也就是说该操作产生对其调用者可见的效果）时才为 true
抛出：
AsynchronousCloseException - 如果已经异步地关闭了通道
ClosedByInterruptException - 如果已中断了阻塞在 I/O 操作中的线程
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractSelectableChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels.spi
类 AbstractSelectableChannel

java.lang.Object
    继承者  java.nio.channels.spi.AbstractInterruptibleChannel
        继承者  java.nio.channels.SelectableChannel
            继承者  java.nio.channels.spi.AbstractSelectableChannel
所有已实现的接口：
Closeable, Channel, InterruptibleChannel
直接已知子类：
DatagramChannel, Pipe.SinkChannel, Pipe.SourceChannel, ServerSocketChannel, SocketChannel
public abstract class AbstractSelectableChannel
extends SelectableChannel

可选择通道的基本实现类。

此类定义了处理通道注册、注销和关闭机制的各种方法。它会维持此通道的当前阻塞模式及其当前的选择键集。它执行实现 SelectableChannel 规范所需的所有同步。此类中所定义的抽象保护方法的实现不必与同一操作中使用的其他线程同步。

从以下版本开始：
1.4

构造方法摘要
protected AbstractSelectableChannel(SelectorProvider provider)
初始化此类的一个新实例。
方法摘要
Object | blockingLock() 获取其 configureBlocking 和 register 方法实现同步的对象。
SelectableChannel | configureBlocking(boolean block) 调整此通道的阻塞模式。
protected void | implCloseChannel() 关闭此通道。
protected abstract void | implCloseSelectableChannel() 关闭此可选择通道。
protected abstract void | implConfigureBlocking(boolean block) 调整此通道的阻塞模式。
boolean | isBlocking() 判断此通道上的每个 I/O 操作在完成前是否被阻塞。
boolean | isRegistered() 判断此通道当前是否已向任何选择器注册。
SelectionKey | keyFor(Selector sel) 获取表示通道向给定选择器注册的键。
SelectorProvider | provider() 返回创建此通道的提供者。
SelectionKey | register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。
从类 java.nio.channels.SelectableChannel 继承的方法
register, validOps
从类 java.nio.channels.spi.AbstractInterruptibleChannel 继承的方法
begin, close, end, isOpen
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.nio.channels.Channel 继承的方法
close, isOpen

构造方法详细信息

AbstractSelectableChannel

protected AbstractSelectableChannel(SelectorProvider provider)
初始化此类的一个新实例。

方法详细信息

provider

public final SelectorProvider provider()
返回创建此通道的提供者。

指定者：
类 SelectableChannel 中的 provider
返回：
创建此通道的提供者

isRegistered

public final boolean isRegistered()
从类 SelectableChannel 复制的描述
判断此通道当前是否已向任何选择器注册。新创建的通道总是未注册的。

由于键取消和通道注销之间固有的延迟，所以在已取消某个通道的所有键后，该通道可能在一定时间内还会保持已注册状态。关闭通道后，该通道可能在一定时间内还会保持已注册状态。

指定者：
类 SelectableChannel 中的 isRegistered
返回：
当且仅当此通道为已注册时才返回 true

keyFor

public final SelectionKey keyFor(Selector sel)
从类 SelectableChannel 复制的描述
获取表示通道向给定选择器注册的键。

指定者：
类 SelectableChannel 中的 keyFor
返回：
当此通道是向给定选择器注册的最后一个通道时返回该键，如果此通道当前未向该选择器注册，则返回 null

register

public final SelectionKey register(Selector sel,
                                   int ops,
                                   Object att)
                            throws ClosedChannelException
向给定的选择器注册此通道，返回一个选择键。

此方法首先验证此通道是否已打开，以及给定的初始相关操作集是否有效。

如果已向给定的选择器注册了此通道，则在将其相关操作集设置为给定值后，返回表示该注册的选择键。

如果尚未向给定的选择器注册此通道，则在保持适当锁定的同时调用选择器的 register 方法。返回前将得到的键添加到此通道的键集中。

指定者：
类 SelectableChannel 中的 register
参数：
sel - 要向其注册此通道的选择器
ops - 所得键的可用操作集
att - 所得键的附件，可能为 null
返回：
表示此通道向给定选择器注册的键
抛出：
ClosedChannelException - 如果此通道已关闭

implCloseChannel

protected final void implCloseChannel()
                               throws IOException
关闭此通道。

此方法在 AbstractInterruptibleChannel 类中指定并且由 close 方法调用，为了实际关闭此通道，此方法依次调用 implCloseSelectableChannel 方法。然后取消此通道的所有键。

指定者：
类 AbstractInterruptibleChannel 中的 implCloseChannel
抛出：
IOException - 如果关闭通道的同时发生 I/O 错误

implCloseSelectableChannel

protected abstract void implCloseSelectableChannel()
                                            throws IOException
关闭此可选择通道。

为了实际关闭此通道，由 close 方法调用此方法。仅在此通道尚未关闭时才能调用此方法，并且只能调用一次。

此方法的实现必须安排阻塞于此通道上 I/O 操作中的所有其他线程立即返回，要么抛出异常，要么正常返回。

抛出：
IOException

isBlocking

public final boolean isBlocking()
从类 SelectableChannel 复制的描述
判断此通道上的每个 I/O 操作在完成前是否被阻塞。新创建的通道总是处于阻塞模式。

如果此通道已关闭，则此方法返回的值是未指定的。

指定者：
类 SelectableChannel 中的 isBlocking
返回：
当且仅当此通道处于阻塞模式时才返回 true

blockingLock

public final Object blockingLock()
从类 SelectableChannel 复制的描述
获取其 configureBlocking 和 register 方法实现同步的对象。在要求在短时间内维持特定阻塞模式的适配器实现中，这通常是很有用的。

指定者：
类 SelectableChannel 中的 blockingLock
返回：
阻塞模式锁定对象

configureBlocking

public final SelectableChannel configureBlocking(boolean block)
                                          throws IOException
调整此通道的阻塞模式。

如果给定的阻塞模式与当前的阻塞模式不同，那么为了改变该模式，此方法调用 implConfigureBlocking 方法，同时保持适当的锁定。

指定者：
类 SelectableChannel 中的 configureBlocking
参数：
block - 如果为 true，则此通道将被置于阻塞模式；如果为 false，则此通道将被置于非阻塞模式
返回：
此可选择通道
抛出：
ClosedChannelException - 如果此通道已关闭
IOException - 如果发生 I/O 错误

implConfigureBlocking

protected abstract void implConfigureBlocking(boolean block)
                                       throws IOException
调整此通道的阻塞模式。

为了执行实际的更改阻塞模式的工作，由 configureBlocking 方法调用此方法。仅在新模式与当前模式不同时才调用此方法。

抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractSelectionKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels.spi
类 AbstractSelectionKey

java.lang.Object
    继承者  java.nio.channels.SelectionKey
        继承者  java.nio.channels.spi.AbstractSelectionKey

public abstract class AbstractSelectionKey
extends SelectionKey

选择键的基本实现类。

此类跟踪键的有效性并实现取消。

从以下版本开始：
1.4

字段摘要
从类 java.nio.channels.SelectionKey 继承的字段
OP_ACCEPT, OP_CONNECT, OP_READ, OP_WRITE
构造方法摘要
protected AbstractSelectionKey()
初始化此类的一个新实例。
方法摘要
void | cancel() 取消此键。
boolean | isValid() 告知此键是否有效。
从类 java.nio.channels.SelectionKey 继承的方法
attach, attachment, channel, interestOps, interestOps, isAcceptable, isConnectable, isReadable, isWritable, readyOps, selector
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractSelectionKey

protected AbstractSelectionKey()
初始化此类的一个新实例。

方法详细信息

isValid

public final boolean isValid()
从类 SelectionKey 复制的描述
告知此键是否有效。

键在创建时是有效的，并在被取消、其通道已关闭或者其选择器已关闭之前保持有效。

指定者：
类 SelectionKey 中的 isValid
返回：
当且仅当此键有效时才返回 true

cancel

public final void cancel()
取消此键。

如果尚未取消此键，则将该键添加到其选择器的已取消键集中，同时在该键集上实现同步。

指定者：
类 SelectionKey 中的 cancel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractSelector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.channels.spi
类 AbstractSelector

java.lang.Object
    继承者  java.nio.channels.Selector
        继承者  java.nio.channels.spi.AbstractSelector

public abstract class AbstractSelector
extends Selector

选择器的基本实现类。

此类封装了实现中断选择操作所需的低级别机制。在调用可能无限期阻塞的 I/O 操作之前和之后，具体的选择器类必须分别调用 begin 和 end 方法。为了确保始终能够调用 end 方法，应该在 try ... finally 块中使用这些方法：

 try {
     begin();
     // Perform blocking I/O operation here
     ...
 } finally {
     end();
 }

此类还定义了用于维护选择器的已取消键集和从其通道的键集中移除键的方法，并且为了执行实际的通道注册工作，还声明了由可选择通道的 register 方法所调用的抽象 register 方法。

从以下版本开始：
1.4

构造方法摘要
protected AbstractSelector(SelectorProvider provider)
初始化此类的一个新实例。
方法摘要
protected void | begin() 标记可能无限期阻塞的 I/O 操作的开始。
protected Set<SelectionKey> | cancelledKeys() 获取此选择器的已取消键集。
void | close() 关闭此选择器。
protected void | deregister(AbstractSelectionKey key) 从其通道的键集中移除给定的键。
protected void | end() 标记可能无限期阻塞的 I/O 操作的结束。
protected abstract void | implCloseSelector() 关闭此选择器。
boolean | isOpen() 告知此选择器是否已打开。
SelectorProvider | provider() 返回创建此通道的提供者。
protected abstract SelectionKey | register(AbstractSelectableChannel ch, int ops, Object att) 向此选择器注册给定的通道。
从类 java.nio.channels.Selector 继承的方法
keys, open, select, select, selectedKeys, selectNow, wakeup
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractSelector

protected AbstractSelector(SelectorProvider provider)
初始化此类的一个新实例。

方法详细信息

close

public final void close()
                 throws IOException
关闭此选择器。

如果已关闭该选择器，则此方法立即返回。否则它会将该选择器标记为已关闭，然后调用 implCloseSelector 方法以完成关闭操作。

指定者：
类 Selector 中的 close
抛出：
IOException - 如果发生 I/O 错误

implCloseSelector

protected abstract void implCloseSelector()
                                   throws IOException
关闭此选择器。

为了实际关闭选择器，由 close 方法调用此方法。仅在尚未关闭此选择器时才能调用此方法，并且只能调用一次。

此方法的实现必须安排阻塞于此选择器上选择操作中的所有其他线程立即返回，就像调用 wakeup 方法一样。

抛出：
IOException - 如果关闭选择器的同时发生 I/O 错误

isOpen

public final boolean isOpen()
从类 Selector 复制的描述
告知此选择器是否已打开。

指定者：
类 Selector 中的 isOpen
返回：
当且仅当此选择器已打开时才返回 true

provider

public final SelectorProvider provider()
返回创建此通道的提供者。

指定者：
类 Selector 中的 provider
返回：
创建此通道的提供者

cancelledKeys

protected final Set<SelectionKey> cancelledKeys()
获取此选择器的已取消键集。

仅应在该键集上实现同步后才能使用它。

返回：
已取消键集

register

protected abstract SelectionKey register(AbstractSelectableChannel ch,
                                         int ops,
                                         Object att)
向此选择器注册给定的通道。

为了实际向此选择器注册通道，由该通道的 register 方法调用此方法。

参数：
ch - 要注册的通道
ops - 初始的相关操作集，必须是有效的
att - 所得键的初始附件
返回：
表示给定通道向此选择器注册的新键

deregister

protected final void deregister(AbstractSelectionKey key)
从其通道的键集中移除给定的键。

必须由选择器为所注销的每个通道调用此方法。

参数：
key - 要移除的选择键

begin

protected final void begin()
标记可能无限期阻塞的 I/O 操作的开始。

为了实现此选择器的中断，应该使用上面所示的 try ... finally 块先后调用此方法和 end 方法。

如果调用某个线程的 interrupt 方法的同时该线程阻塞于选择器上的某个 I/O 操作中，则调用此方法来安排选择器的 wakeup 方法被调用。

end

protected final void end()
标记可能无限期阻塞的 I/O 操作的结束。

为了实现此选择器的中断，应该使用上面所示的 try ... finally 块先后调用此方法和 begin 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SelectorProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio.channels.spi
类 SelectorProvider

java.lang.Object
    继承者  java.nio.channels.spi.SelectorProvider

public abstract class SelectorProvider
extends Object

用于选择器和可选择通道的服务提供者类。

选择器提供者是此类的一个具体子类，它具有零参数的构造方法，并实现了以下指定的抽象方法。给定的对 Java 虚拟机的调用维护了单个系统级的默认提供者实例，它由 provider 方法返回。第一次调用该方法将查找以下指定的默认提供者。

系统级的默认提供者由 DatagramChannel、Pipe、Selector、ServerSocketChannel 和 SocketChannel 类的静态 open 方法使用。System.inheritedChannel() 方法也使用它。除了默认提供者之外，程序还可以使用其他提供者，方法是通过实例化一个提供者，然后直接调用此类中定义的 open 方法。

多个并发线程可安全地使用此类中的所有方法。

从以下版本开始：
1.4

构造方法摘要
protected SelectorProvider()
初始化此类的一个新实例。
方法摘要
Channel | inheritedChannel() 返回从创建此 Java 虚拟机的实体中继承的通道。
abstract DatagramChannel | openDatagramChannel() 打开数据报通道。
abstract Pipe | openPipe() 打开一个管道。
abstract AbstractSelector | openSelector() 打开一个选择器。
abstract ServerSocketChannel | openServerSocketChannel() 打开服务器套接字通道。
abstract SocketChannel | openSocketChannel() 打开套接字通道。
static SelectorProvider | provider() 返回此次调用 Java 虚拟机的系统级默认选择器提供者。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SelectorProvider

protected SelectorProvider()
初始化此类的一个新实例。

抛出：
SecurityException - 如果已安装安全管理器并且它拒绝 RuntimePermission ("selectorProvider")
方法详细信息

provider

public static SelectorProvider provider()
返回此次调用 Java 虚拟机的系统级默认选择器提供者。

首次调用此方法会按如下方式查找默认的提供者对象：

  1. 如果定义了系统属性 java.nio.channels.spi.SelectorProvider，则将该属性名看作具体提供者类的完全限定名。加载并实例化该类；如果此进程失败，则抛出未指定的错误。

  2. 如果在对系统类加载器可见的 jar 文件中安装了提供者类，并且该 jar 文件包含资源目录 META-INF/services 中名为 java.nio.channels.spi.SelectorProvider 的提供者配置文件，则采用在该文件中指定的第一个类名称。加载并实例化该类；如果此进程失败，则抛出未指定的错误。

  3. 最后，如果未通过上述任意方式指定任何提供者，则实例化系统默认的提供者类并返回该结果。

后续调用此方法会返回首次调用此方法时所返回的提供者。

返回：
系统级默认选择器提供者

openDatagramChannel

public abstract DatagramChannel openDatagramChannel()
                                             throws IOException
打开数据报通道。

返回：
新的通道
抛出：
IOException

openPipe

public abstract Pipe openPipe()
                       throws IOException
打开一个管道。

返回：
新管道
抛出：
IOException

openSelector

public abstract AbstractSelector openSelector()
                                       throws IOException
打开一个选择器。

返回：
新的选择器
抛出：
IOException

openServerSocketChannel

public abstract ServerSocketChannel openServerSocketChannel()
                                                     throws IOException
打开服务器套接字通道。

返回：
新的通道
抛出：
IOException

openSocketChannel

public abstract SocketChannel openSocketChannel()
                                         throws IOException
打开套接字通道。

返回：
新的通道
抛出：
IOException

inheritedChannel

public Channel inheritedChannel()
                         throws IOException
返回从创建此 Java 虚拟机的实体中继承的通道。

在很多操作系统上可以通过下列方式启动某个进程（如 Java 虚拟机）：即允许该进程从创建该进程的实体上继承一个通道。正如连接到通道的可能实体一样，完成此继承的方式与系统相关。例如，在 UNIX 系统上，当请求到达关联的网络端口时，使用 Internet 服务守护程序 (inetd) 启动程序来服务该请求。在本例中，所启动的进程继承了一个表示网络套接字的通道。

在所继承的通道表示网络套接字的情况下，以如下方式确定此方法所返回的 Channel 类型：

  • 如果继承的通道表示一个面向流的已连接套接字，则返回 SocketChannel。该套接字通道是处于（至少最初是）阻塞模式的、已绑定到套接字地址，并且已连接到同位体。

  • 如果继承的通道表示一个面向流的侦听套接字，则返回 ServerSocketChannel。该服务器套接字通道处于（至少最初是）阻塞模式，并且已绑定到套接字地址，

  • 如果继承的通道表示一个面向数据报的套接字，则返回 DatagramChannel。该数据报通道处于（至少最初是）阻塞模式，并且已绑定到套接字地址，

除了已描述的面向网络的通道之外，此方法以后还可能返回其他类型的通道。

首次调用此方法会创建所返回的通道。后续调用此方法会返回相同的通道。

返回：
继承的通道（如果有），否则返回 null。
抛出：
IOException - 如果发生 I/O 错误
SecurityException - 如果已安装安全管理器并且它拒绝 RuntimePermission ("inheritedChannel")
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.nio.channels.spi (Java 2 Platform SE 6)

 java.nio.channels.spi
类
AbstractInterruptibleChannel
AbstractSelectableChannel
AbstractSelectionKey
AbstractSelector
SelectorProvider


java.nio.channels.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.nio.channels.spi

用于 java.nio.channels 包的服务提供者类。

请参见：
描述

类摘要
AbstractInterruptibleChannel | 可中断通道的基本实现类。
AbstractSelectableChannel | 可选择通道的基本实现类。
AbstractSelectionKey | 选择键的基本实现类。
AbstractSelector | 选择器的基本实现类。
SelectorProvider | 用于选择器和可选择通道的服务提供者类。

软件包 java.nio.channels.spi 的描述

用于 java.nio.channels 包的服务提供者类。

只有那些定义新的选择器提供者的开发人员才应直接使用此包。

除非另行说明，否则将 null 参数传递给此包中任何类或接口的构造方法或方法将会导致抛出 NullPointerException。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.nio.channels.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.channels.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.nio.channels.spi.AbstractInterruptibleChannel (implements java.nio.channels.Channel, java.nio.channels.InterruptibleChannel)
      • java.nio.channels.SelectableChannel (implements java.nio.channels.Channel)
        • java.nio.channels.spi.AbstractSelectableChannel
    • java.nio.channels.SelectionKey
      • java.nio.channels.spi.AbstractSelectionKey
    • java.nio.channels.Selector
      • java.nio.channels.spi.AbstractSelector
    • java.nio.channels.spi.SelectorProvider
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.nio.channels.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.channels.spi
的使用

使用 java.nio.channels.spi 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 使用的 java.nio.channels.spi 中的类
AbstractInterruptibleChannel
可中断通道的基本实现类。
AbstractSelectableChannel
可选择通道的基本实现类。
SelectorProvider
用于选择器和可选择通道的服务提供者类。

java.nio.channels.spi 使用的 java.nio.channels.spi 中的类
AbstractInterruptibleChannel
可中断通道的基本实现类。
AbstractSelectableChannel
可选择通道的基本实现类。
AbstractSelectionKey
选择键的基本实现类。
AbstractSelector
选择器的基本实现类。
SelectorProvider
用于选择器和可选择通道的服务提供者类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.spi.AbstractSelectionKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractSelectionKey
的使用

使用 AbstractSelectionKey 的软件包
java.nio.channels.spi 用于 java.nio.channels 包的服务提供者类。

java.nio.channels.spi 中 AbstractSelectionKey 的使用

参数类型为 AbstractSelectionKey 的 java.nio.channels.spi 中的方法
protected  void AbstractSelector.deregister(AbstractSelectionKey key)
从其通道的键集中移除给定的键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.spi.AbstractSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractSelector
的使用

使用 AbstractSelector 的软件包
java.nio.channels.spi 用于 java.nio.channels 包的服务提供者类。

java.nio.channels.spi 中 AbstractSelector 的使用

返回 AbstractSelector 的 java.nio.channels.spi 中的方法
abstract  AbstractSelector SelectorProvider.openSelector()
打开一个选择器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.spi.SelectorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.SelectorProvider
的使用

使用 SelectorProvider 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 SelectorProvider 的使用

返回 SelectorProvider 的 java.nio.channels 中的方法
abstract SelectorProvider | Selector.provider() 返回创建此通道的提供者。
abstract SelectorProvider | SelectableChannel.provider() 返回创建此通道的提供者。

参数类型为 SelectorProvider 的 java.nio.channels 中的构造方法
DatagramChannel(SelectorProvider provider)
初始化此类的一个新实例。
Pipe.SinkChannel(SelectorProvider provider)
初始化此类的一个新实例。
Pipe.SourceChannel(SelectorProvider provider)
构造此类的一个新实例。
ServerSocketChannel(SelectorProvider provider)
初始化此类的一个新实例。
SocketChannel(SelectorProvider provider)
初始化此类的一个新实例。

java.nio.channels.spi 中 SelectorProvider 的使用

返回 SelectorProvider 的 java.nio.channels.spi 中的方法
SelectorProvider | AbstractSelector.provider() 返回创建此通道的提供者。
static SelectorProvider | SelectorProvider.provider() 返回此次调用 Java 虚拟机的系统级默认选择器提供者。
SelectorProvider | AbstractSelectableChannel.provider() 返回创建此通道的提供者。

参数类型为 SelectorProvider 的 java.nio.channels.spi 中的构造方法
AbstractSelectableChannel(SelectorProvider provider)
初始化此类的一个新实例。
AbstractSelector(SelectorProvider provider)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.spi.AbstractSelectableChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractSelectableChannel
的使用

使用 AbstractSelectableChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 AbstractSelectableChannel 的使用

java.nio.channels 中 AbstractSelectableChannel 的子类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 AbstractSelectableChannel 的使用

参数类型为 AbstractSelectableChannel 的 java.nio.channels.spi 中的方法
protected abstract  SelectionKey AbstractSelector.register(AbstractSelectableChannel ch, int ops, Object att)
向此选择器注册给定的通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.spi.AbstractInterruptibleChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.spi.AbstractInterruptibleChannel
的使用

使用 AbstractInterruptibleChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 AbstractInterruptibleChannel 的使用

java.nio.channels 中 AbstractInterruptibleChannel 的子类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 AbstractInterruptibleChannel 的使用

java.nio.channels.spi 中 AbstractInterruptibleChannel 的子类
 class AbstractSelectableChannel
可选择通道的基本实现类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.AlreadyConnectedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.AlreadyConnectedException
的使用

没有 java.nio.channels.AlreadyConnectedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.AsynchronousCloseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.AsynchronousCloseException
的使用

使用 AsynchronousCloseException 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 AsynchronousCloseException 的使用

java.nio.channels 中 AsynchronousCloseException 的子类
 class ClosedByInterruptException
当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。

java.nio.channels.spi 中 AsynchronousCloseException 的使用

抛出 AsynchronousCloseException 的 java.nio.channels.spi 中的方法
protected  void AbstractInterruptibleChannel.end(boolean completed)
标记可能无限期阻塞的 I/O 操作的结尾。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.CancelledKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.CancelledKeyException
的使用

没有 java.nio.channels.CancelledKeyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.Channels 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Channels
的使用

没有 java.nio.channels.Channels 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.ClosedByInterruptException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ClosedByInterruptException
的使用

没有 java.nio.channels.ClosedByInterruptException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.ClosedChannelException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ClosedChannelException
的使用

使用 ClosedChannelException 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 ClosedChannelException 的使用

java.nio.channels 中 ClosedChannelException 的子类
class | AsynchronousCloseException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程关闭了该信道或部分信道时，该信道所接收的经过检查的异常。
class | ClosedByInterruptException 当在某个信道的 I/O 操作中处于阻塞状态的某个线程被另一个线程中断时，该线程将收到此经过检查的异常。

抛出 ClosedChannelException 的 java.nio.channels 中的方法
SelectionKey | SelectableChannel.register(Selector sel, int ops) 向给定的选择器注册此通道，返回一个选择键。
abstract SelectionKey | SelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

java.nio.channels.spi 中 ClosedChannelException 的使用

抛出 ClosedChannelException 的 java.nio.channels.spi 中的方法
 SelectionKey AbstractSelectableChannel.register(Selector sel, int ops, Object att)
向给定的选择器注册此通道，返回一个选择键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.ClosedSelectorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ClosedSelectorException
的使用

没有 java.nio.channels.ClosedSelectorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.ConnectionPendingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ConnectionPendingException
的使用

没有 java.nio.channels.ConnectionPendingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.DatagramChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.DatagramChannel
的使用

使用 DatagramChannel 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.net 中 DatagramChannel 的使用

返回 DatagramChannel 的 java.net 中的方法
 DatagramChannel DatagramSocket.getChannel()
返回与此数据报套接字关联的唯一 DatagramChannel 对象（如果有）。

java.nio.channels 中 DatagramChannel 的使用

返回 DatagramChannel 的 java.nio.channels 中的方法
abstract DatagramChannel | DatagramChannel.connect(SocketAddress remote) 连接此通道的套接字。
abstract DatagramChannel | DatagramChannel.disconnect() 断开此通道套接字的连接。
static DatagramChannel | DatagramChannel.open() 打开数据报通道。

java.nio.channels.spi 中 DatagramChannel 的使用

返回 DatagramChannel 的 java.nio.channels.spi 中的方法
abstract  DatagramChannel SelectorProvider.openDatagramChannel()
打开数据报通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.FileLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileLock
的使用

使用 FileLock 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 FileLock 的使用

返回 FileLock 的 java.nio.channels 中的方法
FileLock | FileChannel.lock() 获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.lock(long position, long size, boolean shared) 获取此通道的文件给定区域上的锁定。
FileLock | FileChannel.tryLock() 试图获取对此通道的文件的独占锁定。
abstract FileLock | FileChannel.tryLock(long position, long size, boolean shared) 试图获取对此通道的文件给定区域的锁定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.FileLockInterruptionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileLockInterruptionException
的使用

没有 java.nio.channels.FileLockInterruptionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.IllegalBlockingModeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.IllegalBlockingModeException
的使用

没有 java.nio.channels.IllegalBlockingModeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.IllegalSelectorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.IllegalSelectorException
的使用

没有 java.nio.channels.IllegalSelectorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.NoConnectionPendingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NoConnectionPendingException
的使用

没有 java.nio.channels.NoConnectionPendingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.NonReadableChannelException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NonReadableChannelException
的使用

没有 java.nio.channels.NonReadableChannelException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.NonWritableChannelException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NonWritableChannelException
的使用

没有 java.nio.channels.NonWritableChannelException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.NotYetBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NotYetBoundException
的使用

没有 java.nio.channels.NotYetBoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.NotYetConnectedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.NotYetConnectedException
的使用

没有 java.nio.channels.NotYetConnectedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.OverlappingFileLockException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.OverlappingFileLockException
的使用

没有 java.nio.channels.OverlappingFileLockException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.Pipe 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Pipe
的使用

使用 Pipe 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 Pipe 的使用

返回 Pipe 的 java.nio.channels 中的方法
static Pipe Pipe.open()
打开一个管道。

java.nio.channels.spi 中 Pipe 的使用

返回 Pipe 的 java.nio.channels.spi 中的方法
abstract  Pipe SelectorProvider.openPipe()
打开一个管道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.Pipe.SourceChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Pipe.SourceChannel
的使用

使用 Pipe.SourceChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 Pipe.SourceChannel 的使用

返回 Pipe.SourceChannel 的 java.nio.channels 中的方法
abstract  Pipe.SourceChannel Pipe.source()
返回此管道的源通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.Pipe.SinkChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Pipe.SinkChannel
的使用

使用 Pipe.SinkChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 Pipe.SinkChannel 的使用

返回 Pipe.SinkChannel 的 java.nio.channels 中的方法
abstract  Pipe.SinkChannel Pipe.sink()
返回此管道的接收器通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.SelectionKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.SelectionKey
的使用

使用 SelectionKey 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 SelectionKey 的使用

返回 SelectionKey 的 java.nio.channels 中的方法
abstract SelectionKey | SelectionKey.interestOps(int ops) 将此键的 interest 集合设置为给定值。
abstract SelectionKey | SelectableChannel.keyFor(Selector sel) 获取表示通道向给定选择器注册的键。
SelectionKey | SelectableChannel.register(Selector sel, int ops) 向给定的选择器注册此通道，返回一个选择键。
abstract SelectionKey | SelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

返回变量类型为 SelectionKey 的类型的 java.nio.channels 中的方法
abstract Set<SelectionKey> | Selector.keys() 返回此选择器的键集。
abstract Set<SelectionKey> | Selector.selectedKeys() 返回此选择器的已选择键集。

java.nio.channels.spi 中 SelectionKey 的使用

java.nio.channels.spi 中 SelectionKey 的子类
 class AbstractSelectionKey
选择键的基本实现类。

返回 SelectionKey 的 java.nio.channels.spi 中的方法
SelectionKey | AbstractSelectableChannel.keyFor(Selector sel)
protected abstract SelectionKey | AbstractSelector.register(AbstractSelectableChannel ch, int ops, Object att) 向此选择器注册给定的通道。
SelectionKey | AbstractSelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

返回变量类型为 SelectionKey 的类型的 java.nio.channels.spi 中的方法
protected  Set<SelectionKey> AbstractSelector.cancelledKeys()
获取此选择器的已取消键集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.Selector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.Selector
的使用

使用 Selector 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 Selector 的使用

返回 Selector 的 java.nio.channels 中的方法
static Selector | Selector.open() 打开一个选择器。
abstract Selector | SelectionKey.selector() 返回为此选择器创建的键。
abstract Selector | Selector.wakeup() 使尚未返回的第一个选择操作立即返回。

参数类型为 Selector 的 java.nio.channels 中的方法
abstract SelectionKey | SelectableChannel.keyFor(Selector sel) 获取表示通道向给定选择器注册的键。
SelectionKey | SelectableChannel.register(Selector sel, int ops) 向给定的选择器注册此通道，返回一个选择键。
abstract SelectionKey | SelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

java.nio.channels.spi 中 Selector 的使用

java.nio.channels.spi 中 Selector 的子类
 class AbstractSelector
选择器的基本实现类。

参数类型为 Selector 的 java.nio.channels.spi 中的方法
SelectionKey | AbstractSelectableChannel.keyFor(Selector sel)
SelectionKey | AbstractSelectableChannel.register(Selector sel, int ops, Object att) 向给定的选择器注册此通道，返回一个选择键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.ServerSocketChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.ServerSocketChannel
的使用

使用 ServerSocketChannel 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.net 中 ServerSocketChannel 的使用

返回 ServerSocketChannel 的 java.net 中的方法
 ServerSocketChannel ServerSocket.getChannel()
返回与此套接字关联的唯一 ServerSocketChannel 对象（如果有）。

java.nio.channels 中 ServerSocketChannel 的使用

返回 ServerSocketChannel 的 java.nio.channels 中的方法
static ServerSocketChannel ServerSocketChannel.open()
打开服务器套接字通道。

java.nio.channels.spi 中 ServerSocketChannel 的使用

返回 ServerSocketChannel 的 java.nio.channels.spi 中的方法
abstract  ServerSocketChannel SelectorProvider.openServerSocketChannel()
打开服务器套接字通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.UnresolvedAddressException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.UnresolvedAddressException
的使用

没有 java.nio.channels.UnresolvedAddressException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.UnsupportedAddressTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.UnsupportedAddressTypeException
的使用

没有 java.nio.channels.UnsupportedAddressTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.SocketChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.SocketChannel
的使用

使用 SocketChannel 的软件包
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.net 中 SocketChannel 的使用

返回 SocketChannel 的 java.net 中的方法
 SocketChannel Socket.getChannel()
返回与此数据报套接字关联的唯一 SocketChannel 对象（如果有）。

java.nio.channels 中 SocketChannel 的使用

返回 SocketChannel 的 java.nio.channels 中的方法
abstract SocketChannel | ServerSocketChannel.accept() 接受到此通道套接字的连接。
static SocketChannel | SocketChannel.open() 打开套接字通道。
static SocketChannel | SocketChannel.open(SocketAddress remote) 打开套接字通道并将其连接到远程地址。

java.nio.channels.spi 中 SocketChannel 的使用

返回 SocketChannel 的 java.nio.channels.spi 中的方法
abstract  SocketChannel SelectorProvider.openSocketChannel()
打开套接字通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.SelectableChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.SelectableChannel
的使用

使用 SelectableChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 SelectableChannel 的使用

java.nio.channels 中 SelectableChannel 的子类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

返回 SelectableChannel 的 java.nio.channels 中的方法
abstract SelectableChannel | SelectionKey.channel() 返回为之创建此键的通道。
abstract SelectableChannel | SelectableChannel.configureBlocking(boolean block) 调整此通道的阻塞模式。

java.nio.channels.spi 中 SelectableChannel 的使用

java.nio.channels.spi 中 SelectableChannel 的子类
 class AbstractSelectableChannel
可选择通道的基本实现类。

返回 SelectableChannel 的 java.nio.channels.spi 中的方法
 SelectableChannel AbstractSelectableChannel.configureBlocking(boolean block)
调整此通道的阻塞模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.FileChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileChannel
的使用

使用 FileChannel 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.io 中 FileChannel 的使用

返回 FileChannel 的 java.io 中的方法
FileChannel | RandomAccessFile.getChannel() 返回与此文件关联的唯一 FileChannel 对象。
FileChannel | FileOutputStream.getChannel() 返回与此文件输出流有关的唯一 FileChannel 对象。
FileChannel | FileInputStream.getChannel() 返回与此文件输入流有关的唯一 FileChannel 对象。

java.nio.channels 中 FileChannel 的使用

返回 FileChannel 的 java.nio.channels 中的方法
FileChannel | FileLock.channel() 返回文件通道，此锁定保持在该通道的文件上。
abstract FileChannel | FileChannel.position(long newPosition) 设置此通道的文件位置。
abstract FileChannel | FileChannel.truncate(long size) 将此通道的文件截取为给定大小。

参数类型为 FileChannel 的 java.nio.channels 中的构造方法
FileLock(FileChannel channel, long position, long size, boolean shared)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.channels.FileChannel.MapMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.channels.FileChannel.MapMode
的使用

使用 FileChannel.MapMode 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 FileChannel.MapMode 的使用

声明为 FileChannel.MapMode 的 java.nio.channels 中的字段
static FileChannel.MapMode | FileChannel.MapMode.PRIVATE 专用（写入时拷贝）映射模式。
static FileChannel.MapMode | FileChannel.MapMode.READ_ONLY 只读映射模式。
static FileChannel.MapMode | FileChannel.MapMode.READ_WRITE 读取/写入映射模式。

参数类型为 FileChannel.MapMode 的 java.nio.channels 中的方法
abstract  MappedByteBuffer FileChannel.map(FileChannel.MapMode mode, long position, long size)
将此通道的文件区域直接映射到内存中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.nio.channels.InterruptibleChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.InterruptibleChannel
的使用

使用 InterruptibleChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.nio.channels 中 InterruptibleChannel 的使用

实现 InterruptibleChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 InterruptibleChannel 的使用

实现 InterruptibleChannel 的 java.nio.channels.spi 中的类
class | AbstractInterruptibleChannel 可中断通道的基本实现类。
class | AbstractSelectableChannel 可选择通道的基本实现类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.nio.channels.ScatteringByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.ScatteringByteChannel
的使用

使用 ScatteringByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 ScatteringByteChannel 的使用

实现 ScatteringByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.nio.channels.GatheringByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.GatheringByteChannel
的使用

使用 GatheringByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 GatheringByteChannel 的使用

实现 GatheringByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.nio.channels.ByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.ByteChannel
的使用

使用 ByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 ByteChannel 的使用

实现 ByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.nio.channels.WritableByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.WritableByteChannel
的使用

使用 WritableByteChannel 的软件包
java.nio.channels 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio.channels 中 WritableByteChannel 的使用

java.nio.channels 中 WritableByteChannel 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | GatheringByteChannel 可从缓冲区序列写入字节的通道。

实现 WritableByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

返回 WritableByteChannel 的 java.nio.channels 中的方法
static WritableByteChannel Channels.newChannel(OutputStream out)
构造向给定流写入字节的信道。

参数类型为 WritableByteChannel 的 java.nio.channels 中的方法
static OutputStream | Channels.newOutputStream(WritableByteChannel ch) 构造向给定信道写入字节的流。
static Writer | Channels.newWriter(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap) 构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。
static Writer | Channels.newWriter(WritableByteChannel ch, String csName) 构造一个 writer，它根据指定的 charset 对字符进行编码，并将所得的字节写入给定的信道。
abstract long | FileChannel.transferTo(long position, long count, WritableByteChannel target) 将字节从此通道的文件传输到给定的可写入字节通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.nio.channels.ReadableByteChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.ReadableByteChannel
的使用

使用 ReadableByteChannel 的软件包
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.nio.channels 中 ReadableByteChannel 的使用

java.nio.channels 中 ReadableByteChannel 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | ScatteringByteChannel 可将字节读入缓冲区序列的通道。

实现 ReadableByteChannel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

返回 ReadableByteChannel 的 java.nio.channels 中的方法
static ReadableByteChannel Channels.newChannel(InputStream in)
构造从给定流读取字节的信道。

参数类型为 ReadableByteChannel 的 java.nio.channels 中的方法
static InputStream | Channels.newInputStream(ReadableByteChannel ch) 构造从给定信道读取字节的流。
static Reader | Channels.newReader(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap) 构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。
static Reader | Channels.newReader(ReadableByteChannel ch, String csName) 构造一个 reader，它根据命名的 charset 对取自给定信道的字节进行解码。
abstract long | FileChannel.transferFrom(ReadableByteChannel src, long position, long count) 将字节从给定的可读取字节通道传输到此通道的文件中。

java.util 中 ReadableByteChannel 的使用

参数类型为 ReadableByteChannel 的 java.util 中的构造方法
Scanner(ReadableByteChannel source)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
Scanner(ReadableByteChannel source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.nio.channels.Channel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.nio.channels.Channel
的使用

使用 Channel 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。

java.lang 中 Channel 的使用

返回 Channel 的 java.lang 中的方法
static Channel System.inheritedChannel()
返回从创建此 Java 虚拟机的实体中继承的信道。

java.nio.channels 中 Channel 的使用

java.nio.channels 中 Channel 的子接口
interface | ByteChannel 可读取和写入字节的信道。
interface | GatheringByteChannel 可从缓冲区序列写入字节的通道。
interface | InterruptibleChannel 可被异步关闭和中断的通道。
interface | ReadableByteChannel 可读取字节的通道。
interface | ScatteringByteChannel 可将字节读入缓冲区序列的通道。
interface | WritableByteChannel 可写入字节的通道。

实现 Channel 的 java.nio.channels 中的类
class | DatagramChannel 针对面向数据报套接字的可选择通道。
class | FileChannel 用于读取、写入、映射和操作文件的通道。
static class | Pipe.SinkChannel 表示 Pipe 的可写入结尾的通道。
static class | Pipe.SourceChannel 表示 Pipe 的可读取结尾的通道。
class | SelectableChannel 可通过 Selector 实现多路复用的通道。
class | ServerSocketChannel 针对面向流的侦听套接字的可选择通道。
class | SocketChannel 针对面向流的连接套接字的可选择通道。

java.nio.channels.spi 中 Channel 的使用

实现 Channel 的 java.nio.channels.spi 中的类
class | AbstractInterruptibleChannel 可中断通道的基本实现类。
class | AbstractSelectableChannel 可选择通道的基本实现类。

返回 Channel 的 java.nio.channels.spi 中的方法
 Channel SelectorProvider.inheritedChannel()
返回从创建此 Java 虚拟机的实体中继承的通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


CharacterCodingException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 CharacterCodingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.nio.charset.CharacterCodingException
所有已实现的接口：
Serializable
直接已知子类：
MalformedInputException, UnmappableCharacterException
public class CharacterCodingException
extends IOException

出现字符编码或解码错误时，抛出此经过检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
CharacterCodingException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CharacterCodingException

public CharacterCodingException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Charset (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 Charset

java.lang.Object
    继承者  java.nio.charset.Charset
所有已实现的接口：
Comparable<Charset>
public abstract class Charset
extends Object
implements Comparable<Charset>

16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。此类定义了用于创建解码器和编码器以及获取与 charset 关联的各种名称的方法。此类的实例是不可变的。

此类也定义了用于测试是否支持特定 charset 的静态方法、通过名称查找 charset 实例的静态方法，以及构造一个包含目前 Java 虚拟机支持的每个 charset 的映射静态方法。通过类 CharsetProvider 中定义的服务提供者接口可以添加对新 charset 的支持。

此类中定义的所有方法用于多个并发线程是安全的。

Charset 名称

通过以下字符所组成的字符串来命名 Charset：

  • 大写字母 'A' 到 'Z'（'\u0041' 到 '\u005a'），
  • 小写字母 'a' 到 'z'（'=pos; 到 ' apos;），
  • 数字 '0' 到 '9'（'\u0030' 到 '\u0039'），
  • 短划线字符 '-'（'\u002d'，连词符号），
  • 句点字符 '.'('\u002e'，句点），
  • 冒号字符 ':'('\u003a'，冒号），和
  • 下划线字符 '_'（'\u005f'，下划线）。
Charset 名称必须以字母或数字开头。空字符串不是合法的 charset 名称。Charset 名称是大小写不敏感的，也就是当比较 charset 名称时总是忽略大小写。Charset 名称通常遵循 RFC2278:IANA Charset Registration Procedures 中所记录的约定。

每个 charset 有一个规范名称，也可能有一个或多个别名。规范名称由此类的 name 方法返回。根据约定，规范名称通常是大写的。charset 的别名由 aliases 方法返回。

一些 charset 有一个历史名称，定义这个名称是为了和以前版本的 Java 平台兼容。charset 的历史名称既可以是它的规范名称，也可以是它的某个别名。历史名称由 InputStreamReader 和 OutputStreamWriter 类的 getEncoding() 方法返回。

如果 Java 平台的实现支持列于 IANA Charset Registry 中的 charset，那么它的规范名称必须是注册表中列出的名字。很多 charset 在注册表中给出不止一个名称，在这种情况下注册表将某个名称标识为 MIME 首选的。如果 charset 有多个注册表名称，那么它的规范名称必须是 MIME 首选的名称，并且注册表中的其他名称必须是合法的别名。如果支持的 charset 没有列在 IANA 注册表中，那么它的规范名称必须以字符串 "X-" 或 "x-" 中的一个开头。

IANA charset 注册表不断进行更改，所以特定 charset 的规范名称和别名也会随之更改。为了确保兼容性，推荐不要删除 charset 的别名，如果更改了 charset 的规范名称，那么可将以前的规范名称作为别名。

标准 charset

Java 平台的每一种实现都需要支持以下标准 charset。请参考该实现的版本文档，查看是否支持其他 charset。这些可选 charset 的行为在不同的实现之间可能有所不同。

Charset

描述

US-ASCII | 7 位 ASCII 字符，也叫作 ISO646-US、Unicode 字符集的基本拉丁块
ISO-8859-1   | ISO 拉丁字母表 No.1，也叫作 ISO-LATIN-1
UTF-8 | 8 位 UCS 转换格式
UTF-16BE | 16 位 UCS 转换格式，Big Endian（最低地址存放高位字节）字节顺序
UTF-16LE | 16 位 UCS 转换格式，Little-endian（最高地址存放低位字节）字节顺序
UTF-16 | 16 位 UCS 转换格式，字节顺序由可选的字节顺序标记来标识

UTF-8 charset 在 RFC 2279 中指定；它所基于的转换格式在 ISO 10646-1 的 Amendment 2 中指定，并在 Unicode Standard 中也有所描述。

UTF-16 charset 在 RFC 2781 中指定；它们基于的转换格式在 ISO10646-1 的 Amendment 1 中指定，并在 Unicode Standard 中也有所描述。

UTF-16 charset 使用 16 位量，因此对字节顺序敏感。在这些编码中，流的字节顺序可以由 Unicode 字符 'FF' 所表示的初始字节顺序标记 来指示。按以下方式处理字节顺序标记：

  • 进行解码时，UTF-16BE 和 UTF-16LE charset 忽略字节顺序标记；进行编码时，不写入字节顺序标记。

  • 进行解码时，UTF-16 charset 解释字节顺序标记，以指示流的字节顺序，但是如果没有字节顺序标记，则默认使用 Big Endian；进行编码时，使用 Big Endian 字节顺序并写入 Big Endian 字节顺序标记。

在任何情况中，在解码操作的开始读取字节顺序标记时，将在结果字符序列中忽略该标记。字节顺序标记出现在输入序列的第一个元素之后时，由于使用相同的代码表示零宽度不间断空格，所以不忽略该标记。

Java 虚拟机的每个实例都有默认的 charset，它可能是也可能不是某个标准 charset。默认 charset 在虚拟机启动时决定，通常根据语言环境和底层操作系统使用的 charset 来确定。

术语

此类的名称取自 RFC 2278 中使用的术语。在该文档中，charset 被定义为编码字符集和字符编码方案的组合。

编码字符集 是抽象字符集合和整数集合之间的映射关系。US-ASCII、ISO 8859-1、JIS X 0201 和与 ISO 10646-1 相同的完整 Unicode 都是编码字符集示例。

字符编码方案 是编码字符集和八位组（八位字节）序列集合之间的映射关系。UTF-8、UCS-2、UTF-16、ISO 2022 和 EUC 是一些字符编码方案示例。编码方案通常与特定的编码字符集相关联；例如，UTF-8 只用来编码 Unicode。但是，一些方案与多个字符集相关联；例如，EUC 可用于编码各种亚洲字符集中的字符。

当编码字符集专门用于一个字符编码方案时，相应的 charset 通常使用字符集合命名；否则 charset 使用编码方案命名，很有可能使用它所支持的字符集的语言环境来命名。因此 US-ASCII 是 US-ASCII charset 名称，而 EUC-JP 是编码 JIS X 0201、JIS X 0208 和 JIS X 0212 字符集的 charset 名称。

Java 编程语言的本机字符编码方案是 UTF-16。因此 Java 平台的 charset 定义了 16 位 UTF-16 代码单元序列和字节序列之间的映射关系。

从以下版本开始：
1.4
另请参见：
CharsetDecoder, CharsetEncoder, CharsetProvider, Character

构造方法摘要
protected Charset(String canonicalName, String[] aliases)
使用给定的规范名称和别名集合初始化新 charset。
方法摘要
Set<String> | aliases() 返回包含此 charset 各个别名的集合。
static SortedMap<String,Charset> | availableCharsets() 构造从规范 charset 名称到 charset 对象的有序映射。
boolean | canEncode() 通知此 charset 是否支持编码。
int | compareTo(Charset that) 比较此 charset 与其他 charset。
abstract boolean | contains(Charset cs) 通知此 charset 是否包含给定的 charset。
CharBuffer | decode(ByteBuffer bb) 将此 charset 中的字节解码成 Unicode 字符的便捷方法。
static Charset | defaultCharset() 返回此 Java 虚拟机的默认 charset。
String | displayName() 返回此 charset 用于默认语言环境的可读名称。
String | displayName(Locale locale) 返回此 charset 用于给定语言环境的可读名称。
ByteBuffer | encode(CharBuffer cb) 将此 charset 中的 Unicode 字符编码成字节的便捷方法。
ByteBuffer | encode(String str) 将此 charset 中的字符串编码成字节的便捷方法。
boolean | equals(Object ob) 通知此对象是否和其他对象相等。
static Charset | forName(String charsetName) 返回指定 charset 的 charset 对象。
int | hashCode() 计算此 charset 的哈希码。
boolean | isRegistered() 通知此 charset 是否已在 IANA Charset Registry 中注册。
static boolean | isSupported(String charsetName) 通知是否支持指定的 charset。
String | name() 返回此 charset 的规范名称。
abstract CharsetDecoder | newDecoder() 为此 charset 构造新的解码器。
abstract CharsetEncoder | newEncoder() 为此 charset 构造新的编码器。
String | toString() 返回描述此 charset 的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Charset

protected Charset(String canonicalName,
                  String[] aliases)
使用给定的规范名称和别名集合初始化新 charset。

参数：
canonicalName - 此 charset 的规范名称
aliases - 此 charset 别名的数组，如果没有别名则为 null
抛出：
IllegalCharsetNameException - 如果规范名称和任何一个别名非法
方法详细信息

isSupported

public static boolean isSupported(String charsetName)
通知是否支持指定的 charset。

参数：
charsetName - 请求的 charset 名称；可能是规范名称或别名
返回：
当且仅当当前 Java 虚拟机支持指定的 charset 时才返回 true
抛出：
IllegalCharsetNameException - 如果给定的 charset 名称是非法的
IllegalArgumentException - 如果给定的 charsetName 为 null

forName

public static Charset forName(String charsetName)
返回指定 charset 的 charset 对象。

参数：
charsetName - 请求的 charset 名称；可能是规范名称或别名
返回：
指定 charset 的 charset 对象
抛出：
IllegalCharsetNameException - 如果给定的 charset 名称是非法的
IllegalArgumentException - 如果给定的 charsetName 为 null
UnsupportedCharsetException - 如果此 Java 虚拟机的实例不支持指定 charset

availableCharsets

public static SortedMap<String,Charset> availableCharsets()
构造从规范 charset 名称到 charset 对象的有序映射。

此方法返回的映射对每个 charset 都有一项，当前 Java 虚拟机是支持这些 charset 的。如果所支持的两个或多个 charset 具有相同的规范名称，则结果映射中只包含它们中的一个；包含哪一个没有指定。

对此方法的调用，以及对结果映射的后续使用可能导致出现耗时的磁盘或网络 I/O 操作。为需要枚举所有可用 charset 的应用程序提供此方法，例如允许用户选择 charset。forName 方法不使用此方法，而是使用一种高效的增量查找算法。

如果新的 charset 提供者可供当前 Java 虚拟机动态使用，则此方法可能在不同的时间返回不同的结果。如果没有这种改变，则此方法返回的 charset 恰好是那些可以通过 forName 方法获取的 charset。

返回：
规范 charset 名称到 charset 对象的不可变的、大小写不敏感的映射

defaultCharset

public static Charset defaultCharset()
返回此 Java 虚拟机的默认 charset。

默认 charset 在虚拟机启动时决定，通常根据语言环境和底层操作系统的 charset 来确定。

返回：
默认 charset 的 charset 对象
从以下版本开始：
1.5

name

public final String name()
返回此 charset 的规范名称。

返回：
此 charset 的规范名称

aliases

public final Set<String> aliases()
返回包含此 charset 各个别名的集合。

返回：
此 charset 不可变的别名集合

displayName

public String displayName()
返回此 charset 用于默认语言环境的可读名称。

此方法的默认实现只返回此 charset 的规范名称。为了提供本地化的显示名称，此类的具体子类可以重写此方法。

返回：
默认语言环境下此 charset 的显示名称

isRegistered

public final boolean isRegistered()
通知此 charset 是否已在 IANA Charset Registry 中注册。

返回：
当且仅当此 charset 的实现程序知道此 charset 已向 IANA 注册时才返回 true

displayName

public String displayName(Locale locale)
返回此 charset 用于给定语言环境的可读名称。

此方法的默认实现只返回此 charset 的规范名称。为了提供本地化的显示名称，此类的具体子类可以重写此方法。

参数：
locale - 要为其获取显示名称的语言环境
返回：
给定语言环境下此 charset 的显示名称

contains

public abstract boolean contains(Charset cs)
通知此 charset 是否包含给定的 charset。

当且仅当在 charset D 中可表示的每个字符，在字符集 C 中也是可表示的时，才能说 C 包含 D。如果存在这种关系，就能保证可在 D 进行编码的所有字符串不用执行任何替换就可在 C 中进行编码。

C 包含 D 不表示 C 中以特定字节序列可表示的每个字符在 D 中也以相同的字节序列表示，尽管有时是这种情况。

每个 charset 包含其自身。

此方法计算近似的包含关系：如果返回 true，则已知给定的 charset 包含在此 charset 中；但是如果返回 false，则不一定说明给定的 charset 不包含在此 charset 中。

返回：
如果给定的 charset 包含在此 charset 中，则返回 true

newDecoder

public abstract CharsetDecoder newDecoder()
为此 charset 构造新的解码器。

返回：
此 charset 的新解码器

newEncoder

public abstract CharsetEncoder newEncoder()
为此 charset 构造新的编码器。

返回：
此 charset 的新编码器
抛出：
UnsupportedOperationException - 如果此 charset 不支持编码

canEncode

public boolean canEncode()
通知此 charset 是否支持编码。

几乎所有的 charset 都支持编码。常见的例外是专用的自动检测 charset，它的解码器通过检查输入字节序列，就能够确定正在使用多个可能编码方案中的哪一个。此类 charset 不支持编码是由于无法确定输出时应该使用哪种编码。此类 charset 的实现应该重写此方法以返回 false。

返回：
当且仅当此 charset 支持编码时才返回 true

decode

public final CharBuffer decode(ByteBuffer bb)
将此 charset 中的字节解码成 Unicode 字符的便捷方法。

在 charset cs 上调用此方法，会返回和下面表达式相同的结果

 cs.newDecoder() .onMalformedInput(CodingErrorAction.REPLACE) .onUnmappableCharacter(CodingErrorAction.REPLACE) .decode(bb);
除此之外它可能更为高效，因为它能在两次连续的调用之间缓存解码器。

此方法总是用此 charset 的默认替换 byte 数组替换错误输入和不可映射的字符序列。为了检测此种序列，可直接使用 CharsetDecoder.decode(java.nio.ByteBuffer) 方法。

参数：
bb - 要解码的 byte 缓冲区
返回：
包含已解码字符的 char 缓冲区

encode

public final ByteBuffer encode(CharBuffer cb)
将此 charset 中的 Unicode 字符编码成字节的便捷方法。

在 charset cs 上调用此方法，会返回和下面表达式相同的结果

 cs.newEncoder() .onMalformedInput(CodingErrorAction.REPLACE) .onUnmappableCharacter(CodingErrorAction.REPLACE) .encode(bb);
除此之外它可能更为高效，因为它能在两次连续的调用之间缓存编码器。

此方法总是用此 charset 的默认替换字符串替换错误输入和不可映射的字符序列。为了检测此种序列，可直接使用 CharsetEncoder.encode(java.nio.CharBuffer) 方法。

参数：
cb - 要编码的 char 缓冲区
返回：
包含已编码字符的 byte 缓冲区

encode

public final ByteBuffer encode(String str)
将此 charset 中的字符串编码成字节的便捷方法。

在 charset cs 上调用此方法，会返回和下面表达式相同的结果

 cs.encode(CharBuffer.wrap(s));

参数：
str - 要编码的字符串
返回：
包含已编码字符的 byte 缓冲区

compareTo

public final int compareTo(Charset that)
比较此 charset 与其他 charset。

charset 根据它们的规范名称排序，而不考虑大小写。

指定者：
接口 Comparable<Charset> 中的 compareTo
参数：
that - 和此 charset 进行比较的 charset
返回：
如果此 charset 小于、等于或大于指定的 charset，则分别返回负整数、零或正整数

hashCode

public final int hashCode()
计算此 charset 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
整数哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public final boolean equals(Object ob)
通知此对象是否和其他对象相等。

当且仅当两个 charset 具有相同的规范名称时它们才相等。一个 charset 从来不和任何其他类型的对象相等。

覆盖：
类 Object 中的 equals
参数：
ob - 要与之比较的引用对象。
返回：
当且仅当此 charset 等于给定对象时才返回 true
另请参见：
Object.hashCode(), Hashtable

toString

public final String toString()
返回描述此 charset 的字符串。

覆盖：
类 Object 中的 toString
返回：
描述此 charset 的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharsetDecoder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 CharsetDecoder

java.lang.Object
    继承者  java.nio.charset.CharsetDecoder

public abstract class CharsetDecoder
extends Object

能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。

输入字节序列由字节缓冲区或一系列这样的缓冲区提供。输出字符序列写入字符缓冲区或一系列这样的缓冲区。应该始终通过下面的方法调用序列使用解码器，下文称为解码操作：

  1. 通过 reset 方法重置解码器，除非以前未使用过；

  2. 只要有其他的输入数据就应零次或多次调用 decode，为 endOfInput 参数传递 false，在调用之间填充输入缓冲区并刷新输出缓冲区。

  3. 最后时刻调用一次 decode 方法，为 endOfInput 参数传递 true；然后

  4. 调用 flush 方法，这样解码器能够将任何内部状态刷新到输出缓冲区。

每次调用 decode 方法将解码尽可能多的输入缓冲区中的字节，将得到的字符写入输出缓冲区。当需要更多的输入时、输出缓冲区没有足够的空间或出现解码错误时，decode 方法返回。在每种情况下都返回用于描述终止原因的 CoderResult 对象。调用者可根据相应的状况检查此对象并填充输入缓冲区、刷新输出缓冲区或尝试从解码错误中恢复，并再次进行尝试。

有两种常规解码错误类型。如果输入字节序列对此 charset 来说是不合法的，那么就认为输入是错误的。如果输入字节序列是合法的，但不能映射为有效的 Unicode 字符，那么就出现了不可映射的字符。

如何处理解码错误取决于为该错误类型所请求的操作，在 CodingErrorAction 类的实例中描述了该类型的错误。可能的错误操作是忽略错误的输入、通过返回的 CoderResult 对象将错误报告给调用者，或者用当前的替换字符串值CodingErrorAction#REPLACE替换错误的输入。 该替换字符串的初始值是 "FD"； 可通过 replaceWith 方法更改此值。

对于错误输入和不可映射的字符错误的默认操作是报告它们。可通过 onMalformedInput 方法更改针对错误输入的错误操作；可通过 onUnmappableCharacter 方法更改不可映射字符错误的操作。

此类设计用来处理解码过程中的许多细节问题，包括错误操作的实现。一个特定 charset 的解码器是此类的具体子类，它只需要实现抽象的 decodeLoop 方法，这个方法封装了基本的解码循环。另外，维护内部状态的子类应该重写 implFlush 和 implReset 方法。

此类的实例用于多个并发线程是不安全的。

从以下版本开始：
1.4
另请参见：
ByteBuffer, CharBuffer, Charset, CharsetEncoder

构造方法摘要
protected CharsetDecoder(Charset cs, float averageCharsPerByte, float maxCharsPerByte)
初始化新的解码器。
方法摘要
float | averageCharsPerByte() 返回为每个输入字节生成的平均字符数。
Charset | charset() 返回创建此解码器的 charset。
CharBuffer | decode(ByteBuffer in) 把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
CoderResult | decode(ByteBuffer in, CharBuffer out, boolean endOfInput) 从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
protected abstract CoderResult | decodeLoop(ByteBuffer in, CharBuffer out) 将一个或多个字节解码为一个或多个字符。
Charset | detectedCharset() 获取此解码器检测到的 charset（可选操作）。
CoderResult | flush(CharBuffer out) 刷新此解码器。
protected CoderResult | implFlush(CharBuffer out) 刷新此解码器。
protected void | implOnMalformedInput(CodingErrorAction newAction) 报告此解码器的错误输入操作的更改。
protected void | implOnUnmappableCharacter(CodingErrorAction newAction) 报告此解码器的不可映射的字符操作的更改。
protected void | implReplaceWith(String newReplacement) 报告此解码器替换值的更改。
protected void | implReset() 重置此解码器，清除所有特定于 charset 的内部状态。
boolean | isAutoDetecting() 通知此解码器是否实现了自动检测 charset。
boolean | isCharsetDetected() 通知此解码器是否已经检测到了一个 charset（可选操作）。
CodingErrorAction | malformedInputAction() 返回此解码器对错误输入错误的当前操作。
float | maxCharsPerByte() 返回为每个输入字节生成的最大字符数。
CharsetDecoder | onMalformedInput(CodingErrorAction newAction) 更改此解码器对错误输入错误的操作。
CharsetDecoder | onUnmappableCharacter(CodingErrorAction newAction) 更改此解码器对不可映射的字符错误的操作。
String | replacement() 返回此解码器的替换值。
CharsetDecoder | replaceWith(String newReplacement) 更改此解码器的替换值。
CharsetDecoder | reset() 重置此解码器，清除所有内部状态。
CodingErrorAction | unmappableCharacterAction() 返回此解码器对不可映射的字符错误的当前操作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CharsetDecoder

protected CharsetDecoder(Charset cs,
                         float averageCharsPerByte,
                         float maxCharsPerByte)
初始化新的解码器。新的解码器具有给定的每字节多少个字符 (chars-per-byte) 值，它的替换值是字符串 "\uFFFD"。

参数：
averageCharsPerByte - 一个正的 float 值，指示为每个输入字节所生成的字符数
maxCharsPerByte - 一个正的 float 值，指示为每个输入字节所生成的最大字符数
抛出：
IllegalArgumentException - 如果参数有关的前提不成立
方法详细信息

charset

public final Charset charset()
返回创建此解码器的 charset。

返回：
此解码器的 charset

replacement

public final String replacement()
返回此解码器的替换值。

返回：
返回此解码器的当前替换值，它永远不能为 null，也不能为空

replaceWith

public final CharsetDecoder replaceWith(String newReplacement)
更改此解码器的替换值。

此方法调用 implReplaceWith 方法，检查新的替换值是可接受的后，传递该新替换值。

参数：
newReplacement - 新替换值；一定不能为 null 且长度必须为非零
返回：
此解码器
抛出：
IllegalArgumentException - 如果参数有关的前提不成立

implReplaceWith

protected void implReplaceWith(String newReplacement)
报告此解码器替换值的更改。

此方法的默认实现不执行任何操作。需要通知替换值更改的解码器应该重写此方法。

参数：
newReplacement -

malformedInputAction

public CodingErrorAction malformedInputAction()
返回此解码器对错误输入错误的当前操作。

返回：
当前的错误输入操作，它永远不能为 null

onMalformedInput

public final CharsetDecoder onMalformedInput(CodingErrorAction newAction)
更改此解码器对错误输入错误的操作。

此方法调用 implOnMalformedInput 方法，传递新的操作。

参数：
newAction - 新的操作；一定不能为 null
返回：
此解码器
抛出：
IllegalArgumentException - 如果参数有关的前提不成立

implOnMalformedInput

protected void implOnMalformedInput(CodingErrorAction newAction)
报告此解码器的错误输入操作的更改。

此方法的默认实现不执行任何操作。需要通知错误输入操作更改的解码器应该重写此方法。

unmappableCharacterAction

public CodingErrorAction unmappableCharacterAction()
返回此解码器对不可映射的字符错误的当前操作。

返回：
当前的不可映射的字符操作，它永远不能为 null

onUnmappableCharacter

public final CharsetDecoder onUnmappableCharacter(CodingErrorAction newAction)
更改此解码器对不可映射的字符错误的操作。

此方法调用 implOnUnmappableCharacter 方法，传递新的操作。

参数：
newAction - 新的操作；一定不能为 null
返回：
此解码器
抛出：
IllegalArgumentException - 如果参数有关的前提不成立

implOnUnmappableCharacter

protected void implOnUnmappableCharacter(CodingErrorAction newAction)
报告此解码器的不可映射的字符操作的更改。

此方法的默认实现不执行任何操作。需要通知不可映射的字符操作更改的解码器应该重写此方法。

averageCharsPerByte

public final float averageCharsPerByte()
返回为每个输入字节生成的平均字符数。此试探值可用来估算给定输入序列所需的输出缓冲区大小。

返回：
每个输入字节生成的平均字符数

maxCharsPerByte

public final float maxCharsPerByte()
返回为每个输入字节生成的最大字符数。此值可用来计算给定输入序列最坏情况下所需的输出缓冲区大小。

返回：
每个输入字节生成的最大字符数

decode

public final CoderResult decode(ByteBuffer in,
                                CharBuffer out,
                                boolean endOfInput)
从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。

应该从各缓冲区的当前位置开始进行读取和写入。最多将读取 in.remaining() 个字节，最多将写入 out.remaining() 个字符。前移缓冲区的位置，以反映字节读取和写入字符，但是其标记和界限将无法修改。

除了从输入缓冲区读取字节和向输出缓冲区写入字符，此方法还返回一个 CoderResult 对象来描述它终止的原因：

  • CoderResult.UNDERFLOW 指示已解码尽可能多的输入缓冲区。如果没有进一步的输入，则调用者可以进行到解码操作的下一个步骤。否则，应该使用进一步的输入再次调用此方法。

  • CoderResult.OVERFLOW 指示该输出缓冲区中没有足够空间来解码任何更多字节。应该使用具有更多剩余字符的输出缓冲区再次调用此方法。这通常是通过排空输出缓冲区的所有解码字符来完成的。

  • CoderResult#malformedForLengthmalformed-input 结果指示已检测到错误输入错误。错误的字节起始于输入缓冲区（可能向前增加）的位置；错误字节数可以通过调用结果对象的 length 方法来确定。这种情况只适用于此解码器的错误输入的动作是 CodingErrorAction.REPORT 的情况下；否则将像请求的那样忽略或替换错误的输入。

  • unmappable-character 结果指示已检测到不可映射的字符错误。解码不可映射的字符的字节起始于输入缓冲区（可能向前增加）的位置；这种字节的数目可以通过调用结果对象的 length 方法来确定。这种情况只适用于此解码器的不可映射的字符的动作是 CodingErrorAction.REPORT的情况下；否则将像请求的那样忽略或替换不可映射的字符。

在任一情况下，如果在相同的解码操作中调用此方法，则要注意保留输入缓冲区中剩余的所有字节，以便可提供给下一次调用使用。

endOfInput 参数通知此方法除了给定输入缓冲区包含的内容，调用者是否能提供更多的输入。如果可能提供其他的输入，则调用者应该为此参数传递 false；如果不能提供更多的输入，则调用者应该传递 true。实际上在一次调用中传递 false，但后来发现实际上没有更多的输入可用是相当普遍的，这不是错误。但关键是，在此方法的一系列调用中，最后一次调用总是传递 true，这样所有剩余的未解码输入都作为错误输入处理。

此方法通过调用 decodeLoop 方法、解释它的结果、处理错误情况并重新调用（如有必要）来完成其工作。

参数：
in - 输入字节缓冲区
out - 输出字符缓冲区
endOfInput - 当且仅当调用者除了给定缓冲区中的内容外不提供其他输入字节时才为 true
返回：
描述终止原因的 CoderResult 对象
抛出：
IllegalStateException - 如果解码操作已在进行中并且前面的步骤不是调用 reset 方法，也不是为 endOfInput 参数使用 false 来调用此方法，也不是为 endOfInput 参数使用 true 来调用此方法，而是一个指示未完成解码操作的返回值
CoderMalfunctionError - 如果对 decodeLoop 方法的调用抛出不可预料的异常

flush

public final CoderResult flush(CharBuffer out)
刷新此解码器。

一些解码器维护内部状态，并且一旦读取完所有的输入序列后，可能需要向输出缓冲区写入一些最终字符。

任何其他输出写入输出缓冲区时都要从缓冲区的当前位置开始。最多将写入 out.remaining() 个字符。缓冲区的位置要相应地向前移动，但是其标记和界限将无法修改。

如果此方法成功完成，则它返回 CoderResult.UNDERFLOW。如果输出缓冲区没有足够的空间，则它返回 CoderResult.OVERFLOW。如果发生这种情况，那么为了完成当前的解码操作，必须使用具有更多空间的输出缓冲区再次调用此方法。

如果此解码器已经刷新，则调用此方法无效。

此方法调用 implFlush 方法来执行实际的刷新操作。

参数：
out - 输出字符缓冲区
返回：
一个 CoderResult 对象，可能是 CoderResult.UNDERFLOW 或 CoderResult.OVERFLOW
抛出：
IllegalStateException - 如果当前解码操作的前一步既不是调用 flush 方法，也不是为 endOfInput 参数使用 true 来调用三参数的 decode 方法

implFlush

protected CoderResult implFlush(CharBuffer out)
刷新此解码器。

此方法的默认实现不执行任何操作，并且始终返回 CoderResult.UNDERFLOW。对于那些一旦读取完整个的输入序列后，可能需要向输出缓冲区写入最终字符的解码器而言，应该重写此方法。

参数：
out - 输出字符缓冲区
返回：
一个 CoderResult 对象，可能是 CoderResult.UNDERFLOW 或 CoderResult.OVERFLOW

reset

public final CharsetDecoder reset()
重置此解码器，清除所有内部状态。

此方法重置与 charset 无关的状态，并且为了执行所有特定于 charset 的重置操作，还会调用 implReset 方法。

返回：
此解码器

implReset

protected void implReset()
重置此解码器，清除所有特定于 charset 的内部状态。

此方法的默认实现不执行任何操作。维护内部状态的解码器应该重写此方法。

decodeLoop

protected abstract CoderResult decodeLoop(ByteBuffer in,
                                          CharBuffer out)
将一个或多个字节解码为一个或多个字符。

此方法封装了基本的解码循环，在用完输入、用完输出缓冲区的空间或遇到解码错误之前解码尽可能多的字节。此方法由 decode 方法调用，decode 方法处理结果解释和错误恢复。

应该从各缓冲区的当前位置开始进行读取和写入。最多将读取 in.remaining() 个字节，最多将写入 out.remaining() 个字符。前移缓冲区的位置，以反映字节读取和写入字符，但是其标记和界限将无法修改。

此方法返回一个 CoderResult 对象描述它终止的原因，其方式和 decode 方法的相同。大多数此方法的实现处理解码错误的方式是由 decode 方法返回一个用来解释错误的相应结果对象。最优的实现可能是检查相关的错误操作并且自己实现该操作。

此方法的一种实现可能在接收到足够的输入之前，通过返回 CoderResult.UNDERFLOW 来执行任意的 lookahead。

参数：
in - 输入字节缓冲区
out - 输出字符缓冲区
返回：
描述终止原因的 CoderResult 对象

decode

public final CharBuffer decode(ByteBuffer in)
                        throws CharacterCodingException
把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。

此方法实现完整的解码操作；也就是说，它重置解码器，然后解码给定字节缓冲区中的字节，最后刷新此解码器。因此如果正在进行解码操作，则不应该调用此方法。

参数：
in - 输入字节缓冲区
返回：
新分配的字符缓冲区，包含解码操作结果。该缓冲区的位置是零，并且它的界限是在最后写入的字符之后。
抛出：
IllegalStateException - 如果已经进行解码操作
MalformedInputException - 如果从输入缓冲区当前位置开始的字节序列对于此 charset 是不合法的，并且当前的错误输入操作是 CodingErrorAction.REPORT
UnmappableCharacterException - 如果从输入缓冲区当前位置开始的字节序列不能映射到等同的字符序列，并且当前的不可映射的字符操作是 CodingErrorAction.REPORT
CharacterCodingException

isAutoDetecting

public boolean isAutoDetecting()
通知此解码器是否实现了自动检测 charset。

此方法的默认实现总是返回 false；为了返回 true，应该由自动检测解码器重写此方法。

返回：
当且仅当此解码器实现自动检测 charset 时才返回 true

isCharsetDetected

public boolean isCharsetDetected()
通知此解码器是否已经检测到了一个 charset（可选操作）。

如果此解码器实现了自动检测 charset，那么在解码操作期间的某个点上此方法可能开始返回 true，以指示在输入字节序列中检测到一个具体的 charset。一旦发生这种情况，就可以调用 detectedCharset 方法来获取检测到 charset。

此方法返回 false 并不表示尚未解码任何字节。一些自动检测解码器能够解码某些（甚至全部）输入字节序列，而不是固定于某个特定的 charset。

此方法的默认实现总是抛出 UnsupportedOperationException；一旦确定了输入 charset，那么为了返回 true，自动检测解码器应该重写此方法。

返回：
当且仅当此解码器检测到具体的 charset 时才返回 true
抛出：
UnsupportedOperationException - 如果此解码器没有实现自动检测 charset

detectedCharset

public Charset detectedCharset()
获取此解码器检测到的 charset（可选操作）。

如果此解码器实现自动检测 charset，那么一旦检测到该 charset，则此方法返回实际的 charset。之后，此方法在当前的解码操作过程中都返回相同的值。如果尚未读取足够的输入字节来确定实际的 charset，则此方法抛出 IllegalStateException。

此方法的默认实现总是抛出 UnsupportedOperationException；为了返回适当的值，应该由自动检测解码器重写此方法。

返回：
此自动检测解码器检测到的 charset，如果尚未确定 charset，则返回 null
抛出：
IllegalStateException - 如果尚未读取足够的字节来确定 charset
UnsupportedOperationException - 如果此解码器没有实现自动检测 charset
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharsetEncoder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 CharsetEncoder

java.lang.Object
    继承者  java.nio.charset.CharsetEncoder

public abstract class CharsetEncoder
extends Object

能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。

输入字符序列由字符缓冲区或一系列这样的缓冲区提供。输出字节序列写入字节缓冲区或一系列这样的缓冲区。应该始终通过下面的方法调用序列使用编码器，下文称为编码操作：

  1. 通过 reset 方法重置编码器，除非以前未使用过；

  2. 只要有其他的输入数据就应零次或多次调用 encode，为 endOfInput 参数传递 false，在调用之间填充输入缓冲区并刷新输出缓冲区。

  3. 最后时刻调用一次 encode 方法，为 endOfInput 参数传递 true；然后

  4. 调用 flush 方法，这样编码器能够将任何内部状态刷新到输出缓冲区。

每次调用 encode 方法将编码尽可能多的输入缓冲区中的字符，将得到的字节写入输出缓冲区。当需要更多的输入时、输出缓冲区没有足够的空间或出现编码错误时，encode 方法返回。在每种情况下都返回用于描述终止原因的 CoderResult 对象。调用者可根据相应的状况检查此对象并填充输入缓冲区、刷新输出缓冲区或尝试从编码错误中恢复，并再次进行尝试。

有两种常规编码错误类型。如果输入字符序列不是合法的 16 位 Unicode 序列，那么就认为输入是错误的。如果输入字符序列是合法的，但不能映射为给定 charset 中的有效字节序列，那么就出现了不可映射的字符。

如何处理编码错误取决于为该错误类型所请求的操作，在 CodingErrorAction 类的实例中描述了该类型的错误。可能的错误操作是忽略错误的输入、通过返回的 CoderResult 对象将错误报告给调用者，或者用当前的替换 byte 数组值替换错误的输入。 该替换值初始设置为编码器的默认替换值，这个值通常（但并非总是）具有初始值 { (byte)'?' }； 可通过 replaceWith 方法更改此值。

对于错误输入和不可映射的字符错误的默认操作是报告它们。可通过 onMalformedInput 方法更改针对错误输入的错误操作；可通过 onUnmappableCharacter 方法更改不可映射的字符错误的操作。

此类设计用来处理编码过程中的许多细节问题，包括错误操作的实现。一个特定 charset 的编码器是此类的具体子类，它只需要实现抽象的 encodeLoop 方法，这个方法封装了基本的编码循环。另外，维护内部状态的子类应该重写 implFlush 和 implReset 方法。

此类的实例用于多个并发线程是不安全的。

从以下版本开始：
1.4
另请参见：
ByteBuffer, CharBuffer, Charset, CharsetDecoder

构造方法摘要
protected | CharsetEncoder(Charset cs, float averageBytesPerChar, float maxBytesPerChar) 初始化新的编码器。
protected | CharsetEncoder(Charset cs, float averageBytesPerChar, float maxBytesPerChar, byte[] replacement) 初始化新的编码器。
方法摘要
float | averageBytesPerChar() 返回为每个输入字符生成的平均字节数。
boolean | canEncode(char c) 通知此编码器是否能够编码给定的字符。
boolean | canEncode(CharSequence cs) 通过此编码器是否能够编码给定的字符序列。
Charset | charset() 返回创建此编码器的 charset。
ByteBuffer | encode(CharBuffer in) 把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
CoderResult | encode(CharBuffer in, ByteBuffer out, boolean endOfInput) 从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
protected abstract CoderResult | encodeLoop(CharBuffer in, ByteBuffer out) 将一个或多个字符编码为一个或多个字节。
CoderResult | flush(ByteBuffer out) 刷新此编码器。
protected CoderResult | implFlush(ByteBuffer out) 刷新此编码器。
protected void | implOnMalformedInput(CodingErrorAction newAction) 报告此编码器的错误输入操作的更改。
protected void | implOnUnmappableCharacter(CodingErrorAction newAction) 报告此编码器的不可映射的字符操作的更改。
protected void | implReplaceWith(byte[] newReplacement) 报告此编码器替换值的更改。
protected void | implReset() 重置此编码器，清除所有特定于 charset 的内部状态。
boolean | isLegalReplacement(byte[] repl) 通知给定的 byte 数组是否为此编码器的合法替换值。
CodingErrorAction | malformedInputAction() 返回此编码器对错误输入错误的当前操作。
float | maxBytesPerChar() 返回为每个输入字符生成的最大字节数。
CharsetEncoder | onMalformedInput(CodingErrorAction newAction) 更改此编码器对错误输入错误的操作。
CharsetEncoder | onUnmappableCharacter(CodingErrorAction newAction) 更改此编码器对不可映射的字符错误的操作。
byte[] | replacement() 返回此编码器的替换值。
CharsetEncoder | replaceWith(byte[] newReplacement) 更改此编码器的替换值。
CharsetEncoder | reset() 重置此编码器，清除所有内部状态。
CodingErrorAction | unmappableCharacterAction() 返回此编码器对不可映射的字符错误的当前操作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CharsetEncoder

protected CharsetEncoder(Charset cs,
                         float averageBytesPerChar,
                         float maxBytesPerChar,
                         byte[] replacement)
初始化新的编码器。新编码器具有给定的每字符多少个字节 (chars-per-byte) 值和替换值。

参数：
averageBytesPerChar - 一个正的 float 值，指示为每个输入字符所生成的字节数
maxBytesPerChar - 一个正的 float 值，指示为每个输入字符所生成的最大字节数
replacement - 初始替换值；一定不能为 null、必须具有非零长度、必须小于 maxBytesPerChar，并且必须为 legal
抛出：
IllegalArgumentException - 如果参数有关的前提不成立

CharsetEncoder

protected CharsetEncoder(Charset cs,
                         float averageBytesPerChar,
                         float maxBytesPerChar)
初始化新的编码器。新编码器具有给定的每字符多少个字节值，它的替换值为 byte 数组 { (byte)'?' }。

参数：
averageBytesPerChar - 一个正的 float 值，指示为每个输入字符所生成的字节数
maxBytesPerChar - 一个正的 float 值，指示为每个输入字符所生成的最大字节数
抛出：
IllegalArgumentException - 如果参数有关的前提不成立
方法详细信息

charset

public final Charset charset()
返回创建此编码器的 charset。

返回：
此编码器的 charset

replacement

public final byte[] replacement()
返回此编码器的替换值。

返回：
此编码器的当前替换值，它永远不能为 null，也不能为空

replaceWith

public final CharsetEncoder replaceWith(byte[] newReplacement)
更改此编码器的替换值。

此方法调用 implReplaceWith 方法，检查新的替换值是可接受的后，传递该新替换值。

参数：
newReplacement - 新的替换值；一定不能为 null、必须具有非零长度、必须小于 maxBytesPerChar 所返回的值，并且必须为 legal
返回：
此编码器
抛出：
IllegalArgumentException - 如果参数有关的前提不成立

implReplaceWith

protected void implReplaceWith(byte[] newReplacement)
报告此编码器替换值的更改。

此方法的默认实现不执行任何操作。需要通知替换值更改的编码器应该重写此方法。

参数：
newReplacement -

isLegalReplacement

public boolean isLegalReplacement(byte[] repl)
通知给定的 byte 数组是否为此编码器的合法替换值。

当且仅当替换值是此编码器的 charset 中合法的字节序列时才是合法的；也就是说，能够把替换值解码成一个或多个 16 位 Unicode 字符。

此方法的默认实现效率不是很高；为了提高性能通常应该重写它。

参数：
repl - 要被测试的 byte 数组
返回：
当且仅当给定的 byte 数组是此编码器的合法替换值时才返回 true

malformedInputAction

public CodingErrorAction malformedInputAction()
返回此编码器对错误输入错误的当前操作。

返回：
当前的错误输入操作，它永远不能为 null

onMalformedInput

public final CharsetEncoder onMalformedInput(CodingErrorAction newAction)
更改此编码器对错误输入错误的操作。

此方法调用 implOnMalformedInput 方法，传递新的操作。

参数：
newAction - 新的操作；一定不能为 null
返回：
此编码器
抛出：
IllegalArgumentException - 如果参数有关的前提不成立

implOnMalformedInput

protected void implOnMalformedInput(CodingErrorAction newAction)
报告此编码器的错误输入操作的更改。

此方法的默认实现不执行任何操作。需要通知错误输入操作更改的编码器应该重写此方法。

unmappableCharacterAction

public CodingErrorAction unmappableCharacterAction()
返回此编码器对不可映射的字符错误的当前操作。

返回：
当前的不可映射的字符操作，它永远不能为 null

onUnmappableCharacter

public final CharsetEncoder onUnmappableCharacter(CodingErrorAction newAction)
更改此编码器对不可映射的字符错误的操作。

此方法调用 implOnUnmappableCharacter 方法，传递新的操作。

参数：
newAction - 新的操作；一定不能为 null
返回：
此编码器
抛出：
IllegalArgumentException - 如果参数有关的前提不成立

implOnUnmappableCharacter

protected void implOnUnmappableCharacter(CodingErrorAction newAction)
报告此编码器的不可映射的字符操作的更改。

此方法的默认实现不执行任何操作。需要通知不可映射的字符操作更改的编码器应该重写此方法。

averageBytesPerChar

public final float averageBytesPerChar()
返回为每个输入字符生成的平均字节数。此试探值可用来估算给定输入序列所需的输出缓冲区大小。

返回：
每个输入字符生成的平均字节数

maxBytesPerChar

public final float maxBytesPerChar()
返回为每个输入字符生成的最大字节数。此值可用来计算给定输入序列最坏情况下所需的输出缓冲区大小。

返回：
每个输入字符生成的最大字节数

encode

public final CoderResult encode(CharBuffer in,
                                ByteBuffer out,
                                boolean endOfInput)
从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。

应该从各缓冲区的当前位置开始进行读取和写入。最多将读取 in.remaining() 个字符，最多将写入 out.remaining() 个字节。前移缓冲区的位置，以反映字符读取和写入字节，但是其标记和界限将无法修改。

除了从输入缓冲区读取字符和向输出缓冲区写入字节，此方法还返回一个 CoderResult 对象来描述它终止的原因：

  • CoderResult.UNDERFLOW 指示已编码尽可能多的输入缓冲区。如果没有进一步的输入，则调用者可以进行到编码操作的下一个步骤。否则，应该使用进一步的输入再次调用此方法。

  • CoderResult.OVERFLOW 指示该输出缓冲区中没有足够空间来编码任何更多字符。应该使用具有更多剩余字节的输出缓冲区再次调用此方法。这通常是通过排空输出缓冲区的所有编码字节来完成的。

  • CoderResult#malformedForLengthmalformed-input 结果指示已检测到错误输入错误。错误的字符起始于输入缓冲区（可能向前增加）的位置；错误字符数可以通过调用结果对象的 length 方法来确定。这种情况只适用于此编码器的错误输入的动作是 CodingErrorAction.REPORT 的情况下；否则将像请求的那样忽略或替换错误的输入。

  • CoderResult#unmappableForLengthunmappable-character 结果指示已检测到不可映射的字符错误。编码不可映射的字符的字符起始于输入缓冲区（可能向前增加）的位置；这种字符的数目可以通过调用结果对象的 length 方法来确定。这种情况只适用于此编码器的不可映射的字符的动作是 CodingErrorAction.REPORT 的情况下；否则将像请求的那样忽略或替换不可映射的字符。

在任一情况下，如果在相同的编码操作中调用此方法，则要注意保留输入缓冲区中剩余的所有字符，以便可提供给下一次调用使用。

endOfInput 参数通知此方法除了给定输入缓冲区包含的内容，调用者是否能提供更多的输入。如果可能提供其他的输入，则调用者应该为此参数传递 false；如果不能提供更多的输入，则调用者应该传递 true。实际上在一次调用中传递 false，但后来发现实际上没有更多的输入可用是相当普遍的，这不是错误。但关键是，在此方法的一系列调用中，最后一次调用总是传递 true，这样所有剩余的未编码输入都作为错误输入处理。

此方法通过调用 encodeLoop 方法、解释它的结果、处理错误情况并重新调用（如有必要）来完成其工作。

参数：
in - 输入字符缓冲区
out - 输出字节缓冲区
endOfInput - 当且仅当调用者除了给定缓冲区中的内容外不提供其他输入字符时才为 true
返回：
描述终止原因的 CoderResult 对象
抛出：
IllegalStateException - 如果编码操作已在进行中并且前面的步骤不是调用 reset 方法，也不是为 endOfInput 参数使用 false 来调用此方法，也不是为 endOfInput 参数使用 true 来调用此方法，而是一个指示未完成编码操作的返回值
CoderMalfunctionError - 如果对 encodeLoop 方法的调用抛出不可预料的异常

flush

public final CoderResult flush(ByteBuffer out)
刷新此编码器。

一些编码器维护内部状态，并且一旦读取完所有的输入序列后，可能需要向输出缓冲区写入一些最终字节。

任何其他输出写入输出缓冲区时都要从缓冲区的当前位置开始。最多将写入 out.remaining() 个字节。缓冲区的位置要相应地向前移动，但是其标记和界限将无法修改。

如果此方法成功完成，则它返回 CoderResult.UNDERFLOW。如果输出缓冲区没有足够的空间，则它返回 CoderResult.OVERFLOW。如果发生这种情况，那么为了完成当前的编码操作，必须使用具有更多空间的输出缓冲区再次调用此方法。

如果此编码器已刷新，则调用此方法无效。

此方法调用 implFlush 方法来执行实际的刷新操作。

参数：
out - 输出字节缓冲区
返回：
一个 CoderResult 对象，可能是 CoderResult.UNDERFLOW 或 CoderResult.OVERFLOW
抛出：
IllegalStateException - 如果当前编码操作的前一步既不是调用 flush 方法，也不是为 endOfInput 参数使用 true 来调用三参数的 encode 方法

implFlush

protected CoderResult implFlush(ByteBuffer out)
刷新此编码器。

此方法的默认实现不执行任何操作，并且始终返回 CoderResult.UNDERFLOW。对于那些一旦读取完整个的输入序列后，可能需要向输出缓冲区写入最终字节的编码器而言，应该重写此方法。

参数：
out - 输出字节缓冲区
返回：
一个 CoderResult 对象，可能是 CoderResult.UNDERFLOW 或 CoderResult.OVERFLOW

reset

public final CharsetEncoder reset()
重置此编码器，清除所有内部状态。

此方法重置与 charset 无关的状态，并且为了执行所有特定于 charset 的重置操作，还会调用 implReset 方法。

返回：
此编码器

implReset

protected void implReset()
重置此编码器，清除所有特定于 charset 的内部状态。

此方法的默认实现不执行任何操作。维护内部状态的编码器应该重写此方法。

encodeLoop

protected abstract CoderResult encodeLoop(CharBuffer in,
                                          ByteBuffer out)
将一个或多个字符编码为一个或多个字节。

此方法封装了基本的编码循环，在用完输入、用完输出缓冲区的空间或遇到编码错误之前编码尽可能多的字符。此方法由 encode 方法调用，encode 方法处理结果解释和错误恢复。

应该从各缓冲区的当前位置开始进行读取和写入。最多将读取 in.remaining() 个字符，最多将写入 out.remaining() 个字节。前移缓冲区的位置，以反映字符读取和写入字节，但是其标记和界限将无法修改。

此方法返回一个 CoderResult 对象描述它终止的原因，其方式和 encode 方法的相同。大多数此方法的实现处理编码错误的方式是由 encode 方法返回一个用来解释错误的相应结果对象。最优的实现可能是检查相关的错误操作并且自己实现该操作。

此方法的一种实现可能在接收到足够的输入之前，通过返回 CoderResult.UNDERFLOW 来执行任意的 lookahead。

参数：
in - 输入字符缓冲区
out - 输出字节缓冲区
返回：
描述终止原因的 CoderResult 对象

encode

public final ByteBuffer encode(CharBuffer in)
                        throws CharacterCodingException
把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。

此方法实现完整的编码操作；也就是说，它重置编码器，然后编码给定字符缓冲区中的字符，最后刷新此编码器。因此如果正在进行编码操作，则不应该调用此方法。

参数：
in - 输入字符缓冲区
返回：
新分配的字节缓冲区，包含编码操作结果。该缓冲区的位置是零，并且它的界限是在最后写入的字节之后。
抛出：
IllegalStateException - 如果已经进行编码操作
MalformedInputException - 如果从输入缓冲区当前位置开始的字符序列不是合法的 16 位 Unicode 序列，并且当前的错误输入操作是 CodingErrorAction.REPORT
UnmappableCharacterException - 如果从输入缓冲区当前位置开始的字符序列不能映射到等同的字节序列，并且当前的不可映射的字符操作是 CodingErrorAction.REPORT
CharacterCodingException

canEncode

public boolean canEncode(char c)
通知此编码器是否能够编码给定的字符。

如果给定的字符是代理项字符，则此方法返回 false；只有当这些字符是高代理项后跟低代理项所组成的代理项对的成员时，才能对其进行解释。可使用 canEncode(CharSequence) 方法来检测是否能够编码某个字符序列。

此方法可以修改此编码器的状态；因此如果正在进行编码操作，则不应该调用此方法。

此方法的默认实现效率不是很高；为了提高性能通常应该重写它。

返回：
当且仅当此编码器能够编码给定字符时才返回 true
抛出：
IllegalStateException - 如果已经进行编码操作

canEncode

public boolean canEncode(CharSequence cs)
通过此编码器是否能够编码给定的字符序列。

如果此方法对特定的字符序列返回 false，则通过执行完整编码操作可获得有关无法编码序列的更多信息。

此方法可以修改此编码器的状态；因此如果正在进行编码操作，则不应该调用此方法。

此方法的默认实现效率不是很高；为了提高性能通常应该重写它。

返回：
当且仅当此编码器在既不抛出任何异常也不执行任何替换的情况下就能编码给定的字符时才返回 true
抛出：
IllegalStateException - 如果已经进行编码操作
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CoderMalfunctionError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 CoderMalfunctionError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.nio.charset.CoderMalfunctionError
所有已实现的接口：
Serializable
public class CoderMalfunctionError
extends Error

当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
CoderMalfunctionError(Exception cause)
初始化此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CoderMalfunctionError

public CoderMalfunctionError(Exception cause)
初始化此类的一个实例。

参数：
cause - 抛出的不可预料的异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CoderResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 CoderResult

java.lang.Object
    继承者  java.nio.charset.CoderResult

public class CoderResult
extends Object

coder 结果状态的描述。

charset coder（即解码器或编码器）使用输入缓冲区中的字节（或字符）、对它们进行转换，并将结果字符（或字节）写入输出缓冲区。编码进程终止的原因是以下四类之一，这些原因由此类的实例描述：

  • 当没有更多的输入要处理时，或者当现有的输入不足而需要其他的输入时报告下溢（Underflow）。这种情况用唯一的结果对象 UNDERFLOW 表示，该对象的 isUnderflow 方法返回 true。

  • 当输出缓冲区没有足够的剩余空间时报告溢出（Overflow）。这种情况用唯一的结果对象 OVERFLOW 表示，该对象的 isOverflow 方法返回 true。

  • 当输入单元序列不是格式良好时报告错误的输入错误。这种错误用此类的实例来描述，该类的 isMalformed 方法返回 true，该类的 length 方法返回错误序列的长度。对所有的给定长度的错误输入错误，有此类的一个唯一实例描述。

  • 当表示一个字符的输入单元序列不能在输出 charset 中表示时报告不可映射的字符错误。这种错误用此类的实例描述，该类的 isUnmappable 方法返回 true，该类的 length 方法返回表示不可映射的字符的输入序列的长度。对所有的给定长度的不可映射的字符错误，有此类的一个唯一实例描述。

为了方便，isError 方法为描述错误输入和不可映射的字符错误的结果对象返回 true，但是为那些描述下溢或溢出情况的结果对象返回 false。

从以下版本开始：
1.4

字段摘要
static CoderResult | OVERFLOW 指示溢出的结果对象，意味着输出缓冲区没有足够的空间。
static CoderResult | UNDERFLOW 指示下溢的结果对象，意味着输入缓冲区中的输入被用完，或者如果输入缓冲区不是空的，但还需要其他的输入。
方法摘要
boolean | isError() 通知此对象是否描述错误情况。
boolean | isMalformed() 通知此对象是否描述错误输入错误。
boolean | isOverflow() 通知此对象是否描述溢出情况。
boolean | isUnderflow() 通知此对象是否描述下溢情况。
boolean | isUnmappable() 通知此对象是否描述不可映射的字符错误。
int | length() 返回此对象描述的错误输入的长度（可选操作）。
static CoderResult | malformedForLength(int length) 静态工厂方法，返回描述给定长度的错误输入错误的唯一对象。
void | throwException() 抛出相应于此对象描述的结果的异常。
String | toString() 返回描述此 CoderResult 的字符串。
static CoderResult | unmappableForLength(int length) 静态工厂方法，返回描述给定长度的不可映射的字符错误的唯一对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

UNDERFLOW

public static final CoderResult UNDERFLOW
指示下溢的结果对象，意味着输入缓冲区中的输入被用完，或者如果输入缓冲区不是空的，但还需要其他的输入。

OVERFLOW

public static final CoderResult OVERFLOW
指示溢出的结果对象，意味着输出缓冲区没有足够的空间。

方法详细信息

toString

public String toString()
返回描述此 CoderResult 的字符串。

覆盖：
类 Object 中的 toString
返回：
一个描述字符串

isUnderflow

public boolean isUnderflow()
通知此对象是否描述下溢情况。

返回：
当且仅当此对象表示下溢时才返回 true

isOverflow

public boolean isOverflow()
通知此对象是否描述溢出情况。

返回：
当且仅当此对象表示溢出时才返回 true

isError

public boolean isError()
通知此对象是否描述错误情况。

返回：
当且仅当此对象表示错误输入错误或不可映射的字符错误时才返回 true

isMalformed

public boolean isMalformed()
通知此对象是否描述错误输入错误。

返回：
当且仅当此对象表示一个错误输入错误时才返回 true

isUnmappable

public boolean isUnmappable()
通知此对象是否描述不可映射的字符错误。

返回：
当且仅当此对象表示一个不可映射的字符错误时才返回 true

length

public int length()
返回此对象描述的错误输入的长度（可选操作）。

返回：
错误输入的长度，一个正整数
抛出：
UnsupportedOperationException - 如果此对象没有描述错误情况，也就是如果 isError 没有返回 true

malformedForLength

public static CoderResult malformedForLength(int length)
静态工厂方法，返回描述给定长度的错误输入错误的唯一对象。

返回：
请求的 CoderResult 对象

unmappableForLength

public static CoderResult unmappableForLength(int length)
静态工厂方法，返回描述给定长度的不可映射的字符错误的唯一对象。

返回：
请求的 CoderResult 对象

throwException

public void throwException()
                    throws CharacterCodingException
抛出相应于此对象描述的结果的异常。

抛出：
BufferUnderflowException - 如果此对象是 UNDERFLOW
BufferOverflowException - 如果此对象是 OVERFLOW
MalformedInputException - 如果此对象表示一个错误输入错误；该异常的长度值是此对象的长度值
UnmappableCharacterException - 如果此对象表示一个不可映射的字符错误；该异常的长度值是此对象的长度值
CharacterCodingException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CodingErrorAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 CodingErrorAction

java.lang.Object
    继承者  java.nio.charset.CodingErrorAction

public class CodingErrorAction
extends Object

编码错误操作的类型安全的枚举。

此类的实例用来指定 charset 的解码器和编码器如何处理错误输入和不可映射的字符错误。

从以下版本开始：
1.4

字段摘要
static CodingErrorAction | IGNORE 指示通过删除错误输入和恢复编码操作来处理编码错误的操作。
static CodingErrorAction | REPLACE 指示通过删除错误输入、向输出缓冲区追加 coder 的替换值和恢复编码操作来处理编码错误的操作。
static CodingErrorAction | REPORT 指示要报告编码错误的操作，报告的方式是通过返回 CoderResult 对象或抛出 CharacterCodingException，以上两者都适合实现编码过程的方法。
方法摘要
 String toString()
返回描述此操作的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

IGNORE

public static final CodingErrorAction IGNORE
指示通过删除错误输入和恢复编码操作来处理编码错误的操作。

REPLACE

public static final CodingErrorAction REPLACE
指示通过删除错误输入、向输出缓冲区追加 coder 的替换值和恢复编码操作来处理编码错误的操作。

REPORT

public static final CodingErrorAction REPORT
指示要报告编码错误的操作，报告的方式是通过返回 CoderResult 对象或抛出 CharacterCodingException，以上两者都适合实现编码过程的方法。

方法详细信息

toString

public String toString()
返回描述此操作的字符串。

覆盖：
类 Object 中的 toString
返回：
一个描述字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalCharsetNameException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 IllegalCharsetNameException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.nio.charset.IllegalCharsetNameException
所有已实现的接口：
Serializable
public class IllegalCharsetNameException
extends IllegalArgumentException

将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
IllegalCharsetNameException(String charsetName)
构造此类的一个实例。
方法摘要
 String getCharsetName()
获取非法的 charset 名称。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalCharsetNameException

public IllegalCharsetNameException(String charsetName)
构造此类的一个实例。

参数：
charsetName - 非法的 charset 名称
方法详细信息

getCharsetName

public String getCharsetName()
获取非法的 charset 名称。

返回：
非法的 charset 名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MalformedInputException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 MalformedInputException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.nio.charset.CharacterCodingException
                    继承者  java.nio.charset.MalformedInputException
所有已实现的接口：
Serializable
public class MalformedInputException
extends CharacterCodingException

当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
MalformedInputException(int inputLength)
方法摘要
int | getInputLength()
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MalformedInputException

public MalformedInputException(int inputLength)
方法详细信息

getInputLength

public int getInputLength()

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnmappableCharacterException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 UnmappableCharacterException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.nio.charset.CharacterCodingException
                    继承者  java.nio.charset.UnmappableCharacterException
所有已实现的接口：
Serializable
public class UnmappableCharacterException
extends CharacterCodingException

当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
UnmappableCharacterException(int inputLength)
方法摘要
int | getInputLength()
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnmappableCharacterException

public UnmappableCharacterException(int inputLength)
方法详细信息

getInputLength

public int getInputLength()

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedCharsetException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio.charset
类 UnsupportedCharsetException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.nio.charset.UnsupportedCharsetException
所有已实现的接口：
Serializable
public class UnsupportedCharsetException
extends IllegalArgumentException

当不支持请求的 charset 时，抛出此未经检查的异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
UnsupportedCharsetException(String charsetName)
构造此类的一个实例。
方法摘要
 String getCharsetName()
获取不受支持的 charset 的名称。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedCharsetException

public UnsupportedCharsetException(String charsetName)
构造此类的一个实例。

参数：
charsetName - 不受支持的 charset 的名称
方法详细信息

getCharsetName

public String getCharsetName()
获取不受支持的 charset 的名称。

返回：
不受支持的 charset 的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.nio.charset (Java 2 Platform SE 6)

 java.nio.charset
类
Charset
CharsetDecoder
CharsetEncoder
CoderResult
CodingErrorAction
异常
CharacterCodingException
IllegalCharsetNameException
MalformedInputException
UnmappableCharacterException
UnsupportedCharsetException
错误
CoderMalfunctionError


java.nio.charset (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.nio.charset

定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

请参见：
描述

类摘要
Charset | 16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。
CharsetDecoder | 能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。
CharsetEncoder | 能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。
CoderResult | coder 结果状态的描述。
CodingErrorAction | 编码错误操作的类型安全的枚举。

异常摘要
CharacterCodingException | 出现字符编码或解码错误时，抛出此经过检查的异常。
IllegalCharsetNameException | 将一个不是合法 charset 名称的字符串用作 charset 名称时，抛出此未经检查的异常。
MalformedInputException | 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
UnmappableCharacterException | 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。
UnsupportedCharsetException | 当不支持请求的 charset 时，抛出此未经检查的异常。

错误摘要
CoderMalfunctionError 当 CharsetDecoder 的 decodeLoop 方法，或 CharsetEncoder 的 encodeLoop 方法抛出不可预料的异常时抛出的错误。

软件包 java.nio.charset 的描述

定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

类名

描述

Charset 字符和字节之间的指定映射关系
CharsetDecoder | 把字节解码为字符
CharsetEncoder   | 把字符编码为字节
CoderResult   | 描述 coder 的结果
CodingErrorAction   描述检测到编码错误时所采取的操作

charset 是 16 位 Unicode 字符序列和字节序列之间的指定映射关系，从某种意义上来说，在 RFC 2278 中对其进行了定义。解码器 是把一个特定 charset 中的字节转换成字符的引擎，编码器 是把字符转换成字节的引擎。编码器和解码器在字节和字符缓冲区上操作。它们共同被称为 coder。

Charset 类定义了为给定的 charset 创建 coder 的方法和获取与某个 charset 相关的名称的方法。它还定义了用于测试是否支持特定 charset 的静态方法、通过名称查找 charset 实例的静态方法，以及构造一个包含目前 Java 虚拟机支持的每个 charset 的映射静态方法。

大多数用户不直接使用这些类；他们使用 String 类中存在的和 charset 有关的构造方法和方法，一起使用的还有 InputStreamReader 和 OutputStreamWriter 类，为了利用此包中定义的 charset 设施，所有这些类的实现都被重写。为了在构造这些类的实例时显式地指定 charset 对象，已经对 InputStreamReader 和 OutputStreamWriter 类做了一些更改。

通过在 java.nio.charset.spi 包中的 CharsetProvider 类中定义的接口，可提供对新 charset 的支持。

除非另行说明，否则将 null 参数传递给此包中任何类或接口的构造方法或方法将会导致抛出 NullPointerException。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.nio.charset 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.charset 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.nio.charset.Charset (implements java.lang.Comparable<T>)
    • java.nio.charset.CharsetDecoder
    • java.nio.charset.CharsetEncoder
    • java.nio.charset.CoderResult
    • java.nio.charset.CodingErrorAction
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.nio.charset.CoderMalfunctionError
      • java.lang.Exception
        • java.io.IOException
          • java.nio.charset.CharacterCodingException
            • java.nio.charset.MalformedInputException
            • java.nio.charset.UnmappableCharacterException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.nio.charset.IllegalCharsetNameException
            • java.nio.charset.UnsupportedCharsetException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.nio.charset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.charset
的使用

使用 java.nio.charset 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 使用的 java.nio.charset 中的类
Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。
CharsetDecoder
能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。
CharsetEncoder
能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。

java.lang 使用的 java.nio.charset 中的类
Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。

java.nio.channels 使用的 java.nio.charset 中的类
CharsetDecoder
能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。
CharsetEncoder
能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。

java.nio.charset 使用的 java.nio.charset 中的类
CharacterCodingException
出现字符编码或解码错误时，抛出此经过检查的异常。
Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。
CharsetDecoder
能够把特定 charset 中的字节序列转换成 16 位 Unicode 字符序列的引擎。
CharsetEncoder
能够把 16 位 Unicode 字符序列转换成特定 charset 中字节序列的引擎。
CoderResult
coder 结果状态的描述。
CodingErrorAction
编码错误操作的类型安全的枚举。

java.nio.charset.spi 使用的 java.nio.charset 中的类
Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。

javax.tools 使用的 java.nio.charset 中的类
Charset
16 位的 Unicode 代码单元序列和字节序列之间的指定映射关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


CharsetProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.nio.charset.spi
类 CharsetProvider

java.lang.Object
    继承者  java.nio.charset.spi.CharsetProvider

public abstract class CharsetProvider
extends Object

Charset 服务提供者类。

charset 提供者是此类的一个具体子类，具有零参数的构造方法和一些相关的 charset 实现类。Charset 提供者可以作为扩展装入到 Java 平台的实例中，也就是把 jar 文件放入任意常用的扩展目录中。通过把提供者加入到 applet 或应用程序类路径中，或者通过某些特定于平台的其他方式来使提供者可用。通过当前线程的上下文类加载器来查找 Charset 提供者。

charset 提供者使用资源目录 META-INF/services 下的名称为 java.nio.charset.spi.CharsetProvider 的提供者配置文件标识它自己。该文件应该包含一个完全限定的具体 charset 提供者类名的列表，每行一个类名。通过下列字符之一表示某行已终止：换行 ('\n')、回车 ('\r') 或回车后直接跟着换行。忽略各名称周围的空格字符和制表符以及空行。注释字符为 '#' ('\u0023')；将忽略每行的第一个注释字符后面的所有字符。文件必须使用 UTF-8 编码。

如果在多个配置文件中命名了一个特定的具体 charset 提供者类，或在同一配置文件中多次对其命名，则忽略重复的命名。命名特定提供者的配置文件不必像提供者本身一样位于同一个 jar 文件或其他的分布式单元中。提供者必须是从同一个类加载器可访问的，为了查找配置文件而在开始时查询该类加载器；这不必是装载文件的类加载器。

从以下版本开始：
1.4
另请参见：
Charset

构造方法摘要
protected CharsetProvider()
初始化新的 charset 提供者。
方法摘要
abstract Charset | charsetForName(String charsetName) 用给定的 charset 名称获取 charset。
abstract Iterator<Charset> | charsets() 创建在此提供者所支持的 charset 上进行迭代的迭代器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CharsetProvider

protected CharsetProvider()
初始化新的 charset 提供者。

抛出：
SecurityException - 如果已安装安全管理器并且它拒绝 RuntimePermission ("charsetProvider")
方法详细信息

charsets

public abstract Iterator<Charset> charsets()
创建在此提供者所支持的 charset 上进行迭代的迭代器。在 Charset.availableCharsets 方法的实现中使用此方法。

返回：
新迭代器

charsetForName

public abstract Charset charsetForName(String charsetName)
用给定的 charset 名称获取 charset。

参数：
charsetName - 请求的 charset 的名称；可以是规范名称或别名
返回：
指定 charset 的 charset 对象；如果此提供者不支持该指定 charset，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.nio.charset.spi (Java 2 Platform SE 6)

 java.nio.charset.spi
类
CharsetProvider


java.nio.charset.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.nio.charset.spi

java.nio.charset 包的服务提供者类。

请参见：
描述

类摘要
CharsetProvider Charset 服务提供者类。

软件包 java.nio.charset.spi 的描述

java.nio.charset 包的服务提供者类。

只有定义新 charset 的开发人员才需要直接使用此包。

除非另行说明，否则将 null 参数传递给此包中任何类或接口的构造方法或方法都将导致抛出 NullPointerException。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.nio.charset.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.charset.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.nio.charset.spi.CharsetProvider
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.nio.charset.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.nio.charset.spi
的使用

没有 java.nio.charset.spi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.spi.CharsetProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.spi.CharsetProvider
的使用

没有 java.nio.charset.spi.CharsetProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.CharacterCodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CharacterCodingException
的使用

使用 CharacterCodingException 的软件包
java.nio.charset 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset 中 CharacterCodingException 的使用

java.nio.charset 中 CharacterCodingException 的子类
class | MalformedInputException 当输入字节序列对于给定 charset 来说是不合法的，或者输入字符序列不是合法的 16 位 Unicode 序列时，抛出此经过检查的异常。
class | UnmappableCharacterException 当输入字符（或字节）序列有效，但不能被映射为输出字节（或字符）序列时，抛出此经过检查的异常。

抛出 CharacterCodingException 的 java.nio.charset 中的方法
CharBuffer | CharsetDecoder.decode(ByteBuffer in) 把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
ByteBuffer | CharsetEncoder.encode(CharBuffer in) 把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
void | CoderResult.throwException() 抛出相应于此对象描述的结果的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.CoderMalfunctionError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CoderMalfunctionError
的使用

没有 java.nio.charset.CoderMalfunctionError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.IllegalCharsetNameException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.IllegalCharsetNameException
的使用

没有 java.nio.charset.IllegalCharsetNameException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.MalformedInputException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.MalformedInputException
的使用

没有 java.nio.charset.MalformedInputException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.UnmappableCharacterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.UnmappableCharacterException
的使用

没有 java.nio.charset.UnmappableCharacterException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.UnsupportedCharsetException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.UnsupportedCharsetException
的使用

没有 java.nio.charset.UnsupportedCharsetException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.CharsetEncoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CharsetEncoder
的使用

使用 CharsetEncoder 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.io 中 CharsetEncoder 的使用

参数类型为 CharsetEncoder 的 java.io 中的构造方法
OutputStreamWriter(OutputStream out, CharsetEncoder enc)
创建使用给定字符集编码器的 OutputStreamWriter。

java.nio.channels 中 CharsetEncoder 的使用

参数类型为 CharsetEncoder 的 java.nio.channels 中的方法
static Writer Channels.newWriter(WritableByteChannel ch, CharsetEncoder enc, int minBufferCap)
构造一个 writer，它使用给定的编码器对字符进行编码，并将所得的字节写入给定的信道。

java.nio.charset 中 CharsetEncoder 的使用

返回 CharsetEncoder 的 java.nio.charset 中的方法
abstract CharsetEncoder | Charset.newEncoder() 为此 charset 构造新的编码器。
CharsetEncoder | CharsetEncoder.onMalformedInput(CodingErrorAction newAction) 更改此编码器对错误输入错误的操作。
CharsetEncoder | CharsetEncoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此编码器对不可映射的字符错误的操作。
CharsetEncoder | CharsetEncoder.replaceWith(byte[] newReplacement) 更改此编码器的替换值。
CharsetEncoder | CharsetEncoder.reset() 重置此编码器，清除所有内部状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.CoderResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CoderResult
的使用

使用 CoderResult 的软件包
java.nio.charset 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset 中 CoderResult 的使用

声明为 CoderResult 的 java.nio.charset 中的字段
static CoderResult | CoderResult.OVERFLOW 指示溢出的结果对象，意味着输出缓冲区没有足够的空间。
static CoderResult | CoderResult.UNDERFLOW 指示下溢的结果对象，意味着输入缓冲区中的输入被用完，或者如果输入缓冲区不是空的，但还需要其他的输入。

返回 CoderResult 的 java.nio.charset 中的方法
CoderResult | CharsetDecoder.decode(ByteBuffer in, CharBuffer out, boolean endOfInput) 从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetDecoder.decodeLoop(ByteBuffer in, CharBuffer out) 将一个或多个字节解码为一个或多个字符。
CoderResult | CharsetEncoder.encode(CharBuffer in, ByteBuffer out, boolean endOfInput) 从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetEncoder.encodeLoop(CharBuffer in, ByteBuffer out) 将一个或多个字符编码为一个或多个字节。
CoderResult | CharsetEncoder.flush(ByteBuffer out) 刷新此编码器。
CoderResult | CharsetDecoder.flush(CharBuffer out) 刷新此解码器。
protected CoderResult | CharsetEncoder.implFlush(ByteBuffer out) 刷新此编码器。
protected CoderResult | CharsetDecoder.implFlush(CharBuffer out) 刷新此解码器。
static CoderResult | CoderResult.malformedForLength(int length) 静态工厂方法，返回描述给定长度的错误输入错误的唯一对象。
static CoderResult | CoderResult.unmappableForLength(int length) 静态工厂方法，返回描述给定长度的不可映射的字符错误的唯一对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.CodingErrorAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CodingErrorAction
的使用

使用 CodingErrorAction 的软件包
java.nio.charset 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.nio.charset 中 CodingErrorAction 的使用

声明为 CodingErrorAction 的 java.nio.charset 中的字段
static CodingErrorAction | CodingErrorAction.IGNORE 指示通过删除错误输入和恢复编码操作来处理编码错误的操作。
static CodingErrorAction | CodingErrorAction.REPLACE 指示通过删除错误输入、向输出缓冲区追加 coder 的替换值和恢复编码操作来处理编码错误的操作。
static CodingErrorAction | CodingErrorAction.REPORT 指示要报告编码错误的操作，报告的方式是通过返回 CoderResult 对象或抛出 CharacterCodingException，以上两者都适合实现编码过程的方法。

返回 CodingErrorAction 的 java.nio.charset 中的方法
CodingErrorAction | CharsetEncoder.malformedInputAction() 返回此编码器对错误输入错误的当前操作。
CodingErrorAction | CharsetDecoder.malformedInputAction() 返回此解码器对错误输入错误的当前操作。
CodingErrorAction | CharsetEncoder.unmappableCharacterAction() 返回此编码器对不可映射的字符错误的当前操作。
CodingErrorAction | CharsetDecoder.unmappableCharacterAction() 返回此解码器对不可映射的字符错误的当前操作。

参数类型为 CodingErrorAction 的 java.nio.charset 中的方法
protected void | CharsetEncoder.implOnMalformedInput(CodingErrorAction newAction) 报告此编码器的错误输入操作的更改。
protected void | CharsetDecoder.implOnMalformedInput(CodingErrorAction newAction) 报告此解码器的错误输入操作的更改。
protected void | CharsetEncoder.implOnUnmappableCharacter(CodingErrorAction newAction) 报告此编码器的不可映射的字符操作的更改。
protected void | CharsetDecoder.implOnUnmappableCharacter(CodingErrorAction newAction) 报告此解码器的不可映射的字符操作的更改。
CharsetEncoder | CharsetEncoder.onMalformedInput(CodingErrorAction newAction) 更改此编码器对错误输入错误的操作。
CharsetDecoder | CharsetDecoder.onMalformedInput(CodingErrorAction newAction) 更改此解码器对错误输入错误的操作。
CharsetEncoder | CharsetEncoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此编码器对不可映射的字符错误的操作。
CharsetDecoder | CharsetDecoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此解码器对不可映射的字符错误的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.CharsetDecoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.CharsetDecoder
的使用

使用 CharsetDecoder 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.io 中 CharsetDecoder 的使用

参数类型为 CharsetDecoder 的 java.io 中的构造方法
InputStreamReader(InputStream in, CharsetDecoder dec)
创建使用给定字符集解码器的 InputStreamReader。

java.nio.channels 中 CharsetDecoder 的使用

参数类型为 CharsetDecoder 的 java.nio.channels 中的方法
static Reader Channels.newReader(ReadableByteChannel ch, CharsetDecoder dec, int minBufferCap)
构造一个 reader，它用给定的解码器对取自给定信道的字节进行解码。

java.nio.charset 中 CharsetDecoder 的使用

返回 CharsetDecoder 的 java.nio.charset 中的方法
abstract CharsetDecoder | Charset.newDecoder() 为此 charset 构造新的解码器。
CharsetDecoder | CharsetDecoder.onMalformedInput(CodingErrorAction newAction) 更改此解码器对错误输入错误的操作。
CharsetDecoder | CharsetDecoder.onUnmappableCharacter(CodingErrorAction newAction) 更改此解码器对不可映射的字符错误的操作。
CharsetDecoder | CharsetDecoder.replaceWith(String newReplacement) 更改此解码器的替换值。
CharsetDecoder | CharsetDecoder.reset() 重置此解码器，清除所有内部状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.charset.Charset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.charset.Charset
的使用

使用 Charset 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.io 中 Charset 的使用

参数类型为 Charset 的 java.io 中的构造方法
InputStreamReader(InputStream in, Charset cs)
创建使用给定字符集的 InputStreamReader。
OutputStreamWriter(OutputStream out, Charset cs)
创建使用给定字符集的 OutputStreamWriter。

java.lang 中 Charset 的使用

参数类型为 Charset 的 java.lang 中的方法
 byte[] String.getBytes(Charset charset)
使用给定的 charset 将此 String 编码到 byte 序列，并将结果存储到新的 byte 数组。

参数类型为 Charset 的 java.lang 中的构造方法
String(byte[] bytes, Charset charset)
通过使用指定的 charset 解码指定的 byte 数组，构造一个新的 String。
String(byte[] bytes, int offset, int length, Charset charset)
通过使用指定的 charset 解码指定的 byte 子数组，构造一个新的 String。

java.nio.charset 中 Charset 的使用

返回 Charset 的 java.nio.charset 中的方法
Charset | CharsetEncoder.charset() 返回创建此编码器的 charset。
Charset | CharsetDecoder.charset() 返回创建此解码器的 charset。
static Charset | Charset.defaultCharset() 返回此 Java 虚拟机的默认 charset。
Charset | CharsetDecoder.detectedCharset() 获取此解码器检测到的 charset（可选操作）。
static Charset | Charset.forName(String charsetName) 返回指定 charset 的 charset 对象。

返回变量类型为 Charset 的类型的 java.nio.charset 中的方法
static SortedMap<String,Charset> Charset.availableCharsets()
构造从规范 charset 名称到 charset 对象的有序映射。

参数类型为 Charset 的 java.nio.charset 中的方法
int | Charset.compareTo(Charset that) 比较此 charset 与其他 charset。
abstract boolean | Charset.contains(Charset cs) 通知此 charset 是否包含给定的 charset。

参数类型为 Charset 的 java.nio.charset 中的构造方法
CharsetDecoder(Charset cs, float averageCharsPerByte, float maxCharsPerByte)
初始化新的解码器。
CharsetEncoder(Charset cs, float averageBytesPerChar, float maxBytesPerChar)
初始化新的编码器。
CharsetEncoder(Charset cs, float averageBytesPerChar, float maxBytesPerChar, byte[] replacement)
初始化新的编码器。

java.nio.charset.spi 中 Charset 的使用

返回 Charset 的 java.nio.charset.spi 中的方法
abstract  Charset CharsetProvider.charsetForName(String charsetName)
用给定的 charset 名称获取 charset。

返回变量类型为 Charset 的类型的 java.nio.charset.spi 中的方法
abstract  Iterator<Charset> CharsetProvider.charsets()
创建在此提供者所支持的 charset 上进行迭代的迭代器。

javax.tools 中 Charset 的使用

参数类型为 Charset 的 javax.tools 中的方法
 StandardJavaFileManager JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset)
为此工具获取一个标准文件管理器实现的新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.BufferOverflowException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.BufferOverflowException
的使用

没有 java.nio.BufferOverflowException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.BufferUnderflowException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.BufferUnderflowException
的使用

没有 java.nio.BufferUnderflowException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.DoubleBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.DoubleBuffer
的使用

使用 DoubleBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 DoubleBuffer 的使用

返回 DoubleBuffer 的 java.nio 中的方法
static DoubleBuffer | DoubleBuffer.allocate(int capacity) 分配新的 double 缓冲区。
abstract DoubleBuffer | ByteBuffer.asDoubleBuffer() 创建此字节缓冲区的视图，作为 double 缓冲区。
abstract DoubleBuffer | DoubleBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 double 缓冲区。
abstract DoubleBuffer | DoubleBuffer.compact() 压缩此缓冲区（可选操作）。
abstract DoubleBuffer | DoubleBuffer.duplicate() 创建共享此缓冲区内容的新的 double 缓冲区。
DoubleBuffer | DoubleBuffer.get(double[] dst) 相对批量 get 方法。
DoubleBuffer | DoubleBuffer.get(double[] dst, int offset, int length) 相对批量 get 方法。
abstract DoubleBuffer | DoubleBuffer.put(double d) 相对 put 方法（可选操作）。
DoubleBuffer | DoubleBuffer.put(double[] src) 相对批量 put 方法（可选操作）。
DoubleBuffer | DoubleBuffer.put(double[] src, int offset, int length) 相对批量 put 方法（可选操作）。
DoubleBuffer | DoubleBuffer.put(DoubleBuffer src) 相对批量 put 方法（可选操作）。
abstract DoubleBuffer | DoubleBuffer.put(int index, double d) 绝对 put 方法（可选操作）。
abstract DoubleBuffer | DoubleBuffer.slice() 创建新的 double 缓冲区，其内容是此缓冲区内容的共享子序列。
static DoubleBuffer | DoubleBuffer.wrap(double[] array) 将 double 数组包装到缓冲区中。
static DoubleBuffer | DoubleBuffer.wrap(double[] array, int offset, int length) 将 double 数组包装到缓冲区中。

参数类型为 DoubleBuffer 的 java.nio 中的方法
int | DoubleBuffer.compareTo(DoubleBuffer that) 将此缓冲区与另一个缓冲区进行比较。
DoubleBuffer | DoubleBuffer.put(DoubleBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.FloatBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.FloatBuffer
的使用

使用 FloatBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 FloatBuffer 的使用

返回 FloatBuffer 的 java.nio 中的方法
static FloatBuffer | FloatBuffer.allocate(int capacity) 分配新的 float 缓冲区。
abstract FloatBuffer | ByteBuffer.asFloatBuffer() 创建此字节缓冲区的视图，作为 float 缓冲区。
abstract FloatBuffer | FloatBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 float 缓冲区。
abstract FloatBuffer | FloatBuffer.compact() 压缩此缓冲区（可选操作）。
abstract FloatBuffer | FloatBuffer.duplicate() 创建共享此缓冲区内容的新的 float 缓冲区。
FloatBuffer | FloatBuffer.get(float[] dst) 相对批量 get 方法。
FloatBuffer | FloatBuffer.get(float[] dst, int offset, int length) 相对批量 get 方法。
abstract FloatBuffer | FloatBuffer.put(float f) 相对 put 方法（可选操作）。
FloatBuffer | FloatBuffer.put(float[] src) 相对批量 put 方法（可选操作）。
FloatBuffer | FloatBuffer.put(float[] src, int offset, int length) 相对批量 put 方法（可选操作）。
FloatBuffer | FloatBuffer.put(FloatBuffer src) 相对批量 put 方法（可选操作）。
abstract FloatBuffer | FloatBuffer.put(int index, float f) 绝对 put 方法（可选操作）。
abstract FloatBuffer | FloatBuffer.slice() 创建新的 float 缓冲区，其内容是此缓冲区内容的共享子序列。
static FloatBuffer | FloatBuffer.wrap(float[] array) 将 float 数组包装到缓冲区中。
static FloatBuffer | FloatBuffer.wrap(float[] array, int offset, int length) 将 float 数组包装到缓冲区中。

参数类型为 FloatBuffer 的 java.nio 中的方法
int | FloatBuffer.compareTo(FloatBuffer that) 将此缓冲区与另一个缓冲区进行比较。
FloatBuffer | FloatBuffer.put(FloatBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.InvalidMarkException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.InvalidMarkException
的使用

没有 java.nio.InvalidMarkException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.LongBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.LongBuffer
的使用

使用 LongBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 LongBuffer 的使用

返回 LongBuffer 的 java.nio 中的方法
static LongBuffer | LongBuffer.allocate(int capacity) 分配新的 long 缓冲区。
abstract LongBuffer | ByteBuffer.asLongBuffer() 创建此字节缓冲区的视图，作为 long 缓冲区。
abstract LongBuffer | LongBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 long 缓冲区。
abstract LongBuffer | LongBuffer.compact() 压缩此缓冲区（可选操作）。
abstract LongBuffer | LongBuffer.duplicate() 创建共享此缓冲区内容的新的 long 缓冲区。
LongBuffer | LongBuffer.get(long[] dst) 相对批量 get 方法。
LongBuffer | LongBuffer.get(long[] dst, int offset, int length) 相对批量 get 方法。
abstract LongBuffer | LongBuffer.put(int index, long l) 绝对 put 方法（可选操作）。
abstract LongBuffer | LongBuffer.put(long l) 相对 put 方法（可选操作）。
LongBuffer | LongBuffer.put(long[] src) 相对批量 put 方法（可选操作）。
LongBuffer | LongBuffer.put(long[] src, int offset, int length) 相对批量 put 方法（可选操作）。
LongBuffer | LongBuffer.put(LongBuffer src) 相对批量 put 方法（可选操作）。
abstract LongBuffer | LongBuffer.slice() 创建新的 long 缓冲区，其内容是此缓冲区内容的共享子序列。
static LongBuffer | LongBuffer.wrap(long[] array) 将 long 数组包装到缓冲区中。
static LongBuffer | LongBuffer.wrap(long[] array, int offset, int length) 将 long 数组包装到缓冲区中。

参数类型为 LongBuffer 的 java.nio 中的方法
int | LongBuffer.compareTo(LongBuffer that) 将此缓冲区与另一个缓冲区进行比较。
LongBuffer | LongBuffer.put(LongBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.ReadOnlyBufferException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ReadOnlyBufferException
的使用

没有 java.nio.ReadOnlyBufferException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.ShortBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ShortBuffer
的使用

使用 ShortBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 ShortBuffer 的使用

返回 ShortBuffer 的 java.nio 中的方法
static ShortBuffer | ShortBuffer.allocate(int capacity) 分配新的 short 缓冲区。
abstract ShortBuffer | ShortBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 short 缓冲区。
abstract ShortBuffer | ByteBuffer.asShortBuffer() 创建此字节缓冲区的视图，作为 short 缓冲区。
abstract ShortBuffer | ShortBuffer.compact() 压缩此缓冲区（可选操作）。
abstract ShortBuffer | ShortBuffer.duplicate() 创建共享此缓冲区内容的新的 short 缓冲区。
ShortBuffer | ShortBuffer.get(short[] dst) 相对批量 get 方法。
ShortBuffer | ShortBuffer.get(short[] dst, int offset, int length) 相对批量 get 方法。
abstract ShortBuffer | ShortBuffer.put(int index, short s) 绝对 put 方法（可选操作）。
abstract ShortBuffer | ShortBuffer.put(short s) 相对 put 方法（可选操作）。
ShortBuffer | ShortBuffer.put(short[] src) 相对批量 put 方法（可选操作）。
ShortBuffer | ShortBuffer.put(short[] src, int offset, int length) 相对批量 put 方法（可选操作）。
ShortBuffer | ShortBuffer.put(ShortBuffer src) 相对批量 put 方法（可选操作）。
abstract ShortBuffer | ShortBuffer.slice() 创建新的 short 缓冲区，其内容是此缓冲区内容的共享子序列。
static ShortBuffer | ShortBuffer.wrap(short[] array) 将 short 数组包装到缓冲区中。
static ShortBuffer | ShortBuffer.wrap(short[] array, int offset, int length) 将 short 数组包装到缓冲区中。

参数类型为 ShortBuffer 的 java.nio 中的方法
int | ShortBuffer.compareTo(ShortBuffer that) 将此缓冲区与另一个缓冲区进行比较。
ShortBuffer | ShortBuffer.put(ShortBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.IntBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.IntBuffer
的使用

使用 IntBuffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 IntBuffer 的使用

返回 IntBuffer 的 java.nio 中的方法
static IntBuffer | IntBuffer.allocate(int capacity) 分配新的 int 缓冲区。
abstract IntBuffer | ByteBuffer.asIntBuffer() 创建此字节缓冲区的视图，作为 int 缓冲区。
abstract IntBuffer | IntBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读 int 缓冲区。
abstract IntBuffer | IntBuffer.compact() 压缩此缓冲区（可选操作）。
abstract IntBuffer | IntBuffer.duplicate() 创建共享此缓冲区内容的新的 int 缓冲区。
IntBuffer | IntBuffer.get(int[] dst) 相对批量 get 方法。
IntBuffer | IntBuffer.get(int[] dst, int offset, int length) 相对批量 get 方法。
abstract IntBuffer | IntBuffer.put(int i) 相对 put 方法（可选操作）。
IntBuffer | IntBuffer.put(int[] src) 相对批量 put 方法（可选操作）。
IntBuffer | IntBuffer.put(int[] src, int offset, int length) 相对批量 put 方法（可选操作）。
IntBuffer | IntBuffer.put(IntBuffer src) 相对批量 put 方法（可选操作）。
abstract IntBuffer | IntBuffer.put(int index, int i) 绝对 put 方法（可选操作）。
abstract IntBuffer | IntBuffer.slice() 创建新的 int 数组，其内容是此缓冲区内容的共享子序列。
static IntBuffer | IntBuffer.wrap(int[] array) 将 int 数组包装到缓冲区中。
static IntBuffer | IntBuffer.wrap(int[] array, int offset, int length) 将 int 数组包装到缓冲区中。

参数类型为 IntBuffer 的 java.nio 中的方法
int | IntBuffer.compareTo(IntBuffer that) 将此缓冲区与另一个缓冲区进行比较。
IntBuffer | IntBuffer.put(IntBuffer src) 相对批量 put 方法（可选操作）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.MappedByteBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.MappedByteBuffer
的使用

使用 MappedByteBuffer 的软件包
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。

java.nio 中 MappedByteBuffer 的使用

返回 MappedByteBuffer 的 java.nio 中的方法
MappedByteBuffer | MappedByteBuffer.force() 将此缓冲区所做的内容更改强制写入包含映射文件的存储设备中。
MappedByteBuffer | MappedByteBuffer.load() 将此缓冲区内容加载到物理内存中。

java.nio.channels 中 MappedByteBuffer 的使用

返回 MappedByteBuffer 的 java.nio.channels 中的方法
abstract  MappedByteBuffer FileChannel.map(FileChannel.MapMode mode, long position, long size)
将此通道的文件区域直接映射到内存中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.CharBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.CharBuffer
的使用

使用 CharBuffer 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。

java.io 中 CharBuffer 的使用

参数类型为 CharBuffer 的 java.io 中的方法
 int Reader.read(CharBuffer target)
试图将字符读入指定的字符缓冲区。

java.lang 中 CharBuffer 的使用

参数类型为 CharBuffer 的 java.lang 中的方法
 int Readable.read(CharBuffer cb)
试图将字符读入指定的字符缓冲区。

java.nio 中 CharBuffer 的使用

返回 CharBuffer 的 java.nio 中的方法
static CharBuffer | CharBuffer.allocate(int capacity) 分配新的字符缓冲区。
CharBuffer | CharBuffer.append(char c) 将指定字符添加到此缓冲区（可选操作）。
CharBuffer | CharBuffer.append(CharSequence csq) 将指定的字符序列添加到此缓冲区（可选操作）。
CharBuffer | CharBuffer.append(CharSequence csq, int start, int end) 将指定字符序列的子序列添加到此缓冲区（可选操作）。
abstract CharBuffer | ByteBuffer.asCharBuffer() 创建此字节缓冲区的视图，作为 char 缓冲区。
abstract CharBuffer | CharBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读字符缓冲区。
abstract CharBuffer | CharBuffer.compact() 压缩此缓冲区（可选操作）。
abstract CharBuffer | CharBuffer.duplicate() 创建共享此缓冲区内容的新的字符缓冲区。
CharBuffer | CharBuffer.get(char[] dst) 相对批量 get 方法。
CharBuffer | CharBuffer.get(char[] dst, int offset, int length) 相对批量 get 方法。
abstract CharBuffer | CharBuffer.put(char c) 相对 put 方法（可选操作）。
CharBuffer | CharBuffer.put(char[] src) 相对批量 put 方法（可选操作）。
CharBuffer | CharBuffer.put(char[] src, int offset, int length) 相对批量 put 方法（可选操作）。
CharBuffer | CharBuffer.put(CharBuffer src) 相对批量 put 方法（可选操作）。
abstract CharBuffer | CharBuffer.put(int index, char c) 绝对 put 方法（可选操作）。
CharBuffer | CharBuffer.put(String src) 相对批量 put 方法（可选操作）。
CharBuffer | CharBuffer.put(String src, int start, int end) 相对批量 put 方法（可选操作）。
abstract CharBuffer | CharBuffer.slice() 创建新的字符缓冲区，其内容为此缓冲区内容的共享子序列。
static CharBuffer | CharBuffer.wrap(char[] array) 将字符数组包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(char[] array, int offset, int length) 将字符数组包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(CharSequence csq) 将字符序列包装到缓冲区中。
static CharBuffer | CharBuffer.wrap(CharSequence csq, int start, int end) 将字符序列包装到缓冲区中。

参数类型为 CharBuffer 的 java.nio 中的方法
int | CharBuffer.compareTo(CharBuffer that) 将此缓冲区与另一个缓冲区进行比较。
CharBuffer | CharBuffer.put(CharBuffer src) 相对批量 put 方法（可选操作）。
int | CharBuffer.read(CharBuffer target) 试图将字符读入指定的字符缓冲区。

java.nio.charset 中 CharBuffer 的使用

返回 CharBuffer 的 java.nio.charset 中的方法
CharBuffer | CharsetDecoder.decode(ByteBuffer in) 把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
CharBuffer | Charset.decode(ByteBuffer bb) 将此 charset 中的字节解码成 Unicode 字符的便捷方法。

参数类型为 CharBuffer 的 java.nio.charset 中的方法
CoderResult | CharsetDecoder.decode(ByteBuffer in, CharBuffer out, boolean endOfInput) 从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetDecoder.decodeLoop(ByteBuffer in, CharBuffer out) 将一个或多个字节解码为一个或多个字符。
ByteBuffer | CharsetEncoder.encode(CharBuffer in) 把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
ByteBuffer | Charset.encode(CharBuffer cb) 将此 charset 中的 Unicode 字符编码成字节的便捷方法。
CoderResult | CharsetEncoder.encode(CharBuffer in, ByteBuffer out, boolean endOfInput) 从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetEncoder.encodeLoop(CharBuffer in, ByteBuffer out) 将一个或多个字符编码为一个或多个字节。
CoderResult | CharsetDecoder.flush(CharBuffer out) 刷新此解码器。
protected CoderResult | CharsetDecoder.implFlush(CharBuffer out) 刷新此解码器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.ByteOrder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ByteOrder
的使用

使用 ByteOrder 的软件包
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

java.nio 中 ByteOrder 的使用

声明为 ByteOrder 的 java.nio 中的字段
static ByteOrder | ByteOrder.BIG_ENDIAN 表示 big-endian 字节顺序的常量。
static ByteOrder | ByteOrder.LITTLE_ENDIAN 表示 little-endian 字节顺序的常量。

返回 ByteOrder 的 java.nio 中的方法
static ByteOrder | ByteOrder.nativeOrder() 获取底层平台的本机字节顺序。
abstract ByteOrder | DoubleBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | FloatBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | LongBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | ShortBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | IntBuffer.order() 获取此缓冲区的字节顺序。
abstract ByteOrder | CharBuffer.order() 获取此缓冲区的字节顺序。
ByteOrder | ByteBuffer.order() 获取此缓冲区的字节顺序。

参数类型为 ByteOrder 的 java.nio 中的方法
 ByteBuffer ByteBuffer.order(ByteOrder bo)
修改此缓冲区的字节顺序。

javax.imageio.stream 中 ByteOrder 的使用

声明为 ByteOrder 的 javax.imageio.stream 中的字段
protected  ByteOrder ImageInputStreamImpl.byteOrder
流的字节顺序，其为枚举类 java.nio.ByteOrder 的实例，其中 ByteOrder.BIG_ENDIAN 指示网络字节顺序，ByteOrder.LITTLE_ENDIAN 指示反向顺序。

返回 ByteOrder 的 javax.imageio.stream 中的方法
ByteOrder | ImageInputStream.getByteOrder() 以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。
ByteOrder | ImageInputStreamImpl.getByteOrder()

参数类型为 ByteOrder 的 javax.imageio.stream 中的方法
void | ImageInputStream.setByteOrder(ByteOrder byteOrder) 设置希望以后从此流中读取数据值时使用的字节顺序。
void | ImageInputStreamImpl.setByteOrder(ByteOrder byteOrder)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.ByteBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.ByteBuffer
的使用

使用 ByteBuffer 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio | 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.lang 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 java.lang 中的方法
protected  Class<?> ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain)
使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

java.nio 中 ByteBuffer 的使用

java.nio 中 ByteBuffer 的子类
 class MappedByteBuffer
直接字节缓冲区，其内容是文件的内存映射区域。

返回 ByteBuffer 的 java.nio 中的方法
static ByteBuffer | ByteBuffer.allocate(int capacity) 分配一个新的字节缓冲区。
static ByteBuffer | ByteBuffer.allocateDirect(int capacity) 分配新的直接字节缓冲区。
abstract ByteBuffer | ByteBuffer.asReadOnlyBuffer() 创建共享此缓冲区内容的新的只读字节缓冲区。
abstract ByteBuffer | ByteBuffer.compact() 压缩此缓冲区（可选操作）。
abstract ByteBuffer | ByteBuffer.duplicate() 创建共享此缓冲区内容的新的字节缓冲区。
ByteBuffer | ByteBuffer.get(byte[] dst) 相对批量 get 方法。
ByteBuffer | ByteBuffer.get(byte[] dst, int offset, int length) 相对批量 get 方法。
ByteBuffer | ByteBuffer.order(ByteOrder bo) 修改此缓冲区的字节顺序。
abstract ByteBuffer | ByteBuffer.put(byte b) 相对 put 方法（可选操作）。
ByteBuffer | ByteBuffer.put(byte[] src) 相对批量 put 方法（可选操作）。
ByteBuffer | ByteBuffer.put(byte[] src, int offset, int length) 相对批量 put 方法（可选操作）。
ByteBuffer | ByteBuffer.put(ByteBuffer src) 相对批量 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.put(int index, byte b) 绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putChar(char value) 用来写入 char 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putChar(int index, char value) 用于写入 char 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putDouble(double value) 用于写入 double 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putDouble(int index, double value) 用于写入 double 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putFloat(float value) 用于写入 float 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putFloat(int index, float value) 用于写入 float 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putInt(int value) 用于写入 int 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putInt(int index, int value) 用于写入 int 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putLong(int index, long value) 用于写入 long 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putLong(long value) 用于写入 long 值（可先操作） 的相对 put 方法。
abstract ByteBuffer | ByteBuffer.putShort(int index, short value) 用于写入 short 值的绝对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.putShort(short value) 用于写入 short 值的相对 put 方法（可选操作）。
abstract ByteBuffer | ByteBuffer.slice() 创建新的字节缓冲区，其内容是此缓冲区内容的共享子序列。
static ByteBuffer | ByteBuffer.wrap(byte[] array) 将 byte 数组包装到缓冲区中。
static ByteBuffer | ByteBuffer.wrap(byte[] array, int offset, int length) 将 byte 数组包装到缓冲区中。

参数类型为 ByteBuffer 的 java.nio 中的方法
int | ByteBuffer.compareTo(ByteBuffer that) 将此缓冲区与另一个缓冲区进行比较。
ByteBuffer | ByteBuffer.put(ByteBuffer src) 相对批量 put 方法（可选操作）。

java.nio.channels 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 java.nio.channels 中的方法
abstract int | DatagramChannel.read(ByteBuffer dst) 从此通道读取数据报。
abstract int | SocketChannel.read(ByteBuffer dst)
abstract int | FileChannel.read(ByteBuffer dst) 将字节序列从此通道读入给定的缓冲区。
int | ReadableByteChannel.read(ByteBuffer dst) 将字节序列从此通道中读入给定的缓冲区。
long | DatagramChannel.read(ByteBuffer[] dsts) 从此通道读取数据报。
long | SocketChannel.read(ByteBuffer[] dsts)
long | FileChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
long | ScatteringByteChannel.read(ByteBuffer[] dsts) 将字节序列从此通道读入给定的缓冲区。
abstract long | DatagramChannel.read(ByteBuffer[] dsts, int offset, int length) 从此通道读取数据报。
abstract long | SocketChannel.read(ByteBuffer[] dsts, int offset, int length)
abstract long | FileChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
long | ScatteringByteChannel.read(ByteBuffer[] dsts, int offset, int length) 将字节序列从此通道读入给定缓冲区的子序列中。
abstract int | FileChannel.read(ByteBuffer dst, long position) 从给定的文件位置开始，从此通道读取字节序列,并写入给定的缓冲区。
abstract SocketAddress | DatagramChannel.receive(ByteBuffer dst) 通过此通道接收数据报。
abstract int | DatagramChannel.send(ByteBuffer src, SocketAddress target) 通过此通道发送数据报。
abstract int | DatagramChannel.write(ByteBuffer src) 将数据报写入此通道。
abstract int | SocketChannel.write(ByteBuffer src)
abstract int | FileChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区写入此通道。
int | WritableByteChannel.write(ByteBuffer src) 将字节序列从给定的缓冲区中写入此通道。
long | DatagramChannel.write(ByteBuffer[] srcs) 将数据报写入此通道。
long | SocketChannel.write(ByteBuffer[] srcs)
long | FileChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs) 将字节序列从给定的缓冲区写入此通道。
abstract long | DatagramChannel.write(ByteBuffer[] srcs, int offset, int length) 将数据报写入此通道。
abstract long | SocketChannel.write(ByteBuffer[] srcs, int offset, int length)
abstract long | FileChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
long | GatheringByteChannel.write(ByteBuffer[] srcs, int offset, int length) 将字节序列从给定缓冲区的子序列写入此通道。
abstract int | FileChannel.write(ByteBuffer src, long position) 从给定的文件位置开始，将字节序列从给定缓冲区写入此通道。

java.nio.charset 中 ByteBuffer 的使用

返回 ByteBuffer 的 java.nio.charset 中的方法
ByteBuffer | CharsetEncoder.encode(CharBuffer in) 把单个输入字符缓冲区的剩余内容编码到新分配的字节缓冲区的便捷方法。
ByteBuffer | Charset.encode(CharBuffer cb) 将此 charset 中的 Unicode 字符编码成字节的便捷方法。
ByteBuffer | Charset.encode(String str) 将此 charset 中的字符串编码成字节的便捷方法。

参数类型为 ByteBuffer 的 java.nio.charset 中的方法
CharBuffer | CharsetDecoder.decode(ByteBuffer in) 把单个输入字节缓冲区的剩余内容解码到新分配的字符缓冲区的便捷方法。
CharBuffer | Charset.decode(ByteBuffer bb) 将此 charset 中的字节解码成 Unicode 字符的便捷方法。
CoderResult | CharsetDecoder.decode(ByteBuffer in, CharBuffer out, boolean endOfInput) 从给定的输入缓冲区中解码尽可能多的字节，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetDecoder.decodeLoop(ByteBuffer in, CharBuffer out) 将一个或多个字节解码为一个或多个字符。
CoderResult | CharsetEncoder.encode(CharBuffer in, ByteBuffer out, boolean endOfInput) 从给定输入缓冲区中编码尽可能多的字符，把结果写入给定的输出缓冲区。
protected abstract CoderResult | CharsetEncoder.encodeLoop(CharBuffer in, ByteBuffer out) 将一个或多个字符编码为一个或多个字节。
CoderResult | CharsetEncoder.flush(ByteBuffer out) 刷新此编码器。
protected CoderResult | CharsetEncoder.implFlush(ByteBuffer out) 刷新此编码器。

java.security 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 java.security 中的方法
protected Class<?> | SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs) 使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。
protected void | SignatureSpi.engineUpdate(ByteBuffer input) 使用指定的 ByteBuffer 更新要签名或验证的数据。
protected void | MessageDigestSpi.engineUpdate(ByteBuffer input) 使用指定的 ByteBuffer 更新摘要。
void | Signature.update(ByteBuffer data) 使用指定的 ByteBuffer 更新要签名或验证的数据。
void | MessageDigest.update(ByteBuffer input) 使用指定的 ByteBuffer 更新摘要。

javax.crypto 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 javax.crypto 中的方法
 int Cipher.doFinal(ByteBuffer input, ByteBuffer output)
按单部分操作加密或解密数据，或者结束一个多部分操作。
protected  int CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output)
按单部分操作加密或解密数据，或者结束一个多部分操作。
protected  void MacSpi.engineUpdate(ByteBuffer input)
从 input.position() 开始处，处理 ByteBuffer input 中的 input.remaining() 字节。
protected  int CipherSpi.engineUpdate(ByteBuffer input, ByteBuffer output)
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
 void Mac.update(ByteBuffer input)
从 input.position() 开始，处理 ByteBuffer input 中的 input.remaining() 个字节。
 int Cipher.update(ByteBuffer input, ByteBuffer output)
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

javax.net.ssl 中 ByteBuffer 的使用

参数类型为 ByteBuffer 的 javax.net.ssl 中的方法
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer src, ByteBuffer dst) 试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.nio.Buffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.nio.Buffer
的使用

使用 Buffer 的软件包
java.nio 定义作为数据容器的缓冲区，并提供其他 NIO 包的概述。

java.nio 中 Buffer 的使用

java.nio 中 Buffer 的子类
class | ByteBuffer 字节缓冲区。
class | CharBuffer 字符缓冲区。
class | DoubleBuffer double 缓冲区。
class | FloatBuffer float 缓冲区。
class | IntBuffer int 缓冲区。
class | LongBuffer long 缓冲区。
class | MappedByteBuffer 直接字节缓冲区，其内容是文件的内存映射区域。
class | ShortBuffer short 缓冲区。

返回 Buffer 的 java.nio 中的方法
Buffer | Buffer.clear() 清除此缓冲区。
Buffer | Buffer.flip() 反转此缓冲区。
Buffer | Buffer.limit(int newLimit) 设置此缓冲区的限制。
Buffer | Buffer.mark() 在此缓冲区的位置设置标记。
Buffer | Buffer.position(int newPosition) 设置此缓冲区的位置。
Buffer | Buffer.reset() 将此缓冲区的位置重置为以前标记的位置。
Buffer | Buffer.rewind() 重绕此缓冲区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AccessException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 AccessException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.AccessException
所有已实现的接口：
Serializable
public class AccessException
extends RemoteException

AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。如果该方法从非本地主机调用，则抛出 AccessException。

从以下版本开始：
JDK1.1
另请参见：
Naming, ActivationSystem, 序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
AccessException(String s)
构造带指定详细消息的 AccessException。
AccessException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 AccessException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AccessException

public AccessException(String s)
构造带指定详细消息的 AccessException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

AccessException

public AccessException(String s,
                       Exception ex)
构造带指定详细消息和嵌入异常的 AccessException。

参数：
s - 详细信息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AlreadyBoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 AlreadyBoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.rmi.AlreadyBoundException
所有已实现的接口：
Serializable
public class AlreadyBoundException
extends Exception

如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。

从以下版本开始：
JDK1.1
另请参见：
Naming.bind(String, java.rmi.Remote), Registry.bind(String, java.rmi.Remote), 序列化表格

构造方法摘要
AlreadyBoundException()
构造不带指定详细消息的 AlreadyBoundException。
AlreadyBoundException(String s)
构造带指定详细消息的 AlreadyBoundException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AlreadyBoundException

public AlreadyBoundException()
构造不带指定详细消息的 AlreadyBoundException。

从以下版本开始：
JDK1.1

AlreadyBoundException

public AlreadyBoundException(String s)
构造带指定详细消息的 AlreadyBoundException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConnectException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 ConnectException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.ConnectException
所有已实现的接口：
Serializable
public class ConnectException
extends RemoteException

如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ConnectException(String s)
构造带指定详细消息的 ConnectException。
ConnectException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConnectException

public ConnectException(String s)
构造带指定详细消息的 ConnectException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

ConnectException

public ConnectException(String s,
                        Exception ex)
构造带指定详细消息和嵌入异常的 ConnectException。

参数：
s - 详细信息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConnectIOException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 ConnectIOException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.ConnectIOException
所有已实现的接口：
Serializable
public class ConnectIOException
extends RemoteException

如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ConnectIOException(String s)
构造带指定详细消息的 ConnectIOException。
ConnectIOException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ConnectIOException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConnectIOException

public ConnectIOException(String s)
构造带指定详细消息的 ConnectIOException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

ConnectIOException

public ConnectIOException(String s,
                          Exception ex)
构造带指定详细消息和嵌入异常的 ConnectIOException。

参数：
s - 详细信息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarshalException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 MarshalException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.MarshalException
所有已实现的接口：
Serializable
public class MarshalException
extends RemoteException

如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。如果接收方不支持发送方的协议版本，也将抛出 MarshalException。

如果在远程方法调用过程中发生 MarshalException，则该调用可能到达也可能没有到达服务器。如果调用已确实到达服务器，则可能已对参数进行了反序列化。调用在抛出 MarshalException 之后可能无法转发，并且可靠地保持“至多发送一次”的调用语义。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
MarshalException(String s)
构造带有指定详细消息的 MarshalException。
MarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 MarshalException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MarshalException

public MarshalException(String s)
构造带有指定详细消息的 MarshalException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

MarshalException

public MarshalException(String s,
                        Exception ex)
构造带指定详细消息和嵌入异常的 MarshalException。

参数：
s - 详细信息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MarshalledObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 MarshalledObject<T>

java.lang.Object
    继承者  java.rmi.MarshalledObject<T>
类型参数：
T - 包含在此 MarshalledObject 中的对象类型
所有已实现的接口：
Serializable
public final class MarshalledObject<T>
extends Object
implements Serializable

MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。在从包含的字节流进行反序列化时，get 方法会返回原始对象的一个新的副本。包含的对象使用相同的用来编组和解组参数的序列化语义进行序列化和反序列化，并返回 RMI 调用的值：创建序列化形式时：

  • 使用可以从中加载类（如果可用）的基本代码 URL 对类进行注释，并且
  • MarshalledObject 中的任何远程对象都由其 stub 的序列化实例表示。

当获取对象的副本时（通过 get 方法），如果本地没有提供此类，则从适当的位置加载它（该位置是由 URL 指定的，在对类序列化时就已经将此 URL 注释了该类的描述符）。

MarshalledObject 便于将对象传入 RMI 调用，该调用不会立即通过远程同位体自动进行反序列化。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
MarshalledObject(T obj)
创建一个新的 MarshalledObject，它包含所提供对象的当前状态的序列化表示形式。
方法摘要
boolean | equals(Object obj) 将此 MarshalledObject 与另一对象进行比较。
T | get() 返回所包含的 marshalledobject 的新副本。
int | hashCode() 返回该 MarshalledObject 的哈希码。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MarshalledObject

public MarshalledObject(T obj)
                 throws IOException
创建一个新的 MarshalledObject，它包含所提供对象的当前状态的序列化表示形式。使用用于 RMI 调用的编组参数的语义序列化该对象。

参数：
obj - 要序列化的对象（必须是可序列化的）
抛出：
IOException - 如果发生 IOException；如果 obj 不是可序列化的，则可能发生 IOException。
从以下版本开始：
1.2
方法详细信息

get

public T get()
      throws IOException,
             ClassNotFoundException
返回所包含的 marshalledobject 的新副本。使用用于 RMI 调用的解编参数的语义反序列化内部表示形式。

返回：
所包含对象的副本
抛出：
IOException - 如果从其内部表示形式反序列化对象时发生 IOException。
ClassNotFoundException - 如果无法找到从其内部表示形式进行反序列化的对象时发生 ClassNotFoundException。
从以下版本开始：
1.2

hashCode

public int hashCode()
返回该 MarshalledObject 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此 MarshalledObject 与另一对象进行比较。当且仅当参数引用完全包含与此对象相同的对象序列化表示形式的 MarshalledObject 时，返回 true。该比较忽略任何基本代码注释，意味着如果两个对象具有相同的序列化表示形式（序列化表示形式中每个类的基本代码除外），则这两个对象等效。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此 MarshalledObject 比较的对象
返回：
如果参数包含等效的序列化对象，则返回 true；否则返回 false
从以下版本开始：
1.2
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Naming (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 Naming

java.lang.Object
    继承者  java.rmi.Naming

public final class Naming
extends Object

Naming 类提供在对象注册表中存储和获得远程对远程对象引用的方法。Naming 类的每个方法都可将某个名称作为其一个参数，该名称是使用以下形式的 URL 格式（没有 scheme 组件）的 java.lang.String：

    //host:port/name

其中 host 是注册表所在的主机（远程或本地），port 是注册表接受调用的端口号，name 是未经注册表解释的简单字符串。host 和 port 两者都是可选项。如果省略了 host，则主机默认为本地主机。如果省略了 port，则端口默认为 1099，该端口是 RMI 的注册表 rmiregistry 使用的“著名”端口。

为远程对象 绑定 名称是指为远程对象关联或注册一个名称，以后可以使用该名称来查找该远程对象。可以使用 Naming 类的 bind 或 rebind 方法将远程对象与某个名称相关联。

一旦远程对象向本地主机上 RMI 注册表注册（绑定），远程（或本地）主机上的调用方可以通过名称查找远程对象，获得其引用，并在该对象上调用远程方法。注册表可由在一个主机上运行的所有服务器共享，需要时个别服务器进程也可以创建和使用自己的注册表（有关详细信息，请参见 java.rmi.registry.LocateRegistry.createRegistry）。

从以下版本开始：
JDK1.1
另请参见：
Registry, LocateRegistry, LocateRegistry.createRegistry(int)

方法摘要
static void | bind(String name, Remote obj) 将指定 name 绑定到远程对象。
static String[] | list(String name) 返回在注册表中绑定的名称所组成的数组。
static Remote | lookup(String name) 返回与指定 name 关联的远程对象的引用（一个 stub）。
static void | rebind(String name, Remote obj) 将指定名称重新绑定到一个新的远程对象。
static void | unbind(String name) 销毁与远程对象关联的指定名称的绑定。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

lookup

public static Remote lookup(String name)
                     throws NotBoundException,
                            MalformedURLException,
                            RemoteException
返回与指定 name 关联的远程对象的引用（一个 stub）。

参数：
name - 使用 URL 格式（不含 scheme 组件）的名称
返回：
远程对象的引用
抛出：
NotBoundException - 如果当前未绑定名称
RemoteException - 如果无法联系注册表
AccessException - 如果不允许执行此操作
MalformedURLException - 如果名称不是适当格式化的 URL
从以下版本开始：
JDK1.1

bind

public static void bind(String name,
                        Remote obj)
                 throws AlreadyBoundException,
                        MalformedURLException,
                        RemoteException
将指定 name 绑定到远程对象。

参数：
name - 使用 URL 格式（不含 scheme 组件）的名称
obj - 远程对象的引用（通常是一个 stub）
抛出：
AlreadyBoundException - 如果已经绑定了名称
MalformedURLException - 如果该名称不是适当格式化的 URL
RemoteException - 如果无法联系注册表
AccessException - 如果不允许进行此操作（例如，如果起源于非本地主机）
从以下版本开始：
JDK1.1

unbind

public static void unbind(String name)
                   throws RemoteException,
                          NotBoundException,
                          MalformedURLException
销毁与远程对象关联的指定名称的绑定。

参数：
name - 使用 URL 格式（不含 scheme 组件）的名称
抛出：
NotBoundException - 如果当前未绑定名称
MalformedURLException - 如果该名称不是适当格式化的 URL
RemoteException - 如果无法联系注册表
AccessException - 如果不允许进行此操作（例如，如果起源于非本地主机）
从以下版本开始：
JDK1.1

rebind

public static void rebind(String name,
                          Remote obj)
                   throws RemoteException,
                          MalformedURLException
将指定名称重新绑定到一个新的远程对象。 将替换任何现有绑定。

参数：
name - 使用 URL 格式（不含 scheme 组件）
obj - 将与名称关联的新远程对象
抛出：
MalformedURLException - 如果该名称不是适当格式化的 URL
RemoteException - 如果无法联系注册表
AccessException - 如果不允许执行此操作（例如，如果起源于非本地主机）
从以下版本开始：
JDK1.1

list

public static String[] list(String name)
                     throws RemoteException,
                            MalformedURLException
返回在注册表中绑定的名称所组成的数组。该名称为 URL 格式（不含 scheme 组件）的字符串。该数组包含在调用时出现在注册表中的名称快照。

参数：
name - 使用 URL 格式（不含 scheme 组件）的注册表名称
返回：
在注册表中绑定的名称（使用适当格式）所组成的数组
抛出：
MalformedURLException - 如果该名称不是适当格式化的 URL
RemoteException - 如果无法联系注册表。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchObjectException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 NoSuchObjectException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.NoSuchObjectException
所有已实现的接口：
Serializable
public class NoSuchObjectException
extends RemoteException

如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。如果试图在某个远程对象上调用方法而发生 NoSuchObjectException，则该调用或许能够转发，并且仍保持 RMI 的“至多发送一次”调用语义。NoSuchObjectException 还可以通过方法 java.rmi.server.RemoteObject.toStub 以及通过 java.rmi.server.UnicastRemoteObject 和 java.rmi.activation.Activatable 的 unexportObject 方法抛出。

从以下版本开始：
JDK1.1
另请参见：
RemoteObject.toStub(Remote),
UnicastRemoteObject.unexportObject(Remote,boolean),
Activatable.unexportObject(Remote,boolean),
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
NoSuchObjectException(String s)
构造带指定详细消息的 NoSuchObjectException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchObjectException

public NoSuchObjectException(String s)
构造带指定详细消息的 NoSuchObjectException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotBoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 NotBoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.rmi.NotBoundException
所有已实现的接口：
Serializable
public class NotBoundException
extends Exception

如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。

从以下版本开始：
JDK1.1
另请参见：
Naming.lookup(String),
Naming.unbind(String),
Registry.lookup(String),
Registry.unbind(String),
序列化表格

构造方法摘要
NotBoundException()
构造不带指定详细消息的 NotBoundException。
NotBoundException(String s)
构造带指定详细消息的 NotBoundException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotBoundException

public NotBoundException()
构造不带指定详细消息的 NotBoundException。

从以下版本开始：
JDK1.1

NotBoundException

public NotBoundException(String s)
构造带指定详细消息的 NotBoundException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Remote (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
接口 Remote

所有已知子接口：
ActivationInstantiator, ActivationMonitor, ActivationSystem, Activator, DGC, Registry, RMIConnection, RMIServer
所有已知实现类：
_Remote_Stub, Activatable, ActivationGroup, ActivationGroup_Stub, RemoteObject, RemoteObjectInvocationHandler, RemoteServer, RemoteStub, RMIConnectionImpl, RMIConnectionImpl_Stub, RMIIIOPServerImpl, RMIJRMPServerImpl, RMIServerImpl, RMIServerImpl_Stub, UnicastRemoteObject
public interface Remote

Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。任何远程对象都必须直接或间接实现此接口。只有在“远程接口”（扩展 java.rmi.Remote 的接口）中指定的这些方法才可远程使用。

实现类可以实现任意数量的远程接口，并且可以扩展其他远程实现类。RMI 提供一些远程对象实现可以扩展的有用类，这些类便于远程对象创建。这些类是 java.rmi.server.UnicastRemoteObject 和 java.rmi.activation.Activatable。

有关 RMI 的完整的详细信息，请参阅描述 RMI API 和系统的 RMI 规范。

从以下版本开始：
JDK1.1
另请参见：
UnicastRemoteObject, Activatable

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 RemoteException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
所有已实现的接口：
Serializable
直接已知子类：
AccessException, ActivateFailedException, ActivityCompletedException, ActivityRequiredException, ConnectException, ConnectIOException, ExportException, InvalidActivityException, InvalidTransactionException, MarshalException, NoSuchObjectException, ServerError, ServerException, ServerRuntimeException, SkeletonMismatchException, SkeletonNotFoundException, StubNotFoundException, TransactionRequiredException, TransactionRolledbackException, UnexpectedException, UnknownHostException, UnmarshalException
public class RemoteException
extends IOException

RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。远程接口（扩展 java.rmi.Remote 的接口）的每个方法必须在其 throws 子句中列出 RemoteException。

从版本 1.4 开始，已对此异常作出改进，以符合通用异常链机制。可以在构造时提供并通过公共 detail 字段访问的“包装的远程异常”现在称为 cause，并可通过 Throwable.getCause() 方法以及前述的“遗留字段”访问。

在 RemoteException 的实例上调用方法 Throwable.initCause(Throwable) 始终抛出 IllegalStateException。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
 Throwable detail
远程异常的原因。
构造方法摘要
RemoteException()
构造一个 RemoteException。
RemoteException(String s)
构造带指定详细消息的 RemoteException。
RemoteException(String s, Throwable cause)
构造带指定详细消息和原因的 RemoteException。
方法摘要
Throwable | getCause() 返回此异常的原因。
String | getMessage() 返回此异常的详细消息，包括来自原因（如果有）方面的消息。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

detail

public Throwable detail
远程异常的原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

构造方法详细信息

RemoteException

public RemoteException()
构造一个 RemoteException。

RemoteException

public RemoteException(String s)
构造带指定详细消息的 RemoteException。

参数：
s - 详细消息

RemoteException

public RemoteException(String s,
                       Throwable cause)
构造带指定详细消息和原因的 RemoteException。此构造方法将 detail 字段设置为指定的 Throwable。

参数：
s - 详细信息
cause - 原因
方法详细信息

getMessage

public String getMessage()
返回此异常的详细消息，包括来自原因（如果有）方面的消息。

覆盖：
类 Throwable 中的 getMessage
返回：
详细消息

getCause

public Throwable getCause()
返回此异常的原因。此方法返回 detail 字段的值。

覆盖：
类 Throwable 中的 getCause
返回：
原因，它可以为 null。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMISecurityException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 RMISecurityException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.SecurityException
                    继承者  java.rmi.RMISecurityException
所有已实现的接口：
Serializable
已过时。 由 SecurityException 取代。应用程序代码从来不应直接引用此类，且 RMISecurityManager 不再抛出 java.lang.SecurityException 的这个子类。

@Deprecated
public class RMISecurityException
extends SecurityException

RMISecurityException 指示在执行 java.rmi.RMISecurityManager 的某个方法过程中已发生安全性异常。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
RMISecurityException(String name)
已过时。 无替换版本
RMISecurityException(String name, String arg)
已过时。 无替换版本
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RMISecurityException

@Deprecated
public RMISecurityException(String name)
已过时。 无替换版本

构造带详细消息的 RMISecurityException。

参数：
name - 详细消息
从以下版本开始：
JDK1.1

RMISecurityException

@Deprecated
public RMISecurityException(String name,
                                       String arg)
已过时。 无替换版本

创建带详细消息的 RMISecurityException。

参数：
name - 详细消息
arg - 忽略
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMISecurityManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 RMISecurityManager

java.lang.Object
    继承者  java.lang.SecurityManager
        继承者  java.rmi.RMISecurityManager

public class RMISecurityManager
extends SecurityManager

由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。如果尚未设置安全管理器，则 RMI 的类加载器不会从远程位置下载任何子类。RMISecurityManager 不用于 applet，它们的运行受其浏览器的安全管理器保护。RMISecurityManager 实现一个与 SecurityManager 实现的策略相同的策略。因此，RMI 应用程序应该使用 SecurityManager 类或其他代替此类的特定于应用程序的 SecurityManager 实现。

要在应用程序中使用 SecurityManager，则将以下语句添加到您的代码（它需要在 RMI 从远程主机下载代码前执行，所以它最可能需要在应用程序的 main 方法中出现）中：

 System.setSecurityManager(new SecurityManager());

从以下版本开始：
JDK1.1

字段摘要
从类 java.lang.SecurityManager 继承的字段
inCheck
构造方法摘要
RMISecurityManager()
构造新的 RMISecurityManager。
方法摘要
从类 java.lang.SecurityManager 继承的方法
checkAccept, checkAccess, checkAccess, checkAwtEventQueueAccess, checkConnect, checkConnect, checkCreateClassLoader, checkDelete, checkExec, checkExit, checkLink, checkListen, checkMemberAccess, checkMulticast, checkMulticast, checkPackageAccess, checkPackageDefinition, checkPermission, checkPermission, checkPrintJobAccess, checkPropertiesAccess, checkPropertyAccess, checkRead, checkRead, checkRead, checkSecurityAccess, checkSetFactory, checkSystemClipboardAccess, checkTopLevelWindow, checkWrite, checkWrite, classDepth, classLoaderDepth, currentClassLoader, currentLoadedClass, getClassContext, getInCheck, getSecurityContext, getThreadGroup, inClass, inClassLoader
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RMISecurityManager

public RMISecurityManager()
构造新的 RMISecurityManager。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 ServerError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.ServerError
所有已实现的接口：
Serializable
public class ServerError
extends RemoteException

当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。ServerError 实例包含作为其 cause 而发生的初始 Error。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ServerError(String s, Error err)
构造带指定详细消息和嵌入错误的 ServerError。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServerError

public ServerError(String s,
                   Error err)
构造带指定详细消息和嵌入错误的 ServerError。

参数：
s - 详细消息
err - 嵌入错误
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 ServerException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.ServerException
所有已实现的接口：
Serializable
public class ServerException
extends RemoteException

在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。 ServerException 实例包含作为 cause 而发生的初始 RemoteException。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ServerException(String s)
构造带指定详细消息的 ServerException。
ServerException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 ServerException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServerException

public ServerException(String s)
构造带指定详细消息的 ServerException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

ServerException

public ServerException(String s,
                       Exception ex)
构造带有指定详细消息和嵌入异常的 ServerException。

参数：
s - 详细消息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerRuntimeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 ServerRuntimeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.ServerRuntimeException
所有已实现的接口：
Serializable
已过时。 无替换版本

@Deprecated
public class ServerRuntimeException
extends RemoteException

当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身，也可以是编组返回值的过程中），如果抛出 RuntimeException，则作为远程方法调用的结果，也会从执行 JDK 1.1 版本的服务器上抛出 ServerRuntimeException。 ServerRuntimeException 实例包含作为其 cause 而发生的初始 RuntimeException。

ServerRuntimeException 不会从执行 Java 2 平台 1.2 或更高版本的服务器上抛出。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ServerRuntimeException(String s, Exception ex)
已过时。 无替换版本
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServerRuntimeException

@Deprecated
public ServerRuntimeException(String s,
                                         Exception ex)
已过时。 无替换版本

构造带有指定详细消息和嵌入异常的 ServerRuntimeException。

参数：
s - 详细消息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StubNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 StubNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.StubNotFoundException
所有已实现的接口：
Serializable
public class StubNotFoundException
extends RemoteException

如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。通过 java.rmi.activation.Activatable.register 方法注册可激活对象时也可能抛出 StubNotFoundException。

从以下版本开始：
JDK1.1
另请参见：
UnicastRemoteObject, Activatable, 序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
StubNotFoundException(String s)
构造带指定详细消息的 StubNotFoundException。
StubNotFoundException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 StubNotFoundException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StubNotFoundException

public StubNotFoundException(String s)
构造带指定详细消息的 StubNotFoundException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

StubNotFoundException

public StubNotFoundException(String s,
                             Exception ex)
构造带指定详细消息和嵌入异常的 StubNotFoundException。

参数：
s - 详细消息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnexpectedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 UnexpectedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.UnexpectedException
所有已实现的接口：
Serializable
public class UnexpectedException
extends RemoteException

如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
UnexpectedException(String s)
构造带指定详细消息的 UnexpectedException。
UnexpectedException(String s, Exception ex)
构造带有指定详细消息和嵌入异常的 UnexpectedException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnexpectedException

public UnexpectedException(String s)
构造带指定详细消息的 UnexpectedException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

UnexpectedException

public UnexpectedException(String s,
                           Exception ex)
构造带有指定详细消息和嵌入异常的 UnexpectedException。

参数：
s - 详细消息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownHostException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 UnknownHostException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.UnknownHostException
所有已实现的接口：
Serializable
public class UnknownHostException
extends RemoteException

如果在创建到远程主机的连接以便进行远程方法调用时发生 java.net.UnknownHostException，则抛出 UnknownHostException。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
UnknownHostException(String s)
构造带指定详细消息的 UnknownHostException。
UnknownHostException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnknownHostException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownHostException

public UnknownHostException(String s)
构造带指定详细消息的 UnknownHostException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

UnknownHostException

public UnknownHostException(String s,
                            Exception ex)
构造带指定详细消息和嵌入异常的 UnknownHostException。

参数：
s - 详细消息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnmarshalException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi
类 UnmarshalException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.UnmarshalException
所有已实现的接口：
Serializable
public class UnmarshalException
extends RemoteException

在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException：

  • 如果在解组调用标题时发生异常
  • 如果返回值的协议无效
  • 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。
  • 如果在解组参数或返回值的过程中发生 java.lang.ClassNotFoundException
  • 如果在服务器端不能加载 skeleton（注意，在 1.1 stub 协议中需要 skeleton，但在 1.2 stub 协议中不需要）。
  • 如果方法哈希无效（即缺少方法）。
  • 如果在解组时创建远程对象的 stub 的远程引用对象失败。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
UnmarshalException(String s)
构造带指定详细消息的 UnmarshalException。
UnmarshalException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 UnmarshalException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnmarshalException

public UnmarshalException(String s)
构造带指定详细消息的 UnmarshalException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

UnmarshalException

public UnmarshalException(String s,
                          Exception ex)
构造带指定详细消息和嵌入异常的 UnmarshalException。

参数：
s - 详细消息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.rmi (Java 2 Platform SE 6)

 java.rmi
接口
Remote
类
MarshalledObject
Naming
RMISecurityManager
异常
AccessException
AlreadyBoundException
ConnectException
ConnectIOException
MarshalException
NoSuchObjectException
NotBoundException
RemoteException
RMISecurityException
ServerError
ServerException
ServerRuntimeException
StubNotFoundException
UnexpectedException
UnknownHostException
UnmarshalException


java.rmi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.rmi

提供 RMI 包。

请参见：
描述

接口摘要
Remote Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。

类摘要
MarshalledObject<T> | MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。
Naming | Naming 类提供在对象注册表中存储和获得远程对远程对象引用的方法。
RMISecurityManager | 由使用下载的代码的 RMI 应用程序使用的 SecurityManager 的子类。

异常摘要
AccessException | AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
AlreadyBoundException | 如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
ConnectException | 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
ConnectIOException | 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
MarshalException | 如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
NoSuchObjectException | 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
NotBoundException | 如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
RemoteException | RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
RMISecurityException | 已过时。 由 SecurityException 取代。
ServerError | 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
ServerException | 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
ServerRuntimeException | 已过时。 无替换版本
StubNotFoundException | 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
UnexpectedException | 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
UnknownHostException | 如果在创建到远程主机的连接以便进行远程方法调用时发生 java.net.UnknownHostException，则抛出 UnknownHostException。
UnmarshalException | 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

软件包 java.rmi 的描述

提供 RMI 包。RMI 指的是远程方法调用 (Remote Method Invocation)。它是一种机制，能够让在某个 Java 虚拟机上的对象调用另一个 Java 虚拟机中的对象上的方法。可以用此方法调用的任何对象必须实现该远程接口。调用这样一个对象时，其参数为 "marshalled" 并将其从本地虚拟机发送到远程虚拟机（该远程虚拟机的参数为 "unmarshalled"）上。该方法终止时，将编组来自远程机的结果并将结果发送到调用方的虚拟机。如果方法调用导致抛出异常，则该异常将指示给调用方。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.rmi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.rmi.MarshalledObject<T> (implements java.io.Serializable)
    • java.rmi.Naming
    • java.lang.SecurityManager
      • java.rmi.RMISecurityManager
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.rmi.AlreadyBoundException
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.AccessException
            • java.rmi.ConnectException
            • java.rmi.ConnectIOException
            • java.rmi.MarshalException
            • java.rmi.NoSuchObjectException
            • java.rmi.ServerError
            • java.rmi.ServerException
            • java.rmi.ServerRuntimeException
            • java.rmi.StubNotFoundException
            • java.rmi.UnexpectedException
            • java.rmi.UnknownHostException
            • java.rmi.UnmarshalException
        • java.rmi.NotBoundException
        • java.lang.RuntimeException
          • java.lang.SecurityException
            • java.rmi.RMISecurityException

接口分层结构

  • java.rmi.Remote
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.rmi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi
的使用

使用 java.rmi 的软件包
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

java.rmi 使用的 java.rmi 中的类
AlreadyBoundException
如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
NotBoundException
如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

java.rmi.activation 使用的 java.rmi 中的类
MarshalledObject
MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。
NoSuchObjectException
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

java.rmi.dgc 使用的 java.rmi 中的类
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

java.rmi.registry 使用的 java.rmi 中的类
AccessException
AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
AlreadyBoundException
如果试图将注册表中的对象绑定到已具有相关绑定的名称上，则抛出 AlreadyBoundException。
NotBoundException
如果试图在注册表中查找或解绑没有相关绑定的名称，则抛出 NotBoundException。
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。
UnknownHostException
如果在创建到远程主机的连接以便进行远程方法调用时发生 java.net.UnknownHostException，则抛出 UnknownHostException。

java.rmi.server 使用的 java.rmi 中的类
NoSuchObjectException
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

javax.activity 使用的 java.rmi 中的类
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

javax.management.remote.rmi 使用的 java.rmi 中的类
MarshalledObject
MarshalledObject 包含一个字节流，该流具有给定了其构造方法的对象的序列化表示形式。
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

javax.rmi 使用的 java.rmi 中的类
NoSuchObjectException
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

javax.rmi.CORBA 使用的 java.rmi 中的类
NoSuchObjectException
如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

javax.transaction 使用的 java.rmi 中的类
RemoteException
RemoteException 是许多与通信相关的异常的通用超类，这些异常可能会在执行远程方法调用期间发生。

org.omg.stub.java.rmi 使用的 java.rmi 中的类
Remote
Remote 接口用于标识其方法可以从非本地虚拟机上调用的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Activatable (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 Activatable

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteServer
            继承者  java.rmi.activation.Activatable
所有已实现的接口：
Serializable, Remote
public abstract class Activatable
extends RemoteServer

Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。

对于构造方法和静态 exportObject 方法，可以像 UnicastRemoteObject 中所描述的那样获得将被导出的远程对象的 stub。

试图显式序列化此类的实例将失败。

从以下版本开始：
1.2

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
protected | Activatable(ActivationID id, int port) 构造方法用于在指定端口上激活/导出对象。
protected | Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 构造方法用于在指定端口上激活/导出对象。
protected | Activatable(String location, MarshalledObject<?> data, boolean restart, int port) 构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
protected | Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
方法摘要
static Remote | exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
protected ActivationID | getID() 返回对象的激活标识符。
static boolean | inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
static Remote | register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
static boolean | unexportObject(Remote obj, boolean force) 从 RMI 运行库中移除远程对象 obj。
static void | unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
从类 java.rmi.server.RemoteServer 继承的方法
getClientHost, getLog, setLog
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Activatable

protected Activatable(String location,
                      MarshalledObject<?> data,
                      boolean restart,
                      int port)
               throws ActivationException,
                      RemoteException
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。

注：建议最好使用同时注册和输出可激活远程对象的 Activatable 构造方法，因为不 保证注册和输出远程对象操作是原子操作。相反，应用程序应该分开注册激活描述符和输出远程对象操作，这样才能正确地处理异常。

此方法使用该对象、指定位置、数据、重启模式和端口调用 exportObject 方法。getID() 的后续调用将返回从 exportObject 调用中返回的激活标识符。

参数：
location - 此对象的类的位置
data - 对象的初始化数据
port - 导出对象的端口（如果 port=0，则使用匿名端口）
restart - 如果该参数为 true，那么在一次意外崩溃之后，如果重启激活器或者重启对象激活组，则该对象也会被重启（激活）；如果参数为 false，则只能根据需要激活该对象。指定 restart 为 true，不强制对新注册的对象立即进行初始激活操作；初始激活是延后进行的。
抛出：
ActivationException - 如果对象注册失败。
RemoteException - 如果下列操作之一失败：a) 通过激活系统注册对象 b) 将对象导出到 RMI 运行库。
从以下版本开始：
1.2

Activatable

protected Activatable(String location,
                      MarshalledObject<?> data,
                      boolean restart,
                      int port,
                      RMIClientSocketFactory csf,
                      RMIServerSocketFactory ssf)
               throws ActivationException,
                      RemoteException
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

注：建议最好使用同时注册和输出可激活远程对象的 Activatable 构造方法，因为不 保证注册和输出远程对象操作是原子操作。相反，应用程序应该分开注册激活描述符和输出远程对象操作，这样才能正确地处理异常。

此方法使用该对象、指定位置、数据、重启模式、端口、客户端和服务器套接字工厂调用 exportObject 方法。getID() 的后续调用将返回从 exportObject 调用中返回的激活标识符。

参数：
location - 此对象的类的位置
data - 对象的初始化数据
restart - 如果该参数为 true，那么在一次意外崩溃之后，如果重启激活器或者重启对象激活组，则该对象也会被重启（激活）；如果该参数为 false，则只能根据需要激活该对象。指定 restart 为 true，不强制对新注册的对象立即进行初始激活操作；初始激活是延后进行的。
port - param port 导出对象的端口（如果 port=0，则使用匿名端口）
csf - 进行远程对象调用的客户端套接字工厂
ssf - 接收远程调用的服务器端套接字工厂
抛出：
ActivationException - 如果注册失败。
RemoteException - 如果下列操作之一失败：a) 通过激活系统注册对象 b) 将对象导出到 RMI 运行库。
从以下版本开始：
1.2

Activatable

protected Activatable(ActivationID id,
                      int port)
               throws RemoteException
构造方法用于在指定端口上激活/导出对象。一个“可激活的”远程对象必须具有带两个参数的构造方法：
  • 对象的激活标识符（ActivationID），以及
  • 对象的初始化数据（MarshalledObject）。

当此类的具体子类通过上述带两个参数的构造方法激活 时，它必须调用此构造方法。作为构造的副作用，远程对象被“导出”到 RMI 运行库中（在指定 port 上），并且可用于接受从客户端传入的调用。

参数：
id - 对象的激活标识符
port - 导出对象的端口的端口号
抛出：
RemoteException - 如果将对象导出到 RMI 运行库中失败
从以下版本开始：
1.2

Activatable

protected Activatable(ActivationID id,
                      int port,
                      RMIClientSocketFactory csf,
                      RMIServerSocketFactory ssf)
               throws RemoteException
构造方法用于在指定端口上激活/导出对象。一个“可激活的”远程对象必须具有带两个参数的构造方法：
  • 对象的激活标识符（ActivationID），以及
  • 对象的初始化数据（MarshalledObject）。

当此类的具体子类通过上述带两个参数的构造方法激活 时，它必须调用此构造方法。作为构造的副作用，远程对象被“导出”到 RMI 运行库中（在指定 port 上），并且可用于接受从客户端传入的调用。

参数：
id - 对象的激活标识符
port - 导出对象的端口的端口号
csf - 进行远程对象调用的客户端套接字工厂
ssf - 接收远程调用的服务器端套接字工厂
抛出：
RemoteException - 如果将对象导出到 RMI 运行库中失败
从以下版本开始：
1.2
方法详细信息

getID

protected ActivationID getID()
返回对象的激活标识符。此方法是受保护的，因此只有子类能获取对象的标识符。

返回：
对象的激活标识符
从以下版本开始：
1.2

register

public static Remote register(ActivationDesc desc)
                       throws UnknownGroupException,
                              ActivationException,
                              RemoteException
为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。

参数：
desc - 对象的描述符
返回：
可激活远程对象的 stub
抛出：
UnknownGroupException - 如果 desc 中的组 id 未使用激活系统注册
ActivationException - 如果激活系统未运行
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

inactive

public static boolean inactive(ActivationID id)
                        throws UnknownObjectException,
                               ActivationException,
                               RemoteException
通知系统具有相应激活 id 的对象目前没有处于活动状态的。如果对象当前处于活动状态的，则该对象从 RMI 运行库“取消导出”（仅在没有任何挂起或者进程内调用时），使其无法再接收传入的调用。此调用通知此 VM 的 ActivationGroup，告诉它对象处于不活动状态，并依次通知其 ActivationMonitor。如果成功完成此调用，则对激活器的后续激活请求将导致对象被重新激活。如果对象被认为是活动的，但是其自身已经取消导出，此操作仍能获得成功。

参数：
id - 对象的激活标识符
返回：
如果操作成功（如果已知对象目前处于活动状态并且已经取消导出，或者对象目前已被导出并且没有任何正在挂起/执行的调用，则此操作能够获得成功），则返回 true；否则，如果对象具有正在挂起/执行的调用，无法对其取消激活，则返回 false
抛出：
UnknownObjectException - 如果对象未知（可能已经处于不活动状态）
ActivationException - 如果组处于不活动状态
RemoteException - 如果调用通知监视器失败
从以下版本开始：
1.2

unregister

public static void unregister(ActivationID id)
                       throws UnknownObjectException,
                              ActivationException,
                              RemoteException
为与 id 关联的激活描述符撤消前面的注册。无法再通过该 id 激活对象。

参数：
id - 对象的激活标识符
抛出：
UnknownObjectException - 如果对象（id）未知
ActivationException - 如果激活系统未运行
RemoteException - 如果对激活系统的远程调用失败
从以下版本开始：
1.2

exportObject

public static ActivationID exportObject(Remote obj,
                                        String location,
                                        MarshalledObject<?> data,
                                        boolean restart,
                                        int port)
                                 throws ActivationException,
                                        RemoteException
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。

注：建议最好使用此方法（以及同时注册和输出可激活远程对象的 Activatable 构造方法），因为不 保证注册和输出远程对象操作是原子操作。相反，应用程序应该分开注册激活描述符和输出远程对象操作，这样才能正确地处理异常。

此方法使用指定对象、位置、数据、重启模式、端口、客户端和服务器套接字工厂（为 null）调用 exportObject 方法，然后返回得到的激活标识符。

参数：
obj - 将被导出的对象
location - 对象的代码基
data - 对象的引导数据
restart - 如果该参数为 true，那么在一次意外崩溃之后，如果重启激活器或者重启对象激活组，则该对象也会被重启（激活）；如果该参数为 false，则只能根据需要激活该对象。指定 restart 为 true，不强制对新注册的对象立即进行初始激活操作；初始激活是延后进行的。
port - 导出对象的端口的端口号（如果 port=0，则使用匿名端口）
返回：
通过激活系统注册描述符 desc 所获得的激活标识符
抛出：
ActivationException - 如果激活组处于不活动状态
RemoteException - 如果对象注册或者导出失败
从以下版本开始：
1.2

exportObject

public static ActivationID exportObject(Remote obj,
                                        String location,
                                        MarshalledObject<?> data,
                                        boolean restart,
                                        int port,
                                        RMIClientSocketFactory csf,
                                        RMIServerSocketFactory ssf)
                                 throws ActivationException,
                                        RemoteException
注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

注：建议最好使用此方法（以及同时注册和输出可激活远程对象的 Activatable 构造方法），因为不 保证注册和输出远程对象操作是原子操作。相反，应用程序应该分开注册激活描述符和输出远程对象操作，这样才能正确地处理异常。

此方法首先按以下步骤注册指定对象的激活描述符。它通过调用 ActivationGroup.getSystem 方法来获取激活系统。然后，此方法通过使用 ActivationDesc 调用激活系统的 registerObject 方法来获取 ActivationID，其中，ActivationDesc 是使用指定对象的类名称、指定位置、数据和重启模式构造的。如果在获取激活系统或注册激活描述符时发生异常，则将向调用者抛出该异常。

然后，此方法使用指定的远程对象、通过注册获取的激活标识符、指定的端口、指定的客户端和服务器套接字工厂调用 exportObject 方法输出对象。如果输出对象时发生异常，那么此方法将尝试使用激活标识符调用激活系统的 unregisterObject 方法来注销激活标识符（通过注册获得）。如果注销标识符时发生异常，则忽略该异常，并向调用者抛出输出对象时发生的原异常。

最后，此方法使用激活标识符和指定远程对象对此 VM 中的激活组调用 activeObject 方法，并向调用者返回激活标识符。

参数：
obj - 将被导出的对象
location - 对象的代码基
data - 对象的引导数据
restart - 如果该参数为 true，那么在一次意外崩溃之后，如果重启激活器或者重启对象激活组，则该对象也会被重启（激活）；如果该参数为 false，则只能根据需要激活该对象。指定 restart 为 true，不强制对新注册的对象立即进行初始激活操作；初始激活是延后进行的。
port - 导出对象的端口的端口号（如果 port=0，则使用匿名端口）
csf - 进行远程对象调用的客户端套接字工厂
ssf - 接收远程调用的服务器端套接字工厂
返回：
通过向激活系统注册描述符所获得的激活标识符
抛出：
ActivationException - 如果激活组处于不活动状态
RemoteException - 如果对象注册或者导出失败
从以下版本开始：
1.2

exportObject

public static Remote exportObject(Remote obj,
                                  ActivationID id,
                                  int port)
                           throws RemoteException
将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。如果 port 为零，则在匿名端口上导出对象。

在激活过程中，此 exportObject 方法应当由一个未扩展 Activatable 类的“可激活”对象显式调用。对于确实扩展了 Activatable 类的对象，无需直接调用此方法，因为该对象是在构造期间输出的。

参数：
obj - 远程对象实现
id - 对象的激活标识符
port - 导出对象的端口的端口号（如果 port=0，则使用匿名端口）
返回：
可激活远程对象的 stub
抛出：
RemoteException - 如果对象导出失败
从以下版本开始：
1.2

exportObject

public static Remote exportObject(Remote obj,
                                  ActivationID id,
                                  int port,
                                  RMIClientSocketFactory csf,
                                  RMIServerSocketFactory ssf)
                           throws RemoteException
将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。如果 port 为零，则在匿名端口上导出对象。

在激活过程中，此 exportObject 方法应当由一个未扩展 Activatable 类的“可激活”对象显式调用。对于确实扩展了 Activatable 类的对象，无需直接调用此方法，因为该对象是在构造期间输出的。

参数：
obj - 远程对象实现
id - 对象的激活标识符
port - 导出对象的端口的端口号（如果 port=0，则使用匿名端口）
csf - 进行远程对象调用的客户端套接字工厂
ssf - 接收远程调用的服务器端套接字工厂
返回：
可激活远程对象的 stub
抛出：
RemoteException - 如果对象导出失败
从以下版本开始：
1.2

unexportObject

public static boolean unexportObject(Remote obj,
                                     boolean force)
                              throws NoSuchObjectException
从 RMI 运行库中移除远程对象 obj。如果成功，该对象无法再接受传入的 RMI 调用。如果 force 参数为 true，那么即使存在挂起的远程对象调用，或者远程对象在进程中仍有调用，对象也会被强制取消导出。如果 force 为 false，则仅当不存在挂起或者进程内调用时，才取消导出对象。

参数：
obj - 要取消导出的远程对象
force - 如果该参数为 true，则即使存在挂起或者进程内调用，仍取消导出对象；如果该参数为 false，则仅当不存在挂起或者进程内调用时，才取消导出对象
返回：
如果操作成功，则返回 true；否则返回 false
抛出：
NoSuchObjectException - 如果远程对象目前没有被导出
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ActivateFailedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivateFailedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.activation.ActivateFailedException
所有已实现的接口：
Serializable
public class ActivateFailedException
extends RemoteException

在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ActivateFailedException(String s)
构造带指定详细消息的 ActivateFailedException。
ActivateFailedException(String s, Exception ex)
构造带指定详细消息和嵌套异常的 ActivateFailedException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ActivateFailedException

public ActivateFailedException(String s)
构造带指定详细消息的 ActivateFailedException。

参数：
s - 详细消息
从以下版本开始：
1.2

ActivateFailedException

public ActivateFailedException(String s,
                               Exception ex)
构造带指定详细消息和嵌套异常的 ActivateFailedException。

参数：
s - 详细消息
ex - 嵌套异常
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationDesc (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationDesc

java.lang.Object
    继承者  java.rmi.activation.ActivationDesc
所有已实现的接口：
Serializable
public final class ActivationDesc
extends Object
implements Serializable

激活描述符包含激活对象所必需的信息：

  • 对象的组标识符，
  • 对象的完全限定的类名，
  • 对象的代码基（类中的位置），一个代码基 URL 路径，
  • 对象的重启“模式”，以及
  • 一个可包含特定于对象的初始化数据的“编组”对象。

一个描述符通过激活系统注册，可用于重建/激活描述符所指定的对象。对象描述符中的 MarshalledObject 被传入作为远程对象构造方法的第二个参数，供对象在重新初始化/激活过程中使用。

从以下版本开始：
1.2
另请参见：
Activatable, 序列化表格

构造方法摘要
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
方法摘要
boolean | equals(Object obj) 比较两个激活描述符的内容相等性。
String | getClassName() 返回此描述符指定的对象的类名。
MarshalledObject<?> | getData() 为此描述符指定的对象返回包含初始化/激活数据的“编组对象”。
ActivationGroupID | getGroupID() 返回由此描述符指定的对象的组标识符。
String | getLocation() 返回此描述符指定的对象的代码基。
boolean | getRestartMode() 返回与此激活描述符关联的对象的“重启”模式。
int | hashCode() 为类似的 ActivationDesc 返回相同的哈希码
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActivationDesc

public ActivationDesc(String className,
                      String location,
                      MarshalledObject<?> data)
               throws ActivationException
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。如果使用这种形式的构造方法，groupID 默认为此 VM 的 ActivationGroup 的当前 id。在同一 VM 中，具有相同 ActivationGroupID 的所有对象都被激活。

注意，由此构造方法所创建的描述符指定的对象将仅仅按需被激活（默认情况下，重启模式为 false）。如果一个可激活的对象需要重启服务，使用带有 boolean 参数 restart 的 ActivationDesc 构造方法之一。

如果此 VM 当前没有任何激活组，则此构造方法将抛出 ActivationException。使用 ActivationGroup.createGroup 方法创建一个 ActivationGroup。

参数：
className - 对象的完全限定包的类名
location - 对象的代码基（类被加载处）
data - 以编组形式包含的对象初始化（激活）数据。
抛出：
ActivationException - 如果当前组不存在
从以下版本开始：
1.2

ActivationDesc

public ActivationDesc(String className,
                      String location,
                      MarshalledObject<?> data,
                      boolean restart)
               throws ActivationException
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。如果使用这种形式的构造方法，groupID 默认为此 VM 的 ActivationGroup 的当前 id。在同一 VM 中，具有相同 ActivationGroupID 的所有对象都被激活。

如果此 VM 当前没有任何激活组，则此构造方法将抛出 ActivationException。使用 ActivationGroup.createGroup 方法创建一个 ActivationGroup。

参数：
className - 对象的完全限定包的类名
location - 对象的代码基（类被加载处）
data - 以编组形式包含的对象初始化（激活）数据。
restart - 如果为 true，则在一次意外崩溃之后，如果激活器被重启或者对象的激活组被重启，则该对象也会被重启（激活）；如果为 false，对象只能按需激活。指定 restart 为 true，不强制对新注册的对象立即进行一次初始激活操作；初始激活是延后的。
抛出：
ActivationException - 如果当前组不存在
从以下版本开始：
1.2

ActivationDesc

public ActivationDesc(ActivationGroupID groupID,
                      String className,
                      String location,
                      MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。在同一 VM 中，具有相同 groupID 的所有对象都被激活。

注意，由此构造方法所创建的描述符指定的对象将仅仅按需激活（默认情况下，重启模式为 false）。如果可激活对象需要重启服务，使用带有 boolean 参数 restart 的 ActivationDesc 构造方法之一。

参数：
groupID - 组的标识符（从注册 ActivationSystem.registerGroup 方法处获得）。该组指示 VM 中的对象应当被激活。
className - 对象的完全限定包的类名
location - 对象的代码基（类被加载处）
data - 以编组形式包含的对象初始化（激活）数据。
抛出：
IllegalArgumentException - 如果 groupID 为 null
从以下版本开始：
1.2

ActivationDesc

public ActivationDesc(ActivationGroupID groupID,
                      String className,
                      String location,
                      MarshalledObject<?> data,
                      boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。在同一 VM 中，具有相同 groupID 的所有对象都被激活。

参数：
groupID - 组的标识符（从注册 ActivationSystem.registerGroup 方法中获得）。该组指示 VM 中的对象应当被激活。
className - 对象的完全限定包的类名
location - 对象的代码基（类被加载处）
data - 以编组形式包含的对象初始化（激活）数据。
restart - 如果为 true，则在一次意外崩溃之后，如果激活器被重启或者对象的激活组被重启，该对象将会被重启（激活）；如果为 false，对象只能按需激活。指定 restart 为 true，不强制对新创建的对象立即进行一次初始激活操作；初始激活是延后的。
抛出：
IllegalArgumentException - 如果 groupID 为 null
从以下版本开始：
1.2
方法详细信息

getGroupID

public ActivationGroupID getGroupID()
返回由此描述符指定的对象的组标识符。组提供一种将对象聚合到单个 Java 虚拟机中的方法。RMI 在同一虚拟机中创建/激活具有相同 groupID 的对象。

返回：
组标识符
从以下版本开始：
1.2

getClassName

public String getClassName()
返回此描述符指定的对象的类名。

返回：
类名
从以下版本开始：
1.2

getLocation

public String getLocation()
返回此描述符指定的对象的代码基。

返回：
代码基
从以下版本开始：
1.2

getData

public MarshalledObject<?> getData()
为此描述符指定的对象返回包含初始化/激活数据的“编组对象”。

返回：
特定于对象的“初始化”数据
从以下版本开始：
1.2

getRestartMode

public boolean getRestartMode()
返回与此激活描述符关联的对象的“重启”模式。

返回：
当守护程序出现或者对象的组在一次意外崩溃后被重启时，如果与此激活描述符关联的可激活对象也通过守护程序被重启，则返回 true；否则返回 false，这意味着该对象仅通过方法调用来按需激活。注意，如果重启模式为 true，则激活器不强制对新注册的对象立即进行一次初始激活操作；初始激活是延后的。
从以下版本开始：
1.2

equals

public boolean equals(Object obj)
比较两个激活描述符的内容相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的 Object
返回：
如果这些 Object 相等，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Hashtable

hashCode

public int hashCode()
为类似的 ActivationDesc 返回相同的哈希码

覆盖：
类 Object 中的 hashCode
返回：
一个整数
另请参见：
Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.rmi.activation.ActivationException
所有已实现的接口：
Serializable
直接已知子类：
UnknownGroupException, UnknownObjectException
public class ActivationException
extends Exception

激活接口所使用的一般异常。

从版本 1.4 开始，已对此异常作出改进，以符合通用异常链机制。可在构造时提供并通过公共 detail 字段访问的“详细的异常”现在称为 cause，该异常也能通过 Throwable.getCause() 方法以及前述的“遗留字段”访问。

在 ActivationException 的一个实例上调用方法 Throwable.initCause(Throwable) 总是抛出 IllegalStateException。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
 Throwable detail
激活异常的原因。
构造方法摘要
ActivationException()
构造一个 ActivationException。
ActivationException(String s)
构造带指定详细消息的 ActivationException。
ActivationException(String s, Throwable cause)
构造带指定详细消息和原因的 ActivationException。
方法摘要
Throwable | getCause() 返回此异常的原因。
String | getMessage() 返回包含来自此异常的原因（如果有）的消息的详细消息。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

detail

public Throwable detail
激活异常的原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

构造方法详细信息

ActivationException

public ActivationException()
构造一个 ActivationException。

ActivationException

public ActivationException(String s)
构造带指定详细消息的 ActivationException。

参数：
s - 详细消息

ActivationException

public ActivationException(String s,
                           Throwable cause)
构造带指定详细消息和原因的 ActivationException。此构造方法设置 detail 字段为给定的 Throwable。

参数：
s - 详细消息
cause - 原因
方法详细信息

getMessage

public String getMessage()
返回包含来自此异常的原因（如果有）的消息的详细消息。

覆盖：
类 Throwable 中的 getMessage
返回：
详细消息

getCause

public Throwable getCause()
返回此异常的原因。此方法返回 detail 字段的值。

覆盖：
类 Throwable 中的 getCause
返回：
原因，它可以为 null。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationGroup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationGroup

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteServer
            继承者  java.rmi.server.UnicastRemoteObject
                继承者  java.rmi.activation.ActivationGroup
所有已实现的接口：
Serializable, ActivationInstantiator, Remote
public abstract class ActivationGroup
extends UnicastRemoteObject
implements ActivationInstantiator

ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。

ActivationGroup 通过以下方式之一被初始 创建：

  • 一方面，为组中的第一个可激活对象创建一个不带显式 ActivationGroupID 的 ActivationDesc，或者
  • 通过 ActivationGroup.createGroup 方法
  • 另一方面，激活只有 ActivationGroupDesc 被注册的组中的第一个对象。

只有激活器能重建 一个 ActivationGroup。激活器根据需要为每个已注册的激活组生成一个单独的 VM（例如，作为一个子进程），并且将激活请求导向适当的组。它是如何生成 VM 的特定实现。一个激活组通过 ActivationGroup.createGroup 静态方法创建。createGroup 方法在创建组方面有两个需求：1) 组必须是 ActivationGroup 的一个具体子类，以及 2) 组必须具有带两个参数的构造方法：

  • 组的 ActivationGroupID ，以及
  • 组的初始化数据（在 java.rmi.MarshalledObject 中）

组被创建后，ActivationGroup 的默认实现将在创建 ActivationGroupDesc 时用请求的属性重写系统属性，并且将设置一个 java.rmi.RMISecurityManager 作为默认的系统安全管理器。如果应用程序需要对象在组中被激活时设置特定的属性，则应用程序应当创建一个特殊的包含这些属性的 Properties 对象，然后使用此 Properties 对象创建一个 ActivationGroupDesc，并且在创建任何 ActivationDesc 之前使用 ActivationGroup.createGroup（在默认的 ActivationGroupDesc 被创建之前）。如果应用程序需要使用安全管理器而不是 java.rmi.RMISecurityManager，则在 ActivativationGroupDescriptor 属性列表中可以将 java.security.manager 属性设置为想要安装的安全管理器的名称。

从以下版本开始：
1.2
另请参见：
ActivationInstantiator, ActivationGroupDesc, ActivationGroupID, 序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
protected ActivationGroup(ActivationGroupID groupID)
用给定的激活组标识符创建一个激活组。
方法摘要
protected void | activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
abstract void | activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static ActivationGroup | createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation) 为当前 VM 创建并设置激活组。
static ActivationGroupID | currentGroupID() 返回当前激活组的标识符。
static ActivationSystem | getSystem() 返回该 VM 的激活系统。
protected void | inactiveGroup() 如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。
boolean | inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
static void | setSystem(ActivationSystem system) 设置该 VM 的激活系统。
从类 java.rmi.server.UnicastRemoteObject 继承的方法
clone, exportObject, exportObject, exportObject, unexportObject
从类 java.rmi.server.RemoteServer 继承的方法
getClientHost, getLog, setLog
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.rmi.activation.ActivationInstantiator 继承的方法
newInstance

构造方法详细信息

ActivationGroup

protected ActivationGroup(ActivationGroupID groupID)
                   throws RemoteException
用给定的激活组标识符创建一个激活组。该组将作为一个 java.rmi.server.UnicastRemoteObject 被导出。

参数：
groupID - 组标识符
抛出：
RemoteException - 如要组不能被导出
从以下版本开始：
1.2
方法详细信息

inactiveObject

public boolean inactiveObject(ActivationID id)
                       throws ActivationException,
                              UnknownObjectException,
                              RemoteException
通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。当该对象不活动（对象认为它不再活动）时，远程对象实现必须调用 Activatable 的 inactive 方法。当对象不活动时，如果对象未调用 Activatable.inactive，则该对象永远不被垃圾回收，因为组保持对它创建的对象的强引用。

组的 inactiveObject 方法从 RMI 运行时取消导出远程对象，因此该对象无法再接收传入的 RMI 调用。如果对象没有任何挂起或者执行的调用，则该对象将仅仅被取消导出。ActivationGroup 的子类必须重写此方法并且取消导出该对象。

从 RMI 运行时移除该对象之后，组必须通知其 ActivationMonitor（通过 inactiveObject 方法），该远程对象当前不是活动的，因此远程对象将在后续激活请求上由激活器重新激活。

此方法简单地通知组的监视器，该对象是不活动的。由 ActivationGroup 的具体子类来实现取消导出该对象的附加需求。

参数：
id - 对象的激活标识符
返回：
如果该对象被成功地取消激活，则返回 true，否则返回 false。
抛出：
UnknownObjectException - 如果对象未知（可能已经是不活动的）
RemoteException - 如果调用通知监视器失败
ActivationException - 如果组是不活动的
从以下版本开始：
1.2

activeObject

public abstract void activeObject(ActivationID id,
                                  Remote obj)
                           throws ActivationException,
                                  UnknownObjectException,
                                  RemoteException
当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。组必须通知其 ActivationMonitor 对象是不活动的（通过监视器的 activeObject 方法），如果该组还没有这么做的话。

参数：
id - 对象的标识符
obj - 远程对象实现
抛出：
UnknownObjectException - 如果对象未注册
RemoteException - 如果调用通知监视器失败
ActivationException - 如果组是不活动的
从以下版本开始：
1.2

createGroup

public static ActivationGroup createGroup(ActivationGroupID id,
                                          ActivationGroupDesc desc,
                                          long incarnation)
                                   throws ActivationException
为当前 VM 创建并设置激活组。仅当当前尚未设置激活组时才设置激活组。当 Activator 初始化激活组的重建以执行传入的 activate 请求时，激活组使用 createGroup 方法来设置。在组可以通过此方法创建之前，该组必须首先通过 ActivationSystem 注册。

由 ActivationGroupDesc 指定的组类必须是 ActivationGroup 的具体子类，并且具有一个公共的带两个参数的构造方法：组的 ActivationGroupID 和包含组的初始化数据的 MarshalledObject（从 ActivationGroupDesc 获得）。

如果 ActivationGroupDesc 中指定的组类名为 null，则此方法将像组描述符包含默认激活组实现类的名称一样执行。

注意，如果应用程序创建其自己的自定义激活组，则必须为该组设置安全管理器。否则，该组中的对象不能被激活，默认设置为 java.rmi.RMISecurityManager。

如果在该组的 VM 中已经设置安全管理器，此方法首先调用该安全管理器的 checkSetFactory 方法。这可能会导致抛出 SecurityException。如果应用程序需要设置不同的安全管理器，则必须确保由组的 ActivationGroupDesc 所指定的策略文件授予该组必要的权限来设置一个新的安全管理器。（注：如果组下载并设置一个安全管理器，这将是必要的）。

在组被创建之后，通过调用 activeGroup 方法通知 ActivationSystem 该组是活动的，返回该组的 ActivationMonitor。应用程序无需独立调用 activeGroup，因为它通过此方法来维护。

一旦组被创建，对 currentGroupID 方法的后续调用将返回此组的标识符，直到组变为不活动的。

参数：
id - 激活组的标识符
desc - 激活组的描述符
incarnation - 组的代号（在组初始化创建时为零）
返回：
针对该 VM 的激活组
抛出：
ActivationException - 如果组已经存在或者如果在组创建过程中发生错误
SecurityException - 如果创建组的权限被拒绝。（注：安全管理器 checkSetFactory 方法的默认实现需要 RuntimePermission 的 "setFactory"）
从以下版本开始：
1.2
另请参见：
SecurityManager.checkSetFactory()

currentGroupID

public static ActivationGroupID currentGroupID()
返回当前激活组的标识符。如果此 VM 当前没有任何组是活动的，则返回 null。

返回：
激活组的标识符
从以下版本开始：
1.2

setSystem

public static void setSystem(ActivationSystem system)
                      throws ActivationException
设置该 VM 的激活系统。仅当当前没有组是活动的，才可以设置激活系统。如果激活系统未通过此调用来设置，则 getSystem 方法尝试通过在 Activator 注册表中查找名称 "java.rmi.activation.ActivationSystem" 来获取对 ActivationSystem 的引用。默认情况下，用于查找该激活系统的端口号由 ActivationSystem.SYSTEM_PORT 定义。此端口可通过设置属性 java.rmi.activation.port 而被重写。

如果存在安全管理器，则此方法首先调用安全管理器的 checkSetFactory 方法。这可能会导致抛出 SecurityException 异常。

参数：
system - 对 ActivationSystem 的远程引用
抛出：
ActivationException - 如果已经设置激活系统
SecurityException - 如果设置激活系统的权限被拒绝。（注：安全管理器 checkSetFactory 方法的默认实现需要 RuntimePermission 的 "setFactory"）
从以下版本开始：
1.2
另请参见：
getSystem(), SecurityManager.checkSetFactory()

getSystem

public static ActivationSystem getSystem()
                                  throws ActivationException
返回该 VM 的激活系统。激活系统可以通过 setSystem 方法设置。如果激活系统未通过 setSystem 方法设置，则 getSystem 方法尝试通过在 Activator 注册表中查找名称 "java.rmi.activation.ActivationSystem" 来获取对 ActivationSystem 的引用。默认情况下，用于查找该激活系统的端口号由 ActivationSystem.SYSTEM_PORT 定义。此端口可通过设置属性 java.rmi.activation.port 而被重写。

返回：
该 VM/组的激活系统
抛出：
ActivationException - 如果激活系统无法获得或者未绑定（意味着它没有运行）
从以下版本开始：
1.2
另请参见：
setSystem(java.rmi.activation.ActivationSystem)

activeObject

protected void activeObject(ActivationID id,
                            MarshalledObject<? extends Remote> mobj)
                     throws ActivationException,
                            UnknownObjectException,
                            RemoteException
如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。此调用简单地转发到组的 ActivationMonitor。

参数：
id - 对象的标识符
mobj - 包含远程对象的 stub 的编组对象
抛出：
UnknownObjectException - 如果对象未注册
RemoteException - 如果调用通知监视器失败
ActivationException - 如果发生激活错误
从以下版本开始：
1.2

inactiveGroup

protected void inactiveGroup()
                      throws UnknownGroupException,
                             RemoteException
如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。此调用简单地转发到组的 ActivationMonitor。同时，该 VM 的当前组被设置为 null。

抛出：
UnknownGroupException - 如果组未注册
RemoteException - 如果调用通知监视器失败
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationGroup_Stub (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationGroup_Stub

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteStub
            继承者  java.rmi.activation.ActivationGroup_Stub
所有已实现的接口：
Serializable, ActivationInstantiator, Remote
public final class ActivationGroup_Stub
extends RemoteStub
implements ActivationInstantiator, Remote

ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

从以下版本开始：
1.2
另请参见：
序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
ActivationGroup_Stub(RemoteRef ref)
为 ActivationGroup 类构造一个 stub。
方法摘要
 MarshalledObject newInstance(ActivationID id, ActivationDesc desc)
ActivationGroup.newInstance 的 stub 方法。
从类 java.rmi.server.RemoteStub 继承的方法
setRef
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ActivationGroup_Stub

public ActivationGroup_Stub(RemoteRef ref)
为 ActivationGroup 类构造一个 stub。它使用参数 ref 来调用超类的 RemoteStub(RemoteRef) 构造方法。

参数：
ref - 一个远程引用
方法详细信息

newInstance

public MarshalledObject newInstance(ActivationID id,
                                    ActivationDesc desc)
                             throws RemoteException,
                                    ActivationException
ActivationGroup.newInstance 的 stub 方法。使用 this 作为第一个参数，一个两元素的 Object[] 作为第二参数（id 作为第一个元素，desc 作为第二个元素），以及 -5274445189091581345L 作为第三个参数，在此实例的 RemoteObject.ref 字段上调用 invoke 方法，并且返回调用结果。如果该调用抛出 RuntimeException、RemoteException 或者 ActivationException，则该异常将被抛给调用者。如果该调用抛出任何其他 java.lang.Exception，则 java.rmi.UnexpectedException 连同最初的异常当作原因一起抛给调用者。

指定者：
接口 ActivationInstantiator 中的 newInstance
参数：
id - 一个激活标识符
desc - 一个激活描述符
返回：
调用的结果
抛出：
RemoteException - 如果调用导致 RemoteException
ActivationException - 如果调用导致 ActivationException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationGroupDesc (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationGroupDesc

java.lang.Object
    继承者  java.rmi.activation.ActivationGroupDesc
所有已实现的接口：
Serializable
public final class ActivationGroupDesc
extends Object
implements Serializable

激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。这种描述符包含：

  • 组的类名，
  • 组的代码基（组类中的位置），以及
  • 一个能包含特定于组的初始化数据的“编组”对象。

组类必须是 ActivationGroup 的一个具体子类。ActivationGroup 子类通过 ActivationGroup.createGroup 静态方法来创建/重建，此静态方法调用带有两个参数的特殊构造方法：

  • 组的 ActivationGroupID 方法，以及
  • 组的初始化数据（在 java.rmi.MarshalledObject 中）

从以下版本开始：
1.2
另请参见：
ActivationGroup, ActivationGroupID, 序列化表格

嵌套类摘要
static class ActivationGroupDesc.CommandEnvironment
ActivationGroup 实现的启动选项。
构造方法摘要
ActivationGroupDesc(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
使用组实现的系统默认值和代码基来构造一个组描述符。
ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。
方法摘要
boolean | equals(Object obj) 比较两个激活组描述符的内容相等性。
String | getClassName() 返回组的类名（可能为 null）。
ActivationGroupDesc.CommandEnvironment | getCommandEnvironment() 返回组的命令环境控制对象。
MarshalledObject<?> | getData() 返回组的初始化数据。
String | getLocation() 返回组的代码基。
Properties | getPropertyOverrides() 返回组的重写属性列表。
int | hashCode() 为类似的 ActivationGroupDesc 产生同样的数。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActivationGroupDesc

public ActivationGroupDesc(Properties overrides,
                           ActivationGroupDesc.CommandEnvironment cmd)
使用组实现的系统默认值和代码基来构造一个组描述符。属性指定 Java 环境重写（将重写组实现的 VM 中的系统属性）。命令环境能控制用于启动子 VM 的精确命令/选项，或者可以为 null，表示接受 rimid 的默认值。

此构造方法将创建一个带有 null 组类名的 ActivationGroupDesc，这表示了系统默认的 ActivationGroup 实现。

参数：
overrides - 当组被重建时要设置的属性集合。
cmd - 在另一个进程中执行 VM 的控制选项（或者为 null）。
从以下版本开始：
1.2

ActivationGroupDesc

public ActivationGroupDesc(String className,
                           String location,
                           MarshalledObject<?> data,
                           Properties overrides,
                           ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

参数：
className - 组的完全限定包的类名，或者为 null。null 组类名表示系统默认的 ActivationGroup 实现。
location - 要加载组的类的位置
data - 以编组形式包含的组的初始化数据（例如，可以包含属性）
overrides - 将重写子进程环境中默认设置的属性映射表（将被转换成 -D 选项），或者为 null。
cmd - 在另一个进程中执行 VM 的控制选项（或者为 null）。
从以下版本开始：
1.2
方法详细信息

getClassName

public String getClassName()
返回组的类名（可能为 null）。null 组类名指示系统默认的 ActivationGroup 实现。

返回：
组的类名
从以下版本开始：
1.2

getLocation

public String getLocation()
返回组的代码基。

返回：
组的代码基
从以下版本开始：
1.2

getData

public MarshalledObject<?> getData()
返回组的初始化数据。

返回：
组的初始化数据
从以下版本开始：
1.2

getPropertyOverrides

public Properties getPropertyOverrides()
返回组的重写属性列表。

返回：
重写属性列表，或者为 null
从以下版本开始：
1.2

getCommandEnvironment

public ActivationGroupDesc.CommandEnvironment getCommandEnvironment()
返回组的命令环境控制对象。

返回：
命令环境对象，或者为 null
从以下版本开始：
1.2

equals

public boolean equals(Object obj)
比较两个激活组描述符的内容相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的 Object
返回：
如果这些 Object 相等，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Hashtable

hashCode

public int hashCode()
为类似的 ActivationGroupDesc 产生同样的数。

覆盖：
类 Object 中的 hashCode
返回：
一个整数
另请参见：
Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationGroupDesc.CommandEnvironment (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationGroupDesc.CommandEnvironment

java.lang.Object
    继承者  java.rmi.activation.ActivationGroupDesc.CommandEnvironment
所有已实现的接口：
Serializable
正在封闭类：
ActivationGroupDesc
public static class ActivationGroupDesc.CommandEnvironment
extends Object
implements Serializable

ActivationGroup 实现的启动选项。此类允许为 ActivationGroups 重写默认的系统属性，并允许指定根据实现定义的选项。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
ActivationGroupDesc.CommandEnvironment(String cmdpath, String[] argv)
用所有必要的信息创建一个 CommandEnvironment。
方法摘要
boolean | equals(Object obj) 比较两个命令环境的内容相等性。
String[] | getCommandOptions() 取得配置的 java 命令选项。
String | getCommandPath() 取得配置的限定路径的 java 命令名称。
int | hashCode() 返回类似 CommandEnvironment 的相同值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActivationGroupDesc.CommandEnvironment

public ActivationGroupDesc.CommandEnvironment(String cmdpath,
                                              String[] argv)
用所有必要的信息创建一个 CommandEnvironment。

参数：
cmdpath - 包括完整路径的 java 可执行程序的名称，或者该参数为 null，这意味着“使用 rmid 的默认值”。该指定程序必须 能接受多个 -Dpropname=value 选项（像 "java" 工具一样注释）。
argv - 将用来创建 ActivationGroup 的额外选项。Null 具有与空列表同样的效果。
从以下版本开始：
1.2
方法详细信息

getCommandPath

public String getCommandPath()
取得配置的限定路径的 java 命令名称。

返回：
配置名称，如果配置为接受默认值，则返回 null
从以下版本开始：
1.2

getCommandOptions

public String[] getCommandOptions()
取得配置的 java 命令选项。

返回：
将通过 rmid 传给新的子命令的命令选项数组。注意，rmid 可能在这些选项之前或之后或者在这两处同时添加其他选项。从不返回 null。
从以下版本开始：
1.2

equals

public boolean equals(Object obj)
比较两个命令环境的内容相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 将与之进行比较的 Object
返回：
如果这些 Object 相等，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Hashtable

hashCode

public int hashCode()
返回类似 CommandEnvironment 的相同值。

覆盖：
类 Object 中的 hashCode
返回：
一个整数
另请参见：
Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationGroupID (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationGroupID

java.lang.Object
    继承者  java.rmi.activation.ActivationGroupID
所有已实现的接口：
Serializable
public class ActivationGroupID
extends Object
implements Serializable

针对一个注册激活组的标识符，它完成几个目标：

  • 在激活系统中唯一地标识该组，以及
  • 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。

ActivationGroupID 由对 ActivationSystem.registerGroup 的调用所返回，并用于标识在该激活系统中的组。当一个激活组被创建/重建时，此组 id 作为激活组的特殊构造方法的参数传入。

从以下版本开始：
1.2
另请参见：
ActivationGroup, ActivationGroupDesc, 序列化表格

构造方法摘要
ActivationGroupID(ActivationSystem system)
构造一个唯一的组 id。
方法摘要
boolean | equals(Object obj) 比较两个组标识符的内容相等性。
ActivationSystem | getSystem() 返回组的激活系统。
int | hashCode() 返回用于组标识符的哈希码。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActivationGroupID

public ActivationGroupID(ActivationSystem system)
构造一个唯一的组 id。

参数：
system - 组的激活系统
从以下版本开始：
1.2
方法详细信息

getSystem

public ActivationSystem getSystem()
返回组的激活系统。

返回：
组的激活系统
从以下版本开始：
1.2

hashCode

public int hashCode()
返回用于组标识符的哈希码。指向同一远程组的两个组标识符将具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
从以下版本开始：
1.2
另请参见：
Hashtable

equals

public boolean equals(Object obj)
比较两个组标识符的内容相等性。如果如下两个条件都为 true，则返回 true：1) 唯一标识符相等（从内容上）和 2) 两个组标识符指定的激活系统引用同一远程对象。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的 Object
返回：
如果这些 Object 相等，则返回 true；否则返回 false。
从以下版本开始：
1.2
另请参见：
Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationID (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 ActivationID

java.lang.Object
    继承者  java.rmi.activation.ActivationID
所有已实现的接口：
Serializable
public class ActivationID
extends Object
implements Serializable

激活利用特定的标识符来表示远程对象，对象能随着时间被激活。一个激活标识符（类 ActivationID 的一个实例）包含了激活一个对象所需的几部分信息：

  • 到对象激活器的远程引用（一个 RemoteRef 实例），以及
  • 对象的惟一标识符（一个 UID 实例）。

对象的激活标识符能通过利用激活系统注册一个对象获得。注册可通过以下几种方式完成：

  • 通过 Activatable.register 方法
  • 通过第一个 Activatable 构造方法（带有三个参数，并且注册和导出该对象)，以及
  • 通过第一个 Activatable.exportObject 方法，它带有激活描述符、对象以及端口作为参数；此方法同时注册和导出对象。

从以下版本开始：
1.2
另请参见：
Activatable, 序列化表格

构造方法摘要
ActivationID(Activator activator)
ActivationID 的构造方法带有单个参数 activator，这指定了一个对激活器（负责激活与此标识符相关联的对象）的远程引用。
方法摘要
Remote | activate(boolean force) 激活此 id 的对象。
boolean | equals(Object obj) 比较两个激活 id 的内容相等性。
int | hashCode() 返回激活 id 的哈希码。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActivationID

public ActivationID(Activator activator)
ActivationID 的构造方法带有单个参数 activator，这指定了一个对激活器（负责激活与此标识符相关联的对象）的远程引用。ActivationID 的实例是全局惟一的。

参数：
activator - 对负责激活对象的激活器的引用
从以下版本开始：
1.2
方法详细信息

activate

public Remote activate(boolean force)
                throws ActivationException,
                       UnknownObjectException,
                       RemoteException
激活此 id 的对象。

参数：
force - 如果为 true，则当激活对象时强制激活器与组联络（而不是返回一个缓存引用）；如果为 false，则返回一个缓存值也可以接受
返回：
对激活远程对象的引用
抛出：
ActivationException - 如果激活失败
UnknownObjectException - 如果对象未知
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

hashCode

public int hashCode()
返回激活 id 的哈希码。引用同一个远程对象的两个标识符将具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
从以下版本开始：
1.2
另请参见：
Hashtable

equals

public boolean equals(Object obj)
比较两个激活 id 的内容相等性。如果以下两个条件都为 true，则返回 true：1) 惟一标识符相等（从内容上）和 2) 每个标识符指定的激活器都引用相同的远程对象。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的 Object
返回：
如果这些 Object 相等，则返回 true；否则返回 false
从以下版本开始：
1.2
另请参见：
Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationInstantiator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
接口 ActivationInstantiator

所有超级接口：
Remote
所有已知实现类：
ActivationGroup, ActivationGroup_Stub
public interface ActivationInstantiator
extends Remote

ActivationInstantiator 负责创建“可激活”对象的实例。一个 ActivationGroup 的具体子类实现了 newInstance 方法来处理在该组中创建对象。

从以下版本开始：
1.2
另请参见：
ActivationGroup

方法摘要
 MarshalledObject<? extends Remote> newInstance(ActivationID id, ActivationDesc desc)
激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。

方法详细信息

newInstance

MarshalledObject<? extends Remote> newInstance(ActivationID id,
                                               ActivationDesc desc)
                                               throws ActivationException,
                                                      RemoteException
激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。初始化程序负责：
  • 使用描述符的 getClassName 方法来确定该对象的类。
  • 从描述符获得的代码基（使用 getLocation 方法）加载该类。
  • 通过调用对象类的特定的“激活”构造方法来创建该类的实例，构造方法带有两个参数：对象的 ActivationID 以及包含特定于对象的初始化数据的 MarshalledObject，并且
  • 返回一个包含其所创建的远程对象的 stub 的 MarshalledObject。

参数：
id - 对象的激活标识符
desc - 对象描述符
返回：
包含了远程对象 stub 的序列化表示的编组对象
抛出：
ActivationException - 如果对象激活失败
RemoteException - 如果远程调用失败
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationMonitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
接口 ActivationMonitor

所有超级接口：
Remote
public interface ActivationMonitor
extends Remote

一个 ActivationMonitor 特定于一个 ActivationGroup，当一个组通过对 ActivationSystem.activeGroup 的调用（这是内部完成的）被报告为活动时，获得一个 ActivationMonitor。在以下任一情况下，一个激活组负责通知其 ActivationMonitor：它的对象成为活动的或者不活动的，或者整个组成为不活动的。

从以下版本开始：
1.2
另请参见：
Activator, ActivationSystem, ActivationGroup

方法摘要
void | activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
void | inactiveGroup(ActivationGroupID id, long incarnation) 通知该组现在是不活动的。
void | inactiveObject(ActivationID id) 当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。

方法详细信息

inactiveObject

void inactiveObject(ActivationID id)
                    throws UnknownObjectException,
                           RemoteException
当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。通过调用激活组的 inactiveObject 方法，激活组发现其所参与激活的某个对象在其 VM 中不再为活动的。

inactiveObject 调用通知 ActivationMonitor，它为具有激活标识符 id 的对象所保持的远程对象引用不再有效。监视器把与 id 关联的引用当作一个旧引用。因为该引用被认为是陈旧的，对相同激活标识符的后续 activate 调用将导致重新激活该远程对象。

参数：
id - 对象的激活标识符
抛出：
UnknownObjectException - 如果对象未知
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

activeObject

void activeObject(ActivationID id,
                  MarshalledObject<? extends Remote> obj)
                  throws UnknownObjectException,
                         RemoteException
通知某个对象现在是活动的。如果 ActivationGroup 组中的对象通过其他方式而不是被直接激活（即对象被注册并且“激活”其自身），则 ActivationGroup 将通知其监视器。

参数：
id - 激活对象的 id
obj - 编组形式的对象 stub
抛出：
UnknownObjectException - 如果对象未知
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

inactiveGroup

void inactiveGroup(ActivationGroupID id,
                   long incarnation)
                   throws UnknownGroupException,
                          RemoteException
通知该组现在是不活动的。根据激活该组中对象的后续请求，重新创建该组。当组中所有的对象都报告它们是不活动的时候，组也成为不活动的。

参数：
id - 组 id
incarnation - 组的代号
抛出：
UnknownGroupException - 如果组未知
RemoteException - 如果远程调用失败
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActivationSystem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
接口 ActivationSystem

所有超级接口：
Remote
public interface ActivationSystem
extends Remote

ActivationSystem 为注册组和在那些组中要被激活的“可激活”对象提供一种方式。ActivationSystem 与 Activator 紧密协作，通过 ActivationSystem 和 ActivationMonitor 来激活注册的对象，ActivationMonitor 获取有关活动的和不活动的对象以及不活动组的信息。

从以下版本开始：
1.2
另请参见：
Activator, ActivationMonitor

字段摘要
static int SYSTEM_PORT
查找激活系统的端口。
方法摘要
ActivationMonitor | activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
ActivationDesc | getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
ActivationGroupDesc | getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
ActivationGroupID | registerGroup(ActivationGroupDesc desc) 注册激活组。
ActivationID | registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
ActivationGroupDesc | setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
void | shutdown() 关闭此激活系统。
void | unregisterGroup(ActivationGroupID id) 移除激活组。
void | unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

字段详细信息

SYSTEM_PORT

static final int SYSTEM_PORT
查找激活系统的端口。

另请参见：
常量字段值
方法详细信息

registerObject

ActivationID registerObject(ActivationDesc desc)
                            throws ActivationException,
                                   UnknownGroupException,
                                   RemoteException
registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。ActivationSystem 为描述符 desc 指定的对象创建一个 ActivationID（激活标识符），并且在稳定的存储器中记录激活描述符及其关联的标识符，以便将来使用。当 Activator 接收一个针对指定标识符的 activate 请求时，激活器为指定的标识符查找激活描述符（前面已注册），并且使用该信息来激活对象。

参数：
desc - 对象的激活描述符
返回：
能用于激活对象的激活 id
抛出：
ActivationException - 如果注册失败（如，数据库更新失败等）。
UnknownGroupException - 如果在 desc 中引用的组未通过此系统注册
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

unregisterObject

void unregisterObject(ActivationID id)
                      throws ActivationException,
                             UnknownObjectException,
                             RemoteException
移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

参数：
id - 对象的激活 id（来自前面的注册）
抛出：
ActivationException - 如果取消注册失败（如，数据库更新失败等）。
UnknownObjectException - 如果对象未知（未注册）
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

registerGroup

ActivationGroupID registerGroup(ActivationGroupDesc desc)
                                throws ActivationException,
                                       RemoteException
注册激活组。一个激活组必须在对象能在该组中注册之前通过 ActivationSystem 来注册。

参数：
desc - 组描述符
返回：
该组的标识符
抛出：
ActivationException - 如果组注册失败
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

activeGroup

ActivationMonitor activeGroup(ActivationGroupID id,
                              ActivationInstantiator group,
                              long incarnation)
                              throws UnknownGroupException,
                                     ActivationException,
                                     RemoteException
通过回调来通知激活系统该组现在是活动的。此调用由 ActivationGroup.createGroup 方法在内部进行，以通知 ActivationSystem 该组现在是活动的。

参数：
id - 激活组的标识符
group - 组的初始化程序
incarnation - 组的代号
返回：
激活组的监视器
抛出：
UnknownGroupException - 如果组未注册
ActivationException - 如果该指定 id 的组已经是活动的，并且该组不等于指定 group，或者该组与指定组 group 具有不同的 incarnation
RemoteException - 如果远程调用失败
从以下版本开始：
1.2

unregisterGroup

void unregisterGroup(ActivationGroupID id)
                     throws ActivationException,
                            UnknownGroupException,
                            RemoteException
移除激活组。一个激活组进行此回调，以通知激活器该组应当被移除（销毁）。如果此调用成功完成，则对象无法再在该组中注册或激活。该组及其相关对象的所有信息都将从系统中移除。

参数：
id - 激活组的标识符
抛出：
ActivationException - 如果取消注册失败（如，数据库更新失败等）。
UnknownGroupException - 如果组未注册
RemoteException - 如果远程过程调用失败
从以下版本开始：
1.2

shutdown

void shutdown()
              throws RemoteException
关闭此激活系统。销毁由此激活守护程序生成的所有组，并退出激活守护程序。

抛出：
RemoteException - 如果联络/关闭激活守护程序失败
从以下版本开始：
1.2

setActivationDesc

ActivationDesc setActivationDesc(ActivationID id,
                                 ActivationDesc desc)
                                 throws ActivationException,
                                        UnknownObjectException,
                                        UnknownGroupException,
                                        RemoteException
为具有激活标识符 id 的对象设置激活描述符 desc。此更改将在该对象的后续激活中生效。

参数：
id - 可激活对象的激活标识符
desc - 可激活对象的激活描述符
返回：
激活描述符的前一个值
抛出：
UnknownGroupException - 与 desc 关联的组不是一个注册组
UnknownObjectException - 激活 id 未被注册
ActivationException - 一般失败（如，不能更新日志）
RemoteException - 如果远程调用失败
从以下版本开始：
1.2
另请参见：
getActivationDesc(java.rmi.activation.ActivationID)

setActivationGroupDesc

ActivationGroupDesc setActivationGroupDesc(ActivationGroupID id,
                                           ActivationGroupDesc desc)
                                           throws ActivationException,
                                                  UnknownGroupException,
                                                  RemoteException
为具有激活组标识符 id 的对象设置激活组描述符 desc。此更改将在该组的后续激活中生效。

参数：
id - 激活组的激活组标识符
desc - 激活组的激活组描述符
返回：
激活组描述符的前一个值
抛出：
UnknownGroupException - 与 id 关联的组不是一个注册组
ActivationException - 一般失败（如，不能更新日志）
RemoteException - 如果远程调用失败
从以下版本开始：
1.2
另请参见：
getActivationGroupDesc(java.rmi.activation.ActivationGroupID)

getActivationDesc

ActivationDesc getActivationDesc(ActivationID id)
                                 throws ActivationException,
                                        UnknownObjectException,
                                        RemoteException
为具有该激活标识符 id 的对象返回激活描述符。

参数：
id - 可激活对象的激活标识符
返回：
激活描述符
抛出：
UnknownObjectException - 如果 id 未被注册
ActivationException - 一般失败
RemoteException - 如果远程调用失败
从以下版本开始：
1.2
另请参见：
setActivationDesc(java.rmi.activation.ActivationID, java.rmi.activation.ActivationDesc)

getActivationGroupDesc

ActivationGroupDesc getActivationGroupDesc(ActivationGroupID id)
                                           throws ActivationException,
                                                  UnknownGroupException,
                                                  RemoteException
为具有该激活组标识符 id 的组返回激活组描述符。

参数：
id - 该组的激活组标识符
返回：
激活组描述符
抛出：
UnknownGroupException - 如果 id 未被注册
ActivationException - 一般失败
RemoteException - 如果远程调用失败
从以下版本开始：
1.2
另请参见：
setActivationGroupDesc(java.rmi.activation.ActivationGroupID, java.rmi.activation.ActivationGroupDesc)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Activator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
接口 Activator

所有超级接口：
Remote
public interface Activator
extends Remote

Activator 方便了远程对象激活。“失效的”远程引用调用激活器 (activator) 的 activate 方法来获得到“可激活的”远程对象的“活”引用。接收到激活的请求后，激活器为激活标识符 id 查找激活描述符，确定应当激活的对象所在的组通过组的 ActivationInstantiator 来初始化对象重创建（通过调用 newInstance 方法）。激活器在必要时才初始化激活组的执行。例如，如果针对某个特定组标识符的激活组尚未执行，则激活器为该组初始化 VM 的执行。

Activator 与 ActivationSystem 和 ActivationMonitor 紧密协作，ActivationSystem 提供了一种方式来注册那些组中的组和对象，而 ActivationMonitor 接收有关活动和不活动对象以及不活动组的信息。

激活器负责监视和检测，当激活组失败时，它可以移除那些组中的组和活动对象的旧远程引用。

从以下版本开始：
1.2
另请参见：
ActivationInstantiator, ActivationGroupDesc, ActivationGroupID

方法摘要
 MarshalledObject<? extends Remote> activate(ActivationID id, boolean force)
激活与激活标识符 id 关联的对象。

方法详细信息

activate

MarshalledObject<? extends Remote> activate(ActivationID id,
                                            boolean force)
                                            throws ActivationException,
                                                   UnknownObjectException,
                                                   RemoteException
激活与激活标识符 id 关联的对象。如果激活器知道对象已经是活动的，并且 force 为 false，则立即向调用方返回具有一个“活”引用的 stub；否则，如果激活器不知道对应的远程对象是否为活动的，则激活器使用激活描述符信息（前面已注册）来确定应当被激活的对象所在的组 (VM)。如果与对象组描述符相对应的 ActivationInstantiator 已经存在，则激活器调用激活组的 newInstance 方法来传递对象的 id 和描述符。

如果针对该对象的组描述符的激活组尚未存在，则激活器启动一次 ActivationInstantiator 执行（例如，通过生成一个子进程）。当激活器接收到激活组的指定该激活组引用的回调（通过 ActivationSystem 的 activeGroup 方法）时，然后激活器可以调用该激活初始化程序的 newInstance 方法来转发每一个挂起的激活请求给激活组，并且向调用方返回结果（一个编组的远程对象引用，一个 stub）。

注意，激活器接收一个“编组”的对象，而不是一个远程对象，以便激活器无需为该对象加载代码或者参与针对该对象的分布式垃圾收集。如果激活器保持对该远程对象的一个强引用，则在正常的分布式垃圾收集机制下，激活器可能阻止对象被垃圾回收。

参数：
id - 正被激活的对象的激活标识符
force - 如果为 true，激活器联络该组来获得该远程对象的引用；如果为 false，返回允许的缓存值。
返回：
以一种编组形式返回远程对象（一个 stub）
抛出：
ActivationException - 如果对象激活失败
UnknownObjectException - 如果对象未知（未注册）
RemoteException - 如果远程调用失败
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownGroupException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 UnknownGroupException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.rmi.activation.ActivationException
                继承者  java.rmi.activation.UnknownGroupException
所有已实现的接口：
Serializable
public class UnknownGroupException
extends ActivationException

当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。如果 ActivationDesc 中的 ActivationGroupID 引用了一个未使用 ActivationSystem 注册的组，也会抛出一个 UnknownGroupException。

从以下版本开始：
1.2
另请参见：
Activatable, ActivationGroup, ActivationGroupID, ActivationMonitor, ActivationSystem, 序列化表格

字段摘要
从类 java.rmi.activation.ActivationException 继承的字段
detail
构造方法摘要
UnknownGroupException(String s)
构造带指定详细消息的 UnknownGroupException。
方法摘要
从类 java.rmi.activation.ActivationException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownGroupException

public UnknownGroupException(String s)
构造带指定详细消息的 UnknownGroupException。

参数：
s - 详细消息
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownObjectException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.activation
类 UnknownObjectException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.rmi.activation.ActivationException
                继承者  java.rmi.activation.UnknownObjectException
所有已实现的接口：
Serializable
public class UnknownObjectException
extends ActivationException

当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。如果 ActivationID 当前对 ActivationSystem 是未知的，则 ActivationID 无效。ActivationID 通过 ActivationSystem.registerObject 方法获得。ActivationID 也能在 Activatable.register 的调用期间获得。

从以下版本开始：
1.2
另请参见：
Activatable, ActivationGroup, ActivationID, ActivationMonitor, ActivationSystem, Activator, 序列化表格

字段摘要
从类 java.rmi.activation.ActivationException 继承的字段
detail
构造方法摘要
UnknownObjectException(String s)
构造带指定详细消息的 UnknownObjectException。
方法摘要
从类 java.rmi.activation.ActivationException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownObjectException

public UnknownObjectException(String s)
构造带指定详细消息的 UnknownObjectException。

参数：
s - 详细消息
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.rmi.activation (Java 2 Platform SE 6)

 java.rmi.activation
接口
ActivationInstantiator
ActivationMonitor
ActivationSystem
Activator
类
Activatable
ActivationDesc
ActivationGroup
ActivationGroup_Stub
ActivationGroupDesc
ActivationGroupDesc.CommandEnvironment
ActivationGroupID
ActivationID
异常
ActivateFailedException
ActivationException
UnknownGroupException
UnknownObjectException


java.rmi.activation (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.rmi.activation

为 RMI 对象激活提供支持。

请参见：
描述

接口摘要
ActivationInstantiator | ActivationInstantiator 负责创建“可激活”对象的实例。
ActivationMonitor | 一个 ActivationMonitor 特定于一个 ActivationGroup，当一个组通过对 ActivationSystem.activeGroup 的调用（这是内部完成的）被报告为活动时，获得一个 ActivationMonitor。
ActivationSystem | ActivationSystem 为注册组和在那些组中要被激活的“可激活”对象提供一种方式。
Activator | Activator 方便了远程对象激活。

类摘要
Activatable | Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
ActivationDesc | 激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。
ActivationGroup | ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
ActivationGroup_Stub | ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。
ActivationGroupDesc | 激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。
ActivationGroupDesc.CommandEnvironment | ActivationGroup 实现的启动选项。
ActivationGroupID | 针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。
ActivationID | 激活利用特定的标识符来表示远程对象，对象能随着时间被激活。

异常摘要
ActivateFailedException | 在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。
ActivationException | 激活接口所使用的一般异常。
UnknownGroupException | 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
UnknownObjectException | 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

软件包 java.rmi.activation 的描述

为 RMI 对象激活提供支持。利用 RMI 激活机制，能使一个远程对象的引用是“持久的”，并且可激活为一个“活动的”对象。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.rmi.activation 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.activation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.rmi.activation.ActivationDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupDesc.CommandEnvironment (implements java.io.Serializable)
    • java.rmi.activation.ActivationGroupID (implements java.io.Serializable)
    • java.rmi.activation.ActivationID (implements java.io.Serializable)
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteServer
        • java.rmi.activation.Activatable
        • java.rmi.server.UnicastRemoteObject
          • java.rmi.activation.ActivationGroup (implements java.rmi.activation.ActivationInstantiator)
      • java.rmi.server.RemoteStub
        • java.rmi.activation.ActivationGroup_Stub (implements java.rmi.activation.ActivationInstantiator, java.rmi.Remote)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.rmi.activation.ActivationException
          • java.rmi.activation.UnknownGroupException
          • java.rmi.activation.UnknownObjectException
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.activation.ActivateFailedException

接口分层结构

  • java.rmi.Remote
    • java.rmi.activation.ActivationInstantiator
    • java.rmi.activation.ActivationMonitor
    • java.rmi.activation.ActivationSystem
    • java.rmi.activation.Activator
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.rmi.activation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.activation
的使用

使用 java.rmi.activation 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 使用的 java.rmi.activation 中的类
ActivationDesc
激活描述符包含激活对象所必需的信息： 对象的组标识符， 对象的完全限定的类名， 对象的代码基（类中的位置），一个代码基 URL 路径， 对象的重启“模式”，以及 一个可包含特定于对象的初始化数据的“编组”对象。
ActivationException
激活接口所使用的一般异常。
ActivationGroup
ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
ActivationGroupDesc
激活组描述符包含了创建/重建在其中激活对象的一个激活组所必需的信息。
ActivationGroupDesc.CommandEnvironment
ActivationGroup 实现的启动选项。
ActivationGroupID
针对一个注册激活组的标识符，它完成几个目标： 在激活系统中唯一地标识该组，以及 包含指向该组的激活系统的引用，以便该组在必要时能够联络上其激活系统。
ActivationID
激活利用特定的标识符来表示远程对象，对象能随着时间被激活。
ActivationInstantiator
ActivationInstantiator 负责创建“可激活”对象的实例。
ActivationMonitor
一个 ActivationMonitor 特定于一个 ActivationGroup，当一个组通过对 ActivationSystem.activeGroup 的调用（这是内部完成的）被报告为活动时，获得一个 ActivationMonitor。
ActivationSystem
ActivationSystem 为注册组和在那些组中要被激活的“可激活”对象提供一种方式。
Activator
Activator 方便了远程对象激活。
UnknownGroupException
当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
UnknownObjectException
当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.Activatable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.Activatable
的使用

没有 java.rmi.activation.Activatable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivateFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivateFailedException
的使用

没有 java.rmi.activation.ActivateFailedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationDesc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationDesc
的使用

使用 ActivationDesc 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationDesc 的使用

返回 ActivationDesc 的 java.rmi.activation 中的方法
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。

参数类型为 ActivationDesc 的 java.rmi.activation 中的方法
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationException
的使用

使用 ActivationException 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationException 的使用

java.rmi.activation 中 ActivationException 的子类
class | UnknownGroupException 当 java.rmi.activation 包中类和接口的方法的 ActivationGroupID 参数被确定为无效时（即不为 ActivationSystem 所知），则这些方法将抛出一个 UnknownGroupException。
class | UnknownObjectException 当 java.rmi.activation 包中类和接口的方法的 ActivationID 参数被确定为无效时，这些方法将抛出一个 UnknownObjectException。

抛出 ActivationException 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static ActivationGroup | ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation) 为当前 VM 创建并设置激活组。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
static ActivationSystem | ActivationGroup.getSystem() 返回该 VM 的激活系统。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
static void | ActivationGroup.setSystem(ActivationSystem system) 设置该 VM 的激活系统。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

抛出 ActivationException 的 java.rmi.activation 中的构造方法
Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc(String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationGroup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroup
的使用

使用 ActivationGroup 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroup 的使用

返回 ActivationGroup 的 java.rmi.activation 中的方法
static ActivationGroup ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation)
为当前 VM 创建并设置激活组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationGroupDesc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroupDesc
的使用

使用 ActivationGroupDesc 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroupDesc 的使用

返回 ActivationGroupDesc 的 java.rmi.activation 中的方法
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。

参数类型为 ActivationGroupDesc 的 java.rmi.activation 中的方法
static ActivationGroup | ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation) 为当前 VM 创建并设置激活组。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroupDesc.CommandEnvironment
的使用

使用 ActivationGroupDesc.CommandEnvironment 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroupDesc.CommandEnvironment 的使用

返回 ActivationGroupDesc.CommandEnvironment 的 java.rmi.activation 中的方法
 ActivationGroupDesc.CommandEnvironment ActivationGroupDesc.getCommandEnvironment()
返回组的命令环境控制对象。

参数类型为 ActivationGroupDesc.CommandEnvironment 的 java.rmi.activation 中的构造方法
ActivationGroupDesc(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
使用组实现的系统默认值和代码基来构造一个组描述符。
ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationGroupID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroupID
的使用

使用 ActivationGroupID 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationGroupID 的使用

返回 ActivationGroupID 的 java.rmi.activation 中的方法
static ActivationGroupID | ActivationGroup.currentGroupID() 返回当前激活组的标识符。
ActivationGroupID | ActivationDesc.getGroupID() 返回由此描述符指定的对象的组标识符。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。

参数类型为 ActivationGroupID 的 java.rmi.activation 中的方法
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
static ActivationGroup | ActivationGroup.createGroup(ActivationGroupID id, ActivationGroupDesc desc, long incarnation) 为当前 VM 创建并设置激活组。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
void | ActivationMonitor.inactiveGroup(ActivationGroupID id, long incarnation) 通知该组现在是不活动的。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。

参数类型为 ActivationGroupID 的 java.rmi.activation 中的构造方法
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。
ActivationGroup(ActivationGroupID groupID)
用给定的激活组标识符创建一个激活组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationGroup_Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationGroup_Stub
的使用

没有 java.rmi.activation.ActivationGroup_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.ActivationID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.ActivationID
的使用

使用 ActivationID 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationID 的使用

返回 ActivationID 的 java.rmi.activation 中的方法
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
protected ActivationID | Activatable.getID() 返回对象的激活标识符。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。

参数类型为 ActivationID 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
void | ActivationMonitor.inactiveObject(ActivationID id) 当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

参数类型为 ActivationID 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port)
构造方法用于在指定端口上激活/导出对象。
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.activation.ActivationInstantiator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.ActivationInstantiator
的使用

使用 ActivationInstantiator 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationInstantiator 的使用

实现 ActivationInstantiator 的 java.rmi.activation 中的类
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

参数类型为 ActivationInstantiator 的 java.rmi.activation 中的方法
 ActivationMonitor ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation)
通过回调来通知激活系统该组现在是活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.activation.ActivationMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.ActivationMonitor
的使用

使用 ActivationMonitor 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationMonitor 的使用

返回 ActivationMonitor 的 java.rmi.activation 中的方法
 ActivationMonitor ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation)
通过回调来通知激活系统该组现在是活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.activation.ActivationSystem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.ActivationSystem
的使用

使用 ActivationSystem 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 ActivationSystem 的使用

返回 ActivationSystem 的 java.rmi.activation 中的方法
static ActivationSystem | ActivationGroup.getSystem() 返回该 VM 的激活系统。
ActivationSystem | ActivationGroupID.getSystem() 返回组的激活系统。

参数类型为 ActivationSystem 的 java.rmi.activation 中的方法
static void ActivationGroup.setSystem(ActivationSystem system)
设置该 VM 的激活系统。

参数类型为 ActivationSystem 的 java.rmi.activation 中的构造方法
ActivationGroupID(ActivationSystem system)
构造一个唯一的组 id。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.activation.Activator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.activation.Activator
的使用

使用 Activator 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 Activator 的使用

参数类型为 Activator 的 java.rmi.activation 中的构造方法
ActivationID(Activator activator)
ActivationID 的构造方法带有单个参数 activator，这指定了一个对激活器（负责激活与此标识符相关联的对象）的远程引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.UnknownGroupException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.UnknownGroupException
的使用

使用 UnknownGroupException 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 UnknownGroupException 的使用

抛出 UnknownGroupException 的 java.rmi.activation 中的方法
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
protected void | ActivationGroup.inactiveGroup() 如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。
void | ActivationMonitor.inactiveGroup(ActivationGroupID id, long incarnation) 通知该组现在是不活动的。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.activation.UnknownObjectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.activation.UnknownObjectException
的使用

使用 UnknownObjectException 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 UnknownObjectException 的使用

抛出 UnknownObjectException 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
void | ActivationMonitor.inactiveObject(ActivationID id) 当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


DGC (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.dgc
接口 DGC

所有超级接口：
Remote
public interface DGC
extends Remote

DGC 抽象用于分布式垃圾回收算法的服务器端。此接口包含了两个方法：dirty 和 clean。当一个远程引用在客户机（客户机由其 VMID 表示）被解组时，则进行一次脏 (dirty) 调用。当客户机上不存任何针对远程引用的更多引用时，则进行一次相应的洁 (clean) 调用。一次失败的脏调用必须安排一次强洁调用，这样调用的序列号才能保持，以检测未来由分布式垃圾回收器接收的无序调用。针对远程对象的引用由保持该引用的客户机租借一段时间。租借期从接收到脏调用时开始。对租借进行续期是客户机的职责，其方式是：在租借期满之前，在客户机保持的远程引用上进行附加的脏调用。如果客户机在期满之前没有对租借进行续期，则分式布垃圾回收器假定远程对象已不再为该客户机所保持。

方法摘要
void | clean(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong) 洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。
Lease | dirty(ObjID[] ids, long sequenceNum, Lease lease) 脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

方法详细信息

dirty

Lease dirty(ObjID[] ids,
            long sequenceNum,
            Lease lease)
            throws RemoteException
脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。该 'lease' 包含了客户机的唯一 VM 标识符 (VMID) 和一个请求的租期。针对从本地 VM 中导出的每个远程对象，垃圾回收器维护了一个引用列表 - 保持对其引用的客户机列表。如果授予租期，垃圾回收器则为 'ids' 指示的每个远程对象添加客户机 VMID 到引用列表。'sequenceNum' 参数是一个用于检测和丢弃对垃圾回收器最近调用的序号。针对垃圾回收器的每次后续调用，该序号应该总是增加的。有些客户机不能生成 VMID，因为 VMID 是一个包含主机地址的通用唯一标识符，而有些客户机由于安全限制无法获取主机地址。在这种情况下，客户机可以使用一个为 null 的 VMID，并且分布式垃圾回收器为客户机赋予一个 VMID。脏调用返回一个包含所使用 VMID 和授予远程引用租期（服务器可能决定授予一个比客户机所请求更小的租期）的 Lease 对象。客户机必须使用垃圾回收器所使用的 VMID，以便当客户机删除远程对象引用时进行相应的洁调用。 客户机 VM 仅需为每个在 VM 中引用的远程引用进行一次初始脏调用（即使它对同一个远程对象持有多个引用）。客户机还必须在租借过期之前进行一次脏调用，以便对远程服务器上的租借进行续期。当客户机不再具有对特定远程对象的任何引用时，它必须为与此引用关联的对象 ID 安排一次洁调用。

参数：
ids - 调用客户机进行引用时要标记的对象 ID
sequenceNum - 序号
lease - 请求的租期
返回：
授予的租期
抛出：
RemoteException - 如果脏调用失败

clean

void clean(ObjID[] ids,
           long sequenceNum,
           VMID vmid,
           boolean strong)
           throws RemoteException
洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。序号用于检测最近的洁调用。如果参数 'strong' 为 true，则洁调用是一次失败的脏调用的结果，因此，应该记住客户机 'vmid' 的序号。

参数：
ids - 调用客户机取消引用时要标记的对象 ID
sequenceNum - 序号
vmid - 客户机 VMID
strong - 进行“强”洁调用
抛出：
RemoteException - 如果洁调用失败
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Lease (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.dgc
类 Lease

java.lang.Object
    继承者  java.rmi.dgc.Lease
所有已实现的接口：
Serializable
public final class Lease
extends Object
implements Serializable

一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。Lease 对象用于为远程对象引用请求和授予租借权限。

另请参见：
序列化表格

构造方法摘要
Lease(VMID id, long duration)
构造一个具有指定 VMID 和租借期限的 lease。
方法摘要
long | getValue() 返回租借期限。
VMID | getVMID() 返回与此 lease 关联的客户机 VMID。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Lease

public Lease(VMID id,
             long duration)
构造一个具有指定 VMID 和租借期限的 lease。该 vmid 可以为 null。

参数：
id - 与此 lease 关联的 VMID
duration - 租借期限
方法详细信息

getVMID

public VMID getVMID()
返回与此 lease 关联的客户机 VMID。

返回：
客户机 VMID

getValue

public long getValue()
返回租借期限。

返回：
租借期限
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VMID (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.dgc
类 VMID

java.lang.Object
    继承者  java.rmi.dgc.VMID
所有已实现的接口：
Serializable
public final class VMID
extends Object
implements Serializable

VMID 是跨所有 Java 虚拟机都唯一的标识符。分布式垃圾回收器使用 VMID 来标识 VM。

另请参见：
序列化表格

构造方法摘要
VMID()
创建一个新的 VMID。
方法摘要
boolean | equals(Object obj) 将此 VMID 与另一个进行比较，如果它们是同一标识符，则返回 true。
int | hashCode() 计算针对此 VMID 的哈希码。
static boolean | isUnique() 已过时。
String | toString() 返回此 VMID 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

VMID

public VMID()
创建一个新的 VMID。在如下条件下，对于所有 Java 虚拟机，从此构造方法所返回每个新的 VMID 都是唯一的：a) 满足 java.rmi.server.UID 类的对象的唯一性条件，以及 b) 为此主机获得的地址是唯一的，并且针对此对象的生存期是不变的。

方法详细信息

isUnique

@Deprecated
public static boolean isUnique()
已过时。

如果能为此主机确定一个精确的地址，则返回 true。如果不能从此主机生成可信赖的 VMID，则返回 false

返回：
如果主机地址能被确定，则返回 true；否则返回 false

hashCode

public int hashCode()
计算针对此 VMID 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此 VMID 与另一个进行比较，如果它们是同一标识符，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回此 VMID 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.rmi.dgc (Java 2 Platform SE 6)

 java.rmi.dgc
接口
DGC
类
Lease
VMID


java.rmi.dgc (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.rmi.dgc

为 RMI 分布式垃圾回收提供了类和接口。

请参见：
描述

接口摘要
DGC DGC 抽象用于分布式垃圾回收算法的服务器端。

类摘要
Lease | 一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。
VMID | VMID 是跨所有 Java 虚拟机都唯一的标识符。

软件包 java.rmi.dgc 的描述

为 RMI 分布式垃圾回收提供了类和接口。当 RMI 服务器返回一个对象到其客户机（远程方法的调用方）时，其跟踪远程对象在客户机中的使用。当再没有更多的对客户机上远程对象的引用时，或者如果引用的“租借”过期并且没有更新，服务器将垃圾回收远程对象。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.rmi.dgc 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.dgc 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.rmi.dgc.Lease (implements java.io.Serializable)
    • java.rmi.dgc.VMID (implements java.io.Serializable)

接口分层结构

  • java.rmi.Remote
    • java.rmi.dgc.DGC
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.rmi.dgc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.dgc
的使用

使用 java.rmi.dgc 的软件包
java.rmi.dgc 为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.dgc 使用的 java.rmi.dgc 中的类
Lease
一个 lease 包含了一个唯一的 VM 标识符和一个租借期限。
VMID
VMID 是跨所有 Java 虚拟机都唯一的标识符。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.dgc.DGC 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.dgc.DGC
的使用

没有 java.rmi.dgc.DGC 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.dgc.Lease 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.dgc.Lease
的使用

使用 Lease 的软件包
java.rmi.dgc 为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.dgc 中 Lease 的使用

返回 Lease 的 java.rmi.dgc 中的方法
 Lease DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease)
脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

参数类型为 Lease 的 java.rmi.dgc 中的方法
 Lease DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease)
脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.dgc.VMID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.dgc.VMID
的使用

使用 VMID 的软件包
java.rmi.dgc 为 RMI 分布式垃圾回收提供了类和接口。

java.rmi.dgc 中 VMID 的使用

返回 VMID 的 java.rmi.dgc 中的方法
 VMID Lease.getVMID()
返回与此 lease 关联的客户机 VMID。

参数类型为 VMID 的 java.rmi.dgc 中的方法
 void DGC.clean(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong)
洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。

参数类型为 VMID 的 java.rmi.dgc 中的构造方法
Lease(VMID id, long duration)
构造一个具有指定 VMID 和租借期限的 lease。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


LocateRegistry (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.registry
类 LocateRegistry

java.lang.Object
    继承者  java.rmi.registry.LocateRegistry

public final class LocateRegistry
extends Object

LocateRegistry 用于获得对特定主机（包括本地主机）上引导远程对象注册表的引用，或用于创建一个接受对特定端口调用的远程对象注册表。

注意，getRegistry 调用并不实际生成到远程主机的连接。它只创建对远程注册表的本地引用，即便远程主机上没有正运行的注册表，它也会成功创建一个引用。因此，调用作为此方法的结果返回的远程注册表的后续方法可能会失败。

从以下版本开始：
JDK1.1
另请参见：
Registry

方法摘要
static Registry | createRegistry(int port) 创建并导出接受指定 port 请求的本地主机上的 Registry 实例。
static Registry | createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
static Registry | getRegistry() 返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | getRegistry(int port) 返回本地主机在指定 port 上对远程对象 Registry 的引用。
static Registry | getRegistry(String host) 返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | getRegistry(String host, int port) 返回指定的 host 和 port 上对远程对象 Registry 的引用。
static Registry | getRegistry(String host, int port, RMIClientSocketFactory csf) 返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getRegistry

public static Registry getRegistry()
                            throws RemoteException
返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。

返回：
对远程对象注册表的引用（一个 stub）
抛出：
RemoteException - 如果无法创建该引用
从以下版本开始：
JDK1.1

getRegistry

public static Registry getRegistry(int port)
                            throws RemoteException
返回本地主机在指定 port 上对远程对象 Registry 的引用。

参数：
port - 注册表在其上接受请求的端口
返回：
对远程对象注册表的引用（一个 stub）
抛出：
RemoteException - 如果无法创建该引用
从以下版本开始：
JDK1.1

getRegistry

public static Registry getRegistry(String host)
                            throws RemoteException
返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。如果 host 为 null，则使用本地主机。

参数：
host - 用于远程注册表的主机
返回：
对远程对象注册表的引用（一个 stub）
抛出：
RemoteException - 如果无法创建该引用
从以下版本开始：
JDK1.1

getRegistry

public static Registry getRegistry(String host,
                                   int port)
                            throws RemoteException
返回指定的 host 和 port 上对远程对象 Registry 的引用。如果 host 为 null，则使用本地主机。

参数：
host - 用于远程注册表的主机
port - 注册表在其上接受请求的端口
返回：
对远程对象注册表的引用（一个 stub）
抛出：
RemoteException - 如果无法创建该对象
从以下版本开始：
JDK1.1

getRegistry

public static Registry getRegistry(String host,
                                   int port,
                                   RMIClientSocketFactory csf)
                            throws RemoteException
返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。与此远程注册表的通信将使用提供的 RMIClientSocketFactory csf 来创建到远程 host 和 port 上注册表的 Socket 连接。

参数：
host - 用于远程注册表的主机
port - 注册表在其上接受请求的端口
csf - 用于生成到注册表的连接的客户端的 Socket 工厂。如果 csf 为 null，则默认客户端的 Socket 工厂将用于注册表 stub。
返回：
对远程对象注册表的引用（一个 stub）
抛出：
RemoteException - 如果无法创建该引用
从以下版本开始：
1.2

createRegistry

public static Registry createRegistry(int port)
                               throws RemoteException
创建并导出接受指定 port 请求的本地主机上的 Registry 实例。

导出 Registry 实例与调用静态 UnicastRemoteObject.exportObject 方法一样，都是将传入 Registry 实例和指定的 port 作为参数，只不过导出的 Registry 实例具有已知对象的标识标符（用值 ObjID.REGISTRY_ID 构造的 ObjID 实例）。

参数：
port - 注册表在其上接受请求的端口
返回：
注册表
抛出：
RemoteException - 如果无法导出注册表
从以下版本开始：
JDK1.1

createRegistry

public static Registry createRegistry(int port,
                                      RMIClientSocketFactory csf,
                                      RMIServerSocketFactory ssf)
                               throws RemoteException
在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。创建的注册表使用从提供的 RMIServerSocketFactory 创建的 ServerSocket 侦听给定 port 上的传入请求。

导出 Registry 实例与调用静态 UnicastRemoteObject.exportObject 方法一样，都是将传入 Registry 实例、指定的 port、指定的 RMIClientSocketFactory 和指定的 RMIServerSocketFactory 作为参数，只不过 Registry 实例具有已知对象的标识符（用值 ObjID.REGISTRY_ID 构造的 ObjID 实例）。

参数：
port - 注册表在其上接受请求的端口
csf - 用于连接到注册表的客户端的 Socket 工厂
ssf - 用于生成到注册表的连接的服务器端的 ServerSocket 工厂
返回：
注册表
抛出：
RemoteException - 如果无法导出注册表
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Registry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.registry
接口 Registry

所有超级接口：
Remote
public interface Registry
extends Remote

Registry 是简单远程对象注册表的一个远程接口，它提供存储和获取绑定了任意字符串名称的远程对象引用的方法。bind、unbind 和 rebind 方法用于改变注册表中的名称绑定，lookup 和 list 方法用于查询当前的名称绑定。

在其典型用法中，Registry 启用 RMI 客户机引导：它为客户机提供获得对远程对象的初始引用的简单方式。因此，导出的注册表的远程对象实现通常具有已知的地址，如具有已知的 ObjID 和 TCP 端口号（默认为 1099）。

LocateRegistry 类提供的一个可编程的 API，以便构造对远程地址上的 Registry 的引导引用（请参阅静态 getRegistry 方法），以及在当前 VM 所在的特定本地地址创建和导出 Registry（请参阅静态 createRegistry 方法）。

Registry 实现可以选择限制对其中的某些或全部方法的访问（例如，可以限制改变注册表绑定的方法来限制对本地主机发起的调用）。如果 Registry 方法选择拒绝对给定调用的访问，则其实现可能抛出 AccessException，抛出的这一异常（因为它扩展 RemoteException）可能会在远程客户端捕获它时包装在 ServerException 中。

在 Registry 中用于绑定的名称是纯字符串，不是经过分析的。在 Registry 中存储其远程引用的服务可能希望将包名称用作名称绑定中的前缀，以减少注册表中可能的名称冲突。

从以下版本开始：
JDK1.1
另请参见：
LocateRegistry

字段摘要
static int REGISTRY_PORT
已知的注册表端口。
方法摘要
void | bind(String name, Remote obj) 绑定对此注册表中指定 name 的远程引用。
String[] | list() 返回在此注册表中绑定的名称的数组。
Remote | lookup(String name) 返回注册表中绑定到指定 name 的远程引用。
void | rebind(String name, Remote obj) 用提供的远程引用替换此注册表中指定的 name 绑定。
void | unbind(String name) 移除此注册表中指定的 name 绑定。

字段详细信息

REGISTRY_PORT

static final int REGISTRY_PORT
已知的注册表端口。

另请参见：
常量字段值
方法详细信息

lookup

Remote lookup(String name)
              throws RemoteException,
                     NotBoundException,
                     AccessException
返回注册表中绑定到指定 name 的远程引用。

参数：
name - 要查找的远程引用的名称
返回：
对远程对象的引用
抛出：
NotBoundException - 如果当前未绑定 name
RemoteException - 如果与注册表的远程通信失败；如果异常是包含 AccessException 的 ServerException，则注册表拒绝调用方对执行此操作的访问。
AccessException - 如果此注册表是本地的，并且它拒绝调用方对执行此操作的访问
NullPointerException - 如果 name 为 null

bind

void bind(String name,
          Remote obj)
          throws RemoteException,
                 AlreadyBoundException,
                 AccessException
绑定对此注册表中指定 name 的远程引用。

参数：
name - 与该远程引用相关的名称
obj - 对远程对象（通常是一个 stub）的引用
抛出：
AlreadyBoundException - 如果已经绑定了 name
RemoteException - 如果与注册表的远程通信失败；如果异常是包含 AccessException 的 ServerException，则注册表拒绝调用方对执行此操作的访问（例如，发起的操作来自非本地主机）
AccessException - 如果此注册表是本地的，并且它拒绝调用方对执行此操作的访问
NullPointerException - 如果 name 为 null，或者如果 obj 为 null

unbind

void unbind(String name)
            throws RemoteException,
                   NotBoundException,
                   AccessException
移除此注册表中指定的 name 绑定。

参数：
name - 要移除的绑定名称
抛出：
NotBoundException - 如果当前未绑定 name
RemoteException - 如果与注册表的远程通信失败；如果异常是包含 AccessException 的 ServerException，则注册表拒绝调用方对执行此操作的访问（例如，发起的操作来自非本地主机）
AccessException - 如果此注册表是本地的，并且它拒绝调用方对执行此操作的访问
NullPointerException - 如果 name 为 null

rebind

void rebind(String name,
            Remote obj)
            throws RemoteException,
                   AccessException
用提供的远程引用替换此注册表中指定的 name 绑定。如果存在指定 name 的现有绑定，则会丢弃此现有的绑定。

参数：
name - 与该远程引用相关的名称
obj - 对远程对象（通常是一个 stub）的引用
抛出：
RemoteException - 如果与注册表的远程通信失败；如果异常是包含 AccessException 的 ServerException，则注册表拒绝调用方对执行此操作的访问（例如，发起的操作来自非本地主机）
AccessException - 如果此注册表是本地的，并且它拒绝调用方对执行此操作的访问
NullPointerException - 如果 name 为 null，或者如果 obj 为 null

list

String[] list()
              throws RemoteException,
                     AccessException
返回在此注册表中绑定的名称的数组。该数组将包含一个此注册表中调用此方法时绑定的名称快照。

返回：
此注册表中绑定名称的数组
抛出：
RemoteException - 如果与注册表的远程通信失败；如果异常是包含 AccessException 的 ServerException，则注册表拒绝调用方对执行此操作的访问。
AccessException - 如果此注册表是本地的，并且它拒绝调用方对执行此操作的访问
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegistryHandler (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.registry
接口 RegistryHandler

已过时。 无替代版本

@Deprecated
public interface RegistryHandler

RegistryHandler 是在以前的实现版本中由 RMI 运行时内部使用的接口。该接口永远不应该通过应用程序代码访问。

从以下版本开始：
JDK1.1

方法摘要
Registry | registryImpl(int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
Registry | registryStub(String host, int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

方法详细信息

registryStub

@Deprecated
Registry registryStub(String host,
                                 int port)
                      throws RemoteException,
                             UnknownHostException
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

返回连接指定主机和端口上的远程注册表的 "stub"。

参数：
host - 远程注册表主机的名称
port - 远程注册表端口
返回：
远程注册表 stub
抛出：
RemoteException - 如果发生远程错误
UnknownHostException - 如果不能解析给定的主机名称

registryImpl

@Deprecated
Registry registryImpl(int port)
                      throws RemoteException
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。

在指定端口上构造并导出一个 Registry。端口必须为非 0。

参数：
port - 要在其上导出注册表的端口
返回：
注册表 stub
抛出：
RemoteException - 如果发生远程错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.rmi.registry (Java 2 Platform SE 6)

 java.rmi.registry
接口
Registry
RegistryHandler
类
LocateRegistry


java.rmi.registry (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.rmi.registry

提供 RMI 注册表的一个类和两个接口。

请参见：
描述

接口摘要
Registry | Registry 是简单远程对象注册表的一个远程接口，它提供存储和获取绑定了任意字符串名称的远程对象引用的方法。
RegistryHandler | 已过时。 无替代版本

类摘要
LocateRegistry LocateRegistry 用于获得对特定主机（包括本地主机）上引导远程对象注册表的引用，或用于创建一个接受对特定端口调用的远程对象注册表。

软件包 java.rmi.registry 的描述

提供 RMI 注册表的一个类和两个接口。注册表是一个将名称映射到远程对象的远程对象。服务器使用注册表注册其远程对象，以便于查找这些对象。当某个对象希望在远程对象上调用某个方法时，则必须首先使用其名称查找该远程对象。注册表将为调用对象返回一个对远程对象的引用，使用这种方法可以调用远程方法。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.rmi.registry 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.registry 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.rmi.registry.LocateRegistry

接口分层结构

  • java.rmi.registry.RegistryHandler
  • java.rmi.Remote
    • java.rmi.registry.Registry
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.rmi.registry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.registry
的使用

使用 java.rmi.registry 的软件包
java.rmi.registry 提供 RMI 注册表的一个类和两个接口。

java.rmi.registry 使用的 java.rmi.registry 中的类
Registry
Registry 是简单远程对象注册表的一个远程接口，它提供存储和获取绑定了任意字符串名称的远程对象引用的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.registry.LocateRegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.registry.LocateRegistry
的使用

没有 java.rmi.registry.LocateRegistry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.registry.Registry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.registry.Registry
的使用

使用 Registry 的软件包
java.rmi.registry 提供 RMI 注册表的一个类和两个接口。

java.rmi.registry 中 Registry 的使用

返回 Registry 的 java.rmi.registry 中的方法
static Registry | LocateRegistry.createRegistry(int port) 创建并导出接受指定 port 请求的本地主机上的 Registry 实例。
static Registry | LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
static Registry | LocateRegistry.getRegistry() 返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(int port) 返回本地主机在指定 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host) 返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port) 返回指定的 host 和 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf) 返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。
Registry | RegistryHandler.registryImpl(int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
Registry | RegistryHandler.registryStub(String host, int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.registry.RegistryHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.registry.RegistryHandler
的使用

没有 java.rmi.registry.RegistryHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ExportException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 ExportException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.server.ExportException
所有已实现的接口：
Serializable
直接已知子类：
SocketSecurityException
public class ExportException
extends RemoteException

ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。通过 java.rmi.server.UnicastRemoteObject 和 java.rmi.activation.Activatable 的构造方法和 exportObject 方法导出远程对象。

从以下版本开始：
JDK1.1
另请参见：
UnicastRemoteObject, Activatable, 序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ExportException(String s)
构造带指定详细消息的 ExportException。
ExportException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 ExportException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ExportException

public ExportException(String s)
构造带指定详细消息的 ExportException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1

ExportException

public ExportException(String s,
                       Exception ex)
构造带指定详细消息和嵌入异常的 ExportException。

参数：
s - 详细消息
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


LoaderHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 LoaderHandler

已过时。 无替代版本

@Deprecated
public interface LoaderHandler

LoaderHandler 是以前实现版本中由 RMI 运行时内部使用的接口。它永远不应该通过应用程序代码访问。

从以下版本开始：
JDK1.1

字段摘要
static String packagePrefix
已过时。 系统 LoaderHandler 实现的包。
方法摘要
Object | getSecurityContext(ClassLoader loader) 已过时。 无替代版本
Class<?> | loadClass(String name) 已过时。 无替代版本
Class<?> | loadClass(URL codebase, String name) 已过时。 无替代版本

字段详细信息

packagePrefix

static final String packagePrefix
已过时。
系统 LoaderHandler 实现的包。

另请参见：
常量字段值
方法详细信息

loadClass

@Deprecated
Class<?> loadClass(String name)
                   throws MalformedURLException,
                          ClassNotFoundException
已过时。 无替代版本

从 java.rmi.server.codebase 属性指定的位置加载类。

参数：
name - 要加载的类名称
返回：
表示加载的类的 Class 对象
抛出：
MalformedURLException - 如果系统属性 java.rmi.server.codebase 包含一个无效的 URL
ClassNotFoundException - 如果在基本代码基无法找到该类的定义。
从以下版本开始：
JDK1.1

loadClass

@Deprecated
Class<?> loadClass(URL codebase,
                              String name)
                   throws MalformedURLException,
                          ClassNotFoundException
已过时。 无替代版本

从 URL 加载类。

参数：
codebase - 从中加载该类的 URL
name - 要加载的类名称
返回：
表示加载的类的 Class 对象
抛出：
MalformedURLException - 如果 codebase 参数包含一个无效 URL
ClassNotFoundException - 如果在指定的 URL 无法找到该类的定义
从以下版本开始：
JDK1.1

getSecurityContext

@Deprecated
Object getSecurityContext(ClassLoader loader)
已过时。 无替代版本

返回给定类加载器的安全上下文。

参数：
loader - 从中获取安全上下文的类加载器
返回：
安全上下文
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 LogStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.io.PrintStream
                继承者  java.rmi.server.LogStream
所有已实现的接口：
Closeable, Flushable, Appendable
已过时。 无替代版本

@Deprecated
public class LogStream
extends PrintStream

LogStream 提供一种记录错误的机制，这一机制专门用来监视系统运行情况。

从以下版本开始：
JDK1.1

字段摘要
static int | BRIEF 已过时。 日志级别常量（简明日志记录）。
static int | SILENT 已过时。 日志级别常量（无日志记录）。
static int | VERBOSE 已过时。 日志级别常量（详细日志记录）。
从类 java.io.FilterOutputStream 继承的字段
out
方法摘要
static PrintStream | getDefaultStream() 已过时。 无替代版本
OutputStream | getOutputStream() 已过时。 无替代版本
static LogStream | log(String name) 已过时。 无替代版本
static int | parseLevel(String s) 已过时。 无替代版本
static void | setDefaultStream(PrintStream newDefault) 已过时。 无替代版本
void | setOutputStream(OutputStream out) 已过时。 无替代版本
String | toString() 已过时。 无替代版本
void | write(byte[] b, int off, int len) 已过时。 无替代版本
void | write(int b) 已过时。 无替代版本
从类 java.io.PrintStream 继承的方法
append, append, append, checkError, clearError, close, flush, format, format, print, print, print, print, print, print, print, print, print, printf, printf, println, println, println, println, println, println, println, println, println, println, setError
从类 java.io.FilterOutputStream 继承的方法
write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SILENT

public static final int SILENT
已过时。
日志级别常量（无日志记录）。

另请参见：
常量字段值

BRIEF

public static final int BRIEF
已过时。
日志级别常量（简明日志记录）。

另请参见：
常量字段值

VERBOSE

public static final int VERBOSE
已过时。
日志级别常量（详细日志记录）。

另请参见：
常量字段值
方法详细信息

log

@Deprecated
public static LogStream log(String name)
已过时。 无替代版本

返回由给定名称标识的 LogStream。如果不存在对应于“名称”的日志，则创建使用默认流的日志。

参数：
name - 标识所需 LogStream 的名称
返回：
与给定名称关联的日志
从以下版本开始：
JDK1.1

getDefaultStream

@Deprecated
public static PrintStream getDefaultStream()
已过时。 无替代版本

返回新日志的当前默认流。

返回：
默认日志流
从以下版本开始：
JDK1.1
另请参见：
setDefaultStream(java.io.PrintStream)

setDefaultStream

@Deprecated
public static void setDefaultStream(PrintStream newDefault)
已过时。 无替代版本

设置新日志的默认流。

参数：
newDefault - 新的默认日志流
从以下版本开始：
JDK1.1
另请参见：
getDefaultStream()

getOutputStream

@Deprecated
public OutputStream getOutputStream()
已过时。 无替代版本

返回将此日志的输出发送到其中的当前流。

返回：
此日志的输出流
从以下版本开始：
JDK1.1
另请参见：
setOutputStream(java.io.OutputStream)

setOutputStream

@Deprecated
public void setOutputStream(OutputStream out)
已过时。 无替代版本

设置将此日志的输出发送到其中的流。

参数：
out - 此日志的新输出流
从以下版本开始：
JDK1.1
另请参见：
getOutputStream()

write

@Deprecated
public void write(int b)
已过时。 无替代版本

将数据的字节写入该流。如果它不是一个新行，则将该字节追加到内部缓冲区。如果它是新行，则将当前缓冲的行发送到日志的输出流中，前缀为适当的日志记录信息。

覆盖：
类 PrintStream 中的 write
参数：
b - 要写入的字节
从以下版本开始：
JDK1.1
另请参见：
PrintStream.print(char), PrintStream.println(char)

write

@Deprecated
public void write(byte[] b,
                             int off,
                             int len)
已过时。 无替代版本

写入字节的子数组。通过写入字节方法传递每个子数组。

覆盖：
类 PrintStream 中的 write
参数：
b - byte 数组
off - 相对于开始写入字节处的偏移量
len - 要写入的字节数
从以下版本开始：
JDK1.1
另请参见：
FilterOutputStream.write(int)

toString

@Deprecated
public String toString()
已过时。 无替代版本

以字符串表示形式返回日志名称。

覆盖：
类 Object 中的 toString
返回：
日志名称
从以下版本开始：
JDK1.1

parseLevel

@Deprecated
public static int parseLevel(String s)
已过时。 无替代版本

将日志记录级别的字符串名称转换为内部整数表示形式。

参数：
s - 日志记录级别的名称（如，'SILENT'、'BRIEF'、'VERBOSE'）
返回：
相应的整数日志级别
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjID (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 ObjID

java.lang.Object
    继承者  java.rmi.server.ObjID
所有已实现的接口：
Serializable
public final class ObjID
extends Object
implements Serializable

ObjID 是用于标识导出到 RMI 运行时的远程对象。导出远程对象时，将根据用于导出的 API，或隐式或显示地向该对象分配一个对象标识符。

ObjID() 构造方法可用于生成唯一的对象标识符。这样一个 ObjID 对于生成它的主机时间来说是唯一的。ObjID(int) 构造方法可用于创建“已知的”对象标识符。已知 ObjID 的范围取决于将它导出到其中的 RMI 运行时。

ObjID 实例包含一个对象数（属于类型 long）和一个地址空间标识符（属于类型 UID）。在唯一的 ObjID 中，地址空间标识符对于给定主机来说是不随时间变化的。在已知的 ObjID 中，地址空间标识符等效于通过调用具有值 0 的 UID.UID(short) 构造方法返回的标识符。

如果将系统属性 java.rmi.server.randomIDs 定义为等于字符串 "true"（不分大小写），则 ObjID() 构造方法将使用加密的强伪随机数生成器来选择返回的 ObjID 的对象数。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
static int | ACTIVATOR_ID 激活程序的已知 ObjID 的对象数。
static int | DGC_ID 分布式垃圾回收器的已知 ObjID 的对象数。
static int | REGISTRY_ID 注册表的已知 ObjID 的对象数。
构造方法摘要
ObjID()
生成唯一的对象标识符。
ObjID(int objNum)
创建“已知的”对象标识符。
方法摘要
boolean | equals(Object obj) 比较指定对象与此 ObjID 是否相等。
int | hashCode() 返回此对象标识符、对象数的哈希码值。
static ObjID | read(ObjectInput in) 通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。
String | toString() 返回此对象标识符的字符串表示形式。
void | write(ObjectOutput out) 将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

REGISTRY_ID

public static final int REGISTRY_ID
注册表的已知 ObjID 的对象数。

另请参见：
常量字段值

ACTIVATOR_ID

public static final int ACTIVATOR_ID
激活程序的已知 ObjID 的对象数。

另请参见：
常量字段值

DGC_ID

public static final int DGC_ID
分布式垃圾回收器的已知 ObjID 的对象数。

另请参见：
常量字段值
构造方法详细信息

ObjID

public ObjID()
生成唯一的对象标识符。

如果将系统属性 java.rmi.server.randomIDs 定义为等于字符串 "true"（不分大小写），则此构造方法将使用加密的强伪随机数生成器来选择返回的 ObjID 的对象数。

ObjID

public ObjID(int objNum)
创建“已知的”对象标识符。

通过此构造方法创建的 ObjID 将不与通过无参数构造方法生成的 ObjID 冲突。

参数：
objNum - 已知对象标识符的对象数
方法详细信息

write

public void write(ObjectOutput out)
           throws IOException
将此 ObjID 的二进制表示形式编组为一个 ObjectOutput 实例。

需要特别说明的是，此方法首先根据此对象标识符的对象数调用给定流的 DataOutput.writeLong(long) 方法，然后根据该流调用 UID.write(DataOutput) 方法写入其地址空间标识符。

参数：
out - 要将此 ObjID 写入其中的 ObjectOutput 实例
抛出：
IOException - 如果在执行此操作时发生 I/O 错误

read

public static ObjID read(ObjectInput in)
                  throws IOException
通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。

特别是，此方法首先调用给定流的 DataInput.readLong() 方法来读取一个对象数，然后根据此流调用 UID.read(DataInput) 来读取地址空间标识符，接着创建并返回一个新的 ObjID 实例，该实例包含从该流读取的对象数和地址空间标识符。

参数：
in - 要从中读取 ObjID 的 ObjectInput 实例
返回：
已解组的 ObjID 实例
抛出：
IOException - 如果在执行此操作时发生 I/O 错误

hashCode

public int hashCode()
返回此对象标识符、对象数的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此对象标识符的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较指定对象与此 ObjID 是否相等。 当且仅当该指定对象是一个与该对象具有相同对象数和地址空间标识符的 ObjID 时，此方法返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此 ObjID 比较的对象
返回：
如果给定对象与此对象等效，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回此对象标识符的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此对象标识符的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Operation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 Operation

java.lang.Object
    继承者  java.rmi.server.Operation
已过时。 无替代版本

@Deprecated
public class Operation
extends Object

Operation 包含 Java 方法的描述。Operation 对象用于 JDK1.1 版本的 stub 和 skeleton。1.2 版本的样式 stub（由 rmic -v1.2 生成的 stub）不需要 Operation 类；因此该类已废弃。

从以下版本开始：
JDK1.1

构造方法摘要
Operation(String op)
已过时。 无替代版本
方法摘要
String | getOperation() 已过时。 无替代版本
String | toString() 已过时。 无替代版本
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Operation

@Deprecated
public Operation(String op)
已过时。 无替代版本

创建一个新的 Operation 对象。

参数：
op - 方法名称
从以下版本开始：
JDK1.1
方法详细信息

getOperation

@Deprecated
public String getOperation()
已过时。 无替代版本

返回方法名称。

返回：
方法名称
从以下版本开始：
JDK1.1

toString

@Deprecated
public String toString()
已过时。 无替代版本

返回该操作的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteCall (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 RemoteCall

已过时。 无替代版本。

@Deprecated
public interface RemoteCall

RemoteCall 是一个只供 RMI 运行时（与远程对象的 stub 和 skeleton 一起）使用来执行远程对象调用的抽象。因为 RemoteCall 接口只供过时的 java.rmi.server.RemoteRef 方法使用，所以该接口已过时。

从以下版本开始：
JDK1.1
另请参见：
RemoteRef

方法摘要
void | done() 已过时。 无替代版本
void | executeCall() 已过时。 无替代版本
ObjectInput | getInputStream() 已过时。 无替代版本
ObjectOutput | getOutputStream() 已过时。 无替代版本
ObjectOutput | getResultStream(boolean success) 已过时。 无替代版本
void | releaseInputStream() 已过时。 无替代版本
void | releaseOutputStream() 已过时。 无替代版本

方法详细信息

getOutputStream

@Deprecated
ObjectOutput getOutputStream()
                             throws IOException
已过时。 无替代版本

返回 stub/skeleton 应将参数/结果放入其中的输出流。

返回：
参数/结果的输出流
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JDK1.1

releaseOutputStream

@Deprecated
void releaseOutputStream()
                         throws IOException
已过时。 无替代版本

释放输出流；这应以某些传送方式释放该流。

抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JDK1.1

getInputStream

@Deprecated
ObjectInput getInputStream()
                           throws IOException
已过时。 无替代版本

获取 stub/skeleton 应从中获取结果/参数的输入流。

返回：
用于读取参数/结果的输入流
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JDK1.1

releaseInputStream

@Deprecated
void releaseInputStream()
                        throws IOException
已过时。 无替代版本

释放输入流。这允许某些传送方式尽早释放通道。

抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JDK1.1

getResultStream

@Deprecated
ObjectOutput getResultStream(boolean success)
                             throws IOException,
                                    StreamCorruptedException
已过时。 无替代版本

返回输出流（可以输出与成功调用相关的头信息）。每个远程调用只能成功一次。

参数：
success - 如果为 true，则指示正常返回；否则指示异常返回。
返回：
用于写入调用结果的输出流
抛出：
IOException - 如果发生 I/O 错误。
StreamCorruptedException - 如果已被调用。
从以下版本开始：
JDK1.1

executeCall

@Deprecated
void executeCall()
                 throws Exception
已过时。 无替代版本

采取一切措施执行调用。

抛出：
Exception - 如果发生常规异常。
从以下版本开始：
JDK1.1

done

@Deprecated
void done()
          throws IOException
已过时。 无替代版本

允许在远程调用完成后执行清除。

抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 RemoteObject

java.lang.Object
    继承者  java.rmi.server.RemoteObject
所有已实现的接口：
Serializable, Remote
直接已知子类：
RemoteObjectInvocationHandler, RemoteServer, RemoteStub
public abstract class RemoteObject
extends Object
implements Remote, Serializable

该 RemoteObject 类实现远程对象的 java.lang.Object 行为。RemoteObject 通过实现 hashCode、equals 和 toString 方法提供 Object 的远程语义。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
protected  RemoteRef ref
对象的远程引用。
构造方法摘要
protected | RemoteObject() 创建远程对象。
protected | RemoteObject(RemoteRef newref) 创建一个用指定远程引用初始化的远程对象。
方法摘要
boolean | equals(Object obj) 比较两个远程对象是否相等。
RemoteRef | getRef() 返回远程对象的远程引用。
int | hashCode() 返回远程对象的哈希码。
String | toString() 返回表示此远程对象的值的 String。
static Remote | toStub(Remote obj) 返回作为参数传递的远程对象 obj 的 stub。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ref

protected transient RemoteRef ref
对象的远程引用。

构造方法详细信息

RemoteObject

protected RemoteObject()
创建远程对象。

RemoteObject

protected RemoteObject(RemoteRef newref)
创建一个用指定远程引用初始化的远程对象。

参数：
newref - 远程引用
方法详细信息

getRef

public RemoteRef getRef()
返回远程对象的远程引用。

注：从此方法返回的对象可以是特定于实现的类的实例。该 RemoteObject 通过其自定义 writeObject 和 readObject 方法的行为确保其实例远程引用的序列化可移植性。不应在 RemoteObject 包装器实例之外序列化 RemoteRef 的实例，否则其结果可能无法移植。

返回：
对远程对象的远程引用
从以下版本开始：
1.2

toStub

public static Remote toStub(Remote obj)
                     throws NoSuchObjectException
返回作为参数传递的远程对象 obj 的 stub。此操作仅在导出对象之后 有效。

参数：
obj - 需要其 stub 的远程对象
返回：
远程对象 obj 的 stub。
抛出：
NoSuchObjectException - 如果无法找到远程对象的 stub。
从以下版本开始：
1.2

hashCode

public int hashCode()
返回远程对象的哈希码。引用同一远程对象的两个远程对象 stub 将有相同的哈希码（以便作为哈希表中的键支持远程对象）。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Hashtable

equals

public boolean equals(Object obj)
比较两个远程对象是否相等。返回指示此远程对象是否与指定对象等效的 boolean。在哈希表中存储远程对象时将使用此方法。如果指定对象本身不是 RemoteObject 的实例，则此方法通过返回调用其参数的 equals 方法的结果将此远程对象委托为参数。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象
返回：
如果这些对象相等，则返回 true；否则，返回 false。
另请参见：
Hashtable

toString

public String toString()
返回表示此远程对象的值的 String。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteObjectInvocationHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 RemoteObjectInvocationHandler

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteObjectInvocationHandler
所有已实现的接口：
Serializable, InvocationHandler, Remote
public class RemoteObjectInvocationHandler
extends RemoteObject
implements InvocationHandler

与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。此调用处理程序可以与取代预生成 stub 类的动态代理实例一起使用。

不期望应用程序直接使用此类。使用具有 UnicastRemoteObject 或 Activatable 的动态代理导出的远程对象将此类的实例作为该代理的调用处理程序。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
RemoteObjectInvocationHandler(RemoteRef ref)
创建一个用指定 RemoteRef 构造的新 RemoteObjectInvocationHandler。
方法摘要
 Object invoke(Object proxy, Method method, Object[] args)
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

RemoteObjectInvocationHandler

public RemoteObjectInvocationHandler(RemoteRef ref)
创建一个用指定 RemoteRef 构造的新 RemoteObjectInvocationHandler。

参数：
ref - 远程引用
抛出：
NullPointerException - 如果 ref 为 null
方法详细信息

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
处理在封装的代理实例 proxy 上进行的方法调用并返回结果。

RemoteObjectInvocationHandler 按以下方式实现此方法：

如果 method 为以下方法之一，则按下面描述的方式处理：

  • Object.hashCode: 返回该代理的哈希码值。
  • Object.equals: 如果参数 (args[0]) 是动态代理类的一个实例，且此调用处理程序等于该参数的调用处理程序，则返回 true；否则返回 false。
  • Object.toString: 返回该代理的字符串表示形式。

否则，按以下方式进行远程调用：

  • 如果 proxy 不是接口 Remote 的实例，则抛出 IllegalArgumentException。
  • 否则，在此调用处理程序的 RemoteRef 上调用 invoke 方法，传递 proxy、method、args 和 method 的哈希码值（在“Java Remote Method Invocation (RMI) 规范”的 section 8.3 中定义）并返回结果。
  • 如果 RemoteRef.invoke 抛出异常，且该异常是一个经检查的异常，不能指派给由 proxy 类实现的方法的 throws 子句中的任何异常，则该异常在 UnexpectedException 中包装且抛出该包装的异常。否则，由此方法抛出的 invoke 抛出该异常。

如果包含此调用处理程序的某个有效动态代理类的实例尚未生成参数，则此方法的语义是不确定的。

指定者：
接口 InvocationHandler 中的 invoke
参数：
proxy - 在其上调用方法的代理实例
method - 与在代理实例上调用的接口方法相对应的 Method 实例
args - 包含传入到代理实例上方法调用的参数值的对象数组；如果该方法不用参数，则为 null
返回：
要从代理实例上的方法调用返回的值
抛出：
Throwable - 从代理实例上的方法调用抛出的异常
另请参见：
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteRef (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 RemoteRef

所有超级接口：
Externalizable, Serializable
所有已知子接口：
ServerRef
public interface RemoteRef
extends Externalizable

RemoteRef 表示远程对象的句柄。RemoteStub 使用远程引用来执行对远程对象的远程方法调用。

从以下版本开始：
JDK1.1
另请参见：
RemoteStub

字段摘要
static String | packagePrefix 初始化服务器包的前缀：假定服务器 ref 类（如 UnicastRef、UnicastServerRef）的实现位于由前缀定义的包中。
static long | serialVersionUID 指示与类的 JDK 1.1.x 版本的兼容性。
方法摘要
 void done(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 String getRefClass(ObjectOutput out)
返回要在流 'out' 上序列化的 ref 类型的类名称。
 void invoke(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 Object invoke(Remote obj, Method method, Object[] params, long opnum)
调用某个方法。
 RemoteCall newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。
 boolean remoteEquals(RemoteRef obj)
比较两个远程对象是否相等。
 int remoteHashCode()
返回远程对象的哈希码。
 String remoteToString()
返回表示此远程对象的引用的 String。
从接口 java.io.Externalizable 继承的方法
readExternal, writeExternal

字段详细信息

serialVersionUID

static final long serialVersionUID
指示与类的 JDK 1.1.x 版本的兼容性。

另请参见：
常量字段值

packagePrefix

static final String packagePrefix
初始化服务器包的前缀：假定服务器 ref 类（如 UnicastRef、UnicastServerRef）的实现位于由前缀定义的包中。

另请参见：
常量字段值
方法详细信息

invoke

Object invoke(Remote obj,
              Method method,
              Object[] params,
              long opnum)
              throws Exception
调用某个方法。将方法调用委托给引用的这一形式允许该引用认真设置到远程主机的连接，编组方法和参数的某一表示形式，然后将该方法调用传送到远程主机。此方法既会返回对位于远程主机上远程对象的方法调用的结果，也会在调用失败时抛出 RemoteException，或者在远程调用抛出异常时抛出应用程序级的异常。

参数：
obj - 包含 RemoteRef（如该对象的 RemoteStub）的对象。
method - 要调用的方法
params - 参数列表
opnum - 可以用于表示该方法的哈希码
返回：
远程方法调用的结果
抛出：
Exception - 如果在远程方法调用过程中发生任何异常
从以下版本开始：
1.2

newCall

@Deprecated
RemoteCall newCall(RemoteObject obj,
                              Operation[] op,
                              int opnum,
                              long hash)
                   throws RemoteException
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

创建一个用于对此对象进行新的远程方法调用的适当调用对象。传递操作数组和索引允许 stub 生成器来分配操作索引，并解释它们。远程引用可能需要该操作以便在调用中编码。

参数：
obj - 要通过它进行调用的远程 stub
op - stub 操作的数组
opnum - 操作数
hash - stub/skeleton 接口哈希码
返回：
表示远程调用的调用对象
抛出：
RemoteException - 如果初始化新的远程调用失败
从以下版本开始：
JDK1.1
另请参见：
invoke(Remote,java.lang.reflect.Method,Object[],long)

invoke

@Deprecated
void invoke(RemoteCall call)
            throws Exception
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。

执行远程调用。调用将激活应该通过的但未被 stub 捕获的所有“用户”异常。如果在远程调用过程中激活任何异常，则调用在激活“用户”或远程异常之前应小心清除连接。

参数：
call - 表示远程调用的对象
抛出：
Exception - 如果在远程方法调用的过程中发生任何异常
从以下版本开始：
JDK1.1
另请参见：
invoke(Remote,java.lang.reflect.Method,Object[],long)

done

@Deprecated
void done(RemoteCall call)
          throws RemoteException
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。

允许远程引用以清除（或重新使用）连接。只有该调用成功（无例外）返回到 stub 时才调用 Done。

参数：
call - 表示远程调用的对象
抛出：
RemoteException - 如果在调用 cleanup 过程中发生远程错误
从以下版本开始：
JDK1.1
另请参见：
invoke(Remote,java.lang.reflect.Method,Object[],long)

getRefClass

String getRefClass(ObjectOutput out)
返回要在流 'out' 上序列化的 ref 类型的类名称。

参数：
out - 要在其中序列化引用的输出流
返回：
引用类型的类名称（不附带包条件）
从以下版本开始：
JDK1.1

remoteHashCode

int remoteHashCode()
返回远程对象的哈希码。引用同一远程对象的两个远程对象 stub 将有相同的哈希码（以便作为哈希表中的键支持远程对象）。

返回：
远程对象的哈希码
从以下版本开始：
JDK1.1
另请参见：
Hashtable

remoteEquals

boolean remoteEquals(RemoteRef obj)
比较两个远程对象是否相等。返回指示此远程对象是否与指定对象等效的 boolean。在哈希表中存储远程对象时将使用此方法。

参数：
obj - 要与之比较的对象
返回：
如果这些对象相等，则返回 true；否则，返回 false。
从以下版本开始：
JDK1.1
另请参见：
Hashtable

remoteToString

String remoteToString()
返回表示此远程对象的引用的 String。

返回：
表示远程对象引用的字符串
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteServer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 RemoteServer

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteServer
所有已实现的接口：
Serializable, Remote
直接已知子类：
Activatable, UnicastRemoteObject
public abstract class RemoteServer
extends RemoteObject

该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。需要特别指出的是，创建和导出远程对象所需的功能（即使其远程可用）理论上由 RemoteServer 提供，具体由其子类提供。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
protected | RemoteServer() 构造一个 RemoteServer。
protected | RemoteServer(RemoteRef ref) 构造带指定引用类型的 RemoteServer。
方法摘要
static String | getClientHost() 返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。
static PrintStream | getLog() 返回用于 RMI 调用日志的流。
static void | setLog(OutputStream out) 将 RMI 调用记录到输出流 out 中。
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

RemoteServer

protected RemoteServer()
构造一个 RemoteServer。

从以下版本开始：
JDK1.1

RemoteServer

protected RemoteServer(RemoteRef ref)
构造带指定引用类型的 RemoteServer。

参数：
ref - 远程引用
从以下版本开始：
JDK1.1
方法详细信息

getClientHost

public static String getClientHost()
                            throws ServerNotActiveException
返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。

返回：
远程客户机主机的字符串表示形式
抛出：
ServerNotActiveException - 如果在当前线程中没有处理远程方法调用
从以下版本开始：
JDK1.1

setLog

public static void setLog(OutputStream out)
将 RMI 调用记录到输出流 out 中。如果 out 为 null，则关闭调用日志记录。

如果存在安全管理器，则其 checkPermission 方法将用 java.util.logging.LoggingPermission("control") 权限调用；这可能会导致 SecurityException。

参数：
out - 应该将 RMI 调用记录到其中的输出流
抛出：
SecurityException - 如果存在安全管理器且其 checkPermission 方法的调用失败
从以下版本开始：
JDK1.1
另请参见：
getLog()

getLog

public static PrintStream getLog()
返回用于 RMI 调用日志的流。

返回：
调用日志
从以下版本开始：
JDK1.1
另请参见：
setLog(java.io.OutputStream)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RemoteStub (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 RemoteStub

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteStub
所有已实现的接口：
Serializable, Remote
直接已知子类：
ActivationGroup_Stub, RMIConnectionImpl_Stub, RMIServerImpl_Stub
public abstract class RemoteStub
extends RemoteObject

该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。Stub 对象是完全支持同一组远程接口的代理项，这些远程接口由远程对象的实际实现定义。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
protected | RemoteStub() 构造一个 RemoteStub。
protected | RemoteStub(RemoteRef ref) 构造带指定远程引用的 RemoteStub。
方法摘要
protected static void setRef(RemoteStub stub, RemoteRef ref)
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

RemoteStub

protected RemoteStub()
构造一个 RemoteStub。

RemoteStub

protected RemoteStub(RemoteRef ref)
构造带指定远程引用的 RemoteStub。

参数：
ref - 远程引用
从以下版本开始：
JDK1.1
方法详细信息

setRef

@Deprecated
protected static void setRef(RemoteStub stub,
                                        RemoteRef ref)
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。

将远程引用设置在远程 stub 内。

参数：
stub - 远程 stub
ref - 远程引用
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIClassLoader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 RMIClassLoader

java.lang.Object
    继承者  java.rmi.server.RMIClassLoader

public class RMIClassLoader
extends Object

RMIClassLoader 包含支持用 RMI 进行动态类加载的静态方法。包含从网络位置（一个或多个 URL）加载类和获取远程方应从其加载现有类的位置的方法。这些方法由 RMI 运行库在编组和解组参数中包含的类时使用，将返回远程方法调用的值，并且还可以由应用程序直接调用，以模仿 RMI 的动态类加载行为。

以下静态方法的实现

  • loadClass(URL,String)
  • loadClass(String,String)
  • loadClass(String,String,ClassLoader)
  • loadProxyClass(String,String[],ClassLoader)
  • getClassLoader(String)
  • getClassAnnotation(Class)
由这些方法的服务提供者接口 RMIClassLoaderSpi 的实例提供。当调用这些方法之一时，其行为是向服务提供者实例委托相应的方法。有关每个方法如何委托给提供者实例的详细信息，在各自特定方法的文档中进行了描述。

服务提供者实例按以下方式选择：

  • 如果定义了系统属性 java.rmi.server.RMIClassLoaderSpi，则其值等于字符串 "default" 时，提供者实例将是调用 getDefaultProviderInstance() 方法返回的值；对于任何其他值，如果可以通过系统类加载器（请参阅 ClassLoader.getSystemClassLoader()）加载用属性值命名的类，并且该类可以分配给 RMIClassLoaderSpi 且具有一个公共无参数的构造方法，则调用构造方法来创建提供者实例。如果定义了属性，但这些条件的所有其他项都不为 true，则向尝试使用 RMIClassLoader 的代码抛出一个不确定的 Error，以指示获取提供者实例失败。
  • 如果名为 META-INF/services/java.rmi.server.RMIClassLoaderSpi 的资源对于系统类加载器来说是可见的，则将该资源的内容解释为提供者配置文件，并将在该文件中指定的第一个类名称用作提供者类名称。如果可以通过系统类加载器加载具有该名称的类，并且该类可分配给 RMIClassLoaderSpi 且有一个公共无参数的构造方法，则调用该构造方法以创建提供者实例。如果找到了资源，但无法按描述的方式实例化提供者，则向尝试使用 RMIClassLoader 的代码抛出一个不确定的 Error，以指示未成功获得提供者实例。
  • 否则，提供者实例将是通过调用 getDefaultProviderInstance() 方法返回的值。

从以下版本开始：
JDK1.1
另请参见：
RMIClassLoaderSpi

方法摘要
static String | getClassAnnotation(Class<?> cl) 返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。
static ClassLoader | getClassLoader(String codebase) 返回从给定的基本代码 URL 路径加载类的类加载器。
static RMIClassLoaderSpi | getDefaultProviderInstance() 返回服务提供者接口 RMIClassLoaderSpi 的默认提供者的规范化实例。
static Object | getSecurityContext(ClassLoader loader) 已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。
static Class<?> | loadClass(String name) 已过时。 由 loadClass(String,String) 方法取代
static Class<?> | loadClass(String codebase, String name) 从基本代码 URL 路径加载类。
static Class<?> | loadClass(String codebase, String name, ClassLoader defaultLoader) 有选择地使用提供的加载器从基本代码 URL 路径加载类。
static Class<?> | loadClass(URL codebase, String name) 从基本代码 URL 加载类。
static Class<?> | loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader) 从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

loadClass

@Deprecated
public static Class<?> loadClass(String name)
                          throws MalformedURLException,
                                 ClassNotFoundException
已过时。 由 loadClass(String,String) 方法取代

加载具有指定 name 的类。

此方法委托给 loadClass(String,String)，将 null 作为第一个参数，将 name 作为第二个参数进行传递。

参数：
name - 要加载的类的名称
返回：
表示加载的类的 Class 对象
抛出：
MalformedURLException - 如果用于加载类的特定于提供者的 URL 无效
ClassNotFoundException - 如果在基本代码基无法找到该类的定义
另请参见：
loadClass(String,String)

loadClass

public static Class<?> loadClass(URL codebase,
                                 String name)
                          throws MalformedURLException,
                                 ClassNotFoundException
从基本代码 URL 加载类。 如果 codebase 为 null，则此方法将与具有 null、codebase 和给定类名的 loadClass(String,String) 行为相同。

此方法委托给提供者实例的 RMIClassLoaderSpi.loadClass(String,String,ClassLoader) 方法，将在给定 URL 上调用 URL.toString() 的结果（或者如果 codebase 为 null，则为 null）作为第一个参数、name 为第二个参数和 null 为第三个参数进行传递。

参数：
codebase - 要从其加载类的 URL，或 null
name - 要加载的类的名称
返回：
表示加载的类的 Class 对象
抛出：
MalformedURLException - 如果 codebase 为 null 且用于加载类的特定于提供者的 URL 无效
ClassNotFoundException - 如果在指定 URL 无法找到该类的定义

loadClass

public static Class<?> loadClass(String codebase,
                                 String name)
                          throws MalformedURLException,
                                 ClassNotFoundException
从基本代码 URL 路径加载类。

此方法委托给提供者实例的 RMIClassLoaderSpi.loadClass(String,String,ClassLoader) 方法，将 codebase 作为第一个参数、name 为第二个参数和 null 为第三个参数进行传递。

参数：
codebase - 要从其加载类的 URL 的列表（由空格分隔），或者为 null
name - 要加载的类的名称
返回：
表示加载的类的 Class 对象
抛出：
MalformedURLException - 如果 codebase 为非 null 且包含一个无效 URL，或者如果 codebase 为 null 且用于加载类的特定于提供者的 URL 无效。
ClassNotFoundException - 如果在指定位置无法找到该类的定义
从以下版本开始：
1.2

loadClass

public static Class<?> loadClass(String codebase,
                                 String name,
                                 ClassLoader defaultLoader)
                          throws MalformedURLException,
                                 ClassNotFoundException
有选择地使用提供的加载器从基本代码 URL 路径加载类。当调用方想让要考虑的其他上下文类加载器（如堆栈上的调用方加载器）可用于提供者实现时应该使用此方法。通常，提供者实现将试图先使用给定的 defaultLoader（如果指定）解析指定的类，然后才试图从代码基 URL 路径解析该类。

此方法委托给提供者实例的 RMIClassLoaderSpi.loadClass(String,String,ClassLoader) 方法，将 codebase 作为第一个参数、name 为第二个参数和 defaultLoader 为第三个参数进行传递。

参数：
codebase - 要从其加载类的 URL 的列表（由空格分隔），或者为 null
name - 要加载的类的名称
defaultLoader - 要使用的其他上下文类加载器，或 null
返回：
表示加载的类的 Class 对象
抛出：
MalformedURLException - 如果 codebase 为非 null 且包含一个无效 URL，或者如果 codebase 为 null 且用于加载类的特定于提供者的 URL 无效。
ClassNotFoundException - 如果在指定位置无法找到该类的定义
从以下版本开始：
1.4

loadProxyClass

public static Class<?> loadProxyClass(String codebase,
                                      String[] interfaces,
                                      ClassLoader defaultLoader)
                               throws ClassNotFoundException,
                                      MalformedURLException
从基本代码 URL 路径加载一个实现一组具有给定名称的接口的动态代理类（请参阅 Proxy）。

将解析的接口类似于通过使用给定 codebase 的 loadClass(String,String) 方法加载的类。

此方法委托给提供者实例的 RMIClassLoaderSpi.loadProxyClass(String,String[],ClassLoader) 方法，将 codebase 作为第一个参数、interfaces 为第二个参数和 defaultLoader 为第三个参数进行传递。

参数：
codebase - 要从其加载类的 URL 列表（由空格分隔），或 null
interfaces - 要实现的代理类的接口名称
defaultLoader - 要使用的其他上下文类加载器，或 null
返回：
实现指定接口的动态代理类
抛出：
MalformedURLException - 如果 codebase 为非 null 且包含一个无效 URL，或者如果 codebase 为 null 且用于加载类的特定于提供者的 URL 无效。
ClassNotFoundException - 如果在指定位置无法找到某个指定接口的定义，或者如果动态代理类的创建失败（例如，如果 Proxy.getProxyClass(ClassLoader,Class[]) 抛出给定接口列表的 IllegalArgumentException）
从以下版本开始：
1.4

getClassLoader

public static ClassLoader getClassLoader(String codebase)
                                  throws MalformedURLException,
                                         SecurityException
返回从给定的基本代码 URL 路径加载类的类加载器。

返回的类加载器是 loadClass(String,String) 方法将用来加载相同 codebase 参数的类的类加载器。

此方法委托给提供者实例的 RMIClassLoaderSpi.getClassLoader(String) 方法，将 codebase 作为第一个参数进行传递。

如果存在安全管理器，则使用 RuntimePermission("getClassLoader") 权限调用其 checkPermission 方法；这会导致 SecurityException。此方法的提供者实现还可以执行进一步的安全检查，以验证调用上下文是否具有连接到代码基 URL 路径中的所有 URL 的权限。

参数：
codebase - 返回的类加载器将从其加载类的 URL 列表（由空格分隔），或 null
返回：
从给定代码基 URL 路径加载类的类加载器
抛出：
MalformedURLException - 如果 codebase 为非 null 且包含一个无效 URL，或者如果 codebase 为 null 且用于标识类加载器的特定于提供方的 URL 无效
SecurityException - 如果存在安全管理器且其 checkPermission 方法的调用失败，或者如果调用方没有连接到代码基 URL 路径中所有 URL 的权限
从以下版本开始：
1.3

getClassAnnotation

public static String getClassAnnotation(Class<?> cl)
返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。

此方法委托给提供者实例的 RMIClassLoaderSpi.getClassAnnotation(Class) 方法，将 cl 作为第一个参数进行传递。

参数：
cl - 要获得其注释的类
返回：
在编组时用于注释给定类的字符串，或 null
抛出：
NullPointerException - 如果 cl 为 null
从以下版本开始：
1.2

getDefaultProviderInstance

public static RMIClassLoaderSpi getDefaultProviderInstance()
返回服务提供者接口 RMIClassLoaderSpi 的默认提供者的规范化实例。如果未定义系统属性 java.rmi.server.RMIClassLoaderSpi，则 RMIClassLoader 静态方法
  • loadClass(URL,String)
  • loadClass(String,String)
  • loadClass(String,String,ClassLoader)
  • loadProxyClass(String,String[],ClassLoader)
  • getClassLoader(String)
  • getClassAnnotation(Class)
将把默认提供者的规范化实例用作服务提供者实例。

如果存在安全管理器，则使用 RuntimePermission("setFactory") 权限调用其 checkPermission 方法；这会导致 SecurityException。

默认服务提供者实例按以下方式实现 RMIClassLoaderSpi：

getClassAnnotation 方法返回一个表示基本代码 URL 路径的 String，远程方应使用该路径下载指定类的定义。返回的字符串的格式是一个由空格分隔的 URL 路径。 返回的基本代码字符串取决于指定类的定义类加载器：

  • 如果类加载器是系统类加载器（请参阅 ClassLoader.getSystemClassLoader()）、系统类加载器的父级（如，用于安装扩展的加载器） 或引导类加载器（可以用 null 表示），则返回 java.rmi.server.codebase 属性的值（或可能是一个原先的缓存值）；如果未设置该属性，则返回 null。

  • 否则，如果类加载器是 URLClassLoader 的实例，则返回的字符串是一个 URL 的外部形式的由空格分隔的列表，该 URL 通过调用加载器 getURLs 方法返回。如果 URLClassLoader 由此提供者创建，用于调用其 loadClass 或 loadProxyClass 方法，则不需要任何权限即可获取关联的基本代码字符串。如果它是其他任意一个 URLClassLoader 实例，则如果存在安全管理器，则对于 getURLs 方法返回的每个 URL 都要调用一次其 checkPermission 方法（所用的权限为对每个 URL 调用 openConnection().getPermission() 返回的权限）；如果这些调用的任何一个抛出 SecurityException 或 IOException，则返回 java.rmi.server.codebase 属性的值（或可能是原先的缓存值）；如果未设置该属性，则返回 null。

  • 最后，如果类加载器不是 URLClassLoader 的实例，则返回 java.rmi.server.codebase 属性的值（或可能是原先的缓存值）；如果未设置该属性，则返回 null。

对于下面描述的方法的实现，这些实现都采用作为由空格分隔的 URL 列表的名为 codebase 的 String 参数，每个调用都有一个关联的基本代码加载器，它通过将 codebase 与当前线程的上下文类加载器一起使用进行标识（请参阅 Thread.getContextClassLoader()）。存在安全管理器时，此提供者将维护类加载器实例（至少是 URLClassLoader 的实例）的内部表，这些内部表通过其父类加载器及其基本代码 URL 路径（排序的 URL 列表）键入。如果 codebase 为 null，则基本代码 URL 路径是系统属性 java.rmi.server.codebase 的值，或可能是原先的缓存值。对于给定的基本代码 URL 路径（该路径作为 codebase 参数传递到下面给定上下文中的方法之一的调用），基本代码加载器位于具有指定基本代码 URL 路径的表中且当前线程的上下文类加载器是其父级的加载器。如果不存在这样的加载器，则创建一个这样的加载器并将其添加到表中。该表不维护对其包含的加载器的强引用，以便于允许它们及其定义类在不可另外到达时被垃圾回收。为了防止不受信任的任意代码被隐式加载到不带安全管理器的虚拟机中，如果未设置安全管理器，则基本代码加载器就是当前线程的上下文类加载器（提供的基本代码 URL 路径被忽略，所以禁止了远程类加载）。

getClassLoader 方法返回指定基本代码 URL 路径的基本代码加载器。如果存在安全管理器，则如果该调用上下文没有连接到基本代码 URL 路径上的所有 URL 的权限，则抛出 SecurityException。

loadClass 方法尝试按以下方式加载具有指定名称的类：

如果 defaultLoader 为非 null，则它首先尝试使用 defaultLoader 加载具有指定 name 的类，比如通过评估
     Class.forName(name, false, defaultLoader)
如果从 defaultLoader 成功加载了类，则返回该类。如果抛出 ClassNotFoundException 之外的异常，则该异常被抛给调用方。

其次，loadClass 方法尝试使用指定基本代码 URL 路径的基本代码加载器加载具有指定 name 的类。如果存在安全管理器，则该调用上下文必须具有连接到基本代码 URL 上的所有 URL 的权限；否则，将使用当前线程的上下文类加载器，而不是基本代码加载器。

loadProxyClass 方法尝试按以下方式返回具有指定接口的动态代理类：

如果 defaultLoader 参数为非 null 且可以通过该加载器解析所有指定接口，则，

  • 如果所有解析的接口都为 public，则它首先尝试获得在基本代码加载器中定义的解析接口的动态代理类（使用 Proxy.getProxyClass）；如果该尝试抛出一个 IllegalArgumentException，则它尝试获得在 defaultLoader 中定义的解析接口的动态代理类。如果两个尝试都抛出 IllegalArgumentException，则此方法将抛出 ClassNotFoundException。如果抛出任何其他异常，则该异常将被抛给调用方。
  • 如果在同一类加载器中定义所有非 public 解析接口，则其尝试获得在该加载器中定义的解析接口的动态代理类。
  • 否则，抛出 LinkageError（因为实现所有指定接口的类无法在任何加载器中定义）。

否则，如果所有指定的接口可通过基本代码加载器解析，则，

  • 如果所有解析接口都为 public，则它尝试获得基本代码中解析接口的动态代理类。如果该尝试抛出 IllegalArgumentException，则此方法抛出一个 ClassNotFoundException。
  • 如果在同一类加载器中定义所有非 public 解析接口，则它尝试获得在该加载器中定义的解析接口的动态代理类。
  • 否则，抛出 LinkageError（因为实现所有指定接口的类无法在任何加载器中定义）。

否则，将为每个无法解析的指定接口抛出 ClassNotFoundException。

返回：
默认服务提供者的规范化实例
抛出：
SecurityException - 如果存在安全管理器，且其 checkPermission 方法的调用将失败
从以下版本开始：
1.4

getSecurityContext

@Deprecated
public static Object getSecurityContext(ClassLoader loader)
已过时。 无替换版本。从 Java 2 平台 v1.2 开始，RMI 不再使用此方法来获取类加载器的安全上下文。

返回给定类加载器的安全上下文。

参数：
loader - 从其获取安全上下文的类加载器
返回：
安全上下文
另请参见：
SecurityManager.getSecurityContext()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIClassLoaderSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 RMIClassLoaderSpi

java.lang.Object
    继承者  java.rmi.server.RMIClassLoaderSpi

public abstract class RMIClassLoaderSpi
extends Object

RMIClassLoaderSpi 是 RMIClassLoader 的服务提供者接口。尤其是，RMIClassLoaderSpi 接口提供 RMIClassLoader 的以下静态方法的实现：

  • RMIClassLoader.loadClass(URL,String)
  • RMIClassLoader.loadClass(String,String)
  • RMIClassLoader.loadClass(String,String,ClassLoader)
  • RMIClassLoader.loadProxyClass(String,String[],ClassLoader)
  • RMIClassLoader.getClassLoader(String)
  • RMIClassLoader.getClassAnnotation(Class)
当调用这些方法之一时，其行为是向此类的实例委托相应的方法。有关每个方法如何委托给提供者实例的详细信息，在各自特定方法的文档中进行了描述。有关如何选择提供者实例的描述，请参阅 RMIClassLoader 文档。

从以下版本开始：
1.4
另请参见：
RMIClassLoader

构造方法摘要
RMIClassLoaderSpi()
方法摘要
abstract  String getClassAnnotation(Class<?> cl)
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。
abstract  ClassLoader getClassLoader(String codebase)
提供 RMIClassLoader.getClassLoader(String) 的实现。
abstract  Class<?> loadClass(String codebase, String name, ClassLoader defaultLoader)
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。
abstract  Class<?> loadProxyClass(String codebase, String[] interfaces, ClassLoader defaultLoader)
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RMIClassLoaderSpi

public RMIClassLoaderSpi()
方法详细信息

loadClass

public abstract Class<?> loadClass(String codebase,
                                   String name,
                                   ClassLoader defaultLoader)
                            throws MalformedURLException,
                                   ClassNotFoundException
提供 RMIClassLoader.loadClass(URL,String)、RMIClassLoader.loadClass(String,String) 和 RMIClassLoader.loadClass(String,String,ClassLoader) 的实现。选用提供的加载程序，从代码基 URL 路径加载某个类。 通常，提供者实现将试图先使用给定的 defaultLoader（如果指定）解析指定的类，然后才试图从代码基 URL 路径解析该类。

此方法的实现必须返回具有给定名称的一个类，或抛出异常。

参数：
codebase - 要从其加载类的 URL 的列表（由空格分隔），或者为 null
name - 要加载的类名称
defaultLoader - 要使用的其他上下文类加载器，或 null
返回：
表示加载的类的 Class 对象
抛出：
MalformedURLException - 如果 codebase 为非 null 且包含一个无效 URL，或者如果 codebase 为 null 且用于加载类的特定于提供者的 URL 无效。
ClassNotFoundException - 如果在指定位置无法找到该类的定义

loadProxyClass

public abstract Class<?> loadProxyClass(String codebase,
                                        String[] interfaces,
                                        ClassLoader defaultLoader)
                                 throws MalformedURLException,
                                        ClassNotFoundException
提供 RMIClassLoader.loadProxyClass(String,String[],ClassLoader) 的实现。选用提供的加载器，从代码基 URL 路径加载实现一组具有给定名称接口集的动态代理类（请参阅 Proxy）。

此方法的实现必须能返回一个实现指定接口的代理类，或抛出异常。

参数：
codebase - 要从其加载类的 URL 列表（由空格分隔），或 null
interfaces - 要实现的代理类的接口名称
defaultLoader - 要使用的其他上下文类加载器，或 null
返回：
实现指定接口的动态代理类
抛出：
MalformedURLException - 如果 codebase 为非 null 且包含一个无效 URL，或者如果 codebase 为 null 且用于加载类的特定于提供者的 URL 无效。
ClassNotFoundException - 如果在指定位置无法找到某个指定接口的定义，或者如果动态代理类的创建失败（例如，如果 Proxy.getProxyClass(ClassLoader,Class[]) 抛出给定接口列表的 IllegalArgumentException）

getClassLoader

public abstract ClassLoader getClassLoader(String codebase)
                                    throws MalformedURLException
提供 RMIClassLoader.getClassLoader(String) 的实现。返回从给定代码基 URL 路径加载类的类加载器。

如果存在安全管理器，则使用 RuntimePermission("getClassLoader") 权限调用其 checkPermission 方法；这会导致 SecurityException。此方法的实现还可以执行进一步的安全检查，以验证调用上下文是否具有连接到代码基 URL 路径中的所有 URL 的权限。

参数：
codebase - 返回的类加载器将从其加载类的 URL 列表（由空格分隔），或 null
返回：
从给定代码基 URL 路径加载类的类加载器
抛出：
MalformedURLException - 如果 codebase 为非 null 且包含一个无效 URL，或者如果 codebase 为 null 且用于标识类加载器的特定于提供者的 URL 无效
SecurityException - 如果存在安全管理器且其 checkPermission 方法的调用失败，或者如果调用方没有连接到代码基 URL 路径中所有 URL 的权限

getClassAnnotation

public abstract String getClassAnnotation(Class<?> cl)
提供 RMIClassLoader.getClassAnnotation(Class) 的实现。返回表示类定义位置的注释字符串，RMI 将在编组给定类的对象时用其注释类描述符。

参数：
cl - 要获得其注释的类
返回：
在编组时用于注释给定类的字符串，或 null
抛出：
NullPointerException - 如果 cl 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIClientSocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 RMIClientSocketFactory

所有已知实现类：
RMISocketFactory, SslRMIClientSocketFactory
public interface RMIClientSocketFactory

RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。通过构造方法或 java.rmi.server.UnicastRemoteObject 和 java.rmi.activation.Activatable 的 exportObject 方法创建/导出远程对象时，可以将其与 RMIClientSocketFactory 关联。

在 RMI 调用中传送远程对象引用时，将把与远程对象关联的 RMIClientSocketFactory 实例下载到客户机。此 RMIClientSocketFactory 将用于创建到远程方法调用的远程对象的连接。

RMIClientSocketFactory 实例也可以与远程对象注册表关联，所以客户机可以使用自定义套接字与远程对象注册表进行通信。

此接口的实现应该是可序列化的，并且应该实现 Object.equals(java.lang.Object)，以便在传递表示相同（功能上等效）客户机套接字工厂实例时返回 true；传递的实例不同时返回 false（并且它还应实现 Object.hashCode() 与其 Object.equals 实现的一致性）。

从以下版本开始：
1.2
另请参见：
UnicastRemoteObject, Activatable, LocateRegistry

方法摘要
 Socket createSocket(String host, int port)
创建连接到指定主机和端口的客户机套接字。

方法详细信息

createSocket

Socket createSocket(String host,
                    int port)
                    throws IOException
创建连接到指定主机和端口的客户机套接字。

参数：
host - 主机名
port - 端口号
返回：
连接到指定主机和端口的套接字。
抛出：
IOException - 如果在套接字创建过程中发生 I/O 错误
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIFailureHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 RMIFailureHandler

public interface RMIFailureHandler

RMIFailureHandler 可以通过 RMISocketFactory.setFailureHandler 调用注册。当 RMI 运行时不能创建 ServerSocket 来侦听传入调用时，将调用该处理程序的 failure 方法。failure 方法返回 boolean，指示运行时是否应该试图重新创建 ServerSocket。

从以下版本开始：
JDK1.1

方法摘要
 boolean failure(Exception ex)
在 RMI 运行时无法通过 RMISocketFactory 创建 ServerSocket 时调用该 failure 回调。

方法详细信息

failure

boolean failure(Exception ex)
在 RMI 运行时无法通过 RMISocketFactory 创建 ServerSocket 时调用该 failure 回调。RMIFailureHandler 可通过调用 RMISocketFacotry.setFailureHandler 注册。如果没有安装故障处理程序，则默认行为是试图重新创建 ServerSocket。

参数：
ex - 在 ServerSocket 创建过程中发生的异常
返回：
如果 RMI 运行时试图重新尝试 ServerSocket 的创建，则返回 true
从以下版本开始：
JDK1.1
另请参见：
RMISocketFactory.setFailureHandler(RMIFailureHandler)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIServerSocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 RMIServerSocketFactory

所有已知实现类：
RMISocketFactory, SslRMIServerSocketFactory
public interface RMIServerSocketFactory

RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。通过构造方法或 java.rmi.server.UnicastRemoteObject 和 java.rmi.activation.Activatable 的 exportObject 方法创建/导出远程对象时，可以将其与 RMIServerSocketFactory 关联。

使用与远程对象关联的 RMIServerSocketFactory 实例获得用于接受从客户机传入调用的 ServerSocket。

RMIServerSocketFactory 实例也可以与远程对象注册表关联，所以客户机可以使用自定义套接字与远程对象注册表进行通信。

此接口的实现应该是可序列化的，并且应该实现 Object.equals(java.lang.Object)，以便在传递表示相同（功能上等效）服务器套接字工厂实例时返回 true；传递的实例不同时返回 false（并且它还应实现 Object.hashCode() 与其 Object.equals 实现的一致性）。

从以下版本开始：
1.2
另请参见：
UnicastRemoteObject, Activatable, LocateRegistry

方法摘要
 ServerSocket createServerSocket(int port)
在指定端口上（端口 0 指示匿名端口）创建服务器套接字。

方法详细信息

createServerSocket

ServerSocket createServerSocket(int port)
                                throws IOException
在指定端口上（端口 0 指示匿名端口）创建服务器套接字。

参数：
port - 端口号
返回：
指定端口上的服务器套接字
抛出：
IOException - 如果在服务器套接字创建过程中发生 I/O 错误
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerRef (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 ServerRef

所有超级接口：
Externalizable, RemoteRef, Serializable
public interface ServerRef
extends RemoteRef

ServerRef 表示远程对象实现的服务器端句柄。

从以下版本开始：
JDK1.1

字段摘要
static long serialVersionUID
指示与类的 JDK 1.1.x 版本的兼容性。
从接口 java.rmi.server.RemoteRef 继承的字段
packagePrefix
方法摘要
RemoteStub | exportObject(Remote obj, Object data) 为提供的 Remote 对象创建客户机 stub 对象。
String | getClientHost() 返回当前客户机的主机名。
从接口 java.rmi.server.RemoteRef 继承的方法
done, getRefClass, invoke, invoke, newCall, remoteEquals, remoteHashCode, remoteToString
从接口 java.io.Externalizable 继承的方法
readExternal, writeExternal

字段详细信息

serialVersionUID

static final long serialVersionUID
指示与类的 JDK 1.1.x 版本的兼容性。

另请参见：
常量字段值
方法详细信息

exportObject

RemoteStub exportObject(Remote obj,
                        Object data)
                        throws RemoteException
为提供的 Remote 对象创建客户机 stub 对象。如果调用成功完成，则远程对象应该能够接受从客户机传入的调用。

参数：
obj - 远程对象实现
data - 导出该对象需要的信息
返回：
远程对象的 stub
抛出：
RemoteException - 如果试图导出对象时发生异常（如无法找到 stub 类）
从以下版本开始：
JDK1.1

getClientHost

String getClientHost()
                     throws ServerNotActiveException
返回当前客户机的主机名。当从主动处理远程方法调用的线程调用时，将返回客户机的主机名。

返回：
客户机的主机名
抛出：
ServerNotActiveException - 如果在服务于远程方法调用之外调用
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMISocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 RMISocketFactory

java.lang.Object
    继承者  java.rmi.server.RMISocketFactory
所有已实现的接口：
RMIClientSocketFactory, RMIServerSocketFactory
public abstract class RMISocketFactory
extends Object
implements RMIClientSocketFactory, RMIServerSocketFactory

RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。应用程序可以使用 setSocketFactory 方法来请求 RMI 运行时使用其套接字工厂实例而不是使用默认的实现。

所用的默认套接字工厂实现通过三层方法来创建客户机套接字。首先，尝试进行到远程 VM 的直接套接字连接。如果该操作失败（因防火墙的问题），则运行时使用具有服务器显式端口号的 HTTP。如果防火墙不允许此类型的通信，则服务器上的 cgi-bin 脚本的 HTTP 用于 POST（发送）该 RMI 调用。

从以下版本开始：
JDK1.1

构造方法摘要
RMISocketFactory()
构造一个 RMISocketFactory。
方法摘要
abstract ServerSocket | createServerSocket(int port) 在指定端口上（端口 0 指示匿名端口）创建服务器套接字。
abstract Socket | createSocket(String host, int port) 创建连接到指定主机和端口的客户机套接字。
static RMISocketFactory | getDefaultSocketFactory() 返回对此 RMI 实现使用的默认套接字工厂的引用。
static RMIFailureHandler | getFailureHandler() 返回由 setFailureHandler 方法设置的套接字创建失败的处理程序。
static RMISocketFactory | getSocketFactory() 返回由 setSocketFactory 方法设置的套接字工厂。
static void | setFailureHandler(RMIFailureHandler fh) 如果服务器套接字创建失败，则设置将由 RMI 运行时调用的 failure 处理程序。
static void | setSocketFactory(RMISocketFactory fac) 设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RMISocketFactory

public RMISocketFactory()
构造一个 RMISocketFactory。

从以下版本开始：
JDK1.1
方法详细信息

createSocket

public abstract Socket createSocket(String host,
                                    int port)
                             throws IOException
创建连接到指定主机和端口的客户机套接字。

指定者：
接口 RMIClientSocketFactory 中的 createSocket
参数：
host - 主机名
port - 端口号
返回：
连接到指定主机和端口的套接字。
抛出：
IOException - 如果套接字创建过程中发生 I/O 错误
从以下版本开始：
JDK1.1

createServerSocket

public abstract ServerSocket createServerSocket(int port)
                                         throws IOException
在指定端口上（端口 0 指示匿名端口）创建服务器套接字。

指定者：
接口 RMIServerSocketFactory 中的 createServerSocket
参数：
port - 端口号
返回：
指定端口上的服务器套接字
抛出：
IOException - 如果在服务器套接字创建过程中发生 I/O 错误
从以下版本开始：
JDK1.1

setSocketFactory

public static void setSocketFactory(RMISocketFactory fac)
                             throws IOException
设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。RMI 套接字工厂只能设置一次。注：RMISocketFactory 只有在当前安全管理器允许设置套接字工厂的情况下设置；如果不允许，则抛出 SecurityException。

参数：
fac - 套接字工厂
抛出：
IOException - 如果已经设置 RMI 套接字工厂
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许进行此操作。
从以下版本开始：
JDK1.1
另请参见：
getSocketFactory(), SecurityManager.checkSetFactory()

getSocketFactory

public static RMISocketFactory getSocketFactory()
返回由 setSocketFactory 方法设置的套接字工厂。如果尚未设置套接字工厂，则返回 null。

返回：
套接字工厂
从以下版本开始：
JDK1.1
另请参见：
setSocketFactory(RMISocketFactory)

getDefaultSocketFactory

public static RMISocketFactory getDefaultSocketFactory()
返回对此 RMI 实现使用的默认套接字工厂的引用。这将是在 getSocketFactory 返回 null 时由 RMI 运行时使用的工厂。

返回：
默认的 RMI 套接字工厂
从以下版本开始：
JDK1.1

setFailureHandler

public static void setFailureHandler(RMIFailureHandler fh)
如果服务器套接字创建失败，则设置将由 RMI 运行时调用的 failure 处理程序。默认情况下，如果没有安装故障处理程序且服务器套接字创建失败，则 RMI 运行时就尝试重新创建服务器套接字。

如果有安全管理器，则此方法首先调用安全管理器的 checkSetFactory 方法，以确保允许进行此操作。这可能会导致 SecurityException。

参数：
fh - failure 处理程序
抛出：
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许进行此操作。
从以下版本开始：
JDK1.1
另请参见：
getFailureHandler(), RMIFailureHandler.failure(Exception)

getFailureHandler

public static RMIFailureHandler getFailureHandler()
返回由 setFailureHandler 方法设置的套接字创建失败的处理程序。

参数：
failure - 处理程序
从以下版本开始：
JDK1.1
另请参见：
setFailureHandler(RMIFailureHandler)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerCloneException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 ServerCloneException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.CloneNotSupportedException
                继承者  java.rmi.server.ServerCloneException
所有已实现的接口：
Serializable
public class ServerCloneException
extends CloneNotSupportedException

如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。

从版本 1.4 开始，已对此异常作出改进，以符合通用异常链机制。可在构造时提供并通过公共 detail 字段访问的“嵌入的异常”现在称为 cause，该异常也能通过 Throwable.getCause() 方法以及前述的“遗留字段”访问。

在 ServerCloneException 的实例上调用方法 Throwable.initCause(Throwable) 始终抛出 IllegalStateException。

从以下版本开始：
JDK1.1
另请参见：
UnicastRemoteObject.clone(), 序列化表格

字段摘要
 Exception detail
异常原因。
构造方法摘要
ServerCloneException(String s)
构造带指定详细消息的 ServerCloneException。
ServerCloneException(String s, Exception cause)
构造带指定详细消息和原因的 ServerCloneException。
方法摘要
Throwable | getCause() 返回此异常的原因。
String | getMessage() 返回此异常的详细信息，包括原因的消息（如果有）。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

detail

public Exception detail
异常原因。

此字段早于通用异常链设施。Throwable.getCause() 方法现在是获取此信息的首选方法。

构造方法详细信息

ServerCloneException

public ServerCloneException(String s)
构造带指定详细消息的 ServerCloneException。

参数：
s - 详细消息。

ServerCloneException

public ServerCloneException(String s,
                            Exception cause)
构造带指定详细消息和原因的 ServerCloneException。

参数：
s - 详细消息。
cause - 原因
方法详细信息

getMessage

public String getMessage()
返回此异常的详细信息，包括原因的消息（如果有）。

覆盖：
类 Throwable 中的 getMessage
返回：
详细消息

getCause

public Throwable getCause()
返回此异常的原因。此方法返回 detail 字段的值。

覆盖：
类 Throwable 中的 getCause
返回：
原因，它可以为 null。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServerNotActiveException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 ServerNotActiveException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.rmi.server.ServerNotActiveException
所有已实现的接口：
Serializable
public class ServerNotActiveException
extends Exception

如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。

从以下版本开始：
JDK1.1
另请参见：
RemoteServer.getClientHost(), 序列化表格

构造方法摘要
ServerNotActiveException()
构造不带指定详细消息的 ServerNotActiveException。
ServerNotActiveException(String s)
构造带指定详细消息的 ServerNotActiveException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServerNotActiveException

public ServerNotActiveException()
构造不带指定详细消息的 ServerNotActiveException。

从以下版本开始：
JDK1.1

ServerNotActiveException

public ServerNotActiveException(String s)
构造带指定详细消息的 ServerNotActiveException。

参数：
s - 详细消息。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Skeleton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 Skeleton

已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

@Deprecated
public interface Skeleton

Skeleton 接口仅供 RMI 实现单独使用。

由 rmic stub 编译器生成的每个 1.1 版本的 skeleton 类（和使用 rmic -vcompat 的 1.2 生成的 1.1 版本兼容 skeleton）都可实现此接口。远程对象的 skeleton 是一个将调用指派给实际远程对象实现的服务器端实体。

从以下版本开始：
JDK1.1

方法摘要
void | dispatch(Remote obj, RemoteCall theCall, int opnum, long hash) 已过时。 无替代版本
Operation[] | getOperations() 已过时。 无替代版本

方法详细信息

dispatch

@Deprecated
void dispatch(Remote obj,
                         RemoteCall theCall,
                         int opnum,
                         long hash)
              throws Exception
已过时。 无替代版本

解组参数，调用实际远程对象实现和编组返回的值或任何异常。

参数：
obj - 要向其指派调用的远程实现
theCall - 表示远程调用的对象
opnum - 操作数
hash - stub/skeleton 接口哈希
抛出：
Exception - 如果发生常见异常。
从以下版本开始：
JDK1.1

getOperations

@Deprecated
Operation[] getOperations()
已过时。 无替代版本

返回该 skeleton 支持的操作。

返回：
skeleton 支持的操作
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SkeletonMismatchException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 SkeletonMismatchException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.server.SkeletonMismatchException
所有已实现的接口：
Serializable
已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

@Deprecated
public class SkeletonMismatchException
extends RemoteException

当接收到与可用的 skeleton 不匹配的调用时抛出此异常。它指示此接口中的远程方法名称或签名已经更改，或指示用于调用和让 skeleton 接收调用的 stub 类不是由同一版本的 stub 编译器 (rmic) 生成的。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
SkeletonMismatchException(String s)
已过时。 无替代版本
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SkeletonMismatchException

@Deprecated
public SkeletonMismatchException(String s)
已过时。 无替代版本

构造带指定详细消息的 SkeletonMismatchException。

参数：
s - 详细消息
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SkeletonNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 SkeletonNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.server.SkeletonNotFoundException
所有已实现的接口：
Serializable
已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。

@Deprecated
public class SkeletonNotFoundException
extends RemoteException

如果未找到对应于正导出的远程对象的 Skeleton，则抛出 SkeletonNotFoundException。不再需要 Skeleton，所以永远不会抛出此异常。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
SkeletonNotFoundException(String s)
已过时。 构造带指定详细消息的 SkeletonNotFoundException。
SkeletonNotFoundException(String s, Exception ex)
已过时。 构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SkeletonNotFoundException

public SkeletonNotFoundException(String s)
已过时。
构造带指定详细消息的 SkeletonNotFoundException。

参数：
s - 详细消息。
从以下版本开始：
JDK1.1

SkeletonNotFoundException

public SkeletonNotFoundException(String s,
                                 Exception ex)
已过时。
构造带指定详细消息和嵌套异常的 SkeletonNotFoundException。

参数：
s - 详细消息。
ex - 嵌套异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketSecurityException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 SocketSecurityException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  java.rmi.server.ExportException
                        继承者  java.rmi.server.SocketSecurityException
所有已实现的接口：
Serializable
public class SocketSecurityException
extends ExportException

已废弃的 ExportException 的子类。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
SocketSecurityException(String s)
构造带指定详细消息的 SocketSecurityException。
SocketSecurityException(String s, Exception ex)
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SocketSecurityException

public SocketSecurityException(String s)
构造带指定详细消息的 SocketSecurityException。

参数：
s - 详细消息。
从以下版本开始：
JDK1.1

SocketSecurityException

public SocketSecurityException(String s,
                               Exception ex)
构造带指定详细消息和嵌入异常的 SocketSecurityIOException。

参数：
s - 详细消息。
ex - 嵌入异常
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UID (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 UID

java.lang.Object
    继承者  java.rmi.server.UID
所有已实现的接口：
Serializable
public final class UID
extends Object
implements Serializable

UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。

UID() 构造方法可以用来生成一个和生成此标识符的主机的时间有关的唯一标识符。UID(short) 构造方法可以用来创建 216 个熟知标识符之一。

UID 实例包含以下三个基本值：

  • unique，它是一个 int 值，唯一标识在其中生成此 UID 的 VM，并和主机和由 time 值表示的时间有关，（unique 值的示例实现是一个进程标识符），对于熟知 UID 此值为 0。
  • time，它是一个 long 值，其等于此 UID 在其中生成的 VM 处于活动状态时的时间（由 System.currentTimeMillis() 返回），对于熟知 UID 为 0。
  • count，它是一个 short值，以区分用同一 time 值在同一个 VM 中生成的 UID。

单独生成的 UID 实例具有唯一性并和生成它的主机的时间有关，条件是主机启动所需时间超过一毫秒，并且系统时钟从不向后调。可以通过将唯一主机标识符（如 IP 地址）和 UID 实例配对来构造全局唯一标识符。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

构造方法摘要
UID()
生成一个 UID，它和生成它的主机的时间有关且具有唯一性。
UID(short num)
创建一个“熟知”UID。
方法摘要
boolean | equals(Object obj) 比较给定对象与此 UID 的相等性。
int | hashCode() 返回此 UID 的哈希码值。
static UID | read(DataInput in) 通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。
String | toString() 返回此 UID 的字符串表示形式。
void | write(DataOutput out) 将此 UID 的二进制表示形式编组为一个 DataOutput 实例。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

UID

public UID()
生成一个 UID，它和生成它的主机的时间有关且具有唯一性。

UID

public UID(short num)
创建一个“熟知”UID。 可能有 216 个这样的熟知 ID。

通过此构造方法创建的 UID 将不与通过无参数构造方法生成的所有 UID 冲突。

参数：
num - 表示熟知 UID 的数字
方法详细信息

hashCode

public int hashCode()
返回此 UID 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此 UID 的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较给定对象与此 UID 的相等性。 当且仅当指定对象为具有与此对象相同的 unique、time 和 count 值的 UID 实例时，此方法返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此 UID 比较的对象
返回：
如果给定对象与此对象等效，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回此 UID 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 UID 的字符串表示形式

write

public void write(DataOutput out)
           throws IOException
将此 UID 的二进制表示形式编组为一个 DataOutput 实例。

需要特别说明的是，此方法首先要用此 UID 的 unique 值调用给定流的 DataOutput.writeInt(int) 方法，然后用 UID 的 time 值调用该流的 DataOutput.writeLong(long) 方法，接着用此 UID 的 count 值调用该流的 DataOutput.writeShort(int) 方法。

参数：
out - 要将此 UID 写入其中的 DataOutput 实例
抛出：
IOException - 如果在执行此操作时发生 I/O 错误

read

public static UID read(DataInput in)
                throws IOException
通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。

需要特别说明的是，此方法首先要调用给定流的 DataInput.readInt() 方法来读取 unique 值，然后调用该流的 DataInput.readLong() 方法来读取 time 值，接着调用该流的 DataInput.readShort() 方法来读取 count 值，接下来创建并返回一个包含从该流中读取的 unique、time 和 count 值的 UID 实例。

参数：
in - 要从中读取 UID 的 DataInput 实例
返回：
已解组的 UID 实例
抛出：
IOException - 如果在执行此操作时发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnicastRemoteObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
类 UnicastRemoteObject

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteServer
            继承者  java.rmi.server.UnicastRemoteObject
所有已实现的接口：
Serializable, Remote
直接已知子类：
ActivationGroup
public class UnicastRemoteObject
extends RemoteServer

用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

对于下面的构造方法和静态 exportObject 方法，正在导出的远程对象的 stub 按以下方式获得：

  • 如果使用 UnicastRemoteObject.exportObject(Remote) 方法导出该远程对象，则加载 stub 类（通常使用 rmic 工具从远程对象的类预生成）并按以下方式构造 stub 类的实例。
    • “根类”按以下情形确定：如果远程对象的类直接实现扩展 Remote 的接口，则远程对象的类为根类；否则，根类为直接实现扩展 Remote 接口的远程对象类的最具派生能力的超类。
    • 要加载的 stub 类的名称通过连接带有后缀 "_Stub" 的根类的二进制名称确定。
    • 按使用根类的类加载器的名称加载 stub 类。该 stub 类必须扩展 RemoteStub 并且必须有公共构造方法，该构造方法有一个属于类型 RemoteRef 的参数。
    • 最后，用 RemoteRef 构造 stub 类的实例。
  • 如果无法找到适当的 stub 类，或无法加载 stub 类，或创建 stub 实例时出现问题，则抛出 StubNotFoundException。

  • 对于所有其他导出方式：

    • 如果无法加载远程对象的 stub 类（如上所述）或将系统属性 java.rmi.server.ignoreStubClasses 设置为 "true"（不分大小写），则用以下属性构造 Proxy 实例：
      • 代理的实例由远程对象类的类加载器定义。
      • 该代理实现由远程对象类实现的所有远程接口。
      • 代理的调用处理程序是用 RemoteRef 构造的 RemoteObjectInvocationHandler 实例。
      • 如果无法创建代理，则抛出 StubNotFoundException。

    • 否则，将远程对象的 stub 类（如上所述）的实例用作 stub。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
protected | UnicastRemoteObject() 使用匿名端口创建并导出一个新 UnicastRemoteObject 对象。
protected | UnicastRemoteObject(int port) 使用提供的特定端口创建并导出一个新 UnicastRemoteObject 对象。
protected | UnicastRemoteObject(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。
方法摘要
Object | clone() 返回与初始对象不同的远程对象的副本。
static RemoteStub | exportObject(Remote obj) 使用匿名端口导出远程对象，以便能够接收传入的调用。
static Remote | exportObject(Remote obj, int port) 使用提供的特定端口导出远程对象，以便能够接收传入的调用。
static Remote | exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
static boolean | unexportObject(Remote obj, boolean force) 从 RMI 运行时移除远程对象 obj。
从类 java.rmi.server.RemoteServer 继承的方法
getClientHost, getLog, setLog
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnicastRemoteObject

protected UnicastRemoteObject()
                       throws RemoteException
使用匿名端口创建并导出一个新 UnicastRemoteObject 对象。

抛出：
RemoteException - 如果导出对象失败
从以下版本开始：
JDK1.1

UnicastRemoteObject

protected UnicastRemoteObject(int port)
                       throws RemoteException
使用提供的特定端口创建并导出一个新 UnicastRemoteObject 对象。

参数：
port - 远程对象在其上接收调用的端口号（如果 port 为 0，则选择匿名端口）
抛出：
RemoteException - 如果导出对象失败
从以下版本开始：
1.2

UnicastRemoteObject

protected UnicastRemoteObject(int port,
                              RMIClientSocketFactory csf,
                              RMIServerSocketFactory ssf)
                       throws RemoteException
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。

参数：
port - 远程对象在其上接收调用的端口号（如果 port 为 0，则选择匿名端口）
csf - 用于调用远程对象的客户端套接字工厂
ssf - 用于接收远程调用的服务器端套接字工厂
抛出：
RemoteException - 如果导出对象失败
从以下版本开始：
1.2
方法详细信息

clone

public Object clone()
             throws CloneNotSupportedException
返回与初始对象不同的远程对象的副本。

覆盖：
类 Object 中的 clone
返回：
新的远程对象
抛出：
CloneNotSupportedException - 如果因为 RemoteException 复制失败。
从以下版本开始：
JDK1.1
另请参见：
Cloneable

exportObject

public static RemoteStub exportObject(Remote obj)
                               throws RemoteException
使用匿名端口导出远程对象，以便能够接收传入的调用。

参数：
obj - 要导出的远程对象
返回：
远程对象的 stub
抛出：
RemoteException - 如果导出失败
从以下版本开始：
JDK1.1

exportObject

public static Remote exportObject(Remote obj,
                                  int port)
                           throws RemoteException
使用提供的特定端口导出远程对象，以便能够接收传入的调用。

参数：
obj - 要导出的远程对象
port - 要在其上导出对象的端口
返回：
远程对象的 stub
抛出：
RemoteException - 如果导出失败
从以下版本开始：
1.2

exportObject

public static Remote exportObject(Remote obj,
                                  int port,
                                  RMIClientSocketFactory csf,
                                  RMIServerSocketFactory ssf)
                           throws RemoteException
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。

参数：
obj - 要导出的远程对象
port - 在其上导出对象的端口
csf - 用于调用远程对象的客户端套接字工厂
ssf - 用于接收远程调用的服务器端套接字工厂
返回：
远程对象的 stub
抛出：
RemoteException - 如果导出失败
从以下版本开始：
1.2

unexportObject

public static boolean unexportObject(Remote obj,
                                     boolean force)
                              throws NoSuchObjectException
从 RMI 运行时移除远程对象 obj。如果成功，该对象可以不再接受传入的 RMI 调用。如果 force 参数为 true，则不会强行导出该对象，即使挂起远程对象的调用或远程对象仍在进行调用也一样。如果 force 参数为 false，则只有在未挂起且未调用对象的情况下才不会导出该对象。

参数：
obj - 将不导出的远程对象
force - 如果为 true，则即便挂起或正在进行调用也不导出对象；如果为 false，则只有在不挂起或未进行调用时才不导出对象
返回：
如果操作成功，则返回 true；否则返回 false
抛出：
NoSuchObjectException - 如果当前未导出远程对象
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Unreferenced (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.rmi.server
接口 Unreferenced

所有已知实现类：
RMIConnectionImpl
public interface Unreferenced

远程对象实现应该实现 Unreferenced 接口，以便在没有多个引用该对象的客户机时接收通知。

从以下版本开始：
JDK1.1

方法摘要
 void unreferenced()
在运行时确定引用列表（引用远程对象的客户机列表）变空之后的某个时候由 RMI 运行时调用。

方法详细信息

unreferenced

void unreferenced()
在运行时确定引用列表（引用远程对象的客户机列表）变空之后的某个时候由 RMI 运行时调用。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.rmi.server (Java 2 Platform SE 6)

 java.rmi.server
接口
LoaderHandler
RemoteCall
RemoteRef
RMIClientSocketFactory
RMIFailureHandler
RMIServerSocketFactory
ServerRef
Skeleton
Unreferenced
类
LogStream
ObjID
Operation
RemoteObject
RemoteObjectInvocationHandler
RemoteServer
RemoteStub
RMIClassLoader
RMIClassLoaderSpi
RMISocketFactory
UID
UnicastRemoteObject
异常
ExportException
ServerCloneException
ServerNotActiveException
SkeletonMismatchException
SkeletonNotFoundException
SocketSecurityException


java.rmi.server (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.rmi.server

提供支持服务器端 RMI 的类和接口。

请参见：
描述

接口摘要
LoaderHandler | 已过时。 无替代版本
RemoteCall | 已过时。 无替代版本。
RemoteRef | RemoteRef 表示远程对象的句柄。
RMIClientSocketFactory | RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIFailureHandler | RMIFailureHandler 可以通过 RMISocketFactory.setFailureHandler 调用注册。
RMIServerSocketFactory | RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。
ServerRef | ServerRef 表示远程对象实现的服务器端句柄。
Skeleton | 已过时。 无替代版本。
Unreferenced | 远程对象实现应该实现 Unreferenced 接口，以便在没有多个引用该对象的客户机时接收通知。

类摘要
LogStream | 已过时。 无替代版本
ObjID | ObjID 是用于标识导出到 RMI 运行时的远程对象。
Operation | 已过时。 无替代版本
RemoteObject | 该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
RemoteObjectInvocationHandler | 与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
RemoteServer | 该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
RemoteStub | 该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
RMIClassLoader | RMIClassLoader 包含支持用 RMI 进行动态类加载的静态方法。
RMIClassLoaderSpi | RMIClassLoaderSpi 是 RMIClassLoader 的服务提供者接口。
RMISocketFactory | RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。
UID | UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。
UnicastRemoteObject | 用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

异常摘要
ExportException | ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
ServerCloneException | 如果在复制 UnicastRemoteObject 的过程中发生远程异常，则抛出 ServerCloneException。
ServerNotActiveException | 如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
SkeletonMismatchException | 已过时。 无替代版本。
SkeletonNotFoundException | 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
SocketSecurityException | 已废弃的 ExportException 的子类。

软件包 java.rmi.server 的描述

提供支持服务器端 RMI 的类和接口。一组由 rmic stub 编译器生成的 stub 和 skeleton 使用的类。另一组类实现 RMI 传输协议和 HTTP 隧道传输。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.rmi.server 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.server 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.rmi.server.ObjID (implements java.io.Serializable)
    • java.rmi.server.Operation
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.io.PrintStream (implements java.lang.Appendable, java.io.Closeable)
          • java.rmi.server.LogStream
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteObjectInvocationHandler (implements java.lang.reflect.InvocationHandler)
      • java.rmi.server.RemoteServer
        • java.rmi.server.UnicastRemoteObject
      • java.rmi.server.RemoteStub
    • java.rmi.server.RMIClassLoader
    • java.rmi.server.RMIClassLoaderSpi
    • java.rmi.server.RMISocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.rmi.server.RMIServerSocketFactory)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.CloneNotSupportedException
          • java.rmi.server.ServerCloneException
        • java.io.IOException
          • java.rmi.RemoteException
            • java.rmi.server.ExportException
              • java.rmi.server.SocketSecurityException
            • java.rmi.server.SkeletonMismatchException
            • java.rmi.server.SkeletonNotFoundException
        • java.rmi.server.ServerNotActiveException
    • java.rmi.server.UID (implements java.io.Serializable)

接口分层结构

  • java.rmi.server.LoaderHandler
  • java.rmi.server.RemoteCall
  • java.rmi.server.RMIClientSocketFactory
  • java.rmi.server.RMIFailureHandler
  • java.rmi.server.RMIServerSocketFactory
  • java.io.Serializable
    • java.io.Externalizable
      • java.rmi.server.RemoteRef
        • java.rmi.server.ServerRef
  • java.rmi.server.Skeleton
  • java.rmi.server.Unreferenced
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.rmi.server 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.rmi.server
的使用

使用 java.rmi.server 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.rmi.activation 使用的 java.rmi.server 中的类
RemoteObject
该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
RemoteRef
RemoteRef 表示远程对象的句柄。
RemoteServer
该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
RemoteStub
该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
RMIClientSocketFactory
RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIServerSocketFactory
RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。
UnicastRemoteObject
用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

java.rmi.dgc 使用的 java.rmi.server 中的类
ObjID
ObjID 是用于标识导出到 RMI 运行时的远程对象。

java.rmi.registry 使用的 java.rmi.server 中的类
RMIClientSocketFactory
RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIServerSocketFactory
RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。

java.rmi.server 使用的 java.rmi.server 中的类
ExportException
ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
LogStream
已过时。 无替代版本
ObjID
ObjID 是用于标识导出到 RMI 运行时的远程对象。
Operation
已过时。 无替代版本
RemoteCall
已过时。 无替代版本。
RemoteObject
该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
RemoteRef
RemoteRef 表示远程对象的句柄。
RemoteServer
该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
RemoteStub
该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
RMIClassLoaderSpi
RMIClassLoaderSpi 是 RMIClassLoader 的服务提供者接口。
RMIClientSocketFactory
RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIFailureHandler
RMIFailureHandler 可以通过 RMISocketFactory.setFailureHandler 调用注册。
RMIServerSocketFactory
RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。
RMISocketFactory
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。
ServerNotActiveException
如果在服务于远程方法调用之外调用 getClientHost 方法，则 ServerNotActiveException 是在调用 RemoteServer.getClientHost 的过程中抛出的 Exception。
UID
UID 表示一个和生成它的主机的时间有关的唯一标识符，或者是 216 个“熟知”标识符之一。

javax.management.remote.rmi 使用的 java.rmi.server 中的类
RemoteObject
该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
RemoteRef
RemoteRef 表示远程对象的句柄。
RemoteStub
该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
RMIClientSocketFactory
RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIServerSocketFactory
RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。
Unreferenced
远程对象实现应该实现 Unreferenced 接口，以便在没有多个引用该对象的客户机时接收通知。

javax.rmi.ssl 使用的 java.rmi.server 中的类
RMIClientSocketFactory
RMIClientSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的客户机套接字。
RMIServerSocketFactory
RMIServerSocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用的服务器套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.ExportException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ExportException
的使用

使用 ExportException 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 ExportException 的使用

java.rmi.server 中 ExportException 的子类
 class SocketSecurityException
已废弃的 ExportException 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.LoaderHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.LoaderHandler
的使用

没有 java.rmi.server.LoaderHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.LogStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.LogStream
的使用

使用 LogStream 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 LogStream 的使用

返回 LogStream 的 java.rmi.server 中的方法
static LogStream LogStream.log(String name)
已过时。 无替代版本

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.ObjID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ObjID
的使用

使用 ObjID 的软件包
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。

java.rmi.dgc 中 ObjID 的使用

参数类型为 ObjID 的 java.rmi.dgc 中的方法
void | DGC.clean(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong) 洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。
Lease | DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease) 脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

java.rmi.server 中 ObjID 的使用

返回 ObjID 的 java.rmi.server 中的方法
static ObjID ObjID.read(ObjectInput in)
通过从 ObjectInput 实例解组二进制表示形式来构造和返回一个新的 ObjID 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.Operation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.Operation
的使用

使用 Operation 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 Operation 的使用

返回 Operation 的 java.rmi.server 中的方法
 Operation[] Skeleton.getOperations()
已过时。 无替代版本

参数类型为 Operation 的 java.rmi.server 中的方法
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.RMIClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RMIClassLoader
的使用

没有 java.rmi.server.RMIClassLoader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.RMIClassLoaderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RMIClassLoaderSpi
的使用

使用 RMIClassLoaderSpi 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RMIClassLoaderSpi 的使用

返回 RMIClassLoaderSpi 的 java.rmi.server 中的方法
static RMIClassLoaderSpi RMIClassLoader.getDefaultProviderInstance()
返回服务提供者接口 RMIClassLoaderSpi 的默认提供者的规范化实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.RMIClientSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RMIClientSocketFactory
的使用

使用 RMIClientSocketFactory 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.rmi.activation 中 RMIClientSocketFactory 的使用

参数类型为 RMIClientSocketFactory 的 java.rmi.activation 中的方法
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 RMIClientSocketFactory 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

java.rmi.registry 中 RMIClientSocketFactory 的使用

参数类型为 RMIClientSocketFactory 的 java.rmi.registry 中的方法
static Registry | LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
static Registry | LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf) 返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。

java.rmi.server 中 RMIClientSocketFactory 的使用

实现 RMIClientSocketFactory 的 java.rmi.server 中的类
 class RMISocketFactory
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。

参数类型为 RMIClientSocketFactory 的 java.rmi.server 中的方法
static Remote UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。

参数类型为 RMIClientSocketFactory 的 java.rmi.server 中的构造方法
UnicastRemoteObject(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。

javax.management.remote.rmi 中 RMIClientSocketFactory 的使用

参数类型为 RMIClientSocketFactory 的 javax.management.remote.rmi 中的构造方法
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

javax.rmi.ssl 中 RMIClientSocketFactory 的使用

实现 RMIClientSocketFactory 的 javax.rmi.ssl 中的类
 class SslRMIClientSocketFactory
SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.RMIFailureHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RMIFailureHandler
的使用

使用 RMIFailureHandler 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RMIFailureHandler 的使用

返回 RMIFailureHandler 的 java.rmi.server 中的方法
static RMIFailureHandler RMISocketFactory.getFailureHandler()
返回由 setFailureHandler 方法设置的套接字创建失败的处理程序。

参数类型为 RMIFailureHandler 的 java.rmi.server 中的方法
static void RMISocketFactory.setFailureHandler(RMIFailureHandler fh)
如果服务器套接字创建失败，则设置将由 RMI 运行时调用的 failure 处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.RMIServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RMIServerSocketFactory
的使用

使用 RMIServerSocketFactory 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi.ssl | 通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

java.rmi.activation 中 RMIServerSocketFactory 的使用

参数类型为 RMIServerSocketFactory 的 java.rmi.activation 中的方法
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 RMIServerSocketFactory 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

java.rmi.registry 中 RMIServerSocketFactory 的使用

参数类型为 RMIServerSocketFactory 的 java.rmi.registry 中的方法
static Registry LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。

java.rmi.server 中 RMIServerSocketFactory 的使用

实现 RMIServerSocketFactory 的 java.rmi.server 中的类
 class RMISocketFactory
RMISocketFactory 实例由 RMI 运行时使用，以便获得 RMI 调用所需的客户机和服务器套接字。

参数类型为 RMIServerSocketFactory 的 java.rmi.server 中的方法
static Remote UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。

参数类型为 RMIServerSocketFactory 的 java.rmi.server 中的构造方法
UnicastRemoteObject(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。

javax.management.remote.rmi 中 RMIServerSocketFactory 的使用

参数类型为 RMIServerSocketFactory 的 javax.management.remote.rmi 中的构造方法
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

javax.rmi.ssl 中 RMIServerSocketFactory 的使用

实现 RMIServerSocketFactory 的 javax.rmi.ssl 中的类
 class SslRMIServerSocketFactory
SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.RMISocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RMISocketFactory
的使用

使用 RMISocketFactory 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RMISocketFactory 的使用

返回 RMISocketFactory 的 java.rmi.server 中的方法
static RMISocketFactory | RMISocketFactory.getDefaultSocketFactory() 返回对此 RMI 实现使用的默认套接字工厂的引用。
static RMISocketFactory | RMISocketFactory.getSocketFactory() 返回由 setSocketFactory 方法设置的套接字工厂。

参数类型为 RMISocketFactory 的 java.rmi.server 中的方法
static void RMISocketFactory.setSocketFactory(RMISocketFactory fac)
设置 RMI 从中获取套接字的全局套接字工厂（如果远程对象与指定客户机和/或服务器套接字工厂无关）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.RemoteCall 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RemoteCall
的使用

使用 RemoteCall 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 RemoteCall 的使用

返回 RemoteCall 的 java.rmi.server 中的方法
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

参数类型为 RemoteCall 的 java.rmi.server 中的方法
 void Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash)
已过时。 无替代版本
 void RemoteRef.done(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
 void RemoteRef.invoke(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.RemoteObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteObject
的使用

使用 RemoteObject 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 RemoteObject 的使用

java.rmi.activation 中 RemoteObject 的子类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

java.rmi.server 中 RemoteObject 的使用

java.rmi.server 中 RemoteObject 的子类
class | RemoteObjectInvocationHandler 与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
class | RemoteServer 该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
class | RemoteStub 该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
class | UnicastRemoteObject 用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

参数类型为 RemoteObject 的 java.rmi.server 中的方法
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

javax.management.remote.rmi 中 RemoteObject 的使用

javax.management.remote.rmi 中 RemoteObject 的子类
class | RMIConnectionImpl_Stub
class | RMIServerImpl_Stub

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.RemoteObjectInvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteObjectInvocationHandler
的使用

没有 java.rmi.server.RemoteObjectInvocationHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.RemoteRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.RemoteRef
的使用

使用 RemoteRef 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 RemoteRef 的使用

参数类型为 RemoteRef 的 java.rmi.activation 中的构造方法
ActivationGroup_Stub(RemoteRef ref)
为 ActivationGroup 类构造一个 stub。

java.rmi.server 中 RemoteRef 的使用

java.rmi.server 中 RemoteRef 的子接口
 interface ServerRef
ServerRef 表示远程对象实现的服务器端句柄。

声明为 RemoteRef 的 java.rmi.server 中的字段
protected  RemoteRef RemoteObject.ref
对象的远程引用。

返回 RemoteRef 的 java.rmi.server 中的方法
 RemoteRef RemoteObject.getRef()
返回远程对象的远程引用。

参数类型为 RemoteRef 的 java.rmi.server 中的方法
boolean | RemoteRef.remoteEquals(RemoteRef obj) 比较两个远程对象是否相等。
protected static void | RemoteStub.setRef(RemoteStub stub, RemoteRef ref) 已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。

参数类型为 RemoteRef 的 java.rmi.server 中的构造方法
RemoteObject(RemoteRef newref)
创建一个用指定远程引用初始化的远程对象。
RemoteObjectInvocationHandler(RemoteRef ref)
创建一个用指定 RemoteRef 构造的新 RemoteObjectInvocationHandler。
RemoteServer(RemoteRef ref)
构造带指定引用类型的 RemoteServer。
RemoteStub(RemoteRef ref)
构造带指定远程引用的 RemoteStub。

javax.management.remote.rmi 中 RemoteRef 的使用

参数类型为 RemoteRef 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl_Stub(RemoteRef ref)
RMIServerImpl_Stub(RemoteRef ref)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.RemoteServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteServer
的使用

使用 RemoteServer 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。

java.rmi.activation 中 RemoteServer 的使用

java.rmi.activation 中 RemoteServer 的子类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。

java.rmi.server 中 RemoteServer 的使用

java.rmi.server 中 RemoteServer 的子类
 class UnicastRemoteObject
用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.RemoteStub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.RemoteStub
的使用

使用 RemoteStub 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 RemoteStub 的使用

java.rmi.activation 中 RemoteStub 的子类
 class ActivationGroup_Stub
ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

java.rmi.server 中 RemoteStub 的使用

返回 RemoteStub 的 java.rmi.server 中的方法
static RemoteStub | UnicastRemoteObject.exportObject(Remote obj) 使用匿名端口导出远程对象，以便能够接收传入的调用。
RemoteStub | ServerRef.exportObject(Remote obj, Object data) 为提供的 Remote 对象创建客户机 stub 对象。

参数类型为 RemoteStub 的 java.rmi.server 中的方法
protected static void RemoteStub.setRef(RemoteStub stub, RemoteRef ref)
已过时。 无替换版本。因为可以用 RemoteStub(RemoteRef) 构造方法创建 RemoteStub，所以不需要 setRef 方法。

javax.management.remote.rmi 中 RemoteStub 的使用

javax.management.remote.rmi 中 RemoteStub 的子类
class | RMIConnectionImpl_Stub
class | RMIServerImpl_Stub

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.ServerCloneException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ServerCloneException
的使用

没有 java.rmi.server.ServerCloneException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.ServerNotActiveException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.ServerNotActiveException
的使用

使用 ServerNotActiveException 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 ServerNotActiveException 的使用

抛出 ServerNotActiveException 的 java.rmi.server 中的方法
static String | RemoteServer.getClientHost() 返回一个客户机主机的字符串表示形式，用于在当前线程中正在处理的远程方法调用。
String | ServerRef.getClientHost() 返回当前客户机的主机名。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.ServerRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.ServerRef
的使用

没有 java.rmi.server.ServerRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.Skeleton 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.Skeleton
的使用

没有 java.rmi.server.Skeleton 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.SkeletonMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.SkeletonMismatchException
的使用

没有 java.rmi.server.SkeletonMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.SkeletonNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.SkeletonNotFoundException
的使用

没有 java.rmi.server.SkeletonNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.SocketSecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.SocketSecurityException
的使用

没有 java.rmi.server.SocketSecurityException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.UID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.UID
的使用

使用 UID 的软件包
java.rmi.server 提供支持服务器端 RMI 的类和接口。

java.rmi.server 中 UID 的使用

返回 UID 的 java.rmi.server 中的方法
static UID UID.read(DataInput in)
通过从 DataInput 实例解组二进制表示形式构造并返回一个新的 UID。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.server.UnicastRemoteObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.server.UnicastRemoteObject
的使用

使用 UnicastRemoteObject 的软件包
java.rmi.activation 为 RMI 对象激活提供支持。

java.rmi.activation 中 UnicastRemoteObject 的使用

java.rmi.activation 中 UnicastRemoteObject 的子类
 class ActivationGroup
ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.server.Unreferenced 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.server.Unreferenced
的使用

使用 Unreferenced 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 Unreferenced 的使用

实现 Unreferenced 的 javax.management.remote.rmi 中的类
 class RMIConnectionImpl
RMIConnection 接口的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.AccessException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.AccessException
的使用

使用 AccessException 的软件包
java.rmi.registry 提供 RMI 注册表的一个类和两个接口。

java.rmi.registry 中 AccessException 的使用

抛出 AccessException 的 java.rmi.registry 中的方法
void | Registry.bind(String name, Remote obj) 绑定对此注册表中指定 name 的远程引用。
String[] | Registry.list() 返回在此注册表中绑定的名称的数组。
Remote | Registry.lookup(String name) 返回注册表中绑定到指定 name 的远程引用。
void | Registry.rebind(String name, Remote obj) 用提供的远程引用替换此注册表中指定的 name 绑定。
void | Registry.unbind(String name) 移除此注册表中指定的 name 绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.AlreadyBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.AlreadyBoundException
的使用

使用 AlreadyBoundException 的软件包
java.rmi | 提供 RMI 包。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。

java.rmi 中 AlreadyBoundException 的使用

抛出 AlreadyBoundException 的 java.rmi 中的方法
static void Naming.bind(String name, Remote obj)
将指定 name 绑定到远程对象。

java.rmi.registry 中 AlreadyBoundException 的使用

抛出 AlreadyBoundException 的 java.rmi.registry 中的方法
 void Registry.bind(String name, Remote obj)
绑定对此注册表中指定 name 的远程引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.ConnectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ConnectException
的使用

没有 java.rmi.ConnectException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.ConnectIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ConnectIOException
的使用

没有 java.rmi.ConnectIOException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.MarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.MarshalException
的使用

没有 java.rmi.MarshalException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.MarshalledObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.MarshalledObject
的使用

使用 MarshalledObject 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.rmi.activation 中 MarshalledObject 的使用

返回 MarshalledObject 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
MarshalledObject<?> | ActivationDesc.getData() 为此描述符指定的对象返回包含初始化/激活数据的“编组对象”。
MarshalledObject<?> | ActivationGroupDesc.getData() 返回组的初始化数据。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。

参数类型为 MarshalledObject 的 java.rmi.activation 中的方法
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。

参数类型为 MarshalledObject 的 java.rmi.activation 中的构造方法
Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(ActivationGroupID groupID, String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码的 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationDesc(String className, String location, MarshalledObject<?> data, boolean restart)
为类名为 className 的对象构造一个对象描述符，这可从代码 location 处加载，并且其初始化信息为 data。
ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

javax.management.remote.rmi 中 MarshalledObject 的使用

参数类型为 MarshalledObject 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.Naming 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.Naming
的使用

没有 java.rmi.Naming 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.NoSuchObjectException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.NoSuchObjectException
的使用

使用 NoSuchObjectException 的软件包
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。

java.rmi.activation 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 java.rmi.activation 中的方法
static boolean Activatable.unexportObject(Remote obj, boolean force)
从 RMI 运行库中移除远程对象 obj。

java.rmi.server 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 java.rmi.server 中的方法
static Remote | RemoteObject.toStub(Remote obj) 返回作为参数传递的远程对象 obj 的 stub。
static boolean | UnicastRemoteObject.unexportObject(Remote obj, boolean force) 从 RMI 运行时移除远程对象 obj。

javax.rmi 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 javax.rmi 中的方法
static Remote | PortableRemoteObject.toStub(Remote obj) 返回给定服务器对象的 stub。
static void | PortableRemoteObject.unexportObject(Remote obj) 从运行时注销服务器对象，允许对象用于垃圾回收。

javax.rmi.CORBA 中 NoSuchObjectException 的使用

抛出 NoSuchObjectException 的 javax.rmi.CORBA 中的方法
 void Tie.deactivate()
取消激活此 tie 表示的目标对象。
 Remote PortableRemoteObjectDelegate.toStub(Remote obj)
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。
 void PortableRemoteObjectDelegate.unexportObject(Remote obj)
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。
static void Util.unexportObject(Remote target)
从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。
 void UtilDelegate.unexportObject(Remote target)
Util.unexportObject(java.rmi.Remote) 的委托调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.NotBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.NotBoundException
的使用

使用 NotBoundException 的软件包
java.rmi | 提供 RMI 包。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。

java.rmi 中 NotBoundException 的使用

抛出 NotBoundException 的 java.rmi 中的方法
static Remote | Naming.lookup(String name) 返回与指定 name 关联的远程对象的引用（一个 stub）。
static void | Naming.unbind(String name) 销毁与远程对象关联的指定名称的绑定。

java.rmi.registry 中 NotBoundException 的使用

抛出 NotBoundException 的 java.rmi.registry 中的方法
Remote | Registry.lookup(String name) 返回注册表中绑定到指定 name 的远程引用。
void | Registry.unbind(String name) 移除此注册表中指定的 name 绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.RMISecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.RMISecurityException
的使用

没有 java.rmi.RMISecurityException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.RMISecurityManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.RMISecurityManager
的使用

没有 java.rmi.RMISecurityManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.RemoteException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.RemoteException
的使用

使用 RemoteException 的软件包
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.activity | 包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
javax.transaction | 包含解组期间通过 ORB 机制抛出的三个异常。

java.rmi 中 RemoteException 的使用

java.rmi 中 RemoteException 的子类
class | AccessException AccessException 由 java.rmi.Naming 类（特别是 bind、rebind 和 unbind）的某些方法和 java.rmi.activation.ActivationSystem 接口的方法抛出，以指示调用方不允许执行该方法调用所请求的操作。
class | ConnectException 如果拒绝远程主机对连接的远程方法调用，则抛出 ConnectException。
class | ConnectIOException 如果在连接到远程主机以便进行远程方法调用时发生 IOException，则抛出 ConnectIOException。
class | MarshalException 如果在编组远程调用标题、参数或远程方法调用的返回值时发生 java.io.IOException，则抛出 MarshalException。
class | NoSuchObjectException 如果试图调用远程虚拟机上已不存在的对象上的方法，则抛出 NoSuchObjectException。
class | ServerError 当在服务器上处理远程方法调用时（既可以是解编参数、执行远程方法本身时，也可以是编组返回值时），如果抛出 Error，则作为远程方法调用的结果，将抛出 ServerError。
class | ServerException 在服务器上处理远程方法调用（既可以在解编参数时，也可以是在执行远程方法本身时）时，如果抛出 RemoteException，则作为远程方法调用的结果，也会抛出 ServerException。
class | ServerRuntimeException 已过时。 无替换版本
class | StubNotFoundException 如果在导入某个远程对象时无法找到该对象的有效 stub 类，则抛出 StubNotFoundException。
class | UnexpectedException 如果远程方法调用的客户机因为该调用而收到一个未经检查的异常（该异常不属于远程接口方法的 throws 语句中声明的经检查的异常类型），则抛出 UnexpectedException。
class | UnknownHostException 如果在创建到远程主机的连接以便进行远程方法调用时发生 java.net.UnknownHostException，则抛出 UnknownHostException。
class | UnmarshalException 在解组参数时或者如果发生以下任何情况导致远程方法调用，则抛出 UnmarshalException： 如果在解组调用标题时发生异常 如果返回值的协议无效 如果解组参数（在服务器端）或返回值（在客户机端）时发生 java.io.IOException。

抛出 RemoteException 的 java.rmi 中的方法
static void | Naming.bind(String name, Remote obj) 将指定 name 绑定到远程对象。
static String[] | Naming.list(String name) 返回在注册表中绑定的名称所组成的数组。
static Remote | Naming.lookup(String name) 返回与指定 name 关联的远程对象的引用（一个 stub）。
static void | Naming.rebind(String name, Remote obj) 将指定名称重新绑定到一个新的远程对象。
static void | Naming.unbind(String name) 销毁与远程对象关联的指定名称的绑定。

java.rmi.activation 中 RemoteException 的使用

java.rmi.activation 中 RemoteException 的子类
 class ActivateFailedException
在一个对可激活对象的远程调用过程中，当激活失败时，此异常由 RMI 运行时抛出。

抛出 RemoteException 的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
ActivationMonitor | ActivationSystem.activeGroup(ActivationGroupID id, ActivationInstantiator group, long incarnation) 通过回调来通知激活系统该组现在是活动的。
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationDesc | ActivationSystem.getActivationDesc(ActivationID id) 为具有该激活标识符 id 的对象返回激活描述符。
ActivationGroupDesc | ActivationSystem.getActivationGroupDesc(ActivationGroupID id) 为具有该激活组标识符 id 的组返回激活组描述符。
static boolean | Activatable.inactive(ActivationID id) 通知系统具有相应激活 id 的对象目前没有处于活动状态的。
protected void | ActivationGroup.inactiveGroup() 如果子类要进行对组监视器的 inactiveGroup 回调，则此 protected 方法是必要的。
void | ActivationMonitor.inactiveGroup(ActivationGroupID id, long incarnation) 通知该组现在是不活动的。
boolean | ActivationGroup.inactiveObject(ActivationID id) 通过调用 Activatable.inactive 方法间接地调用组的 inactiveObject 方法。
void | ActivationMonitor.inactiveObject(ActivationID id) 当组中的一个对象成为不活动（取消激活）时，一个激活组调用其监视器的 inactiveObject 方法。
MarshalledObject | ActivationGroup_Stub.newInstance(ActivationID id, ActivationDesc desc) ActivationGroup.newInstance 的 stub 方法。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。
ActivationGroupID | ActivationSystem.registerGroup(ActivationGroupDesc desc) 注册激活组。
ActivationID | ActivationSystem.registerObject(ActivationDesc desc) registerObject 方法用于注册一个激活描述符 desc，并且为可激活的远程对象获取一个激活标识符。
ActivationDesc | ActivationSystem.setActivationDesc(ActivationID id, ActivationDesc desc) 为具有激活标识符 id 的对象设置激活描述符 desc。
ActivationGroupDesc | ActivationSystem.setActivationGroupDesc(ActivationGroupID id, ActivationGroupDesc desc) 为具有激活组标识符 id 的对象设置激活组描述符 desc。
void | ActivationSystem.shutdown() 关闭此激活系统。
static void | Activatable.unregister(ActivationID id) 为与 id 关联的激活描述符撤消前面的注册。
void | ActivationSystem.unregisterGroup(ActivationGroupID id) 移除激活组。
void | ActivationSystem.unregisterObject(ActivationID id) 移除前面通过 ActivationSystem 注册的激活 id 和描述符；该对象无法再通过对象的激活 id 被激活。

抛出 RemoteException 的 java.rmi.activation 中的构造方法
Activatable(ActivationID id, int port)
构造方法用于在指定端口上激活/导出对象。
Activatable(ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造方法用于在指定端口上激活/导出对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port)
构造一个可激活的远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
Activatable(String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
构造一个可激活远程对象：注册此对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
ActivationGroup(ActivationGroupID groupID)
用给定的激活组标识符创建一个激活组。

java.rmi.dgc 中 RemoteException 的使用

抛出 RemoteException 的 java.rmi.dgc 中的方法
void | DGC.clean(ObjID[] ids, long sequenceNum, VMID vmid, boolean strong) 洁调用从 'ids' 指示的每个远程对象的引用列表中移除 'vmid'。
Lease | DGC.dirty(ObjID[] ids, long sequenceNum, Lease lease) 脏调用为（与包含在数组 'ids' 中的对象标识符关联的）远程对象引用请求租借。

java.rmi.registry 中 RemoteException 的使用

抛出 RemoteException 的 java.rmi.registry 中的方法
void | Registry.bind(String name, Remote obj) 绑定对此注册表中指定 name 的远程引用。
static Registry | LocateRegistry.createRegistry(int port) 创建并导出接受指定 port 请求的本地主机上的 Registry 实例。
static Registry | LocateRegistry.createRegistry(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 在本地主机上创建并导出 Registry 实例，该本地主机使用的是与该实例通信的自定义套接字工厂。
static Registry | LocateRegistry.getRegistry() 返回本地主机在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(int port) 返回本地主机在指定 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host) 返回指定 host 在默认注册表端口 1099 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port) 返回指定的 host 和 port 上对远程对象 Registry 的引用。
static Registry | LocateRegistry.getRegistry(String host, int port, RMIClientSocketFactory csf) 返回本地创建的指定 host 和 port 上对远程对象 Registry 的远程引用。
String[] | Registry.list() 返回在此注册表中绑定的名称的数组。
Remote | Registry.lookup(String name) 返回注册表中绑定到指定 name 的远程引用。
void | Registry.rebind(String name, Remote obj) 用提供的远程引用替换此注册表中指定的 name 绑定。
Registry | RegistryHandler.registryImpl(int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的实现。
Registry | RegistryHandler.registryStub(String host, int port) 已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。
void | Registry.unbind(String name) 移除此注册表中指定的 name 绑定。

java.rmi.server 中 RemoteException 的使用

java.rmi.server 中 RemoteException 的子类
class | ExportException ExportException 是在尝试导出远程对象失败时抛出的 RemoteException。
class | SkeletonMismatchException 已过时。 无替代版本。在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SkeletonNotFoundException 已过时。 无替代版本在 Java 2 平台 1.2 版及更高版本中，远程方法调用不再需要 Skeleton。
class | SocketSecurityException 已废弃的 ExportException 的子类。

抛出 RemoteException 的 java.rmi.server 中的方法
 void RemoteRef.done(RemoteCall call)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值解组，而不是使用对远程引用（newCall、invoke 和 done）的方法调用序列。
static RemoteStub UnicastRemoteObject.exportObject(Remote obj)
使用匿名端口导出远程对象，以便能够接收传入的调用。
static Remote UnicastRemoteObject.exportObject(Remote obj, int port)
使用提供的特定端口导出远程对象，以便能够接收传入的调用。
static Remote UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
 RemoteStub ServerRef.exportObject(Remote obj, Object data)
为提供的 Remote 对象创建客户机 stub 对象。
 RemoteCall RemoteRef.newCall(RemoteObject obj, Operation[] op, int opnum, long hash)
已过时。 1.2 样式 stub 不再使用此方法。stub 使用远程引用上的单个方法 invoke(Remote, Method, Object[], int) 来执行参数编组、远程方法执行和返回值的解组，而不是使用该 stub 的远程引用（newCall、invoke 和 done）上的方法调用序列。

抛出 RemoteException 的 java.rmi.server 中的构造方法
UnicastRemoteObject()
使用匿名端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int port)
使用提供的特定端口创建并导出一个新 UnicastRemoteObject 对象。
UnicastRemoteObject(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf)
使用提供的特定端口和套接字工厂创建并导出一个新 UnicastRemoteObject 对象。

javax.activity 中 RemoteException 的使用

javax.activity 中 RemoteException 的子类
class | ActivityCompletedException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
class | ActivityRequiredException 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
class | InvalidActivityException 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

javax.management.remote.rmi 中 RemoteException 的使用

抛出 RemoteException 的 javax.management.remote.rmi 中的方法
String | RMIServer.getVersion() 此连接器服务器能识别的 RMI 连接协议版本。
String | RMIServerImpl_Stub.getVersion()

javax.rmi 中 RemoteException 的使用

抛出 RemoteException 的 javax.rmi 中的方法
static void | PortableRemoteObject.connect(Remote target, Remote source) 使 Remote 对象准备好进行远程通信。
static void | PortableRemoteObject.exportObject(Remote obj) 准备服务器对象，以接收远程调用。

抛出 RemoteException 的 javax.rmi 中的构造方法
PortableRemoteObject()
通过调用 exportObject(this) 初始化该对象。

javax.rmi.CORBA 中 RemoteException 的使用

返回 RemoteException 的 javax.rmi.CORBA 中的方法
static RemoteException Util.mapSystemException(SystemException ex)
将 SystemException 映射到 RemoteException。
 RemoteException UtilDelegate.mapSystemException(SystemException ex)
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。
static RemoteException Util.wrapException(Throwable orig)
包装由实现方法抛出的异常。
 RemoteException UtilDelegate.wrapException(Throwable obj)
Util.wrapException(java.lang.Throwable) 的委托调用。

抛出 RemoteException 的 javax.rmi.CORBA 中的方法
 void Stub.connect(ORB orb)
将此 stub 连接到 ORB。
 void PortableRemoteObjectDelegate.connect(Remote target, Remote source)
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。
 void StubDelegate.connect(Stub self, ORB orb)
Stub.connect(org.omg.CORBA.ORB) 的委托调用。
static Object Util.copyObject(Object obj, ORB orb)
复制或连接一个对象。
 Object UtilDelegate.copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。
static Object[] Util.copyObjects(Object[] obj, ORB orb)
复制或连接一个对象数组。
 Object[] UtilDelegate.copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。
 void PortableRemoteObjectDelegate.exportObject(Remote obj)
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。
static boolean Util.isLocal(Stub stub)
isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。
 boolean UtilDelegate.isLocal(Stub stub)
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。

javax.transaction 中 RemoteException 的使用

javax.transaction 中 RemoteException 的子类
class | InvalidTransactionException 此异常指示该请求带来了无效的事务上下文。
class | TransactionRequiredException 此异常指示某个请求带来了 null 事务上下文，但目标对象需要激活的事务。
class | TransactionRolledbackException 此异常指示与请求处理关联的事务已回滚，或已标记为回滚。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.ServerError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ServerError
的使用

没有 java.rmi.ServerError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.ServerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ServerException
的使用

没有 java.rmi.ServerException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.ServerRuntimeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.ServerRuntimeException
的使用

没有 java.rmi.ServerRuntimeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.StubNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.StubNotFoundException
的使用

没有 java.rmi.StubNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.UnexpectedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.UnexpectedException
的使用

没有 java.rmi.UnexpectedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.UnknownHostException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.UnknownHostException
的使用

使用 UnknownHostException 的软件包
java.rmi.registry 提供 RMI 注册表的一个类和两个接口。

java.rmi.registry 中 UnknownHostException 的使用

抛出 UnknownHostException 的 java.rmi.registry 中的方法
 Registry RegistryHandler.registryStub(String host, int port)
已过时。 无替代版本。从 Java 2 平台 1.2 版本开始，RMI 不再使用 RegistryHandler 获取注册表的 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.rmi.UnmarshalException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.rmi.UnmarshalException
的使用

没有 java.rmi.UnmarshalException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.rmi.Remote 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.rmi.Remote
的使用

使用 Remote 的软件包
java.rmi | 提供 RMI 包。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.rmi.dgc | 为 RMI 分布式垃圾回收提供了类和接口。
java.rmi.registry | 提供 RMI 注册表的一个类和两个接口。
java.rmi.server | 提供支持服务器端 RMI 的类和接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.rmi | 包含 RMI-IIOP 的用户 API。
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

java.rmi 中 Remote 的使用

返回 Remote 的 java.rmi 中的方法
static Remote Naming.lookup(String name)
返回与指定 name 关联的远程对象的引用（一个 stub）。

参数类型为 Remote 的 java.rmi 中的方法
static void | Naming.bind(String name, Remote obj) 将指定 name 绑定到远程对象。
static void | Naming.rebind(String name, Remote obj) 将指定名称重新绑定到一个新的远程对象。

java.rmi.activation 中 Remote 的使用

java.rmi.activation 中 Remote 的子接口
interface | ActivationInstantiator ActivationInstantiator 负责创建“可激活”对象的实例。
interface | ActivationMonitor 一个 ActivationMonitor 特定于一个 ActivationGroup，当一个组通过对 ActivationSystem.activeGroup 的调用（这是内部完成的）被报告为活动时，获得一个 ActivationMonitor。
interface | ActivationSystem ActivationSystem 为注册组和在那些组中要被激活的“可激活”对象提供一种方式。
interface | Activator Activator 方便了远程对象激活。

实现 Remote 的 java.rmi.activation 中的类
class | Activatable Activatable 类为那些需要进行持久访问并能由系统激活的远程对象提供支持。
class | ActivationGroup ActivationGroup 负责创建组中“可激活”对象的新实例，在以下情况通知其 ActivationMonitor：它的对象变成活动的或者不活动的，或者整个组变成不活动的。
class | ActivationGroup_Stub ActivationGroup_Stub 是一个当作 java.rmi.server.UnicastRemoteObject 被导出的 java.rmi.activation.ActivationGroup 子类的 stub 类。

返回 Remote 的 java.rmi.activation 中的方法
Remote | ActivationID.activate(boolean force) 激活此 id 的对象。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.register(ActivationDesc desc) 为可激活远程对象注册一个对象描述符，以便可以根据需要激活它。

返回变量类型为 Remote 的类型的 java.rmi.activation 中的方法
MarshalledObject<? extends Remote> | Activator.activate(ActivationID id, boolean force) 激活与激活标识符 id 关联的对象。
MarshalledObject<? extends Remote> | ActivationInstantiator.newInstance(ActivationID id, ActivationDesc desc) 激活程序调用一个初始化程序的 newInstance 方法，以便在该组中重建具有激活标识符 id 和描述符 desc 的对象。

参数类型为 Remote 的 java.rmi.activation 中的方法
abstract void | ActivationGroup.activeObject(ActivationID id, Remote obj) 当对象被导出时（通过 Activatable 对象的构造或者通过显式调用 Activatable.exportObject），组的 activeObject 方法被调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static Remote | Activatable.exportObject(Remote obj, ActivationID id, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 将可激活远程对象导出到 RMI 运行库中，使该对象能接收传入的调用。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口输出该对象。
static ActivationID | Activatable.exportObject(Remote obj, String location, MarshalledObject<?> data, boolean restart, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 注册指定对象的激活描述符（使用指定的位置、数据和重启模式），并使用指定的端口、指定的客户端和服务器套接字工厂输出该对象。
static boolean | Activatable.unexportObject(Remote obj, boolean force) 从 RMI 运行库中移除远程对象 obj。

类型变量类型为 Remote 的 java.rmi.activation 中的方法参数
protected void | ActivationGroup.activeObject(ActivationID id, MarshalledObject<? extends Remote> mobj) 如果子类要进行对组监视器的 activeObject 回调，则此 protected 方法是必要的。
void | ActivationMonitor.activeObject(ActivationID id, MarshalledObject<? extends Remote> obj) 通知某个对象现在是活动的。

java.rmi.dgc 中 Remote 的使用

java.rmi.dgc 中 Remote 的子接口
 interface DGC
DGC 抽象用于分布式垃圾回收算法的服务器端。

java.rmi.registry 中 Remote 的使用

java.rmi.registry 中 Remote 的子接口
 interface Registry
Registry 是简单远程对象注册表的一个远程接口，它提供存储和获取绑定了任意字符串名称的远程对象引用的方法。

返回 Remote 的 java.rmi.registry 中的方法
 Remote Registry.lookup(String name)
返回注册表中绑定到指定 name 的远程引用。

参数类型为 Remote 的 java.rmi.registry 中的方法
void | Registry.bind(String name, Remote obj) 绑定对此注册表中指定 name 的远程引用。
void | Registry.rebind(String name, Remote obj) 用提供的远程引用替换此注册表中指定的 name 绑定。

java.rmi.server 中 Remote 的使用

实现 Remote 的 java.rmi.server 中的类
class | RemoteObject 该 RemoteObject 类实现远程对象的 java.lang.Object 行为。
class | RemoteObjectInvocationHandler 与 Java Remote Method Invocation（Java 远程方法调用，即 Java RMI）一起使用的 InvocationHandler 接口的实现。
class | RemoteServer 该 RemoteServer 类是服务器实现的公共超类，并提供支持大量远程引用语义的框架。
class | RemoteStub 该 RemoteStub 类是客户机 stub 的公共超类，并提供支持大量远程引用语义的框架。
class | UnicastRemoteObject 用于导出带 JRMP 的远程对象和获得与该远程对象通信的 stub。

返回 Remote 的 java.rmi.server 中的方法
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port) 使用提供的特定端口导出远程对象，以便能够接收传入的调用。
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
static Remote | RemoteObject.toStub(Remote obj) 返回作为参数传递的远程对象 obj 的 stub。

参数类型为 Remote 的 java.rmi.server 中的方法
void | Skeleton.dispatch(Remote obj, RemoteCall theCall, int opnum, long hash) 已过时。 无替代版本
static RemoteStub | UnicastRemoteObject.exportObject(Remote obj) 使用匿名端口导出远程对象，以便能够接收传入的调用。
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port) 使用提供的特定端口导出远程对象，以便能够接收传入的调用。
static Remote | UnicastRemoteObject.exportObject(Remote obj, int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf) 使用由给定的套接字工厂指定的传送方式导出远程对象，以便能够接收传入的调用。
RemoteStub | ServerRef.exportObject(Remote obj, Object data) 为提供的 Remote 对象创建客户机 stub 对象。
Object | RemoteRef.invoke(Remote obj, Method method, Object[] params, long opnum) 调用某个方法。
static Remote | RemoteObject.toStub(Remote obj) 返回作为参数传递的远程对象 obj 的 stub。
static boolean | UnicastRemoteObject.unexportObject(Remote obj, boolean force) 从 RMI 运行时移除远程对象 obj。

javax.management.remote.rmi 中 Remote 的使用

javax.management.remote.rmi 中 Remote 的子接口
interface | RMIConnection RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。
interface | RMIServer 用于建立到 RMI 连接器的连接的 RMI 对象。

实现 Remote 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl RMIConnection 接口的实现。
class | RMIConnectionImpl_Stub
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
class | RMIServerImpl 表示连接器服务器的 RMI 对象。
class | RMIServerImpl_Stub

返回 Remote 的 javax.management.remote.rmi 中的方法
Remote | RMIIIOPServerImpl.toStub() 返回一个 IIOP stub。
Remote | RMIJRMPServerImpl.toStub() 返回此 RMIServer 对象的可序列化的 stub。
abstract Remote | RMIServerImpl.toStub() 返回此服务器对象的可远程化的 stub。

javax.rmi 中 Remote 的使用

返回 Remote 的 javax.rmi 中的方法
static Remote PortableRemoteObject.toStub(Remote obj)
返回给定服务器对象的 stub。

参数类型为 Remote 的 javax.rmi 中的方法
static void | PortableRemoteObject.connect(Remote target, Remote source) 使 Remote 对象准备好进行远程通信。
static void | PortableRemoteObject.exportObject(Remote obj) 准备服务器对象，以接收远程调用。
static Remote | PortableRemoteObject.toStub(Remote obj) 返回给定服务器对象的 stub。
static void | PortableRemoteObject.unexportObject(Remote obj) 从运行时注销服务器对象，允许对象用于垃圾回收。

javax.rmi.CORBA 中 Remote 的使用

返回 Remote 的 javax.rmi.CORBA 中的方法
 Remote Tie.getTarget()
返回此 tie 的目标。
 Remote PortableRemoteObjectDelegate.toStub(Remote obj)
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。

参数类型为 Remote 的 javax.rmi.CORBA 中的方法
 void PortableRemoteObjectDelegate.connect(Remote target, Remote source)
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。
 void PortableRemoteObjectDelegate.exportObject(Remote obj)
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。
static Tie Util.getTie(Remote target)
返回给定目标对象的 tie（如果存在）。
 Tie UtilDelegate.getTie(Remote target)
Util.getTie(java.rmi.Remote) 的委托调用。
static void Util.registerTarget(Tie tie, Remote target)
为 tie 注册一个目标。
 void UtilDelegate.registerTarget(Tie tie, Remote target)
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。
 void Tie.setTarget(Remote target)
由 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 调用以设置此 tie 的目标。
 Remote PortableRemoteObjectDelegate.toStub(Remote obj)
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。
 void PortableRemoteObjectDelegate.unexportObject(Remote obj)
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。
static void Util.unexportObject(Remote target)
从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。
 void UtilDelegate.unexportObject(Remote target)
Util.unexportObject(java.rmi.Remote) 的委托调用。

org.omg.stub.java.rmi 中 Remote 的使用

实现 Remote 的 org.omg.stub.java.rmi 中的类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AccessControlContext (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security
类 AccessControlContext

java.lang.Object
    继承者  java.security.AccessControlContext

public final class AccessControlContext
extends Object

AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。

更确切地说，它封装一个上下文并且具有单个方法 (checkPermission)，该方法等效于 AccessController 类中的 checkPermission 方法，只有一个不同点：AccessControlContext 的 checkPermission 方法基于它所封装的上下文而不是当前执行线程的上下文作出访问决定。

因此，AccessControlContext 的目的是用于那些实际需要在另一个 上下文（例如，在 worker 线程中）中执行应该在给定上下文中进行的安全检查的情形下。

AccessControlContext 通过调用 AccessController.getContext 方法创建。getContext 方法获取当前调用上下文“快照”，并将其置于它所返回的 AccessControlContext 对象中。示例调用如下：

   AccessControlContext acc = AccessController.getContext()

另一上下文中的代码可以随后在以前保存的 AccessControlContext 对象上调用 checkPermission 方法。示例调用如下：

   acc.checkPermission(permission)

另请参见：
AccessController

构造方法摘要
AccessControlContext(AccessControlContext acc, DomainCombiner combiner)
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。
AccessControlContext(ProtectionDomain[] context)
创建带有给定 ProtectionDomain 集合的 AccessControlContext。
方法摘要
void | checkPermission(Permission perm) 基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。
boolean | equals(Object obj) 检查两个 AccessControlContext 对象是否相等。
DomainCombiner | getDomainCombiner() 获取与此 AccessControlContext 关联的 DomainCombiner。
int | hashCode() 返回此上下文的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AccessControlContext

public AccessControlContext(ProtectionDomain[] context)
创建带有给定 ProtectionDomain 集合的 AccessControlContext。上下文不能为 null。重复的域将从上下文中被移除。

参数：
context - 与此上下文关联的 ProtectionDomain。从数组复制非重复域。数组的后续更改对此 AccessControlContext 没有影响。

AccessControlContext

public AccessControlContext(AccessControlContext acc,
                            DomainCombiner combiner)
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。此构造方法将提供的 DomainCombiner 与提供的 AccessControlContext 关联起来。

参数：
acc - 与此提供的 DomainCombiner 关联的 AccessControlContext。

combiner - 要与提供的 AccessControlContext 关联的 DomainCombiner。
抛出：
NullPointerException - 如果提供的 context 为 null。

SecurityException - 如果调用者没有调用此构造方法的权限。
从以下版本开始：
1.3
方法详细信息

getDomainCombiner

public DomainCombiner getDomainCombiner()
获取与此 AccessControlContext 关联的 DomainCombiner。

返回：
与此 AccessControlContext 关联的 DomainCombiner；如果关联项不存在，则返回 null。
抛出：
SecurityException - 如果调用者没有获取与此 AccessControlContext 关联的 DomainCombiner 的权限。
从以下版本开始：
1.3

checkPermission

public void checkPermission(Permission perm)
                     throws AccessControlException
基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。只有在上下文中每个 ProtectionDomain 都隐含该权限时，才允许该请求。否则拒绝该请求。

如果允许访问请求，则此方法正常返回；否则抛出适当的 AccessControlException。

参数：
perm - 请求的权限。
抛出：
AccessControlException - 如果基于当前的安全策略和此对象所封装的上下文不允许指定权限。
NullPointerException - 如果要检查的权限为 null。

equals

public boolean equals(Object obj)
检查两个 AccessControlContext 对象是否相等。检查 obj 是否为 AccessControlContext 且具有与此上下文相同的 ProtectionDomain 集合。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 为 AccessControlContext 且具有与此上下文相同的 ProtectionDomain 集合，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此上下文的哈希码值。该哈希码是通过对上下文中所有保护域的哈希码进行异或计算得到的。

覆盖：
类 Object 中的 hashCode
返回：
此上下文的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AccessControlException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AccessControlException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.SecurityException
                    继承者  java.security.AccessControlException
所有已实现的接口：
Serializable
public class AccessControlException
extends SecurityException

此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。

拒绝访问的原因各不相同。例如，请求的权限可能类型不正确、包含无效值，或者根据安全策略不允许请求访问。在抛出异常时，只要可能，就应给出此类信息。

另请参见：
序列化表格

构造方法摘要
AccessControlException(String s)
构造带指定详细消息的 AccessControlException。
AccessControlException(String s, Permission p)
构造带指定详细消息和导致异常的请求权限的 AccessControlException。
方法摘要
 Permission getPermission()
获取与此异常关联的 Permission 对象；如果不存在相应的 Permission 对象，则为 null。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AccessControlException

public AccessControlException(String s)
构造带指定详细消息的 AccessControlException。

参数：
s - 详细消息。

AccessControlException

public AccessControlException(String s,
                              Permission p)
构造带指定详细消息和导致异常的请求权限的 AccessControlException。

参数：
s - 详细消息。
p - 导致异常的权限。
方法详细信息

getPermission

public Permission getPermission()
获取与此异常关联的 Permission 对象；如果不存在相应的 Permission 对象，则为 null。

返回：
Permission 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessController (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AccessController

java.lang.Object
    继承者  java.security.AccessController

public final class AccessController
extends Object

AccessController 类用于与访问控制相关的操作和决定。

更确切地说，AccessController 类用于以下三个目的：

  • 基于当前生效的安全策略决定是允许还是拒绝对关键系统资源的访问

  • 将代码标记为享有“特权”，从而影响后续访问决定，以及

  • 获取当前调用上下文的“快照”，这样便可以相对于已保存的上下文作出其他上下文的访问控制决定。

checkPermission 方法确定应该批准还是拒绝由指定权限所指示的访问请求。示例调用如下所示。在此例中，checkPermission 将确定是否批准对 "/temp" 目录中名为 "testFile" 的文件的“读”访问。

    FilePermission perm = new FilePermission("/temp/testFile", "read");
    AccessController.checkPermission(perm);

如果允许执行请求的访问，则 checkPermission 正常返回。如果拒绝，则抛出 AccessControlException。如果请求的权限类型不正确或包含无效值，也会抛出 AccessControlException。只要有可能，都会给出此类信息。假定当前线程按照调用方 1 到调用方 2 直到调用方 m 的顺序遍历了 m 个调用方。那么调用方 m 调用 checkPermission 方法。checkPermission 方法基于以下算法确定是批准还是拒绝进行访问：

 i = m;

 while (i > 0) {

      if (caller i's domain does not have the permission)
              throw AccessControlException

      else if (caller i is marked as privileged) {
              if (a context was specified in the call to doPrivileged)
                 context.checkPermission(permission)
return;
      }
      i = i - 1;
 };

    // Next, check the context inherited when
    // the thread was created. Whenever a new thread is created, the
    // AccessControlContext at that time is
    // stored and associated with the new thread, as the "inherited"
// context.

 inheritedContext.checkPermission(permission);

可以将调用方标记为享有“特权”（请参阅 doPrivileged 及下文）。在做访问控制决定时，如果遇到通过调用不带上下文参数（请参阅下文，以获取关于上下文参数的信息）的 doPrivileged 标记为“特权”的调用方，则 checkPermission 方法将停止检查。如果该调用方的域具有指定的权限，则不进行进一步检查，并且 checkPermission 正常返回，指示允许所请求的访问。如果该域不具有指定的权限，则通常抛出异常。

“特权”功能的标准用法如下所示。如果不需要从“特权”块返回值，则使用以下代码：

   somemethod() {
        ...normal code here...
        AccessController.doPrivileged(new PrivilegedAction() {
            public Object run() {
                // privileged code goes here, for example:
                System.loadLibrary("awt");
                return null; // nothing to return
            }
        });
       ...normal code here...
  }

PrivilegedAction 是一个具有单个方法的接口，该方法名为 run 并返回一个 Object。上述示例显示该接口的实现的创建；提供了 run 方法的具体实现。调用 doPrivileged 时，将 PrivilegedAction 实现的实例传递给它。doPrivileged 方法在启用特权后从 PrivilegedAction 实现调用 run 方法，并返回 run 方法的返回值作为 doPrivileged 的返回值（在此示例中忽略）。

如果需要返回值，则可使用以下代码：

   somemethod() {
        ...normal code here...
        String user = (String) AccessController.doPrivileged(
          new PrivilegedAction() {
            public Object run() {
                return System.getProperty("user.name");
            }
          }
        );
        ...normal code here...
  }

如果在 run 方法中执行的操作可以抛出“已经过检查”异常（列在方法的 throws 子句中），则需要使用 PrivilegedExceptionAction 接口代替 PrivilegedAction 接口：

   somemethod() throws FileNotFoundException {
        ...normal code here...
      try {
        FileInputStream fis = (FileInputStream) AccessController.doPrivileged(
          new PrivilegedExceptionAction() {
            public Object run() throws FileNotFoundException {
                return new FileInputStream("someFile");
            }
          }
        );
      } catch (PrivilegedActionException e) {
        // e.getException() should be an instance of FileNotFoundException,
        // as only "checked" exceptions will be "wrapped" in a
        // PrivilegedActionException.
        throw (FileNotFoundException) e.getException();
      }
        ...normal code here...
  }

在使用“特权”构造时务必 * 特别 * 小心，始终让享有特权的代码段尽可能的小。

注意，checkPermission 始终在当前执行线程的上下文中执行安全性检查。有时，本来应该在给定上下文中进行的安全性检查实际需要在另一个 上下文中（例如，在 worker 线程中）完成。getContext 方法和 AccessControlContext 类就是为这种情况提供的。getContext 方法获取当前调用上下文的“快照”，并将其置于它所返回的 AccessControlContext 对象中。示例调用如下：

   AccessControlContext acc = AccessController.getContext()

AccessControlContext 本身具有一个 checkPermission 方法，该方法基于它 所封装的上下文而不是当前执行线程作出访问决定。因此，另一上下文中的代码可以在以前保存的 AccessControlContext 对象上调用该方法。示例调用如下：

   acc.checkPermission(permission)

有时候您可能不知道用于检查上下文的权限的优先级。这时可以使用 doPrivileged 方法获取上下文：

   somemethod() {
         AccessController.doPrivileged(new PrivilegedAction() {
              public Object run() {
                 // Code goes here. Any permission checks within this
                 // run method will require that the intersection of the
                 // callers protection domain and the snapshot's
                 // context have the desired permission.
              }
         }, acc);
         ...normal code here...
   }

另请参见：
AccessControlContext

方法摘要
static void checkPermission(Permission perm)
基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。
static
<T> T
doPrivileged(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。
static
<T> T
doPrivileged(PrivilegedAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。
static
<T> T
doPrivileged(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
doPrivileged(PrivilegedExceptionAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
doPrivilegedWithCombiner(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。
static
<T> T
doPrivilegedWithCombiner(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。
static AccessControlContext getContext()
此方法获取当前调用上下文（包括当前 Thread 的继承 AccessControlContext）的“快照”，并将其置于 AccessControlContext 对象中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

doPrivileged

public static <T> T doPrivileged(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。该操作在调用者保护域所拥有的全部 权限下执行。

如果该操作的 run 方法抛出（未经过检查的）异常，则该异常将通过此方法传播。

注意，执行该操作时，任何与当前 AccessControlContext 关联的 DomainCombiner 都将被忽略。

参数：
action - 要执行的操作。
返回：
操作的 run 方法返回的值。
抛出：
NullPointerException - 如果该操作为 null。
另请参见：
doPrivileged(PrivilegedAction,AccessControlContext), doPrivileged(PrivilegedExceptionAction), doPrivilegedWithCombiner(PrivilegedAction), DomainCombiner

doPrivilegedWithCombiner

public static <T> T doPrivilegedWithCombiner(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。该操作在调用者保护域所拥有的全部 权限下执行。

如果操作的 run 方法抛出（未经过检查的）异常，那么它将通过此方法传播。

执行该操作时，此方法保留当前 AccessControlContext 的 DomainCombiner（可能为 null）。

参数：
action - 要执行的操作。
返回：
操作的 run 方法返回的值。
抛出：
NullPointerException - 如果 action 为 null
从以下版本开始：
1.6
另请参见：
doPrivileged(PrivilegedAction), DomainCombiner

doPrivileged

public static <T> T doPrivileged(PrivilegedAction<T> action,
                                 AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。该操作在调用方保护域所拥有权限与指定的 AccessControlContext 表示的域所拥有权限的交集下执行。

如果该操作的 run 方法抛出（未经过检查的）异常，则该异常将通过此方法传播。

参数：
action - 要执行的操作。
context - 访问控制上下文，表示执行指定操作前应用于调用方的域特权的限制条件。如果上下文为 null，则不应用任何附加限制。
返回：
操作的 run 方法返回的值。
抛出：
NullPointerException - 如果该操作为 null。
另请参见：
doPrivileged(PrivilegedAction), doPrivileged(PrivilegedExceptionAction,AccessControlContext)

doPrivileged

public static <T> T doPrivileged(PrivilegedExceptionAction<T> action)
                      throws PrivilegedActionException
启用特权，执行指定的 PrivilegedExceptionAction。该操作在调用方保护域所拥有的全部 权限下执行。

如果该操作的 run 方法抛出未经过检查的 异常，则该异常将通过此方法传播。

注意，执行操作时任何与当前 AccessControlContext 关联的 DomainCombiner 都将被忽略。

参数：
action - 要执行的操作
返回：
操作的 run 方法返回的值
抛出：
PrivilegedActionException - 如果指定操作的 run 方法抛出未经过检查的 异常
NullPointerException - 如果操作为 null
另请参见：
doPrivileged(PrivilegedAction), doPrivileged(PrivilegedExceptionAction,AccessControlContext), doPrivilegedWithCombiner(PrivilegedExceptionAction), DomainCombiner

doPrivilegedWithCombiner

public static <T> T doPrivilegedWithCombiner(PrivilegedExceptionAction<T> action)
                                  throws PrivilegedActionException
启用特权，执行指定的 PrivilegedExceptionAction。该操作在调用者保护域所拥有的全部 权限下执行。

如果操作的 run 方法抛出（未经过检查的）异常，则该异常将通过此方法传播。

执行该操作时，此方法保留当前 AccessControlContext 的 DomainCombiner（可能为 null）。

参数：
action - 要执行的操作。
返回：
操作的 run 方法返回的值
抛出：
PrivilegedActionException - 如果指定操作的 run 方法抛出经过检查的 异常
NullPointerException - 如果操作为 null
从以下版本开始：
1.6
另请参见：
doPrivileged(PrivilegedAction), doPrivileged(PrivilegedExceptionAction,AccessControlContext), DomainCombiner

doPrivileged

public static <T> T doPrivileged(PrivilegedExceptionAction<T> action,
                                 AccessControlContext context)
                      throws PrivilegedActionException
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。操作在调用方保护域所拥有权限与指定的 AccessControlContext 表示的域所拥有权限的交集下执行。

如果该操作的 run 方法抛出未经过检查的 异常，则该异常将通过此方法传播。

参数：
action - 要执行的操作
context - 访问控制上下文，表示执行指定操作前应用于调用方的域特权的限制条件。如果上下文为 null，则不应用任何附加限制。
返回：
操作的 run 方法返回的值
抛出：
PrivilegedActionException - 如果指定操作的 run 方法抛出未经过检查的 异常
NullPointerException - 如果操作为 null
另请参见：
doPrivileged(PrivilegedAction), doPrivileged(PrivilegedExceptionAction,AccessControlContext)

getContext

public static AccessControlContext getContext()
此方法获取当前调用上下文（包括当前 Thread 的继承 AccessControlContext）的“快照”，并将其置于 AccessControlContext 对象中。稍后可能在另一个线程中对此上下文进行检查。

返回：
基于当前上下文的 AccessControlContext。
另请参见：
AccessControlContext

checkPermission

public static void checkPermission(Permission perm)
                            throws AccessControlException
基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。如果允许访问请求，此方法正常返回；否则抛出适当的 AccessControlException。

参数：
perm - 请求的权限。
抛出：
AccessControlException - 如果根据当前的安全策略不允许使用指定的权限。
NullPointerException - 如果指定权限为 null 并且基于当前生效的安全策略进行了检查。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AlgorithmParameterGenerator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AlgorithmParameterGenerator

java.lang.Object
    继承者  java.security.AlgorithmParameterGenerator

public class AlgorithmParameterGenerator
extends Object

AlgorithmParameterGenerator 类用于生成将在某个特定算法中使用的参数集合。参数生成器是使用 getInstance 工厂方法（返回给定类的实例的 static 方法）构造的。

可以使用以下两种方式初始化将生成参数的对象：与算法无关的方式或特定于算法的方式：

  • 使用与算法无关的方式时，所有参数生成器都共享“大小”概念和一个随机源。大小的测量由所有算法参数所普遍共享，尽管不同的算法对它有不同的解释。例如，在使用 DSA 算法的参数的情况下，“大小”对应于质数模数的大小（以位为单位）。使用这一方法时，特定于算法的参数生成值（如果有）默认为某些标准值，除非它们可以从指定大小派生。

  • 另外一种方式使用特定于算法的语义初始化参数生成器对象，这些语义由特定于算法的参数生成值集合表示。例如，倘若要生成 Diffie-Hellman 系统参数，则参数生成值通常由质数模数的大小和随机指数的大小组成，这两个大小都使用位数指定。

为防止客户端没有显式初始化 AlgorithmParameterGenerator（通过调用 init 方法），每个提供商都必须提供（并记录）一种默认的初始化。例如，Sun 提供商使用 1024 位的默认模数主大小生成 DSA 参数。

从以下版本开始：
1.2
另请参见：
AlgorithmParameters, AlgorithmParameterSpec

构造方法摘要
protected AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameterGenerator 对象。
方法摘要
AlgorithmParameters | generateParameters() 生成参数。
String | getAlgorithm() 返回与此参数生成器关联的算法的标准名称。
static AlgorithmParameterGenerator | getInstance(String algorithm) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static AlgorithmParameterGenerator | getInstance(String algorithm, Provider provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static AlgorithmParameterGenerator | getInstance(String algorithm, String provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
Provider | getProvider() 返回此算法参数生成器对象的提供者。
void | init(AlgorithmParameterSpec genParamSpec) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | init(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | init(int size) 针对某个特定大小初始化此参数生成器。
void | init(int size, SecureRandom random) 针对某个特定大小和随机源初始化此参数生成器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AlgorithmParameterGenerator

protected AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi,
                                      Provider provider,
                                      String algorithm)
创建一个 AlgorithmParameterGenerator 对象。

参数：
paramGenSpi - 委托
provider - 提供者
algorithm - 算法
方法详细信息

getAlgorithm

public final String getAlgorithm()
返回与此参数生成器关联的算法的标准名称。

返回：
算法的字符串名称。

getInstance

public static AlgorithmParameterGenerator getInstance(String algorithm)
                                               throws NoSuchAlgorithmException
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

此方法从首选的 Provider 开始遍历已注册安全提供者列表。返回封装新 AlgorithmParameterGeneratorSpi 实现的 AlgorithmParameterGenerator 对象，该对象取自第一个支持指定算法的 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 与此参数生成器关联的算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
新的 AlgorithmParameterGenerator 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 AlgorithmParameterGeneratorSpi 实现。
另请参见：
Provider

getInstance

public static AlgorithmParameterGenerator getInstance(String algorithm,
                                                      String provider)
                                               throws NoSuchAlgorithmException,
                                                      NoSuchProviderException
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

返回封装 AlgorithmParameterGeneratorSpi 实现的新 AlgorithmParameterGenerator 对象，该实现取自指定 Provider。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 与此参数生成器关联的算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - Provider 的字符串名称。
返回：
新的 AlgorithmParameterGenerator 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 AlgorithmParameterGeneratorSpi 实现不能从指定 Provider 获得。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static AlgorithmParameterGenerator getInstance(String algorithm,
                                                      Provider provider)
                                               throws NoSuchAlgorithmException
返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

返回封装 AlgorithmParameterGeneratorSpi 实现的新 AlgorithmParameterGenerator 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 与此参数生成器关联的算法的字符串名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - Provider 对象。
返回：
新的 AlgorithmParameterGenerator 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 AlgorithmParameterGeneratorSpi 实现不能从指定 Provider 对象获得。
IllegalArgumentException - 如果指定 provider 为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此算法参数生成器对象的提供者。

返回：
此算法参数生成器对象的提供者

init

public final void init(int size)
针对某个特定大小初始化此参数生成器。要创建参数，则需要将最高优先级安装的提供者的 SecureRandom 实现用作随机源。（如果任何安装的提供者都不提供 SecureRandom 的实现，则使用系统提供的随机源。）

参数：
size - 大小（位数）。

init

public final void init(int size,
                       SecureRandom random)
针对某个特定大小和随机源初始化此参数生成器。

参数：
size - 大小（位数）。
random - 随机源。

init

public final void init(AlgorithmParameterSpec genParamSpec)
                throws InvalidAlgorithmParameterException
利用特定于算法的参数生成值集合初始化此参数生成器。要生成参数，则需要将最高优先级安装的提供者的 SecureRandom 实现用作随机源。（如果任何安装的提供者都不提供 SecureRandom 的实现，则使用系统提供的随机源。）

参数：
genParamSpec - 特定于算法的参数生成值的集合。
抛出：
InvalidAlgorithmParameterException - 如果给定的参数生成值不适合此参数生成器。

init

public final void init(AlgorithmParameterSpec genParamSpec,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
利用特定于算法的参数生成值集合初始化此参数生成器。

参数：
genParamSpec - 特定于算法的参数生成值的集合。
random - 随机源。
抛出：
InvalidAlgorithmParameterException - 如果给定的参数生成值不适合此参数生成器。

generateParameters

public final AlgorithmParameters generateParameters()
生成参数。

返回：
新的 AlgorithmParameters 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AlgorithmParameterGeneratorSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AlgorithmParameterGeneratorSpi

java.lang.Object
    继承者  java.security.AlgorithmParameterGeneratorSpi

public abstract class AlgorithmParameterGeneratorSpi
extends Object

此类为 AlgorithmParameterGenerator 类定义服务提供者接口 (SPI)，AlgorithmParameterGenerator 类用于生成在某个特定算法中使用的参数集合。

每个希望为特定算法提供参数生成器实现的密码服务提供者都必须实现此类中的所有抽象方法。

为防止客户端不显式初始化 AlgorithmParameterGenerator（通过调用 engineInit 方法），每个提供者都必须提供（并记录）一种默认的初始化。例如，Sun 提供者使用 1024 位的默认模数主大小生成 DSA 参数。

从以下版本开始：
1.2
另请参见：
AlgorithmParameterGenerator, AlgorithmParameters, AlgorithmParameterSpec

构造方法摘要
AlgorithmParameterGeneratorSpi()
方法摘要
protected abstract AlgorithmParameters | engineGenerateParameters() 生成参数。
protected abstract void | engineInit(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值的集合初始化此参数生成器。
protected abstract void | engineInit(int size, SecureRandom random) 针对某个特定大小和随机源初始化此参数生成器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AlgorithmParameterGeneratorSpi

public AlgorithmParameterGeneratorSpi()
方法详细信息

engineInit

protected abstract void engineInit(int size,
                                   SecureRandom random)
针对某个特定大小和随机源初始化此参数生成器。

参数：
size - 大小（位数）。
random - 随机源。

engineInit

protected abstract void engineInit(AlgorithmParameterSpec genParamSpec,
                                   SecureRandom random)
                            throws InvalidAlgorithmParameterException
利用特定于算法的参数生成值的集合初始化此参数生成器。

参数：
genParamSpec - 特定于算法的参数生成值的集合。
random - 随机源。
抛出：
InvalidAlgorithmParameterException - 如果给定的参数生成值不适合此参数生成器。

engineGenerateParameters

protected abstract AlgorithmParameters engineGenerateParameters()
生成参数。

返回：
新的 AlgorithmParameters 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AlgorithmParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AlgorithmParameters

java.lang.Object
    继承者  java.security.AlgorithmParameters

public class AlgorithmParameters
extends Object

此类用作密码参数的不透明表示形式。

可以通过调用 getInstance 工厂方法（返回给定类的实例的 static 方法）之一获取用于管理特定算法的参数的 AlgorithmParameters 对象。

返回 AlgorithmParameters 对象后，必须使用适当的参数规范或参数编码通过调用 init 方法初始化该对象。

通过调用 getParameterSpec 可以从 AlgorithmParameters 对象获取透明参数规范，可以通过调用 getEncoded 获取参数的字节编码。

从以下版本开始：
1.2
另请参见：
AlgorithmParameterSpec, DSAParameterSpec, KeyPairGenerator

构造方法摘要
protected AlgorithmParameters(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameters 对象。
方法摘要
 String getAlgorithm()
返回与此参数对象关联的算法的名称。
 byte[] getEncoded()
返回基本编码格式的参数。
 byte[] getEncoded(String format)
返回以指定方案编码的参数。
static AlgorithmParameters getInstance(String algorithm)
返回指定算法的参数对象。
static AlgorithmParameters getInstance(String algorithm, Provider provider)
返回指定算法的参数对象。
static AlgorithmParameters getInstance(String algorithm, String provider)
返回指定算法的参数对象。
<T extends AlgorithmParameterSpec>
T
getParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
 Provider getProvider()
返回此参数对象的提供者。
 void init(AlgorithmParameterSpec paramSpec)
使用在 paramSpec 中指定的参数初始化此参数对象。
 void init(byte[] params)
根据参数的基本解码格式导入指定的参数并对其解码。
 void init(byte[] params, String format)
根据指定的解码方案从 params 导入参数并对其解码。
 String toString()
返回描述参数的格式化字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AlgorithmParameters

protected AlgorithmParameters(AlgorithmParametersSpi paramSpi,
                              Provider provider,
                              String algorithm)
创建一个 AlgorithmParameters 对象。

参数：
paramSpi - 委托
provider - 提供者
algorithm - 算法
方法详细信息

getAlgorithm

public final String getAlgorithm()
返回与此参数对象关联的算法的名称。

返回：
算法名称。

getInstance

public static AlgorithmParameters getInstance(String algorithm)
                                       throws NoSuchAlgorithmException
返回指定算法的参数对象。

此方法从首选 Provider 开始，遍历已注册安全提供者列表。返回一个封装 AlgorithmParametersSpi 实现的新 AlgorithmParameters 对象，该实现取自第一个支持指定算法的 Provider。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

必须使用适当参数规范或参数编码通过调用 init 方法初始化返回的参数对象。

参数：
algorithm - 所请求算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。
返回：
新的参数对象。
抛出：
NoSuchAlgorithmException - 如果没有任何 Provider 支持指定算法的 AlgorithmParametersSpi 实现。
另请参见：
Provider

getInstance

public static AlgorithmParameters getInstance(String algorithm,
                                              String provider)
                                       throws NoSuchAlgorithmException,
                                              NoSuchProviderException
返回指定算法的参数对象。

返回一个封装 AlgorithmParametersSpi 实现的新 AlgorithmParameters 对象，该实现取自指定的提供者。指定的提供者必须已经在安全提供者列表中注册。

注意，已注册提供者列表可以使用 Security.getProviders() 方法获得。

参数：
algorithm - 所请求算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。
provider - 提供者的名称。
返回：
新的参数对象。
抛出：
NoSuchAlgorithmException - 如果无法从指定提供者获得指定算法的 AlgorithmParametersSpi 实现。
NoSuchProviderException - 如果指定提供者没有在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static AlgorithmParameters getInstance(String algorithm,
                                              Provider provider)
                                       throws NoSuchAlgorithmException
返回指定算法的参数对象。

返回一个封装 AlgorithmParametersSpi 实现的新 AlgorithmParameters 对象，该实现取自指定的 Provider 对象。注意，指定的 Provider 对象无需在提供者列表中注册。

必须使用适当参数规范或参数编码通过调用 init 方法初始化返回的参数对象。

参数：
algorithm - 所请求算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。
provider - 提供者的名称。
返回：
新的参数对象。
抛出：
NoSuchAlgorithmException - 如果无法从指定 Provider 对象获得指定算法的 AlgorithmParametersSpi 实现。
IllegalArgumentException - 如果 provider 为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此参数对象的提供者。

返回：
此参数对象的提供者。

init

public final void init(AlgorithmParameterSpec paramSpec)
                throws InvalidParameterSpecException
使用在 paramSpec 中指定的参数初始化此参数对象。

参数：
paramSpec - 参数规范。
抛出：
InvalidParameterSpecException - 如果给定的参数规范不适用于初始化此参数对象，或者已经初始化此参数对象。

init

public final void init(byte[] params)
                throws IOException
根据参数的基本解码格式导入指定的参数并对其解码。如果此参数类型的 ASN.1 规范存在，则参数的基本解码格式为 ASN.1。

参数：
params - 编码的参数。
抛出：
IOException - 如果发生解码错误，或者已经初始化此参数对象。

init

public final void init(byte[] params,
                       String format)
                throws IOException
根据指定的解码方案从 params 导入参数并对其解码。如果 format 为 null，则使用参数的基本解码格式。如果这些参数的 ASN.1 规范存在，则基本解码格式为 ASN.1。

参数：
params - 编码的参数。
format - 解码方案的名称。
抛出：
IOException - 如果发生解码错误，或者已经初始化此参数对象。

getParameterSpec

public final <T extends AlgorithmParameterSpec> T getParameterSpec(Class<T> paramSpec)
                                                        throws InvalidParameterSpecException
返回此参数对象的（透明）规范。paramSpec 标识应该在其中返回参数的规范类。例如，该类可以为 DSAParameterSpec.class，指示应该在 DSAParameterSpec 类的实例中返回参数。

参数：
paramSpec - 应该在其中返回参数的规范类。
返回：
参数规范。
抛出：
InvalidParameterSpecException - 如果请求的参数规范不适合此参数对象，或者尚未初始化此参数对象。

getEncoded

public final byte[] getEncoded()
                        throws IOException
返回基本编码格式的参数。如果此参数类型的 ASN.1 规范存在，则参数的基本编码格式为 ASN.1。

返回：
使用基本编码格式编码的参数。
抛出：
IOException - 如果发生编码错误，或者尚未初始化此参数对象。

getEncoded

public final byte[] getEncoded(String format)
                        throws IOException
返回以指定方案编码的参数。如果 format 为 null，则使用参数的基本编码格式。如果这些参数的 ASN.1 规范存在，则基本编码格式为 ASN.1。

参数：
format - 编码格式的名称。
返回：
使用指定的编码方案编码的参数。
抛出：
IOException - 如果发生编码错误，或者尚未初始化此参数对象。

toString

public final String toString()
返回描述参数的格式化字符串。

覆盖：
类 Object 中的 toString
返回：
描述参数的格式化字符串；如果尚未初始化此参数对象，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AlgorithmParametersSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AlgorithmParametersSpi

java.lang.Object
    继承者  java.security.AlgorithmParametersSpi

public abstract class AlgorithmParametersSpi
extends Object

此类为 AlgorithmParameters 类定义服务提供者接口 (SPI)，AlgorithmParameters 类用于管理算法参数。

每个希望为特定算法提供参数管理的密码服务提供者都必须实现此类中的所有抽象方法。

从以下版本开始：
1.2
另请参见：
AlgorithmParameters, AlgorithmParameterSpec, DSAParameterSpec

构造方法摘要
AlgorithmParametersSpi()
方法摘要
protected abstract  byte[] engineGetEncoded()
返回基本编码格式的参数。
protected abstract  byte[] engineGetEncoded(String format)
返回以指定格式编码的参数。
protected abstract
<T extends AlgorithmParameterSpec>
T
engineGetParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
protected abstract  void engineInit(AlgorithmParameterSpec paramSpec)
使用在 paramSpec 中指定的参数初始化此参数对象。
protected abstract  void engineInit(byte[] params)
根据参数的基本解码格式导入指定的参数并对其解码。
protected abstract  void engineInit(byte[] params, String format)
根据指定的解码格式从 params 导入参数并对其解码。
protected abstract  String engineToString()
返回描述参数的格式化字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AlgorithmParametersSpi

public AlgorithmParametersSpi()
方法详细信息

engineInit

protected abstract void engineInit(AlgorithmParameterSpec paramSpec)
                            throws InvalidParameterSpecException
使用在 paramSpec 中指定的参数初始化此参数对象。

参数：
paramSpec - 参数规范。
抛出：
InvalidParameterSpecException - 如果给定参数规范不适用于初始化此参数对象。

engineInit

protected abstract void engineInit(byte[] params)
                            throws IOException
根据参数的基本解码格式导入指定的参数并对其解码。如果此参数类型的 ASN.1 规范存在，则参数的基本解码格式即为 ASN.1。

参数：
params - 编码的参数。
抛出：
IOException - 当解码发生错误时

engineInit

protected abstract void engineInit(byte[] params,
                                   String format)
                            throws IOException
根据指定的解码格式从 params 导入参数并对其解码。如果 format 为 null，则使用参数的基本解码格式。如果这些参数的 ASN.1 规范存在，则基本解码格式即为 ASN.1。

参数：
params - 编码的参数。
format - 解码格式的名称。
抛出：
IOException - 当解码发生错误时

engineGetParameterSpec

protected abstract <T extends AlgorithmParameterSpec> T engineGetParameterSpec(Class<T> paramSpec)
                                                                    throws InvalidParameterSpecException
返回此参数对象的（透明）规范。paramSpec 标识应该在其中返回参数的规范类。例如，该类可以为 DSAParameterSpec.class，指示应该在 DSAParameterSpec 类的实例中返回参数。

参数：
paramSpec - 应该在其中返回参数的规范类。
返回：
参数规范。
抛出：
InvalidParameterSpecException - 如果请求的参数规范不适用于初始化此参数对象。

engineGetEncoded

protected abstract byte[] engineGetEncoded()
                                    throws IOException
返回基本编码格式的参数。如果此参数类型的 ASN.1 规范存在，则参数的基本编码格式即为 ASN.1。

返回：
使用其主要编码格式编码的参数。
抛出：
IOException - 当编码发生错误时。

engineGetEncoded

protected abstract byte[] engineGetEncoded(String format)
                                    throws IOException
返回以指定格式编码的参数。如果 format 为 null，则使用参数的基本编码格式。如果这些参数的 ASN.1 规范存在，则基本编码格式即为 ASN.1。

参数：
format - 编码格式的名称。
返回：
使用指定的编码方案编码的参数。
抛出：
IOException - 当编码发生错误时。

engineToString

protected abstract String engineToString()
返回描述参数的格式化字符串。

返回：
描述参数的格式化字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AllPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AllPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.AllPermission
所有已实现的接口：
Serializable, Guard
public final class AllPermission
extends Permission

AllPermission 是暗含所有其他权限的权限。

注：授予 AllPermission 时应该非常小心，因为它暗含所有其他权限。因此，它授予代码可以不受安全性限制地运行。将此类权限授予代码前，应该慎重考虑。此权限只应在测试期间使用，或者在应用程序或 applet 完全受信任并且将必要的权限添加到策略实在过于麻烦的极少数情况下使用。

另请参见：
Permission, AccessController, Permissions, PermissionCollection, SecurityManager

构造方法摘要
AllPermission()
创建新的 AllPermission 对象。
AllPermission(String name, String actions)
创建新的 AllPermission 对象。
方法摘要
boolean | equals(Object obj) 检查两个 AllPermission 对象是否相等。
String | getActions() 返回操作的规范化字符串表示形式。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此对象是否“暗含”指定的权限。
PermissionCollection | newPermissionCollection() 返回用于存储 AllPermission 对象的新 PermissionCollection 对象。
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AllPermission

public AllPermission()
创建新的 AllPermission 对象。

AllPermission

public AllPermission(String name,
                     String actions)
创建新的 AllPermission 对象。此构造方法存在是为了 Policy 对象可以使用它来实例化新的 Permission 对象。

参数：
name - 忽略
actions - 忽略。
方法详细信息

implies

public boolean implies(Permission p)
检查此对象是否“暗含”指定的权限。此方法始终返回 true。

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的权限。
返回：
true

equals

public boolean equals(Object obj)
检查两个 AllPermission 对象是否相等。两个 AllPermission 对象始终相等。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 为 AllPermission，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回操作的规范化字符串表示形式。

指定者：
类 Permission 中的 getActions
返回：
操作。

newPermissionCollection

public PermissionCollection newPermissionCollection()
返回用于存储 AllPermission 对象的新 PermissionCollection 对象。

覆盖：
类 Permission 中的 newPermissionCollection
返回：
适合存储 AllPermission 的新 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AuthProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 AuthProvider

java.lang.Object
    继承者  java.util.Dictionary<K,V>
        继承者  java.util.Hashtable<Object,Object>
            继承者  java.util.Properties
                继承者  java.security.Provider
                    继承者  java.security.AuthProvider
所有已实现的接口：
Serializable, Cloneable, Map<Object,Object>
public abstract class AuthProvider
extends Provider

此类定义 provider 的登录和注销方法。

调用者可以直接调用 login，但如果 provider 确定必须在某些特定操作前执行登录，则其也可以代表调用者调用 login。

从以下版本开始：
1.5
另请参见：
序列化表格

嵌套类摘要
从类 java.security.Provider 继承的嵌套类/接口
Provider.Service
字段摘要
从类 java.util.Properties 继承的字段
defaults
构造方法摘要
protected AuthProvider(String name, double version, String info)
构造具有指定名称、版本号和信息的 provider。
方法摘要
abstract void | login(Subject subject, CallbackHandler handler) 登录到此 provider 中。
abstract void | logout() 在此 provider 中注销。
abstract void | setCallbackHandler(CallbackHandler handler) 设置 CallbackHandler。
从类 java.security.Provider 继承的方法
clear, elements, entrySet, get, getInfo, getName, getProperty, getService, getServices, getVersion, keys, keySet, load, put, putAll, putService, remove, removeService, toString, values
从类 java.util.Properties 继承的方法
getProperty, list, list, load, loadFromXML, propertyNames, save, setProperty, store, store, storeToXML, storeToXML, stringPropertyNames
从类 java.util.Hashtable 继承的方法
clone, contains, containsKey, containsValue, equals, hashCode, isEmpty, rehash, size
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AuthProvider

protected AuthProvider(String name,
                       double version,
                       String info)
构造具有指定名称、版本号和信息的 provider。

参数：
name - provider 的名称。
version - provider 的版本号。
info - provider 及其服务的描述。
方法详细信息

login

public abstract void login(Subject subject,
                           CallbackHandler handler)
                    throws LoginException
登录到此 provider 中。

provider 依靠 CallbackHandler 从调用者（例如，PIN）获取验证信息。如果调用者向此方法传递为 null 的 provider，则 provider 将使用在 setCallbackHandler 方法中设置的处理程序。如果在该方法中没有设置处理程序，则 provider 将查询 auth.login.defaultCallbackHandler 安全属性，以获取默认处理程序实现的完全限定类名称。如果没有设置安全属性，则假定 provider 具有获取验证信息的替代方法。

参数：
subject - Subject，它可能包含用于验证的主体/凭据，或者可以在成功完成验证后利用其他主体/凭据填充。此参数可以为 null。
handler - 此 provider 用于从调用者获取验证信息的 CallbackHandler，它可能为 null
抛出：
LoginException - 如果登录操作失败
SecurityException - 如果调用者不传递对 SecurityPermission("authProvider.name")（其中 name 为此 provider 的 getName 方法所返回的值）的安全检查。

logout

public abstract void logout()
                     throws LoginException
在此 provider 中注销。

抛出：
LoginException - 如果注销操作失败
SecurityException - 如果调用者不传递 SecurityPermission("authProvider.name")（其中 name 为此 provider 的 getName 方法所返回的值）的安全检查。

setCallbackHandler

public abstract void setCallbackHandler(CallbackHandler handler)
设置 CallbackHandler。

如果没有传递给 login 方法一个处理程序，则 provider 使用此处理程序。如果 provider 代表调用者调用 login，则其也使用此处理程序。在任何一种情况下，如果没有通过此方法中设置处理程序，则 provider 将查询 auth.login.defaultCallbackHandler 安全属性，以获取默认处理程序实现的完全限定类名称。如果没有设置安全属性，则假定 provider 具有获取验证信息的替代方法。

参数：
handler - 用于获取验证信息（可以为 null）的 CallbackHandler
抛出：
SecurityException - 如果调用者不传递 SecurityPermission("authProvider.name")（其中 name 为此 provider 的 getName 方法所返回的值）的安全检查。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 BasicPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
所有已实现的接口：
Serializable, Guard
直接已知子类：
AudioPermission, AuthPermission, AWTPermission, DelegationPermission, LoggingPermission, ManagementPermission, MBeanServerPermission, MBeanTrustPermission, NetPermission, PropertyPermission, ReflectPermission, RuntimePermission, SecurityPermission, SerializablePermission, SQLPermission, SSLPermission, SubjectDelegationPermission, WebServicePermission
public abstract class BasicPermission
extends Permission
implements Serializable

BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。

BasicPermission 的名称就是给定权限的名称（例如，"exit"、"setFactory"、"print.queueJob" 等）。命名约定遵守层次结构属性命名约定。星号可能单独出现，也可能紧跟在 "." 后面出现在名称的末尾，它表示通配符匹配。例如，"*" 和 "java.*" 有效，而 "*java"、"a*b" 和 "java*" 无效。

不使用（从 Permission 继承的）操作字符串。因此，BasicPermission 通常用作“指定”权限（包含名称但不包含操作列表的权限；或者具有指定权限或者不具有）的基类。需要时子类可以在 BasicPermission 之上实现操作。

另请参见：
Permission, Permissions, PermissionCollection, RuntimePermission, SecurityPermission, PropertyPermission, AWTPermission, NetPermission, SecurityManager, 序列化表格

构造方法摘要
BasicPermission(String name)
创建具有指定名称的新 BasicPermission。
BasicPermission(String name, String actions)
创建具有指定名称的新 BasicPermission 对象。
方法摘要
boolean | equals(Object obj) 检查两个 BasicPermission 对象是否相等。
String | getActions() 返回操作的规范化字符串表示形式，该表示形式当前为空字符串 ""，因为不存在 BasicPermission 的操作。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此对象是否“暗含”指定的权限。
PermissionCollection | newPermissionCollection() 用于存储 BasicPermission 对象的新 PermissionCollection 对象。
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

BasicPermission

public BasicPermission(String name)
创建具有指定名称的新 BasicPermission。name 是权限的符号名，如 "setFactory"、"print.queueJob" 或 "topLevelWindow"，等等。

参数：
name - BasicPermission 的名称。
抛出：
NullPointerException - 如果 name 为 null
IllegalArgumentException - 如果 name 为空。

BasicPermission

public BasicPermission(String name,
                       String actions)
创建具有指定名称的新 BasicPermission 对象。该名称是 BasicPermission 的符号名，以及当前不使用操作 String。

参数：
name - BasicPermission 的名称。
actions - 忽略。
抛出：
NullPointerException - 如果 name 为 null
IllegalArgumentException - 如果 name 为空。
方法详细信息

implies

public boolean implies(Permission p)
检查此对象是否“暗含”指定的权限。

更明确地说，如果此方法满足以下条件，则返回 true：

  • p 的类与此对象的类相同，并且

  • p 的名称等于此对象的名称或者（在使用通配符的情况下）此对象的名称暗含它的名称。例如，"a.b.*" 暗含 "a.b.c"。

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果传递的权限等于此权限或者暗含于此权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 BasicPermission 对象是否相等。检查 obj 的类是否与此对象的类相同并且具有与此对象相同的名称。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 为 BasicPermission 并且具有与此 BasicPermission 对象相同的名称，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。所用的哈希码是名称的哈希码，也就是 getName().hashCode()，其中 getName 来自 Permission 超类。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回操作的规范化字符串表示形式，该表示形式当前为空字符串 ""，因为不存在 BasicPermission 的操作。

指定者：
类 Permission 中的 getActions
返回：
空字符串 ""。

newPermissionCollection

public PermissionCollection newPermissionCollection()
用于存储 BasicPermission 对象的新 PermissionCollection 对象。

BasicPermissionCollection 存储 BasicPermission 权限的集合。

BasicPermission 对象必须以允许将它们按任意顺序插入的方式来存储，但同时也允许以有效（并一致）的方式实现 PermissionCollection 的 implies 方法。

覆盖：
类 Permission 中的 newPermissionCollection
返回：
适合存储 BasicPermissions 的新 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Certificate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 Certificate

已过时。 在 Java 平台中创建了新的证书处理包。此 Certificate 接口已完全废弃，其仍存在是为了能平稳地过渡到新包。

@Deprecated
public interface Certificate

这是一个用于管理多种身份证书的抽象方法的接口。身份证书是某个主体的保证，保证某个公钥是另一个主体的公钥。（主体表示实体，如个别用户、团体或公司。）

需要特别指出的是，此接口应为具有不同格式但重要的公共用途的那些构造的公共抽象。例如，不同的证书类型（如 X.509 证书和 PGP 证书）共享通用的证书功能（编码和解码证书所需要的）和某些类型的信息，如公钥、将公钥作为密钥的主体和保证公钥是指定主体的密钥的 guarantor。因此，X.509 证书的实现和 PGP 证书的实现都可以利用 Certificate 接口，尽管它们的格式和附加类型以及存储的信息量各不相同。

重要主意事项：此接口对编目和分组共享某些公共用途的对象很有用。它本身没有任何语义。需要特别指出的是，Certificate 对象不作出任何关于绑定有效性 的声明。由实现此接口的应用程序来负责验证证书并赋予其本身有效性。

另请参见：
Certificate

方法摘要
void | decode(InputStream stream) 已过时。 从输入流解码证书。
void | encode(OutputStream stream) 已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
String | getFormat() 已过时。 返回编码格式的名称。
Principal | getGuarantor() 已过时。 返回证书的保证人，即某个主体，其保证与此证书关联的公钥是与此证书关联的主体的公钥。
Principal | getPrincipal() 已过时。 返回保证人所保证的主体密钥对的主体。
PublicKey | getPublicKey() 已过时。 返回保证人所保证的主体密钥对的密钥。
String | toString(boolean detailed) 已过时。 返回表示证书内容的字符串。

方法详细信息

getGuarantor

Principal getGuarantor()
已过时。
返回证书的保证人，即某个主体，其保证与此证书关联的公钥是与此证书关联的主体的公钥。对于 X.509 证书，保证人通常为 Certificate Authority（如美国邮政管理局或 Verisign 等）。

返回：
保证主体密钥绑定的保证人。

getPrincipal

Principal getPrincipal()
已过时。
返回保证人所保证的主体密钥对的主体。

返回：
此证书绑定的主体。

getPublicKey

PublicKey getPublicKey()
已过时。
返回保证人所保证的主体密钥对的密钥。

返回：
此证书证明的属于特定主体的公钥。

encode

void encode(OutputStream stream)
            throws KeyException,
                   IOException
已过时。
以 decode 方法可以解码的格式将证书编码到输出流。

参数：
stream - 要将证书编码到的输出流。
抛出：
KeyException - 如果没有正确初始化证书，或者丢失数据，等等。
IOException - 如果在试图将已编码的证书输出到输出流中时发生流异常。
另请参见：
decode(java.io.InputStream), getFormat()

decode

void decode(InputStream stream)
            throws KeyException,
                   IOException
已过时。
从输入流解码证书。格式应为 getFormat 所返回的格式并且由 encode 产生。

参数：
stream - 从中获取要解码的数据的输入流。
抛出：
KeyException - 如果没有正确初始化证书，或者丢失数据，等等。
IOException - 如果在试图从输入流输入已编码的证书时发生异常。
另请参见：
encode(java.io.OutputStream), getFormat()

getFormat

String getFormat()
已过时。
返回编码格式的名称。该名称用作查找适当解析器的提示。它可以为 "X.509"、"PGP" 等。这是由 encode 和 decode 方法产生被可以被它们理解的格式。

返回：
编码格式的名称。

toString

String toString(boolean detailed)
已过时。
返回表示证书内容的字符串。

参数：
detailed - 是否给出关于证书的详细信息
返回：
表示证书内容的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CodeSigner (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 CodeSigner

java.lang.Object
    继承者  java.security.CodeSigner
所有已实现的接口：
Serializable
public final class CodeSigner
extends Object
implements Serializable

此类封装关于代码签名者的信息。它是不可变的。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
CodeSigner(CertPath signerCertPath, Timestamp timestamp)
构造 CodeSigner 对象。
方法摘要
boolean | equals(Object obj) 测试指定对象与此代码签名者之间是否相等。
CertPath | getSignerCertPath() 返回签名者的证书路径。
Timestamp | getTimestamp() 返回签名时间戳。
int | hashCode() 返回此代码签名者的哈希码值。
String | toString() 返回描述此代码签名者的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CodeSigner

public CodeSigner(CertPath signerCertPath,
                  Timestamp timestamp)
构造 CodeSigner 对象。

参数：
signerCertPath - 签名者的证书路径。它一定不能为 null。
timestamp - 签名时间戳。如果为 null，则不为签名生成任何时间戳。
抛出：
NullPointerException - 如果 signerCertPath 为 null。
方法详细信息

getSignerCertPath

public CertPath getSignerCertPath()
返回签名者的证书路径。

返回：
证书路径。

getTimestamp

public Timestamp getTimestamp()
返回签名时间戳。

返回：
时间戳；如果不存在任何时间戳，则返回 null。

hashCode

public int hashCode()
返回此代码签名者的哈希码值。哈希码使用签名者的证书路径和时间戳（如果有）生成。

覆盖：
类 Object 中的 hashCode
返回：
此代码签名的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
测试指定对象与此代码签名者之间是否相等。如果它们的签名证书路径相等且时间戳（如果两者中都存在）也相等，则认为这两个代码签名者相等。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果对象被视为相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回描述此代码签名者的字符串。

覆盖：
类 Object 中的 toString
返回：
由签名者的证书和时间戳（如果有）组成的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CodeSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 CodeSource

java.lang.Object
    继承者  java.security.CodeSource
所有已实现的接口：
Serializable
public class CodeSource
extends Object
implements Serializable

此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。

另请参见：
序列化表格

构造方法摘要
CodeSource(URL url, Certificate[] certs)
构造一个 CodeSource 并将其与指定位置和证书集合相关联。
CodeSource(URL url, CodeSigner[] signers)
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。
方法摘要
boolean | equals(Object obj) 测试指定对象与此对象之间的相等性。
Certificate[] | getCertificates() 返回与此 CodeSource 关联的证书。
CodeSigner[] | getCodeSigners() 返回与此 CodeSource 关联的代码签名者。
URL | getLocation() 返回与此 CodeSource 关联的位置。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(CodeSource codesource) 如果此 CodeSource 对象“暗含”指定的 CodeSource，则返回 true。
String | toString() 返回描述此 CodeSource 的字符串，告知其 URL 和证书。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CodeSource

public CodeSource(URL url,
                  Certificate[] certs)
构造一个 CodeSource 并将其与指定位置和证书集合相关联。

参数：
url - 位置 (URL)。
certs - 证书。它可以为 null。复制数组的内容，以防随后进行修改。

CodeSource

public CodeSource(URL url,
                  CodeSigner[] signers)
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。

参数：
url - 位置 (URL)。
signers - 代码签名者。它可以为 null。复制数组的内容，以防随后进行修改。
从以下版本开始：
1.5
方法详细信息

hashCode

public int hashCode()
返回此对象的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
测试指定对象与此对象之间的相等性。如果两个 CodeSource 对象的位置具有相同值并且其签名者证书链也具有相同值，则认为这两个对象相等。不要求证书链具有相同的顺序。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果对象被视为相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getLocation

public final URL getLocation()
返回与此 CodeSource 关联的位置。

返回：
位置 (URL)。

getCertificates

public final Certificate[] getCertificates()
返回与此 CodeSource 关联的证书。

如果此 CodeSource 对象是使用 CodeSource(URL url, CodeSigner[] signers) 构造方法创建的，则提取其证书链并使用它们来创建一个 Certificate 对象数组。每个签名证书后面跟着其支持证书链（可能为空）。每个签名证书及其支持证书链按从底到顶进行排序（即签名证书排在首位置，（根）证书授权排在末位置）。

返回：
证书数组的副本；如果不存在副本，则返回 null。

getCodeSigners

public final CodeSigner[] getCodeSigners()
返回与此 CodeSource 关联的代码签名者。

如果此 CodeSource 对象是使用 CodeSource(URL url, Certificate[] certs) 构造方法创建的，则提取其证书链并使用它们来创建一个 CodeSigner 对象数组。注意，仅检查 X.509 证书，所有其他证书类型都将被忽略。

返回：
代码签名者数组的副本；如果不存在副本，则返回 null。
从以下版本开始：
1.5

implies

public boolean implies(CodeSource codesource)
如果此 CodeSource 对象“暗含”指定的 CodeSource，则返回 true。

更确切地说，此方法将按顺序进行以下检查。如果任何一项检查失败，它都返回 false。如果所有检查都成功了，它将返回 true。

  1. codesource 一定不能为 null。
  2. 如果此对象的证书不为 null，则此对象的所有证书一定都存在于 codesource 的证书中。
  3. 如果此对象的位置 (getLocation()) 不为 null，则针对此对象的位置和 codesource 的位置进行以下检查：

    1. codesource 的位置一定不能为 null。
    2. 如果此对象的位置等于 codesource 的位置，则返回 true。
    3. 此对象的协议 (getLocation().getProtocol()) 一定等于 codesource 的协议。
    4. 如果此对象的主机 (getLocation().getHost()) 不为 null，则使用此对象的主机构造的 SocketPermission 一定暗含使用 codesource 的主机构造的 SocketPermission。
    5. 如果此对象的端口 (getLocation().getPort()) 不等于 -1（即如果端口是指定的），则它必须等于 codesource 的端口。
    6. 如果此对象的文件 (getLocation().getFile()) 不等于 codesource 的文件，则进行以下检查：如果此对象的文件以 "/-" 结尾，则 codesource 的文件必须使用此对象的文件（不包括尾部 "-"）开头。如果此对象的文件以 "/*" 结尾，则 codesource 的文件必须使用此对象的文件开头并且一定不能再有 "/" 分隔符。如果此对象的文件不以 "/" 结尾，则 codesource 的文件必须使用追加的一个 '/'来匹配此对象的文件。
    7. 如果此对象的引用 (getLocation().getRef()) 不为 null，则它必须等于 codesource 的引用。

例如，具有以下位置和 null 证书的 codesource 对象都暗含具有 "http://java.sun.com/classes/foo.jar" 位置和 null 证书的 codesource。

     http:
     http://*.sun.com/classes/*
     http://java.sun.com/classes/-
     http://java.sun.com/classes/foo.jar
注意，如果此 CodeSource 具有 null 位置和 null 证书链，则其暗含所有其他的 CodeSource。

参数：
codesource - 用于比较的 CodeSource。
返回：
如果此 codesource 暗含指定的 codesource，则返回 true；否则返回 false。

toString

public String toString()
返回描述此 CodeSource 的字符串，告知其 URL 和证书。

覆盖：
类 Object 中的 toString
返回：
关于此 CodeSource 的信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DigestException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 DigestException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.DigestException
所有已实现的接口：
Serializable
public class DigestException
extends GeneralSecurityException

此为一般 Message Digest 异常。

另请参见：
序列化表格

构造方法摘要
DigestException()
构造不带详细消息的 DigestException。
DigestException(String msg)
构造带指定详细消息的 DigestException。
DigestException(String message, Throwable cause)
创建带指定详细消息和 cause 的 DigestException。
DigestException(Throwable cause)
创建带指定 cause 和详细消息 DigestException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DigestException

public DigestException()
构造不带详细消息的 DigestException。（详细消息是描述此特定异常的 String）。

DigestException

public DigestException(String msg)
构造带指定详细消息的 DigestException。（详细消息是描述此特定异常的 String）。

参数：
msg - 详细消息。

DigestException

public DigestException(String message,
                       Throwable cause)
创建带指定详细消息和 cause 的 DigestException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存它以便以后通过 Throwable.getCause() 方法获取）。（允许使用 null 值，指示 cause 不存在或未知。）
从以下版本开始：
1.5

DigestException

public DigestException(Throwable cause)
创建带指定 cause 和详细消息 DigestException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。

参数：
cause - cause（保存它以便以后通过 Throwable.getCause() 方法获取）。（允许使用 null 值，指示 cause 不存在或未知。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DomainCombiner (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 DomainCombiner

所有已知实现类：
SubjectDomainCombiner
public interface DomainCombiner

DomainCombiner 提供一个动态更新与当前 AccessControlContext 关联的 ProtectionDomain 的方法。

将 DomainCombiner 作为参数传递给 AccessControlContext 的适当的构造方法。然后，将新构造的上下文传递给 AccessController.doPrivileged(..., context) 方法来将提供的上下文（以及关联的 DomainCombiner）与当前的执行线程绑定在一起。对 AccessController.getContext 或 AccessController.checkPermission 的后续调用将导致对 DomainCombiner.combine 的调用。

combine 方法带有两个参数。第一个参数表示从最近一次调用 AccessController.doPrivileged 以来当前执行线程中 ProtectionDomain 的数组。如果没有调用 doPrivileged，则第一个参数将包含当前执行线程中的所有 ProtectionDomain。第二个参数表示继承的 ProtectionDomain 的数组，可能为 null。ProtectionDomain 可能是从父线程或特权上下文继承的。如果没有调用 doPrivileged，则第二个参数将包含从父线程继承的 ProtectionDomain。如果对 doPrivileged 进行了一次或多次调用，并且最近一次调用的是 doPrivileged(action, context)，那么第二个参数将包含特权上下文中的 ProtectionDomain。如果最近一次调用的是 doPrivileged(action)，则不存在特权上下文，第二个参数将为 null。

combine 方法研究两个 ProtectionDomain 的输入数组，返回包含更新的 ProtectionDomain 的单个数组。在最简单的情况下，combine 方法将两个堆栈合并为一个。在较复杂的情况下，combine 方法返回 ProtectionDomain 的修改的堆栈。修改操作可能添加新的 ProtectionDomain、移除某些特定的 ProtectionDomain 或者只是更新现有的 ProtectionDomain。对 ProtectionDomain 重新排序及进行其他优化也是允许的。通常，combine 方法基于 DomainCombiner 中封装的信息进行更新。

在 AccessController.getContext 方法从 DomainCombiner 接收 ProtectionDomain 后备的组合堆栈后，它将返回包含组合 ProtectionDomain 和 DomainCombiner 的新 AccessControlContext。

从以下版本开始：
1.3
另请参见：
AccessController, AccessControlContext

方法摘要
 ProtectionDomain[] combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
修改或更新提供的 ProtectionDomain。

方法详细信息

combine

ProtectionDomain[] combine(ProtectionDomain[] currentDomains,
                           ProtectionDomain[] assignedDomains)
修改或更新提供的 ProtectionDomain。可以将 ProtectionDomain 添加到给定的 ProtectionDomain 中，也可以从中移除。可以重新排列 ProtectionDomain 的顺序。可以修改个别 ProtectionDomain（例如，利用新的 Permission 的集合）。

参数：
currentDomains - 与当前执行线程关联的 ProtectionDomain，直到最近的特权 ProtectionDomain.ProtectionDomain 按执行的顺序列出，最近执行的 ProtectionDomain 位于数组的开头。如果当前执行的线程没有任何关联的 ProtectionDomain，则此参数为 null。

assignedDomains - 继承的 ProtectionDomain 组成的数组。ProtectionDomain 可能是从父线程或特权 AccessControlContext 继承的。如果不存在任何继承的 ProtectionDomain，则此参数为 null。
返回：
由更新的 ProtectionDomain 组成的新数组；或者 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DigestInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 DigestInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.security.DigestInputStream
所有已实现的接口：
Closeable
public class DigestInputStream
extends FilterInputStream

使用通过流的位更新关联消息摘要的透明流。

要完成消息摘要计算，先要调用此摘要输入流的一个 read 方法，之后在关联的消息摘要上调用一个 digest 方法。

开启或关闭此流都是可能的（请参见 on）。开启时，调用 read 方法之一将导致消息摘要的更新。但是关闭时，不更新消息摘要。流在默认情况下是开启的。

注意，摘要对象只能计算一个摘要（参见 MessageDigest），因此，为了计算中间摘要，调用者应该保留到摘要对象的句柄并为要计算的每一个摘要复制该对象，不改动原始摘要。

另请参见：
MessageDigest, DigestOutputStream

字段摘要
protected  MessageDigest digest
与此流关联的消息摘要。
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
DigestInputStream(InputStream stream, MessageDigest digest)
使用指定的输入流和消息摘要创建一个摘要输入流。
方法摘要
MessageDigest | getMessageDigest() 返回与此流关联的消息摘要。
void | on(boolean on) 开启或关闭摘要功能。
int | read() 读取字节并更新消息摘要（如果开启了摘要功能）。
int | read(byte[] b, int off, int len) 读入 byte 数组并更新消息摘要（如果开启了摘要功能）。
void | setMessageDigest(MessageDigest digest) 将指定的消息摘要与此流相关联。
String | toString() 打印此摘要输入流及其关联的消息摘要对象的字符串表示形式。
从类 java.io.FilterInputStream 继承的方法
available, close, mark, markSupported, read, reset, skip
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

digest

protected MessageDigest digest
与此流关联的消息摘要。

构造方法详细信息

DigestInputStream

public DigestInputStream(InputStream stream,
                         MessageDigest digest)
使用指定的输入流和消息摘要创建一个摘要输入流。

参数：
stream - 输入流。
digest - 要与此流关联的消息摘要。
方法详细信息

getMessageDigest

public MessageDigest getMessageDigest()
返回与此流关联的消息摘要。

返回：
与此流关联的消息摘要。
另请参见：
setMessageDigest(java.security.MessageDigest)

setMessageDigest

public void setMessageDigest(MessageDigest digest)
将指定的消息摘要与此流相关联。

参数：
digest - 要与此流关联的消息摘要。
另请参见：
getMessageDigest()

read

public int read()
         throws IOException
读取字节并更新消息摘要（如果开启了摘要功能）。即此方法从输入流读取字节，在实际读取字节前一直为阻塞状态。如果开启摘要功能（参见 on），则此方法将在与此流关联的消息摘要上调用 update，将读取的字节传递给该方法。

覆盖：
类 FilterInputStream 中的 read
返回：
读取的字节。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
MessageDigest.update(byte)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
读入 byte 数组并更新消息摘要（如果开启了摘要功能）。即此方法从输入流将至多 len 个字节读入数组 b，从偏移量 off 开始。此方法在实际读取数据前一直阻塞。如果开启摘要功能（参见 on），则此方法将在与此流关联的消息摘要上调用 update，将数据传递给该方法。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 从中读取数据的数组。
off - b 中的偏移量，应将数据从此处开始放入数组。
len - 从输入流读入 b 的最大字节数，从偏移量 off 开始。
返回：
读取的实际字节数。如果在读取 len 个字节前到达了流的末尾，则其小于 len。如果因为进行调用时已经到达了流的末尾而没有读取任何字节，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
MessageDigest.update(byte[], int, int)

on

public void on(boolean on)
开启或关闭摘要功能。默认为开启。开启时，调用 read 方法之一将导致消息摘要的更新。但是关闭时，不更新消息摘要。

参数：
on - 为 true 表示开启摘要功能，为 false 表示关闭。

toString

public String toString()
打印此摘要输入流及其关联的消息摘要对象的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DigestOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 DigestOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.security.DigestOutputStream
所有已实现的接口：
Closeable, Flushable
public class DigestOutputStream
extends FilterOutputStream

使用通过流的位更新关联消息摘要的透明流。

要完成消息摘要计算，先要调用此摘要输出流的一个 write 方法，之后在关联的消息摘要上调用 digest 方法之一。

开启或关闭此流都是可能的（参见 on）。开启时，调用 write 方法之一将导致消息摘要的更新。但是关闭时，不更新消息摘要。流在默认情况下是开启的。

另请参见：
MessageDigest, DigestInputStream

字段摘要
protected  MessageDigest digest
与此流关联的消息摘要。
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
DigestOutputStream(OutputStream stream, MessageDigest digest)
使用指定的输出流和消息摘要创建一个摘要输出流。
方法摘要
MessageDigest | getMessageDigest() 返回与此流关联的消息摘要。
void | on(boolean on) 开启或关闭摘要功能。
void | setMessageDigest(MessageDigest digest) 将指定的消息摘要与此流相关联。
String | toString() 打印此摘要输出流及其关联的消息摘要对象的字符串表示形式。
void | write(byte[] b, int off, int len) 使用指定的子数组更新消息摘要（如果开启了摘要功能），并将子数组写入输出流（不管是否开启了摘要功能）。
void | write(int b) 使用指定的字节更新消息摘要（如果开启了摘要功能），并将字节写入输出流（不管是否开启了摘要功能）。
从类 java.io.FilterOutputStream 继承的方法
close, flush, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

digest

protected MessageDigest digest
与此流关联的消息摘要。

构造方法详细信息

DigestOutputStream

public DigestOutputStream(OutputStream stream,
                          MessageDigest digest)
使用指定的输出流和消息摘要创建一个摘要输出流。

参数：
stream - 输出流。
digest - 要与此流关联的消息摘要。
方法详细信息

getMessageDigest

public MessageDigest getMessageDigest()
返回与此流关联的消息摘要。

返回：
与此流关联的消息摘要。
另请参见：
setMessageDigest(java.security.MessageDigest)

setMessageDigest

public void setMessageDigest(MessageDigest digest)
将指定的消息摘要与此流相关联。

参数：
digest - 要与此流关联的消息摘要。
另请参见：
getMessageDigest()

write

public void write(int b)
           throws IOException
使用指定的字节更新消息摘要（如果开启了摘要功能），并将字节写入输出流（不管是否开启了摘要功能）。即如果开启摘要功能（参见 on），则此方法将在与此流关联的消息摘要上调用 update，将字节 b 传递给该方法。然后，此方法将字节写入输出流，在实际写入字节前一直为阻塞状态。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要用于更新和写入输出流的字节。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
MessageDigest.update(byte)

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
使用指定的子数组更新消息摘要（如果开启了摘要功能），并将子数组写入输出流（不管是否开启了摘要功能）。即如果开启摘要功能（参见 on），则此方法将在与此流关联的消息摘要上调用 update，将子数组规范传递给该方法。然后，此方法将子数组字节写入输出流，在实际写入字节前一直为阻塞状态。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要用于更新和写入输出流的包含子数组的数组。
off - 要更新和写入的第一个字节在 b 中的偏移量。
len - 要根据 b 更新和写入的数据的字节数，从偏移量 off 开始。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
MessageDigest.update(byte[], int, int)

on

public void on(boolean on)
开启或关闭摘要功能。默认为开启。开启时，调用 write 方法之一将导致消息摘要的更新。但是关闭时，不更新消息摘要。

参数：
on - 为 true 表示开启摘要功能，为 false 表示关闭。

toString

public String toString()
打印此摘要输出流及其关联的消息摘要对象的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GeneralSecurityException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 GeneralSecurityException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
所有已实现的接口：
Serializable
直接已知子类：
BadPaddingException, CertificateException, CertPathBuilderException, CertPathValidatorException, CertStoreException, CRLException, DigestException, ExemptionMechanismException, IllegalBlockSizeException, InvalidAlgorithmParameterException, InvalidKeySpecException, InvalidParameterSpecException, KeyException, KeyStoreException, LoginException, NoSuchAlgorithmException, NoSuchPaddingException, NoSuchProviderException, ShortBufferException, SignatureException, UnrecoverableEntryException
public class GeneralSecurityException
extends Exception

GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。

另请参见：
序列化表格

构造方法摘要
GeneralSecurityException()
构造不带详细消息的 GeneralSecurityException。
GeneralSecurityException(String msg)
构造带指定详细消息的 GeneralSecurityException。
GeneralSecurityException(String message, Throwable cause)
创建带指定详细消息和 cause 的 GeneralSecurityException。
GeneralSecurityException(Throwable cause)
用指定的原因和详细消息创建一个 GeneralSecurityException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

GeneralSecurityException

public GeneralSecurityException()
构造不带详细消息的 GeneralSecurityException。

GeneralSecurityException

public GeneralSecurityException(String msg)
构造带指定详细消息的 GeneralSecurityException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

GeneralSecurityException

public GeneralSecurityException(String message,
                                Throwable cause)
创建带指定详细消息和 cause 的 GeneralSecurityException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存它以便以后通过 Throwable.getCause() 方法获取）。（允许使用 null 值，指示 cause 不存在或未知。）
从以下版本开始：
1.5

GeneralSecurityException

public GeneralSecurityException(Throwable cause)
用指定的原因和详细消息创建一个 GeneralSecurityException，详细消息是 (cause==null ? null：cause.toString())（它通常包含该类和 cause 的详细消息）。

参数：
cause - cause（保存它以便以后通过 Throwable.getCause() 方法获取）。（允许使用 null 值，指示 cause 不存在或未知。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Guard (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 Guard

所有已知实现类：
AllPermission, AudioPermission, AuthPermission, AWTPermission, BasicPermission, DelegationPermission, FilePermission, LoggingPermission, ManagementPermission, MBeanPermission, MBeanServerPermission, MBeanTrustPermission, NetPermission, Permission, PrivateCredentialPermission, PropertyPermission, ReflectPermission, RuntimePermission, SecurityPermission, SerializablePermission, ServicePermission, SocketPermission, SQLPermission, SSLPermission, SubjectDelegationPermission, UnresolvedPermission, WebServicePermission
public interface Guard

此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。

此接口包含带有单个 object 参数的单个方法 checkGuard。调用 checkGuard 对象（通过 GuardedObject getObject 方法）可以确定是否允许访问对象。

另请参见：
GuardedObject

方法摘要
 void checkGuard(Object object)
确定是否允许访问受保护的 object 对象。

方法详细信息

checkGuard

void checkGuard(Object object)
                throws SecurityException
确定是否允许访问受保护的 object 对象。如果允许访问，则正常返回。否则，抛出 SecurityException。

参数：
object - 由 guard 保护的对象。
抛出：
SecurityException - 如果访问被拒绝。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GuardedObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 GuardedObject

java.lang.Object
    继承者  java.security.GuardedObject
所有已实现的接口：
Serializable
public class GuardedObject
extends Object
implements Serializable

GuardedObject 是一个用来保护对另一个对象的访问的对象。

GuardedObject 封装一个目标对象和一个 Guard 对象，仅当 Guard 对象允许时才可能对目标对象进行访问。一旦 GuardedObject 封装了某个对象，getObject 方法就会控制对该对象的访问,这一方法将对保护访问的 Guard 对象调用 checkGuard 方法。如果不允许访问，则抛出异常。

另请参见：
Guard, Permission, 序列化表格

构造方法摘要
GuardedObject(Object object, Guard guard)
使用指定的对象和 guard 构造 GuardedObject。
方法摘要
 Object getObject()
获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GuardedObject

public GuardedObject(Object object,
                     Guard guard)
使用指定的对象和 guard 构造 GuardedObject。如果 Guard 对象为 null，则对于谁可以访问对象没有任何限制。

参数：
object - 要保护的对象。
guard - 保护对对象的访问的 Guard 对象。
方法详细信息

getObject

public Object getObject()
                 throws SecurityException
获取受保护对象；如果 guard 拒绝了对受保护对象的访问，则抛出异常。

返回：
受保护对象
抛出：
SecurityException - 如果拒绝对受保护对象的访问。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Identity (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Identity

java.lang.Object
    继承者  java.security.Identity
所有已实现的接口：
Serializable, Principal
直接已知子类：
IdentityScope, Signer
已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。

@Deprecated
public abstract class Identity
extends Object
implements Principal, Serializable

此类表示身份：现实世界的对象，比如人、公司或组织，它们的身份可以通过使用公钥验证。Identity 也可以是更抽象（或具体）的概念，例如守护线程或智能卡。

所有的 Identity 对象都具有一个名称和一个公钥。名称是不可变的。Identity 也可以有作用域。也就是说，如果一个 Identity 被指定具有一个特定的作用域，那么 Identity 的名称和公钥在该作用域内是唯一的。

Identity 也有一个证书集合（都证明其本身的公钥）。只要密钥相同，在这些证书中指定的主体名称不必相同。

可以为 Identity 创建子类，以包括邮政和电子邮件地址、电话号码、面部图像和徽标等等。

另请参见：
IdentityScope, Signer, Principal, 序列化表格

构造方法摘要
protected | Identity() 已过时。 只用于序列化的构造器。
 | Identity(String name) 已过时。 构造一个具有指定名称且没有作用域的 Identity。
 | Identity(String name, IdentityScope scope) 已过时。 构造一个具有指定名称和作用域的 Identity。
方法摘要
void | addCertificate(Certificate certificate) 已过时。 为此 Identity 添加一个证书。
Certificate[] | certificates() 已过时。 返回此 Identity 所有证书的一个副本。
boolean | equals(Object identity) 已过时。 测试指定对象与此 Identity 的相等性。
String | getInfo() 已过时。 返回以前为此 Identity 指定的常规信息字符串。
String | getName() 已过时。 返回此 Identity 的名称。
PublicKey | getPublicKey() 已过时。 返回此 Identity 的公钥。
IdentityScope | getScope() 已过时。 返回此 Identity 的作用域。
int | hashCode() 已过时。 返回此 Identity 的哈希码。
protected boolean | identityEquals(Identity identity) 已过时。 测试指定 Identity 与此 Identity 的相等性。
void | removeCertificate(Certificate certificate) 已过时。 从此 Identity 中移除证书。
void | setInfo(String info) 已过时。 为此 Identity 指定一个常规信息字符串。
void | setPublicKey(PublicKey key) 已过时。 设置此 Identity 的公钥。
String | toString() 已过时。 返回描述此 Identity 的短字符串，说明其名称和作用域（如果有的话）。
String | toString(boolean detailed) 已过时。 返回此 Identity 的字符串表示形式，可以选择比不带任何参数的 toString 方法带有更多的详细信息。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Identity

protected Identity()
已过时。
只用于序列化的构造器。

Identity

public Identity(String name,
                IdentityScope scope)
         throws KeyManagementException
已过时。
构造一个具有指定名称和作用域的 Identity。

参数：
name - Identity 的名称。
scope - Identity 的作用域。
抛出：
KeyManagementException - 在此作用域内已经存在一个具有相同名称的 Identity。

Identity

public Identity(String name)
已过时。
构造一个具有指定名称且没有作用域的 Identity。

参数：
name - Identity 的名称。
方法详细信息

getName

public final String getName()
已过时。
返回此 Identity 的名称。

指定者：
接口 Principal 中的 getName
返回：
此 Identity 的名称。

getScope

public final IdentityScope getScope()
已过时。
返回此 Identity 的作用域。

返回：
此 Identity 的作用域。

getPublicKey

public PublicKey getPublicKey()
已过时。
返回此 Identity 的公钥。

返回：
此 Identity 的公钥。
另请参见：
setPublicKey(java.security.PublicKey)

setPublicKey

public void setPublicKey(PublicKey key)
                  throws KeyManagementException
已过时。
设置此 Identity 的公钥。此操作移除旧的密钥和此 Identity 的所有证书。

首先，如果存在安全管理器，则用 "setIdentityPublicKey" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以设置公钥。

参数：
key - 此 Identity 的公钥。
抛出：
KeyManagementException - 如果在此 Identity 的作用域内的另外一个 Identity 具有相同的公钥，或者发生其他异常。
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许设置公钥。
另请参见：
getPublicKey(), SecurityManager.checkSecurityAccess(java.lang.String)

setInfo

public void setInfo(String info)
已过时。
为此 Identity 指定一个常规信息字符串。

首先，如果有安全管理器，则用 "setIdentityInfo" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以指定信息字符串。

参数：
info - 信息字符串。
抛出：
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许设置信息字符串。
另请参见：
getInfo(), SecurityManager.checkSecurityAccess(java.lang.String)

getInfo

public String getInfo()
已过时。
返回以前为此 Identity 指定的常规信息字符串。

返回：
关于此 Identity 的常规信息。
另请参见：
setInfo(java.lang.String)

addCertificate

public void addCertificate(Certificate certificate)
                    throws KeyManagementException
已过时。
为此 Identity 添加一个证书。如果 Identity 有一个公钥，则证书中的公钥必须相同，如果 Identity 没有公钥，则将 Identity 的公钥设置为证书中所指定的公钥。

首先，如果存在安全管理器，则用 "addIdentityCertificate" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以添加一个证书。

参数：
certificate - 要添加的证书。
抛出：
KeyManagementException - 如果证书是无效的；如果要添加到证书中的公钥和此 Identity 冲突；如果发生其他异常。
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许添加证书。
另请参见：
SecurityManager.checkSecurityAccess(java.lang.String)

removeCertificate

public void removeCertificate(Certificate certificate)
                       throws KeyManagementException
已过时。
从此 Identity 中移除证书。

首先，如果存在安全管理器，则用 "removeIdentityCertificate" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以移除证书。

参数：
certificate - 要移除的证书。
抛出：
KeyManagementException - 如果证书丢失，或者发生其他异常。
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许移除证书。
另请参见：
SecurityManager.checkSecurityAccess(java.lang.String)

certificates

public Certificate[] certificates()
已过时。
返回此 Identity 所有证书的一个副本。

返回：
此 Identity 所有证书的一个副本。

equals

public final boolean equals(Object identity)
已过时。
测试指定对象与此 Identity 的相等性。此方法首先测试两个实体是否实际引用的是同一对象，在这种情况下它返回 true。然后它检查两个实体是否有相同的名称和作用域。如果是这样，则该方法返回 true。否则，它调用子类应该重写的 identityEquals。

指定者：
接口 Principal 中的 equals
覆盖：
类 Object 中的 equals
参数：
identity - 要与此 Identity 进行相等性测试的对象。
返回：
如果对象被视为相等，则返回 true；否则返回 false。
另请参见：
identityEquals(java.security.Identity)

identityEquals

protected boolean identityEquals(Identity identity)
已过时。
测试指定 Identity 与此 Identity 的相等性。子类应该重写此方法来测试相等性。如果名称和公钥相等，默认的行为是返回 true。

参数：
identity - 要与此 Identity 进行相等性测试的 Identity。
返回：
如果 Identity 被视为相等，则返回 true；否则，返回 false。
另请参见：
equals(java.lang.Object)

toString

public String toString()
已过时。
返回描述此 Identity 的短字符串，说明其名称和作用域（如果有的话）。

首先，如果存在安全管理器，则用 "printIdentity" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以返回字符串。

指定者：
接口 Principal 中的 toString
覆盖：
类 Object 中的 toString
返回：
关于此 Identity 的信息，例如其名称和作用域（如果有的话）。
抛出：
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许返回描述此 Identity 的字符串。
另请参见：
SecurityManager.checkSecurityAccess(java.lang.String)

toString

public String toString(boolean detailed)
已过时。
返回此 Identity 的字符串表示形式，可以选择比不带任何参数的 toString 方法带有更多的详细信息。

首先，如果存在安全管理器，则用 "printIdentity" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以返回字符串。

参数：
detailed - 是否提供详细的信息。
返回：
关于此 Identity 的信息。如果 detailed 为 true，那么此方法比不带任何参数的 toString 方法返回更多的信息。
抛出：
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许返回描述此 Identity 的字符串。
另请参见：
toString(), SecurityManager.checkSecurityAccess(java.lang.String)

hashCode

public int hashCode()
已过时。
返回此 Identity 的哈希码。

指定者：
接口 Principal 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 Identity 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdentityScope (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 IdentityScope

java.lang.Object
    继承者  java.security.Identity
        继承者  java.security.IdentityScope
所有已实现的接口：
Serializable, Principal
已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。

@Deprecated
public abstract class IdentityScope
extends Identity

此类表示身份的作用域。它本身也是 Identity，因此有名称和作用域。它也可以选择有一个公钥和关联的证书。

IdentityScope 可以包括各种类型的 Identity 对象，包括 Signer。所有类型的 Identity 对象都可以使用相同的方法获取、添加和删除。注意，对于在各种类型的 Identity 上的各种操作，不同类型的身份作用域将应用不同的策略，这是可能的，实际上也期望如此。

密钥和身份是一对一的映射关系，在每个作用域内一个密钥只能有一个副本。例如，假定 Acme Software, Inc 是用户已知的软件发行人。假定它是一个 Identity，也就是说，它有公钥和关联的证书集合。它在某个作用域内使用名称 "Acme Software" 命名。该作用域内没有其他指定 Identity 具有相同的公钥。当然，也没有相同的名称。

另请参见：
Identity, Signer, Principal, Key, 序列化表格

构造方法摘要
protected | IdentityScope() 已过时。 此构造方法只用于序列化，不能被子类使用。
 | IdentityScope(String name) 已过时。 构造具有指定名称的新身份作用域。
 | IdentityScope(String name, IdentityScope scope) 已过时。 构造具有指定名称和作用域的新身份作用域。
方法摘要
abstract void | addIdentity(Identity identity) 已过时。 向此身份作用域添加一个身份。
Identity | getIdentity(Principal principal) 已过时。 获取名称与指定的主体相同的身份。
abstract Identity | getIdentity(PublicKey key) 已过时。 获取具有指定公钥的身份。
abstract Identity | getIdentity(String name) 已过时。 返回此作用域内具有指定名称的身份（如果有的话）。
static IdentityScope | getSystemScope() 已过时。 返回系统的身份作用域。
abstract Enumeration<Identity> | identities() 已过时。 返回此身份作用域内所有身份的枚举。
abstract void | removeIdentity(Identity identity) 已过时。 从此身份作用作用域移除一个身份。
protected static void | setSystemScope(IdentityScope scope) 已过时。 设置系统的身份作用域。
abstract int | size() 已过时。 返回此身份作用域内身份的数目。
String | toString() 已过时。 返回此身份作用域的字符串表示形式，包括其名称、作用域名称和此身份作用域中身份的数目。
从类 java.security.Identity 继承的方法
addCertificate, certificates, equals, getInfo, getName, getPublicKey, getScope, hashCode, identityEquals, removeCertificate, setInfo, setPublicKey, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

IdentityScope

protected IdentityScope()
已过时。
此构造方法只用于序列化，不能被子类使用。

IdentityScope

public IdentityScope(String name)
已过时。
构造具有指定名称的新身份作用域。

参数：
name - 作用域名称。

IdentityScope

public IdentityScope(String name,
                     IdentityScope scope)
              throws KeyManagementException
已过时。
构造具有指定名称和作用域的新身份作用域。

参数：
name - 作用域名称。
scope - 新身份作用域的作用域。
抛出：
KeyManagementException - 在此作用域内已经存在一个具有相同名称的 Identity。
方法详细信息

getSystemScope

public static IdentityScope getSystemScope()
已过时。
返回系统的身份作用域。

返回：
系统的身份作用域。
另请参见：
setSystemScope(java.security.IdentityScope)

setSystemScope

protected static void setSystemScope(IdentityScope scope)
已过时。
设置系统的身份作用域。

首先，如果存在安全管理器，则用 "setSystemScope" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以设置身份作用域。

参数：
scope - 要设置的作用域。
抛出：
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许设置身份作用域。
另请参见：
getSystemScope(), SecurityManager.checkSecurityAccess(java.lang.String)

size

public abstract int size()
已过时。
返回此身份作用域内身份的数目。

返回：
此身份作用域内身份的数目。

getIdentity

public abstract Identity getIdentity(String name)
已过时。
返回此作用域内具有指定名称的身份（如果有的话）。

参数：
name - 要获取的身份的名称。
返回：
名称为 name 的身份，如果在此作用域内没有名称为 name 的身份，则返回 null。

getIdentity

public Identity getIdentity(Principal principal)
已过时。
获取名称与指定的主体相同的身份。（注：Identity 实现 Principal。）

参数：
principal - 相应于要获取的身份的主体。
返回：
名称与指定的主体相同的身份，如果在此作用域内没有具有该名称的身份，则返回 null。

getIdentity

public abstract Identity getIdentity(PublicKey key)
已过时。
获取具有指定公钥的身份。

参数：
key - 要返回的身份的公钥。
返回：
具有给定密钥的身份，如果此作用域内没有具有该密钥的身份，则返回 null。

addIdentity

public abstract void addIdentity(Identity identity)
                          throws KeyManagementException
已过时。
向此身份作用域添加一个身份。

参数：
identity - 要添加的身份。
抛出：
KeyManagementException - 如果身份是无效的、出现了名称冲突、另一个身份与要添加的身份有相同的公钥，或者出现其他异常

removeIdentity

public abstract void removeIdentity(Identity identity)
                             throws KeyManagementException
已过时。
从此身份作用作用域移除一个身份。

参数：
identity - 要移除的身份。
抛出：
KeyManagementException - 如果身份丢失或出现其他的异常。

identities

public abstract Enumeration<Identity> identities()
已过时。
返回此身份作用域内所有身份的枚举。

返回：
此身份作用域内所有身份的枚举。

toString

public String toString()
已过时。
返回此身份作用域的字符串表示形式，包括其名称、作用域名称和此身份作用域中身份的数目。

指定者：
接口 Principal 中的 toString
覆盖：
类 Identity 中的 toString
返回：
此身份作用域的字符串表示形式。
另请参见：
SecurityManager.checkSecurityAccess(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidAlgorithmParameterException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 InvalidAlgorithmParameterException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.InvalidAlgorithmParameterException
所有已实现的接口：
Serializable
public class InvalidAlgorithmParameterException
extends GeneralSecurityException

用于无效或不合适的算法参数的异常。

从以下版本开始：
1.2
另请参见：
AlgorithmParameters, AlgorithmParameterSpec, 序列化表格

构造方法摘要
InvalidAlgorithmParameterException()
构造不带详细消息的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(String msg)
构造带指定详细消息的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。
InvalidAlgorithmParameterException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidAlgorithmParameterException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidAlgorithmParameterException

public InvalidAlgorithmParameterException()
构造不带详细消息的 InvalidAlgorithmParameterException。详细消息是描述此特定异常的字符串。

InvalidAlgorithmParameterException

public InvalidAlgorithmParameterException(String msg)
构造带指定详细消息的 InvalidAlgorithmParameterException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

InvalidAlgorithmParameterException

public InvalidAlgorithmParameterException(String message,
                                          Throwable cause)
创建带指定详细消息和 cause 的 InvalidAlgorithmParameterException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5

InvalidAlgorithmParameterException

public InvalidAlgorithmParameterException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidAlgorithmParameterException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidKeyException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 InvalidKeyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.KeyException
                    继承者  java.security.InvalidKeyException
所有已实现的接口：
Serializable
public class InvalidKeyException
extends KeyException

用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。

另请参见：
序列化表格

构造方法摘要
InvalidKeyException()
构造不带详细消息的 InvalidKeyException。
InvalidKeyException(String msg)
构造带指定详细消息的 InvalidKeyException。
InvalidKeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 InvalidKeyException。
InvalidKeyException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidKeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidKeyException

public InvalidKeyException()
构造不带详细消息的 InvalidKeyException。详细消息是描述此特定异常的字符串。

InvalidKeyException

public InvalidKeyException(String msg)
构造带指定详细消息的 InvalidKeyException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

InvalidKeyException

public InvalidKeyException(String message,
                           Throwable cause)
创建带指定详细消息和 cause 的 InvalidKeyException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5

InvalidKeyException

public InvalidKeyException(Throwable cause)
创建带指定 cause 和详细消息的 InvalidKeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidParameterException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 InvalidParameterException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.security.InvalidParameterException
所有已实现的接口：
Serializable
public class InvalidParameterException
extends IllegalArgumentException

当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。

另请参见：
序列化表格

构造方法摘要
InvalidParameterException()
构造不带详细消息的 InvalidParameterException。
InvalidParameterException(String msg)
构造带指定详细消息的 InvalidParameterException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidParameterException

public InvalidParameterException()
构造不带详细消息的 InvalidParameterException。详细消息是描述此特定异常的字符串。

InvalidParameterException

public InvalidParameterException(String msg)
构造带指定详细消息的 InvalidParameterException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Key (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 Key

所有超级接口：
Serializable
所有已知子接口：
DHPrivateKey, DHPublicKey, DSAPrivateKey, DSAPublicKey, ECPrivateKey, ECPublicKey, PBEKey, PrivateKey, PublicKey, RSAMultiPrimePrivateCrtKey, RSAPrivateCrtKey, RSAPrivateKey, RSAPublicKey, SecretKey
所有已知实现类：
KerberosKey, SecretKeySpec
public interface Key
extends Serializable

Key 是所有密钥的顶层接口。它定义了供所有密钥对象共享的功能。所有的密钥都具有三个特征：

  • 算法

    这是该密钥的密钥算法。密钥算法通常是加密或不对称操作算法（如 DSA 或 RSA），它们将和那些算法及相关的算法（例如 MD5 和 RSA，SHA-1 和 RSA、Raw DSA 等等）一起使用。用 getAlgorithm 方法获取密钥算法的名称。

  • 编码形式

    这是密钥的外部编码形式，在 Java 虚拟机之外需要密钥的标准表示形式时以及将密钥传输到其他某些部分时使用。密钥根据标准格式（如 X.509 SubjectPublicKeyInfo 或 PKCS#8）编码，使用 getEncoded 方法返回。注：ASN.1 类型 SubjectPublicKeyInfo 的语法定义如下：

     SubjectPublicKeyInfo ::= SEQUENCE {
   algorithm AlgorithmIdentifier,
   subjectPublicKey BIT STRING }

 AlgorithmIdentifier ::= SEQUENCE {
   algorithm OBJECT IDENTIFIER,
   parameters ANY DEFINED BY algorithm OPTIONAL }
    有关更多信息，请参见 RFC 2459: Internet X.509 Public Key Infrastructure Certificate and CRL Profile.

  • 格式

    这是已编码密钥的格式的名称。它由 getFormat 方法返回。

密钥通常通过密钥生成器、证书或用来管理密钥的各种 Identity 类来获取。密钥也可以通过使用密钥工厂（请参见 KeyFactory）从密钥规范（基础密钥材料的透明表示形式）获取。

密钥应该使用 KeyRep 作为其序列化的表示形式。注意，序列化的 Key 可能包含不应该在不可信任的环境中显示的敏感信息。有关更多信息，请参见序列化规范的安全附录。

另请参见：
PublicKey, PrivateKey, KeyPair, KeyPairGenerator, KeyFactory, KeyRep, KeySpec, Identity, Signer

字段摘要
static long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。
方法摘要
String | getAlgorithm() 返回此密钥的标准算法名称。
byte[] | getEncoded() 返回基本编码格式的密钥，如果此密钥不支持编码，则返回 null。
String | getFormat() 返回此密钥的基本编码格式，如果此密钥不支持编码，则返回 null。

字段详细信息

serialVersionUID

static final long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。

另请参见：
常量字段值
方法详细信息

getAlgorithm

String getAlgorithm()
返回此密钥的标准算法名称。例如，"DSA" 指示此密钥是一个 DSA 密钥。有关标准算法名称的信息，请参见 Java Cryptography Architecture API Specification & Reference 中的附录 A。

返回：
与此密钥关联的算法名称。

getFormat

String getFormat()
返回此密钥的基本编码格式，如果此密钥不支持编码，则返回 null。如果存在此密钥的 ASN.1 规范，则根据合适的 ASN.1 数据格式命名基本编码格式。例如，公钥的 ASN.1 数据格式名称是 SubjectPublicKeyInfo（由 X.509 标准定义）；在这种情况下，返回的格式为 "X.509"。类似地，私钥的 ASN.1 数据格式名称是 PrivateKeyInfo（由 PKCS #8 标准定义）；在这种情况下，返回的格式为 "PKCS#8"。

返回：
密钥的基本编码格式。

getEncoded

byte[] getEncoded()
返回基本编码格式的密钥，如果此密钥不支持编码，则返回 null。

返回：
编码的密钥，如果此密钥不支持编码，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.KeyException
所有已实现的接口：
Serializable
直接已知子类：
InvalidKeyException, KeyManagementException
public class KeyException
extends GeneralSecurityException

此异常是基本的密钥异常。

另请参见：
Key, InvalidKeyException, KeyManagementException, 序列化表格

构造方法摘要
KeyException()
构造不带详细消息的 KeyException。
KeyException(String msg)
构造带指定详细消息的 KeyException。
KeyException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyException。
KeyException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeyException

public KeyException()
构造不带详细消息的 KeyException。详细消息是描述此特定异常的字符串。

KeyException

public KeyException(String msg)
构造带指定详细消息的 KeyException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

KeyException

public KeyException(String message,
                    Throwable cause)
创建带指定详细消息和 cause 的 KeyException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5

KeyException

public KeyException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyFactory

java.lang.Object
    继承者  java.security.KeyFactory

public class KeyFactory
extends Object

密钥工厂用于将密钥（Key 类型的不透明加密密钥）转换成密钥规范（底层密钥材料的透明表示），反之亦然。

密钥工厂是双向的。也就是说，它们允许根据给定的密钥规范（密钥材料）构建不透明的密钥对象，也允许获取以恰当格式表示的密钥对象的底层密钥材料。

对于同一个密钥可以存在多个兼容的密钥规范。例如，可以使用 DSAPublicKeySpec 或 X509EncodedKeySpec 指定 DSA 公钥。密钥工厂可用于兼容密钥规范之间的转换。

以下是一个如何使用密钥工厂根据其编码实例化 DSA 公钥的示例。假定 Alice 收到了 Bob 的数字签名。Bob 也向她发送其公钥（以编码的格式）来验证他的签名。然后 Alice 执行以下操作：

 X509EncodedKeySpec bobPubKeySpec = new X509EncodedKeySpec(bobEncodedPubKey);
 KeyFactory keyFactory = KeyFactory.getInstance("DSA");
 PublicKey bobPubKey = keyFactory.generatePublic(bobPubKeySpec);
 Signature sig = Signature.getInstance("DSA");
 sig.initVerify(bobPubKey);
 sig.update(data);
 sig.verify(signature);

从以下版本开始：
1.2
另请参见：
Key, PublicKey, PrivateKey, KeySpec, DSAPublicKeySpec, X509EncodedKeySpec

构造方法摘要
protected KeyFactory(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 KeyFactory 对象。
方法摘要
 PrivateKey generatePrivate(KeySpec keySpec)
根据提供的密钥规范（密钥材料）生成私钥对象。
 PublicKey generatePublic(KeySpec keySpec)
根据提供的密钥规范（密钥材料）生成公钥对象。
 String getAlgorithm()
获取与此 KeyFactory 关联的算法的名称。
static KeyFactory getInstance(String algorithm)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static KeyFactory getInstance(String algorithm, Provider provider)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static KeyFactory getInstance(String algorithm, String provider)
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
<T extends KeySpec>
T
getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
 Provider getProvider()
返回此密钥工厂对象的提供者。
 Key translateKey(Key key)
将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyFactory

protected KeyFactory(KeyFactorySpi keyFacSpi,
                     Provider provider,
                     String algorithm)
创建一个 KeyFactory 对象。

参数：
keyFacSpi - 代理
provider - 提供者
algorithm - 与此 KeyFactory 关联的算法名称
方法详细信息

getInstance

public static KeyFactory getInstance(String algorithm)
                              throws NoSuchAlgorithmException
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 KeyFactorySpi 实现的新 KeyFactory 对象，该实现取自第一个支持指定算法的 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 请求密钥算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
新的 KeyFactory 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 KeyFactorySpi 实现。
另请参见：
Provider

getInstance

public static KeyFactory getInstance(String algorithm,
                                     String provider)
                              throws NoSuchAlgorithmException,
                                     NoSuchProviderException
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

返回一个封装 KeyFactorySpi 实现的新 KeyFactory 对象，该实现取自指定提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 请求密钥算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者的名称。
返回：
新的 KeyFactory 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 KeyFactorySpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static KeyFactory getInstance(String algorithm,
                                     Provider provider)
                              throws NoSuchAlgorithmException
返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

返回一个封装 KeyFactorySpi 实现的新 KeyFactory 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 请求密钥算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者。
返回：
新的 KeyFactory 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定 Provider 对象获得指定算法的 KeyFactorySpi 实现。
IllegalArgumentException - 如果指定提供者为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此密钥工厂对象的提供者。

返回：
此密钥工厂对象的提供者。

getAlgorithm

public final String getAlgorithm()
获取与此 KeyFactory 关联的算法的名称。

返回：
与此 KeyFactory 关联的算法的名称。

generatePublic

public final PublicKey generatePublic(KeySpec keySpec)
                               throws InvalidKeySpecException
根据提供的密钥规范（密钥材料）生成公钥对象。

参数：
keySpec - 公钥的规范（密钥材料）。
返回：
公钥。
抛出：
InvalidKeySpecException - 如果给定的密钥规范不适合此密钥工厂生成公钥。

generatePrivate

public final PrivateKey generatePrivate(KeySpec keySpec)
                                 throws InvalidKeySpecException
根据提供的密钥规范（密钥材料）生成私钥对象。

参数：
keySpec - 私钥的规范（密钥材料）。
返回：
私钥。
抛出：
InvalidKeySpecException - 如果给定的密钥规范不适合此密钥工厂生成私钥。

getKeySpec

public final <T extends KeySpec> T getKeySpec(Key key,
                                              Class<T> keySpec)
                                   throws InvalidKeySpecException
返回给定密钥对象的规范（密钥材料）。keySpec 标识应接受返回密钥材料的规范类。例如，它可能是 DSAPublicKeySpec.class，指示密钥材料应该返回到 DSAPublicKeySpec 类的一个实例中。

参数：
key - 密钥。
keySpec - 应接受返回密钥材料的规范类。
返回：
请求规范类实例中的底层密钥规范（密钥材料）。
抛出：
InvalidKeySpecException - 如果请求的密钥规范不适合给定密钥，或无法处理给定密钥（例如，给定密钥具有不能识别的算法或格式）。

translateKey

public final Key translateKey(Key key)
                       throws InvalidKeyException
将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。

参数：
key - 提供者未知或不受信任的密钥对象。
返回：
已转换的密钥。
抛出：
InvalidKeyException - 如果此密钥工厂无法处理给定密钥。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyFactorySpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyFactorySpi

java.lang.Object
    继承者  java.security.KeyFactorySpi

public abstract class KeyFactorySpi
extends Object

此类为 KeyFactory 类定义服务提供者接口 (SPI)。希望提供特定算法的密钥工厂实现的每个加密服务提供者必须实现此类中所有的抽象方法。

密钥工厂用来把 keys（类型 Key 的不透明密钥）转换成密钥规范（底层密钥材料的透明表示形式），反之亦然。

密钥工厂是双向的。也就是说，它们允许根据一个给定的密钥规范（密钥材料）来建造一个不透明的密钥对象，或获取以合适格式表示的密钥对象的底层密钥材料。

对于同一个密钥可以存在多个兼容的密钥规范。例如，一个 DSA 公钥可以使用 DSAPublicKeySpec 或 X509EncodedKeySpec 指定。密钥工厂可以用来在兼容的密钥规范之间转换。

provider 应该记录其密钥工厂支持的所有密钥规范。

从以下版本开始：
1.2
另请参见：
KeyFactory, Key, PublicKey, PrivateKey, KeySpec, DSAPublicKeySpec, X509EncodedKeySpec

构造方法摘要
KeyFactorySpi()
方法摘要
protected abstract  PrivateKey engineGeneratePrivate(KeySpec keySpec)
根据所提供的密钥规范（密钥材料）生成私钥对象。
protected abstract  PublicKey engineGeneratePublic(KeySpec keySpec)
根据所提供的密钥规范（密钥材料）生成公钥对象。
protected abstract
<T extends KeySpec>
T
engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
protected abstract  Key engineTranslateKey(Key key)
将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyFactorySpi

public KeyFactorySpi()
方法详细信息

engineGeneratePublic

protected abstract PublicKey engineGeneratePublic(KeySpec keySpec)
                                           throws InvalidKeySpecException
根据所提供的密钥规范（密钥材料）生成公钥对象。

参数：
keySpec - 公钥的规范（密钥材料）。
返回：
公钥。
抛出：
InvalidKeySpecException - 如果给定的密钥规范不适合此密钥工厂来生成公钥。

engineGeneratePrivate

protected abstract PrivateKey engineGeneratePrivate(KeySpec keySpec)
                                             throws InvalidKeySpecException
根据所提供的密钥规范（密钥材料）生成私钥对象。

参数：
keySpec - 私钥的规范（密钥材料）。
返回：
私钥。
抛出：
InvalidKeySpecException - 如果给定的密钥规范不适合此密钥工厂来生成私钥。

engineGetKeySpec

protected abstract <T extends KeySpec> T engineGetKeySpec(Key key,
                                                          Class<T> keySpec)
                                               throws InvalidKeySpecException
返回给定密钥对象的规范（密钥材料）。keySpec 标识应该将密钥材料返回到其中的规范类。例如，它可能是 DSAPublicKeySpec.class，指示密钥材料应该返回到 DSAPublicKeySpec 类的一个实例中。

参数：
key - 密钥。
keySpec - 应该将密钥材料返回到其中的规范类。
返回：
请求的规范类中的底层密钥规范（密钥材料）。
抛出：
InvalidKeySpecException - 如果请求的密钥规范不适合给定的密钥，或给定的密钥不能被处理（例如，给定的密钥具有不能识别的格式）。

engineTranslateKey

protected abstract Key engineTranslateKey(Key key)
                                   throws InvalidKeyException
将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。

参数：
key - 其 provider 是未知的或不受信任的密钥对象。
返回：
已转换的密钥。
抛出：
InvalidKeyException - 如果给定密钥不能被此密钥工厂处理。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyManagementException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyManagementException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.KeyException
                    继承者  java.security.KeyManagementException
所有已实现的接口：
Serializable
public class KeyManagementException
extends KeyException

此异常是用于所有处理密钥管理的操作的通用密钥管理异常。开发人员可能创建用来给出更多详细信息的 KeyManagementException 子类的示例可能包括：

  • KeyIDConflictException
  • KeyAuthorizationFailureException
  • ExpiredKeyException

另请参见：
Key, KeyException, 序列化表格

构造方法摘要
KeyManagementException()
构造不带详细消息的 KeyManagementException。
KeyManagementException(String msg)
构造带指定详细消息的 KeyManagementException。
KeyManagementException(String message, Throwable cause)
创建带指定详细消息和 cause 的 KeyManagementException。
KeyManagementException(Throwable cause)
创建带指定 cause 和详细消息的 KeyManagementException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeyManagementException

public KeyManagementException()
构造不带详细消息的 KeyManagementException。详细消息是描述此特定异常的字符串。

KeyManagementException

public KeyManagementException(String msg)
构造带指定详细消息的 KeyManagementException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

KeyManagementException

public KeyManagementException(String message,
                              Throwable cause)
创建带指定详细消息和 cause 的 KeyManagementException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

KeyManagementException

public KeyManagementException(Throwable cause)
创建带指定 cause 和详细消息的 KeyManagementException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出 cause 是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyPair (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyPair

java.lang.Object
    继承者  java.security.KeyPair
所有已实现的接口：
Serializable
public final class KeyPair
extends Object
implements Serializable

此类是简单的密钥对（公钥和私钥）持有者。它没有增强任何安全性，另外初始化时应该将它当作 PrivateKey 对待。

另请参见：
PublicKey, PrivateKey, 序列化表格

构造方法摘要
KeyPair(PublicKey publicKey, PrivateKey privateKey)
根据给定的公钥和私钥构造密钥对。
方法摘要
PrivateKey | getPrivate() 返回对此密钥对的私钥组件的引用。
PublicKey | getPublic() 返回对此密钥对的公钥组件的引用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyPair

public KeyPair(PublicKey publicKey,
               PrivateKey privateKey)
根据给定的公钥和私钥构造密钥对。

注意，此构造方法只在生成的密钥对中存储对公钥和私钥组件的引用。这是安全的，因为 Key 对象是不可变的。

参数：
publicKey - 公钥。
privateKey - 私钥。
方法详细信息

getPublic

public PublicKey getPublic()
返回对此密钥对的公钥组件的引用。

返回：
对公钥的一个引用。

getPrivate

public PrivateKey getPrivate()
返回对此密钥对的私钥组件的引用。

返回：
对私钥的一个引用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyRep (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyRep

java.lang.Object
    继承者  java.security.KeyRep
所有已实现的接口：
Serializable
public class KeyRep
extends Object
implements Serializable

已序列化的 Key 对象的标准表示形式。

注意，序列化的 Key 可能包含不应该在不可信任的环境中显示的敏感信息。有关更多信息，请参见序列化规范的安全附录。

从以下版本开始：
1.5
另请参见：
Key, KeyFactory, SecretKeySpec, X509EncodedKeySpec, PKCS8EncodedKeySpec, 序列化表格

嵌套类摘要
static class KeyRep.Type
Key 类型。
构造方法摘要
KeyRep(KeyRep.Type type, String algorithm, String format, byte[] encoded)
构造替换的 Key 类。
方法摘要
protected  Object readResolve()
解析 Key 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyRep

public KeyRep(KeyRep.Type type,
              String algorithm,
              String format,
              byte[] encoded)
构造替换的 Key 类。

参数：
type - Type.SECRET、Type.PUBLIC 或 Type.PRIVATE 之一
algorithm - 从 Key.getAlgorithm() 返回的算法
format - 从 Key.getFormat() 返回的编码格式
encoded - 从 Key.getEncoded() 返回的编码字节
抛出：
NullPointerException - 如果 type 为 null、algorithm 为 null、format 为 null 或 encoded 为 null
方法详细信息

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析 Key 对象。

此方法支持三种 Type/format 组合：

  • Type.SECRET/"RAW" - 返回使用编码的密钥字节和算法构建的 SecretKeySpec 对象
  • Type.PUBLIC/"X.509" - 获取该密钥算法的 KeyFactory 实例，用编码的密钥字节构建 X509EncodedKeySpec，根据 spec 生成公钥
  • Type.PRIVATE/"PKCS#8" - 获取该密钥算法的 KeyFactory 实例，用编码的密钥字节构造 PKCS8EncodedKeySpec，根据 spec 生成私钥

返回：
解析的 Key 对象
抛出：
ObjectStreamException - 如果 Type/format 组合是不能识别的；如果算法、密钥格式或编码的密钥字节是不能识别的/无效的；如果由于任何原因密钥解析失败。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyPairGenerator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyPairGenerator

java.lang.Object
    继承者  java.security.KeyPairGeneratorSpi
        继承者  java.security.KeyPairGenerator

public abstract class KeyPairGenerator
extends KeyPairGeneratorSpi

KeyPairGenerator 类用于生成公钥和私钥对。密钥对生成器是使用 getInstance 工厂方法（返回一个给定类的实例的静态方法）构造的。

特定算法的密钥对生成器可以创建能够与此算法一起使用的公钥/私钥对。它还可以将特定于算法的参数与每个生成的密钥关联。

有两种生成密钥对的方式：与算法无关的方式和特定于算法的方式。两种方式的唯一区别在于对象的初始化：

  • 与算法无关的初始化

    所有的密钥对生成器遵循密钥大小和随机源的概念。对于不同的算法，密钥大小的解释也不相同（例如，对于 DSA 算法，密钥大小对应于模的长度）。此 KeyPairGenerator 类有一个 initialize 方法，该方法带有两个通用的共享类型的参数。还有一个只带有 keysize 参数的方法，它使用以最高优先级安装的提供者的 SecureRandom 实现作为随机源。（如果任何安装的提供者都不提供 SecureRandom 的实现，则使用系统提供的随机源。）

    因为调用上述与算法无关的 initialize 方法时没有指定其他参数，所以由提供者决定如何处理与每个密钥关联的特定于算法的参数（如果有）。

    如果算法为 DSA 算法，密钥大小（模大小）为 512、768 或 1024，那么 Sun 提供者对 p、q 和 g 参数使用一组预计算值。如果模大小不是上述值之一，则 Sun 提供者创建一个新的参数集合。其他提供者可能具有供更多模大小（不仅仅是上文提及的那三个）使用的预计算参数集合。其他提供者也可能没有任何预计算参数列表，而总是创建新的参数集合。

  • 特定于算法的初始化

    对于特定于算法的参数集合已存在的情况（例如，DSA 中所谓的公用参数），有两个 initialize 方法具有 AlgorithmParameterSpec 参数。其中一个方法还有一个 SecureRandom 参数，而另一个方法使用以最高优先级安装的提供者的 SecureRandom 实现作为随机源。（如果任何安装的提供者都不提供 SecureRandom 的实现，则使用系统提供的随机源。）

每个提供者都必须提供（并记录）默认的初始化，以防客户端没有显式初始化 KeyPairGenerator（通过调用 initialize 方法）。例如，Sun 提供者使用 1024 位的默认模大小（密钥大小）。

注意，由于历史原因，此类是抽象类，是从 KeyPairGeneratorSpi 扩展的。应用程序开发人员只需注意在此 KeyPairGenerator 类中定义的方法；超类中的所有方法是供加密服务提供者使用的，这些加密服务提供者希望提供自己的密钥对生成器实现。

另请参见：
AlgorithmParameterSpec

构造方法摘要
protected KeyPairGenerator(String algorithm)
为指定的算法创建 KeyPairGenerator 对象。
方法摘要
KeyPair | generateKeyPair() 生成一个密钥对。
KeyPair | genKeyPair() 生成密钥对。
String | getAlgorithm() 返回此密钥对生成器算法的标准名称。
static KeyPairGenerator | getInstance(String algorithm) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyPairGenerator | getInstance(String algorithm, Provider provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyPairGenerator | getInstance(String algorithm, String provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
Provider | getProvider() 返回此密钥对生成器对象的提供者。
void | initialize(AlgorithmParameterSpec params) 初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。
void | initialize(AlgorithmParameterSpec params, SecureRandom random) 使用给定参数集合和随机源初始化密钥对生成器。
void | initialize(int keysize) 初始化确定密钥大小的密钥对生成器，使用默认的参数集合，并使用以最高优先级安装的提供者的 SecureRandom 实现作为随机源。
void | initialize(int keysize, SecureRandom random) 使用给定的随机源（和默认的参数集合）初始化确定密钥大小的密钥对生成器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyPairGenerator

protected KeyPairGenerator(String algorithm)
为指定的算法创建 KeyPairGenerator 对象。

参数：
algorithm - 算法的标准字符串名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
方法详细信息

getAlgorithm

public String getAlgorithm()
返回此密钥对生成器算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。

返回：
算法的标准字符串名称。

getInstance

public static KeyPairGenerator getInstance(String algorithm)
                                    throws NoSuchAlgorithmException
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回封装 KeyPairGeneratorSpi 实现的新 KeyPairGenerator 对象，该实现取自第一个支持指定算法的 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 算法的标准字符串名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
新的 KeyPairGenerator 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 KeyPairGeneratorSpi 实现。
另请参见：
Provider

getInstance

public static KeyPairGenerator getInstance(String algorithm,
                                           String provider)
                                    throws NoSuchAlgorithmException,
                                           NoSuchProviderException
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

返回一个封装 KeyPairGeneratorSpi 实现的新 KeyPairGenerator 对象，该实现取自指定提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 算法的标准字符串名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者的字符串名称。
返回：
新的 KeyPairGenerator 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 KeyPairGeneratorSpi 实现不能从指定提供者获得。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static KeyPairGenerator getInstance(String algorithm,
                                           Provider provider)
                                    throws NoSuchAlgorithmException
返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

返回一个封装 KeyPairGeneratorSpi 实现的新 KeyPairGenerator 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 算法的标准字符串名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者。
返回：
新的 KeyPairGenerator 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 KeyPairGeneratorSpi 实现不能从指定提供者对象获得。
IllegalArgumentException - 如果指定提供者为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此密钥对生成器对象的提供者。

返回：
返回此密钥对生成器对象的提供者

initialize

public void initialize(int keysize)
初始化确定密钥大小的密钥对生成器，使用默认的参数集合，并使用以最高优先级安装的提供者的 SecureRandom 实现作为随机源。（如果任何安装的提供者都不提供 SecureRandom 的实现，则使用系统提供的随机源。）

参数：
keysize - 密钥大小。它是特定于算法的度量（如模长度），以位数为单位指定。
抛出：
InvalidParameterException - 如果 keysize 不受此 KeyPairGenerator 对象支持。

initialize

public void initialize(int keysize,
                       SecureRandom random)
使用给定的随机源（和默认的参数集合）初始化确定密钥大小的密钥对生成器。

指定者：
类 KeyPairGeneratorSpi 中的 initialize
参数：
keysize - 密钥大小。它是特定于算法的度量（如模长度），以位数为单位指定。
random - 随机源。
抛出：
InvalidParameterException - 如果 keysize 不受此 KeyPairGenerator 对象支持。
从以下版本开始：
1.2

initialize

public void initialize(AlgorithmParameterSpec params)
                throws InvalidAlgorithmParameterException
初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。（如果任何安装的提供者都不提供 SecureRandom 的实现，则使用系统提供的随机源。）

已将此具体方法添加到以前定义的这个抽象类中。此方法调用 KeyPairGeneratorSpi 的 initialize 方法，为它传递 params 和随机源（从以最高优先级安装的提供者获得；如果任何已安装的提供者都不能提供，则由系统提供）。如果没有被提供者重写，则该 initialize 方法总是抛出 UnsupportedOperationException。

参数：
params - 用于生成密钥的参数集合。
抛出：
InvalidAlgorithmParameterException - 如果给定的参数不适合此密钥对生成器。
从以下版本开始：
1.2

initialize

public void initialize(AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
使用给定参数集合和随机源初始化密钥对生成器。

已将此具体方法添加到以前定义的这个抽象类中。此方法调用 KeyPairGeneratorSpi 的 initialize 方法，为它传递 params 和 random。如果没有被提供者重写，则该 initialize 方法总是抛出 UnsupportedOperationException。

覆盖：
类 KeyPairGeneratorSpi 中的 initialize
参数：
params - 用于生成密钥的参数集合。
random - 随机源。
抛出：
InvalidAlgorithmParameterException - 如果给定的参数不适合此密钥对生成器。
从以下版本开始：
1.2

genKeyPair

public final KeyPair genKeyPair()
生成密钥对。

如果此 KeyPairGenerator 没有被显式初始化，特定于提供者的默认值将用于所生成密钥的大小和其他（特定于算法的）值。

每次调用此方法都将生成新的密钥对。

此方法在功能上等同于 generateKeyPair。

返回：
生成的密钥对
从以下版本开始：
1.2

generateKeyPair

public KeyPair generateKeyPair()
生成一个密钥对。

如果此 KeyPairGenerator 没有被显式初始化，特定于提供者的默认值将用于所生成密钥的大小和其他（特定于算法的）值。

每次调用此方法都将生成新的密钥对。

此方法在功能上等同于 generateKeyPair。

指定者：
类 KeyPairGeneratorSpi 中的 generateKeyPair
返回：
生成的密钥对
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyPairGeneratorSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyPairGeneratorSpi

java.lang.Object
    继承者  java.security.KeyPairGeneratorSpi
直接已知子类：
KeyPairGenerator
public abstract class KeyPairGeneratorSpi
extends Object

此类为用来生成公钥和私钥的 KeyPairGenerator 类定义了服务提供者接口 (SPI)。

每个希望为特定算法提供密钥对生成器实现的密码服务提供者，都必须实现此类中的所有抽象方法。

每个 provider 都必须提供（并记录）一种默认的初始化，以防客户端没有显式初始化 KeyPairGenerator（通过调用 initialize 方法）。例如，Sun provider 使用 1024 位的默认模大小（密钥大小）。

另请参见：
KeyPairGenerator, AlgorithmParameterSpec

构造方法摘要
KeyPairGeneratorSpi()
方法摘要
abstract KeyPair | generateKeyPair() 生成密钥对。
void | initialize(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集合和用户提供的随机源初始化密钥对生成器。
abstract void | initialize(int keysize, SecureRandom random) 使用默认参数集初始化确定密钥大小的密钥对生成器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyPairGeneratorSpi

public KeyPairGeneratorSpi()
方法详细信息

initialize

public abstract void initialize(int keysize,
                                SecureRandom random)
使用默认参数集初始化确定密钥大小的密钥对生成器。

参数：
keysize - 密钥大小。这是特定于算法的度量（如模长度），以位数的形式指定。
random - 此生成器的随机源。
抛出：
InvalidParameterException - 如果 keysize 不受此 KeyPairGeneratorSpi 对象支持。

initialize

public void initialize(AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
用指定参数集合和用户提供的随机源初始化密钥对生成器。

已将此具体方法添加到以前定义的这个抽象类中。（为了向后兼容性，它不能是抽象的）。provider 可以重写它来初始化密钥对生成器。如果参数不适合此密钥对生成器，这种重写将会抛出 InvalidAlgorithmParameterException。如果不重写此方法，它总是抛出 UnsupportedOperationException。

参数：
params - 用于生成密钥的参数集合。
random - 此生成器的随机源。
抛出：
InvalidAlgorithmParameterException - 如果给定的参数不适合此密钥对生成器。
从以下版本开始：
1.2

generateKeyPair

public abstract KeyPair generateKeyPair()
生成密钥对。如果没有使用 KeyPairGenerator 接口调用初始化方法，则将使用特定于算法的默认值。每次调用此方法都将生成新的密钥对。

返回：
新生成的 KeyPair
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyRep.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.security
枚举 KeyRep.Type

java.lang.Object
    继承者  java.lang.Enum<KeyRep.Type>
        继承者  java.security.KeyRep.Type
所有已实现的接口：
Serializable, Comparable<KeyRep.Type>
正在封闭类：
KeyRep
public static enum KeyRep.Type
extends Enum<KeyRep.Type>

Key 类型。

从以下版本开始：
1.5

枚举常量摘要
PRIVATE
私钥的 Type。
PUBLIC
公钥的 Type。
SECRET
秘密密钥的 Type。
方法摘要
static KeyRep.Type | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static KeyRep.Type[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

SECRET

public static final KeyRep.Type SECRET
秘密密钥的 Type。

PUBLIC

public static final KeyRep.Type PUBLIC
公钥的 Type。

PRIVATE

public static final KeyRep.Type PRIVATE
私钥的 Type。

方法详细信息

values

public static final KeyRep.Type[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(KeyRep.Type c : KeyRep.Type.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static KeyRep.Type valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


KeyStore (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStore

java.lang.Object
    继承者  java.security.KeyStore

public class KeyStore
extends Object

此类表示密钥和证书的存储设施。

KeyStore 管理不同类型的条目。每种类型的条目都实现 KeyStore.Entry 接口。提供了三种基本的 KeyStore.Entry 实现：

  • KeyStore.PrivateKeyEntry

    此类型的条目保存一个加密的 PrivateKey，可以选择用受保护格式存储该私钥，以防止未授权访问。它还随附一个相应公钥的证书链。

    给定条目使用私钥和证书链进行自验证 (self-authentication)。应用此验证的包括软件发布组织，它们将 JAR 文件签名为发布和/或许可软件的一部分。

  • KeyStore.SecretKeyEntry

    此类型的条目保存一个加密的 SecretKey，可以选择用受保护格式存储该密钥，以防止未授权访问。

  • KeyStore.TrustedCertificateEntry

    此类型的条目包含一个属于另一方的单个公钥 Certificate。它被称为可信证书，因为 keystore 的所有者相信证书中的公钥确实属于该证书的 subject（所有者）所标识的身份。

    此类型的条目可用于验证其他方。

KeyStore 中的每一条目都用 “alias” 字符串标识。对于私钥及其关联的证书链，这些字符串用于区分实体验证自身可以采用的不同方式。例如，实体可以使用不同的证书授权或不同的公钥算法来验证自身。

别名是否区分大小写与实现有关。为了避免出现问题，建议不要在 KeyStore 中使用只有大小写区别的别名。

在这里没有指定 keystore 是否是持久性的，也没有指定 keystore 是持久性时所使用的机制。这允许使用各种技术保护敏感的（例如，私有的或秘密的）密钥。一种选择是使用智能卡或其他集成加密引擎 (SafeKeyper)，也可以（以各种格式）使用文件之类更为简单的机制。

请求 KeyStore 对象的典型方式包括使用默认类型和提供一个特定的 keystore 类型。

  • 使用默认类型：
        KeyStore ks = KeyStore.getInstance(KeyStore.getDefaultType());
    系统将返回默认类型的 keystore 实现。

  • 提供特定的 keystore 类型：
          KeyStore ks = KeyStore.getInstance("JKS");
    系统将返回环境中可用的指定 keystore 类型的首选实现。

必须先加载 keystore 才能对其进行访问。

    KeyStore ks = KeyStore.getInstance(KeyStore.getDefaultType());

    // get user password and file input stream
    char[] password = getPassword();

    java.io.FileInputStream fis = null;
    try {
        fis = new java.io.FileInputStream("keyStoreName");
        ks.load(fis, password);
    } finally {
        if (fis != null) {
            fis.close();
        }
    }
要使用上述 load 方法创建一个空 keystore，传递 null 作为 InputStream 的参数。

一旦加载了 keystore，就能够从 keystore 读取现有条目，或向 keystore 写入新条目：

    // get my private key
    KeyStore.PrivateKeyEntry pkEntry = (KeyStore.PrivateKeyEntry)
        ks.getEntry("privateKeyAlias", password);
    PrivateKey myPrivateKey = pkEntry.getPrivateKey();

    // save my secret key
    javax.crypto.SecretKey mySecretKey;
    KeyStore.SecretKeyEntry skEntry =
        new KeyStore.SecretKeyEntry(mySecretKey);
    ks.setEntry("secretKeyAlias", skEntry,
        new KeyStore.PasswordProtection(password));

    // store away the keystore
    java.io.FileOutputStream fos = null;
    try {
        fos = new java.io.FileOutputStream("newKeyStoreName");
        ks.store(fos, password);
    } finally {
        if (fos != null) {
            fos.close();
        }
    }
注意，可以使用相同的密码加载 keystore、保护私钥条目、保护秘密密钥条目以及存储 keystore（如上文示例代码所示），也可以使用不同的密码或其他保护参数。

从以下版本开始：
1.2
另请参见：
PrivateKey, SecretKey, Certificate

嵌套类摘要
static class | KeyStore.Builder 将被实例化的 KeyStore 对象的描述。
static class | KeyStore.CallbackHandlerProtection 封装 CallbackHandler 的 ProtectionParameter。
static interface | KeyStore.Entry 用于 KeyStore 项类型的标记接口。
static interface | KeyStore.LoadStoreParameter 用于 KeyStore load 和 store 参数的标记接口。
static class | KeyStore.PasswordProtection ProtectionParameter 的一个基于密码的实现。
static class | KeyStore.PrivateKeyEntry 保存 PrivateKey 和相应证书链的 KeyStore 项。
static interface | KeyStore.ProtectionParameter 用于 keystore 保护参数的标记接口。
static class | KeyStore.SecretKeyEntry 保存 SecretKey 的 KeyStore 项。
static class | KeyStore.TrustedCertificateEntry 保存可信的 Certificate 的 KeyStore 项。
构造方法摘要
protected KeyStore(KeyStoreSpi keyStoreSpi, Provider provider, String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。
方法摘要
Enumeration<String> | aliases() 列出此 keystore 的所有别名。
boolean | containsAlias(String alias) 检查给定别名是否存在于此 keystore 中。
void | deleteEntry(String alias) 删除此 keystore 中给定别名标识的条目。
boolean | entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
Certificate | getCertificate(String alias) 返回与给定别名关联的证书。
String | getCertificateAlias(Certificate cert) 返回证书与给定证书匹配的第一个 keystore 条目的别名。
Certificate[] | getCertificateChain(String alias) 返回与给定别名关联的证书链。
Date | getCreationDate(String alias) 返回给定别名标识的条目的创建日期。
static String | getDefaultType() 返回 Java 安全属性文件中指定的默认 keystore 类型；如果不存在此类属性，则返回字符串 "jks"（"Java keystore" 的首字母缩写）。
KeyStore.Entry | getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。
static KeyStore | getInstance(String type) 返回指定类型的 keystore 对象。
static KeyStore | getInstance(String type, Provider provider) 返回指定类型的 keystore 对象。
static KeyStore | getInstance(String type, String provider) 返回指定类型的 keystore 对象。
Key | getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。
Provider | getProvider() 返回此 keystore 的提供者。
String | getType() 返回此 keystore 的类型。
boolean | isCertificateEntry(String alias) 如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。
boolean | isKeyEntry(String alias) 如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。
void | load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。
void | load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
void | setCertificateEntry(String alias, Certificate cert) 将给定可信证书分配给给定别名。
void | setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 keystore Entry。
void | setKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
void | setKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，并用给定密码保护它。
int | size() 获取此 keystore 中条目数。
void | store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyStore

protected KeyStore(KeyStoreSpi keyStoreSpi,
                   Provider provider,
                   String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。

参数：
keyStoreSpi - 提供者实现
provider - 提供者
type - keystore 类型。
方法详细信息

getInstance

public static KeyStore getInstance(String type)
                            throws KeyStoreException
返回指定类型的 keystore 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 KeyStoreSpi 实现的新 KeyStore 对象，该实现取自第一个支持指定类型的 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
type - keystore 类型。有关标准 keystore 类型的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
指定类型的 keystore 对象。
抛出：
KeyStoreException - 如果没有 Provider 支持指定类型的 KeyStoreSpi 实现。
另请参见：
Provider

getInstance

public static KeyStore getInstance(String type,
                                   String provider)
                            throws KeyStoreException,
                                   NoSuchProviderException
返回指定类型的 keystore 对象。

返回一个封装 KeyStoreSpi 实现的新 KeyStore 对象，该实现取自指定提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
type - keystore 类型。有关标准 keystore 类型的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者的名称。
返回：
指定类型的 keystore 对象。
抛出：
KeyStoreException - 如果不能从指定提供者获得指定类型的 KeyStoreSpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static KeyStore getInstance(String type,
                                   Provider provider)
                            throws KeyStoreException
返回指定类型的 keystore 对象。

返回一个封装 KeyStoreSpi 实现的新 KeyStore 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

参数：
type - keystore 类型。有关标准 keystore 类型的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者。
返回：
指定类型的 keystore 对象。
抛出：
KeyStoreException - 如果不能从指定 Provider 对象获得指定类型的 KeyStoreSpi 实现。
IllegalArgumentException - 如果指定提供者为 null。
从以下版本开始：
1.4
另请参见：
Provider

getDefaultType

public static final String getDefaultType()
返回 Java 安全属性文件中指定的默认 keystore 类型；如果不存在此类属性，则返回字符串 "jks"（"Java keystore" 的首字母缩写）。Java 安全属性文件位于名为 <JAVA_HOME>/lib/security/java.security 的文件中。<JAVA_HOME> 引用 java.home 系统属性的值，并指定安装 JRE 的目录。

调用某个 getInstance 方法时不希望使用固定编码 (hard coded) keystore 类型的应用程序，以及用户未指定 keystore 类型时希望提供默认 keystore 类型的应用程序可以使用默认的 keystore 类型。

通过将 "keystore.type" 安全属性（在 Java 安全属性文件中）的值设置为所需的 keystore 类型，可以更改默认的 keystore 类型。

返回：
Java 安全属性文件中指定的默认 keystore 类型；如果不存在此类属性，则返回字符串 "jks"。

getProvider

public final Provider getProvider()
返回此 keystore 的提供者。

返回：
此 keystore 的提供者。

getType

public final String getType()
返回此 keystore 的类型。

返回：
此 keystore 的类型。

getKey

public final Key getKey(String alias,
                        char[] password)
                 throws KeyStoreException,
                        NoSuchAlgorithmException,
                        UnrecoverableKeyException
返回与给定别名关联的密钥，并用给定密码来恢复它。必须已经通过调用 setKeyEntry，或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 关联密钥与别名。

参数：
alias - 别名
password - 用于恢复密钥的密码
返回：
请求的密钥；如果给定别名不存在或不标识与密钥相关的条目，则返回 null。
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。
NoSuchAlgorithmException - 如果不能找到恢复密钥的算法
UnrecoverableKeyException - 如果不能恢复密钥（例如，给定密码错误）。

getCertificateChain

public final Certificate[] getCertificateChain(String alias)
                                        throws KeyStoreException
返回与给定别名关联的证书链。必须已经通过调用 setKeyEntry，或者以 PrivateKeyEntry 为参数的 setEntry 关联证书链与别名。

参数：
alias - 别名
返回：
证书链（按用户证书在前，根证书授权在后的顺序）；如果给定别名不存在或不包含证书链，则返回 null
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

getCertificate

public final Certificate getCertificate(String alias)
                                 throws KeyStoreException
返回与给定别名关联的证书。

如果给定的别名标识通过调用 setCertificateEntry 创建的条目，或者通过调用以 TrustedCertificateEntry 为参数的 setEntry 创建的条目，则返回包含在该条目中的可信证书。

如果给定的别名标识通过调用 setKeyEntry 创建的条目，或者通过调用以 PrivateKeyEntry 为参数的 setEntry 创建的条目，则返回该条目中证书链的第一个元素。

参数：
alias - 别名
返回：
证书；如果给定别名不存在或不包含证书，则返回 null。
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

getCreationDate

public final Date getCreationDate(String alias)
                           throws KeyStoreException
返回给定别名标识的条目的创建日期。

参数：
alias - 别名
返回：
此条目的创建日期；如果给定的别名不存在，则返回 null
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

setKeyEntry

public final void setKeyEntry(String alias,
                              Key key,
                              char[] password,
                              Certificate[] chain)
                       throws KeyStoreException
将给定的密钥分配给给定的别名，并用给定密码保护它。

如果给定密钥的类型为 java.security.PrivateKey，则它必须附带证明相应公钥的证书链。

如果给定别名已经存在，则与别名关联的 keystore 信息将被给定密钥（还可能包括证书链）重写。

参数：
alias - 别名
key - 要与别名关联的密钥
password - 保护密钥的密码
chain - 相应公钥的证书链（只在给定密钥的类型为 java.security.PrivateKey 时需要）。
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）、无法保护给定的密钥，或者此操作由于某些其他原因而失败

setKeyEntry

public final void setKeyEntry(String alias,
                              byte[] key,
                              Certificate[] chain)
                       throws KeyStoreException
将给定密钥（已经被保护）分配给给定别名。

如果受保护密钥的类型为 java.security.PrivateKey，则它必须附带证明相应公钥的证书链。如果底层 keystore 实现的类型为 jks，则必须根据 PKCS #8 标准中的定义将 key 编码为 EncryptedPrivateKeyInfo。

如果给定别名已经存在，则与别名关联的 keystore 信息将被给定密钥（还可能包括证书链）重写。

参数：
alias - 别名
key - 要与别名关联的密钥（以受保护格式）
chain - 相应公钥的证书链（只在受保护密钥的类型为 java.security.PrivateKey 时有用）。
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载），或者此操作由于某些其他原因而失败。

setCertificateEntry

public final void setCertificateEntry(String alias,
                                      Certificate cert)
                               throws KeyStoreException
将给定可信证书分配给给定别名。

如果给定别名标识通过调用 setCertificateEntry 创建的现有条目，或者通过调用以 TrustedCertificateEntry 为参数的 setEntry 创建的现有条目，则现有条目中的可信证书将被给定证书重写。

参数：
alias - 别名
cert - 证书
抛出：
KeyStoreException - 如果 keystore 尚未被初始化，或者给定别名已存在但不标识包含可信证书的条目，或者此操作由于其他某些原因失败。

deleteEntry

public final void deleteEntry(String alias)
                       throws KeyStoreException
删除此 keystore 中给定别名标识的条目。

参数：
alias - 别名
抛出：
KeyStoreException - 如果 keystore 尚未被初始化，或者条目不能被移除。

aliases

public final Enumeration<String> aliases()
                                  throws KeyStoreException
列出此 keystore 的所有别名。

返回：
别名的枚举
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

containsAlias

public final boolean containsAlias(String alias)
                            throws KeyStoreException
检查给定别名是否存在于此 keystore 中。

参数：
alias - 别名
返回：
如果别名存在，则返回 true；否则返回 false
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

size

public final int size()
               throws KeyStoreException
获取此 keystore 中条目数。

返回：
此 keystore 中的条目数
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

isKeyEntry

public final boolean isKeyEntry(String alias)
                         throws KeyStoreException
如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。

参数：
alias - 要检查的 keystore 条目的别名
返回：
如果给定别名标识的条目是与密钥相关的条目，则返回 true；否则返回 false。
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

isCertificateEntry

public final boolean isCertificateEntry(String alias)
                                 throws KeyStoreException
如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。

参数：
alias - 要检查的 keystore 条目的别名
返回：
如果给定别名标识的条目包含一个可信证书，则返回 true；否则返回 false。
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

getCertificateAlias

public final String getCertificateAlias(Certificate cert)
                                 throws KeyStoreException
返回证书与给定证书匹配的第一个 keystore 条目的别名。

此方法尝试将给定证书与每一个 keystore 条目匹配。如果认为条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则将给定证书与该条目的证书进行比较。

如果认为条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 为参数的 setEntry 创建的，则将给定证书与该条目证书链的第一个元素进行比较。

参数：
cert - 要匹配的证书
返回：
带有匹配证书的第一个条目的别名；如果此 keystore 中不存在这种条目，则返回 null。
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。

store

public final void store(OutputStream stream,
                        char[] password)
                 throws KeyStoreException,
                        IOException,
                        NoSuchAlgorithmException,
                        CertificateException
将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

参数：
stream - 要写入此 keystore 的输出流。
password - 生成 keystore 完整性检验的密码
抛出：
KeyStoreException - 如果 keystore 尚未被初始化（加载）。
IOException - 如果存在数据 I/O 问题
NoSuchAlgorithmException - 如果不存在恰当的数据完整性算法
CertificateException - 如果 keystore 数据中包含无法存储的证书

store

public final void store(KeyStore.LoadStoreParameter param)
                 throws KeyStoreException,
                        IOException,
                        NoSuchAlgorithmException,
                        CertificateException
使用给定 LoadStoreParameter 存储此 keystore。

参数：
param - 指定如何存储 keystore 的 LoadStoreParameter，该参数可以为 null
抛出：
IllegalArgumentException - 如果无法识别给定的 LoadStoreParameter 输入
KeyStoreException - 如果 keystore 尚未被初始化（加载）
IOException - 如果存在数据 I/O 问题
NoSuchAlgorithmException - 如果不存在恰当的数据完整性算法
CertificateException - 如果 keystore 数据中包含无法存储的证书
从以下版本开始：
1.5

load

public final void load(InputStream stream,
                       char[] password)
                throws IOException,
                       NoSuchAlgorithmException,
                       CertificateException
从给定输入流中加载此 KeyStore。

可以给定一个密码来解锁 keystore（例如，驻留在硬件标记设备上的 keystore）或检验 keystore 数据的完整性。如果没有指定用于完整性检验的密码，则不会执行完整性检验。

如果要创建空 keystore，或者不能从流中初始化 keystore，则传递 null 作为 stream 的参数。

注意，如果此 keystore 已经被加载，那么它将被重新初始化，并再次从给定输入流中加载。

参数：
stream - 从中加载 keystore 的输入流，或者 null
password - 用来检验 keystore 完整性的密码，用来解锁 keystore 的密码，或者 null
抛出：
IOException - 如果存在 keystore 数据 I/O 问题或格式问题，如果需要密码却没有指定，或者指定的密码错误。如果错误是由于密码错误引起的，那么 IOException 的 cause 应该是 UnrecoverableKeyException
NoSuchAlgorithmException - 如果不存在用来检验 keystore 完整性的算法
CertificateException - 如果不能加载 keystore 中的任何证书

load

public final void load(KeyStore.LoadStoreParameter param)
                throws IOException,
                       NoSuchAlgorithmException,
                       CertificateException
使用给定 LoadStoreParameter 加载此 keystore。

注意，如果此 KeyStore 已经被加载，那么它将被重新初始化，并再次从给定参数加载。

参数：
param - 指定如何加载 keystore 的 LoadStoreParameter，可以为 null
抛出：
IllegalArgumentException - 如果无法识别给定 LoadStoreParameter 输入
IOException - 如果存在 keystore 数据 I/O 问题或格式问题。如果错误是由于 ProtectionParameter 不正确（如密码错误）引起的，那么 IOException 的 cause 应该是 UnrecoverableKeyException
NoSuchAlgorithmException - 如果不存在用来检验 keystore 完整性的算法
CertificateException - 如果不能加载 keystore 中的任何证书
从以下版本开始：
1.5

getEntry

public final KeyStore.Entry getEntry(String alias,
                                     KeyStore.ProtectionParameter protParam)
                              throws NoSuchAlgorithmException,
                                     UnrecoverableEntryException,
                                     KeyStoreException
使用指定保护参数获取指定别名的 keystore Entry。

参数：
alias - 获取此别名的 keystore Entry
protParam - 用来保护 Entry 的 ProtectionParameter，可以为 null
返回：
指定别名的 keystore Entry；如果不存在这种条目，则返回 null
抛出：
NullPointerException - 如果 alias 为 null
NoSuchAlgorithmException - 如果不存在用来恢复条目的算法
UnrecoverableEntryException - 如果指定的 protParam 不足或无效
UnrecoverableKeyException - 如果该条目是 PrivateKeyEntry 或 SecretKeyEntry，并且指定的 protParam 不包含恢复密钥所需的信息（如密码错误）
KeyStoreException - 如果 keystore 尚未被初始化（加载）
从以下版本开始：
1.5
另请参见：
setEntry(String, KeyStore.Entry, KeyStore.ProtectionParameter)

setEntry

public final void setEntry(String alias,
                           KeyStore.Entry entry,
                           KeyStore.ProtectionParameter protParam)
                    throws KeyStoreException
用指定别名保存 keystore Entry。保护参数用来保护 Entry。

如果指定别名的条目已经存在，它将被重写。

参数：
alias - 以此别名保存 keystore Entry
entry - 要保存的 Entry
protParam - 用来保护 Entry 的 ProtectionParameter，可以为 null
抛出：
NullPointerException - 如果 alias 或 entry 为 null
KeyStoreException - 如果 keystore 尚未被初始化（加载），或者此操作由于其他原因失败
从以下版本开始：
1.5
另请参见：
getEntry(String, KeyStore.ProtectionParameter)

entryInstanceOf

public final boolean entryInstanceOf(String alias,
                                     Class<? extends KeyStore.Entry> entryClass)
                              throws KeyStoreException
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

参数：
alias - 别名
entryClass - 条目的类
返回：
true 如果指定 alias 的 keystore Entry 是指定 entryClass 的实例或子类，则返回 true；否则返回 false。
抛出：
NullPointerException - 如果 alias 或 entryClass 为 null
KeyStoreException - 如果 keystore 尚未被初始化（加载）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.Builder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStore.Builder

java.lang.Object
    继承者  java.security.KeyStore.Builder
正在封闭类：
KeyStore
public abstract static class KeyStore.Builder
extends Object

将被实例化的 KeyStore 对象的描述。

此类的实例封装了初始化和实例化 KeyStore 对象所需的信息。当调用 getKeyStore() 方法时触发该过程。

这使将配置从 KeyStore 对象的创建中分离出来和（例如）在需要前一直延迟密码提示成为可能。

从以下版本开始：
1.5
另请参见：
KeyStore, KeyStoreBuilderParameters

构造方法摘要
protected KeyStore.Builder()
构造新的 Builder。
方法摘要
abstract KeyStore | getKeyStore() 返回此对象描述的 KeyStore。
abstract KeyStore.ProtectionParameter | getProtectionParameter(String alias) 返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。
static KeyStore.Builder | newInstance(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter) 返回封装给定 KeyStore 的新 Builder。
static KeyStore.Builder | newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
static KeyStore.Builder | newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyStore.Builder

protected KeyStore.Builder()
构造新的 Builder。

方法详细信息

getKeyStore

public abstract KeyStore getKeyStore()
                              throws KeyStoreException
返回此对象描述的 KeyStore。

抛出：
KeyStoreException - 如果操作期间出现错误，例如，如果 KeyStore 不能被实例化或加载。

getProtectionParameter

public abstract KeyStore.ProtectionParameter getProtectionParameter(String alias)
                                                             throws KeyStoreException
返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。在调用此方法前必须调用 getKeyStore 方法。

参数：
alias - KeyStore 项的别名
返回：
应该用来获取具有给定别名的 Entry 的 ProtectionParameters。
抛出：
NullPointerException - 如果 alias 为 null
KeyStoreException - 如果操作期间发生错误
IllegalStateException - 如果调用此方法前没有调用 getKeyStore 方法

newInstance

public static KeyStore.Builder newInstance(KeyStore keyStore,
                                           KeyStore.ProtectionParameter protectionParameter)
返回封装给定 KeyStore 的新 Builder。所返回对象的 getKeyStore() 方法将返回 keyStore，getProtectionParameter() 方法将返回 protectionParameters。

如果一个现有的 KeyStore 对象需要和基于 Builder 的 APIs 一起使用，则此方法很有用。

参数：
keyStore - 将被封装的 KeyStore
protectionParameter - 用来保护 KeyStore 项的 ProtectionParameter
返回：
新的 Builder 对象
抛出：
NullPointerException - 如果 keyStore 或 protectionParameters 为 null
IllegalArgumentException - 如果 keyStore 没有被初始化

newInstance

public static KeyStore.Builder newInstance(String type,
                                           Provider provider,
                                           File file,
                                           KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

第一次对返回的 builder 调用 getKeyStore() 方法将创建 type 类型的 KeyStore，并将调用其 load() 方法。inputStream 参数是根据 file 构建的。如果 protection 是 PasswordProtection，则通过调用 getPassword 方法获取密码。而如果 protection 是 CallbackHandlerProtection，则通过调用 CallbackHandler 获取密码。

对 getKeyStore() 的后续调用和初始调用返回相同的对象。如果初始调用失败且抛出 KeyStoreException，则后续的调用也抛出 KeyStoreException。

根据 provider（如果非 null）初始化 KeyStore。否则，将搜索所有安装的提供者。

调用 getProtectionParameter() 将返回 PasswordProtection 对象，该对象封装用来调用 load 方法的密码。

注意，getKeyStore() 方法在调用此方法的代码的 AccessControlContext 中执行。

参数：
type - 将构造的 KeyStore 类型
provider - 根据其实例化 KeyStore 提供者（或 null）
file - 包含 KeyStore 数据的 File
protection - 保护 KeyStore 数据的 ProtectionParameter
返回：
新的 Builder 对象
抛出：
NullPointerException - 如果 type、file 或 protection 为 null
IllegalArgumentException - 如果 protection 既不是 PasswordProtection 也不是 CallbackHandlerProtection 的实例；如果 file 不存在或其不表示一个标准文件

newInstance

public static KeyStore.Builder newInstance(String type,
                                           Provider provider,
                                           KeyStore.ProtectionParameter protection)
返回新的 Builder 对象。

每次对返回的 builder 调用 getKeyStore() 方法将返回新的 type 类型的 KeyStore 对象。使用封装 protection 的 LoadStoreParameter 调用其 load() 方法。

根据 provider（如果非 null）初始化 KeyStore。否则，将搜索所有安装的提供者。

调用 getProtectionParameter() 将返回 protection。

注意，getKeyStore() 方法在调用此方法的代码的 AccessControlContext 中执行。

参数：
type - 将构造的 KeyStore 类型
provider - 根据其实例化 KeyStore 的提供者（或 null）
protection - 保护 Keystore 的 ProtectionParameter
返回：
新的 Builder 对象
抛出：
NullPointerException - 如果 type 或 protection 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.CallbackHandlerProtection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStore.CallbackHandlerProtection

java.lang.Object
    继承者  java.security.KeyStore.CallbackHandlerProtection
所有已实现的接口：
KeyStore.ProtectionParameter
正在封闭类：
KeyStore
public static class KeyStore.CallbackHandlerProtection
extends Object
implements KeyStore.ProtectionParameter

封装 CallbackHandler 的 ProtectionParameter。

从以下版本开始：
1.5

构造方法摘要
KeyStore.CallbackHandlerProtection(CallbackHandler handler)
根据 CallbackHandler 构造新的 CallbackHandlerProtection。
方法摘要
 CallbackHandler getCallbackHandler()
返回 CallbackHandler。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyStore.CallbackHandlerProtection

public KeyStore.CallbackHandlerProtection(CallbackHandler handler)
根据 CallbackHandler 构造新的 CallbackHandlerProtection。

参数：
handler - CallbackHandler
抛出：
NullPointerException - 如果 handler 为 null
方法详细信息

getCallbackHandler

public CallbackHandler getCallbackHandler()
返回 CallbackHandler。

返回：
CallbackHandler。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.Entry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 KeyStore.Entry

所有已知实现类：
KeyStore.PrivateKeyEntry, KeyStore.SecretKeyEntry, KeyStore.TrustedCertificateEntry
正在封闭类：
KeyStore
public static interface KeyStore.Entry

用于 KeyStore 项类型的标记接口。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.LoadStoreParameter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 KeyStore.LoadStoreParameter

正在封闭类：
KeyStore
public static interface KeyStore.LoadStoreParameter

用于 KeyStore load 和 store 参数的标记接口。

从以下版本开始：
1.5

方法摘要
 KeyStore.ProtectionParameter getProtectionParameter()
获取用于保护 keystore 数据的参数。

方法详细信息

getProtectionParameter

KeyStore.ProtectionParameter getProtectionParameter()
获取用于保护 keystore 数据的参数。

返回：
用于保护 keystore 数据的参数，或 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.PasswordProtection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStore.PasswordProtection

java.lang.Object
    继承者  java.security.KeyStore.PasswordProtection
所有已实现的接口：
KeyStore.ProtectionParameter, Destroyable
正在封闭类：
KeyStore
public static class KeyStore.PasswordProtection
extends Object
implements KeyStore.ProtectionParameter, Destroyable

ProtectionParameter 的一个基于密码的实现。

从以下版本开始：
1.5

构造方法摘要
KeyStore.PasswordProtection(char[] password)
创建一个 password 参数。
方法摘要
void | destroy() 清除密码。
char[] | getPassword() 获取密码。
boolean | isDestroyed() 确定密码是否已被清除。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyStore.PasswordProtection

public KeyStore.PasswordProtection(char[] password)
创建一个 password 参数。

在将指定的 password 存储进新的 PasswordProtection 对象前将其复制。

方法详细信息

getPassword

public char[] getPassword()
获取密码。

注意，此方法返回一个对密码的引用。如果创建了数组的一个副本，调用方负责在不再需要密码后清空密码信息。

返回：
密码，它可以为 null
抛出：
IllegalStateException - 如果密码已经被清除（销毁）
另请参见：
destroy()

destroy

public void destroy()
             throws DestroyFailedException
清除密码。

指定者：
接口 Destroyable 中的 destroy
抛出：
DestroyFailedException - 如果此方法不能清除密码。

isDestroyed

public boolean isDestroyed()
确定密码是否已被清除。

指定者：
接口 Destroyable 中的 isDestroyed
返回：
如果密码已经被清除，则返回 true；否则，返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.PrivateKeyEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStore.PrivateKeyEntry

java.lang.Object
    继承者  java.security.KeyStore.PrivateKeyEntry
所有已实现的接口：
KeyStore.Entry
正在封闭类：
KeyStore
public static final class KeyStore.PrivateKeyEntry
extends Object
implements KeyStore.Entry

保存 PrivateKey 和相应证书链的 KeyStore 项。

从以下版本开始：
1.5

构造方法摘要
KeyStore.PrivateKeyEntry(PrivateKey privateKey, Certificate[] chain)
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。
方法摘要
Certificate | getCertificate() 从此项中的证书链获取终端实体 Certificate。
Certificate[] | getCertificateChain() 从此项获取 Certificate 链。
PrivateKey | getPrivateKey() 从此项获取 PrivateKey。
String | toString() 返回此 PrivateKeyEntry 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeyStore.PrivateKeyEntry

public KeyStore.PrivateKeyEntry(PrivateKey privateKey,
                                Certificate[] chain)
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。

在将指定的 chain 存储进新的 PrivateKeyEntry 对象前将其复制。

参数：
privateKey - PrivateKey
chain - 表示证书链的 Certificate 数组。证书链必须是有序的并且在索引 0 处包含与私钥相对应的 Certificate。
抛出：
NullPointerException - 如果 privateKey 或 chain 为 null
IllegalArgumentException - 如果指定的证书链长度为 0、指定的证书链不包含相同类型的 Certificate、或者 PrivateKey 算法与在终端实体 Certificate（索引 0 处）中 PublicKey 的算法不匹配
方法详细信息

getPrivateKey

public PrivateKey getPrivateKey()
从此项获取 PrivateKey。

返回：
此项中的 PrivateKey

getCertificateChain

public Certificate[] getCertificateChain()
从此项获取 Certificate 链。

存储的链在返回前被复制。

返回：
与公钥的证书链相对应的 Certificate 数组。如果证书的类型是 X.509，返回数组的运行时类型是 X509Certificate[]。

getCertificate

public Certificate getCertificate()
从此项中的证书链获取终端实体 Certificate。

返回：
此项中证书链的终端实体 Certificate（索引 0 处）。如果证书的类型是 X.509，返回证书的运行时类型是 X509Certificate。

toString

public String toString()
返回此 PrivateKeyEntry 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 PrivateKeyEntry 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.ProtectionParameter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 KeyStore.ProtectionParameter

所有已知实现类：
KeyStore.CallbackHandlerProtection, KeyStore.PasswordProtection
正在封闭类：
KeyStore
public static interface KeyStore.ProtectionParameter

用于 keystore 保护参数的标记接口。

存储在 ProtectionParameter 对象中的信息保护 keystore 的内容。例如，保护参数可以用于检查 keystore 数据的完整性，或用于保护敏感的 keystore 数据（例如，PrivateKey）的机密性。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.SecretKeyEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStore.SecretKeyEntry

java.lang.Object
    继承者  java.security.KeyStore.SecretKeyEntry
所有已实现的接口：
KeyStore.Entry
正在封闭类：
KeyStore
public static final class KeyStore.SecretKeyEntry
extends Object
implements KeyStore.Entry

保存 SecretKey 的 KeyStore 项。

从以下版本开始：
1.5

构造方法摘要
KeyStore.SecretKeyEntry(SecretKey secretKey)
用 SecretKey 构造 SecretKeyEntry。
方法摘要
SecretKey | getSecretKey() 从此项中获取 SecretKey。
String | toString() 返回此 SecretKeyEntry 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeyStore.SecretKeyEntry

public KeyStore.SecretKeyEntry(SecretKey secretKey)
用 SecretKey 构造 SecretKeyEntry。

参数：
secretKey - SecretKey
抛出：
NullPointerException - 如果 secretKey 为 null。
方法详细信息

getSecretKey

public SecretKey getSecretKey()
从此项中获取 SecretKey。

返回：
此项中的 SecretKey。

toString

public String toString()
返回此 SecretKeyEntry 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 SecretKeyEntry 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStore.TrustedCertificateEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStore.TrustedCertificateEntry

java.lang.Object
    继承者  java.security.KeyStore.TrustedCertificateEntry
所有已实现的接口：
KeyStore.Entry
正在封闭类：
KeyStore
public static final class KeyStore.TrustedCertificateEntry
extends Object
implements KeyStore.Entry

保存可信的 Certificate 的 KeyStore 项。

从以下版本开始：
1.5

构造方法摘要
KeyStore.TrustedCertificateEntry(Certificate trustedCert)
用可信 Certificate 构造 TrustedCertificateEntry。
方法摘要
Certificate | getTrustedCertificate() 从此项获取可信 Certficate。
String | toString() 返回此 TrustedCertificateEntry 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeyStore.TrustedCertificateEntry

public KeyStore.TrustedCertificateEntry(Certificate trustedCert)
用可信 Certificate 构造 TrustedCertificateEntry。

参数：
trustedCert - 可信 Certificate
抛出：
NullPointerException - 如果 trustedCert 为 null。
方法详细信息

getTrustedCertificate

public Certificate getTrustedCertificate()
从此项获取可信 Certficate。

返回：
此项中的可信 Certificate。

toString

public String toString()
返回此 TrustedCertificateEntry 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 TrustedCertificateEntry 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Permission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Permission

java.lang.Object
    继承者  java.security.Permission
所有已实现的接口：
Serializable, Guard
直接已知子类：
AllPermission, BasicPermission, FilePermission, MBeanPermission, PrivateCredentialPermission, ServicePermission, SocketPermission, UnresolvedPermission
public abstract class Permission
extends Object
implements Guard, Serializable

表示访问系统资源的抽象类。所有权限都有一个名称（对它们的解释依赖于子类），以及用来定义特定 Permission 子类的语义的抽象方法。

大多数 Permission 对象也包含一个 "actions" 列表，它告知此对象上允许的操作。例如，对于 java.io.FilePermission 对象，权限名称是文件（或目录）的路径名，操作列表（如 "read, write"）指定授予指定文件（或指定目录下的文件）的操作。对于不需要此类列表 Permission 对象（如 java.lang.RuntimePermission），操作列表是可选的；可以有命名的权限（如 "system.exit"），也可以没有。

每个子类都必须实现的重要方法是 implies 方法，此方法用来比较 Permission。基本上，“权限 p1”暗含“权限 p2”意味着如果授予权限 p1，则自然授予权限 p2。因此，这不是相等性测试，而是子集测试。

Permission 对象和 String 对象的相似之处在于它们一经创建便不可改变。一旦创建了权限，子类不应该提供能够更改该权限状态的方法。

另请参见：
Permissions, PermissionCollection, 序列化表格

构造方法摘要
Permission(String name)
构造具有指定名称的权限。
方法摘要
void | checkGuard(Object object) 为某权限实现 guard 接口。
abstract boolean | equals(Object obj) 检查两个 Permission 对象是否相等。
abstract String | getActions() 以 String 的形式返回操作。
String | getName() 返回此 Permission 的名称。
abstract int | hashCode() 返回此 Permission 对象的哈希码值。
abstract boolean | implies(Permission permission) 检查此对象的操作是否“暗含”指定权限的操作。
PermissionCollection | newPermissionCollection() 对给定 Permission 对象返回空 PermissionCollection，如果没有定义则返回 null。
String | toString() 返回描述此 Permission 的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Permission

public Permission(String name)
构造具有指定名称的权限。

参数：
name - 将创建的 Permission 对象的名称。
方法详细信息

checkGuard

public void checkGuard(Object object)
                throws SecurityException
为某权限实现 guard 接口。调用 SecurityManager.checkPermission 方法，将此权限对象作为要检查的权限传递。如果准许访问，则正常返回。否则，抛出 SecurityException。

指定者：
接口 Guard 中的 checkGuard
参数：
object - 将被保护的对象（当前忽略）。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许访问。
另请参见：
Guard, GuardedObject, SecurityManager.checkPermission(java.security.Permission)

implies

public abstract boolean implies(Permission permission)
检查此对象的操作是否“暗含”指定权限的操作。

Permission 子类必须实现此方法，因为它们是惟一能在 Permission 对象上施加语义的类。

AccessController 使用 implies 方法来确定某个所请求的权限是否暗含于另一个在当前执行上下文中已知为有效的权限中。

参数：
permission - 要依据其来检查的权限。
返回：
如果对象暗含指定的权限，则返回 true；否则返回 false。

equals

public abstract boolean equals(Object obj)
检查两个 Permission 对象是否相等。

不要使用 equals 方法做访问控制的决定；使用 implies 方法。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果两个 Permission 对象等价，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public abstract int hashCode()
返回此 Permission 对象的哈希码值。

Permission 对象所需的 hashCode 行为如下：

  • 在 Java 应用程序执行期间，无论何时在同一个 Permission 对象上调用 hashCode 方法超过一次，它都必须始终返回相同的整数。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。

  • 如果根据 equals 方法，两个 Permission 对象是相等的，那么在两个 Permission 对象中的每个对象上调用 hashCode 方法必须生成相同的整数结果。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getName

public final String getName()
返回此 Permission 的名称。例如，就 java.io.FilePermission 来说，名称将是路径名。

返回：
此 Permission 的名称。

getActions

public abstract String getActions()
以 String 的形式返回操作。由于此方法是抽象的，所以子类可以推迟到需要的时候才创建一个 String 的表示形式。子类应该始终以操作所认为的规范形式返回这些操作。例如，通过以下方式创建两个 FilePermission 对象：
   perm1 = new FilePermission(p1,"read,write");
   perm2 = new FilePermission(p2,"write,read");
当调用 getActions 方法时，两者都返回 "read,write"。

返回：
此 Permission 的操作。

newPermissionCollection

public PermissionCollection newPermissionCollection()
对给定 Permission 对象返回空 PermissionCollection，如果没有定义则返回 null。如果 Permission 类的子类需要在一个特定的 PermissionCollection 对象中存储其权限，以便调用 PermissionCollection.implies 方法时能提供正确的语义，则它们应该重写此方法。如果返回 null，那么此方法的调用方可以在任何它们选择的 PermissionCollection（使用 Hashtable 的，使用 Vector 的，等等)中随意存储此类型的权限。

返回：
此 Permission 类型的 PermissionCollection 对象，如果都没有定义则返回 null。

toString

public String toString()
返回描述此 Permission 的字符串。约定是指定类名称、权限名称和以下格式的操作：'("ClassName" "name" "actions")'。

覆盖：
类 Object 中的 toString
返回：
关于此 Permission 的信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStoreException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStoreException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.KeyStoreException
所有已实现的接口：
Serializable
public class KeyStoreException
extends GeneralSecurityException

这是一般的 KeyStore 异常。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
KeyStoreException()
构造不带详细消息的 KeyStoreException。
KeyStoreException(String msg)
构造带指定详细消息的 KeyStoreException。
KeyStoreException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 KeyStoreException。
KeyStoreException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeyStoreException

public KeyStoreException()
构造不带详细消息的 KeyStoreException。（详细消息是描述此特定异常的 String）。

KeyStoreException

public KeyStoreException(String msg)
构造带指定详细消息的 KeyStoreException。（详细消息是描述此特定异常的 String）。

参数：
msg - 详细消息。

KeyStoreException

public KeyStoreException(String message,
                         Throwable cause)
创建带指定的详细消息和 cause 的 KeyStoreException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

KeyStoreException

public KeyStoreException(Throwable cause)
创建带指定 cause 和详细消息的 KeyException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStoreSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 KeyStoreSpi

java.lang.Object
    继承者  java.security.KeyStoreSpi

public abstract class KeyStoreSpi
extends Object

此类为 KeyStore 类定义服务提供者接口 (SPI)。希望提供特定 keystore 类型的 keystore 实现的每个加密服务提供者必须实现此类中所有的抽象方法。

从以下版本开始：
1.2
另请参见：
KeyStore

构造方法摘要
KeyStoreSpi()
方法摘要
abstract Enumeration<String> | engineAliases() 列出此 keystore 的所有别名。
abstract boolean | engineContainsAlias(String alias) 检查给定别名是否存在于此 keystore 中。
abstract void | engineDeleteEntry(String alias) 删除由此 keystore 中给定的别名标识的项。
boolean | engineEntryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
abstract Certificate | engineGetCertificate(String alias) 返回与给定别名关联的证书。
abstract String | engineGetCertificateAlias(Certificate cert) 返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。
abstract Certificate[] | engineGetCertificateChain(String alias) 返回与给定别名关联的证书链。
abstract Date | engineGetCreationDate(String alias) 返回该别名标识的项的创建日期。
KeyStore.Entry | engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
abstract Key | engineGetKey(String alias, char[] password) 返回与给定别名关联的密钥，使用给定密码恢复它。
abstract boolean | engineIsCertificateEntry(String alias) 如果给定别名标识的项是通过调用 setCertificateEntry 或者调用使用 TrustedCertificateEntry 作为参数的 setEntry 来创建的，则返回 true。
abstract boolean | engineIsKeyEntry(String alias) 如果给定别名标识的项是通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 或 SecretKeyEntry 作为参数的 setEntry 创建的，则返回 true。
abstract void | engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
abstract void | engineSetCertificateEntry(String alias, Certificate cert) 将给定证书分配给给定别名。
void | engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 KeyStore.Entry。
abstract void | engineSetKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
abstract void | engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，用给定的密码保护它。
abstract int | engineSize() 获取此 keystore 中项的数目。
void | engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
abstract void | engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyStoreSpi

public KeyStoreSpi()
方法详细信息

engineGetKey

public abstract Key engineGetKey(String alias,
                                 char[] password)
                          throws NoSuchAlgorithmException,
                                 UnrecoverableKeyException
返回与给定别名关联的密钥，使用给定密码恢复它。必须通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 或 SecretKeyEntry 作为参数的 setEntry 将密钥与别名关联。

参数：
alias - 别名
password - 恢复密钥所用的密码
返回：
请求的密钥，如果给定别名不存在或不标识与密钥相关的项，则返回 null。
抛出：
NoSuchAlgorithmException - 如果不能找到恢复密钥的算法
UnrecoverableKeyException - 如果不能恢复密钥（例如,给定的密码错误）。

engineGetCertificateChain

public abstract Certificate[] engineGetCertificateChain(String alias)
返回与给定别名关联的证书链。必须通过调用 setKeyEntry，或者调用使用 PrivateKeyEntry 做参数的 setEntry 将密钥与别名关联。

参数：
alias - 别名
返回：
证书链（按用户证书在前根证书授权中心在后的顺序），如果给定别名不存在或不包含证书链，则返回 null

engineGetCertificate

public abstract Certificate engineGetCertificate(String alias)
返回与给定别名关联的证书。

如果给定的别名标识通过调用 setCertificateEntry 创建的项，或标识通过调用使用 TrustedCertificateEntry 参数的 setEntry 创建的项，那么返回包含在该项中的可信证书。

如果给定的别名标识通过调用 setKeyEntry 创建的项，或标识通过调用使用 PrivateKeyEntry 作为参数的 setEntry 创建的项，那么返回该项中证书链（如果存在证书链）的第一个元素。

参数：
alias - 别名
返回：
证书，如果给定别名不存在或不包含证书，则返回 null。

engineGetCreationDate

public abstract Date engineGetCreationDate(String alias)
返回该别名标识的项的创建日期。

参数：
alias - 别名
返回：
此项的创建日期，如果给定的别名不存在，则返回 null

engineSetKeyEntry

public abstract void engineSetKeyEntry(String alias,
                                       Key key,
                                       char[] password,
                                       Certificate[] chain)
                                throws KeyStoreException
将给定的密钥分配给给定的别名，用给定的密码保护它。

如果给定密钥的类型为 java.security.PrivateKey 类型，则它必须附带证明相应公钥的证书链。

如果给定的别名已经存在，则与别名关联的 keystore 信息被给定的密钥（可能和证书链）重写。

参数：
alias - 别名
key - 要与别名关联的密钥
password - 保护密钥的密码
chain - 相应公钥的证书链（只在给定密钥的类型为 java.security.PrivateKey 时需要）。
抛出：
KeyStoreException - 如果不能保护给定密钥，或此操作由于某些其他原因而失败

engineSetKeyEntry

public abstract void engineSetKeyEntry(String alias,
                                       byte[] key,
                                       Certificate[] chain)
                                throws KeyStoreException
将给定密钥（已经被保护）分配给给定别名。

如果被保护密钥的类型为 java.security.PrivateKey，则它必须附带证明相应公钥的证书链。

如果给定的别名已经存在，则与别名关联的 keystore 信息被给定的密钥（可能和证书链）重写。

参数：
alias - 别名
key - 要与别名关联的密钥（以受保护格式）
chain - 相应公钥的证书链（只在受保护密钥的类型为 java.security.PrivateKey 时有用）。
抛出：
KeyStoreException - 如果此操作失败。

engineSetCertificateEntry

public abstract void engineSetCertificateEntry(String alias,
                                               Certificate cert)
                                        throws KeyStoreException
将给定证书分配给给定别名。

如果给定的别名标识通过调用 setCertificateEntry 创建的现有项，或者标识通过调用使用 TrustedCertificateEntry 作为参数的 setEntry 创建的现有项，那么现有项中的可信证书被给定证书重写。

参数：
alias - 别名
cert - 证书
抛出：
KeyStoreException - 如果给定别名已存在且不标识一个包含可信任证书的项，或此操作由于其他某些原因而失败。

engineDeleteEntry

public abstract void engineDeleteEntry(String alias)
                                throws KeyStoreException
删除由此 keystore 中给定的别名标识的项。

参数：
alias - 别名
抛出：
KeyStoreException - 如果该项不能被移除

engineAliases

public abstract Enumeration<String> engineAliases()
列出此 keystore 的所有别名。

返回：
别名的枚举

engineContainsAlias

public abstract boolean engineContainsAlias(String alias)
检查给定别名是否存在于此 keystore 中。

参数：
alias - 别名
返回：
如果别名存在，则返回 true；否则，返回 false

engineSize

public abstract int engineSize()
获取此 keystore 中项的数目。

返回：
此 keystore 中的项的数目

engineIsKeyEntry

public abstract boolean engineIsKeyEntry(String alias)
如果给定别名标识的项是通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 或 SecretKeyEntry 作为参数的 setEntry 创建的，则返回 true。

参数：
alias - 要检查的 keystore 项的别名
返回：
如果给定别名标识的项与密钥相关，则返回 true；否则返回 false。

engineIsCertificateEntry

public abstract boolean engineIsCertificateEntry(String alias)
如果给定别名标识的项是通过调用 setCertificateEntry 或者调用使用 TrustedCertificateEntry 作为参数的 setEntry 来创建的，则返回 true。

参数：
alias - 要检查的 keystore 项的别名
返回：
如果给定别名标识的项包含一个可信证书，则返回 true；否则，返回 false。

engineGetCertificateAlias

public abstract String engineGetCertificateAlias(Certificate cert)
返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。

此方法试图将给定证书与每一个 keystore 项相匹配。如果将被考虑的项是通过调用 setCertificateEntry 或者调用使用 TrustedCertificateEntry 作为参数的 setEntry 创建的，则将给定证书与该项的证书进行比较。

如果将被考虑的项是通过调用 setKeyEntry 或者调用使用 PrivateKeyEntry 作为参数的 setEntry 创建的，则将给定证书与该项证书链的第一个元素进行比较。

参数：
cert - 要匹配的证书
返回：
带有匹配证书的第一个项的别名；如果在此 keystore 中没有此类项存在，则返回 null。

engineStore

public abstract void engineStore(OutputStream stream,
                                 char[] password)
                          throws IOException,
                                 NoSuchAlgorithmException,
                                 CertificateException
将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。

参数：
stream - 要写入此 keystore 的输出流。
password - 生成 keystore 完整性检验的密码
抛出：
IOException - 如果存在数据的 I/O 问题
NoSuchAlgorithmException - 如果不能找到恰当的数据完整性算法
CertificateException - 如果包含在 keystore 数据中的任何证书不能被存储

engineStore

public void engineStore(KeyStore.LoadStoreParameter param)
                 throws IOException,
                        NoSuchAlgorithmException,
                        CertificateException
使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。

参数：
param - 指出存储 keystore 的方式的 KeyStore.LoadStoreParmeter，可以为 null
抛出：
IllegalArgumentException - 如果给定的 KeyStore.LoadStoreParmeter 输入无法识别
IOException - 如果存在数据 I/O 问题
NoSuchAlgorithmException - 如果不能找到恰当的数据完整性算法
CertificateException - 如果 keystore 数据中的任何证书不能被存储
从以下版本开始：
1.5

engineLoad

public abstract void engineLoad(InputStream stream,
                                char[] password)
                         throws IOException,
                                NoSuchAlgorithmException,
                                CertificateException
从给定的输入流中加载此 KeyStore。

可能给出密码来解锁 keystore（例如驻留在硬件标记设备上的 keystore）或检验 keystore 数据的完整性。如果没有给出用于完整性检验的密码，那么就不会执行完整性检验。

参数：
stream - 从其加载 keystore 的输入流，或 null
password - 用来检验 keystore 完整性的密码，用来解锁 keystore 的密码，或 null
抛出：
IOException - 如果存在 keystore 数据的 I/O 或格式问题，如果需要密码却没有给出，或者给出的密码错误。如果错误是由于密码错误，则 IOException 的 cause 应该是一个 UnrecoverableKeyException
NoSuchAlgorithmException - 如果不能找到用来检验 keystore 完整性的算法
CertificateException - 如果不能加载 keystore 中的任何证书

engineLoad

public void engineLoad(KeyStore.LoadStoreParameter param)
                throws IOException,
                       NoSuchAlgorithmException,
                       CertificateException
使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。

注意，如果此 KeyStore 已经被加载，则它将再次从给定参数中被初始化和加载。

参数：
param - 指出加载 keystore 的方式的 KeyStore.LoadStoreParameter，可以为 null
抛出：
IllegalArgumentException - 如果给定的 KeyStore.LoadStoreParameter 输入无法识别
IOException - 如果存在 keystore 数据的 I/O 或格式问题。如果错误是由于 ProtectionParameter 不正确（如密码错误），则 IOException 的 cause 应该是一个 UnrecoverableKeyException
NoSuchAlgorithmException - 如果不能找到用来检验 keystore 完整性的算法
CertificateException - 如果不能加载 keystore 中的任何证书
从以下版本开始：
1.5

engineGetEntry

public KeyStore.Entry engineGetEntry(String alias,
                                     KeyStore.ProtectionParameter protParam)
                              throws KeyStoreException,
                                     NoSuchAlgorithmException,
                                     UnrecoverableEntryException
使用指定保护参数获取指定别名的 KeyStore.Entry。

参数：
alias - 获取此别名的 KeyStore.Entry
protParam - 用来保护 Entry 的 ProtectionParameter，可以为 null
返回：
指定别名的 KeyStore.Entry；如果不存在这样的项，则返回 null
抛出：
KeyStoreException - 如果操作失败
NoSuchAlgorithmException - 如果不能找到恢复项的算法
UnrecoverableEntryException - 如果指定的 protParam 不足或无效
UnrecoverableKeyException - 如果该项是 PrivateKeyEntry 或 SecretKeyEntry 并且指定的 protParam 不包含恢复密钥所需的信息（如密码错误）
从以下版本开始：
1.5

engineSetEntry

public void engineSetEntry(String alias,
                           KeyStore.Entry entry,
                           KeyStore.ProtectionParameter protParam)
                    throws KeyStoreException
用指定别名保存 KeyStore.Entry。指定的保护参数用来保护 Entry。

如果指定别名的项已经存在，它将被重写。

参数：
alias - 以此别名保存 KeyStore.Entry
entry - 要保存的 Entry
protParam - 用来保护 Entry 的 ProtectionParameter，可以为 null
抛出：
KeyStoreException - 如果此操作失败
从以下版本开始：
1.5

engineEntryInstanceOf

public boolean engineEntryInstanceOf(String alias,
                                     Class<? extends KeyStore.Entry> entryClass)
确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

参数：
alias - 别名
entryClass - 项的类
返回：
如果指定 alias 的 keystore Entry 是指定 entryClass 的实例或子类，则返回 true；否则返回 false。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageDigest (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 MessageDigest

java.lang.Object
    继承者  java.security.MessageDigestSpi
        继承者  java.security.MessageDigest

public abstract class MessageDigest
extends MessageDigestSpi

此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。信息摘要是安全的单向哈希函数，它接收任意大小的数据，并输出固定长度的哈希值。

MessageDigest 对象开始被初始化。该对象通过使用 update 方法处理数据。任何时候都可以调用 reset 方法重置摘要。一旦所有需要更新的数据都已经被更新了，应该调用 digest 方法之一完成哈希计算。

对于给定数量的更新数据，digest 方法只能被调用一次。在调用 digest 之后，MessageDigest 对象被重新设置成其初始状态。

该实现可随意选择是否实现 Cloneable 接口。客户端应用程可以通过尝试复制和捕获 CloneNotSupportedException 来测试可复制性：

 MessageDigest md = MessageDigest.getInstance("SHA");

 try {
     md.update(toChapter1);
     MessageDigest tc1 = md.clone();
     byte[] toChapter1Digest = tc1.digest();
     md.update(toChapter2);
     ...etc.
 } catch (CloneNotSupportedException cnse) {
     throw new DigestException("couldn't make digest of partial content");
 }

注意，如果给定的实现是不可复制的，而事先已经知道摘要的数目，则仍然能够通过实例化几个实例计算中间摘要。

注意，由于历史原因，此类是抽象类，是从 MessageDigestSpi 扩展的。应用程序开发人员只需注意在此 MessageDigest 类中定义的方法；超类中的所有方法是供希望提供自己的信息摘要算法实现的加密服务提供者使用的。

另请参见：
DigestInputStream, DigestOutputStream

构造方法摘要
protected MessageDigest(String algorithm)
创建具有指定算法名称的信息摘要。
方法摘要
Object | clone() 如果实现是可复制的，则返回一个副本。
byte[] | digest() 通过执行诸如填充之类的最终操作完成哈希计算。
byte[] | digest(byte[] input) 使用指定的 byte 数组对摘要进行最后更新，然后完成摘要计算。
int | digest(byte[] buf, int offset, int len) 通过执行诸如填充之类的最终操作完成哈希计算。
String | getAlgorithm() 返回标识算法的独立于实现细节的字符串。
int | getDigestLength() 返回以字节为单位的摘要长度，如果提供者不支持此操作并且实现是不可复制的，则返回 0。
static MessageDigest | getInstance(String algorithm) 返回实现指定摘要算法的 MessageDigest 对象。
static MessageDigest | getInstance(String algorithm, Provider provider) 返回实现指定摘要算法的 MessageDigest 对象。
static MessageDigest | getInstance(String algorithm, String provider) 返回实现指定摘要算法的 MessageDigest 对象。
Provider | getProvider() 返回此信息摘要对象的提供者。
static boolean | isEqual(byte[] digesta, byte[] digestb) 比较两个摘要的相等性。
void | reset() 重置摘要以供再次使用。
String | toString() 返回此信息摘要对象的字符串表示形式。
void | update(byte input) 使用指定的字节更新摘要。
void | update(byte[] input) 使用指定的 byte 数组更新摘要。
void | update(byte[] input, int offset, int len) 使用指定的 byte 数组，从指定的偏移量开始更新摘要。
void | update(ByteBuffer input) 使用指定的 ByteBuffer 更新摘要。
从类 java.security.MessageDigestSpi 继承的方法
engineDigest, engineDigest, engineGetDigestLength, engineReset, engineUpdate, engineUpdate, engineUpdate
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MessageDigest

protected MessageDigest(String algorithm)
创建具有指定算法名称的信息摘要。

参数：
algorithm - 摘要算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
方法详细信息

getInstance

public static MessageDigest getInstance(String algorithm)
                                 throws NoSuchAlgorithmException
返回实现指定摘要算法的 MessageDigest 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回封装取自第一个 Provider 的 MessageDigestSpi 实现的新 MessageDigest 对象，第一个 Provider 支持指定算法。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
实现指定算法的 Message Digest 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 MessageDigestSpi 实现
另请参见：
Provider

getInstance

public static MessageDigest getInstance(String algorithm,
                                        String provider)
                                 throws NoSuchAlgorithmException,
                                        NoSuchProviderException
返回实现指定摘要算法的 MessageDigest 对象。

返回封装 MessageDigestSpi 实现的新 MessageDigest 对象，该实现取自指定提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者的名称。
返回：
实现指定算法的 MessageDigest 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 MessageDigestSpi 实现不能从指定提供者获得。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static MessageDigest getInstance(String algorithm,
                                        Provider provider)
                                 throws NoSuchAlgorithmException
返回实现指定摘要算法的 MessageDigest 对象。

返回封装 MessageDigestSpi 实现的新 MessageDigest 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求算法的名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者。
返回：
实现指定算法的 MessageDigest 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 MessageDigestSpi 实现不能从指定的提供者对象获得。
IllegalArgumentException - 如果指定的提供者为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此信息摘要对象的提供者。

返回：
此信息摘要对象的提供者。

update

public void update(byte input)
使用指定的字节更新摘要。

参数：
input - 用于更新摘要的字节。

update

public void update(byte[] input,
                   int offset,
                   int len)
使用指定的 byte 数组，从指定的偏移量开始更新摘要。

参数：
input - byte 数组。
offset - byte 数组中的偏移量，操作从此处开始。
len - 要使用的字节数，始于 offset。

update

public void update(byte[] input)
使用指定的 byte 数组更新摘要。

参数：
input - byte 数组。

update

public final void update(ByteBuffer input)
使用指定的 ByteBuffer 更新摘要。使用始于 input.position() 处的 input.remaining() 个字节更新摘要。一旦返回，该缓冲区的位置将等于它的界限；它的界限将不会更改。

参数：
input - ByteBuffer
从以下版本开始：
1.5

digest

public byte[] digest()
通过执行诸如填充之类的最终操作完成哈希计算。在调用此方法之后，摘要被重置。

返回：
存放哈希值结果的 byte 数组。

digest

public int digest(byte[] buf,
                  int offset,
                  int len)
           throws DigestException
通过执行诸如填充之类的最终操作完成哈希计算。在调用此方法之后，摘要被重置。

参数：
buf - 存放计算摘要的输出缓冲区
offset - 输出缓冲区中的偏移量，从此处开始存储摘要。
len - 在 buf 中分配给摘要的字节数
返回：
放到 buf 中的字节数
抛出：
DigestException - 如果发生错误。

digest

public byte[] digest(byte[] input)
使用指定的 byte 数组对摘要进行最后更新，然后完成摘要计算。也就是说，此方法首先调用 update(input)，向 update 方法传递 input 数组，然后调用 digest()。

参数：
input - 在完成摘要计算前要更新的输入。
返回：
存放哈希值结果的 byte 数组。

toString

public String toString()
返回此信息摘要对象的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

isEqual

public static boolean isEqual(byte[] digesta,
                              byte[] digestb)
比较两个摘要的相等性。做简单的字节比较。

参数：
digesta - 要比较的摘要之一。
digestb - 要比较的另一个摘要。
返回：
如果摘要相等，则返回 true；否则返回 false

reset

public void reset()
重置摘要以供再次使用。

getAlgorithm

public final String getAlgorithm()
返回标识算法的独立于实现细节的字符串。此名称应该是标准的 Java 安全名称（如 "SHA"、"MD5" 等等）。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。

返回：
算法的名称

getDigestLength

public final int getDigestLength()
返回以字节为单位的摘要长度，如果提供者不支持此操作并且实现是不可复制的，则返回 0。

返回：
以字节为单位的摘要长度，如果提供者不支持此操作并且实现是不可复制的，则返回 0。
从以下版本开始：
1.2

clone

public Object clone()
             throws CloneNotSupportedException
如果实现是可复制的，则返回一个副本。

覆盖：
类 MessageDigestSpi 中的 clone
返回：
如果实现是可复制的，则返回一个副本。
抛出：
CloneNotSupportedException - 如果对一个不支持 Cloneable 的实现调用此方法。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageDigestSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 MessageDigestSpi

java.lang.Object
    继承者  java.security.MessageDigestSpi
直接已知子类：
MessageDigest
public abstract class MessageDigestSpi
extends Object

此类为 MessageDigest 类定义服务提供者接口 (SPI)，MessageDigest 类提供信息摘要算法的功能，如 MD5 或 SHA。信息摘要是安全的单向哈希函数，它接收任意大小的数据，输出固定长度的哈希值。

希望提供特定信息摘要算法的密码服务提供者必须实现此类中的所有抽象方法。

实现可随意选择是否实现 Cloneable 接口。

另请参见：
MessageDigest

构造方法摘要
MessageDigestSpi()
方法摘要
Object | clone() 如果实现是可复制的，则返回一个副本。
protected abstract byte[] | engineDigest() 通过执行诸如填充等之类的最终操作完成哈希计算。
protected int | engineDigest(byte[] buf, int offset, int len) 通过执行诸如填充等之类的最终操作完成哈希计算。
protected int | engineGetDigestLength() 返回以字节为单位的摘要长度。
protected abstract void | engineReset() 为进一步使用重置摘要。
protected abstract void | engineUpdate(byte input) 使用指定的字节更新摘要。
protected abstract void | engineUpdate(byte[] input, int offset, int len) 使用指定的 byte 数组，在指定的偏移量处开始更新摘要。
protected void | engineUpdate(ByteBuffer input) 使用指定的 ByteBuffer 更新摘要。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageDigestSpi

public MessageDigestSpi()
方法详细信息

engineGetDigestLength

protected int engineGetDigestLength()
返回以字节为单位的摘要长度。

已将此具体方法添加到以前定义的这个抽象类中。（为了向后兼容性，它不能是抽象的）。

默认行为是返回 0。

提供者可以重写此方法来返回摘要长度。

返回：
以字节为单位的摘要长度。
从以下版本开始：
1.2

engineUpdate

protected abstract void engineUpdate(byte input)
使用指定的字节更新摘要。

参数：
input - 更新所使用的字节。

engineUpdate

protected abstract void engineUpdate(byte[] input,
                                     int offset,
                                     int len)
使用指定的 byte 数组，在指定的偏移量处开始更新摘要。

参数：
input - 用来更新的 byte 数组。
offset - byte 数组中的偏移量，操作从此处开始。
len - 要使用的字节数，始于 offset。

engineUpdate

protected void engineUpdate(ByteBuffer input)
使用指定的 ByteBuffer 更新摘要。使用始于 input.position() 处的 input.remaining() 个字节更新摘要。一旦返回，该缓冲区的位置将等于它的界限；它的界限将不会更改。

参数：
input - ByteBuffer
从以下版本开始：
1.5

engineDigest

protected abstract byte[] engineDigest()
通过执行诸如填充等之类的最终操作完成哈希计算。一旦 engineDigest 被调用，引擎应该被重置（请参见 engineReset）。重置由引擎实现者负责。

返回：
存放哈希值结果的 byte 数组。

engineDigest

protected int engineDigest(byte[] buf,
                           int offset,
                           int len)
                    throws DigestException
通过执行诸如填充等之类的最终操作完成哈希计算。一旦 engineDigest 被调用，引擎应该被重置（请参见 engineReset）。重置由引擎实现者负责。 此方法应该是抽象的，但是为了二进制兼容性使其具体。有知识的 (Knowledgeable) 的提供者应该重写此方法。

参数：
buf - 存储摘要的输出缓冲区
offset - 输出缓冲区中的偏移量，操作从此处开始
len - 在 buf 中分配给摘要的字节数。此默认实现和 SUN 的提供者都不返回部分摘要。使用此参数仅仅是为了在 API 中保持一致性。如果此参数的值小于实际的摘要长度，该方法将抛出 DigestException。此参数的值如果大于等于实际的摘要长度，它会被忽略。
返回：
存储在输出缓冲区中的摘要长度。
抛出：
DigestException - 如果发生错误。
从以下版本开始：
1.2

engineReset

protected abstract void engineReset()
为进一步使用重置摘要。

clone

public Object clone()
             throws CloneNotSupportedException
如果实现是可复制的，则返回一个副本。

覆盖：
类 Object 中的 clone
返回：
如果实现是可复制的，则返回一个副本。
抛出：
CloneNotSupportedException - 如果对一个不支持 Cloneable 的实现调用此方法。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchAlgorithmException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 NoSuchAlgorithmException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.NoSuchAlgorithmException
所有已实现的接口：
Serializable
public class NoSuchAlgorithmException
extends GeneralSecurityException

当请求特定的加密算法而它在该环境中不可用时抛出此异常。

另请参见：
序列化表格

构造方法摘要
NoSuchAlgorithmException()
构造不带详细消息的 NoSuchAlgorithmException。
NoSuchAlgorithmException(String msg)
构造带指定详细消息的 NoSuchAlgorithmException。
NoSuchAlgorithmException(String message, Throwable cause)
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。
NoSuchAlgorithmException(Throwable cause)
创建带指定 cause 和详细消息的 NoSuchAlgorithmException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchAlgorithmException

public NoSuchAlgorithmException()
构造不带详细消息的 NoSuchAlgorithmException。详细消息是描述此特定异常的字符串。

NoSuchAlgorithmException

public NoSuchAlgorithmException(String msg)
构造带指定详细消息的 NoSuchAlgorithmException。详细消息是描述此特定异常的字符串，例如，它可以指示哪个算法是不可用的。

参数：
msg - 详细消息。

NoSuchAlgorithmException

public NoSuchAlgorithmException(String message,
                                Throwable cause)
创建带指定详细消息和 cause 的 NoSuchAlgorithmException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5

NoSuchAlgorithmException

public NoSuchAlgorithmException(Throwable cause)
创建带指定 cause 和详细消息的 NoSuchAlgorithmException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchProviderException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 NoSuchProviderException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.NoSuchProviderException
所有已实现的接口：
Serializable
public class NoSuchProviderException
extends GeneralSecurityException

当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。

另请参见：
序列化表格

构造方法摘要
NoSuchProviderException()
构造不带详细消息的 NoSuchProviderException。
NoSuchProviderException(String msg)
构造带指定详细消息的 NoSuchProviderException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchProviderException

public NoSuchProviderException()
构造不带详细消息的 NoSuchProviderException。详细消息是描述此特定异常的字符串。

NoSuchProviderException

public NoSuchProviderException(String msg)
构造带指定详细消息的 NoSuchProviderException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PermissionCollection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 PermissionCollection

java.lang.Object
    继承者  java.security.PermissionCollection
所有已实现的接口：
Serializable
直接已知子类：
Permissions
public abstract class PermissionCollection
extends Object
implements Serializable

表示 Permission 对象集合的抽象类。

使用 PermissionCollection，您可以：

  • 使用 add 方法向集合添加权限。
  • 使用 implies 方法查看是否集合中暗含了特定的权限。
  • 使用 elements 方法枚举所有的权限。

当需要集合许多相同类型的 Permission 对象时，首先应该调用该特定 Permission 对象类型上的 newPermissionCollection 方法。默认的行为（来自 Permission 类）只是返回 null。如果 Permission 类的子类需要在一个特定的 PermissionCollection 对象中存储其权限，以便调用 PermissionCollection.implies 方法时能提供正确的语义，则它们应该重写此方法。如果返回非 null 值，一定要使用该 PermissionCollection。如果返回 null，那么 newPermissionCollection 的调用方可以在任何它们选择的 PermissionCollection（使用 Hashtable 的，使用 Vector 的，等等)中随意存储给定类型的权限。

Permission.newPermissionCollection 方法返回的 PermissionCollection 是同类的集合，它们只存储给定 Permission 类型的 Permission 对象。PermissionCollection 也可以是不同种类的。例如，Permissions 是 PermissionCollection 的子类，表示 PermissionCollection 的集合。也就是说，它的每一个成员是一个同类的 PermissionCollection。例如，一个 Permissions 对象可能有一个用于所有 FilePermission 对象的 FilePermissionCollection，有一个用于所有的 SocketPermission 对象的 SocketPermissionCollection，等等。它的 add 方法将权限添加到恰当的集合。

只要将一个权限添加到不同种类的 PermissionCollection（如 Permissions），并且 PermissionCollection 尚未包含指定权限类型的 PermissionCollection，PermissionCollection 都应该对该权限的类调用 newPermissionCollection 方法来查看其是否需要特殊的 PermissionCollection。如果 newPermissionCollection 返回 null，则 PermissionCollection 可以将权限随意存储在它需要的任何类型的 PermissionCollection 中（使用 Hashtable 的，使用 Vector 的，等等）。例如，Permissions 对象使用默认的 PermissionCollection 实现，该实现将权限存储在 Hashtable 中。

PermissionCollection 的子类实现应该假定它们可能在多个线程中被同时调用，因此应该被正确地同步。此外，通过 elements 方法返回的枚举不是快速失败 的。正在对一个集合进行枚举时，不应该修改该集合。

另请参见：
Permission, Permissions, 序列化表格

构造方法摘要
PermissionCollection()
方法摘要
abstract void | add(Permission permission) 将一个权限对象添加到当前权限对象的集合。
abstract Enumeration<Permission> | elements() 返回集合中所有 Permission 对象的枚举。
abstract boolean | implies(Permission permission) 查看此 PermissionCollection 中保存的 Permission 对象集合是否暗含指定的权限。
boolean | isReadOnly() 如果此 PermissionCollection 对象被标记为只读，则返回 true。
void | setReadOnly() 将此 PermissionCollection 对象标记为 "readonly"。
String | toString() 返回描述此 PermissionCollection 对象的字符串，提供该对象中包含的关于所有权限的信息。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PermissionCollection

public PermissionCollection()
方法详细信息

add

public abstract void add(Permission permission)
将一个权限对象添加到当前权限对象的集合。

参数：
permission - 要添加的 Permission 对象。
抛出：
SecurityException - 如果此 PermissionCollection 对象已被标记为只读。

implies

public abstract boolean implies(Permission permission)
查看此 PermissionCollection 中保存的 Permission 对象集合是否暗含指定的权限。

参数：
permission - 要比较的 Permission 对象。
返回：
如果集合中的权限暗含 "permission"，则返回 true；否则返回 false。

elements

public abstract Enumeration<Permission> elements()
返回集合中所有 Permission 对象的枚举。

返回：
所有 Permission 的枚举。

setReadOnly

public void setReadOnly()
将此 PermissionCollection 对象标记为 "readonly"。当 PermissionCollection 对象被标记为只读后，不能使用 add 向其中添加任何新的 Permission 对象。

isReadOnly

public boolean isReadOnly()
如果此 PermissionCollection 对象被标记为只读，则返回 true。如果它是只读的，则不能使用 add 向其中添加任何新的 Permission 对象。

默认情况下，对象不 是只读的。它可以通过调用 setReadOnly 设置为只读。

返回：
如果此 PermissionCollection 对象被标记为只读，则返回 true ；否则返回 false。

toString

public String toString()
返回描述此 PermissionCollection 对象的字符串，提供该对象中包含的关于所有权限的信息。格式为：
super.toString() (
   // enumerate all the Permission
   // objects and call toString() on them,
   // one per line..
 )
super.toString 调用此对象的超类的 toString 方法，其超类是 Object。结果是此 PermissionCollection 的类型名称，后跟此对象的哈希码，因此使客户端能区分不同的 PermissionCollections 对象，即使它们包含相同的权限。

覆盖：
类 Object 中的 toString
返回：
有关此 PermissionCollection 对象的信息，如上所述。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Permissions (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Permissions

java.lang.Object
    继承者  java.security.PermissionCollection
        继承者  java.security.Permissions
所有已实现的接口：
Serializable
public final class Permissions
extends PermissionCollection
implements Serializable

此类表示一个不同种类的 Permission 集合。也就是说，它包含组编到 PermissionCollection 中的不同类型的 Permission 对象。例如，如果将任何 java.io.FilePermission 对象添加到此类的实例中，它们都将被存储在单个 PermissionCollection 中。调用 FilePermission 类的 newPermissionCollection 方法返回的是 PermissionCollection。类似的，任何 java.lang.RuntimePermission 对象都存储在调用 RuntimePermission 类的 newPermissionCollection 方法所返回的 PermissionCollection 中。因此，此类表示 PermissionCollection 的集合。

当调用 add 方法添加 Permission 时，Permission 将被存储在合适的 PermissionCollection 中。如果还没有这样的集合存在，则确定 Permission 对象的类并对该类调用 newPermissionCollection 方法来创建 PermissionCollection，然后将其添加到 Permissions 对象中。如果 newPermissionCollection 返回 null，那么将创建和使用一个默认使用 hashtable 的 PermissionCollection。每个 hashtable 项存储了一个 Permission 对象作为键和值。

通过 elements 方法返回的枚举不是快速失败 的。正在对一个集合进行枚举时，不应该修改该集合。

另请参见：
Permission, PermissionCollection, AllPermission

构造方法摘要
Permissions()
创建一个不包含任何 PermissionCollection 的新 Permissions 对象。
方法摘要
void | add(Permission permission) 将一个 permission 对象添加到该权限所属的类的 PermissionCollection 中。
Enumeration<Permission> | elements() 返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。
boolean | implies(Permission permission) 查看此对象用于指定 permission 类的 permissions 的 PermissionCollection 是否暗含了 permission 对象中表示的权限。
从类 java.security.PermissionCollection 继承的方法
isReadOnly, setReadOnly, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Permissions

public Permissions()
创建一个不包含任何 PermissionCollection 的新 Permissions 对象。

方法详细信息

add

public void add(Permission permission)
将一个 permission 对象添加到该权限所属的类的 PermissionCollection 中。例如，如果 permission 是 FilePermission，则将它添加到存储在此 Permissions 对象中的 FilePermissionCollection 中。 如果不存在合适的 collection，则此方法创建一个新的 PermissionCollection 对象（并且向其中添加权限）。

指定者：
类 PermissionCollection 中的 add
参数：
permission - 要添加的 Permission 对象。
抛出：
SecurityException - 如果此 Permissions 对象被标记为只读。
另请参见：
PermissionCollection.isReadOnly()

implies

public boolean implies(Permission permission)
查看此对象用于指定 permission 类的 permissions 的 PermissionCollection 是否暗含了 permission 对象中表示的权限。如果合适的 PermissionCollection（例如，用于 FilePermission 的 FilePermissionCollection）中权限的组合一起暗含了指定的权限，则返回 true。

例如，假定在此 Permissions 对象中有一个 FilePermissionCollection，它包含一个指定对 "/tmp" 目录所有子目录下的所有文件进行 "read" 访问的 FilePermission，以及另一个指定对 "/tmp/scratch/foo" 目录下所有文件进行 "write" 访问的 FilePermission。那么如果使用指定对 "/tmp/scratch/foo" 目录下的文件进行 "read" 和 "write" 访问权限的 permission 作为参数调用 implies 方法，则返回 true。

此外，如果此 PermissionCollection 包含 AllPermission，此方法将总是返回 true。

指定者：
类 PermissionCollection 中的 implies
参数：
permission - 要检查的 Permission 对象。
返回：
如果 "permission" 所属的 PermissionCollection 中的权限暗含了 "permission"，则返回 true；否则，返回 false。

elements

public Enumeration<Permission> elements()
返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。

指定者：
类 PermissionCollection 中的 elements
返回：
所有 Permission 的枚举。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Policy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Policy

java.lang.Object
    继承者  java.security.Policy

public abstract class Policy
extends Object

Policy 对象负责确定在 Java 运行时环境中执行的代码是否有权执行安全敏感的操作。

任意给定时刻只有一个 Policy 对象安装在运行时中。可以通过调用 setPolicy 方法安装 Policy 对象。安装的 Policy 对象可以通过调用 getPolicy 方法获得。

如果尚未在运行时中安装任何 Policy 对象，那么将调用 getPolicy 安装默认 Policy 实现的实例（此抽象类的默认子类实现）。 通过将 "policy.provider" 安全属性（在 Java 安全属性文件中）的值设置为所需 Policy 子类实现的完全限定名，可以更改默认 Policy 实现。Java 安全属性文件位于名为 <JAVA_HOME>/lib/security/java.security 的文件中。 <JAVA_HOME> 引用 java.home 系统属性的值，并指定 JRE 的安装目录。

应用程序代码可以直接子类化 Policy，提供定制的实现。此外，通过调用某一个 getInstance 工厂方法并使用标准类型作为参数，可以构建一个 Policy 对象的实现。默认策略类型是 "JavaPolicy"。有关标准 Policy 类型列表，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。

安装了 Policy 实例后（通过默认安装或调用 setPolicy），在需要确定执行代码（封装在 ProtectionDomain 中）是否可以执行受保护 SecurityManager 操作时，Java 运行时将调用其 implies。Policy 对象如何获取其策略数据由 Policy 实现本身决定。策略数据可以存储在纯 ASCII 文件中、Policy 类的序列化二进制文件中、数据库中等等。

refresh 方法使 Policy 对象刷新/重载其数据。 此操作与实现有关。例如，如果 Policy 对象将其数据存储在配制文件中，那么调用 refresh 将导致重读配制策略文件。如果不支持刷新操作，那么此方法不执行任何操作。注意，刷新策略对特定 ProtectionDomain 中的类可能无效。这取决于 Policy 提供者的 implies 方法实现及其 PermissionCollection 缓存策略。

另请参见：
Provider, ProtectionDomain, Permission

嵌套类摘要
static interface Policy.Parameters
此类表示用于 Policy 参数的标记接口。
字段摘要
static PermissionCollection UNSUPPORTED_EMPTY_COLLECTION
一个空的只读 PermissionCollection 实例。
构造方法摘要
Policy()
方法摘要
static Policy | getInstance(String type, Policy.Parameters params) 返回指定类型的 Policy 对象。
static Policy | getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static Policy | getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。
Policy.Parameters | getParameters() 返回 Policy 参数。
PermissionCollection | getPermissions(CodeSource codesource) 返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。
PermissionCollection | getPermissions(ProtectionDomain domain) 返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。
static Policy | getPolicy() 返回安装的 Policy 对象。
Provider | getProvider() 返回此 Policy 的 Provider。
String | getType() 返回此 Policy 的类型。
boolean | implies(ProtectionDomain domain, Permission permission) 计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。
void | refresh() 刷新/重新加载策略配置。
static void | setPolicy(Policy p) 设置系统范围的 Policy 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UNSUPPORTED_EMPTY_COLLECTION

public static final PermissionCollection UNSUPPORTED_EMPTY_COLLECTION
一个空的只读 PermissionCollection 实例。

从以下版本开始：
1.6
构造方法详细信息

Policy

public Policy()
方法详细信息

getPolicy

public static Policy getPolicy()
返回安装的 Policy 对象。此值不应该被缓存，因为它可能通过调用 setPolicy 更改。此方法首先使用 SecurityPermission("getPolicy") 权限调用 SecurityManager.checkPermission 来保证可以获取 Policy 对象。

返回：
安装的 Policy。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许获取 Policy 对象。
另请参见：
SecurityManager.checkPermission(Permission), setPolicy(java.security.Policy)

setPolicy

public static void setPolicy(Policy p)
设置系统范围的 Policy 对象。此方法首先使用 SecurityPermission("setPolicy") 权限调用 SecurityManager.checkPermission 来保证可以设置 Policy。

参数：
p - 新的系统 Policy 对象。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许设置 Policy。
另请参见：
SecurityManager.checkPermission(Permission), getPolicy()

getInstance

public static Policy getInstance(String type,
                                 Policy.Parameters params)
                          throws NoSuchAlgorithmException
返回指定类型的 Policy 对象。

此方法从首选 Provider 开始，遍历已注册安全提供者列表。返回一个封装 PolicySpi 实现的新 Policy 对象，该实现取自第一个支持指定类型的 Provider。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

参数：
type - 指定的 Policy 类型。有关标准 Policy 类型列表，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。
params - Policy 的参数，可以为 null。
返回：
新的 Policy 对象。
抛出：
SecurityException - 如果调用者无权获取指定类型的 Policy 实例。
NullPointerException - 如果指定类型为 null。
IllegalArgumentException - 如果选定 Provider 的 PolicySpi 实现不理解指定的参数。
NoSuchAlgorithmException - 如果没有任何 Provider 支持指定类型的 PolicySpi 实现。
从以下版本开始：
1.6
另请参见：
Provider

getInstance

public static Policy getInstance(String type,
                                 Policy.Parameters params,
                                 String provider)
                          throws NoSuchProviderException,
                                 NoSuchAlgorithmException
返回指定类型的 Policy 对象。

返回一个封装 PolicySpi 实现的新 Policy 对象，该实现取自指定提供者。注意，指定的提供者必须已在安全提供者列表中注册。

注意，已注册提供者列表可以使用 Security.getProviders() 方法获得。

参数：
type - 指定的 Policy 类型。有关标准 Policy 类型列表，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。
params - Policy 的参数，可以为 null。
provider - 提供者。
返回：
新的 Policy 对象。
抛出：
SecurityException - 如果调用者无权获取指定类型的 Policy 实例。
NullPointerException - 如果指定类型为 null。
IllegalArgumentException - 如果指定提供者为 null 或空，或者指定提供者的 PolicySpi 实现不理解指定的参数。
NoSuchProviderException - 如果指定提供者没有在安全提供者列表中注册。
NoSuchAlgorithmException - 如果指定提供者不支持指定类型的 PolicySpi 实现。
从以下版本开始：
1.6
另请参见：
Provider

getInstance

public static Policy getInstance(String type,
                                 Policy.Parameters params,
                                 Provider provider)
                          throws NoSuchAlgorithmException
返回指定类型的 Policy 对象。

返回一个封装 PolicySpi 实现的新 Policy 对象，该实现取自指定 Provider 对象。注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
type - 指定的 Policy 类型。有关标准 Policy 类型列表，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。
params - Policy 的参数，可以为 null。
provider - Provider。
返回：
新的 Policy 对象。
抛出：
SecurityException - 如果调用者无权获取指定类型的 Policy 实例。
NullPointerException - 如果指定类型为 null。
IllegalArgumentException - 如果指定的 Provider 为 null，或者指定 Provider 的 PolicySpi 实现不理解指定的参数。
NoSuchAlgorithmException - 如果指定的 Provider 不支持指定类型的 PolicySpi 实现。
从以下版本开始：
1.6
另请参见：
Provider

getProvider

public Provider getProvider()
返回此 Policy 的 Provider。

只有通过调用 Policy.getInstance 获取的 Policy 实例才有 Provider。否则此方法返回 null。

返回：
此 Policy 的 Provider，或者 null。
从以下版本开始：
1.6

getType

public String getType()
返回此 Policy 的类型。

只有通过调用 Policy.getInstance 获取的 Policy 实例才有类型。否则此方法返回 null。

返回：
此 Policy 的类型，或者 null。
从以下版本开始：
1.6

getParameters

public Policy.Parameters getParameters()
返回 Policy 参数。

只有通过调用 Policy.getInstance 获取的 Policy 实例才有参数。否则此方法返回 null。

返回：
Policy 参数，或者 null。
从以下版本开始：
1.6

getPermissions

public PermissionCollection getPermissions(CodeSource codesource)
返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。

建议应用程序不要调用此方法，因此并非所有策略实现都支持此操作。 应用程序只能依赖 implies 方法执行策略检查。如果应用程序不得不调用 getPermissions 方法，那么它应该调用 getPermissions(ProtectionDomain)。

此方法的默认实现返回 Policy.UNSUPPORTED_EMPTY_COLLECTION。如果策略实现可以返回授予 CodeSource 的权限组，则可以重写此方法。

参数：
codesource - 已授予返回 PermissionCollection 的 CodeSource。
返回：
授予指定 CodeSource 的权限集。如果支持此操作，那么返回的权限集必须是新的可变实例，并且它必须支持多种 Permission 类型。如果不支持此操作，则返回 Policy.UNSUPPORTED_EMPTY_COLLECTION。

getPermissions

public PermissionCollection getPermissions(ProtectionDomain domain)
返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。

建议应用程序不要调用此方法，因此并非所有策略实现都支持此操作。 应用程序应依赖 implies 方法执行策略检查。

此方法的默认实现首先获取 getPermissions(CodeSource)（CodeSource 取自指定的 ProtectionDomain）返回的权限，以及位于指定 ProtectionDomain 中的权限。 然后组合所有这些权限，并在一个新的 PermissionCollection 对象中返回。如果 getPermissions(CodeSource) 返回 Policy.UNSUPPORTED_EMPTY_COLLECTION，那么此方法在一个新的 PermissionCollection 对象中返回包含在指定 ProtectionDomain 中的权限。

如果策略实现支持返回授予 ProtectionDomain 的权限组，则可以重写此方法。

参数：
domain - 已授予返回 PermissionCollection 的 ProtectionDomain。
返回：
授予指定 ProtectionDomain 的权限集。如果支持此操作，那么返回的权限集必须是新的可变实例，并且它必须支持多种 Permission 类型。如果不支持此操作，则返回 Policy.UNSUPPORTED_EMPTY_COLLECTION。
从以下版本开始：
1.4
另请参见：
ProtectionDomain, SecureClassLoader

implies

public boolean implies(ProtectionDomain domain,
                       Permission permission)
计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。

参数：
domain - 要测试的 ProtectionDomain
permission - 要测试其暗含权限的 Permission 对象。
返回：
如果 "permission" 是授予此 ProtectionDomain 的真子集，则返回 true。
从以下版本开始：
1.4
另请参见：
ProtectionDomain

refresh

public void refresh()
刷新/重新加载策略配置。此方法的行为取决于实现。例如，对基于文件的策略调用 refresh 将导致重新读取该文件。

此方法的默认实现不执行任何操作。如果策略实现支持刷新操作，则可以重写此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Policy.Parameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 Policy.Parameters

所有已知实现类：
URIParameter
正在封闭类：
Policy
public static interface Policy.Parameters

此类表示用于 Policy 参数的标记接口。

从以下版本开始：
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicySpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 PolicySpi

java.lang.Object
    继承者  java.security.PolicySpi

public abstract class PolicySpi
extends Object

此类为 Policy 类定义服务提供者接口 (SPI)。每个想要提供 Policy 实现的服务提供者都必须实现此类中的所有抽象方法。

此抽象类的子类实现必须提供可将 Policy.Parameters 对象作为输入参数的公共构造方法。如果此构造方法不理解 Policy.Parameters 输入，它同样必须抛出 IllegalArgumentException。

从以下版本开始：
1.6

构造方法摘要
PolicySpi()
方法摘要
protected PermissionCollection | engineGetPermissions(CodeSource codesource) 返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。
protected PermissionCollection | engineGetPermissions(ProtectionDomain domain) 返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。
protected abstract boolean | engineImplies(ProtectionDomain domain, Permission permission) 检查该策略是否已将 Permission 授予 ProtectionDomain。
protected void | engineRefresh() 刷新/重载策略配置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PolicySpi

public PolicySpi()
方法详细信息

engineImplies

protected abstract boolean engineImplies(ProtectionDomain domain,
                                         Permission permission)
检查该策略是否已将 Permission 授予 ProtectionDomain。

参数：
domain - 要检查的 ProtectionDomain。
permission - 检查是否已将此权限授予指定的域。
返回：
如果已将此权限授予该域，则返回 boolean 值 true。

engineRefresh

protected void engineRefresh()
刷新/重载策略配置。此方法的行为取决于实现。例如，对基于文件的策略调用 refresh 将导致重新读取该文件。

此方法的默认实现不执行任何操作。如果策略实现支持刷新操作，则应该重写此方法。

engineGetPermissions

protected PermissionCollection engineGetPermissions(CodeSource codesource)
返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。

此方法的默认实现返回 Policy.UNSUPPORTED_EMPTY_COLLECTION 对象。如果策略实现可以返回授予 CodeSource 的权限集，则可以重写此方法。

参数：
codesource - 授予了返回 PermissionCollection 的 CodeSource。
返回：
授予指定 CodeSource 的权限集。如果支持此操作，则返回的权限集必须是可变的新实例，并且它必须支持不同的 Permission 类型。如果不支持此操作，则返回 Policy.UNSUPPORTED_EMPTY_COLLECTION。

engineGetPermissions

protected PermissionCollection engineGetPermissions(ProtectionDomain domain)
返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。

此方法的默认实现返回 Policy.UNSUPPORTED_EMPTY_COLLECTION 对象。如果策略实现可以返回授予 ProtectionDomain 的权限集，则可以重写此方法。

参数：
domain - 授予了返回 PermissionCollection 的 ProtectionDomain。
返回：
授予指定 ProtectionDomain 的权限集。如果支持此操作，则返回的权限集必须是可变的新实例，并且它必须支持不同的 Permission 类型。如果不支持此操作，则返回 Policy.UNSUPPORTED_EMPTY_COLLECTION。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Principal (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 Principal

所有已知子接口：
Group
所有已知实现类：
Identity, IdentityScope, JMXPrincipal, KerberosPrincipal, Signer, X500Principal
public interface Principal

此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。

另请参见：
X509Certificate

方法摘要
boolean | equals(Object another) 将此主体与指定对象比较。
String | getName() 返回此主体的名称。
int | hashCode() 返回此主体的哈希码。
String | toString() 返回此主体的字符串表示形式。

方法详细信息

equals

boolean equals(Object another)
将此主体与指定对象比较。如果传入的对象与此接口的实现所表示的主体相匹配，则返回 true。

覆盖：
类 Object 中的 equals
参数：
another - 要与之比较的主体。
返回：
如果传入的主体与此主体封装的主体相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

String toString()
返回此主体的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此主体的字符串表示形式。

hashCode

int hashCode()
返回此主体的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此主体的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

getName

String getName()
返回此主体的名称。

返回：
此主体的名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrivateKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 PrivateKey

所有超级接口：
Key, Serializable
所有已知子接口：
DHPrivateKey, DSAPrivateKey, ECPrivateKey, RSAMultiPrimePrivateCrtKey, RSAPrivateCrtKey, RSAPrivateKey
public interface PrivateKey
extends Key

私钥。此接口不包含任何方法或常量。它仅用于将所有私钥接口分组（并为其提供类型安全）。 注：特定的私钥接口扩展此接口。请参见（例如）java.security.interfaces 中的 DSAPrivateKey 接口。

另请参见：
Key, PublicKey, Certificate, Signature.initVerify(java.security.PublicKey), DSAPrivateKey, RSAPrivateKey, RSAPrivateCrtKey

字段摘要
static long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。
方法摘要
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrivilegedAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 PrivilegedAction<T>

public interface PrivilegedAction<T>

启用特权的情况下要执行的计算。通过在 PrivilegedAction 对象上调用 AccessController.doPrivileged 执行该计算。此接口只用于那些不抛出经过检查的异常的计算；抛出经过检查的异常的计算必须使用 PrivilegedExceptionAction。

另请参见：
AccessController, AccessController.doPrivileged(PrivilegedAction), PrivilegedExceptionAction

方法摘要
 T run()
执行计算。

方法详细信息

run

T run()
执行计算。此方法将在启动优先级后由 AccessController.doPrivileged 调用。

返回：
可以表示计算结果的与类有关的值。每个实现 PrivilegedAction 的类都应该记录是否此值表示某些内容及其表示的内容。
另请参见：
AccessController.doPrivileged(PrivilegedAction), AccessController.doPrivileged(PrivilegedAction, AccessControlContext)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrivilegedActionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 PrivilegedActionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.PrivilegedActionException
所有已实现的接口：
Serializable
public class PrivilegedActionException
extends Exception

doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。可以通过调用 getException 方法捕获操作抛出的异常。实际上，PrivilegedActionException 是特权操作抛出的异常的“包装器”。

从版本 1.4 开始，已对此异常作出改进，以符合通用异常链机制。“特权计算抛出的异常”是在构造的时候提供的，可以通过 getException() 方法访问，这类对象目前被认为是导致异常的 cause，可以通过 Throwable.getCause() 方法以及后面提到的“遗留方法”访问它。

另请参见：
PrivilegedExceptionAction, AccessController.doPrivileged(PrivilegedExceptionAction), AccessController.doPrivileged(PrivilegedExceptionAction,AccessControlContext), 序列化表格

构造方法摘要
PrivilegedActionException(Exception exception)
构造一个新的“包装”指定 Exception 的 PrivilegedActionException。
方法摘要
Throwable | getCause() 返回此异常（特权计算抛出的异常，该异常导致此 PrivilegedActionException）的 cause。
Exception | getException() 返回特权计算抛出的异常，该异常导致此 PrivilegedActionException。
String | toString() 返回此 throwable 的简短描述。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrivilegedActionException

public PrivilegedActionException(Exception exception)
构造一个新的“包装”指定 Exception 的 PrivilegedActionException。

参数：
exception - 抛出的异常
方法详细信息

getException

public Exception getException()
返回特权计算抛出的异常，该异常导致此 PrivilegedActionException。

这是通用异常链设施之前的方法。Throwable.getCause() 方法现在是获取此信息的首选方法。

返回：
特权计算抛出的异常，该异常导致此 PrivilegedActionException。
另请参见：
PrivilegedExceptionAction, AccessController.doPrivileged(PrivilegedExceptionAction), AccessController.doPrivileged(PrivilegedExceptionAction, AccessControlContext)

getCause

public Throwable getCause()
返回此异常（特权计算抛出的异常，该异常导致此 PrivilegedActionException）的 cause。

覆盖：
类 Throwable 中的 getCause
返回：
此异常的 cause。
从以下版本开始：
1.4

toString

public String toString()
从类 Throwable 复制的描述
返回此 throwable 的简短描述。结果是以下字符串的串联：
  • 此对象的类的 name
  • ": "（冒号和一个空格）
  • 调用此对象 Throwable.getLocalizedMessage() 方法的结果
如果 getLocalizedMessage 返回 null，则只返回类名称。

覆盖：
类 Throwable 中的 toString
返回：
该 throwable 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrivilegedExceptionAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 PrivilegedExceptionAction<T>

public interface PrivilegedExceptionAction<T>

在启用特权的情况下将要执行的计算，会抛出一个或多个经过检查的异常。通过在 PrivilegedExceptionAction 对象上调用 AccessController.doPrivileged 执行该计算。此接口只用于那些抛出经过检查的异常的计算；抛出未经过检查的异常的计算应使用 PrivilegedAction。

另请参见：
AccessController, AccessController.doPrivileged(PrivilegedExceptionAction), AccessController.doPrivileged(PrivilegedExceptionAction, AccessControlContext), PrivilegedAction

方法摘要
 T run()
执行计算。

方法详细信息

run

T run()
      throws Exception
执行计算。此方法将在启动优先级后由 AccessController.doPrivileged 调用。

返回：
可以表示计算结果的与类有关的值。每个实现 PrivilegedExceptionAction 的类都应该记录是否此值表示某些内容及其表示的内容。
抛出：
Exception - 出现异常情况。每个实现 PrivilegedExceptionAction 的类都应该记录其 run 方法能够抛出的异常。
另请参见：
AccessController.doPrivileged(PrivilegedExceptionAction), AccessController.doPrivileged(PrivilegedExceptionAction,AccessControlContext)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProtectionDomain (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 ProtectionDomain

java.lang.Object
    继承者  java.security.ProtectionDomain

public class ProtectionDomain
extends Object

此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。

在构造 ProtectionDomain 时可以对它绑定一个静态的权限集合；不管 Policy 是否有效，都会将这些权限授予域。但是，为了支持动态安全策略，也可以构造 ProtectionDomain，使得只要检查权限时就能通过当前 Policy 将其动态地映射到一个权限集合。

构造方法摘要
ProtectionDomain(CodeSource codesource, PermissionCollection permissions)
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。
方法摘要
ClassLoader | getClassLoader() 返回此域的 ClassLoader。
CodeSource | getCodeSource() 返回此域的 CodeSource。
PermissionCollection | getPermissions() 返回授予此域的静态权限。
Principal[] | getPrincipals() 返回此域的 principals 数组。
boolean | implies(Permission permission) 查看此 ProtectionDomain 是否暗含了 Permission 对象中表示的权限。
String | toString() 将 ProtectionDomain 转换成为 String。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ProtectionDomain

public ProtectionDomain(CodeSource codesource,
                        PermissionCollection permissions)
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。如果 permissions 对象不为 null，那么将在传入的 Permissions 对象上调用 setReadOnly()。只授予此域那些指定的权限；不参考当前的 Policy。

参数：
codesource - 与此域关联的 codesource
permissions - 授予此域的权限

ProtectionDomain

public ProtectionDomain(CodeSource codesource,
                        PermissionCollection permissions,
                        ClassLoader classloader,
                        Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。如果 permissions 对象不为 null，那么将在传入的 Permissions 对象上调用 setReadOnly()。授予此域的权限是动态的；它们包括传递给此构造方法的静态权限以及检查权限时当前 Policy 授予此域的任何权限。

此构造方法通常由 ClassLoaders 和 DomainCombiners 使用，它们委托 Policy 积极地关联授予此域的权限。此构造方法为 Policy provider 提供扩充 PermissionCollection 的机会以反映策略变化。

参数：
codesource - 与此域关联的 CodeSource
permissions - 授予此域的权限
classloader - 与此域关联的 ClassLoader
principals - 与此域关联的 Principals。复制数组的内容，以防随后进行修改。
从以下版本开始：
1.4
另请参见：
Policy.refresh(), Policy.getPermissions(ProtectionDomain)
方法详细信息

getCodeSource

public final CodeSource getCodeSource()
返回此域的 CodeSource。

返回：
此域的 CodeSource，它可以为 null。
从以下版本开始：
1.2

getClassLoader

public final ClassLoader getClassLoader()
返回此域的 ClassLoader。

返回：
此域的 ClassLoader，它可以为 null。
从以下版本开始：
1.4

getPrincipals

public final Principal[] getPrincipals()
返回此域的 principals 数组。

返回：
此域非 null 的 principals 数组。每次调用此方法都返回一个新的数组。
从以下版本开始：
1.4

getPermissions

public final PermissionCollection getPermissions()
返回授予此域的静态权限。

返回：
此域的静态权限集合，它可以为 null。
另请参见：
Policy.refresh(), Policy.getPermissions(ProtectionDomain)

implies

public boolean implies(Permission permission)
查看此 ProtectionDomain 是否暗含了 Permission 对象中表示的权限。

计算的权限集合依赖于该 ProtectionDomain 是用静态的权限集合构造的还是被绑定到动态映射的权限集合。

如果 ProtectionDomain 被构造为静态绑定的 PermissionCollection，那么只会依据构造时提供的 PermissionCollection 来检查权限。

但是，如果 ProtectionDomain 是用支持动态绑定权限的构造方法变体构造的,那么将会依据构造时提供的 PermissionCollection 和当前 Policy 绑定的组合来检查权限。

参数：
permission - 要检查的 Permission 对象。
返回：
如果 "permission" 暗含此 ProtectionDomain 中，则返回 true。

toString

public String toString()
将 ProtectionDomain 转换成为 String。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Provider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Provider

java.lang.Object
    继承者  java.util.Dictionary<K,V>
        继承者  java.util.Hashtable<Object,Object>
            继承者  java.util.Properties
                继承者  java.security.Provider
所有已实现的接口：
Serializable, Cloneable, Map<Object,Object>
直接已知子类：
AuthProvider
public abstract class Provider
extends Properties

此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。provider 可能实现的服务包括：

  • 算法（如 DSA、RSA、MD5 或 SHA-1）。
  • 密钥的生成、转换和管理设施（如用于特定于算法的密钥）。

每个 provider 有一个名称和一个版本号，并且在每个它装入运行时中进行配置。

有关特定类型的 provider、加密服务 provider 如何工作和安装的信息，请参阅 "Java Cryptography Architecture API Specification & Reference" 中的 Provider 类。但是，请注意 provider 能够被用来实现 Java 中的任何安全服务,这些安全服务使用带有适合下层的实现选择的可插入架构。

某些 provider 的实现在操作时可能遇到不可恢复的内部错误，例如与安全性令牌通信的错误。应该使用 ProviderException 指示此类错误。

服务类型 Provider 留给安全框架使用。此类型的服务不能被应用程序添加、移除或修改。以下属性自动放置在每个 Provider 对象中：

名称 | 值
Provider.id name | String.valueOf(provider.getName())
Provider.id version | String.valueOf(provider.getVersion())
Provider.id info | String.valueOf(provider.getInfo())
Provider.id className | provider.getClass().getName()

另请参见：
序列化表格

嵌套类摘要
static class Provider.Service
安全服务的描述。
字段摘要
从类 java.util.Properties 继承的字段
defaults
构造方法摘要
protected Provider(String name, double version, String info)
用指定的名称、版本号和信息构造一个 provider。
方法摘要
 void clear()
清除此 provider，使其不再包含用来查找由该 provider 实现的设施的属性。
 Enumeration<Object> elements()
返回此哈希表中的值的枚举。
 Set<Map.Entry<Object,Object>> entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。
 Object get(Object key)
返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null. 更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。
 String getInfo()
返回 provider 及其服务的人可读 (human-readable) 的描述。
 String getName()
返回此 provider 的名称。
 String getProperty(String key)
用指定的键在此属性列表中搜索属性。
 Provider.Service getService(String type, String algorithm)
获取描述此算法或别名的指定类型的此 Provider 实现的服务。
 Set<Provider.Service> getServices()
获取此 Provider 支持的所有服务的一个不可修改的 Set。
 double getVersion()
返回此 provider 的版本号。
 Enumeration<Object> keys()
返回此哈希表中的键的枚举。
 Set<Object> keySet()
返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。
 void load(InputStream inStream)
从输入流中读取属性列表（键和元素对）。
 Object put(Object key, Object value)
设置 key 属性，使其具有指定的 value。
 void putAll(Map<?,?> t)
将指定 Map 中所有映射关系复制到此 provider 中。
protected  void putService(Provider.Service s)
添加服务。
 Object remove(Object key)
移除 key 属性（及其相应的 value）。
protected  void removeService(Provider.Service s)
移除以前用 putService() 添加的服务。
 String toString()
返回具有此 provider 名称和版本号的字符串。
 Collection<Object> values()
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。
从类 java.util.Properties 继承的方法
getProperty, list, list, load, loadFromXML, propertyNames, save, setProperty, store, store, storeToXML, storeToXML, stringPropertyNames
从类 java.util.Hashtable 继承的方法
clone, contains, containsKey, containsValue, equals, hashCode, isEmpty, rehash, size
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Provider

protected Provider(String name,
                   double version,
                   String info)
用指定的名称、版本号和信息构造一个 provider。

参数：
name - provider 的名称。
version - provider 的版本号。
info - provider 及其服务的描述。
方法详细信息

getName

public String getName()
返回此 provider 的名称。

返回：
此 provider 的名称。

getVersion

public double getVersion()
返回此 provider 的版本号。

返回：
此 provider 的版本号。

getInfo

public String getInfo()
返回 provider 及其服务的人可读 (human-readable) 的描述。此方法可能返回带有相关链接的 HTML 页面。

返回：
provider 及其服务的描述。

toString

public String toString()
返回具有此 provider 名称和版本号的字符串。

覆盖：
类 Hashtable<Object,Object> 中的 toString
返回：
具有此 provider 名称和版本号的字符串。

clear

public void clear()
清除此 provider，使其不再包含用来查找由该 provider 实现的设施的属性。

首先，如果存在安全管理器，则用字符串 "clearProviderProperties."+name（其中 name 是 provider 的名称）作为参数值调用其 checkSecurityAccess 方法，以查看是否能够清除此 provider。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致使用 SecurityPermission("clearProviderProperties."+name) 权限来调用安全管理器的 checkPermission 方法。

指定者：
接口 Map<Object,Object> 中的 clear
覆盖：
类 Hashtable<Object,Object> 中的 clear
抛出：
SecurityException - 如果存在安全管理器，且其 {SecurityManager.checkSecurityAccess(java.lang.String) 方法拒绝清除此 provider
从以下版本开始：
1.2

load

public void load(InputStream inStream)
          throws IOException
从输入流中读取属性列表（键和元素对）。

覆盖：
类 Properties 中的 load
参数：
inStream - 输入流。
抛出：
IOException - 如果读取输入流时发生错误。
另请参见：
Properties.load(java.io.Reader)

putAll

public void putAll(Map<?,?> t)
将指定 Map 中所有映射关系复制到此 provider 中。针对指定 Map 中的当前所有键，这些映射关系将替换此 provider 中具有的所有属性。

指定者：
接口 Map<Object,Object> 中的 putAll
覆盖：
类 Hashtable<Object,Object> 中的 putAll
参数：
t - 将存储在此映射中的映射关系。
从以下版本开始：
1.2

entrySet

public Set<Map.Entry<Object,Object>> entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。

指定者：
接口 Map<Object,Object> 中的 entrySet
覆盖：
类 Hashtable<Object,Object> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图
从以下版本开始：
1.2
另请参见：
Map.Entry

keySet

public Set<Object> keySet()
返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。

指定者：
接口 Map<Object,Object> 中的 keySet
覆盖：
类 Hashtable<Object,Object> 中的 keySet
返回：
此映射中包含的键的 set 视图
从以下版本开始：
1.2

values

public Collection<Object> values()
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。

指定者：
接口 Map<Object,Object> 中的 values
覆盖：
类 Hashtable<Object,Object> 中的 values
返回：
此映射中包含的值的 collection 视图
从以下版本开始：
1.2

put

public Object put(Object key,
                  Object value)
设置 key 属性，使其具有指定的 value。

首先，如果存在安全管理器，则用字符串 "clearProviderProperties."+name（其中 name 是 provider 的名称）作为参数调用其 checkSecurityAccess 方法，以查看是否能设置此 provider 的属性值。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致使用 SecurityPermission("putProviderProperty."+name) 权限来调用安全管理器的 checkPermission 方法。

指定者：
接口 Map<Object,Object> 中的 put
覆盖：
类 Hashtable<Object,Object> 中的 put
参数：
key - 属性键。
value - 属性值。
返回：
指定属性 (key) 以前的值；如果不存在该值，则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkSecurityAccess(java.lang.String) 方法拒绝设置属性值。
从以下版本开始：
1.2
另请参见：
Object.equals(Object), Hashtable.get(Object)

remove

public Object remove(Object key)
移除 key 属性（及其相应的 value）。

首先，如果存在安全管理器，则用字符串 "removeProviderProperty."+name（其中 name 是 provider 的名称）作为参数调用其 checkSecurityAccess 方法，以查看是否能移除此 provider 的属性。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致使用 SecurityPermission("removeProviderProperty."+name) 权限来调用安全管理器的 checkPermission 方法。

指定者：
接口 Map<Object,Object> 中的 remove
覆盖：
类 Hashtable<Object,Object> 中的 remove
参数：
key - 要移除的属性的键。
返回：
与该键存在映射关系的值；如果该键没有映射关系，则返回 null。
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkDelete(java.lang.String) 方法拒绝移除此 provider 的属性。
从以下版本开始：
1.2

get

public Object get(Object key)
从类 Hashtable 复制的描述
返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null.

更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。（最多只能有一个这样的映射。）

指定者：
接口 Map<Object,Object> 中的 get
覆盖：
类 Hashtable<Object,Object> 中的 get
参数：
key - 要返回其相关值的键
返回：
指定键映射到的值，如果此映射不包含到键的映射，则返回 null。
另请参见：
Hashtable.put(Object, Object)

keys

public Enumeration<Object> keys()
从类 Hashtable 复制的描述
返回此哈希表中的键的枚举。

覆盖：
类 Hashtable<Object,Object> 中的 keys
返回：
此哈希表中的键的枚举。
另请参见：
Enumeration, Hashtable.elements(), Hashtable.keySet(), Map

elements

public Enumeration<Object> elements()
从类 Hashtable 复制的描述
返回此哈希表中的值的枚举。对返回的对象使用 Enumeration 方法，以便按顺序获取这些元素。

覆盖：
类 Hashtable<Object,Object> 中的 elements
返回：
此哈希表中的值的枚举。
另请参见：
Enumeration, Hashtable.keys(), Hashtable.values(), Map

getProperty

public String getProperty(String key)
从类 Properties 复制的描述
用指定的键在此属性列表中搜索属性。如果在此属性列表中未找到该键，则接着递归检查默认属性列表及其默认值。如果未找到属性，则此方法返回 null。

覆盖：
类 Properties 中的 getProperty
参数：
key - 属性键。
返回：
属性列表中具有指定键值的值。
另请参见：
Properties.setProperty(java.lang.String, java.lang.String), Properties.defaults

getService

public Provider.Service getService(String type,
                                   String algorithm)
获取描述此算法或别名的指定类型的此 Provider 实现的服务。如果不存在此类实现，则此方法返回 null。如果存在两个匹配的服务，分别使用 putService() 和 put() 添加到此 provider，那么返回通过 putService() 添加的服务。

参数：
type - 请求的 service 类型（例如 MessageDigest）
algorithm - 所请求服务不区分大小写的算法名称（或备用的别名）（例如 SHA-1）
返回：
描述此 Provider 的匹配服务的服务，如果不存在此类服务，则返回 null
抛出：
NullPointerException - 如果类型或算法为 null
从以下版本开始：
1.5

getServices

public Set<Provider.Service> getServices()
获取此 Provider 支持的所有服务的一个不可修改的 Set。

返回：
此 Provider 支持的所有服务的一个不可修改的 Set。
从以下版本开始：
1.5

putService

protected void putService(Provider.Service s)
添加服务。如果存在一个具有相同算法名称的相同类型服务，并且它是使用 putService() 添加的，则其将被新的服务替换。此方法还将关于此服务的信息放在 provider 的 Hashtable 值中，以 Java Cryptography Architecture API Specification & Reference 中描述的格式存放。

同样，如果存在安全管理器，则用字符串 "clearProviderProperties."+name（其中 name 是 provider 的名称）作为参数调用其 checkSecurityAccess 方法，以查看是否能设置此 provider 的属性值。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致使用 SecurityPermission("putProviderProperty."+name) 权限来调用安全管理器的 checkPermission 方法。

参数：
s - 要添加的服务
抛出：
SecurityException - 如果存在安全管理器，且其 SecurityManager.checkSecurityAccess(java.lang.String) 方法拒绝设置属性值。
NullPointerException - 如果 s 为 null
从以下版本开始：
1.5

removeService

protected void removeService(Provider.Service s)
移除以前用 putService() 添加的服务。从此 provider 中移除指定的服务。它将不再会被 getService() 返回，并且将从此 provider 的 Hashtable 中移除其信息。

同样，如果存在安全管理器，则用字符串 "removeProviderProperty."+name（其中 name 是 provider 的名称）作为参数调用其 checkSecurityAccess 方法，以查看是否能移除此 provider 的属性。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致使用 SecurityPermission("removeProviderProperty."+name) 权限来调用安全管理器的 checkPermission 方法。

参数：
s - 要移除的服务
抛出：
SecurityException - 如果存在安全管理器，且其 checkDelete 方法拒绝移除此 provider 的属性。
NullPointerException - 如果 s 为 null
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Provider.Service (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Provider.Service

java.lang.Object
    继承者  java.security.Provider.Service
正在封闭类：
Provider
public static class Provider.Service
extends Object

安全服务的描述。它封装服务的属性并包含获得此服务新的实现实例的一个工厂方法。

每个服务都有一个提供者，它提供服务、类型、算法名称和实现该服务的类的名称。它也可以选择包括此服务（别名）和属性的替换算法名称列表，该列表是 (name, value) String 对的映射表。

此类定义了方法 supportsParameter() 和 newInstance()，Java 安全框架搜索合适的服务并实例化它们时使用这两个方法。这些方法的有效参数取决于服务的类型。关于 Java SE 中定义的服务类型的有效值，请参见 Java Cryptography Architecture API Specification & Reference 。注意，Java SE 以外的组件可以定义其他类型的服务及其行为。

此类的实例是不可变的。

从以下版本开始：
1.5

构造方法摘要
Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。
方法摘要
String | getAlgorithm() 返回此服务的算法的名称。
String | getAttribute(String name) 返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。
String | getClassName() 返回实现此服务的类的名称。
Provider | getProvider() 返回此服务的 Provider。
String | getType() 获取此服务的类型。
Object | newInstance(Object constructorParameter) 返回此服务描述的实现的新实例。
boolean | supportsParameter(Object parameter) 测试此 Service 是否能使用指定的参数。
String | toString() 返回此服务的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Provider.Service

public Provider.Service(Provider provider,
                        String type,
                        String algorithm,
                        String className,
                        List<String> aliases,
                        Map<String,String> attributes)
构造新的服务。

参数：
provider - 提供此服务的提供者
type - 此服务的类型
algorithm - 算法名称
className - 实现此服务的类的名称
aliases - 别名的列表，如果算法没有别名则为 null
attributes - 属性的 Map，如果此实现没有属性则为 null
抛出：
NullPointerException - 如果 provider、type、algorithm、或 className 为 null
方法详细信息

getType

public final String getType()
获取此服务的类型。例如，MessageDigest。

返回：
此服务的类型

getAlgorithm

public final String getAlgorithm()
返回此服务的算法的名称。例如，SHA-1。

返回：
此服务的算法

getProvider

public final Provider getProvider()
返回此服务的 Provider。

返回：
此服务的 Provider。

getClassName

public final String getClassName()
返回实现此服务的类的名称。

返回：
实现此服务的类的名称。

getAttribute

public final String getAttribute(String name)
返回指定属性的值，如果没有为此 Service 设置此属性，则返回 null。

参数：
name - 请求的属性的名称
返回：
指定的属性的值，如果属性不存在则返回 null
抛出：
NullPointerException - 如果 name 为 null

newInstance

public Object newInstance(Object constructorParameter)
                   throws NoSuchAlgorithmException
返回此服务描述的实现的新实例。安全提供者框架使用此方法构造实现。应用程序通常不需要调用它。

默认实现使用反射调用此服务类型的标准构造方法。安全提供者可以重写此方法来以不同的方式实现实例化。有关详细信息和各种服务类型的有效 constructorParameter 值，请参见 Java Cryptography Architecture API Specification & Reference。

参数：
constructorParameter - 传递给构造器的值，如果此服务类型不使用 constructorParameter，则为 null。
返回：
此服务的新实现
抛出：
InvalidParameterException - 如果 constructorParameter 对于此服务类型是无效值
NoSuchAlgorithmException - 如果由于任何其他原因实例化失败。

supportsParameter

public boolean supportsParameter(Object parameter)
测试此 Service 是否能使用指定的参数。如果此服务不能使用该参数，则返回 false。如果此服务能使用该参数、快速测试不可行或状态未知，则返回 true。

安全提供者框架用一些服务类型作为参数使用此方法来快速排除所考虑实现中的不匹配项。应用程序通常不需要调用它。

有关详细信息和各种服务类型的有效参数值，请参见此类的顶部和 Java Cryptography Architecture API Specification & Reference。安全提供者可以重写它以实现自己的测试。

参数：
parameter - 要测试的参数。
返回：
如果此服务不能使用指定的参数返回 false；如果它可能使用该参数返回 true
抛出：
InvalidParameterException - 如果参数值对于此服务类型无效或此方法不能随此服务类型一同使用。

toString

public String toString()
返回此服务的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此服务的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProviderException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 ProviderException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.security.ProviderException
所有已实现的接口：
Serializable
public class ProviderException
extends RuntimeException

用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。

另请参见：
序列化表格

构造方法摘要
ProviderException()
构造不带详细消息的 ProviderException。
ProviderException(String s)
构造带指定详细消息的 ProviderException。
ProviderException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 ProviderException。
ProviderException(Throwable cause)
创建带指定的 cause 和详细消息的 ProviderException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ProviderException

public ProviderException()
构造不带详细消息的 ProviderException。详细消息是描述此特定异常的字符串。

ProviderException

public ProviderException(String s)
构造带指定详细消息的 ProviderException。详细消息是描述此特定异常的字符串。

参数：
s - 详细消息。

ProviderException

public ProviderException(String message,
                         Throwable cause)
创建带指定的详细消息和 cause 的 ProviderException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5

ProviderException

public ProviderException(Throwable cause)
创建带指定的 cause 和详细消息的 ProviderException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PublicKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
接口 PublicKey

所有超级接口：
Key, Serializable
所有已知子接口：
DHPublicKey, DSAPublicKey, ECPublicKey, RSAPublicKey
public interface PublicKey
extends Key

公钥。此接口不包含任何方法或常量。它仅用于将所有公钥接口分组（并为其提供类型安全）。 注：特定的公钥接口扩展此接口。请参见（例如）java.security.interfaces 中的 DSAPublicKey 接口。

另请参见：
Key, PrivateKey, Certificate, Signature.initVerify(java.security.PublicKey), DSAPublicKey, RSAPublicKey

字段摘要
static long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。
方法摘要
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecureClassLoader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 SecureClassLoader

java.lang.Object
    继承者  java.lang.ClassLoader
        继承者  java.security.SecureClassLoader
直接已知子类：
URLClassLoader
public class SecureClassLoader
extends ClassLoader

此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。

构造方法摘要
protected | SecureClassLoader() 使用默认的父类加载器为委托创建新 SecureClassLoader。
protected | SecureClassLoader(ClassLoader parent) 使用指定的父类加载器为委托创建新 SecureClassLoader。
方法摘要
protected Class<?> | defineClass(String name, byte[] b, int off, int len, CodeSource cs) 使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。
protected Class<?> | defineClass(String name, ByteBuffer b, CodeSource cs) 使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。
protected PermissionCollection | getPermissions(CodeSource codesource) 返回给定的 CodeSource 对象的权限。
从类 java.lang.ClassLoader 继承的方法
clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findClass, findLibrary, findLoadedClass, findResource, findResources, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecureClassLoader

protected SecureClassLoader(ClassLoader parent)
使用指定的父类加载器为委托创建新 SecureClassLoader。

如果有安全管理器，此方法会首先调用安全管理器的 checkCreateClassLoader 方法，以确保允许创建类加载器。

参数：
parent - 父 ClassLoader
抛出：
SecurityException - 如果安全管理器存在并且其 checkCreateClassLoader 方法不允许创建类加载器。
另请参见：
SecurityManager.checkCreateClassLoader()

SecureClassLoader

protected SecureClassLoader()
使用默认的父类加载器为委托创建新 SecureClassLoader。

如果有安全管理器，此方法会首先调用安全管理器的 checkCreateClassLoader 方法，以确保允许创建类加载器。

抛出：
SecurityException - 如果安全管理器存在并且其 checkCreateClassLoader 方法不允许创建类加载器。
另请参见：
SecurityManager.checkCreateClassLoader()
方法详细信息

defineClass

protected final Class<?> defineClass(String name,
                                     byte[] b,
                                     int off,
                                     int len,
                                     CodeSource cs)
使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。类必须解析后才能使用。

如果提供了非 null CodeSource，将构造 ProtectionDomain 并将其与要定义的类关联起来。

参数：
name - 期望的类名称，如果未知，则为 null，使用 '.'（而不是 '/'）作为分隔符，并且末尾没有 ".class" 后缀。
b - 组成类数据的字节。从 off 到 off+len-1 的字节应该具有由 Java Virtual Machine Specification 定义的有效类文件的格式。
off - 类数据的 b 的起始偏移量
len - 类数据的长度
cs - 相关的 CodeSource，如果没有，则为 null
返回：
通过该数据创建的 Class 对象和可选的 CodeSource。
抛出：
ClassFormatError - 如果数据未包含有效的类
IndexOutOfBoundsException - 如果 off 或 len 为负数，或者 off+len 大于 b.length。
SecurityException - 如果试图将该类添加到包含用与该类不同的证书集签名的类的包中，或者类名以 "java." 开头。

defineClass

protected final Class<?> defineClass(String name,
                                     ByteBuffer b,
                                     CodeSource cs)
使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。类必须解析后才能使用。

如果提供了非 null CodeSource，将构造 ProtectionDomain 并将其与要定义的类关联起来。

参数：
name - 期望的类名称，如果未知，则为 null，使用 '.'（而不是 '/'）作为分隔符，并且末尾没有 ".class" 后缀。
b - 组成类数据的字节。从 b.position() 到 b.position() + b.limit() -1 的字节应该具有由 Java Virtual Machine Specification 定义的有效类文件的格式。
cs - 相关的 CodeSource，如果没有，则为 null
返回：
通过该数据创建的 Class 对象和可选的 CodeSource。
抛出：
ClassFormatError - 如果数据未包含一个有效类
SecurityException - 如果试图将该类添加到包含使用与该类不同的证书集签名的类的包中，或者类名以 "java." 开头。
从以下版本开始：
1.5

getPermissions

protected PermissionCollection getPermissions(CodeSource codesource)
返回给定的 CodeSource 对象的权限。

此方法将由 defineClass 方法调用，后者在构造 ProtectionDomain 时将 CodeSource 作为要定义的类的参数。

参数：
codesource - codesource。
返回：
授予 codesource 的权限。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecureRandom (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 SecureRandom

java.lang.Object
    继承者  java.util.Random
        继承者  java.security.SecureRandom
所有已实现的接口：
Serializable
public class SecureRandom
extends Random

此类提供强加密随机数生成器 (RNG)。

强加密随机数至少要遵从 FIPS 140-2, Security Requirements for Cryptographic Modules 中 4.9.1 部分指定的统计随机数生成器测试。此外，SecureRandom 还必须生成非确定性输出。因此，根据 RFC 1750: Randomness Recommendations for Security 中的描述，任何传递给 SecureRandom 对象的种子材料必须是不可预知的，所有 SecureRandom 的输出序列必须是强加密的。

调用者可通过无参数构造方法或一个 getInstance 方法获取 SecureRandom 实例：

      SecureRandom random = new SecureRandom();

许多 SecureRandom 实现是伪随机数生成器 (PRNG) 的形式，这意味着它们将使用确定的算法根据实际随机种子生成伪随机序列。 其他实现可以生成实际随机数，而另一些实现则可能结合使用这两项技术。

通常，SecureRandom 的调用者调用以下方法获取随机字节：

      SecureRandom random = new SecureRandom();
   byte bytes[] = new byte[20];
      random.nextBytes(bytes);

调用者还可以调用 generateSeed 方法生成给定的种子字节数（例如，为其他随机数生成器提供种子）：

      byte seed[] = random.generateSeed(20);

另请参见：
SecureRandomSpi, Random, 序列化表格

构造方法摘要
 | SecureRandom() 构造一个实现默认随机数算法的安全随机数生成器 (RNG)。
 | SecureRandom(byte[] seed) 构造一个实现默认随机数算法的安全随机数生成器 (RNG)。
protected | SecureRandom(SecureRandomSpi secureRandomSpi, Provider provider) 创建 SecureRandom 对象。
方法摘要
byte[] | generateSeed(int numBytes) 返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。
String | getAlgorithm() 返回此 SecureRandom 对象实现的算法的名称。
static SecureRandom | getInstance(String algorithm) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static SecureRandom | getInstance(String algorithm, Provider provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static SecureRandom | getInstance(String algorithm, String provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
Provider | getProvider() 返回此 SecureRandom 对象的提供者。
static byte[] | getSeed(int numBytes) 返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。
protected int | next(int numBits) 生成一个包含用户指定伪随机位数的整数（右对齐，带前导零）。
void | nextBytes(byte[] bytes) 生成用户指定的随机字节数。
void | setSeed(byte[] seed) 重新设置此随机对象的种子。
void | setSeed(long seed) 使用给定 long seed 中包含的八个字节，重新设置此随机对象的种子。
从类 java.util.Random 继承的方法
nextBoolean, nextDouble, nextFloat, nextGaussian, nextInt, nextInt, nextLong
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecureRandom

public SecureRandom()
构造一个实现默认随机数算法的安全随机数生成器 (RNG)。

此构造方法从首选 Provider 开始，遍历已注册安全提供者列表。返回一个封装 SecureRandomSpi 实现的新 SecureRandom 对象，该实现取自第一个支持 SecureRandom (RNG) 算法的 Provider。如果没有 Provider 支持 RNG 算法，则返回一个特定于实现的默认对象。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

有关标准 RNG 算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。

尚未设置返回 SecureRandom 对象的种子。要设置返回对象的种子，可以调用 setSeed 方法。 如果没有调用 setSeed，那么第一次调用 nextBytes 时将强行将 SecureRandom 对象设置为自身的种子。 如果之前调用了 setSeed，则不会发生该操作。

SecureRandom

public SecureRandom(byte[] seed)
构造一个实现默认随机数算法的安全随机数生成器 (RNG)。SecureRandom 实例使用指定的种子字节设置种子。

此构造方法从首选 Provider 开始，遍历已注册安全提供者列表。返回一个封装 SecureRandomSpi 实现的新 SecureRandom 对象，该实现取自第一个支持 SecureRandom (RNG) 算法的 Provider。如果没有 Provider 支持 RNG 算法，则返回一个特定于实现的默认对象。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

有关标准 RNG 算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 的附录 A。

参数：
seed - 种子。

SecureRandom

protected SecureRandom(SecureRandomSpi secureRandomSpi,
                       Provider provider)
创建 SecureRandom 对象。

参数：
secureRandomSpi - SecureRandom 实现。
provider - 提供者。
方法详细信息

getInstance

public static SecureRandom getInstance(String algorithm)
                                throws NoSuchAlgorithmException
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

此方法从首选 Provider 开始，遍历已注册安全提供者列表。返回一个封装 SecureRandomSpi 实现的新 SecureRandom 对象，该实现取自第一个支持指定算法的 Provider。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

尚未设置返回 SecureRandom 对象的种子。要设置返回对象的种子，可以调用 setSeed 方法。 如果没有调用 setSeed，那么第一次调用 nextBytes 时将强行将 SecureRandom 对象设置为自身的种子。 如果之前调用了 setSeed，则不会发生该操作。

参数：
algorithm - RNG 算法的名称。有关标准 RNG 算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
新的 SecureRandom 对象。
抛出：
NoSuchAlgorithmException - 如果没有任何 Provider 支持指定算法的 SecureRandomSpi 实现。
从以下版本开始：
1.2
另请参见：
Provider

getInstance

public static SecureRandom getInstance(String algorithm,
                                       String provider)
                                throws NoSuchAlgorithmException,
                                       NoSuchProviderException
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

返回一个封装 SecureRandomSpi 实现的新 SecureRandom 对象，该实现取自指定提供者。指定的提供者必须已在安全提供者列表中注册。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

尚未设置返回 SecureRandom 对象的种子。要设置返回对象的种子，可以调用 setSeed 方法。 如果没有调用 setSeed，那么第一次调用 nextBytes 时将强行将 SecureRandom 对象设置为自身的种子。 如果之前调用了 setSeed，则不会发生该操作。

参数：
algorithm - RNG 算法的名称。有关标准 RNG 算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者的名称。
返回：
新的 SecureRandom 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 SecureRandomSpi 实现。
NoSuchProviderException - 如果指定提供者没有在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
从以下版本开始：
1.2
另请参见：
Provider

getInstance

public static SecureRandom getInstance(String algorithm,
                                       Provider provider)
                                throws NoSuchAlgorithmException
返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

返回一个封装 SecureRandomSpi 实现的新 SecureRandom 对象，该实现取自指定 Provider 对象。注意，指定的 Provider 对象无需在安全提供者列表中注册。

尚未设置返回 SecureRandom 对象的种子。要设置返回对象的种子，可以调用 setSeed 方法。 如果没有调用 setSeed，那么第一次调用 nextBytes 时将强行将 SecureRandom 对象设置为自身的种子。 如果之前调用了 setSeed，则不会发生该操作。

参数：
algorithm - RNG 算法的名称。有关标准 RNG 算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者。
返回：
新的 SecureRandom 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定的 Provider 对象获得指定算法的 SecureRandomSpi 实现。
IllegalArgumentException - 如果指定提供者为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 SecureRandom 对象的提供者。

返回：
此 SecureRandom 对象的提供者。

getAlgorithm

public String getAlgorithm()
返回此 SecureRandom 对象实现的算法的名称。

返回：
算法的名称；如果无法确定算法名称，则返回 unknown。
从以下版本开始：
1.5

setSeed

public void setSeed(byte[] seed)
重新设置此随机对象的种子。给定种子补充而不是取代现有的种子。因此，保证重复调用不会降低随机性。

参数：
seed - 种子。
另请参见：
getSeed(int)

setSeed

public void setSeed(long seed)
使用给定 long seed 中包含的八个字节，重新设置此随机对象的种子。给定种子补充而不是取代现有的种子。因此，保证重复调用不会降低随机性。

定义此方法是为了与 java.util.Random 兼容。

覆盖：
类 Random 中的 setSeed
参数：
seed - 种子。
另请参见：
getSeed(int)

nextBytes

public void nextBytes(byte[] bytes)
生成用户指定的随机字节数。

如果之前没有调用过 setSeed，那么第一次调用此方法时将强行将此 SecureRandom 对象设置为自身的种子。 如果之前调用了 setSeed，则不会发生该操作。

覆盖：
类 Random 中的 nextBytes
参数：
bytes - 用随机字节填充的数组。

next

protected final int next(int numBits)
生成一个包含用户指定伪随机位数的整数（右对齐，带前导零）。此方法将重写 java.util.Random 方法，并将为继承自类的所有方法（例如，nextInt、nextLong 和 nextFloat）提供随机位源。

覆盖：
类 Random 中的 next
参数：
numBits - 要生成的伪随机位数，其中 0 <= numBits <= 32。
返回：
一个 int，包含用户指定的伪随机位数（右对齐，带前导零）。

getSeed

public static byte[] getSeed(int numBytes)
返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。此调用可用于设置其他随机数生成器的种子。

包含此方法只是为了向后兼容。建议调用者使用一个替代 getInstance 方法来获取 SecureRandom 对象，然后调用 generateSeed 方法获取该对象中的种子字节。

参数：
numBytes - 将生成的种子字节数量。
返回：
种子字节。
另请参见：
setSeed(byte[])

generateSeed

public byte[] generateSeed(int numBytes)
返回给定的种子字节数量，该数量可使用此类用来将自身设置为种子的种子生成算法来计算。此调用可用于设置其他随机数生成器的种子。

参数：
numBytes - 将生成的种子字节数量。
返回：
种子字节。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecureRandomSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 SecureRandomSpi

java.lang.Object
    继承者  java.security.SecureRandomSpi
所有已实现的接口：
Serializable
public abstract class SecureRandomSpi
extends Object
implements Serializable

此类为 SecureRandom 类定义了服务提供者接口 (SPI)。此类中的所有抽象方法必须由这样的服务提供者来实现：该服务提供者希望提供加密的强伪随机数生成器的实现。

从以下版本开始：
1.2
另请参见：
SecureRandom, 序列化表格

构造方法摘要
SecureRandomSpi()
方法摘要
protected abstract byte[] | engineGenerateSeed(int numBytes) 返回给定的种子字节数。
protected abstract void | engineNextBytes(byte[] bytes) 生成用户指定的随机字节数。
protected abstract void | engineSetSeed(byte[] seed) 重新提供此随机对象的种子。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecureRandomSpi

public SecureRandomSpi()
方法详细信息

engineSetSeed

protected abstract void engineSetSeed(byte[] seed)
重新提供此随机对象的种子。给定种子补充而不是取代现有的种子。因此，重复调用保证了始终不会降低随机性。

参数：
seed - 种子。

engineNextBytes

protected abstract void engineNextBytes(byte[] bytes)
生成用户指定的随机字节数。

如果以前没有调用 engineSetSeed，则第一次调用此方法会强制将此 SecureRandom 实现设置为自身的种子。如果以前调用了 engineSetSeed，则不会发生此操作。

参数：
bytes - 用随机字节填充的数组。

engineGenerateSeed

protected abstract byte[] engineGenerateSeed(int numBytes)
返回给定的种子字节数。此调用可用来作为其他随机数生成器的种子。

参数：
numBytes - 将生成的种子字节的数量。
返回：
种子字节。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Security (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Security

java.lang.Object
    继承者  java.security.Security

public final class Security
extends Object

此类集中了所有的安全属性和常见的安全方法。其主要用途之一是管理提供者。

方法摘要
static int | addProvider(Provider provider) 将提供者添加到下一个可用位置。
static String | getAlgorithmProperty(String algName, String propName) 已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。
static Set<String> | getAlgorithms(String serviceName) 返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。
static String | getProperty(String key) 获取安全属性值。
static Provider | getProvider(String name) 返回使用指定的名称安装的提供者（如果有）。
static Provider[] | getProviders() 返回包含所有已安装的提供者的数组。
static Provider[] | getProviders(Map<String,String> filter) 返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
static Provider[] | getProviders(String filter) 返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
static int | insertProviderAt(Provider provider, int position) 在指定的位置添加新的提供者。
static void | removeProvider(String name) 移除带有指定名称的提供者。
static void | setProperty(String key, String datum) 设置安全属性值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getAlgorithmProperty

@Deprecated
public static String getAlgorithmProperty(String algName,
                                                     String propName)
已过时。 此方法用来返回 "SUN" 密码服务提供者的主文件中的专有属性的值，以便确定如何解析特定于算法的参数。使用新的基于提供者的、与算法无关的 AlgorithmParameters 和 KeyFactory 引擎类（在 J2SE 1.2 版中引入）代替。

获取某个算法的指定属性。算法名称必须是标准名称。有关标准算法名称的信息，请参见 Java Cryptography Architecture API Specification & Reference 中的附录 A。一种可能的用法是利用专门的算法分析程序，这些程序可以将类映射到它们理解的算法中（非常类似于 Key 分析程序的做法）。

参数：
algName - 算法名称。
propName - 要获得的属性名称。
返回：
指定的属性值。

insertProviderAt

public static int insertProviderAt(Provider provider,
                                   int position)
在指定的位置添加新的提供者。该位置就是在其中搜索提供者以寻找请求的算法的首选顺序。该位置从 1 开始，也就是说 1 是首选数，其后是 2，等等。

如果将给定的提供者安装到了请求的位置，则在该位置使用的提供者和所有位置大于 position 的提供者将向上移动一个位置（向所安装的提供者列表的尾部移动）。

如果已经安装了某个提供者，则不能再添加该程序。

首先，如果有安全管理器，则调用带有字符串 "insertProvider."+provider.getName() 的 checkSecurityAccess 方法可查看是否可以添加新的提供者。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致调用带有 SecurityPermission("insertProvider."+provider.getName()) 权限的安全管理器的 checkPermission 方法。

参数：
provider - 要添加的提供者。
position - 调用方调用此提供者的首选位置。
返回：
添加提供者的实际首选位置，如果因已安装了提供者而未添加它，则返回 -1。
抛出：
NullPointerException - 如果提供者为 null
SecurityException - 如果安全管理器已存在，且其 SecurityManager.checkSecurityAccess(java.lang.String) 方法拒绝对新的提供者进行添加访问
另请参见：
getProvider(java.lang.String), removeProvider(java.lang.String), SecurityPermission

addProvider

public static int addProvider(Provider provider)
将提供者添加到下一个可用位置。

首先，如果有安全管理器，则调用带有字符串 "insertProvider."+provider.getName() 的 checkSecurityAccess 方法可查看是否可以添加新的提供者。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致调用带有 SecurityPermission("insertProvider."+provider.getName()) 权限的安全管理器的 checkPermission 方法。

参数：
provider - 要添加的提供者。
返回：
添加提供者的首选位置，如果因已安装了提供者而未添加它，则返回 -1。
抛出：
NullPointerException - 如果提供者为 null
SecurityException - 如果安全管理器已存在，且其 SecurityManager.checkSecurityAccess(java.lang.String) 方法拒绝对新的提供者进行添加访问
另请参见：
getProvider(java.lang.String), removeProvider(java.lang.String), SecurityPermission

removeProvider

public static void removeProvider(String name)
移除带有指定名称的提供者。

当移除指定的提供者时，所有位置大于指定提供者所在位置的提供者都将向下移动一个位置（向已安装的提供者列表的头部移动）。

此方法默认返回是否未安装提供者或者名称是否为 null。

首先，如果有安全管理器，则调用带有字符串 "removeProvider."+name 的 checkSecurityAccess 方法可查看是否可以移除该提供者。如果使用 checkSecurityAccess 的默认实现（即未重写此方法），则会导致调用带有 SecurityPermission("removeProvider."+name) 权限的安全管理器的 checkPermission 方法。

参数：
name - 要移除的提供者的名称。
抛出：
SecurityException - 如果有安全管理器，且其 SecurityManager.checkSecurityAccess(java.lang.String) 方法拒绝对该提供者进行移除访问
另请参见：
getProvider(java.lang.String), addProvider(java.security.Provider)

getProviders

public static Provider[] getProviders()
返回包含所有已安装的提供者的数组。数组中提供者的顺序是其首选顺序。

返回：
所有已安装的提供者的数组。

getProvider

public static Provider getProvider(String name)
返回使用指定的名称安装的提供者（如果有）。如果未安装带有指定名称的提供者，或者名称为 null，则将返回 null。

参数：
name - 要获取的提供者的名称。
返回：
指定名称的提供者。
另请参见：
removeProvider(java.lang.String), addProvider(java.security.Provider)

getProviders

public static Provider[] getProviders(String filter)
返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。返回的提供者将根据其首选顺序进行排序。

加密服务始终与特定的算法或类型相关。例如，数字签名服务始终与特定算法（如 DSA）相关，CertificateFactory 服务始终与特定的证书类型（如 X.509）相关。

选择标准必须用以下两种格式之一指定：

  • <crypto_service>.<algorithm_or_type>

    加密服务名不能包含任何圆点。

    当且仅当提供者为指定的加密服务实现了指定的算法或类型时，该提供者才可以满足指定的选择标准。

    例如，任何为 X.509 证书提供 CertificateFactory 实现的提供者都可以满足 "CertificateFactory.X.509" 的要求。

  • <crypto_service>.<algorithm_or_type> <attribute_name>:< attribute_value>

    加密服务名不能包含任何圆点。在 <algorithm_or_type> 与 <attribute_name> 之间必须有一个或多个空格字符。

    当且仅当某个提供者为指定的加密服务实现了指定的算法或类型，并且其实现可以满足由指定的属性名称/值对表达的限制要求时，该提供者才可以满足此选择标准。

    例如，任何实施了 SHA1withDSA 签名算法、keysize 为 1024（或更大）的提供者都可以满足 "Signature.SHA1withDSA KeySize:1024" 的需要。

有关标准加密服务名称、标准算法名称和标准属性名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。

参数：
filter - 选择提供者的标准。过滤器是区分大小写的。
返回：
可满足选择标准的所有已安装的提供者，如果尚未安装此类提供者，则返回 null。
抛出：
InvalidParameterException - 如果过滤器不是需要的格式
NullPointerException - 如果过滤器为 null
从以下版本开始：
1.3
另请参见：
getProviders(java.util.Map)

getProviders

public static Provider[] getProviders(Map<String,String> filter)
返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。返回的提供者将根据其 preference order 进行排序。

选择标准将通过映射表示。每个映射项都表示一种选择标准。当且仅当某个提供者满足所有选择标准时才可选择它。此映射中任何项的密钥都必须使用以下两种格式之一：

  • <crypto_service>.<algorithm_or_type>

    加密服务名不能包含任何圆点。

    与密钥相关的值必须为空字符串。

    当且仅当某个提供者为指定的加密服务实现了指定的算法或类型时，该提供者才能满足此选择标准。

  • <crypto_service>.<algorithm_or_type> <attribute_name>

    加密服务名不能包含任何圆点。在 <algorithm_or_type> 与 <attribute_name> 之间必须有一个或多个空格字符。

    与密钥相关的值必须为非空字符串。当且仅当某个提供者为指定的加密服务实现了指定的算法或类型，并且其实现可以满足由指定的属性名称/值对表达的限制要求时，该提供者才可以满足此选择标准。

有关标准加密服务名称、标准算法名称和标准属性名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。

参数：
filter - 选择提供者的标准。过滤器是区分大小写的。
返回：
所有可满足选择标准的已安装的提供者，如果尚未安装此类提供者，则返回 null。
抛出：
InvalidParameterException - 如果过滤器不是需要的格式
NullPointerException - 如果过滤器为 null
从以下版本开始：
1.3
另请参见：
getProviders(java.lang.String)

getProperty

public static String getProperty(String key)
获取安全属性值。

首先，如果有安全管理器，将调用带有 java.security.SecurityPermission("getProperty."+key) 权限的 checkPermission 方法，以查看是否可以获取指定的安全属性值。

参数：
key - 要获取的属性的密钥。
返回：
与密钥对应的安全属性的值。
抛出：
SecurityException - 如果有安全管理器，并且其 SecurityManager.checkPermission(java.security.Permission) 方法拒绝对指定的安全属性值进行获取访问
NullPointerException - 如果密钥为 null
另请参见：
setProperty(java.lang.String, java.lang.String), SecurityPermission

setProperty

public static void setProperty(String key,
                               String datum)
设置安全属性值。

首先，如果有安全管理器，将调用其带有 java.security.SecurityPermission("setProperty."+key) 权限的 checkPermission 方法，以查看是否可以设置指定的安全属性值。

参数：
key - 要设置的属性的名称。
datum - 要设置的属性的值。
抛出：
SecurityException - 如果有安全管理器并且其 SecurityManager.checkPermission(java.security.Permission) 方法拒绝对指定的安全属性值进行设置访问
NullPointerException - 如果密钥或数据为 null
另请参见：
getProperty(java.lang.String), SecurityPermission

getAlgorithms

public static Set<String> getAlgorithms(String serviceName)
返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。如果没有支持指定服务的提供者，或者 serviceName 为 null，则返回一个空 Set。有关 Java 加密服务的完整列表，请参阅 Java Cryptography Architecture API Specification & Reference。注：返回的 set 是不可改变的。

参数：
serviceName - Java 加密服务的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。注：此参数是区分大小写的。
返回：
字符串的 Set，这些字符串包含用于指定的 Java 加密服务的所有可用算法或类型，如果没有支持指定服务的提供者，则返回一个空 set。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecurityPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 SecurityPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.security.SecurityPermission
所有已实现的接口：
Serializable, Guard
public final class SecurityPermission
extends BasicPermission

此类用于安全权限。SecurityPermission 包含一个名称（也称为“目标名称”），但没有操作列表；可以使用，也可以不使用指定权限。

目标名称就是安全配置参数的名称（见下表）。目前 SecurityPermission 对象可用来保护对 Policy、Security、Provider、Signer 和 Identity 对象的访问。

下表列出了所有可能的 SecurityPermission 目标名称，并提供了权限所允许的操作的简要说明，还讨论了授予代码该权限的风险。

权限目标名称 | 权限所允许的操作 | 允许此权限所带来的风险
createAccessControlContext | 创建 AccessControlContext | 这允许攻击者使用 DomainCombiner 实例化 AccessControlContext。由于为 DomainCombiner 提供了到当前堆栈上的 ProtectionDomains 的引用，所以如果 DomainCombiner 是恶意的，则这样可能会导致隐私泄漏。
getDomainCombiner | 获取 AccessControlContext 的 DomainCombiner | 这样将允许获取 AccessControlContext 的 DomainCombiner。由于 DomainCombiners 可以包含敏感信息，所以这可能会潜在地导致隐私泄漏。
getPolicy | 获取系统级安全策略（具体来说，就是获取当前安装的 Policy 对象） | 这将允许通过 getPermissions 调用来查询策略，这样将泄漏授予指定 CodeSource 的权限。虽然暴露策略并不足以危及系统安全，但它确实为恶意代码提供了更多信息，恶意代码可能会使用这些信息更好地锁定攻击目标。明智之举就是不泄漏不必要的信息。
setPolicy | 设置系统级安全策略（具体来说，就是设置 Policy 对象） | 授予此权限相当危险，因为恶意代码会授予自身成功攻击系统所需的所有必要权限。
createPolicy.{policy type} | 从提供者获取 Policy 实现的实例 | 授予此权限将允许代码获取 Policy 对象。恶意代码可以查询该 Policy 对象，以确定除其自身以外授予了代码哪些权限。
getProperty.{key} | 使用指定的密钥获取安全属性 | 根据已经授予其访问权的特定密钥，代码可以访问安全提供者列表，以及系统级位置和用户安全策略。虽然泄漏此信息并不足以危及系统安全性，但它确实为恶意代码提供了更多信息，恶意代码可能会使用这些信息更好地锁定攻击目标。
setProperty.{key} | 使用指定的密钥设置安全属性 | 这包括设置安全提供者或定义系统级安全策略的位置。有权设置新的安全提供者的恶意代码会设置一个恶意提供者，以盗取诸如加密的私钥之类的保密信息。此外，有权设置系统级安全策略的恶意代码还会将此恶意提供者指向安全策略，授予攻击者成功攻击系统所需的全部必要权限。
insertProvider.{provider name} | 使用指定的名称添加一个新的提供者 | 这会使用户把可能的恶意提供者（例如，泄漏传递给它的私钥的提供者）当作最高优先级的提供者引入。之所以出现这种情况，是因为 Security 对象（它管理已安装的提供者）目前在接触该提供者之前不检查其完整性和真实性。
removeProvider.{provider name} | 移除指定的提供者 | 这可能会更改程序的行为或禁止执行程序的其他部分。如果程序以后请求提供者时该提供者已被移除，则可能导致执行失败。另外，如果程序的其他部分未明确请求已移除的提供者，但是当请求加密服务时通常会选择这一提供者（原因在于其在提供者列表中的位置靠前），这时将另外选择提供者，或者找不到合适的提供者，因而会导致程序失败。
setSystemScope | 设置系统标识范围 | 这会允许攻击者使用不受信任的证书来配置系统标识范围，并因此授权使用这些证书签名的 applet 或应用程序代码享有被系统的原始标识范围所拒绝的特权
setIdentityPublicKey | 设置标识的公钥 | 如果标识被标记为 "trusted"（受信任），这将允许攻击者引入其他不受系统标识范围信任的公钥（例如，它自己的公钥），因此，将授权使用该公钥签名的 applet 或应用程序代码享有在其他情况下将遭受拒绝的特权。
setIdentityInfo | 设置标识的常规信息字符串 | 这将允许攻击者设置对标识的常规信息描述。这会欺骗应用程序使用其他标识而不是本打算使用的标识，或者会阻止应用程序查找特定的标识。
addIdentityCertificate | 添加标识证书 | 这允许攻击者为标识的公钥设置证书。这样将非常危险，因为这会影响整个系统的信任关系。与先前相比，此公钥的受信任范围突然变大。
removeIdentityCertificate | 移除标识证书 | 这允许攻击者移除标识的公钥证书。这样将非常危险，因为这会影响整个系统的信任关系。与先前相比，此公钥的受信任范围突然变得不如以前。
printIdentity | 查看主体名称和可选的使用范围，以及在该范围内是否认为它是“受信任”的 | 输出范围可以是文件名称，在这种情况下它可以传达本机系统信息。例如，此处是一个输出名为 "carol" 标识的示例，在用户的标识数据库中，它被标记为不受信任： carol[/home/luehe/identitydb.obj][not trusted]
clearProviderProperties.{provider name} | “清除”一个提供者，以使其不再包含用来搜索由提供者实现的服务的属性 | 这将禁用由该提供者实现的服务搜索。因此，正如 "removeProvider.{provider name}" 权限中所描述的那样，这可能会更改正常利用该提供者的程序的行为或禁止程序的其他部分的执行。
putProviderProperty.{provider name} | 设置指定提供者的属性 | 每种提供者属性都要指定由该提供者实现的特定服务的名称和位置。通过授予此权限，可以让代码将服务规范替换为另外一种，并据此指定另外一种实现。
removeProviderProperty.{provider name} | 从指定的提供者移除属性 | 这将禁用由该提供者实现的服务搜索。由于移除了指定提供者名称和位置的属性，所以无法再访问这些提供者。正如 "removeProvider.{provider name}" 权限中所描述的那样，这可能会更改正常利用该提供者的程序行为或禁止程序其他部分的执行。
getSignerPrivateKey | 获取 Signer 的私钥 | 允许访问私钥是非常危险的；一般认为密钥是用来保守秘密的。否则，代码会使用私钥签署各种文件并声称签名来自 Signer。
setSignerKeyPair | 设置 Signer 的密钥对（公钥和私钥） | 这将允许攻击者把其他人的（“目标的”）密钥对替换为可能更弱的密钥对（例如，更小密钥大小的密钥对）。这还会允许攻击者侦听目标与其同位体之间加密的通信。目标的同位体可以用目标的“新”公钥包装加密的会话密钥，这将允许攻击者（拥有对应私钥）打开该会话密钥并解密使用该会话密钥加密的通信数据。

另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
SecurityPermission(String name)
创建具有指定名称的新 SecurityPermission。
SecurityPermission(String name, String actions)
创建具有指定名称的新 SecurityPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

SecurityPermission

public SecurityPermission(String name)
创建具有指定名称的新 SecurityPermission。此名称是 SecurityPermission 的符号名称。名称的末尾可能有一个星号，星号前有一个 "."（也可能没有），用来表示通配符。

参数：
name - SecurityPermission 的名称
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

SecurityPermission

public SecurityPermission(String name,
                          String actions)
创建具有指定名称的新 SecurityPermission 对象。此名称是 SecurityPermission 的符号名，且目前不使用操作 String，其应该为 null。

参数：
name - SecurityPermission 的名称
actions - 其应该为 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Signature (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Signature

java.lang.Object
    继承者  java.security.SignatureSpi
        继承者  java.security.Signature

public abstract class Signature
extends SignatureSpi

此 Signature 类用来为应用程序提供数字签名算法功能。数字签名用于确保数字数据的验证和完整性。

在所有算法当中，数字签名可以是 NIST 标准的 DSA，它使用 DSA 和 SHA-1。可以将使用 SHA-1 消息摘要算法的 DSA 算法指定为 SHA1withDSA。如果使用 RSA，对消息摘要算法则会有多种选择，因此，可以将签名算法指定为 MD2withRSA、MD5withRSA 或 SHA1withRSA。因为没有默认的算法名称，所以必须为其指定名称。

Signature 对象可用来生成和验证数字签名。

使用 Signature 对象签名数据或验证签名包括以下三个阶段：

  1. 初始化，使用
    • 初始化验证签名的公钥（请参见 initVerify），或使用
    • 初始化签署签名的私钥（也可以选择“安全随机数生成器”），（请参见 initSign(PrivateKey) 和 initSign(PrivateKey, SecureRandom)）。

  2. 更新

    根据初始化类型，这可更新要签名或验证的字节。请参见 update 方法。

  3. 签署或验证所有更新字节的签名。请参见 sign 方法和 verify 方法。

注意，由于历史原因，此类是从 SignatureSpi 中抽象出来的，并进行了扩展。应用程序开发人员只需注意在此 Signature 类中定义的方法即可；超类中的所有方法都是供那些希望提供自己的数字签名算法实现的加密服务提供者使用的。

字段摘要
protected static int | SIGN 可能的 state 值，表示此签名对象已经初始化签名。
protected int | state 此签名对象的当前状态。
protected static int | UNINITIALIZED 可能的 state 值，表示尚未初始化此签名对象。
protected static int | VERIFY 可能的 state 值，表示此签名对象已经初始化验证。
从类 java.security.SignatureSpi 继承的字段
appRandom
构造方法摘要
protected Signature(String algorithm)
创建指定算法的 Signature 对象。
方法摘要
Object | clone() 如果此实现可以复制，则返回副本。
String | getAlgorithm() 返回此签名对象的算法名称。
static Signature | getInstance(String algorithm) 返回实现指定签名算法的 Signature 对象。
static Signature | getInstance(String algorithm, Provider provider) 返回实现指定签名算法的 Signature 对象。
static Signature | getInstance(String algorithm, String provider) 返回实现指定签名算法的 Signature 对象。
Object | getParameter(String param) 已过时。
AlgorithmParameters | getParameters() 返回与此签名对象一起使用的参数。
Provider | getProvider() 返回此签名对象的提供者。
void | initSign(PrivateKey privateKey) 初始化这个用于签名的对象。
void | initSign(PrivateKey privateKey, SecureRandom random) 初始化这个用于签名的对象。
void | initVerify(Certificate certificate) 使用来自给定证书的公钥初始化此用于验证的对象。
void | initVerify(PublicKey publicKey) 初始化此用于验证的对象。
void | setParameter(AlgorithmParameterSpec params) 使用指定的参数集初始化此签名引擎。
void | setParameter(String param, Object value) 已过时。 使用 setParameter 取代。
byte[] | sign() 返回所有已更新数据的签名字节。
int | sign(byte[] outbuf, int offset, int len) 完成签名操作并从 offset 开始，将得到的签名字节存储在提供的缓冲区 outbuf 中。
String | toString() 返回此签名对象的字符串表示形式，以提供包括对象状态和所用算法名称在内的信息。
void | update(byte b) 更新要由字节签名或验证的数据。
void | update(byte[] data) 使用指定的 byte 数组更新要签名或验证的数据。
void | update(byte[] data, int off, int len) 从指定的偏移量开始，使用指定的 byte 数组更新要签名或验证的数据。
void | update(ByteBuffer data) 使用指定的 ByteBuffer 更新要签名或验证的数据。
boolean | verify(byte[] signature) 验证传入的签名。
boolean | verify(byte[] signature, int offset, int length) 从指定的偏移量开始，验证指定的 byte 数组中传入的签名。
从类 java.security.SignatureSpi 继承的方法
engineGetParameter, engineGetParameters, engineInitSign, engineInitSign, engineInitVerify, engineSetParameter, engineSetParameter, engineSign, engineSign, engineUpdate, engineUpdate, engineUpdate, engineVerify, engineVerify
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

UNINITIALIZED

protected static final int UNINITIALIZED
可能的 state 值，表示尚未初始化此签名对象。

另请参见：
常量字段值

SIGN

protected static final int SIGN
可能的 state 值，表示此签名对象已经初始化签名。

另请参见：
常量字段值

VERIFY

protected static final int VERIFY
可能的 state 值，表示此签名对象已经初始化验证。

另请参见：
常量字段值

state

protected int state
此签名对象的当前状态。

构造方法详细信息

Signature

protected Signature(String algorithm)
创建指定算法的 Signature 对象。

参数：
algorithm - 算法的标准字符串名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
方法详细信息

getInstance

public static Signature getInstance(String algorithm)
                             throws NoSuchAlgorithmException
返回实现指定签名算法的 Signature 对象。

此方法从首选的提供者开始遍历已注册安全提供者列表。返回封装 SignatureSpi 实现的新 Signature 对象，该实现取自第一个支持指定算法的 Provider。

注意，可以通 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
新 Signature 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 Signature 实现。
另请参见：
Provider

getInstance

public static Signature getInstance(String algorithm,
                                    String provider)
                             throws NoSuchAlgorithmException,
                                    NoSuchProviderException
返回实现指定签名算法的 Signature 对象。

返回封装 SignatureSpi 实现的新 Signature 对象，该实现取自指定提供者。指定的提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者的名称。
返回：
新 Signature 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 SignatureSpi 实现不能从指定提供者获得。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static Signature getInstance(String algorithm,
                                    Provider provider)
                             throws NoSuchAlgorithmException
返回实现指定签名算法的 Signature 对象。

返回封装 SignatureSpi 实现的新 Signature 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者。
返回：
新 Signature 对象。
抛出：
NoSuchAlgorithmException - 如果指定算法的 SignatureSpi 实现不能从指定提供者对象获得。
IllegalArgumentException - 如果 provider 为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此签名对象的提供者。

返回：
此签名对象的提供者

initVerify

public final void initVerify(PublicKey publicKey)
                      throws InvalidKeyException
初始化此用于验证的对象。如果使用其他参数再次调用此方法，此调用的结果将无效。

参数：
publicKey - 将验证其签名的标识的公钥。
抛出：
InvalidKeyException - 如果密钥无效。

initVerify

public final void initVerify(Certificate certificate)
                      throws InvalidKeyException
使用来自给定证书的公钥初始化此用于验证的对象。

如果证书是 X.509 类型且具有标记为重要的 key usage 扩展字段，并且 key usage 扩展字段的值暗示着证书中的公钥及其对应的私钥不允许用于数字签名，则抛出 InvalidKeyException。

参数：
certificate - 将验证其签名的标识的证书。
抛出：
InvalidKeyException - 如果证书中的公钥未被正确解码，或者未包括所请求的参数信息，或者不能用于数字签名。
从以下版本开始：
1.3

initSign

public final void initSign(PrivateKey privateKey)
                    throws InvalidKeyException
初始化这个用于签名的对象。如果使用其他参数再次调用此方法，此调用的结果将无效。

参数：
privateKey - 将生成其签名的标识的私钥。
抛出：
InvalidKeyException - 如果密钥无效。

initSign

public final void initSign(PrivateKey privateKey,
                           SecureRandom random)
                    throws InvalidKeyException
初始化这个用于签名的对象。如果使用其他参数再次调用此方法，此调用的结果将无效。

参数：
privateKey - 将生成其签名的标识的私钥。
random - 此签名的随机源。
抛出：
InvalidKeyException - 如果密钥无效。

sign

public final byte[] sign()
                  throws SignatureException
返回所有已更新数据的签名字节。签名的格式取决于基础签名方案。

对此方法的调用将把此签名对象重新设置到以前为进行签名而通过调用 initSign(PrivateKey) 对其初始化时的状态。也就是说，如果需要，通过重新调用 update 和 sign，可重新设置对象，并且可以通过它从同一个签署者中生成其他人的签名。

返回：
签名操作结果的签名字节。
抛出：
SignatureException - 如果此签名对象未得到正确初始化，或者此签名算法不能处理所提供的输入数据。

sign

public final int sign(byte[] outbuf,
                      int offset,
                      int len)
               throws SignatureException
完成签名操作并从 offset 开始，将得到的签名字节存储在提供的缓冲区 outbuf 中。签名的格式取决于基础签名方案。

此签名对象将被重新设置到其初始状态（对其中的一种 initSign 方法调用之后所处的状态），并且可重新使用此签名对象，用同一个私钥生成将来的签名。

参数：
outbuf - 输出签名结果的缓冲区。
offset - 到存储签名的 outbuf 的偏移量。
len - outbuf 中分配给签名的字节数。
返回：
放入 outbuf 中的字节数。
抛出：
SignatureException - 如果此签名对象未得到正确初始化，如果此签名算法无法处理所提供的输入数据，或者 len 少于实际签名长度。
从以下版本开始：
1.2

verify

public final boolean verify(byte[] signature)
                     throws SignatureException
验证传入的签名。

对此方法的调用将把此签名对象重新设置到以前为进行验证而通过调用 initVerify(PublicKey) 对其初始化时的状态。也就是说，该对象将被重新设置，并且可以用来验证调用 initVerify 时其公钥所指定的标识中的其他签名。

参数：
signature - 要验证的签名字节。
返回：
如果签名得到验证，则返回 true，否则将返回 false。
抛出：
SignatureException - 如果此签名对象未得到正确初始化，传入的签名未得到正确解码，或类型错误，如果此签名算法不能处理所提供的输入数据等。

verify

public final boolean verify(byte[] signature,
                            int offset,
                            int length)
                     throws SignatureException
从指定的偏移量开始，验证指定的 byte 数组中传入的签名。

对此方法的调用将把此签名对象重新设置到以前为进行验证而通过调用 initVerify(PublicKey) 对其初始化时的状态。也就是说，该对象将被重新设置，并且可以用来验证调用 initVerify 时其公钥所指定的标识中的其他签名。

参数：
signature - 要验证的签名字节。
offset - byte 数组中起始处的偏移量。
length - 要使用的字节数（从偏移量起始处算起）。
返回：
如果签名得到验证，则返回 true，否则将返回 false。
抛出：
SignatureException - 如果此签名对象未得到正确初始化，传入的签名未得到正确解码，或者类型错误，如果此签名算法无法处理所提供的输入数据等。
IllegalArgumentException - 如果 signature byte 数组为 null，或者 offset 或 length 小于 0，或者 offset 与 length 的和大于 signature byte 数组的长度。
从以下版本开始：
1.4

update

public final void update(byte b)
                  throws SignatureException
更新要由字节签名或验证的数据。

参数：
b - 用于更新的字节。
抛出：
SignatureException - 如果此签名对象未得到正确初始化。

update

public final void update(byte[] data)
                  throws SignatureException
使用指定的 byte 数组更新要签名或验证的数据。

参数：
data - 用于更新的 byte 数组。
抛出：
SignatureException - 如果此签名对象未得到正确初始化。

update

public final void update(byte[] data,
                         int off,
                         int len)
                  throws SignatureException
从指定的偏移量开始，使用指定的 byte 数组更新要签名或验证的数据。

参数：
data - byte 数组。
off - 到 byte 数组开始处的偏移量。
len - 要使用的字节数，从偏移量起始处算起。
抛出：
SignatureException - 如果此签名对象未得到正确初始化。

update

public final void update(ByteBuffer data)
                  throws SignatureException
使用指定的 ByteBuffer 更新要签名或验证的数据。处理从 data.position() 处开始的 data.remaining() 字节。返回时，缓冲区的位置将等于其限制；其限制并未改变。

参数：
data - ByteBuffer
抛出：
SignatureException - 如果此签名对象未得到正确初始化。
从以下版本开始：
1.5

getAlgorithm

public final String getAlgorithm()
返回此签名对象的算法名称。

返回：
此签名对象的算法名称。

toString

public String toString()
返回此签名对象的字符串表示形式，以提供包括对象状态和所用算法名称在内的信息。

覆盖：
类 Object 中的 toString
返回：
此签名对象的字符串表示形式。

setParameter

@Deprecated
public final void setParameter(String param,
                                          Object value)
                        throws InvalidParameterException
已过时。 使用 setParameter 取代。

将指定的算法参数设置为指定的值。此方法提供了一种通用机制，通过它可以设置此对象的各种参数。参数可以是算法的任何可设置参数，如参数大小、签名生成的随机源位（如果适当），或者表示是否执行具体但可选的计算。每个参数都需要统一的、特定于算法的命名方案，但此时尚未指定这种方案。

参数：
param - 参数的字符串标示符。
value - 参数值。
抛出：
InvalidParameterException - 如果 param 是此算法引擎的无效参数，或者已经设置参数并且不能重新设置，或者出现了安全异常等等。
另请参见：
getParameter(java.lang.String)

setParameter

public final void setParameter(AlgorithmParameterSpec params)
                        throws InvalidAlgorithmParameterException
使用指定的参数集初始化此签名引擎。

参数：
params - 参数
抛出：
InvalidAlgorithmParameterException - 如果给定的参数不适合此签名引擎
另请参见：
getParameters()

getParameters

public final AlgorithmParameters getParameters()
返回与此签名对象一起使用的参数。

返回的参数可能与用来初始化此签名的参数相同；如果此签名需要算法参数但却未使用任何参数进行初始化，则返回的参数可能会包含由底层签名实现所使用的默认值和随机生成的参数值的组合。

返回：
用于此签名的参数，如果此签名不使用任何参数，则返回 null。
从以下版本开始：
1.4
另请参见：
setParameter(AlgorithmParameterSpec)

getParameter

@Deprecated
public final Object getParameter(String param)
                          throws InvalidParameterException
已过时。

获取指定的算法参数的值。此方法提供了一种通用机制，通过它能够获取此对象的各种参数。参数可以是算法的任何可设置参数，如参数大小、签名生成的随机源位（如果适当），或者表示是否执行具体但可选的计算。每个参数都需要统一的、特定于算法的命名方案，但此时尚未指定这种方案。

参数：
param - 参数的字符串名称。
返回：
表示参数值的对象，如果没有，则返回 null。
抛出：
InvalidParameterException - 如果 param 是此引擎的无效参数，或者尝试获取此参数时出现其他异常。
另请参见：
setParameter(String, Object)

clone

public Object clone()
             throws CloneNotSupportedException
如果此实现可以复制，则返回副本。

覆盖：
类 SignatureSpi 中的 clone
返回：
如果此实现可以复制，则返回一个副本。
抛出：
CloneNotSupportedException - 如果调用一个不支持 Cloneable 的实现。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignatureException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 SignatureException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.SignatureException
所有已实现的接口：
Serializable
public class SignatureException
extends GeneralSecurityException

这是一般的签名异常。

另请参见：
序列化表格

构造方法摘要
SignatureException()
构造不带详细消息的 SignatureException。
SignatureException(String msg)
构造带指定详细消息的 SignatureException。
SignatureException(String message, Throwable cause)
创建带指定详细消息和原因的 SignatureException。
SignatureException(Throwable cause)
创建带指定的原因和详细消息的 SignatureException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SignatureException

public SignatureException()
构造不带详细消息的 SignatureException。详细消息是描述此特定异常的字符串。

SignatureException

public SignatureException(String msg)
构造带指定详细消息的 SignatureException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

SignatureException

public SignatureException(String message,
                          Throwable cause)
创建带指定详细消息和原因的 SignatureException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指示原因是不存在的或是未知的。）
从以下版本开始：
1.5

SignatureException

public SignatureException(Throwable cause)
创建带指定的原因和详细消息的 SignatureException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignatureSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 SignatureSpi

java.lang.Object
    继承者  java.security.SignatureSpi
直接已知子类：
Signature
public abstract class SignatureSpi
extends Object

此类为 Signature 类定义了服务提供者接口 (SPI)，可用来提供数字签名算法功能。数字签名用来保证数字数据的真实性和完整性。

此类中的所有抽象方法都必须由每个想要提供实现特定签名算法的加密服务提供者实现。

另请参见：
Signature

字段摘要
protected  SecureRandom appRandom
应用程序指定的随机源。
构造方法摘要
SignatureSpi()
方法摘要
Object | clone() 如果此实现可以复制，则返回一个副本。
protected abstract Object | engineGetParameter(String param) 已过时。
protected AlgorithmParameters | engineGetParameters() 此方法将由提供者重写，以返回与此签名引擎配合使用的参数，如果此签名引擎未使用任何参数，则返回 null。
protected abstract void | engineInitSign(PrivateKey privateKey) 通过用于签名操作的指定私钥初始化此签名对象。
protected void | engineInitSign(PrivateKey privateKey, SecureRandom random) 通过用于签名操作的指定私钥和随机源初始化此签名对象。
protected abstract void | engineInitVerify(PublicKey publicKey) 通过用于验证操作的指定公钥初始化此签名对象。
protected void | engineSetParameter(AlgorithmParameterSpec params) 此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。
protected abstract void | engineSetParameter(String param, Object value) 已过时。 由 engineSetParameter 取代。
protected abstract byte[] | engineSign() 返回迄今为止所有更新的数据的签名字节。
protected int | engineSign(byte[] outbuf, int offset, int len) 完成此签名操作，并从 offset 开始将得到的签名字节保存在提供的缓冲区 outbuf 中。
protected abstract void | engineUpdate(byte b) 使用指定的字节更新要签名或验证的数据。
protected abstract void | engineUpdate(byte[] b, int off, int len) 使用指定的 byte 数组，从指定的偏移量开始更新要签名或验证的数据。
protected void | engineUpdate(ByteBuffer input) 使用指定的 ByteBuffer 更新要签名或验证的数据。
protected abstract boolean | engineVerify(byte[] sigBytes) 验证传入的签名。
protected boolean | engineVerify(byte[] sigBytes, int offset, int length) 在指定的 byte 数组中，从指定的偏移量处开始，验证传入的签名。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

appRandom

protected SecureRandom appRandom
应用程序指定的随机源。

构造方法详细信息

SignatureSpi

public SignatureSpi()
方法详细信息

engineInitVerify

protected abstract void engineInitVerify(PublicKey publicKey)
                                  throws InvalidKeyException
通过用于验证操作的指定公钥初始化此签名对象。

参数：
publicKey - 其签名将被验证的标识的公钥。
抛出：
InvalidKeyException - 如果密钥未得到正确编码、参数丢失等等。

engineInitSign

protected abstract void engineInitSign(PrivateKey privateKey)
                                throws InvalidKeyException
通过用于签名操作的指定私钥初始化此签名对象。

参数：
privateKey - 将生成其签名的标识的私钥。
抛出：
InvalidKeyException - 如果密钥未得到正确编码、参数丢失等等。

engineInitSign

protected void engineInitSign(PrivateKey privateKey,
                              SecureRandom random)
                       throws InvalidKeyException
通过用于签名操作的指定私钥和随机源初始化此签名对象。

已将此具体方法添加到了先前定义过的抽象类中。（为向后兼容，它不能为抽象方法）。

参数：
privateKey - 将生成其签名的标识的私钥。
random - 随机源
抛出：
InvalidKeyException - 如果密钥未得到正确编码、参数丢失等等。

engineUpdate

protected abstract void engineUpdate(byte b)
                              throws SignatureException
使用指定的字节更新要签名或验证的数据。

参数：
b - 用于更新的字节。
抛出：
SignatureException - 如果引擎未得到正确初始化。

engineUpdate

protected abstract void engineUpdate(byte[] b,
                                     int off,
                                     int len)
                              throws SignatureException
使用指定的 byte 数组，从指定的偏移量开始更新要签名或验证的数据。

参数：
b - byte 数组
off - byte 数组开始处的偏移量
len - 要使用的字节数（从偏移量开始处计算）
抛出：
SignatureException - 如果引擎未得到正确初始化

engineUpdate

protected void engineUpdate(ByteBuffer input)
使用指定的 ByteBuffer 更新要签名或验证的数据。处理从 data.position() 处开始的 data.remaining() 字节。返回时，缓冲区的位置将等于其限制；其限制并未改变。

参数：
input - the ByteBuffer
从以下版本开始：
1.5

engineSign

protected abstract byte[] engineSign()
                              throws SignatureException
返回迄今为止所有更新的数据的签名字节。签名的格式取决于底层签名方案。

返回：
签名操作结果的签名字节。
抛出：
SignatureException - 如果引擎未得到正确初始化，或者此签名算法无法处理所提供的输入数据。

engineSign

protected int engineSign(byte[] outbuf,
                         int offset,
                         int len)
                  throws SignatureException
完成此签名操作，并从 offset 开始将得到的签名字节保存在提供的缓冲区 outbuf 中。签名的格式取决于基本签名方案。

此签名实现将被重新设置到其初始状态（对其中的一种 engineInitSign 方法调用之后所处的状态），并且可以重新使用该签名实现，用同一个私钥生成将来的签名。 此方法应是一个抽象方法，但出于二进制兼容性考虑，允许它保留具体方法。因此提供者应重写此方法。

参数：
outbuf - 输出签名结果的缓冲区。
offset - 到存储签名的 outbuf 的偏移量。
len - outbuf 中分配给签名的字节数。此默认实现和 SUN 提供者匀不返回部分摘要。如果此参数的值小于实际签名长度，此方法将抛出一个 SignatureException。如果其值大于或等于实际签名长度，则将忽略此参数。
返回：
放入 outbuf 中的字节数
抛出：
SignatureException - 如果引擎未得到正确初始化，或者此签名算法无法处理所提供的输入数据，或者 len 小于实际签名长度。
从以下版本开始：
1.2

engineVerify

protected abstract boolean engineVerify(byte[] sigBytes)
                                 throws SignatureException
验证传入的签名。

参数：
sigBytes - 要验证的签名字节。
返回：
如果签名得到验证，则返回 true，否则将返回 false。
抛出：
SignatureException - 如果引擎未得到正确初始化，或传入的签名未被正确编码或类型错误，或者此签名算法无法处理所提供的输入数据等等。

engineVerify

protected boolean engineVerify(byte[] sigBytes,
                               int offset,
                               int length)
                        throws SignatureException
在指定的 byte 数组中，从指定的偏移量处开始，验证传入的签名。

注：子类应改写此默认实现。

参数：
sigBytes - 要验证的签名字节。
offset - byte 数组中起始处的偏移量。
length - 要使用的字节数（从偏移量起始处计算）。
返回：
如果签名得到验证，则返回 true，否则将返回 false。
抛出：
SignatureException - 如果引擎未得到正确初始化，或传入的签名未被正确编码或类型错误，或者此签名算法无法处理所提供的输入数据等等。
从以下版本开始：
1.4

engineSetParameter

@Deprecated
protected abstract void engineSetParameter(String param,
                                                      Object value)
                                    throws InvalidParameterException
已过时。 由 engineSetParameter 取代。

将指定的算法参数设置为指定的值。此方法提供了一种通用机制，通过它可以设置此对象的各种参数。参数可以是算法的任何可设置参数，如参数大小、签名生成的随机源位（如果适当），或者表示是否执行具体但可选的计算。每个参数都需要统一的、特定于算法的命名方案，但此时尚未指定这种方案。

参数：
param - 参数的字符串标示符。
value - 参数值。
抛出：
InvalidParameterException - 如果 param 是此算法引擎的无效参数，或者已经设置参数并且不能重新设置，或者发生了安全异常等等。

engineSetParameter

protected void engineSetParameter(AlgorithmParameterSpec params)
                           throws InvalidAlgorithmParameterException

此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。

参数：
params - 参数
抛出：
UnsupportedOperationException - 如果提供者未重写此方法
InvalidAlgorithmParameterException - 如果提供者未重写此方法并且指定的参数不适合此签名引擎

engineGetParameters

protected AlgorithmParameters engineGetParameters()

此方法将由提供者重写，以返回与此签名引擎配合使用的参数，如果此签名引擎未使用任何参数，则返回 null。

返回的参数可能与用来初始化此签名引擎的参数相同；如果此签名引擎需要算法参数但却未使用任何参数进行初始化，则返回的参数可能会包含由底层签名实现使用的默认和随机生成的参数值的组合。

返回：
与此签名引擎一块使用的参数，如果此签名引擎未使用任何参数，则返回 null
抛出：
UnsupportedOperationException - 如果提供者未重写此方法
从以下版本开始：
1.4

engineGetParameter

@Deprecated
protected abstract Object engineGetParameter(String param)
                                      throws InvalidParameterException
已过时。

获取指定算法参数的值。此方法提供了一种通用机制，通过它能够获取此对象的各种参数。参数可以是算法的任何可设置参数，如参数大小、签名生成的随机源位（如果适当），或者表示是否执行具体但可选的计算。每个参数都需要统一的、特定于算法的命名方案，但此时尚未指定这种方案。

参数：
param - 参数的字符串名称。
返回：
表示参数值的对象，如果没有，则返回 null。
抛出：
InvalidParameterException - 如果 param 是此引擎的无效参数，或者尝试获取此参数时发生了其他异常。

clone

public Object clone()
             throws CloneNotSupportedException
如果此实现可以复制，则返回一个副本。

覆盖：
类 Object 中的 clone
返回：
如果此实现可以复制，则返回一个副本。
抛出：
CloneNotSupportedException - 如果调用一个不支持 Cloneable 的实现。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SignedObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 SignedObject

java.lang.Object
    继承者  java.security.SignedObject
所有已实现的接口：
Serializable
public final class SignedObject
extends Object
implements Serializable

SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。

更明确地说，SignedObject 包含另外一个 Serializable 对象，即（要）签名的对象及其签名。

签名对象是对原始对象的“深层复制”（以序列化形式）。一旦生成了副本，对原始对象的进一步操作就不再影响该副本。

底层签名算法是由传递给构造方法和 verify 方法的 Signature 对象指定。下面是签名的典型用法：

 Signature signingEngine = Signature.getInstance(algorithm,
                                                 provider);
 SignedObject so = new SignedObject(myobject, signingKey,
                                    signingEngine);

下面是对验证的典型用法（已接收到 SignedObject so）：

 Signature verificationEngine =
     Signature.getInstance(algorithm, provider);
 if (so.verify(publickey, verificationEngine))
     try {
         Object myobj = so.getObject();
     } catch (java.lang.ClassNotFoundException e) {};

以下几点需要注意。首先，不需要初始化签名或验证引擎，因为它将在构造方法和 verify 方法中被重新初始化。其次，为了成功验证，指定的公钥必须是与用来生成 SignedObject 的私钥对应的公钥。

更为重要的是，出于灵活性考虑，构造方法和 verify 方法允许使用自定义的签名引擎，这样可以实现未作为加密提供者一部分正常安装的签名算法。不过，编程人员编写知道使用什么 Signature 引擎的校验器代码至关重要，因为将调用它自己的 verify 方法的实现来验证签名。换句话说，恶意 Signature 在尝试绕过安全检查的验证中会选择始终返回 true。

在所有算法中，签名算法可以是使用 DSA 和 SHA-1 的 NIST 标准 DSA。该算法使用与签名惯例相同的惯例来指定。例如，可以将使用 SHA-1 消息分类算法的 DSA 算法指定为 "SHA/DSA" 或 "SHA-1/DSA"（它们是等效的）。如果使用 RSA 标准，消息分类算法将有多种选择，例如，可将签名算法指定为 "MD2/RSA"、"MD5/RSA" 或 "SHA-1/RSA"。没有默认的算法名称，所以必须为其指定名称。

Cryptography Package Provider 的名称也是由构造方法和 verify 方法的 Signature 参数指定的。如果未指定提供者，则使用默认的提供者。每种安装都可以配置为将特定的提供者作为默认提供者。

SignedObject 可能的应用领域包括：

  • 可将它内部用作任何 Java 运行时的不可遗忘的授权标记 -- 这种标记可以到处传递而不必担心其被恶意修改而又检测不到。
  • 可使用它来为 Java 运行时之外（例如，磁盘上存储的关键访问控制数据）的存储签名和序列化数据/对象。
  • 嵌套的 SignedObject 可用来构造签名的逻辑序列，以模拟一系列授权和委托。

另请参见：
Signature, 序列化表格

构造方法摘要
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。
方法摘要
String | getAlgorithm() 获取签名算法的名称。
Object | getObject() 获取已封装的对象。
byte[] | getSignature() 在已签名对象上按 byte 数组的形式获取签名。
boolean | verify(PublicKey verificationKey, Signature verificationEngine) 使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SignedObject

public SignedObject(Serializable object,
                    PrivateKey signingKey,
                    Signature signingEngine)
             throws IOException,
                    InvalidKeyException,
                    SignatureException
通过任何可序列化对象构造 SignedObject。使用指派的签名引擎，通过给定的签名密钥将给定的对象签名。

参数：
object - 要签名的对象。
signingKey - 用于签名的私钥。
signingEngine - 用于签名的签名引擎。
抛出：
IOException - 如果在序列化期间发生错误
InvalidKeyException - 如果密钥无效。
SignatureException - 如果签名失败。
方法详细信息

getObject

public Object getObject()
                 throws IOException,
                        ClassNotFoundException
获取已封装的对象。在返回已封装的对象之前要先对它反序列化。

返回：
已封装的对象。
抛出：
IOException - 如果在反序列化期间发生错误
ClassNotFoundException - 如果在反序列化期间发生错误

getSignature

public byte[] getSignature()
在已签名对象上按 byte 数组的形式获取签名。

返回：
签名。每次调用此方法时都返回一个新的数组。

getAlgorithm

public String getAlgorithm()
获取签名算法的名称。

返回：
签名算法名称。

verify

public boolean verify(PublicKey verificationKey,
                      Signature verificationEngine)
               throws InvalidKeyException,
                      SignatureException
使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

参数：
verificationKey - 用于验证的公钥。
verificationEngine - 签名验证引擎。
返回：
如果签名有效，则返回 true，否则返回 false
抛出：
SignatureException - 如果签名验证失败。
InvalidKeyException - 如果验证密钥无效。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Signer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Signer

java.lang.Object
    继承者  java.security.Identity
        继承者  java.security.Signer
所有已实现的接口：
Serializable, Principal
已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

@Deprecated
public abstract class Signer
extends Identity

此类用来表示一个 Identity，它还可以用数字方法签名数据。

管理签署人 (signer) 的私钥是一个非常重要而又敏感的问题，应该由子类根据他们的使用目的适当处理。

另请参见：
Identity, 序列化表格

构造方法摘要
protected | Signer() 已过时。 创建 signer。
 | Signer(String name) 已过时。 创建带有指定标识名称的 signer。
 | Signer(String name, IdentityScope scope) 已过时。 创建带有指定标识名称和范围的 signer。
方法摘要
PrivateKey | getPrivateKey() 已过时。 返回此 signer 的私钥。
void | setKeyPair(KeyPair pair) 已过时。 为此签署人设置密钥对（公钥和私钥）。
String | toString() 已过时。 返回有关该 signer 信息的字符串。
从类 java.security.Identity 继承的方法
addCertificate, certificates, equals, getInfo, getName, getPublicKey, getScope, hashCode, identityEquals, removeCertificate, setInfo, setPublicKey, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Signer

protected Signer()
已过时。
创建 signer。此构造方法只用于序列化。

Signer

public Signer(String name)
已过时。
创建带有指定标识名称的 signer。

参数：
name - 标识名称。

Signer

public Signer(String name,
              IdentityScope scope)
       throws KeyManagementException
已过时。
创建带有指定标识名称和范围的 signer。

参数：
name - 标识名称。
scope - 标识的范围。
抛出：
KeyManagementException - 如果范围内已经有一个具有相同名称的标识。
方法详细信息

getPrivateKey

public PrivateKey getPrivateKey()
已过时。
返回此 signer 的私钥。

首先，如果有安全管理器，则用 "getSignerPrivateKey" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以返回该私钥。

返回：
此 signer 的私钥，如果尚未设置私钥，则返回 null。
抛出：
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许访问私钥。
另请参见：
SecurityManager.checkSecurityAccess(java.lang.String)

setKeyPair

public final void setKeyPair(KeyPair pair)
                      throws InvalidParameterException,
                             KeyException
已过时。
为此签署人设置密钥对（公钥和私钥）。

首先，如果有安全管理器，则用 "setSignerKeyPair" 作为参数调用其 checkSecurityAccess 方法，以查看它是否可以设置密钥对。

参数：
pair - 经过初始化的密钥对。
抛出：
InvalidParameterException - 如果未正确初始化密钥对。
KeyException - 如果密钥对因其他任何原因不能设置。
SecurityException - 如果安全管理器存在并且其 checkSecurityAccess 方法不允许设置密钥对。
另请参见：
SecurityManager.checkSecurityAccess(java.lang.String)

toString

public String toString()
已过时。
返回有关该 signer 信息的字符串。

指定者：
接口 Principal 中的 toString
覆盖：
类 Identity 中的 toString
返回：
有关该 signer 信息的字符串。
另请参见：
SecurityManager.checkSecurityAccess(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Timestamp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 Timestamp

java.lang.Object
    继承者  java.security.Timestamp
所有已实现的接口：
Serializable
public final class Timestamp
extends Object
implements Serializable

此类封装有关签署时间戳的信息。其不可更改。它包括时间戳的日期和时间，以及有关生成和签署时间戳的 Timestamping Authority (TSA) 的信息。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
Timestamp(Date timestamp, CertPath signerCertPath)
构造一个时间戳。
方法摘要
boolean | equals(Object obj) 比较指定的对象和此时间戳之间的相同性。
CertPath | getSignerCertPath() 返回 Timestamping Authority 的证书路径。
Date | getTimestamp() 返回生成时间戳时的日期和时间。
int | hashCode() 返回此时间戳的哈希码值。
String | toString() 返回描述此时间戳的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Timestamp

public Timestamp(Date timestamp,
                 CertPath signerCertPath)
构造一个时间戳。

参数：
timestamp - 其为时间戳的日期和时间。它不能为 null。
signerCertPath - 其为 TSA 的证书路径。它不能为 null。
抛出：
NullPointerException - 如果时间戳或 signerCertPath 为 null。
方法详细信息

getTimestamp

public Date getTimestamp()
返回生成时间戳时的日期和时间。

返回：
时间戳的日期和时间。

getSignerCertPath

public CertPath getSignerCertPath()
返回 Timestamping Authority 的证书路径。

返回：
TSA 的证书路径。

hashCode

public int hashCode()
返回此时间戳的哈希码值。哈希码通过使用时间戳的日期和时间以及 TSA 的证书路径生成。

覆盖：
类 Object 中的 hashCode
返回：
此时间戳的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较指定的对象和此时间戳之间的相同性。如果两个时间戳的日期和时间以及它们的签署人的证书路径都相同，则视其为相同。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此时间戳进行相同性比较的对象。
返回：
如果时间戳相同，则返回 true；否则，返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回描述此时间戳的字符串。

覆盖：
类 Object 中的 toString
返回：
构成时间戳的日期和时间及其签署人证书的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnrecoverableEntryException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 UnrecoverableEntryException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.UnrecoverableEntryException
所有已实现的接口：
Serializable
直接已知子类：
UnrecoverableKeyException
public class UnrecoverableEntryException
extends GeneralSecurityException

如果 keystore 中的某项无法恢复，则抛出此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
UnrecoverableEntryException()
构造不带详细消息的 UnrecoverableEntryException。
UnrecoverableEntryException(String msg)
构造具有指定详细消息的 UnrecoverableEntryException，其提供了有关为什么抛出此异常的更多信息。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnrecoverableEntryException

public UnrecoverableEntryException()
构造不带详细消息的 UnrecoverableEntryException。

UnrecoverableEntryException

public UnrecoverableEntryException(String msg)
构造具有指定详细消息的 UnrecoverableEntryException，其提供了有关为什么抛出此异常的更多信息。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnrecoverableKeyException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 UnrecoverableKeyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.UnrecoverableEntryException
                    继承者  java.security.UnrecoverableKeyException
所有已实现的接口：
Serializable
public class UnrecoverableKeyException
extends UnrecoverableEntryException

如果 keystore 中的密钥无法恢复，则抛出此异常。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
UnrecoverableKeyException()
构造不带详细消息的 UnrecoverableKeyException。
UnrecoverableKeyException(String msg)
构造具有指定详细消息的 UnrecoverableKeyException，其提供了有关为什么抛出此异常的更多信息。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnrecoverableKeyException

public UnrecoverableKeyException()
构造不带详细消息的 UnrecoverableKeyException。

UnrecoverableKeyException

public UnrecoverableKeyException(String msg)
构造具有指定详细消息的 UnrecoverableKeyException，其提供了有关为什么抛出此异常的更多信息。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnresolvedPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security
类 UnresolvedPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.UnresolvedPermission
所有已实现的接口：
Serializable, Guard
public final class UnresolvedPermission
extends Permission
implements Serializable

UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。未解析的权限是这样的一种权限：初始化 Policy 时其实际 Permission 类尚未存在（请参见以下内容）。

Java 运行时的策略（指定各种主体代码可用的权限）由 Policy 对象表示。每当初始化或刷新 Policy 时，都将为该 Policy 允许的所有权限创建相应类的 Permission 对象。

策略配置引用的许多权限类类型都是一些本机存在的类型（即一些可在 CLASSPATH 上找到的类型）。此类权限的对象可在策略初始化期间实例化。例如，自从在 CLASSPATH 上找到 FilePermission 类之后，始终可以实例化 java.io.FilePermission。

在 Policy 初始化期间，其他权限类可能尚未存在。例如，引用的权限类可能处在以后将加载的 JAR 文件中。将对每个这样的类初始化 UnresolvedPermission。因此，UnresolvedPermission 实际上是一个包含有关权限信息的“占位符”。

稍后，当代码在以前未解析、但其类在那时已经加载的类型权限上调用 AccessController.checkPermission 时，该类型以前未解析的权限将被“解析”。也就是说，将基于 UnresolvedPermission 中的信息，为每个这样的 UnresolvedPermission 实例化一个新的相应类类型的对象。

为了实例化此新类，UnresolvedPermission 假定该类提供了零、一个和/或两个参数构造方法。零参数构造方法将用来实例化不带有名称和操作的权限。假定带一个参数的构造方法采用 String 名称作为输入；带两个参数的构造方法采用 String 名称和 String 操作作为输入。UnresolvedPermission 可以调用带有 null 名称和/或操作的构造方法。如果没有提供适当的权限构造方法，则将忽略 UnresolvedPermission，并且不会授予执行代码的相关权限。

新创建的权限对象取代 UnresolvedPermission，并将后者移除。

注意，用于 UnresolvedPermission 的 getName 方法将返回尚未解析的基础权限的 type（类名称）。

另请参见：
Permission, Permissions, PermissionCollection, Policy, 序列化表格

构造方法摘要
UnresolvedPermission(String type, String name, String actions, Certificate[] certs)
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。
方法摘要
boolean | equals(Object obj) 检查两个 UnresolvedPermission 对象的相等性。
String | getActions() 返回这些操作的规范的字符串表示形式，该字符串当前为空字符串 ""，原因是没有针对 UnresolvedPermission 的操作。
String | getUnresolvedActions() 获取尚未解析的基础权限的操作。
Certificate[] | getUnresolvedCerts() 获取尚未解析的基础权限的签署者证书（无任何支持链）。
String | getUnresolvedName() 获取尚未解析的基础权限的目标名称。
String | getUnresolvedType() 获取尚未解析的基础权限的类型（类名称）。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 对于未解析的权限，此方法始终返回 false。
PermissionCollection | newPermissionCollection() 返回存储 UnresolvedPermission 对象的新 PermissionCollection 对象。
String | toString() 返回描述此 UnresolvedPermission 的字符串。
从类 java.security.Permission 继承的方法
checkGuard, getName
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnresolvedPermission

public UnresolvedPermission(String type,
                            String name,
                            String actions,
                            Certificate[] certs)
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。

参数：
type - 解析此未解析的权限时将创建的 Permission 类的类名称。
name - 权限名称。
actions - 对权限的操作。
certs - 用来为权限类签名的证书。这是一个证书链列表，其中每个链都是由签署人证书和其可选的支持证书链构成。每个链都按从底到顶进行排序（即签署人证书排在首位置，（根）证书授权排在末位置）。签署人证书是从数组中复制的。数组的后续更改不会影响此 UnsolvedPermission。
方法详细信息

implies

public boolean implies(Permission p)
对于未解析的权限，此方法始终返回 false。也就是说，从不认为 UnresolvedPermission 暗含其他权限。

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的权限。
返回：
false。

equals

public boolean equals(Object obj)
检查两个 UnresolvedPermission 对象的相等性。检查 obj 是否为 UnresolvedPermission，是否具有与此对象相同的类型（类）名称、权限名称、操作和证书。

为了确定证书是否相等，此方法仅比较实际签署人证书。此方法没有考虑对证书链的支持。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 是 UnresolvedPermission，并且具有与此对象相同的类型（类）名称、权限名称、操作和证书，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回这些操作的规范的字符串表示形式，该字符串当前为空字符串 ""，原因是没有针对 UnresolvedPermission 的操作。也就是说，解析此 UnresolvedPermission 时将创建的权限的操作可以为非 null，但永远不会认为 UnresolvedPermission 本身具有任何操作。

指定者：
类 Permission 中的 getActions
返回：
空字符串 ""。

getUnresolvedType

public String getUnresolvedType()
获取尚未解析的基础权限的类型（类名称）。

返回：
获取尚未解析的基础权限的类型（类名称）
从以下版本开始：
1.5

getUnresolvedName

public String getUnresolvedName()
获取尚未解析的基础权限的目标名称。

返回：
获取尚未解析的基础权限的目标名称，如果没有目标名称，则返回 null
从以下版本开始：
1.5

getUnresolvedActions

public String getUnresolvedActions()
获取尚未解析的基础权限的操作。

返回：
尚未解析的基础权限的操作，如果没有操作，则返回 null
从以下版本开始：
1.5

getUnresolvedCerts

public Certificate[] getUnresolvedCerts()
获取尚未解析的基础权限的签署者证书（无任何支持链）。

返回：
尚未解析的基础权限的签署者证书，如果没有签署者证书，则返回 null。每次调用此方法时都返回一个新的数组。
从以下版本开始：
1.5

toString

public String toString()
返回描述此 UnresolvedPermission 的字符串。惯例是按以下形式指定类名称、权限名称和操作：'(unresolved "ClassName" "name" "actions")'。

覆盖：
类 Permission 中的 toString
返回：
与此 UnresolvedPermission 有关的信息。

newPermissionCollection

public PermissionCollection newPermissionCollection()
返回存储 UnresolvedPermission 对象的新 PermissionCollection 对象。

覆盖：
类 Permission 中的 newPermissionCollection
返回：
适合存储 UnresolvedPermissions 的新 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URIParameter (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security
类 URIParameter

java.lang.Object
    继承者  java.security.URIParameter
所有已实现的接口：
Policy.Parameters, Configuration.Parameters
public class URIParameter
extends Object
implements Policy.Parameters, Configuration.Parameters

包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

从以下版本开始：
1.6

构造方法摘要
URIParameter(URI uri)
使用指向数据的 URI 构造一个 URIParameter，指向的数据用于 SPI 实现。
方法摘要
 URI getURI()
返回 URI。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

URIParameter

public URIParameter(URI uri)
使用指向数据的 URI 构造一个 URIParameter，指向的数据用于 SPI 实现。

参数：
uri - 指向数据的 URI。
抛出：
NullPointerException - 如果指定的 URI 为 null。
方法详细信息

getURI

public URI getURI()
返回 URI。

返回：
uri URI。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.security (Java 2 Platform SE 6)

 java.security
接口
Certificate
DomainCombiner
Guard
Key
KeyStore.Entry
KeyStore.LoadStoreParameter
KeyStore.ProtectionParameter
Policy.Parameters
Principal
PrivateKey
PrivilegedAction
PrivilegedExceptionAction
PublicKey
类
AccessControlContext
AccessController
AlgorithmParameterGenerator
AlgorithmParameterGeneratorSpi
AlgorithmParameters
AlgorithmParametersSpi
AllPermission
AuthProvider
BasicPermission
CodeSigner
CodeSource
DigestInputStream
DigestOutputStream
GuardedObject
Identity
IdentityScope
KeyFactory
KeyFactorySpi
KeyPair
KeyPairGenerator
KeyPairGeneratorSpi
KeyRep
KeyStore
KeyStore.Builder
KeyStore.CallbackHandlerProtection
KeyStore.PasswordProtection
KeyStore.PrivateKeyEntry
KeyStore.SecretKeyEntry
KeyStore.TrustedCertificateEntry
KeyStoreSpi
MessageDigest
MessageDigestSpi
Permission
PermissionCollection
Permissions
Policy
PolicySpi
ProtectionDomain
Provider
Provider.Service
SecureClassLoader
SecureRandom
SecureRandomSpi
Security
SecurityPermission
Signature
SignatureSpi
SignedObject
Signer
Timestamp
UnresolvedPermission
URIParameter
枚举
KeyRep.Type
异常
AccessControlException
DigestException
GeneralSecurityException
InvalidAlgorithmParameterException
InvalidKeyException
InvalidParameterException
KeyException
KeyManagementException
KeyStoreException
NoSuchAlgorithmException
NoSuchProviderException
PrivilegedActionException
ProviderException
SignatureException
UnrecoverableEntryException
UnrecoverableKeyException


java.security (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.security

为安全框架提供类和接口。

请参见：
描述

接口摘要
Certificate | 已过时。 在 Java 平台中创建了新的证书处理包。
DomainCombiner | DomainCombiner 提供一个动态更新与当前 AccessControlContext 关联的 ProtectionDomain 的方法。
Guard | 此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Key | Key 是所有密钥的顶层接口。
KeyStore.Entry | 用于 KeyStore 项类型的标记接口。
KeyStore.LoadStoreParameter | 用于 KeyStore load 和 store 参数的标记接口。
KeyStore.ProtectionParameter | 用于 keystore 保护参数的标记接口。
Policy.Parameters | 此类表示用于 Policy 参数的标记接口。
Principal | 此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
PrivateKey | 私钥。
PrivilegedAction<T> | 启用特权的情况下要执行的计算。
PrivilegedExceptionAction<T> | 在启用特权的情况下将要执行的计算，会抛出一个或多个经过检查的异常。
PublicKey | 公钥。

类摘要
AccessControlContext | AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。
AccessController | AccessController 类用于与访问控制相关的操作和决定。
AlgorithmParameterGenerator | AlgorithmParameterGenerator 类用于生成将在某个特定算法中使用的参数集合。
AlgorithmParameterGeneratorSpi | 此类为 AlgorithmParameterGenerator 类定义服务提供者接口 (SPI)，AlgorithmParameterGenerator 类用于生成在某个特定算法中使用的参数集合。
AlgorithmParameters | 此类用作密码参数的不透明表示形式。
AlgorithmParametersSpi | 此类为 AlgorithmParameters 类定义服务提供者接口 (SPI)，AlgorithmParameters 类用于管理算法参数。
AllPermission | AllPermission 是暗含所有其他权限的权限。
AuthProvider | 此类定义 provider 的登录和注销方法。
BasicPermission | BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
CodeSigner | 此类封装关于代码签名者的信息。
CodeSource | 此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。
DigestInputStream | 使用通过流的位更新关联消息摘要的透明流。
DigestOutputStream | 使用通过流的位更新关联消息摘要的透明流。
GuardedObject | GuardedObject 是一个用来保护对另一个对象的访问的对象。
Identity | 已过时。 不再使用此类。
IdentityScope | 已过时。 此类不再被使用。
KeyFactory | 密钥工厂用于将密钥（Key 类型的不透明加密密钥）转换成密钥规范（底层密钥材料的透明表示），反之亦然。
KeyFactorySpi | 此类为 KeyFactory 类定义服务提供者接口 (SPI)。
KeyPair | 此类是简单的密钥对（公钥和私钥）持有者。
KeyPairGenerator | KeyPairGenerator 类用于生成公钥和私钥对。
KeyPairGeneratorSpi | 此类为用来生成公钥和私钥的 KeyPairGenerator 类定义了服务提供者接口 (SPI)。
KeyRep | 已序列化的 Key 对象的标准表示形式。
KeyStore | 此类表示密钥和证书的存储设施。
KeyStore.Builder | 将被实例化的 KeyStore 对象的描述。
KeyStore.CallbackHandlerProtection | 封装 CallbackHandler 的 ProtectionParameter。
KeyStore.PasswordProtection | ProtectionParameter 的一个基于密码的实现。
KeyStore.PrivateKeyEntry | 保存 PrivateKey 和相应证书链的 KeyStore 项。
KeyStore.SecretKeyEntry | 保存 SecretKey 的 KeyStore 项。
KeyStore.TrustedCertificateEntry | 保存可信的 Certificate 的 KeyStore 项。
KeyStoreSpi | 此类为 KeyStore 类定义服务提供者接口 (SPI)。
MessageDigest | 此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。
MessageDigestSpi | 此类为 MessageDigest 类定义服务提供者接口 (SPI)，MessageDigest 类提供信息摘要算法的功能，如 MD5 或 SHA。
Permission | 表示访问系统资源的抽象类。
PermissionCollection | 表示 Permission 对象集合的抽象类。
Permissions | 此类表示一个不同种类的 Permission 集合。
Policy | Policy 对象负责确定在 Java 运行时环境中执行的代码是否有权执行安全敏感的操作。
PolicySpi | 此类为 Policy 类定义服务提供者接口 (SPI)。
ProtectionDomain | 此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。
Provider | 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
Provider.Service | 安全服务的描述。
SecureClassLoader | 此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。
SecureRandom | 此类提供强加密随机数生成器 (RNG)。
SecureRandomSpi | 此类为 SecureRandom 类定义了服务提供者接口 (SPI)。
Security | 此类集中了所有的安全属性和常见的安全方法。
SecurityPermission | 此类用于安全权限。
Signature | 此 Signature 类用来为应用程序提供数字签名算法功能。
SignatureSpi | 此类为 Signature 类定义了服务提供者接口 (SPI)，可用来提供数字签名算法功能。
SignedObject | SignedObject 是一个用来创建实际运行时对象的类，在检测不到这些对象的情况下，其完整性不会遭受损害。
Signer | 已过时。 将不再使用此类。
Timestamp | 此类封装有关签署时间戳的信息。
UnresolvedPermission | UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。
URIParameter | 包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

枚举摘要
KeyRep.Type Key 类型。

异常摘要
AccessControlException | 此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
DigestException | 此为一般 Message Digest 异常。
GeneralSecurityException | GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
InvalidAlgorithmParameterException | 用于无效或不合适的算法参数的异常。
InvalidKeyException | 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
InvalidParameterException | 当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
KeyException | 此异常是基本的密钥异常。
KeyManagementException | 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
KeyStoreException | 这是一般的 KeyStore 异常。
NoSuchAlgorithmException | 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchProviderException | 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
PrivilegedActionException | doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
ProviderException | 用于 Provider 异常(例如误配置错误或不可恢复的内部错误）的运行时异常，Provider 可以为它创建子类以抛出特殊的、特定于 provider 的运行时错误。
SignatureException | 这是一般的签名异常。
UnrecoverableEntryException | 如果 keystore 中的某项无法恢复，则抛出此异常。
UnrecoverableKeyException | 如果 keystore 中的密钥无法恢复，则抛出此异常。

软件包 java.security 的描述

为安全框架提供类和接口。包括那些实现了可方便配置的、细粒度的访问控制安全架构的类。此包也支持密码公钥对的生成和存储，以及包括信息摘要和签名生成在内的可输出密码操作。最后，此包提供支持 signed/guarded 对象和安全随机数生成的对象。此包中提供的许多类（特别是密码和安全随机数生成器类）是基于提供商的。该类本身定义了应用程序可以写入的编程接口。实现本身可由独立的第三方厂商来写，可以根据需要进行无缝的插入。因此，应用程序开发人员可以利用任何数量的基于提供商的实现而不必添加或重写代码。

包规范

  • 加密体系结构
  • PKCS8:私钥信息标准 1.2 版，1993 年 11 月

相关文档

有关进一步文档，请参阅：
  • Security Architecture
  • How to Implement a Provider for the Java Cryptography Architecture
  • Default Policy Implementation and Policy File Syntax
  • Policy Permissions
  • Security Tools Summary
  • keytool ( 对于 Solaris/Linux) ( 对于 Windows)
  • jarsigner ( 对于 Solaris/Linux) ( 对于 Windows)

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.security 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.security.AccessControlContext
    • java.security.AccessController
    • java.security.AlgorithmParameterGenerator
    • java.security.AlgorithmParameterGeneratorSpi
    • java.security.AlgorithmParameters
    • java.security.AlgorithmParametersSpi
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
    • java.security.CodeSigner (implements java.io.Serializable)
    • java.security.CodeSource (implements java.io.Serializable)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
          • java.security.Provider
            • java.security.AuthProvider
    • java.security.GuardedObject (implements java.io.Serializable)
    • java.security.Identity (implements java.security.Principal, java.io.Serializable)
      • java.security.IdentityScope
      • java.security.Signer
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • java.security.DigestInputStream
    • java.security.KeyFactory
    • java.security.KeyFactorySpi
    • java.security.KeyPair (implements java.io.Serializable)
    • java.security.KeyPairGeneratorSpi
      • java.security.KeyPairGenerator
    • java.security.KeyRep (implements java.io.Serializable)
    • java.security.KeyStore
    • java.security.KeyStore.Builder
    • java.security.KeyStore.CallbackHandlerProtection (implements java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PasswordProtection (implements javax.security.auth.Destroyable, java.security.KeyStore.ProtectionParameter)
    • java.security.KeyStore.PrivateKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.SecretKeyEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStore.TrustedCertificateEntry (implements java.security.KeyStore.Entry)
    • java.security.KeyStoreSpi
    • java.security.MessageDigestSpi
      • java.security.MessageDigest
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.security.DigestOutputStream
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.AllPermission
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.security.SecurityPermission
      • java.security.UnresolvedPermission (implements java.io.Serializable)
    • java.security.PermissionCollection (implements java.io.Serializable)
      • java.security.Permissions (implements java.io.Serializable)
    • java.security.Policy
    • java.security.PolicySpi
    • java.security.ProtectionDomain
    • java.security.Provider.Service
    • java.util.Random (implements java.io.Serializable)
      • java.security.SecureRandom
    • java.security.SecureRandomSpi (implements java.io.Serializable)
    • java.security.Security
    • java.security.SignatureSpi
      • java.security.Signature
    • java.security.SignedObject (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.DigestException
          • java.security.InvalidAlgorithmParameterException
          • java.security.KeyException
            • java.security.InvalidKeyException
            • java.security.KeyManagementException
          • java.security.KeyStoreException
          • java.security.NoSuchAlgorithmException
          • java.security.NoSuchProviderException
          • java.security.SignatureException
          • java.security.UnrecoverableEntryException
            • java.security.UnrecoverableKeyException
        • java.security.PrivilegedActionException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.security.InvalidParameterException
          • java.security.ProviderException
          • java.lang.SecurityException
            • java.security.AccessControlException
    • java.security.Timestamp (implements java.io.Serializable)
    • java.security.URIParameter (implements javax.security.auth.login.Configuration.Parameters, java.security.Policy.Parameters)

接口分层结构

  • java.security.Certificate
  • java.security.DomainCombiner
  • java.security.Guard
  • java.security.KeyStore.Entry
  • java.security.KeyStore.LoadStoreParameter
  • java.security.KeyStore.ProtectionParameter
  • java.security.Policy.Parameters
  • java.security.Principal
  • java.security.PrivilegedAction<T>
  • java.security.PrivilegedExceptionAction<T>
  • java.io.Serializable
    • java.security.Key
      • java.security.PrivateKey
      • java.security.PublicKey

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.security.KeyRep.Type
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.security 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security
的使用

使用 java.security 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.ws | 此包包含核心 JAX-WS API。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.awt 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。

java.io 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
PermissionCollection
表示 Permission 对象集合的抽象类。

java.lang 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
ProtectionDomain
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。

java.lang.instrument 使用的 java.security 中的类
ProtectionDomain
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。

java.lang.management 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。

java.lang.reflect 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。

java.net 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
CodeSource
此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
PermissionCollection
表示 Permission 对象集合的抽象类。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
SecureClassLoader
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。

java.security 使用的 java.security 中的类
AccessControlContext
AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。
AccessControlException
此异常由 AccessController 抛出，提示请求的访问（对关键系统资源（如文件系统或网络）的访问）被拒绝。
AlgorithmParameterGenerator
AlgorithmParameterGenerator 类用于生成将在某个特定算法中使用的参数集合。
AlgorithmParameterGeneratorSpi
此类为 AlgorithmParameterGenerator 类定义服务提供者接口 (SPI)，AlgorithmParameterGenerator 类用于生成在某个特定算法中使用的参数集合。
AlgorithmParameters
此类用作密码参数的不透明表示形式。
AlgorithmParametersSpi
此类为 AlgorithmParameters 类定义服务提供者接口 (SPI)，AlgorithmParameters 类用于管理算法参数。
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Certificate
已过时。 在 Java 平台中创建了新的证书处理包。此 Certificate 接口已完全废弃，其仍存在是为了能平稳地过渡到新包。
CodeSigner
此类封装关于代码签名者的信息。
CodeSource
此类扩展 codebase 的概念，不仅可以封装位置 (URL) 而且可以封装用于验证起源于该位置的签名代码的证书链。
DigestException
此为一般 Message Digest 异常。
DomainCombiner
DomainCombiner 提供一个动态更新与当前 AccessControlContext 关联的 ProtectionDomain 的方法。
GeneralSecurityException
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Identity
已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
IdentityScope
已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
InvalidAlgorithmParameterException
用于无效或不合适的算法参数的异常。
InvalidKeyException
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
InvalidParameterException
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
Key
Key 是所有密钥的顶层接口。
KeyException
此异常是基本的密钥异常。
KeyFactory
密钥工厂用于将密钥（Key 类型的不透明加密密钥）转换成密钥规范（底层密钥材料的透明表示），反之亦然。
KeyFactorySpi
此类为 KeyFactory 类定义服务提供者接口 (SPI)。
KeyManagementException
此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
KeyPair
此类是简单的密钥对（公钥和私钥）持有者。
KeyPairGenerator
KeyPairGenerator 类用于生成公钥和私钥对。
KeyPairGeneratorSpi
此类为用来生成公钥和私钥的 KeyPairGenerator 类定义了服务提供者接口 (SPI)。
KeyRep.Type
Key 类型。
KeyStore
此类表示密钥和证书的存储设施。
KeyStore.Builder
将被实例化的 KeyStore 对象的描述。
KeyStore.Entry
用于 KeyStore 项类型的标记接口。
KeyStore.LoadStoreParameter
用于 KeyStore load 和 store 参数的标记接口。
KeyStore.ProtectionParameter
用于 keystore 保护参数的标记接口。
KeyStoreException
这是一般的 KeyStore 异常。
KeyStoreSpi
此类为 KeyStore 类定义服务提供者接口 (SPI)。
MessageDigest
此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。
MessageDigestSpi
此类为 MessageDigest 类定义服务提供者接口 (SPI)，MessageDigest 类提供信息摘要算法的功能，如 MD5 或 SHA。
NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
Permission
表示访问系统资源的抽象类。
PermissionCollection
表示 Permission 对象集合的抽象类。
Policy
Policy 对象负责确定在 Java 运行时环境中执行的代码是否有权执行安全敏感的操作。
Policy.Parameters
此类表示用于 Policy 参数的标记接口。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
PrivateKey
私钥。
PrivilegedAction
启用特权的情况下要执行的计算。
PrivilegedActionException
doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
PrivilegedExceptionAction
在启用特权的情况下将要执行的计算，会抛出一个或多个经过检查的异常。
ProtectionDomain
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
Provider.Service
安全服务的描述。
PublicKey
公钥。
SecureRandom
此类提供强加密随机数生成器 (RNG)。
SecureRandomSpi
此类为 SecureRandom 类定义了服务提供者接口 (SPI)。
Signature
此 Signature 类用来为应用程序提供数字签名算法功能。
SignatureException
这是一般的签名异常。
SignatureSpi
此类为 Signature 类定义了服务提供者接口 (SPI)，可用来提供数字签名算法功能。
Timestamp
此类封装有关签署时间戳的信息。
UnrecoverableEntryException
如果 keystore 中的某项无法恢复，则抛出此异常。
UnrecoverableKeyException
如果 keystore 中的密钥无法恢复，则抛出此异常。

java.security.acl 使用的 java.security 中的类
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。

java.security.cert 使用的 java.security 中的类
GeneralSecurityException
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
InvalidAlgorithmParameterException
用于无效或不合适的算法参数的异常。
InvalidKeyException
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
KeyStore
此类表示密钥和证书的存储设施。
KeyStoreException
这是一般的 KeyStore 异常。
NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
PublicKey
公钥。
SignatureException
这是一般的签名异常。

java.security.interfaces 使用的 java.security 中的类
InvalidParameterException
当将无效参数传递给某个方法时抛出此异常，设计该异常供 JCA/JCE 引擎类使用。
Key
Key 是所有密钥的顶层接口。
PrivateKey
私钥。
PublicKey
公钥。
SecureRandom
此类提供强加密随机数生成器 (RNG)。

java.security.spec 使用的 java.security 中的类
GeneralSecurityException
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。

java.sql 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。

java.util 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
PermissionCollection
表示 Permission 对象集合的抽象类。

java.util.concurrent 使用的 java.security 中的类
PrivilegedAction
启用特权的情况下要执行的计算。
PrivilegedExceptionAction
在启用特权的情况下将要执行的计算，会抛出一个或多个经过检查的异常。

java.util.jar 使用的 java.security 中的类
CodeSigner
此类封装关于代码签名者的信息。

java.util.logging 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。

javax.crypto 使用的 java.security 中的类
AlgorithmParameters
此类用作密码参数的不透明表示形式。
GeneralSecurityException
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
InvalidAlgorithmParameterException
用于无效或不合适的算法参数的异常。
InvalidKeyException
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
Key
Key 是所有密钥的顶层接口。
NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
SecureRandom
此类提供强加密随机数生成器 (RNG)。

javax.crypto.interfaces 使用的 java.security 中的类
Key
Key 是所有密钥的顶层接口。
PrivateKey
私钥。
PublicKey
公钥。

javax.crypto.spec 使用的 java.security 中的类
InvalidKeyException
用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
Key
Key 是所有密钥的顶层接口。

javax.management 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
PermissionCollection
表示 Permission 对象集合的抽象类。

javax.management.loading 使用的 java.security 中的类
SecureClassLoader
此类扩展了 ClassLoader，使它另外还支持使用相关的代码源和权限定义类，这些代码源和权限默认情况下可根据系统策略获取到。

javax.management.remote 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。

javax.net.ssl 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
InvalidAlgorithmParameterException
用于无效或不合适的算法参数的异常。
KeyManagementException
此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
KeyStore
此类表示密钥和证书的存储设施。
KeyStore.Builder
将被实例化的 KeyStore 对象的描述。
KeyStoreException
这是一般的 KeyStore 异常。
NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
Permission
表示访问系统资源的抽象类。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
PrivateKey
私钥。
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
SecureRandom
此类提供强加密随机数生成器 (RNG)。
UnrecoverableKeyException
如果 keystore 中的密钥无法恢复，则抛出此异常。

javax.security.auth 使用的 java.security 中的类
AccessControlContext
AccessControlContext 用于基于它所封装的上下文作出系统资源访问决定。
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
DomainCombiner
DomainCombiner 提供一个动态更新与当前 AccessControlContext 关联的 ProtectionDomain 的方法。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
PermissionCollection
表示 Permission 对象集合的抽象类。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
PrivilegedAction
启用特权的情况下要执行的计算。
PrivilegedActionException
doPrivileged(PrivilegedExceptionAction) 和 doPrivileged(PrivilegedExceptionAction, AccessControlContext context) 抛出此异常来指示执行的操作抛出了经过检查的异常。
PrivilegedExceptionAction
在启用特权的情况下将要执行的计算，会抛出一个或多个经过检查的异常。
ProtectionDomain
此 ProtectionDomain 类封装域的特征，域中包装一个类集合，在代表给定的主体集合执行这些类的实例时会授予它们一个权限集合。

javax.security.auth.kerberos 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Key
Key 是所有密钥的顶层接口。
Permission
表示访问系统资源的抽象类。
PermissionCollection
表示 Permission 对象集合的抽象类。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。

javax.security.auth.login 使用的 java.security 中的类
GeneralSecurityException
GeneralSecurityException 类是一个一般安全异常类，可以为所有从其扩展的与安全有关的异常类提供类型安全。
NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

javax.security.auth.x500 使用的 java.security 中的类
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。
PrivateKey
私钥。

javax.sound.sampled 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。

javax.xml.crypto 使用的 java.security 中的类
Key
Key 是所有密钥的顶层接口。

javax.xml.crypto.dsig 使用的 java.security 中的类
InvalidAlgorithmParameterException
用于无效或不合适的算法参数的异常。
NoSuchAlgorithmException
当请求特定的加密算法而它在该环境中不可用时抛出此异常。
NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

javax.xml.crypto.dsig.dom 使用的 java.security 中的类
Key
Key 是所有密钥的顶层接口。

javax.xml.crypto.dsig.keyinfo 使用的 java.security 中的类
KeyException
此异常是基本的密钥异常。
NoSuchProviderException
当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。
PublicKey
公钥。

javax.xml.ws 使用的 java.security 中的类
BasicPermission
BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
Guard
此接口表示一个 guard，guard 是用来保护对另一个对象的访问的对象。
Permission
表示访问系统资源的抽象类。
Principal
此接口表示主体的抽象概念，它可以用来表示任何实体，例如，个人、公司或登录 id。

org.ietf.jgss 使用的 java.security 中的类
Provider
此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Acl (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.acl
接口 Acl

所有超级接口：
Owner
public interface Acl
extends Owner

表示访问控制列表 (ACL) 的接口。访问控制列表是一种数据结构，用于保护对资源的访问。

可将一个 ACL 看作是具有多个 ACL 项的数据结构。每个接口类型为 AclEntry 的 ACL 项都包含一组与特定主体相关联的权限。（主体表示一个实体，如单独用户或一个用户组）。另外，可以将每个 ACL 项指定为 positive 或 negative 的。如果为 positive，则将权限授予相关联的主体。如果为 negative，则拒绝该权限。

每个 ACL 中的 ACL 项都遵循以下规则：

  • 每个主体最多有一个 positive ACL 项和一个 negative ACL 项；也就是对于任何主体，不允许有多个 positive 或 negative ACL 项。每项指定了一组要授予（如果为 positive）或要拒绝（如果为 negative）的权限。

  • 如果没有针对特定主体的 ACL 项，则认为该主体具有一个 null（空）的权限集。

  • 如果有向某个主体授予特定权限的 positive 项，并且有拒绝向该主体授予同一权限的 negative 项，则结果就如同既不授予也不拒绝该权限一样。

  • 个体权限总是覆盖该个体所属组（组群）的权限。也就是说，个体 negative 权限（特定权限的拒绝）覆盖组的 positive 权限。而个体 positive 权限则覆盖组的 negative 权限。

java.security.acl 包为 ACL 和相关的数据结构（ACL 项、组、权限等等）提供了接口，sun.security.acl 类则提供了该接口的默认实现。例如，java.security.acl.Acl 为 ACL 提供了接口，而 sun.security.acl.AclImpl 类则提供了该接口的默认实现。

java.security.acl.Acl 接口扩展了 java.security.acl.Owner 接口。该 Owner 接口用于维护每个 ACL 的所有者列表。只允许 ACL 的所有者修改该 ACL。例如，只有所有者才能调用 ACL 的 addEntry 方法来向 ACL 中添加新的 ACL 项。

另请参见：
AclEntry, Owner, getPermissions(java.security.Principal)

方法摘要
boolean | addEntry(Principal caller, AclEntry entry) 向此 ACL 中添加 ACL 项。
boolean | checkPermission(Principal principal, Permission permission) 检查指定的主体是否具有指定的权限。
Enumeration<AclEntry> | entries() 返回此 ACL 中各项的枚举。
String | getName() 返回此 ACL 的名称。
Enumeration<Permission> | getPermissions(Principal user) 返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
boolean | removeEntry(Principal caller, AclEntry entry) 从此 ACL 中移除 ACL 项。
void | setName(Principal caller, String name) 设置此 ACL 的名称。
String | toString() 返回 ACL 内容的字符串表示形式。
从接口 java.security.acl.Owner 继承的方法
addOwner, deleteOwner, isOwner

方法详细信息

setName

void setName(Principal caller,
             String name)
             throws NotOwnerException
设置此 ACL 的名称。

参数：
caller - 调用此方法的主体。必须是此 ACL 的所有者。
name - 赋予此 ACL 的名称。
抛出：
NotOwnerException - 如果调用方主体不是此 ACL 的所有者。
另请参见：
getName()

getName

String getName()
返回此 ACL 的名称。

返回：
此 ACL 的名称。
另请参见：
setName(java.security.Principal, java.lang.String)

addEntry

boolean addEntry(Principal caller,
                 AclEntry entry)
                 throws NotOwnerException
向此 ACL 中添加 ACL 项。ACL 项将主体（例如个体或组）与一组权限关联起来。每个主体最多有一个 positive ACL 项（指定要授予该主体的权限）和一个 negative ACL 项（指定要拒绝的权限）。如果该 ACL 中已经有一个相同类型（ negative 或 positive ）的 ACL 项，则返回 false。

参数：
caller - 调用此方法的主体。必须是此 ACL 的所有者。
entry - 要添加到此 ACL 中的 ACL 项。
返回：
如果添加成功，则返回 true；如果此 ACL 中已经有一个针对同一主体的相同类型（negative 或 positive）的 ACL 项，则返回 false。
抛出：
NotOwnerException - 如果调用方主体不是此 ACL 的所有者。

removeEntry

boolean removeEntry(Principal caller,
                    AclEntry entry)
                    throws NotOwnerException
从此 ACL 中移除 ACL 项。

参数：
caller - 调用此方法的主体。必须是此 ACL 的所有者。
entry - 要从此 ACL 中移除的 ACL 项。
返回：
如果移除成功，则返回 true；如果该项不是此 ACL 的一部分，则返回 false。
抛出：
NotOwnerException - 如果调用方主体不是此 ACL 的所有者。

getPermissions

Enumeration<Permission> getPermissions(Principal user)
返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。按以下方式计算该许可权限集合：

  • 如果此访问控制列表中没有针对指定主体的项，则返回空的权限集合。

  • 否则确定该主体的组权限集合。（一个主体可以属于一个或多个组，其中组是一个主体组，由 Group 接口表示。）该组的 positive 权限集合是该主体所属每个组的所有 positive 权限的并集。该组的 negative 权限集合是该主体所属每个组的所有 negative 权限的并集。如果某个指定的权限同时出现在 positive 权限集合和 negative 权限集合中，则将它从这两个集合中移除。

    还要确定个体 positive 和 negative 权限集合。positive 权限集合包含该主体的 positive ACL 项（如果有的话）中所指定的权限。类似地，negative 权限集合包含该主体的 negative ACL 项（如果有的话）中所指定的权限。如果此 ACL 中没有针对该主体的 positive（negative）ACL 项，则认为个体 positive（或 negative ）权限集合为 null。

    然后使用个体权限总是覆盖组权限这一简单规则来计算授予该主体的权限集合。也就是说，该主体的个体 negative 权限集合（特定权限的拒绝）覆盖组的 positive 权限集合，该主体的个体 positive 权限集合则覆盖组的 negative 权限集合。

参数：
user - 要返回其权限集合的主体。
返回：
指定该主体的许可权限的权限集合。

entries

Enumeration<AclEntry> entries()
返回此 ACL 中各项的枚举。该枚举中的每个元素的类型都是 AclEntry。

返回：
此 ACL 中各项的枚举。

checkPermission

boolean checkPermission(Principal principal,
                        Permission permission)
检查指定的主体是否具有指定的权限。如果确实有，则返回 true；否则返回 false。 更明确地说，此方法检查所传入的权限是否为指定主体的许可权限集合的一个成员。由 getPermissions 方法所使用的相同算法来确定该许可权限集合。

参数：
principal - 主体，假定是一个有效的、已进行身份验证的 Principal。
permission - 要检查的权限。
返回：
如果主体具有指定的权限，则返回 true；否则返回 false。
另请参见：
getPermissions(java.security.Principal)

toString

String toString()
返回 ACL 内容的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
ACL 内容的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AclEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.acl
接口 AclEntry

所有超级接口：
Cloneable
public interface AclEntry
extends Cloneable

这是用于表示访问控制列表 (ACL) 中某个项的接口。

可将一个 ACL 视为具有多个 ACL 项对象的数据结构。每个 ACL 项对象都包含一组与特定主体相关联的权限。（主体表示一种实体，如个体用户或一个用户组）。另外，可以将每个 ACL 项指定为 positive 或 negative 的。如果为 positive，则将权限授予相关联的主体。如果为 negative，则拒绝该权限。每个主体最多有一个 positive ACL 项和一个 negative ACL 项；也就是对于任何主体，不允许有多个 positive 或 negative ACL 项。 注：默认情况下，ACL 项是 positive 的。仅在某个项上调用 setNegativePermissions 方法后，该项才会变成 negative 项。

另请参见：
Acl

方法摘要
boolean | addPermission(Permission permission) 向此 ACL 项添加指定的权限。
boolean | checkPermission(Permission permission) 检查指定的权限是否为此项中权限集合的一部分。
Object | clone() 复制此 ACL 项。
Principal | getPrincipal() 返回此 ACL 项将为其授予或拒绝权限的主体。
boolean | isNegative() 如果此项是一个 negative ACL 项（关联的主体拒绝该项中的权限集合），则返回 true；否则返回 false。
Enumeration<Permission> | permissions() 返回此 ACL 项中各个权限的枚举。
boolean | removePermission(Permission permission) 从此 ACL 项中移除指定的权限。
void | setNegativePermissions() 将此 ACL 项设置为 negative 项。
boolean | setPrincipal(Principal user) 指定此 ACL 项要为其授予或拒绝权限的主体。
String | toString() 返回此 ACL 项内容的字符串表示形式。

方法详细信息

setPrincipal

boolean setPrincipal(Principal user)
指定此 ACL 项要为其授予或拒绝权限的主体。如果已为此 ACL 项设置了某个主体，则返回 false，否则返回 true。

参数：
user - 要为此项设置的主体。
返回：
如果设置主体，则返回 true；如果已存在针对此项的主体，则返回 false。
另请参见：
getPrincipal()

getPrincipal

Principal getPrincipal()
返回此 ACL 项将为其授予或拒绝权限的主体。如果尚未为此项设置主体，则返回 null。

返回：
与此项关联的主体。
另请参见：
setPrincipal(java.security.Principal)

setNegativePermissions

void setNegativePermissions()
将此 ACL 项设置为 negative 项。也就是说，关联的主体（例如用户或组）将拒绝该项中指定的权限。 注：默认情况下，ACL 项是 positive 的。只有在某个项上调用此 setNegativePermissions 方法后，该项才会变成 negative 项。

isNegative

boolean isNegative()
如果此项是一个 negative ACL 项（关联的主体拒绝该项中的权限集合），则返回 true；否则返回 false。

返回：
此项是一个 negative ACL 项，则返回 true；如果不是，则返回 false。

addPermission

boolean addPermission(Permission permission)
向此 ACL 项添加指定的权限。注：一个项可以有多个权限。

参数：
permission - 要与此项中的主体相关联的权限。
返回：
如果添加了该权限，则返回 true；如果该权限已经是此项权限集合的一部分，则返回 false。

removePermission

boolean removePermission(Permission permission)
从此 ACL 项中移除指定的权限。

参数：
permission - 要从此项中移除的权限。
返回：
如果移除了该权限，则返回 true；如果该权限不是此项权限集合的一部分，则返回 false。

checkPermission

boolean checkPermission(Permission permission)
检查指定的权限是否为此项中权限集合的一部分。

参数：
permission - 要检查的权限。
返回：
如果该权限是此项中权限集合的一部分，则返回 true；否则返回 false。

permissions

Enumeration<Permission> permissions()
返回此 ACL 项中各个权限的枚举。

返回：
此 ACL 项中各个权限的枚举。

toString

String toString()
返回此 ACL 项内容的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该内容的字符串表示形式。

clone

Object clone()
复制此 ACL 项。

返回：
此 ACL 项的一个副本。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AclNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.acl
类 AclNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.acl.AclNotFoundException
所有已实现的接口：
Serializable
public class AclNotFoundException
extends Exception

如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。

另请参见：
序列化表格

构造方法摘要
AclNotFoundException()
构造一个 AclNotFoundException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AclNotFoundException

public AclNotFoundException()
构造一个 AclNotFoundException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Group (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.acl
接口 Group

所有超级接口：
Principal
public interface Group
extends Principal

此接口用于表示一个主体组。（主体表示一种实体，如单个用户或一家公司）。

注意，Group 扩展了 Principal。因此，可将 Principal 或 Group 作为参数传入到包含 Principal 参数的方法中。例如，可以通过调用 Group 对象的 addMember 方法来向该对象添加 Principal 或 Group，将其传递到 Principal 或 Group。

方法摘要
boolean | addMember(Principal user) 向组中添加指定的成员。
boolean | isMember(Principal member) 如果传递的主体是组的一个成员，则返回 true。
Enumeration<? extends Principal> | members() 返回此组中成员的枚举。
boolean | removeMember(Principal user) 从组中移除指定的成员。
从接口 java.security.Principal 继承的方法
equals, getName, hashCode, toString

方法详细信息

addMember

boolean addMember(Principal user)
向组中添加指定的成员。

参数：
user - 要添加到此组中的主体。
返回：
如果成功添加了该成员，则返回 true；如果该主体已经是一个成员，则返回 false。

removeMember

boolean removeMember(Principal user)
从组中移除指定的成员。

参数：
user - 从此组中移除的主体。
返回：
如果移除了该主体，则返回 true；如果该主体不是一个成员，则返回 false。

isMember

boolean isMember(Principal member)
如果传递的主体是组的一个成员，则返回 true。此方法执行递归搜索，所以如果主体所属的组是此组的一个成员，则返回 true。

参数：
member - 要检查其成员关系的主体。
返回：
如果该主体是此组的一个成员，则返回 true；否则返回 false。

members

Enumeration<? extends Principal> members()
返回此组中成员的枚举。返回的对象可以是 Principal 或 Group（它是 Principal 的一个子类）的一个实例。

返回：
组成员的一个枚举。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LastOwnerException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.acl
类 LastOwnerException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.acl.LastOwnerException
所有已实现的接口：
Serializable
public class LastOwnerException
extends Exception

如果试图删除访问控制列表的最后一个所有者，则抛出此异常。

另请参见：
Owner.deleteOwner(java.security.Principal, java.security.Principal), 序列化表格

构造方法摘要
LastOwnerException()
构造一个 LastOwnerException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LastOwnerException

public LastOwnerException()
构造一个 LastOwnerException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotOwnerException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.acl
类 NotOwnerException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.acl.NotOwnerException
所有已实现的接口：
Serializable
public class NotOwnerException
extends Exception

当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

另请参见：
序列化表格

构造方法摘要
NotOwnerException()
构造一个 NotOwnerException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotOwnerException

public NotOwnerException()
构造一个 NotOwnerException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Owner (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.acl
接口 Owner

所有已知子接口：
Acl
public interface Owner

管理访问控制列表 (ACL) 的所有者或 ACL 配置的接口。（注意，java.security.acl 包中的 Acl 接口扩展了此 Owner 接口。）应该将初始的所有者 Principal 指定为实现此接口的类构造方法的一个参数。

另请参见：
Acl

方法摘要
boolean | addOwner(Principal caller, Principal owner) 添加一个所有者。
boolean | deleteOwner(Principal caller, Principal owner) 删除一个所有者。
boolean | isOwner(Principal owner) 如果给定的主体是该 ACL 的所有者，则返回 true。

方法详细信息

addOwner

boolean addOwner(Principal caller,
                 Principal owner)
                 throws NotOwnerException
添加一个所有者。只有所有者可以修改 ACL 内容。为了调用此方法，调用者主体必须是 ACL 的所有者。也就是说，只有所有者才能添加另一个所有者。在构造 ACL 时配置初始的所有者。

参数：
caller - 调用此方法的主体。必须是 ACL 的所有者。
owner - 应该添加到所有者列表中的所有者。
返回：
如果添加成功，则返回 true，如果 owner 已经是一个所有者，则返回 false。
抛出：
NotOwnerException - 如果调用者主体不是该 ACL 的所有者。

deleteOwner

boolean deleteOwner(Principal caller,
                    Principal owner)
                    throws NotOwnerException,
                           LastOwnerException
删除一个所有者。如果这是 ACL 中的最后一个所有者，则会引发异常。

为了调用此方法，调用者主体必须是 ACL 的所有者。

参数：
caller - 调用此方法的主体。必须是 ACL 的所有者。
owner - 应该从所有者列表中移除的所有者。
返回：
如果移除了该所有者，则返回 true，如果该所有者不是所有者列表的一部分，则返回 false。
抛出：
NotOwnerException - 如果调用者主体不是该 ACL 的所有者。
LastOwnerException - 如果只剩下一个所有者，这样 deleteOwner 将使该 ACL 变成无所有者。

isOwner

boolean isOwner(Principal owner)
如果给定的主体是该 ACL 的所有者，则返回 true。

参数：
owner - 主体，要检查以确定它是否为一个所有者。
返回：
如果传递的主体在所有者列表中，则返回 true，如果不在则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Permission (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.acl
接口 Permission

public interface Permission

此接口表示一个权限，比如授予访问资源的特定类型的权限。

方法摘要
boolean | equals(Object another) 如果传递的对象与此接口中所表示的权限相匹配，则返回 true。
String | toString() 打印此权限的字符串表示形式。

方法详细信息

equals

boolean equals(Object another)
如果传递的对象与此接口中所表示的权限相匹配，则返回 true。

覆盖：
类 Object 中的 equals
参数：
another - 要与之比较的 Permission 对象。
返回：
如果 Permission 对象相等，则返回 true，否则返回 false
另请参见：
Object.hashCode(), Hashtable

toString

String toString()
打印此权限的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该权限的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.security.acl (Java 2 Platform SE 6)

 java.security.acl
接口
Acl
AclEntry
Group
Owner
Permission
异常
AclNotFoundException
LastOwnerException
NotOwnerException


java.security.acl (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.security.acl

此包中的类和接口已经被 java.security 包中的类取代。

请参见：
描述

接口摘要
Acl | 表示访问控制列表 (ACL) 的接口。
AclEntry | 这是用于表示访问控制列表 (ACL) 中某个项的接口。
Group | 此接口用于表示一个主体组。
Owner | 管理访问控制列表 (ACL) 的所有者或 ACL 配置的接口。
Permission | 此接口表示一个权限，比如授予访问资源的特定类型的权限。

异常摘要
AclNotFoundException | 如果对不存在的 ACL（访问控制列表）进行引用，则抛出此异常。
LastOwnerException | 如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
NotOwnerException | 当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。

软件包 java.security.acl 的描述

此包中的类和接口已经被 java.security 包中的类取代。有关细节，请参阅该包和 java.security.Permission。

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.security.acl 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.acl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.acl.AclNotFoundException
        • java.security.acl.LastOwnerException
        • java.security.acl.NotOwnerException

接口分层结构

  • java.lang.Cloneable
    • java.security.acl.AclEntry
  • java.security.acl.Owner
    • java.security.acl.Acl
  • java.security.acl.Permission
  • java.security.Principal
    • java.security.acl.Group
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.security.acl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.acl
的使用

使用 java.security.acl 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 使用的 java.security.acl 中的类
AclEntry
这是用于表示访问控制列表 (ACL) 中某个项的接口。
LastOwnerException
如果试图删除访问控制列表的最后一个所有者，则抛出此异常。
NotOwnerException
当只允许对象（如访问控制列表）的所有者修改对象，但是试图进行修改的 Principal 不是所有者时，抛出此异常。
Owner
管理访问控制列表 (ACL) 的所有者或 ACL 配置的接口。
Permission
此接口表示一个权限，比如授予访问资源的特定类型的权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.acl.Acl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Acl
的使用

没有 java.security.acl.Acl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.acl.AclEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.AclEntry
的使用

使用 AclEntry 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 AclEntry 的使用

返回变量类型为 AclEntry 的类型的 java.security.acl 中的方法
 Enumeration<AclEntry> Acl.entries()
返回此 ACL 中各项的枚举。

参数类型为 AclEntry 的 java.security.acl 中的方法
boolean | Acl.addEntry(Principal caller, AclEntry entry) 向此 ACL 中添加 ACL 项。
boolean | Acl.removeEntry(Principal caller, AclEntry entry) 从此 ACL 中移除 ACL 项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.acl.AclNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.acl.AclNotFoundException
的使用

没有 java.security.acl.AclNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.acl.Group 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Group
的使用

没有 java.security.acl.Group 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.acl.LastOwnerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.acl.LastOwnerException
的使用

使用 LastOwnerException 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 LastOwnerException 的使用

抛出 LastOwnerException 的 java.security.acl 中的方法
 boolean Owner.deleteOwner(Principal caller, Principal owner)
删除一个所有者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.acl.NotOwnerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.acl.NotOwnerException
的使用

使用 NotOwnerException 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 NotOwnerException 的使用

抛出 NotOwnerException 的 java.security.acl 中的方法
boolean | Acl.addEntry(Principal caller, AclEntry entry) 向此 ACL 中添加 ACL 项。
boolean | Owner.addOwner(Principal caller, Principal owner) 添加一个所有者。
boolean | Owner.deleteOwner(Principal caller, Principal owner) 删除一个所有者。
boolean | Acl.removeEntry(Principal caller, AclEntry entry) 从此 ACL 中移除 ACL 项。
void | Acl.setName(Principal caller, String name) 设置此 ACL 的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.acl.Owner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Owner
的使用

使用 Owner 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 Owner 的使用

java.security.acl 中 Owner 的子接口
 interface Acl
表示访问控制列表 (ACL) 的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.acl.Permission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.acl.Permission
的使用

使用 Permission 的软件包
java.security.acl 此包中的类和接口已经被 java.security 包中的类取代。

java.security.acl 中 Permission 的使用

返回变量类型为 Permission 的类型的 java.security.acl 中的方法
Enumeration<Permission> | Acl.getPermissions(Principal user) 返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
Enumeration<Permission> | AclEntry.permissions() 返回此 ACL 项中各个权限的枚举。

参数类型为 Permission 的 java.security.acl 中的方法
boolean | AclEntry.addPermission(Permission permission) 向此 ACL 项添加指定的权限。
boolean | AclEntry.checkPermission(Permission permission) 检查指定的权限是否为此项中权限集合的一部分。
boolean | Acl.checkPermission(Principal principal, Permission permission) 检查指定的主体是否具有指定的权限。
boolean | AclEntry.removePermission(Permission permission) 从此 ACL 项中移除指定的权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Certificate (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 Certificate

java.lang.Object
    继承者  java.security.cert.Certificate
所有已实现的接口：
Serializable
直接已知子类：
X509Certificate
public abstract class Certificate
extends Object
implements Serializable

管理各种身份证书的抽象类。身份证书是一个主体与由另一个主体所担保的公钥之间的绑定关系。（一个主体表示一种实体，如个体用户、一个用户组或一家公司）。

此类是具有不同格式但是很常用的证书的抽象。例如，不同的证书类型（如 X.509 和 PGP）共享通用的证书功能（如编码和验证）和某些信息类型（如公钥）。

虽然 X.509、PGP 和 SDSI 证书包含不同的信息集，并且它们以不同的方式存储和获取信息，但都可以通过继承 Certificate 类来实现它们。

另请参见：
X509Certificate, CertificateFactory, 序列化表格

嵌套类摘要
protected static class Certificate.CertificateRep
用于序列化的替换 Certificate 类。
构造方法摘要
protected Certificate(String type)
创建指定类型的证书。
方法摘要
boolean | equals(Object other) 比较此证书与指定对象的相等性。
abstract byte[] | getEncoded() 返回此证书的编码形式。
abstract PublicKey | getPublicKey() 从此证书中获取公钥。
String | getType() 返回此证书的类型。
int | hashCode() 根据此证书的编码形式返回该证书的哈希码值。
abstract String | toString() 返回此证书的字符串表示形式。
abstract void | verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。
protected Object | writeReplace() 替换要被序列化的 Certificate。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Certificate

protected Certificate(String type)
创建指定类型的证书。

参数：
type - 证书类型的标准名称。有关标准证书类型的信息，请参见 Java Cryptography Architecture API Specification & Reference 中的 Appendix A。
方法详细信息

getType

public final String getType()
返回此证书的类型。

返回：
此证书的类型。

equals

public boolean equals(Object other)
比较此证书与指定对象的相等性。如果 other 对象是一个 Certificate 实例，则获取其编码形式并且与此证书的编码形式进行比较。

覆盖：
类 Object 中的 equals
参数：
other - 要与此证书进行相等性测试的对象。
返回：
当且仅当两个证书的编码形式匹配时，返回 true；否则，返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
根据此证书的编码形式返回该证书的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getEncoded

public abstract byte[] getEncoded()
                           throws CertificateEncodingException
返回此证书的编码形式。假定每种证书类型只有一种编码形式；例如 X.509 证书将以 ASN.1 DER 的形式进行编码。

返回：
此证书的编码形式
抛出：
CertificateEncodingException - 如果出现编码错误。

verify

public abstract void verify(PublicKey key)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
验证是否已使用与指定公钥相应的私钥签署了此证书。

参数：
key - 用于进行验证的 PublicKey。
抛出：
NoSuchAlgorithmException - 如果签名算法不受支持。
InvalidKeyException - 如果 key 不正确。
NoSuchProviderException - 如果没有默认的提供者。
SignatureException - 如果出现签名错误。
CertificateException - 如果出现编码错误。

verify

public abstract void verify(PublicKey key,
                            String sigProvider)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
验证是否已使用与指定公钥相应的私钥签署了此证书。此方法使用指定提供者所提供的签名验证引擎。

参数：
key - 用于进行验证的 PublicKey。
sigProvider - 签名提供者的名称。
抛出：
NoSuchAlgorithmException - 如果签名算法不受支持。
InvalidKeyException - 如果 key 不正确。
NoSuchProviderException - 如果提供者不正确。
SignatureException - 如果出现签名错误。
CertificateException - 如果出现编码错误。

toString

public abstract String toString()
返回此证书的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此证书的字符串表示形式。

getPublicKey

public abstract PublicKey getPublicKey()
从此证书中获取公钥。

返回：
公钥。

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
替换要被序列化的 Certificate。

返回：
要序列化的对象的替换 Certificate 对象
抛出：
ObjectStreamException - 如果新对象表示无法创建此 Certificate
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Certificate.CertificateRep (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 Certificate.CertificateRep

java.lang.Object
    继承者  java.security.cert.Certificate.CertificateRep
所有已实现的接口：
Serializable
正在封闭类：
Certificate
protected static class Certificate.CertificateRep
extends Object
implements Serializable

用于序列化的替换 Certificate 类。

从以下版本开始：
1.3
另请参见：
序列化表格

构造方法摘要
protected Certificate.CertificateRep(String type, byte[] data)
构造带有 Certificate 类型和 Certificate 编码字节的替代 Certificate 类。
方法摘要
protected  Object readResolve()
解析该 Certificate 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Certificate.CertificateRep

protected Certificate.CertificateRep(String type,
                                     byte[] data)
构造带有 Certificate 类型和 Certificate 编码字节的替代 Certificate 类。

参数：
type - Certificate 类型的标准名称。

data - Certificate 数据。
方法详细信息

readResolve

protected Object readResolve()
                      throws ObjectStreamException
解析该 Certificate 对象。

返回：
解析后的 Certificate 对象
抛出：
ObjectStreamException - 如果无法解析该 Certificate
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateEncodingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertificateEncodingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertificateException
                    继承者  java.security.cert.CertificateEncodingException
所有已实现的接口：
Serializable
public class CertificateEncodingException
extends CertificateException

证书编码异常。每当试图对证书进行编码而出现错误时，就抛出此异常。

另请参见：
序列化表格

构造方法摘要
CertificateEncodingException()
构造不带详细消息的 CertificateEncodingException。
CertificateEncodingException(String message)
构造带指定详细消息的 CertificateEncodingException。
CertificateEncodingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateEncodingException。
CertificateEncodingException(Throwable cause)
创建带指定原因和详细消息的 CertificateEncodingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateEncodingException

public CertificateEncodingException()
构造不带详细消息的 CertificateEncodingException。详细消息是描述此特定异常的字符串。

CertificateEncodingException

public CertificateEncodingException(String message)
构造带指定详细消息的 CertificateEncodingException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。

CertificateEncodingException

public CertificateEncodingException(String message,
                                    Throwable cause)
创建带指定详细消息和原因的 CertificateEncodingException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

CertificateEncodingException

public CertificateEncodingException(Throwable cause)
创建带指定原因和详细消息的 CertificateEncodingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertificateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertificateException
所有已实现的接口：
Serializable
直接已知子类：
CertificateEncodingException, CertificateExpiredException, CertificateNotYetValidException, CertificateParsingException
public class CertificateException
extends GeneralSecurityException

此异常指示各种证书问题中的一种。

另请参见：
Certificate, 序列化表格

构造方法摘要
CertificateException()
构造不带详细消息的 Certificate 异常。
CertificateException(String msg)
构造带给定详细消息的 Certificate 异常。
CertificateException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateException。
CertificateException(Throwable cause)
创建带指定原因和详细消息的 CertificateException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateException

public CertificateException()
构造不带详细消息的 Certificate 异常。详细消息是描述此特定异常的字符串。

CertificateException

public CertificateException(String msg)
构造带给定详细消息的 Certificate 异常。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

CertificateException

public CertificateException(String message,
                            Throwable cause)
创建带指定详细消息和原因的 CertificateException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

CertificateException

public CertificateException(Throwable cause)
创建带指定原因和详细消息的 CertificateException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateExpiredException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertificateExpiredException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertificateException
                    继承者  java.security.cert.CertificateExpiredException
所有已实现的接口：
Serializable
public class CertificateExpiredException
extends CertificateException

证书过期异常。只要当前的 Date 或指定的 Date 超过证书有效期中所指定的 notAfter 日期/时间，就抛出此异常。

另请参见：
序列化表格

构造方法摘要
CertificateExpiredException()
构造不带详细消息的 CertificateExpiredException。
CertificateExpiredException(String message)
构造带指定详细消息的 CertificateExpiredException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateExpiredException

public CertificateExpiredException()
构造不带详细消息的 CertificateExpiredException。详细消息是描述此特定异常的字符串。

CertificateExpiredException

public CertificateExpiredException(String message)
构造带指定详细消息的 CertificateExpiredException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertificateFactory

java.lang.Object
    继承者  java.security.cert.CertificateFactory

public class CertificateFactory
extends Object

此类定义了用于从相关的编码中生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象的 CertificateFactory 功能。

为了实现多个证书组成的编码，如果要解析一个可能由多个不相关证书组成的集合时，应使用 generateCertificates。否则，如果要生成 CertPath（证书链）并随后使用 CertPathValidator 验证它，则应使用 generateCertPath。

X.509 的 CertificateFactory 返回的证书必须是 java.security.cert.X509Certificate 的实例，CRL 的 CertificateFactory 返回的证书则必须是 java.security.cert.X509CRL 的实例。

以下示例代码读取一个具有 Base64 编码证书的文件，该证书由 -----BEGIN CERTIFICATE----- 语句开始，由 -----END CERTIFICATE----- 语句结束。我们将 FileInputStream（它不支持 mark 和 reset）转换成 BufferedInputStream（它支持这些方法），这样每次调用 generateCertificate 只需要一个证书，并将输入流的读取位置定位在文件中的下一个证书处：

 FileInputStream fis = new FileInputStream(filename);
 BufferedInputStream bis = new BufferedInputStream(fis);

 CertificateFactory cf = CertificateFactory.getInstance("X.509");

 while (bis.available() > 0) {
    Certificate cert = cf.generateCertificate(bis);
    System.out.println(cert.toString());
 }

以下示例代码将解析存储在文件中的 PKCS#7 格式的证书答复，并从中提取所有的证书：

 FileInputStream fis = new FileInputStream(filename);
 CertificateFactory cf = CertificateFactory.getInstance("X.509");
 Collection c = cf.generateCertificates(fis);
 Iterator i = c.iterator();
 while (i.hasNext()) {
    Certificate cert = (Certificate)i.next();
    System.out.println(cert);
 }

从以下版本开始：
1.2
另请参见：
Certificate, X509Certificate, CertPath, CRL, X509CRL

构造方法摘要
protected CertificateFactory(CertificateFactorySpi certFacSpi, Provider provider, String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。
方法摘要
Certificate | generateCertificate(InputStream inStream) 生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends Certificate> | generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | generateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | generateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
CRL | generateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends CRL> | generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Iterator<String> | getCertPathEncodings() 返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
static CertificateFactory | getInstance(String type) 返回实现指定证书类型的 CertificateFactory 对象。
static CertificateFactory | getInstance(String type, Provider provider) 返回指定证书类型的 CertificateFactory 对象。
static CertificateFactory | getInstance(String type, String provider) 返回指定证书类型的 CertificateFactory 对象。
Provider | getProvider() 返回此 CertificateFactory 的提供者。
String | getType() 返回与此 CertificateFactory 关联的证书类型的名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertificateFactory

protected CertificateFactory(CertificateFactorySpi certFacSpi,
                             Provider provider,
                             String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。

参数：
certFacSpi - 提供者实现。
provider - 提供者。
type - 证书类型。
方法详细信息

getInstance

public static final CertificateFactory getInstance(String type)
                                            throws CertificateException
返回实现指定证书类型的 CertificateFactory 对象。

此方法从首选提供者开始遍历已注册安全提供者列表。返回封装 CertificateFactorySpi 实现的新 CertificateFactory 对象，该实现取自第一个支持指定类型的 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
type - 所请求的证书类型的名称。有关标准证书类型的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
返回：
指定类型的 CertificateFactory 对象。
抛出：
CertificateException - 如果没有 Provider 支持指定类型的 CertificateFactorySpi 实现。
另请参见：
Provider

getInstance

public static final CertificateFactory getInstance(String type,
                                                   String provider)
                                            throws CertificateException,
                                                   NoSuchProviderException
返回指定证书类型的 CertificateFactory 对象。

返回封装 CertificateFactorySpi 实现的新 CertificateFactory 对象，该实现取自指定提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
type - 证书类型。有关标准证书类型的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者的名称。
返回：
指定类型的 CertificateFactory 对象。
抛出：
CertificateException - 如果指定算法的 CertificateFactorySpi 实现不能从指定提供者获得。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static final CertificateFactory getInstance(String type,
                                                   Provider provider)
                                            throws CertificateException
返回指定证书类型的 CertificateFactory 对象。

返回封装 CertificateFactorySpi 实现的新 CertificateFactory 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象并不一定要在提供者列表中注册。

参数：
type - 证书类型。有关标准证书类型的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
provider - 提供者。
返回：
指定类型的 CertificateFactory 对象。
抛出：
CertificateException - 如果指定算法的 CertificateFactorySpi 实现不能从指定提供者对象获得。
IllegalArgumentException - 如果 provider 为 null。
从以下版本开始：
1.4
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 CertificateFactory 的提供者。

返回：
此 CertificateFactory 的提供者。

getType

public final String getType()
返回与此 CertificateFactory 关联的证书类型的名称。

返回：
与此 CertificateFactory 关联的证书类型的名称。

generateCertificate

public final Certificate generateCertificate(InputStream inStream)
                                      throws CertificateException
生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。

为了利用受此 CertificateFactory 支持的专门的证书格式，可将返回的证书对象的类型强制转换为相应的证书类。例如，如果此 CertificateFactory 实现 X.509 证书，则可将返回的证书对象的类型强制转换为 X509Certificate 类。

在用于 X.509 证书的 CertificateFactory 情况中，inStream 中提供的证书必须是 DER 编码的，并且可以用二进制或可打印的 (Base64) 编码形式提供。如果以 Base64 编码的形式提供该证书，则该证书必须由 -----BEGIN CERTIFICATE----- 语句开始，由 -----END CERTIFICATE----- 语句结束。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。否则，每次调用此方法都需要一个证书，并且将输入流的读取位置定位在固有的证书结尾标记后的下一个可用字节处。如果输入流中的数据不包含固有的证书结尾标记（不同于 EOF），并且在解析该证书后有一个尾随数据，则将抛出 CertificateException。

参数：
inStream - 带有证书数据的输入流。
返回：
已使用输入流中的数据初始化的证书对象。
抛出：
CertificateException - 如果发生解析错误。

getCertPathEncodings

public final Iterator<String> getCertPathEncodings()
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。有关标准编码名称及其格式的信息，请参见 Java Certification Path API Programmer's Guide 中的附录 A。

试图修改返回的 Iterator（通过其 remove 方法）会导致抛出 UnsupportedOperationException。

返回：
在受支持的 CertPath 编码名称（以 String 的形式）上进行迭代的 Iterator
从以下版本开始：
1.4

generateCertPath

public final CertPath generateCertPath(InputStream inStream)
                                throws CertificateException
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。假定数据是以默认编码方式进行编码的。默认编码名称是 getCertPathEncodings 方法返回的 Iterator 的第一个元素。

参数：
inStream - 包含数据的 InputStream
返回：
已使用 InputStream 中的数据初始化的 CertPath
抛出：
CertificateException - 如果解码时出现异常
从以下版本开始：
1.4

generateCertPath

public final CertPath generateCertPath(InputStream inStream,
                                       String encoding)
                                throws CertificateException
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。假定数据是以指定的编码方式进行编码的。有关标准编码名称及其格式的信息，请参见 Java Certification Path API Programmer's Guide 中的附录 A。

参数：
inStream - 包含数据的 InputStream
encoding - 数据使用的编码
返回：
已使用 InputStream 中的数据初始化的 CertPath
抛出：
CertificateException - 如果解码时出现异常或者不支持所请求的编码
从以下版本开始：
1.4

generateCertPath

public final CertPath generateCertPath(List<? extends Certificate> certificates)
                                throws CertificateException
生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。

所提供的证书必须是该 CertificateFactory 支持的类型。将从提供的 List 对象中复制出这些证书。

参数：
certificates - Certificate 的 List
返回：
已使用所提供的证书列表初始化的 CertPath
抛出：
CertificateException - 如果出现异常
从以下版本开始：
1.4

generateCertificates

public final Collection<? extends Certificate> generateCertificates(InputStream inStream)
                                                             throws CertificateException
返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。

为了利用此 CertificateFactory 所支持的特殊证书格式，可将返回的集合视图中的每个元素的类型强制转换为相应的证书类。例如，如果此 CertificateFactory 实现 X.509 证书，则可将返回集合中的元素的类型强制转换为 X509Certificate 类。

在用于 X.509 证书的 CertificateFactory 的情况中，inStream 可能包含一个 DER 编码的证书序列，这些证书使用 generateCertificate 所描述的格式。另外，inStream 可能包含一个 PKCS#7 证书链。这是一个 PKCS#7 SignedData 对象，具有唯一认可 的有效字段。需要特别指出的是，签名和内容会被忽略。此格式允许同时下载多个证书。如果没有证书，则返回一个空集合。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。

参数：
inStream - 带有证书的输入流。
返回：
java.security.cert.Certificate 对象的集合视图（可能为空），用输入流中的数据对该对象进行初始化。
抛出：
CertificateException - 如果发生解析错误。

generateCRL

public final CRL generateCRL(InputStream inStream)
                      throws CRLException
生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。

为了利用此受 CertificateFactory 支持的专门的 CRL 格式，可将返回的 CRL 对象的类型强制转换为相应的 CRL 类。例如，如果此 CertificateFactory 实现 X.509 CRL，则可将返回的 CRL 对象的类型强制转换为 X509CRL 类。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。否则，每次调用此方法都需要一个 CRL，并且将输入流的读取位置定位在固有 CRL 结尾标记后的下一个可用字节处。如果输入流中的数据不包含固有的 CRL 结尾标记（不同于 EOF），并且在解析该 CRL 后有一个尾随数据，则将抛出 CRLException。

参数：
inStream - 带有 CRL 数据的输入流。
返回：
已使用输入流中的数据初始化的 CRL 对象。
抛出：
CRLException - 如果发生解析错误。

generateCRLs

public final Collection<? extends CRL> generateCRLs(InputStream inStream)
                                             throws CRLException
返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。

为了利用受此 CertificateFactory 支持的专门的 CRL 格式，可将返回的集合视图中的每个元素的类型强制转换为相应的 CRL 类。例如，如果此 CertificateFactory 实现 X.509 CRL，则可将返回集合中的元素类型强制转换为 X509CRL 类。

在用于 X.509 CRL 的 CertificateFactory 情况中，inStream 可能包含一个 DER 编码的 CRL 序列。另外，inStream 可能包含一个 PKCS#7 CRL 集合。这是一个 PKCS#7 SignedData 对象，具有唯一被 crl 的有效字段。需要特别指出的是，签名和内容会被忽略。此格式允许同时下载多个 CRL。如果没有 CRL，则返回一个空集合。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。

参数：
inStream - 带有 CRL 的输入流。
返回：
java.security.cert.CRL 对象的集合视图（可能为空），用输入流中的数据对该对象进行初始化。
抛出：
CRLException - 如果发生解析错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateFactorySpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertificateFactorySpi

java.lang.Object
    继承者  java.security.cert.CertificateFactorySpi

public abstract class CertificateFactorySpi
extends Object

此类定义了 CertificateFactory 类的服务提供者接口 (SPI)。希望为特定的证书类型（如 X.509）提供 CertificateFactory 实现的每个加密服务提供者都必须实现此类中的所有抽象方法。

CertificateFactory 用于根据相关的编码生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象。

X.509 的 CertificateFactory 返回的证书必须是 java.security.cert.X509Certificate 的实例，CRL 的 CertificateFactory 返回的证书则必须是 java.security.cert.X509CRL 的实例。

从以下版本开始：
1.2
另请参见：
CertificateFactory, Certificate, X509Certificate, CertPath, CRL, X509CRL

构造方法摘要
CertificateFactorySpi()
方法摘要
abstract Certificate | engineGenerateCertificate(InputStream inStream) 生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends Certificate> | engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | engineGenerateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | engineGenerateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
abstract CRL | engineGenerateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends CRL> | engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Iterator<String> | engineGetCertPathEncodings() 返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertificateFactorySpi

public CertificateFactorySpi()
方法详细信息

engineGenerateCertificate

public abstract Certificate engineGenerateCertificate(InputStream inStream)
                                               throws CertificateException
生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。

为了利用此 CertificateFactory 所支持的专门的证书格式，可将返回的证书对象的类型强制转换为相应的证书类。例如，如果此 CertificateFactory 实现 X.509 证书，则可将返回的证书对象的类型强制转换为 X509Certificate 类。

在用于 X.509 证书的 CertificateFactory 情况中，inStream 中提供的证书必须是 DER 编码的，并且可以二进制或可打印的 (Base64) 编码形式提供。如果以 Base64 编码的形式提供该证书，则该证书必须由 -----BEGIN CERTIFICATE----- 语句开始，由 -----END CERTIFICATE----- 语句结束。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。否则，每次调用此方法都需要一个证书，并且将输入流的读取位置定位在固有证书结尾标记后的下一个可用字节处。如果输入流中的数据不包含固有的证书结尾标记（不同于 EOF），并且在解析该证书后有一个尾随数据，则抛出 CertificateException。

参数：
inStream - 带有证书数据的输入流。
返回：
已使用输入流中的数据初始化的证书对象。
抛出：
CertificateException - 如果发生解析错误。

engineGenerateCertPath

public CertPath engineGenerateCertPath(InputStream inStream)
                                throws CertificateException
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。假定数据是以默认编码方式进行编码的。

Java 2 Platform Standard Edition 的 1.4 版本中添加了此方法。为了维持与现有服务提供者的后向兼容性，无法 abstract 此方法，并且默认会抛出 UnsupportedOperationException。

参数：
inStream - 包含数据的 InputStream
返回：
已使用 InputStream 中的数据初始化的 CertPath
抛出：
CertificateException - 如果解码时出现异常
UnsupportedOperationException - 如果不支持此方法
从以下版本开始：
1.4

engineGenerateCertPath

public CertPath engineGenerateCertPath(InputStream inStream,
                                       String encoding)
                                throws CertificateException
生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。假定数据是以指定的编码方式进行编码的。

Java 2 Platform Standard Edition 的 1.4 版本中添加了此方法。为了维持与现有服务提供者的后向兼容性，无法 abstract 此方法，并且默认会抛出 UnsupportedOperationException。

参数：
inStream - 包含数据的 InputStream
encoding - 数据使用的编码
返回：
已使用 InputStream 中的数据初始化的 CertPath
抛出：
CertificateException - 如果解码时出现异常或者不支持所请求的编码
UnsupportedOperationException - 如果不支持此方法
从以下版本开始：
1.4

engineGenerateCertPath

public CertPath engineGenerateCertPath(List<? extends Certificate> certificates)
                                throws CertificateException
生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。

所提供的证书必须是该 CertificateFactory 所支持的类型。将从提供的 List 对象中复制出这些证书。

Java 2 Platform Standard Edition 的 1.4 版本中添加了此方法。为了维持与现有服务提供者的后向兼容性，无法 abstract 此方法，并且默认会抛出 UnsupportedOperationException。

参数：
certificates - Certificate 的 List
返回：
已使用所提供的证书列表初始化的 CertPath
抛出：
CertificateException - 如果出现异常
UnsupportedOperationException - 如果不支持此方法
从以下版本开始：
1.4

engineGetCertPathEncodings

public Iterator<String> engineGetCertPathEncodings()
返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。有关标准编码名称的信息，请参阅 Java Certification Path API Programmer's Guide 中的附录 A。

试图修改返回的 Iterator（通过其 remove 方法）会导致抛出 UnsupportedOperationException。

Java 2 Platform Standard Edition 的 1.4 版本中添加了此方法。为了维持与现有服务提供者的后向兼容性，无法 abstract 此方法，并且默认会抛出 UnsupportedOperationException。

返回：
在受支持的 CertPath 编码名称（以 String 的形式）上进行迭代的 Iterator
抛出：
UnsupportedOperationException - 如果不支持此方法
从以下版本开始：
1.4

engineGenerateCertificates

public abstract Collection<? extends Certificate> engineGenerateCertificates(InputStream inStream)
                                                                      throws CertificateException
返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。

为了利用此 CertificateFactory 所支持的专门的证书格式，可将返回的集合视图中的每个元素的类型强制转换为相应的证书类。例如，如果此 CertificateFactory 实现 X.509 证书，则可将返回集合中的元素的类型强制转换为 X509Certificate 类。

在用于 X.509 证书的 CertificateFactory 情况中，inStream 可能包含单个 DER 编码的证书，这些证书使用 generateCertificate 所描述的格式。另外，inStream 可能包含一个 PKCS#7 证书链。这是一个 PKCS#7 SignedData 对象，具有惟一认可 的有效字段。需要特别指出的是，签名和内容会被忽略。此格式允许同时下载多个证书。如果没有证书，则返回一个空集合。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。

参数：
inStream - 带有证书的输入流。
返回：
java.security.cert.Certificate 对象的集合视图（可能为空），用输入流中的数据对该对象进行初始化。
抛出：
CertificateException - 如果发生解析错误。

engineGenerateCRL

public abstract CRL engineGenerateCRL(InputStream inStream)
                               throws CRLException
生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。

为了利用此 CertificateFactory 所支持的专门的 CRL 格式，可将返回的 CRL 对象的类型强制转换为相应的 CRL 类。例如，如果此 CertificateFactory 实现 X.509 CRL，则可将返回的 CRL 对象的类型强制转换为 X509CRL 类。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。否则，每次调用此方法都需要一个 CRL，并且将输入流的读取位置定位在固有 CRL 结尾标记后的下一个可用字节处。如果输入流中的数据不包含固有的 CRL 结尾标记（不同于 EOF），并且在解析该 CRL 后有一个尾随数据，则抛出 CRLException。

参数：
inStream - 带有 CRL 数据的输入流。
返回：
已使用输入流中的数据初始化的 CRL 对象。
抛出：
CRLException - 如果发生解析错误。

engineGenerateCRLs

public abstract Collection<? extends CRL> engineGenerateCRLs(InputStream inStream)
                                                      throws CRLException
返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。

为了利用此 CertificateFactory 所支持的专门的 CRL 格式，可将返回的集合视图中的每个元素的类型强制转换为相应的 CRL 类。例如，如果此 CertificateFactory 实现 X.509 CRL，则可将返回集合中的元素类型强制转换为 X509CRL 类。

在用于 X.509 CRL 的 CertificateFactory 情况中，inStream 可能包含单个 DER 编码的 CRL。另外，inStream 可能包含一个 PKCS#7 CRL 集合。这是一个 PKCS#7 SignedData 对象，具有惟一被 crl 的有效字段。需要特别指出的是，签名和内容会被忽略。此格式允许同时下载多个 CRL。如果没有 CRL，则返回一个空集合。

注意，如果给定的输入流不支持 mark 和 reset，则此方法将使用整个输入流。

参数：
inStream - 带有 CRL 的输入流。
返回：
java.security.cert.CRL 对象的集合视图（可能为空），用输入流中的数据对该对象进行初始化。
抛出：
CRLException - 如果发生解析错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateNotYetValidException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertificateNotYetValidException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertificateException
                    继承者  java.security.cert.CertificateNotYetValidException
所有已实现的接口：
Serializable
public class CertificateNotYetValidException
extends CertificateException

证书尚无效异常。只要当前的 Date 或指定的 Date 在证书有效期中的 notBefore 日期/时间之前，就抛出此异常。

另请参见：
序列化表格

构造方法摘要
CertificateNotYetValidException()
构造不带详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateNotYetValidException

public CertificateNotYetValidException()
构造不带详细消息的 CertificateNotYetValidException。详细消息是描述此特定异常的字符串。

CertificateNotYetValidException

public CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateParsingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertificateParsingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertificateException
                    继承者  java.security.cert.CertificateParsingException
所有已实现的接口：
Serializable
public class CertificateParsingException
extends CertificateException

证书解析异常。只要解析了无效的 DER 编码证书或者在该 Certificate 中发现了不受支持的 DER 功能，就抛出此异常。

另请参见：
序列化表格

构造方法摘要
CertificateParsingException()
构造不带详细消息的 CertificateParsingException。
CertificateParsingException(String message)
构造带指定详细消息的 CertificateParsingException。
CertificateParsingException(String message, Throwable cause)
创建带指定详细消息和原因的 CertificateParsingException。
CertificateParsingException(Throwable cause)
创建带指定原因和详细消息的 CertificateParsingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateParsingException

public CertificateParsingException()
构造不带详细消息的 CertificateParsingException。详细消息是描述此特定异常的字符串。

CertificateParsingException

public CertificateParsingException(String message)
构造带指定详细消息的 CertificateParsingException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。

CertificateParsingException

public CertificateParsingException(String message,
                                   Throwable cause)
创建带指定详细消息和原因的 CertificateParsingException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出 cause 是不存在的或是未知的。）
从以下版本开始：
1.5

CertificateParsingException

public CertificateParsingException(Throwable cause)
创建带指定原因和详细消息的 CertificateParsingException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出 cause 是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPath (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPath

java.lang.Object
    继承者  java.security.cert.CertPath
所有已实现的接口：
Serializable
public abstract class CertPath
extends Object
implements Serializable

不可变的证书序列（证书路径）。

这是一个抽象类，定义了常用于所有 CertPath 的方法。其子类可处理不同类型的证书（X.509、PGP 等等）。

所有 CertPath 对象都包含类型、Certificate 列表及其支持的一种或多种编码。由于 CertPath 类是不可变的，所以构造 CertPath 后无法以任何外部可见的方式更改它。此规定适用于此类的所有公共字段和方法，以及由子类添加或重写的所有公共字段和方法。

类型是标识证书路径中 Certificate 类型的一个 String。对于证书路径 certPath 中的每个证书 cert 而言，cert.getType().equals(certPath.getType()) 必须为 true。

Certificate 列表是零个或多个 Certificate 的有序 List。此 List 和其中所包含的所有 Certificate 都必须是不可变的。

每个 CertPath 对象必须支持一种或多种编码方式，这样可将对象转换成 byte 数组进行存储，或传输给其他方。这些编码最好应该具有记录良好的标准（例如 PKCS#7）。将 CertPath 支持的某种编码视为默认编码。如果没有显式地请求编码（例如，getEncoded() 方法），则使用此编码。

所有 CertPath 对象都是 Serializable。在序列化期间将 CertPath 对象解析为一个替换的 CertPathRep 对象。这就允许不管 CertPath 对象的基础实现如何，都可以将该对象序列化为等效的表示形式。

可使用 CertificateFactory 创建 CertPath 对象，或者可通过其他类（如 CertPathBuilder）返回这些对象。

按照惯例，X.509 CertPath（由 X509Certificate 组成）的顺序按照从目标证书开始，从信任的定位点所发布的证书结束。也就是说，证书的发布方是以下某个主体。表示 TrustAnchor 的证书不应包括在证书路径中。未验证的 X.509 CertPath 可能不遵循这些约定。PKIX CertPathValidator 将检测任何与这些约定的偏差，这些偏差会导致证书路径无效并且抛出 CertPathValidatorException。

并发访问

所有 CertPath 对象必须是线程安全的。也就是说，多个线程在单个 CertPath 对象（或多个对象）上并发调用此类中所定义的各种方法不会产生坏的影响。对于 CertPath.getCertificates 返回的 List 也应如此。

要求 CertPath 对象是不可变的并且是线程安全的，就允许将其传递到各种代码片断中，而无需担心协调访问。通常提供此种线程安全性并不难，因为相关的 CertPath 和 List 对象都是不可变的。

从以下版本开始：
1.4
另请参见：
CertificateFactory, CertPathBuilder, 序列化表格

嵌套类摘要
protected static class CertPath.CertPathRep
用于序列化的替换 CertPath 类。
构造方法摘要
protected CertPath(String type)
创建指定类型的 CertPath。
方法摘要
boolean | equals(Object other) 比较此证书路径与指定对象的相等性。
abstract List<? extends Certificate> | getCertificates() 返回此证书路径中的证书列表。
abstract byte[] | getEncoded() 返回此证书路径的编码形式，使用默认的编码。
abstract byte[] | getEncoded(String encoding) 返回此证书路径的编码形式，使用指定的编码。
abstract Iterator<String> | getEncodings() 返回此证书路径支持的编码的迭代，默认编码方式优先。
String | getType() 返回此证书路径中的 Certificate 类型。
int | hashCode() 返回此证书路径的哈希码。
String | toString() 返回此证书路径的字符串表示形式。
protected Object | writeReplace() 使用 CertPathRep 对象替换要被序列化的 CertPath。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertPath

protected CertPath(String type)
创建指定类型的 CertPath。

此构造方法是受保护的，因为大多数用户应该使用 CertificateFactory 来创建 CertPath。

参数：
type - 此路径中 Certificate 类型的标准名称
方法详细信息

getType

public String getType()
返回此证书路径中的 Certificate 类型。这与 cert.getType() 为证书路径中的所有 Certificate 所返回的字符串相同。

返回：
此证书路径中的 Certificate 类型（从不为 null）

getEncodings

public abstract Iterator<String> getEncodings()
返回此证书路径支持的编码的迭代，默认编码方式优先。试图修改返回的 Iterator（通过其 remove 方法）会导致抛出 UnsupportedOperationException。

返回：
在受支持的编码的名称（以 String 的形式）上进行迭代的 Iterator

equals

public boolean equals(Object other)
比较此证书路径与指定对象的相等性。当且仅当两个 CertPath 的类型相等并且其证书 List（通过模拟这些 List 中的 Certificate）相等时，这两个 CertPath 才相等。CertPath 不会等于一个非 CertPath 对象。

此方法实现此种算法。如果重写此方法，则必须维护在此指定的行为。

覆盖：
类 Object 中的 equals
参数：
other - 要与此证书路径进行相等性测试的对象
返回：
如果指定的对象等于此证书路径，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此证书路径的哈希码。证书路径的哈希码定义为以下计算的结果：

  hashCode = path.getType().hashCode();
  hashCode = 31*hashCode + path.getCertificates().hashCode();
这确保对于任意两个证书路径 path1 和 path2 而言，path1.equals(path2) 就意味着 path1.hashCode()==path2.hashCode()，正如 Object.hashCode 的常规协定所要求的那样。

覆盖：
类 Object 中的 hashCode
返回：
此证书路径的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此证书路径的字符串表示形式。这会在路径中的每个 Certificate 上调用 toString 方法。

覆盖：
类 Object 中的 toString
返回：
此证书路径的字符串表示形式

getEncoded

public abstract byte[] getEncoded()
                           throws CertificateEncodingException
返回此证书路径的编码形式，使用默认的编码。

返回：
已编码的字节
抛出：
CertificateEncodingException - 如果发生编码错误

getEncoded

public abstract byte[] getEncoded(String encoding)
                           throws CertificateEncodingException
返回此证书路径的编码形式，使用指定的编码。

参数：
encoding - 要使用的编码名称
返回：
已编码的字节
抛出：
CertificateEncodingException - 如果发生编码错误或者编码请求不受支持

getCertificates

public abstract List<? extends Certificate> getCertificates()
返回此证书路径中的证书列表。返回的 List 必须是不可变的和线程安全的。

返回：
一个不可变的 Certificate List（可以为空，但是不能为 null）

writeReplace

protected Object writeReplace()
                       throws ObjectStreamException
使用 CertPathRep 对象替换要被序列化的 CertPath。

返回：
要被序列化的 CertPathRep
抛出：
ObjectStreamException - 如果不能创建表示此证书路径的 CertPathRep 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPath.CertPathRep (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPath.CertPathRep

java.lang.Object
    继承者  java.security.cert.CertPath.CertPathRep
所有已实现的接口：
Serializable
正在封闭类：
CertPath
protected static class CertPath.CertPathRep
extends Object
implements Serializable

用于序列化的替换 CertPath 类。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
protected CertPath.CertPathRep(String type, byte[] data)
创建具有指定证书路径类型和编码形式的 CertPathRep。
方法摘要
protected  Object readResolve()
返回根据类型和数据所构造的 CertPath。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertPath.CertPathRep

protected CertPath.CertPathRep(String type,
                               byte[] data)
创建具有指定证书路径类型和编码形式的 CertPathRep。

参数：
type - CertPath 类型的标准名称
data - 证书路径的编码形式
方法详细信息

readResolve

protected Object readResolve()
                      throws ObjectStreamException
返回根据类型和数据所构造的 CertPath。

返回：
解析后的 CertPath 对象
抛出：
ObjectStreamException - 如果无法构造 CertPath
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathBuilder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPathBuilder

java.lang.Object
    继承者  java.security.cert.CertPathBuilder

public class CertPathBuilder
extends Object

构建证书路径（也称为证书链）的类。

此类使用基于提供者的架构。要创建一个 CertPathBuilder，应调用某个 static getInstance 方法、传入所需的 CertPathBuilder 算法名称，或者所需的提供者名称。

一旦创建了 CertPathBuilder 对象，则可以通过调用 build 方法并传递一个特定于算法的参数集来构造证书路径。如果成功，则在一个实现 CertPathBuilderResult 接口的对象中返回结果（包括已构建的 CertPath）。

并发访问

可保证此类的 static 方法是线程安全的。多个线程可以并发调用此类中定义的 static 方法，而不会产生什么坏的影响。

但是，对于此类所定义的非 static 方法并非如此。除非具体的提供者另行指定，否则需要并发访问单个 CertPathBuilder 实例的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同 CertPathBuilder 实例的多个线程而言，则无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPath

构造方法摘要
protected CertPathBuilder(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。
方法摘要
CertPathBuilderResult | build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
String | getAlgorithm() 返回此 CertPathBuilder 的算法名称。
static String | getDefaultType() 返回 Java 安全属性文件中所指定的默认 CertPathBuilder 类型，如果没有此属性，则返回字符串 "PKIX"。
static CertPathBuilder | getInstance(String algorithm) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathBuilder | getInstance(String algorithm, Provider provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathBuilder | getInstance(String algorithm, String provider) 返回实现了指定算法的 CertPathBuilder 对象。
Provider | getProvider() 返回此 CertPathBuilder 的提供者。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertPathBuilder

protected CertPathBuilder(CertPathBuilderSpi builderSpi,
                          Provider provider,
                          String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。

参数：
builderSpi - 提供者实现
provider - 提供者
algorithm - 算法名称
方法详细信息

getInstance

public static CertPathBuilder getInstance(String algorithm)
                                   throws NoSuchAlgorithmException
返回实现了指定算法的 CertPathBuilder 对象。

此方法从首选 Provider 开始，遍历已注册安全提供者列表。返回一个封装 CertPathBuilderSpi 实现的新 CertPathBuilder 对象，该实现取自第一个支持指定算法的 Provider。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

参数：
algorithm - 所请求的 CertPathBuilder 算法名称。有关标准算法名称的信息，请参阅 Java Certification Path API Programmer's Guide 的附录 A。
返回：
实现了指定算法的 CertPathBuilder 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 CertPathBuilderSpi 实现。
另请参见：
Provider

getInstance

public static CertPathBuilder getInstance(String algorithm,
                                          String provider)
                                   throws NoSuchAlgorithmException,
                                          NoSuchProviderException
返回实现了指定算法的 CertPathBuilder 对象。

返回一个封装 CertPathBuilderSpi 实现的新 CertPathBuilder 对象，该实现取自指定的提供者。指定的提供者必须已在安全提供者列表中注册。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

参数：
algorithm - 所请求的 CertPathBuilder 算法名称。有关标准算法名称的信息，请参阅 Java Certification Path API Programmer's Guide 的附录 A。
provider - 提供者的名称。
返回：
实现了指定算法的 CertPathBuilder 对象。
抛出：
NoSuchAlgorithmException - 如果无法从指定提供者获得指定算法的 CertPathBuilderSpi 实现。
NoSuchProviderException - 如果指定提供者没有在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static CertPathBuilder getInstance(String algorithm,
                                          Provider provider)
                                   throws NoSuchAlgorithmException
返回实现了指定算法的 CertPathBuilder 对象。

返回一个封装 CertPathBuilderSpi 实现的新 CertPathBuilder 对象，该实现取自指定 Provider 对象。注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求的 CertPathBuilder 算法名称。有关标准算法名称的信息，请参阅 Java Certification Path API Programmer's Guide 的附录 A。
provider - 提供者。
返回：
实现了指定算法的 CertPathBuilder 对象
抛出：
NoSuchAlgorithmException - 如果无法从指定 Provider 对象获得指定算法的 CertPathBuilderSpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 CertPathBuilder 的提供者。

返回：
此 CertPathBuilder 的提供者

getAlgorithm

public final String getAlgorithm()
返回此 CertPathBuilder 的算法名称。

返回：
此 CertPathBuilder 的算法名称

build

public final CertPathBuilderResult build(CertPathParameters params)
                                  throws CertPathBuilderException,
                                         InvalidAlgorithmParameterException
尝试使用指定的算法参数集构建一个证书路径。

参数：
params - 算法参数
返回：
构建算法的结果
抛出：
CertPathBuilderException - 如果该生成器无法构造一个满足指定参数要求的证书路径
InvalidAlgorithmParameterException - 如果指定的参数不适合此 CertPathBuilder

getDefaultType

public static final String getDefaultType()
返回 Java 安全属性文件中所指定的默认 CertPathBuilder 类型，如果没有此属性，则返回字符串 "PKIX"。Java 安全属性文件位于名为 <JAVA_HOME>/lib/security/java.security 文件中。 <JAVA_HOME> 引用 java.home 系统属型的值，并指定安装 JRE 的目录。

如果调用某个 getInstance 方法时不希望使用硬编码 CertPathBuilder 类型，并且在用户未指定所用 CertPathBuilder 类型的情况下希望提供默认类型的应用程序，那么可以使用默认的 CertPathBuilder 类型。

通过将 "certpathbuilder.type" 安全属性（在 Java 安全属性文件中）的值设置为所需的类型，这样就可以更改默认的 CertPathBuilder 类型。

返回：
Java 安全属性文件中指定的默认 CertPathBuilder 类型，如果没有此属性，则返回字符串 "PKIX"。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathBuilderException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPathBuilderException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertPathBuilderException
所有已实现的接口：
Serializable
public class CertPathBuilderException
extends GeneralSecurityException

指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。

CertPathBuilderException 提供了对包装异常的支持。getCause 方法返回导致此异常抛出的 throwable（如果有）。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。每个线程都操作单独对象的多个线程无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPathBuilder, 序列化表格

构造方法摘要
CertPathBuilderException()
创建详细消息为 null 的 CertPathBuilderException。
CertPathBuilderException(String msg)
创建带给定详细消息的 CertPathBuilderException。
CertPathBuilderException(String msg, Throwable cause)
创建带指定详细消息和原因的 CertPathBuilderException。
CertPathBuilderException(Throwable cause)
创建包装指定 throwable 的 CertPathBuilderException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertPathBuilderException

public CertPathBuilderException()
创建详细消息为 null 的 CertPathBuilderException。

CertPathBuilderException

public CertPathBuilderException(String msg)
创建带给定详细消息的 CertPathBuilderException。详细消息是更为详细地描述此特定异常的 String。

参数：
msg - 详细消息

CertPathBuilderException

public CertPathBuilderException(Throwable cause)
创建包装指定 throwable 的 CertPathBuilderException。这就允许将任何异常都转换成 CertPathBuilderException，同时保留有关已包装异常的信息，而这些信息可能对调试很有用。将详细消息设置为：(cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许使用 null 值，并指出 cause 是不存在的或是未知的。）

CertPathBuilderException

public CertPathBuilderException(String msg,
                                Throwable cause)
创建带指定详细消息和原因的 CertPathBuilderException。

参数：
msg - 详细消息
cause - cause（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许使用 null 值，并指出 cause 是不存在的或是未知的。）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathBuilderResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 CertPathBuilderResult

所有超级接口：
Cloneable
所有已知实现类：
PKIXCertPathBuilderResult
public interface CertPathBuilderResult
extends Cloneable

证书路径生成器算法的结果的规范。CertPathBuilder.build 方法返回的所有结果必须实现此接口。

CertPathBuilderResult 至少会包含由 CertPathBuilder 实例所构造的 CertPath。此接口的实现可以添加方法，以返回实现或算法的具体信息，如调试信息或证书路径的验证结果。

并发访问

除非另行指定，否则此接口中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。每个线程都操作单独对象的多个线程无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPathBuilder

方法摘要
Object | clone() 对此 CertPathBuilderResult 进行复制。
CertPath | getCertPath() 返回已构建的证书路径。

方法详细信息

getCertPath

CertPath getCertPath()
返回已构建的证书路径。

返回：
证书路径（不会为 null）

clone

Object clone()
对此 CertPathBuilderResult 进行复制。对副本的更改不会影响原件，反之亦然。

返回：
此 CertPathBuilderResult 的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathBuilderSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPathBuilderSpi

java.lang.Object
    继承者  java.security.cert.CertPathBuilderSpi

public abstract class CertPathBuilderSpi
extends Object

CertPathBuilder 类的服务提供者接口 (SPI)。所有 CertPathBuilder 实现必须包括扩展此类 (CertPathBuilderSpi) 并实现其所有方法的类（SPI 类）。通常，只应通过 CertPathBuilder 类来访问此类的实例。有关细节，请参阅《Java Cryptography Architecture》。

并发访问

对于多个线程的并发访问，无需保护此类的实例。需要并发访问单个 CertPathBuilderSpi 实例的多个线程应该在它们之间实现同步并在调用包装的 CertPathBuilder 对象前提供所需的锁定。

但是 CertPathBuilderSpi 的实现仍可能遇到并发问题，因为每个线程都操作一个不同 CertPathBuilderSpi 实例的多个线程无需实现同步。

从以下版本开始：
1.4

构造方法摘要
CertPathBuilderSpi()
默认的构造方法。
方法摘要
abstract  CertPathBuilderResult engineBuild(CertPathParameters params)
尝试使用指定的算法参数集构建一个证书路径。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertPathBuilderSpi

public CertPathBuilderSpi()
默认的构造方法。

方法详细信息

engineBuild

public abstract CertPathBuilderResult engineBuild(CertPathParameters params)
                                           throws CertPathBuilderException,
                                                  InvalidAlgorithmParameterException
尝试使用指定的算法参数集构建一个证书路径。

参数：
params - 算法参数
返回：
构建算法的结果
抛出：
CertPathBuilderException - 如果该生成器无法构造一个满足指定参数要求的证书路径
InvalidAlgorithmParameterException - 如果指定的参数不适合此 CertPathBuilder
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 CertPathParameters

所有超级接口：
Cloneable
所有已知实现类：
PKIXBuilderParameters, PKIXParameters
public interface CertPathParameters
extends Cloneable

证书路径算法参数的规范。此接口的目的是对所有 CertPath 参数规范进行分组（并为之提供类型安全）。所有 CertPath 参数规范必须实现此接口。

从以下版本开始：
1.4
另请参见：
CertPathValidator.validate(CertPath, CertPathParameters), CertPathBuilder.build(CertPathParameters)

方法摘要
 Object clone()
对此 CertPathParameters 进行复制。

方法详细信息

clone

Object clone()
对此 CertPathParameters 进行复制。对副本的更改不会影响原件，反之亦然。

返回：
此 CertPathParameters 的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathValidator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPathValidator

java.lang.Object
    继承者  java.security.cert.CertPathValidator

public class CertPathValidator
extends Object

验证证书路径（也称为证书链）的类。

此类使用基于提供者的架构。要创建一个 CertPathValidator，应调用某个 static getInstance 方法、传入所需的 CertPathValidator 算法名称，

一旦创建了 CertPathValidator 对象，就可使用它来验证证书路径，方法是调用 validate 方法并向其传递要验证的 CertPath 和一个特定于算法的参数集。如果验证成功，则在一个实现了 CertPathValidatorResult 接口的对象中返回结果。

并发访问

可保证此类的 static 方法是线程安全的。多个线程可以并发调用此类中所定义的 static 方法，而不会产生什么恶果。

但是，对于此类所定义的非 static 方法并非如此。除非具体的提供者另行指定，否则需要并发访问单个 CertPathValidator 实例的多个线程应该在它们之间实现同步并提供所需的锁定。如果对每个线程都操作一个不同 CertPathValidator 实例的多个线程而言，则无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPath

构造方法摘要
protected CertPathValidator(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。
方法摘要
String | getAlgorithm() 返回此 CertPathValidator 的算法名称。
static String | getDefaultType() 返回 Java 安全属性文件中所指定的默认 CertPathValidator 类型，如果没有此属性，则返回字符串 "PKIX"。
static CertPathValidator | getInstance(String algorithm) 返回实现了指定算法的 CertPathValidator 对象。
static CertPathValidator | getInstance(String algorithm, Provider provider) 返回实现指定算法的 CertPathValidator 对象。
static CertPathValidator | getInstance(String algorithm, String provider) 返回实现指定算法的 CertPathValidator 对象。
Provider | getProvider() 返回此 CertPathValidator 的 Provider。
CertPathValidatorResult | validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertPathValidator

protected CertPathValidator(CertPathValidatorSpi validatorSpi,
                            Provider provider,
                            String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。

参数：
validatorSpi - 提供者实现
provider - 提供者
algorithm - 算法名称
方法详细信息

getInstance

public static CertPathValidator getInstance(String algorithm)
                                     throws NoSuchAlgorithmException
返回实现了指定算法的 CertPathValidator 对象。

此方法从首选 Provider 开始，遍历已注册安全提供者列表。返回一个封装 CertPathValidatorSpi 实现的新 CertPathValidator 对象，该实现取自第一个支持指定算法的 Provider。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

参数：
algorithm - 所请求的 CertPathValidator 算法名称。有关标准算法名称的信息，请参阅 Java Certification Path API Programmer's Guide 的附录 A。
返回：
实现了指定算法的 CertPathValidator 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 CertPathValidatorSpi 实现。
另请参见：
Provider

getInstance

public static CertPathValidator getInstance(String algorithm,
                                            String provider)
                                     throws NoSuchAlgorithmException,
                                            NoSuchProviderException
返回实现指定算法的 CertPathValidator 对象。

返回一个封装 CertPathValidatorSpi 实现的新 CertPathValidator 对象，该实现取自指定的提供者。指定的提供者必须已在安全提供者列表中注册。

注意，已注册提供者列表可以通过 Security.getProviders() 方法获得。

参数：
algorithm - 所请求的 CertPathValidator 算法名称。有关标准算法名称的信息，请参阅 Java Certification Path API Programmer's Guide 的附录 A。
provider - 提供者的名称。
返回：
实现指定算法的 CertPathValidator 对象。
抛出：
NoSuchAlgorithmException - 如果无法从指定提供者获得指定算法的 CertPathValidatorSpi 实现。
NoSuchProviderException - 如果指定提供者没有在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static CertPathValidator getInstance(String algorithm,
                                            Provider provider)
                                     throws NoSuchAlgorithmException
返回实现指定算法的 CertPathValidator 对象。

返回一个封装 CertPathValidatorSpi 实现的新 CertPathValidator 对象，该实现取自指定的 Provider 对象。注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求的 CertPathValidator 算法名称。有关标准算法名称的信息，请参阅 Java Certification Path API Programmer's Guide 的附录 A。
provider - 提供者。
返回：
实现指定算法的 CertPathValidator 对象。
抛出：
NoSuchAlgorithmException - 如果无法从指定 Provider 对象获得指定算法的 CertPathValidatorSpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 CertPathValidator 的 Provider。

返回：
此 CertPathValidator 的 Provider

getAlgorithm

public final String getAlgorithm()
返回此 CertPathValidator 的算法名称。

返回：
此 CertPathValidator 的算法名称

validate

public final CertPathValidatorResult validate(CertPath certPath,
                                              CertPathParameters params)
                                       throws CertPathValidatorException,
                                              InvalidAlgorithmParameterException
使用指定的算法参数集验证指定的证书路径。

所指定的 CertPath 必须是该验证算法支持的类型，否则抛出 InvalidAlgorithmParameterException。例如，实现 PKIX 算法的 CertPathValidator 将验证 X.509 类型的 CertPath 对象。

参数：
certPath - 要验证的 CertPath
params - 算法参数
返回：
验证算法的结果
抛出：
CertPathValidatorException - 如果 CertPath 未通过验证
InvalidAlgorithmParameterException - 如果指定的参数或指定 CertPath 的类型不适合此 CertPathValidator

getDefaultType

public static final String getDefaultType()
返回 Java 安全属性文件中所指定的默认 CertPathValidator 类型，如果没有此属性，则返回字符串 "PKIX"。Java 安全属性文件位于名为 <JAVA_HOME>/lib/security/java.security 文件中。 <JAVA_HOME> 引用 java.home 系统属型的值，并指定安装 JRE 的目录。

如果调用某个 getInstance 方法时不希望使用硬编码 CertPathValidator 类型，并且在用户未指定所用 CertPathValidator 类型的情况下希望提供默认类型的应用程序，那么可以使用默认的 CertPathValidator 类型。

通过将 "certpathvalidator.type" 安全属性（在 Java 安全属性文件中）的值设置为所需的类型，就可以更改默认的 CertPathValidator 类型。

返回：
Java 安全属性文件中指定的默认 CertPathValidator 类型，如果没有此属性，则返回字符串 "PKIX"。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathValidatorException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPathValidatorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertPathValidatorException
所有已实现的接口：
Serializable
public class CertPathValidatorException
extends GeneralSecurityException

指示在验证一个证书路径时遇到了某种问题的异常。

CertPathValidatorException 提供了对包装异常的支持。getCause 方法返回导致此异常抛出的 throwable（如果有的话）。

CertPathValidatorException 可能还包括异常抛出时所验证的证书路径，以及导致该异常抛出的证书在证书路径中的索引。使用 getCertPath 和 getIndex 方法可获取此信息。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPathValidator, 序列化表格

构造方法摘要
CertPathValidatorException()
创建不带详细消息的 CertPathValidatorException。
CertPathValidatorException(String msg)
创建带给定详细消息的 CertPathValidatorException。
CertPathValidatorException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertPathValidatorException。
CertPathValidatorException(String msg, Throwable cause, CertPath certPath, int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。
CertPathValidatorException(Throwable cause)
创建包装指定 throwable 的 CertPathValidatorException。
方法摘要
CertPath | getCertPath() 返回抛出异常时正在验证的证书路径
int | getIndex() 返回导致该异常抛出的证书在证书路径中的索引。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertPathValidatorException

public CertPathValidatorException()
创建不带详细消息的 CertPathValidatorException。

CertPathValidatorException

public CertPathValidatorException(String msg)
创建带给定详细消息的 CertPathValidatorException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息

CertPathValidatorException

public CertPathValidatorException(Throwable cause)
创建包装指定 throwable 的 CertPathValidatorException。这就允许将任何异常转换成 CertPathValidatorException，同时保留有关已包装异常的信息，而这些信息可能对调试很有用。将详细消息设置为：(cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许使用 null 值，并指出 cause 是不存在的或是未知的。）

CertPathValidatorException

public CertPathValidatorException(String msg,
                                  Throwable cause)
创建带指定详细消息和 cause 的 CertPathValidatorException。

参数：
msg - 详细消息
cause - cause（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许使用 null 值，并指出 cause 是不存在的或是未知的。）

CertPathValidatorException

public CertPathValidatorException(String msg,
                                  Throwable cause,
                                  CertPath certPath,
                                  int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。

参数：
msg - 详细消息（如果没有则为 null）
cause - cause（如果没有则为 null）
certPath - 遇到错误时正在验证的证书路径
index - 导致错误的证书在证书路径中的索引（如果不适用，则为 -1）。注意，CertPath 中的证书列表是基于零的。
抛出：
IndexOutOfBoundsException - 如果 index 超出范围 (index < -1 || (certPath != null && index >= certPath.getCertificates().size())
IllegalArgumentException - 如果 certPath 为 null 并且 index 不是 -1
方法详细信息

getCertPath

public CertPath getCertPath()
返回抛出异常时正在验证的证书路径

返回：
抛出异常时正在验证的 CertPath（如果未指定则返回 null）

getIndex

public int getIndex()
返回导致该异常抛出的证书在证书路径中的索引。注意，CertPath 中的证书列表是基于零的。如果尚未设置索引，则返回 -1。

返回：
已设置的索引，如果尚未设置索引，则返回 -1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathValidatorResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 CertPathValidatorResult

所有超级接口：
Cloneable
所有已知实现类：
PKIXCertPathBuilderResult, PKIXCertPathValidatorResult
public interface CertPathValidatorResult
extends Cloneable

证书路径验证器算法的结果的规范。

此接口的目的是对所有证书路径验证器结果进行分组（并为之提供类型安全）。CertPathValidator.validate 方法返回的所有结果必须实现此接口。

从以下版本开始：
1.4
另请参见：
CertPathValidator

方法摘要
 Object clone()
对此 CertPathValidatorResult 进行复制。

方法详细信息

clone

Object clone()
对此 CertPathValidatorResult 进行复制。对副本的更改不会影响原件，反之亦然。

返回：
此 CertPathValidatorResult 的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertPathValidatorSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertPathValidatorSpi

java.lang.Object
    继承者  java.security.cert.CertPathValidatorSpi

public abstract class CertPathValidatorSpi
extends Object

CertPathValidator 类的服务提供者接口 (SPI)。所有 CertPathValidator 实现必须包括扩展此类 (CertPathValidatorSpi) 并实现其所有方法的类（SPI 类）。通常，只应通过 CertPathValidator 类来访问此类的实例。有关细节，请参阅 Java Cryptography Architecture。

并发访问

对于多个线程的并发访问，无需保护此类的实例。需要并发访问单个 CertPathValidatorSpi 实例的多个线程应该在它们之间实现同步并在调用包装的 CertPathValidator 对象前提供所需的锁定。

但是 CertPathValidatorSpi 的实现仍可能遇到并发问题，因为对于每个线程都操作一个不同 CertPathValidatorSpi 实例的多个线程而言，无需实现同步。

从以下版本开始：
1.4

构造方法摘要
CertPathValidatorSpi()
默认的构造方法。
方法摘要
abstract  CertPathValidatorResult engineValidate(CertPath certPath, CertPathParameters params)
使用指定的算法参数集验证指定的证书路径。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertPathValidatorSpi

public CertPathValidatorSpi()
默认的构造方法。

方法详细信息

engineValidate

public abstract CertPathValidatorResult engineValidate(CertPath certPath,
                                                       CertPathParameters params)
                                                throws CertPathValidatorException,
                                                       InvalidAlgorithmParameterException
使用指定的算法参数集验证指定的证书路径。

所指定的 CertPath 必须是该验证算法所支持的类型，否则会抛出 InvalidAlgorithmParameterException。例如，实现 PKIX 算法的 CertPathValidator 会验证 X.509 类型的 CertPath 对象。

参数：
certPath - 要被验证的 CertPath
params - 算法参数
返回：
验证算法的结果
抛出：
CertPathValidatorException - 如果 CertPath 未通过验证
InvalidAlgorithmParameterException - 如果指定的参数或指定 CertPath 的类型不适合此 CertPathValidator
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertSelector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 CertSelector

所有超级接口：
Cloneable
所有已知实现类：
X509CertSelector
public interface CertSelector
extends Cloneable

一个定义了一套选择 Certificate 的标准的选择器。实现此接口的类通常用于指定从 CertStore 中获取哪些 Certificate。

并发访问

除非另行指定，否则此接口中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。每个线程都操作单独对象的多个线程无需实现同步。

从以下版本开始：
1.4
另请参见：
Certificate, CertStore, CertStore.getCertificates(java.security.cert.CertSelector)

方法摘要
Object | clone() 对此 CertSelector 进行复制。
boolean | match(Certificate cert) 决定是否应该选择某个 Certificate。

方法详细信息

match

boolean match(Certificate cert)
决定是否应该选择某个 Certificate。

参数：
cert - 要检查的 Certificate
返回：
如果应该选择该 Certificate，则返回 true；否则返回 false

clone

Object clone()
对此 CertSelector 进行复制。对副本的更改不会影响原件，反之亦然。

返回：
此 CertSelector 的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertStore (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertStore

java.lang.Object
    继承者  java.security.cert.CertStore

public class CertStore
extends Object

用于从存储库中获取 Certificate 和 CRL 的类。

此类使用基于提供者的架构。要创建一个 CertStore，可调用其中一个静态 getInstance 方法，并传入所需的 CertStore 类型、任何适用的初始化参数，以及所需提供者名称（可选）。

创建了 CertStore 以后，就可以通过调用其 getCertificates 和 getCRLs 方法来获取 Certificate 和 CRL。

CertStore 与 KeyStore 不同，KeyStore 提供对私钥和可信任证书缓存的访问，而 CertStore 提供对不可信任证书和 CRL 存储库（可能很大）的访问。例如，CertStore 的 LDAP 实现使用 LDAP 协议和 RFC 服务属性中定义的方案，提供对存储在一个或多个目录中的证书和 CRL 的访问。有关标准 CertStore 类型的更多信息，请参见 Java Certification Path API Programmer's Guide 中的附录 A。

并发访问

所有 CertStore 对象的公共方法必须是线程安全的。也就是说，多个线程可以在单个 CertStore 对象（或多个对象）上并发调用这些方法，而不产生任何不良影响。例如，允许 CertPathBuilder 在搜索 CRL 的同时搜索其他证书。

还应确保此类的静态方法是线程安全的。多个线程可以并发调用此类中所定义的静态方法，而不产生任何不良影响。

从以下版本开始：
1.4

构造方法摘要
protected CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。
方法摘要
Collection<? extends Certificate> | getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
CertStoreParameters | getCertStoreParameters() 返回初始化此 CertStore 所用的参数。
Collection<? extends CRL> | getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
static String | getDefaultType() 返回 Java 安全属性文件中指定的默认 CertStore 类型；如果没有此属性，则返回字符串 "LDAP"。
static CertStore | getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
Provider | getProvider() 返回此 CertStore 的提供者。
String | getType() 返回此 CertStore 的类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertStore

protected CertStore(CertStoreSpi storeSpi,
                    Provider provider,
                    String type,
                    CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。

参数：
storeSpi - 提供者实现
provider - 提供者
type - 类型
params - 初始化参数（可以为 null）
方法详细信息

getCertificates

public final Collection<? extends Certificate> getCertificates(CertSelector selector)
                                                        throws CertStoreException
返回与指定选择器匹配的 Certificate 的 Collection。如果没有与此选择器匹配的 Certificate，则返回一个空 Collection。

对于某些 CertStore 类型，得到的 Collection 可能并不包含与选择器匹配的所有 Certificate。例如，LDAP CertStore 可能并不搜索目录中的所有条目。相反，它只搜索那些可能包含要查找的 Certificate 的条目。

如果没有提供一个包含用于查找证书的特定标准的非 null CertSelector，那么某些 CertStore 实现（特别是 LDAP CertStore）将抛出 CertStoreException。发布方和/或主体名称是特别有用的标准。

参数：
selector - 用于选择应该返回哪些 Certificate 的 CertSelector。指定 null 表示返回所有 Certificate（如果支持）。
返回：
与指定选择器匹配的 Certificate 的 Collection（不为 null）
抛出：
CertStoreException - 如果发生异常

getCRLs

public final Collection<? extends CRL> getCRLs(CRLSelector selector)
                                        throws CertStoreException
返回与指定选择器匹配的 CRL 的 Collection。如果没有与此选择器匹配的 CRL，则返回一个空 Collection。

对于某些 CertStore 类型，得到的 Collection 可能并不包含与选择器匹配的所有 CRL。例如，LDAP CertStore 可能并不搜索目录中的所有条目。相反，它只搜索那些可能包含要查找的 CRL 的条目。

如果没有提供一个包含用于查找 CRL 的特定标准的非 null CRLSelector，那么某些 CertStore 实现（特别是 LDAP CertStore）将抛出 CertStoreException。发布方名称和/或要检查的证书特别有用。

参数：
selector - 用于选择应该返回哪些 CRL 的 CRLSelector。指定 null 表示返回所有 CRL（如果支持）。
返回：
与指定选择器匹配的 CRL 的 Collection（不为 null）
抛出：
CertStoreException - 如果发生异常

getInstance

public static CertStore getInstance(String type,
                                    CertStoreParameters params)
                             throws InvalidAlgorithmParameterException,
                                    NoSuchAlgorithmException
返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 CertStoreSpi 实现的新 CertStore 对象，该实现取自第一个支持指定类型的 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

使用指定的 CertStoreParameters 初始化返回的 CertStore。不同类型的 CertStore 所需的参数类型有所不同。注意，指定的 CertStoreParameters 对象将被复制。

参数：
type - 请求的 CertStore 类型的名称。有关标准类型的信息，请参阅 Java Certification Path API Programmer's Guide 中的附录 A。
params - 初始化参数（可以为 null）。
返回：
实现指定 CertStore 类型的 CertStore 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定类型的 CertStoreSpi 实现。
InvalidAlgorithmParameterException - 如果指定的初始化参数不适合此 CertStore。
另请参见：
Provider

getInstance

public static CertStore getInstance(String type,
                                    CertStoreParameters params,
                                    String provider)
                             throws InvalidAlgorithmParameterException,
                                    NoSuchAlgorithmException,
                                    NoSuchProviderException
返回一个实现指定 CertStore 类型的 CertStore 对象。

返回一个封装 CertStoreSpi 实现的新 CertStore 对象，该实现取自指定提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

使用指定的 CertStoreParameters 初始化返回的 CertStore。不同类型的 CertStore 所需的参数类型有所不同。注意，指定的 CertStoreParameters 对象将被复制。

参数：
type - 请求的 CertStore 类型。有关标准类型的信息，请参阅 Java Certification Path API Programmer's Guide 中的附录 A。
params - 初始化参数（可以为 null）。
provider - 提供者名称。
返回：
实现指定类型的 CertStore 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定的提供者获得指定类型的 CertStoreSpi 实现。
InvalidAlgorithmParameterException - 如果指定的初始化参数不适合此 CertStore。
NoSuchProviderException - 如果指定的提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static CertStore getInstance(String type,
                                    CertStoreParameters params,
                                    Provider provider)
                             throws NoSuchAlgorithmException,
                                    InvalidAlgorithmParameterException
返回一个实现指定 CertStore 类型的 CertStore 对象。

返回一个封装 CertStoreSpi 实现的新 CertStore 对象，该实现取自指定 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

使用指定的 CertStoreParameters 初始化返回的 CertStore。不同类型的 CertStore 所需的参数类型有所不同。注意，指定的 CertStoreParameters 对象将被复制。

参数：
type - 请求的 CertStore 类型。有关标准类型的信息，请参阅 Java Certification Path API Programmer's Guide 中的附录 A。
params - 初始化参数（可以为 null）。
provider - 提供者。
返回：
实现指定类型的 CertStore 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定 Provider 对象获得指定类型的 CertStoreSpi 实现。
InvalidAlgorithmParameterException - 如果指定的初始化参数不适合此 CertStore
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getCertStoreParameters

public final CertStoreParameters getCertStoreParameters()
返回初始化此 CertStore 所用的参数。注意，CertStoreParameters 对象返回之前将被复制。

返回：
初始化此 CertStore 所用的参数（可以为 null）

getType

public final String getType()
返回此 CertStore 的类型。

返回：
此 CertStore 的类型

getProvider

public final Provider getProvider()
返回此 CertStore 的提供者。

返回：
此 CertStore 的提供者

getDefaultType

public static final String getDefaultType()
返回 Java 安全属性文件中指定的默认 CertStore 类型；如果没有此属性，则返回字符串 "LDAP"。Java 安全属性文件位于指定的 <JAVA_HOME>/lib/security/java.security 文件中。<JAVA_HOME> 引用 java.home 系统属性的值，并指定安装 JRE 的目录。

调用某个 getInstance 方法时不希望使用固定编码 (hard-coded) CertStore 类型的应用程序，以及用户未指定所用 CertStore 类型时希望提供默认 CertStore 类型的应用程序可以使用默认 CertStore 类型。

通过将 "certstore.type" 安全属性（在 Java 安全属性文件中）的值设置为所需的类型，可以更改默认的 CertStore 类型。

返回：
Java 安全属性文件中指定的默认 CertStore 类型；如果没有此属性，则返回字符串 "LDAP"。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertStoreException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertStoreException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CertStoreException
所有已实现的接口：
Serializable
public class CertStoreException
extends GeneralSecurityException

指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。

CertStoreException 提供了对包装异常的支持。getCause 方法返回导致此异常抛出的 throwable（如果有）。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertStore, 序列化表格

构造方法摘要
CertStoreException()
创建详细消息为 null 的 CertStoreException。
CertStoreException(String msg)
创建带指定详细消息的 CertStoreException。
CertStoreException(String msg, Throwable cause)
创建带指定详细消息和 cause 的 CertStoreException。
CertStoreException(Throwable cause)
创建包装指定 throwable 的 CertStoreException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertStoreException

public CertStoreException()
创建详细消息为 null 的 CertStoreException。

CertStoreException

public CertStoreException(String msg)
创建带指定详细消息的 CertStoreException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息

CertStoreException

public CertStoreException(Throwable cause)
创建包装指定 throwable 的 CertStoreException。这就允许将任何异常转换成 CertStoreException，同时保留有关异常 cause 的信息，而这些信息可能对调试很有用。将详细消息设置为：(cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许使用 null 值，并指出 cause 是不存在的或是未知的。）

CertStoreException

public CertStoreException(String msg,
                          Throwable cause)
创建带指定详细消息和 cause 的 CertStoreException。

参数：
msg - 详细消息
cause - cause（保存此 cause，以便以后通过 getCause() 方法获取它）。（允许使用 null 值，并指出 cause 是不存在的或是未知的。）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertStoreParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 CertStoreParameters

所有超级接口：
Cloneable
所有已知实现类：
CollectionCertStoreParameters, LDAPCertStoreParameters
public interface CertStoreParameters
extends Cloneable

CertStore 参数的规范。

此接口的目的是对所有 CertStore 参数规范进行分组（并为之提供类型安全）。所有 CertStore 参数规范必须实现此接口。

通常将 CertStoreParameters 对象作为参数传递到某个 CertStore.getInstance 方法中。getInstance 方法返回一个用于获取 Certificate 和 CRL 的 CertStore。使用指定的参数初始化返回的 CertStore。不同类型的 CertStore 所需的参数类型有所不同。

从以下版本开始：
1.4
另请参见：
CertStore.getInstance(java.lang.String, java.security.cert.CertStoreParameters)

方法摘要
 Object clone()
对此 CertStoreParameters 进行复制。

方法详细信息

clone

Object clone()
对此 CertStoreParameters 进行复制。

“副本”的准确含义可能依赖于 CertStoreParameters 对象的类。典型的实现会执行此对象的“深层复制”，但这不是绝对要求。某些实现可能执行此对象的某些或全部字段的“浅表复制”。

注意，CertStore.getInstance 方法对指定的 CertStoreParameters 进行复制。clone 的深层复制实现更为安全并且更为可靠，因为它可防止调用者随后因修改其初始化参数内容而损坏共享的 CertStore。但是 clone 的浅表复制实现更适合于那些需要保持对 CertStoreParameters 中所含参数的引用的应用程序。例如，浅表复制的 clone 允许应用程序立即释放特定 CertStore 初始化参数的资源，而不是等待垃圾回收机制开始工作。对此应万分小心，因为其他线程可能仍在使用 CertStore。

每个子类都应该声明此方法的准确行为，这样用户和开发人员才能知道以后的行为。

返回：
此 CertStoreParameters 的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertStoreSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CertStoreSpi

java.lang.Object
    继承者  java.security.cert.CertStoreSpi

public abstract class CertStoreSpi
extends Object

CertStore 类的服务提供者接口 (SPI)。所有 CertStore 实现必须包括一个类（SPI 类），该类扩展此类 (CertStoreSpi) 、提供一个具有单个 CertStoreParameters 类型参数的构造方法，并实现其所有方法。通常，只应通过 CertStore 类来访问此类的实例。有关细节，请参阅 Java Cryptography Architecture。

并发访问

所有 CertStoreSpi 对象的公共方法必须是线程安全的。也就是说，多个线程在单个 CertStoreSpi 对象（或多个对象）上并发调用这些方法而不会产生坏的影响。例如，这就允许 CertPathBuilder 搜索 CRL 的同时搜索其他的证书。

简单的 CertStoreSpi 实现可能会确保线程安全性，方法是向其 engineGetCertificates 和 engineGetCRLs 方法添加 synchronized 关键字。更复杂的实现可能允许真正并发的访问。

从以下版本开始：
1.4

构造方法摘要
CertStoreSpi(CertStoreParameters params)
唯一的构造方法。
方法摘要
abstract Collection<? extends Certificate> | engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
abstract Collection<? extends CRL> | engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertStoreSpi

public CertStoreSpi(CertStoreParameters params)
             throws InvalidAlgorithmParameterException
唯一的构造方法。

参数：
params - 初始化参数（可以为 null）
抛出：
InvalidAlgorithmParameterException - 如果初始化参数不适合此 CertStoreSpi
方法详细信息

engineGetCertificates

public abstract Collection<? extends Certificate> engineGetCertificates(CertSelector selector)
                                                                 throws CertStoreException
返回与指定选择器匹配的 Certificate 的 Collection。如果没有与此选择器匹配的 Certificate，则返回一个空 Collection。

对于某些 CertStore 类型，得到的 Collection 可能不包含与该选择器匹配的所有 Certificate。例如，LDAP CertStore 可能不搜索目录中的所有项。相反，它可能只搜索那些很可能包含正要查找的 Certificate 的项。

如果未提供一个包括了用于查找证书的具体标准的非 null CertSelector，则某些 CertStore 实现（特别是 LDAP CertStore）可能抛出 CertStoreException。发布方和/或主体名称是特别有用的标准。

参数：
selector - 用于选择应该返回哪些 Certificate 的 CertSelector。指定 null 返回所有的 Certificate（如果受支持的话）。
返回：
与指定选择器匹配的 Certificate 的 Collection（不会为 null）
抛出：
CertStoreException - 如果出现异常

engineGetCRLs

public abstract Collection<? extends CRL> engineGetCRLs(CRLSelector selector)
                                                 throws CertStoreException
返回与指定选择器匹配的 CRL 的 Collection。如果没有与此选择器匹配的 CRL，则返回一个空 Collection。

对于某些 CertStore 类型，得到的 Collection 可能不包含与该选择器匹配的所有 CRL。例如，LDAP CertStore 可能不搜索目录中的所有项。相反，它可能只搜索那些很可能包含正要查找的 CRL 的项。

如果未提供一个包括了用于查找 CRL 的具体标准的非 null CRLSelector，则某些 CertStore 实现（特别是 LDAP CertStore）可能抛出 CertStoreException。发布方名称和/或要检查的证书特别有用。

参数：
selector - 用于选择应该返回哪些 CRL 的 CRLSelector。指定 null 返回所有的 CRL（如果受支持的话）。
返回：
与指定选择器匹配的 CRL 的 Collection（不会为 null）
抛出：
CertStoreException - 如果出现异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CollectionCertStoreParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CollectionCertStoreParameters

java.lang.Object
    继承者  java.security.cert.CollectionCertStoreParameters
所有已实现的接口：
Cloneable, CertStoreParameters
public class CollectionCertStoreParameters
extends Object
implements CertStoreParameters

用作 Collection CertStore 算法输入的参数。

此类用于为 Collection CertStore 算法的实现提供必需的配置参数。此类中所包括的唯一参数是 Collection，CertStore 将从中获取证书和 CRL。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
Collection, CertStore

构造方法摘要
CollectionCertStoreParameters()
创建具有默认参数值（一个空的并且不可变的 Collection）的 CollectionCertStoreParameters 的实例
CollectionCertStoreParameters(Collection<?> collection)
创建 CollectionCertStoreParameters 的一个实例，它允许从指定的 Collection 中获取证书和 CRL。
方法摘要
Object | clone() 返回此对象的副本。
Collection<?> | getCollection() 返回从中获取 Certificate 和 CRL 的 Collection。
String | toString() 返回描述该参数的格式化字符串。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CollectionCertStoreParameters

public CollectionCertStoreParameters(Collection<?> collection)
创建 CollectionCertStoreParameters 的一个实例，它允许从指定的 Collection 中获取证书和 CRL。如果指定的 Collection 包含不是 Certificate 或 CRL 的对象，则该 Collection CertStore 将忽略该对象。

该 Collection 不是复制的。相反，使用的是一个引用。这就允许调用方随后从 Collection 中添加或移除 Certificates 或 CRL，从而更改 CertStore 可用的 Certificates 或 CRL 集。Collection CertStore 不会修改该 Collection 的内容。

如果某个线程修改此 Collection 的同时，另一个线程正在调用已使用此 Collection 初始化的 Collection CertStore 方法，则该 Collection 必须具有快速失败的迭代器。

参数：
collection - Certificate 和 CRL 的 Collection
抛出：
NullPointerException - 如果 collection 为 null

CollectionCertStoreParameters

public CollectionCertStoreParameters()
创建具有默认参数值（一个空的并且不可变的 Collection）的 CollectionCertStoreParameters 的实例

方法详细信息

getCollection

public Collection<?> getCollection()
返回从中获取 Certificate 和 CRL 的 Collection。这不是该 Collection 的副本，它是一个引用。这就允许调用方随后从该 Collection 中添加或移除 Certificates 或 CRL。

返回：
Collection（不会为 null）

clone

public Object clone()
返回此对象的副本。注意，仅复制对该 Collection 引用，而不复制内容。

指定者：
接口 CertStoreParameters 中的 clone
覆盖：
类 Object 中的 clone
返回：
副本
另请参见：
Cloneable

toString

public String toString()
返回描述该参数的格式化字符串。

覆盖：
类 Object 中的 toString
返回：
描述该参数的格式化字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CRL (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CRL

java.lang.Object
    继承者  java.security.cert.CRL
直接已知子类：
X509CRL
public abstract class CRL
extends Object

此类是具有不同格式但很常用的证书撤消列表 (CRL) 的抽象。例如，所有 CRL 都具有列出已取消证书的功能，并且可以就是否列出了给定的证书进行查询。

通过扩展此抽象类可以定义专门的 CRL 类型。

从以下版本开始：
1.2
另请参见：
X509CRL, CertificateFactory

构造方法摘要
protected CRL(String type)
创建指定类型的 CRL。
方法摘要
String | getType() 返回此 CRL 的类型。
abstract boolean | isRevoked(Certificate cert) 检查给定的证书是否在此 CRL 中。
abstract String | toString() 返回此 CRL 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CRL

protected CRL(String type)
创建指定类型的 CRL。

参数：
type - CRL 类型的标准名称。有关标准 CRL 类型的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。
方法详细信息

getType

public final String getType()
返回此 CRL 的类型。

返回：
此 CRL 的类型。

toString

public abstract String toString()
返回此 CRL 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 CRL 的字符串表示形式。

isRevoked

public abstract boolean isRevoked(Certificate cert)
检查给定的证书是否在此 CRL 中。

参数：
cert - 要检查的证书。
返回：
如果给定的证书在此 CRL 中，则返回 true，否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CRLException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 CRLException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.cert.CRLException
所有已实现的接口：
Serializable
public class CRLException
extends GeneralSecurityException

CRL（证书撤消列表）异常。

另请参见：
序列化表格

构造方法摘要
CRLException()
构造不带详细消息的 CRLException。
CRLException(String message)
构造带指定详细消息的 CRLException。
CRLException(String message, Throwable cause)
创建带指定详细消息和 cause 的 CRLException。
CRLException(Throwable cause)
创建带指定 cause 和详细消息的 CRLException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CRLException

public CRLException()
构造不带详细消息的 CRLException。详细消息是描述此特定异常的字符串。

CRLException

public CRLException(String message)
构造带指定详细消息的 CRLException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。

CRLException

public CRLException(String message,
                    Throwable cause)
创建带指定详细消息和 cause 的 CRLException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出 cause 是不存在的或是未知的。）
从以下版本开始：
1.5

CRLException

public CRLException(Throwable cause)
创建带指定 cause 和详细消息的 CRLException，详细消息是 (cause==null ? null :cause.toString())（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指出 cause 是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyNode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 PolicyNode

public interface PolicyNode

PKIX 证书路径验证算法所定义的、不可变的有效策略树节点。

PKIX 证书路径验证算法的输出是有效策略树，其中包括确定为有效的策略、如何实现该确定，以及遇到的所有策略限定符。此树的深度为 n，其中 n 是已验证的证书路径的长度。

大多数应用程序无需检验有效策略树。它们可以通过设置 PKIXParameters 中与策略相关的参数来获得其策略处理目标。但是，大多数复杂的应用程序都可使用有效策略树，特别是那些处理策略限定符的应用程序。

PKIXCertPathValidatorResult.getPolicyTree 返回有效策略树的根节点。可使用 getChildren 和 getParent 方法遍历该树。可使用 PolicyNode 的其他方法来获取有关特定节点的数据。

并发访问

所有 PolicyNode 对象必须是不可变的和线程安全的。多个线程在单个 PolicyNode 对象（或多个对象）上并发调用此类中所定义的各种方法不会产生坏的影响。此规定适用于此类的所有公共字段和方法，以及由子类添加或重写的所有公共字段和方法。

从以下版本开始：
1.4

方法摘要
Iterator<? extends PolicyNode> | getChildren() 返回在此节点的子节点上进行迭代的迭代器。
int | getDepth() 返回有效策略树中此节点的深度。
Set<String> | getExpectedPolicies() 返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。
PolicyNode | getParent() 返回此节点的父节点，如果此节点是根节点，则返回 null。
Set<? extends PolicyQualifierInfo> | getPolicyQualifiers() 返回与此节点所表示的有效策略相关联的策略限定符集。
String | getValidPolicy() 返回此节点所表示的有效策略。
boolean | isCritical() 返回最近处理的证书中其证书策略扩展的关键性指示符。

方法详细信息

getParent

PolicyNode getParent()
返回此节点的父节点，如果此节点是根节点，则返回 null。

返回：
此节点的父节点，如果此节点是根节点，则返回 null

getChildren

Iterator<? extends PolicyNode> getChildren()
返回在此节点的子节点上进行迭代的迭代器。任何试图通过该 Iterator 的 remove 方法来修改此节点的子节点的行为都必须抛出 UnsupportedOperationException。

返回：
在此节点的子节点上进行迭代的迭代器

getDepth

int getDepth()
返回有效策略树中此节点的深度。

返回：
此节点的深度（0 代表根节点，1 代表其子节点，依此类推）

getValidPolicy

String getValidPolicy()
返回此节点所表示的有效策略。

返回：
此节点所表示的有效策略的 String OID，或者是特殊值 "any-policy"。对于根节点，此方法始终返回特殊值 "any-policy"。

getPolicyQualifiers

Set<? extends PolicyQualifierInfo> getPolicyQualifiers()
返回与此节点所表示的有效策略相关联的策略限定符集。

返回：
一个不可变的 PolicyQualifierInfo Set。对于根节点，此方法始终返回一个空 Set。

getExpectedPolicies

Set<String> getExpectedPolicies()
返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。

返回：
一个不可变的预期策略 String OID 的 Set，或者具有单个特殊值 "any-policy" 的不可变 Set。对于根节点，此方法始终返回具有单个值 "any-policy" 的 Set。

isCritical

boolean isCritical()
返回最近处理的证书中其证书策略扩展的关键性指示符。

返回：
如果扩展标记为关键的，则返回 true；否则返回 false。对于根节点，此方法始终返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CRLSelector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 CRLSelector

所有超级接口：
Cloneable
所有已知实现类：
X509CRLSelector
public interface CRLSelector
extends Cloneable

一个定义了一套选择 CRL 的标准的选择器。实现此接口的类通常用于指定应该从 CertStore 中获取哪些 CRL。

并发访问

除非另行指定，否则此接口中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CRL, CertStore, CertStore.getCRLs(java.security.cert.CRLSelector)

方法摘要
Object | clone() 对此 CRLSelector 进行复制。
boolean | match(CRL crl) 决定是否应该选择某个 CRL。

方法详细信息

match

boolean match(CRL crl)
决定是否应该选择某个 CRL。

参数：
crl - 要检查的 CRL
返回：
如果应该选择该 CRL，则返回 true，否则返回 false

clone

Object clone()
对此 CRLSelector 进行复制。对副本的更改不会影响原件，反之亦然。

返回：
此 CRLSelector 的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LDAPCertStoreParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 LDAPCertStoreParameters

java.lang.Object
    继承者  java.security.cert.LDAPCertStoreParameters
所有已实现的接口：
Cloneable, CertStoreParameters
public class LDAPCertStoreParameters
extends Object
implements CertStoreParameters

用作 LDAP CertStore 算法的输入的参数。

此类用于为 LDAP CertStore 算法的实现提供必需的配置参数（服务器名称和端口号）。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertStore

构造方法摘要
LDAPCertStoreParameters()
创建具有默认参数值（服务器名称 "localhost"，端口 389）的 LDAPCertStoreParameters 的实例。
LDAPCertStoreParameters(String serverName)
创建具有指定服务器名称和默认端口 389 的 LDAPCertStoreParameters 的实例。
LDAPCertStoreParameters(String serverName, int port)
创建具有指定参数值的 LDAPCertStoreParameters 的实例。
方法摘要
Object | clone() 返回此对象的副本。
int | getPort() 返回 LDAP 服务器的端口号。
String | getServerName() 返回 LDAP 服务器的 DNS 名称。
String | toString() 返回描述该参数的格式化字符串。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LDAPCertStoreParameters

public LDAPCertStoreParameters(String serverName,
                               int port)
创建具有指定参数值的 LDAPCertStoreParameters 的实例。

参数：
serverName - LDAP 服务器的 DNS 名称
port - LDAP 服务器的端口号
抛出：
NullPointerException - 如果 serverName 为 null

LDAPCertStoreParameters

public LDAPCertStoreParameters(String serverName)
创建具有指定服务器名称和默认端口 389 的 LDAPCertStoreParameters 的实例。

参数：
serverName - LDAP 服务器的 DNS 名称
抛出：
NullPointerException - 如果 serverName 为 null

LDAPCertStoreParameters

public LDAPCertStoreParameters()
创建具有默认参数值（服务器名称 "localhost"，端口 389）的 LDAPCertStoreParameters 的实例。

方法详细信息

getServerName

public String getServerName()
返回 LDAP 服务器的 DNS 名称。

返回：
名称（不能为 null）

getPort

public int getPort()
返回 LDAP 服务器的端口号。

返回：
端口号

clone

public Object clone()
返回此对象的副本。对副本的更改不会影响原件，反之亦然。

注：此方法目前对该对象执行浅表复制（只是调用 Object.clone()）。如果添加了不应共享的新参数，则在以后的修订本中可能对此进行更改，以执行深层复制。

指定者：
接口 CertStoreParameters 中的 clone
覆盖：
类 Object 中的 clone
返回：
副本
另请参见：
Cloneable

toString

public String toString()
返回描述该参数的格式化字符串。

覆盖：
类 Object 中的 toString
返回：
描述该参数的格式化字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PKIXBuilderParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 PKIXBuilderParameters

java.lang.Object
    继承者  java.security.cert.PKIXParameters
        继承者  java.security.cert.PKIXBuilderParameters
所有已实现的接口：
Cloneable, CertPathParameters
public class PKIXBuilderParameters
extends PKIXParameters

用作 PKIX CertPathBuilder 算法的输入的参数。

PKIX CertPathBuilder 使用这些参数构建一个已根据 PKIX 证书路径验证算法验证的 CertPath。

要实例化 PKIXBuilderParameters 对象，应用程序必须指定一个或多个由 PKIX 证书路径验证算法所定义的最受信任的 CA。可以使用两个构造方法中的一个来指定最受信任的 CA。应用程序可以调用 PKIXBuilderParameters(Set, CertSelector) 来指定一个 TrustAnchor 对象 Set，其中每个对象都标识一个最受信任的 CA。另外，应用程序也可调用 PKIXBuilderParameters(KeyStore, CertSelector) 来指定一个 KeyStore 实例，其中包含多个受信任的证书项，每个项都认为是一个最受信任的 CA。

另外，应用程序必须指定有关目标证书的限制，CertPathBuilder 将试图为该目标证书构建路径。以 CertSelector 对象的形式指定这些限制。这些限制应该为 CertPathBuilder 提供足够的搜索标准以找到该目标证书。X509Certificate 的最小标准通常包括了主体名称和/或一个或多个主体替换名称。如果未指定足够的标准，则 CertPathBuilder 可能抛出 CertPathBuilderException。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPathBuilder

构造方法摘要
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
方法摘要
int | getMaxPathLength() 返回证书路径中可能存在的中间非自发布证书的最大数目值。
void | setMaxPathLength(int maxPathLength) 设置证书路径中可能存在的非自发中间证书的最大数目值。
String | toString() 返回描述该参数的格式化字符串。
从类 java.security.cert.PKIXParameters 继承的方法
addCertPathChecker, addCertStore, clone, getCertPathCheckers, getCertStores, getDate, getInitialPolicies, getPolicyQualifiersRejected, getSigProvider, getTargetCertConstraints, getTrustAnchors, isAnyPolicyInhibited, isExplicitPolicyRequired, isPolicyMappingInhibited, isRevocationEnabled, setAnyPolicyInhibited, setCertPathCheckers, setCertStores, setDate, setExplicitPolicyRequired, setInitialPolicies, setPolicyMappingInhibited, setPolicyQualifiersRejected, setRevocationEnabled, setSigProvider, setTargetCertConstraints, setTrustAnchors
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PKIXBuilderParameters

public PKIXBuilderParameters(Set<TrustAnchor> trustAnchors,
                             CertSelector targetConstraints)
                      throws InvalidAlgorithmParameterException
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。该 set 中的每个元素都是一个 TrustAnchor。

注意，为了保护该 Set 以防后续修改，会复制该 Set。

参数：
trustAnchors - 一个 TrustAnchor Set
targetConstraints - 指定有关目标证书限制的 CertSelector
抛出：
InvalidAlgorithmParameterException - 如果 trustAnchors 为空 (trustAnchors.isEmpty() == true)
NullPointerException - 如果 trustAnchors 为 null
ClassCastException - 如果 trustAnchors 的任一元素不是 java.security.cert.TrustAnchor 类型的

PKIXBuilderParameters

public PKIXBuilderParameters(KeyStore keystore,
                             CertSelector targetConstraints)
                      throws KeyStoreException,
                             InvalidAlgorithmParameterException
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。只考虑那些包含受信任 X509Certificate 的 keystore 项；忽略所有其他证书类型。

参数：
keystore - 一个 KeyStore，将根据它来生成最受信任的 CA 集
targetConstraints - 指定有关目标证书限制的 CertSelector
抛出：
KeyStoreException - 如果尚未初始化 keystore
InvalidAlgorithmParameterException - 如果 keystore 不包含受信的证书项
NullPointerException - 如果 keystore 为 null
方法详细信息

setMaxPathLength

public void setMaxPathLength(int maxPathLength)
设置证书路径中可能存在的非自发中间证书的最大数目值。如果主体和发布方字段中出现的 DN 相同并且不为空，则该证书是自发布的。注意，证书路径中最后一个证书不是中间证书，并且不受此限制的约束。通常最后一个证书是一个结束实体证书，但它可能是一个 CA 证书。PKIX CertPathBuilder 实例所构建的路径不能超过所指定的长度。

值为 0 意味着该路径只包含单个证书。值为 -1 则意味着该路径长度是不受约束的（即没有最大值）。如果未指定，则默认的最大路径长度是 5。设置小于 -1 的值将导致抛出异常。

如果任意 CA 证书包含 BasicConstraintsExtension，那么只要结果是一个更短长度的证书路径，则扩展的 pathLenConstraint 字段覆盖最大路径长度参数。

参数：
maxPathLength - 证书路径中可能存在的中间非自发布证书的最大数
抛出：
InvalidParameterException - 如果将 maxPathLength 设置为小于 -1 的值
另请参见：
getMaxPathLength()

getMaxPathLength

public int getMaxPathLength()
返回证书路径中可能存在的中间非自发布证书的最大数目值。有关详细信息，请参阅 setMaxPathLength(int) 方法。

返回：
证书路径中可能存在的中间非自发布证书的最大数，如果没有限制，则返回 -1
另请参见：
setMaxPathLength(int)

toString

public String toString()
返回描述该参数的格式化字符串。

覆盖：
类 PKIXParameters 中的 toString
返回：
描述该参数的格式化字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PKIXCertPathBuilderResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 PKIXCertPathBuilderResult

java.lang.Object
    继承者  java.security.cert.PKIXCertPathValidatorResult
        继承者  java.security.cert.PKIXCertPathBuilderResult
所有已实现的接口：
Cloneable, CertPathBuilderResult, CertPathValidatorResult
public class PKIXCertPathBuilderResult
extends PKIXCertPathValidatorResult
implements CertPathBuilderResult

此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。所有使用此算法构建并返回的证书路径都通过了 PKIX 证书路径验证算法的验证。

CertPathBuilder 对象的 build 方法所返回的 PKIXCertPathBuilderResult 实例实现该 PKIX 算法。

所有的 PKIXCertPathBuilderResult 对象都包含由构建算法所构造的证书路径、构建算法生成的有效策略树和主体公钥，以及一个描述作为证书路径受信定位点的证书颁发机构 (CA) 的 TrustAnchor。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPathBuilderResult

构造方法摘要
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
方法摘要
CertPath | getCertPath() 返回已构建并已验证的证书路径。
String | toString() 返回此 PKIXCertPathBuilderResult 的可打印表示形式。
从类 java.security.cert.PKIXCertPathValidatorResult 继承的方法
clone, getPolicyTree, getPublicKey, getTrustAnchor
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.security.cert.CertPathBuilderResult 继承的方法
clone

构造方法详细信息

PKIXCertPathBuilderResult

public PKIXCertPathBuilderResult(CertPath certPath,
                                 TrustAnchor trustAnchor,
                                 PolicyNode policyTree,
                                 PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。

参数：
certPath - 已验证的 CertPath
trustAnchor - 描述作为证书路径受信的定位点的 CA 的 TrustAnchor
policyTree - 不可变的有效策略树，如果没有有效的策略，则为 null
subjectPublicKey - 主体公钥
抛出：
NullPointerException - 如果 certPath、trustAnchor 或 subjectPublicKey 参数为 null
方法详细信息

getCertPath

public CertPath getCertPath()
返回已构建并已验证的证书路径。CertPath 对象不包括受信的定位点。相反，应使用 getTrustAnchor() 方法来获得作为证书路径受信定位点的 TrustAnchor。

指定者：
接口 CertPathBuilderResult 中的 getCertPath
返回：
已构建并已验证的 CertPath（不会为 null）

toString

public String toString()
返回此 PKIXCertPathBuilderResult 的可打印表示形式。

覆盖：
类 PKIXCertPathValidatorResult 中的 toString
返回：
描述此 PKIXCertPathBuilderResult 内容的 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PKIXCertPathChecker (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 PKIXCertPathChecker

java.lang.Object
    继承者  java.security.cert.PKIXCertPathChecker
所有已实现的接口：
Cloneable
public abstract class PKIXCertPathChecker
extends Object
implements Cloneable

对 X509Certificate 执行一种或多种检查的抽象类。

可创建 PKIXCertPathChecker 类的具体实现，以扩展 PKIX 证书路径验证算法。例如，一种实现可以检查并处理证书路径中每个证书的一种关键私有扩展。

PKIXCertPathChecker 实例可以用作 PKIXParameters 和 PKIXBuilderParameters 类中的 setCertPathCheckers 或 addCertPathChecker 方法的参数。然后为 PKIX CertPathValidator 或 CertPathBuilder 实现所处理的每个证书依次调用每个 PKIXCertPathChecker 的 check 方法。

可以在证书路径中的连续证书上多次调用 PKIXCertPathChecker。应该由具体的子类维护那些检查连续证书所必需的所有内部状态。init 方法用于初始化该检查器的内部状态，这样就可以检查新证书路径中的各个证书。为了允许 PKIX CertPathBuilder 高效地回溯并尝试其他路径，如有必要，有状态的实现必须重写该 clone 方法。在这种情况下，通过恢复已复制的 PKIXCertPathChecker，CertPathBuilder 能够恢复以前的路径验证状态。

呈现给 PKIXCertPathChecker 的证书顺序可以是正向的（从目标到最受信任的 CA），也可以是反向的（从最受信任的 CA 到目标）。PKIXCertPathChecker 实现必须支持反向检查（反向呈现证书时执行其检查的能力），并且可以支持正向检查（正向呈现证书时执行其检查的能力）。isForwardCheckingSupported 方法指示是否支持正向检查。

执行检查所需的其他输入参数可以通过此类具体实现的构造方法来指定。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
PKIXParameters, PKIXBuilderParameters

构造方法摘要
protected PKIXCertPathChecker()
默认的构造方法。
方法摘要
abstract void | check(Certificate cert, Collection<String> unresolvedCritExts) 使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
Object | clone() 返回此对象的副本。
abstract Set<String> | getSupportedExtensions() 返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。
abstract void | init(boolean forward) 初始化此 PKIXCertPathChecker 的内部状态。
abstract boolean | isForwardCheckingSupported() 指示是否支持正向检查。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PKIXCertPathChecker

protected PKIXCertPathChecker()
默认的构造方法。

方法详细信息

init

public abstract void init(boolean forward)
                   throws CertPathValidatorException
初始化此 PKIXCertPathChecker 的内部状态。

forward 标志指定向 check 方法传递的证书顺序（是正向还是反向的）。PKIXCertPathChecker 必须支持反向检查，并且可以支持正向检查。

参数：
forward - 向 check 方法呈现证书的顺序。如果为 true，则按照从目标到最受信任的 CA（正向）的顺序来呈现各个证书；如果为 false，则按照从最受信任的 CA 到目标（反向）的顺序来呈现各个证书。
抛出：
CertPathValidatorException - 如果此 PKIXCertPathChecker 无法按指定的顺序检查各个证书；如果 forward 标志为 false，则永远不应抛出该异常，因为必须支持反向检查

isForwardCheckingSupported

public abstract boolean isForwardCheckingSupported()
指示是否支持正向检查。正向检查是指以正向（从目标到最受信任的 CA）将各个证书呈现给 check 方法时，PKIXCertPathChecker 可执行其检查的能力。

返回：
如果支持正向检查，则返回 true；否则返回 false

getSupportedExtensions

public abstract Set<String> getSupportedExtensions()
返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。

该集合的每个元素都是一个 String，表示支持的 X.509 扩展的对象标识符 (OID)。该 OID 由一组句点分隔的非负整数来表示。

该集合中应该包括 PKIXCertPathChecker 可以处理的所有 X.509 证书扩展。

返回：
一个此 PKIXCertPathChecker 支持的 X.509 扩展 OID（以 String 格式）的不可变 Set，如果不支持这些扩展，则返回 null

check

public abstract void check(Certificate cert,
                           Collection<String> unresolvedCritExts)
                    throws CertPathValidatorException
使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。按照 init 方法所指定的顺序呈现各个证书。

参数：
cert - 要检查的 Certificate
unresolvedCritExts - 一个 OID 字符串 Collection，表示当前未解析的关键扩展集
抛出：
CertPathValidatorException - 如果指定的证书无法通过检查

clone

public Object clone()
返回此对象的副本。调用 Object.clone() 方法。如有必要，所有维护状态的子类必须支持并重写此方法。

覆盖：
类 Object 中的 clone
返回：
此 PKIXCertPathChecker 的副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PKIXCertPathValidatorResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 PKIXCertPathValidatorResult

java.lang.Object
    继承者  java.security.cert.PKIXCertPathValidatorResult
所有已实现的接口：
Cloneable, CertPathValidatorResult
直接已知子类：
PKIXCertPathBuilderResult
public class PKIXCertPathValidatorResult
extends Object
implements CertPathValidatorResult

此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。

CertPathValidator 对象的 validate 方法所返回的 PKIXCertPathValidatorResult 实例实现该 PKIX 算法。

所有的 PKIXCertPathValidatorResult 对象都包含由验证算法所生成的有效策略树和主体公钥，以及一个描述作为证书路径受信定位点的证书颁发机构 (CA) 的 TrustAnchor。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPathValidatorResult

构造方法摘要
PKIXCertPathValidatorResult(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。
方法摘要
Object | clone() 返回此对象的副本。
PolicyNode | getPolicyTree() 返回 PKIX 证书路径验证算法所得的有效策略树的根节点。
PublicKey | getPublicKey() 返回证书路径主体（目标）的公钥，如果适用，要包括所有继承的公钥参数。
TrustAnchor | getTrustAnchor() 返回描述作为证书路径受信定位点的 CA 的 TrustAnchor。
String | toString() 返回此 PKIXCertPathValidatorResult 的可打印表示形式。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PKIXCertPathValidatorResult

public PKIXCertPathValidatorResult(TrustAnchor trustAnchor,
                                   PolicyNode policyTree,
                                   PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。

参数：
trustAnchor - 描述作为证书路径受信定位点的 CA 的 TrustAnchor
policyTree - 不可变的有效策略树，如果没有有效的策略，则为 null
subjectPublicKey - 主体的公钥
抛出：
NullPointerException - 如果 subjectPublicKey 或 trustAnchor 参数为 null
方法详细信息

getTrustAnchor

public TrustAnchor getTrustAnchor()
返回描述作为证书路径受信定位点的 CA 的 TrustAnchor。

返回：
TrustAnchor（从不为 null）

getPolicyTree

public PolicyNode getPolicyTree()
返回 PKIX 证书路径验证算法所得的有效策略树的根节点。返回的 PolicyNode 对象和所有通过公共方法所返回的对象都是不可变的。

大多数应用程序无需检验有效策略树。它们可以通过设置 PKIXParameters 中与策略相关的参数来获得其策略处理目标。但是更为复杂的应用程序，特别是那些处理策略限定符的应用程序可能需要使用 PolicyNode.getParent 和 PolicyNode.getChildren 方法来遍历有效策略树。

返回：
有效策略树的根节点，如果没有有效的策略，则返回 null

getPublicKey

public PublicKey getPublicKey()
返回证书路径主体（目标）的公钥，如果适用，要包括所有继承的公钥参数。

返回：
主体的公钥（从不为 null）

clone

public Object clone()
返回此对象的副本。

指定者：
接口 CertPathValidatorResult 中的 clone
覆盖：
类 Object 中的 clone
返回：
副本
另请参见：
Cloneable

toString

public String toString()
返回此 PKIXCertPathValidatorResult 的可打印表示形式。

覆盖：
类 Object 中的 toString
返回：
描述此 PKIXCertPathValidatorResult 内容的 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PKIXParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 PKIXParameters

java.lang.Object
    继承者  java.security.cert.PKIXParameters
所有已实现的接口：
Cloneable, CertPathParameters
直接已知子类：
PKIXBuilderParameters
public class PKIXParameters
extends Object
implements CertPathParameters

用作 PKIX CertPathValidator 算法的输入的参数。

PKIX CertPathValidator 使用这些参数、根据 PKIX 证书路径验证算法来验证 CertPath。

要实例化 PKIXParameters 对象，应用程序必须指定一个或多个由 PKIX 证书路径验证算法所定义的最受信任的 CA。可以使用两个构造方法中的一个来指定最受信任的 CA。应用程序可以调用 PKIXParameters(Set) 来指定一个 TrustAnchor 对象 Set，其中每个对象都标识一个最受信任的 CA。另外，应用程序也可调用 PKIXParameters(KeyStore) 来指定一个 KeyStore 实例，其中包含多个受信任的证书项，每个项都认为是一个最受信任的 CA。

一旦创建了 PKIXParameters 对象，就可以指定其他参数（例如通过调用 setInitialPolicies 或 setDate），然后沿着要被 CertPathValidator.validate 所验证的 CertPath 传递 PKIXParameters。

所有未设置（或被设置为 null）的参数将被设置为该参数的默认值。date 参数的默认值是 null，指示验证该路径时的当前时间。其余参数的默认值是约束最少的。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertPathValidator

构造方法摘要
PKIXParameters(KeyStore keystore)
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。
PKIXParameters(Set<TrustAnchor> trustAnchors)
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。
方法摘要
void | addCertPathChecker(PKIXCertPathChecker checker) 向证书路径检查器列表中添加一个 PKIXCertPathChecker。
void | addCertStore(CertStore store) 将 CertStore 添加到查找证书和 CRL 所使用的 CertStore 列表末尾。
Object | clone() 对此 PKIXParameters 对象进行复制。
List<PKIXCertPathChecker> | getCertPathCheckers() 返回证书路径检查器的 List。
List<CertStore> | getCertStores() 返回用于查找证书和 CRL 的不可变 CertStore List。
Date | getDate() 返回应该确定证书路径有效性的时间。
Set<String> | getInitialPolicies() 返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
boolean | getPolicyQualifiersRejected() 获取 PolicyQualifiersRejected 标志。
String | getSigProvider() 返回签名提供者的名称，如果未设置，则返回 null。
CertSelector | getTargetCertConstraints() 返回目标证书所需的限制。
Set<TrustAnchor> | getTrustAnchors() 返回不可变的、最受信任的 CA Set。
boolean | isAnyPolicyInhibited() 检查当证书中包括了任何策略 OID 时是否应该处理它。
boolean | isExplicitPolicyRequired() 检查是否需要显式策略。
boolean | isPolicyMappingInhibited() 检查是否禁止策略映射。
boolean | isRevocationEnabled() 检查 RevocationEnabled 标志。
void | setAnyPolicyInhibited(boolean val) 设置状态，以确定当证书中包括了策略 OID 时是否应该处理它。
void | setCertPathCheckers(List<PKIXCertPathChecker> checkers) 设置其他证书路径检查器的 List。
void | setCertStores(List<CertStore> stores) 设置在查找证书和 CRL 时所使用的 CertStore 列表。
void | setDate(Date date) 设置应该确定证书路径有效性的时间。
void | setExplicitPolicyRequired(boolean val) 设置 ExplicitPolicyRequired 标志。
void | setInitialPolicies(Set<String> initialPolicies) 设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
void | setPolicyMappingInhibited(boolean val) 设置 PolicyMappingInhibited 标志。
void | setPolicyQualifiersRejected(boolean qualifiersRejected) 设置 PolicyQualifiersRejected 标志。
void | setRevocationEnabled(boolean val) 设置 RevocationEnabled 标志。
void | setSigProvider(String sigProvider) 设置签名提供者的名称。
void | setTargetCertConstraints(CertSelector selector) 设置目标证书所需的限制。
void | setTrustAnchors(Set<TrustAnchor> trustAnchors) 设置最受信任的 CA Set。
String | toString() 返回描述该参数的格式化字符串。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PKIXParameters

public PKIXParameters(Set<TrustAnchor> trustAnchors)
               throws InvalidAlgorithmParameterException
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。该 set 中的每个元素都是一个 TrustAnchor。

注意，要复制该 Set 以防对其进行后续修改。

参数：
trustAnchors - TrustAnchor 的 Set
抛出：
InvalidAlgorithmParameterException - 如果指定的 Set 为空 (trustAnchors.isEmpty() == true)
NullPointerException - 如果指定的 Set 为 null
ClassCastException - 如果该 Set 中任一元素不是 java.security.cert.TrustAnchor 类型的

PKIXParameters

public PKIXParameters(KeyStore keystore)
               throws KeyStoreException,
                      InvalidAlgorithmParameterException
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。只考虑那些包含受信 X509Certificates 的 keystore 项；忽略所有其他证书类型。

参数：
keystore - 一个 KeyStore，将根据它来生成最受信任的 CA 集
抛出：
KeyStoreException - 如果尚未初始化 keystore
InvalidAlgorithmParameterException - 如果 keystore 不包含一个受信证书项
NullPointerException - 如果 keystore 为 null
方法详细信息

getTrustAnchors

public Set<TrustAnchor> getTrustAnchors()
返回不可变的、最受信任的 CA Set。

返回：
不可变的 TrustAnchor Set（从不为 null）
另请参见：
setTrustAnchors(java.util.Set)

setTrustAnchors

public void setTrustAnchors(Set<TrustAnchor> trustAnchors)
                     throws InvalidAlgorithmParameterException
设置最受信任的 CA Set。

注意，要复制该 Set 以防对其进行后续修改。

参数：
trustAnchors - TrustAnchor 的 Set
抛出：
InvalidAlgorithmParameterException - 如果指定的 Set 为空 (trustAnchors.isEmpty() == true)
NullPointerException - 如果指定的 Set 为 null
ClassCastException - 如果该 Set 中的任一元素不是 java.security.cert.TrustAnchor 类型的
另请参见：
getTrustAnchors()

getInitialPolicies

public Set<String> getInitialPolicies()
返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。默认返回值是一个空 Set，它可以解释为任意策略均是可接受的。

返回：
初始策略 OID（以 String 的形式）的不可变 Set，或者是空 Set（暗示所有策略均是可接受的）。从不返回 null。
另请参见：
setInitialPolicies(java.util.Set)

setInitialPolicies

public void setInitialPolicies(Set<String> initialPolicies)
设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。默认情况下，任意策略（也就是所有策略）都是可接受的，所以想要任意策略都为可接受的用户不必调用此方法，或者可以用空的 Set（或者 null）调用此方法。

注意，要复制该 Set 以防对其进行后续修改。

参数：
initialPolicies - 初始策略 OID（以 String 格式）的 Set（或者为 null）
抛出：
ClassCastException - 如果该 set 中的任一元素不是 String 类型的
另请参见：
getInitialPolicies()

setCertStores

public void setCertStores(List<CertStore> stores)
设置在查找证书和 CRL 时所使用的 CertStore 列表。可以为 null，在这种情况下将不使用 CertStore。列表中前面出现的 CertStore 可能优先于后面出现的 CertStore 使用。

注意，要复制该 List 以防对其进行后续修改。

参数：
stores - CertStore 的 List（或者为 null）
抛出：
ClassCastException - 如果该 list 中的任一元素不是 java.security.cert.CertStore 类型的
另请参见：
getCertStores()

addCertStore

public void addCertStore(CertStore store)
将 CertStore 添加到查找证书和 CRL 所使用的 CertStore 列表末尾。

参数：
store - 要添加的 CertStore。如果为 null，则忽略该 CertStore（不添加到列表中）。

getCertStores

public List<CertStore> getCertStores()
返回用于查找证书和 CRL 的不可变 CertStore List。

返回：
一个不可变的 CertStore List（可能为空，但从不为 null）
另请参见：
setCertStores(java.util.List)

setRevocationEnabled

public void setRevocationEnabled(boolean val)
设置 RevocationEnabled 标志。如果此标志为 true，则使用底层 PKIX 服务提供者的默认撤消检查机制。如果此标志为 false，则禁用（不使用）默认撤消检查机制。

创建 PKIXParameters 对象时，此标志被设置为 true。此设置反映了检查撤消最常见的策略，因为每个服务提供者必须支持撤消检查是遵守 PKIX 的。当复杂的应用程序没有实际使用 PKIX 服务提供者的默认撤消检查机制时，或者使用一个替代的撤消检查机制来替换（仍通过调用 addCertPathChecker 或 setCertPathCheckers 方法）时，应该将此标志设置为 false。

参数：
val - RevocationEnabled 标志的新值

isRevocationEnabled

public boolean isRevocationEnabled()
检查 RevocationEnabled 标志。如果此标志为 true，则将使用底层 PKIX 服务提供者的默认撤消检查机制。如果此标志为 false，则禁用（不使用）默认撤消检查机制。有关设置此标志值的更多细节，请参见 setRevocationEnabled 方法。

返回：
RevocationEnabled 标志的当前值

setExplicitPolicyRequired

public void setExplicitPolicyRequired(boolean val)
设置 ExplicitPolicyRequired 标志。如果此标志为 true，则需要在每个证书中显式地标识一个可接受的策略。默认情况下，ExplicitPolicyRequired 标志为 false。

参数：
val - 如果需要显式策略，则为 true；否则为 false

isExplicitPolicyRequired

public boolean isExplicitPolicyRequired()
检查是否需要显式策略。如果此标志为 true，则需要在每个证书中显式地标识一个可接受的策略。默认情况下，ExplicitPolicyRequired 标志为 false。

返回：
如果需要显式策略，则返回 true；否则返回 false

setPolicyMappingInhibited

public void setPolicyMappingInhibited(boolean val)
设置 PolicyMappingInhibited 标志。如果此标志为 true，则禁止策略映射。默认情况下，不禁止策略映射（其标志为 false）。

参数：
val - 如果禁止策略映射，则为 true；否则为 false

isPolicyMappingInhibited

public boolean isPolicyMappingInhibited()
检查是否禁止策略映射。如果此标志为 true，则禁止策略映射。默认情况下，不禁止策略映射（其标志为 false）。

返回：
如果禁止策略映射，则返回 true；否则返回 false

setAnyPolicyInhibited

public void setAnyPolicyInhibited(boolean val)
设置状态，以确定当证书中包括了策略 OID 时是否应该处理它。默认情况下，不禁止任何策略 OID（isAnyPolicyInhibited() 返回 false）。

参数：
val - 如果要禁止任何策略 OID，则为 true；否则为 false

isAnyPolicyInhibited

public boolean isAnyPolicyInhibited()
检查当证书中包括了任何策略 OID 时是否应该处理它。

返回：
如果禁止任何策略 OID，则返回 true；否则返回 false

setPolicyQualifiersRejected

public void setPolicyQualifiersRejected(boolean qualifiersRejected)
设置 PolicyQualifiersRejected 标志。如果此标志为 true，则在其被标记为关键的证书策略扩展中包括策略限定符的证书被拒绝。如果该标志为 false，则不拒绝此种证书。

创建 PKIXParameters 对象后，此标志设置为 true。此设置反映了处理策略限定符最常见（也是最简单的）的策略。希望使用更复杂策略的应用程序必须将此标志设置为 false。

注意，PKIX 证书路径验证算法规定，对标记为关键的证书策略扩展中的策略限定符必须加以处理和验证。否则必须放弃该证书路径。如果 policyQualifiersRejected 标志设置为 false，那么为了遵守 PKIX ，由应用程序以此方式来验证所有的策略限定符。

参数：
qualifiersRejected - PolicyQualifiersRejected 标志的新值
另请参见：
getPolicyQualifiersRejected(), PolicyQualifierInfo

getPolicyQualifiersRejected

public boolean getPolicyQualifiersRejected()
获取 PolicyQualifiersRejected 标志。如果此标志为 true，则在其被标记为关键的证书策略扩展中包括策略限定符的证书被拒绝。如果该标志为 false，则不拒绝此种证书。

创建 PKIXParameters 对象后，此标志设置为 true。此设置反映了处理策略限定符最常见（也是最简单的）的策略。希望使用更复杂策略的应用程序必须将此标志设置为 false。

返回：
PolicyQualifiersRejected 标志的当前值
另请参见：
setPolicyQualifiersRejected(boolean)

getDate

public Date getDate()
返回应该确定证书路径有效性的时间。如果返回 null，则使用当前时间。

注意，要复制返回的 Date 以防对其进行后续修改。

返回：
Date，如果未设置，则返回 null
另请参见：
setDate(java.util.Date)

setDate

public void setDate(Date date)
设置应该确定证书路径有效性的时间。如果返回 null，则使用当前时间。

注意，要复制此处提供的 Date 以防对其进行后续修改。

参数：
date - Date，如果使用当前时间，则为 null
另请参见：
getDate()

setCertPathCheckers

public void setCertPathCheckers(List<PKIXCertPathChecker> checkers)
设置其他证书路径检查器的 List。如果指定的 List 包含不是 PKIXCertPathChecker 的对象，则忽略它。

每个指定的 PKIXCertPathChecker 都对证书进行额外的检查。通常，这些检查是对证书中所包含的私有扩展进行处理和验证。应该使用执行该检查所需的所有初始化参数对每个 PKIXCertPathChecker 进行实例化。

此方法允许复杂的应用程序扩展 PKIX CertPathValidator 或 CertPathBuilder。依次由 PKIX CertPathValidator 或 CertPathBuilder 为每个要处理或验证的证书调用每个指定的 PKIXCertPathChecker。

不管是否设置了这些额外的 PKIXCertPathChecker，PKIX CertPathValidator 或 CertPathBuilder 都必须对每个证书执行所有所需的 PKIX 检查。此规则的一个例外是，RevocationEnabled 标志设置为 false 的情况（请参见 setRevocationEnabled 方法）。

注意，将复制此处提供的 List，并且复制该 List 中的所有 PKIXCertPathChecker 以防对其进行后续修改。

参数：
checkers - PKIXCertPathChecker 的 List。可以为 null，在这种情况下将不使用其他的检查器。
抛出：
ClassCastException - 如果该 List 中的任一元素不是 java.security.cert.PKIXCertPathChecker 类型的
另请参见：
getCertPathCheckers()

getCertPathCheckers

public List<PKIXCertPathChecker> getCertPathCheckers()
返回证书路径检查器的 List。返回的 List 是不可变的，并且复制该 List 中的所有 PKIXCertPathChecker 以防对其进行后续修改。

返回：
一个不可变的 PKIXCertPathChecker List（可能为空，但从不为 null）
另请参见：
setCertPathCheckers(java.util.List)

addCertPathChecker

public void addCertPathChecker(PKIXCertPathChecker checker)
向证书路径检查器列表中添加一个 PKIXCertPathChecker。有关详细信息，请参见 setCertPathCheckers 方法。

注意，要复制该 PKIXCertPathChecker 以防对其进行后续修改。

参数：
checker - 要添加到检查列表中的 PKIXCertPathChecker。如果为 null，则忽略该检查器（不添加到列表中）。

getSigProvider

public String getSigProvider()
返回签名提供者的名称，如果未设置，则返回 null。

返回：
签名提供者的名称（或者返回 null）
另请参见：
setSigProvider(java.lang.String)

setSigProvider

public void setSigProvider(String sigProvider)
设置签名提供者的名称。创建 Signature 对象时将首选该指定的提供者。如果为 null 或未设置，则将使用所找到的、支持该算法的第一个提供者。

参数：
sigProvider - 签名提供者的名称（或者为 null）
另请参见：
getSigProvider()

getTargetCertConstraints

public CertSelector getTargetCertConstraints()
返回目标证书所需的限制。以 CertSelector 实例的形式返回这些限制。如果为 null，则未定义限制。

注意，要复制返回的 CertSelector 以防对其进行后续修改。

返回：
指定目标证书限制的 CertSelector（或者返回 null）
另请参见：
setTargetCertConstraints(java.security.cert.CertSelector)

setTargetCertConstraints

public void setTargetCertConstraints(CertSelector selector)
设置目标证书所需的限制。以 CertSelector 实例的形式指定这些限制。如果为 null，则未定义限制。

注意，要复制所指定的 CertSelector 以防对其进行后续修改。

参数：
selector - 指定目标证书限制的 CertSelector（或者为 null）
另请参见：
getTargetCertConstraints()

clone

public Object clone()
对此 PKIXParameters 对象进行复制。对副本的更改不会影响原件，反之亦然。

指定者：
接口 CertPathParameters 中的 clone
覆盖：
类 Object 中的 clone
返回：
此 PKIXParameters 对象的副本
另请参见：
Cloneable

toString

public String toString()
返回描述该参数的格式化字符串。

覆盖：
类 Object 中的 toString
返回：
描述该参数的格式化字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PolicyQualifierInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 PolicyQualifierInfo

java.lang.Object
    继承者  java.security.cert.PolicyQualifierInfo

public class PolicyQualifierInfo
extends Object

由 ASN.1 PolicyQualifierInfo 结构所表示的、不可变的策略限定符。

ASN.1 的定义如下：

   PolicyQualifierInfo ::= SEQUENCE {
        policyQualifierId       PolicyQualifierId,
        qualifier               ANY DEFINED BY policyQualifierId }

如果在 X.509 第 3 版的证书中有证书策略扩展，则该扩展包含一个或多个策略信息项的序列，每一项都由一个对象标识符 (OID) 和可选的限定符组成。在最终实体证书中，这些策略信息项指示了策略（根据此策略发布证书）和目的（该证书的可能用途）。在 CA 证书中，这些策略信息项则限制了包括此证书的证书路径的策略集。

PolicyQualifierInfo 对象的 Set 由 PolicyNode.getPolicyQualifiers 方法返回。这就允许带有具体策略要求的应用程序处理并验证每个策略限定符。处理策略限定符的应用程序在验证一个证书路径前，应该显式地将 policyQualifiersRejected 标志设置为 false（通过调用 PKIXParameters.setPolicyQualifiersRejected 方法）。

注意，PKIX 证书路径验证算法规定，对标记为关键的证书策略扩展中的策略限定符必须加以处理和验证。否则必须放弃该证书路径。如果 policyQualifiersRejected 标志设置为 false，那么为了遵守 PKIX ，由应用程序以此方式来验证所有的策略限定符。

并发访问

所有 PolicyQualifierInfo 对象必须是不可变的和线程安全的。也就是说，多个线程在单个 PolicyQualifierInfo 对象（或多个对象）上并发调用此类中所定义的各种方法不会产生坏的影响。要求 PolicyQualifierInfo 对象是不可变的并且是线程安全的，就允许将其传递到各种代码片断中，而无需担心协调访问。

从以下版本开始：
1.4

构造方法摘要
PolicyQualifierInfo(byte[] encoded)
根据已编码的字节创建一个 PolicyQualifierInfo 实例。
方法摘要
byte[] | getEncoded() 返回此 PolicyQualifierInfo 的 ASN.1 DER 编码形式。
byte[] | getPolicyQualifier() 返回此 PolicyQualifierInfo 的 qualifier 字段的 ASN.1 DER 编码形式。
String | getPolicyQualifierId() 返回此 PolicyQualifierInfo 的 policyQualifierId 字段。
String | toString() 返回此 PolicyQualifierInfo 的可打印表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PolicyQualifierInfo

public PolicyQualifierInfo(byte[] encoded)
                    throws IOException
根据已编码的字节创建一个 PolicyQualifierInfo 实例。在构造时复制该已编码的 byte 数组。

参数：
encoded - 包含 DER 编码中限定符的 byte 数组
抛出：
IOException - 如果该 byte 数组不表示一个有效并且可解析的策略限定符
方法详细信息

getPolicyQualifierId

public final String getPolicyQualifierId()
返回此 PolicyQualifierInfo 的 policyQualifierId 字段。policyQualifierId 是一个对象标识符 (OID)，由一组句点分隔的非负整数来表示。

返回：
OID（从不为 null）

getEncoded

public final byte[] getEncoded()
返回此 PolicyQualifierInfo 的 ASN.1 DER 编码形式。

返回：
以 ASN.1 DER 编码的字节（从不为 null）。注意，返回的是一个副本，所以每次调用此方法时都复制数据。

getPolicyQualifier

public final byte[] getPolicyQualifier()
返回此 PolicyQualifierInfo 的 qualifier 字段的 ASN.1 DER 编码形式。

返回：
qualifier 字段以 ASN.1 DER 编码的字节。注意，返回的是一个副本，所以每次调用此方法时都复制数据。

toString

public String toString()
返回此 PolicyQualifierInfo 的可打印表示形式。

覆盖：
类 Object 中的 toString
返回：
描述此 PolicyQualifierInfo 内容的 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrustAnchor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 TrustAnchor

java.lang.Object
    继承者  java.security.cert.TrustAnchor

public class TrustAnchor
extends Object

一个信任定位点或最受信任的证书颁发机构 (CA)。

此类表示“最受信任的 CA”，该 CA 用作验证 X.509 证书路径的信任定位点。最受信任的 CA 包括该 CA 的公钥、该 CA 的名称，以及可能使用此密钥所验证的路径集上的所有限制。可以受信任的 X509Certificate 形式或以单个参数的形式来指定这些参数。

并发访问

所有 TrustAnchor 对象必须是不可变的和线程安全的。也就是说，多个线程在单个 TrustAnchor 对象（或多个对象）上并发调用此类中所定义的各种方法不会产生什么恶果。要求 TrustAnchor 对象是不可变的并且是线程安全的就允许将其传递到各种代码片断中，而无需担心并列的访问。此规定适用于此类的所有公共字段和方法，以及由子类添加或重写的所有公共字段和方法。

从以下版本开始：
1.4
另请参见：
PKIXParameters.PKIXParameters(Set), PKIXBuilderParameters.PKIXBuilderParameters(Set, CertSelector)

构造方法摘要
TrustAnchor(String caName, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。
TrustAnchor(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。
TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints)
创建具有指定 X509Certificate 和可选 nameConstraints 的 TrustAnchor 实例，在验证 X.509 证书路径时，该 nameConstraints 用作额外的限制条件。
方法摘要
X500Principal | getCA() 以 X500Principal 的形式返回最受信任的 CA 的名称。
String | getCAName() 以 RFC 2253 String 格式返回最受信任的 CA 的名称。
PublicKey | getCAPublicKey() 返回最受信任的 CA 的公钥。
byte[] | getNameConstraints() 返回 nameConstraints 参数。
X509Certificate | getTrustedCert() 返回最受信任的 CA 证书。
String | toString() 返回描述此 TrustAnchor 的格式化字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TrustAnchor

public TrustAnchor(X509Certificate trustedCert,
                   byte[] nameConstraints)
创建具有指定 X509Certificate 和可选 nameConstraints 的 TrustAnchor 实例，在验证 X.509 证书路径时，该 nameConstraints 用作额外的限制条件。

以 byte 数组的形式指定该 nameConstraints。此 byte 数组应该包含 DER 编码形式的 nameConstraints，因为它们将出现在 RFC 2459 和 X.509 内所定义的 NameConstraints 结构中。此结构的 ASN.1 定义如下。

  NameConstraints ::= SEQUENCE {
       permittedSubtrees       [0]     GeneralSubtrees OPTIONAL,
       excludedSubtrees        [1]     GeneralSubtrees OPTIONAL }

  GeneralSubtrees ::= SEQUENCE SIZE (1..MAX) OF GeneralSubtree

  GeneralSubtree ::= SEQUENCE {
       base                    GeneralName,
       minimum         [0]     BaseDistance DEFAULT 0,
       maximum         [1]     BaseDistance OPTIONAL }

  BaseDistance ::= INTEGER (0..MAX)

  GeneralName ::= CHOICE {
       otherName                       [0]     OtherName,
       rfc822Name                      [1]     IA5String,
       dNSName                         [2]     IA5String,
       x400Address                     [3]     ORAddress,
       directoryName                   [4]     Name,
       ediPartyName                    [5]     EDIPartyName,
       uniformResourceIdentifier       [6]     IA5String,
       iPAddress                       [7]     OCTET STRING,
       registeredID                    [8]     OBJECT IDENTIFIER}

注意，为了防止后续修改，将复制所提供的 nameConstraints byte 数组。

参数：
trustedCert - 受信任的 X509Certificate
nameConstraints - 一个 byte 数组，包含为检查 nameConstraints 所使用的 NameConstraints 扩展的 ASN.1 DER 编码。只包括该扩展的值，不包括 OID 或关键程度标志。指定 null 可省略该参数。
抛出：
IllegalArgumentException - 如果无法解码该 nameConstraints
NullPointerException - 如果指定的 X509Certificate 为 null

TrustAnchor

public TrustAnchor(X500Principal caPrincipal,
                   PublicKey pubKey,
                   byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。nameConstraints 是可选的参数，在验证 X.509 证书路径时，将其用作额外的限制条件。

以 byte 数组的形式指定该 nameConstraints。此 byte 数组包含 DER 编码形式的 nameConstraints，因为它们将出现在 RFC 2459 和 X.509 内所定义的 NameConstraints 结构中。TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints) 的文档中提供了此结构的 ASN.1 符号。

注意，为了防止后续修改，将复制此处所提供的 nameConstraints byte 数组。

参数：
caPrincipal - 最受信任的 CA 的名称，以 X500Principal 形式提供
pubKey - 最受信任的 CA 的公钥
nameConstraints - 一个 byte 数组，包含为检查 nameConstraints 所使用的 NameConstraints 扩展的 ASN.1 DER 编码。只包括该扩展的值，不包括 OID 或关键程度标志。指定 null 可省略该参数。
抛出：
NullPointerException - 如果指定的 caPrincipal 或 pubKey 参数为 null
从以下版本开始：
1.5

TrustAnchor

public TrustAnchor(String caName,
                   PublicKey pubKey,
                   byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。nameConstraints 是可选的参数，在验证 X.509 证书路径时，将其用作额外的限制条件。

以 byte 数组的形式指定该 nameConstraints。此 byte 数组包含 DER 编码形式的 nameConstraints，因为它们将出现在 RFC 2459 和 X.509 内所定义的 NameConstraints 结构中。TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints) 的文档中提供了此结构的 ASN.1 符号。

注意，为了防止后续修改，将复制此处所提供的 nameConstraints byte 数组。

参数：
caName - 最受信任的 CA 的 X.500 区分名，以 RFC 2253 String 格式提供
pubKey - 最受信任的 CA 的公钥
nameConstraints - 一个 byte 数组，包含为检查 nameConstraints 所使用的 NameConstraints 扩展的 ASN.1 DER 编码。只包括该扩展的值，不包括 OID 或关键程度标志。指定 null 可省略该参数。
抛出：
IllegalArgumentException - 如果指定的 caName 参数是空 (caName.length() == 0)，或者格式不正确，或者无法解码该 nameConstraints
NullPointerException - 如果指定的 caName 或 pubKey 参数为 null
方法详细信息

getTrustedCert

public final X509Certificate getTrustedCert()
返回最受信任的 CA 证书。

返回：
受信任的 X509Certificate，如果信任定位点未被指定为受信任的证书，则返回 null

getCA

public final X500Principal getCA()
以 X500Principal 的形式返回最受信任的 CA 的名称。

返回：
最受信任的 CA 的 X.500 区分名，如果信任定位点未被指定为受信任公钥和名称或 X500Principal 对，则返回 null
从以下版本开始：
1.5

getCAName

public final String getCAName()
以 RFC 2253 String 格式返回最受信任的 CA 的名称。

返回：
最受信任的 CA 的 X.500 区分名，如果信任定位点未被指定为受信任公钥和名称或 X500Principal 对，则返回 null

getCAPublicKey

public final PublicKey getCAPublicKey()
返回最受信任的 CA 的公钥。

返回：
最受信任的 CA 的公钥，如果信任定位点未被指定为受信任公钥和名称或 X500Principal 对，则返回 null

getNameConstraints

public final byte[] getNameConstraints()
返回 nameConstraints 参数。指定的 nameConstraints 是与此信任定位点相关联的，并且在验证 X.509 证书路径时，将其用作额外的限制条件。

以 byte 数组的形式返回该 nameConstraints。此 byte 数组包含 DER 编码形式的 nameConstraints，因为它们将出现在 RFC 2459 和 X.509 内所定义的 NameConstraints 结构中。TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints) 的文档中提供了此结构的 ASN.1 符号。

注意，为了保护后续的修改，将复制返回的 byte 数组。

返回：
一个 byte 数组，包含为检查 nameConstraints 所使用的 NameConstraints 扩展的 ASN.1 DER 编码，如果未设置，则返回 null。

toString

public String toString()
返回描述此 TrustAnchor 的格式化字符串。

覆盖：
类 Object 中的 toString
返回：
描述此 TrustAnchor 的格式化字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509Certificate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 X509Certificate

java.lang.Object
    继承者  java.security.cert.Certificate
        继承者  java.security.cert.X509Certificate
所有已实现的接口：
Serializable, X509Extension
public abstract class X509Certificate
extends Certificate
implements X509Extension

X.509 证书的抽象类。此类提供了一种访问 X.509 证书所有属性的标准方式。

1996 年 6 月，ISO/IEC 和 ANSI X9 完成了基本的 X.509 v3 格式，在 ASN.1 中描述如下：

 Certificate  ::=  SEQUENCE  {
     tbsCertificate       TBSCertificate,
     signatureAlgorithm   AlgorithmIdentifier,
     signature            BIT STRING  }

这些证书被广泛使用以支持 Internet 安全系统中的身份验证和其他功能。常见的应用包括增强保密邮件 (PEM)、传输层安全 (SSL)、用于受信任软件发布的代码签名和安全电子交易 (SET)。

由证书颁发机构 (CA) 来管理和担保这些证书。CA 的工作是创建证书，方法是将数据置于 X.509 标准格式，然后以数字方式签署该数据。CA 充当受信任的第三方，在不能直接通信的主体之间传递信息。CA 证书可由其自身签名，也可由其他 CA 签名，如“根”CA。

在 RFC 2459，即 "Internet X.509 Public Key Infrastructure Certificate and CRL Profile"（位于 http://www.ietf.org/rfc/rfc2459.txt ）中可找到更多信息。

tbsCertificate 的 ASN.1 定义是：

 TBSCertificate  ::=  SEQUENCE  {
     version         [0]  EXPLICIT Version DEFAULT v1,
     serialNumber         CertificateSerialNumber,
     signature            AlgorithmIdentifier,
     issuer               Name,
     validity             Validity,
     subject              Name,
     subjectPublicKeyInfo SubjectPublicKeyInfo,
     issuerUniqueID  [1]  IMPLICIT UniqueIdentifier OPTIONAL,
                          -- If present, version must be v2 or v3
     subjectUniqueID [2]  IMPLICIT UniqueIdentifier OPTIONAL,
                          -- If present, version must be v2 or v3
     extensions      [3]  EXPLICIT Extensions OPTIONAL
                          -- If present, version must be v3
     }

使用证书工厂来实例化证书。下面的示例演示了如何实例化一个 X.509 证书。

 InputStream inStream = new FileInputStream("fileName-of-cert");
 CertificateFactory cf = CertificateFactory.getInstance("X.509");
 X509Certificate cert = (X509Certificate)cf.generateCertificate(inStream);
 inStream.close();

另请参见：
Certificate, CertificateFactory, X509Extension, 序列化表格

嵌套类摘要
从类 java.security.cert.Certificate 继承的嵌套类/接口
Certificate.CertificateRep
构造方法摘要
protected X509Certificate()
X.509 证书的构造方法。
方法摘要
abstract  void checkValidity()
检查证书目前是否有效。
abstract  void checkValidity(Date date)
检查给定的日期是否处于证书的有效期内。
abstract  int getBasicConstraints()
从关键 BasicConstraints 扩展 (OID = 2.5.29.19) 中获取证书的限制路径长度。
 List<String> getExtendedKeyUsage()
获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。
 Collection<List<?>> getIssuerAlternativeNames()
从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
abstract  Principal getIssuerDN()
已过时，由 getIssuerX500Principal() 替代。
abstract  boolean[] getIssuerUniqueID()
获取证书的 issuerUniqueID 值。
 X500Principal getIssuerX500Principal()
以 X500Principal 的形式返回证书的发布方（发布方标识名）值。
abstract  boolean[] getKeyUsage()
获取一个表示 KeyUsage 扩展 (OID = 2.5.29.15) 的各个位的 boolean 数组。
abstract  Date getNotAfter()
获取证书有效期的 notAfter 日期。
abstract  Date getNotBefore()
获取证书有效期的 notBefore 日期。
abstract  BigInteger getSerialNumber()
获取证书的 serialNumber 值。
abstract  String getSigAlgName()
获取证书签名算法的签名算法名。
abstract  String getSigAlgOID()
获取证书的签名算法 OID 字符串。
abstract  byte[] getSigAlgParams()
从此证书的签名算法中获取 DER 编码形式的签名算法参数。
abstract  byte[] getSignature()
获取证书的 signature 值（原始签名位）。
 Collection<List<?>> getSubjectAlternativeNames()
从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。
abstract  Principal getSubjectDN()
已过时，由 getSubjectX500Principal() 替代。
abstract  boolean[] getSubjectUniqueID()
获取证书的 subjectUniqueID 值。
 X500Principal getSubjectX500Principal()
以 X500Principal 的形式返回证书的主体（主体标识名）值。
abstract  byte[] getTBSCertificate()
从此证书中获取以 DER 编码的证书信息，即 tbsCertificate。
abstract  int getVersion()
获取证书的 version（版本号）值。
从类 java.security.cert.Certificate 继承的方法
equals, getEncoded, getPublicKey, getType, hashCode, toString, verify, verify, writeReplace
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.security.cert.X509Extension 继承的方法
getCriticalExtensionOIDs, getExtensionValue, getNonCriticalExtensionOIDs, hasUnsupportedCriticalExtension

构造方法详细信息

X509Certificate

protected X509Certificate()
X.509 证书的构造方法。

方法详细信息

checkValidity

public abstract void checkValidity()
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
检查证书目前是否有效。即当前的日期和时间是否仍在证书中所给定的有效期内。

有效期由两个日期/时间值组成：证书有效的起始和终止日期（和时间）。在 ASN.1 中定义如下：

 validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }

抛出：
CertificateExpiredException - 如果证书已过期。
CertificateNotYetValidException - 如果证书不再有效。

checkValidity

public abstract void checkValidity(Date date)
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
检查给定的日期是否处于证书的有效期内。换句话说，这确定该证书在给定的日期/时间是否有效。

参数：
date - 要检查的 Date，以确定此证书在该日期/时间是否有效。
抛出：
CertificateExpiredException - 如果对于所提供的 date 而言该证书已过期。
CertificateNotYetValidException - 如果对于所提供的 date 而言该证书不再有效。
另请参见：
checkValidity()

getVersion

public abstract int getVersion()
获取证书的 version（版本号）值。此内容的 ASN.1 定义如下：
 version  [0] EXPLICIT Version DEFAULT v1

 Version ::=  INTEGER  {  v1(0), v2(1), v3(2)  }

返回：
版本号，比如 1、2 或 3。

getSerialNumber

public abstract BigInteger getSerialNumber()
获取证书的 serialNumber 值。序列号是证书颁发机构为每个证书所分配的一个整数。给定的 CA 所发布的每个证书的序列号必须是唯一的（即发布方名称和序列号标识一个唯一的证书）。此内容的 ASN.1 定义如下：
 serialNumber     CertificateSerialNumber

 CertificateSerialNumber  ::=  INTEGER

返回：
序列号。

getIssuerDN

public abstract Principal getIssuerDN()
已过时，由 getIssuerX500Principal() 替代。此方法返回作为特定 Principal 对象实现的 issuer，可移植的代码不应依靠该对象。

获取证书的 issuer（发布方的标识名）值。发布方名称标识了签署（并发布）该证书的实体。

发布方名称字段包含一个 X.500 标识名 (DN)。此内容的 ASN.1 定义如下：

 issuer    Name

 Name ::= CHOICE { RDNSequence }
 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName
 RelativeDistinguishedName ::=
     SET OF AttributeValueAssertion

 AttributeValueAssertion ::= SEQUENCE {
                               AttributeType,
                               AttributeValue }
 AttributeType ::= OBJECT IDENTIFIER
 AttributeValue ::= ANY
Name 描述了一个层次结构名，由属性（如国家/地区名）和相应值（如 US）组成。AttributeValue 组件的类型由 AttributeType 来确定；一般是 directoryString。directoryString 通常是 PrintableString、TeletexString 或 UniversalString 之一。

返回：
一个 Principal，其名称是发布方的标识名。

getIssuerX500Principal

public X500Principal getIssuerX500Principal()
以 X500Principal 的形式返回证书的发布方（发布方标识名）值。

建议子类重写此方法。

返回：
一个表示发布方标识名的 X500Principal
从以下版本开始：
1.4

getSubjectDN

public abstract Principal getSubjectDN()
已过时，由 getSubjectX500Principal() 替代。此方法返回作为特定 Principal 对象实现的 subject，可移植的代码不应依靠该对象。

获取证书的 subject（主体的标识名）值。如果 subject 值为空，则返回的 Principal 对象的 getName() 方法将返回一个空字符串 ("")。

此内容的 ASN.1 定义如下：

 subject    Name

有关 Name 和其他相关定义的信息，请参见 getIssuerDN。

返回：
一个 Principal，其名称是主体名。

getSubjectX500Principal

public X500Principal getSubjectX500Principal()
以 X500Principal 的形式返回证书的主体（主体标识名）值。如果 subject 值为空，则返回的 X500Principal 对象的 getName() 方法将返回一个空字符串 ("")。

建议子类重写此方法。

返回：
一个表示主体标识名的 X500Principal
从以下版本开始：
1.4

getNotBefore

public abstract Date getNotBefore()
获取证书有效期的 notBefore 日期。相关的 ASN.1 定义如下：
 validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }

返回：
有效期的起始日期。
另请参见：
checkValidity()

getNotAfter

public abstract Date getNotAfter()
获取证书有效期的 notAfter 日期。有关相关的 ASN.1 定义，请参见 getNotBefore。

返回：
有效期的终止日期。
另请参见：
checkValidity()

getTBSCertificate

public abstract byte[] getTBSCertificate()
                                  throws CertificateEncodingException
从此证书中获取以 DER 编码的证书信息，即 tbsCertificate。这可用于独立验证签名。

返回：
以 DER 编码的证书信息。
抛出：
CertificateEncodingException - 如果发生编码错误。

getSignature

public abstract byte[] getSignature()
获取证书的 signature 值（原始签名位）。此内容的 ASN.1 定义如下：
 signature     BIT STRING

返回：
签名。

getSigAlgName

public abstract String getSigAlgName()
获取证书签名算法的签名算法名。例如字符串 "SHA-1/DSA"。此内容的 ASN.1 定义如下：
 signatureAlgorithm   AlgorithmIdentifier

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm               OBJECT IDENTIFIER,
     parameters              ANY DEFINED BY algorithm OPTIONAL  }
                             -- contains a value of the type
                             -- registered for use with the
                             -- algorithm object identifier value

根据 algorithm OID 字符串确定该算法名。

返回：
签名算法名。

getSigAlgOID

public abstract String getSigAlgOID()
获取证书的签名算法 OID 字符串。OID 由一组句点分隔的非负整数集来表示。例如，按照 RFC 2459 中的规定，字符串 "1.2.840.10040.4.3" 标识使用 DSA 签名算法的 SHA-1。

有关相关的 ASN.1 定义，请参见 getSigAlgName。

返回：
签名算法 OID 字符串。

getSigAlgParams

public abstract byte[] getSigAlgParams()
从此证书的签名算法中获取 DER 编码形式的签名算法参数。在大多数情况下，该签名算法参数为 null；该参数通常提供证书的公钥。如果需要访问个别参数值，则使用 AlgorithmParameters，并使用 getSigAlgName 所返回的名称进行实例化。

有关相关的 ASN.1 定义，请参见 getSigAlgName。

返回：
DER 编码形式的签名算法参数，如果没有该参数，则返回 null。

getIssuerUniqueID

public abstract boolean[] getIssuerUniqueID()
获取证书的 issuerUniqueID 值。证书中发布方的唯一标识符用于处理以后可能出现的发布方名称重用的情况。RFC 2459 建议不重用该名称，并建议合格的证书不要使用唯一标识符。遵守该配置文件的应用程序应该能够解析唯一标识符并进行比较。

此内容的 ASN.1 定义如下：

 issuerUniqueID  [1]  IMPLICIT UniqueIdentifier OPTIONAL

 UniqueIdentifier  ::=  BIT STRING

返回：
发布方的唯一标识符，如果证书中没有该标识符，则返回 null。

getSubjectUniqueID

public abstract boolean[] getSubjectUniqueID()
获取证书的 subjectUniqueID 值。

此内容的 ASN.1 定义如下：

 subjectUniqueID  [2]  IMPLICIT UniqueIdentifier OPTIONAL

 UniqueIdentifier  ::=  BIT STRING

返回：
主体唯一标识符，如果证书中没有该标识符，则返回 null。

getKeyUsage

public abstract boolean[] getKeyUsage()
获取一个表示 KeyUsage 扩展 (OID = 2.5.29.15) 的各个位的 boolean 数组。KeyUsage 扩展定义证书中所含密钥的目的（如编码、签名、证书签署）。此内容的 ASN.1 定义如下：
 KeyUsage ::= BIT STRING {
     digitalSignature        (0),
     nonRepudiation          (1),
     keyEncipherment         (2),
     dataEncipherment        (3),
     keyAgreement            (4),
     keyCertSign             (5),
     cRLSign                 (6),
     encipherOnly            (7),
     decipherOnly            (8) }
RFC 2459 建议，使用该扩展时将其标记为关键扩展。

返回：
此证书的 KeyUsage 扩展，以 boolean 数组的形式表示。该数组中 KeyUsage 值的顺序与上面 ASN.1 定义中的顺序相同。该数组将包含上面定义的每个 KeyUsage 的值。如果证书中编码的 KeyUsage 列表要比上面的列表长，则不会截取它。如果此证书不包含 KeyUsage 扩展，则返回 null。

getExtendedKeyUsage

public List<String> getExtendedKeyUsage()
                                 throws CertificateParsingException
获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。除了或代替 KeyUsage 扩展字段中所指示的基本目的，它还指示了一个或多个使用已认证公钥的目的。此内容的 ASN.1 定义如下：
 ExtKeyUsageSyntax ::= SEQUENCE SIZE (1..MAX) OF KeyPurposeId

 KeyPurposeId ::= OBJECT IDENTIFIER
任何有需要的组织都可定义 KeyPurpose。依照 IANA 或 ITU-T Rec X.660 | ISO/IEC/ITU 9834-1 的规定分配用于标识 KeyPurpose 的对象标识符

Java 2 Platform Standard Edition 的 1.4 版本中添加了此方法。为了维持与现有服务提供者的后向兼容性，没有 abstract 此方法，并且它提供了一个默认实现。子类应该通过正确的实现重写此方法。

返回：
以 String 表示的、对象标识符不可修改的列表形式返回此证书的 ExtendedKeyUsage 扩展。如果此证书不包含 ExtendedKeyUsage 扩展，则返回 null。
抛出：
CertificateParsingException - 如果无法对该扩展进行解码
从以下版本开始：
1.4

getBasicConstraints

public abstract int getBasicConstraints()
从关键 BasicConstraints 扩展 (OID = 2.5.29.19) 中获取证书的限制路径长度。

BasicConstraints 扩展标识证书的主体是否为一个证书颁发机构 (CA)，以及通过该 CA 的证书路径的深度。仅在将 cA 设置为 TRUE 时，pathLenConstraint 字段（参见以下内容）才有意义。在这种情况下，它给出证书路径中此证书后面的最大 CA 证书数。值为零指示路径中只有一个终端实体证书。

注意，对于 RFC 2459，如果 cA 为 TRUE（意味着此证书属于证书颁发机构），则始终将此扩展标记为关键的。

此内容的 ASN.1 定义如下：

 BasicConstraints ::= SEQUENCE {
     cA                  BOOLEAN DEFAULT FALSE,
     pathLenConstraint   INTEGER (0..MAX) OPTIONAL }

返回：
如果证书中有 BasicConstraints 扩展并且该证书的主体是 CA，则返回 pathLenConstraint 的值；否则返回 -1。如果该证书的主体是 CA 并且未出现 pathLenConstraint，则返回 Integer.MAX_VALUE，指示对于该证书路径的长度没有限制。

getSubjectAlternativeNames

public Collection<List<?>> getSubjectAlternativeNames()
                                               throws CertificateParsingException
从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。

SubjectAltName 扩展的 ASN.1 定义如下：

 SubjectAltName ::= GeneralNames

 GeneralNames :: = SEQUENCE SIZE (1..MAX) OF GeneralName

 GeneralName ::= CHOICE {
      otherName                       [0]     OtherName,
      rfc822Name                      [1]     IA5String,
      dNSName                         [2]     IA5String,
      x400Address                     [3]     ORAddress,
      directoryName                   [4]     Name,
      ediPartyName                    [5]     EDIPartyName,
      uniformResourceIdentifier       [6]     IA5String,
      iPAddress                       [7]     OCTET STRING,
      registeredID                    [8]     OBJECT IDENTIFIER}

如果此证书不包含 SubjectAltName 扩展，则返回 null。否则返回一个 Collection，其中的项表示该扩展中所包括的每个 GeneralName。每一项都是一个 List，该 List 的第一项是一个 Integer（0-8，表示名称类型），第二项是一个 String 或 byte 数组（分别为 string 或 ASN.1 DER 编码形式，表示名称）。

RFC 822、DNS 和 URI 名称是使用这些类型已定义的 string 格式（受 RFC 2459 中所包括的限制的影响）以 String 的形式返回的。使用四点表示法（dotted quad notation）返回 IPv4 地址名。以 "a1:a2:...:a8" 的形式返回 IPv6 地址名，其中 a1-a8 是十六进制值，表示该地址的 8 个 16 位部分。以 String 形式返回 OID 名称，该字符串用一系列句点分隔的非负整数来表示。以 RFC 2253 string 格式返回目录名（标识名）。没有为 otherNames、X.400 名、EDI 方名或其他所有类型的名称定义标准的 string 格式。它们是以 byte 数组的形式返回的，其中包含 ASN.1 DER 编码形式的名称。

注意，返回的 Collection 可能包含多个相同类型的名称。另外还要注意，返回的 Collection 是不可变的，并且将复制 byte 数组中所包含的所有项，以防止后续的修改。

Java 2 Platform Standard Edition 的 1.4 版本中添加了此方法。为了维持与现有服务提供者的后向兼容性，没有 abstract 此方法，并且它提供了一个默认实现。子类应该通过正确的实现重写此方法。

返回：
主体替换名称的不可变 Collection（或者为 null）
抛出：
CertificateParsingException - 如果无法对该扩展进行解码
从以下版本开始：
1.4

getIssuerAlternativeNames

public Collection<List<?>> getIssuerAlternativeNames()
                                              throws CertificateParsingException
从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。

IssuerAltName 扩展的 ASN.1 定义如下：

 IssuerAltName ::= GeneralNames
在 getSubjectAlternativeNames 中定义了 GeneralNames 的 ASN.1 定义。

如果此证书不包含 IssuerAltName 扩展，则返回 null。否则返回一个 Collection，其中的项表示该扩展中所包括的每个 GeneralName。每一项都是一个 List，该 List 的第一项是一个 Integer（0-8，表示名称类型），第二项是一个 String 或 byte 数组（分别为 string 或 ASN.1 DER 编码形式，表示名称）。有关每种名称类型所用格式的更多细节，请参见 getSubjectAlternativeNames 方法。

注意，返回的 Collection 可能包含多个相同类型的名称。另外还要注意，返回的 Collection 是不可变的，并且将复制 byte 数组中所包含的所有项，以防止后续的修改。

Java 2 Platform Standard Edition 的 1.4 版本中添加了此方法。为了维持与现有服务提供者的后向兼容性，没有 abstract 此方法，并且它提供了一个默认实现。子类应该通过正确的实现重写此方法。

返回：
发布方替换名称的不可变 Collection（或者为 null）
抛出：
CertificateParsingException - 如果无法对该扩展进行解码
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509CertSelector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 X509CertSelector

java.lang.Object
    继承者  java.security.cert.X509CertSelector
所有已实现的接口：
Cloneable, CertSelector
public class X509CertSelector
extends Object
implements CertSelector

选择与所有指定标准匹配的 X509Certificates 的 CertSelector。从 CertStore 中选择证书以构建一个符合 PKIX 的证书路径时，此类特别有用。

最初构造 X509CertSelector 时，它没有启用任何标准，并且每个 get 方法都返回一个默认值（null，对于 getBasicConstraints 方法，则返回 -1）。因此，对于任意 X509Certificate 而言，match 方法都将返回 true。通常，启用多种标准（例如通过调用 setIssuer 或 setKeyUsage），然后将 X509CertSelector 传递到 CertStore.getCertificates 或某个类似方法。

可以启用多种标准（例如通过调用 setIssuer 和 setSerialNumber），这样通常 match 方法会唯一地匹配单个 X509Certificate。我们在此说“通常”，是因为两个发布证书的 CA 可能具有相同的标识名，并且这两个 CA 发布了具有相同序列号的证书。其他独特的组合包含 issuer、subject、subjectKeyIdentifier 和/或 subjectPublicKey 标准。

有关下面所述各个 X.509 证书扩展的定义，请参阅 RFC 2459。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CertSelector, X509Certificate

构造方法摘要
X509CertSelector()
创建一个 X509CertSelector。
方法摘要
 void addPathToName(int type, byte[] name)
向 pathToNames 标准中添加一个名称。
 void addPathToName(int type, String name)
向 pathToNames 标准中添加一个名称。
 void addSubjectAlternativeName(int type, byte[] name)
向 subjectAlternativeNames 标准中添加一个名称。
 void addSubjectAlternativeName(int type, String name)
向 subjectAlternativeNames 标准中添加一个名称。
 Object clone()
返回此对象的副本。
 byte[] getAuthorityKeyIdentifier()
返回 authorityKeyIdentifier 标准。
 int getBasicConstraints()
返回 BasicConstraints 限制。
 X509Certificate getCertificate()
返回 certificateEquals 标准。
 Date getCertificateValid()
返回 certificateValid 标准。
 Set<String> getExtendedKeyUsage()
返回 extendedKeyUsage 标准。
 X500Principal getIssuer()
以 X500Principal 的形式返回 issuer 标准。
 byte[] getIssuerAsBytes()
返回以 byte 数组表示的 issuer 标准。
 String getIssuerAsString()
已过时，使用 getIssuer() 或 getIssuerAsBytes() 替代。
 boolean[] getKeyUsage()
返回 keyUsage 标准。
 boolean getMatchAllSubjectAltNames()
指示 X509Certificate 是否必须包含 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有或至少某个 subjectAlternativeNames。
 byte[] getNameConstraints()
返回 NameConstraints 标准。
 Collection<List<?>> getPathToNames()
返回 pathToNames 标准的一个副本。
 Set<String> getPolicy()
返回策略标准。
 Date getPrivateKeyValid()
返回 privateKeyValid 标准。
 BigInteger getSerialNumber()
返回 serialNumber 标准。
 X500Principal getSubject()
以 X500Principal 的形式返回 subject 标准。
 Collection<List<?>> getSubjectAlternativeNames()
返回 subjectAlternativeNames 标准的一个副本。
 byte[] getSubjectAsBytes()
以 byte 数组的形式返回 subject 标准。
 String getSubjectAsString()
已过时，使用 getSubject() 或 getSubjectAsBytes() 替代。
 byte[] getSubjectKeyIdentifier()
返回 subjectKeyIdentifier 标准。
 PublicKey getSubjectPublicKey()
返回 subjectPublicKey 标准。
 String getSubjectPublicKeyAlgID()
返回 subjectPublicKeyAlgID 标准。
 boolean match(Certificate cert)
决定是否应该选择某个 Certificate。
 void setAuthorityKeyIdentifier(byte[] authorityKeyID)
设置 authorityKeyIdentifier 扩展。
 void setBasicConstraints(int minMaxPathLen)
设置 basicConstraints 限制。
 void setCertificate(X509Certificate cert)
设置 certificateEquals 标准。
 void setCertificateValid(Date certValid)
设置 certificateValid 标准。
 void setExtendedKeyUsage(Set<String> keyPurposeSet)
设置 extendedKeyUsage 标准。
 void setIssuer(byte[] issuerDN)
设置 issuer 标准。
 void setIssuer(String issuerDN)
已过时，使用 setIssuer(X500Principal) 或 setIssuer(byte[]) 替代。
 void setIssuer(X500Principal issuer)
设置 issuer 标准。
 void setKeyUsage(boolean[] keyUsage)
设置 keyUsage 标准。
 void setMatchAllSubjectAltNames(boolean matchAllNames)
允许/禁止匹配 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有 subjectAlternativeNames。
 void setNameConstraints(byte[] bytes)
设置 NameConstraints 标准。
 void setPathToNames(Collection<List<?>> names)
设置 pathToNames 标准。
 void setPolicy(Set<String> certPolicySet)
设置策略限制。
 void setPrivateKeyValid(Date privateKeyValid)
设置 privateKeyValid 标准。
 void setSerialNumber(BigInteger serial)
设置 serialNumber 标准。
 void setSubject(byte[] subjectDN)
设置 subject 标准。
 void setSubject(String subjectDN)
已过时，使用 setSubject(X500Principal) 或 setSubject(byte[]) 替代。
 void setSubject(X500Principal subject)
设置 subject 标准。
 void setSubjectAlternativeNames(Collection<List<?>> names)
设置 subjectAlternativeNames 标准。
 void setSubjectKeyIdentifier(byte[] subjectKeyID)
设置 subjectKeyIdentifier 标准。
 void setSubjectPublicKey(byte[] key)
设置 subjectPublicKey 标准。
 void setSubjectPublicKey(PublicKey key)
设置 subjectPublicKey 标准。
 void setSubjectPublicKeyAlgID(String oid)
设置 subjectPublicKeyAlgID 标准。
 String toString()
返回该 CertSelector 的可打印表示形式。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

X509CertSelector

public X509CertSelector()
创建一个 X509CertSelector。最初未设置任何标准，所以任何 X509Certificate 都匹配。

方法详细信息

setCertificate

public void setCertificate(X509Certificate cert)
设置 certificateEquals 标准。指定的 X509Certificate 必须等于传入到 match 方法的 X509Certificate。如果它为 null，则不进行此项检查。

必需与单个证书匹配时，此方法特别有用。虽然可以与 certificateEquals 标准一起指定其他标准，但这样做通常不实用或不必要。

参数：
cert - 要匹配的 X509Certificate（或者为 null）
另请参见：
getCertificate()

setSerialNumber

public void setSerialNumber(BigInteger serial)
设置 serialNumber 标准。指定的 serialNumber 必须与 X509Certificate 中的证书 serialNumber 匹配。如果该 serialNumber 为 null，则与任何证书 serialNumber 匹配都可以。

参数：
serial - 要匹配的证书 serialNumber（或者为 null）
另请参见：
getSerialNumber()

setIssuer

public void setIssuer(X500Principal issuer)
设置 issuer 标准。指定的标识名必须与 X509Certificate 中的发布方标识名匹配。如果该发布方标识名为 null，则与任何发布方 标识名匹配都可以。

参数：
issuer - X500Principal 形式的标识名（或者为 null）
从以下版本开始：
1.5

setIssuer

public void setIssuer(String issuerDN)
               throws IOException
已过时，使用 setIssuer(X500Principal) 或 setIssuer(byte[]) 替代。由于某些 RFC 2253 String 形式的标识名中会丢失编码信息，所以当此方法与某些证书不匹配时不应该依赖它。

设置 issuer 标准。指定的标识名必须与 X509Certificate 中的发布方标识名匹配。如果该发布方标识名为 null，则与任何发布方标识名匹配都可以。

如果 issuerDN 不为 null，则应该包含一个 RFC 2253 格式的标识名。

参数：
issuerDN - RFC 2253 格式的标识名（或者为 null）
抛出：
IOException - 如果出现解析错误（错误的 DN 形式）

setIssuer

public void setIssuer(byte[] issuerDN)
               throws IOException
设置 issuer 标准。指定的标识名必须与 X509Certificate 中的发布方标识名匹配。如果指定了 null，则禁用 issuer 标准，且与任何发布方标识名匹配都可以。

如果 issuerDN 不为 null，则应该包含单个 DER 编码形式的标识名，正如 X.501 中定义的一样。此结构的 ASN.1 表示如下：

 Name ::= CHOICE {
   RDNSequence }

 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName

 RelativeDistinguishedName ::=
   SET SIZE (1 .. MAX) OF AttributeTypeAndValue

 AttributeTypeAndValue ::= SEQUENCE {
   type     AttributeType,
   value    AttributeValue }

 AttributeType ::= OBJECT IDENTIFIER

 AttributeValue ::= ANY DEFINED BY AttributeType
 ....
 DirectoryString ::= CHOICE {
       teletexString           TeletexString (SIZE (1..MAX)),
       printableString         PrintableString (SIZE (1..MAX)),
       universalString         UniversalString (SIZE (1..MAX)),
       utf8String              UTF8String (SIZE (1.. MAX)),
       bmpString               BMPString (SIZE (1..MAX)) }

注意，要复制此处指定的 byte 数组以防后续修改。

参数：
issuerDN - 一个 byte 数组，包含 ASN.1 DER 编码形式的标识名（或者为 null）
抛出：
IOException - 如果出现编码错误（错误的 DN 形式）

setSubject

public void setSubject(X500Principal subject)
设置 subject 标准。指定的标识名必须与 X509Certificate 中的主体标识名匹配。如果该主体标识名为 null，则与任何主体标识名匹配都可以。

参数：
subject - X500Principal 形式的标识名（或者为 null）
从以下版本开始：
1.5

setSubject

public void setSubject(String subjectDN)
                throws IOException
已过时，使用 setSubject(X500Principal) 或 setSubject(byte[]) 替代。由于某些 RFC 2253 String 形式的标识名中会丢失编码信息，所以当此方法与某些证书不匹配时不应该依赖它。

设置 subject 标准。指定的标识名必须与 X509Certificate 中的 主体标识名匹配。如果该主体标识名为 null，则与任何主体标识名匹配都可以。

如果 subjectDN 不为 null，则应该包含一个 RFC 2253 格式的标识名。

参数：
subjectDN - RFC 2253 格式的标识名（或者为 null）
抛出：
IOException - 如果出现解析错误（错误的 DN 形式）

setSubject

public void setSubject(byte[] subjectDN)
                throws IOException
设置 subject 标准。指定的标识名必须与 X509Certificate 中的主体标识名匹配。如果该主体标识名为 null，则与任何主体标识名匹配都可以。

如果 subjectDN 不为 null，则应该包含单个 DER 编码形式的标识名，正如 X.501 中定义的一样。有关此结构的 ASN.1 表示，请参阅 setIssuer(byte [] issuerDN)。

参数：
subjectDN - 一个 byte 数组，包含 ASN.1 DER 格式的标识名（或者为 null）
抛出：
IOException - 如果出现编码错误（错误的 DN 形式）

setSubjectKeyIdentifier

public void setSubjectKeyIdentifier(byte[] subjectKeyID)
设置 subjectKeyIdentifier 标准。X509Certificate 必须包含一个 SubjectKeyIdentifier 扩展，且该扩展的内容与指定的标准值匹配。如果该标准值为 null，则不执行 subjectKeyIdentifier 检查。

如果 subjectKeyID 不为 null，则应该包含与 SubjectKeyIdentifier 扩展的扩展值内容（不包括对象标识符、关键性设置和封装 OCTET STRING）相对应的 DER 编码形式的值。此结构的 ASN.1 表示如下：

 SubjectKeyIdentifier ::= KeyIdentifier

 KeyIdentifier ::= OCTET STRING

由于任何标准都没有要求 SubjectKeyIdentifier 的格式，所以 X509CertSelector 不解析 SubjectKeyIdentifier。相反，使用逐字节比较的方式来比较该值。

注意，要复制此处提供的 byte 数组以防后续修改。

参数：
subjectKeyID - SubjectKeyIdentifier（或者为 null）
另请参见：
getSubjectKeyIdentifier()

setAuthorityKeyIdentifier

public void setAuthorityKeyIdentifier(byte[] authorityKeyID)
设置 authorityKeyIdentifier 扩展。X509Certificate 必须包含一个 AuthorityKeyIdentifier 扩展，且该扩展值的内容与指定的标准值匹配。如果该标准值为 null，则不执行 authorityKeyIdentifier 检查。

如果 authorityKeyID 不为 null，则应该包含单个与 AuthorityKeyIdentifier 扩展的扩展值内容（不包括对象标识符、关键性设置和封装 OCTET STRING）相对应的 DER 编码形式的值。此结构的 ASN.1 表示如下：

 AuthorityKeyIdentifier ::= SEQUENCE {
    keyIdentifier             [0] KeyIdentifier           OPTIONAL,
    authorityCertIssuer       [1] GeneralNames            OPTIONAL,
    authorityCertSerialNumber [2] CertificateSerialNumber OPTIONAL  }

 KeyIdentifier ::= OCTET STRING

X509CertSelector 不解析 AuthorityKeyIdentifier。相反，使用逐字节比较的方式来比较该值。

生成 AuthorityKeyIdentifier 的 keyIdentifier 字段时，通常从发布方证书中的 SubjectKeyIdentifier 扩展中获取该值。但是要注意，在发布方的证书上执行 X509Certificate.getExtensionValue(<SubjectKeyIdentifier Object Identifier>) 所得到的结果可能无法直接用作 setAuthorityKeyIdentifier 的输入。这是因为 SubjectKeyIdentifier 只包含一个 KeyIdentifier OCTET STRING（八位字节字符串），而不是 KeyIdentifier、GeneralNames 和 CertificateSerialNumber 的 SEQUENCE。为了使用发布方证书的 SubjectKeyIdentifier 扩展的扩展值，必需提取嵌入的 KeyIdentifier OCTET STRING 值，然后将此 OCTET STRING 以 DER 编码方式放入一个 SEQUENCE 中。有关 SubjectKeyIdentifier 的更多详细信息，请参见 setSubjectKeyIdentifier(byte[] subjectKeyID)。

还要注意，要复制此处提供的 byte 数组以防后续修改。

参数：
authorityKeyID - AuthorityKeyIdentifier（或者为 null）
另请参见：
getAuthorityKeyIdentifier()

setCertificateValid

public void setCertificateValid(Date certValid)
设置 certificateValid 标准。指定的日期必须在 X509Certificate 的证书有效期内。如果其值为 null，则不执行 certificateValid 检查。

注意，要复制此处提供的 Date 以防后续修改。

参数：
certValid - 要检查的 Date（或者为 null）
另请参见：
getCertificateValid()

setPrivateKeyValid

public void setPrivateKeyValid(Date privateKeyValid)
设置 privateKeyValid 标准。指定的日期必须在 X509Certificate 的私钥有效期内。如果为 null，则不执行 privateKeyValid 检查。

注意，要复制此处提供的 Date 以防后续修改。

参数：
privateKeyValid - 要检查的 Date（或者为 null）
另请参见：
getPrivateKeyValid()

setSubjectPublicKeyAlgID

public void setSubjectPublicKeyAlgID(String oid)
                              throws IOException
设置 subjectPublicKeyAlgID 标准。X509Certificate 必须包含一个具有指定算法的主体公钥。如果其值为 null，则不执行 subjectPublicKeyAlgID 检查。

参数：
oid - 用于检查的算法的对象标识符 (OID)（或者为 null）。OID 由一组句点分隔的非负整数来表示。
抛出：
IOException - 如果该 OID 无效，例如其第一部分不是 0、1 或 2，或第二部分大于 39。
另请参见：
getSubjectPublicKeyAlgID()

setSubjectPublicKey

public void setSubjectPublicKey(PublicKey key)
设置 subjectPublicKey 标准。X509Certificate 必须包含指定的主体公钥。如果其值为 null，则不执行 subjectPublicKey 检查。

参数：
key - 用于检查的 subjectPublicKey（或者为 null）
另请参见：
getSubjectPublicKey()

setSubjectPublicKey

public void setSubjectPublicKey(byte[] key)
                         throws IOException
设置 subjectPublicKey 标准。X509Certificate 必须包含指定的主体公钥。如果其值为 null，则不执行 subjectPublicKey 检查。

因为此方法允许以 byte 数组的方式指定公钥，所以可将其用于未知的密钥类型。

如果 key 不为 null，则它应该包含单个 DER 编码形式的 SubjectPublicKeyInfo 结构，正如 X.509 中定义的一样。此结构的 ASN.1 表示如下：

 SubjectPublicKeyInfo  ::=  SEQUENCE  {
   algorithm            AlgorithmIdentifier,
   subjectPublicKey     BIT STRING  }

 AlgorithmIdentifier  ::=  SEQUENCE  {
   algorithm               OBJECT IDENTIFIER,
   parameters              ANY DEFINED BY algorithm OPTIONAL  }
                              -- contains a value of the type
                              -- registered for use with the
                              -- algorithm object identifier value

注意，要复制此处提供的 byte 数组以防后续修改。

参数：
key - 一个 byte 数组，包含 ASN.1 DER 编码形式的 subjectPublicKey（或者为 null）
抛出：
IOException - 如果出现编码错误（subjectPublicKey 形式不正确）
另请参见：
getSubjectPublicKey()

setKeyUsage

public void setKeyUsage(boolean[] keyUsage)
设置 keyUsage 标准。X509Certificate 必须允许使用指定的 keyUsage 值。如果其值为 null，则不执行 keyUsage 检查。注意，没有 keyUsage 扩展的 X509Certificate 隐式地允许使用所有 keyUsage 值。

注意，要复制此处提供的 boolean 数组以防后续修改。

参数：
keyUsage - 一个 boolean 数组，其格式与 X509Certificate.getKeyUsage() 返回的 boolean 数组格式相同。或者为 null。
另请参见：
getKeyUsage()

setExtendedKeyUsage

public void setExtendedKeyUsage(Set<String> keyPurposeSet)
                         throws IOException
设置 extendedKeyUsage 标准。X509Certificate 必须允许其 extendedKeyUsage 扩展中的指定 keyPurpose。如果 keyPurposeSet 为空或为 null，则不执行 extendedKeyUsage 检查。注意，没有 extendedKeyUsage 扩展的 X509Certificate 隐式地允许所有 keyPurpose。

注意，要复制该 Set 以防后续修改。

参数：
keyPurposeSet - string 格式的 keyPurpose OID 的 Set（或者为 null）。每个 OID 都由一组句点分隔的非负整数来表示。
抛出：
IOException - 如果该 OID 无效，例如其第一部分不是 0、1 或 2，或第二部分大于 39。
另请参见：
getExtendedKeyUsage()

setMatchAllSubjectAltNames

public void setMatchAllSubjectAltNames(boolean matchAllNames)
允许/禁止匹配 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有 subjectAlternativeNames。如果允许匹配，则 X509Certificate 必须包含所有指定的 subjectAlternativeNames。如果禁止匹配，则 X509Certificate 至少必须包含某个指定的 subjectAlternativeName。

默认情况下，matchAllNames 标志为 true。

参数：
matchAllNames - 如果为 true，则启用该标志；如果为 false，则禁用该标志。
另请参见：
getMatchAllSubjectAltNames()

setSubjectAlternativeNames

public void setSubjectAlternativeNames(Collection<List<?>> names)
                                throws IOException
设置 subjectAlternativeNames 标准。X509Certificate 必须包含所有或至少某个指定的 subjectAlternativeNames，这取决于 matchAllNames 标志的值（参见 setMatchAllSubjectAltNames）。

此方法允许调用方（使用单个方法调用）为 subjectAlternativeNames 标准指定完整的 subjectAlternativeNames 集。指定的值会替换 subjectAlternativeNames 标准以前的值。

names 参数（如果不为 null）是一个 Collection，subjectAlternativeNames 标准中所包括的每个名称都对应该集合中的一项。每一项都是一个 List，该 List 的第一项是一个 Integer（0-8，表示名称类型），第二项是一个 String 或 byte 数组（分别为 string 或 ASN.1 DER 编码形式，表示名称）。相同类型可以有多个名称。如果为此参数提供的值为 null，则不执行 subjectAlternativeNames 检查。

Collection 中的每个 subjectAlternativeNames 都可以指定为一个 String 或 一个 ASN.1 编码的 byte 数组。有关所用格式的更多详细信息，请参阅 addSubjectAlternativeName(int type, String name) 和 addSubjectAlternativeName(int type, byte [] name)。

注：对于标识名，应指定为 byte 数组，而不是 String。有关更多信息，请参阅 addSubjectAlternativeName(int, String) 中的注视。

注意，names 参数可以包含重复的名称（相同的名称和名称类型），但是可能从 getSubjectAlternativeNames 方法返回的名称 Collection 中将这些名称移除。

注意，要对该 Collection 执行深层复制以防后续修改。

参数：
names - 一个名称 Collection（或者为 null）
抛出：
IOException - 如果出现解析错误
另请参见：
getSubjectAlternativeNames()

addSubjectAlternativeName

public void addSubjectAlternativeName(int type,
                                      String name)
                               throws IOException
向 subjectAlternativeNames 标准中添加一个名称。X509Certificate 必须包含所有或至少某个指定的 subjectAlternativeNames，这取决于 matchAllNames 标志的值（参见 setMatchAllSubjectAltNames）。

此方法允许调用方向 subjectAlternativeNames 集中添加一个名称。将指定的名称添加到 subjectAlternativeNames 标准的以前值中。如果指定的名称是重复的，则忽略它。

以 string 格式提供该名称。RFC 822、DNS 和 URI 名称使用这些类型（受 RFC 2459 中所包括的限制的影响）的 string 格式。使用四点表示法（dotted quad notation）提供 IPv4 地址名。OID 地址名用一系列句点分隔的非负整数来表示。以 RFC 2253 格式提供目录名（标识名）。对于 otherNames、X.400 名、EDI 方的名称、IPv6 地址名或其他所有名称类型，则没有定义标准 string 格式。应该使用 addSubjectAlternativeName(int type, byte [] name) 方法指定它们。

注：对于标识名，请使用 addSubjectAlternativeName(int, byte[])。由于某些 RFC 2253 String 形式的标识名中会丢失编码信息，所以当此方法与某些证书不匹配时不应该依赖它。

参数：
type - 名称类型（0-8，在 RFC 2459 的 4.2.1.7 部分中指定）
name - string 形式的名称（不能为 null）
抛出：
IOException - 如果出现解析错误

addSubjectAlternativeName

public void addSubjectAlternativeName(int type,
                                      byte[] name)
                               throws IOException
向 subjectAlternativeNames 标准中添加一个名称。X509Certificate 必须包含所有或至少某个指定的 subjectAlternativeNames，这取决于 matchAllNames 标志的值（参见 setMatchAllSubjectAltNames）。

此方法允许调用方向 subjectAlternativeNames 集中添加一个名称。将指定的名称添加到 subjectAlternativeNames 标准的以前值中。如果指定的名称是重复的，则忽略它。

以 byte 数组的形式提供该名称。此 byte 数组应该包含 DER 编码名称，因为它将出现在 RFC 2459 和 X.509 内所定义的 GeneralName 结构中。已编码的 byte 数组应该只包含该名称的已编码值，不应该包括 GeneralName 结构中与该名称关联的标记。此结构的 ASN.1 定义如下：

  GeneralName ::= CHOICE {
       otherName                       [0]     OtherName,
       rfc822Name                      [1]     IA5String,
       dNSName                         [2]     IA5String,
       x400Address                     [3]     ORAddress,
       directoryName                   [4]     Name,
       ediPartyName                    [5]     EDIPartyName,
       uniformResourceIdentifier       [6]     IA5String,
       iPAddress                       [7]     OCTET STRING,
       registeredID                    [8]     OBJECT IDENTIFIER}

注意，要复制此处提供的 byte 数组以防后续修改。

参数：
type - 名称类型（0-8，如上所列）
name - 一个 byte 数组，包含 ASN.1 DER 编码形式的名称
抛出：
IOException - 如果出现解析错误

setNameConstraints

public void setNameConstraints(byte[] bytes)
                        throws IOException
设置 NameConstraints 标准。X509Certificate 必须具有满足指定 NameConstraints 要求的 subject 和 subjectAlternativeNames。

以 byte 数组的形式指定该 NameConstraints。此 byte 数组应该包含 DER 编码形式的 NameConstraints，因为它们将出现在 RFC 2459 和 X.509 内所定义的 NameConstraints 结构中。此结构的 ASN.1 定义如下：

  NameConstraints ::= SEQUENCE {
       permittedSubtrees       [0]     GeneralSubtrees OPTIONAL,
       excludedSubtrees        [1]     GeneralSubtrees OPTIONAL }

  GeneralSubtrees ::= SEQUENCE SIZE (1..MAX) OF GeneralSubtree

  GeneralSubtree ::= SEQUENCE {
       base                    GeneralName,
       minimum         [0]     BaseDistance DEFAULT 0,
       maximum         [1]     BaseDistance OPTIONAL }

  BaseDistance ::= INTEGER (0..MAX)

  GeneralName ::= CHOICE {
       otherName                       [0]     OtherName,
       rfc822Name                      [1]     IA5String,
       dNSName                         [2]     IA5String,
       x400Address                     [3]     ORAddress,
       directoryName                   [4]     Name,
       ediPartyName                    [5]     EDIPartyName,
       uniformResourceIdentifier       [6]     IA5String,
       iPAddress                       [7]     OCTET STRING,
       registeredID                    [8]     OBJECT IDENTIFIER}

注意，要复制此处提供的 byte 数组以防后续修改。

参数：
bytes - 一个 byte 数组，包含为检查 NameConstraints 所使用的 NameConstraints 扩展的 ASN.1 DER 编码。只包括该扩展的值，不包括 OID 或关键性标志。其值可以为 null，此时将不执行 NameConstraints 检查。
抛出：
IOException - 如果出现解析错误
另请参见：
getNameConstraints()

setBasicConstraints

public void setBasicConstraints(int minMaxPathLen)
设置 basicConstraints 限制。如果该值大于等于零，则 X509Certificates 包括的 basicConstraints 扩展具有的 pathLen 不能小于此值。如果该值为 -2，则只接受最终实体证书。如果该值为 -1，则不执行检查。

构建正向证书路径（从目标到受信定位点）时，此限制很有用。如果已构建了部分路径，则任何候选证书的 maxPathLen 值都必须大于等于这些路径中的证书数。

参数：
minMaxPathLen - basicConstraints 限制的值
抛出：
IllegalArgumentException - 如果该值小于 -2
另请参见：
getBasicConstraints()

setPolicy

public void setPolicy(Set<String> certPolicySet)
               throws IOException
设置策略限制。X509Certificate 至少必须包括其证书策略扩展中指定的一种策略。如果 certPolicySet 为空，则 X509Certificate 至少必须包括其证书策略扩展中指定的某个策略。如果 certPolicySet 为 null，则不执行策略检查。

注意，要复制该 Set 以防后续修改。

参数：
certPolicySet - string 格式的证书策略 OID 的 Set（或者为 null）。每个 OID 都由一组句点分隔的非负整数来表示。
抛出：
IOException - 如果出现 OID 的解析错误，例如其第一部分不是 0、1 或 2，或第二部分大于 39。
另请参见：
getPolicy()

setPathToNames

public void setPathToNames(Collection<List<?>> names)
                    throws IOException
设置 pathToNames 标准。X509Certificate 不能包括禁止构建指定名称路径的 NameConstraints。

此方法允许调用方（使用单个方法调用）指定 X509Certificates 的 NameConstraints 必须允许使用的完整名称集。指定的值会替换 pathToNames 标准以前的值。

构建正向证书路径（从目标到受信定位点）时，此限制很有用。如果已构建了部分路径，则任何候选证书所包括的 NameConstraints 都不能禁止构建到达这些路径中任意名称的路径。

names 参数（如果不为 null）是一个 Collection，pathToNames 标准中所包括的每个名称都对应该集合中的一项。每一项都是一个 List，该 List 的第一项是一个 Integer（0-8，表示名称类型），第二项是一个 String 或 byte 数组（分别为 string 或 ASN.1 DER 编码形式，表示名称）。相同类型可以有多个名称。如果提供的参数值为 null，则不执行 pathToNames 检查。

Collection 中的每个名称都可以指定为一个 String 或一个 ASN.1 编码的 byte 数组。有关所用格式的更多详细信息，请参阅 addPathToName(int type, String name) 和 addPathToName(int type, byte [] name)。

注：对于标识名，应指定为 byte 数组，而不是 String。有关更多信息，请参阅 addPathToName(int, String) 中的注释。

注意，names 参数可以包含重复的名称（相同的名称和名称类型），但是可能从 getPathToNames 方法返回的名称 Collection 中将这些名称移除。

注意，要对该 Collection 执行深层复制以防后续修改。

参数：
names - 每个名称都对应一项的 Collection（或者为 null）
抛出：
IOException - 如果出现解析错误
另请参见：
getPathToNames()

addPathToName

public void addPathToName(int type,
                          String name)
                   throws IOException
向 pathToNames 标准中添加一个名称。X509Certificate 不能包括禁止构建指定名称路径的 NameConstraints。

此方法允许调用方向 X509Certificates 的 NameConstraints 必须允许使用的名称集中添加一个名称。将指定的名称添加到 pathToNames 标准的以前值中。如果该名称是重复的，则忽略它。

以 string 格式提供该名称。RFC 822、DNS 和 URI 名称使用这些类型（受 RFC 2459 中所包括的限制的影响）的 string 格式。使用四点表示法（dotted quad notation）提供 IPv4 地址名。OID 地址名用一系列句点分隔的非负整数来表示。以 RFC 2253 格式提供目录名（标识名）。对于 otherNames、X.400 名、EDI 方的名称、IPv6 地址名或其他所有名称类型，则没有定义标准 string 格式。应该使用 addPathToName(int type, byte [] name) 方法指定它们。

注：对于标识名，请使用 addPathToName(int, byte[])。由于某些 RFC 2253 String 形式的标识名中会丢失编码信息，所以当此方法与某些证书不匹配时不应该依赖它。

参数：
type - 名称类型（0-8，在 RFC 2459 的 4.2.1.7 部分中指定）
name - string 形式的名称
抛出：
IOException - 如果出现解析错误

addPathToName

public void addPathToName(int type,
                          byte[] name)
                   throws IOException
向 pathToNames 标准中添加一个名称。X509Certificate 不能包括禁止构建指定名称路径的 NameConstraints。

此方法允许调用方向 X509Certificates 的 NameConstraints 必须允许使用的名称集中添加一个名称。将指定的名称添加到 pathToNames 标准的以前值中。如果该名称是重复的，则忽略它。

以 byte 数组的形式提供该名称。此 byte 数组应该包含 DER 编码名称，因为它将出现在 RFC 2459 和 X.509 内所定义的 GeneralName 结构中。addSubjectAlternativeName(int type, byte [] name) 的文档中有此结构的 ASN.1 定义。

注意，要复制此处提供的 byte 数组以防后续修改。

参数：
type - 名称类型（0-8，在 RFC 2459 的 4.2.1.7 部分中指定）
name - 一个 byte 数组，包含 ASN.1 DER 编码名称
抛出：
IOException - 如果出现解析错误

getCertificate

public X509Certificate getCertificate()
返回 certificateEquals 标准。指定的 X509Certificate 必须等于传入到 match 方法的 X509Certificate。如果它为 null，则不进行此项检查。

返回：
要匹配的 X509Certificate（或者为 null）
另请参见：
setCertificate(java.security.cert.X509Certificate)

getSerialNumber

public BigInteger getSerialNumber()
返回 serialNumber 标准。指定的 serialNumber 必须与 X509Certificate 中的证书 serialNumber 匹配。如果该 serialNumber 为 null，则任何证书 serialNumber 都可以。

返回：
要匹配的证书 serialNumber（或者为 null）
另请参见：
setSerialNumber(java.math.BigInteger)

getIssuer

public X500Principal getIssuer()
以 X500Principal 的形式返回 issuer 标准。此标识名必须与 X509Certificate 中的发布方标识名匹配。如果该发布方标识名为 null，则禁用 issuer 标准，且与任何发布方标识名匹配都可以。

返回：
以 X500Principal 形式返回所要求的发布方标识名（或者为 null）
从以下版本开始：
1.5

getIssuerAsString

public String getIssuerAsString()
已过时，使用 getIssuer() 或 getIssuerAsBytes() 替代。由于某些 RFC 2253 String 形式的标识名中会丢失编码信息，所以当此方法与某些证书不匹配时不应该依赖它。

返回以 String 表示的 issuer 标准。此标识名必须与 X509Certificate 中的发布方标识名匹配。如果该发布方标识名为 null，则禁用 issuer 标准，且与任何发布方标识名匹配都可以。

如果返回的值不为 null，则是一个 RFC 2253 格式的标识名。

返回：
以 RFC 2253 格式返回所要求的发布方标识名（或者为 null）

getIssuerAsBytes

public byte[] getIssuerAsBytes()
                        throws IOException
返回以 byte 数组表示的 issuer 标准。此标识名必须与 X509Certificate 中的发布方标识名匹配。如果该发布方标识名为 null，则禁用 issuer 标准，且与任何发布方标识名匹配都可以。

如果返回的值不为 null，则是包含单个 DER 编码形式的标识名的 byte 数组，正如 X.501 中定义的一样。setIssuer(byte [] issuerDN) 的文档中提供了此结构的 ASN.1 表示。

注意，要复制返回的 byte 数组以防后续修改。

返回：
一个 byte 数组，以 ASN.1 DER 格式包含所要求的发布方标识名（或者为 null）
抛出：
IOException - 如果出现编码错误

getSubject

public X500Principal getSubject()
以 X500Principal 的形式返回 subject 标准。此标识名必须与 X509Certificate 中的主体标识名匹配。如果该主体标识名为 null，则禁用 subject 标准，且与任何主体标识名匹配都可以。

返回：
以 X500Principal 形式返回所要求的主体标识名（或者为 null）
从以下版本开始：
1.5

getSubjectAsString

public String getSubjectAsString()
已过时，使用 getSubject() 或 getSubjectAsBytes() 替代。由于某些 RFC 2253 String 形式的标识名中会丢失编码信息，所以当此方法与某些证书不匹配时不应该依赖它。

返回以 String 表示的 subject 标准。此标识名必须与 X509Certificate 中的主体标识名匹配。如果该主体标识名为 null，则禁用 subject 标准，且与任何主体标识名匹配都可以。

如果返回的值不为 null，则是一个 RFC 2253 格式的标识名。

返回：
以 RFC 2253 格式返回所要求的主体标识名（或者为 null）

getSubjectAsBytes

public byte[] getSubjectAsBytes()
                         throws IOException
以 byte 数组的形式返回 subject 标准。此标识名必须与 X509Certificate 中的主体标识名匹配。如果该主体标识名为 null，则禁用 subject 标准，且与任何主体标识名匹配都可以。

如果返回的值不为 null，则是包含单个 DER 编码形式的标识名的 byte 数组，正如 X.501 中定义的一样。setSubject(byte [] subjectDN) 的文档中提供了此结构的 ASN.1 表示。

注意，要复制返回的 byte 数组以防后续修改。

返回：
一个 byte 数组，以 ASN.1 DER 格式包含所要求的主体标识名（或者为 null）
抛出：
IOException - 如果出现编码错误

getSubjectKeyIdentifier

public byte[] getSubjectKeyIdentifier()
返回 subjectKeyIdentifier 标准。X509Certificate 必须包含一个具有指定值的 SubjectKeyIdentifier 扩展。如果其值为 null，则不执行 subjectKeyIdentifier 检查。

注意，要复制返回的 byte 数组以防后续修改。

返回：
密钥标识符（或者为 null）
另请参见：
setSubjectKeyIdentifier(byte[])

getAuthorityKeyIdentifier

public byte[] getAuthorityKeyIdentifier()
返回 authorityKeyIdentifier 标准。X509Certificate 必须包含一个具有指定值的 AuthorityKeyIdentifier 扩展。如果其值为 null，则不执行 authorityKeyIdentifier 检查。

注意，要复制返回的 byte 数组以防后续修改。

返回：
密钥标识符（或者为 null）
另请参见：
setAuthorityKeyIdentifier(byte[])

getCertificateValid

public Date getCertificateValid()
返回 certificateValid 标准。指定的日期必须在 X509Certificate 的证书有效期内。如果其值为 null，则不执行 certificateValid 检查。

注意，要复制返回的 Date 以防后续修改。

返回：
要检查的 Date（或者为 null）
另请参见：
setCertificateValid(java.util.Date)

getPrivateKeyValid

public Date getPrivateKeyValid()
返回 privateKeyValid 标准。指定的日期必须在 X509Certificate 的私钥有效期内。如果其值为 null，则不执行 privateKeyValid 检查。

注意，要复制返回的 Date 以防后续修改。

返回：
要检查的 Date（或者为 null）
另请参见：
setPrivateKeyValid(java.util.Date)

getSubjectPublicKeyAlgID

public String getSubjectPublicKeyAlgID()
返回 subjectPublicKeyAlgID 标准。X509Certificate 必须包含一个具有指定算法的主体公钥。如果其值为 null，则不执行 subjectPublicKeyAlgID 检查。

返回：
用于检查的签名算法的对象标识符 (OID)（或者为 null）。OID 由一组句点分隔的非负整数来表示。
另请参见：
setSubjectPublicKeyAlgID(java.lang.String)

getSubjectPublicKey

public PublicKey getSubjectPublicKey()
返回 subjectPublicKey 标准。X509Certificate 必须包含指定的主体公钥。如果其值为 null，则不执行 subjectPublicKey 检查。

返回：
用于检查的 subjectPublicKey（或者为 null）
另请参见：
setSubjectPublicKey(java.security.PublicKey)

getKeyUsage

public boolean[] getKeyUsage()
返回 keyUsage 标准。X509Certificate 必须允许使用指定的 keyUsage 值。如果其值为 null，则不执行 keyUsage 检查。

注意，要复制返回的 boolean 数组以防后续修改。

返回：
一个 boolean 数组，其格式与 X509Certificate.getKeyUsage() 返回的 boolean 数组格式相同。或者为 null。
另请参见：
setKeyUsage(boolean[])

getExtendedKeyUsage

public Set<String> getExtendedKeyUsage()
返回 extendedKeyUsage 标准。X509Certificate 必须允许其 extendedKeyUsage 扩展中的指定 keyPurpose。如果返回的 keyPurposeSet 为空或为 null，则不执行 extendedKeyUsage 检查。注意，没有 extendedKeyUsage 扩展的 X509Certificate 隐式地允许所有 keyPurpose。

返回：
一个 string 格式的 keyPurpose OID 的不可变 Set（或者为 null）
另请参见：
setExtendedKeyUsage(java.util.Set)

getMatchAllSubjectAltNames

public boolean getMatchAllSubjectAltNames()
指示 X509Certificate 是否必须包含 setSubjectAlternativeNames 或 addSubjectAlternativeName 方法中所指定的所有或至少某个 subjectAlternativeNames。如果此方法返回值为 true，则 X509Certificate 必须包含所有指定的 subjectAlternativeNames。如果为 false，则 X509Certificate 必须至少包含某个指定的 subjectAlternativeNames。

返回：
如果启用此标志，则返回 true；如果禁用此标志，则返回 false。默认情况下此标志为 true。
另请参见：
setMatchAllSubjectAltNames(boolean)

getSubjectAlternativeNames

public Collection<List<?>> getSubjectAlternativeNames()
返回 subjectAlternativeNames 标准的一个副本。X509Certificate 必须包含所有或至少某个指定的 subjectAlternativeNames，这取决于 matchAllNames 标志的值（参见 getMatchAllSubjectAltNames）。如果返回的值为 null，则不执行 subjectAlternativeNames 检查。

如果返回的值不为 null，则是一个 Collection，subjectAlternativeNames 标准中所包括的每个名称在该集合中都对应一项。每一项都是一个 List，该 List 的第一项是一个 Integer（0-8，表示名称类型），第二项是一个 String 或 byte 数组（分别为 string 或 ASN.1 DER 编码形式，表示名称）。相同类型可以有多个名称。注意，返回的 Collection 可能包含重复的名称（相同的名称和名称类型）。

Collection 中的每个 subjectAlternativeNames 都可以指定为一个 String 或 一个 ASN.1 编码的 byte 数组。有关所用格式的更多详细信息，请参阅 addSubjectAlternativeName(int type, String name) 和 addSubjectAlternativeName(int type, byte [] name)。

注意，要对该 Collection 执行深层复制以防后续修改。

返回：
一个名称 Collection（或者为 null）
另请参见：
setSubjectAlternativeNames(java.util.Collection>)

getNameConstraints

public byte[] getNameConstraints()
返回 NameConstraints 标准。X509Certificate 必须具有满足指定 NameConstraints 要求的 subject 和 subjectAlternativeNames。

以 byte 数组的形式返回该 NameConstraints。此 byte 数组包含 DER 编码形式的 NameConstraints，因为它们将出现在 RFC 2459 和 X.509 内所定义的 NameConstraints 结构中。setNameConstraints(byte [] bytes) 的文档中提供了此结构的 ASN.1 表示。

注意，要复制返回的 byte 数组以防后续修改。

返回：
一个 byte 数组，包含为检查 NameConstraints 所使用的 NameConstraints 扩展的 ASN.1 DER 编码，如果不执行 NameConstraints 检查，则返回 null。
另请参见：
setNameConstraints(byte[])

getBasicConstraints

public int getBasicConstraints()
返回 BasicConstraints 限制。如果该值大于等于零，则 X509Certificates 包括的 basicConstraints 扩展具有的 pathLen 不能小于此值。如果该值为 -2，则只接受终最终实体证书。如果该值为 -1，则不执行 basicConstraints 检查。

返回：
basicConstraints 限制的值
另请参见：
setBasicConstraints(int)

getPolicy

public Set<String> getPolicy()
返回策略标准。X509Certificate 至少必须包括其证书策略扩展中指定的一种策略。如果返回的 Set 为空，则 X509Certificate 至少必须包括其证书策略扩展中指定的某个策略。如果返回的 Set 为 null，则不执行策略检查。

返回：
一个 string 格式的证书策略 OID 的不可变 Set（或者为 null）
另请参见：
setPolicy(java.util.Set)

getPathToNames

public Collection<List<?>> getPathToNames()
返回 pathToNames 标准的一个副本。X509Certificate 不能包括禁止构建指定名称路径的 NameConstraints。如果返回的值为 null，则不执行 pathToNames 检查。

如果返回的值不为 null，则是一个 Collection，pathToNames 标准中所包括的每个名称在该集合中都对应一项。每一项都是一个 List，该 List 的第一项是一个 Integer（0-8，表示名称类型），第二项是一个 String 或 byte 数组（分别为 string 或 ASN.1 DER 编码形式，表示名称）。相同类型可以有多个名称。注意，返回的 Collection 可能包含重复的名称（相同的名称和名称类型）。

Collection 中的每个名称都可以指定为一个 String 或一个 ASN.1 编码的 byte 数组。有关所用格式的更多详细信息，请参阅 addPathToName(int type, String name) 和 addPathToName(int type, byte [] name)。

注意，要对该 Collection 执行深层复制以防后续修改。

返回：
一个名称 Collection（或者为 null）
另请参见：
setPathToNames(java.util.Collection>)

toString

public String toString()
返回该 CertSelector 的可打印表示形式。

覆盖：
类 Object 中的 toString
返回：
描述此 CertSelector 内容的 String

match

public boolean match(Certificate cert)
决定是否应该选择某个 Certificate。

指定者：
接口 CertSelector 中的 match
参数：
cert - 要检查的 Certificate
返回：
如果应该选择该 Certificate，则返回 true；否则返回 false

clone

public Object clone()
返回此对象的副本。

指定者：
接口 CertSelector 中的 clone
覆盖：
类 Object 中的 clone
返回：
副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509CRL (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 X509CRL

java.lang.Object
    继承者  java.security.cert.CRL
        继承者  java.security.cert.X509CRL
所有已实现的接口：
X509Extension
public abstract class X509CRL
extends CRL
implements X509Extension

X.509 证书撤消列表 (CRL) 的抽象类。CRL 是标识已撤消证书的时间戳列表。它由证书颁发机构 (CA) 签署并且可在公共存储库中随意使用。

在 CRL 中，通过每个已撤消证书的证书序列号来标识该证书。当使用证书的系统使用某个证书（例如，用它验证远程用户的数字签名）时，该系统不仅要检查该证书的签名和有效性，而且还要获取一个最近合适的 CRL，并检查该证书序列号在不在该 CRL 中。“最近合适”的含义可能随本地策略的不同而有所不同，但是它通常指的是最近发布的 CRL。CA 定期发布新的 CRL（例如每小时、每日、每周）。当撤消发生时向 CRL 添加一个项，而到达证书的终止日期时，可能会移除一个项。

X.509 v2 CRL 格式的 ASN.1 描述如下：

 CertificateList  ::=  SEQUENCE  {
     tbsCertList          TBSCertList,
     signatureAlgorithm   AlgorithmIdentifier,
     signature            BIT STRING  }

在 RFC 2459，即 "Internet X.509 Public Key Infrastructure Certificate and CRL Profile"（位于 http://www.ietf.org/rfc/rfc2459.txt ）中可找到更多信息。

tbsCertList 的 ASN.1 定义是：

 TBSCertList  ::=  SEQUENCE  {
     version                 Version OPTIONAL,
                             -- if present, must be v2
     signature               AlgorithmIdentifier,
     issuer                  Name,
     thisUpdate              ChoiceOfTime,
     nextUpdate              ChoiceOfTime OPTIONAL,
     revokedCertificates     SEQUENCE OF SEQUENCE  {
         userCertificate         CertificateSerialNumber,
         revocationDate          ChoiceOfTime,
         crlEntryExtensions      Extensions OPTIONAL
                                 -- if present, must be v2
         }  OPTIONAL,
     crlExtensions           [0]  EXPLICIT Extensions OPTIONAL
                                  -- if present, must be v2
     }

CRL 是使用证书工厂进行实例化的。下面的示例演示了如何实例化一个 X.509 CRL：

 InputStream inStream = new FileInputStream("fileName-of-crl");
 CertificateFactory cf = CertificateFactory.getInstance("X.509");
 X509CRL crl = (X509CRL)cf.generateCRL(inStream);
 inStream.close();

另请参见：
CRL, CertificateFactory, X509Extension

构造方法摘要
protected X509CRL()
X.509 CRL 的构造方法。
方法摘要
 boolean equals(Object other)
比较此 CRL 与给定对象的相等性。
abstract  byte[] getEncoded()
返回此 CRL 的 ASN.1 DER 编码形式。
abstract  Principal getIssuerDN()
已过时，由 getIssuerX500Principal() 替代。
 X500Principal getIssuerX500Principal()
以 X500Principal 的形式返回 CRL 的发布方（发布方标识名）值。
abstract  Date getNextUpdate()
获取 CRL 的 nextUpdate 日期。
abstract  X509CRLEntry getRevokedCertificate(BigInteger serialNumber)
获取具有给定证书 serialNumber 的 CRL 项（如果有）。
 X509CRLEntry getRevokedCertificate(X509Certificate certificate)
获取给定证书的 CRL 项（如果有）。
abstract  Set<? extends X509CRLEntry> getRevokedCertificates()
获取此 CRL 中的所有项。
abstract  String getSigAlgName()
获取 CRL 签名算法的签名算法名。
abstract  String getSigAlgOID()
获取 CRL 的签名算法 OID 字符串。
abstract  byte[] getSigAlgParams()
获取此 CRL 的签名算法中 DER 编码形式的签名算法参数。
abstract  byte[] getSignature()
获取 CRL 的 signature 值（原始签名位）。
abstract  byte[] getTBSCertList()
从此 CRL 中获取以 DER 编码的 CRL 信息，即 tbsCertList。
abstract  Date getThisUpdate()
获取 CRL 的 thisUpdate 日期。
abstract  int getVersion()
获取 CRL 的 version（版本号）值。
 int hashCode()
根据此 CRL 的编码形式返回该 CRL 的哈希码值。
abstract  void verify(PublicKey key)
验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract  void verify(PublicKey key, String sigProvider)
验证是否已使用与给定公钥相应的私钥签署了此 CRL。
从类 java.security.cert.CRL 继承的方法
getType, isRevoked, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.security.cert.X509Extension 继承的方法
getCriticalExtensionOIDs, getExtensionValue, getNonCriticalExtensionOIDs, hasUnsupportedCriticalExtension

构造方法详细信息

X509CRL

protected X509CRL()
X.509 CRL 的构造方法。

方法详细信息

equals

public boolean equals(Object other)
比较此 CRL 与给定对象的相等性。如果 other 对象是一个 instanceof X509CRL，则获取其编码形式并且与此 CRL 的编码形式进行比较。

覆盖：
类 Object 中的 equals
参数：
other - 要与此 CRL 进行相等性测试的对象。
返回：
当且仅当两个 CRL 的编码形式匹配时才返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
根据此 CRL 的编码形式返回该 CRL 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getEncoded

public abstract byte[] getEncoded()
                           throws CRLException
返回此 CRL 的 ASN.1 DER 编码形式。

返回：
此证书的编码形式
抛出：
CRLException - 如果发生编码错误。

verify

public abstract void verify(PublicKey key)
                     throws CRLException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
验证是否已使用与给定公钥相应的私钥签署了此 CRL。

参数：
key - 用于进行验证的 PublicKey。
抛出：
NoSuchAlgorithmException - 如果签名算法不受支持。
InvalidKeyException - 如果密钥不正确。
NoSuchProviderException - 如果没有默认的提供者。
SignatureException - 如果发生签名错误。
CRLException - 如果发生编码错误。

verify

public abstract void verify(PublicKey key,
                            String sigProvider)
                     throws CRLException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
验证是否已使用与给定公钥相应的私钥签署了此 CRL。此方法使用给定提供者所提供的签名验证引擎。

参数：
key - 用于进行验证的 PublicKey。
sigProvider - 签名提供者的名称。
抛出：
NoSuchAlgorithmException - 如果签名算法不受支持。
InvalidKeyException - 如果密钥不正确。
NoSuchProviderException - 如果提供者不正确。
SignatureException - 如果发生签名错误。
CRLException - 如果发生编码错误。

getVersion

public abstract int getVersion()
获取 CRL 的 version（版本号）值。此内容的 ASN.1 定义如下：
 version    Version OPTIONAL,
             -- if present, must be v2

 Version  ::=  INTEGER  {  v1(0), v2(1), v3(2)  }
             -- v3 does not apply to CRLs but appears for consistency
             -- with definition of Version for certs

返回：
版本号，比如 1 或 2。

getIssuerDN

public abstract Principal getIssuerDN()
已过时，由 getIssuerX500Principal() 替代。此方法返回作为特定 Principal 对象实现的 issuer，可移植的代码不应依靠该对象。

获取 CRL 的 issuer（发布方的标识名）。发布方名称标识了签署（并发布）该 CRL 的实体。

发布方名称字段包含一个 X.500 标识名 (DN)。此内容的 ASN.1 定义如下：

 issuer    Name

 Name ::= CHOICE { RDNSequence }
 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName
 RelativeDistinguishedName ::=
     SET OF AttributeValueAssertion

 AttributeValueAssertion ::= SEQUENCE {
                               AttributeType,
                               AttributeValue }
 AttributeType ::= OBJECT IDENTIFIER
 AttributeValue ::= ANY
Name 描述了一个层次结构名，由属性（如国家/地区名）和相应值（如 US）组成。AttributeValue 组件的类型由 AttributeType 来确定；一般是 directoryString。directoryString 通常是 PrintableString、TeletexString 或 UniversalString 之一。

返回：
一个 Principal，其名称是发布方的标识名。

getIssuerX500Principal

public X500Principal getIssuerX500Principal()
以 X500Principal 的形式返回 CRL 的发布方（发布方标识名）值。

建议子类重写此方法。

返回：
一个表示发布方标识名的 X500Principal
从以下版本开始：
1.4

getThisUpdate

public abstract Date getThisUpdate()
获取 CRL 的 thisUpdate 日期。此内容的 ASN.1 定义如下：
 thisUpdate   ChoiceOfTime
 ChoiceOfTime ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }

返回：
获取 CRL 的 thisUpdate 日期。

getNextUpdate

public abstract Date getNextUpdate()
获取 CRL 的 nextUpdate 日期。

返回：
获取 CRL 的 nextUpdate 日期，如果不存在，则返回 null。

getRevokedCertificate

public abstract X509CRLEntry getRevokedCertificate(BigInteger serialNumber)
获取具有给定证书 serialNumber 的 CRL 项（如果有）。

参数：
serialNumber - 要查找其 CRL 项的证书的序列号
返回：
具有给定序列号的项，如果此 CRL 中没有该项，则返回 null。
另请参见：
X509CRLEntry

getRevokedCertificate

public X509CRLEntry getRevokedCertificate(X509Certificate certificate)
获取给定证书的 CRL 项（如果有）。

此方法可用于在间接 CRL 中查找 CRL 项，间接 CRL 意味着其中包含来自不同于 CRL 发布方的发布方的项。默认的实现只返回由 CRL 发布方所发布的证书项。希望支持间接 CRL 的子类应该重写此方法。

参数：
certificate - 证书，在 CRL 中查找此证书的 CRL 项
返回：
给定证书的项，如果此 CRL 中没有该项，则返回 null。
抛出：
NullPointerException - 如果 certificate 为 null
从以下版本开始：
1.5

getRevokedCertificates

public abstract Set<? extends X509CRLEntry> getRevokedCertificates()
获取此 CRL 中的所有项。这会返回一个 X509CRLEntry 对象 Set。

返回：
所有项，如果没有项，则返回 null。
另请参见：
X509CRLEntry

getTBSCertList

public abstract byte[] getTBSCertList()
                               throws CRLException
从此 CRL 中获取以 DER 编码的 CRL 信息，即 tbsCertList。这可用于独立验证签名。

返回：
以 DER 编码的 CRL 信息。
抛出：
CRLException - 如果发生编码错误。

getSignature

public abstract byte[] getSignature()
获取 CRL 的 signature 值（原始签名位）。此内容的 ASN.1 定义如下：
 signature     BIT STRING

返回：
签名。

getSigAlgName

public abstract String getSigAlgName()
获取 CRL 签名算法的签名算法名。例如字符串 "SHA-1/DSA"。此内容的 ASN.1 定义如下：
 signatureAlgorithm   AlgorithmIdentifier

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm               OBJECT IDENTIFIER,
     parameters              ANY DEFINED BY algorithm OPTIONAL  }
                             -- contains a value of the type
                             -- registered for use with the
                             -- algorithm object identifier value

根据 algorithm OID 字符串确定该算法名。

返回：
签名算法名。

getSigAlgOID

public abstract String getSigAlgOID()
获取 CRL 的签名算法 OID 字符串。OID 由一组句点分隔的非负整数集来表示。例如，按照 RFC 2459 中的规定，字符串 "1.2.840.10040.4.3" 标识使用 DSA 签名算法的 SHA-1。

有关相关的 ASN.1 定义，请参见 getSigAlgName。

返回：
签名算法 OID 字符串。

getSigAlgParams

public abstract byte[] getSigAlgParams()
获取此 CRL 的签名算法中 DER 编码形式的签名算法参数。在大多数情况下，该签名算法参数为 null；该参数通常提供公钥。如果需要访问个别参数值，则使用 AlgorithmParameters 并使用 getSigAlgName 所返回的名称进行实例化。

有关相关的 ASN.1 定义，请参见 getSigAlgName。

返回：
DER 编码形式的签名算法参数，如果没有该参数，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509CRLEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 X509CRLEntry

java.lang.Object
    继承者  java.security.cert.X509CRLEntry
所有已实现的接口：
X509Extension
public abstract class X509CRLEntry
extends Object
implements X509Extension

用于 CRL（证书撤消列表）中已撤消证书的抽象类。 revokedCertificates 的 ASN.1 定义如下：

 revokedCertificates    SEQUENCE OF SEQUENCE  {
     userCertificate    CertificateSerialNumber,
     revocationDate     ChoiceOfTime,
     crlEntryExtensions Extensions OPTIONAL
                        -- if present, must be v2
 }  OPTIONAL

 CertificateSerialNumber  ::=  INTEGER

 Extensions  ::=  SEQUENCE SIZE (1..MAX) OF Extension

 Extension  ::=  SEQUENCE  {
     extnId        OBJECT IDENTIFIER,
     critical      BOOLEAN DEFAULT FALSE,
     extnValue     OCTET STRING
                   -- contains a DER encoding of a value
                   -- of the type registered for use with
                   -- the extnId object identifier value
 }

另请参见：
X509CRL, X509Extension

构造方法摘要
X509CRLEntry()
方法摘要
boolean | equals(Object other) 比较此 CRL 项与给定对象的相等性。
X500Principal | getCertificateIssuer() 获取此项所描述的 X509Certificate 的发布方。
abstract byte[] | getEncoded() 返回此 CRL Entry 的 ASN.1 DER 编码形式，即内部 SEQUENCE。
abstract Date | getRevocationDate() 获取此 X509CRLEntry 的撤消日期 revocationDate。
abstract BigInteger | getSerialNumber() 获取此 X509CRLEntry 的序列号 userCertificate。
abstract boolean | hasExtensions() 如果此 CRL 项有扩展，则返回 true。
int | hashCode() 根据此 CRL 项的编码形式返回该 CRL 项的哈希码值。
abstract String | toString() 返回此 CRL 项的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.security.cert.X509Extension 继承的方法
getCriticalExtensionOIDs, getExtensionValue, getNonCriticalExtensionOIDs, hasUnsupportedCriticalExtension

构造方法详细信息

X509CRLEntry

public X509CRLEntry()
方法详细信息

equals

public boolean equals(Object other)
比较此 CRL 项与给定对象的相等性。如果 other 对象是一个 instanceof X509CRLEntry，则获取其编码形式（内部 SEQUENCE）并且与此 CRL 项的编码形式进行比较。

覆盖：
类 Object 中的 equals
参数：
other - 要与此 CRL 项进行相等性测试的对象。
返回：
当且仅当两个 CRL 项的编码形式匹配时才返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
根据此 CRL 项的编码形式返回该 CRL 项的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getEncoded

public abstract byte[] getEncoded()
                           throws CRLException
返回此 CRL Entry 的 ASN.1 DER 编码形式，即内部 SEQUENCE。

返回：
此证书的编码形式
抛出：
CRLException - 如果出现编码错误。

getSerialNumber

public abstract BigInteger getSerialNumber()
获取此 X509CRLEntry 的序列号 userCertificate。

返回：
序列号。

getCertificateIssuer

public X500Principal getCertificateIssuer()
获取此项所描述的 X509Certificate 的发布方。如果该证书发布方也是 CRL 的发布方，则此方法返回 null。

此方法用于间接 CRL。默认实现始终返回 null。希望支持间接 CRL 的子类应该重写此方法。

返回：
此项所描述的 X509Certificate 的发布方，如果此证书由该 CRL 的发布方所发布，则返回 null。
从以下版本开始：
1.5

getRevocationDate

public abstract Date getRevocationDate()
获取此 X509CRLEntry 的撤消日期 revocationDate。

返回：
撤消日期。

hasExtensions

public abstract boolean hasExtensions()
如果此 CRL 项有扩展，则返回 true。

返回：
如果此 CRL 项有扩展，则返回 true；否则返回 false。

toString

public abstract String toString()
返回此 CRL 项的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 CRL 项的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509CRLSelector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.cert
类 X509CRLSelector

java.lang.Object
    继承者  java.security.cert.X509CRLSelector
所有已实现的接口：
Cloneable, CRLSelector
public class X509CRLSelector
extends Object
implements CRLSelector

选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。从 CertStore 中选择 CRL 以检查特定证书的撤消状态时，此类特别有用。

最初构造 X509CRLSelector 时，它没有启用任何标准，并且每个 get 方法都返回一个默认值 (null)。因此，对于任意 X509CRL 而言，match 方法将返回 true。通常，启用多种标准（例如通过调用 setIssuers 或 setDateAndTime），然后将 X509CRLSelector 传递到 CertStore.getCRLs 或某个类似方法。

有关 X.509 CRL 各字段和下面所述各扩展的定义，请参阅 RFC 2459。

并发访问

除非另行指定，否则此类中所定义的方法不是线程安全的。需要并发访问单个对象的多个线程应该在它们之间实现同步并提供所需的锁定。对于每个线程都操作一个不同对象的多个线程而言，无需实现同步。

从以下版本开始：
1.4
另请参见：
CRLSelector, X509CRL

构造方法摘要
X509CRLSelector()
创建一个 X509CRLSelector。
方法摘要
void | addIssuer(X500Principal issuer) 向 issuerNames 标准中添加名称。
void | addIssuerName(byte[] name) 向 issuerNames 标准中添加名称。
void | addIssuerName(String name) 已过时，使用 addIssuer(X500Principal) 或 addIssuerName(byte[]) 替代。
Object | clone() 返回此对象的副本。
X509Certificate | getCertificateChecking() 返回要检查的证书。
Date | getDateAndTime() 返回 dateAndTime 标准。
Collection<Object> | getIssuerNames() 返回该 issuerNames 标准的一个副本。
Collection<X500Principal> | getIssuers() 返回 issuerNames 标准。
BigInteger | getMaxCRL() 返回 maxCRLNumber 标准。
BigInteger | getMinCRL() 返回 minCRLNumber 标准。
boolean | match(CRL crl) 决定是否应该选择某个 CRL。
void | setCertificateChecking(X509Certificate cert) 设置要检查的证书。
void | setDateAndTime(Date dateAndTime) 设置 dateAndTime 标准。
void | setIssuerNames(Collection<?> names) 注意：请使用 setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。
void | setIssuers(Collection<X500Principal> issuers) 设置 issuerNames 标准。
void | setMaxCRLNumber(BigInteger maxCRL) 设置 maxCRLNumber 标准。
void | setMinCRLNumber(BigInteger minCRL) 设置 minCRLNumber 标准。
String | toString() 返回该 X509CRLSelector 的可打印表示形式。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

X509CRLSelector

public X509CRLSelector()
创建一个 X509CRLSelector。最初未设置任何标准，所以任何 X509CRL 都匹配。

方法详细信息

setIssuers

public void setIssuers(Collection<X500Principal> issuers)
设置 issuerNames 标准。X509CRL 中的发布方标识名必须至少与某个指定的标识名相匹配。如果指定的标识名为 null，则将匹配任意发布方标识名。

此方法允许调用方（使用单个方法调用）指定 X509CRL 可能包含的全部发布方名称集。指定的值会替换 issuerNames 标准以前的值。

names 参数（如果不为 null）是一个 X500Principal 的 Collection。

注意，names 参数可以包含重复的标识名，但是可能从 getIssuers 方法返回的名称 Collection 中将其移除。

注意，要对该 Collection 执行复制以防后续修改。

参数：
issuers - X500Principals 的 Collection（或者为 null）
从以下版本开始：
1.5
另请参见：
getIssuers()

setIssuerNames

public void setIssuerNames(Collection<?> names)
                    throws IOException
注意：请使用 setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。有关更多信息，请参阅 addIssuerName(String)。

设置 issuerNames 标准。X509CRL 中的发布方标识名必须至少与某个指定的标识名相匹配。如果指定的标识名为 null，则将匹配任意发布方标识名。

此方法允许调用方（使用单个方法调用）指定 X509CRL 可能包含的全部发布方名称集。指定的值会替换 issuerNames 标准以前的值。

names 参数（如果不为 null）是一个名称的 Collection。每个名称都是一个 String 或 byte 数组（分别为 RFC 2253 或 ASN.1 DER 编码形式），表示一个标识名。如果为此参数提供 null 值，则不执行 issuerNames 检查。

注意，names 参数可以包含重复的标识名，但是可能从 getIssuerNames 方法返回的名称 Collection 中将其移除。

如果以 byte 数组的形式指定名称，那么它应该包含单个 DER 编码形式的标识名，正如 X.501 中定义的一样。此结构的 ASN.1 表示如下：

 Name ::= CHOICE {
   RDNSequence }

 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName

 RelativeDistinguishedName ::=
   SET SIZE (1 .. MAX) OF AttributeTypeAndValue

 AttributeTypeAndValue ::= SEQUENCE {
   type     AttributeType,
   value    AttributeValue }

 AttributeType ::= OBJECT IDENTIFIER

 AttributeValue ::= ANY DEFINED BY AttributeType
 ....
 DirectoryString ::= CHOICE {
       teletexString           TeletexString (SIZE (1..MAX)),
       printableString         PrintableString (SIZE (1..MAX)),
       universalString         UniversalString (SIZE (1..MAX)),
       utf8String              UTF8String (SIZE (1.. MAX)),
       bmpString               BMPString (SIZE (1..MAX)) }

注意，要对该 Collection 执行深层复制以防后续修改。

参数：
names - 一个名称 Collection（或者为 null）
抛出：
IOException - 如果发生解析错误
另请参见：
getIssuerNames()

addIssuer

public void addIssuer(X500Principal issuer)
向 issuerNames 标准中添加名称。X509CRL 中的发布方标识名必须至少与某个指定的标识名相匹配。

此方法允许调用方向 X509CRL 可能包含的发布方名称集中添加一个名称。将指定的名称添加到 issuerNames 标准的以前值中。如果指定的名称是重复的，则忽略它。

参数：
issuer - X500Principal 形式的发布方
从以下版本开始：
1.5

addIssuerName

public void addIssuerName(String name)
                   throws IOException
已过时，使用 addIssuer(X500Principal) 或 addIssuerName(byte[]) 替代。由于某些 RFC 2253 String 形式的标识名中会丢失编码信息，所以当此方法与某些 CRL 不匹配时不应该依赖它。

向 issuerNames 标准中添加名称。X509CRL 中的发布方标识名必须至少与某个指定的标识名相匹配。

此方法允许调用方向 X509CRL 可能包含的发布方名称集中添加一个名称。将指定的名称添加到 issuerNames 标准的以前值中。如果指定的名称是重复的，则忽略它。

参数：
name - RFC 2253 形式的名称
抛出：
IOException - 如果发生解析错误

addIssuerName

public void addIssuerName(byte[] name)
                   throws IOException
向 issuerNames 标准中添加名称。X509CRL 中的发布方标识名必须至少与某个指定的标识名相匹配。

此方法允许调用方向 X509CRL 可能包含的发布方名称集中添加一个名称。将指定的名称添加到 issuerNames 标准的以前值中。如果指定的名称是重复的，则忽略它。如果以 byte 数组的形式指定名称，那么它应该包含单个 DER 编码形式的标识名，正如 X.501 中定义的一样。此结构的 ASN.1 表示如下：

以 byte 数组的形式提供该名称。此 byte 数组应该包含单个 DER 编码形式的标识名，正如 X.501 中定义的一样。setIssuerNames(Collection names) 的文档中提供了此结构的 ASN.1 表示。

注意，要复制此处提供的 byte 数组以防后续修改。

参数：
name - 包含 ASN.1 DER 编码形式名称的 byte 数组
抛出：
IOException - 如果发生解析错误

setMinCRLNumber

public void setMinCRLNumber(BigInteger minCRL)
设置 minCRLNumber 标准。X509CRL 具有的 CRL 数字扩展的值必须大于或等于指定值。如果其值为 null，则不执行 minCRLNumber 检查。

参数：
minCRL - 接受的最小 CRL 数字（或者为 null）

setMaxCRLNumber

public void setMaxCRLNumber(BigInteger maxCRL)
设置 maxCRLNumber 标准。X509CRL 具有的 CRL 数字扩展的值必须小于等于指定值。如果其值为 null，则不执行 maxCRLNumber 检查。

参数：
maxCRL - 接受的最大 CRL 数字（或者为 null）

setDateAndTime

public void setDateAndTime(Date dateAndTime)
设置 dateAndTime 标准。指定的日期必须等于或迟于 X509CRL 的 thisUpdate 组件的日期，且早于 nextUpdate 组件的值日期。如果 X509CRL 不包含 nextUpdate 组件，则没有匹配。如果其值为 null，则不执行 dateAndTime 检查。

注意，要复制此处提供的 Date 以防后续修改。

参数：
dateAndTime - 要进行匹配的 Date（或者为 null）
另请参见：
getDateAndTime()

setCertificateChecking

public void setCertificateChecking(X509Certificate cert)
设置要检查的证书。这不是一个标准。相反，这是一个可选的信息，在检查指定证书的撤消状态时，它可帮助 CertStore 找到相关的 CRL。如果指定为 null，则不提供此种可选的信息。

参数：
cert - 要检查的 X509Certificate（或者为 null）
另请参见：
getCertificateChecking()

getIssuers

public Collection<X500Principal> getIssuers()
返回 issuerNames 标准。X509CRL 中的发布方标识名必须至少与某个指定的标识名相匹配。如果返回值为 null，则任意发布方标识名都匹配。

如果返回值不为 null，则是一个 X500Principal 的不可修改的 Collection。

返回：
一个不可修改的名称 Collection（或者为 null）
从以下版本开始：
1.5
另请参见：
setIssuers(java.util.Collection)

getIssuerNames

public Collection<Object> getIssuerNames()
返回该 issuerNames 标准的一个副本。X509CRL 中的发布方标识名必须至少与某个指定的标识名相匹配。如果返回值为 null，则任意发布方标识名都匹配。

如果返回值不为 null，则是一个名称 Collection。每个名称都是一个 String 或 byte 数组（分别为 RFC 2253 或 ASN.1 DER 编码形式），表示一个标识名。注意，返回的 Collection 可能包含重复的名称。

如果以 byte 数组的形式指定名称，那么它应该包含单个 DER 编码形式的标识名，正如 X.501 中定义的一样。setIssuerNames(Collection names) 的文档中给出了此结构的 ASN.1 表示。

注意，要对该 Collection 执行深层复制以防后续修改。

返回：
一个名称 Collection（或者为 null）
另请参见：
setIssuerNames(java.util.Collection)

getMinCRL

public BigInteger getMinCRL()
返回 minCRLNumber 标准。X509CRL 具有的 CRL 数字扩展的值必须大于或等于指定值。如果其值为 null，则不执行 minCRLNumber 检查。

返回：
接受的最小 CRL 数字（或者为 null）

getMaxCRL

public BigInteger getMaxCRL()
返回 maxCRLNumber 标准。X509CRL 具有的 CRL 数字扩展的值必须小于等于指定值。如果其值为 null，则不执行 maxCRLNumber 检查。

返回：
接受的最大 CRL 数字（或者为 null）

getDateAndTime

public Date getDateAndTime()
返回 dateAndTime 标准。指定的日期必须等于或迟于 X509CRL 的 thisUpdate 组件的日期，且早于 nextUpdate 组件的日期。如果 X509CRL 不包含 nextUpdate 组件，则没有匹配。如果其值为 null，则不执行 dateAndTime 检查。

注意，要复制返回的 Date 以防后续修改。

返回：
要进行匹配的 Date（或者为 null）
另请参见：
setDateAndTime(java.util.Date)

getCertificateChecking

public X509Certificate getCertificateChecking()
返回要检查的证书。这不是一个标准。相反，这是一个可选的信息，在检查指定证书的撤消状态时，它可帮助 CertStore 找到相关的 CRL。如果返回值为 null，则不提供此种可选的信息。

返回：
要检查的证书（或者为 null）
另请参见：
setCertificateChecking(java.security.cert.X509Certificate)

toString

public String toString()
返回该 X509CRLSelector 的可打印表示形式。

覆盖：
类 Object 中的 toString
返回：
描述该 X509CRLSelector 内容的 String。

match

public boolean match(CRL crl)
决定是否应该选择某个 CRL。

指定者：
接口 CRLSelector 中的 match
参数：
crl - 要检查的 CRL
返回：
如果应该选择该 CRL，则返回 true；否则返回 false

clone

public Object clone()
返回此对象的副本。

指定者：
接口 CRLSelector 中的 clone
覆盖：
类 Object 中的 clone
返回：
副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509Extension (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.cert
接口 X509Extension

所有已知实现类：
X509Certificate, X509CRL, X509CRLEntry
public interface X509Extension

X.509 扩展的接口。

为 X.509 v3 Certificates 和 v2 CRLs（证书撤消列表）所定义的扩展提供了各种方法，用于将其他属性与用户或公钥相关联、管理证书层次结构和管理 CRL 的分发。X.509 扩展格式还允许各种团体定义私有扩展，以承载这些团体的惟一信息。

证书/CRL 中的每种扩展都可以指定为关键的或非关键的。如果使用证书/CRL 的系统（验证证书/CRL 的应用程序）遇到了它无法识别的关键扩展，则它必须拒绝该证书/CRL。如果该系统无法识别非关键扩展，则可将其忽略。

此内容的 ASN.1 定义如下：

 Extensions  ::=  SEQUENCE SIZE (1..MAX) OF Extension

 Extension  ::=  SEQUENCE  {
     extnId        OBJECT IDENTIFIER,
     critical      BOOLEAN DEFAULT FALSE,
     extnValue     OCTET STRING
                   -- contains a DER encoding of a value
                   -- of the type registered for use with
                   -- the extnId object identifier value
 }
由于并非所有的扩展都是已知的，所以 getExtensionValue 方法返回扩展值（也就是 extnValue）的 DER 编码形式的 OCTET STRING。然后可由识别该扩展的类 来处理该返回值。

方法摘要
Set<String> | getCriticalExtensionOIDs() 获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。
byte[] | getExtensionValue(String oid) 获取扩展值 (extnValue) 的 DER 编码 OCTET 字符串，该扩展值由传入的 oid String 标识。
Set<String> | getNonCriticalExtensionOIDs() 获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。
boolean | hasUnsupportedCriticalExtension() 检查是否存在不支持的关键扩展。

方法详细信息

hasUnsupportedCriticalExtension

boolean hasUnsupportedCriticalExtension()
检查是否存在不支持的关键扩展。

返回：
如果找到了不支持的关键扩展，则返回 true；否则返回 false。

getCriticalExtensionOIDs

Set<String> getCriticalExtensionOIDs()
获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。 下面的示例代码从 X509Certificate 中获取一个关键扩展的 Set 并打印 OID：

 InputStream inStrm = new FileInputStream("DER-encoded-Cert");
 CertificateFactory cf = CertificateFactory.getInstance("X.509");
 X509Certificate cert = (X509Certificate)cf.generateCertificate(inStrm);
 inStrm.close();

 Set critSet = cert.getCriticalExtensionOIDs();
 if (critSet != null && !critSet.isEmpty()) {
     System.out.println("Set of critical extensions:");
     for (Iterator i = critSet.iterator(); i.hasNext();) {
         String oid = (String)i.next();
         System.out.println(oid);
     }
 }

返回：
标记为关键扩展的扩展 OID 字符串 Set（如果没有标记为关键的扩展，则返回一个空 Set）。如果根本没有扩展，则此方法返回 null。

getNonCriticalExtensionOIDs

Set<String> getNonCriticalExtensionOIDs()
获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。 下面的示例代码从 X509CRL 已撤消证书项中获取一个非关键扩展的 Set 并打印 OID：

 InputStream inStrm = new FileInputStream("DER-encoded-CRL");
 CertificateFactory cf = CertificateFactory.getInstance("X.509");
 X509CRL crl = (X509CRL)cf.generateCRL(inStrm);
 inStrm.close();

 byte[] certData = <DER-encoded certificate data>
 ByteArrayInputStream bais = new ByteArrayInputStream(certData);
 X509Certificate cert = (X509Certificate)cf.generateCertificate(bais);
 bais.close();
 X509CRLEntry badCert =
              crl.getRevokedCertificate(cert.getSerialNumber());

 if (badCert != null) {
     Set nonCritSet = badCert.getNonCriticalExtensionOIDs();

     if (nonCritSet != null)
         for (Iterator i = nonCritSet.iterator(); i.hasNext();) {
             String oid = (String)i.next();
             System.out.println(oid);
         }
 }

返回：
标记为非关键扩展的扩展 OID 字符串 Set（如果没有标记为非关键的扩展，则返回一个空 Set）。如果根本没有扩展，则此方法返回 null。

getExtensionValue

byte[] getExtensionValue(String oid)
获取扩展值 (extnValue) 的 DER 编码 OCTET 字符串，该扩展值由传入的 oid String 标识。该 oid 字符串由一组句点分隔的非负整数集来表示。

例如：

OID（对象标识符） | 扩展名
2.5.29.14 | SubjectKeyIdentifier
2.5.29.15 | KeyUsage
2.5.29.16 | PrivateKeyUsage
2.5.29.17 | SubjectAlternativeName
2.5.29.18 | IssuerAlternativeName
2.5.29.19 | BasicConstraints
2.5.29.30 | NameConstraints
2.5.29.33 | PolicyMappings
2.5.29.35 | AuthorityKeyIdentifier
2.5.29.36 | PolicyConstraints

参数：
oid - 该扩展的对象标识符值。
返回：
扩展值的 DER 编码的八位字节字符串，如果不存在，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.security.cert (Java 2 Platform SE 6)

 java.security.cert
接口
CertPathBuilderResult
CertPathParameters
CertPathValidatorResult
CertSelector
CertStoreParameters
CRLSelector
PolicyNode
X509Extension
类
Certificate
Certificate.CertificateRep
CertificateFactory
CertificateFactorySpi
CertPath
CertPath.CertPathRep
CertPathBuilder
CertPathBuilderSpi
CertPathValidator
CertPathValidatorSpi
CertStore
CertStoreSpi
CollectionCertStoreParameters
CRL
LDAPCertStoreParameters
PKIXBuilderParameters
PKIXCertPathBuilderResult
PKIXCertPathChecker
PKIXCertPathValidatorResult
PKIXParameters
PolicyQualifierInfo
TrustAnchor
X509Certificate
X509CertSelector
X509CRL
X509CRLEntry
X509CRLSelector
异常
CertificateEncodingException
CertificateException
CertificateExpiredException
CertificateNotYetValidException
CertificateParsingException
CertPathBuilderException
CertPathValidatorException
CertStoreException
CRLException


java.security.cert (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.security.cert

提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

请参见：
描述

接口摘要
CertPathBuilderResult | 证书路径生成器算法的结果的规范。
CertPathParameters | 证书路径算法参数的规范。
CertPathValidatorResult | 证书路径验证器算法的结果的规范。
CertSelector | 一个定义了一套选择 Certificate 的标准的选择器。
CertStoreParameters | CertStore 参数的规范。
CRLSelector | 一个定义了一套选择 CRL 的标准的选择器。
PolicyNode | PKIX 证书路径验证算法所定义的、不可变的有效策略树节点。
X509Extension | X.509 扩展的接口。

类摘要
Certificate | 管理各种身份证书的抽象类。
Certificate.CertificateRep | 用于序列化的替换 Certificate 类。
CertificateFactory | 此类定义了用于从相关的编码中生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象的 CertificateFactory 功能。
CertificateFactorySpi | 此类定义了 CertificateFactory 类的服务提供者接口 (SPI)。
CertPath | 不可变的证书序列（证书路径）。
CertPath.CertPathRep | 用于序列化的替换 CertPath 类。
CertPathBuilder | 构建证书路径（也称为证书链）的类。
CertPathBuilderSpi | CertPathBuilder 类的服务提供者接口 (SPI)。
CertPathValidator | 验证证书路径（也称为证书链）的类。
CertPathValidatorSpi | CertPathValidator 类的服务提供者接口 (SPI)。
CertStore | 用于从存储库中获取 Certificate 和 CRL 的类。
CertStoreSpi | CertStore 类的服务提供者接口 (SPI)。
CollectionCertStoreParameters | 用作 Collection CertStore 算法输入的参数。
CRL | 此类是具有不同格式但很常用的证书撤消列表 (CRL) 的抽象。
LDAPCertStoreParameters | 用作 LDAP CertStore 算法的输入的参数。
PKIXBuilderParameters | 用作 PKIX CertPathBuilder 算法的输入的参数。
PKIXCertPathBuilderResult | 此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。
PKIXCertPathChecker | 对 X509Certificate 执行一种或多种检查的抽象类。
PKIXCertPathValidatorResult | 此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。
PKIXParameters | 用作 PKIX CertPathValidator 算法的输入的参数。
PolicyQualifierInfo | 由 ASN.1 PolicyQualifierInfo 结构所表示的、不可变的策略限定符。
TrustAnchor | 一个信任定位点或最受信任的证书颁发机构 (CA)。
X509Certificate | X.509 证书的抽象类。
X509CertSelector | 选择与所有指定标准匹配的 X509Certificates 的 CertSelector。
X509CRL | X.509 证书撤消列表 (CRL) 的抽象类。
X509CRLEntry | 用于 CRL（证书撤消列表）中已撤消证书的抽象类。
X509CRLSelector | 选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。

异常摘要
CertificateEncodingException | 证书编码异常。
CertificateException | 此异常指示各种证书问题中的一种。
CertificateExpiredException | 证书过期异常。
CertificateNotYetValidException | 证书尚无效异常。
CertificateParsingException | 证书解析异常。
CertPathBuilderException | 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
CertPathValidatorException | 指示在验证一个证书路径时遇到了某种问题的异常。
CertStoreException | 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
CRLException | CRL（证书撤消列表）异常。

软件包 java.security.cert 的描述

提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。它包含对 X.509 v3 证书和 X.509 v2 CRL 的支持。

包规范

  • 加密体系结构
  • RFC 2459:X.509 证书和 CRL 配置文件

相关文档

有关 X.509 证书和 CRL 的信息，请参阅：
  • http://www.ietf.org/rfc/rfc2459.txt
  • X.509 Certificates and CRLs

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.security.cert 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.cert 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.security.cert.Certificate (implements java.io.Serializable)
      • java.security.cert.X509Certificate (implements java.security.cert.X509Extension)
    • java.security.cert.Certificate.CertificateRep (implements java.io.Serializable)
    • java.security.cert.CertificateFactory
    • java.security.cert.CertificateFactorySpi
    • java.security.cert.CertPath (implements java.io.Serializable)
    • java.security.cert.CertPath.CertPathRep (implements java.io.Serializable)
    • java.security.cert.CertPathBuilder
    • java.security.cert.CertPathBuilderSpi
    • java.security.cert.CertPathValidator
    • java.security.cert.CertPathValidatorSpi
    • java.security.cert.CertStore
    • java.security.cert.CertStoreSpi
    • java.security.cert.CollectionCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.security.cert.CRL
      • java.security.cert.X509CRL (implements java.security.cert.X509Extension)
    • java.security.cert.LDAPCertStoreParameters (implements java.security.cert.CertStoreParameters)
    • java.security.cert.PKIXCertPathChecker (implements java.lang.Cloneable)
    • java.security.cert.PKIXCertPathValidatorResult (implements java.security.cert.CertPathValidatorResult)
      • java.security.cert.PKIXCertPathBuilderResult (implements java.security.cert.CertPathBuilderResult)
    • java.security.cert.PKIXParameters (implements java.security.cert.CertPathParameters)
      • java.security.cert.PKIXBuilderParameters
    • java.security.cert.PolicyQualifierInfo
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.cert.CertificateException
            • java.security.cert.CertificateEncodingException
            • java.security.cert.CertificateExpiredException
            • java.security.cert.CertificateNotYetValidException
            • java.security.cert.CertificateParsingException
          • java.security.cert.CertPathBuilderException
          • java.security.cert.CertPathValidatorException
          • java.security.cert.CertStoreException
          • java.security.cert.CRLException
    • java.security.cert.TrustAnchor
    • java.security.cert.X509CertSelector (implements java.security.cert.CertSelector)
    • java.security.cert.X509CRLEntry (implements java.security.cert.X509Extension)
    • java.security.cert.X509CRLSelector (implements java.security.cert.CRLSelector)

接口分层结构

  • java.lang.Cloneable
    • java.security.cert.CertPathBuilderResult
    • java.security.cert.CertPathParameters
    • java.security.cert.CertPathValidatorResult
    • java.security.cert.CertSelector
    • java.security.cert.CertStoreParameters
    • java.security.cert.CRLSelector
  • java.security.cert.PolicyNode
  • java.security.cert.X509Extension
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.security.cert 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.cert
的使用

使用 java.security.cert 的软件包
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.net 使用的 java.security.cert 中的类
Certificate
管理各种身份证书的抽象类。

java.security 使用的 java.security.cert 中的类
Certificate
管理各种身份证书的抽象类。
CertificateException
此异常指示各种证书问题中的一种。
CertPath
不可变的证书序列（证书路径）。

java.security.cert 使用的 java.security.cert 中的类
Certificate
管理各种身份证书的抽象类。
CertificateEncodingException
证书编码异常。
CertificateException
此异常指示各种证书问题中的一种。
CertificateExpiredException
证书过期异常。
CertificateFactory
此类定义了用于从相关的编码中生成证书、证书路径 (CertPath) 和证书撤消列表 (CRL) 对象的 CertificateFactory 功能。
CertificateFactorySpi
此类定义了 CertificateFactory 类的服务提供者接口 (SPI)。
CertificateNotYetValidException
证书尚无效异常。
CertificateParsingException
证书解析异常。
CertPath
不可变的证书序列（证书路径）。
CertPathBuilder
构建证书路径（也称为证书链）的类。
CertPathBuilderException
指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
CertPathBuilderResult
证书路径生成器算法的结果的规范。
CertPathBuilderSpi
CertPathBuilder 类的服务提供者接口 (SPI)。
CertPathParameters
证书路径算法参数的规范。
CertPathValidator
验证证书路径（也称为证书链）的类。
CertPathValidatorException
指示在验证一个证书路径时遇到了某种问题的异常。
CertPathValidatorResult
证书路径验证器算法的结果的规范。
CertPathValidatorSpi
CertPathValidator 类的服务提供者接口 (SPI)。
CertSelector
一个定义了一套选择 Certificate 的标准的选择器。
CertStore
用于从存储库中获取 Certificate 和 CRL 的类。
CertStoreException
指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
CertStoreParameters
CertStore 参数的规范。
CertStoreSpi
CertStore 类的服务提供者接口 (SPI)。
CRL
此类是具有不同格式但很常用的证书撤消列表 (CRL) 的抽象。
CRLException
CRL（证书撤消列表）异常。
CRLSelector
一个定义了一套选择 CRL 的标准的选择器。
PKIXCertPathChecker
对 X509Certificate 执行一种或多种检查的抽象类。
PKIXCertPathValidatorResult
此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。
PKIXParameters
用作 PKIX CertPathValidator 算法的输入的参数。
PolicyNode
PKIX 证书路径验证算法所定义的、不可变的有效策略树节点。
PolicyQualifierInfo
由 ASN.1 PolicyQualifierInfo 结构所表示的、不可变的策略限定符。
TrustAnchor
一个信任定位点或最受信任的证书颁发机构 (CA)。
X509Certificate
X.509 证书的抽象类。
X509CRLEntry
用于 CRL（证书撤消列表）中已撤消证书的抽象类。
X509Extension
X.509 扩展的接口。

java.util.jar 使用的 java.security.cert 中的类
Certificate
管理各种身份证书的抽象类。

javax.crypto 使用的 java.security.cert 中的类
Certificate
管理各种身份证书的抽象类。

javax.net.ssl 使用的 java.security.cert 中的类
Certificate
管理各种身份证书的抽象类。
CertificateException
此异常指示各种证书问题中的一种。
CertPathParameters
证书路径算法参数的规范。
X509Certificate
X.509 证书的抽象类。

javax.security.auth.x500 使用的 java.security.cert 中的类
X509Certificate
X.509 证书的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CRL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CRL
的使用

使用 CRL 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CRL 的使用

java.security.cert 中 CRL 的子类
 class X509CRL
X.509 证书撤消列表 (CRL) 的抽象类。

返回 CRL 的 java.security.cert 中的方法
abstract CRL | CertificateFactorySpi.engineGenerateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
CRL | CertificateFactory.generateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。

返回变量类型为 CRL 的类型的 java.security.cert 中的方法
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。

参数类型为 CRL 的 java.security.cert 中的方法
boolean | CRLSelector.match(CRL crl) 决定是否应该选择某个 CRL。
boolean | X509CRLSelector.match(CRL crl) 决定是否应该选择某个 CRL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CRLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CRLException
的使用

使用 CRLException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CRLException 的使用

抛出 CRLException 的 java.security.cert 中的方法
abstract CRL | CertificateFactorySpi.engineGenerateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
CRL | CertificateFactory.generateCRL(InputStream inStream) 生成一个证书撤消列表 (CRL) 对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
abstract byte[] | X509CRL.getEncoded() 返回此 CRL 的 ASN.1 DER 编码形式。
abstract byte[] | X509CRLEntry.getEncoded() 返回此 CRL Entry 的 ASN.1 DER 编码形式，即内部 SEQUENCE。
abstract byte[] | X509CRL.getTBSCertList() 从此 CRL 中获取以 DER 编码的 CRL 信息，即 tbsCertList。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.CRLSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CRLSelector
的使用

使用 CRLSelector 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CRLSelector 的使用

实现 CRLSelector 的 java.security.cert 中的类
 class X509CRLSelector
选择与所有指定标准相匹配的 X509CRL 的 CRLSelector。

参数类型为 CRLSelector 的 java.security.cert 中的方法
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPathBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathBuilder
的使用

使用 CertPathBuilder 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilder 的使用

返回 CertPathBuilder 的 java.security.cert 中的方法
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, Provider provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, String provider) 返回实现了指定算法的 CertPathBuilder 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPathBuilderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathBuilderException
的使用

使用 CertPathBuilderException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilderException 的使用

抛出 CertPathBuilderException 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.CertPathBuilderResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertPathBuilderResult
的使用

使用 CertPathBuilderResult 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilderResult 的使用

实现 CertPathBuilderResult 的 java.security.cert 中的类
 class PKIXCertPathBuilderResult
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。

返回 CertPathBuilderResult 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPathBuilderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathBuilderSpi
的使用

使用 CertPathBuilderSpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathBuilderSpi 的使用

参数类型为 CertPathBuilderSpi 的 java.security.cert 中的构造方法
CertPathBuilder(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.CertPathParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertPathParameters
的使用

使用 CertPathParameters 的软件包
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security.cert 中 CertPathParameters 的使用

实现 CertPathParameters 的 java.security.cert 中的类
class | PKIXBuilderParameters 用作 PKIX CertPathBuilder 算法的输入的参数。
class | PKIXParameters 用作 PKIX CertPathValidator 算法的输入的参数。

参数类型为 CertPathParameters 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

javax.net.ssl 中 CertPathParameters 的使用

返回 CertPathParameters 的 javax.net.ssl 中的方法
 CertPathParameters CertPathTrustManagerParameters.getParameters()
返回此类封装的 CertPathParameters 的副本。

参数类型为 CertPathParameters 的 javax.net.ssl 中的构造方法
CertPathTrustManagerParameters(CertPathParameters parameters)
根据指定的 parameters 构造新的 CertPathTrustManagerParameters。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPathValidator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathValidator
的使用

使用 CertPathValidator 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidator 的使用

返回 CertPathValidator 的 java.security.cert 中的方法
static CertPathValidator | CertPathValidator.getInstance(String algorithm) 返回实现了指定算法的 CertPathValidator 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, Provider provider) 返回实现指定算法的 CertPathValidator 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, String provider) 返回实现指定算法的 CertPathValidator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPathValidatorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathValidatorException
的使用

使用 CertPathValidatorException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidatorException 的使用

抛出 CertPathValidatorException 的 java.security.cert 中的方法
abstract void | PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts) 使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
abstract void | PKIXCertPathChecker.init(boolean forward) 初始化此 PKIXCertPathChecker 的内部状态。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.CertPathValidatorResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertPathValidatorResult
的使用

使用 CertPathValidatorResult 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidatorResult 的使用

实现 CertPathValidatorResult 的 java.security.cert 中的类
class | PKIXCertPathBuilderResult 此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。
class | PKIXCertPathValidatorResult 此类表示 PKIX 证书路径验证算法执行成功时所返回的结果。

返回 CertPathValidatorResult 的 java.security.cert 中的方法
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPathValidatorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPathValidatorSpi
的使用

使用 CertPathValidatorSpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertPathValidatorSpi 的使用

参数类型为 CertPathValidatorSpi 的 java.security.cert 中的构造方法
CertPathValidator(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.CertSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertSelector
的使用

使用 CertSelector 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertSelector 的使用

实现 CertSelector 的 java.security.cert 中的类
 class X509CertSelector
选择与所有指定标准匹配的 X509Certificates 的 CertSelector。

返回 CertSelector 的 java.security.cert 中的方法
 CertSelector PKIXParameters.getTargetCertConstraints()
返回目标证书所需的限制。

参数类型为 CertSelector 的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
void | PKIXParameters.setTargetCertConstraints(CertSelector selector) 设置目标证书所需的限制。

参数类型为 CertSelector 的 java.security.cert 中的构造方法
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertStore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertStore
的使用

使用 CertStore 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStore 的使用

返回 CertStore 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。

返回变量类型为 CertStore 的类型的 java.security.cert 中的方法
 List<CertStore> PKIXParameters.getCertStores()
返回用于查找证书和 CRL 的不可变 CertStore List。

参数类型为 CertStore 的 java.security.cert 中的方法
 void PKIXParameters.addCertStore(CertStore store)
将 CertStore 添加到查找证书和 CRL 所使用的 CertStore 列表末尾。

类型变量类型为 CertStore 的 java.security.cert 中的方法参数
 void PKIXParameters.setCertStores(List<CertStore> stores)
设置在查找证书和 CRL 时所使用的 CertStore 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertStoreException
的使用

使用 CertStoreException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStoreException 的使用

抛出 CertStoreException 的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.CertStoreParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.CertStoreParameters
的使用

使用 CertStoreParameters 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStoreParameters 的使用

实现 CertStoreParameters 的 java.security.cert 中的类
class | CollectionCertStoreParameters 用作 Collection CertStore 算法输入的参数。
class | LDAPCertStoreParameters 用作 LDAP CertStore 算法的输入的参数。

返回 CertStoreParameters 的 java.security.cert 中的方法
 CertStoreParameters CertStore.getCertStoreParameters()
返回初始化此 CertStore 所用的参数。

参数类型为 CertStoreParameters 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。

参数类型为 CertStoreParameters 的 java.security.cert 中的构造方法
CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。
CertStoreSpi(CertStoreParameters params)
唯一的构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertStoreSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertStoreSpi
的使用

使用 CertStoreSpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertStoreSpi 的使用

参数类型为 CertStoreSpi 的 java.security.cert 中的构造方法
CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertificateEncodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateEncodingException
的使用

使用 CertificateEncodingException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateEncodingException 的使用

抛出 CertificateEncodingException 的 java.security.cert 中的方法
abstract byte[] | CertPath.getEncoded() 返回此证书路径的编码形式，使用默认的编码。
abstract byte[] | Certificate.getEncoded() 返回此证书的编码形式。
abstract byte[] | CertPath.getEncoded(String encoding) 返回此证书路径的编码形式，使用指定的编码。
abstract byte[] | X509Certificate.getTBSCertificate() 从此证书中获取以 DER 编码的证书信息，即 tbsCertificate。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertificateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateException
的使用

使用 CertificateException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 CertificateException 的使用

抛出 CertificateException 的 java.security 中的方法
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

java.security.cert 中 CertificateException 的使用

java.security.cert 中 CertificateException 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书尚无效异常。
class | CertificateParsingException 证书解析异常。

抛出 CertificateException 的 java.security.cert 中的方法
abstract Certificate | CertificateFactorySpi.engineGenerateCertificate(InputStream inStream) 生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
Certificate | CertificateFactory.generateCertificate(InputStream inStream) 生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
CertPath | CertificateFactory.generateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
static CertificateFactory | CertificateFactory.getInstance(String type) 返回实现指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, Provider provider) 返回指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, String provider) 返回指定证书类型的 CertificateFactory 对象。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.net.ssl 中 CertificateException 的使用

抛出 CertificateException 的 javax.net.ssl 中的方法
void | X509TrustManager.checkClientTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。
void | X509TrustManager.checkServerTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertificateExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateExpiredException
的使用

使用 CertificateExpiredException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateExpiredException 的使用

抛出 CertificateExpiredException 的 java.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查给定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertificateNotYetValidException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateNotYetValidException
的使用

使用 CertificateNotYetValidException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateNotYetValidException 的使用

抛出 CertificateNotYetValidException 的 java.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查给定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertificateParsingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateParsingException
的使用

使用 CertificateParsingException 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateParsingException 的使用

抛出 CertificateParsingException 的 java.security.cert 中的方法
List<String> | X509Certificate.getExtendedKeyUsage() 获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。
Collection<List<?>> | X509Certificate.getIssuerAlternativeNames() 从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
Collection<List<?>> | X509Certificate.getSubjectAlternativeNames() 从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CollectionCertStoreParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CollectionCertStoreParameters
的使用

没有 java.security.cert.CollectionCertStoreParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.LDAPCertStoreParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.LDAPCertStoreParameters
的使用

没有 java.security.cert.LDAPCertStoreParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.PKIXBuilderParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXBuilderParameters
的使用

没有 java.security.cert.PKIXBuilderParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.PKIXCertPathBuilderResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXCertPathBuilderResult
的使用

没有 java.security.cert.PKIXCertPathBuilderResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.PKIXCertPathChecker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXCertPathChecker
的使用

使用 PKIXCertPathChecker 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PKIXCertPathChecker 的使用

返回变量类型为 PKIXCertPathChecker 的类型的 java.security.cert 中的方法
 List<PKIXCertPathChecker> PKIXParameters.getCertPathCheckers()
返回证书路径检查器的 List。

参数类型为 PKIXCertPathChecker 的 java.security.cert 中的方法
 void PKIXParameters.addCertPathChecker(PKIXCertPathChecker checker)
向证书路径检查器列表中添加一个 PKIXCertPathChecker。

类型变量类型为 PKIXCertPathChecker 的 java.security.cert 中的方法参数
 void PKIXParameters.setCertPathCheckers(List<PKIXCertPathChecker> checkers)
设置其他证书路径检查器的 List。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.PKIXParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXParameters
的使用

使用 PKIXParameters 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PKIXParameters 的使用

java.security.cert 中 PKIXParameters 的子类
 class PKIXBuilderParameters
用作 PKIX CertPathBuilder 算法的输入的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.PKIXCertPathValidatorResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PKIXCertPathValidatorResult
的使用

使用 PKIXCertPathValidatorResult 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PKIXCertPathValidatorResult 的使用

java.security.cert 中 PKIXCertPathValidatorResult 的子类
 class PKIXCertPathBuilderResult
此类表示 PKIX 证书路径生成器算法执行成功时所返回的结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.PolicyNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.PolicyNode
的使用

使用 PolicyNode 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PolicyNode 的使用

返回 PolicyNode 的 java.security.cert 中的方法
PolicyNode | PolicyNode.getParent() 返回此节点的父节点，如果此节点是根节点，则返回 null。
PolicyNode | PKIXCertPathValidatorResult.getPolicyTree() 返回 PKIX 证书路径验证算法所得的有效策略树的根节点。

返回变量类型为 PolicyNode 的类型的 java.security.cert 中的方法
 Iterator<? extends PolicyNode> PolicyNode.getChildren()
返回在此节点的子节点上进行迭代的迭代器。

参数类型为 PolicyNode 的 java.security.cert 中的构造方法
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathValidatorResult(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.PolicyQualifierInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.PolicyQualifierInfo
的使用

使用 PolicyQualifierInfo 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 PolicyQualifierInfo 的使用

返回变量类型为 PolicyQualifierInfo 的类型的 java.security.cert 中的方法
 Set<? extends PolicyQualifierInfo> PolicyNode.getPolicyQualifiers()
返回与此节点所表示的有效策略相关联的策略限定符集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.TrustAnchor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.TrustAnchor
的使用

使用 TrustAnchor 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 TrustAnchor 的使用

返回 TrustAnchor 的 java.security.cert 中的方法
 TrustAnchor PKIXCertPathValidatorResult.getTrustAnchor()
返回描述作为证书路径受信定位点的 CA 的 TrustAnchor。

返回变量类型为 TrustAnchor 的类型的 java.security.cert 中的方法
 Set<TrustAnchor> PKIXParameters.getTrustAnchors()
返回不可变的、最受信任的 CA Set。

类型变量类型为 TrustAnchor 的 java.security.cert 中的方法参数
 void PKIXParameters.setTrustAnchors(Set<TrustAnchor> trustAnchors)
设置最受信任的 CA Set。

参数类型为 TrustAnchor 的 java.security.cert 中的构造方法
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathValidatorResult(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。

类型变量类型为 TrustAnchor 的 java.security.cert 中的构造方法参数
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXParameters(Set<TrustAnchor> trustAnchors)
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.X509CRL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CRL
的使用

没有 java.security.cert.X509CRL 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.X509CRLEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CRLEntry
的使用

使用 X509CRLEntry 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 X509CRLEntry 的使用

返回 X509CRLEntry 的 java.security.cert 中的方法
abstract X509CRLEntry | X509CRL.getRevokedCertificate(BigInteger serialNumber) 获取具有给定证书 serialNumber 的 CRL 项（如果有）。
X509CRLEntry | X509CRL.getRevokedCertificate(X509Certificate certificate) 获取给定证书的 CRL 项（如果有）。

返回变量类型为 X509CRLEntry 的类型的 java.security.cert 中的方法
abstract  Set<? extends X509CRLEntry> X509CRL.getRevokedCertificates()
获取此 CRL 中的所有项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.X509CRLSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CRLSelector
的使用

没有 java.security.cert.X509CRLSelector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.X509CertSelector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509CertSelector
的使用

没有 java.security.cert.X509CertSelector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPath 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPath
的使用

使用 CertPath 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security 中 CertPath 的使用

返回 CertPath 的 java.security 中的方法
CertPath | Timestamp.getSignerCertPath() 返回 Timestamping Authority 的证书路径。
CertPath | CodeSigner.getSignerCertPath() 返回签名者的证书路径。

参数类型为 CertPath 的 java.security 中的构造方法
CodeSigner(CertPath signerCertPath, Timestamp timestamp)
构造 CodeSigner 对象。
Timestamp(Date timestamp, CertPath signerCertPath)
构造一个时间戳。

java.security.cert 中 CertPath 的使用

返回 CertPath 的 java.security.cert 中的方法
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(InputStream inStream, String encoding) 生成一个 CertPath 对象，并使用从 InputStream inStream 中读取的数据对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
CertPath | CertPathBuilderResult.getCertPath() 返回已构建的证书路径。
CertPath | CertPathValidatorException.getCertPath() 返回抛出异常时正在验证的证书路径
CertPath | PKIXCertPathBuilderResult.getCertPath() 返回已构建并已验证的证书路径。

参数类型为 CertPath 的 java.security.cert 中的方法
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

参数类型为 CertPath 的 java.security.cert 中的构造方法
CertPathValidatorException(String msg, Throwable cause, CertPath certPath, int index)
创建带指定详细消息、cause、证书路径和索引的 CertPathValidatorException。
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertPath.CertPathRep 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertPath.CertPathRep
的使用

没有 java.security.cert.CertPath.CertPathRep 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.X509Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.X509Certificate
的使用

使用 X509Certificate 的软件包
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.security.cert 中 X509Certificate 的使用

返回 X509Certificate 的 java.security.cert 中的方法
X509Certificate | X509CertSelector.getCertificate() 返回 certificateEquals 标准。
X509Certificate | X509CRLSelector.getCertificateChecking() 返回要检查的证书。
X509Certificate | TrustAnchor.getTrustedCert() 返回最受信任的 CA 证书。

参数类型为 X509Certificate 的 java.security.cert 中的方法
X509CRLEntry | X509CRL.getRevokedCertificate(X509Certificate certificate) 获取给定证书的 CRL 项（如果有）。
void | X509CertSelector.setCertificate(X509Certificate cert) 设置 certificateEquals 标准。
void | X509CRLSelector.setCertificateChecking(X509Certificate cert) 设置要检查的证书。

参数类型为 X509Certificate 的 java.security.cert 中的构造方法
TrustAnchor(X509Certificate trustedCert, byte[] nameConstraints)
创建具有指定 X509Certificate 和可选 nameConstraints 的 TrustAnchor 实例，在验证 X.509 证书路径时，该 nameConstraints 用作额外的限制条件。

javax.net.ssl 中 X509Certificate 的使用

返回 X509Certificate 的 javax.net.ssl 中的方法
X509Certificate[] | X509TrustManager.getAcceptedIssuers() 返回受验证同位体信任的认证中心的数组。
X509Certificate[] | X509KeyManager.getCertificateChain(String alias) 返回与给定别名关联的证书链。

参数类型为 X509Certificate 的 javax.net.ssl 中的方法
void | X509TrustManager.checkClientTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。
void | X509TrustManager.checkServerTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。

javax.security.auth.x500 中 X509Certificate 的使用

返回 X509Certificate 的 javax.security.auth.x500 中的方法
 X509Certificate X500PrivateCredential.getCertificate()
返回 X.509 证书。

参数类型为 X509Certificate 的 javax.security.auth.x500 中的构造方法
X500PrivateCredential(X509Certificate cert, PrivateKey key)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.cert.X509Extension 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.cert.X509Extension
的使用

使用 X509Extension 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 X509Extension 的使用

实现 X509Extension 的 java.security.cert 中的类
class | X509Certificate X.509 证书的抽象类。
class | X509CRL X.509 证书撤消列表 (CRL) 的抽象类。
class | X509CRLEntry 用于 CRL（证书撤消列表）中已撤消证书的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertificateFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateFactorySpi
的使用

使用 CertificateFactorySpi 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateFactorySpi 的使用

参数类型为 CertificateFactorySpi 的 java.security.cert 中的构造方法
CertificateFactory(CertificateFactorySpi certFacSpi, Provider provider, String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.CertificateFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.CertificateFactory
的使用

使用 CertificateFactory 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 CertificateFactory 的使用

返回 CertificateFactory 的 java.security.cert 中的方法
static CertificateFactory | CertificateFactory.getInstance(String type) 返回实现指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, Provider provider) 返回指定证书类型的 CertificateFactory 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, String provider) 返回指定证书类型的 CertificateFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.Certificate
的使用

使用 Certificate 的软件包
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 Certificate 的使用

返回 Certificate 的 java.net 中的方法
 Certificate[] JarURLConnection.getCertificates()
如果此连接的 URL 指向 JAR 文件条目，则返回其 Certificate 对象；否则返回 null。

返回变量类型为 Certificate 的类型的 java.net 中的方法
abstract List<Certificate> | SecureCacheResponse.getLocalCertificateChain() 返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。
abstract List<Certificate> | SecureCacheResponse.getServerCertificateChain() 从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。

java.security 中 Certificate 的使用

返回 Certificate 的 java.security 中的方法
abstract Certificate | KeyStoreSpi.engineGetCertificate(String alias) 返回与给定别名关联的证书。
abstract Certificate[] | KeyStoreSpi.engineGetCertificateChain(String alias) 返回与给定别名关联的证书链。
Certificate | KeyStore.PrivateKeyEntry.getCertificate() 从此项中的证书链获取终端实体 Certificate。
Certificate | KeyStore.getCertificate(String alias) 返回与给定别名关联的证书。
Certificate[] | KeyStore.PrivateKeyEntry.getCertificateChain() 从此项获取 Certificate 链。
Certificate[] | KeyStore.getCertificateChain(String alias) 返回与给定别名关联的证书链。
Certificate[] | CodeSource.getCertificates() 返回与此 CodeSource 关联的证书。
Certificate | KeyStore.TrustedCertificateEntry.getTrustedCertificate() 从此项获取可信 Certficate。
Certificate[] | UnresolvedPermission.getUnresolvedCerts() 获取尚未解析的基础权限的签署者证书（无任何支持链）。

参数类型为 Certificate 的 java.security 中的方法
abstract String | KeyStoreSpi.engineGetCertificateAlias(Certificate cert) 返回其证书和给定证书匹配的第一个 keystore 项的名称（别名）。
abstract void | KeyStoreSpi.engineSetCertificateEntry(String alias, Certificate cert) 将给定证书分配给给定别名。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，用给定的密码保护它。
String | KeyStore.getCertificateAlias(Certificate cert) 返回证书与给定证书匹配的第一个 keystore 条目的别名。
void | Signature.initVerify(Certificate certificate) 使用来自给定证书的公钥初始化此用于验证的对象。
void | KeyStore.setCertificateEntry(String alias, Certificate cert) 将给定可信证书分配给给定别名。
void | KeyStore.setKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
void | KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，并用给定密码保护它。

参数类型为 Certificate 的 java.security 中的构造方法
CodeSource(URL url, Certificate[] certs)
构造一个 CodeSource 并将其与指定位置和证书集合相关联。
KeyStore.PrivateKeyEntry(PrivateKey privateKey, Certificate[] chain)
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。
KeyStore.TrustedCertificateEntry(Certificate trustedCert)
用可信 Certificate 构造 TrustedCertificateEntry。
UnresolvedPermission(String type, String name, String actions, Certificate[] certs)
在解析权限时，创建一个新的 UnresolvedPermission，使之包含稍后实际创建指定类的 Permission 时所需的权限信息。

java.security.cert 中 Certificate 的使用

java.security.cert 中 Certificate 的子类
 class X509Certificate
X.509 证书的抽象类。

返回 Certificate 的 java.security.cert 中的方法
abstract Certificate | CertificateFactorySpi.engineGenerateCertificate(InputStream inStream) 生成一个证书对象并使用从输入流 inStream 中读取的数据对它进行初始化。
Certificate | CertificateFactory.generateCertificate(InputStream inStream) 生成一个证书对象，并使用从输入流 inStream 中读取的数据对它进行初始化。

返回变量类型为 Certificate 的类型的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
abstract List<? extends Certificate> | CertPath.getCertificates() 返回此证书路径中的证书列表。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。

参数类型为 Certificate 的 java.security.cert 中的方法
abstract void | PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts) 使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
abstract boolean | CRL.isRevoked(Certificate cert) 检查给定的证书是否在此 CRL 中。
boolean | CertSelector.match(Certificate cert) 决定是否应该选择某个 Certificate。
boolean | X509CertSelector.match(Certificate cert) 决定是否应该选择某个 Certificate。

类型变量类型为 Certificate 的 java.security.cert 中的方法参数
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。

java.util.jar 中 Certificate 的使用

返回 Certificate 的 java.util.jar 中的方法
 Certificate[] JarEntry.getCertificates()
返回此条目的 Certificate 对象；如果没有，则返回 null。

javax.crypto 中 Certificate 的使用

参数类型为 Certificate 的 javax.crypto 中的方法
void | Cipher.init(int opmode, Certificate certificate) 用取自给定证书的公钥初始化此 Cipher。
void | Cipher.init(int opmode, Certificate certificate, SecureRandom random) 用取自给定证书的公钥和随机源初始化此 Cipher。

javax.net.ssl 中 Certificate 的使用

返回 Certificate 的 javax.net.ssl 中的方法
Certificate[] | HandshakeCompletedEvent.getLocalCertificates() 返回握手期间发送到同位体的证书。
Certificate[] | SSLSession.getLocalCertificates() 返回握手期间发送给同位体的证书。
abstract Certificate[] | HttpsURLConnection.getLocalCertificates() 返回握手期间发送给服务器的证书。
Certificate[] | HandshakeCompletedEvent.getPeerCertificates() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Certificate[] | SSLSession.getPeerCertificates() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
abstract Certificate[] | HttpsURLConnection.getServerCertificates() 返回服务器的证书链，它是作为定义会话的一部分而建立的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.cert.Certificate.CertificateRep 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.cert.Certificate.CertificateRep
的使用

没有 java.security.cert.Certificate.CertificateRep 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


DSAKey (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 DSAKey

所有已知子接口：
DSAPrivateKey, DSAPublicKey
public interface DSAKey

DSA 公用或专用密钥的接口。DSA（数字签名算法）在 NIST 的 FIPS-186 中进行了定义。

另请参见：
DSAParams, Key, Signature

方法摘要
 DSAParams getParams()
返回特定于 DSA 的密钥参数。

方法详细信息

getParams

DSAParams getParams()
返回特定于 DSA 的密钥参数。这些参数从来不是秘密的。

返回：
特定于 DSA 的密钥参数。
另请参见：
DSAParams
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DSAKeyPairGenerator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 DSAKeyPairGenerator

public interface DSAKeyPairGenerator

能够生成 DSA 密钥对的对象的接口。

可以对每个 initialize 方法调用任意多次。如果没有对 DSAKeyPairGenerator 调用 initialize 方法，则默认使用预计算的 p、q、g 参数并使用 SecureRandom 的某个实例作为随机位源，生成一个 1024 位的密钥。

希望指示特定于 DSA 参数的用户，以及希望生成适合于 DSA 算法使用的密钥对的用户通常可以进行以下操作：

  1. 通过调用 KeyPairGenerator getInstance 方法并将 "DSA" 作为其参数，获取 DSA 算法的密钥对生成器。

  2. 通过将结果强制转换为 DSAKeyPairGenerator，并从此 DSAKeyPairGenerator 接口调用 initialize 方法之一，初始化该生成器。

  3. 通过从 KeyPairGenerator 类调用 generateKeyPair 方法生成一个密钥对。

注：并非总是需要对 DSA 密钥对生成器执行特定于算法的初始化。也就是说，并非总是需要调用此接口中的 initialize 方法。接受特定于算法的参数的默认值时，只需要使用 KeyPairGenerator 接口 initialize 方法的与算法无关的初始化。

另请参见：
KeyPairGenerator

方法摘要
void | initialize(DSAParams params, SecureRandom random) 使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。
void | initialize(int modlen, boolean genParams, SecureRandom random) 使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。

方法详细信息

initialize

void initialize(DSAParams params,
                SecureRandom random)
                throws InvalidParameterException
使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。如果需要 SecureRandom 位源但没有提供，即 SecureRandom 为 null，则使用默认 SecureRandom 实例。

参数：
params - 用于生成密钥的参数。
random - 用于生成密钥位的随机位源；可以为 null。
抛出：
InvalidParameterException - 如果 params 值无效或为 null。

initialize

void initialize(int modlen,
                boolean genParams,
                SecureRandom random)
                throws InvalidParameterException
使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。如果需要 SecureRandom 位源但没有提供，即 SecureRandom 为 null，则使用默认 SecureRandom 实例。

如果 genParams 为 true，则此方法生成新的 p、q 和 g 参数。如果为 false，则该方法使用对应于所请求系数长度的预计算参数。如果不存在对应于该系数长度的预计算参数，则将抛出一个异常。确保总是存在系数长度为 512 和 1024 位的对应默认参数。

参数：
modlen - 以位为单位的系数长度。有效值在 512 到 1024（包括两者）之间，且是 8 的倍数。
random - 用于生成密钥位的随机位源；可以为 null。
genParams - 是否生成对应所请求系数长度的新参数。
抛出：
InvalidParameterException - 如果 modlen 不在 512 到 1024 之间，或者 genParams 为 false，并且不存在对应所请求系数长度的预计算参数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DSAParams (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 DSAParams

所有已知实现类：
DSAParameterSpec
public interface DSAParams

特定于 DSA 的密钥参数集的接口，它定义 DSA 密钥系列。DSA（数字签名算法）在 NIST 的 FIPS-186 中进行了定义。

另请参见：
DSAKey, Key, Signature

方法摘要
BigInteger | getG() 返回基数 g。
BigInteger | getP() 返回素数 p。
BigInteger | getQ() 返回子素数 q。

方法详细信息

getP

BigInteger getP()
返回素数 p。

返回：
素数 p。

getQ

BigInteger getQ()
返回子素数 q。

返回：
子素数 q。

getG

BigInteger getG()
返回基数 g。

返回：
基数 g。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DSAPrivateKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 DSAPrivateKey

所有超级接口：
DSAKey, Key, PrivateKey, Serializable
public interface DSAPrivateKey
extends DSAKey, PrivateKey

DSA 专用密钥的标准接口。DSA（数字签名算法）在 NIST 的 FIPS-186 中进行了定义。

另请参见：
Key, Signature, DSAKey, DSAPublicKey

字段摘要
static long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。
方法摘要
 BigInteger getX()
返回专用密钥值 x。
从接口 java.security.interfaces.DSAKey 继承的方法
getParams
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。

另请参见：
常量字段值
方法详细信息

getX

BigInteger getX()
返回专用密钥值 x。

返回：
专用密钥值 x。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DSAPublicKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 DSAPublicKey

所有超级接口：
DSAKey, Key, PublicKey, Serializable
public interface DSAPublicKey
extends DSAKey, PublicKey

DSA 公用密钥的接口。DSA（数字签名算法）在 NIST 的 FIPS-186 中进行了定义。

另请参见：
Key, Signature, DSAKey, DSAPrivateKey

字段摘要
static long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。
方法摘要
 BigInteger getY()
返回公用密钥值 y。
从接口 java.security.interfaces.DSAKey 继承的方法
getParams
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
设置为指示与以前的类版本序列化兼容的类指纹。

另请参见：
常量字段值
方法详细信息

getY

BigInteger getY()
返回公用密钥值 y。

返回：
公用密钥值 y。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 ECKey

所有已知子接口：
ECPrivateKey, ECPublicKey
public interface ECKey

椭圆曲线 (EC) 密钥的接口。

从以下版本开始：
1.5

方法摘要
 ECParameterSpec getParams()
返回与此密钥关联的域参数。

方法详细信息

getParams

ECParameterSpec getParams()
返回与此密钥关联的域参数。域参数要么显式地指定，要么在生成密钥的过程中隐式创建。

返回：
关联的域参数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECPrivateKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 ECPrivateKey

所有超级接口：
ECKey, Key, PrivateKey, Serializable
public interface ECPrivateKey
extends PrivateKey, ECKey

椭圆曲线 (EC) 专用密钥的接口。

从以下版本开始：
1.5
另请参见：
PrivateKey, ECKey

字段摘要
static long serialVersionUID
设置为指示序列化兼容性的类指纹。
方法摘要
 BigInteger getS()
返回专用密钥值 S。
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat
从接口 java.security.interfaces.ECKey 继承的方法
getParams

字段详细信息

serialVersionUID

static final long serialVersionUID
设置为指示序列化兼容性的类指纹。

另请参见：
常量字段值
方法详细信息

getS

BigInteger getS()
返回专用密钥值 S。

返回：
专用密钥值 S。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECPublicKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 ECPublicKey

所有超级接口：
ECKey, Key, PublicKey, Serializable
public interface ECPublicKey
extends PublicKey, ECKey

椭圆曲线 (EC) 公用密钥的接口。

从以下版本开始：
1.5
另请参见：
PublicKey, ECKey, ECPoint

字段摘要
static long serialVersionUID
设置为指示序列化兼容性的类指纹。
方法摘要
 ECPoint getW()
返回公用点 W。
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat
从接口 java.security.interfaces.ECKey 继承的方法
getParams

字段详细信息

serialVersionUID

static final long serialVersionUID
设置为指示序列化兼容性的类指纹。

另请参见：
常量字段值
方法详细信息

getW

ECPoint getW()
返回公用点 W。

返回：
公用点 W。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 RSAKey

所有已知子接口：
RSAMultiPrimePrivateCrtKey, RSAPrivateCrtKey, RSAPrivateKey, RSAPublicKey
public interface RSAKey

RSA 公用密钥或专用密钥的接口。

从以下版本开始：
1.3
另请参见：
RSAPublicKey, RSAPrivateKey

方法摘要
 BigInteger getModulus()
返回该系数。

方法详细信息

getModulus

BigInteger getModulus()
返回该系数。

返回：
系数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAMultiPrimePrivateCrtKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 RSAMultiPrimePrivateCrtKey

所有超级接口：
Key, PrivateKey, RSAKey, RSAPrivateKey, Serializable
public interface RSAMultiPrimePrivateCrtKey
extends RSAPrivateKey

如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。

从以下版本开始：
1.4
另请参见：
RSAPrivateKeySpec, RSAMultiPrimePrivateCrtKeySpec, RSAPrivateKey, RSAPrivateCrtKey

字段摘要
static long serialVersionUID
方法摘要
BigInteger | getCrtCoefficient() 返回 crtCoefficient。
RSAOtherPrimeInfo[] | getOtherPrimeInfo() 返回 otherPrimeInfo；如果仅存在两个素数因子（p 和 q），则返回 null。
BigInteger | getPrimeExponentP() 返回 primeExponentP。
BigInteger | getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | getPrimeP() 返回 primeP。
BigInteger | getPrimeQ() 返回 primeQ。
BigInteger | getPublicExponent() 返回公用指数。
从接口 java.security.interfaces.RSAPrivateKey 继承的方法
getPrivateExponent
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat
从接口 java.security.interfaces.RSAKey 继承的方法
getModulus

字段详细信息

serialVersionUID

static final long serialVersionUID
另请参见：
常量字段值
方法详细信息

getPublicExponent

BigInteger getPublicExponent()
返回公用指数。

返回：
该公用指数。

getPrimeP

BigInteger getPrimeP()
返回 primeP。

返回：
primeP。

getPrimeQ

BigInteger getPrimeQ()
返回 primeQ。

返回：
primeQ。

getPrimeExponentP

BigInteger getPrimeExponentP()
返回 primeExponentP。

返回：
primeExponentP。

getPrimeExponentQ

BigInteger getPrimeExponentQ()
返回 primeExponentQ。

返回：
primeExponentQ。

getCrtCoefficient

BigInteger getCrtCoefficient()
返回 crtCoefficient。

返回：
crtCoefficient。

getOtherPrimeInfo

RSAOtherPrimeInfo[] getOtherPrimeInfo()
返回 otherPrimeInfo；如果仅存在两个素数因子（p 和 q），则返回 null。

返回：
otherPrimeInfo。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAPrivateCrtKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 RSAPrivateCrtKey

所有超级接口：
Key, PrivateKey, RSAKey, RSAPrivateKey, Serializable
public interface RSAPrivateCrtKey
extends RSAPrivateKey

如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。

另请参见：
RSAPrivateKey

字段摘要
static long serialVersionUID
方法摘要
BigInteger | getCrtCoefficient() 返回 crtCoefficient。
BigInteger | getPrimeExponentP() 返回 primeExponentP。
BigInteger | getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | getPrimeP() 返回 primeP。
BigInteger | getPrimeQ() 返回 primeQ。
BigInteger | getPublicExponent() 返回公用指数。
从接口 java.security.interfaces.RSAPrivateKey 继承的方法
getPrivateExponent
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat
从接口 java.security.interfaces.RSAKey 继承的方法
getModulus

字段详细信息

serialVersionUID

static final long serialVersionUID
另请参见：
常量字段值
方法详细信息

getPublicExponent

BigInteger getPublicExponent()
返回公用指数。

返回：
该公用指数

getPrimeP

BigInteger getPrimeP()
返回 primeP。

返回：
primeP

getPrimeQ

BigInteger getPrimeQ()
返回 primeQ。

返回：
primeQ

getPrimeExponentP

BigInteger getPrimeExponentP()
返回 primeExponentP。

返回：
primeExponentP

getPrimeExponentQ

BigInteger getPrimeExponentQ()
返回 primeExponentQ。

返回：
primeExponentQ

getCrtCoefficient

BigInteger getCrtCoefficient()
返回 crtCoefficient。

返回：
crtCoefficient
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAPrivateKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 RSAPrivateKey

所有超级接口：
Key, PrivateKey, RSAKey, Serializable
所有已知子接口：
RSAMultiPrimePrivateCrtKey, RSAPrivateCrtKey
public interface RSAPrivateKey
extends PrivateKey, RSAKey

RSA 专用密钥的接口。

另请参见：
RSAPrivateCrtKey

字段摘要
static long serialVersionUID
方法摘要
 BigInteger getPrivateExponent()
返回专用指数。
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat
从接口 java.security.interfaces.RSAKey 继承的方法
getModulus

字段详细信息

serialVersionUID

static final long serialVersionUID
另请参见：
常量字段值
方法详细信息

getPrivateExponent

BigInteger getPrivateExponent()
返回专用指数。

返回：
该专用指数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAPublicKey (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.interfaces
接口 RSAPublicKey

所有超级接口：
Key, PublicKey, RSAKey, Serializable
public interface RSAPublicKey
extends PublicKey, RSAKey

RSA 公用密钥的接口。

字段摘要
static long serialVersionUID
方法摘要
 BigInteger getPublicExponent()
返回该公用指数。
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat
从接口 java.security.interfaces.RSAKey 继承的方法
getModulus

字段详细信息

serialVersionUID

static final long serialVersionUID
另请参见：
常量字段值
方法详细信息

getPublicExponent

BigInteger getPublicExponent()
返回该公用指数。

返回：
该公用指数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.security.interfaces (Java 2 Platform SE 6)

 java.security.interfaces
接口
DSAKey
DSAKeyPairGenerator
DSAParams
DSAPrivateKey
DSAPublicKey
ECKey
ECPrivateKey
ECPublicKey
RSAKey
RSAMultiPrimePrivateCrtKey
RSAPrivateCrtKey
RSAPrivateKey
RSAPublicKey


java.security.interfaces (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.security.interfaces

提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

请参见：
描述

接口摘要
DSAKey | DSA 公用或专用密钥的接口。
DSAKeyPairGenerator | 能够生成 DSA 密钥对的对象的接口。
DSAParams | 特定于 DSA 的密钥参数集的接口，它定义 DSA 密钥系列。
DSAPrivateKey | DSA 专用密钥的标准接口。
DSAPublicKey | DSA 公用密钥的接口。
ECKey | 椭圆曲线 (EC) 密钥的接口。
ECPrivateKey | 椭圆曲线 (EC) 专用密钥的接口。
ECPublicKey | 椭圆曲线 (EC) 公用密钥的接口。
RSAKey | RSA 公用密钥或专用密钥的接口。
RSAMultiPrimePrivateCrtKey | 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
RSAPrivateCrtKey | 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
RSAPrivateKey | RSA 专用密钥的接口。
RSAPublicKey | RSA 公用密钥的接口。

软件包 java.security.interfaces 的描述

提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

注意，这些接口仅用于密钥内容可访问且可用的密钥实现。这些接口仅用于密钥内容位于不可访问的受保护存储设备（如位于硬件设备）中的密钥实现。

有关如何使用这些接口（包括如何为硬件设备设计 Key 类）的更多开发人员的信息，请参考以下加密提供者开发人员指南：

  • How to Implement a Provider for the JavaTM Cryptography Architecture

包规范

  • PKCS #1:RSA 加密标准 1.5 版，1993 年 11 月
  • 联邦信息处理标准出版物 (FIPS PUB) 186：数字签名标准 (DSS)

相关文档

有关详细的文档信息，请参阅：
  • JavaTM Cryptography Architecture API Specification and Reference

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.security.interfaces 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.interfaces 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • java.security.interfaces.DSAKey
    • java.security.interfaces.DSAPrivateKey (并 extends java.security.PrivateKey)
    • java.security.interfaces.DSAPublicKey (并 extends java.security.PublicKey)
  • java.security.interfaces.DSAKeyPairGenerator
  • java.security.interfaces.DSAParams
  • java.security.interfaces.ECKey
    • java.security.interfaces.ECPrivateKey (并 extends java.security.PrivateKey)
    • java.security.interfaces.ECPublicKey (并 extends java.security.PublicKey)
  • java.security.interfaces.RSAKey
    • java.security.interfaces.RSAPrivateKey (并 extends java.security.PrivateKey)
      • java.security.interfaces.RSAMultiPrimePrivateCrtKey
      • java.security.interfaces.RSAPrivateCrtKey
    • java.security.interfaces.RSAPublicKey (并 extends java.security.PublicKey)
  • java.io.Serializable
    • java.security.Key
      • java.security.PrivateKey
        • java.security.interfaces.DSAPrivateKey (并 extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPrivateKey (并 extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAPrivateKey (并 extends java.security.interfaces.RSAKey)
          • java.security.interfaces.RSAMultiPrimePrivateCrtKey
          • java.security.interfaces.RSAPrivateCrtKey
      • java.security.PublicKey
        • java.security.interfaces.DSAPublicKey (并 extends java.security.interfaces.DSAKey)
        • java.security.interfaces.ECPublicKey (并 extends java.security.interfaces.ECKey)
        • java.security.interfaces.RSAPublicKey (并 extends java.security.interfaces.RSAKey)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.security.interfaces 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.interfaces
的使用

使用 java.security.interfaces 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 使用的 java.security.interfaces 中的类
DSAKey
DSA 公用或专用密钥的接口。
DSAParams
特定于 DSA 的密钥参数集的接口，它定义 DSA 密钥系列。
ECKey
椭圆曲线 (EC) 密钥的接口。
RSAKey
RSA 公用密钥或专用密钥的接口。
RSAPrivateKey
RSA 专用密钥的接口。

java.security.spec 使用的 java.security.interfaces 中的类
DSAParams
特定于 DSA 的密钥参数集的接口，它定义 DSA 密钥系列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.DSAKeyPairGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAKeyPairGenerator
的使用

没有 java.security.interfaces.DSAKeyPairGenerator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.ECKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.ECKey
的使用

使用 ECKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 ECKey 的使用

java.security.interfaces 中 ECKey 的子接口
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.ECPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.ECPrivateKey
的使用

没有 java.security.interfaces.ECPrivateKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.ECPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.ECPublicKey
的使用

没有 java.security.interfaces.ECPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAMultiPrimePrivateCrtKey
的使用

没有 java.security.interfaces.RSAMultiPrimePrivateCrtKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.DSAPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAPrivateKey
的使用

没有 java.security.interfaces.DSAPrivateKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.DSAParams 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAParams
的使用

使用 DSAParams 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 DSAParams 的使用

返回 DSAParams 的 java.security.interfaces 中的方法
 DSAParams DSAKey.getParams()
返回特定于 DSA 的密钥参数。

参数类型为 DSAParams 的 java.security.interfaces 中的方法
 void DSAKeyPairGenerator.initialize(DSAParams params, SecureRandom random)
使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。

java.security.spec 中 DSAParams 的使用

实现 DSAParams 的 java.security.spec 中的类
 class DSAParameterSpec
此类指定用于 DSA 算法的参数的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.DSAPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAPublicKey
的使用

没有 java.security.interfaces.DSAPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.DSAKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.DSAKey
的使用

使用 DSAKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 DSAKey 的使用

java.security.interfaces 中 DSAKey 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | DSAPublicKey DSA 公用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.RSAPrivateCrtKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAPrivateCrtKey
的使用

没有 java.security.interfaces.RSAPrivateCrtKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.RSAPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAPrivateKey
的使用

使用 RSAPrivateKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 RSAPrivateKey 的使用

java.security.interfaces 中 RSAPrivateKey 的子接口
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.RSAPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAPublicKey
的使用

没有 java.security.interfaces.RSAPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.interfaces.RSAKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.interfaces.RSAKey
的使用

使用 RSAKey 的软件包
java.security.interfaces 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security.interfaces 中 RSAKey 的使用

java.security.interfaces 中 RSAKey 的子接口
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AlgorithmParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.spec
接口 AlgorithmParameterSpec

所有已知子接口：
C14NMethodParameterSpec, DigestMethodParameterSpec, SignatureMethodParameterSpec, TransformParameterSpec
所有已知实现类：
DHGenParameterSpec, DHParameterSpec, DSAParameterSpec, ECGenParameterSpec, ECParameterSpec, ExcC14NParameterSpec, HMACParameterSpec, IvParameterSpec, MGF1ParameterSpec, OAEPParameterSpec, PBEParameterSpec, PSSParameterSpec, RC2ParameterSpec, RC5ParameterSpec, RSAKeyGenParameterSpec, XPathFilter2ParameterSpec, XPathFilterParameterSpec, XSLTTransformParameterSpec
public interface AlgorithmParameterSpec

加密参数的（透明）规范。

此接口不包含任何方法或常量。它仅用于将所有参数规范分组，并为其提供类型安全。所有参数规范都必须实现此接口。

从以下版本开始：
1.2
另请参见：
AlgorithmParameters, DSAParameterSpec

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DSAParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 DSAParameterSpec

java.lang.Object
    继承者  java.security.spec.DSAParameterSpec
所有已实现的接口：
DSAParams, AlgorithmParameterSpec
public class DSAParameterSpec
extends Object
implements AlgorithmParameterSpec, DSAParams

此类指定用于 DSA 算法的参数的集合。

从以下版本开始：
1.2
另请参见：
AlgorithmParameterSpec

构造方法摘要
DSAParameterSpec(BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新的 DSAParameterSpec。
方法摘要
BigInteger | getG() 返回基数 g。
BigInteger | getP() 返回素数 p。
BigInteger | getQ() 返回子素数 q。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DSAParameterSpec

public DSAParameterSpec(BigInteger p,
                        BigInteger q,
                        BigInteger g)
创建一个具有指定参数值的新的 DSAParameterSpec。

参数：
p - 素数。
q - 子素数。
g - 基数。
方法详细信息

getP

public BigInteger getP()
返回素数 p。

指定者：
接口 DSAParams 中的 getP
返回：
素数 p。

getQ

public BigInteger getQ()
返回子素数 q。

指定者：
接口 DSAParams 中的 getQ
返回：
子素数 q。

getG

public BigInteger getG()
返回基数 g。

指定者：
接口 DSAParams 中的 getG
返回：
基数 g。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DSAPrivateKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 DSAPrivateKeySpec

java.lang.Object
    继承者  java.security.spec.DSAPrivateKeySpec
所有已实现的接口：
KeySpec
public class DSAPrivateKeySpec
extends Object
implements KeySpec

此类指定带关联参数的 DSA 专用密钥。

从以下版本开始：
1.2
另请参见：
Key, KeyFactory, KeySpec, DSAPublicKeySpec, PKCS8EncodedKeySpec

构造方法摘要
DSAPrivateKeySpec(BigInteger x, BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新 DSAPrivateKeySpec。
方法摘要
BigInteger | getG() 返回基数 g。
BigInteger | getP() 返回素数 p。
BigInteger | getQ() 返回子素数 q。
BigInteger | getX() 返回专用密钥 x。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DSAPrivateKeySpec

public DSAPrivateKeySpec(BigInteger x,
                         BigInteger p,
                         BigInteger q,
                         BigInteger g)
创建一个具有指定参数值的新 DSAPrivateKeySpec。

参数：
x - 专用密钥。
p - 素数。
q - 子素数。
g - 基数。
方法详细信息

getX

public BigInteger getX()
返回专用密钥 x。

返回：
专用密钥 x。

getP

public BigInteger getP()
返回素数 p。

返回：
素数 p。

getQ

public BigInteger getQ()
返回子素数 q。

返回：
子素数 q。

getG

public BigInteger getG()
返回基数 g。

返回：
基数 g。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DSAPublicKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 DSAPublicKeySpec

java.lang.Object
    继承者  java.security.spec.DSAPublicKeySpec
所有已实现的接口：
KeySpec
public class DSAPublicKeySpec
extends Object
implements KeySpec

此类指定带关联参数的 DSA 公用密钥。

从以下版本开始：
1.2
另请参见：
Key, KeyFactory, KeySpec, DSAPrivateKeySpec, X509EncodedKeySpec

构造方法摘要
DSAPublicKeySpec(BigInteger y, BigInteger p, BigInteger q, BigInteger g)
创建一个具有指定参数值的新 DSAPublicKeySpec。
方法摘要
BigInteger | getG() 返回基数 g。
BigInteger | getP() 返回素数 p。
BigInteger | getQ() 返回子素数 q。
BigInteger | getY() 返回公用密钥 y。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DSAPublicKeySpec

public DSAPublicKeySpec(BigInteger y,
                        BigInteger p,
                        BigInteger q,
                        BigInteger g)
创建一个具有指定参数值的新 DSAPublicKeySpec。

参数：
y - 公用键。
p - 素数。
q - 子素数。
g - 基数。
方法详细信息

getY

public BigInteger getY()
返回公用密钥 y。

返回：
公用密钥 y。

getP

public BigInteger getP()
返回素数 p。

返回：
素数 p。

getQ

public BigInteger getQ()
返回子素数 q。

返回：
子素数 q。

getG

public BigInteger getG()
返回基数 g。

返回：
基数 g。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
接口 ECField

所有已知实现类：
ECFieldF2m, ECFieldFp
public interface ECField

此接口表示椭圆曲线 (EC) 有限字段。所有专用的 EC 字段都必须实现此接口。

从以下版本开始：
1.5
另请参见：
ECFieldFp, ECFieldF2m

方法摘要
 int getFieldSize()
返回以比特为单位的字段大小。

方法详细信息

getFieldSize

int getFieldSize()
返回以比特为单位的字段大小。注：对于素数有限字段 ECFieldFp，返回以比特为单位的素数 p 的大小。对于首数为 2 的有限字段 ECFieldF2m，返回 m。

返回：
以比特为单位的字段大小。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECFieldF2m (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 ECFieldF2m

java.lang.Object
    继承者  java.security.spec.ECFieldF2m
所有已实现的接口：
ECField
public class ECFieldF2m
extends Object
implements ECField

此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。

从以下版本开始：
1.5
另请参见：
ECField

构造方法摘要
ECFieldF2m(int m)
使用常规方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldF2m(int m, BigInteger rp)
使用多项式方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
ECFieldF2m(int m, int[] ks)
使用多项式方法创建椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。
方法摘要
boolean | equals(Object obj) 比较此有限字段与指定对象的相等性。
int | getFieldSize() 返回以比特为单位的字段大小，对于此首数为 2 的有限字段，该字段大小为 m。
int | getM() 返回此首数为 2 的有限字段的值 m。
int[] | getMidTermsOfReductionPolynomial() 对于多项式方法，返回包含降序排列多项式的中间项顺序的整数数组，对于常规方法，返回 null。
BigInteger | getReductionPolynomial() 对于多项式方法，返回一个 BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数，对于常规方法，返回 null。
int | hashCode() 返回此首数为 2 的有限字段的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ECFieldF2m

public ECFieldF2m(int m)
使用常规方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。

参数：
m - 2^m 表示元素数。
抛出：
IllegalArgumentException - 如果 m 不是正数。

ECFieldF2m

public ECFieldF2m(int m,
                  BigInteger rp)
使用多项式方法创建一个椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。此字段的降序排列多项式基于 rp，其第 i 位对应于降序排列多项式的第 i 个系数。

注：一个有效的降序排列多项式或者是一个三项式（X^m + X^k + 1，其中 m > k >= 1），或者是一个五项式（X^m + X^k3 + X^k2 + X^k1 + 1，其中 m > k3 > k2 > k1 >= 1）。

参数：
m - 2^m 表示元素数。
rp - BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数。
抛出：
NullPointerException - 如果 rp 为 null。
IllegalArgumentException - 如果 m 不是正数，或者 rp 不表示一个有效的降序排列多项式。

ECFieldF2m

public ECFieldF2m(int m,
                  int[] ks)
使用多项式方法创建椭圆曲线首数为 2（具有 2^m 个元素）的有限字段。此字段的降序排列多项式基于 ks，其内容包含降序排列多项式的中间项的顺序。注：一个有效的降序排列多项式要么是一个三项式（X^m + X^k + 1，其中 m > k >= 1），要么是一个五项式（X^m + X^k3 + X^k2 + X^k1 + 1，其中 m > k3 > k2 > k1 >= 1），所以，ks 的长度应为 1 或 3。

参数：
m - 2^m 表示元素数。
ks - 降序排列多项式的中间项的顺序。复制此数组的内容，以防止随后进行修改。
抛出：
NullPointerException - 如果 ks 为 null。
IllegalArgumentException - 如果 m 不是正数，或者 ks 的长度既不是 1，也不是 3，或者 ks 中的值不在 m-1 和 1（包括）之间，并且不按降序排列。
方法详细信息

getFieldSize

public int getFieldSize()
返回以比特为单位的字段大小，对于此首数为 2 的有限字段，该字段大小为 m。

指定者：
接口 ECField 中的 getFieldSize
返回：
以比特为单位的字段大小。

getM

public int getM()
返回此首数为 2 的有限字段的值 m。

返回：
m 2^m 表示元素数。

getReductionPolynomial

public BigInteger getReductionPolynomial()
对于多项式方法，返回一个 BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数，对于常规方法，返回 null。

返回：
对于多项式方法，返回一个 BigInteger，其第 i 位对应于降序排列多项式的第 i 个系数，对于常规方法，返回 null。

getMidTermsOfReductionPolynomial

public int[] getMidTermsOfReductionPolynomial()
对于多项式方法，返回包含降序排列多项式的中间项顺序的整数数组，对于常规方法，返回 null。

返回：
对于多项式方法，返回包含降序排列多项式的中间项顺序的整数数组，对于常规方法，返回 null。每次调用此方法时，都返回一个新数组。

equals

public boolean equals(Object obj)
比较此有限字段与指定对象的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象。
返回：
如果 obj 是 ECFieldF2m 的一个实例，并且 m 和降序排列多项式匹配，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此首数为 2 的有限字段的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECFieldFp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 ECFieldFp

java.lang.Object
    继承者  java.security.spec.ECFieldFp
所有已实现的接口：
ECField
public class ECFieldFp
extends Object
implements ECField

此不可变类定义椭圆曲线 (EC) 素数的有限字段。

从以下版本开始：
1.5
另请参见：
ECField

构造方法摘要
ECFieldFp(BigInteger p)
根据指定的素数 p 创建一个椭圆曲线素数的有限字段。
方法摘要
boolean | equals(Object obj) 比较此素数有限字段与指定对象的相等性。
int | getFieldSize() 返回以比特为单位的字段大小，对于此素数有限字段，则为素数 p 的大小。
BigInteger | getP() 返回此素数有限字段的素数 p。
int | hashCode() 返回此素数有限字段的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ECFieldFp

public ECFieldFp(BigInteger p)
根据指定的素数 p 创建一个椭圆曲线素数的有限字段。

参数：
p - 素数。
抛出：
NullPointerException - 如果 p 为 null。
IllegalArgumentException - 如果 p 不是正数。
方法详细信息

getFieldSize

public int getFieldSize()
返回以比特为单位的字段大小，对于此素数有限字段，则为素数 p 的大小。

指定者：
接口 ECField 中的 getFieldSize
返回：
以比特为单位的字段大小。

getP

public BigInteger getP()
返回此素数有限字段的素数 p。

返回：
素数。

equals

public boolean equals(Object obj)
比较此素数有限字段与指定对象的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象。
返回：
如果 obj 是 ECFieldFp 的一个实例，并且素数值匹配，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此素数有限字段的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECGenParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 ECGenParameterSpec

java.lang.Object
    继承者  java.security.spec.ECGenParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class ECGenParameterSpec
extends Object
implements AlgorithmParameterSpec

此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。

从以下版本开始：
1.5
另请参见：
AlgorithmParameterSpec

构造方法摘要
ECGenParameterSpec(String stdName)
使用标准的（或预定义的）名称 stdName 创建用于 EC 参数生成的参数规范，以便生成相应的（预计算的）椭圆曲线域参数。
方法摘要
 String getName()
返回要生成的 EC 域参数的标准名称或预定义名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ECGenParameterSpec

public ECGenParameterSpec(String stdName)
使用标准的（或预定义的）名称 stdName 创建用于 EC 参数生成的参数规范，以便生成相应的（预计算的）椭圆曲线域参数。有关受支持的名称列表，请参考将使用其实现的供应商的文档。

参数：
stdName - 要生成的 EC 域参数的标准名称。
抛出：
NullPointerException - 如果 stdName 为 null。
方法详细信息

getName

public String getName()
返回要生成的 EC 域参数的标准名称或预定义名称。

返回：
标准名称或预定义名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 ECParameterSpec

java.lang.Object
    继承者  java.security.spec.ECParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class ECParameterSpec
extends Object
implements AlgorithmParameterSpec

此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。

从以下版本开始：
1.5
另请参见：
AlgorithmParameterSpec

构造方法摘要
ECParameterSpec(EllipticCurve curve, ECPoint g, BigInteger n, int h)
创建基于指定值的椭圆曲线域参数。
方法摘要
int | getCofactor() 返回余因子。
EllipticCurve | getCurve() 返回此参数定义的椭圆曲线。
ECPoint | getGenerator() 返回也称为基点的生成器。
BigInteger | getOrder() 返回生成器的顺序。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ECParameterSpec

public ECParameterSpec(EllipticCurve curve,
                       ECPoint g,
                       BigInteger n,
                       int h)
创建基于指定值的椭圆曲线域参数。

参数：
curve - 此参数定义的椭圆曲线。
g - 生成器，也称为基点。
n - 生成器 g 的顺序。
h - 余因子。
抛出：
NullPointerException - 如果 curve、g 或 n 为 null。
IllegalArgumentException - 如果 n 或 h 不是正数。
方法详细信息

getCurve

public EllipticCurve getCurve()
返回此参数定义的椭圆曲线。

返回：
此参数定义的椭圆曲线。

getGenerator

public ECPoint getGenerator()
返回也称为基点的生成器。

返回：
也称为基点的生成器。

getOrder

public BigInteger getOrder()
返回生成器的顺序。

返回：
生成器的顺序。

getCofactor

public int getCofactor()
返回余因子。

返回：
余因子。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECPoint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 ECPoint

java.lang.Object
    继承者  java.security.spec.ECPoint

public class ECPoint
extends Object

此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。其他坐标系可以扩展此类，以便在其他坐标中表示此点。

从以下版本开始：
1.5

字段摘要
static ECPoint POINT_INFINITY
这就将该点定义为无穷大。
构造方法摘要
ECPoint(BigInteger x, BigInteger y)
根据指定的仿射 x 坐标 x 和仿射 y 坐标 y 创建 ECPoint。
方法摘要
boolean | equals(Object obj) 比较此椭圆曲线点与指定对象的相等性。
BigInteger | getAffineX() 返回仿射 x 坐标 x。
BigInteger | getAffineY() 返回仿射 y 坐标 y。
int | hashCode() 返回此椭圆曲线点的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

POINT_INFINITY

public static final ECPoint POINT_INFINITY
这就将该点定义为无穷大。

构造方法详细信息

ECPoint

public ECPoint(BigInteger x,
               BigInteger y)
根据指定的仿射 x 坐标 x 和仿射 y 坐标 y 创建 ECPoint。

参数：
x - 仿射 x 坐标。
y - 仿射 y 坐标。
抛出：
NullPointerException - 如果 x 或 y 为 null。
方法详细信息

getAffineX

public BigInteger getAffineX()
返回仿射 x 坐标 x。注：POINT_INFINITY 的仿射 x 坐标为 null。

返回：
仿射 x 坐标。

getAffineY

public BigInteger getAffineY()
返回仿射 y 坐标 y。注：POINT_INFINITY 的仿射 y 坐标为 null 。

返回：
仿射 y 坐标。

equals

public boolean equals(Object obj)
比较此椭圆曲线点与指定对象的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象。
返回：
如果 obj 是 ECPoint 的一个实例，并且仿射坐标相匹配，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此椭圆曲线点的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECPrivateKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 ECPrivateKeySpec

java.lang.Object
    继承者  java.security.spec.ECPrivateKeySpec
所有已实现的接口：
KeySpec
public class ECPrivateKeySpec
extends Object
implements KeySpec

此不可变类指定带关联参数的椭圆曲线专用密钥。

从以下版本开始：
1.5
另请参见：
KeySpec, ECParameterSpec

构造方法摘要
ECPrivateKeySpec(BigInteger s, ECParameterSpec params)
使用指定的参数值创建一个新的 ECPrivateKeySpec。
方法摘要
ECParameterSpec | getParams() 返回关联的椭圆曲线域参数。
BigInteger | getS() 返回专用值 S。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ECPrivateKeySpec

public ECPrivateKeySpec(BigInteger s,
                        ECParameterSpec params)
使用指定的参数值创建一个新的 ECPrivateKeySpec。

参数：
s - 专用值。
params - 关联的椭圆曲线域参数。
抛出：
NullPointerException - 如果 s 或 params 为 null。
方法详细信息

getS

public BigInteger getS()
返回专用值 S。

返回：
专用值 S。

getParams

public ECParameterSpec getParams()
返回关联的椭圆曲线域参数。

返回：
EC 域参数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ECPublicKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 ECPublicKeySpec

java.lang.Object
    继承者  java.security.spec.ECPublicKeySpec
所有已实现的接口：
KeySpec
public class ECPublicKeySpec
extends Object
implements KeySpec

此不可变类指定带关联参数的椭圆曲线公用密钥。

从以下版本开始：
1.5
另请参见：
KeySpec, ECPoint, ECParameterSpec

构造方法摘要
ECPublicKeySpec(ECPoint w, ECParameterSpec params)
根据指定参数值，创建一个新的 ECPublicKeySpec。
方法摘要
ECParameterSpec | getParams() 返回关联的椭圆曲线域参数。
ECPoint | getW() 返回公用点 W。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ECPublicKeySpec

public ECPublicKeySpec(ECPoint w,
                       ECParameterSpec params)
根据指定参数值，创建一个新的 ECPublicKeySpec。

参数：
w - 公用点。
params - 关联的椭圆曲线域参数。
抛出：
NullPointerException - 如果 w 或 params 为 null。
IllegalArgumentException - 如果 w 是无穷大的点，即：ECPoint.POINT_INFINITY
方法详细信息

getW

public ECPoint getW()
返回公用点 W。

返回：
公用点 W。

getParams

public ECParameterSpec getParams()
返回关联的椭圆曲线域参数。

返回：
EC 域参数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EllipticCurve (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 EllipticCurve

java.lang.Object
    继承者  java.security.spec.EllipticCurve

public class EllipticCurve
extends Object

此不可变类持有表示椭圆曲线所必需的值。

从以下版本开始：
1.5
另请参见：
ECField, ECFieldFp, ECFieldF2m

构造方法摘要
EllipticCurve(ECField field, BigInteger a, BigInteger b)
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。
EllipticCurve(ECField field, BigInteger a, BigInteger b, byte[] seed)
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。
方法摘要
boolean | equals(Object obj) 比较此椭圆曲线与指定对象的相等性。
BigInteger | getA() 返回椭圆曲线的第一个系数 a。
BigInteger | getB() 返回椭圆曲线的第二个系数 b。
ECField | getField() 返回此椭圆曲线结束的有限字段 field。
byte[] | getSeed() 返回曲线生成期间所使用的种子字节 seed。
int | hashCode() 返回此椭圆曲线的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EllipticCurve

public EllipticCurve(ECField field,
                     BigInteger a,
                     BigInteger b)
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。

参数：
field - 此椭圆曲线结束的有限字段。
a - 此椭圆曲线的第一个系数。
b - 此椭圆曲线的第二个系数。
抛出：
NullPointerException - 如果 field、a 或 b 为 null。
IllegalArgumentException - 如果 a 或 b 不为 null，并且不在 field 中。

EllipticCurve

public EllipticCurve(ECField field,
                     BigInteger a,
                     BigInteger b,
                     byte[] seed)
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。

参数：
field - 此椭圆曲线结束的有限字段。
a - 此椭圆曲线的第一个系数。
b - 此椭圆曲线的第二个系数。
seed - 曲线生成期间使用的字节，用于以后验证。复制此数组的内容，以防止随后进行修改。
抛出：
NullPointerException - 如果 field、a 或 b 为 null。
IllegalArgumentException - 如果 a 或 b 不为 null，并且不在 field 中。
方法详细信息

getField

public ECField getField()
返回此椭圆曲线结束的有限字段 field。

返回：
此曲线结束的字段 field。

getA

public BigInteger getA()
返回椭圆曲线的第一个系数 a。

返回：
第一个系数 a。

getB

public BigInteger getB()
返回椭圆曲线的第二个系数 b。

返回：
第二个系数 b。

getSeed

public byte[] getSeed()
返回曲线生成期间所使用的种子字节 seed。如果没有指定，则可以为 null。

返回：
种子字节 seed。每次调用此方法时，都返回一个新数组。

equals

public boolean equals(Object obj)
比较此椭圆曲线与指定对象的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象。
返回：
如果 obj 是 EllipticCurve 的一个实例，并且字段 A、B 和种子字节匹配，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此椭圆曲线的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EncodedKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 EncodedKeySpec

java.lang.Object
    继承者  java.security.spec.EncodedKeySpec
所有已实现的接口：
KeySpec
直接已知子类：
PKCS8EncodedKeySpec, X509EncodedKeySpec
public abstract class EncodedKeySpec
extends Object
implements KeySpec

此类用编码格式表示公用密钥或专用密钥。

从以下版本开始：
1.2
另请参见：
Key, KeyFactory, KeySpec, X509EncodedKeySpec, PKCS8EncodedKeySpec

构造方法摘要
EncodedKeySpec(byte[] encodedKey)
根据给定的编码密钥创建一个新的 EncodedKeySpec。
方法摘要
byte[] | getEncoded() 返回编码密钥。
abstract String | getFormat() 返回与此密钥规范关联的编码格式的名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EncodedKeySpec

public EncodedKeySpec(byte[] encodedKey)
根据给定的编码密钥创建一个新的 EncodedKeySpec。

参数：
encodedKey - 编码密钥。复制数组的内容，以防随后进行修改。
抛出：
NullPointerException - 如果 encodedKey 为 null。
方法详细信息

getEncoded

public byte[] getEncoded()
返回编码密钥。

返回：
编码密钥。每次调用此方法时，都返回一个新数组。

getFormat

public abstract String getFormat()
返回与此密钥规范关联的编码格式的名称。

如果可以将密钥的不透明表示形式（请参见 Key）转换（请参见 KeyFactory）为此密钥的规范（或它的子类），则对不透明密钥调用 getFormat 方法会返回与此密钥规范的 getFormat 方法相同的值。

返回：
该编码格式的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidKeySpecException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 InvalidKeySpecException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.spec.InvalidKeySpecException
所有已实现的接口：
Serializable
public class InvalidKeySpecException
extends GeneralSecurityException

这是针对无效密钥规范的异常。

从以下版本开始：
1.2
另请参见：
KeySpec, 序列化表格

构造方法摘要
InvalidKeySpecException()
构造不带详细消息的 InvalidKeySpecException。
InvalidKeySpecException(String msg)
构造带指定详细消息的 InvalidKeySpecException。
InvalidKeySpecException(String message, Throwable cause)
创建带指定的详细消息和 cause 的 InvalidKeySpecException。
InvalidKeySpecException(Throwable cause)
创建带指定的 cause 和详细消息 (cause==null ? null : cause.toString()) 的 InvalidKeySpecException（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidKeySpecException

public InvalidKeySpecException()
构造不带详细消息的 InvalidKeySpecException。详细消息是描述此特定异常的字符串。

InvalidKeySpecException

public InvalidKeySpecException(String msg)
构造带指定详细消息的 InvalidKeySpecException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。

InvalidKeySpecException

public InvalidKeySpecException(String message,
                               Throwable cause)
创建带指定的详细消息和 cause 的 InvalidKeySpecException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5

InvalidKeySpecException

public InvalidKeySpecException(Throwable cause)
创建带指定的 cause 和详细消息 (cause==null ? null : cause.toString()) 的 InvalidKeySpecException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许使用 null 值，指示 cause 是不存在的或未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
接口 KeySpec

所有已知实现类：
DESedeKeySpec, DESKeySpec, DHPrivateKeySpec, DHPublicKeySpec, DSAPrivateKeySpec, DSAPublicKeySpec, ECPrivateKeySpec, ECPublicKeySpec, EncodedKeySpec, PBEKeySpec, PKCS8EncodedKeySpec, RSAMultiPrimePrivateCrtKeySpec, RSAPrivateCrtKeySpec, RSAPrivateKeySpec, RSAPublicKeySpec, SecretKeySpec, X509EncodedKeySpec
public interface KeySpec

组成加密密钥的密钥内容的（透明）规范。

如果密钥存储在硬件设备上，则其规范可以包含有助于标识该设备上的密钥的信息。

用特定于算法的方法或独立于算法的编码格式（例如，ASN.1）可以指定密钥。例如，DSA 专用密钥可以由其组件 x、p、q 和 g 指定（请参见 DSAPrivateKeySpec），或使用其 DER 编码指定（请参见 PKCS8EncodedKeySpec）。

此接口不包含任何方法或常量。它仅用于将所有密钥规范分组，并为其提供类型安全。所有密钥规范都必须实现此接口。

从以下版本开始：
1.2
另请参见：
Key, KeyFactory, EncodedKeySpec, X509EncodedKeySpec, PKCS8EncodedKeySpec, DSAPrivateKeySpec, DSAPublicKeySpec

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidParameterSpecException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 InvalidParameterSpecException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  java.security.spec.InvalidParameterSpecException
所有已实现的接口：
Serializable
public class InvalidParameterSpecException
extends GeneralSecurityException

这是针对无效参数规范的异常。

从以下版本开始：
1.2
另请参见：
AlgorithmParameters, AlgorithmParameterSpec, DSAParameterSpec, 序列化表格

构造方法摘要
InvalidParameterSpecException()
构造不带详细消息的 InvalidParameterSpecException。
InvalidParameterSpecException(String msg)
构造带指定详细消息的 InvalidParameterSpecException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidParameterSpecException

public InvalidParameterSpecException()
构造不带详细消息的 InvalidParameterSpecException。详细消息是描述此特定异常的字符串。

InvalidParameterSpecException

public InvalidParameterSpecException(String msg)
构造带指定详细消息的 InvalidParameterSpecException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MGF1ParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 MGF1ParameterSpec

java.lang.Object
    继承者  java.security.spec.MGF1ParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class MGF1ParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。

它在 PKCS#1 标准中的 ASN.1 定义描述如下：

 MGF1Parameters ::= OAEP-PSSDigestAlgorthms
其中
 OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }

从以下版本开始：
1.5
另请参见：
PSSParameterSpec, OAEPParameterSpec

字段摘要
static MGF1ParameterSpec | SHA1 使用“SHA-1”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | SHA256 使用“SHA-256”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | SHA384 使用“SHA-384”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | SHA512 使用 SHA-512 消息摘要的 MGF1ParameterSpec。
构造方法摘要
MGF1ParameterSpec(String mdName)
构造如 PKCS #1 标准中所定义的掩码生成函数 MGF1 的参数集。
方法摘要
 String getDigestAlgorithm()
返回掩码生成函数使用的消息摘要的算法名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SHA1

public static final MGF1ParameterSpec SHA1
使用“SHA-1”消息摘要的 MGF1ParameterSpec。

SHA256

public static final MGF1ParameterSpec SHA256
使用“SHA-256”消息摘要的 MGF1ParameterSpec。

SHA384

public static final MGF1ParameterSpec SHA384
使用“SHA-384”消息摘要的 MGF1ParameterSpec。

SHA512

public static final MGF1ParameterSpec SHA512
使用 SHA-512 消息摘要的 MGF1ParameterSpec。

构造方法详细信息

MGF1ParameterSpec

public MGF1ParameterSpec(String mdName)
构造如 PKCS #1 标准中所定义的掩码生成函数 MGF1 的参数集。

参数：
mdName - 此掩码生成函数 MGF1 中使用的消息摘要的算法名称。
抛出：
NullPointerException - 如果 mdName 为 null。
方法详细信息

getDigestAlgorithm

public String getDigestAlgorithm()
返回掩码生成函数使用的消息摘要的算法名称。

返回：
消息摘要的算法名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PKCS8EncodedKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 PKCS8EncodedKeySpec

java.lang.Object
    继承者  java.security.spec.EncodedKeySpec
        继承者  java.security.spec.PKCS8EncodedKeySpec
所有已实现的接口：
KeySpec
public class PKCS8EncodedKeySpec
extends EncodedKeySpec

此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。PKCS#8 中定义的 PrivateKeyInfo 语法如下：

 PrivateKeyInfo ::= SEQUENCE {
   version Version,
   privateKeyAlgorithm PrivateKeyAlgorithmIdentifier,
   privateKey PrivateKey,
   attributes [0] IMPLICIT Attributes OPTIONAL }

 Version ::= INTEGER

 PrivateKeyAlgorithmIdentifier ::= AlgorithmIdentifier

 PrivateKey ::= OCTET STRING

 Attributes ::= SET OF Attribute

从以下版本开始：
1.2
另请参见：
Key, KeyFactory, KeySpec, EncodedKeySpec, X509EncodedKeySpec

构造方法摘要
PKCS8EncodedKeySpec(byte[] encodedKey)
根据给定的编码密钥创建一个新的 PKCS8EncodedKeySpec。
方法摘要
byte[] | getEncoded() 返回按照 PKCS #8 标准编码的密钥字节。
String | getFormat() 返回与此密钥规范关联的编码格式的名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PKCS8EncodedKeySpec

public PKCS8EncodedKeySpec(byte[] encodedKey)
根据给定的编码密钥创建一个新的 PKCS8EncodedKeySpec。

参数：
encodedKey - 假设按照 PKCS #8 标准对其进行编码的密钥。复制数组的内容，以防随后的修改。
抛出：
NullPointerException - 如果 encodedKey 为 null。
方法详细信息

getEncoded

public byte[] getEncoded()
返回按照 PKCS #8 标准编码的密钥字节。

覆盖：
类 EncodedKeySpec 中的 getEncoded
返回：
密钥的 PKCS #8 编码。每次调用此方法时，都返回一个新数组。

getFormat

public final String getFormat()
返回与此密钥规范关联的编码格式的名称。

指定者：
类 EncodedKeySpec 中的 getFormat
返回：
字符串 "PKCS#8"。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PSSParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 PSSParameterSpec

java.lang.Object
    继承者  java.security.spec.PSSParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class PSSParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。

它在 PKCS#1 标准中的 ASN.1 定义描述如下：

 RSASSA-PSS-params ::= SEQUENCE {
   hashAlgorithm      [0] OAEP-PSSDigestAlgorithms  DEFAULT sha1,
   maskGenAlgorithm   [1] PKCS1MGFAlgorithms  DEFAULT mgf1SHA1,
   saltLength         [2] INTEGER  DEFAULT 20,
   trailerField       [3] INTEGER  DEFAULT 1
 }
其中
 OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }

 PKCS1MGFAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-mgf1 PARAMETERS OAEP-PSSDigestAlgorithms },
   ...  -- Allows for future expansion --
 }

注：PSSParameterSpec.DEFAULT 使用：消息摘要 --“SHA-1”掩码生成函数 (mgf) --mgf 的“MGF1”参数 -- MGF1ParameterSpec.SHA1 SaltLength -- 20 TrailerField -- 1

从以下版本开始：
1.4
另请参见：
MGF1ParameterSpec, AlgorithmParameterSpec, Signature

字段摘要
static PSSParameterSpec DEFAULT
带所有默认值的 PSS 参数集合。
构造方法摘要
PSSParameterSpec(int saltLen)
使用指定的 salt 长度和 PKCS#1 定义的其他默认值创建一个新的 PSSParameterSpec。
PSSParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。
方法摘要
String | getDigestAlgorithm() 返回消息摘要算法名称。
String | getMGFAlgorithm() 返回掩码生成函数算法名称。
AlgorithmParameterSpec | getMGFParameters() 返回掩码生成函数的参数。
int | getSaltLength() 返回 salt 长度（以比特为单位）。
int | getTrailerField() 返回尾部字段的值，即：PKCS#1 v2.1 中的 bc。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT

public static final PSSParameterSpec DEFAULT
带所有默认值的 PSS 参数集合。

从以下版本开始：
1.5
构造方法详细信息

PSSParameterSpec

public PSSParameterSpec(String mdName,
                        String mgfName,
                        AlgorithmParameterSpec mgfSpec,
                        int saltLen,
                        int trailerField)
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。

参数：
mdName - 哈希函数的算法名称。
mgfName - 掩码生成函数的算法名称。
mgfSpec - 掩码生成函数的参数。如果指定 null，则 getMGFParameters() 将返回 null。
saltLen - salt 的长度。
trailerField - 尾部字段的值。
抛出：
NullPointerException - 如果 mdName 或 mgfName 为 null。
IllegalArgumentException - 如果 saltLen 或 trailerField 小于 0。
从以下版本开始：
1.5

PSSParameterSpec

public PSSParameterSpec(int saltLen)
使用指定的 salt 长度和 PKCS#1 定义的其他默认值创建一个新的 PSSParameterSpec。

参数：
saltLen - 用于 PKCS#1 PSS 编码的 salt 长度（以比特为单位）。
抛出：
IllegalArgumentException - 如果 saltLen 小于 0。
方法详细信息

getDigestAlgorithm

public String getDigestAlgorithm()
返回消息摘要算法名称。

返回：
消息摘要算法名称。
从以下版本开始：
1.5

getMGFAlgorithm

public String getMGFAlgorithm()
返回掩码生成函数算法名称。

返回：
掩码生成函数算法名称。
从以下版本开始：
1.5

getMGFParameters

public AlgorithmParameterSpec getMGFParameters()
返回掩码生成函数的参数。

返回：
掩码生成函数的参数。
从以下版本开始：
1.5

getSaltLength

public int getSaltLength()
返回 salt 长度（以比特为单位）。

返回：
salt 长度。

getTrailerField

public int getTrailerField()
返回尾部字段的值，即：PKCS#1 v2.1 中的 bc。

返回：
尾部字段的值，即：PKCS#1 v2.1 中的 bc。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAKeyGenParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 RSAKeyGenParameterSpec

java.lang.Object
    继承者  java.security.spec.RSAKeyGenParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class RSAKeyGenParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定用于生成 RSA 密钥对的参数集。

从以下版本开始：
1.3
另请参见：
KeyPairGenerator.initialize(java.security.spec.AlgorithmParameterSpec)

字段摘要
static BigInteger | F0 公用指数值 F0 = 3。
static BigInteger | F4 公用指数值 F4 = 65537。
构造方法摘要
RSAKeyGenParameterSpec(int keysize, BigInteger publicExponent)
构造一个具有给定密钥大小和公用指数值的新的 RSAParameterSpec 对象。
方法摘要
int | getKeysize() 返回密钥大小。
BigInteger | getPublicExponent() 返回公用指数值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

F0

public static final BigInteger F0
公用指数值 F0 = 3。

F4

public static final BigInteger F4
公用指数值 F4 = 65537。

构造方法详细信息

RSAKeyGenParameterSpec

public RSAKeyGenParameterSpec(int keysize,
                              BigInteger publicExponent)
构造一个具有给定密钥大小和公用指数值的新的 RSAParameterSpec 对象。

参数：
keysize - 系数大小（用位数指定）
publicExponent - 公用指数
方法详细信息

getKeysize

public int getKeysize()
返回密钥大小。

返回：
密钥大小。

getPublicExponent

public BigInteger getPublicExponent()
返回公用指数值。

返回：
公用指数值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAMultiPrimePrivateCrtKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 RSAMultiPrimePrivateCrtKeySpec

java.lang.Object
    继承者  java.security.spec.RSAPrivateKeySpec
        继承者  java.security.spec.RSAMultiPrimePrivateCrtKeySpec
所有已实现的接口：
KeySpec
public class RSAMultiPrimePrivateCrtKeySpec
extends RSAPrivateKeySpec

如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。

从以下版本开始：
1.4
另请参见：
Key, KeyFactory, KeySpec, PKCS8EncodedKeySpec, RSAPrivateKeySpec, RSAPublicKeySpec, RSAOtherPrimeInfo

构造方法摘要
RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。
方法摘要
BigInteger | getCrtCoefficient() 返回 crtCoefficient。
RSAOtherPrimeInfo[] | getOtherPrimeInfo() 返回 otherPrimeInfo 的副本，如果仅有两个素数因子（p 和 q），则返回 null。
BigInteger | getPrimeExponentP() 返回 primeExponentP。
BigInteger | getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | getPrimeP() 返回 primeP。
BigInteger | getPrimeQ() 返回 primeQ。
BigInteger | getPublicExponent() 返回公用指数。
从类 java.security.spec.RSAPrivateKeySpec 继承的方法
getModulus, getPrivateExponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RSAMultiPrimePrivateCrtKeySpec

public RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus,
                                      BigInteger publicExponent,
                                      BigInteger privateExponent,
                                      BigInteger primeP,
                                      BigInteger primeQ,
                                      BigInteger primeExponentP,
                                      BigInteger primeExponentQ,
                                      BigInteger crtCoefficient,
                                      RSAOtherPrimeInfo[] otherPrimeInfo)
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。

注意，要复制 otherPrimeInfo 的内容，以防止以后在构造此对象时发生修改。

参数：
modulus - 系数 n。
publicExponent - 公用指数 e。
privateExponent - 专用指数 d。
primeP - n 的素数因子 p。
primeQ - n 的素数因子 q。
primeExponentP - 这是 d mod (p-1)。
primeExponentQ - 这是 d mod (q-1)。
crtCoefficient - Chinese Remainder Theorem 系数 q-1 除以 p 所得的余数。
otherPrimeInfo - 其余素数的三元组，如果仅有两个素数因子（p 和 q），则可以指定 null。
抛出：
NullPointerException - 如果任一参数（即：modulus、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ 和 crtCoefficient）为 null。
IllegalArgumentException - 如果为空（即：长度为 0），则指定 otherPrimeInfo。
方法详细信息

getPublicExponent

public BigInteger getPublicExponent()
返回公用指数。

返回：
该公用指数。

getPrimeP

public BigInteger getPrimeP()
返回 primeP。

返回：
primeP。

getPrimeQ

public BigInteger getPrimeQ()
返回 primeQ。

返回：
primeQ。

getPrimeExponentP

public BigInteger getPrimeExponentP()
返回 primeExponentP。

返回：
primeExponentP。

getPrimeExponentQ

public BigInteger getPrimeExponentQ()
返回 primeExponentQ。

返回：
primeExponentQ。

getCrtCoefficient

public BigInteger getCrtCoefficient()
返回 crtCoefficient。

返回：
crtCoefficient。

getOtherPrimeInfo

public RSAOtherPrimeInfo[] getOtherPrimeInfo()
返回 otherPrimeInfo 的副本，如果仅有两个素数因子（p 和 q），则返回 null。

返回：
otherPrimeInfo。每次调用此方法时，都返回一个新数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAOtherPrimeInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 RSAOtherPrimeInfo

java.lang.Object
    继承者  java.security.spec.RSAOtherPrimeInfo

public class RSAOtherPrimeInfo
extends Object

此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。RSA 的 OtherPrimeInfo 的 ASN.1 语法如下：

 OtherPrimeInfo ::= SEQUENCE {
   prime INTEGER,
   exponent INTEGER,
   coefficient INTEGER
   }

从以下版本开始：
1.4
另请参见：
RSAPrivateCrtKeySpec, RSAMultiPrimePrivateCrtKey

构造方法摘要
RSAOtherPrimeInfo(BigInteger prime, BigInteger primeExponent, BigInteger crtCoefficient)
给定如 PKCS#1 中所定义的素数、primeExponent 和 crtCoefficient，创建一个新的 RSAOtherPrimeInfo。
方法摘要
BigInteger | getCrtCoefficient() 返回素数的 crtCoefficient。
BigInteger | getExponent() 返回素数的指数。
BigInteger | getPrime() 返回素数。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RSAOtherPrimeInfo

public RSAOtherPrimeInfo(BigInteger prime,
                         BigInteger primeExponent,
                         BigInteger crtCoefficient)
给定如 PKCS#1 中所定义的素数、primeExponent 和 crtCoefficient，创建一个新的 RSAOtherPrimeInfo。

参数：
prime - n 的素数因子。
primeExponent - 指数。
crtCoefficient - Chinese Remainder Theorem 系数。
抛出：
NullPointerException - 如果任一参数（即：prime、primeExponent 和 crtCoefficient）为 null。
方法详细信息

getPrime

public final BigInteger getPrime()
返回素数。

返回：
素数。

getExponent

public final BigInteger getExponent()
返回素数的指数。

返回：
primeExponent。

getCrtCoefficient

public final BigInteger getCrtCoefficient()
返回素数的 crtCoefficient。

返回：
crtCoefficient。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAPrivateCrtKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 RSAPrivateCrtKeySpec

java.lang.Object
    继承者  java.security.spec.RSAPrivateKeySpec
        继承者  java.security.spec.RSAPrivateCrtKeySpec
所有已实现的接口：
KeySpec
public class RSAPrivateCrtKeySpec
extends RSAPrivateKeySpec

为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。

另请参见：
Key, KeyFactory, KeySpec, PKCS8EncodedKeySpec, RSAPrivateKeySpec, RSAPublicKeySpec

构造方法摘要
RSAPrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient)
给定在 PKCS#1 v2.1 中所定义的系数、publicExponent、privateExponent、 primeP、primeQ、primeExponentP、primeExponentQ 和 crtCoefficient，创建一个新的 RSAPrivateCrtKeySpec。
方法摘要
BigInteger | getCrtCoefficient() 返回 crtCoefficient。
BigInteger | getPrimeExponentP() 返回 primeExponentP。
BigInteger | getPrimeExponentQ() 返回 primeExponentQ。
BigInteger | getPrimeP() 返回 primeP。
BigInteger | getPrimeQ() 返回 primeQ。
BigInteger | getPublicExponent() 返回公用指数。
从类 java.security.spec.RSAPrivateKeySpec 继承的方法
getModulus, getPrivateExponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RSAPrivateCrtKeySpec

public RSAPrivateCrtKeySpec(BigInteger modulus,
                            BigInteger publicExponent,
                            BigInteger privateExponent,
                            BigInteger primeP,
                            BigInteger primeQ,
                            BigInteger primeExponentP,
                            BigInteger primeExponentQ,
                            BigInteger crtCoefficient)
给定在 PKCS#1 v2.1 中所定义的系数、publicExponent、privateExponent、 primeP、primeQ、primeExponentP、primeExponentQ 和 crtCoefficient，创建一个新的 RSAPrivateCrtKeySpec。

参数：
modulus - 系数 n
publicExponent - 公用指数 e
privateExponent - 专用指数 d
primeP - n 的素数因子 p
primeQ - n 的素数因子 q
primeExponentP - 这是 d 除以 (p-1) 所得的余数
primeExponentQ - 这是 d 除以 (q-1) 所得的余数
crtCoefficient - Chinese Remainder Theorem 系数 q-1 除以 p 所得的余数
方法详细信息

getPublicExponent

public BigInteger getPublicExponent()
返回公用指数。

返回：
该公用指数

getPrimeP

public BigInteger getPrimeP()
返回 primeP。

返回：
primeP

getPrimeQ

public BigInteger getPrimeQ()
返回 primeQ。

返回：
primeQ

getPrimeExponentP

public BigInteger getPrimeExponentP()
返回 primeExponentP。

返回：
primeExponentP

getPrimeExponentQ

public BigInteger getPrimeExponentQ()
返回 primeExponentQ。

返回：
primeExponentQ

getCrtCoefficient

public BigInteger getCrtCoefficient()
返回 crtCoefficient。

返回：
crtCoefficient
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAPrivateKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 RSAPrivateKeySpec

java.lang.Object
    继承者  java.security.spec.RSAPrivateKeySpec
所有已实现的接口：
KeySpec
直接已知子类：
RSAMultiPrimePrivateCrtKeySpec, RSAPrivateCrtKeySpec
public class RSAPrivateKeySpec
extends Object
implements KeySpec

此类指定 RSA 专用密钥。

另请参见：
Key, KeyFactory, KeySpec, PKCS8EncodedKeySpec, RSAPublicKeySpec, RSAPrivateCrtKeySpec

构造方法摘要
RSAPrivateKeySpec(BigInteger modulus, BigInteger privateExponent)
创建一个新的 RSAPrivateKeySpec。
方法摘要
BigInteger | getModulus() 返回系数。
BigInteger | getPrivateExponent() 返回专用指数。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RSAPrivateKeySpec

public RSAPrivateKeySpec(BigInteger modulus,
                         BigInteger privateExponent)
创建一个新的 RSAPrivateKeySpec。

参数：
modulus - 系数
privateExponent - 专用指数
方法详细信息

getModulus

public BigInteger getModulus()
返回系数。

返回：
系数

getPrivateExponent

public BigInteger getPrivateExponent()
返回专用指数。

返回：
该专用指数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RSAPublicKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 RSAPublicKeySpec

java.lang.Object
    继承者  java.security.spec.RSAPublicKeySpec
所有已实现的接口：
KeySpec
public class RSAPublicKeySpec
extends Object
implements KeySpec

此类指定 RSA 公用密钥。

另请参见：
Key, KeyFactory, KeySpec, X509EncodedKeySpec, RSAPrivateKeySpec, RSAPrivateCrtKeySpec

构造方法摘要
RSAPublicKeySpec(BigInteger modulus, BigInteger publicExponent)
创建一个新的 RSAPublicKeySpec。
方法摘要
BigInteger | getModulus() 返回该系数。
BigInteger | getPublicExponent() 返回该公用指数。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RSAPublicKeySpec

public RSAPublicKeySpec(BigInteger modulus,
                        BigInteger publicExponent)
创建一个新的 RSAPublicKeySpec。

参数：
modulus - 系数
publicExponent - 公用指数
方法详细信息

getModulus

public BigInteger getModulus()
返回该系数。

返回：
该系数

getPublicExponent

public BigInteger getPublicExponent()
返回该公用指数。

返回：
该公用指数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509EncodedKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.security.spec
类 X509EncodedKeySpec

java.lang.Object
    继承者  java.security.spec.EncodedKeySpec
        继承者  java.security.spec.X509EncodedKeySpec
所有已实现的接口：
KeySpec
public class X509EncodedKeySpec
extends EncodedKeySpec

此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。X.509 标准中定义的 SubjectPublicKeyInfo 语法如下：

 SubjectPublicKeyInfo ::= SEQUENCE {
   algorithm AlgorithmIdentifier,
   subjectPublicKey BIT STRING }

从以下版本开始：
1.2
另请参见：
Key, KeyFactory, KeySpec, EncodedKeySpec, PKCS8EncodedKeySpec

构造方法摘要
X509EncodedKeySpec(byte[] encodedKey)
根据给定的编码密钥创建一个新的 X509EncodedKeySpec。
方法摘要
byte[] | getEncoded() 返回按照 X.509 标准进行编码的密钥的字节。
String | getFormat() 返回与此密钥规范关联的编码格式的名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

X509EncodedKeySpec

public X509EncodedKeySpec(byte[] encodedKey)
根据给定的编码密钥创建一个新的 X509EncodedKeySpec。

参数：
encodedKey - 假设按照 X.509 标准对其进行编码的密钥。复制数组的内容，以防随后进行修改。
抛出：
NullPointerException - 如果 encodedKey 为 null。
方法详细信息

getEncoded

public byte[] getEncoded()
返回按照 X.509 标准进行编码的密钥的字节。

覆盖：
类 EncodedKeySpec 中的 getEncoded
返回：
密钥的 X.509 编码。每次调用此方法时，都返回一个新数组。

getFormat

public final String getFormat()
返回与此密钥规范关联的编码格式的名称。

指定者：
类 EncodedKeySpec 中的 getFormat
返回：
字符串 "X.509"。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.security.spec (Java 2 Platform SE 6)

 java.security.spec
接口
AlgorithmParameterSpec
ECField
KeySpec
类
DSAParameterSpec
DSAPrivateKeySpec
DSAPublicKeySpec
ECFieldF2m
ECFieldFp
ECGenParameterSpec
ECParameterSpec
ECPoint
ECPrivateKeySpec
ECPublicKeySpec
EllipticCurve
EncodedKeySpec
MGF1ParameterSpec
PKCS8EncodedKeySpec
PSSParameterSpec
RSAKeyGenParameterSpec
RSAMultiPrimePrivateCrtKeySpec
RSAOtherPrimeInfo
RSAPrivateCrtKeySpec
RSAPrivateKeySpec
RSAPublicKeySpec
X509EncodedKeySpec
异常
InvalidKeySpecException
InvalidParameterSpecException


java.security.spec (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.security.spec

提供密钥规范和算法参数规范的类和接口。

请参见：
描述

接口摘要
AlgorithmParameterSpec | 加密参数的（透明）规范。
ECField | 此接口表示椭圆曲线 (EC) 有限字段。
KeySpec | 组成加密密钥的密钥内容的（透明）规范。

类摘要
DSAParameterSpec | 此类指定用于 DSA 算法的参数的集合。
DSAPrivateKeySpec | 此类指定带关联参数的 DSA 专用密钥。
DSAPublicKeySpec | 此类指定带关联参数的 DSA 公用密钥。
ECFieldF2m | 此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。
ECFieldFp | 此不可变类定义椭圆曲线 (EC) 素数的有限字段。
ECGenParameterSpec | 此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。
ECParameterSpec | 此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。
ECPoint | 此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。
ECPrivateKeySpec | 此不可变类指定带关联参数的椭圆曲线专用密钥。
ECPublicKeySpec | 此不可变类指定带关联参数的椭圆曲线公用密钥。
EllipticCurve | 此不可变类持有表示椭圆曲线所必需的值。
EncodedKeySpec | 此类用编码格式表示公用密钥或专用密钥。
MGF1ParameterSpec | 此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。
PKCS8EncodedKeySpec | 此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。
PSSParameterSpec | 此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。
RSAKeyGenParameterSpec | 此类指定用于生成 RSA 密钥对的参数集。
RSAMultiPrimePrivateCrtKeySpec | 如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。
RSAOtherPrimeInfo | 此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。
RSAPrivateCrtKeySpec | 为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。
RSAPrivateKeySpec | 此类指定 RSA 专用密钥。
RSAPublicKeySpec | 此类指定 RSA 公用密钥。
X509EncodedKeySpec | 此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。

异常摘要
InvalidKeySpecException | 这是针对无效密钥规范的异常。
InvalidParameterSpecException | 这是针对无效参数规范的异常。

软件包 java.security.spec 的描述

提供密钥规范和算法参数规范的类和接口。

密钥规范是组成密钥的密钥内容的透明表示形式。用特定于算法的方法或独立于算法的编码格式（例如，ASN.1）可以指定密钥。此包包含以下密钥的密钥规范：DSA 公用密钥和专用密钥、RSA 公用密钥和专用密钥、DER 编码格式的 PKCS #8 专用密钥和 DER 编码格式的 X.509 公用密钥和专用密钥。

算法参数规范用于算法的参数集的透明表示形式。此包包含用于 DSA 算法的参数的算法参数规范。

包规范

  • PKCS #1:RSA 加密标准 1.5 版，1993 年 11 月
  • PKCS #8:专用密钥信息语法标准 1.2 版，1993 年 11 月
  • 联邦信息处理标准出版物 (FIPS PUB) 186：数字签名标准 (DSS)

相关文档

有关包含关于算法参数和密钥规范的信息文档，请参阅：
  • JavaTM Cryptography Architecture API Specification and Reference
  • How to Implement a Provider for the JavaTM Cryptography Architecture

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.security.spec 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.spec 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.security.spec.DSAParameterSpec (implements java.security.spec.AlgorithmParameterSpec, java.security.interfaces.DSAParams)
    • java.security.spec.DSAPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.DSAPublicKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.ECFieldF2m (implements java.security.spec.ECField)
    • java.security.spec.ECFieldFp (implements java.security.spec.ECField)
    • java.security.spec.ECGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.ECPoint
    • java.security.spec.ECPrivateKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.ECPublicKeySpec (implements java.security.spec.KeySpec)
    • java.security.spec.EllipticCurve
    • java.security.spec.EncodedKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.PKCS8EncodedKeySpec
      • java.security.spec.X509EncodedKeySpec
    • java.security.spec.MGF1ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.PSSParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.RSAKeyGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • java.security.spec.RSAOtherPrimeInfo
    • java.security.spec.RSAPrivateKeySpec (implements java.security.spec.KeySpec)
      • java.security.spec.RSAMultiPrimePrivateCrtKeySpec
      • java.security.spec.RSAPrivateCrtKeySpec
    • java.security.spec.RSAPublicKeySpec (implements java.security.spec.KeySpec)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • java.security.spec.InvalidKeySpecException
          • java.security.spec.InvalidParameterSpecException

接口分层结构

  • java.security.spec.AlgorithmParameterSpec
  • java.security.spec.ECField
  • java.security.spec.KeySpec
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.security.spec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.security.spec
的使用

使用 java.security.spec 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

java.security 使用的 java.security.spec 中的类
AlgorithmParameterSpec
加密参数的（透明）规范。
InvalidKeySpecException
这是针对无效密钥规范的异常。
InvalidParameterSpecException
这是针对无效参数规范的异常。
KeySpec
组成加密密钥的密钥内容的（透明）规范。

java.security.interfaces 使用的 java.security.spec 中的类
ECParameterSpec
此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。
ECPoint
此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。
RSAOtherPrimeInfo
此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。

java.security.spec 使用的 java.security.spec 中的类
AlgorithmParameterSpec
加密参数的（透明）规范。
ECField
此接口表示椭圆曲线 (EC) 有限字段。
ECParameterSpec
此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。
ECPoint
此不可变类在仿射坐标中表示椭圆曲线 (EC) 上的点。
EllipticCurve
此不可变类持有表示椭圆曲线所必需的值。
EncodedKeySpec
此类用编码格式表示公用密钥或专用密钥。
KeySpec
组成加密密钥的密钥内容的（透明）规范。
MGF1ParameterSpec
此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。
PSSParameterSpec
此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。
RSAOtherPrimeInfo
此类表示 RSA 的 OtherPrimeInfo 结构中的三元组（素数、指数和素数），如 PKCS#1 v2.1 中所定义的。
RSAPrivateKeySpec
此类指定 RSA 专用密钥。

javax.crypto 使用的 java.security.spec 中的类
AlgorithmParameterSpec
加密参数的（透明）规范。
InvalidKeySpecException
这是针对无效密钥规范的异常。
KeySpec
组成加密密钥的密钥内容的（透明）规范。
PKCS8EncodedKeySpec
此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。

javax.crypto.spec 使用的 java.security.spec 中的类
AlgorithmParameterSpec
加密参数的（透明）规范。
KeySpec
组成加密密钥的密钥内容的（透明）规范。

javax.xml.crypto 使用的 java.security.spec 中的类
AlgorithmParameterSpec
加密参数的（透明）规范。

javax.xml.crypto.dsig 使用的 java.security.spec 中的类
AlgorithmParameterSpec
加密参数的（透明）规范。

javax.xml.crypto.dsig.spec 使用的 java.security.spec 中的类
AlgorithmParameterSpec
加密参数的（透明）规范。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.DSAPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.DSAPrivateKeySpec
的使用

没有 java.security.spec.DSAPrivateKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.spec.ECField 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.spec.ECField
的使用

使用 ECField 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 ECField 的使用

实现 ECField 的 java.security.spec 中的类
class | ECFieldF2m 此不可变类定义椭圆曲线 (EC) 首数为 2 的有限字段。
class | ECFieldFp 此不可变类定义椭圆曲线 (EC) 素数的有限字段。

返回 ECField 的 java.security.spec 中的方法
 ECField EllipticCurve.getField()
返回此椭圆曲线结束的有限字段 field。

参数类型为 ECField 的 java.security.spec 中的构造方法
EllipticCurve(ECField field, BigInteger a, BigInteger b)
使用指定的椭圆字段 field 以及系数 a 和 b 创建椭圆曲线。
EllipticCurve(ECField field, BigInteger a, BigInteger b, byte[] seed)
使用指定的椭圆字段 field、系数 a 和 b，以及用于生成曲线的 seed 创建椭圆曲线。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.ECFieldF2m 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECFieldF2m
的使用

没有 java.security.spec.ECFieldF2m 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.ECFieldFp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECFieldFp
的使用

没有 java.security.spec.ECFieldFp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.ECGenParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECGenParameterSpec
的使用

没有 java.security.spec.ECGenParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.ECParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECParameterSpec
的使用

使用 ECParameterSpec 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 ECParameterSpec 的使用

返回 ECParameterSpec 的 java.security.interfaces 中的方法
 ECParameterSpec ECKey.getParams()
返回与此密钥关联的域参数。

java.security.spec 中 ECParameterSpec 的使用

返回 ECParameterSpec 的 java.security.spec 中的方法
ECParameterSpec | ECPrivateKeySpec.getParams() 返回关联的椭圆曲线域参数。
ECParameterSpec | ECPublicKeySpec.getParams() 返回关联的椭圆曲线域参数。

参数类型为 ECParameterSpec 的 java.security.spec 中的构造方法
ECPrivateKeySpec(BigInteger s, ECParameterSpec params)
使用指定的参数值创建一个新的 ECPrivateKeySpec。
ECPublicKeySpec(ECPoint w, ECParameterSpec params)
根据指定参数值，创建一个新的 ECPublicKeySpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.ECPoint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECPoint
的使用

使用 ECPoint 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 ECPoint 的使用

返回 ECPoint 的 java.security.interfaces 中的方法
 ECPoint ECPublicKey.getW()
返回公用点 W。

java.security.spec 中 ECPoint 的使用

声明为 ECPoint 的 java.security.spec 中的字段
static ECPoint ECPoint.POINT_INFINITY
这就将该点定义为无穷大。

返回 ECPoint 的 java.security.spec 中的方法
ECPoint | ECParameterSpec.getGenerator() 返回也称为基点的生成器。
ECPoint | ECPublicKeySpec.getW() 返回公用点 W。

参数类型为 ECPoint 的 java.security.spec 中的构造方法
ECParameterSpec(EllipticCurve curve, ECPoint g, BigInteger n, int h)
创建基于指定值的椭圆曲线域参数。
ECPublicKeySpec(ECPoint w, ECParameterSpec params)
根据指定参数值，创建一个新的 ECPublicKeySpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.ECPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECPrivateKeySpec
的使用

没有 java.security.spec.ECPrivateKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.ECPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.ECPublicKeySpec
的使用

没有 java.security.spec.ECPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.EllipticCurve 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.EllipticCurve
的使用

使用 EllipticCurve 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 EllipticCurve 的使用

返回 EllipticCurve 的 java.security.spec 中的方法
 EllipticCurve ECParameterSpec.getCurve()
返回此参数定义的椭圆曲线。

参数类型为 EllipticCurve 的 java.security.spec 中的构造方法
ECParameterSpec(EllipticCurve curve, ECPoint g, BigInteger n, int h)
创建基于指定值的椭圆曲线域参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.InvalidParameterSpecException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.InvalidParameterSpecException
的使用

使用 InvalidParameterSpecException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 InvalidParameterSpecException 的使用

抛出 InvalidParameterSpecException 的 java.security 中的方法
protected abstract
<T extends AlgorithmParameterSpec>
T
AlgorithmParametersSpi.engineGetParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
protected abstract  void AlgorithmParametersSpi.engineInit(AlgorithmParameterSpec paramSpec)
使用在 paramSpec 中指定的参数初始化此参数对象。
<T extends AlgorithmParameterSpec>
T
AlgorithmParameters.getParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
 void AlgorithmParameters.init(AlgorithmParameterSpec paramSpec)
使用在 paramSpec 中指定的参数初始化此参数对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.MGF1ParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.MGF1ParameterSpec
的使用

使用 MGF1ParameterSpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 MGF1ParameterSpec 的使用

声明为 MGF1ParameterSpec 的 java.security.spec 中的字段
static MGF1ParameterSpec | MGF1ParameterSpec.SHA1 使用“SHA-1”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | MGF1ParameterSpec.SHA256 使用“SHA-256”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | MGF1ParameterSpec.SHA384 使用“SHA-384”消息摘要的 MGF1ParameterSpec。
static MGF1ParameterSpec | MGF1ParameterSpec.SHA512 使用 SHA-512 消息摘要的 MGF1ParameterSpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.PSSParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.PSSParameterSpec
的使用

使用 PSSParameterSpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 PSSParameterSpec 的使用

声明为 PSSParameterSpec 的 java.security.spec 中的字段
static PSSParameterSpec PSSParameterSpec.DEFAULT
带所有默认值的 PSS 参数集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.RSAKeyGenParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAKeyGenParameterSpec
的使用

没有 java.security.spec.RSAKeyGenParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAMultiPrimePrivateCrtKeySpec
的使用

没有 java.security.spec.RSAMultiPrimePrivateCrtKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.RSAOtherPrimeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAOtherPrimeInfo
的使用

使用 RSAOtherPrimeInfo 的软件包
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。

java.security.interfaces 中 RSAOtherPrimeInfo 的使用

返回 RSAOtherPrimeInfo 的 java.security.interfaces 中的方法
 RSAOtherPrimeInfo[] RSAMultiPrimePrivateCrtKey.getOtherPrimeInfo()
返回 otherPrimeInfo；如果仅存在两个素数因子（p 和 q），则返回 null。

java.security.spec 中 RSAOtherPrimeInfo 的使用

返回 RSAOtherPrimeInfo 的 java.security.spec 中的方法
 RSAOtherPrimeInfo[] RSAMultiPrimePrivateCrtKeySpec.getOtherPrimeInfo()
返回 otherPrimeInfo 的副本，如果仅有两个素数因子（p 和 q），则返回 null。

参数类型为 RSAOtherPrimeInfo 的 java.security.spec 中的构造方法
RSAMultiPrimePrivateCrtKeySpec(BigInteger modulus, BigInteger publicExponent, BigInteger privateExponent, BigInteger primeP, BigInteger primeQ, BigInteger primeExponentP, BigInteger primeExponentQ, BigInteger crtCoefficient, RSAOtherPrimeInfo[] otherPrimeInfo)
给定系数、publicExponent、privateExponent、primeP、primeQ、primeExponentP、primeExponentQ、crtCoefficient 和如 PKCS#1 v2.1 中所定义的 otherPrimeInfo，创建一个新的 RSAMultiPrimePrivateCrtKeySpec。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.DSAParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.DSAParameterSpec
的使用

没有 java.security.spec.DSAParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.spec.AlgorithmParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.spec.AlgorithmParameterSpec
的使用

使用 AlgorithmParameterSpec 的软件包
java.security | 为安全框架提供类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。

java.security 中 AlgorithmParameterSpec 的使用

类型参数类型为 AlgorithmParameterSpec 的 java.security 中的方法
protected abstract
<T extends AlgorithmParameterSpec>
T
AlgorithmParametersSpi.engineGetParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。
<T extends AlgorithmParameterSpec>
T
AlgorithmParameters.getParameterSpec(Class<T> paramSpec)
返回此参数对象的（透明）规范。

参数类型为 AlgorithmParameterSpec 的 java.security 中的方法
protected abstract void | AlgorithmParametersSpi.engineInit(AlgorithmParameterSpec paramSpec) 使用在 paramSpec 中指定的参数初始化此参数对象。
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值的集合初始化此参数生成器。
protected void | SignatureSpi.engineSetParameter(AlgorithmParameterSpec params) 此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | AlgorithmParameters.init(AlgorithmParameterSpec paramSpec) 使用在 paramSpec 中指定的参数初始化此参数对象。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params) 初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params, SecureRandom random) 使用给定参数集合和随机源初始化密钥对生成器。
void | KeyPairGeneratorSpi.initialize(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集合和用户提供的随机源初始化密钥对生成器。
void | Signature.setParameter(AlgorithmParameterSpec params) 使用指定的参数集初始化此签名引擎。

java.security.spec 中 AlgorithmParameterSpec 的使用

实现 AlgorithmParameterSpec 的 java.security.spec 中的类
class | DSAParameterSpec 此类指定用于 DSA 算法的参数的集合。
class | ECGenParameterSpec 此不可变类指定用于生成椭圆曲线 (EC) 域参数的参数集。
class | ECParameterSpec 此不可变类指定用于椭圆曲线加密方法 (ECC) 的域参数集。
class | MGF1ParameterSpec 此类指定 OAEP Padding 和 RSA-PSS 签名方案中的掩码生成函数 MGF1（如 PKCS #1 v2.1 标准中所定义的）使用的参数集。
class | PSSParameterSpec 此类指定 RSA-PSS 签名方案的参数规范，如 PKCS#1 v2.1 标准中所定义的。
class | RSAKeyGenParameterSpec 此类指定用于生成 RSA 密钥对的参数集。

返回 AlgorithmParameterSpec 的 java.security.spec 中的方法
 AlgorithmParameterSpec PSSParameterSpec.getMGFParameters()
返回掩码生成函数的参数。

参数类型为 AlgorithmParameterSpec 的 java.security.spec 中的构造方法
PSSParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, int saltLen, int trailerField)
根据 PKCS #1 中的定义，使用指定的消息摘要、掩码生成函数、掩码生成函数的参数、salt 长度和尾部字段值，创建一个新的 PSSParameterSpec。

javax.crypto 中 AlgorithmParameterSpec 的使用

返回 AlgorithmParameterSpec 的 javax.crypto 中的方法
static AlgorithmParameterSpec Cipher.getMaxAllowedParameterSpec(String transformation)
根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。

参数类型为 AlgorithmParameterSpec 的 javax.crypto 中的方法
protected abstract void | KeyGeneratorSpi.engineInit(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化密钥生成器。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyGenerator.init(AlgorithmParameterSpec params) 用指定参数集初始化此密钥生成器。
void | KeyGenerator.init(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化此密钥生成器。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。

javax.crypto.spec 中 AlgorithmParameterSpec 的使用

实现 AlgorithmParameterSpec 的 javax.crypto.spec 中的类
class | DHGenParameterSpec 此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。
class | DHParameterSpec 此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。
class | IvParameterSpec 此类指定一个初始化向量 (IV)。
class | OAEPParameterSpec 此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。
class | PBEParameterSpec 此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。
class | RC2ParameterSpec 此类指定随同 RC2 算法使用的参数。
class | RC5ParameterSpec 此类指定随同 RC5 算法使用的参数。

返回 AlgorithmParameterSpec 的 javax.crypto.spec 中的方法
 AlgorithmParameterSpec OAEPParameterSpec.getMGFParameters()
返回掩码生成函数的参数。

参数类型为 AlgorithmParameterSpec 的 javax.crypto.spec 中的构造方法
OAEPParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。

javax.xml.crypto 中 AlgorithmParameterSpec 的使用

返回 AlgorithmParameterSpec 的 javax.xml.crypto 中的方法
 AlgorithmParameterSpec AlgorithmMethod.getParameterSpec()
返回此 AlgorithmMethod 的算法参数。

javax.xml.crypto.dsig 中 AlgorithmParameterSpec 的使用

返回 AlgorithmParameterSpec 的 javax.xml.crypto.dsig 中的方法
AlgorithmParameterSpec | CanonicalizationMethod.getParameterSpec() 返回与此 CanonicalizationMethod 关联的特定于算法的输入参数。
AlgorithmParameterSpec | DigestMethod.getParameterSpec() 返回与此 DigestMethod 关联的特定于算法的输入参数。
AlgorithmParameterSpec | SignatureMethod.getParameterSpec() 返回此 SignatureMethod 的特定于算法的输入参数。
AlgorithmParameterSpec | Transform.getParameterSpec() 返回与此 Transform 关联的特定于算法的输入参数。

javax.xml.crypto.dsig.spec 中 AlgorithmParameterSpec 的使用

javax.xml.crypto.dsig.spec 中 AlgorithmParameterSpec 的子接口
interface | C14NMethodParameterSpec CanonicalizationMethod 算法的算法参数规范。
interface | DigestMethodParameterSpec 用于 DigestMethod 算法的算法参数的规范。
interface | SignatureMethodParameterSpec 用于 XML SignatureMethod 算法的算法参数规范。
interface | TransformParameterSpec 用于 Transform 算法的算法参数规范。

实现 AlgorithmParameterSpec 的 javax.xml.crypto.dsig.spec 中的类
class | ExcC14NParameterSpec W3C Recommendation 的参数：Exclusive XML Canonicalization (C14N) 算法。
class | HMACParameterSpec XML Signature HMAC Algorithm 的参数。
class | XPathFilter2ParameterSpec W3C Recommendation XPath Filter 2.0 Transform Algorithm 的参数。
class | XPathFilterParameterSpec XPath Filtering Transform Algorithm 的参数。
class | XSLTTransformParameterSpec XSLT Transform Algorithm 的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.InvalidKeySpecException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.InvalidKeySpecException
的使用

使用 InvalidKeySpecException 的软件包
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。

java.security 中 InvalidKeySpecException 的使用

抛出 InvalidKeySpecException 的 java.security 中的方法
protected abstract  PrivateKey KeyFactorySpi.engineGeneratePrivate(KeySpec keySpec)
根据所提供的密钥规范（密钥材料）生成私钥对象。
protected abstract  PublicKey KeyFactorySpi.engineGeneratePublic(KeySpec keySpec)
根据所提供的密钥规范（密钥材料）生成公钥对象。
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
 PrivateKey KeyFactory.generatePrivate(KeySpec keySpec)
根据提供的密钥规范（密钥材料）生成私钥对象。
 PublicKey KeyFactory.generatePublic(KeySpec keySpec)
根据提供的密钥规范（密钥材料）生成公钥对象。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。

javax.crypto 中 InvalidKeySpecException 的使用

抛出 InvalidKeySpecException 的 javax.crypto 中的方法
protected abstract SecretKey | SecretKeyFactorySpi.engineGenerateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
SecretKey | SecretKeyFactory.generateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Cipher cipher) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.DSAPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.DSAPublicKeySpec
的使用

没有 java.security.spec.DSAPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.PKCS8EncodedKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.PKCS8EncodedKeySpec
的使用

使用 PKCS8EncodedKeySpec 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 PKCS8EncodedKeySpec 的使用

返回 PKCS8EncodedKeySpec 的 javax.crypto 中的方法
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Cipher cipher) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.RSAPrivateCrtKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAPrivateCrtKeySpec
的使用

没有 java.security.spec.RSAPrivateCrtKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.RSAPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAPrivateKeySpec
的使用

使用 RSAPrivateKeySpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 RSAPrivateKeySpec 的使用

java.security.spec 中 RSAPrivateKeySpec 的子类
class | RSAMultiPrimePrivateCrtKeySpec 如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。
class | RSAPrivateCrtKeySpec 为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.RSAPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.RSAPublicKeySpec
的使用

没有 java.security.spec.RSAPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.X509EncodedKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.X509EncodedKeySpec
的使用

没有 java.security.spec.X509EncodedKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.spec.EncodedKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.spec.EncodedKeySpec
的使用

使用 EncodedKeySpec 的软件包
java.security.spec 提供密钥规范和算法参数规范的类和接口。

java.security.spec 中 EncodedKeySpec 的使用

java.security.spec 中 EncodedKeySpec 的子类
class | PKCS8EncodedKeySpec 此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。
class | X509EncodedKeySpec 此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.spec.KeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.spec.KeySpec
的使用

使用 KeySpec 的软件包
java.security | 为安全框架提供类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。

java.security 中 KeySpec 的使用

类型参数类型为 KeySpec 的 java.security 中的方法
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。

参数类型为 KeySpec 的 java.security 中的方法
protected abstract PrivateKey | KeyFactorySpi.engineGeneratePrivate(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成私钥对象。
protected abstract PublicKey | KeyFactorySpi.engineGeneratePublic(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成公钥对象。
PrivateKey | KeyFactory.generatePrivate(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成私钥对象。
PublicKey | KeyFactory.generatePublic(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成公钥对象。

java.security.spec 中 KeySpec 的使用

实现 KeySpec 的 java.security.spec 中的类
class | DSAPrivateKeySpec 此类指定带关联参数的 DSA 专用密钥。
class | DSAPublicKeySpec 此类指定带关联参数的 DSA 公用密钥。
class | ECPrivateKeySpec 此不可变类指定带关联参数的椭圆曲线专用密钥。
class | ECPublicKeySpec 此不可变类指定带关联参数的椭圆曲线公用密钥。
class | EncodedKeySpec 此类用编码格式表示公用密钥或专用密钥。
class | PKCS8EncodedKeySpec 此类表示按照 ASN.1 类型 PrivateKeyInfo 进行编码的专用密钥的 ASN.1 编码。
class | RSAMultiPrimePrivateCrtKeySpec 如 PKCS#1 v2.1 中所定义的，此类为了提高效率，使用 Chinese Remainder Theorem (CRT) 信息值指定 RSA 多素数专用密钥。
class | RSAPrivateCrtKeySpec 为了提高效率，此类根据 PKCS#1 标准所定义的，使用 Chinese Remainder Theorem（中国剩余定理，CRT）信息值指定一个 RSA 专用密钥。
class | RSAPrivateKeySpec 此类指定 RSA 专用密钥。
class | RSAPublicKeySpec 此类指定 RSA 公用密钥。
class | X509EncodedKeySpec 此类表示根据 ASN.1 类型 SubjectPublicKeyInfo 进行编码的公用密钥的 ASN.1 编码。

javax.crypto 中 KeySpec 的使用

返回 KeySpec 的 javax.crypto 中的方法
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。

参数类型为 KeySpec 的 javax.crypto 中的方法
protected abstract SecretKey | SecretKeyFactorySpi.engineGenerateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
SecretKey | SecretKeyFactory.generateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。

javax.crypto.spec 中 KeySpec 的使用

实现 KeySpec 的 javax.crypto.spec 中的类
class | DESedeKeySpec 此类指定一个 DES-EDE ("triple-DES") 密钥。
class | DESKeySpec 此类指定一个 DES 密钥。
class | DHPrivateKeySpec 此类使用其关联的参数指定一个 Diffie-Hellman 私钥。
class | DHPublicKeySpec 此类使用关联的参数指定一个 Diffie-Hellman 公钥。
class | PBEKeySpec 可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。
class | SecretKeySpec 此类以与 provider 无关的方式指定一个密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AccessControlException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AccessControlException
的使用

使用 AccessControlException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AccessControlException 的使用

抛出 AccessControlException 的 java.security 中的方法
static void | AccessController.checkPermission(Permission perm) 基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。
void | AccessControlContext.checkPermission(Permission perm) 基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AlgorithmParameterGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParameterGenerator
的使用

使用 AlgorithmParameterGenerator 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AlgorithmParameterGenerator 的使用

返回 AlgorithmParameterGenerator 的 java.security 中的方法
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, String provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AlgorithmParameterGeneratorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParameterGeneratorSpi
的使用

使用 AlgorithmParameterGeneratorSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AlgorithmParameterGeneratorSpi 的使用

参数类型为 AlgorithmParameterGeneratorSpi 的 java.security 中的构造方法
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameterGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Certificate
的使用

使用 Certificate 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Certificate 的使用

返回 Certificate 的 java.security 中的方法
 Certificate[] Identity.certificates()
已过时。 返回此 Identity 所有证书的一个副本。

参数类型为 Certificate 的 java.security 中的方法
void | Identity.addCertificate(Certificate certificate) 已过时。 为此 Identity 添加一个证书。
void | Identity.removeCertificate(Certificate certificate) 已过时。 从此 Identity 中移除证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.DigestException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.DigestException
的使用

使用 DigestException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 DigestException 的使用

抛出 DigestException 的 java.security 中的方法
int | MessageDigest.digest(byte[] buf, int offset, int len) 通过执行诸如填充之类的最终操作完成哈希计算。
protected int | MessageDigestSpi.engineDigest(byte[] buf, int offset, int len) 通过执行诸如填充等之类的最终操作完成哈希计算。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.DigestInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.DigestInputStream
的使用

没有 java.security.DigestInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.DigestOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.DigestOutputStream
的使用

没有 java.security.DigestOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.DomainCombiner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.DomainCombiner
的使用

使用 DomainCombiner 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 DomainCombiner 的使用

返回 DomainCombiner 的 java.security 中的方法
 DomainCombiner AccessControlContext.getDomainCombiner()
获取与此 AccessControlContext 关联的 DomainCombiner。

参数类型为 DomainCombiner 的 java.security 中的构造方法
AccessControlContext(AccessControlContext acc, DomainCombiner combiner)
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。

javax.security.auth 中 DomainCombiner 的使用

实现 DomainCombiner 的 javax.security.auth 中的类
 class SubjectDomainCombiner
SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.GuardedObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.GuardedObject
的使用

没有 java.security.GuardedObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Identity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Identity
的使用

使用 Identity 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Identity 的使用

java.security 中 Identity 的子类
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

返回 Identity 的 java.security 中的方法
Identity | IdentityScope.getIdentity(Principal principal) 已过时。 获取名称与指定的主体相同的身份。
abstract Identity | IdentityScope.getIdentity(PublicKey key) 已过时。 获取具有指定公钥的身份。
abstract Identity | IdentityScope.getIdentity(String name) 已过时。 返回此作用域内具有指定名称的身份（如果有的话）。

返回变量类型为 Identity 的类型的 java.security 中的方法
abstract  Enumeration<Identity> IdentityScope.identities()
已过时。 返回此身份作用域内所有身份的枚举。

参数类型为 Identity 的 java.security 中的方法
abstract void | IdentityScope.addIdentity(Identity identity) 已过时。 向此身份作用域添加一个身份。
protected boolean | Identity.identityEquals(Identity identity) 已过时。 测试指定 Identity 与此 Identity 的相等性。
abstract void | IdentityScope.removeIdentity(Identity identity) 已过时。 从此身份作用作用域移除一个身份。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.IdentityScope 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.IdentityScope
的使用

使用 IdentityScope 的软件包
java.security 为安全框架提供类和接口。

java.security 中 IdentityScope 的使用

返回 IdentityScope 的 java.security 中的方法
IdentityScope | Identity.getScope() 已过时。 返回此 Identity 的作用域。
static IdentityScope | IdentityScope.getSystemScope() 已过时。 返回系统的身份作用域。

参数类型为 IdentityScope 的 java.security 中的方法
protected static void IdentityScope.setSystemScope(IdentityScope scope)
已过时。 设置系统的身份作用域。

参数类型为 IdentityScope 的 java.security 中的构造方法
Identity(String name, IdentityScope scope)
已过时。 构造一个具有指定名称和作用域的 Identity。
IdentityScope(String name, IdentityScope scope)
已过时。 构造具有指定名称和作用域的新身份作用域。
Signer(String name, IdentityScope scope)
已过时。 创建带有指定标识名称和范围的 signer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.InvalidAlgorithmParameterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.InvalidAlgorithmParameterException
的使用

使用 InvalidAlgorithmParameterException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

java.security 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 java.security 中的方法
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值的集合初始化此参数生成器。
protected void | SignatureSpi.engineSetParameter(AlgorithmParameterSpec params) 此方法将由提供者重写，以便使用指定的参数设置初始化此签名引擎。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params) 初始化密钥对生成器，使用指定参数集合，并使用以最高优先级安装的提供者的 SecureRandom 的实现作为随机源。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params, SecureRandom random) 使用给定参数集合和随机源初始化密钥对生成器。
void | KeyPairGeneratorSpi.initialize(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集合和用户提供的随机源初始化密钥对生成器。
void | Signature.setParameter(AlgorithmParameterSpec params) 使用指定的参数集初始化此签名引擎。

java.security.cert 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 java.security.cert 中的方法
CertPathBuilderResult | CertPathBuilder.build(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathBuilderResult | CertPathBuilderSpi.engineBuild(CertPathParameters params) 尝试使用指定的算法参数集构建一个证书路径。
abstract CertPathValidatorResult | CertPathValidatorSpi.engineValidate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
void | PKIXParameters.setTrustAnchors(Set<TrustAnchor> trustAnchors) 设置最受信任的 CA Set。
CertPathValidatorResult | CertPathValidator.validate(CertPath certPath, CertPathParameters params) 使用指定的算法参数集验证指定的证书路径。

抛出 InvalidAlgorithmParameterException 的 java.security.cert 中的构造方法
CertStoreSpi(CertStoreParameters params)
唯一的构造方法。
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXParameters(KeyStore keystore)
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。
PKIXParameters(Set<TrustAnchor> trustAnchors)
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。

javax.crypto 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 javax.crypto 中的方法
protected abstract void | KeyGeneratorSpi.engineInit(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化密钥生成器。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyGenerator.init(AlgorithmParameterSpec params) 用指定参数集初始化此密钥生成器。
void | KeyGenerator.init(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化此密钥生成器。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。

javax.net.ssl 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用密钥内容源初始化此工厂。
protected abstract void | TrustManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用特定于提供者的密钥材料源初始化此工厂。
void | KeyManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的密钥内容源初始化此工厂。
void | TrustManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的信任材料源初始化此工厂。

javax.xml.crypto.dsig 中 InvalidAlgorithmParameterException 的使用

抛出 InvalidAlgorithmParameterException 的 javax.xml.crypto.dsig 中的方法
abstract void | TransformService.init(TransformParameterSpec params) 使用指定的参数初始化此 TransformService。
abstract void | TransformService.init(XMLStructure parent, XMLCryptoContext context) 使用指定的参数和文档上下文初始化此 TransformService。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract DigestMethod | XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params) 针对指定的算法 URI 和参数创建 DigestMethod。
abstract SignatureMethod | XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params) 针对指定的算法 URI 和参数创建 SignatureMethod。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyManagementException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyManagementException
的使用

使用 KeyManagementException 的软件包
java.security | 为安全框架提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyManagementException 的使用

抛出 KeyManagementException 的 java.security 中的方法
void | Identity.addCertificate(Certificate certificate) 已过时。 为此 Identity 添加一个证书。
abstract void | IdentityScope.addIdentity(Identity identity) 已过时。 向此身份作用域添加一个身份。
void | Identity.removeCertificate(Certificate certificate) 已过时。 从此 Identity 中移除证书。
abstract void | IdentityScope.removeIdentity(Identity identity) 已过时。 从此身份作用作用域移除一个身份。
void | Identity.setPublicKey(PublicKey key) 已过时。 设置此 Identity 的公钥。

抛出 KeyManagementException 的 java.security 中的构造方法
Identity(String name, IdentityScope scope)
已过时。 构造一个具有指定名称和作用域的 Identity。
IdentityScope(String name, IdentityScope scope)
已过时。 构造具有指定名称和作用域的新身份作用域。
Signer(String name, IdentityScope scope)
已过时。 创建带有指定标识名称和范围的 signer。

javax.net.ssl 中 KeyManagementException 的使用

抛出 KeyManagementException 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyPair 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyPair
的使用

使用 KeyPair 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyPair 的使用

返回 KeyPair 的 java.security 中的方法
KeyPair | KeyPairGenerator.generateKeyPair() 生成一个密钥对。
abstract KeyPair | KeyPairGeneratorSpi.generateKeyPair() 生成密钥对。
KeyPair | KeyPairGenerator.genKeyPair() 生成密钥对。

参数类型为 KeyPair 的 java.security 中的方法
 void Signer.setKeyPair(KeyPair pair)
已过时。 为此签署人设置密钥对（公钥和私钥）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyRep 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyRep
的使用

没有 java.security.KeyRep 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyPairGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyPairGenerator
的使用

使用 KeyPairGenerator 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyPairGenerator 的使用

返回 KeyPairGenerator 的 java.security 中的方法
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyPairGeneratorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyPairGeneratorSpi
的使用

使用 KeyPairGeneratorSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyPairGeneratorSpi 的使用

java.security 中 KeyPairGeneratorSpi 的子类
 class KeyPairGenerator
KeyPairGenerator 类用于生成公钥和私钥对。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyRep.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyRep.Type
的使用

使用 KeyRep.Type 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyRep.Type 的使用

返回 KeyRep.Type 的 java.security 中的方法
static KeyRep.Type | KeyRep.Type.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static KeyRep.Type[] | KeyRep.Type.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 KeyRep.Type 的 java.security 中的构造方法
KeyRep(KeyRep.Type type, String algorithm, String format, byte[] encoded)
构造替换的 Key 类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore
的使用

使用 KeyStore 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyStore 的使用

返回 KeyStore 的 java.security 中的方法
static KeyStore | KeyStore.getInstance(String type) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, Provider provider) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, String provider) 返回指定类型的 keystore 对象。
abstract KeyStore | KeyStore.Builder.getKeyStore() 返回此对象描述的 KeyStore。

参数类型为 KeyStore 的 java.security 中的方法
static KeyStore.Builder KeyStore.Builder.newInstance(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter)
返回封装给定 KeyStore 的新 Builder。

java.security.cert 中 KeyStore 的使用

参数类型为 KeyStore 的 java.security.cert 中的构造方法
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXParameters(KeyStore keystore)
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。

javax.net.ssl 中 KeyStore 的使用

参数类型为 KeyStore 的 javax.net.ssl 中的方法
protected abstract void | TrustManagerFactorySpi.engineInit(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
void | TrustManagerFactory.init(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.KeyStore.LoadStoreParameter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.KeyStore.LoadStoreParameter
的使用

使用 KeyStore.LoadStoreParameter 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStore.LoadStoreParameter 的使用

参数类型为 KeyStore.LoadStoreParameter 的 java.security 中的方法
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.KeyStore.ProtectionParameter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.KeyStore.ProtectionParameter
的使用

使用 KeyStore.ProtectionParameter 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStore.ProtectionParameter 的使用

实现 KeyStore.ProtectionParameter 的 java.security 中的类
static class | KeyStore.CallbackHandlerProtection 封装 CallbackHandler 的 ProtectionParameter。
static class | KeyStore.PasswordProtection ProtectionParameter 的一个基于密码的实现。

返回 KeyStore.ProtectionParameter 的 java.security 中的方法
KeyStore.ProtectionParameter | KeyStore.LoadStoreParameter.getProtectionParameter() 获取用于保护 keystore 数据的参数。
abstract KeyStore.ProtectionParameter | KeyStore.Builder.getProtectionParameter(String alias) 返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。

参数类型为 KeyStore.ProtectionParameter 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
void | KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 KeyStore.Entry。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。
static KeyStore.Builder | KeyStore.Builder.newInstance(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter) 返回封装给定 KeyStore 的新 Builder。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
void | KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 keystore Entry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStore.PasswordProtection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.PasswordProtection
的使用

没有 java.security.KeyStore.PasswordProtection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStore.CallbackHandlerProtection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.CallbackHandlerProtection
的使用

没有 java.security.KeyStore.CallbackHandlerProtection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.KeyStore.Entry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.KeyStore.Entry
的使用

使用 KeyStore.Entry 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStore.Entry 的使用

实现 KeyStore.Entry 的 java.security 中的类
static class | KeyStore.PrivateKeyEntry 保存 PrivateKey 和相应证书链的 KeyStore 项。
static class | KeyStore.SecretKeyEntry 保存 SecretKey 的 KeyStore 项。
static class | KeyStore.TrustedCertificateEntry 保存可信的 Certificate 的 KeyStore 项。

返回 KeyStore.Entry 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。

参数类型为 KeyStore.Entry 的 java.security 中的方法
void | KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 KeyStore.Entry。
void | KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 keystore Entry。

类型变量类型为 KeyStore.Entry 的 java.security 中的方法参数
boolean | KeyStoreSpi.engineEntryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
boolean | KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStore.PrivateKeyEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.PrivateKeyEntry
的使用

没有 java.security.KeyStore.PrivateKeyEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStore.SecretKeyEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.SecretKeyEntry
的使用

没有 java.security.KeyStore.SecretKeyEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStore.TrustedCertificateEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.TrustedCertificateEntry
的使用

没有 java.security.KeyStore.TrustedCertificateEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStore.Builder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStore.Builder
的使用

使用 KeyStore.Builder 的软件包
java.security | 为安全框架提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyStore.Builder 的使用

返回 KeyStore.Builder 的 java.security 中的方法
static KeyStore.Builder | KeyStore.Builder.newInstance(KeyStore keyStore, KeyStore.ProtectionParameter protectionParameter) 返回封装给定 KeyStore 的新 Builder。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。

javax.net.ssl 中 KeyStore.Builder 的使用

参数类型为 KeyStore.Builder 的 javax.net.ssl 中的构造方法
KeyStoreBuilderParameters(KeyStore.Builder builder)
根据指定的 KeyStore.Builder 构造新的 KeyStoreBuilderParameters。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.PolicySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.PolicySpi
的使用

没有 java.security.PolicySpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStoreException
的使用

使用 KeyStoreException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 KeyStoreException 的使用

抛出 KeyStoreException 的 java.security 中的方法
Enumeration<String> | KeyStore.aliases() 列出此 keystore 的所有别名。
boolean | KeyStore.containsAlias(String alias) 检查给定别名是否存在于此 keystore 中。
void | KeyStore.deleteEntry(String alias) 删除此 keystore 中给定别名标识的条目。
abstract void | KeyStoreSpi.engineDeleteEntry(String alias) 删除由此 keystore 中给定的别名标识的项。
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
abstract void | KeyStoreSpi.engineSetCertificateEntry(String alias, Certificate cert) 将给定证书分配给给定别名。
void | KeyStoreSpi.engineSetEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 KeyStore.Entry。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
abstract void | KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，用给定的密码保护它。
boolean | KeyStore.entryInstanceOf(String alias, Class<? extends KeyStore.Entry> entryClass) 确定指定 alias 的 keystore Entry 是否是指定 entryClass 的实例或子类。
Certificate | KeyStore.getCertificate(String alias) 返回与给定别名关联的证书。
String | KeyStore.getCertificateAlias(Certificate cert) 返回证书与给定证书匹配的第一个 keystore 条目的别名。
Certificate[] | KeyStore.getCertificateChain(String alias) 返回与给定别名关联的证书链。
Date | KeyStore.getCreationDate(String alias) 返回给定别名标识的条目的创建日期。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。
static KeyStore | KeyStore.getInstance(String type) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, Provider provider) 返回指定类型的 keystore 对象。
static KeyStore | KeyStore.getInstance(String type, String provider) 返回指定类型的 keystore 对象。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。
abstract KeyStore | KeyStore.Builder.getKeyStore() 返回此对象描述的 KeyStore。
abstract KeyStore.ProtectionParameter | KeyStore.Builder.getProtectionParameter(String alias) 返回应该用来获取具有给定别名的 Entry 的 ProtectionParameters。
boolean | KeyStore.isCertificateEntry(String alias) 如果给定别名标识的条目是通过调用 setCertificateEntry 或者以 TrustedCertificateEntry 为参数的 setEntry 创建的，则返回 true。
boolean | KeyStore.isKeyEntry(String alias) 如果给定别名标识的条目是通过调用 setKeyEntry 或者以 PrivateKeyEntry 或 SecretKeyEntry 为参数的 setEntry 创建的，则返回 true。
void | KeyStore.setCertificateEntry(String alias, Certificate cert) 将给定可信证书分配给给定别名。
void | KeyStore.setEntry(String alias, KeyStore.Entry entry, KeyStore.ProtectionParameter protParam) 用指定别名保存 keystore Entry。
void | KeyStore.setKeyEntry(String alias, byte[] key, Certificate[] chain) 将给定密钥（已经被保护）分配给给定别名。
void | KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain) 将给定的密钥分配给给定的别名，并用给定密码保护它。
int | KeyStore.size() 获取此 keystore 中条目数。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

java.security.cert 中 KeyStoreException 的使用

抛出 KeyStoreException 的 java.security.cert 中的构造方法
PKIXBuilderParameters(KeyStore keystore, CertSelector targetConstraints)
创建一个 PKIXBuilderParameters 实例，它根据指定 KeyStore 中所包含的受信任证书项生成最受信任的 CA 集。
PKIXParameters(KeyStore keystore)
创建一个 PKIXParameters 实例，它根据指定 KeyStore 中所包含的受信证书项生成最受信任的 CA 集。

javax.net.ssl 中 KeyStoreException 的使用

抛出 KeyStoreException 的 javax.net.ssl 中的方法
protected abstract void | TrustManagerFactorySpi.engineInit(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
void | TrustManagerFactory.init(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyStoreSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyStoreSpi
的使用

使用 KeyStoreSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyStoreSpi 的使用

参数类型为 KeyStoreSpi 的 java.security 中的构造方法
KeyStore(KeyStoreSpi keyStoreSpi, Provider provider, String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.NoSuchProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.NoSuchProviderException
的使用

使用 NoSuchProviderException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

java.security 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 java.security 中的方法
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, String provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyStore | KeyStore.getInstance(String type, String provider) 返回指定类型的 keystore 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, String provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, String provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, String provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, String provider) 返回实现指定摘要算法的 MessageDigest 对象。

java.security.cert 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, String provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, String provider) 返回实现指定算法的 CertPathValidator 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, String provider) 返回指定证书类型的 CertificateFactory 对象。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.crypto 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.crypto 中的方法
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, String provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, String provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, String provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。

javax.net.ssl 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.net.ssl 中的方法
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, String provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, String provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, String provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。

javax.security.auth.login 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.security.auth.login 中的方法
static Configuration Configuration.getInstance(String type, Configuration.Parameters params, String provider)
返回指定类型的 Configuration 对象。

javax.security.cert 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

javax.xml.crypto.dsig 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.xml.crypto.dsig 中的方法
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, String provider) 返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, String provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

javax.xml.crypto.dsig.keyinfo 中 NoSuchProviderException 的使用

抛出 NoSuchProviderException 的 javax.xml.crypto.dsig.keyinfo 中的方法
static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, String provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.SecureRandom 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecureRandom
的使用

使用 SecureRandom 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 SecureRandom 的使用

声明为 SecureRandom 的 java.security 中的字段
protected  SecureRandom SignatureSpi.appRandom
应用程序指定的随机源。

返回 SecureRandom 的 java.security 中的方法
static SecureRandom | SecureRandom.getInstance(String algorithm) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, Provider provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, String provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。

参数类型为 SecureRandom 的 java.security 中的方法
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值的集合初始化此参数生成器。
protected abstract void | AlgorithmParameterGeneratorSpi.engineInit(int size, SecureRandom random) 针对某个特定大小和随机源初始化此参数生成器。
protected void | SignatureSpi.engineInitSign(PrivateKey privateKey, SecureRandom random) 通过用于签名操作的指定私钥和随机源初始化此签名对象。
void | AlgorithmParameterGenerator.init(AlgorithmParameterSpec genParamSpec, SecureRandom random) 利用特定于算法的参数生成值集合初始化此参数生成器。
void | AlgorithmParameterGenerator.init(int size, SecureRandom random) 针对某个特定大小和随机源初始化此参数生成器。
void | KeyPairGenerator.initialize(AlgorithmParameterSpec params, SecureRandom random) 使用给定参数集合和随机源初始化密钥对生成器。
void | KeyPairGeneratorSpi.initialize(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集合和用户提供的随机源初始化密钥对生成器。
void | KeyPairGenerator.initialize(int keysize, SecureRandom random) 使用给定的随机源（和默认的参数集合）初始化确定密钥大小的密钥对生成器。
abstract void | KeyPairGeneratorSpi.initialize(int keysize, SecureRandom random) 使用默认参数集初始化确定密钥大小的密钥对生成器。
void | Signature.initSign(PrivateKey privateKey, SecureRandom random) 初始化这个用于签名的对象。

java.security.interfaces 中 SecureRandom 的使用

参数类型为 SecureRandom 的 java.security.interfaces 中的方法
void | DSAKeyPairGenerator.initialize(DSAParams params, SecureRandom random) 使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。
void | DSAKeyPairGenerator.initialize(int modlen, boolean genParams, SecureRandom random) 使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。

javax.crypto 中 SecureRandom 的使用

参数类型为 SecureRandom 的 javax.crypto 中的方法
protected abstract void | KeyGeneratorSpi.engineInit(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化密钥生成器。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 cipher。
protected abstract void | KeyGeneratorSpi.engineInit(int keysize, SecureRandom random) 使用给定随机源初始化此密钥生成器，以获取确定的密钥长度。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
protected abstract void | KeyAgreementSpi.engineInit(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协定。
protected abstract void | KeyGeneratorSpi.engineInit(SecureRandom random) 初始化该密钥生成器。
void | KeyGenerator.init(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化此密钥生成器。
void | Cipher.init(int opmode, Certificate certificate, SecureRandom random) 用取自给定证书的公钥和随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 Cipher。
void | KeyGenerator.init(int keysize, SecureRandom random) 使用用户提供的随机源初始化此密钥生成器，使其具有确定的密钥大小。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyAgreement.init(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协议。
void | KeyGenerator.init(SecureRandom random) 初始化此密钥生成器。

javax.net.ssl 中 SecureRandom 的使用

参数类型为 SecureRandom 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.SignedObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SignedObject
的使用

没有 java.security.SignedObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Signer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Signer
的使用

没有 java.security.Signer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Timestamp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Timestamp
的使用

使用 Timestamp 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Timestamp 的使用

返回 Timestamp 的 java.security 中的方法
 Timestamp CodeSigner.getTimestamp()
返回签名时间戳。

参数类型为 Timestamp 的 java.security 中的构造方法
CodeSigner(CertPath signerCertPath, Timestamp timestamp)
构造 CodeSigner 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.URIParameter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.URIParameter
的使用

没有 java.security.URIParameter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.UnrecoverableEntryException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.UnrecoverableEntryException
的使用

使用 UnrecoverableEntryException 的软件包
java.security 为安全框架提供类和接口。

java.security 中 UnrecoverableEntryException 的使用

java.security 中 UnrecoverableEntryException 的子类
 class UnrecoverableKeyException
如果 keystore 中的密钥无法恢复，则抛出此异常。

抛出 UnrecoverableEntryException 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.UnrecoverableKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.UnrecoverableKeyException
的使用

使用 UnrecoverableKeyException 的软件包
java.security | 为安全框架提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。

java.security 中 UnrecoverableKeyException 的使用

抛出 UnrecoverableKeyException 的 java.security 中的方法
abstract Key | KeyStoreSpi.engineGetKey(String alias, char[] password) 返回与给定别名关联的密钥，使用给定密码恢复它。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。

javax.net.ssl 中 UnrecoverableKeyException 的使用

抛出 UnrecoverableKeyException 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.InvalidKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.InvalidKeyException
的使用

使用 InvalidKeyException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.security.cert | 为公钥证书提供类。

java.security 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 java.security 中的方法
protected abstract void | SignatureSpi.engineInitSign(PrivateKey privateKey) 通过用于签名操作的指定私钥初始化此签名对象。
protected void | SignatureSpi.engineInitSign(PrivateKey privateKey, SecureRandom random) 通过用于签名操作的指定私钥和随机源初始化此签名对象。
protected abstract void | SignatureSpi.engineInitVerify(PublicKey publicKey) 通过用于验证操作的指定公钥初始化此签名对象。
protected abstract Key | KeyFactorySpi.engineTranslateKey(Key key) 将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
void | Signature.initSign(PrivateKey privateKey) 初始化这个用于签名的对象。
void | Signature.initSign(PrivateKey privateKey, SecureRandom random) 初始化这个用于签名的对象。
void | Signature.initVerify(Certificate certificate) 使用来自给定证书的公钥初始化此用于验证的对象。
void | Signature.initVerify(PublicKey publicKey) 初始化此用于验证的对象。
Key | KeyFactory.translateKey(Key key) 将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。
boolean | SignedObject.verify(PublicKey verificationKey, Signature verificationEngine) 使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

抛出 InvalidKeyException 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.cert 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 java.security.cert 中的方法
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.crypto 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 javax.crypto 中的方法
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
protected int | CipherSpi.engineGetKeySize(Key key) 返回给定密钥对象的密钥大小，以位为单位。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key) 用密钥初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
protected abstract void | KeyAgreementSpi.engineInit(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协定。
protected abstract SecretKey | SecretKeyFactorySpi.engineTranslateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
protected Key | CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 打开一个以前包装的密钥。
protected byte[] | CipherSpi.engineWrap(Key key) 将密钥包装。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
void | Cipher.init(int opmode, Certificate certificate) 用取自给定证书的公钥初始化此 Cipher。
void | Cipher.init(int opmode, Certificate certificate, SecureRandom random) 用取自给定证书的公钥和随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key) 用密钥初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key) 用密钥初始化此豁免机制。
void | KeyAgreement.init(Key key) 用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。
void | Mac.init(Key key) 用给定的密钥初始化此 Mac 对象。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyAgreement.init(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协议。
SecretKey | SecretKeyFactory.translateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。
Key | Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 解包一个以前包装的密钥。
byte[] | Cipher.wrap(Key key) 包装密钥。

javax.crypto.spec 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 javax.crypto.spec 中的方法
static boolean | DESKeySpec.isParityAdjusted(byte[] key, int offset) 确定给定的始于且包含 offset 的 DES 密钥内容是否是奇偶校验的 (parity-adjusted)。
static boolean | DESedeKeySpec.isParityAdjusted(byte[] key, int offset) 确定给定的始于且包含 offset 的 DES-EDE 密钥是否是奇偶校验的 (parity-adjusted)。
static boolean | DESKeySpec.isWeak(byte[] key, int offset) 确定给定的 DES 密钥内容是否是全弱或者半弱的。

抛出 InvalidKeyException 的 javax.crypto.spec 中的构造方法
DESedeKeySpec(byte[] key)
创建一个 DESedeKeySpec 对象，使用 key 中的前 24 个字节作为 DES-EDE 密钥的密钥内容。
DESedeKeySpec(byte[] key, int offset)
创建一个 DESedeKeySpec 对象，使用 key 中始于且包含 offset 的前 24 个字节作为 DES-EDE 密钥的密钥内容。
DESKeySpec(byte[] key)
创建一个 DESKeySpec 对象，使用 key 中的前 8 个字节作为 DES 密钥的密钥内容。
DESKeySpec(byte[] key, int offset)
创建一个 DESKeySpec 对象，使用 key 中始于且包含 offset 的前 8 个字节作为 DES-EDE 密钥的密钥内容。

javax.security.cert 中 InvalidKeyException 的使用

抛出 InvalidKeyException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyException
的使用

使用 KeyException 的软件包
java.security | 为安全框架提供类和接口。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

java.security 中 KeyException 的使用

java.security 中 KeyException 的子类
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。

抛出 KeyException 的 java.security 中的方法
void | Certificate.decode(InputStream stream) 已过时。 从输入流解码证书。
void | Certificate.encode(OutputStream stream) 已过时。 以 decode 方法可以解码的格式将证书编码到输出流。
void | Signer.setKeyPair(KeyPair pair) 已过时。 为此签署人设置密钥对（公钥和私钥）。

javax.xml.crypto.dsig.keyinfo 中 KeyException 的使用

抛出 KeyException 的 javax.xml.crypto.dsig.keyinfo 中的方法
PublicKey | KeyValue.getPublicKey() 返回此 KeyValue 的公钥。
abstract KeyValue | KeyInfoFactory.newKeyValue(PublicKey key) 根据指定的公钥创建 KeyValue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.SignatureException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SignatureException
的使用

使用 SignatureException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.security.cert | 为公钥证书提供类。

java.security 中 SignatureException 的使用

抛出 SignatureException 的 java.security 中的方法
protected abstract byte[] | SignatureSpi.engineSign() 返回迄今为止所有更新的数据的签名字节。
protected int | SignatureSpi.engineSign(byte[] outbuf, int offset, int len) 完成此签名操作，并从 offset 开始将得到的签名字节保存在提供的缓冲区 outbuf 中。
protected abstract void | SignatureSpi.engineUpdate(byte b) 使用指定的字节更新要签名或验证的数据。
protected abstract void | SignatureSpi.engineUpdate(byte[] b, int off, int len) 使用指定的 byte 数组，从指定的偏移量开始更新要签名或验证的数据。
protected abstract boolean | SignatureSpi.engineVerify(byte[] sigBytes) 验证传入的签名。
protected boolean | SignatureSpi.engineVerify(byte[] sigBytes, int offset, int length) 在指定的 byte 数组中，从指定的偏移量处开始，验证传入的签名。
byte[] | Signature.sign() 返回所有已更新数据的签名字节。
int | Signature.sign(byte[] outbuf, int offset, int len) 完成签名操作并从 offset 开始，将得到的签名字节存储在提供的缓冲区 outbuf 中。
void | Signature.update(byte b) 更新要由字节签名或验证的数据。
void | Signature.update(byte[] data) 使用指定的 byte 数组更新要签名或验证的数据。
void | Signature.update(byte[] data, int off, int len) 从指定的偏移量开始，使用指定的 byte 数组更新要签名或验证的数据。
void | Signature.update(ByteBuffer data) 使用指定的 ByteBuffer 更新要签名或验证的数据。
boolean | Signature.verify(byte[] signature) 验证传入的签名。
boolean | Signature.verify(byte[] signature, int offset, int length) 从指定的偏移量开始，验证指定的 byte 数组中传入的签名。
boolean | SignedObject.verify(PublicKey verificationKey, Signature verificationEngine) 使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

抛出 SignatureException 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.cert 中 SignatureException 的使用

抛出 SignatureException 的 java.security.cert 中的方法
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.security.cert 中 SignatureException 的使用

抛出 SignatureException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.InvalidParameterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.InvalidParameterException
的使用

使用 InvalidParameterException 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。

java.security 中 InvalidParameterException 的使用

抛出 InvalidParameterException 的 java.security 中的方法
protected abstract Object | SignatureSpi.engineGetParameter(String param) 已过时。
protected abstract void | SignatureSpi.engineSetParameter(String param, Object value) 已过时。 由 engineSetParameter 取代。
Object | Signature.getParameter(String param) 已过时。
void | Signer.setKeyPair(KeyPair pair) 已过时。 为此签署人设置密钥对（公钥和私钥）。
void | Signature.setParameter(String param, Object value) 已过时。 使用 setParameter 取代。

java.security.interfaces 中 InvalidParameterException 的使用

抛出 InvalidParameterException 的 java.security.interfaces 中的方法
void | DSAKeyPairGenerator.initialize(DSAParams params, SecureRandom random) 使用 DSA 系列参数（p、q 和 g）和可选 SecureRandom 位源初始化密钥对生成器。
void | DSAKeyPairGenerator.initialize(int modlen, boolean genParams, SecureRandom random) 使用给定系数长度（而不是参数）和可选 SecureRandom 位源初始化密钥对生成器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.SecurityPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecurityPermission
的使用

没有 java.security.SecurityPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.ProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.ProviderException
的使用

没有 java.security.ProviderException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AuthProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AuthProvider
的使用

没有 java.security.AuthProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.CodeSigner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.CodeSigner
的使用

使用 CodeSigner 的软件包
java.security | 为安全框架提供类和接口。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.security 中 CodeSigner 的使用

返回 CodeSigner 的 java.security 中的方法
 CodeSigner[] CodeSource.getCodeSigners()
返回与此 CodeSource 关联的代码签名者。

参数类型为 CodeSigner 的 java.security 中的构造方法
CodeSource(URL url, CodeSigner[] signers)
构造一个 CodeSource 并将其与指定位置和代码签名者集合相关联。

java.util.jar 中 CodeSigner 的使用

返回 CodeSigner 的 java.util.jar 中的方法
 CodeSigner[] JarEntry.getCodeSigners()
返回此条目的 CodeSigner 对象；如果没有，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Signature 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Signature
的使用

使用 Signature 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Signature 的使用

返回 Signature 的 java.security 中的方法
static Signature | Signature.getInstance(String algorithm) 返回实现指定签名算法的 Signature 对象。
static Signature | Signature.getInstance(String algorithm, Provider provider) 返回实现指定签名算法的 Signature 对象。
static Signature | Signature.getInstance(String algorithm, String provider) 返回实现指定签名算法的 Signature 对象。

参数类型为 Signature 的 java.security 中的方法
 boolean SignedObject.verify(PublicKey verificationKey, Signature verificationEngine)
使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

参数类型为 Signature 的 java.security 中的构造方法
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.SignatureSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SignatureSpi
的使用

使用 SignatureSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 SignatureSpi 的使用

java.security 中 SignatureSpi 的子类
 class Signature
此 Signature 类用来为应用程序提供数字签名算法功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AlgorithmParametersSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParametersSpi
的使用

使用 AlgorithmParametersSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 AlgorithmParametersSpi 的使用

参数类型为 AlgorithmParametersSpi 的 java.security 中的构造方法
AlgorithmParameters(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameters 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AlgorithmParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AlgorithmParameters
的使用

使用 AlgorithmParameters 的软件包
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。

java.security 中 AlgorithmParameters 的使用

返回 AlgorithmParameters 的 java.security 中的方法
protected abstract AlgorithmParameters | AlgorithmParameterGeneratorSpi.engineGenerateParameters() 生成参数。
protected AlgorithmParameters | SignatureSpi.engineGetParameters() 此方法将由提供者重写，以返回与此签名引擎配合使用的参数，如果此签名引擎未使用任何参数，则返回 null。
AlgorithmParameters | AlgorithmParameterGenerator.generateParameters() 生成参数。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm) 返回指定算法的参数对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, Provider provider) 返回指定算法的参数对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, String provider) 返回指定算法的参数对象。
AlgorithmParameters | Signature.getParameters() 返回与此签名对象一起使用的参数。

javax.crypto 中 AlgorithmParameters 的使用

返回 AlgorithmParameters 的 javax.crypto 中的方法
protected abstract AlgorithmParameters | CipherSpi.engineGetParameters() 返回此 cipher 使用的参数。
AlgorithmParameters | EncryptedPrivateKeyInfo.getAlgParameters() 返回加密算法使用的算法参数。
AlgorithmParameters | Cipher.getParameters() 返回此 Cipher 使用的参数。

参数类型为 AlgorithmParameters 的 javax.crypto 中的方法
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。

参数类型为 AlgorithmParameters 的 javax.crypto 中的构造方法
EncryptedPrivateKeyInfo(AlgorithmParameters algParams, byte[] encryptedData)
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.PrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PrivateKey
的使用

使用 PrivateKey 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.security 中 PrivateKey 的使用

返回 PrivateKey 的 java.security 中的方法
protected abstract PrivateKey | KeyFactorySpi.engineGeneratePrivate(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成私钥对象。
PrivateKey | KeyFactory.generatePrivate(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成私钥对象。
PrivateKey | KeyPair.getPrivate() 返回对此密钥对的私钥组件的引用。
PrivateKey | KeyStore.PrivateKeyEntry.getPrivateKey() 从此项获取 PrivateKey。
PrivateKey | Signer.getPrivateKey() 已过时。 返回此 signer 的私钥。

参数类型为 PrivateKey 的 java.security 中的方法
protected abstract void | SignatureSpi.engineInitSign(PrivateKey privateKey) 通过用于签名操作的指定私钥初始化此签名对象。
protected void | SignatureSpi.engineInitSign(PrivateKey privateKey, SecureRandom random) 通过用于签名操作的指定私钥和随机源初始化此签名对象。
void | Signature.initSign(PrivateKey privateKey) 初始化这个用于签名的对象。
void | Signature.initSign(PrivateKey privateKey, SecureRandom random) 初始化这个用于签名的对象。

参数类型为 PrivateKey 的 java.security 中的构造方法
KeyPair(PublicKey publicKey, PrivateKey privateKey)
根据给定的公钥和私钥构造密钥对。
KeyStore.PrivateKeyEntry(PrivateKey privateKey, Certificate[] chain)
构造带 PrivateKey 和相应证书链的 PrivateKeyEntry。
SignedObject(Serializable object, PrivateKey signingKey, Signature signingEngine)
通过任何可序列化对象构造 SignedObject。

java.security.interfaces 中 PrivateKey 的使用

java.security.interfaces 中 PrivateKey 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。

javax.crypto.interfaces 中 PrivateKey 的使用

javax.crypto.interfaces 中 PrivateKey 的子接口
 interface DHPrivateKey
Diffie-Hellman 私钥接口。

javax.net.ssl 中 PrivateKey 的使用

返回 PrivateKey 的 javax.net.ssl 中的方法
 PrivateKey X509KeyManager.getPrivateKey(String alias)
返回与给定别名关联的密钥。

javax.security.auth.x500 中 PrivateKey 的使用

返回 PrivateKey 的 javax.security.auth.x500 中的方法
 PrivateKey X500PrivateCredential.getPrivateKey()
返回 PrivateKey。

参数类型为 PrivateKey 的 javax.security.auth.x500 中的构造方法
X500PrivateCredential(X509Certificate cert, PrivateKey key)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyFactorySpi
的使用

使用 KeyFactorySpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyFactorySpi 的使用

参数类型为 KeyFactorySpi 的 java.security 中的构造方法
KeyFactory(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 KeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.KeyFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.KeyFactory
的使用

使用 KeyFactory 的软件包
java.security 为安全框架提供类和接口。

java.security 中 KeyFactory 的使用

返回 KeyFactory 的 java.security 中的方法
static KeyFactory | KeyFactory.getInstance(String algorithm) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.PublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PublicKey
的使用

使用 PublicKey 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.security.cert | 为公钥证书提供类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。

java.security 中 PublicKey 的使用

返回 PublicKey 的 java.security 中的方法
protected abstract PublicKey | KeyFactorySpi.engineGeneratePublic(KeySpec keySpec) 根据所提供的密钥规范（密钥材料）生成公钥对象。
PublicKey | KeyFactory.generatePublic(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成公钥对象。
PublicKey | KeyPair.getPublic() 返回对此密钥对的公钥组件的引用。
PublicKey | Certificate.getPublicKey() 已过时。 返回保证人所保证的主体密钥对的密钥。
PublicKey | Identity.getPublicKey() 已过时。 返回此 Identity 的公钥。

参数类型为 PublicKey 的 java.security 中的方法
protected abstract void | SignatureSpi.engineInitVerify(PublicKey publicKey) 通过用于验证操作的指定公钥初始化此签名对象。
abstract Identity | IdentityScope.getIdentity(PublicKey key) 已过时。 获取具有指定公钥的身份。
void | Signature.initVerify(PublicKey publicKey) 初始化此用于验证的对象。
void | Identity.setPublicKey(PublicKey key) 已过时。 设置此 Identity 的公钥。
boolean | SignedObject.verify(PublicKey verificationKey, Signature verificationEngine) 使用指派的验证引擎，通过给定的验证密钥验证此 SignedObject 中的签名是否为内部存储对象的有效签名。

参数类型为 PublicKey 的 java.security 中的构造方法
KeyPair(PublicKey publicKey, PrivateKey privateKey)
根据给定的公钥和私钥构造密钥对。

java.security.cert 中 PublicKey 的使用

返回 PublicKey 的 java.security.cert 中的方法
PublicKey | TrustAnchor.getCAPublicKey() 返回最受信任的 CA 的公钥。
PublicKey | PKIXCertPathValidatorResult.getPublicKey() 返回证书路径主体（目标）的公钥，如果适用，要包括所有继承的公钥参数。
abstract PublicKey | Certificate.getPublicKey() 从此证书中获取公钥。
PublicKey | X509CertSelector.getSubjectPublicKey() 返回 subjectPublicKey 标准。

参数类型为 PublicKey 的 java.security.cert 中的方法
void | X509CertSelector.setSubjectPublicKey(PublicKey key) 设置 subjectPublicKey 标准。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

参数类型为 PublicKey 的 java.security.cert 中的构造方法
PKIXCertPathBuilderResult(CertPath certPath, TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathBuilderResult 实例。
PKIXCertPathValidatorResult(TrustAnchor trustAnchor, PolicyNode policyTree, PublicKey subjectPublicKey)
创建包含指定参数的 PKIXCertPathValidatorResult 实例。
TrustAnchor(String caName, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以不同的名称和公钥的形式指定最受信任的 CA。
TrustAnchor(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。

java.security.interfaces 中 PublicKey 的使用

java.security.interfaces 中 PublicKey 的子接口
interface | DSAPublicKey DSA 公用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

javax.crypto.interfaces 中 PublicKey 的使用

javax.crypto.interfaces 中 PublicKey 的子接口
 interface DHPublicKey
Diffie-Hellman 公钥接口。

javax.security.cert 中 PublicKey 的使用

返回 PublicKey 的 javax.security.cert 中的方法
abstract  PublicKey Certificate.getPublicKey()
从此证书中获取公钥。

参数类型为 PublicKey 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

javax.xml.crypto.dsig.keyinfo 中 PublicKey 的使用

返回 PublicKey 的 javax.xml.crypto.dsig.keyinfo 中的方法
 PublicKey KeyValue.getPublicKey()
返回此 KeyValue 的公钥。

参数类型为 PublicKey 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract  KeyValue KeyInfoFactory.newKeyValue(PublicKey key)
根据指定的公钥创建 KeyValue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.Key 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Key
的使用

使用 Key 的软件包
java.security | 为安全框架提供类和接口。
java.security.interfaces | 提供的接口用于生成 RSA Laboratory Technical Note PKCS#1 中定义的 RSA（Rivest、Shamir 和 Adleman AsymmetricCipher 算法）密钥，以及 NIST 的 FIPS-186 中定义的 DSA（数字签名算法）密钥。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dsig.dom | javax.xml.crypto.dsig 包特定于 DOM 的类。

java.security 中 Key 的使用

java.security 中 Key 的子接口
interface | PrivateKey 私钥。
interface | PublicKey 公钥。

返回 Key 的 java.security 中的方法
abstract Key | KeyStoreSpi.engineGetKey(String alias, char[] password) 返回与给定别名关联的密钥，使用给定密码恢复它。
protected abstract Key | KeyFactorySpi.engineTranslateKey(Key key) 将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。
Key | KeyFactory.translateKey(Key key) 将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。

参数类型为 Key 的 java.security 中的方法
protected abstract
<T extends KeySpec>
T
KeyFactorySpi.engineGetKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
abstract  void KeyStoreSpi.engineSetKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，用给定的密码保护它。
protected abstract  Key KeyFactorySpi.engineTranslateKey(Key key)
将其 provider 可能是未知的或可能不受信任的密钥对象转换成此密钥工厂的相应密钥对象。
<T extends KeySpec>
T
KeyFactory.getKeySpec(Key key, Class<T> keySpec)
返回给定密钥对象的规范（密钥材料）。
 void KeyStore.setKeyEntry(String alias, Key key, char[] password, Certificate[] chain)
将给定的密钥分配给给定的别名，并用给定密码保护它。
 Key KeyFactory.translateKey(Key key)
将提供者可能未知或不受信任的密钥对象转换成此密钥工厂对应的密钥对象。

java.security.interfaces 中 Key 的使用

java.security.interfaces 中 Key 的子接口
interface | DSAPrivateKey DSA 专用密钥的标准接口。
interface | DSAPublicKey DSA 公用密钥的接口。
interface | ECPrivateKey 椭圆曲线 (EC) 专用密钥的接口。
interface | ECPublicKey 椭圆曲线 (EC) 公用密钥的接口。
interface | RSAMultiPrimePrivateCrtKey 如 PKCS#1 v2.1 中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 多素数专用密钥的接口。
interface | RSAPrivateCrtKey 如 PKCS#1 标准中所定义的，使用 Chinese Remainder Theorem (CRT) 信息值的 RSA 专用密钥的接口。
interface | RSAPrivateKey RSA 专用密钥的接口。
interface | RSAPublicKey RSA 公用密钥的接口。

javax.crypto 中 Key 的使用

javax.crypto 中 Key 的子接口
 interface SecretKey
秘密（对称）密钥。

返回 Key 的 javax.crypto 中的方法
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected Key | CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 打开一个以前包装的密钥。
Key | Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 解包一个以前包装的密钥。

参数类型为 Key 的 javax.crypto 中的方法
Key | KeyAgreement.doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
protected abstract Key | KeyAgreementSpi.engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected int | CipherSpi.engineGetKeySize(Key key) 返回给定密钥对象的密钥大小，以位为单位。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | CipherSpi.engineInit(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 cipher。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key) 用密钥初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | MacSpi.engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | KeyAgreementSpi.engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
protected abstract void | KeyAgreementSpi.engineInit(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协定。
protected byte[] | CipherSpi.engineWrap(Key key) 将密钥包装。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
void | Cipher.init(int opmode, Key key) 用密钥初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | Cipher.init(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 Cipher。
void | ExemptionMechanism.init(Key key) 用密钥初始化此豁免机制。
void | KeyAgreement.init(Key key) 用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。
void | Mac.init(Key key) 用给定的密钥初始化此 Mac 对象。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | Mac.init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | KeyAgreement.init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | KeyAgreement.init(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协议。
boolean | ExemptionMechanism.isCryptoAllowed(Key key) 返回此豁免机制是否已成功生成结果 blob。
byte[] | Cipher.wrap(Key key) 包装密钥。

javax.crypto.interfaces 中 Key 的使用

javax.crypto.interfaces 中 Key 的子接口
interface | DHPrivateKey Diffie-Hellman 私钥接口。
interface | DHPublicKey Diffie-Hellman 公钥接口。
interface | PBEKey 调用者 PBE 密钥接口。

javax.crypto.spec 中 Key 的使用

实现 Key 的 javax.crypto.spec 中的类
 class SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

javax.security.auth.kerberos 中 Key 的使用

实现 Key 的 javax.security.auth.kerberos 中的类
 class KerberosKey
此类为 Kerberos 主体封装一个长期秘密密钥。

javax.xml.crypto 中 Key 的使用

返回 Key 的 javax.xml.crypto 中的方法
 Key KeySelectorResult.getKey()
返回选定的密钥。

参数类型为 Key 的 javax.xml.crypto 中的方法
static KeySelector KeySelector.singletonKeySelector(Key key)
返回一个总是选择指定密钥的 KeySelector，不管传递给它的 KeyInfo 是什么。

javax.xml.crypto.dsig.dom 中 Key 的使用

参数类型为 Key 的 javax.xml.crypto.dsig.dom 中的构造方法
DOMSignContext(Key signingKey, Node parent)
创建带有指定签名密钥和父节点的 DOMSignContext。
DOMSignContext(Key signingKey, Node parent, Node nextSibling)
创建带有指定的签名密钥、父节点和下一个兄弟节点的 DOMSignContext。
DOMValidateContext(Key validatingKey, Node node)
创建包含指定密钥和节点的 DOMValidateContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.MessageDigest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.MessageDigest
的使用

使用 MessageDigest 的软件包
java.security 为安全框架提供类和接口。

java.security 中 MessageDigest 的使用

声明为 MessageDigest 的 java.security 中的字段
protected MessageDigest | DigestInputStream.digest 与此流关联的消息摘要。
protected MessageDigest | DigestOutputStream.digest 与此流关联的消息摘要。

返回 MessageDigest 的 java.security 中的方法
static MessageDigest | MessageDigest.getInstance(String algorithm) 返回实现指定摘要算法的 MessageDigest 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, Provider provider) 返回实现指定摘要算法的 MessageDigest 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, String provider) 返回实现指定摘要算法的 MessageDigest 对象。
MessageDigest | DigestInputStream.getMessageDigest() 返回与此流关联的消息摘要。
MessageDigest | DigestOutputStream.getMessageDigest() 返回与此流关联的消息摘要。

参数类型为 MessageDigest 的 java.security 中的方法
void | DigestInputStream.setMessageDigest(MessageDigest digest) 将指定的消息摘要与此流相关联。
void | DigestOutputStream.setMessageDigest(MessageDigest digest) 将指定的消息摘要与此流相关联。

参数类型为 MessageDigest 的 java.security 中的构造方法
DigestInputStream(InputStream stream, MessageDigest digest)
使用指定的输入流和消息摘要创建一个摘要输入流。
DigestOutputStream(OutputStream stream, MessageDigest digest)
使用指定的输出流和消息摘要创建一个摘要输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.MessageDigestSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.MessageDigestSpi
的使用

使用 MessageDigestSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 MessageDigestSpi 的使用

java.security 中 MessageDigestSpi 的子类
 class MessageDigest
此 MessageDigest 类为应用程序提供信息摘要算法的功能，如 MD5 或 SHA 算法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.NoSuchAlgorithmException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.NoSuchAlgorithmException
的使用

使用 NoSuchAlgorithmException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.cert | 为公钥证书提供类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。

java.security 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 java.security 中的方法
KeyStore.Entry | KeyStoreSpi.engineGetEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 KeyStore.Entry。
abstract Key | KeyStoreSpi.engineGetKey(String alias, char[] password) 返回与给定别名关联的密钥，使用给定密码恢复它。
abstract void | KeyStoreSpi.engineLoad(InputStream stream, char[] password) 从给定的输入流中加载此 KeyStore。
void | KeyStoreSpi.engineLoad(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParameter 加载该 keystore。
void | KeyStoreSpi.engineStore(KeyStore.LoadStoreParameter param) 使用给定的 KeyStore.LoadStoreParmeter 存储此 keystore。
abstract void | KeyStoreSpi.engineStore(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流中，并用给定的密码保护其完整性。
KeyStore.Entry | KeyStore.getEntry(String alias, KeyStore.ProtectionParameter protParam) 使用指定保护参数获取指定别名的 keystore Entry。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm) 返回实现指定摘要算法的 MessageDigest 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, Provider provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, Provider provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, Provider provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, Provider provider) 返回实现指定摘要算法的 MessageDigest 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, String provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, String provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, String provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, String provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, String provider) 返回实现指定摘要算法的 MessageDigest 对象。
Key | KeyStore.getKey(String alias, char[] password) 返回与给定别名关联的密钥，并用给定密码来恢复它。
void | KeyStore.load(InputStream stream, char[] password) 从给定输入流中加载此 KeyStore。
void | KeyStore.load(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 加载此 keystore。
Object | Provider.Service.newInstance(Object constructorParameter) 返回此服务描述的实现的新实例。
void | KeyStore.store(KeyStore.LoadStoreParameter param) 使用给定 LoadStoreParameter 存储此 keystore。
void | KeyStore.store(OutputStream stream, char[] password) 将此 keystore 存储到给定输出流，并用给定密码保护其完整性。

java.security.cert 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 java.security.cert 中的方法
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm) 返回实现了指定算法的 CertPathValidator 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params) 返回一个实现指定 CertStore 类型，并已使用指定参数初始化的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, String provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, Provider provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, Provider provider) 返回实现指定算法的 CertPathValidator 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, String provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, String provider) 返回实现指定算法的 CertPathValidator 对象。
abstract void | X509CRL.verify(PublicKey key) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相应的私钥签署了此证书。
abstract void | X509CRL.verify(PublicKey key, String sigProvider) 验证是否已使用与给定公钥相应的私钥签署了此 CRL。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相应的私钥签署了此证书。

javax.crypto 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.crypto 中的方法
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
protected abstract void | CipherSpi.engineSetMode(String mode) 设置此 cipher 的模式。
protected Key | CipherSpi.engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 打开一个以前包装的密钥。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
static Cipher | Cipher.getInstance(String transformation) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, Provider provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, Provider provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, Provider provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, String provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, String provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, String provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
static int | Cipher.getMaxAllowedKeyLength(String transformation) 根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。
static AlgorithmParameterSpec | Cipher.getMaxAllowedParameterSpec(String transformation) 根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。
Object | SealedObject.getObject(Key key) 获取原始（封装的）对象。
Object | SealedObject.getObject(Key key, String provider) 获取原始（封装的）对象。
Key | Cipher.unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 解包一个以前包装的密钥。

抛出 NoSuchAlgorithmException 的 javax.crypto 中的构造方法
EncryptedPrivateKeyInfo(AlgorithmParameters algParams, byte[] encryptedData)
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(String algName, byte[] encryptedData)
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。

javax.net.ssl 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
static SSLContext | SSLContext.getDefault() 返回默认的 SSL 上下文。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, Provider provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, Provider provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, Provider provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, String provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, String provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, String provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
void | KeyManagerFactory.init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。

javax.security.auth.login 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.security.auth.login 中的方法
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, Provider provider) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, String provider) 返回指定类型的 Configuration 对象。

javax.security.cert 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.security.cert 中的方法
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

javax.xml.crypto.dsig 中 NoSuchAlgorithmException 的使用

抛出 NoSuchAlgorithmException 的 javax.xml.crypto.dsig 中的方法
static TransformService | TransformService.getInstance(String algorithm, String mechanismType) 返回支持指定算法 URI 的 TransformService（比如：Transform.XPATH2）和机制类型（比如：DOM）。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, Provider provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, String provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, C14NMethodParameterSpec params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract CanonicalizationMethod | XMLSignatureFactory.newCanonicalizationMethod(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 CanonicalizationMethod。
abstract DigestMethod | XMLSignatureFactory.newDigestMethod(String algorithm, DigestMethodParameterSpec params) 针对指定的算法 URI 和参数创建 DigestMethod。
abstract SignatureMethod | XMLSignatureFactory.newSignatureMethod(String algorithm, SignatureMethodParameterSpec params) 针对指定的算法 URI 和参数创建 SignatureMethod。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, TransformParameterSpec params) 针对指定的算法 URI 和参数创建 Transform。
abstract Transform | XMLSignatureFactory.newTransform(String algorithm, XMLStructure params) 针对指定的算法 URI 和参数创建 Transform。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.GeneralSecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.GeneralSecurityException
的使用

使用 GeneralSecurityException 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.security.spec | 提供密钥规范和算法参数规范的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。

java.security 中 GeneralSecurityException 的使用

java.security 中 GeneralSecurityException 的子类
class | DigestException 此为一般 Message Digest 异常。
class | InvalidAlgorithmParameterException 用于无效或不合适的算法参数的异常。
class | InvalidKeyException 用于无效 Key（无效的编码、错误的长度、未初始化等）的异常。
class | KeyException 此异常是基本的密钥异常。
class | KeyManagementException 此异常是用于所有处理密钥管理的操作的通用密钥管理异常。
class | KeyStoreException 这是一般的 KeyStore 异常。
class | NoSuchAlgorithmException 当请求特定的加密算法而它在该环境中不可用时抛出此异常。
class | NoSuchProviderException 当请求特定安全性 provider 但它在该环境中不可用时抛出此异常。
class | SignatureException 这是一般的签名异常。
class | UnrecoverableEntryException 如果 keystore 中的某项无法恢复，则抛出此异常。
class | UnrecoverableKeyException 如果 keystore 中的密钥无法恢复，则抛出此异常。

java.security.cert 中 GeneralSecurityException 的使用

java.security.cert 中 GeneralSecurityException 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateException 此异常指示各种证书问题中的一种。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书尚无效异常。
class | CertificateParsingException 证书解析异常。
class | CertPathBuilderException 指示在使用 CertPathBuilder 构建证书路径时遇到了某种问题的异常。
class | CertPathValidatorException 指示在验证一个证书路径时遇到了某种问题的异常。
class | CertStoreException 指示从 CertStore 中获取证书和 CRL 时遇到了某种问题的异常。
class | CRLException CRL（证书撤消列表）异常。

java.security.spec 中 GeneralSecurityException 的使用

java.security.spec 中 GeneralSecurityException 的子类
class | InvalidKeySpecException 这是针对无效密钥规范的异常。
class | InvalidParameterSpecException 这是针对无效参数规范的异常。

javax.crypto 中 GeneralSecurityException 的使用

javax.crypto 中 GeneralSecurityException 的子类
class | BadPaddingException 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
class | ExemptionMechanismException 此为一般 ExemptionMechanism 异常。
class | IllegalBlockSizeException 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
class | NoSuchPaddingException 当请求特定填充机制但该环境中未提供时，抛出此异常。
class | ShortBufferException 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

javax.security.auth.login 中 GeneralSecurityException 的使用

javax.security.auth.login 中 GeneralSecurityException 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。
class | LoginException 此异常是基本的登录异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.SecureRandomSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecureRandomSpi
的使用

使用 SecureRandomSpi 的软件包
java.security 为安全框架提供类和接口。

java.security 中 SecureRandomSpi 的使用

参数类型为 SecureRandomSpi 的 java.security 中的构造方法
SecureRandom(SecureRandomSpi secureRandomSpi, Provider provider)
创建 SecureRandom 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Security 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Security
的使用

没有 java.security.Security 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Policy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Policy
的使用

使用 Policy 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Policy 的使用

返回 Policy 的 java.security 中的方法
static Policy | Policy.getInstance(String type, Policy.Parameters params) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getPolicy() 返回安装的 Policy 对象。

参数类型为 Policy 的 java.security 中的方法
static void Policy.setPolicy(Policy p)
设置系统范围的 Policy 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Provider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Provider
的使用

使用 Provider 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
org.ietf.jgss | 此包提供一个框架，该框架允许应用程序开发人员通过利用统一的 API 使用一些来自各种基础安全机制（如 Kerberos）的安全服务，如验证、数据完整性和和数据机密性。

java.security 中 Provider 的使用

java.security 中 Provider 的子类
 class AuthProvider
此类定义 provider 的登录和注销方法。

返回 Provider 的 java.security 中的方法
Provider | AlgorithmParameterGenerator.getProvider() 返回此算法参数生成器对象的提供者。
Provider | KeyPairGenerator.getProvider() 返回此密钥对生成器对象的提供者。
Provider | KeyStore.getProvider() 返回此 keystore 的提供者。
Provider | SecureRandom.getProvider() 返回此 SecureRandom 对象的提供者。
Provider | Signature.getProvider() 返回此签名对象的提供者。
Provider | AlgorithmParameters.getProvider() 返回此参数对象的提供者。
Provider | KeyFactory.getProvider() 返回此密钥工厂对象的提供者。
Provider | MessageDigest.getProvider() 返回此信息摘要对象的提供者。
Provider | Provider.Service.getProvider() 返回此服务的 Provider。
Provider | Policy.getProvider() 返回此 Policy 的 Provider。
static Provider | Security.getProvider(String name) 返回使用指定的名称安装的提供者（如果有）。
static Provider[] | Security.getProviders() 返回包含所有已安装的提供者的数组。
static Provider[] | Security.getProviders(Map<String,String> filter) 返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
static Provider[] | Security.getProviders(String filter) 返回包含满足指定的选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。

参数类型为 Provider 的 java.security 中的方法
static int | Security.addProvider(Provider provider) 将提供者添加到下一个可用位置。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static AlgorithmParameterGenerator | AlgorithmParameterGenerator.getInstance(String algorithm, Provider provider) 返回生成与指定算法一起使用的参数集的 AlgorithmParameterGenerator 对象。
static KeyPairGenerator | KeyPairGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的 public/private 密钥对的 KeyPairGenerator 对象。
static KeyStore | KeyStore.getInstance(String type, Provider provider) 返回指定类型的 keystore 对象。
static SecureRandom | SecureRandom.getInstance(String algorithm, Provider provider) 返回实现指定随机数生成器 (RNG) 算法的 SecureRandom 对象。
static Signature | Signature.getInstance(String algorithm, Provider provider) 返回实现指定签名算法的 Signature 对象。
static AlgorithmParameters | AlgorithmParameters.getInstance(String algorithm, Provider provider) 返回指定算法的参数对象。
static KeyFactory | KeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的 public/private 关键字的 KeyFactory 对象。
static MessageDigest | MessageDigest.getInstance(String algorithm, Provider provider) 返回实现指定摘要算法的 MessageDigest 对象。
static int | Security.insertProviderAt(Provider provider, int position) 在指定的位置添加新的提供者。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, File file, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。
static KeyStore.Builder | KeyStore.Builder.newInstance(String type, Provider provider, KeyStore.ProtectionParameter protection) 返回新的 Builder 对象。

参数类型为 Provider 的 java.security 中的构造方法
AlgorithmParameterGenerator(AlgorithmParameterGeneratorSpi paramGenSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameterGenerator 对象。
AlgorithmParameters(AlgorithmParametersSpi paramSpi, Provider provider, String algorithm)
创建一个 AlgorithmParameters 对象。
KeyFactory(KeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 KeyFactory 对象。
KeyStore(KeyStoreSpi keyStoreSpi, Provider provider, String type)
创建给定类型的 KeyStore 对象，并在其中封装给定的提供者实现（SPI 对象）。
Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。
SecureRandom(SecureRandomSpi secureRandomSpi, Provider provider)
创建 SecureRandom 对象。

java.security.cert 中 Provider 的使用

返回 Provider 的 java.security.cert 中的方法
Provider | CertPathBuilder.getProvider() 返回此 CertPathBuilder 的提供者。
Provider | CertPathValidator.getProvider() 返回此 CertPathValidator 的 Provider。
Provider | CertStore.getProvider() 返回此 CertStore 的提供者。
Provider | CertificateFactory.getProvider() 返回此 CertificateFactory 的提供者。

参数类型为 Provider 的 java.security.cert 中的方法
static CertStore | CertStore.getInstance(String type, CertStoreParameters params, Provider provider) 返回一个实现指定 CertStore 类型的 CertStore 对象。
static CertPathBuilder | CertPathBuilder.getInstance(String algorithm, Provider provider) 返回实现了指定算法的 CertPathBuilder 对象。
static CertPathValidator | CertPathValidator.getInstance(String algorithm, Provider provider) 返回实现指定算法的 CertPathValidator 对象。
static CertificateFactory | CertificateFactory.getInstance(String type, Provider provider) 返回指定证书类型的 CertificateFactory 对象。

参数类型为 Provider 的 java.security.cert 中的构造方法
CertificateFactory(CertificateFactorySpi certFacSpi, Provider provider, String type)
创建给定类型的 CertificateFactory 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathBuilder(CertPathBuilderSpi builderSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathBuilder 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertPathValidator(CertPathValidatorSpi validatorSpi, Provider provider, String algorithm)
创建一个给定算法的 CertPathValidator 对象，并在其中封装给定的提供者实现（SPI 对象）。
CertStore(CertStoreSpi storeSpi, Provider provider, String type, CertStoreParameters params)
创建一个给定类型的 CertStore 对象，并在其中封装给定提供者实现（SPI 对象）。

javax.crypto 中 Provider 的使用

返回 Provider 的 javax.crypto 中的方法
Provider | Cipher.getProvider() 返回此 Cipher 对象的提供者。
Provider | ExemptionMechanism.getProvider() 返回此 ExemptionMechanism 对象的提供者。
Provider | KeyAgreement.getProvider() 返回此 KeyAgreement 对象的提供者。
Provider | KeyGenerator.getProvider() 返回此 KeyGenerator 对象的提供者。
Provider | Mac.getProvider() 返回此 Mac 对象的提供者。
Provider | SecretKeyFactory.getProvider() 返回此 SecretKeyFactory 对象的提供者。

参数类型为 Provider 的 javax.crypto 中的方法
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, Provider provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, Provider provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static Mac | Mac.getInstance(String algorithm, Provider provider) 返回实现指定 MAC 算法的 Mac 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

参数类型为 Provider 的 javax.crypto 中的构造方法
Cipher(CipherSpi cipherSpi, Provider provider, String transformation)
创建 Cipher 对象。
ExemptionMechanism(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
创建 ExemptionMechanism 对象。
KeyAgreement(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
创建一个 KeyAgreement 对象。
KeyGenerator(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
创建一个 KeyGenerator 对象。
Mac(MacSpi macSpi, Provider provider, String algorithm)
创建一个 MAC 对象。
SecretKeyFactory(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 SecretKeyFactory 对象。

javax.net.ssl 中 Provider 的使用

返回 Provider 的 javax.net.ssl 中的方法
Provider | KeyManagerFactory.getProvider() 返回此 KeyManagerFactory 对象的提供者。
Provider | SSLContext.getProvider() 返回此 SSLContext 对象的提供者。
Provider | TrustManagerFactory.getProvider() 返回此 TrustManagerFactory 对象的提供者。

参数类型为 Provider 的 javax.net.ssl 中的方法
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, Provider provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static SSLContext | SSLContext.getInstance(String protocol, Provider provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, Provider provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。

参数类型为 Provider 的 javax.net.ssl 中的构造方法
KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 KeyManagerFactory 对象。
SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
创建 SSLContext 对象。
TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 TrustManagerFactory 对象。

javax.security.auth.login 中 Provider 的使用

返回 Provider 的 javax.security.auth.login 中的方法
 Provider Configuration.getProvider()
返回此 Configuration 的 Provider。

参数类型为 Provider 的 javax.security.auth.login 中的方法
static Configuration Configuration.getInstance(String type, Configuration.Parameters params, Provider provider)
返回指定类型的 Configuration 对象。

javax.xml.crypto.dsig 中 Provider 的使用

返回 Provider 的 javax.xml.crypto.dsig 中的方法
Provider | TransformService.getProvider() 返回此 TransformService 的提供者。
Provider | XMLSignatureFactory.getProvider() 返回此 XMLSignatureFactory 的提供者。

参数类型为 Provider 的 javax.xml.crypto.dsig 中的方法
static XMLSignatureFactory | XMLSignatureFactory.getInstance(String mechanismType, Provider provider) 返回支持请求的 XML 处理机制和表示形式类型（比如：“DOM”）的 XMLSignatureFactory，由指定提供者提供。
static TransformService | TransformService.getInstance(String algorithm, String mechanismType, Provider provider) 返回支持指定算法 URI（比如：Transform.XPATH2）和机制类型（比如：DOM）的 TransformService，由指定提供者提供。

javax.xml.crypto.dsig.keyinfo 中 Provider 的使用

返回 Provider 的 javax.xml.crypto.dsig.keyinfo 中的方法
 Provider KeyInfoFactory.getProvider()
返回此 KeyInfoFactory 的提供者。

参数类型为 Provider 的 javax.xml.crypto.dsig.keyinfo 中的方法
static KeyInfoFactory KeyInfoFactory.getInstance(String mechanismType, Provider provider)
返回支持所需的 XML 处理机制和表示形式类型（比如：“DOM”）的 KeyInfoFactory，由指定提供者提供。

org.ietf.jgss 中 Provider 的使用

参数类型为 Provider 的 org.ietf.jgss 中的方法
abstract void | GSSManager.addProviderAtEnd(Provider p, Oid mech) 此方法用于向 GSSManager 指示，如果没有其他的提供者支持指定的机制，则应用程序将使用特定的提供者。
abstract void | GSSManager.addProviderAtFront(Provider p, Oid mech) 此方法用来向 GSSManager 表示，当支持是指定的机制所需要的支持时，应用程序希望优先于其他所有提供者使用特定的提供者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Provider.Service 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Provider.Service
的使用

使用 Provider.Service 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Provider.Service 的使用

返回 Provider.Service 的 java.security 中的方法
 Provider.Service Provider.getService(String type, String algorithm)
获取描述此算法或别名的指定类型的此 Provider 实现的服务。

返回变量类型为 Provider.Service 的类型的 java.security 中的方法
 Set<Provider.Service> Provider.getServices()
获取此 Provider 支持的所有服务的一个不可修改的 Set。

参数类型为 Provider.Service 的 java.security 中的方法
protected  void Provider.putService(Provider.Service s)
添加服务。
protected  void Provider.removeService(Provider.Service s)
移除以前用 putService() 添加的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.Principal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Principal
的使用

使用 Principal 的软件包
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.cert | 为公钥证书提供类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.net 中 Principal 的使用

返回 Principal 的 java.net 中的方法
abstract Principal | SecureCacheResponse.getLocalPrincipal() 返回在获得了网络资源的初始连接中的联络期间发送到服务器的主体。
abstract Principal | SecureCacheResponse.getPeerPrincipal() 返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。

java.security 中 Principal 的使用

实现 Principal 的 java.security 中的类
class | Identity 已过时。 不再使用此类。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | IdentityScope 已过时。 此类不再被使用。其功能已经由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 取代。
class | Signer 已过时。 将不再使用此类。其功能已由 java.security.KeyStore、java.security.cert 包和 java.security.Principal 所取代。

返回 Principal 的 java.security 中的方法
Principal | Certificate.getGuarantor() 已过时。 返回证书的保证人，即某个主体，其保证与此证书关联的公钥是与此证书关联的主体的公钥。
Principal | Certificate.getPrincipal() 已过时。 返回保证人所保证的主体密钥对的主体。
Principal[] | ProtectionDomain.getPrincipals() 返回此域的 principals 数组。

参数类型为 Principal 的 java.security 中的方法
 Identity IdentityScope.getIdentity(Principal principal)
已过时。 获取名称与指定的主体相同的身份。

参数类型为 Principal 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。

java.security.acl 中 Principal 的使用

java.security.acl 中 Principal 的子接口
 interface Group
此接口用于表示一个主体组。

返回 Principal 的 java.security.acl 中的方法
 Principal AclEntry.getPrincipal()
返回此 ACL 项将为其授予或拒绝权限的主体。

返回变量类型为 Principal 的类型的 java.security.acl 中的方法
 Enumeration<? extends Principal> Group.members()
返回此组中成员的枚举。

参数类型为 Principal 的 java.security.acl 中的方法
boolean | Acl.addEntry(Principal caller, AclEntry entry) 向此 ACL 中添加 ACL 项。
boolean | Group.addMember(Principal user) 向组中添加指定的成员。
boolean | Owner.addOwner(Principal caller, Principal owner) 添加一个所有者。
boolean | Acl.checkPermission(Principal principal, Permission permission) 检查指定的主体是否具有指定的权限。
boolean | Owner.deleteOwner(Principal caller, Principal owner) 删除一个所有者。
Enumeration<Permission> | Acl.getPermissions(Principal user) 返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
boolean | Group.isMember(Principal member) 如果传递的主体是组的一个成员，则返回 true。
boolean | Owner.isOwner(Principal owner) 如果给定的主体是该 ACL 的所有者，则返回 true。
boolean | Acl.removeEntry(Principal caller, AclEntry entry) 从此 ACL 中移除 ACL 项。
boolean | Group.removeMember(Principal user) 从组中移除指定的成员。
void | Acl.setName(Principal caller, String name) 设置此 ACL 的名称。
boolean | AclEntry.setPrincipal(Principal user) 指定此 ACL 项要为其授予或拒绝权限的主体。

java.security.cert 中 Principal 的使用

返回 Principal 的 java.security.cert 中的方法
abstract  Principal X509CRL.getIssuerDN()
已过时，由 X509CRL.getIssuerX500Principal() 替代。
abstract  Principal X509Certificate.getIssuerDN()
已过时，由 X509Certificate.getIssuerX500Principal() 替代。
abstract  Principal X509Certificate.getSubjectDN()
已过时，由 X509Certificate.getSubjectX500Principal() 替代。

javax.management.remote 中 Principal 的使用

实现 Principal 的 javax.management.remote 中的类
 class JMXPrincipal
JMX Remote API 的远程客户端的身份。

javax.net.ssl 中 Principal 的使用

返回 Principal 的 javax.net.ssl 中的方法
Principal | HandshakeCompletedEvent.getLocalPrincipal() 返回握手期间发送到同位体的主体。
Principal | SSLSession.getLocalPrincipal() 返回握手期间发送给同位体的主体。
Principal | HttpsURLConnection.getLocalPrincipal() 返回握手期间发送到服务器的主体。
Principal | HandshakeCompletedEvent.getPeerPrincipal() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Principal | SSLSession.getPeerPrincipal() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
Principal | HttpsURLConnection.getPeerPrincipal() 返回服务器的主体，它是作为定义会话的一部分而建立的。

参数类型为 Principal 的 javax.net.ssl 中的方法
String | X509KeyManager.chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。
String | X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。
String | X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。
String | X509KeyManager.chooseServerAlias(String keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。
String[] | X509KeyManager.getClientAliases(String keyType, Principal[] issuers) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。
String[] | X509KeyManager.getServerAliases(String keyType, Principal[] issuers) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

javax.security.auth 中 Principal 的使用

类型参数类型为 Principal 的 javax.security.auth 中的方法
<T extends Principal>
Set<T>
Subject.getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。

返回变量类型为 Principal 的类型的 javax.security.auth 中的方法
 Set<Principal> Subject.getPrincipals()
返回与此 Subject 关联的 Principal Set。

类型变量类型为 Principal 的 javax.security.auth 中的构造方法参数
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。

javax.security.auth.kerberos 中 Principal 的使用

实现 Principal 的 javax.security.auth.kerberos 中的类
 class KerberosPrincipal
此类封装 Kerberos 主体。

javax.security.auth.x500 中 Principal 的使用

实现 Principal 的 javax.security.auth.x500 中的类
 class X500Principal
此类表示一个 X.500 Principal。

javax.security.cert 中 Principal 的使用

返回 Principal 的 javax.security.cert 中的方法
abstract Principal | X509Certificate.getIssuerDN() 获取证书的 issuer（发布方的标识名）值。
abstract Principal | X509Certificate.getSubjectDN() 获取证书的 subject（主体的标识名）值。

javax.xml.ws 中 Principal 的使用

返回 Principal 的 javax.xml.ws 中的方法
 Principal WebServiceContext.getUserPrincipal()
返回标识当前正服务请求发送方的 Principal。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.UnresolvedPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.UnresolvedPermission
的使用

没有 java.security.UnresolvedPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AllPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AllPermission
的使用

没有 java.security.AllPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.Policy.Parameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Policy.Parameters
的使用

使用 Policy.Parameters 的软件包
java.security 为安全框架提供类和接口。

java.security 中 Policy.Parameters 的使用

实现 Policy.Parameters 的 java.security 中的类
 class URIParameter
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

返回 Policy.Parameters 的 java.security 中的方法
 Policy.Parameters Policy.getParameters()
返回 Policy 参数。

参数类型为 Policy.Parameters 的 java.security 中的方法
static Policy | Policy.getInstance(String type, Policy.Parameters params) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, Provider provider) 返回指定类型的 Policy 对象。
static Policy | Policy.getInstance(String type, Policy.Parameters params, String provider) 返回指定类型的 Policy 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Permissions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Permissions
的使用

没有 java.security.Permissions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.PermissionCollection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.PermissionCollection
的使用

使用 PermissionCollection 的软件包
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

java.io 中 PermissionCollection 的使用

返回 PermissionCollection 的 java.io 中的方法
 PermissionCollection FilePermission.newPermissionCollection()
返回用于存储 FilePermission 对象的新 PermissionCollection 对象。

java.net 中 PermissionCollection 的使用

返回 PermissionCollection 的 java.net 中的方法
protected PermissionCollection | URLClassLoader.getPermissions(CodeSource codesource) 返回给定 codesource 对象的权限。
PermissionCollection | SocketPermission.newPermissionCollection() 用于存储 SocketPermission 对象的新 PermissionCollection 对象。

java.security 中 PermissionCollection 的使用

java.security 中 PermissionCollection 的子类
 class Permissions
此类表示一个不同种类的 Permission 集合。

声明为 PermissionCollection 的 java.security 中的字段
static PermissionCollection Policy.UNSUPPORTED_EMPTY_COLLECTION
一个空的只读 PermissionCollection 实例。

返回 PermissionCollection 的 java.security 中的方法
protected PermissionCollection | PolicySpi.engineGetPermissions(CodeSource codesource) 返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。
protected PermissionCollection | PolicySpi.engineGetPermissions(ProtectionDomain domain) 返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。
PermissionCollection | ProtectionDomain.getPermissions() 返回授予此域的静态权限。
PermissionCollection | Policy.getPermissions(CodeSource codesource) 返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。
protected PermissionCollection | SecureClassLoader.getPermissions(CodeSource codesource) 返回给定的 CodeSource 对象的权限。
PermissionCollection | Policy.getPermissions(ProtectionDomain domain) 返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。
PermissionCollection | UnresolvedPermission.newPermissionCollection() 返回存储 UnresolvedPermission 对象的新 PermissionCollection 对象。
PermissionCollection | AllPermission.newPermissionCollection() 返回用于存储 AllPermission 对象的新 PermissionCollection 对象。
PermissionCollection | BasicPermission.newPermissionCollection() 用于存储 BasicPermission 对象的新 PermissionCollection 对象。
PermissionCollection | Permission.newPermissionCollection() 对给定 Permission 对象返回空 PermissionCollection，如果没有定义则返回 null。

参数类型为 PermissionCollection 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions)
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。

java.util 中 PermissionCollection 的使用

返回 PermissionCollection 的 java.util 中的方法
 PermissionCollection PropertyPermission.newPermissionCollection()
用于存储 PropertyPermission 对象的新 PermissionCollection 对象。

javax.management 中 PermissionCollection 的使用

返回 PermissionCollection 的 javax.management 中的方法
 PermissionCollection MBeanServerPermission.newPermissionCollection()

javax.security.auth 中 PermissionCollection 的使用

返回 PermissionCollection 的 javax.security.auth 中的方法
abstract PermissionCollection | Policy.getPermissions(Subject subject, CodeSource cs) 已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。
PermissionCollection | PrivateCredentialPermission.newPermissionCollection() 返回 PermissionCollection 中同类的 PrivateCredentialPermissions 集合。

javax.security.auth.kerberos 中 PermissionCollection 的使用

返回 PermissionCollection 的 javax.security.auth.kerberos 中的方法
PermissionCollection | DelegationPermission.newPermissionCollection() 返回用于存储 DelegationPermission 对象的 PermissionCollection 对象。
PermissionCollection | ServicePermission.newPermissionCollection() 返回用于存储 ServicePermission 对象的 PermissionCollection 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.CodeSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.CodeSource
的使用

使用 CodeSource 的软件包
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.net 中 CodeSource 的使用

参数类型为 CodeSource 的 java.net 中的方法
protected  PermissionCollection URLClassLoader.getPermissions(CodeSource codesource)
返回给定 codesource 对象的权限。

java.security 中 CodeSource 的使用

返回 CodeSource 的 java.security 中的方法
 CodeSource ProtectionDomain.getCodeSource()
返回此域的 CodeSource。

参数类型为 CodeSource 的 java.security 中的方法
protected Class<?> | SecureClassLoader.defineClass(String name, byte[] b, int off, int len, CodeSource cs) 使用可选的 CodeSource 将 byte 数组转换为 Class 类的实例。
protected Class<?> | SecureClassLoader.defineClass(String name, ByteBuffer b, CodeSource cs) 使用可选的 CodeSource 将 ByteBuffer 转换为 Class 类的实例。
protected PermissionCollection | PolicySpi.engineGetPermissions(CodeSource codesource) 返回包含授予指定 CodeSource 的权限集的 PermissionCollection 对象。
PermissionCollection | Policy.getPermissions(CodeSource codesource) 返回一个 PermissionCollection 对象，它包含授予指定 CodeSource 的权限集。
protected PermissionCollection | SecureClassLoader.getPermissions(CodeSource codesource) 返回给定的 CodeSource 对象的权限。
boolean | CodeSource.implies(CodeSource codesource) 如果此 CodeSource 对象“暗含”指定的 CodeSource，则返回 true。

参数类型为 CodeSource 的 java.security 中的构造方法
ProtectionDomain(CodeSource codesource, PermissionCollection permissions)
创建具有给定 CodeSource 和 Permissions 的新 ProtectionDomain。
ProtectionDomain(CodeSource codesource, PermissionCollection permissions, ClassLoader classloader, Principal[] principals)
创建由给定的 CodeSource、Permissions、ClassLoader 和 Principal 数组限定的新 ProtectionDomain。

javax.security.auth 中 CodeSource 的使用

参数类型为 CodeSource 的 javax.security.auth 中的方法
abstract  PermissionCollection Policy.getPermissions(Subject subject, CodeSource cs)
已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.PrivilegedActionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.PrivilegedActionException
的使用

使用 PrivilegedActionException 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 PrivilegedActionException 的使用

抛出 PrivilegedActionException 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivilegedWithCombiner(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。

javax.security.auth 中 PrivilegedActionException 的使用

抛出 PrivilegedActionException 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedExceptionAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.PrivilegedExceptionAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PrivilegedExceptionAction
的使用

使用 PrivilegedExceptionAction 的软件包
java.security | 为安全框架提供类和接口。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 PrivilegedExceptionAction 的使用

参数类型为 PrivilegedExceptionAction 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。
static
<T> T
AccessController.doPrivilegedWithCombiner(PrivilegedExceptionAction<T> action)
启用特权，执行指定的 PrivilegedExceptionAction。

java.util.concurrent 中 PrivilegedExceptionAction 的使用

参数类型为 PrivilegedExceptionAction 的 java.util.concurrent 中的方法
static Callable<Object> Executors.callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。

javax.security.auth 中 PrivilegedExceptionAction 的使用

参数类型为 PrivilegedExceptionAction 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedExceptionAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.SecureClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.SecureClassLoader
的使用

使用 SecureClassLoader 的软件包
java.net | 为实现网络应用程序提供类。
javax.management.loading | 提供实现高级动态加载的类。

java.net 中 SecureClassLoader 的使用

java.net 中 SecureClassLoader 的子类
 class URLClassLoader
该类加载器用于从指向 JAR 文件和目录的 URL 的搜索路径加载类和资源。

javax.management.loading 中 SecureClassLoader 的使用

javax.management.loading 中 SecureClassLoader 的子类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.PrivilegedAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.PrivilegedAction
的使用

使用 PrivilegedAction 的软件包
java.security | 为安全框架提供类和接口。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 PrivilegedAction 的使用

参数类型为 PrivilegedAction 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。
static
<T> T
AccessController.doPrivileged(PrivilegedAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。
static
<T> T
AccessController.doPrivilegedWithCombiner(PrivilegedAction<T> action)
启用特权，执行指定的 PrivilegedAction。

java.util.concurrent 中 PrivilegedAction 的使用

参数类型为 PrivilegedAction 的 java.util.concurrent 中的方法
static Callable<Object> Executors.callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。

javax.security.auth 中 PrivilegedAction 的使用

参数类型为 PrivilegedAction 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AccessController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AccessController
的使用

没有 java.security.AccessController 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.BasicPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.BasicPermission
的使用

使用 BasicPermission 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.awt 中 BasicPermission 的使用

java.awt 中 BasicPermission 的子类
 class AWTPermission
此类用于 AWT 权限。

java.io 中 BasicPermission 的使用

java.io 中 BasicPermission 的子类
 class SerializablePermission
此类用于可序列化权限。

java.lang 中 BasicPermission 的使用

java.lang 中 BasicPermission 的子类
 class RuntimePermission
该类用于运行时权限。

java.lang.management 中 BasicPermission 的使用

java.lang.management 中 BasicPermission 的子类
 class ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

java.lang.reflect 中 BasicPermission 的使用

java.lang.reflect 中 BasicPermission 的子类
 class ReflectPermission
反射操作的 Permission 类。

java.net 中 BasicPermission 的使用

java.net 中 BasicPermission 的子类
 class NetPermission
此类可用于各种网络权限。

java.security 中 BasicPermission 的使用

java.security 中 BasicPermission 的子类
 class SecurityPermission
此类用于安全权限。

java.sql 中 BasicPermission 的使用

java.sql 中 BasicPermission 的子类
 class SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

java.util 中 BasicPermission 的使用

java.util 中 BasicPermission 的子类
 class PropertyPermission
此类用于属性权限。

java.util.logging 中 BasicPermission 的使用

java.util.logging 中 BasicPermission 的子类
 class LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

javax.management 中 BasicPermission 的使用

javax.management 中 BasicPermission 的子类
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。

javax.management.remote 中 BasicPermission 的使用

javax.management.remote 中 BasicPermission 的子类
 class SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

javax.net.ssl 中 BasicPermission 的使用

javax.net.ssl 中 BasicPermission 的子类
 class SSLPermission
此类用于各种网络权限。

javax.security.auth 中 BasicPermission 的使用

javax.security.auth 中 BasicPermission 的子类
 class AuthPermission
此类用于验证权限。

javax.security.auth.kerberos 中 BasicPermission 的使用

javax.security.auth.kerberos 中 BasicPermission 的子类
 class DelegationPermission
此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。

javax.sound.sampled 中 BasicPermission 的使用

javax.sound.sampled 中 BasicPermission 的子类
 class AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

javax.xml.ws 中 BasicPermission 的使用

javax.xml.ws 中 BasicPermission 的子类
 class WebServicePermission
此类定义 Web 服务权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.Permission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.Permission
的使用

使用 Permission 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.awt 中 Permission 的使用

java.awt 中 Permission 的子类
 class AWTPermission
此类用于 AWT 权限。

java.io 中 Permission 的使用

java.io 中 Permission 的子类
class | FilePermission 此类表示对文件和目录的访问。
class | SerializablePermission 此类用于可序列化权限。

参数类型为 Permission 的 java.io 中的方法
 boolean FilePermission.implies(Permission p)
检查 FilePermission 对象是否“隐含”指定的权限。

java.lang 中 Permission 的使用

java.lang 中 Permission 的子类
 class RuntimePermission
该类用于运行时权限。

参数类型为 Permission 的 java.lang 中的方法
void | SecurityManager.checkPermission(Permission perm) 如果基于当前有效的安全策略，不允许执行根据给定权限所指定的请求访问，则抛出 SecurityException。
void | SecurityManager.checkPermission(Permission perm, Object context) 如果拒绝指定的安全上下文访问由给定权限所指定的资源，则抛出 SecurityException。

java.lang.management 中 Permission 的使用

java.lang.management 中 Permission 的子类
 class ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

java.lang.reflect 中 Permission 的使用

java.lang.reflect 中 Permission 的子类
 class ReflectPermission
反射操作的 Permission 类。

java.net 中 Permission 的使用

java.net 中 Permission 的子类
class | NetPermission 此类可用于各种网络权限。
class | SocketPermission 此类表示通过套接字对网络的访问。

返回 Permission 的 java.net 中的方法
Permission | HttpURLConnection.getPermission()
Permission | URLConnection.getPermission() 返回一个权限对象，其代表建立此对象表示的连接所需的权限。

参数类型为 Permission 的 java.net 中的方法
 boolean SocketPermission.implies(Permission p)
检查此套接字权限对象是否“暗含”指定的权限。

java.security 中 Permission 的使用

java.security 中 Permission 的子类
class | AllPermission AllPermission 是暗含所有其他权限的权限。
class | BasicPermission BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
class | SecurityPermission 此类用于安全权限。
class | UnresolvedPermission UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

返回 Permission 的 java.security 中的方法
 Permission AccessControlException.getPermission()
获取与此异常关联的 Permission 对象；如果不存在相应的 Permission 对象，则为 null。

返回变量类型为 Permission 的类型的 java.security 中的方法
Enumeration<Permission> | Permissions.elements() 返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。
abstract Enumeration<Permission> | PermissionCollection.elements() 返回集合中所有 Permission 对象的枚举。

参数类型为 Permission 的 java.security 中的方法
void | Permissions.add(Permission permission) 将一个 permission 对象添加到该权限所属的类的 PermissionCollection 中。
abstract void | PermissionCollection.add(Permission permission) 将一个权限对象添加到当前权限对象的集合。
static void | AccessController.checkPermission(Permission perm) 基于当前 AccessControlContext 和安全策略确定是否允许指定权限所指示的访问请求。
void | AccessControlContext.checkPermission(Permission perm) 基于当前生效的安全策略和此对象中的上下文确定是否允许指定权限指示的访问请求。
protected abstract boolean | PolicySpi.engineImplies(ProtectionDomain domain, Permission permission) 检查该策略是否已将 Permission 授予 ProtectionDomain。
boolean | UnresolvedPermission.implies(Permission p) 对于未解析的权限，此方法始终返回 false。
boolean | AllPermission.implies(Permission p) 检查此对象是否“暗含”指定的权限。
boolean | Permissions.implies(Permission permission) 查看此对象用于指定 permission 类的 permissions 的 PermissionCollection 是否暗含了 permission 对象中表示的权限。
abstract boolean | PermissionCollection.implies(Permission permission) 查看此 PermissionCollection 中保存的 Permission 对象集合是否暗含指定的权限。
boolean | BasicPermission.implies(Permission p) 检查此对象是否“暗含”指定的权限。
abstract boolean | Permission.implies(Permission permission) 检查此对象的操作是否“暗含”指定权限的操作。
boolean | ProtectionDomain.implies(Permission permission) 查看此 ProtectionDomain 是否暗含了 Permission 对象中表示的权限。
boolean | Policy.implies(ProtectionDomain domain, Permission permission) 计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。

参数类型为 Permission 的 java.security 中的构造方法
AccessControlException(String s, Permission p)
构造带指定详细消息和导致异常的请求权限的 AccessControlException。

java.sql 中 Permission 的使用

java.sql 中 Permission 的子类
 class SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

java.util 中 Permission 的使用

java.util 中 Permission 的子类
 class PropertyPermission
此类用于属性权限。

参数类型为 Permission 的 java.util 中的方法
 boolean PropertyPermission.implies(Permission p)
检查 PropertyPermission 对象是否“暗指”指定的权限。

java.util.logging 中 Permission 的使用

java.util.logging 中 Permission 的子类
 class LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

javax.management 中 Permission 的使用

javax.management 中 Permission 的子类
class | MBeanPermission 权限控制对 MBeanServer 操作的访问。
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。

参数类型为 Permission 的 javax.management 中的方法
boolean | MBeanPermission.implies(Permission p) 检查此 MBeanPermission 对象是否“隐含”指定的权限。
boolean | MBeanServerPermission.implies(Permission p) 检查此 MBeanServerPermission 对象是否“隐含”指定的权限。

javax.management.remote 中 Permission 的使用

javax.management.remote 中 Permission 的子类
 class SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

javax.net.ssl 中 Permission 的使用

javax.net.ssl 中 Permission 的子类
 class SSLPermission
此类用于各种网络权限。

javax.security.auth 中 Permission 的使用

javax.security.auth 中 Permission 的子类
class | AuthPermission 此类用于验证权限。
class | PrivateCredentialPermission 此类用来保护对属于特定 Subject 的私有 Credential 的访问。

参数类型为 Permission 的 javax.security.auth 中的方法
 boolean PrivateCredentialPermission.implies(Permission p)
检查此 PrivateCredentialPermission 是否暗含指定的Permission。

javax.security.auth.kerberos 中 Permission 的使用

javax.security.auth.kerberos 中 Permission 的子类
class | DelegationPermission 此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
class | ServicePermission 此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

参数类型为 Permission 的 javax.security.auth.kerberos 中的方法
boolean | DelegationPermission.implies(Permission p) 检查此 Kerberos 代理权限对象是否“隐含”指定的权限。
boolean | ServicePermission.implies(Permission p) 检查此 Kerberos 服务权限对象是否“隐含”指定的权限。

javax.sound.sampled 中 Permission 的使用

javax.sound.sampled 中 Permission 的子类
 class AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

javax.xml.ws 中 Permission 的使用

javax.xml.ws 中 Permission 的子类
 class WebServicePermission
此类定义 Web 服务权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.security.Guard 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.security.Guard
的使用

使用 Guard 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.lang.reflect | 提供类和接口，以获得关于类和对象的反射信息。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.awt 中 Guard 的使用

实现 Guard 的 java.awt 中的类
 class AWTPermission
此类用于 AWT 权限。

java.io 中 Guard 的使用

实现 Guard 的 java.io 中的类
class | FilePermission 此类表示对文件和目录的访问。
class | SerializablePermission 此类用于可序列化权限。

java.lang 中 Guard 的使用

实现 Guard 的 java.lang 中的类
 class RuntimePermission
该类用于运行时权限。

java.lang.management 中 Guard 的使用

实现 Guard 的 java.lang.management 中的类
 class ManagementPermission
使用 SecurityManager 运行的代码调用 Java 平台的管理接口中定义的方法时，SecurityManager 将要检查的权限。

java.lang.reflect 中 Guard 的使用

实现 Guard 的 java.lang.reflect 中的类
 class ReflectPermission
反射操作的 Permission 类。

java.net 中 Guard 的使用

实现 Guard 的 java.net 中的类
class | NetPermission 此类可用于各种网络权限。
class | SocketPermission 此类表示通过套接字对网络的访问。

java.security 中 Guard 的使用

实现 Guard 的 java.security 中的类
class | AllPermission AllPermission 是暗含所有其他权限的权限。
class | BasicPermission BasicPermission 类扩展 Permission 类，并且可以用作希望与 BasicPermission 遵守相同命名约定的权限的基类。
class | Permission 表示访问系统资源的抽象类。
class | SecurityPermission 此类用于安全权限。
class | UnresolvedPermission UnresolvedPermission 类用来保持初始化 Policy 时“未解析”的权限。

参数类型为 Guard 的 java.security 中的构造方法
GuardedObject(Object object, Guard guard)
使用指定的对象和 guard 构造 GuardedObject。

java.sql 中 Guard 的使用

实现 Guard 的 java.sql 中的类
 class SQLPermission
SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。

java.util 中 Guard 的使用

实现 Guard 的 java.util 中的类
 class PropertyPermission
此类用于属性权限。

java.util.logging 中 Guard 的使用

实现 Guard 的 java.util.logging 中的类
 class LoggingPermission
当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

javax.management 中 Guard 的使用

实现 Guard 的 javax.management 中的类
class | MBeanPermission 权限控制对 MBeanServer 操作的访问。
class | MBeanServerPermission 执行与 MBeanServer 关联的操作的 Permission。
class | MBeanTrustPermission 此权限表示“信任”签名者或代码基。

javax.management.remote 中 Guard 的使用

实现 Guard 的 javax.management.remote 中的类
 class SubjectDelegationPermission
授权标识表示验证标识执行操作所需的权限。

javax.net.ssl 中 Guard 的使用

实现 Guard 的 javax.net.ssl 中的类
 class SSLPermission
此类用于各种网络权限。

javax.security.auth 中 Guard 的使用

实现 Guard 的 javax.security.auth 中的类
class | AuthPermission 此类用于验证权限。
class | PrivateCredentialPermission 此类用来保护对属于特定 Subject 的私有 Credential 的访问。

javax.security.auth.kerberos 中 Guard 的使用

实现 Guard 的 javax.security.auth.kerberos 中的类
class | DelegationPermission 此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
class | ServicePermission 此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

javax.sound.sampled 中 Guard 的使用

实现 Guard 的 javax.sound.sampled 中的类
 class AudioPermission
AudioPermission 类表示对音频系统资源的访问权限。

javax.xml.ws 中 Guard 的使用

实现 Guard 的 javax.xml.ws 中的类
 class WebServicePermission
此类定义 Web 服务权限。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.AccessControlContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.AccessControlContext
的使用

使用 AccessControlContext 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.security 中 AccessControlContext 的使用

返回 AccessControlContext 的 java.security 中的方法
static AccessControlContext AccessController.getContext()
此方法获取当前调用上下文（包括当前 Thread 的继承 AccessControlContext）的“快照”，并将其置于 AccessControlContext 对象中。

参数类型为 AccessControlContext 的 java.security 中的方法
static
<T> T
AccessController.doPrivileged(PrivilegedAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedAction。
static
<T> T
AccessController.doPrivileged(PrivilegedExceptionAction<T> action, AccessControlContext context)
通过指定的 AccessControlContext 启用和限制特权，执行指定的 PrivilegedExceptionAction。

参数类型为 AccessControlContext 的 java.security 中的构造方法
AccessControlContext(AccessControlContext acc, DomainCombiner combiner)
创建具有给定 AccessControlContext 和 DomainCombiner 的新 AccessControlContext。

javax.security.auth 中 AccessControlContext 的使用

参数类型为 AccessControlContext 的 javax.security.auth 中的方法
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
static Subject Subject.getSubject(AccessControlContext acc)
获取与提供的 AccessControlContext 关联的 Subject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.security.ProtectionDomain 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.security.ProtectionDomain
的使用

使用 ProtectionDomain 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。

java.lang 中 ProtectionDomain 的使用

返回 ProtectionDomain 的 java.lang 中的方法
 ProtectionDomain Class.getProtectionDomain()
返回该类的 ProtectionDomain。

参数类型为 ProtectionDomain 的 java.lang 中的方法
protected Class<?> | ClassLoader.defineClass(String name, byte[] b, int off, int len, ProtectionDomain protectionDomain) 使用可选的 ProtectionDomain 将一个 byte 数组转换为 Class 类的实例。
protected Class<?> | ClassLoader.defineClass(String name, ByteBuffer b, ProtectionDomain protectionDomain) 使用可选的 ProtectionDomain 将 ByteBuffer 转换为 Class 类的实例。

java.lang.instrument 中 ProtectionDomain 的使用

参数类型为 ProtectionDomain 的 java.lang.instrument 中的方法
 byte[] ClassFileTransformer.transform(ClassLoader loader, String className, Class<?> classBeingRedefined, ProtectionDomain protectionDomain, byte[] classfileBuffer)
此方法的实现可以转换提供的类文件，并返回一个新的替换类文件。

java.security 中 ProtectionDomain 的使用

返回 ProtectionDomain 的 java.security 中的方法
 ProtectionDomain[] DomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
修改或更新提供的 ProtectionDomain。

参数类型为 ProtectionDomain 的 java.security 中的方法
ProtectionDomain[] | DomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 修改或更新提供的 ProtectionDomain。
ProtectionDomain[] | DomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 修改或更新提供的 ProtectionDomain。
protected PermissionCollection | PolicySpi.engineGetPermissions(ProtectionDomain domain) 返回包含授予指定 ProtectionDomain 的权限集的 PermissionCollection 对象。
protected abstract boolean | PolicySpi.engineImplies(ProtectionDomain domain, Permission permission) 检查该策略是否已将 Permission 授予 ProtectionDomain。
PermissionCollection | Policy.getPermissions(ProtectionDomain domain) 返回一个 PermissionCollection 对象，它包含授予指定 ProtectionDomain 的权限集。
boolean | Policy.implies(ProtectionDomain domain, Permission permission) 计算授予 ProtectionDomain 的权限的全局策略，并测试是否授予了该权限。

参数类型为 ProtectionDomain 的 java.security 中的构造方法
AccessControlContext(ProtectionDomain[] context)
创建带有给定 ProtectionDomain 集合的 AccessControlContext。

javax.security.auth 中 ProtectionDomain 的使用

返回 ProtectionDomain 的 javax.security.auth 中的方法
 ProtectionDomain[] SubjectDomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains)
使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。

参数类型为 ProtectionDomain 的 javax.security.auth 中的方法
ProtectionDomain[] | SubjectDomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。
ProtectionDomain[] | SubjectDomainCombiner.combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Array (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Array

所有已知实现类：
SerialArray
public interface Array

SQL 类型 ARRAY 在 Java 编程语言中的映射关系。默认情况下，Array 值是对 SQL ARRAY 值的事务处理期引用。默认情况下，Array 对象是使用 SQL LOCATOR(array) 内部实现的，这意味着 Array 对象包含一个指向 SQL ARRAY 值中数据的逻辑指针，而不是包含 ARRAY 值的数据。

Array 接口提供了某些方法将 SQL ARRAY 值的数据作为数组或 ResultSet 对象传送到客户端。如果 SQL ARRAY 的元素是一个 UDT，那么可以自定义映射它们。要创建自定义映射关系，编程人员必须做两件事：

  • 为将被自定义映射的 UDT 创建一个实现 SQLData 接口的类。
  • 在类型映射表中生成一个项，该项包含
    • UDT 的完全限定 SQL 类型名称
    • 实现 SQLData 的类的 Class 对象

在将带有对应于基本类型的项的类型映射表提供给 getArray 和 getResultSet 方法时，该表所包含的映射关系将用于映射 ARRAY 值的元素。如果没有提供类型映射表（通常是这种情况），则默认使用连接的类型映射表。如果该连接的类型映射表或为某一方法提供的类型映射表没有对应于基本类型的项，则根据标准映射关系来映射这些元素。

如果 JDBC 驱动程序支持该数据类型，则必须完全实现 Array 接口上的所有方法。

从以下版本开始：
1.2

方法摘要
void | free() 此方法释放 Array 对象以及它占用的资源。
Object | getArray() 以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。
Object | getArray(long index, int count) 获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
Object | getArray(long index, int count, Map<String,Class<?>> map) 获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
Object | getArray(Map<String,Class<?>> map) 获取由此 Array 对象指定的 SQL ARRAY 值的内容。
int | getBaseType() 在由此 Array 对象指定的数组中获取元素的 JDBC 类型。
String | getBaseTypeName() 在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。
ResultSet | getResultSet() 获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
ResultSet | getResultSet(long index, int count) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | getResultSet(long index, int count, Map<String,Class<?>> map) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | getResultSet(Map<String,Class<?>> map) 获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。

方法详细信息

getBaseTypeName

String getBaseTypeName()
                       throws SQLException
在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。如果元素是内置类型，则返回这些元素特定于数据库的类型名称。如果元素是用户定义类型 (UDT)，则此方法返回完全限定 SQL 类型名称。

返回：
一个 String，对于内置基本类型，该字符串是特定于数据库的名称；对于为 UDT 的基本类型，该字符串是完全限定的 SQL 类型名称
抛出：
SQLException - 如果在试图访问该类型名称时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getBaseType

int getBaseType()
                throws SQLException
在由此 Array 对象指定的数组中获取元素的 JDBC 类型。

返回：
Types 类中的一个常量，它是由此 Array 对象指定的数组中的元素的类型代码
抛出：
SQLException - 如果在试图访问该基本类型时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getArray

Object getArray()
                throws SQLException
以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。这一 getArray 方法使用与该连接相关联的类型映射表来自定义类型映射关系。

注意：当 getArray 用于实现映射到基本数据类型的基类型时，返回数组是该基本数据类型数组还是 Object 数组将由实现定义。

返回：
一个 Java 编程语言形式的数组，它包含由此 Array 对象指定的 SQL ARRAY 值的有序元素
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getArray

Object getArray(Map<String,Class<?>> map)
                throws SQLException
获取由此 Array 对象指定的 SQL ARRAY 值的内容。此方法使用指定的 map 进行类型映射自定义，除非数组的基本类型与 map 中用户定义类型不匹配，这种情况下使用标准映射关系。这一 getArray 方法使用给定类型映射表或标准映射关系；它绝不会使用与连接关联的类型映射表。

注意：当 getArray 用于实现映射到基本数据类型的基类型时，返回数组是该基本数据类型数组还是 Object 数组将由实现定义。

参数：
map - 一个 java.util.Map 对象，该对象包含 SQL 类型名称到 Java 编程语言形式的类的映射关系
返回：
一个 Java 编程语言形式的数组，该数组包含由此对象指定的 SQL 数组的有序元素
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getArray

Object getArray(long index,
                int count)
                throws SQLException
获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。此方法使用与连接关联的类型映射表来自定义类型映射关系。

注意：当 getArray 用于实现映射到基本数据类型的基类型时，返回数组是该基本数据类型数组还是 Object 数组将由实现定义。

参数：
index - 要获取的第一个元素的数组索引；第一个元素位于索引 1 处
count - 要获取的连续 SQL 数组元素的数量
返回：
包含 count 个连续 SQL 数组元素的数组，从元素 index 开始
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getArray

Object getArray(long index,
                int count,
                Map<String,Class<?>> map)
                throws SQLException
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。

此方法使用指定的 map 进行类型映射自定义，除非数组的基本类型与 map 中用户定义类型不匹配，这种情况下使用标准映射关系。这一 getArray 方法使用给定类型映射表或标准映射关系；它绝不会使用与连接关联的类型映射表。

注意：当 getArray 用于实现映射到基本数据类型的基类型时，返回数组是该基本数据类型数组还是 Object 数组将由实现定义。

参数：
index - 要获取的第一个元素的数组索引；第一个元素位于索引 1 处
count - 要获取的连续 SQL 数组元素的数量
map - 一个 java.util.Map 对象，该对象包含 SQL 类型名称以及它们所映射的 Java 编程语言形式的类
返回：
一个数组，它包含此 Array 对象指定的 SQL ARRAY 值的 count 个连续元素（从元素 index 开始）
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getResultSet

ResultSet getResultSet()
                       throws SQLException
获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。如果合适，则使用该连接的类型映射表来映射数组的元素；否则使用标准映射关系。

结果集合中每个数组元素占一行，每行有两列。第二列存储元素值；第一列存储元素数组中的索引（第一个数组元素位于索引 1 处）。这些行按升序排列，对应于索引的顺序。

返回：
一个 ResultSet 对象，它在为此 Array 对象指定的数组中的每个元素包含一个行，这些行基于索引按升序排列。
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getResultSet

ResultSet getResultSet(Map<String,Class<?>> map)
                       throws SQLException
获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。此方法使用指定的 map 进行类型映射自定义，除非数组的基本类型与 map 中用户定义类型不匹配，这种情况下使用标准映射关系。这一 getResultSet 方法使用给定类型映射表或标准映射关系；它绝不会使用与连接关联的类型映射表。

结果集合中每个数组元素占一行，每行有两列。第二列存储元素值；第一列存储元素数组中的索引（第一个数组元素位于索引 1 处）。这些行按升序排列，对应于索引的顺序。

参数：
map - 包含 SQL 用户定义类型到 Java 编程语言形式的类的映射关系
返回：
一个 ResultSet 对象，它在为此 Array 对象指定的数组中的每个元素包含一个行，这些行基于索引按升序排列。
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getResultSet

ResultSet getResultSet(long index,
                       int count)
                       throws SQLException
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。此方法使用连接的类型映射表来映射数组的元素，如果该映射表包含一个对应于基本类型的项。否则使用标准映射关系。

结果集合中此对象指定的 SQL 数组的每个元素对应有一个行，第一行包含位于索引 index 处的元素。结果集合中包含 count 个行，这些行基于索引按升序排列。每行有两列：第二列存储元素值；第一列存储该元素数组中的索引。

参数：
index - 要获取的第一个元素的数组索引；第一个元素位于索引 1 处
count - 要获取的连续 SQL 数组元素的数量
返回：
一个 ResultSet 对象，该对象包含此 Array 对象指定的 SQL 数组的 count 个连续元素（从索引 index 开始）。
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getResultSet

ResultSet getResultSet(long index,
                       int count,
                       Map<String,Class<?>> map)
                       throws SQLException
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。此方法使用指定的 map 进行类型映射自定义，除非数组的基本类型与 map 中用户定义类型不匹配，这种情况下使用标准映射关系。这一 getResultSet 方法使用给定类型映射表或标准映射关系；它绝不会使用与连接关联的类型映射表。

结果集合中此对象指定的 SQL 数组的每个元素对应有一个行，第一行包含位于索引 index 处的元素。结果集合中包含 count 个行，这些行基于索引按升序排列。每行有两列：第二列存储元素值；第一列存储该元素数组中的索引。

参数：
index - 要获取的第一个元素的数组索引；第一个元素位于索引 1 处
count - 要获取的连续 SQL 数组元素的数量
map - Map 对象，包含从 SQL 类型名称到 Java(tm) 编程语言形式的类的映射关系
返回：
一个 ResultSet 对象，该对象包含此 Array 对象指定的 SQL 数组的 count 个连续元素（从索引 index 开始）。
抛出：
SQLException - 如果在试图访问该数组时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

free

void free()
          throws SQLException
此方法释放 Array 对象以及它占用的资源。调用 free 方法后，该对象无效。

已调用 free 之后，任何调用 free 以外方法的尝试将会导致抛出 SQLException。如果多次调用 free，则后续对 free 的调用被视为无操作。

抛出：
SQLException - 如果释放 Array 资源时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BatchUpdateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 BatchUpdateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.BatchUpdateException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class BatchUpdateException
extends SQLException

进行批量更新操作期间发生错误时抛出的 SQLException 子类。除了 SQLException 提供的信息以外，BatchUpdateException 还提供批量更新期间成功执行的所有命令的更新计数，也就是发生错误之前执行的所有命令的更新计数。更新计数数组中元素的顺序对应于将命令添加到批处理中的顺序。

批量更新中的命令无法正确执行并抛出 BatchUpdateException 之后，驱动程序可以继续处理批处理中的剩余命令，也可以不再进行处理。如果驱动程序在失败后继续进行处理，那么批处理的每个命令在 BatchUpdateException.getUpdateCounts 方法返回的数组中都有一个对应的元素，而不仅仅是发生错误前成功执行的命令才有对应的元素。在驱动程序继续处理命令的情况下，所有执行失败的命令对应的数组元素都是 Statement.EXECUTE_FAILED。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
BatchUpdateException()
构造一个 BatchUpdateException 对象。
BatchUpdateException(int[] updateCounts)
构造一个使用给定 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(int[] updateCounts, Throwable cause)
构造一个使用给定 cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, int[] updateCounts)
构造一个使用给定 reason 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int[] updateCounts)
构造一个使用给定 reason、SQLState 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts)
构造一个使用给定 reason、SQLState、vendorCode 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(String reason, String SQLState, int vendorCode, int[] updateCounts, Throwable cause)
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。
BatchUpdateException(Throwable cause)
构造一个使用给定 cause 初始化的 BatchUpdateException 对象。
方法摘要
 int[] getUpdateCounts()
获取发生此异常前批量更新中成功执行的每个更新语句的更新计数。
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BatchUpdateException

public BatchUpdateException(String reason,
                            String SQLState,
                            int vendorCode,
                            int[] updateCounts)
构造一个使用给定 reason、SQLState、vendorCode 和 updateCounts 初始化的 BatchUpdateException 对象。cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法进行初始化。

参数：
reason - 对错误的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 供特定数据库供应商使用的异常代码
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
从以下版本开始：
1.2

BatchUpdateException

public BatchUpdateException(String reason,
                            String SQLState,
                            int[] updateCounts)
构造一个使用给定 reason、SQLState 和 updateCounts 初始化的 BatchUpdateException 对象。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法进行初始化。供应商代码被初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
从以下版本开始：
1.2

BatchUpdateException

public BatchUpdateException(String reason,
                            int[] updateCounts)
构造一个使用给定 reason 和 updateCounts 初始化的 BatchUpdateException 对象。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法进行初始化。SQLState 被初始化为 null，供应商代码被初始化为 0。

参数：
reason - 对异常的描述
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
从以下版本开始：
1.2

BatchUpdateException

public BatchUpdateException(int[] updateCounts)
构造一个使用给定 updateCounts 初始化的 BatchUpdateException 对象。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法进行初始化。reason 和 SQLState 被初始化为 null，供应商代码被初始化为 0。

参数：
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
从以下版本开始：
1.2

BatchUpdateException

public BatchUpdateException()
构造一个 BatchUpdateException 对象。reason、SQLState 和 updateCounts 被初始化为 null，供应商代码被初始化为 0。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法进行初始化。

从以下版本开始：
1.2

BatchUpdateException

public BatchUpdateException(Throwable cause)
构造一个使用给定 cause 初始化的 BatchUpdateException 对象。SQLState 和 updateCounts 被初始化为 null，供应商代码被初始化为 0。如果 cause==null，那么 reason 被初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 导致此 SQLException 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6

BatchUpdateException

public BatchUpdateException(int[] updateCounts,
                            Throwable cause)
构造一个使用给定 cause 和 updateCounts 初始化的 BatchUpdateException 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。如果 cause==null，那么 reason 被初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
cause - 导致此 SQLException 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6

BatchUpdateException

public BatchUpdateException(String reason,
                            int[] updateCounts,
                            Throwable cause)
构造一个使用给定 reason、cause 和 updateCounts 构造的 BatchUpdateException 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。

参数：
reason - 对异常的描述
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
cause - 导致此 SQLException 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6

BatchUpdateException

public BatchUpdateException(String reason,
                            String SQLState,
                            int[] updateCounts,
                            Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 updateCounts 初始化的 BatchUpdateException 对象。供应商代码被初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
cause - 导致此 SQLException 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6

BatchUpdateException

public BatchUpdateException(String reason,
                            String SQLState,
                            int vendorCode,
                            int[] updateCounts,
                            Throwable cause)
构造一个使用给定 reason、SQLState、vendorCode、cause 和 updateCounts 初始化的 BatchUpdateException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 由特定数据库供应商使用的异常代码
updateCounts - 一个 int 数组，对于命令失败后继续进行处理的 JDBC 驱动程序，每个数组元素对应批处理中的每个 SQL 命令，指示更新计数、Statement.SUCCESS_NO_INFO 或 Statement.EXECUTE_FAILED；对于命令失败后停止处理的 JDBC 驱动程序，每个数组元素对应失败之前批处理中的每个 SQL 命令，指示更新计数或 Statement.SUCCESS_NO_INFO
cause - 导致此 SQLException 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6
方法详细信息

getUpdateCounts

public int[] getUpdateCounts()
获取发生此异常前批量更新中成功执行的每个更新语句的更新计数。在某一命令无法正确执行时，实现批量更新的驱动程序可以继续处理批处理中的剩余命令，也可以不再进行处理。如果驱动程序继续处理命令，那么此方法返回的数组所拥有的元素数量将与批处理中的命令数量相同；否则，该数组将包含抛出 BatchUpdateException 之前成功执行的每条命令的更新计数。

此方法的可能返回值是在 Java 2 SDK 标准版 1.3 版中修改的。这样做是为了使其适应在抛出了 BatchUpdateException 对象之后仍然能够继续处理批量更新中的命令这一新选项。

返回：
一个 int 数组，该数组包含发生此错误前成功执行的更新的更新计数。如果驱动程序在发生错误之后仍然继续处理命令，则对批处理中的每条命令返回以下内容之一：
  1. 更新计数
  2. Statement.SUCCESS_NO_INFO，指示成功执行了命令，但受影响的行数是未知的
  3. Statement.EXECUTE_FAILED，指示没有成功地执行命令
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Blob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Blob

所有已知实现类：
SerialBlob
public interface Blob

SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。SQL BLOB 是内置类型，它将二进制大对象 (Binary Large Object) 存储为数据库表某一行中的一个列值。默认情况下，驱动程序使用 SQL locator(BLOB) 实现 Blob，这意味着 Blob 对象包含一个指向 SQL BLOB 数据的逻辑指针而不是数据本身。Blob 对象在它被创建的事务处理期间有效。

接口 ResultSet、CallableStatement 和 PreparedStatement 中的方法（如 getBlob 和 setBlob）允许编程人员访问 SQL BLOB 值。Blob 接口提供一些方法来获取 SQL BLOB (Binary Large Object) 值的长度、在客户端实现 BLOB 值以及确定 BLOB 值中某一字节样本的位置。此外，此接口还有更新 BLOB 值的方法。

如果 JDBC 驱动程序支持该数据类型，则必须完全实现 Blob 接口的所有方法。

从以下版本开始：
1.2

方法摘要
void | free() 此方法释放 Blob 对象以及它所占用的资源。
InputStream | getBinaryStream() 以流的形式获取此 Blob 实例指定的 BLOB 值。
InputStream | getBinaryStream(long pos, long length) 返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。
byte[] | getBytes(long pos, int length) 以 byte 数组的形式获取此 Blob 对象表示的全部或部分 BLOB 值。
long | length() 返回此 Blob 对象指定的 BLOB 值中的字节数。
long | position(Blob pattern, long start) 获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。
long | position(byte[] pattern, long start) 获取此 Blob 对象表示的 BLOB 值中指定 byte 数组 pattern 开始处的字节位置。
OutputStream | setBinaryStream(long pos) 获取用于写入此 Blob 对象表示的 BLOB 值的流。
int | setBytes(long pos, byte[] bytes) 从位置 pos 处开始，将给定 byte 数组写入此 Blob 对象表示的 BLOB 值，并返回写入的字节数。
int | setBytes(long pos, byte[] bytes, int offset, int len) 将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
void | truncate(long len) 截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。

方法详细信息

length

long length()
            throws SQLException
返回此 Blob 对象指定的 BLOB 值中的字节数。

返回：
BLOB 的字节长度
抛出：
SQLException - 如果访问 BLOB 的长度时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getBytes

byte[] getBytes(long pos,
                int length)
                throws SQLException
以 byte 数组的形式获取此 Blob 对象表示的全部或部分 BLOB 值。此 byte 数组包含从位置 pos 开始的 length 个连续字节。

参数：
pos - 要提取的 BLOB 值中第一个字节的顺序位置；第一个字节位于位置 1 处
length - 要复制的连续字节的数量；length 的值必须大于等于 0
返回：
一个字节数组，它包含此 Blob 对象指定的 BLOB 值中的 length 个连续字节（从位置 pos 处的字节开始）
抛出：
SQLException - 如果访问 BLOB 值时发生错误；如果 pos 小于 1 或 length 小于 0
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
setBytes(long, byte[])

getBinaryStream

InputStream getBinaryStream()
                            throws SQLException
以流的形式获取此 Blob 实例指定的 BLOB 值。

返回：
包含 BLOB 数据的流
抛出：
SQLException - 如果访问 BLOB 值时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
setBinaryStream(long)

position

long position(byte[] pattern,
              long start)
              throws SQLException
获取此 Blob 对象表示的 BLOB 值中指定 byte 数组 pattern 开始处的字节位置。对 pattern 的搜索从位置 start 开始。

参数：
pattern - 要搜索的字节数组
start - 开始搜索的位置；第一个位置是 1
返回：
pattern 出现的位置，否则返回 -1
抛出：
SQLException - 如果访问 BLOB 时发生错误或者 start 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

position

long position(Blob pattern,
              long start)
              throws SQLException
获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。从位置 start 开始搜索。

参数：
pattern - 指定要搜索的 BLOB 值的 Blob 对象
start - BLOB 值中开始进行搜索的位置；第一个位置是 1
返回：
pattern 开始处的位置，否则返回 -1
抛出：
SQLException - 如果访问 BLOB 值时发生错误或者 start 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setBytes

int setBytes(long pos,
             byte[] bytes)
             throws SQLException
从位置 pos 处开始，将给定 byte 数组写入此 Blob 对象表示的 BLOB 值，并返回写入的字节数。该 byte 数组将从位置 pos 开始重写 Blob 对象中的现有字节。如果在写 byte 数组时到达 Blob 值的末尾，则将增加 Blob 值的长度，以容纳额外的字节。

注：如果为 pos 指定的值大于 BLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
pos - BLOB 对象开始进行写入操作的位置；第一个位置是 1
bytes - 要写入此 Blob 对象表示的 BLOB 值中的 byte 数组
返回：
写入的字节数
抛出：
SQLException - 如果访问 BLOB 值时发生错误或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getBytes(long, int)

setBytes

int setBytes(long pos,
             byte[] bytes,
             int offset,
             int len)
             throws SQLException
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。写入操作从 BLOB 值中的位置 pos 处开始；写入给定 byte 数组中的 len 个字节。该 byte 数组将从位置 pos 开始重写 Blob 对象中的现有字节。如果在写 byte 数组时到达 Blob 值的末尾，则将增加 Blob 值的长度，以容纳额外的字节。

注：如果为 pos 指定的值大于 BLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
pos - BLOB 对象开始进行写入操作的位置；第一个位置是 1
bytes - 要写入此 BLOB 对象中的 byte 数组
offset - 数组 bytes 中的偏移量，从此处开始读取要设置的字节
len - 要从 byte 数组 bytes 中写入 BLOB 值的字节数
返回：
写入的字节数
抛出：
SQLException - 如果访问 BLOB 值时发生错误或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getBytes(long, int)

setBinaryStream

OutputStream setBinaryStream(long pos)
                             throws SQLException
获取用于写入此 Blob 对象表示的 BLOB 值的流。该流从位置 pos 处开始。写入流中的字节将从位置 pos 开始重写 Blob 对象中的现有字节。如果在写入流时到达 Blob 值的末尾，则将增加 Blob 值的长度，以容纳额外的字节。

注：如果为 pos 指定的值大于 BLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
pos - BLOB 值中开始进行写入操作的位置；第一个位置是 1
返回：
可以将数据写入其中的 java.io.OutputStream 对象
抛出：
SQLException - 如果访问 BLOB 值时发生错误或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getBinaryStream()

truncate

void truncate(long len)
              throws SQLException
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。

注：如果为 pos 指定的值大于 BLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
len - 此 Blob 对象表示的 BLOB 值将被截取的字节长度
抛出：
SQLException - 如果访问 BLOB 值时发生错误或者 len 小于 0
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

free

void free()
          throws SQLException
此方法释放 Blob 对象以及它所占用的资源。调用 free 方法后，该对象将无效。

在调用 free 方法之后，试图调用 free 之外的方法将导致抛出 SQLException。如果多次调用 free，则对 free 的后续调用被视为无操作 (no-op)。

抛出：
SQLException - 如果在释放 Blob 的资源时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getBinaryStream

InputStream getBinaryStream(long pos,
                            long length)
                            throws SQLException
返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。

参数：
pos - 将获取的部分值第一个字节的偏移量。Blob 中的第一个字节在位置 1 处
length - 将获取的部分值的字节长度
返回：
将从中读取部分 Blob 值的 InputStream。
抛出：
SQLException - 如果 pos 小于 1，或者 pos 大于 Blob 中的字节数，或者 pos + length 大于 Blob 中的字节数
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CallableStatement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 CallableStatement

所有超级接口：
PreparedStatement, Statement, Wrapper
public interface CallableStatement
extends PreparedStatement

用于执行 SQL 存储过程的接口。JDBC API 提供了一个存储过程 SQL 转义语法，该语法允许对所有 RDBMS 使用标准方式调用存储过程。此转义语法有一个包含结果参数的形式和一个不包含结果参数的形式。如果使用结果参数，则必须将其注册为 OUT 参数。其他参数可用于输入、输出或同时用于二者。参数是根据编号按顺序引用的，第一个参数的编号是 1。

   {?= call <procedure-name>[(<arg1>,<arg2>, ...)]}
   {call <procedure-name>[(<arg1>,<arg2>, ...)]}

IN 参数值是使用继承自 PreparedStatement 的 set 方法设置的。在执行存储过程之前，必须注册所有 OUT 参数的类型；它们的值是在执行后通过此类提供的 get 方法获取的。

CallableStatement 可以返回一个 ResultSet 对象或多个 ResultSet 对象。多个 ResultSet 对象是使用继承自 Statement 的操作处理的。

为了获得最大的可移植性，某一调用的 ResultSet 对象和更新计数应该在获得输出参数的值之前处理。

另请参见：
Connection.prepareCall(java.lang.String), ResultSet

字段摘要
从接口 java.sql.Statement 继承的字段
CLOSE_ALL_RESULTS, CLOSE_CURRENT_RESULT, EXECUTE_FAILED, KEEP_CURRENT_RESULT, NO_GENERATED_KEYS, RETURN_GENERATED_KEYS, SUCCESS_NO_INFO
方法摘要
Array | getArray(int parameterIndex) 以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。
Array | getArray(String parameterName) 以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。
BigDecimal | getBigDecimal(int parameterIndex) 以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
BigDecimal | getBigDecimal(int parameterIndex, int scale) 已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
BigDecimal | getBigDecimal(String parameterName) 以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
Blob | getBlob(int parameterIndex) 以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
Blob | getBlob(String parameterName) 以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。
boolean | getBoolean(int parameterIndex) 以 Java 编程语言中 boolean 值的形式获取指定的 JDBC BIT 或 BOOLEAN 参数的值。
boolean | getBoolean(String parameterName) 以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。
byte | getByte(int parameterIndex) 以 Java 编程语言中 byte 的形式获取指定的 JDBC TINYINT 参数的值。
byte | getByte(String parameterName) 以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。
byte[] | getBytes(int parameterIndex) 以 Java 编程语言中 byte 数组值的形式获取指定的 JDBC BINARY 或 VARBINARY 参数的值。
byte[] | getBytes(String parameterName) 以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。
Reader | getCharacterStream(int parameterIndex) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | getCharacterStream(String parameterName) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Clob | getClob(int parameterIndex) 以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
Clob | getClob(String parameterName) 以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。
Date | getDate(int parameterIndex) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。
Date | getDate(int parameterIndex, Calendar cal) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | getDate(String parameterName) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。
Date | getDate(String parameterName, Calendar cal) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
double | getDouble(int parameterIndex) 以 Java 编程语言中 double 值的形式获取指定的 JDBC DOUBLE 参数的值。
double | getDouble(String parameterName) 以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。
float | getFloat(int parameterIndex) 以 Java 编程语言中 float 值的形式获取指定的 JDBC FLOAT 参数的值。
float | getFloat(String parameterName) 以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。
int | getInt(int parameterIndex) 以 Java 编程语言中 int 值的形式获取指定的 JDBC INTEGER 参数的值。
int | getInt(String parameterName) 以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。
long | getLong(int parameterIndex) 以 Java 编程语言中 long 值的形式获取指定的 JDBC BIGINT 参数的值。
long | getLong(String parameterName) 以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。
Reader | getNCharacterStream(int parameterIndex) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
Reader | getNCharacterStream(String parameterName) 以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
NClob | getNClob(int parameterIndex) 以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。
NClob | getNClob(String parameterName) 以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。
String | getNString(int parameterIndex) 以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
String | getNString(String parameterName) 以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
Object | getObject(int parameterIndex) 以 Java 编程语言中 Object 的形式获取指定参数的值。
Object | getObject(int parameterIndex, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | getObject(String parameterName) 以 Java 编程语言中 Object 的形式获取参数的值。
Object | getObject(String parameterName, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
Ref | getRef(int parameterIndex) 以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。
Ref | getRef(String parameterName) 以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。
RowId | getRowId(int parameterIndex) 以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
RowId | getRowId(String parameterName) 以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
short | getShort(int parameterIndex) 以 Java 编程语言中 short 值的形式获取指定的 JDBC SMALLINT 参数的值。
short | getShort(String parameterName) 以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。
SQLXML | getSQLXML(int parameterIndex) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
SQLXML | getSQLXML(String parameterName) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
String | getString(int parameterIndex) 以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
String | getString(String parameterName) 以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
Time | getTime(int parameterIndex) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。
Time | getTime(int parameterIndex, Calendar cal) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | getTime(String parameterName) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。
Time | getTime(String parameterName, Calendar cal) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Timestamp | getTimestamp(int parameterIndex) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。
Timestamp | getTimestamp(int parameterIndex, Calendar cal) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | getTimestamp(String parameterName) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。
Timestamp | getTimestamp(String parameterName, Calendar cal) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
URL | getURL(int parameterIndex) 以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。
URL | getURL(String parameterName) 以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。
void | registerOutParameter(int parameterIndex, int sqlType) 按顺序位置 parameterIndex 将 OUT 参数注册为 JDBC 类型 sqlType。
void | registerOutParameter(int parameterIndex, int sqlType, int scale) 按顺序位置 parameterIndex 将参数注册为 JDBC 类型 sqlType。
void | registerOutParameter(int parameterIndex, int sqlType, String typeName) 注册指定的输出参数。
void | registerOutParameter(String parameterName, int sqlType) 将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。
void | registerOutParameter(String parameterName, int sqlType, int scale) 将名为 parameterName 的参数注册为 JDBC 类型 sqlType。
void | registerOutParameter(String parameterName, int sqlType, String typeName) 注册指定的输出参数。
void | setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | setAsciiStream(String parameterName, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定 java.math.BigDecimal 值。
void | setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
void | setBinaryStream(String parameterName, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。
void | setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | setBoolean(String parameterName, boolean x) 将指定参数设置为给定 Java boolean 值。
void | setByte(String parameterName, byte x) 将指定参数设置为给定 Java byte 值。
void | setBytes(String parameterName, byte[] x) 将指定参数设置为给定 Java byte 数组。
void | setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。
void | setCharacterStream(String parameterName, Reader reader, long length) 将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。
void | setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setDate(String parameterName, Date x) 使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。
void | setDate(String parameterName, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | setDouble(String parameterName, double x) 将指定参数设置为给定 Java double 值。
void | setFloat(String parameterName, float x) 将指定参数设置为给定 Java float 值。
void | setInt(String parameterName, int x) 将指定参数设置为给定 Java int 值。
void | setLong(String parameterName, long x) 将指定参数设置为给定 Java long 值。
void | setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setNString(String parameterName, String value) 将指定参数设置为给定 String 对象。
void | setNull(String parameterName, int sqlType) 将指定参数设置为 SQL NULL。
void | setNull(String parameterName, int sqlType, String typeName) 将指定参数设置为 SQL NULL。
void | setObject(String parameterName, Object x) 使用给定对象设置指定参数的值。
void | setObject(String parameterName, Object x, int targetSqlType) 使用给定对象设置指定参数的值。
void | setObject(String parameterName, Object x, int targetSqlType, int scale) 使用给定对象设置指定参数的值。
void | setRowId(String parameterName, RowId x) 将指定参数设置为给定 java.sql.RowId 对象。
void | setShort(String parameterName, short x) 将指定参数设置为给定 Java short 值。
void | setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | setString(String parameterName, String x) 将指定参数设置为给定 Java String 值。
void | setTime(String parameterName, Time x) 将指定参数设置为给定 java.sql.Time 值。
void | setTime(String parameterName, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定 java.sql.Timestamp 值。
void | setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | setURL(String parameterName, URL val) 将指定参数设置为给定 java.net.URL 对象。
boolean | wasNull() 查询最后一个读取的 OUT 参数是否为 SQL NULL。
从接口 java.sql.PreparedStatement 继承的方法
addBatch, clearParameters, execute, executeQuery, executeUpdate, getMetaData, getParameterMetaData, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBoolean, setByte, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setDate, setDate, setDouble, setFloat, setInt, setLong, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNString, setNull, setNull, setObject, setObject, setObject, setRef, setRowId, setShort, setSQLXML, setString, setTime, setTime, setTimestamp, setTimestamp, setUnicodeStream, setURL
从接口 java.sql.Statement 继承的方法
addBatch, cancel, clearBatch, clearWarnings, close, execute, execute, execute, execute, executeBatch, executeQuery, executeUpdate, executeUpdate, executeUpdate, executeUpdate, getConnection, getFetchDirection, getFetchSize, getGeneratedKeys, getMaxFieldSize, getMaxRows, getMoreResults, getMoreResults, getQueryTimeout, getResultSet, getResultSetConcurrency, getResultSetHoldability, getResultSetType, getUpdateCount, getWarnings, isClosed, isPoolable, setCursorName, setEscapeProcessing, setFetchDirection, setFetchSize, setMaxFieldSize, setMaxRows, setPoolable, setQueryTimeout
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

方法详细信息

registerOutParameter

void registerOutParameter(int parameterIndex,
                          int sqlType)
                          throws SQLException
按顺序位置 parameterIndex 将 OUT 参数注册为 JDBC 类型 sqlType。所有 OUT 参数都必须在执行存储过程前注册。

sqlType 为 OUT 参数指定的 JDBC 类型确定必须用于 get 方法，以读取该参数值的 Java 类型。

如果预期返回给此输出参数的 JDBC 类型是取决于此特定数据库的，则 sqlType 应该是 java.sql.Types.OTHER。方法 getObject(int) 获取该值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
sqlType - java.sql.Types 定义的 JDBC 类型代码。如果参数是 JDBC 类型 NUMERIC 或 DECIMAL，则应使用接受标度值的那种 registerOutParameter。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型
另请参见：
Types

registerOutParameter

void registerOutParameter(int parameterIndex,
                          int sqlType,
                          int scale)
                          throws SQLException
按顺序位置 parameterIndex 将参数注册为 JDBC 类型 sqlType。所有 OUT 参数都必须在执行存储过程前注册。

sqlType 为 OUT 参数指定的 JDBC 类型确定必须用于 get 方法，以读取该参数值的 Java 类型。

这种形式的 registerOutParameter 应该在参数是 JDBC 类型 NUMERIC 或 DECIMAL 时使用。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
sqlType - 由 java.sql.Types 定义的 SQL 类型代码。
scale - 小数点右边所需的位数。该参数必须大于等于 0。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型
另请参见：
Types

wasNull

boolean wasNull()
                throws SQLException
查询最后一个读取的 OUT 参数是否为 SQL NULL。注意，此方法只应该在调用获取方法之后调用；否则没有用来确定它是否为 null 的值。

返回：
如果最后一个读取的参数为 SQL NULL，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法

getString

String getString(int parameterIndex)
                 throws SQLException
以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

对于固定长度类型 SQL CHAR，返回的 String 对象与数据库中的 JDBC CHAR 值完全相同，包括数据库添加的任何填充数据。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setString(java.lang.String, java.lang.String)

getBoolean

boolean getBoolean(int parameterIndex)
                   throws SQLException
以 Java 编程语言中 boolean 值的形式获取指定的 JDBC BIT 或 BOOLEAN 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 false。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setBoolean(java.lang.String, boolean)

getByte

byte getByte(int parameterIndex)
             throws SQLException
以 Java 编程语言中 byte 的形式获取指定的 JDBC TINYINT 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setByte(java.lang.String, byte)

getShort

short getShort(int parameterIndex)
               throws SQLException
以 Java 编程语言中 short 值的形式获取指定的 JDBC SMALLINT 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setShort(java.lang.String, short)

getInt

int getInt(int parameterIndex)
           throws SQLException
以 Java 编程语言中 int 值的形式获取指定的 JDBC INTEGER 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setInt(java.lang.String, int)

getLong

long getLong(int parameterIndex)
             throws SQLException
以 Java 编程语言中 long 值的形式获取指定的 JDBC BIGINT 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setLong(java.lang.String, long)

getFloat

float getFloat(int parameterIndex)
               throws SQLException
以 Java 编程语言中 float 值的形式获取指定的 JDBC FLOAT 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setFloat(java.lang.String, float)

getDouble

double getDouble(int parameterIndex)
                 throws SQLException
以 Java 编程语言中 double 值的形式获取指定的 JDBC DOUBLE 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setDouble(java.lang.String, double)

getBigDecimal

BigDecimal getBigDecimal(int parameterIndex,
                         int scale)
                         throws SQLException
已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)

以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边有 scale 个位数。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
scale - 小数点右边的位数
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
另请参见：
setBigDecimal(java.lang.String, java.math.BigDecimal)

getBytes

byte[] getBytes(int parameterIndex)
                throws SQLException
以 Java 编程语言中 byte 数组值的形式获取指定的 JDBC BINARY 或 VARBINARY 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setBytes(java.lang.String, byte[])

getDate

Date getDate(int parameterIndex)
             throws SQLException
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setDate(java.lang.String, java.sql.Date)

getTime

Time getTime(int parameterIndex)
             throws SQLException
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setTime(java.lang.String, java.sql.Time)

getTimestamp

Timestamp getTimestamp(int parameterIndex)
                       throws SQLException
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
setTimestamp(java.lang.String, java.sql.Timestamp)

getObject

Object getObject(int parameterIndex)
                 throws SQLException
以 Java 编程语言中 Object 的形式获取指定参数的值。如果值为 SQL NULL，则驱动程序返回一个 Java null。

此方法返回一个 Java 对象，其类型对应于使用 registerOutParameter 方法为此参数注册的 JDBC 类型。通过将目标 JDBC 类型注册为 java.sql.Types.OTHER，可以使用此方法来读取特定于数据库的抽象数据类型。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
保存 OUT 参数值的 java.lang.Object
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
另请参见：
Types, setObject(java.lang.String, java.lang.Object, int, int)

getBigDecimal

BigDecimal getBigDecimal(int parameterIndex)
                         throws SQLException
以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
全精度参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
从以下版本开始：
1.2
另请参见：
setBigDecimal(java.lang.String, java.math.BigDecimal)

getObject

Object getObject(int parameterIndex,
                 Map<String,Class<?>> map)
                 throws SQLException
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。

此方法返回一个 Java 对象，其类型对应于使用 registerOutParameter 方法为此参数注册的 JDBC 类型。通过将目标 JDBC 类型注册为 java.sql.Types.OTHER，可以使用此方法来读取特定于数据库的抽象数据类型。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
map - SQL 类型名称到 Java 类的映射关系
返回：
保存 OUT 参数值的 java.lang.Object
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
setObject(java.lang.String, java.lang.Object, int, int)

getRef

Ref getRef(int parameterIndex)
           throws SQLException
以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
Java 编程语言中 Ref 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getBlob

Blob getBlob(int parameterIndex)
             throws SQLException
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
Java 编程语言中 Blob 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getClob

Clob getClob(int parameterIndex)
             throws SQLException
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
Java 编程语言中 Clob 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getArray

Array getArray(int parameterIndex)
               throws SQLException
以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
Java 编程语言中 Array 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getDate

Date getDate(int parameterIndex,
             Calendar cal)
             throws SQLException
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。利用 Calendar 对象，驱动程序可以在考虑自定义时区和语言环境的情况下计算日期。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区和语言环境。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
cal - 供驱动程序用来构造日期的 Calendar 对象
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
从以下版本开始：
1.2
另请参见：
setDate(java.lang.String, java.sql.Date)

getTime

Time getTime(int parameterIndex,
             Calendar cal)
             throws SQLException
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。利用 Calendar 对象，驱动程序可以在考虑自定义时区和语言环境的情况下计算时间。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区和语言环境。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
cal - 供驱动程序用来构造时间的 Calendar 对象
返回：
参数值；如果该值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
从以下版本开始：
1.2
另请参见：
setTime(java.lang.String, java.sql.Time)

getTimestamp

Timestamp getTimestamp(int parameterIndex,
                       Calendar cal)
                       throws SQLException
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。利用 Calendar 对象，驱动程序可以在考虑自定义时区和语言环境的情况下计算时间戳。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区和语言环境。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
cal - 供驱动程序用来构造时间戳的 Calendar 对象
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
从以下版本开始：
1.2
另请参见：
setTimestamp(java.lang.String, java.sql.Timestamp)

registerOutParameter

void registerOutParameter(int parameterIndex,
                          int sqlType,
                          String typeName)
                          throws SQLException
注册指定的输出参数。这种形式的 registerOutParameter 方法应该用于用户定义的输出参数或 REF 输出参数。用户定义类型的示例有：STRUCT、DISTINCT、JAVA_OBJECT 和指定的数组类型。

所有 OUT 参数都必须在执行存储过程前注册。

对于用户定义的参数，还应该提供该参数的完全限定 SQL 类型名称，而 REF 参数则要求提供引用类型的完全限定类型名称。不需要类型代码和类型名称信息的 JDBC 驱动程序可以忽略它。不过，为了便于移植，应用程序应该为用户定义的参数和 REF 参数提供这些值。 尽管此方法是供用户定义的参数和 REF 参数使用的，但也可以将其用于注册任何 JDBC 类型的参数。如果参数没有用户定义的类型或 REF 类型，则忽略 typeName 参数。

注：在读取 out 参数的值时，必须使用某个获取方法，该方法的 Java 类型对应于参数的已注册 SQL 类型。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
sqlType - 取自 Types 的一个值
typeName - SQL 结构类型的完全限定名称
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.2
另请参见：
Types

registerOutParameter

void registerOutParameter(String parameterName,
                          int sqlType)
                          throws SQLException
将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。所有 OUT 参数都必须在执行存储过程前注册。

sqlType 为 OUT 参数指定的 JDBC 类型确定必须用于 get 方法，以读取该参数值的 Java 类型。

如果预期返回给此输出参数的 JDBC 类型是特定于此特定数据库的，则 sqlType 应该是 java.sql.Types.OTHER。方法 getObject(int) 获取该值。

参数：
parameterName - 参数名
sqlType - 由 java.sql.Types 定义的 JDBC 类型代码。如果参数是 JDBC 类型 NUMERIC 或 DECIMAL，则应使用接受标度值的那种 registerOutParameter。
抛出：
SQLException - 如果 parameterName 不对应指定的参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型，或者 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
Types

registerOutParameter

void registerOutParameter(String parameterName,
                          int sqlType,
                          int scale)
                          throws SQLException
将名为 parameterName 的参数注册为 JDBC 类型 sqlType。所有 OUT 参数都必须在执行存储过程前注册。

sqlType 为 OUT 参数指定的 JDBC 类型确定必须用于 get 方法，以读取该参数值的 Java 类型。

这种形式的 registerOutParameter 应该在参数是 JDBC 类型 NUMERIC 或 DECIMAL 时使用。

参数：
parameterName - 参数名
sqlType - 由 java.sql.Types 定义的 SQL 类型代码。
scale - 小数点右边所需的位数。该参数必须大于等于 0。
抛出：
SQLException - 如果 parameterName 不对应指定的参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型，或者 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
Types

registerOutParameter

void registerOutParameter(String parameterName,
                          int sqlType,
                          String typeName)
                          throws SQLException
注册指定的输出参数。这种形式的 registerOutParameter 方法应该用于用户命名的输出参数或 REF 输出参数。用户命名类型的示例有：STRUCT、DISTINCT、JAVA_OBJECT 和指定的数组类型。

所有 OUT 参数都必须在执行存储过程前注册。

对于用户命名的参数，还应该提供参数的完全限定 SQL 类型名称，而 REF 参数则要求提供所引用类型的完全限定类型名称。不需要类型代码和类型名称信息的 JDBC 驱动程序可以忽略它。不过，为了便于移植，应用程序应该为用户命名的参数和 REF 参数提供这些值。尽管此方法是供用户命名的参数和 REF 参数使用的，但也可以将其用于注册任何 JDBC 类型的参数。如果参数没有用户命名的类型或 REF 类型，则忽略 typeName 参数。

注：在读取 out 参数的值时，必须使用 getXXX 方法，其 Java 类型 XXX 对应于参数的已注册 SQL 类型。

参数：
parameterName - 参数名
sqlType - 取自 Types 的一个值
typeName - SQL 结构类型的完全限定名称
抛出：
SQLException - 如果 parameterName 不对应指定的参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型，或者 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
Types

getURL

URL getURL(int parameterIndex)
           throws SQLException
以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
返回：
表示用作指定参数的 JDBC DATALINK 值的 java.net.URL 对象
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法，或者将返回的 URL 在 Java 平台上是一个无效 URL
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setURL(java.lang.String, java.net.URL)

setURL

void setURL(String parameterName,
            URL val)
            throws SQLException
将指定参数设置为给定 java.net.URL 对象。在将该值发送到数据库时，驱动程序将它转换成一个 SQL DATALINK 值。

参数：
parameterName - 参数名
val - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法，或者 URL 是错误的
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getURL(int)

setNull

void setNull(String parameterName,
             int sqlType)
             throws SQLException
将指定参数设置为 SQL NULL。

注：必须指定参数的 SQL 类型。

参数：
parameterName - 参数名
sqlType - java.sql.Types 中定义的 SQL 类型代码
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setBoolean

void setBoolean(String parameterName,
                boolean x)
                throws SQLException
将指定参数设置为给定 Java boolean 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL BIT 或 BOOLEAN 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getBoolean(int)

setByte

void setByte(String parameterName,
             byte x)
             throws SQLException
将指定参数设置为给定 Java byte 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL TINYINT 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getByte(int)

setShort

void setShort(String parameterName,
              short x)
              throws SQLException
将指定参数设置为给定 Java short 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL SMALLINT 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getShort(int)

setInt

void setInt(String parameterName,
            int x)
            throws SQLException
将指定参数设置为给定 Java int 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL INTEGER 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getInt(int)

setLong

void setLong(String parameterName,
             long x)
             throws SQLException
将指定参数设置为给定 Java long 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL BIGINT 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getLong(int)

setFloat

void setFloat(String parameterName,
              float x)
              throws SQLException
将指定参数设置为给定 Java float 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL FLOAT 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getFloat(int)

setDouble

void setDouble(String parameterName,
               double x)
               throws SQLException
将指定参数设置为给定 Java double 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL DOUBLE 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getDouble(int)

setBigDecimal

void setBigDecimal(String parameterName,
                   BigDecimal x)
                   throws SQLException
将指定参数设置为给定 java.math.BigDecimal 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL NUMERIC 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getBigDecimal(int, int)

setString

void setString(String parameterName,
               String x)
               throws SQLException
将指定参数设置为给定 Java String 值。在将此值发送给数据库时，驱动程序将它转换成一个 SQL VARCHAR 或 LONGVARCHAR 值（取决于该参数相对于驱动程序在 VARCHAR 值上的限制的大小）。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getString(int)

setBytes

void setBytes(String parameterName,
              byte[] x)
              throws SQLException
将指定参数设置为给定 Java byte 数组。在将此值发送给数据库时，驱动程序将它转换成一个 SQL VARBINARY 或 LONGVARBINARY 值（取决于该参数相对于驱动程序在 VARBINARY 值上的限制的大小）。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getBytes(int)

setDate

void setDate(String parameterName,
             Date x)
             throws SQLException
使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL DATE 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getDate(int)

setTime

void setTime(String parameterName,
             Time x)
             throws SQLException
将指定参数设置为给定 java.sql.Time 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL TIME 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getTime(int)

setTimestamp

void setTimestamp(String parameterName,
                  Timestamp x)
                  throws SQLException
将指定参数设置为给定 java.sql.Timestamp 值。在将该值发送到数据库时，驱动程序将它转换成一个 SQL TIMESTAMP 值。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getTimestamp(int)

setAsciiStream

void setAsciiStream(String parameterName,
                    InputStream x,
                    int length)
                    throws SQLException
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。在将一个非常大的 ASCII 值输入给 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注：此流对象可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数名
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setBinaryStream

void setBinaryStream(String parameterName,
                     InputStream x,
                     int length)
                     throws SQLException
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。在将一个非常大的二进制值输入给 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注：此流对象可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数名
x - 包含二进制参数值的 java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setObject

void setObject(String parameterName,
               Object x,
               int targetSqlType,
               int scale)
               throws SQLException
使用给定对象设置指定参数的值。第二个参数必须是一个对象类型；对于整数值，应该使用 java.lang 的等效对象。

在被发送到数据库之前，给定 Java 对象将被转换为给定 targetSqlType。 如果对象具有自定义映射关系（是实现 SQLData 接口的类），则 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流中。另一方面，如果该对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将它作为相应 SQL 类型的值传递给数据库。

注意，此方法可用于传递特定于数据库的抽象数据类型。

参数：
parameterName - 参数名
x - 包含输入参数值的对象
targetSqlType - 将发送到数据库的 SQL 类型（在 java.sql.Types 中定义）。scale 参数可以进一步限定此类型。
scale - 对于 java.sql.Types.DECIMAL 或 java.sql.Types.NUMERIC 类型，该参数是小数点后的位数。对于其他所有类型，将忽略此值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.4
另请参见：
Types, getObject(int)

setObject

void setObject(String parameterName,
               Object x,
               int targetSqlType)
               throws SQLException
使用给定对象设置指定参数的值。除了假定 scale 为 0 外，此方法类似于上面的 setObject 方法。

参数：
parameterName - 参数名
x - 包含输入参数值的对象
targetSqlType - 要发送到数据库的 SQL 类型（在 java.sql.Types 中定义）
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.4
另请参见：
getObject(int)

setObject

void setObject(String parameterName,
               Object x)
               throws SQLException
使用给定对象设置指定参数的值。第二个参数必须是类型 Object；所以，应该对内置类型使用 java.lang 的等效对象。

JDBC 规范指定了一个从 Java Object 类型到 SQL 类型的标准映射关系。在被发送到数据库之前，给定参数将被转换为相应 SQL 类型。

注意，通过使用特定于驱动程序的 Java 类型，此方法可用于传递特定于数据库的抽象数据类型。 如果对象是实现 SQLData 接口的类，则 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流中。另一方面，如果该对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将它作为相应 SQL 类型的值传递给数据库。

如果出现混淆，例如，如果该对象是实现不止一个上述指定接口的类，则此方法抛出异常。

注： 并非所有允许非类型 Null 的数据库都被发送到后端。为了获得最大的可移植性，应该使用 setNull 或 setObject(String parameterName, Object x, int sqlType) 方法替代 setObject(String parameterName, Object x)。

参数：
parameterName - 参数名
x - 包含输入参数值的对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法，或者给定的 Object 参数不明确
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getObject(int)

setCharacterStream

void setCharacterStream(String parameterName,
                        Reader reader,
                        int length)
                        throws SQLException
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。在将一个非常大的 UNICODE 值输入给 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注：此流对象可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数名
reader - 包含用作指定参数的 UNICODE 数据的 java.io.Reader 对象
length - 流中的字节数
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setDate

void setDate(String parameterName,
             Date x,
             Calendar cal)
             throws SQLException
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。驱动程序使用 Calendar 对象构造一个 SQL DATE 值，该值随后被驱动程序发送给数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算日期。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数名
x - 参数值
cal - 供驱动程序用来构造日期的 Calendar 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getDate(int)

setTime

void setTime(String parameterName,
             Time x,
             Calendar cal)
             throws SQLException
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。驱动程序使用 Calendar 对象构造一个 SQL TIME 值，该值随后被驱动程序发送给数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数名
x - 参数值
cal - 供驱动程序用来构造时间的 Calendar 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getTime(int)

setTimestamp

void setTimestamp(String parameterName,
                  Timestamp x,
                  Calendar cal)
                  throws SQLException
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。驱动程序使用 Calendar 对象构造一个 SQL TIMESTAMP 值，该值随后被驱动程序发送给数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间戳。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数名
x - 参数值
cal - 供驱动程序用来构造时间戳的 Calendar 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getTimestamp(int)

setNull

void setNull(String parameterName,
             int sqlType,
             String typeName)
             throws SQLException
将指定参数设置为 SQL NULL。这种形式的 setNull 方法应该用于用户定义类型的参数或 REF 类型的参数。用户定义类型的示例有：STRUCT、DISTINCT、JAVA_OBJECT 和指定的数组类型。

注：为了便于移植，在指定 NULL 用户定义参数或 REF 参数时，应用程序必须提供 SQL 类型代码和完全限定的 SQL 类型名称。对于用户定义的类型，该名称是参数本身的类型名称。对于 REF 参数，该名称是所引用类型的类型名称。

尽管此方法是供用户定义的参数和 Ref 参数使用的，但也可以将其用于设置任何 JDBC 类型的 null 参数。如果参数没有用户定义的类型或 REF 类型，则忽略 typeName。

参数：
parameterName - 参数名
sqlType - 取自 java.sql.Types 的一个值
typeName - SQL 用户定义类型的完全限定名；如果该参数不是用户定义的类型或 SQL REF 值，则忽略它
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getString

String getString(String parameterName)
                 throws SQLException
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。

对于固定长度类型 JDBC CHAR，返回的 String 对象与数据库拥有的 SQL CHAR 值完全相同，包括数据库添加的任何填充数据。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setString(java.lang.String, java.lang.String)

getBoolean

boolean getBoolean(String parameterName)
                   throws SQLException
以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 false。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setBoolean(java.lang.String, boolean)

getByte

byte getByte(String parameterName)
             throws SQLException
以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setByte(java.lang.String, byte)

getShort

short getShort(String parameterName)
               throws SQLException
以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setShort(java.lang.String, short)

getInt

int getInt(String parameterName)
           throws SQLException
以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setInt(java.lang.String, int)

getLong

long getLong(String parameterName)
             throws SQLException
以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setLong(java.lang.String, long)

getFloat

float getFloat(String parameterName)
               throws SQLException
以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setFloat(java.lang.String, float)

getDouble

double getDouble(String parameterName)
                 throws SQLException
以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 0。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setDouble(java.lang.String, double)

getBytes

byte[] getBytes(String parameterName)
                throws SQLException
以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setBytes(java.lang.String, byte[])

getDate

Date getDate(String parameterName)
             throws SQLException
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setDate(java.lang.String, java.sql.Date)

getTime

Time getTime(String parameterName)
             throws SQLException
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setTime(java.lang.String, java.sql.Time)

getTimestamp

Timestamp getTimestamp(String parameterName)
                       throws SQLException
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。

参数：
parameterName - 参数名
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setTimestamp(java.lang.String, java.sql.Timestamp)

getObject

Object getObject(String parameterName)
                 throws SQLException
以 Java 编程语言中 Object 的形式获取参数的值。如果值为 SQL NULL，则驱动程序返回一个 Java null。

此方法返回一个 Java 对象，其类型对应于使用 registerOutParameter 方法为此参数注册的 JDBC 类型。通过将目标 JDBC 类型注册为 java.sql.Types.OTHER，可以使用此方法来读取特定于数据库的抽象数据类型。

参数：
parameterName - 参数名
返回：
保存 OUT 参数值的 java.lang.Object。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
Types, setObject(java.lang.String, java.lang.Object, int, int)

getBigDecimal

BigDecimal getBigDecimal(String parameterName)
                         throws SQLException
以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。

参数：
parameterName - 参数名
返回：
全精度参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setBigDecimal(java.lang.String, java.math.BigDecimal)

getObject

Object getObject(String parameterName,
                 Map<String,Class<?>> map)
                 throws SQLException
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。

此方法返回一个 Java 对象，其类型对应于使用 registerOutParameter 方法为此参数注册的 JDBC 类型。通过将目标 JDBC 类型注册为 java.sql.Types.OTHER，可以使用此方法来读取特定于数据库的抽象数据类型。

参数：
parameterName - 参数名
map - SQL 类型名称到 Java 类的映射关系
返回：
保存 OUT 参数值的 java.lang.Object
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setObject(java.lang.String, java.lang.Object, int, int)

getRef

Ref getRef(String parameterName)
           throws SQLException
以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。

参数：
parameterName - 参数名
返回：
Java 编程语言中 Ref 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getBlob

Blob getBlob(String parameterName)
             throws SQLException
以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。

参数：
parameterName - 参数名
返回：
Java 编程语言中 Blob 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getClob

Clob getClob(String parameterName)
             throws SQLException
以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。

参数：
parameterName - 参数名
返回：
Java 编程语言中 Clob 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getArray

Array getArray(String parameterName)
               throws SQLException
以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。

参数：
parameterName - 参数名
返回：
Java 编程语言中 ARRAY 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getDate

Date getDate(String parameterName,
             Calendar cal)
             throws SQLException
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。利用 Calendar 对象，驱动程序可以在考虑自定义时区和语言环境的情况下计算日期。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区和语言环境。

参数：
parameterName - 参数名
cal - 供驱动程序用来构造日期的 Calendar 对象
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 并不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setDate(java.lang.String, java.sql.Date)

getTime

Time getTime(String parameterName,
             Calendar cal)
             throws SQLException
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。利用 Calendar 对象，驱动程序可以在考虑自定义时区和语言环境的情况下计算时间。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区和语言环境。

参数：
parameterName - 参数名
cal - 供驱动程序用来构造时间的 Calendar 对象
返回：
参数值；如果该值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setTime(java.lang.String, java.sql.Time)

getTimestamp

Timestamp getTimestamp(String parameterName,
                       Calendar cal)
                       throws SQLException
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。利用 Calendar 对象，驱动程序可以在考虑自定义时区和语言环境的情况下计算时间戳。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区和语言环境。

参数：
parameterName - 参数名
cal - 供驱动程序用来构造时间戳的 Calendar 对象
返回：
参数值。如果值为 SQL NULL，则结果为 null。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setTimestamp(java.lang.String, java.sql.Timestamp)

getURL

URL getURL(String parameterName)
           throws SQLException
以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。

参数：
parameterName - 参数名
返回：
Java 编程语言中 java.net.URL 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法，或者 URL 有问题
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setURL(java.lang.String, java.net.URL)

getRowId

RowId getRowId(int parameterIndex)
               throws SQLException
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
返回：
表示被用作指定参数的 JDBC ROWID 值的 RowId 对象。如果该参数包含一个 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getRowId

RowId getRowId(String parameterName)
               throws SQLException
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。

参数：
parameterName - 参数名
返回：
表示被用作指定参数的 JDBC ROWID 值的 RowId 对象。如果该参数包含一个 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setRowId

void setRowId(String parameterName,
              RowId x)
              throws SQLException
将指定参数设置为给定 java.sql.RowId 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL ROWID。

参数：
parameterName - 参数名
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNString

void setNString(String parameterName,
                String value)
                throws SQLException
将指定参数设置为给定 String 对象。驱动程序将此对象转换成一个 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR。

参数：
parameterName - 要设置的参数的名称
value - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果驱动程序不支持国家字符 (national character) 集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(String parameterName,
                         Reader value,
                         long length)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 将读取数据，直到到达文件末尾。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。

参数：
parameterName - 要设置的参数名
参数值 -
length - 该参数数据中的字符数。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(String parameterName,
              NClob value)
              throws SQLException
将指定参数设置为 java.sql.NClob 对象。该对象实现 java.sql.NClob 接口。此 NClob 对象映射到 SQL NCLOB。

参数：
parameterName - 要设置的参数名
value - 参数值
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(String parameterName,
             Reader reader,
             long length)
             throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 指定的字符数，否则在执行 CallableStatement 时将生成一个 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它会通知驱动程序应该将参数值作为 CLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARCHAR 还是 CLOB 发送给服务器

参数：
parameterName - 要设置的参数名
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果指定的 length 小于 0；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(String parameterName,
             InputStream inputStream,
             long length)
             throws SQLException
将指定参数设置为 InputStream 对象。inputstream 必须包含 length 指定的字符数，否则在执行 CallableStatement 时将生成一个 SQLException。此方法不同于 setBinaryStream (int, InputStream, int) 方法，因为它会通知驱动程序应该将参数值作为 BLOB 发送给服务器。在使用 setBinaryStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARBINARY 还是 BLOB 发送给服务器

参数：
parameterName - 要设置的参数名
inputStream - 包含用来设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果指定的 length 小于 0；如果输入流中的字节数与指定 length 不匹配；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(String parameterName,
              Reader reader,
              long length)
              throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 指定的字符数，否则在执行 CallableStatement 时将生成一个 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它会通知驱动程序应该将参数值作为 NCLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGNVARCHAR 还是 NCLOB 发送给服务器

参数：
parameterName - 要设置的参数名
reader - 包含用于设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果指定 length 小于 0；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNClob

NClob getNClob(int parameterIndex)
               throws SQLException
以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，依此类推
返回：
Java 编程语言中 NClob 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterIndex 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNClob

NClob getNClob(String parameterName)
               throws SQLException
以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。

参数：
parameterName - 参数名
返回：
Java 编程语言中 NClob 对象形式的参数值。如果值为 SQL NULL，则返回 null 值。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setSQLXML

void setSQLXML(String parameterName,
               SQLXML xmlObject)
               throws SQLException
将指定参数设置为给定 java.sql.SQLXML 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL XML 值。

参数：
parameterName - 参数名
xmlObject - 映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误；在关闭的 CallableStatement 上调用此方法，或者 java.xml.transform.Result、Writer 或 OutputStream 没有关闭（对于 SQLXML 对象而言）
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getSQLXML

SQLXML getSQLXML(int parameterIndex)
                 throws SQLException
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
返回：
映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getSQLXML

SQLXML getSQLXML(String parameterName)
                 throws SQLException
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。

参数：
parameterName - 参数名
返回：
映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNString

String getNString(int parameterIndex)
                  throws SQLException
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

对于固定长度类型 JDBC NCHAR，返回的 String 对象与数据库拥有的 SQL NCHAR 值完全相同，包括数据库添加的任何填充数据。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
返回：
映射 NCHAR、NVARCHAR 或 LONGNVARCHAR 值的 String 对象
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
另请参见：
setNString(java.lang.String, java.lang.String)

getNString

String getNString(String parameterName)
                  throws SQLException
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。

对于固定长度类型 JDBC NCHAR，返回的 String 对象与数据库中所拥有的 SQL NCHAR 值完全相同，包括数据库添加的任何填充数据。

参数：
parameterName - 参数名
返回：
映射 NCHAR、NVARCHAR 或 LONGNVARCHAR 值的 String 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
另请参见：
setNString(java.lang.String, java.lang.String)

getNCharacterStream

Reader getNCharacterStream(int parameterIndex)
                           throws SQLException
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。此方法用于访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 参数时。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
返回：
包含参数值的 java.io.Reader 对象；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNCharacterStream

Reader getNCharacterStream(String parameterName)
                           throws SQLException
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。此方法用于访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 参数时。

参数：
parameterName - 参数名
返回：
包含参数值的 java.io.Reader 对象；如果该值为 SQL NULL，则返回值是 Java 编程语言中的 null
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getCharacterStream

Reader getCharacterStream(int parameterIndex)
                          throws SQLException
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
返回：
包含参数值的 java.io.Reader 对象；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null。
抛出：
SQLException - 如果 parameterIndex 无效；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
从以下版本开始：
1.6

getCharacterStream

Reader getCharacterStream(String parameterName)
                          throws SQLException
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。

参数：
parameterName - 参数名
返回：
包含参数值的 java.io.Reader 对象；如果该值为 SQL NULL，则返回值是 Java 编程语言中的 null
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(String parameterName,
             Blob x)
             throws SQLException
将指定参数设置为给定的 java.sql.Blob 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL BLOB 值。

参数：
parameterName - 参数名
x - 映射 SQL BLOB 值的 Blob 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(String parameterName,
             Clob x)
             throws SQLException
将指定参数设置为给定的 java.sql.Clob 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL CLOB 值。

参数：
parameterName - 参数名
x - 映射 SQL CLOB 值的 Clob 对象
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setAsciiStream

void setAsciiStream(String parameterName,
                    InputStream x,
                    long length)
                    throws SQLException
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数名
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

void setBinaryStream(String parameterName,
                     InputStream x,
                     long length)
                     throws SQLException
将指定参数设置为给定输入流，该输入流将拥有指定字节数。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数名
x - 包含二进制参数值的 java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setCharacterStream

void setCharacterStream(String parameterName,
                        Reader reader,
                        long length)
                        throws SQLException
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。在将一个非常大的 UNICODE 值输入给 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数名
reader - 包含用作指定参数的 UNICODE 数据的 java.io.Reader 对象
length - 流中的字节数
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setAsciiStream

void setAsciiStream(String parameterName,
                    InputStream x)
                    throws SQLException
将指定参数设置为给定输入流。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setAsciiStream 是否更有效。

参数：
parameterName - 参数名
x - 包含 ASCII 参数值的 Java 输入流
x - 参数值
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

void setBinaryStream(String parameterName,
                     InputStream x)
                     throws SQLException
将指定参数设置为给定输入流。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setBinaryStream 是否更有效。

参数：
parameterName - 参数名
x - 包含二进制参数值的 java 输入流
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setCharacterStream

void setCharacterStream(String parameterName,
                        Reader reader)
                        throws SQLException
将指定参数设置为给定 Reader 对象。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setCharacterStream 是否更有效。

参数：
parameterName - 参数名
reader - 包含 Unicode 数据的 java.io.Reader 对象
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(String parameterName,
                         Reader value)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 将读取数据，直到到达文件末尾。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setNCharacterStream 是否更有效。

参数：
parameterName - 要设置的参数名
value - 参数值
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(String parameterName,
             Reader reader)
             throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它会通知驱动程序应该将参数值作为 CLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARCHAR 还是 CLOB 发送给服务器。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setClob 是否更有效。

参数：
parameterName - 参数名
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterName 不对应于指定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(String parameterName,
             InputStream inputStream)
             throws SQLException
将指定参数设置为 InputStream 对象。此方法不同于 setBinaryStream (int, InputStream) 方法，因为它会通知驱动程序应该将参数值作为 BLOB 发送给服务器。在使用 setBinaryStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARBINARY 还是 BLOB 发送给服务器。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setBlob 是否更有效。

参数：
parameterName - 参数名
inputStream - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(String parameterName,
              Reader reader)
              throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它会通知驱动程序应该将参数值作为 NCLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGNVARCHAR 还是 NCLOB 发送给服务器。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setNClob 是否更有效。

参数：
parameterName - 参数名
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterName 不对应于给定参数；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ClientInfoStatus (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.sql
枚举 ClientInfoStatus

java.lang.Object
    继承者  java.lang.Enum<ClientInfoStatus>
        继承者  java.sql.ClientInfoStatus
所有已实现的接口：
Serializable, Comparable<ClientInfoStatus>
public enum ClientInfoStatus
extends Enum<ClientInfoStatus>

无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。

从以下版本开始：
1.6

枚举常量摘要
REASON_UNKNOWN
由于某种未知原因而无法设置客户端信息属性
REASON_UNKNOWN_PROPERTY
指定的客户端信息属性不是一个可识别的属性名称。
REASON_VALUE_INVALID
为客户端信息属性指定的值无效。
REASON_VALUE_TRUNCATED
为客户端信息属性指定的值太大。
方法摘要
static ClientInfoStatus | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ClientInfoStatus[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

REASON_UNKNOWN

public static final ClientInfoStatus REASON_UNKNOWN
由于某种未知原因而无法设置客户端信息属性

从以下版本开始：
1.6

REASON_UNKNOWN_PROPERTY

public static final ClientInfoStatus REASON_UNKNOWN_PROPERTY
指定的客户端信息属性不是一个可识别的属性名称。

从以下版本开始：
1.6

REASON_VALUE_INVALID

public static final ClientInfoStatus REASON_VALUE_INVALID
为客户端信息属性指定的值无效。

从以下版本开始：
1.6

REASON_VALUE_TRUNCATED

public static final ClientInfoStatus REASON_VALUE_TRUNCATED
为客户端信息属性指定的值太大。

从以下版本开始：
1.6
方法详细信息

values

public static final ClientInfoStatus[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(ClientInfoStatus c : ClientInfoStatus.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ClientInfoStatus valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Clob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Clob

所有已知子接口：
NClob
所有已知实现类：
SerialClob
public interface Clob

SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。SQL CLOB 是内置类型，它将字符大对象 (Character Large Object) 存储为数据库表某一行中的一个列值。默认情况下，驱动程序使用 SQL locator(CLOB) 实现 Clob 对象，这意味着 CLOB 对象包含一个指向 SQL CLOB 数据的逻辑指针而不是数据本身。Clob 对象在它被创建的事务处理期间有效。

CLOB 接口提供一些方法来获取 SQL CLOB (Character Large Object) 值长度、在客户端实现 CLOB 值以及搜索 CLOB 值中的子字符串或 CLOB 对象。接口 ResultSet、CallableStatement 和 PreparedStatement 中的方法（如 getClob 和 setClob）允许编程人员访问 SQL CLOB 值。此外，此接口还拥有更新 CLOB 值的方法。

如果 JDBC 驱动程序支持该数据类型，则必须完全实现 Clob 接口上的所有方法。

从以下版本开始：
1.2

方法摘要
void | free() 此方法释放 Clob 对象以及它所占用的资源。
InputStream | getAsciiStream() 以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。
Reader | getCharacterStream() 以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。
Reader | getCharacterStream(long pos, long length) 返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
String | getSubString(long pos, int length) 获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。
long | length() 获取此 Clob 对象指定的 CLOB 值中的字符数。
long | position(Clob searchstr, long start) 获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。
long | position(String searchstr, long start) 获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。
OutputStream | setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。
Writer | setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。
int | setString(long pos, String str) 在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。
int | setString(long pos, String str, int offset, int len) 将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。
void | truncate(long len) 截取此 Clob 指定的 CLOB 值，使其长度为 len 个字符。

方法详细信息

length

long length()
            throws SQLException
获取此 Clob 对象指定的 CLOB 值中的字符数。

返回：
CLOB 的字符长度
抛出：
SQLException - 如果访问 CLOB 值的长度时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getSubString

String getSubString(long pos,
                    int length)
                    throws SQLException
获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。子字符串开始于位置 pos 处，有 length 个连续字符。

参数：
pos - 要提取的子字符串的第一个字符。第一个字符位于位置 1 处。
length - 要复制的连续字符的数量；length 的值必须大于等于 0
返回：
一个 String，它是由此 Clob 对象指定的 CLOB 值中的指定子字符串
抛出：
SQLException - 如果访问 CLOB 值时发生错误；如果 pos 小于 1 或者 length 小于 0
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getCharacterStream

Reader getCharacterStream()
                          throws SQLException
以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。

返回：
包含 CLOB 数据的 java.io.Reader 对象
抛出：
SQLException - 如果访问 CLOB 值时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
setCharacterStream(long)

getAsciiStream

InputStream getAsciiStream()
                           throws SQLException
以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。

返回：
包含 CLOB 数据的 java.io.InputStream 对象
抛出：
SQLException - 如果访问 CLOB 值时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
setAsciiStream(long)

position

long position(String searchstr,
              long start)
              throws SQLException
获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。从位置 start 开始搜索。

参数：
searchstr - 要搜索的子字符串
start - 开始搜索的位置；第一个位置是 1
返回：
子字符串出现的位置；如果没有出现，则返回 -1；第一个位置是 1
抛出：
SQLException - 如果访问 CLOB 值时发生错误，或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

position

long position(Clob searchstr,
              long start)
              throws SQLException
获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。从位置 start 开始搜索。

参数：
searchstr - 要搜索的 Clob 对象
start - 开始搜索的位置；第一个位置是 1
返回：
Clob 对象出现的位置；如果没有出现，则返回 -1；第一个位置是 1
抛出：
SQLException - 如果访问 CLOB 值时发生错误，或者 start 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setString

int setString(long pos,
              String str)
              throws SQLException
在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。该字符串将从位置 pos 开始重写 Clob 对象中的现有字节。如果在写入给定字符串时到达 Clob 值的末尾，则将增加 Clob 值的长度，以容纳额外的字符。

注：如果为 pos 指定的值大于 CLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
pos - 开始写入此 Clob 对象表示的 CLOB 值的位置；第一个位置是 1
str - 要写入此 Clob 指定的 CLOB 值中的字符串
返回：
写入的字符数
抛出：
SQLException - 如果访问 CLOB 值时发生错误，或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setString

int setString(long pos,
              String str,
              int offset,
              int len)
              throws SQLException
将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。该字符串将从位置 pos 开始重写 Clob 对象中的现有字节。如果在写入给定字符串时到达 Clob 值的末尾，则将增加 Clob 值的长度，以容纳额外的字符。

注：如果为 pos 指定的值大于 CLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
pos - 开始写入此 CLOB 对象的位置；第一个位置是 1
str - 要写入此 Clob 对象表示的 CLOB 值中的字符串
offset - str 中开始读取要写入字符的偏移量
len - 要写入的字符数
返回：
写入的字符数
抛出：
SQLException - 如果访问 CLOB 值时发生错误，或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setAsciiStream

OutputStream setAsciiStream(long pos)
                            throws SQLException
获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。写入流中的字符将从位置 pos 开始重写 Clob 对象中的现有字节。如果在将字符写入流中时到达 Clob 值的末尾，则将增加 Clob 值的长度，以容纳额外的字符。

注：如果为 pos 指定的值大于 CLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
pos - 开始写入此 CLOB 对象中的位置；第一个位置是 1
返回：
可以将 ASCII 编码字符写入其中的流
抛出：
SQLException - 如果访问 CLOB 值时发生错误，或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getBinaryStream

setCharacterStream

Writer setCharacterStream(long pos)
                          throws SQLException
获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。写入流中的字符将从位置 pos 开始重写 Clob 对象中的现有字节。如果在将字符写入流中时到达 Clob 值的末尾，则将增加 Clob 值的长度，以容纳额外的字符。

注：如果为 pos 指定的值大于 CLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
pos - 开始写入 CLOB 值中的位置；第一个位置是 1
返回：
可将 Unicode 编码字符写入其中的流
抛出：
SQLException - 如果访问 CLOB 值时发生错误，或者 pos 小于 1
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getCharacterStream()

truncate

void truncate(long len)
              throws SQLException
截取此 Clob 指定的 CLOB 值，使其长度为 len 个字符。

注：如果为 pos 指定的值大于 CLOB 值的长度+1，则行为是不确定的。一些 JDBC 驱动程序可能抛出 SQLException，而另一些驱动程序可能支持此操作。

参数：
len - CLOB 值应被截取的字符长度
抛出：
SQLException - 如果访问 CLOB 值时发生错误，或者 len 小于 0
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

free

void free()
          throws SQLException
此方法释放 Clob 对象以及它所占用的资源。调用 free 方法后，该对象无效。

在调用 free 方法之后，试图调用 free 之外的方法将导致抛出 SQLException。如果多次调用 free，则对 free 的后续调用被视为无操作 (no-op)。

抛出：
SQLException - 如果释放 Clob 的资源时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getCharacterStream

Reader getCharacterStream(long pos,
                          long length)
                          throws SQLException
返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。

参数：
pos - 将获取的部分值第一个字符的偏移量。Clob 中的第一个字符在位置 1 处。
length - 要获取的部分值的字符长度。
返回：
Reader，可以通过它来读取部分 Clob 值。
抛出：
SQLException - 如果 pos 小于 1，或者 pos 大于 Clob 中的字符数，或者 pos + length 大于 Clob 中的字符数
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Connection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Connection

所有超级接口：
Wrapper
public interface Connection
extends Wrapper

与特定数据库的连接（会话）。在连接上下文中执行 SQL 语句并返回结果。

Connection 对象的数据库能够提供描述其表、所支持的 SQL 语法、存储过程、此连接功能等等的信息。此信息是使用 getMetaData 方法获得的。

注：在配置 Connection 时，JDBC 应用程序应该使用适当的 Connection 方法，比如 setAutoCommit 或 setTransactionIsolation。在有可用的 JDBC 方法时，应用程序不能直接调用 SQL 命令更改连接的配置。默认情况下，Connection 对象处于自动提交模式下，这意味着它在执行每个语句后都会自动提交更改。如果禁用了自动提交模式，那么要提交更改就必须显式调用 commit 方法；否则无法保存数据库更改。

使用 JDBC 2.1 核心 API 创建的新 Connection 对象有一个与之关联的最初为空的类型映射。用户可以为此类型映射中的 UDT 输入一个自定义映射关系。在使用 ResultSet.getObject 方法从数据源中获取 UDT 时，getObject 方法将检查该连接的类型映射是否有对应该 UDT 的条目。如果有，那么 getObject 方法将该 UDT 映射到所指示的类。如果没有条目，则使用标准映射关系映射该 UDT。

用户可以创建一个新的类型映射，该映射是一个 java.util.Map 对象，可在其中创建一个条目，并将该条目传递给可以执行自定义映射关系的 java.sql 方法。在这种情况下，该方法将使用给定的类型映射，而不是与连接关联的映射。

例如，以下代码片段指定 SQL 类型 ATHLETES 将被映射到 Java 编程语言中的 Athletes 类。该代码片段为 Connection 对象 con 获取类型映射，并在其中插入条目，然后使用新的条目将该类型映射设置为连接的类型映射。

      java.util.Map map = con.getTypeMap();
      map.put("mySchemaName.ATHLETES", Class.forName("Athletes"));
      con.setTypeMap(map);

另请参见：
DriverManager.getConnection(java.lang.String, java.util.Properties), Statement, ResultSet, DatabaseMetaData

字段摘要
static int | TRANSACTION_NONE 指示事务不受支持的常量。
static int | TRANSACTION_READ_COMMITTED 指示不可以发生脏读的常量；不可重复读和虚读可以发生。
static int | TRANSACTION_READ_UNCOMMITTED 指示可以发生脏读 (dirty read)、不可重复读和虚读 (phantom read) 的常量。
static int | TRANSACTION_REPEATABLE_READ 指示不可以发生脏读和不可重复读的常量；虚读可以发生。
static int | TRANSACTION_SERIALIZABLE 指示不可以发生脏读、不可重复读和虚读的常量。
方法摘要
void | clearWarnings() 清除为此 Connection 对象报告的所有警告。
void | close() 立即释放此 Connection 对象的数据库和 JDBC 资源，而不是等待它们被自动释放。
void | commit() 使所有上一次提交/回滚后进行的更改成为持久更改，并释放此 Connection 对象当前持有的所有数据库锁。
Array | createArrayOf(String typeName, Object[] elements) 创建 Array 对象的工厂方法。
Blob | createBlob() 构造实现 Blob 接口的对象。
Clob | createClob() 构造实现 Clob 接口的对象。
NClob | createNClob() 构造实现 NClob 接口的对象。
SQLXML | createSQLXML() 构造实现 SQLXML 接口的对象。
Statement | createStatement() 创建一个 Statement 对象来将 SQL 语句发送到数据库。
Statement | createStatement(int resultSetType, int resultSetConcurrency) 创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
Statement | createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
Struct | createStruct(String typeName, Object[] attributes) 创建 Struct 对象的工厂方法。
boolean | getAutoCommit() 获取此 Connection 对象的当前自动提交模式。
String | getCatalog() 获取此 Connection 对象的当前目录名称。
Properties | getClientInfo() 返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。
String | getClientInfo(String name) 返回通过名称指定的客户端信息属性的值。
int | getHoldability() 获取使用此 Connection 对象创建的 ResultSet 对象的当前可保存性。
DatabaseMetaData | getMetaData() 获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。
int | getTransactionIsolation() 获取此 Connection 对象的当前事务隔离级别。
Map<String,Class<?>> | getTypeMap() 获取与此 Connection 对象关联的 Map 对象。
SQLWarning | getWarnings() 获取此 Connection 对象上的调用报告的第一个警告。
boolean | isClosed() 查询此 Connection 对象是否已经被关闭。
boolean | isReadOnly() 查询此 Connection 对象是否处于只读模式。
boolean | isValid(int timeout) 如果连接尚未关闭并且仍然有效，则返回 true。
String | nativeSQL(String sql) 将给定的 SQL 语句转换成系统本机 SQL 语法。
CallableStatement | prepareCall(String sql) 创建一个 CallableStatement 对象来调用数据库存储过程。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency) 创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
CallableStatement | prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
PreparedStatement | prepareStatement(String sql) 创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。
PreparedStatement | prepareStatement(String sql, int autoGeneratedKeys) 创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。
PreparedStatement | prepareStatement(String sql, int[] columnIndexes) 创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency) 创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
PreparedStatement | prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
PreparedStatement | prepareStatement(String sql, String[] columnNames) 创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
void | releaseSavepoint(Savepoint savepoint) 从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。
void | rollback() 取消在当前事务中进行的所有更改，并释放此 Connection 对象当前持有的所有数据库锁。
void | rollback(Savepoint savepoint) 取消所有设置给定 Savepoint 对象之后进行的更改。
void | setAutoCommit(boolean autoCommit) 将此连接的自动提交模式设置为给定状态。
void | setCatalog(String catalog) 设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。
void | setClientInfo(Properties properties) 设置连接的客户端信息属性的值。
void | setClientInfo(String name, String value) 将 name 指定的客户端信息属性的值设置为 value 指定的值。
void | setHoldability(int holdability) 将使用此 Connection 对象创建的 ResultSet 对象的默认可保存性 (holdability) 更改为给定可保存性。
void | setReadOnly(boolean readOnly) 将此连接设置为只读模式，作为驱动程序启用数据库优化的提示。
Savepoint | setSavepoint() 在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。
Savepoint | setSavepoint(String name) 在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。
void | setTransactionIsolation(int level) 试图将此 Connection 对象的事务隔离级别更改为给定的级别。
void | setTypeMap(Map<String,Class<?>> map) 将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

字段详细信息

TRANSACTION_NONE

static final int TRANSACTION_NONE
指示事务不受支持的常量。

另请参见：
常量字段值

TRANSACTION_READ_UNCOMMITTED

static final int TRANSACTION_READ_UNCOMMITTED
指示可以发生脏读 (dirty read)、不可重复读和虚读 (phantom read) 的常量。此级别允许被某一事务更改的行在已提交该行所有更改之前被另一个事务读取（“脏读”）。如果所有更改都被回滚，则第二个事务将获取无效的行。

另请参见：
常量字段值

TRANSACTION_READ_COMMITTED

static final int TRANSACTION_READ_COMMITTED
指示不可以发生脏读的常量；不可重复读和虚读可以发生。此级别只禁止事务读取其中带有未提交更改的行。

另请参见：
常量字段值

TRANSACTION_REPEATABLE_READ

static final int TRANSACTION_REPEATABLE_READ
指示不可以发生脏读和不可重复读的常量；虚读可以发生。此级别禁止事务读取带有未提交更改的行，它还禁止这种情况：一个事务读取某一行，而另一个事务更改该行，第一个事务重新读取该行，并在第二次读取时获得不同的值（“不可重复读”）。

另请参见：
常量字段值

TRANSACTION_SERIALIZABLE

static final int TRANSACTION_SERIALIZABLE
指示不可以发生脏读、不可重复读和虚读的常量。此级别包括 TRANSACTION_REPEATABLE_READ 中禁止的事项，同时还禁止出现这种情况：某一事务读取所有满足 WHERE 条件的行，另一个事务插入一个满足 WHERE 条件的行，第一个事务重新读取满足相同条件的行，并在第二次读取时获得额外的“虚”行。

另请参见：
常量字段值
方法详细信息

createStatement

Statement createStatement()
                          throws SQLException
创建一个 Statement 对象来将 SQL 语句发送到数据库。不带参数的 SQL 语句通常使用 Statement 对象执行。如果多次执行相同的 SQL 语句，使用 PreparedStatement 对象可能更有效。

使用返回的 Statement 对象创建的结果集在默认情况下类型为 TYPE_FORWARD_ONLY，并带有 CONCUR_READ_ONLY 并发级别。已创建结果集的可保存性可调用 getHoldability() 确定。

返回：
一个新的默认 Statement 对象
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法

prepareStatement

PreparedStatement prepareStatement(String sql)
                                   throws SQLException
创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。

带有 IN 参数或不带有 IN 参数的 SQL 语句都可以被预编译并存储在 PreparedStatement 对象中。然后可以有效地使用此对象来多次执行该语句。

注：为了处理受益于预编译的带参数 SQL 语句，此方法进行了优化。如果驱动程序支持预编译，则 prepareStatement 方法将该语句发送给数据库进行预编译。一些驱动程序可能不支持预编译。在这种情况下，执行 PreparedStatement 对象之前无法将语句发送给数据库。这对用户没有直接影响；但它的确会影响哪些方法将抛出某些 SQLException 对象。

使用返回的 PreparedStatement 对象创建的结果集在默认情况下类型为 TYPE_FORWARD_ONLY，并带有 CONCUR_READ_ONLY 并发级别。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
sql - 可能包含一个或多个 '?' IN 参数占位符的 SQL 语句
返回：
包含预编译 SQL 语句的新的默认 PreparedStatement 对象
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法

prepareCall

CallableStatement prepareCall(String sql)
                              throws SQLException
创建一个 CallableStatement 对象来调用数据库存储过程。CallableStatement 对象提供了设置其 IN 和 OUT 参数的方法，以及用来执行调用存储过程的方法。

注：为了处理存储过程调用语句，此方法进行了优化。某些驱动程序可以在调用 prepareCall 方法后将调用语句发送给数据库；另一些则直到执行了 CallableStatement 对象后才可以发送。这对用户没有直接影响；但它的确会影响哪些方法将抛出某些 SQLException。

使用返回的 CallableStatement 对象创建的结果集在默认情况下类型为 TYPE_FORWARD_ONLY，并带有 CONCUR_READ_ONLY 并发级别。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
sql - 可以包含一个或多个 '?' 参数占位符的 SQL 语句。通常此语句是使用 JDBC 调用转义语法指定的。
返回：
包含预编译 SQL 语句的新的默认 CallableStatement 对象
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法

nativeSQL

String nativeSQL(String sql)
                 throws SQLException
将给定的 SQL 语句转换成系统本机 SQL 语法。在发送 JDBC SQL 语法之前，驱动程序可以将其转换成其系统本机 SQL 语法。此方法返回驱动程序将发送的语句的本机形式。

参数：
sql - 可以包含一个或多个 '?' 参数占位符的 SQL 语句
返回：
此语句的本机形式
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法

setAutoCommit

void setAutoCommit(boolean autoCommit)
                   throws SQLException
将此连接的自动提交模式设置为给定状态。如果连接处于自动提交模式下，则它的所有 SQL 语句将被执行并作为单个事务提交。否则，它的 SQL 语句将聚集到事务中，直到调用 commit 方法或 rollback 方法为止。默认情况下，新连接处于自动提交模式。

提交发生在语句完成时。语句完成的时间取决于 SQL 语句的类型：

  • 对于 DML 语句（比如 Insert、Update 或 Delete）和 DDL 语句，语句在执行完毕时完成。
  • 对于 Select 语句，语句在关联结果集关闭时完成。
  • 对于 CallableStatement 对象或者返回多个结果的语句，语句在所有关联结果集关闭并且已获得所有更新计数和输出参数时完成。

注：如果在事务和自动提交模式更改期间调用此方法，则提交该事务。如果调用 setAutoCommit 而自动提交模式未更改，则该调用无操作（no-op）。

参数：
autoCommit - 为 true 表示启用自动提交模式；为 false 表示禁用自动提交模式
抛出：
SQLException - 如果发生数据库访问错误，在参与分布式事务的同时调用 setAutoCommit(true)，或者在关闭的连接上调用此方法
另请参见：
getAutoCommit()

getAutoCommit

boolean getAutoCommit()
                      throws SQLException
获取此 Connection 对象的当前自动提交模式。

返回：
此 Connection 对象的自动提交模式的当前状态
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
另请参见：
getAutoCommit(), setAutoCommit(boolean)

commit

void commit()
            throws SQLException
使所有上一次提交/回滚后进行的更改成为持久更改，并释放此 Connection 对象当前持有的所有数据库锁。此方法只应该在已禁用自动提交模式时使用。

抛出：
SQLException - 如果发生数据库访问错误，在参与分布式事务的同时调用此方法，在关闭的连接上调用此方法，或者此 Connection 对象处于自动提交模式
另请参见：
setAutoCommit(boolean)

rollback

void rollback()
              throws SQLException
取消在当前事务中进行的所有更改，并释放此 Connection 对象当前持有的所有数据库锁。此方法只应该在已禁用自动提交模式时使用。

抛出：
SQLException - 如果发生数据库访问错误，在参与分布式事务的同时调用此方法，在关闭的连接上调用此方法，或者此 Connection 对象处于自动提交模式
另请参见：
setAutoCommit(boolean)

close

void close()
           throws SQLException
立即释放此 Connection 对象的数据库和 JDBC 资源，而不是等待它们被自动释放。

在已经关闭的 Connection 对象上调用 close 方法无操作 (no-op)。

建议最好在调用 close 方法之前，应用程序显式提交或回滚一个活动事务。如果调用 close 方法并且有一个活动事务，那么结果将由实现定义。

抛出：
SQLException - 如果发生数据库访问错误

isClosed

boolean isClosed()
                 throws SQLException
查询此 Connection 对象是否已经被关闭。如果在连接上调用了 close 方法或者发生某些严重的错误，则连接被关闭。只有在调用了 Connection.close 方法之后被调用时，此方法才保证返回 true。

通常不能调用此方法确定到数据库的连接是有效的还是无效的。通过捕获在试图进行某一操作时可能抛出的异常，典型的客户端可以确定某一连接是无效的。

返回：
如果此 Connection 对象是关闭的，则返回 true；如果它仍然处于打开状态，则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getMetaData

DatabaseMetaData getMetaData()
                             throws SQLException
获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。元数据包括关于数据库的表、受支持的 SQL 语法、存储过程、此连接功能等等的信息。

返回：
此 Connection 对象的一个 DatabaseMetaData 对象
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法

setReadOnly

void setReadOnly(boolean readOnly)
                 throws SQLException
将此连接设置为只读模式，作为驱动程序启用数据库优化的提示。

注：此方法不能在事务处理期间调用。

参数：
readOnly - 为 true 表示启用只读模式；为 false 表示禁用只读模式
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者在事务处理期间调用此方法

isReadOnly

boolean isReadOnly()
                   throws SQLException
查询此 Connection 对象是否处于只读模式。

返回：
如果此 Connection 对象是只读的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法

setCatalog

void setCatalog(String catalog)
                throws SQLException
设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。

如果驱动程序不支持这些目录，那么它将直接忽略此请求。

参数：
catalog - 在其中进行工作的目录（此 Connection 对象的数据库的子空间）的名称
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
另请参见：
getCatalog()

getCatalog

String getCatalog()
                  throws SQLException
获取此 Connection 对象的当前目录名称。

返回：
当前目录名称；如果不存在，则返回 null
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
另请参见：
setCatalog(java.lang.String)

setTransactionIsolation

void setTransactionIsolation(int level)
                             throws SQLException
试图将此 Connection 对象的事务隔离级别更改为给定的级别。可能的事务隔离级别是 Connection 接口中定义的常量。

注：如果在事务处理期间调用此方法，则结果由实现定义。

参数：
level - 以下 Connection 常量之一：Connection.TRANSACTION_READ_UNCOMMITTED、Connection.TRANSACTION_READ_COMMITTED、Connection.TRANSACTION_REPEATABLE_READ 或 Connection.TRANSACTION_SERIALIZABLE。（注意，不能使用 Connection.TRANSACTION_NONE，因为它指定了不受支持的事务。）
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是 Connection 常量之一
另请参见：
DatabaseMetaData.supportsTransactionIsolationLevel(int), getTransactionIsolation()

getTransactionIsolation

int getTransactionIsolation()
                            throws SQLException
获取此 Connection 对象的当前事务隔离级别。

返回：
当前事务隔离级别，它将是以下常量之一：Connection.TRANSACTION_READ_UNCOMMITTED、Connection.TRANSACTION_READ_COMMITTED、Connection.TRANSACTION_REPEATABLE_READ、Connection.TRANSACTION_SERIALIZABLE 或 Connection.TRANSACTION_NONE。
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
另请参见：
setTransactionIsolation(int)

getWarnings

SQLWarning getWarnings()
                       throws SQLException
获取此 Connection 对象上的调用报告的第一个警告。如果有多个警告，则后续警告将被链接到第一个警告，可以通过对之前获得的警告调用 SQLWarning.getNextWarning 方法获取。

不可以在关闭的连接上调用此方法，这样做将导致抛出 SQLException。

注：后续警告将被链接到此 SQLWarning。

返回：
第一个 SQLWarning 对象；如果不存在，则返回 null
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
另请参见：
SQLWarning

clearWarnings

void clearWarnings()
                   throws SQLException
清除为此 Connection 对象报告的所有警告。调用此方法后，在为此 Connection 对象报告新的警告前，getWarnings 方法将返回 null。

抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法

createStatement

Statement createStatement(int resultSetType,
                          int resultSetConcurrency)
                          throws SQLException
创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。此方法与上述 createStatement 方法相同，但它允许重写默认结果集类型和并发性。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
resultSetType - 结果集类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
resultSetConcurrency - 并发类型；它是 ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE 之一
返回：
一个新的 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指示类型和并发性的 ResultSet 常量
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法，或者对于指定的结果集类型和结果集并发性，此方法不受支持。
从以下版本开始：
1.2

prepareStatement

PreparedStatement prepareStatement(String sql,
                                   int resultSetType,
                                   int resultSetConcurrency)
                                   throws SQLException
创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。此方法与上述 prepareStatement 方法相同，但它允许重写默认结果集类型和并发性。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
sql - 一个 String 对象，它是将被发送到数据库的 SQL 语句，可以包含一个或多个 '?' IN 参数
resultSetType - 结果集类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
resultSetConcurrency - 并发类型，它是 ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE 之一
返回：
包含预编译的 SQL 语句的新 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指示类型和并发性的 ResultSet 常量
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法，或者对于指定的结果集类型和结果集并发性此方法不受支持。
从以下版本开始：
1.2

prepareCall

CallableStatement prepareCall(String sql,
                              int resultSetType,
                              int resultSetConcurrency)
                              throws SQLException
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。此方法与上述 prepareCall 方法相同，但它允许重写默认结果集类型和并发性。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
sql - 一个 String 对象，它是将被发送给数据库的 SQL 语句，可以包含一个或多个 '?' 参数
resultSetType - 结果集类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
resultSetConcurrency - 并发类型，它是 ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE 之一
返回：
一个包含预编译的 SQL 语句的新 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指示类型和并发性的 ResultSet 常量
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法，或者或者对于指定的结果集类型和结果集并发性此方法不受支持。
从以下版本开始：
1.2

getTypeMap

Map<String,Class<?>> getTypeMap()
                                throws SQLException
获取与此 Connection 对象关联的 Map 对象。除非应用程序已经添加了一个条目，否则返回的类型映射将为空。

返回：
与此 Connection 对象关联的 java.util.Map 对象
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
setTypeMap(java.util.Map>)

setTypeMap

void setTypeMap(Map<String,Class<?>> map)
                throws SQLException
将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。该映射将用于 SQL 结构类型和独特类型的自定义映射。

参数：
map - 将作为此 Connection 对象默认类型映射的替代安装的 java.util.Map 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是 java.util.Map 对象
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
getTypeMap()

setHoldability

void setHoldability(int holdability)
                    throws SQLException
将使用此 Connection 对象创建的 ResultSet 对象的默认可保存性 (holdability) 更改为给定可保存性。ResultSet 对象的默认可保存性可调用 DatabaseMetaData.getResultSetHoldability() 确定。

参数：
holdability - ResultSet 的可保存性常量，它是 ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT 之一
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指示可保存性的 ResultSet 常量
SQLFeatureNotSupportedException - 如果给定可保存性不受支持
从以下版本开始：
1.4
另请参见：
getHoldability(), DatabaseMetaData.getResultSetHoldability(), ResultSet

getHoldability

int getHoldability()
                   throws SQLException
获取使用此 Connection 对象创建的 ResultSet 对象的当前可保存性。

返回：
可保存性，它是 ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT 之一
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
从以下版本开始：
1.4
另请参见：
setHoldability(int), DatabaseMetaData.getResultSetHoldability(), ResultSet

setSavepoint

Savepoint setSavepoint()
                       throws SQLException
在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。

如果在活动事务范围之外调用 setSavepoint，则将在新创建的保存点上启动事务。

返回：
新的 Savepoint 对象
抛出：
SQLException - 如果发生数据库访问错误，在参与分布式事务的同时调用此方法，在关闭的连接上调用此方法，或者此 Connection 对象当前处于自动提交模式
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
Savepoint

setSavepoint

Savepoint setSavepoint(String name)
                       throws SQLException
在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。

如果在活动事务范围之外调用 setSavepoint，则将在新创建的保存点上启动事务。

参数：
name - 包含保存点名称的 String
返回：
新的 Savepoint 对象
抛出：
SQLException - 如果发生数据库访问错误，在参与分布式事务的同时调用此方法，在关闭的连接上调用此方法，或者此 Connection 对象当前处于自动提交模式下
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
Savepoint

rollback

void rollback(Savepoint savepoint)
              throws SQLException
取消所有设置给定 Savepoint 对象之后进行的更改。

此方法只应该在已禁用自动提交时使用。

参数：
savepoint - 要回滚到的 Savepoint 对象
抛出：
SQLException - 如果发生数据库访问错误，在参与分布式事务的同时调用此方法，在关闭的连接上调用此方法，Savepoint 对象不再有效，或者此 Connection 对象当前处于自动提交模式
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
Savepoint, rollback()

releaseSavepoint

void releaseSavepoint(Savepoint savepoint)
                      throws SQLException
从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。在已移除保存点之后，对该保存点的任何引用都会导致抛出 SQLException。

参数：
savepoint - 将移除的 Savepoint 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定 Savepoint 对象在当前事务中不是一个有效的保存点
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

createStatement

Statement createStatement(int resultSetType,
                          int resultSetConcurrency,
                          int resultSetHoldability)
                          throws SQLException
创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。此方法与上述 createStatement 方法相同，但它允许重写默认结果集类型、并发性和可保存性。

参数：
resultSetType - 以下 ResultSet 常量之一：ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
resultSetConcurrency - 以下 ResultSet 常量之一：ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
resultSetHoldability - 以下 ResultSet 常量之一：ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT
返回：
一个新的 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指定类型、并发性和可保存性的 ResultSet 常量
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法，或者对于指定结果集类型、结果集可保存性和结果集并发性，此方法不受支持。
从以下版本开始：
1.4
另请参见：
ResultSet

prepareStatement

PreparedStatement prepareStatement(String sql,
                                   int resultSetType,
                                   int resultSetConcurrency,
                                   int resultSetHoldability)
                                   throws SQLException
创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。

此方法与上述 prepareStatement 方法相同，但它允许重写默认结果集类型、并发性和可保存性。

参数：
sql - 一个 String 对象，它是将被发送到数据库的 SQL 语句，可以包含一个或多个 '?' IN 参数
resultSetType - 以下 ResultSet 常量之一：ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
resultSetConcurrency - 以下 ResultSet 常量之一：ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
resultSetHoldability - 以下 ResultSet 常量之一：ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT
返回：
一个包含预编译 SQL 语句的新 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指示类型、并发性和可保存性的 ResultSet 常量
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法，或者对于指定结果集类型、结果集可保存性和结果集并发性，此方法不受支持。
从以下版本开始：
1.4
另请参见：
ResultSet

prepareCall

CallableStatement prepareCall(String sql,
                              int resultSetType,
                              int resultSetConcurrency,
                              int resultSetHoldability)
                              throws SQLException
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。此方法与上述 prepareCall 方法相同，但它允许重写默认结果集类型、结果集并发性类型和可保存性。

参数：
sql - 一个 String 对象，它是将被发送到数据库的 SQL 语句，可以包含一个或多个 '?' 参数
resultSetType - 以下 ResultSet 常量之一：ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
resultSetConcurrency - 以下 ResultSet 常量之一：ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
resultSetHoldability - 以下 ResultSet 常量之一：ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT
返回：
一个包含预编译 SQL 语句的新 CallableStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指示类型、并发性和可保存性的 ResultSet 常量
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法，或者对于指定结果集类型、结果集可保存性和结果集并发性，此方法不受支持。
从以下版本开始：
1.4
另请参见：
ResultSet

prepareStatement

PreparedStatement prepareStatement(String sql,
                                   int autoGeneratedKeys)
                                   throws SQLException
创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。给定常量告知驱动程序是否可以获取自动生成的键。如果 SQL 语句不是一条 INSERT 语句，或者 SQL 语句能够返回自动生成的键（这类语句的列表是特定于供应商的），则忽略此参数。

注：为了处理受益于预编译的带参数 SQL 语句，此方法进行了优化。如果驱动程序支持预编译，则 prepareStatement 方法将该语句发送给数据库进行预编译。一些驱动程序可能不支持预编译。在这种情况下，执行 PreparedStatement 对象之前无法将语句发送给数据库。这对用户没有直接影响；但它的确会影响哪些方法将抛出某些 SQLException。

使用返回的 PreparedStatement 对象创建的结果集在默认情况下类型为 TYPE_FORWARD_ONLY，并带有 CONCUR_READ_ONLY 并发级别。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
sql - 可能包含一个或多个 '?' IN 参数占位符的 SQL 语句
autoGeneratedKeys - 指示是否应该返回自动生成的键的标志，它是 Statement.RETURN_GENERATED_KEYS 或 Statement.NO_GENERATED_KEYS 之一
返回：
一个包含预编译 SQL 语句的新 PreparedStatement 对象，该对象能够返回自动生成的键
抛出：
SQLException - 如果发生数据库访问错误，在关闭的连接上调用此方法，或者给定参数不是指示是否应该返回自动生成键的 Statement 常量
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持带有 Statement.RETURN_GENERATED_KEYS 常量的此方法
从以下版本开始：
1.4

prepareStatement

PreparedStatement prepareStatement(String sql,
                                   int[] columnIndexes)
                                   throws SQLException
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。此数组包含目标表中列的索引，而目标表包含应该可返回的自动生成的键。如果 SQL 语句不是 INSERT 语句，或者 SQL 语言能够返回自动生成的键（这类语句的列表是特定于供应商的），则驱动程序将忽略该数组。

带 IN 参数或不带 IN 参数的 SQL 语句都可以被预编辑并存储在 PreparedStatement 对象中。然后可以使用此对象多次有效地执行该语句。

注：为了处理受益于预编译的带参数 SQL 语句，此方法进行了优化。如果驱动程序支持预编译，则 prepareStatement 方法将该语句发送给数据库进行预编译。一些驱动程序可能不支持预编译。在这种情况下，执行 PreparedStatement 对象之前无法将语句发送给数据库。这对用户没有直接影响；但它的确会影响哪些方法将抛出某些 SQLException。

使用返回的 PreparedStatement 对象创建的结果集在默认情况下类型为 TYPE_FORWARD_ONLY，并带有 CONCUR_READ_ONLY 并发级别。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
sql - 可能包含一个或多个 '?' IN 参数占位符的 SQL 语句
columnIndexes - 列索引数组，这些索引指示应该从一个或多个插入行中返回的那些列
返回：
一个包含预编译语句的新 PreparedStatement 对象，该对象能够返回由给定列索引数组指定的自动生成键
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

prepareStatement

PreparedStatement prepareStatement(String sql,
                                   String[] columnNames)
                                   throws SQLException
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。此数组包含目标表中列的名称，而目标表包含应该返回的自动生成键。如果 SQL 语句不是 INSERT 语句，或者 SQL 语言能够返回自动生成的键（这类语句的列表是特定于供应商的），则驱动程序将忽略该数组。

带 IN 参数或不带 IN 参数的 SQL 语句都可以被预编辑并存储在 PreparedStatement 对象中。然后可以使用此对象多次有效地执行该语句。

注：为了处理受益于预编译的带参数 SQL 语句，此方法进行了优化。如果驱动程序支持预编译，则 prepareStatement 方法将该语句发送给数据库进行预编译。一些驱动程序可能不支持预编译。在这种情况下，执行 PreparedStatement 对象之前无法将语句发送给数据库。这对用户没有直接影响；但它的确会影响哪些方法将抛出某些 SQLException。

使用返回的 PreparedStatement 对象创建的结果集在默认情况下类型为 TYPE_FORWARD_ONLY，并带有 CONCUR_READ_ONLY 并发级别。已创建结果集的可保存性可调用 getHoldability() 确定。

参数：
sql - 可能包含一个或多个 '?' IN 参数占位符的 SQL 语句
columnNames - 列名称数组，这些名称指示应该从一个或多个插入行中返回的那些列
返回：
一个包含预编译语句的新 PreparedStatement 对象，该对象能够返回由给定列名称数组指定的自动生成键
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的连接上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

createClob

Clob createClob()
                throws SQLException
构造实现 Clob 接口的对象。返回的对象最初不包含任何数据。Clob 接口的 setAsciiStream、setCharacterStream 和 setString 方法可用来向 Clob 添加数据。

返回：
实现 Clob 接口的对象
抛出：
SQLException - 如果无法构造实现 Clob 接口的对象，在关闭的连接上调用此方法，或者发生数据库访问错误。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.6

createBlob

Blob createBlob()
                throws SQLException
构造实现 Blob 接口的对象。返回的对象最初不包含任何数据。Blob 接口的 setBinaryStream 和 setBytes 方法可用来向 Blob 添加数据。

返回：
实现 Blob 接口的对象
抛出：
SQLException - 如果无法构造实现 Blob 接口的对象，在关闭的连接上调用此方法，或者发生数据库访问错误。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.6

createNClob

NClob createNClob()
                  throws SQLException
构造实现 NClob 接口的对象。返回的对象最初不包含任何数据。NClob 接口的 setAsciiStream、setCharacterStream 和 setString 方法可用来向 NClob 添加数据。

返回：
实现 NClob 接口的对象
抛出：
SQLException - 如果无法构造实现 NClob 接口的对象，在关闭的连接上调用此方法，或者发生数据库访问错误。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.6

createSQLXML

SQLXML createSQLXML()
                    throws SQLException
构造实现 SQLXML 接口的对象。返回的对象最初不包含任何数据。SQLXML 接口的 createXmlStreamWriter 和 setString 方法可用来向 SQLXML 对象添加数据。

返回：
实现 SQLXML 接口的对象
抛出：
SQLException - 如果无法构造实现 SQLXML 接口的对象，在关闭的连接上调用此方法，或者发生数据库访问错误。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.6

isValid

boolean isValid(int timeout)
                throws SQLException
如果连接尚未关闭并且仍然有效，则返回 true。驱动程序将提交一个关于该连接的查询，或者使用其他某种能确切验证在调用此方法时连接是否仍然有效的机制。

由驱动程序提交的用来验证该连接的查询将在当前事务的上下文中执行。

参数：
timeout - 等待用来验证连接是否完成的数据库操作的时间，以秒为单位。如果在操作完成之前超时期满，则此方法返回 false。0 值表示不对数据库操作应用超时值。

返回：
如果连接有效，则返回 true，否则返回 false
抛出：
SQLException - 如果为 timeout 提供的值小于 0
从以下版本开始：
1.6

另请参见：
DatabaseMetaData.getClientInfoProperties()

setClientInfo

void setClientInfo(String name,
                   String value)
                   throws SQLClientInfoException
将 name 指定的客户端信息属性的值设置为 value 指定的值。

应用程序可以使用 DatabaseMetaData.getClientInfoProperties 方法确定驱动程序支持的客户端信息属性，以及为每个属性指定的最大长度。

驱动程序存储数据库中合适位置上指定的值。例如，在特殊注册表 (special register)、会话参数 (session parameter) 或者系统表 (system table) 列中。为了提高效率，驱动程序可以将设置数据库中的值推迟到下一次执行语句或者准备执行语句时。除了在数据库中的适当位置存储客户端信息之外，这些方法不能以任何方式改变连接的行为。为这些方法提供的值只能用于计数、诊断和调试目的。

如果指定的客户端属性名称不被驱动程序所识别，那么该驱动程序将生成一个警告。

如果为此方法指定的值大于该属性的最大长度，则驱动程序可能截取该值并生成一个警告，或者生成一个 SQLClientInfoException。如果驱动程序生成一个 SQLClientInfoException，则指定的值不是在连接上设置的。

以下是标准的客户端信息属性。不过，如果驱动程序支持可由某个标准属性描述的客户端信息属性，则驱动程序无需支持这些属性，应该使用标准属性名称。

  • ApplicationName - 当前正在使用连接的应用程序的名称
  • ClientUser - 用户名，正在使用连接的应用程序将为该用户执行工作。这与建立连接所使用的用户名可能不同。
  • ClientHostname - 计算机的主机名，正使用连接的应用程序将在该计算机上运行。

参数：
name - 要设置的客户端信息属性名称
value - 要设置为客户端信息属性的值。如果该值为 null，则清除指定属性的当前值。

抛出：
SQLClientInfoException - 如果在数据库服务器上设置客户端信息值时数据库服务器返回一个错误，或者在关闭的连接上调用此方法

从以下版本开始：
1.6

setClientInfo

void setClientInfo(Properties properties)
                   throws SQLClientInfoException
设置连接的客户端信息属性的值。Properties 对象包含将要设置的客户端属性的名称和值。包含在属性列表中的客户端信息属性集将替换连接上的当前客户端信息属性集。如果当前在连接上设置的某个属性不在属性列表中，则清除该属性。指定一个空属性列表将清除连接上的所有属性。有关更多信息，请参阅 setClientInfo (String, String)。

如果在设置任何客户端信息属性时发生错误，则抛出 SQLClientInfoException。SQLClientInfoException 包含指示未设置的客户端信息属性的信息。客户端信息的状态是未知的，因为某些数据库不允许自动设置多个客户端信息属性。对于这些数据库，在错误发生之前已经设置了一个或多个属性。

参数：
properties - 要设置的客户端信息属性列表

抛出：
SQLClientInfoException - 如果在数据库服务器上设置 clientInfo 值时数据库服务器返回一个错误，或者在关闭的连接上调用此方法

从以下版本开始：
1.6

另请参见：
setClientInfo(String, String)

getClientInfo

String getClientInfo(String name)
                     throws SQLException
返回通过名称指定的客户端信息属性的值。如果指定的客户端信息属性尚未设置并且没有默认值，那么此方法返回 null。如果指定客户端信息属性名称不受驱动程序支持，那么此方法也将返回 null。

应用程序可以使用 DatabaseMetaData.getClientInfoProperties 方法确定受驱动程序支持的客户端信息属性。

参数：
name - 要获取的客户端信息属性的名称

返回：
指定的客户端信息属性的值

抛出：
SQLException - 如果在从数据库中获取客户端信息值时数据库服务器返回一个错误，或者在关闭的连接上调用此方法

从以下版本开始：
1.6

另请参见：
DatabaseMetaData.getClientInfoProperties()

getClientInfo

Properties getClientInfo()
                         throws SQLException
返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。如果客户端信息属性尚未设置并且没有默认值，那么客户端信息属性的值为 null。

返回：
一个 Properties 对象，它包含驱动程序支持的每个客户端信息属性的名称和当前值。

抛出：
SQLException - 如果在从数据库中获取客户端信息值时数据库服务器返回一个错误，或者在关闭的连接上调用此方法

从以下版本开始：
1.6

createArrayOf

Array createArrayOf(String typeName,
                    Object[] elements)
                    throws SQLException
创建 Array 对象的工厂方法。

注：当使用 createArrayOf 创建映射到基本数据类型的数组对象时，则 Array 对象是基本数据类型数组还是 Object 数组将由实现来定义。

注：JDBC 驱动程序负责将元素 Object 数组映射到 java.sql.Types 中为 Object 的给定类定义的默认 JDBC SQL 类型。默认映射关系是在 JDBC 规范的附录 B 中指定的。如果得到的 JDBC 类型对于给定 typeName 而言不是合适的类型，则抛出 SQLException 还是驱动程序支持得到的转换将由实现来定义。

参数：
typeName - 数组元素将映射到的类型的 SQL 名称。typeName 是特定于数据库的名称，它可能是内置类、用户定义类型或此数据库支持的标准 SQL 类型的名称。该参数是 Array.getBaseTypeName 返回的值
elements - 填充所返回对象的元素
返回：
其元素映射到指定 SQL 类型的 Array 对象
抛出：
SQLException - 如果发生数据库错误，JDBC 类型对于 typeName 不是合适类型并且该转换不受支持，typeName 为 null，或者在关闭的连接上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.6

createStruct

Struct createStruct(String typeName,
                    Object[] attributes)
                    throws SQLException
创建 Struct 对象的工厂方法。

参数：
typeName - 此 Struct 对象将映射到的 SQL 构造类型的 SQL 类型名称。typeName 是为此数据库定义的用户定义类型的名称。该参数是 Struct.getSQLTypeName 返回的值。
attributes - 填充所返回对象的属性
返回：
映射到给定 SQL 类型的 Struct 对象，该对象将使用给定属性填充
抛出：
SQLException - 如果发生数据库错误，typeName 为 null，或者在关闭的连接上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DatabaseMetaData (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 DatabaseMetaData

所有超级接口：
Wrapper
public interface DatabaseMetaData
extends Wrapper

关于数据库的整体综合信息。

此接口由驱动程序供应商实现，让用户了解 Database Management System (DBMS) 在与驱动程序（基于与其一起使用的 JDBCTM 技术（“JDBC 驱动程序”））相结合时的能力。不同的关系 DBMS 常常支持不同的功能，以不同方式实现这些功能，并使用不同的数据类型。此外，驱动程序可以实现 DBMS 提供的顶级功能。此接口中的方法返回的信息关系到一起工作的特定驱动程序和特定 DBMS 的能力。注意，正如此文档中所使用的那样，术语“数据库”通常既指驱动程序，又指 DBMS。

此接口的用户通常是一个需要发现如何处理底层 DBMS 的工具。对于试图与多个 DBMS 一起使用的应用程序而言尤其如此。例如，一个工具可能使用 getTypeInfo 方法找出可以在 CREATE TABLE 语句中使用的数据类型。或者用户可能调用 supportsCorrelatedSubqueries 方法查看是否可以使用相关子查询，或者调用 supportsBatchUpdates 查看是否可以使用批量更新。

有些 DatabaseMetaData 方法以 ResultSet 对象的形式返回信息列表。常规 ResultSet 方法（比如 getString 和 getInt）可用于从这些 ResultSet 对象中获取数据。如果给定形式的元数据不可用，则将返回一个空 ResultSet。对于被定义为由 ResultSet 对象的给定方法所返回的列以外的其他列，可以由 JDBC 驱动程序供应商定义，且必须通过其列标签访问。

有些 DatabaseMetaData 方法使用 String 模式的参数。这些参数都有 fooPattern 这样的名称。在模式 String 中，"%" 表示匹配 0 个或多个字符的任何子字符串，"_" 表示匹配任何一个字符。仅返回匹配搜索模式的元数据项。如果将搜索模式参数设置为 null，则从搜索中删除参数标准。

字段摘要
static short | attributeNoNulls 指示可能不允许使用 NULL 值。
static short | attributeNullable 指示明确允许使用 NULL 值。
static short | attributeNullableUnknown 指示不知道是否允许使用 NULL 值。
static int | bestRowNotPseudo 指示最佳行标识符“不”是伪列。
static int | bestRowPseudo 指示最佳行标识符是伪列。
static int | bestRowSession 指示最佳行标识符的作用域是当前会话的剩余部分。
static int | bestRowTemporary 指示最佳行标识符的作用域是临时的，仅在使用该行时可用。
static int | bestRowTransaction 指示最佳行标识符的作用域是当前事务的剩余部分。
static int | bestRowUnknown 指示最佳行标识符可能是伪列 (pseudo column)，也可能不是。
static int | columnNoNulls 指示列中可能不允许使用 NULL 值。
static int | columnNullable 指示列中明确允许使用 NULL 值。
static int | columnNullableUnknown 指示不知道列是否可为 null。
static int | functionColumnIn 指示参数或列是一个 IN 参数。
static int | functionColumnInOut 指示参数或列是一个 INOUT 参数。
static int | functionColumnOut 指示参数或列是一个 OUT 参数。
static int | functionColumnResult 指示参数或列是结果集中的一列。
static int | functionColumnUnknown 指示该类型的参数或列未知。
static int | functionNoNulls 指示不允许 NULL 值。
static int | functionNoTable 指示函数不返回一个表。
static int | functionNullable 指示允许 NULL 值。
static int | functionNullableUnknown 指示是否允许 NULL 值是未知的。
static int | functionResultUnknown 指示不知道函数是返回一个结果还是一个表。
static int | functionReturn 指示参数或列是一个返回值。
static int | functionReturnsTable 指示函数返回一个表。
static int | importedKeyCascade 对于 UPDATE_RULE 列，指示在更新主键时，外键（导入的键）的更改要与之一致。
static int | importedKeyInitiallyDeferred 指示可延迟性。
static int | importedKeyInitiallyImmediate 指示可延迟性。
static int | importedKeyNoAction 对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果主键已导入，则无法更新或删除它。
static int | importedKeyNotDeferrable 指示可延迟性。
static int | importedKeyRestrict 对于 UPDATE_RULE 列，指示如果主键已被另一个表作为外键导入，则可能不更新该主键。
static int | importedKeySetDefault 对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果更新或删除了主键，则将外键（导入的键）设置为默认值。
static int | importedKeySetNull 对于 UPDATE_RULE 和 DELETE_RULE 列，指示在更新或删除主键时，将外键（导入的键）更改为 NULL。
static int | procedureColumnIn 指示列中存储了 IN 参数。
static int | procedureColumnInOut 指示列中存储了 INOUT 参数。
static int | procedureColumnOut 指示列中存储了 OUT 参数。
static int | procedureColumnResult 指示列中存储了结果。
static int | procedureColumnReturn 指示列中存储了返回值。
static int | procedureColumnUnknown 指示列的类型为未知。
static int | procedureNoNulls 指示不允许使用 NULL 值。
static int | procedureNoResult 指示过程不返回结果。
static int | procedureNullable 指示允许使用 NULL 值。
static int | procedureNullableUnknown 指示不知道是否允许使用 NULL 值。
static int | procedureResultUnknown 指示不知道过程是否返回结果。
static int | procedureReturnsResult 指示过程返回结果。
static int | sqlStateSQL DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQLSTATE 值。
static int | sqlStateSQL99 DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQL99 SQLSTATE 值。
static int | sqlStateXOpen DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 返回的值是否是一个 X/Open（现在称为 Open Group）SQL CLI SQLSTATE 值。
static short | tableIndexClustered 指示此表索引是一个集群索引 (clustered index)。
static short | tableIndexHashed 指示此表索引是一个散列索引。
static short | tableIndexOther 指示此表索引不是集群索引、散列索引或表统计信息，它是其他某种东西。
static short | tableIndexStatistic 指示此列包含与表的索引描述一起返回的表统计信息。
static int | typeNoNulls 指示“不”允许对这种数据类型使用 NULL 值。
static int | typeNullable 指示允许对这种数据类型使用 NULL 值。
static int | typeNullableUnknown 指示不知道是否允许对这种数据类型使用 NULL 值。
static int | typePredBasic 指示该数据类型只能用于不使用 LIKE 谓词的 WHERE 搜索子句中。
static int | typePredChar 指示该数据类型只能用于使用 LIKE 谓词的 WHERE 搜索子句中。
static int | typePredNone 指示不支持将 WHERE 搜索子句用于这种类型。
static int | typeSearchable 指示在此类型上可以建立所有 WHERE 搜索子句。
static int | versionColumnNotPseudo 指示这种版本的列“不”是伪列。
static int | versionColumnPseudo 指示这种版本的列是伪列。
static int | versionColumnUnknown 指示这种版本的列可能是伪列，也可能不是。
方法摘要
boolean | allProceduresAreCallable() 获取当前用户是否可以调用 getProcedures 方法返回的所有过程。
boolean | allTablesAreSelectable() 获取当前用户是否可以使用 SELECT 语句中的 getTables 方法返回的所有表。
boolean | autoCommitFailureClosesAllResultSets() 当 autoCommit 为 true 时，获取 SQLException 是否指示所有打开的 ResultSets 已关闭（包括那些可保持的）。
boolean | dataDefinitionCausesTransactionCommit() 获取事务中的数据定义语句是否强迫该事务进行提交。
boolean | dataDefinitionIgnoredInTransactions() 获取此数据库是否忽略事务中的数据定义语句。
boolean | deletesAreDetected(int type) 获取是否可以通过调用 ResultSet.rowDeleted 方法检测可见行的删除。
boolean | doesMaxRowSizeIncludeBlobs() 获取 getMaxRowSize 方法的返回值是否包括 SQL 数据类型 LONGVARCHAR 和 LONGVARBINARY。
ResultSet | getAttributes(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern) 获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。
ResultSet | getBestRowIdentifier(String catalog, String schema, String table, int scope, boolean nullable) 获取唯一标识行的表的最佳列集合的描述。
ResultSet | getCatalogs() 获取可在此数据库中使用的类别名称。
String | getCatalogSeparator() 获取此数据库用作类别和表名之间的分隔符的 String。
String | getCatalogTerm() 获取数据库供应商用于 "catalog" 的首选术语。
ResultSet | getClientInfoProperties() 获取驱动程序支持的客户端信息属性的列表。
ResultSet | getColumnPrivileges(String catalog, String schema, String table, String columnNamePattern) 获取用于表列的访问权的描述。
ResultSet | getColumns(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern) 获取可在指定类别中使用的表列的描述。
Connection | getConnection() 获取此元数据对象所产生的连接。
ResultSet | getCrossReference(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable) 获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。
int | getDatabaseMajorVersion() 获取底层数据库的主版本号。
int | getDatabaseMinorVersion() 底层数据库的次版本号。
String | getDatabaseProductName() 获取此数据库产品的名称。
String | getDatabaseProductVersion() 获取此数据库产品的版本号。
int | getDefaultTransactionIsolation() 获取此数据库的默认事务隔离级别。
int | getDriverMajorVersion() 获取此 JDBC 驱动程序的主版本号。
int | getDriverMinorVersion() 获取此 JDBC 驱动程序的次版本号。
String | getDriverName() 获取此 JDBC 驱动程序的名称。
String | getDriverVersion() 获取此 JDBC 驱动程序的 String 形式的版本号。
ResultSet | getExportedKeys(String catalog, String schema, String table) 获取引用给定表的主键列（表导入的外键）的外键列的描述。
String | getExtraNameCharacters() 获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。
ResultSet | getFunctionColumns(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern) 获取给定类别的系统或用户函数参数和返回类型的描述。
ResultSet | getFunctions(String catalog, String schemaPattern, String functionNamePattern) 获取给定类别中可用的系统和用户函数的描述。
String | getIdentifierQuoteString() 获取用于引用 SQL 标识符的字符串。
ResultSet | getImportedKeys(String catalog, String schema, String table) 获取由给定表的外键列（表导入的主键）引用的主键列的描述。
ResultSet | getIndexInfo(String catalog, String schema, String table, boolean unique, boolean approximate) 获取给定表的索引和统计信息的描述。
int | getJDBCMajorVersion() 获取此驱动程序的主 JDBC 版本号。
int | getJDBCMinorVersion() 获取此驱动程序的次 JDBC 版本号。
int | getMaxBinaryLiteralLength() 获取此数据库允许在内嵌二进制字面值中使用的最大十六进制字符数。
int | getMaxCatalogNameLength() 获取此数据库允许用于类别名称的最大字符数。
int | getMaxCharLiteralLength() 获取此数据库允许用于字符字面值的最大字符数。
int | getMaxColumnNameLength() 获取此数据库允许用于列名称的最大字符数。
int | getMaxColumnsInGroupBy() 获取此数据库允许在 GROUP BY 子句中使用的最大列数。
int | getMaxColumnsInIndex() 获取此数据库允许在索引中使用的最大列数。
int | getMaxColumnsInOrderBy() 获取此数据库允许在 ORDER BY 子句中使用的最大列数。
int | getMaxColumnsInSelect() 获取此数据库允许在 SELECT 列表中使用的最大列数。
int | getMaxColumnsInTable() 获取此数据库允许在表中使用的最大列数。
int | getMaxConnections() 获取连接到此数据库的并发连接的可能最大数。
int | getMaxCursorNameLength() 获取此数据库允许用于游标名称的最大字符数。
int | getMaxIndexLength() 获取此数据库允许用于索引（包括索引的所有部分）的最大字节数。
int | getMaxProcedureNameLength() 获取此数据库允许用于过程名称的最大字符数。
int | getMaxRowSize() 获取此数据库允许在单行中使用的最大字节数。
int | getMaxSchemaNameLength() 获取此数据库允许在模式名称中使用的最大字符数。
int | getMaxStatementLength() 获取此数据库允许在 SQL 语句中使用的最大字符数。
int | getMaxStatements() 获取在此数据库中在同一时间内可处于开放状态的最大活动语句数。
int | getMaxTableNameLength() 获取此数据库允许在表名称中使用的最大字符数。
int | getMaxTablesInSelect() 获取此数据库允许在 SELECT 语句中使用的表的最大数量。
int | getMaxUserNameLength() 获取此数据库允许在用户名称中使用的最大字符数。
String | getNumericFunctions() 获取可用于此数据库的数学函数的逗号分隔列表。
ResultSet | getPrimaryKeys(String catalog, String schema, String table) 获取对给定表的主键列的描述。
ResultSet | getProcedureColumns(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern) 获取给定类别的存储过程参数和结果列的描述。
ResultSet | getProcedures(String catalog, String schemaPattern, String procedureNamePattern) 获取可在给定类别中使用的存储过程的描述。
String | getProcedureTerm() 获取数据库供应商用于 "procedure" 的首选术语。
int | getResultSetHoldability() 针对 ResultSet 对象获取此数据库的默认可保存性。
RowIdLifetime | getRowIdLifetime() 指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。
ResultSet | getSchemas() 获取可在此数据库中使用的模式名称。
ResultSet | getSchemas(String catalog, String schemaPattern) 获取此数据库中可用的模式名称。
String | getSchemaTerm() 获取数据库供应商用于 "schema" 的首选术语。
String | getSearchStringEscape() 获取可用于转义通配符的字符串。
String | getSQLKeywords() 获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。
int | getSQLStateType() 指示由 SQLException.getSQLState 返回的 SQLSTATE 是 X/Open（现在称为 Open Group）SQL CLI 还是 SQL:2003。
String | getStringFunctions() 获取可用于此数据库的字符串函数的逗号分隔列表。
ResultSet | getSuperTables(String catalog, String schemaPattern, String tableNamePattern) 获取在此数据库的特定模式中定义的表分层结构的描述。
ResultSet | getSuperTypes(String catalog, String schemaPattern, String typeNamePattern) 获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。
String | getSystemFunctions() 获取可用于此数据库的系统函数的逗号分隔列表。
ResultSet | getTablePrivileges(String catalog, String schemaPattern, String tableNamePattern) 获取可在类别中使用的每个表的访问权的描述。
ResultSet | getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types) 获取可在给定类别中使用的表的描述。
ResultSet | getTableTypes() 获取可在此数据库中使用的表类型。
String | getTimeDateFunctions() 获取可用于此数据库的时间和日期函数的逗号分隔列表。
ResultSet | getTypeInfo() 获取此数据库支持的所有数据类型的描述。
ResultSet | getUDTs(String catalog, String schemaPattern, String typeNamePattern, int[] types) 获取在特定模式中定义的用户定义类型 (UDT) 的描述。
String | getURL() 获取此 DBMS 的 URL。
String | getUserName() 获取此数据库的已知的用户名称。
ResultSet | getVersionColumns(String catalog, String schema, String table) 获取在更新行中的任意值时自动更新的表列的描述。
boolean | insertsAreDetected(int type) 获取是否可以通过调用 ResultSet.rowInserted 方法检测可见行的插入。
boolean | isCatalogAtStart() 获取某个类别是否出现在完全限定表名的开头。
boolean | isReadOnly() 获取此数据库是否处于只读模式。
boolean | locatorsUpdateCopy() 指示对 LOB 的更新是在副本上进行还是直接更新到 LOB。
boolean | nullPlusNonNullIsNull() 获取此数据库是否支持 NULL 值与等于 NULL 的非 NULL 值之间的连接。
boolean | nullsAreSortedAtEnd() 获取 NULL 值是否始终排在末尾，不管排序顺序如何。
boolean | nullsAreSortedAtStart() 获取 NULL 值是否始终排在开头，不管排序顺序如何。
boolean | nullsAreSortedHigh() 获取 NULL 值是否被高排序。
boolean | nullsAreSortedLow() 获取 NULL 值是否被低排序。
boolean | othersDeletesAreVisible(int type) 获取由其他结果集类型进行的删除是否可见。
boolean | othersInsertsAreVisible(int type) 获取由其他结果集类型进行的插入是否可见。
boolean | othersUpdatesAreVisible(int type) 获取由其他结果集类型进行的更新是否可见。
boolean | ownDeletesAreVisible(int type) 获取结果集自身的删除是否可见。
boolean | ownInsertsAreVisible(int type) 获取结果集自身的插入是否可见。
boolean | ownUpdatesAreVisible(int type) 获取对于给定类型的 ResultSet 对象，结果集自身的更新是否可见。
boolean | storesLowerCaseIdentifiers() 获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
boolean | storesLowerCaseQuotedIdentifiers() 获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
boolean | storesMixedCaseIdentifiers() 获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
boolean | storesMixedCaseQuotedIdentifiers() 获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
boolean | storesUpperCaseIdentifiers() 获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
boolean | storesUpperCaseQuotedIdentifiers() 获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
boolean | supportsAlterTableWithAddColumn() 获取此数据库是否支持带有 add 列的 ALTER TABLE。
boolean | supportsAlterTableWithDropColumn() 获取此数据库是否支持带有 drop 列的 ALTER TABLE。
boolean | supportsANSI92EntryLevelSQL() 获取此数据库是否支持 ANSI92 入门级 SQL 语法。
boolean | supportsANSI92FullSQL() 获取此数据库是否支持受支持的 ANSI92 完全 SQL 语法。
boolean | supportsANSI92IntermediateSQL() 获取此数据库是否支持受支持的 ANSI92 中间 SQL 语法。
boolean | supportsBatchUpdates() 获取此数据库是否支持批量更新。
boolean | supportsCatalogsInDataManipulation() 获取某个类别名称是否可以在数据操作语句中使用。
boolean | supportsCatalogsInIndexDefinitions() 获取某个类别名称是否可以在获取定义语句中使用。
boolean | supportsCatalogsInPrivilegeDefinitions() 获取某个类别名称是否可以在特权定义语句中使用。
boolean | supportsCatalogsInProcedureCalls() 获取某个类别名称是否可以在过程调用语句中使用。
boolean | supportsCatalogsInTableDefinitions() 获取某个类别名称是否可以在表定义语句中使用。
boolean | supportsColumnAliasing() 获取此数据库是否支持为列提供别名。
boolean | supportsConvert() 获取此数据库是否支持用于 JDBC 类型之间转换的 JDBC 标量函数 CONVERT。
boolean | supportsConvert(int fromType, int toType) 获取此数据库是否支持用于 JDBC fromType 和 toType 类型之间转换的 JDBC 标量函数 CONVERT。
boolean | supportsCoreSQLGrammar() 获取此数据库是否支持 ODBC Core SQL 语法。
boolean | supportsCorrelatedSubqueries() 获取此数据库是否支持相关子查询。
boolean | supportsDataDefinitionAndDataManipulationTransactions() 获取此数据库是否同时支持事务中的数据定义和数据操作语句。
boolean | supportsDataManipulationTransactionsOnly() 获取此数据库是否仅支持事务中的数据操作语句。
boolean | supportsDifferentTableCorrelationNames() 获取在表关联名称受支持时，是否要限制它们与表的名称不同。
boolean | supportsExpressionsInOrderBy() 获取此数据库是否支持 ORDER BY 列表中的表达式。
boolean | supportsExtendedSQLGrammar() 获取此数据库是否支持 ODBC Extended SQL 语法。
boolean | supportsFullOuterJoins() 获取此数据库是否支持完全嵌套的外连接。
boolean | supportsGetGeneratedKeys() 获取是否可以在执行语句后获取自动生成的键。
boolean | supportsGroupBy() 获取此数据库是否支持某种形式的 GROUP BY 子句。
boolean | supportsGroupByBeyondSelect() 获取此数据库是否支持使用不包含在 SELECT 语句中而包含在 GROUP BY 子句中的列，假设 SELECT 语句中的所有列都包含在 GROUP BY 子句中。
boolean | supportsGroupByUnrelated() 获取此数据库是否支持使用不在 SELECT 语句中而在 GROUP BY 子句中的列。
boolean | supportsIntegrityEnhancementFacility() 获取此数据库是否支持 SQL Integrity Enhancement Facility。
boolean | supportsLikeEscapeClause() 获取此数据库是否支持指定 LIKE 转义子句。
boolean | supportsLimitedOuterJoins() 获取此数据库是否为外连接提供受限制的支持。
boolean | supportsMinimumSQLGrammar() 获取此数据库是否支持 ODBC Minimum SQL 语法。
boolean | supportsMixedCaseIdentifiers() 获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
boolean | supportsMixedCaseQuotedIdentifiers() 获取此数据库是否将大小写混写的带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
boolean | supportsMultipleOpenResults() 获取是否可以同时拥有从 CallableStatement 对象中返回的多个 ResultSet 对象。
boolean | supportsMultipleResultSets() 获取此数据库是否支持一次调用 execute 方法获得多个 ResultSet 对象。
boolean | supportsMultipleTransactions() 获取此数据库是否允许一次打开多个事务（在不同的 connection 上）。
boolean | supportsNamedParameters() 获取此数据库是否支持可调用语句的指定参数。
boolean | supportsNonNullableColumns() 获取是否可以将此数据库中的列定义为非 null。
boolean | supportsOpenCursorsAcrossCommit() 获取此数据库是否支持在进行提交期间保持游标开放。
boolean | supportsOpenCursorsAcrossRollback() 获取此数据库是否支持在回滚期间保持游标开放。
boolean | supportsOpenStatementsAcrossCommit() 获取此数据库是否支持在进行提交期间保持语句开放。
boolean | supportsOpenStatementsAcrossRollback() 获取此数据库是否支持在回滚期间保持语句开放。
boolean | supportsOrderByUnrelated() 获取此数据库是否支持使用不在 SELECT 语句中而在 ORDER BY 子句中的列。
boolean | supportsOuterJoins() 获取此数据库是否支持某种形式的外连接。
boolean | supportsPositionedDelete() 获取此数据库是否支持位置的 DELETE 语句。
boolean | supportsPositionedUpdate() 获取此数据库是否支持位置的 UPDATE 语句。
boolean | supportsResultSetConcurrency(int type, int concurrency) 获取此数据库是否支持与给定结果集类型结合在一起的给定并发性类型。
boolean | supportsResultSetHoldability(int holdability) 获取此数据库是否支持给定结果集可保存性。
boolean | supportsResultSetType(int type) 获取此数据库是否支持给定结果集类型。
boolean | supportsSavepoints() 获取此数据库是否支持保存点 (savepoint)。
boolean | supportsSchemasInDataManipulation() 获取某个模式名称是否可以数据操作语句中使用。
boolean | supportsSchemasInIndexDefinitions() 获取某个模式名称是否可以在获取定义语句中使用。
boolean | supportsSchemasInPrivilegeDefinitions() 获取某个模式名称是否可以在特权定义语句中使用。
boolean | supportsSchemasInProcedureCalls() 获取某个模式名称是否可以在过程调用语句中使用。
boolean | supportsSchemasInTableDefinitions() 获取某个模式名称是否可以在表定义语句中使用。
boolean | supportsSelectForUpdate() 获取此数据库是否支持位置的 SELECT FOR UPDATE 语句。
boolean | supportsStatementPooling() 获取此数据库是否支持语句合并 (statement pooling)。
boolean | supportsStoredFunctionsUsingCallSyntax() 获取此数据库是否支持使用存储过程转义语法调用用户定义的函数或供应商函数。
boolean | supportsStoredProcedures() 获取此数据库是否支持使用存储过程转义语法的存储过程调用。
boolean | supportsSubqueriesInComparisons() 获取此数据库是否支持比较表达式中的子查询。
boolean | supportsSubqueriesInExists() 获取此数据库是否支持 EXISTS 表达式中的子查询。
boolean | supportsSubqueriesInIns() 获取此数据库是否支持 IN 表达式中的子查询。
boolean | supportsSubqueriesInQuantifieds() 获取此数据库是否支持量化表达式 (quantified expression) 中的子查询。
boolean | supportsTableCorrelationNames() 获取此数据库是否支持表关联名称。
boolean | supportsTransactionIsolationLevel(int level) 获取此数据库是否支持给定事务隔离级别。
boolean | supportsTransactions() 获取此数据库是否支持事务。
boolean | supportsUnion() 获取此数据库是否支持 SQL UNION。
boolean | supportsUnionAll() 获取此数据库是否支持 SQL UNION ALL。
boolean | updatesAreDetected(int type) 获取是否可以通过调用 ResultSet.rowUpdated 方法检测可见行的更新。
boolean | usesLocalFilePerTable() 获取此数据库是否为每个表使用一个文件。
boolean | usesLocalFiles() 获取此数据库是否将表存储在本地文件中。
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

字段详细信息

procedureResultUnknown

static final int procedureResultUnknown
指示不知道过程是否返回结果。

getProcedures 方法返回的 ResultSet 对象中 PROCEDURE_TYPE 列的可能值。

另请参见：
常量字段值

procedureNoResult

static final int procedureNoResult
指示过程不返回结果。

getProcedures 方法返回的 ResultSet 对象中 PROCEDURE_TYPE 列的可能值。

另请参见：
常量字段值

procedureReturnsResult

static final int procedureReturnsResult
指示过程返回结果。

getProcedures 方法返回的 ResultSet 对象中 PROCEDURE_TYPE 列的可能值。

另请参见：
常量字段值

procedureColumnUnknown

static final int procedureColumnUnknown
指示列的类型为未知。

getProcedureColumns 方法返回的 ResultSet 对象中 COLUMN_TYPE 列的可能值。

另请参见：
常量字段值

procedureColumnIn

static final int procedureColumnIn
指示列中存储了 IN 参数。

getProcedureColumns 方法返回的 ResultSet 对象中 COLUMN_TYPE 列的可能值。

另请参见：
常量字段值

procedureColumnInOut

static final int procedureColumnInOut
指示列中存储了 INOUT 参数。

getProcedureColumns 方法返回的 ResultSet 对象中 COLUMN_TYPE 列的可能值。

另请参见：
常量字段值

procedureColumnOut

static final int procedureColumnOut
指示列中存储了 OUT 参数。

getProcedureColumns 方法返回的 ResultSet 对象中 COLUMN_TYPE 列的可能值。

另请参见：
常量字段值

procedureColumnReturn

static final int procedureColumnReturn
指示列中存储了返回值。

getProcedureColumns 方法返回的 ResultSet 对象中 COLUMN_TYPE 列的可能值。

另请参见：
常量字段值

procedureColumnResult

static final int procedureColumnResult
指示列中存储了结果。

getProcedureColumns 方法返回的 ResultSet 对象中 COLUMN_TYPE 列的可能值。

另请参见：
常量字段值

procedureNoNulls

static final int procedureNoNulls
指示不允许使用 NULL 值。

getProcedureColumns 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

procedureNullable

static final int procedureNullable
指示允许使用 NULL 值。

getProcedureColumns 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

procedureNullableUnknown

static final int procedureNullableUnknown
指示不知道是否允许使用 NULL 值。

getProcedureColumns 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

columnNoNulls

static final int columnNoNulls
指示列中可能不允许使用 NULL 值。

getColumns 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

columnNullable

static final int columnNullable
指示列中明确允许使用 NULL 值。

getColumns 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

columnNullableUnknown

static final int columnNullableUnknown
指示不知道列是否可为 null。

getColumns 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

bestRowTemporary

static final int bestRowTemporary
指示最佳行标识符的作用域是临时的，仅在使用该行时可用。

getBestRowIdentifier 方法返回的 ResultSet 对象中 SCOPE 列的可能值。

另请参见：
常量字段值

bestRowTransaction

static final int bestRowTransaction
指示最佳行标识符的作用域是当前事务的剩余部分。

getBestRowIdentifier 方法返回的 ResultSet 对象中 SCOPE 列的可能值。

另请参见：
常量字段值

bestRowSession

static final int bestRowSession
指示最佳行标识符的作用域是当前会话的剩余部分。

getBestRowIdentifier 方法返回的 ResultSet 对象中 SCOPE 列的可能值。

另请参见：
常量字段值

bestRowUnknown

static final int bestRowUnknown
指示最佳行标识符可能是伪列 (pseudo column)，也可能不是。

getBestRowIdentifier 方法返回的 ResultSet 对象中 PSEUDO_COLUMN 列的可能值。

另请参见：
常量字段值

bestRowNotPseudo

static final int bestRowNotPseudo
指示最佳行标识符“不”是伪列。

getBestRowIdentifier 方法返回的 ResultSet 对象中 PSEUDO_COLUMN 列的可能值。

另请参见：
常量字段值

bestRowPseudo

static final int bestRowPseudo
指示最佳行标识符是伪列。

getBestRowIdentifier 方法返回的 ResultSet 对象中 PSEUDO_COLUMN 列的可能值。

另请参见：
常量字段值

versionColumnUnknown

static final int versionColumnUnknown
指示这种版本的列可能是伪列，也可能不是。

getVersionColumns 方法返回的 ResultSet 对象中 PSEUDO_COLUMN 列的可能值。

另请参见：
常量字段值

versionColumnNotPseudo

static final int versionColumnNotPseudo
指示这种版本的列“不”是伪列。

getVersionColumns 方法返回的 ResultSet 对象中 PSEUDO_COLUMN 列的可能值。

另请参见：
常量字段值

versionColumnPseudo

static final int versionColumnPseudo
指示这种版本的列是伪列。

getVersionColumns 方法返回的 ResultSet 对象中 PSEUDO_COLUMN 列的可能值。

另请参见：
常量字段值

importedKeyCascade

static final int importedKeyCascade
对于 UPDATE_RULE 列，指示在更新主键时，外键（导入的键）的更改要与之一致。对于 DELETE_RULE 列，它指示在删除主键时，也应删除导入该键的行。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 UPDATE_RULE 和 DELETE_RULE 列的可能值。

另请参见：
常量字段值

importedKeyRestrict

static final int importedKeyRestrict
对于 UPDATE_RULE 列，指示如果主键已被另一个表作为外键导入，则可能不更新该主键。对于 DELETE_RULE 列，指示如果主键已被另一个表作为外键导入，则可能不删除该主键。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 UPDATE_RULE 和 DELETE_RULE 列的可能值。

另请参见：
常量字段值

importedKeySetNull

static final int importedKeySetNull
对于 UPDATE_RULE 和 DELETE_RULE 列，指示在更新或删除主键时，将外键（导入的键）更改为 NULL。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 UPDATE_RULE 和 DELETE_RULE 列的可能值。

另请参见：
常量字段值

importedKeyNoAction

static final int importedKeyNoAction
对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果主键已导入，则无法更新或删除它。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 UPDATE_RULE 和 DELETE_RULE 列的可能值。

另请参见：
常量字段值

importedKeySetDefault

static final int importedKeySetDefault
对于 UPDATE_RULE 和 DELETE_RULE 列，指示如果更新或删除了主键，则将外键（导入的键）设置为默认值。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 UPDATE_RULE 和 DELETE_RULE 列的可能值。

另请参见：
常量字段值

importedKeyInitiallyDeferred

static final int importedKeyInitiallyDeferred
指示可延迟性。有关定义，请参见 SQL-92。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 DEFERRABILITY 列的可能值。

另请参见：
常量字段值

importedKeyInitiallyImmediate

static final int importedKeyInitiallyImmediate
指示可延迟性。有关定义，请参见 SQL-92。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 DEFERRABILITY 列的可能值。

另请参见：
常量字段值

importedKeyNotDeferrable

static final int importedKeyNotDeferrable
指示可延迟性。有关定义，请参见 SQL-92。

方法 getImportedKeys、getExportedKeys 和 getCrossReference 返回的 ResultSet 对象中 DEFERRABILITY 列的可能值。

另请参见：
常量字段值

typeNoNulls

static final int typeNoNulls
指示“不”允许对这种数据类型使用 NULL 值。

getTypeInfo 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

typeNullable

static final int typeNullable
指示允许对这种数据类型使用 NULL 值。

getTypeInfo 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

typeNullableUnknown

static final int typeNullableUnknown
指示不知道是否允许对这种数据类型使用 NULL 值。

getTypeInfo 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

typePredNone

static final int typePredNone
指示不支持将 WHERE 搜索子句用于这种类型。

getTypeInfo 方法返回的 ResultSet 对象中 SEARCHABLE 列的可能值。

另请参见：
常量字段值

typePredChar

static final int typePredChar
指示该数据类型只能用于使用 LIKE 谓词的 WHERE 搜索子句中。

getTypeInfo 方法返回的 ResultSet 对象中 SEARCHABLE 列的可能值。

另请参见：
常量字段值

typePredBasic

static final int typePredBasic
指示该数据类型只能用于不使用 LIKE 谓词的 WHERE 搜索子句中。

getTypeInfo 方法返回的 ResultSet 对象中 SEARCHABLE 列的可能值。

另请参见：
常量字段值

typeSearchable

static final int typeSearchable
指示在此类型上可以建立所有 WHERE 搜索子句。

getTypeInfo 方法返回的 ResultSet 对象中 SEARCHABLE 列的可能值。

另请参见：
常量字段值

tableIndexStatistic

static final short tableIndexStatistic
指示此列包含与表的索引描述一起返回的表统计信息。

getIndexInfo 方法返回的 ResultSet 对象中 TYPE 列的可能值。

另请参见：
常量字段值

tableIndexClustered

static final short tableIndexClustered
指示此表索引是一个集群索引 (clustered index)。

getIndexInfo 方法返回的 ResultSet 对象中 TYPE 列的可能值。

另请参见：
常量字段值

tableIndexHashed

static final short tableIndexHashed
指示此表索引是一个散列索引。

getIndexInfo 方法返回的 ResultSet 对象中 TYPE 列的可能值。

另请参见：
常量字段值

tableIndexOther

static final short tableIndexOther
指示此表索引不是集群索引、散列索引或表统计信息，它是其他某种东西。

getIndexInfo 方法返回的 ResultSet 对象中 TYPE 列的可能值。

另请参见：
常量字段值

attributeNoNulls

static final short attributeNoNulls
指示可能不允许使用 NULL 值。

getAttributes 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

attributeNullable

static final short attributeNullable
指示明确允许使用 NULL 值。

getAttributes 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

attributeNullableUnknown

static final short attributeNullableUnknown
指示不知道是否允许使用 NULL 值。

getAttributes 方法返回的 ResultSet 对象中 NULLABLE 列的可能值。

另请参见：
常量字段值

sqlStateXOpen

static final int sqlStateXOpen
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 返回的值是否是一个 X/Open（现在称为 Open Group）SQL CLI SQLSTATE 值。

从以下版本开始：
1.4
另请参见：
常量字段值

sqlStateSQL

static final int sqlStateSQL
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQLSTATE 值。

从以下版本开始：
1.6
另请参见：
常量字段值

sqlStateSQL99

static final int sqlStateSQL99
DatabaseMetaData.getSQLStateType 方法一个可能的返回值，用于指示 SQLException.getSQLState 方法返回的值是否是一个 SQL99 SQLSTATE 值。

注：保留此常量仅出于兼容性考虑。开发人员应该使用 sqlStateSQL 常量来代替。

从以下版本开始：
1.4
另请参见：
常量字段值

functionColumnUnknown

static final int functionColumnUnknown
指示该类型的参数或列未知。

ResultSet 中由 getFunctionColumns 方法返回的 COLUMN_TYPE 列的可能值。

另请参见：
常量字段值

functionColumnIn

static final int functionColumnIn
指示参数或列是一个 IN 参数。

ResultSet 中由 getFunctionColumns 方法返回的 COLUMN_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionColumnInOut

static final int functionColumnInOut
指示参数或列是一个 INOUT 参数。

ResultSet 中由 getFunctionColumns 方法返回的 COLUMN_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionColumnOut

static final int functionColumnOut
指示参数或列是一个 OUT 参数。

ResultSet 中由 getFunctionColumns 方法返回的 COLUMN_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionReturn

static final int functionReturn
指示参数或列是一个返回值。

ResultSet 中由 getFunctionColumns 方法返回的 COLUMN_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionColumnResult

static final int functionColumnResult
指示参数或列是结果集中的一列。

ResultSet 中由 getFunctionColumns 方法返回的 COLUMN_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionNoNulls

static final int functionNoNulls
指示不允许 NULL 值。

ResultSet 对象中由 getFunctionColumns 方法返回的 NULLABLE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionNullable

static final int functionNullable
指示允许 NULL 值。

ResultSet 对象中由 getFunctionColumns 方法返回的 NULLABLE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionNullableUnknown

static final int functionNullableUnknown
指示是否允许 NULL 值是未知的。

ResultSet 对象中由 getFunctionColumns 方法返回的 NULLABLE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionResultUnknown

static final int functionResultUnknown
指示不知道函数是返回一个结果还是一个表。

ResultSet 对象中由 getFunctions 方法返回的 FUNCTION_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionNoTable

static final int functionNoTable
指示函数不返回一个表。

ResultSet 对象中由 getFunctions 方法返回的 FUNCTION_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值

functionReturnsTable

static final int functionReturnsTable
指示函数返回一个表。

ResultSet 对象中由 getFunctions 方法返回的 FUNCTION_TYPE 列的可能值。

从以下版本开始：
1.6
另请参见：
常量字段值
方法详细信息

allProceduresAreCallable

boolean allProceduresAreCallable()
                                 throws SQLException
获取当前用户是否可以调用 getProcedures 方法返回的所有过程。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

allTablesAreSelectable

boolean allTablesAreSelectable()
                               throws SQLException
获取当前用户是否可以使用 SELECT 语句中的 getTables 方法返回的所有表。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getURL

String getURL()
              throws SQLException
获取此 DBMS 的 URL。

返回：
此 DBMS 的 URL，如果无法生成该 URL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误

getUserName

String getUserName()
                   throws SQLException
获取此数据库的已知的用户名称。

返回：
数据库用户名称
抛出：
SQLException - 如果发生数据库访问错误

isReadOnly

boolean isReadOnly()
                   throws SQLException
获取此数据库是否处于只读模式。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

nullsAreSortedHigh

boolean nullsAreSortedHigh()
                           throws SQLException
获取 NULL 值是否被高排序。高排序是指在域中，NULL 值的排序高于其他任何值。在升序中，如果此方法返回 true，则 NULL 值将出现在末尾。相反，nullsAreSortedAtEnd 方法指示 NULL 值始终存储在末尾，不管排序顺序如何。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

nullsAreSortedLow

boolean nullsAreSortedLow()
                          throws SQLException
获取 NULL 值是否被低排序。低排序是指在域中，NULL 值的排序低于其他任何值。在升序中，如果此方法返回 true，则 NULL 值将出现在开头。相反，nullsAreSortedAtStart 方法指示 NULL 值始终存储在开头，不管排序顺序如何。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

nullsAreSortedAtStart

boolean nullsAreSortedAtStart()
                              throws SQLException
获取 NULL 值是否始终排在开头，不管排序顺序如何。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

nullsAreSortedAtEnd

boolean nullsAreSortedAtEnd()
                            throws SQLException
获取 NULL 值是否始终排在末尾，不管排序顺序如何。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getDatabaseProductName

String getDatabaseProductName()
                              throws SQLException
获取此数据库产品的名称。

返回：
数据库产品名称
抛出：
SQLException - 如果发生数据库访问错误

getDatabaseProductVersion

String getDatabaseProductVersion()
                                 throws SQLException
获取此数据库产品的版本号。

返回：
数据库版本号
抛出：
SQLException - 如果发生数据库访问错误

getDriverName

String getDriverName()
                     throws SQLException
获取此 JDBC 驱动程序的名称。

返回：
JDBC 驱动程序名称
抛出：
SQLException - 如果发生数据库访问错误

getDriverVersion

String getDriverVersion()
                        throws SQLException
获取此 JDBC 驱动程序的 String 形式的版本号。

返回：
JDBC 驱动程序版本
抛出：
SQLException - 如果发生数据库访问错误

getDriverMajorVersion

int getDriverMajorVersion()
获取此 JDBC 驱动程序的主版本号。

返回：
JDBC 驱动程序的主版本

getDriverMinorVersion

int getDriverMinorVersion()
获取此 JDBC 驱动程序的次版本号。

返回：
JDBC 驱动程序的次版本号

usesLocalFiles

boolean usesLocalFiles()
                       throws SQLException
获取此数据库是否将表存储在本地文件中。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

usesLocalFilePerTable

boolean usesLocalFilePerTable()
                              throws SQLException
获取此数据库是否为每个表使用一个文件。

返回：
如果此数据库为每个表使用一个本地文件，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsMixedCaseIdentifiers

boolean supportsMixedCaseIdentifiers()
                                     throws SQLException
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

storesUpperCaseIdentifiers

boolean storesUpperCaseIdentifiers()
                                   throws SQLException
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

storesLowerCaseIdentifiers

boolean storesLowerCaseIdentifiers()
                                   throws SQLException
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

storesMixedCaseIdentifiers

boolean storesMixedCaseIdentifiers()
                                   throws SQLException
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsMixedCaseQuotedIdentifiers

boolean supportsMixedCaseQuotedIdentifiers()
                                           throws SQLException
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

storesUpperCaseQuotedIdentifiers

boolean storesUpperCaseQuotedIdentifiers()
                                         throws SQLException
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

storesLowerCaseQuotedIdentifiers

boolean storesLowerCaseQuotedIdentifiers()
                                         throws SQLException
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

storesMixedCaseQuotedIdentifiers

boolean storesMixedCaseQuotedIdentifiers()
                                         throws SQLException
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getIdentifierQuoteString

String getIdentifierQuoteString()
                                throws SQLException
获取用于引用 SQL 标识符的字符串。如果标识符引用不受支持，则此方法返回一个空格 " "。

返回：
引用字符串，如果引用不受支持，则返回一个空格
抛出：
SQLException - 如果发生数据库访问错误

getSQLKeywords

String getSQLKeywords()
                      throws SQLException
获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。

返回：
此数据库的还不是 SQL:2003 关键字的那些关键字组成的列表
抛出：
SQLException - 如果发生数据库访问错误

getNumericFunctions

String getNumericFunctions()
                           throws SQLException
获取可用于此数据库的数学函数的逗号分隔列表。这些是用于 JDBC 函数转义子句中的 Open /Open CLI 数学函数名称。

返回：
此数据库支持的数学函数的列表
抛出：
SQLException - 如果发生数据库访问错误

getStringFunctions

String getStringFunctions()
                          throws SQLException
获取可用于此数据库的字符串函数的逗号分隔列表。这些是用于 JDBC 函数转义子句中的 Open Group CLI 字符串函数名称。

返回：
受此数据库支持的字符串函数的列表
抛出：
SQLException - 如果发生数据库访问错误

getSystemFunctions

String getSystemFunctions()
                          throws SQLException
获取可用于此数据库的系统函数的逗号分隔列表。这些是用于 JDBC 函数转义子句中的 Open Group CLI 系统函数名称。

返回：
受此数据库支持的系统函数的列表
抛出：
SQLException - 如果发生数据库访问错误

getTimeDateFunctions

String getTimeDateFunctions()
                            throws SQLException
获取可用于此数据库的时间和日期函数的逗号分隔列表。

返回：
受此数据库支持的时间和日期函数的列表
抛出：
SQLException - 如果发生数据库访问错误

getSearchStringEscape

String getSearchStringEscape()
                             throws SQLException
获取可用于转义通配符的字符串。该字符串是可用于在类别搜索参数中转义 '_' 或 '%' 的字符串，这些类别搜索参数表示模式（因此使用通配符之一）。

'_' 字符表示任何单个字符；'%' 字符表示零个或多个字符的任意序列。

返回：
用于转义通配符的字符串
抛出：
SQLException - 如果发生数据库访问错误

getExtraNameCharacters

String getExtraNameCharacters()
                              throws SQLException
获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。

返回：
包含额外字符的字符串
抛出：
SQLException - 如果发生数据库访问错误

supportsAlterTableWithAddColumn

boolean supportsAlterTableWithAddColumn()
                                        throws SQLException
获取此数据库是否支持带有 add 列的 ALTER TABLE。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsAlterTableWithDropColumn

boolean supportsAlterTableWithDropColumn()
                                         throws SQLException
获取此数据库是否支持带有 drop 列的 ALTER TABLE。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsColumnAliasing

boolean supportsColumnAliasing()
                               throws SQLException
获取此数据库是否支持为列提供别名。

如果支持，则可以使用 SQL AS 子句为已经计算的列提供名称，或者为所需要的列提供别名。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

nullPlusNonNullIsNull

boolean nullPlusNonNullIsNull()
                              throws SQLException
获取此数据库是否支持 NULL 值与等于 NULL 的非 NULL 值之间的连接。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsConvert

boolean supportsConvert()
                        throws SQLException
获取此数据库是否支持用于 JDBC 类型之间转换的 JDBC 标量函数 CONVERT。JDBC 类型是 java.sql.Types 中定义的一般 SQL 数据类型。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsConvert

boolean supportsConvert(int fromType,
                        int toType)
                        throws SQLException
获取此数据库是否支持用于 JDBC fromType 和 toType 类型之间转换的 JDBC 标量函数 CONVERT。JDBC 类型是 java.sql.Types 中定义的一般 SQL 数据类型。

参数：
fromType - 要转换的类型，它是 java.sql.Types 类中的类型代码之一
toType - 要转换的目标类型，它是 java.sql.Types 类中的类型代码之一
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Types

supportsTableCorrelationNames

boolean supportsTableCorrelationNames()
                                      throws SQLException
获取此数据库是否支持表关联名称。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsDifferentTableCorrelationNames

boolean supportsDifferentTableCorrelationNames()
                                               throws SQLException
获取在表关联名称受支持时，是否要限制它们与表的名称不同。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsExpressionsInOrderBy

boolean supportsExpressionsInOrderBy()
                                     throws SQLException
获取此数据库是否支持 ORDER BY 列表中的表达式。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsOrderByUnrelated

boolean supportsOrderByUnrelated()
                                 throws SQLException
获取此数据库是否支持使用不在 SELECT 语句中而在 ORDER BY 子句中的列。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsGroupBy

boolean supportsGroupBy()
                        throws SQLException
获取此数据库是否支持某种形式的 GROUP BY 子句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsGroupByUnrelated

boolean supportsGroupByUnrelated()
                                 throws SQLException
获取此数据库是否支持使用不在 SELECT 语句中而在 GROUP BY 子句中的列。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsGroupByBeyondSelect

boolean supportsGroupByBeyondSelect()
                                    throws SQLException
获取此数据库是否支持使用不包含在 SELECT 语句中而包含在 GROUP BY 子句中的列，假设 SELECT 语句中的所有列都包含在 GROUP BY 子句中。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsLikeEscapeClause

boolean supportsLikeEscapeClause()
                                 throws SQLException
获取此数据库是否支持指定 LIKE 转义子句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsMultipleResultSets

boolean supportsMultipleResultSets()
                                   throws SQLException
获取此数据库是否支持一次调用 execute 方法获得多个 ResultSet 对象。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsMultipleTransactions

boolean supportsMultipleTransactions()
                                     throws SQLException
获取此数据库是否允许一次打开多个事务（在不同的 connection 上）。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsNonNullableColumns

boolean supportsNonNullableColumns()
                                   throws SQLException
获取是否可以将此数据库中的列定义为非 null。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsMinimumSQLGrammar

boolean supportsMinimumSQLGrammar()
                                  throws SQLException
获取此数据库是否支持 ODBC Minimum SQL 语法。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsCoreSQLGrammar

boolean supportsCoreSQLGrammar()
                               throws SQLException
获取此数据库是否支持 ODBC Core SQL 语法。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsExtendedSQLGrammar

boolean supportsExtendedSQLGrammar()
                                   throws SQLException
获取此数据库是否支持 ODBC Extended SQL 语法。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsANSI92EntryLevelSQL

boolean supportsANSI92EntryLevelSQL()
                                    throws SQLException
获取此数据库是否支持 ANSI92 入门级 SQL 语法。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsANSI92IntermediateSQL

boolean supportsANSI92IntermediateSQL()
                                      throws SQLException
获取此数据库是否支持受支持的 ANSI92 中间 SQL 语法。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsANSI92FullSQL

boolean supportsANSI92FullSQL()
                              throws SQLException
获取此数据库是否支持受支持的 ANSI92 完全 SQL 语法。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsIntegrityEnhancementFacility

boolean supportsIntegrityEnhancementFacility()
                                             throws SQLException
获取此数据库是否支持 SQL Integrity Enhancement Facility。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsOuterJoins

boolean supportsOuterJoins()
                           throws SQLException
获取此数据库是否支持某种形式的外连接。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsFullOuterJoins

boolean supportsFullOuterJoins()
                               throws SQLException
获取此数据库是否支持完全嵌套的外连接。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsLimitedOuterJoins

boolean supportsLimitedOuterJoins()
                                  throws SQLException
获取此数据库是否为外连接提供受限制的支持。（如果 supportsFullOuterJoins 方法返回 true，则此为 true）。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getSchemaTerm

String getSchemaTerm()
                     throws SQLException
获取数据库供应商用于 "schema" 的首选术语。

返回：
供应商用于 "schema" 的术语
抛出：
SQLException - 如果发生数据库访问错误

getProcedureTerm

String getProcedureTerm()
                        throws SQLException
获取数据库供应商用于 "procedure" 的首选术语。

返回：
供应商用于 "procedure" 的术语
抛出：
SQLException - 如果发生数据库访问错误

getCatalogTerm

String getCatalogTerm()
                      throws SQLException
获取数据库供应商用于 "catalog" 的首选术语。

返回：
供应商用于 "catalog" 的术语
抛出：
SQLException - 如果发生数据库访问错误

isCatalogAtStart

boolean isCatalogAtStart()
                         throws SQLException
获取某个类别是否出现在完全限定表名的开头。如果没有出现在开头，则类别出现在表名末尾。

返回：
如果类别出现在完全限定表名的开头，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getCatalogSeparator

String getCatalogSeparator()
                           throws SQLException
获取此数据库用作类别和表名之间的分隔符的 String。

返回：
分隔符字符串
抛出：
SQLException - 如果发生数据库访问错误

supportsSchemasInDataManipulation

boolean supportsSchemasInDataManipulation()
                                          throws SQLException
获取某个模式名称是否可以数据操作语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSchemasInProcedureCalls

boolean supportsSchemasInProcedureCalls()
                                        throws SQLException
获取某个模式名称是否可以在过程调用语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSchemasInTableDefinitions

boolean supportsSchemasInTableDefinitions()
                                          throws SQLException
获取某个模式名称是否可以在表定义语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSchemasInIndexDefinitions

boolean supportsSchemasInIndexDefinitions()
                                          throws SQLException
获取某个模式名称是否可以在获取定义语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSchemasInPrivilegeDefinitions

boolean supportsSchemasInPrivilegeDefinitions()
                                              throws SQLException
获取某个模式名称是否可以在特权定义语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsCatalogsInDataManipulation

boolean supportsCatalogsInDataManipulation()
                                           throws SQLException
获取某个类别名称是否可以在数据操作语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsCatalogsInProcedureCalls

boolean supportsCatalogsInProcedureCalls()
                                         throws SQLException
获取某个类别名称是否可以在过程调用语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsCatalogsInTableDefinitions

boolean supportsCatalogsInTableDefinitions()
                                           throws SQLException
获取某个类别名称是否可以在表定义语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsCatalogsInIndexDefinitions

boolean supportsCatalogsInIndexDefinitions()
                                           throws SQLException
获取某个类别名称是否可以在获取定义语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsCatalogsInPrivilegeDefinitions

boolean supportsCatalogsInPrivilegeDefinitions()
                                               throws SQLException
获取某个类别名称是否可以在特权定义语句中使用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsPositionedDelete

boolean supportsPositionedDelete()
                                 throws SQLException
获取此数据库是否支持位置的 DELETE 语句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsPositionedUpdate

boolean supportsPositionedUpdate()
                                 throws SQLException
获取此数据库是否支持位置的 UPDATE 语句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSelectForUpdate

boolean supportsSelectForUpdate()
                                throws SQLException
获取此数据库是否支持位置的 SELECT FOR UPDATE 语句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsStoredProcedures

boolean supportsStoredProcedures()
                                 throws SQLException
获取此数据库是否支持使用存储过程转义语法的存储过程调用。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSubqueriesInComparisons

boolean supportsSubqueriesInComparisons()
                                        throws SQLException
获取此数据库是否支持比较表达式中的子查询。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSubqueriesInExists

boolean supportsSubqueriesInExists()
                                   throws SQLException
获取此数据库是否支持 EXISTS 表达式中的子查询。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSubqueriesInIns

boolean supportsSubqueriesInIns()
                                throws SQLException
获取此数据库是否支持 IN 表达式中的子查询。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsSubqueriesInQuantifieds

boolean supportsSubqueriesInQuantifieds()
                                        throws SQLException
获取此数据库是否支持量化表达式 (quantified expression) 中的子查询。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsCorrelatedSubqueries

boolean supportsCorrelatedSubqueries()
                                     throws SQLException
获取此数据库是否支持相关子查询。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsUnion

boolean supportsUnion()
                      throws SQLException
获取此数据库是否支持 SQL UNION。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsUnionAll

boolean supportsUnionAll()
                         throws SQLException
获取此数据库是否支持 SQL UNION ALL。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsOpenCursorsAcrossCommit

boolean supportsOpenCursorsAcrossCommit()
                                        throws SQLException
获取此数据库是否支持在进行提交期间保持游标开放。

返回：
如果游标总是保持开放，则返回 true；如果游标可能无法保持开放，则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsOpenCursorsAcrossRollback

boolean supportsOpenCursorsAcrossRollback()
                                          throws SQLException
获取此数据库是否支持在回滚期间保持游标开放。

返回：
如果游标总是保持开放，则返回 true；如果游标可能无法保持开放，则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsOpenStatementsAcrossCommit

boolean supportsOpenStatementsAcrossCommit()
                                           throws SQLException
获取此数据库是否支持在进行提交期间保持语句开放。

返回：
如果语句总是保持开放，则返回 true；如果游标可能无法保持开放，则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsOpenStatementsAcrossRollback

boolean supportsOpenStatementsAcrossRollback()
                                             throws SQLException
获取此数据库是否支持在回滚期间保持语句开放。

返回：
如果语句总是保持开放，则返回 true；如果游标可能无法保持开放，则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getMaxBinaryLiteralLength

int getMaxBinaryLiteralLength()
                              throws SQLException
获取此数据库允许在内嵌二进制字面值中使用的最大十六进制字符数。

返回：
max，即用于二进制字面值的最大长度（十六进制字符形式）；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxCharLiteralLength

int getMaxCharLiteralLength()
                            throws SQLException
获取此数据库允许用于字符字面值的最大字符数。

返回：
允许用于字符字面值的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxColumnNameLength

int getMaxColumnNameLength()
                           throws SQLException
获取此数据库允许用于列名称的最大字符数。

返回：
允许用于列名称的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxColumnsInGroupBy

int getMaxColumnsInGroupBy()
                           throws SQLException
获取此数据库允许在 GROUP BY 子句中使用的最大列数。

返回：
所允许的最大列数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxColumnsInIndex

int getMaxColumnsInIndex()
                         throws SQLException
获取此数据库允许在索引中使用的最大列数。

返回：
所允许的最大列数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxColumnsInOrderBy

int getMaxColumnsInOrderBy()
                           throws SQLException
获取此数据库允许在 ORDER BY 子句中使用的最大列数。

返回：
所允许的最大列数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxColumnsInSelect

int getMaxColumnsInSelect()
                          throws SQLException
获取此数据库允许在 SELECT 列表中使用的最大列数。

返回：
所允许的最大列数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxColumnsInTable

int getMaxColumnsInTable()
                         throws SQLException
获取此数据库允许在表中使用的最大列数。

返回：
所允许的最大列数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxConnections

int getMaxConnections()
                      throws SQLException
获取连接到此数据库的并发连接的可能最大数。

返回：
在某一时间可能的活动连接的最大数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxCursorNameLength

int getMaxCursorNameLength()
                           throws SQLException
获取此数据库允许用于游标名称的最大字符数。

返回：
允许用于游标名称的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxIndexLength

int getMaxIndexLength()
                      throws SQLException
获取此数据库允许用于索引（包括索引的所有部分）的最大字节数。

返回：
所允许的最大字节数；这一限制由该索引所有组成部分的组成；结果为零意味着没有限制或者限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxSchemaNameLength

int getMaxSchemaNameLength()
                           throws SQLException
获取此数据库允许在模式名称中使用的最大字符数。

返回：
允许用于模式名称的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxProcedureNameLength

int getMaxProcedureNameLength()
                              throws SQLException
获取此数据库允许用于过程名称的最大字符数。

返回：
允许用于过程名称的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxCatalogNameLength

int getMaxCatalogNameLength()
                            throws SQLException
获取此数据库允许用于类别名称的最大字符数。

返回：
允许用于类别名称的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxRowSize

int getMaxRowSize()
                  throws SQLException
获取此数据库允许在单行中使用的最大字节数。

返回：
允许在行中使用的最大字节数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

doesMaxRowSizeIncludeBlobs

boolean doesMaxRowSizeIncludeBlobs()
                                   throws SQLException
获取 getMaxRowSize 方法的返回值是否包括 SQL 数据类型 LONGVARCHAR 和 LONGVARBINARY。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getMaxStatementLength

int getMaxStatementLength()
                          throws SQLException
获取此数据库允许在 SQL 语句中使用的最大字符数。

返回：
允许在 SQL 语句中使用的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxStatements

int getMaxStatements()
                     throws SQLException
获取在此数据库中在同一时间内可处于开放状态的最大活动语句数。

返回：
在某一时间可同时处于开放状态的最大语句数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxTableNameLength

int getMaxTableNameLength()
                          throws SQLException
获取此数据库允许在表名称中使用的最大字符数。

返回：
允许用于表名称的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxTablesInSelect

int getMaxTablesInSelect()
                         throws SQLException
获取此数据库允许在 SELECT 语句中使用的表的最大数量。

返回：
允许在 SELECT 语句中使用的表的最大数量；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getMaxUserNameLength

int getMaxUserNameLength()
                         throws SQLException
获取此数据库允许在用户名称中使用的最大字符数。

返回：
允许用于用户名称的最大字符数；结果为零意味着没有限制或限制是未知的
抛出：
SQLException - 如果发生数据库访问错误

getDefaultTransactionIsolation

int getDefaultTransactionIsolation()
                                   throws SQLException
获取此数据库的默认事务隔离级别。java.sql.Connection 中定义了一些可能值。

返回：
默认隔离级别
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Connection

supportsTransactions

boolean supportsTransactions()
                             throws SQLException
获取此数据库是否支持事务。如果不支持，则调用 commit 方法是无操作 (noop)，并且隔离级别是 TRANSACTION_NONE。

返回：
如果事务受支持，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsTransactionIsolationLevel

boolean supportsTransactionIsolationLevel(int level)
                                          throws SQLException
获取此数据库是否支持给定事务隔离级别。

参数：
level - java.sql.Connection 中定义的事务隔离级别之一
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Connection

supportsDataDefinitionAndDataManipulationTransactions

boolean supportsDataDefinitionAndDataManipulationTransactions()
                                                              throws SQLException
获取此数据库是否同时支持事务中的数据定义和数据操作语句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

supportsDataManipulationTransactionsOnly

boolean supportsDataManipulationTransactionsOnly()
                                                 throws SQLException
获取此数据库是否仅支持事务中的数据操作语句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

dataDefinitionCausesTransactionCommit

boolean dataDefinitionCausesTransactionCommit()
                                              throws SQLException
获取事务中的数据定义语句是否强迫该事务进行提交。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

dataDefinitionIgnoredInTransactions

boolean dataDefinitionIgnoredInTransactions()
                                            throws SQLException
获取此数据库是否忽略事务中的数据定义语句。

返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getProcedures

ResultSet getProcedures(String catalog,
                        String schemaPattern,
                        String procedureNamePattern)
                        throws SQLException
获取可在给定类别中使用的存储过程的描述。

仅返回与模式和过程名称标准匹配的过程。它们根据 PROCEDURE_CAT、PROCEDURE_SCHEM、PROCEDURE_NAME 和 SPECIFIC_ NAME 进行排序。

每个过程描述都有以下列：

  1. PROCEDURE_CAT String => 过程类别（可为 null）
  2. PROCEDURE_SCHEM String => 过程模式（可为 null）
  3. PROCEDURE_NAME String => 过程名称
  4. 保留供以后使用
  5. 保留供以后使用
  6. 保留供以后使用
  7. REMARKS String => 过程的解释性注释
  8. PROCEDURE_TYPE short => 过程的种类：
    • procedureResultUnknown - 不能确定是否将返回一个返回值。
    • procedureNoResult - 不返回一个返回值
    • procedureReturnsResult - 返回一个返回值
  9. SPECIFIC_NAME String => 唯一标识其模式中此过程的名称。

用户可能不具有执行 getProcedures 返回的所有过程的权限

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
procedureNamePattern - 过程名称模式；它必须与存储在数据库中的过程名称匹配
返回：
ResultSet - 每个行都是一个过程描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getSearchStringEscape()

getProcedureColumns

ResultSet getProcedureColumns(String catalog,
                              String schemaPattern,
                              String procedureNamePattern,
                              String columnNamePattern)
                              throws SQLException
获取给定类别的存储过程参数和结果列的描述。

仅返回与模式、过程和参数名称标准匹配的描述。它们根据 PROCEDURE_CAT、PROCEDURE_SCHEM、PROCEDURE_NAME 和 SPECIFIC_NAME 进行排序。在此排序中，返回值（如果有）排在最前面。接着是参数描述，它们按调用顺序排序。然后是列描述，它们按列编号顺序进行排序。

ResultSet 中的每个行都是带以下字段的参数描述或列描述：

  1. PROCEDURE_CAT String => 过程类别（可为 null）
  2. PROCEDURE_SCHEM String => 过程模式（可为 null）
  3. PROCEDURE_NAME String => 过程名称
  4. COLUMN_NAME String => 列/参数名称
  5. COLUMN_TYPE Short => 列/参数的种类：
    • procedureColumnUnknown - 没人知道
    • procedureColumnIn - IN 参数
    • procedureColumnInOut - INOUT 参数
    • procedureColumnOut - OUT 参数
    • procedureColumnReturn - 过程返回值
    • procedureColumnResult - ResultSet 中的结果列
  6. DATA_TYPE int => 来自 java.sql.Types 的 SQL 类型
  7. TYPE_NAME String => SQL 类型名称，对于 UDT 类型，类型名称是完全限定的
  8. PRECISION int => 精度
  9. LENGTH int => 数据的长度，以字节为单位
  10. SCALE short => scale - 对于 SCALE 不适用的数据类型返回 null。
  11. RADIX short => 基数
  12. NULLABLE short => 是否可以包含 NULL。
    • procedureNoNulls - 不允许使用 NULL 值
    • procedureNullable - 允许使用 NULL 值
    • procedureNullableUnknown - 不知道是否可使用 null
  13. REMARKS String => 描述参数/列的注释
  14. COLUMN_DEF String => 列的默认值，当该值在单引号内时被解释为一个字符串（可以为 null）
    • 字符串 NULL（不在引号内）- 如果 NULL 作为默认值指定
    • TRUNCATE（不在引号内） - 如果指定的默认值截取后才能被表示
    • NULL - 如果没有指定默认值
  15. SQL_DATA_TYPE int => 保留供以后使用
  16. SQL_DATETIME_SUB int => 保留供以后使用
  17. CHAR_OCTET_LENGTH int => 基于二进制和字符的列的最大长度。对于任何其他数据类型，返回值为 NULL
  18. ORDINAL_POSITION int => 顺序位置，对于过程的输入和输出参数该位置从 1 开始。如果此行描述过程的返回值，则返回值 0。对于结果集列，它是从 1 开始的结果集中列的顺序位置。如果有多个结果集，则列顺序位置是已定义的实现。
  19. IS_NULLABLE String => ISO 规则用于确定列是否可以包括 null。
    • YES --- 如果参数可以包括 NULL
    • NO --- 如果参数不可以包括 NULL
    • 空字符串 --- 如果不知道参数是否可以包括 Null
  20. SPECIFIC_NAME String => 唯一标识其模式中此过程的名称。

注：有些数据库可能不为过程返回列描述。

PRECISION 列表示给定列的指定列大小。对于数值数据，这是最大精度。对于字符数据，这是字符长度。对于日期时间数据类型，这是 String 表示形式的字符长度（假定允许的最大小数秒组件的精度）。对于二进制数据，这是字节长度。对于 ROWID 数据类型，这是字节长度。对于列大小不适用的数据类型，则返回 Null。

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 则获取没有类别的描述，表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
procedureNamePattern - 过程名称模式；它必须与存储在数据库中的过程名称匹配
columnNamePattern - 列名称模式；它必须与存储在数据库中的列名称匹配
返回：
ResultSet - 每一行都描述一个存储过程参数或列
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getSearchStringEscape()

getTables

ResultSet getTables(String catalog,
                    String schemaPattern,
                    String tableNamePattern,
                    String[] types)
                    throws SQLException
获取可在给定类别中使用的表的描述。仅返回与类别、模式、表名称和类型标准匹配的表描述。它们根据 TABLE_TYPE、TABLE_CAT、TABLE_SCHEM 和 TABLE_NAME 进行排序。

每个表描述都有以下列：

  1. TABLE_CAT String => 表类别（可为 null）
  2. TABLE_SCHEM String => 表模式（可为 null）
  3. TABLE_NAME String => 表名称
  4. TABLE_TYPE String => 表类型。典型的类型是 "TABLE"、"VIEW"、"SYSTEM TABLE"、"GLOBAL TEMPORARY"、"LOCAL TEMPORARY"、"ALIAS" 和 "SYNONYM"。
  5. REMARKS String => 表的解释性注释
  6. TYPE_CAT String => 类型的类别（可为 null）
  7. TYPE_SCHEM String => 类型模式（可为 null）
  8. TYPE_NAME String => 类型名称（可为 null）
  9. SELF_REFERENCING_COL_NAME String => 有类型表的指定 "identifier" 列的名称（可为 null）
  10. REF_GENERATION String => 指定在 SELF_REFERENCING_COL_NAME 中创建值的方式。这些值为 "SYSTEM"、"USER" 和 "DERIVED"。（可能为 null）

注： 有些数据库可能不返回用于所有表的信息。

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
tableNamePattern - 表名称模式；它必须与存储在数据库中的表名称匹配
types - 要包括的表类型所组成的列表，必须取自从 getTableTypes() 返回的表类型列表；null 表示返回所有类型
返回：
ResultSet - 每一行都是一个表描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getSearchStringEscape()

getSchemas

ResultSet getSchemas()
                     throws SQLException
获取可在此数据库中使用的模式名称。可根据 TABLE_CATALOG 和 TABLE_SCHEM 对结果进行排序。

模式列为：

  1. TABLE_SCHEM String => 模式名称
  2. TABLE_CATALOG String => 类别名称（可为 null）

返回：
ResultSet 对象，在该对象中，每一行都是一个模式描述
抛出：
SQLException - 如果发生数据库访问错误

getCatalogs

ResultSet getCatalogs()
                      throws SQLException
获取可在此数据库中使用的类别名称。可根据类别名称对结果进行排序。

类别列为：

  1. TABLE_CAT String => 类别名称

返回：
ResultSet 对象，在该对象中，每一行都有一个作为类别名称的 String 列
抛出：
SQLException - 如果发生数据库访问错误

getTableTypes

ResultSet getTableTypes()
                        throws SQLException
获取可在此数据库中使用的表类型。可根据表类型对结果进行排序。

表类型为：

  1. TABLE_TYPE String => 表类型。典型的类型为 "TABLE"、"VIEW"、"SYSTEM TABLE"、"GLOBAL TEMPORARY"、"LOCAL TEMPORARY"、"ALIAS" 和 "SYNONYM"。

返回：
ResultSet 对象，在该对象中，每一行都有一个作为表类型的 String 列
抛出：
SQLException - 如果发生数据库访问错误

getColumns

ResultSet getColumns(String catalog,
                     String schemaPattern,
                     String tableNamePattern,
                     String columnNamePattern)
                     throws SQLException
获取可在指定类别中使用的表列的描述。

仅返回与类别、模式、表和列名称标准匹配的列描述。它们根据 TABLE_CAT、TABLE_SCHEM、TABLE_NAME 和 ORDINAL_POSITION 进行排序。

每个列描述都有以下列：

  1. TABLE_CAT String => 表类别（可为 null）
  2. TABLE_SCHEM String => 表模式（可为 null）
  3. TABLE_NAME String => 表名称
  4. COLUMN_NAME String => 列名称
  5. DATA_TYPE int => 来自 java.sql.Types 的 SQL 类型
  6. TYPE_NAME String => 数据源依赖的类型名称，对于 UDT，该类型名称是完全限定的
  7. COLUMN_SIZE int => 列的大小。
  8. BUFFER_LENGTH 未被使用。
  9. DECIMAL_DIGITS int => 小数部分的位数。对于 DECIMAL_DIGITS 不适用的数据类型，则返回 Null。
  10. NUM_PREC_RADIX int => 基数（通常为 10 或 2）
  11. NULLABLE int => 是否允许使用 NULL。
    • columnNoNulls - 可能不允许使用 NULL 值
    • columnNullable - 明确允许使用 NULL 值
    • columnNullableUnknown - 不知道是否可使用 null
  12. REMARKS String => 描述列的注释（可为 null）
  13. COLUMN_DEF String => 该列的默认值，当值在单引号内时应被解释为一个字符串（可为 null）
  14. SQL_DATA_TYPE int => 未使用
  15. SQL_DATETIME_SUB int => 未使用
  16. CHAR_OCTET_LENGTH int => 对于 char 类型，该长度是列中的最大字节数
  17. ORDINAL_POSITION int => 表中的列的索引（从 1 开始）
  18. IS_NULLABLE String => ISO 规则用于确定列是否包括 null。
    • YES --- 如果参数可以包括 NULL
    • NO --- 如果参数不可以包括 NULL
    • 空字符串 --- 如果不知道参数是否可以包括 null
  19. SCOPE_CATLOG String => 表的类别，它是引用属性的作用域（如果 DATA_TYPE 不是 REF，则为 null）
  20. SCOPE_SCHEMA String => 表的模式，它是引用属性的作用域（如果 DATA_TYPE 不是 REF，则为 null）
  21. SCOPE_TABLE String => 表名称，它是引用属性的作用域（如果 DATA_TYPE 不是 REF，则为 null）
  22. SOURCE_DATA_TYPE short => 不同类型或用户生成 Ref 类型、来自 java.sql.Types 的 SQL 类型的源类型（如果 DATA_TYPE 不是 DISTINCT 或用户生成的 REF，则为 null）
  23. IS_AUTOINCREMENT String => 指示此列是否自动增加
    • YES --- 如果该列自动增加
    • NO --- 如果该列不自动增加
    • 空字符串 --- 如果不能确定该列是否是自动增加参数

COLUMN_SIZE 列表示给定列的指定列大小。对于数值数据，这是最大精度。对于字符数据，这是字符长度。对于日期时间数据类型，这是 String 表示形式的字符长度（假定允许的最大小数秒组件的精度）。对于二进制数据，这是字节长度。对于 ROWID 数据类型，这是字节长度。对于列大小不适用的数据类型，则返回 Null。

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
tableNamePattern - 表名称模式；它必须与存储在数据库中的表名称匹配
columnNamePattern - 列名称模式；它必须与存储在数据库中的列名称匹配
返回：
ResultSet - 每一行都是一个列描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getSearchStringEscape()

getColumnPrivileges

ResultSet getColumnPrivileges(String catalog,
                              String schema,
                              String table,
                              String columnNamePattern)
                              throws SQLException
获取用于表列的访问权的描述。

仅返回与列名称标准匹配的特权。它们根据 COLUMN_NAME 和 PRIVILEGE 进行排序。

每个特权描述都有以下列：

  1. TABLE_CAT String => 表类别（可为 null）
  2. TABLE_SCHEM String => 表模式（可为 null）
  3. TABLE_NAME String => 表名称
  4. COLUMN_NAME String => 列名称
  5. GRANTOR String => 访问权的授权人（可为 null）
  6. GRANTEE String => 访问权的被授权人
  7. PRIVILEGE String => 访问权的名称（SELECT、INSERT、UPDATE、REFRENCES 等）
  8. IS_GRANTABLE String => 如果允许被授权人将权利授予他人，则为 "YES"；如果不允许，则为 "NO"；如果未知，则为 null

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那 些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
table - 表名称；它必须与存储在数据库中的表名称匹配
columnNamePattern - 列名称模式；它必须与存储在数据库中的列名称匹配
返回：
ResultSet - 每一行都是一个列特权描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getSearchStringEscape()

getTablePrivileges

ResultSet getTablePrivileges(String catalog,
                             String schemaPattern,
                             String tableNamePattern)
                             throws SQLException
获取可在类别中使用的每个表的访问权的描述。注意，表特权可用于表中的一个或多个列。假定此特权可用于所有列是错误的（对于某些系统可能是正确的，但并非所有的系统都如此）。

仅返回与模式和表名称标准匹配的特权。它们根据 TABLE_CAT、TABLE_SCHEM、TABLE_NAME 和 PRIVILEGE 进行排序。

每个特权描述都有以下列：

  1. TABLE_CAT String => 表类别（可为 null）
  2. TABLE_SCHEM String => 表模式（可为 null）
  3. TABLE_NAME String => 表名称
  4. GRANTOR String => 访问权的授权人（可为 null）
  5. GRANTEE String => 访问权的被授权人
  6. PRIVILEGE String => 访问权的名称（SELECT、INSERT、UPDATE、REFRENCES 等）
  7. IS_GRANTABLE String => 如果允许被授权人将权利授予他人，则为 "YES"；如果不允许，则为 "NO"；如果未知，则为 null

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
tableNamePattern - 表名称模式；它必须与存储在数据库中的表名称匹配
返回：
ResultSet - 每个行都是一个表特权描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getSearchStringEscape()

getBestRowIdentifier

ResultSet getBestRowIdentifier(String catalog,
                               String schema,
                               String table,
                               int scope,
                               boolean nullable)
                               throws SQLException
获取唯一标识行的表的最佳列集合的描述。它们根据 SCOPE 进行排序。

每个列描述都有以下列：

  1. SCOPE short => 实际结果作用域
    • bestRowTemporary - 暂时性的，在使用行时使用
    • bestRowTransaction - 对当前事务的剩余部分有效
    • bestRowSession - 对当前会话的剩余部分有效
  2. COLUMN_NAME String => 列名称
  3. DATA_TYPE int => 来自 java.sql.Types 的 SQL 数据类型
  4. TYPE_NAME String => 数据源依赖的类型名称，对于 UDT，该类型名称是完全限定的
  5. COLUMN_SIZE int => 精度
  6. BUFFER_LENGTH int => 未被使用
  7. DECIMAL_DIGITS short => 标度，对于 DECIMAL_DIGITS 不适用的数据类型，则返回 Null。
  8. PSEUDO_COLUMN short => 此是否为类似 Oracle ROWID 的伪列
    • bestRowUnknown - 可能是伪列，也可能不是
    • bestRowNotPseudo - “不”是伪列
    • bestRowPseudo - 是伪列

COLUMN_SIZE 列表示给定列的指定列大小。对于数值数据，这是最大精度。对于字符数据，这是字符长度。对于日期时间数据类型，这是 String 表示形式字符长度（假定允许的最大小数秒组件的精度）。对于二进制数据，这是字节长度。对于 ROWID 数据类型，这是字节长度。对于列大小不适用的数据类型，则返回 Null。

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那 些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
table - 表名称；它必须与存储在数据库中的表名称匹配
scope - 感兴趣的作用域，可使用于 SCOPE 相同的值
nullable - 包含可为 null 的列。
返回：
ResultSet - 每一行都是一个列描述
抛出：
SQLException - 如果发生数据库访问错误

getVersionColumns

ResultSet getVersionColumns(String catalog,
                            String schema,
                            String table)
                            throws SQLException
获取在更新行中的任意值时自动更新的表列的描述。它们是无序的。

每个列描述都有以下列：

  1. SCOPE short => 未被使用
  2. COLUMN_NAME String => 列名称
  3. DATA_TYPE int => 来自 java.sql.Types 的 SQL 数据类型
  4. TYPE_NAME String => 依赖数据源的类型名称
  5. COLUMN_SIZE int => 精度
  6. BUFFER_LENGTH int => 列值的长度，以字节为单位
  7. DECIMAL_DIGITS short => 标度，对于 DECIMAL_DIGITS 不适用的数据类型，则返回 Null。
  8. PSEUDO_COLUMN short => 此是否为类似 Oracle ROWID 的伪列
    • versionColumnUnknown - 可能是伪列，也可能不是
    • versionColumnNotPseudo - “不”是伪列
    • versionColumnPseudo - 是伪列

COLUMN_SIZE 列表示给定列的指定列大小。对于数值数据，这是最大精度。对于字符数据，这是字符长度。对于日期时间数据类型，这是 String 表示形式字符长度（假定允许的最大小数秒组件的精度）。对于二进制数据，这是字节长度。对于 ROWID 数据类型，这是字节长度。对于列大小不适用的数据类型，则返回 Null。

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那 些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
table - 表名称；它必须与存储在数据库中的表名称匹配
返回：
一个 ResultSet 对象，在该对象中，每一行都是一个列描述
抛出：
SQLException - 如果发生数据库访问错误

getPrimaryKeys

ResultSet getPrimaryKeys(String catalog,
                         String schema,
                         String table)
                         throws SQLException
获取对给定表的主键列的描述。它们根据 COLUMN_NAME 进行排序。

每个主键列描述都有以下列：

  1. TABLE_CAT String => 表类别（可为 null）
  2. TABLE_SCHEM String => 表模式（可为 null）
  3. TABLE_NAME String => 表名称
  4. COLUMN_NAME String => 列名称
  5. KEY_SEQ short => 主键中的序列号（值 1 表示主键中的第一列，值 2 表示主键中的第二列）。
  6. PK_NAME String => 主键的名称（可为 null）

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那 些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
table - 表名称；它必须与存储在数据库中的表名称匹配
返回：
ResultSet - 每一行都是一个主键列描述
抛出：
SQLException - 如果发生数据库访问错误

getImportedKeys

ResultSet getImportedKeys(String catalog,
                          String schema,
                          String table)
                          throws SQLException
获取由给定表的外键列（表导入的主键）引用的主键列的描述。它们根据 PKTABLE_CAT、PKTABLE_SCHEM、PKTABLE_NAME 和 KEY_SEQ 进行排序。

每个主键列描述都有以下列：

  1. PKTABLE_CAT String => 被导入的主键表类别（可为 null）
  2. PKTABLE_SCHEM String => 被导入的主键表模式（可为 null）
  3. PKTABLE_NAME String => 被导入的主键表名称
  4. PKCOLUMN_NAME String => 被导入的主键列名称
  5. FKTABLE_CAT String => 外键表类别（可为 null）
  6. FKTABLE_SCHEM String => 外键表模式（可为 null）
  7. FKTABLE_NAME String => 外键表名称
  8. FKCOLUMN_NAME String => 外键列名称
  9. KEY_SEQ short => 外键中的序列号（值 1 表示外键中的第一列，值 2 表示外键中的第二列）。
  10. UPDATE_RULE short => 更新主键时外键发生的变化：
    • importedNoAction - 如果已经被导入，则不允许更新主键
    • importedKeyCascade - 将导入的键更改为与主键更新一致
    • importedKeySetNull - 如果已更新导入键的主键，则将导入键更改为 NULL
    • importedKeySetDefault - 如果已更新导入键的主键，则将导入键更改为默认值
    • importedKeyRestrict - 与 importedKeyNoAction 相同（为了与 ODBC 2.x 兼容）
  11. DELETE_RULE short => 删除主键时外键发生的变化。
    • importedKeyNoAction - 如果已经导入，则不允许删除主键
    • importedKeyCascade - 删除导入删除键的行
    • importedKeySetNull - 如果已删除导入键的主键，则将导入键更改为 NULL
    • importedKeyRestrict - 与 importedKeyNoAction 相同（为了与 ODBC 2.x 兼容）
    • importedKeySetDefault - 如果已删除导入键的主键，则将导入键更改为默认值
  12. FK_NAME String => 外键的名称（可为 null）
  13. PK_NAME String => 主键的名称（可为 null）
  14. DEFERRABILITY short => 是否可以将对外键约束的评估延迟到提交时间
    • importedKeyInitiallyDeferred - 有关定义，请参见 SQL92
    • importedKeyInitiallyImmediate - 有关定义，请参见 SQL92
    • importedKeyNotDeferrable - 有关定义，请参见 SQL92

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那 些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
table - 表名称；它必须与存储在数据库中的表名称匹配
返回：
ResultSet - 每一行都是一个主键列描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getExportedKeys(java.lang.String, java.lang.String, java.lang.String)

getExportedKeys

ResultSet getExportedKeys(String catalog,
                          String schema,
                          String table)
                          throws SQLException
获取引用给定表的主键列（表导入的外键）的外键列的描述。它们根据 FKTABLE_CAT、FKTABLE_SCHEM、FKTABLE_NAME 和 KEY_SEQ 进行排序。

每个外键列描述都有以下列：

  1. PKTABLE_CAT String => 主键表类别（可为 null）
  2. PKTABLE_SCHEM String => 主键表模式（可为 null）
  3. PKTABLE_NAME String => 主键表名称
  4. PKCOLUMN_NAME String => 主键列名称
  5. FKTABLE_CAT String => 被导入的外键表类别（可能为 null），该字符串可能为 null
  6. FKTABLE_SCHEM String => 被导入的外键表模式（可能为 null），该字符串可能为 null
  7. FKTABLE_NAME String => 被导入的外键表名称
  8. FKCOLUMN_NAME String => 被导入的外键列名称
  9. KEY_SEQ short => 外键中的序列号（值 1 表示外键中的第一列，值 2 表示外键中的第二列）。
  10. UPDATE_RULE short => 更新主键时外键发生的变化：
    • importedNoAction - 如果已经导入，则不允许更新主键
    • importedKeyCascade - 将导入的键更改为与主键更新一致
    • importedKeySetNull - 如果已更新导入键的主键，则将导入键更改为 NULL
    • importedKeySetDefault - 如果已更新导入键的主键，则将导入键更改为默认值
    • importedKeyRestrict - 与 importedKeyNoAction 相同（为了与 ODBC 2.x 兼容）
  11. DELETE_RULE short => 删除主键时外键发生的变化。
    • importedKeyNoAction - 如果已经导入，则不允许删除主键
    • importedKeyCascade - 删除导入删除键的行
    • importedKeySetNull - 如果已删除导入键的主键，则将导入键更改为 NULL
    • importedKeyRestrict - 与 importedKeyNoAction 相同（为了与 ODBC 2.x 兼容）
    • importedKeySetDefault - 如果已删除导入键的主键，则将导入键更改为默认值
  12. FK_NAME String => 外键的名称（可为 null）
  13. PK_NAME String => 主键的名称（可为 null）
  14. DEFERRABILITY short => 是否可以将对外键约束的评估延迟到提交时间
    • importedKeyInitiallyDeferred - 有关定义，请参见 SQL92
    • importedKeyInitiallyImmediate - 有关定义，请参见 SQL92
    • importedKeyNotDeferrable - 有关定义，请参见 SQL92

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那 些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
table - 表名称；它必须与存储在数据库中的表名称匹配
返回：
一个 ResultSet 对象，在该对象中，每一行都是一个外键列描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getImportedKeys(java.lang.String, java.lang.String, java.lang.String)

getCrossReference

ResultSet getCrossReference(String parentCatalog,
                            String parentSchema,
                            String parentTable,
                            String foreignCatalog,
                            String foreignSchema,
                            String foreignTable)
                            throws SQLException
获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。从父表返回的列数必须与组成外键的列数匹配。它们根据 FKTABLE_CAT、FKTABLE_SCHEM、FKTABLE_NAME 和 KEY_SEQ 进行排序。

每个外键列描述都有以下列：

  1. PKTABLE_CAT String => 父键表类别（可为 null）
  2. PKTABLE_SCHEM String => 父键表模式（可为 null）
  3. PKTABLE_NAME String => 父键表名称
  4. PKCOLUMN_NAME String => 父键列名称
  5. FKTABLE_CAT String => 被导入的外键表类别（可能为 null），该字符串可能为 null
  6. FKTABLE_SCHEM String => 被导入的外键表模式（可能为 null），该字符串可能为 null
  7. FKTABLE_NAME String => 被导入的外键表名称
  8. FKCOLUMN_NAME String => 被导入的外键列名称
  9. KEY_SEQ short => 外键中的序列号（值 1 表示外键中的第一列，值 2 表示外键中的第二列）。
  10. UPDATE_RULE short => 更新父键时外键发生的变化：
    • importedNoAction - 如果已经导入，则不允许更新父键
    • importedKeyCascade - 将导入的键更改为与父键更新一致
    • importedKeySetNull - 如果已更新导入键的父键，则将导入键更改为 NULL
    • importedKeySetDefault - 如果已更新导入键的父键，则将导入键更改为默认值
    • importedKeyRestrict - 与 importedKeyNoAction 相同（为了与 ODBC 2.x 兼容）
  11. DELETE_RULE short => 删除父键时外键发生的变化。
    • importedKeyNoAction - 如果已经导入，则不允许删除父键
    • importedKeyCascade - 删除导入删除键的行
    • importedKeySetNull - 如果已删除导入键的主键，则将导入键更改为 NULL
    • importedKeyRestrict - 与 importedKeyNoAction 相同（为了与 ODBC 2.x 兼容）
    • importedKeySetDefault - 如果已删除导入键的父键，则将导入键更改为默认值
  12. FK_NAME String => 外键的名称（可为 null）
  13. PK_NAME String => 父键的名称（可为 null）
  14. DEFERRABILITY short => 是否可以将对外键约束的评估延迟到提交时间
    • importedKeyInitiallyDeferred - 有关定义，请参见 SQL92
    • importedKeyInitiallyImmediate - 有关定义，请参见 SQL92
    • importedKeyNotDeferrable - 有关定义，请参见 SQL92

参数：
parentCatalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
parentSchema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
parentTable - 导出该键的表的名称；它必须与存储在数据库中的表名称匹配
foreignCatalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 则获取没有类别的那些描述，为 null 则表示从选择标准中删除类别名称
foreignSchema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取那些没有模式的描述，为 null 则表示从选择标准中删除模式名称
foreignTable - 导入该键的表的名称；它必须与存储在数据库中的表名称匹配
返回：
ResultSet - 每一行是一个外键列描述
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getImportedKeys(java.lang.String, java.lang.String, java.lang.String)

getTypeInfo

ResultSet getTypeInfo()
                      throws SQLException
获取此数据库支持的所有数据类型的描述。它们先按照 DATA_TYPE 排序，然后按照数据类型映射表与相应的 JDBC SQL 类型的接近程度排序。

如果数据库支持 SQL 独特类型，则 getTypeInfo() 将返回一行类型为 DISTINCT 的 TYPE_NAME 和类型为 Types.DISTINCT 的 DATA_TYPE。如果数据库支持 SQL 结构类型，则 getTypeInfo() 将会返回一行类型为 STRUCT 的 TYPE_NAME 和类型为 Types.STRUCT 的 DATA_TYPE。

如果支持 SQL 独特类型和结构类型，则每种类型的信息可以从 getUDTs() 方法获得。

每个类型描述都有以下列：

  1. TYPE_NAME String => 类型名称
  2. DATA_TYPE int => 来自 java.sql.Types 的 SQL 数据类型
  3. PRECISION int => 最大精度
  4. LITERAL_PREFIX String => 用于引用字面值的前缀（可为 null）
  5. LITERAL_SUFFIX String => 用于引用字面值的后缀（可为 null）
  6. CREATE_PARAMS String => 用于创建类型的参数（可为 null）
  7. NULLABLE short => 是否可对此类型使用 NULL。
    • typeNoNulls - 不允许使用 NULL 值
    • typeNullable - 允许使用 NULL 值
    • typeNullableUnknown - 不知道是否可使用 null
  8. CASE_SENSITIVE boolean=> 是否区分大小写。
  9. SEARCHABLE short => 是否可以基于此类型使用 "WHERE"：
    • typePredNone - 不支持
    • typePredChar - 仅支持 WHERE ..LIKE
    • typePredBasic - 除 WHERE ..LIKE 以外都受支持
    • typeSearchable - 所有 WHERE ..都受支持
  10. UNSIGNED_ATTRIBUTE boolean => 是否不带符号。
  11. FIXED_PREC_SCALE boolean => 是否可以为钱币值。
  12. AUTO_INCREMENT boolean => 是否可以用于自动增量值。
  13. LOCAL_TYPE_NAME String => 类型名称的本地版（可为 null）
  14. MINIMUM_SCALE short => 受支持的最小标度
  15. MAXIMUM_SCALE short => 受支持的最大标度
  16. SQL_DATA_TYPE int => 未被使用
  17. SQL_DATETIME_SUB int => 未被使用
  18. NUM_PREC_RADIX int => 通常为 2 或 10

对于给定数据类型，PRECISION 列表示服务器支持的最大列大小。对于数值数据，这是最大精度。对于字符数据，这是字符长度。对于日期时间数据类型，这是 String 表示形式的字符长度（假定允许的最大小数秒组件的精度）。对于二进制数据，这是字节长度。对于 ROWID 数据类型，这是字节长度。对于列大小不适用的数据类型，则返回 Null。

返回：
ResultSet 对象，在此对象中，每一行都是一个 SQL 类型描述
抛出：
SQLException - 如果发生数据库访问错误

getIndexInfo

ResultSet getIndexInfo(String catalog,
                       String schema,
                       String table,
                       boolean unique,
                       boolean approximate)
                       throws SQLException
获取给定表的索引和统计信息的描述。它们根据 NON_UNIQUE、TYPE、INDEX_NAME 和 ORDINAL_POSITION 进行排序。

每个索引列描述都有以下列：

  1. TABLE_CAT String => 表类别（可为 null）
  2. TABLE_SCHEM String => 表模式（可为 null）
  3. TABLE_NAME String => 表名称
  4. NON_UNIQUE boolean => 索引值是否可以不唯一。TYPE 为 tableIndexStatistic 时索引值为 false
  5. INDEX_QUALIFIER String => 索引类别（可为 null）；TYPE 为 tableIndexStatistic 时索引类别为 null
  6. INDEX_NAME String => 索引名称；TYPE 为 tableIndexStatistic 时索引名称为 null
  7. TYPE short => 索引类型：
    • tableIndexStatistic - 此标识与表的索引描述一起返回的表统计信息
    • tableIndexClustered - 此为集群索引
    • tableIndexHashed - 此为散列索引
    • tableIndexOther - 此为某种其他样式的索引
  8. ORDINAL_POSITION short => 索引中的列序列号；TYPE 为 tableIndexStatistic 时该序列号为零
  9. COLUMN_NAME String => 列名称；TYPE 为 tableIndexStatistic 时列名称为 null
  10. ASC_OR_DESC String => 列排序序列，"A" => 升序，"D" => 降序，如果排序序列不受支持，可能为 null；TYPE 为 tableIndexStatistic 时排序序列为 null
  11. CARDINALITY int => TYPE 为 tableIndexStatistic 时，它是表中的行数；否则，它是索引中唯一值的数量。
  12. PAGES int => TYPE 为 tableIndexStatisic 时，它是用于表的页数，否则它是用于当前索引的页数。
  13. FILTER_CONDITION String => 过滤器条件，如果有的话。（可能为 null）

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schema - 模式名称；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那 些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
table - 表名称；它必须与存储在数据库中的表名称匹配
unique - 该参数为 true 时，仅返回唯一值的索引；该参数为 false 时，返回所有索引，不管它们是否唯一
approximate - 该参数为 true 时，允许结果是接近的数据值或这些数据值以外的值；该参数为 false 时，要求结果是精确结果
返回：
ResultSet - 每一行都是一个索引列描述
抛出：
SQLException - 如果发生数据库访问错误

supportsResultSetType

boolean supportsResultSetType(int type)
                              throws SQLException
获取此数据库是否支持给定结果集类型。

参数：
type - 在 java.sql.ResultSet 中定义
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2
另请参见：
Connection

supportsResultSetConcurrency

boolean supportsResultSetConcurrency(int type,
                                     int concurrency)
                                     throws SQLException
获取此数据库是否支持与给定结果集类型结合在一起的给定并发性类型。

参数：
type - 在 java.sql.ResultSet 中定义
concurrency - java.sql.ResultSet 中定义的类型
返回：
如果支持，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2
另请参见：
Connection

ownUpdatesAreVisible

boolean ownUpdatesAreVisible(int type)
                             throws SQLException
获取对于给定类型的 ResultSet 对象，结果集自身的更新是否可见。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果更新对于给定结果集是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

ownDeletesAreVisible

boolean ownDeletesAreVisible(int type)
                             throws SQLException
获取结果集自身的删除是否可见。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果删除对于给定结果集是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

ownInsertsAreVisible

boolean ownInsertsAreVisible(int type)
                             throws SQLException
获取结果集自身的插入是否可见。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果插入对于给定结果集是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

othersUpdatesAreVisible

boolean othersUpdatesAreVisible(int type)
                                throws SQLException
获取由其他结果集类型进行的更新是否可见。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果由其他结果集类型进行的更新对于给定结果集是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

othersDeletesAreVisible

boolean othersDeletesAreVisible(int type)
                                throws SQLException
获取由其他结果集类型进行的删除是否可见。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果由其他结果集类型进行的删除对于给定结果集是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

othersInsertsAreVisible

boolean othersInsertsAreVisible(int type)
                                throws SQLException
获取由其他结果集类型进行的插入是否可见。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果由其他结果集类型进行的插入对于给定结果集是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

updatesAreDetected

boolean updatesAreDetected(int type)
                           throws SQLException
获取是否可以通过调用 ResultSet.rowUpdated 方法检测可见行的更新。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果根据结果集类型检测更改，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

deletesAreDetected

boolean deletesAreDetected(int type)
                           throws SQLException
获取是否可以通过调用 ResultSet.rowDeleted 方法检测可见行的删除。如果 deletesAreDetected 方法返回 false，则意味着从结果集中移除已删除的行。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果根据给定结果集类型检测删除，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

insertsAreDetected

boolean insertsAreDetected(int type)
                           throws SQLException
获取是否可以通过调用 ResultSet.rowInserted 方法检测可见行的插入。

参数：
type - ResultSet 类型，它是 ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
返回：
如果根据指定结果集类型检测更改，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

supportsBatchUpdates

boolean supportsBatchUpdates()
                             throws SQLException
获取此数据库是否支持批量更新。

返回：
如果此数据库支持批量更新，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

getUDTs

ResultSet getUDTs(String catalog,
                  String schemaPattern,
                  String typeNamePattern,
                  int[] types)
                  throws SQLException
获取在特定模式中定义的用户定义类型 (UDT) 的描述。特定于模式的 UDT 可能具有类型 JAVA_OBJECT、STRUCT 或 DISTINCT。

仅返回与类别、模式、类型名称和类型标准匹配的类型。它们根据 DATA_TYPE、TYPE_CAT、TYPE_SCHEM 和 TYPE_NAME 进行排序。类型名称参数可能为完全限定名称。在这种情况下，忽略 catalog 和 schemaPattern 参数。

每个类型描述都有以下列：

  1. TYPE_CAT String => 类型的类别（可为 null）
  2. TYPE_SCHEM String => 类型的模式（可为 null）
  3. TYPE_NAME String => 类型名称
  4. CLASS_NAME String => Java 类名称
  5. DATA_TYPE int => 在 java.sql.Types 中定义的类型值，它是 JAVA_OBJECT、STRUCT 或 DISTINCT 之一
  6. REMARKS String => 类型的解释性注释
  7. BASE_TYPE short => DISTINCT 类型或实现结构类型的 SELF_REFERENCING_COLUMN 的用户生成引用类型的类型的源类型类型代码，正如在 java.sql.Types 中定义的那样（如果 DATA_TYPE 不是 DISTINCT 或者不是带有 REFERENCE_GENERATION = USER_DEFINED 的 STRUCT，则该类型代码为 null）

注： 如果驱动程序不支持 UDT，则返回空结果集。

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
typeNamePattern - 类型名称模式；它必须与存储在数据库中的类型名称匹配，它可以是一个完全限定名称
types - 将包括的用户定义类型（JAVA_OBJECT、STRUCT 或 DISTINCT）组成的列表；该参数为 null 则返回所有类型
返回：
ResultSet 对象，其中每一行都描述了一个 UDT
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2
另请参见：
getSearchStringEscape()

getConnection

Connection getConnection()
                         throws SQLException
获取此元数据对象所产生的连接。

返回：
此元数据对象所产生的连接
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2

supportsSavepoints

boolean supportsSavepoints()
                           throws SQLException
获取此数据库是否支持保存点 (savepoint)。

返回：
如果保存点受支持，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

supportsNamedParameters

boolean supportsNamedParameters()
                                throws SQLException
获取此数据库是否支持可调用语句的指定参数。

返回：
如果指定参数受支持，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

supportsMultipleOpenResults

boolean supportsMultipleOpenResults()
                                    throws SQLException
获取是否可以同时拥有从 CallableStatement 对象中返回的多个 ResultSet 对象。

返回：
如果一个 CallableStatement 对象可以同时返回多个 ResultSet 对象，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

supportsGetGeneratedKeys

boolean supportsGetGeneratedKeys()
                                 throws SQLException
获取是否可以在执行语句后获取自动生成的键。

返回：
如果可以在已执行语句后获取自动生成的键，则返回 true；否则返回 false

如果返回 true，则 JDBC 驱动程序至少必须为 SQL INSERT 语句支持自动生成键的返回值。

抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getSuperTypes

ResultSet getSuperTypes(String catalog,
                        String schemaPattern,
                        String typeNamePattern)
                        throws SQLException
获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。仅建模直接的超类型/子类型关系。

仅返回与类别、模式和类型名称匹配的用于 UDT 的超类型信息。类型名称参数可能为完全限定名称。当提供的 UDT 名称是完全限定名称时，忽略 catalog 和 schemaPattern 参数。

如果 UDT 没有直接的超类型，则它不会在这里列出。由此方法返回的 ResultSet 对象的一行描述了指定 UDT 和直接超类型。每一行都具有以下列：

  1. TYPE_CAT String => UDT 的类别（可为 null）
  2. TYPE_SCHEM String => UDT 的模式（可为 null）
  3. TYPE_NAME String => UDT 的类型名称
  4. SUPERTYPE_CAT String => 直接超类型的类别（可为 null）
  5. SUPERTYPE_SCHEM String => 直接超类型的模式（可为 null）
  6. SUPERTYPE_NAME String => 直接超类型的名称

注： 如果驱动程序不支持类型分层结构，则返回空结果集。

参数：
catalog - 类别名称，该参数为 "" 表示获取没有类别的那些描述，为 null 则表示从选择标准中删除类别名称
schemaPattern - 模式名称的模式，该参数为 "" 表示获取没有模式的那些描述
typeNamePattern - UDT 名称模式，可以是一个完全限定名称
返回：
ResultSet 对象，其中一行给出了关于指定 UDT 的信息
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
另请参见：
getSearchStringEscape()

getSuperTables

ResultSet getSuperTables(String catalog,
                         String schemaPattern,
                         String tableNamePattern)
                         throws SQLException
获取在此数据库的特定模式中定义的表分层结构的描述。

仅返回与类别、模式和表名称匹配的表的超表 (supertable) 信息。表名称参数可能为完全限定名称，在这种情况下，可忽略 catalog 和 schemaPattern 参数。如果表没有超表，则它不会在这里列出。超表必须使用与子表相同的类别和模式来定义。所以，类型描述不必包含子表的此信息。

每个类型描述都有以下列：

  1. TABLE_CAT String => 类型的类别（可为 null）
  2. TABLE_SCHEM String => 类型的模式（可为 null）
  3. TABLE_NAME String => 类型名称
  4. SUPERTABLE_NAME String => 直接超类型的名称

注： 如果驱动程序不支持类型分层结构，则返回空结果集。

参数：
catalog - 类别名称，该参数为 "" 表示获取没有类别的那些描述，为 null 则表示从选择标准中删除类别名称
schemaPattern - 模式名称的模式，该参数为 "" 表示获取没有模式的那些描述
tableNamePattern - 表名称模式，可以是一个完全限定名称
返回：
一个 ResultSet 对象，其中的每一行都是一个类型描述
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
另请参见：
getSearchStringEscape()

getAttributes

ResultSet getAttributes(String catalog,
                        String schemaPattern,
                        String typeNamePattern,
                        String attributeNamePattern)
                        throws SQLException
获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。

仅返回与类别、模式、类型和属性名称标准匹配的 UDT 的属性描述。它们根据 TYPE_CAT、TYPE_SCHEM、TYPE_NAME 和 ORDINAL_POSITION 进行排序。此描述不包含某些特定的继承属性。

返回的 ResultSet 对象具有以下列：

  1. TYPE_CAT String => 类型的类别（可为 null）
  2. TYPE_SCHEM String => 类型的模式（可为 null）
  3. TYPE_NAME String => 类型名称
  4. ATTR_NAME String => 属性名称
  5. DATA_TYPE int => 来自 java.sql.Types 的 SQL 类型的属性类型
  6. ATTR_TYPE_NAME String => 依赖数据源的类型名称。对于 UDT，类型名称是完全限定的。对于 REF，类型名称是完全限定的，并且表示引用类型的目标类型。
  7. ATTR_SIZE int => 列的大小。对于 char 或 date 类型，列的大小是最大字符数；对于 numeric 和 decimal 类型，列的大小就是精度。
  8. DECIMAL_DIGITS int => 小数部分的位数。对于 DECIMAL_DIGITS 不适用的数据类型，则返回 Null。
  9. NUM_PREC_RADIX int => 基数（通常为 10 或 2）
  10. NULLABLE int => 是否允许使用 NULL
    • attributeNoNulls - 可能不允许使用 NULL 值
    • attributeNullable - 明确允许使用 NULL 值
    • attributeNullableUnknown - 不知道是否可使用 null
  11. REMARKS String => 描述列的注释（可为 null）
  12. ATTR_DEF String => 默认值（可为 null）
  13. SQL_DATA_TYPE int => 未被使用
  14. SQL_DATETIME_SUB int => 未被使用
  15. CHAR_OCTET_LENGTH int => 对于 char 类型，该长度是列中的最大字节数
  16. ORDINAL_POSITION int => UDT 中的属性的索引（从 1 开始）
  17. IS_NULLABLE String => ISO 规则用于确定属性是否可以包括 Null。
    • YES --- 如果属性可以包括 NULL
    • NO --- 如果属性不可以包括 NULL
    • 空字符串 --- 如果不知道属性是否可以包括 Null
  18. SCOPE_CATALOG String => 表的类别，它是引用属性的作用域（如果 DATA_TYPE 不是 REF，则为 null）
  19. SCOPE_SCHEMA String => 表的模式，它是引用属性的作用域（如果 DATA_TYPE 不是 REF，则为 null）
  20. SCOPE_TABLE String => 表名称，它是引用属性的作用域（如果 DATA_TYPE 不是 REF，则为 null）
  21. SOURCE_DATA_TYPE short => 不同类型或用户生成 Ref 类型、来自 java.sql.Types 的 SQL 类型的源类型（如果 DATA_TYPE 不是 DISTINCT 或用户生成的 REF，则为 null）

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；该参数为 "" 表示获取没有类别的那些描述；为 null 则表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；该参数为 "" 表示获取没有模式的那些描述；为 null 则表示该模式名称不应该用于缩小搜索范围
typeNamePattern - 类型名称模式；它必须与存储在数据库中的类型名称匹配
attributeNamePattern - 属性名称模式；它必须与在数据库中被声明的属性名称匹配
返回：
一个 ResultSet 对象，其中每一行都是一个属性描述
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
另请参见：
getSearchStringEscape()

supportsResultSetHoldability

boolean supportsResultSetHoldability(int holdability)
                                     throws SQLException
获取此数据库是否支持给定结果集可保存性。

参数：
holdability - 以下常量之一：ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT
返回：
如果支持，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
另请参见：
Connection

getResultSetHoldability

int getResultSetHoldability()
                            throws SQLException
针对 ResultSet 对象获取此数据库的默认可保存性。

返回：
默认可保存性，它是 ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getDatabaseMajorVersion

int getDatabaseMajorVersion()
                            throws SQLException
获取底层数据库的主版本号。

返回：
底层数据库的主版本号
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getDatabaseMinorVersion

int getDatabaseMinorVersion()
                            throws SQLException
底层数据库的次版本号。

返回：
底层数据库的次版本号
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getJDBCMajorVersion

int getJDBCMajorVersion()
                        throws SQLException
获取此驱动程序的主 JDBC 版本号。

返回：
JDBC 的主版本号
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getJDBCMinorVersion

int getJDBCMinorVersion()
                        throws SQLException
获取此驱动程序的次 JDBC 版本号。

返回：
JDBC 的次版本号
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getSQLStateType

int getSQLStateType()
                    throws SQLException
指示由 SQLException.getSQLState 返回的 SQLSTATE 是 X/Open（现在称为 Open Group）SQL CLI 还是 SQL:2003。

返回：
SQLSTATE 的类型，它为 sqlStateXOpen 或 sqlStateSQL 之一
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

locatorsUpdateCopy

boolean locatorsUpdateCopy()
                           throws SQLException
指示对 LOB 的更新是在副本上进行还是直接更新到 LOB。

返回：
如果更新在 LOB 的副本上进行，则返回 true；如果直接更新到 LOB，则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

supportsStatementPooling

boolean supportsStatementPooling()
                                 throws SQLException
获取此数据库是否支持语句合并 (statement pooling)。

返回：
如果支持，则返回 true；否则返回 false
抛出：
SQLExcpetion - 如果发生数据库访问错误
SQLException
从以下版本开始：
1.4

getRowIdLifetime

RowIdLifetime getRowIdLifetime()
                               throws SQLException
指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。

返回的 int 值之间具有以下关系：

     ROWID_UNSUPPORTED < ROWID_VALID_OTHER < ROWID_VALID_TRANSACTION
         < ROWID_VALID_SESSION < ROWID_VALID_FOREVER
因此，可以使用
     if (metadata.getRowIdLifetime() > DatabaseMetaData.ROWID_VALID_TRANSACTION)
之类的条件逻辑。永远有效 (ROWID_VALID_FOREVER) 意味着在所有会话中有效，对会话有效 (ROWID_VALID_SESSION) 意味着在其包含的所有事务中有效。

返回：
指示 RowId 生存期的状态
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

getSchemas

ResultSet getSchemas(String catalog,
                     String schemaPattern)
                     throws SQLException
获取此数据库中可用的模式名称。结果根据 TABLE_CATALOG 和 TABLE_SCHEM 进行排序。

模式列为：

  1. TABLE_SCHEM String => 模式名称
  2. TABLE_CATALOG String => 类别名称（可以为 null）

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；为 "" 表示获取没有类别的模式名称；为 null 表示该类别名称不应该用于缩小搜索范围。
schemaPattern - 模式名称；它必须与存储在数据库中的模式名称匹配；为 null 则表示该模式名称不应该用于缩小搜索范围。
返回：
每行是一个模式描述的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6
另请参见：
getSearchStringEscape()

supportsStoredFunctionsUsingCallSyntax

boolean supportsStoredFunctionsUsingCallSyntax()
                                               throws SQLException
获取此数据库是否支持使用存储过程转义语法调用用户定义的函数或供应商函数。

返回：
如果支持，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

autoCommitFailureClosesAllResultSets

boolean autoCommitFailureClosesAllResultSets()
                                             throws SQLException
当 autoCommit 为 true 时，获取 SQLException 是否指示所有打开的 ResultSets 已关闭（包括那些可保持的）。当发生 SQLException 而 autocommit 为 true 时，则 JDBC 驱动程序是以提交操作、回滚操作响应还是既不提交也不回滚是特定于供应商的。此差异的可能结果在于可保持的 ResultSets 是否关闭。

返回：
如果是，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

getClientInfoProperties

ResultSet getClientInfoProperties()
                                  throws SQLException
获取驱动程序支持的客户端信息属性的列表。结果集包括以下列

  1. NAME String=> 客户端信息属性的名称
  2. MAX_LEN int=> 属性值的最大长度
  3. DEFAULT_VALUE String=> 属性的默认值
  4. DESCRIPTION String=> 属性的描述。通常包括关于此属性存储在数据库何处的信息。

ResultSet 按 NAME 列排序

返回：
一个 ResultSet 对象；每行是一个客户端信息属性

抛出：
SQLException - 如果发生数据库访问错误

从以下版本开始：
1.6

getFunctions

ResultSet getFunctions(String catalog,
                       String schemaPattern,
                       String functionNamePattern)
                       throws SQLException
获取给定类别中可用的系统和用户函数的描述。

只返回那些匹配模式和函数名称标准的系统和用户函数的描述。它们按照 FUNCTION_CAT、FUNCTION_SCHEM、FUNCTION_NAME 和 SPECIFIC_ NAME 进行排序。

每个函数描述都有以下列：

  1. FUNCTION_CAT String => 函数类别（可为 null）
  2. FUNCTION_SCHEM String => 函数模式（可为 null）
  3. FUNCTION_NAME String => 函数名称。这是用于调用该函数的名称
  4. REMARKS String => 函数的解释性注释
  5. FUNCTION_TYPE short => 函数的种类：
    • functionResultUnknown - 不能确定是否将返回一个返回值或表。
    • functionNoTable- 不返回表
    • functionReturnsTable - 返回表
  6. SPECIFIC_NAME String => 唯一标识模式中此函数的名数。这是用户指定的或 DBMS 生成的名称，这可能不同于带有重载函数的 FUNCTION_NAME

用户可能不具有执行 getFunctions 返回的所有函数的权限

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；为 "" 表示获取没有类别的那些描述；为 null 表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；为 "" 表示获取没有模式的那些描述；为 null 表示该模式名称不应该用于缩小搜索范围
functionNamePattern - 函数名称模式；它必须与存储在数据库中的函数名称匹配
返回：
ResultSet - 每行是一个函数描述
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6
另请参见：
getSearchStringEscape()

getFunctionColumns

ResultSet getFunctionColumns(String catalog,
                             String schemaPattern,
                             String functionNamePattern,
                             String columnNamePattern)
                             throws SQLException
获取给定类别的系统或用户函数参数和返回类型的描述。

只返回那些匹配模式、函数和参数名称标准的描述。它们按照 FUNCTION_CAT、FUNCTION_SCHEM、FUNCTION_NAME 和 SPECIFIC_ NAME 进行排序。 在此排序中，返回值（如果有）排在最前面。接着是参数描述，它们按调用顺序排序。然后是列描述，它们按列编号顺序排序。

ResultSet 中的每个行都是带以下字段的参数描述、列描述或返回类型描述：

  1. FUNCTION_CAT String => 函数类别（可为 null）
  2. FUNCTION_SCHEM String => 函数模式（可为 null）
  3. FUNCTION_NAME String => 函数名称。这是用于调用该函数的名称
  4. COLUMN_NAME String => 列/参数名称
  5. COLUMN_TYPE Short => 列/参数的种类：
    • functionColumnUnknown - 未知
    • functionColumnIn - IN 参数
    • functionColumnInOut - INOUT 参数
    • functionColumnOut - OUT 参数
    • functionColumnReturn - 函数返回值
    • functionColumnResult - 指示该参数或列是 ResultSet 中的列。
  6. DATA_TYPE int => 取自 java.sql.Types 的 SQL 类型
  7. TYPE_NAME String => SQL 类型名称，对于 UDT 类型该类型名称是完全限定的
  8. PRECISION int => 精度
  9. LENGTH int => 数据的字节长度
  10. SCALE short => scale - 对于其 SCALE 不适用的数据类型返回 null。
  11. RADIX short => 基数
  12. NULLABLE short => 是否可以包含 NULL。
    • functionNoNulls - 不允许使用 NULL 值
    • functionNullable - 允许使用 NULL 值
    • functionNullableUnknown - 不知道是否可使用 Null 值
  13. REMARKS String => 描述列/参数的注释
  14. CHAR_OCTET_LENGTH int => 基于二进制和字符的参数或列的最大长度。对于任何其他数据类型，返回值为 NULL
  15. ORDINAL_POSITION int => 顺序位置，对于输入和输出参数，从 1 开始。如果此行描述函数的返回值，则返回值 0。对于结果集列，它是结果集中列的顺序位置（从 1 开始）。
  16. IS_NULLABLE String => ISO 规则用于确定参数或列是否可以包括 Null
    • YES --- 如果该参数或列可以包括 NULL
    • NO --- 如果该参数或列不可以包括 NULL
    • 空字符串 --- 如果不知道该参数或列是否可以包括 Null
  17. SPECIFIC_NAME String => 唯一标识模式中此函数的名数。这是用户指定的或 DBMS 生成的名称，这可能不同于带有重载函数的 FUNCTION_NAME

PRECISION 列表示给定参数或列的指定列大小。对于数值数据，这是最大精度。对于字符数据，这是字符长度。对于日期时间数据类型，这是 String 表示形式字符长度（假定允许的最大小数秒组件的精度）。对于二进制数据，这是字节长度。对于 ROWID 数据类型，这是字节长度。对于列大小不适用的数据类型，则返回 Null。

参数：
catalog - 类别名称；它必须与存储在数据库中的类别名称匹配；为 "" 表示获取没有类别的那些描述；为 null 表示该类别名称不应该用于缩小搜索范围
schemaPattern - 模式名称的模式；它必须与存储在数据库中的模式名称匹配；为 "" 表示获取没有模式的那 些描述；为 null 表示该模式名称不应该用于缩小搜索范围
functionNamePattern - 进程名称模式；它必须与存储在数据库中的函数名称匹配
columnNamePattern - 参数名称模式；它必须与存储在数据库中的参数或列名称匹配
返回：
ResultSet - 每行描述一个用户函数参数、列或返回类型
抛出：
SQLException - 如果发生数据库访问错误。
从以下版本开始：
1.6
另请参见：
getSearchStringEscape()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataTruncation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 DataTruncation

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLWarning
                    继承者  java.sql.DataTruncation
所有已实现的接口：
Serializable, Iterable<Throwable>
public class DataTruncation
extends SQLWarning

以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。

读取期间 DataTruncation 的 SQLstate 为 01004。

写入期间 DataTruncation 的 SQLstate 为 22001。

另请参见：
序列化表格

构造方法摘要
DataTruncation(int index, boolean parameter, boolean read, int dataSize, int transferSize)
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
DataTruncation(int index, boolean parameter, boolean read, int dataSize, int transferSize, Throwable cause)
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。
方法摘要
int | getDataSize() 获得应该传输的数据字节数。
int | getIndex() 获取被截断的列或参数的索引。
boolean | getParameter() 指示被截断的值是一个参数值还是一个列值。
boolean | getRead() 指示该值是否在读取时被截断。
int | getTransferSize() 获得实际传输的数据字节数。
从类 java.sql.SQLWarning 继承的方法
getNextWarning, setNextWarning
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DataTruncation

public DataTruncation(int index,
                      boolean parameter,
                      boolean read,
                      int dataSize,
                      int transferSize)
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。cause 尚未进行初始化，随后可通过调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
index - 参数或列值的索引
parameter - 如果参数值被截断，则该参数为 true
read - 如果某一 read 字段被截断，则该参数为 true
dataSize - 数据的原始大小
transferSize - 截断后的大小

DataTruncation

public DataTruncation(int index,
                      boolean parameter,
                      boolean read,
                      int dataSize,
                      int transferSize,
                      Throwable cause)
创建一个 DataTruncation 对象，当 read 被设置为 true 时，该对象的 SQLState 初始化为 01004，当 read 被设置为 false 时，则初始化为 22001，reason 被设置为 "Data truncation"，供应商代码被设置为 0，其他字段被设置为给定值。

参数：
index - 参数或列值的索引
parameter - 如果参数值被截断，则该参数为 true
read - 如果某一 read 字段被截断，则该参数为 true
dataSize - 数据的原始大小
transferSize - 截断后的大小
cause - 此 DataTruncation 的底层原因（保存此原因，以便以后通过 getCause() 方法获取）；可以为 null，表示该原因不存在或未知。
从以下版本开始：
1.6
方法详细信息

getIndex

public int getIndex()
获取被截断的列或参数的索引。

如果列或参数索引是未知的，返回值可能为 -1，在这种情况下，应该忽略 parameter 和 read 字段。

返回：
截断的参数或列值的索引

getParameter

public boolean getParameter()
指示被截断的值是一个参数值还是一个列值。

返回：
如果被截断的值是一个参数，则返回 true；如果被截断的值是一个列值，则返回 false

getRead

public boolean getRead()
指示该值是否在读取时被截断。

返回：
如果该值在从数据库中读取时被截断，则返回 true；如果该值在写入时被截断，则返回 false

getDataSize

public int getDataSize()
获得应该传输的数据字节数。如果执行了数据转换，则该数可能是一个近似数。如果大小是未知的，则该值可能为 -1。

返回：
应该传输的数据字节数

getTransferSize

public int getTransferSize()
获得实际传输的数据字节数。如果大小是未知的，则该值可能为 -1。

返回：
实际传输的数据字节数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Date (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 Date

java.lang.Object
    继承者  java.util.Date
        继承者  java.sql.Date
所有已实现的接口：
Serializable, Cloneable, Comparable<Date>
public class Date
extends Date

一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。毫秒值表示自 1970 年 1 月 1 日 00:00:00 GMT 以来经过的毫秒数。

为了与 SQL DATE 的定义一致，由 java.sql.Date 实例包装的毫秒值必须通过将小时、分钟、秒和毫秒设置为与该实例相关的特定时区中的零来“规范化”。

另请参见：
序列化表格

构造方法摘要
Date(int year, int month, int day)
已过时。 使用构造方法 Date(long date) 替代
Date(long date)
使用给定毫秒时间值构造一个 Date 对象。
方法摘要
int | getHours() 已过时。
int | getMinutes() 已过时。
int | getSeconds() 已过时。
void | setHours(int i) 已过时。
void | setMinutes(int i) 已过时。
void | setSeconds(int i) 已过时。
void | setTime(long date) 使用给定毫秒时间值设置现有 Date 对象。
String | toString() 格式化日期转义形式 yyyy-mm-dd 的日期。
static Date | valueOf(String s) 将 JDBC 日期转义形式的字符串转换成 Date 值。
从类 java.util.Date 继承的方法
after, before, clone, compareTo, equals, getDate, getDay, getMonth, getTime, getTimezoneOffset, getYear, hashCode, parse, setDate, setMonth, setYear, toGMTString, toLocaleString, UTC
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Date

public Date(int year,
            int month,
            int day)
已过时。 使用构造方法 Date(long date) 替代

构造一个使用给定 year、month 和 day 初始化的 Date 对象。

如果给定参数超出范围，则结果是不确定的。

参数：
year - year 减去 1900，它必须是 0 到 8099 之间的数。（注意，8099 是由 9999 减去 1900 得到的。）
month - 0 到 11 之间的数
day - 1 到 31 之间的数

Date

public Date(long date)
使用给定毫秒时间值构造一个 Date 对象。如果给定毫秒值包含时间信息，则驱动程序会将时间组件设置为对应于零 GMT 的默认时区（运行应用程序的 Java 虚拟机的时区）中的时间。

参数：
date - 不超过 year 8099 的毫秒表示的自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。负数指示在 1970 年 1 月 1 日 00:00:00 GMT 之前的毫秒数。
方法详细信息

setTime

public void setTime(long date)
使用给定毫秒时间值设置现有 Date 对象。如果给定毫秒值包含时间信息，则驱动程序会将时间组件设置为对应于零 GMT 的默认时区（运行应用程序的 Java 虚拟机的时区）中的时间。

覆盖：
类 Date 中的 setTime
参数：
date - 不超过 year 8099 的毫秒表示的自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。负数指示在 1970 年 1 月 1 日 00:00:00 GMT 之前的毫秒数。

valueOf

public static Date valueOf(String s)
将 JDBC 日期转义形式的字符串转换成 Date 值。

参数：
s - 表示 "yyyy-mm-dd" 形式的日期的 String 对象
返回：
表示给定日期的 java.sql.Date 对象
抛出：
IllegalArgumentException - 如果给定日期不是 JDBC 日期转义形式 (yyyy-mm-dd)

toString

public String toString()
格式化日期转义形式 yyyy-mm-dd 的日期。

覆盖：
类 Date 中的 toString
返回：
一个 yyyy-mm-dd 形式的 String
另请参见：
Date.toLocaleString(), Date.toGMTString()

getHours

public int getHours()
已过时。

因为 SQL Date 值没有时间组件，所以不建议并且不应使用此方法。

覆盖：
类 Date 中的 getHours
返回：
此日期所表示的小时。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
setHours(int)

getMinutes

public int getMinutes()
已过时。

因为 SQL Date 值没有时间组件，所以不建议并且不应使用此方法。

覆盖：
类 Date 中的 getMinutes
返回：
此日期所表示的小时已经过去的分钟数。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
setMinutes(int)

getSeconds

public int getSeconds()
已过时。

因为 SQL Date 值没有时间组件，所以不建议并且不应使用此方法。

覆盖：
类 Date 中的 getSeconds
返回：
此日期表示的分钟已经过去的秒数。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
setSeconds(int)

setHours

public void setHours(int i)
已过时。

因为 SQL Date 值没有时间组件，所以不建议并且不应使用此方法。

覆盖：
类 Date 中的 setHours
参数：
i - 小时值。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
getHours()

setMinutes

public void setMinutes(int i)
已过时。

因为 SQL Date 值没有时间组件，所以不建议并且不应使用此方法。

覆盖：
类 Date 中的 setMinutes
参数：
i - 分钟值。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
getMinutes()

setSeconds

public void setSeconds(int i)
已过时。

因为 SQL Date 值没有时间组件，所以不建议并且不应使用此方法。

覆盖：
类 Date 中的 setSeconds
参数：
i - 秒数值。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
getSeconds()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Driver (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Driver

public interface Driver

每个驱动程序类必须实现的接口。

Java SQL 框架允许多个数据库驱动程序。

每个驱动程序都应该提供一个实现 Driver 接口的类。

DriverManager 会试着加载尽可能多的它可以找到的驱动程序，然后，对于任何给定连接请求，它会让每个驱动程序依次试着连接到目标 URL。

强烈建议每个 Driver 类应该是小型的并且是单独的，这样就可以在不必引入大量支持代码的情况下加载和查询 Driver 类。

在加载某一 Driver 类时，它应该创建自己的实例并向 DriverManager 注册该实例。这意味着用户可以通过调用以下程序加载和注册一个驱动程序

   Class.forName("foo.bah.Driver")

另请参见：
DriverManager, Connection

方法摘要
boolean | acceptsURL(String url) 查询驱动程序是否认为它可以打开到给定 URL 的连接。
Connection | connect(String url, Properties info) 试图创建一个到给定 URL 的数据库连接。
int | getMajorVersion() 获取此驱动程序的主版本号。
int | getMinorVersion() 获得此驱动程序的次版本号。
DriverPropertyInfo[] | getPropertyInfo(String url, Properties info) 获得此驱动程序的可能属性信息。
boolean | jdbcCompliant() 报告此驱动程序是否是一个真正的 JDBC CompliantTM 驱动程序。

方法详细信息

connect

Connection connect(String url,
                   Properties info)
                   throws SQLException
试图创建一个到给定 URL 的数据库连接。如果驱动程序识别出它是连接到给定 URL 的错误类型的驱动程序，那么它应该返回 "null"。这会很常见，因为在要求 JDBC 驱动程序管理器连接到给定 URL 时，它会将该 URL 依次传递给每个已加载的驱动程序。

如果要连接到给定 URL 的驱动程序是正确的驱动程序，但却无法连接到数据库，则该驱动程序应该抛出 SQLException。

可以使用 java.util.Properties 参数将任意字符串标记/值对作为连接参数传递。通常 Properties 对象中至少应该包括 "user" 和 "password" 属性。

参数：
url - 要连接到的数据库的 URL
info - 做为连接参数的任意字符串标记/值对的列表。通常至少应该包括 "user" 和 "password" 属性。
返回：
表示到 URL 的连接的 Connection 对象
抛出：
SQLException - 如果发生数据库访问错误

acceptsURL

boolean acceptsURL(String url)
                   throws SQLException
查询驱动程序是否认为它可以打开到给定 URL 的连接。通常，如果驱动程序理解该 URL 中指定的子协议，则这些驱动程序将返回 true；否则，返回 false。

参数：
url - 数据库的 URL
返回：
如果此驱动程序理解给定的 URL，则返回 true；否则，返回 false
抛出：
SQLException - 如果发生数据库访问错误

getPropertyInfo

DriverPropertyInfo[] getPropertyInfo(String url,
                                     Properties info)
                                     throws SQLException
获得此驱动程序的可能属性信息。

getPropertyInfo 方法允许一般 GUI 工具发现哪些属性它应该提示用户，以便获得连接到数据库的足够信息。注意，根据用户目前为止已经提供的值，额外的值也可能变成必需的，因此可能有必要通过多次调用 getPropertyInfo 方法对它们进行迭代。

参数：
url - 要连接到的数据库的 URL
info - 将要在打开的连接上发送的标记/值对的建议列表
返回：
描述可能属性的 DriverPropertyInfo 对象的数组。如果不需要任何属性，该数组可能是一个空数组。
抛出：
SQLException - 如果发生数据库访问错误

getMajorVersion

int getMajorVersion()
获取此驱动程序的主版本号。最初，此版本号应该为 1。

返回：
此驱动程序的主版本号

getMinorVersion

int getMinorVersion()
获得此驱动程序的次版本号。最初，此版本号应该为 0。

返回：
此驱动程序的次版本号

jdbcCompliant

boolean jdbcCompliant()
报告此驱动程序是否是一个真正的 JDBC CompliantTM 驱动程序。如果通过 JDBC 兼容测试，驱动程序在这里可以只报告 true；否则它需要返回 false。

JDBC 兼容要求完全支持 JDBC API 和完全支持 SQL 92 Entry Level。期望 JDBC 兼容驱动程序可用于所有主要商业数据库。

此方法不打算鼓励开发非 JDBC 兼容驱动程序，但要认识到这样一个事实：一些供应商对将 JDBC API 和框架用于不支持完整的数据库功能的轻量级数据库感兴趣，或者对将 JDBC API 和框架用于一些特殊数据库感兴趣，比如文档信息获取，在这些数据库中 SQL 实现是不可行。

返回：
如果此驱动程序是 JDBC 兼容的，则返回 true；否则，返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DriverManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 DriverManager

java.lang.Object
    继承者  java.sql.DriverManager

public class DriverManager
extends Object

管理一组 JDBC 驱动程序的基本服务。
注：DataSource 接口是 JDBC 2.0 API 中的新增内容，它提供了连接到数据源的另一种方法。使用 DataSource 对象是连接到数据源的首选方法。

作为初始化的一部分，DriverManager 类会尝试加载在 "jdbc.drivers" 系统属性中引用的驱动程序类。这允许用户定制由他们的应用程序使用的 JDBC Driver。例如，在 ~/.hotjava/properties 文件中，用户可以指定：

 jdbc.drivers=foo.bah.Driver:wombat.sql.Driver:bad.taste.ourDriver

DriverManager 类的方法 getConnection 和 getDrivers 已经得到提高以支持 Java Standard Edition Service Provider 机制。 JDBC 4.0 Drivers 必须包括 META-INF/services/java.sql.Driver 文件。此文件包含 java.sql.Driver 的 JDBC 驱动程序实现的名称。例如，要加载 my.sql.Driver 类，META-INF/services/java.sql.Driver 文件需要包含下面的条目：

 my.sql.Driver

应用程序不再需要使用 Class.forName() 显式地加载 JDBC 驱动程序。当前使用 Class.forName() 加载 JDBC 驱动程序的现有程序将在不作修改的情况下继续工作。

在调用 getConnection 方法时，DriverManager 会试着从初始化时加载的那些驱动程序以及使用与当前 applet 或应用程序相同的类加载器显式加载的那些驱动程序中查找合适的驱动程序。

从 Java 2 SDK 标准版本 1.3 版开始，只有当已授予适当权限时设置日志流。通常这将使用工具 PolicyTool 完成，该工具可用于授予 permission java.sql.SQLPermission "setLog" 权限。

另请参见：
Driver, Connection

方法摘要
static void | deregisterDriver(Driver driver) 从 DriverManager 的列表中删除一个驱动程序。
static Connection | getConnection(String url) 试图建立到给定数据库 URL 的连接。
static Connection | getConnection(String url, Properties info) 试图建立到给定数据库 URL 的连接。
static Connection | getConnection(String url, String user, String password) 试图建立到给定数据库 URL 的连接。
static Driver | getDriver(String url) 试图查找能理解给定 URL 的驱动程序。
static Enumeration<Driver> | getDrivers() 获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。
static int | getLoginTimeout() 获取驱动程序试图登录到某一数据库时可以等待的最长时间，以秒为单位。
static PrintStream | getLogStream() 已过时。
static PrintWriter | getLogWriter() 获取日志 writer。
static void | println(String message) 将一条消息打印到当前 JDBC 日志流中。
static void | registerDriver(Driver driver) 向 DriverManager 注册给定驱动程序。
static void | setLoginTimeout(int seconds) 设置驱动程序试图连接到某一数据库时将等待的最长时间，以秒为单位。
static void | setLogStream(PrintStream out) 已过时。
static void | setLogWriter(PrintWriter out) 设置由 DriverManager 和所有驱动程序使用的日志/追踪 PrintWriter 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getLogWriter

public static PrintWriter getLogWriter()
获取日志 writer。应该使用 getLogWriter 和 setLogWriter 方法，而不是使用 get/setlogStream 方法，后者已不建议使用。

返回：
java.io.PrintWriter 对象
从以下版本开始：
1.2
另请参见：
setLogWriter(java.io.PrintWriter)

setLogWriter

public static void setLogWriter(PrintWriter out)
设置由 DriverManager 和所有驱动程序使用的日志/追踪 PrintWriter 对象。

存在一个因为引入 setLogWriter 方法而导致的次版本问题。setLogWriter 方法无法创建将由 getLogStream 返回的 PrintStream 对象，Java 版本不提供后向转换。结果，使用 setLogWriter 的新应用程序以及仍然使用利用 getLogStream 的 JDBC 1.0 驱动程序的新程序很可能将无法查看由该驱动程序写入的调试信息。

从 Java 2 SDK 标准版 1.3 版开始，此方法将查看设置日志流之前是否有 SQLPermission 对象。如果存在 SecurityManager 并且其 checkPermission 方法拒绝设置日志 writer，则此方法将抛出 java.lang.SecurityException。

参数：
out - 新的日志/追踪 PrintStream 对象；null 表示禁止日志和追踪
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法拒绝设置日志 writer
从以下版本开始：
1.2
另请参见：
SecurityManager.checkPermission(java.security.Permission), getLogWriter()

getConnection

public static Connection getConnection(String url,
                                       Properties info)
                                throws SQLException
试图建立到给定数据库 URL 的连接。DriverManager 试图从已注册的 JDBC 驱动程序集中选择一个适当的驱动程序。

参数：
url - jdbc:subprotocol:subname 形式的数据库 url
info - 作为连接参数的任意字符串标记/值对的列表；通常至少应该包括 "user" 和 "password" 属性
返回：
a 到 URL 的连接
抛出：
SQLException - 如果发生数据库访问错误

getConnection

public static Connection getConnection(String url,
                                       String user,
                                       String password)
                                throws SQLException
试图建立到给定数据库 URL 的连接。DriverManager 试图从已注册的 JDBC 驱动程序集中选择一个适当的驱动程序。

参数：
url - jdbc:subprotocol:subname 形式的数据库 url
user - 数据库用户，连接是为该用户建立的
password - 用户的密码
返回：
到 URL 的连接
抛出：
SQLException - 如果发生数据库访问错误

getConnection

public static Connection getConnection(String url)
                                throws SQLException
试图建立到给定数据库 URL 的连接。DriverManager 试图从已注册的 JDBC 驱动程序集中选择一个适当的驱动程序。

参数：
url - jdbc:subprotocol:subname 形式的数据库 url
返回：
到 URL 的连接
抛出：
SQLException - 如果发生数据库访问错误

getDriver

public static Driver getDriver(String url)
                        throws SQLException
试图查找能理解给定 URL 的驱动程序。DriverManager 试图从已注册的 JDBC 驱动程序集中选择一个适当的驱动程序。

参数：
url - jdbc:subprotocol:subname 形式的数据库 URL
返回：
表示可以连接到给定 URL 的驱动程序的 Driver 对象
抛出：
SQLException - 如果发生数据库访问错误

registerDriver

public static void registerDriver(Driver driver)
                           throws SQLException
向 DriverManager 注册给定驱动程序。新加载的驱动程序类应该调用 registerDriver 方法让 DriverManager 知道自己。

参数：
driver - 将向 DriverManager 注册的新的 JDBC Driver
抛出：
SQLException - 如果发生数据库访问错误

deregisterDriver

public static void deregisterDriver(Driver driver)
                             throws SQLException
从 DriverManager 的列表中删除一个驱动程序。applet 只能注销取自其自身的类加载器的驱动程序。

参数：
driver - 要删除的 JDBC Driver
抛出：
SQLException - 如果发生数据库访问错误

getDrivers

public static Enumeration<Driver> getDrivers()
获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。

注：驱动程序的类名称可以使用 d.getClass().getName() 得到

返回：
由调用者的类加载器加载的 JDBC Driver 组成的列表

setLoginTimeout

public static void setLoginTimeout(int seconds)
设置驱动程序试图连接到某一数据库时将等待的最长时间，以秒为单位。

参数：
seconds - 登录时间限制，以秒为单位；0 表示没有限制
另请参见：
getLoginTimeout()

getLoginTimeout

public static int getLoginTimeout()
获取驱动程序试图登录到某一数据库时可以等待的最长时间，以秒为单位。

返回：
驱动程序登录时间限制，以秒为单位
另请参见：
setLoginTimeout(int)

setLogStream

public static void setLogStream(PrintStream out)
已过时。

设置由 DriverManager 和所有驱动程序使用的日志/追踪 PrintStream。

在 Java 2 SDK 标准版 1.3 版中，此方法将查看设置日志流之前是否有 SQLPermission 对象。如果存在 SecurityManager 并且其 checkPermission 方法拒绝设置日志 writer，则此方法将抛出 java.lang.SecurityException。

参数：
out - 新的日志/追踪 PrintStream；要禁止日志和追踪，可将该参数设置为 null
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法拒绝设置日志流
另请参见：
SecurityManager.checkPermission(java.security.Permission), getLogStream()

getLogStream

public static PrintStream getLogStream()
已过时。

获取由 DriverManager 和所有驱动程序使用的日志/追踪 PrintStream。

返回：
日志/追踪 PrintStream；如果禁止日志和追踪，则返回 null
另请参见：
setLogStream(java.io.PrintStream)

println

public static void println(String message)
将一条消息打印到当前 JDBC 日志流中。

参数：
message - 一条日志或追踪消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DriverPropertyInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 DriverPropertyInfo

java.lang.Object
    继承者  java.sql.DriverPropertyInfo

public class DriverPropertyInfo
extends Object

用于建立连接的驱动程序属性。只有那些需要通过 getDriverProperties 方法与 Driver 交互来发现并提供用于连接的属性的高级编程人员，才需要对类 DriverPropertyInfo 感兴趣。

字段摘要
String[] | choices 如果可以从特定一组值中选择 DriverPropertyInfo.value 字段的值，则返回可能值组成的数组；否则返回 null。
String | description 属性的简要描述，可能为 null。
String | name 属性的名称。
boolean | required 如果在 Driver.connect 期间必须为此属性提供一个值，则 required 字段为 true，否则为 false。
String | value value 字段通过综合为 getPropertyInfo 方法提供的信息、Java 环境和驱动程序提供的默认值来指定当前属性值。
构造方法摘要
DriverPropertyInfo(String name, String value)
构造一个带有给定名称和值的 DriverPropertyInfo 对象。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

name

public String name
属性的名称。

description

public String description
属性的简要描述，可能为 null。

required

public boolean required
如果在 Driver.connect 期间必须为此属性提供一个值，则 required 字段为 true，否则为 false。

value

public String value
value 字段通过综合为 getPropertyInfo 方法提供的信息、Java 环境和驱动程序提供的默认值来指定当前属性值。如果不知道任何值，则该字段可以为 null。

choices

public String[] choices
如果可以从特定一组值中选择 DriverPropertyInfo.value 字段的值，则返回可能值组成的数组；否则返回 null。

构造方法详细信息

DriverPropertyInfo

public DriverPropertyInfo(String name,
                          String value)
构造一个带有给定名称和值的 DriverPropertyInfo 对象。description 和 choices 被初始化为 null，required 被初始化为 false。

参数：
name - 属性的名称
value - 当前值，可能为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NClob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 NClob

所有超级接口：
Clob
public interface NClob
extends Clob

SQL NCLOB 类型在 JavaTM 编程语言中的映射。SQL NCLOB 是内置类型，它将使用国家字符集（NATIONAL CHARACTER SET）的字符型大对象（Character Large Object）存储为数据库表某一行中的一个列值。

NClob 接口扩展 Clob 接口，Clob 接口提供一些方法来获取 SQL NCLOB 值的长度、在客户端实现 NCLOB 值、搜索 NCLOB 值中的子字符串或 NCLOB 对象。与 Clob 对象一样，NClob 对象在创建它的事务处理期间有效。接口 ResultSet、CallableStatement 和 PreparedStatement 中的方法（如 getNClob 和 setNClob ）允许程序员访问 SQL NCLOB 值。此外，此接口还有更新 NCLOB 值的方法。

如果 JDBC 驱动程序支持该数据类型，则必须完全实现 NClob 接口中的所有方法。

从以下版本开始：
1.6

方法摘要
从接口 java.sql.Clob 继承的方法
free, getAsciiStream, getCharacterStream, getCharacterStream, getSubString, length, position, position, setAsciiStream, setCharacterStream, setString, setString, truncate

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParameterMetaData (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 ParameterMetaData

所有超级接口：
Wrapper
public interface ParameterMetaData
extends Wrapper

可用于获取关于 PreparedStatement 对象中每个参数标记的类型和属性信息的对象。对于某些查询和驱动程序实现，由 ParameterMetaData 对象返回的数据在 PreparedStatement 执行前可能不可用。

某些驱动程序实现无法提供关于 CallableStatement 对象中每个参数标记的类型和属性的信息。

从以下版本开始：
1.4

字段摘要
static int | parameterModeIn 指示参数模式为 IN 的常量。
static int | parameterModeInOut 指示参数模式为 INOUT 的常量。
static int | parameterModeOut 指示参数模式为 OUT 的常量。
static int | parameterModeUnknown 指示参数模式是未知的常量。
static int | parameterNoNulls 指示某一参数将不允许使用 NULL 值的常量。
static int | parameterNullable 指示某一参数将允许使用 NULL 值的常量。
static int | parameterNullableUnknown 指示不知道某一参数是否可为 null 的常量。
方法摘要
String | getParameterClassName(int param) 获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。
int | getParameterCount() 获取 PreparedStatement 对象中的参数的数量，此 ParameterMetaData 对象包含了该对象的信息。
int | getParameterMode(int param) 获取指定参数的模式。
int | getParameterType(int param) 获取指定参数的 SQL 类型。
String | getParameterTypeName(int param) 获取指定参数的特定于数据库的类型名称。
int | getPrecision(int param) 获取指定参数的指定列大小。
int | getScale(int param) 获取指定参数的小数点右边的位数。
int | isNullable(int param) 获取是否允许在指定参数中使用 null 值。
boolean | isSigned(int param) 获取指定参数的值是否可以是带符号的数字。
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

字段详细信息

parameterNoNulls

static final int parameterNoNulls
指示某一参数将不允许使用 NULL 值的常量。

另请参见：
常量字段值

parameterNullable

static final int parameterNullable
指示某一参数将允许使用 NULL 值的常量。

另请参见：
常量字段值

parameterNullableUnknown

static final int parameterNullableUnknown
指示不知道某一参数是否可为 null 的常量。

另请参见：
常量字段值

parameterModeUnknown

static final int parameterModeUnknown
指示参数模式是未知的常量。

另请参见：
常量字段值

parameterModeIn

static final int parameterModeIn
指示参数模式为 IN 的常量。

另请参见：
常量字段值

parameterModeInOut

static final int parameterModeInOut
指示参数模式为 INOUT 的常量。

另请参见：
常量字段值

parameterModeOut

static final int parameterModeOut
指示参数模式为 OUT 的常量。

另请参见：
常量字段值
方法详细信息

getParameterCount

int getParameterCount()
                      throws SQLException
获取 PreparedStatement 对象中的参数的数量，此 ParameterMetaData 对象包含了该对象的信息。

返回：
参数的数量
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

isNullable

int isNullable(int param)
               throws SQLException
获取是否允许在指定参数中使用 null 值。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
给定参数的状态是否可为 null，该状态值是 ParameterMetaData.parameterNoNulls、ParameterMetaData.parameterNullable 或 ParameterMetaData.parameterNullableUnknown 之一
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

isSigned

boolean isSigned(int param)
                 throws SQLException
获取指定参数的值是否可以是带符号的数字。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getPrecision

int getPrecision(int param)
                 throws SQLException
获取指定参数的指定列大小。

返回值表示给定参数的最大列大小。对于数值数据，这是最大精度。对于字符数据，这是字符长度。对于日期时间数据类型，这是 String 表示形式的字符长度（假定允许的最大小数秒组件的精度）。对于二进制数据，这是字节长度。对于 ROWID 数据类型，这是字节长度。对于列大小不可用的数据类型，则返回 0。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
精度
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getScale

int getScale(int param)
             throws SQLException
获取指定参数的小数点右边的位数。对于标度不可用的数据类型，则返回 0。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
精度
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getParameterType

int getParameterType(int param)
                     throws SQLException
获取指定参数的 SQL 类型。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
来自 java.sql.Types 的 SQL 类型
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
另请参见：
Types

getParameterTypeName

String getParameterTypeName(int param)
                            throws SQLException
获取指定参数的特定于数据库的类型名称。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
数据库使用的类型名称。如果参数类型是用户定义的类型，则返回完全限定的类型名称。
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getParameterClassName

String getParameterClassName(int param)
                             throws SQLException
获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
Java 编程语言中的类的完全限定名称，方法 PreparedStatement.setObject 将使用该名称设置指定参数中的值。此为用于自定义映射关系的类名称。
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4

getParameterMode

int getParameterMode(int param)
                     throws SQLException
获取指定参数的模式。

参数：
param - 第一个参数是 1，第二个参数是 2，……
返回：
参数的模式，该模式是 ParameterMetaData.parameterModeIn、ParameterMetaData.parameterModeOut、ParameterMetaData.parameterModeInOut 或 ParameterMetaData.parameterModeUnknown 之一。
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PreparedStatement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 PreparedStatement

所有超级接口：
Statement, Wrapper
所有已知子接口：
CallableStatement
public interface PreparedStatement
extends Statement

表示预编译的 SQL 语句的对象。

SQL 语句被预编译并存储在 PreparedStatement 对象中。然后可以使用此对象多次高效地执行该语句。

注：用于设置 IN 参数值的设置方法（setShort、setString 等等）必须指定与输入参数的已定义 SQL 类型兼容的类型。例如，如果 IN 参数具有 SQL 类型 INTEGER，那么应该使用 setInt 方法。

如果需要任意参数类型转换，使用 setObject 方法时应该将目标 SQL 类型作为其参数。

在以下设置参数的示例中，con 表示一个活动连接：

   PreparedStatement pstmt = con.prepareStatement("UPDATE EMPLOYEES
                                     SET SALARY = ? WHERE ID = ?");
   pstmt.setBigDecimal(1, 153833.00)
   pstmt.setInt(2, 110592)

另请参见：
Connection.prepareStatement(java.lang.String), ResultSet

字段摘要
从接口 java.sql.Statement 继承的字段
CLOSE_ALL_RESULTS, CLOSE_CURRENT_RESULT, EXECUTE_FAILED, KEEP_CURRENT_RESULT, NO_GENERATED_KEYS, RETURN_GENERATED_KEYS, SUCCESS_NO_INFO
方法摘要
void | addBatch() 将一组参数添加到此 PreparedStatement 对象的批处理命令中。
void | clearParameters() 立即清除当前参数值。
boolean | execute() 在此 PreparedStatement 对象中执行 SQL 语句，该语句可以是任何种类的 SQL 语句。
ResultSet | executeQuery() 在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。
int | executeUpdate() 在此 PreparedStatement 对象中执行 SQL 语句，该语句必须是一个 SQL 数据操作语言（Data Manipulation Language，DML）语句，比如 INSERT、UPDATE 或 DELETE 语句；或者是无返回内容的 SQL 语句，比如 DDL 语句。
ResultSetMetaData | getMetaData() 获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。
ParameterMetaData | getParameterMetaData() 获取此 PreparedStatement 对象的参数的编号、类型和属性。
void | setArray(int parameterIndex, Array x) 将指定参数设置为给定 java.sql.Array 对象。
void | setAsciiStream(int parameterIndex, InputStream x) 将指定参数设置为给定输入流。
void | setAsciiStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将具有给定字节数。
void | setAsciiStream(int parameterIndex, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将具有指定字节数。
void | setBigDecimal(int parameterIndex, BigDecimal x) 将指定参数设置为给定 java.math.BigDecimal 值。
void | setBinaryStream(int parameterIndex, InputStream x) 将指定参数设置为给定输入流。
void | setBinaryStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将具有给定字节数。
void | setBinaryStream(int parameterIndex, InputStream x, long length) 将指定参数设置为给定输入流，该输入流将具有指定字节数。
void | setBlob(int parameterIndex, Blob x) 将指定参数设置为给定 java.sql.Blob 对象。
void | setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | setBoolean(int parameterIndex, boolean x) 将指定参数设置为给定 Java boolean 值。
void | setByte(int parameterIndex, byte x) 将指定参数设置为给定 Java byte 值。
void | setBytes(int parameterIndex, byte[] x) 将指定参数设置为给定 Java byte 数组。
void | setCharacterStream(int parameterIndex, Reader reader) 将指定参数设置为给定 Reader 对象。
void | setCharacterStream(int parameterIndex, Reader reader, int length) 将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | setCharacterStream(int parameterIndex, Reader reader, long length) 将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
void | setClob(int parameterIndex, Clob x) 将指定参数设置为给定 java.sql.Clob 对象。
void | setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setDate(int parameterIndex, Date x) 使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。
void | setDate(int parameterIndex, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | setDouble(int parameterIndex, double x) 将指定参数设置为给定 Java double 值。
void | setFloat(int parameterIndex, float x) 将指定参数设置为给定 Java REAL 值。
void | setInt(int parameterIndex, int x) 将指定参数设置为给定 Java int 值。
void | setLong(int parameterIndex, long x) 将指定参数设置为给定 Java long 值。
void | setNCharacterStream(int parameterIndex, Reader value) 将指定参数设置为 Reader 对象。
void | setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setNString(int parameterIndex, String value) 将指定参数设置为给定 String 对象。
void | setNull(int parameterIndex, int sqlType) 将指定参数设置为 SQL NULL。
void | setNull(int parameterIndex, int sqlType, String typeName) 将指定参数设置为 SQL NULL。
void | setObject(int parameterIndex, Object x) 使用给定对象设置指定参数的值。
void | setObject(int parameterIndex, Object x, int targetSqlType) 使用给定对象设置指定参数的值。
void | setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength) 使用给定对象设置指定参数的值。
void | setRef(int parameterIndex, Ref x) 将指定参数设置为给定 REF(<structured-type>) 值。
void | setRowId(int parameterIndex, RowId x) 将指定参数设置为给定 java.sql.RowId 对象。
void | setShort(int parameterIndex, short x) 将指定参数设置为给定 Java short 值。
void | setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | setString(int parameterIndex, String x) 将指定参数设置为给定 Java String 值。
void | setTime(int parameterIndex, Time x) 将指定参数设置为给定 java.sql.Time 值。
void | setTime(int parameterIndex, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | setTimestamp(int parameterIndex, Timestamp x) 将指定参数设置为给定 java.sql.Timestamp 值。
void | setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | setUnicodeStream(int parameterIndex, InputStream x, int length) 已过时。
void | setURL(int parameterIndex, URL x) 将指定参数设置为给定 java.net.URL 值。
从接口 java.sql.Statement 继承的方法
addBatch, cancel, clearBatch, clearWarnings, close, execute, execute, execute, execute, executeBatch, executeQuery, executeUpdate, executeUpdate, executeUpdate, executeUpdate, getConnection, getFetchDirection, getFetchSize, getGeneratedKeys, getMaxFieldSize, getMaxRows, getMoreResults, getMoreResults, getQueryTimeout, getResultSet, getResultSetConcurrency, getResultSetHoldability, getResultSetType, getUpdateCount, getWarnings, isClosed, isPoolable, setCursorName, setEscapeProcessing, setFetchDirection, setFetchSize, setMaxFieldSize, setMaxRows, setPoolable, setQueryTimeout
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

方法详细信息

executeQuery

ResultSet executeQuery()
                       throws SQLException
在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。

返回：
包含该查询生成的数据的 ResultSet 对象；不会返回 null
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 PreparedStatement 上调用此方法，或者 SQL 语句没有返回 ResultSet 对象

executeUpdate

int executeUpdate()
                  throws SQLException
在此 PreparedStatement 对象中执行 SQL 语句，该语句必须是一个 SQL 数据操作语言（Data Manipulation Language，DML）语句，比如 INSERT、UPDATE 或 DELETE 语句；或者是无返回内容的 SQL 语句，比如 DDL 语句。

返回：
(1) SQL 数据操作语言 (DML) 语句的行数 (2) 对于无返回内容的 SQL 语句，返回 0
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 PreparedStatement 上调用此方法，或者 SQL 语句返回一个 ResultSet 对象

setNull

void setNull(int parameterIndex,
             int sqlType)
             throws SQLException
将指定参数设置为 SQL NULL。

注：必须指定参数的 SQL 类型。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
sqlType - java.sql.Types 中定义的 SQL 类型代码
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型

setBoolean

void setBoolean(int parameterIndex,
                boolean x)
                throws SQLException
将指定参数设置为给定 Java boolean 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL BIT 或 BOOLEAN 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setByte

void setByte(int parameterIndex,
             byte x)
             throws SQLException
将指定参数设置为给定 Java byte 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL TINYINT 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setShort

void setShort(int parameterIndex,
              short x)
              throws SQLException
将指定参数设置为给定 Java short 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL SMALLINT 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setInt

void setInt(int parameterIndex,
            int x)
            throws SQLException
将指定参数设置为给定 Java int 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL INTEGER 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setLong

void setLong(int parameterIndex,
             long x)
             throws SQLException
将指定参数设置为给定 Java long 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL BIGINT 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setFloat

void setFloat(int parameterIndex,
              float x)
              throws SQLException
将指定参数设置为给定 Java REAL 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL FLOAT 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setDouble

void setDouble(int parameterIndex,
               double x)
               throws SQLException
将指定参数设置为给定 Java double 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL DOUBLE 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setBigDecimal

void setBigDecimal(int parameterIndex,
                   BigDecimal x)
                   throws SQLException
将指定参数设置为给定 java.math.BigDecimal 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL NUMERIC 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setString

void setString(int parameterIndex,
               String x)
               throws SQLException
将指定参数设置为给定 Java String 值。在将此值发送给数据库时，驱动程序将它转换成一个 SQL VARCHAR 或 LONGVARCHAR 值（取决于该参数相对于驱动程序在 VARCHAR 值上的限制的大小）。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setBytes

void setBytes(int parameterIndex,
              byte[] x)
              throws SQLException
将指定参数设置为给定 Java byte 数组。在将此值发送给数据库时，驱动程序将它转换成一个 SQL VARBINARY 或 LONGVARBINARY 值（取决于该参数相对于驱动程序在 VARBINARY 值上的限制的大小）。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setDate

void setDate(int parameterIndex,
             Date x)
             throws SQLException
使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL DATE 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setTime

void setTime(int parameterIndex,
             Time x)
             throws SQLException
将指定参数设置为给定 java.sql.Time 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL TIME 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setTimestamp

void setTimestamp(int parameterIndex,
                  Timestamp x)
                  throws SQLException
将指定参数设置为给定 java.sql.Timestamp 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL TIMESTAMP 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setAsciiStream

void setAsciiStream(int parameterIndex,
                    InputStream x,
                    int length)
                    throws SQLException
将指定参数设置为给定输入流，该输入流将具有给定字节数。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setUnicodeStream

void setUnicodeStream(int parameterIndex,
                      InputStream x,
                      int length)
                      throws SQLException
已过时。

将指定参数设置为给定输入流，该输入流将具有给定字节数。在将一个非常大的 Unicode 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 Unicode 到数据库 char 格式的任何必要转换。根据 Java 虚拟机规范中的定义，Unicode 流的字节格式必须是 Java UTF-8。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含 Unicode 参数值的 java.io.InputStream 对象
length - 流中的字节数
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

setBinaryStream

void setBinaryStream(int parameterIndex,
                     InputStream x,
                     int length)
                     throws SQLException
将指定参数设置为给定输入流，该输入流将具有给定字节数。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含二进制参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

clearParameters

void clearParameters()
                     throws SQLException
立即清除当前参数值。

通常参数值对语句的重复使用仍然有效。设置一个参数值会自动清除其以前的值。不过，在某些情况下，直接释放当前参数值使用的资源也是很有用的；这可以通过调用 clearParameters 方法实现。

抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法

setObject

void setObject(int parameterIndex,
               Object x,
               int targetSqlType)
               throws SQLException
使用给定对象设置指定参数的值。除了假定 scale 为 0，此方法类似于上面的 setObject 方法。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（定义于 java.sql.Types 中）
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型
另请参见：
Types

setObject

void setObject(int parameterIndex,
               Object x)
               throws SQLException

使用给定对象设置指定参数的值。第二个参数必须是 Object 类型；所以，应该对内置类型使用 java.lang 的等效对象。

JDBC 规范指定了一个从 Java Object 类型到 SQL 类型的标准映射关系。在发送到数据库之前，给定参数将被转换为相应 SQL 类型。

注意，通过使用特定于驱动程序的 Java 类型，此方法可用于传递特定于数据库的抽象数据类型。如果对象是实现 SQLData 接口的类，则 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流中。另一方面，如果该对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL、RowId、SQLXML 或 Array 的类，则驱动程序应该将它作为相应 SQL 类型的值传递给数据库。

注：并非所有的数据库都允许将非类型 Null 发送给后端。为了获得最大的可移植性，应该使用 setNull 或 setObject(int parameterIndex, Object x, int sqlType) 方法替代 setObject(int parameterIndex, Object x)。

注：如果出现混淆，例如，如果该对象是实现多个上述指定接口的类，则此方法抛出异常。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含输入参数值的对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误；在关闭的 PreparedStatement 上调用此方法，或者给定对象的类型不明确

execute

boolean execute()
                throws SQLException
在此 PreparedStatement 对象中执行 SQL 语句，该语句可以是任何种类的 SQL 语句。一些预处理过的语句返回多个结果，execute 方法处理这些复杂的语句，executeQuery 和 executeUpdate 处理形式更简单的语句。

execute 方法返回一个 boolean 值，指示第一个结果的形式。必须调用 getResultSet 或 getUpdateCount 方法获取该结果，必须调用 getMoreResults 获取任何后续结果。

返回：
如果第一个结果是 ResultSet 对象，则返回 true；如果第一个结果是更新计数或者没有结果，则返回 false
抛出：
SQLException - 如果发生数据库访问错误；在关闭的 PreparedStatement 上调用此方法，或者为此方法提供了参数
另请参见：
Statement.execute(java.lang.String),
Statement.getResultSet(),
Statement.getUpdateCount(),
Statement.getMoreResults()

addBatch

void addBatch()
              throws SQLException
将一组参数添加到此 PreparedStatement 对象的批处理命令中。

抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.2
另请参见：
Statement.addBatch(java.lang.String)

setCharacterStream

void setCharacterStream(int parameterIndex,
                        Reader reader,
                        int length)
                        throws SQLException
将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
reader - 包含 Unicode 数据的 java.io.Reader 对象
length - 流中的字符数
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.2

setRef

void setRef(int parameterIndex,
            Ref x)
            throws SQLException
将指定参数设置为给定 REF(<structured-type>) 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL REF 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 一个 SQL REF 值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setBlob

void setBlob(int parameterIndex,
             Blob x)
             throws SQLException
将指定参数设置为给定 java.sql.Blob 对象。在将此对象发送到数据库时，驱动程序将它转换成一个 SQL BLOB 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 一个映射 SQL BLOB 值的 Blob 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setClob

void setClob(int parameterIndex,
             Clob x)
             throws SQLException
将指定参数设置为给定 java.sql.Clob 对象。在将此对象发送到数据库时，驱动程序将它转换成一个 SQL CLOB 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 一个映射 SQL Clob 值的 Clob 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setArray

void setArray(int parameterIndex,
              Array x)
              throws SQLException
将指定参数设置为给定 java.sql.Array 对象。在将此对象发送到数据库时，驱动程序将它转换成一个 SQL ARRAY 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 一个映射 SQL Array 值的 Array 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getMetaData

ResultSetMetaData getMetaData()
                              throws SQLException
获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。

因为 PreparedStatement 对象被预编译，所以不必执行就可以知道它将返回的 ResultSet 对象。因此，可以对 PreparedStatement 对象调用 getMetaData 方法，而不必等待执行该对象，然后再对返回的 ResultSet 对象调用 ResultSet.getMetaData 方法。

注：对于某些缺乏底层 DBMS 支持的驱动程序，使用此方法开销可能很大。

返回：
ResultSet 对象列的描述；如果驱动程序无法返回一个 ResultSetMetaData 对象，则返回 null
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setDate

void setDate(int parameterIndex,
             Date x,
             Calendar cal)
             throws SQLException
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。驱动程序使用 Calendar 对象构造一个 SQL DATE 值，该值随后被驱动程序发送给数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算日期。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
cal - 驱动程序将用来构造日期的 Calendar 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.2

setTime

void setTime(int parameterIndex,
             Time x,
             Calendar cal)
             throws SQLException
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。驱动程序使用 Calendar 对象构造一个 SQL TIME 值，该值随后被驱动程序发送给数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
cal - 驱动程序将用来构造时间的 Calendar 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.2

setTimestamp

void setTimestamp(int parameterIndex,
                  Timestamp x,
                  Calendar cal)
                  throws SQLException
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。驱动程序使用 Calendar 对象构造一个 SQL TIMESTAMP 值，该值随后被驱动程序发送给数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间戳。如果没有指定任何 Calendar 对象，那么驱动程序将使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
cal - 驱动程序将用来构造时间戳的 Calendar 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.2

setNull

void setNull(int parameterIndex,
             int sqlType,
             String typeName)
             throws SQLException
将指定参数设置为 SQL NULL。这种形式的 setNull 方法应该用于用户定义的类型或 REF 类型参数。用户定义类型的示例有：STRUCT、DISTINCT、JAVA_OBJECT 和指定的数组类型。

注：为了便于移植，在指定 NULL 用户定义参数或 REF 参数时，应用程序必须提供 SQL 类型代码和完全限定的 SQL 类型名称。对于户定义类型，名称是参数本身的类型名称。对于 REF 参数，名称是所引用类型的类型名称。如果 JDBC 驱动程序不需要类型代码和类型名称信息，则可以忽略这些信息。尽管此方法是供用户定义的参数和 Ref 参数使用的，但也可以使用其设置任何 JDBC 类型的 null 参数。如果该参数没有用户定义的类型或 REF 类型，则忽略给定的 typeName。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
sqlType - 取自 java.sql.Types 的一个值
typeName - SQL 用户定义类型的完全限定名称；如果该参数不是用户定义类型或 REF，则忽略它
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 sqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一并且 JDBC 驱动程序不支持此数据类型，或者 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setURL

void setURL(int parameterIndex,
            URL x)
            throws SQLException
将指定参数设置为给定 java.net.URL 值。在将此值发送到数据库时，驱动程序将它转换成一个 SQL DATALINK 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 要设置的 java.net.URL 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getParameterMetaData

ParameterMetaData getParameterMetaData()
                                       throws SQLException
获取此 PreparedStatement 对象的参数的编号、类型和属性。

返回：
一个 ParameterMetaData 对象，它包含有关此 PreparedStatement 对象的每个参数标记的编号、类型和属性的信息
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.4
另请参见：
ParameterMetaData

setRowId

void setRowId(int parameterIndex,
              RowId x)
              throws SQLException
将指定参数设置为给定 java.sql.RowId 对象。在将此对象发送到数据库时，驱动程序将它转换成一个 SQL ROWID 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNString

void setNString(int parameterIndex,
                String value)
                throws SQLException
将指定参数设置为给定 String 对象。在将此对象发送给数据库时，驱动程序将它转换成一个 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR 值（取决于该参数相对于驱动程序在 NVARCHAR 值上的限制的大小）。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
value - 参数值
抛出：
如果 - parameterIndex 不对应于 SQL 语句中的参数标记；如果驱动程序不支持国家字符 (national character) 集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
SQLException
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(int parameterIndex,
                         Reader value,
                         long length)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 将读取数据，直到到达文件末尾。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
value - 参数值
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(int parameterIndex,
              NClob value)
              throws SQLException
将指定参数设置为 java.sql.NClob 对象。在将此对象发送到数据库时，驱动程序将它转换成一个 SQL NCLOB 值。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
value - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(int parameterIndex,
             Reader reader,
             long length)
             throws SQLException
将指定参数设置为 Reader 对象。Reader 必须包含 length 指定的字符数，否则在执行 PreparedStatement 时将生成一个 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它会通知驱动程序应该将参数值作为 CLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARCHAR 还是 CLOB 发送给服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
reader - 包含用于设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误；在关闭的 PreparedStatement 上调用此方法，如果指定的长度小于 0。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(int parameterIndex,
             InputStream inputStream,
             long length)
             throws SQLException
将指定参数设置为 InputStream 对象。Inputstream 必须包含 length 指定的字符数，否则在执行 PreparedStatement 时将生成一个 SQLException。此方法不同于 setBinaryStream (int, InputStream, int) 方法，因为它会通知驱动程序应该将参数值作为 BLOB 发送给服务器。在使用 setBinaryStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARBINARY 还是 BLOB 发送给服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
inputStream - 包含用于设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误；在关闭的 PreparedStatement 上调用此方法，如果指定长度小于 0，或者输入流中的字节数与指定长度不匹配。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(int parameterIndex,
              Reader reader,
              long length)
              throws SQLException
将指定参数设置为 Reader 对象。Reader 必须包含 length 指定的字符数，否则在执行 PreparedStatement 时将生成一个 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它会通知驱动程序应该将参数值作为 NCLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGNVARCHAR 还是 NCLOB 发送给服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
reader - 包含用于设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果指定长度小于 0；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setSQLXML

void setSQLXML(int parameterIndex,
               SQLXML xmlObject)
               throws SQLException
将指定参数设置为给定 java.sql.SQLXML 对象。在将此对象发送到数据库时，驱动程序将它转换成一个 SQL XML 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
xmlObject - 映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误；或者在关闭的 PreparedStatement 上调用此方法，或者 java.xml.transform.Result、Writer 或 OutputStream 已经关闭（对于 SQLXML 对象）
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setObject

void setObject(int parameterIndex,
               Object x,
               int targetSqlType,
               int scaleOrLength)
               throws SQLException

使用给定对象设置指定参数的值。第二个参数必须是一个对象类型；对于整数值，应该使用 java.lang 的等效对象。 如果第二个参数是一个 InputStream，则该流必须包含 scaleOrLength 指定的字节数。如果第二个参数是一个 Reader，则该 Reader 必须包含 scaleOrLength 指定的字符数。如果这些条件不满足，则驱动程序在执行准备好的语句时将生成一个 SQLException。

在发送到数据库之前，给定 Java 对象将被转换为给定 targetSqlType。 如果对象具有自定义映射关系（属于实现 SQLData 接口的类），那么 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流。另一方面，如果该对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，那么驱动程序应该将它作为相应 SQL 类型的值传递给数据库。

注意，此方法可用于传递特定于数据库的抽象数据类型。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（定义于 java.sql.Types 中）。scale 参数可以进一步限定此类型。
scaleOrLength - 对于 java.sql.Types.DECIMAL 或 java.sql.Types.NUMERIC 类型，此值是小数点后的位数。对于 Java Object 类型 InputStream 和 Reader，此值是流或 Reader 中数据的长度。对于所有其他类型，忽略此值。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误；如果在关闭的 PreparedStatement 上调用此方法，或者 x 指定的 Java Object 是一个 InputStream 或 Reader 对象，并且 scale 参数的值小于 0
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型之一，并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.6
另请参见：
Types

setAsciiStream

void setAsciiStream(int parameterIndex,
                    InputStream x,
                    long length)
                    throws SQLException
将指定参数设置为给定输入流，该输入流将具有指定字节数。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.6

setBinaryStream

void setBinaryStream(int parameterIndex,
                     InputStream x,
                     long length)
                     throws SQLException
将指定参数设置为给定输入流，该输入流将具有指定字节数。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含二进制参数值的 java 输入流
length - 流中的字节数
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.6

setCharacterStream

void setCharacterStream(int parameterIndex,
                        Reader reader,
                        long length)
                        throws SQLException
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。在将一个非常大的 UNICODE 值输入给 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
reader - 包含 Unicode 数据的 java.io.Reader 对象
length - 流中的字符数
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
从以下版本开始：
1.6

setAsciiStream

void setAsciiStream(int parameterIndex,
                    InputStream x)
                    throws SQLException
将指定参数设置为给定输入流。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setAsciiStream 是否更有效。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含 ASCII 参数值的 Java 输入流
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

void setBinaryStream(int parameterIndex,
                     InputStream x)
                     throws SQLException
将指定参数设置为给定输入流。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setBinaryStream 是否更有效。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
x - 包含二进制参数值的 java 输入流
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setCharacterStream

void setCharacterStream(int parameterIndex,
                        Reader reader)
                        throws SQLException
将指定参数设置为给定 Reader 对象。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setCharacterStream 是否更有效。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
reader - 包含 Unicode 数据的 java.io.Reader 对象
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(int parameterIndex,
                         Reader value)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 将读取数据，直到到达文件末尾。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setNCharacterStream 是否更有效。

参数：
parameterIndex - 第一个参数是 1，第二个参数是 2，……
value - 参数值
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(int parameterIndex,
             Reader reader)
             throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它会通知驱动程序应该将参数值作为 CLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARCHAR 还是 CLOB 发送给服务器。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setClob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
reader - 包含用于设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误；在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(int parameterIndex,
             InputStream inputStream)
             throws SQLException
将指定参数设置为 InputStream 对象。此方法不同于 setBinaryStream (int, InputStream) 方法，因为它会通知驱动程序应该将参数值作为 BLOB 发送给服务器。在使用 setBinaryStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGVARBINARY 还是 BLOB 发送给服务器。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setBlob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
inputStream - 包含用于设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果发生数据库访问错误；在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(int parameterIndex,
              Reader reader)
              throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它会通知驱动程序应该将参数值作为 NCLOB 发送给服务器。在使用 setCharacterStream 方法时，驱动程序可能必须做一些额外的工作，以确定应该将参数数据作为 LONGNVARCHAR 还是 NCLOB 发送给服务器。

注：查询 JDBC 驱动程序文档，以确定使用带 length 参数的 setNClob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2，……
reader - 包含用于设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterIndex 不对应于 SQL 语句中的参数标记；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Ref (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Ref

所有已知实现类：
SerialRef
public interface Ref

Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。

SQL REF 值存储在一个包含可引用 SQL 结构类型实例的表中，每个 REF 值都是该表中一个实例的唯一标识符。SQL REF 值可用作表中的列值或结构类型中的属性值，取代它所引用的 SQL 结构类型。

因为 SQL REF 值是一个指向 SQL 结构类型的逻辑指针，所以在默认情况下 Ref 对象也是一个逻辑指针。因此，以 Ref 对象的形式获取 SQL REF 值不会在客户端上实现结构类型的属性。

可以使用 PreparedStatement.setRef 方法在数据库中存储 Ref 对象。

如果 JDBC 驱动程序支持数据类型，那么 Ref 接口上的所有方法必须完全实现。

从以下版本开始：
1.2
另请参见：
Struct

方法摘要
String | getBaseTypeName() 获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。
Object | getObject() 获取此 Ref 对象引用的 SQL 结构类型实例。
Object | getObject(Map<String,Class<?>> map) 获取引用对象并使用给定类型映射表将其映射到 Java 类型。
void | setObject(Object value) 将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。

方法详细信息

getBaseTypeName

String getBaseTypeName()
                       throws SQLException
获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。

返回：
SQL 结构类型引用的完全限定的 SQL 名称
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getObject

Object getObject(Map<String,Class<?>> map)
                 throws SQLException
获取引用对象并使用给定类型映射表将其映射到 Java 类型。

参数：
map - 包含要使用的映射关系的 java.util.Map 对象（要引用的 SQL 结构类型的完全限定名和将 SQL 结构类型映射到的 SQLData 实现的类对象）
返回：
Java Object，它是此 Ref 对象引用的 SQL 结构类型的自定义映射关系
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setObject(java.lang.Object)

getObject

Object getObject()
                 throws SQLException
获取此 Ref 对象引用的 SQL 结构类型实例。如果连接的类型映射具有一个结构类型的项，则实例将被自定义映射到类型映射中指示的 Java 类。否则，结构类型实例被映射到 Struct 对象。

返回：
Java Object，它是此 Ref 对象引用的 SQL 结构类型的映射关系
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
setObject(java.lang.Object)

setObject

void setObject(Object value)
               throws SQLException
将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。在将该值发送到数据库时，驱动程序将它转换成一个 SQL 结构类型值。

参数：
value - 一个 Object，表示此 Ref 对象将引用的 SQL 结构类型实例
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getObject(), getObject(Map), PreparedStatement.setObject(int, Object), CallableStatement.setObject(String, Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResultSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 ResultSet

所有超级接口：
Wrapper
所有已知子接口：
CachedRowSet, FilteredRowSet, JdbcRowSet, JoinRowSet, RowSet, SyncResolver, WebRowSet
public interface ResultSet
extends Wrapper

表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。

ResultSet 对象具有指向其当前数据行的光标。最初，光标被置于第一行之前。next 方法将光标移动到下一行；因为该方法在 ResultSet 对象没有下一行时返回 false，所以可以在 while 循环中使用它来迭代结果集。

默认的 ResultSet 对象不可更新，仅有一个向前移动的光标。因此，只能迭代它一次，并且只能按从第一行到最后一行的顺序进行。可以生成可滚动和/或可更新的 ResultSet 对象。以下代码片段（其中 con 为有效的 Connection 对象）演示了如何生成可滚动且不受其他更新影响的可更新结果集。有关其他选项，请参见 ResultSet 字段。

       Statement stmt = con.createStatement(
                                      ResultSet.TYPE_SCROLL_INSENSITIVE,
                                      ResultSet.CONCUR_UPDATABLE);
       ResultSet rs = stmt.executeQuery("SELECT a, b FROM TABLE2");
       // rs will be scrollable, will not show changes made by others,
       // and will be updatable
ResultSet 接口提供用于从当前行获取列值的获取 方法（getBoolean、getLong 等）。可以使用列的索引编号或列的名称获取值。一般情况下，使用列索引较为高效。列从 1 开始编号。为了获得最大的可移植性，应该按从左到右的顺序读取每行中的结果集列，每列只能读取一次。

对于获取方法，JDBC 驱动程序尝试将底层数据转换为在获取方法中指定的 Java 类型，并返回适当的 Java 值。JDBC 规范有一个表，显示允许的从 SQL 类型到 ResultSet 获取方法所使用的 Java 类型的映射关系。

用作获取方法的输入的列名称不区分大小写。用列名称调用获取方法时，如果多个列具有这一名称，则返回第一个匹配列的值。在生成结果集的 SQL 查询中使用列名称时，将使用列名称选项。对于没有在查询中显式指定的列，最好使用列编号。如果使用列名称，则程序员应该注意保证名称唯一引用预期的列，这可以使用 SQL AS 子句确定。

在 JDBC 2.0 API（JavaTM 2 SDK 标准版 1.2 版）中，此接口添加了一组更新方法。关于获取方法参数的注释同样适用于更新方法的参数。

可以用以下两种方式使用更新方法：

  1. 更新当前行中的列值。在可滚动的 ResultSet 对象中，可以向前和向后移动光标，将其置于绝对位置或相对于当前行的位置。以下代码片段更新 ResultSet 对象 rs 第五行中的 NAME 列，然后使用方法 updateRow 更新导出 rs 的数据源表。

       rs.absolute(5); // moves the cursor to the fifth row of rs
       rs.updateString("NAME", "AINSWORTH"); // updates the
          // NAME column of row 5 to be AINSWORTH
       rs.updateRow(); // updates the row in the data source
  2. 将列值插入到插入行中。可更新的 ResultSet 对象具有一个与其关联的特殊行，该行用作构建要插入的行的暂存区域 (staging area)。以下代码片段将光标移动到插入行，构建一个三列的行，并使用方法 insertRow 将其插入到 rs 和数据源表中。

       rs.moveToInsertRow(); // moves cursor to the insert row
       rs.updateString(1, "AINSWORTH"); // updates the
          // first column of the insert row to be AINSWORTH
       rs.updateInt(2,35); // updates the second column to be 35
       rs.updateBoolean(3, true); // updates the third column to true
       rs.insertRow();
       rs.moveToCurrentRow();

当生成 ResultSet 对象的 Statement 对象关闭、重新执行或用来从多个结果的序列获取下一个结果时，ResultSet 对象将自动关闭。

ResultSet 对象的列的编号、类型和属性由 ResultSet.getMetaData 方法返回的 ResulSetMetaData 对象提供。

另请参见：
Statement.executeQuery(java.lang.String), Statement.getResultSet(), ResultSetMetaData

字段摘要
static int | CLOSE_CURSORS_AT_COMMIT 该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将被关闭。
static int | CONCUR_READ_ONLY 该常量指示不可以更新的 ResultSet 对象的并发模式。
static int | CONCUR_UPDATABLE 该常量指示可以更新的 ResultSet 对象的并发模式。
static int | FETCH_FORWARD 该常量指示将按正向（即从第一个到最后一个）处理结果集中的行。
static int | FETCH_REVERSE 该常量指示将按逆向（即从最后一个到第一个）处理结果集中的行处理。
static int | FETCH_UNKNOWN 该常量指示结果集中的行的处理顺序未知。
static int | HOLD_CURSORS_OVER_COMMIT 该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将保持开放。
static int | TYPE_FORWARD_ONLY 该常量指示光标只能向前移动的 ResultSet 对象的类型。
static int | TYPE_SCROLL_INSENSITIVE 该常量指示可滚动但通常不受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。
static int | TYPE_SCROLL_SENSITIVE 该常量指示可滚动并且通常受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。
方法摘要
boolean | absolute(int row) 将光标移动到此 ResultSet 对象的给定行编号。
void | afterLast() 将光标移动到此 ResultSet 对象的末尾，正好位于最后一行之后。
void | beforeFirst() 将光标移动到此 ResultSet 对象的开头，正好位于第一行之前。
void | cancelRowUpdates() 取消对 ResultSet 对象中的当前行所作的更新。
void | clearWarnings() 清除在此 ResultSet 对象上报告的所有警告。
void | close() 立即释放此 ResultSet 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
void | deleteRow() 从此 ResultSet 对象和底层数据库中删除当前行。
int | findColumn(String columnLabel) 将给定的 ResultSet 列标签映射到其 ResultSet 列索引。
boolean | first() 将光标移动到此 ResultSet 对象的第一行。
Array | getArray(int columnIndex) 以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Array | getArray(String columnLabel) 以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | getAsciiStream(int columnIndex) 以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | getAsciiStream(String columnLabel) 以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
BigDecimal | getBigDecimal(int columnIndex) 以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
BigDecimal | getBigDecimal(int columnIndex, int scale) 已过时。
BigDecimal | getBigDecimal(String columnLabel) 以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
BigDecimal | getBigDecimal(String columnLabel, int scale) 已过时。
InputStream | getBinaryStream(int columnIndex) 以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。
InputStream | getBinaryStream(String columnLabel) 以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。
Blob | getBlob(int columnIndex) 以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Blob | getBlob(String columnLabel) 以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
boolean | getBoolean(int columnIndex) 以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
boolean | getBoolean(String columnLabel) 以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
byte | getByte(int columnIndex) 以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
byte | getByte(String columnLabel) 以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
byte[] | getBytes(int columnIndex) 以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
byte[] | getBytes(String columnLabel) 以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | getCharacterStream(int columnIndex) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | getCharacterStream(String columnLabel) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Clob | getClob(int columnIndex) 以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Clob | getClob(String columnLabel) 以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
int | getConcurrency() 获取此 ResultSet 对象的并发模式。
String | getCursorName() 获取此 ResultSet 对象使用的 SQL 光标的名称。
Date | getDate(int columnIndex) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | getDate(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | getDate(String columnLabel) 以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | getDate(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
double | getDouble(int columnIndex) 以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
double | getDouble(String columnLabel) 以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
int | getFetchDirection() 获取此 ResultSet 对象的获取方向。
int | getFetchSize() 获取此 ResultSet 对象的获取大小。
float | getFloat(int columnIndex) 以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
float | getFloat(String columnLabel) 以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
int | getHoldability() 获取此 ResultSet 对象的可保存性
int | getInt(int columnIndex) 以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
int | getInt(String columnLabel) 以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
long | getLong(int columnIndex) 以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
long | getLong(String columnLabel) 以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
ResultSetMetaData | getMetaData() 获取此 ResultSet 对象的列的编号、类型和属性。
Reader | getNCharacterStream(int columnIndex) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Reader | getNCharacterStream(String columnLabel) 以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
NClob | getNClob(int columnIndex) 以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
NClob | getNClob(String columnLabel) 以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
String | getNString(int columnIndex) 以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
String | getNString(String columnLabel) 以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | getObject(int columnIndex) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | getObject(int columnIndex, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | getObject(String columnLabel) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | getObject(String columnLabel, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Ref | getRef(int columnIndex) 以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Ref | getRef(String columnLabel) 以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
int | getRow() 获取当前行编号。
RowId | getRowId(int columnIndex) 以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
RowId | getRowId(String columnLabel) 以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
short | getShort(int columnIndex) 以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
short | getShort(String columnLabel) 以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
SQLXML | getSQLXML(int columnIndex) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
SQLXML | getSQLXML(String columnLabel) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Statement | getStatement() 获取生成此 ResultSet 对象的 Statement 对象。
String | getString(int columnIndex) 以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
String | getString(String columnLabel) 以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | getTime(int columnIndex) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | getTime(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | getTime(String columnLabel) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | getTime(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | getTimestamp(int columnIndex) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | getTimestamp(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | getTimestamp(String columnLabel) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | getTimestamp(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
int | getType() 获取此 ResultSet 对象的类型。
InputStream | getUnicodeStream(int columnIndex) 已过时。 使用 getCharacterStream 取代 getUnicodeStream
InputStream | getUnicodeStream(String columnLabel) 已过时。 使用 getCharacterStream 代替
URL | getURL(int columnIndex) 以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
URL | getURL(String columnLabel) 以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
SQLWarning | getWarnings() 获取此 ResultSet 对象上的调用报告的第一个警告。
void | insertRow() 将插入行的内容插入到此 ResultSet 对象和数据库中。
boolean | isAfterLast() 获取光标是否位于此 ResultSet 对象的最后一行之后。
boolean | isBeforeFirst() 获取光标是否位于此 ResultSet 对象的第一行之前。
boolean | isClosed() 获取此 ResultSet 对象是否已关闭。
boolean | isFirst() 获取光标是否位于此 ResultSet 对象的第一行。
boolean | isLast() 获取光标是否位于此 ResultSet 对象的最后一行。
boolean | last() 将光标移动到此 ResultSet 对象的最后一行。
void | moveToCurrentRow() 将光标移动到记住的光标位置，通常为当前行。
void | moveToInsertRow() 将光标移动到插入行。
boolean | next() 将光标从当前位置向前移一行。
boolean | previous() 将光标移动到此 ResultSet 对象的上一行。
void | refreshRow() 用数据库中的最近值刷新当前行。
boolean | relative(int rows) 按相对行数（或正或负）移动光标。
boolean | rowDeleted() 获取是否已删除某行。
boolean | rowInserted() 获取当前行是否已有插入。
boolean | rowUpdated() 获取是否已更新当前行。
void | setFetchDirection(int direction) 设置此 ResultSet 对象中行的处理方向。
void | setFetchSize(int rows) 为 JDBC 驱动程序设置此 ResultSet 对象需要更多行时应该从数据库获取的行数。
void | updateArray(int columnIndex, Array x) 用 java.sql.Array 值更新指定列。
void | updateArray(String columnLabel, Array x) 用 java.sql.Array 值更新指定列。
void | updateAsciiStream(int columnIndex, InputStream x) 用 ascii 流值更新指定的列。
void | updateAsciiStream(int columnIndex, InputStream x, int length) 用 ascii 流值更新指定列，该列将具有指定字节数。
void | updateAsciiStream(int columnIndex, InputStream x, long length) 用 ascii 流值更新指定的列，该值将具有指定的字节数。
void | updateAsciiStream(String columnLabel, InputStream x) 用 ascii 流值更新指定列。
void | updateAsciiStream(String columnLabel, InputStream x, int length) 用 ascii 流值更新指定列，该列具有指定的字节数。
void | updateAsciiStream(String columnLabel, InputStream x, long length) 用 ascii 流值更新指定的列，该值将具有指定的字节数。
void | updateBigDecimal(int columnIndex, BigDecimal x) 用 java.math.BigDecimal 值更新指定列。
void | updateBigDecimal(String columnLabel, BigDecimal x) 用 java.sql.BigDecimal 值更新指定列。
void | updateBinaryStream(int columnIndex, InputStream x) 用二进制流值更新指定的列。
void | updateBinaryStream(int columnIndex, InputStream x, int length) 用二进制流值更新指定列，该列将具有指定字节数。
void | updateBinaryStream(int columnIndex, InputStream x, long length) 用二进制流值更新指定的列，该值将具有指定的字节数。
void | updateBinaryStream(String columnLabel, InputStream x) 用二进制流值更新指定列。
void | updateBinaryStream(String columnLabel, InputStream x, int length) 用二进制流值更新指定列，该列具有指定的字节数。
void | updateBinaryStream(String columnLabel, InputStream x, long length) 用二进制流值更新指定的列，该值将具有指定的字节数。
void | updateBlob(int columnIndex, Blob x) 用 java.sql.Blob 值更新指定列。
void | updateBlob(int columnIndex, InputStream inputStream) 使用给定输入流值更新指定列。
void | updateBlob(int columnIndex, InputStream inputStream, long length) 使用给定输入流更新指定的列，该流将具有指定的字节数。
void | updateBlob(String columnLabel, Blob x) 用 java.sql.Blob 值更新指定列。
void | updateBlob(String columnLabel, InputStream inputStream) 使用给定输入流值更新指定列。
void | updateBlob(String columnLabel, InputStream inputStream, long length) 使用给定输入流更新指定列，该流将具有指定的字节数。
void | updateBoolean(int columnIndex, boolean x) 用 boolean 值更新指定列。
void | updateBoolean(String columnLabel, boolean x) 用 boolean 值更新指定列。
void | updateByte(int columnIndex, byte x) 用 byte 值更新指定列。
void | updateByte(String columnLabel, byte x) 用 byte 值更新指定列。
void | updateBytes(int columnIndex, byte[] x) 用 byte 数组值更新指定列。
void | updateBytes(String columnLabel, byte[] x) 用字节数组值更新指定列。
void | updateCharacterStream(int columnIndex, Reader x) 用字符流值更新指定的列。
void | updateCharacterStream(int columnIndex, Reader x, int length) 用字符流值更新指定列，该列将具有指定字节数。
void | updateCharacterStream(int columnIndex, Reader x, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | updateCharacterStream(String columnLabel, Reader reader) 用字符流值更新指定列。
void | updateCharacterStream(String columnLabel, Reader reader, int length) 用字符流值更新指定列，该列具有指定的字节数。
void | updateCharacterStream(String columnLabel, Reader reader, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | updateClob(int columnIndex, Clob x) 用 java.sql.Clob 值更新指定列。
void | updateClob(int columnIndex, Reader reader) 使用给定的 Reader 对象更新指定列。
void | updateClob(int columnIndex, Reader reader, long length) 使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
void | updateClob(String columnLabel, Clob x) 用 java.sql.Clob 值更新指定列。
void | updateClob(String columnLabel, Reader reader) 使用给定的 Reader 对象更新指定列。
void | updateClob(String columnLabel, Reader reader, long length) 使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
void | updateDate(int columnIndex, Date x) 用 java.sql.Date 值更新指定列。
void | updateDate(String columnLabel, Date x) 用 java.sql.Date 值更新指定列。
void | updateDouble(int columnIndex, double x) 用 double 值更新指定列。
void | updateDouble(String columnLabel, double x) 用 double 值更新指定列。
void | updateFloat(int columnIndex, float x) 用 float 值更新指定列。
void | updateFloat(String columnLabel, float x) 用 float 值更新指定列。
void | updateInt(int columnIndex, int x) 用 int 值更新指定列。
void | updateInt(String columnLabel, int x) 用 int 值更新指定列。
void | updateLong(int columnIndex, long x) 用 long 值更新指定列。
void | updateLong(String columnLabel, long x) 用 long 值更新指定列。
void | updateNCharacterStream(int columnIndex, Reader x) 用字符流值更新指定的列。
void | updateNCharacterStream(int columnIndex, Reader x, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | updateNCharacterStream(String columnLabel, Reader reader) 用字符流值更新指定的列。
void | updateNCharacterStream(String columnLabel, Reader reader, long length) 用字符流值更新指定的列，该值将具有指定的字节数。
void | updateNClob(int columnIndex, NClob nClob) 用 java.sql.NClob 值更新指定的列。
void | updateNClob(int columnIndex, Reader reader) 使用给定的 Reader 对象更新指定列。
void | updateNClob(int columnIndex, Reader reader, long length) 使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
void | updateNClob(String columnLabel, NClob nClob) 用 java.sql.NClob 值更新指定的列。
void | updateNClob(String columnLabel, Reader reader) 使用给定的 Reader 对象更新指定列。
void | updateNClob(String columnLabel, Reader reader, long length) 使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
void | updateNString(int columnIndex, String nString) 用 String 值更新指定的列。
void | updateNString(String columnLabel, String nString) 用 String 值更新指定的列。
void | updateNull(int columnIndex) 用 null 值更新指定列。
void | updateNull(String columnLabel) 用 null 值更新指定列。
void | updateObject(int columnIndex, Object x) 用 Object 值更新指定列。
void | updateObject(int columnIndex, Object x, int scaleOrLength) 用 Object 值更新指定列。
void | updateObject(String columnLabel, Object x) 用 Object 值更新指定列。
void | updateObject(String columnLabel, Object x, int scaleOrLength) 用 Object 值更新指定列。
void | updateRef(int columnIndex, Ref x) 用 java.sql.Ref 值更新指定列。
void | updateRef(String columnLabel, Ref x) 用 java.sql.Ref 值更新指定列。
void | updateRow() 用此 ResultSet 对象的当前行的新内容更新底层数据库。
void | updateRowId(int columnIndex, RowId x) 用 RowId 值更新指定列。
void | updateRowId(String columnLabel, RowId x) 用 RowId 值更新指定的列。
void | updateShort(int columnIndex, short x) 用 short 值更新指定列。
void | updateShort(String columnLabel, short x) 用 short 值更新指定列。
void | updateSQLXML(int columnIndex, SQLXML xmlObject) 用 java.sql.SQLXML 值更新指定列。
void | updateSQLXML(String columnLabel, SQLXML xmlObject) 用 java.sql.SQLXML 值更新指定的列。
void | updateString(int columnIndex, String x) 用 String 值更新指定列。
void | updateString(String columnLabel, String x) 用 String 值更新指定列。
void | updateTime(int columnIndex, Time x) 用 java.sql.Time 值更新指定列。
void | updateTime(String columnLabel, Time x) 用 java.sql.Time 值更新指定列。
void | updateTimestamp(int columnIndex, Timestamp x) 用 java.sql.Timestamp 值更新指定列。
void | updateTimestamp(String columnLabel, Timestamp x) 用 java.sql.Timestamp 值更新指定列。
boolean | wasNull() 报告最后一个读取的列是否具有值 SQL NULL。
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

字段详细信息

FETCH_FORWARD

static final int FETCH_FORWARD
该常量指示将按正向（即从第一个到最后一个）处理结果集中的行。setFetchDirection 方法将此常量用作驱动程序的提示，驱动程序可能忽略它。

从以下版本开始：
1.2
另请参见：
常量字段值

FETCH_REVERSE

static final int FETCH_REVERSE
该常量指示将按逆向（即从最后一个到第一个）处理结果集中的行处理。setFetchDirection 方法将此常量用作驱动程序的提示，驱动程序可能忽略它。

从以下版本开始：
1.2
另请参见：
常量字段值

FETCH_UNKNOWN

static final int FETCH_UNKNOWN
该常量指示结果集中的行的处理顺序未知。setFetchDirection 方法将此常量用作驱动程序的提示，驱动程序可能忽略它。

另请参见：
常量字段值

TYPE_FORWARD_ONLY

static final int TYPE_FORWARD_ONLY
该常量指示光标只能向前移动的 ResultSet 对象的类型。

从以下版本开始：
1.2
另请参见：
常量字段值

TYPE_SCROLL_INSENSITIVE

static final int TYPE_SCROLL_INSENSITIVE
该常量指示可滚动但通常不受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。

从以下版本开始：
1.2
另请参见：
常量字段值

TYPE_SCROLL_SENSITIVE

static final int TYPE_SCROLL_SENSITIVE
该常量指示可滚动并且通常受 ResultSet 底层数据更改影响的 ResultSet 对象的类型。

从以下版本开始：
1.2
另请参见：
常量字段值

CONCUR_READ_ONLY

static final int CONCUR_READ_ONLY
该常量指示不可以更新的 ResultSet 对象的并发模式。

从以下版本开始：
1.2
另请参见：
常量字段值

CONCUR_UPDATABLE

static final int CONCUR_UPDATABLE
该常量指示可以更新的 ResultSet 对象的并发模式。

从以下版本开始：
1.2
另请参见：
常量字段值

HOLD_CURSORS_OVER_COMMIT

static final int HOLD_CURSORS_OVER_COMMIT
该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将保持开放。

从以下版本开始：
1.4
另请参见：
常量字段值

CLOSE_CURSORS_AT_COMMIT

static final int CLOSE_CURSORS_AT_COMMIT
该常量指示提交当前事务时，具有此可保存性的打开的 ResultSet 对象将被关闭。

从以下版本开始：
1.4
另请参见：
常量字段值
方法详细信息

next

boolean next()
             throws SQLException
将光标从当前位置向前移一行。ResultSet 光标最初位于第一行之前；第一次调用 next 方法使第一行成为当前行；第二次调用使第二行成为当前行，依此类推。

当调用 next 方法返回 false 时，光标位于最后一行的后面。任何要求当前行的 ResultSet 方法调用将导致抛出 SQLException。如果结果集的类型是 TYPE_FORWARD_ONLY，则其 JDBC 驱动程序实现对后续 next 调用是返回 false 还是抛出 SQLException 将由供应商指定。

如果对当前行开启了输入流，则调用 next 方法将隐式关闭它。读取新行时，将清除 ResultSet 对象的警告链。

返回：
如果新的当前行有效，则返回 true；如果不存在下一行，则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法

close

void close()
           throws SQLException
立即释放此 ResultSet 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。

关闭 ResultSet 对象不会关闭 ResultSet 创建的 Blob、Clob 或 NClob 对象。Blob、Clob 或 NClob 对象至少在创建它们的事务期间持续有效，除非调用了其 free 方法。

当关闭 ResultSet 时，所有通过调用 getMetaData 方法创建的 ResultSetMetaData 实例都可以访问。

注：当生成 ResultSet 对象的 Statement 对象关闭、重新执行或用来从多个结果的序列获取下一个结果时，该 Statement 对象将自动关闭 ResultSet 对象。

在已关闭的 ResultSet 对象上调用 close 方法是无操作 (no-op)。

抛出：
SQLException - 如果发生数据库访问错误

wasNull

boolean wasNull()
                throws SQLException
报告最后一个读取的列是否具有值 SQL NULL。注意，必须首先对列调用一个获取方法尝试读取其值，然后调用 wasNull 方法查看读取的值是否为 SQL NULL。

返回：
如果最后一个读取的列值为 SQL NULL，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法

getString

String getString(int columnIndex)
                 throws SQLException
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getBoolean

boolean getBoolean(int columnIndex)
                   throws SQLException
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。

如果指定列的数据类型为 CHAR 或 VARCHAR 且包含 "0"，或者数据类型为 BIT、TINYINT、SMALLINT、INTEGER 或 BIGINT 且包含 0，则返回 false 值。如果指定列的数据类型为 CHAR 或 VARCHAR 且包含 "1"，或者数据类型为 BIT、TINYINT、SMALLINT、INTEGER 或 BIGINT 且包含 1，则返回 true 值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 false
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getByte

byte getByte(int columnIndex)
             throws SQLException
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getShort

short getShort(int columnIndex)
               throws SQLException
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getInt

int getInt(int columnIndex)
           throws SQLException
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getLong

long getLong(int columnIndex)
             throws SQLException
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getFloat

float getFloat(int columnIndex)
               throws SQLException
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getDouble

double getDouble(int columnIndex)
                 throws SQLException
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getBigDecimal

BigDecimal getBigDecimal(int columnIndex,
                         int scale)
                         throws SQLException
已过时。

以 Java 编程语言中 java.sql.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
scale - 小数点右边的位数
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

getBytes

byte[] getBytes(int columnIndex)
                throws SQLException
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。这些字节表示驱动程序返回的原始值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getDate

Date getDate(int columnIndex)
             throws SQLException
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getTime

Time getTime(int columnIndex)
             throws SQLException
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getTimestamp

Timestamp getTimestamp(int columnIndex)
                       throws SQLException
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getAsciiStream

InputStream getAsciiStream(int columnIndex)
                           throws SQLException
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。然后，可以按块从流中读取值。此方法尤其适合于获取很大的 LONGVARCHAR 值。JDBC 驱动程序将执行从数据库格式到 ASCII 的任何必要转换。

注：在获取任何其他列的值之前必须读取返回流中的所有数据。下一次调用获取方法将隐式关闭该流。此外，当调用 InputStream.available 方法时，不管是否存在可用数据，流都可能返回 0。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
以一字节 ASCII 字符流的形式返回传递数据库列值的 Java 输入流；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getUnicodeStream

InputStream getUnicodeStream(int columnIndex)
                             throws SQLException
已过时。 使用 getCharacterStream 取代 getUnicodeStream

以两字节 3 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。第一个字节是高字节；第二个字节是低字节。然后，可以按块从流中读取值。此方法尤其适合于获取很大的 LONGVARCHAR 值。JDBC 驱动程序将执行从数据库格式到 Unicode 的任何必要转换。

注：在获取任何其他列的值之前必须读取返回流中的所有数据。下一次调用获取方法将隐式关闭该流。此外，当调用 InputStream.available 方法时，不管是否存在可用数据，流都可能返回 0。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
以两字节 Unicode 字符流的形式返回传递数据库列值的 Java 输入流；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

getBinaryStream

InputStream getBinaryStream(int columnIndex)
                            throws SQLException
以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。然后，可以按块从流中读取值。此方法尤其适合于获取很大的 LONGVARBINARY 值。

注：在获取任何其他列的值之前必须读取返回流中的所有数据。下一次调用获取方法将隐式关闭该流。此外，当调用 InputStream.available 方法时，不管是否存在可用数据，流都可能返回 0。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
以未解释字节的流的形式返回传递数据库列值的 Java 输入流；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getString

String getString(String columnLabel)
                 throws SQLException
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getBoolean

boolean getBoolean(String columnLabel)
                   throws SQLException
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。

如果指定列的数据类型为 CHAR 或 VARCHAR 且包含 "0"，或者数据类型为 BIT、TINYINT、SMALLINT、INTEGER 或 BIGINT 且包含 0，则返回 false 值。如果指定列的数据类型为 CHAR 或 VARCHAR 且包含 "1"，或者数据类型为 BIT、TINYINT、SMALLINT、INTEGER 或 BIGINT 且包含 1，则返回 true 值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 false
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getByte

byte getByte(String columnLabel)
             throws SQLException
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getShort

short getShort(String columnLabel)
               throws SQLException
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getInt

int getInt(String columnLabel)
           throws SQLException
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getLong

long getLong(String columnLabel)
             throws SQLException
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getFloat

float getFloat(String columnLabel)
               throws SQLException
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getDouble

double getDouble(String columnLabel)
                 throws SQLException
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 0
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getBigDecimal

BigDecimal getBigDecimal(String columnLabel,
                         int scale)
                         throws SQLException
已过时。

以 Java 编程语言中 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
scale - 小数点右边的位数
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

getBytes

byte[] getBytes(String columnLabel)
                throws SQLException
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。这些字节表示驱动程序返回的原始值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getDate

Date getDate(String columnLabel)
             throws SQLException
以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getTime

Time getTime(String columnLabel)
             throws SQLException
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getTimestamp

Timestamp getTimestamp(String columnLabel)
                       throws SQLException
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getAsciiStream

InputStream getAsciiStream(String columnLabel)
                           throws SQLException
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。然后，可以按块从流中读取值。此方法尤其适合于获取很大的 LONGVARCHAR 值。JDBC 驱动程序将执行从数据库格式到 ASCII 的任何必要转换。

注：在获取任何其他列的值之前必须读取返回流中的所有数据。下一次调用获取方法将隐式关闭该流。此外，当调用 available 方法时，不管是否存在可用数据，流都可能返回 0。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
以一字节 ASCII 字符流的形式返回传递数据库列值的 Java 输入流。如果值为 SQL NULL，则返回值为 null。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getUnicodeStream

InputStream getUnicodeStream(String columnLabel)
                             throws SQLException
已过时。 使用 getCharacterStream 代替

以两字节 Unicode 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。第一个字节是高字节；第二个字节是低字节。然后，可以按块从流中读取值。此方法尤其适合于获取很大的 LONGVARCHAR 值。采用 JDBC 技术的驱动程序将执行从数据库格式到 Unicode 的任何必要转换。

注：在获取任何其他列的值之前必须读取返回流中的所有数据。下一次调用获取方法将隐式关闭该流。此外，当调用 InputStream.available 方法时，不管是否存在可用数据，流都可能返回 0。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
以两字节 Unicode 字符流的形式返回传递数据库列值的 Java 输入流。如果值为 SQL NULL，则返回值为 null。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

getBinaryStream

InputStream getBinaryStream(String columnLabel)
                            throws SQLException
以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。然后，可以按块从流中读取该值。此方法尤其适合于获取很大的 LONGVARBINARY 值。

注：在获取任何其他列的值之前必须读取返回流中的所有数据。下一次调用获取方法将隐式关闭该流。此外，当调用 available 方法时，不管是否存在可用数据，流都可能返回 0。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
以未解释字节流的形式返回传递数据库列值的 Java 输入流；如果值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getWarnings

SQLWarning getWarnings()
                       throws SQLException
获取此 ResultSet 对象上的调用报告的第一个警告。此 ResultSet 对象上的后续警告会被链接到此方法返回的 SQLWarning 对象。

每次读取新行时，都会自动清除警告链。不可以在已经关闭的 ResultSet 对象上调用此方法；这样做将导致抛出 SQLException。

注：此警告链仅包含 ResultSet 方法产生的警告。Statement 方法（如读取 OUT 参数）产生的任何警告都将链接在 Statement 对象上。

返回：
报告的第一个 SQLWarning 对象；如果不存在，则返回 null
抛出：
SQLException - 如果发生数据库访问错误或在关闭的结果集上调用此方法

clearWarnings

void clearWarnings()
                   throws SQLException
清除在此 ResultSet 对象上报告的所有警告。调用此方法后，在为此 ResultSet 对象报告新的警告之前，getWarnings 方法将返回 null。

抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法

getCursorName

String getCursorName()
                     throws SQLException
获取此 ResultSet 对象使用的 SQL 光标的名称。

在 SQL 中，通过指定的光标获取结果表。通过一个引用光标名称来定位的更新/删除语句，可以更新或删除结果集的当前行。为了确保光标具有支持更新的适当隔离级别，光标的 SELECT 语句的形式应该为 SELECT FOR UPDATE。如果省略 FOR UPDATE，则定位更新可能失败。

JDBC API 通过提供 ResultSet 对象使用的 SQL 光标的名称支持此 SQL 功能。ResultSet 对象的当前行也是此 SQL 光标的当前行。

返回：
此 ResultSet 对象的光标的 SQL 名称
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

getMetaData

ResultSetMetaData getMetaData()
                              throws SQLException
获取此 ResultSet 对象的列的编号、类型和属性。

返回：
此 ResultSet 对象的列的描述
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法

getObject

Object getObject(int columnIndex)
                 throws SQLException

以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

此方法将以 Java 对象的形式返回给定列的值。Java 对象的类型将为与该列的 SQL 类型相对应的默认 Java 对象类型，它遵守在 JDBC 规范中指定的内置类型的映射关系。如果值为 SQL NULL，则驱动程序返回一个 Java null。

此方法还可用于读取特定于数据库的抽象数据类型。在 JDBC 2.0 API 中，可以扩展 getObject 方法的行为来实现 SQL 自定义类型的数据。

如果 Connection.getTypeMap 不抛出 SQLFeatureNotSupportedException，则当列包含结构值或独特值时，此方法的行为类似于调用：getObject(columnIndex, this.getStatement().getConnection().getTypeMap())。 如果 Connection.getTypeMap 抛出 SQLFeatureNotSupportedException，则结构值不受支持，独特值映射到 DISTINCT 类型的底层 SQL 类型确定的默认 Java 类。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
保存列值的 java.lang.Object
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

getObject

Object getObject(String columnLabel)
                 throws SQLException

以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。

此方法将以 Java 对象的形式返回给定列的值。Java 对象的类型将为与该列的 SQL 类型相对应的默认 Java 对象类型，它遵守在 JDBC 规范中指定的内置类型的映射关系。如果值为 SQL NULL，则驱动程序返回一个 Java null。

此方法还可用于读取特定于数据库的抽象数据类型。

在 JDBC 2.0 API 中，可以扩展 getObject 方法的行为来实现 SQL 自定义类型的数据。当列包含结构化的或独特的值时，此方法的行为类似于调用：getObject(columnIndex, this.getStatement().getConnection().getTypeMap())。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
保存列值的 java.lang.Object
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法

findColumn

int findColumn(String columnLabel)
               throws SQLException
将给定的 ResultSet 列标签映射到其 ResultSet 列索引。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
给定列名称的列索引
抛出：
SQLException - 如果 ResultSet 对象不包含标记为 columnLabel 的列，发生数据库访问错误或在已关闭的结果集上调用此方法

getCharacterStream

Reader getCharacterStream(int columnIndex)
                          throws SQLException
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
包含列值的 java.io.Reader 对象；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getCharacterStream

Reader getCharacterStream(String columnLabel)
                          throws SQLException
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
包含列值的 java.io.Reader 对象；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getBigDecimal

BigDecimal getBigDecimal(int columnIndex)
                         throws SQLException
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值（全精度）；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getBigDecimal

BigDecimal getBigDecimal(String columnLabel)
                         throws SQLException
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值（全精度）；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

isBeforeFirst

boolean isBeforeFirst()
                      throws SQLException
获取光标是否位于此 ResultSet 对象的第一行之前。

注：对于带有 TYPE_FORWARD_ONLY 的结果集类型的 ResultSet，对 isBeforeFirst 方法的支持是可选的

返回：
如果光标位于第一行之前，则返回 true；如果光标位于任何其他位置或者结果集不包含任何行，则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

isAfterLast

boolean isAfterLast()
                    throws SQLException
获取光标是否位于此 ResultSet 对象的最后一行之后。

注：对于带有 TYPE_FORWARD_ONLY 的结果集类型的 ResultSet，对 isAfterLast 方法的支持是可选的

返回：
如果光标位于最后一行之后，则返回 true；如果光标位于任何其他位置或者结果集不包含任何行，则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

isFirst

boolean isFirst()
                throws SQLException
获取光标是否位于此 ResultSet 对象的第一行。

注：对于带有 TYPE_FORWARD_ONLY 的结果集类型的 ResultSet，对 isFirst 方法的支持是可选的

返回：
如果光标位于第一行，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

isLast

boolean isLast()
               throws SQLException
获取光标是否位于此 ResultSet 对象的最后一行。注：调用 isLast 方法可能开销很大，因为 JDBC 驱动程序可能需要再往后获取一行，以确定当前行是否为结果集中的最后一行。

注：对于带有 TYPE_FORWARD_ONLY 的结果集类型的 ResultSet，对 isLast 方法的支持是可选的

返回：
如果光标位于最后一行上，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

beforeFirst

void beforeFirst()
                 throws SQLException
将光标移动到此 ResultSet 对象的开头，正好位于第一行之前。如果结果集中不包含任何行，则此方法无效。

抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

afterLast

void afterLast()
               throws SQLException
将光标移动到此 ResultSet 对象的末尾，正好位于最后一行之后。如果结果集中不包含任何行，则此方法无效。

抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

first

boolean first()
              throws SQLException
将光标移动到此 ResultSet 对象的第一行。

返回：
如果光标位于有效行，则返回 true；如果结果集中不存在任何行，则返回 false
抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

last

boolean last()
             throws SQLException
将光标移动到此 ResultSet 对象的最后一行。

返回：
如果光标位于有效行，则返回 true；如果结果集中不存在任何行，则返回 false
抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getRow

int getRow()
           throws SQLException
获取当前行编号。第一行为 1 号，第二行为 2 号，依此类推。

注：对于带有 TYPE_FORWARD_ONLY 的结果集类型的 ResultSet，对 getRow 方法的支持是可选的

返回：
当前行的编号；如果不存在当前行，则返回 0
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

absolute

boolean absolute(int row)
                 throws SQLException
将光标移动到此 ResultSet 对象的给定行编号。

如果行编号为正，则将光标移动到相对于结果集开头的给定行编号。第一行为行 1，第二行为行 2，依此类推。

如果给定行编号为负，则将光标移动到相对于结果集末尾的绝对行位置。例如，调用方法 absolute(-1) 将光标置于最后一行；调用方法 absolute(-2) 将光标移动到倒数第二行，依此类推。

试图将光标置于结果集的第一行/最后一行之外将导致光标位于第一行之前或最后一行之后。

注：调用 absolute(1) 等效于调用 first()。调用 absolute(-1) 等效于调用 last()。

参数：
row - 光标应该移动到的行的编号。正的编号指示从结果集开头开始计数的行编号；负的编号指示从结果集末尾开始计数的行编号
返回：
如果光标移动到此 ResultSet 对象的位置处，则返回 true；如果光标在第一行的前面或最后一行的后面，则返回 false
抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

relative

boolean relative(int rows)
                 throws SQLException
按相对行数（或正或负）移动光标。试图移动到结果集的第一行/最后一行之外，会将光标置于第一行之前或最后一行之后。调用 relative(0) 有效，但是不更改光标位置。

注：调用方法 relative(1) 等效于调用方法 next()，而调用方法 relative(-1) 等效于调用方法 previous()。

参数：
rows - 指定从当前行开始移动的行数的 int；正数表示光标向前移动；负数表示光标向后移动
返回：
如果光标位于行上，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

previous

boolean previous()
                 throws SQLException
将光标移动到此 ResultSet 对象的上一行。

当调用 previous 方法返回 false 时，光标位于第一行之前。要求当前行的任何 ResultSet 方法的调用将导致抛出 SQLException。

如果开启了对当前行的输入流，则调用 previous 方法将隐式关闭它。读取新的一行时清除 ResultSet 对象的警告更改。

返回：
如果光标现在位于有效行上，则返回 true；如果光标位于第一行的前面，则返回 false
抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

setFetchDirection

void setFetchDirection(int direction)
                       throws SQLException
设置此 ResultSet 对象中行的处理方向。初始值由生成此 ResultSet 对象的 Statement 对象确定。获取方向可以在任何时间更改。

参数：
direction - 指定建议获取方向的 int；ResultSet.FETCH_FORWARD、ResultSet.FETCH_REVERSE 或 ResultSet.FETCH_UNKNOWN 之一
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的结果集上调用此方法或结果集类型为 TYPE_FORWARD_ONLY 但获取方向不是 FETCH_FORWARD
从以下版本开始：
1.2
另请参见：
Statement.setFetchDirection(int), getFetchDirection()

getFetchDirection

int getFetchDirection()
                      throws SQLException
获取此 ResultSet 对象的获取方向。

返回：
此 ResultSet 对象的当前获取方向
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2
另请参见：
setFetchDirection(int)

setFetchSize

void setFetchSize(int rows)
                  throws SQLException
为 JDBC 驱动程序设置此 ResultSet 对象需要更多行时应该从数据库获取的行数。如果指定的获取大小为零，则 JDBC 驱动程序忽略该值，随意对获取大小作出它自己的最佳猜测。默认值由创建结果集的 Statement 对象设置。获取大小可以在任何时间更改。

参数：
rows - 要获取的行数
抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或不满足条件 rows >= 0
从以下版本开始：
1.2
另请参见：
getFetchSize()

getFetchSize

int getFetchSize()
                 throws SQLException
获取此 ResultSet 对象的获取大小。

返回：
此 ResultSet 对象的当前获取大小
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2
另请参见：
setFetchSize(int)

getType

int getType()
            throws SQLException
获取此 ResultSet 对象的类型。类型由创建结果集的 Statement 对象确定。

返回：
ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getConcurrency

int getConcurrency()
                   throws SQLException
获取此 ResultSet 对象的并发模式。使用的并发由创建结果集的 Statement 对象确定。

返回：
并发类型，ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

rowUpdated

boolean rowUpdated()
                   throws SQLException
获取是否已更新当前行。返回值取决于结果集是否可以检测到更新。

注：对于 CONCUR_READ_ONLY 的结果集并发性，对 rowUpdated 方法的支持是可选的

返回：
如果所有者和其他人检测到当前行已进行可见更新，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
DatabaseMetaData.updatesAreDetected(int)

rowInserted

boolean rowInserted()
                    throws SQLException
获取当前行是否已有插入。返回值取决于此 ResultSet 对象是否可以检测到可见插入。

注：对于 CONCUR_READ_ONLY 的结果集并发性，对 rowUpdated 方法的支持是可选的

返回：
如果当前检测到已插入，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
DatabaseMetaData.insertsAreDetected(int)

rowDeleted

boolean rowDeleted()
                   throws SQLException
获取是否已删除某行。删除的行可能在结果集中留下一个可见的“洞”。此方法可用于检测结果集中的洞。返回值取决于此 ResultSet 对象是否可以检测到删除。

注：对于 CONCUR_READ_ONLY 的结果集并发性，对 rowDeleted 方法的支持是可选的

返回：
如果所有者或其他人检测到当前行已删除，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
另请参见：
DatabaseMetaData.deletesAreDetected(int)

updateNull

void updateNull(int columnIndex)
                throws SQLException
用 null 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBoolean

void updateBoolean(int columnIndex,
                   boolean x)
                   throws SQLException
用 boolean 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateByte

void updateByte(int columnIndex,
                byte x)
                throws SQLException
用 byte 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateShort

void updateShort(int columnIndex,
                 short x)
                 throws SQLException
用 short 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateInt

void updateInt(int columnIndex,
               int x)
               throws SQLException
用 int 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateLong

void updateLong(int columnIndex,
                long x)
                throws SQLException
用 long 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateFloat

void updateFloat(int columnIndex,
                 float x)
                 throws SQLException
用 float 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateDouble

void updateDouble(int columnIndex,
                  double x)
                  throws SQLException
用 double 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBigDecimal

void updateBigDecimal(int columnIndex,
                      BigDecimal x)
                      throws SQLException
用 java.math.BigDecimal 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateString

void updateString(int columnIndex,
                  String x)
                  throws SQLException
用 String 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBytes

void updateBytes(int columnIndex,
                 byte[] x)
                 throws SQLException
用 byte 数组值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateDate

void updateDate(int columnIndex,
                Date x)
                throws SQLException
用 java.sql.Date 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateTime

void updateTime(int columnIndex,
                Time x)
                throws SQLException
用 java.sql.Time 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateTimestamp

void updateTimestamp(int columnIndex,
                     Timestamp x)
                     throws SQLException
用 java.sql.Timestamp 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateAsciiStream

void updateAsciiStream(int columnIndex,
                       InputStream x,
                       int length)
                       throws SQLException
用 ascii 流值更新指定列，该列将具有指定字节数。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
length - 流的长度
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBinaryStream

void updateBinaryStream(int columnIndex,
                        InputStream x,
                        int length)
                        throws SQLException
用二进制流值更新指定列，该列将具有指定字节数。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
length - 流的长度
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateCharacterStream

void updateCharacterStream(int columnIndex,
                           Reader x,
                           int length)
                           throws SQLException
用字符流值更新指定列，该列将具有指定字节数。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
length - 流的长度
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateObject

void updateObject(int columnIndex,
                  Object x,
                  int scaleOrLength)
                  throws SQLException
用 Object 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

如果第二个参数是 InputStream，则该流必须包含 scaleOrLength 指定的字节数。如果第二个参数是 Reader，则它必须包含 scaleOrLength 指定的字符数。如果这些条件不为真，则执行该语句时驱动程序将生成一个 SQLException。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
scaleOrLength - 对于 java.math.BigDecimal 对象，此参数是小数点后的位数。对于 Java 对象类型 InputStream 和 Reader，此参数是该流或 reader 中数据的长度。对于其他所有类型，将忽略此值。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateObject

void updateObject(int columnIndex,
                  Object x)
                  throws SQLException
用 Object 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateNull

void updateNull(String columnLabel)
                throws SQLException
用 null 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBoolean

void updateBoolean(String columnLabel,
                   boolean x)
                   throws SQLException
用 boolean 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateByte

void updateByte(String columnLabel,
                byte x)
                throws SQLException
用 byte 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateShort

void updateShort(String columnLabel,
                 short x)
                 throws SQLException
用 short 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateInt

void updateInt(String columnLabel,
               int x)
               throws SQLException
用 int 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateLong

void updateLong(String columnLabel,
                long x)
                throws SQLException
用 long 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateFloat

void updateFloat(String columnLabel,
                 float x)
                 throws SQLException
用 float 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateDouble

void updateDouble(String columnLabel,
                  double x)
                  throws SQLException
用 double 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBigDecimal

void updateBigDecimal(String columnLabel,
                      BigDecimal x)
                      throws SQLException
用 java.sql.BigDecimal 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateString

void updateString(String columnLabel,
                  String x)
                  throws SQLException
用 String 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBytes

void updateBytes(String columnLabel,
                 byte[] x)
                 throws SQLException
用字节数组值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateDate

void updateDate(String columnLabel,
                Date x)
                throws SQLException
用 java.sql.Date 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateTime

void updateTime(String columnLabel,
                Time x)
                throws SQLException
用 java.sql.Time 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateTimestamp

void updateTimestamp(String columnLabel,
                     Timestamp x)
                     throws SQLException
用 java.sql.Timestamp 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateAsciiStream

void updateAsciiStream(String columnLabel,
                       InputStream x,
                       int length)
                       throws SQLException
用 ascii 流值更新指定列，该列具有指定的字节数。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
length - 流的长度
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateBinaryStream

void updateBinaryStream(String columnLabel,
                        InputStream x,
                        int length)
                        throws SQLException
用二进制流值更新指定列，该列具有指定的字节数。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
length - 流的长度
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateCharacterStream

void updateCharacterStream(String columnLabel,
                           Reader reader,
                           int length)
                           throws SQLException
用字符流值更新指定列，该列具有指定的字节数。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含新列值的 java.io.Reader 对象
length - 流的长度
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateObject

void updateObject(String columnLabel,
                  Object x,
                  int scaleOrLength)
                  throws SQLException
用 Object 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

如果第二个参数是 InputStream，则该流必须包含 scaleOrLength 指定的字节数。如果第二个参数是 Reader，则它必须包含 scaleOrLength 指定的字符数。如果这些条件不为真，则执行该语句时驱动程序将生成一个 SQLException。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
scaleOrLength - 对于 java.math.BigDecimal 对象，此参数是小数点后的位数。对于 Java 对象类型 InputStream 和 Reader，此参数是该流或 reader 中数据的长度。 对于其他所有类型，将忽略此值。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateObject

void updateObject(String columnLabel,
                  Object x)
                  throws SQLException
用 Object 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

insertRow

void insertRow()
               throws SQLException
将插入行的内容插入到此 ResultSet 对象和数据库中。调用此方法时，光标必须位于插入行上。

抛出：
SQLException - 如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法；如果在光标不位于插入行上时调用此方法，或者插入行中所有不可为 null 的列中还存在未分配非 null 值的列
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

updateRow

void updateRow()
               throws SQLException
用此 ResultSet 对象的当前行的新内容更新底层数据库。光标不位于插入行上时不能调用此方法。

抛出：
SQLException - 如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY；在已关闭的结果集上调用此方法，或者在光标不位于插入行上时调用了此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

deleteRow

void deleteRow()
               throws SQLException
从此 ResultSet 对象和底层数据库中删除当前行。光标不位于插入行上时不能调用此方法。

抛出：
SQLException - 如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY；在已关闭的结果集上调用此方法，或者在光标不位于插入行上时调用了此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

refreshRow

void refreshRow()
                throws SQLException
用数据库中的最近值刷新当前行。光标不位于插入行上时不能调用此方法。

refreshRow 方法提供一种让应用程序显式告知 JDBC 驱动程序从数据库重新获取行的方式。应用程序可能需要在 JDBC 驱动程序完成缓存或预获取操作后调用 refreshRow，以便从数据库获取行的最新值。如果获取大小大于 1，则 JDBC 驱动程序可以一次实际刷新多行。

应根据事务隔离级别和光标敏感度确定是否重新获取所有值。如果在调用更新方法之后，但在调用 updateRow 方法之前调用 refreshRow，则会丢失对行所作的更新。频繁调用方法 refreshRow 可能导致性能下降。

抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法；结果集类型为 TYPE_FORWARD_ONLY，或者在光标不位于插入行上时调用了此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法，或者对于指定的结果集类型和结果集并发性此方法不受支持。
从以下版本开始：
1.2

cancelRowUpdates

void cancelRowUpdates()
                      throws SQLException
取消对 ResultSet 对象中的当前行所作的更新。此方法在调用更新方法之后，但在调用 updateRow 方法之前调用才可以回滚对行所作的更新。如果没有进行任何更新或者已经调用 updateRow 方法，则此方法无效。

抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法；结果集并发性为 CONCUR_READ_ONLY，或者在光标不位于插入行上时调用了此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

moveToInsertRow

void moveToInsertRow()
                     throws SQLException
将光标移动到插入行。将光标置于插入行上时，当前的光标位置会被记住。插入行是一个与可更新结果集相关联的特殊行。它实际上是一个缓冲区，在将行插入到结果集前可以通过调用更新方法在其中构造新行。当光标位于插入行上时，仅能调用更新方法、获取方法以及 insertRow 方法。每次在调用 insertRow 之前调用此方法时，必须为结果集中的所有列分配值。在对列值调用获取方法之前，必须调用更新方法。

抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

moveToCurrentRow

void moveToCurrentRow()
                      throws SQLException
将光标移动到记住的光标位置，通常为当前行。如果光标不位于插入行上，则此方法无效。

抛出：
SQLException - 如果发生数据库访问错误；在已关闭的结果集上调用此方法或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getStatement

Statement getStatement()
                       throws SQLException
获取生成此 ResultSet 对象的 Statement 对象。如果结果集是以其他方式生成的（如通过 DatabaseMetaData 方法），则此方法可能返回 null。

返回：
生成此 ResultSet 对象的 Statment 对象；如果结果集是以其他方法生成的，则返回 null
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getObject

Object getObject(int columnIndex,
                 Map<String,Class<?>> map)
                 throws SQLException
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。如果值为 SQL NULL，则驱动程序返回一个 Java null。此方法使用给定的 Map 对象作为正在获取的 SQL 结构化或独特类型的自定义映射关系。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
map - 一个 java.util.Map 对象，包含从 SQL 类型名称到 Java 编程语言中类的映射关系
返回：
表示 SQL 值的 Java 编程语言中的 Object
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getRef

Ref getRef(int columnIndex)
           throws SQLException
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
表示 SQL REF 值的 Ref 对象
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getBlob

Blob getBlob(int columnIndex)
             throws SQLException
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
表示指定列中的 SQL BLOB 值的 BLOB 对象
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getClob

Clob getClob(int columnIndex)
             throws SQLException
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
表示指定列中的 SQL Clob 值的 Clob 对象
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getArray

Array getArray(int columnIndex)
               throws SQLException
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
表示指定列中的 SQL Array 值的 Array 对象
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getObject

Object getObject(String columnLabel,
                 Map<String,Class<?>> map)
                 throws SQLException
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。如果值为 SQL NULL，则驱动程序返回一个 Java null。此方法使用指定的 Map 对象自定义映射关系（如果合适）。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
map - 包含从 SQL 类型名称到 Java 编程语言中类的映射关系的 java.util.Map 对象
返回：
表示指定列中的 SQL 值的 Object
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getRef

Ref getRef(String columnLabel)
           throws SQLException
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
表示指定列中 SQL Ref 值的 Ref 对象
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getBlob

Blob getBlob(String columnLabel)
             throws SQLException
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
表示指定列中 SQL Blob 值的 Blob 对象
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getClob

Clob getClob(String columnLabel)
             throws SQLException
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
表示指定列中 SQL CLOB 值的 Clob 对象
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getArray

Array getArray(String columnLabel)
               throws SQLException
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
表示指定列中 SQL ARRAY 值的 ARRAY 对象
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getDate

Date getDate(int columnIndex,
             Calendar cal)
             throws SQLException
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。如果底层数据库未存储时区信息，则此方法使用给定日历构造日期的适当毫秒值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
cal - 在构造日期时使用的 java.util.Calendar 对象
返回：
java.sql.Date 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getDate

Date getDate(String columnLabel,
             Calendar cal)
             throws SQLException
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。如果底层数据库未存储时区信息，则此方法使用给定日历构造日期的适当毫秒值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
cal - 在构造日期时使用的 java.util.Calendar 对象
返回：
java.sql.Date 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getTime

Time getTime(int columnIndex,
             Calendar cal)
             throws SQLException
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。如果底层数据库未存储时区信息，则此方法使用给定日历构造时间的适当毫秒值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
cal - 在构造时间时使用的 java.util.Calendar 对象
返回：
java.sql.Time 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getTime

Time getTime(String columnLabel,
             Calendar cal)
             throws SQLException
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。如果底层数据库未存储时区信息，则此方法使用给定日历构造时间的适当毫秒值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
cal - 在构造时间时使用的 java.util.Calendar 对象
返回：
java.sql.Time 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getTimestamp

Timestamp getTimestamp(int columnIndex,
                       Calendar cal)
                       throws SQLException
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。如果底层数据库未存储时区信息，则此方法使用给定日历构造时间戳的适当毫秒值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
cal - 在构造时间戳时使用的 java.util.Calendar 对象
返回：
java.sql.Timestamp 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getTimestamp

Timestamp getTimestamp(String columnLabel,
                       Calendar cal)
                       throws SQLException
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。如果底层数据库未存储时区信息，则此方法使用给定日历构造时间戳的适当毫秒值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
cal - 在构造日期时使用的 java.util.Calendar 对象
返回：
java.sql.Timestamp 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.2

getURL

URL getURL(int columnIndex)
           throws SQLException
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 索引，其中第一个列是 1、第二个列是 2，……
返回：
java.net.URL 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法或 URL 是错误的
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getURL

URL getURL(String columnLabel)
           throws SQLException
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
java.net.URL 对象形式的列值；如果值为 SQL NULL，则返回值为 Java 编程语言中的 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法，或者 URL 是错误的
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateRef

void updateRef(int columnIndex,
               Ref x)
               throws SQLException
用 java.sql.Ref 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateRef

void updateRef(String columnLabel,
               Ref x)
               throws SQLException
用 java.sql.Ref 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateBlob

void updateBlob(int columnIndex,
                Blob x)
                throws SQLException
用 java.sql.Blob 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateBlob

void updateBlob(String columnLabel,
                Blob x)
                throws SQLException
用 java.sql.Blob 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateClob

void updateClob(int columnIndex,
                Clob x)
                throws SQLException
用 java.sql.Clob 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateClob

void updateClob(String columnLabel,
                Clob x)
                throws SQLException
用 java.sql.Clob 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateArray

void updateArray(int columnIndex,
                 Array x)
                 throws SQLException
用 java.sql.Array 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

updateArray

void updateArray(String columnLabel,
                 Array x)
                 throws SQLException
用 java.sql.Array 值更新指定列。更新方法用于更新当前行或插入行中的列值，并不会更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getRowId

RowId getRowId(int columnIndex)
               throws SQLException
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果该值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getRowId

RowId getRowId(String columnLabel)
               throws SQLException
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果该值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateRowId

void updateRowId(int columnIndex,
                 RowId x)
                 throws SQLException
用 RowId 值更新指定列。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateRowId

void updateRowId(String columnLabel,
                 RowId x)
                 throws SQLException
用 RowId 值更新指定的列。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getHoldability

int getHoldability()
                   throws SQLException
获取此 ResultSet 对象的可保存性

返回：
ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT
抛出：
SQLException - 如果发生数据库访问错误或在已关闭的结果集上调用此方法
从以下版本开始：
1.6

isClosed

boolean isClosed()
                 throws SQLException
获取此 ResultSet 对象是否已关闭。如果已经在 ResultSet 上调用了 close 方法，或者 ResultSet 自动关闭，则 ResultSet 已关闭。

返回：
如果此 ResultSet 对象已关闭，则返回 true；如果它仍然是打开的，则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

updateNString

void updateNString(int columnIndex,
                   String nString)
                   throws SQLException
用 String 值更新指定的列。更新 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时使用该方法。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
nString - 要更新的列值
抛出：
SQLException - 如果 columnIndex 无效；如果驱动程序不支持国家字符集 (national character set)；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；结果集并发性为 CONCUR_READ_ONLY 或发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNString

void updateNString(String columnLabel,
                   String nString)
                   throws SQLException
用 String 值更新指定的列。更新 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时使用该方法。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
nString - 要更新的列值
抛出：
SQLException - 如果 columnLabel 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；结果集并发性为 CONCUR_READ_ONLY 或发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNClob

void updateNClob(int columnIndex,
                 NClob nClob)
                 throws SQLException
用 java.sql.NClob 值更新指定的列。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
nClob - 要更新的列值
抛出：
SQLException - 如果 columnIndex 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；发生数据库访问错误或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNClob

void updateNClob(String columnLabel,
                 NClob nClob)
                 throws SQLException
用 java.sql.NClob 值更新指定的列。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
nClob - 要更新的列值
抛出：
SQLException - 如果 columnLabel 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；发生数据库访问错误或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNClob

NClob getNClob(int columnIndex)
               throws SQLException
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
表示指定列中 SQL NCLOB 值的 NClob 对象
抛出：
SQLException - 如果 columnIndex 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法或发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNClob

NClob getNClob(String columnLabel)
               throws SQLException
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
表示指定列中 SQL NCLOB 值的 NClob 对象
抛出：
SQLException - 如果 columnLabel 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法或发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getSQLXML

SQLXML getSQLXML(int columnIndex)
                 throws SQLException
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
一个映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getSQLXML

SQLXML getSQLXML(String columnLabel)
                 throws SQLException
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
一个映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateSQLXML

void updateSQLXML(int columnIndex,
                  SQLXML xmlObject)
                  throws SQLException
用 java.sql.SQLXML 值更新指定列。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
xmlObject - 要更新的列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；在已关闭的结果集上调用此方法；没有为 SQLXML 对象关闭 java.xml.transform.Result、Writer 或 OutputStream；如果在处理 XML 值的过程中发生错误或结果集并发性为 CONCUR_READ_ONLY。该异常的 getCause 方法可以提供更详细的异常信息，例如，如果该流不包含有效的 XML。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateSQLXML

void updateSQLXML(String columnLabel,
                  SQLXML xmlObject)
                  throws SQLException
用 java.sql.SQLXML 值更新指定的列。更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
xmlObject - 列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；在已关闭的结果集上调用此方法；没有为 SQLXML 对象关闭 java.xml.transform.Result、Writer 或 OutputStream；如果在处理 XML 值的过程中发生错误或结果集并发性为 CONCUR_READ_ONLY。该异常的 getCause 方法可能提供更详细的异常信息，例如，如果该流不包含有效的 XML。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNString

String getNString(int columnIndex)
                  throws SQLException
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
列值；如果该值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNString

String getNString(String columnLabel)
                  throws SQLException
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
列值；如果该值为 SQL NULL，则返回值为 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNCharacterStream

Reader getNCharacterStream(int columnIndex)
                           throws SQLException
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
返回：
包含该列值的 java.io.Reader 对象；如果该值为 SQL NULL，则返回 Java 编程语言中的值 null。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getNCharacterStream

Reader getNCharacterStream(String columnLabel)
                           throws SQLException
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
返回：
包含该列值的 java.io.Reader 对象；如果该值为 SQL NULL，则返回 Java 编程语言中的值 null
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNCharacterStream

void updateNCharacterStream(int columnIndex,
                            Reader x,
                            long length)
                            throws SQLException
用字符流值更新指定的列，该值将具有指定的字节数。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。更新 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
length - 流长度
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNCharacterStream

void updateNCharacterStream(String columnLabel,
                            Reader reader,
                            long length)
                            throws SQLException
用字符流值更新指定的列，该值将具有指定的字节数。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。更新 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含新列值的 java.io.Reader 对象
length - 流长度
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateAsciiStream

void updateAsciiStream(int columnIndex,
                       InputStream x,
                       long length)
                       throws SQLException
用 ascii 流值更新指定的列，该值将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
length - 流长度
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBinaryStream

void updateBinaryStream(int columnIndex,
                        InputStream x,
                        long length)
                        throws SQLException
用二进制流值更新指定的列，该值将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
length - 流长度
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateCharacterStream

void updateCharacterStream(int columnIndex,
                           Reader x,
                           long length)
                           throws SQLException
用字符流值更新指定的列，该值将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
length - 流长度
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateAsciiStream

void updateAsciiStream(String columnLabel,
                       InputStream x,
                       long length)
                       throws SQLException
用 ascii 流值更新指定的列，该值将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
length - 流长度
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBinaryStream

void updateBinaryStream(String columnLabel,
                        InputStream x,
                        long length)
                        throws SQLException
用二进制流值更新指定的列，该值将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
length - 流长度
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateCharacterStream

void updateCharacterStream(String columnLabel,
                           Reader reader,
                           long length)
                           throws SQLException
用字符流值更新指定的列，该值将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含新列值的 java.io.Reader 对象
length - 流长度
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBlob

void updateBlob(int columnIndex,
                InputStream inputStream,
                long length)
                throws SQLException
使用给定输入流更新指定的列，该流将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
inputStream - 包含用来设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBlob

void updateBlob(String columnLabel,
                InputStream inputStream,
                long length)
                throws SQLException
使用给定输入流更新指定列，该流将具有指定的字节数。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
inputStream - 包含用来设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateClob

void updateClob(int columnIndex,
                Reader reader,
                long length)
                throws SQLException
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateClob

void updateClob(String columnLabel,
                Reader reader,
                long length)
                throws SQLException
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNClob

void updateNClob(int columnIndex,
                 Reader reader,
                 long length)
                 throws SQLException
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 columnIndex 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；如果发生数据库访问错误或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNClob

void updateNClob(String columnLabel,
                 Reader reader,
                 long length)
                 throws SQLException
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 columnLabel 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；如果发生数据库访问错误或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNCharacterStream

void updateNCharacterStream(int columnIndex,
                            Reader x)
                            throws SQLException
用字符流值更新指定的列。将根据需要从流中读取数据，一直读取到流末尾。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。更新 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateNCharacterStream 是否更有效。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNCharacterStream

void updateNCharacterStream(String columnLabel,
                            Reader reader)
                            throws SQLException
用字符流值更新指定的列。将根据需要从流中读取数据，一直读取到流末尾。驱动程序执行从 Java 字符格式到数据库中国家字符集的必要转换。更新 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时可使用此方法。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateNCharacterStream 是否更有效。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含新列值的 java.io.Reader 对象
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateAsciiStream

void updateAsciiStream(int columnIndex,
                       InputStream x)
                       throws SQLException
用 ascii 流值更新指定的列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateAsciiStream 是否更有效。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBinaryStream

void updateBinaryStream(int columnIndex,
                        InputStream x)
                        throws SQLException
用二进制流值更新指定的列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateBinaryStream 是否更有效。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateCharacterStream

void updateCharacterStream(int columnIndex,
                           Reader x)
                           throws SQLException
用字符流值更新指定的列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateCharacterStream 是否更有效。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
x - 新列值
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateAsciiStream

void updateAsciiStream(String columnLabel,
                       InputStream x)
                       throws SQLException
用 ascii 流值更新指定列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateAsciiStream 是否更有效。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBinaryStream

void updateBinaryStream(String columnLabel,
                        InputStream x)
                        throws SQLException
用二进制流值更新指定列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateBinaryStream 是否更有效。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
x - 新列值
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateCharacterStream

void updateCharacterStream(String columnLabel,
                           Reader reader)
                           throws SQLException
用字符流值更新指定列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateCharacterStream 是否更有效。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含新列值的 java.io.Reader 对象
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBlob

void updateBlob(int columnIndex,
                InputStream inputStream)
                throws SQLException
使用给定输入流值更新指定列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateBlob 是否更有效。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
inputStream - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateBlob

void updateBlob(String columnLabel,
                InputStream inputStream)
                throws SQLException
使用给定输入流值更新指定列。将根据需要从流中读取数据，一直读取到流末尾。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateBlob 是否更有效。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
inputStream - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateClob

void updateClob(int columnIndex,
                Reader reader)
                throws SQLException
使用给定的 Reader 对象更新指定列。将根据需要从流中读取数据，一直读取到流末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateClob 是否更有效。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 columnIndex 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateClob

void updateClob(String columnLabel,
                Reader reader)
                throws SQLException
使用给定的 Reader 对象更新指定列。将根据需要从流中读取数据，一直读取到流末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateClob 是否更有效。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 columnLabel 无效；如果发生数据库访问错误；结果集并发性为 CONCUR_READ_ONLY 或在已关闭的结果集上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNClob

void updateNClob(int columnIndex,
                 Reader reader)
                 throws SQLException
使用给定的 Reader 对象更新指定列。将根据需要从流中读取数据，一直读取到流末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateNClob 是否更有效。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 columnIndex 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；如果发生数据库访问错误或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

updateNClob

void updateNClob(String columnLabel,
                 Reader reader)
                 throws SQLException
使用给定的 Reader 对象更新指定列。将根据需要从流中读取数据，一直读取到流末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

更新方法用于更新当前行或插入行中的列值。更新方法不更新底层数据库；更新数据库要调用 updateRow 或 insertRow 方法。

注：请参考 JDBC 驱动程序文档，以确定使用带长度参数的 updateNClob 是否更有效。

参数：
columnLabel - 使用 SQL AS 子句指定的列标签。如果未指定 SQL AS 子句，则标签是列名称
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 columnLabel 无效；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；在已关闭的结果集上调用此方法；如果发生数据库访问错误或结果集并发性为 CONCUR_READ_ONLY
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResultSetMetaData (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 ResultSetMetaData

所有超级接口：
Wrapper
所有已知子接口：
RowSetMetaData
所有已知实现类：
RowSetMetaDataImpl
public interface ResultSetMetaData
extends Wrapper

可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。以下代码片段创建 ResultSet 对象 rs，创建 ResultSetMetaData 对象 rsmd，并使用 rsmd 查找 rs 有多少列，以及 rs 中的第一列是否可以在 WHERE 子句中使用。

     ResultSet rs = stmt.executeQuery("SELECT a, b, c FROM TABLE2");
     ResultSetMetaData rsmd = rs.getMetaData();
     int numberOfColumns = rsmd.getColumnCount();
     boolean b = rsmd.isSearchable(1);

字段摘要
static int | columnNoNulls 指示列不允许使用 NULL 值的常量。
static int | columnNullable 指示列允许使用 NULL 值的常量。
static int | columnNullableUnknown 指示不知道列的值是否可为 null 的常量。
方法摘要
String | getCatalogName(int column) 获取指定列的表目录名称。
String | getColumnClassName(int column) 如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。
int | getColumnCount() 返回此 ResultSet 对象中的列数。
int | getColumnDisplaySize(int column) 指示指定列的最大标准宽度，以字符为单位。
String | getColumnLabel(int column) 获取用于打印输出和显示的指定列的建议标题。
String | getColumnName(int column) 获取指定列的名称。
int | getColumnType(int column) 获取指定列的 SQL 类型。
String | getColumnTypeName(int column) 获取指定列的数据库特定的类型名称。
int | getPrecision(int column) 获取指定列的指定列宽。
int | getScale(int column) 获取指定列的小数点右边的位数。
String | getSchemaName(int column) 获取指定列的表模式。
String | getTableName(int column) 获取指定列的名称。
boolean | isAutoIncrement(int column) 指示是否自动为指定列进行编号。
boolean | isCaseSensitive(int column) 指示列的大小写是否有关系。
boolean | isCurrency(int column) 指示指定的列是否是一个哈希代码值。
boolean | isDefinitelyWritable(int column) 指示在指定的列上进行写操作是否明确可以获得成功。
int | isNullable(int column) 指示指定列中的值是否可以为 null。
boolean | isReadOnly(int column) 指示指定的列是否明确不可写入。
boolean | isSearchable(int column) 指示是否可以在 where 子句中使用指定的列。
boolean | isSigned(int column) 指示指定列中的值是否带正负号。
boolean | isWritable(int column) 指示在指定的列上进行写操作是否可以获得成功。
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

字段详细信息

columnNoNulls

static final int columnNoNulls
指示列不允许使用 NULL 值的常量。

另请参见：
常量字段值

columnNullable

static final int columnNullable
指示列允许使用 NULL 值的常量。

另请参见：
常量字段值

columnNullableUnknown

static final int columnNullableUnknown
指示不知道列的值是否可为 null 的常量。

另请参见：
常量字段值
方法详细信息

getColumnCount

int getColumnCount()
                   throws SQLException
返回此 ResultSet 对象中的列数。

返回：
列数
抛出：
SQLException - 如果发生数据库访问错误

isAutoIncrement

boolean isAutoIncrement(int column)
                        throws SQLException
指示是否自动为指定列进行编号。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

isCaseSensitive

boolean isCaseSensitive(int column)
                        throws SQLException
指示列的大小写是否有关系。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

isSearchable

boolean isSearchable(int column)
                     throws SQLException
指示是否可以在 where 子句中使用指定的列。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

isCurrency

boolean isCurrency(int column)
                   throws SQLException
指示指定的列是否是一个哈希代码值。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

isNullable

int isNullable(int column)
               throws SQLException
指示指定列中的值是否可以为 null。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
给定列的状态是否可以为 null 的判断，此状态值是 columnNoNulls、columnNullable 或 columnNullableUnknown 之一
抛出：
SQLException - 如果发生数据库访问错误

isSigned

boolean isSigned(int column)
                 throws SQLException
指示指定列中的值是否带正负号。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getColumnDisplaySize

int getColumnDisplaySize(int column)
                         throws SQLException
指示指定列的最大标准宽度，以字符为单位。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
允许作为指定列宽度的最大标准字符数
抛出：
SQLException - 如果发生数据库访问错误

getColumnLabel

String getColumnLabel(int column)
                      throws SQLException
获取用于打印输出和显示的指定列的建议标题。建议标题通常由 SQL AS 子句来指定。如果未指定 SQL AS，则从 getColumnLabel 返回的值将和 getColumnName 方法返回的值相同。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
建立列标题
抛出：
SQLException - 如果发生数据库访问错误

getColumnName

String getColumnName(int column)
                     throws SQLException
获取指定列的名称。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
列名称
抛出：
SQLException - 如果发生数据库访问错误

getSchemaName

String getSchemaName(int column)
                     throws SQLException
获取指定列的表模式。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
模式名称；如果没有可应用的名称，则返回 ""
抛出：
SQLException - 如果发生数据库访问错误

getPrecision

int getPrecision(int column)
                 throws SQLException
获取指定列的指定列宽。对于数值型数据，是指最大精度。对于字符型数据，是指字符串长度。对于日期时间的数据类型，是指 String 表示形式的字符串长度（假定为最大允许的小数秒组件）。对于二进制型数据，是指字节长度。对于 ROWID 数据类型，是指字节长度。对于其列大小不可用的数据类型，则返回 0。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
精度
抛出：
SQLException - 如果发生数据库访问错误

getScale

int getScale(int column)
             throws SQLException
获取指定列的小数点右边的位数。对于其标度不可用的数据类型，则返回 0。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
标度
抛出：
SQLException - 如果发生数据库访问错误

getTableName

String getTableName(int column)
                    throws SQLException
获取指定列的名称。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
表名称；如果没有可应用的名称，则返回 ""
抛出：
SQLException - 如果发生数据库访问错误

getCatalogName

String getCatalogName(int column)
                      throws SQLException
获取指定列的表目录名称。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
在其中显示给定列的表的目录名称；如果可应用的名称，则返回 ""
抛出：
SQLException - 如果发生数据库访问错误

getColumnType

int getColumnType(int column)
                  throws SQLException
获取指定列的 SQL 类型。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
来自 java.sql.Types 的 SQL 类型
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Types

getColumnTypeName

String getColumnTypeName(int column)
                         throws SQLException
获取指定列的数据库特定的类型名称。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
数据库使用的类型名称。如果列类型是用户定义的类型，则返回完全限定的类型名称。
抛出：
SQLException - 如果发生数据库访问错误

isReadOnly

boolean isReadOnly(int column)
                   throws SQLException
指示指定的列是否明确不可写入。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

isWritable

boolean isWritable(int column)
                   throws SQLException
指示在指定的列上进行写操作是否可以获得成功。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

isDefinitelyWritable

boolean isDefinitelyWritable(int column)
                             throws SQLException
指示在指定的列上进行写操作是否明确可以获得成功。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
如果是这样，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误

getColumnClassName

String getColumnClassName(int column)
                          throws SQLException

如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。ResultSet.getObject 可能返回此方法所返回的类的子类。

参数：
column - 第一列是 1，第二个列是 2，……
返回：
Java 编程语言中类的完全限定名称，方法 ResultSet.getObject 将使用该名称获取指定列中的值。此名称为用于自定义映射关系的类名称。
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowId (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 RowId

public interface RowId

SQL ROWID 值在 Java 编程语言中的表示形式（映射）。SQL ROWID 是一种内置类型，其值可视为它标识的行在数据库表中的一个地址。该地址是逻辑的还是物理的（在某些方面）取决于它的原始数据源。

接口 ResultSet、CallableStatement 和 PreparedStatement 中的方法（如 getRowId 和 setRowId）允许程序员访问 SQL ROWID 值。RowId 接口提供以 byte 数组或 String 形式表示 ROWID 值的方法。

接口 DatabaseMetaData 中的方法 getRowIdLifetime 可用于确定 RowId 对象在创建它的事务及会话处理期间是否仍然有效，实际上，也就是用于确定其标识的行未被删除之前，RowId 是否仍然有效。除指定其原始数据源外的有效生存期之外，getRowIdLifetime 还指定其原始数据源内的 ROWID 值的有效生存期。在这一点上，它不同于大对象，因为原始数据源内大对象的有效生存期没有限制。

如果 JDBC 驱动程序支持该数据类型，则必须完全实现 RowId 接口中的所有方法。

从以下版本开始：
1.6
另请参见：
DatabaseMetaData

方法摘要
boolean | equals(Object obj) 将此 RowId 与指定对象比较。
byte[] | getBytes() 返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 byte 数组。
int | hashCode() 返回此 RowId 对象的哈希码值。
String | toString() 返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 String。

方法详细信息

equals

boolean equals(Object obj)
将此 RowId 与指定对象比较。当且仅当参数不为 null，并且是一个与此对象表示相同 ROWID 的 RowId 对象时，结果才为 true。

将一个 RowId 与另一个 RowId 比较时，同时考虑它的原始生存期和有效生存期非常重要。如果两者都有效，并且两者都来自同一数据源的同一个表，那么如果它们相等，则标识相同的行；如果它们中有一个或多个不再保证有效，或者它们源自不同的数据源，或同一数据源的不同表，那么它们可能相等，但仍然不可能标识相同的行。

覆盖：
类 Object 中的 equals
参数：
obj - 用于比较此 RowId 对象的 Object。
返回：
如果 RowId 相等，则返回 true；否则返回 false
从以下版本开始：
1.6
另请参见：
Object.hashCode(), Hashtable

getBytes

byte[] getBytes()
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 byte 数组。

返回：
byte 数组，其长度由提供连接并表示此 java.sql.RowId 对象指定的 ROWID 值的驱动程序决定。

toString

String toString()
返回表示此 java.sql.RowId 对象指定的 SQL ROWID 值的 String。

与 java.sql.Date.toString() 以 String "2004-03-17" 形式而不是 SQL DATE 字面值形式（它可以是 String DATE "2004-03-17"）返回其 DATE 的内容类似，toString() 以特定于提供连接的驱动程序的形式，而不是 ROWID 字面值形式返回其 ROWID 的内容。

覆盖：
类 Object 中的 toString
返回：
String，其格式由提供连接并表示此 java.sql.RowId 对象指定的 ROWID 值的驱动程序决定。

hashCode

int hashCode()
返回此 RowId 对象的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
RowId 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowIdLifetime (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.sql
枚举 RowIdLifetime

java.lang.Object
    继承者  java.lang.Enum<RowIdLifetime>
        继承者  java.sql.RowIdLifetime
所有已实现的接口：
Serializable, Comparable<RowIdLifetime>
public enum RowIdLifetime
extends Enum<RowIdLifetime>

RowId 生存期值的枚举。

从以下版本开始：
1.6

枚举常量摘要
ROWID_UNSUPPORTED
表示此数据源不支持 ROWID 类型。
ROWID_VALID_FOREVER
表示来自此数据源的 RowId 的生存期实际上没有限制。
ROWID_VALID_OTHER
表示来自此数据源的 RowId 的生存期是不确定的；但不是 ROWID_VALID_TRANSACTION、ROWID_VALID_SESSION 或 ROWID_VALID_FOREVER 之一。
ROWID_VALID_SESSION
表示来自此数据源的 RowId 至少在包含它的会话期间有效。
ROWID_VALID_TRANSACTION
表示来自此数据源的 RowId 的生存期至少在包含它的事务期间有效。
方法摘要
static RowIdLifetime | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowIdLifetime[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

ROWID_UNSUPPORTED

public static final RowIdLifetime ROWID_UNSUPPORTED
表示此数据源不支持 ROWID 类型。

ROWID_VALID_OTHER

public static final RowIdLifetime ROWID_VALID_OTHER
表示来自此数据源的 RowId 的生存期是不确定的；但不是 ROWID_VALID_TRANSACTION、ROWID_VALID_SESSION 或 ROWID_VALID_FOREVER 之一。

ROWID_VALID_SESSION

public static final RowIdLifetime ROWID_VALID_SESSION
表示来自此数据源的 RowId 至少在包含它的会话期间有效。

ROWID_VALID_TRANSACTION

public static final RowIdLifetime ROWID_VALID_TRANSACTION
表示来自此数据源的 RowId 的生存期至少在包含它的事务期间有效。

ROWID_VALID_FOREVER

public static final RowIdLifetime ROWID_VALID_FOREVER
表示来自此数据源的 RowId 的生存期实际上没有限制。

方法详细信息

values

public static final RowIdLifetime[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(RowIdLifetime c : RowIdLifetime.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static RowIdLifetime valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Savepoint (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Savepoint

public interface Savepoint

保存点的表示形式，保存点是可以从 Connection.rollback 方法引用的当前事务中的点。将事务回滚到保存点时，在该保存点之后所作的全部更改都将被撤消。

保存点可以是命名的，也可以是未命名的。未命名的保存点由基础数据源生成的 ID 来标识。

从以下版本开始：
1.4

方法摘要
int | getSavepointId() 获取此 Savepoint 对象表示的保存点的生成 ID。
String | getSavepointName() 获取此 Savepoint 对象表示的保存点的名称。

方法详细信息

getSavepointId

int getSavepointId()
                   throws SQLException
获取此 Savepoint 对象表示的保存点的生成 ID。

返回：
此保存点的数字 ID
抛出：
SQLException - 如果此为已命名的保存点
从以下版本开始：
1.4

getSavepointName

String getSavepointName()
                        throws SQLException
获取此 Savepoint 对象表示的保存点的名称。

返回：
此保存点的名称
抛出：
SQLException - 如果此为未命名的保存点
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLClientInfoException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLClientInfoException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLClientInfoException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLClientInfoException
extends SQLException

当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。除了 SQLException 提供的信息外，SQLClientInfoException 还提供未设置的客户端信息属性列表。 某些数据库不允许一次设置多个客户端信息属性。对于这些数据库，即使 Connection.setClientInfo 方法抛出异常，可能也已经设置了一些客户端信息属性。应用程序可以使用 getFailedProperties 方法获取未设置的客户端信息属性列表。通过将 Map<String,ClientInfoStatus> 传递给适当的 SQLClientInfoException 构造方法来标识属性。

从以下版本开始：
1.6
另请参见：
ClientInfoStatus, Connection.setClientInfo(java.lang.String, java.lang.String), 序列化表格

构造方法摘要
SQLClientInfoException()
构造一个 SQLClientInfoException 对象。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
方法摘要
 Map<String,ClientInfoStatus> getFailedProperties()
返回无法设置的客户端信息属性列表。
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLClientInfoException

public SQLClientInfoException()
构造一个 SQLClientInfoException 对象。reason、SQLState 和 failedProperties 列表初始化为 null，供应商代码初始化为 0。cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。

参数：
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。 如果 cause==null，则 reason 初始化为 null；如果 cause!=null，则 reason 初始化为 cause.toString()，供应商代码初始化为 0。

参数：
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码
cause - 此 SQLClientInfoException 的底层原因（保存此 cause，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(String reason,
                              Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。

参数：
reason - 对异常的描述
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(String reason,
                              Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(String reason,
                              String SQLState,
                              Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(String reason,
                              String SQLState,
                              Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(String reason,
                              String SQLState,
                              int vendorCode,
                              Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码

从以下版本开始：
1.6

SQLClientInfoException

public SQLClientInfoException(String reason,
                              String SQLState,
                              int vendorCode,
                              Map<String,ClientInfoStatus> failedProperties,
                              Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
failedProperties - 包含无法设置的属性值的 Map。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。

从以下版本开始：
1.6
方法详细信息

getFailedProperties

public Map<String,ClientInfoStatus> getFailedProperties()
返回无法设置的客户端信息属性列表。Map 中的键包含无法设置的客户端信息属性名称，值包含 ClientInfoStatus 中定义的某一原因代码

返回：
包含无法设置的客户端信息属性的 Map 列表

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLData (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 SQLData

public interface SQLData

该接口用于 SQL 用户定义类型 (UDT) 到 Java 编程语言中类的自定义映射关系。实现 SQLData 接口的类的类对象将以适当的 Connection 对象类型映射连同 UDT（此对象是它的自定义映射关系）的 SQL 名称一起进行输入。

通常，SQLData 实现将为 SQL 结构类型的每个属性定义一个字段，或者为 SQL DISTINCT 类型定义单个字段。用 ResultSet.getObject 方法从数据源获取 UDT 时，会将其映射为此类的实例。程序员可以像对待 Java 编程语言中的其他对象那样在此类实例上执行操作，然后通过调用 PreparedStatement.setObject 方法（此方法将其映射回 SQL 类型）存储对它所作的更改。

预期自定义映射关系的类的实现可以通过工具完成。在典型的实现中，程序员将仅提供 SQL UDT 的名称、要将该名称映射到的类的名称和要将 UDT 的每个属性映射到的字段名称。工具将使用此信息实现 SQLData.readSQL 和 SQLData.writeSQL 方法。readSQL 方法调用适当的 SQLInput 方法从 SQLInput 对象读取每个属性，writeSQL 方法调用 SQLOutput 方法通过 SQLOutput 对象将每个属性写回数据源。

应用程序员通常不直接调用 SQLData 方法，而 SQLInput 和 SQLOutput 方法由 SQLData 方法而不是应用程序代码在内部调用。

从以下版本开始：
1.2

方法摘要
String | getSQLTypeName() 返回此对象表示的 SQL 用户定义类型的完全限定名。
void | readSQL(SQLInput stream, String typeName) 用从数据库读取的数据填充此对象。
void | writeSQL(SQLOutput stream) 将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。

方法详细信息

getSQLTypeName

String getSQLTypeName()
                      throws SQLException
返回此对象表示的 SQL 用户定义类型的完全限定名。JDBC 驱动程序调用此方法来获取 UDT 实例的名称，该名称将被映射到 SQLData 的这一实例。

返回：
构造和填充此对象时传递到方法 readSQL 的类型名称
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 不支持此方法
从以下版本开始：
1.2

readSQL

void readSQL(SQLInput stream,
             String typeName)
             throws SQLException
用从数据库读取的数据填充此对象。该方法的实现必须遵守此协议：
  • 必须从给定输入流读取 SQL 类型的每个属性或元素。此操作通过调用输入流的某个方法读取每个项（按照它们在类型的 SQL 定义中显示的顺序）。
  • 然后，readSQL 方法将数据分配给（此对象或其他对象的）适当字段或元素。明确地说，它必须调用适当的 reader 方法（SQLInput.readString、SQLInput.readBigDecimal 等）来执行以下操作：对于不同类型，读取其单个数据元素；对于结构类型，读取 SQL 类型的每个属性的值。
JDBC 驱动程序在调用此方法之前用类型映射初始化输入流，此方法由流上适当的 SQLInput reader 方法使用。

参数：
stream - SQLInput 对象，从中读取要自定义映射的值的数据
typeName - 数据流上的值的 SQL 类型名称
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 不支持此方法
从以下版本开始：
1.2
另请参见：
SQLInput

writeSQL

void writeSQL(SQLOutput stream)
              throws SQLException
将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。方法的实现必须遵守此协议：
必须将 SQL 类型的每个属性写入给定的输出流。此操作通过调用输出流的某个方法写入每个项（按照它们在类型的 SQL 定义中显示的顺序）。明确地说，它必须调用适当的 SQLOutput writer 方法（writeInt、writeString 等）来执行以下操作：对于不同类型，写入其单个数据元素；对于结构类型，写入 SQL 类型的每个属性的值。

参数：
stream - SQLOutput 对象，要在其中写入自定义映射的值的数据
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 不支持此方法
从以下版本开始：
1.2
另请参见：
SQLOutput
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLDataException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLDataException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLNonTransientException
                    继承者  java.sql.SQLDataException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLDataException
extends SQLNonTransientException

当 SQLState 类值为“22”时抛出的 SQLException 子类。此异常表示各种数据错误，包括但不限于未经允许的转换、除以 0、对函数无效的参数。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLDataException()
构造一个 SQLDataException 对象。
SQLDataException(String reason)
构造一个带有给定 reason 的 SQLDataException 对象。
SQLDataException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLDataException 对象。
SQLDataException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLDataException 对象。
SQLDataException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。
SQLDataException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。
SQLDataException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。
SQLDataException(Throwable cause)
构造一个带有给定 cause 的 SQLDataException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLDataException

public SQLDataException()
构造一个 SQLDataException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLDataException

public SQLDataException(String reason)
构造一个带有给定 reason 的 SQLDataException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLDataException

public SQLDataException(String reason,
                        String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLDataException 对象。供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLDataException

public SQLDataException(String reason,
                        String SQLState,
                        int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLDataException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLDataException

public SQLDataException(Throwable cause)
构造一个带有给定 cause 的 SQLDataException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLDataException

public SQLDataException(String reason,
                        Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLDataException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLDataException

public SQLDataException(String reason,
                        String SQLState,
                        Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLDataException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法方法获取）；可以为 null，表示原因不存在或未知。
从以下版本开始：
1.6

SQLDataException

public SQLDataException(String reason,
                        String SQLState,
                        int vendorCode,
                        Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLDataException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示原因不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
所有已实现的接口：
Serializable, Iterable<Throwable>
直接已知子类：
BatchUpdateException, RowSetWarning, SerialException, SQLClientInfoException, SQLNonTransientException, SQLRecoverableException, SQLTransientException, SQLWarning, SyncFactoryException, SyncProviderException
public class SQLException
extends Exception
implements Iterable<Throwable>

提供关于数据库访问错误或其他错误信息的异常。

每个 SQLException 都可提供以下多种消息：

  • 描述错误的字符串。此字符串用作 Java Exception 消息，可以通过方法 getMessage 获得。
  • "SQLstate" 字符串，该字符串遵守 XOPEN SQLstate 约定或 SQL:2003 约定。SQLState 字符串的值在适当的规范中描述。DatabaseMetaData 的方法 getSQLStateType 可用于确定驱动程序返回 XOPEN 类型还是 SQL:2003 类型。
  • 特定于每个供应商的整数错误代码。通常，这将是底层数据库返回的实际错误代码。
  • 到下一个 Exception 的链接。可以使用此链接提供其他错误信息。
  • 因果关系，如果存在任何导致此 SQLException 的原因。

另请参见：
序列化表格

构造方法摘要
SQLException()
构造一个 SQLException 对象。
SQLException(String reason)
构造一个具有给定 reason 的 SQLException 对象。
SQLException(String reason, String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLException 对象。
SQLException(String reason, String SQLState, int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLException 对象。
SQLException(String reason, String sqlState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。
SQLException(String reason, String sqlState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。
SQLException(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLException 对象。
SQLException(Throwable cause)
构造一个具有给定 cause 的 SQLException 对象。
方法摘要
int | getErrorCode() 获取此 SQLException 对象的特定于供应商的异常代码。
SQLException | getNextException() 通过 setNextException(SQLException ex) 获取链接到此 SQLException 对象的异常。
String | getSQLState() 获取此 SQLException 对象的 SQLState。
Iterator<Throwable> | iterator() 返回在链接的 SQLExceptions 上进行迭代的迭代器。
void | setNextException(SQLException ex) 将 SQLException 对象添加到链接的末尾。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLException

public SQLException(String reason,
                    String SQLState,
                    int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLException 对象。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码

SQLException

public SQLException(String reason,
                    String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLException 对象。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码被初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码

SQLException

public SQLException(String reason)
构造一个具有给定 reason 的 SQLException 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述

SQLException

public SQLException()
构造一个 SQLException 对象。reason 和 SQLState 被初始化为 null，供应商代码被初始化为 0。cause 没有初始化，随后可调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

SQLException

public SQLException(Throwable cause)
构造一个具有给定 cause 的 SQLException 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。如果 cause==null，则 reason 被初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 导致此 SQLException 的底层原因（保存此 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6

SQLException

public SQLException(String reason,
                    Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLException 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。

参数：
reason - 对异常的描述。
cause - 导致此 SQLException 的底层原因（保存此 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6

SQLException

public SQLException(String reason,
                    String sqlState,
                    Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLException 对象。供应商代码被初始化为 0。

参数：
reason - 对异常的描述。
sqlState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 导致此 SQLException 的底层原因（保存此 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6

SQLException

public SQLException(String reason,
                    String sqlState,
                    int vendorCode,
                    Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLException 对象。

参数：
reason - 对异常的描述
sqlState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 导致此 SQLException 的底层原因（保存此 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
从以下版本开始：
1.6
方法详细信息

getSQLState

public String getSQLState()
获取此 SQLException 对象的 SQLState。

返回：
SQLState 值

getErrorCode

public int getErrorCode()
获取此 SQLException 对象的特定于供应商的异常代码。

返回：
供应商的错误代码

getNextException

public SQLException getNextException()
通过 setNextException(SQLException ex) 获取链接到此 SQLException 对象的异常。

返回：
链接中的 SQLException 对象；如果不存在，则返回 null
另请参见：
setNextException(java.sql.SQLException)

setNextException

public void setNextException(SQLException ex)
将 SQLException 对象添加到链接的末尾。

参数：
ex - 将添加到 SQLException 链接末尾的新异常
另请参见：
getNextException()

iterator

public Iterator<Throwable> iterator()
返回在链接的 SQLExceptions 上进行迭代的迭代器。该迭代器将用来在每个 SQLException 及其底层 cause（如果有）进行迭代。

指定者：
接口 Iterable<Throwable> 中的 iterator
返回：
以适当的顺序在链接的 SQLExceptions 和 cause 上进行迭代的迭代器
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLFeatureNotSupportedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLFeatureNotSupportedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLNonTransientException
                    继承者  java.sql.SQLFeatureNotSupportedException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLFeatureNotSupportedException
extends SQLNonTransientException

当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。此异常表示 JDBC 驱动程序不支持可选的 JDBC 特性。可选 JDBC 特性可分为以下类别：

  • 不支持可选特性
  • 不支持可选重载方法
  • 不支持可选方法模式。方法模式根据作为参数值传递给方法的常量确定。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLFeatureNotSupportedException()
构造一个 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason)
构造一个带有给定 reason 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。
SQLFeatureNotSupportedException(Throwable cause)
构造一个带有给定 cause 的 SQLFeatureNotSupportedException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException()
构造一个 SQLFeatureNotSupportedException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException(String reason)
构造一个带有给定 reason 的 SQLFeatureNotSupportedException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException(String reason,
                                       String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLFeatureNotSupportedException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException(String reason,
                                       String SQLState,
                                       int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLFeatureNotSupportedException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException(Throwable cause)
构造一个带有给定 cause 的 SQLFeatureNotSupportedException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示原因不存在或未知。
从以下版本开始：
1.6

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException(String reason,
                                       Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLFeatureNotSupportedException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException(String reason,
                                       String SQLState,
                                       Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLFeatureNotSupportedException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLFeatureNotSupportedException

public SQLFeatureNotSupportedException(String reason,
                                       String SQLState,
                                       int vendorCode,
                                       Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLFeatureNotSupportedException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示原因不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLInput (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 SQLInput

所有已知实现类：
SQLInputImpl
public interface SQLInput

一个输入流，它包含表示 SQL 结构化类型或 SQL 不同类型的实例的值组成的流。此接口（仅用于自定义映射关系）供应用程序在后台使用，程序员永远不能直接调用 SQLInput 方法。reader 方法（readLong、readBytes 等）为 SQLData 接口的实现提供了读取 SQLInput 对象值的一种方式。根据 SQLData 中的描述，必须按照其相应属性在类型的 SQL 定义中出现的顺序调用 reader 方法。方法 wasNull 用于确定读取的最后一个值是否是 SQL NULL。

当用实现接口 SQLData 的类的对象调用方法 getObject 时，JDBC 驱动程序调用方法 SQLData.getSQLType 来确定要自定义映射的用户定义类型 (UDT) 的 SQL 类型。驱动程序创建一个 SQLInput 实例，并用 UDT 的属性填充它。然后，驱动程序将输入流传递给方法 SQLData.readSQL，而该方法在其从输入流读取属性的实现中依次调用 SQLInput reader 方法。

从以下版本开始：
1.2

方法摘要
Array | readArray() 从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。
InputStream | readAsciiStream() 读取流中的下一个属性并将其作为 ASCII 字符流返回。
BigDecimal | readBigDecimal() 读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。
InputStream | readBinaryStream() 读取流中的下一个属性并将其作为未解释的字节流返回。
Blob | readBlob() 从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。
boolean | readBoolean() 读取流中的下一个属性并将其作为 Java 编程语言中的 boolean 返回。
byte | readByte() 读取流中的下一个属性并将其作为 Java 编程语言中的 byte 返回。
byte[] | readBytes() 读取流中的下一个属性并将其作为 Java 编程语言中的字节数组返回。
Reader | readCharacterStream() 读取流中的下一个属性并将其作为 Unicode 字符流返回。
Clob | readClob() 从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。
Date | readDate() 读取流中的下一个属性并将其作为 java.sql.Date 对象返回。
double | readDouble() 读取流中的下一个属性并将其作为 Java 编程语言中的 double 返回。
float | readFloat() 读取流中的下一个属性并将其作为 Java 编程语言中的 float 返回。
int | readInt() 读取流中的下一个属性并将其作为 Java 编程语言中的 int 返回。
long | readLong() 读取流中的下一个属性并将其作为 Java 编程语言中的 long 返回。
NClob | readNClob() 从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。
String | readNString() 读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。
Object | readObject() 读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。
Ref | readRef() 从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。
RowId | readRowId() 从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。
short | readShort() 读取流中的下一个属性并将其作为 Java 编程语言中的 short 返回。
SQLXML | readSQLXML() 从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。
String | readString() 读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。
Time | readTime() 读取流中的下一个属性并将其作为 java.sql.Time 对象返回。
Timestamp | readTimestamp() 读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。
URL | readURL() 从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。
boolean | wasNull() 获取最后一个读取的值是否为 SQL NULL。

方法详细信息

readString

String readString()
                  throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readBoolean

boolean readBoolean()
                    throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 boolean 返回。

返回：
属性；如果值为 SQL NULL，则返回 false
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readByte

byte readByte()
              throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 byte 返回。

返回：
属性；如果值为 SQL NULL，则返回 0
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readShort

short readShort()
                throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 short 返回。

返回：
属性；如果值为 SQL NULL，则返回 0
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readInt

int readInt()
            throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 int 返回。

返回：
属性；如果值为 SQL NULL，则返回 0
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readLong

long readLong()
              throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 long 返回。

返回：
属性；如果值为 SQL NULL，则返回 0
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readFloat

float readFloat()
                throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 float 返回。

返回：
属性；如果值为 SQL NULL，则返回 0
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readDouble

double readDouble()
                  throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 double 返回。

返回：
属性；如果值为 SQL NULL，则返回 0
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readBigDecimal

BigDecimal readBigDecimal()
                          throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readBytes

byte[] readBytes()
                 throws SQLException
读取流中的下一个属性并将其作为 Java 编程语言中的字节数组返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readDate

Date readDate()
              throws SQLException
读取流中的下一个属性并将其作为 java.sql.Date 对象返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readTime

Time readTime()
              throws SQLException
读取流中的下一个属性并将其作为 java.sql.Time 对象返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readTimestamp

Timestamp readTimestamp()
                        throws SQLException
读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readCharacterStream

Reader readCharacterStream()
                           throws SQLException
读取流中的下一个属性并将其作为 Unicode 字符流返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readAsciiStream

InputStream readAsciiStream()
                            throws SQLException
读取流中的下一个属性并将其作为 ASCII 字符流返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readBinaryStream

InputStream readBinaryStream()
                             throws SQLException
读取流中的下一个属性并将其作为未解释的字节流返回。

返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readObject

Object readObject()
                  throws SQLException
读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。返回对象的实际类型由默认类型映射关系和此流的类型映射表中存在的自定义设置来确定。

类型映射表在将流传递给应用程序前通过 JDBC 驱动程序在流中注册。

当流的头 (head of the stream) 中的数据为 SQL NULL 时，该方法返回 null。如果数据为 SQL 结构化类型或不同类型，则该方法确定了流的头中的数据的 SQL 类型。如果流的类型映射表具有该 SQL 类型的项，则驱动程序将构造相应类的对象，并对该对象调用 SQLData.readSQL 方法，该方法使用为它描述的协议从流读取其他数据。

返回：
作为 Java 编程语言中的 Object 返回流的头中的数据；如果数据为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readRef

Ref readRef()
            throws SQLException
从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。

返回：
表示流的头中的 SQL REF 值的 Ref 对象；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readBlob

Blob readBlob()
              throws SQLException
从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。

返回：
表示流的头中的 SQL BLOB 值数据的 Blob 对象；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readClob

Clob readClob()
              throws SQLException
从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。

返回：
表示流的头中的 SQL CLOB 值数据的 Clob 对象；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readArray

Array readArray()
                throws SQLException
从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。

返回：
表示流的头中的 SQL ARRAY 值数据的 Array 对象；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

wasNull

boolean wasNull()
                throws SQLException
获取最后一个读取的值是否为 SQL NULL。

返回：
如果最近读取的 SQL 值为 SQL NULL，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

readURL

URL readURL()
            throws SQLException
从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。

返回：
java.net.URL 对象。
抛出：
SQLException - 如果发生数据库访问错误或者 URL 是错误的
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

readNClob

NClob readNClob()
                throws SQLException
从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。

返回：
表示流的头中的 SQL NCLOB 值数据的 NClob 对象；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

readNString

String readNString()
                   throws SQLException
读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。此方法用于访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时。

返回：
属性；如果该值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

readSQLXML

SQLXML readSQLXML()
                  throws SQLException
从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。

返回：
表示流的头中的 SQL XML 值数据的 SQLXML 对象；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

readRowId

RowId readRowId()
                throws SQLException
从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。

返回：
表示流的头中的 SQL ROWID 值数据的 RowId 对象；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLIntegrityConstraintViolationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLIntegrityConstraintViolationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLNonTransientException
                    继承者  java.sql.SQLIntegrityConstraintViolationException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLIntegrityConstraintViolationException
extends SQLNonTransientException

当 SQLState 类值为“23”时抛出的 SQLException 子类。此异常表示违反了一个完整性约束（外键、主键或唯一键）。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLIntegrityConstraintViolationException()
构造一个 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason)
构造一个带有给定 reason 的 SQLIntegrityConstraintViolationException。
SQLIntegrityConstraintViolationException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。
SQLIntegrityConstraintViolationException(Throwable cause)
构造一个带有给定 cause 的 SQLIntegrityConstraintViolationException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException()
构造一个 SQLIntegrityConstraintViolationException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException(String reason)
构造一个带有给定 reason 的 SQLIntegrityConstraintViolationException。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException(String reason,
                                                String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLIntegrityConstraintViolationException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException(String reason,
                                                String SQLState,
                                                int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLIntegrityConstraintViolationException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException(Throwable cause)
构造一个带有给定 cause 的 SQLIntegrityConstraintViolationException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException(String reason,
                                                Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLIntegrityConstraintViolationException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException(String reason,
                                                String SQLState,
                                                Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLIntegrityConstraintViolationException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLIntegrityConstraintViolationException

public SQLIntegrityConstraintViolationException(String reason,
                                                String SQLState,
                                                int vendorCode,
                                                Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLIntegrityConstraintViolationException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLInvalidAuthorizationSpecException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLInvalidAuthorizationSpecException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLNonTransientException
                    继承者  java.sql.SQLInvalidAuthorizationSpecException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLInvalidAuthorizationSpecException
extends SQLNonTransientException

当 SQLState 类值为“28”时抛出的 SQLException 子类。此异常表示建立连接期间提供的授权凭据无效。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLInvalidAuthorizationSpecException()
构造一个 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason)
构造一个带有给定 reason 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。
SQLInvalidAuthorizationSpecException(Throwable cause)
构造一个带有给定 cause 的 SQLInvalidAuthorizationSpecException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException()
构造一个 SQLInvalidAuthorizationSpecException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException(String reason)
构造一个带有给定 reason 的 SQLInvalidAuthorizationSpecException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException(String reason,
                                            String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLInvalidAuthorizationSpecException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException(String reason,
                                            String SQLState,
                                            int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLInvalidAuthorizationSpecException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException(Throwable cause)
构造一个带有给定 cause 的 SQLInvalidAuthorizationSpecException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException(String reason,
                                            Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLInvalidAuthorizationSpecException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException(String reason,
                                            String SQLState,
                                            Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLInvalidAuthorizationSpecException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLInvalidAuthorizationSpecException

public SQLInvalidAuthorizationSpecException(String reason,
                                            String SQLState,
                                            int vendorCode,
                                            Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLInvalidAuthorizationSpecException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示原因不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLNonTransientConnectionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLNonTransientConnectionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLNonTransientException
                    继承者  java.sql.SQLNonTransientConnectionException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLNonTransientConnectionException
extends SQLNonTransientException

SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLNonTransientConnectionException()
构造一个 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。
SQLNonTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientConnectionException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLNonTransientConnectionException

public SQLNonTransientConnectionException()
构造一个 SQLNonTransientConnectionException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLNonTransientConnectionException

public SQLNonTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLNonTransientConnectionException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLNonTransientConnectionException

public SQLNonTransientConnectionException(String reason,
                                          String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientConnectionException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLNonTransientConnectionException

public SQLNonTransientConnectionException(String reason,
                                          String SQLState,
                                          int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientConnectionException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLNonTransientConnectionException

public SQLNonTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientConnectionException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLNonTransientConnectionException

public SQLNonTransientConnectionException(String reason,
                                          Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLNonTransientConnectionException

public SQLNonTransientConnectionException(String reason,
                                          String SQLState,
                                          Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientConnectionException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLNonTransientConnectionException

public SQLNonTransientConnectionException(String reason,
                                          String SQLState,
                                          int vendorCode,
                                          Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientConnectionException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLNonTransientException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLNonTransientException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLNonTransientException
所有已实现的接口：
Serializable, Iterable<Throwable>
直接已知子类：
SQLDataException, SQLFeatureNotSupportedException, SQLIntegrityConstraintViolationException, SQLInvalidAuthorizationSpecException, SQLNonTransientConnectionException, SQLSyntaxErrorException
public class SQLNonTransientException
extends SQLException

重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLNonTransientException()
构造一个 SQLNonTransientException 对象。
SQLNonTransientException(String reason)
构造一个带有给定 reason 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。
SQLNonTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLNonTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLNonTransientException

public SQLNonTransientException()
构造一个 SQLNonTransientException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLNonTransientException

public SQLNonTransientException(String reason)
构造一个带有给定 reason 的 SQLNonTransientException 对象。 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLNonTransientException

public SQLNonTransientException(String reason,
                                String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLNonTransientException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLNonTransientException

public SQLNonTransientException(String reason,
                                String SQLState,
                                int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLNonTransientException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLNonTransientException

public SQLNonTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLNonTransientException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLNonTransientException

public SQLNonTransientException(String reason,
                                Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLNonTransientException

public SQLNonTransientException(String reason,
                                String SQLState,
                                Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLNonTransientException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLNonTransientException

public SQLNonTransientException(String reason,
                                String SQLState,
                                int vendorCode,
                                Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLNonTransientException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLXML (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 SQLXML

public interface SQLXML

SQL XML 类型在 JavaTM 编程语言中的映射关系。XML 是内置类型，它将 XML 值存储为数据库表某一行中的一个列值。默认情况下，驱动程序将 SQLXML 对象实现为一个指向 XML 数据而不是数据本身的逻辑指针。SQLXML 对象在创建它的事务处理期间有效。

SQLXML 接口以 String、Reader、Writer 或 Stream 形式提供访问 XML 值的方法。XML 值也可以通过 Source 进行访问，或设置为 Result，这两个对象与 XML Parser API（如 DOM、SAX 和 StAX）以及 XSLT 变换和 XPath 计算配合使用。

接口 ResultSet、CallableStatement 和 PreparedStatement 中的方法（如 getSQLXML）允许程序员访问 XML 值。此外，此接口还拥有更新 XML 值的方法。

使用以下方法能以 BinaryStream 形式获取 SQLXML 实例的 XML 值：

SQLXML sqlxml = resultSet.getSQLXML(column);
InputStream binaryStream = sqlxml.getBinaryStream();
例如，使用 DOM 解析器解析 XML 值：
DocumentBuilder parser = DocumentBuilderFactory.newInstance().newDocumentBuilder();
Document result = parser.parse(binaryStream);
或者，使用处理程序的 SAX 解析器解析 XML 值：
SAXParser parser = SAXParserFactory.newInstance().newSAXParser();
parser.parse(binaryStream, myHandler);
或者，使用 StAX 解析器解析 XML 值：
XMLInputFactory factory = XMLInputFactory.newInstance();
XMLStreamReader streamReader = factory.createXMLStreamReader(binaryStream);

因为数据库可以使用优化的 XML 表示形式，所以通过 getSource() 和 setResult() 访问值可以提高处理性能，且无需序列化为流表示形式和解析 XML。

例如，获取 DOM Document Node：

DOMSource domSource = sqlxml.getSource(DOMSource.class);
Document document = (Document) domSource.getNode();
或者，将值设置为 myNode 的 DOM Document Node：
DOMResult domResult = sqlxml.setResult(DOMResult.class);
domResult.setNode(myNode);
或者，将 SAX 事件发送到处理程序：
SAXSource saxSource = sqlxml.getSource(SAXSource.class);
XMLReader xmlReader = saxSource.getXMLReader();
xmlReader.setContentHandler(myHandler);
xmlReader.parse(saxSource.getInputSource());
或者，设置 SAX 事件的结果值：
SAXResult saxResult = sqlxml.setResult(SAXResult.class);
ContentHandler contentHandler = saxResult.getXMLReader().getContentHandler();
contentHandler.startDocument();
// set the XML elements and attributes into the result
contentHandler.endDocument();
或者，获取 StAX 事件：
StAXSource staxSource = sqlxml.getSource(StAXSource.class);
XMLStreamReader streamReader = staxSource.getXMLStreamReader();
或者，设置 StAX 事件的结果值：
StAXResult staxResult = sqlxml.setResult(StAXResult.class);
XMLStreamWriter streamWriter = staxResult.getXMLStreamWriter();
或者，使用输出到 resultFile 文件的 xsltFile 中的 XSLT 对 XML 值执行 XSLT 变换：
File xsltFile = new File("a.xslt");
File myFile = new File("result.xml");
Transformer xslt = TransformerFactory.newInstance().newTransformer(new StreamSource(xsltFile));
Source source = sqlxml.getSource(null);
Result result = new StreamResult(myFile);
xslt.transform(source, result);
或者，在 XML 值上计算 XPath 表达式：
XPath xpath = XPathFactory.newInstance().newXPath();
DOMSource domSource = sqlxml.getSource(DOMSource.class);
Document document = (Document) domSource.getNode();
String expression = "/foo/@bar";
String barValue = xpath.evaluate(expression, document);
将 XML 值设置为 XSLT 转化的结果：
File sourceFile = new File("source.xml");
Transformer xslt = TransformerFactory.newInstance().newTransformer(new StreamSource(xsltFile));
Source streamSource = new StreamSource(sourceFile);
Result result = sqlxml.setResult(null);
xslt.transform(streamSource, result);
使用调用 newTransformer() 指定的恒等变换，任何 Source 都可以变换为 Result。
Transformer identity = TransformerFactory.newInstance().newTransformer();
Source source = sqlxml.getSource(null);
File myFile = new File("result.xml");
Result result = new StreamResult(myFile);
identity.transform(source, result);
将 Source 的内容写入标准输出：
Transformer identity = TransformerFactory.newInstance().newTransformer();
Source source = sqlxml.getSource(null);
Result result = new StreamResult(System.out);
identity.transform(source, result);
根据 DOMSource 创建 DOMResult：
DOMSource domSource = new DOMSource(domResult.getNode());

设置不完整或无效的 XML 值时可能导致 SQLException，该异常也可能在执行 execute() 时发生。执行 execute() 前必须关闭所有流，否则将抛出 SQLException。

从 SQLXML 对象读取和向 SQLXML 对象写入 XML 值最多可以发生一次。可读和不可读（概念上的状态）确定一个读取 API 将返回一个值还是抛出一个异常。可写和不可写（概念上的状态）确定一个写入 API 将设置一个值还是抛出一个异常。

在调用 free() 或以下任一读取 API 后，状态从可读转为不可读：getBinaryStream()、getCharacterStream()、getSource() 和 getString()。在这种情况下，实现也可以将状态更改为不可写。

在调用 free() 或以下任一写入 API 后，状态从可写状态转为不可写状态：setBinaryStream()、setCharacterStream()、setResult() 和 setString()。在这种情况下，实现也可以将状态更改为不可读。

如果 JDBC 驱动程序支持该数据类型，则必须完全实现 SQLXML 接口中的所有方法。

从以下版本开始：
1.6
另请参见：
javax.xml.parsers, javax.xml.stream, javax.xml.transform, javax.xml.xpath

方法摘要
 void free()
此方法关闭此对象并释放其持有的资源。
 InputStream getBinaryStream()
以流的形式获取此 SQLXML 实例指定的 XML 值。
 Reader getCharacterStream()
以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。
<T extends Source>
T
getSource(Class<T> sourceClass)
返回读取此 SQLXML 实例指定的 XML 值的 Source。
 String getString()
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。
 OutputStream setBinaryStream()
获取可用于写入此 SQLXML 实例表示的 XML 值的流。
 Writer setCharacterStream()
获取用于写入此 SQLXML 实例表示的 XML 值的流。
<T extends Result>
T
setResult(Class<T> resultClass)
返回设置此 SQLXML 实例指定的 XML 值的 Result。
 void setString(String value)
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。

方法详细信息

free

void free()
          throws SQLException
此方法关闭此对象并释放其持有的资源。当调用此方法时，SQL XML 对象变为无效并不再可读或可写。 调用 free 之后，尝试调用 free 之外的方法都将导致抛出 SQLException。如果多次调用 free，则后续对 free 的调用都被视为无操作 (no-op)。

抛出：
SQLException - 如果释放 XML 值时出现错误。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getBinaryStream

InputStream getBinaryStream()
                            throws SQLException
以流的形式获取此 SQLXML 实例指定的 XML 值。根据 XML 1.0 规范中的附录 F 解释输入流的字节。当 ResultSet 的指定列的类型为 SQLXML java.sql.Types 时，此方法的行为与 ResultSet.getBinaryStream() 相同。

调用此方法时，SQL XML 对象将变为不可读，也可能变为不可写，具体取决于实现。

返回：
包含 XML 数据的流。
抛出：
SQLException - 如果处理 XML 值时出现错误。如果状态为不可读，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

OutputStream setBinaryStream()
                             throws SQLException
获取可用于写入此 SQLXML 实例表示的 XML 值的流。该流从位置 0 处开始。根据 XML 1.0 规范中的附录 F 解释流的字节。当 ResultSet 的指定列的类型为 SQLXML java.sql.Types 类型时，此方法的行为与 ResultSet.updateBinaryStream() 相同。

调用此方法时，SQL XML 对象将变为不可写，也可能变为不可读，具体取决于实现。

返回：
可以写入数据的流。
抛出：
SQLException - 如果处理 XML 值时出现错误。如果状态为不可写，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getCharacterStream

Reader getCharacterStream()
                          throws SQLException
以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。此流的格式由 org.xml.sax.InputSource 定义，根据 XML 1.0 规范的第 2 节和附录 B，流中的字符表示 XML 的 unicode 代码点。尽管可能存在 unicode 以外的编码声明，但流的编码是 unicode。当 ResultSet 的指定列的类型为 SQLXML java.sql.Types 时，此方法的行为与 ResultSet.getCharacterStream() 相同。

调用此方法时，SQL XML 对象将变为不可读，也可能变为不可写，具体取决于实现。

返回：
包含 XML 数据的流。
抛出：
SQLException - 如果处理 XML 值时出现错误。该异常的 getCause() 方法可以提供更详细的异常，例如，如果流不包含有效字符。如果状态为不可读，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setCharacterStream

Writer setCharacterStream()
                          throws SQLException
获取用于写入此 SQLXML 实例表示的 XML 值的流。此流的格式由 org.xml.sax.InputSource 定义，根据 XML 1.0 规范的第 2 节和附录 B，流中的字符表示 XML 的 unicode 代码点。尽管可能存在 unicode 之外的其他编码声明，但流的编码是 unicode。当 ResultSet 的指定列的类型为 SQLXML java.sql.Types 时，此方法的行为与 ResultSet.updateCharacterStream() 相同。

调用此方法时，SQL XML 对象将变为不可写，也可能变为不可读，具体取决于实现。

返回：
可以写入数据的流。
抛出：
SQLException - 如果处理 XML 值时出现错误。该异常的 getCause() 方法可以提供更详细的异常，例如，如果流不包含有效字符。如果状态为不可写，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getString

String getString()
                 throws SQLException
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。此 String 的格式由 org.xml.sax.InputSource 定义，根据 XML 1.0 规范的第 2 节和附录 B，流中的字符表示 XML 的 unicode 代码点。尽管可能存在 unicode 以外的编码声明，但 String 的编码是 unicode。当 ResultSet 的指定列的类型为 SQLXML java.sql.Types 时，此方法的行为与 ResultSet.getString() 相同。

调用此方法时，SQL XML 对象将变为不可读，也可能变为不可写，具体取决于实现。

返回：
此 SQLXML 实例指定的 XML 值的字符串表示形式。
抛出：
SQLException - 如果处理 XML 值时出现错误。该异常的 getCause() 方法可以提供更详细的异常，例如，如果流不包含有效字符。如果状态为不可读，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setString

void setString(String value)
               throws SQLException
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。此 String 的格式由 org.xml.sax.InputSource 定义，根据 XML 1.0 规范的第 2 节和附录 B，流中的字符表示 XML 的 unicode 代码点。尽管可能存在 unicode 以外的编码声明，但 String 的编码是 unicode。当 ResultSet 的指定列的类型为 SQLXML java.sql.Types 时，此方法的行为与 ResultSet.updateString() 相同。

调用此方法时，SQL XML 对象将变为不可写，也可能变为不可读，具体取决于实现。

参数：
value - XML 值
抛出：
SQLException - 如果处理 XML 值时出现错误。该异常的 getCause() 方法可以提供更详细的异常，例如，是否流不包含有效字符。如果状态为不可写，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getSource

<T extends Source> T getSource(Class<T> sourceClass)
                           throws SQLException
返回读取此 SQLXML 实例指定的 XML 值的 Source。Source 用作对 XML 解析器和 XSLT 转换器的输入。

XML 解析器的 Source 将以默认方式处理名称空间。Source 的 systemID 与实现有关。

调用此方法时，SQL XML 对象将变为不可读，也可能变为不可写，具体取决于实现。

注意，SAX 是一个回调架构，因此应使用通过解析接收 SAX 事件的内容处理程序设置返回的 SAXSource。内容处理程序将根据 XML 的内容接收回调。

SAXSource saxSource = sqlxml.getSource(SAXSource.class);
XMLReader xmlReader = saxSource.getXMLReader();
xmlReader.setContentHandler(myHandler);
xmlReader.parse(saxSource.getInputSource());

参数：
sourceClass - 源的类，或为 null。如果该类为 null，则将返回特定于供应商的 Source 实现。至少支持以下类：
javax.xml.transform.dom.DOMSource - 返回 DOMSource
javax.xml.transform.sax.SAXSource - 返回 SAXSource
javax.xml.transform.stax.StAXSource - 返回 StAXSource
javax.xml.transform.stream.StreamSource - 返回 StreamSource
返回：
读取 XML 值的 Source。
抛出：
SQLException - 如果处理 XML 值时出现错误，或者此性能不受支持。该异常的 getCause() 方法可以提供更详细的异常，例如，是否发生 XML 解析器异常。如果状态为不可读，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setResult

<T extends Result> T setResult(Class<T> resultClass)
                           throws SQLException
返回设置此 SQLXML 实例指定的 XML 值的 Result。

Result 的 systemID 与实现有关。

调用此方法时，SQL XML 对象将变为不可写，也可能变为不可读，具体取决于实现。

注意，SAX 是一个回调架构，返回的 SAXResult 分配了一个可根据 XML 内容接收 SAX 事件的内容处理程序。根据 XML 文档的内容调用内容处理程序来分配值。

SAXResult saxResult = sqlxml.setResult(SAXResult.class);
ContentHandler contentHandler = saxResult.getXMLReader().getContentHandler();
contentHandler.startDocument();
// set the XML elements and attributes into the result
contentHandler.endDocument();

参数：
resultClass - 所得的类，或为 null。如果 resultClass 为 null，则将返回特定于供应商的 Result 实现。至少支持以下类：
javax.xml.transform.dom.DOMResult - 返回 DOMResult
javax.xml.transform.sax.SAXResult - 返回 SAXResult
javax.xml.transform.stax.StAXResult - 返回 StAXResult
javax.xml.transform.stream.StreamResult - 返回 StreamResult
返回：
返回设置 XML 值的 Result。
抛出：
SQLException - 如果处理 XML 值时出现错误，或者此性能不受支持。该异常的 getCause() 方法可以提供更详细的异常，例如，是否发生 XML 解析器异常。如果状态为不可写，也将抛出该异常。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLOutput (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 SQLOutput

所有已知实现类：
SQLOutputImpl
public interface SQLOutput

用于将用户定义类型的属性写回数据库的输出流。此接口（仅用于自定义映射关系）供应用程序使用，程序员永远不能直接调用其方法。

将实现接口 SQLData 的类的对象作为参数传递给 SQL 语句时，JDBC 驱动程序将调用方法 SQLData.getSQLType 来确定要传递到数据库的 SQL 数据的种类。然后，驱动程序创建 SQLOutput 的实例并将其传递给方法 SQLData.writeSQL。方法 writeSQL 依次调用适当的 SQLOutput writer 方法（writeBoolean、writeCharacterStream 等），将数据作为 SQL 用户定义类型的表示形式从 SQLData 对象写入 SQLOutput 输出流。

从以下版本开始：
1.2

方法摘要
void | writeArray(Array x) 将 SQL ARRAY 值写入流中。
void | writeAsciiStream(InputStream x) 将下一个属性作为 ASCII 字符流写入流中。
void | writeBigDecimal(BigDecimal x) 将下一个属性作为 java.math.BigDecimal 对象写入流中。
void | writeBinaryStream(InputStream x) 将下一个属性作为未解释字节流写入流中。
void | writeBlob(Blob x) 将 SQL BLOB 值写入流中。
void | writeBoolean(boolean x) 将下一个属性作为 Java boolean 值写入流。
void | writeByte(byte x) 将下一个属性作为 Java byte 值写入流中。
void | writeBytes(byte[] x) 将下一个属性作为字节数组写入流中。
void | writeCharacterStream(Reader x) 将下一个属性作为 Unicode 字符的流写入流中。
void | writeClob(Clob x) 将 SQL CLOB 值写入流中。
void | writeDate(Date x) 将下一个属性作为 java.sql.Date 对象写入流中。
void | writeDouble(double x) 将下一个属性作为 Java double 值写入流中。
void | writeFloat(float x) 将下一个属性作为 Java float 值写入流中。
void | writeInt(int x) 将下一个属性作为 Java int 值写入流中。
void | writeLong(long x) 将下一个属性作为 Java long 值写入流中。
void | writeNClob(NClob x) 将 SQL NCLOB 值写入流中。
void | writeNString(String x) 将下一个属性以 Java 编程语言中 String 的形式写入流中。
void | writeObject(SQLData x) 将给定 SQLData 对象中包含的数据写入流中。
void | writeRef(Ref x) 将 SQL REF 值写入流中。
void | writeRowId(RowId x) 将 SQL ROWID 值写入流中。
void | writeShort(short x) 将下一个属性作为 Java short 值写入流中。
void | writeSQLXML(SQLXML x) 将 SQL XML 值写入流中。
void | writeString(String x) 将下一个属性作为 Java 编程语言中的 String 写入流中。
void | writeStruct(Struct x) 将 SQL 结构类型值写入流中。
void | writeTime(Time x) 将下一个属性作为 java.sql.Time 对象写入流中。
void | writeTimestamp(Timestamp x) 将下一个属性作为 java.sql.Timestamp 对象写入流中。
void | writeURL(URL x) 将 SQL DATALINK 值写入流中。

方法详细信息

writeString

void writeString(String x)
                 throws SQLException
将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeBoolean

void writeBoolean(boolean x)
                  throws SQLException
将下一个属性作为 Java boolean 值写入流。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeByte

void writeByte(byte x)
               throws SQLException
将下一个属性作为 Java byte 值写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeShort

void writeShort(short x)
                throws SQLException
将下一个属性作为 Java short 值写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeInt

void writeInt(int x)
              throws SQLException
将下一个属性作为 Java int 值写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeLong

void writeLong(long x)
               throws SQLException
将下一个属性作为 Java long 值写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeFloat

void writeFloat(float x)
                throws SQLException
将下一个属性作为 Java float 值写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeDouble

void writeDouble(double x)
                 throws SQLException
将下一个属性作为 Java double 值写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeBigDecimal

void writeBigDecimal(BigDecimal x)
                     throws SQLException
将下一个属性作为 java.math.BigDecimal 对象写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeBytes

void writeBytes(byte[] x)
                throws SQLException
将下一个属性作为字节数组写入流中。将下一个属性作为 Java 编程语言中的 String 写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeDate

void writeDate(Date x)
               throws SQLException
将下一个属性作为 java.sql.Date 对象写入流中。将下一个属性作为 Java 编程语言中的 java.sql.Date 对象写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeTime

void writeTime(Time x)
               throws SQLException
将下一个属性作为 java.sql.Time 对象写入流中。将下一个属性作为 Java 编程语言中的 java.sql.Date 对象写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeTimestamp

void writeTimestamp(Timestamp x)
                    throws SQLException
将下一个属性作为 java.sql.Timestamp 对象写入流中。将下一个属性作为 Java 编程语言中的 java.sql.Date 对象写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeCharacterStream

void writeCharacterStream(Reader x)
                          throws SQLException
将下一个属性作为 Unicode 字符的流写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeAsciiStream

void writeAsciiStream(InputStream x)
                      throws SQLException
将下一个属性作为 ASCII 字符流写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeBinaryStream

void writeBinaryStream(InputStream x)
                       throws SQLException
将下一个属性作为未解释字节流写入流中。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeObject

void writeObject(SQLData x)
                 throws SQLException
将给定 SQLData 对象中包含的数据写入流中。当 SQLData 对象为 null 时，此方法将 SQL NULL 写入流中。否则，它将调用给定对象的 SQLData.writeSQL 方法，该方法将对象的属性写入流中。方法 SQLData.writeSQ 的实现调用适当的 SQLOutput writer 方法，依次写入对象的每个属性。从 SQLInput 输入流读取属性和将属性写入 SQLOutput 输出流都必须按照在用户定义类型的 SQL 定义中将它们列出的顺序进行。

参数：
x - 表示 SQL 结构或不同类型的数据的对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeRef

void writeRef(Ref x)
              throws SQLException
将 SQL REF 值写入流中。

参数：
x - 表示 SQL 的数据的 Ref 对象 REF value
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeBlob

void writeBlob(Blob x)
               throws SQLException
将 SQL BLOB 值写入流中。

参数：
x - 表示 SQL BLOB 值的数据的 Blob 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeClob

void writeClob(Clob x)
               throws SQLException
将 SQL CLOB 值写入流中。

参数：
x - 表示 SQL CLOB 值的数据的 Clob 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeStruct

void writeStruct(Struct x)
                 throws SQLException
将 SQL 结构类型值写入流中。

参数：
x - 表示 SQL 结构类型的数据的 Struct 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeArray

void writeArray(Array x)
                throws SQLException
将 SQL ARRAY 值写入流中。

参数：
x - 表示 SQL ARRAY 类型的数据的 Array 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

writeURL

void writeURL(URL x)
              throws SQLException
将 SQL DATALINK 值写入流中。

参数：
x - 表示 SQL DATALINK 类型的数据的 java.net.URL 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

writeNString

void writeNString(String x)
                  throws SQLException
将下一个属性以 Java 编程语言中 String 的形式写入流中。在将该属性发送给流时，驱动程序将其转换为 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR 值（具体取决于该参数相对于驱动程序在 NVARCHAR 值上的限制的大小）。

参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

writeNClob

void writeNClob(NClob x)
                throws SQLException
将 SQL NCLOB 值写入流中。

参数：
x - 表示 SQL NCLOB 值数据的 NClob 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

writeRowId

void writeRowId(RowId x)
                throws SQLException
将 SQL ROWID 值写入流中。

参数：
x - 表示 SQL ROWID 值的数据的 RowId 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

writeSQLXML

void writeSQLXML(SQLXML x)
                 throws SQLException
将 SQL XML 值写入流中。

参数：
x - 表示 SQL XML 值数据的 SQLXML 对象
抛出：
SQLException - 如果发生数据库访问错误，如果没有为 SQLXML 对象关闭 java.xml.transform.Result、Writer 或 OutputStream，或者在处理 XML 值的过程中发生错误。异常的 getCause 方法可以提供更详细的异常信息，例如，如果该流不包含有效的 XML。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.sql.SQLPermission
所有已实现的接口：
Serializable, Guard
public final class SQLPermission
extends BasicPermission

SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。如果不存在 SQLPermission 对象，则这些方法将抛出 java.lang.SecurityException 作为运行时异常。

SQLPermission 对象包含一个名称（也称为“目标名称”），但没有动作列表；可能有指定的权限，也可能没有。目标名称是权限的名称（参见下面内容）。命名约定遵守层次结构属性命名约定。此外，名称的末尾可能有一个星号，星号前有一个 "."，该星号用来表示通配符。例如：loadLibrary.* 或 * 是有效的，而 *loadLibrary 或 a*b 则无效。

下表列出了所有可能的 SQLPermission 目标名称。目前，只有 setLog 是允许的名称。该表提供了允许权限的说明，并讨论了授权代码权限的风险。

权限目标名称 | 允许的权限 | 允许此权限所带来的风险
setLog | 日志流的设置 | 授予该权限是危险的。日志的内容可能包含用户名和密码、SQL 语句和 SQL 数据。
运行 applet 的人员可以决定允许使用哪些权限，并通过运行 Policy Tool 在策略文件中创建 SQLPermission。程序员不是直接使用构造方法来创建 SQLPermission 实例，而是使用工具进行创建。

从以下版本开始：
1.3
另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
SQLPermission(String name)
创建具有指定名称的新 SQLPermission 对象。
SQLPermission(String name, String actions)
创建具有指定名称的新 SQLPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLPermission

public SQLPermission(String name)
创建具有指定名称的新 SQLPermission 对象。该名称是 SQLPermission 的符号名；目前只有 "setLog" 是允许的名称。

参数：
name - 此 SQLPermission 对象的名称，该名称必须为 setLog
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

SQLPermission

public SQLPermission(String name,
                     String actions)
创建具有指定名称的新 SQLPermission 对象。该 name 是 SQLPermission 的符号名；目前未使用 actions String，应该为 null。

参数：
name - 此 SQLPermission 对象的名称，该名称必须为 setLog
actions - 应该为 null
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLRecoverableException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLRecoverableException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLRecoverableException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLRecoverableException
extends SQLException

应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。恢复操作至少必须包括关闭当前连接和获得一个新连接。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLRecoverableException()
构造一个 SQLRecoverableException 对象。
SQLRecoverableException(String reason)
构造一个带有给定 reason 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。
SQLRecoverableException(Throwable cause)
构造一个带有给定 cause 的 SQLRecoverableException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLRecoverableException

public SQLRecoverableException()
构造一个 SQLRecoverableException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLRecoverableException

public SQLRecoverableException(String reason)
构造一个带有给定 reason 的 SQLRecoverableException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLRecoverableException

public SQLRecoverableException(String reason,
                               String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLRecoverableException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLRecoverableException

public SQLRecoverableException(String reason,
                               String SQLState,
                               int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLRecoverableException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLRecoverableException

public SQLRecoverableException(Throwable cause)
构造一个带有给定 cause 的 SQLRecoverableException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLRecoverableException

public SQLRecoverableException(String reason,
                               Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLRecoverableException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLRecoverableException

public SQLRecoverableException(String reason,
                               String SQLState,
                               Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLRecoverableException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLRecoverableException

public SQLRecoverableException(String reason,
                               String SQLState,
                               int vendorCode,
                               Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLRecoverableException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLSyntaxErrorException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLSyntaxErrorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLNonTransientException
                    继承者  java.sql.SQLSyntaxErrorException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLSyntaxErrorException
extends SQLNonTransientException

当 SQLState 类值为“42”时抛出的 SQLException 子类。此异常表示正在进行的查询违反了 SQL 语法规则。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLSyntaxErrorException()
构造一个 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason)
构造一个带有给定 reason 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。
SQLSyntaxErrorException(Throwable cause)
构造一个带有给定 cause 的 SQLSyntaxErrorException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLSyntaxErrorException

public SQLSyntaxErrorException()
构造一个 SQLSyntaxErrorException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLSyntaxErrorException

public SQLSyntaxErrorException(String reason)
构造一个带有给定 reason 的 SQLSyntaxErrorException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLSyntaxErrorException

public SQLSyntaxErrorException(String reason,
                               String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLSyntaxErrorException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLSyntaxErrorException

public SQLSyntaxErrorException(String reason,
                               String SQLState,
                               int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLSyntaxErrorException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLSyntaxErrorException

public SQLSyntaxErrorException(Throwable cause)
构造一个带有给定 cause 的 SQLSyntaxErrorException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLSyntaxErrorException

public SQLSyntaxErrorException(String reason,
                               Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLSyntaxErrorException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLSyntaxErrorException

public SQLSyntaxErrorException(String reason,
                               String SQLState,
                               Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLSyntaxErrorException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLSyntaxErrorException

public SQLSyntaxErrorException(String reason,
                               String SQLState,
                               int vendorCode,
                               Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLSyntaxErrorException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLTimeoutException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLTimeoutException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLTransientException
                    继承者  java.sql.SQLTimeoutException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLTimeoutException
extends SQLTransientException

Statement 指定的超时已到期时抛出的 SQLException 子类。

此异常不对应标准的 SQLState。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLTimeoutException()
构造一个 SQLTimeoutException 对象。
SQLTimeoutException(String reason)
构造一个带有给定 reason 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。
SQLTimeoutException(Throwable cause)
构造一个带有给定 cause 的 SQLTimeoutException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLTimeoutException

public SQLTimeoutException()
构造一个 SQLTimeoutException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLTimeoutException

public SQLTimeoutException(String reason)
构造一个带有给定 reason 的 SQLTimeoutException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLTimeoutException

public SQLTimeoutException(String reason,
                           String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTimeoutException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLTimeoutException

public SQLTimeoutException(String reason,
                           String SQLState,
                           int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTimeoutException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLTimeoutException

public SQLTimeoutException(Throwable cause)
构造一个带有给定 cause 的 SQLTimeoutException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTimeoutException

public SQLTimeoutException(String reason,
                           Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTimeoutException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTimeoutException

public SQLTimeoutException(String reason,
                           String SQLState,
                           Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTimeoutException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTimeoutException

public SQLTimeoutException(String reason,
                           String SQLState,
                           int vendorCode,
                           Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTimeoutException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLTransactionRollbackException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLTransactionRollbackException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLTransientException
                    继承者  java.sql.SQLTransactionRollbackException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLTransactionRollbackException
extends SQLTransientException

当 SQLState 类值为“40”时，抛出此 SQLException 的子类。此异常表示由于死锁或其他事务序列化失败，当前语句自动被数据库回滚。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLTransactionRollbackException()
构造一个 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason)
构造一个带有给定 reason 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。
SQLTransactionRollbackException(Throwable cause)
构造一个带有给定 cause 的 SQLTransactionRollbackException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLTransactionRollbackException

public SQLTransactionRollbackException()
构造一个 SQLTransactionRollbackException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。

从以下版本开始：
1.6

SQLTransactionRollbackException

public SQLTransactionRollbackException(String reason)
构造一个带有给定 reason 的 SQLTransactionRollbackException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLTransactionRollbackException

public SQLTransactionRollbackException(String reason,
                                       String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransactionRollbackException 对象。 cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLTransactionRollbackException

public SQLTransactionRollbackException(String reason,
                                       String SQLState,
                                       int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransactionRollbackException 对象。 cause 没有初始化，随后可以通过调用 Throwable.initCause(java.lang.Throwable) 方法来初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLTransactionRollbackException

public SQLTransactionRollbackException(Throwable cause)
构造一个带有给定 cause 的 SQLTransactionRollbackException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，则 reason 初始化为 null；如果 cause!=null，则 reason 初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransactionRollbackException

public SQLTransactionRollbackException(String reason,
                                       Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransactionRollbackException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransactionRollbackException

public SQLTransactionRollbackException(String reason,
                                       String SQLState,
                                       Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransactionRollbackException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransactionRollbackException

public SQLTransactionRollbackException(String reason,
                                       String SQLState,
                                       int vendorCode,
                                       Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransactionRollbackException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLTransientConnectionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLTransientConnectionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLTransientException
                    继承者  java.sql.SQLTransientConnectionException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SQLTransientConnectionException
extends SQLTransientException

SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLTransientConnectionException()
构造一个 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。
SQLTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientConnectionException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLTransientConnectionException

public SQLTransientConnectionException()
构造一个 SQLTransientConnectionException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLTransientConnectionException

public SQLTransientConnectionException(String reason)
构造一个带有给定 reason 的 SQLTransientConnectionException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLTransientConnectionException

public SQLTransientConnectionException(String reason,
                                       String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientConnectionException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLTransientConnectionException

public SQLTransientConnectionException(String reason,
                                       String SQLState,
                                       int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientConnectionException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLTransientConnectionException

public SQLTransientConnectionException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientConnectionException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransientConnectionException

public SQLTransientConnectionException(String reason,
                                       Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientConnectionException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransientConnectionException

public SQLTransientConnectionException(String reason,
                                       String SQLState,
                                       Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientConnectionException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransientConnectionException

public SQLTransientConnectionException(String reason,
                                       String SQLState,
                                       int vendorCode,
                                       Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientConnectionException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLTransientException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLTransientException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLTransientException
所有已实现的接口：
Serializable, Iterable<Throwable>
直接已知子类：
SQLTimeoutException, SQLTransactionRollbackException, SQLTransientConnectionException
public class SQLTransientException
extends SQLException

没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
SQLTransientException()
构造一个 SQLTransientException 对象。
SQLTransientException(String reason)
构造一个带有给定 reason 的 SQLTransientException 对象。
SQLTransientException(String reason, String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientException 对象。
SQLTransientException(String reason, String SQLState, int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientException 对象。
SQLTransientException(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。
SQLTransientException(String reason, String SQLState, Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。
SQLTransientException(String reason, Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。
SQLTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientException 对象。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLTransientException

public SQLTransientException()
构造一个 SQLTransientException 对象。reason 和 SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

从以下版本开始：
1.6

SQLTransientException

public SQLTransientException(String reason)
构造一个带有给定 reason 的 SQLTransientException 对象。SQLState 初始化为 null，供应商代码初始化为 0。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
从以下版本开始：
1.6

SQLTransientException

public SQLTransientException(String reason,
                             String SQLState)
构造一个带有给定 reason 和 SQLState 的 SQLTransientException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码初始化为 0。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
从以下版本开始：
1.6

SQLTransientException

public SQLTransientException(String reason,
                             String SQLState,
                             int vendorCode)
构造一个带有给定 reason、SQLState 和 vendorCode 的 SQLTransientException 对象。 cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
从以下版本开始：
1.6

SQLTransientException

public SQLTransientException(Throwable cause)
构造一个带有给定 cause 的 SQLTransientException 对象。SQLState 初始化为 null，供应商代码初始化为 0。如果 cause==null，那么 reason 初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransientException

public SQLTransientException(String reason,
                             Throwable cause)
构造一个带有给定 reason 和 cause 的 SQLTransientException 对象。SQLState 初始化为 null，供应商代码初始化为 0。

参数：
reason - 对异常的描述。
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransientException

public SQLTransientException(String reason,
                             String SQLState,
                             Throwable cause)
构造一个带有给定 reason、SQLState 和 cause 的 SQLTransientException 对象。供应商代码初始化为 0。

参数：
reason - 对异常的描述。
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6

SQLTransientException

public SQLTransientException(String reason,
                             String SQLState,
                             int vendorCode,
                             Throwable cause)
构造一个带有给定 reason、SQLState、vendorCode 和 cause 的 SQLTransientException 对象。

参数：
reason - 对异常的描述
SQLState - 标识异常的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的异常代码
cause - 此 SQLException 的底层原因（保存此原因，以供以后通过 getCause() 方法获取）；可以为 null，表示 cause 不存在或未知。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLWarning (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 SQLWarning

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  java.sql.SQLWarning
所有已实现的接口：
Serializable, Iterable<Throwable>
直接已知子类：
DataTruncation
public class SQLWarning
extends SQLException

提供关于数据库访问警告信息的异常。这些警告直接链接到导致报告警告的方法所在的对象。

警告可以从 Connection、Statement 和 ResultSet 对象中获得。试图在已经关闭的连接上获取警告将导致抛出异常。类似地，试图在已经关闭的语句上或已经关闭的结果集上获取警告也将导致抛出异常。注意，关闭语句时还会关闭它可能生成的结果集。

另请参见：
Connection.getWarnings(),
Statement.getWarnings(),
ResultSet.getWarnings(),
序列化表格

构造方法摘要
SQLWarning()
构造一个 SQLWarning 对象。
SQLWarning(String reason)
构造一个具有给定 reason 的 SQLWarning 对象。
SQLWarning(String reason, String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLWarning 对象。
SQLWarning(String reason, String SQLState, int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLWarning 对象。
SQLWarning(String reason, String SQLState, int vendorCode, Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。
SQLWarning(String reason, String SQLState, Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。
SQLWarning(String reason, Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。
SQLWarning(Throwable cause)
构造一个具有给定 cause 的 SQLWarning 对象。
方法摘要
SQLWarning | getNextWarning() 通过 setNextWarning 获取链接到此 SQLWarning 对象的警告。
void | setNextWarning(SQLWarning w) 将 SQLWarning 对象添加到链接的末尾。
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SQLWarning

public SQLWarning(String reason,
                  String SQLState,
                  int vendorCode)
构造一个具有给定 reason、SQLState 和 vendorCode 的 SQLWarning 对象。cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对警告的描述
SQLState - 标识警告的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的警告代码

SQLWarning

public SQLWarning(String reason,
                  String SQLState)
构造一个具有给定 reason 和 SQLState 的 SQLWarning 对象。cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。供应商代码被初始化为 0。

参数：
reason - 对警告的描述
SQLState - 标识警告的 XOPEN 或 SQL 2003 代码

SQLWarning

public SQLWarning(String reason)
构造一个具有给定 reason 的 SQLWarning 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

参数：
reason - 对警告的描述

SQLWarning

public SQLWarning()
构造一个 SQLWarning 对象。reason 和 SQLState 被初始化为 null，供应商代码被初始化为 0。cause 没有初始化，随后可以调用 Throwable.initCause(java.lang.Throwable) 方法初始化。

SQLWarning

public SQLWarning(Throwable cause)
构造一个具有给定 cause 的 SQLWarning 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。如果 cause==null，则 reason 被初始化为 null；如果 cause!=null，则初始化为 cause.toString()。

参数：
cause - 导致此 SQLWarning 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。

SQLWarning

public SQLWarning(String reason,
                  Throwable cause)
构造一个具有给定 reason 和 cause 的 SQLWarning 对象。SQLState 被初始化为 null，供应商代码被初始化为 0。

参数：
reason - 对警告的描述
cause - 导致此 SQLWarning 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。

SQLWarning

public SQLWarning(String reason,
                  String SQLState,
                  Throwable cause)
构造一个具有给定 reason、SQLState 和 cause 的 SQLWarning 对象。供应商代码被初始化为 0。

参数：
reason - 对警告的描述
SQLState - 标识警告的 XOPEN 或 SQL:2003 代码
cause - 导致此 SQLWarning 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。

SQLWarning

public SQLWarning(String reason,
                  String SQLState,
                  int vendorCode,
                  Throwable cause)
构造一个具有给定 reason、SQLState、vendorCode 和 cause 的 SQLWarning 对象。

参数：
reason - 对警告的描述
SQLState - 标识警告的 XOPEN 或 SQL:2003 代码
vendorCode - 特定于数据库供应商的警告代码
cause - 导致此 SQLWarning 的底层原因（保存该 cause，以供以后通过 getCause() 方法获取）；此参数可以为 null，指示 cause 不存在或未知。
方法详细信息

getNextWarning

public SQLWarning getNextWarning()
通过 setNextWarning 获取链接到此 SQLWarning 对象的警告。

返回：
链接中的下一个 SQLException 对象；如果不存在，则返回 null
另请参见：
setNextWarning(java.sql.SQLWarning)

setNextWarning

public void setNextWarning(SQLWarning w)
将 SQLWarning 对象添加到链接的末尾。

参数：
w - SQLException 链接的新末尾
另请参见：
getNextWarning()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Statement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Statement

所有超级接口：
Wrapper
所有已知子接口：
CallableStatement, PreparedStatement
public interface Statement
extends Wrapper

用于执行静态 SQL 语句并返回它所生成结果的对象。

在默认情况下，同一时间每个 Statement 对象在只能打开一个 ResultSet 对象。因此，如果读取一个 ResultSet 对象与读取另一个交叉，则这两个对象必须是由不同的 Statement 对象生成的。如果存在某个语句的打开的当前 ResultSet 对象，则 Statement 接口中的所有执行方法都会隐式关闭它。

另请参见：
Connection.createStatement(), ResultSet

字段摘要
static int | CLOSE_ALL_RESULTS 该常量指示调用 getMoreResults 时应该关闭以前一直打开的所有 ResultSet 对象。
static int | CLOSE_CURRENT_RESULT 该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。
static int | EXECUTE_FAILED 该常量指示在执行批量语句时发生错误。
static int | KEEP_CURRENT_RESULT 该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。
static int | NO_GENERATED_KEYS 该常量指示生成的键应该不可用于获取。
static int | RETURN_GENERATED_KEYS 该常量指示生成的键应该可用于获取。
static int | SUCCESS_NO_INFO 该常量指示批量语句执行成功但不存在受影响的可用行数计数。
方法摘要
void | addBatch(String sql) 将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。
void | cancel() 如果 DBMS 和驱动程序都支持中止 SQL 语句，则取消此 Statement 对象。
void | clearBatch() 清空此 Statement 对象的当前 SQL 命令列表。
void | clearWarnings() 清除在此 Statement 对象上报告的所有警告。
void | close() 立即释放此 Statement 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
boolean | execute(String sql) 执行给定的 SQL 语句，该语句可能返回多个结果。
boolean | execute(String sql, int autoGeneratedKeys) 执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。
boolean | execute(String sql, int[] columnIndexes) 执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
boolean | execute(String sql, String[] columnNames) 执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
int[] | executeBatch() 将一批命令提交给数据库来执行，如果全部命令执行成功，则返回更新计数组成的数组。
ResultSet | executeQuery(String sql) 执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。
int | executeUpdate(String sql) 执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。
int | executeUpdate(String sql, int autoGeneratedKeys) 执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。
int | executeUpdate(String sql, int[] columnIndexes) 执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
int | executeUpdate(String sql, String[] columnNames) 执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
Connection | getConnection() 获取生成此 Statement 对象的 Connection 对象。
int | getFetchDirection() 获取从数据库表获取行的方向，该方向是根据此 Statement 对象生成的结果集合的默认值。
int | getFetchSize() 获取结果集合的行数，该数是根据此 Statement 对象生成的 ResultSet 对象的默认获取大小。
ResultSet | getGeneratedKeys() 获取由于执行此 Statement 对象而创建的所有自动生成的键。
int | getMaxFieldSize() 获取可以为此 Statement 对象所生成 ResultSet 对象中的字符和二进制列值返回的最大字节数。
int | getMaxRows() 获取由此 Statement 对象生成的 ResultSet 对象可以包含的最大行数。
boolean | getMoreResults() 移动到此 Statement 对象的下一个结果，如果其为 ResultSet 对象，则返回 true，并隐式关闭利用方法 getResultSet 获取的所有当前 ResultSet 对象。
boolean | getMoreResults(int current) 将此 Statement 对象移动到下一个结果，根据给定标志指定的指令处理所有当前 ResultSet 对象；如果下一个结果为 ResultSet 对象，则返回 true。
int | getQueryTimeout() 获取驱动程序等待 Statement 对象执行的秒数。
ResultSet | getResultSet() 以 ResultSet 对象的形式获取当前结果。
int | getResultSetConcurrency() 获取此 Statement 对象生成的 ResultSet 对象的结果集合并发性。
int | getResultSetHoldability() 获取此 Statement 对象生成的 ResultSet 对象的结果集合可保存性。
int | getResultSetType() 获取此 Statement 对象生成的 ResultSet 对象的结果集合类型。
int | getUpdateCount() 以更新计数的形式获取当前结果；如果结果为 ResultSet 对象或没有更多结果，则返回 -1。
SQLWarning | getWarnings() 获取此 Statement 对象上的调用报告的第一个警告。
boolean | isClosed() 获取是否已关闭了此 Statement 对象。
boolean | isPoolable() 返回指示 Statement 是否是可池化的值。
void | setCursorName(String name) 将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。
void | setEscapeProcessing(boolean enable) 将转义处理设置为开或关。
void | setFetchDirection(int direction) 向驱动程序提供关于方向的提示，在使用此 Statement 对象创建的 ResultSet 对象中将按该方向处理行。
void | setFetchSize(int rows) 为 JDBC 驱动程序提供一个提示，它提示此 Statement 生成的 ResultSet 对象需要更多行时应该从数据库获取的行数。
void | setMaxFieldSize(int max) 设置此 Statement 对象生成的 ResultSet 对象中字符和二进制列值可以返回的最大字节数限制。
void | setMaxRows(int max) 将此 Statement 对象生成的所有 ResultSet 对象可以包含的最大行数限制设置为给定数。
void | setPoolable(boolean poolable) 请求将 Statement 池化或非池化。
void | setQueryTimeout(int seconds) 将驱动程序等待 Statement 对象执行的秒数设置为给定秒数。
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

字段详细信息

CLOSE_CURRENT_RESULT

static final int CLOSE_CURRENT_RESULT
该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。

从以下版本开始：
1.4
另请参见：
常量字段值

KEEP_CURRENT_RESULT

static final int KEEP_CURRENT_RESULT
该常量指示调用 getMoreResults 时应该关闭当前 ResultSet 对象。

从以下版本开始：
1.4
另请参见：
常量字段值

CLOSE_ALL_RESULTS

static final int CLOSE_ALL_RESULTS
该常量指示调用 getMoreResults 时应该关闭以前一直打开的所有 ResultSet 对象。

从以下版本开始：
1.4
另请参见：
常量字段值

SUCCESS_NO_INFO

static final int SUCCESS_NO_INFO
该常量指示批量语句执行成功但不存在受影响的可用行数计数。

从以下版本开始：
1.4
另请参见：
常量字段值

EXECUTE_FAILED

static final int EXECUTE_FAILED
该常量指示在执行批量语句时发生错误。

从以下版本开始：
1.4
另请参见：
常量字段值

RETURN_GENERATED_KEYS

static final int RETURN_GENERATED_KEYS
该常量指示生成的键应该可用于获取。

从以下版本开始：
1.4
另请参见：
常量字段值

NO_GENERATED_KEYS

static final int NO_GENERATED_KEYS
该常量指示生成的键应该不可用于获取。

从以下版本开始：
1.4
另请参见：
常量字段值
方法详细信息

executeQuery

ResultSet executeQuery(String sql)
                       throws SQLException
执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。

参数：
sql - 要发送给数据库的 SQL 语句，通常为静态 SQL SELECT 语句
返回：
包含给定查询所生成数据的 ResultSet 对象；永远不能为 null
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者给定 SQL 语句生成单个 ResultSet 对象之外的任何其他内容

executeUpdate

int executeUpdate(String sql)
                  throws SQLException
执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。

参数：
sql - SQL 数据操作语言（Data Manipulation Language，DML）语句，如 INSERT、UPDATE 或 DELETE；或者不返回任何内容的 SQL 语句，如 DDL 语句。
返回：
(1) 对于 SQL 数据操作语言 (DML) 语句，返回行计数 (2) 对于什么都不返回的 SQL 语句，返回 0
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者给定的 SQL 语句生成 ResultSet 对象

close

void close()
           throws SQLException
立即释放此 Statement 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。一般来说，使用完后立即释放资源是一个好习惯，这样可以避免对数据库资源的占用。

在已经关闭的 Statement 对象上调用 close 方法无效。

注：关闭 Statement 对象时，还将同时关闭其当前的 ResultSet 对象（如果有）。

抛出：
SQLException - 如果发生数据库访问错误

getMaxFieldSize

int getMaxFieldSize()
                    throws SQLException
获取可以为此 Statement 对象所生成 ResultSet 对象中的字符和二进制列值返回的最大字节数。此限制仅应用于 BINARY、VARBINARY、LONGVARBINARY、CHAR、VARCHAR、NCHAR、NVARCHAR、LONGNVARCHAR 和 LONGVARCHAR 列。如果超过了该限制，则直接丢弃多出的数据。

返回：
存储字符和二进制值的列的当前列大小限制；0 表示没有任何限制
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
另请参见：
setMaxFieldSize(int)

setMaxFieldSize

void setMaxFieldSize(int max)
                     throws SQLException
设置此 Statement 对象生成的 ResultSet 对象中字符和二进制列值可以返回的最大字节数限制。此限制仅应用于 BINARY、VARBINARY、LONGVARBINARY、CHAR、VARCHAR、NCHAR、NVARCHAR、LONGNVARCHAR 和 LONGVARCHAR 字段。如果超过了该限制，则直接丢弃多出的数据。为了获得最大的可移植性，应该使用大于 256 的值。

参数：
max - 以字节为单位的新列大小限制；0 表示没有任何限制
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者不满足条件 max >= 0
另请参见：
getMaxFieldSize()

getMaxRows

int getMaxRows()
               throws SQLException
获取由此 Statement 对象生成的 ResultSet 对象可以包含的最大行数。如果超过了此限制，则直接撤消多出的行。

返回：
由此 Statement 对象生成的 ResultSet 对象的当前最大行数；0 表示不存在任何限制
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
另请参见：
setMaxRows(int)

setMaxRows

void setMaxRows(int max)
                throws SQLException
将此 Statement 对象生成的所有 ResultSet 对象可以包含的最大行数限制设置为给定数。如果超过了该限制，则直接撤消多出的行。

参数：
max - 新的最大行数限制；0 表示没有任何限制
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者不满足条件 max >= 0
另请参见：
getMaxRows()

setEscapeProcessing

void setEscapeProcessing(boolean enable)
                         throws SQLException
将转义处理设置为开或关。如果转义扫描为开启（默认值），则驱动程序在将 SQL 语句发送到数据库之前执行转义替换。注：因为准备的语句通常在进行此调用之前解析，所以对 PreparedStatements 对象禁用转义处理无效。

参数：
enable - 为 true 表示启用转义处理；为 false 表示禁用转义处理
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法

getQueryTimeout

int getQueryTimeout()
                    throws SQLException
获取驱动程序等待 Statement 对象执行的秒数。如果超过该限制，则抛出 SQLException。

返回：
以秒为单位的当前查询超时限制；0 表示不存在任何限制
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
另请参见：
setQueryTimeout(int)

setQueryTimeout

void setQueryTimeout(int seconds)
                     throws SQLException
将驱动程序等待 Statement 对象执行的秒数设置为给定秒数。如果超过该限制，则抛出 SQLException。JDBC 驱动程序必须将此限制应用于 execute、executeQuery 和 executeUpdate 方法。JDBC 驱动程序实现也可以将此限制应用于 ResultSet 方法（有关详细信息，请参考驱动程序供应商文档）。

参数：
seconds - 以秒为单位的查询超时限制；0 表示没有任何限制
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者不满足条件 seconds >= 0
另请参见：
getQueryTimeout()

cancel

void cancel()
            throws SQLException
如果 DBMS 和驱动程序都支持中止 SQL 语句，则取消此 Statement 对象。一个线程可以使用此方法取消另一个线程正在执行的语句。

抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

getWarnings

SQLWarning getWarnings()
                       throws SQLException
获取此 Statement 对象上的调用报告的第一个警告。后续的 Statement 对象警告将链接到此 SQLWarning 对象上。

每次（重新）执行语句时，都会自动清除警告链。不可以在关闭的 Statement 对象上调用此方法，这样做将导致抛出 SQLException。

注：如果要处理 ResultSet 对象，则与该 ResultSet 对象上的读操作相关联的所有警告都链接到它上面，而不是链接到生成它的 Statement 对象上。

返回：
第一个 SQLWarning 对象；如果不存在任何警告，则返回 null
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法

clearWarnings

void clearWarnings()
                   throws SQLException
清除在此 Statement 对象上报告的所有警告。调用此方法后，在为此 Statement 对象报告新的警告之前，getWarnings 方法将一直返回 null。

抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法

setCursorName

void setCursorName(String name)
                   throws SQLException
将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。然后，可以在 SQL 位置更新或删除语句中使用该名称来标识由此语句生成的 ResultSet 对象中的当前行。如果数据库不支持位置更新/删除，则此方法为无操作 (noop)。为了确保指针具有支持更新的适当隔离级别，指针的 SELECT 语句的形式应该为 SELECT FOR UPDATE。如果 FOR UPDATE 不存在，则位置更新可能失败。

注：按照定义，位置更新和删除必须由生成的用于放置的 ResultSet 对象之外的某个 Statement 对象来执行。此外，在连接中指针名称还必须是唯一的。

参数：
name - 新指针名称，该名称在连接中必须是唯一的
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

execute

boolean execute(String sql)
                throws SQLException
执行给定的 SQL 语句，该语句可能返回多个结果。在某些（不常见）情形下，单个 SQL 语句可能返回多个结果集合和/或更新计数。这一点通常可以忽略，除非正在 (1) 执行已知可能返回多个结果的存储过程或者 (2) 动态执行未知 SQL 字符串。

execute 方法执行 SQL 语句并指示第一个结果的形式。然后，必须使用方法 getResultSet 或 getUpdateCount 来获取结果，使用 getMoreResults 来移动后续结果。

参数：
sql - 任何 SQL 语句
返回：
如果第一个结果为 ResultSet 对象，则返回 true；如果其为更新计数或者不存在任何结果，则返回 false
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
另请参见：
getResultSet(),
getUpdateCount(),
getMoreResults()

getResultSet

ResultSet getResultSet()
                       throws SQLException
以 ResultSet 对象的形式获取当前结果。每个结果只应调用一次此方法。

返回：
以 ResultSet 对象的形式返回当前结果；如果结果是更新计数或没有更多的结果，则返回 null
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
另请参见：
execute(java.lang.String)

getUpdateCount

int getUpdateCount()
                   throws SQLException
以更新计数的形式获取当前结果；如果结果为 ResultSet 对象或没有更多结果，则返回 -1。每个结果只应调用一次此方法。

返回：
以更新计数的形式返回当前结果；如果当前结果为 ResultSet 对象或没有更多结果，则返回 -1
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
另请参见：
execute(java.lang.String)

getMoreResults

boolean getMoreResults()
                       throws SQLException
移动到此 Statement 对象的下一个结果，如果其为 ResultSet 对象，则返回 true，并隐式关闭利用方法 getResultSet 获取的所有当前 ResultSet 对象。

当以下表达式为 true 时没有更多结果：

     // stmt is a Statement object
     ((stmt.getMoreResults() == false) && (stmt.getUpdateCount() == -1))

返回：
如果下一个结果为 ResultSet 对象，则返回 true；如果其为更新计数或不存在更多结果，则返回 false
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
另请参见：
execute(java.lang.String)

setFetchDirection

void setFetchDirection(int direction)
                       throws SQLException
向驱动程序提供关于方向的提示，在使用此 Statement 对象创建的 ResultSet 对象中将按该方向处理行。默认值为 ResultSet.FETCH_FORWARD。

注意，此方法为此 Statement 对象生成的结果集合设置默认获取方向。每个结果集合都具有它自己用于获取和设置其自身获取方向的方法。

参数：
direction - 用于处理行的初始方向
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者给定的方向不是 ResultSet.FETCH_FORWARD、ResultSet.FETCH_REVERSE 和 ResultSet.FETCH_UNKNOWN 之一
从以下版本开始：
1.2
另请参见：
getFetchDirection()

getFetchDirection

int getFetchDirection()
                      throws SQLException
获取从数据库表获取行的方向，该方向是根据此 Statement 对象生成的结果集合的默认值。如果此 Statement 对象没有通过调用方法 setFetchDirection 设置获取方向，则返回值是特定于实现的。

返回：
根据此 Statement 对象生成的结果集合的默认获取方向
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
从以下版本开始：
1.2
另请参见：
setFetchDirection(int)

setFetchSize

void setFetchSize(int rows)
                  throws SQLException
为 JDBC 驱动程序提供一个提示，它提示此 Statement 生成的 ResultSet 对象需要更多行时应该从数据库获取的行数。指定的行数仅影响使用此语句创建的结果集合。如果指定的值为 0，则忽略该提示。默认值为 0。

参数：
rows - 要获取的行数
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者不满足条件 rows >= 0。
从以下版本开始：
1.2
另请参见：
getFetchSize()

getFetchSize

int getFetchSize()
                 throws SQLException
获取结果集合的行数，该数是根据此 Statement 对象生成的 ResultSet 对象的默认获取大小。如果此 Statement 对象没有通过调用方法 setFetchSize 设置获取大小，则返回值是特定于实现的。

返回：
根据此 Statement 对象生成的结果集合的默认获取大小
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
从以下版本开始：
1.2
另请参见：
setFetchSize(int)

getResultSetConcurrency

int getResultSetConcurrency()
                            throws SQLException
获取此 Statement 对象生成的 ResultSet 对象的结果集合并发性。

返回：
ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
从以下版本开始：
1.2

getResultSetType

int getResultSetType()
                     throws SQLException
获取此 Statement 对象生成的 ResultSet 对象的结果集合类型。

返回：
ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE 之一
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
从以下版本开始：
1.2

addBatch

void addBatch(String sql)
              throws SQLException
将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。通过调用方法 executeBatch 可以批量执行此列表中的命令。

参数：
sql - 通常此参数为 SQL INSERT 或 UPDATE 语句
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者驱动程序不支持批量更新
从以下版本开始：
1.2
另请参见：
executeBatch(), DatabaseMetaData.supportsBatchUpdates()

clearBatch

void clearBatch()
                throws SQLException
清空此 Statement 对象的当前 SQL 命令列表。

抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者驱动程序不支持批量更新
从以下版本开始：
1.2
另请参见：
addBatch(java.lang.String), DatabaseMetaData.supportsBatchUpdates()

executeBatch

int[] executeBatch()
                   throws SQLException
将一批命令提交给数据库来执行，如果全部命令执行成功，则返回更新计数组成的数组。返回数组的 int 元素的排序对应于批中的命令，批中的命令根据被添加到批中的顺序排序。方法 executeBatch 返回的数组中的元素可能为以下元素之一：
  1. 大于等于 0 的数 - 指示成功处理了命令，是给出执行命令所影响数据库中行数的更新计数
  2. SUCCESS_NO_INFO 的值 - 指示成功执行了命令，但受影响的行数是未知的

    如果批量更新中的命令之一无法正确执行，则此方法抛出 BatchUpdateException，并且 JDBC 驱动程序可能继续处理批处理中的剩余命令，也可能不执行。无论如何，驱动程序的行为必须与特定的 DBMS 一致，要么始终继续处理命令，要么永远不继续处理命令。如果驱动程序在某一次失败后继续进行处理，则 BatchUpdateException.getUpdateCounts 方法返回的数组将包含的元素与批中存在的命令一样多，并且其中至少有一个元素将为：

  3. EXECUTE_FAILED 的值 - 指示未能成功执行命令，仅当命令失败后驱动程序继续处理命令时出现

在 Java 2 SDK, Standard Edition, 1.3 版中已经修改了可能的实现和返回值，以适应抛出 BatchUpdateException 对象后在批量更新中继续处理命令的选项。

返回：
包含批中每个命令的一个元素的更新计数所组成的数组。数组的元素根据将命令添加到批中的顺序排序。
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者驱动程序不支持批量语句。如果未能正确执行发送到数据库的命令之一或者尝试返回结果集合，则抛出 BatchUpdateException（SQLException 的子类）。
从以下版本开始：
1.3
另请参见：
addBatch(java.lang.String), DatabaseMetaData.supportsBatchUpdates()

getConnection

Connection getConnection()
                         throws SQLException
获取生成此 Statement 对象的 Connection 对象。

返回：
此语句生成的连接
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
从以下版本开始：
1.2

getMoreResults

boolean getMoreResults(int current)
                       throws SQLException
将此 Statement 对象移动到下一个结果，根据给定标志指定的指令处理所有当前 ResultSet 对象；如果下一个结果为 ResultSet 对象，则返回 true。

当以下表达式为 true 时没有更多结果：

     // stmt is a Statement object
     ((stmt.getMoreResults(current) == false) && (stmt.getUpdateCount() == -1))

参数：
current - 下列 Statement 常量之一，这些常量指示将对使用 getResultSet 方法获取的当前 ResultSet 对象发生的操作：Statement.CLOSE_CURRENT_RESULT、Statement.KEEP_CURRENT_RESULT 或 Statement.CLOSE_ALL_RESULTS
返回：
如果下一个结果为 ResultSet 对象，则返回 true；如果其为更新计数或者不存在更多的结果，则返回 false
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者提供的参数不是以下参数之一：Statement.CLOSE_CURRENT_RESULT、Statement.KEEP_CURRENT_RESULT 或 Statement.CLOSE_ALL_RESULTS
SQLFeatureNotSupportedException - 如果 DatabaseMetaData.supportsMultipleOpenResults 返回 false，并且 Statement.KEEP_CURRENT_RESULT 或 Statement.CLOSE_ALL_RESULTS 作为参数提供。
从以下版本开始：
1.4
另请参见：
execute(java.lang.String)

getGeneratedKeys

ResultSet getGeneratedKeys()
                           throws SQLException
获取由于执行此 Statement 对象而创建的所有自动生成的键。如果此 Statement 对象没有生成任何键，则返回空的 ResultSet 对象。

注：如果未指定表示自动生成键的列，则 JDBC 驱动程序实现将确定最能表示自动生成键的列。

返回：
包含通过执行此 Statement 对象自动生成的键的 ResultSet 对象
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

executeUpdate

int executeUpdate(String sql,
                  int autoGeneratedKeys)
                  throws SQLException
执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。如果该 SQL 语句不是 INSERT 语句，或者不是可以返回自动生成键的 SQL 语句（这些语句的列表是特定于供应商的），则驱动程序将忽略该标志。

参数：
sql - SQL 数据操作语言（Data Manipulation Language，DML）语句，如 INSERT、UPDATE 或 DELETE；或者是不返回任何内容的 SQL 语句，如 DDL 语句。
autoGeneratedKeys - 指示自动生成的键是否可用于获取的标志；以下常量之一：Statement.RETURN_GENERATED_KEYS Statement.NO_GENERATED_KEYS
返回：
(1) 对于 SQL 数据操作语言 (DML) 语句，返回行计数 (2) 对于不返回任何内容的 SQL 语句，返回 0
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，给定的 SQL 语句返回 ResultSet 对象，或者给定的常量不是允许的常量之一
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持带 Statement.RETURN_GENERATED_KEYS 常量的此方法
从以下版本开始：
1.4

executeUpdate

int executeUpdate(String sql,
                  int[] columnIndexes)
                  throws SQLException
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。此数组包含目标表中的列的索引，该目标表包含应该可获取的自动生成的键。如果该 SQL 语句不是 INSERT 语句，或者不是可以返回自动生成键的 SQL 语句（这些语句的列表是特定于供应商的），则驱动程序将忽略该数组。

参数：
sql - SQL 数据操作语言 (DML) 语句，如 INSERT、UPDATE 或 DELETE；或者不返回任何内容的 SQL 语句，如 DDL 语句。
columnIndexes - 指示应该从插入行返回列的列索引数组
返回：
(1) 对于 SQL 数据操作语言 (DML) 语句，返回行计数 (2) 对于不返回任何内容的 SQL 语句，返回 0
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，SQL 语句返回 ResultSet 对象，或者提供给此方法的第二个参数不是其元素为有效列索引的 int 数组
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

executeUpdate

int executeUpdate(String sql,
                  String[] columnNames)
                  throws SQLException
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。此数组包含目标表中的列的名称，该目标表包含应该可获取的自动生成的键。如果该 SQL 语句不是 INSERT 语句，或者不是可以返回自动生成键的 SQL 语句（这些语句的列表是特定于供应商的），则驱动程序将忽略该数组。

参数：
sql - SQL 数据操作语言 (DML) 语句，如 INSERT、UPDATE 或 DELETE；或者不返回任何内容的 SQL 语句，如 DDL 语句。
columnNames - 应该从插入行返回的列的名称数组
返回：
或者为 INSERT、UPDATE 或 DELETE 语句，或者为 0，表示不返回任何内容的 SQL 语句
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，SQL 语句返回 ResultSet 对象，或者提供给此方法的第二个参数不是其元素为有效列名称的 String 数组
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

execute

boolean execute(String sql,
                int autoGeneratedKeys)
                throws SQLException
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。如果该 SQL 语句不是 INSERT 语句，或者不是可以返回自动生成键的 SQL 语句（这些语句的列表是特定于供应商的），则驱动程序将忽略此信号。

在某些（不常见）情形下，单个 SQL 语句可能返回多个结果集合和/或更新计数。这一点通常可以忽略，除非正在 (1) 执行已知可能返回多个结果的存储过程或者 (2) 动态执行未知 SQL 字符串。

execute 方法执行 SQL 语句并指示第一个结果的形式。然后，必须使用方法 getResultSet 或 getUpdateCount 来获取结果，使用 getMoreResults 来移动后续结果。

参数：
sql - 任何 SQL 语句
autoGeneratedKeys - 指示是否应该使用 getGeneratedKeys 方法使自动生成的键可用于获取的常量；以下常量之一：Statement.RETURN_GENERATED_KEYS 或 Statement.NO_GENERATED_KEYS
返回：
如果第一个结果为 ResultSet 对象，则返回 true；如果其为更新计数或者不存在任何结果，则返回 false
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者提供给此方法的第二个参数不是 Statement.RETURN_GENERATED_KEYS 或 Statement.NO_GENERATED_KEYS。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持带 Statement.RETURN_GENERATED_KEYS 常量的此方法
从以下版本开始：
1.4
另请参见：
getResultSet(),
getUpdateCount(),
getMoreResults(),
getGeneratedKeys()

execute

boolean execute(String sql,
                int[] columnIndexes)
                throws SQLException
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。此数组包含目标表中的列的索引，而该目标表包含应该使其可用的自动生成的键。如果该 SQL 语句不是 INSERT 语句，或者不是可以返回自动生成键的 SQL 语句（这些语句的列表是特定于供应商的），则驱动程序将忽略该数组。

在某些（不常见）情形下，单个 SQL 语句可能返回多个结果集合和/或更新计数。这一点通常可以忽略，除非正在 (1) 执行已知可能返回多个结果的存储过程或者 (2) 动态执行未知 SQL 字符串。

execute 方法执行 SQL 语句并指示第一个结果的形式。然后，必须使用方法 getResultSet 或 getUpdateCount 来获取结果，使用 getMoreResults 来移动后续结果。

参数：
sql - 任何 SQL 语句
columnIndexes - 通过调用方法 getGeneratedKeys 应该可用于获取的插入行中的列索引数组
返回：
如果第一个结果为 ResultSet 对象，则返回 true；如果其为更新计数或者不存在任何结果，则返回 false
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者传递给此方法的 int 数组中的元素不是有效的列索引
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getResultSet(),
getUpdateCount(),
getMoreResults()

execute

boolean execute(String sql,
                String[] columnNames)
                throws SQLException
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。此数组包含目标表中的列的名称，而该目标表包含应该使其可用的自动生成的键。如果该 SQL 语句不是 INSERT 语句，或者不是可以返回自动生成键的 SQL 语句（这些语句的列表是特定于供应商的），则驱动程序将忽略该数组。

在某些（不常见）情形下，单个 SQL 语句可能返回多个结果集合和/或更新计数。这一点通常可以忽略，除非正在 (1) 执行已知可能返回多个结果的存储过程或者 (2) 动态执行未知 SQL 字符串。

execute 方法执行 SQL 语句并指示第一个结果的形式。然后，必须使用方法 getResultSet 或 getUpdateCount 来获取结果，使用 getMoreResults 来移动后续结果。

参数：
sql - 任何 SQL 语句
columnNames - 通过调用方法 getGeneratedKeys 应该可用于获取的插入行中的列名称数组
返回：
如果下一个结果为 ResultSet 对象，则返回 true；如果其为更新计数或者不存在更多结果，则返回 false
抛出：
SQLException - 如果发生数据库访问错误，在已关闭的 Statement 上调用此方法，或者传递给此方法的 String 数组的元素不是有效的列名称
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
getResultSet(),
getUpdateCount(),
getMoreResults(),
getGeneratedKeys()

getResultSetHoldability

int getResultSetHoldability()
                            throws SQLException
获取此 Statement 对象生成的 ResultSet 对象的结果集合可保存性。

返回：
ResultSet.HOLD_CURSORS_OVER_COMMIT 或 ResultSet.CLOSE_CURSORS_AT_COMMIT
抛出：
SQLException - 如果发生数据库访问错误，或者在已关闭的 Statement 上调用此方法
从以下版本开始：
1.4

isClosed

boolean isClosed()
                 throws SQLException
获取是否已关闭了此 Statement 对象。如果已经对它调用了 close 方法，或者它自动关闭，则 Statement 已关闭。

返回：
如果此 Statement 对象关闭，则返回 true；如果它仍是打开的，则返回 false
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

setPoolable

void setPoolable(boolean poolable)
                 throws SQLException
请求将 Statement 池化或非池化。指定值是语句池实现的一个提示，指示应用程序是否希望语句被池化。关于是否使用该提示，由语句池管理器决定。

语句的可池化的值对驱动程序实现的内部语句缓存以及应用程序服务器和其他应用程序实现的外部语句缓存都适用。

默认情况下，Statement 在创建时不是可池化的，而 PreparedStatement 和 CallableStatement 在创建时是可池化的。

参数：
poolable - 如果为 true，则请求将语句池化；如果为 false，则不池化语句

抛出：
SQLException - 如果在已关闭的 Statement 上调用此方法

从以下版本开始：
1.6

isPoolable

boolean isPoolable()
                   throws SQLException
返回指示 Statement 是否是可池化的值。

返回：
如果 Statement 是可池化的，则返回 true；否则返回 false

抛出：
SQLException - 如果在已关闭的 Statement 上调用此方法

从以下版本开始：
1.6

另请参见：
setPoolable(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Struct (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Struct

所有已知实现类：
SerialStruct
public interface Struct

用于 SQL 结构化类型的 Java 编程语言中的标准映射关系。Struct 对象为它所表示的 SQL 结构化类型的每个属性包含一个值。默认情况下，只要应用程序可以引用 Struct 实例，该实例就有效。

如果 JDBC 驱动程序支持该数据类型，则必须完全实现 Struct 接口上的所有方法。

从以下版本开始：
1.2

方法摘要
Object[] | getAttributes() 生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。
Object[] | getAttributes(Map<String,Class<?>> map) 生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
String | getSQLTypeName() 获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。

方法详细信息

getSQLTypeName

String getSQLTypeName()
                      throws SQLException
获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。

返回：
SQL 结构化类型的完全限定的类型名称，此 Struct 对象是该名称的一般表示形式
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getAttributes

Object[] getAttributes()
                       throws SQLException
生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。与处理每个属性一样，此方法使用与连接关联的类型映射来自定义类型映射关系。如果在连接类型映射中不存在与属性所表示的结构类型匹配的条目，则驱动程序使用标准映射关系。

从概念上讲，此方法对结构化类型的每个属性都调用 getObject 方法并返回包含结果的 Java 数组。

返回：
包含有序属性值的数组
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2

getAttributes

Object[] getAttributes(Map<String,Class<?>> map)
                       throws SQLException
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。与处理每个属性一样，此方法使用给定类型映射表来自定义类型映射关系。如果在给定类型映射表中不存在与属性所表示的结构类型匹配的条目，则驱动程序使用标准映射关系。此方法永远不使用与 connection 关联的类型映射表。

从概念上讲，此方法对结构化类型的每个属性都调用 getObject 方法并返回包含结果的 Java 数组。

参数：
map - 从 SQL 类型名称到 Java 类的映射
返回：
包含有序属性值的数组
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Time (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 Time

java.lang.Object
    继承者  java.util.Date
        继承者  java.sql.Time
所有已实现的接口：
Serializable, Cloneable, Comparable<Date>
public class Time
extends Date

一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。Time 类添加格式化和解析操作以支持时间值的 JDBC 转义语法。

应该将日期组件设置为 1970 年 1 月 1 日的 "zero epoch" 值并且不应访问该值。

另请参见：
序列化表格

构造方法摘要
Time(int hour, int minute, int second)
已过时。 使用采用毫秒值的构造方法取代此构造方法
Time(long time)
使用毫秒时间值构造 Time 对象。
方法摘要
int | getDate() 已过时。
int | getDay() 已过时。
int | getMonth() 已过时。
int | getYear() 已过时。
void | setDate(int i) 已过时。
void | setMonth(int i) 已过时。
void | setTime(long time) 使用毫秒时间值设置 Time 对象。
void | setYear(int i) 已过时。
String | toString() 使用 JDBC 时间转义格式对时间进行格式化。
static Time | valueOf(String s) 将使用 JDBC 时间转义格式的字符串转换为 Time 值。
从类 java.util.Date 继承的方法
after, before, clone, compareTo, equals, getHours, getMinutes, getSeconds, getTime, getTimezoneOffset, hashCode, parse, setHours, setMinutes, setSeconds, toGMTString, toLocaleString, UTC
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Time

@Deprecated
public Time(int hour,
                       int minute,
                       int second)
已过时。 使用采用毫秒值的构造方法取代此构造方法

构造一个 Time 对象，用小时、分钟和秒钟的给定值对其进行初始化。驱动程序将日期组件设置为 1970 年 1 月 1 日。尝试访问 Time 对象的日期组件的任何方法都将抛出 java.lang.IllegalArgumentException。

如果给定的参数超出范围，则结果是不确定的。

参数：
hour - 0 到 23
minute - 0 到 59
second - 0 到 59

Time

public Time(long time)
使用毫秒时间值构造 Time 对象。

参数：
time - 自从 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数；负数表示在 1970 年 1 月 1 日 00:00:00 GMT 之前的毫秒数
方法详细信息

setTime

public void setTime(long time)
使用毫秒时间值设置 Time 对象。

覆盖：
类 Date 中的 setTime
参数：
time - 自从 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数；负数表示在 1970 年 1 月 1 日 00:00:00 GMT 之前的毫秒数

valueOf

public static Time valueOf(String s)
将使用 JDBC 时间转义格式的字符串转换为 Time 值。

参数：
s - 使用 "hh:mm:ss" 格式的时间
返回：
相应的 Time 对象

toString

public String toString()
使用 JDBC 时间转义格式对时间进行格式化。

覆盖：
类 Date 中的 toString
返回：
使用 hh:mm:ss 格式的 String
另请参见：
Date.toLocaleString(), Date.toGMTString()

getYear

@Deprecated
public int getYear()
已过时。

此方法已不建议使用并且不应再使用，因为 SQL TIME 值没有年 (year) 组件。

覆盖：
类 Date 中的 getYear
返回：
日期表示的年份减去 1900。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
setYear(int)

getMonth

@Deprecated
public int getMonth()
已过时。

此方法已不建议使用并且不应再使用，因为 SQL TIME 值没有月 (month) 组件。

覆盖：
类 Date 中的 getMonth
返回：
此日期所表示的月份。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
setMonth(int)

getDay

@Deprecated
public int getDay()
已过时。

此方法已不建议使用并且不应再使用，因为 SQL TIME 值没有日 (day) 组件。

覆盖：
类 Date 中的 getDay
返回：
此日期所表示的一周中的某一天。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
Calendar

getDate

@Deprecated
public int getDate()
已过时。

此方法已不建议使用并且不应再使用，因为 SQL TIME 值没有日期 (date) 组件。

覆盖：
类 Date 中的 getDate
返回：
此日期所表示的月份中的某一天。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
setDate(int)

setYear

@Deprecated
public void setYear(int i)
已过时。

此方法已不建议使用并且不应再使用，因为 SQL TIME 值没有年 (year) 组件。

覆盖：
类 Date 中的 setYear
参数：
i - 年份值。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
getYear()

setMonth

@Deprecated
public void setMonth(int i)
已过时。

此方法已不建议使用并且不应再使用，因为 SQL TIME 值没有月 (month) 组件。

覆盖：
类 Date 中的 setMonth
参数：
i - 0-11 之间的月份值。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
getMonth()

setDate

@Deprecated
public void setDate(int i)
已过时。

此方法已不建议使用并且不应再使用，因为 SQL TIME 值没有日期 (date) 组件。

覆盖：
类 Date 中的 setDate
参数：
i - 月份中 1-31 之间的某一天。
抛出：
IllegalArgumentException - 如果调用此方法
另请参见：
getDate()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Timestamp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 Timestamp

java.lang.Object
    继承者  java.util.Date
        继承者  java.sql.Timestamp
所有已实现的接口：
Serializable, Cloneable, Comparable<Date>
public class Timestamp
extends Date

一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。它通过允许小数秒到纳秒级精度的规范来添加保存 SQL TIMESTAMP 小数秒值的能力。Timestamp 也提供支持时间戳值的 JDBC 转义语法的格式化和解析操作的能力。

计算 Timestamp 对象的精度为二者之一：

  • 19 ，其为 yyyy-mm-dd hh:mm:ss 格式下的字符数
  • 20 + s ，其为 yyyy-mm-dd hh:mm:ss.[fff...] 格式下的字符数，s 表示给定 Timestamp 的标度（其小数秒精度）。

注：此类型由 java.util.Date 和单独的毫微秒值组成。只有整数秒才会存储在 java.util.Date 组件中。小数秒（毫微秒）是独立存在的。传递不是 java.sql.Timestamp 实例的对象时，Timestamp.equals(Object) 方法永远不会返回 true，因为日期的毫微秒组件是未知的。因此，相对于 java.util.Date.equals(Object) 方法而言，Timestamp.equals(Object) 方法是不对称的。此外，hashcode 方法使用底层 java.util.Date 实现并因此在其计算中不包括毫微秒。

鉴于 Timestamp 类和上述 java.util.Date 类之间的不同，建议代码一般不要将 Timestamp 值视为 java.util.Date 的实例。Timestamp 和 java.util.Date 之间的继承关系实际上指的是实现继承，而不是类型继承。

另请参见：
序列化表格

构造方法摘要
Timestamp(int year, int month, int date, int hour, int minute, int second, int nano)
已过时。 使用构造方法 Timestamp(long millis) 来代替
Timestamp(long time)
使用毫秒时间值构造 Timestamp 对象。
方法摘要
boolean | after(Timestamp ts) 指示此 Timestamp 对象是否晚于给定的 Timestamp 对象。
boolean | before(Timestamp ts) 指示此 Timestamp 对象是否早于给定的 Timestamp 对象。
int | compareTo(Date o) 将此 Timestamp 对象与给定的 Date（必须为 Timestamp 对象）相比较。
int | compareTo(Timestamp ts) 将此 Timestamp 对象与给定 Timestamp 对象相比较。
boolean | equals(Object ts) 测试此对象是否等于给定的 Timestamp 对象。
boolean | equals(Timestamp ts) 测试此 Timestamp 对象是否等于给定的 Timestamp 对象。
int | getNanos() 获取此 Timestamp 对象的 nanos 值。
long | getTime() 返回此 Timestamp 对象表示的自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。
void | setNanos(int n) 将此 Timestamp 对象的 nanos 字段设置为给定值。
void | setTime(long time) 设置此 Timestamp 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。
String | toString() 使用 JDBC 时间戳转义格式编排时间戳。
static Timestamp | valueOf(String s) 将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。
从类 java.util.Date 继承的方法
after, before, clone, getDate, getDay, getHours, getMinutes, getMonth, getSeconds, getTimezoneOffset, getYear, hashCode, parse, setDate, setHours, setMinutes, setMonth, setSeconds, setYear, toGMTString, toLocaleString, UTC
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Timestamp

@Deprecated
public Timestamp(int year,
                            int month,
                            int date,
                            int hour,
                            int minute,
                            int second,
                            int nano)
已过时。 使用构造方法 Timestamp(long millis) 来代替

构造一个 Timestamp 对象，使用给定值对其进行初始化。

参数：
year - 年减去 1900
month - 0 到 11
date - 1 到 31
hour - 0 到 23
minute - 0 到 59
second - 0 到 59
nano - 0 到 999,999,999
抛出：
IllegalArgumentException - 如果毫微参数超出范围

Timestamp

public Timestamp(long time)
使用毫秒时间值构造 Timestamp 对象。整数秒存储在底层日期值中；小数秒存储在 Timestamp 对象的 nanos 字段中。

参数：
time - 自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。负数表示 1970 年 1 月 1 日 00:00:00 GMT 之前的毫秒数。
另请参见：
Calendar
方法详细信息

setTime

public void setTime(long time)
设置此 Timestamp 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。

覆盖：
类 Date 中的 setTime
参数：
time - 毫秒数。
另请参见：
getTime(), Timestamp(long time), Calendar

getTime

public long getTime()
返回此 Timestamp 对象表示的自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。

覆盖：
类 Date 中的 getTime
返回：
此日期表示的自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。
另请参见：
setTime(long)

valueOf

public static Timestamp valueOf(String s)
将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。

参数：
s - 使用 yyyy-mm-dd hh:mm:ss[.f...] 格式的时间戳。可以省略小数秒。
返回：
相应的 Timestamp 值
抛出：
IllegalArgumentException - 如果给定的参数不具有 yyyy-mm-dd hh:mm:ss[.f...] 格式

toString

public String toString()
使用 JDBC 时间戳转义格式编排时间戳。yyyy-mm-dd hh:mm:ss.fffffffff，其中 ffffffffff 指示毫微秒。

覆盖：
类 Date 中的 toString
返回：
使用 yyyy-mm-dd hh:mm:ss.fffffffff 格式的 String 对象
另请参见：
Date.toLocaleString(), Date.toGMTString()

getNanos

public int getNanos()
获取此 Timestamp 对象的 nanos 值。

返回：
此 Timestamp 对象的小数秒组件
另请参见：
setNanos(int)

setNanos

public void setNanos(int n)
将此 Timestamp 对象的 nanos 字段设置为给定值。

参数：
n - 新小数秒组件
抛出：
IllegalArgumentException - 如果给定参数大于 999999999 或小于 0
另请参见：
getNanos()

equals

public boolean equals(Timestamp ts)
测试此 Timestamp 对象是否等于给定的 Timestamp 对象。

参数：
ts - 用于比较的 Timestamp 值
返回：
如果给定 Timestamp 对象等于此 Timestamp 对象，则返回 true，否则返回 false

equals

public boolean equals(Object ts)
测试此对象是否等于给定的 Timestamp 对象。 添加了此版本的 equals 方法，可以修复不正确的 Timestamp.equals(Timestamp) 签名，并保留与现有类文件的向后兼容性。 注：相对于基类中的 equals(Object) 方法而言，此方法是不对称的。

覆盖：
类 Date 中的 equals
参数：
ts - 要与之进行比较的 Object 值
返回：
如果给定 Object 是等于此 Timestamp 对象的 Timestamp 实例，则返回 true；否则返回 false
另请参见：
Date.getTime()

before

public boolean before(Timestamp ts)
指示此 Timestamp 对象是否早于给定的 Timestamp 对象。

参数：
ts - 要与之进行比较的 Timestamp 值
返回：
如果此 Timestamp 对象较早，则返回 true，否则返回 false

after

public boolean after(Timestamp ts)
指示此 Timestamp 对象是否晚于给定的 Timestamp 对象。

参数：
ts - 要与之进行比较的 Timestamp 值
返回：
如果此 Timestamp 对象较晚，则返回 true，否则返回 false

compareTo

public int compareTo(Timestamp ts)
将此 Timestamp 对象与给定 Timestamp 对象相比较。

参数：
ts - 要与此 Timestamp 对象进行比较的 Timestamp 对象
返回：
如果两个 Timestamp 对象相等，则返回值 0；如果此 Timestamp 对象早于给定参数，则返回小于 0 的值；如果此 Timestamp 对象晚于给定参数，则返回大于 0 的值。
从以下版本开始：
1.4

compareTo

public int compareTo(Date o)
将此 Timestamp 对象与给定的 Date（必须为 Timestamp 对象）相比较。如果参数不是 Timestamp 对象，则此方法抛出 ClassCastException 对象。（Timestamp 只有与其他的 Timestamp 对象相比较。）

指定者：
接口 Comparable<Date> 中的 compareTo
覆盖：
类 Date 中的 compareTo
参数：
o - 要比较的 Date，必须为 Timestamp 对象
返回：
如果此 Timestamp 对象与给定对象相等，则返回值 0；如果此 Timestamp 对象早于给定参数，则返回小于 0 的值；如果此 Timestamp 对象晚于给定参数，则返回大于 0 的值。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Types (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.sql
类 Types

java.lang.Object
    继承者  java.sql.Types

public class Types
extends Object

定义用于标识一般 SQL 类型（称为 JDBC 类型）的常量的类。

此类永远是不可序列化的。

字段摘要
static int | ARRAY 标识一般 SQL 类型 ARRAY 的 Java 编程语言中的常量（有时称为类型代码）。
static int | BIGINT 标识一般 SQL 类型 BIGINT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | BINARY 标识一般 SQL 类型 BINARY 的 Java 编程语言中的常量（有时称为类型代码）。
static int | BIT 标识一般 SQL 类型 BIT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | BLOB 标识一般 SQL 类型 BLOB 的 Java 编程语言中的常量（有时称为类型代码）。
static int | BOOLEAN 标识一般 SQL 类型 BOOLEAN 的 Java 编程语言中的常量（有时称为类型代码）。
static int | CHAR 标识一般 SQL 类型 CHAR 的 Java 编程语言中的常量（有时称为类型代码）。
static int | CLOB 标识一般 SQL 类型 CLOB 的 Java 编程语言中的常量（有时称为类型代码）。
static int | DATALINK 标识一般 SQL 类型 DATALINK 的 Java 编程语言中的常量（有时称为类型代码）。
static int | DATE 标识一般 SQL 类型 DATE 的 Java 编程语言中的常量（有时称为类型代码）。
static int | DECIMAL 标识一般 SQL 类型 DECIMAL 的 Java 编程语言中的常量（有时称为类型代码）。
static int | DISTINCT 标识一般 SQL 类型 DISTINCT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | DOUBLE 标识一般 SQL 类型 DOUBLE 的 Java 编程语言中的常量（有时称为类型代码）。
static int | FLOAT 标识一般 SQL 类型 FLOAT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | INTEGER 标识一般 SQL 类型 INTEGER 的 Java 编程语言中的常量（有时称为类型代码）。
static int | JAVA_OBJECT 标识一般 SQL 类型 JAVA_OBJECT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | LONGNVARCHAR 标识一般 SQL 类型 LONGNVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
static int | LONGVARBINARY 标识一般 SQL 类型 LONGVARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。
static int | LONGVARCHAR 标识一般 SQL 类型 LONGVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
static int | NCHAR 标识一般 SQL 类型 NCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
static int | NCLOB 标识一般 SQL 类型 NCLOB 的 Java 编程语言中的常量（有时称为类型代码）。
static int | NULL 标识一般 SQL 值 NULL 的 Java 编程语言中的常量。
static int | NUMERIC 标识一般 SQL 类型 NUMERIC 的 Java 编程语言中的常量（有时称为类型代码）。
static int | NVARCHAR 标识一般 SQL 类型 NVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
static int | OTHER Java 编程语言中的常量，该常量指示 SQL 类型是特定于数据库的并且被映射到可通过 getObject 和 setObject 方法访问的 Java 对象。
static int | REAL 标识一般 SQL 类型 REAL 的 Java 编程语言中的常量（有时称为类型代码）。
static int | REF 标识一般 SQL 类型 REF 的 Java 编程语言中的常量（有时称为类型代码）。
static int | ROWID 标识一般 SQL 类型 ROWID 的 Java 编程语言中的常量（有时称为类型代码）。
static int | SMALLINT 标识一般 SQL 类型 SMALLINT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | SQLXML 标识一般 SQL 类型 XML 的 Java 编程语言中的常量（有时称为类型代码）。
static int | STRUCT 标识一般 SQL 类型 STRUCT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | TIME 标识一般 SQL 类型 TIME 的 Java 编程语言中的常量（有时称为类型代码）。
static int | TIMESTAMP 标识一般 SQL 类型 TIMESTAMP 的 Java 编程语言中的常量（有时称为类型代码）。
static int | TINYINT 标识一般 SQL 类型 TINYINT 的 Java 编程语言中的常量（有时称为类型代码）。
static int | VARBINARY 标识一般 SQL 类型 VARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。
static int | VARCHAR 标识一般 SQL 类型 VARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

BIT

public static final int BIT

标识一般 SQL 类型 BIT 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

TINYINT

public static final int TINYINT

标识一般 SQL 类型 TINYINT 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

SMALLINT

public static final int SMALLINT

标识一般 SQL 类型 SMALLINT 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

INTEGER

public static final int INTEGER

标识一般 SQL 类型 INTEGER 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

BIGINT

public static final int BIGINT

标识一般 SQL 类型 BIGINT 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

FLOAT

public static final int FLOAT

标识一般 SQL 类型 FLOAT 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

REAL

public static final int REAL

标识一般 SQL 类型 REAL 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

DOUBLE

public static final int DOUBLE

标识一般 SQL 类型 DOUBLE 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

NUMERIC

public static final int NUMERIC

标识一般 SQL 类型 NUMERIC 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

DECIMAL

public static final int DECIMAL

标识一般 SQL 类型 DECIMAL 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

CHAR

public static final int CHAR

标识一般 SQL 类型 CHAR 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

VARCHAR

public static final int VARCHAR

标识一般 SQL 类型 VARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

LONGVARCHAR

public static final int LONGVARCHAR

标识一般 SQL 类型 LONGVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

DATE

public static final int DATE

标识一般 SQL 类型 DATE 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

TIME

public static final int TIME

标识一般 SQL 类型 TIME 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

TIMESTAMP

public static final int TIMESTAMP

标识一般 SQL 类型 TIMESTAMP 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

BINARY

public static final int BINARY

标识一般 SQL 类型 BINARY 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

VARBINARY

public static final int VARBINARY

标识一般 SQL 类型 VARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

LONGVARBINARY

public static final int LONGVARBINARY

标识一般 SQL 类型 LONGVARBINARY 的 Java 编程语言中的常量（有时称为类型代码）。

另请参见：
常量字段值

NULL

public static final int NULL

标识一般 SQL 值 NULL 的 Java 编程语言中的常量。

另请参见：
常量字段值

OTHER

public static final int OTHER
Java 编程语言中的常量，该常量指示 SQL 类型是特定于数据库的并且被映射到可通过 getObject 和 setObject 方法访问的 Java 对象。

另请参见：
常量字段值

JAVA_OBJECT

public static final int JAVA_OBJECT
标识一般 SQL 类型 JAVA_OBJECT 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.2
另请参见：
常量字段值

DISTINCT

public static final int DISTINCT
标识一般 SQL 类型 DISTINCT 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.2
另请参见：
常量字段值

STRUCT

public static final int STRUCT
标识一般 SQL 类型 STRUCT 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.2
另请参见：
常量字段值

ARRAY

public static final int ARRAY
标识一般 SQL 类型 ARRAY 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.2
另请参见：
常量字段值

BLOB

public static final int BLOB
标识一般 SQL 类型 BLOB 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.2
另请参见：
常量字段值

CLOB

public static final int CLOB
标识一般 SQL 类型 CLOB 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.2
另请参见：
常量字段值

REF

public static final int REF
标识一般 SQL 类型 REF 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.2
另请参见：
常量字段值

DATALINK

public static final int DATALINK
标识一般 SQL 类型 DATALINK 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.4
另请参见：
常量字段值

BOOLEAN

public static final int BOOLEAN
标识一般 SQL 类型 BOOLEAN 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.4
另请参见：
常量字段值

ROWID

public static final int ROWID
标识一般 SQL 类型 ROWID 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.6
另请参见：
常量字段值

NCHAR

public static final int NCHAR
标识一般 SQL 类型 NCHAR 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.6
另请参见：
常量字段值

NVARCHAR

public static final int NVARCHAR
标识一般 SQL 类型 NVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.6
另请参见：
常量字段值

LONGNVARCHAR

public static final int LONGNVARCHAR
标识一般 SQL 类型 LONGNVARCHAR 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.6
另请参见：
常量字段值

NCLOB

public static final int NCLOB
标识一般 SQL 类型 NCLOB 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.6
另请参见：
常量字段值

SQLXML

public static final int SQLXML
标识一般 SQL 类型 XML 的 Java 编程语言中的常量（有时称为类型代码）。

从以下版本开始：
1.6
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Wrapper (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.sql
接口 Wrapper

所有已知子接口：
CachedRowSet, CallableStatement, Connection, DatabaseMetaData, DataSource, FilteredRowSet, JdbcRowSet, JoinRowSet, ParameterMetaData, PreparedStatement, ResultSet, ResultSetMetaData, RowSet, RowSetMetaData, Statement, SyncResolver, WebRowSet
所有已知实现类：
RowSetMetaDataImpl
public interface Wrapper

在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。

许多 JDBC 驱动程序实现使用包装器模式提供超越传统 JDBC API 的扩展，传统 JDBC API 是特定于数据源的。开发人员可能希望访问那些被包装（代理）为代表实际资源代理类实例的资源。此接口描述访问那些由代理代表的包装资源的标准机制，以允许对资源代理的直接访问。

从以下版本开始：
1.6

方法摘要
 boolean isWrapperFor(Class<?> iface)
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。
<T> T
unwrap(Class<T> iface)
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。

方法详细信息

unwrap

<T> T unwrap(Class<T> iface)
         throws SQLException
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。 如果接收者实现了该接口，那么结果是接收者或接收者代理。如果接收者是包装器且包装对象实现了该接口，那么结果是包装对象或包装对象的代理。否则，返回以递归方式对包装对象调用 unwrap 的结果或该结果的代理。如果接收者不是包装器且未实现该接口，则抛出 SQLException。

参数：
iface - 定义结果必须实现的接口的 Class。
返回：
实现接口的对象。可以是实际实现对象的代理。
抛出：
SQLException - 如果未找到实现接口的对象。
从以下版本开始：
1.6

isWrapperFor

boolean isWrapperFor(Class<?> iface)
                     throws SQLException
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。否则返回 false。如果调用此方法的对象实现了接口，则返回 true；如果它是包装器，则返回以递归方式对包装对象调用 isWrapperFor 的结果。如果调用此方法的对象未实现该接口且不是包装器，则返回 false。此方法相比 unwrap 而言，应作为低成本操作实现，以便调用者可以使用此方法避免调用可能失败的昂贵的 unwrap。如果此方法返回 true，那么使用相同的参数调用 unwrap 应该会成功。

参数：
iface - 定义接口的 Class。
返回：
如果调用此方法的对象实现了接口，或者直接或间接包装实现了接口的对象，则返回 true。
抛出：
SQLException - 如果在确定调用此方法的对象是否是使用给定接口的对象的包装器时发生错误。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.sql (Java 2 Platform SE 6)

 java.sql
接口
Array
Blob
CallableStatement
Clob
Connection
DatabaseMetaData
Driver
NClob
ParameterMetaData
PreparedStatement
Ref
ResultSet
ResultSetMetaData
RowId
Savepoint
SQLData
SQLInput
SQLOutput
SQLXML
Statement
Struct
Wrapper
类
Date
DriverManager
DriverPropertyInfo
SQLPermission
Time
Timestamp
Types
枚举
ClientInfoStatus
RowIdLifetime
异常
BatchUpdateException
DataTruncation
SQLClientInfoException
SQLDataException
SQLException
SQLFeatureNotSupportedException
SQLIntegrityConstraintViolationException
SQLInvalidAuthorizationSpecException
SQLNonTransientConnectionException
SQLNonTransientException
SQLRecoverableException
SQLSyntaxErrorException
SQLTimeoutException
SQLTransactionRollbackException
SQLTransientConnectionException
SQLTransientException
SQLWarning


java.sql 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.sql 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.Date (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.sql.Date
      • java.sql.Time
      • java.sql.Timestamp
    • java.sql.DriverManager
    • java.sql.DriverPropertyInfo
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.sql.SQLPermission
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • java.sql.BatchUpdateException
          • java.sql.SQLClientInfoException
          • java.sql.SQLNonTransientException
            • java.sql.SQLDataException
            • java.sql.SQLFeatureNotSupportedException
            • java.sql.SQLIntegrityConstraintViolationException
            • java.sql.SQLInvalidAuthorizationSpecException
            • java.sql.SQLNonTransientConnectionException
            • java.sql.SQLSyntaxErrorException
          • java.sql.SQLRecoverableException
          • java.sql.SQLTransientException
            • java.sql.SQLTimeoutException
            • java.sql.SQLTransactionRollbackException
            • java.sql.SQLTransientConnectionException
          • java.sql.SQLWarning
            • java.sql.DataTruncation
    • java.sql.Types

接口分层结构

  • java.sql.Array
  • java.sql.Blob
  • java.sql.Clob
    • java.sql.NClob
  • java.sql.Driver
  • java.sql.Ref
  • java.sql.RowId
  • java.sql.Savepoint
  • java.sql.SQLData
  • java.sql.SQLInput
  • java.sql.SQLOutput
  • java.sql.SQLXML
  • java.sql.Struct
  • java.sql.Wrapper
    • java.sql.Connection
    • java.sql.DatabaseMetaData
    • java.sql.ParameterMetaData
    • java.sql.ResultSet
    • java.sql.ResultSetMetaData
    • java.sql.Statement
      • java.sql.PreparedStatement
        • java.sql.CallableStatement

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.sql.ClientInfoStatus
      • java.sql.RowIdLifetime
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


java.sql (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.sql

提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

请参见：
描述

接口摘要
Array | SQL 类型 ARRAY 在 Java 编程语言中的映射关系。
Blob | SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。
CallableStatement | 用于执行 SQL 存储过程的接口。
Clob | SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。
Connection | 与特定数据库的连接（会话）。
DatabaseMetaData | 关于数据库的整体综合信息。
Driver | 每个驱动程序类必须实现的接口。
NClob | SQL NCLOB 类型在 JavaTM 编程语言中的映射。
ParameterMetaData | 可用于获取关于 PreparedStatement 对象中每个参数标记的类型和属性信息的对象。
PreparedStatement | 表示预编译的 SQL 语句的对象。
Ref | Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。
ResultSet | 表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
ResultSetMetaData | 可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
RowId | SQL ROWID 值在 Java 编程语言中的表示形式（映射）。
Savepoint | 保存点的表示形式，保存点是可以从 Connection.rollback 方法引用的当前事务中的点。
SQLData | 该接口用于 SQL 用户定义类型 (UDT) 到 Java 编程语言中类的自定义映射关系。
SQLInput | 一个输入流，它包含表示 SQL 结构化类型或 SQL 不同类型的实例的值组成的流。
SQLOutput | 用于将用户定义类型的属性写回数据库的输出流。
SQLXML | SQL XML 类型在 JavaTM 编程语言中的映射关系。
Statement | 用于执行静态 SQL 语句并返回它所生成结果的对象。
Struct | 用于 SQL 结构化类型的 Java 编程语言中的标准映射关系。
Wrapper | 在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。

类摘要
Date | 一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
DriverManager | 管理一组 JDBC 驱动程序的基本服务。
DriverPropertyInfo | 用于建立连接的驱动程序属性。
SQLPermission | SecurityManager 将用来检查在 applet 中运行的代码何时调用 DriverManager.setLogWriter 方法或 DriverManager.setLogStream（不建议使用）方法的权限。
Time | 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
Timestamp | 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。
Types | 定义用于标识一般 SQL 类型（称为 JDBC 类型）的常量的类。

枚举摘要
ClientInfoStatus | 无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
RowIdLifetime | RowId 生存期值的枚举。

异常摘要
BatchUpdateException | 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
DataTruncation | 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
SQLClientInfoException | 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
SQLDataException | 当 SQLState 类值为“22”时抛出的 SQLException 子类。
SQLException | 提供关于数据库访问错误或其他错误信息的异常。
SQLFeatureNotSupportedException | 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
SQLIntegrityConstraintViolationException | 当 SQLState 类值为“23”时抛出的 SQLException 子类。
SQLInvalidAuthorizationSpecException | 当 SQLState 类值为“28”时抛出的 SQLException 子类。
SQLNonTransientConnectionException | SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
SQLNonTransientException | 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
SQLRecoverableException | 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
SQLSyntaxErrorException | 当 SQLState 类值为“42”时抛出的 SQLException 子类。
SQLTimeoutException | Statement 指定的超时已到期时抛出的 SQLException 子类。
SQLTransactionRollbackException | 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
SQLTransientConnectionException | SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
SQLTransientException | 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
SQLWarning | 提供关于数据库访问警告信息的异常。

软件包 java.sql 的描述

提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。此 API 包括一个框架，凭借此框架可以动态地安装不同驱动程序来访问不同数据源。尽管 JDBCTM API 主要用于将 SQL 语句传递给数据库，但它还可以用于以表格方式从任何数据源中读写数据。通过接口的 javax.sql.RowSet 组可以使用的 reader/writer 实用程序，可以被定制以使用和更新来自电子表格、纯文本文件或其他任何表格式数据源的数据。

JDBCTM 4.0 API 中包括的内容

JDBCTM 4.0 API 中包括 java.sql 包，被称为 JDBC 核心 API，和 javax.sql 包，被称为 JDBC Optional Package API。完整的 JDBC API 包含在 JavaTM 标准版 (Java SETM) 6 版中。javax.sql 包扩展了 JDBC API 的功能，将它从客户端 API 扩展到服务器端 API，该包是 JavaTM、企业版 (JavaTM) 技术的重要部分。

版本

JDBC 4.0 API 综合了以前所有 JDBC API 版本：
  • JDBC 3.0 API
  • JDBC 2.1 核心 API
  • JDBC 2.0 Optional Package API
    （注意，JDBC 2.1 核心 API 和 JDBC 2.0 Optional Package API 组合在一起被称为 JDBC 2.0 API。）
  • The JDBC 1.2 API
  • The JDBC 1.0 API

类、接口、方法、字段、构造方法和异常都有以下 "since" 标记，以指示它们何时被引入 Java 平台。当将这些 "since" 标记用于 JDBC API 的 JavadocTM 注释时，它们指示以下内容：

  • Since 1.6：JDBC 4.0 API 中的新内容和 Java SE 平台 6 版的部分内容
  • Since 1.4：JDBC 3.0 API 中的新内容和 J2SE 平台 1.4 版的部分内容
  • Since 1.2：JDBC 2.0 API 中的新内容和 J2SE 平台 1.2 版的部分内容
  • Since 1.1 或者没有 "since" 标记：原始 JDBC 1.0 API 和 JDKTM 1.1 版的部分内容

注：许多新特性都是可选的，因此，在这些版本支持的驱动程序和特性中有一些变体。在尝试使用它之前,总是检查驱动程序的文档，以查看它是否支持某一特性。

注：SQLPermission 类被添加到 JavaTM 2 SDK 标准版 1.3 版中。此类用于防止对与 DriverManager 相关联的记录流进行无授权访问，该流可以包含诸如表名称、列数据等信息。

java.sql Package 包含的内容

java.sql 包中包含用于以下方面的 API：
  • 通过 DriverManager 实用程序建立与数据库的连接
    • DriverManager 类：建立与驱动程序的连接
    • SQLPermission 类：当代码在 Security Manager（比如 applet）中运行时提供权限，试图通过 DriverManager 设置一个记录流
    • Driver 接口：提供用来注册和连接基于 JDBC 技术（“JDBC 驱动程序”）的驱动程序的 API，通常仅由 DriverManager 类使用
    • DriverPropertyInfo 类：提供 JDBC 驱动程序的属性，不是供一般用户使用的
  • 向数据库发送 SQL 语句
    • Statement：用于发送基本 SQL 语句
    • PreparedStatement：用于发送准备好的语句或基本 SQL 语句（派生自 Statement）
    • CallableStatement：用于调用数据库存储过程（派生自 PreparedStatement）
    • Connection 接口：提供创建语句以及管理连接及其属性的方法
    • Savepoint：在事务中提供保存点
  • 获取和更新查询的结果
    • ResultSet 接口
  • SQL 类型到 Java 编程语言中的类和接口的标准映射关系
    • Array 接口：SQL ARRAY 的映射关系
    • Blob 接口：SQL BLOB 的映射关系
    • Clob 接口：SQL CLOB 的映射关系
    • Date 类：SQL DATE 的映射关系
    • NClob 接口：SQL NCLOB 的映射关系
    • Ref 接口：SQL REF 的映射关系
    • RowId 接口：SQL ROWID 的映射关系
    • Struct 接口：SQL STRUCT 的映射关系
    • SQLXML 接口：SQL XML 的映射关系
    • Time 类：SQL TIME 的映射关系
    • Timestamp 类：SQL TIMESTAMP 的映射关系
    • Types 类：提供用于 SQL 类型的常量
  • 自定义映射 SQL 用户定义类型 (UDT) 到 Java 编程语言中的类
    • SQLData 接口：指定 UDT 到此类的一个实例的映射关系
    • SQLInput 接口：提供用来从流中读取 UDT 属性的方法
    • SQLOutput 接口：提供用来将 UDT 属性写回流中的方法
  • 元数据
    • DatabaseMetaData 接口：提供有关数据库的信息
    • ResultSetMetaData 接口：提供有关 ResultSet 对象的列的信息
    • ParameterMetaData 接口：提供有关 PreparedStatement 命令的参数的信息
  • 异常
    • SQLException：由大多数方法在访问数据出问题时抛出，以及因为其他原因由其他一些方法抛出
    • SQLWarning：为了指示一个警告而抛出
    • DataTruncation：为了指示数据可能已经被截断而抛出
    • BatchUpdateException：为了指示并不是批量更新中的所有命令都成功执行而抛出

JDBC 4.0 API 中引入的 java.sql 和 javax.sql 特性

  • 自动 java.sql.Driver 发现：不再需要通过 Class.forName 来加载 java.sql.Driver 类
  • 添加了国家字符集 (National Character Set) 支持
  • 为 SQL:2003 XML 数据类型添加的支持
  • SQLException 增强：为原因链添加的支持；为公用 SQLState 类值代码添加新 SQLException
  • 增强的 Blob/Clob 功能：提供创建和释放 Blob/Clob 实例以及为了提高可访问性所添加的一些其他方法
  • 为访问 SQL ROWID 添加的支持
  • 添加的支持，允许 JDBC 应用程序访问已被供应商包装的 JDBC 资源实例，通常在一个应用程序服务器或连接池环境中。
  • 当与 PooledConnection 关联的 PreparedStatement 已关闭或驱动程序确定为无效时要通知的可用性

JDBC 3.0 API 中引入的 java.sql 和 javax.sql 特性

  • 入池语句 (pooled statement)：重新使用与某个已入池的连接 (pooled connection) 相关的语句
  • 保存点：允许将事务回滚到某一指定保存点
  • 为 ConnectionPoolDataSource 定义的属性：指定将连接入池的方法
  • PreparedStatement 对象的参数的元数据
  • 从自动生成的列中获取值的能力
  • 使从 CallableStatement 对象中返回的多个 ResultSet 对象同时打开的能力
  • 通过名称和索引标识 CallableStatement 对象的参数的能力
  • ResultSet 可保存性：指定是否应该让游标在某一事务结束时保持打开或关闭状态的能力
  • 获取和更新 Ref 对象引用的 SQL 结构化类型实例的能力
  • 通过编程方式更新 BLOB、CLOB、ARRAY 和 REF 值的能力。
  • java.sql.Types.DATALINK 数据类型的添加：允许 JDBC 驱动程序访问数据源以外的地方存储的对象
  • 用于获取 SQL 类型分层结构的元数据的添加

JDBC 2.1 Core API 中引入的 java.sql 特性

  • 可滚动的结果集：使用 ResultSet 接口中的新方法，这些方法允许将光标移动到某一特定行，或者移动到其当前位置的某一相对位置
  • 批量更新
  • 编程式更新：使用 ResultSet updater 方法
  • 新数据类型：映射 SQL3 数据类型的接口
  • 用户定义类型 (UDT) 的自定义映射关系
  • 其他特性，包括性能提示、字符流的使用、java.math.BigDecimal 值的完全精度、其他安全性，以及对日期、时间和时间戳值中的时区的支持。

JDBC 2.0 Package API 中引入的 javax.sql 特性

  • DataSource 接口被认为是建立连接的一种方式。Java Naming 和 Directory InterfaceTM (JNDI) 用于向命名服务注册一个 DataSource 对象和获取该对象。
  • 入池连接：允许使用和重新使用连接
  • 分布式事务：允许事务跨越不同的 DBMS 服务器
  • RowSet 技术：提供一个处理和传递数据的便捷方法

UDT 的自定义映射关系

可以将 SQL 中定义的用户定义类型 (UDT) 映射到 Java 编程语言中的类。SQL 结构化类型或 SQL DISTINCT 类型是可以自定义映射的 UDT。以下三个步骤设置了一个自定义映射关系：
  1. 在 SQL 中定义 SQL 结构化类型或 DISTINCT 类型
  2. 定义 Java 编程语言中的类，SQL UDT 将映射到该类。此类必须实现 SQLData 接口。
  3. 在 Connection 对象的类型映射表中创建一个项，该项包含两项内容：
    • UDT 的完全限定 SQL 名称
    • 实现 SQLData 接口的类的 Class 对象

为 UDT 准备好这些之后，在该 UDT 上调用 ResultSet.getObject 或 CallableStatement.getObject 方法将自动获取该 UDT 的自定义映射关系。此外，PreparedStatement.setObject 方法会自动将该对象映射回其 SQL 类型，以便将它存储在数据源中。

包规范

  • JDBC 4.0 API 规范

相关文档

  • Getting Started：主要接口的概述

  • Chapters on the JDBC API：取自 The Java Tutorial Continued 的在线版本

  • JDBCTMAPI Tutorial and Reference, Third Edition：JDBC 3.0 API 的完整参考和指南

从以下版本开始：
1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


软件包 java.sql 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.sql
的使用

使用 java.sql 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 使用的 java.sql 中的类
Array
SQL 类型 ARRAY 在 Java 编程语言中的映射关系。
Blob
SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。
CallableStatement
用于执行 SQL 存储过程的接口。
ClientInfoStatus
无法通过调用 Connection.setClientInfo 设置属性的原因状态的枚举。
Clob
SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。
Connection
与特定数据库的连接（会话）。
DatabaseMetaData
关于数据库的整体综合信息。
Date
一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
Driver
每个驱动程序类必须实现的接口。
DriverPropertyInfo
用于建立连接的驱动程序属性。
NClob
SQL NCLOB 类型在 JavaTM 编程语言中的映射。
ParameterMetaData
可用于获取关于 PreparedStatement 对象中每个参数标记的类型和属性信息的对象。
PreparedStatement
表示预编译的 SQL 语句的对象。
Ref
Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。
ResultSet
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
ResultSetMetaData
可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
RowId
SQL ROWID 值在 Java 编程语言中的表示形式（映射）。
RowIdLifetime
RowId 生存期值的枚举。
Savepoint
保存点的表示形式，保存点是可以从 Connection.rollback 方法引用的当前事务中的点。
SQLClientInfoException
当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
SQLData
该接口用于 SQL 用户定义类型 (UDT) 到 Java 编程语言中类的自定义映射关系。
SQLException
提供关于数据库访问错误或其他错误信息的异常。
SQLInput
一个输入流，它包含表示 SQL 结构化类型或 SQL 不同类型的实例的值组成的流。
SQLNonTransientException
重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
SQLOutput
用于将用户定义类型的属性写回数据库的输出流。
SQLTransientException
没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
SQLWarning
提供关于数据库访问警告信息的异常。
SQLXML
SQL XML 类型在 JavaTM 编程语言中的映射关系。
Statement
用于执行静态 SQL 语句并返回它所生成结果的对象。
Struct
用于 SQL 结构化类型的 Java 编程语言中的标准映射关系。
Time
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
Timestamp
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。
Wrapper
在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。

javax.sql 使用的 java.sql 中的类
Array
SQL 类型 ARRAY 在 Java 编程语言中的映射关系。
Blob
SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。
Clob
SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。
Connection
与特定数据库的连接（会话）。
Date
一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
NClob
SQL NCLOB 类型在 JavaTM 编程语言中的映射。
PreparedStatement
表示预编译的 SQL 语句的对象。
Ref
Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。
ResultSet
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
ResultSetMetaData
可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
RowId
SQL ROWID 值在 Java 编程语言中的表示形式（映射）。
SQLException
提供关于数据库访问错误或其他错误信息的异常。
SQLXML
SQL XML 类型在 JavaTM 编程语言中的映射关系。
Time
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
Timestamp
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。
Wrapper
在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。

javax.sql.rowset 使用的 java.sql 中的类
Array
SQL 类型 ARRAY 在 Java 编程语言中的映射关系。
Blob
SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。
Clob
SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。
Connection
与特定数据库的连接（会话）。
Date
一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
NClob
SQL NCLOB 类型在 JavaTM 编程语言中的映射。
Ref
Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。
ResultSet
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
ResultSetMetaData
可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
RowId
SQL ROWID 值在 Java 编程语言中的表示形式（映射）。
Savepoint
保存点的表示形式，保存点是可以从 Connection.rollback 方法引用的当前事务中的点。
SQLException
提供关于数据库访问错误或其他错误信息的异常。
SQLXML
SQL XML 类型在 JavaTM 编程语言中的映射关系。
Time
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
Timestamp
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。
Wrapper
在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。

javax.sql.rowset.serial 使用的 java.sql 中的类
Array
SQL 类型 ARRAY 在 Java 编程语言中的映射关系。
Blob
SQL BLOB 值在 JavaTM 编程语言中的表示形式（映射关系）。
Clob
SQL 类型 CLOB 在 JavaTM 编程语言中的映射关系。
Date
一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
NClob
SQL NCLOB 类型在 JavaTM 编程语言中的映射。
Ref
Java 编程语言中 SQL REF 值的映射关系，它是到数据库中的 SQL 结构类型值的引用。
ResultSet
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
RowId
SQL ROWID 值在 Java 编程语言中的表示形式（映射）。
SQLData
该接口用于 SQL 用户定义类型 (UDT) 到 Java 编程语言中类的自定义映射关系。
SQLException
提供关于数据库访问错误或其他错误信息的异常。
SQLInput
一个输入流，它包含表示 SQL 结构化类型或 SQL 不同类型的实例的值组成的流。
SQLOutput
用于将用户定义类型的属性写回数据库的输出流。
SQLXML
SQL XML 类型在 JavaTM 编程语言中的映射关系。
Struct
用于 SQL 结构化类型的 Java 编程语言中的标准映射关系。
Time
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
Timestamp
一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。

javax.sql.rowset.spi 使用的 java.sql 中的类
ResultSet
表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
Savepoint
保存点的表示形式，保存点是可以从 Connection.rollback 方法引用的当前事务中的点。
SQLException
提供关于数据库访问错误或其他错误信息的异常。
Wrapper
在相关实例实际上是代理类时提供获取委托实例能力的 JDBC 类的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLClientInfoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLClientInfoException
的使用

使用 SQLClientInfoException 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLClientInfoException 的使用

抛出 SQLClientInfoException 的 java.sql 中的方法
void | Connection.setClientInfo(Properties properties) 设置连接的客户端信息属性的值。
void | Connection.setClientInfo(String name, String value) 将 name 指定的客户端信息属性的值设置为 value 指定的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.ClientInfoStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.ClientInfoStatus
的使用

使用 ClientInfoStatus 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 ClientInfoStatus 的使用

返回 ClientInfoStatus 的 java.sql 中的方法
static ClientInfoStatus | ClientInfoStatus.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ClientInfoStatus[] | ClientInfoStatus.values() Returns an array containing the constants of this enum type, in the order they are declared.

返回变量类型为 ClientInfoStatus 的类型的 java.sql 中的方法
 Map<String,ClientInfoStatus> SQLClientInfoException.getFailedProperties()
返回无法设置的客户端信息属性列表。

类型变量类型为 ClientInfoStatus 的 java.sql 中的构造方法参数
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Array 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Array
的使用

使用 Array 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Array 的使用

返回 Array 的 java.sql 中的方法
Array | Connection.createArrayOf(String typeName, Object[] elements) 创建 Array 对象的工厂方法。
Array | CallableStatement.getArray(int parameterIndex) 以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。
Array | ResultSet.getArray(int columnIndex) 以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Array | CallableStatement.getArray(String parameterName) 以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。
Array | ResultSet.getArray(String columnLabel) 以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Array | SQLInput.readArray() 从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。

参数类型为 Array 的 java.sql 中的方法
void | PreparedStatement.setArray(int parameterIndex, Array x) 将指定参数设置为给定 java.sql.Array 对象。
void | ResultSet.updateArray(int columnIndex, Array x) 用 java.sql.Array 值更新指定列。
void | ResultSet.updateArray(String columnLabel, Array x) 用 java.sql.Array 值更新指定列。
void | SQLOutput.writeArray(Array x) 将 SQL ARRAY 值写入流中。

javax.sql 中 Array 的使用

参数类型为 Array 的 javax.sql 中的方法
 void RowSet.setArray(int i, Array x)
使用给定 Array 值设置此 RowSet 对象命令中的指定参数。

javax.sql.rowset 中 Array 的使用

参数类型为 Array 的 javax.sql.rowset 中的方法
 void BaseRowSet.setArray(int parameterIndex, Array array)
将指定参数设置为 Java 编程语言中的 Array 对象。

javax.sql.rowset.serial 中 Array 的使用

实现 Array 的 javax.sql.rowset.serial 中的类
 class SerialArray
序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。

返回 Array 的 javax.sql.rowset.serial 中的方法
 Array SQLInputImpl.readArray()
从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。

参数类型为 Array 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeArray(Array x)
将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。

参数类型为 Array 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array)
根据给定 Array 对象构造新的 SerialArray 对象。
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.BatchUpdateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.BatchUpdateException
的使用

没有 java.sql.BatchUpdateException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Blob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Blob
的使用

使用 Blob 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Blob 的使用

返回 Blob 的 java.sql 中的方法
Blob | Connection.createBlob() 构造实现 Blob 接口的对象。
Blob | CallableStatement.getBlob(int parameterIndex) 以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
Blob | ResultSet.getBlob(int columnIndex) 以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Blob | CallableStatement.getBlob(String parameterName) 以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。
Blob | ResultSet.getBlob(String columnLabel) 以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Blob | SQLInput.readBlob() 从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。

参数类型为 Blob 的 java.sql 中的方法
long | Blob.position(Blob pattern, long start) 获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。
void | PreparedStatement.setBlob(int parameterIndex, Blob x) 将指定参数设置为给定 java.sql.Blob 对象。
void | CallableStatement.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。
void | ResultSet.updateBlob(int columnIndex, Blob x) 用 java.sql.Blob 值更新指定列。
void | ResultSet.updateBlob(String columnLabel, Blob x) 用 java.sql.Blob 值更新指定列。
void | SQLOutput.writeBlob(Blob x) 将 SQL BLOB 值写入流中。

javax.sql 中 Blob 的使用

参数类型为 Blob 的 javax.sql 中的方法
void | RowSet.setBlob(int i, Blob x) 使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。

javax.sql.rowset 中 Blob 的使用

参数类型为 Blob 的 javax.sql.rowset 中的方法
void | BaseRowSet.setBlob(int parameterIndex, Blob x) 将指定参数设置为 Java 编程语言中的给定 Blob 对象。
void | BaseRowSet.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。

javax.sql.rowset.serial 中 Blob 的使用

实现 Blob 的 javax.sql.rowset.serial 中的类
 class SerialBlob
SQL BLOB 值在 Java 编程语言中的序列化映射关系。

返回 Blob 的 javax.sql.rowset.serial 中的方法
 Blob SQLInputImpl.readBlob()
以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。

参数类型为 Blob 的 javax.sql.rowset.serial 中的方法
long | SerialBlob.position(Blob pattern, long start) 返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
void | SQLOutputImpl.writeBlob(Blob x) 将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。

参数类型为 Blob 的 javax.sql.rowset.serial 中的构造方法
SerialBlob(Blob blob)
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.CallableStatement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.CallableStatement
的使用

使用 CallableStatement 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 CallableStatement 的使用

返回 CallableStatement 的 java.sql 中的方法
CallableStatement | Connection.prepareCall(String sql) 创建一个 CallableStatement 对象来调用数据库存储过程。
CallableStatement | Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency) 创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
CallableStatement | Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Clob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Clob
的使用

使用 Clob 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Clob 的使用

java.sql 中 Clob 的子接口
 interface NClob
SQL NCLOB 类型在 JavaTM 编程语言中的映射。

返回 Clob 的 java.sql 中的方法
Clob | Connection.createClob() 构造实现 Clob 接口的对象。
Clob | CallableStatement.getClob(int parameterIndex) 以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
Clob | ResultSet.getClob(int columnIndex) 以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Clob | CallableStatement.getClob(String parameterName) 以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。
Clob | ResultSet.getClob(String columnLabel) 以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Clob | SQLInput.readClob() 从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。

参数类型为 Clob 的 java.sql 中的方法
long | Clob.position(Clob searchstr, long start) 获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。
void | PreparedStatement.setClob(int parameterIndex, Clob x) 将指定参数设置为给定 java.sql.Clob 对象。
void | CallableStatement.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。
void | ResultSet.updateClob(int columnIndex, Clob x) 用 java.sql.Clob 值更新指定列。
void | ResultSet.updateClob(String columnLabel, Clob x) 用 java.sql.Clob 值更新指定列。
void | SQLOutput.writeClob(Clob x) 将 SQL CLOB 值写入流中。

javax.sql 中 Clob 的使用

参数类型为 Clob 的 javax.sql 中的方法
void | RowSet.setClob(int i, Clob x) 使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。

javax.sql.rowset 中 Clob 的使用

参数类型为 Clob 的 javax.sql.rowset 中的方法
void | BaseRowSet.setClob(int parameterIndex, Clob x) 将指定参数设置为 Java 编程语言中的给定 Clob 对象。
void | BaseRowSet.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。

javax.sql.rowset.serial 中 Clob 的使用

实现 Clob 的 javax.sql.rowset.serial 中的类
 class SerialClob
SQL CLOB 值在 Java 编程语言中的序列化映射关系。

返回 Clob 的 javax.sql.rowset.serial 中的方法
 Clob SQLInputImpl.readClob()
以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。

参数类型为 Clob 的 javax.sql.rowset.serial 中的方法
long | SerialClob.position(Clob searchStr, long start) 返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
void | SQLOutputImpl.writeClob(Clob x) 将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。

参数类型为 Clob 的 javax.sql.rowset.serial 中的构造方法
SerialClob(Clob clob)
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Connection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Connection
的使用

使用 Connection 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

java.sql 中 Connection 的使用

返回 Connection 的 java.sql 中的方法
Connection | Driver.connect(String url, Properties info) 试图创建一个到给定 URL 的数据库连接。
Connection | DatabaseMetaData.getConnection() 获取此元数据对象所产生的连接。
Connection | Statement.getConnection() 获取生成此 Statement 对象的 Connection 对象。
static Connection | DriverManager.getConnection(String url) 试图建立到给定数据库 URL 的连接。
static Connection | DriverManager.getConnection(String url, Properties info) 试图建立到给定数据库 URL 的连接。
static Connection | DriverManager.getConnection(String url, String user, String password) 试图建立到给定数据库 URL 的连接。

javax.sql 中 Connection 的使用

返回 Connection 的 javax.sql 中的方法
Connection | DataSource.getConnection() 尝试建立与此 DataSource 对象所表示的数据源的连接。
Connection | PooledConnection.getConnection() 创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。
Connection | RowSetInternal.getConnection() 获取传递给此 RowSet 对象的 Connection 对象。
Connection | DataSource.getConnection(String username, String password) 尝试建立与此 DataSource 对象所表示的数据源的连接。

javax.sql.rowset 中 Connection 的使用

参数类型为 Connection 的 javax.sql.rowset 中的方法
void | CachedRowSet.acceptChanges(Connection con) 将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。
void | CachedRowSet.execute(Connection conn) 用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.DataTruncation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.DataTruncation
的使用

没有 java.sql.DataTruncation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.DatabaseMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.DatabaseMetaData
的使用

使用 DatabaseMetaData 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 DatabaseMetaData 的使用

返回 DatabaseMetaData 的 java.sql 中的方法
 DatabaseMetaData Connection.getMetaData()
获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.Date 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Date
的使用

使用 Date 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Date 的使用

返回 Date 的 java.sql 中的方法
Date | CallableStatement.getDate(int parameterIndex) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。
Date | ResultSet.getDate(int columnIndex) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(int parameterIndex, Calendar cal) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(String parameterName) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。
Date | ResultSet.getDate(String columnLabel) 以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(String parameterName, Calendar cal) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | SQLInput.readDate() 读取流中的下一个属性并将其作为 java.sql.Date 对象返回。
static Date | Date.valueOf(String s) 将 JDBC 日期转义形式的字符串转换成 Date 值。

参数类型为 Date 的 java.sql 中的方法
void | PreparedStatement.setDate(int parameterIndex, Date x) 使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。
void | PreparedStatement.setDate(int parameterIndex, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | CallableStatement.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。
void | CallableStatement.setDate(String parameterName, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | ResultSet.updateDate(int columnIndex, Date x) 用 java.sql.Date 值更新指定列。
void | ResultSet.updateDate(String columnLabel, Date x) 用 java.sql.Date 值更新指定列。
void | SQLOutput.writeDate(Date x) 将下一个属性作为 java.sql.Date 对象写入流中。

javax.sql 中 Date 的使用

参数类型为 Date 的 javax.sql 中的方法
void | RowSet.setDate(int parameterIndex, Date x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(int parameterIndex, Date x, Calendar cal) 使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

javax.sql.rowset 中 Date 的使用

参数类型为 Date 的 javax.sql.rowset 中的方法
void | BaseRowSet.setDate(int parameterIndex, Date x) 将指定参数设置为给定的 java.sql.Date 值。
void | BaseRowSet.setDate(int parameterIndex, Date x, Calendar cal) 将指定参数设置为给定的 java.sql.Date 对象。
void | BaseRowSet.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | BaseRowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。

javax.sql.rowset.serial 中 Date 的使用

返回 Date 的 javax.sql.rowset.serial 中的方法
 Date SQLInputImpl.readDate()
以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。

参数类型为 Date 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeDate(Date x)
将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Driver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Driver
的使用

使用 Driver 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 Driver 的使用

返回 Driver 的 java.sql 中的方法
static Driver DriverManager.getDriver(String url)
试图查找能理解给定 URL 的驱动程序。

返回变量类型为 Driver 的类型的 java.sql 中的方法
static Enumeration<Driver> DriverManager.getDrivers()
获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。

参数类型为 Driver 的 java.sql 中的方法
static void | DriverManager.deregisterDriver(Driver driver) 从 DriverManager 的列表中删除一个驱动程序。
static void | DriverManager.registerDriver(Driver driver) 向 DriverManager 注册给定驱动程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.DriverManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.DriverManager
的使用

没有 java.sql.DriverManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.DriverPropertyInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.DriverPropertyInfo
的使用

使用 DriverPropertyInfo 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 DriverPropertyInfo 的使用

返回 DriverPropertyInfo 的 java.sql 中的方法
 DriverPropertyInfo[] Driver.getPropertyInfo(String url, Properties info)
获得此驱动程序的可能属性信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.NClob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.NClob
的使用

使用 NClob 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 NClob 的使用

返回 NClob 的 java.sql 中的方法
NClob | Connection.createNClob() 构造实现 NClob 接口的对象。
NClob | CallableStatement.getNClob(int parameterIndex) 以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。
NClob | ResultSet.getNClob(int columnIndex) 以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
NClob | CallableStatement.getNClob(String parameterName) 以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。
NClob | ResultSet.getNClob(String columnLabel) 以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
NClob | SQLInput.readNClob() 从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。

参数类型为 NClob 的 java.sql 中的方法
void | PreparedStatement.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | CallableStatement.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | ResultSet.updateNClob(int columnIndex, NClob nClob) 用 java.sql.NClob 值更新指定的列。
void | ResultSet.updateNClob(String columnLabel, NClob nClob) 用 java.sql.NClob 值更新指定的列。
void | SQLOutput.writeNClob(NClob x) 将 SQL NCLOB 值写入流中。

javax.sql 中 NClob 的使用

参数类型为 NClob 的 javax.sql 中的方法
void | RowSet.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | RowSet.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。

javax.sql.rowset 中 NClob 的使用

参数类型为 NClob 的 javax.sql.rowset 中的方法
void | BaseRowSet.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | BaseRowSet.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。

javax.sql.rowset.serial 中 NClob 的使用

返回 NClob 的 javax.sql.rowset.serial 中的方法
 NClob SQLInputImpl.readNClob()
从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。

参数类型为 NClob 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeNClob(NClob x)
将 SQL NCLOB 值写入流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.ParameterMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.ParameterMetaData
的使用

使用 ParameterMetaData 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 ParameterMetaData 的使用

返回 ParameterMetaData 的 java.sql 中的方法
 ParameterMetaData PreparedStatement.getParameterMetaData()
获取此 PreparedStatement 对象的参数的编号、类型和属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.PreparedStatement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.PreparedStatement
的使用

使用 PreparedStatement 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

java.sql 中 PreparedStatement 的使用

java.sql 中 PreparedStatement 的子接口
 interface CallableStatement
用于执行 SQL 存储过程的接口。

返回 PreparedStatement 的 java.sql 中的方法
PreparedStatement | Connection.prepareStatement(String sql) 创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。
PreparedStatement | Connection.prepareStatement(String sql, int autoGeneratedKeys) 创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。
PreparedStatement | Connection.prepareStatement(String sql, int[] columnIndexes) 创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
PreparedStatement | Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency) 创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
PreparedStatement | Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
PreparedStatement | Connection.prepareStatement(String sql, String[] columnNames) 创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。

javax.sql 中 PreparedStatement 的使用

返回 PreparedStatement 的 javax.sql 中的方法
 PreparedStatement StatementEvent.getStatement()
返回正在关闭或无效的 PreparedStatement。

参数类型为 PreparedStatement 的 javax.sql 中的构造方法
StatementEvent(PooledConnection con, PreparedStatement statement)
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。
StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Ref 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Ref
的使用

使用 Ref 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Ref 的使用

返回 Ref 的 java.sql 中的方法
Ref | CallableStatement.getRef(int parameterIndex) 以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。
Ref | ResultSet.getRef(int columnIndex) 以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Ref | CallableStatement.getRef(String parameterName) 以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。
Ref | ResultSet.getRef(String columnLabel) 以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Ref | SQLInput.readRef() 从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。

参数类型为 Ref 的 java.sql 中的方法
void | PreparedStatement.setRef(int parameterIndex, Ref x) 将指定参数设置为给定 REF(<structured-type>) 值。
void | ResultSet.updateRef(int columnIndex, Ref x) 用 java.sql.Ref 值更新指定列。
void | ResultSet.updateRef(String columnLabel, Ref x) 用 java.sql.Ref 值更新指定列。
void | SQLOutput.writeRef(Ref x) 将 SQL REF 值写入流中。

javax.sql 中 Ref 的使用

参数类型为 Ref 的 javax.sql 中的方法
 void RowSet.setRef(int i, Ref x)
使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。

javax.sql.rowset 中 Ref 的使用

参数类型为 Ref 的 javax.sql.rowset 中的方法
 void BaseRowSet.setRef(int parameterIndex, Ref ref)
将指定参数设置为 Java 编程语言中的给定 Ref 对象。

javax.sql.rowset.serial 中 Ref 的使用

实现 Ref 的 javax.sql.rowset.serial 中的类
 class SerialRef
Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。

返回 Ref 的 javax.sql.rowset.serial 中的方法
 Ref SQLInputImpl.readRef()
以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。

参数类型为 Ref 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeRef(Ref x)
将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。

参数类型为 Ref 的 javax.sql.rowset.serial 中的构造方法
SerialRef(Ref ref)
根据给定 Ref 对象构造 SerialRef 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.ResultSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.ResultSet
的使用

使用 ResultSet 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 ResultSet 的使用

返回 ResultSet 的 java.sql 中的方法
ResultSet | PreparedStatement.executeQuery() 在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。
ResultSet | Statement.executeQuery(String sql) 执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。
ResultSet | DatabaseMetaData.getAttributes(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern) 获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。
ResultSet | DatabaseMetaData.getBestRowIdentifier(String catalog, String schema, String table, int scope, boolean nullable) 获取唯一标识行的表的最佳列集合的描述。
ResultSet | DatabaseMetaData.getCatalogs() 获取可在此数据库中使用的类别名称。
ResultSet | DatabaseMetaData.getClientInfoProperties() 获取驱动程序支持的客户端信息属性的列表。
ResultSet | DatabaseMetaData.getColumnPrivileges(String catalog, String schema, String table, String columnNamePattern) 获取用于表列的访问权的描述。
ResultSet | DatabaseMetaData.getColumns(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern) 获取可在指定类别中使用的表列的描述。
ResultSet | DatabaseMetaData.getCrossReference(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable) 获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。
ResultSet | DatabaseMetaData.getExportedKeys(String catalog, String schema, String table) 获取引用给定表的主键列（表导入的外键）的外键列的描述。
ResultSet | DatabaseMetaData.getFunctionColumns(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern) 获取给定类别的系统或用户函数参数和返回类型的描述。
ResultSet | DatabaseMetaData.getFunctions(String catalog, String schemaPattern, String functionNamePattern) 获取给定类别中可用的系统和用户函数的描述。
ResultSet | Statement.getGeneratedKeys() 获取由于执行此 Statement 对象而创建的所有自动生成的键。
ResultSet | DatabaseMetaData.getImportedKeys(String catalog, String schema, String table) 获取由给定表的外键列（表导入的主键）引用的主键列的描述。
ResultSet | DatabaseMetaData.getIndexInfo(String catalog, String schema, String table, boolean unique, boolean approximate) 获取给定表的索引和统计信息的描述。
ResultSet | DatabaseMetaData.getPrimaryKeys(String catalog, String schema, String table) 获取对给定表的主键列的描述。
ResultSet | DatabaseMetaData.getProcedureColumns(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern) 获取给定类别的存储过程参数和结果列的描述。
ResultSet | DatabaseMetaData.getProcedures(String catalog, String schemaPattern, String procedureNamePattern) 获取可在给定类别中使用的存储过程的描述。
ResultSet | Array.getResultSet() 获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
ResultSet | Statement.getResultSet() 以 ResultSet 对象的形式获取当前结果。
ResultSet | Array.getResultSet(long index, int count) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(long index, int count, Map<String,Class<?>> map) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(Map<String,Class<?>> map) 获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
ResultSet | DatabaseMetaData.getSchemas() 获取可在此数据库中使用的模式名称。
ResultSet | DatabaseMetaData.getSchemas(String catalog, String schemaPattern) 获取此数据库中可用的模式名称。
ResultSet | DatabaseMetaData.getSuperTables(String catalog, String schemaPattern, String tableNamePattern) 获取在此数据库的特定模式中定义的表分层结构的描述。
ResultSet | DatabaseMetaData.getSuperTypes(String catalog, String schemaPattern, String typeNamePattern) 获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。
ResultSet | DatabaseMetaData.getTablePrivileges(String catalog, String schemaPattern, String tableNamePattern) 获取可在类别中使用的每个表的访问权的描述。
ResultSet | DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types) 获取可在给定类别中使用的表的描述。
ResultSet | DatabaseMetaData.getTableTypes() 获取可在此数据库中使用的表类型。
ResultSet | DatabaseMetaData.getTypeInfo() 获取此数据库支持的所有数据类型的描述。
ResultSet | DatabaseMetaData.getUDTs(String catalog, String schemaPattern, String typeNamePattern, int[] types) 获取在特定模式中定义的用户定义类型 (UDT) 的描述。
ResultSet | DatabaseMetaData.getVersionColumns(String catalog, String schema, String table) 获取在更新行中的任意值时自动更新的表列的描述。

javax.sql 中 ResultSet 的使用

javax.sql 中 ResultSet 的子接口
 interface RowSet
该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。

返回 ResultSet 的 javax.sql 中的方法
ResultSet | RowSetInternal.getOriginal() 获取包含此 RowSet 对象原始值的 ResultSet 对象。
ResultSet | RowSetInternal.getOriginalRow() 获取仅包含当前行原始值的 ResultSet 对象。

javax.sql.rowset 中 ResultSet 的使用

javax.sql.rowset 中 ResultSet 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

返回 ResultSet 的 javax.sql.rowset 中的方法
ResultSet | CachedRowSet.getOriginal() 返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。
ResultSet | CachedRowSet.getOriginalRow() 返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。

参数类型为 ResultSet 的 javax.sql.rowset 中的方法
void | CachedRowSet.populate(ResultSet data) 使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
void | CachedRowSet.populate(ResultSet rs, int startRow) 使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
void | WebRowSet.writeXml(ResultSet rs, OutputStream oStream) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。
void | WebRowSet.writeXml(ResultSet rs, Writer writer) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。

javax.sql.rowset.serial 中 ResultSet 的使用

返回 ResultSet 的 javax.sql.rowset.serial 中的方法
ResultSet | SerialArray.getResultSet() 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。
ResultSet | SerialArray.getResultSet(long index, int count) 获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

javax.sql.rowset.spi 中 ResultSet 的使用

javax.sql.rowset.spi 中 ResultSet 的子接口
 interface SyncResolver
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.ResultSetMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.ResultSetMetaData
的使用

使用 ResultSetMetaData 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

java.sql 中 ResultSetMetaData 的使用

返回 ResultSetMetaData 的 java.sql 中的方法
ResultSetMetaData | PreparedStatement.getMetaData() 获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。
ResultSetMetaData | ResultSet.getMetaData() 获取此 ResultSet 对象的列的编号、类型和属性。

javax.sql 中 ResultSetMetaData 的使用

javax.sql 中 ResultSetMetaData 的子接口
 interface RowSetMetaData
该对象包含关于 RowSet 对象的列的信息。

javax.sql.rowset 中 ResultSetMetaData 的使用

实现 ResultSetMetaData 的 javax.sql.rowset 中的类
 class RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.RowId 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.RowId
的使用

使用 RowId 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 RowId 的使用

返回 RowId 的 java.sql 中的方法
RowId | CallableStatement.getRowId(int parameterIndex) 以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
RowId | ResultSet.getRowId(int columnIndex) 以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
RowId | CallableStatement.getRowId(String parameterName) 以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
RowId | ResultSet.getRowId(String columnLabel) 以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
RowId | SQLInput.readRowId() 从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。

参数类型为 RowId 的 java.sql 中的方法
void | PreparedStatement.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定 java.sql.RowId 对象。
void | CallableStatement.setRowId(String parameterName, RowId x) 将指定参数设置为给定 java.sql.RowId 对象。
void | ResultSet.updateRowId(int columnIndex, RowId x) 用 RowId 值更新指定列。
void | ResultSet.updateRowId(String columnLabel, RowId x) 用 RowId 值更新指定的列。
void | SQLOutput.writeRowId(RowId x) 将 SQL ROWID 值写入流中。

javax.sql 中 RowId 的使用

参数类型为 RowId 的 javax.sql 中的方法
void | RowSet.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | RowSet.setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。

javax.sql.rowset 中 RowId 的使用

参数类型为 RowId 的 javax.sql.rowset 中的方法
void | BaseRowSet.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | BaseRowSet.setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。

javax.sql.rowset.serial 中 RowId 的使用

返回 RowId 的 javax.sql.rowset.serial 中的方法
 RowId SQLInputImpl.readRowId()
从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。

参数类型为 RowId 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeRowId(RowId x)
将 SQL ROWID 值写入流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.RowIdLifetime 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.RowIdLifetime
的使用

使用 RowIdLifetime 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 RowIdLifetime 的使用

返回 RowIdLifetime 的 java.sql 中的方法
RowIdLifetime | DatabaseMetaData.getRowIdLifetime() 指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。
static RowIdLifetime | RowIdLifetime.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowIdLifetime[] | RowIdLifetime.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.SQLData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLData
的使用

使用 SQLData 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLData 的使用

参数类型为 SQLData 的 java.sql 中的方法
 void SQLOutput.writeObject(SQLData x)
将给定 SQLData 对象中包含的数据写入流中。

javax.sql.rowset.serial 中 SQLData 的使用

参数类型为 SQLData 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeObject(SQLData x)
将包含在给定 SQLData 对象中的数据写入流中。

参数类型为 SQLData 的 javax.sql.rowset.serial 中的构造方法
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLDataException
的使用

没有 java.sql.SQLDataException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLException
的使用

使用 SQLException 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 SQLException 的使用

java.sql 中 SQLException 的子类
class | BatchUpdateException 进行批量更新操作期间发生错误时抛出的 SQLException 子类。
class | DataTruncation 以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。
class | SQLClientInfoException 当无法在 Connection 上设置一个或多个客户端信息属性时，抛出此 SQLException 的子类。
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLNonTransientException 重试相同操作将失败（除非纠正了 SQLException 的 cause）的情况下抛出的 SQLException 子类。
class | SQLRecoverableException 应用程序执行某些恢复步骤并重试整个事务或事务分支（在分布式事务中）后，可以成功执行先前失败操作的情况下抛出的 SQLException 子类。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。
class | SQLTransientException 没有任何应用程序级功能干预时，重试先前失败操作可以成功的情况下抛出的 SQLException 子类。
class | SQLWarning 提供关于数据库访问警告信息的异常。

返回 SQLException 的 java.sql 中的方法
 SQLException SQLException.getNextException()
通过 setNextException(SQLException ex) 获取链接到此 SQLException 对象的异常。

参数类型为 SQLException 的 java.sql 中的方法
 void SQLException.setNextException(SQLException ex)
将 SQLException 对象添加到链接的末尾。

抛出 SQLException 的 java.sql 中的方法
 boolean ResultSet.absolute(int row)
将光标移动到此 ResultSet 对象的给定行编号。
 boolean Driver.acceptsURL(String url)
查询驱动程序是否认为它可以打开到给定 URL 的连接。
 void PreparedStatement.addBatch()
将一组参数添加到此 PreparedStatement 对象的批处理命令中。
 void Statement.addBatch(String sql)
将给定的 SQL 命令添加到此 Statement 对象的当前命令列表中。
 void ResultSet.afterLast()
将光标移动到此 ResultSet 对象的末尾，正好位于最后一行之后。
 boolean DatabaseMetaData.allProceduresAreCallable()
获取当前用户是否可以调用 getProcedures 方法返回的所有过程。
 boolean DatabaseMetaData.allTablesAreSelectable()
获取当前用户是否可以使用 SELECT 语句中的 getTables 方法返回的所有表。
 boolean DatabaseMetaData.autoCommitFailureClosesAllResultSets()
当 autoCommit 为 true 时，获取 SQLException 是否指示所有打开的 ResultSets 已关闭（包括那些可保持的）。
 void ResultSet.beforeFirst()
将光标移动到此 ResultSet 对象的开头，正好位于第一行之前。
 void Statement.cancel()
如果 DBMS 和驱动程序都支持中止 SQL 语句，则取消此 Statement 对象。
 void ResultSet.cancelRowUpdates()
取消对 ResultSet 对象中的当前行所作的更新。
 void Statement.clearBatch()
清空此 Statement 对象的当前 SQL 命令列表。
 void PreparedStatement.clearParameters()
立即清除当前参数值。
 void Connection.clearWarnings()
清除为此 Connection 对象报告的所有警告。
 void ResultSet.clearWarnings()
清除在此 ResultSet 对象上报告的所有警告。
 void Statement.clearWarnings()
清除在此 Statement 对象上报告的所有警告。
 void Connection.close()
立即释放此 Connection 对象的数据库和 JDBC 资源，而不是等待它们被自动释放。
 void ResultSet.close()
立即释放此 ResultSet 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
 void Statement.close()
立即释放此 Statement 对象的数据库和 JDBC 资源，而不是等待该对象自动关闭时发生此操作。
 void Connection.commit()
使所有上一次提交/回滚后进行的更改成为持久更改，并释放此 Connection 对象当前持有的所有数据库锁。
 Connection Driver.connect(String url, Properties info)
试图创建一个到给定 URL 的数据库连接。
 Array Connection.createArrayOf(String typeName, Object[] elements)
创建 Array 对象的工厂方法。
 Blob Connection.createBlob()
构造实现 Blob 接口的对象。
 Clob Connection.createClob()
构造实现 Clob 接口的对象。
 NClob Connection.createNClob()
构造实现 NClob 接口的对象。
 SQLXML Connection.createSQLXML()
构造实现 SQLXML 接口的对象。
 Statement Connection.createStatement()
创建一个 Statement 对象来将 SQL 语句发送到数据库。
 Statement Connection.createStatement(int resultSetType, int resultSetConcurrency)
创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 Statement Connection.createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
 Struct Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。
 boolean DatabaseMetaData.dataDefinitionCausesTransactionCommit()
获取事务中的数据定义语句是否强迫该事务进行提交。
 boolean DatabaseMetaData.dataDefinitionIgnoredInTransactions()
获取此数据库是否忽略事务中的数据定义语句。
 void ResultSet.deleteRow()
从此 ResultSet 对象和底层数据库中删除当前行。
 boolean DatabaseMetaData.deletesAreDetected(int type)
获取是否可以通过调用 ResultSet.rowDeleted 方法检测可见行的删除。
static void DriverManager.deregisterDriver(Driver driver)
从 DriverManager 的列表中删除一个驱动程序。
 boolean DatabaseMetaData.doesMaxRowSizeIncludeBlobs()
获取 getMaxRowSize 方法的返回值是否包括 SQL 数据类型 LONGVARCHAR 和 LONGVARBINARY。
 boolean PreparedStatement.execute()
在此 PreparedStatement 对象中执行 SQL 语句，该语句可以是任何种类的 SQL 语句。
 boolean Statement.execute(String sql)
执行给定的 SQL 语句，该语句可能返回多个结果。
 boolean Statement.execute(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序所有自动生成的键都应该可用于获取。
 boolean Statement.execute(String sql, int[] columnIndexes)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 boolean Statement.execute(String sql, String[] columnNames)
执行给定的 SQL 语句（该语句可能返回多个结果），并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 int[] Statement.executeBatch()
将一批命令提交给数据库来执行，如果全部命令执行成功，则返回更新计数组成的数组。
 ResultSet PreparedStatement.executeQuery()
在此 PreparedStatement 对象中执行 SQL 查询，并返回该查询生成的 ResultSet 对象。
 ResultSet Statement.executeQuery(String sql)
执行给定的 SQL 语句，该语句返回单个 ResultSet 对象。
 int PreparedStatement.executeUpdate()
在此 PreparedStatement 对象中执行 SQL 语句，该语句必须是一个 SQL 数据操作语言（Data Manipulation Language，DML）语句，比如 INSERT、UPDATE 或 DELETE 语句；或者是无返回内容的 SQL 语句，比如 DDL 语句。
 int Statement.executeUpdate(String sql)
执行给定 SQL 语句，该语句可能为 INSERT、UPDATE 或 DELETE 语句，或者不返回任何内容的 SQL 语句（如 SQL DDL 语句）。
 int Statement.executeUpdate(String sql, int autoGeneratedKeys)
执行给定的 SQL 语句，并用给定标志通知驱动程序由此 Statement 生成的自动生成键是否可用于获取。
 int Statement.executeUpdate(String sql, int[] columnIndexes)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 int Statement.executeUpdate(String sql, String[] columnNames)
执行给定的 SQL 语句，并通知驱动程序在给定数组中指示的自动生成的键应该可用于获取。
 int ResultSet.findColumn(String columnLabel)
将给定的 ResultSet 列标签映射到其 ResultSet 列索引。
 boolean ResultSet.first()
将光标移动到此 ResultSet 对象的第一行。
 void Array.free()
此方法释放 Array 对象以及它占用的资源。
 void Blob.free()
此方法释放 Blob 对象以及它所占用的资源。
 void Clob.free()
此方法释放 Clob 对象以及它所占用的资源。
 void SQLXML.free()
此方法关闭此对象并释放其持有的资源。
 Object Array.getArray()
以 Java 编程语言数组的形式获取由此 Array 对象指定的 SQL ARRAY 值的内容。
 Array CallableStatement.getArray(int parameterIndex)
以 Java 编程语言中 Array 对象的形式获取指定的 JDBC ARRAY 参数的值。
 Array ResultSet.getArray(int columnIndex)
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object Array.getArray(long index, int count)
获取由此 Array 对象指定的 SQL ARRAY 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
 Object Array.getArray(long index, int count, Map<String,Class<?>> map)
获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
 Object Array.getArray(Map<String,Class<?>> map)
获取由此 Array 对象指定的 SQL ARRAY 值的内容。
 Array CallableStatement.getArray(String parameterName)
以 Java 编程语言中 java.sql.ARRAY 对象的形式获取 JDBC ARRAY 参数的值。
 Array ResultSet.getArray(String columnLabel)
以 Java 编程语言中 Array 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 InputStream Clob.getAsciiStream()
以 ascii 流形式获取此 Clob 对象指定的 CLOB 值。
 InputStream ResultSet.getAsciiStream(int columnIndex)
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
 InputStream ResultSet.getAsciiStream(String columnLabel)
以 ASCII 字符流的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object[] Struct.getAttributes()
生成此 Struct 对象所表示的 SQL 结构类型属性的有序值。
 Object[] Struct.getAttributes(Map<String,Class<?>> map)
生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
 ResultSet DatabaseMetaData.getAttributes(String catalog, String schemaPattern, String typeNamePattern, String attributeNamePattern)
获取可在给定模式和类别中使用的用户定义类型 (UDT) 的给定类型的给定属性的描述。
 boolean Connection.getAutoCommit()
获取此 Connection 对象的当前自动提交模式。
 int Array.getBaseType()
在由此 Array 对象指定的数组中获取元素的 JDBC 类型。
 String Array.getBaseTypeName()
在由此 Array 对象指定的数组中获取元素的 SQL 类型名称。
 String Ref.getBaseTypeName()
获取此 Ref 对象所引用 SQL 结构类型的完全限定的 SQL 名称。
 ResultSet DatabaseMetaData.getBestRowIdentifier(String catalog, String schema, String table, int scope, boolean nullable)
获取唯一标识行的表的最佳列集合的描述。
 BigDecimal CallableStatement.getBigDecimal(int parameterIndex)
以 java.math.BigDecimal 对象的形式获取指定 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
 BigDecimal ResultSet.getBigDecimal(int columnIndex)
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
 BigDecimal CallableStatement.getBigDecimal(int parameterIndex, int scale)
已过时。 使用 getBigDecimal(int parameterIndex) 或 getBigDecimal(String parameterName)
 BigDecimal ResultSet.getBigDecimal(int columnIndex, int scale)
已过时。
 BigDecimal CallableStatement.getBigDecimal(String parameterName)
以 java.math.BigDecimal 对象的形式获取 JDBC NUMERIC 参数的值，小数点右边的位数与该参数值所包含的位数相同。
 BigDecimal ResultSet.getBigDecimal(String columnLabel)
以具有全精度的 java.math.BigDecimal 的形式获取此 ResultSet 对象的当前行中指定列的值。
 BigDecimal ResultSet.getBigDecimal(String columnLabel, int scale)
已过时。
 InputStream Blob.getBinaryStream()
以流的形式获取此 Blob 实例指定的 BLOB 值。
 InputStream SQLXML.getBinaryStream()
以流的形式获取此 SQLXML 实例指定的 XML 值。
 InputStream ResultSet.getBinaryStream(int columnIndex)
以未解释字节的流的形式获取此 ResultSet 对象的当前行中指定列的值。
 InputStream Blob.getBinaryStream(long pos, long length)
返回包含部分 Blob 值的 InputStream 对象，该值从 pos 指定的字节开始，长度为 length 个字节。
 InputStream ResultSet.getBinaryStream(String columnLabel)
以未解释的 byte 流的形式获取此 ResultSet 对象的当前行中指定列的值。
 Blob CallableStatement.getBlob(int parameterIndex)
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
 Blob ResultSet.getBlob(int columnIndex)
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Blob CallableStatement.getBlob(String parameterName)
以 Java 编程语言中 Blob 对象的形式获取 JDBC BLOB 参数的值。
 Blob ResultSet.getBlob(String columnLabel)
以 Java 编程语言中 Blob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 boolean CallableStatement.getBoolean(int parameterIndex)
以 Java 编程语言中 boolean 值的形式获取指定的 JDBC BIT 或 BOOLEAN 参数的值。
 boolean ResultSet.getBoolean(int columnIndex)
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
 boolean CallableStatement.getBoolean(String parameterName)
以 Java 编程语言中 boolean 值的形式获取 JDBC BIT 或 BOOLEAN 参数的值。
 boolean ResultSet.getBoolean(String columnLabel)
以 Java 编程语言中 boolean 的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte CallableStatement.getByte(int parameterIndex)
以 Java 编程语言中 byte 的形式获取指定的 JDBC TINYINT 参数的值。
 byte ResultSet.getByte(int columnIndex)
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte CallableStatement.getByte(String parameterName)
以 Java 编程语言中 byte 值的形式获取 JDBC TINYINT 参数的值。
 byte ResultSet.getByte(String columnLabel)
以 Java 编程语言中 byte 的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte[] CallableStatement.getBytes(int parameterIndex)
以 Java 编程语言中 byte 数组值的形式获取指定的 JDBC BINARY 或 VARBINARY 参数的值。
 byte[] ResultSet.getBytes(int columnIndex)
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
 byte[] Blob.getBytes(long pos, int length)
以 byte 数组的形式获取此 Blob 对象表示的全部或部分 BLOB 值。
 byte[] CallableStatement.getBytes(String parameterName)
以 Java 编程语言中 byte 数组值的形式获取 JDBC BINARY 或 VARBINARY 参数的值。
 byte[] ResultSet.getBytes(String columnLabel)
以 Java 编程语言中 byte 数组的形式获取此 ResultSet 对象的当前行中指定列的值。
 String Connection.getCatalog()
获取此 Connection 对象的当前目录名称。
 String ResultSetMetaData.getCatalogName(int column)
获取指定列的表目录名称。
 ResultSet DatabaseMetaData.getCatalogs()
获取可在此数据库中使用的类别名称。
 String DatabaseMetaData.getCatalogSeparator()
获取此数据库用作类别和表名之间的分隔符的 String。
 String DatabaseMetaData.getCatalogTerm()
获取数据库供应商用于 "catalog" 的首选术语。
 Reader Clob.getCharacterStream()
以 java.io.Reader 对象形式（或字符流形式）获取此 Clob 对象指定的 CLOB 值。
 Reader SQLXML.getCharacterStream()
以 java.io.Reader 对象的形式获取此 SQLXML 实例指定的 XML 值。
 Reader CallableStatement.getCharacterStream(int parameterIndex)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getCharacterStream(int columnIndex)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Reader Clob.getCharacterStream(long pos, long length)
返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
 Reader CallableStatement.getCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Properties Connection.getClientInfo()
返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。
 String Connection.getClientInfo(String name)
返回通过名称指定的客户端信息属性的值。
 ResultSet DatabaseMetaData.getClientInfoProperties()
获取驱动程序支持的客户端信息属性的列表。
 Clob CallableStatement.getClob(int parameterIndex)
以 Java 编程语言中 java.sql.Clob 对象的形式获取指定的 JDBC CLOB 参数的值。
 Clob ResultSet.getClob(int columnIndex)
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Clob CallableStatement.getClob(String parameterName)
以 Java 编程语言中 java.sql.CLOB 对象的形式获取 JDBC CLOB 参数的值。
 Clob ResultSet.getClob(String columnLabel)
以 Java 编程语言中 Clob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String ResultSetMetaData.getColumnClassName(int column)
如果调用方法 ResultSet.getObject 从列中获取值，则返回构造其实例的 Java 类的完全限定名称。
 int ResultSetMetaData.getColumnCount()
返回此 ResultSet 对象中的列数。
 int ResultSetMetaData.getColumnDisplaySize(int column)
指示指定列的最大标准宽度，以字符为单位。
 String ResultSetMetaData.getColumnLabel(int column)
获取用于打印输出和显示的指定列的建议标题。
 String ResultSetMetaData.getColumnName(int column)
获取指定列的名称。
 ResultSet DatabaseMetaData.getColumnPrivileges(String catalog, String schema, String table, String columnNamePattern)
获取用于表列的访问权的描述。
 ResultSet DatabaseMetaData.getColumns(String catalog, String schemaPattern, String tableNamePattern, String columnNamePattern)
获取可在指定类别中使用的表列的描述。
 int ResultSetMetaData.getColumnType(int column)
获取指定列的 SQL 类型。
 String ResultSetMetaData.getColumnTypeName(int column)
获取指定列的数据库特定的类型名称。
 int ResultSet.getConcurrency()
获取此 ResultSet 对象的并发模式。
 Connection DatabaseMetaData.getConnection()
获取此元数据对象所产生的连接。
 Connection Statement.getConnection()
获取生成此 Statement 对象的 Connection 对象。
static Connection DriverManager.getConnection(String url)
试图建立到给定数据库 URL 的连接。
static Connection DriverManager.getConnection(String url, Properties info)
试图建立到给定数据库 URL 的连接。
static Connection DriverManager.getConnection(String url, String user, String password)
试图建立到给定数据库 URL 的连接。
 ResultSet DatabaseMetaData.getCrossReference(String parentCatalog, String parentSchema, String parentTable, String foreignCatalog, String foreignSchema, String foreignTable)
获取给定外键列表中外键列的描述，这些列引用主键或表示父表（可能是相同的表，也可能是不同的表）唯一约束的列。
 String ResultSet.getCursorName()
获取此 ResultSet 对象使用的 SQL 光标的名称。
 int DatabaseMetaData.getDatabaseMajorVersion()
获取底层数据库的主版本号。
 int DatabaseMetaData.getDatabaseMinorVersion()
底层数据库的次版本号。
 String DatabaseMetaData.getDatabaseProductName()
获取此数据库产品的名称。
 String DatabaseMetaData.getDatabaseProductVersion()
获取此数据库产品的版本号。
 Date CallableStatement.getDate(int parameterIndex)
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值。
 Date ResultSet.getDate(int columnIndex)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Date CallableStatement.getDate(int parameterIndex, Calendar cal)
以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
 Date ResultSet.getDate(int columnIndex, Calendar cal)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Date CallableStatement.getDate(String parameterName)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值。
 Date ResultSet.getDate(String columnLabel)
以 Java 编程语言中的 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Date CallableStatement.getDate(String parameterName, Calendar cal)
以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
 Date ResultSet.getDate(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 int DatabaseMetaData.getDefaultTransactionIsolation()
获取此数据库的默认事务隔离级别。
 double CallableStatement.getDouble(int parameterIndex)
以 Java 编程语言中 double 值的形式获取指定的 JDBC DOUBLE 参数的值。
 double ResultSet.getDouble(int columnIndex)
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
 double CallableStatement.getDouble(String parameterName)
以 Java 编程语言中 double 值的形式获取 JDBC DOUBLE 参数的值。
 double ResultSet.getDouble(String columnLabel)
以 Java 编程语言中 double 的形式获取此 ResultSet 对象的当前行中指定列的值。
static Driver DriverManager.getDriver(String url)
试图查找能理解给定 URL 的驱动程序。
 String DatabaseMetaData.getDriverName()
获取此 JDBC 驱动程序的名称。
 String DatabaseMetaData.getDriverVersion()
获取此 JDBC 驱动程序的 String 形式的版本号。
 ResultSet DatabaseMetaData.getExportedKeys(String catalog, String schema, String table)
获取引用给定表的主键列（表导入的外键）的外键列的描述。
 String DatabaseMetaData.getExtraNameCharacters()
获取可以在不带引号的标识符名称中使用的所有“额外”字符（除了 a-z、A-Z、0-9 和 _ 以外的字符）。
 int ResultSet.getFetchDirection()
获取此 ResultSet 对象的获取方向。
 int Statement.getFetchDirection()
获取从数据库表获取行的方向，该方向是根据此 Statement 对象生成的结果集合的默认值。
 int ResultSet.getFetchSize()
获取此 ResultSet 对象的获取大小。
 int Statement.getFetchSize()
获取结果集合的行数，该数是根据此 Statement 对象生成的 ResultSet 对象的默认获取大小。
 float CallableStatement.getFloat(int parameterIndex)
以 Java 编程语言中 float 值的形式获取指定的 JDBC FLOAT 参数的值。
 float ResultSet.getFloat(int columnIndex)
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
 float CallableStatement.getFloat(String parameterName)
以 Java 编程语言中 float 值的形式获取 JDBC FLOAT 参数的值。
 float ResultSet.getFloat(String columnLabel)
以 Java 编程语言中 float 的形式获取此 ResultSet 对象的当前行中指定列的值。
 ResultSet DatabaseMetaData.getFunctionColumns(String catalog, String schemaPattern, String functionNamePattern, String columnNamePattern)
获取给定类别的系统或用户函数参数和返回类型的描述。
 ResultSet DatabaseMetaData.getFunctions(String catalog, String schemaPattern, String functionNamePattern)
获取给定类别中可用的系统和用户函数的描述。
 ResultSet Statement.getGeneratedKeys()
获取由于执行此 Statement 对象而创建的所有自动生成的键。
 int Connection.getHoldability()
获取使用此 Connection 对象创建的 ResultSet 对象的当前可保存性。
 int ResultSet.getHoldability()
获取此 ResultSet 对象的可保存性
 String DatabaseMetaData.getIdentifierQuoteString()
获取用于引用 SQL 标识符的字符串。
 ResultSet DatabaseMetaData.getImportedKeys(String catalog, String schema, String table)
获取由给定表的外键列（表导入的主键）引用的主键列的描述。
 ResultSet DatabaseMetaData.getIndexInfo(String catalog, String schema, String table, boolean unique, boolean approximate)
获取给定表的索引和统计信息的描述。
 int CallableStatement.getInt(int parameterIndex)
以 Java 编程语言中 int 值的形式获取指定的 JDBC INTEGER 参数的值。
 int ResultSet.getInt(int columnIndex)
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
 int CallableStatement.getInt(String parameterName)
以 Java 编程语言中 int 值的形式获取 JDBC INTEGER 参数的值。
 int ResultSet.getInt(String columnLabel)
以 Java 编程语言中 int 的形式获取此 ResultSet 对象的当前行中指定列的值。
 int DatabaseMetaData.getJDBCMajorVersion()
获取此驱动程序的主 JDBC 版本号。
 int DatabaseMetaData.getJDBCMinorVersion()
获取此驱动程序的次 JDBC 版本号。
 long CallableStatement.getLong(int parameterIndex)
以 Java 编程语言中 long 值的形式获取指定的 JDBC BIGINT 参数的值。
 long ResultSet.getLong(int columnIndex)
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
 long CallableStatement.getLong(String parameterName)
以 Java 编程语言中 long 值的形式获取 JDBC BIGINT 参数的值。
 long ResultSet.getLong(String columnLabel)
以 Java 编程语言中 long 的形式获取此 ResultSet 对象的当前行中指定列的值。
 int DatabaseMetaData.getMaxBinaryLiteralLength()
获取此数据库允许在内嵌二进制字面值中使用的最大十六进制字符数。
 int DatabaseMetaData.getMaxCatalogNameLength()
获取此数据库允许用于类别名称的最大字符数。
 int DatabaseMetaData.getMaxCharLiteralLength()
获取此数据库允许用于字符字面值的最大字符数。
 int DatabaseMetaData.getMaxColumnNameLength()
获取此数据库允许用于列名称的最大字符数。
 int DatabaseMetaData.getMaxColumnsInGroupBy()
获取此数据库允许在 GROUP BY 子句中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInIndex()
获取此数据库允许在索引中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInOrderBy()
获取此数据库允许在 ORDER BY 子句中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInSelect()
获取此数据库允许在 SELECT 列表中使用的最大列数。
 int DatabaseMetaData.getMaxColumnsInTable()
获取此数据库允许在表中使用的最大列数。
 int DatabaseMetaData.getMaxConnections()
获取连接到此数据库的并发连接的可能最大数。
 int DatabaseMetaData.getMaxCursorNameLength()
获取此数据库允许用于游标名称的最大字符数。
 int Statement.getMaxFieldSize()
获取可以为此 Statement 对象所生成 ResultSet 对象中的字符和二进制列值返回的最大字节数。
 int DatabaseMetaData.getMaxIndexLength()
获取此数据库允许用于索引（包括索引的所有部分）的最大字节数。
 int DatabaseMetaData.getMaxProcedureNameLength()
获取此数据库允许用于过程名称的最大字符数。
 int Statement.getMaxRows()
获取由此 Statement 对象生成的 ResultSet 对象可以包含的最大行数。
 int DatabaseMetaData.getMaxRowSize()
获取此数据库允许在单行中使用的最大字节数。
 int DatabaseMetaData.getMaxSchemaNameLength()
获取此数据库允许在模式名称中使用的最大字符数。
 int DatabaseMetaData.getMaxStatementLength()
获取此数据库允许在 SQL 语句中使用的最大字符数。
 int DatabaseMetaData.getMaxStatements()
获取在此数据库中在同一时间内可处于开放状态的最大活动语句数。
 int DatabaseMetaData.getMaxTableNameLength()
获取此数据库允许在表名称中使用的最大字符数。
 int DatabaseMetaData.getMaxTablesInSelect()
获取此数据库允许在 SELECT 语句中使用的表的最大数量。
 int DatabaseMetaData.getMaxUserNameLength()
获取此数据库允许在用户名称中使用的最大字符数。
 DatabaseMetaData Connection.getMetaData()
获取一个 DatabaseMetaData 对象，该对象包含关于此 Connection 对象所连接的数据库的元数据。
 ResultSetMetaData PreparedStatement.getMetaData()
获取包含有关 ResultSet 对象列信息的 ResultSetMetaData 对象，ResultSet 对象将在执行此 PreparedStatement 对象时返回。
 ResultSetMetaData ResultSet.getMetaData()
获取此 ResultSet 对象的列的编号、类型和属性。
 boolean Statement.getMoreResults()
移动到此 Statement 对象的下一个结果，如果其为 ResultSet 对象，则返回 true，并隐式关闭利用方法 getResultSet 获取的所有当前 ResultSet 对象。
 boolean Statement.getMoreResults(int current)
将此 Statement 对象移动到下一个结果，根据给定标志指定的指令处理所有当前 ResultSet 对象；如果下一个结果为 ResultSet 对象，则返回 true。
 Reader CallableStatement.getNCharacterStream(int parameterIndex)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getNCharacterStream(int columnIndex)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Reader CallableStatement.getNCharacterStream(String parameterName)
以 Java 编程语言中 java.io.Reader 对象的形式获取指定参数的值。
 Reader ResultSet.getNCharacterStream(String columnLabel)
以 java.io.Reader 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 NClob CallableStatement.getNClob(int parameterIndex)
以 Java 编程语言中 java.sql.NClob 对象的形式获取指定的 JDBC NCLOB 参数的值。
 NClob ResultSet.getNClob(int columnIndex)
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 NClob CallableStatement.getNClob(String parameterName)
以 Java 编程语言中 java.sql.NClob 对象的形式获取 JDBC NCLOB 参数的值。
 NClob ResultSet.getNClob(String columnLabel)
以 Java 编程语言中 NClob 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String CallableStatement.getNString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
 String ResultSet.getNString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String CallableStatement.getNString(String parameterName)
以 Java 编程语言中 String 的形式获取指定的 NCHAR、NVARCHAR 或 LONGNVARCHAR 参数的值。
 String ResultSet.getNString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getNumericFunctions()
获取可用于此数据库的数学函数的逗号分隔列表。
 Object Ref.getObject()
获取此 Ref 对象引用的 SQL 结构类型实例。
 Object CallableStatement.getObject(int parameterIndex)
以 Java 编程语言中 Object 的形式获取指定参数的值。
 Object ResultSet.getObject(int columnIndex)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
 Object ResultSet.getObject(int columnIndex, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object Ref.getObject(Map<String,Class<?>> map)
获取引用对象并使用给定类型映射表将其映射到 Java 类型。
 Object CallableStatement.getObject(String parameterName)
以 Java 编程语言中 Object 的形式获取参数的值。
 Object ResultSet.getObject(String columnLabel)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 Object CallableStatement.getObject(String parameterName, Map<String,Class<?>> map)
返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
 Object ResultSet.getObject(String columnLabel, Map<String,Class<?>> map)
以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String ParameterMetaData.getParameterClassName(int param)
获取 Java 类的完全限定名称，该类的实例应该传递给 PreparedStatement.setObject 方法。
 int ParameterMetaData.getParameterCount()
获取 PreparedStatement 对象中的参数的数量，此 ParameterMetaData 对象包含了该对象的信息。
 ParameterMetaData PreparedStatement.getParameterMetaData()
获取此 PreparedStatement 对象的参数的编号、类型和属性。
 int ParameterMetaData.getParameterMode(int param)
获取指定参数的模式。
 int ParameterMetaData.getParameterType(int param)
获取指定参数的 SQL 类型。
 String ParameterMetaData.getParameterTypeName(int param)
获取指定参数的特定于数据库的类型名称。
 int ParameterMetaData.getPrecision(int param)
获取指定参数的指定列大小。
 int ResultSetMetaData.getPrecision(int column)
获取指定列的指定列宽。
 ResultSet DatabaseMetaData.getPrimaryKeys(String catalog, String schema, String table)
获取对给定表的主键列的描述。
 ResultSet DatabaseMetaData.getProcedureColumns(String catalog, String schemaPattern, String procedureNamePattern, String columnNamePattern)
获取给定类别的存储过程参数和结果列的描述。
 ResultSet DatabaseMetaData.getProcedures(String catalog, String schemaPattern, String procedureNamePattern)
获取可在给定类别中使用的存储过程的描述。
 String DatabaseMetaData.getProcedureTerm()
获取数据库供应商用于 "procedure" 的首选术语。
 DriverPropertyInfo[] Driver.getPropertyInfo(String url, Properties info)
获得此驱动程序的可能属性信息。
 int Statement.getQueryTimeout()
获取驱动程序等待 Statement 对象执行的秒数。
 Ref CallableStatement.getRef(int parameterIndex)
以 Java 编程语言中 Ref 对象的形式获取指定的 JDBC REF(<structured-type>) 参数的值。
 Ref ResultSet.getRef(int columnIndex)
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Ref CallableStatement.getRef(String parameterName)
以 Java 编程语言中 Ref 对象的形式获取 JDBC REF(<structured-type>) 参数的值。
 Ref ResultSet.getRef(String columnLabel)
以 Java 编程语言中 Ref 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 ResultSet Array.getResultSet()
获取包含此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
 ResultSet Statement.getResultSet()
以 ResultSet 对象的形式获取当前结果。
 ResultSet Array.getResultSet(long index, int count)
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
 ResultSet Array.getResultSet(long index, int count, Map<String,Class<?>> map)
获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
 ResultSet Array.getResultSet(Map<String,Class<?>> map)
获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
 int Statement.getResultSetConcurrency()
获取此 Statement 对象生成的 ResultSet 对象的结果集合并发性。
 int DatabaseMetaData.getResultSetHoldability()
针对 ResultSet 对象获取此数据库的默认可保存性。
 int Statement.getResultSetHoldability()
获取此 Statement 对象生成的 ResultSet 对象的结果集合可保存性。
 int Statement.getResultSetType()
获取此 Statement 对象生成的 ResultSet 对象的结果集合类型。
 int ResultSet.getRow()
获取当前行编号。
 RowId CallableStatement.getRowId(int parameterIndex)
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
 RowId ResultSet.getRowId(int columnIndex)
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 RowId CallableStatement.getRowId(String parameterName)
以 java.sql.RowId 对象的形式获取指定 JDBC ROWID 参数的值。
 RowId ResultSet.getRowId(String columnLabel)
以 Java 编程语言中 java.sql.RowId 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 RowIdLifetime DatabaseMetaData.getRowIdLifetime()
指示此数据源是否支持 SQL ROWID 类型，如果支持，则 RowId 对象在该类型的生存期内持续有效。
 int Savepoint.getSavepointId()
获取此 Savepoint 对象表示的保存点的生成 ID。
 String Savepoint.getSavepointName()
获取此 Savepoint 对象表示的保存点的名称。
 int ParameterMetaData.getScale(int param)
获取指定参数的小数点右边的位数。
 int ResultSetMetaData.getScale(int column)
获取指定列的小数点右边的位数。
 String ResultSetMetaData.getSchemaName(int column)
获取指定列的表模式。
 ResultSet DatabaseMetaData.getSchemas()
获取可在此数据库中使用的模式名称。
 ResultSet DatabaseMetaData.getSchemas(String catalog, String schemaPattern)
获取此数据库中可用的模式名称。
 String DatabaseMetaData.getSchemaTerm()
获取数据库供应商用于 "schema" 的首选术语。
 String DatabaseMetaData.getSearchStringEscape()
获取可用于转义通配符的字符串。
 short CallableStatement.getShort(int parameterIndex)
以 Java 编程语言中 short 值的形式获取指定的 JDBC SMALLINT 参数的值。
 short ResultSet.getShort(int columnIndex)
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
 short CallableStatement.getShort(String parameterName)
以 Java 编程语言中 short 值的形式获取 JDBC SMALLINT 参数的值。
 short ResultSet.getShort(String columnLabel)
以 Java 编程语言中 short 的形式获取此 ResultSet 对象的当前行中指定列的值。
<T extends Source>
T
SQLXML.getSource(Class<T> sourceClass)
返回读取此 SQLXML 实例指定的 XML 值的 Source。
 String DatabaseMetaData.getSQLKeywords()
获取此数据库的还“不”是 SQL:2003 关键字的所有 SQL 关键字的逗号分隔列表。
 int DatabaseMetaData.getSQLStateType()
指示由 SQLException.getSQLState 返回的 SQLSTATE 是 X/Open（现在称为 Open Group）SQL CLI 还是 SQL:2003。
 String SQLData.getSQLTypeName()
返回此对象表示的 SQL 用户定义类型的完全限定名。
 String Struct.getSQLTypeName()
获取此 Struct 对象所表示 SQL 结构的完全限定的 SQL 名称。
 SQLXML CallableStatement.getSQLXML(int parameterIndex)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
 SQLXML ResultSet.getSQLXML(int columnIndex)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 SQLXML CallableStatement.getSQLXML(String parameterName)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
 SQLXML ResultSet.getSQLXML(String columnLabel)
以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Statement ResultSet.getStatement()
获取生成此 ResultSet 对象的 Statement 对象。
 String SQLXML.getString()
返回此 SQLXML 实例指定的 XML 值的字符串表示形式。
 String CallableStatement.getString(int parameterIndex)
以 Java 编程语言中 String 的形式获取指定的 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
 String ResultSet.getString(int columnIndex)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String CallableStatement.getString(String parameterName)
以 Java 编程语言中 String 的形式获取 JDBC CHAR、VARCHAR 或 LONGVARCHAR 参数的值。
 String ResultSet.getString(String columnLabel)
以 Java 编程语言中 String 的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getStringFunctions()
获取可用于此数据库的字符串函数的逗号分隔列表。
 String Clob.getSubString(long pos, int length)
获取此 Clob 对象指定的 CLOB 值中指定子字符串的副本。
 ResultSet DatabaseMetaData.getSuperTables(String catalog, String schemaPattern, String tableNamePattern)
获取在此数据库的特定模式中定义的表分层结构的描述。
 ResultSet DatabaseMetaData.getSuperTypes(String catalog, String schemaPattern, String typeNamePattern)
获取在此数据库的特定模式中定义的用户定义类型 (UDT) 分层结构的描述。
 String DatabaseMetaData.getSystemFunctions()
获取可用于此数据库的系统函数的逗号分隔列表。
 String ResultSetMetaData.getTableName(int column)
获取指定列的名称。
 ResultSet DatabaseMetaData.getTablePrivileges(String catalog, String schemaPattern, String tableNamePattern)
获取可在类别中使用的每个表的访问权的描述。
 ResultSet DatabaseMetaData.getTables(String catalog, String schemaPattern, String tableNamePattern, String[] types)
获取可在给定类别中使用的表的描述。
 ResultSet DatabaseMetaData.getTableTypes()
获取可在此数据库中使用的表类型。
 Time CallableStatement.getTime(int parameterIndex)
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。
 Time ResultSet.getTime(int columnIndex)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Time CallableStatement.getTime(int parameterIndex, Calendar cal)
以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
 Time ResultSet.getTime(int columnIndex, Calendar cal)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Time CallableStatement.getTime(String parameterName)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。
 Time ResultSet.getTime(String columnLabel)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Time CallableStatement.getTime(String parameterName, Calendar cal)
以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
 Time ResultSet.getTime(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getTimeDateFunctions()
获取可用于此数据库的时间和日期函数的逗号分隔列表。
 Timestamp CallableStatement.getTimestamp(int parameterIndex)
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。
 Timestamp ResultSet.getTimestamp(int columnIndex)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Timestamp CallableStatement.getTimestamp(int parameterIndex, Calendar cal)
以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
 Timestamp ResultSet.getTimestamp(int columnIndex, Calendar cal)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Timestamp CallableStatement.getTimestamp(String parameterName)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。
 Timestamp ResultSet.getTimestamp(String columnLabel)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 Timestamp CallableStatement.getTimestamp(String parameterName, Calendar cal)
以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
 Timestamp ResultSet.getTimestamp(String columnLabel, Calendar cal)
以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 int Connection.getTransactionIsolation()
获取此 Connection 对象的当前事务隔离级别。
 int ResultSet.getType()
获取此 ResultSet 对象的类型。
 ResultSet DatabaseMetaData.getTypeInfo()
获取此数据库支持的所有数据类型的描述。
 Map<String,Class<?>> Connection.getTypeMap()
获取与此 Connection 对象关联的 Map 对象。
 ResultSet DatabaseMetaData.getUDTs(String catalog, String schemaPattern, String typeNamePattern, int[] types)
获取在特定模式中定义的用户定义类型 (UDT) 的描述。
 InputStream ResultSet.getUnicodeStream(int columnIndex)
已过时。 使用 getCharacterStream 取代 getUnicodeStream
 InputStream ResultSet.getUnicodeStream(String columnLabel)
已过时。 使用 getCharacterStream 代替
 int Statement.getUpdateCount()
以更新计数的形式获取当前结果；如果结果为 ResultSet 对象或没有更多结果，则返回 -1。
 String DatabaseMetaData.getURL()
获取此 DBMS 的 URL。
 URL CallableStatement.getURL(int parameterIndex)
以 java.sql.URL 对象的形式获取指定 JDBC DATALINK 参数的值。
 URL ResultSet.getURL(int columnIndex)
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 URL CallableStatement.getURL(String parameterName)
以 java.net.URL 对象的形式获取 JDBC DATALINK 参数的值。
 URL ResultSet.getURL(String columnLabel)
以 Java 编程语言中 java.net.URL 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
 String DatabaseMetaData.getUserName()
获取此数据库的已知的用户名称。
 ResultSet DatabaseMetaData.getVersionColumns(String catalog, String schema, String table)
获取在更新行中的任意值时自动更新的表列的描述。
 SQLWarning Connection.getWarnings()
获取此 Connection 对象上的调用报告的第一个警告。
 SQLWarning ResultSet.getWarnings()
获取此 ResultSet 对象上的调用报告的第一个警告。
 SQLWarning Statement.getWarnings()
获取此 Statement 对象上的调用报告的第一个警告。
 void ResultSet.insertRow()
将插入行的内容插入到此 ResultSet 对象和数据库中。
 boolean DatabaseMetaData.insertsAreDetected(int type)
获取是否可以通过调用 ResultSet.rowInserted 方法检测可见行的插入。
 boolean ResultSet.isAfterLast()
获取光标是否位于此 ResultSet 对象的最后一行之后。
 boolean ResultSetMetaData.isAutoIncrement(int column)
指示是否自动为指定列进行编号。
 boolean ResultSet.isBeforeFirst()
获取光标是否位于此 ResultSet 对象的第一行之前。
 boolean ResultSetMetaData.isCaseSensitive(int column)
指示列的大小写是否有关系。
 boolean DatabaseMetaData.isCatalogAtStart()
获取某个类别是否出现在完全限定表名的开头。
 boolean Connection.isClosed()
查询此 Connection 对象是否已经被关闭。
 boolean ResultSet.isClosed()
获取此 ResultSet 对象是否已关闭。
 boolean Statement.isClosed()
获取是否已关闭了此 Statement 对象。
 boolean ResultSetMetaData.isCurrency(int column)
指示指定的列是否是一个哈希代码值。
 boolean ResultSetMetaData.isDefinitelyWritable(int column)
指示在指定的列上进行写操作是否明确可以获得成功。
 boolean ResultSet.isFirst()
获取光标是否位于此 ResultSet 对象的第一行。
 boolean ResultSet.isLast()
获取光标是否位于此 ResultSet 对象的最后一行。
 int ParameterMetaData.isNullable(int param)
获取是否允许在指定参数中使用 null 值。
 int ResultSetMetaData.isNullable(int column)
指示指定列中的值是否可以为 null。
 boolean Statement.isPoolable()
返回指示 Statement 是否是可池化的值。
 boolean Connection.isReadOnly()
查询此 Connection 对象是否处于只读模式。
 boolean DatabaseMetaData.isReadOnly()
获取此数据库是否处于只读模式。
 boolean ResultSetMetaData.isReadOnly(int column)
指示指定的列是否明确不可写入。
 boolean ResultSetMetaData.isSearchable(int column)
指示是否可以在 where 子句中使用指定的列。
 boolean ParameterMetaData.isSigned(int param)
获取指定参数的值是否可以是带符号的数字。
 boolean ResultSetMetaData.isSigned(int column)
指示指定列中的值是否带正负号。
 boolean Connection.isValid(int timeout)
如果连接尚未关闭并且仍然有效，则返回 true。
 boolean Wrapper.isWrapperFor(Class<?> iface)
如果调用此方法的对象实现接口参数，或者是实现接口参数的对象的直接或间接包装器，则返回 true。
 boolean ResultSetMetaData.isWritable(int column)
指示在指定的列上进行写操作是否可以获得成功。
 boolean ResultSet.last()
将光标移动到此 ResultSet 对象的最后一行。
 long Blob.length()
返回此 Blob 对象指定的 BLOB 值中的字节数。
 long Clob.length()
获取此 Clob 对象指定的 CLOB 值中的字符数。
 boolean DatabaseMetaData.locatorsUpdateCopy()
指示对 LOB 的更新是在副本上进行还是直接更新到 LOB。
 void ResultSet.moveToCurrentRow()
将光标移动到记住的光标位置，通常为当前行。
 void ResultSet.moveToInsertRow()
将光标移动到插入行。
 String Connection.nativeSQL(String sql)
将给定的 SQL 语句转换成系统本机 SQL 语法。
 boolean ResultSet.next()
将光标从当前位置向前移一行。
 boolean DatabaseMetaData.nullPlusNonNullIsNull()
获取此数据库是否支持 NULL 值与等于 NULL 的非 NULL 值之间的连接。
 boolean DatabaseMetaData.nullsAreSortedAtEnd()
获取 NULL 值是否始终排在末尾，不管排序顺序如何。
 boolean DatabaseMetaData.nullsAreSortedAtStart()
获取 NULL 值是否始终排在开头，不管排序顺序如何。
 boolean DatabaseMetaData.nullsAreSortedHigh()
获取 NULL 值是否被高排序。
 boolean DatabaseMetaData.nullsAreSortedLow()
获取 NULL 值是否被低排序。
 boolean DatabaseMetaData.othersDeletesAreVisible(int type)
获取由其他结果集类型进行的删除是否可见。
 boolean DatabaseMetaData.othersInsertsAreVisible(int type)
获取由其他结果集类型进行的插入是否可见。
 boolean DatabaseMetaData.othersUpdatesAreVisible(int type)
获取由其他结果集类型进行的更新是否可见。
 boolean DatabaseMetaData.ownDeletesAreVisible(int type)
获取结果集自身的删除是否可见。
 boolean DatabaseMetaData.ownInsertsAreVisible(int type)
获取结果集自身的插入是否可见。
 boolean DatabaseMetaData.ownUpdatesAreVisible(int type)
获取对于给定类型的 ResultSet 对象，结果集自身的更新是否可见。
 long Blob.position(Blob pattern, long start)
获取此 Blob 对象指定的 BLOB 值中 pattern 开始处的字节位置。
 long Blob.position(byte[] pattern, long start)
获取此 Blob 对象表示的 BLOB 值中指定 byte 数组 pattern 开始处的字节位置。
 long Clob.position(Clob searchstr, long start)
获取此 Clob 对象中指定的 Clob 对象 searchstr 出现的字符位置。
 long Clob.position(String searchstr, long start)
获取此 Clob 对象表示的 SQL CLOB 值中指定子字符串 searchstr 出现的字符位置。
 CallableStatement Connection.prepareCall(String sql)
创建一个 CallableStatement 对象来调用数据库存储过程。
 CallableStatement Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 CallableStatement Connection.prepareCall(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 CallableStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 PreparedStatement Connection.prepareStatement(String sql)
创建一个 PreparedStatement 对象来将参数化的 SQL 语句发送到数据库。
 PreparedStatement Connection.prepareStatement(String sql, int autoGeneratedKeys)
创建一个默认 PreparedStatement 对象，该对象能获取自动生成的键。
 PreparedStatement Connection.prepareStatement(String sql, int[] columnIndexes)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
 PreparedStatement Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
 PreparedStatement Connection.prepareStatement(String sql, int resultSetType, int resultSetConcurrency, int resultSetHoldability)
创建一个 PreparedStatement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
 PreparedStatement Connection.prepareStatement(String sql, String[] columnNames)
创建一个能返回由给定数组指定的自动生成键的默认 PreparedStatement 对象。
 boolean ResultSet.previous()
将光标移动到此 ResultSet 对象的上一行。
 Array SQLInput.readArray()
从流中读取 SQL ARRAY 值并将其作为 Java 编程语言中的 Array 对象返回。
 InputStream SQLInput.readAsciiStream()
读取流中的下一个属性并将其作为 ASCII 字符流返回。
 BigDecimal SQLInput.readBigDecimal()
读取流中的下一个属性并将其作为 Java 编程语言中的 java.math.BigDecimal 对象返回。
 InputStream SQLInput.readBinaryStream()
读取流中的下一个属性并将其作为未解释的字节流返回。
 Blob SQLInput.readBlob()
从流中读取 SQL BLOB 值并将其作为 Java 编程语言中的 Blob 对象返回。
 boolean SQLInput.readBoolean()
读取流中的下一个属性并将其作为 Java 编程语言中的 boolean 返回。
 byte SQLInput.readByte()
读取流中的下一个属性并将其作为 Java 编程语言中的 byte 返回。
 byte[] SQLInput.readBytes()
读取流中的下一个属性并将其作为 Java 编程语言中的字节数组返回。
 Reader SQLInput.readCharacterStream()
读取流中的下一个属性并将其作为 Unicode 字符流返回。
 Clob SQLInput.readClob()
从流中读取 SQL CLOB 值并将其作为 Java 编程语言中的 Clob 对象返回。
 Date SQLInput.readDate()
读取流中的下一个属性并将其作为 java.sql.Date 对象返回。
 double SQLInput.readDouble()
读取流中的下一个属性并将其作为 Java 编程语言中的 double 返回。
 float SQLInput.readFloat()
读取流中的下一个属性并将其作为 Java 编程语言中的 float 返回。
 int SQLInput.readInt()
读取流中的下一个属性并将其作为 Java 编程语言中的 int 返回。
 long SQLInput.readLong()
读取流中的下一个属性并将其作为 Java 编程语言中的 long 返回。
 NClob SQLInput.readNClob()
从流中读取一个 SQL NCLOB 值，并以 Java 编程语言中 NCLOB 对象的形式返回。
 String SQLInput.readNString()
读取流中的下一个属性，并以 Java 编程语言中 String 的形式返回。
 Object SQLInput.readObject()
读取流头中的下一个属性并将其作为 Java 编程语言中的 Object 返回。
 Ref SQLInput.readRef()
从流读取 SQL REF 值并将其作为 Java 编程语言中的 Ref 对象返回。
 RowId SQLInput.readRowId()
从流中读取一个 SQL ROWID 值，并以 Java 编程语言中 RowId 对象的形式返回。
 short SQLInput.readShort()
读取流中的下一个属性并将其作为 Java 编程语言中的 short 返回。
 void SQLData.readSQL(SQLInput stream, String typeName)
用从数据库读取的数据填充此对象。
 SQLXML SQLInput.readSQLXML()
从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。
 String SQLInput.readString()
读取流中的下一个属性并将其作为 Java 编程语言中的 String 返回。
 Time SQLInput.readTime()
读取流中的下一个属性并将其作为 java.sql.Time 对象返回。
 Timestamp SQLInput.readTimestamp()
读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。
 URL SQLInput.readURL()
从流中读取 SQL DATALINK 值并将其作为 Java 编程语言中的 java.net.URL 对象返回。
 void ResultSet.refreshRow()
用数据库中的最近值刷新当前行。
static void DriverManager.registerDriver(Driver driver)
向 DriverManager 注册给定驱动程序。
 void CallableStatement.registerOutParameter(int parameterIndex, int sqlType)
按顺序位置 parameterIndex 将 OUT 参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(int parameterIndex, int sqlType, int scale)
按顺序位置 parameterIndex 将参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(int parameterIndex, int sqlType, String typeName)
注册指定的输出参数。
 void CallableStatement.registerOutParameter(String parameterName, int sqlType)
将名为 parameterName 的 OUT 参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(String parameterName, int sqlType, int scale)
将名为 parameterName 的参数注册为 JDBC 类型 sqlType。
 void CallableStatement.registerOutParameter(String parameterName, int sqlType, String typeName)
注册指定的输出参数。
 boolean ResultSet.relative(int rows)
按相对行数（或正或负）移动光标。
 void Connection.releaseSavepoint(Savepoint savepoint)
从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。
 void Connection.rollback()
取消在当前事务中进行的所有更改，并释放此 Connection 对象当前持有的所有数据库锁。
 void Connection.rollback(Savepoint savepoint)
取消所有设置给定 Savepoint 对象之后进行的更改。
 boolean ResultSet.rowDeleted()
获取是否已删除某行。
 boolean ResultSet.rowInserted()
获取当前行是否已有插入。
 boolean ResultSet.rowUpdated()
获取是否已更新当前行。
 void PreparedStatement.setArray(int parameterIndex, Array x)
将指定参数设置为给定 java.sql.Array 对象。
 void PreparedStatement.setAsciiStream(int parameterIndex, InputStream x)
将指定参数设置为给定输入流。
 void PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将具有给定字节数。
 void PreparedStatement.setAsciiStream(int parameterIndex, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将具有指定字节数。
 OutputStream Clob.setAsciiStream(long pos)
获取用于将 Ascii 字符写入此 Clob 对象表示的 Clob 值中的流，从位置 pos 处开始。
 void CallableStatement.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。
 void CallableStatement.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
 void CallableStatement.setAsciiStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
 void Connection.setAutoCommit(boolean autoCommit)
将此连接的自动提交模式设置为给定状态。
 void PreparedStatement.setBigDecimal(int parameterIndex, BigDecimal x)
将指定参数设置为给定 java.math.BigDecimal 值。
 void CallableStatement.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定 java.math.BigDecimal 值。
 OutputStream SQLXML.setBinaryStream()
获取可用于写入此 SQLXML 实例表示的 XML 值的流。
 void PreparedStatement.setBinaryStream(int parameterIndex, InputStream x)
将指定参数设置为给定输入流。
 void PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将具有给定字节数。
 void PreparedStatement.setBinaryStream(int parameterIndex, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将具有指定字节数。
 OutputStream Blob.setBinaryStream(long pos)
获取用于写入此 Blob 对象表示的 BLOB 值的流。
 void CallableStatement.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。
 void CallableStatement.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定的字节数。
 void CallableStatement.setBinaryStream(String parameterName, InputStream x, long length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
 void PreparedStatement.setBlob(int parameterIndex, Blob x)
将指定参数设置为给定 java.sql.Blob 对象。
 void PreparedStatement.setBlob(int parameterIndex, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void PreparedStatement.setBlob(int parameterIndex, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void CallableStatement.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。
 void CallableStatement.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void CallableStatement.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void PreparedStatement.setBoolean(int parameterIndex, boolean x)
将指定参数设置为给定 Java boolean 值。
 void CallableStatement.setBoolean(String parameterName, boolean x)
将指定参数设置为给定 Java boolean 值。
 void PreparedStatement.setByte(int parameterIndex, byte x)
将指定参数设置为给定 Java byte 值。
 void CallableStatement.setByte(String parameterName, byte x)
将指定参数设置为给定 Java byte 值。
 void PreparedStatement.setBytes(int parameterIndex, byte[] x)
将指定参数设置为给定 Java byte 数组。
 int Blob.setBytes(long pos, byte[] bytes)
从位置 pos 处开始，将给定 byte 数组写入此 Blob 对象表示的 BLOB 值，并返回写入的字节数。
 int Blob.setBytes(long pos, byte[] bytes, int offset, int len)
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
 void CallableStatement.setBytes(String parameterName, byte[] x)
将指定参数设置为给定 Java byte 数组。
 void Connection.setCatalog(String catalog)
设置给定目录名称，以便选择要在其中进行工作的此 Connection 对象数据库的子空间。
 Writer SQLXML.setCharacterStream()
获取用于写入此 SQLXML 实例表示的 XML 值的流。
 void PreparedStatement.setCharacterStream(int parameterIndex, Reader reader)
将指定参数设置为给定 Reader 对象。
 void PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, int length)
将给定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
 void PreparedStatement.setCharacterStream(int parameterIndex, Reader reader, long length)
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
 Writer Clob.setCharacterStream(long pos)
获取用于将 Unicode 字符流写入此 Clob 对象表示的 CLOB 值中（位置 pos 处）的流。
 void CallableStatement.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。
 void CallableStatement.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数。
 void CallableStatement.setCharacterStream(String parameterName, Reader reader, long length)
将指定参数设置为给定 Reader 对象，该对象具有给定字符数长度。
 void PreparedStatement.setClob(int parameterIndex, Clob x)
将指定参数设置为给定 java.sql.Clob 对象。
 void PreparedStatement.setClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void CallableStatement.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。
 void CallableStatement.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void CallableStatement.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void Statement.setCursorName(String name)
将 SQL 指针名称设置为给定的 String，后续 Statement 对象的 execute 方法将使用此字符串。
 void PreparedStatement.setDate(int parameterIndex, Date x)
使用运行应用程序的虚拟机的默认时区将指定参数设置为给定 java.sql.Date 值。
 void PreparedStatement.setDate(int parameterIndex, Date x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
 void CallableStatement.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机默认时区将指定参数设置为给定 java.sql.Date 值。
 void CallableStatement.setDate(String parameterName, Date x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
 void PreparedStatement.setDouble(int parameterIndex, double x)
将指定参数设置为给定 Java double 值。
 void CallableStatement.setDouble(String parameterName, double x)
将指定参数设置为给定 Java double 值。
 void Statement.setEscapeProcessing(boolean enable)
将转义处理设置为开或关。
 void ResultSet.setFetchDirection(int direction)
设置此 ResultSet 对象中行的处理方向。
 void Statement.setFetchDirection(int direction)
向驱动程序提供关于方向的提示，在使用此 Statement 对象创建的 ResultSet 对象中将按该方向处理行。
 void ResultSet.setFetchSize(int rows)
为 JDBC 驱动程序设置此 ResultSet 对象需要更多行时应该从数据库获取的行数。
 void Statement.setFetchSize(int rows)
为 JDBC 驱动程序提供一个提示，它提示此 Statement 生成的 ResultSet 对象需要更多行时应该从数据库获取的行数。
 void PreparedStatement.setFloat(int parameterIndex, float x)
将指定参数设置为给定 Java REAL 值。
 void CallableStatement.setFloat(String parameterName, float x)
将指定参数设置为给定 Java float 值。
 void Connection.setHoldability(int holdability)
将使用此 Connection 对象创建的 ResultSet 对象的默认可保存性 (holdability) 更改为给定可保存性。
 void PreparedStatement.setInt(int parameterIndex, int x)
将指定参数设置为给定 Java int 值。
 void CallableStatement.setInt(String parameterName, int x)
将指定参数设置为给定 Java int 值。
 void PreparedStatement.setLong(int parameterIndex, long x)
将指定参数设置为给定 Java long 值。
 void CallableStatement.setLong(String parameterName, long x)
将指定参数设置为给定 Java long 值。
 void Statement.setMaxFieldSize(int max)
设置此 Statement 对象生成的 ResultSet 对象中字符和二进制列值可以返回的最大字节数限制。
 void Statement.setMaxRows(int max)
将此 Statement 对象生成的所有 ResultSet 对象可以包含的最大行数限制设置为给定数。
 void PreparedStatement.setNCharacterStream(int parameterIndex, Reader value)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNCharacterStream(int parameterIndex, Reader value, long length)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNClob(int parameterIndex, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void PreparedStatement.setNClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void CallableStatement.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void CallableStatement.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void PreparedStatement.setNString(int parameterIndex, String value)
将指定参数设置为给定 String 对象。
 void CallableStatement.setNString(String parameterName, String value)
将指定参数设置为给定 String 对象。
 void PreparedStatement.setNull(int parameterIndex, int sqlType)
将指定参数设置为 SQL NULL。
 void PreparedStatement.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void CallableStatement.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。
 void CallableStatement.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void PreparedStatement.setObject(int parameterIndex, Object x)
使用给定对象设置指定参数的值。
 void PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定对象设置指定参数的值。
 void PreparedStatement.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength)
使用给定对象设置指定参数的值。
 void Ref.setObject(Object value)
将此 Ref 对象引用的结构类型值设置为给定的 Object 实例。
 void CallableStatement.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。
 void CallableStatement.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。
 void CallableStatement.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。
 void Statement.setPoolable(boolean poolable)
请求将 Statement 池化或非池化。
 void Statement.setQueryTimeout(int seconds)
将驱动程序等待 Statement 对象执行的秒数设置为给定秒数。
 void Connection.setReadOnly(boolean readOnly)
将此连接设置为只读模式，作为驱动程序启用数据库优化的提示。
 void PreparedStatement.setRef(int parameterIndex, Ref x)
将指定参数设置为给定 REF(<structured-type>) 值。
<T extends Result>
T
SQLXML.setResult(Class<T> resultClass)
返回设置此 SQLXML 实例指定的 XML 值的 Result。
 void PreparedStatement.setRowId(int parameterIndex, RowId x)
将指定参数设置为给定 java.sql.RowId 对象。
 void CallableStatement.setRowId(String parameterName, RowId x)
将指定参数设置为给定 java.sql.RowId 对象。
 Savepoint Connection.setSavepoint()
在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。
 Savepoint Connection.setSavepoint(String name)
在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。
 void PreparedStatement.setShort(int parameterIndex, short x)
将指定参数设置为给定 Java short 值。
 void CallableStatement.setShort(String parameterName, short x)
将指定参数设置为给定 Java short 值。
 void PreparedStatement.setSQLXML(int parameterIndex, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。
 void CallableStatement.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。
 void PreparedStatement.setString(int parameterIndex, String x)
将指定参数设置为给定 Java String 值。
 int Clob.setString(long pos, String str)
在位置 pos 处将给定 Java String 写入此 Clob 对象指定的 CLOB 值中。
 int Clob.setString(long pos, String str, int offset, int len)
将 str 的 len 个字符（从字符 offset 开始）写入此 Clob 表示的 CLOB 值中。
 void SQLXML.setString(String value)
将此 SQLXML 实例指定的 XML 值设置为给定的 String 表示形式。
 void CallableStatement.setString(String parameterName, String x)
将指定参数设置为给定 Java String 值。
 void PreparedStatement.setTime(int parameterIndex, Time x)
将指定参数设置为给定 java.sql.Time 值。
 void PreparedStatement.setTime(int parameterIndex, Time x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
 void CallableStatement.setTime(String parameterName, Time x)
将指定参数设置为给定 java.sql.Time 值。
 void CallableStatement.setTime(String parameterName, Time x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
 void PreparedStatement.setTimestamp(int parameterIndex, Timestamp x)
将指定参数设置为给定 java.sql.Timestamp 值。
 void PreparedStatement.setTimestamp(int parameterIndex, Timestamp x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
 void CallableStatement.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定 java.sql.Timestamp 值。
 void CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
 void Connection.setTransactionIsolation(int level)
试图将此 Connection 对象的事务隔离级别更改为给定的级别。
 void Connection.setTypeMap(Map<String,Class<?>> map)
将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。
 void PreparedStatement.setUnicodeStream(int parameterIndex, InputStream x, int length)
已过时。
 void PreparedStatement.setURL(int parameterIndex, URL x)
将指定参数设置为给定 java.net.URL 值。
 void CallableStatement.setURL(String parameterName, URL val)
将指定参数设置为给定 java.net.URL 对象。
 boolean DatabaseMetaData.storesLowerCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
 boolean DatabaseMetaData.storesLowerCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以小写形式存储它们。
 boolean DatabaseMetaData.storesMixedCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
 boolean DatabaseMetaData.storesMixedCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大小写混合形式存储它们。
 boolean DatabaseMetaData.storesUpperCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
 boolean DatabaseMetaData.storesUpperCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为不区分大小写的形式处理，并以大写形式存储它们。
 boolean DatabaseMetaData.supportsAlterTableWithAddColumn()
获取此数据库是否支持带有 add 列的 ALTER TABLE。
 boolean DatabaseMetaData.supportsAlterTableWithDropColumn()
获取此数据库是否支持带有 drop 列的 ALTER TABLE。
 boolean DatabaseMetaData.supportsANSI92EntryLevelSQL()
获取此数据库是否支持 ANSI92 入门级 SQL 语法。
 boolean DatabaseMetaData.supportsANSI92FullSQL()
获取此数据库是否支持受支持的 ANSI92 完全 SQL 语法。
 boolean DatabaseMetaData.supportsANSI92IntermediateSQL()
获取此数据库是否支持受支持的 ANSI92 中间 SQL 语法。
 boolean DatabaseMetaData.supportsBatchUpdates()
获取此数据库是否支持批量更新。
 boolean DatabaseMetaData.supportsCatalogsInDataManipulation()
获取某个类别名称是否可以在数据操作语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInIndexDefinitions()
获取某个类别名称是否可以在获取定义语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInPrivilegeDefinitions()
获取某个类别名称是否可以在特权定义语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInProcedureCalls()
获取某个类别名称是否可以在过程调用语句中使用。
 boolean DatabaseMetaData.supportsCatalogsInTableDefinitions()
获取某个类别名称是否可以在表定义语句中使用。
 boolean DatabaseMetaData.supportsColumnAliasing()
获取此数据库是否支持为列提供别名。
 boolean DatabaseMetaData.supportsConvert()
获取此数据库是否支持用于 JDBC 类型之间转换的 JDBC 标量函数 CONVERT。
 boolean DatabaseMetaData.supportsConvert(int fromType, int toType)
获取此数据库是否支持用于 JDBC fromType 和 toType 类型之间转换的 JDBC 标量函数 CONVERT。
 boolean DatabaseMetaData.supportsCoreSQLGrammar()
获取此数据库是否支持 ODBC Core SQL 语法。
 boolean DatabaseMetaData.supportsCorrelatedSubqueries()
获取此数据库是否支持相关子查询。
 boolean DatabaseMetaData.supportsDataDefinitionAndDataManipulationTransactions()
获取此数据库是否同时支持事务中的数据定义和数据操作语句。
 boolean DatabaseMetaData.supportsDataManipulationTransactionsOnly()
获取此数据库是否仅支持事务中的数据操作语句。
 boolean DatabaseMetaData.supportsDifferentTableCorrelationNames()
获取在表关联名称受支持时，是否要限制它们与表的名称不同。
 boolean DatabaseMetaData.supportsExpressionsInOrderBy()
获取此数据库是否支持 ORDER BY 列表中的表达式。
 boolean DatabaseMetaData.supportsExtendedSQLGrammar()
获取此数据库是否支持 ODBC Extended SQL 语法。
 boolean DatabaseMetaData.supportsFullOuterJoins()
获取此数据库是否支持完全嵌套的外连接。
 boolean DatabaseMetaData.supportsGetGeneratedKeys()
获取是否可以在执行语句后获取自动生成的键。
 boolean DatabaseMetaData.supportsGroupBy()
获取此数据库是否支持某种形式的 GROUP BY 子句。
 boolean DatabaseMetaData.supportsGroupByBeyondSelect()
获取此数据库是否支持使用不包含在 SELECT 语句中而包含在 GROUP BY 子句中的列，假设 SELECT 语句中的所有列都包含在 GROUP BY 子句中。
 boolean DatabaseMetaData.supportsGroupByUnrelated()
获取此数据库是否支持使用不在 SELECT 语句中而在 GROUP BY 子句中的列。
 boolean DatabaseMetaData.supportsIntegrityEnhancementFacility()
获取此数据库是否支持 SQL Integrity Enhancement Facility。
 boolean DatabaseMetaData.supportsLikeEscapeClause()
获取此数据库是否支持指定 LIKE 转义子句。
 boolean DatabaseMetaData.supportsLimitedOuterJoins()
获取此数据库是否为外连接提供受限制的支持。
 boolean DatabaseMetaData.supportsMinimumSQLGrammar()
获取此数据库是否支持 ODBC Minimum SQL 语法。
 boolean DatabaseMetaData.supportsMixedCaseIdentifiers()
获取此数据库是否将大小写混写的不带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
 boolean DatabaseMetaData.supportsMixedCaseQuotedIdentifiers()
获取此数据库是否将大小写混写的带引号的 SQL 标识符作为区分大小写的形式处理，并且最后以大小写混合形式存储它们。
 boolean DatabaseMetaData.supportsMultipleOpenResults()
获取是否可以同时拥有从 CallableStatement 对象中返回的多个 ResultSet 对象。
 boolean DatabaseMetaData.supportsMultipleResultSets()
获取此数据库是否支持一次调用 execute 方法获得多个 ResultSet 对象。
 boolean DatabaseMetaData.supportsMultipleTransactions()
获取此数据库是否允许一次打开多个事务（在不同的 connection 上）。
 boolean DatabaseMetaData.supportsNamedParameters()
获取此数据库是否支持可调用语句的指定参数。
 boolean DatabaseMetaData.supportsNonNullableColumns()
获取是否可以将此数据库中的列定义为非 null。
 boolean DatabaseMetaData.supportsOpenCursorsAcrossCommit()
获取此数据库是否支持在进行提交期间保持游标开放。
 boolean DatabaseMetaData.supportsOpenCursorsAcrossRollback()
获取此数据库是否支持在回滚期间保持游标开放。
 boolean DatabaseMetaData.supportsOpenStatementsAcrossCommit()
获取此数据库是否支持在进行提交期间保持语句开放。
 boolean DatabaseMetaData.supportsOpenStatementsAcrossRollback()
获取此数据库是否支持在回滚期间保持语句开放。
 boolean DatabaseMetaData.supportsOrderByUnrelated()
获取此数据库是否支持使用不在 SELECT 语句中而在 ORDER BY 子句中的列。
 boolean DatabaseMetaData.supportsOuterJoins()
获取此数据库是否支持某种形式的外连接。
 boolean DatabaseMetaData.supportsPositionedDelete()
获取此数据库是否支持位置的 DELETE 语句。
 boolean DatabaseMetaData.supportsPositionedUpdate()
获取此数据库是否支持位置的 UPDATE 语句。
 boolean DatabaseMetaData.supportsResultSetConcurrency(int type, int concurrency)
获取此数据库是否支持与给定结果集类型结合在一起的给定并发性类型。
 boolean DatabaseMetaData.supportsResultSetHoldability(int holdability)
获取此数据库是否支持给定结果集可保存性。
 boolean DatabaseMetaData.supportsResultSetType(int type)
获取此数据库是否支持给定结果集类型。
 boolean DatabaseMetaData.supportsSavepoints()
获取此数据库是否支持保存点 (savepoint)。
 boolean DatabaseMetaData.supportsSchemasInDataManipulation()
获取某个模式名称是否可以数据操作语句中使用。
 boolean DatabaseMetaData.supportsSchemasInIndexDefinitions()
获取某个模式名称是否可以在获取定义语句中使用。
 boolean DatabaseMetaData.supportsSchemasInPrivilegeDefinitions()
获取某个模式名称是否可以在特权定义语句中使用。
 boolean DatabaseMetaData.supportsSchemasInProcedureCalls()
获取某个模式名称是否可以在过程调用语句中使用。
 boolean DatabaseMetaData.supportsSchemasInTableDefinitions()
获取某个模式名称是否可以在表定义语句中使用。
 boolean DatabaseMetaData.supportsSelectForUpdate()
获取此数据库是否支持位置的 SELECT FOR UPDATE 语句。
 boolean DatabaseMetaData.supportsStatementPooling()
获取此数据库是否支持语句合并 (statement pooling)。
 boolean DatabaseMetaData.supportsStoredFunctionsUsingCallSyntax()
获取此数据库是否支持使用存储过程转义语法调用用户定义的函数或供应商函数。
 boolean DatabaseMetaData.supportsStoredProcedures()
获取此数据库是否支持使用存储过程转义语法的存储过程调用。
 boolean DatabaseMetaData.supportsSubqueriesInComparisons()
获取此数据库是否支持比较表达式中的子查询。
 boolean DatabaseMetaData.supportsSubqueriesInExists()
获取此数据库是否支持 EXISTS 表达式中的子查询。
 boolean DatabaseMetaData.supportsSubqueriesInIns()
获取此数据库是否支持 IN 表达式中的子查询。
 boolean DatabaseMetaData.supportsSubqueriesInQuantifieds()
获取此数据库是否支持量化表达式 (quantified expression) 中的子查询。
 boolean DatabaseMetaData.supportsTableCorrelationNames()
获取此数据库是否支持表关联名称。
 boolean DatabaseMetaData.supportsTransactionIsolationLevel(int level)
获取此数据库是否支持给定事务隔离级别。
 boolean DatabaseMetaData.supportsTransactions()
获取此数据库是否支持事务。
 boolean DatabaseMetaData.supportsUnion()
获取此数据库是否支持 SQL UNION。
 boolean DatabaseMetaData.supportsUnionAll()
获取此数据库是否支持 SQL UNION ALL。
 void Blob.truncate(long len)
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
 void Clob.truncate(long len)
截取此 Clob 指定的 CLOB 值，使其长度为 len 个字符。
<T> T
Wrapper.unwrap(Class<T> iface)
返回一个对象，该对象实现给定接口，以允许访问非标准方法或代理未公开的标准方法。
 void ResultSet.updateArray(int columnIndex, Array x)
用 java.sql.Array 值更新指定列。
 void ResultSet.updateArray(String columnLabel, Array x)
用 java.sql.Array 值更新指定列。
 void ResultSet.updateAsciiStream(int columnIndex, InputStream x)
用 ascii 流值更新指定的列。
 void ResultSet.updateAsciiStream(int columnIndex, InputStream x, int length)
用 ascii 流值更新指定列，该列将具有指定字节数。
 void ResultSet.updateAsciiStream(int columnIndex, InputStream x, long length)
用 ascii 流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateAsciiStream(String columnLabel, InputStream x)
用 ascii 流值更新指定列。
 void ResultSet.updateAsciiStream(String columnLabel, InputStream x, int length)
用 ascii 流值更新指定列，该列具有指定的字节数。
 void ResultSet.updateAsciiStream(String columnLabel, InputStream x, long length)
用 ascii 流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateBigDecimal(int columnIndex, BigDecimal x)
用 java.math.BigDecimal 值更新指定列。
 void ResultSet.updateBigDecimal(String columnLabel, BigDecimal x)
用 java.sql.BigDecimal 值更新指定列。
 void ResultSet.updateBinaryStream(int columnIndex, InputStream x)
用二进制流值更新指定的列。
 void ResultSet.updateBinaryStream(int columnIndex, InputStream x, int length)
用二进制流值更新指定列，该列将具有指定字节数。
 void ResultSet.updateBinaryStream(int columnIndex, InputStream x, long length)
用二进制流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateBinaryStream(String columnLabel, InputStream x)
用二进制流值更新指定列。
 void ResultSet.updateBinaryStream(String columnLabel, InputStream x, int length)
用二进制流值更新指定列，该列具有指定的字节数。
 void ResultSet.updateBinaryStream(String columnLabel, InputStream x, long length)
用二进制流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateBlob(int columnIndex, Blob x)
用 java.sql.Blob 值更新指定列。
 void ResultSet.updateBlob(int columnIndex, InputStream inputStream)
使用给定输入流值更新指定列。
 void ResultSet.updateBlob(int columnIndex, InputStream inputStream, long length)
使用给定输入流更新指定的列，该流将具有指定的字节数。
 void ResultSet.updateBlob(String columnLabel, Blob x)
用 java.sql.Blob 值更新指定列。
 void ResultSet.updateBlob(String columnLabel, InputStream inputStream)
使用给定输入流值更新指定列。
 void ResultSet.updateBlob(String columnLabel, InputStream inputStream, long length)
使用给定输入流更新指定列，该流将具有指定的字节数。
 void ResultSet.updateBoolean(int columnIndex, boolean x)
用 boolean 值更新指定列。
 void ResultSet.updateBoolean(String columnLabel, boolean x)
用 boolean 值更新指定列。
 void ResultSet.updateByte(int columnIndex, byte x)
用 byte 值更新指定列。
 void ResultSet.updateByte(String columnLabel, byte x)
用 byte 值更新指定列。
 void ResultSet.updateBytes(int columnIndex, byte[] x)
用 byte 数组值更新指定列。
 void ResultSet.updateBytes(String columnLabel, byte[] x)
用字节数组值更新指定列。
 void ResultSet.updateCharacterStream(int columnIndex, Reader x)
用字符流值更新指定的列。
 void ResultSet.updateCharacterStream(int columnIndex, Reader x, int length)
用字符流值更新指定列，该列将具有指定字节数。
 void ResultSet.updateCharacterStream(int columnIndex, Reader x, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定列。
 void ResultSet.updateCharacterStream(String columnLabel, Reader reader, int length)
用字符流值更新指定列，该列具有指定的字节数。
 void ResultSet.updateCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateClob(int columnIndex, Clob x)
用 java.sql.Clob 值更新指定列。
 void ResultSet.updateClob(int columnIndex, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateClob(int columnIndex, Reader reader, long length)
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
 void ResultSet.updateClob(String columnLabel, Clob x)
用 java.sql.Clob 值更新指定列。
 void ResultSet.updateClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定列，该对象是给定的字符长度数目。
 void ResultSet.updateDate(int columnIndex, Date x)
用 java.sql.Date 值更新指定列。
 void ResultSet.updateDate(String columnLabel, Date x)
用 java.sql.Date 值更新指定列。
 void ResultSet.updateDouble(int columnIndex, double x)
用 double 值更新指定列。
 void ResultSet.updateDouble(String columnLabel, double x)
用 double 值更新指定列。
 void ResultSet.updateFloat(int columnIndex, float x)
用 float 值更新指定列。
 void ResultSet.updateFloat(String columnLabel, float x)
用 float 值更新指定列。
 void ResultSet.updateInt(int columnIndex, int x)
用 int 值更新指定列。
 void ResultSet.updateInt(String columnLabel, int x)
用 int 值更新指定列。
 void ResultSet.updateLong(int columnIndex, long x)
用 long 值更新指定列。
 void ResultSet.updateLong(String columnLabel, long x)
用 long 值更新指定列。
 void ResultSet.updateNCharacterStream(int columnIndex, Reader x)
用字符流值更新指定的列。
 void ResultSet.updateNCharacterStream(int columnIndex, Reader x, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateNCharacterStream(String columnLabel, Reader reader)
用字符流值更新指定的列。
 void ResultSet.updateNCharacterStream(String columnLabel, Reader reader, long length)
用字符流值更新指定的列，该值将具有指定的字节数。
 void ResultSet.updateNClob(int columnIndex, NClob nClob)
用 java.sql.NClob 值更新指定的列。
 void ResultSet.updateNClob(int columnIndex, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateNClob(int columnIndex, Reader reader, long length)
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
 void ResultSet.updateNClob(String columnLabel, NClob nClob)
用 java.sql.NClob 值更新指定的列。
 void ResultSet.updateNClob(String columnLabel, Reader reader)
使用给定的 Reader 对象更新指定列。
 void ResultSet.updateNClob(String columnLabel, Reader reader, long length)
使用给定的 Reader 对象更新指定的列，该对象是给定的字符长度数目。
 void ResultSet.updateNString(int columnIndex, String nString)
用 String 值更新指定的列。
 void ResultSet.updateNString(String columnLabel, String nString)
用 String 值更新指定的列。
 void ResultSet.updateNull(int columnIndex)
用 null 值更新指定列。
 void ResultSet.updateNull(String columnLabel)
用 null 值更新指定列。
 void ResultSet.updateObject(int columnIndex, Object x)
用 Object 值更新指定列。
 void ResultSet.updateObject(int columnIndex, Object x, int scaleOrLength)
用 Object 值更新指定列。
 void ResultSet.updateObject(String columnLabel, Object x)
用 Object 值更新指定列。
 void ResultSet.updateObject(String columnLabel, Object x, int scaleOrLength)
用 Object 值更新指定列。
 void ResultSet.updateRef(int columnIndex, Ref x)
用 java.sql.Ref 值更新指定列。
 void ResultSet.updateRef(String columnLabel, Ref x)
用 java.sql.Ref 值更新指定列。
 void ResultSet.updateRow()
用此 ResultSet 对象的当前行的新内容更新底层数据库。
 void ResultSet.updateRowId(int columnIndex, RowId x)
用 RowId 值更新指定列。
 void ResultSet.updateRowId(String columnLabel, RowId x)
用 RowId 值更新指定的列。
 boolean DatabaseMetaData.updatesAreDetected(int type)
获取是否可以通过调用 ResultSet.rowUpdated 方法检测可见行的更新。
 void ResultSet.updateShort(int columnIndex, short x)
用 short 值更新指定列。
 void ResultSet.updateShort(String columnLabel, short x)
用 short 值更新指定列。
 void ResultSet.updateSQLXML(int columnIndex, SQLXML xmlObject)
用 java.sql.SQLXML 值更新指定列。
 void ResultSet.updateSQLXML(String columnLabel, SQLXML xmlObject)
用 java.sql.SQLXML 值更新指定的列。
 void ResultSet.updateString(int columnIndex, String x)
用 String 值更新指定列。
 void ResultSet.updateString(String columnLabel, String x)
用 String 值更新指定列。
 void ResultSet.updateTime(int columnIndex, Time x)
用 java.sql.Time 值更新指定列。
 void ResultSet.updateTime(String columnLabel, Time x)
用 java.sql.Time 值更新指定列。
 void ResultSet.updateTimestamp(int columnIndex, Timestamp x)
用 java.sql.Timestamp 值更新指定列。
 void ResultSet.updateTimestamp(String columnLabel, Timestamp x)
用 java.sql.Timestamp 值更新指定列。
 boolean DatabaseMetaData.usesLocalFilePerTable()
获取此数据库是否为每个表使用一个文件。
 boolean DatabaseMetaData.usesLocalFiles()
获取此数据库是否将表存储在本地文件中。
 boolean CallableStatement.wasNull()
查询最后一个读取的 OUT 参数是否为 SQL NULL。
 boolean ResultSet.wasNull()
报告最后一个读取的列是否具有值 SQL NULL。
 boolean SQLInput.wasNull()
获取最后一个读取的值是否为 SQL NULL。
 void SQLOutput.writeArray(Array x)
将 SQL ARRAY 值写入流中。
 void SQLOutput.writeAsciiStream(InputStream x)
将下一个属性作为 ASCII 字符流写入流中。
 void SQLOutput.writeBigDecimal(BigDecimal x)
将下一个属性作为 java.math.BigDecimal 对象写入流中。
 void SQLOutput.writeBinaryStream(InputStream x)
将下一个属性作为未解释字节流写入流中。
 void SQLOutput.writeBlob(Blob x)
将 SQL BLOB 值写入流中。
 void SQLOutput.writeBoolean(boolean x)
将下一个属性作为 Java boolean 值写入流。
 void SQLOutput.writeByte(byte x)
将下一个属性作为 Java byte 值写入流中。
 void SQLOutput.writeBytes(byte[] x)
将下一个属性作为字节数组写入流中。
 void SQLOutput.writeCharacterStream(Reader x)
将下一个属性作为 Unicode 字符的流写入流中。
 void SQLOutput.writeClob(Clob x)
将 SQL CLOB 值写入流中。
 void SQLOutput.writeDate(Date x)
将下一个属性作为 java.sql.Date 对象写入流中。
 void SQLOutput.writeDouble(double x)
将下一个属性作为 Java double 值写入流中。
 void SQLOutput.writeFloat(float x)
将下一个属性作为 Java float 值写入流中。
 void SQLOutput.writeInt(int x)
将下一个属性作为 Java int 值写入流中。
 void SQLOutput.writeLong(long x)
将下一个属性作为 Java long 值写入流中。
 void SQLOutput.writeNClob(NClob x)
将 SQL NCLOB 值写入流中。
 void SQLOutput.writeNString(String x)
将下一个属性以 Java 编程语言中 String 的形式写入流中。
 void SQLOutput.writeObject(SQLData x)
将给定 SQLData 对象中包含的数据写入流中。
 void SQLOutput.writeRef(Ref x)
将 SQL REF 值写入流中。
 void SQLOutput.writeRowId(RowId x)
将 SQL ROWID 值写入流中。
 void SQLOutput.writeShort(short x)
将下一个属性作为 Java short 值写入流中。
 void SQLData.writeSQL(SQLOutput stream)
将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。
 void SQLOutput.writeSQLXML(SQLXML x)
将 SQL XML 值写入流中。
 void SQLOutput.writeString(String x)
将下一个属性作为 Java 编程语言中的 String 写入流中。
 void SQLOutput.writeStruct(Struct x)
将 SQL 结构类型值写入流中。
 void SQLOutput.writeTime(Time x)
将下一个属性作为 java.sql.Time 对象写入流中。
 void SQLOutput.writeTimestamp(Timestamp x)
将下一个属性作为 java.sql.Timestamp 对象写入流中。
 void SQLOutput.writeURL(URL x)
将 SQL DATALINK 值写入流中。

javax.sql 中 SQLException 的使用

返回 SQLException 的 javax.sql 中的方法
SQLException | ConnectionEvent.getSQLException() 获取此 ConnectionEvent 对象的 SQLException。
SQLException | StatementEvent.getSQLException() 返回驱动程序将要抛出的 SQLException。

抛出 SQLException 的 javax.sql 中的方法
void | RowSet.clearParameters() 清除为此 RowSet 对象命令设置的参数。
void | PooledConnection.close() 关闭此 PooledConnection 对象表示的物理连接。
void | RowSet.execute() 使用数据填充此 RowSet 对象。
Connection | DataSource.getConnection() 尝试建立与此 DataSource 对象所表示的数据源的连接。
Connection | PooledConnection.getConnection() 创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。
Connection | RowSetInternal.getConnection() 获取传递给此 RowSet 对象的 Connection 对象。
Connection | DataSource.getConnection(String username, String password) 尝试建立与此 DataSource 对象所表示的数据源的连接。
boolean | RowSet.getEscapeProcessing() 获取是否为此 RowSet 对象启用转义处理。
int | CommonDataSource.getLoginTimeout() 获取此数据源试图连接到某一数据库时可以等待的最长时间，以秒为单位。
PrintWriter | CommonDataSource.getLogWriter() 获取此 DataSource 对象的日志 writer。
int | RowSet.getMaxFieldSize() 获取可以对某些列值返回的最大字节数。
int | RowSet.getMaxRows() 获取此 RowSet 对象可以包含的最大行数。
ResultSet | RowSetInternal.getOriginal() 获取包含此 RowSet 对象原始值的 ResultSet 对象。
ResultSet | RowSetInternal.getOriginalRow() 获取仅包含当前行原始值的 ResultSet 对象。
Object[] | RowSetInternal.getParams() 获取已为此 RowSet 对象的命令设置的参数。
PooledConnection | ConnectionPoolDataSource.getPooledConnection() 尝试建立可用作入池连接的物理数据库连接。
PooledConnection | ConnectionPoolDataSource.getPooledConnection(String user, String password) 尝试建立可用作入池连接的物理数据库连接。
int | RowSet.getQueryTimeout() 获取驱动程序等待语句执行的最大秒数。
Map<String,Class<?>> | RowSet.getTypeMap() 获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。
String | RowSet.getUrl() 如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。
XAConnection | XADataSource.getXAConnection() 尝试建立可在分布式事务中使用的物理数据库连接。
XAConnection | XADataSource.getXAConnection(String user, String password) 使用给定的用户名和密码，尝试建立一个物理数据库连接。
XAResource | XAConnection.getXAResource() 获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。
void | RowSetReader.readData(RowSetInternal caller) 读取调用 RowSet 对象的新内容。
void | RowSet.setArray(int i, Array x) 使用给定 Array 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setAsciiStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | RowSetMetaData.setAutoIncrement(int columnIndex, boolean property) 设置是否为指定列自动编号。
void | RowSet.setBigDecimal(int parameterIndex, BigDecimal x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。
void | RowSet.setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | RowSet.setBinaryStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | RowSet.setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | RowSet.setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有给定字节数。
void | RowSet.setBlob(int i, Blob x) 使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | RowSet.setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | RowSet.setBoolean(int parameterIndex, boolean x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java boolean 值。
void | RowSet.setBoolean(String parameterName, boolean x) 将指定参数设置为给定的 Java boolean 值。
void | RowSet.setByte(int parameterIndex, byte x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值。
void | RowSet.setByte(String parameterName, byte x) 将指定参数设置为给定的 Java byte 值。
void | RowSet.setBytes(int parameterIndex, byte[] x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值数组。
void | RowSet.setBytes(String parameterName, byte[] x) 将指定参数设置为给定的 Java byte 数组。
void | RowSetMetaData.setCaseSensitive(int columnIndex, boolean property) 设置指定列是否区分大小写。
void | RowSetMetaData.setCatalogName(int columnIndex, String catalogName) 将指定列的表的类别名称（如果有）设置为给定的 String。
void | RowSet.setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(int parameterIndex, Reader reader, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。
void | RowSet.setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | RowSet.setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。
void | RowSet.setClob(int i, Clob x) 使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。
void | RowSet.setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSetMetaData.setColumnCount(int columnCount) 将 RowSet 对象中的列数设置为给定数。
void | RowSetMetaData.setColumnDisplaySize(int columnIndex, int size) 将指定列的正常最大宽度（以 char 表示）设置为给定的 int。
void | RowSetMetaData.setColumnLabel(int columnIndex, String label) 将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。
void | RowSetMetaData.setColumnName(int columnIndex, String columnName) 将指定列的名称设置为给定的 String。
void | RowSetMetaData.setColumnType(int columnIndex, int SQLType) 将指定列的 SQL 类型设置为给定的类型。
void | RowSetMetaData.setColumnTypeName(int columnIndex, String typeName) 将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。
void | RowSet.setCommand(String cmd) 将此 RowSet 对象的命令属性设置为给定的 SQL 查询。
void | RowSet.setConcurrency(int concurrency) 将此 RowSet 对象的并发性设置为给定的并发级别。
void | RowSetMetaData.setCurrency(int columnIndex, boolean property) 设置指定的列是否是现金值。
void | RowSet.setDataSourceName(String name) 将此 RowSet 对象的数据源名称属性设置为给定的 String。
void | RowSet.setDate(int parameterIndex, Date x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(int parameterIndex, Date x, Calendar cal) 使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setDouble(int parameterIndex, double x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java double 值。
void | RowSet.setDouble(String parameterName, double x) 将指定参数设置为给定的 Java double 值。
void | RowSet.setEscapeProcessing(boolean enable) 将此 RowSet 对象的转义处理设置为开或关。
void | RowSet.setFloat(int parameterIndex, float x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java float 值。
void | RowSet.setFloat(String parameterName, float x) 将指定参数设置为给定的 Java float 值。
void | RowSet.setInt(int parameterIndex, int x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java int 值。
void | RowSet.setInt(String parameterName, int x) 将指定参数设置为给定的 Java int 值。
void | CommonDataSource.setLoginTimeout(int seconds) 设置此数据源试图连接到某一数据库时将等待的最长时间，以秒为单位。
void | CommonDataSource.setLogWriter(PrintWriter out) 将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。
void | RowSet.setLong(int parameterIndex, long x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java long 值。
void | RowSet.setLong(String parameterName, long x) 将指定参数设置为给定的 Java long 值。
void | RowSet.setMaxFieldSize(int max) 将可以对列值返回的最大字节数设置为给定的字节数。
void | RowSet.setMaxRows(int max) 将此 RowSet 对象可以包含的最大行数设置为指定数。
void | RowSetInternal.setMetaData(RowSetMetaData md) 将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | RowSet.setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | RowSet.setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | RowSet.setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | RowSet.setNString(int parameterIndex, String value) 将指定参数设置为给定的 String 对象。
void | RowSet.setNString(String parameterName, String value) 将指定参数设置为给定的 String 对象。
void | RowSet.setNull(int parameterIndex, int sqlType) 将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
void | RowSet.setNull(int paramIndex, int sqlType, String typeName) 将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
void | RowSet.setNull(String parameterName, int sqlType) 将指定参数设置为 SQL NULL。
void | RowSet.setNull(String parameterName, int sqlType, String typeName) 将指定参数设置为 SQL NULL。
void | RowSetMetaData.setNullable(int columnIndex, int property) 设置是否可以将指定列的值设置为 NULL。
void | RowSet.setObject(int parameterIndex, Object x) 使用 Java Object 设置此 RowSet 对象命令中的指定参数。
void | RowSet.setObject(int parameterIndex, Object x, int targetSqlType) 使用 Java Object 设置此 RowSet 对象命令中的指定参数。
void | RowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength) 使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。
void | RowSet.setObject(String parameterName, Object x) 使用给定对象设置指定参数的值。
void | RowSet.setObject(String parameterName, Object x, int targetSqlType) 使用给定对象设置指定参数的值。
void | RowSet.setObject(String parameterName, Object x, int targetSqlType, int scale) 使用给定对象设置指定参数的值。
void | RowSet.setPassword(String password) 将此 RowSet 对象的数据库密码设置为给定的 String。
void | RowSetMetaData.setPrecision(int columnIndex, int precision) 将指定列的小数位数设置为给定的 int。
void | RowSet.setQueryTimeout(int seconds) 将驱动程序等待语句执行的最大秒数设置为给定的秒数。
void | RowSet.setReadOnly(boolean value) 将此 RowSet 对象的只读性设置为给定的 boolean 值。
void | RowSet.setRef(int i, Ref x) 使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | RowSet.setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | RowSetMetaData.setScale(int columnIndex, int scale) 将指定列的小数点右边的位数设置为给定的 int。
void | RowSetMetaData.setSchemaName(int columnIndex, String schemaName) 将指定列的表模式的名称（如果有）设置为给定的 String。
void | RowSetMetaData.setSearchable(int columnIndex, boolean property) 设置是否可以在 where 子句中使用指定的列。
void | RowSet.setShort(int parameterIndex, short x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java short 值。
void | RowSet.setShort(String parameterName, short x) 将指定参数设置为给定的 Java short 值。
void | RowSetMetaData.setSigned(int columnIndex, boolean property) 设置指定列是否是有符号数字。
void | RowSet.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | RowSet.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。
void | RowSet.setString(int parameterIndex, String x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。
void | RowSet.setString(String parameterName, String x) 将指定参数设置为给定的 Java String 值。
void | RowSetMetaData.setTableName(int columnIndex, String tableName) 将指定列的表名称（如果有）设置为给定的 String。
void | RowSet.setTime(int parameterIndex, Time x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(int parameterIndex, Time x, Calendar cal) 使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTransactionIsolation(int level) 设置此 RowSet 对象的事务隔离级别。
void | RowSet.setType(int type) 将此 RowSet 对象的类型设置为给定的类型。
void | RowSet.setTypeMap(Map<String,Class<?>> map) 将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。
void | RowSet.setURL(int parameterIndex, URL x) 将指定参数设置为给定的 java.net.URL 值。
void | RowSet.setUrl(String url) 设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。
void | RowSet.setUsername(String name) 将此 RowSet 对象的用户名属性设置为给定的 String。
boolean | RowSetWriter.writeData(RowSetInternal caller) 将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。

参数类型为 SQLException 的 javax.sql 中的构造方法
ConnectionEvent(PooledConnection con, SQLException ex)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。
StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。

javax.sql.rowset 中 SQLException 的使用

javax.sql.rowset 中 SQLException 的子类
 class RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

抛出 SQLException 的 javax.sql.rowset 中的方法
 void JoinRowSet.addRowSet(Joinable rowset)
将给定的 RowSet 对象添加到此 JoinRowSet 对象。
 void JoinRowSet.addRowSet(RowSet[] rowset, int[] columnIdx)
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。
 void JoinRowSet.addRowSet(RowSet[] rowset, String[] columnName)
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。
 void JoinRowSet.addRowSet(RowSet rowset, int columnIdx)
将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。
 void JoinRowSet.addRowSet(RowSet rowset, String columnName)
将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。
 void BaseRowSet.clearParameters()
清除所有此 RowSet 对象的内部参数表示形式的当前参数值，这些参数值将在执行此 RowSet 对象的命令时在其中设置这些参数。
 boolean CachedRowSet.columnUpdated(int idx)
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
 boolean CachedRowSet.columnUpdated(String columnName)
指示此 CachedRowSet 对象当前行中的指定列是否已更新。
 void CachedRowSet.commit()
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
 void JdbcRowSet.commit()
每个 JdbcRowSet 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
 CachedRowSet CachedRowSet.createCopy()
创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。
 CachedRowSet CachedRowSet.createCopyNoConstraints()
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。
 CachedRowSet CachedRowSet.createCopySchema()
创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。
 RowSet CachedRowSet.createShared()
返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。
 boolean Predicate.evaluate(Object value, int column)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。
 boolean Predicate.evaluate(Object value, String columnName)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。
 void CachedRowSet.execute(Connection conn)
用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。
 boolean JdbcRowSet.getAutoCommit()
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 String RowSetMetaDataImpl.getCatalogName(int columnIndex)
获取派生指定列中值的表的类别名称。
 String RowSetMetaDataImpl.getColumnClassName(int columnIndex)
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。
 int RowSetMetaDataImpl.getColumnCount()
获取为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。
 int RowSetMetaDataImpl.getColumnDisplaySize(int columnIndex)
获取以 char 为单位的指定列的正常最大宽度。
 String RowSetMetaDataImpl.getColumnLabel(int columnIndex)
获取用于打印输出和显示的指定列的建议列标题。
 String RowSetMetaDataImpl.getColumnName(int columnIndex)
获取指定列的名称。
 int RowSetMetaDataImpl.getColumnType(int columnIndex)
获取存储在指定行中值的 SQL 类型的类型代码（java.sql.Types 常量之一）。
 String RowSetMetaDataImpl.getColumnTypeName(int columnIndex)
获取存储在指定列中值的特定于 DBMS 的类型名称。
 int BaseRowSet.getConcurrency()
返回此 RowSet 对象的并发性。
 boolean BaseRowSet.getEscapeProcessing()
确定是否为此 RowSet 对象启用了转义处理。
 int BaseRowSet.getFetchDirection()
获取此 RowSet 对象的当前有关获取方向的设置。
 int BaseRowSet.getFetchSize()
返回此 RowSet 对象的获取大小。
 int JoinRowSet.getJoinType()
返回一个 int 值，它描述控制此 JoinRowSet 实例的已设置 SQL JOIN 类型。
 int[] CachedRowSet.getKeyColumns()
返回一个包含一个或多个列号的数组，这些列号指示了形成某个键的列，该键唯一地标识了此 CachedRowSet 对象中的某个行。
 int[] Joinable.getMatchColumnIndexes()
获取使用方法 setMatchColumn(int[] columnIdxes) 为此 RowSet 对象设置的匹配列的索引。
 String[] Joinable.getMatchColumnNames()
获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。
 int BaseRowSet.getMaxFieldSize()
获取可用于此 RowSet 对象列值的最大字节数。
 int BaseRowSet.getMaxRows()
获取此 RowSet 对象可以包含的最大行数。
 ResultSet CachedRowSet.getOriginal()
返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。
 ResultSet CachedRowSet.getOriginalRow()
返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。
 Object[] BaseRowSet.getParams()
获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。
 int RowSetMetaDataImpl.getPrecision(int columnIndex)
获取存储在指定列中的值的数字总数。
 int BaseRowSet.getQueryTimeout()
获取驱动程序等待查询执行的最大秒数。
 String[] JoinRowSet.getRowSetNames()
返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。
 Collection<?> JoinRowSet.getRowSets()
返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。
 RowSetWarning CachedRowSet.getRowSetWarnings()
获取此 RowSet 对象上的调用报告的第一个警告。
 RowSetWarning JdbcRowSet.getRowSetWarnings()
获取此 JdbcRowSet 对象上的调用报告的第一个警告。
 int RowSetMetaDataImpl.getScale(int columnIndex)
获取存储在指定列中的值的小数点右边的数字数。
 String RowSetMetaDataImpl.getSchemaName(int columnIndex)
获取派生指定列中值的表的模式名称。
 boolean BaseRowSet.getShowDeleted()
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 boolean CachedRowSet.getShowDeleted()
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 boolean JdbcRowSet.getShowDeleted()
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 SyncProvider CachedRowSet.getSyncProvider()
获取此 CachedRowSet 对象的 SyncProvider 实现。
 String CachedRowSet.getTableName()
返回创建此 CachedRowSet 对象时所用对象（表）的标识符。
 String RowSetMetaDataImpl.getTableName(int columnIndex)
获取派生指定列中值的表名称。
 int BaseRowSet.getType()
返回此 RowSet 对象的类型。
 String BaseRowSet.getUrl()
获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。
 String JoinRowSet.getWhereClause()
返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。
 boolean RowSetMetaDataImpl.isAutoIncrement(int columnIndex)
获取存储在指定列中的值是否自动编号，因而是只读的。
 boolean RowSetMetaDataImpl.isCaseSensitive(int columnIndex)
指示指定列的名称是否区分大小写。
 boolean RowSetMetaDataImpl.isCurrency(int columnIndex)
指示存储在指定列中的值是否为缓存值。
 boolean RowSetMetaDataImpl.isDefinitelyWritable(int columnIndex)
指示在指定的列上进行写操作是否一定可以获得成功。
 int RowSetMetaDataImpl.isNullable(int columnIndex)
获取指示是否可以在指定列中存储 NULL 值的常量。
 boolean RowSetMetaDataImpl.isReadOnly(int columnIndex)
指示指定的列是否一定不可写入，即只读。
 boolean RowSetMetaDataImpl.isSearchable(int columnIndex)
指示是否可以在 WHERE 子句中使用存储在指定列中的值。
 boolean RowSetMetaDataImpl.isSigned(int columnIndex)
指示存储在指定列中的值是否为有符号数。
 boolean RowSetMetaDataImpl.isWrapperFor(Class<?> interfaces)
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。
 boolean RowSetMetaDataImpl.isWritable(int columnIndex)
指示在指定的列上进行写操作是否可以获得成功。
 boolean CachedRowSet.nextPage()
逐个增加 CachedRowSet 的当前页。
protected  void BaseRowSet.notifyCursorMoved()
通知向此 RowSet 对象注册的所有侦听器其光标已移动。
protected  void BaseRowSet.notifyRowChanged()
通知向此 RowSet 对象注册的所有侦听器其行已更改。
protected  void BaseRowSet.notifyRowSetChanged()
通知向此 RowSet 对象注册的所有侦听器其整个内容已更改。
 void CachedRowSet.populate(ResultSet data)
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
 void CachedRowSet.populate(ResultSet rs, int startRow)
使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
 boolean CachedRowSet.previousPage()
逐个减少 CachedRowSet 的当前页。
 void WebRowSet.readXml(InputStream iStream)
读取基于流的 XML 输入，以填充此 WebRowSet 对象。
 void WebRowSet.readXml(Reader reader)
从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。
 void CachedRowSet.release()
释放此 CachedRowSet 对象的当前内容并将 rowSetChanged 事件发送到所有已注册侦听器。
 void CachedRowSet.restoreOriginal()
将此 CachedRowSet 对象还原成其原始值，即执行上一组更改前的值。
 void CachedRowSet.rollback()
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void JdbcRowSet.rollback()
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void CachedRowSet.rollback(Savepoint s)
每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void JdbcRowSet.rollback(Savepoint s)
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void CachedRowSet.rowSetPopulated(RowSetEvent event, int numRows)
通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。
 void BaseRowSet.setArray(int parameterIndex, Array array)
将指定参数设置为 Java 编程语言中的 Array 对象。
 void BaseRowSet.setAsciiStream(int parameterIndex, InputStream x)
将此 RowSet 对象命令中的指定参数设置为给定输入流。
 void BaseRowSet.setAsciiStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。
 void BaseRowSet.setAsciiStream(String parameterName, InputStream x)
将指定参数设置为给定的输入流。
 void BaseRowSet.setAsciiStream(String parameterName, InputStream x, int length)
将指定参数设置为给定输入流，该输入流将拥有指定字节数。
 void JdbcRowSet.setAutoCommit(boolean autoCommit)
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
 void RowSetMetaDataImpl.setAutoIncrement(int columnIndex, boolean property)
将指定列设置为给定 boolean 值，以指示是否为该列自动编号，从而变为只读。
 void BaseRowSet.setBigDecimal(int parameterIndex, BigDecimal x)
将指定参数设置为给定的 java.lang.BigDecimal 值。
 void BaseRowSet.setBigDecimal(String parameterName, BigDecimal x)
将指定参数设置为给定的 java.math.BigDecimal 值。
 void BaseRowSet.setBinaryStream(int parameterIndex, InputStream x)
将此 RowSet 对象命令中的指定参数设置为给定输入流。
 void BaseRowSet.setBinaryStream(int parameterIndex, InputStream x, int length)
将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。
 void BaseRowSet.setBinaryStream(String parameterName, InputStream x)
将指定参数设置为给定输入流。
 void BaseRowSet.setBinaryStream(String parameterName, InputStream x, int length)
将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。
 void BaseRowSet.setBlob(int parameterIndex, Blob x)
将指定参数设置为 Java 编程语言中的给定 Blob 对象。
 void BaseRowSet.setBlob(int parameterIndex, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBlob(int parameterIndex, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBlob(String parameterName, Blob x)
将指定参数设置为给定的 java.sql.Blob 对象。
 void BaseRowSet.setBlob(String parameterName, InputStream inputStream)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBlob(String parameterName, InputStream inputStream, long length)
将指定参数设置为 InputStream 对象。
 void BaseRowSet.setBoolean(int parameterIndex, boolean x)
将指定参数设置为 Java 编程语言中的给定 boolean 值。
 void BaseRowSet.setBoolean(String parameterName, boolean x)
将指定参数设置为给定的 Java boolean 值。
 void BaseRowSet.setByte(int parameterIndex, byte x)
将指定参数设置为 Java 编程语言中的给定 byte 值。
 void BaseRowSet.setByte(String parameterName, byte x)
将指定参数设置为给定的 Java byte 值。
 void BaseRowSet.setBytes(int parameterIndex, byte[] x)
将指定参数设置为给定的 byte 数组。
 void BaseRowSet.setBytes(String parameterName, byte[] x)
将指定参数设置为给定的 Java byte 数组。
 void RowSetMetaDataImpl.setCaseSensitive(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示该列的名称是否区分大小写。
 void RowSetMetaDataImpl.setCatalogName(int columnIndex, String catalogName)
将派生指定列的表名称设置为 catalogName。
 void BaseRowSet.setCharacterStream(int parameterIndex, Reader reader)
将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。
 void BaseRowSet.setCharacterStream(int parameterIndex, Reader reader, int length)
将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。
 void BaseRowSet.setCharacterStream(String parameterName, Reader reader)
将指定参数设置为给定 Reader 对象。
 void BaseRowSet.setCharacterStream(String parameterName, Reader reader, int length)
将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。
 void BaseRowSet.setClob(int parameterIndex, Clob x)
将指定参数设置为 Java 编程语言中的给定 Clob 对象。
 void BaseRowSet.setClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setClob(String parameterName, Clob x)
将指定参数设置为给定的 java.sql.Clob 对象。
 void BaseRowSet.setClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void RowSetMetaDataImpl.setColumnCount(int columnCount)
在为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中，将列数设置为给定数。
 void RowSetMetaDataImpl.setColumnDisplaySize(int columnIndex, int size)
将指定列中的正常最大 char 数设置为给定数。
 void RowSetMetaDataImpl.setColumnLabel(int columnIndex, String label)
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。
 void RowSetMetaDataImpl.setColumnName(int columnIndex, String columnName)
将指定列的列名称设置为给定的名称。
 void RowSetMetaDataImpl.setColumnType(int columnIndex, int SQLType)
将存储在指定列中的值的 SQL 类型代码设置为 java.sql.Types 类中的给定类型代码。
 void RowSetMetaDataImpl.setColumnTypeName(int columnIndex, String typeName)
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。
 void BaseRowSet.setCommand(String cmd)
将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。
 void BaseRowSet.setConcurrency(int concurrency)
将此 RowSet 对象的并发性设置为指定的并发性。
 void RowSetMetaDataImpl.setCurrency(int columnIndex, boolean property)
将指定列设置为给定的 boolean，以指示存储在该列中的值是否为缓存值。
 void BaseRowSet.setDataSourceName(String name)
将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。
 void BaseRowSet.setDate(int parameterIndex, Date x)
将指定参数设置为给定的 java.sql.Date 值。
 void BaseRowSet.setDate(int parameterIndex, Date x, Calendar cal)
将指定参数设置为给定的 java.sql.Date 对象。
 void BaseRowSet.setDate(String parameterName, Date x)
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
 void BaseRowSet.setDate(String parameterName, Date x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
 void BaseRowSet.setDouble(int parameterIndex, double x)
将指定参数设置为 Java 编程语言中的给定 double 值。
 void BaseRowSet.setDouble(String parameterName, double x)
将指定参数设置为给定的 Java double 值。
 void BaseRowSet.setEscapeProcessing(boolean enable)
设置为给定的 boolean 值，指示将 SQL 语句发送到数据库之前，驱动程序是否扫描转义语法并进行转义替换。
 void BaseRowSet.setFetchDirection(int direction)
为驱动程序提供一个性能提示，该提示指示处理此 RowSet 对象中各行时使用的方向。
 void BaseRowSet.setFetchSize(int rows)
将此 RowSet 对象的获取大小设置为给定的行数。
 void FilteredRowSet.setFilter(Predicate p)
将给定的 Predicate 对象应用到此 FilteredRowSet 对象。
 void BaseRowSet.setFloat(int parameterIndex, float x)
将指定参数设置为 Java 编程语言中的给定 float 值。
 void BaseRowSet.setFloat(String parameterName, float x)
将指定参数设置为给定的 Java float 值。
 void BaseRowSet.setInt(int parameterIndex, int x)
将指定参数设置为 Java 编程语言中的 int 值。
 void BaseRowSet.setInt(String parameterName, int x)
将指定参数设置为给定的 Java int 值。
 void JoinRowSet.setJoinType(int joinType)
允许应用程序调整在 JoinRowSet 对象实例包含的表上强制应用的 JOIN 类型。
 void CachedRowSet.setKeyColumns(int[] keys)
使用给定的列号数组设置此 CachedRowSet 对象的 keyCols 字段，它形成了唯一标识此 CachedRowSet 对象中某个行的键。
 void BaseRowSet.setLong(int parameterIndex, long x)
将指定参数设置为 Java 编程语言中的给定 long 值。
 void BaseRowSet.setLong(String parameterName, long x)
将指定参数设置为给定的 Java long 值。
 void Joinable.setMatchColumn(int columnIdx)
将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.setMatchColumn(int[] columnIdxes)
将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.setMatchColumn(String columnName)
将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.setMatchColumn(String[] columnNames)
将指定的列设置为此 RowSet 对象的匹配列。
 void BaseRowSet.setMaxFieldSize(int max)
将可用于此 RowSet 对象列值的最大字节数设置为给定数。
 void BaseRowSet.setMaxRows(int max)
将此 RowSet 对象可以包含的最大行数设置为给定数。
 void CachedRowSet.setMetaData(RowSetMetaData md)
使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。
 void BaseRowSet.setNCharacterStream(int parameterIndex, Reader value)
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
 void BaseRowSet.setNCharacterStream(int parameterIndex, Reader value, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNCharacterStream(String parameterName, Reader value)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNCharacterStream(String parameterName, Reader value, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(int parameterIndex, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void BaseRowSet.setNClob(int parameterIndex, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(int parameterIndex, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(String parameterName, NClob value)
将指定参数设置为 java.sql.NClob 对象。
 void BaseRowSet.setNClob(String parameterName, Reader reader)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNClob(String parameterName, Reader reader, long length)
将指定参数设置为 Reader 对象。
 void BaseRowSet.setNString(int parameterIndex, String value)
将指定参数设置为给定的 String 对象。
 void BaseRowSet.setNString(String parameterName, String value)
将指定参数设置为给定的 String 对象。
 void BaseRowSet.setNull(int parameterIndex, int sqlType)
将指定参数设置为 SQL NULL。
 void BaseRowSet.setNull(int parameterIndex, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void BaseRowSet.setNull(String parameterName, int sqlType)
将指定参数设置为 SQL NULL。
 void BaseRowSet.setNull(String parameterName, int sqlType, String typeName)
将指定参数设置为 SQL NULL。
 void RowSetMetaDataImpl.setNullable(int columnIndex, int property)
将指定列设置为 ResultSetMetaData 接口中的给定常量，以指示是否可以将存储在该列中的值设置为 NULL。
 void BaseRowSet.setObject(int parameterIndex, Object x)
将指定参数设置为 Java 编程语言中的 Object。
 void BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType)
使用给定 Object 值设置指定参数的值。
 void BaseRowSet.setObject(int parameterIndex, Object x, int targetSqlType, int scale)
将指定参数设置为 Java 编程语言中的 Object。
 void BaseRowSet.setObject(String parameterName, Object x)
使用给定对象设置指定参数的值。
 void BaseRowSet.setObject(String parameterName, Object x, int targetSqlType)
使用给定对象设置指定参数的值。
 void BaseRowSet.setObject(String parameterName, Object x, int targetSqlType, int scale)
使用给定对象设置指定参数的值。
 void CachedRowSet.setOriginalRow()
将此 CachedRowSet 对象中的当前行设置为原始行。
 void CachedRowSet.setPageSize(int size)
设置 CachedRowSet 对象的页大小。
 void RowSetMetaDataImpl.setPrecision(int columnIndex, int precision)
将存储在指定列中的值的小数位数的总数设置为给定数。
 void BaseRowSet.setQueryTimeout(int seconds)
将驱动程序等待查询执行的最大秒数设置为给定的数。
 void BaseRowSet.setRef(int parameterIndex, Ref ref)
将指定参数设置为 Java 编程语言中的给定 Ref 对象。
 void BaseRowSet.setRowId(int parameterIndex, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。
 void BaseRowSet.setRowId(String parameterName, RowId x)
将指定参数设置为给定的 java.sql.RowId 对象。
 void RowSetMetaDataImpl.setScale(int columnIndex, int scale)
将存储在指定列中的值的小数点右边的位数设置为给定数。
 void RowSetMetaDataImpl.setSchemaName(int columnIndex, String schemaName)
将指定列的表的模式名称（如果有）设置为 schemaName。
 void RowSetMetaDataImpl.setSearchable(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否可以在 WHERE 子句中使用。
 void BaseRowSet.setShort(int parameterIndex, short x)
将指定参数设置为 Java 编程语言中的给定 short 值。
 void BaseRowSet.setShort(String parameterName, short x)
将指定参数设置为给定的 Java short 值。
 void BaseRowSet.setShowDeleted(boolean value)
将属性 showDeleted 设置为给定的 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
 void CachedRowSet.setShowDeleted(boolean b)
将属性 showDeleted 设置为给定的 boolean 值，它确定标记为删除的行是否会出现在当前行集合中。
 void JdbcRowSet.setShowDeleted(boolean b)
将属性 showDeleted 设置为给定的 boolean 值。
 void RowSetMetaDataImpl.setSigned(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否为有符号数。
 void BaseRowSet.setSQLXML(int parameterIndex, SQLXML xmlObject)
将指定参数设置为给定 java.sql.SQLXML 对象。
 void BaseRowSet.setSQLXML(String parameterName, SQLXML xmlObject)
将指定参数设置为给定的 java.sql.SQLXML 对象。
 void BaseRowSet.setString(int parameterIndex, String x)
将指定参数设置为给定的 String 值。
 void BaseRowSet.setString(String parameterName, String x)
将指定参数设置为给定的 Java String 值。
 void CachedRowSet.setSyncProvider(String provider)
将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。
 void RowSetMetaDataImpl.setTableName(int columnIndex, String tableName)
将派生指定列的表名称设置为给定的表名称。
 void CachedRowSet.setTableName(String tabName)
将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。
 void BaseRowSet.setTime(int parameterIndex, Time x)
将指定参数设置为给定的 java.sql.Time 值。
 void BaseRowSet.setTime(int parameterIndex, Time x, Calendar cal)
将指定参数设置为给定的 java.sql.Time 对象。
 void BaseRowSet.setTime(String parameterName, Time x)
将指定参数设置为给定的 java.sql.Time 值。
 void BaseRowSet.setTime(String parameterName, Time x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
 void BaseRowSet.setTimestamp(int parameterIndex, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。
 void BaseRowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal)
将指定参数设置为给定的 java.sql.Timestamp 对象。
 void BaseRowSet.setTimestamp(String parameterName, Timestamp x)
将指定参数设置为给定的 java.sql.Timestamp 值。
 void BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal)
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
 void BaseRowSet.setTransactionIsolation(int level)
将此 JDBC RowSet 对象的事务隔离属性设置为给定的常量。
 void BaseRowSet.setType(int type)
将此 RowSet 对象的类型设置为指定类型。
 void BaseRowSet.setUnicodeStream(int parameterIndex, InputStream x, int length)
已过时。 应该使用 getCharacterStream 替代它
 void BaseRowSet.setURL(int parameterIndex, URL x)
将指定参数设置为给定的 java.net.URL 值。
 void BaseRowSet.setUrl(String url)
将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。
 CachedRowSet JoinRowSet.toCachedRowSet()
创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。
 Collection<?> CachedRowSet.toCollection()
将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。
 Collection<?> CachedRowSet.toCollection(int column)
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
 Collection<?> CachedRowSet.toCollection(String column)
将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
 void CachedRowSet.undoDelete()
取消删除当前行并通知侦听器已更改了某个行。
 void CachedRowSet.undoInsert()
如果已经插入了当前行，则立即将它从此 CachedRowSet 对象移除，同样要通知侦听器已更改了某个行。
 void CachedRowSet.undoUpdate()
如果已经修改了行，则立即逆转上一次更新操作。
 void Joinable.unsetMatchColumn(int columnIdx)
取消将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.unsetMatchColumn(int[] columnIdxes)
取消将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.unsetMatchColumn(String columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。
 void Joinable.unsetMatchColumn(String[] columnName)
取消将指定的列设置为此 RowSet 对象的匹配列。
<T> T
RowSetMetaDataImpl.unwrap(Class<T> iface)
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。
 void WebRowSet.writeXml(OutputStream oStream)
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
 void WebRowSet.writeXml(ResultSet rs, OutputStream oStream)
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。
 void WebRowSet.writeXml(ResultSet rs, Writer writer)
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。
 void WebRowSet.writeXml(Writer writer)
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。

javax.sql.rowset.serial 中 SQLException 的使用

javax.sql.rowset.serial 中 SQLException 的子类
 class SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

抛出 SQLException 的 javax.sql.rowset.serial 中的方法
void | SerialArray.free() 此方法释放 Array 对象及其占有的资源。
void | SerialBlob.free() 此方法释放 Blob 对象及其占有的资源。
void | SerialClob.free()
InputStream | SerialClob.getAsciiStream() 以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
InputStream | SerialBlob.getBinaryStream(long pos, long length) 返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。
Reader | SerialClob.getCharacterStream(long pos, long length)
long | SerialBlob.position(Blob pattern, long start) 返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
long | SerialBlob.position(byte[] pattern, long start) 返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。
long | SerialClob.position(Clob searchStr, long start) 返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
long | SerialClob.position(String searchStr, long start) 返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。
Array | SQLInputImpl.readArray() 从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。
InputStream | SQLInputImpl.readAsciiStream() 以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。
BigDecimal | SQLInputImpl.readBigDecimal() 以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。
InputStream | SQLInputImpl.readBinaryStream() 以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。
Blob | SQLInputImpl.readBlob() 以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。
boolean | SQLInputImpl.readBoolean() 以 Java 编程语言中 boolean 的形式获取此 SQLInputImpl 对象中的下一个属性。
byte | SQLInputImpl.readByte() 以 Java 编程语言中 byte 的形式获取此 SQLInputImpl 对象中的下一个属性。
byte[] | SQLInputImpl.readBytes() 以字节数组的形式获取此 SQLInputImpl 对象中的下一个属性。
Reader | SQLInputImpl.readCharacterStream() 以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。
Clob | SQLInputImpl.readClob() 以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。
Date | SQLInputImpl.readDate() 以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。
double | SQLInputImpl.readDouble() 以 Java 编程语言中 double 的形式获取此 SQLInputImpl 对象中的下一个属性。
float | SQLInputImpl.readFloat() 以 Java 编程语言中 float 的形式获取此 SQLInputImpl 对象中的下一个属性。
int | SQLInputImpl.readInt() 以 Java 编程语言中 int 的形式获取此 SQLInputImpl 对象中的下一个属性。
long | SQLInputImpl.readLong() 以 Java 编程语言中 long 的形式获取此 SQLInputImpl 对象中的下一个属性。
NClob | SQLInputImpl.readNClob() 从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。
String | SQLInputImpl.readNString() 读取流中下一个属性并以 Java 编程语言中 String 的形式返回。
Object | SQLInputImpl.readObject() 以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。
Ref | SQLInputImpl.readRef() 以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。
RowId | SQLInputImpl.readRowId() 从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。
short | SQLInputImpl.readShort() 以 Java 编程语言中 short 的形式获取此 SQLInputImpl 对象中的下一个属性。
SQLXML | SQLInputImpl.readSQLXML() 从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。
String | SQLInputImpl.readString() 以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。
Time | SQLInputImpl.readTime() 以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
Timestamp | SQLInputImpl.readTimestamp() 以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
URL | SQLInputImpl.readURL() 从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。
OutputStream | SerialClob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
OutputStream | SerialBlob.setBinaryStream(long pos) 获取用于写入此 Blob 对象所表示的 BLOB 值的流。
int | SerialBlob.setBytes(long pos, byte[] bytes) 将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。
int | SerialBlob.setBytes(long pos, byte[] bytes, int offset, int length) 将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
Writer | SerialClob.setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。
boolean | SQLInputImpl.wasNull() 确认从此 SQLInputImpl 对象读取的上一个值是否为 null。
void | SQLOutputImpl.writeArray(Array x) 将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeAsciiStream(InputStream x) 将 ASCII 字符流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBigDecimal(BigDecimal x) 将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBinaryStream(InputStream x) 将未解释字节流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBlob(Blob x) 将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBoolean(boolean x) 将 Java 编程语言中的 boolean 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeByte(byte x) 将 Java 编程语言中的 byte 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeBytes(byte[] x) 将 Java 编程语言中的 byte 数组写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeCharacterStream(Reader x) 将 Unicode 字符流写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeClob(Clob x) 将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeDate(Date x) 将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeDouble(double x) 将 Java 编程语言中的 double 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeFloat(float x) 将 Java 编程语言中的 float 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeInt(int x) 将 Java 编程语言中的 int 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeLong(long x) 将 Java 编程语言中的 long 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeNClob(NClob x) 将 SQL NCLOB 值写入流中。
void | SQLOutputImpl.writeNString(String x) 将下一个属性以 Java 编程语言中 String 的形式写入流中。
void | SQLOutputImpl.writeObject(SQLData x) 将包含在给定 SQLData 对象中的数据写入流中。
void | SQLOutputImpl.writeRef(Ref x) 将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeRowId(RowId x) 将 SQL ROWID 值写入流中。
void | SQLOutputImpl.writeShort(short x) 将 Java 编程语言中的 short 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeSQLXML(SQLXML x) 将 SQL XML 值写入流中。
void | SQLOutputImpl.writeString(String x) 将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeStruct(Struct x) 将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeTime(Time x) 将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeTimestamp(Timestamp x) 将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。
void | SQLOutputImpl.writeURL(URL url) 将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。

抛出 SQLException 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array)
根据给定 Array 对象构造新的 SerialArray 对象。
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialBlob(Blob blob)
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。
SerialBlob(byte[] b)
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。
SerialClob(char[] ch)
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。
SerialClob(Clob clob)
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。
SerialRef(Ref ref)
根据给定 Ref 对象构造 SerialRef 对象。
SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。
SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.sql.rowset.spi 中 SQLException 的使用

javax.sql.rowset.spi 中 SQLException 的子类
class | SyncFactoryException 指示 SyncFactory 机制发生的错误。
class | SyncProviderException 指示 SyncProvider 机制发生的错误。

抛出 SQLException 的 javax.sql.rowset.spi 中的方法
void | TransactionalWriter.commit() 使最后一次调用 commit 或 rollback 方法以来 acceptChanges 执行的所有更改永久化。
Object | SyncResolver.getConflictValue(int index) 获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
Object | SyncResolver.getConflictValue(String columnName) 获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
boolean | SyncResolver.nextConflict() 将指针从其当前位置移动到下一个包含冲突值的行。
boolean | SyncResolver.previousConflict() 将指针从其当前位置移动到此 SyncResolver 对象中上一个冲突行。
void | XmlReader.readXML(WebRowSet caller, Reader reader) 从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。
void | TransactionalWriter.rollback() 撤消在当前事务中进行的所有更改。
void | TransactionalWriter.rollback(Savepoint s) 撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。
void | SyncResolver.setResolvedValue(int index, Object obj) 将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。
void | SyncResolver.setResolvedValue(String columnName, Object obj) 将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。
void | XmlWriter.writeXML(WebRowSet caller, Writer writer) 将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLFeatureNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLFeatureNotSupportedException
的使用

没有 java.sql.SQLFeatureNotSupportedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.SQLInput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLInput
的使用

使用 SQLInput 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLInput 的使用

参数类型为 SQLInput 的 java.sql 中的方法
 void SQLData.readSQL(SQLInput stream, String typeName)
用从数据库读取的数据填充此对象。

javax.sql.rowset.serial 中 SQLInput 的使用

实现 SQLInput 的 javax.sql.rowset.serial 中的类
 class SQLInputImpl
用于自定义映射用户定义类型 (UDT) 的输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLIntegrityConstraintViolationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLIntegrityConstraintViolationException
的使用

没有 java.sql.SQLIntegrityConstraintViolationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLInvalidAuthorizationSpecException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLInvalidAuthorizationSpecException
的使用

没有 java.sql.SQLInvalidAuthorizationSpecException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLNonTransientConnectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLNonTransientConnectionException
的使用

没有 java.sql.SQLNonTransientConnectionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLNonTransientException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLNonTransientException
的使用

使用 SQLNonTransientException 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLNonTransientException 的使用

java.sql 中 SQLNonTransientException 的子类
class | SQLDataException 当 SQLState 类值为“22”时抛出的 SQLException 子类。
class | SQLFeatureNotSupportedException 当 SQLState 类值为“0A”（值为“零”A）时抛出的 SQLException 子类。
class | SQLIntegrityConstraintViolationException 当 SQLState 类值为“23”时抛出的 SQLException 子类。
class | SQLInvalidAuthorizationSpecException 当 SQLState 类值为“28”时抛出的 SQLException 子类。
class | SQLNonTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在失败原因没有纠正的情况下重试操作时，失败的连接操作不会成功。
class | SQLSyntaxErrorException 当 SQLState 类值为“42”时抛出的 SQLException 子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.SQLOutput 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLOutput
的使用

使用 SQLOutput 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLOutput 的使用

参数类型为 SQLOutput 的 java.sql 中的方法
 void SQLData.writeSQL(SQLOutput stream)
将此对象写入给定的 SQL 数据流，同时将其转换回数据源中它的 SQL 值。

javax.sql.rowset.serial 中 SQLOutput 的使用

实现 SQLOutput 的 javax.sql.rowset.serial 中的类
 class SQLOutputImpl
用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLPermission
的使用

没有 java.sql.SQLPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLRecoverableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLRecoverableException
的使用

没有 java.sql.SQLRecoverableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLSyntaxErrorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLSyntaxErrorException
的使用

没有 java.sql.SQLSyntaxErrorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLTimeoutException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTimeoutException
的使用

没有 java.sql.SQLTimeoutException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLTransactionRollbackException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTransactionRollbackException
的使用

没有 java.sql.SQLTransactionRollbackException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLTransientConnectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTransientConnectionException
的使用

没有 java.sql.SQLTransientConnectionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLTransientException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLTransientException
的使用

使用 SQLTransientException 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLTransientException 的使用

java.sql 中 SQLTransientException 的子类
class | SQLTimeoutException Statement 指定的超时已到期时抛出的 SQLException 子类。
class | SQLTransactionRollbackException 当 SQLState 类值为“40”时，抛出此 SQLException 的子类。
class | SQLTransientConnectionException SQLState 类值为“08”时抛出的 SQLException 子类，表示在没有进行任何应用程序级更改的情况下重试操作时，失败的连接操作可以成功。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.SQLWarning 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.SQLWarning
的使用

使用 SQLWarning 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 SQLWarning 的使用

java.sql 中 SQLWarning 的子类
 class DataTruncation
以 DataTruncation 异常形式抛出的异常（写入时），或者由于除数据值超出 MaxFieldSize 之外的某种原因意外地截断该数据值时以 DataTruncation 警告形式报告的异常（读取时）。

返回 SQLWarning 的 java.sql 中的方法
SQLWarning | SQLWarning.getNextWarning() 通过 setNextWarning 获取链接到此 SQLWarning 对象的警告。
SQLWarning | Connection.getWarnings() 获取此 Connection 对象上的调用报告的第一个警告。
SQLWarning | ResultSet.getWarnings() 获取此 ResultSet 对象上的调用报告的第一个警告。
SQLWarning | Statement.getWarnings() 获取此 Statement 对象上的调用报告的第一个警告。

参数类型为 SQLWarning 的 java.sql 中的方法
 void SQLWarning.setNextWarning(SQLWarning w)
将 SQLWarning 对象添加到链接的末尾。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.SQLXML 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.SQLXML
的使用

使用 SQLXML 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 SQLXML 的使用

返回 SQLXML 的 java.sql 中的方法
SQLXML | Connection.createSQLXML() 构造实现 SQLXML 接口的对象。
SQLXML | CallableStatement.getSQLXML(int parameterIndex) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
SQLXML | ResultSet.getSQLXML(int columnIndex) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
SQLXML | CallableStatement.getSQLXML(String parameterName) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取指定的 SQL XML 参数的值。
SQLXML | ResultSet.getSQLXML(String columnLabel) 以 Java 编程语言中 java.sql.SQLXML 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
SQLXML | SQLInput.readSQLXML() 从流中读取一个 SQL XML 值，并以 Java 编程语言中 SQLXML 对象的形式返回。

参数类型为 SQLXML 的 java.sql 中的方法
void | PreparedStatement.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | CallableStatement.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | ResultSet.updateSQLXML(int columnIndex, SQLXML xmlObject) 用 java.sql.SQLXML 值更新指定列。
void | ResultSet.updateSQLXML(String columnLabel, SQLXML xmlObject) 用 java.sql.SQLXML 值更新指定的列。
void | SQLOutput.writeSQLXML(SQLXML x) 将 SQL XML 值写入流中。

javax.sql 中 SQLXML 的使用

参数类型为 SQLXML 的 javax.sql 中的方法
void | RowSet.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | RowSet.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。

javax.sql.rowset 中 SQLXML 的使用

参数类型为 SQLXML 的 javax.sql.rowset 中的方法
void | BaseRowSet.setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | BaseRowSet.setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。

javax.sql.rowset.serial 中 SQLXML 的使用

返回 SQLXML 的 javax.sql.rowset.serial 中的方法
 SQLXML SQLInputImpl.readSQLXML()
从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。

参数类型为 SQLXML 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeSQLXML(SQLXML x)
将 SQL XML 值写入流中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Savepoint 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Savepoint
的使用

使用 Savepoint 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 Savepoint 的使用

返回 Savepoint 的 java.sql 中的方法
Savepoint | Connection.setSavepoint() 在当前事务中创建一个未命名的保存点 (savepoint)，并返回表示它的新 Savepoint 对象。
Savepoint | Connection.setSavepoint(String name) 在当前事务中创建一个具有给定名称的保存点，并返回表示它的新 Savepoint 对象。

参数类型为 Savepoint 的 java.sql 中的方法
void | Connection.releaseSavepoint(Savepoint savepoint) 从当前事务中移除指定的 Savepoint 和后续 Savepoint 对象。
void | Connection.rollback(Savepoint savepoint) 取消所有设置给定 Savepoint 对象之后进行的更改。

javax.sql.rowset 中 Savepoint 的使用

参数类型为 Savepoint 的 javax.sql.rowset 中的方法
void | CachedRowSet.rollback(Savepoint s) 每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
void | JdbcRowSet.rollback(Savepoint s) 每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。

javax.sql.rowset.spi 中 Savepoint 的使用

参数类型为 Savepoint 的 javax.sql.rowset.spi 中的方法
 void TransactionalWriter.rollback(Savepoint s)
撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Statement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Statement
的使用

使用 Statement 的软件包
java.sql 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。

java.sql 中 Statement 的使用

java.sql 中 Statement 的子接口
interface | CallableStatement 用于执行 SQL 存储过程的接口。
interface | PreparedStatement 表示预编译的 SQL 语句的对象。

返回 Statement 的 java.sql 中的方法
Statement | Connection.createStatement() 创建一个 Statement 对象来将 SQL 语句发送到数据库。
Statement | Connection.createStatement(int resultSetType, int resultSetConcurrency) 创建一个 Statement 对象，该对象将生成具有给定类型和并发性的 ResultSet 对象。
Statement | Connection.createStatement(int resultSetType, int resultSetConcurrency, int resultSetHoldability) 创建一个 Statement 对象，该对象将生成具有给定类型、并发性和可保存性的 ResultSet 对象。
Statement | ResultSet.getStatement() 获取生成此 ResultSet 对象的 Statement 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Struct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Struct
的使用

使用 Struct 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Struct 的使用

返回 Struct 的 java.sql 中的方法
 Struct Connection.createStruct(String typeName, Object[] attributes)
创建 Struct 对象的工厂方法。

参数类型为 Struct 的 java.sql 中的方法
 void SQLOutput.writeStruct(Struct x)
将 SQL 结构类型值写入流中。

javax.sql.rowset.serial 中 Struct 的使用

实现 Struct 的 javax.sql.rowset.serial 中的类
 class SerialStruct
SQL 结构类型在 Java 编程语言中的序列化映射关系。

参数类型为 Struct 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeStruct(Struct x)
将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。

参数类型为 Struct 的 javax.sql.rowset.serial 中的构造方法
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.Time 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Time
的使用

使用 Time 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Time 的使用

返回 Time 的 java.sql 中的方法
Time | CallableStatement.getTime(int parameterIndex) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值。
Time | ResultSet.getTime(int columnIndex) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(int parameterIndex, Calendar cal) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(String parameterName) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值。
Time | ResultSet.getTime(String columnLabel) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(String parameterName, Calendar cal) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | SQLInput.readTime() 读取流中的下一个属性并将其作为 java.sql.Time 对象返回。
static Time | Time.valueOf(String s) 将使用 JDBC 时间转义格式的字符串转换为 Time 值。

参数类型为 Time 的 java.sql 中的方法
void | PreparedStatement.setTime(int parameterIndex, Time x) 将指定参数设置为给定 java.sql.Time 值。
void | PreparedStatement.setTime(int parameterIndex, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | CallableStatement.setTime(String parameterName, Time x) 将指定参数设置为给定 java.sql.Time 值。
void | CallableStatement.setTime(String parameterName, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | ResultSet.updateTime(int columnIndex, Time x) 用 java.sql.Time 值更新指定列。
void | ResultSet.updateTime(String columnLabel, Time x) 用 java.sql.Time 值更新指定列。
void | SQLOutput.writeTime(Time x) 将下一个属性作为 java.sql.Time 对象写入流中。

javax.sql 中 Time 的使用

参数类型为 Time 的 javax.sql 中的方法
void | RowSet.setTime(int parameterIndex, Time x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(int parameterIndex, Time x, Calendar cal) 使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

javax.sql.rowset 中 Time 的使用

参数类型为 Time 的 javax.sql.rowset 中的方法
void | BaseRowSet.setTime(int parameterIndex, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | BaseRowSet.setTime(int parameterIndex, Time x, Calendar cal) 将指定参数设置为给定的 java.sql.Time 对象。
void | BaseRowSet.setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | BaseRowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。

javax.sql.rowset.serial 中 Time 的使用

返回 Time 的 javax.sql.rowset.serial 中的方法
 Time SQLInputImpl.readTime()
以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 Time 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeTime(Time x)
将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.Timestamp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Timestamp
的使用

使用 Timestamp 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

java.sql 中 Timestamp 的使用

返回 Timestamp 的 java.sql 中的方法
Timestamp | CallableStatement.getTimestamp(int parameterIndex) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值。
Timestamp | ResultSet.getTimestamp(int columnIndex) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(int parameterIndex, Calendar cal) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(String parameterName) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值。
Timestamp | ResultSet.getTimestamp(String columnLabel) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(String parameterName, Calendar cal) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | SQLInput.readTimestamp() 读取流中的下一个属性并将其作为 java.sql.Timestamp 对象返回。
static Timestamp | Timestamp.valueOf(String s) 将使用 JDBC 时间戳转义格式的 String 对象转换为 Timestamp 值。

参数类型为 Timestamp 的 java.sql 中的方法
boolean | Timestamp.after(Timestamp ts) 指示此 Timestamp 对象是否晚于给定的 Timestamp 对象。
boolean | Timestamp.before(Timestamp ts) 指示此 Timestamp 对象是否早于给定的 Timestamp 对象。
int | Timestamp.compareTo(Timestamp ts) 将此 Timestamp 对象与给定 Timestamp 对象相比较。
boolean | Timestamp.equals(Timestamp ts) 测试此 Timestamp 对象是否等于给定的 Timestamp 对象。
void | PreparedStatement.setTimestamp(int parameterIndex, Timestamp x) 将指定参数设置为给定 java.sql.Timestamp 值。
void | PreparedStatement.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | CallableStatement.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定 java.sql.Timestamp 值。
void | CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | ResultSet.updateTimestamp(int columnIndex, Timestamp x) 用 java.sql.Timestamp 值更新指定列。
void | ResultSet.updateTimestamp(String columnLabel, Timestamp x) 用 java.sql.Timestamp 值更新指定列。
void | SQLOutput.writeTimestamp(Timestamp x) 将下一个属性作为 java.sql.Timestamp 对象写入流中。

javax.sql 中 Timestamp 的使用

参数类型为 Timestamp 的 javax.sql 中的方法
void | RowSet.setTimestamp(int parameterIndex, Timestamp x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.sql.rowset 中 Timestamp 的使用

参数类型为 Timestamp 的 javax.sql.rowset 中的方法
void | BaseRowSet.setTimestamp(int parameterIndex, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | BaseRowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 将指定参数设置为给定的 java.sql.Timestamp 对象。
void | BaseRowSet.setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.sql.rowset.serial 中 Timestamp 的使用

返回 Timestamp 的 javax.sql.rowset.serial 中的方法
 Timestamp SQLInputImpl.readTimestamp()
以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。

参数类型为 Timestamp 的 javax.sql.rowset.serial 中的方法
 void SQLOutputImpl.writeTimestamp(Timestamp x)
将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.sql.Types 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.sql.Types
的使用

没有 java.sql.Types 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.sql.Wrapper 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.sql.Wrapper
的使用

使用 Wrapper 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.sql 中 Wrapper 的使用

java.sql 中 Wrapper 的子接口
interface | CallableStatement 用于执行 SQL 存储过程的接口。
interface | Connection 与特定数据库的连接（会话）。
interface | DatabaseMetaData 关于数据库的整体综合信息。
interface | ParameterMetaData 可用于获取关于 PreparedStatement 对象中每个参数标记的类型和属性信息的对象。
interface | PreparedStatement 表示预编译的 SQL 语句的对象。
interface | ResultSet 表示数据库结果集的数据表，通常通过执行查询数据库的语句生成。
interface | ResultSetMetaData 可用于获取关于 ResultSet 对象中列的类型和属性信息的对象。
interface | Statement 用于执行静态 SQL 语句并返回它所生成结果的对象。

javax.sql 中 Wrapper 的使用

javax.sql 中 Wrapper 的子接口
interface | DataSource 该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。
interface | RowSet 该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
interface | RowSetMetaData 该对象包含关于 RowSet 对象的列的信息。

javax.sql.rowset 中 Wrapper 的使用

javax.sql.rowset 中 Wrapper 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

实现 Wrapper 的 javax.sql.rowset 中的类
 class RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

javax.sql.rowset.spi 中 Wrapper 的使用

javax.sql.rowset.spi 中 Wrapper 的子接口
 interface SyncResolver
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Annotation (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.text
类 Annotation

java.lang.Object
    继承者  java.text.Annotation

public class Annotation
extends Object

如果文本属性具有 annotation 特征，则 Annotation 对象用作文本属性值的包装器。这些特征是：

  • 属性所应用的文本范围对范围语义至关重要。这意味着，属性不能应用于其所应用的文本范围的子范围，并且，如果两个相邻的文本范围针对此属性具有相同的值，此属性也不能将此值应用于整体的复合范围。
  • 当底层文本改变时，属性或其值通常不再适用。
一个例子是与句子相关联的语法信息：在上面的句子中，您可以说“一个例子”是主语，但您不能说“一个”、“例子”或者“一个例”也是。当文本改变时，语法信息通常变成无效的了。另一个例子是日语阅读信息 (yomi)。

将属性值包装在一个 Annotation 对象中保证了既使属性值相等，相邻的文本不会合并，并且指示文本容器如果属性值下面的文本修改了，则应该丢弃属性。

从以下版本开始：
1.2
另请参见：
AttributedCharacterIterator

构造方法摘要
Annotation(Object value)
构造一条具有给定值（可能为 null）的 annotation 记录。
方法摘要
Object | getValue() 返回属性值，可能为 null。
String | toString() 返回此 Annotation 的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Annotation

public Annotation(Object value)
构造一条具有给定值（可能为 null）的 annotation 记录。

参数：
value - 属性值。
方法详细信息

getValue

public Object getValue()
返回属性值，可能为 null。

toString

public String toString()
返回此 Annotation 的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AttributedCharacterIterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
接口 AttributedCharacterIterator

所有超级接口：
CharacterIterator, Cloneable
public interface AttributedCharacterIterator
extends CharacterIterator

AttributedCharacterIterator 允许对文本和相关属性信息的迭代。

属性是一个由键来标识的键/值对。在一个给定字符上的两个属性不能有相同的键。

一个属性的值是不可变的，或者不能由客户端或存储来改变。其始终按引用而不是复制来传递。

对于以下情况，关于属性的运行 是一个最大的文本范围：

  • 在整个范围中属性没有定义或为 null，或者
  • 定义了属性值并且在整个范围中具有同样的非 null 值。

对于每个成员属性都满足此条件的关于属性集合的运行 是一个最大的文本范围。

返回的索引限定于迭代器的范围之内。

返回的属性信息限定于包含当前字符的运行中。

属性键是 AttributedCharacterIterator.Attribute 及其子类的实例，比如 java.awt.font.TextAttribute。

从以下版本开始：
1.2
另请参见：
AttributedCharacterIterator.Attribute。, java.awt.font.TextAttribute。, AttributedString。, Annotation。

嵌套类摘要
static class AttributedCharacterIterator.Attribute
定义用于标识文本属性的属性键。
字段摘要
从接口 java.text.CharacterIterator 继承的字段
DONE
方法摘要
Set<AttributedCharacterIterator.Attribute> | getAllAttributeKeys() 返回定义于迭代器文本范围上的所有属性的键。
Object | getAttribute(AttributedCharacterIterator.Attribute attribute) 返回当前字符的命名属性的值。
Map<AttributedCharacterIterator.Attribute,Object> | getAttributes() 返回具有定义于当前字符上的多个属性的映射。
int | getRunLimit() 返回关于包含当前字符的所有属性的运行之后的第一个字符的索引。
int | getRunLimit(AttributedCharacterIterator.Attribute attribute) 返回关于包含当前字符的给定属性的运行之后的第一个字符的索引。
int | getRunLimit(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。
int | getRunStart() 返回关于包含当前字符的所有属性的运行的第一个字符的索引。
int | getRunStart(AttributedCharacterIterator.Attribute attribute) 返回关于包含当前字符的给定属性的运行的第一个字符的索引。
int | getRunStart(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。
从接口 java.text.CharacterIterator 继承的方法
clone, current, first, getBeginIndex, getEndIndex, getIndex, last, next, previous, setIndex

方法详细信息

getRunStart

int getRunStart()
返回关于包含当前字符的所有属性的运行的第一个字符的索引。

getRunStart

int getRunStart(AttributedCharacterIterator.Attribute attribute)
返回关于包含当前字符的给定属性的运行的第一个字符的索引。

getRunStart

int getRunStart(Set<? extends AttributedCharacterIterator.Attribute> attributes)
返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。

getRunLimit

int getRunLimit()
返回关于包含当前字符的所有属性的运行之后的第一个字符的索引。

getRunLimit

int getRunLimit(AttributedCharacterIterator.Attribute attribute)
返回关于包含当前字符的给定属性的运行之后的第一个字符的索引。

getRunLimit

int getRunLimit(Set<? extends AttributedCharacterIterator.Attribute> attributes)
返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。

getAttributes

Map<AttributedCharacterIterator.Attribute,Object> getAttributes()
返回具有定义于当前字符上的多个属性的映射。

getAttribute

Object getAttribute(AttributedCharacterIterator.Attribute attribute)
返回当前字符的命名属性的值。Returns 如果属性未定义，则返回 null。

参数：
attribute - 其值被请求的属性的键。

getAllAttributeKeys

Set<AttributedCharacterIterator.Attribute> getAllAttributeKeys()
返回定义于迭代器文本范围上的所有属性的键。如果未定义任何属性，则集合为空。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributedCharacterIterator.Attribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 AttributedCharacterIterator.Attribute

java.lang.Object
    继承者  java.text.AttributedCharacterIterator.Attribute
所有已实现的接口：
Serializable
直接已知子类：
Format.Field, TextAttribute
正在封闭接口：
AttributedCharacterIterator
public static class AttributedCharacterIterator.Attribute
extends Object
implements Serializable

定义用于标识文本属性的属性键。这些键用于 AttributedCharacterIterator 和 AttributedString 中。

从以下版本开始：
1.2
另请参见：
AttributedCharacterIterator, AttributedString, 序列化表格

字段摘要
static AttributedCharacterIterator.Attribute | INPUT_METHOD_SEGMENT 输入法段的属性键。
static AttributedCharacterIterator.Attribute | LANGUAGE 某些文本的语言的属性键。
static AttributedCharacterIterator.Attribute | READING 某些文本的读法的属性键。
构造方法摘要
protected AttributedCharacterIterator.Attribute(String name)
构造具有给定名称的 Attribute。
方法摘要
boolean | equals(Object obj) 比较两个对象的相等性。
protected String | getName() 返回此属性的名称。
int | hashCode() 返回此对象的哈希码值。
protected Object | readResolve() 解析将被反序列化为预定义常量的实例。
String | toString() 返回该对象的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

LANGUAGE

public static final AttributedCharacterIterator.Attribute LANGUAGE
某些文本的语言的属性键。

值是 Locale 的实例。

另请参见：
Locale

READING

public static final AttributedCharacterIterator.Attribute READING
某些文本的读法的属性键。在某些书写形式与单词发音仅仅松散关联的语言（比如日语）中，将读法（发音）与书写形式保存在一起也往往是必要的。

值是保存 String 实例的 Annotation 的实例。

另请参见：
Annotation, String

INPUT_METHOD_SEGMENT

public static final AttributedCharacterIterator.Attribute INPUT_METHOD_SEGMENT
输入法段的属性键。通常与单词对应，输入法经常把文本分解成段。

值是保存 null 引用的 Annotation 的实例。

另请参见：
Annotation
构造方法详细信息

AttributedCharacterIterator.Attribute

protected AttributedCharacterIterator.Attribute(String name)
构造具有给定名称的 Attribute。

方法详细信息

equals

public final boolean equals(Object obj)
比较两个对象的相等性。此版本仅当 x.equals(y)（即 x 和 y 引用同一个对象并且保证其子类也这样）时返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
返回此对象的哈希码值。此版本与 Object 中的哈希码相同，但也是 final 类型的。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回该对象的字符串表示形式。此版本返回类名、"("、标识属性的名称和 ")" 连接成的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getName

protected String getName()
返回此属性的名称。

readResolve

protected Object readResolve()
                      throws InvalidObjectException
解析将被反序列化为预定义常量的实例。

抛出：
InvalidObjectException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributedString (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 AttributedString

java.lang.Object
    继承者  java.text.AttributedString

public class AttributedString
extends Object

AttributedString 保存文本及相关属性信息。在文本 reader 希望通过 AttributedCharacterIterator 接口访问属性文本的情况下，它可用于存储实际数据。

属性是一个键/值对，由键来标识。给定字符上的两个属性不能有相同的键。

属性的值是不变的，或者必须由客户端或存储来更换。它们始终由引用来传递，但是不进行复制。

从以下版本开始：
1.2
另请参见：
AttributedCharacterIterator, Annotation

构造方法摘要
AttributedString(AttributedCharacterIterator text)
构造带有 AttributedCharacterIterator 表示的给定属性文本的 AttributedString。
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex)
构造带有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributedString(String text)
构造带给定文本的 AttributedString 实例。
AttributedString(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。
方法摘要
void | addAttribute(AttributedCharacterIterator.Attribute attribute, Object value) 将一个属性添加到整个字符串中。
void | addAttribute(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex) 将一个属性添加到字符串的子范围。
void | addAttributes(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex) 将属性集添加到字符串的子范围。
AttributedCharacterIterator | getIterator() 创建一个 AttributedCharacterIterator 实例，提供对整个字符串内容的访问。
AttributedCharacterIterator | getIterator(AttributedCharacterIterator.Attribute[] attributes) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
AttributedCharacterIterator | getIterator(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AttributedString

public AttributedString(String text)
构造带给定文本的 AttributedString 实例。

参数：
text - 此属性字符串的文本。
抛出：
NullPointerException - 如果 text 为 null。

AttributedString

public AttributedString(String text,
                        Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。

参数：
text - 此属性字符串的文本。
attributes - 应用于整个字符串的属性。
抛出：
NullPointerException - 如果 text 或 attributes 为 null。
IllegalArgumentException - 如果文本长度为 0 且属性参数不是一个空 Map（属性不能应用于 0 长度范围文本）。

AttributedString

public AttributedString(AttributedCharacterIterator text)
构造带有 AttributedCharacterIterator 表示的给定属性文本的 AttributedString。

参数：
text - 此属性字符串的文本。
抛出：
NullPointerException - 如果 text 为 null。

AttributedString

public AttributedString(AttributedCharacterIterator text,
                        int beginIndex,
                        int endIndex)
构造带有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。如果给定的范围产生一个空文本，所有的属性将被丢弃。注意，对于初始属性范围的子范围，Annotation 对象包装的任何属性都被丢弃。

参数：
text - 此属性字符串的文本。
beginIndex - 该范围的第一个字符的索引。
endIndex - 范围最后一个字符之后紧邻字符的索引。
抛出：
NullPointerException - 如果 text 为 null。
IllegalArgumentException - 如果 beginIndex 和 endIndex 给出的子范围超出文本范围。
另请参见：
Annotation

AttributedString

public AttributedString(AttributedCharacterIterator text,
                        int beginIndex,
                        int endIndex,
                        AttributedCharacterIterator.Attribute[] attributes)
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。只有属性与给定的属性匹配时才被合并进该实例。如果指定的范围产生一个空文本，所有的属性将被丢弃。注意，对于初始属性范围的子范围，Annotation 对象包装的任何属性都被丢弃。

参数：
text - 此属性字符串的文本。
beginIndex - 该范围的第一个字符的索引。
endIndex - 范围最后一个字符之后紧邻字符的索引。
attributes - 指定要从文本中提取出来的属性。如果指定为 null，则用到所有可用属性。
抛出：
NullPointerException - 如果 text 或 attributes 为 null。
IllegalArgumentException - 如果 beginIndex 和 endIndex 给出的子范围超出文本范围。
另请参见：
Annotation
方法详细信息

addAttribute

public void addAttribute(AttributedCharacterIterator.Attribute attribute,
                         Object value)
将一个属性添加到整个字符串中。

参数：
attribute - 属性键
value - 属性值；可以为 null
抛出：
NullPointerException - 如果 attribute 为 null。
IllegalArgumentException - 如果 AttributedString 长度为 0（属性不能应用于 0 长度范围文本）。

addAttribute

public void addAttribute(AttributedCharacterIterator.Attribute attribute,
                         Object value,
                         int beginIndex,
                         int endIndex)
将一个属性添加到字符串的子范围。

参数：
attribute - 属性键
value - 属性值。可以为 null。
beginIndex - 该范围的第一个字符的索引。
endIndex - 范围最后一个字符之后紧邻字符的索引。
抛出：
NullPointerException - 如果 attribute 为 null。
IllegalArgumentException - 如果 beginIndex 小于 0，endIndex 大于字符串的长度，或者 beginIndex 和 endIndex 一起未定义字符串的非空子范围。

addAttributes

public void addAttributes(Map<? extends AttributedCharacterIterator.Attribute,?> attributes,
                          int beginIndex,
                          int endIndex)
将属性集添加到字符串的子范围。

参数：
attributes - 要添加到字符串的属性。
beginIndex - 该范围的第一个字符的索引。
endIndex - 范围最后一个字符之后紧邻字符的索引。
抛出：
NullPointerException - 如果 attribute 为 null。
IllegalArgumentException - 如果 beginIndex 小于 0，endIndex 大于字符串的长度，或者 beginIndex 和 endIndex 一起未定义字符串的非空子范围，且属性参数不是一个空 Map。

getIterator

public AttributedCharacterIterator getIterator()
创建一个 AttributedCharacterIterator 实例，提供对整个字符串内容的访问。

返回：
提供访问文本及其属性的迭代器。

getIterator

public AttributedCharacterIterator getIterator(AttributedCharacterIterator.Attribute[] attributes)
创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。实现者不必让没有列于属性中的属性信息通过迭代器可访问。如果列表为 null，则应该让所有可用的属性信息都可访问。

参数：
attributes - 客户端感兴趣的属性列表
返回：
提供访问整个文本及其选定属性的迭代器

getIterator

public AttributedCharacterIterator getIterator(AttributedCharacterIterator.Attribute[] attributes,
                                               int beginIndex,
                                               int endIndex)
创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。实现者不必让没有列于属性中的属性信息通过迭代器可访问。如果列表为 null，则应该让所有可用的属性信息都可访问。

参数：
attributes - 客户端感兴趣的属性列表
beginIndex - 第一个字符的索引
endIndex - 最后一个字符之后紧邻字符的索引
返回：
提供访问文本及其属性的迭代器
抛出：
IllegalArgumentException - 如果 beginIndex 小于 0，endIndex 大于字符串的长度，或者 beginIndex 大于 endIndex。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Bidi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 Bidi

java.lang.Object
    继承者  java.text.Bidi

public final class Bidi
extends Object

此类实现了 Unicode 双向算法 (Unicode Bidirectional Algorithm)。

Bidi 对象提供了有关用于创建它的文本的双向重排序的信息。例如，这对于正确显示阿拉伯语或者希伯来语文本来说是必需的。这些语言本来是混合方向的，因为其从左向右排列数字，而大多数其他文本则从右向左排列。

一旦创建完成，Bidi 对象就能查询，以查看文本表示都是从左向右或从右向左。这些对象都是非常轻量级的并且此文本也相对容易处理。

如果有多次文本的运行，则可以通过索引访问运行的信息，以获得起始位置、限制和运行层次。层次代表了方向和一个方向运行的“嵌套层次”。奇数层次是从右到左，则偶数层次是从左到右。因此，例如层次 0 代表从左到右的文本，而层次 1 代表从右到左的文本，层次 2 代表嵌入在一个从右到左的运行中的从左到右的文本。

从以下版本开始：
1.4

字段摘要
static int | DIRECTION_DEFAULT_LEFT_TO_RIGHT 表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。
static int | DIRECTION_DEFAULT_RIGHT_TO_LEFT 表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。
static int | DIRECTION_LEFT_TO_RIGHT 表示基本方向是从左到右的常量。
static int | DIRECTION_RIGHT_TO_LEFT 表示基本方向是从右到左的常量。
构造方法摘要
Bidi(AttributedCharacterIterator paragraph)
由给定的文本段构造 Bidi。
Bidi(char[] text, int textStart, byte[] embeddings, int embStart, int paragraphLength, int flags)
由给定的文本、嵌入和方向信息构造 Bidi。
Bidi(String paragraph, int flags)
由给定的文本段和基本方向构造 Bidi。
方法摘要
boolean | baseIsLeftToRight() 如果基本方向是从左到右，则返回 true。
Bidi | createLineBidi(int lineStart, int lineLimit) 构造一个 Bidi 对象，表示当前 Bidi 所代表的段落中的一行文本上的双向信息。
int | getBaseLevel() 返回基本层次（如果是从左到右，则为 0；如果是从右到左，则为 1）。
int | getLength() 返回该行中文本的长度。
int | getLevelAt(int offset) 返回偏移位置处的字符的解析层次。
int | getRunCount() 返回层次运行的数目。
int | getRunLevel(int run) 返回该行中第 n 次逻辑运行的层次。
int | getRunLimit(int run) 以该行开始的偏移量返回该行中第 n 次逻辑运行之后的字符索引。
int | getRunStart(int run) 以该行开始的偏移量返回该行中第 n 次逻辑运行开始时的字符索引。
boolean | isLeftToRight() 如果该行都是从左到右的文本且基本方向也是从左到右，则返回 true。
boolean | isMixed() 如果该行既不是从左到右也不是从右到左，则返回 true。
boolean | isRightToLeft() 如果该行都是从右到左的文本且基本方向也是从右到左，则返回 true。
static void | reorderVisually(byte[] levels, int levelStart, Object[] objects, int objectStart, int count) 根据对象的层次，在数组中将对象重新排序为可视顺序。
static boolean | requiresBidi(char[] text, int start, int limit) 如果指定的文本需要双向解析，则返回 true。
String | toString() 用于调试时显示双向算法的内部状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DIRECTION_LEFT_TO_RIGHT

public static final int DIRECTION_LEFT_TO_RIGHT
表示基本方向是从左到右的常量。

另请参见：
常量字段值

DIRECTION_RIGHT_TO_LEFT

public static final int DIRECTION_RIGHT_TO_LEFT
表示基本方向是从右到左的常量。

另请参见：
常量字段值

DIRECTION_DEFAULT_LEFT_TO_RIGHT

public static final int DIRECTION_DEFAULT_LEFT_TO_RIGHT
表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。如果没有强方向字符，则基本方向是从左到右。

另请参见：
常量字段值

DIRECTION_DEFAULT_RIGHT_TO_LEFT

public static final int DIRECTION_DEFAULT_RIGHT_TO_LEFT
表示基本方向依赖于根据 Unicode 双向算法得到的文本中第一个强方向字符的常量。如果没有强方向字符，则基本方向是从右到左。

另请参见：
常量字段值
构造方法详细信息

Bidi

public Bidi(String paragraph,
            int flags)
由给定的文本段和基本方向构造 Bidi。

参数：
paragraph - 一个文本段
flags - 控制算法的标志集合。此算法识别标志 DIRECTION_LEFT_TO_RIGHT、DIRECTION_RIGHT_TO_LEFT、DIRECTION_DEFAULT_LEFT_TO_RIGHT 以及 DIRECTION_DEFAULT_RIGHT_TO_LEFT。其他值保留。

Bidi

public Bidi(AttributedCharacterIterator paragraph)
由给定的文本段构造 Bidi。

文本中 RUN_DIRECTION 属性（如果存在）定义了基本方向（从左到右或者从右到左）。如果不存在，使用 Unicode 双向算法计算基本方向，默认为如果文本中没有强方向字符则从左到右。此属性（如果存在）必须应用于段中所有文本。

文本中 BIDI_EMBEDDING 属性（如果存在）代表了嵌入层次信息。从 -1 到 -62 的负值指示重写层次的绝对值。从 1 到 62 的正值指示嵌入。如果值为 0 或者没有定义，则基本的嵌入层次由假定的基本方向来决定。

文本中的 NUMERIC_SHAPING 属性（如果存在）在运行双向算法之前将欧洲数字转换成其他十进制数字。此属性（如果存在）必须应用于段中所有文本。

参数：
paragraph - 具有可选的字符和段落属性信息的文本段。
另请参见：
TextAttribute.BIDI_EMBEDDING, TextAttribute.NUMERIC_SHAPING, TextAttribute.RUN_DIRECTION

Bidi

public Bidi(char[] text,
            int textStart,
            byte[] embeddings,
            int embStart,
            int paragraphLength,
            int flags)
由给定的文本、嵌入和方向信息构造 Bidi。Embeddings 数组可以为 null。如果有的话，其值代表了嵌入层次信息。从 -1 到 -61 的负值指示重写层次的绝对值。从 1 到 61 的正值指示嵌入。如果值为 0，则基本的嵌入层次由假定的基本方向来决定。

参数：
text - 包含了要处理的文本段的一个数组。
textStart - 段落开始的文本数组中的索引。
embeddings - 包含了段落中每个字符的嵌入值的一个数组。在假定不存在外部嵌入信息的情况下可能为空。
embStart - 段落开始的嵌入数组中的索引。
paragraphLength - 在文本和嵌入数组中的段落长度。
flags - 控制算法的标志集合。此算法识别标志 DIRECTION_LEFT_TO_RIGHT、DIRECTION_RIGHT_TO_LEFT、DIRECTION_DEFAULT_LEFT_TO_RIGHT 和 DIRECTION_DEFAULT_RIGHT_TO_LEFT。其他值保留。
方法详细信息

createLineBidi

public Bidi createLineBidi(int lineStart,
                           int lineLimit)
构造一个 Bidi 对象，表示当前 Bidi 所代表的段落中的一行文本上的双向信息。如果整个段落装配在一行中则不需要此调用。

参数：
lineStart - 从段的开始到行的开始的偏移量。
lineLimit - 从段的开始到行的限制的偏移量。

isMixed

public boolean isMixed()
如果该行既不是从左到右也不是从右到左，则返回 true。这意味着它具有从左到右和从右到左文本的混合运行，或者基本方向与文本单运行的方向不同。

返回：
如果该行既不是从左到右也不是从右到左，则返回 true。

isLeftToRight

public boolean isLeftToRight()
如果该行都是从左到右的文本且基本方向也是从左到右，则返回 true。

返回：
如果该行都是从左到右的文本且基本方向也是从左到右，则返回 true

isRightToLeft

public boolean isRightToLeft()
如果该行都是从右到左的文本且基本方向也是从右到左，则返回 true。

返回：
如果该行都是从右到左的文本且基本方向也是从右到左，则返回 true

getLength

public int getLength()
返回该行中文本的长度。

返回：
该行中文本的长度

baseIsLeftToRight

public boolean baseIsLeftToRight()
如果基本方向是从左到右，则返回 true。

返回：
如果基本方向是从左到右，则返回 true

getBaseLevel

public int getBaseLevel()
返回基本层次（如果是从左到右，则为 0；如果是从右到左，则为 1）。

返回：
基本层次

getLevelAt

public int getLevelAt(int offset)
返回偏移位置处的字符的解析层次。如果偏移量小于 0 或者大于等于行的长度，则返回基本的方向层次。

参数：
offset - 返回层次的字符的索引
返回：
偏移位置处的字符的解析层次

getRunCount

public int getRunCount()
返回层次运行的数目。

返回：
层次运行的数目

getRunLevel

public int getRunLevel(int run)
返回该行中第 n 次逻辑运行的层次。

参数：
run - 运行的索引，在 0 到 getRunCount() 之间
返回：
运行层次

getRunStart

public int getRunStart(int run)
以该行开始的偏移量返回该行中第 n 次逻辑运行开始时的字符索引。

参数：
run - 运行的索引，在 0 到 getRunCount() 之间
返回：
运行的开始位置

getRunLimit

public int getRunLimit(int run)
以该行开始的偏移量返回该行中第 n 次逻辑运行之后的字符索引。例如，这将返回该行上最后一次运行的行的长度。

参数：
run - 运行的索引，在 0 到 getRunCount() 之间
返回：
运行的限制

requiresBidi

public static boolean requiresBidi(char[] text,
                                   int start,
                                   int limit)
如果指定的文本需要双向解析，则返回 true。如果返回 false，该文本将从左到右显示。客户端可以避免构造一个 Bidi 对象。Unicode 的 Arabic Presentation Forms 区域的文本假定为已经针对显示进行整形和排序，因此不会导致此函数返回 true。

参数：
text - 包含测试字符的文本
start - 测试字符的范围的开始
limit - 测试字符的范围的限制
返回：
如果该字符范围需要双向解析，则返回 true

reorderVisually

public static void reorderVisually(byte[] levels,
                                   int levelStart,
                                   Object[] objects,
                                   int objectStart,
                                   int count)
根据对象的层次，在数组中将对象重新排序为可视顺序。当您有一个以逻辑顺序表示文本运行的对象集合时（其中每个运行包含同一个层次上的文本），这是一个可用的实用工具函数。假定每一个文本运行具有层次数组中相应的元素（位于 index - objectStart + levelStart）所指示的层次时，对象数组中位于 index 的元素从 objectStart 一直到 objectStart + count 将被重新排序为可视顺序。

参数：
levels - 表示每一个对象双向层次的数组
levelStart - 层次数组中的开始位置
objects - 将被重新排序为可视顺序的对象数组
objectStart - 对象数组中的开始位置
count - 要重新排序的对象数

toString

public String toString()
用于调试时显示双向算法的内部状态。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BreakIterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 BreakIterator

java.lang.Object
    继承者  java.text.BreakIterator
所有已实现的接口：
Cloneable
public abstract class BreakIterator
extends Object
implements Cloneable

BreakIterator 类实现用于查找文本中边界位置的方法。BreakIterator 的实例维护一个当前位置并扫描文本，同时返回边界出现处的字符索引。在内部，BreakIterator 使用 CharacterIterator 扫描文本，因此能扫描实现该协议的任何对象所保存的文本。StringCharacterIterator 用于扫描传递给 setText 的 String 对象。

可以用此类提供的工厂方法创建不同类型的分解迭代器实例。具体来说，可以使用 getWordIterator、getLineIterator、getSentenceIterator 和 getCharacterIterator 分别创建执行单词、行、句子和字符边界分析的 BreakIterator。一个 BreakIterator 只能在一个单元（单词、行、句子等）上工作。对于希望执行的每个单元边界分析，必须使用不同的迭代器。

行边界分析决定了文本字符串换行时如何分解。这种机制能正确处理标点符号和带连字符的单词。实际的行分解还需要考虑可用的行宽，是通过较高级别的软件处理的。

句子边界分析使选中内容能正确解释数字和缩写中的句点，以及结尾的标点符号，如引号和圆括号。

单词边界分析用于搜索和替换功能，以及允许用户使用鼠标双击选择单词的文本编辑应用程序。单词选择能正确地解释单词内及单词后的标点符号。符号或者标点符号之类不属于单词的字符在其两端都会分解。

字符边界分析允许用户以期望的方式与字符交互，比如，将光标移过一个文本字符串。字符边界分析提供通过字符串的正确导航，而无需考虑字符如何存储。返回的边界可能是增补字符的边界，由字符序列或连字集群组成。例如，一个强调字符可能存储为一个基本字符和一个可区别的标记。被用户视为字符的内容随语言不同而不同。

由此类的工厂方法返回的 BreakIterator 实例只用于自然语言，不用于编程语言文本。不过，可以定义标记某种编程语言的子类。

示例：

创建并使用文本边界：

 public static void main(String args[]) {
      if (args.length == 1) {
          String stringToExamine = args[0];
          //print each word in order
          BreakIterator boundary = BreakIterator.getWordInstance();
          boundary.setText(stringToExamine);
          printEachForward(boundary, stringToExamine);
          //print each sentence in reverse order
          boundary = BreakIterator.getSentenceInstance(Locale.US);
          boundary.setText(stringToExamine);
          printEachBackward(boundary, stringToExamine);
          printFirst(boundary, stringToExamine);
          printLast(boundary, stringToExamine);
      }
 }
按顺序打印每个元素：
 public static void printEachForward(BreakIterator boundary, String source) {
     int start = boundary.first();
     for (int end = boundary.next();
          end != BreakIterator.DONE;
          start = end, end = boundary.next()) {
          System.out.println(source.substring(start,end));
     }
 }
按逆序打印每个元素：
 public static void printEachBackward(BreakIterator boundary, String source) {
     int end = boundary.last();
     for (int start = boundary.previous();
          start != BreakIterator.DONE;
          end = start, start = boundary.previous()) {
         System.out.println(source.substring(start,end));
     }
 }
打印第一个元素：
 public static void printFirst(BreakIterator boundary, String source) {
     int start = boundary.first();
     int end = boundary.next();
     System.out.println(source.substring(start,end));
 }
打印最后一个元素：
 public static void printLast(BreakIterator boundary, String source) {
     int end = boundary.last();
     int start = boundary.previous();
     System.out.println(source.substring(start,end));
 }
打印指定位置的元素：
 public static void printAt(BreakIterator boundary, int pos, String source) {
     int end = boundary.following(pos);
     int start = boundary.previous();
     System.out.println(source.substring(start,end));
 }
查找下一个单词：
 public static int nextWordStartAfter(int pos, String text) {
     BreakIterator wb = BreakIterator.getWordInstance();
     wb.setText(text);
     int last = wb.following(pos);
     int current = wb.next();
     while (current != BreakIterator.DONE) {
         for (int p = last; p < current; p++) {
             if (Character.isLetter(text.codePointAt(p)))
                 return last;
         }
         last = current;
         current = wb.next();
     }
     return BreakIterator.DONE;
 }
（BreakIterator.getWordInstance() 返回的迭代器是唯一的，因为它所返回的分解位置不表示迭代内容的开始和结束。也就是说，一个句子分解迭代器返回的每一个分解表示一个句子的结束和下一个句子的开始。使用单词分解迭代器，两个边界之间的字符可能是一个单词，也可能是两个单词之间的标点符号或空格。以上代码使用一个简单的示例来确定哪一个边界是单词的开始：如果此边界和下一边界之间的字符至少包含了一个字母（可以是字母表中的字母、中日韩 (CJK) 表意字符、韩文音节、日语假名字符等等），那么此边界和下一边界之间的文本就是一个单词；否则，它就是单词之间的内容。）

另请参见：
CharacterIterator

字段摘要
static int DONE
在已经到达第一个或最后一个文本边界时，previous()、next()、next(int)、preceding(int) 和 following(int) 将返回 DONE。
构造方法摘要
protected BreakIterator()
构造方法。
方法摘要
 Object clone()
创建此迭代器的副本。
abstract  int current()
返回最近由 next()、next(int)、previous()、first()、last()、following(int) 或 preceding(int) 返回的文本边界的字符索引。
abstract  int first()
返回第一个边界。
abstract  int following(int offset)
返回指定字符偏移量后面的第一个边界。
static Locale[] getAvailableLocales()
返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
static BreakIterator getCharacterInstance()
返回一个用于默认语言环境 字符分解的新 BreakIterator 实例。
static BreakIterator getCharacterInstance(Locale locale)
返回一个用于给定语言环境字符分解的新 BreakIterator 实例。
static BreakIterator getLineInstance()
返回一个用于默认语言环境 行分解的新 BreakIterator 实例。
static BreakIterator getLineInstance(Locale locale)
返回一个用于给定语言环境行分解的新 BreakIterator 实例。
static BreakIterator getSentenceInstance()
返回一个用于默认语言环境 句子分解的新 BreakIterator 实例。
static BreakIterator getSentenceInstance(Locale locale)
返回一个用于给定语言环境句子分解的新 BreakIterator 实例。
abstract  CharacterIterator getText()
获取被扫描的文本
static BreakIterator getWordInstance()
返回一个用于默认语言环境 单词分解的新 BreakIterator 实例。
static BreakIterator getWordInstance(Locale locale)
返回一个用于给定语言环境单词分解的新 BreakIterator 实例。
 boolean isBoundary(int offset)
如果指定字符偏移量是一个文本边界，则返回 true。
abstract  int last()
返回最后一个边界。
abstract  int next()
返回当前边界的后一个边界。
abstract  int next(int n)
返回从当前边界起第 n 个边界。
 int preceding(int offset)
返回指定字符偏移量前面的最后一个边界。
abstract  int previous()
返回当前边界的前一个边界。
abstract  void setText(CharacterIterator newText)
设置一个新文本用于扫描。
 void setText(String newText)
设置要被扫描的新文本字符串。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DONE

public static final int DONE
在已经到达第一个或最后一个文本边界时，previous()、next()、next(int)、preceding(int) 和 following(int) 将返回 DONE。

另请参见：
常量字段值
构造方法详细信息

BreakIterator

protected BreakIterator()
构造方法。BreakIterator 是无状态的并且没有任何默认行为。

方法详细信息

clone

public Object clone()
创建此迭代器的副本。

覆盖：
类 Object 中的 clone
返回：
此迭代器的副本。
另请参见：
Cloneable

first

public abstract int first()
返回第一个边界。迭代器的当前位置被设置为第一个文本边界。

返回：
第一个文本边界的字符索引。

last

public abstract int last()
返回最后一个边界。迭代器的当前位置被设置为最后一个文本边界。

返回：
最后一个文本边界的字符索引。

next

public abstract int next(int n)
返回从当前边界起第 n 个边界。如果已经到达第一个或最后一个文本边界，则返回 BreakIterator.DONE，当前位置被设置为第一个文本边界或最后一个文本边界，具体取决于所到达的边界。否则，迭代器的当前位置被设置为新边界。例如，如果迭代器的当前位置是第 m 个文本边界，并且从当前文本边界到最后一个文本边界之间还有三个边界，则 next(2) 调用将返回 m + 2。新文本位置被设置为第 (m + 2) 个文本边界。next(4) 调用将返回 BreakIterator.DONE，而最后一个文本边界将成为新的文本位置。

参数：
n - 要返回的边界。0 值表示不执行任何操作。负值移向前面的边界，正值移向后面的边界。
返回：
从当前位置起第 n 个边界的字符索引；如果已经到达第一个或最后一个文本边界，则返回 BreakIterator.DONE。

next

public abstract int next()
返回当前边界的后一个边界。如果当前边界是最后一个文本边界，则返回 BreakIterator.DONE，迭代器的当前位置不变。否则，迭代器的当前位置被设置为当前边界的后一个边界。

返回：
下一个文本边界的字符索引；如果当前边界是最后一个文本边界，则返回 BreakIterator.DONE。等效于 next(1)。
另请参见：
next(int)

previous

public abstract int previous()
返回当前边界的前一个边界。如果当前边界是第一个文本边界，则返回 BreakIterator.DONE，迭代器的当前位置不变。否则，迭代器的当前位置被设置为当前边界的前一个边界。

返回：
前一个文本边界的字符索引；如果当前边界是第一个文本边界，则返回 BreakIterator.DONE。

following

public abstract int following(int offset)
返回指定字符偏移量后面的第一个边界。如果指定偏移量等于最后一个文本边界，则返回 BreakIterator.DONE，迭代器的当前位置不变。否则，迭代器的当前位置被设置为返回的边界。返回的值总是大于 offset，或者为值 BreakIterator.DONE。

参数：
offset - 开始进行扫描的字符偏移量。
返回：
指定偏移量之后的第一个边界；如果传入最后一个文本边界作为偏移量，则返回 BreakIterator.DONE。
抛出：
IllegalArgumentException - 如果指定偏移量小于第一个文本边界或者大于最后一个文本边界。

preceding

public int preceding(int offset)
返回指定字符偏移量前面的最后一个边界。如果指定偏移量等于第一个文本边界，则返回 BreakIterator.DONE，迭代器的当前位置不变。否则，迭代器的当前位置被设置为返回的边界。返回的值总是小于 offset，或者为值 BreakIterator.DONE。

参数：
offset - 开始进行扫描的字符偏移量。
返回：
指定偏移量之前的最后一个边界；如果传入第一个文本边界作为偏移量，则返回 BreakIterator.DONE。
抛出：
IllegalArgumentException - 如果指定偏移量小于第一个文本边界或者大于最后一个文本边界。
从以下版本开始：
1.2

isBoundary

public boolean isBoundary(int offset)
如果指定字符偏移量是一个文本边界，则返回 true。

参数：
offset - 要检查的字符偏移量。
返回：
如果 "offset" 是一个边界位置，则返回 true；否则返回 false。
从以下版本开始：
1.2

current

public abstract int current()
返回最近由 next()、next(int)、previous()、first()、last()、following(int) 或 preceding(int) 返回的文本边界的字符索引。如果这些方法因为到达第一个或最后一个文本边界而返回 BreakIterator.DONE，则返回第一个或最后一个文本边界，具体取决于到达的是哪一个边界。

返回：
从上述方法返回的文本边界，即第一个或最后一个文本边界。 text boundary.
另请参见：
next(),
next(int),
previous(),
first(),
last(),
following(int),
preceding(int)

getText

public abstract CharacterIterator getText()
获取被扫描的文本

返回：
被扫描的文本。

setText

public void setText(String newText)
设置要被扫描的新文本字符串。当前扫描位置被重置为 first()。

参数：
newText - 要扫描的新文本。

setText

public abstract void setText(CharacterIterator newText)
设置一个新文本用于扫描。当前扫描位置被重置为 first()。

参数：
newText - 要扫描的新文本。

getWordInstance

public static BreakIterator getWordInstance()
返回一个用于默认语言环境 单词分解的新 BreakIterator 实例。

返回：
用于单词分解的分解迭代器

getWordInstance

public static BreakIterator getWordInstance(Locale locale)
返回一个用于给定语言环境单词分解的新 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
用于单词分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null

getLineInstance

public static BreakIterator getLineInstance()
返回一个用于默认语言环境 行分解的新 BreakIterator 实例。

返回：
用于行分解的分解迭代器

getLineInstance

public static BreakIterator getLineInstance(Locale locale)
返回一个用于给定语言环境行分解的新 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
用于行分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null

getCharacterInstance

public static BreakIterator getCharacterInstance()
返回一个用于默认语言环境 字符分解的新 BreakIterator 实例。

返回：
用于字符分解的分解迭代器

getCharacterInstance

public static BreakIterator getCharacterInstance(Locale locale)
返回一个用于给定语言环境字符分解的新 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
用于字符分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null

getSentenceInstance

public static BreakIterator getSentenceInstance()
返回一个用于默认语言环境 句子分解的新 BreakIterator 实例。

返回：
用于句子分解的分解迭代器

getSentenceInstance

public static BreakIterator getSentenceInstance(Locale locale)
返回一个用于给定语言环境句子分解的新 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
用于句子分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null

getAvailableLocales

public static Locale[] getAvailableLocales()
返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。返回的数组表示 Java 运行时所支持的语言环境和已安装的 BreakIteratorProvider 实现所支持的语言环境的并集。该数组至少必须包含一个等于 Locale.US 的 Locale 实例。

返回：
一个语言环境数组，可获得这些语言环境的本地化 BreakIterator 实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CharacterIterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
接口 CharacterIterator

所有超级接口：
Cloneable
所有已知子接口：
AttributedCharacterIterator
所有已知实现类：
Segment, StringCharacterIterator
public interface CharacterIterator
extends Cloneable

此接口定义了对文本进行双向迭代的协议。迭代器对有界字符序列进行迭代。这些字符使用从 getBeginIndex() 返回的值开始，一直到 getEndIndex()-1 返回的值结束之间的值进行索引。

迭代器维护当前的字符索引，索引值的有效范围是从 getBeginIndex() 到 getEndIndex()；出于历史原因，包括了值 getEndIndex() 以允许处理零长度的文本范围。可以通过调用 getIndex() 获取当前索引，还可以通过调用 setIndex()、first() 和 last() 直接设置当前索引。

使用方法 previous() 和 next() 进行迭代。如果方法进行到从 getBeginIndex() 到 getEndIndex() -1 的范围之外，则返回 DONE，指示迭代器已经到达序列末尾。DONE 还可以由其他方法返回，以指示当前索引超出了此范围。

示例：

从前往后遍历文本

 public void traverseForward(CharacterIterator iter) {
     for(char c = iter.first(); c != CharacterIterator.DONE; c = iter.next()) {
         processChar(c);
     }
 }
从后往前逆向遍历文本
 public void traverseBackward(CharacterIterator iter) {
     for(char c = iter.last(); c != CharacterIterator.DONE; c = iter.previous()) {
         processChar(c);
     }
 }
从文本中给定的位置进行正向和逆向遍历。在此例中调用 notBoundary() 表示某个附加的停止遍历的标准。
 public void traverseOut(CharacterIterator iter, int pos) {
     for (char c = iter.setIndex(pos);
              c != CharacterIterator.DONE && notBoundary(c);
              c = iter.next()) {
     }
     int end = iter.getIndex();
     for (char c = iter.setIndex(pos);
             c != CharacterIterator.DONE && notBoundary(c);
             c = iter.previous()) {
     }
     int start = iter.getIndex();
     processSection(start, end);
 }

另请参见：
StringCharacterIterator, AttributedCharacterIterator

字段摘要
static char DONE
当迭代器已到达文本末尾或开始处时返回的常量。
方法摘要
 Object clone()
创建此迭代器的一个副本
 char current()
获取当前位置（由 getIndex() 返回）的字符。
 char first()
将位置设置为 getBeginIndex()，并返回该位置的字符。
 int getBeginIndex()
返回文本的起始索引。
 int getEndIndex()
返回文本的结束索引。
 int getIndex()
返回当前索引。
 char last()
将位置设置为 getEndIndex()-1（如果文本为空，则为 getEndIndex()），并返回该位置的字符。
 char next()
将迭代器的索引加一，并返回新索引处的字符。
 char previous()
将迭代器的索引减一，并返回新索引处的字符。
 char setIndex(int position)
将位置设置为文本中的指定位置，并返回该字符。

字段详细信息

DONE

static final char DONE
当迭代器已到达文本末尾或开始处时返回的常量。其值为 '\\uFFFF'，即不应该出现在任何有效 Unicode 字符串中的 "not a character" 值。

另请参见：
常量字段值
方法详细信息

first

char first()
将位置设置为 getBeginIndex()，并返回该位置的字符。

返回：
文本中的第一个字符，如果文本为空，则返回 DONE
另请参见：
getBeginIndex()

last

char last()
将位置设置为 getEndIndex()-1（如果文本为空，则为 getEndIndex()），并返回该位置的字符。

返回：
文本中的最后一个字符，如果文本为空，则返回 DONE
另请参见：
getEndIndex()

current

char current()
获取当前位置（由 getIndex() 返回）的字符。

返回：
当前位置的字符；如果当前位置已超出文本末尾，则返回 DONE。
另请参见：
getIndex()

next

char next()
将迭代器的索引加一，并返回新索引处的字符。如果得到的索引大于等于 getEndIndex()，则将当前索引重置为 getEndIndex()，并返回值 DONE。

返回：
新位置的索引；如果该新位置已超出文本范围的末尾，则返回 DONE。

previous

char previous()
将迭代器的索引减一，并返回新索引处的字符。如果当前索引为 getBeginIndex()，则新索引仍为 getBeginIndex()，并返回值 DONE。

返回：
新位置的字符；如果当前位置等于 getBeginIndex()，则返回 DONE。

setIndex

char setIndex(int position)
将位置设置为文本中的指定位置，并返回该字符。

参数：
position - 文本中的位置。从 getBeginIndex() 到 getEndIndex() 的有效值。如果提供了无效值，则抛出 IllegalArgumentException。
返回：
指定位置的字符；如果指定位置等于 getEndIndex()，则返回 DONE

getBeginIndex

int getBeginIndex()
返回文本的起始索引。

返回：
文本开始处的索引。

getEndIndex

int getEndIndex()
返回文本的结束索引。此索引是文本末尾后面第一个字符的索引。

返回：
文本中最后一个字符后面的索引

getIndex

int getIndex()
返回当前索引。

返回：
当前索引。

clone

Object clone()
创建此迭代器的一个副本

返回：
迭代器的副本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChoiceFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 ChoiceFormat

java.lang.Object
    继承者  java.text.Format
        继承者  java.text.NumberFormat
            继承者  java.text.ChoiceFormat
所有已实现的接口：
Serializable, Cloneable
public class ChoiceFormat
extends NumberFormat

ChoiceFormat 允许将格式应用到某个范围的数。它通常用于在 MessageFormat 中处理复数。使用按升序排列的 double 列表指定 choice，列表中每一项都指定一个到下一项的半开区间：

当且仅当 limit[j] <= X < limit[j+1] 时，X 匹配 j
如果不匹配，则根据数 (X) 的是太小还是太大，选择使用第一个或最后一个索引。如果 limit 数组不按升序排列，则格式化的结果将不正确。ChoiceFormat 还接受 \u221E（等同于无穷大 (INF)）。

注：ChoiceFormat 不同于其他 Format 类，因为 ChoiceFormat 对象是通过构造方法创建的（而不是通过 getInstance 样式工厂方法）。工厂方法不是必需的，因为 ChoiceFormat 不要求针对给定语言环境进行任何复杂的设置。事实上，ChoiceFormat 并不实现任何特定于语言环境的行为。

创建 ChoiceFormat 时，必须指定一个 format 数组和一个 limit 数组。这些数组的长度必须相同。例如，

  • limits = {1,2,3,4,5,6,7}
    formats = {"Sun","Mon","Tue","Wed","Thur","Fri","Sat"}
  • limits = {0, 1, ChoiceFormat.nextDouble(1)}
    formats = {"no files", "one file", "many files"}
    （nextDouble 可用于获取下一个更大的 double 值，以形成半开区间。）

以下是一个显示格式化和解析的简单例子：

 double[] limits = {1,2,3,4,5,6,7};
 String[] dayOfWeekNames = {"Sun","Mon","Tue","Wed","Thur","Fri","Sat"};
 ChoiceFormat form = new ChoiceFormat(limits, dayOfWeekNames);
 ParsePosition status = new ParsePosition(0);
 for (double i = 0.0; i <= 8.0; ++i) {
     status.setIndex(0);
     System.out.println(i + " -> " + form.format(i) + " -> "
                              + form.parse(form.format(i),status));
 }
以下是一个较复杂的带模式格式的例子：
 double[] filelimits = {0,1,2};
 String[] filepart = {"are no files","is one file","are {2} files"};
 ChoiceFormat fileform = new ChoiceFormat(filelimits, filepart);
 Format[] testFormats = {fileform, null, NumberFormat.getInstance()};
 MessageFormat pattform = new MessageFormat("There {0} on {1}");
 pattform.setFormats(testFormats);
 Object[] testArgs = {null, "ADisk", null};
 for (int i = 0; i < 4; ++i) {
     testArgs[0] = new Integer(i);
     testArgs[2] = testArgs[0];
     System.out.println(pattform.format(testArgs));
 }

为 ChoiceFormat 对象指定一个模式是相当直接的。例如：

 ChoiceFormat fmt = new ChoiceFormat(
      "-1#is negative| 0#is zero or fraction | 1#is one |1.0<is 1+ |2#is two |2<is more than 2.");
 System.out.println("Formatter Pattern : " + fmt.toPattern());

 System.out.println("Format with -INF : " + fmt.format(Double.NEGATIVE_INFINITY));
 System.out.println("Format with -1.0 : " + fmt.format(-1.0));
 System.out.println("Format with 0 : " + fmt.format(0));
 System.out.println("Format with 0.9 : " + fmt.format(0.9));
 System.out.println("Format with 1.0 : " + fmt.format(1));
 System.out.println("Format with 1.5 : " + fmt.format(1.5));
 System.out.println("Format with 2 : " + fmt.format(2));
 System.out.println("Format with 2.1 : " + fmt.format(2.1));
 System.out.println("Format with NaN : " + fmt.format(Double.NaN));
 System.out.println("Format with +INF : " + fmt.format(Double.POSITIVE_INFINITY));
输出结果类似如下：

   Format with -INF : is negative
   Format with -1.0 : is negative
   Format with 0 : is zero or fraction
   Format with 0.9 : is zero or fraction
   Format with 1.0 : is one
   Format with 1.5 : is 1+
   Format with 2 : is two
   Format with 2.1 : is more than 2.
   Format with NaN : is negative
   Format with +INF : is more than 2.

Synchronization

Choice 格式不是同步的。建议为每个线程创建单独的格式实例。如果多个线程并发访问一个格式，则它必须保持外部同步。

另请参见：
DecimalFormat, MessageFormat, 序列化表格

嵌套类摘要
从类 java.text.NumberFormat 继承的嵌套类/接口
NumberFormat.Field
字段摘要
从类 java.text.NumberFormat 继承的字段
FRACTION_FIELD, INTEGER_FIELD
构造方法摘要
ChoiceFormat(double[] limits, String[] formats)
根据 limit 和相应的 format 构造。
ChoiceFormat(String newPattern)
根据 limit 和相应的 format（基于模式）构造。
方法摘要
void | applyPattern(String newPattern) 设置模式。
Object | clone() 重写 Cloneable
boolean | equals(Object obj) 两个对象之间的相等性比较。
StringBuffer | format(double number, StringBuffer toAppendTo, FieldPosition status) 返回带已格式化 double 的模式。
StringBuffer | format(long number, StringBuffer toAppendTo, FieldPosition status) 特殊格式。
Object[] | getFormats() 获取传入构造方法的 format。
double[] | getLimits() 获取传入构造方法的 limit。
int | hashCode() 为消息格式对象生成哈希码。
static double | nextDouble(double d) 查找大于 d 的最小 double 值。
static double | nextDouble(double d, boolean positive) 查找大于 d 的最小 double 值（如果 positive == true），或者小于 d 的最大值（如果 positive == false）。
Number | parse(String text, ParsePosition status) 解析输入文本中的一个 Number。
static double | previousDouble(double d) 查找小于 d 的最大 double 值。
void | setChoices(double[] limits, String[] formats) 设置要在格式化中使用的 choice。
String | toPattern() 获取模式。
从类 java.text.NumberFormat 继承的方法
format, format, format, getAvailableLocales, getCurrency, getCurrencyInstance, getCurrencyInstance, getInstance, getInstance, getIntegerInstance, getIntegerInstance, getMaximumFractionDigits, getMaximumIntegerDigits, getMinimumFractionDigits, getMinimumIntegerDigits, getNumberInstance, getNumberInstance, getPercentInstance, getPercentInstance, getRoundingMode, isGroupingUsed, isParseIntegerOnly, parse, parseObject, setCurrency, setGroupingUsed, setMaximumFractionDigits, setMaximumIntegerDigits, setMinimumFractionDigits, setMinimumIntegerDigits, setParseIntegerOnly, setRoundingMode
从类 java.text.Format 继承的方法
format, formatToCharacterIterator, parseObject
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChoiceFormat

public ChoiceFormat(String newPattern)
根据 limit 和相应的 format（基于模式）构造。

另请参见：
applyPattern(java.lang.String)

ChoiceFormat

public ChoiceFormat(double[] limits,
                    String[] formats)
根据 limit 和相应的 format 构造。

另请参见：
setChoices(double[], java.lang.String[])
方法详细信息

applyPattern

public void applyPattern(String newPattern)
设置模式。

参数：
newPattern - 参见类描述。

toPattern

public String toPattern()
获取模式。

setChoices

public void setChoices(double[] limits,
                       String[] formats)
设置要在格式化中使用的 choice。

参数：
limits - 包含要使用该格式进行解析的最大值，应该按升序排列。格式化 X 时，如果 limit[i] <= X < limit[i+1]，则 choice 为 i。如果 limit 数组不按升序排列，则格式化的结果将不正确。
formats - 要为每个 limit 使用的格式。格式可以是 Format 对象或 String。用对象 Y 格式化时，如果该对象是一个 NumberFormat，则调用 ((NumberFormat) Y).format(X)。否则调用 Y.toString()。

getLimits

public double[] getLimits()
获取传入构造方法的 limit。

返回：
limit。

getFormats

public Object[] getFormats()
获取传入构造方法的 format。

返回：
format。

format

public StringBuffer format(long number,
                           StringBuffer toAppendTo,
                           FieldPosition status)
特殊格式。此方法真正调用 format(double, StringBuffer, FieldPosition)，这样，受支持的 long 范围只等于 double 存储的范围。这不是一个实用的限制。

指定者：
类 NumberFormat 中的 format
另请参见：
Format.format(java.lang.Object)

format

public StringBuffer format(double number,
                           StringBuffer toAppendTo,
                           FieldPosition status)
返回带已格式化 double 的模式。

指定者：
类 NumberFormat 中的 format
参数：
number - 要格式化或替换的数。
toAppendTo - 将文本添加到的地方。
status - 忽略，无有用的状态返回。
另请参见：
Format.format(java.lang.Object)

parse

public Number parse(String text,
                    ParsePosition status)
解析输入文本中的一个 Number。

指定者：
类 NumberFormat 中的 parse
参数：
text - 源文本。
status - 一个输入输出参数。输入时，status.index 字段指示应该解析的源文本中的第一个字符。退出时，如果没有发生错误，则将 status.index 设置为源文本中第一个未解析的字符。退出时，如果发生了错误，则 status.index 保持不变，将 status.errorIndex 设置为引起解析失败的第一个字符的索引。
返回：
一个表示已解析数值的 Number。
另请参见：
NumberFormat.isParseIntegerOnly(), Format.parseObject(java.lang.String, java.text.ParsePosition)

nextDouble

public static final double nextDouble(double d)
查找大于 d 的最小 double 值。如果为 NaN，则返回相同的值。

用于形成半开区间。

另请参见：
previousDouble(double)

previousDouble

public static final double previousDouble(double d)
查找小于 d 的最大 double 值。如果为 NaN，则返回相同的值。

另请参见：
nextDouble(double)

clone

public Object clone()
重写 Cloneable

覆盖：
类 NumberFormat 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

hashCode

public int hashCode()
为消息格式对象生成哈希码。

覆盖：
类 NumberFormat 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
两个对象之间的相等性比较。

覆盖：
类 NumberFormat 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

nextDouble

public static double nextDouble(double d,
                                boolean positive)
查找大于 d 的最小 double 值（如果 positive == true），或者小于 d 的最大值（如果 positive == false）。如果为 NaN，则返回相同的值。 如果这些成员函数不调用以下方法，就不会影响浮点标志： Double.longBitsToDouble(long) Double.doubleToLongBits(double) Double.isNaN(double)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CollationElementIterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 CollationElementIterator

java.lang.Object
    继承者  java.text.CollationElementIterator

public final class CollationElementIterator
extends Object

CollationElementIterator 类用作一个迭代器，以遍历国际化字符串的每个字符。使用该迭代器返回所定位字符的排序优先级。我们所指的字符排序优先级，是指在给定 collation 对象中定义字符排序方式的一个键。

例如，在西班牙语中考虑以下字符串：

"ca" -> 第一个键是键 ('c')，而第二个键是键 ('a')。
"cha" -> 第一个键是键 ('ch')，而第二个键是键 ('a')。
在德语中，考虑以下字符串：
"?b" -> 第一个键是键 ('a')，第二个键是键 ('e')，
第三个键是键 ('b')。
字符的键是由主顺序（short）、第二顺序（byte）和第三顺序（byte）组成的一个整数。Java 严格定义了其基本数据类型的大小和符号。因此，static 函数 primaryOrder、secondaryOrder 和 tertiaryOrder 分别返回 int、short 和 short，以确保键值的正确性。

以下是使用迭代器的例子：

  String testString = "This is a test";
  RuleBasedCollator ruleBasedCollator = (RuleBasedCollator)Collator.getInstance();
  CollationElementIterator collationElementIterator = ruleBasedCollator.getCollationElementIterator(testString);
  int primaryOrder = CollationElementIterator.primaryOrder(collationElementIterator.next());

CollationElementIterator.next 返回下一个字符的 collation 顺序。collation 顺序由主顺序、第二顺序和第三顺序组成。collation 顺序的数据类型是 int。collation 顺序的前 16 位是它的主顺序，接下来 8 位是第二顺序，最后 8 位是第三顺序。

另请参见：
Collator, RuleBasedCollator

字段摘要
static int NULLORDER
Null 顺序指示光标到达字符串末尾。
方法摘要
int | getMaxExpansion(int order) 返回以指定比较顺序结束的所有扩展序列的最大长度。
int | getOffset() 返回源文本中对应于下一个 collation 元素的字符偏移量。
int | next() 获取字符串中的下一个 collation 元素。
int | previous() 获取字符串中前一个 collation 元素。
static int | primaryOrder(int order) 返回 collation 元素的主顺序。
void | reset() 将光标重置于字符串开始处。
static short | secondaryOrder(int order) 返回 collation 元素的第二顺序。
void | setOffset(int newOffset) 将迭代器设置为指向对应于指定字符的 collation 元素（参数是源字符串中的一个 CHARACTER 偏移量，而不是其对应 collation 元素序列的偏移量）。
void | setText(CharacterIterator source) 设置一个要迭代的新字符串。
void | setText(String source) 设置一个要迭代的新字符串。
static short | tertiaryOrder(int order) 返回 collation 元素的第三顺序。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NULLORDER

public static final int NULLORDER
Null 顺序指示光标到达字符串末尾。

另请参见：
常量字段值
方法详细信息

reset

public void reset()
将光标重置于字符串开始处。下一次调用 next() 将返回字符串中的第一个 collation 元素。

next

public int next()
获取字符串中的下一个 collation 元素。

此迭代器对构建于字符串的 collation 元素序列进行迭代。因为从字符到 collation 元素不一定存在一一映射关系，因此这与“返回字符串中下一个字符的 collation 元素（或排序优先级）”意义不同。

此函数返回迭代器当前指向的 collation 元素，然后将内部指针更新为指向下一个元素。previous() 则首先更新指针，然后再返回元素。这意味着，如果您在进行迭代时改变方向（例如，调用 next()，然后调用 previous()，或者调用 previous()，然后调用 next()），将两次获取同一个元素。

previous

public int previous()
获取字符串中前一个 collation 元素。

此迭代器对构建于字符串的 collation 元素序列进行迭代。因为从字符到 collation 元素不一定存在一一映射关系，因此这与“返回字符串中前一个字符的 collation 元素（或排序优先级）”意义不同。

此函数将迭代器的内部指针更新为指向它当前指向的 collation 元素的前一个元素，然后返回该元素；而 next() 则先返回当前元素，然后更新指针。这意味着，如果您在进行迭代时改变方向（例如，调用 next()，然后调用 previous()，或者调用 previous()，然后调用 next()），将两次获取同一个元素。

从以下版本开始：
1.2

primaryOrder

public static final int primaryOrder(int order)
返回 collation 元素的主顺序。

参数：
order - collation 元素
返回：
该元素的主顺序

secondaryOrder

public static final short secondaryOrder(int order)
返回 collation 元素的第二顺序。

参数：
order - collation 元素
返回：
该元素的第二顺序

tertiaryOrder

public static final short tertiaryOrder(int order)
返回 collation 元素的第三顺序。

参数：
order - collation 元素
返回：
该元素的第二顺序

setOffset

public void setOffset(int newOffset)
将迭代器设置为指向对应于指定字符的 collation 元素（参数是源字符串中的一个 CHARACTER 偏移量，而不是其对应 collation 元素序列的偏移量）。下一次调用 next() 返回的值将是对应于文本中指定位置的 collation 元素。如果该位置在 contracting 字符序列的中间，则下一次调用 next() 的结果是该序列的 collation 元素。这意味着 getOffset() 返回的值不一定是前一次调用 setOffset() 所传入的值。

参数：
newOffset - 源文本中新的字符偏移量。
从以下版本开始：
1.2

getOffset

public int getOffset()
返回源文本中对应于下一个 collation 元素的字符偏移量。（也就是说，getOffset() 返回的文本中的位置对应于下一次调用 next() 所返回的 collation 元素。）此值始终是对应于 collation 元素的 FIRST 字符的索引（contracting 字符序列是指两个或更多个字符都对应于同一个 collation 元素）。这意味着，如果调用 setOffset(x)后紧接着调用 getOffset()，getOffset() 不一定返回 x。

返回：
源文本中对应于下一次调用 next() 所返回的 collation 元素的字符偏移量。
从以下版本开始：
1.2

getMaxExpansion

public int getMaxExpansion(int order)
返回以指定比较顺序结束的所有扩展序列的最大长度。

参数：
order - 由 previous 或 next 返回的 collation 顺序。
返回：
以指定比较顺序结束的所有扩展序列的最大长度。
从以下版本开始：
1.2

setText

public void setText(String source)
设置一个要迭代的新字符串。

参数：
source - 新的源文本
从以下版本开始：
1.2

setText

public void setText(CharacterIterator source)
设置一个要迭代的新字符串。

参数：
source - 新的源文本。
从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CollationKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 CollationKey

java.lang.Object
    继承者  java.text.CollationKey
所有已实现的接口：
Comparable<CollationKey>
public abstract class CollationKey
extends Object
implements Comparable<CollationKey>

CollationKey 表示遵守特定 Collator 对象规则的 String。比较两个 CollationKey 将返回它们所表示的 String 的相对顺序。使用 CollationKey 来比较 String 通常比使用 Collator.compare 更快。因此，当必须多次比较 String 时（例如，对一个 String 列表进行排序），使用 CollationKey 会更高效。

不能直接创建 CollationKey。而是通过调用 Collator.getCollationKey 来生成。只能比较同一个 Collator 对象生成的 CollationKey。

为一个 String 生成 CollationKey 涉及到检查整个 String，并将它转换成可以按位比较的一系列位。一旦生成了键，就允许进行快速比较。当 String 需要多次比较时，以更快速的比较方式生成键的成本可以忽略不计。另一方面，比较的结果通常由每个 String 的第一对字符确定。Collator.compare 只检查实际需要比较的字符，当进行单次比较时，此比较方式更快。

以下例子显示如何使用 CollationKey 对一个 String 列表进行排序。

 // Create an array of CollationKeys for the Strings to be sorted.
 Collator myCollator = Collator.getInstance();
 CollationKey[] keys = new CollationKey[3];
 keys[0] = myCollator.getCollationKey("Tom");
 keys[1] = myCollator.getCollationKey("Dick");
 keys[2] = myCollator.getCollationKey("Harry");
 sort( keys );

 //...

 // Inside body of sort routine, compare keys this way
 if( keys[i].compareTo( keys[j] ) > 0 )
    // swap keys[i] and keys[j]

 //...

 // Finally, when we've returned from sort.
 System.out.println( keys[0].getSourceString() );
 System.out.println( keys[1].getSourceString() );
 System.out.println( keys[2].getSourceString() );

另请参见：
Collator, RuleBasedCollator

构造方法摘要
protected CollationKey(String source)
CollationKey 构造方法。
方法摘要
abstract int | compareTo(CollationKey target) 比较此 CollationKey 与目标 CollationKey。
String | getSourceString() 返回此 CollationKey 表示的 String。
abstract byte[] | toByteArray() 将 CollationKey 转换成位序列。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CollationKey

protected CollationKey(String source)
CollationKey 构造方法。

参数：
source - - 源字符串。
抛出：
NullPointerException - 如果 source 为 null。
从以下版本开始：
1.6
方法详细信息

compareTo

public abstract int compareTo(CollationKey target)
比较此 CollationKey 与目标 CollationKey。创建这些键的 Collator 对象的 collation 规则将被应用。注：不能比较由不同 Collator 对象创建的 CollationKey。

指定者：
接口 Comparable<CollationKey> 中的 compareTo
参数：
target - 目标 CollationKey
返回：
一个整数值。如果此 CollationKey 小于目标 CollationKey，则值小于零；如果此 CollationKey 与目标 CollationKey 相等，则值等于零；如果此 CollationKey 大于目标 CollationKey，则值大于零。
另请参见：
Collator.compare(java.lang.String, java.lang.String)

getSourceString

public String getSourceString()
返回此 CollationKey 表示的 String。

toByteArray

public abstract byte[] toByteArray()
将 CollationKey 转换成位序列。如果两个 CollationKey 可以进行合法的比较，则可以比较每个键的字节数组，其结果相同。字节数组从最高有效字节开始组织。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Collator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 Collator

java.lang.Object
    继承者  java.text.Collator
所有已实现的接口：
Cloneable, Comparator<Object>
直接已知子类：
RuleBasedCollator
public abstract class Collator
extends Object
implements Comparator<Object>, Cloneable

Collator 类执行区分语言环境的 String 比较。使用此类可为自然语言文本构建搜索和排序例程。

Collator 是一个抽象基类。其子类实现具体的整理策略。Java 平台目前提供了 RuleBasedCollator 子类，它适用于很多种语言。还可以创建其他子类，以处理更多的专门需要。

与其他区分语言环境的类一样，可以使用静态工厂方法 getInstance 来为给定的语言环境获得适当的 Collator 对象。如果需要理解特定整理策略的细节或者需要修改策略，只需查看 Collator 的子类即可。

下面的示例显示了如何使用针对默认语言环境的 Collator 比较两个字符串。

 // Compare two strings in the default locale
 Collator myCollator = Collator.getInstance();
 if( myCollator.compare("abc", "ABC") < 0 )
     System.out.println("abc is less than ABC");
 else
     System.out.println("abc is greater than or equal to ABC");

可以设置 Collator 的 strength 属性来确定比较中认为显著的差异级别。提供了四种 strength：PRIMARY、SECONDARY、TERTIARY 和 IDENTICAL。对语言特征的确切 strength 赋值和语言环境相关。例如在捷克语中，"e" 和 "f" 被认为是 PRIMARY 差异，而 "e" 和 "ě" 则是 SECONDARY 差异，"e" 和 "E" 是 TERTIARY 差异，"e" 和 "e" 是 IDENTICAL。下面的示例显示了如何针对美国英语忽略大小写和重音。

 //Get the Collator for US English and set its strength to PRIMARY
 Collator usCollator = Collator.getInstance(Locale.US);
 usCollator.setStrength(Collator.PRIMARY);
 if( usCollator.compare("abc", "ABC") == 0 ) {
     System.out.println("Strings are equivalent");
 }

如果正好比较 String 一次，则 compare 方法可提供最佳性能。但在对 String 列表排序时，通常需要对每个 String 进行多次比较。在这种情况下，CollationKey 可提供更好的性能。CollationKey 类将一个 String 转换成一系列可与其他 CollationKey 进行按位比较的位。CollationKey 是由 Collator 对象为给定的 String 所创建的。
注：不能比较由不同 Collator 创建的 CollationKey。有关使用 CollationKey 的示例，请参阅 CollationKey 的类描述。

另请参见：
RuleBasedCollator, CollationKey, CollationElementIterator, Locale

字段摘要
static int | CANONICAL_DECOMPOSITION Decomposition 模式值。
static int | FULL_DECOMPOSITION Decomposition 模式值。
static int | IDENTICAL Collator 的 strength 值。
static int | NO_DECOMPOSITION Decomposition 模式值。
static int | PRIMARY Collator 的 strength 值。
static int | SECONDARY Collator 的 strength 值。
static int | TERTIARY Collator 的 strength 值。
构造方法摘要
protected Collator()
默认的构造方法。
方法摘要
Object | clone() 重写 Cloneable
int | compare(Object o1, Object o2) 比较此方法两个参数的顺序。
abstract int | compare(String source, String target) 根据此 Collator 的整理规则来比较源字符串和目标字符串。
boolean | equals(Object that) 比较两个 Collator 的相等性。
boolean | equals(String source, String target) 根据此 Collator 的整理规则比较两个字符串是否相等的便捷方法。
static Locale[] | getAvailableLocales() 返回一个所有受支持语言环境的数组，此类的 getInstance 方法可为这些语言环境返回已本地化的实例。
abstract CollationKey | getCollationKey(String source) 将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。
int | getDecomposition() 获取此 Collator 的 decomposition 模式。
static Collator | getInstance() 获取当前默认语言环境的 Collator。
static Collator | getInstance(Locale desiredLocale) 获取所需语言环境的 Collator。
int | getStrength() 返回此 Collator 的 strength 属性。
abstract int | hashCode() 生成此 Collator 的哈希码。
void | setDecomposition(int decompositionMode) 设置此 Collator 的 decomposition 模式。
void | setStrength(int newStrength) 设置此 Collator 的 strength 属性。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PRIMARY

public static final int PRIMARY
Collator 的 strength 值。设置该值后，比较期间仅将 PRIMARY 及以上的差异视为显著的。对语言特征的 strength 赋值和语言环境相关。常见的例子是将不同的基本字母（"a" 和 "b"）视为 PRIMARY 差异。

另请参见：
setStrength(int), getStrength(), 常量字段值

SECONDARY

public static final int SECONDARY
Collator 的 strength 值。设置该值后，比较期间仅将 SECONDARY 的差异视为显著的。对语言特征的 strength 赋值和语言环境相关。常见的例子是将相同基本字母的不同重音形式（"a" 和 "?"）视为 SECONDARY 差异。

另请参见：
setStrength(int), getStrength(), 常量字段值

TERTIARY

public static final int TERTIARY
Collator 的 strength 值。设置该值后，比较期间仅将 TERTIARY 及以上的差异视为显著的。对语言特征的 strength 赋值和语言环境相关。常见的例子是将大小写差异（如 "a" 和 "A"）视为 TERTIARY 差异。

另请参见：
setStrength(int), getStrength(), 常量字段值

IDENTICAL

public static final int IDENTICAL
Collator 的 strength 值。设置该值后，比较期间将所有的差异都视为显著的。对语言特征的 strength 赋值和语言环境相关。常见的例子是控制字符（"\u0001" 和 "\u0002"）在 PRIMARY、SECONDARY 和 TERTIARY 级别视为相等的，但在 IDENTICAL 级别则是不同的。另外，如果将 decomposition 设置为 NO_DECOMPOSITION，则像 "\u00C0"（A-重音）的前构重音和像 "A\u0300"（A，组合重音）的组合重音将在 IDENTICAL 级别被视为是显著差异。

另请参见：
常量字段值

NO_DECOMPOSITION

public static final int NO_DECOMPOSITION
Decomposition 模式值。设置为 NO_DECOMPOSITION 时，不会为了整理而分解重音字符。这是默认的设置并可提供最快的整理，但是仅对那些不使用重音的语言才能得出正确的结果。

另请参见：
getDecomposition(), setDecomposition(int), 常量字段值

CANONICAL_DECOMPOSITION

public static final int CANONICAL_DECOMPOSITION
Decomposition 模式值。设置为 CANONICAL_DECOMPOSITION 时，将为整理而分解那些根据 Unicode 标准为规范变体的字符。要获取重音字符的正确整理，应该使用该值。

CANONICAL_DECOMPOSITION 对应于 Unicode Technical Report #15 中所描述的 Normalization Form D。

另请参见：
getDecomposition(), setDecomposition(int), 常量字段值

FULL_DECOMPOSITION

public static final int FULL_DECOMPOSITION
Decomposition 模式值。设置为 FULL_DECOMPOSITION 时，将为整理而分解 Unicode 规范变体和 Unicode 兼容变体。这样就不仅能排序重音字符，而且对于具有特殊格式的字符，也能够使用其标准化形式进行排序。例如，半角和全角的 ASCII 字符与片假名字符就能一同排序了。FULL_DECOMPOSITION 是最完整的，因此也是最慢的 decomposition 模式。

FULL_DECOMPOSITION 对应于 Unicode Technical Report #15 中所描述的 Normalization Form KD。

另请参见：
getDecomposition(), setDecomposition(int), 常量字段值
构造方法详细信息

Collator

protected Collator()
默认的构造方法。此构造方法是受保护的，所以子类可以访问它。用户通常调用 getInstance 工厂方法来创建一个 Collator 子类。

另请参见：
getInstance()
方法详细信息

getInstance

public static Collator getInstance()
获取当前默认语言环境的 Collator。通过 java.util.Locale.getDefault 来确定默认的语言环境。

返回：
默认语言环境（例如 en_US）的 Collator。
另请参见：
Locale.getDefault()

getInstance

public static Collator getInstance(Locale desiredLocale)
获取所需语言环境的 Collator。

参数：
desiredLocale - 所需的语言环境。
返回：
所需语言环境的 Collator。
另请参见：
Locale, ResourceBundle

compare

public abstract int compare(String source,
                            String target)
根据此 Collator 的整理规则来比较源字符串和目标字符串。根据源字符串是小于、等于或大于目标字符串来返回负整数、零或正整数。有关此方法的使用示例，请参阅 Collator 的类描述。

对于一次比较，此方法具有最佳性能。如果在多次比较中涉及给定的 String，则 CollationKey.compareTo 具有最佳性能。有关使用 CollationKeys 的示例，请参阅 Collator 的类描述。

参数：
source - 源字符串。
target - 目标字符串。
返回：
返回一个整数值。如果源小于目标，则该值小于零；如果源等于目标，则该值为零；如果源大于目标，则该值大于零。
另请参见：
CollationKey, getCollationKey(java.lang.String)

compare

public int compare(Object o1,
                   Object o2)
比较此方法两个参数的顺序。第一个参数小于、等于或大于第二个参数时分别返回负整数、零或正整数。

此实现仅返回 compare((String)o1, (String)o2)。

指定者：
接口 Comparator<Object> 中的 compare
参数：
o1 - 要比较的第一个对象。
o2 - 要比较的第二个对象。
返回：
第一个参数小于、等于或大于第二个参数时分别返回负整数、零或正整数。
抛出：
ClassCastException - 无法将参数强制转换为 String。
从以下版本开始：
1.2
另请参见：
Comparator

getCollationKey

public abstract CollationKey getCollationKey(String source)
将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。在多次比较中均涉及 String 时，CollationKey 的性能要优于 Collator.compare。有关使用 CollationKeys 的示例，请参阅 Collator 的类描述。

参数：
source - 将要被转换为整理键的字符串。
返回：
根据此 Collator 的整理规则为给定 String 创建的 CollationKey。如果源 String 为 null，则返回一个 null CollationKey。
另请参见：
CollationKey, compare(java.lang.String, java.lang.String)

equals

public boolean equals(String source,
                      String target)
根据此 Collator 的整理规则比较两个字符串是否相等的便捷方法。

参数：
source - 要比较的源字符串。
target - 要比较的目标字符串。
返回：
如果根据整理规则，两个字符串相等，则返回 true；否则返回 false。
另请参见：
compare(java.lang.String, java.lang.String)

getStrength

public int getStrength()
返回此 Collator 的 strength 属性。strength 属性确定了在比较期间被视为显著的最低差异级别。有关此方法的使用示例，请参阅 Collator 的类描述。

返回：
此 Collator 的当前 strength 属性。
另请参见：
setStrength(int), PRIMARY, SECONDARY, TERTIARY, IDENTICAL

setStrength

public void setStrength(int newStrength)
设置此 Collator 的 strength 属性。strength 属性确定了在比较期间被视为显著的最低差异级别。有关此方法的使用示例，请参阅 Collator 的类描述。

参数：
newStrength - 新的 strength 值。
抛出：
IllegalArgumentException - 如果新的 strength 值不是 PRIMARY、SECONDARY、TERTIARY 或 IDENTICAL 之一。
另请参见：
getStrength(), PRIMARY, SECONDARY, TERTIARY, IDENTICAL

getDecomposition

public int getDecomposition()
获取此 Collator 的 decomposition 模式。Decomposition 模式确定如何处理 Unicode 组合字符。调整 decomposition 模式允许用户在更快和更完整的整理行为之间进行选择。

用于 decomposition 模式的三个值是：

  • NO_DECOMPOSITION，
  • CANONICAL_DECOMPOSITION，
  • FULL_DECOMPOSITION。
有关这三个常量含义的描述，请参阅这些常量的文档。

返回：
decomposition 模式
另请参见：
setDecomposition(int), NO_DECOMPOSITION, CANONICAL_DECOMPOSITION, FULL_DECOMPOSITION

setDecomposition

public void setDecomposition(int decompositionMode)
设置此 Collator 的 decomposition 模式。有关 decomposition 模式的描述，请参阅 getDecomposition。

参数：
decompositionMode - 新的 decomposition 模式。
抛出：
IllegalArgumentException - 如果给定值不是有效的 decomposition 模式。
另请参见：
getDecomposition(), NO_DECOMPOSITION, CANONICAL_DECOMPOSITION, FULL_DECOMPOSITION

getAvailableLocales

public static Locale[] getAvailableLocales()
返回一个所有受支持语言环境的数组，此类的 getInstance 方法可为这些语言环境返回已本地化的实例。 返回的数组代表 Java 运行时和已安装的 CollatorProvider 实现所支持的语言环境的联合。它至少包含一个等同于 Locale.US 的 Locale 实例。

返回：
一个语言环境数组，可以为这些语言环境提供已本地化的 Collator 实例。

clone

public Object clone()
重写 Cloneable

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

equals

public boolean equals(Object that)
比较两个 Collator 的相等性。

指定者：
接口 Comparator<Object> 中的 equals
覆盖：
类 Object 中的 equals
参数：
that - 要与此 Collator 进行比较的 Collator。
返回：
如果此 Collator 与该 Collator 相同，则返回 true；否则返回 false.
另请参见：
Object.hashCode(), Hashtable

hashCode

public abstract int hashCode()
生成此 Collator 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 DateFormat

java.lang.Object
    继承者  java.text.Format
        继承者  java.text.DateFormat
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
SimpleDateFormat
public abstract class DateFormat
extends Format

DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。日期/时间格式化子类（如 SimpleDateFormat）允许进行格式化（也就是日期 -> 文本）、解析（文本-> 日期）和标准化。将日期表示为 Date 对象，或者表示为从 GMT（格林尼治标准时间）1970 年 1 月 1 日 00:00:00 这一刻开始的毫秒数。

DateFormat 提供了很多类方法，以获得基于默认或给定语言环境和多种格式化风格的默认日期/时间 Formatter。格式化风格包括 FULL、LONG、MEDIUM 和 SHORT。方法描述中提供了使用这些风格的更多细节和示例。

DateFormat 可帮助进行格式化并解析任何语言环境的日期。对于月、星期，甚至日历格式（阴历和阳历），其代码可完全与语言环境的约定无关。

要格式化一个当前语言环境下的日期，可使用某个静态工厂方法：

  myString = DateFormat.getDateInstance().format(myDate);

如果格式化多个日期，那么获取该格式并多次使用它是更为高效的做法，这样系统就不必多次获取有关环境语言和国家/地区约定的信息了。

  DateFormat df = DateFormat.getDateInstance();
  for (int i = 0; i < myDate.length; ++i) {
    output.println(df.format(myDate[i]) + "; ");
  }

要格式化不同语言环境的日期，可在 getDateInstance() 的调用中指定它。

  DateFormat df = DateFormat.getDateInstance(DateFormat.LONG, Locale.FRANCE);

还可使用 DateFormat 进行解析。

  myDate = df.parse(myString);

使用 getDateInstance 来获取该国家/地区的标准日期格式。另外还提供了一些其他静态工厂方法。使用 getTimeInstance 可获取该国家/地区的时间格式。使用 getDateTimeInstance 可获取日期和时间格式。可以将不同选项传入这些工厂方法，以控制结果的长度（从 SHORT 到 MEDIUM 到 LONG 再到 FULL）。确切的结果取决于语言环境，但是通常：

  • SHORT 完全为数字，如 12.13.52 或 3:30pm
  • MEDIUM 较长，如 Jan 12, 1952
  • LONG 更长，如 January 12, 1952 或 3:30:32pm
  • FULL 是完全指定，如 Tuesday、April 12、1952 AD 或 3:30:42pm PST。

如果愿意，还可以在格式上设置时区。如果想对格式化或解析施加更多的控制（或者给予用户更多的控制），可以尝试将从工厂方法所获取的 DateFormat 强制转换为 SimpleDateFormat。这适用于大多数国家/地区；只是要记住将其放入一个 try 代码块中，以防遇到特殊的格式。

还可以使用借助 ParsePosition 和 FieldPosition 的解析和格式化方法形式来

  • 逐步地解析字符串的各部分。
  • 对齐任意特定的字段，或者找出字符串在屏幕上的选择位置。

同步

日期格式不是同步的。建议为每个线程创建独立的格式实例。如果多个线程同时访问一个格式，则它必须保持外部同步。

另请参见：
Format, NumberFormat, SimpleDateFormat, Calendar, GregorianCalendar, TimeZone, 序列化表格

嵌套类摘要
static class DateFormat.Field
定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
字段摘要
static int | AM_PM_FIELD 用于对齐 AM_PM 字段的有用常量。
protected Calendar | calendar DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。
static int | DATE_FIELD 用于对齐 DATE 字段的有用常量。
static int | DAY_OF_WEEK_FIELD 用于对齐 DAY_OF_WEEK 字段的有用常量。
static int | DAY_OF_WEEK_IN_MONTH_FIELD 用于对齐 DAY_OF_WEEK_IN_MONTH 字段的有用常量。
static int | DAY_OF_YEAR_FIELD 用于对齐 DAY_OF_YEAR 字段的有用常量。
static int | DEFAULT 用于默认模式的常量。
static int | ERA_FIELD 用于对齐 ERA 字段的有用常量。
static int | FULL 用于 FULL 模式的常量。
static int | HOUR_OF_DAY0_FIELD 用于对齐从 0 开始的 HOUR_OF_DAY 字段的有用常量。
static int | HOUR_OF_DAY1_FIELD 用于对齐从 1 开始的 HOUR_OF_DAY 字段的有用常量。
static int | HOUR0_FIELD 用于对齐从 0 开始的 HOUR 字段的有用常量。
static int | HOUR1_FIELD 用于对齐从 1 开始的 HOUR 字段的有用常量。
static int | LONG 用于 LONG 模式的常量。
static int | MEDIUM 用于 MEDIUM 模式的常量。
static int | MILLISECOND_FIELD 用于对齐 MILLISECOND 字段的有用常量。
static int | MINUTE_FIELD 用于对齐 MINUTE 字段的有用常量。
static int | MONTH_FIELD 用于对齐 MONTH 字段的有用常量。
protected NumberFormat | numberFormat 数字格式器，DateFormat 用其来格式化日期和时间中的数字。
static int | SECOND_FIELD 用于对齐 SECOND 字段的有用常量。
static int | SHORT 用于 SHORT 模式的常量。
static int | TIMEZONE_FIELD 用于对齐 TIMEZONE 字段的有用常量。
static int | WEEK_OF_MONTH_FIELD 用于对齐 WEEK_OF_MONTH 字段的有用常量。
static int | WEEK_OF_YEAR_FIELD 用于对齐 WEEK_OF_YEAR 字段的有用常量。
static int | YEAR_FIELD 用于对齐 YEAR 字段的有用常量。
构造方法摘要
protected DateFormat()
创建一个新的 DateFormat。
方法摘要
Object | clone() 重写 Cloneable
boolean | equals(Object obj) 重写 equals
String | format(Date date) 将一个 Date 格式化为日期/时间字符串。
abstract StringBuffer | format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition) 重写 Format。
static Locale[] | getAvailableLocales() 返回所有语言环境的数组，此类的 get*Instance 方法可以为其返回已本地化的实例。
Calendar | getCalendar() 获取与此日期/时间格式器关联的日历。
static DateFormat | getDateInstance() 获取日期格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | getDateInstance(int style) 获取日期格式器，该格式器具有默认语言环境的给定格式化风格。
static DateFormat | getDateInstance(int style, Locale aLocale) 获取日期格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | getDateTimeInstance() 获取日期/时间格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | getDateTimeInstance(int dateStyle, int timeStyle) 获取日期/时间格式器，该格式器具有默认语言环境的给定日期和时间格式化风格。
static DateFormat | getDateTimeInstance(int dateStyle, int timeStyle, Locale aLocale) 获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | getInstance() 获取为日期和时间使用 SHORT 风格的默认日期/时间格式器。
NumberFormat | getNumberFormat() 获取此日期/时间格式器用于格式化和解析时间的数字格式器。
static DateFormat | getTimeInstance() 获取时间格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | getTimeInstance(int style) 获取时间格式器，该格式器具有默认语言环境的给定格式化风格。
static DateFormat | getTimeInstance(int style, Locale aLocale) 获取时间格式器，该格式器具有给定语言环境的给定格式化风格。
TimeZone | getTimeZone() 获取时区。
int | hashCode() 重写 hashCode
boolean | isLenient() 判断日期/时间解析是否为不严格的。
Date | parse(String source) 从给定字符串的开始解析文本，以生成一个日期。
abstract Date | parse(String source, ParsePosition pos) 根据给定的解析位置开始解析日期/时间字符串。
Object | parseObject(String source, ParsePosition pos) 解析字符串中的文本，以生成一个 Date。
void | setCalendar(Calendar newCalendar) 设置此日期格式所使用的日历。
void | setLenient(boolean lenient) 指定日期/时间解析是否不严格。
void | setNumberFormat(NumberFormat newNumberFormat) 允许用户设置数字格式器。
void | setTimeZone(TimeZone zone) 为此 DateFormat 对象的日历设置时区。
从类 java.text.Format 继承的方法
format, formatToCharacterIterator, parseObject
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

calendar

protected Calendar calendar
DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。子类应将此 calendar 初始化为适合于与此 DateFormat 关联的语言环境的日历。

numberFormat

protected NumberFormat numberFormat
数字格式器，DateFormat 用其来格式化日期和时间中的数字。子类应将此数字格式器初始化为适合于与此 DateFormat 关联的语言环境的数字格式。

ERA_FIELD

public static final int ERA_FIELD
用于对齐 ERA 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

YEAR_FIELD

public static final int YEAR_FIELD
用于对齐 YEAR 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

MONTH_FIELD

public static final int MONTH_FIELD
用于对齐 MONTH 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

DATE_FIELD

public static final int DATE_FIELD
用于对齐 DATE 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

HOUR_OF_DAY1_FIELD

public static final int HOUR_OF_DAY1_FIELD
用于对齐从 1 开始的 HOUR_OF_DAY 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。HOUR_OF_DAY1_FIELD 用于从 1 开始的 24 小时时钟。例如，23:59 ＋ 01:00 的结果是 24:59。

另请参见：
常量字段值

HOUR_OF_DAY0_FIELD

public static final int HOUR_OF_DAY0_FIELD
用于对齐从 0 开始的 HOUR_OF_DAY 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。HOUR_OF_DAY0_FIELD 用于从 0 开始的 24 小时时钟。例如，23:59 ＋ 01:00 的结果是 00:59。

另请参见：
常量字段值

MINUTE_FIELD

public static final int MINUTE_FIELD
用于对齐 MINUTE 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

SECOND_FIELD

public static final int SECOND_FIELD
用于对齐 SECOND 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

MILLISECOND_FIELD

public static final int MILLISECOND_FIELD
用于对齐 MILLISECOND 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

DAY_OF_WEEK_FIELD

public static final int DAY_OF_WEEK_FIELD
用于对齐 DAY_OF_WEEK 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

DAY_OF_YEAR_FIELD

public static final int DAY_OF_YEAR_FIELD
用于对齐 DAY_OF_YEAR 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

DAY_OF_WEEK_IN_MONTH_FIELD

public static final int DAY_OF_WEEK_IN_MONTH_FIELD
用于对齐 DAY_OF_WEEK_IN_MONTH 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

WEEK_OF_YEAR_FIELD

public static final int WEEK_OF_YEAR_FIELD
用于对齐 WEEK_OF_YEAR 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

WEEK_OF_MONTH_FIELD

public static final int WEEK_OF_MONTH_FIELD
用于对齐 WEEK_OF_MONTH 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

AM_PM_FIELD

public static final int AM_PM_FIELD
用于对齐 AM_PM 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

HOUR1_FIELD

public static final int HOUR1_FIELD
用于对齐从 1 开始的 HOUR 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。HOUR1_FIELD 用于从 1 开始的 12 小时时钟。例如，11:30 PM ＋ 1 小时的结果是 12:30 AM。

另请参见：
常量字段值

HOUR0_FIELD

public static final int HOUR0_FIELD
用于对齐从 0 开始的 HOUR 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。HOUR0_FIELD 用于从 0 开始的 12 小时时钟。例如，11:30 PM ＋ 1 小时的结果是 00:30 AM。

另请参见：
常量字段值

TIMEZONE_FIELD

public static final int TIMEZONE_FIELD
用于对齐 TIMEZONE 字段的有用常量。用于日期/时间格式化的 FieldPosition 中。

另请参见：
常量字段值

FULL

public static final int FULL
用于 FULL 模式的常量。

另请参见：
常量字段值

LONG

public static final int LONG
用于 LONG 模式的常量。

另请参见：
常量字段值

MEDIUM

public static final int MEDIUM
用于 MEDIUM 模式的常量。

另请参见：
常量字段值

SHORT

public static final int SHORT
用于 SHORT 模式的常量。

另请参见：
常量字段值

DEFAULT

public static final int DEFAULT
用于默认模式的常量。其值为 MEDIUM。

另请参见：
常量字段值
构造方法详细信息

DateFormat

protected DateFormat()
创建一个新的 DateFormat。

方法详细信息

format

public final StringBuffer format(Object obj,
                                 StringBuffer toAppendTo,
                                 FieldPosition fieldPosition)
重写 Format。将时间对象格式化为时间字符串。时间对象的示例有以毫秒表示的时间值和 Date 对象。

指定者：
类 Format 中的 format
参数：
obj - 必须为 Number 或 Date。
toAppendTo - 用于返回的时间字符串的字符串缓冲区。
fieldPosition - 跟踪返回字符串中字段的位置。输入时：如果需要，是一个对齐字段。输出时：对齐字段的偏移量。例如，在给定时间文本 "1996.07.10 AD at 15:08:56 PDT" 的情况下，如果给定的 fieldPosition 是 DateFormat.YEAR_FIELD，则将 fieldPosition 的开始索引和结束索引分别设置为 0 和 4。注意，如果在一个模式中多次出现同一时间字段，则为第一次出现的该时间字段设置 fieldPosition。例如，使用模式 "h a z (zzzz)" 和对齐字段 DateFormat.TIMEZONE_FIELD 将某个 Date 格式化为时间字符串 "1 PM PDT (Pacific Daylight Time)" 时，针对时区模式字符 'z' 的首个匹配项，将 fieldPosition 的开始索引和结束索引分别设置为 5 和 8。
返回：
作为 toAppendTo 进行传入的字符串缓冲区，添加上已格式化的文本。
另请参见：
Format

format

public abstract StringBuffer format(Date date,
                                    StringBuffer toAppendTo,
                                    FieldPosition fieldPosition)
将一个 Date 格式化为日期/时间字符串。

参数：
date - 要格式化为日期/时间字符串的 Date。
toAppendTo - 用于返回的日期/时间字符串的字符串缓冲区。
fieldPosition - 跟踪返回字符串中字段的位置。输入时：如果需要，是一个对齐字段。输出时：对齐字段的偏移量。例如，在给定时间文本 "1996.07.10 AD at 15:08:56 PDT" 的情况下，如果给定的 fieldPosition 是 DateFormat.YEAR_FIELD，则将 fieldPosition 的开始索引和结束索引分别设置为 0 和 4。注意，如果在一个模式中多次出现同一时间字段，则为该时间字段的首个匹配项设置 fieldPosition。例如，使用模式 "h a z (zzzz)" 和对齐字段 DateFormat.TIMEZONE_FIELD 将某个 Date 格式化为时间字符串 "1 PM PDT (Pacific Daylight Time)" 时，针对时区模式字符 'z' 的首个匹配项，将 fieldPosition 的开始索引和结束索引分别设置为 5 和 8。
返回：
作为 toAppendTo 进行传入的字符串缓冲区，添加上已格式化的文件。

format

public final String format(Date date)
将一个 Date 格式化为日期/时间字符串。

参数：
date - 要格式化为时间字符串的时间值。
返回：
已格式化的时间字符串。

parse

public Date parse(String source)
           throws ParseException
从给定字符串的开始解析文本，以生成一个日期。该方法不使用给定字符串的整个文本。

有关日期解析的更多信息，请参阅 parse(String, ParsePosition) 方法。

参数：
source - 一个 String，应从其开始处进行解析。
返回：
解析字符串得到的 Date。
抛出：
ParseException - 如果无法解析指定字符串的开始处。

parse

public abstract Date parse(String source,
                           ParsePosition pos)
根据给定的解析位置开始解析日期/时间字符串。例如，时间文本 "07/10/96 4:5 PM, PDT" 会解析成等同于 Date(837039928046) 的 Date。

在默认情况下，进行的解析是不严格的：如果输入的形式不是此对象的格式化方法使用的形式，但仍可作为日期进行解析，则解析将获得成功。客户端可能通过调用 setLenient(false) 来强调严格遵守该格式。

参数：
source - 要解析的日期/时间字符串
pos - 输入时，是开始进行解析的位置；输出时，是解析终止的位置，如果解析失败，则为开始位置。
返回：
一个 Date，如果无法解析输入，则为 null
另请参见：
setLenient(boolean)

parseObject

public Object parseObject(String source,
                          ParsePosition pos)
解析字符串中的文本，以生成一个 Date。

该方法试图从 pos 所给定的索引处开始解析文本。如果解析成功，则将 pos 的索引更新为所用最后一个字符后面的索引（解析过程不一定使用到字符串末尾为止的所有字符），并返回解析得到的日期。可以使用更新后的 pos 指示下一次调用此方法的开始点。如果发生错误，则不更改 pos 的索引，并将 pos 的错误索引设置为发生错误处的字符索引，并且返回 null。

有关日期解析的更多信息，请参阅 parse(String, ParsePosition) 方法。

指定者：
类 Format 中的 parseObject
参数：
source - 一个 String，应解析其中的部分内容。
pos - 具有索引和上述错误索引信息的 ParsePosition 对象。
返回：
解析字符串得到的 Date。在出现错误的情况下返回 null。
抛出：
NullPointerException - 如果 pos 为 null。

getTimeInstance

public static final DateFormat getTimeInstance()
获取时间格式器，该格式器具有默认语言环境的默认格式化风格。

返回：
时间格式器。

getTimeInstance

public static final DateFormat getTimeInstance(int style)
获取时间格式器，该格式器具有默认语言环境的给定格式化风格。

参数：
style - 给定的格式化风格。例如，SHORT 用于 US 语言环境中的 "h:mm a"。
返回：
时间格式器。

getTimeInstance

public static final DateFormat getTimeInstance(int style,
                                               Locale aLocale)
获取时间格式器，该格式器具有给定语言环境的给定格式化风格。

参数：
style - 给定的格式化风格。例如，SHORT 用于 US 语言环境中的 "h:mm a"。
aLocale - 给定的语言环境。
返回：
时间格式器。

getDateInstance

public static final DateFormat getDateInstance()
获取日期格式器，该格式器具有默认语言环境的默认格式化风格。

返回：
日期格式器。

getDateInstance

public static final DateFormat getDateInstance(int style)
获取日期格式器，该格式器具有默认语言环境的给定格式化风格。

参数：
style - 给定的格式化风格。例如，SHORT 用于 US 语言环境中的 "M/d/yy"。
返回：
日期格式器。

getDateInstance

public static final DateFormat getDateInstance(int style,
                                               Locale aLocale)
获取日期格式器，该格式器具有给定语言环境的给定格式化风格。

参数：
style - 给定的格式化风格。例如，SHORT 用于 US 语言环境中的 "M/d/yy"。
aLocale - 给定的语言环境。
返回：
日期格式器。

getDateTimeInstance

public static final DateFormat getDateTimeInstance()
获取日期/时间格式器，该格式器具有默认语言环境的默认格式化风格。

返回：
日期/时间格式器。

getDateTimeInstance

public static final DateFormat getDateTimeInstance(int dateStyle,
                                                   int timeStyle)
获取日期/时间格式器，该格式器具有默认语言环境的给定日期和时间格式化风格。

参数：
dateStyle - 给定的日期格式化风格。例如，SHORT 用于 US 语言环境中的 "M/d/yy"。
timeStyle - 给定的时间格式化风格。例如，SHORT 用于 US 语言环境中的 "h:mm a"。
返回：
日期/时间格式器。

getDateTimeInstance

public static final DateFormat getDateTimeInstance(int dateStyle,
                                                   int timeStyle,
                                                   Locale aLocale)
获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。

参数：
dateStyle - 给定的日期格式化风格。
timeStyle - 给定的时间格式化风格。
aLocale - 给定的语言环境。
返回：
日期/时间格式器。

getInstance

public static final DateFormat getInstance()
获取为日期和时间使用 SHORT 风格的默认日期/时间格式器。

getAvailableLocales

public static Locale[] getAvailableLocales()
返回所有语言环境的数组，此类的 get*Instance 方法可以为其返回已本地化的实例。返回的数组代表 Java 运行时和已安装的 DateFormatProvider 实现所支持的语言环境的联合。它至少必须包含一个等同于 Locale.US 的 Locale 实例。

返回：
一个语言环境数组，为这些语言环境提供了已本地化的 DateFormat 实例。

setCalendar

public void setCalendar(Calendar newCalendar)
设置此日期格式所使用的日历。最初为指定或默认的语言环境使用默认的日历。

参数：
newCalendar - 该日期格式所使用的新 Calendar

getCalendar

public Calendar getCalendar()
获取与此日期/时间格式器关联的日历。

返回：
与此日期/时间格式器关联的日历。

setNumberFormat

public void setNumberFormat(NumberFormat newNumberFormat)
允许用户设置数字格式器。

参数：
newNumberFormat - 给定的新 NumberFormat。

getNumberFormat

public NumberFormat getNumberFormat()
获取此日期/时间格式器用于格式化和解析时间的数字格式器。

返回：
此日期/时间格式器使用的数字格式器。

setTimeZone

public void setTimeZone(TimeZone zone)
为此 DateFormat 对象的日历设置时区。

参数：
zone - 给定的新时区。

getTimeZone

public TimeZone getTimeZone()
获取时区。

返回：
与此 DateFormat 的日历相关联的时区。

setLenient

public void setLenient(boolean lenient)
指定日期/时间解析是否不严格。进行不严格解析时，解析程序可以使用启发式的方法来解释与此对象的格式不精确匹配的输入。进行严格解析时，输入必须匹配此对象的格式。

参数：
lenient - 为 true 时，解析过程是不严格的
另请参见：
Calendar.setLenient(boolean)

isLenient

public boolean isLenient()
判断日期/时间解析是否为不严格的。

hashCode

public int hashCode()
重写 hashCode

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
重写 equals

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

clone

public Object clone()
重写 Cloneable

覆盖：
类 Format 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateFormat.Field (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 DateFormat.Field

java.lang.Object
    继承者  java.text.AttributedCharacterIterator.Attribute
        继承者  java.text.Format.Field
            继承者  java.text.DateFormat.Field
所有已实现的接口：
Serializable
正在封闭类：
DateFormat
public static class DateFormat.Field
extends Format.Field

定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。

该类还提供了两个方法，以在其常量和相应的 Calendar 常量之间进行映射。

从以下版本开始：
1.4
另请参见：
Calendar, 序列化表格

字段摘要
static DateFormat.Field | AM_PM 标识每日时间指示符（例如 "a.m." 或 "p.m."）的常量。
static DateFormat.Field | DAY_OF_MONTH 标识 DAY_OF_MONTH 字段的常量。
static DateFormat.Field | DAY_OF_WEEK 标识 DAY_OF_WEEK 字段的常量。
static DateFormat.Field | DAY_OF_WEEK_IN_MONTH 标识 DAY_OF_WEEK_IN_MONTH 字段的常量。
static DateFormat.Field | DAY_OF_YEAR 标识 DAY_OF_YEAR 字段的常量。
static DateFormat.Field | ERA 标识 ERA 字段的常量。
static DateFormat.Field | HOUR_OF_DAY0 标识 HOUR_OF_DAY0 字段的常量，其合法的值是 0 到 23。
static DateFormat.Field | HOUR_OF_DAY1 标识 HOUR_OF_DAY1 字段的常量，其合法的值是 1 到 24。
static DateFormat.Field | HOUR0 标识 HOUR0 字段的常量，其合法的值是 1 到 11。
static DateFormat.Field | HOUR1 标识 HOUR1 字段的常量，其合法的值是 1 到 12。
static DateFormat.Field | MILLISECOND 标识 MILLISECOND 字段的常量。
static DateFormat.Field | MINUTE 标识 MINUTE 字段的常量。
static DateFormat.Field | MONTH 标识 MONTH 字段的常量。
static DateFormat.Field | SECOND 标识 SECOND 字段的常量。
static DateFormat.Field | TIME_ZONE 标识 TIME_ZONE 字段的常量。
static DateFormat.Field | WEEK_OF_MONTH 标识 WEEK_OF_MONTH 字段的常量。
static DateFormat.Field | WEEK_OF_YEAR 标识 WEEK_OF_YEAR 字段的常量。
static DateFormat.Field | YEAR 标识 YEAR 字段的常量。
从类 java.text.AttributedCharacterIterator.Attribute 继承的字段
INPUT_METHOD_SEGMENT, LANGUAGE, READING
构造方法摘要
protected DateFormat.Field(String name, int calendarField)
创建一个 Field。
方法摘要
int | getCalendarField() 返回与此属性关联的 Calendar 字段。
static DateFormat.Field | ofCalendarField(int calendarField) 返回与此 Calendar 常量 calendarField 对应的 Field 常量。
protected Object | readResolve() 将反序列化的实例解析成预定义的常量。
从类 java.text.AttributedCharacterIterator.Attribute 继承的方法
equals, getName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ERA

public static final DateFormat.Field ERA
标识 ERA 字段的常量。

YEAR

public static final DateFormat.Field YEAR
标识 YEAR 字段的常量。

MONTH

public static final DateFormat.Field MONTH
标识 MONTH 字段的常量。

DAY_OF_MONTH

public static final DateFormat.Field DAY_OF_MONTH
标识 DAY_OF_MONTH 字段的常量。

HOUR_OF_DAY1

public static final DateFormat.Field HOUR_OF_DAY1
标识 HOUR_OF_DAY1 字段的常量，其合法的值是 1 到 24。

HOUR_OF_DAY0

public static final DateFormat.Field HOUR_OF_DAY0
标识 HOUR_OF_DAY0 字段的常量，其合法的值是 0 到 23。

MINUTE

public static final DateFormat.Field MINUTE
标识 MINUTE 字段的常量。

SECOND

public static final DateFormat.Field SECOND
标识 SECOND 字段的常量。

MILLISECOND

public static final DateFormat.Field MILLISECOND
标识 MILLISECOND 字段的常量。

DAY_OF_WEEK

public static final DateFormat.Field DAY_OF_WEEK
标识 DAY_OF_WEEK 字段的常量。

DAY_OF_YEAR

public static final DateFormat.Field DAY_OF_YEAR
标识 DAY_OF_YEAR 字段的常量。

DAY_OF_WEEK_IN_MONTH

public static final DateFormat.Field DAY_OF_WEEK_IN_MONTH
标识 DAY_OF_WEEK_IN_MONTH 字段的常量。

WEEK_OF_YEAR

public static final DateFormat.Field WEEK_OF_YEAR
标识 WEEK_OF_YEAR 字段的常量。

WEEK_OF_MONTH

public static final DateFormat.Field WEEK_OF_MONTH
标识 WEEK_OF_MONTH 字段的常量。

AM_PM

public static final DateFormat.Field AM_PM
标识每日时间指示符（例如 "a.m." 或 "p.m."）的常量。

HOUR1

public static final DateFormat.Field HOUR1
标识 HOUR1 字段的常量，其合法的值是 1 到 12。

HOUR0

public static final DateFormat.Field HOUR0
标识 HOUR0 字段的常量，其合法的值是 1 到 11。

TIME_ZONE

public static final DateFormat.Field TIME_ZONE
标识 TIME_ZONE 字段的常量。

构造方法详细信息

DateFormat.Field

protected DateFormat.Field(String name,
                           int calendarField)
创建一个 Field。

参数：
name - Field 的名称
calendarField - 与此 Field 一致的 Calendar 常量；可以使用任意值，即使是超出合法的 Calendar 范围的值，但是在与合法的 Calendar 值不一致的情况下，应该使用 -1。
方法详细信息

ofCalendarField

public static DateFormat.Field ofCalendarField(int calendarField)
返回与此 Calendar 常量 calendarField 对应的 Field 常量。如果 Calendar 常量与 Field 之间没有直接的映射关系，则返回 null。

参数：
calendarField - Calendar 字段常量
返回：
表示 calendarField 的 Field 实例。
抛出：
IllegalArgumentException - 如果 calendarField 不是 Calendar 字段常量值。
另请参见：
Calendar

getCalendarField

public int getCalendarField()
返回与此属性关联的 Calendar 字段。例如，如果此属性表示 Calendar 的 HOUR 字段，则此方法返回 Calendar.HOUR。如果没有对应的 Calendar 常量，则此方法返回 -1。

返回：
此字段的 Calendar 常量
另请参见：
Calendar

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将反序列化的实例解析成预定义的常量。

覆盖：
类 AttributedCharacterIterator.Attribute 中的 readResolve
返回：
解析后的 DateFormat.Field 常量
抛出：
InvalidObjectException - 如果无法解析该常量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateFormatSymbols (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 DateFormatSymbols

java.lang.Object
    继承者  java.text.DateFormatSymbols
所有已实现的接口：
Serializable, Cloneable
public class DateFormatSymbols
extends Object
implements Serializable, Cloneable

DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。DateFormat 和 SimpleDateFormat 都使用 DateFormatSymbols 封装此信息。

通常不应直接使用 DateFormatSymbols。建议最好使用 DateFormat 类的工厂方法创建日期-时间格式器 (formatter)：getTimeInstance、getDateInstance 或 getDateTimeInstance。这些方法自动为格式器创建一个 DateFormatSymbols，所以用户就不必再创建了。创建了格式器后，可使用 setPattern 方法修改它的格式模式。有关使用 DateFormat 的工厂方法创建格式器的更多信息，请参阅 DateFormat。

如果要为特定语言环境创建具有特定格式模式的日期-时间格式器，可使用以下语句实现：

 new SimpleDateFormat(aPattern, DateFormatSymbols.getInstance(aLocale)).

DateFormatSymbols 对象是可复制的。获得一个 DateFormatSymbols 对象后，可随意修改日期-时间格式化数据。例如，可以使用便于记忆的字符替换本地化的日期-时间格式模式字符。也可以将有代表性的城市更改为最喜欢的城市。

要为其他语言环境进行日期-时间格式化，可添加新的 DateFormatSymbols 子类以支持 SimpleDateFormat。

另请参见：
DateFormat, SimpleDateFormat, SimpleTimeZone, 序列化表格

构造方法摘要
DateFormatSymbols()
通过从默认语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
DateFormatSymbols(Locale locale)
通过从给定语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
方法摘要
Object | clone() 重写 Cloneable。
boolean | equals(Object obj) 重写 equals。
String[] | getAmPmStrings() 获取 ampm 字符串。
static Locale[] | getAvailableLocales() 返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
String[] | getEras() 获取年代字符串。
static DateFormatSymbols | getInstance() 获取默认语言环境的 DateFormatSymbols 实例。
static DateFormatSymbols | getInstance(Locale locale) 获取指定语言环境的 DateFormatSymbols 实例。
String | getLocalPatternChars() 获取本地化的日期-时间模式字符。
String[] | getMonths() 获取月份字符串。
String[] | getShortMonths() 获取简短形式的月份字符串。
String[] | getShortWeekdays() 获取简短形式的星期字符串。
String[] | getWeekdays() 获取星期字符串。
String[][] | getZoneStrings() 获取时区字符串。
int | hashCode() 重写 hashCode。
void | setAmPmStrings(String[] newAmpms) 设置 ampm 字符串。
void | setEras(String[] newEras) 设置年代字符串。
void | setLocalPatternChars(String newLocalPatternChars) 设置本地化的日期-时间模式字符。
void | setMonths(String[] newMonths) 设置月份字符串。
void | setShortMonths(String[] newShortMonths) 设置简短形式的月份字符串。
void | setShortWeekdays(String[] newShortWeekdays) 设置简短形式的星期字符串。
void | setWeekdays(String[] newWeekdays) 设置星期字符串。
void | setZoneStrings(String[][] newZoneStrings) 设置时区字符串。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DateFormatSymbols

public DateFormatSymbols()
通过从默认语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。此构造方法只能构造 Java 运行时环境所支持的语言环境实例，不能构造已安装的 DateFormatSymbolsProvider 实现所支持的语言环境实例。要覆盖所有的语言环境，可使用 getInstance 方法。

抛出：
MissingResourceException - 如果无法找到或加载默认语言环境的资源。
另请参见：
getInstance()

DateFormatSymbols

public DateFormatSymbols(Locale locale)
通过从给定语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。此构造方法只能构造 Java 运行时环境所支持的语言环境实例，不能构造已安装的 DateFormatSymbolsProvider 实现所支持的语言环境实例。要覆盖所有的语言环境，可使用 getInstance 方法。

抛出：
MissingResourceException - 如果无法找到或加载指定语言环境的资源。
另请参见：
getInstance(Locale)
方法详细信息

getAvailableLocales

public static Locale[] getAvailableLocales()
返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。返回的数组表示 Java 运行时所支持的语言环境和已安装的 DateFormatSymbolsProvider 实现所支持的语言环境的并集。 它至少必须包含一个等于 Locale.US 的 Locale 实例。

返回：
一个语言环境数组，可获取这些语言环境的本地化 DateFormatSymbols 实例。
从以下版本开始：
1.6

getInstance

public static final DateFormatSymbols getInstance()
获取默认语言环境的 DateFormatSymbols 实例。此方法可访问 Java 运行时本身以及已安装 DateFormatSymbolsProvider 实现所支持的语言环境的 DateFormatSymbols 实例。

返回：
一个 DateFormatSymbols 实例。
从以下版本开始：
1.6

getInstance

public static final DateFormatSymbols getInstance(Locale locale)
获取指定语言环境的 DateFormatSymbols 实例。此方法可访问 Java 运行时本身以及已安装 DateFormatSymbolsProvider 实现所支持的语言环境的 DateFormatSymbols 实例。

参数：
给定的语言环境 -
返回：
一个 DateFormatSymbols 实例。
抛出：
如果 - locale 为 null
从以下版本开始：
1.6

getEras

public String[] getEras()
获取年代字符串。例如："AD" 和 "BC"。

返回：
年代字符串。

setEras

public void setEras(String[] newEras)
设置年代字符串。例如："AD" 和 "BC"。

参数：
newEras - 新的年代字符串。

getMonths

public String[] getMonths()
获取月份字符串。例如："January"、"February" 等等。

返回：
月份字符串。

setMonths

public void setMonths(String[] newMonths)
设置月份字符串。例如："January"、"February" 等等。

参数：
newMonths - 新的月份字符串。

getShortMonths

public String[] getShortMonths()
获取简短形式的月份字符串。例如："Jan"、"Feb" 等等。

返回：
简短形式的月份字符串。

setShortMonths

public void setShortMonths(String[] newShortMonths)
设置简短形式的月份字符串。例如："Jan"、"Feb" 等等

参数：
newShortMonths - 新的简写形式的月份字符串。

getWeekdays

public String[] getWeekdays()
获取星期字符串。例如："Sunday"、"Monday" 等等。

返回：
星期字符串。使用 Calendar.SUNDAY、Calendar.MONDAY 等指出所得数组。

setWeekdays

public void setWeekdays(String[] newWeekdays)
设置星期字符串。例如："Sunday"、"Monday" 等等。

参数：
newWeekdays - 新的星期字符串。应该通过 Calendar.SUNDAY、Calendar.MONDAY 等指出该数组。

getShortWeekdays

public String[] getShortWeekdays()
获取简短形式的星期字符串。例如："Sun"、"Mon" 等等。

返回：
简短形式的星期字符串。使用 Calendar.SUNDAY、Calendar.MONDAY 等指出所得数组。

setShortWeekdays

public void setShortWeekdays(String[] newShortWeekdays)
设置简短形式的星期字符串。例如："Sun"、"Mon" 等等。

参数：
newShortWeekdays - 新的简短形式星期字符串。应该通过 Calendar.SUNDAY、Calendar.MONDAY 等指出该数组。

getAmPmStrings

public String[] getAmPmStrings()
获取 ampm 字符串。例如："AM" 和 "PM"。

返回：
ampm 字符串。

setAmPmStrings

public void setAmPmStrings(String[] newAmpms)
设置 ampm 字符串。例如："AM" 和 "PM"。

参数：
newAmpms - 新的 ampm 字符串。

getZoneStrings

public String[][] getZoneStrings()
获取时区字符串。不建议使用此方法；可以使用 TimeZone.getDisplayName() 替代。

返回值是一个二维字符串数字，其大小为 n × m，其中 m 至少为 5。每个 n 行都是一个包含单个 TimeZone 本地化名称的条目。每个这样的行包含（i 的范围从 0 到 n-1）：

  • zoneStrings[i][0] - 时区 ID
  • zoneStrings[i][1] - 标准时时区的长名称
  • zoneStrings[i][2] - 标准时时区的短名称
  • zoneStrings[i][3] - 夏令时时区的长名称
  • zoneStrings[i][4] - 夏令时时区的短名称
时区 ID 没有 被本地化；它是 TimeZone 类的有效 ID 之一，但不是自定义 ID。其他所有条目都是本地化名称。如果某个时区没有实现夏令时，则不能使用夏令时名称。

如果没有在此 DateFormatSymbols 实例上调用 setZoneStrings，则返回该调用提供的字符串。否则，返回的数组包含 Java 运行时和已安装的 TimeZoneNameProvider 实现所提供的名称。

返回：
时区字符串。
另请参见：
setZoneStrings(String[][])

setZoneStrings

public void setZoneStrings(String[][] newZoneStrings)
设置时区字符串。该参数必须是一个二维字符串数组，其大小为 n × m，其中 m 至少为 5。每个 n 行都是一个包含单个 TimeZone 本地化名称的条目。每个这样的行包含（i 的范围从 0 到 n-1）：
  • zoneStrings[i][0] - 时区 ID
  • zoneStrings[i][1] - 标准时时区的长名称
  • zoneStrings[i][2] - 标准时时区的短名称
  • zoneStrings[i][3] - 夏令时时区的长名称
  • zoneStrings[i][4] - 夏令时时区的短名称
时区 ID 没有 被本地化；它是 TimeZone 类的有效 ID 之一，但不是自定义 ID。其他所有条目都是本地化名称。

参数：
newZoneStrings - 新的时区字符串。
抛出：
IllegalArgumentException - 如果 newZoneStrings 中任何行的长度小于 5
NullPointerException - 如果 newZoneStrings 为 null
另请参见：
getZoneStrings()

getLocalPatternChars

public String getLocalPatternChars()
获取本地化的日期-时间模式字符。例如：'u'、't' 等等。

返回：
本地化的日期-时间模式字符。

setLocalPatternChars

public void setLocalPatternChars(String newLocalPatternChars)
设置本地化的日期-时间模式字符。例如：'u'、't' 等等。

参数：
newLocalPatternChars - 新的本地化的日期-时间模式字符。

clone

public Object clone()
重写 Cloneable。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

hashCode

public int hashCode()
重写 hashCode。生成 DateFormatSymbols 对象的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
重写 equals。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DecimalFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 DecimalFormat

java.lang.Object
    继承者  java.text.Format
        继承者  java.text.NumberFormat
            继承者  java.text.DecimalFormat
所有已实现的接口：
Serializable, Cloneable
public class DecimalFormat
extends NumberFormat

DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。该类设计有各种功能，使其能够解析和格式化任意语言环境中的数，包括对西方语言、阿拉伯语和印度语数字的支持。它还支持不同类型的数，包括整数 (123)、定点数 (123.4)、科学记数法表示的数 (1.23E4)、百分数 (12%) 和金额 ($123)。所有这些内容都可以本地化。

要获取具体语言环境的 NumberFormat（包括默认语言环境），可调用 NumberFormat 的某个工厂方法，如 getInstance()。通常不直接调用 DecimalFormat 的构造方法，因为 NumberFormat 的工厂方法可能返回不同于 DecimalFormat 的子类。如果需要自定义格式对象，可执行：

 NumberFormat f = NumberFormat.getInstance(loc);
 if (f instanceof DecimalFormat) {
     ((DecimalFormat) f).setDecimalSeparatorAlwaysShown(true);
 }

DecimalFormat 包含一个模式 和一组符号。可直接使用 applyPattern() 或间接使用 API 方法来设置模式。符号存储在 DecimalFormatSymbols 对象中。使用 NumberFormat 工厂方法时，可从已本地化的 ResourceBundle 中读取模式和符号。

模式

DecimalFormat 模式具有下列语法：
模式：
正数模式
正数模式；负数模式
正数模式：
前缀opt 数字后缀opt
负数模式：
前缀opt 数字后缀opt
前缀：
除 \uFFFE、\uFFFF 和特殊字符以外的所有 Unicode 字符
后缀：
除 \uFFFE、\uFFFF 和特殊字符以外的所有 Unicode 字符
数字：
整数指数opt
整数。小数指数opt
整数：
最小整数
         #
# 整数
# , 整数
最小整数：
         0
0 最小整数
0 , 最小整数
小数：
最小小数opt 可选小数opt
最小小数：
0 最小小数opt
可选小数：
# 可选小数opt
指数：
E 最小指数
最小指数：
0 最小指数opt

DecimalFormat 模式包含正数和负数子模式，例如 "#,##0.00;(#,##0.00)"。每个子模式都有前缀、数字部分和后缀。负数子模式是可选的；如果存在，则将用已本地化的减号（在多数语言环境中是 '-'）作为前缀的正数子模式用作负数子模式。也就是说，单独的 "0.00" 等效于 "0.00;-0.00"。如果存在显式的负数子模式，则它仅指定负数前缀和后缀；数字位数、最小位数，其他特征都与正数模式相同。这意味着 "#,##0.0#;(#)" 的行为与 "#,##0.0#;(#,##0.0#)" 完全相同。

用于无穷大值、数字、千位分隔符、小数分隔符等的前缀、后缀和各种符号可设置为任意值，并且能在格式化期间正确显示。但是，必须注意不要让符号和字符串发生冲突，否则解析是不可靠的。例如，为了让 DecimalFormat.parse() 能够区分正数和负数，正数和负数前缀或后缀必须是不同的。（如果它们相同，则 DecimalFormat 的行为就如同未指定负数子模式一样。）另一个示例是小数分隔符和千位分隔符应该是不同的字符，否则将不可能进行解析。

分组分隔符通常用于千位，但是在某些国家/地区中它用于分隔万位。分组大小是分组字符之间的固定数字位数，例如 100,000,000 是 3，而 1,0000,0000 则是 4。如果使用具有多个分组字符的模式，则最后一个分隔符和整数结尾之间的间隔才是使用的分组大小。所以 "#,##,###,####" == "######,####" == "##,####,####"。

特殊模式字符

模式中的很多字符都是按字面解释的；在解析期间对其进行匹配，在格式化期间则不经改变地输出。另一方面，特殊字符代表了其他字符、字符串或字符类。如果要将其作为字面量出现在前缀或后缀中，那么除非另行说明，否则必须对其加引号。

下列字符用在非本地化的模式中。已本地化的模式使用从此格式器的 DecimalFormatSymbols 对象中获得的相应字符，这些字符已失去其特殊状态。两种例外是货币符号和引号，不将其本地化。

符号 | 位置 | 本地化？ | 含义
0 | 数字 | 是 | 阿拉伯数字
# 数字字 是 阿拉伯数字，如果不存在则显示为 0
. 数字 是 小数分隔符或货币小数分隔符
- 数字 是 减号
, 数字 是 分组分隔符
E | 数字 | 是 | 分隔科学计数法中的尾数和指数。在前缀或后缀中无需加引号。
; 子模式边界 是 分隔正数和负数子模式
% 前缀或后缀 是 乘以 100 并显示为百分数
\u2030 | 前缀或后缀 | 是 | 乘以 1000 并显示为千分数
¤ (\u00A4) | 前缀或后缀 | 否 | 货币记号，由货币符号替换。如果两个同时出现，则用国际货币符号替换。如果出现在某个模式中，则使用货币小数分隔符，而不使用小数分隔符。
' 前缀或后缀 否 用于在前缀或或后缀中为特殊字符加引号，例如 "'#'#" 将 123 格式化为 "#123"。要创建单引号本身，请连续使用两个单引号："# o''clock"。

科学计数法

科学计数法中的数表示为一个尾数和一个 10 的几次幂的乘积，例如可将 1234 表示为 1.234 x 10^3。尾数的范围通常是 1.0 <= x < 10.0，但并非必需如此。可指示 DecimalFormat 仅通过某个模式 来格式化和解析科学计数法表示的数；目前没有创建科学计数法格式的工厂方法。在这个模式中，指数字符后面紧跟着一个或多个数字字符即指示科学计数法。示例："0.###E0" 将数字 1234 格式化为 "1.234E3"。

  • 指数字符后面的数字位数字符数给出了最小的指数位数。没有最大值。使用本地化的减号来格式化负数指数，不 使用模式中的前缀和后缀。这就允许存在诸如 "0.###E0 m/s" 等此类的模式。
  • 最小和最大整数数字位数一起进行解释：
    • 如果最大整数数字位数大于其最小整数数字位数并且大于 1，则强制要求指数为最大整数数字位数的倍数，并将最小整数数字位数解释为 1。最常见的用法是生成工程计数法，其中指数是 3 的倍数，如 "##0.#####E0"。使用此模式时，数 12345 格式化为 "12.345E3"，123456 则格式化为 "123.456E3"。
    • 否则通过调整指数来得到最小整数数字位数。示例：使用 "00.###E0" 格式化 0.00123 时得到 "12.3E-4"。
  • 尾数中的有效位数是最小整数 和最大小数 位数的和，不受最大整数位数的影响。例如，使用 "##0.##E0" 格式化 12345 得到 "12.3E3"。要显示所有位数，请将有效位数计数设置为零。有效位数不会影响解析。
  • 指数模式可能不包含分组分隔符。

舍入

DecimalFormat 提供 RoundingMode 中定义的舍入模式进行格式化。默认情况下，它使用 RoundingMode.HALF_EVEN。

阿拉伯数字

为了进行格式化，DecimalFormat 使用 DecimalFormatSymbols 对象中所定义的、从已本地化的阿拉伯数字 0 开始的 10 个连续字符作为阿拉伯数字。为了进行解析，可识别 Character.digit 所定义的这些阿拉伯数字和所有 Unicode 十进制阿拉伯数字。

特殊值

NaN 被格式化为一个字符串，通常具有单个字符 \uFFFD。此字符串由 DecimalFormatSymbols 对象所确定。这是唯一不使用前缀和后缀的值。

无穷大的值被格式化为一个字符串，通常具有单个字符 \u221E，具有正数或负数前缀和后缀。无穷大值的字符串由 DecimalFormatSymbols 对象所确定。

将负零（"-0"）解析为

  • 如果 isParseBigDecimal() 为 true，则为 BigDecimal(0)，
  • 如果 isParseBigDecimal() 为 false 并且 isParseIntegerOnly() 为 true，则为 Long(0)，
  • 如果 isParseBigDecimal() 和 isParseIntegerOnly() 均为 false，则为 Double(-0.0)。

同步

DecimalFormat 通常不是同步的。建议为每个线程创建独立的格式实例。如果多个线程同时访问某个格式，则必须保持外部同步。

示例

 // Print out a number using the localized number, integer, currency,
 // and percent format for each locale
 Locale[] locales = NumberFormat.getAvailableLocales();
 double myNumber = -1234.56;
 NumberFormat form;
 for (int j=0; j<4; ++j) {
     System.out.println("FORMAT");
     for (int i = 0; i < locales.length; ++i) {
         if (locales[i].getCountry().length() == 0) {
            continue; // Skip language-only locales
         }
         System.out.print(locales[i].getDisplayName());
         switch (j) {
         case 0:
             form = NumberFormat.getInstance(locales[i]); break;
         case 1:
             form = NumberFormat.getIntegerInstance(locales[i]); break;
         case 2:
             form = NumberFormat.getCurrencyInstance(locales[i]); break;
default:
             form = NumberFormat.getPercentInstance(locales[i]); break;
         }
         if (form instanceof DecimalFormat) {
             System.out.print(": " + ((DecimalFormat) form).toPattern());
         }
         System.out.print(" -> " + form.format(myNumber));
         try {
             System.out.println(" -> " + form.parse(form.format(myNumber)));
} catch (ParseException e) {}
     }
 }

另请参见：
Java Tutorial, NumberFormat, DecimalFormatSymbols, ParsePosition, 序列化表格

嵌套类摘要
从类 java.text.NumberFormat 继承的嵌套类/接口
NumberFormat.Field
字段摘要
从类 java.text.NumberFormat 继承的字段
FRACTION_FIELD, INTEGER_FIELD
构造方法摘要
DecimalFormat()
使用默认模式和默认语言环境的符号创建一个 DecimalFormat。
DecimalFormat(String pattern)
使用给定的模式和默认语言环境的符号创建一个 DecimalFormat。
DecimalFormat(String pattern, DecimalFormatSymbols symbols)
使用给定的模式和符号创建一个 DecimalFormat。
方法摘要
 void applyLocalizedPattern(String pattern)
将给定的模式应用于此 Format 对象。
 void applyPattern(String pattern)
将给定的模式应用于此 Format 对象。
 Object clone()
标准重写；没有语义上的变化。
 boolean equals(Object obj)
重写 equals
 StringBuffer format(double number, StringBuffer result, FieldPosition fieldPosition)
格式化一个 double 值，以生成一个字符串。
 StringBuffer format(long number, StringBuffer result, FieldPosition fieldPosition)
格式化一个 long 值，以生成一个字符串。
 StringBuffer format(Object number, StringBuffer toAppendTo, FieldPosition pos)
格式化一个数，并将所得文本追加到给定的字符串缓冲区。
 AttributedCharacterIterator formatToCharacterIterator(Object obj)
格式化一个 Object，以生成一个 AttributedCharacterIterator。
 Currency getCurrency()
获取格式化货币值时，此十进制格式使用的货币。
 DecimalFormatSymbols getDecimalFormatSymbols()
返回小数格式符号的一个副本，通常程序员或用户不改变此副本。
 int getGroupingSize()
返回分组大小。
 int getMaximumFractionDigits()
获取某个数的小数部分中所允许的最大数字位数。
 int getMaximumIntegerDigits()
获取某个数的整数部分中所允许的最大数字位数。
 int getMinimumFractionDigits()
获取某个数的小数部分中所允许的最小数字位数。
 int getMinimumIntegerDigits()
获取某个数的整数部分中所允许的最小数字位数。
 int getMultiplier()
获取百分数、千分数和类似格式中使用的乘数。
 String getNegativePrefix()
获取负数前缀。
 String getNegativeSuffix()
获取负数后缀。
 String getPositivePrefix()
获取正数前缀。
 String getPositiveSuffix()
获取正数后缀。
 RoundingMode getRoundingMode()
获取在此 DecimalFormat 中使用的 RoundingMode。
 int hashCode()
重写 hashCode
 boolean isDecimalSeparatorAlwaysShown()
允许获取整数中小数分隔符的行为。
 boolean isParseBigDecimal()
返回 parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。
 Number parse(String text, ParsePosition pos)
解析字符串中的文本，以生成一个 Number。
 void setCurrency(Currency currency)
设置格式化货币值时，此数字格式使用的货币。
 void setDecimalFormatSymbols(DecimalFormatSymbols newSymbols)
设置小数格式符号，通常程序员或用户不改变此符号。
 void setDecimalSeparatorAlwaysShown(boolean newValue)
允许设置整数中小数分隔符的行为。
 void setGroupingSize(int newValue)
设置分组大小。
 void setMaximumFractionDigits(int newValue)
设置某个数的小数部分中所允许的最大数字位数。
 void setMaximumIntegerDigits(int newValue)
设置某个数字的整数部分中所允许的最大数字位数。
 void setMinimumFractionDigits(int newValue)
设置某个数的小数部分中所允许的最小数字位数。
 void setMinimumIntegerDigits(int newValue)
设置某个数字的整数部分中所允许的最小数字位数。
 void setMultiplier(int newValue)
设置百分数、千分数和类似格式中使用的乘数。
 void setNegativePrefix(String newValue)
设置负数前缀。
 void setNegativeSuffix(String newValue)
设置负数后缀。
 void setParseBigDecimal(boolean newValue)
设置 parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。
 void setPositivePrefix(String newValue)
设置正数前缀。
 void setPositiveSuffix(String newValue)
设置正数后缀。
 void setRoundingMode(RoundingMode roundingMode)
设置在此 DecimalFormat 中使用的 RoundingMode。
 String toLocalizedPattern()
合成一个表示此 Format 对象当前状态的、已本地化的模式字符串。
 String toPattern()
合成一个表示此 Format 对象当前状态的模式字符串。
从类 java.text.NumberFormat 继承的方法
format, format, getAvailableLocales, getCurrencyInstance, getCurrencyInstance, getInstance, getInstance, getIntegerInstance, getIntegerInstance, getNumberInstance, getNumberInstance, getPercentInstance, getPercentInstance, isGroupingUsed, isParseIntegerOnly, parse, parseObject, setGroupingUsed, setParseIntegerOnly
从类 java.text.Format 继承的方法
format, parseObject
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DecimalFormat

public DecimalFormat()
使用默认模式和默认语言环境的符号创建一个 DecimalFormat。当国际化不是主要的考虑方面时，这是获取 DecimalFormat 的便捷方式。

要为给定的语言环境获取标准的格式，请对 NumberFormat 使用工厂方法，如 getNumberInstance。这些工厂方法将为给定的语言环境返回最适合的 NumberFormat 子类。

另请参见：
NumberFormat.getInstance(),
NumberFormat.getNumberInstance(),
NumberFormat.getCurrencyInstance(),
NumberFormat.getPercentInstance()

DecimalFormat

public DecimalFormat(String pattern)
使用给定的模式和默认语言环境的符号创建一个 DecimalFormat。当国际化不是主要的考虑方面时，这是获取 DecimalFormat 的便捷方式。

要为给定的语言环境获取标准的格式，请对 NumberFormat 使用工厂方法，如 getNumberInstance。这些工厂方法将为给定的语言环境返回最适合的 NumberFormat 子类。

参数：
pattern - 一个非本地化的模式字符串。
抛出：
NullPointerException - 如果 pattern 为 null
IllegalArgumentException - 如果给定的 pattern 无效。
另请参见：
NumberFormat.getInstance(),
NumberFormat.getNumberInstance(),
NumberFormat.getCurrencyInstance(),
NumberFormat.getPercentInstance()

DecimalFormat

public DecimalFormat(String pattern,
                     DecimalFormatSymbols symbols)
使用给定的模式和符号创建一个 DecimalFormat。需要完全自定义格式化的行为时使用此构造方法。

要为给定的语言环境获取标准的格式，请对 NumberFormat 使用工厂方法，如 getInstance 或 getCurrencyInstance。如果只需为标准格式进行微小的调整，则可修改 NumberFormat 工厂方法所返回的格式。

参数：
pattern - 一个非本地化的模式字符串。
symbols - 要使用的符号集
抛出：
NullPointerException - 如果任意给定的参数为 null
IllegalArgumentException - 如果给定的 pattern 无效
另请参见：
NumberFormat.getInstance(),
NumberFormat.getNumberInstance(),
NumberFormat.getCurrencyInstance(),
NumberFormat.getPercentInstance(),
DecimalFormatSymbols
方法详细信息

format

public final StringBuffer format(Object number,
                                 StringBuffer toAppendTo,
                                 FieldPosition pos)
格式化一个数，并将所得文本追加到给定的字符串缓冲区。该数可以是 Number 的任意子类。

此实现使用所允许的最大精度。

覆盖：
类 NumberFormat 中的 format
参数：
number - 要格式化的数
toAppendTo - 将格式化的文本所要追加到的 StringBuffer
pos - 在输入上：如果需要，是一个对齐字段。在输出上：对齐字段的偏移量。
返回：
以 toAppendTo 形式传入的值
抛出：
IllegalArgumentException - 如果 number 为 null 或不是 Number 的一个实例。
NullPointerException - 如果 toAppendTo 或 pos 为 null
ArithmeticException - 如果需要使用设置为 RoundingMode.UNNECESSARY 的舍入模式进行舍入
另请参见：
FieldPosition

format

public StringBuffer format(double number,
                           StringBuffer result,
                           FieldPosition fieldPosition)
格式化一个 double 值，以生成一个字符串。

指定者：
类 NumberFormat 中的 format
参数：
number - 要格式化的 double 值
result - 将文本追加到的地方
fieldPosition - 在输入上：如果需要，是一个对齐字段。在输出上：对齐字段的偏移量。
返回：
已格式化的数字字符串
抛出：
ArithmeticException - 如果需要使用设置为 RoundingMode.UNNECESSARY 的舍入模式进行舍入
另请参见：
FieldPosition

format

public StringBuffer format(long number,
                           StringBuffer result,
                           FieldPosition fieldPosition)
格式化一个 long 值，以生成一个字符串。

指定者：
类 NumberFormat 中的 format
参数：
number - 要格式化的 long 值
result - 将文本追加到的地方
fieldPosition - 在输入上：如果需要，是一个对齐字段。在输出上：对齐字段的偏移量。
返回：
已格式化的数字字符串
抛出：
ArithmeticException - 如果需要使用设置为 RoundingMode.UNNECESSARY 的舍入模式进行舍入
另请参见：
FieldPosition

formatToCharacterIterator

public AttributedCharacterIterator formatToCharacterIterator(Object obj)
格式化一个 Object，以生成一个 AttributedCharacterIterator。可以使用返回的 AttributedCharacterIterator 来生成所得 String，并确定有关所得 String 的信息。

AttributedCharacterIterator 的每个属性键都是 NumberFormat.Field 类型的，属性值与属性键相同。

覆盖：
类 Format 中的 formatToCharacterIterator
参数：
obj - 要格式化的对象
返回：
描述格式化值的 AttributedCharacterIterator。
抛出：
NullPointerException - 如果 obj 为 null。
IllegalArgumentException - Format 无法格式化给定的对象时。
ArithmeticException - 如果需要使用设置为 RoundingMode.UNNECESSARY 的舍入模式进行舍入
从以下版本开始：
1.4

parse

public Number parse(String text,
                    ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

该方法试图解析从 pos 所给定的索引处开始的文本。如果解析成功，则将 pos 的索引更新为所用最后一个字符后面的索引（不一定解析直到字符串末尾的所有字符），并返回解析后的数。可以使用更新后的 pos 指示下一次调用此方法的开始点。如果发生错误，则不更改 pos 的索引，并将 pos 的错误索引设置为发生错误处的字符索引，并且返回 null。

返回的子类取决于 isParseBigDecimal() 的值以及所解析的字符串。

  • 如果 isParseBigDecimal() 为 false（默认值），则以 Long 对象返回多数整数值，而不管其写入方式如何："17" 和 "17.000" 都解析成 Long(17)。不符合 Long 的值则以 Double 的形式返回。这包括有小数部分的值、无穷大的值、NaN 和值 -0.0。DecimalFormat 不 根据源字符串中是否有小数分隔符来决定返回 Double 还是 Long 值。这样做会无法准确地解析导致某个 double 尾数（如 "-9,223,372,036,854,775,808.00"）溢出的整数。

    调用者可能使用 Number 的方法 doubleValue、longValue 等来获取所需类型的数值。

  • 如果 isParseBigDecimal() 为 true，则以 BigDecimal 对象的形式返回值。这些值是由 BigDecimal.BigDecimal(String) 以和语言环境无关的格式为相应字符串所构造的那些值。特殊的情况是正负无穷大和 NaN 值，它们以 Double 实例的形式返回，其中保存了相应的 Double 常量值。

DecimalFormat 解析所有由 Character.digit() 所定义的、表示小数数字的 Unicode 字符。另外，DecimalFormat 也将 DecimalFormatSymbols 对象中所定义的、从已本地化的阿拉伯数字 0 开始的 10 个连续字符识别为阿拉伯数字。

指定者：
类 NumberFormat 中的 parse
参数：
text - 要解析的字符串
pos - 具有索引和上述错误索引信息的 ParsePosition 对象。
返回：
解析得到的值，如果解析失败，则为 null
抛出：
NullPointerException - 如果 text 或 pos 为 null。
另请参见：
NumberFormat.isParseIntegerOnly(), Format.parseObject(java.lang.String, java.text.ParsePosition)

getDecimalFormatSymbols

public DecimalFormatSymbols getDecimalFormatSymbols()
返回小数格式符号的一个副本，通常程序员或用户不改变此副本。

返回：
所需的 DecimalFormatSymbols 的一个副本
另请参见：
DecimalFormatSymbols

setDecimalFormatSymbols

public void setDecimalFormatSymbols(DecimalFormatSymbols newSymbols)
设置小数格式符号，通常程序员或用户不改变此符号。

参数：
newSymbols - 所需的 DecimalFormatSymbols
另请参见：
DecimalFormatSymbols

getPositivePrefix

public String getPositivePrefix()
获取正数前缀。

示例：+123、$123、sFr123

setPositivePrefix

public void setPositivePrefix(String newValue)
设置正数前缀。

示例：+123、$123、sFr123

getNegativePrefix

public String getNegativePrefix()
获取负数前缀。

示例：-123、($123)（带有负数后缀）、sFr-123

setNegativePrefix

public void setNegativePrefix(String newValue)
设置负数前缀。

示例：-123、($123)（带有负数后缀）、sFr-123

getPositiveSuffix

public String getPositiveSuffix()
获取正数后缀。

示例： 123%

setPositiveSuffix

public void setPositiveSuffix(String newValue)
设置正数后缀。

示例：123%

getNegativeSuffix

public String getNegativeSuffix()
获取负数后缀。

示例：-123%、($123)（带有正数后缀）

setNegativeSuffix

public void setNegativeSuffix(String newValue)
设置负数后缀。

示例： 123%

getMultiplier

public int getMultiplier()
获取百分数、千分数和类似格式中使用的乘数。

另请参见：
setMultiplier(int)

setMultiplier

public void setMultiplier(int newValue)
设置百分数、千分数和类似格式中使用的乘数。对于百分数格式，将该乘数设置为 100 并将后缀设置为 '%'（对于阿拉伯语，请使用阿拉伯语的百分数符号）。对于千分数格式，将该乘数设置为 1000 并将后缀设置为 '\u2030'。

示例：使用乘数 100 时，1.23 被格式化为 "123"，"123" 则被解析为 1.23。

另请参见：
getMultiplier()

getGroupingSize

public int getGroupingSize()
返回分组大小。分组大小是数的整数部分中分组分隔符之间的数字位数。例如在数 "123,456.78" 中，分组大小是 3。

另请参见：
setGroupingSize(int), NumberFormat.isGroupingUsed(), DecimalFormatSymbols.getGroupingSeparator()

setGroupingSize

public void setGroupingSize(int newValue)
设置分组大小。分组大小是数的整数部分中分组分隔符之间的数字位数。例如在数 "123,456.78" 中，分组大小是 3。
传入的值被转换为 一个字节，这可能导致信息丢失。

另请参见：
getGroupingSize(),
NumberFormat.setGroupingUsed(boolean),
DecimalFormatSymbols.setGroupingSeparator(char)

isDecimalSeparatorAlwaysShown

public boolean isDecimalSeparatorAlwaysShown()
允许获取整数中小数分隔符的行为。（有小数时始终显示小数分隔符。）

示例：小数 ON： 12345 -> 12345.; OFF: 12345 -> 12345

setDecimalSeparatorAlwaysShown

public void setDecimalSeparatorAlwaysShown(boolean newValue)
允许设置整数中小数分隔符的行为。（有小数时始终显示小数分隔符。）

示例：小数 ON： 12345 -> 12345.; OFF: 12345 -> 12345

isParseBigDecimal

public boolean isParseBigDecimal()
返回 parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。默认值为 false。

从以下版本开始：
1.5
另请参见：
setParseBigDecimal(boolean)

setParseBigDecimal

public void setParseBigDecimal(boolean newValue)
设置 parse(java.lang.String, java.text.ParsePosition) 方法是否返回 BigDecimal。

从以下版本开始：
1.5
另请参见：
isParseBigDecimal()

clone

public Object clone()
标准重写；没有语义上的变化。

覆盖：
类 NumberFormat 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

equals

public boolean equals(Object obj)
重写 equals

覆盖：
类 NumberFormat 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
重写 hashCode

覆盖：
类 NumberFormat 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toPattern

public String toPattern()
合成一个表示此 Format 对象当前状态的模式字符串。

另请参见：
applyPattern(java.lang.String)

toLocalizedPattern

public String toLocalizedPattern()
合成一个表示此 Format 对象当前状态的、已本地化的模式字符串。

另请参见：
applyPattern(java.lang.String)

applyPattern

public void applyPattern(String pattern)
将给定的模式应用于此 Format 对象。模式是各种格式化属性的简写规范。也可以通过各种设置方法来单独改变这些属性。

对此例程所设置的整数位数没有限制，因为这通常是终端用户的需要；如果想设置某个实际值，请使用 setMaximumInteger。对于负数，可使用由分号分隔的第二个模式。

示例 "#,#00.0#" -> 1,234.56

这意味着最少 2 个整数位数、1 个小数位数，以及最多 2 个小数位数。

示例："#,#00.0#;(#,#00.0#)"，括号中的内容用于负数。

在负数模式中，忽略最小和最大计数；在正数模式中假定要设置这些计数。

抛出：
NullPointerException - 如果 pattern 为 null
IllegalArgumentException - 如果给定的 pattern 无效。

applyLocalizedPattern

public void applyLocalizedPattern(String pattern)
将给定的模式应用于此 Format 对象。假定该 pattern 以本地化表示法来表示。模式是各种格式化属性的简写规范。也可以通过各种设置方法来单独改变这些属性。

对此例程所设置的整数位数没有限制，因为这通常是终端用户的需要；如果想设置某个实际值，请使用 setMaximumInteger。对于负数，可使用由分号分隔的第二个模式

示例 "#,#00.0#" -> 1,234.56

这意味着最少 2 个整数位数、1 个小数位数，以及最多 2 个小数位数。

示例："#,#00.0#;(#,#00.0#)"，括号中的内容用于负数。

在负数模式中，忽略最小和最大计数；在正数模式中假定要设置这些计数。

抛出：
NullPointerException - 如果 pattern 为 null
IllegalArgumentException - 如果给定的 pattern 无效。

setMaximumIntegerDigits

public void setMaximumIntegerDigits(int newValue)
设置某个数字的整数部分中所允许的最大数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数字，则使用 newValue 的低位部分和 309。用 0 替换负数输入值。

覆盖：
类 NumberFormat 中的 setMaximumIntegerDigits
参数：
newValue - 要显示的最大整数位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
NumberFormat.setMaximumIntegerDigits(int)

setMinimumIntegerDigits

public void setMinimumIntegerDigits(int newValue)
设置某个数字的整数部分中所允许的最小数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数字，则使用 newValue 的低位部分和 309。用 0 替换负数输入值。

覆盖：
类 NumberFormat 中的 setMinimumIntegerDigits
参数：
newValue - 要显示的整数的最小位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
NumberFormat.setMinimumIntegerDigits(int)

setMaximumFractionDigits

public void setMaximumFractionDigits(int newValue)
设置某个数的小数部分中所允许的最大数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数字，则使用 newValue 的低位部分和 340。用 0 替换负数输入值。

覆盖：
类 NumberFormat 中的 setMaximumFractionDigits
参数：
newValue - 要显示的小数的最大位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
NumberFormat.setMaximumFractionDigits(int)

setMinimumFractionDigits

public void setMinimumFractionDigits(int newValue)
设置某个数的小数部分中所允许的最小数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数字，则使用 newValue 的低位部分和 340。用 0 替换负数输入值。

覆盖：
类 NumberFormat 中的 setMinimumFractionDigits
参数：
newValue - 要显示的小数的最小位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
NumberFormat.setMinimumFractionDigits(int)

getMaximumIntegerDigits

public int getMaximumIntegerDigits()
获取某个数的整数部分中所允许的最大数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数字，则使用返回值的低位部分和 309。

覆盖：
类 NumberFormat 中的 getMaximumIntegerDigits
另请参见：
setMaximumIntegerDigits(int)

getMinimumIntegerDigits

public int getMinimumIntegerDigits()
获取某个数的整数部分中所允许的最小数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数字，则使用返回值的低位部分和 309。

覆盖：
类 NumberFormat 中的 getMinimumIntegerDigits
另请参见：
setMinimumIntegerDigits(int)

getMaximumFractionDigits

public int getMaximumFractionDigits()
获取某个数的小数部分中所允许的最大数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数，则使用返回值的低位部分和 340。

覆盖：
类 NumberFormat 中的 getMaximumFractionDigits
另请参见：
setMaximumFractionDigits(int)

getMinimumFractionDigits

public int getMinimumFractionDigits()
获取某个数的小数部分中所允许的最小数字位数。如需格式化除 BigInteger 和 BigDecimal 对象之外的数，则使用返回值的低位部分和 340。

覆盖：
类 NumberFormat 中的 getMinimumFractionDigits
另请参见：
setMinimumFractionDigits(int)

getCurrency

public Currency getCurrency()
获取格式化货币值时，此十进制格式使用的货币。通过在此数字格式的符号上调用 DecimalFormatSymbols.getCurrency 来获取该货币。

覆盖：
类 NumberFormat 中的 getCurrency
返回：
此十进制格式使用的货币，或者为 null
从以下版本开始：
1.4

setCurrency

public void setCurrency(Currency currency)
设置格式化货币值时，此数字格式使用的货币。这不会更新该数字格式使用的最小和最大小数位数。通过在此数字格式的符号上调用 DecimalFormatSymbols.setCurrency 来设置该货币。

覆盖：
类 NumberFormat 中的 setCurrency
参数：
currency - 此十进制格式要使用的新货币
抛出：
NullPointerException - 如果 currency 为 null
从以下版本开始：
1.4

getRoundingMode

public RoundingMode getRoundingMode()
获取在此 DecimalFormat 中使用的 RoundingMode。

覆盖：
类 NumberFormat 中的 getRoundingMode
返回：
用于此 DecimalFormat 的 RoundingMode。
从以下版本开始：
1.6
另请参见：
setRoundingMode(RoundingMode)

setRoundingMode

public void setRoundingMode(RoundingMode roundingMode)
设置在此 DecimalFormat 中使用的 RoundingMode。

覆盖：
类 NumberFormat 中的 setRoundingMode
参数：
roundingMode - 要使用的 RoundingMode
抛出：
NullPointerException - 如果 roundingMode 为 null。
从以下版本开始：
1.6
另请参见：
getRoundingMode()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Format (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 Format

java.lang.Object
    继承者  java.text.Format
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
DateFormat, MessageFormat, NumberFormat
public abstract class Format
extends Object
implements Serializable, Cloneable

Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。

Format 定义了编程接口，用于将语言环境敏感的对象格式化为 String（使用 format 方法）和将 String 重新解析为对象（使用 parseObject 方法）。

通常，一个 format 的 parseObject 方法必须能解析任何由其 format 方法格式化的字符串。不过，也可能存在不能解析的异常情况。例如，format 方法可能创建中间无分隔符的两个相邻整数，在这种情况下，parseObject 无法判断哪个数字属于哪个数。

子类化

Java 平台为格式化日期、消息和数字分别提供了三个特殊的 Format 的子类：DateFormat、MessageFormat 和 NumberFormat。

具体的子类必须实现三个方法：

  1. format(Object obj, StringBuffer toAppendTo, FieldPosition pos)
  2. formatToCharacterIterator(Object obj)
  3. parseObject(String source, ParsePosition pos)
这些常规方法允许对对象进行多态解析和格式化，还可以被使用（如被 MessageFormat 使用）。子类通常也为特定的输入类型提供了另外的 format 方法，也为特定的结果类型提供了 parse 方法。当在输入文本的开始没有任何所需格式的文本时，则任何不带 ParsePosition 参数的 parse 方法都应该抛出 ParseException。

大多数子类还将实现以下工厂方法：

  1. getInstance 获取一个适合于当前语言环境的有用的格式对象
  2. getInstance(Locale) 获取一个适合于指定语言环境的有用的格式对象。
此外，某些子类还可能为了更特殊的控制实现其它 getXxxxInstance 方法。例如，NumberFormat 类提供了 getPercentInstance 和 getCurrencyInstance 方法来获取特殊的数字格式器。

Format 的子类如果允许程序员能为不同语言环境（比如用 getInstance(Locale) ）创建对象，必须实现以下类方法：

 public static Locale[] getAvailableLocales()

最后子类定义一个常量集合来标识格式输出中的不同字段。这些常量用于创建一个 FieldPosition 对象，该对象标识字段中所包含的信息及其在格式化结果中的位置。这些常量应当命名为item _FIELD，其中item 标识了该字段。有关这些常量的例子，请参阅 ERA_FIELD 及其在 DateFormat 中的同类。

同步

格式通常不是同步的。建议为每个线程创建独立的格式实例。如果多个线程同时访问一个格式，其它必须保持外部同步。

另请参见：
ParsePosition, FieldPosition, NumberFormat, DateFormat, MessageFormat, 序列化表格

嵌套类摘要
static class Format.Field
定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
构造方法摘要
protected Format()
单独的构造方法。
方法摘要
Object | clone() 创建并返回此对象的一个副本。
String | format(Object obj) 格式化一个对象以生成一个字符串。
abstract StringBuffer | format(Object obj, StringBuffer toAppendTo, FieldPosition pos) 格式化一个对象，并将得到的文本添加到给定的字符缓冲区。
AttributedCharacterIterator | formatToCharacterIterator(Object obj) 格式化一个对象，生成一个 AttributedCharacterIterator。
Object | parseObject(String source) 从给定字符串的开始处解析文本以生成一个对象。
abstract Object | parseObject(String source, ParsePosition pos) 解析字符串文本，生成一个对象。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Format

protected Format()
单独的构造方法。（由子类的构造方法调用，通常是隐式的。）

方法详细信息

format

public final String format(Object obj)
格式化一个对象以生成一个字符串。这等效于
format (obj, new StringBuffer(), new FieldPosition(0)).toString();

参数：
obj - 要格式化的对象
返回：
格式化后的字符串。
抛出：
IllegalArgumentException - 如果该 Format 不能格式化给定的对象

format

public abstract StringBuffer format(Object obj,
                                    StringBuffer toAppendTo,
                                    FieldPosition pos)
格式化一个对象，并将得到的文本添加到给定的字符缓冲区。如果 pos 参数标识了一个由 format 使用的字段，那么其索引就设置为第一次出现的此类字段的起始和结束索引。

参数：
obj - 要格式化的对象
toAppendTo - 文本要添加的位置
pos - 标识格式化文本中字段的一个 FieldPosition。
返回：
添加了格式化文本并作为 toAppendTo 传入的字符串缓冲区
抛出：
NullPointerException - 如果 toAppendTo 或 pos 为 null
IllegalArgumentException - 如果 Format 不能格式化给定的对象

formatToCharacterIterator

public AttributedCharacterIterator formatToCharacterIterator(Object obj)
格式化一个对象，生成一个 AttributedCharacterIterator。可以使用返回的 AttributedCharacterIterator 来生成得到的 String，并确定与得到的 String 有关的信息。

AttributedCharacterIterator 的每一个属性键都是 Field 类型的。由每个 Format 实现为 AttributedCharacterIterator 中的每个属性定义其合法值，但是通常属性键也用作属性值。

默认的实现创建了一个没有任何属性的 AttributedCharacterIterator。支持字段的子类应该重写此方法并创建一个具有有意义属性的 AttributedCharacterIterator。

参数：
obj - 要格式化的对象
返回：
描述格式化值的 AttributedCharacterIterator。
抛出：
NullPointerException - 如果 obj 为 null。
IllegalArgumentException - 如果该 Format 无法格式化给定的对象。
从以下版本开始：
1.4

parseObject

public abstract Object parseObject(String source,
                                   ParsePosition pos)
解析字符串文本，生成一个对象。

此方法试图解析从 pos 给定索引处开始的文本。如果解析成功，则将 pos 的索引更新到使用的最后一个字符之后的索引（不一定要解析直到字符串末尾的所有字符），并返回解析后的对象。更新的 pos 可以用来指示下一次调用此方法的起始点。如果发生错误，则不更改 pos 的索引，将 pos 的错误索引设置为错误发生处的字符的索引，并返回 null。

参数：
source - 其中一部分应该被解析的 String。
pos - 具有上面所描述的索引和错误索引信息的一个 ParsePosition 对象。
返回：
从字符串解析的一个 Object。如果有错误，返回 null。
抛出：
NullPointerException - 如果 pos 为 null。

parseObject

public Object parseObject(String source)
                   throws ParseException
从给定字符串的开始处解析文本以生成一个对象。此方法不可以使用给定字符串的全部文本。

参数：
source - 必须解析其开头的 String。
返回：
从字符串进行解析的一个 Object。
抛出：
ParseException - 如果无法解析指定字符串的开头。

clone

public Object clone()
创建并返回此对象的一个副本。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DecimalFormatSymbols (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 DecimalFormatSymbols

java.lang.Object
    继承者  java.text.DecimalFormatSymbols
所有已实现的接口：
Serializable, Cloneable
public class DecimalFormatSymbols
extends Object
implements Cloneable, Serializable

此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。DecimalFormat 根据其语言环境数据为其自身创建一个 DecimalFormatSymbols 实例。如果需要更改这些符号，可从 DecimalFormat 获得 DecimalFormatSymbols 对象并修改它。

另请参见：
Locale, DecimalFormat, 序列化表格

构造方法摘要
DecimalFormatSymbols()
为默认的语言环境创建一个 DecimalFormatSymbols 对象。
DecimalFormatSymbols(Locale locale)
为给定的语言环境创建一个 DecimalFormatSymbols 对象。
方法摘要
Object | clone() 标准重写。
boolean | equals(Object obj) 重写 equals。
static Locale[] | getAvailableLocales() 返回一个数组，它包括所有此类的 getInstance 方法可为之返回本地化实例的语言环境。
Currency | getCurrency() 获得这些 DecimalFormatSymbols 的货币。
String | getCurrencySymbol() 返回这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。
char | getDecimalSeparator() 获得用于十进制符号的字符。
char | getDigit() 获得用于某种模式中数字的字符。
String | getExponentSeparator() 返回用于分隔尾数和指数的字符串。
char | getGroupingSeparator() 获得用于千位分隔符的字符。
String | getInfinity() 获得用于表示无穷大的字符串。
static DecimalFormatSymbols | getInstance() 获取默认语言环境的 DecimalFormatSymbols 实例。
static DecimalFormatSymbols | getInstance(Locale locale) 获取指定语言环境的 DecimalFormatSymbols 实例。
String | getInternationalCurrencySymbol() 返回这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。
char | getMinusSign() 获得用于表示减号的字符。
char | getMonetaryDecimalSeparator() 返回货币小数点分隔符。
String | getNaN() 获得用于表示“非数字”的字符串。
char | getPatternSeparator() 获得用于在模式中分隔正数和负数子模式的字符。
char | getPercent() 获得用于百分数符号的字符。
char | getPerMill() 获得用于千分数符号的字符。
char | getZeroDigit() 获得用于零的字符。
int | hashCode() 重写 hashCode。
void | setCurrency(Currency currency) 设置这些 DecimalFormatSymbols 的货币。
void | setCurrencySymbol(String currency) 设置这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。
void | setDecimalSeparator(char decimalSeparator) 设置用于十进制符号的字符。
void | setDigit(char digit) 设置用于某种模式中数字的字符。
void | setExponentSeparator(String exp) 设置用于分隔尾数和指数的字符串。
void | setGroupingSeparator(char groupingSeparator) 设置用于千位分隔符的字符。
void | setInfinity(String infinity) 设置用于表示无穷大的字符串。
void | setInternationalCurrencySymbol(String currencyCode) 设置这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。
void | setMinusSign(char minusSign) 设置用于表示减号的字符。
void | setMonetaryDecimalSeparator(char sep) 设置货币小数点分隔符。
void | setNaN(String NaN) 设置用于表示“非数字”的字符串。
void | setPatternSeparator(char patternSeparator) 设置用于在模式中分隔正数和负数子模式的字符。
void | setPercent(char percent) 设置用于百分数符号的字符。
void | setPerMill(char perMill) 设置用于千分数符号的字符。
void | setZeroDigit(char zeroDigit) 设置用于零的字符。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DecimalFormatSymbols

public DecimalFormatSymbols()
为默认的语言环境创建一个 DecimalFormatSymbols 对象。此构造方法只能为 Java 运行时环境所支持的语言环境构造实例，而不能为那些已安装的 DecimalFormatSymbolsProvider 实现所支持的语言环境构造实例。要覆盖所有语言环境，请使用 getInstance 方法。

DecimalFormatSymbols

public DecimalFormatSymbols(Locale locale)
为给定的语言环境创建一个 DecimalFormatSymbols 对象。此构造方法只能为 Java 运行时环境所支持的语言环境构造实例，而不能为那些已安装的 DecimalFormatSymbolsProvider 实现所支持的语言环境构造实例。要覆盖所有语言环境，请使用 getInstance 方法。

抛出：
NullPointerException - 如果 locale 为 null
方法详细信息

getAvailableLocales

public static Locale[] getAvailableLocales()
返回一个数组，它包括所有此类的 getInstance 方法可为之返回本地化实例的语言环境。返回的数组表示 Java 运行时和已安装的 DecimalFormatSymbolsProvider 实现所支持的语言环境的并集。返回的数组必须至少包含一个等同于 Locale.US 的 Locale 实例。

返回：
可获得其本地化 DecimalFormatSymbols 实例的语言环境数组。
从以下版本开始：
1.6

getInstance

public static final DecimalFormatSymbols getInstance()
获取默认语言环境的 DecimalFormatSymbols 实例。此方法为 Java 运行时本身以及已安装的 DecimalFormatSymbolsProvider 实现所支持的语言环境提供对 DecimalFormatSymbols 实例的访问。

返回：
一个 DecimalFormatSymbols 实例。
从以下版本开始：
1.6

getInstance

public static final DecimalFormatSymbols getInstance(Locale locale)
获取指定语言环境的 DecimalFormatSymbols 实例。此方法为 Java 运行时本身以及已安装的 DecimalFormatSymbolsProvider 实现所支持的语言环境提供对 DecimalFormatSymbols 实例的访问。

参数：
locale - 所需的语言环境。
返回：
一个 DecimalFormatSymbols 实例。
抛出：
NullPointerException - 如果 locale 为 null
从以下版本开始：
1.6

getZeroDigit

public char getZeroDigit()
获得用于零的字符。用于阿拉伯语等的该字符不同。

setZeroDigit

public void setZeroDigit(char zeroDigit)
设置用于零的字符。用于阿拉伯语等的该字符不同。

getGroupingSeparator

public char getGroupingSeparator()
获得用于千位分隔符的字符。用于法语等的该字符不同。

setGroupingSeparator

public void setGroupingSeparator(char groupingSeparator)
设置用于千位分隔符的字符。用于法语等的该字符不同。

getDecimalSeparator

public char getDecimalSeparator()
获得用于十进制符号的字符。用于法语等的该字符不同。

setDecimalSeparator

public void setDecimalSeparator(char decimalSeparator)
设置用于十进制符号的字符。用于法语等的该字符不同。

getPerMill

public char getPerMill()
获得用于千分数符号的字符。用于阿拉伯语等的该字符不同。

setPerMill

public void setPerMill(char perMill)
设置用于千分数符号的字符。用于阿拉伯语等的该字符不同。

getPercent

public char getPercent()
获得用于百分数符号的字符。用于阿拉伯语等的该字符不同。

setPercent

public void setPercent(char percent)
设置用于百分数符号的字符。用于阿拉伯语等的该字符不同。

getDigit

public char getDigit()
获得用于某种模式中数字的字符。

setDigit

public void setDigit(char digit)
设置用于某种模式中数字的字符。

getPatternSeparator

public char getPatternSeparator()
获得用于在模式中分隔正数和负数子模式的字符。

setPatternSeparator

public void setPatternSeparator(char patternSeparator)
设置用于在模式中分隔正数和负数子模式的字符。

getInfinity

public String getInfinity()
获得用于表示无穷大的字符串。几乎总是保持不变。

setInfinity

public void setInfinity(String infinity)
设置用于表示无穷大的字符串。几乎总是保持不变。

getNaN

public String getNaN()
获得用于表示“非数字”的字符串。几乎总是保持不变。

setNaN

public void setNaN(String NaN)
设置用于表示“非数字”的字符串。几乎总是保持不变。

getMinusSign

public char getMinusSign()
获得用于表示减号的字符。如果未指定显式的负数格式，则通过将 minusSign 作为正数格式的前缀来形成一个负数格式。

setMinusSign

public void setMinusSign(char minusSign)
设置用于表示减号的字符。如果未指定显式的负数格式，则通过将 minusSign 作为正数格式的前缀来形成一个负数格式。

getCurrencySymbol

public String getCurrencySymbol()
返回这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。

从以下版本开始：
1.2

setCurrencySymbol

public void setCurrencySymbol(String currency)
设置这些 DecimalFormatSymbols 货币在其语言环境中的货币符号。

从以下版本开始：
1.2

getInternationalCurrencySymbol

public String getInternationalCurrencySymbol()
返回这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。

从以下版本开始：
1.2

setInternationalCurrencySymbol

public void setInternationalCurrencySymbol(String currencyCode)
设置这些 DecimalFormatSymbols 货币的 ISO 4217 货币代码。如果货币代码有效（如 Currency.getInstance 所定义的），则此方法还为相应的 Currency 实例设置货币属性，并为 DecimalFormatSymbols 语言环境中的货币符号设置货币符号属性。如果货币代码无效，则将货币属性设置为 null，并且不修改货币符号属性。

从以下版本开始：
1.2
另请参见：
setCurrency(java.util.Currency), setCurrencySymbol(java.lang.String)

getCurrency

public Currency getCurrency()
获得这些 DecimalFormatSymbols 的货币。如果以前将货币符号属性设置为不是有效 ISO 4217 货币代码的值，则可能为 null。

返回：
使用的货币，或者为 null
从以下版本开始：
1.4

setCurrency

public void setCurrency(Currency currency)
设置这些 DecimalFormatSymbols 的货币。这还为 DecimalFormatSymbols 语言环境中的货币符号设置了货币符号属性，并为该货币的 ISO 4217 货币代码设置了国际货币符号。

参数：
currency - 要使用的新货币
抛出：
NullPointerException - 如果 currency 为 null
从以下版本开始：
1.4
另请参见：
setCurrencySymbol(java.lang.String), setInternationalCurrencySymbol(java.lang.String)

getMonetaryDecimalSeparator

public char getMonetaryDecimalSeparator()
返回货币小数点分隔符。

从以下版本开始：
1.2

setMonetaryDecimalSeparator

public void setMonetaryDecimalSeparator(char sep)
设置货币小数点分隔符。

从以下版本开始：
1.2

getExponentSeparator

public String getExponentSeparator()
返回用于分隔尾数和指数的字符串。示例：1.23x10^4 中的 "x10^"，1.23E4 中的 "E" 。

返回：
指数分隔符字符串
从以下版本开始：
1.6
另请参见：
setExponentSeparator(java.lang.String)

setExponentSeparator

public void setExponentSeparator(String exp)
设置用于分隔尾数和指数的字符串。示例：1.23x10^4 中的 "x10^"，1.23E4 中的 "E" 。

参数：
exp - 指数分隔符字符串
抛出：
NullPointerException - 如果 exp 为 null
从以下版本开始：
1.6
另请参见：
getExponentSeparator()

clone

public Object clone()
标准重写。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

equals

public boolean equals(Object obj)
重写 equals。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
重写 hashCode。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FieldPosition (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 FieldPosition

java.lang.Object
    继承者  java.text.FieldPosition

public class FieldPosition
extends Object

FieldPosition 是 Format 及其子类用于在格式输出中标识字段的简单类。字段可以通过两种方式标识：

  • 通过一个其名称通常以 _FIELD 结尾的整型常量。这些常量在 Format 的不同子类中定义。
  • 通过一个 Format.Field 常量，有关例子，请参阅 DateFormat 中的 ERA_FIELD 及其同类。

FieldPosition 保持对格式输出中字段位置的两个索引进行跟踪：字段的第一个字符的索引和字段的最后一个字符的索引。

不同的 Format 类中的 format 方法需要一个 FieldPosition 对象作为参数。使用此 format 方法执行部分格式化或者以获取格式化输出的信息（比如字段位置）。

如果对格式化字符串中所有属性的位置感兴趣，请使用 Format 的方法 formatToCharacterIterator。

另请参见：
Format

构造方法摘要
FieldPosition(Format.Field attribute)
为给定的字段常量创建一个 FieldPosition 对象。
FieldPosition(Format.Field attribute, int fieldID)
为给定的字段创建一个 FieldPosition 对象。
FieldPosition(int field)
为给定字段创建一个 FieldPosition 对象。
方法摘要
boolean | equals(Object obj) 重写 equals
int | getBeginIndex() 获取请求字段中第一个字符的索引。
int | getEndIndex() 获取紧跟请求字段中最后一个字符的字符索引。
int | getField() 获取字段的标识符。
Format.Field | getFieldAttribute() 以来自 Field 子类之一的属性常量返回该字段的标识符。
int | hashCode() 返回此 FieldPosition 的哈希码。
void | setBeginIndex(int bi) 设置起始索引。
void | setEndIndex(int ei) Sets the end index.由 Format 的子类使用。
String | toString() 返回此 FieldPosition 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

FieldPosition

public FieldPosition(int field)
为给定字段创建一个 FieldPosition 对象。字段由常量标识，在不同的 Format 子类中，常量名称一般以 _FIELD 结尾。

另请参见：
NumberFormat.INTEGER_FIELD, NumberFormat.FRACTION_FIELD, DateFormat.YEAR_FIELD, DateFormat.MONTH_FIELD

FieldPosition

public FieldPosition(Format.Field attribute)
为给定的字段常量创建一个 FieldPosition 对象。字段由不同 Format 子类中定义的常量来标识。这等效于调用 new FieldPosition(attribute, -1)。

参数：
attribute - 标识一个字段的 Format.Field 常量
从以下版本开始：
1.4

FieldPosition

public FieldPosition(Format.Field attribute,
                     int fieldID)
为给定的字段创建一个 FieldPosition 对象。字段由来自 Field 的子类之一的属性常量以及一个由 Format 的子类定义的整型字段 ID 标识。当 attribute 不为 null 时，需要使用 Field 的 Format 子类应当优先考虑 attribute 而忽略 fieldID。不过，旧的 Format 子类可能不知道 Field 而依靠 fieldID。如果该字段没有相应的整型常量，则 fieldID 应为 -1。

参数：
attribute - 标识一个字段的 Format.Field 常量
fieldID - 标识一个字段的整型常量
从以下版本开始：
1.4
方法详细信息

getFieldAttribute

public Format.Field getFieldAttribute()
以来自 Field 子类之一的属性常量返回该字段的标识符。如果该字段仅由一个整型字段 ID 指定时，可能返回 null。

返回：
该字段的标识符
从以下版本开始：
1.4

getField

public int getField()
获取字段的标识符。

getBeginIndex

public int getBeginIndex()
获取请求字段中第一个字符的索引。

getEndIndex

public int getEndIndex()
获取紧跟请求字段中最后一个字符的字符索引。

setBeginIndex

public void setBeginIndex(int bi)
设置起始索引。由 Format 的子类使用。

从以下版本开始：
1.2

setEndIndex

public void setEndIndex(int ei)
Sets the end index.由 Format 的子类使用。

从以下版本开始：
1.2

equals

public boolean equals(Object obj)
重写 equals

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 FieldPosition 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 FieldPosition 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Format.Field (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 Format.Field

java.lang.Object
    继承者  java.text.AttributedCharacterIterator.Attribute
        继承者  java.text.Format.Field
所有已实现的接口：
Serializable
直接已知子类：
DateFormat.Field, MessageFormat.Field, NumberFormat.Field
正在封闭类：
Format
public static class Format.Field
extends AttributedCharacterIterator.Attribute

定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
从类 java.text.AttributedCharacterIterator.Attribute 继承的字段
INPUT_METHOD_SEGMENT, LANGUAGE, READING
构造方法摘要
protected Format.Field(String name)
创建具有指定名称的 Field。
方法摘要
从类 java.text.AttributedCharacterIterator.Attribute 继承的方法
equals, getName, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Format.Field

protected Format.Field(String name)
创建具有指定名称的 Field。

参数：
name - 属性的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 MessageFormat

java.lang.Object
    继承者  java.text.Format
        继承者  java.text.MessageFormat
所有已实现的接口：
Serializable, Cloneable
public class MessageFormat
extends Format

MessageFormat 提供了以与语言无关方式生成连接消息的方式。使用此方法构造向终端用户显示的消息。

MessageFormat 获取一组对象，格式化这些对象，然后将格式化后的字符串插入到模式中的适当位置。

注：MessageFormat 不同于其他 Format 类，因为 MessageFormat 对象是用其构造方法之一创建的（而不是使用 getInstance 样式的工厂方法创建的）。工厂方法不是必需的，因为 MessageFormat 本身不实现特定于语言环境的行为。特定于语言环境的行为是由所提供的模式和用于已插入参数的子格式来定义的。

模式及其解释

MessageFormat 使用以下形式的模式：
 MessageFormatPattern:
         String
         MessageFormatPattern FormatElement String

 FormatElement:
         { ArgumentIndex }
         { ArgumentIndex , FormatType }
         { ArgumentIndex , FormatType , FormatStyle }

 FormatType: one of
         number date time choice

 FormatStyle:
         short
         medium
         long
         full
         integer
         currency
         percent
         SubformatPattern

 String:
         StringPartopt
         String StringPart

 StringPart:
         ''
         ' QuotedString '
         UnquotedString

 SubformatPattern:
         SubformatPatternPartopt
         SubformatPattern SubformatPatternPart

 SubFormatPatternPart:
         ' QuotedPattern '
         UnquotedPattern

在 String 中，"''" 表示单引号。QuotedString 可以包含除单引号之外的任意字符；围绕的单引号被移除。UnquotedString 可以包含除单引号和左花括号之外的任意字符。因此，格式化后消息字符串为 "'{0}'" 的字符串可以写作 "'''{'0}''" 或 "'''{0}'''"。

在 SubformatPattern 中，应用了不同的规则。QuotedPattern 可包含除单引号之外的任意字符，但不 移除围绕的单引号，因此它们可以由子格式解释。例如，"{1,number,$'#',##}" 将产生一个带井号的数字格式，结果如："$#31,45"。 UnquotedPattern 可以包含除单引号之外的任意字符，但其中的花括号必须成对出现。例如，"ab {0} de" 和 "ab '}' de" 是有效的子格式模式，而 "ab {0'}' de" 和 "ab } de" 则是无效的。

警告：
不过，在消息格式模式中使用引号的规则在一定程度上显示混乱。尤其是，本地化程序并不总是清楚单引号是否需要成对。要确保通知本地化程序关于规则的信息，并告诉它们（例如，通过使用资源包源文件中的注释）MessageFormat 将处理哪些字符串。注意，本地化程序在转换后的字符串中必须使用单引号，其中原始版本不包含单引号。

ArgumentIndex 值是使用数字 '0' 到 '9' 表示的非负整数，它表示传递给 format 方法的 arguments 数组的一个索引，或者表示由 parse 方法返回的结果数组的一个索引。

FormatType 和 FormatStyle 值用来创建格式元素的 Format 实例。下表显示了值如何映射到 Format 实例。表中没有显示的组合是非法的。SubformatPattern 必须是所使用的 Format 子类的一个有效的模式字符串。

格式类型 | 格式样式 | 创建的子格式
无 | 无 | null
number | 无 | NumberFormat.getInstance(getLocale())
 | integer | NumberFormat.getIntegerInstance(getLocale())
 | currency | NumberFormat.getCurrencyInstance(getLocale())
 | percent | NumberFormat.getPercentInstance(getLocale())
 | SubformatPattern | new DecimalFormat(subformatPattern, DecimalFormatSymbols.getInstance(getLocale()))
date | 无 | DateFormat.getDateInstance(DateFormat.DEFAULT, getLocale())
 | short | DateFormat.getDateInstance(DateFormat.SHORT, getLocale())
 | medium | DateFormat.getDateInstance(DateFormat.DEFAULT, getLocale())
 | long | DateFormat.getDateInstance(DateFormat.LONG, getLocale())
 | full | DateFormat.getDateInstance(DateFormat.FULL, getLocale())
 | SubformatPattern | new SimpleDateFormat(subformatPattern, getLocale())
time | 无 | DateFormat.getTimeInstance(DateFormat.DEFAULT, getLocale())
 | short | DateFormat.getTimeInstance(DateFormat.SHORT, getLocale())
 | medium | DateFormat.getTimeInstance(DateFormat.DEFAULT, getLocale())
 | long | DateFormat.getTimeInstance(DateFormat.LONG, getLocale())
 | full | DateFormat.getTimeInstance(DateFormat.FULL, getLocale())
 | SubformatPattern | new SimpleDateFormat(subformatPattern, getLocale())
choice | SubformatPattern | new ChoiceFormat(subformatPattern)

用法信息

下面给出一些用法例子。当然，在实际的国际化程序中，消息格式模式和其他静态字符串将从资源包中获取。其他参数在运行时动态确定。

第一个例子使用静态的方法 MessageFormat.format，它在内部创建一个只使用一次的 MessageFormat：

 int planet = 7;
 String event = "a disturbance in the Force";

 String result = MessageFormat.format(
     "At {1,time} on {1,date}, there was {2} on planet {0,number,integer}.",
     planet, new Date(), event);
输出为：
 At 12:30 PM on Jul 3, 2053, there was a disturbance in the Force on planet 7.

下面的例子创建了一个可以重复使用的 MessageFormat 实例：

 int fileCount = 1273;
 String diskName = "MyDisk";
 Object[] testArgs = {new Long(fileCount), diskName};

 MessageFormat form = new MessageFormat(
     "The disk \"{1}\" contains {0} file(s).");

 System.out.println(form.format(testArgs));
不同 fileCount 值的输出：
 The disk "MyDisk" contains 0 file(s).
 The disk "MyDisk" contains 1 file(s).
 The disk "MyDisk" contains 1,273 file(s).

对于更复杂的模式，可以使用 ChoiceFormat 来生成正确的单数和复数形式：

 MessageFormat form = new MessageFormat("The disk \"{1}\" contains {0}.");
 double[] filelimits = {0,1,2};
 String[] filepart = {"no files","one file","{0,number} files"};
 ChoiceFormat fileform = new ChoiceFormat(filelimits, filepart);
 form.setFormatByArgumentIndex(0, fileform);

 int fileCount = 1273;
 String diskName = "MyDisk";
 Object[] testArgs = {new Long(fileCount), diskName};

 System.out.println(form.format(testArgs));
不同的 fileCount 值的输出：
 The disk "MyDisk" contains no files.
 The disk "MyDisk" contains one file.
 The disk "MyDisk" contains 1,273 files.

如上例所示，可以以编程方式来创建 ChoiceFormat，或使用模式创建。有关更多信息，请参阅 ChoiceFormat。

 form.applyPattern(
    "There {0,choice,0#are no files|1#is one file|1<are {0,number,integer} files}.");

注：从上面的例子可以看到，由 MessageFormat 中的 ChoiceFormat 所生成的字符串要进行特殊处理；'{' 的出现用来指示子格式，并导致递归。如果 MessageFormat 和 ChoiceFormat 都是以编程方式创建的（而不是使用字符串模式），那么要注意不要生成对其自身进行递归的格式，这将导致无限循环。

当一个参数在字符串中被多次解析时，最后的匹配将是解析的最终结果。例如，

 MessageFormat mf = new MessageFormat("{0,number,#.##}, {0,number,#.#}");
 Object[] objs = {new Double(3.1415)};
 String result = mf.format( objs );
 // result now equals "3.14, 3.1"
 objs = null;
 objs = mf.parse(result, new ParsePosition(0));
 // objs now equals {new Double(3.1)}

同样，使用包含同一参数多个匹配项的模式对 MessageFormat 对象进行解析时将返回最后的匹配。例如，

 MessageFormat mf = new MessageFormat("{0}, {0}, {0}");
 String forParsing = "x, y, z";
 Object[] objs = mf.parse(forParsing, new ParsePosition(0));
 // result now equals {new String("z")}

同步

消息格式不是同步的。建议为每个线程创建独立的格式实例。如果多个线程同时访问一个格式，则它必须是外部同步的。

另请参见：
Locale, Format, NumberFormat, DecimalFormat, ChoiceFormat, 序列化表格

嵌套类摘要
static class MessageFormat.Field
在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
构造方法摘要
MessageFormat(String pattern)
构造默认语言环境和指定模式的 MessageFormat。
MessageFormat(String pattern, Locale locale)
构造指定语言环境和模式的 MessageFormat。
方法摘要
void | applyPattern(String pattern) 设置此消息格式所使用的模式。
Object | clone() 创建并返回此对象的一个副本。
boolean | equals(Object obj) 两个消息格式对象之间的相等性比较
StringBuffer | format(Object[] arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
StringBuffer | format(Object arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
static String | format(String pattern, Object... arguments) 创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。
AttributedCharacterIterator | formatToCharacterIterator(Object arguments) 格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。
Format[] | getFormats() 获取用于以前所设置的模式字符串中格式元素的格式。
Format[] | getFormatsByArgumentIndex() 获取传递给 format 方法或从 parse 方法返回的值的格式。
Locale | getLocale() 获取创建或比较子格式时所使用的语言环境。
int | hashCode() 生成此消息格式对象的哈希码。
Object[] | parse(String source) 从给定字符串的开始位置解析文本，以生成一个对象数组。
Object[] | parse(String source, ParsePosition pos) 解析字符串。
Object | parseObject(String source, ParsePosition pos) 解析字符串文本，生成一个对象数组。
void | setFormat(int formatElementIndex, Format newFormat) 使用在以前设置的模式字符串中给定的格式元素索引来设置格式元素使用的格式。
void | setFormatByArgumentIndex(int argumentIndex, Format newFormat) 设置用于以前所设置的模式字符串中格式元素的格式，其中以前的模式字符串是用给定的参数索引设置的。
void | setFormats(Format[] newFormats) 设置用于以前所设置的模式字符串中格式元素的格式。
void | setFormatsByArgumentIndex(Format[] newFormats) 设置传递给 format 方法或从 parse 方法返回的值使用的格式。
void | setLocale(Locale locale) 设置创建或比较子格式时要使用的语言环境。
String | toPattern() 返回表示消息格式当前状态的模式。
从类 java.text.Format 继承的方法
format, parseObject
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MessageFormat

public MessageFormat(String pattern)
构造默认语言环境和指定模式的 MessageFormat。构造方法首先设置语言环境，然后解析模式，并为其包含的格式元素创建子格式列表。在类描述中指定了模式及其解释。

参数：
pattern - 此消息格式的模式
抛出：
IllegalArgumentException - 如果模式无效

MessageFormat

public MessageFormat(String pattern,
                     Locale locale)
构造指定语言环境和模式的 MessageFormat。构造方法首先设置语言环境，然后解析模式，并为其包含的格式元素创建子格式列表。在类描述中指定了模式及其解释。

参数：
pattern - 此消息格式的模式
locale - 此消息格式的语言环境
抛出：
IllegalArgumentException - 如果模式无效
从以下版本开始：
1.4
方法详细信息

setLocale

public void setLocale(Locale locale)
设置创建或比较子格式时要使用的语言环境。 这将影响对下面方法的后续调用
  • 对 applyPattern 和 toPattern 方法的后续调用，如果格式元素指定了格式类型并且因此具有在 applyPattern 方法中创建的子格式，以及
  • 对 format 和 formatToCharacterIterator 方法的后续调用，如果格式元素未指定格式类型并且因此具有在格式化方法中创建的子格式。
不影响已经创建的子格式。

参数：
locale - 创建或比较子格式时所使用的语言环境

getLocale

public Locale getLocale()
获取创建或比较子格式时所使用的语言环境。

返回：
创建或比较子格式时所使用的语言环境

applyPattern

public void applyPattern(String pattern)
设置此消息格式所使用的模式。此方法对模式进行解析，并为其所包含的格式元素创建子格式列表。在类描述中指定了模式及其解释。

参数：
pattern - 此消息格式的模式
抛出：
IllegalArgumentException - 如果模式无效

toPattern

public String toPattern()
返回表示消息格式当前状态的模式。字符串是从内部信息创建的，因此不需要与以前应用的模式相等。

返回：
表示消息格式当前状态的模式

setFormatsByArgumentIndex

public void setFormatsByArgumentIndex(Format[] newFormats)
设置传递给 format 方法或从 parse 方法返回的值使用的格式。newFormats 中元素的索引对应于以前设置的模式字符串中使用的参数索引。因此，newFormats 中的格式顺序对应于传递给 format 方法的 arguments 数组或从 parse 方法返回的结果数组中的元素顺序。

如果一个参数索引用于模式字符串中的多个格式元素，那么对应的新的格式将用于所有这样的格式元素。如果参数索引不用于模式字符串的任何一个格式元素，那么对应的新的格式将被忽略。如果提供的格式少于所需的格式，那么只替换其参数索引小于 newFormats.length 的格式。

参数：
newFormats - 要使用的新格式
抛出：
NullPointerException - 如果 newFormats 为 null
从以下版本开始：
1.4

setFormats

public void setFormats(Format[] newFormats)
设置用于以前所设置的模式字符串中格式元素的格式。newFormats 中的格式顺序对应于模式字符串中的格式元素的顺序。

如果提供的格式多于模式字符串所需的格式，那么剩余的格式将被忽略。如果提供的格式少于所需的格式，那么只替换前 newFormats.length 个格式。

由于在本地化期间，模式字符串中的格式元素顺序经常发生变化，因此最好使用 setFormatsByArgumentIndex 方法，此方法假定格式顺序对应于传递给 format 方法或从 parse 方法返回的结果数组的 arguments 数组中的元素顺序。

参数：
newFormats - 要使用的新格式
抛出：
NullPointerException - 如果 newFormats 为 null

setFormatByArgumentIndex

public void setFormatByArgumentIndex(int argumentIndex,
                                     Format newFormat)
设置用于以前所设置的模式字符串中格式元素的格式，其中以前的模式字符串是用给定的参数索引设置的。参数索引是格式元素定义的一部分，它表示传递给 format 方法或从 parse 方法返回的结果数组的 arguments 数组的索引。

如果参数索引用于模式字符串中的多个格式元素，那么新的格式将用于所有这样的格式元素。如果参数索引没有用于模式字符串的任何格式元素，那么新的格式将被忽略。

参数：
argumentIndex - 要用于新的格式的参数索引
newFormat - 要使用的新格式
从以下版本开始：
1.4

setFormat

public void setFormat(int formatElementIndex,
                      Format newFormat)
使用在以前设置的模式字符串中给定的格式元素索引来设置格式元素使用的格式。格式元素索引是从模式字符串起始位置开始计数的、从 0 开始的数字。

由于在本地化期间，模式字符串中的格式元素的顺序经常发生变化，因此最好使用 setFormatByArgumentIndex 方法，此方法根据它们所指定的参数索引来访问格式元素。

参数：
formatElementIndex - 模式中的格式元素的索引
newFormat - 要用于指定格式元素的格式
抛出：
ArrayIndexOutOfBoundsException - 如果 formatElementIndex 等于或大于模式字符串中格式元素的个数

getFormatsByArgumentIndex

public Format[] getFormatsByArgumentIndex()
获取传递给 format 方法或从 parse 方法返回的值的格式。返回的数组中的元素的索引对应于以前设置模式字符串中所使用的参数索引。因此，返回的数组中的格式顺序对应于传递给 format 方法或从 parse 方法返回的 arguments 数组中的元素顺序。

如果一个参数索引用于模式字符串中的多个格式元素，那么在数组中将返回用于最后一个这样的元素的格式。如果参数索引不用于模式字符串中的任何一个格式元素，那么在数组中将返回 null。

返回：
用于模式中参数的格式
从以下版本开始：
1.4

getFormats

public Format[] getFormats()
获取用于以前所设置的模式字符串中格式元素的格式。返回的数组中的格式顺序对应于模式字符串中的格式元素顺序。

由于在本地化期间，模式字符串中的格式元素的顺序经常发生变化，因此最好使用 getFormatsByArgumentIndex 方法，此方法假定格式的顺序对应于传递给 format 方法的 arguments 数组或从 parse 方法返回的结果数组中的元素顺序。

返回：
用于模式中格式元素的格式

format

public final StringBuffer format(Object[] arguments,
                                 StringBuffer result,
                                 FieldPosition pos)
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。

替换个别格式元素的文本从格式元素和位于格式元素参数索引处的 arguments 元素的当前子格式中派生出来，如下表中第一个匹配行所示。如果 arguments 为 null，或者元素的个数少于 argumentIndex+1，则参数是不可用的。

子格式 | 参数 | 格式化文本
所有 | 不可用 | "{" + argumentIndex + "}"
所有 | null | "null"
instanceof ChoiceFormat 所有 subformat.format(argument).indexOf('{') >= 0 ?
(new MessageFormat(subformat.format(argument), getLocale())).format(argument) : subformat.format(argument)
!= null | 所有 | subformat.format(argument)
null | instanceof Number | NumberFormat.getInstance(getLocale()).format(argument)
null | instanceof Date | DateFormat.getDateTimeInstance(DateFormat.SHORT, DateFormat.SHORT, getLocale()).format(argument)
null | instanceof String | argument
null | 所有 | argument.toString()

如果 pos 不为 null，且引用 Field.ARGUMENT，那么将返回第一个格式化字符串的位置。

参数：
arguments - 要被格式化和替换的对象数组。
result - 添加文本的位置。
pos - 输入时：如果需要，是一个对齐字段。输出时：为对齐字段的偏移量。
抛出：
IllegalArgumentException - 如果 arguments 数组中的参数不是使用该参数的格式元素期望的类型。

format

public static String format(String pattern,
                            Object... arguments)
创建具有给定模式的 MessageFormat，并用它来格式化给定的参数。这等效于
(new MessageFormat(pattern)).format(arguments, new StringBuffer(), null).toString()

抛出：
IllegalArgumentException - 如果模式无效，或者 arguments 数组中的参数不是使用该参数的格式元素期望的类型。

format

public final StringBuffer format(Object arguments,
                                 StringBuffer result,
                                 FieldPosition pos)
格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。这等效于
format((Object[]) arguments, result, pos)

指定者：
类 Format 中的 format
参数：
arguments - 要被格式化和替换的对象数组。
result - 添加文本的位置。
pos - 输入时：如果需要，是一个对齐字段。输出时：为对齐字段的偏移量。
返回：
添加了格式化文本并作为 toAppendTo 传入的字符串缓冲区
抛出：
IllegalArgumentException - 如果 arguments 数组中的参数不是使用该参数的格式元素期望的类型。

formatToCharacterIterator

public AttributedCharacterIterator formatToCharacterIterator(Object arguments)
格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。可以使用返回的 AttributedCharacterIterator 来生成得到的字符串，以及确定关于得到字符串的信息。

返回的 AttributedCharacterIterator 的文本与以下语句返回的结果相同

format(arguments, new StringBuffer(), null).toString()

此外，AttributedCharacterIterator 至少包含一些属性，指示从 arguments 数组的某个参数生成文本的位置。这些属性的键是 MessageFormat.Field 类型的，其值是 Integer 对象，指示参数的 arguments 数组中的索引，其中文本是从此索引生成的。

MessageFormat 所使用的底层 Format 实例的属性/值也将存放在得到的 AttributedCharacterIterator 中。这不仅允许查找参数被存放在得到的 String 中的位置，而且允许查找它依次包含哪些字段。

覆盖：
类 Format 中的 formatToCharacterIterator
参数：
arguments - 要被格式化和替换的对象数组。
返回：
描述格式化后的值的 AttributedCharacterIterator。
抛出：
NullPointerException - 如果 arguments 为 null。
IllegalArgumentException - 如果 arguments 数组中的参数不是使用该参数的格式元素期望的类型。
从以下版本开始：
1.4

parse

public Object[] parse(String source,
                      ParsePosition pos)
解析字符串。

警告：在许多情况下解析可能失败。例如：

  • 如果某个参数未出现在模式中。
  • 如果丢失了参数的格式信息，例如对于一个格式化选项，其中一个大数格式化为 "many"。
  • 尚未处理递归（其中替换后的字符串包含 {n} 引用）。
  • 当解析的某个部分不明确时，将不能总找到一个匹配（或者正确的匹配）。例如，如果模式 "{1},{2}" 用于字符串参数 {"a,b", "c"}，它将格式化为 "a,b,c"。当解析结果时，它将返回 {"a", "b,c"}。
  • 如果字符串中的参数被解析多次，那么将保留最后一次的解析结果。
当解析失败时，使用 ParsePosition.getErrorIndex() 来查找字符串的哪个位置导致了解析失败。返回的错误索引是要用来与字符串比较的子模式的起始偏移量。例如，如果解析的字符串 "AAA {0} BBB" 与模式 "AAD {0} BBB" 进行比较，则错误索引为 0。当发生错误时，对此方法的调用将返回 null。如果源为 null，则返回一个空数组。

parse

public Object[] parse(String source)
               throws ParseException
从给定字符串的开始位置解析文本，以生成一个对象数组。此方法不可以使用给定字符串的全部文本。

有关消息解析的更多信息，请参阅 parse(String, ParsePosition) 方法。

参数：
source - 必须解析其开头的 String。
返回：
从字符串进行解析的 Object 数组。
抛出：
ParseException - 如果无法解析指定字符串的开头。

parseObject

public Object parseObject(String source,
                          ParsePosition pos)
解析字符串文本，生成一个对象数组。

此方法试图解析从 pos 给定的索引处开始的文本。如果解析成功，则将 pos 的索引更新到所解析的最后一个字符后面的索引（不必对直到字符串结尾的所有字符进行解析），并返回解析后的对象数组。更新的 pos 可以用来指示下次调用此方法的起始点。如果发生错误，则不更改 pos 的索引，并将 pos 的错误索引设置为发生错误处的字符索引，并且返回 null。

有关消息解析的更多信息，请参阅 parse(String, ParsePosition) 方法。

指定者：
类 Format 中的 parseObject
参数：
source - 应该解析其中一部分的 String。
pos - 具有以上所述的索引和错误索引信息的 ParsePosition 对象。
返回：
从字符串进行解析的 Object 数组。如果发生错误，则返回 null。
抛出：
NullPointerException - 如果 pos 为 null。

clone

public Object clone()
创建并返回此对象的一个副本。

覆盖：
类 Format 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

equals

public boolean equals(Object obj)
两个消息格式对象之间的相等性比较

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
生成此消息格式对象的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MessageFormat.Field (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 MessageFormat.Field

java.lang.Object
    继承者  java.text.AttributedCharacterIterator.Attribute
        继承者  java.text.Format.Field
            继承者  java.text.MessageFormat.Field
所有已实现的接口：
Serializable
正在封闭类：
MessageFormat
public static class MessageFormat.Field
extends Format.Field

在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
static MessageFormat.Field ARGUMENT
标识消息某一部分的常量，其中此消息是从传入 formatToCharacterIterator 的参数生成的。
从类 java.text.AttributedCharacterIterator.Attribute 继承的字段
INPUT_METHOD_SEGMENT, LANGUAGE, READING
构造方法摘要
protected MessageFormat.Field(String name)
创建具有指定名称的 Field。
方法摘要
protected  Object readResolve()
把正被反序列化的实例解析为预定义的常量。
从类 java.text.AttributedCharacterIterator.Attribute 继承的方法
equals, getName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ARGUMENT

public static final MessageFormat.Field ARGUMENT
标识消息某一部分的常量，其中此消息是从传入 formatToCharacterIterator 的参数生成的。与键关联的值将是一个 Integer，指示从其生成文本的 arguments 参数数组中的索引。

构造方法详细信息

MessageFormat.Field

protected MessageFormat.Field(String name)
创建具有指定名称的 Field。

参数：
name - 属性名称
方法详细信息

readResolve

protected Object readResolve()
                      throws InvalidObjectException
把正被反序列化的实例解析为预定义的常量。

覆盖：
类 AttributedCharacterIterator.Attribute 中的 readResolve
返回：
解析后的 MessageFormat.Field 常量
抛出：
InvalidObjectException - 如果常量无法解析。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Normalizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 Normalizer

java.lang.Object
    继承者  java.text.Normalizer

public final class Normalizer
extends Object

此类提供 normalize 方法，它把 Unicode 文本转换为等效的组合或分解形式，允许对文本进行更方便地分类和搜索。normalize 方法支持在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的标准的标准化形式。

在 Unicode 中，带有重音或其他装饰的字符可以用几种不同的方式进行编码。例如，字符 A-acute。在 Unicode 中，可以被编码为单个字符（“组合”形式）：

U+00C1    LATIN CAPITAL LETTER A WITH ACUTE

或者两个单独的字符（“分解”形式）：

U+0041    LATIN CAPITAL LETTER A
U+0301    COMBINING ACUTE ACCENT

然而，对程序的用户而言，这两个序列都可以被视为同样的“用户级”字符“带有 acute 重音的 A”。当您搜索或比较文本时，必须确保这两个序列被视为是等效的。另外，您必须处理带有多个重音的字符。有时候一个字符的组合重音顺序很重要，而在另一些情况下，不同顺序的重音序列则可能完全等效。

类似地，字符串 "ffi" 可被编码为三个单独的字母。

U+0066    LATIN SMALL LETTER F
U+0066    LATIN SMALL LETTER F
U+0069    LATIN SMALL LETTER I

或者单个字符

U+FB03    LATIN SMALL LIGATURE FFI

ffi 连字不是明显的语义字符，严格来说，它根本不应该在 Unicode 中，这里包含它是为了与已经提供它的现有字符集兼容。通过“相容 (compatibility)”分解，Unicode 标准将这类字符标识为相应的语义字符。进行分类和搜索时，您会经常希望使用这些映射。

normalize 方法通过将文本转换为规范的组合和分解形式来帮助解决这些问题，正如上面第一个例子所示。另外，您可以使它执行相容分解，以便可以将兼容性字符视为与其等价物一样。最后，normalize 方法将重音重新排列为适当的规范顺序，因此不必考虑重音的重新排列问题。

W3C 通常建议在 NFC 中交换文本。还要注意，大多数遗留字符编码仅使用预组合形式，并且其本身并不对任何合成标记进行编码。对于到此类字符编码的转换，Unicode 文本需要标准化为 NFC。有关更多使用实例，请参见 Unicode Standard Annex。

从以下版本开始：
1.6

嵌套类摘要
static class Normalizer.Form
此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。
方法摘要
static boolean | isNormalized(CharSequence src, Normalizer.Form form) 确定给定的 char 值序列是否被标准化。
static String | normalize(CharSequence src, Normalizer.Form form) 标准化 char 值序列。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

normalize

public static String normalize(CharSequence src,
                               Normalizer.Form form)
标准化 char 值序列。将根据指定标准化形式对序列进行标准化。

参数：
src - 要标准化的 char 值序列。
form - 标准化形式；Normalizer.Form.NFC、Normalizer.Form.NFD、Normalizer.Form.NFKC、Normalizer.Form.NFKD 之一
返回：
已标准化的 String
抛出：
NullPointerException - 如果 src 或 form 为 null。

isNormalized

public static boolean isNormalized(CharSequence src,
                                   Normalizer.Form form)
确定给定的 char 值序列是否被标准化。

参数：
src - 要检查的 char 值序列。
form - 标准化形式；Normalizer.Form.NFC、Normalizer.Form.NFD、Normalizer.Form.NFKC、Normalizer.Form.NFKD 之一
返回：
如果 char 值序列已被标准化，则返回 true；否则返回 false 。
抛出：
NullPointerException - 如果 src 或 form 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Normalizer.Form (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.text
枚举 Normalizer.Form

java.lang.Object
    继承者  java.lang.Enum<Normalizer.Form>
        继承者  java.text.Normalizer.Form
所有已实现的接口：
Serializable, Comparable<Normalizer.Form>
正在封闭类：
Normalizer
public static enum Normalizer.Form
extends Enum<Normalizer.Form>

此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。

从以下版本开始：
1.6

枚举常量摘要
NFC
规范分解，然后是规范组合。
NFD
规范分解。
NFKC
相容分解，然后是规范组合。
NFKD
相容分解。
方法摘要
static Normalizer.Form | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Normalizer.Form[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

NFD

public static final Normalizer.Form NFD
规范分解。

NFC

public static final Normalizer.Form NFC
规范分解，然后是规范组合。

NFKD

public static final Normalizer.Form NFKD
相容分解。

NFKC

public static final Normalizer.Form NFKC
相容分解，然后是规范组合。

方法详细信息

values

public static final Normalizer.Form[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Normalizer.Form c : Normalizer.Form.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Normalizer.Form valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


NumberFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 NumberFormat

java.lang.Object
    继承者  java.text.Format
        继承者  java.text.NumberFormat
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
ChoiceFormat, DecimalFormat
public abstract class NumberFormat
extends Format

NumberFormat 是所有数值格式的抽象基类。此类提供格式化和解析数值的接口。NumberFormat 还提供了一些方法来确定哪些语言环境具有数值格式，以及它们的名称是什么。

NumberFormat 可用于格式化和解析任何语言环境的数值。使代码能够完全独立于小数点、千位分隔符甚至所用特定小数位数的语言环境约定，并与数值格式是否为偶小数无关。

若要格式化当前 Locale 的数值，可使用其中一个工厂类方法：

  myString = NumberFormat.getInstance().format(myNumber);
如果格式化多个数值，那么获取该格式并多次使用它是更为高效的做法，这样系统就不必多次获取关于语言环境语言和国家/地区约定的信息了。
 NumberFormat nf = NumberFormat.getInstance();
 for (int i = 0; i < myNumber.length; ++i) {
     output.println(nf.format(myNumber[i]) + "; ");
 }
若要格式化不同 Locale 的日期，可在对 getInstance 的调用中指定它。
 NumberFormat nf = NumberFormat.getInstance(Locale.FRENCH);
还可以使用 NumberFormat 来解析数值：
 myNumber = nf.parse(myString);
使用 getInstance 或 getNumberInstance 来获取常规数值格式。使用 getIntegerInstance 来获取整数数值格式。使用 getCurrencyInstance 来获取货币数值格式。使用 getPercentInstance 来获取显示百分比的格式。使用此格式，小数 0.53 将显示为 53%。

使用 setMinimumFractionDigits 之类的方法还可以控制数值的显示。如果想对格式化和解析进行更多的控制（或者给予用户更多的控制），可以尝试将从工厂方法获取的 NumberFormat 强制转换为 DecimalFormat。这适用于大多数语言环境；只是要记住将其放入一个 try 代码块中，以防遇到特殊情况。

NumberFormat 和 DecimalFormat 的作用在于，有一些方法控制格式化，还有一些方法控制解析。以下是对每种控制方法的详细描述：

setParseIntegerOnly : 只影响解析，例如，如果为 true，则 "3456.78" -> 3456（并保留索引 6 后面的那个解析位置），如果为 false，则 "3456.78" -> 3456.78（并保留索引 8 后面的那个解析位置）。此方法与格式化无关。如果希望在小数点后面没有数值的情况下不显示小数点，则使用 setDecimalSeparatorAlwaysShown。

setDecimalSeparatorAlwaysShown :只影响格式化，且只影响小数点后没有数值的情况，例如模式 "#,##0.##"，如果为 true，则 3456.00 -> "3,456."，如果为 false，则 3456.00 -> "3456"。此方法与解析无关。如果希望解析在小数点处停止，则使用 setParseIntegerOnly。

还可以使用带有 ParsePosition 和 FieldPosition 的 parse 和 format 方法的形式，它们允许：

  • 逐步地解析字符串的各部分
  • 对齐小数点和其他区域
例如，可以通过两种方式对齐数值：
  1. 如果使用以间隔来对齐的等宽字体，可以在格式调用中传递 FieldPosition，令 field = INTEGER_FIELD。在输出时，getEndIndex 将被设置为最后一个整数字符和小数字符之间的偏移量。在字符串前面加入 (desiredSpaceCount - getEndIndex) 个空格。
  2. 如果使用成比例的字体，则不是通过填充空格的方法，而是以像素为单位度量从开始处到 getEndIndex 的字符串宽度。然后在绘制文本之前将画笔移动 (desiredPixelWidth - widthToAlignmentPoint) 个像素。对于没有小数但可能在末尾有其他字符的字符串，这种方法也是有效的，例如，带有圆括号的负数："(12)" 用于 -12。

同步

数值格式化通常是不同步的。建议为每个线程创建独立的格式实例。如果多个线程同时访问一个格式，则它必须是外部同步的。

另请参见：
DecimalFormat, ChoiceFormat, 序列化表格

嵌套类摘要
static class NumberFormat.Field
定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。
字段摘要
static int | FRACTION_FIELD 用于构造 FieldPosition 对象的字段常量。
static int | INTEGER_FIELD 用于构造 FieldPosition 对象的字段常量。
构造方法摘要
protected NumberFormat()
唯一的构造方法。
方法摘要
Object | clone() 重写 Cloneable
boolean | equals(Object obj) 重写 equals
String | format(double number) 格式规范。
abstract StringBuffer | format(double number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
String | format(long number) 格式规范。
abstract StringBuffer | format(long number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数并将所得文本添加到给定字符串缓冲区。
static Locale[] | getAvailableLocales() 返回一个数组，它包含所有此类的 get*Instance 方法可以为其返回本地化实例的语言环境。
Currency | getCurrency() 获取格式化货币值时此数值格式使用的货币。
static NumberFormat | getCurrencyInstance() 返回当前默认语言环境的货币格式。
static NumberFormat | getCurrencyInstance(Locale inLocale) 返回指定语言环境的货币格式。
static NumberFormat | getInstance() 返回当前默认语言环境的通用数值格式。
static NumberFormat | getInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | getIntegerInstance() 返回当前默认语言环境的整数格式。
static NumberFormat | getIntegerInstance(Locale inLocale) 返回指定语言环境的整数格式。
int | getMaximumFractionDigits() 返回数的小数部分所允许的最大位数。
int | getMaximumIntegerDigits() 返回数的整数部分所允许的最大位数。
int | getMinimumFractionDigits() 返回数的小数部分所允许的最小位数。
int | getMinimumIntegerDigits() 返回数的整数部分所允许的最小位数。
static NumberFormat | getNumberInstance() 返回当前默认语言环境的通用数值格式。
static NumberFormat | getNumberInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | getPercentInstance() 返回当前默认语言环境的百分比格式。
static NumberFormat | getPercentInstance(Locale inLocale) 返回指定语言环境的百分比格式。
RoundingMode | getRoundingMode() 获取在此 NumberFormat 中使用的 RoundingMode。
int | hashCode() 重写 hashCode
boolean | isGroupingUsed() 如果此格式中使用了分组，则返回 true。
boolean | isParseIntegerOnly() 如果此格式只将数作为整数解析，则返回 true。
Number | parse(String source) 解析给定字符串开头的文本，生成一个数值。
abstract Number | parse(String source, ParsePosition parsePosition) 如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。
Object | parseObject(String source, ParsePosition pos) 解析字符串中的文本，以生成一个 Number。
void | setCurrency(Currency currency) 设置格式化货币值时此数值格式使用的货币。
void | setGroupingUsed(boolean newValue) 设置此格式中是否使用分组。
void | setMaximumFractionDigits(int newValue) 设置数的小数部分所允许的最大位数。
void | setMaximumIntegerDigits(int newValue) 设置数的整数部分所允许的最大位数。
void | setMinimumFractionDigits(int newValue) 设置数的小数部分所允许的最小位数。
void | setMinimumIntegerDigits(int newValue) 设置数的整数部分所允许的最小位数。
void | setParseIntegerOnly(boolean value) 设置数是否应该仅作为整数进行解析。
void | setRoundingMode(RoundingMode roundingMode) 设置在此 NumberFormat 中使用的 RoundingMode。
从类 java.text.Format 继承的方法
format, formatToCharacterIterator, parseObject
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

INTEGER_FIELD

public static final int INTEGER_FIELD
用于构造 FieldPosition 对象的字段常量。表示必须返回格式化数值整数部分的位置。

另请参见：
FieldPosition, 常量字段值

FRACTION_FIELD

public static final int FRACTION_FIELD
用于构造 FieldPosition 对象的字段常量。表示必须返回格式化数值小数部分的位置。

另请参见：
FieldPosition, 常量字段值
构造方法详细信息

NumberFormat

protected NumberFormat()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

format

public StringBuffer format(Object number,
                           StringBuffer toAppendTo,
                           FieldPosition pos)
格式化一个数并将所得文本添加到给定字符串缓冲区。该数可以是 Number 的任何子类。

对于能够被转换为 long 类型而不丢失信息的所有整型值，此实现使用 Number.longValue() 提取其数值，包括位长小于 64 的 BigInteger 值；使用 Number.doubleValue() 提取所有其他类型的值。然后它调用 format(long,java.lang.StringBuffer,java.text.FieldPosition) 或 format(double,java.lang.StringBuffer,java.text.FieldPosition)。这可能导致丢失数值信息以及 BigInteger 和 BigDecimal 值的精度。

指定者：
类 Format 中的 format
参数：
number - 要格式化的数
toAppendTo - 要添加格式化文本的 StringBuffer
pos - 输入时：如果需要，是一个对齐字段。输出时：是对齐字段的偏移量。
返回：
作为 toAppendTo 传入的值
抛出：
IllegalArgumentException - 如果 number 为 null 或不是 Number 的实例。
NullPointerException - 如果 toAppendTo 或 pos 为 null
ArithmeticException - 如果需要进行舍入但舍入模式设置为 RoundingMode.UNNECESSARY
另请参见：
FieldPosition

parseObject

public final Object parseObject(String source,
                                ParsePosition pos)
解析字符串中的文本，以生成一个 Number。

此方法试图解析从 pos 给定的索引处开始的文本。如果解析成功，则将 pos 的索引更新为所解析的最后一字符后的索引（不一定对直到字符串结尾的所有字符进行解析），并返回解析后的数。更新后的 pos 可以用来指示下次调用此方法的起始点。如果发生错误，则 pos 的索引不变，pos 的错误索引被设置为发生错误的字符的索引，并返回 null。

有关数值解析的更多信息，请参阅 parse(String, ParsePosition) 方法。

指定者：
类 Format 中的 parseObject
参数：
source - 一部分将要被解析的 String。
pos - 具有以上所述的索引和错误索引信息的 ParsePosition 对象。
返回：
从字符串进行解析的 Number。如果发生错误，则返回 null。
抛出：
NullPointerException - 如果 pos 为 null。

format

public final String format(double number)
格式规范。

抛出：
ArithmeticException - 如果需要进行舍入但舍入模式设置为 RoundingMode.UNNECESSARY
另请参见：
Format.format(java.lang.Object)

format

public final String format(long number)
格式规范。

抛出：
ArithmeticException - 如果需要进行舍入但舍入模式设置为 RoundingMode.UNNECESSARY
另请参见：
Format.format(java.lang.Object)

format

public abstract StringBuffer format(double number,
                                    StringBuffer toAppendTo,
                                    FieldPosition pos)
格式规范。

抛出：
ArithmeticException - 如果需要进行舍入但舍入模式设置为 RoundingMode.UNNECESSARY
另请参见：
Format.format(java.lang.Object)

format

public abstract StringBuffer format(long number,
                                    StringBuffer toAppendTo,
                                    FieldPosition pos)
格式规范。

抛出：
ArithmeticException - 如果需要进行舍入但舍入模式设置为 RoundingMode.UNNECESSARY
另请参见：
Format.format(java.lang.Object)

parse

public abstract Number parse(String source,
                             ParsePosition parsePosition)
如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。如果设置了 IntegerOnly，则将在小数点处停止解析（或者；例如，对于有理数 "1 2/3"，将在 1 后面停止）。不抛出异常；如果没有可被解析的对象，则索引不变！

另请参见：
isParseIntegerOnly(), Format.parseObject(java.lang.String, java.text.ParsePosition)

parse

public Number parse(String source)
             throws ParseException
解析给定字符串开头的文本，生成一个数值。此方法不可以使用给定字符串的全部文本。

有关数值解析的更多信息，请参阅 parse(String, ParsePosition) 方法。

参数：
source - 开头应被解析的 String。
返回：
从字符串解析的 Number。
抛出：
ParseException - 如果无法解析指定字符串的开头。

isParseIntegerOnly

public boolean isParseIntegerOnly()
如果此格式只将数作为整数解析，则返回 true。例如，在 English 语言环境中，如果 ParseIntegerOnly 为 true，则字符串 "1234." 将作为整数值 1234 进行解析，且解析将在 "." 字符处停止。当然，解析操作所接受的确切格式与语言环境相关，并且是由 NumberFormat 的子类确定的。

setParseIntegerOnly

public void setParseIntegerOnly(boolean value)
设置数是否应该仅作为整数进行解析。

另请参见：
isParseIntegerOnly()

getInstance

public static final NumberFormat getInstance()
返回当前默认语言环境的通用数值格式。这与调用 getNumberInstance() 相同。

getInstance

public static NumberFormat getInstance(Locale inLocale)
返回指定语言环境的通用数值格式。这与调用 getNumberInstance(inLocale) 相同。

getNumberInstance

public static final NumberFormat getNumberInstance()
返回当前默认语言环境的通用数值格式。

getNumberInstance

public static NumberFormat getNumberInstance(Locale inLocale)
返回指定语言环境的通用数值格式。

getIntegerInstance

public static final NumberFormat getIntegerInstance()
返回当前默认语言环境的整数格式。返回数的格式使用四舍五入算法将浮点数舍入为最接近的整数（参见 RoundingMode.HALF_EVEN)，并只解析输入字符串的整数部分（参见 isParseIntegerOnly）。

返回：
整数值的数值格式
从以下版本开始：
1.4
另请参见：
getRoundingMode()

getIntegerInstance

public static NumberFormat getIntegerInstance(Locale inLocale)
返回指定语言环境的整数格式。返回数的格式使用四舍五入算法将浮点数舍入为最接近的整数（参见 RoundingMode.HALF_EVEN)，并只解析输入字符串的整数部分（参见 isParseIntegerOnly）。

返回：
整数值的数值格式
从以下版本开始：
1.4
另请参见：
getRoundingMode()

getCurrencyInstance

public static final NumberFormat getCurrencyInstance()
返回当前默认语言环境的货币格式。

getCurrencyInstance

public static NumberFormat getCurrencyInstance(Locale inLocale)
返回指定语言环境的货币格式。

getPercentInstance

public static final NumberFormat getPercentInstance()
返回当前默认语言环境的百分比格式。

getPercentInstance

public static NumberFormat getPercentInstance(Locale inLocale)
返回指定语言环境的百分比格式。

getAvailableLocales

public static Locale[] getAvailableLocales()
返回一个数组，它包含所有此类的 get*Instance 方法可以为其返回本地化实例的语言环境。返回数组表示 Java 运行时和安装的 NumberFormatProvider 实现所支持的语言环境的并集。它必须至少包含一个等同于 Locale.US 的 Locale 实例。

返回：
一个数组，它包含可获得其本地化 NumberFormat 实例的语言环境。

hashCode

public int hashCode()
重写 hashCode

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
重写 equals

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

clone

public Object clone()
重写 Cloneable

覆盖：
类 Format 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

isGroupingUsed

public boolean isGroupingUsed()
如果此格式中使用了分组，则返回 true。例如，在 English 语言环境中，如果使用了分组，则数 1234567 将被格式化为 "1,234,567"。组分隔符以及每个组的大小是与语言环境相关的，由 NumberFormat 的子类确定。

另请参见：
setGroupingUsed(boolean)

setGroupingUsed

public void setGroupingUsed(boolean newValue)
设置此格式中是否使用分组。

另请参见：
isGroupingUsed()

getMaximumIntegerDigits

public int getMaximumIntegerDigits()
返回数的整数部分所允许的最大位数。

另请参见：
setMaximumIntegerDigits(int)

setMaximumIntegerDigits

public void setMaximumIntegerDigits(int newValue)
设置数的整数部分所允许的最大位数。maximumIntegerDigits 必须 >= minimumIntegerDigits。如果 maximumIntegerDigits 的新值小于 minimumIntegerDigits 的当前值，则 minimumIntegerDigits 也将被设置为新值。

参数：
newValue - 要显示的最大整数位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
getMaximumIntegerDigits()

getMinimumIntegerDigits

public int getMinimumIntegerDigits()
返回数的整数部分所允许的最小位数。

另请参见：
setMinimumIntegerDigits(int)

setMinimumIntegerDigits

public void setMinimumIntegerDigits(int newValue)
设置数的整数部分所允许的最小位数。minimumIntegerDigits 必须 <= maximumIntegerDigits。如果 minimumIntegerDigits 的新值超过了 maximumIntegerDigits 的当前值，那么 maximumIntegerDigits 也将被设置为新值

参数：
newValue - 要显示的整数的最小位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
getMinimumIntegerDigits()

getMaximumFractionDigits

public int getMaximumFractionDigits()
返回数的小数部分所允许的最大位数。

另请参见：
setMaximumFractionDigits(int)

setMaximumFractionDigits

public void setMaximumFractionDigits(int newValue)
设置数的小数部分所允许的最大位数。maximumFractionDigits 必须 >= minimumFractionDigits。如果 maximumFractionDigits 的新值小于 minimumFractionDigits 的当前值，则 minimumFractionDigits 也将被设置为新值。

参数：
newValue - 要显示的小数的最大位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
getMaximumFractionDigits()

getMinimumFractionDigits

public int getMinimumFractionDigits()
返回数的小数部分所允许的最小位数。

另请参见：
setMinimumFractionDigits(int)

setMinimumFractionDigits

public void setMinimumFractionDigits(int newValue)
设置数的小数部分所允许的最小位数。minimumFractionDigits 必须 <= maximumFractionDigits。如果 minimumFractionDigits 的新值超过了 maximumFractionDigits 的当前值，那么 maximumIntegerDigits 也将被设置为新值

参数：
newValue - 要显示的小数的最小位数；如果小于 0，则使用 0。具体子类可以为此值强加一个上限，以适合于被格式化的数值类型。
另请参见：
getMinimumFractionDigits()

getCurrency

public Currency getCurrency()
获取格式化货币值时此数值格式使用的货币。以与语言环境相关的方式导出初始值。如果不能确定有效的货币，或者没有使用 setCurrency 设置任何货币，则返回值为 null。

默认实现抛出 UnsupportedOperationException。

返回：
此数值格式使用的货币，或者 null
抛出：
UnsupportedOperationException - 如果数值格式类不实现货币格式化
从以下版本开始：
1.4

setCurrency

public void setCurrency(Currency currency)
设置格式化货币值时此数值格式使用的货币。此方法不更新数值格式所使用的小数的最小位数或最大位数。

默认实现抛出 UnsupportedOperationException。

参数：
currency - 此数值格式要使用的新货币
抛出：
UnsupportedOperationException - 如果数值格式类不实现货币格式化
NullPointerException - 如果 currency 为 null
从以下版本开始：
1.4

getRoundingMode

public RoundingMode getRoundingMode()
获取在此 NumberFormat 中使用的 RoundingMode。在 NumberFormat 中此方法的默认实现始终抛出 UnsupportedOperationException。处理不同舍入模式的子类应该重写此方法。

返回：
用于此 NumberFormat 的 RoundingMode。
抛出：
UnsupportedOperationException - 默认实现始终抛出此异常
从以下版本开始：
1.6
另请参见：
setRoundingMode(RoundingMode)

setRoundingMode

public void setRoundingMode(RoundingMode roundingMode)
设置在此 NumberFormat 中使用的 RoundingMode。在 NumberFormat 中此方法的默认实现始终抛出 UnsupportedOperationException。处理不同舍入模式的子类应该重写此方法。

参数：
roundingMode - 要使用的 RoundingMode
抛出：
UnsupportedOperationException - 默认实现始终抛出此异常
NullPointerException - 如果 roundingMode 为 null
从以下版本开始：
1.6
另请参见：
getRoundingMode()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberFormat.Field (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 NumberFormat.Field

java.lang.Object
    继承者  java.text.AttributedCharacterIterator.Attribute
        继承者  java.text.Format.Field
            继承者  java.text.NumberFormat.Field
所有已实现的接口：
Serializable
正在封闭类：
NumberFormat
public static class NumberFormat.Field
extends Format.Field

定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
static NumberFormat.Field | CURRENCY 标识货币字段的常量。
static NumberFormat.Field | DECIMAL_SEPARATOR 标识小数点字段的常量。
static NumberFormat.Field | EXPONENT 标识指数字段的常量。
static NumberFormat.Field | EXPONENT_SIGN 标识指数符号 (exponent sign) 字段的常量。
static NumberFormat.Field | EXPONENT_SYMBOL 标识指数符号 (exponent symbol) 字段的常量。
static NumberFormat.Field | FRACTION 标识小数字段的常量。
static NumberFormat.Field | GROUPING_SEPARATOR 标识组分隔符字段的常量。
static NumberFormat.Field | INTEGER 标识整数字段的常量。
static NumberFormat.Field | PERCENT 标识百分数字段的常量。
static NumberFormat.Field | PERMILLE 标识千分数字段的常量。
static NumberFormat.Field | SIGN 标识符号字段的常量。
从类 java.text.AttributedCharacterIterator.Attribute 继承的字段
INPUT_METHOD_SEGMENT, LANGUAGE, READING
构造方法摘要
protected NumberFormat.Field(String name)
创建具有指定名称的 Field 实例。
方法摘要
protected  Object readResolve()
将正被反序列化的实例解析为预定义的常量。
从类 java.text.AttributedCharacterIterator.Attribute 继承的方法
equals, getName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

INTEGER

public static final NumberFormat.Field INTEGER
标识整数字段的常量。

FRACTION

public static final NumberFormat.Field FRACTION
标识小数字段的常量。

EXPONENT

public static final NumberFormat.Field EXPONENT
标识指数字段的常量。

DECIMAL_SEPARATOR

public static final NumberFormat.Field DECIMAL_SEPARATOR
标识小数点字段的常量。

SIGN

public static final NumberFormat.Field SIGN
标识符号字段的常量。

GROUPING_SEPARATOR

public static final NumberFormat.Field GROUPING_SEPARATOR
标识组分隔符字段的常量。

EXPONENT_SYMBOL

public static final NumberFormat.Field EXPONENT_SYMBOL
标识指数符号 (exponent symbol) 字段的常量。

PERCENT

public static final NumberFormat.Field PERCENT
标识百分数字段的常量。

PERMILLE

public static final NumberFormat.Field PERMILLE
标识千分数字段的常量。

CURRENCY

public static final NumberFormat.Field CURRENCY
标识货币字段的常量。

EXPONENT_SIGN

public static final NumberFormat.Field EXPONENT_SIGN
标识指数符号 (exponent sign) 字段的常量。

构造方法详细信息

NumberFormat.Field

protected NumberFormat.Field(String name)
创建具有指定名称的 Field 实例。

参数：
name - 属性名称
方法详细信息

readResolve

protected Object readResolve()
                      throws InvalidObjectException
将正被反序列化的实例解析为预定义的常量。

覆盖：
类 AttributedCharacterIterator.Attribute 中的 readResolve
返回：
解析后的 NumberFormat.Field 常量
抛出：
InvalidObjectException - 如果无法解析常量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParseException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 ParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.text.ParseException
所有已实现的接口：
Serializable
public class ParseException
extends Exception

表示解析时出现意外错误。

另请参见：
Exception, Format, FieldPosition, 序列化表格

构造方法摘要
ParseException(String s, int errorOffset)
构造带指定详细消息和偏移量的 ParseException。
方法摘要
 int getErrorOffset()
返回发现错误的位置。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ParseException

public ParseException(String s,
                      int errorOffset)
构造带指定详细消息和偏移量的 ParseException。详细消息是描述此特定异常的字符串。

参数：
s - 详细消息
errorOffset - 解析时发现错误的位置。
方法详细信息

getErrorOffset

public int getErrorOffset()
返回发现错误的位置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ParsePosition (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 ParsePosition

java.lang.Object
    继承者  java.text.ParsePosition

public class ParsePosition
extends Object

ParsePosition 是 Format 及其子类所使用的简单类，用来在解析过程中跟踪当前位置。各种 Format 类中的 parseObject 方法要求将 ParsePosition 对象作为一个变量。

解析具有不同格式的字符串时，可以使用同一个 ParsePosition，因为索引参数记录的是当前位置。

另请参见：
Format

构造方法摘要
ParsePosition(int index)
创建一个具有给定初始索引的新 ParsePosition。
方法摘要
boolean | equals(Object obj) 重写 equals
int | getErrorIndex() 获取出错时的索引，如果没有设置错误索引，则为 -1。
int | getIndex() 获取当前的解析位置。
int | hashCode() 返回此 ParsePosition 的哈希码。
void | setErrorIndex(int ei) 设置解析出错时的索引。
void | setIndex(int index) 设置当前解析位置。
String | toString() 返回此 ParsePosition 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ParsePosition

public ParsePosition(int index)
创建一个具有给定初始索引的新 ParsePosition。

方法详细信息

getIndex

public int getIndex()
获取当前的解析位置。对于解析方法的输入，这是解析开始处字符的索引；对于输出，这是被解析的最后一个字符后的字符索引。

setIndex

public void setIndex(int index)
设置当前解析位置。

setErrorIndex

public void setErrorIndex(int ei)
设置解析出错时的索引。格式器应该在从它们的 parseObject方法返回错误代码之前进行此设置。如果没有设置，则默认值为 -1。

从以下版本开始：
1.2

getErrorIndex

public int getErrorIndex()
获取出错时的索引，如果没有设置错误索引，则为 -1。

从以下版本开始：
1.2

equals

public boolean equals(Object obj)
重写 equals

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 ParsePosition 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 ParsePosition 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RuleBasedCollator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 RuleBasedCollator

java.lang.Object
    继承者  java.text.Collator
        继承者  java.text.RuleBasedCollator
所有已实现的接口：
Cloneable, Comparator<Object>
public class RuleBasedCollator
extends Collator

RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。可以通过此类来创建基于表的自定义 Collator。RuleBasedCollator 将字符映射到排序键。

为了提高效率，对 RuleBasedCollator 做了如下限制（其他子类可以用于更复杂的语言）：

  1. 如果指定了由 <modifier> 控制的特殊整理规则，则它将用于整个 collator 对象。
  2. 所有未指定的字符位于整理顺序的末尾。

整理表由一组整理规则组成，其中每个规则是以下三种形式之一：

    <modifier>
    <relation> <text-argument>
    <reset> <text-argument>
规则元素的定义如下：
  • 文本参数：文本参数可以是任何的字符序列，不包括特殊字符（即公共空白字符 [0009-000D、0020] 和规则语法字符 [0021-002F、003A-0040、005B-0060、007B-007E]）。如果需要使用这些字符，可以把它们放在单引号内（例如 & => '&'）。注意，没有使用引号的空白字符将被忽略；例如 b c 视为 bc。
  • 修饰符：目前有两个修饰符用于开启特殊的整理规则。
    • '@' : 开启重音字符的逆向排序（二级区别），以法语为例。
    • '!' : 开启 Thai/Lao 元音-辅音字母交换。如果当 \U0E40-\U0E44 范围内的 Thai 元音字母排在 \U0E01-\U0E2E 范围内的 Thai 辅音字母前面，或者 \U0EC0-\U0EC4 范围内的 Lao 元音字母排在 \U0E81-\U0EAE 范围内的 Lao 辅音字母前面时此规则有效，那么经过整理后元音字母将被放置在辅音字母的后面。

    '@' : 指示重音字符按逆向排序，以法语为例。

  • 关系：关系如下：
    • '<' : 大于，当字母不同时（一级）
    • ';' : 大于，当重音不同时（二级）
    • ',' : 大于，当大小写不同时（三级)
    • '=' : 等于
  • 重置：存在单一的重置主要用于规则集的缩减和扩充，但它也可以用于在规则集的末尾添加修改。

    '&' : 指示下一条规则在重置文本参数将要被排序的位置后面。

实际的操作要比看起来简单。例如，以下表达是等效的：

 a < b < c
 a < b & b < c
 a < c & a < b
注意，顺序很重要，因为后续项直接跟在文本参数的后面。以下是不等效的：
 a < b & a < c
 a < c & a < b
序列中必须存在文本参数，或者存在某个文本参数的初始子字符串。(例如，"a < b & ae < e" 是有效的，因为在 "ae" 被重置之前 "a" 存在）。在后一种情况中，"ae" 不是作为单个字符进行输入和处理的；相反，"e" 被排序，其结果类似于它被扩充为两个字符："a" 后跟 "e"。此差别会出现在不同的自然语言中：在传统的西班牙语中，"ch" 被处理的结果类似于将它缩短为一个字符（表示为 "c < ch < d"），而在传统的德语中，a-umlaut 被处理的结果类似于将它扩充为两个字符（表示为 "a,A < b,B ...&ae;&AE;")。&ae;\u00e3&AE;\u00c3").当然，[\u00e3 和 \u00c3 是 a-umlaut 的转义序列。]

可忽略的字符

对于可忽略的字符，第一个规则必须从一个关系开始（以上例子实际上是不完整的；"a < b" 实际上应该为 "< a < b"）。但是，如果第一个关系不是 "<"，那么所有文本参数一直到第一个 "<" 都将被忽略。例如，", - < a < b" 将把 "-" 作为被忽略的字符，正如在前面的单词 "black-birds" 中所看到的。在不同语言的示例中，可以看到大多数重音字符被忽略。

规范化和重音

RuleBasedCollator 自动处理其规则表，以包含重音字符的预组合和组合后的字符版本。即使提供的规则字符串仅包含基本字符和独立的组合重音字符，匹配规则字符串中所有规范字符组合的预组合重音字符也将被输入到表中。

即使 collator 被设置为 NO_DECOMPOSITION，这也允许使用 RuleBasedCollator 来比较重音字符串。但是有两点警告：首先，如果要整理的字符串包含不规范顺序的组合序列，那么应该把 collator 设置为 CANONICAL_DECOMPOSITION 或 FULL_DECOMPOSITION 以启用组合序列的排序。其次，如果字符串包含兼容性分解的字符（例如全角和半角形式），那么必须使用 FULL_DECOMPOSITION，因为规则表只包括规范的映射。

错误

以下为错误：

  • 文本参数包含未使用引号的标点符号（例如 "a < b-c < d"）。
  • 关系或重置字符后面没有文本参数（例如 "a < ,b"）。
  • 文本参数（或者文本参数的初始子字符串）不在序列中的重置。（例如 "a < b & e < f"）
如果发生这些错误，RuleBasedCollator 将抛出 ParseException。

以下是例子

Simple: "< a < b < c < d"

在挪威语中： "< a,A< b,B< c,C< d,D< e,E< f,F< g,G< h,H< i,I< j,J < k,K< l,L< m,M< n,N< o,O< p,P< q,Q< r,R< s,S< t,T < u,U< v,V< w,W< x,X< y,Y< z,Z < \u00E5=a\u030A,\u00C5=A\u030A ;aa,AA< \u00E6,\u00C6< \u00F8,\u00D8"

要创建 RuleBasedCollator 对象，使此对象具有特殊的规则以满足需要，应该根据 String 中包含的规则来构造 RuleBasedCollator。例如：

 String simple = "< a< b< c< d";
 RuleBasedCollator mySimple = new RuleBasedCollator(simple);
或者：
 String Norwegian = "< a,A< b,B< c,C< d,D< e,E< f,F< g,G< h,H< i,I< j,J" +
                 "< k,K< l,L< m,M< n,N< o,O< p,P< q,Q< r,R< s,S< t,T" +
                 "< u,U< v,V< w,W< x,X< y,Y< z,Z" +
                 "< \u00E5=a\u030A,\u00C5=A\u030A" +
                 ";aa,AA< \u00E6,\u00C6< \u00F8,\u00D8";
 RuleBasedCollator myNorwegian = new RuleBasedCollator(Norwegian);

可以通过连接规则字符串来创建新的整理字符串。例如，可以连接由 getRules() 返回的规则，以联合多个 RuleBasedCollator。

以下例子演示了如何改变无空格重音字符的顺序。

 // old rule
 String oldRules = "=\u0301;\u0300;\u0302;\u0308"    // main accents
                 + ";\u0327;\u0303;\u0304;\u0305"    // main accents
                 + ";\u0306;\u0307;\u0309;\u030A"    // main accents
                 + ";\u030B;\u030C;\u030D;\u030E"    // main accents
                 + ";\u030F;\u0310;\u0311;\u0312"    // main accents
                 + "< a , A ; ae, AE ; \u00e6 , \u00c6"
                 + "< b , B < c, C < e, E & C < d, D";
 // change the order of accent characters
 String addOn = "& \u0300 ; \u0308 ; \u0302";
 RuleBasedCollator myCollator = new RuleBasedCollator(oldRules + addOn);

另请参见：
Collator, CollationElementIterator

字段摘要
从类 java.text.Collator 继承的字段
CANONICAL_DECOMPOSITION, FULL_DECOMPOSITION, IDENTICAL, NO_DECOMPOSITION, PRIMARY, SECONDARY, TERTIARY
构造方法摘要
RuleBasedCollator(String rules)
RuleBasedCollator 构造方法。
方法摘要
Object | clone() 标准重写，无语义变化。
int | compare(String source, String target) 根据表规则比较存储在两个不同字符串中的字符数据。
boolean | equals(Object obj) 比较两个 collation 对象的相等性。
CollationElementIterator | getCollationElementIterator(CharacterIterator source) 返回给定 String 的 CollationElementIterator。
CollationElementIterator | getCollationElementIterator(String source) 返回给定 String 的 CollationElementIterator。
CollationKey | getCollationKey(String source) 将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。
String | getRules() 获取 collation 对象的基于表的规则。
int | hashCode() 生成基于表的 collation 对象的哈希码
从类 java.text.Collator 继承的方法
compare, equals, getAvailableLocales, getDecomposition, getInstance, getInstance, getStrength, setDecomposition, setStrength
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RuleBasedCollator

public RuleBasedCollator(String rules)
                  throws ParseException
RuleBasedCollator 构造方法。它采用表规则并生成一个整理表。有关整理规则语法的更多信息，请参阅 RuleBasedCollator 类描述。

参数：
rules - 用来生成整理表的整理规则。
抛出：
ParseException - 如果规则的生成进程失败，则抛出一个格式异常。例如，生成规则 "a < ?< d" 将导致构造方法抛出 ParseException，因为 '?' 没有使用引号。
另请参见：
Locale
方法详细信息

getRules

public String getRules()
获取 collation 对象的基于表的规则。

返回：
创建表 collation 对象的整理规则。

getCollationElementIterator

public CollationElementIterator getCollationElementIterator(String source)
返回给定 String 的 CollationElementIterator。

另请参见：
CollationElementIterator

getCollationElementIterator

public CollationElementIterator getCollationElementIterator(CharacterIterator source)
返回给定 String 的 CollationElementIterator。

从以下版本开始：
1.2
另请参见：
CollationElementIterator

compare

public int compare(String source,
                   String target)
根据表规则比较存储在两个不同字符串中的字符数据。返回关于一个字符串小于、大于等于另一个字符串的信息。在子类中这可以被重写。

指定者：
类 Collator 中的 compare
参数：
source - 源字符串。
target - 目标字符串。
返回：
返回一个整数值。如果源小于目标，则该值小于零；如果源等于目标，则该值为零；如果源大于目标，则该值大于零。
另请参见：
CollationKey, Collator.getCollationKey(java.lang.String)

getCollationKey

public CollationKey getCollationKey(String source)
将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。这将重写 java.text.Collator.getCollationKey。在子类中它可以被重写。

指定者：
类 Collator 中的 getCollationKey
参数：
source - 将要被转换为整理键的字符串。
返回：
根据此 Collator 的整理规则为给定 String 创建的 CollationKey。如果源 String 为 null，则返回一个 null CollationKey。
另请参见：
CollationKey, Collator.compare(java.lang.String, java.lang.String)

clone

public Object clone()
标准重写，无语义变化。

覆盖：
类 Collator 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

equals

public boolean equals(Object obj)
比较两个 collation 对象的相等性。

指定者：
接口 Comparator<Object> 中的 equals
覆盖：
类 Collator 中的 equals
参数：
obj - 要与此对象进行比较的基于表的 collation 对象。
返回：
如果当前的基于表的 collation 对象与基于表的 collation 对象 obj 相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
生成基于表的 collation 对象的哈希码

指定者：
类 Collator 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleDateFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text
类 SimpleDateFormat

java.lang.Object
    继承者  java.text.Format
        继承者  java.text.DateFormat
            继承者  java.text.SimpleDateFormat
所有已实现的接口：
Serializable, Cloneable
public class SimpleDateFormat
extends DateFormat

SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。它允许进行格式化（日期 -> 文本）、解析（文本 -> 日期）和规范化。

SimpleDateFormat 使得可以选择任何用户定义的日期-时间格式的模式。但是，仍然建议通过 DateFormat 中的 getTimeInstance、getDateInstance 或 getDateTimeInstance 来创建日期-时间格式器。每一个这样的类方法都能够返回一个以默认格式模式初始化的日期/时间格式器。可以根据需要使用 applyPattern 方法来修改格式模式。有关使用这些方法的更多信息，请参阅 DateFormat。

日期和时间模式

日期和时间格式由日期和时间模式 字符串指定。在日期和时间模式字符串中，未加引号的字母 'A' 到 'Z' 和 'a' 到 'z' 被解释为模式字母，用来表示日期或时间字符串元素。文本可以使用单引号 (') 引起来，以免进行解释。"''" 表示单引号。所有其他字符均不解释；只是在格式化时将它们简单复制到输出字符串，或者在解析时与输入字符串进行匹配。

定义了以下模式字母（所有其他字符 'A' 到 'Z' 和 'a' 到 'z' 都被保留）：

字母 | 日期或时间元素 | 表示 | 示例
G | Era 标志符 | Text | AD
y | 年 | Year | 1996; 96
M | 年中的月份 | Month | July; Jul; 07
w | 年中的周数 | Number | 27
W | 月份中的周数 | Number | 2
D | 年中的天数 | Number | 189
d | 月份中的天数 | Number | 10
F | 月份中的星期 | Number | 2
E | 星期中的天数 | Text | Tuesday; Tue
a | Am/pm 标记 | Text | PM
H | 一天中的小时数（0-23） | Number | 0
k | 一天中的小时数（1-24） | Number | 24
K | am/pm 中的小时数（0-11） | Number | 0
h | am/pm 中的小时数（1-12） | Number | 12
m | 小时中的分钟数 | Number | 30
s | 分钟中的秒数 | Number | 55
S | 毫秒数 | Number | 978
z | 时区 | General time zone | Pacific Standard Time; PST; GMT-08:00
Z | 时区 | RFC 822 time zone | -0800
模式字母通常是重复的，其数量确定其精确表示：
  • Text: 对于格式化来说，如果模式字母的数量大于等于 4，则使用完全形式；否则，在可用的情况下使用短形式或缩写形式。对于解析来说，两种形式都是可接受的，与模式字母的数量无关。
  • Number: 对于格式化来说，模式字母的数量是最小的数位，如果数位不够，则用 0 填充以达到此数量。对于解析来说，模式字母的数量被忽略，除非必须分开两个相邻字段。
  • Year: 如果格式器的 Calendar 是格里高利历，则应用以下规则。
    • 对于格式化来说，如果模式字母的数量为 2，则年份截取为 2 位数,否则将年份解释为 number。
    • 对于解析来说，如果模式字母的数量大于 2，则年份照字面意义进行解释，而不管数位是多少。因此使用模式 "MM/dd/yyyy"，将 "01/11/12" 解析为公元 12 年 1 月 11 日。
    • 在解析缩写年份模式（"y" 或 "yy"）时，SimpleDateFormat 必须相对于某个世纪来解释缩写的年份。这通过将日期调整为 SimpleDateFormat 实例创建之前的 80 年和之后 20 年范围内来完成。例如，在 "MM/dd/yy" 模式下，如果 SimpleDateFormat 实例是在 1997 年 1 月 1 日创建的，则字符串 "01/11/12" 将被解释为 2012 年 1 月 11 日，而字符串 "05/04/64" 将被解释为 1964 年 5 月 4 日。在解析时，只有恰好由两位数字组成的字符串（如 Character.isDigit(char) 所定义的）被解析为默认的世纪。其他任何数字字符串将照字面意义进行解释，例如单数字字符串，3 个或更多数字组成的字符串，或者不都是数字的两位数字字符串（例如"-1"）。因此，在相同的模式下， "01/02/3" 或 "01/02/003" 解释为公元 3 年 1 月 2 日。同样，"01/02/-3" 解析为公元前 4 年 1 月 2 日。
    否则，则应用日历系统特定的形式。对于格式化和解析，如果模式字母的数量为 4 或大于 4，则使用日历特定的 long form。否则，则使用日历特定的 short or abbreviated form。
  • Month: 如果模式字母的数量为 3 或大于 3，则将月份解释为 text；否则解释为 number。
  • General time zone: 如果时区有名称，则将它们解释为 text。对于表示 GMT 偏移值的时区，使用以下语法：
         GMTOffsetTimeZone:
             GMT Sign Hours : Minutes
     Sign: one of
             + -
     Hours:
             Digit
             Digit Digit
     Minutes:
             Digit Digit
     Digit: one of
             0 1 2 3 4 5 6 7 8 9
    Hours 必须在 0 到 23 之间，Minutes 必须在 00 到 59 之间。格式是与语言环境无关的，并且数字必须取自 Unicode 标准的 Basic Latin 块。

    对于解析来说，RFC 822 time zones 也是可接受的。

  • RFC 822 time zone: 对于格式化来说，使用 RFC 822 4-digit 时区格式：
         RFC822TimeZone:
             Sign TwoDigitHours Minutes
     TwoDigitHours:
             Digit Digit
    TwoDigitHours 必须在 00 和 23 之间。其他定义请参阅 general time zones。

    对于解析来说，general time zones 也是可接受的。

SimpleDateFormat 还支持本地化日期和时间模式 字符串。在这些字符串中，以上所述的模式字母可以用其他与语言环境有关的模式字母来替换。SimpleDateFormat 不处理除模式字母之外的文本本地化；而由类的客户端来处理。

示例

以下示例显示了如何在美国语言环境中解释日期和时间模式。给定的日期和时间为美国太平洋时区的本地时间 2001-07-04 12:08:56。
日期和时间模式 | 结果
"yyyy.MM.dd G 'at' HH:mm:ss z" | 2001.07.04 AD at 12:08:56 PDT
"EEE, MMM d, ''yy" | Wed, Jul 4, '01
"h:mm a" | 12:08 PM
"hh 'o''clock' a, zzzz" | 12 o'clock PM, Pacific Daylight Time
"K:mm a, z" | 0:08 PM, PDT
"yyyyy.MMMMM.dd GGG hh:mm aaa" | 02001.July.04 AD 12:08 PM
"EEE, d MMM yyyy HH:mm:ss Z" | Wed, 4 Jul 2001 12:08:56 -0700
"yyMMddHHmmssZ" | 010704120856-0700
"yyyy-MM-dd'T'HH:mm:ss.SSSZ" | 2001-07-04T12:08:56.235-0700

同步

日期格式是不同步的。建议为每个线程创建独立的格式实例。如果多个线程同时访问一个格式，则它必须是外部同步的。

另请参见：
Java Tutorial, Calendar, TimeZone, DateFormat, DateFormatSymbols, 序列化表格

嵌套类摘要
从类 java.text.DateFormat 继承的嵌套类/接口
DateFormat.Field
字段摘要
从类 java.text.DateFormat 继承的字段
AM_PM_FIELD, calendar, DATE_FIELD, DAY_OF_WEEK_FIELD, DAY_OF_WEEK_IN_MONTH_FIELD, DAY_OF_YEAR_FIELD, DEFAULT, ERA_FIELD, FULL, HOUR_OF_DAY0_FIELD, HOUR_OF_DAY1_FIELD, HOUR0_FIELD, HOUR1_FIELD, LONG, MEDIUM, MILLISECOND_FIELD, MINUTE_FIELD, MONTH_FIELD, numberFormat, SECOND_FIELD, SHORT, TIMEZONE_FIELD, WEEK_OF_MONTH_FIELD, WEEK_OF_YEAR_FIELD, YEAR_FIELD
构造方法摘要
SimpleDateFormat()
用默认的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String pattern)
用给定的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。
SimpleDateFormat(String pattern, DateFormatSymbols formatSymbols)
用给定的模式和日期符号构造 SimpleDateFormat。
SimpleDateFormat(String pattern, Locale locale)
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。
方法摘要
void | applyLocalizedPattern(String pattern) 将给定的本地化模式字符串应用于此日期格式。
void | applyPattern(String pattern) 将给定模式字符串应用于此日期格式。
Object | clone() 创建此 SimpleDateFormat 的一个副本。
boolean | equals(Object obj) 比较给定对象与此 SimpleDateFormat 的相等性。
StringBuffer | format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
AttributedCharacterIterator | formatToCharacterIterator(Object obj) 格式化生成 AttributedCharacterIterator 的对象。
Date | get2DigitYearStart() 返回在 100 年周期内被解释的两位数字年份的开始日期。
DateFormatSymbols | getDateFormatSymbols() 获取此日期格式的日期和时间格式符号的一个副本。
int | hashCode() 返回此 SimpleDateFormat 对象的哈希码值。
Date | parse(String text, ParsePosition pos) 解析字符串的文本，生成 Date。
void | set2DigitYearStart(Date startDate) 设置 100 年周期的两位数年份，该年份将被解释为从用户指定的日期开始。
void | setDateFormatSymbols(DateFormatSymbols newFormatSymbols) 设置此日期格式的日期和时间格式符号。
String | toLocalizedPattern() 返回描述此日期格式的本地化模式字符串。
String | toPattern() 返回描述此日期格式的模式字符串。
从类 java.text.DateFormat 继承的方法
format, format, getAvailableLocales, getCalendar, getDateInstance, getDateInstance, getDateInstance, getDateTimeInstance, getDateTimeInstance, getDateTimeInstance, getInstance, getNumberFormat, getTimeInstance, getTimeInstance, getTimeInstance, getTimeZone, isLenient, parse, parseObject, setCalendar, setLenient, setNumberFormat, setTimeZone
从类 java.text.Format 继承的方法
format, parseObject
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SimpleDateFormat

public SimpleDateFormat()
用默认的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。注：此构造方法可能不支持所有语言环境。要覆盖所有地区，请使用 DateFormat 类中的工厂方法。

SimpleDateFormat

public SimpleDateFormat(String pattern)
用给定的模式和默认语言环境的日期格式符号构造 SimpleDateFormat。注：此构造方法可能不支持所有语言环境。要覆盖所有语言环境，请使用 DateFormat 类中的工厂方法。

参数：
pattern - 描述日期和时间格式的模式
抛出：
NullPointerException - 如果给定的模式为 null
IllegalArgumentException - 如果给定的模式无效

SimpleDateFormat

public SimpleDateFormat(String pattern,
                        Locale locale)
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。注：此构造方法可能不支持所有语言环境。要覆盖所有语言环境，请使用 DateFormat 类中的工厂方法。

参数：
pattern - 描述日期和时间格式的模式
locale - 其日期格式符号要被使用的语言环境
抛出：
NullPointerException - 如果给定的模式或语言环境为 null
IllegalArgumentException - 如果给定的模式无效

SimpleDateFormat

public SimpleDateFormat(String pattern,
                        DateFormatSymbols formatSymbols)
用给定的模式和日期符号构造 SimpleDateFormat。

参数：
pattern - 描述日期和时间格式的模式
formatSymbols - 要用来格式化的日期格式符号
抛出：
NullPointerException - 如果给定的模式或 formatSymbols 为 null
IllegalArgumentException - 如果给定的模式无效
方法详细信息

set2DigitYearStart

public void set2DigitYearStart(Date startDate)
设置 100 年周期的两位数年份，该年份将被解释为从用户指定的日期开始。

参数：
startDate - 在解析时，两位数年份将被置于 startDate 和 startDate + 100 years 之间的范围内。
从以下版本开始：
1.2
另请参见：
get2DigitYearStart()

get2DigitYearStart

public Date get2DigitYearStart()
返回在 100 年周期内被解释的两位数字年份的开始日期。

返回：
在 100 年周期内被解析的两位数字年份的开始日期
从以下版本开始：
1.2
另请参见：
set2DigitYearStart(java.util.Date)

format

public StringBuffer format(Date date,
                           StringBuffer toAppendTo,
                           FieldPosition pos)
将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。

指定者：
类 DateFormat 中的 format
参数：
date - 要被格式化为日期-时间字符串的日期-时间值。
toAppendTo - 新的日期-时间文本被添加的位置。
pos - 格式化的位置。输入时：如果需要，是一个对齐字段。输出时：为对齐字段的偏移量。
返回：
格式化的日期-时间字符串。
抛出：
NullPointerException - 如果给定的日期为 null

formatToCharacterIterator

public AttributedCharacterIterator formatToCharacterIterator(Object obj)
格式化生成 AttributedCharacterIterator 的对象。可以使用返回的 AttributedCharacterIterator 来生成所得的字符串，以及确定关于所得字符串的信息。

AttributedCharacterIterator 的每个属性键都是 DateFormat.Field 类型的，对应的属性值与属性键相同。

覆盖：
类 Format 中的 formatToCharacterIterator
参数：
obj - 要格式化的对象
返回：
描述格式化的值的 AttributedCharacterIterator。
抛出：
NullPointerException - 如果 obj 为 null。
IllegalArgumentException - 如果 Format 不能格式化给定的对象，或者 Format 的模式字符串无效。
从以下版本开始：
1.4

parse

public Date parse(String text,
                  ParsePosition pos)
解析字符串的文本，生成 Date。

此方法试图解析从 pos 给定的索引处开始的文本。如果解析成功，则将 pos 的索引更新为所用最后一个字符后面的索引（不必对直到字符串结尾的所有字符进行解析），并返回解析得到的日期。更新后的 pos 可以用来指示下次调用此方法的起始点。如果发生错误，则不更改 pos 的索引，并将 pos 的错误索引设置为发生错误处的字符索引，并且返回 null。

指定者：
类 DateFormat 中的 parse
参数：
text - 应该解析其中一部分的 String。
pos - 具有以上所述的索引和错误索引信息的 ParsePosition 对象。
返回：
从字符串进行解析的 Date。如果发生错误，则返回 null。
抛出：
NullPointerException - 如果 text 或 pos 为 null。
另请参见：
DateFormat.setLenient(boolean)

toPattern

public String toPattern()
返回描述此日期格式的模式字符串。

返回：
描述此日期格式的模式字符串。

toLocalizedPattern

public String toLocalizedPattern()
返回描述此日期格式的本地化模式字符串。

返回：
描述此日期格式的本地化模式字符串。

applyPattern

public void applyPattern(String pattern)
将给定模式字符串应用于此日期格式。

参数：
pattern - 此日期格式的新的日期和时间模式
抛出：
NullPointerException - 如果给定的模式为 null
IllegalArgumentException - 如果给定的模式无效

applyLocalizedPattern

public void applyLocalizedPattern(String pattern)
将给定的本地化模式字符串应用于此日期格式。

参数：
pattern - 要被映射到此格式的新的日期和时间格式模式的字符串
抛出：
NullPointerException - 如果给定的模式为 null
IllegalArgumentException - 如果给定的模式无效

getDateFormatSymbols

public DateFormatSymbols getDateFormatSymbols()
获取此日期格式的日期和时间格式符号的一个副本。

返回：
此日期格式的日期和时间格式符号
另请参见：
setDateFormatSymbols(java.text.DateFormatSymbols)

setDateFormatSymbols

public void setDateFormatSymbols(DateFormatSymbols newFormatSymbols)
设置此日期格式的日期和时间格式符号。

参数：
newFormatSymbols - 新的日期和时间格式符号
抛出：
NullPointerException - 如果给定的 newFormatSymbols 为 null
另请参见：
getDateFormatSymbols()

clone

public Object clone()
创建此 SimpleDateFormat 的一个副本。此副本也将复制格式的日期格式符号。

覆盖：
类 DateFormat 中的 clone
返回：
此 SimpleDateFormat 的一个副本
另请参见：
Cloneable

hashCode

public int hashCode()
返回此 SimpleDateFormat 对象的哈希码值。

覆盖：
类 DateFormat 中的 hashCode
返回：
此 SimpleDateFormat 对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较给定对象与此 SimpleDateFormat 的相等性。

覆盖：
类 DateFormat 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
true 如果给定对象与此 SimpleDateFormat 相等
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringCharacterIterator (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.text
类 StringCharacterIterator

java.lang.Object
    继承者  java.text.StringCharacterIterator
所有已实现的接口：
Cloneable, CharacterIterator
public final class StringCharacterIterator
extends Object
implements CharacterIterator

StringCharacterIterator 为 String 实现 CharacterIterater 协议。StringCharacterIterator 类对整个 String 进行迭代。

另请参见：
CharacterIterator

字段摘要
从接口 java.text.CharacterIterator 继承的字段
DONE
构造方法摘要
StringCharacterIterator(String text)
构造初始索引为 0 的迭代器。
StringCharacterIterator(String text, int pos)
构造具有指定的初始索引的迭代器。
StringCharacterIterator(String text, int begin, int end, int pos)
构造对给定字符串的给定范围进行迭代的迭代器（其索引设置为指定位置）。
方法摘要
 Object clone()
创建此迭代器的副本。
 char current()
实现 String 的 CharacterIterator.current()。
 boolean equals(Object obj)
比较两个 StringCharacterIterator 对象的相等性。
 char first()
实现 String 的 CharacterIterator.first()。
 int getBeginIndex()
实现 String 的 CharacterIterator.getBeginIndex()。
 int getEndIndex()
实现 String 的 CharacterIterator.getEndIndex()。
 int getIndex()
实现 String 的 CharacterIterator.getIndex()。
 int hashCode()
计算此迭代器的哈希码。
 char last()
实现 String 的 CharacterIterator.last()。
 char next()
实现 String 的 CharacterIterator.next()。
 char previous()
实现 String 的 CharacterIterator.previous()。
 char setIndex(int p)
实现 String 的 CharacterIterator.setIndex()。
 void setText(String text)
将此迭代器重置为指向一个新的字符串。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringCharacterIterator

public StringCharacterIterator(String text)
构造初始索引为 0 的迭代器。

StringCharacterIterator

public StringCharacterIterator(String text,
                               int pos)
构造具有指定的初始索引的迭代器。

参数：
text - 要对其进行迭代的 String
pos - 初始迭代器位置

StringCharacterIterator

public StringCharacterIterator(String text,
                               int begin,
                               int end,
                               int pos)
构造对给定字符串的给定范围进行迭代的迭代器（其索引设置为指定位置）。

参数：
text - 要对其进行迭代的 String
begin - 首字符的索引
end - 最后一个字符后面的字符的索引
pos - 迭代器的初始位置
方法详细信息

setText

public void setText(String text)
将此迭代器重置为指向一个新的字符串。此包可见的（package-visible）方法由其他 java.text 类使用，这些类需要在每次调用其 setText 方法时避免分配新的 StringCharacterIterator 对象。

参数：
text - 要对其进行迭代的 String
从以下版本开始：
1.2

first

public char first()
实现 String 的 CharacterIterator.first()。

指定者：
接口 CharacterIterator 中的 first
返回：
文本中的第一个字符，如果文本为空，则返回 DONE
另请参见：
CharacterIterator.first()

last

public char last()
实现 String 的 CharacterIterator.last()。

指定者：
接口 CharacterIterator 中的 last
返回：
文本中的最后一个字符，如果文本为空，则返回 DONE
另请参见：
CharacterIterator.last()

setIndex

public char setIndex(int p)
实现 String 的 CharacterIterator.setIndex()。

指定者：
接口 CharacterIterator 中的 setIndex
参数：
p - 文本中的位置。从 getBeginIndex() 到 getEndIndex() 的有效值。如果提供了无效值，则抛出 IllegalArgumentException。
返回：
指定位置的字符；如果指定位置等于 getEndIndex()，则返回 DONE
另请参见：
CharacterIterator.setIndex(int)

current

public char current()
实现 String 的 CharacterIterator.current()。

指定者：
接口 CharacterIterator 中的 current
返回：
当前位置的字符；如果当前位置已超出文本末尾，则返回 DONE。
另请参见：
CharacterIterator.current()

next

public char next()
实现 String 的 CharacterIterator.next()。

指定者：
接口 CharacterIterator 中的 next
返回：
新位置的索引；如果该新位置已超出文本范围的末尾，则返回 DONE。
另请参见：
CharacterIterator.next()

previous

public char previous()
实现 String 的 CharacterIterator.previous()。

指定者：
接口 CharacterIterator 中的 previous
返回：
新位置的字符；如果当前位置等于 getBeginIndex()，则返回 DONE。
另请参见：
CharacterIterator.previous()

getBeginIndex

public int getBeginIndex()
实现 String 的 CharacterIterator.getBeginIndex()。

指定者：
接口 CharacterIterator 中的 getBeginIndex
返回：
文本开始处的索引。
另请参见：
CharacterIterator.getBeginIndex()

getEndIndex

public int getEndIndex()
实现 String 的 CharacterIterator.getEndIndex()。

指定者：
接口 CharacterIterator 中的 getEndIndex
返回：
文本中最后一个字符后面的索引
另请参见：
CharacterIterator.getEndIndex()

getIndex

public int getIndex()
实现 String 的 CharacterIterator.getIndex()。

指定者：
接口 CharacterIterator 中的 getIndex
返回：
当前索引。
另请参见：
CharacterIterator.getIndex()

equals

public boolean equals(Object obj)
比较两个 StringCharacterIterator 对象的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要进行比较的 StringCharacterIterator 对象。
返回：
如果给定的 obj 与 StringCharacterIterator 对象相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
计算此迭代器的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

clone

public Object clone()
创建此迭代器的副本。

指定者：
接口 CharacterIterator 中的 clone
覆盖：
类 Object 中的 clone
返回：
此迭代器的副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.text (Java 2 Platform SE 6)

 java.text
接口
AttributedCharacterIterator
CharacterIterator
类
Annotation
AttributedCharacterIterator.Attribute
AttributedString
Bidi
BreakIterator
ChoiceFormat
CollationElementIterator
CollationKey
Collator
DateFormat
DateFormat.Field
DateFormatSymbols
DecimalFormat
DecimalFormatSymbols
FieldPosition
Format
Format.Field
MessageFormat
MessageFormat.Field
Normalizer
NumberFormat
NumberFormat.Field
ParsePosition
RuleBasedCollator
SimpleDateFormat
StringCharacterIterator
枚举
Normalizer.Form
异常
ParseException


java.text (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.text

提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

请参见：
描述

接口摘要
AttributedCharacterIterator | AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
CharacterIterator | 此接口定义了对文本进行双向迭代的协议。

类摘要
Annotation | 如果文本属性具有 annotation 特征，则 Annotation 对象用作文本属性值的包装器。
AttributedCharacterIterator.Attribute | 定义用于标识文本属性的属性键。
AttributedString | AttributedString 保存文本及相关属性信息。
Bidi | 此类实现了 Unicode 双向算法 (Unicode Bidirectional Algorithm)。
BreakIterator | BreakIterator 类实现用于查找文本中边界位置的方法。
ChoiceFormat | ChoiceFormat 允许将格式应用到某个范围的数。
CollationElementIterator | CollationElementIterator 类用作一个迭代器，以遍历国际化字符串的每个字符。
CollationKey | CollationKey 表示遵守特定 Collator 对象规则的 String。
Collator | Collator 类执行区分语言环境的 String 比较。
DateFormat | DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
DateFormat.Field | 定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
DateFormatSymbols | DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
DecimalFormat | DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
DecimalFormatSymbols | 此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
FieldPosition | FieldPosition 是 Format 及其子类用于在格式输出中标识字段的简单类。
Format | Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
Format.Field | 定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
MessageFormat | MessageFormat 提供了以与语言无关方式生成连接消息的方式。
MessageFormat.Field | 在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
Normalizer | 此类提供 normalize 方法，它把 Unicode 文本转换为等效的组合或分解形式，允许对文本进行更方便地分类和搜索。
NumberFormat | NumberFormat 是所有数值格式的抽象基类。
NumberFormat.Field | 定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。
ParsePosition | ParsePosition 是 Format 及其子类所使用的简单类，用来在解析过程中跟踪当前位置。
RuleBasedCollator | RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。
SimpleDateFormat | SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。
StringCharacterIterator | StringCharacterIterator 为 String 实现 CharacterIterater 协议。

枚举摘要
Normalizer.Form 此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。

异常摘要
ParseException 表示解析时出现意外错误。

软件包 java.text 的描述

提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。这意味着所编写的主程序或 applet 是与语言无关的，并且它可以依靠独立的、动态链接的本地化资源。这实现了随时为新本地化添加本地化的灵活性。

这些类能够格式化日期、数字和消息、解析、搜索和排序字符串，以及迭代字符、单词、语句和换行符。此包包含类和接口的三大主要组：

  • 用于迭代文本的类
  • 用于格式化和分析的类
  • 用于整理字符串的类

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.text 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.text 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.text.Annotation
    • java.text.AttributedCharacterIterator.Attribute (implements java.io.Serializable)
      • java.text.Format.Field
        • java.text.DateFormat.Field
        • java.text.MessageFormat.Field
        • java.text.NumberFormat.Field
    • java.text.AttributedString
    • java.text.Bidi
    • java.text.BreakIterator (implements java.lang.Cloneable)
    • java.text.CollationElementIterator
    • java.text.CollationKey (implements java.lang.Comparable<T>)
    • java.text.Collator (implements java.lang.Cloneable, java.util.Comparator<T>)
      • java.text.RuleBasedCollator
    • java.text.DateFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • java.text.DecimalFormatSymbols (implements java.lang.Cloneable, java.io.Serializable)
    • java.text.FieldPosition
    • java.text.Format (implements java.lang.Cloneable, java.io.Serializable)
      • java.text.DateFormat
        • java.text.SimpleDateFormat
      • java.text.MessageFormat
      • java.text.NumberFormat
        • java.text.ChoiceFormat
        • java.text.DecimalFormat
    • java.text.Normalizer
    • java.text.ParsePosition
    • java.text.StringCharacterIterator (implements java.text.CharacterIterator)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.text.ParseException

接口分层结构

  • java.lang.Cloneable
    • java.text.CharacterIterator
      • java.text.AttributedCharacterIterator

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.text.Normalizer.Form
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.text 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.text
的使用

使用 java.text 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 使用的 java.text 中的类
AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
AttributedCharacterIterator.Attribute
定义用于标识文本属性的属性键。
CharacterIterator
此接口定义了对文本进行双向迭代的协议。

java.awt.event 使用的 java.text 中的类
AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。

java.awt.font 使用的 java.text 中的类
AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
AttributedCharacterIterator.Attribute
定义用于标识文本属性的属性键。
BreakIterator
BreakIterator 类实现用于查找文本中边界位置的方法。

java.awt.im 使用的 java.text 中的类
AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
AttributedCharacterIterator.Attribute
定义用于标识文本属性的属性键。

java.awt.im.spi 使用的 java.text 中的类
AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。

java.text 使用的 java.text 中的类
AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
AttributedCharacterIterator.Attribute
定义用于标识文本属性的属性键。
Bidi
此类实现了 Unicode 双向算法 (Unicode Bidirectional Algorithm)。
BreakIterator
BreakIterator 类实现用于查找文本中边界位置的方法。
CharacterIterator
此接口定义了对文本进行双向迭代的协议。
CollationElementIterator
CollationElementIterator 类用作一个迭代器，以遍历国际化字符串的每个字符。
CollationKey
CollationKey 表示遵守特定 Collator 对象规则的 String。
Collator
Collator 类执行区分语言环境的 String 比较。
DateFormat
DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
DateFormat.Field
定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
DateFormatSymbols
DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
DecimalFormatSymbols
此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
FieldPosition
FieldPosition 是 Format 及其子类用于在格式输出中标识字段的简单类。
Format
Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
Format.Field
定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
MessageFormat.Field
在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
Normalizer.Form
此枚举提供在 Unicode Standard Annex #15 — Unicode Normalization Forms 中描述的四个 Unicode 标准化形式的常量，以及访问这些常量的两个方法。
NumberFormat
NumberFormat 是所有数值格式的抽象基类。
NumberFormat.Field
定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。
ParseException
表示解析时出现意外错误。
ParsePosition
ParsePosition 是 Format 及其子类所使用的简单类，用来在解析过程中跟踪当前位置。

java.text.spi 使用的 java.text 中的类
BreakIterator
BreakIterator 类实现用于查找文本中边界位置的方法。
Collator
Collator 类执行区分语言环境的 String 比较。
DateFormat
DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
DateFormatSymbols
DateFormatSymbols 是一个公共类，用于封装可本地化的日期-时间格式化数据，如月名、星期几的名称和时区数据。
DecimalFormatSymbols
此类表示了 DecimalFormat 格式化数字所需的符号集（如小数点、组分隔符等等）。
NumberFormat
NumberFormat 是所有数值格式的抽象基类。

javax.swing 使用的 java.text 中的类
AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。
DecimalFormat
DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
Format
Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
MessageFormat
MessageFormat 提供了以与语言无关方式生成连接消息的方式。
ParseException
表示解析时出现意外错误。
SimpleDateFormat
SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

javax.swing.plaf.synth 使用的 java.text 中的类
ParseException
表示解析时出现意外错误。

javax.swing.text 使用的 java.text 中的类
CharacterIterator
此接口定义了对文本进行双向迭代的协议。
DateFormat
DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
Format
Format 是一个用于格式化语言环境敏感的信息（如日期、消息和数字）的抽象基类。
Format.Field
定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
MessageFormat
MessageFormat 提供了以与语言无关方式生成连接消息的方式。
NumberFormat
NumberFormat 是所有数值格式的抽象基类。
ParseException
表示解析时出现意外错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BreakIteratorProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.text.spi
类 BreakIteratorProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.text.spi.BreakIteratorProvider

public abstract class BreakIteratorProvider
extends LocaleServiceProvider

提供 BreakIterator 类具体实现的服务提供者的抽象类。

从以下版本开始：
1.6

构造方法摘要
protected BreakIteratorProvider()
唯一的构造方法。
方法摘要
abstract BreakIterator | getCharacterInstance(Locale locale) 为给定语言环境的字符分解返回新的 BreakIterator 实例。
abstract BreakIterator | getLineInstance(Locale locale) 为给定语言环境的行分解返回新的 BreakIterator 实例。
abstract BreakIterator | getSentenceInstance(Locale locale) 为给定语言环境的句子分解返回新的 BreakIterator 实例。
abstract BreakIterator | getWordInstance(Locale locale) 为给定语言环境的单词分解返回一个新 BreakIterator 实例。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BreakIteratorProvider

protected BreakIteratorProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getWordInstance

public abstract BreakIterator getWordInstance(Locale locale)
为给定语言环境的单词分解返回一个新 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
单词分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
BreakIterator.getWordInstance(java.util.Locale)

getLineInstance

public abstract BreakIterator getLineInstance(Locale locale)
为给定语言环境的行分解返回新的 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
行分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
BreakIterator.getLineInstance(java.util.Locale)

getCharacterInstance

public abstract BreakIterator getCharacterInstance(Locale locale)
为给定语言环境的字符分解返回新的 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
字符分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
BreakIterator.getCharacterInstance(java.util.Locale)

getSentenceInstance

public abstract BreakIterator getSentenceInstance(Locale locale)
为给定语言环境的句子分解返回新的 BreakIterator 实例。

参数：
locale - 所需的语言环境
返回：
句子分解的分解迭代器
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
BreakIterator.getSentenceInstance(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CollatorProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text.spi
类 CollatorProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.text.spi.CollatorProvider

public abstract class CollatorProvider
extends LocaleServiceProvider

提供 Collator 类具体实现的服务提供者的抽象类。

从以下版本开始：
1.6

构造方法摘要
protected CollatorProvider()
唯一的构造方法（由子类构造方法调用，通常是隐式的）。
方法摘要
abstract  Collator getInstance(Locale locale)
为指定语言环境返回新的 Collator 实例。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CollatorProvider

protected CollatorProvider()
唯一的构造方法（由子类构造方法调用，通常是隐式的）。

方法详细信息

getInstance

public abstract Collator getInstance(Locale locale)
为指定语言环境返回新的 Collator 实例。

参数：
locale - 所需的语言环境。
返回：
所需语言环境的 Collator。
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
Collator.getInstance(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateFormatProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text.spi
类 DateFormatProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.text.spi.DateFormatProvider

public abstract class DateFormatProvider
extends LocaleServiceProvider

提供 DateFormat 类具体实现的服务提供者的抽象类。

从以下版本开始：
1.6

构造方法摘要
protected DateFormatProvider()
唯一的构造方法。
方法摘要
abstract DateFormat | getDateInstance(int style, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。
abstract DateFormat | getDateTimeInstance(int dateStyle, int timeStyle, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。
abstract DateFormat | getTimeInstance(int style, Locale locale) 返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DateFormatProvider

protected DateFormatProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getTimeInstance

public abstract DateFormat getTimeInstance(int style,
                                           Locale locale)
返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。

参数：
style - 给定的格式化风格。DateFormat.SHORT、DateFormat.MEDIUM、DateFormat.LONG 或 DateFormat.FULL 之一。
locale - 所需的语言环境。
返回：
一个时间格式器
抛出：
IllegalArgumentException - 如果 style 无效，或者 locale 不是 getAvailableLocales() 返回的语言环境之一。
NullPointerException - 如果 locale 为 null
另请参见：
DateFormat.getTimeInstance(int, java.util.Locale)

getDateInstance

public abstract DateFormat getDateInstance(int style,
                                           Locale locale)
返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。

参数：
style - 给定的格式化风格。DateFormat.SHORT、DateFormat.MEDIUM、DateFormat.LONG 或 DateFormat.FULL 之一。
locale - 所需的语言环境。
返回：
一个日期格式器
抛出：
IllegalArgumentException - 如果 style 无效，或者 locale 不是 getAvailableLocales() 返回的语言环境之一。
NullPointerException - 如果 locale 为 null
另请参见：
DateFormat.getDateInstance(int, java.util.Locale)

getDateTimeInstance

public abstract DateFormat getDateTimeInstance(int dateStyle,
                                               int timeStyle,
                                               Locale locale)
返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。

参数：
dateStyle - 给定的日期格式化风格。DateFormat.SHORT、DateFormat.MEDIUM、DateFormat.LONG 或 DateFormat.FULL 之一。
timeStyle - 给定的时间格式化风格。DateFormat.SHORT、DateFormat.MEDIUM、DateFormat.LONG 或 DateFormat.FULL 之一。
locale - 所需的语言环境。
返回：
一个 日期/时间格式器。
抛出：
IllegalArgumentException - 如果 dateStyle 或 timeStyle 无效，如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
NullPointerException - 如果 locale 为 null
另请参见：
DateFormat.getDateTimeInstance(int, int, java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateFormatSymbolsProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text.spi
类 DateFormatSymbolsProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.text.spi.DateFormatSymbolsProvider

public abstract class DateFormatSymbolsProvider
extends LocaleServiceProvider

提供 DateFormatSymbols 类实例的服务提供者的抽象类。

从以下版本开始：
1.6

构造方法摘要
protected DateFormatSymbolsProvider()
唯一的构造方法。
方法摘要
abstract  DateFormatSymbols getInstance(Locale locale)
为指定语言环境返回一个新的 DateFormatSymbols 实例。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DateFormatSymbolsProvider

protected DateFormatSymbolsProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getInstance

public abstract DateFormatSymbols getInstance(Locale locale)
为指定语言环境返回一个新的 DateFormatSymbols 实例。

参数：
locale - 所需的语言环境
返回：
一个 DateFormatSymbols 实例。
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
DateFormatSymbols.getInstance(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DecimalFormatSymbolsProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.text.spi
类 DecimalFormatSymbolsProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.text.spi.DecimalFormatSymbolsProvider

public abstract class DecimalFormatSymbolsProvider
extends LocaleServiceProvider

提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。

从以下版本开始：
1.6

构造方法摘要
protected DecimalFormatSymbolsProvider()
唯一的构造方法。
方法摘要
abstract  DecimalFormatSymbols getInstance(Locale locale)
为指定语言环境返回新的 DecimalFormatSymbols 实例。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DecimalFormatSymbolsProvider

protected DecimalFormatSymbolsProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getInstance

public abstract DecimalFormatSymbols getInstance(Locale locale)
为指定语言环境返回新的 DecimalFormatSymbols 实例。

参数：
locale - 所需的语言环境
返回：
一个 DecimalFormatSymbols 实例。
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
DecimalFormatSymbols.getInstance(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberFormatProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.text.spi
类 NumberFormatProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.text.spi.NumberFormatProvider

public abstract class NumberFormatProvider
extends LocaleServiceProvider

提供 NumberFormat 类具体实现的服务提供者的抽象类。

从以下版本开始：
1.6

构造方法摘要
protected NumberFormatProvider()
唯一的构造方法。
方法摘要
abstract NumberFormat | getCurrencyInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。
abstract NumberFormat | getIntegerInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。
abstract NumberFormat | getNumberInstance(Locale locale) 为指定语言环境返回新的通用 NumberFormat 实例。
abstract NumberFormat | getPercentInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NumberFormatProvider

protected NumberFormatProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getCurrencyInstance

public abstract NumberFormat getCurrencyInstance(Locale locale)
返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。

参数：
locale - 所需的语言环境。
返回：
货币格式器
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
NumberFormat.getCurrencyInstance(java.util.Locale)

getIntegerInstance

public abstract NumberFormat getIntegerInstance(Locale locale)
返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。返回的数的格式使用四舍五入算法（参见 ROUND_HALF_EVEN）将浮点数字舍入为最接近的整数，并只解析输入字符串的整数部分（参见 isParseIntegerOnly）。

参数：
locale - 所需的语言环境
返回：
整数值的数字格式
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
NumberFormat.getIntegerInstance(java.util.Locale)

getNumberInstance

public abstract NumberFormat getNumberInstance(Locale locale)
为指定语言环境返回新的通用 NumberFormat 实例。

参数：
locale - 所需的语言环境
返回：
通用的数字格式器
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
NumberFormat.getNumberInstance(java.util.Locale)

getPercentInstance

public abstract NumberFormat getPercentInstance(Locale locale)
返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。

参数：
locale - 所需的语言环境
返回：
百分比格式器
抛出：
NullPointerException - 如果 locale 为 null
IllegalArgumentException - 如果 locale 不是 getAvailableLocales() 返回的语言环境之一。
另请参见：
NumberFormat.getPercentInstance(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.text.spi (Java 2 Platform SE 6)

 java.text.spi
类
BreakIteratorProvider
CollatorProvider
DateFormatProvider
DateFormatSymbolsProvider
DecimalFormatSymbolsProvider
NumberFormatProvider


java.text.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.text.spi

java.text 包中类的服务提供者类。

请参见：
描述

类摘要
BreakIteratorProvider | 提供 BreakIterator 类具体实现的服务提供者的抽象类。
CollatorProvider | 提供 Collator 类具体实现的服务提供者的抽象类。
DateFormatProvider | 提供 DateFormat 类具体实现的服务提供者的抽象类。
DateFormatSymbolsProvider | 提供 DateFormatSymbols 类实例的服务提供者的抽象类。
DecimalFormatSymbolsProvider | 提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。
NumberFormatProvider | 提供 NumberFormat 类具体实现的服务提供者的抽象类。

软件包 java.text.spi 的描述

java.text 包中类的服务提供者类。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.text.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.text.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.text.spi.BreakIteratorProvider
      • java.text.spi.CollatorProvider
      • java.text.spi.DateFormatProvider
      • java.text.spi.DateFormatSymbolsProvider
      • java.text.spi.DecimalFormatSymbolsProvider
      • java.text.spi.NumberFormatProvider
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.text.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.text.spi
的使用

没有 java.text.spi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.spi.BreakIteratorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.BreakIteratorProvider
的使用

没有 java.text.spi.BreakIteratorProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.spi.DateFormatProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.DateFormatProvider
的使用

没有 java.text.spi.DateFormatProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.spi.CollatorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.CollatorProvider
的使用

没有 java.text.spi.CollatorProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.spi.DecimalFormatSymbolsProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.DecimalFormatSymbolsProvider
的使用

没有 java.text.spi.DecimalFormatSymbolsProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.spi.NumberFormatProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.NumberFormatProvider
的使用

没有 java.text.spi.NumberFormatProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.spi.DateFormatSymbolsProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.spi.DateFormatSymbolsProvider
的使用

没有 java.text.spi.DateFormatSymbolsProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.Annotation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Annotation
的使用

没有 java.text.Annotation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.text.AttributedCharacterIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.text.AttributedCharacterIterator
的使用

使用 AttributedCharacterIterator 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.awt 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 java.awt 中的方法
abstract void | Graphics2D.drawString(AttributedCharacterIterator iterator, float x, float y) 依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
abstract void | Graphics2D.drawString(AttributedCharacterIterator iterator, int x, int y) 依照 TextAttribute 类的规范应用指定迭代器的属性，呈现指定迭代器的文本。
abstract void | Graphics.drawString(AttributedCharacterIterator iterator, int x, int y) 依据 TextAttribute 类的规范应用指定迭代器的属性，呈现迭代器的文本。

java.awt.event 中 AttributedCharacterIterator 的使用

返回 AttributedCharacterIterator 的 java.awt.event 中的方法
 AttributedCharacterIterator InputMethodEvent.getText()
获取已提交文本和撰写文本的组合。

参数类型为 AttributedCharacterIterator 的 java.awt.event 中的构造方法
InputMethodEvent(Component source, int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、文本、插入符和 visiblePosition 来构造 InputMethodEvent。
InputMethodEvent(Component source, int id, long when, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
通过指定源组件、类型、时间、文本、插入符和 visiblePosition 来构造 InputMethodEvent。

java.awt.font 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 java.awt.font 中的方法
void | LineBreakMeasurer.deleteChar(AttributedCharacterIterator newParagraph, int deletePos) 从文本删除单个字符之后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
void | TextMeasurer.deleteChar(AttributedCharacterIterator newParagraph, int deletePos) 从当前由此 TextMeasurer 表示的段落中删除一个字符后，更新 TextMeasurer。
void | LineBreakMeasurer.insertChar(AttributedCharacterIterator newParagraph, int insertPos) 将单个字符插入文本后，更新此 LineBreakMeasurer，并将当前位置设置为段落的开始。
void | TextMeasurer.insertChar(AttributedCharacterIterator newParagraph, int insertPos) 在将单个字符插入当前由此 TextMeasurer 表示的段落中后，更新该 TextMeasurer。

参数类型为 AttributedCharacterIterator 的 java.awt.font 中的构造方法
LineBreakMeasurer(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
LineBreakMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。
TextLayout(AttributedCharacterIterator text, FontRenderContext frc)
根据样式文本上的迭代器构造一个 TextLayout。
TextMeasurer(AttributedCharacterIterator text, FontRenderContext frc)
从源文本构造 TextMeasurer。

java.awt.im 中 AttributedCharacterIterator 的使用

返回 AttributedCharacterIterator 的 java.awt.im 中的方法
AttributedCharacterIterator | InputMethodRequests.cancelLatestCommittedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。
AttributedCharacterIterator | InputMethodRequests.getCommittedText(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes) 获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。
AttributedCharacterIterator | InputMethodRequests.getSelectedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取当前已选定文本。

java.awt.im.spi 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 java.awt.im.spi 中的方法
 void InputMethodContext.dispatchInputMethodEvent(int id, AttributedCharacterIterator text, int committedCharacterCount, TextHitInfo caret, TextHitInfo visiblePosition)
根据给定的参数创建输入方法事件并将其指派到客户端组件。

java.text 中 AttributedCharacterIterator 的使用

返回 AttributedCharacterIterator 的 java.text 中的方法
AttributedCharacterIterator | DecimalFormat.formatToCharacterIterator(Object obj) 格式化一个 Object，以生成一个 AttributedCharacterIterator。
AttributedCharacterIterator | SimpleDateFormat.formatToCharacterIterator(Object obj) 格式化生成 AttributedCharacterIterator 的对象。
AttributedCharacterIterator | MessageFormat.formatToCharacterIterator(Object arguments) 格式化一个对象数组，并将它们插入 MessageFormat 的模式中，生成一个 AttributedCharacterIterator。
AttributedCharacterIterator | Format.formatToCharacterIterator(Object obj) 格式化一个对象，生成一个 AttributedCharacterIterator。
AttributedCharacterIterator | AttributedString.getIterator() 创建一个 AttributedCharacterIterator 实例，提供对整个字符串内容的访问。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。

参数类型为 AttributedCharacterIterator 的 java.text 中的构造方法
AttributedString(AttributedCharacterIterator text)
构造带有 AttributedCharacterIterator 表示的给定属性文本的 AttributedString。
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex)
构造带有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。
Bidi(AttributedCharacterIterator paragraph)
由给定的文本段构造 Bidi。

javax.swing 中 AttributedCharacterIterator 的使用

参数类型为 AttributedCharacterIterator 的 javax.swing 中的方法
 void DebugGraphics.drawString(AttributedCharacterIterator iterator, int x, int y)
重写 Graphics.drawString。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.AttributedCharacterIterator.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.AttributedCharacterIterator.Attribute
的使用

使用 AttributedCharacterIterator.Attribute 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.awt 中 AttributedCharacterIterator.Attribute 的使用

返回 AttributedCharacterIterator.Attribute 的 java.awt 中的方法
 AttributedCharacterIterator.Attribute[] Font.getAvailableAttributes()
返回由此 Font 支持的所有属性的键。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.awt 中的方法参数
Font | Font.deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
static Font | Font.getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 返回适合于这些属性的 Font。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.awt 中的构造方法参数
Font(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
创建一个具有指定属性的新 Font。

java.awt.font 中 AttributedCharacterIterator.Attribute 的使用

java.awt.font 中 AttributedCharacterIterator.Attribute 的子类
 class TextAttribute
TextAttribute 类定义用于呈现文本的属性键和属性值。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.awt.font 中的构造方法参数
TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。

java.awt.im 中 AttributedCharacterIterator.Attribute 的使用

参数类型为 AttributedCharacterIterator.Attribute 的 java.awt.im 中的方法
AttributedCharacterIterator | InputMethodRequests.cancelLatestCommittedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取最新的提交文本，并将其从该组件的文本正文中移除。
AttributedCharacterIterator | InputMethodRequests.getCommittedText(int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes) 获取提供对文本编辑组件中包含的除未提交文本外整个文本和属性访问的迭代器。
AttributedCharacterIterator | InputMethodRequests.getSelectedText(AttributedCharacterIterator.Attribute[] attributes) 从文本编辑组件中获取当前已选定文本。

java.text 中 AttributedCharacterIterator.Attribute 的使用

java.text 中 AttributedCharacterIterator.Attribute 的子类
static class | DateFormat.Field 定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
static class | Format.Field 定义在 AttributedCharacterIterator（从 Format.formatToCharacterIterator 返回）中用作属性键和在 FieldPosition 中用作字段标识符的常量。
static class | MessageFormat.Field 在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
static class | NumberFormat.Field 定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。

声明为 AttributedCharacterIterator.Attribute 的 java.text 中的字段
static AttributedCharacterIterator.Attribute | AttributedCharacterIterator.Attribute.INPUT_METHOD_SEGMENT 输入法段的属性键。
static AttributedCharacterIterator.Attribute | AttributedCharacterIterator.Attribute.LANGUAGE 某些文本的语言的属性键。
static AttributedCharacterIterator.Attribute | AttributedCharacterIterator.Attribute.READING 某些文本的读法的属性键。

返回变量类型为 AttributedCharacterIterator.Attribute 的类型的 java.text 中的方法
Set<AttributedCharacterIterator.Attribute> | AttributedCharacterIterator.getAllAttributeKeys() 返回定义于迭代器文本范围上的所有属性的键。
Map<AttributedCharacterIterator.Attribute,Object> | AttributedCharacterIterator.getAttributes() 返回具有定义于当前字符上的多个属性的映射。

参数类型为 AttributedCharacterIterator.Attribute 的 java.text 中的方法
void | AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value) 将一个属性添加到整个字符串中。
void | AttributedString.addAttribute(AttributedCharacterIterator.Attribute attribute, Object value, int beginIndex, int endIndex) 将一个属性添加到字符串的子范围。
Object | AttributedCharacterIterator.getAttribute(AttributedCharacterIterator.Attribute attribute) 返回当前字符的命名属性的值。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
AttributedCharacterIterator | AttributedString.getIterator(AttributedCharacterIterator.Attribute[] attributes, int beginIndex, int endIndex) 创建一个 AttributedCharacterIterator 实例，提供对字符串选定内容的访问。
int | AttributedCharacterIterator.getRunLimit(AttributedCharacterIterator.Attribute attribute) 返回关于包含当前字符的给定属性的运行之后的第一个字符的索引。
int | AttributedCharacterIterator.getRunStart(AttributedCharacterIterator.Attribute attribute) 返回关于包含当前字符的给定属性的运行的第一个字符的索引。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.text 中的方法参数
void | AttributedString.addAttributes(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex) 将属性集添加到字符串的子范围。
int | AttributedCharacterIterator.getRunLimit(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。
int | AttributedCharacterIterator.getRunStart(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。

参数类型为 AttributedCharacterIterator.Attribute 的 java.text 中的构造方法
AttributedString(AttributedCharacterIterator text, int beginIndex, int endIndex, AttributedCharacterIterator.Attribute[] attributes)
构造具有 AttributedCharacterIterator 表示的给定属性文本子范围的 AttributedString。

类型变量类型为 AttributedCharacterIterator.Attribute 的 java.text 中的构造方法参数
AttributedString(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.AttributedString 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.AttributedString
的使用

没有 java.text.AttributedString 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.Bidi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Bidi
的使用

使用 Bidi 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 Bidi 的使用

返回 Bidi 的 java.text 中的方法
 Bidi Bidi.createLineBidi(int lineStart, int lineLimit)
构造一个 Bidi 对象，表示当前 Bidi 所代表的段落中的一行文本上的双向信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.BreakIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.BreakIterator
的使用

使用 BreakIterator 的软件包
java.awt.font | 提供与字体相关的类和接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.awt.font 中 BreakIterator 的使用

参数类型为 BreakIterator 的 java.awt.font 中的构造方法
LineBreakMeasurer(AttributedCharacterIterator text, BreakIterator breakIter, FontRenderContext frc)
为指定的文本构造一个 LineBreakMeasurer。

java.text 中 BreakIterator 的使用

返回 BreakIterator 的 java.text 中的方法
static BreakIterator | BreakIterator.getCharacterInstance() 返回一个用于默认语言环境 字符分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getCharacterInstance(Locale locale) 返回一个用于给定语言环境字符分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getLineInstance() 返回一个用于默认语言环境 行分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getLineInstance(Locale locale) 返回一个用于给定语言环境行分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getSentenceInstance() 返回一个用于默认语言环境 句子分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getSentenceInstance(Locale locale) 返回一个用于给定语言环境句子分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getWordInstance() 返回一个用于默认语言环境 单词分解的新 BreakIterator 实例。
static BreakIterator | BreakIterator.getWordInstance(Locale locale) 返回一个用于给定语言环境单词分解的新 BreakIterator 实例。

java.text.spi 中 BreakIterator 的使用

返回 BreakIterator 的 java.text.spi 中的方法
abstract BreakIterator | BreakIteratorProvider.getCharacterInstance(Locale locale) 为给定语言环境的字符分解返回新的 BreakIterator 实例。
abstract BreakIterator | BreakIteratorProvider.getLineInstance(Locale locale) 为给定语言环境的行分解返回新的 BreakIterator 实例。
abstract BreakIterator | BreakIteratorProvider.getSentenceInstance(Locale locale) 为给定语言环境的句子分解返回新的 BreakIterator 实例。
abstract BreakIterator | BreakIteratorProvider.getWordInstance(Locale locale) 为给定语言环境的单词分解返回一个新 BreakIterator 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.ChoiceFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.ChoiceFormat
的使用

没有 java.text.ChoiceFormat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.CollationElementIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.CollationElementIterator
的使用

使用 CollationElementIterator 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 CollationElementIterator 的使用

返回 CollationElementIterator 的 java.text 中的方法
CollationElementIterator | RuleBasedCollator.getCollationElementIterator(CharacterIterator source) 返回给定 String 的 CollationElementIterator。
CollationElementIterator | RuleBasedCollator.getCollationElementIterator(String source) 返回给定 String 的 CollationElementIterator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.CollationKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.CollationKey
的使用

使用 CollationKey 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 CollationKey 的使用

返回 CollationKey 的 java.text 中的方法
CollationKey | RuleBasedCollator.getCollationKey(String source) 将字符串转换为能够与 CollationKey.compareTo 进行比较的一系列字符。
abstract CollationKey | Collator.getCollationKey(String source) 将该 String 转换为一系列可以和其他 CollationKey 按位进行比较的位。

参数类型为 CollationKey 的 java.text 中的方法
abstract  int CollationKey.compareTo(CollationKey target)
比较此 CollationKey 与目标 CollationKey。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.ParsePosition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.ParsePosition
的使用

使用 ParsePosition 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 ParsePosition 的使用

参数类型为 ParsePosition 的 java.text 中的方法
Number | ChoiceFormat.parse(String text, ParsePosition status) 解析输入文本中的一个 Number。
Number | DecimalFormat.parse(String text, ParsePosition pos) 解析字符串中的文本，以生成一个 Number。
abstract Number | NumberFormat.parse(String source, ParsePosition parsePosition) 如果可能则返回 Long （例如，在 [Long.MIN_VALUE, Long.MAX_VALUE] 范围内且没有小数），否则返回 Double。
Date | SimpleDateFormat.parse(String text, ParsePosition pos) 解析字符串的文本，生成 Date。
abstract Date | DateFormat.parse(String source, ParsePosition pos) 根据给定的解析位置开始解析日期/时间字符串。
Object[] | MessageFormat.parse(String source, ParsePosition pos) 解析字符串。
Object | NumberFormat.parseObject(String source, ParsePosition pos) 解析字符串中的文本，以生成一个 Number。
Object | DateFormat.parseObject(String source, ParsePosition pos) 解析字符串中的文本，以生成一个 Date。
Object | MessageFormat.parseObject(String source, ParsePosition pos) 解析字符串文本，生成一个对象数组。
abstract Object | Format.parseObject(String source, ParsePosition pos) 解析字符串文本，生成一个对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.StringCharacterIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.StringCharacterIterator
的使用

没有 java.text.StringCharacterIterator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.Normalizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Normalizer
的使用

没有 java.text.Normalizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.Normalizer.Form 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Normalizer.Form
的使用

使用 Normalizer.Form 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 Normalizer.Form 的使用

返回 Normalizer.Form 的 java.text 中的方法
static Normalizer.Form | Normalizer.Form.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Normalizer.Form[] | Normalizer.Form.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 Normalizer.Form 的 java.text 中的方法
static boolean | Normalizer.isNormalized(CharSequence src, Normalizer.Form form) 确定给定的 char 值序列是否被标准化。
static String | Normalizer.normalize(CharSequence src, Normalizer.Form form) 标准化 char 值序列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.RuleBasedCollator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.RuleBasedCollator
的使用

没有 java.text.RuleBasedCollator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.Collator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Collator
的使用

使用 Collator 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.text 中 Collator 的使用

java.text 中 Collator 的子类
 class RuleBasedCollator
RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。

返回 Collator 的 java.text 中的方法
static Collator | Collator.getInstance() 获取当前默认语言环境的 Collator。
static Collator | Collator.getInstance(Locale desiredLocale) 获取所需语言环境的 Collator。

java.text.spi 中 Collator 的使用

返回 Collator 的 java.text.spi 中的方法
abstract  Collator CollatorProvider.getInstance(Locale locale)
为指定语言环境返回新的 Collator 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.ParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.ParseException
的使用

使用 ParseException 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 ParseException 的使用

抛出 ParseException 的 java.text 中的方法
Number | NumberFormat.parse(String source) 解析给定字符串开头的文本，生成一个数值。
Date | DateFormat.parse(String source) 从给定字符串的开始解析文本，以生成一个日期。
Object[] | MessageFormat.parse(String source) 从给定字符串的开始位置解析文本，以生成一个对象数组。
Object | Format.parseObject(String source) 从给定字符串的开始处解析文本以生成一个对象。

抛出 ParseException 的 java.text 中的构造方法
RuleBasedCollator(String rules)
RuleBasedCollator 构造方法。

javax.swing 中 ParseException 的使用

抛出 ParseException 的 javax.swing 中的方法
void | JFormattedTextField.commitEdit() 强制从 AbstractFormatter 获得当前值并将其设置为当前值。
void | JSpinner.commitEdit() 将当前编辑的值提交给 SpinnerModel。
void | JSpinner.DefaultEditor.commitEdit() 将当前编辑值赋给 SpinnerModel。
abstract Object | JFormattedTextField.AbstractFormatter.stringToValue(String text) 分析 text，返回任意 Object。
abstract String | JFormattedTextField.AbstractFormatter.valueToString(Object value) 返回为 value 显示的 string 值。

javax.swing.plaf.synth 中 ParseException 的使用

抛出 ParseException 的 javax.swing.plaf.synth 中的方法
void | SynthLookAndFeel.load(InputStream input, Class<?> resourceBase) 加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。
void | SynthLookAndFeel.load(URL url) 加载此 SynthLookAndFeel 将使用的 SynthStyle 集合。

javax.swing.text 中 ParseException 的使用

抛出 ParseException 的 javax.swing.text 中的方法
void | MaskFormatter.setMask(String mask) 设置指示合法字符的掩码。
Object | DefaultFormatter.stringToValue(String string) 通过使用带 String 参数的构造方法将传入的 String 转换为 getValueClass 的一个实例。
Object | InternationalFormatter.stringToValue(String text) 返回 String text 的 Object 表示形式。
Object | MaskFormatter.stringToValue(String value) 解析文本，返回 String value 的适当 Object 表示形式。
String | DefaultFormatter.valueToString(Object value) 使用 toString 方法将传入的 Object 转换为 String。
String | InternationalFormatter.valueToString(Object value) 返回 Object value 的 String 表示形式。
String | MaskFormatter.valueToString(Object value) 返回基于掩码的 Object value 的 String 表示形式。

抛出 ParseException 的 javax.swing.text 中的构造方法
MaskFormatter(String mask)
创建具有指定掩码的 MaskFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.DecimalFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DecimalFormat
的使用

使用 DecimalFormat 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 DecimalFormat 的使用

返回 DecimalFormat 的 javax.swing 中的方法
 DecimalFormat JSpinner.NumberEditor.getFormat()
返回 JFormattedTextField 用于分析和格式化数字的 java.text.DecimalFormat 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.DecimalFormatSymbols 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DecimalFormatSymbols
的使用

使用 DecimalFormatSymbols 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.text 中 DecimalFormatSymbols 的使用

返回 DecimalFormatSymbols 的 java.text 中的方法
DecimalFormatSymbols | DecimalFormat.getDecimalFormatSymbols() 返回小数格式符号的一个副本，通常程序员或用户不改变此副本。
static DecimalFormatSymbols | DecimalFormatSymbols.getInstance() 获取默认语言环境的 DecimalFormatSymbols 实例。
static DecimalFormatSymbols | DecimalFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DecimalFormatSymbols 实例。

参数类型为 DecimalFormatSymbols 的 java.text 中的方法
 void DecimalFormat.setDecimalFormatSymbols(DecimalFormatSymbols newSymbols)
设置小数格式符号，通常程序员或用户不改变此符号。

参数类型为 DecimalFormatSymbols 的 java.text 中的构造方法
DecimalFormat(String pattern, DecimalFormatSymbols symbols)
使用给定的模式和符号创建一个 DecimalFormat。

java.text.spi 中 DecimalFormatSymbols 的使用

返回 DecimalFormatSymbols 的 java.text.spi 中的方法
abstract  DecimalFormatSymbols DecimalFormatSymbolsProvider.getInstance(Locale locale)
为指定语言环境返回新的 DecimalFormatSymbols 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.NumberFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.NumberFormat
的使用

使用 NumberFormat 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 NumberFormat 的使用

java.text 中 NumberFormat 的子类
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。

声明为 NumberFormat 的 java.text 中的字段
protected  NumberFormat DateFormat.numberFormat
数字格式器，DateFormat 用其来格式化日期和时间中的数字。

返回 NumberFormat 的 java.text 中的方法
static NumberFormat | NumberFormat.getCurrencyInstance() 返回当前默认语言环境的货币格式。
static NumberFormat | NumberFormat.getCurrencyInstance(Locale inLocale) 返回指定语言环境的货币格式。
static NumberFormat | NumberFormat.getInstance() 返回当前默认语言环境的通用数值格式。
static NumberFormat | NumberFormat.getInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | NumberFormat.getIntegerInstance() 返回当前默认语言环境的整数格式。
static NumberFormat | NumberFormat.getIntegerInstance(Locale inLocale) 返回指定语言环境的整数格式。
NumberFormat | DateFormat.getNumberFormat() 获取此日期/时间格式器用于格式化和解析时间的数字格式器。
static NumberFormat | NumberFormat.getNumberInstance() 返回当前默认语言环境的通用数值格式。
static NumberFormat | NumberFormat.getNumberInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | NumberFormat.getPercentInstance() 返回当前默认语言环境的百分比格式。
static NumberFormat | NumberFormat.getPercentInstance(Locale inLocale) 返回指定语言环境的百分比格式。

参数类型为 NumberFormat 的 java.text 中的方法
 void DateFormat.setNumberFormat(NumberFormat newNumberFormat)
允许用户设置数字格式器。

java.text.spi 中 NumberFormat 的使用

返回 NumberFormat 的 java.text.spi 中的方法
abstract NumberFormat | NumberFormatProvider.getCurrencyInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。
abstract NumberFormat | NumberFormatProvider.getIntegerInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。
abstract NumberFormat | NumberFormatProvider.getNumberInstance(Locale locale) 为指定语言环境返回新的通用 NumberFormat 实例。
abstract NumberFormat | NumberFormatProvider.getPercentInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。

javax.swing.text 中 NumberFormat 的使用

参数类型为 NumberFormat 的 javax.swing.text 中的构造方法
NumberFormatter(NumberFormat format)
创建具有指定 Format 实例的 NumberFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.NumberFormat.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.NumberFormat.Field
的使用

使用 NumberFormat.Field 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 NumberFormat.Field 的使用

声明为 NumberFormat.Field 的 java.text 中的字段
static NumberFormat.Field | NumberFormat.Field.CURRENCY 标识货币字段的常量。
static NumberFormat.Field | NumberFormat.Field.DECIMAL_SEPARATOR 标识小数点字段的常量。
static NumberFormat.Field | NumberFormat.Field.EXPONENT 标识指数字段的常量。
static NumberFormat.Field | NumberFormat.Field.EXPONENT_SIGN 标识指数符号 (exponent sign) 字段的常量。
static NumberFormat.Field | NumberFormat.Field.EXPONENT_SYMBOL 标识指数符号 (exponent symbol) 字段的常量。
static NumberFormat.Field | NumberFormat.Field.FRACTION 标识小数字段的常量。
static NumberFormat.Field | NumberFormat.Field.GROUPING_SEPARATOR 标识组分隔符字段的常量。
static NumberFormat.Field | NumberFormat.Field.INTEGER 标识整数字段的常量。
static NumberFormat.Field | NumberFormat.Field.PERCENT 标识百分数字段的常量。
static NumberFormat.Field | NumberFormat.Field.PERMILLE 标识千分数字段的常量。
static NumberFormat.Field | NumberFormat.Field.SIGN 标识符号字段的常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.DateFormatSymbols 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DateFormatSymbols
的使用

使用 DateFormatSymbols 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。

java.text 中 DateFormatSymbols 的使用

返回 DateFormatSymbols 的 java.text 中的方法
DateFormatSymbols | SimpleDateFormat.getDateFormatSymbols() 获取此日期格式的日期和时间格式符号的一个副本。
static DateFormatSymbols | DateFormatSymbols.getInstance() 获取默认语言环境的 DateFormatSymbols 实例。
static DateFormatSymbols | DateFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DateFormatSymbols 实例。

参数类型为 DateFormatSymbols 的 java.text 中的方法
 void SimpleDateFormat.setDateFormatSymbols(DateFormatSymbols newFormatSymbols)
设置此日期格式的日期和时间格式符号。

参数类型为 DateFormatSymbols 的 java.text 中的构造方法
SimpleDateFormat(String pattern, DateFormatSymbols formatSymbols)
用给定的模式和日期符号构造 SimpleDateFormat。

java.text.spi 中 DateFormatSymbols 的使用

返回 DateFormatSymbols 的 java.text.spi 中的方法
abstract  DateFormatSymbols DateFormatSymbolsProvider.getInstance(Locale locale)
为指定语言环境返回一个新的 DateFormatSymbols 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.SimpleDateFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.SimpleDateFormat
的使用

使用 SimpleDateFormat 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 SimpleDateFormat 的使用

返回 SimpleDateFormat 的 javax.swing 中的方法
 SimpleDateFormat JSpinner.DateEditor.getFormat()
返回 JFormattedTextField 用于分析和格式化数字的 java.text.SimpleDateFormat 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.DateFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DateFormat
的使用

使用 DateFormat 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 DateFormat 的使用

java.text 中 DateFormat 的子类
 class SimpleDateFormat
SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

返回 DateFormat 的 java.text 中的方法
static DateFormat | DateFormat.getDateInstance() 获取日期格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | DateFormat.getDateInstance(int style) 获取日期格式器，该格式器具有默认语言环境的给定格式化风格。
static DateFormat | DateFormat.getDateInstance(int style, Locale aLocale) 获取日期格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | DateFormat.getDateTimeInstance() 获取日期/时间格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | DateFormat.getDateTimeInstance(int dateStyle, int timeStyle) 获取日期/时间格式器，该格式器具有默认语言环境的给定日期和时间格式化风格。
static DateFormat | DateFormat.getDateTimeInstance(int dateStyle, int timeStyle, Locale aLocale) 获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | DateFormat.getInstance() 获取为日期和时间使用 SHORT 风格的默认日期/时间格式器。
static DateFormat | DateFormat.getTimeInstance() 获取时间格式器，该格式器具有默认语言环境的默认格式化风格。
static DateFormat | DateFormat.getTimeInstance(int style) 获取时间格式器，该格式器具有默认语言环境的给定格式化风格。
static DateFormat | DateFormat.getTimeInstance(int style, Locale aLocale) 获取时间格式器，该格式器具有给定语言环境的给定格式化风格。

java.text.spi 中 DateFormat 的使用

返回 DateFormat 的 java.text.spi 中的方法
abstract DateFormat | DateFormatProvider.getDateInstance(int style, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。
abstract DateFormat | DateFormatProvider.getDateTimeInstance(int dateStyle, int timeStyle, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。
abstract DateFormat | DateFormatProvider.getTimeInstance(int style, Locale locale) 返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。

javax.swing.text 中 DateFormat 的使用

参数类型为 DateFormat 的 javax.swing.text 中的方法
 void DateFormatter.setFormat(DateFormat format)
设置用于指示可编辑和显示的合法值的格式。

参数类型为 DateFormat 的 javax.swing.text 中的构造方法
DateFormatter(DateFormat format)
返回用指定的 Format 实例配置的 DateFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.DateFormat.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.DateFormat.Field
的使用

使用 DateFormat.Field 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 DateFormat.Field 的使用

声明为 DateFormat.Field 的 java.text 中的字段
static DateFormat.Field | DateFormat.Field.AM_PM 标识每日时间指示符（例如 "a.m." 或 "p.m."）的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_MONTH 标识 DAY_OF_MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_WEEK 标识 DAY_OF_WEEK 字段的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_WEEK_IN_MONTH 标识 DAY_OF_WEEK_IN_MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.DAY_OF_YEAR 标识 DAY_OF_YEAR 字段的常量。
static DateFormat.Field | DateFormat.Field.ERA 标识 ERA 字段的常量。
static DateFormat.Field | DateFormat.Field.HOUR_OF_DAY0 标识 HOUR_OF_DAY0 字段的常量，其合法的值是 0 到 23。
static DateFormat.Field | DateFormat.Field.HOUR_OF_DAY1 标识 HOUR_OF_DAY1 字段的常量，其合法的值是 1 到 24。
static DateFormat.Field | DateFormat.Field.HOUR0 标识 HOUR0 字段的常量，其合法的值是 1 到 11。
static DateFormat.Field | DateFormat.Field.HOUR1 标识 HOUR1 字段的常量，其合法的值是 1 到 12。
static DateFormat.Field | DateFormat.Field.MILLISECOND 标识 MILLISECOND 字段的常量。
static DateFormat.Field | DateFormat.Field.MINUTE 标识 MINUTE 字段的常量。
static DateFormat.Field | DateFormat.Field.MONTH 标识 MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.SECOND 标识 SECOND 字段的常量。
static DateFormat.Field | DateFormat.Field.TIME_ZONE 标识 TIME_ZONE 字段的常量。
static DateFormat.Field | DateFormat.Field.WEEK_OF_MONTH 标识 WEEK_OF_MONTH 字段的常量。
static DateFormat.Field | DateFormat.Field.WEEK_OF_YEAR 标识 WEEK_OF_YEAR 字段的常量。
static DateFormat.Field | DateFormat.Field.YEAR 标识 YEAR 字段的常量。

返回 DateFormat.Field 的 java.text 中的方法
static DateFormat.Field DateFormat.Field.ofCalendarField(int calendarField)
返回与此 Calendar 常量 calendarField 对应的 Field 常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.FieldPosition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.FieldPosition
的使用

使用 FieldPosition 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 FieldPosition 的使用

参数类型为 FieldPosition 的 java.text 中的方法
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | ChoiceFormat.format(double number, StringBuffer toAppendTo, FieldPosition status) 返回带已格式化 double 的模式。
StringBuffer | DecimalFormat.format(double number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 double 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(double number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | ChoiceFormat.format(long number, StringBuffer toAppendTo, FieldPosition status) 特殊格式。
StringBuffer | DecimalFormat.format(long number, StringBuffer result, FieldPosition fieldPosition) 格式化一个 long 值，以生成一个字符串。
abstract StringBuffer | NumberFormat.format(long number, StringBuffer toAppendTo, FieldPosition pos) 格式规范。
StringBuffer | MessageFormat.format(Object[] arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
StringBuffer | DecimalFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数，并将所得文本追加到给定的字符串缓冲区。
StringBuffer | NumberFormat.format(Object number, StringBuffer toAppendTo, FieldPosition pos) 格式化一个数并将所得文本添加到给定字符串缓冲区。
StringBuffer | DateFormat.format(Object obj, StringBuffer toAppendTo, FieldPosition fieldPosition) 重写 Format。
StringBuffer | MessageFormat.format(Object arguments, StringBuffer result, FieldPosition pos) 格式化一个对象数组，并将 MessageFormat 的模式添加到所提供的 StringBuffer，用格式化后的对象替换格式元素。
abstract StringBuffer | Format.format(Object obj, StringBuffer toAppendTo, FieldPosition pos) 格式化一个对象，并将得到的文本添加到给定的字符缓冲区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.MessageFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.MessageFormat
的使用

使用 MessageFormat 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 MessageFormat 的使用

参数类型为 MessageFormat 的 javax.swing 中的方法
Printable | JTable.getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 返回打印此 JTable 中所使用的 Printable。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

javax.swing.text 中 MessageFormat 的使用

参数类型为 MessageFormat 的 javax.swing.text 中的方法
Printable | JTextComponent.getPrintable(MessageFormat headerFormat, MessageFormat footerFormat) 返回一个 Printable，用于打印此 JTextComponent 的内容。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷打印方法，它显示打印对话框，然后在交互 模式下打印此 JTextComponent，打印指定的标题和脚注文本。
boolean | JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive) 打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.MessageFormat.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.MessageFormat.Field
的使用

使用 MessageFormat.Field 的软件包
java.text 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。

java.text 中 MessageFormat.Field 的使用

声明为 MessageFormat.Field 的 java.text 中的字段
static MessageFormat.Field MessageFormat.Field.ARGUMENT
标识消息某一部分的常量，其中此消息是从传入 formatToCharacterIterator 的参数生成的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.Format 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Format
的使用

使用 Format 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 Format 的使用

java.text 中 Format 的子类
class | ChoiceFormat ChoiceFormat 允许将格式应用到某个范围的数。
class | DateFormat DateFormat 是日期/时间格式化子类的抽象类，它以与语言无关的方式格式化并解析日期或时间。
class | DecimalFormat DecimalFormat 是 NumberFormat 的一个具体子类，用于格式化十进制数字。
class | MessageFormat MessageFormat 提供了以与语言无关方式生成连接消息的方式。
class | NumberFormat NumberFormat 是所有数值格式的抽象基类。
class | SimpleDateFormat SimpleDateFormat 是一个以与语言环境有关的方式来格式化和解析日期的具体类。

返回 Format 的 java.text 中的方法
Format[] | MessageFormat.getFormats() 获取用于以前所设置的模式字符串中格式元素的格式。
Format[] | MessageFormat.getFormatsByArgumentIndex() 获取传递给 format 方法或从 parse 方法返回的值的格式。

参数类型为 Format 的 java.text 中的方法
void | MessageFormat.setFormat(int formatElementIndex, Format newFormat) 使用在以前设置的模式字符串中给定的格式元素索引来设置格式元素使用的格式。
void | MessageFormat.setFormatByArgumentIndex(int argumentIndex, Format newFormat) 设置用于以前所设置的模式字符串中格式元素的格式，其中以前的模式字符串是用给定的参数索引设置的。
void | MessageFormat.setFormats(Format[] newFormats) 设置用于以前所设置的模式字符串中格式元素的格式。
void | MessageFormat.setFormatsByArgumentIndex(Format[] newFormats) 设置传递给 format 方法或从 parse 方法返回的值使用的格式。

javax.swing 中 Format 的使用

参数类型为 Format 的 javax.swing 中的构造方法
JFormattedTextField(Format format)
创建一个 JFormattedTextField。

javax.swing.text 中 Format 的使用

返回 Format 的 javax.swing.text 中的方法
 Format InternationalFormatter.getFormat()
返回指示可以编辑和显示的合法值的格式。

参数类型为 Format 的 javax.swing.text 中的方法
void | InternationalFormatter.setFormat(Format format) 设置指示可以编辑和显示的合法值的格式。
void | NumberFormatter.setFormat(Format format) 设置指示可以编辑和显示的合法值的格式。

参数类型为 Format 的 javax.swing.text 中的构造方法
InternationalFormatter(Format format)
创建一个具有指定 Format 实例的 InternationalFormatter。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.text.Format.Field 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.text.Format.Field
的使用

使用 Format.Field 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.text 中 Format.Field 的使用

java.text 中 Format.Field 的子类
static class | DateFormat.Field 定义了各种常量，这些常量用作 DateFormat.formatToCharacterIterator 所返回的 AttributedCharacterIterator 中的属性键和 FieldPosition 中的字段标识符。
static class | MessageFormat.Field 在从 MessageFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中定义用作属性键的常量。
static class | NumberFormat.Field 定义将用作从 NumberFormat.formatToCharacterIterator 返回的 AttributedCharacterIterator 中属性键以及 FieldPosition 中字段标识符的常量。

返回 Format.Field 的 java.text 中的方法
 Format.Field FieldPosition.getFieldAttribute()
以来自 Field 子类之一的属性常量返回该字段的标识符。

参数类型为 Format.Field 的 java.text 中的构造方法
FieldPosition(Format.Field attribute)
为给定的字段常量创建一个 FieldPosition 对象。
FieldPosition(Format.Field attribute, int fieldID)
为给定的字段创建一个 FieldPosition 对象。

javax.swing.text 中 Format.Field 的使用

返回 Format.Field 的 javax.swing.text 中的方法
 Format.Field[] InternationalFormatter.getFields(int offset)
返回与 offset 处的文本相关的 Format.Field 常量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.text.CharacterIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.text.CharacterIterator
的使用

使用 CharacterIterator 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 CharacterIterator 的使用

参数类型为 CharacterIterator 的 java.awt 中的方法
int | Font.canDisplayUpTo(CharacterIterator iter, int start, int limit) 指示此 Font 是否可以显示由 iter 指定的文本（从 start 开始至 limit 结束）。
GlyphVector | Font.createGlyphVector(FontRenderContext frc, CharacterIterator ci) 根据此 Font 中的 Unicode cmap 将指定字符一一映射到字形，从而创建一个 GlyphVector。
LineMetrics | Font.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回使用指定参数创建的 LineMetrics 对象。
LineMetrics | FontMetrics.getLineMetrics(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回指定 Graphics 上下文中指定 CharacterIterator 的 LineMetrics 对象。
Rectangle2D | Font.getStringBounds(CharacterIterator ci, int beginIndex, int limit, FontRenderContext frc) 返回指定 FontRenderContext 中针对指定 CharacterIterator 进行索引的字符的逻辑边界。
Rectangle2D | FontMetrics.getStringBounds(CharacterIterator ci, int beginIndex, int limit, Graphics context) 返回用指定 Graphics 上下文中指定 CharacterIterator 进行索引的字符的边界。

java.text 中 CharacterIterator 的使用

java.text 中 CharacterIterator 的子接口
 interface AttributedCharacterIterator
AttributedCharacterIterator 允许对文本和相关属性信息的迭代。

实现 CharacterIterator 的 java.text 中的类
 class StringCharacterIterator
StringCharacterIterator 为 String 实现 CharacterIterater 协议。

返回 CharacterIterator 的 java.text 中的方法
abstract  CharacterIterator BreakIterator.getText()
获取被扫描的文本

参数类型为 CharacterIterator 的 java.text 中的方法
CollationElementIterator | RuleBasedCollator.getCollationElementIterator(CharacterIterator source) 返回给定 String 的 CollationElementIterator。
abstract void | BreakIterator.setText(CharacterIterator newText) 设置一个新文本用于扫描。
void | CollationElementIterator.setText(CharacterIterator source) 设置一个要迭代的新字符串。

javax.swing.text 中 CharacterIterator 的使用

实现 CharacterIterator 的 javax.swing.text 中的类
 class Segment
表示文本片段的字符数组的 segment。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractCollection (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractCollection<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
所有已实现的接口：
Iterable<E>, Collection<E>
直接已知子类：
AbstractList, AbstractQueue, AbstractSet, ArrayDeque
public abstract class AbstractCollection<E>
extends Object
implements Collection<E>

此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。

要实现一个不可修改的 collection，编程人员只需扩展此类，并提供 iterator 和 size 方法的实现。（iterator 方法返回的迭代器必须实现 hasNext 和 next。）

要实现可修改的 collection，编程人员必须另外重写此类的 add 方法（否则，会抛出 UnsupportedOperationException），iterator 方法返回的迭代器还必须另外实现其 remove 方法。

按照 Collection 接口规范中的建议，编程人员通常应提供一个 void （无参数）和 Collection 构造方法。

此类中每个非抽象方法的文档详细描述了其实现。如果要实现的 collection 允许更有效的实现，则可以重写这些方法中的每个方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection

构造方法摘要
protected AbstractCollection()
唯一的构造方法。
方法摘要
 boolean add(E e)
确保此 collection 包含指定的元素（可选操作）。
 boolean addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
 void clear()
移除此 collection 中的所有元素（可选操作）。
 boolean contains(Object o)
如果此 collection 包含指定的元素，则返回 true。
 boolean containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
 boolean isEmpty()
如果此 collection 不包含元素，则返回 true。
abstract  Iterator<E> iterator()
返回在此 collection 中的元素上进行迭代的迭代器。
 boolean remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。
 boolean removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
 boolean retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
abstract  int size()
返回此 collection 中的元素数。
 Object[] toArray()
返回包含此 collection 中所有元素的数组。
<T> T[]
toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。
 String toString()
返回此 collection 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Collection 继承的方法
equals, hashCode

构造方法详细信息

AbstractCollection

protected AbstractCollection()
唯一的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

iterator

public abstract Iterator<E> iterator()
返回在此 collection 中的元素上进行迭代的迭代器。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
返回：
在此 collection 中的元素上进行迭代的迭代器。

size

public abstract int size()
从接口 Collection 复制的描述
返回此 collection 中的元素数。如果此 collection 包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

指定者：
接口 Collection<E> 中的 size
返回：
此 collection 中的元素数

isEmpty

public boolean isEmpty()
如果此 collection 不包含元素，则返回 true。

此实现返回 size() == 0。

指定者：
接口 Collection<E> 中的 isEmpty
返回：
如果此 collection 不包含元素，则返回 true

contains

public boolean contains(Object o)
如果此 collection 包含指定的元素，则返回 true。更确切地讲，当且仅当此 collection 至少包含一个满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，返回 true。

此实现在 collection 中的元素上进行迭代，并依次检查每个元素以确定其是否与指定的元素相等。

指定者：
接口 Collection<E> 中的 contains
参数：
o - 测试在此 collection 中是否存在的元素。
返回：
如果此 collection 包含指定的元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类型与此 collection 不兼容（可选）。
NullPointerException - 如果指定的元素为 null，并且此 collection 不允许 null 元素（可选）。

toArray

public Object[] toArray()
返回包含此 collection 中所有元素的数组。如果 collection 对其迭代器返回的元素顺序做出了某些保证，那么此方法必须以相同的顺序返回这些元素。

返回的数组将是“安全的”，因为此 collection 并不维护对返回数组的任何引用。（换句话说，即使 collection 受到数组的支持，此方法也必须分配一个新的数组）。因此，调用者可以随意修改返回的数组。

此方法充当了基于数组的 API 与基于 collection 的 API 之间的桥梁。

此实现返回一个数组，它包含此 collection 的迭代器返回的所有元素，这些元素的排列顺序与数组的连续元素存储顺序相同，都是从索引 0 开始。返回数组的长度等于迭代器返回的元素数，即使此 collection 的大小发生更改也是如此，这种情况可能发生在 collection 允许在迭代期间进行并发修改时。size 方法只是作为一个优化提示被调用；即使迭代器返回不同的元素数，也会返回正确的结果。

此方法等效于：

 List<E> list = new ArrayList<E>(size());
 for (E e : this)
     list.add(e);
 return list.toArray();

指定者：
接口 Collection<E> 中的 toArray
返回：
包含此 collection 中所有元素的数组

toArray

public <T> T[] toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。如果指定的数组能容纳该 collection，则返回包含此 collection 元素的数组。否则，将分配一个具有指定数组的运行时类型和此 collection 大小的新数组。

如果指定的数组能容纳 collection，并有剩余空间（即数组的元素比 collection 的元素多），那么会将数组中紧接 collection 尾部的元素设置为 null。（只有 在调用者知道此 collection 没有包含任何 null 元素时才能用此方法确定 collection 的长度。）

如果此 collection 对其迭代器返回的元素顺序做出了某些保证，那么此方法必须以相同的顺序返回这些元素。

像 Collection.toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，并且在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知 collection。以下代码用来将 collection 转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

此实现返回一个数组，它包含此 collection 的迭代器返回的所有元素，这些元素的排列顺序与数组的连续元素存储顺序相同，都是从索引 0 开始。如果迭代器返回的元素数太大，不适合指定数组，则在新分配的数组中返回这些元素，该数组的长度等于迭代器返回的元素数，即使此 collection 的大小在进行迭代期间发生更改也是如此，这种情况可能发生在 collection 允许在迭代期间进行并发修改时。size 方法只是作为一个优化提示被调用；即使迭代器返回不同的元素数，也会返回正确的结果。

此方法等效于：

 List<E> list = new ArrayList<E>(size());
 for (E e : this)
     list.add(e);
 return list.toArray(a);

指定者：
接口 Collection<E> 中的 toArray
参数：
a - 存储此 collection 元素的数组（如果其足够大）；否则，将为此分配一个具有相同运行时类型的新数组。
返回：
包含此 collection 中所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此 collection 每个元素运行时类型的超类型
NullPointerException - 如果指定的数组为 null

add

public boolean add(E e)
确保此 collection 包含指定的元素（可选操作）。如果此 collection 由于调用而发生更改，则返回 true。（如果此 collection 不允许有重复元素，并且已经包含了指定的元素，则返回 false。）

支持此操作的 collection 可以限制哪些元素能添加到此 collection 中来。需要特别指出的是，一些 collection 拒绝添加 null 元素，其他一些 collection 将对可以添加的元素类型强加限制。Collection 类应该在其文档中清楚地指定能添加哪些元素方面的所有限制。

如果 collection 由于某些原因（已经包含该元素的原因除外）拒绝添加特定的元素，那么它必须 抛出一个异常（而不是返回 false）。这确保了在此调用返回后，collection 总是包含指定的元素。

此实现总是抛出一个 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 add
参数：
e - 确定此 collection 中是否存在的元素。
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 add 操作
ClassCastException - 如果指定元素的类不允许它添加到此 collection 中
NullPointerException - 如果指定的元素为 null，并且此 collection 不允许 null 元素
IllegalArgumentException - 如果元素的某属性不允许它添加到此 collection 中
IllegalStateException - 如果由于插入限制，元素不能在此时间添加

remove

public boolean remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。更确切地讲，如果此 collection 包含一个或多个满足 (o==null ? e==null : o.equals(e)) 的元素 e，则移除这样的元素。如果此 collection 包含指定的元素（或者此 collection 由于调用而发生更改），则返回 true 。

此实现在该 collection 上进行迭代，查找指定的元素。如果找到该元素，那么它会使用迭代器的 remove 方法从该 collection 中移除该元素。

注意，如果此 collection 的 iterator 方法所返回的迭代器无法实现 remove 方法，并且此 collection 包含指定的对象，那么此实现将抛出 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 remove
参数：
o - 要从此 collection 中移除的元素（如果存在）。
返回：
如果此调用将移除一个元素，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 remove 操作
ClassCastException - 如果指定元素的类型与此 collection 不兼容（可选）
NullPointerException - 如果指定的元素为 null，并且此 collection 不允许 null 元素（可选）。

containsAll

public boolean containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。

此实现在指定的 collection 上进行迭代，依次检查该迭代器返回的每个元素，查看其是否包含在此 collection 中。如果是，则返回 true；否则返回 false。

指定者：
接口 Collection<E> 中的 containsAll
参数：
c - 将检查是否包含在此 collection 中的 collection
返回：
如果此 collection 包含指定 collection 中的所有元素，则返回 true
抛出：
ClassCastException - 如果指定 collection 中有一个或多个元素的类型与此 collection 不兼容（可选）
NullPointerException - 如果指定 collection 包含一个或多个 null 元素，并且此 collection 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
contains(Object)

addAll

public boolean addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。如果在进行此操作的同时修改指定的 collection，那么此操作行为是不确定的。（这意味着如果指定的 collection 是此 collection，并且此 collection 为非空，那么此调用的行为是不确定的。）

此实现在指定的 collection 上进行迭代，并依次将迭代器返回的每个对象添加到此 collection 中。

注意，除非重写 add，否则此实现将抛出 UnsupportedOperationException（假定指定的 collection 非空）。

指定者：
接口 Collection<E> 中的 addAll
参数：
c - 包含要添加到此 collection 的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 addAll 方法
ClassCastException - 如果指定 collection 中某个元素的类不允许它添加到此 collection 中
NullPointerException - 如果指定 collection 包含 null 元素，并且此 collection 不支持 null 元素，或者指定的 collection 为 null
IllegalArgumentException - 如果指定 collection 的元素的某属性不允许它添加到此 collection 中
IllegalStateException - 如果由于插入限制，不是所有的元素都能在此时间添加
另请参见：
add(Object)

removeAll

public boolean removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。此调用返回后，collection 中将不包含任何与指定 collection 相同的元素。

此实现在此 collection 上进行迭代，依次检查该迭代器返回的每个元素，以查看其是否包含在指定的 collection 中。如果是，则使用迭代器的 remove 方法将其从此 collection 中移除。

注意，如果 iterator 方法返回的迭代器无法实现 remove 方法，并且此 collection 包含一个或多个与指定 collection 共有的元素，那么此实现将抛出 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 removeAll
参数：
c - 办好要从此 collection 移除的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 removeAll 方法
ClassCastException - 如果此 collection 中一个或多个元素的类型与指定 collection 不兼容（可选）
NullPointerException - 如果此 collection 包含一个或多个 null 元素，并且指定的 collection 不支持 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object), contains(Object)

retainAll

public boolean retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。换句话说，移除此 collection 中未包含在指定 collection 中的所有元素。

此实现在此 collection 上进行迭代，依次检查该迭代器返回的每个元素，以查看其是否包含在指定的 collection 中。如果不是，则使用迭代器的 remove 方法将其从此 collection 中移除。

注意，如果 iterator 方法返回的迭代器无法实现 remove 方法，并且此 collection 包含一个或多个在指定 collection 中不存在的元素，那么此实现将抛出 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 retainAll
参数：
c - 包含保留在此 collection 中的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 retainAll 操作
ClassCastException - 如果此 collection 中一个或多个元素的类型与指定 collection 不兼容（可选）
NullPointerException - 如果此 collection 包含一个或多个 null 元素，并且指定的 collection 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object), contains(Object)

clear

public void clear()
移除此 collection 中的所有元素（可选操作）。此方法返回后，除非抛出一个异常。

此实现在此 collection 上进行迭代，并使用 Iterator.remove 操作移除每个元素。为了提高效率，多数实现可能会选择重写此方法。

注意，如果此 collection 的 iterator 方法所返回的迭代器无法实现 remove 方法，并且此 collection 非空，那么此实现将抛出 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 clear
抛出：
UnsupportedOperationException - 如果此 collection 不支持 clear 操作

toString

public String toString()
返回此 collection 的字符串表示形式。该字符串表示形式由 collection 元素的列表组成，这些元素按其迭代器返回的顺序排列，并用方括号 ("[]") 括起来。相邻元素由字符 ", "（逗号加空格）分隔。通过 String.valueOf(Object) 可以将元素转换成字符串。

覆盖：
类 Object 中的 toString
返回：
此 collection 的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractList<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
所有已实现的接口：
Iterable<E>, Collection<E>, List<E>
直接已知子类：
AbstractSequentialList, ArrayList, Vector
public abstract class AbstractList<E>
extends AbstractCollection<E>
implements List<E>

此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。对于连续的访问数据（如链表），应优先使用 AbstractSequentialList，而不是此类。

要实现不可修改的列表，编程人员只需扩展此类，并提供 get(int) 和 size() 方法的实现。

要实现可修改的列表，编程人员必须另外重写 set(int, E) 方法（否则将抛出 UnsupportedOperationException）。如果列表为可变大小，则编程人员必须另外重写 add(int, E) 和 remove(int) 方法。

按照 Collection 接口规范中的建议，编程人员通常应该提供一个 void（无参数）和 collection 构造方法。

与其他抽象 collection 实现不同，编程人员不必 提供迭代器实现；迭代器和列表迭代器由此类在以下“随机访问”方法上实现：get(int)、set(int, E)、add(int, E) 和 remove(int)。

此类中每个非抽象方法的文档详细描述了其实现。如果要实现的 collection 允许更有效的实现，则可以重写所有这些方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2

字段摘要
protected  int modCount
已从结构上修改 此列表的次数。
构造方法摘要
protected AbstractList()
唯一的构造方法。
方法摘要
boolean | add(E e) 将指定的元素添加到此列表的尾部（可选操作）。
void | add(int index, E element) 在列表的指定位置插入指定元素（可选操作）。
boolean | addAll(int index, Collection<? extends E> c) 将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
void | clear() 从此列表中移除所有元素（可选操作）。
boolean | equals(Object o) 将指定的对象与此列表进行相等性比较。
abstract E | get(int index) 返回列表中指定位置的元素。
int | hashCode() 返回此列表的哈希码值。
int | indexOf(Object o) 返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
Iterator<E> | iterator() 返回以恰当顺序在此列表的元素上进行迭代的迭代器。
int | lastIndexOf(Object o) 返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
ListIterator<E> | listIterator() 返回此列表元素的列表迭代器（按适当顺序）。
ListIterator<E> | listIterator(int index) 返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
E | remove(int index) 移除列表中指定位置的元素（可选操作）。
protected void | removeRange(int fromIndex, int toIndex) 从此列表中移除索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。
E | set(int index, E element) 用指定元素替换列表中指定位置的元素（可选操作）。
List<E> | subList(int fromIndex, int toIndex) 返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
从类 java.util.AbstractCollection 继承的方法
addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray

字段详细信息

modCount

protected transient int modCount
已从结构上修改 此列表的次数。从结构上修改是指更改列表的大小，或者打乱列表，从而使正在进行的迭代产生错误的结果。

此字段由 iterator 和 listIterator 方法返回的迭代器和列表迭代器实现使用。如果意外更改了此字段中的值，则迭代器（或列表迭代器）将抛出 ConcurrentModificationException 来响应 next、remove、previous、set 或 add 操作。在迭代期间面临并发修改时，它提供了快速失败 行为，而不是非确定性行为。

子类是否使用此字段是可选的。如果子类希望提供快速失败迭代器（和列表迭代器），则它只需在其 add(int, E) 和 remove(int) 方法（以及它所重写的、导致列表结构上修改的任何其他方法）中增加此字段。对 add(int, E) 或 remove(int) 的单个调用向此字段添加的数量不得超过 1，否则迭代器（和列表迭代器）将抛出虚假的 ConcurrentModificationExceptions。如果某个实现不希望提供快速失败迭代器，则可以忽略此字段。

构造方法详细信息

AbstractList

protected AbstractList()
唯一的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

add

public boolean add(E e)
将指定的元素添加到此列表的尾部（可选操作）。

支持此操作的列表可能对列表可以添加的元素做出一些限制。具体来说，某些列表将拒绝添加 null 元素，另一些列表将在可以添加的元素类型上施加限制。List 类应该在它们的文档中明确指定可以添加何种元素的所有限制。

此实现调用 add(size(), e)。

注意，除非重写 add(int, E)，否则此实现将抛出 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 List<E> 中的 add
覆盖：
类 AbstractCollection<E> 中的 add
参数：
e - 将添加到此列表的元素
返回：
true（正如 Collection.add(E) 所指定的那样）
抛出：
UnsupportedOperationException - 如果此列表不支持 add 操作
ClassCastException - 如果指定元素的类不允许将该元素添加到此列表
NullPointerException - 如果指定元素为 null 并且此列表不允许使用 null 元素
IllegalArgumentException - 如果此元素的某些属性不允许将该元素添加到此列表

get

public abstract E get(int index)
返回列表中指定位置的元素。

指定者：
接口 List<E> 中的 get
参数：
index - 要返回的元素的索引
返回：
列表中指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

set

public E set(int index,
             E element)
用指定元素替换列表中指定位置的元素（可选操作）。

此实现始终抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 set
参数：
index - 要替换的元素的索引
element - 要在指定位置存储的元素
返回：
以前在指定位置的元素
抛出：
UnsupportedOperationException - 如果列表不支持 set 操作
ClassCastException - 如果指定元素的类不允许它添加到此列表
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

add

public void add(int index,
                E element)
在列表的指定位置插入指定元素（可选操作）。将当前处于该位置的元素（如果有的话）和所有后续元素向右移动（在其索引中加 1）。

此实现始终抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 add
参数：
index - 要在其中插入指定元素处的索引
element - 要插入的元素
抛出：
UnsupportedOperationException - 如果列表不支持 add 操作
ClassCastException - 如果指定元素的类不允许它添加到此列表
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

remove

public E remove(int index)
移除列表中指定位置的元素（可选操作）。将所有的后续元素向左移动（将其索引减 1）。返回从列表中移除的元素。

此实现始终抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 remove
参数：
index - 要移除的元素的索引
返回：
以前在指定位置的元素
抛出：
UnsupportedOperationException - 如果列表不支持 remove 操作
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

indexOf

public int indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i；如果没有这样的索引，则返回 -1。

此实现首先获取一个列表迭代器（使用 listIterator()）。然后它迭代列表，直至找到指定的元素，或者到达列表的末尾。

指定者：
接口 List<E> 中的 indexOf
参数：
o - 要搜索的元素
返回：
此列表中第一次出现的指定元素的索引，如果列表不包含该元素，则返回 -1
抛出：
ClassCastException - 如果指定元素的类型和此列表不兼容（可选）
NullPointerException - 如果指定的元素是 null，并且此列表不允许 null 元素（可选）

lastIndexOf

public int lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最高索引 i；如果没有这样的索引，则返回 -1。

此实现首先获取一个指向列表末尾的列表迭代器（使用 listIterator(size())）。然后它逆向迭代列表，直至找到指定的元素，或者到达列表的开头。

指定者：
接口 List<E> 中的 lastIndexOf
参数：
o - 要搜索的元素
返回：
列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1
抛出：
ClassCastException - 如果指定元素的类型和此列表不兼容（可选）
NullPointerException - 如果指定的元素是 null，并且此列表不允许 null 元素（可选）

clear

public void clear()
从此列表中移除所有元素（可选操作）。此调用返回后，列表将为空。

此实现调用 removeRange(0, size())。

注意，除非重写 remove(int index) 或 removeRange(int fromIndex, int toIndex)，否则此实现将抛出 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 List<E> 中的 clear
覆盖：
类 AbstractCollection<E> 中的 clear
抛出：
UnsupportedOperationException - 如果此列表不支持 clear 操作。

addAll

public boolean addAll(int index,
                      Collection<? extends E> c)
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。将当前处于该位置的元素（如果有的话）和所有后续元素向右移动（增加其索引）。新元素将按照它们通过指定 collection 的迭代器所返回的顺序出现在此列表中。如果在操作正在进行中修改了指定的 collection，那么该操作的行为是不确定的（注意，如果指定的 collection 是此列表，并且它是非空的，则会发生这种情况。）

此实现获取指定 collection 上的迭代器并迭代它，使用 add(int, E) 将迭代器获取的元素插入此列表的适当位置，一次一个。为了提高效率，多数实现将重写此方法。

注意，除非重写 add(int, E)，否则此实现将抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 addAll
参数：
index - 将指定 collection 的第一个元素所插入位置的索引
c - 包含要添加到此列表的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果列表不支持 addAll 操作
ClassCastException - 如果指定 collection 中某个元素的类不允许它添加到此列表
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素，并且该列表不允许 null 元素，或者指定的 collection 为 null
IllegalArgumentException - 如果指定 collection 的元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

iterator

public Iterator<E> iterator()
返回以恰当顺序在此列表的元素上进行迭代的迭代器。

此实现返回 iterator 接口的一个直接实现，具体取决于底层实现列表的 size()、get(int) 和 remove(int) 方法。

注意，除非重写列表的 remove(int) 方法，否则此方法返回的迭代器将抛出一个 UnsupportedOperationException 来响应其 remove 方法。

根据 (protected) modCount 字段规范中的描述，在面临并发修改时，可以使此实现抛出运行时异常。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 List<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此 collection 中的元素上进行迭代的迭代器。
另请参见：
modCount

listIterator

public ListIterator<E> listIterator()
返回此列表元素的列表迭代器（按适当顺序）。

指定者：
接口 List<E> 中的 listIterator
返回：
此列表中的元素的迭代器（按适当顺序）。

此实现返回 listIterator(0)。

另请参见：
listIterator(int)

listIterator

public ListIterator<E> listIterator(int index)
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。指定的索引表示 next 的初始调用所返回的第一个元素。previous 方法的初始调用将返回索引比指定索引少 1 的元素。

此实现返回 ListIterator 接口的直接实现，扩展了由 iterator() 方法返回的 Iterator 接口的实现。ListIterator 实现依赖于底层实现列表的 get(int)、set(int, E)、add(int, E) 和 remove(int) 方法。

注意，除非重写列表的 remove(int)、set(int, E) 和 add(int, E) 方法，否则此实现返回的列表迭代器将抛出 UnsupportedOperationException 来响应其 remove、set 和 add 方法。

根据 (protected) modCount 字段规范中的描述，在面临并发修改时，可以使此实现抛出运行时异常。

指定者：
接口 List<E> 中的 listIterator
参数：
index - 从列表迭代器返回的第一个元素的索引（通过调用 next 方法）
返回：
此列表中元素的列表迭代器（按适当顺序），从列表中的指定位置开始
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())
另请参见：
modCount

subList

public List<E> subList(int fromIndex,
                       int toIndex)
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。（如果 fromIndex 和 toIndex 相等，则返回的列表为空）。返回的列表由此列表支持，因此返回列表中的非结构性更改将反映在此列表中，反之亦然。返回的列表支持此列表支持的所有可选列表操作。

此方法省去了显式范围操作（此操作通常针对数组存在）。通过传递 subList 视图而非整个列表，期望列表的任何操作可用作范围操作。例如，下面的语句从列表中移除了元素的范围：

            list.subList(from, to).clear();
可以对 indexOf 和 lastIndexOf 构造类似的语句，而且 Collections 类中的所有算法都可以应用于 subList。

如果支持列表（即此列表）通过任何其他方式（而不是通过返回的列表）从结构上修改，则此方法返回的列表语义将变为未定义（从结构上修改是指更改列表的大小，或者以其他方式打乱列表，使正在进行的迭代产生错误的结果）。

此实现返回一个子类化 AbstractList 的列表。子类在 private 字段中存储底层实现列表中 subList 的偏移量、subList 的大小（随其生存期变化）以及底层实现列表的预期 modCount 值。子类有两个变体，其中一个实现 RandomAccess。如果此列表实现 RandomAccess，则返回的列表将是实现 RandomAccess 的子类实例。

子类的 set(int, E)、get(int)、add(int, E)、remove(int)、addAll(int, Collection) 和 removeRange(int, int) 方法在对索引进行边界检查和调整偏移量之后，都委托给底层实现抽象列表上的相应方法。addAll(Collection c) 方法返回 addAll(size, c)。

listIterator(int) 方法返回底层实现列表的列表迭代器上的“包装器对象”，使用底层实现列表上的相应方法可创建该迭代器。iterator 方法返回 listIterator()，size 方法返回子类的 size 字段。

所有方法都将首先检查底层实现列表的实际 modCount 是否与其预期的值相等，并且在不相等时将抛出 ConcurrentModificationException。

指定者：
接口 List<E> 中的 subList
参数：
fromIndex - subList 的低端（包括）
toIndex - subList 的高端（不包括）
返回：
列表中指定范围的视图
抛出：
IndexOutOfBoundsException - 端点索引值超出范围 (fromIndex < 0 || toIndex > size)
IllegalArgumentException - 端点索引顺序颠倒 (fromIndex > toIndex)

equals

public boolean equals(Object o)
将指定的对象与此列表进行相等性比较。当且仅当指定的对象也是一个列表，两个列表具有相同的大小，而且两个列表中所有相应的元素对都相等 时，才返回 true。（如果 (e1==null ? e2==null : e1.equals(e2))，则元素 e1 和 e2 相等。）换句话说，如果两个列表包含相同的元素，且元素的顺序也相同，才将它们定义为相等。

此实现首先检查指定的对象是否为此列表。如果是，则返回 true；否则，它将检查指定的对象是否为一个列表。如果不是，它将返回 false；如果是，它将迭代两个列表，比较相应的元素对。如果有任何比较结果返回 false，则此方法将返回 false。如果某中某个迭代器在另一迭代器之前迭代完元素，则会返回 false（因为列表是不等长的）；否则，在迭代完成时将返回 true。

指定者：
接口 Collection<E> 中的 equals
指定者：
接口 List<E> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 与此列表进行相等性比较的对象。
返回：
如果指定对象与此列表相等，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此列表的哈希码值。

此实现使用在 List.hashCode() 方法的文档中用于定义列表哈希函数的代码。

指定者：
接口 Collection<E> 中的 hashCode
指定者：
接口 List<E> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此列表的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

removeRange

protected void removeRange(int fromIndex,
                           int toIndex)
从此列表中移除索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。向左移动所有后续元素（减小其索引）。此调用缩短了 ArrayList，将其减少了 (toIndex - fromIndex) 个元素。（如果 toIndex==fromIndex，则此操作无效。）

此方法由此列表及其 subList 上的 clear 操作调用。重写此方法以利用内部列表实现可以极大地 改进此列表及其 subList 上 clear 操作的性能。

此实现获取一个位于 fromIndex 之前的列表迭代器，并在移除该范围内的元素前重复调用 ListIterator.next（后跟 ListIterator.remove）。注：如果 ListIterator.remove 需要的时间与元素数呈线性关系，那么此实现需要的时间与元素数的平方呈线性关系。

参数：
fromIndex - 要移除的第一个元素的索引。
toIndex - 要移除的最后一个元素之后的索引。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
类型参数：
K - 此映射维护的键的类型
V - 映射值的类型
所有已实现的接口：
Map<K,V>
直接已知子类：
ConcurrentHashMap, ConcurrentSkipListMap, EnumMap, HashMap, IdentityHashMap, TreeMap, WeakHashMap
public abstract class AbstractMap<K,V>
extends Object
implements Map<K,V>

此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。

要实现不可修改的映射，编程人员只需扩展此类并提供 entrySet 方法的实现即可，该方法将返回映射的映射关系 set 视图。通常，返回的 set 将依次在 AbstractSet 上实现。此 set 不支持 add 或 remove 方法，其迭代器也不支持 remove 方法。

要实现可修改的映射，编程人员必须另外重写此类的 put 方法（否则将抛出 UnsupportedOperationException），entrySet().iterator() 返回的迭代器也必须另外实现其 remove 方法。

按照 Map 接口规范中的建议，编程人员通常应该提供一个 void（无参数）构造方法和 map 构造方法。

此类中每个非抽象方法的文档详细描述了其实现。如果要实现的映射允许更有效的实现，则可以重写所有这些方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Map, Collection

嵌套类摘要
static class | AbstractMap.SimpleEntry<K,V> 维护键和值的 Entry。
static class | AbstractMap.SimpleImmutableEntry<K,V> 维护不可变的键和值的 Entry。
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
构造方法摘要
protected AbstractMap()
唯一的构造方法。
方法摘要
void | clear() 从此映射中移除所有映射关系（可选操作）。
protected Object | clone() 返回此 AbstractMap 实例的浅表副本：不复制键和值本身。
boolean | containsKey(Object key) 如果此映射包含指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
abstract Set<Map.Entry<K,V>> | entrySet() 返回此映射中包含的映射关系的 Set 视图。
boolean | equals(Object o) 比较指定对象与此映射的相等性。
V | get(Object key) 返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。
int | hashCode() 返回此映射的哈希码值。
boolean | isEmpty() 如果此映射未包含键-值映射关系，则返回 true。
Set<K> | keySet() 返回此映射中包含的键的 Set 视图。
V | put(K key, V value) 将指定的值与此映射中的指定键关联（可选操作）。
void | putAll(Map<? extends K,? extends V> m) 从指定映射中将所有映射关系复制到此映射中（可选操作）。
V | remove(Object key) 如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。
int | size() 返回此映射中的键-值映射关系数。
String | toString() 返回此映射的字符串表示形式。
Collection<V> | values() 返回此映射中包含的值的 Collection 视图。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractMap

protected AbstractMap()
唯一的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

size

public int size()
返回此映射中的键-值映射关系数。如果该映射包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

此实现返回 entrySet().size()。

指定者：
接口 Map<K,V> 中的 size
返回：
此映射中的键-值映射关系数

isEmpty

public boolean isEmpty()
如果此映射未包含键-值映射关系，则返回 true。

此实现返回 size() == 0。

指定者：
接口 Map<K,V> 中的 isEmpty
返回：
如果此映射未包含键-值映射关系，则返回 true

containsValue

public boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。更确切地讲，当且仅当此映射至少包含一个对满足 (value==null ? v==null : value.equals(v)) 的值 v 的映射关系时，返回 true。对于大多数 Map 接口的实现而言，此操作需要的时间可能与映射大小呈线性关系。

此实现在 entrySet() 上进行迭代，以搜索带有指定值的条目。如果找到这样的条目，则返回 true。如果迭代终止，并且没有找到这样的条目，则返回 false。注意，此实现所需的时间与映射的大小呈线性关系。

指定者：
接口 Map<K,V> 中的 containsValue
参数：
value - 测试是否存在于此映射中的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true
抛出：
ClassCastException - 如果该值对于此映射是不合适的类型（可选）
NullPointerException - 如果指定值为 null 并且此映射不允许 null 值（可选）

containsKey

public boolean containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。更确切地讲，当且仅当此映射包含针对满足 (key==null ? k==null : key.equals(k)) 的键 k 的映射关系时，返回 true。（最多只能有一个这样的映射关系）。

此实现在 entrySet() 上进行迭代，以搜索带有指定键的条目。如果找到这样的条目，则返回 true。如果迭代终止，并且没有找到这样的条目，则返回 false。注意，此实现所需的时间与映射的大小呈线性关系；许多实现将重写此方法。

指定者：
接口 Map<K,V> 中的 containsKey
参数：
key - 测试是否存在于此映射中的键
返回：
如果此映射包含指定键的映射关系，则返回 true
抛出：
ClassCastException - 如果该键对于此映射是不合适的类型（可选）
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键（可选）

get

public V get(Object key)
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。

更确切地讲，如果此映射包含满足 (key==null ? k==null : key.equals(k)) 的键 k 到值 v 的映射关系，则此方法返回 v；否则返回 null。（最多只能有一个这样的映射关系）。

如果此映射允许 null 值，则返回 null 值并不一定 表示该映射不包含该键的映射关系；也可能该映射将该键显示地映射到 null。使用 containsKey 操作可区分这两种情况。

此实现在 entrySet() 上进行迭代，以搜索带有指定键的条目。如果找到这样的条目，则返回该条目的值。如果迭代终止，并且没有找到这样的条目，则返回 null。注意，此实现所需的时间与映射的大小呈线性关系；许多实现将重写此方法。

指定者：
接口 Map<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
抛出：
ClassCastException - 如果该键对于此映射是不合适的类型（可选）
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键（可选）

put

public V put(K key,
             V value)
将指定的值与此映射中的指定键关联（可选操作）。如果此映射以前包含一个该键的映射关系，则用指定值替换旧值（当且仅当 m.containsKey(k) 返回 true 时，才能说映射 m 包含键 k 的映射关系）。

此实现始终抛出 UnsupportedOperationException。

指定者：
接口 Map<K,V> 中的 put
参数：
key - 与指定值关联的键
value - 与指定键关联的值
返回：
以前与 key 关联的值，如果没有针对 key 的映射关系，则返回 null。（如果该实现支持 null 值，则返回 null 也可能表示此映射以前将 null 与 key 关联）。
抛出：
UnsupportedOperationException - 如果此映射不支持 put 操作
ClassCastException - 如果指定键或值的类不允许将其存储在此映射中
NullPointerException - 如果指定键或值为 null，并且此映射不允许 null 键或值
IllegalArgumentException - 如果指定键或值的某些属性不允许将其存储在此映射中

remove

public V remove(Object key)
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。更确切地讲，如果此映射包含从满足 (key==null ? k==null :key.equals(k)) 的键 k 到值 v 的映射关系，则移除该映射关系。（该映射最多只能包含一个这样的映射关系。）

返回此映射中以前关联该键的值，如果此映射不包含该键的映射关系，则返回 null。

如果此映射允许 null 值，则返回 null 值并不一定 表示该映射不包含该键的映射关系；也可能该映射将该键显示地映射到 null。

调用返回后，此映射将不再包含指定键的映射关系。

此实现在 entrySet() 上进行迭代，以搜索带有指定键的条目。如果找到这样的条目，则通过 getValue 操作获取该条目的值，然后使用迭代器的 remove 操作从 collection（以及底层实现映射）中移除该条目，并返回保存的值。如果迭代终止，并且没有找到这样的条目，则返回 null。注意，此实现所需的时间与映射大小呈线性关系；许多实现将重写此方法。

注意，如果 entrySet 迭代器不支持 remove 方法，并且此映射包含指定键的映射关系，则此实现将抛出 UnsupportedOperationException。

指定者：
接口 Map<K,V> 中的 remove
参数：
key - 从映射中移除其映射关系的键
返回：
以前与 key 关联的值；如果没有 key 的映射关系，则返回 null。
抛出：
UnsupportedOperationException - 如果此映射不支持 remove 操作
ClassCastException - 如果该键对于此映射是不合适的类型（可选）
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键（可选）

putAll

public void putAll(Map<? extends K,? extends V> m)
从指定映射中将所有映射关系复制到此映射中（可选操作）。对于指定映射中的每个键 k 到值 v 的映射关系，此调用等效于对此映射调用一次 put(k, v)。如果正在进行此操作的同时修改了指定的映射，则此操作的行为是不确定的。

此实现在指定映射的 entrySet() collection 上进行迭代，并对迭代返回的每个条目调用一次此映射的 put 操作。

注意，如果此映射不支持 put 操作，并且指定映射为非空，则此实现将抛出 UnsupportedOperationException。

指定者：
接口 Map<K,V> 中的 putAll
参数：
m - 要存储在此映射中的映射关系
抛出：
UnsupportedOperationException - 如果此映射不支持 putAll 操作
ClassCastException - 如果指定映射中的键或值的类不允许将其存储在此映射中
NullPointerException - 如果指定映射为 null，或者此映射不允许 null 键或值，并且指定的映射包含 null 键或值
IllegalArgumentException - 如果指定映射中的键或值的某些属性不允许将其存储在此映射中

clear

public void clear()
从此映射中移除所有映射关系（可选操作）。此调用返回后，该映射将为空。

此实现调用 entrySet().clear()。

注意，如果 entrySet 不支持 clear 操作，则此实现将抛出 UnsupportedOperationException。

指定者：
接口 Map<K,V> 中的 clear
抛出：
UnsupportedOperationException - 如果此映射不支持 clear 操作

keySet

public Set<K> keySet()
返回此映射中包含的键的 Set 视图。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

此实现返回一个子类化 AbstractSet 的 set。子类的 iterator 方法通过此映射的 entrySet() 迭代器返回一个“包装器对象”。size 方法委托给此映射的 size 方法，contains 方法委托给此映射的 containsKey 方法。

set 是在第一次调用此方法时创建的，并为响应所有后续调用而返回。 因为不执行同步操作，所以对此方法的多个调用几乎总是返回相同的 set。

指定者：
接口 Map<K,V> 中的 keySet
返回：
此映射中包含的键的 set 视图

values

public Collection<V> values()
返回此映射中包含的值的 Collection 视图。该 collection 受映射支持，所以对映射的更改可在此 collection 中反映出来，反之亦然。如果对该 collection 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。collection 支持元素移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

此实现返回一个子类化 AbstractCollection 的 collection。子类的 iterator 方法通过此映射的 entrySet() 迭代器返回一个“包装器对象”。size 方法委托给此映射的 size 方法，contains 方法委托给此映射的 containsValue 方法。

collection 是在第一次调用此方法时创建的，并为响应所有后续调用而返回。因为不执行同步操作，所以对此方法的多个调用几乎总是返回相同的 collection。

指定者：
接口 Map<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public abstract Set<Map.Entry<K,V>> entrySet()
从接口 Map 复制的描述
返回此映射中包含的映射关系的 Set 视图。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作，或者通过对迭代器返回的映射项执行 setValue 操作除外），则迭代结果是不确定的。set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图

equals

public boolean equals(Object o)
比较指定对象与此映射的相等性。如果给定对象也是一个映射并且两个映射表示相同的映射关系，则返回 true。更确切地讲，如果 m1.entrySet().equals(m2.entrySet())，则两个映射 m1 和 m2 表示相同的映射关系。这可以确保 equals 方法在 Map 接口的不同实现中正常工作。

此实现首先检查指定的对象是否为此映射；如果是，则返回 true。然后，它将检查指定的对象是否是一个大小与此映射相等的映射；如果不是，则返回 false。如果是，则在此映射的 entrySet collection 上进行迭代，并检查指定的映射是否包含此映射所包含的每个映射关系。如果指定的映射中不包含这样的映射关系，则返回 false。如果迭代完成，则返回 true。

指定者：
接口 Map<K,V> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与此映射进行相等性比较的对象
返回：
如果指定的对象等于此映射，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此映射的哈希码值。映射的哈希码被定义为该映射的 entrySet() 视图中每个条目的哈希码之和。这确保了 m1.equals(t2) 对于任意两个映射 m1 和 m2 都意味着 m1.hashCode()==m2.hashCode()，正如 Object.hashCode() 的常规协定所要求的。

此实现在 entrySet() 上进行迭代，对 set 中的每个元素（条目）调用 hashCode()，并合计结果。

指定者：
接口 Map<K,V> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此映射的哈希码值。
另请参见：
Map.Entry.hashCode(),
Object.equals(Object),
Set.equals(Object)

toString

public String toString()
返回此映射的字符串表示形式。该字符串表示形式由键-值映射关系列表组成，按照该映射 entrySet 视图的迭代器返回的顺序排列，并用括号 ("{}") 括起来。相邻的映射关系是用字符 ", "（逗号加空格）分隔的。每个键-值映射关系按以下方式呈现：键，后面是一个等号 ("=")，再后面是关联的值。键和值都通过 String.valueOf(Object) 转换为字符串。

覆盖：
类 Object 中的 toString
返回：
此映射的字符串表示形式。

clone

protected Object clone()
                throws CloneNotSupportedException
返回此 AbstractMap 实例的浅表副本：不复制键和值本身。

覆盖：
类 Object 中的 clone
返回：
此映射的浅表副本
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractMap.SimpleEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractMap.SimpleEntry<K,V>

java.lang.Object
    继承者  java.util.AbstractMap.SimpleEntry<K,V>
所有已实现的接口：
Serializable, Map.Entry<K,V>
正在封闭类：
AbstractMap<K,V>
public static class AbstractMap.SimpleEntry<K,V>
extends Object
implements Map.Entry<K,V>, Serializable

维护键和值的 Entry。可以使用 setValue 方法更改值。此类简化了构建自定义映射实现的过程。例如，可以使用 Map.entrySet().toArray 方法方便地返回 SimpleEntry 实例数组。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
AbstractMap.SimpleEntry(K key, V value)
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定的项相同。
方法摘要
boolean | equals(Object o) 比较指定对象与此项的相等性。
K | getKey() 返回对应于此项的键。
V | getValue() 返回对应于此项的值。
int | hashCode() 返回此映射项的哈希码值。
V | setValue(V value) 用指定值替换对应于此项的值。
String | toString() 返回此映射项的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractMap.SimpleEntry

public AbstractMap.SimpleEntry(K key,
                               V value)
创建一个项，它表示从指定键到指定值的映射关系。

参数：
key - 此项所表示的键
value - 此项所表示的值

AbstractMap.SimpleEntry

public AbstractMap.SimpleEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定的项相同。

参数：
entry - 要复制的项
方法详细信息

getKey

public K getKey()
返回对应于此项的键。

指定者：
接口 Map.Entry<K,V> 中的 getKey
返回：
对应于此项的键

getValue

public V getValue()
返回对应于此项的值。

指定者：
接口 Map.Entry<K,V> 中的 getValue
返回：
对应于此项的值

setValue

public V setValue(V value)
用指定值替换对应于此项的值。

指定者：
接口 Map.Entry<K,V> 中的 setValue
参数：
value - 要在此项中存储的新值
返回：
对应于此项的旧值

equals

public boolean equals(Object o)
比较指定对象与此项的相等性。如果给定对象也是一个映射项，并且两个项表示的映射关系相同，则返回 true。 更确切地讲，如果满足以下条件，则两个项 e1 和 e2 表示的映射关系相同：
(e1.getKey()==null ?
e2.getKey()==null :
e1.getKey().equals(e2.getKey()))
   &&
(e1.getValue()==null ?
e2.getValue()==null :
e1.getValue().equals(e2.getValue()))
这确保 equals 方法可在 Map.Entry 接口的不同实现之间正常工作。

指定者：
接口 Map.Entry<K,V> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 将与此映射项进行相等性比较的对象
返回：
如果指定的对象等于此映射项，则返回 true
另请参见：
hashCode()

hashCode

public int hashCode()
返回此映射项的哈希码值。映射项 e 的哈希码值定义如下：
(e.getKey()==null   ?0 : e.getKey().hashCode()) ^
(e.getValue()==null ?0 : e.getValue().hashCode())
这确保 e1.equals(e2) 意味着对于任意两个项 e1 和 e2 而言，都存在 e1.hashCode()==e2.hashCode()，正如 Object.hashCode() 常规协定所要求的那样。

指定者：
接口 Map.Entry<K,V> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此映射项的哈希码值
另请参见：
equals(java.lang.Object)

toString

public String toString()
返回此映射项的 String 表示形式。此实现返回此项的键的字符串表示形式，后跟等号 ("=")，然后是此项的值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此映射项的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractMap.SimpleImmutableEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractMap.SimpleImmutableEntry<K,V>

java.lang.Object
    继承者  java.util.AbstractMap.SimpleImmutableEntry<K,V>
所有已实现的接口：
Serializable, Map.Entry<K,V>
正在封闭类：
AbstractMap<K,V>
public static class AbstractMap.SimpleImmutableEntry<K,V>
extends Object
implements Map.Entry<K,V>, Serializable

维护不可变的键和值的 Entry。此类不支持 setValue 方法。在返回线程安全的键-值映射关系快照的方法中，此类也许很方便。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
AbstractMap.SimpleImmutableEntry(K key, V value)
创建一个项，它表示从指定键到指定值的映射关系。
AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定项相同。
方法摘要
boolean | equals(Object o) 比较指定对象与此项的相等性。
K | getKey() 返回对应于此项的键。
V | getValue() 返回对应于此项的值。
int | hashCode() 返回此映射项的哈希码值。
V | setValue(V value) 用指定值替换对应于此项的值（可选操作）。
String | toString() 返回此映射项的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractMap.SimpleImmutableEntry

public AbstractMap.SimpleImmutableEntry(K key,
                                        V value)
创建一个项，它表示从指定键到指定值的映射关系。

参数：
key - 此项所表示的键
value - 此项所表示的值

AbstractMap.SimpleImmutableEntry

public AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定项相同。

参数：
entry - 要复制的项
方法详细信息

getKey

public K getKey()
返回对应于此项的键。

指定者：
接口 Map.Entry<K,V> 中的 getKey
返回：
对应于此项的键

getValue

public V getValue()
返回对应于此项的值。

指定者：
接口 Map.Entry<K,V> 中的 getValue
返回：
对应于此项的值

setValue

public V setValue(V value)
用指定值替换对应于此项的值（可选操作）。此类实现一个不可变的 映射项，所以此实现抛出 UnsupportedOperationException。

指定者：
接口 Map.Entry<K,V> 中的 setValue
参数：
value - 要在此项中存储的新值
返回：
与此项对应的旧值
抛出：
UnsupportedOperationException - 始终抛出

equals

public boolean equals(Object o)
比较指定对象与此项的相等性。如果给定对象也是一个映射项，并且两个项表示的映射关系相同，则返回 true。 更确切地讲，如果满足以下条件，则两个项 e1 和 e2 表示的映射关系相同：
(e1.getKey()==null ?
e2.getKey()==null :
e1.getKey().equals(e2.getKey()))
   &&
(e1.getValue()==null ?
e2.getValue()==null :
e1.getValue().equals(e2.getValue()))
这确保 equals 方法可在 Map.Entry 接口的不同实现之间正常工作。

指定者：
接口 Map.Entry<K,V> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 将与此映射项进行相等性比较的对象
返回：
如果指定的对象等于此映射项，则返回 true
另请参见：
hashCode()

hashCode

public int hashCode()
返回此映射项的哈希码值。映射项 e 的哈希码值定义如下：
(e.getKey()==null   ?0 : e.getKey().hashCode()) ^
(e.getValue()==null ?0 : e.getValue().hashCode())
这确保 e1.equals(e2) 意味着对于任意两个项 e1 和 e2 而言，都存在 e1.hashCode()==e2.hashCode()，正如 Object.hashCode() 常规协定所要求的那样。

指定者：
接口 Map.Entry<K,V> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此映射项的哈希码值
另请参见：
equals(java.lang.Object)

toString

public String toString()
返回此映射项的 String 表示形式。此实现返回此项的键的字符串表示形式，后跟等号 ("=")，然后是此项的值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此映射项的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractQueue<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
类型参数：
E - 此 collection 中所保存元素的类型
所有已实现的接口：
Iterable<E>, Collection<E>, Queue<E>
直接已知子类：
ArrayBlockingQueue, ConcurrentLinkedQueue, DelayQueue, LinkedBlockingDeque, LinkedBlockingQueue, PriorityBlockingQueue, PriorityQueue, SynchronousQueue
public abstract class AbstractQueue<E>
extends AbstractCollection<E>
implements Queue<E>

此类提供某些 Queue 操作的骨干实现。此类中的实现适用于基本实现不 允许包含 null 元素时。add、remove 和 element 方法分别基于 offer、poll 和 peek 方法，但是它们通过抛出异常而不是返回 false 或 null 来指示失败。

扩展此类的 Queue 实现至少必须定义一个不允许插入 null 元素的 Queue.offer(E) 方法，该方法以及 Queue.peek()、Queue.poll()、Collection.size() 和 Collection.iterator() 都支持 Iterator.remove() 方法。通常还要重写其他方法。如果无法满足这些要求，那么可以转而考虑为 AbstractCollection 创建子类。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5

构造方法摘要
protected AbstractQueue()
子类使用的构造方法。
方法摘要
boolean | add(E e) 将指定的元素插入到此队列中（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
boolean | addAll(Collection<? extends E> c) 将指定 collection 中的所有元素都添加到此队列中。
void | clear() 移除此队列中的所有元素。
E | element() 获取但不移除此队列的头。
E | remove() 获取并移除此队列的头。
从类 java.util.AbstractCollection 继承的方法
contains, containsAll, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Queue 继承的方法
offer, peek, poll
从接口 java.util.Collection 继承的方法
contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray

构造方法详细信息

AbstractQueue

protected AbstractQueue()
子类使用的构造方法。

方法详细信息

add

public boolean add(E e)
将指定的元素插入到此队列中（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用空间，则抛出 IllegalStateException。

如果 offer 成功，则此实现返回 true，否则抛出 IllegalStateException。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractCollection<E> 中的 add
参数：
e - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
IllegalStateException - 如果此时由于容量限制不能添加元素
ClassCastException - 如果指定元素的类不允许将该元素添加到此队列中
NullPointerException - 如果指定元素为 null 并且此队列不允许 null 元素
IllegalArgumentException - 如果此元素的某些属性不允许将该元素添加到此队列中

remove

public E remove()
获取并移除此队列的头。此方法与 poll 唯一的不同在于：此队列为空时将抛出一个异常。

除非队列为空，否则此实现返回 poll 的结果。

指定者：
接口 Queue<E> 中的 remove
返回：
此队列的头
抛出：
NoSuchElementException - 如果此队列为空

element

public E element()
获取但不移除此队列的头。此方法与 peek 唯一的不同在于：此队列为空时将抛出一个异常。

除非队列为空，否则此实现返回 peek 的结果。

指定者：
接口 Queue<E> 中的 element
返回：
此队列的头
抛出：
NoSuchElementException - 如果此队列为空

clear

public void clear()
移除此队列中的所有元素。此调用返回后，队列将为空。

此实现重复调用 poll，直到它返回 null 为止。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractCollection<E> 中的 clear

addAll

public boolean addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此队列中。如果试图将某一队列 addAll 到该队列本身中，则会导致 IllegalArgumentException。此外，如果正在进行此操作时修改指定的 collection，则此操作的行为是不确定的。

此实现在指定的 collection 上进行迭代，并依次将迭代器返回的每一个元素添加到此队列中。在试图添加某一元素（尤其是 null 元素）时如果遇到了运行时异常，则可能导致在抛出相关异常时只成功地添加了某些元素。

指定者：
接口 Collection<E> 中的 addAll
覆盖：
类 AbstractCollection<E> 中的 addAll
参数：
c - 包含要添加到此队列的元素的 collection
返回：
如果此队列由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果指定 collection 元素的类不允许将该元素添加到此队列中
NullPointerException - 如果指定 collection 包含一个 null 元素并且此队列不允许 null 元素，或者指定 collection 为 null
IllegalArgumentException - 如果指定 collection 元素的某些属性不允许将该元素添加到此队列中，或者指定 collection 是此队列
IllegalStateException - 如果此时由于插入限制无法添加所有元素
另请参见：
add(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractSequentialList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractSequentialList<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.AbstractSequentialList<E>
所有已实现的接口：
Iterable<E>, Collection<E>, List<E>
直接已知子类：
LinkedList
public abstract class AbstractSequentialList<E>
extends AbstractList<E>

此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。对于随机访问数据（如数组），应该优先使用 AbstractList，而不是先使用此类。

从某种意义上说，此类与在列表的列表迭代器上实现“随机访问”方法（get(int index)、set(int index, E element)、add(int index, E element) 和 remove(int index)）的 AbstractList 类相对立，而不是其他关系。

要实现一个列表，程序员只需要扩展此类，并提供 listIterator 和 size 方法的实现即可。对于不可修改的列表，程序员只需要实现列表迭代器的 hasNext、next、hasPrevious、previous 和 index 方法即可。

对于可修改的列表，程序员应该再另外实现列表迭代器的 set 方法。对于可变大小的列表，程序员应该再另外实现列表迭代器的 remove 和 add 方法。

按照 Collection 接口规范中的推荐，程序员通常应该提供一个 void（无参数）构造方法和 collection 构造方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, List, AbstractList, AbstractCollection

字段摘要
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
protected AbstractSequentialList()
单独的构造方法。
方法摘要
void | add(int index, E element) 在此列表中的指定位置上插入指定的元素（可选操作）。
boolean | addAll(int index, Collection<? extends E> c) 在此列表中指定的位置上插入指定 collection 中的所有元素（可选操作）。
E | get(int index) 返回此列表中指定位置上的元素。
Iterator<E> | iterator() 返回在此列表中的元素上进行迭代的迭代器（按适当顺序）。
abstract ListIterator<E> | listIterator(int index) 返回在此列表中的元素上进行迭代的列表迭代器（按适当顺序）。
E | remove(int index) 移除此列表中指定位置上的元素（可选操作）。
E | set(int index, E element) 用指定的元素替代此列表中指定位置上的元素（可选操作）。
从类 java.util.AbstractList 继承的方法
add, clear, equals, hashCode, indexOf, lastIndexOf, listIterator, removeRange, subList
从类 java.util.AbstractCollection 继承的方法
addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
addAll, contains, containsAll, isEmpty, remove, removeAll, retainAll, size, toArray, toArray

构造方法详细信息

AbstractSequentialList

protected AbstractSequentialList()
单独的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

get

public E get(int index)
返回此列表中指定位置上的元素。

此实现首先获得一个指向索引元素的列表迭代器（通过 listIterator(index) 方法）。然后它使用 ListIterator.next 获得该元素并返回它。

指定者：
接口 List<E> 中的 get
指定者：
类 AbstractList<E> 中的 get
参数：
index - 要返回的元素的索引
返回：
列表中指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

set

public E set(int index,
             E element)
用指定的元素替代此列表中指定位置上的元素（可选操作）。

此实现首先获得一个指向索引元素的列表迭代器（通过 listIterator(index) 方法）。然后它使用 ListIterator.next 获得当前元素，并使用 ListIterator.set 替代它。

注意，如果该列表迭代器没有实现 set 操作，则此实现将抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 set
覆盖：
类 AbstractList<E> 中的 set
参数：
index - 要替换的元素的索引
element - 要在指定位置存储的元素
返回：
以前在指定位置的元素
抛出：
UnsupportedOperationException - 如果列表不支持 set 操作
ClassCastException - 如果指定元素的类不允许它添加到此列表
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

add

public void add(int index,
                E element)
在此列表中的指定位置上插入指定的元素（可选操作）。向右移动当前位于该位置上的元素（如果有）以及所有后续元素（将其索引加 1）。

此实现首先获得一个指向索引元素的列表迭代器（通过 listIterator(index)）。然后它使用 ListIterator.add 插入指定的元素。

注意，如果列表迭代器没有实现 add 操作，则此实现将抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 add
覆盖：
类 AbstractList<E> 中的 add
参数：
index - 要在其中插入指定元素处的索引
element - 要插入的元素
抛出：
UnsupportedOperationException - 如果列表不支持 add 操作
ClassCastException - 如果指定元素的类不允许它添加到此列表
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

remove

public E remove(int index)
移除此列表中指定位置上的元素（可选操作）。向左移动所有后续元素（将其索引减 1）。返回从列表中移除的元素。

此实现首先获得一个指向索引元素的列表迭代器（通过 listIterator(index) 方法）。然后它使用 ListIterator.remove 移除该元素。

注意，如果该列表迭代器没有实现 remove 操作，则此实现将抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 remove
覆盖：
类 AbstractList<E> 中的 remove
参数：
index - 要移除的元素的索引
返回：
以前在指定位置的元素
抛出：
UnsupportedOperationException - 如果列表不支持 remove 操作
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

addAll

public boolean addAll(int index,
                      Collection<? extends E> c)
在此列表中指定的位置上插入指定 collection 中的所有元素（可选操作）。向右移动当前位于该位置上的元素（如果有）以及所有后续元素（增加其索引）。新元素将按指定 collection 的迭代器所返回的顺序出现在列表中。如果正在进行此操作时修改指定的 collection，则此操作行为是未指定的。（注意，如果指定的 collection 是此列表并且是非空的，则会发生这种情况。）

此实现获得指定 collection 的迭代器，以及此列表指向索引元素的列表迭代器（通过 listIterator(index) 方法）。然后，它在指定的 collection 上进行迭代，通过使用 ListIterator.next 之后紧接着使用 ListIterator.add 方法（以跳过添加的元素），把从迭代器中获得的元素逐个插入此列表中。

注意，如果 listIterator 方法返回的列表迭代器没有实现 add 操作，则此实现将会抛出 UnsupportedOperationException。

指定者：
接口 List<E> 中的 addAll
覆盖：
类 AbstractList<E> 中的 addAll
参数：
index - 将指定 collection 的第一个元素所插入位置的索引
c - 包含要添加到此列表的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果列表不支持 addAll 操作
ClassCastException - 如果指定 collection 中某个元素的类不允许它添加到此列表
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素，并且该列表不允许 null 元素，或者指定的 collection 为 null
IllegalArgumentException - 如果指定 collection 的元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

iterator

public Iterator<E> iterator()
返回在此列表中的元素上进行迭代的迭代器（按适当顺序）。

此实现仅返回列表的一个列表迭代器。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 List<E> 中的 iterator
覆盖：
类 AbstractList<E> 中的 iterator
返回：
在此列表中的元素上进行迭代的迭代器（按适当顺序）
另请参见：
AbstractList.modCount

listIterator

public abstract ListIterator<E> listIterator(int index)
返回在此列表中的元素上进行迭代的列表迭代器（按适当顺序）。

指定者：
接口 List<E> 中的 listIterator
覆盖：
类 AbstractList<E> 中的 listIterator
参数：
index - 从列表迭代器返回（通过调用 next 方法）的第一个元素的索引
返回：
在此列表中的元素上进行迭代的列表迭代器（按适当顺序）
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())
另请参见：
AbstractList.modCount
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 AbstractSet<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
类型参数：
E - 此 set 所维护的元素的类型
所有已实现的接口：
Iterable<E>, Collection<E>, Set<E>
直接已知子类：
ConcurrentSkipListSet, CopyOnWriteArraySet, EnumSet, HashSet, TreeSet
public abstract class AbstractSet<E>
extends AbstractCollection<E>
implements Set<E>

此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。

通过扩展此类来实现一个 set 的过程与通过扩展 AbstractCollection 来实现 Collection 的过程是相同的，除了此类的子类中的所有方法和构造方法都必须服从 Set 接口所强加的额外限制（例如，add 方法必须不允许将一个对象的多个实例添加到一个 set 中）。

注意，此类并没有重写 AbstractCollection 类中的任何实现。它仅仅添加了 equals 和 hashCode 的实现。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, AbstractCollection, Set

构造方法摘要
protected AbstractSet()
单独的构造方法。
方法摘要
boolean | equals(Object o) 比较指定对象与此 set 的相等性。
int | hashCode() 返回此 set 的哈希码值。
boolean | removeAll(Collection<?> c) 从此 set 中移除包含在指定 collection 中的所有元素（可选操作）。
从类 java.util.AbstractCollection 继承的方法
add, addAll, clear, contains, containsAll, isEmpty, iterator, remove, retainAll, size, toArray, toArray, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Set 继承的方法
add, addAll, clear, contains, containsAll, isEmpty, iterator, remove, retainAll, size, toArray, toArray

构造方法详细信息

AbstractSet

protected AbstractSet()
单独的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

equals

public boolean equals(Object o)
比较指定对象与此 set 的相等性。如果给定对象也是一个 set，两个 set 的大小相等，并且给定 set 的每个成员都包含在此 set 中，则返回 true。这确保 equals 方法在 Set 接口的不同实现间正常工作。

此实现首先检查指定的对象是否是此 set；如果是，则返回 true。然后，它将检查指定的对象是否是一个大小与此 set 的大小相等的 set；如果不是，则返回 false。如果是，则返回 containsAll((Collection) o)。

指定者：
接口 Collection<E> 中的 equals
指定者：
接口 Set<E> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与此 set 进行相等性比较的对象
返回：
如果指定的对象等于此 set，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 set 的哈希码值。set 的哈希码被定义为该 set 中元素的哈希码的总和，其中 null 元素的哈希码被定义为 0。这确保了 s1.equals(s2) 意味着对于任何两个 set s1 和 s2，都有 s1.hashCode()==s2.hashCode()，正如 Object.hashCode() 的常规协定所要求的。

此实现对 set 进行迭代，在 set 的每个元素上调用 hashCode 方法，并合计结果。

指定者：
接口 Collection<E> 中的 hashCode
指定者：
接口 Set<E> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 set 的哈希码值。
另请参见：
Object.equals(Object), Set.equals(Object)

removeAll

public boolean removeAll(Collection<?> c)
从此 set 中移除包含在指定 collection 中的所有元素（可选操作）。如果指定 collection 也是一个 set，则此操作有效地修改此 set，从而其值成为两个 set 的不对称差集。

通过在此 set 和指定 collection 上调用 size 方法，此实现可以确定哪一个更小。如果此 set 中的元素更少，则该实现将在此 set 上进行迭代，依次检查迭代器返回的每个元素，查看它是否包含在指定的 collection 中。如果包含它，则使用迭代器的 remove 方法从此 set 中将其移除。如果指定 collection 中的元素更少，则该实现将在指定的 collection 上进行迭代，并使用此 set 的 remove 方法，从此 set 中移除迭代器返回的每个元素。

注意，如果 iterator 方法返回的迭代器没有实现 remove 方法，则此实现抛出 UnsupportedOperationException。

指定者：
接口 Collection<E> 中的 removeAll
指定者：
接口 Set<E> 中的 removeAll
覆盖：
类 AbstractCollection<E> 中的 removeAll
参数：
c - 包含将从此 set 中移除的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 set 不支持 removeAll 操作
ClassCastException - 如果此 set 元素的类与指定 collection 不兼容（可选）
NullPointerException - 如果此 set 包含一个 null 元素并且指定 collection 不允许 null 元素（可选），或者指定 collection 为 null
另请参见：
AbstractCollection.remove(Object), AbstractCollection.contains(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ArrayDeque (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ArrayDeque<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.ArrayDeque<E>
类型参数：
E - the type of elements held in this collection
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, Deque<E>, Queue<E>
public class ArrayDeque<E>
extends AbstractCollection<E>
implements Deque<E>, Cloneable, Serializable

Deque 接口的大小可变数组的实现。数组双端队列没有容量限制；它们可根据需要增加以支持使用。它们不是线程安全的；在没有外部同步时，它们不支持多个线程的并发访问。禁止 null 元素。此类很可能在用作堆栈时快于 Stack，在用作队列时快于 LinkedList。

大多数 ArrayDeque 操作以摊销的固定时间运行。异常包括 remove、removeFirstOccurrence、removeLastOccurrence、contains、iterator.remove() 以及批量操作，它们均以线性时间运行。

此类的 iterator 方法返回的迭代器是快速失败 的：如果在创建迭代器后的任意时间通过除迭代器本身的 remove 方法之外的任何其他方式修改了双端队列，则迭代器通常将抛出 ConcurrentModificationException。因此，面对并发修改，迭代器很快就会完全失败，而不是冒着在将来不确定的时刻任意发生不确定行为的风险。

注意，迭代器的快速失败行为不能得到保证，一般来说，存在不同步的并发修改时，不可能作出任何坚决的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测 bug。

此类及其迭代器实现 Collection 和 Iterator 接口的所有可选 方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
ArrayDeque()
构造一个初始容量能够容纳 16 个元素的空数组双端队列。
ArrayDeque(Collection<? extends E> c)
构造一个包含指定 collection 的元素的双端队列，这些元素按 collection 的迭代器返回的顺序排列。
ArrayDeque(int numElements)
构造一个初始容量能够容纳指定数量的元素的空数组双端队列。
方法摘要
 boolean add(E e)
将指定元素插入此双端队列的末尾。
 void addFirst(E e)
将指定元素插入此双端队列的开头。
 void addLast(E e)
将指定元素插入此双端队列的末尾。
 void clear()
从此双端队列中移除所有元素。
 ArrayDeque<E> clone()
返回此双端队列的副本。
 boolean contains(Object o)
如果此双端队列包含指定元素，则返回 true。
 Iterator<E> descendingIterator()
返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。
 E element()
获取，但不移除此双端队列所表示的队列的头。
 E getFirst()
获取，但不移除此双端队列的第一个元素。
 E getLast()
获取，但不移除此双端队列的最后一个元素。
 boolean isEmpty()
如果此双端队列未包含任何元素，则返回 true。
 Iterator<E> iterator()
返回在此双端队列的元素上进行迭代的迭代器。
 boolean offer(E e)
将指定元素插入此双端队列的末尾。
 boolean offerFirst(E e)
将指定元素插入此双端队列的开头。
 boolean offerLast(E e)
将指定元素插入此双端队列的末尾。
 E peek()
获取，但不移除此双端队列所表示的队列的头；如果此双端队列为空，则返回 null。
 E peekFirst()
获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
 E peekLast()
获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
 E poll()
获取并移除此双端队列所表示的队列的头（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
 E pollFirst()
获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
 E pollLast()
获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
 E pop()
从此双端队列所表示的堆栈中弹出一个元素。
 void push(E e)
将元素推入此双端队列所表示的堆栈。
 E remove()
获取并移除此双端队列所表示的队列的头。
 boolean remove(Object o)
从此双端队列中移除指定元素的单个实例。
 E removeFirst()
获取并移除此双端队列第一个元素。
 boolean removeFirstOccurrence(Object o)
移除此双端队列中第一次出现的指定元素（当从头部到尾部遍历双端队列时）。
 E removeLast()
获取并移除此双端队列的最后一个元素。
 boolean removeLastOccurrence(Object o)
移除此双端队列中最后一次出现的指定元素（当从头部到尾部遍历双端队列时）。
 int size()
返回此双端队列中的元素数。
 Object[] toArray()
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）。
<T> T[]
toArray(T[] a)
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。
从类 java.util.AbstractCollection 继承的方法
addAll, containsAll, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Collection 继承的方法
addAll, containsAll, equals, hashCode, removeAll, retainAll

构造方法详细信息

ArrayDeque

public ArrayDeque()
构造一个初始容量能够容纳 16 个元素的空数组双端队列。

ArrayDeque

public ArrayDeque(int numElements)
构造一个初始容量能够容纳指定数量的元素的空数组双端队列。

参数：
numElements - 双端队列初始容量的下边界

ArrayDeque

public ArrayDeque(Collection<? extends E> c)
构造一个包含指定 collection 的元素的双端队列，这些元素按 collection 的迭代器返回的顺序排列。（collection 迭代器返回的第一个元素将是第一个元素，或双端队列的开头。）

参数：
c - 要将其元素放入双端队列的 collection
抛出：
NullPointerException - 如果指定 collection 为 null
方法详细信息

addFirst

public void addFirst(E e)
将指定元素插入此双端队列的开头。

指定者：
接口 Deque<E> 中的 addFirst
参数：
e - 要添加的元素
抛出：
NullPointerException - 如果指定元素为 null

addLast

public void addLast(E e)
将指定元素插入此双端队列的末尾。

此方法等效于 add(E)。

指定者：
接口 Deque<E> 中的 addLast
参数：
e - 要添加的元素
抛出：
NullPointerException - 如果指定元素为 null

offerFirst

public boolean offerFirst(E e)
将指定元素插入此双端队列的开头。

指定者：
接口 Deque<E> 中的 offerFirst
参数：
e - 要添加的元素
返回：
true （根据 Deque.offerFirst(E) 的规定）
抛出：
NullPointerException - 如果指定元素为 null

offerLast

public boolean offerLast(E e)
将指定元素插入此双端队列的末尾。

指定者：
接口 Deque<E> 中的 offerLast
参数：
e - 要添加的元素
返回：
true （根据 Deque.offerLast(E) 的规定）
抛出：
NullPointerException - 如果指定元素为 null

removeFirst

public E removeFirst()
从接口 Deque 复制的描述
获取并移除此双端队列第一个元素。此方法与 pollFirst 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 removeFirst
返回：
此双端队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

removeLast

public E removeLast()
从接口 Deque 复制的描述
获取并移除此双端队列的最后一个元素。此方法与 pollLast 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 removeLast
返回：
此双端队列的尾部
抛出：
NoSuchElementException - 如果此双端队列为空

pollFirst

public E pollFirst()
从接口 Deque 复制的描述
获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 pollFirst
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

pollLast

public E pollLast()
从接口 Deque 复制的描述
获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 pollLast
返回：
此双端队列的尾部；如果此双端队列为空，则返回 null

getFirst

public E getFirst()
从接口 Deque 复制的描述
获取，但不移除此双端队列的第一个元素。 此方法与 peekFirst 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 getFirst
返回：
此双端队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

getLast

public E getLast()
从接口 Deque 复制的描述
获取，但不移除此双端队列的最后一个元素。此方法与 peekLast 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 getLast
返回：
此双端队列的尾部
抛出：
NoSuchElementException - 如果此双端队列为空

peekFirst

public E peekFirst()
从接口 Deque 复制的描述
获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 peekFirst
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

peekLast

public E peekLast()
从接口 Deque 复制的描述
获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 peekLast
返回：
此双端队列的尾部；如果此双端队列为空，则返回 null

removeFirstOccurrence

public boolean removeFirstOccurrence(Object o)
移除此双端队列中第一次出现的指定元素（当从头部到尾部遍历双端队列时）。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

指定者：
接口 Deque<E> 中的 removeFirstOccurrence
参数：
o - 要从此双端队列中移除的元素（如果存在）
返回：
如果双端队列包含指定元素，则返回 true

removeLastOccurrence

public boolean removeLastOccurrence(Object o)
移除此双端队列中最后一次出现的指定元素（当从头部到尾部遍历双端队列时）。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除最后一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

指定者：
接口 Deque<E> 中的 removeLastOccurrence
参数：
o - 要从此双端队列中移除的元素（如果存在）
返回：
如果双端队列包含指定元素，则返回 true

add

public boolean add(E e)
将指定元素插入此双端队列的末尾。

此方法等效于 addLast(E)。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Deque<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractCollection<E> 中的 add
参数：
e - 要添加的元素
返回：
true （根据 Collection.add(E) 的规定）
抛出：
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e)
将指定元素插入此双端队列的末尾。

此方法等效于 offerLast(E)。

指定者：
接口 Deque<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
true（根据 Queue.offer(E) 的规定）
抛出：
NullPointerException - 如果指定元素为 null

remove

public E remove()
获取并移除此双端队列所表示的队列的头。 此方法与 poll 的不同之处在于：如果此双端队列为空，它将抛出一个异常。

此方法等效于 removeFirst()。

指定者：
接口 Deque<E> 中的 remove
指定者：
接口 Queue<E> 中的 remove
返回：
此双端队列所表示的队列的头
抛出：
NoSuchElementException - 如果此双端队列为空

poll

public E poll()
获取并移除此双端队列所表示的队列的头（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。

此方法等效于 pollFirst()。

指定者：
接口 Deque<E> 中的 poll
指定者：
接口 Queue<E> 中的 poll
返回：
此双端队列所表示的队列的头；如果此双端队列为空，则返回 null

element

public E element()
获取，但不移除此双端队列所表示的队列的头。此方法与 peek 的不同之处在于：如果此双端队列为空，它将抛出一个异常。

此方法等效于 getFirst()。

指定者：
接口 Deque<E> 中的 element
指定者：
接口 Queue<E> 中的 element
返回：
此双端队列所表示的队列的头
抛出：
NoSuchElementException - 如果此双端队列为空

peek

public E peek()
获取，但不移除此双端队列所表示的队列的头；如果此双端队列为空，则返回 null。

此方法等效于 peekFirst()。

指定者：
接口 Deque<E> 中的 peek
指定者：
接口 Queue<E> 中的 peek
返回：
此双端队列所表示的队列的头；如果此双端队列为空，则返回 null

push

public void push(E e)
将元素推入此双端队列所表示的堆栈。换句话说，将元素插入此双端队列的开头。

此方法等效于 addFirst(E)。

指定者：
接口 Deque<E> 中的 push
参数：
e - 要推入的元素
抛出：
NullPointerException - 如果指定元素为 null

pop

public E pop()
从此双端队列所表示的堆栈中弹出一个元素。换句话说，移除并返回此双端队列第一个元素。

此方法等效于 removeFirst()。

指定者：
接口 Deque<E> 中的 pop
返回：
此双端队列开头的元素（它是此双端队列所表示的堆栈的顶部）
抛出：
NoSuchElementException - 如果此双端队列为空

size

public int size()
返回此双端队列中的元素数。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 Deque<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此双端队列中的元素数

isEmpty

public boolean isEmpty()
如果此双端队列未包含任何元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
如果此双端队列未包含任何元素，则返回 true

iterator

public Iterator<E> iterator()
返回在此双端队列的元素上进行迭代的迭代器。元素将按从第一个（头）到最后一个（尾）的顺序进行排序。这与元素出列（通过连续调用 remove()）或弹出（通过连续调用 pop()）的顺序相同。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Deque<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此双端队列的元素上进行迭代的迭代器

descendingIterator

public Iterator<E> descendingIterator()
从接口 Deque 复制的描述
返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。元素将按从最后一个（尾部）到第一个（头部）的顺序返回。

指定者：
接口 Deque<E> 中的 descendingIterator
返回：
以逆向顺序在此双端队列中的元素上进行迭代的迭代器

contains

public boolean contains(Object o)
如果此双端队列包含指定元素，则返回 true。更确切地讲，当且仅当此双端队列至少包含一个满足 o.equals(e) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 Deque<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 检查是否包含于此双端队列的对象
返回：
如果此双端队列包含指定的元素，则返回 true。

remove

public boolean remove(Object o)
从此双端队列中移除指定元素的单个实例。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

此方法等效于 removeFirstOccurrence(java.lang.Object)。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 Deque<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此双端队列中移除的元素（如果存在）
返回：
如果此双端队列包含指定元素，则返回 true

clear

public void clear()
从此双端队列中移除所有元素。在此调用返回之后，该双端队列将为空。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractCollection<E> 中的 clear

toArray

public Object[] toArray()
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）。

由于此双端队列不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新的数组）。因此，调用者可以自由地修改返回的数组。

此方法充当了基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此双端队列中所有元素的数组。

toArray

public <T> T[] toArray(T[] a)
返回一个以恰当顺序包含此双端队列所有元素的数组（从第一个元素到最后一个元素）；返回数组的运行时类型是指定数组的运行时类型。如果指定的数组能容纳双端队列，则将它返回此处。否则，将分配一个具有指定数组的运行时类型和此双端队列大小的新数组。

如果指定的数组能容纳此双端队列，并有剩余的空间（即数组的元素比此双端队列多），那么将数组中紧接双端队列尾部的元素设置为 null。

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，还可以用来节省分配开销。

假定 x 是只包含字符串的一个已知双端队列。以下代码可用来将该双端队列转储到一个新分配的 String 数组：

String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 要用来存储双端队列元素的数组（如果该数组足够大）；否则，将为此分配一个具有相同运行时类型的新数组
返回：
包含此双端队列所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此双端队列每个元素的运行时类型的超类型
NullPointerException - 如果指定的数组为 null

clone

public ArrayDeque<E> clone()
返回此双端队列的副本。

覆盖：
类 Object 中的 clone
返回：
此双端队列的副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ArrayList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ArrayList<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.ArrayList<E>
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, List<E>, RandomAccess
直接已知子类：
AttributeList, RoleList, RoleUnresolvedList
public class ArrayList<E>
extends AbstractList<E>
implements List<E>, RandomAccess, Cloneable, Serializable

List 接口的大小可变数组的实现。实现了所有可选列表操作，并允许包括 null 在内的所有元素。除了实现 List 接口外，此类还提供一些方法来操作内部用来存储列表的数组的大小。（此类大致上等同于 Vector 类，除了此类是不同步的。）

size、isEmpty、get、set、iterator 和 listIterator 操作都以固定时间运行。add 操作以分摊的固定时间 运行，也就是说，添加 n 个元素需要 O(n) 时间。其他所有操作都以线性时间运行（大体上讲）。与用于 LinkedList 实现的常数因子相比，此实现的常数因子较低。

每个 ArrayList 实例都有一个容量。该容量是指用来存储列表元素的数组的大小。它总是至少等于列表的大小。随着向 ArrayList 中不断添加元素，其容量也自动增长。并未指定增长策略的细节，因为这不只是添加元素会带来分摊固定时间开销那样简单。

在添加大量元素前，应用程序可以使用 ensureCapacity 操作来增加 ArrayList 实例的容量。这可以减少递增式再分配的数量。

注意，此实现不是同步的。如果多个线程同时访问一个 ArrayList 实例，而其中至少一个线程从结构上修改了列表，那么它必须 保持外部同步。（结构上的修改是指任何添加或删除一个或多个元素的操作，或者显式调整底层数组的大小；仅仅设置元素的值不是结构上的修改。）这一般通过对自然封装该列表的对象进行同步操作来完成。如果不存在这样的对象，则应该使用 Collections.synchronizedList 方法将该列表“包装”起来。这最好在创建时完成，以防止意外对列表进行不同步的访问：

        List list = Collections.synchronizedList(new ArrayList(...));

此类的 iterator 和 listIterator 方法返回的迭代器是快速失败的：在创建迭代器之后，除非通过迭代器自身的 remove 或 add 方法从结构上对列表进行修改，否则在任何时间以任何方式对列表进行修改，迭代器都会抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不是冒着在将来某个不确定时间发生任意不确定行为的风险。

注意，迭代器的快速失败行为无法得到保证，因为一般来说，不可能对是否出现不同步并发修改做出任何硬性保证。快速失败迭代器会尽最大努力抛出 ConcurrentModificationException。因此，为提高这类迭代器的正确性而编写一个依赖于此异常的程序是错误的做法：迭代器的快速失败行为应该仅用于检测 bug。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, List, LinkedList, Vector, Collections.synchronizedList(List), 序列化表格

字段摘要
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
ArrayList()
构造一个初始容量为 10 的空列表。
ArrayList(Collection<? extends E> c)
构造一个包含指定 collection 的元素的列表，这些元素是按照该 collection 的迭代器返回它们的顺序排列的。
ArrayList(int initialCapacity)
构造一个具有指定初始容量的空列表。
方法摘要
 boolean add(E e)
将指定的元素添加到此列表的尾部。
 void add(int index, E element)
将指定的元素插入此列表中的指定位置。
 boolean addAll(Collection<? extends E> c)
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
 boolean addAll(int index, Collection<? extends E> c)
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
 void clear()
移除此列表中的所有元素。
 Object clone()
返回此 ArrayList 实例的浅表副本。
 boolean contains(Object o)
如果此列表中包含指定的元素，则返回 true。
 void ensureCapacity(int minCapacity)
如有必要，增加此 ArrayList 实例的容量，以确保它至少能够容纳最小容量参数所指定的元素数。
 E get(int index)
返回此列表中指定位置上的元素。
 int indexOf(Object o)
返回此列表中首次出现的指定元素的索引，或如果此列表不包含元素，则返回 -1。
 boolean isEmpty()
如果此列表中没有元素，则返回 true
 int lastIndexOf(Object o)
返回此列表中最后一次出现的指定元素的索引，或如果此列表不包含索引，则返回 -1。
 E remove(int index)
移除此列表中指定位置上的元素。
 boolean remove(Object o)
移除此列表中首次出现的指定元素（如果存在）。
protected  void removeRange(int fromIndex, int toIndex)
移除列表中索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。
 E set(int index, E element)
用指定的元素替代此列表中指定位置上的元素。
 int size()
返回此列表中的元素数。
 Object[] toArray()
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组。
<T> T[]
toArray(T[] a)
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
 void trimToSize()
将此 ArrayList 实例的容量调整为列表的当前大小。
从类 java.util.AbstractList 继承的方法
equals, hashCode, iterator, listIterator, listIterator, subList
从类 java.util.AbstractCollection 继承的方法
containsAll, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

构造方法详细信息

ArrayList

public ArrayList(int initialCapacity)
构造一个具有指定初始容量的空列表。

参数：
initialCapacity - 列表的初始容量
抛出：
IllegalArgumentException - 如果指定的初始容量为负

ArrayList

public ArrayList()
构造一个初始容量为 10 的空列表。

ArrayList

public ArrayList(Collection<? extends E> c)
构造一个包含指定 collection 的元素的列表，这些元素是按照该 collection 的迭代器返回它们的顺序排列的。

参数：
c - 其元素将放置在此列表中的 collection
抛出：
NullPointerException - 如果指定的 collection 为 null
方法详细信息

trimToSize

public void trimToSize()
将此 ArrayList 实例的容量调整为列表的当前大小。应用程序可以使用此操作来最小化 ArrayList 实例的存储量。

ensureCapacity

public void ensureCapacity(int minCapacity)
如有必要，增加此 ArrayList 实例的容量，以确保它至少能够容纳最小容量参数所指定的元素数。

参数：
minCapacity - 所需的最小容量

size

public int size()
返回此列表中的元素数。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 List<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此列表中的元素数

isEmpty

public boolean isEmpty()
如果此列表中没有元素，则返回 true

指定者：
接口 Collection<E> 中的 isEmpty
指定者：
接口 List<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
如果此列表中没有元素，则返回 true

contains

public boolean contains(Object o)
如果此列表中包含指定的元素，则返回 true。更确切地讲，当且仅当此列表包含至少一个满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，则返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 List<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 测试此列表中是否存在的元素
返回：
如果此列表包含特定的元素，则返回 true

indexOf

public int indexOf(Object o)
返回此列表中首次出现的指定元素的索引，或如果此列表不包含元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i ，如果不存在此类索引，则返回 -1。

指定者：
接口 List<E> 中的 indexOf
覆盖：
类 AbstractList<E> 中的 indexOf
参数：
o - 要搜索的元素
返回：
此列表中第一次出现的指定元素的索引，如果列表不包含该元素，则返回 -1

lastIndexOf

public int lastIndexOf(Object o)
返回此列表中最后一次出现的指定元素的索引，或如果此列表不包含索引，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最高索引 i，如果不存在此类索引，则返回 -1。

指定者：
接口 List<E> 中的 lastIndexOf
覆盖：
类 AbstractList<E> 中的 lastIndexOf
参数：
o - 要搜索的元素
返回：
列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1

clone

public Object clone()
返回此 ArrayList 实例的浅表副本。（不复制这些元素本身。）

覆盖：
类 Object 中的 clone
返回：
此 ArrayList 实例的一个副本
另请参见：
Cloneable

toArray

public Object[] toArray()
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组。

由于此列表不维护对返回数组的任何引用，，因而它将是“安全的”。（换句话说，此方法必须分配一个新的数组）。因此，调用者可以自由地修改返回的数组。

此方法担当基于数组的 API 和基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此列表中所有元素的数组（按适当顺序）
另请参见：
Arrays.asList(Object[])

toArray

public <T> T[] toArray(T[] a)
按适当顺序（从第一个到最后一个元素）返回包含此列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。如果指定的数组能容纳列表，则将该列表返回此处。否则，将分配一个具有指定数组的运行时类型和此列表大小的新数组。

如果指定的数组能容纳队列，并有剩余的空间（即数组的元素比队列多），那么会将数组中紧接 collection 尾部的元素设置为 null。（仅 在调用者知道列表中不包含任何 null 元素时才能用此方法确定列表长度）。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 要在其中存储列表元素的数组（如果它足够大）；否则，为此分配一个具有相同运行时类型的新数组。
返回：
包含列表元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此列表每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

get

public E get(int index)
返回此列表中指定位置上的元素。

指定者：
接口 List<E> 中的 get
指定者：
类 AbstractList<E> 中的 get
参数：
index - 要返回元素的索引
返回：
此列表中指定位置上的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

set

public E set(int index,
             E element)
用指定的元素替代此列表中指定位置上的元素。

指定者：
接口 List<E> 中的 set
覆盖：
类 AbstractList<E> 中的 set
参数：
index - 要替代的元素的索引
element - 存储在指定位置上的元素
返回：
以前位于该指定位置上的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

add

public boolean add(E e)
将指定的元素添加到此列表的尾部。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 List<E> 中的 add
覆盖：
类 AbstractList<E> 中的 add
参数：
e - 要添加到此列表中的元素
返回：
true（按照 Collection.add(E) 的指定）

add

public void add(int index,
                E element)
将指定的元素插入此列表中的指定位置。向右移动当前位于该位置的元素（如果有）以及所有后续元素（将其索引加 1）。

指定者：
接口 List<E> 中的 add
覆盖：
类 AbstractList<E> 中的 add
参数：
index - 指定元素所插入位置的索引
element - 要插入的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

remove

public E remove(int index)
移除此列表中指定位置上的元素。向左移动所有后续元素（将其索引减 1）。

指定者：
接口 List<E> 中的 remove
覆盖：
类 AbstractList<E> 中的 remove
参数：
index - 要移除的元素的索引
返回：
从列表中移除的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

remove

public boolean remove(Object o)
移除此列表中首次出现的指定元素（如果存在）。如果列表不包含此元素，则列表不做改动。更确切地讲，移除满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引的元素（如果存在此类元素）。如果列表中包含指定的元素，则返回 true（或者等同于这种情况：如果列表由于调用而发生更改，则返回 true）。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 List<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此列表中移除的元素（如果存在）
返回：
如果此列表包含指定的元素，则返回 true

clear

public void clear()
移除此列表中的所有元素。此调用返回后，列表将为空。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 List<E> 中的 clear
覆盖：
类 AbstractList<E> 中的 clear

addAll

public boolean addAll(Collection<? extends E> c)
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。如果正在进行此操作时修改指定的 collection ，那么此操作的行为是不确定的。（这意味着如果指定的 collection 是此列表且此列表是非空的，那么此调用的行为是不确定的）。

指定者：
接口 Collection<E> 中的 addAll
指定者：
接口 List<E> 中的 addAll
覆盖：
类 AbstractCollection<E> 中的 addAll
参数：
c - 包含要添加到此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
NullPointerException - 如果指定的 collection 为 null
另请参见：
AbstractCollection.add(Object)

addAll

public boolean addAll(int index,
                      Collection<? extends E> c)
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。向右移动当前位于该位置的元素（如果有）以及所有后续元素（增加其索引）。新元素将按照指定 collection 的迭代器所返回的元素顺序出现在列表中。

指定者：
接口 List<E> 中的 addAll
覆盖：
类 AbstractList<E> 中的 addAll
参数：
index - 插入指定 collection 中的首个元素的位置索引
c - 包含要添加到此列表中元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())
NullPointerException - 如果指定的 collection 为 null

removeRange

protected void removeRange(int fromIndex,
                           int toIndex)
移除列表中索引在 fromIndex（包括）和 toIndex（不包括）之间的所有元素。向左移动所有后续元素（减小其索引）。此调用将列表缩短了 (toIndex - fromIndex) 个元素。（如果 toIndex==fromIndex，则此操作无效。）

覆盖：
类 AbstractList<E> 中的 removeRange
参数：
fromIndex - 要移除的首个元素的索引
toIndex - 最后一个要移除的元素后面那个元素的索引
抛出：
IndexOutOfBoundsException - 如果 fromIndex 或 toIndex 超出范围 (fromIndex < 0 || fromIndex >= size() || toIndex > size() || toIndex < fromIndex)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Arrays (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Arrays

java.lang.Object
    继承者  java.util.Arrays

public class Arrays
extends Object

此类包含用来操作数组（比如排序和搜索）的各种方法。此类还包含一个允许将数组作为列表来查看的静态工厂。

除非特别注明，否则如果指定数组引用为 null，则此类中的方法都会抛出 NullPointerException。

此类中所含方法的文档都包括对实现 的简短描述。应该将这些描述视为实现注意事项，而不应将它们视为规范 的一部分。实现者应该可以随意替代其他算法，只要遵循规范本身即可。（例如，sort(Object[]) 使用的算法不必是一个合并排序算法，但它必须是稳定的。）

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2

方法摘要
static
<T> List<T>
asList(T... a)
返回一个受指定数组支持的固定大小的列表。
static int binarySearch(byte[] a, byte key)
使用二分搜索法来搜索指定的 byte 型数组，以获得指定的值。
static int binarySearch(byte[] a, int fromIndex, int toIndex, byte key)
使用二分搜索法来搜索指定的 byte 型数组的范围，以获得指定的值。
static int binarySearch(char[] a, char key)
使用二分搜索法来搜索指定的 char 型数组，以获得指定的值。
static int binarySearch(char[] a, int fromIndex, int toIndex, char key)
使用二分搜索法来搜索指定的 char 型数组的范围，以获得指定的值。
static int binarySearch(double[] a, double key)
使用二分搜索法来搜索指定的 double 型数组，以获得指定的值。
static int binarySearch(double[] a, int fromIndex, int toIndex, double key)
使用二分搜索法来搜索指定的 double 型数组的范围，以获得指定的值。
static int binarySearch(float[] a, float key)
使用二分搜索法来搜索指定的 float 型数组，以获得指定的值。
static int binarySearch(float[] a, int fromIndex, int toIndex, float key)
使用二分搜索法来搜索指定的 float 型数组的范围，以获得指定的值。
static int binarySearch(int[] a, int key)
使用二分搜索法来搜索指定的 int 型数组，以获得指定的值。
static int binarySearch(int[] a, int fromIndex, int toIndex, int key)
使用二分搜索法来搜索指定的 int 型数组的范围，以获得指定的值。
static int binarySearch(long[] a, int fromIndex, int toIndex, long key)
使用二分搜索法来搜索指定的 long 型数组的范围，以获得指定的值。
static int binarySearch(long[] a, long key)
使用二分搜索法来搜索指定的 long 型数组，以获得指定的值。
static int binarySearch(Object[] a, int fromIndex, int toIndex, Object key)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
static int binarySearch(Object[] a, Object key)
使用二分搜索法来搜索指定数组，以获得指定对象。
static int binarySearch(short[] a, int fromIndex, int toIndex, short key)
使用二分搜索法来搜索指定的 short 型数组的范围，以获得指定的值。
static int binarySearch(short[] a, short key)
使用二分搜索法来搜索指定的 short 型数组，以获得指定的值。
static
<T> int
binarySearch(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
static
<T> int
binarySearch(T[] a, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组，以获得指定对象。
static boolean[] copyOf(boolean[] original, int newLength)
复制指定的数组，截取或用 false 填充（如有必要），以使副本具有指定的长度。
static byte[] copyOf(byte[] original, int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
static char[] copyOf(char[] original, int newLength)
复制指定的数组，截取或用 null 字符填充（如有必要），以使副本具有指定的长度。
static double[] copyOf(double[] original, int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
static float[] copyOf(float[] original, int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
static int[] copyOf(int[] original, int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
static long[] copyOf(long[] original, int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
static short[] copyOf(short[] original, int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。
static
<T> T[]
copyOf(T[] original, int newLength)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
static
<T,U> T[]
copyOf(U[] original, int newLength, Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。
static boolean[] copyOfRange(boolean[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static byte[] copyOfRange(byte[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static char[] copyOfRange(char[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static double[] copyOfRange(double[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static float[] copyOfRange(float[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static int[] copyOfRange(int[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static long[] copyOfRange(long[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static short[] copyOfRange(short[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static
<T> T[]
copyOfRange(T[] original, int from, int to)
将指定数组的指定范围复制到一个新数组。
static
<T,U> T[]
copyOfRange(U[] original, int from, int to, Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。
static boolean deepEquals(Object[] a1, Object[] a2)
如果两个指定数组彼此是深层相等 的，则返回 true。
static int deepHashCode(Object[] a)
基于指定数组的“深层内容”返回哈希码。
static String deepToString(Object[] a)
返回指定数组“深层内容”的字符串表示形式。
static boolean equals(boolean[] a, boolean[] a2)
如果两个指定的 boolean 型数组彼此相等，则返回 true。
static boolean equals(byte[] a, byte[] a2)
如果两个指定的 byte 型数组彼此相等，则返回 true。
static boolean equals(char[] a, char[] a2)
如果两个指定的 char 型数组彼此相等，则返回 true。
static boolean equals(double[] a, double[] a2)
如果两个指定的 double 型数组彼此相等，则返回 true。
static boolean equals(float[] a, float[] a2)
如果两个指定的 float 型数组彼此相等，则返回 true。
static boolean equals(int[] a, int[] a2)
如果两个指定的 int 型数组彼此相等，则返回 true。
static boolean equals(long[] a, long[] a2)
如果两个指定的 long 型数组彼此相等，则返回 true。
static boolean equals(Object[] a, Object[] a2)
如果两个指定的 Objects 数组彼此相等，则返回 true。
static boolean equals(short[] a, short[] a2)
如果两个指定的 short 型数组彼此相等，则返回 true。
static void fill(boolean[] a, boolean val)
将指定的 boolean 值分配给指定 boolean 型数组的每个元素。
static void fill(boolean[] a, int fromIndex, int toIndex, boolean val)
将指定的 boolean 值分配给指定 boolean 型数组指定范围中的每个元素。
static void fill(byte[] a, byte val)
将指定的 byte 值分配给指定 byte 节型数组的每个元素。
static void fill(byte[] a, int fromIndex, int toIndex, byte val)
将指定的 byte 值分配给指定 byte 型数组指定范围中的每个元素。
static void fill(char[] a, char val)
将指定的 char 值分配给指定 char 型数组的每个元素。
static void fill(char[] a, int fromIndex, int toIndex, char val)
将指定的 char 值分配给指定 char 型数组指定范围中的每个元素。
static void fill(double[] a, double val)
将指定的 double 值分配给指定 double 型数组的每个元素。
static void fill(double[] a, int fromIndex, int toIndex, double val)
将指定的 double 值分配给指定 double 型数组指定范围中的每个元素。
static void fill(float[] a, float val)
将指定的 float 值分配给指定 float 型数组的每个元素。
static void fill(float[] a, int fromIndex, int toIndex, float val)
将指定的 float 值分配给指定 float 型数组指定范围中的每个元素。
static void fill(int[] a, int val)
将指定的 int 值分配给指定 int 型数组的每个元素。
static void fill(int[] a, int fromIndex, int toIndex, int val)
将指定的 int 值分配给指定 int 型数组指定范围中的每个元素。
static void fill(long[] a, int fromIndex, int toIndex, long val)
将指定的 long 值分配给指定 long 型数组指定范围中的每个元素。
static void fill(long[] a, long val)
将指定的 long 值分配给指定 long 型数组的每个元素。
static void fill(Object[] a, int fromIndex, int toIndex, Object val)
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。
static void fill(Object[] a, Object val)
将指定的 Object 引用分配给指定 Object 数组的每个元素。
static void fill(short[] a, int fromIndex, int toIndex, short val)
将指定的 short 值分配给指定 short 型数组指定范围中的每个元素。
static void fill(short[] a, short val)
将指定的 short 值分配给指定 short 型数组的每个元素。
static int hashCode(boolean[] a)
基于指定数组的内容返回哈希码。
static int hashCode(byte[] a)
基于指定数组的内容返回哈希码。
static int hashCode(char[] a)
基于指定数组的内容返回哈希码。
static int hashCode(double[] a)
基于指定数组的内容返回哈希码。
static int hashCode(float[] a)
基于指定数组的内容返回哈希码。
static int hashCode(int[] a)
基于指定数组的内容返回哈希码。
static int hashCode(long[] a)
基于指定数组的内容返回哈希码。
static int hashCode(Object[] a)
基于指定数组的内容返回哈希码。
static int hashCode(short[] a)
基于指定数组的内容返回哈希码。
static void sort(byte[] a)
对指定的 byte 型数组按数字升序进行排序。
static void sort(byte[] a, int fromIndex, int toIndex)
对指定 byte 型数组的指定范围按数字升序进行排序。
static void sort(char[] a)
对指定的 char 型数组按数字升序进行排序。
static void sort(char[] a, int fromIndex, int toIndex)
对指定 char 型数组的指定范围按数字升序进行排序。
static void sort(double[] a)
对指定的 double 型数组按数字升序进行排序。
static void sort(double[] a, int fromIndex, int toIndex)
对指定 double 型数组的指定范围按数字升序进行排序。
static void sort(float[] a)
对指定的 float 型数组按数字升序进行排序。
static void sort(float[] a, int fromIndex, int toIndex)
对指定 float 型数组的指定范围按数字升序进行排序。
static void sort(int[] a)
对指定的 int 型数组按数字升序进行排序。
static void sort(int[] a, int fromIndex, int toIndex)
对指定 int 型数组的指定范围按数字升序进行排序。
static void sort(long[] a)
对指定的 long 型数组按数字升序进行排序。
static void sort(long[] a, int fromIndex, int toIndex)
对指定 long 型数组的指定范围按数字升序进行排序。
static void sort(Object[] a)
根据元素的自然顺序对指定对象数组按升序进行排序。
static void sort(Object[] a, int fromIndex, int toIndex)
根据元素的自然顺序对指定对象数组的指定范围按升序进行排序。
static void sort(short[] a)
对指定的 short 型数组按数字升序进行排序。
static void sort(short[] a, int fromIndex, int toIndex)
对指定 short 型数组的指定范围按数字升序进行排序。
static
<T> void
sort(T[] a, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组进行排序。
static
<T> void
sort(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。
static String toString(boolean[] a)
返回指定数组内容的字符串表示形式。
static String toString(byte[] a)
返回指定数组内容的字符串表示形式。
static String toString(char[] a)
返回指定数组内容的字符串表示形式。
static String toString(double[] a)
返回指定数组内容的字符串表示形式。
static String toString(float[] a)
返回指定数组内容的字符串表示形式。
static String toString(int[] a)
返回指定数组内容的字符串表示形式。
static String toString(long[] a)
返回指定数组内容的字符串表示形式。
static String toString(Object[] a)
返回指定数组内容的字符串表示形式。
static String toString(short[] a)
返回指定数组内容的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

sort

public static void sort(long[] a)
对指定的 long 型数组按数字升序进行排序。该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组

sort

public static void sort(long[] a,
                        int fromIndex,
                        int toIndex)
对指定 long 型数组的指定范围按数字升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

sort

public static void sort(int[] a)
对指定的 int 型数组按数字升序进行排序。该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组

sort

public static void sort(int[] a,
                        int fromIndex,
                        int toIndex)
对指定 int 型数组的指定范围按数字升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

sort

public static void sort(short[] a)
对指定的 short 型数组按数字升序进行排序。该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组

sort

public static void sort(short[] a,
                        int fromIndex,
                        int toIndex)
对指定 short 型数组的指定范围按数字升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

sort

public static void sort(char[] a)
对指定的 char 型数组按数字升序进行排序。该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组

sort

public static void sort(char[] a,
                        int fromIndex,
                        int toIndex)
对指定 char 型数组的指定范围按数字升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

sort

public static void sort(byte[] a)
对指定的 byte 型数组按数字升序进行排序。该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组

sort

public static void sort(byte[] a,
                        int fromIndex,
                        int toIndex)
对指定 byte 型数组的指定范围按数字升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

sort

public static void sort(double[] a)
对指定的 double 型数组按数字升序进行排序。

虽然 < 关系式对不同数字 -0.0 == 0.0 返回的结果为 true，并且认为 NaN 值既不小于或大于任何浮点值，也不等于任何浮点值，甚至不等于它自身。但 < 关系式不能提供所有浮点值的整体排序。为了允许进行排序，此方法不使用 < 关系式来确定数字升序排序，而是利用 Double.compareTo(java.lang.Double) 来完成整体排序。此排序法不同于 < 关系式，其中 -0.0 被认为是小于 0.0 的值，并且 NaN 被认为大于其他任何浮点值。为了进行排序，所有 NaN 值都被认为是等效且相等的。

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组

sort

public static void sort(double[] a,
                        int fromIndex,
                        int toIndex)
对指定 double 型数组的指定范围按数字升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）

虽然 < 关系式对不同数字 -0.0 == 0.0 返回的结果为 true，并且认为 NaN 值既不小于或大于任何浮点值，也不等于任何浮点值，甚至不等于它自身。但 < 关系式不能提供所有浮点值的整体排序。为了允许进行排序，此方法不使用 < 关系式来确定数字升序排序，而是利用 Double.compareTo(java.lang.Double) 来完成整体排序。此排序法不同于 < 关系式，其中 -0.0 被认为是小于 0.0 的值，并且 NaN 被认为大于其他任何浮点值。为了进行排序，所有 NaN 值都被认为是等效且相等的。

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

sort

public static void sort(float[] a)
对指定的 float 型数组按数字升序进行排序。

虽然 < 关系式对不同数字 -0.0f == 0.0f 返回的结果为 true，并且认为 NaN 值既不小于或大于任何浮点值，也不等于任何浮点值，甚至不等于它自身。但 < 关系式不能提供所有浮点值的整体排序。为了允许进行排序，此方法不使用 < 关系式来确定数字升序排序，而是利用 Float.compareTo(java.lang.Float) 来完成整体排序。此排序法不同于 < 关系式，其中 -0.0f 被认为是小于 0.0f 的值，并且 NaN 被认为大于其他任何浮点值。为了进行排序，所有 NaN 值都被认为是等效且相等的。

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组

sort

public static void sort(float[] a,
                        int fromIndex,
                        int toIndex)
对指定 float 型数组的指定范围按数字升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）

虽然 < 关系式对不同数字 -0.0f == 0.0f 返回的结果为 true，并且认为 NaN 值既不小于或大于任何浮点值，也不等于任何浮点值，甚至不等于它自身。但 < 关系式不能提供所有浮点值的整体排序。为了允许进行排序，此方法不使用 < 关系式来确定数字升序排序，而是利用 Float.compareTo(java.lang.Float) 来完成整体排序。此排序法不同于 < 关系式，其中 -0.0f 被认为是小于 0.0f 的值，并且 NaN 被认为大于其他任何浮点值。为了进行排序，所有 NaN 值都被认为是等效且相等的。

该排序算法是一个经过调优的快速排序法，改编自 Jon L. Bentley 和 M. Douglas McIlroy 合著的 Engineering a Sort Function", Software-Practice and Experience Vol. 23(11) P. 1249-1265 (November 1993)。此算法在许多数据集上提供 n*log(n) 性能，这导致其他快速排序会降低二次型性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

sort

public static void sort(Object[] a)
根据元素的自然顺序对指定对象数组按升序进行排序。数组中的所有元素都必须实现 Comparable 接口。此外，数组中的所有元素都必须是可相互比较的（也就是说，对于数组中的任何 e1 和 e2 元素而言，e1.compareTo(e2) 不得抛出 ClassCastException）。

保证此排序是稳定的：不会因调用 sort 方法而对相等的元素进行重新排序。

该排序算法是一个经过修改的合并排序算法（其中，如果低子列表中的最高元素小于高子列表中的最低元素，则忽略合并）。此算法提供可保证的 n*log(n) 性能。

参数：
a - 要排序的数组
抛出：
ClassCastException - 如果数组包含不可相互比较的 的元素（例如，字符串和整数）。

sort

public static void sort(Object[] a,
                        int fromIndex,
                        int toIndex)
根据元素的自然顺序对指定对象数组的指定范围按升序进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）此范围中的所有元素都必须实现 Comparable 接口。此外，此范围中的所有元素都必须是可相互比较的（也就是说，对于数组中的任何 e1 和 e2 元素而言，e1.compareTo(e2) 不得抛出 ClassCastException）。

保证此排序是稳定的：不会因调用 sort 方法而对相等的元素进行重新排序。

该排序算法是一个经过修改的合并排序算法（其中，如果低子列表中的最高元素小于高子列表中的最低元素，则忽略合并）。此算法提供可保证的 n*log(n) 性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
ClassCastException - 如果数组包含不可相互比较的 的元素（例如，字符串和整数）。

sort

public static <T> void sort(T[] a,
                            Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组进行排序。数组中的所有元素都必须是通过指定比较器可相互比较的（也就是说，对于数组中的任何 e1 和 e2 元素而言，c.compare(e1, e2) 不得抛出 ClassCastException）。

保证此排序是稳定的：不会因调用 sort 方法而对相等的元素进行重新排序。

该排序算法是一个经过修改的合并排序算法（其中，如果低子列表中的最高元素小于高子列表中的最低元素，则忽略合并）。此算法提供可保证的 n*log(n) 性能。

参数：
a - 要排序的数组
c - 确定数组顺序的比较器。null 值指示应该使用元素的自然顺序。
抛出：
ClassCastException - 如果数组包含使用指定的比较器不可相互比较的 的元素。

sort

public static <T> void sort(T[] a,
                            int fromIndex,
                            int toIndex,
                            Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。排序的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则排序范围为空。）此范围内的所有元素都必须是通过指定比较器可相互比较的（也就是说，对于该范围中的任何 e1 和 e2 元素而言，c.compare(e1, e2) 不得抛出 ClassCastException）。

保证此排序是稳定的：不会因调用 sort 方法而对相等的元素进行重新排序。

该排序算法是一个经过修改的合并排序算法（其中，如果低子列表中的最高元素小于高子列表中的最低元素，则忽略合并）。此算法提供可保证的 n*log(n) 性能。

参数：
a - 要排序的数组
fromIndex - 要排序的第一个元素的索引（包括）
toIndex - 要排序的最后一个元素的索引（不包括）
c - 确定数组顺序的比较器。null 值指示应该使用元素的自然顺序。
抛出：
ClassCastException - 如果数组包含使用指定的比较器不可相互比较的 的元素。
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

binarySearch

public static int binarySearch(long[] a,
                               long key)
使用二分搜索法来搜索指定的 long 型数组，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(long[]) 方法）。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。

binarySearch

public static int binarySearch(long[] a,
                               int fromIndex,
                               int toIndex,
                               long key)
使用二分搜索法来搜索指定的 long 型数组的范围，以获得指定的值。必须在进行此调用之前对范围进行排序（通过 sort(long[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static int binarySearch(int[] a,
                               int key)
使用二分搜索法来搜索指定的 int 型数组，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(int[]) 方法）。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。

binarySearch

public static int binarySearch(int[] a,
                               int fromIndex,
                               int toIndex,
                               int key)
使用二分搜索法来搜索指定的 int 型数组的范围，以获得指定的值。必须在进行此调用之前对范围进行排序（通过 sort(int[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static int binarySearch(short[] a,
                               short key)
使用二分搜索法来搜索指定的 short 型数组，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(short[]) 方法）。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。

binarySearch

public static int binarySearch(short[] a,
                               int fromIndex,
                               int toIndex,
                               short key)
使用二分搜索法来搜索指定的 short 型数组的范围，以获得指定的值。必须在进行此调用之前对范围进行排序（通过 sort(short[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static int binarySearch(char[] a,
                               char key)
使用二分搜索法来搜索指定的 char 型数组，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(char[]) 方法）。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。

binarySearch

public static int binarySearch(char[] a,
                               int fromIndex,
                               int toIndex,
                               char key)
使用二分搜索法来搜索指定的 char 型数组的范围，以获得指定的值。必须在进行此调用之前对范围进行排序（通过 sort(char[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static int binarySearch(byte[] a,
                               byte key)
使用二分搜索法来搜索指定的 byte 型数组，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(byte[]) 方法）。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。

binarySearch

public static int binarySearch(byte[] a,
                               int fromIndex,
                               int toIndex,
                               byte key)
使用二分搜索法来搜索指定的 byte 型数组的范围，以获得指定的值。必须在进行此调用之前对范围进行排序（通过 sort(byte[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个带有指定值的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static int binarySearch(double[] a,
                               double key)
使用二分搜索法来搜索指定的 double 型数组，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(double[]) 方法）。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个带有指定值的元素，则无法保证找到的是哪一个。此方法认为所有 NaN 值都是等效且相等的。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。

binarySearch

public static int binarySearch(double[] a,
                               int fromIndex,
                               int toIndex,
                               double key)
使用二分搜索法来搜索指定的 double 型数组的范围，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(double[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个带有指定值的元素，则无法保证找到的是哪一个。此方法认为所有 NaN 值都是等效且相等的。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static int binarySearch(float[] a,
                               float key)
使用二分搜索法来搜索指定的 float 型数组，以获得指定的值。必须在进行此调用之前对数组进行排序（通过 sort(float[]) 方法）。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个带有指定值的元素，则无法保证找到的是哪一个。此方法认为所有 NaN 值都是等效且相等的。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。

binarySearch

public static int binarySearch(float[] a,
                               int fromIndex,
                               int toIndex,
                               float key)
使用二分搜索法来搜索指定的 float 型数组的范围，以获得指定的值。必须在进行此调用之前对范围进行排序（通过 sort(float[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个带有指定值的元素，则无法保证找到的是哪一个。此方法认为所有 NaN 值都是等效且相等的。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static int binarySearch(Object[] a,
                               Object key)
使用二分搜索法来搜索指定数组，以获得指定对象。在进行此调用之前，必须根据元素的自然顺序对数组进行升序排序（通过 sort(Object[]) 方法）。如果没有对数组进行排序，则结果是不确定的。（如果数组包含不可相互比较的元素（例如，字符串和整数），则无法 根据其元素的自然顺序对数组进行排序，因此结果是不确定的。）如果数组包含多个等于指定对象的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
key - 要搜索的值
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
ClassCastException - 如果搜索的键不能与数组的元素进行比较。

binarySearch

public static int binarySearch(Object[] a,
                               int fromIndex,
                               int toIndex,
                               Object key)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。在进行此调用之前，必须根据元素的自然顺序对范围进行升序排序（通过 sort(Object[], int, int) 方法）。如果没有对范围进行排序，则结果是不确定的。（如果范围包含不可相互比较的元素，例如，字符串和整数，则无法 根据其元素的自然顺序对范围进行排序，因此结果是不确定的。）如果范围包含多个等于指定对象的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
ClassCastException - 如果搜索的键不能与数组的指定范围内的元素进行比较。
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

binarySearch

public static <T> int binarySearch(T[] a,
                                   T key,
                                   Comparator<? super T> c)
使用二分搜索法来搜索指定数组，以获得指定对象。在进行此调用之前，必须根据指定的比较器（通过 sort(T[], Comparator) 方法）对数组进行升序排序。如果没有对数组进行排序，则结果是不确定的。如果数组包含多个等于指定对象的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
key - 要搜索的值
c - 用来对数组进行排序的比较器。null 值指示应该使用元素的自然顺序。
返回：
如果它包含在数组中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即第一个大于此键的元素索引，如果数组中的所有元素都小于指定的键，则为 a.length。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
ClassCastException - 如果数组包含使用指定的比较器不可相互比较 的元素，或者使用此比较器无法相互比较搜索键与数组的元素。

binarySearch

public static <T> int binarySearch(T[] a,
                                   int fromIndex,
                                   int toIndex,
                                   T key,
                                   Comparator<? super T> c)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。在进行此调用之前，必须根据指定的比较器（通过 sort(T[], int, int, Comparator) 方法）对范围进行升序排序。如果没有对范围进行排序，则结果是不确定的。如果范围包含多个等于指定对象的元素，则无法保证找到的是哪一个。

参数：
a - 要搜索的数组
fromIndex - 要搜索的第一个元素的索引（包括）
toIndex - 要搜索的最后一个元素的索引（不包括）
key - 要搜索的值
c - 用来对数组进行排序的比较器。null 值指示应该使用元素的自然顺序。
返回：
如果它包含在数组的指定范围内，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入数组的那一点：即范围中第一个大于此键的元素索引，如果范围中的所有元素都小于指定的键，则为 toIndex。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
ClassCastException - 如果范围包含使用指定的比较器不可相互比较 的元素，或者使用此比较器无法相互比较搜索键与范围中的元素。
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
从以下版本开始：
1.6

equals

public static boolean equals(long[] a,
                             long[] a2)
如果两个指定的 long 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true

equals

public static boolean equals(int[] a,
                             int[] a2)
如果两个指定的 int 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true

equals

public static boolean equals(short[] a,
                             short[] a2)
如果两个指定的 short 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true

equals

public static boolean equals(char[] a,
                             char[] a2)
如果两个指定的 char 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true

equals

public static boolean equals(byte[] a,
                             byte[] a2)
如果两个指定的 byte 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true

equals

public static boolean equals(boolean[] a,
                             boolean[] a2)
如果两个指定的 boolean 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true

equals

public static boolean equals(double[] a,
                             double[] a2)
如果两个指定的 double 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

如果以下条件成立，则认为两个 double 型数组 d1 和 d2 是相等的：

    new Double(d1).equals(new Double(d2))
（与 == 操作符不同，此方法认为 NaN 等于它本身，而 0.0d 不等于 -0.0d。）

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true
另请参见：
Double.equals(Object)

equals

public static boolean equals(float[] a,
                             float[] a2)
如果两个指定的 float 型数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

如果以下条件成立，则认为两个 float 型数组 f1 和 f2 是相等的：

    new Float(f1).equals(new Float(f2))
（与 == 操作符不同，此方法认为 NaN 等于它本身，而 0.0f 不等于 -0.0f。）

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true
另请参见：
Float.equals(Object)

equals

public static boolean equals(Object[] a,
                             Object[] a2)
如果两个指定的 Objects 数组彼此相等，则返回 true。如果两个数组包含相同数量的元素，并且两个数组中的所有相应元素对都是相等的，则认为这两个数组是相等的。如果 (e1==null ? e2==null : e1.equals(e2))，则认为 e1 和 e2 这两个对象是相等的 。换句话说，如果两个数组以相同顺序包含相同的元素，则两个数组是相等的。此外，如果两个数组引用都为 null，则认为它们是相等的。

参数：
a - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true

fill

public static void fill(long[] a,
                        long val)
将指定的 long 值分配给指定 long 型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(long[] a,
                        int fromIndex,
                        int toIndex,
                        long val)
将指定的 long 值分配给指定 long 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(int[] a,
                        int val)
将指定的 int 值分配给指定 int 型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(int[] a,
                        int fromIndex,
                        int toIndex,
                        int val)
将指定的 int 值分配给指定 int 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(short[] a,
                        short val)
将指定的 short 值分配给指定 short 型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(short[] a,
                        int fromIndex,
                        int toIndex,
                        short val)
将指定的 short 值分配给指定 short 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(char[] a,
                        char val)
将指定的 char 值分配给指定 char 型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(char[] a,
                        int fromIndex,
                        int toIndex,
                        char val)
将指定的 char 值分配给指定 char 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(byte[] a,
                        byte val)
将指定的 byte 值分配给指定 byte 节型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(byte[] a,
                        int fromIndex,
                        int toIndex,
                        byte val)
将指定的 byte 值分配给指定 byte 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(boolean[] a,
                        boolean val)
将指定的 boolean 值分配给指定 boolean 型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(boolean[] a,
                        int fromIndex,
                        int toIndex,
                        boolean val)
将指定的 boolean 值分配给指定 boolean 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(double[] a,
                        double val)
将指定的 double 值分配给指定 double 型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(double[] a,
                        int fromIndex,
                        int toIndex,
                        double val)
将指定的 double 值分配给指定 double 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(float[] a,
                        float val)
将指定的 float 值分配给指定 float 型数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值

fill

public static void fill(float[] a,
                        int fromIndex,
                        int toIndex,
                        float val)
将指定的 float 值分配给指定 float 型数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length

fill

public static void fill(Object[] a,
                        Object val)
将指定的 Object 引用分配给指定 Object 数组的每个元素。

参数：
a - 要填充的数组
val - 要存储在数组所有元素中的值
抛出：
ArrayStoreException - 如果指定值不是可存储在指定数组中的运行时类型

fill

public static void fill(Object[] a,
                        int fromIndex,
                        int toIndex,
                        Object val)
将指定的 Object 引用分配给指定 Object 数组指定范围中的每个元素。填充的范围从索引 fromIndex（包括）一直到索引 toIndex（不包括）。（如果 fromIndex==toIndex，则填充范围为空。）

参数：
a - 要填充的数组
fromIndex - 要使用指定值填充的第一个元素的索引（包括）
toIndex - 要使用指定值填充的最后一个元素的索引（不包括）
val - 要存储在数组的所有元素中的值
抛出：
IllegalArgumentException - 如果 fromIndex > toIndex
ArrayIndexOutOfBoundsException - 如果 fromIndex < 0 或 toIndex > a.length
ArrayStoreException - 如果指定值不是可存储在指定数组中的运行时类型

copyOf

public static <T> T[] copyOf(T[] original,
                             int newLength)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 null。当且仅当指定长度大于原数组的长度时，这些索引存在。所得数组和原数组属于完全相同的类。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 null 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static <T,U> T[] copyOf(U[] original,
                               int newLength,
                               Class<? extends T[]> newType)
复制指定的数组，截取或用 null 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 null。当且仅当指定长度大于原数组的长度时，这些索引存在。所得数组属于 newType 类。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
newType - 要返回的副本的类
返回：
原数组的副本，截取或用 null 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
ArrayStoreException - 如果从 original 中复制的元素不属于存储在 newType 类数组中的运行时类型
从以下版本开始：
1.6

copyOf

public static byte[] copyOf(byte[] original,
                            int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 (byte)0。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 0 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static short[] copyOf(short[] original,
                             int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 (short)0。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 0 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static int[] copyOf(int[] original,
                           int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 0。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 0 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static long[] copyOf(long[] original,
                            int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 0L。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 0 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static char[] copyOf(char[] original,
                            int newLength)
复制指定的数组，截取或用 null 字符填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 '\\u000'。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 null 字符填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static float[] copyOf(float[] original,
                             int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 0f。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 0 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static double[] copyOf(double[] original,
                              int newLength)
复制指定的数组，截取或用 0 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 0d。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 0 填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOf

public static boolean[] copyOf(boolean[] original,
                               int newLength)
复制指定的数组，截取或用 false 填充（如有必要），以使副本具有指定的长度。对于在原数组和副本中都有效的所有索引，这两个数组将包含相同的值。对于在副本中有效而在原数组无效的所有索引，副本将包含 false。当且仅当指定长度大于原数组的长度时，这些索引存在。

参数：
original - 要复制的数组
newLength - 要返回的副本的长度
返回：
原数组的副本，截取或用 false 元素填充以获得指定的长度
抛出：
NegativeArraySizeException - 如果 newLength 为负
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static <T> T[] copyOfRange(T[] original,
                                  int from,
                                  int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to)（必须大于等于 from）可以大于 original.length，在这种情况下，null 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

所得数组与原数组属于完全相同的类。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 null 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static <T,U> T[] copyOfRange(U[] original,
                                    int from,
                                    int to,
                                    Class<? extends T[]> newType)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to) （必须大于等于 from）可以大于 original.length，在这种情况下，null 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。所得数组属于 newType 类。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
newType - 要返回的副本的类
返回：
包含取自原数组指定范围的新数组，截取或用 null 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
ArrayStoreException - 如果从 original 复制的元素不属于可以存储在 newType 类数组中的运行时类型。
从以下版本开始：
1.6

copyOfRange

public static byte[] copyOfRange(byte[] original,
                                 int from,
                                 int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to) （必须大于等于 from）可以大于 original.length，在这种情况下，(byte)0 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 0 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static short[] copyOfRange(short[] original,
                                  int from,
                                  int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to)（必须大于等于 from）可以大于 original.length，在这种情况下，(short)0 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 0 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static int[] copyOfRange(int[] original,
                                int from,
                                int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to)（必须大于等于 from）可以大于 original.length，在这种情况下，0 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 0 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static long[] copyOfRange(long[] original,
                                 int from,
                                 int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to)（必须大于等于 from）可以大于 original.length，在这种情况下，>0L 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 0 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static char[] copyOfRange(char[] original,
                                 int from,
                                 int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to)（必须大于等于 from）可以大于 original.length，在这种情况下，'\\u000' 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 0 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static float[] copyOfRange(float[] original,
                                  int from,
                                  int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to)（必须大于等于 from）可以大于 original.length，在这种情况下，0f 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可以位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 0 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static double[] copyOfRange(double[] original,
                                   int from,
                                   int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to)（必须大于等于 from）可以大于 original.length，在这种情况下，0d 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可能位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 0 填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

copyOfRange

public static boolean[] copyOfRange(boolean[] original,
                                    int from,
                                    int to)
将指定数组的指定范围复制到一个新数组。该范围的初始索引 (from) 必须位于 0 和 original.length（包括）之间。original[from] 处的值放入副本的初始元素中（除非 from == original.length 或 from == to）。原数组中后续元素的值放入副本的后续元素。该范围的最后索引 (to) （必须大于等于 from）可以大于 original.length，在这种情况下，false 被放入索引大于等于 original.length - from 的副本的所有元素中。返回数组的长度为 to - from。

参数：
original - 将要从其复制一个范围的数组
from - 要复制的范围的初始索引（包括）
to - 要复制的范围的最后索引（不包括）。（此索引可能位于数组范围之外）。
返回：
包含取自原数组指定范围的新数组，截取或用 false 元素填充以获得所需长度
抛出：
ArrayIndexOutOfBoundsException - 如果 from < 0 或 from > original.length()
IllegalArgumentException - 如果 from > to
NullPointerException - 如果 original 为 null
从以下版本开始：
1.6

asList

public static <T> List<T> asList(T... a)
返回一个受指定数组支持的固定大小的列表。（对返回列表的更改会“直接写”到数组。）此方法同 Collection.toArray() 一起，充当了基于数组的 API 与基于 collection 的 API 之间的桥梁。返回的列表是可序列化的，并且实现了 RandomAccess。

此方法还提供了一个创建固定长度的列表的便捷方法，该列表被初始化为包含多个元素：

     List<String> stooges = Arrays.asList("Larry", "Moe", "Curly");

参数：
a - 支持列表的数组。
返回：
指定数组的列表视图。

hashCode

public static int hashCode(long[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的 long 型数组 a 和 b，也可以说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Long 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(int[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的非 null int 型数组 a 和 b，也可以说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Integer 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(short[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的 short 型数组 a 和 b，也可用说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Short 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(char[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的 char 型数组 a 和 b，也可用说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Character 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(byte[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的 byte 型数组 a 和 b，也可用说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Byte 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(boolean[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的 boolean 型数组 a 和 b，也可以说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Boolean 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(float[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的 float 型数组 a 和 b，也可以说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Float 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(double[] a)
基于指定数组的内容返回哈希码。对于任何两个满足 Arrays.equals(a, b) 的 double 型数组 a 和 b，也可以说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值与在 List 上调用 hashCode 方法获得的值相同，该 List 包含以相同顺序表示 a 数组元素的 Double 实例的序列。如果 a 为 null，则此方法返回 0。

参数：
a - 要计算其哈希值的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5

hashCode

public static int hashCode(Object[] a)
基于指定数组的内容返回哈希码。如果数组包含作为元素的其他数组，则哈希码将基于其标识，而不是基于其内容。所以，在将自身包含为一个元素的数组上，直接或间接通过一个或多个数组级别来调用此方法是可接受的。

对于任何两个满足 Arrays.equals(a, b) 的数组 a 和 b，也可以说 Arrays.hashCode(a) == Arrays.hashCode(b)。

此方法返回的值等于 Arrays.asList(a).hashCode() 返回的值，除非 a 为 null，在这种情况下返回 0。

参数：
a - 将计算其基于内容的哈希码的数组
返回：
a 数组基于内容的哈希码
从以下版本开始：
1.5
另请参见：
deepHashCode(Object[])

deepHashCode

public static int deepHashCode(Object[] a)
基于指定数组的“深层内容”返回哈希码。如果数组包含作为元素的其他数组，则哈希码将基于其内容，并以此类推，直至无穷。所以，在将自身包含为一个元素的数组上，直接或间接通过一个或多个数组级别来调用此方法是不可接受的。这种调用的行为是不确定的。

对于任何两个满足 Arrays.deepEquals(a, b) 的数组 a 和 b，也可以说 Arrays.deepHashCode(a) == Arrays.deepHashCode(b)。

对此方法返回值的计算类似于对列表上的 List.hashCode() 返回值的计算，该列表以相同的顺序包含与 a 数组相同的元素，但有一点不同：如果数组 a 的 e 元素本身是一个数组，则不能通过调用 e.hashCode() 计算其哈希码，但是，如果 e 是一个基本类型数组，则可以通过调用 Arrays.hashCode(e) 的适当重载来计算其哈希码，或者，如果 e 是一个引用类型数组，则可以通过递归调用 Arrays.deepHashCode(e) 来计算其哈希码。如果 a 为 null，则此方法返回 0。

参数：
a - 将计算其基于深层内容的哈希码的数组
返回：
a 数组基于深层内容的哈希码
从以下版本开始：
1.5
另请参见：
hashCode(Object[])

deepEquals

public static boolean deepEquals(Object[] a1,
                                 Object[] a2)
如果两个指定数组彼此是深层相等 的，则返回 true。与 equals(Object[],Object[]) 方法不同，此方法适用于任意深度的嵌套数组。

如果两个数组引用均为 null，或者它们引用了包含相同元素数量的数组，并且两个数组中的所有相应元素对都是深层相等的，则认为这两个数组引用是深层相等的。

如果满足以下任意条件之一，则两个 null 元素 e1 和 e2 可能是深层相等的：

  • e1 和 e2 都是对象引用类型的数组，并且 Arrays.deepEquals(e1, e2) 将返回 true。
  • e1 和 e2 都是相同基本类型的数组，并且 Arrays.equals(e1, e2) 的适当重载将返回 true。
  • e1 == e2
  • e1.equals(e2) 将返回 true。
注意，此定义支持任意深度的 null 元素。

如果指定数组中的任意一个数组，直接或间接通过一个或多个数组级别，包含数组本身作为其元素，则此方法的行为是不确定的。

参数：
a1 - 将测试其相等性的一个数组
a2 - 将测试其相等性的另一个数组
返回：
如果两个数组相等，则返回 true
从以下版本开始：
1.5
另请参见：
equals(Object[],Object[])

toString

public static String toString(long[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(long) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(int[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(int) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(short[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(short) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(char[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(char) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(byte[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(byte) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(boolean[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(boolean) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(float[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(float) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(double[] a)
返回指定数组内容的字符串表示形式。字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(double) 转换为字符串。如果 a 为 null，则返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5

toString

public static String toString(Object[] a)
返回指定数组内容的字符串表示形式。如果数组包含作为元素的其他数组，则通过从 Object 中继承的 Object.toString() 方法将它们转换为字符串，这描述了它们的标识，而不是它们的内容。

此方法返回的值等于 Arrays.asList(a).toString() 返回的值，除非 a 为 null，在这种情况下返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5
另请参见：
deepToString(Object[])

deepToString

public static String deepToString(Object[] a)
返回指定数组“深层内容”的字符串表示形式。如果数组包含作为元素的其他数组，则字符串表示形式包含其内容等。此方法是为了将多维数组转换为字符串而设计的。

字符串表示形式由数组的元素列表组成，括在方括号（"[]"）中。相邻元素用字符 ", "（逗号加空格）分隔。这些元素通过 String.valueOf(Object) 转换为字符串，除非它们是自身的数组。

如果元素 e 是一个基本类型的数组，则通过调用 Arrays.toString(e) 的适当重载将它转换为字符串。如果元素 e 是一个引用类型的数组，则通过递归调用此方法将它转换为字符串。

为了避免无限递归，如果指定数组包含本身作为其元素，或者包含通过一个或多个数组级别对其自身的间接引用，则将自引用转换为字符串 "[...]"。例如，只包含对自身进行引用的数组将呈现为 "[[...]]"。

如果指定数组为 null，则此方法返回 "null"。

参数：
a - 返回其字符串表示形式的数组
返回：
a 的字符串表示形式
从以下版本开始：
1.5
另请参见：
toString(Object[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BitSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 BitSet

java.lang.Object
    继承者  java.util.BitSet
所有已实现的接口：
Serializable, Cloneable
public class BitSet
extends Object
implements Cloneable, Serializable

此类实现了一个按需增长的位向量。位 set 的每个组件都有一个 boolean 值。用非负的整数将 BitSet 的位编入索引。可以对每个编入索引的位进行测试、设置或者清除。通过逻辑与、逻辑或和逻辑异或操作，可以使用一个 BitSet 修改另一个 BitSet 的内容。

默认情况下，set 中所有位的初始值都是 false。

每个位 set 都有一个当前大小，也就是该位 set 当前所用空间的位数。注意，这个大小与位 set 的实现有关，所以它可能随实现的不同而更改。位 set 的长度与位 set 的逻辑长度有关，并且是与实现无关而定义的。

除非另行说明，否则将 null 参数传递给 BitSet 中的任何方法都将导致 NullPointerException。

在没有外部同步的情况下，多个线程操作一个 BitSet 是不安全的。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
BitSet()
创建一个新的位 set。
BitSet(int nbits)
创建一个位 set，它的初始大小足以显式表示索引范围在 0 到 nbits-1 的位。
方法摘要
void | and(BitSet set) 对此目标位 set 和参数位 set 执行逻辑与操作。
void | andNot(BitSet set) 清除此 BitSet 中所有的位，其相应的位在指定的 BitSet 中已设置。
int | cardinality() 返回此 BitSet 中设置为 true 的位数。
void | clear() 将此 BitSet 中的所有位设置为 false。
void | clear(int bitIndex) 将索引指定处的位设置为 false。
void | clear(int fromIndex, int toIndex) 将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 false。
Object | clone() 复制此 BitSet，生成一个与之相等的新 BitSet。
boolean | equals(Object obj) 将此对象与指定的对象进行比较。
void | flip(int bitIndex) 将指定索引处的位设置为其当前值的补码。
void | flip(int fromIndex, int toIndex) 将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的每个位设置为其当前值的补码。
boolean | get(int bitIndex) 返回指定索引处的位值。
BitSet | get(int fromIndex, int toIndex) 返回一个新的 BitSet，它由此 BitSet 中从 fromIndex（包括）到 toIndex（不包括）范围内的位组成。
int | hashCode() 返回此位 set 的哈希码值。
boolean | intersects(BitSet set) 如果指定的 BitSet 中有设置为 true 的位，并且在此 BitSet 中也将其设置为 true，则返回 ture。
boolean | isEmpty() 如果此 BitSet 中没有包含任何设置为 true 的位，则返回 ture。
int | length() 返回此 BitSet 的“逻辑大小”：BitSet 中最高设置位的索引加 1。
int | nextClearBit(int fromIndex) 返回第一个设置为 false 的位的索引，这发生在指定的起始索引或之后的索引上。
int | nextSetBit(int fromIndex) 返回第一个设置为 true 的位的索引，这发生在指定的起始索引或之后的索引上。
void | or(BitSet set) 对此位 set 和位 set 参数执行逻辑或操作。
void | set(int bitIndex) 将指定索引处的位设置为 true。
void | set(int bitIndex, boolean value) 将指定索引处的位设置为指定的值。
void | set(int fromIndex, int toIndex) 将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 true。
void | set(int fromIndex, int toIndex, boolean value) 将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为指定的值。
int | size() 返回此 BitSet 表示位值时实际使用空间的位数。
String | toString() 返回此位 set 的字符串表示形式。
void | xor(BitSet set) 对此位 set 和位 set 参数执行逻辑异或操作。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

BitSet

public BitSet()
创建一个新的位 set。所有的位初始均为 false。

BitSet

public BitSet(int nbits)
创建一个位 set，它的初始大小足以显式表示索引范围在 0 到 nbits-1 的位。所有的位初始均为 false。

参数：
nbits - 位 set 的初始大小。
抛出：
NegativeArraySizeException - 如果指定的初始大小为负。
方法详细信息

flip

public void flip(int bitIndex)
将指定索引处的位设置为其当前值的补码。

参数：
bitIndex - 要翻转位的索引。
抛出：
IndexOutOfBoundsException - 如果指定的索引为负。
从以下版本开始：
1.4

flip

public void flip(int fromIndex,
                 int toIndex)
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的每个位设置为其当前值的补码。

参数：
fromIndex - 第一个要翻转位的索引。
toIndex - 最后一个要翻转位之后那个位的索引。
抛出：
IndexOutOfBoundsException - 如果 fromIndex 为负，或者 toIndex 为负，或者 fromIndex 大于 toIndex。
从以下版本开始：
1.4

set

public void set(int bitIndex)
将指定索引处的位设置为 true。

参数：
bitIndex - 一个位索引。
抛出：
IndexOutOfBoundsException - 如果指定的索引为负。
从以下版本开始：
JDK1.0

set

public void set(int bitIndex,
                boolean value)
将指定索引处的位设置为指定的值。

参数：
bitIndex - 一个位索引。
value - 要设置的 boolean 值。
抛出：
IndexOutOfBoundsException - 如果指定的索引为负。
从以下版本开始：
1.4

set

public void set(int fromIndex,
                int toIndex)
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 true。

参数：
fromIndex - 第一个要设置位的索引。
toIndex - 最后一个要设置位之后那个位的索引。
抛出：
IndexOutOfBoundsException - 如果 fromIndex 为负，或者 toIndex 为负，或者 fromIndex 大于 toIndex。
从以下版本开始：
1.4

set

public void set(int fromIndex,
                int toIndex,
                boolean value)
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为指定的值。

参数：
fromIndex - 第一个要设置位的索引。
toIndex - 最后一个要设置位之后那个位的索引
value - 所选择的位上要设置的值
抛出：
IndexOutOfBoundsException - 如果 fromIndex 为负，或者 toIndex 为负，或者 fromIndex 大于 toIndex。
从以下版本开始：
1.4

clear

public void clear(int bitIndex)
将索引指定处的位设置为 false。

参数：
bitIndex - 要清除位的索引。
抛出：
IndexOutOfBoundsException - 如果指定的索引为负。
从以下版本开始：
JDK1.0

clear

public void clear(int fromIndex,
                  int toIndex)
将指定的 fromIndex（包括）到指定的 toIndex（不包括）范围内的位设置为 false。

参数：
fromIndex - 第一个要清除位的索引。
toIndex - 最后一个要清除位之后那个位的索引。
抛出：
IndexOutOfBoundsException - 如果 fromIndex 为负，或者 toIndex 为负，或者 fromIndex 大于 toIndex。
从以下版本开始：
1.4

clear

public void clear()
将此 BitSet 中的所有位设置为 false。

从以下版本开始：
1.4

get

public boolean get(int bitIndex)
返回指定索引处的位值。如果当前已设置了此 BitSet 中索引 bitIndex 处的位，则返回 true；否则结果为 false。

参数：
bitIndex - 位索引。
返回：
指定索引处的位值。
抛出：
IndexOutOfBoundsException - 如果指定的索引为负。

get

public BitSet get(int fromIndex,
                  int toIndex)
返回一个新的 BitSet，它由此 BitSet 中从 fromIndex（包括）到 toIndex（不包括）范围内的位组成。

参数：
fromIndex - 第一个要包括位的索引。
toIndex - 最后一个要包括位之后那个位的索引。
返回：
包含此 BitSet 某个范围内各位的新 BitSet。
抛出：
IndexOutOfBoundsException - 如果 fromIndex 为负，或者 toIndex 为负，或者 fromIndex 大于 toIndex。
从以下版本开始：
1.4

nextSetBit

public int nextSetBit(int fromIndex)
返回第一个设置为 true 的位的索引，这发生在指定的起始索引或之后的索引上。如果没有这样的位，则返回 -1。 要在 BitSet 中的 true 位上进行迭代，可以使用以下循环：
for(int i=bs.nextSetBit(0); i>=0; i=bs.nextSetBit(i+1)) {
     // operate on index i here
 }

参数：
fromIndex - 开始检查的索引（包括）。
返回：
下一个已设置为 true 位的索引。
抛出：
IndexOutOfBoundsException - 如果指定的索引为负。
从以下版本开始：
1.4

nextClearBit

public int nextClearBit(int fromIndex)
返回第一个设置为 false 的位的索引，这发生在指定的起始索引或之后的索引上。

参数：
fromIndex - 开始检查的索引（包括）。
返回：
下一个已清除位的索引。
抛出：
IndexOutOfBoundsException - 如果指定的索引为负。
从以下版本开始：
1.4

length

public int length()
返回此 BitSet 的“逻辑大小”：BitSet 中最高设置位的索引加 1。如果 BitSet 中不包含任何设置位，则返回零。

返回：
此 BitSet 的逻辑大小。
从以下版本开始：
1.2

isEmpty

public boolean isEmpty()
如果此 BitSet 中没有包含任何设置为 true 的位，则返回 ture。

返回：
指示此 BitSet 是否为空的 boolean 值。
从以下版本开始：
1.4

intersects

public boolean intersects(BitSet set)
如果指定的 BitSet 中有设置为 true 的位，并且在此 BitSet 中也将其设置为 true，则返回 ture。

参数：
set - 要与其交叉的 BitSet
返回：
指示此 BitSet 与指定的 BitSet 是否存在交叉的 boolean 值。
从以下版本开始：
1.4

cardinality

public int cardinality()
返回此 BitSet 中设置为 true 的位数。

返回：
此 BitSet 中设置为 true 的位数。
从以下版本开始：
1.4

and

public void and(BitSet set)
对此目标位 set 和参数位 set 执行逻辑与操作。当且仅当目标位 set 的初始值均为 true，并且位 set 参数中对应位的值也为 true 时才修改此位 set，这样其内每个位的值均为 true。

参数：
set - 一个位 set。

or

public void or(BitSet set)
对此位 set 和位 set 参数执行逻辑或操作。当且仅当此位 set 中某个位的值为 true，或者位 set 参数中对应位的值为 true 时才修改此位 set，这样其内该位的值为 true。

参数：
set - 一个位 set。

xor

public void xor(BitSet set)
对此位 set 和位 set 参数执行逻辑异或操作。当且仅当以下语句之一成立时才修改此位 set，这样其内某个位的值为 true：
  • 位的初始值为 true，并且参数对应位的值为 false。
  • 位的初始值为 false，并且参数对应位的值为 true。

参数：
set - 一个位 set。

andNot

public void andNot(BitSet set)
清除此 BitSet 中所有的位，其相应的位在指定的 BitSet 中已设置。

参数：
set - 用来屏蔽此 BitSet 的 BitSet。
从以下版本开始：
JDK1.2

hashCode

public int hashCode()
返回此位 set 的哈希码值。哈希码只取决于此 BitSet 中已经设置的位。计算其哈希码的算法可以描述如下。

假定 BitSet 中的位将存储在一个 long 型的数组（比方说叫 words）中，那么当且仅当表达式

((k>>6) < words.length) && ((words[k>>6] & (1L << (bit & 0x3F))) != 0)
为 ture 时，才在 BitSet 中设置位 k（对于非负的 k 值）。然后以下定义的 hashCode 方法才是实际算法的正确实现：
 public int hashCode() {
      long h = 1234;
      for (int i = words.length; --i >= 0; ) {
           h ^= words[i] * (i + 1);
      }
      return (int)((h >> 32) ^ h);
 }
注意，如果位的设置改变，则哈希码值也将发生更改。

重写 Object 的 hashCode 方法。

覆盖：
类 Object 中的 hashCode
返回：
此位 set 的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

size

public int size()
返回此 BitSet 表示位值时实际使用空间的位数。set 中值最大的元素是第 size - 1 个元素。

返回：
此位 set 中当前的位数。

equals

public boolean equals(Object obj)
将此对象与指定的对象进行比较。当且仅当参数不是 null，并且是一个与此位 set 有着完全相同的位 set 设置（为 true）的 Bitset 对象时，结果才为 true。也就是说，对于每个非负的 int 索引 k，
((BitSet)obj).get(k) == this.get(k)
一定为 ture。两个位 set 的当前大小不用进行比较。

重写 Object 的 equals 方法。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则返回 false。
另请参见：
size()

clone

public Object clone()
复制此 BitSet，生成一个与之相等的新 BitSet。复制得到的是另一个位 set，它与此位 set 有着完全相同的、设置为 true）的位。

重写 Object 的 clone 方法。

覆盖：
类 Object 中的 clone
返回：
此位 set 的一个副本。
另请参见：
size()

toString

public String toString()
返回此位 set 的字符串表示形式。对于此 BitSet 中包含的、处于已设置状态的每个位的索引，在结果中会包含这些索引的十进制表示形式。这些索引是按从低到高的顺序列出的、之间用 "," 分隔（一个逗号加一个空格），并用括号括起来，结果形成了一组整数的常用数学符号。

重写 Object 的 toString 方法。

示例：

 BitSet drPepper = new BitSet();
现在 drPepper.toString() 返回 "{}"。

 drPepper.set(2);
现在 drPepper.toString() 返回 "{2}"。

 drPepper.set(4);
 drPepper.set(10);
现在 drPepper.toString() 返回 "{2, 4, 10}"。

覆盖：
类 Object 中的 toString
返回：
此位 set 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Calendar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Calendar

java.lang.Object
    继承者  java.util.Calendar
所有已实现的接口：
Serializable, Cloneable, Comparable<Calendar>
直接已知子类：
GregorianCalendar
public abstract class Calendar
extends Object
implements Serializable, Cloneable, Comparable<Calendar>

Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。瞬间可用毫秒值来表示，它是距历元（即格林威治标准时间 1970 年 1 月 1 日的 00:00:00.000，格里高利历）的偏移量。

该类还为实现包范围外的具体日历系统提供了其他字段和方法。这些字段和方法被定义为 protected。

与其他语言环境敏感类一样，Calendar 提供了一个类方法 getInstance，以获得此类型的一个通用的对象。Calendar 的 getInstance 方法返回一个 Calendar 对象，其日历字段已由当前日期和时间初始化：

     Calendar rightNow = Calendar.getInstance();

Calendar 对象能够生成为特定语言和日历风格实现日期-时间格式化所需的所有日历字段值，例如，日语-格里高里历，日语-传统日历。Calendar 定义了某些日历字段返回值的范围，以及这些值的含义。例如，对于所有日历，日历系统第一个月的值是 MONTH == JANUARY。其他值是由具体子类（例如 ERA）定义的。有关此内容的细节，请参阅每个字段的文档和子类文档。

获得并设置日历字段值

可以通过调用 set 方法来设置日历字段值。在需要计算时间值（距历元所经过的毫秒）或日历字段值之前，不会解释 Calendar 中的所有字段值设置。调用 get、getTimeInMillis、getTime、add 和 roll 涉及此类计算。

宽松性

Calendar 有两种解释日历字段的模式，即 lenient 和 non-lenient。当 Calendar 处于 lenient 模式时，它可接受比它所生成的日历字段范围更大范围内的值。当 Calendar 重新计算日历字段值，以便由 get() 返回这些值时，所有日历字段都被标准化。例如，lenient 模式下的 GregorianCalendar 将 MONTH == JANUARY、DAY_OF_MONTH == 32 解释为 February 1。

当 Calendar 处于 non-lenient 模式时，如果其日历字段中存在任何不一致性，它都会抛出一个异常。例如，GregorianCalendar 总是在 1 与月份的长度之间生成 DAY_OF_MONTH 值。如果已经设置了任何超出范围的字段值，那么在计算时间或日历字段值时，处于 non-lenient 模式下的 GregorianCalendar 会抛出一个异常。

第一个星期

Calendar 使用两个参数定义了特定于语言环境的 7 天制星期：星期的第一天和第一个星期中的最小一天（从 1 到 7）。这些数字取自构造 Calendar 时的语言环境资源数据。还可以通过为其设置值的方法来显式地指定它们。

在设置或获得 WEEK_OF_MONTH 或 WEEK_OF_YEAR 字段时，Calendar 必须确定一个月或一年的第一个星期，以此作为参考点。一个月或一年的第一个星期被确定为开始于 getFirstDayOfWeek() 的最早七天，它最少包含那一个月或一年的 getMinimalDaysInFirstWeek() 天数。第一个星期之前的各星期编号为 ...、-1、0；之后的星期编号为 2、3、...。注意，get() 返回的标准化编号方式可能有所不同。例如，特定 Calendar 子类可能将某一年第 1 个星期之前的那个星期指定为前一年的第 n 个星期。

日历字段解析

在计算日历字段中的日期和时间时，可能没有足够的信息用于计算（例如只有年和月，但没有日），或者可能有不一致的信息( 例如 "Tuesday, July 15, 1996"（格林威治时间）——实际上，1996 年 7 月 15 日是星期一 )。Calendar 将解析日历字段值，以便用以下方式确定日期和时间。

如果日历字段值中存在任何冲突，则 Calendar 将为最近设置的日历字段提供优先权。以下是日历字段的默认组合。将使用由最近设置的单个字段所确定的最近组合。

对于日期字段：

 YEAR + MONTH + DAY_OF_MONTH
 YEAR + MONTH + WEEK_OF_MONTH + DAY_OF_WEEK
 YEAR + MONTH + DAY_OF_WEEK_IN_MONTH + DAY_OF_WEEK
 YEAR + DAY_OF_YEAR
 YEAR + DAY_OF_WEEK + WEEK_OF_YEAR
对于时间字段：
 HOUR_OF_DAY
 AM_PM + HOUR

如果在选定的字段组合中，还有尚未设置值的任一日历字段，那么 Calendar 将使用其默认值。每个字段的默认值可能依据具体的日历系统而有所不同。例如，在 GregorianCalendar 中，字段的默认值与历元起始部分的字段值相同：即 YEAR = 1970、MONTH = JANUARY、DAY_OF_MONTH = 1，等等。

注： 对于某些特别时间的解释可能会有某些歧义，可以用下列方式解决：

  1. 23:59 是一天中的最后一分钟，而 00:00 是下一天的第一分钟。因此，1999 年 12 月 31 日的 23:59 < 2000 年 1 月 1 日的 00:00。
  2. 尽管从历史上看不够精确，但午夜也属于 "am",，中午属于 "pm"，所以在同一天，12:00 am ( 午夜 ) < 12:01 am，12:00 pm ( 中午 ) < 12:01 pm。

日期或时间格式字符串不是日历定义的一部分，因为在运行时，用户必须能够修改或重写它们。可以使用 DateFormat 格式化日期。

字段操作

可以使用三种方法更改日历字段：set()、add() 和 roll()。

set(f, value) 将日历字段 f 更改为 value。此外，它设置了一个内部成员变量，以指示日历字段 f 已经被更改。尽管日历字段 f 是立即更改的，但是直到下次调用 get()、getTime()、getTimeInMillis()、add() 或 roll() 时才会重新计算日历的时间值（以毫秒为单位）。因此，多次调用 set() 不会触发多次不必要的计算。使用 set() 更改日历字段的结果是，其他日历字段也可能发生更改，这取决于日历字段、日历字段值和日历系统。此外，在重新计算日历字段之后，get(f) 没必要通过调用 set 方法返回 value 集合。具体细节是通过具体的日历类确定的。

示例：假定 GregorianCalendar 最初被设置为 1999 年 8 月 31 日。调用 set(Calendar.MONTH, Calendar.SEPTEMBER) 将该日期设置为 1999 年 9 月 31 日。如果随后调用 getTime()，那么这是解析 1999 年 10 月 1 日的一个暂时内部表示。但是，在调用 getTime() 之前调用 set(Calendar.DAY_OF_MONTH, 30) 会将该日期设置为 1999 年 9 月 30 日，因为在调用 set() 之后没有发生重新计算。

add(f, delta) 将 delta 添加到 f 字段中。这等同于调用 set(f, get(f) + delta)，但要带以下两个调整：

Add 规则 1。调用后 f 字段的值减去调用前 f 字段的值等于 delta，以字段 f 中发生的任何溢出为模。溢出发生在字段值超出其范围时，结果，下一个更大的字段会递增或递减，并将字段值调整回其范围内。

Add 规则 2。如果期望某一个更小的字段是不变的，但让它等于以前的值是不可能的，因为在字段 f 发生更改之后，或者在出现其他约束之后，比如时区偏移量发生更改，它的最大值和最小值也在发生更改，然后它的值被调整为尽量接近于所期望的值。更小的字段表示一个更小的时间单元。HOUR 是一个比 DAY_OF_MONTH 小的字段。对于不期望是不变字段的更小字段，无需进行任何调整。日历系统会确定期望不变的那些字段。

此外，与 set() 不同，add() 强迫日历系统立即重新计算日历的毫秒数和所有字段。

示例：假定 GregorianCalendar 最初被设置为 1999 年 8 月 31 日。调用 add(Calendar.MONTH, 13) 将日历设置为 2000 年 9 月 30 日。Add 规则 1 将 MONTH 字段设置为 September，因为向 August 添加 13 个月得出的就是下一年的 September。因为在 GregorianCalendar 中，DAY_OF_MONTH 不可能是 9 月 31 日，所以 add 规则 2 将 DAY_OF_MONTH 设置为 30，即最可能的值。尽管它是一个更小的字段，但不能根据规则 2 调整 DAY_OF_WEEK，因为在 GregorianCalendar 中的月份发生变化时，该值也需要发生变化。

roll(f, delta) 将 delta 添加到 f 字段中，但不更改更大的字段。这等同于调用 add(f, delta)，但要带以下调整：

Roll 规则。在完成调用后，更大的字段无变化。更大的字段表示一个更大的时间单元。DAY_OF_MONTH 是一个比 HOUR 大的字段。

示例：请参阅 GregorianCalendar.roll(int, int)。

使用模型。为了帮助理解 add() 和 roll() 的行为，假定有一个用户界面组件，它带有用于月、日、年和底层 GregorianCalendar 的递增或递减按钮。如果从界面上读取的日期为 1999 年 1 月 31 日，并且用户按下月份的递增按钮，那么应该得到什么？如果底层实现使用 set()，那么可以将该日期读为 1999 年 3 月 3 日。更好的结果是 1999 年 2 月 28 日。此外，如果用户再次按下月份的递增按钮，那么该日期应该读为 1999 年 3 月 31 日，而不是 1999 年 3 月 28 日。通过保存原始日期并使用 add() 或 roll()，根据是否会影响更大的字段，用户界面可以像大多数用户所期望的那样运行。

从以下版本开始：
JDK1.1
另请参见：
System.currentTimeMillis(), Date, GregorianCalendar, TimeZone, DateFormat, 序列化表格

字段摘要
static int | ALL_STYLES 指示所有风格名称的 getDisplayNames 的风格说明符，比如 "January" 和 "Jan"。
static int | AM 指示从午夜到中午之前这段时间的 AM_PM 字段值。
static int | AM_PM get 和 set 的字段数字，指示 HOUR 是在中午之前还是在中午之后。
static int | APRIL 指示在格里高利历和罗马儒略历中一年中第四个月的 MONTH 字段值。
protected boolean | areFieldsSet 如果 fields[] 与当前的设置时间同步，则返回 true。
static int | AUGUST 指示在格里高利历和罗马儒略历中一年中第八个月的 MONTH 字段值。
static int | DATE get 和 set 的字段数字，指示一个月中的某天。
static int | DAY_OF_MONTH get 和 set 的字段数字，指示一个月中的某天。
static int | DAY_OF_WEEK get 和 set 的字段数字，指示一个星期中的某天。
static int | DAY_OF_WEEK_IN_MONTH get 和 set 的字段数字，指示当前月中的第几个星期。
static int | DAY_OF_YEAR get 和 set 的字段数字，指示当前年中的天数。
static int | DECEMBER 指示在格里高利历和罗马儒略历中一年中第十二个月的 MONTH 字段值。
static int | DST_OFFSET get 和 set 的字段数字，以毫秒为单位指示夏令时的偏移量。
static int | ERA 指示年代的 get 和 set 的字段数字，比如罗马儒略历中的 AD 或 BC。
static int | FEBRUARY 指示在格里高利历和罗马儒略历中一年中第二个月的 MONTH 字段值。
static int | FIELD_COUNT get 和 set 可识别的不同字段的数量。
protected int[] | fields 此日历当前设置时间的日历字段值。
static int | FRIDAY 指示 Friday 的 DAY_OF_WEEK 字段值。
static int | HOUR get 和 set 的字段数字，指示上午或下午的小时。
static int | HOUR_OF_DAY get 和 set 的字段数字，指示一天中的小时。
protected boolean[] | isSet 通知是否设置了该日历某一指定日历字段的标志。
protected boolean | isTimeSet 如果 time 值是一个有效值，则返回 true。
static int | JANUARY 指示在格里高利历和罗马儒略历中一年中第一个月的 MONTH 字段值。
static int | JULY 指示在格里高利历和罗马儒略历中一年中第七个月的 MONTH 字段值。
static int | JUNE 指示在格里高利历和罗马儒略历中一年中第六个月的 MONTH 字段值。
static int | LONG 指示长名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "January"。
static int | MARCH 指示在格里高利历和罗马儒略历中一年中第三个月的 MONTH 字段值。
static int | MAY 指示在格里高利历和罗马儒略历中一年中第五个月的 MONTH 字段值。
static int | MILLISECOND get 和 set 的字段数字，指示一秒中的毫秒。
static int | MINUTE get 和 set 的字段数字，指示一小时中的分钟。
static int | MONDAY 指示 Monday 的 DAY_OF_WEEK 字段值。
static int | MONTH 指示月份的 get 和 set 的字段数字。
static int | NOVEMBER 指示在格里高利历和罗马儒略历中一年中第十一个月的 MONTH 字段值。
static int | OCTOBER 指示在格里高利历和罗马儒略历中一年中第十个月的 MONTH 字段值。
static int | PM 指示从中午到午夜之前这段时间的 AM_PM 字段值。
static int | SATURDAY 指示 Saturday 的 DAY_OF_WEEK 字段值。
static int | SECOND get 和 set 的字段数字，指示一分钟中的秒。
static int | SEPTEMBER 指示在格里高利历和罗马儒略历中一年中第九个月的 MONTH 字段值。
static int | SHORT 指示短名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "Jan"。
static int | SUNDAY 指示 Sunday 的 DAY_OF_WEEK 字段值。
static int | THURSDAY 指示 Thursday 的 DAY_OF_WEEK 字段值。
protected long | time 日历的当前设置时间，以毫秒为单位，表示自格林威治标准时间 1970 年 1月 1 日 0:00:00 后经过的时间。
static int | TUESDAY 指示 Tuesday 的 DAY_OF_WEEK 字段值。
static int | UNDECIMBER 指示一年中第十三个月的 MONTH 字段值。
static int | WEDNESDAY 指示 Wednesday 的 DAY_OF_WEEK 字段值。
static int | WEEK_OF_MONTH get 和 set 的字段数字，指示当前月中的星期数。
static int | WEEK_OF_YEAR get 和 set 的字段数字，指示当前年中的星期数。
static int | YEAR 指示年的 get 和 set 的字段数字。
static int | ZONE_OFFSET get 和 set 的字段数字，以毫秒为单位指示距 GMT 的大致偏移量。
构造方法摘要
protected | Calendar() 构造一个带有默认时区和语言环境的 Calendar。
protected | Calendar(TimeZone zone, Locale aLocale) 构造一个带有指定时区和语言环境的 Calendar。
方法摘要
abstract void | add(int field, int amount) 根据日历的规则，为给定的日历字段添加或减去指定的时间量。
boolean | after(Object when) 判断此 Calendar 表示的时间是否在指定 Object 表示的时间之后，返回判断结果。
boolean | before(Object when) 判断此 Calendar 表示的时间是否在指定 Object 表示的时间之前，返回判断结果。
void | clear() 将此 Calendar 的所日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。
void | clear(int field) 将此 Calendar 的给定日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。
Object | clone() 创建并返回此对象的一个副本。
int | compareTo(Calendar anotherCalendar) 比较两个 Calendar 对象表示的时间值（从历元至现在的毫秒偏移量）。
protected void | complete() 填充日历字段中所有未设置的字段。
protected abstract void | computeFields() 将当前毫秒时间值 time 转换为 fields[] 中的日历字段值。
protected abstract void | computeTime() 将 fields[] 中的当前日历字段值转换为毫秒时间值 time。
boolean | equals(Object obj) 将此 Calendar 与指定 Object 比较。
int | get(int field) 返回给定日历字段的值。
int | getActualMaximum(int field) 给定此 Calendar 的时间值，返回指定日历字段可能拥有的最大值。
int | getActualMinimum(int field) 给定此 Calendar 的时间值，返回指定日历字段可能拥有的最小值。
static Locale[] | getAvailableLocales() 返回所有语言环境的数组，此类的 getInstance 方法可以为其返回本地化的实例。
String | getDisplayName(int field, int style, Locale locale) 返回给定 style 和 locale 下的日历 field 值的字符串表示形式。
Map<String,Integer> | getDisplayNames(int field, int style, Locale locale) 返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。
int | getFirstDayOfWeek() 获取一星期的第一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。
abstract int | getGreatestMinimum(int field) 返回此 Calendar 实例给定日历字段的最高的最小值。
static Calendar | getInstance() 使用默认时区和语言环境获得一个日历。
static Calendar | getInstance(Locale aLocale) 使用默认时区和指定语言环境获得一个日历。
static Calendar | getInstance(TimeZone zone) 使用指定时区和默认语言环境获得一个日历。
static Calendar | getInstance(TimeZone zone, Locale aLocale) 使用指定时区和语言环境获得一个日历。
abstract int | getLeastMaximum(int field) 返回此 Calendar 实例给定日历字段的最低的最大值。
abstract int | getMaximum(int field) 返回此 Calendar 实例给定日历字段的最大值。
int | getMinimalDaysInFirstWeek() 获取一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则此方法将返回 1。
abstract int | getMinimum(int field) 返回此 Calendar 实例给定日历字段的最小值。
Date | getTime() 返回一个表示此 Calendar 时间值（从历元至现在的毫秒偏移量）的 Date 对象。
long | getTimeInMillis() 返回此 Calendar 的时间值，以毫秒为单位。
TimeZone | getTimeZone() 获得时区。
int | hashCode() 返回该此日历的哈希码。
protected int | internalGet(int field) 返回给定日历字段的值。
boolean | isLenient() 判断日期/时间的解释是否为宽松的。
boolean | isSet(int field) 确定给定日历字段是否已经设置了一个值，其中包括因为调用 get 方法触发内部字段计算而导致已经设置该值的情况。
abstract void | roll(int field, boolean up) 在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。
void | roll(int field, int amount) 向指定日历字段添加指定（有符号的）时间量，不更改更大的字段。
void | set(int field, int value) 将给定的日历字段设置为给定值。
void | set(int year, int month, int date) 设置日历字段 YEAR、MONTH 和 DAY_OF_MONTH 的值。
void | set(int year, int month, int date, int hourOfDay, int minute) 设置日历字段 YEAR、MONTH、DAY_OF_MONTH、HOUR_OF_DAY 和 MINUTE 的值。
void | set(int year, int month, int date, int hourOfDay, int minute, int second) 设置字段 YEAR、MONTH、DAY_OF_MONTH、HOUR、MINUTE 和 SECOND 的值。
void | setFirstDayOfWeek(int value) 设置一星期的第一天是哪一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。
void | setLenient(boolean lenient) 指定日期/时间解释是否是宽松的。
void | setMinimalDaysInFirstWeek(int value) 设置一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则使用值 1 调用此方法。
void | setTime(Date date) 使用给定的 Date 设置此 Calendar 的时间。
void | setTimeInMillis(long millis) 用给定的 long 值设置此 Calendar 的当前时间值。
void | setTimeZone(TimeZone value) 使用给定的时区值来设置时区。
String | toString() 返回此日历的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ERA

public static final int ERA
指示年代的 get 和 set 的字段数字，比如罗马儒略历中的 AD 或 BC。这是一个特定于日历的值；请参阅子类文档。

另请参见：
GregorianCalendar.AD, GregorianCalendar.BC, 常量字段值

YEAR

public static final int YEAR
指示年的 get 和 set 的字段数字。这是一个特定于日历的值；请参阅子类文档。

另请参见：
常量字段值

MONTH

public static final int MONTH
指示月份的 get 和 set 的字段数字。这是一个特定于日历的值。在格里高利历和罗马儒略历中一年中的第一个月是 JANUARY，它为 0；最后一个月取决于一年中的月份数。

另请参见：
JANUARY, FEBRUARY, MARCH, APRIL, MAY, JUNE, JULY, AUGUST, SEPTEMBER, OCTOBER, NOVEMBER, DECEMBER, UNDECIMBER, 常量字段值

WEEK_OF_YEAR

public static final int WEEK_OF_YEAR
get 和 set 的字段数字，指示当前年中的星期数。正如 getFirstDayOfWeek() 和 getMinimalDaysInFirstWeek() 所定义的那样，一年中第一个星期的值为 1。子类定义一年第一个星期之前的天数，即 WEEK_OF_YEAR 的值。

另请参见：
getFirstDayOfWeek(), getMinimalDaysInFirstWeek(), 常量字段值

WEEK_OF_MONTH

public static final int WEEK_OF_MONTH
get 和 set 的字段数字，指示当前月中的星期数。正如 getFirstDayOfWeek() 和 getMinimalDaysInFirstWeek() 所定义的那样，一个月中第一个星期的值为 1。子类定义一个月第一个星期之前的天数，即 WEEK_OF_MONTH 的值。

另请参见：
getFirstDayOfWeek(), getMinimalDaysInFirstWeek(), 常量字段值

DATE

public static final int DATE
get 和 set 的字段数字，指示一个月中的某天。它与 DAY_OF_MONTH 是同义词。一个月中第一天的值为 1。

另请参见：
DAY_OF_MONTH, 常量字段值

DAY_OF_MONTH

public static final int DAY_OF_MONTH
get 和 set 的字段数字，指示一个月中的某天。它与 DATE 是同义词。一个月中第一天的值为 1。

另请参见：
DATE, 常量字段值

DAY_OF_YEAR

public static final int DAY_OF_YEAR
get 和 set 的字段数字，指示当前年中的天数。一年中第一天的值为 1。

另请参见：
常量字段值

DAY_OF_WEEK

public static final int DAY_OF_WEEK
get 和 set 的字段数字，指示一个星期中的某天。该字段可取的值为 SUNDAY、MONDAY、TUESDAY、WEDNESDAY、THURSDAY、FRIDAY 和 SATURDAY。

另请参见：
SUNDAY, MONDAY, TUESDAY, WEDNESDAY, THURSDAY, FRIDAY, SATURDAY, 常量字段值

DAY_OF_WEEK_IN_MONTH

public static final int DAY_OF_WEEK_IN_MONTH
get 和 set 的字段数字，指示当前月中的第几个星期。与 DAY_OF_WEEK 字段一起使用时，就可以唯一地指定某月中的某一天。与 WEEK_OF_MONTH 和 WEEK_OF_YEAR 不同，该字段的值并不 取决于 getFirstDayOfWeek() 或 getMinimalDaysInFirstWeek()。DAY_OF_MONTH 1 到 7 总是对应于 DAY_OF_WEEK_IN_MONTH 1；8 到 14 总是对应于 DAY_OF_WEEK_IN_MONTH 2，依此类推。DAY_OF_WEEK_IN_MONTH 0 表示 DAY_OF_WEEK_IN_MONTH 1 之前的那个星期。负值是从一个月的末尾开始逆向计数，因此，一个月的最后一个星期天被指定为 DAY_OF_WEEK = SUNDAY, DAY_OF_WEEK_IN_MONTH = -1。因为负值是逆向计数的，所以它们在月份中的对齐方式通常与正值的不同。例如，如果一个月有 31 天，那么 DAY_OF_WEEK_IN_MONTH -1 将与 DAY_OF_WEEK_IN_MONTH 5 和 DAY_OF_WEEK_IN_MONTH 4 的末尾相重叠。

另请参见：
DAY_OF_WEEK, WEEK_OF_MONTH, 常量字段值

AM_PM

public static final int AM_PM
get 和 set 的字段数字，指示 HOUR 是在中午之前还是在中午之后。例如，在 10:04:15.250 PM 这一时刻，AM_PM 为 PM。

另请参见：
AM, PM, HOUR, 常量字段值

HOUR

public static final int HOUR
get 和 set 的字段数字，指示上午或下午的小时。HOUR 用于 12 小时制时钟 (0 - 11)。中午和午夜用 0 表示，不用 12 表示。例如，在 10:04:15.250 PM 这一时刻，HOUR 为 10。

另请参见：
AM_PM, HOUR_OF_DAY, 常量字段值

HOUR_OF_DAY

public static final int HOUR_OF_DAY
get 和 set 的字段数字，指示一天中的小时。HOUR_OF_DAY 用于 24 小时制时钟。例如，在 10:04:15.250 PM 这一时刻，HOUR_OF_DAY 为 22。

另请参见：
HOUR, 常量字段值

MINUTE

public static final int MINUTE
get 和 set 的字段数字，指示一小时中的分钟。例如，在 10:04:15.250 PM 这一时刻，MINUTE 为 4。

另请参见：
常量字段值

SECOND

public static final int SECOND
get 和 set 的字段数字，指示一分钟中的秒。例如，在 10:04:15.250 PM 这一时刻，SECOND 为 15。

另请参见：
常量字段值

MILLISECOND

public static final int MILLISECOND
get 和 set 的字段数字，指示一秒中的毫秒。例如，在 10:04:15.250 PM 这一时刻，MILLISECOND 为 250。

另请参见：
常量字段值

ZONE_OFFSET

public static final int ZONE_OFFSET
get 和 set 的字段数字，以毫秒为单位指示距 GMT 的大致偏移量。

如果 TimeZone 实现子类支持历史上用过的 GMT 偏移量更改，则此字段可反应此 Calendar 时区的正确 GMT 偏移量值。

另请参见：
常量字段值

DST_OFFSET

public static final int DST_OFFSET
get 和 set 的字段数字，以毫秒为单位指示夏令时的偏移量。

如果 TimeZone 实现子类支持历史上用过的 Daylight Saving Time 时间表更改，则此字段可反应此 Calendar 时区的正确夏令时偏移量值。

另请参见：
常量字段值

FIELD_COUNT

public static final int FIELD_COUNT
get 和 set 可识别的不同字段的数量。字段编号的范围是从 0 到 FIELD_COUNT-1。

另请参见：
常量字段值

SUNDAY

public static final int SUNDAY
指示 Sunday 的 DAY_OF_WEEK 字段值。

另请参见：
常量字段值

MONDAY

public static final int MONDAY
指示 Monday 的 DAY_OF_WEEK 字段值。

另请参见：
常量字段值

TUESDAY

public static final int TUESDAY
指示 Tuesday 的 DAY_OF_WEEK 字段值。

另请参见：
常量字段值

WEDNESDAY

public static final int WEDNESDAY
指示 Wednesday 的 DAY_OF_WEEK 字段值。

另请参见：
常量字段值

THURSDAY

public static final int THURSDAY
指示 Thursday 的 DAY_OF_WEEK 字段值。

另请参见：
常量字段值

FRIDAY

public static final int FRIDAY
指示 Friday 的 DAY_OF_WEEK 字段值。

另请参见：
常量字段值

SATURDAY

public static final int SATURDAY
指示 Saturday 的 DAY_OF_WEEK 字段值。

另请参见：
常量字段值

JANUARY

public static final int JANUARY
指示在格里高利历和罗马儒略历中一年中第一个月的 MONTH 字段值。

另请参见：
常量字段值

FEBRUARY

public static final int FEBRUARY
指示在格里高利历和罗马儒略历中一年中第二个月的 MONTH 字段值。

另请参见：
常量字段值

MARCH

public static final int MARCH
指示在格里高利历和罗马儒略历中一年中第三个月的 MONTH 字段值。

另请参见：
常量字段值

APRIL

public static final int APRIL
指示在格里高利历和罗马儒略历中一年中第四个月的 MONTH 字段值。

另请参见：
常量字段值

MAY

public static final int MAY
指示在格里高利历和罗马儒略历中一年中第五个月的 MONTH 字段值。

另请参见：
常量字段值

JUNE

public static final int JUNE
指示在格里高利历和罗马儒略历中一年中第六个月的 MONTH 字段值。

另请参见：
常量字段值

JULY

public static final int JULY
指示在格里高利历和罗马儒略历中一年中第七个月的 MONTH 字段值。

另请参见：
常量字段值

AUGUST

public static final int AUGUST
指示在格里高利历和罗马儒略历中一年中第八个月的 MONTH 字段值。

另请参见：
常量字段值

SEPTEMBER

public static final int SEPTEMBER
指示在格里高利历和罗马儒略历中一年中第九个月的 MONTH 字段值。

另请参见：
常量字段值

OCTOBER

public static final int OCTOBER
指示在格里高利历和罗马儒略历中一年中第十个月的 MONTH 字段值。

另请参见：
常量字段值

NOVEMBER

public static final int NOVEMBER
指示在格里高利历和罗马儒略历中一年中第十一个月的 MONTH 字段值。

另请参见：
常量字段值

DECEMBER

public static final int DECEMBER
指示在格里高利历和罗马儒略历中一年中第十二个月的 MONTH 字段值。

另请参见：
常量字段值

UNDECIMBER

public static final int UNDECIMBER
指示一年中第十三个月的 MONTH 字段值。尽管 GregorianCalendar 没有使用该值，但阴历会使用。

另请参见：
常量字段值

AM

public static final int AM
指示从午夜到中午之前这段时间的 AM_PM 字段值。

另请参见：
常量字段值

PM

public static final int PM
指示从中午到午夜之前这段时间的 AM_PM 字段值。

另请参见：
常量字段值

ALL_STYLES

public static final int ALL_STYLES
指示所有风格名称的 getDisplayNames 的风格说明符，比如 "January" 和 "Jan"。

从以下版本开始：
1.6
另请参见：
SHORT, LONG, 常量字段值

SHORT

public static final int SHORT
指示短名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "Jan"。

从以下版本开始：
1.6
另请参见：
LONG, 常量字段值

LONG

public static final int LONG
指示长名称的 getDisplayName 和 getDisplayNames 的风格说明符，比如 "January"。

从以下版本开始：
1.6
另请参见：
SHORT, 常量字段值

fields

protected int[] fields
此日历当前设置时间的日历字段值。这是一个 FIELD_COUNT 整数数组，索引值为 ERA 到 DST_OFFSET。

isSet

protected boolean[] isSet
通知是否设置了该日历某一指定日历字段的标志。新的对象没有设置任何字段。在第一次调用生成该字段的某一方法后，这些字段都将保留调用之后的设置。这是一个 FIELD_COUNT 布尔值数组，索引值为 ERA 到 DST_OFFSET。

time

protected long time
日历的当前设置时间，以毫秒为单位，表示自格林威治标准时间 1970 年 1月 1 日 0:00:00 后经过的时间。

另请参见：
isTimeSet

isTimeSet

protected boolean isTimeSet
如果 time 值是一个有效值，则返回 true。通过更改 field[] 的项，可以使时间无效。

另请参见：
time

areFieldsSet

protected boolean areFieldsSet
如果 fields[] 与当前的设置时间同步，则返回 true。如果返回 false，则在下一次试图获得某一字段的值时，将强行重新计算 time 当前值中的所有字段。

构造方法详细信息

Calendar

protected Calendar()
构造一个带有默认时区和语言环境的 Calendar。

另请参见：
TimeZone.getDefault()

Calendar

protected Calendar(TimeZone zone,
                   Locale aLocale)
构造一个带有指定时区和语言环境的 Calendar。

参数：
zone - 要使用的时区
aLocale - 用于星期数据的语言环境
方法详细信息

getInstance

public static Calendar getInstance()
使用默认时区和语言环境获得一个日历。返回的 Calendar 基于当前时间，使用了默认时区和默认语言环境。

返回：
一个 Calendar。

getInstance

public static Calendar getInstance(TimeZone zone)
使用指定时区和默认语言环境获得一个日历。返回的 Calendar 基于当前时间，使用了给定时区和默认语言环境。

参数：
zone - 要使用的时区
返回：
一个 Calendar。

getInstance

public static Calendar getInstance(Locale aLocale)
使用默认时区和指定语言环境获得一个日历。返回的 Calendar 基于当前时间，使用了默认时区和给定的语言环境。

参数：
aLocale - 用于星期数据的语言环境
返回：
一个 Calendar。

getInstance

public static Calendar getInstance(TimeZone zone,
                                   Locale aLocale)
使用指定时区和语言环境获得一个日历。返回的 Calendar 基于当前时间，使用了给定的时区和给定的语言环境。

参数：
zone - 要使用的时区
aLocale - 用于星期数据的语言环境
返回：
一个 Calendar。

getAvailableLocales

public static Locale[] getAvailableLocales()
返回所有语言环境的数组，此类的 getInstance 方法可以为其返回本地化的实例。返回的数组必须至少包含一个 Locale 实例，它等同 Locale.US。

返回：
语言环境的数组，对于该数组，本地化的 Calendar 实例是可用的。

computeTime

protected abstract void computeTime()
将 fields[] 中的当前日历字段值转换为毫秒时间值 time。

另请参见：
complete(), computeFields()

computeFields

protected abstract void computeFields()
将当前毫秒时间值 time 转换为 fields[] 中的日历字段值。这允许您将该日历字段值与为日历设置的新时间同步。并不 首先重新计算该时间；为了重新计算时间和字段，请调用 complete() 方法。

另请参见：
computeTime()

getTime

public final Date getTime()
返回一个表示此 Calendar 时间值（从历元至现在的毫秒偏移量）的 Date 对象。

返回：
表示时间值的 Date。
另请参见：
setTime(Date), getTimeInMillis()

setTime

public final void setTime(Date date)
使用给定的 Date 设置此 Calendar 的时间。

注：使用 Date(Long.MAX_VALUE) 或 Date(Long.MIN_VALUE) 调用 setTime() 可能产生来自 get() 的错误字段值。

参数：
date - 给定的 Date。
另请参见：
getTime(), setTimeInMillis(long)

getTimeInMillis

public long getTimeInMillis()
返回此 Calendar 的时间值，以毫秒为单位。

返回：
当前时间，以从历元至现在所经过的 UTC 毫秒数形式。
另请参见：
getTime(), setTimeInMillis(long)

setTimeInMillis

public void setTimeInMillis(long millis)
用给定的 long 值设置此 Calendar 的当前时间值。

参数：
millis - 新时间，以从历元至现在所经过的 UTC 毫秒数形式。
另请参见：
setTime(Date), getTimeInMillis()

get

public int get(int field)
返回给定日历字段的值。在 lenient 模式下，所有日历字段都被标准化。在 non-lenient 模式下，所有日历字段都是经过验证的，如果任何日历字段有超出范围的值，则此方法抛出一个异常。标准化和验证都是通过 complete() 方法处理的，这个过程与日历系统有关。

参数：
field - 给定的日历字段。
返回：
给定日历字段的值。
抛出：
ArrayIndexOutOfBoundsException - 如果指定字段超出范围 (field < 0 || field >= FIELD_COUNT)。
另请参见：
set(int,int), complete()

internalGet

protected final int internalGet(int field)
返回给定日历字段的值。此方法不涉及字段值的标准化或验证。

参数：
field - 给定的日历字段。
返回：
给定日历字段的值。
另请参见：
get(int)

set

public void set(int field,
                int value)
将给定的日历字段设置为给定值。不管处于何种宽松性模式下，该值都不由此方法进行解释。

参数：
field - 给定的日历字段。
value - 给定日历字段所要设置的值。
抛出：
ArrayIndexOutOfBoundsException - 如果指定字段超出范围 (field < 0 || field >= FIELD_COUNT)，并且处于 non-lenient 模式下。
另请参见：
set(int,int,int),
set(int,int,int,int,int),
set(int,int,int,int,int,int),
get(int)

set

public final void set(int year,
                      int month,
                      int date)
设置日历字段 YEAR、MONTH 和 DAY_OF_MONTH 的值。保留其他日历字段以前的值。如果不需要这样做，则先调用 clear()。

参数：
year - 用来设置 YEAR 日历字段的值。
month - 用来设置 MONTH 日历字段的值。Month 值是基于 0 的。例如，0 表示 January。
date - 用来设置 DAY_OF_MONTH 日历字段的值。
另请参见：
set(int,int),
set(int,int,int,int,int),
set(int,int,int,int,int,int)

set

public final void set(int year,
                      int month,
                      int date,
                      int hourOfDay,
                      int minute)
设置日历字段 YEAR、MONTH、DAY_OF_MONTH、HOUR_OF_DAY 和 MINUTE 的值。保留其他字段以前的值。如果不需要这样做，则先调用 clear()。

参数：
year - 用来设置 YEAR 日历字段的值。
month - 用来设置 MONTH 日历字段的值。Month 值是基于 0 的。例如，0 表示 January。
date - 用来设置 DAY_OF_MONTH 日历字段的值。
hourOfDay - 用来设置 HOUR_OF_DAY 日历字段的值。
minute - 用来设置 MINUTE 日历字段的值。
另请参见：
set(int,int),
set(int,int,int),
set(int,int,int,int,int,int)

set

public final void set(int year,
                      int month,
                      int date,
                      int hourOfDay,
                      int minute,
                      int second)
设置字段 YEAR、MONTH、DAY_OF_MONTH、HOUR、MINUTE 和 SECOND 的值。保留其他字段以前的值。如果不需要这样做，则先调用 clear()。

参数：
year - 用来设置 YEAR 日历字段的值。
month - 用来设置 MONTH 日历字段的值。Month 值是基于 0 的。例如，0 表示 January。
date - 用来设置 DAY_OF_MONTH 日历字段的值。
hourOfDay - 用来设置 HOUR_OF_DAY 日历字段的值。
minute - 用来设置 MINUTE 日历字段的值。
second - 用来设置 SECOND 日历字段的值。
另请参见：
set(int,int),
set(int,int,int),
set(int,int,int,int,int)

clear

public final void clear()
将此 Calendar 的所日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。这意味着 isSet() 对于所有的日历字段都将返回 false，并且日期和时间计算会将这些字段作为从未设置的字段对待。Calendar 实现类可能对日期/时间计算使用字段的特定默认值。例如，如果未定义 YEAR 字段值，则 GregorianCalendar 会使用 1970。

另请参见：
clear(int)

clear

public final void clear(int field)
将此 Calendar 的给定日历字段值和时间值（从历元至现在的毫秒偏移量）设置成未定义。这意味着 isSet(field) 将返回 false，并且日期和时间计算会将该字段作为从未设置的字段对待。Calendar 实现类可能对日期和时间计算使用字段的特定默认值。

HOUR_OF_DAY、HOUR 和 AM_PM 字段都是单独处理的，并且应用了一天中时间的解析规则。清除其中的一个字段不会重置此 Calendar 中的小时值。使用 set(Calendar.HOUR_OF_DAY, 0) 重置小时值。

参数：
field - 要清除的日历字段。
另请参见：
clear()

isSet

public final boolean isSet(int field)
确定给定日历字段是否已经设置了一个值，其中包括因为调用 get 方法触发内部字段计算而导致已经设置该值的情况。

返回：
如果给定日历字段已经设置了一个值，则返回 true；否则返回 false。

getDisplayName

public String getDisplayName(int field,
                             int style,
                             Locale locale)
返回给定 style 和 locale 下的日历 field 值的字符串表示形式。如果没有可用的字符串表示形式，则返回 null。如果字符串表示形式可用于给定的日历 field，则此方法调用 get(field) 来获取日历 field 值。

例如，如果此 Calendar 是 GregorianCalendar 并且其日期是 2005-01-01，那么 MONTH 字段的字符串表示形式在英语语言环境中将是 long 类型的 "January" 或者 short 类型的 "Jan"。然而，DAY_OF_MONTH 字段没有可用的字符串表示形式，并且此方法将返回 null。

默认实现支持日历字段，DateFormatSymbols 在给定 locale 中具有此类名称。

参数：
field - 其字符串表示形式返回的日历字段
style - 应用于字符串表示形式的类型；SHORT 或 LONG 之一。
locale - 字符串表示形式的语言环境
返回：
给定 style 中给定 field 的字符串表示形式；如果没有可用的字符串表示形式，则返回 null。
抛出：
IllegalArgumentException - 如果 field 或 style 无效，如果此 Calendar 处于 non-lenient 模式并且所有日历字段都有无效值
NullPointerException - 如果 locale 为 null
从以下版本开始：
1.6

getDisplayNames

public Map<String,Integer> getDisplayNames(int field,
                                           int style,
                                           Locale locale)
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。例如，如果此 Calendar 是 GregorianCalendar，则在英语语言环境的 short 类型中的返回映射将包含 "Jan" 到 JANUARY，"Feb" 到 FEBRUARY 诸如此类。

可以考虑用其他日历字段值来确定显示名称集。例如，如果此 Calendar 是月与日的日历系统并且由 YEAR 字段给定的年值有闰月，此方法将返回包含闰月名称的月名称，并且月名称被映射到该年中其指定值。

默认实现支持 DateFormatSymbols 中包含的显示名称。例如，如果 field 是 MONTH 并且 style 是 ALL_STYLES，则此方法返回包含 DateFormatSymbols.getShortMonths() 和 DateFormatSymbols.getMonths() 返回的所有字符串的 Map。

参数：
field - 其返回显示名称的日历字段
style - 应用于显示名称的风格；SHORT、LONG 或 ALL_STYLES 之一。
locale - 显示名称的语言环境
返回：
包含 style 和 locale 下的所有显示名称的 Map 及其字段值；如果没有显示名称，则返回 null
抛出：
IllegalArgumentException - 如果 field 或 style 无效，如果此 Calendar 处于 non-lenient 模式并且所有日历字段都有无效值
NullPointerException - 如果 locale 为 null
从以下版本开始：
1.6

complete

protected void complete()
填充日历字段中所有未设置的字段。首先，如果已经从日历字段值中计算出了时间值（从历元至现在的毫秒偏移量），则调用 computeTime() 方法。然后调用 computeFields() 方法来计算所有的日历字段值。

equals

public boolean equals(Object obj)
将此 Calendar 与指定 Object 比较。当且仅当参数是同一日历系统的 Calendar 对象时，结果才为 true，该日历系统将同一 Calendar 参数下的同一时间值（从历元至现在的毫秒偏移量）表示为此对象。

Calendar 参数是通过 isLenient、getFirstDayOfWeek、getMinimalDaysInFirstWeek 和 getTimeZone 方法表示的值。如果在两个 Calendar 之间这些参数中存在任何不同之处，则此方法返回 false。

使用 compareTo 方法来仅对时间值进行比较。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果此对象等于 obj，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回该此日历的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
从以下版本开始：
1.2
另请参见：
Object.equals(java.lang.Object), Hashtable

before

public boolean before(Object when)
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之前，返回判断结果。此方法等效于：

         compareTo(when) < 0
当且仅当 when 是一个 Calendar 实例时才返回 true。否则该方法返回 false。

参数：
when - 要比较的 Object
返回：
如果此 Calendar 的时间在 when 表示的时间之前，则返回 true；否则返回 false。
另请参见：
compareTo(Calendar)

after

public boolean after(Object when)
判断此 Calendar 表示的时间是否在指定 Object 表示的时间之后，返回判断结果。此方法等效于：

         compareTo(when) > 0
当且仅当 when 是一个 Calendar 实例时才返回 true。否则该方法返回 false。

参数：
when - 要比较的 Object
返回：
如果此 Calendar 的时间在 when 表示的时间之后，则返回 true；否则返回 false。
另请参见：
compareTo(Calendar)

compareTo

public int compareTo(Calendar anotherCalendar)
比较两个 Calendar 对象表示的时间值（从历元至现在的毫秒偏移量）。

指定者：
接口 Comparable<Calendar> 中的 compareTo
参数：
anotherCalendar - 要比较的 Calendar。
返回：
如果参数表示的时间等于此 Calendar 表示的时间，则返回 0 值；如果此 Calendar 的时间在参数表示的时间之前，则返回小于 0 的值；如果此 Calendar 的时间在参数表示的时间之后，则返回大于 0 的值。
抛出：
NullPointerException - 如果指定的 Calendar 为 null。
IllegalArgumentException - 如果因为无效的日历值而无法获得指定 Calendar 对象的时间值。
从以下版本开始：
1.5

add

public abstract void add(int field,
                         int amount)
根据日历的规则，为给定的日历字段添加或减去指定的时间量。例如，要从当前日历时间减去 5 天，可以通过调用以下方法做到这一点：

add(Calendar.DAY_OF_MONTH, -5)。

参数：
field - 日历字段。
amount - 为字段添加的日期或时间量。
另请参见：
roll(int,int), set(int,int)

roll

public abstract void roll(int field,
                          boolean up)
在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。例如，要将当前日期向上滚动一天，可以通过调用以下方法做到这一点：

roll(Calendar.DATE, true)。在 year 或 Calendar.YEAR 字段上滚动时，将在从 1 到调用 getMaximum(Calendar.YEAR) 的返回值之间的范围内滚动 year 值。在 month 或 Calendar.MONTH 字段上滚动时，其他字段（如 date）可能发生冲突，因此需要更改它们。例如，在日期 01/31/96 上滚动 month 将产生 02/29/96 的日期。在 hour-in-day 或 Calendar.HOUR_OF_DAY 字段上滚动时，小时值会在 0 到 23 之间的范围内滚动，它是基于 0 的。

参数：
field - 时间字段。
up - 指示指定时间字段的值是向上滚动还是向下滚动。如果向上滚动，则使用 true，否则使用 false。
另请参见：
add(int,int), set(int,int)

roll

public void roll(int field,
                 int amount)
向指定日历字段添加指定（有符号的）时间量，不更改更大的字段。负的时间量意味着向下滚动。

注：Calendar 上的此默认实现只是重复地调用滚动一个单元的 roll() 版本。这可能并非总是正确的。例如，如果 DAY_OF_MONTH 字段为 31，则在 February 的范围内滚动会将它设置为 28。此函数的 GregorianCalendar 版本会小心地处理这个问题。其他子类还应该提供此函数的重写版本，以正确实现该功能。

参数：
field - 日历字段。
amount - 要添加到日历 field 中的有符号时间量。
从以下版本开始：
1.2
另请参见：
roll(int,boolean),
add(int,int),
set(int,int)

setTimeZone

public void setTimeZone(TimeZone value)
使用给定的时区值来设置时区。

参数：
value - 给定的时区。

getTimeZone

public TimeZone getTimeZone()
获得时区。

返回：
与此日历有关的时区对象。

setLenient

public void setLenient(boolean lenient)
指定日期/时间解释是否是宽松的。对于宽松的解释，可以将诸如 "February 942, 1996" 之类的日期视为等同于 1996 年 1 月 1 日后的第 941 天。而对于严格的（non-lenient）解释，这样的日期会导致抛出异常。默认情况下是宽松的。

参数：
lenient - 如果开启 lenient 模式，则为 true；如果关闭此模式，则为 false。
另请参见：
isLenient(), DateFormat.setLenient(boolean)

isLenient

public boolean isLenient()
判断日期/时间的解释是否为宽松的。

返回：
如果此日历的解释模式是 lenient，则返回 true；否则返回 false。
另请参见：
setLenient(boolean)

setFirstDayOfWeek

public void setFirstDayOfWeek(int value)
设置一星期的第一天是哪一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。

参数：
value - 给出的一星期的第一天。
另请参见：
getFirstDayOfWeek(), getMinimalDaysInFirstWeek()

getFirstDayOfWeek

public int getFirstDayOfWeek()
获取一星期的第一天；例如，在美国，这一天是 SUNDAY，而在法国，这一天是 MONDAY。

返回：
一星期的第一天。
另请参见：
setFirstDayOfWeek(int), getMinimalDaysInFirstWeek()

setMinimalDaysInFirstWeek

public void setMinimalDaysInFirstWeek(int value)
设置一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则使用值 1 调用此方法。如果最少天数必须是一整个星期，则使用值 7 调用此方法。

参数：
value - 一年中第一个星期所需的给定最少天数。
另请参见：
getMinimalDaysInFirstWeek()

getMinimalDaysInFirstWeek

public int getMinimalDaysInFirstWeek()
获取一年中第一个星期所需的最少天数，例如，如果定义第一个星期包含一年第一个月的第一天，则此方法将返回 1。如果最少天数必须是一整个星期，则此方法将返回 7。

返回：
一年中第一个星期所需的最少天数。
另请参见：
setMinimalDaysInFirstWeek(int)

getMinimum

public abstract int getMinimum(int field)
返回此 Calendar 实例给定日历字段的最小值。最小值被定义为 get 方法为任何可能时间值返回的最小值。最小值取决于日历系统实例的特定参数。

参数：
field - 日历字段。
返回：
给定日历字段的最小值。
另请参见：
getMaximum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMinimum(int), getActualMaximum(int)

getMaximum

public abstract int getMaximum(int field)
返回此 Calendar 实例给定日历字段的最大值。最大值被定义为 get 方法为任何可能时间值返回的最大值。最大值取决于日历系统实例的特定参数。

参数：
field - 日历字段。
返回：
给定日历字段的最大值。
另请参见：
getMinimum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMinimum(int), getActualMaximum(int)

getGreatestMinimum

public abstract int getGreatestMinimum(int field)
返回此 Calendar 实例给定日历字段的最高的最小值。最高的最小值被定义为 getActualMinimum(int) 方法为任何可能时间值返回的最大值。最高的最小值取决于日历系统实例的特定参数。

参数：
field - 日历字段。
返回：
给定日历字段的最高的最小值。
另请参见：
getMinimum(int), getMaximum(int), getLeastMaximum(int), getActualMinimum(int), getActualMaximum(int)

getLeastMaximum

public abstract int getLeastMaximum(int field)
返回此 Calendar 实例给定日历字段的最低的最大值。最低的最大值被定义为 getActualMaximum(int) 方法为任何可能时间值返回的最小值。最低的最大值取决于日历系统实例的特定参数。例如，对于格里高利历系统，Calendar 将为 DAY_OF_MONTH 字段返回 28，因为第 28 天是该日历最短那个月的最后一天，即普通年的二月。

参数：
field - 日历字段。
返回：
给定日历字段的最低的最大值。
另请参见：
getMinimum(int), getMaximum(int), getGreatestMinimum(int), getActualMinimum(int), getActualMaximum(int)

getActualMinimum

public int getActualMinimum(int field)
给定此 Calendar 的时间值，返回指定日历字段可能拥有的最小值。

此方法的默认实现使用了一个迭代算法来确定日历字段的实际最小值。如果可能的话，子类应该使用更有效的实现来重写此方法——在许多情况下，它们只是简单地返回 getMinimum()。

参数：
field - 日历字段
返回：
对于此 Calendar 的时间值而言，给定日历字段的最小值
从以下版本开始：
1.2
另请参见：
getMinimum(int), getMaximum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMaximum(int)

getActualMaximum

public int getActualMaximum(int field)
给定此 Calendar 的时间值，返回指定日历字段可能拥有的最大值。例如，在某些年份中，MONTH 字段的实际最大值是 12，而在希伯来日历系统的其他年份中，该字段的实际最大值是 13。

此方法的默认实现使用了一个迭代算法来确定日历字段的实际最大值。如果有可能的话，子类应该使用一个更有效的实现来重写此方法。

参数：
field - 日历字段
返回：
对于此 Calendar 的时间值而言，给定日历字段的最大值
从以下版本开始：
1.2
另请参见：
getMinimum(int), getMaximum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMaximum(int)

clone

public Object clone()
创建并返回此对象的一个副本。

覆盖：
类 Object 中的 clone
返回：
此对象的一个副本。
另请参见：
Cloneable

toString

public String toString()
返回此日历的字符串表示形式。此方法仅在进行调试的时候使用，不同实现之间所返回的字符串格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Object 中的 toString
返回：
此日历的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Collection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Collection<E>

所有超级接口：
Iterable<E>
所有已知子接口：
BeanContext, BeanContextServices, BlockingDeque<E>, BlockingQueue<E>, Deque<E>, List<E>, NavigableSet<E>, Queue<E>, Set<E>, SortedSet<E>
所有已知实现类：
AbstractCollection, AbstractList, AbstractQueue, AbstractSequentialList, AbstractSet, ArrayBlockingQueue, ArrayDeque, ArrayList, AttributeList, BeanContextServicesSupport, BeanContextSupport, ConcurrentLinkedQueue, ConcurrentSkipListSet, CopyOnWriteArrayList, CopyOnWriteArraySet, DelayQueue, EnumSet, HashSet, JobStateReasons, LinkedBlockingDeque, LinkedBlockingQueue, LinkedHashSet, LinkedList, PriorityBlockingQueue, PriorityQueue, RoleList, RoleUnresolvedList, Stack, SynchronousQueue, TreeSet, Vector
public interface Collection<E>
extends Iterable<E>

Collection 层次结构 中的根接口。Collection 表示一组对象，这些对象也称为 collection 的元素。一些 collection 允许有重复的元素，而另一些则不允许。一些 collection 是有序的，而另一些则是无序的。JDK 不提供此接口的任何直接 实现：它提供更具体的子接口（如 Set 和 List）实现。此接口通常用来传递 collection，并在需要最大普遍性的地方操作这些 collection。

包 (bag) 或多集合 (multiset)（可能包含重复元素的无序 collection）应该直接实现此接口。

所有通用的 Collection 实现类（通常通过它的一个子接口间接实现 Collection）应该提供两个“标准”构造方法：一个是 void（无参数）构造方法，用于创建空 collection；另一个是带有 Collection 类型单参数的构造方法，用于创建一个具有与其参数相同元素新的 collection。实际上，后者允许用户复制任何 collection，以生成所需实现类型的一个等效 collection。尽管无法强制执行此约定（因为接口不能包含构造方法），但是 Java 平台库中所有通用的 Collection 实现都遵从它。

此接口中包含的“破坏性”方法，是指可修改其所操作的 collection 的那些方法，如果此 collection 不支持该操作，则指定这些方法抛出 UnsupportedOperationException。如果是这样，那么在调用对该 collection 无效时，这些方法可能，但并不一定抛出 UnsupportedOperationException。例如，如果要添加的 collection 为空且不可修改，则对该 collection 调用 addAll(Collection) 方法时，可能但并不一定抛出异常。

一些 collection 实现对它们可能包含的元素有所限制。例如，某些实现禁止 null 元素，而某些实现则对元素的类型有限制。试图添加不合格的元素将抛出一个未经检查的异常，通常是 NullPointerException 或 ClassCastException。试图查询是否存在不合格的元素可能抛出一个异常，或者只是简单地返回 false；某些实现将表现出前一种行为，而某些实现则表现后一种。较为常见的是，试图对某个不合格的元素执行操作且该操作的完成不会导致将不合格的元素插入 collection 中，将可能抛出一个异常，也可能操作成功，这取决于实现本身。这样的异常在此接口的规范中标记为“可选”。

由每个 collection 来确定其自身的同步策略。在没有实现的强烈保证的情况下，调用由另一进程正在更改的 collection 的方法可能会出现不确定行为；这包括直接调用，将 collection 传递给可能执行调用的方法，以及使用现有迭代器检查 collection。

Collections Framework 接口中的很多方法是根据 equals 方法定义的。例如，contains(Object o) 方法的规范声明：“当且仅当此 collection 包含至少一个满足 (o==null ? e==null :o.equals(e)) 的元素 e 时，返回 true。”不 应将此规范理解为它暗指调用具有非空参数 o 的 Collection.contains 方法会导致为任意的 e 元素调用 o.equals(e) 方法。可随意对各种实现执行优化，只要避免调用 equals 即可，例如，通过首先比较两个元素的哈希码。（Object.hashCode() 规范保证哈希码不相等的两个对象不会相等）。较为常见的是，各种 Collections Framework 接口的实现可随意利用底层 Object 方法的指定行为，而不管实现程序认为它是否合适。

此接口是 Java Collections Framework 的一个成员。

从以下版本开始：
1.2
另请参见：
Set, List, Map, SortedSet, SortedMap, HashSet, TreeSet, ArrayList, LinkedList, Vector, Collections, Arrays, AbstractCollection

方法摘要
 boolean add(E e)
确保此 collection 包含指定的元素（可选操作）。
 boolean addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
 void clear()
移除此 collection 中的所有元素（可选操作）。
 boolean contains(Object o)
如果此 collection 包含指定的元素，则返回 true。
 boolean containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
 boolean equals(Object o)
比较此 collection 与指定对象是否相等。
 int hashCode()
返回此 collection 的哈希码值。
 boolean isEmpty()
如果此 collection 不包含元素，则返回 true。
 Iterator<E> iterator()
返回在此 collection 的元素上进行迭代的迭代器。
 boolean remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。
 boolean removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
 boolean retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
 int size()
返回此 collection 中的元素数。
 Object[] toArray()
返回包含此 collection 中所有元素的数组。
<T> T[]
toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。

方法详细信息

size

int size()
返回此 collection 中的元素数。如果此 collection 包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

返回：
此 collection 中的元素数

isEmpty

boolean isEmpty()
如果此 collection 不包含元素，则返回 true。

返回：
如果此 collection 不包含元素，则返回 true

contains

boolean contains(Object o)
如果此 collection 包含指定的元素，则返回 true。更确切地讲，当且仅当此 collection 至少包含一个满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，返回 true。

参数：
o - 测试在此 collection 中是否存在的元素。
返回：
如果此 collection 包含指定的元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类型与此 collection 不兼容（可选）。
NullPointerException - 如果指定的元素为 null，并且此 collection 不允许 null 元素（可选）。

iterator

Iterator<E> iterator()
返回在此 collection 的元素上进行迭代的迭代器。关于元素返回的顺序没有任何保证（除非此 collection 是某个能提供保证顺序的类实例）。

指定者：
接口 Iterable<E> 中的 iterator
返回：
在此 collection 的元素上进行迭代的 Iterator

toArray

Object[] toArray()
返回包含此 collection 中所有元素的数组。如果 collection 对其迭代器返回的元素顺序做出了某些保证，那么此方法必须以相同的顺序返回这些元素。

返回的数组将是“安全的”，因为此 collection 并不维护对返回数组的任何引用。（换句话说，即使 collection 受到数组的支持，此方法也必须分配一个新的数组）。因此，调用者可以随意修改返回的数组。

此方法充当了基于数组的 API 与基于 collection 的 API 之间的桥梁。

返回：
包含此 collection 中所有元素的数组

toArray

<T> T[] toArray(T[] a)
返回包含此 collection 中所有元素的数组；返回数组的运行时类型与指定数组的运行时类型相同。如果指定的数组能容纳该 collection，则返回包含此 collection 元素的数组。否则，将分配一个具有指定数组的运行时类型和此 collection 大小的新数组。

如果指定的数组能容纳 collection，并有剩余空间（即数组的元素比 collection 的元素多），那么会将数组中紧接 collection 尾部的元素设置为 null。（只有 在调用者知道此 collection 没有包含任何 null 元素时才能用此方法确定 collection 的长度。）

如果此 collection 对其迭代器返回的元素顺序做出了某些保证，那么此方法必须以相同的顺序返回这些元素。

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，并且在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知 collection。以下代码用来将 collection 转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

参数：
a - 存储此 collection 元素的数组（如果其足够大）；否则，将为此分配一个具有相同运行时类型的新数组。
返回：
包含此 collection 中所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此 collection 每个元素运行时类型的超类型
NullPointerException - 如果指定的数组为 null

add

boolean add(E e)
确保此 collection 包含指定的元素（可选操作）。如果此 collection 由于调用而发生更改，则返回 true。（如果此 collection 不允许有重复元素，并且已经包含了指定的元素，则返回 false。）

支持此操作的 collection 可以限制哪些元素能添加到此 collection 中来。需要特别指出的是，一些 collection 拒绝添加 null 元素，其他一些 collection 将对可以添加的元素类型强加限制。Collection 类应该在其文档中清楚地指定能添加哪些元素方面的所有限制。

如果 collection 由于某些原因（已经包含该元素的原因除外）拒绝添加特定的元素，那么它必须 抛出一个异常（而不是返回 false）。这确保了在此调用返回后，collection 总是包含指定的元素。

参数：
e - 确定此 collection 中是否存在的元素。
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 add 操作
ClassCastException - 如果指定元素的类不允许它添加到此 collection 中
NullPointerException - 如果指定的元素为 null，并且此 collection 不允许 null 元素
IllegalArgumentException - 如果元素的某属性不允许它添加到此 collection 中
IllegalStateException - 如果由于插入限制，元素不能在此时间添加

remove

boolean remove(Object o)
从此 collection 中移除指定元素的单个实例，如果存在的话（可选操作）。更确切地讲，如果此 collection 包含一个或多个满足 (o==null ? e==null : o.equals(e)) 的元素 e，则移除这样的元素。如果此 collection 包含指定的元素（或者此 collection 由于调用而发生更改），则返回 true 。

参数：
o - 要从此 collection 中移除的元素（如果存在）。
返回：
如果此调用将移除一个元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类型与此 collection 不兼容（可选）
NullPointerException - 如果指定的元素为 null，并且此 collection 不允许 null 元素（可选）。
UnsupportedOperationException - 如果此 collection 不支持 remove 操作

containsAll

boolean containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。

参数：
c - 将检查是否包含在此 collection 中的 collection
返回：
如果此 collection 包含指定 collection 中的所有元素，则返回 true
抛出：
ClassCastException - 如果指定 collection 中有一个或多个元素的类型与此 collection 不兼容（可选）
NullPointerException - 如果指定 collection 包含一个或多个 null 元素，并且此 collection 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
contains(Object)

addAll

boolean addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。如果在进行此操作的同时修改指定的 collection，那么此操作行为是不确定的。（这意味着如果指定的 collection 是此 collection，并且此 collection 为非空，那么此调用的行为是不确定的。）

参数：
c - 包含要添加到此 collection 的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 addAll 方法
ClassCastException - 如果指定 collection 中某个元素的类不允许它添加到此 collection 中
NullPointerException - 如果指定 collection 包含 null 元素，并且此 collection 不支持 null 元素，或者指定的 collection 为 null
IllegalArgumentException - 如果指定 collection 的元素的某属性不允许它添加到此 collection 中
IllegalStateException - 如果由于插入限制，不是所有的元素都能在此时间添加
另请参见：
add(Object)

removeAll

boolean removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。此调用返回后，collection 中将不包含任何与指定 collection 相同的元素。

参数：
c - 办好要从此 collection 移除的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 removeAll 方法
ClassCastException - 如果此 collection 中一个或多个元素的类型与指定 collection 不兼容（可选）
NullPointerException - 如果此 collection 包含一个或多个 null 元素，并且指定的 collection 不支持 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object), contains(Object)

retainAll

boolean retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。换句话说，移除此 collection 中未包含在指定 collection 中的所有元素。

参数：
c - 包含保留在此 collection 中的元素的 collection
返回：
如果此 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 collection 不支持 retainAll 操作
ClassCastException - 如果此 collection 中一个或多个元素的类型与指定 collection 不兼容（可选）
NullPointerException - 如果此 collection 包含一个或多个 null 元素，并且指定的 collection 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object), contains(Object)

clear

void clear()
移除此 collection 中的所有元素（可选操作）。此方法返回后，除非抛出一个异常。

抛出：
UnsupportedOperationException - 如果此 collection 不支持 clear 操作

equals

boolean equals(Object o)
比较此 collection 与指定对象是否相等。

当 Collection 接口没有对 Object.equals 的常规协定添加任何约定时，“直接”实现该 Collection 接口（换句话说，创建一个 Collection，但它不是 Set 或 List 的类）的程序员选择重写 Object.equals 方法时必须小心。没必要这样做，最简单的方案是依靠 Object 的实现，然而实现者可能希望实现“值比较”，而不是默认的“引用比较”。（List 和 Set 接口要求进行这样的值比较。）

Object.equals 方法的常规协定声称相等必须是对称的（换句话说，当且仅当存在 b.equals(a) 时，才存在 a.equals(b)）。List.equals 和 Set.equals 的协定声称列表只能与列表相等，set 只能与 set 相等。因此，对于一个既不实现 List 又不实现 Set 接口的 collection 类，当将此 collection 与任何列表或 set 进行比较时，常规的 equals 方法必须返回 false。（按照相同的逻辑，不可能编写一个同时正确实现 Set 和 List 接口的类。）

覆盖：
类 Object 中的 equals
参数：
o - 要与此 collection 进行相等性比较的对象。
返回：
如果指定对象与此 collection 相等，则返回 true
另请参见：
Object.equals(Object),
Set.equals(Object),
List.equals(Object)

hashCode

int hashCode()
返回此 collection 的哈希码值。当 Collection 接口没有为 Object.hashCode 方法的常规协定添加任何约束时，为了满足 Object.hashCode 方法的常规协定，程序员应该注意任何重写 Object.equals 方法的类必须重写 Object.hashCode 方法。需要特别指出的是，c1.equals(c2) 暗示着 c1.hashCode()==c2.hashCode()。

覆盖：
类 Object 中的 hashCode
返回：
此 collection 的哈希码值
另请参见：
Object.hashCode(), Object.equals(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Collections (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Collections

java.lang.Object
    继承者  java.util.Collections

public class Collections
extends Object

此类完全由在 collection 上进行操作或返回 collection 的静态方法组成。它包含在 collection 上操作的多态算法，即“包装器”，包装器返回由指定 collection 支持的新 collection，以及少数其他内容。

如果为此类的方法所提供的 collection 或类对象为 null，则这些方法都将抛出 NullPointerException。

此类中所含多态算法的文档通常包括对实现 的简短描述。应该将这类描述视为实现注意事项，而不是规范 的一部分。实现者应该可以随意使用其他算法替代，只要遵循规范本身即可。（例如，sort 使用的算法不一定是合并排序算法，但它必须是稳定的。）

此类中包含的“破坏性”算法，即可修改其所操作的 collection 的算法，该算法被指定在 collection 不支持适当的可变基元（比如 set 方法）时抛出 UnsupportedOperationException。如果调用不会对 collection 产生任何影响，那么这些算法可能（但不要求）抛出此异常。例如，在已经排序的、不可修改列表上调用 sort 方法可能会（也可能不会）抛出 UnsupportedOperationException。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, Set, List, Map

字段摘要
static List | EMPTY_LIST 空的列表（不可变的）。
static Map | EMPTY_MAP 空的映射（不可变的）。
static Set | EMPTY_SET 空的 set（不可变的）。
方法摘要
static
<T> boolean
addAll(Collection<? super T> c, T... elements)
将所有指定元素添加到指定 collection 中。
static
<T> Queue<T>
asLifoQueue(Deque<T> deque)
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。
static
<T> int
binarySearch(List<? extends Comparable<? super T>> list, T key)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<T> int
binarySearch(List<? extends T> list, T key, Comparator<? super T> c)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<E> Collection<E>
checkedCollection(Collection<E> c, Class<E> type)
返回指定 collection 的一个动态类型安全视图。
static
<E> List<E>
checkedList(List<E> list, Class<E> type)
返回指定列表的一个动态类型安全视图。
static
<K,V> Map<K,V>
checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<E> Set<E>
checkedSet(Set<E> s, Class<E> type)
返回指定 set 的一个动态类型安全视图。
static
<K,V> SortedMap<K,V>
checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
static
<E> SortedSet<E>
checkedSortedSet(SortedSet<E> s, Class<E> type)
返回指定有序 set 的一个动态类型安全视图。
static
<T> void
copy(List<? super T> dest, List<? extends T> src)
将所有元素从一个列表复制到另一个列表。
static boolean disjoint(Collection<?> c1, Collection<?> c2)
如果两个指定 collection 中没有相同的元素，则返回 true。
static
<T> List<T>
emptyList()
返回空的列表（不可变的）。
static
<K,V> Map<K,V>
emptyMap()
返回空的映射（不可变的）。
static
<T> Set<T>
emptySet()
返回空的 set（不可变的）。
static
<T> Enumeration<T>
enumeration(Collection<T> c)
返回一个指定 collection 上的枚举。
static
<T> void
fill(List<? super T> list, T obj)
使用指定元素替换指定列表中的所有元素。
static int frequency(Collection<?> c, Object o)
返回指定 collection 中等于指定对象的元素数。
static int indexOfSubList(List<?> source, List<?> target)
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static int lastIndexOfSubList(List<?> source, List<?> target)
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static
<T> ArrayList<T>
list(Enumeration<T> e)
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。
static
<T extends Object & Comparable<? super T>>
T
max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。
static
<T> T
max(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最大元素。
static
<T extends Object & Comparable<? super T>>
T
min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。
static
<T> T
min(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最小元素。
static
<T> List<T>
nCopies(int n, T o)
返回由指定对象的 n 个副本组成的不可变列表。
static
<E> Set<E>
newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。
static
<T> boolean
replaceAll(List<T> list, T oldVal, T newVal)
使用另一个值替换列表中出现的所有某一指定值。
static void reverse(List<?> list)
反转指定列表中元素的顺序。
static
<T> Comparator<T>
reverseOrder()
返回一个比较器，它强行逆转实现了 Comparable 接口的对象 collection 的自然顺序。
static
<T> Comparator<T>
reverseOrder(Comparator<T> cmp)
返回一个比较器，它强行逆转指定比较器的顺序。
static void rotate(List<?> list, int distance)
根据指定的距离轮换指定列表中的元素。
static void shuffle(List<?> list)
使用默认随机源对指定列表进行置换。
static void shuffle(List<?> list, Random rnd)
使用指定的随机源对指定列表进行置换。
static
<T> Set<T>
singleton(T o)
返回一个只包含指定对象的不可变 set。
static
<T> List<T>
singletonList(T o)
返回一个只包含指定对象的不可变列表。
static
<K,V> Map<K,V>
singletonMap(K key, V value)
返回一个不可变的映射，它只将指定键映射到指定值。
static
<T extends Comparable<? super T>>
void
sort(List<T> list)
根据元素的自然顺序 对指定列表按升序进行排序。
static
<T> void
sort(List<T> list, Comparator<? super T> c)
根据指定比较器产生的顺序对指定列表进行排序。
static void swap(List<?> list, int i, int j)
在指定列表的指定位置处交换元素。
static
<T> Collection<T>
synchronizedCollection(Collection<T> c)
返回指定 collection 支持的同步（线程安全的）collection。
static
<T> List<T>
synchronizedList(List<T> list)
返回指定列表支持的同步（线程安全的）列表。
static
<K,V> Map<K,V>
synchronizedMap(Map<K,V> m)
返回由指定映射支持的同步（线程安全的）映射。
static
<T> Set<T>
synchronizedSet(Set<T> s)
返回指定 set 支持的同步（线程安全的）set。
static
<K,V> SortedMap<K,V>
synchronizedSortedMap(SortedMap<K,V> m)
返回指定有序映射支持的同步（线程安全的）有序映射。
static
<T> SortedSet<T>
synchronizedSortedSet(SortedSet<T> s)
返回指定有序 set 支持的同步（线程安全的）有序 set。
static
<T> Collection<T>
unmodifiableCollection(Collection<? extends T> c)
返回指定 collection 的不可修改视图。
static
<T> List<T>
unmodifiableList(List<? extends T> list)
返回指定列表的不可修改视图。
static
<K,V> Map<K,V>
unmodifiableMap(Map<? extends K,? extends V> m)
返回指定映射的不可修改视图。
static
<T> Set<T>
unmodifiableSet(Set<? extends T> s)
返回指定 set 的不可修改视图。
static
<K,V> SortedMap<K,V>
unmodifiableSortedMap(SortedMap<K,? extends V> m)
返回指定有序映射的不可修改视图。
static
<T> SortedSet<T>
unmodifiableSortedSet(SortedSet<T> s)
返回指定有序 set 的不可修改视图。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

EMPTY_SET

public static final Set EMPTY_SET
空的 set（不可变的）。此 set 是可序列化的。

另请参见：
emptySet()

EMPTY_LIST

public static final List EMPTY_LIST
空的列表（不可变的）。此列表是可序列化的。

另请参见：
emptyList()

EMPTY_MAP

public static final Map EMPTY_MAP
空的映射（不可变的）。此映射是可序列化的。

从以下版本开始：
1.3
另请参见：
emptyMap()
方法详细信息

sort

public static <T extends Comparable<? super T>> void sort(List<T> list)
根据元素的自然顺序 对指定列表按升序进行排序。列表中的所有元素都必须实现 Comparable 接口。此外，列表中的所有元素都必须是可相互比较的（也就是说，对于列表中的任何 e1 和 e2 元素，e1.compareTo(e2) 不得抛出 ClassCastException）。

此排序方法具有稳定性：不会因调用 sort 方法而对相等的元素进行重新排序。

指定列表必须是可修改的，但不必是大小可调整的。

该排序算法是一个经过修改的合并排序算法（其中，如果低子列表中的最高元素小于高子列表中的最低元素，则忽略合并）。此算法提供可保证的 n log(n) 性能。 此实现将指定列表转储到一个数组中，并对数组进行排序，在重置数组中相应位置处每个元素的列表上进行迭代。这避免了由于试图原地对链接列表进行排序而产生的 n2 log(n) 性能。

参数：
list - 要排序的列表。
抛出：
ClassCastException - 如果列表包含不可相互比较 的元素（例如，字符串和整数）。
UnsupportedOperationException - 如果指定列表的列表迭代器不支持 set 操作。
另请参见：
Comparable

sort

public static <T> void sort(List<T> list,
                            Comparator<? super T> c)
根据指定比较器产生的顺序对指定列表进行排序。此列表内的所有元素都必须可使用指定比较器相互比较（也就是说，对于列表中的任意 e1 和 e2 元素，c.compare(e1, e2) 不得抛出 ClassCastException）。

此排序被保证是稳定的：不会因调用 sort 而对相等的元素进行重新排序。

排序算法是一个经过修改的合并排序算法（其中，如果低子列表中的最高元素小于高子列表中的最低元素，则忽略合并）。此算法提供可保证的 n log(n) 性能。 指定列表必须是可修改的，但不必是可大小调整的。此实现将指定列表转储到一个数组中，并对数组进行排序，在重置数组中相应位置每个元素的列表上进行迭代。这避免了由于试图原地对链接列表进行排序而产生的 n2 log(n) 性能。

参数：
list - 要排序的列表。
c - 确定列表顺序的比较器。null 值指示应该使用元素的自然顺序。
抛出：
ClassCastException - 如果列表中包含不可使用指定比较器相互比较 的元素。
UnsupportedOperationException - 如果指定列表的列表迭代器不支持 set 操作。
另请参见：
Comparator

binarySearch

public static <T> int binarySearch(List<? extends Comparable<? super T>> list,
                                   T key)
使用二分搜索法搜索指定列表，以获得指定对象。在进行此调用之前，必须根据列表元素的自然顺序对列表进行升序排序（通过 sort(List) 方法）。如果没有对列表进行排序，则结果是不确定的。如果列表包含多个等于指定对象的元素，则无法保证找到的是哪一个。

此方法对“随机访问”列表运行 log(n) 次（它提供接近固定时间的位置访问）。如果指定列表没有实现 RandomAccess 接口并且是一个大型列表，则此方法将执行基于迭代器的二分搜索，执行 O(n) 次链接遍历和 O(log n) 次元素比较。

参数：
list - 要搜索的列表。
key - 要搜索的键。
返回：
如果搜索键包含在列表中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入列表的那一点：即第一个大于此键的元素索引；如果列表中的所有元素都小于指定的键，则为 list.size()。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
ClassCastException - 如果列表中包含不可相互比较 的元素（例如，字符串和整数），或者搜索键无法与列表的元素进行相互比较。

binarySearch

public static <T> int binarySearch(List<? extends T> list,
                                   T key,
                                   Comparator<? super T> c)
使用二分搜索法搜索指定列表，以获得指定对象。在进行此调用之前，必须根据指定的比较器对列表进行升序排序（通过 sort(List, Comparator) 方法）。如果没有对列表进行排序，则结果是不确定的。如果列表包含多个等于指定对象的元素，则无法保证找到的是哪一个。

此方法对“随机访问”的列表运行 log(n) 次（它提供接近固定时间的位置访问）。如果指定列表没有实现 RandomAccess 接口并且是一个大型列表，则此方法将执行基于迭代器的二分搜索，执行 O(n) 次链接遍历和 O(log n) 次元素比较。

参数：
list - 要搜索的列表。
key - 要搜索的键。
c - 排序列表的比较器。null 值指示应该使用元素的自然顺序。
返回：
如果搜索键包含在列表中，则返回搜索键的索引；否则返回 (-(插入点) - 1)。插入点 被定义为将键插入列表的那一点：即第一个大于此键的元素索引；如果列表中的所有元素都小于指定的键，则为 list.size()。注意，这保证了当且仅当此键被找到时，返回的值将 >= 0。
抛出：
ClassCastException - 如果列表中包含使用指定的比较器不可相互比较 的元素，或者使用此比较器无法相互比较搜索键与列表元素。

reverse

public static void reverse(List<?> list)
反转指定列表中元素的顺序。

此方法以线性时间运行。

参数：
list - 元素要被反转的列表。
抛出：
UnsupportedOperationException - 如果指定列表或其列表迭代器不支持 set 操作。

shuffle

public static void shuffle(List<?> list)
使用默认随机源对指定列表进行置换。所有置换发生的可能性都是大致相等的。

前面描述中使用了不确定的词“大致”，因为随机源只是大致上独立选择位的无偏源。如果它是一个随机选择位的最佳源，那么算法将完全一致的选择置换。

此实现向后遍历列表，从最后一个元素一直到第二个元素，将随机选择的元素重复交换到“当前位置”。元素是从列表的一部分随机选择的，该部分列表从第一个元素一直到当前位置（包括）。

此方法以线性时间运行。如果指定列表没有实现 RandomAccess 接口并且是一个大型列表，则此实现在改组列表前将指定列表转储到数组中，并将改组后的数组转储回列表中。这避免了二次行为，该行为是原地改组一个“有序访问”列表引起的。

参数：
list - 要改组的列表。
抛出：
UnsupportedOperationException - 如果指定列表或其列表迭代器不支持 set 操作。

shuffle

public static void shuffle(List<?> list,
                           Random rnd)
使用指定的随机源对指定列表进行置换。所有置换发生的可能性都是相等的，假定随机源是公平的。

此实现向后遍历列表，从最后一个元素一直到第二个元素，将随机选择的元素重复交换到“当前位置”。元素是从列表的一部分随机选择的，该部分列表从第一个元素一直到当前位置（包括）。

此方法以线性时间运行。如果指定列表没有实现 RandomAccess 接口并且是一个大型列表，则此实现在改组列表前将指定列表转储到一个数组中，并将改组后的数组转储回列表中。这避免了二次行为，该行为是原地改组一个“有序访问”列表引起的。

参数：
list - 要改组的列表。
rnd - 用来改组列表的随机源。
抛出：
UnsupportedOperationException - 如果指定列表或其列表迭代器不支持 set 操作。

swap

public static void swap(List<?> list,
                        int i,
                        int j)
在指定列表的指定位置处交换元素。（如果指定位置相同，则调用此方法不会更改列表。）

参数：
list - 进行元素交换的列表。
i - 要交换的一个元素的索引。
j - 要交换的另一个元素的索引。
抛出：
IndexOutOfBoundsException - 如果 i 或 j 超出范围 (i < 0 || i >= list.size() || j < 0 || j >= list.size())。
从以下版本开始：
1.4

fill

public static <T> void fill(List<? super T> list,
                            T obj)
使用指定元素替换指定列表中的所有元素。

此方法以线性时间运行。

参数：
list - 使用指定元素填充的列表。
obj - 用来填充指定列表的元素。
抛出：
UnsupportedOperationException - 如果指定列表或其列表迭代器不支持 set 操作。

copy

public static <T> void copy(List<? super T> dest,
                            List<? extends T> src)
将所有元素从一个列表复制到另一个列表。执行此操作后，目标列表中每个已复制元素的索引将等同于源列表中该元素的索引。目标列表的长度至少必须等于源列表。如果目标列表更长一些，也不会影响目标列表中的其余元素。

此方法以线性时间运行。

参数：
dest - 目标列表。
src - 源列表。
抛出：
IndexOutOfBoundsException - 如果目标列表太小而无法包含整个源列表。
UnsupportedOperationException - 如果目标列表的列表迭代器不支持 set 操作。

min

public static <T extends Object & Comparable<? super T>> T min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。collection 中的所有元素都必须实现 Comparable 接口。此外，collection 中的所有元素都必须是可相互比较的（也就是说，对于 collection 中的任意 e1 和 e2 元素，e1.compareTo(e2) 不得抛出 ClassCastException）。

此方法在整个 collection 上进行迭代，所以它需要的时间与 collection 的大小成正比。

参数：
coll - 将确定其最小元素的 collection。
返回：
根据元素的自然顺序，返回给定 collection 的最小元素。
抛出：
ClassCastException - 如果 collection 包含不可相互比较 的元素（例如，字符串和整数）。
NoSuchElementException - 如果 collection 为空。
另请参见：
Comparable

min

public static <T> T min(Collection<? extends T> coll,
                        Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最小元素。collection 中的所有元素都必须可通过指定比较器相互比较（也就是说，对于 collection 中的任意 e1 和 e2 元素，comp.compare(e1, e2) 不得抛出 ClassCastException）。

此方法在整个 collection 上进行迭代，所以它需要的时间与 collection 的大小成正比。

参数：
coll - 将确定其最小元素的 collection。
comp - 用来确定最小元素的比较器。null 值指示应该使用元素的自然顺序。
返回：
根据指定比较器返回给定 collection 的最小元素。
抛出：
ClassCastException - 如果 collection 中包含不可使用指定比较器相互比较 的元素。
NoSuchElementException - 如果 collection 为空。
另请参见：
Comparable

max

public static <T extends Object & Comparable<? super T>> T max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。collection 中的所有元素都必须实现 Comparable 接口。此外，collection 中的所有元素都必须是可相互比较的（也就是说，对于 collection 中的任意 e1 和 e2 元素，e1.compareTo(e2) 不得抛出 ClassCastException）。

此方法在整个 collection 上进行迭代，所以它需要的时间与 collection 的大小成正比。

参数：
coll - 将确定其最大元素的 collection。
返回：
根据元素的自然顺序 返回给定 collection 的最大元素。
抛出：
ClassCastException - 如果 collection 包含不可相互比较 的元素（例如，字符串和整数）。
NoSuchElementException - 如果 collection 为空。
另请参见：
Comparable

max

public static <T> T max(Collection<? extends T> coll,
                        Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最大元素。collection 中的所有元素都必须可通过指定比较器相互比较（也就是说，对于 collection 中的任意 e1 和 e2 元素，comp.compare(e1, e2) 不得抛出 ClassCastException）。

此方法在整个 collection 上进行迭代，所以它需要的时间与 collection 的大小成正比。

参数：
coll - 将确定其最大元素的 collection。
comp - 用来确定最大元素的比较器。null 值指示应该使用元素的自然顺序。
返回：
根据指定比较器返回给定 collection 的最大元素。
抛出：
ClassCastException - 如果 collection 中包含不可使用指定比较器相互比较 的元素。
NoSuchElementException - 如果 collection 为空。
另请参见：
Comparable

rotate

public static void rotate(List<?> list,
                          int distance)
根据指定的距离轮换指定列表中的元素。调用此方法后，对于 0 和 list.size()-1（包括）之间的所有 i 值，索引 i 处的元素将是以前位于索引 (i - distance) mod list.size() 处的元素。（此方法对列表的大小没有任何影响。）

例如，假设 list 包含 [t, a, n, k, s]。在调用 Collections.rotate(list, 1)（或 Collections.rotate(list, -4)）之后，list 将包含 [s, t, a, n, k]。

注意，此方法用于子列表时非常有用，可以在保留其余元素顺序的同时，在列表中移动一个或多个元素。例如，以下语句可以将索引 j 处的元素向前移动到位置 k 上（k 必须大于等于 j）：

     Collections.rotate(list.subList(j, k+1), -1);
为了具体说明这一点，假设 list 包含 [a, b, c, d, e]。要将索引 1 处的元素（b）向前移动两个位置，请执行以下调用：
     Collections.rotate(l.subList(1, 4), -1);
得到的列表是 [a, c, d, b, e]。

要将多个元素向前移动，则需要增加循环移动距离的绝对值。要将元素向后移动，请使用一个正的移动距离。

如果指定列表是一个小型列表，或者它实现了 RandomAccess 接口，则此实现会将第一个元素交换到它应该去的位置上，然后重复执行交换操作，将替换的元素交换到它们应该去的位置上，直到替换的元素交换成第一个元素。如有必要，需要在第二个或后续元素上重复这个过程，直到完成轮换。如果指定的列表是大型列表并且没有实现 RandomAccess 接口，则此实现会将列表拆分成位于 -distance mod size 索引两边的两个子列表视图。然后在每个子列表视图上调用 reverse(List) 方法，并最终在整个列表上调用此方法。有关这两种算法更为完整的描述，请参阅 Jon Bentley 撰写的 Programming Pearls (Addison-Wesley, 1986) 一书中的第 2.3 小节。

参数：
list - 要轮换的列表。
distance - 列表轮换的距离。在此值上没有任何限制；它可以是 0、负数或大于 list.size() 的数。
抛出：
UnsupportedOperationException - 如果指定列表或其列表迭代器不支持 set 操作。
从以下版本开始：
1.4

replaceAll

public static <T> boolean replaceAll(List<T> list,
                                     T oldVal,
                                     T newVal)
使用另一个值替换列表中出现的所有某一指定值。更确切地讲，使用 newVal 替换 list 中满足 (oldVal==null ? e==null : oldVal.equals(e)) 的每个 e 元素。（此方法对列表的大小没有任何影响。）

参数：
list - 在其中进行替换的列表。
oldVal - 将被替换的原值。
newVal - 替换 oldVal 的新值。
返回：
如果 list 包含一个或多个满足 (oldVal==null ? e==null : oldVal.equals(e)) 的 e 元素，则返回 true。
抛出：
UnsupportedOperationException - 如果指定列表或其列表迭代器不支持 set 操作。
从以下版本开始：
1.4

indexOfSubList

public static int indexOfSubList(List<?> source,
                                 List<?> target)
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。更确切地讲，返回满足 source.subList(i, i+target.size()).equals(target) 的最低索引 i；如果不存在这样的索引，则返回 -1。（如果 target.size() > source.size()，则返回 -1。）

此实现使用 "brute force" 扫描技术在源列表上进行扫描，依次在每个位置上寻找与目标匹配的列表项。

参数：
source - 在该列表中搜索第一次出现的 target。
target - 作为 source 子列表搜索的列表。
返回：
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
从以下版本开始：
1.4

lastIndexOfSubList

public static int lastIndexOfSubList(List<?> source,
                                     List<?> target)
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。更确切地讲，返回满足 source.subList(i, i+target.size()).equals(target) 的最高索引 i；如果不存在这样的索引，则返回 -1。（如果 target.size() > source.size()，则返回 -1。）

此实现使用 "brute force" 迭代技术在源列表上进行迭代，依次在每个位置上寻找与目标匹配的列表项。

参数：
source - 在该列表中搜索最后一次出现的 target。
target - 作为 source 子列表搜索的列表。
返回：
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
从以下版本开始：
1.4

unmodifiableCollection

public static <T> Collection<T> unmodifiableCollection(Collection<? extends T> c)
返回指定 collection 的不可修改视图。此方法允许模块为用户提供对内部 collection 的“只读”访问。在返回的 collection 上执行的查询操作将“读完”指定的 collection。试图修改返回的 collection（不管是直接修改还是通过其迭代器进行修改）将导致抛出 UnsupportedOperationException。

返回的 collection 不会 将 hashCode 和 equals 操作传递给底层实现 collection，但这依赖于 Object 的 equals 和 hashCode 方法。在底层实现 collection 是一个 set 或是一个列表的情况下，有必要遵守这些操作的协定。

如果指定 collection 是可序列化的，则返回的 collection 也将是可序列化的。

参数：
c - 将为其返回一个不可修改视图的 collection。
返回：
指定 collection 的不可修改视图。

unmodifiableSet

public static <T> Set<T> unmodifiableSet(Set<? extends T> s)
返回指定 set 的不可修改视图。此方法允许模块为用户提供对内部 set 的“只读”访问。在返回的 set 上执行的查询操作将“读完”指定的 set。试图修改返回的 set（不管是直接修改还是通过其迭代器进行修改）将导致抛出 UnsupportedOperationException。

如果指定 set 是可序列化的，则返回的 set 也将是可序列化的。

参数：
s - 将为其返回一个不可修改视图的 set。
返回：
指定 set 的不可修改视图。

unmodifiableSortedSet

public static <T> SortedSet<T> unmodifiableSortedSet(SortedSet<T> s)
返回指定有序 set 的不可修改视图。此方法允许模块为用户提供对内部有序 set 的“只读”访问。在返回的有序 set 上执行的查询操作将“读完”指定的有序 set。试图修改返回的有序 set（无论是直接修改、通过其迭代器修改，还是通过其 subSet、headSet 或 tailSet 视图修改）将导致抛出 UnsupportedOperationException。

如果指定有序 set 是可序列化的，则返回的有序 set 也将是可序列化的。

参数：
s - 将为其返回一个不可修改视图的有序 set。
返回：
指定有序 set 的不可修改视图。

unmodifiableList

public static <T> List<T> unmodifiableList(List<? extends T> list)
返回指定列表的不可修改视图。此方法允许模块为用户提供对内部列表的“只读”访问。在返回的列表上执行的查询操作将“读完”指定的列表。试图修改返回的列表（不管是直接修改还是通过其迭代器进行修改）将导致抛出 UnsupportedOperationException。

如果指定列表是可序列化的，则返回的列表也将是可序列化的。类似地，如果指定列表实现 RandomAccess，则返回列表也将这样做。

参数：
list - 将为其返回一个不可修改视图的列表。
返回：
指定列表的不可修改视图。

unmodifiableMap

public static <K,V> Map<K,V> unmodifiableMap(Map<? extends K,? extends V> m)
返回指定映射的不可修改视图。此方法允许模块为用户提供对内部映射的“只读”访问。在返回的映射上执行的查询操作将“读完”指定的映射。试图修改返回的映射（不管是直接修改还是通过其 collection 视图进行修改）将导致抛出 UnsupportedOperationException。

如果指定映射是可序列化的，则返回的映射也将是可序列化的。

参数：
m - 将为其返回一个不可修改视图的映射。
返回：
指定映射的不可修改视图。

unmodifiableSortedMap

public static <K,V> SortedMap<K,V> unmodifiableSortedMap(SortedMap<K,? extends V> m)
返回指定有序映射的不可修改视图。此方法允许模块为用户提供对内部有序映射的“只读”访问。在返回的有序映射上执行的查询操作将“读完”指定的有序映射。试图修改返回的有序映射（无论是直接修改、通过其 collection 视图修改，还是通过其 subMap、headMap 或 tailMap 视图修改）将导致抛出 UnsupportedOperationException。

如果指定的有序映射是可序列化的，则返回的有序映射也将是可序列化的。

参数：
m - 将为其返回一个不可修改视图的有序映射。
返回：
指定有序映射的不可修改视图。

synchronizedCollection

public static <T> Collection<T> synchronizedCollection(Collection<T> c)
返回指定 collection 支持的同步（线程安全的）collection。为了保证按顺序访问，必须通过返回的 collection 完成所有对底层实现 collection 的访问。

在返回的 collection 上进行迭代时，用户必须手工在返回的 collection 上进行同步：

  Collection c = Collections.synchronizedCollection(myCollection);
     ...
  synchronized(c) {
      Iterator i = c.iterator(); // Must be in the synchronized block
      while (i.hasNext())
         foo(i.next());
  }
不遵从此建议将导致无法确定的行为。

返回的 collection 不会 将 hashCode 和 equals 操作传递给底层实现 collection，但这依赖于 Object 的 equals 和 hashCode 方法。在底层实现 collection 是一个 set 或一个列表的情况下，有必要遵守这些操作的协定。

如果指定 collection 是可序列化的，则返回的 collection 也将是可序列化的。

参数：
c - 被“包装”在同步 collection 中的 collection。
返回：
指定 collection 的同步视图。

synchronizedSet

public static <T> Set<T> synchronizedSet(Set<T> s)
返回指定 set 支持的同步（线程安全的）set。为了保证按顺序访问，必须通过返回的 set 完成对所有底层实现 set 的访问。

在返回的 set 上进行迭代时，用户必须手工在返回的 set 上进行同步：

  Set s = Collections.synchronizedSet(new HashSet());
      ...
  synchronized(s) {
      Iterator i = s.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
不遵从此建议将导致无法确定的行为。

如果指定 set 是可序列化的，则返回的 set 也将是可序列化的。

参数：
s - 被“包装”在同步 set 中的 set。
返回：
指定 set 的同步视图。

synchronizedSortedSet

public static <T> SortedSet<T> synchronizedSortedSet(SortedSet<T> s)
返回指定有序 set 支持的同步（线程安全的）有序 set。为了保证按顺序访问，必须通过返回的有序 set（或其视图）完成对所有底层实现有序 set 的访问。

在返回的有序 set 上或者其任意 subSet、headSet 或 tailSet 视图上进行迭代时，用户必须手工在返回的有序 set 上进行同步。

  SortedSet s = Collections.synchronizedSortedSet(new TreeSet());
      ...
  synchronized(s) {
      Iterator i = s.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
或者：
  SortedSet s = Collections.synchronizedSortedSet(new TreeSet());
  SortedSet s2 = s.headSet(foo);
      ...
  synchronized(s) {  // Note: s, not s2!!!
      Iterator i = s2.iterator(); // Must be in the synchronized block
      while (i.hasNext())
          foo(i.next());
  }
不遵从此建议将导致无法确定的行为。

如果指定的有序 set 是可序列化的，则返回的有序 set 也将是可序列化的。

参数：
s - 被“包装”在同步有序 set 中的有序 set。
返回：
指定有序 set 的同步视图。

synchronizedList

public static <T> List<T> synchronizedList(List<T> list)
返回指定列表支持的同步（线程安全的）列表。为了保证按顺序访问，必须通过返回的列表完成所有对底层实现列表的访问。

在返回的列表上进行迭代时，用户必须手工在返回的列表上进行同步：

  List list = Collections.synchronizedList(new ArrayList());
      ...
  synchronized(list) {
      Iterator i = list.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
不遵从此建议将导致无法确定的行为。

如果指定列表是可序列化的，则返回的列表也将是可序列化的。

参数：
list - 被“包装”在同步列表中的列表。
返回：
指定列表的同步视图。

synchronizedMap

public static <K,V> Map<K,V> synchronizedMap(Map<K,V> m)
返回由指定映射支持的同步（线程安全的）映射。为了保证按顺序访问，必须通过返回的映射完成所有对底层实现映射的访问。

在返回映射的任意 collection 视图上进行迭代时，用户必须手工在返回的映射上进行同步：

  Map m = Collections.synchronizedMap(new HashMap());
      ...
  Set s = m.keySet();  // Needn't be in synchronized block
      ...
  synchronized(m) {  // Synchronizing on m, not s!
      Iterator i = s.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
不遵从此建议将导致无法确定的行为。

如果指定映射是可序列化的，则返回的映射也将是可序列化的。

参数：
m - 被“包装”在同步映射中的映射。
返回：
指定映射的同步视图。

synchronizedSortedMap

public static <K,V> SortedMap<K,V> synchronizedSortedMap(SortedMap<K,V> m)
返回指定有序映射支持的同步（线程安全的）有序映射。为了保证按顺序访问，必须通过返回的有序映射（或其视图）完成对所有底层有序映射的访问。

当在返回的有序映射的 collection 视图或者其任何 subMap、headMap 或 tailMap 视图进行迭代时，用户必须手工在该映射上进行同步：

  SortedMap m = Collections.synchronizedSortedMap(new TreeMap());
      ...
  Set s = m.keySet();  // Needn't be in synchronized block
      ...
  synchronized(m) {  // Synchronizing on m, not s!
      Iterator i = s.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
或者：
  SortedMap m = Collections.synchronizedSortedMap(new TreeMap());
  SortedMap m2 = m.subMap(foo, bar);
      ...
  Set s2 = m2.keySet();  // Needn't be in synchronized block
      ...
  synchronized(m) {  // Synchronizing on m, not m2 or s2!
      Iterator i = s.iterator(); // Must be in synchronized block
      while (i.hasNext())
          foo(i.next());
  }
不遵从此建议将导致无法确定的行为。

如果指定的有序映射是可序列化的，则返回的有序映射也将是可序列化的。

参数：
m - 被“包装”在同步有序映射中的有序映射。
返回：
指定有序映射的同步视图。

checkedCollection

public static <E> Collection<E> checkedCollection(Collection<E> c,
                                                  Class<E> type)
返回指定 collection 的一个动态类型安全视图。试图插入一个错误类型的元素将导致立即抛出 ClassCastException。假设在生成动态类型安全视图之前，collection 不包含任何类型不正确的元素，并且所有对该 collection 的后续访问都通过该视图进行，则可以保证 该 collection 不包含类型不正确的元素。

一般的编程语言机制中都提供了编译时（静态）类型检查，但是一些未经检查的强制转换可能会使此机制无效。通常这不是一个问题，因为编译器会在所有这类未经检查的操作上发出警告。但有的时候，只进行单独的静态类型检查并不够。例如，假设将 collection 传递给一个第三方库，则库代码不能通过插入一个错误类型的元素来毁坏 collection。

动态类型安全视图的另一个用途是调试。假设某个程序运行失败并抛出 ClassCastException，这指示一个类型不正确的元素被放入已参数化 collection 中。不幸的是，该异常可以发生在插入错误元素之后的任何时间，因此，这通常只能提供很少或无法提供任何关于问题真正来源的信息。如果问题是可再现的，那么可以暂时修改程序，使用一个动态类型安全视图来包装该 collection，通过这种方式可快速确定问题的来源。例如，以下声明：

     Collection<String> c = new HashSet<String>();
可以暂时用下面的声明代替：
     Collection<String> c = Collections.checkedCollection(
         new HashSet<String>(), String.class);
再次运行程序会造成它在将类型不正确的元素插入 collection 的地方失败，从而清楚地识别问题的来源。问题得以解决后，可以将修改后的声明转换回原来的声明。

返回的 collection 不会 将 hashCode 和 equals 操作传递给底层实现 collection，但这依赖于 Object 的 equals 和 hashCode 方法。在底层实现 collection 是一个 set 或一个列表的情况下，有必要遵守这些操作的协定。

如果指定 collection 是可序列化的，则返回的 collection 也将是可序列化的。

参数：
c - 将返回其动态类型安全视图的 collection
type - 允许 c 持有的元素类型
返回：
指定 collection 的动态安全类型视图
从以下版本开始：
1.5

checkedSet

public static <E> Set<E> checkedSet(Set<E> s,
                                    Class<E> type)
返回指定 set 的一个动态类型安全视图。试图插入一个错误类型的元素将导致立即抛出 ClassCastException。假设在生成动态类型安全视图之前，set 不包含任何类型不正确的元素，并且所有对该 set 的后续访问都通过该视图进行，则可以保证 该 set 不包含类型不正确的元素。

可以在 checkedCollection 方法的文档中找到有关使用动态类型安全视图的讨论。

如果指定 set 是可序列化的，则返回的 set 也将是可序列化的。

参数：
s - 将返回其动态类型安全视图的 set
type - 允许 s 持有的元素类型
返回：
指定 set 的动态安全类型视图
从以下版本开始：
1.5

checkedSortedSet

public static <E> SortedSet<E> checkedSortedSet(SortedSet<E> s,
                                                Class<E> type)
返回指定有序 set 的一个动态类型安全视图。试图插入一个错误类型的元素将导致立即抛出 ClassCastException。假设在生成动态类型安全视图之前，有序 set 不包含任何类型不正确的元素，并且所有对该有序 set 的后续访问都通过该视图进行，则可以保证 该有序 set 不包含类型不正确的元素。

可以在 checkedCollection 方法的文档中找到有关使用动态类型安全视图的讨论。

如果指定的有序 set 是可序列化的，则返回的有序 set 也将是可序列化的。

参数：
s - 将返回其动态类型安全视图的 set
type - 允许 s 持有的元素类型
返回：
指定有序 set 的动态安全类型视图
从以下版本开始：
1.5

checkedList

public static <E> List<E> checkedList(List<E> list,
                                      Class<E> type)
返回指定列表的一个动态类型安全视图。试图插入一个错误类型的元素将导致立即抛出 ClassCastException。假设在生成动态类型安全视图之前，列表不包含任何类型不正确的元素，并且所有对该列表的后续访问都通过该视图进行，则可以保证 此列表不包含类型不正确的元素。

可以在 checkedCollection 方法的文档中找到有关使用动态类型安全视图的讨论。

如果指定列表是可序列化的，则返回的列表也将是可序列化的。

参数：
list - 将返回其动态类型安全视图的列表
type - 允许 list 持有的元素类型
返回：
指定列表的一个动态安全类型视图
从以下版本开始：
1.5

checkedMap

public static <K,V> Map<K,V> checkedMap(Map<K,V> m,
                                        Class<K> keyType,
                                        Class<V> valueType)
返回指定映射的一个动态类型安全视图。试图插入一个具有错误类型键或值的映射关系将导致立即抛出 ClassCastException。类似地，试图修改当前与键关联的值（无论是直接通过映射自身，还是通过一个从该映射项集视图中获得的 Map.Entry 实例）都将导致立即抛出 ClassCastException。

假设在生成动态类型安全视图之前，映射中不包含任何类型不正确的键或值，并且所有对映射的后续访问都通过该视图（或其 collection 视图之一）进行，则可以保证 该映射不包含类型不正确的键或值。

可以在 checkedCollection 方法的文档中找到有关使用动态类型安全视图的讨论。

如果指定映射是可序列化的，则返回的映射也将是可序列化的。

参数：
m - 将返回其动态类型安全视图的映射
keyType - 允许 m 持有的键类型
valueType - 允许 m 持有的值类型
返回：
指定映射的动态类型安全视图
从以下版本开始：
1.5

checkedSortedMap

public static <K,V> SortedMap<K,V> checkedSortedMap(SortedMap<K,V> m,
                                                    Class<K> keyType,
                                                    Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。试图插入一个具有错误类型键或值的映射关系将导致立即抛出 ClassCastException。类似地，试图修改当前与键关联的值（无论是直接通过映射自身，还是通过一个从该映射项集视图中获得的 Map.Entry 实例）将导致立即抛出 ClassCastException。

假设在生成动态类型安全视图之前，映射中不包含任何类型不正确的键或值，并且所有对映射的后续访问都通过该视图（或其 collection 视图之一）进行，则可以保证 此映射不包含类型不正确的键或值。

可以在 checkedCollection 方法的文档中找到有关使用动态类型安全视图的讨论。

如果指定映射是可序列化的，则返回的映射也将是可序列化的。

参数：
m - 将返回其动态类型安全视图的映射
keyType - 允许 m 持有的键的类型
valueType - 允许 m 持有的值的类型
返回：
指定映射的动态类型安全视图
从以下版本开始：
1.5

emptySet

public static final <T> Set<T> emptySet()
返回空的 set（不可变的）。此 set 是可序列化的。与 like-named 字段不同，此方法是参数化的。

以下示例演示了获得空 set 的类型安全 (type-safe) 方式：

     Set<String> s = Collections.emptySet();
实现注意事项：实现此方法不需要为每次调用创建一个单独的 Set 对象。使用此方法的开销与使用 like-named 字段相当。（与此方法不同，该字段不提供类型安全。）

从以下版本开始：
1.5
另请参见：
EMPTY_SET

emptyList

public static final <T> List<T> emptyList()
返回空的列表（不可变的）。此列表是可序列化的。

以下示例演示了获得空列表的类型安全方式：

     List<String> s = Collections.emptyList();
实现注意事项：实现此方法不需要为每次调用创建一个单独的 List 对象。使用此方法的开销与使用 like-named 字段相当。（与此方法不同，该字段不提供类型安全。）

从以下版本开始：
1.5
另请参见：
EMPTY_LIST

emptyMap

public static final <K,V> Map<K,V> emptyMap()
返回空的映射（不可变的）。此映射是可序列化的。

以下示例演示了获得空 set 的类型安全方式：

     Map<String, Date> s = Collections.emptyMap();
实现注意事项：实现此方法不需要为每次调用创建一个单独的 Map 对象。使用此方法的开销与使用 like-named 字段相当。（与此方法不同，该字段不提供类型安全。）

从以下版本开始：
1.5
另请参见：
EMPTY_MAP

singleton

public static <T> Set<T> singleton(T o)
返回一个只包含指定对象的不可变 set。返回的 set 是可序列化的。

参数：
o - 将存储到返回 set 中的单独对象。
返回：
一个只包含指定对象的不可变 set。

singletonList

public static <T> List<T> singletonList(T o)
返回一个只包含指定对象的不可变列表。返回的列表是可序列化的。

参数：
o - 将存储到返回列表中的单独对象。
返回：
一个只包含指定对象的不可变列表。
从以下版本开始：
1.3

singletonMap

public static <K,V> Map<K,V> singletonMap(K key,
                                          V value)
返回一个不可变的映射，它只将指定键映射到指定值。返回的映射是可序列化的。

参数：
key - 将存储到返回映射中的单独键。
value - 返回的映射将 key 映射到的值。
返回：
只包含指定键-值映射关系的不可变映射。
从以下版本开始：
1.3

nCopies

public static <T> List<T> nCopies(int n,
                                  T o)
返回由指定对象的 n 个副本组成的不可变列表。新分配的数据对象非常小（它只包含一个对该数据对象的引用）。在通过与 List.addAll 方法组合来增大列表时，此方法很有用。返回的列表是可序列化的。

参数：
n - 返回列表中的元素数。
o - 重复出现在返回列表中的元素。
返回：
由指定对象 n 个副本组成的不可变列表。
抛出：
IllegalArgumentException - 如果 n < 0。
另请参见：
List.addAll(Collection), List.addAll(int, Collection)

reverseOrder

public static <T> Comparator<T> reverseOrder()
返回一个比较器，它强行逆转实现了 Comparable 接口的对象 collection 的自然顺序。（自然顺序是通过对象自身的 compareTo 方法强行排序的。）此方法允许使用单个语句，以逆自然顺序对实现了 Comparable 接口的对象 collection（或数组）进行排序（或维护）。例如，假设 a 是一个字符串数组。那么：
                Arrays.sort(a, Collections.reverseOrder());
将按照逆字典（字母）顺序对数组进行排序。

返回的比较器是可序列化的。

返回：
返回一个比较器，它强行逆转实现了 Comparable 接口的对象 collection 的自然顺序。
另请参见：
Comparable

reverseOrder

public static <T> Comparator<T> reverseOrder(Comparator<T> cmp)
返回一个比较器，它强行逆转指定比较器的顺序。如果指定比较器为 null，则此方法等同于 reverseOrder()（换句话说，它返回一个比较器，该比较器将强行逆转实现了 Comparable 接口的对象 collection 的自然顺序）。

返回的比较器是可序列化的（假设指定的比较器也是可序列化的或者为 null）。

返回：
强行逆转指定比较器顺序的比较器。
从以下版本开始：
1.5

enumeration

public static <T> Enumeration<T> enumeration(Collection<T> c)
返回一个指定 collection 上的枚举。此方法提供与遗留 API 的互操作性，遗留 API 需要一个枚举作为输入。

参数：
c - 将返回其枚举的 collection。
返回：
指定 collection 上的一个枚举。
另请参见：
Enumeration

list

public static <T> ArrayList<T> list(Enumeration<T> e)
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。此方法提供返回枚举的遗留 API 与需要 collection 的新 API 之间的互操作性。

参数：
e - 为返回的数组列表提供元素的枚举
返回：
包含指定枚举返回元素的数组列表。
从以下版本开始：
1.4
另请参见：
Enumeration, ArrayList

frequency

public static int frequency(Collection<?> c,
                            Object o)
返回指定 collection 中等于指定对象的元素数。更确切地讲，返回 collection 中满足 (o == null ? e == null : o.equals(e)) 的 e 元素的数量。

参数：
c - 在其中确定 o 出现频率的 collection
o - 将确定出现频率的对象
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.5

disjoint

public static boolean disjoint(Collection<?> c1,
                               Collection<?> c2)
如果两个指定 collection 中没有相同的元素，则返回 true。

如果将此方法用在不符合 Collection 常规协定的 collection 上，则必须小心。实现可以在任一 collection 上进行迭代，测试元素是否包含在另一个 collection 中（或执行任何等效的计算）。如果任一 collection 使用了一个非标准的相等性测试（比如顺序不是与 equals 一致的 SortedSet，或者 IdentityHashMap 的键集），则两个 collection 都必须使用相同的非标准相等性测试，否则此方法的结果是不确定的。

注意，允许在两个参数中传递相同的 collection，在这种情况下，当且仅当 collection 为空时此方法返回 true。

参数：
c1 - 一个 collection
c2 - 一个 collection
抛出：
NullPointerException - 如果任一 collection 为 null
从以下版本开始：
1.5

addAll

public static <T> boolean addAll(Collection<? super T> c,
                                 T... elements)
将所有指定元素添加到指定 collection 中。可以分别指定要添加的元素，或者将它们指定为一个数组。此便捷方法的行为与 c.addAll(Arrays.asList(elements)) 的行为是相同的，但在大多数实现下，此方法运行起来可能要快得多。

在分别指定元素时，此方法提供了将少数元素添加到现有 collection 中的一个便捷方式：

     Collections.addAll(flavors, "Peaches 'n Plutonium", "Rocky Racoon");

参数：
c - 要插入 elements 的 collection
elements - 插入 c 的元素
返回：
如果 collection 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果 c 不支持 add 操作
NullPointerException - 如果 elements 包含一个或多个 null 值并且 c 不允许使用 null 元素，或者 c 或 elements 为 null
IllegalArgumentException - 如果 elements 中值的某个属性不允许将它添加到 c 中
从以下版本开始：
1.5
另请参见：
Collection.addAll(Collection)

newSetFromMap

public static <E> Set<E> newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。得到的 set 与底层实现映射有相同的顺序、并发性和性能特征。事实上，此工厂方法提供了一个对应于任何 Map 实现的 Set 实现。不必在已经有一个对应 Set 实现（比如 HashMap 或 TreeMap）的 Map 实现上使用此方法。

每次在此方法返回的 set 上调用方法都将导致在底层实现映射或其 keySet 视图上调用该方法一次，并伴随一个异常。addAll 方法是作为底层实现映射上的 put 调用序列实现的。

在调用此方法时，指定映射必须为空，并且不能在此方法返回之后直接访问。如果将映射创建为空，直接传递给此方法，并且没有保留对该映射的引用，则这些条件都可以得到保证，如以下代码片段所示：

    Set<Object> weakHashSet = Collections.newSetFromMap(
        new WeakHashMap<Object, Boolean>());

参数：
map - 底层实现映射
返回：
受映射支持的 set
抛出：
IllegalArgumentException - 如果 map 不为空
从以下版本开始：
1.6

asLifoQueue

public static <T> Queue<T> asLifoQueue(Deque<T> deque)
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。方法 add 被映射到 push，remove 被映射到 pop 等等。在希望使用某一方法获取一个 Queue 并且需要它具有 Lifo 顺序时，此方法很有用。

每次在此方法返回的队列上调用方法都将导致在底层实现队列上调用该方法一次，并伴随一个异常。addAll 方法是作为底层实现队列上的 addFirst 调用序列实现的。

参数：
deque - 队列
返回：
队列
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Comparator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Comparator<T>

类型参数：
T - 此 Comparator 可以比较的对象类型
所有已知实现类：
Collator, RuleBasedCollator
public interface Comparator<T>

强行对某个对象 collection 进行整体排序 的比较函数。可以将 Comparator 传递给 sort 方法（如 Collections.sort 或 Arrays.sort），从而允许在排序顺序上实现精确控制。还可以使用 Comparator 来控制某些数据结构（如有序 set或有序映射）的顺序，或者为那些没有自然顺序的对象 collection 提供排序。

当且仅当对于一组元素 S 中的每个 e1 和 e2 而言，c.compare(e1, e2)==0 与 e1.equals(e2) 具有相等的布尔值时，Comparator c 强行对 S 进行的排序才叫做与 equals 一致 的排序。

当使用具有与 equals 不一致的强行排序能力的 Comparator 对有序 set（或有序映射）进行排序时，应该小心谨慎。假定一个带显式 Comparator c 的有序 set（或有序映射）与从 set S 中抽取出来的元素（或键）一起使用。如果 c 强行对 S 进行的排序是与 equals 不一致的，那么有序 set（或有序映射）将是行为“怪异的”。尤其是有序 set（或有序映射）将违背根据 equals 所定义的 set（或映射）的常规协定。

例如，假定使用 Comparator c 将满足 (a.equals(b) && c.compare(a, b) != 0) 的两个元素 a 和 b 添加到一个空 TreeSet 中，则第二个 add 操作将返回 true（树 set 的大小将会增加），因为从树 set 的角度来看，a 和 b 是不相等的，即使这与 Set.add 方法的规范相反。

注：通常来说，让 Comparator 也实现 java.io.Serializable 是一个好主意，因为它们在可序列化的数据结构（像 TreeSet、TreeMap）中可用作排序方法。为了成功地序列化数据结构，Comparator（如果已提供）必须实现 Serializable。

在算术上，定义给定 Comparator c 对给定对象 set S 实施强行排序 的关系式 为：

       {(x, y) such that c.compare(x, y) <= 0}.
此整体排序的商 (quotient) 为：
       {(x, y) such that c.compare(x, y) == 0}.
它直接遵循 compare 的协定，商是 S 上的等价关系，强行排序是 S 上的整体排序。当我们说 c 强行对 S 的排序是与 equals 一致 的时，意思是说排序的商是对象的 equals(Object) 方法所定义的等价关系：
       {(x, y) such that x.equals(y)}.

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Comparable, Serializable

方法摘要
int | compare(T o1, T o2) 比较用来排序的两个参数。
boolean | equals(Object obj) 指示某个其他对象是否“等于”此 Comparator。

方法详细信息

compare

int compare(T o1,
            T o2)
比较用来排序的两个参数。根据第一个参数小于、等于或大于第二个参数分别返回负整数、零或正整数。

在前面的描述中，符号 sgn(expression) 表示 signum 数学函数，根据 expression 的值为负数、0 还是正数，该函数分别返回 -1、0 或 1。

实现程序必须确保对于所有的 x 和 y 而言，都存在 sgn(compare(x, y)) == -sgn(compare(y, x))。（这意味着当且仅当 compare(y, x) 抛出异常时 compare(x, y) 才必须抛出异常。）

实现程序还必须确保关系是可传递的：((compare(x, y)>0) && (compare(y, z)>0)) 意味着 compare(x, z)>0。

最后，实现程序必须确保 compare(x, y)==0 意味着对于所有的 z 而言，都存在 sgn(compare(x, z))==sgn(compare(y, z))。

虽然这种情况很普遍，但并不 严格要求 (compare(x, y)==0) == (x.equals(y))。一般说来，任何违背这个条件的 Comparator 都应该清楚地指出这一事实。推荐的语言是“注意：此 Comparator 强行进行与 equals 不一致的排序。”

参数：
o1 - 要比较的第一个对象。
o2 - 要比较的第二个对象。
返回：
根据第一个参数小于、等于或大于第二个参数分别返回负整数、零或正整数。
抛出：
ClassCastException - 如果参数的类型不允许此 Comparator 对它们进行比较。

equals

boolean equals(Object obj)
指示某个其他对象是否“等于”此 Comparator。此方法必须遵守 Object.equals(Object) 的常规协定。此外，仅当 指定的对象也是一个 Comparator，并且强行实施与此 Comparator 相同的排序时，此方法才返回 true。因此，comp1.equals(comp2) 意味着对于每个对象引用 o1 和 o2 而言，都存在 sgn(comp1.compare(o1, o2))==sgn(comp2.compare(o1, o2))。

注意，不 重写 Object.equals(Object) 方法总是 安全的。然而，在某些情况下，重写此方法可以允许程序确定两个不同的 Comparator 是否强行实施了相同的排序，从而提高性能。

覆盖：
类 Object 中的 equals
参数：
obj - 要进行比较的引用对象。
返回：
仅当指定的对象也是一个 Comparator，并且强行实施与此 Comparator 相同的排序时才返回 true。
另请参见：
Object.equals(Object), Object.hashCode()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Currency (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Currency

java.lang.Object
    继承者  java.util.Currency
所有已实现的接口：
Serializable
public final class Currency
extends Object
implements Serializable

表示货币。货币由 ISO 4217 货币代码标识。有关此内容的详细消息（包括货币代码表），请访问 BSi 网站 。

该类的设计目标是：对于任何指定货币，从不会有多个 Currency 实例。因此，没有公共的构造方法。可以使用 getInstance 方法获得 Currency 实例。

从以下版本开始：
1.4
另请参见：
序列化表格

方法摘要
String | getCurrencyCode() 获取此货币的 ISO 4217 货币代码。
int | getDefaultFractionDigits() 获取与此货币一起使用的默认小数位数。
static Currency | getInstance(Locale locale) 返回给定语言环境的国家/地区的 Currency 实例。
static Currency | getInstance(String currencyCode) 返回给定货币代码的 Currency 实例。
String | getSymbol() 获取默认语言环境的货币符号。
String | getSymbol(Locale locale) 获取指定语言环境的货币符号。
String | toString() 返回此货币的 ISO 4217 货币代码。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getInstance

public static Currency getInstance(String currencyCode)
返回给定货币代码的 Currency 实例。

参数：
currencyCode - 货币的 ISO 4217 代码
返回：
给定货币代码的 Currency 实例
抛出：
NullPointerException - 如果 currencyCode 为 null
IllegalArgumentException - 如果 currencyCode 不是受支持 ISO 4217 代码。

getInstance

public static Currency getInstance(Locale locale)
返回给定语言环境的国家/地区的 Currency 实例。忽略语言环境的语言和变量组件。因为国家/地区会改变其货币，所以结果可能随时间而变化。例如，对于欧洲货币联盟的最初成员国，该方法在 2001 年 12 月 31 日前返回旧的国家/地区货币，从 2002 年 1 月 1 日（各自国家/地区的本地时间）起返回欧元。

对于没有货币的地区（比如南极洲），该方法返回 null。

参数：
locale - 该语言环境的国家/地区需要 Currency 实例
返回：
给定语言环境的国家/地区的 Currency 实例，或者 null
抛出：
NullPointerException - 如果 locale 或其国家/地区代码为 null
IllegalArgumentException - 如果给定语言环境的国家/地区不是受支持的 ISO 3166 国家/地区代码。

getCurrencyCode

public String getCurrencyCode()
获取此货币的 ISO 4217 货币代码。

返回：
此货币的 ISO 4217 货币代码。

getSymbol

public String getSymbol()
获取默认语言环境的货币符号。例如，对于美元，如果默认语言环境是美国，则符号是 "$"，而对于其他语言环境，它可能是 "US$"。如果无法确定符号，则返回 ISO 4217 货币代码。

返回：
默认语言环境的货币符号

getSymbol

public String getSymbol(Locale locale)
获取指定语言环境的货币符号。例如，对于美元，如果指定语言环境是美国，则符号是 "$"，而对于其他语言环境，它可能是 "US$"。如果无法确定符号，则返回 ISO 4217 货币代码。

参数：
locale - 需要显示此货币名称的语言环境
返回：
指定语言环境的货币符号
抛出：
NullPointerException - 如果 locale 为 null

getDefaultFractionDigits

public int getDefaultFractionDigits()
获取与此货币一起使用的默认小数位数。例如对于欧元，默认的小数位数为 2，而对于日元，则为 0。对于伪货币（如 IMF Special Drawing Rights），则返回 -1。

返回：
此货币使用的默认小数位数

toString

public String toString()
返回此货币的 ISO 4217 货币代码。

覆盖：
类 Object 中的 toString
返回：
此货币的 ISO 4217 货币代码
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConcurrentModificationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ConcurrentModificationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.util.ConcurrentModificationException
所有已实现的接口：
Serializable
public class ConcurrentModificationException
extends RuntimeException

当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。

例如，某个线程在 Collection 上进行迭代时，通常不允许另一个线性修改该 Collection。通常在这些情况下，迭代的结果是不确定的。如果检测到这种行为，一些迭代器实现（包括 JRE 提供的所有通用 collection 实现）可能选择抛出此异常。执行该操作的迭代器称为快速失败 迭代器，因为迭代器很快就完全失败，而不会冒着在将来某个时间任意发生不确定行为的风险。

注意，此异常不会始终指出对象已经由不同 线程并发修改。如果单线程发出违反对象协定的方法调用序列，则该对象可能抛出此异常。例如，如果线程使用快速失败迭代器在 collection 上迭代时直接修改该 collection，则迭代器将抛出此异常。

注意，迭代器的快速失败行为无法得到保证，因为一般来说，不可能对是否出现不同步并发修改做出任何硬性保证。快速失败操作会尽最大努力抛出 ConcurrentModificationException。因此，为提高此类操作的正确性而编写一个依赖于此异常的程序是错误的做法，正确做法是：ConcurrentModificationException 应该仅用于检测 bug。

从以下版本开始：
1.2
另请参见：
Collection, Iterator, ListIterator, Vector, LinkedList, HashSet, Hashtable, TreeMap, AbstractList, 序列化表格

构造方法摘要
ConcurrentModificationException()
构造不带详细消息的 ConcurrentModificationException。
ConcurrentModificationException(String message)
构造带指定详细消息的 ConcurrentModificationException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConcurrentModificationException

public ConcurrentModificationException()
构造不带详细消息的 ConcurrentModificationException。

ConcurrentModificationException

public ConcurrentModificationException(String message)
构造带指定详细消息的 ConcurrentModificationException。

参数：
message - 和该异常有关的详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Date (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Date

java.lang.Object
    继承者  java.util.Date
所有已实现的接口：
Serializable, Cloneable, Comparable<Date>
直接已知子类：
Date, Time, Timestamp
public class Date
extends Object
implements Serializable, Cloneable, Comparable<Date>

类 Date 表示特定的瞬间，精确到毫秒。

在 JDK 1.1 之前，类 Date 有两个其他的函数。它允许把日期解释为年、月、日、小时、分钟和秒值。它也允许格式化和解析日期字符串。不过，这些函数的 API 不易于实现国际化。从 JDK 1.1 开始，应该使用 Calendar 类实现日期和时间字段之间转换，使用 DateFormat 类来格式化和解析日期字符串。Date 中的相应方法已废弃。

尽管 Date 类打算反映协调世界时 (UTC)，但无法做到如此准确，这取决于 Java 虚拟机的主机环境。当前几乎所有操作系统都假定 1 天 = 24 × 60 × 60 = 86400 秒。但对于 UTC，大约每一两年出现一次额外的一秒，称为“闰秒”。闰秒始终作为当天的最后一秒增加，并且始终在 12 月 31 日或 6 月 30 日增加。例如，1995 年的最后一分钟是 61 秒，因为增加了闰秒。大多数计算机时钟不是特别的准确，因此不能反映闰秒的差别。

一些计算机标准是按照格林威治标准时 (GMT) 定义的，格林威治标准时和世界时 (UT) 是相等的。GMT 是标准的“民间”名称；UT 是相同标准的“科学”名称。UTC 和 UT 的区别是：UTC 是基于原子时钟的，UT 是基于天体观察的，两者在实际应用中难分轩轾。因为地球的旋转不是均匀的（它以复杂的方式减速和加速），所以 UT 始终不是均匀地流过。闰秒是根据需要引入 UTC 的，以便把 UTC 保持在 UT1 的 0.9 秒之内，UT1 是应用了某些更正的 UT 版本。还有其他的时间和日期系统；例如，基于卫星的全球定位系统 (GPS) 使用的时间刻度与 UTC 同步，但没有 针对闰秒进行调整。有关更多信息的一个有趣来源是美国海军天文台，特别是 Directorate of Time 的网址：

     http://tycho.usno.navy.mil

还有它们对 "Systems of Time" 的定义，网址为：

     http://tycho.usno.navy.mil/systime.html

在类 Date 所有可以接受或返回年、月、日期、小时、分钟和秒值的方法中，将使用下面的表示形式：

  • 年份 y 由整数 y - 1900 表示。
  • 月份由从 0 至 11 的整数表示；0 是一月、1 是二月等等；因此 11 是十二月。
  • 日期（一月中的某天）按通常方式由整数 1 至 31 表示。
  • 小时由从 0 至 23 的整数表示。因此，从午夜到 1 a.m. 的时间是 0 点，从中午到 1 p.m. 的时间是 12 点。
  • 分钟按通常方式由 0 至 59 的整数表示。
  • 秒由 0 至 61 的整数表示；值 60 和 61 只对闰秒发生，尽管那样，也只用在实际正确跟踪闰秒的 Java 实现中。于按当前引入闰秒的方式，两个闰秒在同一分钟内发生是极不可能的，但此规范遵循 ISO C 的日期和时间约定。

在所有情形中，针对这些目的赋予方法的参数不需要在指定的范围内；例如，可以把日期指定为 1 月 32 日，并把它解释为 2 月 1 日的相同含义。

从以下版本开始：
JDK1.0
另请参见：
DateFormat, Calendar, TimeZone, 序列化表格

构造方法摘要
Date()
分配 Date 对象并初始化此对象，以表示分配它的时间（精确到毫秒）。
Date(int year, int month, int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date) 或 GregorianCalendar(year + 1900, month, date) 取代。
Date(int year, int month, int date, int hrs, int min)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min) 或 GregorianCalendar(year + 1900, month, date, hrs, min) 取代。
Date(int year, int month, int date, int hrs, int min, int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代。
Date(long date)
分配 Date 对象并初始化此对象，以表示自从标准基准时间（称为“历元（epoch）”，即 1970 年 1 月 1 日 00:00:00 GMT）以来的指定毫秒数。
Date(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
方法摘要
 boolean after(Date when)
测试此日期是否在指定日期之后。
 boolean before(Date when)
测试此日期是否在指定日期之前。
 Object clone()
返回此对象的副本。
 int compareTo(Date anotherDate)
比较两个日期的顺序。
 boolean equals(Object obj)
比较两个日期的相等性。
 int getDate()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_MONTH) 取代。
 int getDay()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_WEEK) 取代。
 int getHours()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.HOUR_OF_DAY) 取代。
 int getMinutes()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MINUTE) 取代。
 int getMonth()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MONTH) 取代。
 int getSeconds()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.SECOND) 取代。
 long getTime()
返回自 1970 年 1 月 1 日 00:00:00 GMT 以来此 Date 对象表示的毫秒数。
 int getTimezoneOffset()
已过时。 从 JDK 1.1 开始，由 -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 取代。
 int getYear()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.YEAR) - 1900 取代。
 int hashCode()
返回此对象的哈希码值。
static long parse(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。
 void setDate(int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.DAY_OF_MONTH, int date) 取代。
 void setHours(int hours)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.HOUR_OF_DAY, int hours) 取代。
 void setMinutes(int minutes)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MINUTE, int minutes) 取代。
 void setMonth(int month)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MONTH, int month) 取代。
 void setSeconds(int seconds)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.SECOND, int seconds) 取代。
 void setTime(long time)
设置此 Date 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。
 void setYear(int year)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.YEAR, year + 1900) 取代。
 String toGMTString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。
 String toLocaleString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。
 String toString()
把此 Date 对象转换为以下形式的 String： dow mon dd hh:mm:ss zzz yyyy 其中： dow 是一周中的某一天 (Sun, Mon, Tue, Wed, Thu, Fri, Sat)。
static long UTC(int year, int month, int date, int hrs, int min, int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代，使用 UTC TimeZone，后跟 Calendar.getTime().getTime()。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Date

public Date()
分配 Date 对象并初始化此对象，以表示分配它的时间（精确到毫秒）。

另请参见：
System.currentTimeMillis()

Date

public Date(long date)
分配 Date 对象并初始化此对象，以表示自从标准基准时间（称为“历元（epoch）”，即 1970 年 1 月 1 日 00:00:00 GMT）以来的指定毫秒数。

参数：
date - 自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。
另请参见：
System.currentTimeMillis()

Date

@Deprecated
public Date(int year,
                       int month,
                       int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date) 或 GregorianCalendar(year + 1900, month, date) 取代。

分配 Date 对象并初始化此对象，以表示由 year、month 和 date 参数指定的一天的开始时间（本地时间晚上 12 时）。

参数：
year - 减 1900 的年份。
month - 0-11 的月份。
date - 一月中 1-31 之间的某一天。
另请参见：
Calendar

Date

@Deprecated
public Date(int year,
                       int month,
                       int date,
                       int hrs,
                       int min)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min) 或 GregorianCalendar(year + 1900, month, date, hrs, min) 取代。

分配 Date 对象并初始化此对象，以表示本地时区中由 year、month、date、hrs 和 min 参数指定的分钟的开始瞬间。

参数：
year - 减 1900 的年份。
month - 0-11 之间的月份。
date - 一月中 1-31 之间的某一天。
hrs - 0-23 之间的小时数。
min - 0-59 之间的分钟数。
另请参见：
Calendar

Date

@Deprecated
public Date(int year,
                       int month,
                       int date,
                       int hrs,
                       int min,
                       int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代。

分配 Date 对象，并初始化此对象，以表示本地时区中由 year、month、date、hrs、min 和 sec 参数指定的秒的开始瞬间。

参数：
year - 减 1900 的年份。
month - 0-11 之间的月份。
date - 一月中 1-31 之间的某一天。
hrs - 0-23 之间的小时数。
min - 0-59 之间的分钟数。
sec - 0-59 之间的秒数。
另请参见：
Calendar

Date

@Deprecated
public Date(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

分配 Date 对象并初始化此对象，以表示字符串 s 指出的日期和时间，就像通过 parse(java.lang.String) 方法解释一样。

参数：
s - 日期的字符串表示形式。
另请参见：
DateFormat, parse(java.lang.String)
方法详细信息

clone

public Object clone()
返回此对象的副本。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

UTC

@Deprecated
public static long UTC(int year,
                                  int month,
                                  int date,
                                  int hrs,
                                  int min,
                                  int sec)
已过时。 从 JDK 1.1 开始，由 Calendar.set(year + 1900, month, date, hrs, min, sec) 或 GregorianCalendar(year + 1900, month, date, hrs, min, sec) 取代，使用 UTC TimeZone，后跟 Calendar.getTime().getTime()。

根据参数确定日期和时间。这些参数被解释为年份、月份、月中某一天、一天中的某一小时、小时中某一分钟和分钟中的某一秒。除了相对于 UTC 而不是本地时区解释这些参数之外，该方法与带 6 个参数的 Date 构造方法完全相同。该方法将返回指示的时间，用该时间与历元（1970 年 1 月 1 日，00:00:00 GMT）的时间差来表示（以毫秒为单位）。

参数：
year - 减 1900 的年份。
month - 0-11 之间的月份。
date - 一月中 1-31 之间的某一天。
hrs - 0-23 之间的小时数。
min - 0-59 之间的分钟数。
sec - 0-59 之间的秒数。
返回：
对于参数指定的日期和时间，返回自 1970 年 1 月 1 日 00:00:00 GMT 以来的毫秒数。
另请参见：
Calendar

parse

@Deprecated
public static long parse(String s)
已过时。 从 JDK 1.1 开始，由 DateFormat.parse(String s) 取代。

尝试把字符串 s 解释为日期和时间的表示形式。如果尝试成功，则返回指示的时间，用该时间与历元（1970 年 1 月 1 日，00:00:00 GMT）的时间差来表示（以毫秒为单位）。如果尝试失败，则抛出 IllegalArgumentException。

它接受许多语法；特别是它识别 IETF 标准日期语法："Sat, 12 Aug 1995 13:30:00 GMT"。它也了解美国大陆时区缩写，但对于一般用途，应该使用时区偏移量："Sat, 12 Aug 1995 13:30:00 GMT+0430"（比格林威治子午线晚 4 小时 30 分）。如果没有指定时区，则假定用本地时区。GMT 和 UTC 被认为是相同的。

系统将从左到右处理字符串 s，从中查找相应的数据。s 中包括在 ASCII 括号字符 ( 和 ) 中的任何内容都将被忽略。括号可以进行嵌套。另外，s 中只允许使用以下 ASCII 字符：

 abcdefghijklmnopqrstuvwxyz
 ABCDEFGHIJKLMNOPQRSTUVWXYZ
 0123456789,+-:/
以及空白字符。

连续的十进制位序列被当成十进制数：

  • 如果数字前面有 + 或 -，并且已经识别了年份，那么数字就是一个时区偏移量。如果数字少于 24，那么它是以小时进行测量的偏移量。否则，它被认为是以分钟进行测量的偏移量，用没有标点的 24 小时时间格式来表示。前面的 - 意味着向西的偏移量。时区偏移量始终相对于 UTC（格林威治）。因此，例如，在字符串中出现的 -5 意味着“比格林威治时间晚 5 小时”，+0430 将意味着“比格林威治时间早 4 小时 30 分”。允许字符串冗余地指定 GMT、UT 或 UTC——例如，GMT-5 或 utc+0430。
  • 如果下面条件之一为真，数字就被认为是年数：
    • 数字等于或大于 70，并且后跟一个空格、逗号、斜杠或结束字符串
    • 数字小于 70，并且已经识别月份和月中的某一天
    如果被识别的年数小于 100，它就被解释为相对于其日期所在世纪的缩写年，缩写年的日期位于初始化 Date 类的时间的 80 年以前和 19 年以后之间。在调整年数后，从其减去 1900。例如，如果当前的年份是 1999，那么范围 19 至 99 的年数就被假定表示 1919 至 1999，而 0 至 18 的年数就被假定表示 2000 至 2018。注意，这与 SimpleDateFormat 中使用的小于 100 的年份具有稍微不同的解释。
  • 如果数字后跟一个冒号，则认为是小时，如果小时已经被识别，则认为是分钟。
  • 如果数字后跟一个斜杠，则认为是月份（把它减 1，以便产生范围 0 至 11 的数字），如果月份已经被识别，则认为它是月中的某一天。
  • 如果数字后跟空白、逗号、连字符或结束字符串，那么如果小时已识别但分钟未识别，则认为是分钟；否则，如果分钟已识别，而秒没有识别，则认为是秒；否则，它被认为是月中的某一天。

连续的字母序列被认为是单词，并按以下方法进行处理：

  • 忽略匹配 AM（忽略大小写）的单词（但如果小时尚未识别，或者小时小于 1 或大于 12，则解析失败）。
  • 匹配 PM（忽略大小写）的单词，添加 12 到小时（但如果小时尚未识别，或者小时小于 1 或大于 12，则解析失败）。
  • 忽略匹配 SUNDAY、MONDAY、TUESDAY、WEDNESDAY、THURSDAY、FRIDAY 或 SATURDAY 的任何前缀（忽略大小写）的任何单词。例如，sat、Friday、TUE 和 Thurs 会被忽略。
  • 否则，匹配 JANUARY、FEBRUARY、MARCH、APRIL、MAY、JUNE、JULY、AUGUST、SEPTEMBER、OCTOBER、NOVEMBER 或 DECEMBER 的任何前缀（忽略大小写，并按这里给出的顺序考虑它们）的任何单词都被识别为指定月份，并被转换成一个数字（0 至 11）。例如，aug、Sept、april 和 NOV 被识别为月份。Ma 也是这样，它被识别为 MARCH，而不是 MAY。
  • 匹配 GMT、UT 或 UTC（忽略大小写）的任何单词都认为是指 UTC。
  • 匹配 EST、CST、MST 或 PST（忽略大小写）的任何单词都被认为是指北美的时区，该时区分别比格林威治时间晚 5、6、7 或 8 小时。匹配 EDT、CDT、MDT 或 PDT（忽略大小写）的任何单词都被识别为在夏令时期间分别指相同的时区。

一旦扫描了整个字符串，就以两种方式之一把它转换成时间结果。如果已经识别时区或时区偏移量，那么年、月、月中某一天、小时、分钟和秒以 UTC 进行解释，然后应用时区偏移量。否则，年、月、月中某一天、小时、分钟和秒用本地时区进行解释。

参数：
s - 要解析为日期的字符串。
返回：
自 1970 年 1 月 1 日 00:00:00 GMT 以来字符串参数表示的毫秒数。
另请参见：
DateFormat

getYear

@Deprecated
public int getYear()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.YEAR) - 1900 取代。

返回一个值，此值是从包含或开始于此 Date 对象表示的瞬间的年份减去 1900 的结果（用本地时区进行解释）。

返回：
日期表示的年份减去 1900。
另请参见：
Calendar

setYear

@Deprecated
public void setYear(int year)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.YEAR, year + 1900) 取代。

把此 Date 对象的年份设置为指定的值加 1900。修改此 Date 对象，以便它用与以前相同的月份、日期、小时、分钟和秒表示指定年份中的时间点（用本地时区进行解释）。（当然，例如，如果日期是 2 月 29 日，并且年份被设置到非闰年，那么新日期将被看作 3 月 1 日。）

参数：
year - 年份值。
另请参见：
Calendar

getMonth

@Deprecated
public int getMonth()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MONTH) 取代。

返回表示月份的数字，该月份包含或开始于此 Date 对象所表示的瞬间。返回的值在 0 和 11 之间，值 0 表示 1 月。

返回：
此日期所表示的月份。
另请参见：
Calendar

setMonth

@Deprecated
public void setMonth(int month)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MONTH, int month) 取代。

把此日期的月份设置为指定值。修改此 Date 对象，以便它用与以前一样的年份、日期、小时、分钟和秒表示指定月份中的时间点（用本地时区进行解释）。例如，如果日期是 10 月 31 日，并将月份设置为 6 月，那么新日期将被看作 7 月 1 日，因为 6 月只有 30 天。

参数：
month - 0-11 之间的月份值。
另请参见：
Calendar

getDate

@Deprecated
public int getDate()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_MONTH) 取代。

返回此 Date 对象表示的月份中的某一天。返回的值在 1 和 31 之间，表示包含或开始于此 Date 对象表示的时间的月份中的某一天（用本地时区进行解释）。

返回：
此日期所表示的月份中的某一天。
另请参见：
Calendar

setDate

@Deprecated
public void setDate(int date)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.DAY_OF_MONTH, int date) 取代。

把此 Date 对象的月份中的某一天设置为指定值。修改此 Date 对象，以便它用与以前一样的年份、月份、小时、分钟和秒表示月份中指定某一天中的时间点（用本地时区进行解释）。例如，如果日期是 4 月 30 日，并且日期被设置为 31，那么它将被看作 5 月 1 日，因为 4 月只有 30 天。

参数：
date - 月份中 1-31 之间的某一天。
另请参见：
Calendar

getDay

@Deprecated
public int getDay()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.DAY_OF_WEEK) 取代。

返回此日期表示的周中的某一天。返回值 (0 = Sunday, 1 = Monday, 2 = Tuesday, 3 = Wednesday, 4 = Thursday, 5 = Friday, 6 = Saturday) 表示一周中的某一天，该周包含或开始于此 Date 对象所表示的瞬间（用本地时区进行解释）。

返回：
此日期所表示的一周中的某一天。
另请参见：
Calendar

getHours

@Deprecated
public int getHours()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.HOUR_OF_DAY) 取代。

返回此 Date 对象表示的小时。返回值是一个数字（0 至 23），表示包含或开始于此 Date 对象表示的瞬间的一天中的小时（用本地时区进行解释）。

返回：
此日期所表示的小时。
另请参见：
Calendar

setHours

@Deprecated
public void setHours(int hours)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.HOUR_OF_DAY, int hours) 取代。

把此 Date 对象的小时设置为指定值。修改此 Date 对象，以便它用与以前一样的年份、月份、日期、分钟和秒表示某一天指定小时中的时间点（用本地时区进行解释）。

参数：
hours - 小时值。
另请参见：
Calendar

getMinutes

@Deprecated
public int getMinutes()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.MINUTE) 取代。

返回此日期所表示的小时已经过去的分钟数（用本地时区进行解释）。返回值在 0 和 59 之间。

返回：
此日期所表示的小时已经过去的分钟数。
另请参见：
Calendar

setMinutes

@Deprecated
public void setMinutes(int minutes)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.MINUTE, int minutes) 取代。

把此 Date 对象的分钟数设置为指定值。修改此 Date 对象，以便它用与以前一样的年份、月份、日期、小时和秒表示小时的指定分钟中的时间点（用本地时区进行解释）。

参数：
minutes - 分钟值。
另请参见：
Calendar

getSeconds

@Deprecated
public int getSeconds()
已过时。 从 JDK 1.1 开始，由 Calendar.get(Calendar.SECOND) 取代。

返回此日期所表示的分钟已经过去的秒数。返回的值在 0 和 61 之间。值 60 和 61 只可能发生在考虑了闰秒的 Java 虚拟机上。

返回：
此日期表示的分钟已经过去的秒数。
另请参见：
Calendar

setSeconds

@Deprecated
public void setSeconds(int seconds)
已过时。 从 JDK 1.1 开始，由 Calendar.set(Calendar.SECOND, int seconds) 取代。

把此 Date 的秒数设置为指定值。修改此 Date 对象，以便它用与以前一样的年份、月份、日期、小时和分钟表示分钟的指定秒数中的时间点（用本地时区进行解释）。

参数：
seconds - 秒数值。
另请参见：
Calendar

getTime

public long getTime()
返回自 1970 年 1 月 1 日 00:00:00 GMT 以来此 Date 对象表示的毫秒数。

返回：
自 1970 年 1 月 1 日 00:00:00 GMT 以来此日期表示的毫秒数。

setTime

public void setTime(long time)
设置此 Date 对象，以表示 1970 年 1 月 1 日 00:00:00 GMT 以后 time 毫秒的时间点。

参数：
time - 毫秒数。

before

public boolean before(Date when)
测试此日期是否在指定日期之前。

参数：
when - 日期。
返回：
当且仅当此 Date 对象表示的瞬间比 when 表示的瞬间早，才返回 true；否则返回 false。
抛出：
NullPointerException - 如果 when 为 null。

after

public boolean after(Date when)
测试此日期是否在指定日期之后。

参数：
when - 日期。
返回：
当且仅当此 Date 对象表示的瞬间比 when 表示的瞬间晚，才返回 true；否则返回 false。
抛出：
NullPointerException - 如果 when 为 null。

equals

public boolean equals(Object obj)
比较两个日期的相等性。当且仅当参数不为 null，并且是一个表示与此对象相同的时间点（到毫秒）的 Date 对象时，结果才为 true。

因此，当且仅当 getTime 方法对于两个 Date 对象返回相同的 long 值时，这两个对象才是相等的。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则，返回 false。
另请参见：
getTime()

compareTo

public int compareTo(Date anotherDate)
比较两个日期的顺序。

指定者：
接口 Comparable<Date> 中的 compareTo
参数：
anotherDate - 要比较的 Date。
返回：
如果参数 Date 等于此 Date，则返回值 0；如果此 Date 在 Date 参数之前，则返回小于 0 的值；如果此 Date 在 Date 参数之后，则返回大于 0 的值。
抛出：
NullPointerException - 如果 anotherDate 为 null。
从以下版本开始：
1.2

hashCode

public int hashCode()
返回此对象的哈希码值。结果是 getTime() 方法返回的基本 long 值的两部分的异或。也就是说，哈希码就是以下表达式的值：
(int)(this.getTime()^(this.getTime() >>> 32))

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
把此 Date 对象转换为以下形式的 String：
 dow mon dd hh:mm:ss zzz yyyy
其中：
  • dow 是一周中的某一天 (Sun, Mon, Tue, Wed, Thu, Fri, Sat)。
  • mon 是月份 (Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec)。
  • dd 是一月中的某一天（01 至 31），显示为两位十进制数。
  • hh 是一天中的小时（00 至 23），显示为两位十进制数。
  • mm 是小时中的分钟（00 至 59），显示为两位十进制数。
  • ss 是分钟中的秒数（00 至 61），显示为两位十进制数。
  • zzz 是时区（并可以反映夏令时）。标准时区缩写包括方法 parse 识别的时区缩写。如果不提供时区信息，则 zzz 为空，即根本不包括任何字符。
  • yyyy 是年份，显示为 4 位十进制数。

覆盖：
类 Object 中的 toString
返回：
此日期的字符串表示形式。
另请参见：
toLocaleString(), toGMTString()

toLocaleString

@Deprecated
public String toLocaleString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代。

以与实现相关的方式创建此 Date 对象的字符串表示形式。其目的是这种形式应该为所有 Java 应用程序的用户所熟悉，而不管它运行在何处。它类似于 ISO C 的 strftime() 函数支持的 "%c" 格式。

返回：
此日期的字符串表示形式（使用语言环境约定）。
另请参见：
DateFormat, toString(), toGMTString()

toGMTString

@Deprecated
public String toGMTString()
已过时。 从 JDK 1.1 开始，由 DateFormat.format(Date date) 取代，使用 GMT TimeZone。

创建此 Date 对象的字符串表示形式，如下： d mon yyyy hh:mm:ss GMT 其中：
  • d 是一月中的某一天（1 至 31），显示为一位或两位十进制数。
  • mon 是月份 (Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec)。
  • yyyy 是年份，显示为 4 位十进制数。
  • hh 是一天中的小时（00 至 23），显示为两位进制数。
  • mm 是小时中的分钟（00 至 59），显示为两位十进制数。
  • ss 分钟中的秒数（00 至 61），显示为两位十进制数。
  • GMT 就是 ASCII 字母 "GMT"，代表格林威治标准时 (Greenwich Mean Time)。

结果不依赖于本地时区。

返回：
此日期的字符串表示形式（使用 Internet GMT 约定）。
另请参见：
DateFormat, toString(), toLocaleString()

getTimezoneOffset

@Deprecated
public int getTimezoneOffset()
已过时。 从 JDK 1.1 开始，由 -(Calendar.get(Calendar.ZONE_OFFSET) + Calendar.get(Calendar.DST_OFFSET)) / (60 * 1000) 取代。

返回相对于 UTC（相应于此 Date 对象表示的时间）的本地时区的偏移量（以分钟为单位）。

例如，在马萨诸塞州，比格林威治时间晚 5 个时区：

new Date(96, 1, 14).getTimezoneOffset() 返回 300
因为在 1996 年 2 月 14 日，使用标准时间（东部标准时间），此时间和 UTC 有 5 小时的偏移量；但是：
new Date(96, 5, 1).getTimezoneOffset() 返回 240
因为在 1996 年 6 月 1 日，使用夏令时（东部日光时间），此时间和 UTC 只有 4 小时的偏移量。

此方法产生与以下计算方式相同的结果：

 (this.getTime() - UTC(this.getYear(),
                       this.getMonth(),
                       this.getDate(),
                       this.getHours(),
                       this.getMinutes(),
                       this.getSeconds())) / (60 * 1000)

返回：
当前时区的时区偏移量（以分钟为单位）。
另请参见：
Calendar.ZONE_OFFSET, Calendar.DST_OFFSET, TimeZone.getDefault()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Deque (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Deque<E>

类型参数：
E - 此 collection 中保存的元素类型
所有超级接口：
Collection<E>, Iterable<E>, Queue<E>
所有已知子接口：
BlockingDeque<E>
所有已知实现类：
ArrayDeque, LinkedBlockingDeque, LinkedList
public interface Deque<E>
extends Queue<E>

一个线性 collection，支持在两端插入和移除元素。名称 deque 是“double ended queue（双端队列）”的缩写，通常读为“deck”。大多数 Deque 实现对于它们能够包含的元素数没有固定限制，但此接口既支持有容量限制的双端队列，也支持没有固定大小限制的双端队列。

此接口定义在双端队列两端访问元素的方法。提供插入、移除和检查元素的方法。每种方法都存在两种形式：一种形式在操作失败时抛出异常，另一种形式返回一个特殊值（null 或 false，具体取决于操作）。插入操作的后一种形式是专为使用有容量限制的 Deque 实现设计的；在大多数实现中，插入操作不能失败。

下表总结了上述 12 种方法：

 | 第一个元素（头部） |  | 最后一个元素（尾部）
 | 抛出异常 | 特殊值 | 抛出异常 | 特殊值
插入 | addFirst(e) | offerFirst(e) | addLast(e) | offerLast(e)
移除 | removeFirst() | pollFirst() | removeLast() | pollLast()
检查 | getFirst() | peekFirst() | getLast() | peekLast()

此接口扩展了 Queue 接口。在将双端队列用作队列时，将得到 FIFO（先进先出）行为。将元素添加到双端队列的末尾，从双端队列的开头移除元素。从 Queue 接口继承的方法完全等效于 Deque 方法，如下表所示：

Queue 方法 | 等效 Deque 方法
add(e) | addLast(e)
offer(e) | offerLast(e)
remove() | removeFirst()
poll() | pollFirst()
element() | getFirst()
peek() | peekFirst()

双端队列也可用作 LIFO（后进先出）堆栈。应优先使用此接口而不是遗留 Stack 类。在将双端队列用作堆栈时，元素被推入双端队列的开头并从双端队列开头弹出。堆栈方法完全等效于 Deque 方法，如下表所示：

堆栈方法 | 等效 Deque 方法
push(e) | addFirst(e)
pop() | removeFirst()
peek() | peekFirst()

注意，在将双端队列用作队列或堆栈时，peek 方法同样正常工作；无论哪种情况下，都从双端队列的开头抽取元素。

此接口提供了两种移除内部元素的方法：removeFirstOccurrence 和 removeLastOccurrence。

与 List 接口不同，此接口不支持通过索引访问元素。

虽然 Deque 实现没有严格要求禁止插入 null 元素，但建议最好这样做。建议任何事实上允许 null 元素的 Deque 实现用户最好不 要利用插入 null 的功能。这是因为各种方法会将 null 用作特殊的返回值来指示双端队列为空。

Deque 实现通常不定义基于元素的 equals 和 hashCode 方法，而是从 Object 类继承基于身份的 equals 和 hashCode 方法。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.6

方法摘要
boolean | add(E e) 将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
void | addFirst(E e) 将指定元素插入此双端队列的开头（如果可以直接这样做而不违反容量限制）。
void | addLast(E e) 将指定元素插入此双端队列的末尾（如果可以直接这样做而不违反容量限制）。
boolean | contains(Object o) 如果此双端队列包含指定元素，则返回 true。
Iterator<E> | descendingIterator() 返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。
E | element() 获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。
E | getFirst() 获取，但不移除此双端队列的第一个元素。
E | getLast() 获取，但不移除此双端队列的最后一个元素。
Iterator<E> | iterator() 返回以恰当顺序在此双端队列的元素上进行迭代的迭代器。
boolean | offer(E e) 将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用的空间，则返回 false。
boolean | offerFirst(E e) 在不违反容量限制的情况下，将指定的元素插入此双端队列的开头。
boolean | offerLast(E e) 在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。
E | peek() 获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
E | peekFirst() 获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
E | peekLast() 获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
E | poll() 获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
E | pollFirst() 获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
E | pollLast() 获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
E | pop() 从此双端队列所表示的堆栈中弹出一个元素。
void | push(E e) 将一个元素推入此双端队列所表示的堆栈（换句话说，此双端队列的头部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。
E | remove() 获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。
boolean | remove(Object o) 从此双端队列中移除第一次出现的指定元素。
E | removeFirst() 获取并移除此双端队列第一个元素。
boolean | removeFirstOccurrence(Object o) 从此双端队列移除第一次出现的指定元素。
E | removeLast() 获取并移除此双端队列的最后一个元素。
boolean | removeLastOccurrence(Object o) 从此双端队列移除最后一次出现的指定元素。
int | size() 返回此双端队列的元素数。
从接口 java.util.Collection 继承的方法
addAll, clear, containsAll, equals, hashCode, isEmpty, removeAll, retainAll, toArray, toArray

方法详细信息

addFirst

void addFirst(E e)
将指定元素插入此双端队列的开头（如果可以直接这样做而不违反容量限制）。在使用有容量限制的双端队列时，通常首选 offerFirst(E) 方法。

参数：
e - 要添加的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
ClassCastException - 如果指定元素的类不允许将它添加此双端队列
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

addLast

void addLast(E e)
将指定元素插入此双端队列的末尾（如果可以直接这样做而不违反容量限制）。在使用有容量限制的双端队列时，通常首选 offerLast(E) 方法。

此方法等效于 add(E)。

参数：
e - 要添加的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
ClassCastException - 如果指定元素的类不允许将它添加此双端队列
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

offerFirst

boolean offerFirst(E e)
在不违反容量限制的情况下，将指定的元素插入此双端队列的开头。当使用有容量限制的双端队列时，此方法通常优于 addFirst(E) 方法，后者可能无法插入元素，而只是抛出一个异常。

参数：
e - 要添加的元素
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许将它添加到此双端队列
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

offerLast

boolean offerLast(E e)
在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。当使用有容量限制的双端队列时，此方法通常优于 addLast(E) 方法，后者可能无法插入元素，而只是抛出一个异常。

参数：
e - 要添加的元素
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许将它添加到此双端队列
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

removeFirst

E removeFirst()
获取并移除此双端队列第一个元素。此方法与 pollFirst 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

返回：
此双端队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

removeLast

E removeLast()
获取并移除此双端队列的最后一个元素。此方法与 pollLast 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

返回：
此双端队列的尾部
抛出：
NoSuchElementException - 如果此双端队列为空

pollFirst

E pollFirst()
获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。

返回：
此双端队列的头部；如果此双端队列为空，则返回 null

pollLast

E pollLast()
获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。

返回：
此双端队列的尾部；如果此双端队列为空，则返回 null

getFirst

E getFirst()
获取，但不移除此双端队列的第一个元素。 此方法与 peekFirst 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

返回：
此双端队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

getLast

E getLast()
获取，但不移除此双端队列的最后一个元素。此方法与 peekLast 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

返回：
此双端队列的尾部
抛出：
NoSuchElementException - 如果此双端队列为空

peekFirst

E peekFirst()
获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。

返回：
此双端队列的头部；如果此双端队列为空，则返回 null

peekLast

E peekLast()
获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。

返回：
此双端队列的尾部；如果此双端队列为空，则返回 null

removeFirstOccurrence

boolean removeFirstOccurrence(Object o)
从此双端队列移除第一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 (o==null ? e==null : o.equals(e)) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果由于此调用而移除了一个元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此双端队列不兼容（可选）
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素（可选）

removeLastOccurrence

boolean removeLastOccurrence(Object o)
从此双端队列移除最后一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除最后一个满足 (o==null ? e==null : o.equals(e)) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果由于此调用而移除了一个元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此双端队列不兼容（可选）
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素（可选）

add

boolean add(E e)
将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。当使用有容量限制的双端队列时，通常首选 offer。

此方法等效于 addLast(E)。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Queue<E> 中的 add
参数：
e - 要添加的元素
返回：
true （根据 Collection.add(E) 的规定）
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
ClassCastException - 如果指定元素的类不允许将它添加到此双端队列
NullPointerException - 如果指定元素为 null，并且此双端队列不支持 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

offer

boolean offer(E e)
将指定元素插入此双端队列所表示的队列（换句话说，此双端队列的尾部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用的空间，则返回 false。当使用有容量限制的双端队列时，此方法通常优于 add(E) 方法，后者可能无法插入元素，而只是抛出一个异常。

此方法等效于 offerLast(E)。

指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许将它添加到此双端队列
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

remove

E remove()
获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。此方法与 poll 的唯一不同在于：如果此双端队列为空，它将抛出一个异常。

此方法等效于 removeFirst()。

指定者：
接口 Queue<E> 中的 remove
返回：
此双端队列表示的队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

poll

E poll()
获取并移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。

此方法等效于 pollFirst()。

指定者：
接口 Queue<E> 中的 poll
返回：
此双端队列的第一个元素；如果此双端队列为空，则返回 null

element

E element()
获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）。此方法与 peek 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

此方法等效于 getFirst()。

指定者：
接口 Queue<E> 中的 element
返回：
此双端队列表示的队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

peek

E peek()
获取，但不移除此双端队列所表示的队列的头部（换句话说，此双端队列的第一个元素）；如果此双端队列为空，则返回 null。

此方法等效于 peekFirst()。

指定者：
接口 Queue<E> 中的 peek
返回：
此双端队列所表示的队列的头；如果此双端队列为空，则返回 null

push

void push(E e)
将一个元素推入此双端队列所表示的堆栈（换句话说，此双端队列的头部），如果可以直接这样做而不违反容量限制的话；如果成功，则返回 true，如果当前没有可用空间，则抛出 IllegalStateException。

此方法等效于 addFirst(E)。

参数：
e - 要推入的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
ClassCastException - 如果指定元素的类不允许将它添加此双端队列
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

pop

E pop()
从此双端队列所表示的堆栈中弹出一个元素。换句话说，移除并返回此双端队列第一个元素。

此方法等效于 removeFirst()。

返回：
此双端队列开头的元素（它是此双端队列所表示的堆栈的顶部）
抛出：
NoSuchElementException - 如果此双端队列为空

remove

boolean remove(Object o)
从此双端队列中移除第一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 (o==null ? e==null : o.equals(e)) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

此方法等效于 removeFirstOccurrence(java.lang.Object)。

指定者：
接口 Collection<E> 中的 remove
参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果由于此调用而移除了一个元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此双端队列不兼容（可选）
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素（可选）

contains

boolean contains(Object o)
如果此双端队列包含指定元素，则返回 true。更确切地讲，当且仅当此双端队列至少包含一个满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
参数：
o - 要测试其是否存在于此双端队列的元素
返回：
如果此双端队列包含指定元素，则返回 true
抛出：
ClassCastException - 如果指定的元素类型与此双端队列不兼容（可选）
NullPointerException - 如果指定元素为 null，并且此双端队列不允许 null 元素（可选）

size

int size()
返回此双端队列的元素数。

指定者：
接口 Collection<E> 中的 size
返回：
此双端队列的元素数

iterator

Iterator<E> iterator()
返回以恰当顺序在此双端队列的元素上进行迭代的迭代器。元素将按从第一个（头部）到最后一个（尾部）的顺序返回。

指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Iterable<E> 中的 iterator
返回：
按恰当顺序在此双端队列的元素上进行迭代的迭代器

descendingIterator

Iterator<E> descendingIterator()
返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。元素将按从最后一个（尾部）到第一个（头部）的顺序返回。

返回：
以逆向顺序在此双端队列中的元素上进行迭代的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Dictionary (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Dictionary<K,V>

java.lang.Object
    继承者  java.util.Dictionary<K,V>
直接已知子类：
Hashtable
public abstract class Dictionary<K,V>
extends Object

Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。每个键和每个值都是一个对象。在任何一个 Dictionary 对象中，每个键至多与一个值相关联。给定一个 Dictionary 和一个键，就可以查找所关联的元素。任何非 null 对象都可以用作键或值。

通常，应该在此类的实现中使用 equals 方法，以决定两个键是否相同。

注：此类已过时。新的实现应该实现 Map 接口，而不是扩展此类。

从以下版本开始：
JDK1.0
另请参见：
Map, Object.equals(java.lang.Object), Object.hashCode(), Hashtable

构造方法摘要
Dictionary()
单独的构造方法。
方法摘要
abstract Enumeration<V> | elements() 返回此 dictionary 中值的枚举。
abstract V | get(Object key) 返回此 dictionary 中该键所映射到的值。
abstract boolean | isEmpty() 测试此 dictionary 是否不存在从键到值的映射。
abstract Enumeration<K> | keys() 返回此 dictionary 中的键的枚举。
abstract V | put(K key, V value) 将指定 key 映射到此 dictionary 中指定 value。
abstract V | remove(Object key) 从此 dictionary 中移除 key （及其相应的 value）。
abstract int | size() 返回此 dictionary 中条目（不同键）的数量。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Dictionary

public Dictionary()
单独的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

size

public abstract int size()
返回此 dictionary 中条目（不同键）的数量。

返回：
此 dictionary 中的键数。

isEmpty

public abstract boolean isEmpty()
测试此 dictionary 是否不存在从键到值的映射。isEmpty 方法的常规协定是，当且仅当此 dictionary 不包含条目时，结果为 true。

返回：
如果此 dictionary 不存在从键到值的映射，则返回 true；否则返回 false。

keys

public abstract Enumeration<K> keys()
返回此 dictionary 中的键的枚举。键方法的常规协定是返回 Enumeration 对象，该对象将生成此 dictionary 包含条目的所有键。

返回：
此 dictionary 中键的枚举。
另请参见：
elements(), Enumeration

elements

public abstract Enumeration<V> elements()
返回此 dictionary 中值的枚举。elements 方法的常规协定是返回 Enumeration 对象，该对象将生成此 dictionary 中包含条目的所有元素。

返回：
此 dictionary 中值的枚举。
另请参见：
keys(), Enumeration

get

public abstract V get(Object key)
返回此 dictionary 中该键所映射到的值。isEmpty 方法的常规协定是，如果此 dictionary 包含所指定键的条目，则返回该键所关联的值；否则，返回 null。

参数：
key - 此 dictionary 中的一个键。如果该键没有映射到此 dictionary 中任何值，则返回 null。
返回：
此 dictionary 中该键所映射到的值；
抛出：
NullPointerException - 如果该 key 为 null。
另请参见：
put(java.lang.Object, java.lang.Object)

put

public abstract V put(K key,
                      V value)
将指定 key 映射到此 dictionary 中指定 value。键和值均不能为 null。

如果此 dictionary 已经包含指定 key 的条目，则在修改条目以包含新元素之后，返回该 key 在此 dictionary 中已有的值。

如果此 dictionary 还没有指定 key 的条目，则为指定 key 和 value 创建条目，并返回 null。

可以通过调用 get 方法来获取 value，使用的 key 与原来的 key 相等。

参数：
key - 哈希表键。
value - 值。
返回：
以前该 key 在此 dictionary 中被映射到的值，如果该键没有以前的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 或 value 为 null。
另请参见：
Object.equals(java.lang.Object), get(java.lang.Object)

remove

public abstract V remove(Object key)
从此 dictionary 中移除 key （及其相应的 value）。如果该 key 不在此 dictionary 中，则该方法不执行任何操作。

参数：
key - 需要移除的键。
返回：
该 key 在此 dictionary 中被映射到的值，如果该键没有以前的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DuplicateFormatFlagsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 DuplicateFormatFlagsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.DuplicateFormatFlagsException
所有已实现的接口：
Serializable
public class DuplicateFormatFlagsException
extends IllegalFormatException

格式说明符中提供重复标志时抛出的未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都将导致抛出 NullPointerException 异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
DuplicateFormatFlagsException(String f)
构造带指定标志的此类的一个实例。
方法摘要
String | getFlags() 返回包含重复标志的一组标志。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DuplicateFormatFlagsException

public DuplicateFormatFlagsException(String f)
构造带指定标志的此类的一个实例。

参数：
f - 包含重复标志的一组格式标志。
方法详细信息

getFlags

public String getFlags()
返回包含重复标志的一组标志。

返回：
标志

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EmptyStackException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 EmptyStackException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.util.EmptyStackException
所有已实现的接口：
Serializable
public class EmptyStackException
extends RuntimeException

该异常由 Stack 类中的方法抛出，以表明堆栈为空。

从以下版本开始：
JDK1.0
另请参见：
Stack, 序列化表格

构造方法摘要
EmptyStackException()
构造一个将 null 作为其错误消息字符串的新 EmptyStackException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

EmptyStackException

public EmptyStackException()
构造一个将 null 作为其错误消息字符串的新 EmptyStackException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Enumeration (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Enumeration<E>

所有已知子接口：
NamingEnumeration<T>
所有已知实现类：
StringTokenizer
public interface Enumeration<E>

实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。连续调用 nextElement 方法将返回一系列的连续元素。

例如，要输出 Vector<E> v 的所有元素，可使用以下方法：

   for (Enumeration<E> e = v.elements(); e.hasMoreElements();)
       System.out.println(e.nextElement());

这些方法主要通过向量的元素、哈希表的键以及哈希表中的值进行枚举。枚举也用于将输入流指定到 SequenceInputStream 中。

注：此接口的功能与 Iterator 接口的功能是重复的。此外，Iterator 接口添加了一个可选的移除操作，并使用较短的方法名。新的实现应该优先考虑使用 Iterator 接口而不是 Enumeration 接口。

从以下版本开始：
JDK1.0
另请参见：
Iterator, SequenceInputStream, nextElement(), Hashtable, Hashtable.elements(), Hashtable.keys(), Vector, Vector.elements()

方法摘要
boolean | hasMoreElements() 测试此枚举是否包含更多的元素。
E | nextElement() 如果此枚举对象至少还有一个可提供的元素，则返回此枚举的下一个元素。

方法详细信息

hasMoreElements

boolean hasMoreElements()
测试此枚举是否包含更多的元素。

返回：
当且仅当此枚举对象至少还包含一个可提供的元素时，才返回 true；否则返回 false。

nextElement

E nextElement()
如果此枚举对象至少还有一个可提供的元素，则返回此枚举的下一个元素。

返回：
此枚举的下一个元素。
抛出：
NoSuchElementException - 如果没有更多的元素存在。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EnumMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 EnumMap<K extends Enum<K>,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.EnumMap<K,V>
所有已实现的接口：
Serializable, Cloneable, Map<K,V>
public class EnumMap<K extends Enum<K>,V>
extends AbstractMap<K,V>
implements Serializable, Cloneable

与枚举类型键一起使用的专用 Map 实现。枚举映射中所有键都必须来自单个枚举类型，该枚举类型在创建映射时显式或隐式地指定。枚举映射在内部表示为数组。此表示形式非常紧凑且高效。

枚举映射根据其键的自然顺序 来维护（该顺序是声明枚举常量的顺序）。在 collection 视图（keySet()、entrySet() 和 values()）所返回的迭代器中反映了这一点。

由 collection 视图返回的迭代器是弱一致 的：它们不会抛出 ConcurrentModificationException，也不一定显示在迭代进行时发生的任何映射修改的效果。

不允许使用 null 键。试图插入 null 键将抛出 NullPointerException。但是，试图测试是否出现 null 键或移除 null 键将不会抛出异常。允许使用 null 值。

像大多数 collection 一样，EnumMap 是不同步的。如果多个线程同时访问一个枚举映射，并且至少有一个线程修改该映射，则此枚举映射在外部应该是同步的。这一般通过对自然封装该枚举映射的某个对象进行同步来完成。如果不存在这样的对象，则应该使用 Collections.synchronizedMap(java.util.Map) 方法来“包装”该枚举。最好在创建时完成这一操作，以防止意外的非同步访问：

     Map<EnumKey, V> m
         = Collections.synchronizedMap(new EnumMap<EnumKey, V>(...));

实现注意事项：所有基本操作都在固定时间内执行。虽然并不保证，但它们很可能比其 HashMap 副本更快。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
EnumSet, 序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
构造方法摘要
EnumMap(Class<K> keyType)
创建一个具有指定键类型的空枚举映射。
EnumMap(EnumMap<K,? extends V> m)
创建一个其键类型与指定枚举映射相同的枚举映射，最初包含相同的映射关系（如果有的话）。
EnumMap(Map<K,? extends V> m)
创建一个枚举映射，从指定映射对其初始化。
方法摘要
void | clear() 从此映射中移除所有映射关系。
EnumMap<K,V> | clone() 返回此枚举映射的浅表副本。
boolean | containsKey(Object key) 如果此映射包含指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
Set<Map.Entry<K,V>> | entrySet() 返回此映射中所包含映射关系的 Set 视图。
boolean | equals(Object o) 比较指定对象与此映射的相等性。
V | get(Object key) 返回指定键所映射的值，如果此映射不包含此键的映射关系，则返回 null。
Set<K> | keySet() 返回此映射中所包含键的 Set 视图。
V | put(K key, V value) 将指定值与此映射中指定键关联。
void | putAll(Map<? extends K,? extends V> m) 将指定映射中所有映射关系复制到此映射中。
V | remove(Object key) 从此映射中移除该键的映射关系（如果存在）。
int | size() 返回此映射中的键-值映射关系数。
Collection<V> | values() 返回此映射中所包含值的 Collection 视图。
从类 java.util.AbstractMap 继承的方法
hashCode, isEmpty, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

EnumMap

public EnumMap(Class<K> keyType)
创建一个具有指定键类型的空枚举映射。

参数：
keyType - 此枚举映射的键类型的 class 对象
抛出：
NullPointerException - 如果 keyType 为空

EnumMap

public EnumMap(EnumMap<K,? extends V> m)
创建一个其键类型与指定枚举映射相同的枚举映射，最初包含相同的映射关系（如果有的话）。

参数：
m - 用于初始化此枚举映射的枚举映射
抛出：
NullPointerException - 如果 m 为空

EnumMap

public EnumMap(Map<K,? extends V> m)
创建一个枚举映射，从指定映射对其初始化。如果指定的映射是一个 EnumMap 实例，则此构造方法的功能与 EnumMap(EnumMap) 相同。否则，指定的映射必须至少包含一个映射关系（以确定新枚举映射的键类型）。

参数：
m - 用于初始化此枚举映射的映射
抛出：
IllegalArgumentException - 如果 m 不是一个 EnumMap 实例，并且不包含映射关系
NullPointerException - 如果 m 为空
方法详细信息

size

public int size()
返回此映射中的键-值映射关系数。

指定者：
接口 Map<K extends Enum<K>,V> 中的 size
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 size
返回：
此映射中的键-值映射关系数。

containsValue

public boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

指定者：
接口 Map<K extends Enum<K>,V> 中的 containsValue
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 containsValue
参数：
value - 将要在此映射中测试其是否存在的值
返回：
如果此映射将一个或多个键映射到此值，则返回 true

containsKey

public boolean containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

指定者：
接口 Map<K extends Enum<K>,V> 中的 containsKey
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 containsKey
参数：
key - 将要在此映射中测试其是否存在的键
返回：
如果此映射包含指定键的映射关系，则返回 true

get

public V get(Object key)
返回指定键所映射的值，如果此映射不包含此键的映射关系，则返回 null。

更确切地讲，如果此映射包含满足 (key == k) 的从键 k 到值 v 的映射关系，则此方法返回 v；否则，返回 null。（最多只能有一个这样的映射关系。）

返回 null 值并不 一定 表示此映射不包含此键的映射关系；也可能是映射显式地将此键映射到了 null。containsKey 操作可以用于区分这两种情况。

指定者：
接口 Map<K extends Enum<K>,V> 中的 get
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null

put

public V put(K key,
             V value)
将指定值与此映射中指定键关联。如果该映射以前包含此键的映射关系，则将原值替换。

指定者：
接口 Map<K extends Enum<K>,V> 中的 put
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 put
参数：
key - 指定值与其关联的键
value - 与指定键关联的值
返回：
与指定键关联的旧值，如果不存在该键的映射关系，则返回 null。（返回 null 还可能表明以前该映射将 null 与指定键关联。）
抛出：
NullPointerException - 如果指定键为 null

remove

public V remove(Object key)
从此映射中移除该键的映射关系（如果存在）。

指定者：
接口 Map<K extends Enum<K>,V> 中的 remove
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 remove
参数：
key - 其映射关系要从映射中移除的键
返回：
以前与指定键关联的值，如果不存在关联值，则返回 null。（返回 null 还可能指示以前该映射将 null 与指定键关联。）

putAll

public void putAll(Map<? extends K,? extends V> m)
将指定映射中所有映射关系复制到此映射中。这些映射关系将替换此映射目前针对指定映射的所有键的所有映射关系。

指定者：
接口 Map<K extends Enum<K>,V> 中的 putAll
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 putAll
参数：
m - 存储在此映射中的映射关系
抛出：
NullPointerException - 如果指定映射为 null，或指定映射中一个或多个键为 null

clear

public void clear()
从此映射中移除所有映射关系。

指定者：
接口 Map<K extends Enum<K>,V> 中的 clear
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 clear

keySet

public Set<K> keySet()
返回此映射中所包含键的 Set 视图。 返回的 set 遵守 Map.keySet() 中描述的常规协定。该 set 的迭代器将按其自然顺序返回键（此顺序是声明枚举常量的顺序）。

指定者：
接口 Map<K extends Enum<K>,V> 中的 keySet
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 keySet
返回：
此枚举映射所包含键的 set 视图

values

public Collection<V> values()
返回此映射中所包含值的 Collection 视图。返回的 collection 遵守 Map.keySet() 中描述的常规协定。该 collection 的迭代器返回值是按照它们相应的键在映射中出现的顺序返回的，即按照它们的自然顺序（此顺序是声明枚举常量的顺序）。

指定者：
接口 Map<K extends Enum<K>,V> 中的 values
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射中所包含映射关系的 Set 视图。返回的 set 遵守 Map.keySet() 中描述的常规协定。该 set 的迭代器返回映射关系是按照它们的键在映射中出现的顺序返回的，即按照它们的自然顺序（此顺序是声明枚举常量的顺序）。

指定者：
接口 Map<K extends Enum<K>,V> 中的 entrySet
指定者：
类 AbstractMap<K extends Enum<K>,V> 中的 entrySet
返回：
此枚举映射中包含的映射关系的 set 视图

equals

public boolean equals(Object o)
比较指定对象与此映射的相等性。如果给定对象也是一个映射，并且按照 Map.equals(Object) 协定，两个映射表示的映射关系相同，则返回 true。

指定者：
接口 Map<K extends Enum<K>,V> 中的 equals
覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 equals
参数：
o - 要与此映射比较的对象
返回：
如果指定对象等于此映射，则返回 true
另请参见：
Object.hashCode(), Hashtable

clone

public EnumMap<K,V> clone()
返回此枚举映射的浅表副本。（这些值本身没有复制。）

覆盖：
类 AbstractMap<K extends Enum<K>,V> 中的 clone
返回：
此枚举映射的浅表副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EnumSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 EnumSet<E extends Enum<E>>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
            继承者  java.util.EnumSet<E>
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, Set<E>
public abstract class EnumSet<E extends Enum<E>>
extends AbstractSet<E>
implements Cloneable, Serializable

与枚举类型一起使用的专用 Set 实现。枚举 set 中所有键都必须来自单个枚举类型，该枚举类型在创建 set 时显式或隐式地指定。枚举 set 在内部表示为位向量。此表示形式非常紧凑且高效。此类的空间和时间性能应该很好，足以用作传统上基于 int 的“位标志”的替换形式，具有高品质、类型安全的优势。如果其参数也是一个枚举 set，则批量操作（如 containsAll 和 retainAll）也应运行得非常快。

由 iterator 方法返回的迭代器按其自然顺序 遍历这些元素（该顺序是声明枚举常量的顺序）。返回的迭代器是弱一致的：它从不抛出 ConcurrentModificationException，也不一定显示在迭代进行时发生的任何 set 修改的效果。

不允许使用 null 元素。试图插入 null 元素将抛出 NullPointerException。但是，试图测试是否出现 null 元素或移除 null 元素将不会抛出异常。

像大多数 collection 实现一样，EnumSet 是不同步的。如果多个线程同时访问一个枚举 set，并且至少有一个线程修改该 set，则此枚举 set 在外部应该是同步的。这通常是通过对自然封装该枚举 set 的对象执行同步操作来完成的。如果不存在这样的对象，则应该使用 Collections.synchronizedSet(java.util.Set) 方法来“包装”该 set。最好在创建时完成这一操作，以防止意外的非同步访问：

 Set<MyEnum> s = Collections.synchronizedSet(EnumSet.noneOf(MyEnum.class));

实现注意事项：所有基本操作都在固定时间内执行。虽然并不保证，但它们很可能比其 HashSet 副本更快。如果其参数也是一个枚举 set ，则批量操作会在固定时间内执行。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
EnumMap

方法摘要
static
<E extends Enum<E>>
EnumSet<E>
allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。
 EnumSet<E> clone()
返回 set 的副本。
static
<E extends Enum<E>>
EnumSet<E>
complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
static
<E extends Enum<E>>
EnumSet<E>
copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。
static
<E extends Enum<E>>
EnumSet<E>
noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
of(E e)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
of(E first, E... rest)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
of(E e1, E e2)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
of(E e1, E e2, E e3)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
of(E e1, E e2, E e3, E e4)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
of(E e1, E e2, E e3, E e4, E e5)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
range(E from, E to)
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。
从类 java.util.AbstractSet 继承的方法
equals, hashCode, removeAll
从类 java.util.AbstractCollection 继承的方法
add, addAll, clear, contains, containsAll, isEmpty, iterator, remove, retainAll, size, toArray, toArray, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Set 继承的方法
add, addAll, clear, contains, containsAll, isEmpty, iterator, remove, retainAll, size, toArray, toArray

方法详细信息

noneOf

public static <E extends Enum<E>> EnumSet<E> noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。

参数：
elementType - 此枚举 set 的元素类型的 class 对象
抛出：
NullPointerException - 如果 elementType 为 null

allOf

public static <E extends Enum<E>> EnumSet<E> allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。

参数：
elementType - 此枚举 set 的元素类型的 class 对象
抛出：
NullPointerException - 如果 elementType 为 null

copyOf

public static <E extends Enum<E>> EnumSet<E> copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。

参数：
s - 用于初始化此枚举 set 的枚举 set
抛出：
NullPointerException - 如果 s 为 null

copyOf

public static <E extends Enum<E>> EnumSet<E> copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。如果指定的 collection 是一个 EnumSet 实例，则此静态工厂方法的功能与 copyOf(EnumSet) 相同。否则，指定的 collection 必须至少包含一个元素（以确定新枚举 set 的元素类型）。

参数：
c - 用于初始化此枚举 set 的 collection
抛出：
IllegalArgumentException - 如果 c 不是一个 EnumSet 实例，并且不包含元素
NullPointerException - 如果 c 为 null

complementOf

public static <E extends Enum<E>> EnumSet<E> complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。

参数：
s - 用其补码初始化此枚举 set 的枚举 set
抛出：
NullPointerException - 如果 s 为 null

of

public static <E extends Enum<E>> EnumSet<E> of(E e)
创建一个最初包含指定元素的枚举 set。 用 1 到 5 个元素重载此方法，从而初始化一个枚举 set。第 6 次重载使用变量参数功能。此重载可能创建一个最初包含任意个元素的枚举 set，但是这样很可能比不使用变量参数的重载运行得慢。

参数：
e - 此 set 最初包含的元素
返回：
最初包含指定元素的枚举 set
抛出：
NullPointerException - 如果 e 为 null

of

public static <E extends Enum<E>> EnumSet<E> of(E e1,
                                                E e2)
创建一个最初包含指定元素的枚举 set。 用 1 到 5 个元素重载此方法，从而初始化一个枚举 set。第 6 次重载使用变量参数功能。此重载可能创建一个最初包含任意个元素的枚举 set，但是这样很可能比不使用变量参数的重载运行得慢。

参数：
e1 - 此 set 最初要包含的元素
e2 - 此 set 最初要包含的另一个元素
返回：
最初包含指定元素的枚举 set
抛出：
NullPointerException - 如果任意参数为 null

of

public static <E extends Enum<E>> EnumSet<E> of(E e1,
                                                E e2,
                                                E e3)
创建一个最初包含指定元素的枚举 set。 用 1 到 5 个元素重载此方法，从而初始化一个枚举 set。第 6 次重载使用变量参数功能。此重载可能创建一个最初包含任意个元素的枚举 set，但是这样很可能比不使用变量参数的重载运行得慢。

参数：
e1 - 此 set 最初要包含的元素
e2 - 此 set 最初要包含的另一个元素
e3 - 此 set 最初要包含的另一个元素
返回：
最初包含指定元素的枚举 set
抛出：
NullPointerException - 如果任意参数为 null

of

public static <E extends Enum<E>> EnumSet<E> of(E e1,
                                                E e2,
                                                E e3,
                                                E e4)
创建一个最初包含指定元素的枚举 set。 用 1 到 5 个元素重载此方法，从而初始化一个枚举 set。第 6 次重载使用变量参数功能。此重载可能创建一个最初包含任意个元素的枚举 set，但是这样很可能比不使用变量参数的重载运行得慢。

参数：
e1 - 此 set 最初要包含的元素
e2 - 此 set 最初要包含的另一个元素
e3 - 此 set 最初要包含的另一个元素
e4 - 此 set 最初要包含的另一个元素
返回：
最初包含指定元素的枚举 set
抛出：
NullPointerException - 如果任意参数为 null

of

public static <E extends Enum<E>> EnumSet<E> of(E e1,
                                                E e2,
                                                E e3,
                                                E e4,
                                                E e5)
创建一个最初包含指定元素的枚举 set。 用 1 到 5 个元素重载此方法，从而初始化一个枚举 set。第 6 次重载使用变量参数功能。此重载可能创建一个最初包含任意个元素的枚举 set，但是这样很可能比不使用变量参数的重载运行得慢。

参数：
e1 - 此 set 最初要包含的元素
e2 - 此 set 最初要包含的另一个元素
e3 - 此 set 最初要包含的另一个元素
e4 - 此 set 最初要包含的另一个元素
e5 - 此 set 最初要包含的另一个元素
返回：
最初包含指定元素的枚举 set
抛出：
NullPointerException - 如果任意参数为 null

of

public static <E extends Enum<E>> EnumSet<E> of(E first,
                                                E... rest)
创建一个最初包含指定元素的枚举 set。此工厂方法的参数列表使用变量参数功能，该方法可以创建一个最初包含任意个元素的枚举 set，但是这样很可能比不使用变量参数的重载运行得慢。

参数：
first - 此 set 最初要包含的元素
rest - 此 set 最初要包含的其余元素
返回：
最初包含指定元素的枚举 set
抛出：
NullPointerException - 如果任意参数为 null，或 rest 为 null

range

public static <E extends Enum<E>> EnumSet<E> range(E from,
                                                   E to)
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。返回的 set 将包含端点本身，这两个端点可能相同，但顺序不能颠倒。

参数：
from - 该范围中的第一个元素
to - 妨碍范围中的最后一个元素
返回：
最初包含由两个指定端点所定义范围内的所有元素的枚举 set
抛出：
NullPointerException - 如果 first 或 last 为 null
IllegalArgumentException - 如果 first.compareTo(last) > 0

clone

public EnumSet<E> clone()
返回 set 的副本。

覆盖：
类 Object 中的 clone
返回：
set 的副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 EventListener

所有已知子接口：
Action, ActionListener, AdjustmentListener, AncestorListener, AWTEventListener, BeanContextMembershipListener, BeanContextServiceRevokedListener, BeanContextServices, BeanContextServicesListener, CaretListener, CellEditorListener, ChangeListener, ComponentListener, ConnectionEventListener, ContainerListener, ControllerEventListener, DocumentListener, DragGestureListener, DragSourceListener, DragSourceMotionListener, DropTargetListener, FlavorListener, FocusListener, HandshakeCompletedListener, HierarchyBoundsListener, HierarchyListener, HyperlinkListener, IIOReadProgressListener, IIOReadUpdateListener, IIOReadWarningListener, IIOWriteProgressListener, IIOWriteWarningListener, InputMethodListener, InternalFrameListener, ItemListener, KeyListener, LineListener, ListDataListener, ListSelectionListener, MenuDragMouseListener, MenuKeyListener, MenuListener, MetaEventListener, MouseInputListener, MouseListener, MouseMotionListener, MouseWheelListener, NamespaceChangeListener, NamingListener, NodeChangeListener, NotificationListener, ObjectChangeListener, PopupMenuListener, PreferenceChangeListener, PropertyChangeListener, RowSetListener, RowSorterListener, SSLSessionBindingListener, StatementEventListener, TableColumnModelListener, TableModelListener, TextListener, TreeExpansionListener, TreeModelListener, TreeSelectionListener, TreeWillExpandListener, UndoableEditListener, UnsolicitedNotificationListener, VetoableChangeListener, WindowFocusListener, WindowListener, WindowStateListener
所有已知实现类：
AbstractAction, AbstractButton.ButtonChangeListener, AWTEventListenerProxy, AWTEventMulticaster, BasicButtonListener, BasicColorChooserUI.PropertyHandler, BasicComboBoxEditor, BasicComboBoxEditor.UIResource, BasicComboBoxUI.FocusHandler, BasicComboBoxUI.ItemHandler, BasicComboBoxUI.KeyHandler, BasicComboBoxUI.ListDataHandler, BasicComboBoxUI.PropertyChangeHandler, BasicComboPopup.InvocationKeyHandler, BasicComboPopup.InvocationMouseHandler, BasicComboPopup.InvocationMouseMotionHandler, BasicComboPopup.ItemHandler, BasicComboPopup.ListDataHandler, BasicComboPopup.ListMouseHandler, BasicComboPopup.ListMouseMotionHandler, BasicComboPopup.ListSelectionHandler, BasicComboPopup.PropertyChangeHandler, BasicDesktopIconUI.MouseInputHandler, BasicDesktopPaneUI.CloseAction, BasicDesktopPaneUI.MaximizeAction, BasicDesktopPaneUI.MinimizeAction, BasicDesktopPaneUI.NavigateAction, BasicDesktopPaneUI.OpenAction, BasicDirectoryModel, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.DoubleClickListener, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.SelectionListener, BasicFileChooserUI.UpdateAction, BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.PropertyChangeHandler, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicInternalFrameUI.BasicInternalFrameListener, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.ComponentHandler, BasicInternalFrameUI.GlassPaneDispatcher, BasicInternalFrameUI.InternalFramePropertyChangeListener, BasicLabelUI, BasicListUI.FocusHandler, BasicListUI.ListDataHandler, BasicListUI.ListSelectionHandler, BasicListUI.MouseInputHandler, BasicListUI.PropertyChangeHandler, BasicMenuItemUI.MouseInputHandler, BasicMenuUI.ChangeHandler, BasicMenuUI.MouseInputHandler, BasicOptionPaneUI.ButtonActionListener, BasicOptionPaneUI.PropertyChangeHandler, BasicProgressBarUI.ChangeHandler, BasicRootPaneUI, BasicScrollBarUI.ArrowButtonListener, BasicScrollBarUI.ModelListener, BasicScrollBarUI.PropertyChangeHandler, BasicScrollBarUI.ScrollListener, BasicScrollBarUI.TrackListener, BasicScrollPaneUI.HSBChangeListener, BasicScrollPaneUI.MouseWheelHandler, BasicScrollPaneUI.PropertyChangeHandler, BasicScrollPaneUI.ViewportChangeHandler, BasicScrollPaneUI.VSBChangeListener, BasicSliderUI.ActionScroller, BasicSliderUI.ChangeHandler, BasicSliderUI.ComponentHandler, BasicSliderUI.FocusHandler, BasicSliderUI.PropertyChangeHandler, BasicSliderUI.ScrollListener, BasicSliderUI.TrackListener, BasicSplitPaneDivider, BasicSplitPaneDivider.MouseHandler, BasicSplitPaneUI.FocusHandler, BasicSplitPaneUI.KeyboardDownRightHandler, BasicSplitPaneUI.KeyboardEndHandler, BasicSplitPaneUI.KeyboardHomeHandler, BasicSplitPaneUI.KeyboardResizeToggleHandler, BasicSplitPaneUI.KeyboardUpLeftHandler, BasicSplitPaneUI.PropertyHandler, BasicTabbedPaneUI.FocusHandler, BasicTabbedPaneUI.MouseHandler, BasicTabbedPaneUI.PropertyChangeHandler, BasicTabbedPaneUI.TabSelectionHandler, BasicTableHeaderUI.MouseInputHandler, BasicTableUI.FocusHandler, BasicTableUI.KeyHandler, BasicTableUI.MouseInputHandler, BasicTextUI.BasicCaret, BasicToolBarUI.DockingListener, BasicToolBarUI.FrameListener, BasicToolBarUI.PropertyListener, BasicToolBarUI.ToolBarContListener, BasicToolBarUI.ToolBarFocusListener, BasicTreeUI.CellEditorHandler, BasicTreeUI.ComponentHandler, BasicTreeUI.FocusHandler, BasicTreeUI.KeyHandler, BasicTreeUI.MouseHandler, BasicTreeUI.MouseInputHandler, BasicTreeUI.PropertyChangeHandler, BasicTreeUI.SelectionModelPropertyChangeHandler, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeExpansionHandler, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreeModelHandler, BasicTreeUI.TreePageAction, BasicTreeUI.TreeSelectionHandler, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction, BeanContextChildSupport, BeanContextServicesSupport, BeanContextServicesSupport.BCSSProxyServiceProvider, BeanContextSupport, Checkbox.AccessibleAWTCheckbox, Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler, ComponentAdapter, Container.AccessibleAWTContainer.AccessibleContainerHandler, ContainerAdapter, DefaultCaret, DefaultCellEditor.EditorDelegate, DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction, DefaultTableColumnModel, DefaultTreeCellEditor, DragSourceAdapter, DragSourceContext, DropTarget, DropTarget.DropTargetAutoScroller, DropTargetAdapter, EventListenerProxy, FocusAdapter, FormView, FormView.MouseEventListener, HierarchyBoundsAdapter, HTMLEditorKit.HTMLTextAction, HTMLEditorKit.InsertHTMLTextAction, HTMLEditorKit.LinkController, InternalFrameAdapter, JCheckBox.AccessibleJCheckBox, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JComboBox, JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler, JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JList.AccessibleJList, JMenu.AccessibleJMenu, JMenu.WinListener, JMenuItem.AccessibleJMenuItem, JPasswordField.AccessibleJPasswordField, JPopupMenu.AccessibleJPopupMenu, JRadioButton.AccessibleJRadioButton, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JScrollPane.AccessibleJScrollPane, JSpinner.AccessibleJSpinner, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, JTabbedPane.AccessibleJTabbedPane, JTabbedPane.ModelListener, JTable, JTable.AccessibleJTable, JTableHeader, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField, JToggleButton.AccessibleJToggleButton, JTree.AccessibleJTree, JTree.TreeModelHandler, JTree.TreeSelectionRedirector, JViewport.ViewListener, KeyAdapter, List.AccessibleAWTList, MetalComboBoxEditor, MetalComboBoxEditor.UIResource, MetalComboBoxUI.MetalPropertyChangeListener, MetalFileChooserUI.DirectoryComboBoxAction, MetalFileChooserUI.FilterComboBoxModel, MetalFileChooserUI.SingleClickListener, MetalLabelUI, MetalRootPaneUI, MetalSliderUI.MetalPropertyListener, MetalToolBarUI.MetalContainerListener, MetalToolBarUI.MetalDockingListener, MetalToolBarUI.MetalRolloverListener, MouseAdapter, MouseDragGestureRecognizer, MouseInputAdapter, MouseMotionAdapter, ProgressMonitor.AccessibleProgressMonitor, PropertyChangeListenerProxy, RelationService, StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction, TextAction, TextArea.AccessibleAWTTextArea, TextComponent.AccessibleAWTTextComponent, TextField.AccessibleAWTTextField, ToolTipManager, ToolTipManager.insideTimerAction, ToolTipManager.outsideTimerAction, ToolTipManager.stillInsideTimerAction, UndoManager, VetoableChangeListenerProxy, WindowAdapter
public interface EventListener

所有事件侦听器接口必须扩展的标记接口。

从以下版本开始：
JDK1.1

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventListenerProxy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 EventListenerProxy

java.lang.Object
    继承者  java.util.EventListenerProxy
所有已实现的接口：
EventListener
直接已知子类：
AWTEventListenerProxy, PropertyChangeListenerProxy, VetoableChangeListenerProxy
public abstract class EventListenerProxy
extends Object
implements EventListener

将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。子类必须为附加的实参或形参提供存储和访问器方法。 EventListenerProxy 的子类作为将指定属性与其侦听器关联的方法，可能由 getListeners() 方法返回。 例如，支持指定属性的 Bean 将包含一个两参数的方法签名，用于为属性添加 PropertyChangeListener： public void addPropertyChangeListener(String propertyName, PropertyChangeListener listener); 如果 Bean 也实现零参数获得侦听器方法： public PropertyChangeListener[] getPropertyChangeListeners(); 那么该数组可能包含内部 PropertyChangeListeners，它也是 PropertyChangeListenerProxy 对象。 如果调用方法可以获取指定属性，那么它必须测试该元素是否是一个代理类。

从以下版本开始：
1.4

构造方法摘要
EventListenerProxy(EventListener listener)
方法摘要
 EventListener getListener()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EventListenerProxy

public EventListenerProxy(EventListener listener)
参数：
listener - 侦听器对象。
方法详细信息

getListener

public EventListener getListener()
返回：
与此代理关联的侦听器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 EventObject

java.lang.Object
    继承者  java.util.EventObject
所有已实现的接口：
Serializable
直接已知子类：
AWTEvent, BeanContextEvent, CaretEvent, ChangeEvent, ConnectionEvent, DragGestureEvent, DragSourceEvent, DropTargetEvent, FlavorEvent, HandshakeCompletedEvent, HyperlinkEvent, LineEvent, ListDataEvent, ListSelectionEvent, MenuEvent, NamingEvent, NamingExceptionEvent, NodeChangeEvent, Notification, PopupMenuEvent, PreferenceChangeEvent, PrintEvent, PropertyChangeEvent, RowSetEvent, RowSorterEvent, SSLSessionBindingEvent, StatementEvent, TableColumnModelEvent, TableModelEvent, TreeExpansionEvent, TreeModelEvent, TreeSelectionEvent, UndoableEditEvent, UnsolicitedNotificationEvent
public class EventObject
extends Object
implements Serializable

所有事件状态对象都将从其派生的根类。

所有 Event 在构造时都引用了对象 "source"，在逻辑上认为该对象是最初发生有关 Event 的对象。

从以下版本开始：
JDK1.1
另请参见：
序列化表格

字段摘要
protected  Object source
最初发生 Event 的对象。
构造方法摘要
EventObject(Object source)
构造一个原型 Event。
方法摘要
Object | getSource() 最初发生 Event 的对象。
String | toString() 返回此 EventObject 的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

source

protected transient Object source
最初发生 Event 的对象。

构造方法详细信息

EventObject

public EventObject(Object source)
构造一个原型 Event。

参数：
source - 最初发生 Event 的对象。
抛出：
IllegalArgumentException - 如果 source 为 null。
方法详细信息

getSource

public Object getSource()
最初发生 Event 的对象。

返回：
最初发生 Event 的对象。

toString

public String toString()
返回此 EventObject 的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
该 EventObject 的 String 表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormatFlagsConversionMismatchException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 FormatFlagsConversionMismatchException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.FormatFlagsConversionMismatchException
所有已实现的接口：
Serializable
public class FormatFlagsConversionMismatchException
extends IllegalFormatException

转换与标志不兼容时抛出未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException 异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
FormatFlagsConversionMismatchException(String f, char c)
构造带指定标志和转换的此类的一个实例。
方法摘要
char | getConversion() 返回不兼容的转换。
String | getFlags() 返回不兼容的标志。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FormatFlagsConversionMismatchException

public FormatFlagsConversionMismatchException(String f,
                                              char c)
构造带指定标志和转换的此类的一个实例。

参数：
f - 标志
c - 转换
方法详细信息

getFlags

public String getFlags()
返回不兼容的标志。

返回：
标志

getConversion

public char getConversion()
返回不兼容的转换。

返回：
转换

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Formattable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Formattable

public interface Formattable

Formattable 接口必须通过需要执行自定义格式化（使用 Formatter 的 's' 转换说明符）的任何类来实现。此接口允许对格式化任意对象的基本控制。 例如，以下类根据标志和长度限制输出股票名称的不同表示形式：

   import java.nio.CharBuffer;
   import java.util.Formatter;
   import java.util.Formattable;
   import java.util.Locale;
   import static java.util.FormattableFlags.*;

  ...

   public class StockName implements Formattable {
       private String symbol, companyName, frenchCompanyName;
       public StockName(String symbol, String companyName,
                        String frenchCompanyName) {
           ...
       }

       ...

       public void formatTo(Formatter fmt, int f, int width, int precision) {
           StringBuilder sb = new StringBuilder();

           // decide form of name
           String name = companyName;
           if (fmt.locale().equals(Locale.FRANCE))
               name = frenchCompanyName;
           boolean alternate = (f & ALTERNATE) == ALTERNATE;
           boolean usesymbol = alternate || (precision != -1 && precision < 10);
           String out = (usesymbol ? symbol : name);

           // apply precision
           if (precision == -1 || out.length() < precision) {
               // write it all
               sb.append(out);
           } else {
               sb.append(out.substring(0, precision - 1)).append('*');
           }

           // apply width and justification
           int len = sb.length();
           if (len < width)
               for (int i = 0; i < width - len; i++)
                   if ((f & LEFT_JUSTIFY) == LEFT_JUSTIFY)
                       sb.append(' ');
                   else
                       sb.insert(0, ' ');

           fmt.format(sb.toString());
       }

       public String toString() {
           return String.format("%s - %s", symbol, companyName);
       }
   }

当与 Formatter 一起使用时，上述类会产生以下各种格式的字符串输出。

   Formatter fmt = new Formatter();
   StockName sn = new StockName("HUGE", "Huge Fruit, Inc.",
                                "Fruit Titanesque, Inc.");
   fmt.format("%s", sn);                   //   -> "Huge Fruit, Inc."
   fmt.format("%s", sn.toString());        //   -> "HUGE - Huge Fruit, Inc."
   fmt.format("%#s", sn);                  //   -> "HUGE"
   fmt.format("%-10.8s", sn);              //   -> "HUGE      "
   fmt.format("%.12s", sn);                //   -> "Huge Fruit,*"
   fmt.format(Locale.FRANCE, "%25s", sn);  //   -> "   Fruit Titanesque, Inc."

可格式化项对于多线程访问而言未必是安全的。线程安全是可选的，并且可以通过扩展和实现此接口的类来强制执行。

除非另行指定，否则将 null 参数传递给此接口中的任何方法都会抛出 NullPointerException。

从以下版本开始：
1.5

方法摘要
 void formatTo(Formatter formatter, int flags, int width, int precision)
使用提供的格式器来格式化对象。

方法详细信息

formatTo

void formatTo(Formatter formatter,
              int flags,
              int width,
              int precision)
使用提供的格式器来格式化对象。

参数：
formatter - 格式器。实现类可以调用 formatter.out() 或 formatter.locale()，以获得分别由此 formatter 使用的 Appendable 或 Locale。
flags - 这些标志将修改输出格式。该值被解释为位掩码(bitmask)。可以将以下标志的组合设置为：FormattableFlags.LEFT_JUSTIFY、FormattableFlags.UPPERCASE 和 FormattableFlags.ALTERNATE。如果没有设置标志，则应用实现类的默认格式。
width - 写入到输出的最少字符数。如果转换值的长度小于 width，那么输出将用 '  ' 来填充，直到总字符数等于 width。默认情况下，从开始处进行填充。如果设置了 FormattableFlags.LEFT_JUSTIFY 标志，则从结尾处进行填充。如果 width 为 -1，则不存在最少字符数。
precision - 写入到输出的最多字符数。precision 应用在 width 之前，因此，即使 width 大于 precision，输出也将被截断为 precision 字符。如果 precision 为 -1，那么对于字符的数量没有明显限制。
抛出：
IllegalFormatException - 如果所有参数都无效。有关所有可能的格式设置错误的规范，请参阅格式器类规范的 Details 一节。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormattableFlags (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 FormattableFlags

java.lang.Object
    继承者  java.util.FormattableFlags

public class FormattableFlags
extends Object

将 FomattableFlags 传递给 Formattable.formatTo() 方法，并修改 Formattables 的输出格式。Formattable 的实现负责解释和验证所有标志。

从以下版本开始：
1.5

字段摘要
static int | ALTERNATE 要求输出使用替换形式。
static int | LEFT_JUSTIFY 将输出左对齐。
static int | UPPERCASE 根据创建 formatTo() 方法的 formatter 参数期间给出的 locale 规则，将输出转换为大写形式。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LEFT_JUSTIFY

public static final int LEFT_JUSTIFY
将输出左对齐。根据需要在所转换值的结尾处添加空格 ('\u0020')，以满足字段的最小宽度要求。如果没有设置此标志，则输出将是右对齐的。

此标志对应于格式说明符中的 '-' ('\u002d')。

另请参见：
常量字段值

UPPERCASE

public static final int UPPERCASE
根据创建 formatTo() 方法的 formatter 参数期间给出的 locale 规则，将输出转换为大写形式。输出应该等同于 String.toUpperCase(java.util.Locale) 的以下调用
     out.toUp2perCase()

此标志对应于格式说明符中的 '^' ('\u005e')。

另请参见：
常量字段值

ALTERNATE

public static final int ALTERNATE
要求输出使用替换形式。该形式的定义是由 Formattable 指定的。

此标志对应于格式说明符中的 '#' ('\u0023')。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Formatter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Formatter

java.lang.Object
    继承者  java.util.Formatter
所有已实现的接口：
Closeable, Flushable
public final class Formatter
extends Object
implements Closeable, Flushable

printf 风格的格式字符串的解释程序。此类提供了对布局对齐和排列的支持，以及对数值、字符串和日期/时间数据的常规格式和特定于语言环境的输出的支持。支持诸如 byte、BigDecimal 和 Calendar 等常见 Java 类型。任意用户类型的受限格式化定制都是通过 Formattable 接口提供的。

Formatter 对于多线程访问而言没必要是安全的。线程安全是可选的，它对此类中的方法用户负责。

Java 语言的格式化输出在很大程度上受到 C 语言 printf 的启发。虽然一些格式字符串与 C 类似，但已进行了某些定制，以适应 Java 语言，并且利用了其中一些特性。此外，Java 的格式比 C 的格式更严格；例如，如果转换与标志不兼容，则会抛出异常。在 C 中，不适用的标志会被忽略。这样，便于 C 程序员识别这些格式字符串，而又不必与 C 中的那些标志完全兼容。

所期望用法的示例：

   StringBuilder sb = new StringBuilder();
   // Send all output to the Appendable object sb
   Formatter formatter = new Formatter(sb, Locale.US);

   // Explicit argument indices may be used to re-order output.
   formatter.format("%4$2s %3$2s %2$2s %1$2s", "a", "b", "c", "d")
   // -> " d  c  b  a"

   // Optional locale as the first argument can be used to get
   // locale-specific formatting of numbers.  The precision and width can be
   // given to round and align the value.
   formatter.format(Locale.FRANCE, "e = %+10.4f", Math.E);
   // -> "e =    +2,7183"

   // The '(' numeric flag may be used to format negative numbers with
   // parentheses rather than a minus sign.  Group separators are
   // automatically inserted.
   formatter.format("Amount gained or lost since last statement: $ %(,.2f",
                    balanceDelta);
   // -> "Amount gained or lost since last statement: $ (6,217.58)"

常见格式化请求的便捷方法是按照如下调用格式来阐明的：

   // Writes a formatted string to System.out.
   System.out.format("Local time: %tT", Calendar.getInstance());
   // -> "Local time: 13:34:18"

   // Writes formatted output to System.err.
   System.err.printf("Unable to open file '%1$s': %2$s",
                     fileName, exception.getMessage());
   // -> "Unable to open file 'food': No such file or directory"

与 C 语言的 sprintf(3) 类似，可以使用静态方法 String#format(String,Object...)String.format 来格式化 Strings：

   // Format a string containing a date.
   import java.util.Calendar;
   import java.util.GregorianCalendar;
   import static java.util.Calendar.*;

   Calendar c = new GregorianCalendar(1995, MAY, 23);
   String s = String.format("Duke's Birthday: %1$tm %1$te,%1$tY", c);
   // -> s == "Duke's Birthday: May 23, 1995"

结构

此规范分为两部分。第一部分是摘要，包括基本的格式概念。这一部分是为那些想要快速入门并熟悉其他编程语言的格式化输出的用户准备的。第二部分是详细信息，包括具体的实现细节。它是为那些需要更精确格式化行为规范的用户准备的。

摘要

这一部分将提供对格式概念的简单概述。有关精确的行为细节，请参阅详细信息部分。

格式字符串语法

产生格式化输出的每个方法都需要格式字符串 和参数列表。格式字符串是一个 String，它可以包含固定文本以及一个或多个嵌入的格式说明符。请考虑以下示例：

   Calendar c = ...;
   String s = String.format("Duke's Birthday: %1$tm %1$te,%1$tY", c);
此格式字符串是 format 方法的第一个参数。它包含三个格式说明符 "%1$tm"、"%1$te" 和 "%1$tY"，它们指出应该如何处理参数以及在文本的什么地方插入它们。格式字符串的其余部分是包括 "Dukes Birthday: " 和其他任何空格或标点符号的固定文本。 参数列表由传递给位于格式字符串之后的方法的所有参数组成。在上述示例中，参数列表的大小为 1，由对象 Calendar c 组成。
  • 常规类型、字符类型和数值类型的格式说明符的语法如下：
       %[argument_index$][flags][width][.precision]conversion

    可选的 argument_index 是一个十进制整数，用于表明参数在参数列表中的位置。第一个参数由 "1$" 引用，第二个参数由 "2$" 引用，依此类推。

    可选 flags 是修改输出格式的字符集。有效标志集取决于转换类型。

    可选 width 是一个非负十进制整数，表明要向输出中写入的最少字符数。

    可选 precision 是一个非负十进制整数，通常用来限制字符数。特定行为取决于转换类型。

    所需 conversion 是一个表明应该如何格式化参数的字符。给定参数的有效转换集取决于参数的数据类型。

  • 用来表示日期和时间类型的格式说明符的语法如下：
       %[argument_index$][flags][width]conversion

    可选的 argument_index、flags 和 width 的定义同上。

    所需的 conversion 是一个由两字符组成的序列。第一个字符是 't' 或 'T'。第二个字符表明所使用的格式。这些字符类似于但不完全等同于那些由 GNU date 和 POSIX strftime(3c) 定义的字符。

  • 与参数不对应的格式说明符的语法如下：
       %[flags][width]conversion

    可选 flags 和 width 的定义同上。

    所需的 conversion 是一个表明要在输出中所插内容的字符。

转换

转换可分为以下几类：

  1. 常规 - 可应用于任何参数类型
  2. 字符 - 可应用于表示 Unicode 字符的基本类型：char、Character、byte、Byte、short 和 Short。当 Character.isValidCodePoint(int) 返回 true 时，可将此转换应用于 int 和 Integer 类型
  3. 数值
    1. 整数 - 可应用于 Java 的整数类型：byte、Byte、short、Short、int、Integer、long、Long 和 BigInteger
    2. 浮点 - 可用于 Java 的浮点类型：float、Float、double、Double 和 BigDecimal
  4. 日期/时间 - 可应用于 Java 的、能够对日期或时间进行编码的类型：long、Long、Calendar 和 Date。
  5. 百分比 - 产生字面值 '%' ('\u0025')
  6. 行分隔符 - 产生特定于平台的行分隔符

下表总结了受支持的转换。由大写字符（如 'B'、'H'、'S'、'C'、'X'、'E'、'G'、'A' 和 'T'）表示的转换与由相应的小写字符的转换等同，根据流行的 Locale 规则将结果转换为大写形式除外。后者等同于 String.toUpperCase() 的以下调用

    out.toUpperCase()
转换 | 参数类别 | 说明
'b', 'B' | 常规 | 如果参数 arg 为 null，则结果为 "false"。如果 arg 是一个 boolean 值或 Boolean，则结果为 String.valueOf() 返回的字符串。否则结果为 "true"。
'h', 'H' | 常规 | 如果参数 arg 为 null，则结果为 "null"。否则，结果为调用 Integer.toHexString(arg.hashCode()) 得到的结果。
's', 'S' | 常规 | 如果参数 arg 为 null，则结果为 "null"。如果 arg 实现 Formattable，则调用 arg.formatTo。否则，结果为调用 arg.toString() 得到的结果。
'c', 'C' | 字符 | 结果是一个 Unicode 字符
'd' | 整数 | 结果被格式化为十进制整数
'o' | 整数 | 结果被格式化为八进制整数
'x', 'X' | 整数 | 结果被格式化为十六进制整数
'e', 'E' | 浮点 | 结果被格式化为用计算机科学记数法表示的十进制数
'f' | 浮点 | 结果被格式化为十进制数
'g', 'G' | 浮点 | 根据精度和舍入运算后的值，使用计算机科学记数形式或十进制格式对结果进行格式化。
'a', 'A' | 浮点 | 结果被格式化为带有效位数和指数的十六进制浮点数
't', 'T' | 日期/时间 | 日期和时间转换字符的前缀。请参阅日期/时间转换。
'%' | 百分比 | 结果为字面值 '%' ('\u0025')
'n' | 行分隔符 | 结果为特定于平台的行分隔符

任何未明确定义为转换的字符都是非法字符，并且都被保留，以供将来扩展使用。

日期/时间转换

以下日期和时间转换的后缀字符是为 't' 和 'T' 转换定义的。这些类型相似于但不完全等同于那些由 GNU date 和 POSIX strftime(3c) 定义的类型。提供其他转换类型是为了访问特定于 Java 的功能（如将 'L' 用作秒中的毫秒）。

以下转换字符用来格式化时间：

'H' | 24 小时制的小时，被格式化为必要时带前导零的两位数，即 00 - 23。
'I' | 12 小时制的小时，被格式化为必要时带前导零的两位数，即 01 - 12。
'k' | 24 小时制的小时，即 0 - 23。
'l' | 12 小时制的小时，即 1 - 12。
'M' | 小时中的分钟，被格式化为必要时带前导零的两位数，即 00 - 59。
'S' | 分钟中的秒，被格式化为必要时带前导零的两位数，即 00 - 60 （"60" 是支持闰秒所需的一个特殊值）。
'L' | 秒中的毫秒，被格式化为必要时带前导零的三位数，即 000 - 999。
'N' | 秒中的毫微秒，被格式化为必要时带前导零的九位数，即 000000000 - 999999999。
'p' | 特定于语言环境的 上午或下午 标记以小写形式表示，例如 "am" 或 "pm"。使用转换前缀 'T' 可以强行将此输出转换为大写形式。
'z' | 相对于 GMT 的 RFC 822 格式的数字时区偏移量，例如 -0800。
'Z' | 表示时区缩写形式的字符串。Formatter 的语言环境将取代参数的语言环境（如果有）。
's' | 自协调世界时 (UTC) 1970 年 1 月 1 日 00:00:00 至现在所经过的秒数，即 Long.MIN_VALUE/1000 与 Long.MAX_VALUE/1000 之间的差值。
'Q' | 自协调世界时 (UTC) 1970 年 1 月 1 日 00:00:00 至现在所经过的毫秒数，即 Long.MIN_VALUE 与 Long.MAX_VALUE 之间的差值。

以下转换字符用来格式化日期：

'B' | 特定于语言环境的月份全称，例如 "January" 和 "February"。
'b' | 特定于语言环境的月份简称，例如 "Jan" 和 "Feb"。
'h' | 与 'b' 相同。
'A' | 特定于语言环境的星期几全称，例如 "Sunday" 和 "Monday"
'a' | 特定于语言环境的星期几简称，例如 "Sun" 和 "Mon"
'C' | 除以 100 的四位数表示的年份，被格式化为必要时带前导零的两位数，即 00 - 99
'Y' | 年份，被格式化为必要时带前导零的四位数（至少），例如，0092 等于格里高利历的 92 CE。
'y' | 年份的最后两位数，被格式化为必要时带前导零的两位数，即 00 - 99。
'j' | 一年中的天数，被格式化为必要时带前导零的三位数，例如，对于格里高利历是 001 - 366。
'm' | 月份，被格式化为必要时带前导零的两位数，即 01 - 13。
'd' | 一个月中的天数，被格式化为必要时带前导零两位数，即 01 - 31
'e' | 一个月中的天数，被格式化为两位数，即 1 - 31。

以下转换字符用于格式化常见的日期/时间组合。

'R' | 24 小时制的时间，被格式化为 "%tH:%tM"
'T' | 24 小时制的时间，被格式化为 "%tH:%tM:%tS"。
'r' | 12 小时制的时间，被格式化为 "%tI:%tM:%tS %Tp"。上午或下午标记 ('%Tp') 的位置可能与语言环境有关。
'D' | 日期，被格式化为 "%tm/%td/%ty"。
'F' | ISO 8601 格式的完整日期，被格式化为 "%tY-%tm-%td"。
'c' | 日期和时间，被格式化为 "%ta %tb %td %tT %tZ %tY"，例如 "Sun Jul 20 16:17:00 EDT 1969"。

任何未明确定义为转换的字符都是非法字符，并且都被保留，以供将来扩展使用。

标志

下表总结了受支持的标志。y 表示该标志受指示参数类型支持。

标志 | 常规 | 字符 | 整数 | 浮点 | 日期/时间 | 说明
'-' | y | y | y | y | y | 结果将是左对齐的。
'#' | y1 | - | y3 | y | - | 结果应该使用依赖于转换类型的替换形式
'+' | - | - | y4 | y | - | 结果总是包括一个符号
' ' | - | - | y4 | y | - | 对于正值，结果中将包括一个前导空格
'0' | - | - | y | y | - | 结果将用零来填充
',' | - | - | y2 | y5 | - | 结果将包括特定于语言环境的组分隔符
'(' | - | - | y4 | y5 | - | 结果将是用圆括号括起来的负数

1 取决于 Formattable 的定义。

2 只适用于 'd' 转换。

3 只适用于 'o'、'x' 和 'X' 转换。

4 对 BigInteger 应用 'd'、'o'、'x' 和 'X' 转换时，或者对 byte 及 Byte、short 及 Short、int 及 Integer、long 及 Long 分别应用 'd' 转换时适用。

5 只适用于 'e'、'E'、'f'、'g' 和 'G' 转换。

任何未显式定义为标志的字符都是非法字符，并且都被保留，以供扩展使用。

宽度

宽度是将向输出中写入的最少字符数。对于行分隔符转换，不适用宽度，如果提供宽度，则会抛出异常。

精度

对于常规参数类型，精度是将向输出中写入的最多字符数。

对于浮点转换 'e'、'E' 和 'f'，精度是小数点分隔符后的位数。如果转换是 'g' 或 'G'，那么精度是舍入计算后所得数值的所有位数。如果转换是 'a' 或 'A'，则不必指定精度。

对于字符、整数和日期/时间参数类型转换，以及百分比和行分隔符转换，精度是不适用的；如果提供精度，则会抛出异常。

参数索引

参数索引是一个十进制整数，用于表明参数在参数列表中的位置。第一个参数由 "1$" 引用，第二个参数由 "2$" 引用，依此类推。

根据位置引用参数的另一种方法是使用 '<' ('\u003c') 标志，这将会重用以前格式说明符的参数。例如，以下两条语句产生的字符相同：

   Calendar c = ...;
   String s1 = String.format("Duke's Birthday: %1$tm %1$te,%1$tY", c);

   String s2 = String.format("Duke's Birthday: %1$tm %<te,%<tY", c);

详细信息

这一部分将提供格式化行为规范方面的细节，其中包括条件和异常、受支持的数据类型、本地化以及标志、转换和数据类型之间的交互。有关格式化概念的概述，请参阅摘要。

任何未明确定义为转换、日期/时间转换前缀或标志的字符都是非法字符，并且这些字符都被保留，以供未来扩展使用。在格式字符串中使用这样的字符会导致抛出 UnknownFormatConversionException 或 UnknownFormatFlagsException。

如果格式说明符包含带有无效值或不受支持的其他值的宽度或精度，则将分别抛出 IllegalFormatWidthException 或 IllegalFormatPrecisionException。

如果格式说明符包含不适用于对应参数的转换字符，则将抛出 IllegalFormatConversionException。

所有指定异常都可能被 Formatter 的任何 format 方法以及任何 format 的便捷方法抛出，比如 String#format(String,Object...)String.format 和 java.io.PrintStream#printf(String,Object...)PrintStream.printf。 String.format} and PrintStream.printf.

由大写字符（如 'B'、'H'、'S'、'C'、'X'、'E'、'G'、'A' 和 'T'）表示的转换与那些相应的小写字符表示的转换相同，根据流行的 Locale 规则将结果转换成大写形式除外。结果等同于 String.toUpperCase() 的以下调用

    out.toUpperCase()

常规

以下常规转换可应用于任何参数类型：

'b' | '\u0062' | 将生成 "true" 或 "false"，由 Boolean.toString(boolean) 返回。 如果参数为 null，则结果为 "false"。如果参数是一个 boolean 值或 Boolean，那么结果是由 String.valueOf() 返回的字符串。否则结果为 "true"。 如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。
'B' | '\u0042' | 'b' 的大写形式。
'h' | '\u0068' | 生成一个表示对象的哈希码值的字符串。 如果参数 arg 为 null，则结果为 "null"。否则，结果为调用 Integer.toHexString(arg.hashCode()) 得到的结果。 如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。
'H' | '\u0048' | 'h' 的大写形式。
's' | '\u0073' | 生成一个字符串。 如果参数为 null，则结果为 "null"。如果参数实现了 Formattable，则调用其 formatTo 方法。否则，结果为调用参数的 toString() 方法得到的结果。 如果给出 '#' 标志，且参数不是 Formattable，则将抛出 FormatFlagsConversionMismatchException。
'S' | '\u0053' | 's' 的大写形式。

以下 标志 应用于常规转换：

'-' | '\u002d' | 将输出左对齐。根据需要在转换值结尾处添加空格 ('\u0020')，以满足字段的最小宽度要求。如果没有提供宽度，则将抛出 MissingFormatWidthException。如果没有给出此标志，则输出将是右对齐的。
'#' | '\u0023' | 要求输出使用替换形式。此形式的定义通过转换指定。

宽度 是将向输出中写入的最少字符数。如果转换值的长度小于宽度，则用 '  ' (\u0020') 填充输出，直到字符总数等于宽度为止。默认情况下，是在左边进行填充。如果给出 '-' 标志，则在右边进行填充。如果没有指定宽度，则没有最小宽度。

精度是将向输出中写入的最多字符数。精度的应用要先于宽度，因此，即使宽度大于精度，输出也将被截取为 precision 字符。如果没有指定精度，则对字符数没有明确限制。

字符

此转换可应用于 char 和 Character。它还可应用于类型 byte、Byte、short 和 Short、 int 和 Integer。当 Character.isValidCodePoint(int) 返回 true 时，此转换也可应用于 int 和 Integer。如果返回 false，则将抛出 IllegalFormatCodePointException。
'c' | '\u0063' | 将参数格式化为 Unicode Character Representation 中描述的 Unicode 字符。在该参数表示增补字符的情况下，它可能是多个 16 位 char。 如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。
'C' | '\u0043' | 'c' 的大写形式。

'-' 标志是为应用常规转换而定义的。如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。

宽度是为了实现常规转换而定义的。

精度不适用。如果指定精度，则将抛出 IllegalFormatPrecisionException。

数值

数值转换分为以下几类：

  1. Byte、Short、Integer 和 Long
  2. BigInteger
  3. Float 和 Double
  4. BigDecimal

将根据以下算法对数值类型进行格式化：

数字本地化算法

在获得数字的整数部分、小数部分和指数（适用于数据类型）之后，将应用以下转换：

  1. 将字符串中的每个数字字符 d 都替换为特定于语言环境的数字，该数字是相对于当前语言环境的零数字 z 来计算的；即 d - '0' + z。
  2. 如果存在小数点分隔符，则用特定于语言环境的小数点分隔符替换。
  3. 如果给出 ',' ('\u002c') flag 标志，则插入特定于语言环境的组分隔符，这是通过从最低位到最高位浏览字符串的整数部分并不时插入该语言环境组大小定义的分隔符来实现的。
  4. 如果给出 '0' 标志，则在符号字符（如果有的话）之后、第一个非零数字前插入特定于语言环境的零数字，直到字符串长度等于所要求的字段宽度。
  5. 如果该值为负，并且给出了 '(' 标志，那么预先考虑 '(' ('\u0028')，并追加一个 ')' ('\u0029')。
  6. 如果该值为负（或者为浮点负零），并且没有给出 '(' 标志，那么预先考虑 '-' ('\u002d')。
  7. 如果给出 '+' 标志，并且该值为正或零（或者为浮点正零），那么将预先考虑 '+' ('\u002b')。

如果该值为 NaN 或正无穷大，则分别输出文本字符串 "NaN" 或 "Infinity"。如果该值为负无穷大，那么输出将是 "(Infinity)"；否则如果给出 '(' 标志，那么输出将是 "-Infinity"。这些值都没有被本地化。

Byte、Short、Integer 和 Long

以下转换可应用于 byte、Byte、short、Short、int、Integer、long 和 Long。

'd' | '\u0054' | 将参数格式化为十进制整数。应用本地化算法。 如果给出 '0' 标志，并且值为负，则在符号后填充零。 如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。
'o' | '\u006f' | 将参数格式化为以 8 为基数的整数。不应用本地化。 如果 x 为负，那么结果将是通过将 2n 添加到值中产生的一个无符号值，其中 n 是在适当时候由类 Byte、Short、Integer 或 Long 中的静态 SIZE 字段返回的类型中的位数。 如果给出 '#' 标志，则输出将始终以基数指示符 '0' 开始。 如果给出 '0' 标志，则使用前导零填充输出，这些零被填充到以下任意指示符号后面的字段宽度中。 如果给出 '('、'+'、' ' 或 '、' 标志，则将抛出 FormatFlagsConversionMismatchException。
'x' | '\u0078' | 将参数格式化为以 16 为基数的整数。不应用本地化。 如果 x 为负，那么结果将为把 2n 添加到值中产生的一个无符号值，其中 n 是在适当时候，由类 Byte、Short、Integer 或 Long 中的静态 SIZE 字段返回的类型中的位数。 如果给出 '#' 标志，则输出将始终以基数指示符 '0x' 开始。 如果给出 '0' 标志，则使用前导零填充输出，这些零被填充到基数指示符或符号（如果存在）后面的字段宽度中。 如果给出 '('、' '、'+' 或 '、' 标志，则将抛出 FormatFlagsConversionMismatchException。
'X' | '\u0058' | 'x' 的大写形式。将表示数字的整个字符串转换为大写，其中包括 'x' （如果有的话） 和所有十六进制数字 'a' - 'f' ('\u0061' - '\u0066')。

如果该转换是 'o'、'x' 或 'X' 转换，并且给出了 '#' 和 '0' 标志，那么结果将包含基数指示符（对于八进制是 '0'，对于十六进制是 '0' 或 "0x"）、一定数量的零（基于宽度）和该值。

如果没有给出 '-' 标志，则在符号前填充空格。

以下 标志 应用于数值整数转换：

'+' | '\u002b' | 要求所有正数的输出都包含一个正号。如果没有给出此标志，则只有负值包含符号。 如果同时给出了 '+' 和 ' ' 标志，则将抛出 IllegalFormatFlagsException。
' ' | '\u0020' | 对于非负值的输出，要求包括单个额外空格 ('\u0020')。 如果同时给出了 '+' 和 ' ' 标志，则将抛出 IllegalFormatFlagsException。
'0' | '\u0030' | 要求将前导零填充到输出中，这些零被填充到以下任意符号或基数指示符之后，以达到最小字段宽度，转换 NaN 或无穷大时除外。如果没有提供宽度，则将抛出 MissingFormatWidthException。 如果同时给出 '-' 和 '0' 标志，则将抛出 IllegalFormatFlagsException。
',' | '\u002c' | 要求输出包括在本地化算法的“群”一节中描述的特定于语言环境的组分隔符。
'(' | '\u0028' | 要求输出预先考虑 '(' ('\u0028')，并将 ')' ('\u0029') 追加到负值中。

如果没有给出 标志 ，则默认格式设置如下：

  • width 中的输出是右对齐的
  • 负数以 '-' ('\u002d') 开始
  • 正数和零不包括符号或额外的前导空格
  • 不包括组分隔符

The 宽度 是将向输出中写入的最少字符数。这包括所有符号、数字、组分隔符、基数指示符和圆括号。如果转换值的长度小于宽度，则用空格('\u0020') 填充输出，直到字符总数等于宽度。默认情况下，在左边进行填补。如果给出 '-' 标志，则在右边进行填补。如果没有指定宽度，则没有最小宽度。

精度不适用。如果指定精度，则将抛出 IllegalFormatPrecisionException。

BigInteger

以下转换可应用于 BigInteger。

'd' | '\u0054' | 要求将输出格式化为十进制整数。应用本地化算法。 如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。
'o' | '\u006f' | 要求将输出格式化为以 8 为基数的整数。不应用本地化。 如果 x 为负，那么结果将是以 '-' ('\u002d') 开始的有符号值。允许对这种类型使用有符号输出，因为它不同于基本类型，在没有假定显式数据类型大小的情况下，不可能创建无符号的等效值。 如果 x 为正数或零，且给出了 '+' 标志，那么结果是以 '+' ('\u002b') 开始的。 如果给出 '#' 标志，那么输出将始终以 '0' 前缀开始。 如果给出 '0' 标志，那么将使用前导零填充输出，这些零被填充到指示符后的字段宽度中。 如果给出 ',' 标志，则将抛出 FormatFlagsConversionMismatchException。
'x' | '\u0078' | 要求将输出格式化为以 16 为基数的整数。不应用本地化。 如果 x 为负，那么结果是以 '-' ('_apos;) 开始的有符号值。此类型允许使用有符号输出，因为与基本类型不同，如果不假定明确的数据类型大小，则不可能创建无符号的等效数。 如果 x 为正数或零，且给出了 '+' 标志，那么结果以 '+' ('\u002b') 开始。 如果给出 '#' 标志，那么输出将始终以基数指示符 '0x' 开始。 如果给出 '0' 标志，那么将使用前导零填充输出，这些零被填充到基数指示符或符号（如果存在）后面的字段宽度中。 如果给出 ',' 标志，则将抛出 FormatFlagsConversionMismatchException。
'X' | '\u0058' | 'x' 的大写形式。将表示数字的整个字符串转换为大写，其中包括 'x'（如果有的话）和所有十六进制数字 'a' - 'f' ('\u0061' - '\u0066')。

如果该转换是 'o'、'x' 或 'X'，并且给出了 '#' 和 '0' 标志，那么结果将包含基数指示符（对于八进制是 '0'，对于十六进制是 '0' 或 "0x"）、一定数量的零（基于宽度）和该值。

如果给出 '0' 标志，并且值为负，则在符号后填充零。

如果没有给出 '-' 标志，则在符号前填充空格。

应用为 Byte、Short、Integer 和 Long 定义的所有标志。没有给出标志时的默认行为与 Byte、Short、Integer 和 Long 的行为相同。

宽度的规范与为 Byte、Short、Integer 和 Long 定义的规范相同。

精度不适用。如果指定精度，则将抛出 IllegalFormatPrecisionException。

Float 和 Double

以下转换可应用于 float、Float、double 和 Double。

'e' '\u0065' 要求使用科学记数法来格式化输出。应用本地化算法。

数值 m 的格式取决它的值。

如果 m 是 NaN 或无穷大，则分别输出文本字符串 "NaN" 或 "Infinity"。这些值都没有被本地化。

如果 m 是正零或负零，则指数将是 "+00"。

否则，结果是表示变量的符号和大小（绝对值）的字符串。符号的格式在本地化算法中已经描述。数值 m 的格式取决它的值。

让 n 成为满足 10n <= m < 10n+1 的唯一整数；让 a 成为 m 和 10n 的精确算术商数值，且满足 1 <= a < 10。然后将该数值解释为 a 的整数部分，因为是一个小数位数，所以后面跟着小数点分隔符，再后面是表示 a 的小数部分的小数位数，后跟指数符号 'e' ('\u0065')，这之后是指数符号，后跟十进制整数形式表示的 n，它由方法 Long.toString(long, int) 产生，并用零填充，使其至少包括两个位数。

在结果中，m 或 a 的小数部分的位数等于精度。如果没有指定精度，则默认值为 6。如果精度小于将出现在分别由 Float.toString(float) 或 Double.toString(double) 返回的字符串中的小数点之后的位数，则使用四舍五入算法对该值进行舍入运算。否则，可能通过追加零来达到所需精度。要获得该值的规范表示形式，请在适当时候使用 Float.toString(float) 或 Double.toString(double)。

如果给出 ',' 标志，则将抛出 FormatFlagsConversionMismatchException。

'E' | '\u0045' | 'e' 的大写形式。指数符号将是 'E' ('\u0045')。
'g' '\u0067' 要求将输出格式化为下面描述的常规科学记数形式。应用本地化算法。

在对精度进行舍入运算后，所得数值 m 的格式取决于它的值。

如果 m 大于等于 10-4 但小于 10精度，则以十进制形式 表示它。

如果 m 小于 10-4 或者大于等于 10精度，则以计算机科学记数法 表示它。

m 中的总有效位数等于其精度。如果没有指定精度，则其默认值为 6。如果精度为 0，则该值将为 1。

如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。

'G' | '\u0047' | 'g' 的大写形式。
'f' '\u0066' 要求使用十进制形式来格式化输出。使用本地化算法。

结果是表示参数的符号和大小（绝对值）的字符串。符号的格式在本地化算法中已经描述。数值 m 的格式取决它的值。

如果 m 是 NaN 或无穷大，则将分别输出文本字符串 "NaN" 或 "Infinity"。这些值都没有被本地化。

将数值格式化为 m 的整数部分（不带前导零），后跟小数点分隔符，再后面是表示 m 的小数部分的一个或多个十进制数字。

在结果中，m 或 a 的小数部分的位数等于精度。如果没有指定精度，则默认值为 6。如果该精度小于将要出现在分别由 Float.toString(float) 或 Double.toString(double) 返回的字符串中的小数点之后的位数，则使用四舍五入算法对该值进行舍入运算。否则，可能通过追加零来达到所需精度。要获得该值的规范表示形式，请在适当时候使用 Float.toString(float) 或 Double.toString(double)。

'a' '\u0061' 要求将输出格式化为十六进制指数形式。不应用本地化。

结果是表示参数 x 的符号和大小（绝对值）的字符串。

如果 x 为负值或负零值，那么结果将以 '-' ('\u002d') 开始。

如果 x 为正值或正零值，且给出了 '+' 标志，那么结果将以 '+' ('\u002b') 开始。

数值 m 的格式取决它的值。

  • 如果该值是 NaN 或无穷大，则将分别输出文本字符串 "NaN" 或 "Infinity"。
  • 如果 m 等于零，则用字符串 "0x0.0p0" 表示它。
  • 如果 m 是具有标准化表现形式的 double 值，则用子字符串来表示有效位数和指数字段。有效位数是用字符串 "0x1." 表示的，后跟该有效位数小数部分的十六进制表示形式。指数用 'p' ('\u0070') 表示，后跟无偏指数的十进制字符串，该值是对指数值调用 Integer.toString 所产生的。
  • 如果 m 是具有低正常表现形式的 double 值，则用字符 "0x0." 表示有效位数，后跟该有效位数小数部分的十六进制表示。用 'p-1022' 表示指数。注意，在低正常有效位数中，至少必须有一个非零数字。

如果给出 '(' 或 ',' 标志，则将抛出 FormatFlagsConversionMismatchException。

'A' | '\u0041' | 'a' 的大写形式。表示数字的整个字符串将被转换为大写形式，其中包括 'x' ('\u0078') 和 'p' ('\u0070' 以及所有的十六进制数字 'a' - 'f' ('\u0061' - '\u0066')。

应用为 Byte、Short、Integer 和 Long 定义的所有标志。

如果给出 '#' 标志，则将始终存在小数点分隔符。

如果没有给出 标志 则默认格式设置如下：

  • width 中的输出是右对齐的。
  • 负数以 '-' 开头
  • 正数和正零不包括符号或额外的前导空格
  • 不包括组分隔符
  • 小数点分隔符只在后面有数字时才出现

The 宽度 是将向输出中写入的最少字符数。这包括可应用的所有符号、数字、组分隔符、小数点分隔符、指数符号、基数指示符、圆括号和表示无穷大和 NaN 的字符串。如果转换值的长度小于宽度，则用空格('\u0020') 填充输出，直到字符总数等于宽度。默认情况下，在左边进行填充。如果给出 '-' 标志，则在右边进行填充。如果没有指定宽度，则没有最小宽度。

如果 转换 是 'e'、'E' 或 'f'，则精度是小数点分隔符后的位数。如果没有指定精度，则假定精度为 6。

如果转换是 'g' 或 'G' 转换，那么精度就是舍入运算后所得数值的总有效位数。如果没有指定精度，则默认值为 6。如果精度为 0，则该值将为 1。

如果转换是 'a' 或 'A' 转换，则精度是小数点分隔符后十六进制数字的位数。如果没有提供精度，则将输出 Double.toHexString(double) 返回的所有数字。

BigDecimal

以下转换可应用于 BigDecimal。

'e' '\u0065' 要求使用计算机科学记数法对输出进行格式化。应用本地化算法。

数值 m 的格式取决于它的值。

如果 m 为正零或负零，则指数将为 "+00"。

否则，结果是表示参数的符号和大小（绝对值）的字符串。符号的格式在本地化算法中已经描述。数值 m 的格式取决于它的值。

让 n 成为满足 10n <= m < 10n+1 的唯一整数；让 a 成为 m 和 10n 的精确算术商数值，且满足 1 <= a < 10。然后将该数值解释为 a 的整数部分，因为是一个小数位数，所以后面跟着小数点分隔符，再后面是表示 a 的小数部分的小数位数，后跟指数符号 'e' ('\u0065')，这之后是指数符号，后跟十进制整数形式表示的 n，它由方法 Long.toString(long, int) 产生，并用零填充，使其至少包括两个位数。

在结果中，m 或 a 的小数部分的位数等于精度。如果没有指定精度，则默认值为 6。如果精度小于将出现在分别由 Float.toString(float) 或 Double.toString(double) 返回的字符串中的小数点之后的位数，则使用四舍五入算法对该值进行舍入运算。否则，可能通过追加零来达到所需精度。要获得该值的规范表示形式，请使用 BigDecimal.toString()。

如果给出 ',' 标志，则将抛出 FormatFlagsConversionMismatchException。

'E' | '\u0045' | 'e' 的大写形式。指数符号将是 'E' ('\u0045')。
'g' '\u0067' 要求将输出格式化为下面描述的常规科学记数形式。应用本地化算法。

在对精度进行舍入运算后，所得数值 m 的格式取决于它的值。

如果 m 大于等于 10-4 但小于 10精度，则以十进制形式 表示它。

如果 m 小于 10-4 或者大于等于 10精度，则以计算机科学记数法 表示它。

m 中的总的有效位数等于精度。如果没有指定精度，则默认值为 6。如果精度为 0，则该值将为 1。

如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。

'G' | '\u0047' | 'g' 的大写形式。
'f' '\u0066' 要求使用十进制形式来格式化输出。应用本地化算法。

结果是表示参数的符号和大小（绝对值）的字符串。符号的格式在本地化算法中已经描述。数值 m 的格式取决于它的值。

将该数值格式化为 m 的整数部分（不带前导零），后跟小数点分隔符，再后面是表示 m 的小数部分的一个或多个十进制数字。

在结果中，m 或 a 的小数部分的位数等于精度。如果没有指定精度，则默认值为 6。如果精度小于将出现在分别由 Float.toString(float) 或 Double.toString(double) 返回的字符串中的小数点之后的位数，则使用四舍五入算法对该值进行舍入运算。否则，可能通过追加零来达到所需精度。要获得该值的规范表示形式，请使用 BigDecimal.toString()。

应用为 Byte、Short、Integer 和 Long 定义的所有标志。

如果给出 '#' 标志，则将始终存在小数点分隔符。

没有给出标志时的默认行为与 Float 和 Double 的行为相同。

宽度和精度的规范与为 Float 和 Double 定义的规范相同。

日期/时间

此转换可应用于 long、Long、Calendar 和 Date。

't' | '\u0074' | 日期和时间转换字符的前缀。
'T' | '\u0054' | 't' 的大写形式。

以下日期和时间转换字符后缀是为 't' 和 'T' 转换定义的。这些类型类似于但不完全等同于 GNU date 和 POSIX strftime(3c) 定义的那些类型。提供其他转换类型是为了访问特定于 Java 的功能（例如，'L' 用于秒中的毫秒）。

以下转换字符用来格式化时间：

'H' | '\u0048' | 24 小时制的小时，被格式化为必要时带前导零的两位数，即 00 - 23。00 对应午夜。
'I' | '\u0049' | 12 小时制的小时，被格式化为必要时带前导零的两位数，即 01 - 12。01 对应于 1 点钟（上午或下午）。
'k' | '\u006b' | 24 小时制的小时，即 0 - 23。0 对应于午夜。
'l' | '\u006c' | 12 小时制的小时，即 1 - 12。1 对应于上午或下午的一点钟。
'M' | '\u004d' | 小时中的分钟，被格式化为必要时带前导零的两位数，即 00 - 59。
'S' | '\u0053' | 分钟中的秒，被格式化为必要时带前导零的两位数，即 00 - 60（"60" 是支持闰秒所需的一个特殊值）。
'L' | '\u004c' | 秒中的毫秒，被格式化为必要时带前导零的三位数，即 000 - 999。
'N' | '\u004e' | 秒中的毫微秒，被格式化为必要时带前导零的九位数，即 000000000 - 999999999。此值的精度受底层操作系统或硬件解析的限制。
'p' | '\u0070' | 特定于语言环境的上午或下午标记以小写形式表示，例如 "am" 或 "pm"。使用转换前缀 'T' 可以强行将此输出转换为大写形式。（注意，'p' 产生的输出是小写的。而 GNU date 和 POSIX strftime(3c) 产生的输出是大写的。）
'z' | '\u007a' | 相对于 GMT 的 RFC 822 格式的数字时区偏移量，例如 -0800。
'Z' | '\u005a' | 表示时区的缩写形式的字符串。
's' | '\u0073' | 自协调世界时 (UTC) 1970 年 1 月 1 日 00:00:00 至现在所经过的秒数，也就是 Long.MIN_VALUE/1000 与 Long.MAX_VALUE/1000 之间的差值。
'Q' | '\u004f' | 自协调世界时 (UTC) 1970 年 1 月 1 日 00:00:00 至现在所经过的毫秒数，即 Long.MIN_VALUE 与 Long.MAX_VALUE 之间的差值。此值的精度受底层操作系统或硬件解析的限制。

以下转换字符用来格式化日期：

'B' | '\u0042' | 特定于语言环境的完整月份名称，例如 "January" 和 "February"。
'b' | '\u0062' | 特定于语言环境的月份简称，例如 "Jan" 和 "Feb"。
'h' | '\u0068' | 与 'b' 相同。
'A' | '\u0041' | 特定于语言环境的星期几的全称，例如 "Sunday" 和 "Monday"
'a' | '\u0061' | 特定于语言环境的星期几的简称，例如 "Sun" 和 "Mon"
'C' | '\u0043' | 除以 100 的四位数表示的年份，被格式化为必要时带前导零的两位数，即 00 - 99
'Y' | '\u0059' | 年份，被格式化为必要时带前导零的四位数（至少），例如 0092 等于格里高利历的 92 CE。
'y' | '\u0079' | 年份的最后两位数，被格式化为必要时带前导零的两位数，即 00 - 99。
'j' | '\u006a' | 一年中的天数，被格式化为必要时带前导零的三位数，例如，对于格里高利历是 001 - 366。001 对应于一年中的第一天。
'm' | '\u006d' | 月份，被格式化为必要时带前导零的两位数，即 01 - 13，其中 "01" 是一年的第一个月，("13" 是支持阴历所需的一个特殊值）。
'd' | '\u0064' | 一个月中的天数，被格式化为必要时带前导零的两位数，即 01 - 31，其中 "01" 是一个月的第一天。
'e' | '\u0065' | 一个月中的天数，被格式化为两位数，即 1 - 31，其中 "1" 是一个月中的第一天。

以下转换字符用于格式化常见的日期/时间组合。

'R' | '\u0052' | 24 小时制的时间，被格式化为 "%tH:%tM"
'T' | '\u0054' | 24 小时制的时间，被格式化为 "%tH:%tM:%tS"。
'r' | '\u0072' | 12 小时制的时间，被格式化为 "%tI:%tM:%tS %Tp"。上午或下午标记 ('%Tp') 的位置可能与地区有关。
'D' | '\u0044' | 日期，被格式化为 "%tm/%td/%ty"。
'F' | '\u0046' | ISO 8601 格式的完整日期，被格式化为 "%tY-%tm-%td"。
'c' | '\u0063' | 日期和时间，被格式化为 "%ta %tb %td %tT %tZ %tY"，例如 "Sun Jul 20 16:17:00 EDT 1969"。

应用为常规转换而定义的 '-' 标志。如果给出 '#' 标志，则将抛出 FormatFlagsConversionMismatchException。

宽度 是将向输出中写入的最少字符数。如果转换值的长度小于 width，则用空格('\u0020') 来填充输出，直到总字符数等于宽度。默认情况下，在左边进行填充。如果给出 '-' 标志，则在右边进行填充。如果没有指定宽度，则没有最小宽度。

精度不适用。如果指定了精度，则将抛出 IllegalFormatPrecisionException。

百分比

该转换不对应于任何参数。

'%' 结果是一个字面值 '%' ('\u0025')

宽度 是将向输出中写入的最少字符数，包括 '%'。如果转换值的长度小于 width，则用空格 ('\u0020') 来填充输出，直到总字符数等于宽度。在左边进行填充。如果没有指定宽度，则只输出 '%'。

应用为常规转换而定义的 '-' 标志。如果提供其他任何标志，则将抛出 FormatFlagsConversionMismatchException。

精度不适用。如果指定精度，则将抛出 IllegalFormatPrecisionException。

行分隔符

该转换不对应于任何参数。

'n' 由 System.getProperty("line.separator") 返回的特定于平台的行分隔符。

标志、宽度和精度都不可用。如果提供这三者，则会分别抛出 IllegalFormatFlagsException、IllegalFormatWidthException 和 IllegalFormatPrecisionException。

参数索引

格式说明符可以通过三种方式引用参数：

  • 显式索引 是在格式说明符中包含参数索引时使用。参数索引是一个十进制整数，用于指示参数在参数列表中的位置。第一个参数由 "1$" 引用，第二个参数由 "2$" 引用，依此类推。可以多次引用任何一个参数。

    例如：

       formatter.format("%4$s %3$s %2$s %1$s %4$s %3$s %2$s %1$s",
                    "a", "b", "c", "d")
   // -> "d c b a d c b a"
  • 相对索引 是在格式说明符中包含 '<' ('\u003c') 标志时使用，该标志将导致重用以前格式说明符的参数。如果不存在以前的参数，则抛出 MissingFormatArgumentException。
        formatter.format("%s %s %<s %<s", "a", "b", "c", "d")
   // -> "b a a b"
    // "c" and "d" are ignored because they are not referenced
  • 普通索引 在格式说明符中既不包含参数索引也不包含 '<' 标志时使用。每个使用普通索引的格式说明符都分配了一个连续隐式索引，分配在独立于显式索引或相对索引使用的参数列表中。
       formatter.format("%s %s %s %s", "a", "b", "c", "d")
   // -> "a b c d"

可能有一个使用所有索引形式的格式字符串，例如：

   formatter.format("%2$s %s %<s %s", "a", "b", "c", "d")
   // -> "b a a b"
   // "c" and "d" are ignored because they are not referenced

参数的最大数量受到 Java Machine Specification 定义的 Java 数组 的最大维数的限制。如果参数索引与可用参数不对应，则抛出 MissingFormatArgumentException。

如果参数多于格式说明符，则忽略额外的参数。

除非另行指定，否则向此类中的任何方法或构造方法传递 null 参数都将抛出 NullPointerException。

从以下版本开始：
1.5

嵌套类摘要
static class Formatter.BigDecimalLayoutForm
构造方法摘要
Formatter()
构造一个新 formatter。
Formatter(Appendable a)
构造一个带指定目标文件的新 formatter。
Formatter(Appendable a, Locale l)
构造一个带指定目标文件和语言环境的新 formatter。
Formatter(File file)
构造一个带指定文件的新 formatter。
Formatter(File file, String csn)
构造一个带指定文件和字符集的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(Locale l)
构造一个带指定语言环境的新 formatter。
Formatter(OutputStream os)
构造一个带指定输出流的新 formatter。
Formatter(OutputStream os, String csn)
构造一个带指定输出流和字符集的新 formatter。
Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。
Formatter(PrintStream ps)
构造一个带指定输出流的新 formatter。
Formatter(String fileName)
构造一个带指定文件名的新 formatter。
Formatter(String fileName, String csn)
构造一个带指定文件名和字符集的新 formatter。
Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。
方法摘要
 void close()
关闭此 formatter。
 void flush()
刷新此 formatter。
 Formatter format(Locale l, String format, Object... args)
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。
 Formatter format(String format, Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。
 IOException ioException()
返回由此 formatter 的 Appendable 方法上次抛出的 IOException 异常。
 Locale locale()
返回构造此 formatter 时设置的语言环境。
 Appendable out()
返回输出的目标文件。
 String toString()
返回对输出的目标文件调用 toString() 的结果。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Formatter

public Formatter()
构造一个新 formatter。

格式化输出的目标文件是 StringBuilder，可以通过调用 out() 来获取它，还可以调用 toString() 将其当前内容转换为一个字符串。对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

Formatter

public Formatter(Appendable a)
构造一个带指定目标文件的新 formatter。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

参数：
a - 格式化输出的 Destination。如果 a 为 null，则创建一个 StringBuilder。

Formatter

public Formatter(Locale l)
构造一个带指定语言环境的新 formatter。

格式化输出的目标文件是 StringBuilder，可以通过调用 out() 来获取它，还可以调用 toString() 将其内容转换为一个字符串。

参数：
l - 格式化期间应用的语言环境。如果 l 为 null，则不应用本地化。

Formatter

public Formatter(Appendable a,
                 Locale l)
构造一个带指定目标文件和语言环境的新 formatter。

参数：
a - 格式化输出的 Destination。如果 a 为 null，则创建一个 StringBuilder。
l - 格式化期间应用的语言环境。如果 l 为 null，则不应用本地化。

Formatter

public Formatter(String fileName)
          throws FileNotFoundException
构造一个带指定文件名的新 formatter。

对于 Java 虚拟机的此实例，所使用的字符集是默认字符集。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

参数：
fileName - 用作此 formatter 的目标文件的文件名称。如果存在该文件，则将其大小截取为零；否则创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
抛出：
SecurityException - 如果存在安全管理器，并且 checkWrite(fileName) 拒绝对文件进行写入访问。
FileNotFoundException - 如果给定的文件名称不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误

Formatter

public Formatter(String fileName,
                 String csn)
          throws FileNotFoundException,
                 UnsupportedEncodingException
构造一个带指定文件名和字符集的新 formatter。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

参数：
fileName - 用作此 formatter 的目标文件的文件名称。如果存在该文件，则将其大小截取为零；否则创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
抛出：
FileNotFoundException - 如果给定的文件名称不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(fileName) 拒绝对文件进行写入访问
UnsupportedEncodingException - 如果不支持指定字符集

Formatter

public Formatter(String fileName,
                 String csn,
                 Locale l)
          throws FileNotFoundException,
                 UnsupportedEncodingException
构造一个带指定文件名、字符集和语言环境的新 formatter。

参数：
fileName - 用作此 formatter 的目标文件的文件名称。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
l - 格式化过程中应用的语言环境。如果 l 为 null，则不应用本地化。
抛出：
FileNotFoundException - 如果给定的文件名称不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(fileName) 拒绝对文件进行写入访问。
UnsupportedEncodingException - 如果不支持指定字符集

Formatter

public Formatter(File file)
          throws FileNotFoundException
构造一个带指定文件的新 formatter。

对于 Java 虚拟机的此实例，所使用的字符集是默认字符集。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

参数：
file - 作为此 formatter 的目标文件使用的文件。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
抛出：
SecurityException - 如果存在安全管理器，并且 checkWrite(file.getPath()) 拒绝对文件进行写入访问。
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误

Formatter

public Formatter(File file,
                 String csn)
          throws FileNotFoundException,
                 UnsupportedEncodingException
构造一个带指定文件和字符集的新 formatter。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

参数：
file - 作为此 formatter 的目标文件使用的文件。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(file.getPath()) 拒绝对文件进行写入访问
UnsupportedEncodingException - 如果不支持指定字符集

Formatter

public Formatter(File file,
                 String csn,
                 Locale l)
          throws FileNotFoundException,
                 UnsupportedEncodingException
构造一个带指定文件、字符集和语言环境的新 formatter。

参数：
file - 作为此 formatter 的目标文件使用的文件。如果存在该文件，则将其大小截取为零；否则，创建一个新文件。将输出写入文件中，并对其进行缓冲处理。
csn - 受支持的字符集的名称
l - 格式化过程中应用的语言环境。如果 l 为 null，则不应用本地化。
抛出：
FileNotFoundException - 如果给定的文件对象不表示现有的可写常规文件，并且无法创建该名称的新常规文件，或者在打开或创建文件时发生其他一些错误
SecurityException - 如果存在安全管理器，并且 checkWrite(file.getPath()) 拒绝对文件进行写入访问。
UnsupportedEncodingException - 如果不支持指定字符集

Formatter

public Formatter(PrintStream ps)
构造一个带指定输出流的新 formatter。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

将字符写入给定的 PrintStream 对象，并使用该对象的字符集对其进行编码。

参数：
ps - 作为此 formatter 的目标文件使用的流。

Formatter

public Formatter(OutputStream os)
构造一个带指定输出流的新 formatter。

对于 Java 虚拟机的此实例，所使用的字符集是默认字符集。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

参数：
os - 作为此 formatter 的目标文件使用的流。将对输出进行缓冲。

Formatter

public Formatter(OutputStream os,
                 String csn)
          throws UnsupportedEncodingException
构造一个带指定输出流和字符集的新 formatter。

对于 Java 虚拟机的此实例，所使用的语言环境是默认语言环境。

参数：
os - 作为此 formatter 的目标文件使用的流。将对输出进行缓冲。
csn - 受支持的字符集的名称
抛出：
UnsupportedEncodingException - 如果不支持指定字符集

Formatter

public Formatter(OutputStream os,
                 String csn,
                 Locale l)
          throws UnsupportedEncodingException
构造一个带指定输出流、字符集和语言环境的新 formatter。

参数：
os - 作为此 formatter 的目标文件使用的流。将对输出进行缓冲。
csn - 受支持的字符集的名称
l - 格式化过程中应用的语言环境。如果 l 为 null，则不应用本地化。
抛出：
UnsupportedEncodingException - 如果不支持指定字符集
方法详细信息

locale

public Locale locale()
返回构造此 formatter 时设置的语言环境。

此对象的带语言环境参数的格式方法不会更改该值。

返回：
如果没有应用本地化，则返回 null；否则返回一个语言环境
抛出：
FormatterClosedException - 如果已经通过调用 close() 方法关闭此 formatter

out

public Appendable out()
返回输出的目标文件。

返回：
输出的目标文件
抛出：
FormatterClosedException - 如果已经通过调用 close() 方法关闭此 formatter

toString

public String toString()
返回对输出的目标文件调用 toString() 的结果。例如，以下代码将文本格式化到 StringBuilder 中，然后获取得到的字符串：
   Formatter f = new Formatter();
   f.format("Last reboot at %tc", lastRebootDate);
   String s = f.toString();
   // -> s == "Last reboot at Sat Jan 01 00:00:00 PST 2000"

调用此方法的方式与调用 out().toString() 的方式完全相同。

     out().toString()

根据针对 Appendable 的 toString 的规范，返回的字符串可能否包含（也可能不包含）写入目标文件的字符。例如，缓冲器通常在 toString() 中返回其内容，而流不能这样做，因为数据已被丢弃。

覆盖：
类 Object 中的 toString
返回：
对输出目标文件调用 toString() 的结果
抛出：
FormatterClosedException - 如果已经通过调用 close() 方法关闭此 formatter

flush

public void flush()
刷新此 formatter。如果目标文件实现 Flushable 接口，则调用其 flush 方法。

刷新 formatter 会使目标文件中的所有缓冲输出都写入底层流中。

指定者：
接口 Flushable 中的 flush
抛出：
FormatterClosedException - 如果已经通过调用 close() 方法关闭此 formatter

close

public void close()
关闭此 formatter。如果目标文件实现 Closeable 接口，则调用其 close 方法。

关闭 formatter 允许释放它可能保持（比如打开文件）的资源。如果已经关闭 formatter，则调用此方法无效。

如果试图在此 formatter 已经关闭之后调用其中除 ioException() 之外的任何方法，那么都将导致 FormatterClosedException。

指定者：
接口 Closeable 中的 close

ioException

public IOException ioException()
返回由此 formatter 的 Appendable 方法上次抛出的 IOException 异常。

如果目标文件的 append() 方法从未抛出 IOException，则此方法将始终返回 null。

返回：
如果不存在这样的异常，则返回由 Appendable 或 null 上次抛出的异常。

format

public Formatter format(String format,
                        Object... args)
使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。使用的语言环境是构造此 formatter 期间定义的语言环境。

参数：
format - 在格式字符串的语法中描述的格式字符串。
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制。
返回：
此 formatter
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
FormatterClosedException - 如果已经通过调用 close() 方法关闭此 formatter

format

public Formatter format(Locale l,
                        String format,
                        Object... args)
使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。

参数：
l - 格式化过程中应用的语言环境。如果 l 为 null，则不应用本地化。这不会改变构造期间设置的对象的语言环境。
format - 在格式字符串的语法中描述的格式字符串
args - 格式字符串中的格式说明符引用的参数。如果参数多于格式说明符，则忽略额外的参数。参数的最大数量受到 Java Virtual Machine Specification 定义的 Java 数组的最大维数的限制
返回：
此 formatter
抛出：
IllegalFormatException - 如果格式字符串包含非法语法、与给定参数不兼容的格式说明符、对给定格式字符串而言不够充足的参数或其他非法条件。有关所有可能的格式错误的规范，请参阅 formatter 类规范的详细信息部分。
FormatterClosedException - 如果已经通过调用 close() 方法关闭此 formatter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


List (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 List<E>

所有超级接口：
Collection<E>, Iterable<E>
所有已知实现类：
AbstractList, AbstractSequentialList, ArrayList, AttributeList, CopyOnWriteArrayList, LinkedList, RoleList, RoleUnresolvedList, Stack, Vector
public interface List<E>
extends Collection<E>

有序的 collection（也称为序列）。此接口的用户可以对列表中每个元素的插入位置进行精确地控制。用户可以根据元素的整数索引（在列表中的位置）访问元素，并搜索列表中的元素。

与 set 不同，列表通常允许重复的元素。更确切地讲，列表通常允许满足 e1.equals(e2) 的元素对 e1 和 e2，并且如果列表本身允许 null 元素的话，通常它们允许多个 null 元素。难免有人希望通过在用户尝试插入重复元素时抛出运行时异常的方法来禁止重复的列表，但我们希望这种用法越少越好。

List 接口在 iterator、add、remove、equals 和 hashCode 方法的协定上加了一些其他约定，超过了 Collection 接口中指定的约定。为方便起见，这里也包括了其他继承方法的声明。

List 接口提供了 4 种对列表元素进行定位（索引）访问方法。列表（像 Java 数组一样）是基于 0 的。注意，这些操作可能在和某些实现（例如 LinkedList 类）的索引值成比例的时间内执行。因此，如果调用者不知道实现，那么在列表元素上迭代通常优于用索引遍历列表。

List 接口提供了特殊的迭代器，称为 ListIterator，除了允许 Iterator 接口提供的正常操作外，该迭代器还允许元素插入和替换，以及双向访问。还提供了一个方法来获取从列表中指定位置开始的列表迭代器。

List 接口提供了两种搜索指定对象的方法。从性能的观点来看，应该小心使用这些方法。在很多实现中，它们将执行高开销的线性搜索。

List 接口提供了两种在列表的任意位置高效插入和移除多个元素的方法。

注意：尽管列表允许把自身作为元素包含在内，但建议要特别小心：在这样的列表上，equals 和 hashCode 方法不再是定义良好的。

某些列表实现对列表可能包含的元素有限制。例如，某些实现禁止 null 元素，而某些实现则对元素的类型有限制。试图添加不合格的元素会抛出未经检查的异常，通常是 NullPointerException 或 ClassCastException。试图查询不合格的元素是否存在可能会抛出异常，也可能简单地返回 false；某些实现会采用前一种行为，而某些则采用后者。概括地说，试图对不合格元素执行操作时，如果完成该操作后不会导致在列表中插入不合格的元素，则该操作可能抛出一个异常，也可能成功，这取决于实现的选择。此接口的规范中将这样的异常标记为“可选”。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, Set, ArrayList, LinkedList, Vector, Arrays.asList(Object[]), Collections.nCopies(int, Object), Collections.EMPTY_LIST, AbstractList, AbstractSequentialList

方法摘要
 boolean add(E e)
向列表的尾部添加指定的元素（可选操作）。
 void add(int index, E element)
在列表的指定位置插入指定元素（可选操作）。
 boolean addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序（可选操作）。
 boolean addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
 void clear()
从列表中移除所有元素（可选操作）。
 boolean contains(Object o)
如果列表包含指定的元素，则返回 true。
 boolean containsAll(Collection<?> c)
如果列表包含指定 collection 的所有元素，则返回 true。
 boolean equals(Object o)
比较指定的对象与列表是否相等。
 E get(int index)
返回列表中指定位置的元素。
 int hashCode()
返回列表的哈希码值。
 int indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
 boolean isEmpty()
如果列表不包含元素，则返回 true。
 Iterator<E> iterator()
返回按适当顺序在列表的元素上进行迭代的迭代器。
 int lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
 ListIterator<E> listIterator()
返回此列表元素的列表迭代器（按适当顺序）。
 ListIterator<E> listIterator(int index)
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
 E remove(int index)
移除列表中指定位置的元素（可选操作）。
 boolean remove(Object o)
从此列表中移除第一次出现的指定元素（如果存在）（可选操作）。
 boolean removeAll(Collection<?> c)
从列表中移除指定 collection 中包含的其所有元素（可选操作）。
 boolean retainAll(Collection<?> c)
仅在列表中保留指定 collection 中所包含的元素（可选操作）。
 E set(int index, E element)
用指定元素替换列表中指定位置的元素（可选操作）。
 int size()
返回列表中的元素数。
 List<E> subList(int fromIndex, int toIndex)
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
 Object[] toArray()
返回按适当顺序包含列表中的所有元素的数组（从第一个元素到最后一个元素）。
<T> T[]
toArray(T[] a)
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。

方法详细信息

size

int size()
返回列表中的元素数。如果列表包含多于 Integer.MAX_VALUE 个元素，则返回 Integer.MAX_VALUE。

指定者：
接口 Collection<E> 中的 size
返回：
列表中的元素数

isEmpty

boolean isEmpty()
如果列表不包含元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
返回：
如果列表不包含元素，则返回 true

contains

boolean contains(Object o)
如果列表包含指定的元素，则返回 true。更确切地讲，当且仅当列表包含满足 (o==null ? e==null : o.equals(e)) 的元素 e 时才返回 true。

指定者：
接口 Collection<E> 中的 contains
参数：
o - 要测试列表中是否存在的元素
返回：
如果列表包含指定的元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类型和此列表不兼容（可选）
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素（可选）

iterator

Iterator<E> iterator()
返回按适当顺序在列表的元素上进行迭代的迭代器。

指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Iterable<E> 中的 iterator
返回：
按适当顺序在列表的元素上进行迭代的迭代器

toArray

Object[] toArray()
返回按适当顺序包含列表中的所有元素的数组（从第一个元素到最后一个元素）。

由于此列表不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，即使数组支持此列表，此方法也必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
返回：
按适当顺序包含该列表中所有元素的数组
另请参见：
Arrays.asList(Object[])

toArray

<T> T[] toArray(T[] a)
返回按适当顺序（从第一个元素到最后一个元素）包含列表中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。如果指定数组能容纳列表，则在其中返回该列表。否则，分配具有指定数组的运行时类型和此列表大小的新数组。

如果指定数组能容纳列表，并剩余空间（即数组的元素比列表的多），那么会将数组中紧随列表尾部的元素设置为 null。（只有 在调用者知道列表不包含任何 null 元素时此方法才能用于确定列表的长度）。

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知列表。以下代码用来将该列表转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
参数：
a - 要存储列表中元素的数组，如果它足够大的话；否则为此目的分配一个运行时类型相同的新数组。
返回：
包含列表中元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此列表中每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

add

boolean add(E e)
向列表的尾部添加指定的元素（可选操作）。

支持该操作的列表可能对列表可以添加的元素有一些限制。特别是某些列表将拒绝添加 null 元素，其他列表将在可能添加的元素类型上施加限制。List 类应该在它们的文档中明确指定有关添加元素的所有限制。

指定者：
接口 Collection<E> 中的 add
参数：
e - 要添加到列表的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
UnsupportedOperationException - 如果列表不支持 add 操作
ClassCastException - 如果指定元素的类不允许它添加到此列表
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素
IllegalArgumentException - 如果此元素的某些属性不允许它添加到此列表

remove

boolean remove(Object o)
从此列表中移除第一次出现的指定元素（如果存在）（可选操作）。如果列表不包含元素，则不更改列表。更确切地讲，移除满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i 的元素（如果存在这样的元素）。如果此列表已包含指定元素（或者此列表由于调用而发生更改），则返回 true。

指定者：
接口 Collection<E> 中的 remove
参数：
o - 要从该列表中移除的元素，如果存在的话
返回：
如果列表包含指定的元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类型和此列表不兼容（可选）
NullPointerException - 如果指定的元素是 null，并且此列表不允许 null 元素（可选）
UnsupportedOperationException - 如果列表不支持 remove 操作

containsAll

boolean containsAll(Collection<?> c)
如果列表包含指定 collection 的所有元素，则返回 true。

指定者：
接口 Collection<E> 中的 containsAll
参数：
c - 要在列表中检查其包含性的 collection
返回：
如果列表包含指定 collection 的所有元素，则返回 true
抛出：
ClassCastException - 如果指定 collection 中的一个或多个元素的类型和此列表不兼容（可选）
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素，并且此列表不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
contains(Object)

addAll

boolean addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序（可选操作）。如果在操作正在进行中修改了指定的 collection，那么此操作的行为是不确定的（注意，如果指定的 collection 是此列表，并且它是非空的，则会发生这种情况。）

指定者：
接口 Collection<E> 中的 addAll
参数：
c - 包含要添加到此列表的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果列表不支持 addAll 操作
ClassCastException - 如果指定 collection 的元素的类不允许它添加到此列表
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素，并且该列表不允许 null 元素，或者指定的 collection 为 null
IllegalArgumentException - 如果指定 collection 的元素的某些属性不允许它添加此列表
另请参见：
add(Object)

addAll

boolean addAll(int index,
               Collection<? extends E> c)
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。将当前处于该位置的元素（如果有的话）和所有后续元素向右移动（增加其索引）。新元素将按照它们通过指定 collection 的迭代器所返回的顺序出现在此列表中。如果在操作正在进行中修改了指定的 collection，那么该操作的行为是不确定的（注意，如果指定的 collection 是此列表，并且它是非空的，则会发生这种情况。）

参数：
index - 将指定 collection 的第一个元素所插入位置的索引
c - 包含要添加到此列表的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果列表不支持 addAll 操作
ClassCastException - 如果指定 collection 中某个元素的类不允许它添加到此列表
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素，并且该列表不允许 null 元素，或者指定的 collection 为 null
IllegalArgumentException - 如果指定 collection 的元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

removeAll

boolean removeAll(Collection<?> c)
从列表中移除指定 collection 中包含的其所有元素（可选操作）。

指定者：
接口 Collection<E> 中的 removeAll
参数：
c - 包含从此列表中移除的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果列表不支持 removeAll 操作
ClassCastException - 如果此列表中的元素的类和指定的 collection 不兼容（可选）
NullPointerException - 如果此列表包含一个 null 元素，并且指定的 collection 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object), contains(Object)

retainAll

boolean retainAll(Collection<?> c)
仅在列表中保留指定 collection 中所包含的元素（可选操作）。换句话说，该方法从列表中移除未包含在指定 collection 中的所有元素。

指定者：
接口 Collection<E> 中的 retainAll
参数：
c - 包含将保留在此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果列表不支持 retainAll 操作
ClassCastException - 如果此列表的元素的类和指定的 collection 不兼容（可选）
NullPointerException - 如果此列表包含一个 null 元素，并且指定的 collection 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object), contains(Object)

clear

void clear()
从列表中移除所有元素（可选操作）。此调用返回后该列表将是空的。

指定者：
接口 Collection<E> 中的 clear
抛出：
UnsupportedOperationException - 如果列表不支持 clear 操作

equals

boolean equals(Object o)
比较指定的对象与列表是否相等。当且仅当指定的对象也是一个列表、两个列表有相同的大小，并且两个列表中的所有相应的元素对相等 时才返回 true（ 如果 (e1==null ? e2==null :e1.equals(e2))，则两个元素 e1 和 e2 是相等 的）。换句话说，如果所定义的两个列表以相同的顺序包含相同的元素，那么它们是相等的。该定义确保了 equals 方法在 List 接口的不同实现间正常工作。

指定者：
接口 Collection<E> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与此列表进行相等性比较的对象
返回：
如果指定对象与此列表相等，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回列表的哈希码值。列表的哈希码定义为以下计算的结果：
  int hashCode = 1;
  Iterator<E> i = list.iterator();
  while (i.hasNext()) {
      E obj = i.next();
      hashCode = 31*hashCode + (obj==null ? 0 : obj.hashCode());
  }
这确保了 list1.equals(list2) 意味着对于任何两个列表 list1 和 list2 而言，可实现 list1.hashCode()==list2.hashCode()，正如 Object.hashCode() 的常规协定所要求的。

指定者：
接口 Collection<E> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此列表的哈希码值
另请参见：
Object.equals(Object), equals(Object)

get

E get(int index)
返回列表中指定位置的元素。

参数：
index - 要返回的元素的索引
返回：
列表中指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

set

E set(int index,
      E element)
用指定元素替换列表中指定位置的元素（可选操作）。

参数：
index - 要替换的元素的索引
element - 要在指定位置存储的元素
返回：
以前在指定位置的元素
抛出：
UnsupportedOperationException - 如果列表不支持 set 操作
ClassCastException - 如果指定元素的类不允许它添加到此列表
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

add

void add(int index,
         E element)
在列表的指定位置插入指定元素（可选操作）。将当前处于该位置的元素（如果有的话）和所有后续元素向右移动（在其索引中加 1）。

参数：
index - 要在其中插入指定元素处的索引
element - 要插入的元素
抛出：
UnsupportedOperationException - 如果列表不支持 add 操作
ClassCastException - 如果指定元素的类不允许它添加到此列表
NullPointerException - 如果指定的元素为 null，并且此列表不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许它添加到此列表
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

remove

E remove(int index)
移除列表中指定位置的元素（可选操作）。将所有的后续元素向左移动（将其索引减 1）。返回从列表中移除的元素。

参数：
index - 要移除的元素的索引
返回：
以前在指定位置的元素
抛出：
UnsupportedOperationException - 如果列表不支持 remove 操作
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

indexOf

int indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i；如果没有这样的索引，则返回 -1。

参数：
o - 要搜索的元素
返回：
此列表中第一次出现的指定元素的索引，如果列表不包含该元素，则返回 -1
抛出：
ClassCastException - 如果指定元素的类型和此列表不兼容（可选）
NullPointerException - 如果指定的元素是 null，并且此列表不允许 null 元素（可选）

lastIndexOf

int lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最高索引 i；如果没有这样的索引，则返回 -1。

参数：
o - 要搜索的元素
返回：
列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1
抛出：
ClassCastException - 如果指定元素的类型和此列表不兼容（可选）
NullPointerException - 如果指定的元素是 null，并且此列表不允许 null 元素（可选）

listIterator

ListIterator<E> listIterator()
返回此列表元素的列表迭代器（按适当顺序）。

返回：
此列表元素的列表迭代器（按适当顺序）

listIterator

ListIterator<E> listIterator(int index)
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。指定的索引表示 next 的初始调用所返回的第一个元素。previous 方法的初始调用将返回索引比指定索引少 1 的元素。

参数：
index - 从列表迭代器返回的第一个元素的索引（通过调用 next 方法）
返回：
此列表中元素的列表迭代器（按适当顺序），从列表中的指定位置开始
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

subList

List<E> subList(int fromIndex,
                int toIndex)
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。（如果 fromIndex 和 toIndex 相等，则返回的列表为空）。返回的列表由此列表支持，因此返回列表中的非结构性更改将反映在此列表中，反之亦然。返回的列表支持此列表支持的所有可选列表操作。

此方法省去了显式范围操作（此操作通常针对数组存在）。通过传递 subList 视图而非整个列表，期望列表的任何操作可用作范围操作。例如，下面的语句从列表中移除了元素的范围：

            list.subList(from, to).clear();
可以对 indexOf 和 lastIndexOf 构造类似的语句，而且 Collections 类中的所有算法都可以应用于 subList。

如果支持列表（即此列表）通过任何其他方式（而不是通过返回的列表）从结构上修改，则此方法返回的列表语义将变为未定义（从结构上修改是指更改列表的大小，或者以其他方式打乱列表，使正在进行的迭代产生错误的结果）。

参数：
fromIndex - subList 的低端（包括）
toIndex - subList 的高端（不包括）
返回：
列表中指定范围的视图
抛出：
IndexOutOfBoundsException - 非法的端点值 (fromIndex < 0 || toIndex > size || fromIndex > toIndex)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Formatter.BigDecimalLayoutForm (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

java.util
枚举 Formatter.BigDecimalLayoutForm

java.lang.Object
    继承者  java.lang.Enum<Formatter.BigDecimalLayoutForm>
        继承者  java.util.Formatter.BigDecimalLayoutForm
所有已实现的接口：
Serializable, Comparable<Formatter.BigDecimalLayoutForm>
正在封闭类：
Formatter
public static enum Formatter.BigDecimalLayoutForm
extends Enum<Formatter.BigDecimalLayoutForm>

枚举常量摘要
DECIMAL_FLOAT
SCIENTIFIC
方法摘要
static Formatter.BigDecimalLayoutForm | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Formatter.BigDecimalLayoutForm[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

SCIENTIFIC

public static final Formatter.BigDecimalLayoutForm SCIENTIFIC

DECIMAL_FLOAT

public static final Formatter.BigDecimalLayoutForm DECIMAL_FLOAT
方法详细信息

values

public static final Formatter.BigDecimalLayoutForm[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Formatter.BigDecimalLayoutForm c : Formatter.BigDecimalLayoutForm.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Formatter.BigDecimalLayoutForm valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


FormatterClosedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 FormatterClosedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.util.FormatterClosedException
所有已实现的接口：
Serializable
public class FormatterClosedException
extends IllegalStateException

格式器已关闭时抛出的未经检查的异常。

除非另行指定，否则向此类中的任何方法或构造方法传递 null 参数都将抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
FormatterClosedException()
构造此类的一个实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FormatterClosedException

public FormatterClosedException()
构造此类的一个实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GregorianCalendar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 GregorianCalendar

java.lang.Object
    继承者  java.util.Calendar
        继承者  java.util.GregorianCalendar
所有已实现的接口：
Serializable, Cloneable, Comparable<Calendar>
public class GregorianCalendar
extends Calendar

GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。

GregorianCalendar 是一种混合日历，在单一间断性的支持下同时支持儒略历和格里高利历系统，在默认情况下，它对应格里高利日历创立时的格里高利历日期（某些国家/地区是在 1582 年 10 月 15 日创立，在其他国家/地区要晚一些）。可由调用者通过调用 setGregorianChange() 来更改起始日期。

历史上，在那些首先采用格里高利历的国家/地区中，1582 年 10 月 4 日（儒略历）之后就是 1582 年 10 月 15 日（格里高利历）。此日历正确地模拟了这些变化。在开始格里高利历之前，GregorianCalendar 实现的是儒略历。格里高利历和儒略历之间的唯一区别就是闰年规则。儒略历指定每 4 年就为闰年，而格里高利历则忽略不能被 400 整除的世纪年。

GregorianCalendar 可实现预期的 格里高利历和儒略历。也就是说，可以通过在时间上无限地向后或向前外推当前规则来计算日期。因此，对于所有的年份，都可以使用 GregorianCalendar 来生成有意义并且一致的结果。但是，采用现代儒略历规则时，使用 GregorianCalendar 得到的日期只在历史上从公元 4 年 3 月 1 日之后是准确的。在此日期之前，闰年规则的应用没有规则性，在 45 BC 之前，甚至不存在儒略历。

在格里高利历创立以前，新年是 3 月 25 日。为了避免混淆，此日历始终使用 1 月 1 日为新年。如果想要格里高利历转换之前并且处于 1 月 1 日和 3 月 24 日之间的日期，则可以进行手动调整。

为 WEEK_OF_YEAR 字段所计算的值的范围从 1 到 53。一年的第一个星期始于 getFirstDayOfWeek() 的最早 7 天，至少包含该年的 getMinimalDaysInFirstWeek() 各天。这取决于 getMinimalDaysInFirstWeek()、getFirstDayOfWeek() 的值以及 1 月 1 日是星期几。一年的第一个星期和下一年的第一个星期之间的各个星期按顺序从 2 到 52 或 53（根据需要）进行编号。

例如，1998 年 1 月 1 日是星期四。如果 getFirstDayOfWeek() 为 MONDAY，并且 getMinimalDaysInFirstWeek() 为 4（这些值反映了 ISO 8601 和很多国家/地区标准），则 1998 年的第一个星期开始于 1997 年 12 月 29 日，结束于 1998 年 1 月 4 日。但是，如果 getFirstDayOfWeek() 为 SUNDAY，那么 1998 年的第一个星期开始于 1998 年 1 月 4 日，结束于 1998 年 1 月 10 日；1998 年头三天是 1997 年第 53 个星期的一部分。

为 WEEK_OF_MONTH 字段所计算的值的范围从 0 到 6。一个月的第一个星期（WEEK_OF_MONTH = 1 的日期）是该月至少连续 getMinimalDaysInFirstWeek() 天中的最早日期，结束于 getFirstDayOfWeek() 的前一天。与一年的第一个星期不同，一个月的第一个星期可能短于 7 天，也不必从 getFirstDayOfWeek() 这一天开始，并且不包括前一个月的日期。在第一个星期之前该月日期的 WEEK_OF_MONTH 为 0。

例如，如果 getFirstDayOfWeek() 为 SUNDAY，getMinimalDaysInFirstWeek() 为 4，那么 1998 年 1 月的第一个星期是从 1 月 4 日星期日到 1 月 10 日星期六。这些天的 WEEK_OF_MONTH 为 1。1 月 1 日星期四到 1 月 3 日星期六的 WEEK_OF_MONTH 为 0。如果 getMinimalDaysInFirstWeek() 变为 3，则 1 月 1 日到 1 月 3 日的 WEEK_OF_MONTH 为 1。

clear 方法将日历字段设置为未定义。GregorianCalendar 为每个日历字段使用以下默认值（如果该值未定义）。

字段
 默认值
ERA
         AD
YEAR
         1970
MONTH
         JANUARY
DAY_OF_MONTH
         1
DAY_OF_WEEK
         一个星期的第一天
WEEK_OF_MONTH
         0
DAY_OF_WEEK_IN_MONTH
         1
AM_PM
         AM
HOUR, HOUR_OF_DAY, MINUTE, SECOND, MILLISECOND
         0

默认值不适用于以上未列出的字段。

示例：

 // get the supported ids for GMT-08:00 (Pacific Standard Time)
 String[] ids = TimeZone.getAvailableIDs(-8 * 60 * 60 * 1000);
 // if no ids were returned, something is wrong. get out.
 if (ids.length == 0)
     System.exit(0);

  // begin output
 System.out.println("Current Time");

 // create a Pacific Standard Time time zone
 SimpleTimeZone pdt = new SimpleTimeZone(-8 * 60 * 60 * 1000, ids[0]);

 // set up rules for daylight savings time
 pdt.setStartRule(Calendar.APRIL, 1, Calendar.SUNDAY, 2 * 60 * 60 * 1000);
 pdt.setEndRule(Calendar.0ctober, -1, Calendar.SUNDAY, 2 * 60 * 60 * 1000);

 // create a GregorianCalendar with the Pacific Daylight time zone
 // and the current date and time
 Calendar calendar = new GregorianCalendar(pdt);
 Date trialTime = new Date();
 calendar.setTime(trialTime);

 // print out a bunch of interesting things
 System.out.println("ERA: " + calendar.get(Calendar.ERA));
 System.out.println("YEAR: " + calendar.get(Calendar.YEAR));
 System.out.println("MONTH: " + calendar.get(Calendar.MONTH));
 System.out.println("WEEK_OF_YEAR: " + calendar.get(Calendar.WEEK_OF_YEAR));
 System.out.println("WEEK_OF_MONTH: " + calendar.get(Calendar.WEEK_OF_MONTH));
 System.out.println("DATE: " + calendar.get(Calendar.DATE));
 System.out.println("DAY_OF_MONTH: " + calendar.get(Calendar.DAY_OF_MONTH));
 System.out.println("DAY_OF_YEAR: " + calendar.get(Calendar.DAY_OF_YEAR));
 System.out.println("DAY_OF_WEEK: " + calendar.get(Calendar.DAY_OF_WEEK));
 System.out.println("DAY_OF_WEEK_IN_MONTH: "
                    + calendar.get(Calendar.DAY_OF_WEEK_IN_MONTH));
 System.out.println("AM_PM: " + calendar.get(Calendar.AM_PM));
 System.out.println("HOUR: " + calendar.get(Calendar.HOUR));
 System.out.println("HOUR_OF_DAY: " + calendar.get(Calendar.HOUR_OF_DAY));
 System.out.println("MINUTE: " + calendar.get(Calendar.MINUTE));
 System.out.println("SECOND: " + calendar.get(Calendar.SECOND));
 System.out.println("MILLISECOND: " + calendar.get(Calendar.MILLISECOND));
 System.out.println("ZONE_OFFSET: "
                    + (calendar.get(Calendar.ZONE_OFFSET)/(60*60*1000)));
 System.out.println("DST_OFFSET: "
                    + (calendar.get(Calendar.DST_OFFSET)/(60*60*1000)));

 System.out.println("Current Time, with hour reset to 3");
 calendar.clear(Calendar.HOUR_OF_DAY); // so doesn't override
 calendar.set(Calendar.HOUR, 3);
 System.out.println("ERA: " + calendar.get(Calendar.ERA));
 System.out.println("YEAR: " + calendar.get(Calendar.YEAR));
 System.out.println("MONTH: " + calendar.get(Calendar.MONTH));
 System.out.println("WEEK_OF_YEAR: " + calendar.get(Calendar.WEEK_OF_YEAR));
 System.out.println("WEEK_OF_MONTH: " + calendar.get(Calendar.WEEK_OF_MONTH));
 System.out.println("DATE: " + calendar.get(Calendar.DATE));
 System.out.println("DAY_OF_MONTH: " + calendar.get(Calendar.DAY_OF_MONTH));
 System.out.println("DAY_OF_YEAR: " + calendar.get(Calendar.DAY_OF_YEAR));
 System.out.println("DAY_OF_WEEK: " + calendar.get(Calendar.DAY_OF_WEEK));
 System.out.println("DAY_OF_WEEK_IN_MONTH: "
                    + calendar.get(Calendar.DAY_OF_WEEK_IN_MONTH));
 System.out.println("AM_PM: " + calendar.get(Calendar.AM_PM));
 System.out.println("HOUR: " + calendar.get(Calendar.HOUR));
 System.out.println("HOUR_OF_DAY: " + calendar.get(Calendar.HOUR_OF_DAY));
 System.out.println("MINUTE: " + calendar.get(Calendar.MINUTE));
 System.out.println("SECOND: " + calendar.get(Calendar.SECOND));
 System.out.println("MILLISECOND: " + calendar.get(Calendar.MILLISECOND));
 System.out.println("ZONE_OFFSET: "
        + (calendar.get(Calendar.ZONE_OFFSET)/(60*60*1000))); // in hours
 System.out.println("DST_OFFSET: "
        + (calendar.get(Calendar.DST_OFFSET)/(60*60*1000))); // in hours

从以下版本开始：
JDK1.1
另请参见：
TimeZone, 序列化表格

字段摘要
static int | AD ERA 字段的值指示公元后（耶稣纪元后）的时期（也称为 CE）。
static int | BC ERA 字段的值指示公元前（Christ 前）的时期（也称为 BCE）。
从类 java.util.Calendar 继承的字段
ALL_STYLES, AM, AM_PM, APRIL, areFieldsSet, AUGUST, DATE, DAY_OF_MONTH, DAY_OF_WEEK, DAY_OF_WEEK_IN_MONTH, DAY_OF_YEAR, DECEMBER, DST_OFFSET, ERA, FEBRUARY, FIELD_COUNT, fields, FRIDAY, HOUR, HOUR_OF_DAY, isSet, isTimeSet, JANUARY, JULY, JUNE, LONG, MARCH, MAY, MILLISECOND, MINUTE, MONDAY, MONTH, NOVEMBER, OCTOBER, PM, SATURDAY, SECOND, SEPTEMBER, SHORT, SUNDAY, THURSDAY, time, TUESDAY, UNDECIMBER, WEDNESDAY, WEEK_OF_MONTH, WEEK_OF_YEAR, YEAR, ZONE_OFFSET
构造方法摘要
GregorianCalendar()
在具有默认语言环境的默认时区内使用当前时间构造一个默认的 GregorianCalendar。
GregorianCalendar(int year, int month, int dayOfMonth)
在具有默认语言环境的默认时区内构造一个带有给定日期设置的 GregorianCalendar。
GregorianCalendar(int year, int month, int dayOfMonth, int hourOfDay, int minute)
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。
GregorianCalendar(int year, int month, int dayOfMonth, int hourOfDay, int minute, int second)
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。
GregorianCalendar(Locale aLocale)
在具有给定语言环境的默认时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone zone)
在具有默认语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone zone, Locale aLocale)
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
方法摘要
void | add(int field, int amount) 根据日历规则，将指定的（有符号的）时间量添加到给定的日历字段中。
Object | clone() 创建并返回此对象的一个副本。
protected void | computeFields() 将时间值（从 Epoch 至现在的毫秒偏移量）转换为日历字段值。
protected void | computeTime() 将日历字段值转换为时间值（从 Epoch 至现在的毫秒偏移量）。
boolean | equals(Object obj) 比较此 GregorianCalendar 与指定的 Object。
int | getActualMaximum(int field) 考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最大值。
int | getActualMinimum(int field) 考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最小值。
int | getGreatestMinimum(int field) 返回此 GregorianCalendar 实例给定日历字段的最高的最小值。
Date | getGregorianChange() 获得格里高利历的更改日期。
int | getLeastMaximum(int field) 返回此 GregorianCalendar 实例给定日历字段的最低的最大值。
int | getMaximum(int field) 返回此 GregorianCalendar 实例的给定日历字段的最大值。
int | getMinimum(int field) 返回此 GregorianCalendar 实例的给定日历字段的最小值。
TimeZone | getTimeZone() 获得时区。
int | hashCode() 生成此 GregorianCalendar 对象的哈希码。
boolean | isLeapYear(int year) 确定给定的年份是否为闰年。
void | roll(int field, boolean up) 在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。
void | roll(int field, int amount) 向指定日历字段添加有符号的时间量，不更改更大的字段。
void | setGregorianChange(Date date) 设置 GregorianCalendar 的更改日期。
void | setTimeZone(TimeZone zone) 使用给定的时区值来设置时区。
从类 java.util.Calendar 继承的方法
after, before, clear, clear, compareTo, complete, get, getAvailableLocales, getDisplayName, getDisplayNames, getFirstDayOfWeek, getInstance, getInstance, getInstance, getInstance, getMinimalDaysInFirstWeek, getTime, getTimeInMillis, internalGet, isLenient, isSet, set, set, set, set, setFirstDayOfWeek, setLenient, setMinimalDaysInFirstWeek, setTime, setTimeInMillis, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

BC

public static final int BC
ERA 字段的值指示公元前（Christ 前）的时期（也称为 BCE）。从 BC 到 AD 各年转换依次是 2 BC、1 BC、1 AD、2 AD……。

另请参见：
Calendar.ERA, 常量字段值

AD

public static final int AD
ERA 字段的值指示公元后（耶稣纪元后）的时期（也称为 CE）。从 BC 到 AD 各年转换依次是 2 BC、1 BC、1 AD、2 AD……。

另请参见：
Calendar.ERA, 常量字段值
构造方法详细信息

GregorianCalendar

public GregorianCalendar()
在具有默认语言环境的默认时区内使用当前时间构造一个默认的 GregorianCalendar。

GregorianCalendar

public GregorianCalendar(TimeZone zone)
在具有默认语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。

参数：
zone - 给定的时区。

GregorianCalendar

public GregorianCalendar(Locale aLocale)
在具有给定语言环境的默认时区内构造一个基于当前时间的 GregorianCalendar。

参数：
aLocale - 给定的语言环境。

GregorianCalendar

public GregorianCalendar(TimeZone zone,
                         Locale aLocale)
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。

参数：
zone - 给定的时区。
aLocale - 给定的语言环境。

GregorianCalendar

public GregorianCalendar(int year,
                         int month,
                         int dayOfMonth)
在具有默认语言环境的默认时区内构造一个带有给定日期设置的 GregorianCalendar。

参数：
year - 用来在日历中设置 YEAR 日历字段的值。
month - 用来在日历中设置 MONTH 日历字段的值。Month 值是基于 0 的，例如，0 表示 1 月。
dayOfMonth - 用来在日历中设置 DAY_OF_MONTH 日历字段的值。

GregorianCalendar

public GregorianCalendar(int year,
                         int month,
                         int dayOfMonth,
                         int hourOfDay,
                         int minute)
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。

参数：
year - 用来在日历中设置 YEAR 日历字段的值。
month - 用来在日历中设置 MONTH 日历字段的值。Month 值是基于 0 的，例如，0 表示 1 月。
dayOfMonth - 用来在日历中设置 DAY_OF_MONTH 日历字段的值。
hourOfDay - 用来在日历中设置 HOUR_OF_DAY 日历字段的值。
minute - 用来在日历中设置 MINUTE 日历字段的值。

GregorianCalendar

public GregorianCalendar(int year,
                         int month,
                         int dayOfMonth,
                         int hourOfDay,
                         int minute,
                         int second)
为具有默认语言环境的默认时区构造一个具有给定日期和时间设置的 GregorianCalendar。

参数：
year - 用来在日历中设置 YEAR 日历字段的值。
month - 用来在日历中设置 MONTH 日历字段的值。Month 值是基于 0 的，例如，0 表示 1 月。
dayOfMonth - 用来在日历中设置 DAY_OF_MONTH 日历字段的值。
hourOfDay - 用来在日历中设置 HOUR_OF_DAY 日历字段的值。
minute - 用来在日历中设置 MINUTE 日历字段的值。
second - 用来在日历中设置 SECOND 日历字段的值。
方法详细信息

setGregorianChange

public void setGregorianChange(Date date)
设置 GregorianCalendar 的更改日期。这是发生从儒略历日期切换到格里高利历日期的点。默认时间是 1582 年 10 月 15 日（格里高利历）。在此之前，日期是按照儒略历计算的。

要得到纯粹的儒略历日历，可将更改日期设置为 Date(Long.MAX_VALUE)。要得到一个纯粹的格里高利历日历，可将更改日期设置为 Date(Long.MIN_VALUE)。

参数：
date - 给定的格里高利历起始日期。

getGregorianChange

public final Date getGregorianChange()
获得格里高利历的更改日期。这是发生从儒略历日期切换到格里高利历日期的点。默认时间是 1582 年 10 月 15 日（格里高利历）。在此之前，日期是按照儒略历计算的。

返回：
此 GregorianCalendar 对象的格里高利历起始日期。

isLeapYear

public boolean isLeapYear(int year)
确定给定的年份是否为闰年。如果给定的年份是闰年，则返回 true。要指定 BC 年份，必须给定 1 - 年份。例如，指定 -3 为 BC 4 年。

参数：
year - 给定的年份。
返回：
如果给定的年份为闰年，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
比较此 GregorianCalendar 与指定的 Object。当且仅当参数是一个 GregorianCalendar 对象，并且这个对象表示在相同的 Calendar 参数和格里高利历更改日期下与此对象具有相同的时间值（从 Epoch 至现在的毫秒偏移量）时，结果为 true。

覆盖：
类 Calendar 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果此对象等于 obj，则返回 true；否则返回 false。
另请参见：
Calendar.compareTo(Calendar)

hashCode

public int hashCode()
生成此 GregorianCalendar 对象的哈希码。

覆盖：
类 Calendar 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

add

public void add(int field,
                int amount)
根据日历规则，将指定的（有符号的）时间量添加到给定的日历字段中。

添加规则 1。调用之后的 field 字段的值减去调用之前的 field 字段的值等于 amount，以 field 中发生的任何溢出为模。溢出发生在字段值超出其范围时，结果，下一个更大的字段会递增或递减，字段值被调整回其范围内。

添加规则 2。如果期望某一个更小的字段是无变化的，但让它等于以前的值是不可能的，因为在字段 field 发生更改之后，它的最大值和最小值也在发生更改，然后它的值被调整为尽量接近于所期望的值。更小的字段表示一个更小的时间单元。HOUR 是一个比 DAY_OF_MONTH 更小的字段。对于不期望是无变化字段的更小字段，无需进行任何调整。日历系统确定期望是无变化字段的那些字段。

指定者：
类 Calendar 中的 add
参数：
field - 日历字段。
amount - 为字段添加的日期或时间量。
抛出：
IllegalArgumentException - 如果 field 为 ZONE_OFFSET、DST_OFFSET，或未知，或者任何日历字段在 non-lenient 模式下具有超出范围的值。
另请参见：
Calendar.roll(int,int), Calendar.set(int,int)

roll

public void roll(int field,
                 boolean up)
在给定的时间字段上添加或减去（上/下）单个时间单元，不更改更大的字段。

示例：考虑原来设置为 1999 年 12 月 31 日的 GregorianCalendar 。现在调用 roll(Calendar.MONTH, true) 将该日历设置为 1999 年 1 月 31 日。YEAR 字段未改变，因为它是一个比 MONTH 更大的字段。

指定者：
类 Calendar 中的 roll
参数：
up - 指出指定日历字段的值是上升还是下降。如果上升了，则使用 true；否则使用 false。
field - 时间字段。
抛出：
IllegalArgumentException - 如果 field 为 ZONE_OFFSET、DST_OFFSET，或未知，或者任何日历字段在 non-lenient 模式下具有超出范围的值。
另请参见：
add(int,int), Calendar.set(int,int)

roll

public void roll(int field,
                 int amount)
向指定日历字段添加有符号的时间量，不更改更大的字段。负的波动量表示从字段减去时间量，不更改更大的字段。如果指定的量为 0，则此方法不执行任何操作。

此方法在添加时间量前调用 Calendar.complete()，使得所有的日历字段都标准化。如果任何日历字段在 non-lenient 模式下具有超出范围的值，则抛出 IllegalArgumentException。

示例：考虑原来设置为 1999 年 8 月 31 日的 GregorianCalendar 。现在调用 roll(Calendar.MONTH, 8) 将该日历设置为 1999 年 4 月 30 日。如果使用 GregorianCalendar，则 4 月份的 DAY_OF_MONTH 字段不可能为 31。将 DAY_OF_MONTH 设置为最可能接近的值 30。YEAR 字段保持为值 1999，因为它是一个比 MONTH 更大的字段。

示例：考虑原来设置为 1999 年 6 月 6 日星期日的 GregorianCalendar 。现在调用 roll(Calendar.WEEK_OF_MONTH, -1) 将该日历设置为 1999 年 6 月 1 日星期二，而调用 add(Calendar.WEEK_OF_MONTH, -1) 则将日历设置为 1999 年 5 月 30 日星期日。这是因为上升和下降规则施加了其他的约束：WEEK_OF_MONTH 改变时 MONTH 必须不变。根据添加规则 1，所得日期必定在 6 月 1 日星期二和 6 月 5 日星期六之间。根据添加规则 2，DAY_OF_WEEK（在改变 WEEK_OF_MONTH 时它是一个不变量）被设置为 Tuesday，是最接近 Sunday 的可能值（其中星期日是一个星期的第一天）。

覆盖：
类 Calendar 中的 roll
参数：
field - 日历字段。
amount - 添加到 field 的有符号时间量。
抛出：
IllegalArgumentException - 如果 field 为 ZONE_OFFSET、DST_OFFSET 或未知，或者任何日历字段在 non-lenient 模式下具有超出范围的值。
从以下版本开始：
1.2
另请参见：
roll(int,boolean),
add(int,int),
Calendar.set(int,int)

getMinimum

public int getMinimum(int field)
返回此 GregorianCalendar 实例的给定日历字段的最小值。考虑到 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，最小值定义为由 get 方法为所有可能的时间值所返回的最小值。

指定者：
类 Calendar 中的 getMinimum
参数：
field - 日历字段。
返回：
给定日历字段的最小值。
另请参见：
getMaximum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMinimum(int), getActualMaximum(int)

getMaximum

public int getMaximum(int field)
返回此 GregorianCalendar 实例的给定日历字段的最大值。考虑到 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，最大值定义为 get 方法为所有可能的时间值所返回的最大值。

指定者：
类 Calendar 中的 getMaximum
参数：
field - 日历字段。
返回：
给定日历字段的最大值。
另请参见：
getMinimum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMinimum(int), getActualMaximum(int)

getGreatestMinimum

public int getGreatestMinimum(int field)
返回此 GregorianCalendar 实例给定日历字段的最高的最小值。考虑到 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，最高的最小值定义为 getActualMinimum(int) 为所有可能的时间值所返回的最大值。

指定者：
类 Calendar 中的 getGreatestMinimum
参数：
field - 日历字段。
返回：
给定日历字段的最高的最小值。
另请参见：
getMinimum(int), getMaximum(int), getLeastMaximum(int), getActualMinimum(int), getActualMaximum(int)

getLeastMaximum

public int getLeastMaximum(int field)
返回此 GregorianCalendar 实例给定日历字段的最低的最大值。考虑到 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，最低的最大值定义为 getActualMaximum(int) 为所有可能的时间值所返回的最小值。

指定者：
类 Calendar 中的 getLeastMaximum
参数：
field - 日历字段。
返回：
给定日历字段的最低的最大值。
另请参见：
getMinimum(int), getMaximum(int), getGreatestMinimum(int), getActualMinimum(int), getActualMaximum(int)

getActualMinimum

public int getActualMinimum(int field)
考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最小值。

例如，如果格里高利历的更改日期是 1970 年 1 月 10 日，而此 GregorianCalendar 的日期是 1970 年 1 月 20 日，则 DAY_OF_MONTH 字段的实际最小值是 10，因为按照儒略历，1970 年 1 月 10 日的前一个日期是 1969 年 12 月 27 日。因此，从 1969 年 12 月 28 日到 1970 年 1 月 9 日的日期不存在。

覆盖：
类 Calendar 中的 getActualMinimum
参数：
field - 日历字段。
返回：
针对此 GregorianCalendar 时间值的给定字段最小值。
从以下版本开始：
1.2
另请参见：
getMinimum(int), getMaximum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMaximum(int)

getActualMaximum

public int getActualMaximum(int field)
考虑到给定的时间值和 getFirstDayOfWeek、getMinimalDaysInFirstWeek、getGregorianChange 和 getTimeZone 方法的当前值，返回此日历字段可能具有的最大值。例如，如果此实例的日期是 2004 年 2 月 1 日，则 DAY_OF_MONTH 字段的实际最大值是 29，因为 2004 年是闰年；如果此实例的日期是 2005 年 2 月 1 日，则最大值是 28。

覆盖：
类 Calendar 中的 getActualMaximum
参数：
field - 日历字段。
返回：
针对此 GregorianCalendar 时间值的给定字段最大值。
从以下版本开始：
1.2
另请参见：
getMinimum(int), getMaximum(int), getGreatestMinimum(int), getLeastMaximum(int), getActualMinimum(int)

clone

public Object clone()
从类 Calendar 复制的描述
创建并返回此对象的一个副本。

覆盖：
类 Calendar 中的 clone
返回：
此对象的一个副本。
另请参见：
Cloneable

getTimeZone

public TimeZone getTimeZone()
从类 Calendar 复制的描述
获得时区。

覆盖：
类 Calendar 中的 getTimeZone
返回：
与此日历有关的时区对象。

setTimeZone

public void setTimeZone(TimeZone zone)
从类 Calendar 复制的描述
使用给定的时区值来设置时区。

覆盖：
类 Calendar 中的 setTimeZone
参数：
zone - 给定的时区。

computeFields

protected void computeFields()
将时间值（从 Epoch 至现在的毫秒偏移量）转换为日历字段值。不会 一开始就重新计算时间；要重新计算时间，并重新计算字段，则需要先调用 complete 方法。

指定者：
类 Calendar 中的 computeFields
另请参见：
Calendar.complete()

computeTime

protected void computeTime()
将日历字段值转换为时间值（从 Epoch 至现在的毫秒偏移量）。

指定者：
类 Calendar 中的 computeTime
抛出：
IllegalArgumentException - 如果存在任何无效的日历字段。
另请参见：
Calendar.complete(), Calendar.computeFields()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HashMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 HashMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.HashMap<K,V>
类型参数：
K - 此映射所维护的键的类型
V - 所映射值的类型
所有已实现的接口：
Serializable, Cloneable, Map<K,V>
直接已知子类：
LinkedHashMap, PrinterStateReasons
public class HashMap<K,V>
extends AbstractMap<K,V>
implements Map<K,V>, Cloneable, Serializable

基于哈希表的 Map 接口的实现。此实现提供所有可选的映射操作，并允许使用 null 值和 null 键。（除了非同步和允许使用 null 之外，HashMap 类与 Hashtable 大致相同。）此类不保证映射的顺序，特别是它不保证该顺序恒久不变。

此实现假定哈希函数将元素适当地分布在各桶之间，可为基本操作（get 和 put）提供稳定的性能。迭代 collection 视图所需的时间与 HashMap 实例的“容量”（桶的数量）及其大小（键-值映射关系数）成比例。所以，如果迭代性能很重要，则不要将初始容量设置得太高（或将加载因子设置得太低）。

HashMap 的实例有两个参数影响其性能：初始容量 和加载因子。容量 是哈希表中桶的数量，初始容量只是哈希表在创建时的容量。加载因子 是哈希表在其容量自动增加之前可以达到多满的一种尺度。当哈希表中的条目数超出了加载因子与当前容量的乘积时，则要对该哈希表进行 rehash 操作（即重建内部数据结构），从而哈希表将具有大约两倍的桶数。

通常，默认加载因子 (.75) 在时间和空间成本上寻求一种折衷。加载因子过高虽然减少了空间开销，但同时也增加了查询成本（在大多数 HashMap 类的操作中，包括 get 和 put 操作，都反映了这一点）。在设置初始容量时应该考虑到映射中所需的条目数及其加载因子，以便最大限度地减少 rehash 操作次数。如果初始容量大于最大条目数除以加载因子，则不会发生 rehash 操作。

如果很多映射关系要存储在 HashMap 实例中，则相对于按需执行自动的 rehash 操作以增大表的容量来说，使用足够大的初始容量创建它将使得映射关系能更有效地存储。

注意，此实现不是同步的。如果多个线程同时访问一个哈希映射，而其中至少一个线程从结构上修改了该映射，则它必须 保持外部同步。（结构上的修改是指添加或删除一个或多个映射关系的任何操作；仅改变与实例已经包含的键关联的值不是结构上的修改。）这一般通过对自然封装该映射的对象进行同步操作来完成。如果不存在这样的对象，则应该使用 Collections.synchronizedMap 方法来“包装”该映射。最好在创建时完成这一操作，以防止对映射进行意外的非同步访问，如下所示：

   Map m = Collections.synchronizedMap(new HashMap(...));

由所有此类的“collection 视图方法”所返回的迭代器都是快速失败 的：在迭代器创建之后，如果从结构上对映射进行修改，除非通过迭代器本身的 remove 方法，其他任何时间任何方式的修改，迭代器都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不冒在将来不确定的时间发生任意不确定行为的风险。

注意，迭代器的快速失败行为不能得到保证，一般来说，存在非同步的并发修改时，不可能作出任何坚决的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的做法是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测程序错误。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Object.hashCode(), Collection, Map, TreeMap, Hashtable, 序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
构造方法摘要
HashMap()
构造一个具有默认初始容量 (16) 和默认加载因子 (0.75) 的空 HashMap。
HashMap(int initialCapacity)
构造一个带指定初始容量和默认加载因子 (0.75) 的空 HashMap。
HashMap(int initialCapacity, float loadFactor)
构造一个带指定初始容量和加载因子的空 HashMap。
HashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定 Map 相同的新 HashMap。
方法摘要
void | clear() 从此映射中移除所有映射关系。
Object | clone() 返回此 HashMap 实例的浅表副本：并不复制键和值本身。
boolean | containsKey(Object key) 如果此映射包含对于指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
Set<Map.Entry<K,V>> | entrySet() 返回此映射所包含的映射关系的 Set 视图。
V | get(Object key) 返回指定键所映射的值；如果对于该键来说，此映射不包含任何映射关系，则返回 null。
boolean | isEmpty() 如果此映射不包含键-值映射关系，则返回 true。
Set<K> | keySet() 返回此映射中所包含的键的 Set 视图。
V | put(K key, V value) 在此映射中关联指定值与指定键。
void | putAll(Map<? extends K,? extends V> m) 将指定映射的所有映射关系复制到此映射中，这些映射关系将替换此映射目前针对指定映射中所有键的所有映射关系。
V | remove(Object key) 从此映射中移除指定键的映射关系（如果存在）。
int | size() 返回此映射中的键-值映射关系数。
Collection<V> | values() 返回此映射所包含的值的 Collection 视图。
从类 java.util.AbstractMap 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Map 继承的方法
equals, hashCode

构造方法详细信息

HashMap

public HashMap(int initialCapacity,
               float loadFactor)
构造一个带指定初始容量和加载因子的空 HashMap。

参数：
initialCapacity - 初始容量
loadFactor - 加载因子
抛出：
IllegalArgumentException - 如果初始容量为负或者加载因子为非正

HashMap

public HashMap(int initialCapacity)
构造一个带指定初始容量和默认加载因子 (0.75) 的空 HashMap。

参数：
initialCapacity - 初始容量。
抛出：
IllegalArgumentException - 如果初始容量为负。

HashMap

public HashMap()
构造一个具有默认初始容量 (16) 和默认加载因子 (0.75) 的空 HashMap。

HashMap

public HashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定 Map 相同的新 HashMap。所创建的 HashMap 具有默认加载因子 (0.75) 和足以容纳指定 Map 中映射关系的初始容量。

参数：
m - 映射，其映射关系将存放在此映射中
抛出：
NullPointerException - 如果指定的映射为 null
方法详细信息

size

public int size()
返回此映射中的键-值映射关系数。

指定者：
接口 Map<K,V> 中的 size
覆盖：
类 AbstractMap<K,V> 中的 size
返回：
此映射中的键-值映射关系数

isEmpty

public boolean isEmpty()
如果此映射不包含键-值映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 isEmpty
覆盖：
类 AbstractMap<K,V> 中的 isEmpty
返回：
如果此映射不包含键-值映射关系，则返回 true

get

public V get(Object key)
返回指定键所映射的值；如果对于该键来说，此映射不包含任何映射关系，则返回 null。

更确切地讲，如果此映射包含一个满足 (key==null ? k==null : key.equals(k)) 的从 k 键到 v 值的映射关系，则此方法返回 v；否则返回 null。（最多只能有一个这样的映射关系。）

返回 null 值并不一定 表明该映射不包含该键的映射关系；也可能该映射将该键显示地映射为 null。可使用 containsKey 操作来区分这两种情况。

指定者：
接口 Map<K,V> 中的 get
覆盖：
类 AbstractMap<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
另请参见：
put(Object, Object)

containsKey

public boolean containsKey(Object key)
如果此映射包含对于指定键的映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 containsKey
覆盖：
类 AbstractMap<K,V> 中的 containsKey
参数：
key - 要测试其是否在此映射中存在的键
返回：
如果此映射包含对于指定键的映射关系，则返回 true。

put

public V put(K key,
             V value)
在此映射中关联指定值与指定键。如果该映射以前包含了一个该键的映射关系，则旧值被替换。

指定者：
接口 Map<K,V> 中的 put
覆盖：
类 AbstractMap<K,V> 中的 put
参数：
key - 指定值将要关联的键
value - 指定键将要关联的值
返回：
与 key 关联的旧值；如果 key 没有任何映射关系，则返回 null。（返回 null 还可能表示该映射之前将 null 与 key 关联。）

putAll

public void putAll(Map<? extends K,? extends V> m)
将指定映射的所有映射关系复制到此映射中，这些映射关系将替换此映射目前针对指定映射中所有键的所有映射关系。

指定者：
接口 Map<K,V> 中的 putAll
覆盖：
类 AbstractMap<K,V> 中的 putAll
参数：
m - 要在此映射中存储的映射关系
抛出：
NullPointerException - 如果指定的映射为 null

remove

public V remove(Object key)
从此映射中移除指定键的映射关系（如果存在）。

指定者：
接口 Map<K,V> 中的 remove
覆盖：
类 AbstractMap<K,V> 中的 remove
参数：
key - 其映射关系要从映射中移除的键
返回：
与 key 关联的旧值；如果 key 没有任何映射关系，则返回 null。（返回 null 还可能表示该映射之前将 null 与 key 关联。）

clear

public void clear()
从此映射中移除所有映射关系。此调用返回后，映射将为空。

指定者：
接口 Map<K,V> 中的 clear
覆盖：
类 AbstractMap<K,V> 中的 clear

containsValue

public boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

指定者：
接口 Map<K,V> 中的 containsValue
覆盖：
类 AbstractMap<K,V> 中的 containsValue
参数：
value - 要测试其是否在此映射中存在的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true

clone

public Object clone()
返回此 HashMap 实例的浅表副本：并不复制键和值本身。

覆盖：
类 AbstractMap<K,V> 中的 clone
返回：
此映射的浅表副本
另请参见：
Cloneable

keySet

public Set<K> keySet()
返回此映射中所包含的键的 Set 视图。该 set 受映射的支持，所以对映射的更改将反映在该 set 中，反之亦然。如果在对 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。该 set 支持元素的移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从该映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 keySet
覆盖：
类 AbstractMap<K,V> 中的 keySet
返回：
此映射中包含的键的 set 视图

values

public Collection<V> values()
返回此映射所包含的值的 Collection 视图。该 collection 受映射的支持，所以对映射的更改将反映在该 collection 中，反之亦然。如果在对 collection 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。该 collection 支持元素的移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作可从该映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 values
覆盖：
类 AbstractMap<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射所包含的映射关系的 Set 视图。 该 set 受映射支持，所以对映射的更改将反映在此 set 中，反之亦然。如果在对 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作，或者通过在该迭代器返回的映射项上执行 setValue 操作除外），则迭代结果是不确定的。该 set 支持元素的移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从该映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 entrySet
指定者：
类 AbstractMap<K,V> 中的 entrySet
返回：
此映射所包含的映射关系的 set 视图。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HashSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 HashSet<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
            继承者  java.util.HashSet<E>
类型参数：
E - 此 set 所维护的元素的类型
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, Set<E>
直接已知子类：
JobStateReasons, LinkedHashSet
public class HashSet<E>
extends AbstractSet<E>
implements Set<E>, Cloneable, Serializable

此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。它不保证 set 的迭代顺序；特别是它不保证该顺序恒久不变。此类允许使用 null 元素。

此类为基本操作提供了稳定性能，这些基本操作包括 add、remove、contains 和 size，假定哈希函数将这些元素正确地分布在桶中。对此 set 进行迭代所需的时间与 HashSet 实例的大小（元素的数量）和底层 HashMap 实例（桶的数量）的“容量”的和成比例。因此，如果迭代性能很重要，则不要将初始容量设置得太高（或将加载因子设置得太低）。

注意，此实现不是同步的。如果多个线程同时访问一个哈希 set，而其中至少一个线程修改了该 set，那么它必须 保持外部同步。这通常是通过对自然封装该 set 的对象执行同步操作来完成的。如果不存在这样的对象，则应该使用 Collections.synchronizedSet 方法来“包装” set。最好在创建时完成这一操作，以防止对该 set 进行意外的不同步访问：

   Set s = Collections.synchronizedSet(new HashSet(...));

此类的 iterator 方法返回的迭代器是快速失败 的：在创建迭代器之后，如果对 set 进行修改，除非通过迭代器自身的 remove 方法，否则在任何时间以任何方式对其进行修改，Iterator 都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不冒将来在某个不确定时间发生任意不确定行为的风险。

注意，迭代器的快速失败行为无法得到保证，因为一般来说，不可能对是否出现不同步并发修改做出任何硬性保证。快速失败迭代器在尽最大努力抛出 ConcurrentModificationException。因此，为提高这类迭代器的正确性而编写一个依赖于此异常的程序是错误做法：迭代器的快速失败行为应该仅用于检测 bug。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, Set, TreeSet, HashMap, 序列化表格

构造方法摘要
HashSet()
构造一个新的空 set，其底层 HashMap 实例的默认初始容量是 16，加载因子是 0.75。
HashSet(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的新 set。
HashSet(int initialCapacity)
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和默认的加载因子（0.75）。
HashSet(int initialCapacity, float loadFactor)
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和指定的加载因子。
方法摘要
boolean | add(E e) 如果此 set 中尚未包含指定元素，则添加指定元素。
void | clear() 从此 set 中移除所有元素。
Object | clone() 返回此 HashSet 实例的浅表副本：并没有复制这些元素本身。
boolean | contains(Object o) 如果此 set 包含指定元素，则返回 true。
boolean | isEmpty() 如果此 set 不包含任何元素，则返回 true。
Iterator<E> | iterator() 返回对此 set 中元素进行迭代的迭代器。
boolean | remove(Object o) 如果指定元素存在于此 set 中，则将其移除。
int | size() 返回此 set 中的元素的数量（set 的容量）。
从类 java.util.AbstractSet 继承的方法
equals, hashCode, removeAll
从类 java.util.AbstractCollection 继承的方法
addAll, containsAll, retainAll, toArray, toArray, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Set 继承的方法
addAll, containsAll, equals, hashCode, removeAll, retainAll, toArray, toArray

构造方法详细信息

HashSet

public HashSet()
构造一个新的空 set，其底层 HashMap 实例的默认初始容量是 16，加载因子是 0.75。

HashSet

public HashSet(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的新 set。使用默认的加载因子 0.75 和足以包含指定 collection 中所有元素的初始容量来创建 HashMap。

参数：
c - 其中的元素将存放在此 set 中的 collection
抛出：
NullPointerException - 如果指定的 collection 为 null

HashSet

public HashSet(int initialCapacity,
               float loadFactor)
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和指定的加载因子。

参数：
initialCapacity - 哈希映射的初始容量
loadFactor - 哈希映射的加载因子
抛出：
IllegalArgumentException - 如果初始容量小于零，或者加载因子为非正数

HashSet

public HashSet(int initialCapacity)
构造一个新的空 set，其底层 HashMap 实例具有指定的初始容量和默认的加载因子（0.75）。

参数：
initialCapacity - 哈希表的初始容量
抛出：
IllegalArgumentException - 如果初始容量小于零
方法详细信息

iterator

public Iterator<E> iterator()
返回对此 set 中元素进行迭代的迭代器。返回元素的顺序并不是特定的。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Set<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
对此 set 中元素进行迭代的 Iterator
另请参见：
ConcurrentModificationException

size

public int size()
返回此 set 中的元素的数量（set 的容量）。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 Set<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此 set 中的元素的数量（set 的容量）

isEmpty

public boolean isEmpty()
如果此 set 不包含任何元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
指定者：
接口 Set<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
如果此 set 不包含任何元素，则返回 true

contains

public boolean contains(Object o)
如果此 set 包含指定元素，则返回 true。 更确切地讲，当且仅当此 set 包含一个满足 (o==null ? e==null : o.equals(e)) 的 e 元素时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 Set<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 其在此 set 中的存在已得到测试的元素
返回：
如果此 set 包含指定元素，则返回 true

add

public boolean add(E e)
如果此 set 中尚未包含指定元素，则添加指定元素。更确切地讲，如果此 set 没有包含满足 (e==null ? e2==null : e.equals(e2)) 的元素 e2，则向此 set 添加指定的元素 e。如果此 set 已包含该元素，则该调用不更改 set 并返回 false。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Set<E> 中的 add
覆盖：
类 AbstractCollection<E> 中的 add
参数：
e - 将添加到此 set 中的元素
返回：
如果此 set 尚未包含指定元素，则返回 true

remove

public boolean remove(Object o)
如果指定元素存在于此 set 中，则将其移除。更确切地讲，如果此 set 包含一个满足 (o==null ? e==null : o.equals(e)) 的元素 e，则将其移除。如果此 set 已包含该元素，则返回 true（或者：如果此 set 因调用而发生更改，则返回 true）。（一旦调用返回，则此 set 不再包含该元素）。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 Set<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 如果存在于此 set 中则需要将其移除的对象
返回：
如果 set 包含指定元素，则返回 true

clear

public void clear()
从此 set 中移除所有元素。此调用返回后，该 set 将为空。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 Set<E> 中的 clear
覆盖：
类 AbstractCollection<E> 中的 clear

clone

public Object clone()
返回此 HashSet 实例的浅表副本：并没有复制这些元素本身。

覆盖：
类 Object 中的 clone
返回：
此 set 的浅表副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Hashtable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Hashtable<K,V>

java.lang.Object
    继承者  java.util.Dictionary<K,V>
        继承者  java.util.Hashtable<K,V>
所有已实现的接口：
Serializable, Cloneable, Map<K,V>
直接已知子类：
Properties, UIDefaults
public class Hashtable<K,V>
extends Dictionary<K,V>
implements Map<K,V>, Cloneable, Serializable

此类实现一个哈希表，该哈希表将键映射到相应的值。任何非 null 对象都可以用作键或值。

为了成功地在哈希表中存储和获取对象，用作键的对象必须实现 hashCode 方法和 equals 方法。

Hashtable 的实例有两个参数影响其性能：初始容量 和加载因子。容量 是哈希表中桶 的数量，初始容量 就是哈希表创建时的容量。注意，哈希表的状态为 open：在发生“哈希冲突”的情况下，单个桶会存储多个条目，这些条目必须按顺序搜索。加载因子 是对哈希表在其容量自动增加之前可以达到多满的一个尺度。初始容量和加载因子这两个参数只是对该实现的提示。关于何时以及是否调用 rehash 方法的具体细节则依赖于该实现。

通常，默认加载因子(.75)在时间和空间成本上寻求一种折衷。加载因子过高虽然减少了空间开销，但同时也增加了查找某个条目的时间（在大多数 Hashtable 操作中，包括 get 和 put 操作，都反映了这一点）。

初始容量主要控制空间消耗与执行 rehash 操作所需要的时间损耗之间的平衡。如果初始容量大于 Hashtable 所包含的最大条目数除以加载因子，则永远 不会发生 rehash 操作。但是，将初始容量设置太高可能会浪费空间。

如果很多条目要存储在一个 Hashtable 中，那么与根据需要执行自动 rehashing 操作来增大表的容量的做法相比，使用足够大的初始容量创建哈希表或许可以更有效地插入条目。

下面这个示例创建了一个数字的哈希表。它将数字的名称用作键：

   Hashtable<String, Integer> numbers
     = new Hashtable<String, Integer>();
   numbers.put("one", 1);
   numbers.put("two", 2);
   numbers.put("three", 3);

要获取一个数字，可以使用以下代码：

   Integer n = numbers.get("two");
     if (n != null) {
         System.out.println("two = " + n);
     }
   }

由所有类的“collection 视图方法”返回的 collection 的 iterator 方法返回的迭代器都是快速失败 的：在创建 Iterator 之后，如果从结构上对 Hashtable 进行修改，除非通过 Iterator 自身的 remove 方法，否则在任何时间以任何方式对其进行修改，Iterator 都将抛出ConcurrentModificationException。因此，面对并发的修改，Iterator 很快就会完全失败，而不冒在将来某个不确定的时间发生任意不确定行为的风险。由 Hashtable 的键和元素方法返回的 Enumeration 不 是快速失败的。

注意，迭代器的快速失败行为无法得到保证，因为一般来说，不可能对是否出现不同步并发修改做出任何硬性保证。快速失败迭代器会尽最大努力抛出 ConcurrentModificationException。因此，为提高这类迭代器的正确性而编写一个依赖于此异常的程序是错误做法：迭代器的快速失败行为应该仅用于检测程序错误。

从Java 2 平台 v1.2起，此类就被改进以实现 Map 接口，使它成为 Java Collections Framework 中的一个成员。不像新的 collection 实现，Hashtable 是同步的

从以下版本开始：
JDK1.0
另请参见：
Object.equals(java.lang.Object), Object.hashCode(), rehash(), Collection, Map, HashMap, TreeMap, 序列化表格

构造方法摘要
Hashtable()
用默认的初始容量 (11) 和加载因子 (0.75) 构造一个新的空哈希表。
Hashtable(int initialCapacity)
用指定初始容量和默认的加载因子 (0.75) 构造一个新的空哈希表。
Hashtable(int initialCapacity, float loadFactor)
用指定初始容量和指定加载因子构造一个新的空哈希表。
Hashtable(Map<? extends K,? extends V> t)
构造一个与给定的 Map 具有相同映射关系的新哈希表。
方法摘要
void | clear() 将此哈希表清空，使其不包含任何键。
Object | clone() 创建此哈希表的浅表副本。
boolean | contains(Object value) 测试此映射表中是否存在与指定值关联的键。
boolean | containsKey(Object key) 测试指定对象是否为此哈希表中的键。
boolean | containsValue(Object value) 如果此 Hashtable 将一个或多个键映射到此值，则返回 true。
Enumeration<V> | elements() 返回此哈希表中的值的枚举。
Set<Map.Entry<K,V>> | entrySet() 返回此映射中包含的键的 Set 视图。
boolean | equals(Object o) 按照 Map 接口的定义，比较指定 Object 与此 Map 是否相等。
V | get(Object key) 返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null. 更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。
int | hashCode() 按照 Map 接口的定义，返回此 Map 的哈希码值。
boolean | isEmpty() 测试此哈希表是否没有键映射到值。
Enumeration<K> | keys() 返回此哈希表中的键的枚举。
Set<K> | keySet() 返回此映射中包含的键的 Set 视图。
V | put(K key, V value) 将指定 key 映射到此哈希表中的指定 value。
void | putAll(Map<? extends K,? extends V> t) 将指定映射的所有映射关系复制到此哈希表中，这些映射关系将替换此哈希表拥有的、针对当前指定映射中所有键的所有映射关系。
protected void | rehash() 增加此哈希表的容量并在内部对其进行重组，以便更有效地容纳和访问其元素。
V | remove(Object key) 从哈希表中移除该键及其相应的值。
int | size() 返回此哈希表中的键的数量。
String | toString() 返回此 Hashtable 对象的字符串表示形式，其形式为 ASCII 字符 ", " （逗号加空格）分隔开的、括在括号中的一组条目。
Collection<V> | values() 返回此映射中包含的键的 Collection 视图。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Hashtable

public Hashtable(int initialCapacity,
                 float loadFactor)
用指定初始容量和指定加载因子构造一个新的空哈希表。

参数：
initialCapacity - 哈希表的初始容量。
loadFactor - 哈希表的加载因子。
抛出：
IllegalArgumentException - 如果初始容量小于零，或者加载因子为非正数。

Hashtable

public Hashtable(int initialCapacity)
用指定初始容量和默认的加载因子 (0.75) 构造一个新的空哈希表。

参数：
initialCapacity - 哈希表的初始容量。
抛出：
IllegalArgumentException - 如果初始容量小于零。

Hashtable

public Hashtable()
用默认的初始容量 (11) 和加载因子 (0.75) 构造一个新的空哈希表。

Hashtable

public Hashtable(Map<? extends K,? extends V> t)
构造一个与给定的 Map 具有相同映射关系的新哈希表。该哈希表是用足以容纳给定 Map 中映射关系的初始容量和默认的加载因子（0.75）创建的。

参数：
t - 其映射关系将存放在此映射中的映射。
抛出：
NullPointerException - 如果指定映射为 null。
从以下版本开始：
1.2
方法详细信息

size

public int size()
返回此哈希表中的键的数量。

指定者：
接口 Map<K,V> 中的 size
指定者：
类 Dictionary<K,V> 中的 size
返回：
此哈希表中的键的数量。

isEmpty

public boolean isEmpty()
测试此哈希表是否没有键映射到值。

指定者：
接口 Map<K,V> 中的 isEmpty
指定者：
类 Dictionary<K,V> 中的 isEmpty
返回：
如果此哈希表没有将任何键映射到值，则返回 true；否则返回 false。

keys

public Enumeration<K> keys()
返回此哈希表中的键的枚举。

指定者：
类 Dictionary<K,V> 中的 keys
返回：
此哈希表中的键的枚举。
另请参见：
Enumeration, elements(), keySet(), Map

elements

public Enumeration<V> elements()
返回此哈希表中的值的枚举。对返回的对象使用 Enumeration 方法，以便按顺序获取这些元素。

指定者：
类 Dictionary<K,V> 中的 elements
返回：
此哈希表中的值的枚举。
另请参见：
Enumeration, keys(), values(), Map

contains

public boolean contains(Object value)
测试此映射表中是否存在与指定值关联的键。此操作比 containsKey 方法的开销更大。

注意，此方法在功能上等同于 containsValue 方法，containValue 是 collection 框架中 Map 接口的一部分。

参数：
value - 要搜索的值。
返回：
当且仅当此哈希表中某个键映射到 value 参数（由 equals 方法确定）时，返回 true；否则返回 false。
抛出：
NullPointerException - 如果该值为 null

containsValue

public boolean containsValue(Object value)
如果此 Hashtable 将一个或多个键映射到此值，则返回 true。

注意，此方法在功能上等同于contains（它先于 Map 接口）。

指定者：
接口 Map<K,V> 中的 containsValue
参数：
value - 将要测试是否存在此哈希表中的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true
抛出：
NullPointerException - 如果该值为 null
从以下版本开始：
1.2

containsKey

public boolean containsKey(Object key)
测试指定对象是否为此哈希表中的键。

指定者：
接口 Map<K,V> 中的 containsKey
参数：
key - 可能的键
返回：
当且仅当指定对象（由 equals 方法确定）是此哈希表中的键时，才返回 true；否则返回 false。
抛出：
NullPointerException - 如果该键为 null
另请参见：
contains(Object)

get

public V get(Object key)
返回指定键所映射到的值，如果此映射不包含此键的映射，则返回 null.

更确切地讲，如果此映射包含满足 (key.equals(k)) 的从键 k 到值 v 的映射，则此方法返回 v；否则，返回 null。（最多只能有一个这样的映射。）

指定者：
接口 Map<K,V> 中的 get
指定者：
类 Dictionary<K,V> 中的 get
参数：
key - 要返回其相关值的键
返回：
指定键映射到的值，如果此映射不包含到键的映射，则返回 null。
抛出：
NullPointerException - 如果指定键为 null
另请参见：
put(Object, Object)

rehash

protected void rehash()
增加此哈希表的容量并在内部对其进行重组，以便更有效地容纳和访问其元素。当哈希表中的键的数量超出哈希表的容量和加载因子时，自动调用此方法。

put

public V put(K key,
             V value)
将指定 key 映射到此哈希表中的指定 value。键和值都不可以为 null。

通过使用与原来的键相同的键调用 get 方法，可以获取相应的值。

指定者：
接口 Map<K,V> 中的 put
指定者：
类 Dictionary<K,V> 中的 put
参数：
key - 哈希表的键
value - 值
返回：
此哈希表中指定键的以前的值；如果不存在该值，则返回 null
抛出：
NullPointerException - 如果键或值为 null
另请参见：
Object.equals(Object), get(Object)

remove

public V remove(Object key)
从哈希表中移除该键及其相应的值。如果该键不在哈希表中，则此方法不执行任何操作。

指定者：
接口 Map<K,V> 中的 remove
指定者：
类 Dictionary<K,V> 中的 remove
参数：
key - 需要移除的键
返回：
此哈希表中与该键存在映射关系的值；如果该键没有映射关系，则返回 null
抛出：
NullPointerException - 如果该键为 null

putAll

public void putAll(Map<? extends K,? extends V> t)
将指定映射的所有映射关系复制到此哈希表中，这些映射关系将替换此哈希表拥有的、针对当前指定映射中所有键的所有映射关系。

指定者：
接口 Map<K,V> 中的 putAll
参数：
t - 将存储在此映射中的映射关系。
抛出：
NullPointerException - 如果指定的映射为 null。
从以下版本开始：
1.2

clear

public void clear()
将此哈希表清空，使其不包含任何键。

指定者：
接口 Map<K,V> 中的 clear

clone

public Object clone()
创建此哈希表的浅表副本。复制哈希表自身的所有结构，但不复制它的键和值。这是一个开销相对较大的操作。

覆盖：
类 Object 中的 clone
返回：
哈希表的一个副本
另请参见：
Cloneable

toString

public String toString()
返回此 Hashtable 对象的字符串表示形式，其形式为 ASCII 字符 ", " （逗号加空格）分隔开的、括在括号中的一组条目。每个条目都按以下方式呈现：键，一个等号 = 和相关元素，其中 toString 方法用于将键和元素转换为字符串。

覆盖：
类 Object 中的 toString
返回：
此哈希表的字符串表示形式

keySet

public Set<K> keySet()
返回此映射中包含的键的 Set 视图。此 set 受映射支持，因此对映射的更改可在 set 中反映出来，反之亦然。如果在此 set 上的迭代器处于进行中时修改此映射（除非通过迭代器自身的 remove 操作），则迭代器的结果是不确定的。通过 Iterator.remove、Set.remove、removeAll、 retainAll、和 clear 操作，此 set 支持元素移除，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 keySet
返回：
此映射中包含的键的 set 视图
从以下版本开始：
1.2

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射中包含的键的 Set 视图。此 set 受映射支持，因此对映射的更改可在 set 中反映出来，反之亦然。如果在此 set 上的迭代器处于进行中时修改此映射（除非通过迭代器自身的 remove 操作，或通过由迭代器返回的映射条目上的 setValue 操作），则迭代器的结果是不确定的。通过 Iterator.remove、Set.remove、removeAll、 retainAll、 和 clear 操作，此set 支持元素移除，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图
从以下版本开始：
1.2

values

public Collection<V> values()
返回此映射中包含的键的 Collection 视图。此 collection 受映射支持，因此对映射的更改可在 collection 中反映出来，反之亦然。如果在此 collection 上的迭代器处于进行中时修改此映射（除非通过迭代器自身的 remove 操作），则迭代器的结果是不确定的。通过 Iterator.remove、Collection.remove、removeAll、 retainAll、 和 clear 操作，此set 支持元素移除，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图
从以下版本开始：
1.2

equals

public boolean equals(Object o)
按照 Map 接口的定义，比较指定 Object 与此 Map 是否相等。

指定者：
接口 Map<K,V> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 将与此哈希表进行比较相等性的对象
返回：
如果指定的 Object 与此 Map 相等，则返回 true。
从以下版本开始：
1.2
另请参见：
Map.equals(Object)

hashCode

public int hashCode()
按照 Map 接口的定义，返回此 Map 的哈希码值。

指定者：
接口 Map<K,V> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
从以下版本开始：
1.2
另请参见：
Map.hashCode()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IdentityHashMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 IdentityHashMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.IdentityHashMap<K,V>
所有已实现的接口：
Serializable, Cloneable, Map<K,V>
public class IdentityHashMap<K,V>
extends AbstractMap<K,V>
implements Map<K,V>, Serializable, Cloneable

此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。换句话说，在 IdentityHashMap 中，当且仅当 (k1==k2) 时，才认为两个键 k1 和 k2 相等（在正常 Map 实现（如 HashMap）中，当且仅当满足下列条件时才认为两个键 k1 和 k2 相等：(k1==null ? k2==null : e1.equals(e2))）。

此类不是 通用 Map 实现！此类实现 Map 接口时，它有意违反 Map 的常规协定，该协定在比较对象时强制使用 equals 方法。此类设计仅用于其中需要引用相等性语义的罕见情况。

此类的典型用法是拓扑保留对象图形转换，如序列化或深层复制。要执行这样的转换，程序必须维护用于跟踪所有已处理对象引用的“节点表”。节点表一定不等于不同对象，即使它们偶然相等也如此。此类的另一种典型用法是维护代理对象。例如，调试设施可能希望为正在调试程序中的每个对象维护代理对象。

此类提供所有的可选映射操作，并且允许 null 值和 null 键。此类对映射的顺序不提供任何保证；特别是不保证顺序随时间的推移保持不变。

此类提供基本操作（get 和 put）的稳定性能，假定系统标识了将桶间元素正确分开的哈希函数 (System.identityHashCode(Object))。

此类具有一个调整参数（影响性能但不影响语义）：expected maximum size。此参数是希望映射保持的键值映射关系最大数。在内部，此参数用于确定最初组成哈希表的桶数。未指定所期望的最大数量和桶数之间的确切关系。

如果映射的大小（键值映射关系数）已经超过期望的最大数量，则桶数会增加，增加桶数（“重新哈希”）可能相当昂贵，因此创建具有足够大的期望最大数量的标识哈希映射更合算。另一方面，对 collection 视图进行迭代所需的时间与哈希表中的桶数成正比，所以如果特别注重迭代性能或内存使用，则不宜将期望的最大数量设置得过高。

注意，此实现不是同步的。如果多个线程同时访问标识哈希映射，并且其中至少一个线程从结构上修改了该映射，则其必须 保持外部同步（结构上的修改是指添加或删除一个或多个映射关系的操作；仅改变与实例已经包含的键关联的值不是结构上的修改。）这一般通过对自然封装该映射的对象进行同步操作来完成。 如果不存在这样的对象，则应该使用 Collections.synchronizedMap 方法来“包装”该映射。最好在创建时完成这一操作，以防止对映射进行意外的不同步访问，如下所示：

     Map m = Collections.synchronizedMap(new HashMap(...));

由所有此类的“collection 视图方法”所返回的collections的iterator 方法返回的迭代器都是快速失败 的：在迭代器创建之后，如果从结构上对映射进行修改，除非通过迭代器自身的 remove 或 add 方法，其他任何时间任何方式的修改，迭代器都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不冒在将来不确定的时间任意发生不确定行为的风险。

注意，迭代器的快速失败行为不能得到保证，一般来说，存在不同步的并发修改时，不可能作出任何强有力的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的方式是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测程序错误。

实现注意事项：此为简单的线性探头 哈希表，如 Sedgewick 和 Knuth 原文示例中所述。该数组交替保持键和值（对于大型表来说，它比使用独立组保持键和值更具优势）。对于多数 JRE 实现和混合操作，此类比 HashMap（它使用链 而不使用线性探头）能产生更好的性能。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.4
另请参见：
System.identityHashCode(Object), Object.hashCode(), Collection, Map, HashMap, TreeMap, 序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
构造方法摘要
IdentityHashMap()
构造一个具有默认期望最大数量 (21) 的新的空标识哈希映射。
IdentityHashMap(int expectedMaxSize)
构造一个具有指定期望最大数量的新的空映射。
IdentityHashMap(Map<? extends K,? extends V> m)
构造包含指定映射中键-值映射关系的新标识哈希映射。
方法摘要
void | clear() 从映射中移除所有映射关系。
Object | clone() 返回此标识哈希映射的浅表副本：不复制键和值本身。
boolean | containsKey(Object key) 测试指定的对象引用是否为此标识哈希映射中的键。
boolean | containsValue(Object value) 测试指定的对象引用是否为此标识哈希映射中的值。
Set<Map.Entry<K,V>> | entrySet() 返回此映射所包含映射关系的 Set 视图。
boolean | equals(Object o) 比较指定对象与此映射的相等性。
V | get(Object key) 返回指定键映射的值；如果映射不包含此键的任何映射关系，则返回 null。
int | hashCode() 返回映射的哈希码值。
boolean | isEmpty() 如果此标识哈希映射不包含键-值映射关系，则返回 true。
Set<K> | keySet() 返回映射中所包含键的基于标识的 set 视图。
V | put(K key, V value) 在此标识哈希映射中关联指定值与指定键。
void | putAll(Map<? extends K,? extends V> m) 将指定映射的全部映射关系复制到此映射，这些映射关系将替换此映射目前针对指定映射的任何键的任何映射关系。
V | remove(Object key) 移除映射中此键的映射关系（如果存在的话）。
int | size() 返回标识哈希映射中的键-值映射关系数。
Collection<V> | values() 返回映射所包含值的 Collection 视图。
从类 java.util.AbstractMap 继承的方法
toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

IdentityHashMap

public IdentityHashMap()
构造一个具有默认期望最大数量 (21) 的新的空标识哈希映射。

IdentityHashMap

public IdentityHashMap(int expectedMaxSize)
构造一个具有指定期望最大数量的新的空映射。将多于期望数的键-值映射关系放置到映射中可能会导致内部数据结构的增长，这种增长是颇为耗时的。

参数：
expectedMaxSize - 映射的期望最大数量
抛出：
IllegalArgumentException - 如果 expectedMaxSize 是负数

IdentityHashMap

public IdentityHashMap(Map<? extends K,? extends V> m)
构造包含指定映射中键-值映射关系的新标识哈希映射。

参数：
m - 要将其映射关系放置在此映射中的映射
抛出：
NullPointerException - 如果指定的映射为 null
方法详细信息

size

public int size()
返回标识哈希映射中的键-值映射关系数。

指定者：
接口 Map<K,V> 中的 size
覆盖：
类 AbstractMap<K,V> 中的 size
返回：
映射中的键-值映射关系数

isEmpty

public boolean isEmpty()
如果此标识哈希映射不包含键-值映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 isEmpty
覆盖：
类 AbstractMap<K,V> 中的 isEmpty
返回：
如果此标识哈希映射不包含键-值映射关系，则返回 true

get

public V get(Object key)
返回指定键映射的值；如果映射不包含此键的任何映射关系，则返回 null。

更确切地讲，如果此映射包含满足 (key == k) 的从键 k 到值 v 的映射关系，则此方法返回 v；否则，返回 null。（最多只能有一个这样的映射关系。）

返回值为 null 并不一定 表示映射不包含此键的映射关系；也可能是映射显式地将键映射到 null。使用 containsKey 方法可以区分这两种情况。

指定者：
接口 Map<K,V> 中的 get
覆盖：
类 AbstractMap<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
另请参见：
put(Object, Object)

containsKey

public boolean containsKey(Object key)
测试指定的对象引用是否为此标识哈希映射中的键。

指定者：
接口 Map<K,V> 中的 containsKey
覆盖：
类 AbstractMap<K,V> 中的 containsKey
参数：
key - 可能的键
返回：
如果指定的对象引用是此映射中的键，则返回 true
另请参见：
containsValue(Object)

containsValue

public boolean containsValue(Object value)
测试指定的对象引用是否为此标识哈希映射中的值。

指定者：
接口 Map<K,V> 中的 containsValue
覆盖：
类 AbstractMap<K,V> 中的 containsValue
参数：
value - 要测试其是否在此映射中存在的值
返回：
如果此映射将一个或多个键映射到指定对象引用，则返回 true
另请参见：
containsKey(Object)

put

public V put(K key,
             V value)
在此标识哈希映射中关联指定值与指定键。如果映射以前包含了一个此键的映射关系，那么将替换旧值。

指定者：
接口 Map<K,V> 中的 put
覆盖：
类 AbstractMap<K,V> 中的 put
参数：
key - 要将指定值关联到的键
value - 要关联到指定键的值
返回：
返回与 key 相关联的先前值，如果 key 没有映射关系，则返回 null（返回 null 可能还表示映射以前将 null 与指定键关联）
另请参见：
Object.equals(Object), get(Object), containsKey(Object)

putAll

public void putAll(Map<? extends K,? extends V> m)
将指定映射的全部映射关系复制到此映射，这些映射关系将替换此映射目前针对指定映射的任何键的任何映射关系。

指定者：
接口 Map<K,V> 中的 putAll
覆盖：
类 AbstractMap<K,V> 中的 putAll
参数：
m - 要在此映射中存储的映射关系。
抛出：
NullPointerException - 如果指定的映射为 null。

remove

public V remove(Object key)
移除映射中此键的映射关系（如果存在的话）。

指定者：
接口 Map<K,V> 中的 remove
覆盖：
类 AbstractMap<K,V> 中的 remove
参数：
key - 其映射关系要从映射中移除的键
返回：
返回与 key 相关联的先前值，如果 key 没有任何映射关系，则返回 null（返回 null 还客表示映射以前将 null 与 key 关联）。

clear

public void clear()
从映射中移除所有映射关系。 此调用返回后映射将为空。

指定者：
接口 Map<K,V> 中的 clear
覆盖：
类 AbstractMap<K,V> 中的 clear

equals

public boolean equals(Object o)
比较指定对象与此映射的相等性。如果给定对象也是一个映射并且两个映射表示相同的对象引用映射关系，则返回 true。更确切地讲，当且仅当映射 this.entrySet().equals(m.entrySet()) 时，此映射等于另一个映射 m。

由于此映射基于引用相等性的语义，所以如果将此映射与正常映射相比，则可能违反 Object.equals 协定的对称性和传递性要求。但是，需要保证在 IdentityHashMap 实例间遵守 Object.equals 协定。

指定者：
接口 Map<K,V> 中的 equals
覆盖：
类 AbstractMap<K,V> 中的 equals
参数：
o - 要与此映射进行相等性比较的对象
返回：
如果指定对象等于此映射，则返回 true
另请参见：
Object.equals(Object)

hashCode

public int hashCode()
返回映射的哈希码值。映射的哈希码被定义为该映射 entrySet() 视图中所有项的哈希码和。这确保了 m1.equals(m2) 意味着对于任何两个 IdentityHashMap 实例 m1 和 m2 而言，都存在 m1.hashCode()==m2.hashCode()，这是 Object.hashCode() 的通用协定的所要求的。

由于此映射的 entrySet 方法所返回 set 中 Map.Entry 实例的基于引用相等性的语义，所以如果进行比较的两个对象中一个是 IdentityHashMap 实例，而另一个是正常映射，则可能违反以上段落中提到的 Object.hashCode 的协定要求。

指定者：
接口 Map<K,V> 中的 hashCode
覆盖：
类 AbstractMap<K,V> 中的 hashCode
返回：
此映射的哈希码值
另请参见：
Object.equals(Object), equals(Object)

clone

public Object clone()
返回此标识哈希映射的浅表副本：不复制键和值本身。

覆盖：
类 AbstractMap<K,V> 中的 clone
返回：
此映射的浅表副本
另请参见：
Cloneable

keySet

public Set<K> keySet()
返回映射中所包含键的基于标识的 set 视图。该 set 受映射支持，所以对映射的改变可在此 set 中反映出来，反之亦然。如果在对 set 进行迭代的同时修改映射，则迭代的结果是未定义的。该 set 支持元素的移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 方法可从映射中移除相应的映射关系。它不支持 add 或 addAll 方法。

此方法返回的对象实现 Set 接口时，它不 遵守 Set 的常规协定。与其底层映射一样，此方法返回的 set 将元素相等性定义为引用相等性，而非对象相等性。这一点将对其 contains、remove、containsAll、equals 和 hashCode 方法的行为产生影响。

如果指定对象是一个包含与返回 set 完全相同的对象引用的 set，则返回 set 的 equals 方法将返回 true。如果将此方法返回的 set 与正常 set 相比较，则可能违反 Object.equals 协定的对称性和传递性要求。但是，需要保证在此方法返回的 set 中遵守 Object.equals 协定。

返回 set 的 hashCode 方法返回该 set 中元素的标识哈希码 和，而不是其哈希码的和。为了强制遵守此方法所返回 set 中 Object.hashCode 方法的常规协定，需要通过更改 equals 方法的语义来强制完成。

指定者：
接口 Map<K,V> 中的 keySet
覆盖：
类 AbstractMap<K,V> 中的 keySet
返回：
映射所含键的基于标识的 set 视图
另请参见：
Object.equals(Object), System.identityHashCode(Object)

values

public Collection<V> values()

返回映射所包含值的 Collection 视图。该 collection 受映射的支持，所以对映射的改变可在此 collection 中反映出来，反之亦然。如果在对 collection 进行迭代的同时修改映射，则迭代的结果是未定义的。该 collection 支持元素的移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 方法可从该映射中移除相应的映射关系。它不支持 add 或 addAll 方法。

此方法返回的对象实现 Collection 接口时，它不 遵守 Collection 的常规协定。与其底层映射一样，此方法返回的 collection 将元素相等性定义为引用相等性，而非对象相等性。这一点将对其 contains、remove 和 containsAll 方法的行为产生影响。

指定者：
接口 Map<K,V> 中的 values
覆盖：
类 AbstractMap<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射所包含映射关系的 Set 视图。在返回的 set 中，每个元素都是一个基于引用相等性的 Map.Entry。该 set 受映射支持，所以对映射的改变可在此 set 中反映出来，反之亦然。如果在对 set 进行迭代的同时修改映射，则迭代的结果是未定义的。该 set 支持元素的移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 方法可从此映射移除相应的映射关系。它不支持 add 或 addAll 方法。

与底层映射一样，此方法所返回 set 中的 Map.Entry 对象将键和值的相等性定义为引用相等性，而非对象相等性。这一点将对 Map.Entry 对象的 equals 和 hashCode 方法的行为产生影响。当且仅当 o 为 Map.Entry 并且 e.getKey()==o.getKey() && e.getValue()==o.getValue() 时，基于引用相等性的 Map.Entry e 等于对象 o。为了适应这些相等语义，hashCode 方法返回 System.identityHashCode(e.getKey()) ^ System.identityHashCode(e.getValue())。

由于此方法所返回 set 中 Map.Entry 实例的基于引用相等性的语义，所以如果将该 set 中的任何项与正常映射项相比较，或者将此方法返回的 set 与正常映射项（比如在正式映射上对此方法的调用所返回的项）的 set 相比较，则可能违反 Object.equals(Object) 协定的对称性和传递性要求。但是，需要保证在基于标识的映射项中和在这些项的 set 中遵守 Object.equals 协定。

指定者：
接口 Map<K,V> 中的 entrySet
指定者：
类 AbstractMap<K,V> 中的 entrySet
返回：
此映射所含标识映射关系的 set 视图
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalFormatCodePointException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 IllegalFormatCodePointException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.IllegalFormatCodePointException
所有已实现的接口：
Serializable
public class IllegalFormatCodePointException
extends IllegalFormatException

将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
IllegalFormatCodePointException(int c)
构造此类的实例，使其具有 Character.isValidCodePoint(int) 所定义的指定非法代码点。
方法摘要
 int getCodePoint()
返回 Character.isValidCodePoint(int) 所定义的非法代码点。
 String getMessage()
返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalFormatCodePointException

public IllegalFormatCodePointException(int c)
构造此类的实例，使其具有 Character.isValidCodePoint(int) 所定义的指定非法代码点。

参数：
c - 非法 Unicode 代码点。
方法详细信息

getCodePoint

public int getCodePoint()
返回 Character.isValidCodePoint(int) 所定义的非法代码点。

返回：
非法 Unicode 代码点。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalFormatConversionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 IllegalFormatConversionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.IllegalFormatConversionException
所有已实现的接口：
Serializable
public class IllegalFormatConversionException
extends IllegalFormatException

当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
IllegalFormatConversionException(char c, Class<?> arg)
使用不匹配转换和相应参数类构造此类的实例。
方法摘要
Class<?> | getArgumentClass() 返回不匹配参数的类。
char | getConversion() 返回不适用的转换。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalFormatConversionException

public IllegalFormatConversionException(char c,
                                        Class<?> arg)
使用不匹配转换和相应参数类构造此类的实例。

参数：
c - 不适用的转换。
arg - 不匹配参数的类。
方法详细信息

getConversion

public char getConversion()
返回不适用的转换。

返回：
不适用的转换。

getArgumentClass

public Class<?> getArgumentClass()
返回不匹配参数的类。

返回：
不匹配参数的类。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 IllegalFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
所有已实现的接口：
Serializable
直接已知子类：
DuplicateFormatFlagsException, FormatFlagsConversionMismatchException, IllegalFormatCodePointException, IllegalFormatConversionException, IllegalFormatFlagsException, IllegalFormatPrecisionException, IllegalFormatWidthException, MissingFormatArgumentException, MissingFormatWidthException, UnknownFormatConversionException, UnknownFormatFlagsException
public class IllegalFormatException
extends IllegalArgumentException

当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。只应当实例化此异常对应于具体错误的显式子类型。

从以下版本开始：
1.5
另请参见：
序列化表格

方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalFormatFlagsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 IllegalFormatFlagsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.IllegalFormatFlagsException
所有已实现的接口：
Serializable
public class IllegalFormatFlagsException
extends IllegalFormatException

当给出非法组合标志时，抛出未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
IllegalFormatFlagsException(String f)
构造带有指定标志的此类的一个实例。
方法摘要
String | getFlags() 返回包含非法组合的标志的集合。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalFormatFlagsException

public IllegalFormatFlagsException(String f)
构造带有指定标志的此类的一个实例。

参数：
f - 包含非法组合的格式标志的集合。
方法详细信息

getFlags

public String getFlags()
返回包含非法组合的标志的集合。

返回：
标志。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalFormatPrecisionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 IllegalFormatPrecisionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.IllegalFormatPrecisionException
所有已实现的接口：
Serializable
public class IllegalFormatPrecisionException
extends IllegalFormatException

当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
IllegalFormatPrecisionException(int p)
构造带有指定精度的此类的一个实例。
方法摘要
String | getMessage() 返回此 throwable 的详细消息字符串。
int | getPrecision() 返回精度。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalFormatPrecisionException

public IllegalFormatPrecisionException(int p)
构造带有指定精度的此类的一个实例。

参数：
p - 精度。
方法详细信息

getPrecision

public int getPrecision()
返回精度。

返回：
精度。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalFormatWidthException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 IllegalFormatWidthException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.IllegalFormatWidthException
所有已实现的接口：
Serializable
public class IllegalFormatWidthException
extends IllegalFormatException

当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
IllegalFormatWidthException(int w)
构造带有指定宽度的此类的一个实例。
方法摘要
String | getMessage() 返回此 throwable 的详细消息字符串。
int | getWidth() 返回宽度。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalFormatWidthException

public IllegalFormatWidthException(int w)
构造带有指定宽度的此类的一个实例。

参数：
w - 宽度。
方法详细信息

getWidth

public int getWidth()
返回宽度。

返回：
宽度。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Iterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Iterator<E>

所有已知子接口：
ListIterator<E>, XMLEventReader
所有已知实现类：
BeanContextSupport.BCSIterator, EventReaderDelegate, Scanner
public interface Iterator<E>

对 collection 进行迭代的迭代器。迭代器取代了 Java Collections Framework 中的 Enumeration。迭代器与枚举有两点不同：

  • 迭代器允许调用者利用定义良好的语义在迭代期间从迭代器所指向的 collection 移除元素。
  • 方法名称得到了改进。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, ListIterator, Enumeration

方法摘要
boolean | hasNext() 如果仍有元素可以迭代，则返回 true。
E | next() 返回迭代的下一个元素。
void | remove() 从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。

方法详细信息

hasNext

boolean hasNext()
如果仍有元素可以迭代，则返回 true。（换句话说，如果 next 返回了元素而不是抛出异常，则返回 true）。

返回：
如果迭代器具有多个元素，则返回 true。

next

E next()
返回迭代的下一个元素。

返回：
迭代的下一个元素。
抛出：
NoSuchElementException - 没有元素可以迭代。

remove

void remove()
从迭代器指向的 collection 中移除迭代器返回的最后一个元素（可选操作）。每次调用 next 只能调用一次此方法。如果进行迭代时用调用此方法之外的其他方式修改了该迭代器所指向的 collection，则迭代器的行为是不确定的。

抛出：
UnsupportedOperationException - 如果迭代器不支持 remove 操作。
IllegalStateException - 如果尚未调用 next 方法，或者在上一次调用 next 方法之后已经调用了 remove 方法。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputMismatchException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 InputMismatchException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.util.NoSuchElementException
                    继承者  java.util.InputMismatchException
所有已实现的接口：
Serializable
public class InputMismatchException
extends NoSuchElementException

由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。

从以下版本开始：
1.5
另请参见：
Scanner, 序列化表格

构造方法摘要
InputMismatchException()
构造 InputMismatchException，使用 null 作为其错误消息字符串。
InputMismatchException(String s)
构造 InputMismatchException，将引用保存到错误消息字符串 s 中，以便将来由 getMessage 方法获取。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InputMismatchException

public InputMismatchException()
构造 InputMismatchException，使用 null 作为其错误消息字符串。

InputMismatchException

public InputMismatchException(String s)
构造 InputMismatchException，将引用保存到错误消息字符串 s 中，以便将来由 getMessage 方法获取。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidPropertiesFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 InvalidPropertiesFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.util.InvalidPropertiesFormatException
所有已实现的接口：
Serializable
public class InvalidPropertiesFormatException
extends IOException

当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。

注意，虽然 InvalidPropertiesFormatException 从 Exception 继承了 Serializable 接口，但是它并非 Serializable。实现适当的序列化方法会抛出 NotSerializableException。

从以下版本开始：
1.5
另请参见：
Properties

构造方法摘要
InvalidPropertiesFormatException(String message)
构造一个带指定详细消息的 InvalidPropertiesFormatException。
InvalidPropertiesFormatException(Throwable cause)
构造一个带指定原因的 InvalidPropertiesFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidPropertiesFormatException

public InvalidPropertiesFormatException(Throwable cause)
构造一个带指定原因的 InvalidPropertiesFormatException。

参数：
cause - 原因（保存此原因，以便将来通过 Throwable#ggetCause() 方法进行获取）。

InvalidPropertiesFormatException

public InvalidPropertiesFormatException(String message)
构造一个带指定详细消息的 InvalidPropertiesFormatException。

参数：
message - 详细消息。保存该详细消息，以便将来通过 Throwable.getMessage() 方法进行获取。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkedHashMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 LinkedHashMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.HashMap<K,V>
            继承者  java.util.LinkedHashMap<K,V>
类型参数：
K - 由此映射维护的键的类型
V - 映射值的类型
所有已实现的接口：
Serializable, Cloneable, Map<K,V>
public class LinkedHashMap<K,V>
extends HashMap<K,V>
implements Map<K,V>

Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。此实现与 HashMap 的不同之处在于，后者维护着一个运行于所有条目的双重链接列表。此链接列表定义了迭代顺序，该迭代顺序通常就是将键插入到映射中的顺序（插入顺序）。注意，如果在映射中重新插入 键，则插入顺序不受影响。（如果在调用 m.put(k, v) 前 m.containsKey(k) 返回了 true，则调用时会将键 k 重新插入到映射 m 中。）

此实现可以让客户避免未指定的、由 HashMap（及 Hashtable）所提供的通常为杂乱无章的排序工作，同时无需增加与 TreeMap 相关的成本。使用它可以生成一个与原来顺序相同的映射副本，而与原映射的实现无关：

     void foo(Map m) {
         Map copy = new LinkedHashMap(m);
         ...
     }
如果模块通过输入得到一个映射，复制这个映射，然后返回由此副本确定其顺序的结果，这种情况下这项技术特别有用。（客户通常期望返回的内容与其出现的顺序相同。）

提供特殊的构造方法来创建链接哈希映射，该哈希映射的迭代顺序就是最后访问其条目的顺序，从近期访问最少到近期访问最多的顺序（访问顺序）。这种映射很适合构建 LRU 缓存。调用 put 或 get 方法将会访问相应的条目（假定调用完成后它还存在）。putAll 方法以指定映射的条目集迭代器提供的键-值映射关系的顺序，为指定映射的每个映射关系生成一个条目访问。任何其他方法均不生成条目访问。特别是，collection 视图上的操作不 影响底层映射的迭代顺序。

可以重写 removeEldestEntry(Map.Entry) 方法来实施策略，以便在将新映射关系添加到映射时自动移除旧的映射关系。

此类提供所有可选的 Map 操作，并且允许 null 元素。与 HashMap 一样，它可以为基本操作（add、contains 和 remove）提供稳定的性能，假定哈希函数将元素正确分布到桶中。由于增加了维护链接列表的开支，其性能很可能比 HashMap 稍逊一筹，不过这一点例外：LinkedHashMap 的 collection 视图迭代所需时间与映射的大小 成比例。HashMap 迭代时间很可能开支较大，因为它所需要的时间与其容量 成比例。

链接的哈希映射具有两个影响其性能的参数：初始容量和加载因子。它们的定义与 HashMap 极其相似。要注意，为初始容量选择非常高的值对此类的影响比对 HashMap 要小，因为此类的迭代时间不受容量的影响。

注意，此实现不是同步的。如果多个线程同时访问链接的哈希映射，而其中至少一个线程从结构上修改了该映射，则它必须 保持外部同步。这一般通过对自然封装该映射的对象进行同步操作来完成。如果不存在这样的对象，则应该使用 Collections.synchronizedMap 方法来“包装”该映射。最好在创建时完成这一操作，以防止对映射的意外的非同步访问：

    Map m = Collections.synchronizedMap(new LinkedHashMap(...));
结构修改是指添加或删除一个或多个映射关系，或者在按访问顺序链接的哈希映射中影响迭代顺序的任何操作。在按插入顺序链接的哈希映射中，仅更改与映射中已包含键关联的值不是结构修改。在按访问顺序链接的哈希映射中，仅利用 get 查询映射不是结构修改。）

Collection（由此类的所有 collection 视图方法所返回）的 iterator 方法返回的迭代器都是快速失败 的：在迭代器创建之后，如果从结构上对映射进行修改，除非通过迭代器自身的 remove 方法，其他任何时间任何方式的修改，迭代器都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不冒将来不确定的时间任意发生不确定行为的风险。

注意，迭代器的快速失败行为无法得到保证，因为一般来说，不可能对是否出现不同步并发修改做出任何硬性保证。快速失败迭代器会尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的方式是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测程序错误。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.4
另请参见：
Object.hashCode(), Collection, Map, HashMap, TreeMap, Hashtable, 序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
构造方法摘要
LinkedHashMap()
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。
LinkedHashMap(int initialCapacity)
构造一个带指定初始容量和默认加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。
LinkedHashMap(int initialCapacity, float loadFactor)
构造一个带指定初始容量和加载因子的空插入顺序 LinkedHashMap 实例。
LinkedHashMap(int initialCapacity, float loadFactor, boolean accessOrder)
构造一个带指定初始容量、加载因子和排序模式的空 LinkedHashMap 实例。
LinkedHashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定映射相同的插入顺序 LinkedHashMap 实例。
方法摘要
void | clear() 从该映射中移除所有映射关系。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
V | get(Object key) 返回此映射到指定键的值。
protected boolean | removeEldestEntry(Map.Entry<K,V> eldest) 如果此映射移除其最旧的条目，则返回 true。
从类 java.util.HashMap 继承的方法
clone, containsKey, entrySet, isEmpty, keySet, put, putAll, remove, size, values
从类 java.util.AbstractMap 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Map 继承的方法
containsKey, entrySet, equals, hashCode, isEmpty, keySet, put, putAll, remove, size, values

构造方法详细信息

LinkedHashMap

public LinkedHashMap(int initialCapacity,
                     float loadFactor)
构造一个带指定初始容量和加载因子的空插入顺序 LinkedHashMap 实例。

参数：
initialCapacity - 初始容量
loadFactor - 加载因子
抛出：
IllegalArgumentException - 如果初始容量为负或者加载因子为非正

LinkedHashMap

public LinkedHashMap(int initialCapacity)
构造一个带指定初始容量和默认加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。

参数：
initialCapacity - 初始容量
抛出：
IllegalArgumentException - 如果初始容量为负

LinkedHashMap

public LinkedHashMap()
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的空插入顺序 LinkedHashMap 实例。

LinkedHashMap

public LinkedHashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定映射相同的插入顺序 LinkedHashMap 实例。所创建的 LinkedHashMap 实例具有默认的加载因子 (0.75) 和足以容纳指定映射中映射关系的初始容量。

参数：
m - 要将其映射关系存放在此映射中的映射
抛出：
NullPointerException - 如果指定的映射为 null

LinkedHashMap

public LinkedHashMap(int initialCapacity,
                     float loadFactor,
                     boolean accessOrder)
构造一个带指定初始容量、加载因子和排序模式的空 LinkedHashMap 实例。

参数：
initialCapacity - 初始容量
loadFactor - 加载因子
accessOrder - 排序模式 - 对于访问顺序，为 true；对于插入顺序，则为 false
抛出：
IllegalArgumentException - 如果初始容量为负或者加载因子为非正
方法详细信息

containsValue

public boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

指定者：
接口 Map<K,V> 中的 containsValue
覆盖：
类 HashMap<K,V> 中的 containsValue
参数：
value - 其在此映射中的存在已经测试的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true

get

public V get(Object key)
返回此映射到指定键的值。如果此映射中没有该键的映射关系，则返回 null 。

更确切地讲，如果此映射包含满足 (key==null ? k==null : key.equals(k)) 的从键 k 到值 v 的映射关系，则此方法返回 v；否则，返回 null。（最多只能有一个这样的映射关系。）

返回 null 值并不 一定 表明此映射不包含该键的映射关系；也可能此映射将该键显式地映射为 null。可使用 containsKey 操作来区分这两种情况。

指定者：
接口 Map<K,V> 中的 get
覆盖：
类 HashMap<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
另请参见：
HashMap.put(Object, Object)

clear

public void clear()
从该映射中移除所有映射关系。 此调用返回后映射将为空。

指定者：
接口 Map<K,V> 中的 clear
覆盖：
类 HashMap<K,V> 中的 clear

removeEldestEntry

protected boolean removeEldestEntry(Map.Entry<K,V> eldest)
如果此映射移除其最旧的条目，则返回 true。在将新条目插入到映射后，put 和 putAll 将调用此方法。此方法可以提供在每次添加新条目时移除最旧条目的实现程序。如果映射表示缓存，则此方法非常有用：它允许映射通过删除旧条目来减少内存损耗。

示例用法：此重写允许映射增加到 100 个条目，然后每次添加新条目时删除最旧的条目，始终维持 100 个条目的稳定状态。

     private static final int MAX_ENTRIES = 100;

     protected boolean removeEldestEntry(Map.Entry eldest) {
        return size() > MAX_ENTRIES;
     }

此方法通常不以任何方式修改映射，相反允许映射在其返回值的指引下进行自我修改。使用此方法直接修改映射是 允许的，但是如果它执行了此操作，则一定 返回 false（表示该映射不应进行任何进一步的修改）。在此方法中修改映射后是否返回 true 是不确定的。

此实现仅返回 false（这样，此映射的行为将类似于正常映射，即永远不能移除最旧的元素）。

参数：
eldest - 在映射中最早插入的条目；如果是访问顺序映射，则为最早访问的条目。如果此方法返回 true，则此为将移除的条目。如果导致此调用的 put 或 putAll 调用之前映射为空，则该条目就是刚刚插入的条目；换句话说，如果映射只包含单个条目，则最旧的条目也是最新的条目。
返回：
如果应该从映射移除最旧的条目，则返回 true；如果应该保留，则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkedHashSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 LinkedHashSet<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
            继承者  java.util.HashSet<E>
                继承者  java.util.LinkedHashSet<E>
类型参数：
E - 由此 set 维护的元素的类型
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, Set<E>
public class LinkedHashSet<E>
extends HashSet<E>
implements Set<E>, Cloneable, Serializable

具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。此实现与 HashSet 的不同之外在于，后者维护着一个运行于所有条目的双重链接列表。此链接列表定义了迭代顺序，即按照将元素插入到 set 中的顺序（插入顺序）进行迭代。注意，插入顺序不 受在 set 中重新插入的 元素的影响。（如果在 s.contains(e) 返回 true 后立即调用 s.add(e)，则元素 e 会被重新插入到 set s 中。）

此实现可以让客户免遭未指定的、由 HashSet 提供的通常杂乱无章的排序工作，而又不致引起与 TreeSet 关联的成本增加。使用它可以生成一个与原来顺序相同的 set 副本，并且与原 set 的实现无关：

     void foo(Set s) {
         Set copy = new LinkedHashSet(s);
         ...
     }
如果模块通过输入得到一个 set，复制这个 set，然后返回由此副本决定了顺序的结果，这种情况下这项技术特别有用。（客户通常期望内容返回的顺序与它们出现的顺序相同。）

此类提供所有可选的 Set 操作，并且允许 null 元素。与 HashSet 一样，它可以为基本操作（add、contains 和 remove）提供稳定的性能，假定哈希函数将元素正确地分布到存储段中。由于增加了维护链接列表的开支，其性能很可能会比 HashSet 稍逊一筹，不过，这一点例外：LinkedHashSet 迭代所需时间与 set 的大小 成正比，而与容量无关。HashSet 迭代很可能支出较大，因为它所需迭代时间与其容量 成正比。

链接的哈希 set 有两个影响其性能的参数：初始容量 和加载因子。它们与 HashSet 中的定义极其相同。注意，为初始容量选择非常高的值对此类的影响比对 HashSet 要小，因为此类的迭代时间不受容量的影响。

注意，此实现不是同步的。如果多个线程同时访问链接的哈希 set，而其中至少一个线程修改了该 set，则它必须 保持外部同步。这一般通过对自然封装该 set 的对象进行同步操作来完成。 如果不存在这样的对象，则应该使用 Collections.synchronizedSet 方法来“包装”该 set。最好在创建时完成这一操作，以防止意外的非同步访问：

     Set s = Collections.synchronizedSet(new LinkedHashSet(...));

此类的 iterator 方法返回的迭代器是快速失败 的：在迭代器创建之后，如果对 set 进行修改，除非通过迭代器自身的 remove 方法，其他任何时间任何方式的修改，迭代器都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不冒将来不确定的时间任意发生不确定行为的风险。

注意，迭代器的快速失败行为不能得到保证，一般来说，存在不同步的并发修改时，不可能作出任何强有力的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的方式是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测程序错误。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.4
另请参见：
Object.hashCode(), Collection, Set, HashSet, TreeSet, Hashtable, 序列化表格

构造方法摘要
LinkedHashSet()
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的新空链接哈希 set。
LinkedHashSet(Collection<? extends E> c)
构造一个与指定 collection 中的元素相同的新链接哈希 set。
LinkedHashSet(int initialCapacity)
构造一个带指定初始容量和默认加载因子 (0.75) 的新空链接哈希 set。
LinkedHashSet(int initialCapacity, float loadFactor)
构造一个带有指定初始容量和加载因子的新空链接哈希 set。
方法摘要
从类 java.util.HashSet 继承的方法
add, clear, clone, contains, isEmpty, iterator, remove, size
从类 java.util.AbstractSet 继承的方法
equals, hashCode, removeAll
从类 java.util.AbstractCollection 继承的方法
addAll, containsAll, retainAll, toArray, toArray, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Set 继承的方法
add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray

构造方法详细信息

LinkedHashSet

public LinkedHashSet(int initialCapacity,
                     float loadFactor)
构造一个带有指定初始容量和加载因子的新空链接哈希 set。

参数：
initialCapacity - 链接哈希 set 的初始容量
loadFactor - 链接哈希 set 的初始加载因子
抛出：
IllegalArgumentException - 如果初始容量小于零或者加载因子为非正

LinkedHashSet

public LinkedHashSet(int initialCapacity)
构造一个带指定初始容量和默认加载因子 (0.75) 的新空链接哈希 set。

参数：
initialCapacity - LinkedHashSet 的初始容量
抛出：
IllegalArgumentException - 如果初始容量小于零

LinkedHashSet

public LinkedHashSet()
构造一个带默认初始容量 (16) 和加载因子 (0.75) 的新空链接哈希 set。

LinkedHashSet

public LinkedHashSet(Collection<? extends E> c)
构造一个与指定 collection 中的元素相同的新链接哈希 set。此链接哈希 set 的创建使用的初始容量足以容纳指定 collection 的元素，使用的加载因子为默认加载因子 (0.75)。

参数：
c - 要将其元素放到此 set 中的 collection
抛出：
NullPointerException - 如果指定的 collection 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkedList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 LinkedList<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.AbstractSequentialList<E>
                继承者  java.util.LinkedList<E>
类型参数：
E - 在此 collection 中保持的元素的类型
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, Deque<E>, List<E>, Queue<E>
public class LinkedList<E>
extends AbstractSequentialList<E>
implements List<E>, Deque<E>, Cloneable, Serializable

List 接口的链接列表实现。实现所有可选的列表操作，并且允许所有元素（包括 null）。除了实现 List 接口外，LinkedList 类还为在列表的开头及结尾 get、remove 和 insert 元素提供了统一的命名方法。这些操作允许将链接列表用作堆栈、队列或双端队列。

此类实现 Deque 接口，为 add、poll 提供先进先出队列操作，以及其他堆栈和双端队列操作。

所有操作都是按照双重链接列表的需要执行的。在列表中编索引的操作将从开头或结尾遍历列表（从靠近指定索引的一端）。

注意，此实现不是同步的。如果多个线程同时访问一个链接列表，而其中至少一个线程从结构上修改了该列表，则它必须 保持外部同步。（结构修改指添加或删除一个或多个元素的任何操作；仅设置元素的值不是结构修改。）这一般通过对自然封装该列表的对象进行同步操作来完成。如果不存在这样的对象，则应该使用 Collections.synchronizedList 方法来“包装”该列表。最好在创建时完成这一操作，以防止对列表进行意外的不同步访问，如下所示：

   List list = Collections.synchronizedList(new LinkedList(...));

此类的 iterator 和 listIterator 方法返回的迭代器是快速失败 的：在迭代器创建之后，如果从结构上对列表进行修改，除非通过迭代器自身的 remove 或 add 方法，其他任何时间任何方式的修改，迭代器都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不冒将来不确定的时间任意发生不确定行为的风险。

注意，迭代器的快速失败行为不能得到保证，一般来说，存在不同步的并发修改时，不可能作出任何硬性保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的方式是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测程序错误。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
List, ArrayList, Vector, 序列化表格

字段摘要
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
LinkedList()
构造一个空列表。
LinkedList(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的列表，这些元素按其 collection 的迭代器返回的顺序排列。
方法摘要
 boolean add(E e)
将指定元素添加到此列表的结尾。
 void add(int index, E element)
在此列表中指定的位置插入指定的元素。
 boolean addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序。
 boolean addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素从指定位置开始插入此列表。
 void addFirst(E e)
将指定元素插入此列表的开头。
 void addLast(E e)
将指定元素添加到此列表的结尾。
 void clear()
从此列表中移除所有元素。
 Object clone()
返回此 LinkedList 的浅表副本。
 boolean contains(Object o)
如果此列表包含指定元素，则返回 true。
 Iterator<E> descendingIterator()
返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。
 E element()
获取但不移除此列表的头（第一个元素）。
 E get(int index)
返回此列表中指定位置处的元素。
 E getFirst()
返回此列表的第一个元素。
 E getLast()
返回此列表的最后一个元素。
 int indexOf(Object o)
返回此列表中首次出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。
 int lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。
 ListIterator<E> listIterator(int index)
返回此列表中的元素的列表迭代器（按适当顺序），从列表中指定位置开始。
 boolean offer(E e)
将指定元素添加到此列表的末尾（最后一个元素）。
 boolean offerFirst(E e)
在此列表的开头插入指定的元素。
 boolean offerLast(E e)
在此列表末尾插入指定的元素。
 E peek()
获取但不移除此列表的头（第一个元素）。
 E peekFirst()
获取但不移除此列表的第一个元素；如果此列表为空，则返回 null。
 E peekLast()
获取但不移除此列表的最后一个元素；如果此列表为空，则返回 null。
 E poll()
获取并移除此列表的头（第一个元素）
 E pollFirst()
获取并移除此列表的第一个元素；如果此列表为空，则返回 null。
 E pollLast()
获取并移除此列表的最后一个元素；如果此列表为空，则返回 null。
 E pop()
从此列表所表示的堆栈处弹出一个元素。
 void push(E e)
将元素推入此列表所表示的堆栈。
 E remove()
获取并移除此列表的头（第一个元素）。
 E remove(int index)
移除此列表中指定位置处的元素。
 boolean remove(Object o)
从此列表中移除首次出现的指定元素（如果存在）。
 E removeFirst()
移除并返回此列表的第一个元素。
 boolean removeFirstOccurrence(Object o)
从此列表中移除第一次出现的指定元素（从头部到尾部遍历列表时）。
 E removeLast()
移除并返回此列表的最后一个元素。
 boolean removeLastOccurrence(Object o)
从此列表中移除最后一次出现的指定元素（从头部到尾部遍历列表时）。
 E set(int index, E element)
将此列表中指定位置的元素替换为指定的元素。
 int size()
返回此列表的元素数。
 Object[] toArray()
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。
<T> T[]
toArray(T[] a)
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。
从类 java.util.AbstractSequentialList 继承的方法
iterator
从类 java.util.AbstractList 继承的方法
equals, hashCode, listIterator, removeRange, subList
从类 java.util.AbstractCollection 继承的方法
containsAll, isEmpty, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
containsAll, equals, hashCode, isEmpty, iterator, listIterator, removeAll, retainAll, subList
从接口 java.util.Deque 继承的方法
iterator

构造方法详细信息

LinkedList

public LinkedList()
构造一个空列表。

LinkedList

public LinkedList(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的列表，这些元素按其 collection 的迭代器返回的顺序排列。

参数：
c - 要将其元素放入此列表的 collection
抛出：
NullPointerException - 如果指定的 collection 为 null
方法详细信息

getFirst

public E getFirst()
返回此列表的第一个元素。

指定者：
接口 Deque<E> 中的 getFirst
返回：
此列表的第一个元素
抛出：
NoSuchElementException - 如果此列表为空

getLast

public E getLast()
返回此列表的最后一个元素。

指定者：
接口 Deque<E> 中的 getLast
返回：
此列表的最后一个元素
抛出：
NoSuchElementException - 如果此列表为空

removeFirst

public E removeFirst()
移除并返回此列表的第一个元素。

指定者：
接口 Deque<E> 中的 removeFirst
返回：
此列表的第一个元素
抛出：
NoSuchElementException - 如果此列表为空

removeLast

public E removeLast()
移除并返回此列表的最后一个元素。

指定者：
接口 Deque<E> 中的 removeLast
返回：
此列表的最后一个元素
抛出：
NoSuchElementException - 如果此列表为空

addFirst

public void addFirst(E e)
将指定元素插入此列表的开头。

指定者：
接口 Deque<E> 中的 addFirst
参数：
e - 要添加的元素

addLast

public void addLast(E e)
将指定元素添加到此列表的结尾。

此方法等效于 add(E)。

指定者：
接口 Deque<E> 中的 addLast
参数：
e - 要添加的元素

contains

public boolean contains(Object o)
如果此列表包含指定元素，则返回 true。更确切地讲，当且仅当此列表包含至少一个满足 (o==null ? e==null : o.equals(e)) 的元素 e 时返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 Deque<E> 中的 contains
指定者：
接口 List<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 要测试在此列表中是否存在的元素
返回：
如果此列表包含指定元素，则返回 true

size

public int size()
返回此列表的元素数。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 Deque<E> 中的 size
指定者：
接口 List<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此列表的元素数

add

public boolean add(E e)
将指定元素添加到此列表的结尾。

此方法等效于 addLast(E)。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Deque<E> 中的 add
指定者：
接口 List<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractList<E> 中的 add
参数：
e - 要添加到此列表的元素
返回：
true（根据 Collection.add(E) 的规定）

remove

public boolean remove(Object o)
从此列表中移除首次出现的指定元素（如果存在）。如果列表不包含该元素，则不作更改。更确切地讲，移除具有满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i 的元素（如果存在这样的元素）。如果此列表已包含指定元素（或者此列表由于调用而发生更改），则返回 true。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 Deque<E> 中的 remove
指定者：
接口 List<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此列表删除的元素，如果存在
返回：
如果此列表包含指定元素，则返回 true

addAll

public boolean addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序。如果指定的 collection 在操作过程中被修改，则此操作的行为是不确定的。（注意，如果指定 collection 就是此列表并且非空，则此操作的行为是不确定的。）

指定者：
接口 Collection<E> 中的 addAll
指定者：
接口 List<E> 中的 addAll
覆盖：
类 AbstractCollection<E> 中的 addAll
参数：
c - 包含要添加到此列表的元素的 collection
返回：
如果此列表由于调用而更改，则返回 true
抛出：
NullPointerException - 如果指定的 collection 为 null
另请参见：
AbstractCollection.add(Object)

addAll

public boolean addAll(int index,
                      Collection<? extends E> c)
将指定 collection 中的所有元素从指定位置开始插入此列表。移动当前在该位置上的元素（如果有），所有后续元素都向右移（增加其索引）。新元素将按由指定 collection 的迭代器返回的顺序在列表中显示。

指定者：
接口 List<E> 中的 addAll
覆盖：
类 AbstractSequentialList<E> 中的 addAll
参数：
index - 在其中插入指定 collection 中第一个元素的索引
c - 包含要添加到此列表的元素的 collection
返回：
如果此列表由于调用而更改，则返回 true
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())
NullPointerException - 如果指定的 collection 为 null

clear

public void clear()
从此列表中移除所有元素。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 List<E> 中的 clear
覆盖：
类 AbstractList<E> 中的 clear

get

public E get(int index)
返回此列表中指定位置处的元素。

指定者：
接口 List<E> 中的 get
覆盖：
类 AbstractSequentialList<E> 中的 get
参数：
index - 要返回的元素的索引
返回：
列表中指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

set

public E set(int index,
             E element)
将此列表中指定位置的元素替换为指定的元素。

指定者：
接口 List<E> 中的 set
覆盖：
类 AbstractSequentialList<E> 中的 set
参数：
index - 要替换的元素的索引
element - 要在指定位置存储的元素
返回：
以前在指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

add

public void add(int index,
                E element)
在此列表中指定的位置插入指定的元素。移动当前在该位置处的元素（如果有），所有后续元素都向右移（在其索引中添加 1）。

指定者：
接口 List<E> 中的 add
覆盖：
类 AbstractSequentialList<E> 中的 add
参数：
index - 要在其中插入指定元素的索引
element - 要插入的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

remove

public E remove(int index)
移除此列表中指定位置处的元素。将任何后续元素向左移（从索引中减 1）。返回从列表中删除的元素。

指定者：
接口 List<E> 中的 remove
覆盖：
类 AbstractSequentialList<E> 中的 remove
参数：
index - 要移除的元素的索引
返回：
以前在指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

indexOf

public int indexOf(Object o)
返回此列表中首次出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i；如果没有此索引，则返回 -1。

指定者：
接口 List<E> 中的 indexOf
覆盖：
类 AbstractList<E> 中的 indexOf
参数：
o - 要搜索的元素
返回：
此列表中首次出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1

lastIndexOf

public int lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引，如果此列表中不包含该元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最高索引 i；如果没有此索引，则返回 -1。

指定者：
接口 List<E> 中的 lastIndexOf
覆盖：
类 AbstractList<E> 中的 lastIndexOf
参数：
o - 要搜索的元素
返回：
此列表中最后出现的指定元素的索引；如果此列表中不包含该元素，则返回 -1

peek

public E peek()
获取但不移除此列表的头（第一个元素）。

指定者：
接口 Deque<E> 中的 peek
指定者：
接口 Queue<E> 中的 peek
返回：
此列表的头，如果此列表为空，则返回 null
从以下版本开始：
1.5

element

public E element()
获取但不移除此列表的头（第一个元素）。

指定者：
接口 Deque<E> 中的 element
指定者：
接口 Queue<E> 中的 element
返回：
列表的头
抛出：
NoSuchElementException - 如果此列表为空
从以下版本开始：
1.5

poll

public E poll()
获取并移除此列表的头（第一个元素）

指定者：
接口 Deque<E> 中的 poll
指定者：
接口 Queue<E> 中的 poll
返回：
此列表的头，如果此列表为空，则返回 null
从以下版本开始：
1.5

remove

public E remove()
获取并移除此列表的头（第一个元素）。

指定者：
接口 Deque<E> 中的 remove
指定者：
接口 Queue<E> 中的 remove
返回：
列表的头
抛出：
NoSuchElementException - 如果此列表为空
从以下版本开始：
1.5

offer

public boolean offer(E e)
将指定元素添加到此列表的末尾（最后一个元素）。

指定者：
接口 Deque<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
true（根据 Queue.offer(E) 的规定）
从以下版本开始：
1.5

offerFirst

public boolean offerFirst(E e)
在此列表的开头插入指定的元素。

指定者：
接口 Deque<E> 中的 offerFirst
参数：
e - 要插入的元素
返回：
true（根据 Deque.offerFirst(E) 的规定）
从以下版本开始：
1.6

offerLast

public boolean offerLast(E e)
在此列表末尾插入指定的元素。

指定者：
接口 Deque<E> 中的 offerLast
参数：
e - 要插入的元素
返回：
true（根据 Deque.offerLast(E) 的规定）
从以下版本开始：
1.6

peekFirst

public E peekFirst()
获取但不移除此列表的第一个元素；如果此列表为空，则返回 null。

指定者：
接口 Deque<E> 中的 peekFirst
返回：
此列表的第一个元素；如果此列表为空，则返回 null
从以下版本开始：
1.6

peekLast

public E peekLast()
获取但不移除此列表的最后一个元素；如果此列表为空，则返回 null。

指定者：
接口 Deque<E> 中的 peekLast
返回：
此列表的最后一个元素；如果此列表为空，则返回 null
从以下版本开始：
1.6

pollFirst

public E pollFirst()
获取并移除此列表的第一个元素；如果此列表为空，则返回 null。

指定者：
接口 Deque<E> 中的 pollFirst
返回：
此列表的第一个元素；如果此列表为空，则返回 null
从以下版本开始：
1.6

pollLast

public E pollLast()
获取并移除此列表的最后一个元素；如果此列表为空，则返回 null。

指定者：
接口 Deque<E> 中的 pollLast
返回：
此列表的最后一个元素；如果此列表为空，则返回 null
从以下版本开始：
1.6

push

public void push(E e)
将元素推入此列表所表示的堆栈。换句话说，将该元素插入此列表的开头。

此方法等效于 addFirst(E)。

指定者：
接口 Deque<E> 中的 push
参数：
e - 要推入的元素
从以下版本开始：
1.6

pop

public E pop()
从此列表所表示的堆栈处弹出一个元素。换句话说，移除并返回此列表的第一个元素。

此方法等效于 removeFirst()。

指定者：
接口 Deque<E> 中的 pop
返回：
此列表开头的元素（它是此列表所表示的堆栈的顶部）
抛出：
NoSuchElementException - 如果此列表为空
从以下版本开始：
1.6

removeFirstOccurrence

public boolean removeFirstOccurrence(Object o)
从此列表中移除第一次出现的指定元素（从头部到尾部遍历列表时）。如果列表不包含该元素，则不作更改。

指定者：
接口 Deque<E> 中的 removeFirstOccurrence
参数：
o - 要从此列表中移除的元素（如果存在）
返回：
如果该列表已包含指定元素，则返回 true
从以下版本开始：
1.6

removeLastOccurrence

public boolean removeLastOccurrence(Object o)
从此列表中移除最后一次出现的指定元素（从头部到尾部遍历列表时）。如果列表不包含该元素，则不作更改。

指定者：
接口 Deque<E> 中的 removeLastOccurrence
参数：
o - 要从此列表中移除的元素（如果存在）
返回：
如果该列表已包含指定元素，则返回 true
从以下版本开始：
1.6

listIterator

public ListIterator<E> listIterator(int index)
返回此列表中的元素的列表迭代器（按适当顺序），从列表中指定位置开始。遵守 List.listIterator(int) 的常规协定。

列表迭代器是快速失败 的：在迭代器创建之后，如果从结构上对列表进行修改，除非通过列表迭代器自身的 remove 或 add 方法，其他任何时间任何方式的修改，列表迭代器都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就会完全失败，而不冒将来不确定的时间任意发生不确定行为的风险。

指定者：
接口 List<E> 中的 listIterator
指定者：
类 AbstractSequentialList<E> 中的 listIterator
参数：
index - 要从列表迭代器返回的第一个元素的索引（通过调用 next 方法）
返回：
此列表中的元素的 ListIterator（按适当顺序），从列表中指定位置开始
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())
另请参见：
List.listIterator(int)

descendingIterator

public Iterator<E> descendingIterator()
从接口 Deque 复制的描述
返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。元素将按从最后一个（尾部）到第一个（头部）的顺序返回。

指定者：
接口 Deque<E> 中的 descendingIterator
返回：
以逆向顺序在此双端队列中的元素上进行迭代的迭代器
从以下版本开始：
1.6

clone

public Object clone()
返回此 LinkedList 的浅表副本。（这些元素本身没有复制。）

覆盖：
类 Object 中的 clone
返回：
此 LinkedList 实例的浅表副本
另请参见：
Cloneable

toArray

public Object[] toArray()
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。

由于此列表不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
以适当顺序包含此列表中所有元素的数组。
另请参见：
Arrays.asList(Object[])

toArray

public <T> T[] toArray(T[] a)
返回以适当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组；返回数组的运行时类型为指定数组的类型。如果指定数组能容纳列表，则在其中返回该列表。否则，分配具有指定数组的运行时类型和此列表大小的新数组。

如果指定数组能容纳列表，并有剩余空间（即数组比列表元素多），则紧跟在列表末尾的数组元素会被设置为 null。（只有 在调用者知道列表不包含任何 null 元素时，才可使用此方法来确定列表的长度。）

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型上进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知列表。以下代码可用来将该列表转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 要在其中存储列表元素的数组（如果它足够大）；否则，为其分配具有相同运行时类型的新数组
返回：
包含列表元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此列表中每个元素的运行时类型的超类型
NullPointerException - 如果指定的数组为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListIterator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 ListIterator<E>

所有超级接口：
Iterator<E>
public interface ListIterator<E>
extends Iterator<E>

系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。ListIterator 没有当前元素；它的光标位置 始终位于调用 previous() 所返回的元素和调用 next() 所返回的元素之间。长度为 n 的列表的迭代器有 n+1 个可能的指针位置，如下面的插入符举例说明：

                      Element(0)   Element(1)   Element(2)   ... Element(n-1)
 cursor positions:  ^            ^            ^            ^                  ^

注意，remove() 和 set(Object) 方法不是 根据光标位置定义的；它们是根据对调用 next() 或 previous() 所返回的最后一个元素的操作定义的。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, List, Iterator, Enumeration, List.listIterator()

方法摘要
void | add(E e) 将指定的元素插入列表（可选操作）。
boolean | hasNext() 以正向遍历列表时，如果列表迭代器有多个元素，则返回 true（换句话说，如果 next 返回一个元素而不是抛出异常，则返回 true）。
boolean | hasPrevious() 如果以逆向遍历列表，列表迭代器有多个元素，则返回 true。
E | next() 返回列表中的下一个元素。
int | nextIndex() 返回对 next 的后续调用所返回元素的索引。
E | previous() 返回列表中的前一个元素。
int | previousIndex() 返回对 previous 的后续调用所返回元素的索引。
void | remove() 从列表中移除由 next 或 previous 返回的最后一个元素（可选操作）。
void | set(E e) 用指定元素替换 next 或 previous 返回的最后一个元素（可选操作）。

方法详细信息

hasNext

boolean hasNext()
以正向遍历列表时，如果列表迭代器有多个元素，则返回 true（换句话说，如果 next 返回一个元素而不是抛出异常，则返回 true）。

指定者：
接口 Iterator<E> 中的 hasNext
返回：
如果以正向遍历列表，列表迭代器有多个元素，则返回 true。

next

E next()
返回列表中的下一个元素。可以重复调用此方法来迭代此列表，或混合调用 previous 来前后移动（注意交替调用 next 和 previous 将重复返回相同的元素）。

指定者：
接口 Iterator<E> 中的 next
返回：
列表中的下一个元素。
抛出：
NoSuchElementException - 如果没有可迭代的下一个元素。

hasPrevious

boolean hasPrevious()
如果以逆向遍历列表，列表迭代器有多个元素，则返回 true。（换句话说，如果 previous 返回一个元素而不是抛出异常，则返回 true）。

返回：
如果以逆向遍历列表，列表迭代器有多个元素，则返回 true。

previous

E previous()
返回列表中的前一个元素。可以重复调用此方法来迭代列表，或混合调用 next 来前后移动（注意交替调用 next 和 previous 将重复返回相同的元素）。

返回：
列表中的上一个元素。
抛出：
NoSuchElementException - 如果没有可迭代的上一个元素。

nextIndex

int nextIndex()
返回对 next 的后续调用所返回元素的索引。（如果列表迭代器在列表的结尾，则返回列表的大小）。

返回：
对 next 的后续调用所返回元素的索引，如果列表迭代器在列表的结尾，则返回列表大小。

previousIndex

int previousIndex()
返回对 previous 的后续调用所返回元素的索引。（如果列表迭代器在列表的开始，则返回 -1）。

返回：
对 previous 的后续调用所返回元素的索引，如果列表迭代器在列表的开始，则返回 -1。

remove

void remove()
从列表中移除由 next 或 previous 返回的最后一个元素（可选操作）。对于每个 next 或 previous 调用，只能执行一次此调用。只有在最后一次调用 next 或 previous 之后，尚未调用 ListIterator.add 时才可以执行该调用。

指定者：
接口 Iterator<E> 中的 remove
抛出：
UnsupportedOperationException - 如果列表迭代器不支持 remove 操作。
IllegalStateException - 既没有调用 next 也没有调用 previous，或者在最后一次调用 next 或 previous 后调用了 remove 或 add。

set

void set(E e)
用指定元素替换 next 或 previous 返回的最后一个元素（可选操作）。只有在最后一次调用 next 或 previous 后既没有调用 ListIterator.remove 也没有调用 ListIterator.add 时才可以进行该调用。

参数：
e - 用于替换 next 或 previous 返回的最后一个元素的元素。
抛出：
UnsupportedOperationException - 如果列表迭代器不支持 set 操作。
ClassCastException - 如果指定元素的类不允许该元素添加到此列表。
IllegalArgumentException - 如果指定元素的某个方面不允许该元素添加到此列表。
IllegalStateException - 如果既没有调用 next 也没有调用 previous，或者在最后一次调用 next 或 previous 后调用了 remove 或 add。

add

void add(E e)
将指定的元素插入列表（可选操作）。该元素直接插入到 next 返回的下一个元素的前面（如果有），或者 previous 返回的下一个元素之后（如果有）；如果列表没有元素，那么新元素就成为列表中的唯一元素。新元素被插入到隐式光标前：不影响对 next 的后续调用，并且对 previous 的后续调用会返回此新元素（此调用把调用 nextIndex 或 previousIndex 所返回的值增加 1）。

参数：
e - 要插入的元素。
抛出：
UnsupportedOperationException - 如果列表迭代器不支持 add 操作。
ClassCastException - 如果指定元素的类不允许该元素添加到此列表。
IllegalArgumentException - 如果此元素的某个方面不允许该元素添加到此列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListResourceBundle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ListResourceBundle

java.lang.Object
    继承者  java.util.ResourceBundle
        继承者  java.util.ListResourceBundle
直接已知子类：
AccessibleResourceBundle
public abstract class ListResourceBundle
extends ResourceBundle

ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。有关资源包的常规信息，请参阅 ResourceBundle。

子类必须重写 getContents 并提供一个数组，其中数组中的每个项都是一个对象对。每对的第一个元素是键，该键必须是一个 String，并且第二个元素是和该键相关联的值。

下面的示例显示了具有基本名称 "MyResources" 的资源包系列的两个成员。"MyResources" 是资源包系列的默认成员，"MyResources_fr" 是 French 成员。这些成员是基于 ListResourceBundle（一个相关的示例显示了如何把一个资源包添加到基于属性文件的此系列）。此示例中的键形式为 "s1" 等。实际的键完全取决于您的选择，只要它们和程序中用于从资源包中获取对象的键相同。键区分大小写。

public class MyResources extends ListResourceBundle {
     protected Object[][] getContents() {
         return new Object[][] = {
     // LOCALIZE THIS
         {"s1", "The disk \"{1}\" contains {0}."},  // MessageFormat pattern
         {"s2", "1"},                               // location of {0} in pattern
         {"s3", "My Disk"},                         // sample disk name
         {"s4", "no files"},                        // first ChoiceFormat choice
         {"s5", "one file"},                        // second ChoiceFormat choice
         {"s6", "{0,number} files"},                // third ChoiceFormat choice
         {"s7", "3 Mar 96"},                        // sample date
         {"s8", new Dimension(1,5)}                 // real object, not just string
     // END OF MATERIAL TO LOCALIZE
     };
   }
 }

 public class MyResources_fr extends ListResourceBundle {
     protected Object[][] getContents() {
         return new Object[][] = {
     // LOCALIZE THIS
         {"s1", "Le disque \"{1}\" {0}."},          // MessageFormat pattern
         {"s2", "1"},                               // location of {0} in pattern
         {"s3", "Mon disque"},                      // sample disk name
         {"s4", "ne contient pas de fichiers"},     // first ChoiceFormat choice
         {"s5", "contient un fichier"},             // second ChoiceFormat choice
         {"s6", "contient {0,number} fichiers"},    // third ChoiceFormat choice
         {"s7", "3 mars 1996"},                     // sample date
         {"s8", new Dimension(1,3)}                 // real object, not just string
     // END OF MATERIAL TO LOCALIZE
     };
   }
}

从以下版本开始：
JDK1.1
另请参见：
ResourceBundle, PropertyResourceBundle

嵌套类摘要
从类 java.util.ResourceBundle 继承的嵌套类/接口
ResourceBundle.Control
字段摘要
从类 java.util.ResourceBundle 继承的字段
parent
构造方法摘要
ListResourceBundle()
单独的构造方法。
方法摘要
protected abstract Object[][] | getContents() 返回一个数组，其中 Object 数组中的每个项都是一个对象对。
Enumeration<String> | getKeys() 返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
Object | handleGetObject(String key) 从此资源包中获取给定键的对象。
protected Set<String> | handleKeySet() 返回只 包含在此 ResourceBundle 中的键的 Set。
从类 java.util.ResourceBundle 继承的方法
clearCache, clearCache, containsKey, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getLocale, getObject, getString, getStringArray, keySet, setParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ListResourceBundle

public ListResourceBundle()
单独的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

handleGetObject

public final Object handleGetObject(String key)
从类 ResourceBundle 复制的描述
从此资源包中获取给定键的对象。如果此资源包未包含给定键的对象，则返回 null。

指定者：
类 ResourceBundle 中的 handleGetObject
参数：
key - 所需对象的键
返回：
给定键的对象，或者返回 null

getKeys

public Enumeration<String> getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。

指定者：
类 ResourceBundle 中的 getKeys
返回：
包含在此 ResourceBundle 及其父包中的键的 Enumeration。
另请参见：
ResourceBundle.keySet()

handleKeySet

protected Set<String> handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

覆盖：
类 ResourceBundle 中的 handleKeySet
返回：
只包含在此 ResourceBundle 中的键的 Set
从以下版本开始：
1.6
另请参见：
ResourceBundle.keySet()

getContents

protected abstract Object[][] getContents()
返回一个数组，其中 Object 数组中的每个项都是一个对象对。每对的第一个元素是键，它必须是 String，第二个元素是与该键关联的值。有关详细信息，请参阅类描述。

返回：
表示键-值对的 Object 数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Locale (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Locale

java.lang.Object
    继承者  java.util.Locale
所有已实现的接口：
Serializable, Cloneable
public final class Locale
extends Object
implements Cloneable, Serializable

Locale 对象表示了特定的地理、政治和文化地区。需要 Locale 来执行其任务的操作称为语言环境敏感的 操作，它使用 Locale 为用户量身定制信息。例如，显示一个数值就是语言环境敏感的操作，应该根据用户的国家、地区或文化的风俗/传统来格式化该数值。

使用此类中的构造方法来创建 Locale：

 Locale(String language)
 Locale(String language, String country)
 Locale(String language, String country, String variant)
语言参数是一个有效的 ISO 语言代码。这些代码是由 ISO-639 定义的小写两字母代码。在许多网站上都可以找到这些代码的完整列表，如：
http://www.loc.gov/standards/iso639-2/englangn.html。

国家/地区参数是一个有效的 ISO 国家/地区代码。这些代码是由 ISO-3166 定义的大写两字母代码。在许多网站上都可以找到这些代码的完整列表，如：
http://www.iso.ch/iso/en/prods-services/iso3166ma/02iso-3166-code-lists/list-en1.html。

变量参数是特定于供应商或浏览器的代码。例如，用 WIN 代表 Windows、MAC 代表 Macintosh 和 POSIX 代表 POSIX。有两个变量时，把它们用下划线区分开来，把最重要的放在前面。例如，一个传统的西班牙排序规则可能用下列语言、国家/地区和变量参数来构造一个语言环境："es"、"ES"、"Traditional_WIN"。

因为一个 Locale 对象就是一个地区的标识符，所以构造一个 Locale 时不执行有效性检查。如果想了解特定的资源在您构造的 Locale 中是否可用，则必须查询那些资源。例如，使用 getAvailableLocales 方法询问 NumberFormat 所支持的语言环境。
注：查询一个特定语言环境的资源时，得到的是最佳的可用匹配，没必要精确地按要求提供资源。有关更多信息，请参见 ResourceBundle。

Locale 类提供了一些方便的常量，可用这些常量为常用的语言环境创建 Locale 对象。例如，下面的内容为美国创建了一个 Locale 对象：

 Locale.US

创建完 Locale 后，就可以查询有关其自身的信息。使用 getCountry 可获取 ISO 国家/地区代码，使用 getLanguage 则获取 ISO 语言代码。可用使用 getDisplayCountry 来获取适合向用户显示的国家/地区名。同样，可用使用 getDisplayLanguage 来获取适合向用户显示的语言名。有趣的是，getDisplayXXX 方法本身是语言环境敏感的，它有两个版本：一个使用默认的语言环境作为参数，另一个则使用指定的语言环境作为参数。

Java 平台提供了多个可执行语言环境敏感操作的类：例如，NumberFormat 类以语言环境敏感的方式格式化数值、货币或百分比。像 NumberFormat 这样的类则有多种创建该类型默认对象的便捷方法。例如，NumberFormat 类提供了三个便捷的方法，用于创建默认的 NumberFormat 对象：

 NumberFormat.getInstance()
 NumberFormat.getCurrencyInstance()
 NumberFormat.getPercentInstance()
这些方法有两个变量；一个有明确的语言环境而另一个则没有；后者使用默认语言环境。
 NumberFormat.getInstance(myLocale)
 NumberFormat.getCurrencyInstance(myLocale)
 NumberFormat.getPercentInstance(myLocale)
Locale 是一种标识所要获取的对象种类 (NumberFormat) 的机制。但 locale 只是一种标识对象的机制，不是对象本身的容器。

从以下版本开始：
1.1
另请参见：
ResourceBundle, Format, NumberFormat, Collator, 序列化表格

字段摘要
static Locale | CANADA 用于表示国家/地区的有用常量。
static Locale | CANADA_FRENCH 用于表示国家/地区的有用常量。
static Locale | CHINA 用于表示国家/地区的有用常量。
static Locale | CHINESE 用于表示语言的有用常量。
static Locale | ENGLISH 用于表示语言的有用常量。
static Locale | FRANCE 用于表示国家/地区的有用常量。
static Locale | FRENCH 用于表示语言的有用常量。
static Locale | GERMAN 用于表示语言的有用常量。
static Locale | GERMANY 用于表示国家/地区的有用常量。
static Locale | ITALIAN 用于表示语言的有用常量。
static Locale | ITALY 用于表示国家/地区的有用常量。
static Locale | JAPAN 用于表示国家/地区的有用常量。
static Locale | JAPANESE 用于表示语言的有用常量。
static Locale | KOREA 用于表示国家/地区的有用常量。
static Locale | KOREAN 用于表示语言的有用常量。
static Locale | PRC 用于表示国家/地区的有用常量。
static Locale | ROOT 用于表示根语言环境的有用常量。
static Locale | SIMPLIFIED_CHINESE 用于表示语言的有用常量。
static Locale | TAIWAN 用于表示国家/地区的有用常量。
static Locale | TRADITIONAL_CHINESE 用于表示语言的有用常量。
static Locale | UK 用于表示国家/地区的有用常量。
static Locale | US 用于表示国家/地区的有用常量。
构造方法摘要
Locale(String language)
根据语言代码构造一个语言环境。
Locale(String language, String country)
根据语言和国家/地区构造一个语言环境。
Locale(String language, String country, String variant)
根据语言、国家/地区和变量构造一个语言环境。
方法摘要
Object | clone() 重写 Cloneable。
boolean | equals(Object obj) 如果该 Locale 等于另一个对象，则返回 true。
static Locale[] | getAvailableLocales() 返回所有已安装语言环境的数组。
String | getCountry() 返回此语言环境的国家/地区代码，将为空字符串或大写的 ISO 3166 两字母代码。
static Locale | getDefault() 获得此 Java 虚拟机实例的当前默认语言环境值。
String | getDisplayCountry() 返回适合向用户显示的语言环境国家/地区名。
String | getDisplayCountry(Locale inLocale) 返回适合向用户显示的语言环境国家/地区名。
String | getDisplayLanguage() 返回适合向用户显示的语言环境语言名。
String | getDisplayLanguage(Locale inLocale) 返回适合向用户显示的语言环境语言名。
String | getDisplayName() 返回适合向用户显示的语言环境名。
String | getDisplayName(Locale inLocale) 返回适合向用户显示的语言环境名。
String | getDisplayVariant() 返回适合向用户显示的语言环境变量代码名。
String | getDisplayVariant(Locale inLocale) 返回适合向用户显示的语言环境变量代码名。
String | getISO3Country() 返回此语言环境国家/地区的三字母缩写。
String | getISO3Language() 返回此语言环境语言的三字母缩写。
static String[] | getISOCountries() 返回 ISO 3166 中所定义的所有两字母国家/地区代码。
static String[] | getISOLanguages() 返回 ISO 639 中所定义的所有两字母语言代码。
String | getLanguage() 返回此语言环境的语言代码，可以是空字符串或小写的 ISO 639 代码。
String | getVariant() 返回此语言环境的变量代码。
int | hashCode() 重写 hashCode。
static void | setDefault(Locale newLocale) 为此 Java 虚拟机实例设置默认语言环境。
String | toString() 使用由下划线分隔的语言、国家/地区和变量来获取整个语言环境的编程名称。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ENGLISH

public static final Locale ENGLISH
用于表示语言的有用常量。

FRENCH

public static final Locale FRENCH
用于表示语言的有用常量。

GERMAN

public static final Locale GERMAN
用于表示语言的有用常量。

ITALIAN

public static final Locale ITALIAN
用于表示语言的有用常量。

JAPANESE

public static final Locale JAPANESE
用于表示语言的有用常量。

KOREAN

public static final Locale KOREAN
用于表示语言的有用常量。

CHINESE

public static final Locale CHINESE
用于表示语言的有用常量。

SIMPLIFIED_CHINESE

public static final Locale SIMPLIFIED_CHINESE
用于表示语言的有用常量。

TRADITIONAL_CHINESE

public static final Locale TRADITIONAL_CHINESE
用于表示语言的有用常量。

FRANCE

public static final Locale FRANCE
用于表示国家/地区的有用常量。

GERMANY

public static final Locale GERMANY
用于表示国家/地区的有用常量。

ITALY

public static final Locale ITALY
用于表示国家/地区的有用常量。

JAPAN

public static final Locale JAPAN
用于表示国家/地区的有用常量。

KOREA

public static final Locale KOREA
用于表示国家/地区的有用常量。

CHINA

public static final Locale CHINA
用于表示国家/地区的有用常量。

PRC

public static final Locale PRC
用于表示国家/地区的有用常量。

TAIWAN

public static final Locale TAIWAN
用于表示国家/地区的有用常量。

UK

public static final Locale UK
用于表示国家/地区的有用常量。

US

public static final Locale US
用于表示国家/地区的有用常量。

CANADA

public static final Locale CANADA
用于表示国家/地区的有用常量。

CANADA_FRENCH

public static final Locale CANADA_FRENCH
用于表示国家/地区的有用常量。

ROOT

public static final Locale ROOT
用于表示根语言环境的有用常量。根语言环境是指其语言、国家、变量是空（""）字符串的语言环境。它被视为所有语言环境的基础语言环境，并且用作语言环境敏感操作的语言/国家的非特定语言环境。

从以下版本开始：
1.6
构造方法详细信息

Locale

public Locale(String language,
              String country,
              String variant)
根据语言、国家/地区和变量构造一个语言环境。注：ISO 639 并非是一个不变的标准；它所定义的某些语言代码（特别是 iw、ji 和 in）已经发生了变化。此构造方法接受旧代码（iw、ji 和 in）和新代码（he、yi 和 id），但是 Locale 中的所有其他 API 将只返回旧代码。

参数：
language - 小写的两字母 ISO-639 代码。
country - 大写的两字母 ISO-3166 代码。
variant - 特定于供应商和浏览器的代码。参见类描述。
抛出：
NullPointerException - 如果任意参数为 null。

Locale

public Locale(String language,
              String country)
根据语言和国家/地区构造一个语言环境。注：ISO 639 并非是一个不变的标准；它所定义的某些语言代码（特别是 iw、ji 和 in）已经发生了变化。此构造方法接受旧代码（iw、ji 和 in）和新代码（he、yi 和 id），但是 Locale 中的所有其他 API 将只返回旧代码。

参数：
language - 小写的两字母 ISO-639 代码。
country - 大写的两字母 ISO-3166 代码。
抛出：
NullPointerException - 如果任意参数为 null。

Locale

public Locale(String language)
根据语言代码构造一个语言环境。注：ISO 639 并非是一个不变的标准；它所定义的某些语言代码（特别是 iw、ji 和 in）已经发生了变化。此构造方法接受旧代码（iw、ji 和 in）和新代码（he、yi 和 id），但是 Locale 中的所有其他 API 将只返回旧代码。

参数：
language - 小写的两字母 ISO-639 代码。
抛出：
NullPointerException - 如果参数为 null。
从以下版本开始：
1.4
方法详细信息

getDefault

public static Locale getDefault()
获得此 Java 虚拟机实例的当前默认语言环境值。

Java 虚拟机根据主机的环境在启动期间设置默认语言环境。如果没有明确地指定语言环境，则很多语言环境敏感的方法都使用该方法。可使用 setDefault 方法更改该值。

返回：
此 Java 虚拟机实例的默认语言环境。

setDefault

public static void setDefault(Locale newLocale)
为此 Java 虚拟机实例设置默认语言环境。这不会影响主机的语言环境。

如果有安全管理器，则在更改默认语言环境前使用 PropertyPermission("user.language", "write") 权限调用其 checkPermission 方法。

Java 虚拟机根据主机的环境在启动期间设置默认语言环境。如果没有明确地指定语言环境，则很多语言环境敏感的方法都使用该方法。

由于更改默认的语言环境可能影响功能的很多方面，所以应该仅在调用者准备重新初始化在同一 Java 虚拟机内所运行的语言环境敏感代码时才使用此方法。

参数：
newLocale - 新的默认语言环境。
抛出：
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许该操作。
NullPointerException - 如果 newLocale 为 null。
另请参见：
SecurityManager.checkPermission(java.security.Permission), PropertyPermission

getAvailableLocales

public static Locale[] getAvailableLocales()
返回所有已安装语言环境的数组。 返回的数组表示由 Java 运行时环境和已安装的 LocaleServiceProvider 所支持的语言环境的联合。它必须至少包含一个等于 Locale.US 的 Locale 实例。

返回：
已安装语言环境的数组。

getISOCountries

public static String[] getISOCountries()
返回 ISO 3166 中所定义的所有两字母国家/地区代码。可用于创建 Locale。

getISOLanguages

public static String[] getISOLanguages()
返回 ISO 639 中所定义的所有两字母语言代码。可用于创建 Locale。[注：ISO 639 并非是一个不变的标准，某些语言代码已经改变。此功能所返回的列表包括了代码已改变的语言的新代码和旧代码。]

getLanguage

public String getLanguage()
返回此语言环境的语言代码，可以是空字符串或小写的 ISO 639 代码。

注：ISO 639 并非是一个不变的标准，某些语言代码已经改变。Locale 的构造方法可识别代码已改变的语言的新代码和旧代码，但是此功能总是返回旧代码。如果想检查代码已改变的特定语言，不要执行

 if (locale.getLanguage().equals("he")）
    ...
Instead, do
 if (locale.getLanguage().equals(new Locale("he", "", "").getLanguage())）
    ...

另请参见：
getDisplayLanguage()

getCountry

public String getCountry()
返回此语言环境的国家/地区代码，将为空字符串或大写的 ISO 3166 两字母代码。

另请参见：
getDisplayCountry()

getVariant

public String getVariant()
返回此语言环境的变量代码。

另请参见：
getDisplayVariant()

toString

public final String toString()
使用由下划线分隔的语言、国家/地区和变量来获取整个语言环境的编程名称。语言总是小写，国家/地区总是大写。如果没有语言，则字符串用一个下划线开头。如果语言和国家/地区字段都丢失了，则此功能将返回空字符串，即使变量字段中填有内容也如此（不能只用变量来创建一个语言环境，变量必须随附在有效的语言或国家/地区代码上）。示例："en"、"de_DE"、"_GB"、"en_US_WIN"、"de__POSIX"、"fr__MAC"。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
另请参见：
getDisplayName()

getISO3Language

public String getISO3Language()
                       throws MissingResourceException
返回此语言环境语言的三字母缩写。如果此语言环境未指定语言，那么这将是一个空字符串。否则，将返回小写的 ISO 639-2/T 语言代码。可在 http://www.loc.gov/standards/iso639-2/englangn.html. 找到 ISO 639-2 语言代码。

抛出：
MissingResourceException - 如果三字母语言缩写不可用于此语言环境，则抛出 MissingResourceException。

getISO3Country

public String getISO3Country()
                      throws MissingResourceException
返回此语言环境国家/地区的三字母缩写。如果此语言环境未指定国家/地区，那么这将是一个空字符串。否则将返回大写的 ISO 3166 三字母国家/地区代码。可在 http://www.davros.org/misc/iso3166.txt. 找到 ISO 3166-2 国家/地区代码。

抛出：
MissingResourceException - 如果三字母国家/地区缩写不可用于此语言环境，则抛出 MissingResourceException。

getDisplayLanguage

public final String getDisplayLanguage()
返回适合向用户显示的语言环境语言名。如有可能，将为默认的语言环境对返回的名称进行本地化。例如，如果语言环境是 fr_FR 并且默认的语言环境是 en_US，则 getDisplayLanguage() 将返回 "French"；如果语言环境是 en_US 并且默认的语言环境是 fr_FR，则 getDisplayLanguage() 将返回 "anglais"。如果无法为默认的语言环境本地化返回的名称（比方说没有 Croatian 的日本名称），则该功能将依赖英文名，并使用 ISO 代码作为最终的值。如果该语言环境未指定语言，则此功能返回空字符串。

getDisplayLanguage

public String getDisplayLanguage(Locale inLocale)
返回适合向用户显示的语言环境语言名。如有可能，将根据 inLocale 对返回的名称进行本地化。例如，如果语言环境是 fr_FR 并且 inLocale 是 en_US，则 getDisplayLanguage() 将返回 "French"；如果语言环境是 en_US 并且 inLocale 是 fr_FR，则 getDisplayLanguage() 将返回 "anglais"。如果无法根据 inLocale 对返回的名称进行本地化（比方说没有 Croatian 的日本名称），则该功能将依赖英文名，并使用 ISO 代码作为最终的值。如果该语言环境未指定语言，则此功能返回空字符串。

抛出：
NullPointerException - 如果 inLocale 为 null

getDisplayCountry

public final String getDisplayCountry()
返回适合向用户显示的语言环境国家/地区名。如有可能，将为默认的语言环境对返回的名称进行本地化。例如，如果语言环境是 fr_FR 并且默认的语言环境是 en_US，则 getDisplayCountry() 将返回 "France"；如果语言环境是 en_US 并且默认的语言环境是 fr_FR，则 getDisplayCountry() 将返回 "Etats-Unis"。如果无法为默认的语言环境本地化返回的名称（比方说没有 Croatia 的日本名称），则该功能将依赖英文名，并使用 ISO 代码作为最终的值。如果该语言环境未指定国家/地区，则此功能返回空字符串。

getDisplayCountry

public String getDisplayCountry(Locale inLocale)
返回适合向用户显示的语言环境国家/地区名。 如有可能，将根据 inLocale 对返回的名称进行本地化。例如，如果语言环境是 fr_FR 并且 inLocale 是 en_US，则 getDisplayCountry() 将返回 "France"；如果语言环境是 en_US 并且 inLocale 是 fr_FR，则 getDisplayCountry() 将返回 "Etats-Unis"。如果无法根据 inLocale 对返回的名称进行本地化（比方说没有 Croatia 的日本名称），则该功能将依赖英文名，并使用 ISO 代码作为最终的值。如果该语言环境未指定国家/地区，则此功能返回空字符串。

抛出：
NullPointerException - 如果 inLocale 为 null

getDisplayVariant

public final String getDisplayVariant()
返回适合向用户显示的语言环境变量代码名。如有可能，将为默认的语言环境对返回的名称进行本地化。如果该语言环境未指定变量代码，则此功能返回空字符串。

getDisplayVariant

public String getDisplayVariant(Locale inLocale)
返回适合向用户显示的语言环境变量代码名。如有可能，将根据 inLocale 对名称进行本地化。如果该语言环境未指定变量代码，则此功能返回空字符串。

抛出：
NullPointerException - 如果 inLocale 为 null

getDisplayName

public final String getDisplayName()
返回适合向用户显示的语言环境名。这将把 getDisplayLanguage()、getDisplayCountry() 和 getDisplayVariant() 返回的值组合到单个字符串中。显示的名称具有下列形式之一：

语言（国家/地区，变量）

语言（国家/地区）

语言（变量）

国家/地区（变量）

语言

国家/地区

变量

这取决于语言环境中指定了哪些字段。如果语言、国家/地区和变量字段都为空，则该功能将返回空字符串。

getDisplayName

public String getDisplayName(Locale inLocale)
返回适合向用户显示的语言环境名。这将把 getDisplayLanguage()、getDisplayCountry() 和 getDisplayVariant() 返回的值组合到单个字符串中。显示的名称具有下列形式之一：

语言（国家/地区，变量）

语言（国家/地区）

语言（变量）

国家/地区（变量）

语言

国家/地区

变量

这取决于语言环境中指定了哪些字段。如果语言、国家/地区和变量字段都为空，则该功能将返回空字符串。

抛出：
NullPointerException - 如果 inLocale 为 null

clone

public Object clone()
重写 Cloneable。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

hashCode

public int hashCode()
重写 hashCode。由于 Locale 经常用于哈希表中，所以缓存该值可提高速度。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
如果该 Locale 等于另一个对象，则返回 true。一个 Locale 与另一个 Locale 具有相同的语言、国家/地区和变量时，则认为它们相等；并与所有其他对象都不相等。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此 Locale 等于指定的对象，则返回 true。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Map (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Map<K,V>

类型参数：
K - 此映射所维护的键的类型
V - 映射值的类型
所有已知子接口：
Bindings, ConcurrentMap<K,V>, ConcurrentNavigableMap<K,V>, LogicalMessageContext, MessageContext, NavigableMap<K,V>, SOAPMessageContext, SortedMap<K,V>
所有已知实现类：
AbstractMap, Attributes, AuthProvider, ConcurrentHashMap, ConcurrentSkipListMap, EnumMap, HashMap, Hashtable, IdentityHashMap, LinkedHashMap, PrinterStateReasons, Properties, Provider, RenderingHints, SimpleBindings, TabularDataSupport, TreeMap, UIDefaults, WeakHashMap
public interface Map<K,V>

将键映射到值的对象。一个映射不能包含重复的键；每个键最多只能映射到一个值。

此接口取代 Dictionary 类，后者完全是一个抽象类，而不是一个接口。

Map 接口提供三种collection 视图，允许以键集、值集或键-值映射关系集的形式查看某个映射的内容。映射顺序 定义为迭代器在映射的 collection 视图上返回其元素的顺序。某些映射实现可明确保证其顺序，如 TreeMap 类；另一些映射实现则不保证顺序，如 HashMap 类。

注：将可变对象用作映射键时必须格外小心。当对象是映射中某个键时，如果以影响 equals 比较的方式更改了对象的值，则映射的行为将是不确定的。此项禁止的一种特殊情况是不允许某个映射将自身作为一个键包含。虽然允许某个映射将自身作为值包含，但请格外小心：在这样的映射上 equals 和 hashCode 方法的定义将不再是明确的。

所有通用的映射实现类应该提供两个“标准的”构造方法：一个 void（无参数）构造方法，用于创建空映射；一个是带有单个 Map 类型参数的构造方法，用于创建一个与其参数具有相同键-值映射关系的新映射。实际上，后一个构造方法允许用户复制任意映射，生成所需类的一个等价映射。尽管无法强制执行此建议（因为接口不能包含构造方法），但是 JDK 中所有通用的映射实现都遵从它。

此接口中包含的“破坏”方法可修改其操作的映射，如果此映射不支持该操作，这些方法将抛出 UnsupportedOperationException。如果是这样，那么在调用对映射无效时，这些方法可以（但不要求）抛出 UnsupportedOperationException。例如，如果某个不可修改的映射（其映射关系是“重叠”的）为空，则对该映射调用 putAll(Map) 方法时，可以（但不要求）抛出异常。

某些映射实现对可能包含的键和值有所限制。例如，某些实现禁止 null 键和值，另一些则对其键的类型有限制。尝试插入不合格的键或值将抛出一个未经检查的异常，通常是 NullPointerException 或 ClassCastException。试图查询是否存在不合格的键或值可能抛出异常，或者返回 false；某些实现将表现出前一种行为，而另一些则表现后一种。一般来说，试图对不合格的键或值执行操作且该操作的完成不会导致不合格的元素被插入映射中时，将可能抛出一个异常，也可能操作成功，这取决于实现本身。这样的异常在此接口的规范中标记为“可选”。

此接口是 Java Collections Framework 的成员。

Collections Framework 接口中的很多方法是根据 equals 方法定义的。例如，containsKey(Object key) 方法的规范中写道：“当且仅当此映射包含针对满足 (key==null ? k==null : key.equals(k)) 的键 k 的映射关系时，返回 true”。不 应将此规范解释为：调用具有非空参数 key 的 Map.containsKey 将导致对任意的键 k 调用 key.equals(k)。实现可随意进行优化，以避免调用 equals，例如，可首先比较两个键的哈希码（Object.hashCode() 规范保证哈希码不相等的两个对象不会相等）。一般来说，只要实现者认为合适，各种 Collections Framework 接口的实现可随意利用底层 Object 方法的指定行为。

从以下版本开始：
1.2
另请参见：
HashMap, TreeMap, Hashtable, SortedMap, Collection, Set

嵌套类摘要
static interface Map.Entry<K,V>
映射项（键-值对）。
方法摘要
void | clear() 从此映射中移除所有映射关系（可选操作）。
boolean | containsKey(Object key) 如果此映射包含指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
Set<Map.Entry<K,V>> | entrySet() 返回此映射中包含的映射关系的 Set 视图。
boolean | equals(Object o) 比较指定的对象与此映射是否相等。
V | get(Object key) 返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。
int | hashCode() 返回此映射的哈希码值。
boolean | isEmpty() 如果此映射未包含键-值映射关系，则返回 true。
Set<K> | keySet() 返回此映射中包含的键的 Set 视图。
V | put(K key, V value) 将指定的值与此映射中的指定键关联（可选操作）。
void | putAll(Map<? extends K,? extends V> m) 从指定映射中将所有映射关系复制到此映射中（可选操作）。
V | remove(Object key) 如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。
int | size() 返回此映射中的键-值映射关系数。
Collection<V> | values() 返回此映射中包含的值的 Collection 视图。

方法详细信息

size

int size()
返回此映射中的键-值映射关系数。如果该映射包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

返回：
此映射中的键-值映射关系数

isEmpty

boolean isEmpty()
如果此映射未包含键-值映射关系，则返回 true。

返回：
如果此映射未包含键-值映射关系，则返回 true

containsKey

boolean containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。更确切地讲，当且仅当此映射包含针对满足 (key==null ? k==null : key.equals(k)) 的键 k 的映射关系时，返回 true。（最多只能有一个这样的映射关系）。

参数：
key - 测试是否存在于此映射中的键
返回：
如果此映射包含指定键的映射关系，则返回 true
抛出：
ClassCastException - 如果该键对于此映射是不合适的类型（可选）
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键（可选）

containsValue

boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。更确切地讲，当且仅当此映射至少包含一个对满足 (value==null ? v==null : value.equals(v)) 的值 v 的映射关系时，返回 true。对于大多数 Map 接口的实现而言，此操作需要的时间可能与映射大小呈线性关系。

参数：
value - 测试是否存在于此映射中的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true
抛出：
ClassCastException - 如果该值对于此映射是不合适的类型（可选）
NullPointerException - 如果指定值为 null 并且此映射不允许 null 值（可选）

get

V get(Object key)
返回指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null。

更确切地讲，如果此映射包含满足 (key==null ? k==null : key.equals(k)) 的键 k 到值 v 的映射关系，则此方法返回 v；否则返回 null。（最多只能有一个这样的映射关系）。

如果此映射允许 null 值，则返回 null 值并不一定 表示该映射不包含该键的映射关系；也可能该映射将该键显示地映射到 null。使用 containsKey 操作可区分这两种情况。

参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
抛出：
ClassCastException - 如果该键对于此映射是不合适的类型（可选）
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键（可选）

put

V put(K key,
      V value)
将指定的值与此映射中的指定键关联（可选操作）。如果此映射以前包含一个该键的映射关系，则用指定值替换旧值（当且仅当 m.containsKey(k) 返回 true 时，才能说映射 m 包含键 k 的映射关系）。

参数：
key - 与指定值关联的键
value - 与指定键关联的值
返回：
以前与 key 关联的值，如果没有针对 key 的映射关系，则返回 null。（如果该实现支持 null 值，则返回 null 也可能表示此映射以前将 null 与 key 关联）。
抛出：
UnsupportedOperationException - 如果此映射不支持 put 操作
ClassCastException - 如果指定键或值的类不允许将其存储在此映射中
NullPointerException - 如果指定键或值为 null，并且此映射不允许 null 键或值
IllegalArgumentException - 如果指定键或值的某些属性不允许将其存储在此映射中

remove

V remove(Object key)
如果存在一个键的映射关系，则将其从此映射中移除（可选操作）。更确切地讲，如果此映射包含从满足 (key==null ? k==null :key.equals(k)) 的键 k 到值 v 的映射关系，则移除该映射关系。（该映射最多只能包含一个这样的映射关系。）

返回此映射中以前关联该键的值，如果此映射不包含该键的映射关系，则返回 null。

如果此映射允许 null 值，则返回 null 值并不一定 表示该映射不包含该键的映射关系；也可能该映射将该键显示地映射到 null。

调用返回后，此映射将不再包含指定键的映射关系。

参数：
key - 从映射中移除其映射关系的键
返回：
以前与 key 关联的值；如果没有 key 的映射关系，则返回 null。
抛出：
UnsupportedOperationException - 如果此映射不支持 remove 操作
ClassCastException - 如果该键对于此映射是不合适的类型（可选）
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键（可选）

putAll

void putAll(Map<? extends K,? extends V> m)
从指定映射中将所有映射关系复制到此映射中（可选操作）。对于指定映射中的每个键 k 到值 v 的映射关系，此调用等效于对此映射调用一次 put(k, v)。如果正在进行此操作的同时修改了指定的映射，则此操作的行为是不确定的。

参数：
m - 要存储在此映射中的映射关系
抛出：
UnsupportedOperationException - 如果此映射不支持 putAll 操作
ClassCastException - 如果指定映射中的键或值的类不允许将其存储在此映射中
NullPointerException - 如果指定映射为 null，或者此映射不允许 null 键或值，并且指定的映射包含 null 键或值
IllegalArgumentException - 如果指定映射中的键或值的某些属性不允许将其存储在此映射中

clear

void clear()
从此映射中移除所有映射关系（可选操作）。此调用返回后，该映射将为空。

抛出：
UnsupportedOperationException - 如果此映射不支持 clear 操作

keySet

Set<K> keySet()
返回此映射中包含的键的 Set 视图。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

返回：
此映射中包含的键的 set 视图

values

Collection<V> values()
返回此映射中包含的值的 Collection 视图。该 collection 受映射支持，所以对映射的更改可在此 collection 中反映出来，反之亦然。如果对该 collection 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。collection 支持元素移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

返回：
此映射中包含的值的 collection 视图

entrySet

Set<Map.Entry<K,V>> entrySet()
返回此映射中包含的映射关系的 Set 视图。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作，或者通过对迭代器返回的映射项执行 setValue 操作除外），则迭代结果是不确定的。set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

返回：
此映射中包含的映射关系的 set 视图

equals

boolean equals(Object o)
比较指定的对象与此映射是否相等。如果给定的对象也是一个映射，并且这两个映射表示相同的映射关系，则返回 true。更确切地讲，如果 m1.entrySet().equals(m2.entrySet())，则两个映射 m1 和 m2 表示相同的映射关系。这可以确保 equals 方法在不同的 Map 接口实现间运行正常。

覆盖：
类 Object 中的 equals
参数：
o - 要与此映射进行相等性比较的对象
返回：
如果指定的对象等于此映射，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此映射的哈希码值。映射的哈希码定义为此映射 entrySet() 视图中每个项的哈希码之和。这确保 m1.equals(m2) 对于任意两个映射 m1 和 m2 而言，都意味着 m1.hashCode()==m2.hashCode()，正如 Object.hashCode() 常规协定的要求。

覆盖：
类 Object 中的 hashCode
返回：
此映射的哈希码值
另请参见：
Map.Entry.hashCode(),
Object.equals(Object),
equals(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Map.Entry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Map.Entry<K,V>

所有已知实现类：
AbstractMap.SimpleEntry, AbstractMap.SimpleImmutableEntry
正在封闭接口：
Map<K,V>
public static interface Map.Entry<K,V>

映射项（键-值对）。Map.entrySet 方法返回映射的 collection 视图，其中的元素属于此类。获得映射项引用的唯一 方法是通过此 collection 视图的迭代器来实现。这些 Map.Entry 对象仅 在迭代期间有效；更确切地讲，如果在迭代器返回项之后修改了底层映射，则某些映射项的行为是不确定的，除了通过 setValue 在映射项上执行操作之外。

从以下版本开始：
1.2
另请参见：
Map.entrySet()

方法摘要
boolean | equals(Object o) 比较指定对象与此项的相等性。
K | getKey() 返回与此项对应的键。
V | getValue() 返回与此项对应的值。
int | hashCode() 返回此映射项的哈希码值。
V | setValue(V value) 用指定的值替换与此项对应的值（可选操作）。

方法详细信息

getKey

K getKey()
返回与此项对应的键。

返回：
与此项对应的键
抛出：
IllegalStateException - 如果已经从底层映射中移除了该项，则实现可能（但不要求）抛出此异常。

getValue

V getValue()
返回与此项对应的值。如果已经从底层映射中移除了映射关系（通过迭代器的 remove 操作），则此调用的结果是不确定的。

返回：
与此项对应的值
抛出：
IllegalStateException - 如果已经从底层映射中移除了该项，则实现可能，但不要求，抛出此异常。

setValue

V setValue(V value)
用指定的值替换与此项对应的值（可选操作）。（写入该映射。）如果已经从映射中移除了映射关系（通过迭代器的 remove 操作），则此调用的行为是不确定的。

参数：
value - 要存储在此项中的新值
返回：
与此项对应的旧值
抛出：
UnsupportedOperationException - 如果底层映射不支持 put 操作
ClassCastException - 如果指定值的类不允许将该值存储在底层映射中
NullPointerException - 如果底层映射不允许 null 值，并且指定的值为 null
IllegalArgumentException - 如果此值的某些方面不允许将其存储在底层映射中
IllegalStateException - 如果已经从底层映射中移除了该项，则实现可能，但不要求，抛出此异常

equals

boolean equals(Object o)
比较指定对象与此项的相等性。如果给定对象也是一个映射项，并且两个项表示相同的映射关系，则返回 true。更确切地讲，如果满足以下条件，则两个项 e1 和 e2 才表示相同的映射关系
     (e1.getKey()==null ?
      e2.getKey()==null : e1.getKey().equals(e2.getKey()))  &&
     (e1.getValue()==null ?
      e2.getValue()==null : e1.getValue().equals(e2.getValue()))
这可以确保 equals 方法在不同的 Map.Entry 接口实现间可正确地工作。

覆盖：
类 Object 中的 equals
参数：
o - 要与此映射项进行相等性比较的对象
返回：
如果指定的对象等于此映射项，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此映射项的哈希码值。映射项 e 的哈希码定义如下：
     (e.getKey()==null   ? 0 : e.getKey().hashCode()) ^
     (e.getValue()==null ? 0 : e.getValue().hashCode())
这确保 e1.equals(e2) 意味着对于任意两个项 e1 和 e2 而言，e1.hashCode()==e2.hashCode()，这正是 Object.hashCode 的常规协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
映射项的哈希码值
另请参见：
Object.hashCode(),
Object.equals(Object),
equals(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MissingFormatArgumentException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 MissingFormatArgumentException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.MissingFormatArgumentException
所有已实现的接口：
Serializable
public class MissingFormatArgumentException
extends IllegalFormatException

如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MissingFormatArgumentException(String s)
构造带有不匹配的格式说明符的此类的一个实例。
方法摘要
String | getFormatSpecifier() 返回不匹配的格式说明符。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MissingFormatArgumentException

public MissingFormatArgumentException(String s)
构造带有不匹配的格式说明符的此类的一个实例。

参数：
s - 没有相应参数的格式说明符。
方法详细信息

getFormatSpecifier

public String getFormatSpecifier()
返回不匹配的格式说明符。

返回：
不匹配的格式说明符。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MissingFormatWidthException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 MissingFormatWidthException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.MissingFormatWidthException
所有已实现的接口：
Serializable
public class MissingFormatWidthException
extends IllegalFormatException

请求格式宽度时抛出未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MissingFormatWidthException(String s)
构造带有指定格式说明符的此类的一个实例。
方法摘要
String | getFormatSpecifier() 返回没有宽度的格式说明符。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MissingFormatWidthException

public MissingFormatWidthException(String s)
构造带有指定格式说明符的此类的一个实例。

参数：
s - 没有宽度的格式说明符。
方法详细信息

getFormatSpecifier

public String getFormatSpecifier()
返回没有宽度的格式说明符。

返回：
没有宽度的格式说明符。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MissingResourceException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 MissingResourceException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.util.MissingResourceException
所有已实现的接口：
Serializable
public class MissingResourceException
extends RuntimeException

缺少资源时抛出此异常。

从以下版本开始：
JDK1.1
另请参见：
Exception, ResourceBundle, 序列化表格

构造方法摘要
MissingResourceException(String s, String className, String key)
构造带有指定信息的 MissingResourceException。
方法摘要
String | getClassName() 获得构造方法所传递的参数。
String | getKey() 获得构造方法所传递的参数。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MissingResourceException

public MissingResourceException(String s,
                                String className,
                                String key)
构造带有指定信息的 MissingResourceException。详细消息是描述这个特定异常的字符串。

参数：
s - 详细消息。
className - 资源类的名称。
key - 所缺少资源的键。
方法详细信息

getClassName

public String getClassName()
获得构造方法所传递的参数。

返回：
资源类的名称。

getKey

public String getKey()
获得构造方法所传递的参数。

返回：
所缺少资源的键。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NavigableMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 NavigableMap<K,V>

类型参数：
K - 此映射维护的键的类型
V - 被映射的值的类型
所有超级接口：
Map<K,V>, SortedMap<K,V>
所有已知子接口：
ConcurrentNavigableMap<K,V>
所有已知实现类：
ConcurrentSkipListMap, TreeMap
public interface NavigableMap<K,V>
extends SortedMap<K,V>

扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。方法 lowerEntry、floorEntry、ceilingEntry 和 higherEntry 分别返回与小于、小于等于、大于等于、大于给定键的键关联的 Map.Entry 对象，如果不存在这样的键，则返回 null。类似地，方法 lowerKey、floorKey、ceilingKey 和 higherKey 只返回关联的键。所有这些方法是为查找条目而不是遍历条目而设计的。

可以按照键的升序或降序访问和遍历 NavigableMap。descendingMap 方法返回映射的一个视图，该视图表示的所有关系方法和方向方法都是逆向的。升序操作和视图的性能很可能比降序操作和视图的性能要好。subMap、headMap 和 tailMap 方法与名称相似的 SortedMap 方法的不同之处在于：可以接受用于描述是否包括（或不包括）下边界和上边界的附加参数。任何 NavigableMap 的 Submap 必须实现 NavigableMap 接口。

此外，此接口还定义了 firstEntry、pollFirstEntry、lastEntry 和 pollLastEntry 方法，它们返回和/或移除最小和最大的映射关系（如果存在），否则返回 null。

条目返回方法的实现应当返回 Map.Entry 对，表示产生映射关系时它们的快照，因此通常不 支持可选的 Entry.setValue 方法。不过要注意的是，可以使用 put 方法在关联映射中更改映射关系。

subMap(K, K)、headMap(K) 和 tailMap(K) 方法被指定为返回 SortedMap，以允许现有 SortedMap 实现能相容地改进为实现 NavigableMap，但鼓励此接口的扩展和实现重写这些方法以返回 NavigableMap。类似地，可以重写 SortedMap.keySet() 以返回 NavigableSet。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.6

嵌套类摘要
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
方法摘要
Map.Entry<K,V> | ceilingEntry(K key) 返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。
K | ceilingKey(K key) 返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。
NavigableSet<K> | descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
NavigableMap<K,V> | descendingMap() 返回此映射中所包含映射关系的逆序视图。
Map.Entry<K,V> | firstEntry() 返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | floorEntry(K key) 返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。
K | floorKey(K key) 返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。
SortedMap<K,V> | headMap(K toKey) 返回此映射的部分视图，其键值严格小于 toKey。
NavigableMap<K,V> | headMap(K toKey, boolean inclusive) 返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
Map.Entry<K,V> | higherEntry(K key) 返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。
K | higherKey(K key) 返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | lastEntry() 返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | lowerEntry(K key) 返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。
K | lowerKey(K key) 返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。
NavigableSet<K> | navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
Map.Entry<K,V> | pollFirstEntry() 移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | pollLastEntry() 移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
NavigableMap<K,V> | subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive) 返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
SortedMap<K,V> | subMap(K fromKey, K toKey) 返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
SortedMap<K,V> | tailMap(K fromKey) 返回此映射的部分视图，其键大于等于 fromKey。
NavigableMap<K,V> | tailMap(K fromKey, boolean inclusive) 返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。
从接口 java.util.SortedMap 继承的方法
comparator, entrySet, firstKey, keySet, lastKey, values
从接口 java.util.Map 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, put, putAll, remove, size

方法详细信息

lowerEntry

Map.Entry<K,V> lowerEntry(K key)
返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
最大键小于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

lowerKey

K lowerKey(K key)
返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
小于 key 的最大键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

floorEntry

Map.Entry<K,V> floorEntry(K key)
返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
最大键小于等于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

floorKey

K floorKey(K key)
返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
小于等于 key 的最大键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

ceilingEntry

Map.Entry<K,V> ceilingEntry(K key)
返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
最小键大于等于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

ceilingKey

K ceilingKey(K key)
返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
大于等于 key 的最小键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

higherEntry

Map.Entry<K,V> higherEntry(K key)
返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
最小键大于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

higherKey

K higherKey(K key)
返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。

参数：
key - 键
返回：
大于 key 的最小键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射不允许 null 键

firstEntry

Map.Entry<K,V> firstEntry()
返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。

返回：
带有最小键的条目；如果此映射为空，则返回 null

lastEntry

Map.Entry<K,V> lastEntry()
返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。

返回：
带有最大键的条目；如果此映射为空，则返回 null

pollFirstEntry

Map.Entry<K,V> pollFirstEntry()
移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。

返回：
此映射中被移除的第一个条目；如果此映射为空，则返回 null

pollLastEntry

Map.Entry<K,V> pollLastEntry()
移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。

返回：
此映射中被移除的最后一个条目；如果此映射为空，则返回 null

descendingMap

NavigableMap<K,V> descendingMap()
返回此映射中所包含映射关系的逆序视图。降序映射受此映射的支持，因此对映射的更改将反映在降序映射中，反之亦然。如果在对任一映射的 collection 视图进行迭代的同时修改了任一映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。

返回映射的顺序等于 Collections.reverseOrder(comparator())。表达式 m.descendingMap().descendingMap() 返回的 m 视图基本等于 m。

返回：
此映射的逆序视图

navigableKeySet

NavigableSet<K> navigableKeySet()
返回此映射中所包含键的 NavigableSet 视图。set 的迭代器按升序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。如果正在对 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

返回：
此映射中键的可导航 set 视图

descendingKeySet

NavigableSet<K> descendingKeySet()
返回此映射中所包含键的逆序 NavigableSet 视图。set 的迭代器按降序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。如果正在对 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

返回：
此映射中键的逆序可导航 set 视图

subMap

NavigableMap<K,V> subMap(K fromKey,
                         boolean fromInclusive,
                         K toKey,
                         boolean toInclusive)
返回此映射的部分视图，其键的范围从 fromKey 到 toKey。如果 fromKey 和 toKey 相等，则返回的映射为空，除非 fromExclusive 和 toExclusive 都为 true。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，或者构造一个任一端点位于其范围之外的子映射，则返回的映射将抛出 IllegalArgumentException。

参数：
fromKey - 返回映射中键的低端点
fromInclusive - 如果低端点要包含在返回的视图中，则为 true
toKey - 返回映射中键的高端点
toInclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键范围从 fromKey 到 toKey
抛出：
ClassCastException - 如果不能使用此映射的比较器（如果映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null 并且此映射不允许 null 键
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

NavigableMap<K,V> headMap(K toKey,
                          boolean inclusive)
返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

参数：
toKey - 返回映射中键的高端点
inclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null 并且此映射不允许 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

NavigableMap<K,V> tailMap(K fromKey,
                          boolean inclusive)
返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

参数：
fromKey - 返回映射中键的低端点
inclusive - 如果低端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null 并且此映射不允许 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外

subMap

SortedMap<K,V> subMap(K fromKey,
                      K toKey)
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。（如果 fromKey 和 toKey 相等，则返回映射为空。）返回的映射受此映射支持，所以在返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 subMap(fromKey, true, toKey, false)。

指定者：
接口 SortedMap<K,V> 中的 subMap
参数：
fromKey - 返回映射中键的低端点（包括）
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）
抛出：
ClassCastException - 如果无法使用此映射的比较器（如果此映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

SortedMap<K,V> headMap(K toKey)
返回此映射的部分视图，其键值严格小于 toKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 headMap(toKey, false)。

指定者：
接口 SortedMap<K,V> 中的 headMap
参数：
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，该映射的键严格小于 toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

SortedMap<K,V> tailMap(K fromKey)
返回此映射的部分视图，其键大于等于 fromKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 tailMap(fromKey, true)。

指定者：
接口 SortedMap<K,V> 中的 tailMap
参数：
fromKey - 返回映射中键的低端点（包括）
返回：
此映射的部分视图，其键大于等于 fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NavigableSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 NavigableSet<E>

类型参数：
E - 此 set 维护的元素类型
所有超级接口：
Collection<E>, Iterable<E>, Set<E>, SortedSet<E>
所有已知实现类：
ConcurrentSkipListSet, TreeSet
public interface NavigableSet<E>
extends SortedSet<E>

扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。方法 lower、floor、ceiling 和 higher 分别返回小于、小于等于、大于等于、大于给定元素的元素，如果不存在这样的元素，则返回 null。可以按升序或降序访问和遍历 NavigableSet。descendingSet 方法返回 set 的一个视图，该视图表示的所有关系方法和方向方法都是逆向的。升序操作和视图的性能很可能比降序操作和视图的性能要好。此外，此接口还定义了 pollFirst 和 pollLast 方法，它们返回并移除最小和最大的元素（如果存在），否则返回 null。subSet、headSet 和 tailSet 方法与名称相似的 SortedSet 方法的不同之处在于：可以接受用于描述是否包括（或不包括）下边界和上边界的附加参数。任何 NavigableSet 的 Submap 必须实现 NavigableSet 接口。

导航方法的返回值在允许 null 元素的实现中可能是不确定的。不过，即使在这种情况下，也可以通过检查 contains(null) 来明确结果。为了避免这样的问题，建议在此接口的实现中不 允许插入 null 元素。（注意，Comparable 元素的有序集本身不允许 null。）

subSet(E, E)、headSet(E) 和 tailSet(E) 方法被指定为返回 SortedSet，以允许现有 SortedSet 实现能相容地改进为实现 NavigableMap，但鼓励此接口的扩展和实现重写这些方法以返回 NavigableSet。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.6

方法摘要
E | ceiling(E e) 返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。
Iterator<E> | descendingIterator() 以降序返回在此 set 的元素上进行迭代的迭代器。
NavigableSet<E> | descendingSet() 返回此 set 中所包含元素的逆序视图。
E | floor(E e) 返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。
SortedSet<E> | headSet(E toElement) 返回此 set 的部分视图，其元素严格小于 toElement。
NavigableSet<E> | headSet(E toElement, boolean inclusive) 返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。
E | higher(E e) 返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。
Iterator<E> | iterator() 以升序返回在此 set 的元素上进行迭代的迭代器。
E | lower(E e) 返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。
E | pollFirst() 获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。
E | pollLast() 获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。
NavigableSet<E> | subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive) 返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。
SortedSet<E> | subSet(E fromElement, E toElement) 返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
SortedSet<E> | tailSet(E fromElement) 返回此 set 的部分视图，其元素大于等于 fromElement。
NavigableSet<E> | tailSet(E fromElement, boolean inclusive) 返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。
从接口 java.util.SortedSet 继承的方法
comparator, first, last
从接口 java.util.Set 继承的方法
add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, remove, removeAll, retainAll, size, toArray, toArray

方法详细信息

lower

E lower(E e)
返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。

参数：
e - 要匹配的值
返回：
小于 e 的最大元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null 并且此 set 不允许 null 元素

floor

E floor(E e)
返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。

参数：
e - 要匹配的值
返回：
小于等于 e 的最大元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null 并且此 set 不允许 null 元素

ceiling

E ceiling(E e)
返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。

参数：
e - 要匹配的值
返回：
大于等于 e 的最小元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null 并且此 set 不允许 null 元素

higher

E higher(E e)
返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。

参数：
e - 要匹配的值
返回：
大于 e 的最小元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null 并且此 set 不允许 null 元素

pollFirst

E pollFirst()
获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。

返回：
第一个元素；如果此 set 为空，则返回 null

pollLast

E pollLast()
获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。

返回：
最后一个元素；如果此 set 为空，则返回 null

iterator

Iterator<E> iterator()
以升序返回在此 set 的元素上进行迭代的迭代器。

指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Set<E> 中的 iterator
返回：
以升序返回在此 set 的元素上进行迭代的迭代器

descendingSet

NavigableSet<E> descendingSet()
返回此 set 中所包含元素的逆序视图。降序 set 受此 set 的支持，因此对此 set 的更改将反映在降序 set 中，反之亦然。如果在对任一 set 进行迭代的同时修改了任一 set（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。

返回 set 的顺序等于 Collections.reverseOrder(comparator())。表达式 s.descendingSet().descendingSet() 返回的 s 视图基本等于 s。

返回：
此 set 的逆序视图

descendingIterator

Iterator<E> descendingIterator()
以降序返回在此 set 的元素上进行迭代的迭代器。效果等同于 descendingSet().iterator()。

返回：
在此 set 的元素上以降序进行迭代的迭代器

subSet

NavigableSet<E> subSet(E fromElement,
                       boolean fromInclusive,
                       E toElement,
                       boolean toInclusive)
返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。如果 fromElement 和 toElement 相等，则返回的 set 为空，除非 fromExclusive 和 toExclusive 都为 true。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

参数：
fromElement - 返回 set 的低端点
fromInclusive - 如果低端点要包含在返回的视图中，则为 true
toElement - 返回 set 的高端点
toInclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素范围从 fromElement（包括）到 toElement（不包括）
抛出：
ClassCastException - 如果不能使用此 set 的比较器或者使用自然顺序（如果 set 没有比较器）比较 fromElement 和 toElement。如果 fromElement 或 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 或 toElement 为 null 并且此 set 不允许 null 元素
IllegalArgumentException - 如果 fromElement 大于 toElement；如果此 set 本身有范围限制，并且 fromElement 或 toElement 位于范围的边界之外。

headSet

NavigableSet<E> headSet(E toElement,
                        boolean inclusive)
返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

参数：
toElement - 返回 set 的高端点
inclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement
抛出：
ClassCastException - 如果 toElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 toElement 没有实现 Comparable）。如果 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toElement 为 null 并且此 set 不允许 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 toElement 位于范围的边界之外

tailSet

NavigableSet<E> tailSet(E fromElement,
                        boolean inclusive)
返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

参数：
fromElement - 返回 set 的低端点
inclusive - 如果低端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素大于等于 fromElement
抛出：
ClassCastException - 如果 fromElement 与此 set 的比较器不兼容（如果 set 没有任何比较器；如果 fromElement 没有实现 Comparable）。如果 fromElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 为 null 并且此 set 不允许 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 fromElement 位于范围的边界之外

subSet

SortedSet<E> subSet(E fromElement,
                    E toElement)
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。（如果 fromElement 和 toElement 相等，则返回空的 set）。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 subSet(fromElement, true, toElement, false)。

指定者：
接口 SortedSet<E> 中的 subSet
参数：
fromElement - 返回 set 的低端点（包括）
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素的范围从 fromElement（包括）到 toElement（不包括）
抛出：
ClassCastException - 如果无法使用此 set 的比较器（如果 set 没有比较器，则使用自然顺序）比较 fromElement 和 toElement。如果 fromElement 或 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 或 toElement 为 null，并且此 set 不允许 null 元素
IllegalArgumentException - 如果 fromElement 大于 toElement；如果此 set 本身有范围限制，并且 fromElement 或 toElement 位于范围的边界之外

headSet

SortedSet<E> headSet(E toElement)
返回此 set 的部分视图，其元素严格小于 toElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 headSet(toElement, false)。

指定者：
接口 SortedSet<E> 中的 headSet
参数：
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素严格小于 toElement
抛出：
ClassCastException - 如果 toElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 toElement 没有实现 Comparable）。如果 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toElement 为 null，并且此 set 不允许 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 toElement 位于范围的边界之外

tailSet

SortedSet<E> tailSet(E fromElement)
返回此 set 的部分视图，其元素大于等于 fromElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 tailSet(fromElement, true)。

指定者：
接口 SortedSet<E> 中的 tailSet
参数：
fromElement - 返回 set 的低端点（包括）
返回：
此 set 的部分视图，其元素大于等于 fromElement
抛出：
ClassCastException - 如果 fromElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 fromElement 没有实现 Comparable）。如果 fromElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 为 null，并且此 set 不允许 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 fromElement 位于范围的边界之外
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchElementException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 NoSuchElementException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.util.NoSuchElementException
所有已实现的接口：
Serializable
直接已知子类：
InputMismatchException
public class NoSuchElementException
extends RuntimeException

由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。

从以下版本开始：
JDK1.0
另请参见：
Enumeration, Enumeration.nextElement(), 序列化表格

构造方法摘要
NoSuchElementException()
构造一个 NoSuchElementException，用 null 作为其错误消息字符串。
NoSuchElementException(String s)
构造一个 NoSuchElementException，保存对错误消息字符串 s 的引用，以便将来通过 getMessage 方法进行获取。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchElementException

public NoSuchElementException()
构造一个 NoSuchElementException，用 null 作为其错误消息字符串。

NoSuchElementException

public NoSuchElementException(String s)
构造一个 NoSuchElementException，保存对错误消息字符串 s 的引用，以便将来通过 getMessage 方法进行获取。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Observable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Observable

java.lang.Object
    继承者  java.util.Observable

public class Observable
extends Object

此类表示模型视图范例中的 observable 对象，或者说“数据”。可将其子类化，表示应用程序想要观察的对象。

一个 observable 对象可以有一个或多个观察者。观察者可以是实现了 Observer 接口的任意对象。一个 observable 实例改变后，调用 Observable 的 notifyObservers 方法的应用程序会通过调用观察者的 update 方法来通知观察者该实例发生了改变。

未指定发送通知的顺序。Observable 类中所提供的默认实现将按照其注册的重要性顺序来通知 Observers，但是子类可能改变此顺序，从而使用非固定顺序在单独的线程上发送通知，或者也可能保证其子类遵从其所选择的顺序。

注意，此通知机制与线程无关，并且与 Object 类的 wait 和 notify 机制完全独立。

新创建一个 observable 对象时，其观察者集是空的。当且仅当 equals 方法为两个观察者返回 true 时，才认为它们是相同的。

从以下版本开始：
JDK1.0
另请参见：
notifyObservers(), notifyObservers(java.lang.Object), Observer, Observer.update(java.util.Observable, java.lang.Object)

构造方法摘要
Observable()
构造一个带有零个观察者的 Observable。
方法摘要
void | addObserver(Observer o) 如果观察者与集合中已有的观察者不同，则向对象的观察者集中添加此观察者。
protected void | clearChanged() 指示对象不再改变，或者它已对其所有的观察者通知了最近的改变，所以 hasChanged 方法将返回 false。
int | countObservers() 返回 Observable 对象的观察者数目。
void | deleteObserver(Observer o) 从对象的观察者集合中删除某个观察者。
void | deleteObservers() 清除观察者列表，使此对象不再有任何观察者。
boolean | hasChanged() 测试对象是否改变。
void | notifyObservers() 如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。
void | notifyObservers(Object arg) 如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。
protected void | setChanged() 标记此 Observable 对象为已改变的对象；现在 hasChanged 方法将返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Observable

public Observable()
构造一个带有零个观察者的 Observable。

方法详细信息

addObserver

public void addObserver(Observer o)
如果观察者与集合中已有的观察者不同，则向对象的观察者集中添加此观察者。未指定向多个观察者发送通知的顺序。请参阅该类的注释。

参数：
o - 要添加的观察者。
抛出：
NullPointerException - 如果参数 o 为 null。

deleteObserver

public void deleteObserver(Observer o)
从对象的观察者集合中删除某个观察者。向此方法传递 null 将使其无效。

参数：
o - 要删除的观察者。

notifyObservers

public void notifyObservers()
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。

每个观察者都有其 update 方法，其调用参数有两个：observable 对象和 null。换句话说，此方法等效于：

notifyObservers(null)

另请参见：
clearChanged(),
hasChanged(),
Observer.update(java.util.Observable, java.lang.Object)

notifyObservers

public void notifyObservers(Object arg)
如果 hasChanged 方法指示对象已改变，则通知其所有观察者，并调用 clearChanged 方法来指示此对象不再改变。

每个观察者都有其 update 方法，其调用参数有两个：observable 对象和 arg 参数。

参数：
arg - 任意对象。
另请参见：
clearChanged(),
hasChanged(),
Observer.update(java.util.Observable, java.lang.Object)

deleteObservers

public void deleteObservers()
清除观察者列表，使此对象不再有任何观察者。

setChanged

protected void setChanged()
标记此 Observable 对象为已改变的对象；现在 hasChanged 方法将返回 true。

clearChanged

protected void clearChanged()
指示对象不再改变，或者它已对其所有的观察者通知了最近的改变，所以 hasChanged 方法将返回 false。notifyObservers 方法自动调用此方法。

另请参见：
notifyObservers(), notifyObservers(java.lang.Object)

hasChanged

public boolean hasChanged()
测试对象是否改变。

返回：
当且仅当在此对象上最近调用了 setChanged 方法，而不是 clearChanged 方法时，才返回 true；否则返回 false。
另请参见：
clearChanged(), setChanged()

countObservers

public int countObservers()
返回 Observable 对象的观察者数目。

返回：
对象的观察者数目。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Observer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Observer

public interface Observer

一个可在观察者要得到 observable 对象更改通知时可实现 Observer 接口的类。

从以下版本开始：
JDK1.0
另请参见：
Observable

方法摘要
 void update(Observable o, Object arg)
只要改变了 observable 对象就调用此方法。

方法详细信息

update

void update(Observable o,
            Object arg)
只要改变了 observable 对象就调用此方法。应用程序调用 Observable 对象的 notifyObservers 方法，以便向所有该对象的观察者通知此改变。

参数：
o - observable 对象。
arg - 传递给 notifyObservers 方法的参数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PriorityQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 PriorityQueue<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.PriorityQueue<E>
类型参数：
E - collection 中所保存元素的类型。
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, Queue<E>
public class PriorityQueue<E>
extends AbstractQueue<E>
implements Serializable

一个基于优先级堆的无界优先级队列。优先级队列的元素按照其自然顺序进行排序，或者根据构造队列时提供的 Comparator 进行排序，具体取决于所使用的构造方法。优先级队列不允许使用 null 元素。依靠自然顺序的优先级队列还不允许插入不可比较的对象（这样做可能导致 ClassCastException）。

此队列的头 是按指定排序方式确定的最小 元素。如果多个元素都是最小值，则头是其中一个元素——选择方法是任意的。队列获取操作 poll、remove、peek 和 element 访问处于队列头的元素。

优先级队列是无界的，但是有一个内部容量，控制着用于存储队列元素的数组大小。它通常至少等于队列的大小。随着不断向优先级队列添加元素，其容量会自动增加。无需指定容量增加策略的细节。

此类及其迭代器实现了 Collection 和 Iterator 接口的所有可选 方法。方法 iterator() 中提供的迭代器不 保证以任何特定的顺序遍历优先级队列中的元素。如果需要按顺序遍历，请考虑使用 Arrays.sort(pq.toArray())。

注意，此实现不是同步的。如果多个线程中的任意线程修改了队列，则这些线程不应同时访问 PriorityQueue 实例。相反，请使用线程安全的 PriorityBlockingQueue 类。

实现注意事项：此实现为排队和出队方法（offer、poll、remove() 和 add）提供 O(log(n)) 时间；为 remove(Object) 和 contains(Object) 方法提供线性时间；为获取方法（peek、element 和 size）提供固定时间。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
PriorityQueue()
使用默认的初始容量（11）创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。
PriorityQueue(Collection<? extends E> c)
创建包含指定 collection 中元素的 PriorityQueue。
PriorityQueue(int initialCapacity)
使用指定的初始容量创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。
PriorityQueue(int initialCapacity, Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityQueue，并根据指定的比较器对元素进行排序。
PriorityQueue(PriorityQueue<? extends E> c)
创建包含指定优先级队列元素的 PriorityQueue。
PriorityQueue(SortedSet<? extends E> c)
创建包含指定有序 set 元素的 PriorityQueue。
方法摘要
 boolean add(E e)
将指定的元素插入此优先级队列。
 void clear()
从此优先级队列中移除所有元素。
 Comparator<? super E> comparator()
返回用来对此队列中的元素进行排序的比较器；如果此队列根据其元素的自然顺序进行排序，则返回 null。
 boolean contains(Object o)
如果此队列包含指定的元素，则返回 true。
 Iterator<E> iterator()
返回在此队列中的元素上进行迭代的迭代器。
 boolean offer(E e)
将指定的元素插入此优先级队列。
 E peek()
获取但不移除此队列的头；如果此队列为空，则返回 null。
 E poll()
获取并移除此队列的头，如果此队列为空，则返回 null。
 boolean remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。
 int size()
返回此 collection 中的元素数。
 Object[] toArray()
返回一个包含此队列所有元素的数组。
<T> T[]
toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
从类 java.util.AbstractQueue 继承的方法
addAll, element, remove
从类 java.util.AbstractCollection 继承的方法
containsAll, isEmpty, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Collection 继承的方法
containsAll, equals, hashCode, isEmpty, removeAll, retainAll

构造方法详细信息

PriorityQueue

public PriorityQueue()
使用默认的初始容量（11）创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。

PriorityQueue

public PriorityQueue(int initialCapacity)
使用指定的初始容量创建一个 PriorityQueue，并根据其自然顺序对元素进行排序。

参数：
initialCapacity - 此优先级队列的初始容量
抛出：
IllegalArgumentException - 如果 initialCapacity 小于 1

PriorityQueue

public PriorityQueue(int initialCapacity,
                     Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityQueue，并根据指定的比较器对元素进行排序。

参数：
initialCapacity - 此优先级队列的初始容量
comparator - 用于对此优先级队列进行排序的比较器。如果该参数为 null，则将使用元素的自然顺序
抛出：
IllegalArgumentException - 如果 initialCapacity 小于 1

PriorityQueue

public PriorityQueue(Collection<? extends E> c)
创建包含指定 collection 中元素的 PriorityQueue。如果指定的 collection 是 SortedSet 的一个实例或者是另一个 PriorityQueue，那么此优先级队列将根据相同顺序进行排序。否则，此优先级队列将根据元素的自然顺序进行排序。

参数：
c - collection，其元素要置于此优先级队列中
抛出：
ClassCastException - 如果根据优先级队列的排序规则无法比较指定 collection 中的各个元素
NullPointerException - 如果指定 collection 或任何元素为 null

PriorityQueue

public PriorityQueue(PriorityQueue<? extends E> c)
创建包含指定优先级队列元素的 PriorityQueue。此优先级队列将根据与给定优先级队列相同的顺序进行排序。

参数：
c - 优先级队列，其元素要置于此优先级队列中
抛出：
ClassCastException - 如果根据 c 的顺序无法比较 c 中的各个元素
NullPointerException - 如果指定优先级队列或任何元素为 null

PriorityQueue

public PriorityQueue(SortedSet<? extends E> c)
创建包含指定有序 set 元素的 PriorityQueue。此优先级队列将根据与给定有序 set 相同的顺序进行排序。

参数：
c - 有序 set，其元素将置于此优先级队列中
抛出：
ClassCastException - 如果根据有序 set 的顺序无法比较该有序 set 中的各个元素
NullPointerException - 如果指定有序 set 或任何元素为 null
方法详细信息

add

public boolean add(E e)
将指定的元素插入此优先级队列。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractQueue<E> 中的 add
参数：
e - 要添加的元素
返回：
true（正如 Collection.add(E) 所指定的那样）
抛出：
ClassCastException - 如果根据优先级队列的顺序无法将指定元素与此优先级队列中当前元素进行比较
NullPointerException - 如果指定的元素为 null

offer

public boolean offer(E e)
将指定的元素插入此优先级队列。

指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
true（正如 Queue.offer(E) 所指定的那样）
抛出：
ClassCastException - 如果根据优先级队列的顺序无法将指定元素与此优先级队列中当前元素进行比较
NullPointerException - 如果指定元素为 null

peek

public E peek()
从接口 Queue 复制的描述
获取但不移除此队列的头；如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 peek
返回：
此队列的头；如果此队列为空，则返回 null

remove

public boolean remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。更确切地讲，如果此队列包含一个或多个满足 o.equals(e) 的元素 e，则移除一个这样的元素。当且仅当此队列包含指定的元素（或者此队列由于调用而发生更改），则返回 true。

指定者：
接口 Collection<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此队列中移除的元素（如果存在）
返回：
如果此队列由于调用而发生更改，则返回 true

contains

public boolean contains(Object o)
如果此队列包含指定的元素，则返回 true。更确切地讲，当且仅当此队列至少包含一个满足 o.equals(e) 的元素 e 时，才返回 true。

指定者：
接口 Collection<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 要检查是否包含于此队列的对象
返回：
如果此队列包含指定元素，则返回 true

toArray

public Object[] toArray()
返回一个包含此队列所有元素的数组。数组元素没有特定的顺序。

由于此队列并不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此队列所有元素的数组

toArray

public <T> T[] toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。返回数组的元素没有特定的顺序。如果指定的数组能容纳队列，则将该队列返回此处。否则，将根据指定数组的运行时类型和此队列的大小分配一个新数组。

如果指定数组能容纳队列，且有剩余空间（即数组比队列元素多），则紧跟在 collection 末尾的数组元素将被设置为 null。

像 toArray() 方法一样，此方法充当基于数组 的 API 与基于 collection 的 API 之间的桥梁。进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知队列。以下代码可以用来将该队列转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 存储此队列元素的数组（如果该数组足够大）；否则，将为此分配一个具有相同运行时类型的新数组。
返回：
包含此队列所有元素的数组
抛出：
如果指定数组的运行时类型不是此队列每个元素的运行时类型的子类型
NullPointerException - 如果指定数组为 null

iterator

public Iterator<E> iterator()
返回在此队列中的元素上进行迭代的迭代器。迭代器并不以任意特定的顺序返回元素。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此队列的元素上进行迭代的迭代器

size

public int size()
从接口 Collection 复制的描述
返回此 collection 中的元素数。如果此 collection 包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

指定者：
接口 Collection<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此 collection 中的元素数

clear

public void clear()
从此优先级队列中移除所有元素。此调用返回后队列为空。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractQueue<E> 中的 clear

poll

public E poll()
从接口 Queue 复制的描述
获取并移除此队列的头，如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 poll
返回：
队列的头，如果此队列为空，则返回 null

comparator

public Comparator<? super E> comparator()
返回用来对此队列中的元素进行排序的比较器；如果此队列根据其元素的自然顺序进行排序，则返回 null。

返回：
用于对此队列进行排序的比较器；如果此队列根据其元素的自然顺序进行排序，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Properties (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Properties

java.lang.Object
    继承者  java.util.Dictionary<K,V>
        继承者  java.util.Hashtable<Object,Object>
            继承者  java.util.Properties
所有已实现的接口：
Serializable, Cloneable, Map<Object,Object>
直接已知子类：
Provider
public class Properties
extends Hashtable<Object,Object>

Properties 类表示了一个持久的属性集。Properties 可保存在流中或从流中加载。属性列表中每个键及其对应值都是一个字符串。

一个属性列表可包含另一个属性列表作为它的“默认值”；如果未能在原有的属性列表中搜索到属性键，则搜索第二个属性列表。

因为 Properties 继承于 Hashtable，所以可对 Properties 对象应用 put 和 putAll 方法。但不建议使用这两个方法，因为它们允许调用者插入其键或值不是 String 的项。相反，应该使用 setProperty 方法。如果在“不安全”的 Properties 对象（即包含非 String 的键或值）上调用 store 或 save 方法，则该调用将失败。类似地，如果在“不安全”的 Properties 对象（即包含非 String 的键）上调用 propertyNames 或 list 方法，则该调用将失败。

load(Reader) / store(Writer, String) 方法按下面所指定的、简单的面向行的格式在基于字符的流中加载和存储属性。除了输入/输出流使用 ISO 8859-1 字符编码外，load(InputStream) / store(OutputStream, String) 方法与 load(Reader)/store(Writer, String) 对的工作方式完全相同。可以使用 Unicode 转义来编写此编码中无法直接表示的字符；转义序列中只允许单个 'u' 字符。可使用 native2ascii 工具对属性文件和其他字符编码进行相互转换。

loadFromXML(InputStream) 和 storeToXML(OutputStream, String, String) 方法按简单的 XML 格式加载和存储属性。默认使用 UTF-8 字符编码，但如果需要，可以指定某种特定的编码。XML 属性文档具有以下 DOCTYPE 声明：

 <!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
注意，导入或导出属性时不 访问系统 URI (http://java.sun.com/dtd/properties.dtd)；该系统 URI 仅作为一个唯一标识 DTD 的字符串：
    <?xml version="1.0" encoding="UTF-8"?>

    <!-- DTD for properties -->

    <!ELEMENT properties ( comment?, entry* ) >

    <!ATTLIST properties version CDATA #FIXED "1.0">

    <!ELEMENT comment (#PCDATA) >

    <!ELEMENT entry (#PCDATA) >

    <!ATTLIST entry key CDATA #REQUIRED>

从以下版本开始：
JDK1.0
另请参见：
native2ascii tool for Solaris, native2ascii tool for Windows

此类是线程安全的：多个线程可以共享单个 Properties 对象而无需进行外部同步。, 序列化表格

字段摘要
protected  Properties defaults
一个属性列表，包含属性列表中所有未找到值的键的默认值。
构造方法摘要
Properties()
创建一个无默认值的空属性列表。
Properties(Properties defaults)
创建一个带有指定默认值的空属性列表。
方法摘要
 String getProperty(String key)
用指定的键在此属性列表中搜索属性。
 String getProperty(String key, String defaultValue)
用指定的键在属性列表中搜索属性。
 void list(PrintStream out)
将属性列表输出到指定的输出流。
 void list(PrintWriter out)
将属性列表输出到指定的输出流。
 void load(InputStream inStream)
从输入流中读取属性列表（键和元素对）。
 void load(Reader reader)
按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。
 void loadFromXML(InputStream in)
将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。
 Enumeration<?> propertyNames()
返回属性列表中所有键的枚举，如果在主属性列表中未找到同名的键，则包括默认属性列表中不同的键。
 void save(OutputStream out, String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。
 Object setProperty(String key, String value)
调用 Hashtable 的方法 put。
 void store(OutputStream out, String comments)
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。
 void store(Writer writer, String comments)
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。
 void storeToXML(OutputStream os, String comment)
发出一个表示此表中包含的所有属性的 XML 文档。
 void storeToXML(OutputStream os, String comment, String encoding)
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。
 Set<String> stringPropertyNames()
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。
从类 java.util.Hashtable 继承的方法
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, get, hashCode, isEmpty, keys, keySet, put, putAll, rehash, remove, size, toString, values
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

defaults

protected Properties defaults
一个属性列表，包含属性列表中所有未找到值的键的默认值。

构造方法详细信息

Properties

public Properties()
创建一个无默认值的空属性列表。

Properties

public Properties(Properties defaults)
创建一个带有指定默认值的空属性列表。

参数：
defaults - 默认值。
方法详细信息

setProperty

public Object setProperty(String key,
                          String value)
调用 Hashtable 的方法 put。使用 getProperty 方法提供并行性。强制要求为属性的键和值使用字符串。返回值是 Hashtable 调用 put 的结果。

参数：
key - 要置于属性列表中的键。
value - 对应于 key 的值。
返回：
属性列表中指定键的旧值，如果没有值，则为 null。
从以下版本开始：
1.2
另请参见：
getProperty(java.lang.String)

load

public void load(Reader reader)
          throws IOException
按简单的面向行的格式从输入字符流中读取属性列表（键和元素对）。

根据行来处理属性。有两种行，即自然行 和逻辑行。自然行定义为通过行结束符字符集（\n 或 \r 或 \r\n），或者通过流的结尾来终止的字符行。一个自然行可能是一个空行、注释行，或者保存了全部或部分键-元素对。逻辑行保存了所有键-元素对的数据，可能分散在多个相邻的自然行中，用反斜杠字符 \ 转义行结束符序列。注意，不能以此方式扩展注释行；每个内容为注释的自然行必须有其自己的注释指示符，正如下面所描述的。到达流结尾前，将一直从输入中读取各行。

仅包含空白字符的自然行认为是空行并被忽略。注释行以 ASCII 字符 '#' 或 '!' 作为其首个非空白字符；注释行也被忽略并且不将其编码为键-元素信息。除了行结束符，此格式还将空格字符（' '，'\u0020'）、制表符（'\t'，'\u0009'）和换页符（'\f'，'\u000C'）作为空白。

如果一个逻辑行分散在多个自然行中，则转义行结束符序列的反斜杠、行结束符序列和后续行开始处的任何空白，对键或元素的值都没有影响。后面对键和元素解析的讨论（加载时）将假定移除行继续符后，构成键和元素的所有字符都出现在单个自然行中。注意，仅检查行结束符前面的字符，以便决定行结束符是否已转义是不 够的；对于要转义的行结束符，必须有奇数个相邻的反斜杠。由于是从左到右来处理输入内容的，所以行结束符前（或其他位置）非零、偶数 2n 个相邻的反斜杠在转义处理后会被编码成 n 个反斜杠。

键包含行中下列区间内的所有字符：从首个非空白字符开始，直到（但不包括）首个非转义的 '='、 ':' 或非行结束符的空白字符。所有这些键终止字符都可能包含在键中，方法是在其前面用反斜杠字符进行转义，例如：

\:\=

将是两字符的键 ":="。可以使用 \r 和 \n 转义序列包括行结束符字符。跳过键后面的所有空白字符；如果键后的首个非空白字符是 '=' 或 ':'，则忽略该字符并且跳过其后的所有空白字符。行中所有剩余的字符都成为关联元素字符串的一部分；如果没有剩余的字符，则该元素为空字符串 ""。一旦标识了组成键和元素的原始字符序列，则如上所述执行转义处理。

作为一个示例，以下三行都指定了键 "Truth" 和关联元素值 "Beauty"：

 Truth = Beauty
        Truth:Beauty
 Truth                  :Beauty
另一个示例，以下三行都指定了单个属性：

 fruits                           apple, banana, pear, \
                                  cantaloupe, watermelon, \
                                  kiwi, mango
键是 "fruits"，关联元素是：

"apple, banana, pear, cantaloupe, watermelon, kiwi, mango"
注意，在每个 \ 的前面出现了一个空格，这样最后的结果中每个逗号的后面将出现一个空格；会将 \、行结束符和后续行中的前导空白字符简单地丢弃，并且不会 用一个或多个其他字符替换它们。

第三个示例，此行：

cheeses
指定键是 "cheeses" 并且关联元素是空字符串 ""。

以键和元素的形式表示的字符可以使用与字符和字符串字面值所用的类似转义序列表示。（请参阅 Java Language Specification 的 §3.3 节 和 §3.10.6 节）。 字符和字符串所用的字符转义序列和 Unicode 转义的差别有：

  • 不识别八进制转义。
  • 字符序列 \b 不表示退格字符。
  • 该方法并不将无效转义字符前的反斜杠字符 \ 视为错误；只是将反斜杠丢弃。例如，在 Java 字符串中，序列 "\z" 将导致编译时错误。相反，此方法会丢弃该反斜杠。因此，此方法将两字符序列 "\b" 与单字符 'b' 视为等同。
  • 转义对于单引号和双引号而言不是必需的；但是根据上面的规则，前面有反斜杠的单引号和双引号字符仍旧分别生成单引号和双引号字符。
  • Uniocde 转义序列中只允许单个 'u' 字符。

此方法返回后，指定的流仍保持打开状态。

参数：
reader - 输入字符流。
抛出：
IOException - 如果从输入流读取时发生错误。
IllegalArgumentException - 如果输入中出现了错误的 Unicode 转义。
从以下版本开始：
1.6

load

public void load(InputStream inStream)
          throws IOException
从输入流中读取属性列表（键和元素对）。输入流按 load(Reader) 中所指定的、简单的面向行的格式，并假定使用 ISO 8859-1 字符编码；即每个字节都是 Latin1 字符。对于非 Latin1 的字符和某些特殊字符，可以使用 Unicode 转义以键和元素的形式来表示它们。

此方法返回后，指定的流仍保持打开状态。

参数：
inStream - 输入流。
抛出：
IOException - 如果读取输入流时发生错误。
IllegalArgumentException - 如果输入流包含错误的 Unicode 转义序列。
从以下版本开始：
1.2

save

@Deprecated
public void save(OutputStream out,
                            String comments)
已过时。 如果在保存属性列表时发生 I/O 错误，则此方法不抛出 IOException。保存属性列表的首选方法是通过 store(OutputStream out, String comments) 方法或 storeToXML(OutputStream os, String comment) 方法来进行。

调用 store(OutputStream out, String comments) 方法并取消抛出的 IOExceptions。

参数：
out - 输出流。
comments - 属性列表的描述。
抛出：
ClassCastException - 如果此 Properties 对象包含任意非 String 的键或值。

store

public void store(Writer writer,
                  String comments)
           throws IOException
以适合使用 load(Reader) 方法的格式，将此 Properties 表中的属性列表（键和元素对）写入输出字符。

对于取自此 Properties 表默认表（如果有的话）的属性，此方法不 将其写入 out。

如果 comments 变量非 null，则首先将 ASCII # 字符、注释字符串和一个行分隔符写入输出流。因此，该 comments 可用作一个标识注释。注释中换行 ('\n')、回车 ('\r') 或回车后直接跟着换行，这些字符中的任意一个都由 Writer 生成的行分隔符替换，如果注释中下一个字符不是 # 字符或 ! 字符，则在该行分隔符后写出 ASCII #。

接下来总是写入一个注释行，该行包括一个 ASCII # 字符、当前的日期和时间（就好像使用 Date 的 toString 方法获取当前时间一样）和一个由 Writer 生成的行分隔符。

然后将此 Properties 表中的所有项写入 out，一次一行。对于每个项而言，先写入键字符串，然后是一个 ASCII =，最后是关联元素字符串。对于键，所有写入的空白字符前面都有一个 \ 字符。对于元素，所有写入的前导空白字符（但是不嵌入或尾随空白字符）前面都有一个 \ 字符。所有写入的键和元素字符 #、!、= 和 : 前面都有反斜杠，确保能正确地加载这些字符。

写入各个项后，刷新输出流。此方法返回后，输出流仍保持打开状态。

参数：
writer - 输出字符流 writer。
comments - 属性列表的描述。
抛出：
IOException - 如果将此属性列表写入指定的输出流时抛出 IOException。
ClassCastException - 如果此 Properties 对象包含任何不是 String 的键或值。
NullPointerException - 如果 writer 为 null。
从以下版本开始：
1.6

store

public void store(OutputStream out,
                  String comments)
           throws IOException
以适合使用 load(InputStream) 方法加载到 Properties 表中的格式，将此 Properties 表中的属性列表（键和元素对）写入输出流。

此方法未 编写此 Properties 表默认表的属性（如果有）。

此方法以 store(Writer) 中指定的相同格式输出注释、属性键和值，注意以下几点不同：

  • 使用 ISO 8859-1 字符编码写入该流。
  • 注释中不是 Latin-1 的字符针对其适当的十六进制值 xxxx 以 \u xxxx 的形式写入。
  • 属性键或值中小于 \u0020 的字符和大于 \u007E 的字符针对适当的十六进制值 xxxx 以 \u xxxx 的形式写入。

写入各个项后，刷新输出流。此方法返回后，输出流仍保持打开状态。

参数：
out - 输出流。
comments - 属性列表的描述。
抛出：
IOException - 如果将此属性列表写入指定的输出流时，抛出 IOException。
ClassCastException - 如果此 Properties 对象包含任意非 String 的键或值。
NullPointerException - 如果 out 为 null。
从以下版本开始：
1.2

loadFromXML

public void loadFromXML(InputStream in)
                 throws IOException,
                        InvalidPropertiesFormatException
将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。

该 XML 文档必须具有以下 DOCTYPE 声明：

 <!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">
而且该文档还必须满足上述属性 DTD 的要求。

此方法返回后，指定的流已关闭。

参数：
in - 从中读取 XML 文档的输入流。
抛出：
IOException - 如果读取指定的输入流导致 IOException。
InvalidPropertiesFormatException - 输入流中的数据没有按要求的文档类型组成有效的 XML 文档。
NullPointerException - 如果 in 为 null。
从以下版本开始：
1.5
另请参见：
storeToXML(OutputStream, String, String)

storeToXML

public void storeToXML(OutputStream os,
                       String comment)
                throws IOException
发出一个表示此表中包含的所有属性的 XML 文档。

以 props.storeToXML(os, comment) 的形式调用此方法的行为与调用 props.storeToXML(os, comment, "UTF-8"); 完全相同。

参数：
os - 根据其内容发出 XML 文档的输出流。
comment - 属性列表的描述，如果没有所需的注释，则为 null。
抛出：
IOException - 如果写入指定的输出流导致一个 IOException。
NullPointerException - 如果 os 为 null。
ClassCastException - 如果此 Properties 对象包含任何不是 String 的键或值。
从以下版本开始：
1.5
另请参见：
loadFromXML(InputStream)

storeToXML

public void storeToXML(OutputStream os,
                       String comment,
                       String encoding)
                throws IOException
使用指定的编码发出一个表示此表中包含的所有属性的 XML 文档。

该 XML 文档要具有以下 DOCTYPE 声明：

 <!DOCTYPE properties SYSTEM "http://java.sun.com/dtd/properties.dtd">

如果指定的注释为 null，则没有注释存储在该文档中。

此方法返回后，指定的流仍保持打开状态。

参数：
os - 根据其内容发出 XML 文档的输出流。
comment - 属性列表的描述，如果没有所需的注释，则为 null。
抛出：
IOException - 如果写入指定的输出流导致一个 IOException。
NullPointerException - 如果 os 为 null，或者 encoding 为 null。
ClassCastException - 如果 Properties 对象包含任何不是 String 的键或值。
从以下版本开始：
1.5
另请参见：
loadFromXML(InputStream)

getProperty

public String getProperty(String key)
用指定的键在此属性列表中搜索属性。如果在此属性列表中未找到该键，则接着递归检查默认属性列表及其默认值。如果未找到属性，则此方法返回 null。

参数：
key - 属性键。
返回：
属性列表中具有指定键值的值。
另请参见：
setProperty(java.lang.String, java.lang.String), defaults

getProperty

public String getProperty(String key,
                          String defaultValue)
用指定的键在属性列表中搜索属性。如果在属性列表中未找到该键，则接着递归检查默认属性列表及其默认值。如果未找到属性，则此方法返回默认值变量。

参数：
key - 哈希表键。
defaultValue - 默认值。
返回：
属性列表中具有指定键值的值。
另请参见：
setProperty(java.lang.String, java.lang.String), defaults

propertyNames

public Enumeration<?> propertyNames()
返回属性列表中所有键的枚举，如果在主属性列表中未找到同名的键，则包括默认属性列表中不同的键。

返回：
属性列表中所有键的枚举，包括默认属性列表中的键。
抛出：
ClassCastException - 如果此属性列表中的任何键不是一个字符串。
另请参见：
Enumeration, defaults, stringPropertyNames()

stringPropertyNames

public Set<String> stringPropertyNames()
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。其键或值不是 String 类型的属性被忽略。

返回的 set 不受 Properties 对象支持。对此 Properties 的改变不能在该 set 中反映出来，反之亦然。

返回：
此属性列表中的键集，其中该键及其对应值是字符串，包括默认属性列表中的键。
从以下版本开始：
1.6
另请参见：
defaults

list

public void list(PrintStream out)
将属性列表输出到指定的输出流。此方法对调试很有用。

参数：
out - 输出流。
抛出：
ClassCastException - 如果此属性列表中的任何键不是字符串。

list

public void list(PrintWriter out)
将属性列表输出到指定的输出流。此方法对调试很有用。

参数：
out - 输出流。
抛出：
ClassCastException - 如果此属性列表中的任何键不是字符串。
从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 PropertyPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.util.PropertyPermission
所有已实现的接口：
Serializable, Guard
public final class PropertyPermission
extends BasicPermission

此类用于属性权限。

其名称就是属性名（"java.home"、"os.name"，等等）。命名约定遵守层次结构属性命名约定。另外，名称的末尾可能有一个星号，星号前有一个 "."，用来表示通配符。例如："java.*" 或 "*" 是有效的，而 "java.*" 或 "a*b"则无效。

将所要授予的动作权限以字符串的形式传递给构造方法，该字符串包含一个零列表或多个由逗号分隔的关键字。可能的关键字有 "read" 和 "write"。其含义定义如下：

read
读权限。允许调用 System.getProperty。
write
写权限。允许调用 System.setProperty。

处理前会将动作字符串转换为小写字母。

授予代码访问某些系统属性的权限前应该小心。例如，授予访问 "java.home" 系统属性的权限就会将有关系统环境（Java 安装目录）的敏感信息给予潜在的恶意代码。另外，授予访问 "user.name" 和 "user.home" 系统属性的权限就会将有关用户环境（用户的帐户名和主目录）的敏感信息给予潜在的恶意代码。

从以下版本开始：
1.2
另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager

构造方法摘要
PropertyPermission(String name, String actions)
创建带指定名称的新 PropertyPermission 对象。
方法摘要
boolean | equals(Object obj) 检查两个 PropertyPermission 对象是否相等。
String | getActions() 返回动作的“规范化字符串表示形式”。
int | hashCode() 返回对象的哈希码值。
boolean | implies(Permission p) 检查 PropertyPermission 对象是否“暗指”指定的权限。
PermissionCollection | newPermissionCollection() 用于存储 PropertyPermission 对象的新 PermissionCollection 对象。
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PropertyPermission

public PropertyPermission(String name,
                          String actions)
创建带指定名称的新 PropertyPermission 对象。其名称就是属性名，并且 actions 包含在该属性上授予的所需动作列表，各动作用逗号分隔。可能的动作有 "read" 和 "write"。

参数：
name - PropertyPermission 的名称。
actions - 动作字符串。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空或者 actions 无效。
方法详细信息

implies

public boolean implies(Permission p)
检查 PropertyPermission 对象是否“暗指”指定的权限。

更明确地说，如果此方法满足以下条件，则返回 true：

  • p 是 PropertyPermission 的一个实例，

  • p 的动作是此对象的动作的一个子集，并且

  • 此对象的名称暗指了 p 的名字。例如，"java.*" 暗指 "java.home"。

覆盖：
类 BasicPermission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果对象暗指了指定的权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 PropertyPermission 对象是否相等。检查 obj 是否为一个 PropertyPermission，并且与此对象具有相同的名称和动作。

覆盖：
类 BasicPermission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 是一个 PropertyPermission，并且与此 PropertyPermission 对象具有相同的名称和动作，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回对象的哈希码值。所用的哈希码是此权限名的哈希码，也就是 getName().hashCode()，其中 getName 来自 Permission 超类。

覆盖：
类 BasicPermission 中的 hashCode
返回：
对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回动作的“规范化字符串表示形式”。也就是说，此方法总是以下列顺序返回存在的动作：read, write。例如，如果此 PropertyPermission 对象允许写和读操作，则调用 getActions 将返回字符串 "read,write"。

覆盖：
类 BasicPermission 中的 getActions
返回：
动作的规范化字符串表示形式。

newPermissionCollection

public PermissionCollection newPermissionCollection()
用于存储 PropertyPermission 对象的新 PermissionCollection 对象。

覆盖：
类 BasicPermission 中的 newPermissionCollection
返回：
适合存储 PropertyPermissions 的新 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PropertyResourceBundle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 PropertyResourceBundle

java.lang.Object
    继承者  java.util.ResourceBundle
        继承者  java.util.PropertyResourceBundle

public class PropertyResourceBundle
extends ResourceBundle

PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。有关资源包的更多信息，请参阅 ResourceBundle。

与其他资源包类型不同，不能为 PropertyResourceBundle 创建子类。相反，要提供含有资源数据的属性文件。ResourceBundle.getBundle 将自动查找合适的属性文件并创建引用该文件的 PropertyResourceBundle。有关搜索和实例化策略的完整描述，请参阅 ResourceBundle.getBundle。

下面的示例显示了资源包系列中具有基本名称 "MyResources" 的成员。文本定义了包 "MyResources_de"，这是该包系列中的德语成员。该成员基于 PropertyResourceBundle，因此文本就是文件 "MyResources_de.properties" 的内容（一个相关的 示例显示了如何将包添加到该系列中，该系列作为 ListResourceBundle 的子类来实现）。本示例的键形式为 "s1" 等等。实际的键完全取决于您的选择，只要它们与在程序中使用的、用于从包中获取对象的键相同即可。键是区分大小写的。

 # MessageFormat pattern
 s1=Die Platte \"{1}\" enthält {0}.

 # location of {0} in pattern
 s2=1

 # sample disk name
 s3=Meine Platte

 # first ChoiceFormat choice
 s4=keine Dateien

 # second ChoiceFormat choice
 s5=eine Datei

 # third ChoiceFormat choice
 s6={0,number} Dateien

 # sample date
 s7=3. März 1996

注：可根据 InputStream 或 Reader 构造 PropertyResourceBundle，它表示一个属性文件。根据 InputStream 构造一个 PropertyResourceBundle 实例要求输入流必须使用 ISO-8859-1 编码。在这种情况下，不能使用 ISO-8859-1 编码表示的字符必须用 Unicode 转义表示，而其他带有 Reader 的构造方法没有该限制。

从以下版本开始：
JDK1.1
另请参见：
ResourceBundle, ListResourceBundle, Properties

嵌套类摘要
从类 java.util.ResourceBundle 继承的嵌套类/接口
ResourceBundle.Control
字段摘要
从类 java.util.ResourceBundle 继承的字段
parent
构造方法摘要
PropertyResourceBundle(InputStream stream)
根据 InputStream 创建属性资源包。
PropertyResourceBundle(Reader reader)
根据 Reader 创建属性资源包。
方法摘要
Enumeration<String> | getKeys() 返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
Object | handleGetObject(String key) 从此资源包中获取给定键的对象。
protected Set<String> | handleKeySet() 返回只 包含在此 ResourceBundle 中的键的 Set。
从类 java.util.ResourceBundle 继承的方法
clearCache, clearCache, containsKey, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getLocale, getObject, getString, getStringArray, keySet, setParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PropertyResourceBundle

public PropertyResourceBundle(InputStream stream)
                       throws IOException
根据 InputStream 创建属性资源包。使用此构造方法读取的属性文件必须使用 ISO-8859-1。

参数：
stream - 一个 InputStream，表示要从其进行读取的属性文件。
抛出：
IOException - 如果发生 I/O 错误
NullPointerException - 如果 stream 为 null

PropertyResourceBundle

public PropertyResourceBundle(Reader reader)
                       throws IOException
根据 Reader 创建属性资源包。与 PropertyResourceBundle(InputStream) 构造方法不同，关于输入属性文件的编码没有限制。

参数：
reader - 一个 Reader，表示要从其进行读取的属性文件。
抛出：
IOException - 如果发生 I/O 错误
NullPointerException - 如果 reader 为 null
从以下版本开始：
1.6
方法详细信息

handleGetObject

public Object handleGetObject(String key)
从类 ResourceBundle 复制的描述
从此资源包中获取给定键的对象。如果此资源包未包含给定键的对象，则返回 null。

指定者：
类 ResourceBundle 中的 handleGetObject
参数：
key - 所需对象的键
返回：
给定键的对象，或者返回 null

getKeys

public Enumeration<String> getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。

指定者：
类 ResourceBundle 中的 getKeys
返回：
包含在此 ResourceBundle 及其父包中的键的 Enumeration。
另请参见：
ResourceBundle.keySet()

handleKeySet

protected Set<String> handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

覆盖：
类 ResourceBundle 中的 handleKeySet
返回：
只包含在此 ResourceBundle 中的键的 Set
从以下版本开始：
1.6
另请参见：
ResourceBundle.keySet()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Queue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Queue<E>

类型参数：
E - collection 中所保存元素的类型。
所有超级接口：
Collection<E>, Iterable<E>
所有已知子接口：
BlockingDeque<E>, BlockingQueue<E>, Deque<E>
所有已知实现类：
AbstractQueue, ArrayBlockingQueue, ArrayDeque, ConcurrentLinkedQueue, DelayQueue, LinkedBlockingDeque, LinkedBlockingQueue, LinkedList, PriorityBlockingQueue, PriorityQueue, SynchronousQueue
public interface Queue<E>
extends Collection<E>

在处理元素前用于保存元素的 collection。除了基本的 Collection 操作外，队列还提供其他的插入、提取和检查操作。每个方法都存在两种形式：一种抛出异常（操作失败时），另一种返回一个特殊值（null 或 false，具体取决于操作）。插入操作的后一种形式是用于专门为有容量限制的 Queue 实现设计的；在大多数实现中，插入操作不会失败。

 | 抛出异常 | 返回特殊值
插入 | add(e) | offer(e)
移除 | remove() | poll()
检查 | element() | peek()

队列通常（但并非一定）以 FIFO（先进先出）的方式排序各个元素。不过优先级队列和 LIFO 队列（或堆栈）例外，前者根据提供的比较器或元素的自然顺序对元素进行排序，后者按 LIFO（后进先出）的方式对元素进行排序。无论使用哪种排序方式，队列的头 都是调用 remove() 或 poll() 所移除的元素。在 FIFO 队列中，所有的新元素都插入队列的末尾。其他种类的队列可能使用不同的元素放置规则。每个 Queue 实现必须指定其顺序属性。

如果可能，offer 方法可插入一个元素，否则返回 false。这与 Collection.add 方法不同，该方法只能通过抛出未经检查的异常使添加元素失败。offer 方法设计用于正常的失败情况，而不是出现异常的情况，例如在容量固定（有界）的队列中。

remove() 和 poll() 方法可移除和返回队列的头。到底从队列中移除哪个元素是队列排序策略的功能，而该策略在各种实现中是不同的。remove() 和 poll() 方法仅在队列为空时其行为有所不同：remove() 方法抛出一个异常，而 poll() 方法则返回 null。

element() 和 peek() 返回，但不移除，队列的头。

Queue 接口并未定义阻塞队列的方法，而这在并发编程中是很常见的。BlockingQueue 接口定义了那些等待元素出现或等待队列中有可用空间的方法，这些方法扩展了此接口。

Queue 实现通常不允许插入 null 元素，尽管某些实现（如 LinkedList）并不禁止插入 null。即使在允许 null 的实现中，也不应该将 null 插入到 Queue 中，因为 null 也用作 poll 方法的一个特殊返回值，表明队列不包含元素。

Queue 实现通常未定义 equals 和 hashCode 方法的基于元素的版本，而是从 Object 类继承了基于身份的版本，因为对于具有相同元素但有不同排序属性的队列而言，基于元素的相等性并非总是定义良好的。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
Collection, LinkedList, PriorityQueue, LinkedBlockingQueue, BlockingQueue, ArrayBlockingQueue, LinkedBlockingQueue, PriorityBlockingQueue

方法摘要
boolean | add(E e) 将指定的元素插入此队列（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。
E | element() 获取，但是不移除此队列的头。
boolean | offer(E e) 将指定的元素插入此队列（如果立即可行且不会违反容量限制），当使用有容量限制的队列时，此方法通常要优于 add(E)，后者可能无法插入元素，而只是抛出一个异常。
E | peek() 获取但不移除此队列的头；如果此队列为空，则返回 null。
E | poll() 获取并移除此队列的头，如果此队列为空，则返回 null。
E | remove() 获取并移除此队列的头。
从接口 java.util.Collection 继承的方法
addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray

方法详细信息

add

boolean add(E e)
将指定的元素插入此队列（如果立即可行且不会违反容量限制），在成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。

指定者：
接口 Collection<E> 中的 add
参数：
e - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
IllegalStateException - 如果由于容量的限制此时不能添加该元素
ClassCastException - 如果指定元素的类不允许将其添加到此队列
NullPointerException - 如果指定元素为 null 并且此队列不允许 null 元素
IllegalArgumentException - 如果此元素的某些属性不允许将其添加到此队列

offer

boolean offer(E e)
将指定的元素插入此队列（如果立即可行且不会违反容量限制），当使用有容量限制的队列时，此方法通常要优于 add(E)，后者可能无法插入元素，而只是抛出一个异常。

参数：
e - 要添加的元素
返回：
如果该元素已添加到此队列，则返回 true；否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许将其添加到此队列
NullPointerException - 如果指定元素为 null 并且此队列不允许 null 元素
IllegalArgumentException - 如果此元素的某些属性不允许将其添加到此队列

remove

E remove()
获取并移除此队列的头。此方法与 poll 唯一的不同在于：此队列为空时将抛出一个异常。

返回：
队列的头
抛出：
NoSuchElementException - 如果此队列为空

poll

E poll()
获取并移除此队列的头，如果此队列为空，则返回 null。

返回：
队列的头，如果此队列为空，则返回 null

element

E element()
获取，但是不移除此队列的头。此方法与 peek 唯一的不同在于：此队列为空时将抛出一个异常。

返回：
队列的头
抛出：
NoSuchElementException - 如果此队列为空

peek

E peek()
获取但不移除此队列的头；如果此队列为空，则返回 null。

返回：
此队列的头；如果此队列为空，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Random (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Random

java.lang.Object
    继承者  java.util.Random
所有已实现的接口：
Serializable
直接已知子类：
SecureRandom
public class Random
extends Object
implements Serializable

此类的实例用于生成伪随机数流。此类使用 48 位的种子，使用线性同余公式 (linear congruential form) 对其进行了修改（请参阅 Donald Knuth 的The Art of Computer Programming, Volume 3，第 3.2.1 节）。

如果用相同的种子创建两个 Random 实例，则对每个实例进行相同的方法调用序列，它们将生成并返回相同的数字序列。为了保证此属性的实现，为类 Random 指定了特定的算法。为了 Java 代码的完全可移植性，Java 实现必须让类 Random 使用此处所示的所有算法。但是允许 Random 类的子类使用其他算法，只要其符合所有方法的常规协定即可。

Random 类实现的算法使用一个 protected 实用工具方法，每次调用它最多可提供 32 个伪随机生成的位。

很多应用程序会发现 Math.random() 方法更易于使用。

从以下版本开始：
JDK1.0
另请参见：
序列化表格

构造方法摘要
Random()
创建一个新的随机数生成器。
Random(long seed)
使用单个 long 种子创建一个新的随机数生成器。
方法摘要
protected int | next(int bits) 生成下一个伪随机数。
boolean | nextBoolean() 返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 boolean 值。
void | nextBytes(byte[] bytes) 生成随机字节并将其置于用户提供的 byte 数组中。
double | nextDouble() 返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 double 值。
float | nextFloat() 返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 float 值。
double | nextGaussian() 返回下一个伪随机数，它是取自此随机数生成器序列的、呈高斯（“正态”）分布的 double 值，其平均值是 0.0，标准差是 1.0。
int | nextInt() 返回下一个伪随机数，它是此随机数生成器的序列中均匀分布的 int 值。
int | nextInt(int n) 返回一个伪随机数，它是取自此随机数生成器序列的、在 0（包括）和指定值（不包括）之间均匀分布的 int 值。
long | nextLong() 返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 long 值。
void | setSeed(long seed) 使用单个 long 种子设置此随机数生成器的种子。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Random

public Random()
创建一个新的随机数生成器。此构造方法将随机数生成器的种子设置为某个值，该值与此构造方法的所有其他调用所用的值完全不同。

Random

public Random(long seed)
使用单个 long 种子创建一个新的随机数生成器。该种子是伪随机数生成器的内部状态的初始值，该生成器可通过方法 next(int) 维护。

调用 new Random(seed) 等效于：

 Random rnd = new Random();
 rnd.setSeed(seed);

参数：
seed - 初始种子
另请参见：
setSeed(long)
方法详细信息

setSeed

public void setSeed(long seed)
使用单个 long 种子设置此随机数生成器的种子。setSeed 的常规协定是它更改此随机数生成器对象的状态，使其状态好像是刚刚使用参数 seed 作为种子创建它的状态一样。通过将种子自动更新为
(seed ^ 0x5DEECE66DL) & ((1L << 48) - 1)
并清除 nextGaussian() 使用的 haveNextNextGaussian 标志，Random 类可实现 setSeed 方法。

Random 类实现的 setSeed 恰好只使用 48 位的给定种子。但是，通常重写方法可能使用 long 参数的所有 64 位作为种子值。

参数：
seed - 初始种子。

next

protected int next(int bits)
生成下一个伪随机数。当被所有其他方法使用时，子类应该重写此方法。

next 的常规协定是，返回一个 int 值，如果参数 bits 位处于 1 和 32（包括）之间，那么返回值的多数低位都将（大致）是单独选择的位值，每个位值是 0 或 1 的机会（大致）相等。通过将种子自动更新为

(seed * 0x5DEECE66DL + 0xBL) & ((1L << 48) - 1)
并返回
(int)(seed >>> (48 - bits))，Random 类可实现 next 方法。
这是一个线性同余伪随机数生成器，由 D. H. Lehmer 定义，Donald E. Knuth 在 The Art of Computer Programming, Volume 3: Seminumerical Algorithms 的第 3.2.1 节中进行了描述。

参数：
bits - 随机位。
返回：
随机数生成器序列的下一个伪随机值。
从以下版本开始：
1.1

nextBytes

public void nextBytes(byte[] bytes)
生成随机字节并将其置于用户提供的 byte 数组中。所生成的随机字节数等于该 byte 数组的长度。

Random 类按如下方式实现 nextBytes 方法：

 public void nextBytes(byte[] bytes) {
   for (int i = 0; i < bytes.length; )
     for (int rnd = nextInt(), n = Math.min(bytes.length - i, 4);
          n-- > 0; rnd >>= 8)
       bytes[i++] = (byte)rnd;
 }

参数：
bytes - 用随机字节填充的 byte 数组
抛出：
NullPointerException - 如果 byte 数组为 null
从以下版本开始：
1.1

nextInt

public int nextInt()
返回下一个伪随机数，它是此随机数生成器的序列中均匀分布的 int 值。nextInt 的常规协定是，伪随机地生成并返回一个 int 值。所有 232 个可能 int 值的生成概率（大致）相同。

Random 类按如下方式实现 nextInt 方法：

 public int nextInt() {
   return next(32);
 }

返回：
下一个伪随机数，它是此随机数生成器的序列中均匀分布的 int 值。

nextInt

public int nextInt(int n)
返回一个伪随机数，它是取自此随机数生成器序列的、在 0（包括）和指定值（不包括）之间均匀分布的 int 值。nextInt 的常规协定是，伪随机地生成并返回指定范围中的一个 int 值。所有可能的 n 个 int 值的生成概率（大致）相同。Random 类按如下方式实现 nextInt(int n) 方法：
 public int nextInt(int n) {
     if (n<=0)
        throw new IllegalArgumentException("n must be positive");

     if ((n & -n) == n)  // i.e., n is a power of 2
         return (int)((n * (long)next(31)) >> 31);

     int bits, val;
     do {
         bits = next(31);
         val = bits % n;
     } while(bits - val + (n-1) < 0);
     return val;
  }

前面的描述中使用了不确定的词“大致”，因为 next 方法只是一个大致上独自选择位的无偏源。如果它是一个随机选择位的最佳源，那么给出的算法应该从规定范围完全一致地选择 int 值。

该算法稍微有些复杂。它拒绝那些会导致不均匀分布的值（由于 2^31 无法被 n 整除）。某个值被拒绝的概率取决于 n。最坏的情况是 n=2^30+1，拒绝的概率是 1/2，循环终止前的预计迭代次数是 2。

该算法特别对待 n 是 2 的次幂的情况：它从底层伪随机数生成器中返回正确的高位数。在不是特殊处理的情况中，将返回正确的低 位数。众所周知，线性同余伪随机数生成器（比如此类所实现的）在其低位的值序列中周期较短。因此，如果 n 是 2 的次幂（幂值较小），则这种特殊情况将大大增加此方法的后续调用所返回的值序列长度。

参数：
n - 要返回的随机数的范围。必须为正数。
返回：
下一个伪随机数，在此随机数生成器序列中 0（包括）和 n（不包括）之间均匀分布的 int 值。
抛出：
IllegalArgumentException - 如果 n 不是正数
从以下版本开始：
1.2

nextLong

public long nextLong()
返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 long 值。nextLong 的常规协定是，伪随机地生成并返回一个 long 值。

Random 类按如下方式实现 nextLong 方法：

 public long nextLong() {
       return ((long)next(32) << 32) + next(32);
  }
因为 Random 类使用只以 48 位表示的种子，所以此算法不会返回所有可能的 long 值。

返回：
下一个伪随机数，它是此随机数生成器序列中均匀分布的 long 值。

nextBoolean

public boolean nextBoolean()
返回下一个伪随机数，它是取自此随机数生成器序列的均匀分布的 boolean 值。nextBoolean 的常规协定是，伪随机地生成并返回一个 boolean 值。值 true 和 false 的生成概率（大致）相同。

Random 类按如下方式实现 nextBoolean 方法：

 public boolean nextBoolean() {
   return next(1) != 0;
 }

返回：
下一个伪随机数，它是此随机数生成器的序列中均匀分布的 boolean 值。
从以下版本开始：
1.2

nextFloat

public float nextFloat()
返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 float 值。

nextFloat 的常规协定是，伪随机地生成并返回一个从 0.0f（包括）到 1.0f（包括）范围内均匀选择（大致）的 float 值。所有可能的 224 个 float 值（其形式为 m x 2-24，其中 m 是一个小于 224 的正整数）的生成概率（大致）相同。

Random 类按如下方式实现 nextFloat 方法：

 public float nextFloat() {
      return next(24) / ((float)(1 << 24));
 }

前面的描述中使用了不确定的词“大致”，因为 next 方法只是一个大致上独立选择位的无偏源。如果它是一个随机选择位的最佳来源，那么给出的算法应该从规定范围完全一致地选择 float 值。

[在 Java 的早期版本中，结果被错误地计算为：

 return next(30) / ((float)(1 << 30));
这可能看似等效（如果不是更好的话），但实际上由于浮点数舍入中的偏差，它会导致轻微的不均匀性：有效数的低位更可能是 0 而不是 1。]

返回：
下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 float 值

nextDouble

public double nextDouble()
返回下一个伪随机数，它是取自此随机数生成器序列的、在 0.0 和 1.0 之间均匀分布的 double 值。

nextDouble 的常规协定是，伪随机地生成并返回一个从 0.0d（包括）到 1.0d（不包括）范围内均匀选择（大致）的 double 值。

Random 类按如下方式实现 nextDouble 方法：

 public double nextDouble() {
       return (((long)next(26) << 27) + next(27))
           / (double)(1L << 53);
 }

前面的描述中使用了不确定的词“大致”，因为 next 方法只是一个大致上独立选择位的无偏源。如果它是一个随机选择位的最佳源，那么给出的算法应该从规定范围完全一致地选择 double 值。

[在 Java 的早期版本中，结果被错误地计算为：

 return (((long)next(27) << 27) + next(27))
      / (double)(1L << 54);
这可能看似等效（如果不是更好的话），但实际上由于浮点数舍入中的偏差，它会引入较大的不均匀性：有效数的低位出现 0 的可能性是 1 的三倍！这种不均匀性在实践中可能没什么关系，但我们总是力求完美。]

返回：
下一个伪随机数，它是此随机数生成器序列中 0.0 和 1.0 之间均匀分布的 double 值
另请参见：
Math.random()

nextGaussian

public double nextGaussian()
返回下一个伪随机数，它是取自此随机数生成器序列的、呈高斯（“正态”）分布的 double 值，其平均值是 0.0，标准差是 1.0。

nextGaussian 的常规协定是，伪随机地生成并返回一个 double 值，该值从（大致）具有平均值 0.0 和标准差 1.0 的标准正态分布中选择。

Random 类按以下这种线程安全的方式实现 nextGaussian 方法：

 private double nextNextGaussian;
 private boolean haveNextNextGaussian = false;

 public double nextGaussian() {
   if (haveNextNextGaussian) {
     haveNextNextGaussian = false;
     return nextNextGaussian;
   } else {
     double v1, v2, s;
     do {
       v1 = 2 * nextDouble() - 1;   // between -1.0 and 1.0
       v2 = 2 * nextDouble() - 1;   // between -1.0 and 1.0
       s = v1 * v1 + v2 * v2;
     } while (s >= 1 || s == 0);
     double multiplier = StrictMath.sqrt(-2 * StrictMath.log(s)/s);
     nextNextGaussian = v2 * multiplier;
     haveNextNextGaussian = true;
     return v1 * multiplier;
   }
 }
这使用了 G. E. P. Box、M. E. Muller 和 G. Marsaglia 的极坐标法 (polar method)，该方法在 Donald E. Knuth 的 The Art of Computer Programming, Volume 3:Seminumerical Algorithms 的第 3.4.1 节，小节 C，算法 P 中进行了描述。注意，它只需调用一次 StrictMath.log 和调用一次 StrictMath.sqrt> 就可以生成两个独立的值。

返回：
下一个伪随机数，它是取自此随机数生成器序列的、呈高斯（“正态”）分布的 double 值，其平均值是 0.0，标准差是 1.0。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RandomAccess (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 RandomAccess

所有已知实现类：
ArrayList, AttributeList, CopyOnWriteArrayList, RoleList, RoleUnresolvedList, Stack, Vector
public interface RandomAccess

List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。此接口的主要目的是允许一般的算法更改其行为，从而在将其应用到随机或连续访问列表时能提供良好的性能。

将操作随机访问列表的最佳算法（如 ArrayList）应用到连续访问列表（如 LinkedList）时，可产生二次项的行为。如果将某个算法应用到连续访问列表，那么在应用可能提供较差性能的算法前，鼓励使用一般的列表算法检查给定列表是否为此接口的一个 instanceof，如果需要保证可接受的性能，还可以更改其行为。

现在已经认识到，随机和连续访问之间的区别通常是模糊的。例如，如果列表很大时，某些 List 实现提供渐进的线性访问时间，但实际上是固定的访问时间。这样的 List 实现通常应该实现此接口。实际经验证明，如果是下列情况，则 List 实现应该实现此接口，即对于典型的类实例而言，此循环：

     for (int i=0, n=list.size(); i < n; i++)
         list.get(i);
的运行速度要快于以下循环：
     for (Iterator i=list.iterator(); i.hasNext(); )
         i.next();

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.4

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceBundle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ResourceBundle

java.lang.Object
    继承者  java.util.ResourceBundle
直接已知子类：
ListResourceBundle, PropertyResourceBundle
public abstract class ResourceBundle
extends Object

资源包包含特定于语言环境的对象。当程序需要一个特定于语言环境的资源时（如 String），程序可以从适合当前用户语言环境的资源包中加载它。使用这种方式，可以编写很大程度上独立于用户语言环境的程序代码，它将资源包中大部分（即便不是全部）特定于语言环境的信息隔离开来。

这使编写的程序可以：

  • 轻松地本地化或翻译成不同的语言
  • 一次处理多个语言环境
  • 以后可以轻松进行修改，以便支持更多的语言环境

资源包属于这样的系列，其成员共享一个公共的基本名称，但是名称中还有标识其语言环境的其他组件。例如，某个资源包系列的基本名称可能是 "MyResources"。该系列应该有一个默认资源包，其名称与其系列名相同（ "MyResources"），如果不支持指定的语言环境，则应该将此资源包用作最后的手段。然后，此系列可根据需要提供特定于语言环境的成员，例如一个名为 "MyResources_de" 的德语资源包。

一个系列中的每个资源包都包含相同的项，但是这些项已经针对该资源包所代表的语言环境进行了翻译。例如，"MyResources" 和 "MyResources_de" 可能有用在取消操作按钮上的 String。在 "MyResources" 中，String 可能包含 "Cancel"，而 "MyResources_de" 中则可能包含 "Abbrechen"。

如果不同的国家/地区有不同的资源，则可以对它们进行限定：例如，"MyResources_de_CH" 包含瑞士 (CH) 中包含德语 (de) 的对象。如果只想修改限定中的某些资源，就可以这样做。

当程序需要特定于语言环境的对象时，它使用 getBundle 方法加载 ResourceBundle 类：

 ResourceBundle myResources =
      ResourceBundle.getBundle("MyResources", currentLocale);

资源包包含键/值对。键唯一地标识了包中特定于语言环境的对象。下面是一个 ListResourceBundle 示例，它包含两个键/值对：

 public class MyResources extends ListResourceBundle {
     protected Object[][] getContents() {
         return new Object[][] {
             // LOCALIZE THE SECOND STRING OF EACH ARRAY (e.g., "OK")
             {"OkKey", "OK"},
             {"CancelKey", "Cancel"},
             // END OF MATERIAL TO LOCALIZE
        };
     }
 }
键始终为 String 类型。在此示例中，两个键是 "OkKey" 和 "CancelKey"。在上面的示例中，值也是 String 类型，即 "OK" 和 "Cancel"，但并非必须如此。值可以是任意对象类型。

可以使用适当的获取方法从资源包中获取某个对象。因为 "OkKey" 和 "CancelKey" 都是字符串，所以应该使用 getString 获取它们：

 button1 = new Button(myResources.getString("OkKey"));
 button2 = new Button(myResources.getString("CancelKey"));
所有获取方法都需要将键作为参数并返回对象（如果找到的话）。如果未找到对象，则获取方法将抛出 MissingResourceException。

除了 getString 之外，ResourceBundle 还提供了获取字符串数组的方法 getStringArray，以及用于其他任意对象类型的 getObject 方法。使用 getObject 时，必须将结果强制转换为适当的类型。例如：

 int[] myIntegers = (int[]) myResources.getObject("intList");

Java 平台提供了两个 ResourceBundle 的子类，即 ListResourceBundle 和 PropertyResourceBundle，这为创建资源提供了一种相当简单的方式。正如在前面示例中所看到的，ListResourceBundle 以键/值对的列表方式管理其资源。PropertyResourceBundle 则使用一个属性文件来管理其资源。

如果 ListResourceBundle 或 PropertyResourceBundle 无法满足需求，那么可以编写自己的 ResourceBundle 子类。子类必须重写两个方法：handleGetObject 和 getKeys()。

ResourceBundle.Control

ResourceBundle.Control 类提供通过带 ResourceBundle.Control 实例的 getBundle 工厂方法执行包加载进程所需的信息。为了启用非标准资源包格式、更改搜索策略或定义缓存参数，可以实现自己的子类。有关细节请参考类和 getBundle 工厂方法的描述。

缓存管理

getBundle 工厂方法创建的资源包实例是默认缓存的，如果资源包实例已经缓存，那么这些工厂方法将多次返回相同的资源包实例。getBundle 客户端可以清除缓存、使用生存时间值管理已缓存资源包实例的生命周期，或者指定不缓存资源包实例。有关细节请参考getBundle 工厂方法、clearCache、ResourceBundle.Control.getTimeToLive 和 ResourceBundle.Control.needsReload 的描述。

示例

下面是一个极其简单的 ResourceBundle 子类示例 MyResources，它管理两个资源（对于大量的资源，应该使用 Map）。注意，如果某个“父级”ResourceBundle 处理具有相同值的相同键（如下面的 okKey），则无需提供值。
 // default (English language, United States)
 public class MyResources extends ResourceBundle {
     public Object handleGetObject(String key) {
         if (key.equals("okKey")) return "Ok";
         if (key.equals("cancelKey")) return "Cancel";
         return null;
     }
     public Enumeration<String> getKeys() {
         return Collections.enumeration(keySet());
     }

     // Overrides handleKeySet() so that the getKeys() implementation
     // can rely on the keySet() value.
     protected Set<String> handleKeySet() {
         return new HashSet<String>(Arrays.asList("okKey", "cancelKey"));
     }
 }

 // German language
 public class MyResources_de extends MyResources {
     public Object handleGetObject(String key) {
         // don't need okKey, since parent level handles it.
         if (key.equals("cancelKey")) return "Abbrechen";
         return null;
     }
   protected Set<String> handleKeySet() {
         return new HashSet<String>(Arrays.asList("cancelKey"));
     }
 }
不必限制只使用 ResourceBundle 的单个系列。例如，可以有异常消息 ExceptionResources 的包集（ExceptionResources_fr、ExceptionResources_de 等）和窗口小部件 WidgetResource 的包集（WidgetResources_fr、WidgetResources_de 等）；可以按自己喜欢的方式分解资源。

从以下版本开始：
JDK1.1
另请参见：
ListResourceBundle, PropertyResourceBundle, MissingResourceException

嵌套类摘要
static class ResourceBundle.Control
ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。
字段摘要
protected  ResourceBundle parent
此包的父包。
构造方法摘要
ResourceBundle()
唯一的构造方法（由子类构造方法调用，通常是隐式的）。
方法摘要
static void | clearCache() 从已经使用调用者的类加载器加载的缓存中移除所有资源包。
static void | clearCache(ClassLoader loader) 从已经使用给定类加载器加载的缓存中移除所有资源包。
boolean | containsKey(String key) 确定给定 key 是否包含在此 ResourceBundle 及其父包中。
static ResourceBundle | getBundle(String baseName) 使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。
static ResourceBundle | getBundle(String baseName, Locale locale) 使用指定的基本名称、语言环境和调用者的类加载器获取资源包。
static ResourceBundle | getBundle(String baseName, Locale locale, ClassLoader loader) 使用指定的基本名称、语言环境和类加载器获取资源包。
static ResourceBundle | getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control) 使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static ResourceBundle | getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control) 使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
static ResourceBundle | getBundle(String baseName, ResourceBundle.Control control) 使用指定基本名称、默认语言环境和指定控件返回一个资源包。
abstract Enumeration<String> | getKeys() 返回键的枚举。
Locale | getLocale() 返回此资源包的语言环境。
Object | getObject(String key) 从此资源包或它的某个父包中获取给定键的对象。
String | getString(String key) 从此资源包或它的某个父包中获取给定键的字符串。
String[] | getStringArray(String key) 从此资源包或它的某个父包中获取给定键的字符串数组。
protected abstract Object | handleGetObject(String key) 从此资源包中获取给定键的对象。
protected Set<String> | handleKeySet() 返回只 包含在此 ResourceBundle 中的键的 Set。
Set<String> | keySet() 返回此 ResourceBundle 及其父包中包含的所有键的 Set。
protected void | setParent(ResourceBundle parent) 设置此包的父包。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

parent

protected ResourceBundle parent
此包的父包。当此包不包含特定资源时，由 getObject 搜索父包。

构造方法详细信息

ResourceBundle

public ResourceBundle()
唯一的构造方法（由子类构造方法调用，通常是隐式的）。

方法详细信息

getString

public final String getString(String key)
从此资源包或它的某个父包中获取给定键的字符串。调用此方法等同于调用
(String) getObject(key)。

参数：
key - 所需字符串的键
返回：
给定键的字符串
抛出：
NullPointerException - 如果 key 为 null
MissingResourceException - 如果未找到给定键的对象
ClassCastException - 如果为给定键找到的对象是不是字符串

getStringArray

public final String[] getStringArray(String key)
从此资源包或它的某个父包中获取给定键的字符串数组。调用此方法等同于调用
(String[]) getObject(key)。

参数：
key - 所需字符串数组的键
返回：
给定键的字符串数组
抛出：
NullPointerException - 如果 key 为 null
MissingResourceException - 如果未找到给定键的对象
ClassCastException - 如果为给定键找到的对象不是字符串数组

getObject

public final Object getObject(String key)
从此资源包或它的某个父包中获取给定键的对象。此方法首先尝试使用 handleGetObject 从此资源包中获取对象。如果不成功，并且父资源包不为 null，则调用父包的 getObject 方法。如果仍不成功，则抛出 MissingResourceException。

参数：
key - 所需对象的键
返回：
给定键的对象
抛出：
NullPointerException - 如果 key 为 null
MissingResourceException - 如果未找到给定键的对象

getLocale

public Locale getLocale()
返回此资源包的语言环境。调用 getBundle() 后可使用此方法来确定返回的资源包是真正对应于所请求的语言环境，还是只是一个回退。

返回：
此资源包的语言环境

setParent

protected void setParent(ResourceBundle parent)
设置此包的父包。当此包不包含特定的资源时，通过 getObject 来搜索父包。

参数：
parent - 此包的父包。

getBundle

public static final ResourceBundle getBundle(String baseName)
使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。调用此方法等同于调用
getBundle(baseName, Locale.getDefault(), this.getClass().getClassLoader())，
不同之处在于要使用 ResourceBundle 的安全特权来运行 getClassLoader()。有关搜索和实例化策略的信息，请参阅 getBundle。

参数：
baseName - 资源包的基本名称，是一个完全限定类名
返回：
具有给定基本名称和默认语言环境的资源包
抛出：
NullPointerException - 如果 baseName 为 null
MissingResourceException - 如果未找到指定基本名称的资源包

getBundle

public static final ResourceBundle getBundle(String baseName,
                                             ResourceBundle.Control control)
使用指定基本名称、默认语言环境和指定控件返回一个资源包。调用此方法等同于调用
 getBundle(baseName, Locale.getDefault(),
           this.getClass().getClassLoader(), control)，
不同之处在于要使用 ResourceBundle 的安全特权来运行 getClassLoader()。有关带 ResourceBundle.Control 的资源包加载进程的完整描述，请参阅 getBundle。

参数：
baseName - 资源包的基本名称，一个完全限定类名
control - 为资源包加载进程提供信息的控件
返回：
用于给定基本名称和默认语言环境的资源包
抛出：
NullPointerException - 如果 baseName 或 control 为 null
MissingResourceException - 如果没有找到用于指定基本名称的资源包
IllegalArgumentException - 如果给定 control 没有正确执行（例如，control.getCandidateLocales 返回 null。）注意，control 的验证是根据需要执行的。
从以下版本开始：
1.6

getBundle

public static final ResourceBundle getBundle(String baseName,
                                             Locale locale)
使用指定的基本名称、语言环境和调用者的类加载器获取资源包。调用此方法等同于调用
getBundle(baseName, locale, this.getClass().getClassLoader())，
不同之处在于要使用 ResourceBundle 的安全特权来运行 getClassLoader()。有关搜索和实例化策略的信息，请参阅 getBundle。

参数：
baseName - 资源包的基本名称，是一个完全限定类名
locale - 资源包所需的语言环境
返回：
具有给定基本名称和语言环境的资源包
抛出：
NullPointerException - 如果 baseName 或 locale 为 null
MissingResourceException - 如果未找到指定基本名称的资源包

getBundle

public static final ResourceBundle getBundle(String baseName,
                                             Locale targetLocale,
                                             ResourceBundle.Control control)
使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。调用此方法等同于调用
 getBundle(baseName, targetLocale, this.getClass().getClassLoader(),
           control)，
不同之处在于要使用 ResourceBundle 的安全特权来运行 getClassLoader()。有关带 ResourceBundle.Control 的资源包加载进程的完整描述，请参阅 getBundle。

参数：
baseName - 资源包的基本名称，一个完全限定类名
targetLocale - 资源包所需的语言环境
control - 为资源包加载进程提供信息的控件
返回：
用于给定基本名称和 locales 中某个 Locale 的资源包
抛出：
NullPointerException - 如果 baseName、locales 或 control 为 null
MissingResourceException - 如果在任何 locales 中都无法找到用于指定基本名称的资源包。
IllegalArgumentException - 如果给定 control 没有正确执行（例如，control.getCandidateLocales 返回 null。）注意，control 的验证是根据需要执行的。
从以下版本开始：
1.6

getBundle

public static ResourceBundle getBundle(String baseName,
                                       Locale locale,
                                       ClassLoader loader)
使用指定的基本名称、语言环境和类加载器获取资源包。

从概念上讲，getBundle 使用下列策略来搜索并实例化资源包：

getBundle 使用基本名称、指定的语言环境和默认语言环境（从 Locale.getDefault 获得）来生成候选包名称 序列。如果指定语言环境的语言、国家/地区和变量都是空字符串，则基本名称就是唯一的候选包名称。否则，从指定语言环境（language1、country1 和 variant1）和默认语言环境（language2、country2 和 variant2）的属性值生成下列序列：

  • baseName + "_" + language1 + "_" + country1 + "_" + variant1
  • baseName + "_" + language1 + "_" + country1
  • baseName + "_" + language1
  • baseName + "_" + language2 + "_" + country2 + "_" + variant2
  • baseName + "_" + language2 + "_" + country2
  • baseName + "_" + language2
  • baseName

省略最后部分为空字符串的候选包名称。例如，如果 country1 是一个空字符串，则省略第二个候选包名称。

然后 getBundle 在候选包名称上进行迭代，找到第一个可实例化 为实际资源包的候选包名称。对于每个候选包名称，它都试图创建资源包：

  • 首先，它试图使用候选包名称加载一个类。如果可以找到这样的类并使用指定的类加载器加载，而且此类的分配与 ResourceBundle 兼容，可通过 ResourceBundle 访问，并可以被实例化，那么 getBundle 将创建此类的一个新实例，并使用它作为结果资源包。
  • 否则，getBundle 尝试搜索属性资源文件。它从候选包名称生成一个路径名，用 "/" 替换所有的 "." 字符，并添加字符串 ".properties"。然后尝试用 ClassLoader.getResource 找到一个具有此名称的“资源”（注意，getResource 获得的“资源”与资源包中的内容没有任何关系，它只是一个数据的容器，如文件）。如果它找到一个“资源”，则会尝试用其内容创建一个新的 PropertyResourceBundle。如果成功，那么此实例就成为结果资源包。

如果未找到结果资源包，则抛出 MissingResourceException。

找到了结果资源包后，它的父链 将被实例化。getBundle 在可以获得的候选包名称中进行迭代，获得名称的方法是从结果资源包的包名称中连续移除变量、国家/地区和语言（每次都用前缀 "_"）。如上所述，省略最后部分为空字符串的候选包名称。对于每个候选包名称，都尝试实例化一个资源包，如上所述。只要能够成功，就用新的资源包调用先前已实例化资源包的 setParent 方法，除非先前已实例化的资源包已经有非 null 的父包。

getBundle 可以缓存已实例化的资源包，并且可以多次返回相同的资源包实例。

baseName 参数应该是一个完全限定类名。但是，为了与早期的版本兼容，Sun 的 Java SE Runtime Environment 并不对此进行检查，所以可通过指定路径名（使用 "/"）而不是完全限定类名（使用 "."）来访问 PropertyResourceBundle。

示例：
提供了下面的类和属性文件：

     MyResources.class
     MyResources.properties
     MyResources_fr.properties
     MyResources_fr_CH.class
     MyResources_fr_CH.properties
     MyResources_en.properties
     MyResources_es_ES.class
所有文件的内容都是有效的（也就是说 ".class" 文件是 ResourceBundle 的公共非抽象子类，".properties" 文件的语法正确）。默认的语言环境是 Locale("en", "GB")。

使用给出的语言环境参数值调用 getBundle 将实例化取自以下源的资源包：

  • Locale("fr", "CH")：结果 MyResources_fr_CH.class、父 MyResources_fr.properties、父 MyResources.class
  • Locale("fr", "FR")：结果 MyResources_fr.properties、父 MyResources.class
  • Locale("de", "DE")：结果 MyResources_en.properties、父 MyResources.class
  • Locale("en", "US")：结果 MyResources_en.properties、父 MyResources.class
  • Locale("es", "ES")：结果 MyResources_es_ES.class、父 MyResources.class

不使用 MyResources_fr_CH.properties 文件，因为它被 MyResources_fr_CH.class 隐藏了。类似地，MyResources.properties 也被 MyResources.class 隐藏了。

参数：
baseName - 资源包的基本名称，是一个完全限定类名
locale - 资源包所需的语言环境
loader - 加载资源包的类加载器
返回：
用于给定基本名称和语言环境的资源包
抛出：
NullPointerException - 如果 baseName、locale 或 loader 为 null
MissingResourceException - 如果未找到指定基本名称的资源包
从以下版本开始：
1.2

getBundle

public static ResourceBundle getBundle(String baseName,
                                       Locale targetLocale,
                                       ClassLoader loader,
                                       ResourceBundle.Control control)
使用指定基本名称、目标语言环境、类加载器和控件返回资源包。与 不带 control 参数的 getBundle 工厂方法不同，给定 control 指定查找和实例化资源包的方式。从概念上说，具有给定 control 的包加载进程是按以下步骤执行的。

  1. 此工厂方法在缓存中为指定 baseName、targetLocale 和 loader 查找资源包。如果在缓存中找到所请求的资源包实例，并且该实例及其所有父实例的生存时间都已经到期，则向调用者返回该实例。否则，此工厂方法继续进行以下加载进程。
  2. 调用 control.getFormats 方法获取生成包名称或资源名称的资源包格式。字符串 "java.class" 和 "java.properties" 分别指定基于类和基于属性的资源包。其他以 "java." 开头的字符串被保留，供以后扩展使用，不必将它们用于应用程序定义的格式。其他字符串指定应用程序定义的格式。
  3. 可以调用带有目标语言环境的 control.getCandidateLocales 方法获取用于已搜索到的资源包的候选 Locale 列表。
  4. 可以调用 control.newBundle 方法实例化针对基本包名称、候选语言环境和某种格式的 ResourceBundle。（参考下方关于缓存查找的注释。）此步骤在所有候选语言环境和格式上进行迭代，直到 newBundle 方法返回一个 ResourceBundle 实例，或者该迭代已经用完了所有的组合。例如，如果候选语言环境是 Locale("de", "DE")、Locale("de") 和 Locale("")，而格式是 "java.class" 和 "java.properties"，那么以下是用来调用 control.newBundle 的语言环境和格式组合的序列。
    语言环境
             格式
    Locale("de", "DE")
             java.class
    Locale("de", "DE") java.properties
    Locale("de") | java.class
    Locale("de") | java.properties
    Locale("")
             java.class
    Locale("") | java.properties
  5. 如果前面的步骤未找到资源包，则前进到步骤 6。如果已经找到用作基本包的包（Locale("") 的包），以及只包含 Locale("") 的候选语言环境列表，则向调用者返回该包。如果已经找到作为基本包的包，但候选语言环境列表包含 Locale("") 之外的语言环境，则暂时搁置该包并前进到步骤 6。如果找到一个不是基本包的包，则前进到步骤 7。
  6. 可调用 control.getFallbackLocale 方法获取一个回退语言环境（当前目标语言环境的替代），以尝试进一步寻找资源包。如果该方法返回一个非 null 语言环境，那么该语言环境将变成下一个目标语言环境，并且加载进程将从步骤 3 开始。否则，如果找到一个基本包并在前面的步骤 5 中暂时被搁置，那么现在要将该语言环境返回给调用者。否则抛出 MissingResourceException。
  7. 此时，我们已经找到一个不是基本包的包。如果此包在其实例化期间设置其父链，则将此包返回给调用者。否则，根据从中找到此包的候选语言环境列表，将此包的父链实例化。最后将该包返回给调用者。

在进行上述资源包加载进程期间，此工厂方法将在调用 control.newBundle 方法之前查找缓存。如果在该缓存中找到的资源包的生存时间已到期，则该工厂方法将调用 control.needsReload 方法确定是否需要重载资源包。如果需要重载，则该工厂方法将调用 control.newBundle 重载资源包。如果 control.newBundle 返回 null，则该工厂方法将在缓存中放一个伪资源包，以此作为不存在资源包的标记，从而避免后续请求所带来的查找开销。这类伪资源包同样受到 control 所指定的到期时间控制。

所有已加载的资源包都是在默认情况下被缓存的。有关细节请参阅 control.getTimeToLive。

以下是带有默认 ResourceBundle.Control 实现的包加载进程的示例。

条件：

  • 基本包的名称：foo.bar.Messages
  • 所请求的 Locale：Locale.ITALY
  • 默认 Locale：Locale.FRENCH
  • 可用的资源包：foo/bar/Messages_fr.properties 和 foo/bar/Messages.properties

首先，getBundle 试图按以下顺序加载资源包。

  • 类 foo.bar.Messages_it_IT
  • 文件 foo/bar/Messages_it_IT.properties
  • 类 foo.bar.Messages_it
  • 文件 foo/bar/Messages_it.properties
  • 类 foo.bar.Messages
  • 文件 foo/bar/Messages.properties

此时，getBundle 找到一个 foo/bar/Messages.properties，该包被搁置，因为它不是一个基本包。getBundle 调用返回 Locale.FRENCH 的 control.getFallbackLocale("foo.bar.Messages", Locale.ITALY)。接着，getBundle 试图按以下顺序加载一个包。

  • 类 foo.bar.Messages_fr
  • 文件 foo/bar/Messages_fr.properties
  • 类 foo.bar.Messages
  • 文件 foo/bar/Messages.properties

getBundle 查找 foo/bar/Messages_fr.properties 并创建一个 ResourceBundle 实例。然后，getBundle 根据候选语言环境列表设置其父链。在该列表中只有 foo/bar/Messages.properties，并且 getBundle 创建一个 ResourceBundle 实例，该实例成为用于 foo/bar/Messages_fr.properties 的实例的父实例。

参数：
baseName - 资源包的基本名称，一个完全限定类名
targetLocale - 资源包所需的语言环境
loader - 加载资源包的类加载器
control - 为资源包加载进程提供信息的控件
返回：
用于给定基本名称和语言环境的资源包
抛出：
NullPointerException - 如果 baseName、targetLocale、loader 或 control 为 null
MissingResourceException - 如果没有找到用于指定基本名称的资源包
IllegalArgumentException - 如果给定 control 没有正确执行（例如，control.getCandidateLocales 返回 null。）注意，control 的验证是根据需要执行的。
从以下版本开始：
1.6

clearCache

public static final void clearCache()
从已经使用调用者的类加载器加载的缓存中移除所有资源包。

从以下版本开始：
1.6
另请参见：
ResourceBundle.Control.getTimeToLive(String,Locale)

clearCache

public static final void clearCache(ClassLoader loader)
从已经使用给定类加载器加载的缓存中移除所有资源包。

参数：
loader - 类加载器
抛出：
NullPointerException - 如果 loader 为 null
从以下版本开始：
1.6
另请参见：
ResourceBundle.Control.getTimeToLive(String,Locale)

handleGetObject

protected abstract Object handleGetObject(String key)
从此资源包中获取给定键的对象。如果此资源包未包含给定键的对象，则返回 null。

参数：
key - 所需对象的键
返回：
给定键的对象，或者返回 null
抛出：
NullPointerException - 如果 key 为 null

getKeys

public abstract Enumeration<String> getKeys()
返回键的枚举。

返回：
此 ResourceBundle 及其父包中所包含键的 Enumeration。

containsKey

public boolean containsKey(String key)
确定给定 key 是否包含在此 ResourceBundle 及其父包中。

参数：
key - 资源 key
返回：
如果给定 key 包含在此 ResourceBundle 或其父包中，则返回 true；否则返回 false。
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.6

keySet

public Set<String> keySet()
返回此 ResourceBundle 及其父包中包含的所有键的 Set。

返回：
此 Set 及其父包中包含的所有键的 Set。
从以下版本开始：
1.6

handleKeySet

protected Set<String> handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。

默认实现返回 getKeys 方法返回的键的 Set，那些 handleGetObject 方法返回 null 的键除外。创建 Set 后，该值就被保存在此 ResourceBundle 中，以避免在下次调用中产生相同的 Set。可在子类实现中重写此方法，以便更快地进行处理。

返回：
只包含于此 ResourceBundle 中的键的 Set
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResourceBundle.Control (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ResourceBundle.Control

java.lang.Object
    继承者  java.util.ResourceBundle.Control
正在封闭类：
ResourceBundle
public static class ResourceBundle.Control
extends Object

ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。换句话说，ResourceBundle.Control 与工厂方法协作可用于加载资源包。回调方法的默认实现为工厂方法提供执行默认行为的必要信息。

除了回调方法外，还定义了 toBundleName 和 toResourceName 方法，其主要目的是为实现回调方法提供方便。但是，若要在本地化资源的组织和打包中提供不同的约定，也可以重写 toBundleName 方法。toResourceName 方法是 final 方法，以避免使用错误的资源和类名称分隔符。

两个工厂方法 getControl(List) 和 getNoFallbackControl(List) 都提供 ResourceBundle.Control 实例，这些实例实现默认包加载进程的常见变量。

在相同基本包的所有 ResourceBundle.getBundle 调用中，getFormats 方法返回的格式和 getCandidateLocales 方法返回的候选语言环境必须一致。否则，ResourceBundle.getBundle 方法返回意料之外的包。例如，如果 getFormats 方法在第一次调用 ResourceBundle.getBundle 时只返回 "java.class"，第二次调用时只返回 "java.properties"，那么第二次调用返回的基于类的包将是在第一次调用过程中缓存的那个包。

如果 ResourceBundle.Control 实例被多个线程同时使用，则它必须是线程安全的。ResourceBundle.getBundle 不会同时调用 ResourceBundle.Control 方法。方法的默认实现是线程安全的。

应用程序可以指定 getControl 工厂方法返回的 ResourceBundle.Control 实例，也可以指定从 ResourceBundle.Control 子类创建的 ResourceBundle.Control 实例，以自定义包加载进程。下面是对默认包加载进程进行更改的示例。

示例 1

以下代码让 ResourceBundle.getBundle 只查找基于属性的资源。

import java.util.*;
import static java.util.ResourceBundle.Control.*;
 ...
ResourceBundle bundle =
ResourceBundle.getBundle("MyResources", new Locale("fr", "CH"),
ResourceBundle.Control.getControl(FORMAT_PROPERTIES));
给定 ResourceBundle.getBundle 描述的示例中的资源包，此 ResourceBundle.getBundle 调用加载 MyResources_fr_CH.properties，它的父属性是 MyResources_fr.properties，而后者的父属性是 MyResources.properties。(没有隐藏 MyResources_fr_CH.properties，但隐藏了 MyResources_fr_CH.class。）

示例 2

下面是使用 Properties.loadFromXML 加载基于 XML 的包的示例。

ResourceBundle rb = ResourceBundle.getBundle("Messages",
new ResourceBundle.Control() {
public List<String> getFormats(String baseName) {
if (baseName == null)
throw new NullPointerException();
return Arrays.asList("xml");
         }
public ResourceBundle newBundle(String baseName,
Locale locale,
String format,
ClassLoader loader,
boolean reload)
throws IllegalAccessException,
InstantiationException,
IOException {
if (baseName == null || locale == null
|| format == null || loader == null)
throw new NullPointerException();
ResourceBundle bundle = null;
if (format.equals("xml")) {
String bundleName = toBundleName(baseName, locale);
String resourceName = toResourceName(bundleName, format);
InputStream stream = null;
if (reload) {
URL url = loader.getResource(resourceName);
if (url != null) {
URLConnection connection = url.openConnection();
if (connection != null) {
// Disable caches to get fresh data for
// reloading.
connection.setUseCaches(false);
stream = connection.getInputStream();
                         }
                     }
} else {
stream = loader.getResourceAsStream(resourceName);
                 }
if (stream != null) {
BufferedInputStream bis = new BufferedInputStream(stream);
bundle = new XMLResourceBundle(bis);
bis.close();
                 }
             }
return bundle;
         }
     });

 ...

private static class XMLResourceBundle extends ResourceBundle {
private Properties props;
XMLResourceBundle(InputStream stream) throws IOException {
props = new Properties();
props.loadFromXML(stream);
     }
protected Object handleGetObject(String key) {
return props.getProperty(key);
     }
public Enumeration<String> getKeys() {
         ...
     }
 }

从以下版本开始：
1.6

字段摘要
static List<String> | FORMAT_CLASS 包含 "java.class" 的纯类 (class-only) 格式 List。
static List<String> | FORMAT_DEFAULT 默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。
static List<String> | FORMAT_PROPERTIES 包含 "java.properties" 的纯属性 (properties-only) 格式 List。
static long | TTL_DONT_CACHE 不缓存已加载资源包实例的生存时间常量。
static long | TTL_NO_EXPIRATION_CONTROL 对缓存中已加载资源包实例禁用到期控制的生存时间常量。
构造方法摘要
protected ResourceBundle.Control()
唯一的构造方法。
方法摘要
List<Locale> | getCandidateLocales(String baseName, Locale locale) 返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。
static ResourceBundle.Control | getControl(List<String> formats) 返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。
Locale | getFallbackLocale(String baseName, Locale locale) 返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。
List<String> | getFormats(String baseName) 返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。
static ResourceBundle.Control | getNoFallbackControl(List<String> formats) 返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。
long | getTimeToLive(String baseName, Locale locale) 返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。
boolean | needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime) 确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
ResourceBundle | newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload) 针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。
String | toBundleName(String baseName, Locale locale) 将给定 baseName 和 locale 转换为包名称。
String | toResourceName(String bundleName, String suffix) 将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FORMAT_DEFAULT

public static final List<String> FORMAT_DEFAULT
默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。此 List 不可修改。

另请参见：
getFormats(String)

FORMAT_CLASS

public static final List<String> FORMAT_CLASS
包含 "java.class" 的纯类 (class-only) 格式 List。此 List 不可修改。

另请参见：
getFormats(String)

FORMAT_PROPERTIES

public static final List<String> FORMAT_PROPERTIES
包含 "java.properties" 的纯属性 (properties-only) 格式 List。此 List 不可修改。

另请参见：
getFormats(String)

TTL_DONT_CACHE

public static final long TTL_DONT_CACHE
不缓存已加载资源包实例的生存时间常量。

另请参见：
getTimeToLive(String, Locale), 常量字段值

TTL_NO_EXPIRATION_CONTROL

public static final long TTL_NO_EXPIRATION_CONTROL
对缓存中已加载资源包实例禁用到期控制的生存时间常量。

另请参见：
getTimeToLive(String, Locale), 常量字段值
构造方法详细信息

ResourceBundle.Control

protected ResourceBundle.Control()
唯一的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

getControl

public static final ResourceBundle.Control getControl(List<String> formats)
返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。formats 必须等于 FORMAT_PROPERTIES、FORMAT_CLASS 或 FORMAT_DEFAULT 之一。此方法返回的 ResourceBundle.Control 实例是单独且线程安全的。

指定 FORMAT_DEFAULT 等效于实例化 ResourceBundle.Control 类，区别在于此方法返回一个单独实例。

参数：
formats - ResourceBundle.Control.getFormats 方法要返回的格式
返回：
支持指定 formats 的 ResourceBundle.Control
抛出：
NullPointerException - 如果 formats 为 null
IllegalArgumentException - 如果 formats 未知

getNoFallbackControl

public static final ResourceBundle.Control getNoFallbackControl(List<String> formats)
返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。formats 必须等于 FORMAT_PROPERTIES、FORMAT_CLASS 或 FORMAT_DEFAULT 之一。此方法返回的 ResourceBundle.Control 实例是单独且线程安全的。

参数：
formats - ResourceBundle.Control.getFormats 方法要返回的格式
返回：
支持指定 formats 的 ResourceBundle.Control，不支持任何回退 Locale
抛出：
NullPointerException - 如果 formats 为 null
IllegalArgumentException - 如果 formats 未知

getFormats

public List<String> getFormats(String baseName)
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。ResourceBundle.getBundle 工厂方法尝试使用按列表指定顺序的格式加载资源包。此方法返回的列表必须至少有一个 String。对于基于类的资源包，预定义的格式是 "java.class"，对于 properties-based 资源包，预定义的格式是 "java.properties"。以 "java." 开头的字符串是为将来扩展而保留的，不得被应用程序定义的格式使用。

不必返回一个不可变的（不可修改的） List。但是，返回的 List 在由 getFormats 返回后不得改变。

默认实现返回 FORMAT_DEFAULT，以便 ResourceBundle.getBundle 工厂方法首先查找基于类的资源包，然后查找基于属性的资源包。

参数：
baseName - 资源包的基本名称，是一个完全限定类名
返回：
String 的 List，它包含加载资源包的格式。
抛出：
NullPointerException - 如果 baseName 为 null
另请参见：
FORMAT_DEFAULT, FORMAT_CLASS, FORMAT_PROPERTIES

getCandidateLocales

public List<Locale> getCandidateLocales(String baseName,
                                        Locale locale)
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。在工厂方法每次尝试为目标 Locale 查找资源包时，由 ResourceBundle.getBundle 工厂方法调用此方法。

如果存在对应于候选语言环境的资源包，并且它们的父包不是由已加载资源包本身定义的，那么候选语言环境序列还将对应于运行时资源查找路径（也称为父链）。如果需要让基本包作为父链的终端，那么列表的最后一个元素必须是根语言环境。

如果给定语言环境等于 Locale.ROOT（根语言环境），则必须返回一个只包含根 Locale 的 List。在这种情况下，ResourceBundle.getBundle 工厂方法只将基本包作为所得资源包加载。

不必返回一个不可变的（不可修改的） List。但是，返回的 List 在由 getCandidateLocales 返回之后不得改变。

默认实现按照以下次序返回包含 Locale 的 List：

Locale(language, country, variant)
Locale(language, country)
Locale(language)
Locale.ROOT
其中 language、country 和 variant 分别指语言、国家/地区和给定 locale 的变量值。省略最后部分的值为空字符串的语言环境。

默认实现使用 ArrayList，重写实现可以在将它返回给调用者之前对它进行修改。但是，子类在它被 getCandidateLocales 返回之后不得修改它。

例如，如果给定 baseName 为 "Messages"，给定 locale 为 Locale("ja", "", "XX")，则返回 Locale 的 List 为：

Locale("ja", "", "XX")
Locale("ja")
Locale.ROOT
而且，如果找到了 "ja" 和 "" Locale 的资源包，则运行时资源查找路径（父链）为：
Messages_ja -> Messages

参数：
baseName - 资源包的基本名称，是一个完全限定类名
locale - 资源包需要的语言环境
返回：
为给定 locale 的候选 Locale List
抛出：
NullPointerException - 如果 baseName 或 locale 为 null

getFallbackLocale

public Locale getFallbackLocale(String baseName,
                                Locale locale)
返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。每次找不到任何对应于 baseName 和 locale 的所得资源包时（其中 locale 是 ResourceBundle.getBundle 的参数，或者此方法以前返回的回退语言环境），从工厂方法调用此方法。

如果不需要进一步的回退搜索，那么该方法返回 null。

如果给定 locale 不是默认的，那么默认实现返回默认 Locale。否则，返回 null。

参数：
baseName - 资源包的基本名称，是一个完全限定类名，ResourceBundle.getBundle 无法为其找到任何资源包（基本包除外）
locale - ResourceBundle.getBundle 无法为其找到任何资源包（基本包除外）的 Locale
返回：
回退搜索的 Locale；如果不需要进一步的搜索，则返回 null。
抛出：
NullPointerException - 如果 baseName 或 locale 为 null

newBundle

public ResourceBundle newBundle(String baseName,
                                Locale locale,
                                String format,
                                ClassLoader loader,
                                boolean reload)
                         throws IllegalAccessException,
                                InstantiationException,
                                IOException
针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。如果对于给定参数没有任何可用的资源包，则此方法返回 null。如果资源包由于无法预料的错误而不能被实例化，则必须通过抛出 Error 或 Exception 来报告错误，而不是简单地返回 null。

如果 reload 标志为 true，则它表示由于以前加载的资源包已到期而调用此方法。

默认实现按如下方法实例化 ResourceBundle。

  • 通过调用 toBundleName(baseName, locale) 获取包名称。
  • 如果 format 为 "java.class"，则通过调用 ClassLoader.loadClass(String) 加载由包名称指定的 Class。然后，通过调用 Class.newInstance() 实例化 ResourceBundle。注意，对于加载此默认实现中基于类的资源包将忽略 reload 标志。
  • 如果 format 为 "java.properties"，则调用 toResourceName(bundlename, "properties") 获取资源名称。如果 reload 为 true，则调用 load.getResource 获取用于创建 URLConnection 的 URL。此 URLConnection 用于禁用底层资源加载层的缓存，并获取 InputStream。否则，调用 loader.getResourceAsStream 获取 InputStream。然后，构造一个带有 InputStream 的 PropertyResourceBundle。
  • 如果 format 既不是 "java.class" 也不是 "java.properties"，则抛出 IllegalArgumentException。

参数：
baseName - 资源包的基本名称，是一个完全限定类名
locale - 应为其实例化资源包的语言环境
format - 要加载的资源包格式
loader - 要用于加载包的 ClassLoader
reload - 用于表示重新加载包的标志；如果重新加载到期的资源包，则为 true，否则为 false
返回：
资源包实例；如果未找到任何实例，则返回 null。
抛出：
NullPointerException - 如果 bundleName、locale、format 或 loader 为 null，或者 toBundleName 返回 null
IllegalArgumentException - 如果 format 未知，或者为给定参数找到的资源包含错误数据。
ClassCastException - 如果已加载类无法被强制转换为 ResourceBundle
IllegalAccessException - 如果类或其 null 构造方法无法访问。
InstantiationException - 如果类的实例化由于某些其他原因而失败。
ExceptionInInitializerError - 如果此方法引起的初始化失败。
SecurityException - 如果安全管理器存在并且拒绝创建新实例。有关详细信息，请参阅 Class.newInstance()。
IOException - 如果在使用任意 I/O 操作读取资源时发生错误

getTimeToLive

public long getTimeToLive(String baseName,
                          Locale locale)
返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。正生存时间值指定不根据构造包的源数据进行验证的情况下，包可以在缓存中保留的毫秒数。值为 0 表示每次从缓存中获取包时必须进行验证。TTL_DONT_CACHE 指定已加载资源包不放入缓存。TTL_NO_EXPIRATION_CONTROL 指定已加载资源包放入缓存且没有到期控制。

到期只通过 ResourceBundle.getBundle 工厂方法影响包加载进程。也就是说，如果该工厂方法发现缓存中的资源包已到期，那么该工厂方法将调用 needsReload 方法确定是否需要重新加载资源包。如果 needsReload 返回 true，则从缓存中移除缓存的资源包实例。否则，实例将保留在缓存中，用此方法返回的新 TTL 值进行更新。

所有缓存的资源包都会由于运行时环境的内存约束而从缓存中移除。返回一个大的正值并不意味着锁定缓存中已加载的资源包。

默认实现返回 TTL_NO_EXPIRATION_CONTROL。

参数：
baseName - 为其指定到期值的资源包基本名称。
locale - 为其指定到期值的资源包语言环境。
返回：
时间（0 或从缓存时间到现在的正毫秒数），表示获取缓存中已加载资源包的到期时间；TTL_NO_EXPIRATION_CONTROL 表示禁用到期控制；TTL_DONT_CACHE 表示禁用缓存。
抛出：
NullPointerException - 如果 baseName 或 locale 为 null

needsReload

public boolean needsReload(String baseName,
                           Locale locale,
                           String format,
                           ClassLoader loader,
                           ResourceBundle bundle,
                           long loadTime)
确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。如果需要重载，那么此方法返回 true，否则返回 false。loadTime 是从 Calendar Epoch 到现在的毫秒数。 调用 ResourceBundle.getBundle 工厂方法在用于其当前调用的 ResourceBundle.Control 实例上调用此方法，而不是在最初加载资源包的调用中所使用的实例上调用此方法。

默认实现将 loadTime 和资源包源数据上一次的修改时间进行比较。如果确定自 loadTime 以来修改过源数据，则返回 true。否则，返回 false。如果给定 format 不是默认格式 "java.class" 或 "java.properties" 之一，此实现假定它是与其文件后缀相同的字符串。

参数：
baseName - 资源包的基本名称，是一个完全限定类名
locale - 应为其实例化资源包的语言环境
format - 要加载的资源包格式
loader - 要用来加载包的 ClassLoader
bundle - 缓存中已到期的资源包实例
loadTime - bundle 被加载并放入缓存的时间
返回：
如果到期的包需要重新加载，则返回 true；否则返回 false。
抛出：
NullPointerException - 如果 baseName、locale、format、loader 或 bundle 为 null

toBundleName

public String toBundleName(String baseName,
                           Locale locale)
将给定 baseName 和 locale 转换为包名称。此方法从 newBundle 和 needsReload 方法的默认实现调用。

此实现返回以下值：

baseName + "_" + language + "_" + country + "_" + variant
其中 language、country 和 variant 分别是语言、国家/地区和 locale 的变量值。为空字符串的最后部分的值与 '_' 之前的部分一起被忽略。如果所有值都为空字符串，则返回 baseName。

例如，如果 baseName 为 "baseName"、locale 为 Locale("ja", "", "XX")，则返回 "baseName_ja_ _XX"。如果给定语言环境为 Locale("en")，则返回 "baseName_en"。

重写此方法允许应用程序在本地化资源的组织和打包中使用不同的约定。

参数：
baseName - 资源包的基本名称，是一个完全限定类名
locale - 应当为其加载资源包的语言环境
返回：
资源包的包名称
抛出：
NullPointerException - 如果 baseName 或 locale 为 null

toResourceName

public final String toResourceName(String bundleName,
                                   String suffix)
将给定 bundleName 转换为 ClassLoader.getResource 方法要求的形式：用 '/' 替换 bundleName 中出现的所有 '.'，并添加一个 '.' 和给定的文件 suffix。例如，如果 bundleName 为 "foo.bar.MyResources_ja_JP"、suffix 为 "properties"，则返回 "foo/bar/MyResources_ja_JP.properties"。

参数：
bundleName - 包名称
suffix - 文件类型后缀
返回：
已转换的资源名称
抛出：
NullPointerException - 如果 bundleName 或 suffix 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Scanner (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Scanner

java.lang.Object
    继承者  java.util.Scanner
所有已实现的接口：
Iterator<String>
public final class Scanner
extends Object
implements Iterator<String>

一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。

Scanner 使用分隔符模式将其输入分解为标记，默认情况下该分隔符模式与空白匹配。然后可以使用不同的 next 方法将得到的标记转换为不同类型的值。

例如，以下代码使用户能够从 System.in 中读取一个数：

     Scanner sc = new Scanner(System.in);
     int i = sc.nextInt();

再看一个例子，以下代码使 long 类型可以通过 myNumbers 文件中的项分配：

      Scanner sc = new Scanner(new File("myNumbers"));
      while (sc.hasNextLong()) {
          long aLong = sc.nextLong();
      }

扫描器还可以使用不同于空白的分隔符。下面是从一个字符串读取若干项的例子：

     String input = "1 fish 2 fish red fish blue fish";
     Scanner s = new Scanner(input).useDelimiter("\\s*fish\\s*");
     System.out.println(s.nextInt());
     System.out.println(s.nextInt());
     System.out.println(s.next());
     System.out.println(s.next());
     s.close();

输出为：

     1
     2
     red
     blue

以下代码使用正则表达式同时解析所有的 4 个标记，并可以产生与上例相同的输出结果：

     String input = "1 fish 2 fish red fish blue fish";
     Scanner s = new Scanner(input);
     s.findInLine("(\\d+) fish (\\d+) fish (\\w+) fish (\\w+)");
     MatchResult result = s.match();
     for (int i=1; i<=result.groupCount(); i++)
         System.out.println(result.group(i));
     s.close();

扫描器所使用的默认空白分隔符通过 Character.isWhitespace 来识别。不管以前是否更改，reset() 方法将把扫描器分隔符的值重置为默认空白分隔符。

扫描操作可能被阻塞，而等待信息的输入。

next() 和 hasNext() 方法及其基本类型 companion 方法（如 nextInt() 和 hasNextInt()）首先跳过与分隔符模式匹配的输入，然后尝试返回下一个标记。在等待更多输入时 hasNext 和 next 方法都可能阻塞。hasNext 方法是否阻塞与其相关的 next 方法是否阻塞无关。

findInLine(java.lang.String)、findWithinHorizon(java.lang.String, int) 和 skip(java.util.regex.Pattern) 方法的执行与分隔符模式无关。这些方法会尝试匹配与输入中的分隔符无关的指定模式，因此可用于分隔符无关的特殊环境中。在等待更多输入时这些方法可能阻塞。

当某一扫描器抛出 InputMismatchException 时，该扫描器不会传递导致该异常的标记，因此可以通过其他某种方法来获取或跳过它。

对于某些类型的分隔模式，可能返回空标记。例如，"\\s+" 模式不会返回空标记，因为它与该分隔符的多个实例匹配。而分隔模式 "\\s" 可能返回空标记，因为它一次只传递一个空格。

扫描器可以从实现 Readable 接口的任何对象读取文本。如果对底层 readable 的 Readable.read(java.nio.CharBuffer) 方法的调用抛出 IOException，则扫描器认为已经到达了输入的结尾。底层 readable 最新抛出的 IOException 可以通过 ioException() 方法获取。

如果 Scanner 关闭，且其输入源实现 Closeable 接口，则该输入源也将关闭。

若没有外部同步，则 Scanner 的多线程使用是不安全的。

除非另行说明，否则将一个 null 参数传递到 Scanner 的任何一个方法中都将抛出 NullPointerException。

默认情况下扫描器会将数字解释为十进制形式，除非已经使用 useRadix(int) 方法设置了不同的基数。不管以前是否更改，reset() 方法将把扫描器的基数重置为10 。

本地化数字

此类的一个实例能够以标准格式以及扫描器语言环境的格式扫描数字。扫描器的 初始语言环境 是 Locale.getDefault() 方法返回的值；它可以通过 useLocale(java.util.Locale) 方法更改。不管以前是否更改，reset() 方法将把扫描器的语言环境重置为初始语言环境。

本地化格式是根据以下参数定义的，对于某一特定语言环境来说，这些参数取自该语言环境的 DecimalFormat 对象 df，及其 DecimalFormatSymbols 对象 dfs。

LocalGroupSeparator | 用于分隔数千个组的字符，即 dfs. getGroupingSeparator()
LocalDecimalSeparator | 用于小数点的字符，即 dfs. getDecimalSeparator()
LocalPositivePrefix | 出现在正数前的字符串（可以为空），即 df. getPositivePrefix()
LocalPositiveSuffix | 出现在正数后的字符串（可以为空），即 df. getPositiveSuffix()
LocalNegativePrefix | 出现在负数前的字符串（可以为空），即 df. getNegativePrefix()
LocalNegativeSuffix | 出现在负数后的字符串（可以为空），即 df. getNegativeSuffix()
LocalNaN | 表示浮点值的非数字的字符串，即 dfs. getNaN()
LocalInfinity | 表示浮点值的无穷大的字符串，即 dfs. getInfinity()

数字语法

可通过此类的一个实例解析为数字的字符串是根据以下正则表达式语法指定的，在这种情况下 Rmax 是正在使用的基数中的最高数字（例如，在基数 10 中 Rmax 为 9）。

NonASCIIDigit :: = 非 ASCII 字符 c，对于它，Character.isDigit (c) 返回 true
Non0Digit :: = [1-Rmax] | NonASCIIDigit
Digit :: = [0-Rmax] | NonASCIIDigit
GroupedNumeral ::
= ( | Non0Digit Digit? Digit?
 | ( LocalGroupSeparator Digit Digit Digit )+ )
Numeral :: = ( ( Digit+ ) | GroupedNumeral )
Integer :: = ( [-+]? ( Numeral ) )
| LocalPositivePrefix Numeral LocalPositiveSuffix
| LocalNegativePrefix Numeral LocalNegativeSuffix
DecimalNumeral :: = Numeral
| Numeral LocalDecimalSeparator Digit*
| LocalDecimalSeparator Digit+
Exponent :: = ( [eE] [+-]? Digit+ )
Decimal :: = ( [-+]? DecimalNumeral Exponent? )
| LocalPositivePrefix DecimalNumeral LocalPositiveSuffix Exponent?
| LocalNegativePrefix DecimalNumeral LocalNegativeSuffix Exponent?
HexFloat :: = [-+]? 0[xX][0-9a-fA-F]*\.[0-9a-fA-F]+ ([pP][-+]?[0-9]+)?
NonNumber :: = NaN | LocalNan | Infinity | LocalInfinity
SignedNonNumber :: = ( [-+]? NonNumber )
| LocalPositivePrefix NonNumber LocalPositiveSuffix
| LocalNegativePrefix NonNumber LocalNegativeSuffix
Float :: = Decimal
| HexFloat
| SignedNonNumber

上面正则表达式中的空白没有意义。

从以下版本开始：
1.5

构造方法摘要
Scanner(File source)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(File source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定文件扫描的。
Scanner(InputStream source)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(InputStream source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。
Scanner(Readable source)
构造一个新的 Scanner，它生成的值是从指定源扫描的。
Scanner(ReadableByteChannel source)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
Scanner(ReadableByteChannel source, String charsetName)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。
Scanner(String source)
构造一个新的 Scanner，它生成的值是从指定字符串扫描的。
方法摘要
 void close()
关闭此扫描器。
 Pattern delimiter()
返回此 Scanner 当前正在用于匹配分隔符的 Pattern。
 String findInLine(Pattern pattern)
试图在忽略分隔符的情况下查找下一个指定模式。
 String findInLine(String pattern)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。
 String findWithinHorizon(Pattern pattern, int horizon)
试图查找下一个指定模式。
 String findWithinHorizon(String pattern, int horizon)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。
 boolean hasNext()
如果此扫描器的输入中有另一个标记，则返回 true。
 boolean hasNext(Pattern pattern)
如果下一个完整标记与指定模式匹配，则返回 true。
 boolean hasNext(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回 true。
 boolean hasNextBigDecimal()
如果通过使用 nextBigDecimal() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigDecimal，则返回 true。
 boolean hasNextBigInteger()
如果通过使用 nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigInteger 值，则返回 true。
 boolean hasNextBigInteger(int radix)
如果通过使用 nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 BigInteger 值，则返回 true。
 boolean hasNextBoolean()
如果通过使用一个从字符串 "true|false" 创建的大小写敏感的模式，此扫描器输入信息中的下一个标记可以解释为一个布尔值，则返回 true。
 boolean hasNextByte()
如果通过使用 nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个字节值，则返回 true。
 boolean hasNextByte(int radix)
如果通过使用 nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个字节值，则返回 true。
 boolean hasNextDouble()
如果通过使用 nextDouble() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 double 值，则返回 true。
 boolean hasNextFloat()
如果通过使用 nextFloat() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 float 值，则返回 true。
 boolean hasNextInt()
如果通过使用 nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 int 值，则返回 true。
 boolean hasNextInt(int radix)
如果通过使用 nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 int 值，则返回 true。
 boolean hasNextLine()
如果在此扫描器的输入中存在另一行，则返回 true。
 boolean hasNextLong()
如果通过使用 nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 long 值，则返回 true。
 boolean hasNextLong(int radix)
如果通过使用 nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 long 值，则返回 true。
 boolean hasNextShort()
如果通过使用 nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 short 值，则返回 true。
 boolean hasNextShort(int radix)
如果通过使用 nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 short 值，则返回 true。
 IOException ioException()
返回此 Scanner 的底层 Readable 最后抛出的 IOException。
 Locale locale()
返回此扫描器的语言环境。
 MatchResult match()
返回此扫描器所执行的最后扫描操作的匹配结果。
 String next()
查找并返回来自此扫描器的下一个完整标记。
 String next(Pattern pattern)
如果下一个标记与指定模式匹配，则返回下一个标记。
 String next(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。
 BigDecimal nextBigDecimal()
将输入信息的下一个标记扫描为一个 BigDecimal。
 BigInteger nextBigInteger()
将输入信息的下一个标记扫描为一个 BigInteger。
 BigInteger nextBigInteger(int radix)
将输入信息的下一个标记扫描为一个 BigInteger。
 boolean nextBoolean()
扫描解释为一个布尔值的输入标记并返回该值。
 byte nextByte()
将输入信息的下一个标记扫描为一个 byte。
 byte nextByte(int radix)
将输入信息的下一个标记扫描为一个 byte。
 double nextDouble()
将输入信息的下一个标记扫描为一个 double。
 float nextFloat()
将输入信息的下一个标记扫描为一个 float。
 int nextInt()
将输入信息的下一个标记扫描为一个 int。
 int nextInt(int radix)
将输入信息的下一个标记扫描为一个 int。
 String nextLine()
此扫描器执行当前行，并返回跳过的输入信息。
 long nextLong()
将输入信息的下一个标记扫描为一个 long。
 long nextLong(int radix)
将输入信息的下一个标记扫描为一个 long。
 short nextShort()
将输入信息的下一个标记扫描为一个 short。
 short nextShort(int radix)
将输入信息的下一个标记扫描为一个 short。
 int radix()
返回此扫描器的默认基数。
 void remove()
Iterator 的这种实现不支持移除操作。
 Scanner reset()
重置此扫描器。
 Scanner skip(Pattern pattern)
在忽略分隔符的情况下跳过与指定模式匹配的输入信息。
 Scanner skip(String pattern)
跳过与从指定字符串构造的模式匹配的输入信息。
 String toString()
返回此 Scanner 的字符串表示形式。
 Scanner useDelimiter(Pattern pattern)
将此扫描器的分隔模式设置为指定模式。
 Scanner useDelimiter(String pattern)
将此扫描器的分隔模式设置为从指定 String 构造的模式。
 Scanner useLocale(Locale locale)
将此扫描器的语言环境设置为指定的语言环境。
 Scanner useRadix(int radix)
将此扫描器的默认基数设置为指定基数。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Scanner

public Scanner(Readable source)
构造一个新的 Scanner，它生成的值是从指定源扫描的。

参数：
source - 实现 Readable 接口的字符源

Scanner

public Scanner(InputStream source)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。取自该流的字节通过底层平台的默认字符集转换成字符。

参数：
source - 要扫描的输入流

Scanner

public Scanner(InputStream source,
               String charsetName)
构造一个新的 Scanner，它生成的值是从指定的输入流扫描的。来自该流的字节通过指定字符集转换成字符。

参数：
source - 要扫描的输入流
charsetName - 用于将来自该流的字节转换成要扫描的字符的编码类型
抛出：
IllegalArgumentException - 如果指定字符集不存在

Scanner

public Scanner(File source)
        throws FileNotFoundException
构造一个新的 Scanner，它生成的值是从指定文件扫描的。来自该文件的字节通过底层平台的默认字符集转换成字符。

参数：
source - 要扫描的文件
抛出：
FileNotFoundException - 如果源文件未找到

Scanner

public Scanner(File source,
               String charsetName)
        throws FileNotFoundException
构造一个新的 Scanner，它生成的值是从指定文件扫描的。来自该文件的字节通过指定字符集转换成字符。

参数：
source - 要扫描的文件
charsetName - 用于将来自该文件的字节转换成要扫描的字符的编码类型
抛出：
FileNotFoundException - 如果源文件未找到
IllegalArgumentException - 如果指定的编码未找到

Scanner

public Scanner(String source)
构造一个新的 Scanner，它生成的值是从指定字符串扫描的。

参数：
source - 要扫描的字符串

Scanner

public Scanner(ReadableByteChannel source)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。来自该源的字节通过底层平台的默认字符集转换成字符。

参数：
source - 要扫描的信道

Scanner

public Scanner(ReadableByteChannel source,
               String charsetName)
构造一个新的 Scanner，它生成的值是从指定信道扫描的。来自该源的字节通过指定字符集转换成字符。

参数：
source - 要扫描的信道
charsetName - 用于将来自该信道的字节转换成要扫描的字符的编码类型
抛出：
IllegalArgumentException - 如果指定字符集不存在
方法详细信息

close

public void close()
关闭此扫描器。

如果此扫描器尚未关闭，并且其底层 readable 也实现 Closeable 接口，则该 readable 的 close 方法将被调用。如果此扫描器已经关闭，则调用此方法无效。

在扫描器关闭后执行搜索操作将导致 IllegalStateException。

ioException

public IOException ioException()
返回此 Scanner 的底层 Readable 最后抛出的 IOException。如果不存在这样的异常，则此方法返回 null。

返回：
此扫描器的 readable 最后抛出的异常

delimiter

public Pattern delimiter()
返回此 Scanner 当前正在用于匹配分隔符的 Pattern。

返回：
此扫描器的分隔模式。

useDelimiter

public Scanner useDelimiter(Pattern pattern)
将此扫描器的分隔模式设置为指定模式。

参数：
pattern - 分隔模式
返回：
此扫描器

useDelimiter

public Scanner useDelimiter(String pattern)
将此扫描器的分隔模式设置为从指定 String 构造的模式。

此方法调用 useDelimiter(pattern) 的行为与调用 useDelimiter(Pattern.compile(pattern)) 完全相同。

调用 reset() 方法将把扫描器的分隔符设置为 默认。

参数：
pattern - 指定分隔模式的字符串
返回：
此扫描器

locale

public Locale locale()
返回此扫描器的语言环境。

扫描器的语言环境会影响其与正则表达式匹配的默认基元的许多元素；参见上面的本地化数字。

返回：
此扫描器的语言环境

useLocale

public Scanner useLocale(Locale locale)
将此扫描器的语言环境设置为指定的语言环境。

扫描器的语言环境会影响其与正则表达式匹配的默认基元的许多元素；参见上面的本地化数字。

调用 reset() 方法将把扫描器的语言环境设置为初始语言环境。

参数：
locale - 指定要使用的语言环境的字符串
返回：
此扫描器

radix

public int radix()
返回此扫描器的默认基数。

扫描器的基数会影响其与正则表达式匹配的默认数的元素；参见上面的本地化数字。

返回：
此扫描器的默认基数

useRadix

public Scanner useRadix(int radix)
将此扫描器的默认基数设置为指定基数。

扫描器的基数会影响其与正则表达式匹配的默认数的元素；参见上面的本地化数字。

如果该基数小于 Character.MIN_RADIX 或大于 Character.MAX_RADIX，则抛出 IllegalArgumentException。

调用 reset() 方法将把扫描器的基数设置为 10。

参数：
radix - 扫描数时要使用的基数
返回：
此扫描器
抛出：
IllegalArgumentException - 如果基数超出范围

match

public MatchResult match()
返回此扫描器所执行的最后扫描操作的匹配结果。如果未执行匹配操作，或者最后的匹配操作失败，则此方法抛出 IllegalStateException。

如果 Scanner 的不同 next 方法执行结束时未抛出异常，则它们会给出一个匹配结果。例如，调用了 nextInt() 方法（它返回一个 int）后，此方法返回一个 MatchResult，作为搜索上述 Integer 正则表达式的结果。类似地，如果 findInLine(java.lang.String)、findWithinHorizon(java.lang.String, int) 和 skip(java.util.regex.Pattern) 方法的调用成功，则它们会给出一个匹配结果。

返回：
最后一次匹配操作的匹配结果
抛出：
IllegalStateException - 如果未给出匹配结果

toString

public String toString()

返回此 Scanner 的字符串表示形式。Scanner 的字符串表示形式包含了对调试可能有用的信息。没有指定确切格式。

覆盖：
类 Object 中的 toString
返回：
此扫描器的字符串表示形式。

hasNext

public boolean hasNext()
如果此扫描器的输入中有另一个标记，则返回 true。在等待要扫描的输入时，此方法可能阻塞。扫描器将不执行任何输入。

指定者：
接口 Iterator<String> 中的 hasNext
返回：
当且仅当此扫描器有另一个标记时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭
另请参见：
Iterator

next

public String next()
查找并返回来自此扫描器的下一个完整标记。完整标记的前后是与分隔模式匹配的输入信息。即使以前调用 hasNext() 返回了 true，在等待要扫描的输入时此方法也可能阻塞。

指定者：
接口 Iterator<String> 中的 next
返回：
下一个标记
抛出：
NoSuchElementException - 如果没有更多标记可用
IllegalStateException - 如果此扫描器已关闭
另请参见：
Iterator

remove

public void remove()
Iterator 的这种实现不支持移除操作。

指定者：
接口 Iterator<String> 中的 remove
抛出：
UnsupportedOperationException - 如果调用此方法。
另请参见：
Iterator

hasNext

public boolean hasNext(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回 true。扫描器不执行任何输入。

此方法调用 hasNext(pattern) 的行为与调用 hasNext(Pattern.compile(pattern)) 完全相同。

参数：
pattern - 指定要扫描的模式的字符串
返回：
当且仅当此扫描器有另一个标记与指定模式匹配时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

next

public String next(String pattern)
如果下一个标记与从指定字符串构造的模式匹配，则返回下一个标记。如果匹配操作成功，则扫描器执行与该模式匹配的输入。

此方法调用 next(pattern) 的行为与调用 next(Pattern.compile(pattern)) 完全相同。

参数：
pattern - 指定要扫描的模式的字符串
返回：
下一标记
抛出：
NoSuchElementException - 如果没有这样的标记可用
IllegalStateException - 如果此扫描器已关闭

hasNext

public boolean hasNext(Pattern pattern)
如果下一个完整标记与指定模式匹配，则返回 true。完整标记以与分隔模式匹配的输入信息为前后缀。在等待输入信息时，此方法可能阻塞。扫描器不执行任何输入。

参数：
pattern - 要扫描的模式
返回：
当且仅当此扫描器有另一个标记与指定模式匹配时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

next

public String next(Pattern pattern)
如果下一个标记与指定模式匹配，则返回下一个标记。即使以前调用 hasNext(Pattern) 返回了 true，在等待要扫描的输入时此方法也可能阻塞。如果此匹配操作成功，则扫描器执行与该模式匹配的输入。

参数：
pattern - 要扫描的模式
返回：
下一个标记
抛出：
NoSuchElementException - 如果没有更多的标记可用
IllegalStateException - 如果此扫描器已关闭

hasNextLine

public boolean hasNextLine()
如果在此扫描器的输入中存在另一行，则返回 true。在等待输入信息时，此方法可能阻塞。扫描器不执行任何输入。

返回：
当且仅当此扫描器有另一行输入时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextLine

public String nextLine()
此扫描器执行当前行，并返回跳过的输入信息。 此方法返回当前行的其余部分，不包括结尾处的行分隔符。当前位置移至下一行的行首。

因为此方法会继续在输入信息中查找行分隔符，所以如果没有行分隔符，它可能会缓冲所有输入信息，并查找要跳过的行。

返回：
跳过的行
抛出：
NoSuchElementException - 如果未找到这样的行
IllegalStateException - 如果此扫描器已关闭

findInLine

public String findInLine(String pattern)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

此方面调用 findInLine(pattern) 的行为与调用 findInLine(Pattern.compile(pattern)) 完全相同。

参数：
pattern - 指定要搜索的模式的字符串
返回：
与指定模式匹配的文本
抛出：
IllegalStateException - 如果此扫描器已关闭

findInLine

public String findInLine(Pattern pattern)
试图在忽略分隔符的情况下查找下一个指定模式。如果在下一个行分隔符前找到了该模式，则扫描器执行匹配的输入信息，并返回与该模式匹配的字符串。如果未找到，则返回 null，且扫描器的位置不变。在等待与该模式匹配的输入信息时，此方法可能阻塞。

因为此方法会继续在输入信息中查找指定的模式，所以如果没有行分隔符，它可能会缓冲所有输入信息，并查找所需的标记。

参数：
pattern - 要扫描的模式
返回：
与指定模式匹配的文本
抛出：
IllegalStateException - 如果此扫描器已关闭

findWithinHorizon

public String findWithinHorizon(String pattern,
                                int horizon)
试图在忽略分隔符的情况下查找下一个从指定字符串构造的模式。

此方法调用 findWithinHorizon(pattern) 的行为与调用 findWithinHorizon(Pattern.compile(pattern, horizon)) 完全相同。

参数：
pattern - 指定要搜索的模式的字符串
返回：
与指定模式匹配的文本
抛出：
IllegalStateException - 如果此扫描器已关闭
IllegalArgumentException - 如果 horizon 为负

findWithinHorizon

public String findWithinHorizon(Pattern pattern,
                                int horizon)
试图查找下一个指定模式。

此方法在忽略分隔符的情况下在指定的搜索范围内搜索输入信息。如果找到了该模式，则扫描器执行匹配的输入信息，并返回与该模式匹配的字符串。如果未找到，则返回 null，且扫描器的位置不变。在等待与该模式匹配的输入信息时，此方法可能阻塞。

扫描器的搜索永远都不超出其当前位置以外的 horizon 代码点。注意，匹配可能被 horizon 剪裁；也就是说，如果 horizon 变大，则任意匹配结果都可能不同。扫描器将 horizon 看作一个不固定的透明边界（请参见 Matcher.useTransparentBounds(boolean) 和 Matcher.useAnchoringBounds(boolean)）。

如果 horizon 为 0，则忽略 horizon，此方法继续在输入信息中查找指定的模式，且不设边界。在这种情况下，它可能会缓冲所有输入信息，并搜索该模式。

如果 horizon 为负，则抛出 IllegalArgumentException。

参数：
pattern - 要扫描的模式
返回：
与指定模式匹配的文本
抛出：
IllegalStateException - 如果此扫描器已关闭
IllegalArgumentException - 如果 horizon 为负

skip

public Scanner skip(Pattern pattern)
在忽略分隔符的情况下跳过与指定模式匹配的输入信息。如果指定模式的固定匹配成功，此方法则跳过输入信息。

如果在当前位置未找到指定模式，则不跳过任何输入信息，并抛出 NoSuchElementException。

由于此方法试图从扫描器的当前位置匹配指定模式，因此可与许多输入信息（例如 ".*"）匹配的模式可能会导致扫描器缓冲大量输入信息。

注意，通过使用没有任何匹配项的模式，例如，sc.skip("[ \t]*")，跳过某些信息同时不抛出 NoSuchElementException 是可能的。

参数：
pattern - 指定要跳过的模式的字符串
返回：
此扫描器
抛出：
NoSuchElementException - 如果未找到指定模式
IllegalStateException - 如果此扫描器已关闭

skip

public Scanner skip(String pattern)
跳过与从指定字符串构造的模式匹配的输入信息。

此方法调用 skip(pattern) 的行为与调用 skip(Pattern.compile(pattern)) 完全相同。

参数：
pattern - 指定要跳过的模式的字符串
返回：
此扫描器
抛出：
IllegalStateException - 如果此扫描器已关闭

hasNextBoolean

public boolean hasNextBoolean()
如果通过使用一个从字符串 "true|false" 创建的大小写敏感的模式，此扫描器输入信息中的下一个标记可以解释为一个布尔值，则返回 true。扫描器不执行匹配的输入。

返回：
当且仅当此扫描器的下一个标记是有效的布尔值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextBoolean

public boolean nextBoolean()
扫描解释为一个布尔值的输入标记并返回该值。如果下一个标记不能转换为有效的布尔值，则此方法将抛出 InputMismatchException。如果此匹配操作成功，则扫描器执行匹配的输入。

返回：
从输入信息扫描的布尔值
抛出：
InputMismatchException - 如果下一标记不是有效的布尔值
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextByte

public boolean hasNextByte()
如果通过使用 nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个字节值，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是有效的字节值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

hasNextByte

public boolean hasNextByte(int radix)
如果通过使用 nextByte() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个字节值，则返回 true。扫描器不执行任何输入。

参数：
radix - 用于将标记解释为一个字节值的基数
返回：
当且仅当此扫描器的下一个标记是有效的字节值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextByte

public byte nextByte()
将输入信息的下一个标记扫描为一个 byte。

此方法调用 nextByte() 的行为与调用 nextByte(radix) 完全相同，其中的 radix 是此扫描器的默认基数。

返回：
从输入信息扫描的 byte
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

nextByte

public byte nextByte(int radix)
将输入信息的下一个标记扫描为一个 byte。如果下一个标记不能转换为有效的字节值，则此方法将抛出 InputMismatchException，如下所述。如果此转换成功，则扫描器执行匹配的输入。

如果下一个标记与上述的 Integer 正则表达式匹配，则该标记转换成一个 byte 值，就好像通过移除所有特定于语言环境的前缀、组分隔符和特定于语言环境的后缀，然后通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字, 如果存在特定于语言环境的负前缀和后缀则预先挂起负号 (-)，以及将得到的字符串传递给带有指定基数的 Byte.parseByte。

参数：
radix - 用于将标记解释为字节值的基数
返回：
从输入信息扫描的 byte
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextShort

public boolean hasNextShort()
如果通过使用 nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 short 值，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是默认基数中的有效的 short 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

hasNextShort

public boolean hasNextShort(int radix)
如果通过使用 nextShort() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 short 值，则返回 true。扫描器不执行任何输入。

参数：
radix - 用于将标记解释为一个 short 值的基数
返回：
当且仅当此扫描器的下一个标记是指定基数中的有效的 short 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextShort

public short nextShort()
将输入信息的下一个标记扫描为一个 short。

此方法调用 nextShort() 行为与调用 nextShort(radix) 完全相同，其中的 radix 是此扫描器的默认基数。

返回：
从输入信息扫描的 short
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

nextShort

public short nextShort(int radix)
将输入信息的下一个标记扫描为一个 short。如果下一个标记不能转换为有效的 short 值，则此方法将抛出 InputMismatchException，如下所述。如果此转换成功，则扫描器执行匹配的输入。

如果下一个标记与上述的 Integer 正则表达式匹配，则该标记转换成一个 short 值，就好像通过移除所有特定于语言环境的前缀、组分隔符和特定于语言环境的后缀，然后通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字, 如果存在特定于语言环境的负前缀和后缀则预先挂起负号 (-)，然后将得到的字符串传递给带有指定基数的 Short.parseShort。

参数：
radix - 用于将标记解释为 short 值的基数
返回：
从输入信息扫描的 short
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextInt

public boolean hasNextInt()
如果通过使用 nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 int 值，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是有效的 int 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

hasNextInt

public boolean hasNextInt(int radix)
如果通过使用 nextInt() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 int 值，则返回 true。扫描器不执行任何输入。

参数：
radix - 用于将标记解释为一个 int 值的基数
返回：
当且仅当此扫描器的下一个标记是有效的 int 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextInt

public int nextInt()
将输入信息的下一个标记扫描为一个 int。

此方法调用 nextInt() 的行为与调用 nextInt(radix) 完全相同，其中的 radix 是此扫描器的默认基数。

返回：
从输入信息扫描的 int
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

nextInt

public int nextInt(int radix)
将输入信息的下一个标记扫描为一个 int。如果下一个标记不能转换为有效的 int 值，则此方法将抛出 InputMismatchException，如下所述。如果此转换成功，则扫描器执行匹配的输入。

如果下一个标记与上述的 Integer 正则表达式匹配，则该标记转换成一个 int 值，就好像通过移除所有特定于语言环境的前缀、组分隔符和特定于语言环境的后缀，然后通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字, 如果存在特定于语言环境的负前缀和后缀则预先挂起负号 (-)，然后将得到的字符串传递给带有指定基数的 Integer.parseInt。

参数：
radix - 用于将标记解释为 int 值的基数
返回：
从输入信息扫描的 int
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextLong

public boolean hasNextLong()
如果通过使用 nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 long 值，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是有效的 long 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

hasNextLong

public boolean hasNextLong(int radix)
如果通过使用 nextLong() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 long 值，则返回 true。扫描器不执行任何输入。

参数：
radix - 用于将标记解释为一个 long 值的基数
返回：
当且仅当此扫描器的下一个标记是有效的 long 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextLong

public long nextLong()
将输入信息的下一个标记扫描为一个 long。

此方法调用 nextLong() 的行为与调用 nextLong(radix) 完全相同，其中的 radix 是此扫描器的默认基数。

返回：
从输入信息扫描的 long
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

nextLong

public long nextLong(int radix)
将输入信息的下一个标记扫描为一个 long。如果下一个标记不能转换为有效的 long 值，则此方法将抛出 InputMismatchException，如下所述。如果此转换成功，则扫描器执行匹配的输入。

如果下一个标记与上述的 Integer 正则表达式匹配，则该标记转换成一个 long 值，就好像通过移除所有特定于语言环境的前缀、组分隔符和特定于语言环境的后缀，然后通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字, 如果存在特定于语言环境的负前缀和后缀则预先挂起负号 (-)，以及将得到的字符串传递给带有指定基数的 Long.parseLong。

参数：
radix - 用于将标记解释为 long 值的基数
返回：
从输入信息扫描的 long
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextFloat

public boolean hasNextFloat()
如果通过使用 nextFloat() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 float 值，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是有效的 float 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextFloat

public float nextFloat()
将输入信息的下一个标记扫描为一个 float。如果下一个标记不能转换为有效的 float 值，则此方法将抛出 InputMismatchException，如下所述。如果此转换成功，则扫描器执行匹配的输入。

如果下一个标记与上述的 Float 正则表达式匹配，则该标记转换成一个 float 值，就好像通过移除所有特定于语言环境的前缀、组分隔符和特定于语言环境的后缀，然后通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字, 如果存在特定于语言环境的负前缀和后缀则预先挂起负号 (-)，以及将得到的字符串传递给 Float.parseFloat。如果标记与本地化的 NaN 或无穷大字符串匹配，则将 "Nan" 或 "Infinity" 相应地传递给 Float.parseFloat。

返回：
从输入信息扫描的 float
抛出：
InputMismatchException - 如果下一个标记与 float 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextDouble

public boolean hasNextDouble()
如果通过使用 nextDouble() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 double 值，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是有效的 double 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextDouble

public double nextDouble()
将输入信息的下一个标记扫描为一个 double。如果下一个标记不能转换为有效的 double 值，则此方法将抛出 InputMismatchException。如果此转换成功，则扫描器执行匹配的输入。

如果下一个标记与上述的 Float 正则表达式匹配，则该标记转换成一个 double 值，就好像通过移除所有特定于语言环境的前缀、组分隔符和特定于语言环境的后缀，然后通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字, 如果存在特定于语言环境的负前缀和后缀则预先挂起负号 (-)，以及将得到的字符串传递给 Double.parseDouble。如果标记与本地化的 NaN 或无穷大字符串匹配，则将 "Nan" 或 "Infinity" 相应地传递给 Double.parseDouble。

返回：
从输入信息扫描的 double
抛出：
InputMismatchException - 如果下一个标记与 float 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextBigInteger

public boolean hasNextBigInteger()
如果通过使用 nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigInteger 值，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是有效的 BigInteger 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

hasNextBigInteger

public boolean hasNextBigInteger(int radix)
如果通过使用 nextBigInteger() 方法，此扫描器输入信息中的下一个标记可以解释为指定基数中的一个 BigInteger 值，则返回 true。扫描器不执行任何输入。

参数：
radix - 用于将标记解释为一个 integer 的基数
返回：
当且仅当此扫描器的下一个标记是有效的 BigInteger 时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextBigInteger

public BigInteger nextBigInteger()
将输入信息的下一个标记扫描为一个 BigInteger。

此方法调用 nextBigInteger() 的行为与调用 nextBigInteger(radix) 完全相同，其中的 radix 是此扫描器的默认基数。

返回：
从输入信息扫描的 BigInteger
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

nextBigInteger

public BigInteger nextBigInteger(int radix)
将输入信息的下一个标记扫描为一个 BigInteger。

如果下一个标记与上述的 Integer 正则表达式匹配，则该标记转换成一个 BigInteger 值，就好像通过移除所有组分隔符，通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字，以及将得到的字符串传递给带有指定基数的 BigInteger(String, int) 构造方法。

参数：
radix - 用于解释标记的基数
返回：
从输入信息扫描的 BigInteger
抛出：
InputMismatchException - 如果下一个标记与 Integer 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

hasNextBigDecimal

public boolean hasNextBigDecimal()
如果通过使用 nextBigDecimal() 方法，此扫描器输入信息中的下一个标记可以解释为默认基数中的一个 BigDecimal，则返回 true。扫描器不执行任何输入。

返回：
当且仅当此扫描器的下一个标记是有效的 BigDecimal 值时才返回 true
抛出：
IllegalStateException - 如果此扫描器已关闭

nextBigDecimal

public BigDecimal nextBigDecimal()
将输入信息的下一个标记扫描为一个 BigDecimal。

如果下一个标记与上述的 Decimal 正则表达式匹配，则该标记转换成一个 BigDecimal 值，就好像通过移除所有组分隔符，通过 Character.digit 将非 ASCII 数字映射为 ASCII 数字，以及将得到的字符串传递给 BigDecimal(String) 构造方法。

返回：
从输入信息扫描的 BigDecimal
抛出：
InputMismatchException - 如果下一个标记与 Decimal 正则表达式不匹配，或者超出范围
NoSuchElementException - 如果输入信息已耗尽
IllegalStateException - 如果此扫描器已关闭

reset

public Scanner reset()
重置此扫描器。

重置扫描器会丢弃其所有明确的状态信息，这些状态信息可能通过调用 useDelimiter(java.util.regex.Pattern)、useLocale(java.util.Locale) 或 useRadix(int) 已被更改。

调用此方法的形式为 scanner.reset()，该调用与以下调用的作用完全相同：

   scanner.useDelimiter("\\p{javaWhitespace}+")
          .useLocale(Locale.getDefault())
          .useRadix(10);

返回：
此扫描器
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceConfigurationError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ServiceConfigurationError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.util.ServiceConfigurationError
所有已实现的接口：
Serializable
public class ServiceConfigurationError
extends Error

在加载服务提供者的过程中出错时抛出的错误。

以下情况将抛出此错误：

  • 提供者配置文件的格式违背规范；
  • 读取提供者配置文件时发生 IOException；
  • 无法找到在提供者配置文件中指定的具体提供者类；
  • 具体提供者类不是服务类的子类；
  • 具体提供者类无法被实例化；或
  • 发生某些其他种类的错误。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
ServiceConfigurationError(String msg)
构造一个带有指定消息的新实例。
ServiceConfigurationError(String msg, Throwable cause)
构造一个带有指定消息和 cause 的新实例。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServiceConfigurationError

public ServiceConfigurationError(String msg)
构造一个带有指定消息的新实例。

参数：
msg - 消息；如果没有消息，则为 null

ServiceConfigurationError

public ServiceConfigurationError(String msg,
                                 Throwable cause)
构造一个带有指定消息和 cause 的新实例。

参数：
msg - 消息；如果没有消息，则为 null
cause - cause；如果 cause 不存在或未知，则为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceLoader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 ServiceLoader<S>

java.lang.Object
    继承者  java.util.ServiceLoader<S>
类型参数：
S - 要被此加载器加载的服务类型。
所有已实现的接口：
Iterable<S>
public final class ServiceLoader<S>
extends Object
implements Iterable<S>

一个简单的服务提供者加载设施。

服务 是一个熟知的接口和类（通常为抽象类）集合。服务提供者 是服务的特定实现。提供者中的类通常实现接口，并子类化在服务本身中定义的子类。服务提供者可以以扩展的形式安装在 Java 平台的实现中，也就是将 jar 文件放入任意常用的扩展目录中。也可通过将提供者加入应用程序类路径，或者通过其他某些特定于平台的方式使其可用。

为了加载，服务由单个类型表示，也就是单个接口或抽象类。（可以使用具体类，但建议不要这样做。）一个给定服务的提供者包含一个或多个具体类，这些类扩展了此服务类型，具有特定于提供者的数据和代码。提供者类 通常不是整个提供者本身而是一个代理，它包含足够的信息来决定提供者是否能满足特定请求，还包含可以根据需要创建实际提供者的代码。提供者类的详细信息高度特定于服务；任何单个类或接口都不能统一它们，因此这里没有定义任何这种类型。此设施唯一强制要求的是，提供者类必须具有不带参数的构造方法，以便它们可以在加载中被实例化。

通过在资源目录 META-INF/services 中放置提供者配置文件 来标识服务提供者。文件名称是服务类型的完全限定二进制名称。该文件包含一个具体提供者类的完全限定二进制名称列表，每行一个。忽略各名称周围的空格、制表符和空行。注释字符为 '#' ('\u0023', NUMBER SIGN)；忽略每行第一个注释字符后面的所有字符。文件必须使用 UTF-8 编码。

如果在多个配置文件中指定了一个特定的具体提供者类，或在同一配置文件中多次被指定，则忽略重复的指定。指定特定提供者的配置文件不必像提供者本身一样位于同一个 jar 文件或其他的分布式单元中。提供者必须可以从最初为了定位配置文件而查询的类加载器访问；注意，这不一定是实际加载文件的类加载器。

以延迟方式查找和实例化提供者，也就是说根据需要进行。服务加载器维护到目前为止已经加载的提供者缓存。每次调用 iterator 方法返回一个迭代器，它首先按照实例化顺序生成缓存的所有元素，然后以延迟方式查找和实例化所有剩余的提供者，依次将每个提供者添加到缓存。可以通过 reload 方法清除缓存。

服务加载器始终在调用者的安全上下文中执行。受信任的系统代码通常应当从特权安全上下文内部调用此类中的方法，以及它们返回的迭代器的方法。

此类的实例用于多个并发线程是不安全的。

除非另有指定，否则将 null 参数传递给此类中的任何方法都会导致抛出 NullPointerException。

示例假定服务类型为 com.example.CodecSet，它用来表示某些协议的编码器/解码器对集合。在这种情况下，它是一个具有两种抽象方法的抽象类：

public abstract Encoder getEncoder(String encodingName);
public abstract Decoder getDecoder(String encodingName);
每种方法都返回一个相应的对象；如果提供者不支持给定编码，则返回 null。典型的提供者支持一种以上的编码。

如果 com.example.impl.StandardCodecs 是 CodecSet 服务的实现，则其 jar 文件还包含一个指定如下的文件：

META-INF/services/com.example.CodecSet

此文件包含一行：

com.example.impl.StandardCodecs    # Standard codecs

CodecSet 类在初始化时创建并保存一个服务实例：

private static ServiceLoader<CodecSet> codecSetLoader
= ServiceLoader.load(CodecSet.class);

为了查找给定编码名称的编码器，它定义了一个静态工厂方法，该方法迭代所有已知并可用的提供者，只在找到适当的编码器或迭代完提供者时返回。

public static Encoder getEncoder(String encodingName) {
for (CodecSet cp :codecSetLoader) {
Encoder enc = cp.getEncoder(encodingName);
if (enc != null)
return enc;
     }
return null;
 }

getDecoder 方法的定义类似。

使用注意事项 如果用于提供者加载的类加载器的类路径包含远程网络 URL，则这些 URL 将在搜索提供者配置文件的过程中被取消引用。

此活动是正常的，尽管它可能导致在 Web 服务器日志中创建一些令人迷惑的条目。但是，如果 Web 服务器配置不正确，那么此活动可能导致提供者加载算法意外失败。

如果请求的资源不存在，则 Web 服务器应返回 HTTP 404 (Not Found) 响应。但有时会错误地将 Web 服务器配置为返回 HTTP 200 (OK) 响应，并伴有这种情况下的 HTML 错误帮助页面。这会导致在此类尝试将 HTML 页面作为提供者配置文件进行解析时抛出 ServiceConfigurationError。此问题的最佳解决方案是修复配置错误的 Web 服务器，以返回正确的响应代码 (HTTP 404) 以及 HTML 错误页面。

从以下版本开始：
1.6

方法摘要
 Iterator<S> iterator()
以延迟方式加载此加载器服务的可用提供者。
static
<S> ServiceLoader<S>
load(Class<S> service)
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。
static
<S> ServiceLoader<S>
load(Class<S> service, ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。
static
<S> ServiceLoader<S>
loadInstalled(Class<S> service)
针对给定服务类型创建新的服务加载器，使用扩展类加载器。
 void reload()
清除此加载器的服务者缓存，以重载所有服务者。
 String toString()
返回一个描述此服务的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

reload

public void reload()
清除此加载器的服务者缓存，以重载所有服务者。

调用此方法后，后续 iterator 方法的调用将以延迟方式从头开始查询和实例化提供者，正如新创建的加载器所做的一样。

此方法用于新提供者可以被装入运行的 Java 虚拟机的情况。

iterator

public Iterator<S> iterator()
以延迟方式加载此加载器服务的可用提供者。

此方法返回的迭代器首先按实例化顺序生成提供者缓存的所有元素。然后以延迟方式加载和实例化所有剩余的提供者，依次将每个提供者添加到缓存。

要实现延迟，解析可用提供者配置文件和实例化提供者的实际工作必须由迭代器本身完成。因此，如果提供者配置文件违背指定的格式、指定了无法找到和实例化的提供者类、实例化类的结果不能分配服务类型、因为查找和实例化下一个提供者而抛出任何其他异常或错误，那么迭代器的 hasNext 和 next 方法将抛出 ServiceConfigurationError。要编写健壮的代码，只需要在使用服务迭代器时捕获 ServiceConfigurationError。

如果抛出此类错误，那么迭代器的后续调用将尽力查找和实例化下一个可用提供者，但通常无法保证此类恢复操作。

设计注意事项 在那些情况下抛出错误显得有些极端。此行为的基本原理是，错误的提供者配置文件（如错误的类文件）表示 Java 虚拟机配置和使用的方式存在严重的问题。因此，最好抛出一个错误而不是试图恢复它，或者直接失败（这样更糟）。

此方法返回的迭代器不支持移除操作。调用其 remove 方法将导致抛出 UnsupportedOperationException。

指定者：
接口 Iterable<S> 中的 iterator
返回：
以延迟方式加载此加载器服务提供者的迭代器

load

public static <S> ServiceLoader<S> load(Class<S> service,
                                        ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。

参数：
service - 表示服务的接口或抽象类
loader - 用来加载提供者配置文件和提供者类的类加载器；如果要使用系统类加载器（如果没有，则使用引导类加载器），则为 null
返回：
新的服务加载器

load

public static <S> ServiceLoader<S> load(Class<S> service)
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。

调用以下形式的此便捷方法

ServiceLoader.load(service)
等价于：
ServiceLoader.load(service,
Thread.currentThread().getContextClassLoader())

参数：
service - 表示服务的接口或抽象类
返回：
新的服务加载器

loadInstalled

public static <S> ServiceLoader<S> loadInstalled(Class<S> service)
针对给定服务类型创建新的服务加载器，使用扩展类加载器。

此便捷方法查询扩展类加载器，称其为 extClassLoader，然后返回

ServiceLoader.load(service, extClassLoader)

如果无法找到扩展类加载器，则使用系统类加载器；如果没有系统类加载器，则使用引导类加载器。

此方法仅供安装所需的提供者时使用。所得服务只查找和加载已经装入当前 Java 虚拟机的提供者；忽略应用程序类路径上的提供者。

参数：
service - 表示服务的接口或抽象方法
返回：
新的服务加载器

toString

public String toString()
返回一个描述此服务的字符串。

覆盖：
类 Object 中的 toString
返回：
一个描述字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Set (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 Set<E>

类型参数：
E - 此 set 所维护元素的类型
所有超级接口：
Collection<E>, Iterable<E>
所有已知子接口：
NavigableSet<E>, SortedSet<E>
所有已知实现类：
AbstractSet, ConcurrentSkipListSet, CopyOnWriteArraySet, EnumSet, HashSet, JobStateReasons, LinkedHashSet, TreeSet
public interface Set<E>
extends Collection<E>

一个不包含重复元素的 collection。更确切地讲，set 不包含满足 e1.equals(e2) 的元素对 e1 和 e2，并且最多包含一个 null 元素。正如其名称所暗示的，此接口模仿了数学上的 set 抽象。

在所有构造方法以及 add、equals 和 hashCode 方法的协定上，Set 接口还加入了其他规定，这些规定超出了从 Collection 接口所继承的内容。出于方便考虑，它还包括了其他继承方法的声明（这些声明的规范已经专门针对 Set 接口进行了修改，但是没有包含任何其他的规定）。

对这些构造方法的其他规定是（不要奇怪），所有构造方法必须创建一个不包含重复元素的 set（正如上面所定义的）。

注：如果将可变对象用作 set 元素，那么必须极其小心。如果对象是 set 中某个元素，以一种影响 equals 比较的方式改变对象的值，那么 set 的行为就是不确定的。此项禁止的一个特殊情况是不允许某个 set 包含其自身作为元素。

某些 set 实现对其所包含的元素有所限制。例如，某些实现禁止 null 元素，而某些则对其元素的类型所有限制。试图添加不合格的元素会抛出未经检查的异常，通常是 NullPointerException 或 ClassCastException。试图查询不合格的元素是否存在可能会抛出异常，也可能简单地返回 false；某些实现会采用前一种行为，而某些则采用后者。概括地说，试图对不合格元素执行操作时，如果完成该操作后不会导致在 set 中插入不合格的元素，则该操作可能抛出一个异常，也可能成功，这取决于实现的选择。此接口的规范中将这样的异常标记为“可选”。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, List, SortedSet, HashSet, TreeSet, AbstractSet, Collections.singleton(java.lang.Object), Collections.EMPTY_SET

方法摘要
 boolean add(E e)
如果 set 中尚未存在指定的元素，则添加此元素（可选操作）。
 boolean addAll(Collection<? extends E> c)
如果 set 中没有指定 collection 中的所有元素，则将其添加到此 set 中（可选操作）。
 void clear()
移除此 set 中的所有元素（可选操作）。
 boolean contains(Object o)
如果 set 包含指定的元素，则返回 true。
 boolean containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。
 boolean equals(Object o)
比较指定对象与此 set 的相等性。
 int hashCode()
返回 set 的哈希码值。
 boolean isEmpty()
如果 set 不包含元素，则返回 true。
 Iterator<E> iterator()
返回在此 set 中的元素上进行迭代的迭代器。
 boolean remove(Object o)
如果 set 中存在指定的元素，则将其移除（可选操作）。
 boolean removeAll(Collection<?> c)
移除 set 中那些包含在指定 collection 中的元素（可选操作）。
 boolean retainAll(Collection<?> c)
仅保留 set 中那些包含在指定 collection 中的元素（可选操作）。
 int size()
返回 set 中的元素数（其容量）。
 Object[] toArray()
返回一个包含 set 中所有元素的数组。
<T> T[]
toArray(T[] a)
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。

方法详细信息

size

int size()
返回 set 中的元素数（其容量）。如果 set 包含多个 Integer.MAX_VALUE 元素，则返回 Integer.MAX_VALUE。

指定者：
接口 Collection<E> 中的 size
返回：
此 set 中的元素数（其容量）

isEmpty

boolean isEmpty()
如果 set 不包含元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
返回：
如果此 set 不包含元素，则返回 true

contains

boolean contains(Object o)
如果 set 包含指定的元素，则返回 true。更确切地讲，当且仅当 set 包含满足 (o==null ? e==null : o.equals(e)) 的元素 e 时返回 true。

指定者：
接口 Collection<E> 中的 contains
参数：
o - 要测试此 set 中是否存在的元素
返回：
如果此 set 包含指定的元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类型与此 set 不兼容（可选）
NullPointerException - 如果指定的元素为 null 并且此 set 不允许 null 元素（可选）

iterator

Iterator<E> iterator()
返回在此 set 中的元素上进行迭代的迭代器。返回的元素没有特定的顺序（除非此 set 是某个提供顺序保证的类的实例）。

指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Iterable<E> 中的 iterator
返回：
在此 set 中的元素上进行迭代的迭代器

toArray

Object[] toArray()
返回一个包含 set 中所有元素的数组。如果此 set 对其迭代器返回的元素的顺序作出了某些保证，那么此方法也必须按相同的顺序返回这些元素。

由于此 set 不维护对返回数组的任何引用，因而它是安全的。（换句话说，即使此 set 受到数组的支持，此方法也必须分配一个新的数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
返回：
包含此 set 中所有元素的数组

toArray

<T> T[] toArray(T[] a)
返回一个包含此 set 中所有元素的数组；返回数组的运行时类型是指定数组的类型。如果指定的数组能容纳该 set，则它将在其中返回。否则，将分配一个具有指定数组的运行时类型和此 set 大小的新数组。

如果指定的数组能容纳此 set，并有剩余的空间（即该数组的元素比此 set 多），那么会将列表中紧接该 set 尾部的元素设置为 null。（只有在调用者知道此 set 不包含任何 null 元素时才能用此方法确定此 set 的长度）。

如果此 set 对其迭代器返回的元素的顺序作出了某些保证，那么此方法也必须按相同的顺序返回这些元素。

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型上进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知 set。以下代码用来将该 set 转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
参数：
a - 存储此 set 中元素的数组（如果其足够大）；否则将为此分配一个具有相同运行时类型的新数组。
返回：
包含此 set 中所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此 set 中所有元素的运行时类型的超类型
NullPointerException - 如果指定的数组为 null

add

boolean add(E e)
如果 set 中尚未存在指定的元素，则添加此元素（可选操作）。更确切地讲，如果此 set 没有包含满足 (e==null ? e2==null : e.equals(e2)) 的元素 e2，则向该 set 中添加指定的元素 e。如果此 set 已经包含该元素，则该调用不改变此 set 并返回 false。结合构造方法上的限制，这就可以确保 set 永远不包含重复的元素。

上述规定并未暗示 set 必须接受所有元素；set 可以拒绝添加任意特定的元素，包括 null，并抛出异常，这与 Collection.add 规范中所描述的一样。每个 set 实现应该明确地记录对其可能包含元素的所有限制。

指定者：
接口 Collection<E> 中的 add
参数：
e - 要添加到 set 中的元素
返回：
如果 set 尚未包含指定的元素，则返回 true
抛出：
UnsupportedOperationException - 如果此 set 不支持 add 操作
ClassCastException - 如果指定元素的类不允许它添加到此 set
NullPointerException - 如果指定的元素为 null 并且此 set 不允许 null 元素
IllegalArgumentException - 如果指定元素的某些属性不允许它添加到此 set

remove

boolean remove(Object o)
如果 set 中存在指定的元素，则将其移除（可选操作）。更确切地讲，如果此 set 中包含满足 (o==null ? e==null : o.equals(e)) 的元素 e，则移除它。如果此 set 包含指定的元素（或者此 set 由于调用而发生更改），则返回 true（一旦调用返回，则此 set 不再包含指定的元素）。

指定者：
接口 Collection<E> 中的 remove
参数：
o - 从 set 中移除的对象（如果存在）
返回：
如果此 set 包含指定的对象，则返回 true
抛出：
ClassCastException - 如果指定元素的类型与此 set 不兼容（可选）
NullPointerException - 如果指定的元素为 null，并且此 set 不允许 null 元素（可选）
UnsupportedOperationException - 如果此 set 不支持 remove 操作

containsAll

boolean containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。如果指定的 collection 也是一个 set，那么当该 collection 是此 set 的子集 时返回 true。

指定者：
接口 Collection<E> 中的 containsAll
参数：
c - 检查是否包含在此 set 中的 collection
返回：
如果此 set 包含指定 collection 中的所有元素，则返回 true
抛出：
ClassCastException - 如果指定 collection 中的一个或多个元素的类型与此 set 不兼容（可选）
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素并且此 set 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
contains(Object)

addAll

boolean addAll(Collection<? extends E> c)
如果 set 中没有指定 collection 中的所有元素，则将其添加到此 set 中（可选操作）。如果指定的 collection 也是一个 set，则 addAll 操作会实际修改此 set，这样其值是两个 set 的一个并集。如果操作正在进行的同时修改了指定的 collection，则此操作的行为是不确定的。

指定者：
接口 Collection<E> 中的 addAll
参数：
c - 包含要添加到此 set 中的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果 set 不支持 addAll 操作
ClassCastException - 如果某些指定 collection 元素的类不允许它添加到此 set
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素并且此 set 不允许 null 元素，或者指定的 collection 为 null
IllegalArgumentException - 如果指定 collection 元素的某些属性不允许它添加到此 set
另请参见：
add(Object)

retainAll

boolean retainAll(Collection<?> c)
仅保留 set 中那些包含在指定 collection 中的元素（可选操作）。换句话说，移除此 set 中所有未包含在指定 collection 中的元素。如果指定的 collection 也是一个 set，则此操作会实际修改此 set，这样其值是两个 set 的一个交集。

指定者：
接口 Collection<E> 中的 retainAll
参数：
c - 包含要保留到此 set 中的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 set 不支持 retainAll 操作
ClassCastException - 如果此 set 元素的类与指定的 collection 不兼容（可选）
NullPointerException - 如果此 set 包含 null 元素并且指定的 collection 不支持 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object)

removeAll

boolean removeAll(Collection<?> c)
移除 set 中那些包含在指定 collection 中的元素（可选操作）。如果指定的 collection 也是一个 set，则此操作会实际修改此 set，这样其值是两个 set 的一个不对称差集。

指定者：
接口 Collection<E> 中的 removeAll
参数：
c - 包含要从此 set 中移除的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
UnsupportedOperationException - 如果此 set 不支持 removeAll 操作
ClassCastException - 如果此 set 元素的类与指定的 collection 不兼容（可选）
NullPointerException - 如果此 set 包含 null 元素并且指定的 collection 不允许 null 元素（可选），或者指定的 collection 为 null
另请参见：
remove(Object), contains(Object)

clear

void clear()
移除此 set 中的所有元素（可选操作）。此调用返回后该 set 将是空的。

指定者：
接口 Collection<E> 中的 clear
抛出：
UnsupportedOperationException - 如果此 set 不支持 clear 方法

equals

boolean equals(Object o)
比较指定对象与此 set 的相等性。如果指定的对象也是一个 set，两个 set 的大小相同，并且指定 set 的所有成员都包含在此 set 中（或者，此 set 的所有成员都包含在指定的 set 中也一样），则返回 true。此定义确保了 equals 方法可在不同的 set 接口实现间正常工作。

指定者：
接口 Collection<E> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与此 set 进行相等性比较的对象
返回：
如果指定的对象等于此 set，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回 set 的哈希码值。一个 set 的哈希码定义为此 set 中所有元素的哈希码和，其中 null 元素的哈希码定义为零。这就确保对于任意两个 set s1 和 s2 而言，s1.equals(s2) 就意味着 s1.hashCode()==s2.hashCode()，正如 Object.hashCode() 的常规协定所要求的那样。

指定者：
接口 Collection<E> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 set 的哈希码值
另请参见：
Object.equals(Object), equals(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleTimeZone (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 SimpleTimeZone

java.lang.Object
    继承者  java.util.TimeZone
        继承者  java.util.SimpleTimeZone
所有已实现的接口：
Serializable, Cloneable
public class SimpleTimeZone
extends TimeZone

SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。此类保持一个相对 GMT 的偏移量，称为原始偏移量，并保持夏令时安排的开始和结束规则。由于它仅为每一项保持单个值，因此它无法处理相对 GMT 的偏移量以及夏令时安排中的历史更改，除了 setStartYear 方法可以指定开始实施夏令时安排的年份之外。

要构造一个带有夏令时安排的 SimpleTimeZone，可以使用一组规则，即开始规则 和结束规则 来描述该安排。夏令时开始或结束的那一天通过 month、day-of-month 和 day-of-week 值联合指定。month 值由 Calendar 的 MONTH 字段值表示，如 Calendar.MARCH。day-of-week 值由 Calendar 的 DAY_OF_WEEK 值表示，如 SUNDAY。这些值的组合含意如下。

  • 一个月的具体某一天
    要指定一个月的具体某一天，可将 month 和 day-of-month 设置为一个具体的值，并将 day-of-week 设置为 0。例如，要指定 3 月 1 日，可将 month 设置为 MARCH，day-of-month 设置为 1，并将 day-of-week 设置为 0。
  • 一个月的某一天或之后的星期几
    要具体指定一个月的某一天或之后的星期几，可将 month 设置为一个具体的月份值，将 day-of-month 设置为在该日期或在该日期之后应用规则的那一天，并将 day-of-week 设置为负的 DAY_OF_WEEK 字段值。例如，要指定 4 月的第二个星期天，可将 month 设置为 APRIL，day-of-month 设置为 8，并将 day-of-week 设置为 - SUNDAY。
  • 一个月的某一天或之前的星期几
    要具体指定一个月的某一天或之前的星期几，可将 day-of-month 和 day-of-week 设置为负值。例如，要指定 3 月 21 日或之前的最后一个星期三，可将 month 设置为 MARCH，将 day-of-month 设置为 -21，并将 day-of-week 设置为 - WEDNESDAY。
  • 一个月的最后一个星期几
    要指定一个月的最后一个星期几，可将 day-of-week 设置为 DAY_OF_WEEK 值，并将 day-of-month 设置为 -1。例如，要设置 10 月的最后一个星期日，可将 month 设置为 OCTOBER，将 day-of-week 设置为 SUNDAY，并将 day-of-month 设置为 -1。
夏令时开始或结束的那一天的具体时间由该日期内的毫秒值指定。有三种指定时间的模式：WALL_TIME、STANDARD_TIME 和 UTC_TIME。例如，如果夏令时在挂钟时间凌晨 2:00 结束，则可以在 WALL_TIME 模式中用 7200000 毫秒指定该时间。在这种情况下，结束规则 的挂钟时间与夏令时时间是一样的。

下面是构造时区对象的一些参数示例。

      // Base GMT offset: -8:00
      // DST starts:      at 2:00am in standard time
      //                  on the first Sunday in April
      // DST ends:        at 2:00am in daylight time
      //                  on the last Sunday in October
      // Save:            1 hour
      SimpleTimeZone(-28800000,
                     "America/Los_Angeles",
                     Calendar.APRIL, 1, -Calendar.SUNDAY,
                     7200000,
                     Calendar.OCTOBER, -1, Calendar.SUNDAY,
                     7200000,
                     3600000)

      // Base GMT offset: +1:00
      // DST starts:      at 1:00am in UTC time
      //                  on the last Sunday in March
      // DST ends:        at 1:00am in UTC time
      //                  on the last Sunday in October
      // Save:            1 hour
      SimpleTimeZone(3600000,
                     "Europe/Paris",
                     Calendar.MARCH, -1, Calendar.SUNDAY,
                     3600000, SimpleTimeZone.UTC_TIME,
                     Calendar.OCTOBER, -1, Calendar.SUNDAY,
                     3600000, SimpleTimeZone.UTC_TIME,
                     3600000)
这些参数规则也适用于设置规则的方法，如 setStartRule。

从以下版本开始：
1.1
另请参见：
Calendar, GregorianCalendar, TimeZone, 序列化表格

字段摘要
static int | STANDARD_TIME 指定为标准时间的开始或结束时间模式的常量。
static int | UTC_TIME 指定为 UTC 的开始或结束时间模式的常量。
static int | WALL_TIME 指定为挂钟时间的开始或结束时间模式的常量。
从类 java.util.TimeZone 继承的字段
LONG, SHORT
构造方法摘要
SimpleTimeZone(int rawOffset, String ID)
使用给定的相对于 GMT 的基准时区偏移量和不带夏令时安排的时区 ID 构造一个 SimpleTimeZone。
SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int endMonth, int endDay, int endDayOfWeek, int endTime, int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
SimpleTimeZone(int rawOffset, String ID, int startMonth, int startDay, int startDayOfWeek, int startTime, int startTimeMode, int endMonth, int endDay, int endDayOfWeek, int endTime, int endTimeMode, int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。
方法摘要
Object | clone() 返回此 SimpleTimeZone 实例的一个副本。
boolean | equals(Object obj) 比较两个 SimpleTimeZone 对象的相等性。
int | getDSTSavings() 返回设置在夏令时期间时钟提前的时间量（以毫秒为单位）。
int | getOffset(int era, int year, int month, int day, int dayOfWeek, int millis) 返回以毫秒为单位的本地时间与 UTC 之间的差别，对于指定日期和时间，把原始偏移量和夏令时的效果同时考虑在内。
int | getOffset(long date) 从给定时间的 UTC 返回此时区的偏移量。
int | getRawOffset() 获取此时区的 GMT 偏移量。
int | hashCode() 生成 SimpleDateFormat 对象的哈希码。
boolean | hasSameRules(TimeZone other) 如果此时区与另一时区具有相同的规则和偏移量，则返回 true。
boolean | inDaylightTime(Date date) 如果给定日期在夏令时期间，则执行查询。
void | setDSTSavings(int millisSavedDuringDST) 设置在夏令时期间时钟提前的时间量（以毫秒为单位）。
void | setEndRule(int endMonth, int endDay, int endTime) 将夏令时结束规则设置为某个月份的固定日期。
void | setEndRule(int endMonth, int endDay, int endDayOfWeek, int endTime) 设置夏令时结束规则。
void | setEndRule(int endMonth, int endDay, int endDayOfWeek, int endTime, boolean after) 将夏令时结束规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。
void | setRawOffset(int offsetMillis) 把基准时区偏移量设置到 GMT。
void | setStartRule(int startMonth, int startDay, int startTime) 将夏令时开始规则设置为某个月份的固定日期。
void | setStartRule(int startMonth, int startDay, int startDayOfWeek, int startTime) 设置夏令时的开始规则。
void | setStartRule(int startMonth, int startDay, int startDayOfWeek, int startTime, boolean after) 将夏令时开始规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。
void | setStartYear(int year) 设置夏令时的开始年份。
String | toString() 返回此时区的字符串表示形式。
boolean | useDaylightTime() 如果此时区使用夏令时，则执行查询。
从类 java.util.TimeZone 继承的方法
getAvailableIDs, getAvailableIDs, getDefault, getDisplayName, getDisplayName, getDisplayName, getDisplayName, getID, getTimeZone, setDefault, setID
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

WALL_TIME

public static final int WALL_TIME
指定为挂钟时间的开始或结束时间模式的常量。挂钟时间是开始规则的标准时间，是结束规则的夏令时时间。

从以下版本开始：
1.4
另请参见：
常量字段值

STANDARD_TIME

public static final int STANDARD_TIME
指定为标准时间的开始或结束时间模式的常量。

从以下版本开始：
1.4
另请参见：
常量字段值

UTC_TIME

public static final int UTC_TIME
指定为 UTC 的开始或结束时间模式的常量。例如，欧盟规则就指定为 UTC 时间。

从以下版本开始：
1.4
另请参见：
常量字段值
构造方法详细信息

SimpleTimeZone

public SimpleTimeZone(int rawOffset,
                      String ID)
使用给定的相对于 GMT 的基准时区偏移量和不带夏令时安排的时区 ID 构造一个 SimpleTimeZone。

参数：
rawOffset - 相对于 GMT 的基准时区偏移量（以毫秒为单位）。
ID - 此实例给定的时区名称。

SimpleTimeZone

public SimpleTimeZone(int rawOffset,
                      String ID,
                      int startMonth,
                      int startDay,
                      int startDayOfWeek,
                      int startTime,
                      int endMonth,
                      int endDay,
                      int endDayOfWeek,
                      int endTime)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。假定 startTime 和 endTime 都要以挂钟时间表示。夏令时节约的时间量假定为 3600000 毫秒（也就是 1 小时）。此构造方法等效于：

     SimpleTimeZone(rawOffset,
                    ID,
                    startMonth,
                    startDay,
                    startDayOfWeek,
                    startTime,
                    SimpleTimeZone.WALL_TIME,
                    endMonth,
                    endDay,
                    endDayOfWeek,
                    endTime,
                    SimpleTimeZone.WALL_TIME,
                    3600000)

参数：
rawOffset - GMT 的给定基准时区偏移量。
ID - 此对象给定的时区 ID。
startMonth - 夏令时开始的月份。月份是一个 MONTH 字段值（基于 0。例如，0 代表 1 月）。
startDay - 夏令时开始的日期。有关此参数的特殊情形，请参阅类的描述。
startDayOfWeek - 夏令时开始时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
startTime - 以本地挂钟时间表示的夏令时开始时间（此天中的毫秒数），在此情况下为本地标准时间。
endMonth - 夏令时结束的月份。月份是一个 MONTH 字段值（基于 0。例如，9 代表 10 月）。
endDay - 夏令时结束的日期。有关此参数的特殊情形，请参阅类的描述。
endDayOfWeek - 夏令时结束时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
endTime - 以本地挂钟时间表示的夏令时结束时间（此天中的毫秒数），在此情况下为本地标准时间。
抛出：
IllegalArgumentException - 如果月份、日期、星期或时间参数超出开始或结束规则的范围。

SimpleTimeZone

public SimpleTimeZone(int rawOffset,
                      String ID,
                      int startMonth,
                      int startDay,
                      int startDayOfWeek,
                      int startTime,
                      int endMonth,
                      int endDay,
                      int endDayOfWeek,
                      int endTime,
                      int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。指定 startTime 和 endTime 都要以挂钟时间表示。此构造方法等效于：

     SimpleTimeZone(rawOffset,
                    ID,
                    startMonth,
                    startDay,
                    startDayOfWeek,
                    startTime,
                    SimpleTimeZone.WALL_TIME,
                    endMonth,
                    endDay,
                    endDayOfWeek,
                    endTime,
                    SimpleTimeZone.WALL_TIME,
                    dstSavings)

参数：
rawOffset - GMT 的给定基准时区偏移量。
ID - 此对象给定的时区 ID。
startMonth - 夏令时开始的月份。月份是一个 MONTH 字段值（基于 0。例如，0 代表 1 月）。
startDay - 夏令时开始的日期。有关此参数的特殊情形，请参阅类的描述。
startDayOfWeek - 夏令时开始时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
startTime - 以本地挂钟时间表示的夏令时开始时间，在此情况下为本地标准时间。
endMonth - 夏令时结束的月份。月份是一个 MONTH 字段值（基于 0。例如，9 代表 10 月）。
endDay - 夏令时结束的日期。有关此参数的特殊情形，请参阅类的描述。
endDayOfWeek - 夏令时结束时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
startTime - 以本地挂钟时间表示的夏令时结束时间，在此情况下为本地标准时间。
dstSavings - 在夏令时期间节省的时间量（以毫秒为单位）。
抛出：
IllegalArgumentException - 如果月份、日期、星期或时间参数超出开始或结束规则的范围。
从以下版本开始：
1.2

SimpleTimeZone

public SimpleTimeZone(int rawOffset,
                      String ID,
                      int startMonth,
                      int startDay,
                      int startDayOfWeek,
                      int startTime,
                      int startTimeMode,
                      int endMonth,
                      int endDay,
                      int endDayOfWeek,
                      int endTime,
                      int endTimeMode,
                      int dstSavings)
根据给定的相对于 GMT 的基准时区偏移量、时区 ID 和夏令时开始和结束的规则来构造一个 SimpleTimeZone。此构造方法采用一组完整的开始和结束规则参数，其中包括 startTime 和 endTime 模式。此模式指定挂钟时间或标准时间或 UTC 时间。

参数：
rawOffset - GMT 的给定基准时区偏移量。
ID - 此对象给定的时区 ID。
startMonth - 夏令时开始的月份。月份是一个 MONTH 字段值（基于 0。例如，0 代表 1 月）。
startDay - 夏令时开始的日期。有关此参数的特殊情形，请参阅类的描述。
startDayOfWeek - 夏令时开始时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
startTime - 由 startTimeMode 指定的时间模式的夏令时开始时间。
startTimeMode - 由 startTime 指定的开始时间模式。
endMonth - 夏令时结束的月份。月份是一个 MONTH 字段值（基于 0。例如，9 代表 10 月）。
endDay - 夏令时结束的日期。有关此参数的特殊情形，请参阅类的描述。
endDayOfWeek - 夏令时结束时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
endTime - 由 endTimeMode 指定的时间模式的夏令时结束时间。
endTimeMode - 由 endTime 指定的结束时间的模式。
dstSavings - 在夏令时期间节省的时间量（以毫秒为单位）。
抛出：
IllegalArgumentException - 如果月份、日期、星期或时间参数超出开始或结束规则的范围，或者某个时间模式值无效。
从以下版本开始：
1.4
另请参见：
WALL_TIME, STANDARD_TIME, UTC_TIME
方法详细信息

setStartYear

public void setStartYear(int year)
设置夏令时的开始年份。

参数：
year - 夏令时的开始年份。

setStartRule

public void setStartRule(int startMonth,
                         int startDay,
                         int startDayOfWeek,
                         int startTime)
设置夏令时的开始规则。例如，如果夏令时在本地挂钟时间的 4 月第一个星期日的上午 2 点开始，则可以通过以下调用来设置开始规则：
setStartRule(Calendar.APRIL, 1, Calendar.SUNDAY, 2*60*60*1000);

参数：
startMonth - 夏令时开始的月份。月份是一个 MONTH 字段值（基于 0。例如，0 代表 1 月）。
startDay - 夏令时开始的日期。有关此参数的特殊情形，请参阅类的描述。
startDayOfWeek - 夏令时开始时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
startTime - 以本地挂钟时间表示的夏令时开始时间，在此情况下为本地标准时间。
抛出：
IllegalArgumentException - 如果 startMonth、startDay、startDayOfWeek 或 startTime 参数超出范围。

setStartRule

public void setStartRule(int startMonth,
                         int startDay,
                         int startTime)
将夏令时开始规则设置为某个月份的固定日期。此方法等效于：
setStartRule(startMonth, startDay, 0, startTime)

参数：
startMonth - 夏令时开始的月份。月份是一个 MONTH 字段值（基于 0。例如，0 代表 1 月）。
startDay - 夏令时开始的日期。
startTime - 以本地挂钟时间表示的夏令时开始时间，在此情况下为本地标准时间。有关此参数的特殊情形，请参阅类的描述。
抛出：
IllegalArgumentException - 如果 startMonth、startDayOfMonth 或 startTime 参数超出范围。
从以下版本开始：
1.2

setStartRule

public void setStartRule(int startMonth,
                         int startDay,
                         int startDayOfWeek,
                         int startTime,
                         boolean after)
将夏令时开始规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。

参数：
startMonth - 夏令时开始的月份。月份是一个 MONTH 字段值（基于 0。例如，0 代表 1 月）。
startDay - 夏令时开始的日期。
startDayOfWeek - 夏令时开始时是一周的星期几。
startTime - 以本地挂钟时间表示的夏令时开始时间，在此情况下为本地标准时间。
after - 如果为 true，则此规则将选择 dayOfMonth 或它之后 的第一个 dayOfWeek。如果为 false，则此规则将选择 dayOfMonth 或它之前 的最后一个 dayOfWeek。
抛出：
IllegalArgumentException - 如果 startMonth、startDay、startDayOfWeek 或 startTime 参数超出范围。
从以下版本开始：
1.2

setEndRule

public void setEndRule(int endMonth,
                       int endDay,
                       int endDayOfWeek,
                       int endTime)
设置夏令时结束规则。例如，如果夏令时在本地挂钟时间的 10 月最后一个星期天的上午 2 点结束，则可以通过以下调用来设置结束规则：setEndRule(Calendar.OCTOBER, -1, Calendar.SUNDAY, 2*60*60*1000);

参数：
endMonth - 夏令时结束的月份。月份是一个 MONTH 字段值（基于 0。例如，9 代表 10 月）。
endDay - 夏令时结束的日期。有关此参数的特殊情形，请参阅类的描述。
endDayOfWeek - 夏令时结束时是一周的星期几。有关此参数的特殊情形，请参阅类的描述。
endTime - 以本地挂钟时间表示的夏令时结束时间（此天中的毫秒数），在此情况下为本地标准时间。
抛出：
IllegalArgumentException - 如果 endMonth、endDay、endDayOfWeek 或 endTime 参数超出范围。

setEndRule

public void setEndRule(int endMonth,
                       int endDay,
                       int endTime)
将夏令时结束规则设置为某个月份的固定日期。此方法等效于：
setEndRule(endMonth, endDay, 0, endTime)

参数：
endMonth - 夏令时结束的月份。月份是一个 MONTH 字段值（基于 0。例如，9 代表 10 月）。
endDay - 夏令时结束的日期。
endTime - 以本地挂钟时间表示的夏令时结束时间（此天中的毫秒数），在此情况下为本地标准时间。
抛出：
IllegalArgumentException - 如果 endMonth、endDay 或 endTime 参数超出范围。
从以下版本开始：
1.2

setEndRule

public void setEndRule(int endMonth,
                       int endDay,
                       int endDayOfWeek,
                       int endTime,
                       boolean after)
将夏令时结束规则设置为某个月份给定日期之前或之后的星期几，例如，8 号或之后的第一个星期一。

参数：
endMonth - 夏令时结束的月份。月份是一个 MONTH 字段值（基于 0。例如，9 代表 10 月）。
endDay - 夏令时结束的日期。
endDayOfWeek - 夏令时结束时是一周的星期几。
endTime - 以本地挂钟时间表示的夏令时结束时间（此天中的毫秒数），在此情况下为本地标准时间。
after - 如果为 true，则此规则将选择 endDay 或它之后 的第一个 endDayOfWeek。如果为 false，则此规则将选择该月份的 endDay 或它之前的最后一个 endDayOfWeek。
抛出：
IllegalArgumentException - 如果 endMonth、endDay、endDayOfWeek 或 endTime 参数超出范围。
从以下版本开始：
1.2

getOffset

public int getOffset(long date)
从给定时间的 UTC 返回此时区的偏移量。如果夏令时在给定的时间是有效的，就使用夏令时节省值调整偏移值。

覆盖：
类 TimeZone 中的 getOffset
参数：
date - 出现时区偏移量的时间。
返回：
添加到 UTC 以获取本地时间的时间量（以毫秒为单位）。
从以下版本开始：
1.4
另请参见：
Calendar.ZONE_OFFSET, Calendar.DST_OFFSET

getOffset

public int getOffset(int era,
                     int year,
                     int month,
                     int day,
                     int dayOfWeek,
                     int millis)
返回以毫秒为单位的本地时间与 UTC 之间的差别，对于指定日期和时间，把原始偏移量和夏令时的效果同时考虑在内。此方法假定开始和结束月份是不同的。它还使用默认的 GregorianCalendar 对象作为其基础日历，例如用于确定闰年。除默认的 GregorianCalendar 之外，请不要将此方法的结果与其他日历一起使用。

注：一般情况下，客户应使用 Calendar.get(ZONE_OFFSET) + Calendar.get(DST_OFFSET) 而不调用此方法。

指定者：
类 TimeZone 中的 getOffset
参数：
era - 给定日期的年代。
year - 给定日期的年份。
month - 给定日期的月份。月份是从 0 开始的，比如 0 代表 1 月。
day - 给定日期的月份中的某一天。
dayOfWeek - 给定日期的一周中的某一天。
millis - 标准 本地时间中天的毫秒数。
返回：
要添加到 UTC 以获取本地时间的毫秒数。
抛出：
IllegalArgumentException - 如果 era、month、day、dayOfWeek 或 millis 参数超出范围。
另请参见：
Calendar.ZONE_OFFSET, Calendar.DST_OFFSET

getRawOffset

public int getRawOffset()
获取此时区的 GMT 偏移量。

指定者：
类 TimeZone 中的 getRawOffset
返回：
以毫秒为单位的 GMT 偏移量值。
另请参见：
setRawOffset(int)

setRawOffset

public void setRawOffset(int offsetMillis)
把基准时区偏移量设置到 GMT。这是添加到 UTC 以获取本地时间的偏移量。

指定者：
类 TimeZone 中的 setRawOffset
参数：
offsetMillis - GMT 的给定基准时区偏移量。
另请参见：
getRawOffset()

setDSTSavings

public void setDSTSavings(int millisSavedDuringDST)
设置在夏令时期间时钟提前的时间量（以毫秒为单位）。

参数：
millisSavedDuringDST - 在夏令时规则生效时，相对于标准时间提前的毫秒数。一个正数，一般为 1 小时 (3600000)。
从以下版本开始：
1.2
另请参见：
getDSTSavings()

getDSTSavings

public int getDSTSavings()
返回设置在夏令时期间时钟提前的时间量（以毫秒为单位）。

覆盖：
类 TimeZone 中的 getDSTSavings
返回：
在夏令时规则生效时，相对于标准时间提前的毫秒数，如果此时区不实施夏令时，则为 0（零）。
从以下版本开始：
1.2
另请参见：
setDSTSavings(int)

useDaylightTime

public boolean useDaylightTime()
如果此时区使用夏令时，则执行查询。

指定者：
类 TimeZone 中的 useDaylightTime
返回：
如果此时区使用夏令时，则返回 true；否则返回 false。

inDaylightTime

public boolean inDaylightTime(Date date)
如果给定日期在夏令时期间，则执行查询。

指定者：
类 TimeZone 中的 inDaylightTime
参数：
date - 给定的日期。
返回：
如果给定的日期在夏令时中，则返回 true，否则返回 false。

clone

public Object clone()
返回此 SimpleTimeZone 实例的一个副本。

覆盖：
类 TimeZone 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

hashCode

public int hashCode()
生成 SimpleDateFormat 对象的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较两个 SimpleTimeZone 对象的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的 SimpleTimeZone 对象。
返回：
如果给定的 obj 与此 SimpleTimeZone 对象相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hasSameRules

public boolean hasSameRules(TimeZone other)
如果此时区与另一时区具有相同的规则和偏移量，则返回 true。

覆盖：
类 TimeZone 中的 hasSameRules
参数：
other - 要与之比较的 TimeZone 对象。
返回：
如果给定时区为 SimpleTimeZone，而且与此时区具有相同的规则和偏移量，则返回 true。
从以下版本开始：
1.2

toString

public String toString()
返回此时区的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此时区的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SortedMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 SortedMap<K,V>

类型参数：
K - 此映射所维护的键的类型
V - 映射值的类型
所有超级接口：
Map<K,V>
所有已知子接口：
ConcurrentNavigableMap<K,V>, NavigableMap<K,V>
所有已知实现类：
ConcurrentSkipListMap, TreeMap
public interface SortedMap<K,V>
extends Map<K,V>

进一步提供关于键的总体排序 的 Map。该映射是根据其键的自然顺序进行排序的，或者根据通常在创建有序映射时提供的 Comparator 进行排序。对有序映射的 collection 视图（由 entrySet、keySet 和 values 方法返回）进行迭代时，此顺序就会反映出来。要采用此排序方式，还需要提供一些其他操作（此接口是 SortedSet 的对应映射）。

插入有序映射的所有键都必须实现 Comparable 接口（或者被指定的比较器接受）。另外，所有这些键都必须是可互相比较的：对有序映射中的任意两个键 k1 和 k2 执行 k1.compareTo(k2)（或 comparator.compare(k1, k2)）都不得抛出 ClassCastException。试图违反此限制将导致违反规则的方法或者构造方法调用抛出 ClassCastException。

注意，如果有序映射要正确实现 Map 接口，则有序映射所维持的顺序（无论是否提供了明确的比较器）都必须与 equals 一致。（有关与 equals 一致 的精确定义，请参阅 Comparable 接口或 Comparator 接口）。这是因为 Map 接口是按照 equals 操作定义的，但有序映射使用它的 compareTo（或 compare）方法对所有键进行比较，因此从有序映射的角度来看，此方法认为相等的两个键就是相等的。即使顺序与 equals 不一致，树映射的行为仍然是 定义良好的，只不过没有遵守 Map 接口的常规协定。

所有通用有序映射实现类都应该提供 4 个“标准”构造方法：1) void（无参数）构造方法，它创建一个空的有序映射，按照键的自然顺序进行排序。2) 带有一个 Comparator 类型参数的构造方法，它创建一个空的有序映射，根据指定的比较器进行排序。3) 带有一个 Map 类型参数的构造方法，它创建一个新的有序映射，其键-值映射关系与参数相同，按照键的自然顺序进行排序。4) 带有一个 SortedMap 类型参数的构造方法，它创建一个新的有序映射，其键-值映射关系和排序方法与输入的有序映射相同。无法保证强制实施此建议，因为接口不能包含构造方法。

注：一些方法返回具有受限键范围的子映射。这些范围区间是半开的，也就是说，它们包括低端点，但不包括高端点（如果适用）。如果需要一个闭区间（同时包括两个端点），且键类型允许计算给定键值的后继值，则只需要请求从 lowEndpoint 到 successor(highEndpoint) 的子区间。例如，假设 m 是一个用字符串作为键的映射。下面的语句将得到一个包含 m 中键在 low 和 high（包括）之间的所有键-值映射关系的视图：

   SortedMap<String, V> sub = m.subMap(low, high+"\0");
可使用类似的技术生成一个开区间 （两个端点都不包括）。下面的语句将得到一个包含 m 中键在 low 和 high（不包括）之间的所有键-值映射关系的视图：
   SortedMap<String, V> sub = m.subMap(low+"\0", high);

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Map, TreeMap, SortedSet, Comparator, Comparable, Collection, ClassCastException

嵌套类摘要
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
方法摘要
Comparator<? super K> | comparator() 返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。
Set<Map.Entry<K,V>> | entrySet() 返回在此映射中包含的映射关系的 Set 视图。
K | firstKey() 返回此映射中当前第一个（最低）键。
SortedMap<K,V> | headMap(K toKey) 返回此映射的部分视图，其键值严格小于 toKey。
Set<K> | keySet() 返回在此映射中所包含键的 Set 视图。
K | lastKey() 返回映射中当前最后一个（最高）键。
SortedMap<K,V> | subMap(K fromKey, K toKey) 返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
SortedMap<K,V> | tailMap(K fromKey) 返回此映射的部分视图，其键大于等于 fromKey。
Collection<V> | values() 返回在此映射中所包含值的 Collection 视图。
从接口 java.util.Map 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, put, putAll, remove, size

方法详细信息

comparator

Comparator<? super K> comparator()
返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。

返回：
用来对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null

subMap

SortedMap<K,V> subMap(K fromKey,
                      K toKey)
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。（如果 fromKey 和 toKey 相等，则返回映射为空。）返回的映射受此映射支持，所以在返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

参数：
fromKey - 返回映射中键的低端点（包括）
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）
抛出：
ClassCastException - 如果无法使用此映射的比较器（如果此映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

SortedMap<K,V> headMap(K toKey)
返回此映射的部分视图，其键值严格小于 toKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

参数：
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，该映射的键严格小于 toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

SortedMap<K,V> tailMap(K fromKey)
返回此映射的部分视图，其键大于等于 fromKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

参数：
fromKey - 返回映射中键的低端点（包括）
返回：
此映射的部分视图，其键大于等于 fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外

firstKey

K firstKey()
返回此映射中当前第一个（最低）键。

返回：
此映射中当前第一个（最低）键
抛出：
NoSuchElementException - 如果此映射为空

lastKey

K lastKey()
返回映射中当前最后一个（最高）键。

返回：
此映射中当前最后一个（最高）键
抛出：
NoSuchElementException - 如果此映射为空

keySet

Set<K> keySet()
返回在此映射中所包含键的 Set 视图。该 set 的迭代器将按升序返回这些键。该 set 受映射支持，所以对映射的更改将反映在此 set 中，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。此 set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 keySet
返回：
此映射所包含的键的 set 视图，按升序排序

values

Collection<V> values()
返回在此映射中所包含值的 Collection 视图。该 collection 的迭代器将按对应键的升序返回这些值。该 collection 受映射支持，所以对映射的更改将反映在此 collection 中，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。该 collection 支持元素的移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 values
返回：
此映射所包含的值的 collection 视图，按升序排序

entrySet

Set<Map.Entry<K,V>> entrySet()
返回在此映射中包含的映射关系的 Set 视图。该 set 的迭代器将按升序键顺序返回这些条目。该 set 受映射支持，所以对映射的更改将反映在此 set 中，反之亦然。如果修改映射的同时正在对该 set 进行迭代（除了通过迭代器自己的 remove 操作，或者通过在迭代器返回的映射项上执行 setValue 操作外），则迭代结果是不确定的。此 set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 entrySet
返回：
此映射所包含的映射关系的 set 视图，按升序键排序
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SortedSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
接口 SortedSet<E>

类型参数：
E - 此 set 维护的元素的类型
所有超级接口：
Collection<E>, Iterable<E>, Set<E>
所有已知子接口：
NavigableSet<E>
所有已知实现类：
ConcurrentSkipListSet, TreeSet
public interface SortedSet<E>
extends Set<E>

进一步提供关于元素的总体排序 的 Set。这些元素使用其自然顺序进行排序，或者根据通常在创建有序 set 时提供的 Comparator 进行排序。该 set 的迭代器将按元素升序遍历 set。提供了一些附加的操作来利用这种排序。（此接口是 SortedMap 的 set 对应接口）。

插入有序 set 的所有元素都必须实现 Comparable 接口（或者被指定的比较器所接受）。另外，所有这些元素都必须是可互相比较的：对于有序 set 中的任意两个元素 e1 和 e2，执行 e1.compareTo(e2)（或 comparator.compare(e1, e2)）都不得抛出 ClassCastException。试图违反此限制将导致违反规则的方法或者构造方法调用抛出 ClassCastException。

注意，如果有序 set 要正确实现 Set 接口，则有序 set 所维持的顺序（无论是否提供了明确的比较器）都必须与 equals 一致。（有关与 equals 一致 的精确定义，请参阅 Comparable 接口或 Comparator 接口。）这是因为 Set 接口是按照 equals 操作定义的，但有序 set 使用它的 compareTo（或 compare）方法对所有元素进行比较，因此从有序 set 的角度来看，此方法认为相等的两个元素就是相等的。即使顺序与 equals 不一致，有序 set 的行为仍然是 定义良好的，只不过没有遵守 Set 接口的常规协定。

所有通用有序 set 实现类都应该提供 4 个“标准”构造方法：1) void（无参数）构造方法，它创建一个空的有序 set，按照元素的自然顺序进行排序。2) 带有一个 Comparator 类型参数的构造方法，它创建一个空的有序 set，根据指定的比较器进行排序。3) 带有一个 Collection 类型参数的构造方法，它创建一个新的有序 set，其元素与参数相同，按照元素的自然顺序进行排序。4) 带有一个 SortedSet 类型参数的构造方法，它创建一个新的有序 set，其元素和排序方法与输入的有序 set 相同。无法保证强制实施此建议，因为接口不能包含构造方法。

注：一些方法返回具有受限范围的子集。这些范围区间是半开的，也就是说，它们包括低端点，但不包括高端点（如果适用）。如果需要一个闭区间（同时包含两个端点），且元素类型允许计算给定值的后继值，则只需要请求从 lowEndpoint 到 successor(highEndpoint) 的子区间。例如，假设 s 是一个字符串有序 set。下面的语句将得到一个包含 s 中从 low 到 high（包括）所有字符串的视图：

   SortedSet<String> sub = s.subSet(low, high+"\0");
可使用类似的技术生成开区间（两个端点都不包括）。下面的语句得到包含 s 中从 low 到 high（不包括）所有字符串的视图：
   SortedSet<String> sub = s.subSet(low+"\0", high);

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Set, TreeSet, SortedMap, Collection, Comparable, Comparator, ClassCastException

方法摘要
Comparator<? super E> | comparator() 返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。
E | first() 返回此 set 中当前第一个（最低）元素。
SortedSet<E> | headSet(E toElement) 返回此 set 的部分视图，其元素严格小于 toElement。
E | last() 返回此 set 中当前最后一个（最高）元素。
SortedSet<E> | subSet(E fromElement, E toElement) 返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
SortedSet<E> | tailSet(E fromElement) 返回此 set 的部分视图，其元素大于等于 fromElement。
从接口 java.util.Set 继承的方法
add, addAll, clear, contains, containsAll, equals, hashCode, isEmpty, iterator, remove, removeAll, retainAll, size, toArray, toArray

方法详细信息

comparator

Comparator<? super E> comparator()
返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。

返回：
用来对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null

subSet

SortedSet<E> subSet(E fromElement,
                    E toElement)
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。（如果 fromElement 和 toElement 相等，则返回空的 set）。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

参数：
fromElement - 返回 set 的低端点（包括）
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素的范围从 fromElement（包括）到 toElement（不包括）
抛出：
ClassCastException - 如果无法使用此 set 的比较器（如果 set 没有比较器，则使用自然顺序）比较 fromElement 和 toElement。如果 fromElement 或 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 或 toElement 为 null，并且此 set 不允许 null 元素
IllegalArgumentException - 如果 fromElement 大于 toElement；如果此 set 本身有范围限制，并且 fromElement 或 toElement 位于范围的边界之外

headSet

SortedSet<E> headSet(E toElement)
返回此 set 的部分视图，其元素严格小于 toElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

参数：
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素严格小于 toElement
抛出：
ClassCastException - 如果 toElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 toElement 没有实现 Comparable）。如果 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toElement 为 null，并且此 set 不允许 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 toElement 位于范围的边界之外

tailSet

SortedSet<E> tailSet(E fromElement)
返回此 set 的部分视图，其元素大于等于 fromElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

参数：
fromElement - 返回 set 的低端点（包括）
返回：
此 set 的部分视图，其元素大于等于 fromElement
抛出：
ClassCastException - 如果 fromElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 fromElement 没有实现 Comparable）。如果 fromElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 为 null，并且此 set 不允许 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 fromElement 位于范围的边界之外

first

E first()
返回此 set 中当前第一个（最低）元素。

返回：
此 set 中当前第一个（最低）元素
抛出：
NoSuchElementException - 如果此 set 为空

last

E last()
返回此 set 中当前最后一个（最高）元素。

返回：
此 set 中当前最后一个（最高）元素
抛出：
NoSuchElementException - 如果此 set 为空
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Stack (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Stack<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.Vector<E>
                继承者  java.util.Stack<E>
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, List<E>, RandomAccess
public class Stack<E>
extends Vector<E>

Stack 类表示后进先出（LIFO）的对象堆栈。它通过五个操作对类 Vector 进行了扩展 ，允许将向量视为堆栈。它提供了通常的 push 和 pop 操作，以及取堆栈顶点的 peek 方法、测试堆栈是否为空的 empty 方法、在堆栈中查找项并确定到堆栈顶距离的 search 方法。

首次创建堆栈时，它不包含项。

Deque 接口及其实现提供了 LIFO 堆栈操作的更完整和更一致的 set，应该优先使用此 set，而非此类。例如：

   Deque<Integer> stack = new ArrayDeque<Integer>();

从以下版本开始：
JDK1.0
另请参见：
序列化表格

字段摘要
从类 java.util.Vector 继承的字段
capacityIncrement, elementCount, elementData
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
Stack()
创建一个空堆栈。
方法摘要
boolean | empty() 测试堆栈是否为空。
E | peek() 查看堆栈顶部的对象，但不从堆栈中移除它。
E | pop() 移除堆栈顶部的对象，并作为此函数的值返回该对象。
E | push(E item) 把项压入堆栈顶部。
int | search(Object o) 返回对象在堆栈中的位置，以 1 为基数。
从类 java.util.Vector 继承的方法
add, add, addAll, addAll, addElement, capacity, clear, clone, contains, containsAll, copyInto, elementAt, elements, ensureCapacity, equals, firstElement, get, hashCode, indexOf, indexOf, insertElementAt, isEmpty, lastElement, lastIndexOf, lastIndexOf, remove, remove, removeAll, removeAllElements, removeElement, removeElementAt, removeRange, retainAll, set, setElementAt, setSize, size, subList, toArray, toArray, toString, trimToSize
从类 java.util.AbstractList 继承的方法
iterator, listIterator, listIterator
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
iterator, listIterator, listIterator

构造方法详细信息

Stack

public Stack()
创建一个空堆栈。

方法详细信息

push

public E push(E item)
把项压入堆栈顶部。其作用与下面的方法完全相同：
 addElement(item)

参数：
item - 压入堆栈的项。
返回：
item 参数。
另请参见：
Vector.addElement(E)

pop

public E pop()
移除堆栈顶部的对象，并作为此函数的值返回该对象。

返回：
堆栈顶部的对象（Vector 对象中的最后一项）。
抛出：
EmptyStackException - 如果堆栈为空。

peek

public E peek()
查看堆栈顶部的对象，但不从堆栈中移除它。

返回：
堆栈顶部的对象（Vector 对象的最后一项）。
抛出：
EmptyStackException - 如果堆栈为空。

empty

public boolean empty()
测试堆栈是否为空。

返回：
当且仅当堆栈中不含任何项时返回 true；否则返回 false。

search

public int search(Object o)
返回对象在堆栈中的位置，以 1 为基数。如果对象 o 是堆栈中的一个项，此方法返回距堆栈顶部最近的出现位置到堆栈顶部的距离；堆栈中最顶部项的距离为 1。使用 equals 方法比较 o 与堆栈中的项。

参数：
o - 目标对象。
返回：
对象到堆栈顶部的位置，以 1 为基数；返回值 -1 表示此对象不在堆栈中。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringTokenizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 StringTokenizer

java.lang.Object
    继承者  java.util.StringTokenizer
所有已实现的接口：
Enumeration<Object>
public class StringTokenizer
extends Object
implements Enumeration<Object>

string tokenizer 类允许应用程序将字符串分解为标记。tokenization 方法比 StreamTokenizer 类所使用的方法更简单。StringTokenizer 方法不区分标识符、数和带引号的字符串，它们也不识别并跳过注释。

可以在创建时指定，也可以根据每个标记来指定分隔符（分隔标记的字符）集。

StringTokenizer 的实例有两种行为方式，这取决于它在创建时使用的 returnDelims 标志的值是 true 还是 false：

  • 如果标志为 false，则分隔符字符用来分隔标记。标记是连续字符（不是分隔符）的最大序列。
  • 如果标志为 true，则认为那些分隔符字符本身即为标记。因此标记要么是一个分隔符字符，要么是那些连续字符（不是分隔符）的最大序列。

StringTokenizer 对象在内部维护字符串中要被标记的当前位置。某些操作将此当前位置移至已处理的字符后。

通过截取字符串的一个子串来返回标记，该字符串用于创建 StringTokenizer 对象。

下面是一个使用 tokenizer 的实例。代码如下：

     StringTokenizer st = new StringTokenizer("this is a test");
     while (st.hasMoreTokens()) {
         System.out.println(st.nextToken());
     }

输出以下字符串：

     this
     is
     a
     test

StringTokenizer 是出于兼容性的原因而被保留的遗留类（虽然在新代码中并不鼓励使用它）。建议所有寻求此功能的人使用 String 的 split 方法或 java.util.regex 包。

下面的示例阐明了如何使用 String.split 方法将字符串分解为基本标记：

     String[] result = "this is a test".split("\\s");
     for (int x=0; x<result.length; x++)
         System.out.println(result[x]);

输出以下字符串：

     this
     is
     a
     test

从以下版本开始：
JDK1.0
另请参见：
StreamTokenizer

构造方法摘要
StringTokenizer(String str)
为指定字符串构造一个 string tokenizer。
StringTokenizer(String str, String delim)
为指定字符串构造一个 string tokenizer。
StringTokenizer(String str, String delim, boolean returnDelims)
为指定字符串构造一个 string tokenizer。
方法摘要
int | countTokens() 计算在生成异常之前可以调用此 tokenizer 的 nextToken 方法的次数。
boolean | hasMoreElements() 返回与 hasMoreTokens 方法相同的值。
boolean | hasMoreTokens() 测试此 tokenizer 的字符串中是否还有更多的可用标记。
Object | nextElement() 除了其声明返回值是 Object 而不是 String 之外，它返回与 nextToken 方法相同的值。
String | nextToken() 返回此 string tokenizer 的下一个标记。
String | nextToken(String delim) 返回此 string tokenizer 的字符串中的下一个标记。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StringTokenizer

public StringTokenizer(String str,
                       String delim,
                       boolean returnDelims)
为指定字符串构造一个 string tokenizer。delim 参数中的所有字符都是分隔标记的分隔符。

如果 returnDelims 标志为 true，则分隔符字符也作为标记返回。每个分隔符都作为一个长度为 1 的字符串返回。如果标志为 false，则跳过分隔符，只是用作标记之间的分隔符。

注意，如果 delim 为 null，则此构造方法不抛出异常。但是，尝试对得到的 StringTokenizer 调用其他方法则可能抛出 NullPointerException。

参数：
str - 要解析的字符串。
delim - 分隔符。
returnDelims - 指示是否将分隔符作为标记返回的标志。
抛出：
NullPointerException - 如果 str 为 null。

StringTokenizer

public StringTokenizer(String str,
                       String delim)
为指定字符串构造一个 string tokenizer。delim 参数中的字符都是分隔标记的分隔符。分隔符字符本身不作为标记。

注意，如果 delim 为 null，则此构造方法不抛出异常。但是，尝试对得到的 StringTokenizer 调用其他方法则可能抛出 NullPointerException。

参数：
str - 要解析的字符串。
delim - 分隔符。
抛出：
NullPointerException - 如果 str 为 null。

StringTokenizer

public StringTokenizer(String str)
为指定字符串构造一个 string tokenizer。tokenizer 使用默认的分隔符集 " \t\n\r\f"，即：空白字符、制表符、换行符、回车符和换页符。分隔符字符本身不作为标记。

参数：
str - 要解析的字符串。
抛出：
NullPointerException - 如果 str 为 null。
方法详细信息

hasMoreTokens

public boolean hasMoreTokens()
测试此 tokenizer 的字符串中是否还有更多的可用标记。如果此方法返回 true，那么后续调用无参数的 nextToken 方法将成功地返回一个标记。

返回：
当且仅当该字符串中当前位置后至少有一个标记时才为 true；否则为 false。

nextToken

public String nextToken()
返回此 string tokenizer 的下一个标记。

返回：
此 string tokenizer 的下一个标记。
抛出：
NoSuchElementException - 如果此 tokenizer 的字符串中没有更多标记。

nextToken

public String nextToken(String delim)
返回此 string tokenizer 的字符串中的下一个标记。首先，字符集被更改为字符串 delim 中的字符，该字符集被认为是 StringTokenizer 对象的分隔符。接着返回字符串中当前位置之后的下一个标记。当前位置被提前到所识别的标记前。进行此调用后新的分隔符集仍然保持默认值。

参数：
delim - 新的分隔符。
返回：
转换到新的分隔符集后的下一个标记。
抛出：
NoSuchElementException - 如果此 tokenizer 的字符串中没有更多标记。
NullPointerException - 如果 delim 为 null。

hasMoreElements

public boolean hasMoreElements()
返回与 hasMoreTokens 方法相同的值。它的存在使得此类可以实现 Enumeration 接口。

指定者：
接口 Enumeration<Object> 中的 hasMoreElements
返回：
如果有更多标记，则为 true；否则为 false。
另请参见：
Enumeration, hasMoreTokens()

nextElement

public Object nextElement()
除了其声明返回值是 Object 而不是 String 之外，它返回与 nextToken 方法相同的值。它的存在使得此类可以实现 Enumeration 接口。

指定者：
接口 Enumeration<Object> 中的 nextElement
返回：
字符串中的下一个标记。
抛出：
NoSuchElementException - 如果此 tokenizer 的字符串中没有更多标记。
另请参见：
Enumeration, nextToken()

countTokens

public int countTokens()
计算在生成异常之前可以调用此 tokenizer 的 nextToken 方法的次数。当前位置没有提前。

返回：
使用当前分隔符集的字符串中剩余的标记数。
另请参见：
nextToken()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Timer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Timer

java.lang.Object
    继承者  java.util.Timer

public class Timer
extends Object

一种工具，线程用其安排以后在后台线程中执行的任务。可安排任务执行一次，或者定期重复执行。

与每个 Timer 对象相对应的是单个后台线程，用于顺序地执行所有计时器任务。计时器任务应该迅速完成。如果完成某个计时器任务的时间太长，那么它会“独占”计时器的任务执行线程。因此，这就可能延迟后续任务的执行，而这些任务就可能“堆在一起”，并且在上述不友好的任务最终完成时才能够被快速连续地执行。

对 Timer 对象最后的引用完成后，并且 所有未处理的任务都已执行完成后，计时器的任务执行线程会正常终止（并且成为垃圾回收的对象）。但是这可能要很长时间后才发生。默认情况下，任务执行线程并不作为守护线程 来运行，所以它能够阻止应用程序终止。如果调用者想要快速终止计时器的任务执行线程，那么调用者应该调用计时器的 cancel 方法。

如果意外终止了计时器的任务执行线程，例如调用了它的 stop 方法，那么所有以后对该计时器安排任务的尝试都将导致 IllegalStateException，就好像调用了计时器的 cancel 方法一样。

此类是线程安全的：多个线程可以共享单个 Timer 对象而无需进行外部同步。

此类不 提供实时保证：它使用 Object.wait(long) 方法来安排任务。

实现注意事项：此类可扩展到大量同时安排的任务（存在数千个都没有问题）。在内部，它使用二进制堆来表示其任务队列，所以安排任务的开销是 O(log n)，其中 n 是同时安排的任务数。

实现注意事项：所有构造方法都启动计时器线程。

从以下版本开始：
1.3
另请参见：
TimerTask, Object.wait(long)

构造方法摘要
Timer()
创建一个新计时器。
Timer(boolean isDaemon)
创建一个新计时器，可以指定其相关的线程作为守护程序运行。
Timer(String name)
创建一个新计时器，其相关的线程具有指定的名称。
Timer(String name, boolean isDaemon)
创建一个新计时器，其相关的线程具有指定的名称，并且可以指定作为守护程序运行。
方法摘要
void | cancel() 终止此计时器，丢弃所有当前已安排的任务。
int | purge() 从此计时器的任务队列中移除所有已取消的任务。
void | schedule(TimerTask task, Date time) 安排在指定的时间执行指定的任务。
void | schedule(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定延迟执行。
void | schedule(TimerTask task, long delay) 安排在指定延迟后执行指定的任务。
void | schedule(TimerTask task, long delay, long period) 安排指定的任务从指定的延迟后开始进行重复的固定延迟执行。
void | scheduleAtFixedRate(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定速率执行。
void | scheduleAtFixedRate(TimerTask task, long delay, long period) 安排指定的任务在指定的延迟后开始进行重复的固定速率执行。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Timer

public Timer()
创建一个新计时器。相关的线程不 作为守护程序运行。

另请参见：
Thread, cancel()

Timer

public Timer(boolean isDaemon)
创建一个新计时器，可以指定其相关的线程作为守护程序运行。如果计时器将用于安排重复的“维护活动”，则调用守护线程，在应用程序运行期间必须调用守护线程，但是该操作不应延长程序的生命周期。

参数：
isDaemon - 如果应该将相关的线程作为守护程序运行，则为 true。
另请参见：
Thread, cancel()

Timer

public Timer(String name)
创建一个新计时器，其相关的线程具有指定的名称。相关的线程不 作为守护程序运行。

参数：
name - 相关线程的名称。
抛出：
NullPointerException - 如果 name 为 null。
从以下版本开始：
1.5
另请参见：
Thread.getName(), Thread.isDaemon()

Timer

public Timer(String name,
             boolean isDaemon)
创建一个新计时器，其相关的线程具有指定的名称，并且可以指定作为守护程序运行。

参数：
name - 相关线程的名称。
isDaemon - 如果应该将相关的线程作为守护程序运行，则为 true。
抛出：
NullPointerException - 如果 name 为 null。
从以下版本开始：
1.5
另请参见：
Thread.getName(), Thread.isDaemon()
方法详细信息

schedule

public void schedule(TimerTask task,
                     long delay)
安排在指定延迟后执行指定的任务。

参数：
task - 所要安排的任务。
delay - 执行任务前的延迟时间，单位是毫秒。
抛出：
IllegalArgumentException - 如果 delay 是负数，或者 delay + System.currentTimeMillis() 是负数。
IllegalStateException - 如果已经安排或取消了任务，或者已经取消计时器。

schedule

public void schedule(TimerTask task,
                     Date time)
安排在指定的时间执行指定的任务。如果此时间已过去，则安排立即执行该任务。

参数：
task - 所要安排的任务。
time - 执行任务的时间。
抛出：
IllegalArgumentException - 如果 time.getTime() 是负数。
IllegalStateException - 如果已经安排或取消了任务，已经取消了计时器，或者计时器线程已终止。

schedule

public void schedule(TimerTask task,
                     long delay,
                     long period)
安排指定的任务从指定的延迟后开始进行重复的固定延迟执行。以近似固定的时间间隔（由指定的周期分隔）进行后续执行。

在固定延迟执行中，根据前一次执行的实际执行时间来安排每次执行。如果由于任何原因（如垃圾回收或其他后台活动）而延迟了某次执行，则后续执行也将被延迟。从长期来看，执行的频率一般要稍慢于指定周期的倒数（假定 Object.wait(long) 所依靠的系统时钟是准确的）。

固定延迟执行适用于那些需要“平稳”运行的重复活动。换句话说，它适用于在短期运行中保持频率准确要比在长期运行中更为重要的活动。这包括大多数动画任务，如以固定时间间隔闪烁的光标。这还包括为响应人类活动所执行的固定活动，如在按住键时自动重复输入字符。

参数：
task - 所要安排的任务。
delay - 执行任务前的延迟时间，单位是毫秒。
period - 执行各后续任务之间的时间间隔，单位是毫秒。
抛出：
IllegalArgumentException - 如果 delay 是负数，或者 delay + System.currentTimeMillis() 是负数。
IllegalStateException - 如果已经安排或取消了任务，已经取消了计时器，或者计时器线程已终止。

schedule

public void schedule(TimerTask task,
                     Date firstTime,
                     long period)
安排指定的任务在指定的时间开始进行重复的固定延迟执行。以近似固定的时间间隔（由指定的周期分隔）进行后续执行。

在固定延迟执行中，根据前一次执行的实际执行时间来安排每次执行。如果由于任何原因（如垃圾回收或其他后台活动）而延迟了某次执行，则后续执行也将被延迟。在长期运行中，执行的频率一般要稍慢于指定周期的倒数（假定 Object.wait(long) 所依靠的系统时钟是准确的）。

固定延迟执行适用于那些需要“平稳”运行的重复执行活动。换句话说，它适用于在短期运行中保持频率准确要比在长期运行中更为重要的活动。这包括大多数动画任务，如以固定时间间隔闪烁的光标。这还包括为响应人类活动所执行的固定活动，如在按住键时自动重复输入字符。

参数：
task - 所要安排的任务。
firstTime - 首次执行任务的时间。
period - 执行各后续任务之间的时间间隔，单位是毫秒。
抛出：
IllegalArgumentException - 如果 time.getTime() 是负数。
IllegalStateException - 如果已经安排或取消了任务，已经取消了计时器，或者计时器线程已终止。

scheduleAtFixedRate

public void scheduleAtFixedRate(TimerTask task,
                                long delay,
                                long period)
安排指定的任务在指定的延迟后开始进行重复的固定速率执行。以近似固定的时间间隔（由指定的周期分隔）进行后续执行。

在固定速率执行中，根据已安排的初始执行时间来安排每次执行。如果由于任何原因（如垃圾回收或其他后台活动）而延迟了某次执行，则将快速连续地出现两次或更多的执行，从而使后续执行能够“追赶上来”。从长远来看，执行的频率将正好是指定周期的倒数（假定 Object.wait(long) 所依靠的系统时钟是准确的）。

固定速率执行适用于那些对绝对 时间敏感的重复执行活动，如每小时准点打钟报时，或者在每天的特定时间运行已安排的维护活动。它还适用于那些完成固定次数执行的总计时间很重要的重复活动，如倒计时的计时器，每秒钟滴答一次，共 10 秒钟。最后，固定速率执行适用于安排多个重复执行的计时器任务，这些任务相互之间必须保持同步。

参数：
task - 所要安排的任务。
delay - 执行任务前的延迟时间，单位是毫秒。
period - 执行各后续任务之间的时间间隔，单位是毫秒。
抛出：
IllegalArgumentException - 如果 delay 是负数，或者 delay + System.currentTimeMillis() 是负数。
IllegalStateException - 如果已经安排或取消了任务，已经取消了计时器，或者计时器线程已终止。

scheduleAtFixedRate

public void scheduleAtFixedRate(TimerTask task,
                                Date firstTime,
                                long period)
安排指定的任务在指定的时间开始进行重复的固定速率执行。以近似固定的时间间隔（由指定的周期分隔）进行后续执行。

在固定速率执行中，相对于已安排的初始执行时间来安排每次执行。如果由于任何原因（如垃圾回收或其他后台活动）而延迟了某次执行，则将快速连续地出现两次或更多次执行，从而使后续执行能够赶上来。从长远来看，执行的频率将正好是指定周期的倒数（假定 Object.wait(long) 所依靠的系统时钟是准确的）。

固定速率执行适用于那些对绝对 时间敏感的重复执行活动，如每小时准点打钟报时，或者在每天的特定时间运行已安排的维护活动。它还适用于那些完成固定次数执行的总计时间很重要的重复活动，如倒计时的计时器，每秒钟滴答一次，共 10 秒钟。最后，固定速率执行适用于安排多次重复执行的计时器任务，这些任务相互之间必须保持同步。

参数：
task - 所要安排的任务。
firstTime - 首次执行任务的时间。
period - 执行各后续任务之间的时间间隔，单位是毫秒。
抛出：
IllegalArgumentException - 如果 time.getTime() 是负数。
IllegalStateException - 如果已经安排或取消了任务，已经取消了计时器，或者计时器线程已终止。

cancel

public void cancel()
终止此计时器，丢弃所有当前已安排的任务。这不会干扰当前正在执行的任务（如果存在）。一旦终止了计时器，那么它的执行线程也会终止，并且无法根据它安排更多的任务。

注意，在此计时器调用的计时器任务的 run 方法内调用此方法，就可以绝对确保正在执行的任务是此计时器所执行的最后一个任务。

可以重复调用此方法；但是第二次和后续调用无效。

purge

public int purge()
从此计时器的任务队列中移除所有已取消的任务。调用此方法对计时器的行为没有影响，但是将无法引用队列中已取消的任务。如果没有对这些任务的外部引用，则它们就成为垃圾回收的合格对象。

多数程序无需调用此方法。它设计用于一些罕见的应用程序，这些程序可取消大量的任务。调用此方法要以时间来换取空间：此方法的运行时可能与 n + c log n 呈正比，其中 n 是队列中的任务数，而 c 是取消的任务数。

注意，从此计时器上所安排的任务中调用此方法是允许的。

返回：
从队列中移除的任务数。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimerTask (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 TimerTask

java.lang.Object
    继承者  java.util.TimerTask
所有已实现的接口：
Runnable
public abstract class TimerTask
extends Object
implements Runnable

由 Timer 安排为一次执行或重复执行的任务。

从以下版本开始：
1.3
另请参见：
Timer

构造方法摘要
protected TimerTask()
创建一个新的计时器任务。
方法摘要
boolean | cancel() 取消此计时器任务。
abstract void | run() 此计时器任务要执行的操作。
long | scheduledExecutionTime() 返回此任务最近实际 执行的已安排 执行时间。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TimerTask

protected TimerTask()
创建一个新的计时器任务。

方法详细信息

run

public abstract void run()
此计时器任务要执行的操作。

指定者：
接口 Runnable 中的 run
另请参见：
Thread.run()

cancel

public boolean cancel()
取消此计时器任务。如果任务安排为一次执行且还未运行，或者尚未安排，则永远不会运行。如果任务安排为重复执行，则永远不会再运行。（如果发生此调用时任务正在运行，则任务将运行完，但永远不会再运行。）

注意，从重复的计时器任务的 run 方法中调用此方法绝对保证计时器任务不会再运行。

此方法可以反复调用；第二次和以后的调用无效。

返回：
如果此任务安排为一次执行且尚未运行，或者此任务安排为重复执行，则返回 true。如果此任务安排为一次执行且已经运行，或者此任务尚未安排，或者此任务已经取消，则返回 false。（一般来说，如果此方法不允许发生一个或多个已安排执行，则返回 true。）

scheduledExecutionTime

public long scheduledExecutionTime()
返回此任务最近实际 执行的已安排 执行时间。（如果在任务执行过程中调用此方法，则返回值为此任务执行的已安排执行时间。）

通常从一个任务的 run 方法中调用此方法，以确定当前任务执行是否能充分及时地保证完成已安排活动：

   public void run() {
       if (System.currentTimeMillis() - scheduledExecutionTime() >=
           MAX_TARDINESS)
               return;  // Too late; skip this execution.
       // Perform the task
   }
通常，此方法不 与固定延迟执行 的重复任务一起使用，因为其已安排执行时间允许随时间浮动，所以毫无意义。

返回：
最近发生此任务执行安排的时间，采用 Date.getTime() 返回的格式。如果任务已开始其首次执行，则返回值不确定。
另请参见：
Date.getTime()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimeZone (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 TimeZone

java.lang.Object
    继承者  java.util.TimeZone
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
SimpleTimeZone
public abstract class TimeZone
extends Object
implements Serializable, Cloneable

TimeZone 表示时区偏移量，也可以计算夏令时。

通常，使用 getDefault 获取 TimeZone，getDefault 基于程序运行所在的时区创建 TimeZone。例如，对于在日本运行的程序，getDefault 基于日本标准时间创建 TimeZone 对象。

也可以用 getTimeZone 及时区 ID 获取 TimeZone 。例如美国太平洋时区的时区 ID 是 "America/Los_Angeles"。因此，可以使用下面语句获得美国太平洋时间 TimeZone 对象：

 TimeZone tz = TimeZone.getTimeZone("America/Los_Angeles");
可以使用 getAvailableIDs 方法来对所有受支持的时区 ID 进行迭代。可以选择受支持的 ID 来获得 TimeZone。如果想要的时区无法用受支持的 ID 之一表示，那么可以指定自定义时区 ID 来生成 TimeZone。自定义时区 ID 的语法是：
 CustomID:
         GMT Sign Hours : Minutes
         GMT Sign Hours Minutes
         GMT Sign Hours
Sign: 下面之一
         + -
 Hours:
         Digit
         Digit Digit
 Minutes:
         Digit Digit
 Digit: 下面之一
         0 1 2 3 4 5 6 7 8 9
Hours 必须在 0 至 23 之间，Minutes 必须在 00 至 59 之间。例如，"GMT+10" 和 "GMT+0010" 分别意味着比 GMT 提前 10 小时和 10 分钟。

格式是与区域无关的，并且数字必须取自 Unicode 标准的 Basic Latin 块。没有夏令时转换安排可以用自定义时区 ID 指定。如果指定的字符串与语法不匹配，就使用 "GMT"。

当创建一个 TimeZone 时，指定的自定义时区 ID 采用下面的语法进行标准化：

 NormalizedCustomID:
         GMT Sign TwoDigitHours : Minutes
Sign: 下面之一
         + -
 TwoDigitHours:
         Digit Digit
 Minutes:
         Digit Digit
 Digit: 下面之一
         0 1 2 3 4 5 6 7 8 9
例如，TimeZone.getTimeZone("GMT-8").getID() 返回 "GMT-08:00"。

三字母时区 ID

为了与 JDK 1.1.x 兼容，一些三字母时区 ID（比如 "PST"、"CTT"、"AST"）也受支持。但是，它们的使用被废弃，这是因为相同的缩写经常用于多个时区（例如，"CST" 可以是美国的 "Central Standard Time" 和 "China Standard Time"），但是 Java 平台只可以识别其中一种。

从以下版本开始：
JDK1.1
另请参见：
Calendar, GregorianCalendar, SimpleTimeZone, 序列化表格

字段摘要
static int | LONG 指出长名称的 getDisplayName() 的风格说明符。
static int | SHORT 指出短名称（比如 "PST"）的 getDisplayName() 的风格说明符。
构造方法摘要
TimeZone()
单独的构造方法。
方法摘要
Object | clone() 创建此 TimeZone 的一个副本。
static String[] | getAvailableIDs() 获取受支持的所有可用 ID。
static String[] | getAvailableIDs(int rawOffset) 根据给定的时区偏移量（以毫秒为单位）获取可用的 ID。
static TimeZone | getDefault() 获取此主机的默认 TimeZone。
String | getDisplayName() 返回适合于展示给默认区域的用户的时区名称。
String | getDisplayName(boolean daylight, int style) 返回适合于展示给默认区域的用户的时区名称。
String | getDisplayName(boolean daylight, int style, Locale locale) 返回适合于展示给指定区域的用户的时区名称。
String | getDisplayName(Locale locale) 返回适合于展示给指定区域的用户的时区名称。
int | getDSTSavings() 返回要添加到本地标准时间以获取本地挂钟时间的时间量。
String | getID() 获取此时区的 ID。
abstract int | getOffset(int era, int year, int month, int day, int dayOfWeek, int milliseconds) 获取当前日期的时区偏移量（在夏令时情况下进行修改）。
int | getOffset(long date) 从给定日期的 UTC 返回此时区的偏移量。
abstract int | getRawOffset() 返回添加到 UTC 以获取此时区中的标准时间的时间量（以毫秒为单位）。
static TimeZone | getTimeZone(String ID) 获取给定 ID 的 TimeZone。
boolean | hasSameRules(TimeZone other) 如果此区域和另一个区域具有相同的规则和偏移量，也就是说，如果此区域只可能在 ID 上与另一个区域不同，则返回 true。
abstract boolean | inDaylightTime(Date date) 查询给定的日期是否在此时区的夏令时中。
static void | setDefault(TimeZone zone) 设置由 getDefault 方法返回的 TimeZone。
void | setID(String ID) 设置时区 ID。
abstract void | setRawOffset(int offsetMillis) 把基准时区偏移量设置到 GMT。
abstract boolean | useDaylightTime() 查询此时区是否使用夏令时。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SHORT

public static final int SHORT
指出短名称（比如 "PST"）的 getDisplayName() 的风格说明符。

从以下版本开始：
1.2
另请参见：
LONG, 常量字段值

LONG

public static final int LONG
指出长名称的 getDisplayName() 的风格说明符。

从以下版本开始：
1.2
另请参见：
SHORT, 常量字段值
构造方法详细信息

TimeZone

public TimeZone()
单独的构造方法。（由子类构造方法调用，通常是隐式的。）

方法详细信息

getOffset

public abstract int getOffset(int era,
                              int year,
                              int month,
                              int day,
                              int dayOfWeek,
                              int milliseconds)
获取当前日期的时区偏移量（在夏令时情况下进行修改）。这是添加到 UTC 获取本地时间的偏移量。

如果底层 TimeZone 实现子类支持历史夏令时安排和 GMT 偏移量改变，那么此方法就返回历史上正确的偏移量。

参数：
era - 给定日期的年代。
year - 给定日期的年份。
month - 给定日期的月份。月份是从 0 开始的，比如 0 代表一月。
day - 给定日期的月份中的某一天。
dayOfWeek - 给定日期的一周中的某一天。
milliseconds - 标准 本地时间中天的毫秒数。
返回：
添加到 GMT 以获取本地时间的偏移量（以毫秒计）。
另请参见：
Calendar.ZONE_OFFSET, Calendar.DST_OFFSET

getOffset

public int getOffset(long date)
从给定日期的 UTC 返回此时区的偏移量。如果夏令时在指定的日期是有效的，就用夏令时调整偏移值。

如果底层 TimeZone 实现子类支持历史夏令时安排和 GMT 偏移量改变，那么此方法就返回历史上正确的偏移值。

参数：
date - 自 1970 年 1 月 1 日 00:00:00 GMT 以来以毫秒表示的日期
返回：
添加到 UTC 以获取本地时间的时间量（以毫秒为单位）。
从以下版本开始：
1.4
另请参见：
Calendar.ZONE_OFFSET, Calendar.DST_OFFSET

setRawOffset

public abstract void setRawOffset(int offsetMillis)
把基准时区偏移量设置到 GMT。这是添加到 UTC 以获取本地时间的偏移量。

如果底层 TimeZone 实现子类支持历史 GMT 偏移量更改，那么指定的 GMT 偏移量被设置为最后的 GMT 偏移量，并通过与已知的最近 GMT 偏移值的差别对所有历史 GMT 偏移值进行调整。

参数：
offsetMillis - GMT 的给定基准时区偏移量。

getRawOffset

public abstract int getRawOffset()
返回添加到 UTC 以获取此时区中的标准时间的时间量（以毫秒为单位）。因为此值不受夏令时的影响，所以它称为原始偏移量。

如果底层 TimeZone 实现子类支持历史 GMT 的偏移量变化，那么此方法返回当前日期的原始偏移量值。例如，在火奴鲁鲁（美国夏威夷州的首府和港市），它的原始偏移量在 1947 年从 GMT-10:30 改变到 GMT-10:00，并且此方法始终返回 -36000000 毫秒（即 -10 小时）。

返回：
添加到 UTC 的原始偏移时间量（以毫秒为单位）。
另请参见：
Calendar.ZONE_OFFSET

getID

public String getID()
获取此时区的 ID。

返回：
此时区的 ID。

setID

public void setID(String ID)
设置时区 ID。这不会改变时区对象中的任何其他数据。

参数：
ID - 新的时区 ID。

getDisplayName

public final String getDisplayName()
返回适合于展示给默认区域的用户的时区名称。此方法返回长名称，不包括夏令时。如果显示名称对于区域不可用，那么此方法以标准化自定义 ID 格式返回一个字符串。

返回：
默认区域中时区的可读名称。
从以下版本开始：
1.2

getDisplayName

public final String getDisplayName(Locale locale)
返回适合于展示给指定区域的用户的时区名称。此方法返回长名称，不包括夏令时。如果显示名称对于区域不可用，那么此方法以标准化自定义 ID 格式返回一个字符串。

参数：
locale - 要提供显示名称的区域。
返回：
给定区域中时区的可读名称。
从以下版本开始：
1.2

getDisplayName

public final String getDisplayName(boolean daylight,
                                   int style)
返回适合于展示给默认区域的用户的时区名称。如果显示名称对于区域不可用，那么此方法以标准化自定义 ID 格式返回一个字符串。

参数：
daylight - 如果为 true，则返回夏令时名称。
style - LONG 或 SHORT
返回：
默认区域中时区的可读名称。
从以下版本开始：
1.2

getDisplayName

public String getDisplayName(boolean daylight,
                             int style,
                             Locale locale)
返回适合于展示给指定区域的用户的时区名称。如果显示名称对于区域不可用，那么此方法以标准化自定义 ID 格式返回一个字符串。

参数：
daylight - 如果为 true，返回夏令时名称。
style - LONG 或 SHORT
locale - 要提供显示名称的区域。
返回：
给定区域中时区的可读名称。
抛出：
IllegalArgumentException - 风格是无效的。
从以下版本开始：
1.2

getDSTSavings

public int getDSTSavings()
返回要添加到本地标准时间以获取本地挂钟时间的时间量。

如果此时区遵守夏令时规则，则默认的实现始终返回 3600000 毫秒（即 1 小时）。否则，返回 0（零）。

如果底层 TimeZone 实现子类支持历史夏令时变化，则此方法返回已知的最新夏令时值。

返回：
节约的时间量（以毫秒为单位）
从以下版本开始：
1.4

useDaylightTime

public abstract boolean useDaylightTime()
查询此时区是否使用夏令时。

如果底层 TimeZone 实现子类支持历史夏令时安排变化，那么方法引用最新的夏令时安排信息。

返回：
如果此时区使用夏令时，则返回 true，否则返回 false。

inDaylightTime

public abstract boolean inDaylightTime(Date date)
查询给定的日期是否在此时区的夏令时中。

参数：
date - 给定的日期。
返回：
如果给定的日期在夏令时中，则返回 true，否则返回 false。

getTimeZone

public static TimeZone getTimeZone(String ID)
获取给定 ID 的 TimeZone。

参数：
ID - TimeZone 的 ID，要么是缩写（如 "PST" ），要么是全名（如 "America/Los_Angeles"），要么是自定义 ID（如 "GMT-8:00"）。注意，对缩写的支持只是出于 JDK 1.1.x 兼容性的考虑，因此应该使用全名。
返回：
指定的 TimeZone，如果给定的 ID 无法理解，则返回 GMT 区域。

getAvailableIDs

public static String[] getAvailableIDs(int rawOffset)
根据给定的时区偏移量（以毫秒为单位）获取可用的 ID。

参数：
rawOffset - 给定的时区 GMT 偏移量（以毫秒为单位）。
返回：
一组 ID，其中该 ID 时区具有指定的 GMT 偏移量。例如，"America/Phoenix" 和 "America/Denver" 都有 GMT-07:00，但其夏令时行为是不同的。

getAvailableIDs

public static String[] getAvailableIDs()
获取受支持的所有可用 ID。

返回：
一组 ID。

getDefault

public static TimeZone getDefault()
获取此主机的默认 TimeZone。默认 TimeZone 的来源可能随实现的变化而变化。

返回：
默认的 TimeZone。
另请参见：
setDefault(java.util.TimeZone)

setDefault

public static void setDefault(TimeZone zone)
设置由 getDefault 方法返回的 TimeZone。如果 zone 为 null，把默认值重设为第一次启动虚拟机时的最初值。

参数：
zone - 新的默认时区
另请参见：
getDefault()

hasSameRules

public boolean hasSameRules(TimeZone other)
如果此区域和另一个区域具有相同的规则和偏移量，也就是说，如果此区域只可能在 ID 上与另一个区域不同，则返回 true。如果其他区域为 null，则返回 false。

参数：
other - 要进行比较的 TimeZone 对象
返回：
如果其他区域不为 null，并且与此区域不同（可能只有 ID 不同），则返回 true
从以下版本开始：
1.2

clone

public Object clone()
创建此 TimeZone 的一个副本。

覆盖：
类 Object 中的 clone
返回：
此 TimeZone 的一个副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TooManyListenersException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 TooManyListenersException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.util.TooManyListenersException
所有已实现的接口：
Serializable
public class TooManyListenersException
extends Exception

TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。

通常在多播 "void addXyzEventListener" 事件侦听器注册模式的任何给定具体实现上都有 "throws TooManyListenersException" 子句，它在实现单播侦听器的特例时用于注释该接口，也就是说，有一个且只有一个侦听器可在特定的事件侦听器源上同时注册。

从以下版本开始：
JDK1.1
另请参见：
EventObject, EventListener, 序列化表格

构造方法摘要
TooManyListenersException()
构造不带详细消息的 TooManyListenersException。
TooManyListenersException(String s)
构造带指定详细消息的 TooManyListenersException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TooManyListenersException

public TooManyListenersException()
构造不带详细消息的 TooManyListenersException。详细消息是描述这个特定异常的字符串。

TooManyListenersException

public TooManyListenersException(String s)
构造带指定详细消息的 TooManyListenersException。详细消息是描述这个特定异常的字符串。

参数：
s - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 TreeMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.TreeMap<K,V>
类型参数：
K - 此映射维护的键的类型
V - 映射值的类型
所有已实现的接口：
Serializable, Cloneable, Map<K,V>, NavigableMap<K,V>, SortedMap<K,V>
public class TreeMap<K,V>
extends AbstractMap<K,V>
implements NavigableMap<K,V>, Cloneable, Serializable

基于红黑树（Red-Black tree）的 NavigableMap 实现。该映射根据其键的自然顺序进行排序，或者根据创建映射时提供的 Comparator 进行排序，具体取决于使用的构造方法。

此实现为 containsKey、get、put 和 remove 操作提供受保证的 log(n) 时间开销。这些算法是 Cormen、Leiserson 和 Rivest 的 Introduction to Algorithms 中的算法的改编。

注意，如果要正确实现 Map 接口，则有序映射所保持的顺序（无论是否明确提供了比较器）都必须与 equals 一致。（关于与 equals 一致 的精确定义，请参阅 Comparable 或 Comparator）。这是因为 Map 接口是按照 equals 操作定义的，但有序映射使用它的 compareTo（或 compare）方法对所有键进行比较，因此从有序映射的观点来看，此方法认为相等的两个键就是相等的。即使排序与 equals 不一致，有序映射的行为仍然是 定义良好的，只不过没有遵守 Map 接口的常规协定。

注意，此实现不是同步的。如果多个线程同时访问一个映射，并且其中至少一个线程从结构上修改了该映射，则其必须 外部同步。（结构上的修改是指添加或删除一个或多个映射关系的操作；仅改变与现有键关联的值不是结构上的修改。）这一般是通过对自然封装该映射的对象执行同步操作来完成的。如果不存在这样的对象，则应该使用 Collections.synchronizedSortedMap 方法来“包装”该映射。最好在创建时完成这一操作，以防止对映射进行意外的不同步访问，如下所示：

   SortedMap m = Collections.synchronizedSortedMap(new TreeMap(...));

collection（由此类所有的“collection 视图方法”返回）的 iterator 方法返回的迭代器都是快速失败 的：在迭代器创建之后，如果从结构上对映射进行修改，除非通过迭代器自身的 remove 方法，否则在其他任何时间以任何方式进行修改都将导致迭代器抛出 ConcurrentModificationException。因此，对于并发的修改，迭代器很快就完全失败，而不会冒着在将来不确定的时间发生不确定行为的风险。

注意，迭代器的快速失败行为无法得到保证，一般来说，当存在不同步的并发修改时，不可能作出任何肯定的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的做法是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测 bug。

此类及其视图中的方法返回的所有 Map.Entry 对都表示生成它们时的映射关系的快照。它们不 支持 Entry.setValue 方法。（不过要注意的是，使用 put 更改相关映射中的映射关系是有可能的。）

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Map, HashMap, Hashtable, Comparable, Comparator, Collection, 序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
构造方法摘要
TreeMap()
使用键的自然顺序构造一个新的、空的树映射。
TreeMap(Comparator<? super K> comparator)
构造一个新的、空的树映射，该映射根据给定比较器进行排序。
TreeMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新的树映射，该映射根据其键的自然顺序 进行排序。
TreeMap(SortedMap<K,? extends V> m)
构造一个与指定有序映射具有相同映射关系和相同排序顺序的新的树映射。
方法摘要
Map.Entry<K,V> | ceilingEntry(K key) 返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。
K | ceilingKey(K key) 返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。
void | clear() 从此映射中移除所有映射关系。
Object | clone() 返回此 TreeMap 实例的浅表副本。
Comparator<? super K> | comparator() 返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。
boolean | containsKey(Object key) 如果此映射包含指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射为指定值映射一个或多个键，则返回 true。
NavigableSet<K> | descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
NavigableMap<K,V> | descendingMap() 返回此映射中所包含映射关系的逆序视图。
Set<Map.Entry<K,V>> | entrySet() 返回此映射中包含的映射关系的 Set 视图。
Map.Entry<K,V> | firstEntry() 返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
K | firstKey() 返回此映射中当前第一个（最低）键。
Map.Entry<K,V> | floorEntry(K key) 返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。
K | floorKey(K key) 返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。
V | get(Object key) 返回指定键所映射的值，如果对于该键而言，此映射不包含任何映射关系，则返回 null。
SortedMap<K,V> | headMap(K toKey) 返回此映射的部分视图，其键值严格小于 toKey。
NavigableMap<K,V> | headMap(K toKey, boolean inclusive) 返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
Map.Entry<K,V> | higherEntry(K key) 返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。
K | higherKey(K key) 返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。
Set<K> | keySet() 返回此映射包含的键的 Set 视图。
Map.Entry<K,V> | lastEntry() 返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
K | lastKey() 返回映射中当前最后一个（最高）键。
Map.Entry<K,V> | lowerEntry(K key) 返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。
K | lowerKey(K key) 返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。
NavigableSet<K> | navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
Map.Entry<K,V> | pollFirstEntry() 移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | pollLastEntry() 移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
V | put(K key, V value) 将指定值与此映射中的指定键进行关联。
void | putAll(Map<? extends K,? extends V> map) 将指定映射中的所有映射关系复制到此映射中。
V | remove(Object key) 如果此 TreeMap 中存在该键的映射关系，则将其删除。
int | size() 返回此映射中的键-值映射关系数。
NavigableMap<K,V> | subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive) 返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
SortedMap<K,V> | subMap(K fromKey, K toKey) 返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
SortedMap<K,V> | tailMap(K fromKey) 返回此映射的部分视图，其键大于等于 fromKey。
NavigableMap<K,V> | tailMap(K fromKey, boolean inclusive) 返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。
Collection<V> | values() 返回此映射包含的值的 Collection 视图。
从类 java.util.AbstractMap 继承的方法
equals, hashCode, isEmpty, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Map 继承的方法
equals, hashCode, isEmpty

构造方法详细信息

TreeMap

public TreeMap()
使用键的自然顺序构造一个新的、空的树映射。插入该映射的所有键都必须实现 Comparable 接口。另外，所有这些键都必须是可互相比较的：对于映射中的任意两个键 k1 和 k2，执行 k1.compareTo(k2) 都不得抛出 ClassCastException。如果用户试图将违反此约束的键添加到映射中（例如，用户试图将字符串键添加到键为整数的映射中），则 put(Object key, Object value) 调用将抛出 ClassCastException。

TreeMap

public TreeMap(Comparator<? super K> comparator)
构造一个新的、空的树映射，该映射根据给定比较器进行排序。插入该映射的所有键都必须由给定比较器进行相互比较：对于映射中的任意两个键 k1 和 k2，执行 comparator.compare(k1, k2) 都不得抛出 ClassCastException。如果用户试图将违反此约束的键放入映射中，则 put(Object key, Object value) 调用将抛出 ClassCastException。

参数：
comparator - 将用来对此映射进行排序的比较器。如果该参数为 null，则将使用键的自然顺序。

TreeMap

public TreeMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新的树映射，该映射根据其键的自然顺序 进行排序。插入此新映射的所有键都必须实现 Comparable 接口。另外，所有这些键都必须是可互相比较的：对于映射中的任意两个键 k1 和 k2，执行 k1.compareTo(k2) 都不得抛出 ClassCastException。此方法的运行时间为 n*log(n)。

参数：
m - 其映射关系将存放在此映射中的映射
抛出：
ClassCastException - 如果 m 中的键不是 Comparable，或者是不可相互比较的
NullPointerException - 如果指定映射为 null

TreeMap

public TreeMap(SortedMap<K,? extends V> m)
构造一个与指定有序映射具有相同映射关系和相同排序顺序的新的树映射。此方法是以线性时间运行的。

参数：
m - 有序映射，其映射关系将存放在此映射中，并且其比较器将用来对此映射进行排序
抛出：
NullPointerException - 如果指定映射为 null
方法详细信息

size

public int size()
返回此映射中的键-值映射关系数。

指定者：
接口 Map<K,V> 中的 size
覆盖：
类 AbstractMap<K,V> 中的 size
返回：
此映射中的键-值映射关系数

containsKey

public boolean containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 containsKey
覆盖：
类 AbstractMap<K,V> 中的 containsKey
参数：
key - 测试是否存在于此映射中的键
返回：
如果此映射包含指定键的映射关系，则返回 true
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射使用自然顺序，或者其比较器不允许使用 null 键

containsValue

public boolean containsValue(Object value)
如果此映射为指定值映射一个或多个键，则返回 true。更确切地讲，当且仅当此映射包含至少一个到值 v 的映射关系，并且该值满足 (value==null ? v==null :value.equals(v)) 时，返回 true。对于大部分实现而言，此操作需要的时间可能与映射的大小呈线性关系。

指定者：
接口 Map<K,V> 中的 containsValue
覆盖：
类 AbstractMap<K,V> 中的 containsValue
参数：
value - 将测试其是否存在于此映射中的值
返回：
如果存在到 value 的映射关系，则返回 true；否则返回 false
从以下版本开始：
1.2

get

public V get(Object key)
返回指定键所映射的值，如果对于该键而言，此映射不包含任何映射关系，则返回 null。

更确切地讲，如果此映射包含从键 k 到值 v 的映射关系，根据该映射的排序 key 比较起来等于 k，那么此方法将返回 v；否则返回 null。（最多只能有一个这样的映射关系。）

返回 null 值并不一定 表明映射不包含该键的映射关系；也可能此映射将该键显式地映射为 null。可以使用 containsKey 操作来区分这两种情况。

指定者：
接口 Map<K,V> 中的 get
覆盖：
类 AbstractMap<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
抛出：
ClassCastException - 如果指定键不能与在映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射使用自然顺序，或者其比较器不允许使用 null 键

comparator

public Comparator<? super K> comparator()
从接口 SortedMap 复制的描述
返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。

指定者：
接口 SortedMap<K,V> 中的 comparator
返回：
用来对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null

firstKey

public K firstKey()
从接口 SortedMap 复制的描述
返回此映射中当前第一个（最低）键。

指定者：
接口 SortedMap<K,V> 中的 firstKey
返回：
此映射中当前第一个（最低）键
抛出：
NoSuchElementException - 如果此映射为空

lastKey

public K lastKey()
从接口 SortedMap 复制的描述
返回映射中当前最后一个（最高）键。

指定者：
接口 SortedMap<K,V> 中的 lastKey
返回：
此映射中当前最后一个（最高）键
抛出：
NoSuchElementException - 如果此映射为空

putAll

public void putAll(Map<? extends K,? extends V> map)
将指定映射中的所有映射关系复制到此映射中。这些映射关系将替换此映射所有当前为指定映射的所有键所包含的映射关系。

指定者：
接口 Map<K,V> 中的 putAll
覆盖：
类 AbstractMap<K,V> 中的 putAll
参数：
map - 将存储在此映射中的映射关系
抛出：
ClassCastException - 如果指定映射中的键或值的类不允许将键或值存储在此映射中
NullPointerException - 如果指定映射为 null，或者指定映射包含 null 键，但此映射不允许使用 null 键

put

public V put(K key,
             V value)
将指定值与此映射中的指定键进行关联。如果该映射以前包含此键的映射关系，那么将替换旧值。

指定者：
接口 Map<K,V> 中的 put
覆盖：
类 AbstractMap<K,V> 中的 put
参数：
key - 要与指定值关联的键
value - 要与指定键关联的值
返回：
与 key 关联的先前值；如果没有针对 key 的映射关系，则返回 null。（返回 null 还可能表示该映射以前将 null 与 key 关联。）
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射使用自然顺序，或者其比较器不允许使用 null 键

remove

public V remove(Object key)
如果此 TreeMap 中存在该键的映射关系，则将其删除。

指定者：
接口 Map<K,V> 中的 remove
覆盖：
类 AbstractMap<K,V> 中的 remove
参数：
key - 将为其移除映射关系的键
返回：
返回与 key 关联的先前值，如果没有针对 key 的映射关系，则返回 null。（返回 null 还可能表示该映射以前将 null 与 key 关联。）
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null 并且此映射使用自然顺序，或者其比较器不允许使用 null 键

clear

public void clear()
从此映射中移除所有映射关系。在此调用返回之后，映射将为空。

指定者：
接口 Map<K,V> 中的 clear
覆盖：
类 AbstractMap<K,V> 中的 clear

clone

public Object clone()
返回此 TreeMap 实例的浅表副本。（键和值本身不被复制。）

覆盖：
类 AbstractMap<K,V> 中的 clone
返回：
此映射的浅表副本
另请参见：
Cloneable

firstEntry

public Map.Entry<K,V> firstEntry()
从接口 NavigableMap 复制的描述
返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 firstEntry
返回：
带有最小键的条目；如果此映射为空，则返回 null
从以下版本开始：
1.6

lastEntry

public Map.Entry<K,V> lastEntry()
从接口 NavigableMap 复制的描述
返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 lastEntry
返回：
带有最大键的条目；如果此映射为空，则返回 null
从以下版本开始：
1.6

pollFirstEntry

public Map.Entry<K,V> pollFirstEntry()
从接口 NavigableMap 复制的描述
移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 pollFirstEntry
返回：
此映射中被移除的第一个条目；如果此映射为空，则返回 null
从以下版本开始：
1.6

pollLastEntry

public Map.Entry<K,V> pollLastEntry()
从接口 NavigableMap 复制的描述
移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 pollLastEntry
返回：
此映射中被移除的最后一个条目；如果此映射为空，则返回 null
从以下版本开始：
1.6

lowerEntry

public Map.Entry<K,V> lowerEntry(K key)
从接口 NavigableMap 复制的描述
返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 lowerEntry
参数：
key - 键
返回：
最大键小于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

lowerKey

public K lowerKey(K key)
从接口 NavigableMap 复制的描述
返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 lowerKey
参数：
key - 键
返回：
小于 key 的最大键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

floorEntry

public Map.Entry<K,V> floorEntry(K key)
从接口 NavigableMap 复制的描述
返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 floorEntry
参数：
key - 键
返回：
最大键小于等于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

floorKey

public K floorKey(K key)
从接口 NavigableMap 复制的描述
返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 floorKey
参数：
key - 键
返回：
小于等于 key 的最大键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

ceilingEntry

public Map.Entry<K,V> ceilingEntry(K key)
从接口 NavigableMap 复制的描述
返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 ceilingEntry
参数：
key - 键
返回：
最小键大于等于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

ceilingKey

public K ceilingKey(K key)
从接口 NavigableMap 复制的描述
返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 ceilingKey
参数：
key - 键
返回：
大于等于 key 的最小键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

higherEntry

public Map.Entry<K,V> higherEntry(K key)
从接口 NavigableMap 复制的描述
返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 higherEntry
参数：
key - 键
返回：
最小键大于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

higherKey

public K higherKey(K key)
从接口 NavigableMap 复制的描述
返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 higherKey
参数：
key - 键
返回：
大于 key 的最小键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
从以下版本开始：
1.6

keySet

public Set<K> keySet()
返回此映射包含的键的 Set 视图。set 的迭代器将按升序返回这些键。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。此 set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 keySet
指定者：
接口 SortedMap<K,V> 中的 keySet
覆盖：
类 AbstractMap<K,V> 中的 keySet
返回：
此映射中包含的键的 set 视图

navigableKeySet

public NavigableSet<K> navigableKeySet()
从接口 NavigableMap 复制的描述
返回此映射中所包含键的 NavigableSet 视图。set 的迭代器按升序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。如果正在对 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 NavigableMap<K,V> 中的 navigableKeySet
返回：
此映射中键的可导航 set 视图
从以下版本开始：
1.6

descendingKeySet

public NavigableSet<K> descendingKeySet()
从接口 NavigableMap 复制的描述
返回此映射中所包含键的逆序 NavigableSet 视图。set 的迭代器按降序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。如果正在对 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 NavigableMap<K,V> 中的 descendingKeySet
返回：
此映射中键的逆序可导航 set 视图
从以下版本开始：
1.6

values

public Collection<V> values()
返回此映射包含的值的 Collection 视图。该 collection 的迭代器将按相关键的升序返回这些值。该 collection 受映射支持，所以对映射的更改可在此 collection 中反映出来，反之亦然。如果对该 collection 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。该 collection 支持元素的移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 values
指定者：
接口 SortedMap<K,V> 中的 values
覆盖：
类 AbstractMap<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射中包含的映射关系的 Set 视图。该 set 的迭代器将按升序返回这些条目。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作，或者通过在迭代器返回的映射条目上执行 setValue 操作除外），则迭代结果是不确定的。此 set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 entrySet
指定者：
接口 SortedMap<K,V> 中的 entrySet
指定者：
类 AbstractMap<K,V> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图

descendingMap

public NavigableMap<K,V> descendingMap()
从接口 NavigableMap 复制的描述
返回此映射中所包含映射关系的逆序视图。降序映射受此映射的支持，因此对映射的更改将反映在降序映射中，反之亦然。如果在对任一映射的 collection 视图进行迭代的同时修改了任一映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。

返回映射的顺序等于 Collections.reverseOrder(comparator())。表达式 m.descendingMap().descendingMap() 返回的 m 视图基本等于 m。

指定者：
接口 NavigableMap<K,V> 中的 descendingMap
返回：
此映射的逆序视图
从以下版本开始：
1.6

subMap

public NavigableMap<K,V> subMap(K fromKey,
                                boolean fromInclusive,
                                K toKey,
                                boolean toInclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键的范围从 fromKey 到 toKey。如果 fromKey 和 toKey 相等，则返回的映射为空，除非 fromExclusive 和 toExclusive 都为 true。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，或者构造一个任一端点位于其范围之外的子映射，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 NavigableMap<K,V> 中的 subMap
参数：
fromKey - 返回映射中键的低端点
fromInclusive - 如果低端点要包含在返回的视图中，则为 true
toKey - 返回映射中键的高端点
toInclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键范围从 fromKey 到 toKey
抛出：
ClassCastException - 如果不能使用此映射的比较器（如果映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外
从以下版本开始：
1.6

headMap

public NavigableMap<K,V> headMap(K toKey,
                                 boolean inclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 NavigableMap<K,V> 中的 headMap
参数：
toKey - 返回映射中键的高端点
inclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外
从以下版本开始：
1.6

tailMap

public NavigableMap<K,V> tailMap(K fromKey,
                                 boolean inclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 NavigableMap<K,V> 中的 tailMap
参数：
fromKey - 返回映射中键的低端点
inclusive - 如果低端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外
从以下版本开始：
1.6

subMap

public SortedMap<K,V> subMap(K fromKey,
                             K toKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。（如果 fromKey 和 toKey 相等，则返回映射为空。）返回的映射受此映射支持，所以在返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 subMap(fromKey, true, toKey, false)。

指定者：
接口 NavigableMap<K,V> 中的 subMap
指定者：
接口 SortedMap<K,V> 中的 subMap
参数：
fromKey - 返回映射中键的低端点（包括）
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）
抛出：
ClassCastException - 如果无法使用此映射的比较器（如果此映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

public SortedMap<K,V> headMap(K toKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键值严格小于 toKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 headMap(toKey, false)。

指定者：
接口 NavigableMap<K,V> 中的 headMap
指定者：
接口 SortedMap<K,V> 中的 headMap
参数：
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，该映射的键严格小于 toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

public SortedMap<K,V> tailMap(K fromKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键大于等于 fromKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 tailMap(fromKey, true)。

指定者：
接口 NavigableMap<K,V> 中的 tailMap
指定者：
接口 SortedMap<K,V> 中的 tailMap
参数：
fromKey - 返回映射中键的低端点（包括）
返回：
此映射的部分视图，其键大于等于 fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null，并且此映射使用自然顺序，或者其比较器不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 TreeSet<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
            继承者  java.util.TreeSet<E>
类型参数：
E - 此 set 维护的元素的类型
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, NavigableSet<E>, Set<E>, SortedSet<E>
public class TreeSet<E>
extends AbstractSet<E>
implements NavigableSet<E>, Cloneable, Serializable

基于 TreeMap 的 NavigableSet 实现。使用元素的自然顺序对元素进行排序，或者根据创建 set 时提供的 Comparator 进行排序，具体取决于使用的构造方法。

此实现为基本操作（add、remove 和 contains）提供受保证的 log(n) 时间开销。

注意，如果要正确实现 Set 接口，则 set 维护的顺序（无论是否提供了显式比较器）必须与 equals 一致。（关于与 equals 一致 的精确定义，请参阅 Comparable 或 Comparator。）这是因为 Set 接口是按照 equals 操作定义的，但 TreeSet 实例使用它的 compareTo（或 compare）方法对所有元素进行比较，因此从 set 的观点来看，此方法认为相等的两个元素就是相等的。即使 set 的顺序与 equals 不一致，其行为也是 定义良好的；它只是违背了 Set 接口的常规协定。

注意，此实现不是同步的。如果多个线程同时访问一个 TreeSet，而其中至少一个线程修改了该 set，那么它必须 外部同步。这一般是通过对自然封装该 set 的对象执行同步操作来完成的。如果不存在这样的对象，则应该使用 Collections.synchronizedSortedSet 方法来“包装”该 set。此操作最好在创建时进行，以防止对 set 的意外非同步访问：

   SortedSet s = Collections.synchronizedSortedSet(new TreeSet(...));

此类的 iterator 方法返回的迭代器是快速失败 的：在创建迭代器之后，如果从结构上对 set 进行修改，除非通过迭代器自身的 remove 方法，否则在其他任何时间以任何方式进行修改都将导致迭代器抛出 ConcurrentModificationException。因此，对于并发的修改，迭代器很快就完全失败，而不会冒着在将来不确定的时间发生不确定行为的风险。

注意，迭代器的快速失败行为无法得到保证，一般来说，存在不同步的并发修改时，不可能作出任何肯定的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的做法是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测 bug。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
Collection, Set, HashSet, Comparable, Comparator, TreeMap, 序列化表格

构造方法摘要
TreeSet()
构造一个新的空 set，该 set 根据其元素的自然顺序进行排序。
TreeSet(Collection<? extends E> c)
构造一个包含指定 collection 元素的新 TreeSet，它按照其元素的自然顺序进行排序。
TreeSet(Comparator<? super E> comparator)
构造一个新的空 TreeSet，它根据指定比较器进行排序。
TreeSet(SortedSet<E> s)
构造一个与指定有序 set 具有相同映射关系和相同排序的新 TreeSet。
方法摘要
boolean | add(E e) 将指定的元素添加到此 set（如果该元素尚未存在于 set 中）。
boolean | addAll(Collection<? extends E> c) 将指定 collection 中的所有元素添加到此 set 中。
E | ceiling(E e) 返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。
void | clear() 移除此 set 中的所有元素。
Object | clone() 返回 TreeSet 实例的浅表副本。
Comparator<? super E> | comparator() 返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。
boolean | contains(Object o) 如果此 set 包含指定的元素，则返回 true。
Iterator<E> | descendingIterator() 返回在此 set 元素上按降序进行迭代的迭代器。
NavigableSet<E> | descendingSet() 返回此 set 中所包含元素的逆序视图。
E | first() 返回此 set 中当前第一个（最低）元素。
E | floor(E e) 返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。
SortedSet<E> | headSet(E toElement) 返回此 set 的部分视图，其元素严格小于 toElement。
NavigableSet<E> | headSet(E toElement, boolean inclusive) 返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。
E | higher(E e) 返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。
boolean | isEmpty() 如果此 set 不包含任何元素，则返回 true。
Iterator<E> | iterator() 返回在此 set 中的元素上按升序进行迭代的迭代器。
E | last() 返回此 set 中当前最后一个（最高）元素。
E | lower(E e) 返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。
E | pollFirst() 获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。
E | pollLast() 获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。
boolean | remove(Object o) 将指定的元素从 set 中移除（如果该元素存在于此 set 中）。
int | size() 返回 set 中的元素数（set 的容量）。
NavigableSet<E> | subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive) 返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。
SortedSet<E> | subSet(E fromElement, E toElement) 返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
SortedSet<E> | tailSet(E fromElement) 返回此 set 的部分视图，其元素大于等于 fromElement。
NavigableSet<E> | tailSet(E fromElement, boolean inclusive) 返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。
从类 java.util.AbstractSet 继承的方法
equals, hashCode, removeAll
从类 java.util.AbstractCollection 继承的方法
containsAll, retainAll, toArray, toArray, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Set 继承的方法
containsAll, equals, hashCode, removeAll, retainAll, toArray, toArray

构造方法详细信息

TreeSet

public TreeSet()
构造一个新的空 set，该 set 根据其元素的自然顺序进行排序。插入该 set 的所有元素都必须实现 Comparable 接口。另外，所有这些元素都必须是可互相比较的：对于 set 中的任意两个元素 e1 和 e2，执行 e1.compareTo(e2) 都不得抛出 ClassCastException。如果用户试图将违反此约束的元素添加到 set（例如，用户试图将字符串元素添加到其元素为整数的 set 中），则 add 调用将抛出 ClassCastException。

TreeSet

public TreeSet(Comparator<? super E> comparator)
构造一个新的空 TreeSet，它根据指定比较器进行排序。插入到该 set 的所有元素都必须能够由指定比较器进行相互比较：对于 set 中的任意两个元素 e1 和 e2，执行 comparator.compare(e1, e2) 都不得抛出 ClassCastException。如果用户试图将违反此约束的元素添加到 set 中，则 add 调用将抛出 ClassCastException。

参数：
comparator - 将用来对此 set 进行排序的比较器。如果该参数为 null，则使用元素的自然顺序。

TreeSet

public TreeSet(Collection<? extends E> c)
构造一个包含指定 collection 元素的新 TreeSet，它按照其元素的自然顺序进行排序。插入该 set 的所有元素都必须实现 Comparable 接口。另外，所有这些元素都必须是可互相比较的：对于 set 中的任意两个元素 e1 和 e2，执行 e1.compareTo(e2) 都不得抛出 ClassCastException。

参数：
c - 一个 collection，其元素将组成新的 set
抛出：
ClassCastException - 如果 c 中的元素不是 Comparable，或者是不可相互比较的
NullPointerException - 如果指定 collection 为 null

TreeSet

public TreeSet(SortedSet<E> s)
构造一个与指定有序 set 具有相同映射关系和相同排序的新 TreeSet。

参数：
s - 一个有序 set，其元素将组成新 set
抛出：
NullPointerException - 如果指定有序 set 为 null
方法详细信息

iterator

public Iterator<E> iterator()
返回在此 set 中的元素上按升序进行迭代的迭代器。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 NavigableSet<E> 中的 iterator
指定者：
接口 Set<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此 set 中的元素上按升序进行迭代的迭代器

descendingIterator

public Iterator<E> descendingIterator()
返回在此 set 元素上按降序进行迭代的迭代器。

指定者：
接口 NavigableSet<E> 中的 descendingIterator
返回：
在此 set 元素上按降序进行迭代的迭代器
从以下版本开始：
1.6

descendingSet

public NavigableSet<E> descendingSet()
从接口 NavigableSet 复制的描述
返回此 set 中所包含元素的逆序视图。降序 set 受此 set 的支持，因此对此 set 的更改将反映在降序 set 中，反之亦然。如果在对任一 set 进行迭代的同时修改了任一 set（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。

返回 set 的顺序等于 Collections.reverseOrder(comparator())。表达式 s.descendingSet().descendingSet() 返回的 s 视图基本等于 s。

指定者：
接口 NavigableSet<E> 中的 descendingSet
返回：
此 set 的逆序视图
从以下版本开始：
1.6

size

public int size()
返回 set 中的元素数（set 的容量）。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 Set<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此 set 中的元素数（set 的容量）

isEmpty

public boolean isEmpty()
如果此 set 不包含任何元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
指定者：
接口 Set<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
如果此 set 不包含任何元素，则返回 true

contains

public boolean contains(Object o)
如果此 set 包含指定的元素，则返回 true。更确切地讲，当且仅当此 set 包含满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 Set<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 将检查是否包含在此 set 中的对象
返回：
如果此 set 包含指定元素，则返回 true
抛出：
ClassCastException - 如果指定对象无法与该 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素

add

public boolean add(E e)
将指定的元素添加到此 set（如果该元素尚未存在于 set 中）。更确切地讲，如果该 set 不包含满足 (e==null ? e2==null : e.equals(e2)) 的元素 e2，则将指定元素 e 添加到此 set 中。如果此 set 已经包含这样的元素，则该调用不改变此 set 并返回 false。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Set<E> 中的 add
覆盖：
类 AbstractCollection<E> 中的 add
参数：
e - 要添加到此 set 的对象
返回：
如果此 set 尚未包含指定元素，则返回 true
抛出：
ClassCastException - 如果指定对象无法与此 set 的当前元素进行比较
NullPointerException - 如果指定元素为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素

remove

public boolean remove(Object o)
将指定的元素从 set 中移除（如果该元素存在于此 set 中）。更确切地讲，如果 set 中包含满足 (o==null ? e==null : o.equals(e)) 的元素 e，则移除一个这样的元素。如果此 set 包含这样的元素（或者此 set 由于调用而发生更改），则返回 true。（一旦调用返回，则此 set 不再包含这样的元素。）

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 Set<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 将从此 set 中移除的对象（如果存在）
返回：
如果此 set 包含指定元素，则返回 true
抛出：
ClassCastException - 如果指定对象无法与该 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素

clear

public void clear()
移除此 set 中的所有元素。在此调用返回之后，set 将为空。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 Set<E> 中的 clear
覆盖：
类 AbstractCollection<E> 中的 clear

addAll

public boolean addAll(Collection<? extends E> c)
将指定 collection 中的所有元素添加到此 set 中。

指定者：
接口 Collection<E> 中的 addAll
指定者：
接口 Set<E> 中的 addAll
覆盖：
类 AbstractCollection<E> 中的 addAll
参数：
c - 包含要添加到此 set 的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果提供的元素无法与 set 中的当前元素进行比较
NullPointerException - 如果指定 collection 为 null，或者任何元素为 null 并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
另请参见：
AbstractCollection.add(Object)

subSet

public NavigableSet<E> subSet(E fromElement,
                              boolean fromInclusive,
                              E toElement,
                              boolean toInclusive)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。如果 fromElement 和 toElement 相等，则返回的 set 为空，除非 fromExclusive 和 toExclusive 都为 true。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

指定者：
接口 NavigableSet<E> 中的 subSet
参数：
fromElement - 返回 set 的低端点
fromInclusive - 如果低端点要包含在返回的视图中，则为 true
toElement - 返回 set 的高端点
toInclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素范围从 fromElement（包括）到 toElement（不包括）
抛出：
ClassCastException - 如果不能使用此 set 的比较器或者使用自然顺序（如果 set 没有比较器）比较 fromElement 和 toElement。如果 fromElement 或 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 或 toElement 为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
IllegalArgumentException - 如果 fromElement 大于 toElement；如果此 set 本身有范围限制，并且 fromElement 或 toElement 位于范围的边界之外。
从以下版本开始：
1.6

headSet

public NavigableSet<E> headSet(E toElement,
                               boolean inclusive)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

指定者：
接口 NavigableSet<E> 中的 headSet
参数：
toElement - 返回 set 的高端点
inclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement
抛出：
ClassCastException - 如果 toElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 toElement 没有实现 Comparable）。如果 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toElement 为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 toElement 位于范围的边界之外
从以下版本开始：
1.6

tailSet

public NavigableSet<E> tailSet(E fromElement,
                               boolean inclusive)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

指定者：
接口 NavigableSet<E> 中的 tailSet
参数：
fromElement - 返回 set 的低端点
inclusive - 如果低端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素大于等于 fromElement
抛出：
ClassCastException - 如果 fromElement 与此 set 的比较器不兼容（如果 set 没有任何比较器；如果 fromElement 没有实现 Comparable）。如果 fromElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 fromElement 位于范围的边界之外
从以下版本开始：
1.6

subSet

public SortedSet<E> subSet(E fromElement,
                           E toElement)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。（如果 fromElement 和 toElement 相等，则返回空的 set）。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 subSet(fromElement, true, toElement, false)。

指定者：
接口 NavigableSet<E> 中的 subSet
指定者：
接口 SortedSet<E> 中的 subSet
参数：
fromElement - 返回 set 的低端点（包括）
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素的范围从 fromElement（包括）到 toElement（不包括）
抛出：
ClassCastException - 如果无法使用此 set 的比较器（如果 set 没有比较器，则使用自然顺序）比较 fromElement 和 toElement。如果 fromElement 或 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 或 toElement 为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
IllegalArgumentException - 如果 fromElement 大于 toElement；如果此 set 本身有范围限制，并且 fromElement 或 toElement 位于范围的边界之外

headSet

public SortedSet<E> headSet(E toElement)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素严格小于 toElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 headSet(toElement, false)。

指定者：
接口 NavigableSet<E> 中的 headSet
指定者：
接口 SortedSet<E> 中的 headSet
参数：
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素严格小于 toElement
抛出：
ClassCastException - 如果 toElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 toElement 没有实现 Comparable）。如果 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toElement 为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 toElement 位于范围的边界之外

tailSet

public SortedSet<E> tailSet(E fromElement)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素大于等于 fromElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 tailSet(fromElement, true)。

指定者：
接口 NavigableSet<E> 中的 tailSet
指定者：
接口 SortedSet<E> 中的 tailSet
参数：
fromElement - 返回 set 的低端点（包括）
返回：
此 set 的部分视图，其元素大于等于 fromElement
抛出：
ClassCastException - 如果 fromElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 fromElement 没有实现 Comparable）。如果 fromElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
IllegalArgumentException - 如果此 set 本身有范围限制，并且 fromElement 位于范围的边界之外

comparator

public Comparator<? super E> comparator()
从接口 SortedSet 复制的描述
返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。

指定者：
接口 SortedSet<E> 中的 comparator
返回：
用来对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null

first

public E first()
从接口 SortedSet 复制的描述
返回此 set 中当前第一个（最低）元素。

指定者：
接口 SortedSet<E> 中的 first
返回：
此 set 中当前第一个（最低）元素
抛出：
NoSuchElementException - 如果此 set 为空

last

public E last()
从接口 SortedSet 复制的描述
返回此 set 中当前最后一个（最高）元素。

指定者：
接口 SortedSet<E> 中的 last
返回：
此 set 中当前最后一个（最高）元素
抛出：
NoSuchElementException - 如果此 set 为空

lower

public E lower(E e)
从接口 NavigableSet 复制的描述
返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 lower
参数：
e - 要匹配的值
返回：
小于 e 的最大元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
从以下版本开始：
1.6

floor

public E floor(E e)
从接口 NavigableSet 复制的描述
返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 floor
参数：
e - 要匹配的值
返回：
小于等于 e 的最大元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
从以下版本开始：
1.6

ceiling

public E ceiling(E e)
从接口 NavigableSet 复制的描述
返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 ceiling
参数：
e - 要匹配的值
返回：
大于等于 e 的最小元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
从以下版本开始：
1.6

higher

public E higher(E e)
从接口 NavigableSet 复制的描述
返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 higher
参数：
e - 要匹配的值
返回：
大于 e 的最小元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定元素为 null，并且此 set 使用自然顺序，或者其比较器不允许使用 null 元素
从以下版本开始：
1.6

pollFirst

public E pollFirst()
从接口 NavigableSet 复制的描述
获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。

指定者：
接口 NavigableSet<E> 中的 pollFirst
返回：
第一个元素；如果此 set 为空，则返回 null
从以下版本开始：
1.6

pollLast

public E pollLast()
从接口 NavigableSet 复制的描述
获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。

指定者：
接口 NavigableSet<E> 中的 pollLast
返回：
最后一个元素；如果此 set 为空，则返回 null
从以下版本开始：
1.6

clone

public Object clone()
返回 TreeSet 实例的浅表副本。（这些元素本身不被复制。）

覆盖：
类 Object 中的 clone
返回：
此 set 的浅表副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownFormatConversionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 UnknownFormatConversionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.UnknownFormatConversionException
所有已实现的接口：
Serializable
public class UnknownFormatConversionException
extends IllegalFormatException

给定未知的转换时所抛出的未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
UnknownFormatConversionException(String s)
使用未知的转换构造此类的实例。
方法摘要
String | getConversion() 返回未知的转换。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownFormatConversionException

public UnknownFormatConversionException(String s)
使用未知的转换构造此类的实例。

参数：
s - 未知的转换。
方法详细信息

getConversion

public String getConversion()
返回未知的转换。

返回：
未知的转换。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownFormatFlagsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 UnknownFormatFlagsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.IllegalFormatException
                        继承者  java.util.UnknownFormatFlagsException
所有已实现的接口：
Serializable
public class UnknownFormatFlagsException
extends IllegalFormatException

给定未知标志时所抛出的未经检查的异常。

除非另行指定，否则将 null 参数传递给此类中的任何方法或构造方法都会抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
UnknownFormatFlagsException(String f)
使用指定的标志构造此类的实例。
方法摘要
String | getFlags() 返回包含未知标志的标志集。
String | getMessage() 返回此 throwable 的详细消息字符串。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownFormatFlagsException

public UnknownFormatFlagsException(String f)
使用指定的标志构造此类的实例。

参数：
f - 格式标志集，其中包含一个未知标志。
方法详细信息

getFlags

public String getFlags()
返回包含未知标志的标志集。

返回：
标志。

getMessage

public String getMessage()
从类 Throwable 复制的描述
返回此 throwable 的详细消息字符串。

覆盖：
类 Throwable 中的 getMessage
返回：
此 Throwable 实例（可以为 null）的详细消息字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UUID (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 UUID

java.lang.Object
    继承者  java.util.UUID
所有已实现的接口：
Serializable, Comparable<UUID>
public final class UUID
extends Object
implements Serializable, Comparable<UUID>

表示通用唯一标识符 (UUID) 的类。 UUID 表示一个 128 位的值。

这些通用标识符具有不同的变体。此类的方法用于操作 Leach-Salz 变体，不过构造方法允许创建任何 UUID 变体（将在下面进行描述）。

变体 2 (Leach-Salz) UUID 的布局如下： long 型数据的最高有效位由以下无符号字段组成：

 0xFFFFFFFF00000000 time_low
 0x00000000FFFF0000 time_mid
 0x000000000000F000 version
 0x0000000000000FFF time_hi
long 型数据的最低有效位由以下无符号字段组成：
 0xC000000000000000 variant
 0x3FFF000000000000 clock_seq
 0x0000FFFFFFFFFFFF node

variant 字段包含一个表示 UUID 布局的值。以上描述的位布局仅在 UUID 的 variant 值为 2（表示 Leach-Salz 变体）时才有效。

version 字段保存描述此 UUID 类型的值。有 4 种不同的基本 UUID 类型：基于时间的 UUID、DCE 安全 UUID、基于名称的 UUID 和随机生成的 UUID。 这些类型的 version 值分别为 1、2、3 和 4。

有关用于创建 UUID 的算法的更多信息，请参阅 RFC 4122: 通用唯一标识符 (Universally Unique Identifier) (UUID) URN Namespace, section 4.2 "；创建基于时间的 UUID" 的算法。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
UUID(long mostSigBits, long leastSigBits)
使用指定的数据构造新的 UUID。
方法摘要
int | clockSequence() 与此 UUID 相关联的时钟序列值。
int | compareTo(UUID val) 将此 UUID 与指定的 UUID 比较。
boolean | equals(Object obj) 将此对象与指定对象比较。
static UUID | fromString(String name) 根据 toString() 方法中描述的字符串标准表示形式创建 UUID。
long | getLeastSignificantBits() 返回此 UUID 的 128 位值中的最低有效 64 位。
long | getMostSignificantBits() 返回此 UUID 的 128 位值中的最高有效 64 位。
int | hashCode() 返回此 UUID 的哈希码。
static UUID | nameUUIDFromBytes(byte[] name) 根据指定的字节数组获取类型 3（基于名称的）UUID 的静态工厂。
long | node() 与此 UUID 相关的节点值。
static UUID | randomUUID() 获取类型 4（伪随机生成的）UUID 的静态工厂。
long | timestamp() 与此 UUID 相关联的时间戳值。
String | toString() 返回表示此 UUID 的 String 对象。
int | variant() 与此 UUID 相关联的变体号。
int | version() 与此 UUID 相关联的版本号。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

UUID

public UUID(long mostSigBits,
            long leastSigBits)
使用指定的数据构造新的 UUID。mostSigBits 用于 UUID 的最高有效 64 位，而 leastSigBits 将成为 UUID 的最低有效 64 位。

参数：
mostSigBits -
leastSigBits -
方法详细信息

randomUUID

public static UUID randomUUID()
获取类型 4（伪随机生成的）UUID 的静态工厂。 使用加密的强伪随机数生成器生成该 UUID。

返回：
随机生成的 UUID。

nameUUIDFromBytes

public static UUID nameUUIDFromBytes(byte[] name)
根据指定的字节数组获取类型 3（基于名称的）UUID 的静态工厂。

参数：
name - 用于构造 UUID 的字节数组。
返回：
根据指定数组生成的 UUID。

fromString

public static UUID fromString(String name)
根据 toString() 方法中描述的字符串标准表示形式创建 UUID。

参数：
name - 指定 UUID 的字符串。
返回：
具有指定值的 UUID。
抛出：
IllegalArgumentException - 如果 name 与 toString() 中描述的字符串表示形式不符。

getLeastSignificantBits

public long getLeastSignificantBits()
返回此 UUID 的 128 位值中的最低有效 64 位。

返回：
此 UUID 的 128 位值中的最低有效 64 位。

getMostSignificantBits

public long getMostSignificantBits()
返回此 UUID 的 128 位值中的最高有效 64 位。

返回：
此 UUID 的 128 位值中最高有效 64 位。

version

public int version()
与此 UUID 相关联的版本号。版本号描述此 UUID 是如何生成的。 版本号具有以下含意：

  • 1 基于时间的 UUID
  • 2 DCE 安全 UUID
  • 3 基于名称的 UUID
  • 4 随机生成的 UUID

返回：
此 UUID 的版本号。

variant

public int variant()
与此 UUID 相关联的变体号。变体号描述 UUID 的布局。 变体号具有以下含意：

  • 0 为 NCS 向后兼容保留
  • 2 Leach-Salz 变体（由此类使用）
  • 6 保留，Microsoft Corporation 向后兼容
  • 7 保留供以后定义使用

返回：
此 UUID 的变体号。

timestamp

public long timestamp()
与此 UUID 相关联的时间戳值。

60 位的时间戳值根据此 UUID 的 time_low、time_mid 和 time_hi 字段构造。所得到的时间戳以 100 毫微秒为单位，从 UTC（通用协调时间） 1582 年 10 月 15 日零时开始。

时间戳值仅在在基于时间的 UUID（其 version 类型为 1）中才有意义。如果此 UUID 不是基于时间的 UUID，则此方法抛出 UnsupportedOperationException。

抛出：
UnsupportedOperationException - 如果此 UUID 不是 version 为 1 的 UUID。

clockSequence

public int clockSequence()
与此 UUID 相关联的时钟序列值。

14 位的时钟序列值根据此 UUID 的 clock_seq 字段构造。clock_seq 字段用于保证在基于时间的 UUID 中的时间唯一性。

clockSequence 值仅在基于时间的 UUID（其 version 类型为 1）中才有意义。如果此 UUID 不是基于时间的 UUID，则此方法抛出 UnsupportedOperationException。

返回：
此 UUID 的时钟序列。
抛出：
UnsupportedOperationException - 如果此 UUID 的 version 不为 1。

node

public long node()
与此 UUID 相关的节点值。

48 位的节点值根据此 UUID 的 node 字段构造。此字段旨在用于保存机器的 IEEE 802 地址，该地址用于生成此 UUID 以保证空间唯一性。

节点值仅在基于时间的 UUID（其 version 类型为 1）中才有意义。如果此 UUID 不是基于时间的 UUID，则此方法抛出 UnsupportedOperationException。

返回：
此 UUID 的节点值。
抛出：
UnsupportedOperationException - 如果此 UUID 的 version 不为 1。

toString

public String toString()
返回表示此 UUID 的 String 对象。

UUID 的字符串表示形式由此 BNF 描述：

 UUID                   = <time_low> "-" <time_mid> "-"
                           <time_high_and_version> "-"
                           <variant_and_sequence> "-"
                           <node>
  time_low               = 4*<hexOctet>
  time_mid               = 2*<hexOctet>
  time_high_and_version  = 2*<hexOctet>
  variant_and_sequence   = 2*<hexOctet>
  node                   = 6*<hexOctet>
  hexOctet               = <hexDigit><hexDigit>
  hexDigit               =
        "0" | "1" | "2" | "3" | "4" | "5" | "6" | "7" | "8" | "9"
        | "a" | "b" | "c" | "d" | "e" | "f"
        | "A" | "B" | "C" | "D" | "E" | "F"

覆盖：
类 Object 中的 toString
返回：
此 UUID 的字符串表示形式。

hashCode

public int hashCode()
返回此 UUID 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
UUID 的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
将此对象与指定对象比较。当且仅当参数不为 null、而是一个 UUID 对象、具有与此 UUID 相同的 varriant、包含相同的值（每一位均相同）时，结果才为 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

compareTo

public int compareTo(UUID val)
将此 UUID 与指定的 UUID 比较。

如果两个 UUID 不同，且第一个 UUID 的最高有效字段大于第二个 UUID 的对应字段，则第一个 UUID 大于第二个 UUID。

指定者：
接口 Comparable<UUID> 中的 compareTo
参数：
val - 要与此 UUID 比较的 UUID。
返回：
在此 UUID 小于、等于或大于 val 时，分别返回 -1、0 或 1。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Vector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util
类 Vector<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.Vector<E>
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, List<E>, RandomAccess
直接已知子类：
Stack
public class Vector<E>
extends AbstractList<E>
implements List<E>, RandomAccess, Cloneable, Serializable

Vector 类可以实现可增长的对象数组。与数组一样，它包含可以使用整数索引进行访问的组件。但是，Vector 的大小可以根据需要增大或缩小，以适应创建 Vector 后进行添加或移除项的操作。

每个向量会试图通过维护 capacity 和 capacityIncrement 来优化存储管理。capacity 始终至少应与向量的大小相等；这个值通常比后者大些，因为随着将组件添加到向量中，其存储将按 capacityIncrement 的大小增加存储块。应用程序可以在插入大量组件前增加向量的容量；这样就减少了增加的重分配的量。

由 Vector 的 iterator 和 listIterator 方法所返回的迭代器是快速失败的：如果在迭代器创建后的任意时间从结构上修改了向量（通过迭代器自身的 remove 或 add 方法之外的任何其他方式），则迭代器将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就完全失败，而不是冒着在将来不确定的时间任意发生不确定行为的风险。Vector 的 elements 方法返回的 Enumeration 不是 快速失败的。

注意，迭代器的快速失败行为不能得到保证，一般来说，存在不同步的并发修改时，不可能作出任何坚决的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常的程序的方式是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测 bug。

从 Java 2 平台 v1.2 开始，此类改进为可以实现 List 接口，使它成为 Java Collections Framework 的成员。与新 collection 实现不同，Vector 是同步的。

从以下版本开始：
JDK1.0
另请参见：
Collection, List, ArrayList, LinkedList, 序列化表格

字段摘要
protected int | capacityIncrement 向量的大小大于其容量时，容量自动增加的量。
protected int | elementCount Vector 对象中的有效组件数。
protected Object[] | elementData 存储向量组件的数组缓冲区。
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
Vector()
构造一个空向量，使其内部数据数组的大小为 10，其标准容量增量为零。
Vector(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的向量，这些元素按其 collection 的迭代器返回元素的顺序排列。
Vector(int initialCapacity)
使用指定的初始容量和等于零的容量增量构造一个空向量。
Vector(int initialCapacity, int capacityIncrement)
使用指定的初始容量和容量增量构造一个空的向量。
方法摘要
 boolean add(E e)
将指定元素添加到此向量的末尾。
 void add(int index, E element)
在此向量的指定位置插入指定的元素。
 boolean addAll(Collection<? extends E> c)
将指定 Collection 中的所有元素添加到此向量的末尾，按照指定 collection 的迭代器所返回的顺序添加这些元素。
 boolean addAll(int index, Collection<? extends E> c)
在指定位置将指定 Collection 中的所有元素插入到此向量中。
 void addElement(E obj)
将指定的组件添加到此向量的末尾，将其大小增加 1。
 int capacity()
返回此向量的当前容量。
 void clear()
从此向量中移除所有元素。
 Object clone()
返回向量的一个副本。
 boolean contains(Object o)
如果此向量包含指定的元素，则返回 true。
 boolean containsAll(Collection<?> c)
如果此向量包含指定 Collection 中的所有元素，则返回 true。
 void copyInto(Object[] anArray)
将此向量的组件复制到指定的数组中。
 E elementAt(int index)
返回指定索引处的组件。
 Enumeration<E> elements()
返回此向量的组件的枚举。
 void ensureCapacity(int minCapacity)
增加此向量的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。
 boolean equals(Object o)
比较指定对象与此向量的相等性。
 E firstElement()
返回此向量的第一个组件（位于索引 0) 处的项）。
 E get(int index)
返回向量中指定位置的元素。
 int hashCode()
返回此向量的哈希码值。
 int indexOf(Object o)
返回此向量中第一次出现的指定元素的索引，如果此向量不包含该元素，则返回 -1。
 int indexOf(Object o, int index)
返回此向量中第一次出现的指定元素的索引，从 index 处正向搜索，如果未找到该元素，则返回 -1。
 void insertElementAt(E obj, int index)
将指定对象作为此向量中的组件插入到指定的 index 处。
 boolean isEmpty()
测试此向量是否不包含组件。
 E lastElement()
返回此向量的最后一个组件。
 int lastIndexOf(Object o)
返回此向量中最后一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1。
 int lastIndexOf(Object o, int index)
返回此向量中最后一次出现的指定元素的索引，从 index 处逆向搜索，如果未找到该元素，则返回 -1。
 E remove(int index)
移除此向量中指定位置的元素。
 boolean remove(Object o)
移除此向量中指定元素的第一个匹配项，如果向量不包含该元素，则元素保持不变。
 boolean removeAll(Collection<?> c)
从此向量中移除包含在指定 Collection 中的所有元素。
 void removeAllElements()
从此向量中移除全部组件，并将其大小设置为零。
 boolean removeElement(Object obj)
从此向量中移除变量的第一个（索引最小的）匹配项。
 void removeElementAt(int index)
删除指定索引处的组件。
protected  void removeRange(int fromIndex, int toIndex)
从此 List 中移除其索引位于 fromIndex（包括）与 toIndex（不包括）之间的所有元素。
 boolean retainAll(Collection<?> c)
在此向量中仅保留包含在指定 Collection 中的元素。
 E set(int index, E element)
用指定的元素替换此向量中指定位置处的元素。
 void setElementAt(E obj, int index)
将此向量指定 index 处的组件设置为指定的对象。
 void setSize(int newSize)
设置此向量的大小。
 int size()
返回此向量中的组件数。
 List<E> subList(int fromIndex, int toIndex)
返回此 List 的部分视图，元素范围为从 fromIndex（包括）到 toIndex（不包括）。
 Object[] toArray()
返回一个数组，包含此向量中以恰当顺序存放的所有元素。
<T> T[]
toArray(T[] a)
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。
 String toString()
返回此向量的字符串表示形式，其中包含每个元素的 String 表示形式。
 void trimToSize()
对此向量的容量进行微调，使其等于向量的当前大小。
从类 java.util.AbstractList 继承的方法
iterator, listIterator, listIterator
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
iterator, listIterator, listIterator

字段详细信息

elementData

protected Object[] elementData
存储向量组件的数组缓冲区。vector 的容量就是此数据缓冲区的长度，该长度至少要足以包含向量的所有元素。

Vector 中的最后一个元素后的任何数组元素都为 null。

elementCount

protected int elementCount
Vector 对象中的有效组件数。从 elementData[0] 到 elementData[elementCount-1] 的组件均为实际项。

capacityIncrement

protected int capacityIncrement
向量的大小大于其容量时，容量自动增加的量。如果容量的增量小于等于零，则每次需要增大容量时，向量的容量将增大一倍。

构造方法详细信息

Vector

public Vector(int initialCapacity,
              int capacityIncrement)
使用指定的初始容量和容量增量构造一个空的向量。

参数：
initialCapacity - 向量的初始容量
capacityIncrement - 当向量溢出时容量增加的量
抛出：
IllegalArgumentException - 如果指定的初始容量为负数

Vector

public Vector(int initialCapacity)
使用指定的初始容量和等于零的容量增量构造一个空向量。

参数：
initialCapacity - 向量的初始容量
抛出：
IllegalArgumentException - 如果指定的初始容量为负数

Vector

public Vector()
构造一个空向量，使其内部数据数组的大小为 10，其标准容量增量为零。

Vector

public Vector(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的向量，这些元素按其 collection 的迭代器返回元素的顺序排列。

参数：
c - 其元素要放入此向量中的 collection
抛出：
NullPointerException - 如果指定的 collection 为 null
从以下版本开始：
1.2
方法详细信息

copyInto

public void copyInto(Object[] anArray)
将此向量的组件复制到指定的数组中。此向量中索引 k 处的项将复制到 anArray 的组件 k 中。

参数：
anArray - 要将组件复制到其中的数组
抛出：
NullPointerException - 如果给定的数组为 null
IndexOutOfBoundsException - 如果指定数组不够大，不能够保存此向量中的所有组件
ArrayStoreException - 如果此向量的组件不属于可在指定数组中存储的运行时类型
另请参见：
toArray(Object[])

trimToSize

public void trimToSize()
对此向量的容量进行微调，使其等于向量的当前大小。如果此向量的容量大于其当前大小，则通过将其内部数据数组（保存在字段 elementData 中）替换为一个较小的数组，从而将容量更改为等于当前大小。应用程序可以使用此操作最小化向量的存储。

ensureCapacity

public void ensureCapacity(int minCapacity)
增加此向量的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。

如果此向量的当前容量小于 minCapacity，则通过将其内部数据数组（保存在字段 elementData 中）替换为一个较大的数组来增加其容量。新数据数组的大小将为原来的大小加上 capacityIncrement，除非 capacityIncrement 的值小于等于零，在后一种情况下，新的容量将为原来容量的两倍，不过，如果此大小仍然小于 minCapacity，则新容量将为 minCapacity。

参数：
minCapacity - 需要的最小容量

setSize

public void setSize(int newSize)
设置此向量的大小。如果新大小大于当前大小，则会在向量的末尾添加相应数量的 null 项。如果新大小小于当前大小，则丢弃索引 newSize 处及其之后的所有项。

参数：
newSize - 此向量的新大小
抛出：
ArrayIndexOutOfBoundsException - 如果新大小为负数

capacity

public int capacity()
返回此向量的当前容量。

返回：
当前容量（保存在此向量的 elementData 字段中的内部数据数组的长度）

size

public int size()
返回此向量中的组件数。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 List<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此向量中的组件数

isEmpty

public boolean isEmpty()
测试此向量是否不包含组件。

指定者：
接口 Collection<E> 中的 isEmpty
指定者：
接口 List<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
当且仅当此向量没有组件（也就是说其大小为零）时返回 true；否则返回 false。

elements

public Enumeration<E> elements()
返回此向量的组件的枚举。返回的 Enumeration 对象将生成此向量中的所有项。生成的第一项为索引 0 处的项，然后是索引 1 处的项，依此类推。

返回：
此向量的组件的枚举
另请参见：
Iterator

contains

public boolean contains(Object o)
如果此向量包含指定的元素，则返回 true。更确切地讲，当且仅当此向量至少包含一个满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 List<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 测试在此向量中是否存在的元素
返回：
如果此向量包含指定的元素，则返回 true

indexOf

public int indexOf(Object o)
返回此向量中第一次出现的指定元素的索引，如果此向量不包含该元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i；如果没有这样的索引，则返回 -1。

指定者：
接口 List<E> 中的 indexOf
覆盖：
类 AbstractList<E> 中的 indexOf
参数：
o - 要搜索的元素
返回：
此向量中第一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1

indexOf

public int indexOf(Object o,
                   int index)
返回此向量中第一次出现的指定元素的索引，从 index 处正向搜索，如果未找到该元素，则返回 -1。更确切地讲，返回满足 (i >= index && (o==null ? get(i)==null : o.equals(get(i)))) 的最低索引 i；如果没有这样的索引，则返回 -1。

参数：
o - 要搜索的元素
index - 搜索开始处的索引
返回：
此向量中 index 位置或之后位置处第一次出现的指定元素的索引；如果未找到该元素，则返回 -1。
抛出：
IndexOutOfBoundsException - 如果指定索引为负数
另请参见：
Object.equals(Object)

lastIndexOf

public int lastIndexOf(Object o)
返回此向量中最后一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最高索引 i；如果没有这样的索引，则返回 -1。

指定者：
接口 List<E> 中的 lastIndexOf
覆盖：
类 AbstractList<E> 中的 lastIndexOf
参数：
o - 要搜索的元素
返回：
此向量中最后一次出现的指定元素的索引；如果此向量不包含该元素，则返回 -1

lastIndexOf

public int lastIndexOf(Object o,
                       int index)
返回此向量中最后一次出现的指定元素的索引，从 index 处逆向搜索，如果未找到该元素，则返回 -1。更确切地讲，返回满足 (i <= index && (o==null ? get(i)==null : o.equals(get(i)))) 的最高索引 i；如果没有这样的索引，则返回 -1。

参数：
o - 要搜索的元素
index - 逆向搜索开始处的索引
返回：
此向量中小于等于 index 位置处最后一次出现的指定元素的索引；如果未找到该元素，则返回 -1。
抛出：
IndexOutOfBoundsException - 如果指定索引大于等于此向量的当前大小

elementAt

public E elementAt(int index)
返回指定索引处的组件。

此方法的功能与 get(int) 方法的功能完全相同（后者是 List 接口的一部分）。

参数：
index - 此向量的一个索引
返回：
指定索引处的组件
抛出：
ArrayIndexOutOfBoundsException - 如果该索引超出范围 (index < 0 || index >= size())

firstElement

public E firstElement()
返回此向量的第一个组件（位于索引 0) 处的项）。

返回：
此向量的第一个组件
抛出：
NoSuchElementException - 如果此向量没有组件

lastElement

public E lastElement()
返回此向量的最后一个组件。

返回：
向量的最后一个组件，即索引 size() - 1 处的组件。
抛出：
NoSuchElementException - 如果此向量为空

setElementAt

public void setElementAt(E obj,
                         int index)
将此向量指定 index 处的组件设置为指定的对象。丢弃该位置以前的组件。

索引必须为一个大于等于 0 且小于向量当前大小的值。

此方法的功能与 set(int, E) 方法的功能完全相同（后者是 List 接口的一部分）。注意，set 方法将反转参数的顺序，与数组用法更为匹配。另外还要注意，set 方法将返回以前存储在指定位置的旧值。

参数：
obj - 将用来设置组件的内容
index - 指定的索引
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

removeElementAt

public void removeElementAt(int index)
删除指定索引处的组件。此向量中的每个索引大于等于指定 index 的组件都将下移，使其索引值变成比以前小 1 的值。此向量的大小将减 1。

索引必须为一个大于等于 0 且小于向量当前大小的值。

此方法的功能与 remove(int) 方法的功能完全相同（后者是 List 接口的一部分）。注意，remove 方法将返回存储在指定位置的旧值。

参数：
index - 要移除对象的索引
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

insertElementAt

public void insertElementAt(E obj,
                            int index)
将指定对象作为此向量中的组件插入到指定的 index 处。此向量中的每个索引大于等于指定 index 的组件都将向上移位，使其索引值变成比以前大 1 的值。

索引必须为一个大于等于 0 且小于等于向量当前大小的值（如果索引等于向量的当前大小，则将新元素添加到向量）。

此方法的功能与 add(int, E) 方法的功能完全相同（后者是 List 接口的一部分）。注意，add 方法将反转参数的顺序，与数组用法更为匹配。

参数：
obj - 要插入的组件
index - 新组件的插入位置
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

addElement

public void addElement(E obj)
将指定的组件添加到此向量的末尾，将其大小增加 1。如果向量的大小比容量大，则增大其容量。

此方法的功能与 add(E) 方法的功能完全相同（后者是 List 接口的一部分）。

参数：
obj - 要添加的组件

removeElement

public boolean removeElement(Object obj)
从此向量中移除变量的第一个（索引最小的）匹配项。如果在此向量中找到该对象，那么向量中索引大于等于该对象索引的每个组件都会下移，使其索引值变成比以前小 1 的值。

此方法的功能与 remove(Object) 方法的功能完全相同（后者是 List 接口的一部分）。

参数：
obj - 要移除的组件
返回：
如果变量值是此向量的一个组件，则返回 true；否则返回 false。

removeAllElements

public void removeAllElements()
从此向量中移除全部组件，并将其大小设置为零。

此方法的功能与 clear() 方法的功能完全相同（后者是 List 接口的一部分）。

clone

public Object clone()
返回向量的一个副本。副本中将包含一个对内部数据数组副本的引用，而非对此 Vector 对象的原始内部数据数组的引用。

覆盖：
类 Object 中的 clone
返回：
向量的一个副本
另请参见：
Cloneable

toArray

public Object[] toArray()
返回一个数组，包含此向量中以恰当顺序存放的所有元素。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此 collection 中所有元素的数组
从以下版本开始：
1.2
另请参见：
Arrays.asList(Object[])

toArray

public <T> T[] toArray(T[] a)
返回一个数组，包含此向量中以恰当顺序存放的所有元素；返回数组的运行时类型为指定数组的类型。如果向量能够适应指定的数组，则返回该数组。否则使用此数组的运行时类型和此向量的大小分配一个新数组。

如果向量能够适应指定的数组，而且还有多余空间（即数组的元素比向量的元素多），则将紧跟向量末尾的数组元素设置为 null。（仅 在调用者知道向量不包含任何 null 元素的情况下，这对确定向量的长度才有用）。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 要在其中存储向量元素的数组（如果该数组足够大）；否则，将为此分配一个具有相同运行时类型的新数组。
返回：
包含向量元素的数组
抛出：
ArrayStoreException - 如果 a 的运行时类型不是此向量中每个元素的运行时类型的超类型
NullPointerException - 如果给定的数组为 null
从以下版本开始：
1.2

get

public E get(int index)
返回向量中指定位置的元素。

指定者：
接口 List<E> 中的 get
指定者：
类 AbstractList<E> 中的 get
参数：
index - 要返回元素的索引
返回：
指定索引处的对象
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())
从以下版本开始：
1.2

set

public E set(int index,
             E element)
用指定的元素替换此向量中指定位置处的元素。

指定者：
接口 List<E> 中的 set
覆盖：
类 AbstractList<E> 中的 set
参数：
index - 要替换元素的索引
element - 要存储在指定位置的元素
返回：
以前位于指定位置处的元素
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())
从以下版本开始：
1.2

add

public boolean add(E e)
将指定元素添加到此向量的末尾。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 List<E> 中的 add
覆盖：
类 AbstractList<E> 中的 add
参数：
e - 要添加到此向量的元素
返回：
true（根据 Collection.add(E) 的规定）
从以下版本开始：
1.2

remove

public boolean remove(Object o)
移除此向量中指定元素的第一个匹配项，如果向量不包含该元素，则元素保持不变。更确切地讲，移除其索引 i 满足 (o==null ? get(i)==null : o.equals(get(i))) 的元素（如果存在这样的元素）。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 List<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从向量中移除的元素（如果存在）
返回：
如果向量包含指定元素，则返回 true
从以下版本开始：
1.2

add

public void add(int index,
                E element)
在此向量的指定位置插入指定的元素。将当前位于该位置的元素（如果有）及所有后续元素右移（将其索引加 1）。

指定者：
接口 List<E> 中的 add
覆盖：
类 AbstractList<E> 中的 add
参数：
index - 要在其位置插入指定元素的索引
element - 要插入的元素
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())
从以下版本开始：
1.2

remove

public E remove(int index)
移除此向量中指定位置的元素。将所有后续元素左移（将其索引减 1）。返回此向量中移除的元素。

指定者：
接口 List<E> 中的 remove
覆盖：
类 AbstractList<E> 中的 remove
参数：
index - 要移除元素的索引
返回：
移除的元素
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())
从以下版本开始：
1.2

clear

public void clear()
从此向量中移除所有元素。此调用返回后，向量将为空（除非抛出了异常）。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 List<E> 中的 clear
覆盖：
类 AbstractList<E> 中的 clear
从以下版本开始：
1.2

containsAll

public boolean containsAll(Collection<?> c)
如果此向量包含指定 Collection 中的所有元素，则返回 true。

指定者：
接口 Collection<E> 中的 containsAll
指定者：
接口 List<E> 中的 containsAll
覆盖：
类 AbstractCollection<E> 中的 containsAll
参数：
c - 要在此向量中测试是否包含其元素的 collection
返回：
如果此向量包含指定 collection 中的所有元素，则返回 true
抛出：
NullPointerException - 如果指定 collection 为 null
另请参见：
AbstractCollection.contains(Object)

addAll

public boolean addAll(Collection<? extends E> c)
将指定 Collection 中的所有元素添加到此向量的末尾，按照指定 collection 的迭代器所返回的顺序添加这些元素。如果指定的 Collection 在操作过程中被修改，则此操作的行为是不确定的（这意味着如果指定的 Collection 是此向量，而此向量不为空，则此调用的行为是不确定的）。

指定者：
接口 Collection<E> 中的 addAll
指定者：
接口 List<E> 中的 addAll
覆盖：
类 AbstractCollection<E> 中的 addAll
参数：
c - 要插入到此向量的元素
返回：
如果此向量由于调用而更改，则返回 true
抛出：
NullPointerException - 如果指定 collection 为 null
从以下版本开始：
1.2
另请参见：
AbstractCollection.add(Object)

removeAll

public boolean removeAll(Collection<?> c)
从此向量中移除包含在指定 Collection 中的所有元素。

指定者：
接口 Collection<E> 中的 removeAll
指定者：
接口 List<E> 中的 removeAll
覆盖：
类 AbstractCollection<E> 中的 removeAll
参数：
c - 要从向量中移除的元素的 collection
返回：
如果此向量由于调用而更改，则返回 true
抛出：
ClassCastException - 如果此向量中的一个或多个元素的类型与指定 collection 不兼容（可选）
NullPointerException - 如果此向量包含一个或多个 null 元素并且指定 collection 不支持 null 元素（可选），或者指定 collection 为 null
从以下版本开始：
1.2
另请参见：
AbstractCollection.remove(Object), AbstractCollection.contains(Object)

retainAll

public boolean retainAll(Collection<?> c)
在此向量中仅保留包含在指定 Collection 中的元素。换句话说，从此向量中移除所有未包含在指定 Collection 中的元素。

指定者：
接口 Collection<E> 中的 retainAll
指定者：
接口 List<E> 中的 retainAll
覆盖：
类 AbstractCollection<E> 中的 retainAll
参数：
c - 要在此向量中保留的元素的 collection（移除其他所有元素）
返回：
如果此向量由于调用而更改，则返回 true
抛出：
ClassCastException - 如果此向量中的一个或多个元素的类型与指定 collection 不兼容（可选）
NullPointerException - 如果此向量包含一个或多个 null 元素并且指定 collection 不支持 null 元素（可选），或者指定 collection 为 null
从以下版本开始：
1.2
另请参见：
AbstractCollection.remove(Object), AbstractCollection.contains(Object)

addAll

public boolean addAll(int index,
                      Collection<? extends E> c)
在指定位置将指定 Collection 中的所有元素插入到此向量中。将当前位于该位置的元素（如果有）及所有后续元素右移（增大其索引值）。新元素在向量中按照其由指定 collection 的迭代器所返回的顺序出现。

指定者：
接口 List<E> 中的 addAll
覆盖：
类 AbstractList<E> 中的 addAll
参数：
index - 要插入指定 collection 的第一个元素的索引
c - 要插入到此向量的元素
返回：
如果此向量由于调用而更改，则返回 true
抛出：
ArrayIndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())
NullPointerException - 如果指定的 collection 为 null
从以下版本开始：
1.2

equals

public boolean equals(Object o)
比较指定对象与此向量的相等性。当且仅当指定的对象也是一个 List、两个 List 大小相同，并且其中所有对应的元素对都相等 时才返回 true。（如果 (e1==null ? e2==null : e1.equals(e2))，则两个元素 e1 和 e2 相等）。换句话说，如果两个 List 包含相同顺序的相同元素，则这两个 List 就定义为相等。

指定者：
接口 Collection<E> 中的 equals
指定者：
接口 List<E> 中的 equals
覆盖：
类 AbstractList<E> 中的 equals
参数：
o - 要与此向量进行相等性比较的对象
返回：
如果指定的 Object 与此向量相等，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此向量的哈希码值。

指定者：
接口 Collection<E> 中的 hashCode
指定者：
接口 List<E> 中的 hashCode
覆盖：
类 AbstractList<E> 中的 hashCode
返回：
此列表的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此向量的字符串表示形式，其中包含每个元素的 String 表示形式。

覆盖：
类 AbstractCollection<E> 中的 toString
返回：
此 collection 的字符串表示形式

subList

public List<E> subList(int fromIndex,
                       int toIndex)
返回此 List 的部分视图，元素范围为从 fromIndex（包括）到 toIndex（不包括）。（如果 fromIndex 和 toIndex 相等，则返回的 List 将为空）。返回的 List 由此 List 支持，因此返回 List 中的更改将反映在此 List 中，反之亦然。返回的列表支持此列表支持的所有可选列表操作。

此方法消除了显式范围操作的需要（此操作通常针对数组存在）。通过操作 subList 视图而非整个 List，期望 List 的任何操作可用作范围操作。例如，下面的语句从 List 中移除了元素的范围：

            list.subList(from, to).clear();
可以对 indexOf 和 lastIndexOf 构造类似的语句，而且 Collections 类中的所有算法都可以应用于 subList。

如果通过任何其他方式（而不是通过返回的列表）从结构上修改 内部 List（即此 List），则此方法返回的 List 的语义将变为不确定的（从结构上修改是指更改 List 的大小，或者以其他方式打乱 List，使正在进行的迭代产生错误的结果）。

指定者：
接口 List<E> 中的 subList
覆盖：
类 AbstractList<E> 中的 subList
参数：
fromIndex - subList的低端点（包括）
toIndex - subList 的高端点（不包括）
返回：
List 中指定范围的视图
抛出：
IndexOutOfBoundsException - 如果端点索引值超出范围 (fromIndex < 0 || toIndex > size)
IllegalArgumentException - 如果端点索引顺序错误 (fromIndex > toIndex)

removeRange

protected void removeRange(int fromIndex,
                           int toIndex)
从此 List 中移除其索引位于 fromIndex（包括）与 toIndex（不包括）之间的所有元素。将所有后续元素左移（减小其索引值）。此调用会将 ArrayList 缩小 (toIndex - fromIndex) 个元素（如果 toIndex==fromIndex，则此操作没有任何效果）。

覆盖：
类 AbstractList<E> 中的 removeRange
参数：
fromIndex - 要移除的第一个元素的索引
toIndex - 要移除的最后一个元素之后的索引
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WeakHashMap (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util
类 WeakHashMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.WeakHashMap<K,V>
类型参数：
K - 此映射所维护的键的类型
V - 映射值的类型
所有已实现的接口：
Map<K,V>
public class WeakHashMap<K,V>
extends AbstractMap<K,V>
implements Map<K,V>

以弱键 实现的基于哈希表的 Map。在 WeakHashMap 中，当某个键不再正常使用时，将自动移除其条目。更精确地说，对于一个给定的键，其映射的存在并不阻止垃圾回收器对该键的丢弃，这就使该键成为可终止的，被终止，然后被回收。丢弃某个键时，其条目从映射中有效地移除，因此，该类的行为与其他的 Map 实现有所不同。

null 值和 null 键都被支持。该类具有与 HashMap 类相似的性能特征,并具有相同的效能参数初始容量 和加载因子。

像大多数 collection 类一样，该类是不同步的。可以使用 Collections.synchronizedMap 方法来构造同步的 WeakHashMap。

该类主要与这样的键对象一起使用，其 equals 方法使用 == 运算符来测试对象标识。一旦这种键被丢弃，就永远无法再创建了，所以，过段时间后在 WeakHashMap 中查找此键是不可能的，不必对其项已移除而感到惊讶。该类十分适合与 equals 方法不是基于对象标识的键对象一起使用，比如，String 实例。然而，对于这种可重新创建的键对象，键若丢弃，就自动移除 WeakHashMap 条目，这种表现令人疑惑。

WeakHashMap 类的行为部分取决于垃圾回收器的动作，所以，几个常见的（虽然不是必需的）Map 常量不支持此类。因为垃圾回收器在任何时候都可能丢弃键，WeakHashMap 就像是一个被悄悄移除条目的未知线程。特别地，即使对 WeakHashMap 实例进行同步，并且没有调用任何赋值方法，在一段时间后 size 方法也可能返回较小的值，对于 isEmpty 方法，返回 false，然后返回 true，对于给定的键，containsKey 方法返回 true 然后返回 false，对于给定的键，get 方法返回一个值，但接着返回 null，对于以前出现在映射中的键，put 方法返回 null，而 remove 方法返回 false，对于键 set、值 collection 和条目 set 进行的检查，生成的元素数量越来越少。

WeakHashMap 中的每个键对象间接地存储为一个弱引用的指示对象。因此，不管是在映射内还是在映射之外，只有在垃圾回收器清除某个键的弱引用之后，该键才会自动移除。

实现注意事项：WeakHashMap 中的值对象由普通的强引用保持。因此应该小心谨慎，确保值对象不会直接或间接地强引用其自身的键，因为这会阻止键的丢弃。注意，值对象可以通过 WeakHashMap 本身间接引用其对应的键；这就是说，某个值对象可能强引用某个其他的键对象，而与该键对象相关联的值对象转而强引用第一个值对象的键。处理此问题的一种方法是，在插入前将值自身包装在 WeakReferences 中，如：m.put(key, new WeakReference(value))，然后，分别用 get 进行解包。

collection 的 iterator 方法所返回的迭代器（由该类所有“collection 视图方法”返回）均是快速失败的：在迭代器创建之后，如果从结构上对映射进行修改，除非通过迭代器自身的 remove 或 add 方法,其他任何时间任何方式的修改，迭代器都将抛出 ConcurrentModificationException。因此，面对并发的修改，迭代器很快就完全失败，而不是冒着在将来不确定的时间任意发生不确定行为的风险。

注意，迭代器的快速失败行为不能得到保证，一般来说，存在不同步的并发修改时，不可能作出任何坚决的保证。快速失败迭代器尽最大努力抛出 ConcurrentModificationException。因此，编写依赖于此异常程序的方式是错误的，正确做法是：迭代器的快速失败行为应该仅用于检测 bug。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.2
另请参见：
HashMap, WeakReference

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
构造方法摘要
WeakHashMap()
构造具有默认初始容量 (16) 和加载因子 (0.75) 的新的空 WeakHashMap。
WeakHashMap(int initialCapacity)
构造具有给定初始容量和默认加载因子 (0.75) 的新的空 WeakHashMap。
WeakHashMap(int initialCapacity, float loadFactor)
用给定的初始容量和加载因子构造一个新的空 WeakHashMap。
WeakHashMap(Map<? extends K,? extends V> m)
构造一个新 WeakHashMap，使其与指定的映射具有相同的映射关系。
方法摘要
void | clear() 从此映射中移除所有映射关系。
boolean | containsKey(Object key) 如果此映射对于指定的键包含映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
Set<Map.Entry<K,V>> | entrySet() 返回此映射所包含的映射关系的 Set 视图。
V | get(Object key) 返回指定键所映射的值，如果对于该键来说，此映射不包含任何映射关系，则返回 null。
boolean | isEmpty() 如果此映射不包含键-值映射关系，则返回 true。
Set<K> | keySet() 返回此映射所包含的键的 Set 视图。
V | put(K key, V value) 关联此映射中的指定值与指定键。
void | putAll(Map<? extends K,? extends V> m) 将指定映射的全部映射关系复制到此映射。
V | remove(Object key) 从此弱哈希映射中移除键的映射关系（如果存在）。
int | size() 返回该映射中的键-值映射关系的数目。
Collection<V> | values() 返回此映射所包含的值的 Collection 视图。
从类 java.util.AbstractMap 继承的方法
clone, equals, hashCode, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Map 继承的方法
equals, hashCode

构造方法详细信息

WeakHashMap

public WeakHashMap(int initialCapacity,
                   float loadFactor)
用给定的初始容量和加载因子构造一个新的空 WeakHashMap。

参数：
initialCapacity - WeakHashMap 的初始容量
loadFactor - WeakHashMap 的加载因子
抛出：
IllegalArgumentException - 如果初始容量为负，或加载因子为非正。

WeakHashMap

public WeakHashMap(int initialCapacity)
构造具有给定初始容量和默认加载因子 (0.75) 的新的空 WeakHashMap。

参数：
initialCapacity - WeakHashMap 的初始容量
抛出：
IllegalArgumentException - 如果初始容量为负

WeakHashMap

public WeakHashMap()
构造具有默认初始容量 (16) 和加载因子 (0.75) 的新的空 WeakHashMap。

WeakHashMap

public WeakHashMap(Map<? extends K,? extends V> m)
构造一个新 WeakHashMap，使其与指定的映射具有相同的映射关系。创建具有默认加载因子 (0.75) 的 WeakHashMap，初始容量足以容纳指定映射中的映射关系。

参数：
m - 映射，其映射关系将存放在此映射中
抛出：
NullPointerException - 如果指定的映射为 null
从以下版本开始：
1.3
方法详细信息

size

public int size()
返回该映射中的键-值映射关系的数目。此结果是个快照，可能无法反映未处理的项，这些项因为不再引用而在下次试图访问前被移除。

指定者：
接口 Map<K,V> 中的 size
覆盖：
类 AbstractMap<K,V> 中的 size
返回：
此映射中的键-值映射关系数

isEmpty

public boolean isEmpty()
如果此映射不包含键-值映射关系，则返回 true。此结果是个快照，可能无法反映未处理的项，这些项因为不再引用而在下次访问前被移除。

指定者：
接口 Map<K,V> 中的 isEmpty
覆盖：
类 AbstractMap<K,V> 中的 isEmpty
返回：
如果此映射未包含键-值映射关系，则返回 true

get

public V get(Object key)
返回指定键所映射的值，如果对于该键来说，此映射不包含任何映射关系，则返回 null。

更确切地讲，如果此映射包含一个满足以下条件的从键 k 到值 v 的映射关系：(key==null ? k==null : key.equals(k))，则此方法返回 v；否则它返回 null。（最多只能有一个这样的映射关系）。

返回值为 null 并不一定 表示映射不包含该键的任何映射关系；也可能是映射显式地将键映射到 null。使用 containsKey 操作可以区分这两种情况。

指定者：
接口 Map<K,V> 中的 get
覆盖：
类 AbstractMap<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
另请参见：
put(Object, Object)

containsKey

public boolean containsKey(Object key)
如果此映射对于指定的键包含映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 containsKey
覆盖：
类 AbstractMap<K,V> 中的 containsKey
参数：
key - 要测试其是否在此映射中存在的键
返回：
如果有 key 的映射关系，则返回 true，否则返回 false。

put

public V put(K key,
             V value)
关联此映射中的指定值与指定键。如果此映射以前包含了一个该键的映射关系，则替换旧值。

指定者：
接口 Map<K,V> 中的 put
覆盖：
类 AbstractMap<K,V> 中的 put
参数：
key - 指定值将要关联的键。
value - 指定键将要关联的值。
返回：
返回与 key 关联的先前值，如果 key 没有任何映射关系，则返回 null。（返回 null 还可以表示该映射以前关联了 null 与 key）。

putAll

public void putAll(Map<? extends K,? extends V> m)
将指定映射的全部映射关系复制到此映射。这些映射关系将替换此映射针对当前指定映射中任何键所具有的任何映射关系。

指定者：
接口 Map<K,V> 中的 putAll
覆盖：
类 AbstractMap<K,V> 中的 putAll
参数：
m - 要在此映射中存储的映射关系。
抛出：
NullPointerException - 如果指定的映射为 null。

remove

public V remove(Object key)
从此弱哈希映射中移除键的映射关系（如果存在）。更确切地讲，如果此映射包含一个满足以下条件的从键 k 到值 v 的映射关系：(key==null ? k==null : key.equals(k))，则移除该映射关系。（该映射最多只能包含一个这样的映射关系）。

返回此映射先前与该键关联的值，如果映射不包含该键的任何映射关系，则返回 null。返回值为 null 并不一定 表示映射不包含该键的任何映射关系；也可能是映射显式地将键映射到 null。

一旦调用返回，则该映射将不再包含指定键的映射关系。

指定者：
接口 Map<K,V> 中的 remove
覆盖：
类 AbstractMap<K,V> 中的 remove
参数：
key - 其映射关系要从映射中移除的键
返回：
与 key 相关联的先前值，如果 key 没有任何映射关系，则返回 null

clear

public void clear()
从此映射中移除所有映射关系。此调用返回后，该映射将是空的。

指定者：
接口 Map<K,V> 中的 clear
覆盖：
类 AbstractMap<K,V> 中的 clear

containsValue

public boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。

指定者：
接口 Map<K,V> 中的 containsValue
覆盖：
类 AbstractMap<K,V> 中的 containsValue
参数：
value - 要测试其是否在此映射中存在的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true

keySet

public Set<K> keySet()
返回此映射所包含的键的 Set 视图。该 set 受映射支持，所以对映射的改变可在此 set 中反映出来，反之亦然。如果在该 set 上进行迭代时修改该映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。该 set 支持元素的移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从该映射移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 keySet
覆盖：
类 AbstractMap<K,V> 中的 keySet
返回：
此映射中包含的键的 set 视图

values

public Collection<V> values()
返回此映射所包含的值的 Collection 视图。该 collection 受映射支持，所以对映射的改变可在该 collection 中反映出来，反之亦然。如果在该 collection 上进行迭代时修改该映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。该 collection 支持元素的移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作可从该映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 values
覆盖：
类 AbstractMap<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射所包含的映射关系的 Set 视图。该 set 受映射支持，所以对映射的改变可在此 set 中反映出来，反之亦然。如果在该 set 上进行迭代时修改该映射（通过迭代器自己的 remove 操作，或者通过迭代器所返回的映射项上的 setValue 操作除外），则迭代结果是不确定的。该 set 支持元素的移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作，从该映射移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<K,V> 中的 entrySet
指定者：
类 AbstractMap<K,V> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util (Java 2 Platform SE 6)

 java.util
接口
Collection
Comparator
Deque
Enumeration
EventListener
Formattable
Iterator
List
ListIterator
Map
Map.Entry
NavigableMap
NavigableSet
Observer
Queue
RandomAccess
Set
SortedMap
SortedSet
类
AbstractCollection
AbstractList
AbstractMap
AbstractMap.SimpleEntry
AbstractMap.SimpleImmutableEntry
AbstractQueue
AbstractSequentialList
AbstractSet
ArrayDeque
ArrayList
Arrays
BitSet
Calendar
Collections
Currency
Date
Dictionary
EnumMap
EnumSet
EventListenerProxy
EventObject
FormattableFlags
Formatter
GregorianCalendar
HashMap
HashSet
Hashtable
IdentityHashMap
LinkedHashMap
LinkedHashSet
LinkedList
ListResourceBundle
Locale
Observable
PriorityQueue
Properties
PropertyPermission
PropertyResourceBundle
Random
ResourceBundle
ResourceBundle.Control
Scanner
ServiceLoader
SimpleTimeZone
Stack
StringTokenizer
Timer
TimerTask
TimeZone
TreeMap
TreeSet
UUID
Vector
WeakHashMap
枚举
Formatter.BigDecimalLayoutForm
异常
ConcurrentModificationException
DuplicateFormatFlagsException
EmptyStackException
FormatFlagsConversionMismatchException
FormatterClosedException
IllegalFormatCodePointException
IllegalFormatConversionException
IllegalFormatException
IllegalFormatFlagsException
IllegalFormatPrecisionException
IllegalFormatWidthException
InputMismatchException
InvalidPropertiesFormatException
MissingFormatArgumentException
MissingFormatWidthException
MissingResourceException
NoSuchElementException
TooManyListenersException
UnknownFormatConversionException
UnknownFormatFlagsException
错误
ServiceConfigurationError


java.util (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util

包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

请参见：
描述

接口摘要
Collection<E> | Collection 层次结构 中的根接口。
Comparator<T> | 强行对某个对象 collection 进行整体排序 的比较函数。
Deque<E> | 一个线性 collection，支持在两端插入和移除元素。
Enumeration<E> | 实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener | 所有事件侦听器接口必须扩展的标记接口。
Formattable | Formattable 接口必须通过需要执行自定义格式化（使用 Formatter 的 's' 转换说明符）的任何类来实现。
Iterator<E> | 对 collection 进行迭代的迭代器。
List<E> | 有序的 collection（也称为序列）。
ListIterator<E> | 系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。
Map<K,V> | 将键映射到值的对象。
Map.Entry<K,V> | 映射项（键-值对）。
NavigableMap<K,V> | 扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。
NavigableSet<E> | 扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
Observer | 一个可在观察者要得到 observable 对象更改通知时可实现 Observer 接口的类。
Queue<E> | 在处理元素前用于保存元素的 collection。
RandomAccess | List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。
Set<E> | 一个不包含重复元素的 collection。
SortedMap<K,V> | 进一步提供关于键的总体排序 的 Map。
SortedSet<E> | 进一步提供关于元素的总体排序 的 Set。

类摘要
AbstractCollection<E> | 此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractList<E> | 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
AbstractMap<K,V> | 此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
AbstractMap.SimpleEntry<K,V> | 维护键和值的 Entry。
AbstractMap.SimpleImmutableEntry<K,V> | 维护不可变的键和值的 Entry。
AbstractQueue<E> | 此类提供某些 Queue 操作的骨干实现。
AbstractSequentialList<E> | 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
AbstractSet<E> | 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
ArrayDeque<E> | Deque 接口的大小可变数组的实现。
ArrayList<E> | List 接口的大小可变数组的实现。
Arrays | 此类包含用来操作数组（比如排序和搜索）的各种方法。
BitSet | 此类实现了一个按需增长的位向量。
Calendar | Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Collections | 此类完全由在 collection 上进行操作或返回 collection 的静态方法组成。
Currency | 表示货币。
Date | 类 Date 表示特定的瞬间，精确到毫秒。
Dictionary<K,V> | Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。
EnumMap<K extends Enum<K>,V> | 与枚举类型键一起使用的专用 Map 实现。
EnumSet<E extends Enum<E>> | 与枚举类型一起使用的专用 Set 实现。
EventListenerProxy | 将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。
EventObject | 所有事件状态对象都将从其派生的根类。
FormattableFlags | 将 FomattableFlags 传递给 Formattable.formatTo() 方法，并修改 Formattables 的输出格式。
Formatter | printf 风格的格式字符串的解释程序。
GregorianCalendar | GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
HashMap<K,V> | 基于哈希表的 Map 接口的实现。
HashSet<E> | 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
Hashtable<K,V> | 此类实现一个哈希表，该哈希表将键映射到相应的值。
IdentityHashMap<K,V> | 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
LinkedHashMap<K,V> | Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
LinkedHashSet<E> | 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
LinkedList<E> | List 接口的链接列表实现。
ListResourceBundle | ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。
Locale | Locale 对象表示了特定的地理、政治和文化地区。
Observable | 此类表示模型视图范例中的 observable 对象，或者说“数据”。
PriorityQueue<E> | 一个基于优先级堆的无界优先级队列。
Properties | Properties 类表示了一个持久的属性集。
PropertyPermission | 此类用于属性权限。
PropertyResourceBundle | PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。
Random | 此类的实例用于生成伪随机数流。
ResourceBundle | 资源包包含特定于语言环境的对象。
ResourceBundle.Control | ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。
Scanner | 一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。
ServiceLoader<S> | 一个简单的服务提供者加载设施。
SimpleTimeZone | SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。
Stack<E> | Stack 类表示后进先出（LIFO）的对象堆栈。
StringTokenizer | string tokenizer 类允许应用程序将字符串分解为标记。
Timer | 一种工具，线程用其安排以后在后台线程中执行的任务。
TimerTask | 由 Timer 安排为一次执行或重复执行的任务。
TimeZone | TimeZone 表示时区偏移量，也可以计算夏令时。
TreeMap<K,V> | 基于红黑树（Red-Black tree）的 NavigableMap 实现。
TreeSet<E> | 基于 TreeMap 的 NavigableSet 实现。
UUID | 表示通用唯一标识符 (UUID) 的类。
Vector<E> | Vector 类可以实现可增长的对象数组。
WeakHashMap<K,V> | 以弱键 实现的基于哈希表的 Map。

枚举摘要
Formatter.BigDecimalLayoutForm

异常摘要
ConcurrentModificationException | 当方法检测到对象的并发修改，但不允许这种修改时，抛出此异常。
DuplicateFormatFlagsException | 格式说明符中提供重复标志时抛出的未经检查的异常。
EmptyStackException | 该异常由 Stack 类中的方法抛出，以表明堆栈为空。
FormatFlagsConversionMismatchException | 转换与标志不兼容时抛出未经检查的异常。
FormatterClosedException | 格式器已关闭时抛出的未经检查的异常。
IllegalFormatCodePointException | 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
IllegalFormatConversionException | 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
IllegalFormatException | 当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
IllegalFormatFlagsException | 当给出非法组合标志时，抛出未经检查的异常。
IllegalFormatPrecisionException | 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
IllegalFormatWidthException | 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
InputMismatchException | 由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。
InvalidPropertiesFormatException | 当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
MissingFormatArgumentException | 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
MissingFormatWidthException | 请求格式宽度时抛出未经检查的异常。
MissingResourceException | 缺少资源时抛出此异常。
NoSuchElementException | 由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
TooManyListenersException | TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。
UnknownFormatConversionException | 给定未知的转换时所抛出的未经检查的异常。
UnknownFormatFlagsException | 给定未知标志时所抛出的未经检查的异常。

错误摘要
ServiceConfigurationError 在加载服务提供者的过程中出错时抛出的错误。

软件包 java.util 的描述

包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

包规范

  • Collections Framework Overview
  • Collections Framework Annotated Outline

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • Collections Framework Tutorial
  • Collections Framework Design FAQ

从以下版本开始：
JDK1.0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.AbstractSequentialList<E>
          • java.util.LinkedList<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.util.List<E>, java.io.Serializable)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
        • java.util.Vector<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • java.util.Stack<E>
      • java.util.AbstractQueue<E> (implements java.util.Queue<E>)
        • java.util.PriorityQueue<E> (implements java.io.Serializable)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.EnumSet<E> (implements java.lang.Cloneable, java.io.Serializable)
        • java.util.HashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
          • java.util.LinkedHashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
        • java.util.TreeSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
      • java.util.ArrayDeque<E> (implements java.lang.Cloneable, java.util.Deque<E>, java.io.Serializable)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.EnumMap<K,V> (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.LinkedHashMap<K,V> (implements java.util.Map<K,V>)
      • java.util.IdentityHashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
      • java.util.TreeMap<K,V> (implements java.lang.Cloneable, java.util.NavigableMap<K,V>, java.io.Serializable)
      • java.util.WeakHashMap<K,V> (implements java.util.Map<K,V>)
    • java.util.AbstractMap.SimpleEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • java.util.AbstractMap.SimpleImmutableEntry<K,V> (implements java.util.Map.Entry<K,V>, java.io.Serializable)
    • java.util.Arrays
    • java.util.BitSet (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.Calendar (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
      • java.util.GregorianCalendar
    • java.util.Collections
    • java.util.Currency (implements java.io.Serializable)
    • java.util.Date (implements java.lang.Cloneable, java.lang.Comparable<T>, java.io.Serializable)
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • java.util.Properties
    • java.util.EventListenerProxy (implements java.util.EventListener)
    • java.util.EventObject (implements java.io.Serializable)
    • java.util.FormattableFlags
    • java.util.Formatter (implements java.io.Closeable, java.io.Flushable)
    • java.util.Locale (implements java.lang.Cloneable, java.io.Serializable)
    • java.util.Observable
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.util.PropertyPermission
    • java.util.Random (implements java.io.Serializable)
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
      • java.util.PropertyResourceBundle
    • java.util.ResourceBundle.Control
    • java.util.Scanner (implements java.util.Iterator<E>)
    • java.util.ServiceLoader<S> (implements java.lang.Iterable<T>)
    • java.util.StringTokenizer (implements java.util.Enumeration<E>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.util.ServiceConfigurationError
      • java.lang.Exception
        • java.io.IOException
          • java.util.InvalidPropertiesFormatException
        • java.lang.RuntimeException
          • java.util.ConcurrentModificationException
          • java.util.EmptyStackException
          • java.lang.IllegalArgumentException
            • java.util.IllegalFormatException
              • java.util.DuplicateFormatFlagsException
              • java.util.FormatFlagsConversionMismatchException
              • java.util.IllegalFormatCodePointException
              • java.util.IllegalFormatConversionException
              • java.util.IllegalFormatFlagsException
              • java.util.IllegalFormatPrecisionException
              • java.util.IllegalFormatWidthException
              • java.util.MissingFormatArgumentException
              • java.util.MissingFormatWidthException
              • java.util.UnknownFormatConversionException
              • java.util.UnknownFormatFlagsException
          • java.lang.IllegalStateException
            • java.util.FormatterClosedException
          • java.util.MissingResourceException
          • java.util.NoSuchElementException
            • java.util.InputMismatchException
        • java.util.TooManyListenersException
    • java.util.Timer
    • java.util.TimerTask (implements java.lang.Runnable)
    • java.util.TimeZone (implements java.lang.Cloneable, java.io.Serializable)
      • java.util.SimpleTimeZone
    • java.util.UUID (implements java.lang.Comparable<T>, java.io.Serializable)

接口分层结构

  • java.util.Comparator<T>
  • java.util.Enumeration<E>
  • java.util.EventListener
  • java.util.Formattable
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.List<E>
      • java.util.Queue<E>
        • java.util.Deque<E>
      • java.util.Set<E>
        • java.util.SortedSet<E>
          • java.util.NavigableSet<E>
  • java.util.Iterator<E>
    • java.util.ListIterator<E>
  • java.util.Map<K,V>
    • java.util.SortedMap<K,V>
      • java.util.NavigableMap<K,V>
  • java.util.Map.Entry<K,V>
  • java.util.Observer
  • java.util.RandomAccess

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.util.Formatter.BigDecimalLayoutForm
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util
的使用

使用 java.util 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.net | 为实现网络应用程序提供类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
java.util.spi | java.util 包中类的服务提供者类。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.activation |
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.namespace | XML 名称空间处理。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Iterator
对 collection 进行迭代的迭代器。
Locale
Locale 对象表示了特定的地理、政治和文化地区。

java.awt 使用的 java.util 中的类
Collection
Collection 层次结构 中的根接口。
EmptyStackException
该异常由 Stack 类中的方法抛出，以表明堆栈为空。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
List
有序的 collection（也称为序列）。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。
Map.Entry
映射项（键-值对）。
Properties
Properties 类表示了一个持久的属性集。
ResourceBundle
资源包包含特定于语言环境的对象。
Set
一个不包含重复元素的 collection。

java.awt.datatransfer 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。

java.awt.dnd 使用的 java.util 中的类
ArrayList
List 接口的大小可变数组的实现。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
TooManyListenersException
TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。

java.awt.event 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventListenerProxy
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。
EventObject
所有事件状态对象都将从其派生的根类。

java.awt.font 使用的 java.util 中的类
Map
将键映射到值的对象。

java.awt.im 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。

java.awt.im.spi 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。

java.awt.image 使用的 java.util 中的类
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
Vector
Vector 类可以实现可增长的对象数组。

java.awt.image.renderable 使用的 java.util 中的类
Vector
Vector 类可以实现可增长的对象数组。

java.beans 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventListenerProxy
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。
EventObject
所有事件状态对象都将从其派生的根类。

java.beans.beancontext 使用的 java.util 中的类
ArrayList
List 接口的大小可变数组的实现。
Collection
Collection 层次结构 中的根接口。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
HashMap
基于哈希表的 Map 接口的实现。
Iterator
对 collection 进行迭代的迭代器。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
TooManyListenersException
TooManyListenersException 异常用作 Java Event 模型的一部分来注释和实现多播 Event Source 的单播特例。

java.io 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Locale
Locale 对象表示了特定的地理、政治和文化地区。

java.lang 使用的 java.util 中的类
Comparator
强行对某个对象 collection 进行整体排序 的比较函数。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。
Properties
Properties 类表示了一个持久的属性集。

java.lang.management 使用的 java.util 中的类
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。

java.math 使用的 java.util 中的类
Random
此类的实例用于生成伪随机数流。

java.net 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。

java.nio.channels 使用的 java.util 中的类
Set
一个不包含重复元素的 collection。

java.nio.channels.spi 使用的 java.util 中的类
Set
一个不包含重复元素的 collection。

java.nio.charset 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Set
一个不包含重复元素的 collection。
SortedMap
进一步提供关于键的总体排序 的 Map。

java.nio.charset.spi 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。

java.rmi.activation 使用的 java.util 中的类
Properties
Properties 类表示了一个持久的属性集。

java.security 使用的 java.util 中的类
Collection
Collection 层次结构 中的根接口。
Date
类 Date 表示特定的瞬间，精确到毫秒。
Dictionary
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
Map.Entry
映射项（键-值对）。
Properties
Properties 类表示了一个持久的属性集。
Random
此类的实例用于生成伪随机数流。
Set
一个不包含重复元素的 collection。

java.security.acl 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。

java.security.cert 使用的 java.util 中的类
Collection
Collection 层次结构 中的根接口。
Date
类 Date 表示特定的瞬间，精确到毫秒。
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
Set
一个不包含重复元素的 collection。

java.sql 使用的 java.util 中的类
Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Date
类 Date 表示特定的瞬间，精确到毫秒。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Iterator
对 collection 进行迭代的迭代器。
Map
将键映射到值的对象。
Properties
Properties 类表示了一个持久的属性集。

java.text 使用的 java.util 中的类
Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Comparator
强行对某个对象 collection 进行整体排序 的比较函数。
Currency
表示货币。
Date
类 Date 表示特定的瞬间，精确到毫秒。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。
TimeZone
TimeZone 表示时区偏移量，也可以计算夏令时。

java.text.spi 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。

java.util 使用的 java.util 中的类
AbstractCollection
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractList
此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
AbstractMap
此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
AbstractQueue
此类提供某些 Queue 操作的骨干实现。
AbstractSequentialList
此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
AbstractSet
此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
ArrayDeque
Deque 接口的大小可变数组的实现。
ArrayList
List 接口的大小可变数组的实现。
BitSet
此类实现了一个按需增长的位向量。
Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Collection
Collection 层次结构 中的根接口。
Comparator
强行对某个对象 collection 进行整体排序 的比较函数。
Currency
表示货币。
Date
类 Date 表示特定的瞬间，精确到毫秒。
Deque
一个线性 collection，支持在两端插入和移除元素。
Dictionary
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EnumMap
与枚举类型键一起使用的专用 Map 实现。
EnumSet
与枚举类型一起使用的专用 Set 实现。
EventListener
所有事件侦听器接口必须扩展的标记接口。
Formatter
printf 风格的格式字符串的解释程序。
Formatter.BigDecimalLayoutForm
HashMap
基于哈希表的 Map 接口的实现。
HashSet
此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
IllegalFormatException
当格式字符串包含非法语法，或者包含与给定参数不兼容的格式说明符时，将抛出未经检查的异常。
InvalidPropertiesFormatException
当按照 Properties 规范，输入内容不符合属性集的正确 XML 文档类型，从而无法完成操作时，抛出此异常。
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
ListIterator
系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。
Map.Entry
映射项（键-值对）。
MissingResourceException
缺少资源时抛出此异常。
NavigableMap
扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。
NavigableSet
扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
NoSuchElementException
由 Enumeration 的 nextElement 方法抛出，表明枚举中没有更多的元素。
Observable
此类表示模型视图范例中的 observable 对象，或者说“数据”。
Observer
一个可在观察者要得到 observable 对象更改通知时可实现 Observer 接口的类。
PriorityQueue
一个基于优先级堆的无界优先级队列。
Properties
Properties 类表示了一个持久的属性集。
Queue
在处理元素前用于保存元素的 collection。
Random
此类的实例用于生成伪随机数流。
RandomAccess
List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。
ResourceBundle
资源包包含特定于语言环境的对象。
ResourceBundle.Control
ResourceBundle.Control 定义一个回调方法集，它在包加载进程中由 ResourceBundle.getBundle 工厂方法调用。
Scanner
一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。
ServiceLoader
一个简单的服务提供者加载设施。
Set
一个不包含重复元素的 collection。
SortedMap
进一步提供关于键的总体排序 的 Map。
SortedSet
进一步提供关于元素的总体排序 的 Set。
TimerTask
由 Timer 安排为一次执行或重复执行的任务。
TimeZone
TimeZone 表示时区偏移量，也可以计算夏令时。
UUID
表示通用唯一标识符 (UUID) 的类。
Vector
Vector 类可以实现可增长的对象数组。

java.util.concurrent 使用的 java.util 中的类
AbstractCollection
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractMap
此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
AbstractQueue
此类提供某些 Queue 操作的骨干实现。
AbstractSet
此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
Collection
Collection 层次结构 中的根接口。
Comparator
强行对某个对象 collection 进行整体排序 的比较函数。
Deque
一个线性 collection，支持在两端插入和移除元素。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
ListIterator
系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。
Map
将键映射到值的对象。
Map.Entry
映射项（键-值对）。
NavigableMap
扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。
NavigableSet
扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
Queue
在处理元素前用于保存元素的 collection。
RandomAccess
List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。
Set
一个不包含重复元素的 collection。
SortedMap
进一步提供关于键的总体排序 的 Map。
SortedSet
进一步提供关于元素的总体排序 的 Set。

java.util.concurrent.locks 使用的 java.util 中的类
Collection
Collection 层次结构 中的根接口。
Date
类 Date 表示特定的瞬间，精确到毫秒。

java.util.jar 使用的 java.util 中的类
Collection
Collection 层次结构 中的根接口。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Map
将键映射到值的对象。
Map.Entry
映射项（键-值对）。
Set
一个不包含重复元素的 collection。
SortedMap
进一步提供关于键的总体排序 的 Map。

java.util.logging 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
List
有序的 collection（也称为序列）。
ResourceBundle
资源包包含特定于语言环境的对象。

java.util.prefs 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。

java.util.spi 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。

java.util.zip 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。

javax.accessibility 使用的 java.util 中的类
ListResourceBundle
ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
ResourceBundle
资源包包含特定于语言环境的对象。
Vector
Vector 类可以实现可增长的对象数组。

javax.activation 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。

javax.annotation.processing 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。

javax.imageio 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Set
一个不包含重复元素的 collection。

javax.imageio.event 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。

javax.imageio.metadata 使用的 java.util 中的类
List
有序的 collection（也称为序列）。
Locale
Locale 对象表示了特定的地理、政治和文化地区。

javax.imageio.plugins.bmp 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。

javax.imageio.plugins.jpeg 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。

javax.imageio.spi 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。
Locale
Locale 对象表示了特定的地理、政治和文化地区。

javax.lang.model.element 使用的 java.util 中的类
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。

javax.lang.model.type 使用的 java.util 中的类
List
有序的 collection（也称为序列）。

javax.lang.model.util 使用的 java.util 中的类
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。

javax.management 使用的 java.util 中的类
AbstractCollection
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractList
此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
ArrayList
List 接口的大小可变数组的实现。
Collection
Collection 层次结构 中的根接口。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
RandomAccess
List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。
Set
一个不包含重复元素的 collection。
Vector
Vector 类可以实现可增长的对象数组。

javax.management.loading 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。

javax.management.monitor 使用的 java.util 中的类
EventObject
所有事件状态对象都将从其派生的根类。

javax.management.openmbean 使用的 java.util 中的类
Collection
Collection 层次结构 中的根接口。
Date
类 Date 表示特定的瞬间，精确到毫秒。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
Map.Entry
映射项（键-值对）。
Set
一个不包含重复元素的 collection。

javax.management.relation 使用的 java.util 中的类
AbstractCollection
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractList
此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
ArrayList
List 接口的大小可变数组的实现。
Collection
Collection 层次结构 中的根接口。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
RandomAccess
List 实现所使用的标记接口，用来表明其支持快速（通常是固定时间）随机访问。
Vector
Vector 类可以实现可增长的对象数组。

javax.management.remote 使用的 java.util 中的类
EventObject
所有事件状态对象都将从其派生的根类。
Map
将键映射到值的对象。

javax.management.remote.rmi 使用的 java.util 中的类
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。

javax.management.timer 使用的 java.util 中的类
Date
类 Date 表示特定的瞬间，精确到毫秒。
EventObject
所有事件状态对象都将从其派生的根类。
Vector
Vector 类可以实现可增长的对象数组。

javax.naming 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
Properties
Properties 类表示了一个持久的属性集。
Vector
Vector 类可以实现可增长的对象数组。

javax.naming.directory 使用的 java.util 中的类
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
Vector
Vector 类可以实现可增长的对象数组。

javax.naming.event 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。

javax.naming.ldap 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
List
有序的 collection（也称为序列）。

javax.naming.spi 使用的 java.util 中的类
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。

javax.net.ssl 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
List
有序的 collection（也称为序列）。

javax.print.attribute 使用的 java.util 中的类
Date
类 Date 表示特定的瞬间，精确到毫秒。
Locale
Locale 对象表示了特定的地理、政治和文化地区。

javax.print.attribute.standard 使用的 java.util 中的类
AbstractCollection
此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
AbstractMap
此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
AbstractSet
此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
Collection
Collection 层次结构 中的根接口。
Date
类 Date 表示特定的瞬间，精确到毫秒。
HashMap
基于哈希表的 Map 接口的实现。
HashSet
此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。

javax.print.event 使用的 java.util 中的类
EventObject
所有事件状态对象都将从其派生的根类。

javax.script 使用的 java.util 中的类
Collection
Collection 层次结构 中的根接口。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
Map.Entry
映射项（键-值对）。
Set
一个不包含重复元素的 collection。

javax.security.auth 使用的 java.util 中的类
Set
一个不包含重复元素的 collection。

javax.security.auth.callback 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。

javax.security.auth.kerberos 使用的 java.util 中的类
Date
类 Date 表示特定的瞬间，精确到毫秒。

javax.security.auth.login 使用的 java.util 中的类
Map
将键映射到值的对象。

javax.security.auth.spi 使用的 java.util 中的类
Map
将键映射到值的对象。

javax.security.auth.x500 使用的 java.util 中的类
Map
将键映射到值的对象。

javax.security.sasl 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Map
将键映射到值的对象。

javax.sound.midi 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。
Vector
Vector 类可以实现可增长的对象数组。

javax.sound.sampled 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Map
将键映射到值的对象。

javax.sql 使用的 java.util 中的类
Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Map
将键映射到值的对象。

javax.sql.rowset 使用的 java.util 中的类
Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Collection
Collection 层次结构 中的根接口。
Map
将键映射到值的对象。

javax.sql.rowset.serial 使用的 java.util 中的类
Map
将键映射到值的对象。
Vector
Vector 类可以实现可增长的对象数组。

javax.sql.rowset.spi 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。

javax.swing 使用的 java.util 中的类
Comparator
强行对某个对象 collection 进行整体排序 的比较函数。
Date
类 Date 表示特定的瞬间，精确到毫秒。
Dictionary
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
List
有序的 collection（也称为序列）。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.event 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。

javax.swing.plaf.basic 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.plaf.metal 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。

javax.swing.plaf.multi 使用的 java.util 中的类
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.table 使用的 java.util 中的类
Comparator
强行对某个对象 collection 进行整体排序 的比较函数。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.text 使用的 java.util 中的类
Dictionary
Dictionary 类是任何可将键映射到相应值的类（如 Hashtable）的抽象父类。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.text.html 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.text.html.parser 使用的 java.util 中的类
BitSet
此类实现了一个按需增长的位向量。
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.tree 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
EventListener
所有事件侦听器接口必须扩展的标记接口。
EventObject
所有事件状态对象都将从其派生的根类。
Vector
Vector 类可以实现可增长的对象数组。

javax.swing.undo 使用的 java.util 中的类
EventListener
所有事件侦听器接口必须扩展的标记接口。
Hashtable
此类实现一个哈希表，该哈希表将键映射到相应的值。
Vector
Vector 类可以实现可增长的对象数组。

javax.tools 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
Set
一个不包含重复元素的 collection。

javax.xml.bind 使用的 java.util 中的类
Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Map
将键映射到值的对象。

javax.xml.crypto 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。

javax.xml.crypto.dom 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。

javax.xml.crypto.dsig 使用的 java.util 中的类
List
有序的 collection（也称为序列）。

javax.xml.crypto.dsig.keyinfo 使用的 java.util 中的类
List
有序的 collection（也称为序列）。

javax.xml.crypto.dsig.spec 使用的 java.util 中的类
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。

javax.xml.datatype 使用的 java.util 中的类
Calendar
Calendar 类是一个抽象类，它为特定瞬间与一组诸如 YEAR、MONTH、DAY_OF_MONTH、HOUR 等 日历字段之间的转换提供了一些方法，并为操作日历字段（例如获得下星期的日期）提供了一些方法。
Date
类 Date 表示特定的瞬间，精确到毫秒。
GregorianCalendar
GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。
Locale
Locale 对象表示了特定的地理、政治和文化地区。
TimeZone
TimeZone 表示时区偏移量，也可以计算夏令时。

javax.xml.namespace 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。

javax.xml.soap 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。
Locale
Locale 对象表示了特定的地理、政治和文化地区。

javax.xml.stream 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。

javax.xml.stream.events 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。

javax.xml.stream.util 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。

javax.xml.transform 使用的 java.util 中的类
Properties
Properties 类表示了一个持久的属性集。

javax.xml.ws 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。

javax.xml.ws.handler 使用的 java.util 中的类
List
有序的 collection（也称为序列）。
Map
将键映射到值的对象。

javax.xml.ws.handler.soap 使用的 java.util 中的类
Map
将键映射到值的对象。
Set
一个不包含重复元素的 collection。

javax.xml.ws.soap 使用的 java.util 中的类
Set
一个不包含重复元素的 collection。

javax.xml.ws.spi 使用的 java.util 中的类
Iterator
对 collection 进行迭代的迭代器。

javax.xml.xpath 使用的 java.util 中的类
List
有序的 collection（也称为序列）。

org.omg.CORBA 使用的 java.util 中的类
Properties
Properties 类表示了一个持久的属性集。

org.xml.sax 使用的 java.util 中的类
Locale
Locale 对象表示了特定的地理、政治和文化地区。

org.xml.sax.helpers 使用的 java.util 中的类
Enumeration
实现 Enumeration 接口的对象，它生成一系列元素，一次生成一个。
Locale
Locale 对象表示了特定的地理、政治和文化地区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractExecutorService (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 AbstractExecutorService

java.lang.Object
    继承者  java.util.concurrent.AbstractExecutorService
所有已实现的接口：
Executor, ExecutorService
直接已知子类：
ThreadPoolExecutor
public abstract class AbstractExecutorService
extends Object
implements ExecutorService

提供 ExecutorService 执行方法的默认实现。此类使用 newTaskFor 返回的 RunnableFuture 实现 submit、invokeAny 和 invokeAll 方法，默认情况下，RunnableFuture 是此包中提供的 FutureTask 类。例如，submit(Runnable) 的实现创建了一个关联 RunnableFuture 类，该类将被执行并返回。子类可以重写 newTaskFor 方法，以返回 FutureTask 之外的 RunnableFuture 实现。

扩展示例。以下是一个类的简要介绍，该类定制 ThreadPoolExecutor 使用 CustomTask 类替代默认 FutureTask：

 public class CustomThreadPoolExecutor extends ThreadPoolExecutor {

   static class CustomTask<V> implements RunnableFuture<V> {...}

   protected <V> RunnableFuture<V> newTaskFor(Callable<V> c) {
       return new CustomTask<V>(c);
   }
   protected <V> RunnableFuture<V> newTaskFor(Runnable r, V v) {
       return new CustomTask<V>(r, v);
   }
   // ... add constructors, etc.
 }

从以下版本开始：
1.5

构造方法摘要
AbstractExecutorService()
方法摘要
<T> List<Future<T>>
invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
protected
<T> RunnableFuture<T>
newTaskFor(Callable<T> callable)
为给定可调用任务返回一个 RunnableFuture。
protected
<T> RunnableFuture<T>
newTaskFor(Runnable runnable, T value)
为给定可运行任务和默认值返回一个 RunnableFuture。
<T> Future<T>
submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
 Future<?> submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
<T> Future<T>
submit(Runnable task, T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.util.concurrent.ExecutorService 继承的方法
awaitTermination, isShutdown, isTerminated, shutdown, shutdownNow
从接口 java.util.concurrent.Executor 继承的方法
execute

构造方法详细信息

AbstractExecutorService

public AbstractExecutorService()
方法详细信息

newTaskFor

protected <T> RunnableFuture<T> newTaskFor(Runnable runnable,
                                           T value)
为给定可运行任务和默认值返回一个 RunnableFuture。

参数：
runnable - 将被包装的可运行任务
value - 用于所返回的将来任务的默认值
返回：
一个 RunnableFuture，在运行的时候，它将运行底层可运行任务，作为 Future 任务，它将生成给定值作为其结果，并为底层任务提供取消操作。
从以下版本开始：
1.6

newTaskFor

protected <T> RunnableFuture<T> newTaskFor(Callable<T> callable)
为给定可调用任务返回一个 RunnableFuture。

参数：
callable - 将包装的可调用任务
返回：
一个 RunnableFuture，在运行的时候，它将调用底层可调用任务，作为 Future 任务，它将生成可调用的结果作为其结果，并为底层任务提供取消操作。
从以下版本开始：
1.6

submit

public Future<?> submit(Runnable task)
从接口 ExecutorService 复制的描述
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。该 Future 的 get 方法在成功 完成时将会返回 null。

指定者：
接口 ExecutorService 中的 submit
参数：
task - 要提交的任务
返回：
表示任务等待完成的 Future

submit

public <T> Future<T> submit(Runnable task,
                            T result)
从接口 ExecutorService 复制的描述
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。该 Future 的 get 方法在成功完成时将会返回给定的结果。

指定者：
接口 ExecutorService 中的 submit
参数：
task - 要提交的任务
result - 返回的结果
返回：
表示任务等待完成的 Future

submit

public <T> Future<T> submit(Callable<T> task)
从接口 ExecutorService 复制的描述
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。该 Future 的 get 方法在成功完成时将会返回该任务的结果。

如果想立即阻塞任务的等待，则可以使用 result = exec.submit(aCallable).get(); 形式的构造。

注：Executors 类包括了一组方法，可以转换某些其他常见的类似于闭包的对象，例如，将 PrivilegedAction 转换为 Callable 形式，这样就可以提交它们了。

指定者：
接口 ExecutorService 中的 submit
参数：
task - 要提交的任务
返回：
表示任务等待完成的 Future

invokeAny

public <T> T invokeAny(Collection<? extends Callable<T>> tasks)
            throws InterruptedException,
                   ExecutionException
从接口 ExecutorService 复制的描述
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。一旦正常或异常返回后，则取消尚未完成的任务。如果此操作正在进行时修改了给定的 collection，则此方法的结果是不确定的。

指定者：
接口 ExecutorService 中的 invokeAny
参数：
tasks - 任务 collection
返回：
某个任务返回的结果
抛出：
InterruptedException - 如果等待时发生中断
ExecutionException - 如果没有任务成功完成

invokeAny

public <T> T invokeAny(Collection<? extends Callable<T>> tasks,
                       long timeout,
                       TimeUnit unit)
            throws InterruptedException,
                   ExecutionException,
                   TimeoutException
从接口 ExecutorService 复制的描述
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。一旦正常或异常返回后，则取消尚未完成的任务。如果此操作正在进行时修改了给定的 collection，则此方法的结果是不确定的。

指定者：
接口 ExecutorService 中的 invokeAny
参数：
tasks - 任务 collection
timeout - 最长等待时间
unit - timeout 参数的时间单位
返回：
某个任务返回的结果
抛出：
InterruptedException - 如果等待时发生中断
ExecutionException - 如果没有任务成功完成
TimeoutException - 如果在所有任务成功完成之前给定的超时期满

invokeAll

public <T> List<Future<T>> invokeAll(Collection<? extends Callable<T>> tasks)
                          throws InterruptedException
从接口 ExecutorService 复制的描述
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。返回列表的所有元素的 Future.isDone() 为 true。注意，可以正常地或通过抛出异常来终止已完成 任务。如果正在进行此操作时修改了给定的 collection，则此方法的结果是不确定的。

指定者：
接口 ExecutorService 中的 invokeAll
参数：
tasks - 任务 collection
返回：
表示任务的 Future 列表，列表顺序与给定任务列表的迭代器所生成的顺序相同，每个任务都已完成。
抛出：
InterruptedException - 如果等待时发生中断，在这种情况下取消尚未完成的任务。

invokeAll

public <T> List<Future<T>> invokeAll(Collection<? extends Callable<T>> tasks,
                                     long timeout,
                                     TimeUnit unit)
                          throws InterruptedException
从接口 ExecutorService 复制的描述
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。返回列表的所有元素的 Future.isDone() 为 true。一旦返回后，即取消尚未完成的任务。注意，可以正常地或通过抛出异常来终止已完成 任务。如果此操作正在进行时修改了给定的 collection，则此方法的结果是不确定的。

指定者：
接口 ExecutorService 中的 invokeAll
参数：
tasks - 任务 collection
timeout - 最长等待时间
unit - timeout 参数的时间单位
返回：
表示任务的 Future 列表，列表顺序与给定任务列表的迭代器所生成的顺序相同。如果操作未超时，则已完成所有任务。如果确实超时了，则某些任务尚未完成。
抛出：
InterruptedException - 如果等待时发生中断，在这种情况下取消尚未完成的任务
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ArrayBlockingQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ArrayBlockingQueue<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.concurrent.ArrayBlockingQueue<E>
类型参数：
E - 在此 collection 中保持的元素类型
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, BlockingQueue<E>, Queue<E>
public class ArrayBlockingQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable

一个由数组支持的有界阻塞队列。此队列按 FIFO（先进先出）原则对元素进行排序。队列的头部 是在队列中存在时间最长的元素。队列的尾部 是在队列中存在时间最短的元素。新元素插入到队列的尾部，队列获取操作则是从队列头部开始获得元素。

这是一个典型的“有界缓存区”，固定大小的数组在其中保持生产者插入的元素和使用者提取的元素。一旦创建了这样的缓存区，就不能再增加其容量。试图向已满队列中放入元素会导致操作受阻塞；试图从空队列中提取元素将导致类似阻塞。

此类支持对等待的生产者线程和使用者线程进行排序的可选公平策略。默认情况下，不保证是这种排序。然而，通过将公平性 (fairness) 设置为 true 而构造的队列允许按照 FIFO 顺序访问线程。公平性通常会降低吞吐量，但也减少了可变性和避免了“不平衡性”。

此类及其迭代器实现了 Collection 和 Iterator 接口的所有可选 方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ArrayBlockingQueue(int capacity)
创建一个带有给定的（固定）容量和默认访问策略的 ArrayBlockingQueue。
ArrayBlockingQueue(int capacity, boolean fair)
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue。
ArrayBlockingQueue(int capacity, boolean fair, Collection<? extends E> c)
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue，它最初包含给定 collection 的元素，并以 collection 迭代器的遍历顺序添加元素。
方法摘要
 boolean add(E e)
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则抛出 IllegalStateException。
 void clear()
自动移除此队列中的所有元素。
 boolean contains(Object o)
如果此队列包含指定的元素，则返回 true。
 int drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 Iterator<E> iterator()
返回在此队列中的元素上按适当顺序进行迭代的迭代器。
 boolean offer(E e)
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则返回 false。
 boolean offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。
 E peek()
获取但不移除此队列的头；如果此队列为空，则返回 null。
 E poll()
获取并移除此队列的头，如果此队列为空，则返回 null。
 E poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
 void put(E e)
将指定的元素插入此队列的尾部，如果该队列已满，则等待可用的空间。
 int remainingCapacity()
返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的其他元素数量。
 boolean remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。
 int size()
返回此队列中元素的数量。
 E take()
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
 Object[] toArray()
返回一个按适当顺序包含此队列中所有元素的数组。
<T> T[]
toArray(T[] a)
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
 String toString()
返回此 collection 的字符串表示形式。
从类 java.util.AbstractQueue 继承的方法
addAll, element, remove
从类 java.util.AbstractCollection 继承的方法
containsAll, isEmpty, removeAll, retainAll
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Queue 继承的方法
element, remove
从接口 java.util.Collection 继承的方法
addAll, containsAll, equals, hashCode, isEmpty, removeAll, retainAll

构造方法详细信息

ArrayBlockingQueue

public ArrayBlockingQueue(int capacity)
创建一个带有给定的（固定）容量和默认访问策略的 ArrayBlockingQueue。

参数：
capacity - 此队列的容量
抛出：
IllegalArgumentException - 如果 capacity 小于 1

ArrayBlockingQueue

public ArrayBlockingQueue(int capacity,
                          boolean fair)
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue。

参数：
capacity - 此队列的容量
fair - 如果为 true，则按照 FIFO 顺序访问插入或移除时受阻塞线程的队列；如果为 false，则访问顺序是不确定的。
抛出：
IllegalArgumentException - 如果 capacity 小于 1

ArrayBlockingQueue

public ArrayBlockingQueue(int capacity,
                          boolean fair,
                          Collection<? extends E> c)
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue，它最初包含给定 collection 的元素，并以 collection 迭代器的遍历顺序添加元素。

参数：
capacity - 此队列的容量
fair - 如果为 true，则按照 FIFO 顺序访问插入或移除时受阻塞线程的队列；如果为 false，则访问顺序是不确定的。
c - 最初要包含的元素的 collection
抛出：
IllegalArgumentException - 如果 capacity 小于 c.size()，或者小于 1
NullPointerException - 如果指定 collection 或任何其元素为 null
方法详细信息

add

public boolean add(E e)
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则抛出 IllegalStateException。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 BlockingQueue<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractQueue<E> 中的 add
参数：
e - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
IllegalStateException - 如果此队列已满
NullPointerException - 如果指定的元素为 null

offer

public boolean offer(E e)
将指定的元素插入到此队列的尾部（如果立即可行且不会超过该队列的容量），在成功时返回 true，如果此队列已满，则返回 false。此方法通常要优于 add(E) 方法，后者可能无法插入元素，而只是抛出一个异常。

指定者：
接口 BlockingQueue<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
如果该元素已添加到此队列，则返回 true；否则返回 false
抛出：
NullPointerException - 如果指定的元素为 null

put

public void put(E e)
         throws InterruptedException
将指定的元素插入此队列的尾部，如果该队列已满，则等待可用的空间。

指定者：
接口 BlockingQueue<E> 中的 put
参数：
e - 要添加的元素
抛出：
InterruptedException - 如果在等待时被中断
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。

指定者：
接口 BlockingQueue<E> 中的 offer
参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true；如果在空间可用前超过了指定的等待时间，则返回 false
抛出：
InterruptedException - 如果在等待时被中断
NullPointerException - 如果指定元素为 null

poll

public E poll()
从接口 Queue 复制的描述
获取并移除此队列的头，如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 poll
返回：
队列的头，如果此队列为空，则返回 null

take

public E take()
       throws InterruptedException
从接口 BlockingQueue 复制的描述
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。

指定者：
接口 BlockingQueue<E> 中的 take
返回：
此队列的头部
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll(long timeout,
              TimeUnit unit)
       throws InterruptedException
从接口 BlockingQueue 复制的描述
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。

指定者：
接口 BlockingQueue<E> 中的 poll
参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此队列的头部；如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

peek

public E peek()
从接口 Queue 复制的描述
获取但不移除此队列的头；如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 peek
返回：
此队列的头；如果此队列为空，则返回 null

size

public int size()
返回此队列中元素的数量。

指定者：
接口 Collection<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
返回此队列中元素的数量

remainingCapacity

public int remainingCapacity()
返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的其他元素数量。它总是等于此队列初始容量，但小于此队列当前的 size。

注意，不能 总是通过检查 remainingCapacity 来判断尝试插入元素能否成功，因为可能出现这样的情况：另一个线程将插入或移除一个元素。

指定者：
接口 BlockingQueue<E> 中的 remainingCapacity
返回：
剩余容量

remove

public boolean remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。更确切地讲，如果此队列包含一个或多个满足 o.equals(e) 的元素 e，则移除该元素。如果此队列包含指定的元素（或者此队列由于调用而发生更改），则返回 true。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 BlockingQueue<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此队列中移除的元素（如果存在）
返回：
如果此队列由于调用而发生更改，则返回 true

contains

public boolean contains(Object o)
如果此队列包含指定的元素，则返回 true。更确切地讲，当且仅当此队列至少包含一个满足 o.equals(e) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 BlockingQueue<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 检查是否包含在此队列中的对象
返回：
如果此队列包含指定的元素，则返回 true

toArray

public Object[] toArray()
返回一个按适当顺序包含此队列中所有元素的数组。

由于此队列不维护对返回数组的任何引用，因而它是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此队列所有元素的数组

toArray

public <T> T[] toArray(T[] a)
返回一个按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。如果指定的数组能容纳该队列，则将该队列返回此处。否则，将分配一个具有指定数组的运行时类型和此队列大小的新数组。

如果指定的数组能容纳此队列，并有剩余空间（即数组的元素比此队列的多），则将数组中紧接队列末尾的元素设置为 null。

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步地说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知队列。以下代码用来将该队列转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 要在其中存储队列元素的数组（如果它足够大）；否则，将为此分配一个具有相同运行时类型的新数组。
返回：
包含此队列中所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

toString

public String toString()
从类 AbstractCollection 复制的描述
返回此 collection 的字符串表示形式。该字符串表示形式由 collection 元素的列表组成，这些元素按其迭代器返回的顺序排列，并用方括号 ("[]") 括起来。相邻元素由字符 ", "（逗号加空格）分隔。通过 String.valueOf(Object) 可以将元素转换成字符串。

覆盖：
类 AbstractCollection<E> 中的 toString
返回：
此 collection 的字符串表示形式

clear

public void clear()
自动移除此队列中的所有元素。在此调用返回之后，队列将为空。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractQueue<E> 中的 clear

drainTo

public int drainTo(Collection<? super E> c)
从接口 BlockingQueue 复制的描述
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。此操作可能比反复轮询此队列更有效。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

drainTo

public int drainTo(Collection<? super E> c,
                   int maxElements)
从接口 BlockingQueue 复制的描述
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
maxElements - 传输元素的最大数量
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

iterator

public Iterator<E> iterator()
返回在此队列中的元素上按适当顺序进行迭代的迭代器。返回的 Iterator 是一个“弱一致”的迭代器，从不抛出 ConcurrentModificationException，并且确保可遍历迭代器构造时存在的元素，此外还可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在队列中的元素上按适当顺序进行迭代的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BlockingDeque (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 BlockingDeque<E>

类型参数：
E - 保存在此 collection 中的元素类型
所有超级接口：
BlockingQueue<E>, Collection<E>, Deque<E>, Iterable<E>, Queue<E>
所有已知实现类：
LinkedBlockingDeque
public interface BlockingDeque<E>
extends BlockingQueue<E>, Deque<E>

支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。

BlockingDeque 方法有四种形式，使用不同的方式处理无法立即满足但在将来某一时刻可能满足的操作：第一种方式抛出异常；第二种返回一个特殊值（null 或 false，具体取决于操作）；第三种无限期阻塞当前线程，直至操作成功；第四种只阻塞给定的最大时间，然后放弃。下表中总结了这些方法：

第一个元素（头部）
 | 抛出异常 | 特殊值 | 阻塞 | 超时期
插入 | addFirst(e) | offerFirst(e) | putFirst(e) | offerFirst(e, time, unit)
移除 | removeFirst() | pollFirst() | takeFirst() | pollFirst(time, unit)
检查 | getFirst() | peekFirst() | 不适用 | 不适用
最后一个元素（尾部）
 | 抛出异常 | 特殊值 | 阻塞 | 超时期
插入 | addLast(e) | offerLast(e) | putLast(e) | offerLast(e, time, unit)
移除 | removeLast() | pollLast() | takeLast() | pollLast(time, unit)
检查 | getLast() | peekLast() | 不适用 | 不适用

像所有 BlockingQueue 一样，BlockingDeque 是线程安全的，但不允许 null 元素，并且可能有（也可能没有）容量限制。

BlockingDeque 实现可以直接用作 FIFO BlockingQueue。继承自 BlockingQueue 接口的方法精确地等效于下表中描述的 BlockingDeque 方法：

BlockingQueue 方法 | 等效的 BlockingDeque 方法
插入
add(e) | addLast(e)
offer(e) | offerLast(e)
put(e) | putLast(e)
offer(e, time, unit) | offerLast(e, time, unit)
移除
remove() | removeFirst()
poll() | pollFirst()
take() | takeFirst()
poll(time, unit) | pollFirst(time, unit)
检查
element() | getFirst()
peek() | peekFirst()

内存一致性效果：当存在其他并发 collection 时，将对象放入 BlockingDeque 之前的线程中的操作 happen-before 随后通过另一线程从 BlockingDeque 中访问或移除该元素的操作。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.6

方法摘要
boolean | add(E e) Inserts the 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则抛出 IllegalStateException。
void | addFirst(E e) 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头；如果当前没有空间可用，则抛出 IllegalStateException。
void | addLast(E e) 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾；如果当前没有空间可用，则抛出 IllegalStateException。
boolean | contains(Object o) 如果此双端队列包含指定的元素，则返回 true。
E | element() 获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。
Iterator<E> | iterator() 返回在此双端队列中的元素上以恰当顺序进行迭代的迭代器。
boolean | offer(E e) 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则返回 false。
boolean | offer(E e, long timeout, TimeUnit unit) 将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
boolean | offerFirst(E e) 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头，并在成功时返回 true；如果当前没有空间可用，则返回 false。
boolean | offerFirst(E e, long timeout, TimeUnit unit) 将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
boolean | offerLast(E e) 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾，并在成功时返回 true；如果当前没有空间可用，则返回 false。
boolean | offerLast(E e, long timeout, TimeUnit unit) 将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
E | peek() 获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
E | poll() 获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
E | poll(long timeout, TimeUnit unit) 获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
E | pollFirst(long timeout, TimeUnit unit) 获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
E | pollLast(long timeout, TimeUnit unit) 获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
void | push(E e) 将元素推入此双端队列表示的栈。
void | put(E e) 将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。
void | putFirst(E e) 将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。
void | putLast(E e) 将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。
E | remove() 获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。
boolean | remove(Object o) 从此双端队列移除第一次出现的指定元素。
boolean | removeFirstOccurrence(Object o) 从此双端队列移除第一次出现的指定元素。
boolean | removeLastOccurrence(Object o) 从此双端队列移除最后一次出现的指定元素。
int | size() 返回此双端队列中的元素数。
E | take() 获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。
E | takeFirst() 获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。
E | takeLast() 获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。
从接口 java.util.concurrent.BlockingQueue 继承的方法
drainTo, drainTo, remainingCapacity
从接口 java.util.Deque 继承的方法
descendingIterator, getFirst, getLast, peekFirst, peekLast, pollFirst, pollLast, pop, removeFirst, removeLast
从接口 java.util.Collection 继承的方法
addAll, clear, containsAll, equals, hashCode, isEmpty, removeAll, retainAll, toArray, toArray

方法详细信息

addFirst

void addFirst(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头；如果当前没有空间可用，则抛出 IllegalStateException。当使用有容量限制的双端队列时，通常首选 offerFirst。

指定者：
接口 Deque<E> 中的 addFirst
参数：
e - 要添加的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
ClassCastException - 如果指定元素的类不允许将它添加此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

addLast

void addLast(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾；如果当前没有空间可用，则抛出 IllegalStateException。当使用有容量限制的双端队列时，通常首选 offerLast。

指定者：
接口 Deque<E> 中的 addLast
参数：
e - 要添加的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
ClassCastException - 如果指定元素的类不允许将它添加此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

offerFirst

boolean offerFirst(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头，并在成功时返回 true；如果当前没有空间可用，则返回 false。当使用有容量限制的双端队列时，此方法通常优于 addFirst 方法，后者可能无法插入元素，而只是抛出一个异常。

指定者：
接口 Deque<E> 中的 offerFirst
参数：
e - 要添加的元素
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许将它添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

offerLast

boolean offerLast(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾，并在成功时返回 true；如果当前没有空间可用，则返回 false。当使用有容量限制的双端队列时，该方法通常优于 addLast 方法，后者可能无法插入元素，而只是抛出一个异常。

指定者：
接口 Deque<E> 中的 offerLast
参数：
e - 要添加的元素
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许将它添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列

putFirst

void putFirst(E e)
              throws InterruptedException
将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。

参数：
e - 要添加的元素
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

putLast

void putLast(E e)
             throws InterruptedException
将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。

参数：
e - 要添加的元素
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

offerFirst

boolean offerFirst(E e,
                   long timeout,
                   TimeUnit unit)
                   throws InterruptedException
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。

参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true；如果在空间可用前超过了指定的等待时间，则返回 false
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

offerLast

boolean offerLast(E e,
                  long timeout,
                  TimeUnit unit)
                  throws InterruptedException
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。

参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true；如果在空间可用前超过了指定的等待时间，则返回 false
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

takeFirst

E takeFirst()
            throws InterruptedException
获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。

返回：
此双端队列的头部
抛出：
InterruptedException - 如果在等待时被中断

takeLast

E takeLast()
           throws InterruptedException
获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。

返回：
此双端队列的尾部
抛出：
InterruptedException - 如果在等待时被中断

pollFirst

E pollFirst(long timeout,
            TimeUnit unit)
            throws InterruptedException
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。

参数：
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此双端队列的头部，如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

pollLast

E pollLast(long timeout,
           TimeUnit unit)
           throws InterruptedException
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。

参数：
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此双端队列的尾部，如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

removeFirstOccurrence

boolean removeFirstOccurrence(Object o)
从此双端队列移除第一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

指定者：
接口 Deque<E> 中的 removeFirstOccurrence
参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果由于此调用而移除了一个元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此双端队列不兼容（可选）
NullPointerException - 如果指定的元素为 null（可选）

removeLastOccurrence

boolean removeLastOccurrence(Object o)
从此双端队列移除最后一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除最后一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

指定者：
接口 Deque<E> 中的 removeLastOccurrence
参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果由于此调用而移除了一个元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此双端队列不兼容（可选）
NullPointerException - 如果指定的元素为 null（可选）

add

boolean add(E e)
Inserts the 如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则抛出 IllegalStateException。当使用有容量限制的双端队列时，通常首选 offer。

此方法等效于 addLast。

指定者：
接口 BlockingQueue<E> 中的 add
指定者：
接口 Collection<E> 中的 add
指定者：
接口 Deque<E> 中的 add
指定者：
接口 Queue<E> 中的 add
参数：
e - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
IllegalStateException - 如果由于容量限制此时不能添加该元素
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

offer

boolean offer(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则返回 false。当使用有容量限制的双端队列时，此方法通常优于 add(E) 方法，后者可能无法插入元素，而只是抛出一个异常。

此方法等效于 offerLast。

指定者：
接口 BlockingQueue<E> 中的 offer
指定者：
接口 Deque<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
如果该元素已添加到此队列，则返回 true；否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

put

void put(E e)
         throws InterruptedException
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。

此方法等效于 putLast。

指定者：
接口 BlockingQueue<E> 中的 put
参数：
e - 要添加的元素
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

offer

boolean offer(E e,
              long timeout,
              TimeUnit unit)
              throws InterruptedException
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。

此方法等效于 offerLast。

指定者：
接口 BlockingQueue<E> 中的 offer
参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许它被添加到此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某个属性不允许它被添加到此双端队列

remove

E remove()
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。此方法与 poll 的不同之处在于：如果此双端队列为空，它会抛出一个异常。

此方法等效于 removeFirst。

指定者：
接口 Deque<E> 中的 remove
指定者：
接口 Queue<E> 中的 remove
返回：
此双端队列表示的队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

poll

E poll()
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。

此方法等效于 Deque.pollFirst()。

指定者：
接口 Deque<E> 中的 poll
指定者：
接口 Queue<E> 中的 poll
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

take

E take()
       throws InterruptedException
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。

此方法等效于 takeFirst。

指定者：
接口 BlockingQueue<E> 中的 take
返回：
此双端队列的头部
抛出：
InterruptedException - 如果在等待时被中断

poll

E poll(long timeout,
       TimeUnit unit)
       throws InterruptedException
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。

此方法等效于 pollFirst。

指定者：
接口 BlockingQueue<E> 中的 poll
参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此双端队列的头部；如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

element

E element()
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）。此方法与 peek 的不同之处在于：如果此双端队列为空，它会抛出一个异常。

此方法等效于 getFirst。

指定者：
接口 Deque<E> 中的 element
指定者：
接口 Queue<E> 中的 element
返回：
此双端队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

peek

E peek()
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。

此方法等效于 peekFirst。

指定者：
接口 Deque<E> 中的 peek
指定者：
接口 Queue<E> 中的 peek
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

remove

boolean remove(Object o)
从此双端队列移除第一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

此方法等效于 removeFirstOccurrence。

指定者：
接口 BlockingQueue<E> 中的 remove
指定者：
接口 Collection<E> 中的 remove
指定者：
接口 Deque<E> 中的 remove
参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果此双端队列由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此双端队列不兼容（可选）
NullPointerException - 如果指定的元素为 null（可选）

contains

boolean contains(Object o)
如果此双端队列包含指定的元素，则返回 true。更确切地讲，当且仅当此双端队列至少包含一个满足 o.equals(e) 的元素 e，返回 true。

指定者：
接口 BlockingQueue<E> 中的 contains
指定者：
接口 Collection<E> 中的 contains
指定者：
接口 Deque<E> 中的 contains
参数：
o - 检查是否包含在此双端队列中的对象
返回：
如果此双端队列包含指定的元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此双端队列不兼容（可选）
NullPointerException - 如果指定的元素为 null（可选）

size

int size()
返回此双端队列中的元素数。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 Deque<E> 中的 size
返回：
此双端队列中的元素数

iterator

Iterator<E> iterator()
返回在此双端队列中的元素上以恰当顺序进行迭代的迭代器。元素将按从第一个（头部）到最后一个（尾部）的顺序返回。

指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Deque<E> 中的 iterator
指定者：
接口 Iterable<E> 中的 iterator
返回：
按恰当顺序在此双端队列中的元素上进行迭代的迭代器

push

void push(E e)
将元素推入此双端队列表示的栈。换句话说，在不违反容量限制的情况下，将元素插入双端队列的开头。

此方法等效于 addFirst。

指定者：
接口 Deque<E> 中的 push
参数：
e - 要推入的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
ClassCastException - 如果指定元素的类不允许将它添加此双端队列
NullPointerException - 如果指定的元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将它添加到此双端队列
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BlockingQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 BlockingQueue<E>

类型参数：
E - 在此 collection 中保持的元素类型
所有超级接口：
Collection<E>, Iterable<E>, Queue<E>
所有已知子接口：
BlockingDeque<E>
所有已知实现类：
ArrayBlockingQueue, DelayQueue, LinkedBlockingDeque, LinkedBlockingQueue, PriorityBlockingQueue, SynchronousQueue
public interface BlockingQueue<E>
extends Queue<E>

支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。

BlockingQueue 方法以四种形式出现，对于不能立即满足但可能在将来某一时刻可以满足的操作，这四种形式的处理方式不同：第一种是抛出一个异常，第二种是返回一个特殊值（null 或 false，具体取决于操作），第三种是在操作可以成功前，无限期地阻塞当前线程，第四种是在放弃前只在给定的最大时间限制内阻塞。下表中总结了这些方法：

 | 抛出异常 | 特殊值 | 阻塞 | 超时
插入 | add(e) | offer(e) | put(e) | offer(e, time, unit)
移除 | remove() | poll() | take() | poll(time, unit)
检查 | element() | peek() | 不可用 | 不可用

BlockingQueue 不接受 null 元素。试图 add、put 或 offer 一个 null 元素时，某些实现会抛出 NullPointerException。null 被用作指示 poll 操作失败的警戒值。

BlockingQueue 可以是限定容量的。它在任意给定时间都可以有一个 remainingCapacity，超出此容量，便无法无阻塞地 put 附加元素。没有任何内部容量约束的 BlockingQueue 总是报告 Integer.MAX_VALUE 的剩余容量。

BlockingQueue 实现主要用于生产者-使用者队列，但它另外还支持 Collection 接口。因此，举例来说，使用 remove(x) 从队列中移除任意一个元素是有可能的。然而，这种操作通常不 会有效执行，只能有计划地偶尔使用，比如在取消排队信息时。

BlockingQueue 实现是线程安全的。所有排队方法都可以使用内部锁或其他形式的并发控制来自动达到它们的目的。然而，大量的 Collection 操作（addAll、containsAll、retainAll 和 removeAll）没有 必要自动执行，除非在实现中特别说明。因此，举例来说，在只添加了 c 中的一些元素后，addAll(c) 有可能失败（抛出一个异常）。

BlockingQueue 实质上不 支持使用任何一种“close”或“shutdown”操作来指示不再添加任何项。这种功能的需求和使用有依赖于实现的倾向。例如，一种常用的策略是：对于生产者，插入特殊的 end-of-stream 或 poison 对象，并根据使用者获取这些对象的时间来对它们进行解释。

以下是基于典型的生产者-使用者场景的一个用例。注意，BlockingQueue 可以安全地与多个生产者和多个使用者一起使用。

 class Producer implements Runnable {
   private final BlockingQueue queue;
   Producer(BlockingQueue q) { queue = q; }
   public void run() {
     try {
       while(true) { queue.put(produce()); }
     } catch (InterruptedException ex) { ... handle ...}
   }
   Object produce() { ... }
 }

 class Consumer implements Runnable {
   private final BlockingQueue queue;
   Consumer(BlockingQueue q) { queue = q; }
   public void run() {
     try {
       while(true) { consume(queue.take()); }
     } catch (InterruptedException ex) { ... handle ...}
   }
   void consume(Object x) { ... }
 }

 class Setup {
   void main() {
     BlockingQueue q = new SomeQueueImplementation();
     Producer p = new Producer(q);
     Consumer c1 = new Consumer(q);
     Consumer c2 = new Consumer(q);
     new Thread(p).start();
     new Thread(c1).start();
     new Thread(c2).start();
   }
 }

内存一致性效果：当存在其他并发 collection 时，将对象放入 BlockingQueue 之前的线程中的操作 happen-before 随后通过另一线程从 BlockingQueue 中访问或移除该元素的操作。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.5

方法摘要
boolean | add(E e) 将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。
boolean | contains(Object o) 如果此队列包含指定元素，则返回 true。
int | drainTo(Collection<? super E> c) 移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
int | drainTo(Collection<? super E> c, int maxElements) 最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
boolean | offer(E e) 将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则返回 false。
boolean | offer(E e, long timeout, TimeUnit unit) 将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。
E | poll(long timeout, TimeUnit unit) 获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
void | put(E e) 将指定元素插入此队列中，将等待可用的空间（如果有必要）。
int | remainingCapacity() 返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的附加元素数量；如果没有内部限制，则返回 Integer.MAX_VALUE。
boolean | remove(Object o) 从此队列中移除指定元素的单个实例（如果存在）。
E | take() 获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
从接口 java.util.Queue 继承的方法
element, peek, poll, remove
从接口 java.util.Collection 继承的方法
addAll, clear, containsAll, equals, hashCode, isEmpty, iterator, removeAll, retainAll, size, toArray, toArray

方法详细信息

add

boolean add(E e)
将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则抛出 IllegalStateException。当使用有容量限制的队列时，通常首选 offer。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Queue<E> 中的 add
参数：
e - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
IllegalStateException - 如果由于容量限制此时不能添加该元素
ClassCastException - 如果指定元素的类不允许将其添加到此队列
NullPointerException - 如果指定元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将其添加到此队列

offer

boolean offer(E e)
将指定元素插入此队列中（如果立即可行且不会违反容量限制），成功时返回 true，如果当前没有可用的空间，则返回 false。当使用有容量限制的队列时，此方法通常要优于 add(E)，后者可能无法插入元素，而只是抛出一个异常。

指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
如果该元素已添加到此队列，则返回 true；否则返回 false
抛出：
ClassCastException - 如果指定元素的类不允许将其添加到此队列
NullPointerException - 如果指定元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将其添加到此队列

put

void put(E e)
         throws InterruptedException
将指定元素插入此队列中，将等待可用的空间（如果有必要）。

参数：
e - 要添加的元素
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许将其添加到此队列
NullPointerException - 如果指定元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将其添加到此队列

offer

boolean offer(E e,
              long timeout,
              TimeUnit unit)
              throws InterruptedException
将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。

参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true；如果在空间可用前超过了指定的等待时间，则返回 false
抛出：
InterruptedException - 如果在等待时被中断
ClassCastException - 如果指定元素的类不允许将其添加到此队列
NullPointerException - 如果指定元素为 null
IllegalArgumentException - 如果指定元素的某些属性不允许将其添加到此队列

take

E take()
       throws InterruptedException
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。

返回：
此队列的头部
抛出：
InterruptedException - 如果在等待时被中断

poll

E poll(long timeout,
       TimeUnit unit)
       throws InterruptedException
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。

参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此队列的头部；如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

remainingCapacity

int remainingCapacity()
返回在无阻塞的理想情况下（不存在内存或资源约束）此队列能接受的附加元素数量；如果没有内部限制，则返回 Integer.MAX_VALUE。

注意，不能 总是通过检查 remainingCapacity 来判断尝试插入元素是否成功，因为可能出现这样的情况：其他线程即将插入或移除一个元素。

返回：
剩余容量

remove

boolean remove(Object o)
从此队列中移除指定元素的单个实例（如果存在）。更确切地讲，如果此队列包含一个或多个满足 o.equals(e) 的元素 e，则移除该元素。如果此队列包含指定元素（或者此队列由于调用而发生更改），则返回 true。

指定者：
接口 Collection<E> 中的 remove
参数：
o - 要从此队列移除的元素（如果存在）
返回：
如果此队列由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此队列不兼容（可选）
NullPointerException - 如果指定元素为 null（可选）

contains

boolean contains(Object o)
如果此队列包含指定元素，则返回 true。更确切地讲，当且仅当此队列至少包含一个满足 o.equals(e) 的元素 e时，返回 true。

指定者：
接口 Collection<E> 中的 contains
参数：
o - 检查是否包含在此队列中的对象
返回：
如果此队列包含指定元素，则返回 true
抛出：
ClassCastException - 如果指定元素的类与此队列不兼容（可选）
NullPointerException - 如果指定元素为 null（可选）

drainTo

int drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。此操作可能比反复轮询此队列更有效。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

参数：
c - 接收传输元素的 collection
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

drainTo

int drainTo(Collection<? super E> c,
            int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

参数：
c - 接收传输元素的 collection
maxElements - 传输元素的最大数量
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BrokenBarrierException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 BrokenBarrierException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.util.concurrent.BrokenBarrierException
所有已实现的接口：
Serializable
public class BrokenBarrierException
extends Exception

当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。

从以下版本开始：
1.5
另请参见：
CyclicBarrier, 序列化表格

构造方法摘要
BrokenBarrierException()
构造不带指定详细消息的 BrokenBarrierException。
BrokenBarrierException(String message)
构造带指定详细消息的 BrokenBarrierException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BrokenBarrierException

public BrokenBarrierException()
构造不带指定详细消息的 BrokenBarrierException。

BrokenBarrierException

public BrokenBarrierException(String message)
构造带指定详细消息的 BrokenBarrierException。

参数：
message - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Callable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 Callable<V>

类型参数：
V - call 方法的结果类型
所有已知子接口：
JavaCompiler.CompilationTask
public interface Callable<V>

返回结果并且可能抛出异常的任务。实现者定义了一个不带任何参数的叫做 call 的方法。

Callable 接口类似于 Runnable，两者都是为那些其实例可能被另一个线程执行的类设计的。但是 Runnable 不会返回结果，并且无法抛出经过检查的异常。

Executors 类包含一些从其他普通形式转换成 Callable 类的实用方法。

从以下版本开始：
1.5
另请参见：
Executor

方法摘要
 V call()
计算结果，如果无法计算结果，则抛出一个异常。

方法详细信息

call

V call()
       throws Exception
计算结果，如果无法计算结果，则抛出一个异常。

返回：
计算的结果
抛出：
Exception - 如果无法计算结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CancellationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 CancellationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalStateException
                    继承者  java.util.concurrent.CancellationException
所有已实现的接口：
Serializable
public class CancellationException
extends IllegalStateException

如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
CancellationException()
构造不带详细消息的 CancellationException。
CancellationException(String message)
构造带指定详细消息的 CancellationException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CancellationException

public CancellationException()
构造不带详细消息的 CancellationException。

CancellationException

public CancellationException(String message)
构造带指定详细消息的 CancellationException。

参数：
message - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompletionService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 CompletionService<V>

所有已知实现类：
ExecutorCompletionService
public interface CompletionService<V>

将生产新的异步任务与使用已完成任务的结果分离开来的服务。生产者 submit 执行的任务。使用者 take 已完成的任务，并按照完成这些任务的顺序处理它们的结果。例如，CompletionService 可以用来管理异步 IO ，执行读操作的任务作为程序或系统的一部分提交，然后，当完成读操作时，会在程序的不同部分执行其他操作，执行操作的顺序可能与所请求的顺序不同。

通常，CompletionService 依赖于一个单独的 Executor 来实际执行任务，在这种情况下，CompletionService 只管理一个内部完成队列。ExecutorCompletionService 类提供了此方法的一个实现。

内存一致性效果：线程中向 CompletionService 提交任务之前的操作 happen-before 该任务执行的操作，后者依次 happen-before 紧跟在从对应 take() 成功返回的操作。

方法摘要
Future<V> | poll() 获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。
Future<V> | poll(long timeout, TimeUnit unit) 获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
Future<V> | submit(Callable<V> task) 提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
Future<V> | submit(Runnable task, V result) 提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
Future<V> | take() 获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。

方法详细信息

submit

Future<V> submit(Callable<V> task)
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。在完成时，可能会提取或轮询此任务。

参数：
task - 要提交的任务
返回：
一个表示挂起的任务完成的 Future
抛出：
RejectedExecutionException - 如果不能安排要执行的任务
NullPointerException - 如果该任务为 null

submit

Future<V> submit(Runnable task,
                 V result)
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。

参数：
task - 要提交的任务
result - 要返回的已成功完成任务的结果
返回：
一个表示挂起的任务完成的 Future，其 get() 方法将返回完成时给出的结果值
抛出：
RejectedExecutionException - 如果不能安排要执行的任务
NullPointerException - 如果该任务为 null

take

Future<V> take()
               throws InterruptedException
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。

返回：
表示下一个已完成任务的 Future
抛出：
InterruptedException - 如果在等待时被中断

poll

Future<V> poll()
获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。

返回：
表示下一个已完成任务的 Future；如果不存在这样的任务，则返回 null

poll

Future<V> poll(long timeout,
               TimeUnit unit)
               throws InterruptedException
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。

参数：
timeout - 放弃之前需要等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
表示下一个已完成任务的 Future；如果等待了指定时间仍然不存在这样的任务，则返回 null
抛出：
InterruptedException - 如果在等待时被中断
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConcurrentHashMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ConcurrentHashMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.concurrent.ConcurrentHashMap<K,V>
类型参数：
K - 此映射维护的键的类型
V - 映射值的类
所有已实现的接口：
Serializable, ConcurrentMap<K,V>, Map<K,V>
public class ConcurrentHashMap<K,V>
extends AbstractMap<K,V>
implements ConcurrentMap<K,V>, Serializable

支持获取的完全并发和更新的所期望可调整并发的哈希表。此类遵守与 Hashtable 相同的功能规范，并且包括对应于 Hashtable 的每个方法的方法版本。不过，尽管所有操作都是线程安全的，但获取操作不 必锁定，并且不 支持以某种防止所有访问的方式锁定整个表。此类可以通过程序完全与 Hashtable 进行互操作，这取决于其线程安全，而与其同步细节无关。

获取操作（包括 get）通常不会受阻塞，因此，可能与更新操作交迭（包括 put 和 remove）。获取会影响最近完成的 更新操作的结果。对于一些聚合操作，比如 putAll 和 clear，并发获取可能只影响某些条目的插入和移除。类似地，在创建迭代器/枚举时或自此之后，Iterators 和 Enumerations 返回在某一时间点上影响哈希表状态的元素。它们不会 抛出 ConcurrentModificationException。不过，迭代器被设计成每次仅由一个线程使用。

这允许通过可选的 concurrencyLevel 构造方法参数（默认值为 16）来引导更新操作之间的并发，该参数用作内部调整大小的一个提示。表是在内部进行分区的，试图允许指示无争用并发更新的数量。因为哈希表中的位置基本上是随意的，所以实际的并发将各不相同。理想情况下，应该选择一个尽可能多地容纳并发修改该表的线程的值。使用一个比所需要的值高很多的值可能会浪费空间和时间，而使用一个显然低很多的值可能导致线程争用。对数量级估计过高或估计过低通常都会带来非常显著的影响。当仅有一个线程将执行修改操作，而其他所有线程都只是执行读取操作时，才认为某个值是合适的。此外，重新调整此类或其他任何种类哈希表的大小都是一个相对较慢的操作，因此，在可能的时候，提供构造方法中期望表大小的估计值是一个好主意。

此类及其视图和迭代器实现了 Map 和 Iterator 接口的所有可选 方法。

此类与 Hashtable 相似，但与 HashMap 不同，它不 允许将 null 用作键或值。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
构造方法摘要
ConcurrentHashMap()
创建一个带有默认初始容量 (16)、加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap(int initialCapacity)
创建一个带有指定初始容量、默认加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap(int initialCapacity, float loadFactor)
创建一个带有指定初始容量、加载因子和默认 concurrencyLevel (16) 的新的空映射。
ConcurrentHashMap(int initialCapacity, float loadFactor, int concurrencyLevel)
创建一个带有指定初始容量、加载因子和并发级别的新的空映射。
ConcurrentHashMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新映射。
方法摘要
void | clear() 从该映射中移除所有映射关系
boolean | contains(Object value) 一种遗留方法，测试此表中是否有一些与指定值存在映射关系的键。
boolean | containsKey(Object key) 测试指定对象是否为此表中的键。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
Enumeration<V> | elements() 返回此表中值的枚举。
Set<Map.Entry<K,V>> | entrySet() 返回此映射所包含的映射关系的 Set 视图。
V | get(Object key) 返回指定键所映射到的值，如果此映射不包含该键的映射关系，则返回 null。
boolean | isEmpty() 如果此映射不包含键-值映射关系，则返回 true。
Enumeration<K> | keys() 返回此表中键的枚举。
Set<K> | keySet() 返回此映射中包含的键的 Set 视图。
V | put(K key, V value) 将指定键映射到此表中的指定值。
void | putAll(Map<? extends K,? extends V> m) 将指定映射中所有映射关系复制到此映射中。
V | putIfAbsent(K key, V value) 如果指定键已经不再与某个值相关联，则将它与给定值关联。
V | remove(Object key) 从此映射中移除键（及其相应的值）。
boolean | remove(Object key, Object value) 只有目前将键的条目映射到给定值时，才移除该键的条目。
V | replace(K key, V value) 只有目前将键的条目映射到某一值时，才替换该键的条目。
boolean | replace(K key, V oldValue, V newValue) 只有目前将键的条目映射到给定值时，才替换该键的条目。
int | size() 返回此映射中的键-值映射关系数。
Collection<V> | values() 返回此映射中包含的值的 Collection 视图。
从类 java.util.AbstractMap 继承的方法
clone, equals, hashCode, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Map 继承的方法
equals, hashCode

构造方法详细信息

ConcurrentHashMap

public ConcurrentHashMap(int initialCapacity,
                         float loadFactor,
                         int concurrencyLevel)
创建一个带有指定初始容量、加载因子和并发级别的新的空映射。

参数：
initialCapacity - 初始容量。该实现执行内部大小调整，以容纳这些元素。
loadFactor - 加载因子阈值，用来控制重新调整大小。在每 bin 中的平均元素数大于此阈值时，可能要重新调整大小。
concurrencyLevel - 当前更新线程的估计数。该实现将执行内部大小调整，以尽量容纳这些线程。
抛出：
IllegalArgumentException - 如果初始容量为负，或者加载因子或 concurrencyLevel 为非正。

ConcurrentHashMap

public ConcurrentHashMap(int initialCapacity,
                         float loadFactor)
创建一个带有指定初始容量、加载因子和默认 concurrencyLevel (16) 的新的空映射。

参数：
initialCapacity - 该实现执行内部的大小调整，以容纳这些元素。
loadFactor - 加载因子阈值，用来控制重新调整大小。在每 bin 中的平均元素数大于此阈值时，可能要重新调整大小。
抛出：
IllegalArgumentException - 如果元素的初始容量为负，或者加载因子为非正
从以下版本开始：
1.6

ConcurrentHashMap

public ConcurrentHashMap(int initialCapacity)
创建一个带有指定初始容量、默认加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。

参数：
initialCapacity - 初始容量。该实现执行内部的大小调整，以容纳这些元素。
抛出：
IllegalArgumentException - 如果元素的初始容量为负。

ConcurrentHashMap

public ConcurrentHashMap()
创建一个带有默认初始容量 (16)、加载因子 (0.75) 和 concurrencyLevel (16) 的新的空映射。

ConcurrentHashMap

public ConcurrentHashMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新映射。使用给定映射中映射关系数 1.5 倍的容量或 16（选更大的那一个）、默认加载因子 (0.75) 和 concurrencyLevel (16) 来创建该映射。

参数：
m - 映射
方法详细信息

isEmpty

public boolean isEmpty()
如果此映射不包含键-值映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 isEmpty
覆盖：
类 AbstractMap<K,V> 中的 isEmpty
返回：
如果此映射不包含键-值映射关系，则返回 true

size

public int size()
返回此映射中的键-值映射关系数。如果该映射包含的元素多于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

指定者：
接口 Map<K,V> 中的 size
覆盖：
类 AbstractMap<K,V> 中的 size
返回：
此映射中的键-值映射关系数

get

public V get(Object key)
返回指定键所映射到的值，如果此映射不包含该键的映射关系，则返回 null。

更确切地讲，如果此映射包含满足从键 k 到值 v 的映射关系 key.equals(k)，则此方法返回 v；否则它返回 null。（最多只能有一个这样的映射关系）。

指定者：
接口 Map<K,V> 中的 get
覆盖：
类 AbstractMap<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
抛出：
NullPointerException - 如果指定键为 null

containsKey

public boolean containsKey(Object key)
测试指定对象是否为此表中的键。

指定者：
接口 Map<K,V> 中的 containsKey
覆盖：
类 AbstractMap<K,V> 中的 containsKey
参数：
key - 可能的键
返回：
当且仅当指定对象（由 equals 方法确定）是此表中的键时，返回 true；否则返回 false。
抛出：
NullPointerException - 如果指定键为 null

containsValue

public boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。注：此方法需要完全内部遍历哈希表，因此它比方法 containsKey 更慢。

指定者：
接口 Map<K,V> 中的 containsValue
覆盖：
类 AbstractMap<K,V> 中的 containsValue
参数：
value - 测试在此映射中是否存在的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true
抛出：
NullPointerException - 如果指定值为 null

contains

public boolean contains(Object value)
一种遗留方法，测试此表中是否有一些与指定值存在映射关系的键。此方法在功能上等同于 containsValue(java.lang.Object)，并且它的存在只是为了确保与 Hashtable 类完全兼容，在引入 Java Collection 框架之前，该类支持此方法。

参数：
value - 要搜索的值
返回：
当且仅当此表中某个键映射到 value 参数时（由 equals 方法确定），返回 true；否则返回 false
抛出：
NullPointerException - 如果指定值为 null

put

public V put(K key,
             V value)
将指定键映射到此表中的指定值。键和值都不可以为 null。

通过使用与原来的键相同的键调用 get 方法，可以获取相应的值。

指定者：
接口 Map<K,V> 中的 put
覆盖：
类 AbstractMap<K,V> 中的 put
参数：
key - 与指定值相关联的键
value - 与指定键相关联的值
返回：
以前与 key 相关联的值，如果 key 没有映射关系，则返回 null
抛出：
NullPointerException - 如果指定键或值为 null

putIfAbsent

public V putIfAbsent(K key,
                     V value)
如果指定键已经不再与某个值相关联，则将它与给定值关联。这等价于：
   if (!map.containsKey(key))
      return map.put(key, value);
  else
       return map.get(key);
除了原子地执行此操作之外。

指定者：
接口 ConcurrentMap<K,V> 中的 putIfAbsent
参数：
key - 与指定值相关联的键
value - 与指定键相关联的值
返回：
以前与指定键相关联的值，如果该键没有映射关系，则返回 null
抛出：
NullPointerException - 如果指定键或值为 null

putAll

public void putAll(Map<? extends K,? extends V> m)
将指定映射中所有映射关系复制到此映射中。针对指定映射中的当前所有键，这些映射关系将替换此映射中具有的所有映射关系。

指定者：
接口 Map<K,V> 中的 putAll
覆盖：
类 AbstractMap<K,V> 中的 putAll
参数：
m - 将存储在此映射中的映射关系

remove

public V remove(Object key)
从此映射中移除键（及其相应的值）。如果该键不在映射中，则此方法不执行任何操作。

指定者：
接口 Map<K,V> 中的 remove
覆盖：
类 AbstractMap<K,V> 中的 remove
参数：
key - 需要移除的键
返回：
与 key 关联的先前值；如果 key 没有映射关系，则返回 null
抛出：
NullPointerException - 如果指定键为 null

remove

public boolean remove(Object key,
                      Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。这等效于：
   if (map.containsKey(key) && map.get(key).equals(value)) {
       map.remove(key);
       return true;
   } else return false;
不同之处在于该操作是以原子方式 (atomically) 执行的。

指定者：
接口 ConcurrentMap<K,V> 中的 remove
参数：
key - 与指定值相关联的键
value - 期望与指定键相关联的值
返回：
如果该值被移除，则返回 true
抛出：
NullPointerException - 如果指定键为 null

replace

public boolean replace(K key,
                       V oldValue,
                       V newValue)
只有目前将键的条目映射到给定值时，才替换该键的条目。这等效于：
   if (map.containsKey(key) && map.get(key).equals(oldValue)) {
       map.put(key, newValue);
       return true;
   } else return false;
不同之处在于该操作是以原子方式执行的。

指定者：
接口 ConcurrentMap<K,V> 中的 replace
参数：
key - 与指定值相关联的键
oldValue - 期望与指定键相关联的值
newValue - 与指定键相关联的值
返回：
如果该值被替换，则返回 true
抛出：
NullPointerException - 如果任何参数为 null

replace

public V replace(K key,
                 V value)
只有目前将键的条目映射到某一值时，才替换该键的条目。这等效于：
   if (map.containsKey(key)) {
       return map.put(key, value);
   } else return null;
不同之处在于该操作是以原子方式执行的。

指定者：
接口 ConcurrentMap<K,V> 中的 replace
参数：
key - 与指定值相关联的键
value - 与指定键相关联的值
返回：
与指定键关联的先前值；如果没有该键的映射关系，则返回 null
抛出：
NullPointerException - 如果指定键或值为 null

clear

public void clear()
从该映射中移除所有映射关系

指定者：
接口 Map<K,V> 中的 clear
覆盖：
类 AbstractMap<K,V> 中的 clear

keySet

public Set<K> keySet()
返回此映射中包含的键的 Set 视图。该 set 受映射支持，所以对映射的改变可在该 set 中反映出来，反之亦然。该 set 支持元素的移除，它通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作，从此映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

该视图的 iterator 是一个“弱一致”的迭代器，它从来不会抛出 ConcurrentModificationException，并且确保可遍历迭代器构造时存在的元素，此外还可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Map<K,V> 中的 keySet
覆盖：
类 AbstractMap<K,V> 中的 keySet
返回：
此映射中包含的键的 set 视图

values

public Collection<V> values()
返回此映射中包含的值的 Collection 视图。该 collection 受映射支持，所以对映射的改变可在该 collection 中反映出来，反之亦然。该 collection 支持元素的移除，它通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作，从此映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

该视图的 iterator 是一个“弱一致”迭代器，它不会抛出 ConcurrentModificationException，并且确保可遍历迭代器构造时存在的元素，此外还可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Map<K,V> 中的 values
覆盖：
类 AbstractMap<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射所包含的映射关系的 Set 视图。该 set 受映射支持，所以对映射的改变可在该 set 中反映出来，反之亦然。该 set 支持元素的移除，它通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作，从此映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

该视图的返回的 iterator 是一个“弱一致”迭代器，它不会抛出 ConcurrentModificationException，并且确保可遍历迭代器构造时存在的元素，此外还可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Map<K,V> 中的 entrySet
指定者：
类 AbstractMap<K,V> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图

keys

public Enumeration<K> keys()
返回此表中键的枚举。

返回：
此表中键的枚举
另请参见：
keySet()

elements

public Enumeration<V> elements()
返回此表中值的枚举。

返回：
此表中值的枚举
另请参见：
values()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConcurrentLinkedQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ConcurrentLinkedQueue<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.concurrent.ConcurrentLinkedQueue<E>
类型参数：
E - 在此 collection 中保持的元素类型
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, Queue<E>
public class ConcurrentLinkedQueue<E>
extends AbstractQueue<E>
implements Queue<E>, Serializable

一个基于链接节点的无界线程安全队列。此队列按照 FIFO（先进先出）原则对元素进行排序。队列的头部 是队列中时间最长的元素。队列的尾部 是队列中时间最短的元素。新的元素插入到队列的尾部，队列获取操作从队列头部获得元素。当多个线程共享访问一个公共 collection 时，ConcurrentLinkedQueue 是一个恰当的选择。此队列不允许使用 null 元素。

此实现采用了有效的“无等待 (wait-free)”算法，该算法基于 Maged M. Michael 和 Michael L. Scott 合著的 Simple, Fast, and Practical Non-Blocking and Blocking Concurrent Queue Algorithms 中描述的算法。

需要小心的是，与大多数 collection 不同，size 方法不是 一个固定时间操作。由于这些队列的异步特性，确定当前元素的数量需要遍历这些元素。

此类及其迭代器实现了 Collection 和 Iterator 接口的所有可选 方法。

内存一致性效果：当存在其他并发 collection 时，将对象放入 ConcurrentLinkedQueue 之前的线程中的操作 happen-before 随后通过另一线程从 ConcurrentLinkedQueue 访问或移除该元素的操作。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ConcurrentLinkedQueue()
创建一个最初为空的 ConcurrentLinkedQueue。
ConcurrentLinkedQueue(Collection<? extends E> c)
创建一个最初包含给定 collection 元素的 ConcurrentLinkedQueue，按照此 collection 迭代器的遍历顺序来添加元素。
方法摘要
 boolean add(E e)
将指定元素插入此队列的尾部。
 boolean contains(Object o)
如果此队列包含指定元素，则返回 true。
 boolean isEmpty()
如果此队列不包含任何元素，则返回 true。
 Iterator<E> iterator()
返回在此队列元素上以恰当顺序进行迭代的迭代器。
 boolean offer(E e)
将指定元素插入此队列的尾部。
 E peek()
获取但不移除此队列的头；如果此队列为空，则返回 null。
 E poll()
获取并移除此队列的头，如果此队列为空，则返回 null。
 boolean remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。
 int size()
返回此队列中的元素数量。
 Object[] toArray()
返回以恰当顺序包含此队列所有元素的数组。
<T> T[]
toArray(T[] a)
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
从类 java.util.AbstractQueue 继承的方法
addAll, clear, element, remove
从类 java.util.AbstractCollection 继承的方法
containsAll, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Queue 继承的方法
element, remove
从接口 java.util.Collection 继承的方法
addAll, clear, containsAll, equals, hashCode, removeAll, retainAll

构造方法详细信息

ConcurrentLinkedQueue

public ConcurrentLinkedQueue()
创建一个最初为空的 ConcurrentLinkedQueue。

ConcurrentLinkedQueue

public ConcurrentLinkedQueue(Collection<? extends E> c)
创建一个最初包含给定 collection 元素的 ConcurrentLinkedQueue，按照此 collection 迭代器的遍历顺序来添加元素。

参数：
c - 最初包含的元素 collection
抛出：
NullPointerException - 如果指定 collection 或其任何元素为 null
方法详细信息

add

public boolean add(E e)
将指定元素插入此队列的尾部。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractQueue<E> 中的 add
参数：
o - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e)
将指定元素插入此队列的尾部。

指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
true（根据 Queue.offer(E) 的规定）
抛出：
NullPointerException - 如果指定元素为 null

poll

public E poll()
从接口 Queue 复制的描述
获取并移除此队列的头，如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 poll
返回：
队列的头，如果此队列为空，则返回 null

peek

public E peek()
从接口 Queue 复制的描述
获取但不移除此队列的头；如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 peek
返回：
此队列的头；如果此队列为空，则返回 null

isEmpty

public boolean isEmpty()
如果此队列不包含任何元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
如果此队列不包含任何元素，则返回 true

size

public int size()
返回此队列中的元素数量。如果此队列包含的元素数大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

需要小心的是，与大多数 collection 不同，此方法不是 一个固定时间操作。由于这些队列的异步特性，确定当前的元素数需要进行一次花费 O(n) 时间的遍历。

指定者：
接口 Collection<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此队列中的元素数

contains

public boolean contains(Object o)
如果此队列包含指定元素，则返回 true。更确切地讲，当且仅当此队列至少包含一个满足 o.equals(e) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 要检查是否包含于此队列的对象
返回：
如果此队列包含指定元素，则返回 true

remove

public boolean remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。更确切地讲，如果此队列包含一个或多个满足 o.equals(e) 的元素 e，则移除一个这样的元素。如果此队列包含指定元素（或者此队列由于调用而发生更改），则返回 true。

指定者：
接口 Collection<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 将从此队列中移除的元素（如果存在）
返回：
如果此队列由于调用而发生更改，则返回 true

toArray

public Object[] toArray()
返回以恰当顺序包含此队列所有元素的数组。

由于此队列并不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此队列所有元素的数组

toArray

public <T> T[] toArray(T[] a)
返回以恰当顺序包含此队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。如果指定的数组能容纳队列，则将该队列返回此处。否则，将分配一个具有指定数组的运行时类型和此队列大小的新数组。

如果指定的数组能容纳队列，并有剩余的空间（即数组的元素比队列多），那么会将紧接队列尾部的元素设置为 null。

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，这可以用来节省分配开销。

假定 x 是只包含字符串的一个已知队列。以下代码用来将该队列转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 将用来存储队列元素的数组（如果该数组足够大）；否则，将为此分配一个具有相同运行时类型的新数组
返回：
包含此队列所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

iterator

public Iterator<E> iterator()
返回在此队列元素上以恰当顺序进行迭代的迭代器。返回的迭代器是一个“弱一致”迭代器，它不会抛出 ConcurrentModificationException，并且可保证遍历迭代器构造时存在的元素，此外还可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此队列元素上以恰当顺序进行迭代的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConcurrentMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 ConcurrentMap<K,V>

类型参数：
K - 此映射维护的键类型
V - 映射值的类型
所有超级接口：
Map<K,V>
所有已知子接口：
ConcurrentNavigableMap<K,V>
所有已知实现类：
ConcurrentHashMap, ConcurrentSkipListMap
public interface ConcurrentMap<K,V>
extends Map<K,V>

提供其他原子 putIfAbsent、remove、replace 方法的 Map。

内存一致性效果：当存在其他并发 collection 时，将对象放入 ConcurrentMap 之前的线程中的操作 happen-before 随后通过另一线程从 ConcurrentMap 中访问或移除该元素的操作。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.5

嵌套类摘要
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
方法摘要
V | putIfAbsent(K key, V value) 如果指定键已经不再与某个值相关联，则将它与给定值关联。
boolean | remove(Object key, Object value) 只有目前将键的条目映射到给定值时，才移除该键的条目。
V | replace(K key, V value) 只有目前将键的条目映射到某一值时，才替换该键的条目。
boolean | replace(K key, V oldValue, V newValue) 只有目前将键的条目映射到给定值时，才替换该键的条目。
从接口 java.util.Map 继承的方法
clear, containsKey, containsValue, entrySet, equals, get, hashCode, isEmpty, keySet, put, putAll, remove, size, values

方法详细信息

putIfAbsent

V putIfAbsent(K key,
              V value)
如果指定键已经不再与某个值相关联，则将它与给定值关联。这等价于：
   if (!map.containsKey(key))
      return map.put(key, value);
  else
       return map.get(key);
除了原子地执行此操作之外。

参数：
key - 与指定值相关联的键
value - 与指定键相关联的值
返回：
与指定键相关联的先前值，如果该键没有映射关系，则返回 null。（如果该实现支持 null 值，则返回 null 还可以指示此映射以前曾将 null 与该键相关联）。
抛出：
UnsupportedOperationException - 如果此映射不支持 put 操作
ClassCastException - 如果指定键或值的类不允许将其存储在此映射中
NullPointerException - 如果指定键或值为 null，并且此映射不允许 null 键或值
IllegalArgumentException - 如果指定键或值的某些属性不允许将其存储在此映射中

remove

boolean remove(Object key,
               Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。这等效于：
   if (map.containsKey(key) && map.get(key).equals(value)) {
       map.remove(key);
       return true;
   } else return false;
不同之处在于该操作是以原子方式 (atomically) 执行的。

参数：
key - 与指定值相关联的键
value - 期望与指定键相关联的值
返回：
如果该值被移除，则返回 true
抛出：
UnsupportedOperationException - 如果此映射不支持 remove 操作
ClassCastException - 如果该键或值是此映射的合适类型（可选）
NullPointerException - 如果指定键或值为 null，并且此映射不允许 null 键或值（可选）

replace

boolean replace(K key,
                V oldValue,
                V newValue)
只有目前将键的条目映射到给定值时，才替换该键的条目。这等效于：
   if (map.containsKey(key) && map.get(key).equals(oldValue)) {
       map.put(key, newValue);
       return true;
   } else return false;
不同之处在于该操作是以原子方式执行的。

参数：
key - 与指定值相关联的键
oldValue - 期望与指定键相关联的值
newValue - 与指定键相关联的值
返回：
如果该值被替换，则返回 true
抛出：
UnsupportedOperationException - 如果此映射不支持 put 操作
ClassCastException - 如果指定键或值的类不允许将其存储在此映射中
NullPointerException - 如果指定键或值为 null，并且此映射不允许 null 键或值
IllegalArgumentException - 如果指定键或值的某些属性不允许将其存储在此映射中

replace

V replace(K key,
          V value)
只有目前将键的条目映射到某一值时，才替换该键的条目。这等效于：
   if (map.containsKey(key)) {
       return map.put(key, value);
   } else return null;
不同之处在于该操作是以原子方式执行的。

参数：
key - 与指定值相关联的键
value - 与指定键相关联的值
返回：
与指定键相关联的先前值，如果该键没有映射关系，则返回 null。（如果该实现支持 null 值，则返回 null 还可以指示此映射以前曾将 null 与该键相关联）。
抛出：
UnsupportedOperationException - 如果此映射不支持 put 操作
ClassCastException - 如果指定键或值的类不允许将其存储在此映射中
NullPointerException - 如果指定键或值为 null，并且此映射不允许 null 键或值
IllegalArgumentException - 如果指定键或值的某些属性不允许将其存储在此映射中
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConcurrentNavigableMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 ConcurrentNavigableMap<K,V>

类型参数：
K - 此映射维护的键类型
V - 映射值的类型
所有超级接口：
ConcurrentMap<K,V>, Map<K,V>, NavigableMap<K,V>, SortedMap<K,V>
所有已知实现类：
ConcurrentSkipListMap
public interface ConcurrentNavigableMap<K,V>
extends ConcurrentMap<K,V>, NavigableMap<K,V>

支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

此接口是 Java Collections Framework 的成员。

从以下版本开始：
1.6

嵌套类摘要
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
方法摘要
NavigableSet<K> | descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
ConcurrentNavigableMap<K,V> | descendingMap() 返回此映射中所包含映射关系的逆序视图。
ConcurrentNavigableMap<K,V> | headMap(K toKey) 返回此映射的部分视图，其键值严格小于 toKey。
ConcurrentNavigableMap<K,V> | headMap(K toKey, boolean inclusive) 返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
NavigableSet<K> | keySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<K> | navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
ConcurrentNavigableMap<K,V> | subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive) 返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
ConcurrentNavigableMap<K,V> | subMap(K fromKey, K toKey) 返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
ConcurrentNavigableMap<K,V> | tailMap(K fromKey) 返回此映射的部分视图，其键大于等于 fromKey。
ConcurrentNavigableMap<K,V> | tailMap(K fromKey, boolean inclusive) 返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。
从接口 java.util.concurrent.ConcurrentMap 继承的方法
putIfAbsent, remove, replace, replace
从接口 java.util.NavigableMap 继承的方法
ceilingEntry, ceilingKey, firstEntry, floorEntry, floorKey, higherEntry, higherKey, lastEntry, lowerEntry, lowerKey, pollFirstEntry, pollLastEntry
从接口 java.util.SortedMap 继承的方法
comparator, entrySet, firstKey, lastKey, values
从接口 java.util.Map 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, put, putAll, remove, size

方法详细信息

subMap

ConcurrentNavigableMap<K,V> subMap(K fromKey,
                                   boolean fromInclusive,
                                   K toKey,
                                   boolean toInclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键的范围从 fromKey 到 toKey。如果 fromKey 和 toKey 相等，则返回的映射为空，除非 fromExclusive 和 toExclusive 都为 true。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，或者构造一个任一端点位于其范围之外的子映射，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 NavigableMap<K,V> 中的 subMap
参数：
fromKey - 返回映射中键的低端点
fromInclusive - 如果低端点要包含在返回的视图中，则为 true
toKey - 返回映射中键的高端点
toInclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键范围从 fromKey 到 toKey
抛出：
ClassCastException - 如果不能使用此映射的比较器（如果映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null 并且此映射不允许 null 键
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

ConcurrentNavigableMap<K,V> headMap(K toKey,
                                    boolean inclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 NavigableMap<K,V> 中的 headMap
参数：
toKey - 返回映射中键的高端点
inclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null 并且此映射不允许 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

ConcurrentNavigableMap<K,V> tailMap(K fromKey,
                                    boolean inclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 NavigableMap<K,V> 中的 tailMap
参数：
fromKey - 返回映射中键的低端点
inclusive - 如果低端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null 并且此映射不允许 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外

subMap

ConcurrentNavigableMap<K,V> subMap(K fromKey,
                                   K toKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。（如果 fromKey 和 toKey 相等，则返回映射为空。）返回的映射受此映射支持，所以在返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 subMap(fromKey, true, toKey, false)。

指定者：
接口 NavigableMap<K,V> 中的 subMap
指定者：
接口 SortedMap<K,V> 中的 subMap
参数：
fromKey - 返回映射中键的低端点（包括）
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）
抛出：
ClassCastException - 如果无法使用此映射的比较器（如果此映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

ConcurrentNavigableMap<K,V> headMap(K toKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键值严格小于 toKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 headMap(toKey, false)。

指定者：
接口 NavigableMap<K,V> 中的 headMap
指定者：
接口 SortedMap<K,V> 中的 headMap
参数：
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，该映射的键严格小于 toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

ConcurrentNavigableMap<K,V> tailMap(K fromKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键大于等于 fromKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 tailMap(fromKey, true)。

指定者：
接口 NavigableMap<K,V> 中的 tailMap
指定者：
接口 SortedMap<K,V> 中的 tailMap
参数：
fromKey - 返回映射中键的低端点（包括）
返回：
此映射的部分视图，其键大于等于 fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null，并且此映射不允许使用 null 键
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外

descendingMap

ConcurrentNavigableMap<K,V> descendingMap()
返回此映射中所包含映射关系的逆序视图。降序映射受此映射的支持，因此对此映射的更改将反映在降序映射中，反之亦然。

返回映射的顺序等于 Collections.reverseOrder(comparator())。表达式 m.descendingMap().descendingMap() 返回的 m 视图基本等效于 m。

指定者：
接口 NavigableMap<K,V> 中的 descendingMap
返回：
此映射的逆序视图

navigableKeySet

NavigableSet<K> navigableKeySet()
返回此映射中所包含键的 NavigableSet 视图。set 的迭代器按升序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

指定者：
接口 NavigableMap<K,V> 中的 navigableKeySet
返回：
此映射中键的可导航 set 视图

keySet

NavigableSet<K> keySet()
返回此映射中所包含键的 NavigableSet 视图。set 的迭代器按升序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

此方法等效于方法 navigableKeySet。

指定者：
接口 Map<K,V> 中的 keySet
指定者：
接口 SortedMap<K,V> 中的 keySet
返回：
此映射中键的可导航 set 视图

descendingKeySet

NavigableSet<K> descendingKeySet()
返回此映射中所包含键的逆序 NavigableSet 视图。set 的迭代器按降序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

指定者：
接口 NavigableMap<K,V> 中的 descendingKeySet
返回：
此映射中键的逆序可导航 set 视图
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConcurrentSkipListMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ConcurrentSkipListMap<K,V>

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.concurrent.ConcurrentSkipListMap<K,V>
类型参数：
K - 此映射维护的键类型
V - 映射值的类型
所有已实现的接口：
Serializable, Cloneable, ConcurrentMap<K,V>, ConcurrentNavigableMap<K,V>, Map<K,V>, NavigableMap<K,V>, SortedMap<K,V>
public class ConcurrentSkipListMap<K,V>
extends AbstractMap<K,V>
implements ConcurrentNavigableMap<K,V>, Cloneable, Serializable

可缩放的并发 ConcurrentNavigableMap 实现。映射可以根据键的自然顺序进行排序，也可以根据创建映射时所提供的 Comparator 进行排序，具体取决于使用的构造方法。

此类实现 SkipLists 的并发变体，为 containsKey、get、put、remove 操作及其变体提供预期平均 log(n) 时间开销。多个线程可以安全地并发执行插入、移除、更新和访问操作。迭代器是弱一致 的，返回的元素将反映迭代器创建时或创建后某一时刻的映射状态。它们不 抛出 ConcurrentModificationException，可以并发处理其他操作。升序键排序视图及其迭代器比降序键排序视图及其迭代器更快。

此类及此类视图中的方法返回的所有 Map.Entry 对，表示他们产生时的映射关系快照。它们不 支持 Entry.setValue 方法。（注意，根据所需效果，可以使用 put、putIfAbsent 或 replace 更改关联映射中的映射关系。）

请注意，与在大多数 collection 中不同，这里的 size 方法不是 一个固定时间 (constant-time) 操作。因为这些映射的异步特性，确定元素的当前数目需要遍历元素。此外，批量操作 putAll、equals 和 clear 并不 保证能以原子方式 (atomically) 执行。例如，与 putAll 操作一起并发操作的迭代器只能查看某些附加元素。

此类及其视图和迭代器实现 Map 和 Iterator 接口的所有可选 方法。与大多数其他并发 collection 一样，此类不 允许使用 null 键或值，因为无法可靠地区分 null 返回值与不存在的元素值。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.6
另请参见：
序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
构造方法摘要
ConcurrentSkipListMap()
构造一个新的空映射，该映射按照键的自然顺序进行排序。
ConcurrentSkipListMap(Comparator<? super K> comparator)
构造一个新的空映射，该映射按照指定的比较器进行排序。
ConcurrentSkipListMap(Map<? extends K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与给定映射包含的映射关系相同，并按照键的自然顺序进行排序。
ConcurrentSkipListMap(SortedMap<K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与指定的有序映射包含的映射关系相同，使用的顺序也相同。
方法摘要
Map.Entry<K,V> | ceilingEntry(K key) 返回与大于等于给定键的最小键关联的键-值映射关系；如果不存在这样的条目，则返回 null。
K | ceilingKey(K key) 返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。
void | clear() 从此映射中移除所有映射关系。
ConcurrentSkipListMap<K,V> | clone() 返回此 ConcurrentSkipListMap 实例的浅表副本。
Comparator<? super K> | comparator() 返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。
boolean | containsKey(Object key) 如果此映射包含指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射为指定值映射一个或多个键，则返回 true。
NavigableSet<K> | descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
ConcurrentNavigableMap<K,V> | descendingMap() 返回此映射中所包含映射关系的逆序视图。
Set<Map.Entry<K,V>> | entrySet() 返回此映射中所包含的映射关系的 Set 视图。
boolean | equals(Object o) 比较指定对象与此映射的相等性。
Map.Entry<K,V> | firstEntry() 返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
K | firstKey() 返回此映射中当前第一个（最低）键。
Map.Entry<K,V> | floorEntry(K key) 返回与小于等于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
K | floorKey(K key) 返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。
V | get(Object key) 返回指定键所映射到的值；如果此映射不包含该键的映射关系，则返回 null。
ConcurrentNavigableMap<K,V> | headMap(K toKey) 返回此映射的部分视图，其键值严格小于 toKey。
ConcurrentNavigableMap<K,V> | headMap(K toKey, boolean inclusive) 返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
Map.Entry<K,V> | higherEntry(K key) 返回与严格大于给定键的最小键关联的键-值映射关系；如果不存在这样的键，则返回 null。
K | higherKey(K key) 返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。
boolean | isEmpty() 如果此映射未包含键-值映射关系，则返回 true。
NavigableSet<K> | keySet() 返回此映射中所包含键的 NavigableSet 视图。
Map.Entry<K,V> | lastEntry() 返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
K | lastKey() 返回映射中当前最后一个（最高）键。
Map.Entry<K,V> | lowerEntry(K key) 返回与严格小于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
K | lowerKey(K key) 返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。
NavigableSet<K> | navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
Map.Entry<K,V> | pollFirstEntry() 移除并返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
Map.Entry<K,V> | pollLastEntry() 移除并返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
V | put(K key, V value) 将指定值与此映射中的指定键关联。
V | putIfAbsent(K key, V value) 如果指定键已经不再与某个值相关联，则将它与给定值关联。
V | remove(Object key) 从此映射中移除指定键的映射关系（如果存在）。
boolean | remove(Object key, Object value) 只有目前将键的条目映射到给定值时，才移除该键的条目。
V | replace(K key, V value) 只有目前将键的条目映射到某一值时，才替换该键的条目。
boolean | replace(K key, V oldValue, V newValue) 只有目前将键的条目映射到给定值时，才替换该键的条目。
int | size() 返回此映射中的键-值映射关系数。
ConcurrentNavigableMap<K,V> | subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive) 返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
ConcurrentNavigableMap<K,V> | subMap(K fromKey, K toKey) 返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
ConcurrentNavigableMap<K,V> | tailMap(K fromKey) 返回此映射的部分视图，其键大于等于 fromKey。
ConcurrentNavigableMap<K,V> | tailMap(K fromKey, boolean inclusive) 返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。
Collection<V> | values() 返回此映射中所包含值的 Collection 视图。
从类 java.util.AbstractMap 继承的方法
hashCode, putAll, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Map 继承的方法
hashCode, putAll

构造方法详细信息

ConcurrentSkipListMap

public ConcurrentSkipListMap()
构造一个新的空映射，该映射按照键的自然顺序进行排序。

ConcurrentSkipListMap

public ConcurrentSkipListMap(Comparator<? super K> comparator)
构造一个新的空映射，该映射按照指定的比较器进行排序。

参数：
comparator - 用于对此映射进行排序的比较器。如果此参数为 null，则使用键的自然顺序。

ConcurrentSkipListMap

public ConcurrentSkipListMap(Map<? extends K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与给定映射包含的映射关系相同，并按照键的自然顺序进行排序。

参数：
m - 映射关系将被存放在此映射中的映射
抛出：
ClassCastException - 如果 m 中的键不是 Comparable，或者无法相互比较
NullPointerException - 如果指定的映射或者它的任何键或值为 null

ConcurrentSkipListMap

public ConcurrentSkipListMap(SortedMap<K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与指定的有序映射包含的映射关系相同，使用的顺序也相同。

参数：
m - 映射关系将被存放在此映射中的有序映射，其比较器用于对此映射进行排序
抛出：
NullPointerException - 如果指定的有序映射或者它的任何键或值为 null
方法详细信息

clone

public ConcurrentSkipListMap<K,V> clone()
返回此 ConcurrentSkipListMap 实例的浅表副本。（不复制键和值本身。）

覆盖：
类 AbstractMap<K,V> 中的 clone
返回：
此映射的浅表副本
另请参见：
Cloneable

containsKey

public boolean containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 containsKey
覆盖：
类 AbstractMap<K,V> 中的 containsKey
参数：
key - 测试是否存在于此映射中的键
返回：
如果此映射包含指定键的映射关系，则返回 true
抛出：
ClassCastException - 如果指定键无法与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

get

public V get(Object key)
返回指定键所映射到的值；如果此映射不包含该键的映射关系，则返回 null。

更确切地讲，如果此映射包含从键 k 到值 v 的映射关系，根据映射的顺序，key 与 k 比较起来相等，那么此方法返回 v；否则返回 null。（最多只能有一个这样的映射关系）。

指定者：
接口 Map<K,V> 中的 get
覆盖：
类 AbstractMap<K,V> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
抛出：
ClassCastException - 如果指定键无法与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

put

public V put(K key,
             V value)
将指定值与此映射中的指定键关联。如果映射以前包含了一个该键的映射关系，那么将替换旧值。

指定者：
接口 Map<K,V> 中的 put
覆盖：
类 AbstractMap<K,V> 中的 put
参数：
key - 与指定值关联的键
value - 与指定键关联的值
返回：
以前与指定键关联的值；如果该键没有映射关系，则返回 null
抛出：
ClassCastException - 如果指定键无法与映射中的当前值进行比较
NullPointerException - 如果指定键或值为 null

remove

public V remove(Object key)
从此映射中移除指定键的映射关系（如果存在）。

指定者：
接口 Map<K,V> 中的 remove
覆盖：
类 AbstractMap<K,V> 中的 remove
参数：
key - 映射关系应该被移除的键
返回：
以前与指定键关联的值；如果该键没有映射关系，则返回 null
抛出：
ClassCastException - 如果指定键无法与映射中的当前值进行比较
NullPointerException - 如果指定键为 null

containsValue

public boolean containsValue(Object value)
如果此映射为指定值映射一个或多个键，则返回 true。此操作所需的时间与映射的大小呈线性关系。

指定者：
接口 Map<K,V> 中的 containsValue
覆盖：
类 AbstractMap<K,V> 中的 containsValue
参数：
value - 测试是否存在于此映射中的值
返回：
如果存在对 value 的映射关系，则返回 true；否则返回 false
抛出：
NullPointerException - 如果指定的值为 null

size

public int size()
返回此映射中的键-值映射关系数。如果此映射包含的元素数大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

请注意，与在大多数 collection 中不同，此方法在这不是 一个固定时间操作。因为这些映射的异步特性，确定元素的当前数目需要遍历元素以计算其数目。此外，在执行此方法期间可以更改大小，在这种情况下，返回的结果将不准确。因此，此方法在并发应用程序中通常不是很有用。

指定者：
接口 Map<K,V> 中的 size
覆盖：
类 AbstractMap<K,V> 中的 size
返回：
此映射中的元素数

isEmpty

public boolean isEmpty()
如果此映射未包含键-值映射关系，则返回 true。

指定者：
接口 Map<K,V> 中的 isEmpty
覆盖：
类 AbstractMap<K,V> 中的 isEmpty
返回：
如果此映射未包含键-值映射关系，则返回 true

clear

public void clear()
从此映射中移除所有映射关系。

指定者：
接口 Map<K,V> 中的 clear
覆盖：
类 AbstractMap<K,V> 中的 clear

keySet

public NavigableSet<K> keySet()
返回此映射中所包含键的 NavigableSet 视图。set 的迭代器按升序返回键。set 受映射支持，因此对映射的更改可在 set 中反映出来，反之亦然。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

此方法等效于方法 navigableKeySet。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 keySet
指定者：
接口 Map<K,V> 中的 keySet
指定者：
接口 SortedMap<K,V> 中的 keySet
覆盖：
类 AbstractMap<K,V> 中的 keySet
返回：
此映射中键的可导航 set 视图

navigableKeySet

public NavigableSet<K> navigableKeySet()
从接口 ConcurrentNavigableMap 复制的描述
返回此映射中所包含键的 NavigableSet 视图。set 的迭代器按升序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 navigableKeySet
指定者：
接口 NavigableMap<K,V> 中的 navigableKeySet
返回：
此映射中键的可导航 set 视图

values

public Collection<V> values()
返回此映射中所包含值的 Collection 视图。collection 的迭代器将按相应键的升序返回值。collection 受映射支持，所以对映射的更改可在此 collection 中反映出来，反之亦然。collection 支持元素移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

指定者：
接口 Map<K,V> 中的 values
指定者：
接口 SortedMap<K,V> 中的 values
覆盖：
类 AbstractMap<K,V> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<K,V>> entrySet()
返回此映射中所包含的映射关系的 Set 视图。set 的迭代器按键的升序返回条目。set 受映射支持，因此对映射的更改可在 set 中反映出来，反之亦然。set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作，可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

由 iterator.next() 返回的 Map.Entry 元素 不 支持 setValue 操作。

指定者：
接口 Map<K,V> 中的 entrySet
指定者：
接口 SortedMap<K,V> 中的 entrySet
指定者：
类 AbstractMap<K,V> 中的 entrySet
返回：
包含在此映射中的映射关系的 set 视图，它按键的升序排序

descendingMap

public ConcurrentNavigableMap<K,V> descendingMap()
从接口 ConcurrentNavigableMap 复制的描述
返回此映射中所包含映射关系的逆序视图。降序映射受此映射的支持，因此对此映射的更改将反映在降序映射中，反之亦然。

返回映射的顺序等于 Collections.reverseOrder(comparator())。表达式 m.descendingMap().descendingMap() 返回的 m 视图基本等效于 m。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 descendingMap
指定者：
接口 NavigableMap<K,V> 中的 descendingMap
返回：
此映射的逆序视图

descendingKeySet

public NavigableSet<K> descendingKeySet()
从接口 ConcurrentNavigableMap 复制的描述
返回此映射中所包含键的逆序 NavigableSet 视图。set 的迭代器按降序返回键。set 受映射支持，因此对映射的更改将反映在 set 中，反之亦然。set 支持元素移除，即通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

视图的 iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历构造迭代器后存在的所有元素，并且可以（但并不保证）反映构造后的所有修改。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 descendingKeySet
指定者：
接口 NavigableMap<K,V> 中的 descendingKeySet
返回：
此映射中键的逆序可导航 set 视图

equals

public boolean equals(Object o)
比较指定对象与此映射的相等性。如果给定对象也是一个映射并且两个映射表示相同的映射关系，则返回 true。更确切地讲，如果 m1.entrySet().equals(m2.entrySet())，那么这两个映射 m1 和 m2 表示相同的映射关系。如果在执行该此方法期间并发地修改了某一个映射，则此操作返回的结果可能不符合实际。

指定者：
接口 Map<K,V> 中的 equals
覆盖：
类 AbstractMap<K,V> 中的 equals
参数：
o - 要与此映射进行相等性比较的对象
返回：
true 如果指定对象等于此映射
另请参见：
Object.hashCode(), Hashtable

putIfAbsent

public V putIfAbsent(K key,
                     V value)
如果指定键已经不再与某个值相关联，则将它与给定值关联。这等价于：
   if (!map.containsKey(key))
      return map.put(key, value);
  else
       return map.get(key);
除了原子地执行此操作之外。

指定者：
接口 ConcurrentMap<K,V> 中的 putIfAbsent
参数：
key - 与指定值相关联的键
value - 与指定键相关联的值
返回：
以前与指定键关联的值；如果没有该键的映射关系，则返回 null
抛出：
ClassCastException - 如果指定键无法与映射中的当前值进行比较
NullPointerException - 如果指定键或值为 null

remove

public boolean remove(Object key,
                      Object value)
只有目前将键的条目映射到给定值时，才移除该键的条目。这等效于：
   if (map.containsKey(key) && map.get(key).equals(value)) {
       map.remove(key);
       return true;
   } else return false;
不同之处在于该操作是以原子方式 (atomically) 执行的。

指定者：
接口 ConcurrentMap<K,V> 中的 remove
参数：
key - 与指定值相关联的键
value - 期望与指定键相关联的值
返回：
如果该值被移除，则返回 true
抛出：
ClassCastException - 如果指定键无法与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

replace

public boolean replace(K key,
                       V oldValue,
                       V newValue)
只有目前将键的条目映射到给定值时，才替换该键的条目。这等效于：
   if (map.containsKey(key) && map.get(key).equals(oldValue)) {
       map.put(key, newValue);
       return true;
   } else return false;
不同之处在于该操作是以原子方式执行的。

指定者：
接口 ConcurrentMap<K,V> 中的 replace
参数：
key - 与指定值相关联的键
oldValue - 期望与指定键相关联的值
newValue - 与指定键相关联的值
返回：
如果该值被替换，则返回 true
抛出：
ClassCastException - 如果指定键无法与映射中的当前键进行比较
NullPointerException - 如果任何参数为 null

replace

public V replace(K key,
                 V value)
只有目前将键的条目映射到某一值时，才替换该键的条目。这等效于：
   if (map.containsKey(key)) {
       return map.put(key, value);
   } else return null;
不同之处在于该操作是以原子方式执行的。

指定者：
接口 ConcurrentMap<K,V> 中的 replace
参数：
key - 与指定值相关联的键
value - 与指定键相关联的值
返回：
以前与指定键关联的值；如果没有该键的映射关系，则返回 null
抛出：
ClassCastException - 如果指定键无法与映射中的当前值进行比较
NullPointerException - 如果指定键或值为 null

comparator

public Comparator<? super K> comparator()
从接口 SortedMap 复制的描述
返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。

指定者：
接口 SortedMap<K,V> 中的 comparator
返回：
用来对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null

firstKey

public K firstKey()
从接口 SortedMap 复制的描述
返回此映射中当前第一个（最低）键。

指定者：
接口 SortedMap<K,V> 中的 firstKey
返回：
此映射中当前第一个（最低）键
抛出：
NoSuchElementException - 如果此映射为空

lastKey

public K lastKey()
从接口 SortedMap 复制的描述
返回映射中当前最后一个（最高）键。

指定者：
接口 SortedMap<K,V> 中的 lastKey
返回：
此映射中当前最后一个（最高）键
抛出：
NoSuchElementException - 如果此映射为空

subMap

public ConcurrentNavigableMap<K,V> subMap(K fromKey,
                                          boolean fromInclusive,
                                          K toKey,
                                          boolean toInclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键的范围从 fromKey 到 toKey。如果 fromKey 和 toKey 相等，则返回的映射为空，除非 fromExclusive 和 toExclusive 都为 true。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，或者构造一个任一端点位于其范围之外的子映射，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 subMap
指定者：
接口 NavigableMap<K,V> 中的 subMap
参数：
fromKey - 返回映射中键的低端点
fromInclusive - 如果低端点要包含在返回的视图中，则为 true
toKey - 返回映射中键的高端点
toInclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键范围从 fromKey 到 toKey
抛出：
ClassCastException - 如果不能使用此映射的比较器（如果映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

public ConcurrentNavigableMap<K,V> headMap(K toKey,
                                           boolean inclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 headMap
指定者：
接口 NavigableMap<K,V> 中的 headMap
参数：
toKey - 返回映射中键的高端点
inclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

public ConcurrentNavigableMap<K,V> tailMap(K fromKey,
                                           boolean inclusive)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。返回的映射受此映射支持，因此返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入一个键，则返回的映射将抛出 IllegalArgumentException。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 tailMap
指定者：
接口 NavigableMap<K,V> 中的 tailMap
参数：
fromKey - 返回映射中键的低端点
inclusive - 如果低端点要包含在返回的视图中，则为 true
返回：
此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外

subMap

public ConcurrentNavigableMap<K,V> subMap(K fromKey,
                                          K toKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。（如果 fromKey 和 toKey 相等，则返回映射为空。）返回的映射受此映射支持，所以在返回映射中的更改将反映在此映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 subMap(fromKey, true, toKey, false)。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 subMap
指定者：
接口 NavigableMap<K,V> 中的 subMap
指定者：
接口 SortedMap<K,V> 中的 subMap
参数：
fromKey - 返回映射中键的低端点（包括）
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）
抛出：
ClassCastException - 如果无法使用此映射的比较器（如果此映射没有比较器，则使用自然顺序）比较 fromKey 和 toKey。如果 fromKey 或 toKey 不能与映射中当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 或 toKey 为 null
IllegalArgumentException - 如果 fromKey 大于 toKey；如果此映射本身有范围限制，并且 fromKey 或 toKey 位于范围的边界之外

headMap

public ConcurrentNavigableMap<K,V> headMap(K toKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键值严格小于 toKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 headMap(toKey, false)。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 headMap
指定者：
接口 NavigableMap<K,V> 中的 headMap
指定者：
接口 SortedMap<K,V> 中的 headMap
参数：
toKey - 返回映射中键的高端点（不包括）
返回：
此映射的部分视图，该映射的键严格小于 toKey
抛出：
ClassCastException - 如果 toKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 toKey 没有实现 Comparable）。如果 toKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toKey 为 null
IllegalArgumentException - 如果此映射本身有范围限制，并且 toKey 位于范围的边界之外

tailMap

public ConcurrentNavigableMap<K,V> tailMap(K fromKey)
从接口 NavigableMap 复制的描述
返回此映射的部分视图，其键大于等于 fromKey。返回的映射受此映射支持，所以在返回映射中的更改将反映在映射中，反之亦然。返回的映射支持此映射支持的所有可选映射操作。

如果试图在返回映射的范围之外插入键，则返回的映射将抛出 IllegalArgumentException。

等效于 tailMap(fromKey, true)。

指定者：
接口 ConcurrentNavigableMap<K,V> 中的 tailMap
指定者：
接口 NavigableMap<K,V> 中的 tailMap
指定者：
接口 SortedMap<K,V> 中的 tailMap
参数：
fromKey - 返回映射中键的低端点（包括）
返回：
此映射的部分视图，其键大于等于 fromKey
抛出：
ClassCastException - 如果 fromKey 与此映射的比较器不兼容（如果该映射没有比较器；如果 fromKey 没有实现 Comparable）。如果 fromKey 不能与映射中的当前键进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromKey 为 null
IllegalArgumentException - 如果此映射本身有范围限制，并且 fromKey 位于范围的边界之外

lowerEntry

public Map.Entry<K,V> lowerEntry(K key)
返回与严格小于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 lowerEntry
参数：
key - 键
返回：
最大键小于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

lowerKey

public K lowerKey(K key)
从接口 NavigableMap 复制的描述
返回严格小于给定键的最大键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 lowerKey
参数：
key - 键
返回：
小于 key 的最大键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

floorEntry

public Map.Entry<K,V> floorEntry(K key)
返回与小于等于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 floorEntry
参数：
key - 键
返回：
最大键小于等于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

floorKey

public K floorKey(K key)
从接口 NavigableMap 复制的描述
返回小于等于给定键的最大键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 floorKey
参数：
key - 键
返回：
小于等于 key 的最大键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

ceilingEntry

public Map.Entry<K,V> ceilingEntry(K key)
返回与大于等于给定键的最小键关联的键-值映射关系；如果不存在这样的条目，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 ceilingEntry
参数：
key - 键
返回：
最小键大于等于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

ceilingKey

public K ceilingKey(K key)
从接口 NavigableMap 复制的描述
返回大于等于给定键的最小键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 ceilingKey
参数：
key - 键
返回：
大于等于 key 的最小键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

higherEntry

public Map.Entry<K,V> higherEntry(K key)
返回与严格大于给定键的最小键关联的键-值映射关系；如果不存在这样的键，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 higherEntry
参数：
key - 键
返回：
最小键大于 key 的条目；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

higherKey

public K higherKey(K key)
从接口 NavigableMap 复制的描述
返回严格大于给定键的最小键；如果不存在这样的键，则返回 null。

指定者：
接口 NavigableMap<K,V> 中的 higherKey
参数：
key - 键
返回：
大于 key 的最小键；如果不存在这样的键，则返回 null
抛出：
ClassCastException - 如果指定键不能与映射中的当前键进行比较
NullPointerException - 如果指定键为 null

firstEntry

public Map.Entry<K,V> firstEntry()
返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 firstEntry
返回：
带有最小键的条目；如果此映射为空，则返回 null

lastEntry

public Map.Entry<K,V> lastEntry()
返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 lastEntry
返回：
带有最大键的条目；如果此映射为空，则返回 null

pollFirstEntry

public Map.Entry<K,V> pollFirstEntry()
移除并返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 pollFirstEntry
返回：
此映射中被移除的第一个条目；如果此映射为空，则返回 null

pollLastEntry

public Map.Entry<K,V> pollLastEntry()
移除并返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。返回的条目不 支持 Entry.setValue 方法。

指定者：
接口 NavigableMap<K,V> 中的 pollLastEntry
返回：
此映射中被移除的最后一个条目；如果此映射为空，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConcurrentSkipListSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ConcurrentSkipListSet<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
            继承者  java.util.concurrent.ConcurrentSkipListSet<E>
类型参数：
E - 此 set 维护的元素类型
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, NavigableSet<E>, Set<E>, SortedSet<E>
public class ConcurrentSkipListSet<E>
extends AbstractSet<E>
implements NavigableSet<E>, Cloneable, Serializable

一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。set 的元素可以根据它们的自然顺序进行排序，也可以根据创建 set 时所提供的 Comparator 进行排序，具体取决于使用的构造方法。

此实现为 contains、add、remove 操作及其变体提供预期平均 log(n) 时间开销。多个线程可以安全地并发执行插入、移除和访问操作。迭代器是弱一致 的，返回的元素将反映迭代器创建时或创建后某一时刻的 set 状态。它们不 抛出 ConcurrentModificationException，可以并发处理其他操作。升序排序视图及其迭代器比降序排序视图及其迭代器更快。

请注意，与在大多数 collection 中不同，这里的 size 方法不是 一个固定时间 (constant-time) 操作。由于这些 set 的异步特性，确定元素的当前数目需要遍历元素。此外，批量操作 addAll、removeAll、retainAll 和 containsAll 并不 保证能以原子方式 (atomically) 执行。例如，与 addAll 操作一起并发操作的迭代器只能查看某些附加元素。

此类及其迭代器实现 Set 和 Iterator 接口的所有可选 方法。与大多数其他并发 collection 实现一样，此类不允许使用 null 元素，因为无法可靠地将 null 参数及返回值与不存在的元素区分开来。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
ConcurrentSkipListSet()
构造一个新的空 set，该 set 按照元素的自然顺序对其进行排序。
ConcurrentSkipListSet(Collection<? extends E> c)
构造一个包含指定 collection 中元素的新 set，这个新 set 按照元素的自然顺序对其进行排序。
ConcurrentSkipListSet(Comparator<? super E> comparator)
构造一个新的空 set，该 set 按照指定的比较器对其元素进行排序。
ConcurrentSkipListSet(SortedSet<E> s)
构造一个新 set，该 set 所包含的元素与指定的有序 set 包含的元素相同，使用的顺序也相同。
方法摘要
boolean | add(E e) 如果此 set 中不包含指定元素，则添加指定元素。
E | ceiling(E e) 返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。
void | clear() 从此 set 中移除所有元素。
ConcurrentSkipListSet<E> | clone() 返回此 ConcurrentSkipListSet 实例的浅表副本。
Comparator<? super E> | comparator() 返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。
boolean | contains(Object o) 如果此 set 包含指定的元素，则返回 true。
Iterator<E> | descendingIterator() 返回在此 set 的元素上以降序进行迭代的迭代器。
NavigableSet<E> | descendingSet() 返回此 set 中所包含元素的逆序视图。
boolean | equals(Object o) 比较指定对象与此 set 的相等性。
E | first() 返回此 set 中当前第一个（最低）元素。
E | floor(E e) 返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。
NavigableSet<E> | headSet(E toElement) 返回此 set 的部分视图，其元素严格小于 toElement。
NavigableSet<E> | headSet(E toElement, boolean inclusive) 返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。
E | higher(E e) 返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。
boolean | isEmpty() 如果此 set 不包含任何元素，则返回 true。
Iterator<E> | iterator() 返回在此 set 的元素上以升序进行迭代的迭代器。
E | last() 返回此 set 中当前最后一个（最高）元素。
E | lower(E e) 返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。
E | pollFirst() 获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。
E | pollLast() 获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。
boolean | remove(Object o) 如果此 set 中存在指定的元素，则将其移除。
boolean | removeAll(Collection<?> c) 从此 set 中移除包含在指定 collection 中的所有元素。
int | size() 返回此 set 中的元素数目。
NavigableSet<E> | subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive) 返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。
NavigableSet<E> | subSet(E fromElement, E toElement) 返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
NavigableSet<E> | tailSet(E fromElement) 返回此 set 的部分视图，其元素大于等于 fromElement。
NavigableSet<E> | tailSet(E fromElement, boolean inclusive) 返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。
从类 java.util.AbstractSet 继承的方法
hashCode
从类 java.util.AbstractCollection 继承的方法
addAll, containsAll, retainAll, toArray, toArray, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Set 继承的方法
addAll, containsAll, hashCode, retainAll, toArray, toArray

构造方法详细信息

ConcurrentSkipListSet

public ConcurrentSkipListSet()
构造一个新的空 set，该 set 按照元素的自然顺序对其进行排序。

ConcurrentSkipListSet

public ConcurrentSkipListSet(Comparator<? super E> comparator)
构造一个新的空 set，该 set 按照指定的比较器对其元素进行排序。

参数：
comparator - 用于对此 set 进行排序的比较器。如果此参数为 null，则使用元素的自然顺序。

ConcurrentSkipListSet

public ConcurrentSkipListSet(Collection<? extends E> c)
构造一个包含指定 collection 中元素的新 set，这个新 set 按照元素的自然顺序对其进行排序。

参数：
c - 将组成新 set 的元素
抛出：
ClassCastException - 如果 c 中的元素不是 Comparable，或者无法相互比较
NullPointerException - 如果指定的 collection 或它的任何元素为 null

ConcurrentSkipListSet

public ConcurrentSkipListSet(SortedSet<E> s)
构造一个新 set，该 set 所包含的元素与指定的有序 set 包含的元素相同，使用的顺序也相同。

参数：
s - 有序 set，其元素将组成新的 set
抛出：
NullPointerException - 如果指定的有序 set 或它的任何元素为 null
方法详细信息

clone

public ConcurrentSkipListSet<E> clone()
返回此 ConcurrentSkipListSet 实例的浅表副本。(这些元素本身没有复制。）

覆盖：
类 Object 中的 clone
返回：
此 set 的浅表副本
另请参见：
Cloneable

size

public int size()
返回此 set 中的元素数目。如果此 set 包含的元素数大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

请注意，与在大多数 collection 中不同，此方法在这里不是 一个固定时间 (constant-time) 操作。由于这些 set 的异步特性，确定元素的当前数目需要遍历元素以计算其数目。此外，在执行此方法期间大小可能更改，在这种情况下，返回的结果将不准确。因此，此方法在并发应用程序中通常不是很有用。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 Set<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此 set 中的元素数

isEmpty

public boolean isEmpty()
如果此 set 不包含任何元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
指定者：
接口 Set<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
如果此 set 不包含任何元素，则返回 true

contains

public boolean contains(Object o)
如果此 set 包含指定的元素，则返回 true。更确切地讲，当且仅当此 set 包含一个满足 o.equals(e) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 Set<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 检查是否包含在此 set 中的对象
返回：
如果此 set 包含指定的元素，则返回 true
抛出：
ClassCastException - 如果指定的元素无法与此 set 中的当前元素进行比较
NullPointerException - 如果指定的元素为 null

add

public boolean add(E e)
如果此 set 中不包含指定元素，则添加指定元素。更确切地讲，如果此 set 不包含满足 e.equals(e2) 的元素 e2，则向 set 中添加指定的元素 e。如果此 set 已经包含该元素，则调用不更改该 set 并返回 false。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Set<E> 中的 add
覆盖：
类 AbstractCollection<E> 中的 add
参数：
e - 要添加到此 set 的元素
返回：
如果此 set 尚未包含指定的元素，则返回 true
抛出：
ClassCastException - 如果 e 无法与此 set 中的当前元素进行比较
NullPointerException - 如果指定的元素为 null

remove

public boolean remove(Object o)
如果此 set 中存在指定的元素，则将其移除。更确切地讲，如果此 set 中包含满足 o.equals(e) 的元素 e，则移除该元素。如果此 set 包含该元素（或者此 set 由于调用而发生了更改），则返回 true。（一旦调用返回，则此 set 不再包含该元素。）

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 Set<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此 set 中移除的对象（如果存在）
返回：
如果此 set 中包含指定的元素，则返回 true
抛出：
ClassCastException - 如果 o 无法与此 set 中的当前元素进行比较
NullPointerException - 如果指定的元素为 null

clear

public void clear()
从此 set 中移除所有元素。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 Set<E> 中的 clear
覆盖：
类 AbstractCollection<E> 中的 clear

iterator

public Iterator<E> iterator()
返回在此 set 的元素上以升序进行迭代的迭代器。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 NavigableSet<E> 中的 iterator
指定者：
接口 Set<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此 set 的元素上以升序进行迭代的迭代器

descendingIterator

public Iterator<E> descendingIterator()
返回在此 set 的元素上以降序进行迭代的迭代器。

指定者：
接口 NavigableSet<E> 中的 descendingIterator
返回：
在此 set 的元素上以降序进行迭代的迭代器

equals

public boolean equals(Object o)
比较指定对象与此 set 的相等性。如果指定的对象也是一个 set，两个 set 的大小相同，并且指定 set 的所有成员都包含在此 set 中（或者此 set 的所有成员都包含在指定的 set 中），则返回 true。此定义确保了 equals 方法可在不同的 set 接口实现间正常工作。

指定者：
接口 Collection<E> 中的 equals
指定者：
接口 Set<E> 中的 equals
覆盖：
类 AbstractSet<E> 中的 equals
参数：
o - 要与此 set 进行相等性比较的对象
返回：
如果指定的对象等于此 set，则返回 true。
另请参见：
Object.hashCode(), Hashtable

removeAll

public boolean removeAll(Collection<?> c)
从此 set 中移除包含在指定 collection 中的所有元素。如果指定的 collection 也是一个 set，那么此操作将实际修改此 set，从而其值是两个 set 的一个不对称差集。

指定者：
接口 Collection<E> 中的 removeAll
指定者：
接口 Set<E> 中的 removeAll
覆盖：
类 AbstractSet<E> 中的 removeAll
参数：
c - 包含要从此 set 中移除的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果此 set 中一个或多个元素的类型与指定的 collection 不兼容
NullPointerException - 如果指定的 collection 或其任何元素为 null
另请参见：
AbstractCollection.remove(Object), AbstractCollection.contains(Object)

lower

public E lower(E e)
从接口 NavigableSet 复制的描述
返回此 set 中严格小于给定元素的最大元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 lower
参数：
e - 要匹配的值
返回：
小于 e 的最大元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定的元素为 null

floor

public E floor(E e)
从接口 NavigableSet 复制的描述
返回此 set 中小于等于给定元素的最大元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 floor
参数：
e - 要匹配的值
返回：
小于等于 e 的最大元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定的元素为 null

ceiling

public E ceiling(E e)
从接口 NavigableSet 复制的描述
返回此 set 中大于等于给定元素的最小元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 ceiling
参数：
e - 要匹配的值
返回：
大于等于 e 的最小元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定的元素为 null

higher

public E higher(E e)
从接口 NavigableSet 复制的描述
返回此 set 中严格大于给定元素的最小元素；如果不存在这样的元素，则返回 null。

指定者：
接口 NavigableSet<E> 中的 higher
参数：
e - 要匹配的值
返回：
大于 e 的最小元素；如果不存在这样的元素，则返回 null
抛出：
ClassCastException - 如果指定元素不能与 set 中的当前元素进行比较
NullPointerException - 如果指定的元素为 null

pollFirst

public E pollFirst()
从接口 NavigableSet 复制的描述
获取并移除第一个（最低）元素；如果此 set 为空，则返回 null。

指定者：
接口 NavigableSet<E> 中的 pollFirst
返回：
第一个元素；如果此 set 为空，则返回 null

pollLast

public E pollLast()
从接口 NavigableSet 复制的描述
获取并移除最后一个（最高）元素；如果此 set 为空，则返回 null。

指定者：
接口 NavigableSet<E> 中的 pollLast
返回：
最后一个元素；如果此 set 为空，则返回 null

comparator

public Comparator<? super E> comparator()
从接口 SortedSet 复制的描述
返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。

指定者：
接口 SortedSet<E> 中的 comparator
返回：
用来对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null

first

public E first()
从接口 SortedSet 复制的描述
返回此 set 中当前第一个（最低）元素。

指定者：
接口 SortedSet<E> 中的 first
返回：
此 set 中当前第一个（最低）元素
抛出：
NoSuchElementException - 如果此 set 为空

last

public E last()
从接口 SortedSet 复制的描述
返回此 set 中当前最后一个（最高）元素。

指定者：
接口 SortedSet<E> 中的 last
返回：
此 set 中当前最后一个（最高）元素
抛出：
NoSuchElementException - 如果此 set 为空

subSet

public NavigableSet<E> subSet(E fromElement,
                              boolean fromInclusive,
                              E toElement,
                              boolean toInclusive)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。如果 fromElement 和 toElement 相等，则返回的 set 为空，除非 fromExclusive 和 toExclusive 都为 true。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

指定者：
接口 NavigableSet<E> 中的 subSet
参数：
fromElement - 返回 set 的低端点
fromInclusive - 如果低端点要包含在返回的视图中，则为 true
toElement - 返回 set 的高端点
toInclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素范围从 fromElement（包括）到 toElement（不包括）
抛出：
ClassCastException - 如果不能使用此 set 的比较器或者使用自然顺序（如果 set 没有比较器）比较 fromElement 和 toElement。如果 fromElement 或 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 或 toElement 为 null
IllegalArgumentException - 如果 fromElement 大于 toElement；如果此 set 本身有范围限制，并且 fromElement 或 toElement 位于范围的边界之外。

headSet

public NavigableSet<E> headSet(E toElement,
                               boolean inclusive)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

指定者：
接口 NavigableSet<E> 中的 headSet
参数：
toElement - 返回 set 的高端点
inclusive - 如果高端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement
抛出：
ClassCastException - 如果 toElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 toElement 没有实现 Comparable）。如果 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toElement 为 null
IllegalArgumentException - 如果此 set 本身有范围限制，并且 toElement 位于范围的边界之外

tailSet

public NavigableSet<E> tailSet(E fromElement,
                               boolean inclusive)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

指定者：
接口 NavigableSet<E> 中的 tailSet
参数：
fromElement - 返回 set 的低端点
inclusive - 如果低端点要包含在返回的视图中，则为 true
返回：
此 set 的部分视图，其元素大于等于 fromElement
抛出：
ClassCastException - 如果 fromElement 与此 set 的比较器不兼容（如果 set 没有任何比较器；如果 fromElement 没有实现 Comparable）。如果 fromElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 为 null
IllegalArgumentException - 如果此 set 本身有范围限制，并且 fromElement 位于范围的边界之外

subSet

public NavigableSet<E> subSet(E fromElement,
                              E toElement)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。（如果 fromElement 和 toElement 相等，则返回空的 set）。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 subSet(fromElement, true, toElement, false)。

指定者：
接口 NavigableSet<E> 中的 subSet
指定者：
接口 SortedSet<E> 中的 subSet
参数：
fromElement - 返回 set 的低端点（包括）
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素的范围从 fromElement（包括）到 toElement（不包括）
抛出：
ClassCastException - 如果无法使用此 set 的比较器（如果 set 没有比较器，则使用自然顺序）比较 fromElement 和 toElement。如果 fromElement 或 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 或 toElement 为 null
IllegalArgumentException - 如果 fromElement 大于 toElement；如果此 set 本身有范围限制，并且 fromElement 或 toElement 位于范围的边界之外

headSet

public NavigableSet<E> headSet(E toElement)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素严格小于 toElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 headSet(toElement, false)。

指定者：
接口 NavigableSet<E> 中的 headSet
指定者：
接口 SortedSet<E> 中的 headSet
参数：
toElement - 返回 set 的高端点（不包括）
返回：
此 set 的部分视图，其元素严格小于 toElement
抛出：
ClassCastException - 如果 toElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 toElement 没有实现 Comparable）。如果 toElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 toElement 为 null
IllegalArgumentException - 如果此 set 本身有范围限制，并且 toElement 位于范围的边界之外

tailSet

public NavigableSet<E> tailSet(E fromElement)
从接口 NavigableSet 复制的描述
返回此 set 的部分视图，其元素大于等于 fromElement。返回的 set 受此 set 支持，所以在返回 set 中的更改将反映在此 set 中，反之亦然。返回的 set 支持此 set 支持的所有可选 set 操作。

如果试图在返回 set 的范围之外插入元素，则返回的 set 将抛出 IllegalArgumentException。

等效于 tailSet(fromElement, true)。

指定者：
接口 NavigableSet<E> 中的 tailSet
指定者：
接口 SortedSet<E> 中的 tailSet
参数：
fromElement - 返回 set 的低端点（包括）
返回：
此 set 的部分视图，其元素大于等于 fromElement
抛出：
ClassCastException - 如果 fromElement 与此 set 的比较器不兼容（如果 set 没有比较器；如果 fromElement 没有实现 Comparable）。如果 fromElement 不能与 set 中的当前元素进行比较，则实现可以（但不是必须）抛出此异常。
NullPointerException - 如果 fromElement 为 null
IllegalArgumentException - 如果此 set 本身有范围限制，并且 fromElement 位于范围的边界之外

descendingSet

public NavigableSet<E> descendingSet()
返回此 set 中所包含元素的逆序视图。降序 set 受此 set 的支持，因此对此 set 的更改将反映在降序 set 中，反之亦然。

返回 set 的顺序等于 Collections.reverseOrder(comparator())。表达式 s.descendingSet().descendingSet() 返回的 s 视图基本等效于 s。

指定者：
接口 NavigableSet<E> 中的 descendingSet
返回：
此 set 的逆序视图
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CountDownLatch (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 CountDownLatch

java.lang.Object
    继承者  java.util.concurrent.CountDownLatch

public class CountDownLatch
extends Object

一个同步辅助类，在完成一组正在其他线程中执行的操作之前，它允许一个或多个线程一直等待。

用给定的计数 初始化 CountDownLatch。由于调用了 countDown() 方法，所以在当前计数到达零之前，await 方法会一直受阻塞。之后，会释放所有等待的线程，await 的所有后续调用都将立即返回。这种现象只出现一次——计数无法被重置。如果需要重置计数，请考虑使用 CyclicBarrier。

CountDownLatch 是一个通用同步工具，它有很多用途。将计数 1 初始化的 CountDownLatch 用作一个简单的开/关锁存器，或入口：在通过调用 countDown() 的线程打开入口前，所有调用 await 的线程都一直在入口处等待。用 N 初始化的 CountDownLatch 可以使一个线程在 N 个线程完成某项操作之前一直等待，或者使其在某项操作完成 N 次之前一直等待。

CountDownLatch 的一个有用特性是，它不要求调用 countDown 方法的线程等到计数到达零时才继续，而在所有线程都能通过之前，它只是阻止任何线程继续通过一个 await。

示例用法： 下面给出了两个类，其中一组 worker 线程使用了两个倒计数锁存器：

  • 第一个类是一个启动信号，在 driver 为继续执行 worker 做好准备之前，它会阻止所有的 worker 继续执行。
  • 第二个类是一个完成信号，它允许 driver 在完成所有 worker 之前一直等待。
 class Driver { // ...
   void main() throws InterruptedException {
     CountDownLatch startSignal = new CountDownLatch(1);
     CountDownLatch doneSignal = new CountDownLatch(N);

     for (int i = 0; i < N; ++i) // create and start threads
       new Thread(new Worker(startSignal, doneSignal)).start();

     doSomethingElse();            // don't let run yet
     startSignal.countDown();      // let all threads proceed
     doSomethingElse();
     doneSignal.await();           // wait for all to finish
   }
 }

 class Worker implements Runnable {
   private final CountDownLatch startSignal;
   private final CountDownLatch doneSignal;
   Worker(CountDownLatch startSignal, CountDownLatch doneSignal) {
      this.startSignal = startSignal;
      this.doneSignal = doneSignal;
   }
   public void run() {
      try {
        startSignal.await();
        doWork();
        doneSignal.countDown();
} catch (InterruptedException ex) {} // return;
   }

   void doWork() { ... }
 }

另一种典型用法是，将一个问题分成 N 个部分，用执行每个部分并让锁存器倒计数的 Runnable 来描述每个部分，然后将所有 Runnable 加入到 Executor 队列。当所有的子部分完成后，协调线程就能够通过 await。（当线程必须用这种方法反复倒计数时，可改为使用 CyclicBarrier。）

 class Driver2 { // ...
   void main() throws InterruptedException {
     CountDownLatch doneSignal = new CountDownLatch(N);
     Executor e = ...

     for (int i = 0; i < N; ++i) // create and start threads
       e.execute(new WorkerRunnable(doneSignal, i));

     doneSignal.await();           // wait for all to finish
   }
 }

 class WorkerRunnable implements Runnable {
   private final CountDownLatch doneSignal;
   private final int i;
   WorkerRunnable(CountDownLatch doneSignal, int i) {
      this.doneSignal = doneSignal;
      this.i = i;
   }
   public void run() {
      try {
        doWork(i);
        doneSignal.countDown();
      } catch (InterruptedException ex) {} // return;
   }

   void doWork() { ... }
 }

内存一致性效果：线程中调用 countDown() 之前的操作 happen-before 紧跟在从另一个线程中对应 await() 成功返回的操作。

从以下版本开始：
1.5

构造方法摘要
CountDownLatch(int count)
构造一个用给定计数初始化的 CountDownLatch。
方法摘要
void | await() 使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断。
boolean | await(long timeout, TimeUnit unit) 使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。
void | countDown() 递减锁存器的计数，如果计数到达零，则释放所有等待的线程。
long | getCount() 返回当前计数。
String | toString() 返回标识此锁存器及其状态的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CountDownLatch

public CountDownLatch(int count)
构造一个用给定计数初始化的 CountDownLatch。

参数：
count - 在线程能通过 await() 之前，必须调用 countDown() 的次数
抛出：
IllegalArgumentException - 如果 count 为负
方法详细信息

await

public void await()
           throws InterruptedException
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断。

如果当前计数为零，则此方法立即返回。

如果当前计数大于零，则出于线程调度目的，将禁用当前线程，且在发生以下两种情况之一前，该线程将一直处于休眠状态：

  • 由于调用 countDown() 方法，计数到达零；或者
  • 其他某个线程中断当前线程。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在等待时被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。

抛出：
InterruptedException - 如果当前线程在等待时被中断

await

public boolean await(long timeout,
                     TimeUnit unit)
              throws InterruptedException
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。

如果当前计数为零，则此方法立刻返回 true 值。

如果当前计数大于零，则出于线程调度目的，将禁用当前线程，且在发生以下三种情况之一前，该线程将一直处于休眠状态：

  • 由于调用 countDown() 方法，计数到达零；或者
  • 其他某个线程中断当前线程；或者
  • 已超出指定的等待时间。

如果计数到达零，则该方法返回 true 值。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在等待时被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果超出了指定的等待时间，则返回值为 false。如果该时间小于等于零，则此方法根本不会等待。

参数：
timeout - 要等待的最长时间
unit - timeout 参数的时间单位。
返回：
如果计数到达零，则返回 true；如果在计数到达零之前超过了等待时间，则返回 false
抛出：
InterruptedException - 如果当前线程在等待时被中断

countDown

public void countDown()
递减锁存器的计数，如果计数到达零，则释放所有等待的线程。

如果当前计数大于零，则将计数减少。如果新的计数为零，出于线程调度目的，将重新启用所有的等待线程。

如果当前计数等于零，则不发生任何操作。

getCount

public long getCount()
返回当前计数。

此方法通常用于调试和测试。

返回：
当前计数

toString

public String toString()
返回标识此锁存器及其状态的字符串。状态用括号括起来，包括字符串 "Count ="，后跟当前计数。

覆盖：
类 Object 中的 toString
返回：
标识此锁存器及其状态的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CopyOnWriteArrayList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 CopyOnWriteArrayList<E>

java.lang.Object
    继承者  java.util.concurrent.CopyOnWriteArrayList<E>
类型参数：
E - 此 collection 中所保存元素的类型
所有已实现的接口：
Serializable, Cloneable, Iterable<E>, Collection<E>, List<E>, RandomAccess
public class CopyOnWriteArrayList<E>
extends Object
implements List<E>, RandomAccess, Cloneable, Serializable

ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

这一般需要很大的开销，但是当遍历操作的数量大大超过可变操作的数量时，这种方法可能比其他替代方法更 有效。在不能或不想进行同步遍历，但又需要从并发线程中排除冲突时，它也很有用。“快照”风格的迭代器方法在创建迭代器时使用了对数组状态的引用。此数组在迭代器的生存期内不会更改，因此不可能发生冲突，并且迭代器保证不会抛出 ConcurrentModificationException。创建迭代器以后，迭代器就不会反映列表的添加、移除或者更改。在迭代器上进行的元素更改操作（remove、set 和 add）不受支持。这些方法将抛出 UnsupportedOperationException。

允许使用所有元素，包括 null。

内存一致性效果：当存在其他并发 collection 时，将对象放入 CopyOnWriteArrayList 之前的线程中的操作 happen-before 随后通过另一线程从 CopyOnWriteArrayList 中访问或移除该元素的操作。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
CopyOnWriteArrayList()
创建一个空列表。
CopyOnWriteArrayList(Collection<? extends E> c)
创建一个按 collection 的迭代器返回元素的顺序包含指定 collection 元素的列表。
CopyOnWriteArrayList(E[] toCopyIn)
创建一个保存给定数组的副本的列表。
方法摘要
 boolean add(E e)
将指定元素添加到此列表的尾部。
 void add(int index, E element)
在此列表的指定位置上插入指定元素。
 boolean addAll(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中的所有元素添加此列表的尾部。
 boolean addAll(int index, Collection<? extends E> c)
从指定位置开始，将指定 collection 的所有元素插入此列表。
 int addAllAbsent(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中尚未包含在此列表中的所有元素添加列表的尾部。
 boolean addIfAbsent(E e)
添加元素（如果不存在）。
 void clear()
从此列表移除所有元素。
 Object clone()
返回此列表的浅表副本。
 boolean contains(Object o)
如果此列表包含指定的元素，则返回 true。
 boolean containsAll(Collection<?> c)
如果此列表包含指定 collection 的所有元素，则返回 true。
 boolean equals(Object o)
比较指定对象与此列表的相等性。
 E get(int index)
返回列表中指定位置的元素。
 int hashCode()
返回此列表的哈希码值。
 int indexOf(E e, int index)
返回第一次出现的指定元素在此列表中的索引，从 index 开始向前搜索，如果没有找到该元素，则返回 -1。
 int indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。
 boolean isEmpty()
如果此列表不包含任何元素，则返回 true。
 Iterator<E> iterator()
返回以恰当顺序在此列表元素上进行迭代的迭代器。
 int lastIndexOf(E e, int index)
返回最后一次出现的指定元素在此列表中的索引，从 index 开始向后搜索，如果没有找到该元素，则返回 -1。
 int lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。
 ListIterator<E> listIterator()
返回此列表元素的列表迭代器（按适当顺序）。
 ListIterator<E> listIterator(int index)
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
 E remove(int index)
移除此列表指定位置上的元素。
 boolean remove(Object o)
从此列表移除第一次出现的指定元素（如果存在）。
 boolean removeAll(Collection<?> c)
从此列表移除所有包含在指定 collection 中的元素。
 boolean retainAll(Collection<?> c)
只保留此列表中包含在指定 collection 中的元素。
 E set(int index, E element)
用指定的元素替代此列表指定位置上的元素。
 int size()
返回此列表中的元素数。
 List<E> subList(int fromIndex, int toIndex)
返回此列表中 fromIndex（包括）和 toIndex（不包括）之间部分的视图。
 Object[] toArray()
返回一个按恰当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。
<T> T[]
toArray(T[] a)
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
 String toString()
返回此列表的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CopyOnWriteArrayList

public CopyOnWriteArrayList()
创建一个空列表。

CopyOnWriteArrayList

public CopyOnWriteArrayList(Collection<? extends E> c)
创建一个按 collection 的迭代器返回元素的顺序包含指定 collection 元素的列表。

参数：
c - 最初保存元素的 collection
抛出：
NullPointerException - 如果指定 collection 为 null

CopyOnWriteArrayList

public CopyOnWriteArrayList(E[] toCopyIn)
创建一个保存给定数组的副本的列表。

参数：
toCopyIn - 数组（将此数组的副本用作内部数组）
抛出：
NullPointerException - 如果指定数组为 null
方法详细信息

size

public int size()
返回此列表中的元素数。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 List<E> 中的 size
返回：
此列表中的元素数

isEmpty

public boolean isEmpty()
如果此列表不包含任何元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
指定者：
接口 List<E> 中的 isEmpty
返回：
如果此列表不包含任何元素，则返回 true

contains

public boolean contains(Object o)
如果此列表包含指定的元素，则返回 true。更确切地讲，当且仅当此列表包含至少一个满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 List<E> 中的 contains
参数：
o - 测试是否存在于此列表中的元素。
返回：
如果此列表包含指定元素，则返回 true

indexOf

public int indexOf(Object o)
返回此列表中第一次出现的指定元素的索引；如果此列表不包含该元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i；如果没有这样的索引，则返回 -1。

指定者：
接口 List<E> 中的 indexOf
参数：
o - 要搜索的元素
返回：
此列表中第一次出现的指定元素的索引，如果列表不包含该元素，则返回 -1

indexOf

public int indexOf(E e,
                   int index)
返回第一次出现的指定元素在此列表中的索引，从 index 开始向前搜索，如果没有找到该元素，则返回 -1。更确切地讲，返回满足 (i >= index && (e==null ? get(i)==null : e.equals(get(i)))) 的最低索引 i，如果不存在这样的索引，则返回 -1。

参数：
e - 要搜索的元素
index - 搜索开始处的索引
返回：
此列表中 index 或其后的位置上第一次出现该元素的位置索引；如果未找到该元素，则返回 -1。
抛出：
IndexOutOfBoundsException - 如果指定索引为负

lastIndexOf

public int lastIndexOf(Object o)
返回此列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1。更确切地讲，返回满足 (o==null ? get(i)==null : o.equals(get(i))) 的最高索引 i；如果没有这样的索引，则返回 -1。

指定者：
接口 List<E> 中的 lastIndexOf
参数：
o - 要搜索的元素
返回：
列表中最后出现的指定元素的索引；如果列表不包含此元素，则返回 -1

lastIndexOf

public int lastIndexOf(E e,
                       int index)
返回最后一次出现的指定元素在此列表中的索引，从 index 开始向后搜索，如果没有找到该元素，则返回 -1。更确切地讲，返回满足 (i <= index && (e==null ? get(i)==null : e.equals(get(i)))) 的最高索引 i，如果不存在这样的索引，则返回 -1。

参数：
e - 要搜索的元素
index - 开始向后搜索处的索引
返回：
此列表中小于等于 index 的位置上最后一次出现该元素的位置索引；如果未找到该元素，则返回 -1。
抛出：
IndexOutOfBoundsException - 如果指定索引大于等于此列表的当前大小

clone

public Object clone()
返回此列表的浅表副本。（这些元素本身未被复制。）

覆盖：
类 Object 中的 clone
返回：
此列表的一个副本
另请参见：
Cloneable

toArray

public Object[] toArray()
返回一个按恰当顺序（从第一个元素到最后一个元素）包含此列表中所有元素的数组。

由于此列表并不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
返回：
返回包含此列表所有元素的数组
另请参见：
Arrays.asList(Object[])

toArray

public <T> T[] toArray(T[] a)
返回以恰当顺序（从第一个元素到最后一个元素）包含列表所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。如果指定数组能容纳列表，则则将该队列返回此处。否则，将分配一个具有指定数组的运行时类型和此列表的大小的新数组。

如果指定的数组能容纳列表，并有剩余的空间（即数组的元素比列表多），那么会将紧接列表尾部的元素设置为 null。（仅 当调用者知道此列表不包含任何 null 元素时，才可使用此方法来确定此列表的长度。）

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，这可以用来节省分配开销。

假定 x 是只包含字符串的一个已知列表。以下代码用来将该列表转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 List<E> 中的 toArray
参数：
a - 要存储列表元素的数组（如果该数组足够大）；否则，将分配一个具有相同运行时类型的新数组。
返回：
包含此列表所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此列表每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

get

public E get(int index)
返回列表中指定位置的元素。

指定者：
接口 List<E> 中的 get
参数：
index - 要返回的元素的索引
返回：
列表中指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

set

public E set(int index,
             E element)
用指定的元素替代此列表指定位置上的元素。

指定者：
接口 List<E> 中的 set
参数：
index - 要替换的元素的索引
element - 要在指定位置存储的元素
返回：
以前在指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

add

public boolean add(E e)
将指定元素添加到此列表的尾部。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 List<E> 中的 add
参数：
e - 要添加到此列表的元素。
返回：
true（根据 Collection.add(E) 的规定）

add

public void add(int index,
                E element)
在此列表的指定位置上插入指定元素。将当前在该位置上的元素（如果有）以及所有后续元素向右移（其索引加 1）。

指定者：
接口 List<E> 中的 add
参数：
index - 要在其中插入指定元素处的索引
element - 要插入的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

remove

public E remove(int index)
移除此列表指定位置上的元素。将所有后续元素都向左移（其索引减 1）。返回从此列表中移除的元素。

指定者：
接口 List<E> 中的 remove
参数：
index - 要移除的元素的索引
返回：
以前在指定位置的元素
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index >= size())

remove

public boolean remove(Object o)
从此列表移除第一次出现的指定元素（如果存在）。 如果列表不包含这样的元素，则不更改列表。更确切地讲，移除具有满足 (o==null ? get(i)==null : o.equals(get(i))) 的最低索引 i 的元素（如果存在这样的元素）。如果此列表包含指定元素（或者此列表由于调用而发生更改），则返回 true。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 List<E> 中的 remove
参数：
o - 要从此列表移除的元素（如果存在）
返回：
如果此列表包含指定的元素，则返回 true

addIfAbsent

public boolean addIfAbsent(E e)
添加元素（如果不存在）。

参数：
e - 要添加到此列表中的元素（如果不存在）
返回：
如果已添加该元素，则返回 true

containsAll

public boolean containsAll(Collection<?> c)
如果此列表包含指定 collection 的所有元素，则返回 true。

指定者：
接口 Collection<E> 中的 containsAll
指定者：
接口 List<E> 中的 containsAll
参数：
c - 将被检查是否包含于此列表的 collection
返回：
如果此列表包含指定 collection 的所有元素，则返回 true
抛出：
NullPointerException - 如果指定 collection 为 null
另请参见：
contains(Object)

removeAll

public boolean removeAll(Collection<?> c)
从此列表移除所有包含在指定 collection 中的元素。在此类中，这是一个开销很大的操作，因为它需要一个内部临时数组。

指定者：
接口 Collection<E> 中的 removeAll
指定者：
接口 List<E> 中的 removeAll
参数：
c - 包含将从此列表中移除的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果此列表的元素与指定 collection 不兼容（可选）
NullPointerException - 如果此列表包含一个 null 元素，并且指定 collection 不允许使用 null 元素（可选），或者指定 collection 为 null
另请参见：
remove(Object)

retainAll

public boolean retainAll(Collection<?> c)
只保留此列表中包含在指定 collection 中的元素。换句话说，从此列表中移除所有未包含在指定 collection 中的元素。

指定者：
接口 Collection<E> 中的 retainAll
指定者：
接口 List<E> 中的 retainAll
参数：
c - 包含保留在此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果此列表的元素的类与指定 collection 不兼容（可选）
NullPointerException - 如果此列表包含一个 null 元素，并且指定 collection 不允许使用 null 元素（可选），或者指定 collection 为 null
另请参见：
remove(Object)

addAllAbsent

public int addAllAbsent(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中尚未包含在此列表中的所有元素添加列表的尾部。

参数：
c - 包含要添加到此列表中的元素的 collection
返回：
添加的元素数量
抛出：
NullPointerException - 如果指定 collection 为 null
另请参见：
addIfAbsent(Object)

clear

public void clear()
从此列表移除所有元素。此调用返回之后，该列表将为空。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 List<E> 中的 clear

addAll

public boolean addAll(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中的所有元素添加此列表的尾部。

指定者：
接口 Collection<E> 中的 addAll
指定者：
接口 List<E> 中的 addAll
参数：
c - 包含将插入此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
NullPointerException - 如果指定 collection 为 null
另请参见：
add(Object)

addAll

public boolean addAll(int index,
                      Collection<? extends E> c)
从指定位置开始，将指定 collection 的所有元素插入此列表。将当前在该位置上的元素（如果有）以及所有后续元素都向右移（其索引加 1）。新元素将按指定 collection 的迭代器返回的顺序出现在列表中。

指定者：
接口 List<E> 中的 addAll
参数：
index - 插入指定 collection 中第一个元素的索引
c - 包含将添加到此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
抛出：
NullPointerException - 如果指定的 collection 包含一个或多个 null 元素，并且该列表不允许 null 元素，或者指定的 collection 为 null
NullPointerException - 如果指定 collection 为 null
另请参见：
add(int,Object)

toString

public String toString()
返回此列表的字符串表示形式。该字符串表示形式由列表元素的字符串表示形式组成，这些元素按其迭代器返回的顺序排序，并用方括号 ("[]") 括起来。相邻元素由字符 ", "（逗号加空格）分隔。通过 String.valueOf(Object) 可以将元素转换成字符串。

覆盖：
类 Object 中的 toString
返回：
此列表的字符串表示形式

equals

public boolean equals(Object o)
比较指定对象与此列表的相等性。如果指定对象与此对象是同一对象，或者它也是一个 List，并且在指定列表上迭代的迭代器所返回的元素的序列与在此列表上迭代的迭代器所返回的元素序列相同，则返回 true。如果两个序列具有相同的长度，并且对应元素在序列的同一位置上，则认为两个序列是相等的。满足 (e1==null ? e2==null : e1.equals(e2)) 的两个元素 e1 和 e2 视为相等。

指定者：
接口 Collection<E> 中的 equals
指定者：
接口 List<E> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 将与此列表进行相等性比较的对象
返回：
如果指定的对象与此列表相等，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此列表的哈希码值。

此实现使用了 List.hashCode() 中的定义。

指定者：
接口 Collection<E> 中的 hashCode
指定者：
接口 List<E> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此列表的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

iterator

public Iterator<E> iterator()
返回以恰当顺序在此列表元素上进行迭代的迭代器。

构造该迭代器时，所返回的迭代器提供了列表状态的一个快照。遍历该迭代器时不需要执行任何同步。该迭代器不 支持 remove 方法。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 List<E> 中的 iterator
返回：
以恰当顺序在此列表元素上进行迭代的迭代器

listIterator

public ListIterator<E> listIterator()
返回此列表元素的列表迭代器（按适当顺序）。

在构造该迭代器时，返回的迭代器提供了列表状态的一个快照。遍历该迭代器时不需要执行任何同步。该迭代器不 支持 remove、set 或者 add 方法。

指定者：
接口 List<E> 中的 listIterator
返回：
此列表元素的列表迭代器（按适当顺序）

listIterator

public ListIterator<E> listIterator(int index)
返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。指定的索引表示 next 的初始调用所返回的第一个元素。previous 方法的初始调用将返回索引比指定索引少 1 的元素。

在构造该迭代器时，返回的迭代器提供了列表状态的一个快照。遍历该迭代器时不需要执行任何同步。该迭代器不 支持 remove、set 或者 add 方法。

指定者：
接口 List<E> 中的 listIterator
参数：
index - 从列表迭代器返回的第一个元素的索引（通过调用 next 方法）
返回：
此列表中元素的列表迭代器（按适当顺序），从列表中的指定位置开始
抛出：
IndexOutOfBoundsException - 如果索引超出范围 (index < 0 || index > size())

subList

public List<E> subList(int fromIndex,
                       int toIndex)
返回此列表中 fromIndex（包括）和 toIndex（不包括）之间部分的视图。返回的列表受此列表的支持，因此返回列表中的更改将反映在此列表中，反之亦然。当支持可变操作时，它们对于 CopyOnWriteArrayLists 可能不是很有用。

如果通过返回列表以外的其他任何方式从结构上修改 底层实现列表（即此列表），则此方法返回的列表语义将是不确定的。（从结构上修改是指更改列表的大小，或者以其他方式打乱列表，使正在进行的迭代生成错误的结果。）

指定者：
接口 List<E> 中的 subList
参数：
fromIndex - subList 的低端点（包括）
toIndex - subList 的高端点（不包括）
返回：
此列表中指定范围的视图
抛出：
IndexOutOfBoundsException - 非法的端点值 (fromIndex < 0 || toIndex > size || fromIndex > toIndex)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CopyOnWriteArraySet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 CopyOnWriteArraySet<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
            继承者  java.util.concurrent.CopyOnWriteArraySet<E>
类型参数：
E - 此 collection 中所保存元素的类型
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, Set<E>
public class CopyOnWriteArraySet<E>
extends AbstractSet<E>
implements Serializable

对其所有操作使用内部 CopyOnWriteArrayList 的 Set。因此，它共享以下相同的基本属性：

  • 它最适合于具有以下特征的应用程序：set 大小通常保持很小，只读操作远多于可变操作，需要在遍历期间防止线程间的冲突。
  • 它是线程安全的。
  • 因为通常需要复制整个基础数组，所以可变操作（add、set 和 remove 等等）的开销很大。
  • 迭代器不支持可变 remove 操作。
  • 使用迭代器进行遍历的速度很快，并且不会与其他线程发生冲突。在构造迭代器时，迭代器依赖于不变的数组快照。

示例用法。 以下代码使用一个写时复制（copy-on-write）的 set，以维护在状态更新时执行某项操作的一组 Handler 对象。

 class Handler { void handle(); ... }

 class X {
    private final CopyOnWriteArraySet<Handler> handlers = new CopyOnWriteArraySet<Handler>();
    public void addHandler(Handler h) { handlers.add(h); }

    private long internalState;
    private synchronized void changeState() { internalState = ...; }

    public void update() {
       changeState();
       for (Handler handler : handlers)
           handler.handle();
    }
 }

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
CopyOnWriteArrayList, 序列化表格

构造方法摘要
CopyOnWriteArraySet()
创建一个空 set。
CopyOnWriteArraySet(Collection<? extends E> c)
创建一个包含指定 collection 所有元素的 set。
方法摘要
 boolean add(E e)
如果指定元素并不存在于此 set 中，则添加它。
 boolean addAll(Collection<? extends E> c)
如果此 set 中没有指定 collection 中的所有元素，则将它们都添加到此 set 中。
 void clear()
移除此 set 中的所有元素。
 boolean contains(Object o)
如果此 set 包含指定元素，则返回 true。
 boolean containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。
 boolean equals(Object o)
比较指定对象与此 set 的相等性。
 boolean isEmpty()
如果此 set 不包含任何元素，则返回 true。
 Iterator<E> iterator()
返回按照元素添加顺序在此 set 中包含的元素上进行迭代的迭代器。
 boolean remove(Object o)
如果指定元素存在于此 set 中，则将其移除。
 boolean removeAll(Collection<?> c)
移除此 set 中包含在指定 collection 中的所有元素。
 boolean retainAll(Collection<?> c)
仅保留此 set 中那些包含在指定 collection 中的元素。
 int size()
返回此 set 中的元素数目。
 Object[] toArray()
返回一个包含此 set 所有元素的数组。
<T> T[]
toArray(T[] a)
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。
从类 java.util.AbstractSet 继承的方法
hashCode
从类 java.util.AbstractCollection 继承的方法
toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CopyOnWriteArraySet

public CopyOnWriteArraySet()
创建一个空 set。

CopyOnWriteArraySet

public CopyOnWriteArraySet(Collection<? extends E> c)
创建一个包含指定 collection 所有元素的 set。

参数：
c - 最初包含元素的 collection
抛出：
NullPointerException - 如果指定 collection 为 null
方法详细信息

size

public int size()
返回此 set 中的元素数目。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 Set<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此 set 中的元素数

isEmpty

public boolean isEmpty()
如果此 set 不包含任何元素，则返回 true。

指定者：
接口 Collection<E> 中的 isEmpty
指定者：
接口 Set<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
如果此 set 不包含任何元素，则返回 true

contains

public boolean contains(Object o)
如果此 set 包含指定元素，则返回 true。更确切地讲，当且仅当此 set 包含满足 (o==null ? e==null : o.equals(e)) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 Set<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 将测试其是否存在于此 set 中的元素
返回：
如果此 set 包含指定元素，则返回 true

toArray

public Object[] toArray()
返回一个包含此 set 所有元素的数组。如果此 set 对其迭代器返回的元素的顺序做出了某些保证，那么此方法必须以相同的顺序返回这些元素。

不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，即使 set 受到数组的支持，此方法也必须分配一个新的数组）。因此，调用这可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 Set<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此 set 所有元素的数组

toArray

public <T> T[] toArray(T[] a)
返回一个包含此 set 所有元素的数组；返回数组的运行时类型是指定数组的类型。如果指定的数组能容纳该 set，则将 set 返回此处。否则，将分配一个具有指定数组的运行时类型和此 set 大小的新数组。

如果指定的数组能容纳 set，并有剩余的空间（即数组的元素比 set 多），那么会将接 set 尾部的元素设置为 null。（仅 当调用者知道此 set 不包含任何 null 元素时，才可使用此方法来确定此 set 的长度。）

如果此 set 对其迭代器返回的元素顺序做出了某些保证，那么此方法必须以相同的顺序返回这些元素。

像 toArray() 方法一样，此方法充当基于数组 的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知 set。以下代码用来将该 set 转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
指定者：
接口 Set<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
存储此 - set 元素的数组（如果该数组足够大）；否则为此分配一个具有相同运行时类型的新数组
返回：
包含此 set 所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此 set 每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

clear

public void clear()
移除此 set 中的所有元素。在此调用返回之后，set 将为空。

指定者：
接口 Collection<E> 中的 clear
指定者：
接口 Set<E> 中的 clear
覆盖：
类 AbstractCollection<E> 中的 clear

remove

public boolean remove(Object o)
如果指定元素存在于此 set 中，则将其移除。更确切地讲，如果此 set 中包含满足 (o==null ? e==null : o.equals(e)) 的元素 e，则移除它。如果此 set 包含指定元素（或者此 set 由于调用而发生更改），则返回 true。（调用返回后，则此 set 便不再包含这样的元素。）

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 Set<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此 set 移除的对象（如果存在）
返回：
如果此 set 包含指定元素，则返回 true

add

public boolean add(E e)
如果指定元素并不存在于此 set 中，则添加它。更确切地讲，如果此 set 不包含满足 (e==null ? e2==null : e.equals(e2)) 的元素 e2，则将指定元素 e 添加到此 set 中。如果此 set 已经包含这样的元素，则该调用不改变此 set 并返回 false。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 Set<E> 中的 add
覆盖：
类 AbstractCollection<E> 中的 add
参数：
e - 要添加到此 set 的元素
返回：
如果此 set 并未包含指定元素，则返回 true

containsAll

public boolean containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。如果指定的 collection 也是一个 set，那么当该 collection 是此 set 的子集 时，此方法返回 true。

指定者：
接口 Collection<E> 中的 containsAll
指定者：
接口 Set<E> 中的 containsAll
覆盖：
类 AbstractCollection<E> 中的 containsAll
参数：
c - 将被检查是否存在于此 set 的 collection
返回：
如果此 set 包含指定 collection 的所有元素，则返回 true
抛出：
NullPointerException - 如果指定 collection 为 null
另请参见：
contains(Object)

addAll

public boolean addAll(Collection<? extends E> c)
如果此 set 中没有指定 collection 中的所有元素，则将它们都添加到此 set 中。如果指定的 collection 也是一个 set，则 addAll 操作会实际修改此 set，从而它的值是两个 set 的一个并集。如果指定 collection 在操作过程中被修改，则此操作的行为是不确定的。

指定者：
接口 Collection<E> 中的 addAll
指定者：
接口 Set<E> 中的 addAll
覆盖：
类 AbstractCollection<E> 中的 addAll
参数：
c - 包含将添加到此 set 中的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
NullPointerException - 如果指定 collection 为 null
另请参见：
add(Object)

removeAll

public boolean removeAll(Collection<?> c)
移除此 set 中包含在指定 collection 中的所有元素。如果指定的 collection 也是一个 set，则此操作会实际修改此 set，从而其值是两个 set 的一个不对称差集。

指定者：
接口 Collection<E> 中的 removeAll
指定者：
接口 Set<E> 中的 removeAll
覆盖：
类 AbstractSet<E> 中的 removeAll
参数：
c - 包含将从此 set 中移除的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果此 set 的元素的类与指定 collection 不兼容（可选）
NullPointerException - 如果此 set 包含一个 null 元素并且指定 collection 不允许使用 null 元素（可选），或者指定 collection 为 null
另请参见：
remove(Object)

retainAll

public boolean retainAll(Collection<?> c)
仅保留此 set 中那些包含在指定 collection 中的元素。换句话说，移除此 set 中所有未包含在指定 collection 中的元素。如果指定的 collection 也是一个 set，则此操作会实际修改此 set，这样其值是两个 set 的一个交集。

指定者：
接口 Collection<E> 中的 retainAll
指定者：
接口 Set<E> 中的 retainAll
覆盖：
类 AbstractCollection<E> 中的 retainAll
参数：
c - 包含保留在此 set 中的元素的 collection
返回：
如果此 set 由于调用而发生更改，则返回 true
抛出：
ClassCastException - 如果此 set 的元素的类与指定 collection 不兼容（可选）
NullPointerException - 如果此 set 包含一个 null 元素并且指定 collection 不允许使用 null 元素（可选），或者指定 collection 为 null
另请参见：
remove(Object)

iterator

public Iterator<E> iterator()
返回按照元素添加顺序在此 set 中包含的元素上进行迭代的迭代器。

在构造迭代器时，返回的迭代器提供该 set 的状态的快照。在遍历迭代器时无需同步。该迭代器不 支持 remove 方法。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 Set<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此 set 中的元素上进行迭代的迭代器

equals

public boolean equals(Object o)
比较指定对象与此 set 的相等性。如果指定对象与此对象是同一对象，则返回 true，如果它也是一个 Set 并且在指定 set 上迭代的迭代器所返回的元素序列与在此 set 上进行迭代迭代器所返回的元素的序列相同。更确切地讲，如果两个迭代器返回相同的元素数，并且对于在指定 set 上进行迭代的迭代器返回的每个元素 e1 而言，都有一个由在此 set 上进行迭代的迭代器返回的元素 e2，且该元素满足 (e1==null ? e2==null : e1.equals(e2))，则认为两个迭代器将返回相同的元素。

指定者：
接口 Collection<E> 中的 equals
指定者：
接口 Set<E> 中的 equals
覆盖：
类 AbstractSet<E> 中的 equals
参数：
o - 将与此 set 进行相等性比较的对象
返回：
如果指定的对象与此 set 相等，则返回 true
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CyclicBarrier (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 CyclicBarrier

java.lang.Object
    继承者  java.util.concurrent.CyclicBarrier

public class CyclicBarrier
extends Object

一个同步辅助类，它允许一组线程互相等待，直到到达某个公共屏障点 (common barrier point)。在涉及一组固定大小的线程的程序中，这些线程必须不时地互相等待，此时 CyclicBarrier 很有用。因为该 barrier 在释放等待线程后可以重用，所以称它为循环 的 barrier。

CyclicBarrier 支持一个可选的 Runnable 命令，在一组线程中的最后一个线程到达之后（但在释放所有线程之前），该命令只在每个屏障点运行一次。若在继续所有参与线程之前更新共享状态，此屏障操作 很有用。

示例用法：下面是一个在并行分解设计中使用 barrier 的例子：

 class Solver {
   final int N;
   final float[][] data;
   final CyclicBarrier barrier;

   class Worker implements Runnable {
     int myRow;
     Worker(int row) { myRow = row; }
     public void run() {
       while (!done()) {
         processRow(myRow);

         try {
           barrier.await();
         } catch (InterruptedException ex) {
return;
         } catch (BrokenBarrierException ex) {
return;
         }
       }
     }
   }

   public Solver(float[][] matrix) {
     data = matrix;
     N = matrix.length;
     barrier = new CyclicBarrier(N,
                                 new Runnable() {
                                   public void run() {
                                     mergeRows(...);
                                   }
                                 });
     for (int i = 0; i < N; ++i)
       new Thread(new Worker(i)).start();

     waitUntilDone();
   }
 }
在这个例子中，每个 worker 线程处理矩阵的一行，在处理完所有的行之前，该线程将一直在屏障处等待。处理完所有的行之后，将执行所提供的 Runnable 屏障操作，并合并这些行。如果合并者确定已经找到了一个解决方案，那么 done() 将返回 true，所有的 worker 线程都将终止。

如果屏障操作在执行时不依赖于正挂起的线程，则线程组中的任何线程在获得释放时都能执行该操作。为方便此操作，每次调用 await() 都将返回能到达屏障处的线程的索引。然后，您可以选择哪个线程应该执行屏障操作，例如：

  if (barrier.await() == 0) {
     // log the completion of this iteration
   }

对于失败的同步尝试，CyclicBarrier 使用了一种要么全部要么全不 (all-or-none) 的破坏模式：如果因为中断、失败或者超时等原因，导致线程过早地离开了屏障点，那么在该屏障点等待的其他所有线程也将通过 BrokenBarrierException（如果它们几乎同时被中断，则用 InterruptedException）以反常的方式离开。

内存一致性效果：线程中调用 await() 之前的操作 happen-before 那些是屏障操作的一部份的操作，后者依次 happen-before 紧跟在从另一个线程中对应 await() 成功返回的操作。

从以下版本开始：
1.5
另请参见：
CountDownLatch

构造方法摘要
CyclicBarrier(int parties)
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，但它不会在启动 barrier 时执行预定义的操作。
CyclicBarrier(int parties, Runnable barrierAction)
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，并在启动 barrier 时执行给定的屏障操作，该操作由最后一个进入 barrier 的线程执行。
方法摘要
int | await() 在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。
int | await(long timeout, TimeUnit unit) 在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
int | getNumberWaiting() 返回当前在屏障处等待的参与者数目。
int | getParties() 返回要求启动此 barrier 的参与者数目。
boolean | isBroken() 查询此屏障是否处于损坏状态。
void | reset() 将屏障重置为其初始状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CyclicBarrier

public CyclicBarrier(int parties,
                     Runnable barrierAction)
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，并在启动 barrier 时执行给定的屏障操作，该操作由最后一个进入 barrier 的线程执行。

参数：
parties - 在启动 barrier 前必须调用 await() 的线程数
barrierAction - 在启动 barrier 时执行的命令；如果不执行任何操作，则该参数为 null
抛出：
IllegalArgumentException - 如果 parties 小于 1

CyclicBarrier

public CyclicBarrier(int parties)
创建一个新的 CyclicBarrier，它将在给定数量的参与者（线程）处于等待状态时启动，但它不会在启动 barrier 时执行预定义的操作。

参数：
parties - 在启动 barrier 前必须调用 await() 的线程数
抛出：
IllegalArgumentException - 如果 parties 小于 1
方法详细信息

getParties

public int getParties()
返回要求启动此 barrier 的参与者数目。

返回：
要求启动此 barrier 的参与者数目

await

public int await()
          throws InterruptedException,
                 BrokenBarrierException
在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。

如果当前线程不是将到达的最后一个线程，出于调度目的，将禁用它，且在发生以下情况之一前，该线程将一直处于休眠状态：

  • 最后一个线程到达；或者
  • 其他某个线程中断当前线程；或者
  • 其他某个线程中断另一个等待线程；或者
  • 其他某个线程在等待 barrier 时超时；或者
  • 其他某个线程在此 barrier 上调用 reset()。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在等待时被中断
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果在线程处于等待状态时 barrier 被 reset()，或者在调用 await 时 barrier 被损坏，抑或任意一个线程正处于等待状态，则抛出 BrokenBarrierException 异常。

如果任何线程在等待时被 中断，则其他所有等待线程都将抛出 BrokenBarrierException 异常，并将 barrier 置于损坏状态。

如果当前线程是最后一个将要到达的线程，并且构造方法中提供了一个非空的屏障操作，则在允许其他线程继续运行之前，当前线程将运行该操作。如果在执行屏障操作过程中发生异常，则该异常将传播到当前线程中，并将 barrier 置于损坏状态。

返回：
到达的当前线程的索引，其中，索引 getParties() - 1 指示将到达的第一个线程，零指示最后一个到达的线程
抛出：
InterruptedException - 如果当前线程在等待时被中断
BrokenBarrierException - 如果另一个 线程在当前线程等待时被中断或超时，或者重置了 barrier，或者在调用 await 时 barrier 被损坏，抑或由于异常而导致屏障操作（如果存在）失败。

await

public int await(long timeout,
                 TimeUnit unit)
          throws InterruptedException,
                 BrokenBarrierException,
                 TimeoutException
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。

如果当前线程不是将到达的最后一个线程，出于调度目的，将禁用它，且在发生以下情况之一前，该线程将一直处于休眠状态：

  • 最后一个线程到达；或者
  • 超出指定的超时时间；或者
  • 其他某个线程中断当前线程；或者
  • 其他某个线程中断另一个等待线程；或者
  • 其他某个线程在等待 barrier 时超时；或者
  • 其他某个线程在此 barrier 上调用 reset()。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在等待时被中断
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果超出指定的等待时间，则抛出 TimeoutException 异常。如果该时间小于等于零，则此方法根本不会等待。

如果在线程处于等待状态时 barrier 被 reset()，或者在调用 await 时 barrier 被损坏，抑或任意一个线程正处于等待状态，则抛出 BrokenBarrierException 异常。

如果任何线程在等待时被中断，则其他所有等待线程都将抛出 BrokenBarrierException，并将屏障置于损坏状态。

如果当前线程是最后一个将要到达的线程，并且构造方法中提供了一个非空的屏障操作，则在允许其他线程继续运行之前，当前线程将运行该操作。如果在执行屏障操作过程中发生异常，则该异常将传播到当前线程中，并将 barrier 置于损坏状态。

参数：
timeout - 等待 barrier 的时间
unit - 超时参数的时间单位
返回：
到达的当前线程的索引，其中，索引 getParties() - 1 指示第一个将要到达的线程，零指示最后一个到达的线程
抛出：
InterruptedException - 如果当前线程在等待时被中断
TimeoutException - 如果超出了指定的超时时间
BrokenBarrierException - 如果另一个 线程在当前线程等待时被中断或超时，或者重置了 barrier，或者调用 await 时 barrier 被损坏，抑或由于异常而导致屏障操作（如果存在）失败。

isBroken

public boolean isBroken()
查询此屏障是否处于损坏状态。

返回：
如果因为构造或最后一次重置而导致中断或超时，从而使一个或多个参与者摆脱此 barrier，或者因为异常而导致某个屏障操作失败，则返回 true；否则返回 false。

reset

public void reset()
将屏障重置为其初始状态。如果所有参与者目前都在屏障处等待，则它们将返回，同时抛出一个 BrokenBarrierException。注意，在由于其他原因造成损坏之后，实行重置可能会变得很复杂；此时需要使用其他方式重新同步线程，并选择其中一个线程来执行重置。与为后续使用创建一个新 barrier 相比，这种方法可能更好一些。

getNumberWaiting

public int getNumberWaiting()
返回当前在屏障处等待的参与者数目。此方法主要用于调试和断言。

返回：
当前阻塞在 await() 中的参与者数目。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Delayed (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 Delayed

所有超级接口：
Comparable<Delayed>
所有已知子接口：
RunnableScheduledFuture<V>, ScheduledFuture<V>
public interface Delayed
extends Comparable<Delayed>

一种混合风格的接口，用来标记那些应该在给定延迟时间之后执行的对象。

此接口的实现必须定义一个 compareTo 方法，该方法提供与此接口的 getDelay 方法一致的排序。

从以下版本开始：
1.5

方法摘要
 long getDelay(TimeUnit unit)
返回与此对象相关的剩余延迟时间，以给定的时间单位表示。
从接口 java.lang.Comparable 继承的方法
compareTo

方法详细信息

getDelay

long getDelay(TimeUnit unit)
返回与此对象相关的剩余延迟时间，以给定的时间单位表示。

参数：
unit - 时间单位
返回：
剩余延迟时间；零或负值指示延迟时间已经用尽
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DelayQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 DelayQueue<E extends Delayed>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.concurrent.DelayQueue<E>
类型参数：
E - 此 collection 中所保存元素的类型
所有已实现的接口：
Iterable<E>, Collection<E>, BlockingQueue<E>, Queue<E>
public class DelayQueue<E extends Delayed>
extends AbstractQueue<E>
implements BlockingQueue<E>

Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。该队列的头部 是延迟期满后保存时间最长的 Delayed 元素。如果延迟都还没有期满，则队列没有头部，并且 poll 将返回 null。当一个元素的 getDelay(TimeUnit.NANOSECONDS) 方法返回一个小于等于 0 的值时，将发生到期。即使无法使用 take 或 poll 移除未到期的元素，也不会将这些元素作为正常元素对待。例如，size 方法同时返回到期和未到期元素的计数。此队列不允许使用 null 元素。

此类及其迭代器实现了 Collection 和 Iterator 接口的所有可选 方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5

构造方法摘要
DelayQueue()
创建一个最初为空的新 DelayQueue。
DelayQueue(Collection<? extends E> c)
创建一个最初包含 Delayed 实例的给定 collection 元素的 DelayQueue。
方法摘要
 boolean add(E e)
将指定元素插入此延迟队列中。
 void clear()
自动移除此延迟队列的所有元素。
 int drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 Iterator<E> iterator()
返回在此队列所有元素（既包括到期的，也包括未到期的）上进行迭代的迭代器。
 boolean offer(E e)
将指定元素插入此延迟队列。
 boolean offer(E e, long timeout, TimeUnit unit)
将指定元素插入此延迟队列中。
 E peek()
获取但不移除此队列的头部；如果此队列为空，则返回 null。
 E poll()
获取并移除此队列的头，如果此队列不包含具有已到期延迟时间的元素，则返回 null。
 E poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。
 void put(E e)
将指定元素插入此延迟队列。
 int remainingCapacity()
因为 DelayQueue 没有容量限制，所以它总是返回 Integer.MAX_VALUE。
 boolean remove(Object o)
从此队列中移除指定元素的单个实例（如果存在），无论它是否到期。
 int size()
返回此 collection 中的元素数。
 E take()
获取并移除此队列的头部，在可从此队列获得到期延迟的元素之前一直等待（如有必要）。
 Object[] toArray()
返回包含此队列所有元素的数组。
<T> T[]
toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
从类 java.util.AbstractQueue 继承的方法
addAll, element, remove
从类 java.util.AbstractCollection 继承的方法
contains, containsAll, isEmpty, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.concurrent.BlockingQueue 继承的方法
contains
从接口 java.util.Queue 继承的方法
element, remove
从接口 java.util.Collection 继承的方法
addAll, containsAll, equals, hashCode, isEmpty, removeAll, retainAll

构造方法详细信息

DelayQueue

public DelayQueue()
创建一个最初为空的新 DelayQueue。

DelayQueue

public DelayQueue(Collection<? extends E> c)
创建一个最初包含 Delayed 实例的给定 collection 元素的 DelayQueue。

参数：
c - 最初包含元素的 collection
抛出：
NullPointerException - 如果指定 collection 或其任意元素为 null
方法详细信息

add

public boolean add(E e)
将指定元素插入此延迟队列中。

指定者：
接口 Collection<E extends Delayed> 中的 add
指定者：
接口 BlockingQueue<E extends Delayed> 中的 add
指定者：
接口 Queue<E extends Delayed> 中的 add
覆盖：
类 AbstractQueue<E extends Delayed> 中的 add
参数：
e - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e)
将指定元素插入此延迟队列。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 offer
指定者：
接口 Queue<E extends Delayed> 中的 offer
参数：
e - 要添加的元素
返回：
true
抛出：
NullPointerException - 如果指定的元素为 null

put

public void put(E e)
将指定元素插入此延迟队列。由于该队列是无界的，所以此方法不会阻塞。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 put
参数：
e - 要添加的元素
抛出：
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e,
                     long timeout,
                     TimeUnit unit)
将指定元素插入此延迟队列中。由于该队列是无界的，所以此方法不会阻塞。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 offer
参数：
e - 要添加的元素
timeout - 忽略此参数，因为此方法不会阻塞
unit - 忽略此参数，因为此方法不会阻塞
返回：
true
抛出：
NullPointerException - 如果指定元素为 null

poll

public E poll()
获取并移除此队列的头，如果此队列不包含具有已到期延迟时间的元素，则返回 null。

指定者：
接口 Queue<E extends Delayed> 中的 poll
返回：
此队列的头；如果此队列不包含任何具有已到期延迟时间的元素，则返回 null

take

public E take()
                       throws InterruptedException
获取并移除此队列的头部，在可从此队列获得到期延迟的元素之前一直等待（如有必要）。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 take
返回：
此队列的头部
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll(long timeout,
              TimeUnit unit)
                       throws InterruptedException
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 poll
参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此队列的头部；如果在可获得到期延迟的元素之前超出了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

peek

public E peek()
获取但不移除此队列的头部；如果此队列为空，则返回 null。与 poll 不同，如果队列中没有到期元素可用，则此方法返回下一个将到期的元素（如果存在一个这样的元素）。

指定者：
接口 Queue<E extends Delayed> 中的 peek
返回：
此队列的头部；如果此队列为空，则返回 null。

size

public int size()
从接口 Collection 复制的描述
返回此 collection 中的元素数。如果此 collection 包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

指定者：
接口 Collection<E extends Delayed> 中的 size
指定者：
类 AbstractCollection<E extends Delayed> 中的 size
返回：
此 collection 中的元素数

drainTo

public int drainTo(Collection<? super E> c)
从接口 BlockingQueue 复制的描述
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。此操作可能比反复轮询此队列更有效。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 drainTo
参数：
c - 接收传输元素的 collection
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

drainTo

public int drainTo(Collection<? super E> c,
                   int maxElements)
从接口 BlockingQueue 复制的描述
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 drainTo
参数：
c - 接收传输元素的 collection
maxElements - 传输元素的最大数量
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

clear

public void clear()
自动移除此延迟队列的所有元素。此调用返回后，队列将为空。不等待未到期延迟的元素；只是从队列中丢弃它们。

指定者：
接口 Collection<E extends Delayed> 中的 clear
覆盖：
类 AbstractQueue<E extends Delayed> 中的 clear

remainingCapacity

public int remainingCapacity()
因为 DelayQueue 没有容量限制，所以它总是返回 Integer.MAX_VALUE。

指定者：
接口 BlockingQueue<E extends Delayed> 中的 remainingCapacity
返回：
Integer.MAX_VALUE

toArray

public Object[] toArray()
返回包含此队列所有元素的数组。所返回数组的元素没有特定的顺序。

由于此队列并不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E extends Delayed> 中的 toArray
覆盖：
类 AbstractCollection<E extends Delayed> 中的 toArray
返回：
包含此队列所有元素的数组

toArray

public <T> T[] toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。所返回数组的元素没有特定的顺序。如果指定的数组能容纳队列，则将该队列返回此处。否则，将分配一个具有指定数组的运行时类型和此队列大小的新数组。

如果指定的数组能容纳队列，并有剩余的空间（即数组的元素比队列多），那么会将紧接队列尾部的元素设置为 null。

像 toArray() 方法一样，此方法充当基于数组 的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，可以用来节省分配开销。

以下代码用来将延迟队列转储到一个新分配的 Delayed 数组：

     Delayed[] a = q.toArray(new Delayed[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E extends Delayed> 中的 toArray
覆盖：
类 AbstractCollection<E extends Delayed> 中的 toArray
参数：
a - 用来存储队列元素的数组（如果该数组足够大）；否则为此分配一个具有相同运行时类型的新数组
返回：
包含此队列所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此队列每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

remove

public boolean remove(Object o)
从此队列中移除指定元素的单个实例（如果存在），无论它是否到期。

指定者：
接口 Collection<E extends Delayed> 中的 remove
指定者：
接口 BlockingQueue<E extends Delayed> 中的 remove
覆盖：
类 AbstractCollection<E extends Delayed> 中的 remove
参数：
o - 要从此 collection 中移除的元素（如果存在）。
返回：
如果此调用将移除一个元素，则返回 true

iterator

public Iterator<E> iterator()
返回在此队列所有元素（既包括到期的，也包括未到期的）上进行迭代的迭代器。迭代器不以任何特定的顺序返回元素。返回的 Iterator 是一个“弱一致”迭代器，不会抛出 ConcurrentModificationException，并且可确保遍历迭代器构造后所存在的所有元素，并且可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Iterable<E extends Delayed> 中的 iterator
指定者：
接口 Collection<E extends Delayed> 中的 iterator
指定者：
类 AbstractCollection<E extends Delayed> 中的 iterator
返回：
在此队列元素上进行迭代的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Exchanger (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 Exchanger<V>

java.lang.Object
    继承者  java.util.concurrent.Exchanger<V>
类型参数：
V - 可以交换的对象类型
public class Exchanger<V>
extends Object

可以在对中对元素进行配对和交换的线程的同步点。每个线程将条目上的某个方法呈现给 exchange 方法，与伙伴线程进行匹配，并且在返回时接收其伙伴的对象。Exchanger 可能被视为 SynchronousQueue 的双向形式。Exchanger 可能在应用程序（比如遗传算法和管道设计）中很有用。

用法示例：以下是重点介绍的一个类，该类使用 Exchanger 在线程间交换缓冲区，因此，在需要时，填充缓冲区的线程获取一个新腾空的缓冲区，并将填满的缓冲区传递给腾空缓冲区的线程。

class FillAndEmpty {
   Exchanger<DataBuffer> exchanger = new Exchanger<DataBuffer>();
   DataBuffer initialEmptyBuffer = ... a made-up type
   DataBuffer initialFullBuffer = ...

   class FillingLoop implements Runnable {
     public void run() {
       DataBuffer currentBuffer = initialEmptyBuffer;
       try {
         while (currentBuffer != null) {
           addToBuffer(currentBuffer);
           if (currentBuffer.isFull())
             currentBuffer = exchanger.exchange(currentBuffer);
         }
       } catch (InterruptedException ex) { ... handle ... }
     }
   }

   class EmptyingLoop implements Runnable {
     public void run() {
       DataBuffer currentBuffer = initialFullBuffer;
       try {
         while (currentBuffer != null) {
           takeFromBuffer(currentBuffer);
           if (currentBuffer.isEmpty())
             currentBuffer = exchanger.exchange(currentBuffer);
         }
       } catch (InterruptedException ex) { ... handle ...}
     }
   }

   void start() {
     new Thread(new FillingLoop()).start();
     new Thread(new EmptyingLoop()).start();
   }
  }

内存一致性效果：对于通过 Exchanger 成功交换对象的每对线程，每个线程中在 exchange() 之前的操作 happen-before 从另一线程中相应的 exchange() 返回的后续操作。

从以下版本开始：
1.5

构造方法摘要
Exchanger()
创建一个新的 Exchanger。
方法摘要
V | exchange(V x) 等待另一个线程到达此交换点（除非当前线程被中断），然后将给定的对象传送给该线程，并接收该线程的对象。
V | exchange(V x, long timeout, TimeUnit unit) 等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Exchanger

public Exchanger()
创建一个新的 Exchanger。

方法详细信息

exchange

public V exchange(V x)
           throws InterruptedException
等待另一个线程到达此交换点（除非当前线程被中断），然后将给定的对象传送给该线程，并接收该线程的对象。

如果另一个线程已经在交换点等待，则出于线程调度目的，继续执行此线程，并接收当前线程传入的对象。当前线程立即返回，接收其他线程传递的交换对象。

如果还没有其他线程在交换点等待，则出于调度目的，禁用当前线程，且在发生以下两种情况之一前，该线程将一直处于休眠状态：

  • 其他某个线程进入交换点；或者
  • 其他某个线程中断当前线程。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在等待交换时被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。

参数：
x - 要交换的对象
返回：
另一个线程提供的对象
抛出：
InterruptedException - 如果当前线程在等待时被中断

exchange

public V exchange(V x,
                  long timeout,
                  TimeUnit unit)
           throws InterruptedException,
                  TimeoutException
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。

如果另一个线程已经在交换点上等待，则出于线程调度目的，继续执行此线程，并接收当前线程传入的对象。当前线程立即返回，并接收其他线程传递的交换对象。

如果还没有其他线程在交换点等待，则出于调度目的，禁用当前线程，且在发生以下三种情况之一前，该线程将一直处于休眠状态：

  • 其他某个线程进入交换点；或者
  • 其他某个线程中断当前线程；或者
  • 已超出指定的等待时间。

如果当前线程：

  • 在进入此方法时已经设置其中断状态；或者
  • 在等待交换时被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果超出指定的等待时间，则抛出 TimeoutException 异常。如果该时间小于等于零，则此方法根本不会等待。

参数：
x - 要交换的对象
timeout - 要等待的最长时间
unit - timeout 参数的时间单位
返回：
其他线程提供的对象
抛出：
InterruptedException - 如果当前线程在等待时被中断
TimeoutException - 如果在另一个线程进入交换点之前已经到达指定的等待时间
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExecutionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ExecutionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.util.concurrent.ExecutionException
所有已实现的接口：
Serializable
public class ExecutionException
extends Exception

当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。可以使用 Throwable.getCause() 方法来检查此异常。

从以下版本开始：
1.5
另请参见：
Future, 序列化表格

构造方法摘要
protected | ExecutionException() 构造不带详细消息的 ExecutionException。
protected | ExecutionException(String message) 构造带指定详细消息的 ExecutionException。
 | ExecutionException(String message, Throwable cause) 构造带指定详细消息和原因的 ExecutionException。
 | ExecutionException(Throwable cause) 构造带指定原因的 ExecutionException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ExecutionException

protected ExecutionException()
构造不带详细消息的 ExecutionException。原因尚未被初始化，可在以后通过调用 initCause 对其进行初始化。

ExecutionException

protected ExecutionException(String message)
构造带指定详细消息的 ExecutionException。原因尚未被初始化，可在以后通过调用 initCause 对其进行初始化。

参数：
message - 详细消息

ExecutionException

public ExecutionException(String message,
                          Throwable cause)
构造带指定详细消息和原因的 ExecutionException。

参数：
message - 详细消息
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）

ExecutionException

public ExecutionException(Throwable cause)
构造带指定原因的 ExecutionException。将详细消息设置为：
  (cause == null ? null :cause.toString())
（它通常包含类和 cause 的详细消息）。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable.getCause() 方法获取它）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Executor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 Executor

所有已知子接口：
ExecutorService, ScheduledExecutorService
所有已知实现类：
AbstractExecutorService, ScheduledThreadPoolExecutor, ThreadPoolExecutor
public interface Executor

执行已提交的 Runnable 任务的对象。此接口提供一种将任务提交与每个任务将如何运行的机制（包括线程使用的细节、调度等）分离开来的方法。通常使用 Executor 而不是显式地创建线程。例如，可能会使用以下方法，而不是为一组任务中的每个任务调用 new Thread(new(RunnableTask())).start()：

 Executor executor = anExecutor;
 executor.execute(new RunnableTask1());
 executor.execute(new RunnableTask2());
 ...
不过，Executor 接口并没有严格地要求执行是异步的。在最简单的情况下，执行程序可以在调用者的线程中立即运行已提交的任务：
 class DirectExecutor implements Executor {
     public void execute(Runnable r) {
         r.run();
     }
 }
更常见的是，任务是在某个不是调用者线程的线程中执行的。以下执行程序将为每个任务生成一个新线程。
 class ThreadPerTaskExecutor implements Executor {
     public void execute(Runnable r) {
         new Thread(r).start();
     }
 }
许多 Executor 实现都对调度任务的方式和时间强加了某种限制。以下执行程序使任务提交与第二个执行程序保持连续，这说明了一个复合执行程序。
 class SerialExecutor implements Executor {
     final Queue<Runnable> tasks = new ArrayDeque<Runnable>();
     final Executor executor;
     Runnable active;

     SerialExecutor(Executor executor) {
         this.executor = executor;
     }

     public synchronized void execute(final Runnable r) {
         tasks.offer(new Runnable() {
             public void run() {
                 try {
                     r.run();
                 } finally {
                     scheduleNext();
                 }
             }
         });
         if (active == null) {
             scheduleNext();
         }
     }

     protected synchronized void scheduleNext() {
         if ((active = tasks.poll()) != null) {
             executor.execute(active);
         }
     }
 }
此包中提供的 Executor 实现实现了 ExecutorService，这是一个使用更广泛的接口。ThreadPoolExecutor 类提供一个可扩展的线程池实现。Executors 类为这些 Executor 提供了便捷的工厂方法。

内存一致性效果：线程中将 Runnable 对象提交到 Executor 之前的操作 happen-before 其执行开始（可能在另一个线程中）。

从以下版本开始：
1.5

方法摘要
 void execute(Runnable command)
在未来某个时间执行给定的命令。

方法详细信息

execute

void execute(Runnable command)
在未来某个时间执行给定的命令。该命令可能在新的线程、已入池的线程或者正调用的线程中执行，这由 Executor 实现决定。

参数：
command - 可运行的任务
抛出：
RejectedExecutionException - 如果不能接受执行此任务。
NullPointerException - 如果命令为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExecutorCompletionService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ExecutorCompletionService<V>

java.lang.Object
    继承者  java.util.concurrent.ExecutorCompletionService<V>
所有已实现的接口：
CompletionService<V>
public class ExecutorCompletionService<V>
extends Object
implements CompletionService<V>

使用提供的 Executor 来执行任务的 CompletionService。此类将安排那些完成时提交的任务，把它们放置在可使用 take 访问的队列上。该类非常轻便，适合于在执行几组任务时临时使用。

用法示例。 假定您有针对某个问题的一组求解程序，每个求解程序都能返回某种类型的 Result 值，并且您想同时运行它们，使用方法 use(Result r) 处理返回非 null 值的每个求解程序的返回结果。可以这样编写程序：

    void solve(Executor e, Collection<Callable<Result>> solvers)
      throws InterruptedException, ExecutionException {
        CompletionService<Result> ecs = new ExecutorCompletionService<Result>(e);
        for (Callable<Result> s : solvers)
            ecs.submit(s);
        int n = solvers.size();
        for (int i = 0; i < n; ++i) {
            Result r = ecs.take().get();
            if (r != null)
                use(r);
        }
    }
假定您想使用任务集中的第一个非 null 结果，而忽略任何遇到异常的任务，并且在第一个任务就绪时取消其他所有任务：
    void solve(Executor e, Collection<Callable<Result>> solvers)
      throws InterruptedException {
        CompletionService<Result> ecs = new ExecutorCompletionService<Result>(e);
        int n = solvers.size();
        List<Future<Result>> futures = new ArrayList<Future<Result>>(n);
        Result result = null;
        try {
            for (Callable<Result> s : solvers)
                futures.add(ecs.submit(s));
            for (int i = 0; i < n; ++i) {
                try {
                    Result r = ecs.take().get();
                    if (r != null) {
                        result = r;
                        break;
                    }
                } catch(ExecutionException ignore) {}
            }
        }
        finally {
            for (Future<Result> f : futures)
                f.cancel(true);
        }

        if (result != null)
            use(result);
    }

构造方法摘要
ExecutorCompletionService(Executor executor)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将 LinkedBlockingQueue 作为完成队列。
ExecutorCompletionService(Executor executor, BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。
方法摘要
Future<V> | poll() 获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。
Future<V> | poll(long timeout, TimeUnit unit) 获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
Future<V> | submit(Callable<V> task) 提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
Future<V> | submit(Runnable task, V result) 提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
Future<V> | take() 获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExecutorCompletionService

public ExecutorCompletionService(Executor executor)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将 LinkedBlockingQueue 作为完成队列。

参数：
executor - 要使用的执行程序
抛出：
NullPointerException - 如果执行程序为 null

ExecutorCompletionService

public ExecutorCompletionService(Executor executor,
                                 BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。

参数：
executor - 要使用的执行程序
completionQueue - 用作完成队列的队列，通常是专供此服务使用的队列
抛出：
NullPointerException - 如果执行程序或 completionQueue 为 null
方法详细信息

submit

public Future<V> submit(Callable<V> task)
从接口 CompletionService 复制的描述
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。在完成时，可能会提取或轮询此任务。

指定者：
接口 CompletionService<V> 中的 submit
参数：
task - 要提交的任务
返回：
一个表示挂起的任务完成的 Future

submit

public Future<V> submit(Runnable task,
                        V result)
从接口 CompletionService 复制的描述
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。

指定者：
接口 CompletionService<V> 中的 submit
参数：
task - 要提交的任务
result - 要返回的已成功完成任务的结果
返回：
一个表示挂起的任务完成的 Future，其 get() 方法将返回完成时给出的结果值

take

public Future<V> take()
               throws InterruptedException
从接口 CompletionService 复制的描述
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。

指定者：
接口 CompletionService<V> 中的 take
返回：
表示下一个已完成任务的 Future
抛出：
InterruptedException - 如果在等待时被中断

poll

public Future<V> poll()
从接口 CompletionService 复制的描述
获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。

指定者：
接口 CompletionService<V> 中的 poll
返回：
表示下一个已完成任务的 Future；如果不存在这样的任务，则返回 null

poll

public Future<V> poll(long timeout,
                      TimeUnit unit)
               throws InterruptedException
从接口 CompletionService 复制的描述
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。

指定者：
接口 CompletionService<V> 中的 poll
参数：
timeout - 放弃之前需要等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
表示下一个已完成任务的 Future；如果等待了指定时间仍然不存在这样的任务，则返回 null
抛出：
InterruptedException - 如果在等待时被中断
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Executors (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 Executors

java.lang.Object
    继承者  java.util.concurrent.Executors

public class Executors
extends Object

此包中所定义的 Executor、ExecutorService、ScheduledExecutorService、ThreadFactory 和 Callable 类的工厂和实用方法。此类支持以下各种方法：

  • 创建并返回设置有常用配置字符串的 ExecutorService 的方法。
  • 创建并返回设置有常用配置字符串的 ScheduledExecutorService 的方法。
  • 创建并返回“包装的”ExecutorService 方法，它通过使特定于实现的方法不可访问来禁用重新配置。
  • 创建并返回 ThreadFactory 的方法，它可将新创建的线程设置为已知的状态。
  • 创建并返回非闭包形式的 Callable 的方法，这样可将其用于需要 Callable 的执行方法中。

从以下版本开始：
1.5

方法摘要
static Callable<Object> callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。
static Callable<Object> callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。
static Callable<Object> callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。
static
<T> Callable<T>
callable(Runnable task, T result)
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。
static ThreadFactory defaultThreadFactory()
返回用于创建新线程的默认线程工厂。
static ExecutorService newCachedThreadPool()
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们。
static ExecutorService newCachedThreadPool(ThreadFactory threadFactory)
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService newFixedThreadPool(int nThreads)
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程。
static ExecutorService newFixedThreadPool(int nThreads, ThreadFactory threadFactory)
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。
static ScheduledExecutorService newScheduledThreadPool(int corePoolSize)
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService newScheduledThreadPool(int corePoolSize, ThreadFactory threadFactory)
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ExecutorService newSingleThreadExecutor()
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程。
static ExecutorService newSingleThreadExecutor(ThreadFactory threadFactory)
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。
static ScheduledExecutorService newSingleThreadScheduledExecutor()
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService newSingleThreadScheduledExecutor(ThreadFactory threadFactory)
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
static
<T> Callable<T>
privilegedCallable(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。
static
<T> Callable<T>
privilegedCallableUsingCurrentClassLoader(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。
static ThreadFactory privilegedThreadFactory()
返回用于创建新线程的线程工厂，这些新线程与当前线程具有相同的权限。
static ExecutorService unconfigurableExecutorService(ExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。
static ScheduledExecutorService unconfigurableScheduledExecutorService(ScheduledExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

newFixedThreadPool

public static ExecutorService newFixedThreadPool(int nThreads)
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程。在任意点，在大多数 nThreads 线程会处于处理任务的活动状态。如果在所有线程处于活动状态时提交附加任务，则在有可用线程之前，附加任务将在队列中等待。如果在关闭前的执行期间由于失败而导致任何线程终止，那么一个新线程将代替它执行后续的任务（如果需要）。在某个线程被显式地关闭之前，池中的线程将一直存在。

参数：
nThreads - 池中的线程数
返回：
新创建的线程池
抛出：
IllegalArgumentException - 如果 nThreads <= 0

newFixedThreadPool

public static ExecutorService newFixedThreadPool(int nThreads,
                                                 ThreadFactory threadFactory)
创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。在任意点，在大多数 nThreads 线程会处于处理任务的活动状态。如果在所有线程处于活动状态时提交附加任务，则在有可用线程之前，附加任务将在队列中等待。如果在关闭前的执行期间由于失败而导致任何线程终止，那么一个新线程将代替它执行后续的任务（如果需要）。在某个线程被显式地关闭之前，池中的线程将一直存在。

参数：
nThreads - 池中的线程数
threadFactory - 创建新线程时使用的工厂
返回：
新创建的线程池
抛出：
NullPointerException - 如果 threadFactory 为 null
IllegalArgumentException - 如果 nThreads <= 0

newSingleThreadExecutor

public static ExecutorService newSingleThreadExecutor()
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程。（注意，如果因为在关闭前的执行期间出现失败而终止了此单个线程，那么如果需要，一个新线程将代替它执行后续的任务）。可保证顺序地执行各个任务，并且在任意给定的时间不会有多个线程是活动的。与其他等效的 newFixedThreadPool(1) 不同，可保证无需重新配置此方法所返回的执行程序即可使用其他的线程。

返回：
新创建的单线程 Executor

newSingleThreadExecutor

public static ExecutorService newSingleThreadExecutor(ThreadFactory threadFactory)
创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。与其他等效的 newFixedThreadPool(1, threadFactory) 不同，可保证无需重新配置此方法所返回的执行程序即可使用其他的线程。

参数：
threadFactory - 创建新线程时使用的工厂
返回：
新创建的单线程 Executor
抛出：
NullPointerException - 如果 threadFactory 为 null

newCachedThreadPool

public static ExecutorService newCachedThreadPool()
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们。对于执行很多短期异步任务的程序而言，这些线程池通常可提高程序性能。调用 execute 将重用以前构造的线程（如果线程可用）。如果现有线程没有可用的，则创建一个新线程并添加到池中。终止并从缓存中移除那些已有 60 秒钟未被使用的线程。因此，长时间保持空闲的线程池不会使用任何资源。注意，可以使用 ThreadPoolExecutor 构造方法创建具有类似属性但细节不同（例如超时参数）的线程池。

返回：
新创建的线程池

newCachedThreadPool

public static ExecutorService newCachedThreadPool(ThreadFactory threadFactory)
创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。

参数：
threadFactory - 创建新线程时使用的工厂
返回：
新创建的线程池
抛出：
NullPointerException - 如果 threadFactory 为 null

newSingleThreadScheduledExecutor

public static ScheduledExecutorService newSingleThreadScheduledExecutor()
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。（注意，如果因为在关闭前的执行期间出现失败而终止了此单个线程，那么如果需要，一个新线程会代替它执行后续的任务）。可保证顺序地执行各个任务，并且在任意给定的时间不会有多个线程是活动的。与其他等效的 newScheduledThreadPool(1) 不同，可保证无需重新配置此方法所返回的执行程序即可使用其他的线程。

返回：
新创建的安排执行程序

newSingleThreadScheduledExecutor

public static ScheduledExecutorService newSingleThreadScheduledExecutor(ThreadFactory threadFactory)
创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。（注意，如果因为在关闭前的执行期间出现失败而终止了此单个线程，那么如果需要，一个新线程会代替它执行后续的任务）。可保证顺序地执行各个任务，并且在任意给定的时间不会有多个线程是活动的。与其他等效的 newScheduledThreadPool(1, threadFactory) 不同，可保证无需重新配置此方法所返回的执行程序即可使用其他的线程。

参数：
threadFactory - 创建新线程时使用的工厂
返回：
新创建的安排执行程序
抛出：
NullPointerException - 如果 threadFactory 为 null

newScheduledThreadPool

public static ScheduledExecutorService newScheduledThreadPool(int corePoolSize)
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。

参数：
corePoolSize - 池中所保存的线程数，即使线程是空闲的也包括在内。
返回：
新创建的安排线程池
抛出：
NullPointerException - 如果 threadFactory 为 null

newScheduledThreadPool

public static ScheduledExecutorService newScheduledThreadPool(int corePoolSize,
                                                              ThreadFactory threadFactory)
创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。

参数：
corePoolSize - 池中所保存的线程数，即使线程是空闲的也包括在内
threadFactory - 执行程序创建新线程时使用的工厂
返回：
新创建的安排线程池
抛出：
IllegalArgumentException - 如果 corePoolSize < 0
NullPointerException - 如果 threadFactory 为 null

unconfigurableExecutorService

public static ExecutorService unconfigurableExecutorService(ExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。这提供了一种可安全地“冻结”配置并且不允许调整给定具体实现的方法。

参数：
executor - 底层实现
返回：
一个 ExecutorService 实例
抛出：
NullPointerException - 如果 executor 为 null

unconfigurableScheduledExecutorService

public static ScheduledExecutorService unconfigurableScheduledExecutorService(ScheduledExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。这提供了一种可安全地“冻结”配置并且不允许调整给定具体实现的方法。

参数：
executor - 底层实现
返回：
一个 ScheduledExecutorService 实例
抛出：
NullPointerException - 如果 executor 为 null

defaultThreadFactory

public static ThreadFactory defaultThreadFactory()
返回用于创建新线程的默认线程工厂。此工厂创建同一 ThreadGroup 中 Executor 使用的所有新线程。如果有 SecurityManager，则它使用 System.getSecurityManager() 组来调用此 defaultThreadFactory 方法，其他情况则使用线程组。每个新线程都作为非守护程序而创建，并且具有设置为 Thread.NORM_PRIORITY 中较小者的优先级以及线程组中允许的最大优先级。新线程具有可通过 pool-N-thread-M 的 Thread.getName() 来访问的名称，其中 N 是此工厂的序列号，M 是此工厂所创建线程的序列号。

返回：
线程工厂

privilegedThreadFactory

public static ThreadFactory privilegedThreadFactory()
返回用于创建新线程的线程工厂，这些新线程与当前线程具有相同的权限。此工厂创建具有与 defaultThreadFactory() 相同设置的线程，新线程的 AccessControlContext 和 contextClassLoader 的其他设置与调用此 privilegedThreadFactory 方法的线程相同。可以在 AccessController.doPrivileged(java.security.PrivilegedAction) 操作中创建一个新 privilegedThreadFactory，设置当前线程的访问控制上下文，以便创建具有该操作中保持的所选权限的线程。

注意，虽然运行在此类线程中的任务具有与当前线程相同的访问控制和类加载器，但是它们无需具有相同的 ThreadLocal 或 InheritableThreadLocal 值。如有必要，使用 ThreadPoolExecutor.beforeExecute(java.lang.Thread, java.lang.Runnable) 在 ThreadPoolExecutor 子类中运行任何任务前，可以设置或重置线程局部变量的特定值。另外，如果必须初始化 worker 线程，以具有与某些其他指定线程相同的 InheritableThreadLocal 设置，则可以在线程等待和服务创建请求的环境中创建自定义的 ThreadFactory，而不是继承其值。

返回：
线程工厂
抛出：
AccessControlException - 如果当前访问控制上下文没有获取和设置上下文类加载器的权限。

callable

public static <T> Callable<T> callable(Runnable task,
                                       T result)
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。这在把需要 Callable 的方法应用到其他无结果的操作时很有用。

参数：
task - 要运行的任务
result - 返回的结果
返回：
一个 callable 对象
抛出：
NullPointerException - 如果 task 为 null

callable

public static Callable<Object> callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。

参数：
task - 要运行的任务
返回：
一个 callable 对象
抛出：
NullPointerException - 如果 task 为 null

callable

public static Callable<Object> callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。

参数：
action - 要运行的特权操作
返回：
一个 callable 对象
抛出：
NullPointerException - 如果 action 为 null

callable

public static Callable<Object> callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。

参数：
action - 要运行的特权异常操作
返回：
一个 callable 对象
抛出：
NullPointerException - 如果 action 为 null

privilegedCallable

public static <T> Callable<T> privilegedCallable(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。通常应该在 AccessController.doPrivileged(java.security.PrivilegedAction) 操作中调用此方法，以便创建 callable 对象，并且如有可能，则在该操作中保持的所选权限设置下执行此对象；如果无法调用，则抛出相关的 AccessControlException。

参数：
callable - 底层任务
返回：
一个 callable 对象
抛出：
NullPointerException - 如果 callable 为 null

privilegedCallableUsingCurrentClassLoader

public static <T> Callable<T> privilegedCallableUsingCurrentClassLoader(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。通常应该在 AccessController.doPrivileged(java.security.PrivilegedAction) 操作中调用此方法，以创建 callable 对象，并且如有可能，则在该操作中保持的所选权限设置下执行此对象；如果无法调用，则抛出相关的 AccessControlException。

参数：
callable - 底层任务
返回：
一个 callable 对象
抛出：
NullPointerException - 如果 callable 为 null
AccessControlException - 如果当前的访问控制上下文没有设置和获得上下文类加载器的权限。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExecutorService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 ExecutorService

所有超级接口：
Executor
所有已知子接口：
ScheduledExecutorService
所有已知实现类：
AbstractExecutorService, ScheduledThreadPoolExecutor, ThreadPoolExecutor
public interface ExecutorService
extends Executor

Executor 提供了管理终止的方法，以及可为跟踪一个或多个异步任务执行状况而生成 Future 的方法。

可以关闭 ExecutorService，这将导致其拒绝新任务。提供两个方法来关闭 ExecutorService。shutdown() 方法在终止前允许执行以前提交的任务，而 shutdownNow() 方法阻止等待任务启动并试图停止当前正在执行的任务。在终止时，执行程序没有任务在执行，也没有任务在等待执行，并且无法提交新任务。应该关闭未使用的 ExecutorService 以允许回收其资源。

通过创建并返回一个可用于取消执行和/或等待完成的 Future，方法 submit 扩展了基本方法 Executor.execute(java.lang.Runnable)。方法 invokeAny 和 invokeAll 是批量执行的最常用形式，它们执行任务 collection，然后等待至少一个，或全部任务完成（可使用 ExecutorCompletionService 类来编写这些方法的自定义变体）。

Executors 类提供了用于此包中所提供的执行程序服务的工厂方法。

用法示例

下面给出了一个网络服务的简单结构，这里线程池中的线程作为传入的请求。它使用了预先配置的 Executors.newFixedThreadPool(int) 工厂方法：
 class NetworkService implements Runnable {
    private final ServerSocket serverSocket;
    private final ExecutorService pool;

    public NetworkService(int port, int poolSize)
        throws IOException {
      serverSocket = new ServerSocket(port);
      pool = Executors.newFixedThreadPool(poolSize);
    }

    public void run() { // run the service
      try {
        for (;;) {
          pool.execute(new Handler(serverSocket.accept()));
        }
      } catch (IOException ex) {
        pool.shutdown();
      }
    }
  }

  class Handler implements Runnable {
    private final Socket socket;
    Handler(Socket socket) { this.socket = socket; }
    public void run() {
      // read and service request on socket
    }
 }
下列方法分两个阶段关闭 ExecutorService。第一阶段调用 shutdown 拒绝传入任务，然后调用 shutdownNow（如有必要）取消所有遗留的任务：
 void shutdownAndAwaitTermination(ExecutorService pool) {
   pool.shutdown(); // Disable new tasks from being submitted
   try {
     // Wait a while for existing tasks to terminate
     if (!pool.awaitTermination(60, TimeUnit.SECONDS)) {
       pool.shutdownNow(); // Cancel currently executing tasks
       // Wait a while for tasks to respond to being cancelled
       if (!pool.awaitTermination(60, TimeUnit.SECONDS))
           System.err.println("Pool did not terminate");
     }
   } catch (InterruptedException ie) {
     // (Re-)Cancel if current thread also interrupted
     pool.shutdownNow();
     // Preserve interrupt status
     Thread.currentThread().interrupt();
   }
 }

内存一致性效果：线程中向 ExecutorService 提交 Runnable 或 Callable 任务之前的操作 happen-before 由该任务所提取的所有操作，后者依次 happen-before 通过 Future.get() 获取的结果。

从以下版本开始：
1.5

方法摘要
 boolean awaitTermination(long timeout, TimeUnit unit)
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
<T> List<Future<T>>
invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
 boolean isShutdown()
如果此执行程序已关闭，则返回 true。
 boolean isTerminated()
如果关闭后所有任务都已完成，则返回 true。
 void shutdown()
启动一次顺序关闭，执行以前提交的任务，但不接受新任务。
 List<Runnable> shutdownNow()
试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。
<T> Future<T>
submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
 Future<?> submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
<T> Future<T>
submit(Runnable task, T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
从接口 java.util.concurrent.Executor 继承的方法
execute

方法详细信息

shutdown

void shutdown()
启动一次顺序关闭，执行以前提交的任务，但不接受新任务。如果已经关闭，则调用没有其他作用。

抛出：
SecurityException - 如果安全管理器存在并且关闭，此 ExecutorService 可能操作某些不允许调用者修改的线程（因为它没有保持 RuntimePermission ("modifyThread")），或者安全管理器的 checkAccess 方法拒绝访问。

shutdownNow

List<Runnable> shutdownNow()
试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。

无法保证能够停止正在处理的活动执行任务，但是会尽力尝试。例如，通过 Thread.interrupt() 来取消典型的实现，所以任何任务无法响应中断都可能永远无法终止。

返回：
从未开始执行的任务的列表
抛出：
SecurityException - 如果安全管理器存在并且关闭，此 ExecutorService 可能操作某些不允许调用者修改的线程（因为它没有保持 RuntimePermission ("modifyThread")），或者安全管理器的 checkAccess 方法拒绝访问。

isShutdown

boolean isShutdown()
如果此执行程序已关闭，则返回 true。

返回：
如果此执行程序已关闭，则返回 true

isTerminated

boolean isTerminated()
如果关闭后所有任务都已完成，则返回 true。注意，除非首先调用 shutdown 或 shutdownNow，否则 isTerminated 永不为 true。

返回：
如果关闭后所有任务都已完成，则返回 true

awaitTermination

boolean awaitTermination(long timeout,
                         TimeUnit unit)
                         throws InterruptedException
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。

参数：
timeout - 最长等待时间
unit - timeout 参数的时间单位
返回：
如果此执行程序终止，则返回 true；如果终止前超时期满，则返回 false
抛出：
InterruptedException - 如果等待时发生中断

submit

<T> Future<T> submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。该 Future 的 get 方法在成功完成时将会返回该任务的结果。

如果想立即阻塞任务的等待，则可以使用 result = exec.submit(aCallable).get(); 形式的构造。

注：Executors 类包括了一组方法，可以转换某些其他常见的类似于闭包的对象，例如，将 PrivilegedAction 转换为 Callable 形式，这样就可以提交它们了。

参数：
task - 要提交的任务
返回：
表示任务等待完成的 Future
抛出：
RejectedExecutionException - 如果任务无法安排执行
NullPointerException - 如果该任务为 null

submit

<T> Future<T> submit(Runnable task,
                     T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。该 Future 的 get 方法在成功完成时将会返回给定的结果。

参数：
task - 要提交的任务
result - 返回的结果
返回：
表示任务等待完成的 Future
抛出：
RejectedExecutionException - 如果任务无法安排执行
NullPointerException - 如果该任务为 null

submit

Future<?> submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。该 Future 的 get 方法在成功 完成时将会返回 null。

参数：
task - 要提交的任务
返回：
表示任务等待完成的 Future
抛出：
RejectedExecutionException - 如果任务无法安排执行
NullPointerException - 如果该任务为 null

invokeAll

<T> List<Future<T>> invokeAll(Collection<? extends Callable<T>> tasks)
                          throws InterruptedException
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。返回列表的所有元素的 Future.isDone() 为 true。注意，可以正常地或通过抛出异常来终止已完成 任务。如果正在进行此操作时修改了给定的 collection，则此方法的结果是不确定的。

参数：
tasks - 任务 collection
返回：
表示任务的 Future 列表，列表顺序与给定任务列表的迭代器所生成的顺序相同，每个任务都已完成。
抛出：
InterruptedException - 如果等待时发生中断，在这种情况下取消尚未完成的任务。
NullPointerException - 如果任务或其任意元素为 null
RejectedExecutionException - 如果所有任务都无法安排执行

invokeAll

<T> List<Future<T>> invokeAll(Collection<? extends Callable<T>> tasks,
                              long timeout,
                              TimeUnit unit)
                          throws InterruptedException
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。返回列表的所有元素的 Future.isDone() 为 true。一旦返回后，即取消尚未完成的任务。注意，可以正常地或通过抛出异常来终止已完成 任务。如果此操作正在进行时修改了给定的 collection，则此方法的结果是不确定的。

参数：
tasks - 任务 collection
timeout - 最长等待时间
unit - timeout 参数的时间单位
返回：
表示任务的 Future 列表，列表顺序与给定任务列表的迭代器所生成的顺序相同。如果操作未超时，则已完成所有任务。如果确实超时了，则某些任务尚未完成。
抛出：
InterruptedException - 如果等待时发生中断，在这种情况下取消尚未完成的任务
NullPointerException - 如果任务或其任意元素或 unit 为 null
RejectedExecutionException - 如果所有任务都无法安排执行

invokeAny

<T> T invokeAny(Collection<? extends Callable<T>> tasks)
            throws InterruptedException,
                   ExecutionException
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。一旦正常或异常返回后，则取消尚未完成的任务。如果此操作正在进行时修改了给定的 collection，则此方法的结果是不确定的。

参数：
tasks - 任务 collection
返回：
某个任务返回的结果
抛出：
InterruptedException - 如果等待时发生中断
NullPointerException - 如果任务或其任意元素为 null
IllegalArgumentException - 如果任务为空
ExecutionException - 如果没有任务成功完成
RejectedExecutionException - 如果任务无法安排执行

invokeAny

<T> T invokeAny(Collection<? extends Callable<T>> tasks,
                long timeout,
                TimeUnit unit)
            throws InterruptedException,
                   ExecutionException,
                   TimeoutException
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。一旦正常或异常返回后，则取消尚未完成的任务。如果此操作正在进行时修改了给定的 collection，则此方法的结果是不确定的。

参数：
tasks - 任务 collection
timeout - 最长等待时间
unit - timeout 参数的时间单位
返回：
某个任务返回的结果
抛出：
InterruptedException - 如果等待时发生中断
NullPointerException - 如果任务或其任意元素或 unit 为 null
TimeoutException - 如果在所有任务成功完成之前给定的超时期满
ExecutionException - 如果没有任务成功完成
RejectedExecutionException - 如果任务无法安排执行
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Future (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 Future<V>

类型参数：
V - 此 Future 的 get 方法所返回的结果类型
所有已知子接口：
Response<T>, RunnableFuture<V>, RunnableScheduledFuture<V>, ScheduledFuture<V>
所有已知实现类：
FutureTask, SwingWorker
public interface Future<V>

Future 表示异步计算的结果。它提供了检查计算是否完成的方法，以等待计算的完成，并获取计算的结果。计算完成后只能使用 get 方法来获取结果，如有必要，计算完成前可以阻塞此方法。取消则由 cancel 方法来执行。还提供了其他方法，以确定任务是正常完成还是被取消了。一旦计算完成，就不能再取消计算。如果为了可取消性而使用 Future 但又不提供可用的结果，则可以声明 Future<?> 形式类型、并返回 null 作为底层任务的结果。

用法示例（注意，下列各类都是构造好的。）

 interface ArchiveSearcher { String search(String target); }
 class App {
   ExecutorService executor = ...
   ArchiveSearcher searcher = ...
   void showSearch(final String target)
       throws InterruptedException {
     Future<String> future
       = executor.submit(new Callable<String>() {
         public String call() {
             return searcher.search(target);
         }});
     displayOtherThings(); // do other things while searching
     try {
       displayText(future.get()); // use future
     } catch (ExecutionException ex) { cleanup(); return; }
   }
 }
FutureTask 类是 Future 的一个实现，Future 可实现 Runnable，所以可通过 Executor 来执行。例如，可用下列内容替换上面带有 submit 的构造：
     FutureTask<String> future =
       new FutureTask<String>(new Callable<String>() {
         public String call() {
           return searcher.search(target);
       }});
     executor.execute(future);

内存一致性效果：异步计算采取的操作  happen-before 另一线程中紧跟在相应的 Future.get() 之后的操作。

从以下版本开始：
1.5
另请参见：
FutureTask, Executor

方法摘要
boolean | cancel(boolean mayInterruptIfRunning) 试图取消对此任务的执行。
V | get() 如有必要，等待计算完成，然后获取其结果。
V | get(long timeout, TimeUnit unit) 如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
boolean | isCancelled() 如果在任务正常完成前将其取消，则返回 true。
boolean | isDone() 如果任务已完成，则返回 true。

方法详细信息

cancel

boolean cancel(boolean mayInterruptIfRunning)
试图取消对此任务的执行。如果任务已完成、或已取消，或者由于某些其他原因而无法取消，则此尝试将失败。当调用 cancel 时，如果调用成功，而此任务尚未启动，则此任务将永不运行。如果任务已经启动，则 mayInterruptIfRunning 参数确定是否应该以试图停止任务的方式来中断执行此任务的线程。

此方法返回后，对 isDone() 的后续调用将始终返回 true。如果此方法返回 true，则对 isCancelled() 的后续调用将始终返回 true。

参数：
mayInterruptIfRunning - 如果应该中断执行此任务的线程，则为 true；否则允许正在运行的任务运行完成
返回：
如果无法取消任务，则返回 false，这通常是由于它已经正常完成；否则返回 true

isCancelled

boolean isCancelled()
如果在任务正常完成前将其取消，则返回 true。

返回：
如果任务完成前将其取消，则返回 true

isDone

boolean isDone()
如果任务已完成，则返回 true。 可能由于正常终止、异常或取消而完成，在所有这些情况中，此方法都将返回 true。

返回：
如果任务已完成，则返回 true

get

V get()
      throws InterruptedException,
             ExecutionException
如有必要，等待计算完成，然后获取其结果。

返回：
计算的结果
抛出：
CancellationException - 如果计算被取消
ExecutionException - 如果计算抛出异常
InterruptedException - 如果当前的线程在等待时被中断

get

V get(long timeout,
      TimeUnit unit)
      throws InterruptedException,
             ExecutionException,
             TimeoutException
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

参数：
timeout - 等待的最大时间
unit - timeout 参数的时间单位
返回：
计算的结果
抛出：
CancellationException - 如果计算被取消
ExecutionException - 如果计算抛出异常
InterruptedException - 如果当前的线程在等待时被中断
TimeoutException - 如果等待超时
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FutureTask (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 FutureTask<V>

java.lang.Object
    继承者  java.util.concurrent.FutureTask<V>
类型参数：
V - 此 FutureTask 的 get 方法所返回的结果类型。
所有已实现的接口：
Runnable, Future<V>, RunnableFuture<V>
public class FutureTask<V>
extends Object
implements RunnableFuture<V>

可取消的异步计算。利用开始和取消计算的方法、查询计算是否完成的方法和获取计算结果的方法，此类提供了对 Future 的基本实现。仅在计算完成时才能获取结果；如果计算尚未完成，则阻塞 get 方法。一旦计算完成，就不能再重新开始或取消计算。

可使用 FutureTask 包装 Callable 或 Runnable 对象。因为 FutureTask 实现了 Runnable，所以可将 FutureTask 提交给 Executor 执行。

除了作为一个独立的类外，此类还提供了 protected 功能，这在创建自定义任务类时可能很有用。

从以下版本开始：
1.5

构造方法摘要
FutureTask(Callable<V> callable)
创建一个 FutureTask，一旦运行就执行给定的 Callable。
FutureTask(Runnable runnable, V result)
创建一个 FutureTask，一旦运行就执行给定的 Runnable，并安排成功完成时 get 返回给定的结果 。
方法摘要
boolean | cancel(boolean mayInterruptIfRunning) 试图取消对此任务的执行。
protected void | done() 当此任务转换到状态 isDone（不管是正常地还是通过取消）时，调用受保护的方法。
V | get() 如有必要，等待计算完成，然后获取其结果。
V | get(long timeout, TimeUnit unit) 如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
boolean | isCancelled() 如果在任务正常完成前将其取消，则返回 true。
boolean | isDone() 如果任务已完成，则返回 true。
void | run() 除非已将此 Future 取消，否则将其设置为其计算的结果。
protected boolean | runAndReset() 执行计算而不设置其结果，然后将此 Future 重置为初始状态，如果计算遇到异常或已取消，则该操作失败。
protected void | set(V v) 除非已经设置了此 Future 或已将其取消，否则将其结果设置为给定的值。
protected void | setException(Throwable t) 除非已经设置了此 Future 或已将其取消，否则它将报告一个 ExecutionException，并将给定的 throwable 作为其原因。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FutureTask

public FutureTask(Callable<V> callable)
创建一个 FutureTask，一旦运行就执行给定的 Callable。

参数：
callable - 可调用的任务。
抛出：
NullPointerException - 如果 callable 为 null。

FutureTask

public FutureTask(Runnable runnable,
                  V result)
创建一个 FutureTask，一旦运行就执行给定的 Runnable，并安排成功完成时 get 返回给定的结果 。

参数：
runnable - 可运行的任务。
result - 成功完成时要返回的结果。如果不需要特定的结果，则考虑使用下列形式的构造：Future<?> f = new FutureTask<Object>(runnable, null)
抛出：
NullPointerException - 如果 runnable 为 null。
方法详细信息

isCancelled

public boolean isCancelled()
从接口 Future 复制的描述
如果在任务正常完成前将其取消，则返回 true。

指定者：
接口 Future<V> 中的 isCancelled
返回：
如果任务完成前将其取消，则返回 true

isDone

public boolean isDone()
从接口 Future 复制的描述
如果任务已完成，则返回 true。 可能由于正常终止、异常或取消而完成，在所有这些情况中，此方法都将返回 true。

指定者：
接口 Future<V> 中的 isDone
返回：
如果任务已完成，则返回 true

cancel

public boolean cancel(boolean mayInterruptIfRunning)
从接口 Future 复制的描述
试图取消对此任务的执行。如果任务已完成、或已取消，或者由于某些其他原因而无法取消，则此尝试将失败。当调用 cancel 时，如果调用成功，而此任务尚未启动，则此任务将永不运行。如果任务已经启动，则 mayInterruptIfRunning 参数确定是否应该以试图停止任务的方式来中断执行此任务的线程。

此方法返回后，对 Future.isDone() 的后续调用将始终返回 true。如果此方法返回 true，则对 Future.isCancelled() 的后续调用将始终返回 true。

指定者：
接口 Future<V> 中的 cancel
参数：
mayInterruptIfRunning - 如果应该中断执行此任务的线程，则为 true；否则允许正在运行的任务运行完成
返回：
如果无法取消任务，则返回 false，这通常是由于它已经正常完成；否则返回 true

get

public V get()
      throws InterruptedException,
             ExecutionException
从接口 Future 复制的描述
如有必要，等待计算完成，然后获取其结果。

指定者：
接口 Future<V> 中的 get
返回：
计算的结果
抛出：
CancellationException - 如果计算被取消
InterruptedException - 如果当前的线程在等待时被中断
ExecutionException - 如果计算抛出异常

get

public V get(long timeout,
             TimeUnit unit)
      throws InterruptedException,
             ExecutionException,
             TimeoutException
从接口 Future 复制的描述
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

指定者：
接口 Future<V> 中的 get
参数：
timeout - 等待的最大时间
unit - timeout 参数的时间单位
返回：
计算的结果
抛出：
CancellationException - 如果计算被取消
InterruptedException - 如果当前的线程在等待时被中断
ExecutionException - 如果计算抛出异常
TimeoutException - 如果等待超时

done

protected void done()
当此任务转换到状态 isDone（不管是正常地还是通过取消）时，调用受保护的方法。默认实现不执行任何操作。子类可以重写此方法，以调用完成回调或执行簿记。注意，可以查询此方法的实现内的状态，从而确定是否已取消了此任务。

set

protected void set(V v)
除非已经设置了此 Future 或已将其取消，否则将其结果设置为给定的值。在计算成功完成时通过 run 方法内部调用此方法。

参数：
v - 值

setException

protected void setException(Throwable t)
除非已经设置了此 Future 或已将其取消，否则它将报告一个 ExecutionException，并将给定的 throwable 作为其原因。在计算失败时通过 run 方法内部调用此方法。

参数：
t - 失败的原因

run

public void run()
除非已将此 Future 取消，否则将其设置为其计算的结果。

指定者：
接口 Runnable 中的 run
指定者：
接口 RunnableFuture<V> 中的 run
另请参见：
Thread.run()

runAndReset

protected boolean runAndReset()
执行计算而不设置其结果，然后将此 Future 重置为初始状态，如果计算遇到异常或已取消，则该操作失败。本操作被设计用于那些本质上要执行多次的任务。

返回：
如果成功运行并重置，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkedBlockingDeque (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 LinkedBlockingDeque<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.concurrent.LinkedBlockingDeque<E>
类型参数：
E - 保存在此 collection 中的元素类型
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, BlockingDeque<E>, BlockingQueue<E>, Deque<E>, Queue<E>
public class LinkedBlockingDeque<E>
extends AbstractQueue<E>
implements BlockingDeque<E>, Serializable

一个基于已链接节点的、任选范围的阻塞双端队列。

可选的容量范围构造方法参数是一种防止过度膨胀的方式。如果未指定容量，那么容量将等于 Integer.MAX_VALUE。只要插入元素不会使双端队列超出容量，每次插入后都将动态地创建链接节点。

大多数操作都以固定时间运行（不计阻塞消耗的时间）。异常包括 remove、removeFirstOccurrence、removeLastOccurrence、contains、iterator.remove() 以及批量操作，它们均以线性时间运行。

此类及其迭代器实现 Collection 和 Iterator 接口的所有可选 方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
LinkedBlockingDeque()
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque。
LinkedBlockingDeque(Collection<? extends E> c)
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque，最初包含给定 collection 的元素，以该 collection 迭代器的遍历顺序添加。
LinkedBlockingDeque(int capacity)
创建一个具有给定（固定）容量的 LinkedBlockingDeque。
方法摘要
 boolean add(E e)
在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。
 void addFirst(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头；如果当前没有空间可用，则抛出 IllegalStateException。
 void addLast(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾；如果当前没有空间可用，则抛出 IllegalStateException。
 void clear()
以原子方式 (atomically) 从此双端队列移除所有元素。
 boolean contains(Object o)
如果此双端队列包含指定的元素，则返回 true。
 Iterator<E> descendingIterator()
返回在此双端队列的元素上以逆向连续顺序进行迭代的迭代器。
 int drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 E element()
获取但不移除此双端队列表示的队列的头部。
 E getFirst()
获取，但不移除此双端队列的第一个元素。
 E getLast()
获取，但不移除此双端队列的最后一个元素。
 Iterator<E> iterator()
返回在此双端队列元素上以恰当顺序进行迭代的迭代器。
 boolean offer(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则返回 false。
 boolean offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
 boolean offerFirst(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头，并在成功时返回 true；如果当前没有空间可用，则返回 false。
 boolean offerFirst(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
 boolean offerLast(E e)
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾，并在成功时返回 true；如果当前没有空间可用，则返回 false。
 boolean offerLast(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
 E peek()
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
 E peekFirst()
获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
 E peekLast()
获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
 E poll()
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。
 E poll(long timeout, TimeUnit unit)
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
 E pollFirst()
获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。
 E pollFirst(long timeout, TimeUnit unit)
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
 E pollLast()
获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。
 E pollLast(long timeout, TimeUnit unit)
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
 E pop()
从此双端队列所表示的堆栈中弹出一个元素。
 void push(E e)
将元素推入此双端队列表示的栈。
 void put(E e)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。
 void putFirst(E e)
将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。
 void putLast(E e)
将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。
 int remainingCapacity()
返回理想情况下（没有内存和资源约束）此双端队列可不受阻塞地接受的额外元素数。
 E remove()
获取并移除此双端队列表示的队列的头部。
 boolean remove(Object o)
从此双端队列移除第一次出现的指定元素。
 E removeFirst()
获取并移除此双端队列第一个元素。
 boolean removeFirstOccurrence(Object o)
从此双端队列移除第一次出现的指定元素。
 E removeLast()
获取并移除此双端队列的最后一个元素。
 boolean removeLastOccurrence(Object o)
从此双端队列移除最后一次出现的指定元素。
 int size()
返回此双端队列中的元素数。
 E take()
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。
 E takeFirst()
获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。
 E takeLast()
获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。
 Object[] toArray()
返回以恰当顺序（从第一个元素到最后一个元素）包含此双端队列所有元素的数组。
<T> T[]
toArray(T[] a)
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
 String toString()
返回此 collection 的字符串表示形式。
从类 java.util.AbstractQueue 继承的方法
addAll
从类 java.util.AbstractCollection 继承的方法
containsAll, isEmpty, removeAll, retainAll
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Collection 继承的方法
addAll, containsAll, equals, hashCode, isEmpty, removeAll, retainAll

构造方法详细信息

LinkedBlockingDeque

public LinkedBlockingDeque()
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque。

LinkedBlockingDeque

public LinkedBlockingDeque(int capacity)
创建一个具有给定（固定）容量的 LinkedBlockingDeque。

参数：
capacity - 此双端队列的容量
抛出：
IllegalArgumentException - 如果 capacity 小于 1

LinkedBlockingDeque

public LinkedBlockingDeque(Collection<? extends E> c)
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque，最初包含给定 collection 的元素，以该 collection 迭代器的遍历顺序添加。

参数：
c - 最初所包含元素所属的 collection
抛出：
NullPointerException - 如果指定 collection 或其任意元素为 null
方法详细信息

addFirst

public void addFirst(E e)
从接口 BlockingDeque 复制的描述
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头；如果当前没有空间可用，则抛出 IllegalStateException。当使用有容量限制的双端队列时，通常首选 offerFirst。

指定者：
接口 BlockingDeque<E> 中的 addFirst
指定者：
接口 Deque<E> 中的 addFirst
参数：
e - 要添加的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
NullPointerException - 如果指定的元素为 null

addLast

public void addLast(E e)
从接口 BlockingDeque 复制的描述
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾；如果当前没有空间可用，则抛出 IllegalStateException。当使用有容量限制的双端队列时，通常首选 offerLast。

指定者：
接口 BlockingDeque<E> 中的 addLast
指定者：
接口 Deque<E> 中的 addLast
参数：
e - 要添加的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
NullPointerException - 如果指定的元素为 null

offerFirst

public boolean offerFirst(E e)
从接口 BlockingDeque 复制的描述
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的开头，并在成功时返回 true；如果当前没有空间可用，则返回 false。当使用有容量限制的双端队列时，此方法通常优于 addFirst 方法，后者可能无法插入元素，而只是抛出一个异常。

指定者：
接口 BlockingDeque<E> 中的 offerFirst
指定者：
接口 Deque<E> 中的 offerFirst
参数：
e - 要添加的元素
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
NullPointerException - 如果指定的元素为 null

offerLast

public boolean offerLast(E e)
从接口 BlockingDeque 复制的描述
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列的末尾，并在成功时返回 true；如果当前没有空间可用，则返回 false。当使用有容量限制的双端队列时，该方法通常优于 addLast 方法，后者可能无法插入元素，而只是抛出一个异常。

指定者：
接口 BlockingDeque<E> 中的 offerLast
指定者：
接口 Deque<E> 中的 offerLast
参数：
e - 要添加的元素
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
NullPointerException - 如果指定的元素为 null

putFirst

public void putFirst(E e)
              throws InterruptedException
从接口 BlockingDeque 复制的描述
将指定的元素插入此双端队列的开头，必要时将一直等待可用空间。

指定者：
接口 BlockingDeque<E> 中的 putFirst
参数：
e - 要添加的元素
抛出：
NullPointerException - 如果指定的元素为 null
InterruptedException - 如果在等待时被中断

putLast

public void putLast(E e)
             throws InterruptedException
从接口 BlockingDeque 复制的描述
将指定的元素插入此双端队列的末尾，必要时将一直等待可用空间。

指定者：
接口 BlockingDeque<E> 中的 putLast
参数：
e - 要添加的元素
抛出：
NullPointerException - 如果指定的元素为 null
InterruptedException - 如果在等待时被中断

offerFirst

public boolean offerFirst(E e,
                          long timeout,
                          TimeUnit unit)
                   throws InterruptedException
从接口 BlockingDeque 复制的描述
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。

指定者：
接口 BlockingDeque<E> 中的 offerFirst
参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true；如果在空间可用前超过了指定的等待时间，则返回 false
抛出：
NullPointerException - 如果指定的元素为 null
InterruptedException - 如果在等待时被中断

offerLast

public boolean offerLast(E e,
                         long timeout,
                         TimeUnit unit)
                  throws InterruptedException
从接口 BlockingDeque 复制的描述
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。

指定者：
接口 BlockingDeque<E> 中的 offerLast
参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true；如果在空间可用前超过了指定的等待时间，则返回 false
抛出：
NullPointerException - 如果指定的元素为 null
InterruptedException - 如果在等待时被中断

removeFirst

public E removeFirst()
从接口 Deque 复制的描述
获取并移除此双端队列第一个元素。此方法与 pollFirst 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 removeFirst
返回：
此双端队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

removeLast

public E removeLast()
从接口 Deque 复制的描述
获取并移除此双端队列的最后一个元素。此方法与 pollLast 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 removeLast
返回：
此双端队列的尾部
抛出：
NoSuchElementException - 如果此双端队列为空

pollFirst

public E pollFirst()
从接口 Deque 复制的描述
获取并移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 pollFirst
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

pollLast

public E pollLast()
从接口 Deque 复制的描述
获取并移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 pollLast
返回：
此双端队列的尾部；如果此双端队列为空，则返回 null

takeFirst

public E takeFirst()
            throws InterruptedException
从接口 BlockingDeque 复制的描述
获取并移除此双端队列的第一个元素，必要时将一直等待可用元素。

指定者：
接口 BlockingDeque<E> 中的 takeFirst
返回：
此双端队列的头部
抛出：
InterruptedException - 如果在等待时被中断

takeLast

public E takeLast()
           throws InterruptedException
从接口 BlockingDeque 复制的描述
获取并移除此双端队列的最后一个元素，必要时将一直等待可用元素。

指定者：
接口 BlockingDeque<E> 中的 takeLast
返回：
此双端队列的尾部
抛出：
InterruptedException - 如果在等待时被中断

pollFirst

public E pollFirst(long timeout,
                   TimeUnit unit)
            throws InterruptedException
从接口 BlockingDeque 复制的描述
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。

指定者：
接口 BlockingDeque<E> 中的 pollFirst
参数：
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此双端队列的头部，如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

pollLast

public E pollLast(long timeout,
                  TimeUnit unit)
           throws InterruptedException
从接口 BlockingDeque 复制的描述
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。

指定者：
接口 BlockingDeque<E> 中的 pollLast
参数：
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此双端队列的尾部，如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

getFirst

public E getFirst()
从接口 Deque 复制的描述
获取，但不移除此双端队列的第一个元素。 此方法与 peekFirst 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 getFirst
返回：
此双端队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

getLast

public E getLast()
从接口 Deque 复制的描述
获取，但不移除此双端队列的最后一个元素。此方法与 peekLast 唯一的不同在于：如果此双端队列为空，它将抛出一个异常。

指定者：
接口 Deque<E> 中的 getLast
返回：
此双端队列的尾部
抛出：
NoSuchElementException - 如果此双端队列为空

peekFirst

public E peekFirst()
从接口 Deque 复制的描述
获取，但不移除此双端队列的第一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 peekFirst
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

peekLast

public E peekLast()
从接口 Deque 复制的描述
获取，但不移除此双端队列的最后一个元素；如果此双端队列为空，则返回 null。

指定者：
接口 Deque<E> 中的 peekLast
返回：
此双端队列的尾部；如果此双端队列为空，则返回 null

removeFirstOccurrence

public boolean removeFirstOccurrence(Object o)
从接口 BlockingDeque 复制的描述
从此双端队列移除第一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

指定者：
接口 BlockingDeque<E> 中的 removeFirstOccurrence
指定者：
接口 Deque<E> 中的 removeFirstOccurrence
参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果由于此调用而移除了一个元素，则返回 true

removeLastOccurrence

public boolean removeLastOccurrence(Object o)
从接口 BlockingDeque 复制的描述
从此双端队列移除最后一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除最后一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

指定者：
接口 BlockingDeque<E> 中的 removeLastOccurrence
指定者：
接口 Deque<E> 中的 removeLastOccurrence
参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果由于此调用而移除了一个元素，则返回 true

add

public boolean add(E e)
在不违反容量限制的情况下，将指定的元素插入此双端队列的末尾。当使用有容量限制的双端队列时，通常首选 offer 方法。

此方法等效于 addLast(E)。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 BlockingDeque<E> 中的 add
指定者：
接口 BlockingQueue<E> 中的 add
指定者：
接口 Deque<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractQueue<E> 中的 add
参数：
e - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
IllegalStateException - 如果此刻由于容量限制而无法添加元素
NullPointerException - 如果指定的元素为 null

offer

public boolean offer(E e)
从接口 BlockingDeque 复制的描述
如果立即可行且不违反容量限制，则将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），并在成功时返回 true；如果当前没有空间可用，则返回 false。当使用有容量限制的双端队列时，此方法通常优于 BlockingDeque.add(E) 方法，后者可能无法插入元素，而只是抛出一个异常。

此方法等效于 offerLast。

指定者：
接口 BlockingDeque<E> 中的 offer
指定者：
接口 BlockingQueue<E> 中的 offer
指定者：
接口 Deque<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
如果该元素已添加到此队列，则返回 true；否则返回 false
抛出：
NullPointerException - 如果指定的元素为 null

put

public void put(E e)
         throws InterruptedException
从接口 BlockingDeque 复制的描述
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将一直等待可用空间。

此方法等效于 putLast。

指定者：
接口 BlockingDeque<E> 中的 put
指定者：
接口 BlockingQueue<E> 中的 put
参数：
e - 要添加的元素
抛出：
NullPointerException - 如果指定的元素为 null
InterruptedException - 如果在等待时被中断

offer

public boolean offer(E e,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
从接口 BlockingDeque 复制的描述
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。

此方法等效于 offerLast。

指定者：
接口 BlockingDeque<E> 中的 offer
指定者：
接口 BlockingQueue<E> 中的 offer
参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果元素被添加到此双端队列，则返回 true，否则返回 false
抛出：
NullPointerException - 如果指定的元素为 null
InterruptedException - 如果在等待时被中断

remove

public E remove()
获取并移除此双端队列表示的队列的头部。此方法与 poll 的不同之处在于：如果此双端队列为空，它将抛出一个异常。

此方法等效于 removeFirst。

指定者：
接口 BlockingDeque<E> 中的 remove
指定者：
接口 Deque<E> 中的 remove
指定者：
接口 Queue<E> 中的 remove
覆盖：
类 AbstractQueue<E> 中的 remove
返回：
此双端队列表示的队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

poll

public E poll()
从接口 BlockingDeque 复制的描述
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。

此方法等效于 Deque.pollFirst()。

指定者：
接口 BlockingDeque<E> 中的 poll
指定者：
接口 Deque<E> 中的 poll
指定者：
接口 Queue<E> 中的 poll
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

take

public E take()
       throws InterruptedException
从接口 BlockingDeque 复制的描述
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），必要时将一直等待可用元素。

此方法等效于 takeFirst。

指定者：
接口 BlockingDeque<E> 中的 take
指定者：
接口 BlockingQueue<E> 中的 take
返回：
此双端队列的头部
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll(long timeout,
              TimeUnit unit)
       throws InterruptedException
从接口 BlockingDeque 复制的描述
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。

此方法等效于 pollFirst。

指定者：
接口 BlockingDeque<E> 中的 poll
指定者：
接口 BlockingQueue<E> 中的 poll
参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此双端队列的头部；如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

element

public E element()
获取但不移除此双端队列表示的队列的头部。此方法与 peek 的不同之处在于：如果此双端队列为空，它将抛出一个异常。

此方法等效于 getFirst。

指定者：
接口 BlockingDeque<E> 中的 element
指定者：
接口 Deque<E> 中的 element
指定者：
接口 Queue<E> 中的 element
覆盖：
类 AbstractQueue<E> 中的 element
返回：
此双端队列表示的队列的头部
抛出：
NoSuchElementException - 如果此双端队列为空

peek

public E peek()
从接口 BlockingDeque 复制的描述
获取但不移除此双端队列表示的队列的头部（即此双端队列的第一个元素）；如果此双端队列为空，则返回 null。

此方法等效于 peekFirst。

指定者：
接口 BlockingDeque<E> 中的 peek
指定者：
接口 Deque<E> 中的 peek
指定者：
接口 Queue<E> 中的 peek
返回：
此双端队列的头部；如果此双端队列为空，则返回 null

remainingCapacity

public int remainingCapacity()
返回理想情况下（没有内存和资源约束）此双端队列可不受阻塞地接受的额外元素数。该数目总是等于此双端队列的初始容量，小于此双端队列的当前 size。

注意，不能 总是通过检查 remainingCapacity 断定试图插入元素能否成功，因为可能出现另一个线程即将插入或移除一个元素的情况。

指定者：
接口 BlockingQueue<E> 中的 remainingCapacity
返回：
剩余容量

drainTo

public int drainTo(Collection<? super E> c)
从接口 BlockingQueue 复制的描述
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。此操作可能比反复轮询此队列更有效。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

drainTo

public int drainTo(Collection<? super E> c,
                   int maxElements)
从接口 BlockingQueue 复制的描述
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
maxElements - 传输元素的最大数量
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

push

public void push(E e)
从接口 BlockingDeque 复制的描述
将元素推入此双端队列表示的栈。换句话说，在不违反容量限制的情况下，将元素插入双端队列的开头。

此方法等效于 addFirst。

指定者：
接口 BlockingDeque<E> 中的 push
指定者：
接口 Deque<E> 中的 push
参数：
e - 要推入的元素
抛出：
IllegalStateException - 如果此时由于容量限制而无法添加元素
NullPointerException - 如果指定的元素为 null

pop

public E pop()
从接口 Deque 复制的描述
从此双端队列所表示的堆栈中弹出一个元素。换句话说，移除并返回此双端队列第一个元素。

此方法等效于 Deque.removeFirst()。

指定者：
接口 Deque<E> 中的 pop
返回：
此双端队列开头的元素（它是此双端队列所表示的堆栈的顶部）
抛出：
NoSuchElementException - 如果此双端队列为空

remove

public boolean remove(Object o)
从此双端队列移除第一次出现的指定元素。如果此双端队列不包含该元素，则不作更改。更确切地讲，移除第一个满足 o.equals(e) 的元素 e（如果存在这样的元素）。如果此双端队列包含指定的元素（或者此双端队列由于调用而发生了更改），则返回 true。

此方法等效于 removeFirstOccurrence。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 BlockingDeque<E> 中的 remove
指定者：
接口 BlockingQueue<E> 中的 remove
指定者：
接口 Deque<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此双端队列移除的元素（如果存在）
返回：
如果此双端队列由于调用而发生更改，则返回 true

size

public int size()
返回此双端队列中的元素数。

指定者：
接口 Collection<E> 中的 size
指定者：
接口 BlockingDeque<E> 中的 size
指定者：
接口 Deque<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此双端队列中的元素数

contains

public boolean contains(Object o)
如果此双端队列包含指定的元素，则返回 true。更确切地讲，当且仅当此双端队列至少包含一个满足 o.equals(e) 的元素 e，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 BlockingDeque<E> 中的 contains
指定者：
接口 BlockingQueue<E> 中的 contains
指定者：
接口 Deque<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 检查是否包含于此双端队列的对象
返回：
如果此双端队列包含指定的元素，则返回 true。

toArray

public Object[] toArray()
返回以恰当顺序（从第一个元素到最后一个元素）包含此双端队列所有元素的数组。

由于此双端队列不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新的数组）。因此，调用者可以自由地修改返回的数组。

此方法充当了基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此双端队列中所有元素的数组。

toArray

public <T> T[] toArray(T[] a)
返回以恰当顺序包含此双端队列所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。如果指定的数组能容纳该双端队列，则将双端队列返回此处。否则，将分配一个具有指定数组的运行时类型和此双端队列大小的新数组。

如果指定的数组能容纳此双端队列，并且有剩余的空间（即数组的元素比双端队列多），那么将数组中紧接双端队列尾部的元素设置为 null。

像 toArray() 方法一样，此方法充当基于数组 的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，还可以用来节省分配开销。

假定 x 是只包含字符串的一个已知双端队列。以下代码用来将该双端队列转储到一个新分配的 String 数组：

String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 要用来存储双端队列元素的数组（如果该数组足够大）；否则，将为此分配一个具有相同运行时类型的新数组
返回：
包含此双端队列所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此双端队列每个元素的运行时类型的超类型
NullPointerException - 如果指定的数组为 null

toString

public String toString()
从类 AbstractCollection 复制的描述
返回此 collection 的字符串表示形式。该字符串表示形式由 collection 元素的列表组成，这些元素按其迭代器返回的顺序排列，并用方括号 ("[]") 括起来。相邻元素由字符 ", "（逗号加空格）分隔。通过 String.valueOf(Object) 可以将元素转换成字符串。

覆盖：
类 AbstractCollection<E> 中的 toString
返回：
此 collection 的字符串表示形式

clear

public void clear()
以原子方式 (atomically) 从此双端队列移除所有元素。在此调用返回之后，该双端队列将为空。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractQueue<E> 中的 clear

iterator

public Iterator<E> iterator()
返回在此双端队列元素上以恰当顺序进行迭代的迭代器。元素将按从第一个（头部）到最后一个（尾部）的顺序返回。返回的 Iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历迭代器构造后存在的所有元素，并可以（但并不保证）反映构造后的任何修改。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
接口 BlockingDeque<E> 中的 iterator
指定者：
接口 Deque<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
按恰当顺序在此双端队列的元素上进行迭代的迭代器

descendingIterator

public Iterator<E> descendingIterator()
返回在此双端队列的元素上以逆向连续顺序进行迭代的迭代器。元素将按从最后一个（尾部）到第一个（头部）的顺序返回。返回的 Iterator 是一个不会抛出 ConcurrentModificationException 的“弱一致”迭代器，能确保遍历迭代器构造后存在的所有元素，并可以（但并不保证）反映构造后的任何修改。

指定者：
接口 Deque<E> 中的 descendingIterator
返回：
以逆向顺序在此双端队列中的元素上进行迭代的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkedBlockingQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 LinkedBlockingQueue<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.concurrent.LinkedBlockingQueue<E>
类型参数：
E - 此 collection 中所保存元素的类型。
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, BlockingQueue<E>, Queue<E>
public class LinkedBlockingQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable

一个基于已链接节点的、范围任意的 blocking queue。此队列按 FIFO（先进先出）排序元素。队列的头部 是在队列中时间最长的元素。队列的尾部 是在队列中时间最短的元素。新元素插入到队列的尾部，并且队列获取操作会获得位于队列头部的元素。链接队列的吞吐量通常要高于基于数组的队列，但是在大多数并发应用程序中，其可预知的性能要低。

可选的容量范围构造方法参数作为防止队列过度扩展的一种方法。如果未指定容量，则它等于 Integer.MAX_VALUE。除非插入节点会使队列超出容量，否则每次插入后会动态地创建链接节点。

此类及其迭代器实现 Collection 和 Iterator 接口的所有可选 方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
LinkedBlockingQueue()
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingQueue。
LinkedBlockingQueue(Collection<? extends E> c)
创建一个容量是 Integer.MAX_VALUE 的 LinkedBlockingQueue，最初包含给定 collection 的元素，元素按该 collection 迭代器的遍历顺序添加。
LinkedBlockingQueue(int capacity)
创建一个具有给定（固定）容量的 LinkedBlockingQueue。
方法摘要
 void clear()
从队列彻底移除所有元素。
 int drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 Iterator<E> iterator()
返回在队列中的元素上按适当顺序进行迭代的迭代器。
 boolean offer(E e)
将指定元素插入到此队列的尾部（如果立即可行且不会超出此队列的容量），在成功时返回 true，如果此队列已满，则返回 false。
 boolean offer(E e, long timeout, TimeUnit unit)
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。
 E peek()
获取但不移除此队列的头；如果此队列为空，则返回 null。
 E poll()
获取并移除此队列的头，如果此队列为空，则返回 null。
 E poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
 void put(E e)
将指定元素插入到此队列的尾部，如有必要，则等待空间变得可用。
 int remainingCapacity()
返回理想情况下（没有内存和资源约束）此队列可接受并且不会被阻塞的附加元素数量。
 boolean remove(Object o)
从此队列移除指定元素的单个实例（如果存在）。
 int size()
返回队列中的元素个数。
 E take()
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
 Object[] toArray()
返回按适当顺序包含此队列中所有元素的数组。
<T> T[]
toArray(T[] a)
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。
 String toString()
返回此 collection 的字符串表示形式。
从类 java.util.AbstractQueue 继承的方法
add, addAll, element, remove
从类 java.util.AbstractCollection 继承的方法
contains, containsAll, isEmpty, removeAll, retainAll
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.concurrent.BlockingQueue 继承的方法
add, contains
从接口 java.util.Queue 继承的方法
element, remove
从接口 java.util.Collection 继承的方法
addAll, containsAll, equals, hashCode, isEmpty, removeAll, retainAll

构造方法详细信息

LinkedBlockingQueue

public LinkedBlockingQueue()
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingQueue。

LinkedBlockingQueue

public LinkedBlockingQueue(int capacity)
创建一个具有给定（固定）容量的 LinkedBlockingQueue。

参数：
capacity - 队列的容量
抛出：
IllegalArgumentException - 如果 capacity 未大于 0

LinkedBlockingQueue

public LinkedBlockingQueue(Collection<? extends E> c)
创建一个容量是 Integer.MAX_VALUE 的 LinkedBlockingQueue，最初包含给定 collection 的元素，元素按该 collection 迭代器的遍历顺序添加。

参数：
c - 最初所包含元素所属的 collection
抛出：
NullPointerException - 如果指定 collection 或其所有元素均为 null
方法详细信息

size

public int size()
返回队列中的元素个数。

指定者：
接口 Collection<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
队列中的元素个数

remainingCapacity

public int remainingCapacity()
返回理想情况下（没有内存和资源约束）此队列可接受并且不会被阻塞的附加元素数量。该数量总是等于此队列的初始容量，小于队列的当前 size。

注意，不能 总是通过检查 remainingCapacity 来断定试图插入一个元素是否成功，因为可能是另一个线程将插入或移除某个元素。

指定者：
接口 BlockingQueue<E> 中的 remainingCapacity
返回：
剩余容量

put

public void put(E e)
         throws InterruptedException
将指定元素插入到此队列的尾部，如有必要，则等待空间变得可用。

指定者：
接口 BlockingQueue<E> 中的 put
参数：
e - 要添加的元素
抛出：
InterruptedException - 如果在等待时被中断
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。

指定者：
接口 BlockingQueue<E> 中的 offer
参数：
e - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true；如果在空间可用前超出了指定的时间，则返回 false。
抛出：
InterruptedException - 如果在等待时被中断
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e)
将指定元素插入到此队列的尾部（如果立即可行且不会超出此队列的容量），在成功时返回 true，如果此队列已满，则返回 false。当使用有容量限制的队列时，此方法通常要优于 add 方法，后者可能无法插入元素，而只是抛出一个异常。

指定者：
接口 BlockingQueue<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
如果该元素已添加到此队列，则返回 true；否则返回 false
抛出：
NullPointerException - 如果指定元素为 null

take

public E take()
       throws InterruptedException
从接口 BlockingQueue 复制的描述
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。

指定者：
接口 BlockingQueue<E> 中的 take
返回：
此队列的头部
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll(long timeout,
              TimeUnit unit)
       throws InterruptedException
从接口 BlockingQueue 复制的描述
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。

指定者：
接口 BlockingQueue<E> 中的 poll
参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此队列的头部；如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll()
从接口 Queue 复制的描述
获取并移除此队列的头，如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 poll
返回：
队列的头，如果此队列为空，则返回 null

peek

public E peek()
从接口 Queue 复制的描述
获取但不移除此队列的头；如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 peek
返回：
此队列的头；如果此队列为空，则返回 null

remove

public boolean remove(Object o)
从此队列移除指定元素的单个实例（如果存在）。更确切地讲，如果此队列包含一个或多个满足 o.equals(e) 的元素 e， 则移除一个这样的元素。如果此队列包含指定元素，则返回 true（或者此队列由于调用而发生更改，则返回 true）。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 BlockingQueue<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要从此队列移除的元素（如果存在）
返回：
如果此队列由于调用而发生更改，则返回 true

toArray

public Object[] toArray()
返回按适当顺序包含此队列中所有元素的数组。

由于此队列不维护对返回数组的任何引用，因而它是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此队列中所有元素的数组

toArray

public <T> T[] toArray(T[] a)
返回按适当顺序包含此队列中所有元素的数组；返回数组的运行时类型是指定数组的运行时类型。如果指定数组能容纳该队列，则在其中返回它。否则，将分配一个具有指定数组的运行时类型和此队列大小的新数组。

如果指定的数组能容纳队列，并有剩余的空间（即数组的元素比队列的多），那么将数组中紧接队列尾部的元素设置为 null。

像 toArray() 方法一样，此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知队列。以下代码用来将该队列转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 用来存储队列元素的数组（如果它足够大）；否则，为此分配一个具有相同运行时类型的新数组。
返回：
包含此队列所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此队列中每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

toString

public String toString()
从类 AbstractCollection 复制的描述
返回此 collection 的字符串表示形式。该字符串表示形式由 collection 元素的列表组成，这些元素按其迭代器返回的顺序排列，并用方括号 ("[]") 括起来。相邻元素由字符 ", "（逗号加空格）分隔。通过 String.valueOf(Object) 可以将元素转换成字符串。

覆盖：
类 AbstractCollection<E> 中的 toString
返回：
此 collection 的字符串表示形式

clear

public void clear()
从队列彻底移除所有元素。此调用返回后队列为空。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractQueue<E> 中的 clear

drainTo

public int drainTo(Collection<? super E> c)
从接口 BlockingQueue 复制的描述
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。此操作可能比反复轮询此队列更有效。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

drainTo

public int drainTo(Collection<? super E> c,
                   int maxElements)
从接口 BlockingQueue 复制的描述
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
maxElements - 传输元素的最大数量
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

iterator

public Iterator<E> iterator()
返回在队列中的元素上按适当顺序进行迭代的迭代器。返回的 Iterator 是一个“弱一致”的迭代器，从不抛出 ConcurrentModificationException，并且确保可遍历迭代器构造后所存在的所有元素，并且可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
按适当顺序对队列中的元素进行迭代的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PriorityBlockingQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 PriorityBlockingQueue<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.concurrent.PriorityBlockingQueue<E>
类型参数：
E - 此 collection 中所保存元素的类型
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, BlockingQueue<E>, Queue<E>
public class PriorityBlockingQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable

一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。虽然此队列逻辑上是无界的，但是资源被耗尽时试图执行 add 操作也将失败（导致 OutOfMemoryError）。此类不允许使用 null 元素。依赖自然顺序的优先级队列也不允许插入不可比较的对象（这样做会导致抛出 ClassCastException）。

此类及其迭代器可以实现 Collection 和 Iterator 接口的所有可选 方法。iterator() 方法中提供的迭代器并不 保证以特定的顺序遍历 PriorityBlockingQueue 的元素。如果需要有序地进行遍历，则应考虑使用 Arrays.sort(pq.toArray())。此外，可以使用方法 drainTo 按优先级顺序移除 全部或部分元素，并将它们放在另一个 collection 中。

在此类上进行的操作不保证具有同等优先级的元素的顺序。如果需要实施某一排序，那么可以定义自定义类或者比较器，比较器可使用修改键断开主优先级值之间的联系。例如，以下是应用先进先出 (first-in-first-out) 规则断开可比较元素之间联系的一个类。要使用该类，则需要插入一个新的 FIFOEntry(anEntry) 来替换普通的条目对象。

 class FIFOEntry<E extends Comparable<? super E>>
     implements Comparable<FIFOEntry<E>> {
   final static AtomicLong seq = new AtomicLong();
   final long seqNum;
   final E entry;
   public FIFOEntry(E entry) {
     seqNum = seq.getAndIncrement();
     this.entry = entry;
   }
   public E getEntry() { return entry; }
   public int compareTo(FIFOEntry<E> other) {
     int res = entry.compareTo(other.entry);
     if (res == 0 && other.entry != this.entry)
       res = (seqNum < other.seqNum ? -1 : 1);
     return res;
   }
 }

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
PriorityBlockingQueue()
用默认的初始容量 (11) 创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。
PriorityBlockingQueue(Collection<? extends E> c)
创建一个包含指定 collection 元素的 PriorityBlockingQueue。
PriorityBlockingQueue(int initialCapacity)
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。
PriorityBlockingQueue(int initialCapacity, Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据指定的比较器对其元素进行排序。
方法摘要
 boolean add(E e)
将指定元素插入此优先级队列。
 void clear()
完全移除此队列中的所有元素。
 Comparator<? super E> comparator()
返回用于对此队列元素进行排序的比较器；如果此队列使用其元素的自然顺序，则返回 null。
 boolean contains(Object o)
如果队列包含指定的元素，则返回 true。
 int drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 Iterator<E> iterator()
返回在此队列元素上进行迭代的迭代器。
 boolean offer(E e)
将指定元素插入此优先级队列。
 boolean offer(E e, long timeout, TimeUnit unit)
将指定元素插入此优先级队列。
 E peek()
获取但不移除此队列的头；如果此队列为空，则返回 null。
 E poll()
获取并移除此队列的头，如果此队列为空，则返回 null。
 E poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
 void put(E e)
将指定元素插入此优先级队列。
 int remainingCapacity()
总是返回 Integer.MAX_VALUE，因为 PriorityBlockingQueue 没有容量限制。
 boolean remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。
 int size()
返回此 collection 中的元素数。
 E take()
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。
 Object[] toArray()
返回包含此队列所有元素的数组。
<T> T[]
toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。
 String toString()
返回此 collection 的字符串表示形式。
从类 java.util.AbstractQueue 继承的方法
addAll, element, remove
从类 java.util.AbstractCollection 继承的方法
containsAll, isEmpty, removeAll, retainAll
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.Queue 继承的方法
element, remove
从接口 java.util.Collection 继承的方法
addAll, containsAll, equals, hashCode, isEmpty, removeAll, retainAll

构造方法详细信息

PriorityBlockingQueue

public PriorityBlockingQueue()
用默认的初始容量 (11) 创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。

PriorityBlockingQueue

public PriorityBlockingQueue(int initialCapacity)
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据元素的自然顺序对其元素进行排序。

参数：
initialCapacity - 此优先级队列的初始容量
抛出：
IllegalArgumentException - 如果 initialCapacity 小于 1

PriorityBlockingQueue

public PriorityBlockingQueue(int initialCapacity,
                             Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据指定的比较器对其元素进行排序。

参数：
initialCapacity - 此优先级队列的初始容量
comparator - 用于对此优先级队列进行排序的比较器。如果参数为 null，则根据元素的自然顺序进行排序
抛出：
IllegalArgumentException - 如果 initialCapacity 小于 1

PriorityBlockingQueue

public PriorityBlockingQueue(Collection<? extends E> c)
创建一个包含指定 collection 元素的 PriorityBlockingQueue。如果指定 collection 是一个 SortedSet 或 PriorityQueue，则此优先级队列将按照相同顺序进行排序。否则，此优先级队列将根据此元素的自然顺序进行排序。

参数：
c - 其元素将被放置在此优先级队列中的 collection
抛出：
ClassCastException - 如果根据优先级队列的顺序，指定 collection 的元素无法与另一个 collection 的元素进行比较
NullPointerException - 如果指定 collection 或其任意元素为 null
方法详细信息

add

public boolean add(E e)
将指定元素插入此优先级队列。

指定者：
接口 Collection<E> 中的 add
指定者：
接口 BlockingQueue<E> 中的 add
指定者：
接口 Queue<E> 中的 add
覆盖：
类 AbstractQueue<E> 中的 add
参数：
o - 要添加的元素
返回：
true（根据 Collection.add(E) 的规定）
抛出：
ClassCastException - 如果根据优先级队列的排序规则，无法将指定的元素与优先级队列中当前的元素进行比较
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e)
将指定元素插入此优先级队列。

指定者：
接口 BlockingQueue<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 将添加的元素
返回：
true（根据 Queue.offer(E) 的规定）
抛出：
ClassCastException - 如果根据优先级队列的排序规则无法将指定元素与优先级队列中当前的元素进行比较
NullPointerException - 如果指定元素为 null

put

public void put(E e)
将指定元素插入此优先级队列。该队列是无界的，所以此方法不会阻塞。

指定者：
接口 BlockingQueue<E> 中的 put
参数：
e - 要添加的元素
抛出：
ClassCastException - 如果根据优先级队列的排序规则无法将指定元素与优先级队列中当前的元素进行比较
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e,
                     long timeout,
                     TimeUnit unit)
将指定元素插入此优先级队列。该队列是无界的，所以此方法不会阻塞。

指定者：
接口 BlockingQueue<E> 中的 offer
参数：
e - 要添加的元素
timeout - 忽略此参数，因为此方法不会阻塞
unit - 忽略此参数，因为此方法不会阻塞
返回：
true
抛出：
ClassCastException - 如果根据优先级队列的排序规则无法将指定元素与优先级队列中当前的元素进行比较
NullPointerException - 如果指定元素为 null

poll

public E poll()
从接口 Queue 复制的描述
获取并移除此队列的头，如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 poll
返回：
队列的头，如果此队列为空，则返回 null

take

public E take()
       throws InterruptedException
从接口 BlockingQueue 复制的描述
获取并移除此队列的头部，在元素变得可用之前一直等待（如果有必要）。

指定者：
接口 BlockingQueue<E> 中的 take
返回：
此队列的头部
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll(long timeout,
              TimeUnit unit)
       throws InterruptedException
从接口 BlockingQueue 复制的描述
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。

指定者：
接口 BlockingQueue<E> 中的 poll
参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
此队列的头部；如果在元素可用前超过了指定的等待时间，则返回 null
抛出：
InterruptedException - 如果在等待时被中断

peek

public E peek()
从接口 Queue 复制的描述
获取但不移除此队列的头；如果此队列为空，则返回 null。

指定者：
接口 Queue<E> 中的 peek
返回：
此队列的头；如果此队列为空，则返回 null

comparator

public Comparator<? super E> comparator()
返回用于对此队列元素进行排序的比较器；如果此队列使用其元素的自然顺序，则返回 null。

返回：
用于对此队列元素进行排序的比较器；如果此队列使用其元素的自然顺序，则返回 null

size

public int size()
从接口 Collection 复制的描述
返回此 collection 中的元素数。如果此 collection 包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

指定者：
接口 Collection<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
此 collection 中的元素数

remainingCapacity

public int remainingCapacity()
总是返回 Integer.MAX_VALUE，因为 PriorityBlockingQueue 没有容量限制。

指定者：
接口 BlockingQueue<E> 中的 remainingCapacity
返回：
Integer.MAX_VALUE

remove

public boolean remove(Object o)
从队列中移除指定元素的单个实例（如果存在）。更确切地讲，如果此队列包含一个或多个满足 o.equals(e) 的元素 e，则移除一个这样的元素。当且仅当此队列包含指定的元素（或者此队列由于调用而发生更改）时，返回 true。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 BlockingQueue<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 将从此队列中移除的元素（如果存在）
返回：
如果此队列由于调用而发生更改，则返回 true

contains

public boolean contains(Object o)
如果队列包含指定的元素，则返回 true。更确切地讲，当且仅当此队列至少包含一个满足 o.equals(e) 的元素 e 时，返回 true。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 BlockingQueue<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 要检查是否包含于此队列的对象
返回：
如果此队列包含指定元素，则返回 true

toArray

public Object[] toArray()
返回包含此队列所有元素的数组。所返回数组的元素没有特定的顺序。

由于此队列并不维护对返回数组的任何引用，因而它将是“安全的”。（换句话说，此方法必须分配一个新数组）。因此，调用者可以随意修改返回的数组。

此方法充当基于数组的 API 与基于 collection 的 API 之间的桥梁。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
包含此队列所有元素的数组

toString

public String toString()
从类 AbstractCollection 复制的描述
返回此 collection 的字符串表示形式。该字符串表示形式由 collection 元素的列表组成，这些元素按其迭代器返回的顺序排列，并用方括号 ("[]") 括起来。相邻元素由字符 ", "（逗号加空格）分隔。通过 String.valueOf(Object) 可以将元素转换成字符串。

覆盖：
类 AbstractCollection<E> 中的 toString
返回：
此 collection 的字符串表示形式

drainTo

public int drainTo(Collection<? super E> c)
从接口 BlockingQueue 复制的描述
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。此操作可能比反复轮询此队列更有效。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

drainTo

public int drainTo(Collection<? super E> c,
                   int maxElements)
从接口 BlockingQueue 复制的描述
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
maxElements - 传输元素的最大数量
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

clear

public void clear()
完全移除此队列中的所有元素。此调用返回后，队列将为空。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractQueue<E> 中的 clear

toArray

public <T> T[] toArray(T[] a)
返回一个包含此队列所有元素的数组；返回数组的运行时类型是指定数组的类型。所返回数组的元素没有特定的顺序。如果指定的数组能容纳队列，则将该队列返回此处。否则，将分配一个具有指定数组的运行时类型和此队列大小的新数组。

如果指定的数组能容纳队列，并有剩余的空间（即数组的元素比队列多），那么会将紧接队列尾部的元素设置为 null。

像 toArray() 方法一样，此方法充当基于数组 的 API 与基于 collection 的 API 之间的桥梁。更进一步说，此方法允许对输出数组的运行时类型进行精确控制，在某些情况下，可以用来节省分配开销。

假定 x 是只包含字符串的一个已知队列。以下代码用来将该队列转储到一个新分配的 String 数组：

     String[] y = x.toArray(new String[0]);
注意，toArray(new Object[0]) 和 toArray() 在功能上是相同的。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 用来存储队列元素的数组（如果该数组足够大）；否则为此分配一个具有相同运行时类型的新数组
返回：
包含此队列所有元素的数组
抛出：
ArrayStoreException - 如果指定数组的运行时类型不是此队列每个元素的运行时类型的超类型
NullPointerException - 如果指定数组为 null

iterator

public Iterator<E> iterator()
返回在此队列元素上进行迭代的迭代器。迭代器不以任何特定的顺序返回元素。返回的 Iterator 是一个“弱一致”迭代器，不会抛出 ConcurrentModificationException，并且可确保遍历迭代器构造后存在的所有元素，并且可能（但并不保证）反映构造后的所有修改。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
在此队列元素上进行迭代的迭代器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RunnableFuture (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 RunnableFuture<V>

类型参数：
V - 此 Future 的 get 方法所返回的结果类型。
所有超级接口：
Future<V>, Runnable
所有已知子接口：
RunnableScheduledFuture<V>
所有已知实现类：
FutureTask, SwingWorker
public interface RunnableFuture<V>
extends Runnable, Future<V>

作为 Runnable 的 Future。成功执行 run 方法可以完成 Future 并允许访问其结果。

从以下版本开始：
1.6
另请参见：
FutureTask, Executor

方法摘要
 void run()
在未被取消的情况下，将此 Future 设置为计算的结果。
从接口 java.util.concurrent.Future 继承的方法
cancel, get, get, isCancelled, isDone

方法详细信息

run

void run()
在未被取消的情况下，将此 Future 设置为计算的结果。

指定者：
接口 Runnable 中的 run
另请参见：
Thread.run()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RejectedExecutionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 RejectedExecutionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.util.concurrent.RejectedExecutionException
所有已实现的接口：
Serializable
public class RejectedExecutionException
extends RuntimeException

当无法执行某个任务时,由 Executor 抛出的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RejectedExecutionException()
构造不带详细消息的 RejectedExecutionException。
RejectedExecutionException(String message)
构造带指定详细消息的 RejectedExecutionException。
RejectedExecutionException(String message, Throwable cause)
构造带指定详细消息和原因的 RejectedExecutionException。
RejectedExecutionException(Throwable cause)
构造带指定原因的 RejectedExecutionException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RejectedExecutionException

public RejectedExecutionException()
构造不带详细消息的 RejectedExecutionException。原因尚未进行初始化，可在以后通过调用 initCause 来初始化。

RejectedExecutionException

public RejectedExecutionException(String message)
构造带指定详细消息的 RejectedExecutionException。原因尚未进行初始化，可在以后通过调用 initCause 来初始化。

参数：
message - 详细消息。

RejectedExecutionException

public RejectedExecutionException(String message,
                                  Throwable cause)
构造带指定详细消息和原因的 RejectedExecutionException。

参数：
message - 详细消息。
cause - 原因（保存此原因，是为了以后通过 Throwable.getCause() 方法来获取）。

RejectedExecutionException

public RejectedExecutionException(Throwable cause)
构造带指定原因的 RejectedExecutionException。详细消息设置为：
 (cause ==
 null ? null :cause.toString())
（它通常包含该类和 cause 的详细消息）。

参数：
cause - 原因（保存此原因，是为了以后通过 Throwable.getCause() 方法来获取）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RejectedExecutionHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 RejectedExecutionHandler

所有已知实现类：
ThreadPoolExecutor.AbortPolicy, ThreadPoolExecutor.CallerRunsPolicy, ThreadPoolExecutor.DiscardOldestPolicy, ThreadPoolExecutor.DiscardPolicy
public interface RejectedExecutionHandler

无法由 ThreadPoolExecutor 执行的任务的处理程序。

从以下版本开始：
1.5

方法摘要
 void rejectedExecution(Runnable r, ThreadPoolExecutor executor)
当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。

方法详细信息

rejectedExecution

void rejectedExecution(Runnable r,
                       ThreadPoolExecutor executor)
当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。因为超出其界限而没有更多可用的线程或队列槽时，或者关闭 Executor 时就可能发生这种情况。

在没有其他替代方法的情况下，该方法可能抛出未经检查的 RejectedExecutionException，而该异常将传播到 execute 的调用者。

参数：
r - 所请求执行的可运行任务。
executor - 试图执行此任务的执行程序。
抛出：
RejectedExecutionException - 如果没有补救方法。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RunnableScheduledFuture (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 RunnableScheduledFuture<V>

类型参数：
V - 此 Future 的 get 方法所返回的结果类型。
所有超级接口：
Comparable<Delayed>, Delayed, Future<V>, Runnable, RunnableFuture<V>, ScheduledFuture<V>
public interface RunnableScheduledFuture<V>
extends RunnableFuture<V>, ScheduledFuture<V>

作为 Runnable 的 ScheduledFuture。成功执行 run 方法可以完成 Future 并允许访问其结果。

从以下版本开始：
1.6
另请参见：
FutureTask, Executor

方法摘要
 boolean isPeriodic()
如果这是一个定期任务，则返回 true。
从接口 java.util.concurrent.RunnableFuture 继承的方法
run
从接口 java.util.concurrent.Delayed 继承的方法
getDelay
从接口 java.lang.Comparable 继承的方法
compareTo
从接口 java.util.concurrent.Future 继承的方法
cancel, get, get, isCancelled, isDone

方法详细信息

isPeriodic

boolean isPeriodic()
如果这是一个定期任务，则返回 true。定期任务可以根据计划重新运行。非定期任务只能运行一次。

返回：
如果此任务是定期的，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduledExecutorService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 ScheduledExecutorService

所有超级接口：
Executor, ExecutorService
所有已知实现类：
ScheduledThreadPoolExecutor
public interface ScheduledExecutorService
extends ExecutorService

一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。

schedule 方法使用各种延迟创建任务，并返回一个可用于取消或检查执行的任务对象。scheduleAtFixedRate 和 scheduleWithFixedDelay 方法创建并执行某些在取消前一直定期运行的任务。

用 Executor.execute(java.lang.Runnable) 和 ExecutorService 的 submit 方法所提交的命令，通过所请求的 0 延迟进行安排。schedule 方法中允许出现 0 和负数延迟（但不是周期），并将这些视为一种立即执行的请求。

所有的 schedule 方法都接受相对 延迟和周期作为参数，而不是绝对的时间或日期。将以 Date 所表示的绝对时间转换成要求的形式很容易。例如，要安排在某个以后的 Date 运行，可以使用：schedule(task, date.getTime() - System.currentTimeMillis(), TimeUnit.MILLISECONDS)。但是要注意，由于网络时间同步协议、时钟漂移或其他因素的存在，因此相对延迟的期满日期不必与启用任务的当前 Date 相符。 Executors 类为此包中所提供的 ScheduledExecutorService 实现提供了便捷的工厂方法。

用法示例

以下是一个带方法的类，它设置了 ScheduledExecutorService ，在 1 小时内每 10 秒钟蜂鸣一次：
 import static java.util.concurrent.TimeUnit.*;
 class BeeperControl {
    private final ScheduledExecutorService scheduler =
       Executors.newScheduledThreadPool(1);

    public void beepForAnHour() {
        final Runnable beeper = new Runnable() {
                public void run() { System.out.println("beep"); }
            };
        final ScheduledFuture<?> beeperHandle =
            scheduler.scheduleAtFixedRate(beeper, 10, 10, SECONDS);
        scheduler.schedule(new Runnable() {
                public void run() { beeperHandle.cancel(true); }
            }, 60 * 60, SECONDS);
    }
 }

从以下版本开始：
1.5

方法摘要
<V> ScheduledFuture<V>
schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
 ScheduledFuture<?> schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
从接口 java.util.concurrent.ExecutorService 继承的方法
awaitTermination, invokeAll, invokeAll, invokeAny, invokeAny, isShutdown, isTerminated, shutdown, shutdownNow, submit, submit, submit
从接口 java.util.concurrent.Executor 继承的方法
execute

方法详细信息

schedule

ScheduledFuture<?> schedule(Runnable command,
                            long delay,
                            TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。

参数：
command - 要执行的任务
delay - 从现在开始延迟执行的时间
unit - 延迟参数的时间单位
返回：
表示挂起任务完成的 ScheduledFuture，并且其 get() 方法在完成后将返回 null
抛出：
RejectedExecutionException - 如果无法安排执行该任务
NullPointerException - 如果 command 为 null

schedule

<V> ScheduledFuture<V> schedule(Callable<V> callable,
                                long delay,
                                TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。

参数：
callable - 要执行的功能
delay - 从现在开始延迟执行的时间
unit - 延迟参数的时间单位
返回：
可用于提取结果或取消的 ScheduledFuture
抛出：
RejectedExecutionException - 如果无法安排执行该任务
NullPointerException - 如果 callable 为 null

scheduleAtFixedRate

ScheduledFuture<?> scheduleAtFixedRate(Runnable command,
                                       long initialDelay,
                                       long period,
                                       TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。如果任务的任何一个执行遇到异常，则后续执行都会被取消。否则，只能通过执行程序的取消或终止方法来终止该任务。如果此任务的任何一个执行要花费比其周期更长的时间，则将推迟后续执行，但不会同时执行。

参数：
command - 要执行的任务
initialDelay - 首次执行的延迟时间
period - 连续执行之间的周期
unit - initialDelay 和 period 参数的时间单位
返回：
表示挂起任务完成的 ScheduledFuture，并且其 get() 方法在取消后将抛出异常
抛出：
RejectedExecutionException - 如果无法安排执行该任务
NullPointerException - 如果 command 为 null
IllegalArgumentException - 如果 period 小于等于 0

scheduleWithFixedDelay

ScheduledFuture<?> scheduleWithFixedDelay(Runnable command,
                                          long initialDelay,
                                          long delay,
                                          TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。如果任务的任一执行遇到异常，就会取消后续执行。否则，只能通过执行程序的取消或终止方法来终止该任务。

参数：
command - 要执行的任务
initialDelay - 首次执行的延迟时间
delay - 一次执行终止和下一次执行开始之间的延迟
unit - initialDelay 和 delay 参数的时间单位
返回：
表示挂起任务完成的 ScheduledFuture，并且其 get() 方法在取消后将抛出异常
抛出：
RejectedExecutionException - 如果无法安排执行该任务
NullPointerException - 如果 command 为 null。
IllegalArgumentException - 如果 delay 小于等于 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduledFuture (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 ScheduledFuture<V>

类型参数：
V - 此 Future 返回的结果类型。
所有超级接口：
Comparable<Delayed>, Delayed, Future<V>
所有已知子接口：
RunnableScheduledFuture<V>
public interface ScheduledFuture<V>
extends Delayed, Future<V>

一个延迟的、结果可接受的操作，可将其取消。通常已安排的 future 是用 ScheduledExecutorService 安排任务的结果。

从以下版本开始：
1.5

方法摘要
从接口 java.util.concurrent.Delayed 继承的方法
getDelay
从接口 java.lang.Comparable 继承的方法
compareTo
从接口 java.util.concurrent.Future 继承的方法
cancel, get, get, isCancelled, isDone

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScheduledThreadPoolExecutor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ScheduledThreadPoolExecutor

java.lang.Object
    继承者  java.util.concurrent.AbstractExecutorService
        继承者  java.util.concurrent.ThreadPoolExecutor
            继承者  java.util.concurrent.ScheduledThreadPoolExecutor
所有已实现的接口：
Executor, ExecutorService, ScheduledExecutorService
public class ScheduledThreadPoolExecutor
extends ThreadPoolExecutor
implements ScheduledExecutorService

ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。需要多个辅助线程时，或者要求 ThreadPoolExecutor 具有额外的灵活性或功能时，此类要优于 Timer。

一旦启用已延迟的任务就执行它，但是有关何时启用，启用后何时执行则没有任何实时保证。按照提交的先进先出 (FIFO) 顺序来启用那些被安排在同一执行时间的任务。

虽然此类继承自 ThreadPoolExecutor，但是几个继承的调整方法对此类并无作用。特别是，因为它作为一个使用 corePoolSize 线程和一个无界队列的固定大小的池，所以调整 maximumPoolSize 没有什么效果。

扩展注意事项：此类重写 AbstractExecutorService 的 submit 方法，以生成内部对象控制每个任务的延迟和调度。若要保留功能性，子类中任何进一步重写的这些方法都必须调用超类版本，超类版本有效地禁用附加任务的定制。但是，此类提供替代受保护的扩展方法 decorateTask（为 Runnable 和 Callable 各提供一种版本），可定制用于通过 execute、submit、schedule、scheduleAtFixedRate 和 scheduleWithFixedDelay 进入的执行命令的具体任务类型。默认情况下，ScheduledThreadPoolExecutor 使用一个扩展 FutureTask 的任务类型。但是，可以使用下列形式的子类修改或替换该类型。

 public class CustomScheduledExecutor extends ScheduledThreadPoolExecutor {

   static class CustomTask<V> implements RunnableScheduledFuture<V> { ... }

   protected <V> RunnableScheduledFuture<V> decorateTask(
                Runnable r, RunnableScheduledFuture<V> task) {
       return new CustomTask<V>(r, task);
   }

   protected <V> RunnableScheduledFuture<V> decorateTask(
                Callable<V> c, RunnableScheduledFuture<V> task) {
       return new CustomTask<V>(c, task);
   }
   // ... add constructors, etc.
 }

从以下版本开始：
1.5

嵌套类摘要
从类 java.util.concurrent.ThreadPoolExecutor 继承的嵌套类/接口
ThreadPoolExecutor.AbortPolicy, ThreadPoolExecutor.CallerRunsPolicy, ThreadPoolExecutor.DiscardOldestPolicy, ThreadPoolExecutor.DiscardPolicy
构造方法摘要
ScheduledThreadPoolExecutor(int corePoolSize)
使用给定核心池大小创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int corePoolSize, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory)
使用给定的初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
方法摘要
protected
<V> RunnableScheduledFuture<V>
decorateTask(Callable<V> callable, RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。
protected
<V> RunnableScheduledFuture<V>
decorateTask(Runnable runnable, RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。
 void execute(Runnable command)
使用所要求的零延迟执行命令。
 boolean getContinueExistingPeriodicTasksAfterShutdownPolicy()
获取有关在此执行程序已 shutdown 的情况下、是否继续执行现有定期任务的策略。
 boolean getExecuteExistingDelayedTasksAfterShutdownPolicy()
获取有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。
 BlockingQueue<Runnable> getQueue()
返回此执行程序使用的任务队列。
 boolean remove(Runnable task)
从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。
<V> ScheduledFuture<V>
schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
 ScheduledFuture<?> schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
 void setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean value)
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有定期任务的策略。
 void setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean value)
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。
 void shutdown()
在以前已提交任务的执行中发起一个有序的关闭，但是不接受新任务。
 List<Runnable> shutdownNow()
尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。
<T> Future<T>
submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
 Future<?> submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
<T> Future<T>
submit(Runnable task, T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
从类 java.util.concurrent.ThreadPoolExecutor 继承的方法
afterExecute, allowCoreThreadTimeOut, allowsCoreThreadTimeOut, awaitTermination, beforeExecute, finalize, getActiveCount, getCompletedTaskCount, getCorePoolSize, getKeepAliveTime, getLargestPoolSize, getMaximumPoolSize, getPoolSize, getRejectedExecutionHandler, getTaskCount, getThreadFactory, isShutdown, isTerminated, isTerminating, prestartAllCoreThreads, prestartCoreThread, purge, setCorePoolSize, setKeepAliveTime, setMaximumPoolSize, setRejectedExecutionHandler, setThreadFactory, terminated
从类 java.util.concurrent.AbstractExecutorService 继承的方法
invokeAll, invokeAll, invokeAny, invokeAny, newTaskFor, newTaskFor
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.util.concurrent.ExecutorService 继承的方法
awaitTermination, invokeAll, invokeAll, invokeAny, invokeAny, isShutdown, isTerminated

构造方法详细信息

ScheduledThreadPoolExecutor

public ScheduledThreadPoolExecutor(int corePoolSize)
使用给定核心池大小创建一个新 ScheduledThreadPoolExecutor。

参数：
corePoolSize - 池中所保存的线程数（包括空闲线程）
抛出：
IllegalArgumentException - 如果 corePoolSize < 0

ScheduledThreadPoolExecutor

public ScheduledThreadPoolExecutor(int corePoolSize,
                                   ThreadFactory threadFactory)
使用给定的初始参数创建一个新 ScheduledThreadPoolExecutor。

参数：
corePoolSize - 池中所保存的线程数（包括空闲线程）
threadFactory - 执行程序创建新线程时使用的工厂
抛出：
IllegalArgumentException - 如果 corePoolSize < 0
NullPointerException - 如果 threadFactory 为 null

ScheduledThreadPoolExecutor

public ScheduledThreadPoolExecutor(int corePoolSize,
                                   RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。

参数：
corePoolSize - 池中所保存的线程数（包括空闲线程）
handler - 由于超出线程范围和队列容量而使执行被阻塞时所使用的处理程序
抛出：
IllegalArgumentException - 如果 corePoolSize < 0
NullPointerException - 如果处理程序为 null

ScheduledThreadPoolExecutor

public ScheduledThreadPoolExecutor(int corePoolSize,
                                   ThreadFactory threadFactory,
                                   RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。

参数：
corePoolSize - 池中所保存的线程数（包括空闲线程）
threadFactory - 执行程序创建新线程时使用的工厂
handler - 由于超出线程范围和队列容量而使执行被阻塞时所使用的处理程序
抛出：
IllegalArgumentException - 如果 corePoolSize < 0
NullPointerException - 如果 threadFactory 或处理程序为 null
方法详细信息

remove

public boolean remove(Runnable task)
从类 ThreadPoolExecutor 复制的描述
从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。

此方法可用作取消方案的一部分。它可能无法移除在放置到内部队列之前已经转换为其他形式的任务。例如，使用 submit 输入的任务可能被转换为维护 Future 状态的形式。但是，在此情况下，ThreadPoolExecutor.purge() 方法可用于移除那些已被取消的 Future。

覆盖：
类 ThreadPoolExecutor 中的 remove
参数：
task - 要移除的任务
返回：
如果已经移除任务，则返回 true

decorateTask

protected <V> RunnableScheduledFuture<V> decorateTask(Runnable runnable,
                                                      RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。此方法可重写用于管理内部任务的具体类。默认实现只返回给定任务。

参数：
runnable - 所提交的 Runnable
task - 执行 runnable 所创建的任务
返回：
可以执行 runnable 的任务
从以下版本开始：
1.6

decorateTask

protected <V> RunnableScheduledFuture<V> decorateTask(Callable<V> callable,
                                                      RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。此方法可重写用于管理内部任务的具体类。默认实现返回给定任务。

参数：
callable - 所提交的 Callable
task - 执行 callable 所创建的任务
返回：
可以执行 callable 的任务
从以下版本开始：
1.6

schedule

public ScheduledFuture<?> schedule(Runnable command,
                                   long delay,
                                   TimeUnit unit)
从接口 ScheduledExecutorService 复制的描述
创建并执行在给定延迟后启用的一次性操作。

指定者：
接口 ScheduledExecutorService 中的 schedule
参数：
command - 要执行的任务
delay - 从现在开始延迟执行的时间
unit - 延迟参数的时间单位
返回：
表示挂起任务完成的 ScheduledFuture，并且其 get() 方法在完成后将返回 null

schedule

public <V> ScheduledFuture<V> schedule(Callable<V> callable,
                                       long delay,
                                       TimeUnit unit)
从接口 ScheduledExecutorService 复制的描述
创建并执行在给定延迟后启用的 ScheduledFuture。

指定者：
接口 ScheduledExecutorService 中的 schedule
参数：
callable - 要执行的功能
delay - 从现在开始延迟执行的时间
unit - 延迟参数的时间单位
返回：
可用于提取结果或取消的 ScheduledFuture

scheduleAtFixedRate

public ScheduledFuture<?> scheduleAtFixedRate(Runnable command,
                                              long initialDelay,
                                              long period,
                                              TimeUnit unit)
从接口 ScheduledExecutorService 复制的描述
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。如果任务的任何一个执行遇到异常，则后续执行都会被取消。否则，只能通过执行程序的取消或终止方法来终止该任务。如果此任务的任何一个执行要花费比其周期更长的时间，则将推迟后续执行，但不会同时执行。

指定者：
接口 ScheduledExecutorService 中的 scheduleAtFixedRate
参数：
command - 要执行的任务
initialDelay - 首次执行的延迟时间
period - 连续执行之间的周期
unit - initialDelay 和 period 参数的时间单位
返回：
表示挂起任务完成的 ScheduledFuture，并且其 get() 方法在取消后将抛出异常

scheduleWithFixedDelay

public ScheduledFuture<?> scheduleWithFixedDelay(Runnable command,
                                                 long initialDelay,
                                                 long delay,
                                                 TimeUnit unit)
从接口 ScheduledExecutorService 复制的描述
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。如果任务的任一执行遇到异常，就会取消后续执行。否则，只能通过执行程序的取消或终止方法来终止该任务。

指定者：
接口 ScheduledExecutorService 中的 scheduleWithFixedDelay
参数：
command - 要执行的任务
initialDelay - 首次执行的延迟时间
delay - 一次执行终止和下一次执行开始之间的延迟
unit - initialDelay 和 delay 参数的时间单位
返回：
表示挂起任务完成的 ScheduledFuture，并且其 get() 方法在取消后将抛出异常

execute

public void execute(Runnable command)
使用所要求的零延迟执行命令。这在效果上等同于调用 schedule(command, 0, anyUnit)。注意，对由 shutdownNow 所返回的队列和列表的检查将访问零延迟的 ScheduledFuture，而不是 command 本身。

指定者：
接口 Executor 中的 execute
覆盖：
类 ThreadPoolExecutor 中的 execute
参数：
command - 要执行的任务。
抛出：
由 - RejectedExecutionHandler 随意决定的 RejectedExecutionException，如果由于执行程序已关闭而无法接受要执行的任务 。
NullPointerException - 如果 command 为 null。

submit

public Future<?> submit(Runnable task)
从接口 ExecutorService 复制的描述
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。该 Future 的 get 方法在成功 完成时将会返回 null。

指定者：
接口 ExecutorService 中的 submit
覆盖：
类 AbstractExecutorService 中的 submit
参数：
task - 要提交的任务
返回：
表示任务等待完成的 Future

submit

public <T> Future<T> submit(Runnable task,
                            T result)
从接口 ExecutorService 复制的描述
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。该 Future 的 get 方法在成功完成时将会返回给定的结果。

指定者：
接口 ExecutorService 中的 submit
覆盖：
类 AbstractExecutorService 中的 submit
参数：
task - 要提交的任务
result - 返回的结果
返回：
表示任务等待完成的 Future

submit

public <T> Future<T> submit(Callable<T> task)
从接口 ExecutorService 复制的描述
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。该 Future 的 get 方法在成功完成时将会返回该任务的结果。

如果想立即阻塞任务的等待，则可以使用 result = exec.submit(aCallable).get(); 形式的构造。

注：Executors 类包括了一组方法，可以转换某些其他常见的类似于闭包的对象，例如，将 PrivilegedAction 转换为 Callable 形式，这样就可以提交它们了。

指定者：
接口 ExecutorService 中的 submit
覆盖：
类 AbstractExecutorService 中的 submit
参数：
task - 要提交的任务
返回：
表示任务等待完成的 Future

setContinueExistingPeriodicTasksAfterShutdownPolicy

public void setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean value)
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有定期任务的策略。在这种情况下，仅在执行 shutdownNow 时，或者在执行程序已关闭、将策略设置为 false 后才终止这些任务。此值默认为 false。

参数：
value - 如果为 true，则在关闭后继续执行；否则不执行。
另请参见：
getContinueExistingPeriodicTasksAfterShutdownPolicy()

getContinueExistingPeriodicTasksAfterShutdownPolicy

public boolean getContinueExistingPeriodicTasksAfterShutdownPolicy()
获取有关在此执行程序已 shutdown 的情况下、是否继续执行现有定期任务的策略。在这种情况下，仅在执行 shutdownNow 时，或者在执行程序已关闭时将策略设置为 false 后才终止这些任务。此值默认为 false。

返回：
如果关闭后继续执行，则返回 true。
另请参见：
setContinueExistingPeriodicTasksAfterShutdownPolicy(boolean)

setExecuteExistingDelayedTasksAfterShutdownPolicy

public void setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean value)
设置有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。在这种情况下，仅在执行 shutdownNow 时，或者在执行程序已关闭、将策略设置为 false 后才终止这些任务。此值默认为 true。

参数：
value - 如果为 true，则在关闭后执行；否则不执行。
另请参见：
getExecuteExistingDelayedTasksAfterShutdownPolicy()

getExecuteExistingDelayedTasksAfterShutdownPolicy

public boolean getExecuteExistingDelayedTasksAfterShutdownPolicy()
获取有关在此执行程序已 shutdown 的情况下是否继续执行现有延迟任务的策略。在这种情况下，仅在执行 shutdownNow 时，或者在执行程序已关闭时将策略设置为 false 后才终止这些任务。此值默认为 true。

返回：
如果关闭后执行，则返回 true
另请参见：
setExecuteExistingDelayedTasksAfterShutdownPolicy(boolean)

shutdown

public void shutdown()
在以前已提交任务的执行中发起一个有序的关闭，但是不接受新任务。如果已将 ExecuteExistingDelayedTasksAfterShutdownPolicy 设置为 false，则取消尚未超出其延迟的现有延迟任务。并且除非已将 ContinueExistingPeriodicTasksAfterShutdownPolicy 设置为 true，否则将取消现有定期任务的后续执行。

指定者：
接口 ExecutorService 中的 shutdown
覆盖：
类 ThreadPoolExecutor 中的 shutdown

shutdownNow

public List<Runnable> shutdownNow()
尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。

虽然尽最大努力，但并不保证可以停止处理正在执行的任务。此实现通过 Thread.interrupt() 取消任务,所以任何无法响应中断的任务都可能永远无法终止。

指定者：
接口 ExecutorService 中的 shutdownNow
覆盖：
类 ThreadPoolExecutor 中的 shutdownNow
返回：
从未开始执行的任务列表。此列表中的每个元素都是一个 ScheduledFuture，包括用 execute 所提交的那些任务，出于安排的目的，这些任务用作零延迟 ScheduledFuture 的基础。
抛出：
SecurityException - 如果安全管理器存在并且关闭此 ExecutorService 可能操作某些不允许调用者修改的线程（因为它没有 RuntimePermission ("modifyThread")），或者安全管理器的 checkAccess 方法拒绝访问。

getQueue

public BlockingQueue<Runnable> getQueue()
返回此执行程序使用的任务队列。此队列中的每个元素都是一个 ScheduledFuture，包括用 execute 所提交的那些任务，出于安排的目的，这些任务用作零延迟 ScheduledFuture 的基础。无法 保证对此队列进行迭代的迭代器会以任务执行的顺序遍历各任务。

覆盖：
类 ThreadPoolExecutor 中的 getQueue
返回：
任务队列。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Semaphore (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 Semaphore

java.lang.Object
    继承者  java.util.concurrent.Semaphore
所有已实现的接口：
Serializable
public class Semaphore
extends Object
implements Serializable

一个计数信号量。从概念上讲，信号量维护了一个许可集。如有必要，在许可可用前会阻塞每一个 acquire()，然后再获取该许可。每个 release() 添加一个许可，从而可能释放一个正在阻塞的获取者。但是，不使用实际的许可对象，Semaphore 只对可用许可的号码进行计数，并采取相应的行动。

Semaphore 通常用于限制可以访问某些资源（物理或逻辑的）的线程数目。例如，下面的类使用信号量控制对内容池的访问：

 class Pool {
   private static final int MAX_AVAILABLE = 100;
   private final Semaphore available = new Semaphore(MAX_AVAILABLE, true);

   public Object getItem() throws InterruptedException {
     available.acquire();
     return getNextAvailableItem();
   }

   public void putItem(Object x) {
     if (markAsUnused(x))
       available.release();
   }

   // Not a particularly efficient data structure; just for demo

   protected Object[] items = ... whatever kinds of items being managed
   protected boolean[] used = new boolean[MAX_AVAILABLE];

   protected synchronized Object getNextAvailableItem() {
     for (int i = 0; i < MAX_AVAILABLE; ++i) {
       if (!used[i]) {
          used[i] = true;
          return items[i];
       }
     }
     return null; // not reached
   }

   protected synchronized boolean markAsUnused(Object item) {
     for (int i = 0; i < MAX_AVAILABLE; ++i) {
       if (item == items[i]) {
          if (used[i]) {
            used[i] = false;
            return true;
          } else
            return false;
       }
     }
     return false;
   }

 }

获得一项前，每个线程必须从信号量获取许可，从而保证可以使用该项。该线程结束后，将项返回到池中并将许可返回到该信号量，从而允许其他线程获取该项。注意，调用 acquire() 时无法保持同步锁，因为这会阻止将项返回到池中。信号量封装所需的同步，以限制对池的访问，这同维持该池本身一致性所需的同步是分开的。

将信号量初始化为 1，使得它在使用时最多只有一个可用的许可，从而可用作一个相互排斥的锁。这通常也称为二进制信号量，因为它只能有两种状态：一个可用的许可，或零个可用的许可。按此方式使用时，二进制信号量具有某种属性（与很多 Lock 实现不同），即可以由线程释放“锁”，而不是由所有者（因为信号量没有所有权的概念）。在某些专门的上下文（如死锁恢复）中这会很有用。

此类的构造方法可选地接受一个公平 参数。当设置为 false 时，此类不对线程获取许可的顺序做任何保证。特别地，闯入 是允许的，也就是说可以在已经等待的线程前为调用 acquire() 的线程分配一个许可，从逻辑上说，就是新线程将自己置于等待线程队列的头部。当公平设置为 true 时，信号量保证对于任何调用获取方法的线程而言，都按照处理它们调用这些方法的顺序（即先进先出；FIFO）来选择线程、获得许可。注意，FIFO 排序必然应用到这些方法内的指定内部执行点。所以，可能某个线程先于另一个线程调用了 acquire，但是却在该线程之后到达排序点，并且从方法返回时也类似。还要注意，非同步的 tryAcquire 方法不使用公平设置，而是使用任意可用的许可。

通常，应该将用于控制资源访问的信号量初始化为公平的，以确保所有线程都可访问资源。为其他的种类的同步控制使用信号量时，非公平排序的吞吐量优势通常要比公平考虑更为重要。

此类还提供便捷的方法来同时 acquire 和释放多个许可。小心，在未将公平设置为 true 时使用这些方法会增加不确定延期的风险。

内存一致性效果：线程中调用“释放”方法（比如 release()）之前的操作 happen-before 另一线程中紧跟在成功的“获取”方法（比如 acquire()）之后的操作。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
Semaphore(int permits)
创建具有给定的许可数和非公平的公平设置的 Semaphore。
Semaphore(int permits, boolean fair)
创建具有给定的许可数和给定的公平设置的 Semaphore。
方法摘要
void | acquire() 从此信号量获取一个许可，在提供一个许可前一直将线程阻塞，否则线程被中断。
void | acquire(int permits) 从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞，或者线程已被中断。
void | acquireUninterruptibly() 从此信号量中获取许可，在有可用的许可前将其阻塞。
void | acquireUninterruptibly(int permits) 从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞。
int | availablePermits() 返回此信号量中当前可用的许可数。
int | drainPermits() 获取并返回立即可用的所有许可。
protected Collection<Thread> | getQueuedThreads() 返回一个 collection，包含可能等待获取的线程。
int | getQueueLength() 返回正在等待获取的线程的估计数目。
boolean | hasQueuedThreads() 查询是否有线程正在等待获取。
boolean | isFair() 如果此信号量的公平设置为 true，则返回 true。
protected void | reducePermits(int reduction) 根据指定的缩减量减小可用许可的数目。
void | release() 释放一个许可，将其返回给信号量。
void | release(int permits) 释放给定数目的许可，将其返回到信号量。
String | toString() 返回标识此信号量的字符串，以及信号量的状态。
boolean | tryAcquire() 仅在调用时此信号量存在一个可用许可，才从信号量获取许可。
boolean | tryAcquire(int permits) 仅在调用时此信号量中有给定数目的许可时，才从此信号量中获取这些许可。
boolean | tryAcquire(int permits, long timeout, TimeUnit unit) 如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。
boolean | tryAcquire(long timeout, TimeUnit unit) 如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Semaphore

public Semaphore(int permits)
创建具有给定的许可数和非公平的公平设置的 Semaphore。

参数：
permits - 初始的可用许可数目。此值可能为负数，在这种情况下，必须在授予任何获取前进行释放。

Semaphore

public Semaphore(int permits,
                 boolean fair)
创建具有给定的许可数和给定的公平设置的 Semaphore。

参数：
permits - 初始的可用许可数目。此值可能为负数，在这种情况下，必须在授予任何获取前进行释放。
fair - 如果此信号量保证在争用时按先进先出的顺序授予许可，则为 true；否则为 false。
方法详细信息

acquire

public void acquire()
             throws InterruptedException
从此信号量获取一个许可，在提供一个许可前一直将线程阻塞，否则线程被中断。

获取一个许可（如果提供了一个）并立即返回，将可用的许可数减 1。

如果没有可用的许可，则在发生以下两种情况之一前，禁止将当前线程用于线程安排目的并使其处于休眠状态：

  • 某些其他线程调用此信号量的 release() 方法，并且当前线程是下一个要被分配许可的线程；或者
  • 其他某些线程中断当前线程。

如果当前线程：

  • 被此方法将其已中断状态设置为 on ；或者
  • 在等待许可时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。

抛出：
InterruptedException - 如果当前线程被中断

acquireUninterruptibly

public void acquireUninterruptibly()
从此信号量中获取许可，在有可用的许可前将其阻塞。

获取一个许可（如果提供了一个）并立即返回，将可用的允许数减 1。

如果没有可用的许可，则在其他某些线程调用此信号量的 release() 方法，并且当前线程是下一个要被分配许可的线程前，禁止当前线程用于线程安排目的并使其处于休眠状态。

如果当前线程在等待许可时被中断，那么它将继续等待，但是与没有发生中断，其将接收允许的时间相比，为该线程分配许可的时间可能改变。当线程确实从此方法返回后，将设置其中断状态。

tryAcquire

public boolean tryAcquire()
仅在调用时此信号量存在一个可用许可，才从信号量获取许可。

获取一个许可（如果提供了一个）并立即返回，其值为 true，将可用的许可数减 1。

如果没有可用的许可，则此方法立即返回并且值为 false。

即使已将此信号量设置为使用公平排序策略，但是调用 tryAcquire() 也将 立即获取许可（如果有一个可用），而不管当前是否有正在等待的线程。在某些情况下，此“闯入”行为可能很有用，即使它会打破公平性也如此。如果希望遵守公平设置，则使用 tryAcquire(0, TimeUnit.SECONDS) ，它几乎是等效的（它也检测中断）。

返回：
如果获取了许可，则返回 true；否则返回 false。

tryAcquire

public boolean tryAcquire(long timeout,
                          TimeUnit unit)
                   throws InterruptedException
如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。

获取一个许可（如果提供了一个）并立即返回，其值为 true，将可用的许可数减 1。

如果没有可用的允许，则在发生以下三种情况之一前，禁止将当前线程用于线程安排目的并使其处于休眠状态：

  • 其他某些线程调用此信号量的 release() 方法并且当前线程是下一个被分配许可的线程；或者
  • 其他某些线程中断当前线程；或者
  • 已超出指定的等待时间。

如果获取了许可，则返回值为 true。

如果当前线程：

  • 被此方法将其已中断状态设置为 on ；或者
  • 在等待获取许可的同时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果超出了指定的等待时间，则返回值为 false。如果该时间小于等于 0，则方法根本不等待。

参数：
timeout - 等待许可的最多时间
unit - timeout 参数的时间单位
返回：
如果获取了许可，则返回 true；如果获取许可前超出了等待时间，则返回 false
抛出：
InterruptedException - 如果当前线程是已中断的

release

public void release()
释放一个许可，将其返回给信号量。

释放一个许可，将可用的许可数增加 1。如果任意线程试图获取许可，则选中一个线程并将刚刚释放的许可给予它。然后针对线程安排目的启用（或再启用）该线程。

不要求释放许可的线程必须通过调用 acquire() 来获取许可。通过应用程序中的编程约定来建立信号量的正确用法。

acquire

public void acquire(int permits)
             throws InterruptedException
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞，或者线程已被中断。

获取给定数目的许可（如果提供了）并立即返回，将可用的许可数减去给定的量。

如果没有足够的可用许可，则在发生以下两种情况之一前，禁止将当前线程用于线程安排目的并使其处于休眠状态：

  • 其他某些线程调用此信号量的某个释放方法，当前线程是下一个被分配允许的线程并且可用许可的数目满足此请求；或者
  • 其他某些线程中断当前线程。

如果当前线程：

  • 被此方法将其已中断状态设置为 on ；或者
  • 在等待许可时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。任何原本应该分配给此线程的许可将被分配给其他试图获取许可的线程，就好像已通过调用 release() 而使许可可用一样。

参数：
permits - 要获取的许可数
抛出：
InterruptedException - 如果当前线程已被中断
IllegalArgumentException - 如果 permits 为负

acquireUninterruptibly

public void acquireUninterruptibly(int permits)
从此信号量获取给定数目的许可，在提供这些许可前一直将线程阻塞。

获取给定数目的许可（如果提供了）并立即返回，将可用的许可数减去给定的量。

如果没有足够的可用许可，则在其他某些线程调用此信号量的某个释放方法，当前线程是下一个要被分配许可的线程，并且可用的许可数目满足此请求前，禁止当前线程用于线程安排目的并使其处于休眠状态。

如果当前的线程在等待许可时被中断，则它会继续等待并且它在队列中的位置不受影响。当线程确实从此方法返回后，将其设置为中断状态。

参数：
permits - 要获取的许可数
抛出：
IllegalArgumentException - 如果 permits 为负

tryAcquire

public boolean tryAcquire(int permits)
仅在调用时此信号量中有给定数目的许可时，才从此信号量中获取这些许可。

获取给定数目的许可（如果提供了）并立即返回，其值为 true，将可用的许可数减去给定的量。

如果没有足够的可用许可，则此方法立即返回，其值为 false，并且不改变可用的许可数。

即使已将此信号量设置为使用公平排序策略，但是调用 tryAcquire 也将 立即获取许可（如果有一个可用），而不管当前是否有正在等待的线程。在某些情况下，此“闯入”行为可能很有用，即使它会打破公平性也如此。如果希望遵守公平设置，则使用 tryAcquire(permits, 0, TimeUnit.SECONDS) ，它几乎是等效的（它也检测中断）。

参数：
permits - 要获取的许可数
返回：
如果获取了许可，则返回 true；否则返回 false
抛出：
IllegalArgumentException - 如果 permits 为负

tryAcquire

public boolean tryAcquire(int permits,
                          long timeout,
                          TimeUnit unit)
                   throws InterruptedException
如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。

获取给定数目的许可（如果提供了）并立即返回，其值为 true，将可用的许可数减去给定的量。

如果没有足够的可用许可，则在发生以下三种情况之一前，禁止将当前线程用于线程安排目的并使其处于休眠状态：

  • 其他某些线程调用此信号量的某个释放方法，当前线程是下一个被分配许可的线程，并且可用许可的数目满足此请求；或者
  • 其他某些线程中断当前线程；或者
  • 已超出指定的等待时间。

如果获取了许可，则返回值为 true。

如果当前线程：

  • 被此方法将其已中断状态设置为 on ；或者
  • 在等待获取允许的同时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。任何原本应该分配给此线程的许可将被分配给其他试图获取许可的线程，就好像已通过调用 release() 而使许可可用一样。

如果超出了指定的等待时间，则返回值为 false。如果该时间小于等于 0，则方法根本不等待。任何原本应该分配给此线程的许可将被分配给其他试图获取许可的线程，就好像已通过调用 release() 而使许可可用一样。

参数：
permits - 要获取的许可数
timeout - 等待许可的最多时间
unit - timeout 参数的时间单位
返回：
如果获取了许可，则返回 true；如果获取所有许可前超出了等待时间，则返回 false
抛出：
InterruptedException - 如果当前线程是已中断的
IllegalArgumentException - 如果 permits 为负

release

public void release(int permits)
释放给定数目的许可，将其返回到信号量。

释放给定数目的许可，将可用的许可数增加该量。如果任意线程试图获取许可，则选中某个线程并将刚刚释放的许可给予该线程。如果可用许可的数目满足该线程的请求，则针对线程安排目的启用（或再启用）该线程；否则在有足够的可用许可前线程将一直等待。如果满足此线程的请求后仍有可用的许可，则依次将这些许可分配给试图获取许可的其他线程。

不要求释放许可的线程必须通过调用获取来获取该许可。通过应用程序中的编程约定来建立信号量的正确用法。

参数：
permits - 要释放的许可数
抛出：
IllegalArgumentException - 如果 permits 为负

availablePermits

public int availablePermits()
返回此信号量中当前可用的许可数。

此方法通常用于调试和测试目的。

返回：
此信号量中的可用许可数

drainPermits

public int drainPermits()
获取并返回立即可用的所有许可。

返回：
获取的许可数

reducePermits

protected void reducePermits(int reduction)
根据指定的缩减量减小可用许可的数目。此方法在使用信号量来跟踪那些变为不可用资源的子类中很有用。此方法不同于 acquire，在许可变为可用的过程中，它不会阻塞等待。

参数：
reduction - 要移除的许可数
抛出：
IllegalArgumentException - 如果 reduction 是负数

isFair

public boolean isFair()
如果此信号量的公平设置为 true，则返回 true。

返回：
如果此信号量的公平设置为 true，则返回 true

hasQueuedThreads

public final boolean hasQueuedThreads()
查询是否有线程正在等待获取。注意，因为同时可能发生取消，所以返回 true 并不保证有其他线程等待获取许可。此方法主要用于监视系统状态。

返回：
如果可能有其他线程正在等待获取锁，则返回 true

getQueueLength

public final int getQueueLength()
返回正在等待获取的线程的估计数目。该值仅是估计的数字，因为在此方法遍历内部数据结构的同时，线程的数目可能动态地变化。此方法用于监视系统状态，不用于同步控制。

返回：
正在等待此锁的线程的估计数目

getQueuedThreads

protected Collection<Thread> getQueuedThreads()
返回一个 collection，包含可能等待获取的线程。因为在构造此结果的同时实际的线程 set 可能动态地变化，所以返回的 collection 仅是尽力的估计值。所返回 collection 中的元素没有特定的顺序。此方法用于加快子类的构造速度，提供更多的监视设施。

返回：
线程 collection

toString

public String toString()
返回标识此信号量的字符串，以及信号量的状态。括号中的状态包括 String 类型的 "Permits ="，后跟许可数。

覆盖：
类 Object 中的 toString
返回：
标识此信号量的字符串，以及信号量的状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SynchronousQueue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 SynchronousQueue<E>

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractQueue<E>
            继承者  java.util.concurrent.SynchronousQueue<E>
类型参数：
E - 此 collection 保持的元素类型
所有已实现的接口：
Serializable, Iterable<E>, Collection<E>, BlockingQueue<E>, Queue<E>
public class SynchronousQueue<E>
extends AbstractQueue<E>
implements BlockingQueue<E>, Serializable

一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。同步队列没有任何内部容量，甚至连一个队列的容量都没有。不能在同步队列上进行 peek，因为仅在试图要移除元素时，该元素才存在；除非另一个线程试图移除某个元素，否则也不能（使用任何方法）插入元素；也不能迭代队列，因为其中没有元素可用于迭代。队列的头 是尝试添加到队列中的首个已排队插入线程的元素；如果没有这样的已排队线程，则没有可用于移除的元素并且 poll() 将会返回 null。对于其他 Collection 方法（例如 contains），SynchronousQueue 作为一个空 collection。此队列不允许 null 元素。

同步队列类似于 CSP 和 Ada 中使用的 rendezvous 信道。它非常适合于传递性设计，在这种设计中，在一个线程中运行的对象要将某些信息、事件或任务传递给在另一个线程中运行的对象，它就必须与该对象同步。

对于正在等待的生产者和使用者线程而言，此类支持可选的公平排序策略。默认情况下不保证这种排序。但是，使用公平设置为 true 所构造的队列可保证线程以 FIFO 的顺序进行访问。

此类及其迭代器实现 Collection 和 Iterator 接口的所有可选 方法。

此类是 Java Collections Framework 的成员。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
SynchronousQueue()
创建一个具有非公平访问策略的 SynchronousQueue。
SynchronousQueue(boolean fair)
创建一个具有指定公平策略的 SynchronousQueue。
方法摘要
 void clear()
不执行任何操作。
 boolean contains(Object o)
始终返回 false。
 boolean containsAll(Collection<?> c)
除非给定 collection 为空，否则返回 false。
 int drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 boolean isEmpty()
始终返回 true。
 Iterator<E> iterator()
返回一个空迭代器，其中 hasNext 始终返回 false。
 boolean offer(E e)
如果另一个线程正在等待以便接收指定元素，则将指定元素插入到此队列。
 boolean offer(E o, long timeout, TimeUnit unit)
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。
 E peek()
始终返回 null。
 E poll()
如果另一个线程当前正要使用某个元素，则获取并移除此队列的头。
 E poll(long timeout, TimeUnit unit)
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。
 void put(E o)
将指定元素添加到此队列，如有必要则等待另一个线程接收它。
 int remainingCapacity()
始终返回 0。
 boolean remove(Object o)
始终返回 false。
 boolean removeAll(Collection<?> c)
始终返回 false。
 boolean retainAll(Collection<?> c)
始终返回 false。
 int size()
始终返回 0。
 E take()
获取并移除此队列的头，如有必要则等待另一个线程插入它。
 Object[] toArray()
返回一个 0 长度的数组。
<T> T[]
toArray(T[] a)
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。
从类 java.util.AbstractQueue 继承的方法
add, addAll, element, remove
从类 java.util.AbstractCollection 继承的方法
toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.util.concurrent.BlockingQueue 继承的方法
add
从接口 java.util.Queue 继承的方法
element, remove
从接口 java.util.Collection 继承的方法
addAll, equals, hashCode

构造方法详细信息

SynchronousQueue

public SynchronousQueue()
创建一个具有非公平访问策略的 SynchronousQueue。

SynchronousQueue

public SynchronousQueue(boolean fair)
创建一个具有指定公平策略的 SynchronousQueue。

参数：
fair - 如果为 true，则等待线程以 FIFO 的顺序竞争访问；否则顺序是未指定的。
方法详细信息

put

public void put(E o)
         throws InterruptedException
将指定元素添加到此队列，如有必要则等待另一个线程接收它。

指定者：
接口 BlockingQueue<E> 中的 put
参数：
o - 要添加的元素
抛出：
InterruptedException - 如果在等待时被中断
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E o,
                     long timeout,
                     TimeUnit unit)
              throws InterruptedException
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。

指定者：
接口 BlockingQueue<E> 中的 offer
参数：
o - 要添加的元素
timeout - 放弃之前等待的时间长度，以 unit 为时间单位
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
如果成功，则返回 true，如果使用者出现前已超出指定的等待时间，则返回 false。
抛出：
InterruptedException - 如果在等待时被中断
NullPointerException - 如果指定元素为 null

offer

public boolean offer(E e)
如果另一个线程正在等待以便接收指定元素，则将指定元素插入到此队列。

指定者：
接口 BlockingQueue<E> 中的 offer
指定者：
接口 Queue<E> 中的 offer
参数：
e - 要添加的元素
返回：
如果该元素已添加到此队列，则返回 true；否则返回 false
抛出：
NullPointerException - 如果指定元素 null

take

public E take()
       throws InterruptedException
获取并移除此队列的头，如有必要则等待另一个线程插入它。

指定者：
接口 BlockingQueue<E> 中的 take
返回：
队列的头
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll(long timeout,
              TimeUnit unit)
       throws InterruptedException
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。

指定者：
接口 BlockingQueue<E> 中的 poll
参数：
timeout - 放弃之前要等待的时间长度，用 unit 的时间单位表示
unit - 确定如何解释 timeout 参数的 TimeUnit
返回：
队列的头，如果该元素出现前已超出指定的等待时间，则返回 null。
抛出：
InterruptedException - 如果在等待时被中断

poll

public E poll()
如果另一个线程当前正要使用某个元素，则获取并移除此队列的头。

指定者：
接口 Queue<E> 中的 poll
返回：
队列的头，如果没有元素可用，则返回 null。

isEmpty

public boolean isEmpty()
始终返回 true。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 isEmpty
覆盖：
类 AbstractCollection<E> 中的 isEmpty
返回：
true

size

public int size()
始终返回 0。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 size
指定者：
类 AbstractCollection<E> 中的 size
返回：
0。

remainingCapacity

public int remainingCapacity()
始终返回 0。SynchronousQueue 没有内部容量。

指定者：
接口 BlockingQueue<E> 中的 remainingCapacity
返回：
0。

clear

public void clear()
不执行任何操作。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 clear
覆盖：
类 AbstractQueue<E> 中的 clear

contains

public boolean contains(Object o)
始终返回 false。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 contains
指定者：
接口 BlockingQueue<E> 中的 contains
覆盖：
类 AbstractCollection<E> 中的 contains
参数：
o - 元素
返回：
false

remove

public boolean remove(Object o)
始终返回 false。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 remove
指定者：
接口 BlockingQueue<E> 中的 remove
覆盖：
类 AbstractCollection<E> 中的 remove
参数：
o - 要移除的元素
返回：
false

containsAll

public boolean containsAll(Collection<?> c)
除非给定 collection 为空，否则返回 false。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 containsAll
覆盖：
类 AbstractCollection<E> 中的 containsAll
参数：
c - collection
返回：
除非给定 collection 为空，否则返回 false
另请参见：
AbstractCollection.contains(Object)

removeAll

public boolean removeAll(Collection<?> c)
始终返回 false。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 removeAll
覆盖：
类 AbstractCollection<E> 中的 removeAll
参数：
c - collection
返回：
false
另请参见：
AbstractCollection.remove(Object), AbstractCollection.contains(Object)

retainAll

public boolean retainAll(Collection<?> c)
始终返回 false。SynchronousQueue 没有内部容量。

指定者：
接口 Collection<E> 中的 retainAll
覆盖：
类 AbstractCollection<E> 中的 retainAll
参数：
c - collection
返回：
false
另请参见：
AbstractCollection.remove(Object), AbstractCollection.contains(Object)

peek

public E peek()
始终返回 null。除非 SynchronousQueue 正在等待，否则不返回元素。

指定者：
接口 Queue<E> 中的 peek
返回：
null

iterator

public Iterator<E> iterator()
返回一个空迭代器，其中 hasNext 始终返回 false。

指定者：
接口 Iterable<E> 中的 iterator
指定者：
接口 Collection<E> 中的 iterator
指定者：
类 AbstractCollection<E> 中的 iterator
返回：
空迭代器

toArray

public Object[] toArray()
返回一个 0 长度的数组。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
返回：
一个 0 长度的数组

toArray

public <T> T[] toArray(T[] a)
将指定数组的第 0 个元素设置为 null（如果该数组有非 0 的长度）并返回它。

指定者：
接口 Collection<E> 中的 toArray
覆盖：
类 AbstractCollection<E> 中的 toArray
参数：
a - 数组
返回：
指定的数组
抛出：
NullPointerException - 如果指定的数组为 null

drainTo

public int drainTo(Collection<? super E> c)
从接口 BlockingQueue 复制的描述
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。此操作可能比反复轮询此队列更有效。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection

drainTo

public int drainTo(Collection<? super E> c,
                   int maxElements)
从接口 BlockingQueue 复制的描述
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。在试图向 collection c 中添加元素没有成功时，可能导致在抛出相关异常时，元素会同时在两个 collection 中出现，或者在其中一个 collection 中出现，也可能在两个 collection 中都不出现。如果试图将一个队列放入自身队列中，则会导致 IllegalArgumentException 异常。此外，如果正在进行此操作时修改指定的 collection，则此操作行为是不确定的。

指定者：
接口 BlockingQueue<E> 中的 drainTo
参数：
c - 接收传输元素的 collection
maxElements - 传输元素的最大数量
返回：
传输元素的数量
抛出：
UnsupportedOperationException - 如果指定 collection 不支持添加元素
ClassCastException - 如果此队列元素的类不允许将其添加到指定 collection
NullPointerException - 如果指定 collection 为 null
IllegalArgumentException - 如果指定 collection 是此队列，或者此队列元素的某些属性不允许将其添加到指定 collection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
接口 ThreadFactory

public interface ThreadFactory

根据需要创建新线程的对象。使用线程工厂就无需再手工编写对 new Thread 的调用了，从而允许应用程序使用特殊的线程子类、属性等等。

此接口最简单的实现就是：

 class SimpleThreadFactory implements ThreadFactory {
   public Thread newThread(Runnable r) {
     return new Thread(r);
   }
 }
Executors.defaultThreadFactory() 方法提供了更有用的简单实现，即在返回线程前将已创建线程的上下文设置为已知的值。

从以下版本开始：
1.5

方法摘要
 Thread newThread(Runnable r)
构造一个新 Thread。

方法详细信息

newThread

Thread newThread(Runnable r)
构造一个新 Thread。实现也可能初始化属性、名称、守护程序状态、ThreadGroup 等等。

参数：
r - 由新线程实例所执行的可运行线程
返回：
构造的线程，如果请求创建线程被拒绝，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPoolExecutor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ThreadPoolExecutor

java.lang.Object
    继承者  java.util.concurrent.AbstractExecutorService
        继承者  java.util.concurrent.ThreadPoolExecutor
所有已实现的接口：
Executor, ExecutorService
直接已知子类：
ScheduledThreadPoolExecutor
public class ThreadPoolExecutor
extends AbstractExecutorService

一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

线程池可以解决两个不同问题：由于减少了每个任务调用的开销，它们通常可以在执行大量异步任务时提供增强的性能，并且还可以提供绑定和管理资源（包括执行任务集时使用的线程）的方法。每个 ThreadPoolExecutor 还维护着一些基本的统计数据，如完成的任务数。

为了便于跨大量上下文使用，此类提供了很多可调整的参数和扩展钩子 (hook)。但是，强烈建议程序员使用较为方便的 Executors 工厂方法 Executors.newCachedThreadPool()（无界线程池，可以进行自动线程回收）、Executors.newFixedThreadPool(int)（固定大小线程池）和 Executors.newSingleThreadExecutor()（单个后台线程），它们均为大多数使用场景预定义了设置。否则，在手动配置和调整此类时，使用以下指导：

核心和最大池大小
ThreadPoolExecutor 将根据 corePoolSize（参见 getCorePoolSize()）和 maximumPoolSize（参见 getMaximumPoolSize()）设置的边界自动调整池大小。当新任务在方法 execute(java.lang.Runnable) 中提交时，如果运行的线程少于 corePoolSize，则创建新线程来处理请求，即使其他辅助线程是空闲的。如果运行的线程多于 corePoolSize 而少于 maximumPoolSize，则仅当队列满时才创建新线程。如果设置的 corePoolSize 和 maximumPoolSize 相同，则创建了固定大小的线程池。如果将 maximumPoolSize 设置为基本的无界值（如 Integer.MAX_VALUE），则允许池适应任意数量的并发任务。在大多数情况下，核心和最大池大小仅基于构造来设置，不过也可以使用 setCorePoolSize(int) 和 setMaximumPoolSize(int) 进行动态更改。
按需构造
默认情况下，即使核心线程最初只是在新任务到达时才创建和启动的，也可以使用方法 prestartCoreThread() 或 prestartAllCoreThreads() 对其进行动态重写。如果构造带有非空队列的池，则可能希望预先启动线程。
创建新线程
使用 ThreadFactory 创建新线程。如果没有另外说明，则在同一个 ThreadGroup 中一律使用 Executors.defaultThreadFactory() 创建线程，并且这些线程具有相同的 NORM_PRIORITY 优先级和非守护进程状态。通过提供不同的 ThreadFactory，可以改变线程的名称、线程组、优先级、守护进程状态，等等。如果从 newThread 返回 null 时 ThreadFactory 未能创建线程，则执行程序将继续运行，但不能执行任何任务。
保持活动时间
如果池中当前有多于 corePoolSize 的线程，则这些多出的线程在空闲时间超过 keepAliveTime 时将会终止（参见 getKeepAliveTime(java.util.concurrent.TimeUnit)）。这提供了当池处于非活动状态时减少资源消耗的方法。如果池后来变得更为活动，则可以创建新的线程。也可以使用方法 setKeepAliveTime(long, java.util.concurrent.TimeUnit) 动态地更改此参数。使用 Long.MAX_VALUE TimeUnit.NANOSECONDS 的值在关闭前有效地从以前的终止状态禁用空闲线程。默认情况下，保持活动策略只在有多于 corePoolSizeThreads 的线程时应用。但是只要 keepAliveTime 值非 0，allowCoreThreadTimeOut(boolean) 方法也可将此超时策略应用于核心线程。
排队
所有 BlockingQueue 都可用于传输和保持提交的任务。可以使用此队列与池大小进行交互：
  • 如果运行的线程少于 corePoolSize，则 Executor 始终首选添加新的线程，而不进行排队。
  • 如果运行的线程等于或多于 corePoolSize，则 Executor 始终首选将请求加入队列，而不添加新的线程。
  • 如果无法将请求加入队列，则创建新的线程，除非创建此线程超出 maximumPoolSize，在这种情况下，任务将被拒绝。
排队有三种通用策略：
  1. 直接提交。工作队列的默认选项是 SynchronousQueue，它将任务直接提交给线程而不保持它们。在此，如果不存在可用于立即运行任务的线程，则试图把任务加入队列将失败，因此会构造一个新的线程。此策略可以避免在处理可能具有内部依赖性的请求集时出现锁。直接提交通常要求无界 maximumPoolSizes 以避免拒绝新提交的任务。当命令以超过队列所能处理的平均数连续到达时，此策略允许无界线程具有增长的可能性。
  2. 无界队列。使用无界队列（例如，不具有预定义容量的 LinkedBlockingQueue）将导致在所有 corePoolSize 线程都忙时新任务在队列中等待。这样，创建的线程就不会超过 corePoolSize。（因此，maximumPoolSize 的值也就无效了。）当每个任务完全独立于其他任务，即任务执行互不影响时，适合于使用无界队列；例如，在 Web 页服务器中。这种排队可用于处理瞬态突发请求，当命令以超过队列所能处理的平均数连续到达时，此策略允许无界线程具有增长的可能性。
  3. 有界队列。当使用有限的 maximumPoolSizes 时，有界队列（如 ArrayBlockingQueue）有助于防止资源耗尽，但是可能较难调整和控制。队列大小和最大池大小可能需要相互折衷：使用大型队列和小型池可以最大限度地降低 CPU 使用率、操作系统资源和上下文切换开销，但是可能导致人工降低吞吐量。如果任务频繁阻塞（例如，如果它们是 I/O 边界），则系统可能为超过您许可的更多线程安排时间。使用小型队列通常要求较大的池大小，CPU 使用率较高，但是可能遇到不可接受的调度开销，这样也会降低吞吐量。
被拒绝的任务
当 Executor 已经关闭，并且 Executor 将有限边界用于最大线程和工作队列容量，且已经饱和时，在方法 execute(java.lang.Runnable) 中提交的新任务将被拒绝。在以上两种情况下，execute 方法都将调用其 RejectedExecutionHandler 的 RejectedExecutionHandler.rejectedExecution(java.lang.Runnable, java.util.concurrent.ThreadPoolExecutor) 方法。下面提供了四种预定义的处理程序策略：
  1. 在默认的 ThreadPoolExecutor.AbortPolicy 中，处理程序遭到拒绝将抛出运行时 RejectedExecutionException。
  2. 在 ThreadPoolExecutor.CallerRunsPolicy 中，线程调用运行该任务的 execute 本身。此策略提供简单的反馈控制机制，能够减缓新任务的提交速度。
  3. 在 ThreadPoolExecutor.DiscardPolicy 中，不能执行的任务将被删除。
  4. 在 ThreadPoolExecutor.DiscardOldestPolicy 中，如果执行程序尚未关闭，则位于工作队列头部的任务将被删除，然后重试执行程序（如果再次失败，则重复此过程）。
定义和使用其他种类的 RejectedExecutionHandler 类也是可能的，但这样做需要非常小心，尤其是当策略仅用于特定容量或排队策略时。
钩子 (hook) 方法
此类提供 protected 可重写的 beforeExecute(java.lang.Thread, java.lang.Runnable) 和 afterExecute(java.lang.Runnable, java.lang.Throwable) 方法，这两种方法分别在执行每个任务之前和之后调用。它们可用于操纵执行环境；例如，重新初始化 ThreadLocal、搜集统计信息或添加日志条目。此外，还可以重写方法 terminated() 来执行 Executor 完全终止后需要完成的所有特殊处理。

如果钩子 (hook) 或回调方法抛出异常，则内部辅助线程将依次失败并突然终止。

队列维护
方法 getQueue() 允许出于监控和调试目的而访问工作队列。强烈反对出于其他任何目的而使用此方法。remove(java.lang.Runnable) 和 purge() 这两种方法可用于在取消大量已排队任务时帮助进行存储回收。
终止
程序 AND 不再引用的池没有剩余线程会自动 shutdown。如果希望确保回收取消引用的池（即使用户忘记调用 shutdown()），则必须安排未使用的线程最终终止：设置适当保持活动时间，使用 0 核心线程的下边界和/或设置 allowCoreThreadTimeOut(boolean)。

扩展示例。此类的大多数扩展可以重写一个或多个受保护的钩子 (hook) 方法。例如，下面是一个添加了简单的暂停/恢复功能的子类：

 class PausableThreadPoolExecutor extends ThreadPoolExecutor {
   private boolean isPaused;
   private ReentrantLock pauseLock = new ReentrantLock();
   private Condition unpaused = pauseLock.newCondition();

   public PausableThreadPoolExecutor(...) { super(...); }

   protected void beforeExecute(Thread t, Runnable r) {
     super.beforeExecute(t, r);
     pauseLock.lock();
     try {
       while (isPaused) unpaused.await();
     } catch(InterruptedException ie) {
       t.interrupt();
     } finally {
       pauseLock.unlock();
     }
   }

   public void pause() {
     pauseLock.lock();
     try {
       isPaused = true;
     } finally {
       pauseLock.unlock();
     }
   }

   public void resume() {
     pauseLock.lock();
     try {
       isPaused = false;
       unpaused.signalAll();
     } finally {
       pauseLock.unlock();
     }
   }
 }

从以下版本开始：
1.5

嵌套类摘要
static class | ThreadPoolExecutor.AbortPolicy 用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.
static class | ThreadPoolExecutor.CallerRunsPolicy 用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。
static class | ThreadPoolExecutor.DiscardOldestPolicy 用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。
static class | ThreadPoolExecutor.DiscardPolicy 用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。
构造方法摘要
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。
方法摘要
protected void | afterExecute(Runnable r, Throwable t) 基于完成执行给定 Runnable 所调用的方法。
void | allowCoreThreadTimeOut(boolean value) 如果在保持活动时间内没有任务到达，新任务到达时正在替换（如果需要），则设置控制核心线程是超时还是终止的策略。
boolean | allowsCoreThreadTimeOut() 如果此池允许核心线程超时和终止，如果在 keepAlive 时间内没有任务到达，新任务到达时正在替换（如果需要），则返回 true。
boolean | awaitTermination(long timeout, TimeUnit unit) 请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
protected void | beforeExecute(Thread t, Runnable r) 在执行给定线程中的给定 Runnable 之前调用的方法。
void | execute(Runnable command) 在将来某个时间执行给定任务。
protected void | finalize() 当不再引用此执行程序时，调用 shutdown。
int | getActiveCount() 返回主动执行任务的近似线程数。
long | getCompletedTaskCount() 返回已完成执行的近似任务总数。
int | getCorePoolSize() 返回核心线程数。
long | getKeepAliveTime(TimeUnit unit) 返回线程保持活动的时间，该时间就是超过核心池大小的线程可以在终止前保持空闲的时间值。
int | getLargestPoolSize() 返回曾经同时位于池中的最大线程数。
int | getMaximumPoolSize() 返回允许的最大线程数。
int | getPoolSize() 返回池中的当前线程数。
BlockingQueue<Runnable> | getQueue() 返回此执行程序使用的任务队列。
RejectedExecutionHandler | getRejectedExecutionHandler() 返回用于未执行任务的当前处理程序。
long | getTaskCount() 返回曾计划执行的近似任务总数。
ThreadFactory | getThreadFactory() 返回用于创建新线程的线程工厂。
boolean | isShutdown() 如果此执行程序已关闭，则返回 true。
boolean | isTerminated() 如果关闭后所有任务都已完成，则返回 true。
boolean | isTerminating() 如果此执行程序处于在 shutdown 或 shutdownNow 之后正在终止但尚未完全终止的过程中，则返回 true。
int | prestartAllCoreThreads() 启动所有核心线程，使其处于等待工作的空闲状态。
boolean | prestartCoreThread() 启动核心线程，使其处于等待工作的空闲状态。
void | purge() 尝试从工作队列移除所有已取消的 Future 任务。
boolean | remove(Runnable task) 从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。
void | setCorePoolSize(int corePoolSize) 设置核心线程数。
void | setKeepAliveTime(long time, TimeUnit unit) 设置线程在终止前可以保持空闲的时间限制。
void | setMaximumPoolSize(int maximumPoolSize) 设置允许的最大线程数。
void | setRejectedExecutionHandler(RejectedExecutionHandler handler) 设置用于未执行任务的新处理程序。
void | setThreadFactory(ThreadFactory threadFactory) 设置用于创建新线程的线程工厂。
void | shutdown() 按过去执行已提交任务的顺序发起一个有序的关闭，但是不接受新任务。
List<Runnable> | shutdownNow() 尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。
protected void | terminated() 当 Executor 已经终止时调用的方法。
从类 java.util.concurrent.AbstractExecutorService 继承的方法
invokeAll, invokeAll, invokeAny, invokeAny, newTaskFor, newTaskFor, submit, submit, submit
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ThreadPoolExecutor

public ThreadPoolExecutor(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。使用 Executors 工厂方法之一比使用此通用构造方法方便得多。

参数：
corePoolSize - 池中所保存的线程数，包括空闲线程。
maximumPoolSize - 池中允许的最大线程数。
keepAliveTime - 当线程数大于核心时，此为终止前多余的空闲线程等待新任务的最长时间。
unit - keepAliveTime 参数的时间单位。
workQueue - 执行前用于保持任务的队列。此队列仅保持由 execute 方法提交的 Runnable 任务。
抛出：
IllegalArgumentException - 如果 corePoolSize 或 keepAliveTime 小于 0，或者 maximumPoolSize 小于等于 0，或者 corePoolSize 大于 maximumPoolSize。
NullPointerException - 如果 workQueue 为 null

ThreadPoolExecutor

public ThreadPoolExecutor(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue,
                          ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。

参数：
corePoolSize - 池中所保存的线程数，包括空闲线程。
maximumPoolSize - 池中允许的最大线程数。
keepAliveTime - 当线程数大于核心时，此为终止前多余的空闲线程等待新任务的最长时间。
unit - keepAliveTime 参数的时间单位。
workQueue - 执行前用于保持任务的队列。此队列仅保持由 execute 方法提交的 Runnable 任务。
threadFactory - 执行程序创建新线程时使用的工厂。
抛出：
IllegalArgumentException - 如果 corePoolSize 或 keepAliveTime 小于 0，或者 maximumPoolSize 小于等于 0，或者 corePoolSize 大于 maximumPoolSize。
NullPointerException - 如果 workQueue 或 threadFactory 为 null。

ThreadPoolExecutor

public ThreadPoolExecutor(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue,
                          RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。

参数：
corePoolSize - 池中所保存的线程数，包括空闲线程。
maximumPoolSize - 池中允许的最大线程数。
keepAliveTime - 当线程数大于核心时，此为终止前多余的空闲线程等待新任务的最长时间。
unit - keepAliveTime 参数的时间单位。
workQueue - 执行前用于保持任务的队列。此队列仅由保持 execute 方法提交的 Runnable 任务。
handler - 由于超出线程范围和队列容量而使执行被阻塞时所使用的处理程序。
抛出：
IllegalArgumentException - 如果 corePoolSize 或 keepAliveTime 小于 0，或者 maximumPoolSize 小于等于 0，或者 corePoolSize 大于 maximumPoolSize。
NullPointerException - 如果 workQueue 或 handler 为 null。

ThreadPoolExecutor

public ThreadPoolExecutor(int corePoolSize,
                          int maximumPoolSize,
                          long keepAliveTime,
                          TimeUnit unit,
                          BlockingQueue<Runnable> workQueue,
                          ThreadFactory threadFactory,
                          RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

参数：
corePoolSize - 池中所保存的线程数，包括空闲线程。
maximumPoolSize - 池中允许的最大线程数。
keepAliveTime - 当线程数大于核心时，此为终止前多余的空闲线程等待新任务的最长时间。
unit - keepAliveTime 参数的时间单位。
workQueue - 执行前用于保持任务的队列。此队列仅保持由 execute 方法提交的 Runnable 任务。
threadFactory - 执行程序创建新线程时使用的工厂。
handler - 由于超出线程范围和队列容量而使执行被阻塞时所使用的处理程序。
抛出：
IllegalArgumentException - 如果 corePoolSize 或 keepAliveTime 小于 0，或者 maximumPoolSize 小于等于 0，或者 corePoolSize 大于 maximumPoolSize。
NullPointerException - 如果 workQueue、threadFactory 或 handler 为 null。
方法详细信息

execute

public void execute(Runnable command)
在将来某个时间执行给定任务。可以在新线程中或者在现有池线程中执行该任务。 如果无法将任务提交执行，或者因为此执行程序已关闭，或者因为已达到其容量，则该任务由当前 RejectedExecutionHandler 处理。

参数：
command - 要执行的任务。
抛出：
RejectedExecutionException - 如果无法接收要执行的任务，则由 RejectedExecutionHandler 决定是否抛出 RejectedExecutionException
NullPointerException - 如果命令为 null

shutdown

public void shutdown()
按过去执行已提交任务的顺序发起一个有序的关闭，但是不接受新任务。如果已经关闭，则调用没有其他作用。

抛出：
SecurityException - 如果安全管理器存在并且关闭此 ExecutorService 可能操作某些不允许调用者修改的线程（因为它没有 RuntimePermission ("modifyThread")），或者安全管理器的 checkAccess 方法拒绝访问。

shutdownNow

public List<Runnable> shutdownNow()
尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。在从此方法返回的任务队列中排空（移除）这些任务。

并不保证能够停止正在处理的活动执行任务，但是会尽力尝试。 此实现通过 Thread.interrupt() 取消任务，所以无法响应中断的任何任务可能永远无法终止。

返回：
从未开始执行的任务的列表。
抛出：
SecurityException - 如果安全管理器存在并且关闭此 ExecutorService 可能操作某些不允许调用者修改的线程（因为它没有 RuntimePermission ("modifyThread")），或者安全管理器的 checkAccess 方法拒绝访问。

isShutdown

public boolean isShutdown()
从接口 ExecutorService 复制的描述
如果此执行程序已关闭，则返回 true。

返回：
如果此执行程序已关闭，则返回 true

isTerminating

public boolean isTerminating()
如果此执行程序处于在 shutdown 或 shutdownNow 之后正在终止但尚未完全终止的过程中，则返回 true。此方法可能对调试很有用。关闭之后很长一段时间才报告返回的 true，这可能表示提交的任务已经被忽略或取消中断，导致此执行程序无法正确终止。

返回：
如果正在终止但尚未完成，则返回 true

isTerminated

public boolean isTerminated()
从接口 ExecutorService 复制的描述
如果关闭后所有任务都已完成，则返回 true。注意，除非首先调用 shutdown 或 shutdownNow，否则 isTerminated 永不为 true。

返回：
如果关闭后所有任务都已完成，则返回 true

awaitTermination

public boolean awaitTermination(long timeout,
                                TimeUnit unit)
                         throws InterruptedException
从接口 ExecutorService 复制的描述
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。

参数：
timeout - 最长等待时间
unit - timeout 参数的时间单位
返回：
如果此执行程序终止，则返回 true；如果终止前超时期满，则返回 false
抛出：
InterruptedException - 如果等待时发生中断

finalize

protected void finalize()
当不再引用此执行程序时，调用 shutdown。

覆盖：
类 Object 中的 finalize

setThreadFactory

public void setThreadFactory(ThreadFactory threadFactory)
设置用于创建新线程的线程工厂。

参数：
threadFactory - 新线程工厂
抛出：
NullPointerException - 如果 threadFactory 为 null
另请参见：
getThreadFactory()

getThreadFactory

public ThreadFactory getThreadFactory()
返回用于创建新线程的线程工厂。

返回：
当前线程工厂
另请参见：
setThreadFactory(java.util.concurrent.ThreadFactory)

setRejectedExecutionHandler

public void setRejectedExecutionHandler(RejectedExecutionHandler handler)
设置用于未执行任务的新处理程序。

参数：
handler - 新处理程序
抛出：
NullPointerException - 如果处理程序为 null
另请参见：
getRejectedExecutionHandler()

getRejectedExecutionHandler

public RejectedExecutionHandler getRejectedExecutionHandler()
返回用于未执行任务的当前处理程序。

返回：
当前处理程序
另请参见：
setRejectedExecutionHandler(java.util.concurrent.RejectedExecutionHandler)

setCorePoolSize

public void setCorePoolSize(int corePoolSize)
设置核心线程数。此操作将重写构造方法中设置的任何值。如果新值小于当前值，则多余的现有线程将在下一次空闲时终止。如果较大，则在需要时启动新线程来执行这些排队的任务。

参数：
corePoolSize - 新核心大小
抛出：
IllegalArgumentException - 如果 corePoolSize 小于 0
另请参见：
getCorePoolSize()

getCorePoolSize

public int getCorePoolSize()
返回核心线程数。

返回：
核心线程数
另请参见：
setCorePoolSize(int)

prestartCoreThread

public boolean prestartCoreThread()
启动核心线程，使其处于等待工作的空闲状态。仅当执行新任务时，此操作才重写默认的启动核心线程策略。如果已启动所有核心线程，此方法将返回 false。

返回：
如果启动了线程，则返回 true

prestartAllCoreThreads

public int prestartAllCoreThreads()
启动所有核心线程，使其处于等待工作的空闲状态。仅当执行新任务时，此操作才重写默认的启动核心线程策略。

返回：
已启动的线程数

allowsCoreThreadTimeOut

public boolean allowsCoreThreadTimeOut()
如果此池允许核心线程超时和终止，如果在 keepAlive 时间内没有任务到达，新任务到达时正在替换（如果需要），则返回 true。当返回 true 时，适用于非核心线程的相同的保持活动策略也同样适用于核心线程。当返回 false（默认值）时，由于没有传入任务，核心线程不会终止。

返回：
如果允许核心线程超时，则返回 true；否则返回 false
从以下版本开始：
1.6

allowCoreThreadTimeOut

public void allowCoreThreadTimeOut(boolean value)
如果在保持活动时间内没有任务到达，新任务到达时正在替换（如果需要），则设置控制核心线程是超时还是终止的策略。当为 false（默认值）时，由于没有传入任务，核心线程将永远不会中止。当为 true 时，适用于非核心线程的相同的保持活动策略也同样适用于核心线程。为了避免连续线程替换，保持活动时间在设置为 true 时必须大于 0。通常应该在主动使用该池前调用此方法。

参数：
value - 如果应该超时，则为 true；否则为 false
抛出：
IllegalArgumentException - 如果 value 为 true 并且当前保持活动时间不大于 0。
从以下版本开始：
1.6

setMaximumPoolSize

public void setMaximumPoolSize(int maximumPoolSize)
设置允许的最大线程数。此操作将重写构造方法中设置的任何值。如果新值小于当前值，则多余的现有线程将在下一次空闲时终止。

参数：
maximumPoolSize - 新的最大值
抛出：
IllegalArgumentException - 如果新的最大值小于等于 0，或者小于核心池大小
另请参见：
getMaximumPoolSize()

getMaximumPoolSize

public int getMaximumPoolSize()
返回允许的最大线程数。

返回：
允许的最大线程数
另请参见：
setMaximumPoolSize(int)

setKeepAliveTime

public void setKeepAliveTime(long time,
                             TimeUnit unit)
设置线程在终止前可以保持空闲的时间限制。如果池中的当前线程数多于核心线程数，在不处理任务的情况下等待这一时间段之后，多余的线程将被终止。此操作将重写构造方法中设置的任何值。

参数：
time - 等待的时间。时间值 0 将导致执行任务后多余的线程立即终止。
unit - 时间参数的时间单位
抛出：
IllegalArgumentException - 如果时间小于 0，或者时间为 0 和 allowsCoreThreadTimeOut
另请参见：
getKeepAliveTime(java.util.concurrent.TimeUnit)

getKeepAliveTime

public long getKeepAliveTime(TimeUnit unit)
返回线程保持活动的时间，该时间就是超过核心池大小的线程可以在终止前保持空闲的时间值。

参数：
unit - 所需的结果时间单位
返回：
时间限制
另请参见：
setKeepAliveTime(long, java.util.concurrent.TimeUnit)

getQueue

public BlockingQueue<Runnable> getQueue()
返回此执行程序使用的任务队列。对任务队列的访问主要用于调试和监控。此队列可能正处于活动使用状态中。获取任务队列不妨碍已加入队列的任务的执行。

返回：
任务队列

remove

public boolean remove(Runnable task)
从执行程序的内部队列中移除此任务（如果存在），从而如果尚未开始，则其不再运行。

此方法可用作取消方案的一部分。它可能无法移除在放置到内部队列之前已经转换为其他形式的任务。例如，使用 submit 输入的任务可能被转换为维护 Future 状态的形式。但是，在此情况下，purge() 方法可用于移除那些已被取消的 Future。

参数：
task - 要移除的任务
返回：
如果已经移除任务，则返回 true

purge

public void purge()
尝试从工作队列移除所有已取消的 Future 任务。此方法可用作存储回收操作，它对功能没有任何影响。取消的任务不会再次执行，但是它们可能在工作队列中累积，直到 worker 线程主动将其移除。调用此方法将试图立即移除它们。但是，如果出现其他线程的干预，那么此方法移除任务将失败。

getPoolSize

public int getPoolSize()
返回池中的当前线程数。

返回：
线程数。

getActiveCount

public int getActiveCount()
返回主动执行任务的近似线程数。

返回：
线程数。

getLargestPoolSize

public int getLargestPoolSize()
返回曾经同时位于池中的最大线程数。

返回：
线程数。

getTaskCount

public long getTaskCount()
返回曾计划执行的近似任务总数。因为在计算期间任务和线程的状态可能动态改变，所以返回值只是一个近似值。

返回：
任务数

getCompletedTaskCount

public long getCompletedTaskCount()
返回已完成执行的近似任务总数。因为在计算期间任务和线程的状态可能动态改变，所以返回值只是一个近似值，但是该值在整个连续调用过程中不会减少。

返回：
任务数。

beforeExecute

protected void beforeExecute(Thread t,
                             Runnable r)
在执行给定线程中的给定 Runnable 之前调用的方法。此方法由将执行任务 r 的线程 t 调用，并且可用于重新初始化 ThreadLocals 或者执行日志记录。

此实现不执行任何操作，但可在子类中定制。注：为了正确嵌套多个重写操作，此方法结束时，子类通常应该调用 super.beforeExecute。

参数：
t - 将运行任务 r 的线程。
r - 将执行的任务。

afterExecute

protected void afterExecute(Runnable r,
                            Throwable t)
基于完成执行给定 Runnable 所调用的方法。此方法由执行任务的线程调用。如果非 null，则 Throwable 是导致执行突然终止的未捕获 RuntimeException 或 Error。

注：当操作显示地或者通过 submit 之类的方法包含在任务内时（如 FutureTask），这些任务对象捕获和维护计算异常，因此它们不会导致突然终止，内部异常不会 传递给此方法。

此实现不执行任何操作，但可在子类中定制。注：为了正确嵌套多个重写操作，此方法开始时，子类通常应该调用 super.afterExecute。

参数：
r - 已经完成的 runnable 线程。
t - 导致终止的异常；如果执行正常结束，则为 null。

terminated

protected void terminated()
当 Executor 已经终止时调用的方法。默认实现不执行任何操作。注：为了正确嵌套多个重写操作，子类通常应该在此方法中调用 super.afterExecute。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPoolExecutor.AbortPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ThreadPoolExecutor.AbortPolicy

java.lang.Object
    继承者  java.util.concurrent.ThreadPoolExecutor.AbortPolicy
所有已实现的接口：
RejectedExecutionHandler
正在封闭类：
ThreadPoolExecutor
public static class ThreadPoolExecutor.AbortPolicy
extends Object
implements RejectedExecutionHandler

用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.

构造方法摘要
ThreadPoolExecutor.AbortPolicy()
创建一个 AbortPolicy。
方法摘要
 void rejectedExecution(Runnable r, ThreadPoolExecutor e)
总是抛出 RejectedExecutionException。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ThreadPoolExecutor.AbortPolicy

public ThreadPoolExecutor.AbortPolicy()
创建一个 AbortPolicy。

方法详细信息

rejectedExecution

public void rejectedExecution(Runnable r,
                              ThreadPoolExecutor e)
总是抛出 RejectedExecutionException。

指定者：
接口 RejectedExecutionHandler 中的 rejectedExecution
参数：
r - 请求执行的可运行任务。
e - 试图执行此任务的执行程序。
抛出：
RejectedExecutionException - 总是抛出此异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPoolExecutor.CallerRunsPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ThreadPoolExecutor.CallerRunsPolicy

java.lang.Object
    继承者  java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy
所有已实现的接口：
RejectedExecutionHandler
正在封闭类：
ThreadPoolExecutor
public static class ThreadPoolExecutor.CallerRunsPolicy
extends Object
implements RejectedExecutionHandler

用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。

构造方法摘要
ThreadPoolExecutor.CallerRunsPolicy()
创建一个 CallerRunsPolicy。
方法摘要
 void rejectedExecution(Runnable r, ThreadPoolExecutor e)
执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ThreadPoolExecutor.CallerRunsPolicy

public ThreadPoolExecutor.CallerRunsPolicy()
创建一个 CallerRunsPolicy。

方法详细信息

rejectedExecution

public void rejectedExecution(Runnable r,
                              ThreadPoolExecutor e)
执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。

指定者：
接口 RejectedExecutionHandler 中的 rejectedExecution
参数：
r - 请求执行的可运行任务。
e - 试图执行此任务的执行程序。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPoolExecutor.DiscardOldestPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ThreadPoolExecutor.DiscardOldestPolicy

java.lang.Object
    继承者  java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy
所有已实现的接口：
RejectedExecutionHandler
正在封闭类：
ThreadPoolExecutor
public static class ThreadPoolExecutor.DiscardOldestPolicy
extends Object
implements RejectedExecutionHandler

用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。

构造方法摘要
ThreadPoolExecutor.DiscardOldestPolicy()
为给定执行程序创建 DiscardOldestPolicy。
方法摘要
 void rejectedExecution(Runnable r, ThreadPoolExecutor e)
获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ThreadPoolExecutor.DiscardOldestPolicy

public ThreadPoolExecutor.DiscardOldestPolicy()
为给定执行程序创建 DiscardOldestPolicy。

方法详细信息

rejectedExecution

public void rejectedExecution(Runnable r,
                              ThreadPoolExecutor e)
获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。

指定者：
接口 RejectedExecutionHandler 中的 rejectedExecution
参数：
r - 请求执行的可运行任务。
e - 试图执行此任务的执行程序。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ThreadPoolExecutor.DiscardPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 ThreadPoolExecutor.DiscardPolicy

java.lang.Object
    继承者  java.util.concurrent.ThreadPoolExecutor.DiscardPolicy
所有已实现的接口：
RejectedExecutionHandler
正在封闭类：
ThreadPoolExecutor
public static class ThreadPoolExecutor.DiscardPolicy
extends Object
implements RejectedExecutionHandler

用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。

构造方法摘要
ThreadPoolExecutor.DiscardPolicy()
创建一个 DiscardPolicy。
方法摘要
 void rejectedExecution(Runnable r, ThreadPoolExecutor e)
不执行任何操作，在这种情况下将放弃任务 r。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ThreadPoolExecutor.DiscardPolicy

public ThreadPoolExecutor.DiscardPolicy()
创建一个 DiscardPolicy。

方法详细信息

rejectedExecution

public void rejectedExecution(Runnable r,
                              ThreadPoolExecutor e)
不执行任何操作，在这种情况下将放弃任务 r。

指定者：
接口 RejectedExecutionHandler 中的 rejectedExecution
参数：
r - 请求执行的可运行任务
e - 试图执行此任务的执行程序
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimeoutException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent
类 TimeoutException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.util.concurrent.TimeoutException
所有已实现的接口：
Serializable
public class TimeoutException
extends Exception

阻塞操作超时时，抛出该异常。对于指定超时的阻塞操作来说，需要一种指示发生超时的方法。多数这样的操作可能返回一个值指示超时；当不可能或不需要返回超时值时，将声明并抛出 TimeoutException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
TimeoutException()
构造不带详细消息的 TimeoutException。
TimeoutException(String message)
构造带指定详细消息的 TimeoutException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TimeoutException

public TimeoutException()
构造不带详细消息的 TimeoutException。

TimeoutException

public TimeoutException(String message)
构造带指定详细消息的 TimeoutException。

参数：
message - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimeUnit (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 | 详细信息： 枚举常量 | 字段 | 方法

java.util.concurrent
枚举 TimeUnit

java.lang.Object
    继承者  java.lang.Enum<TimeUnit>
        继承者  java.util.concurrent.TimeUnit
所有已实现的接口：
Serializable, Comparable<TimeUnit>
public enum TimeUnit
extends Enum<TimeUnit>

TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。TimeUnit 不维护时间信息，但是有助于组织和使用可能跨各种上下文单独维护的时间表示形式。毫微秒定义为千分之一微秒，微秒为千分之一毫秒，毫秒为千分之一秒，一分钟为六十秒，一小时为六十分钟，一天为二十四小时。

TimeUnit 主要用于通知基于时间的方法如何解释给定的计时参数。例如，如果 lock 不可用，则以下代码将在 50 毫秒后超时：

  Lock lock = ...;
  if ( lock.tryLock(50L, TimeUnit.MILLISECONDS) ) ...
而以下代码将在 50 秒后超时：
  Lock lock = ...;
  if ( lock.tryLock(50L, TimeUnit.SECONDS) ) ...
但是注意，不保证特定超时实现能够以与给定 TimeUnit 相同的粒度通知 段。

从以下版本开始：
1.5

枚举常量摘要
DAYS
HOURS
MICROSECONDS
MILLISECONDS
MINUTES
NANOSECONDS
SECONDS
方法摘要
long | convert(long sourceDuration, TimeUnit sourceUnit) 将给定单元的时间段转换到此单元。
void | sleep(long timeout) 使用此单元执行 Thread.sleep.这是将时间参数转换为 Thread.sleep 方法所需格式的便捷方法。
void | timedJoin(Thread thread, long timeout) 使用此时间单元执行计时的 Thread.join。
void | timedWait(Object obj, long timeout) 使用此时间单元执行计时的 Object.wait。
long | toDays(long duration) 等效于 DAYS.convert(duration, this)。
long | toHours(long duration) 等效于 HOURS.convert(duration, this)。
long | toMicros(long duration) 等效于 MICROSECONDS.convert(duration, this)。
long | toMillis(long duration) 等效于 MILLISECONDS.convert(duration, this)。
long | toMinutes(long duration) 等效于 MINUTES.convert(duration, this)。
long | toNanos(long duration) 等效于 NANOSECONDS.convert(duration, this)。
long | toSeconds(long duration) 等效于 SECONDS.convert(duration, this)。
static TimeUnit | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TimeUnit[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

NANOSECONDS

public static final TimeUnit NANOSECONDS

MICROSECONDS

public static final TimeUnit MICROSECONDS

MILLISECONDS

public static final TimeUnit MILLISECONDS

SECONDS

public static final TimeUnit SECONDS

MINUTES

public static final TimeUnit MINUTES

HOURS

public static final TimeUnit HOURS

DAYS

public static final TimeUnit DAYS
方法详细信息

values

public static final TimeUnit[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(TimeUnit c : TimeUnit.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TimeUnit valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

convert

public long convert(long sourceDuration,
                    TimeUnit sourceUnit)
将给定单元的时间段转换到此单元。从较细粒度到较粗粒度的舍位转换，这样会失去精确性。例如，将 999 毫秒转换为秒的结果为 0。使用参数从较粗粒度到较细粒度转换，如果参数为负，则在数字上溢出至 Long.MIN_VALUE，如果为正，则为 Long.MAX_VALUE。

例如，要将 10 分钟转换为毫秒，请使用：TimeUnit.MILLISECONDS.convert(10L, TimeUnit.MINUTES)

参数：
sourceDuration - 给定 sourceUnit 中的时间段
sourceUnit - sourceDuration 参数的单元
返回：
此单元中的转换时间段；如果转换将负溢出，则返回 Long.MIN_VALUE；如果转换将正溢出，则返回 Long.MAX_VALUE。

toNanos

public long toNanos(long duration)
等效于 NANOSECONDS.convert(duration, this)。

参数：
duration - 时间段
返回：
转换时间段，如果转换将负溢出，则返回 Long.MIN_VALUE；如果转换将正溢出，则返回 Long.MAX_VALUE。
另请参见：
convert(long, java.util.concurrent.TimeUnit)

toMicros

public long toMicros(long duration)
等效于 MICROSECONDS.convert(duration, this)。

参数：
duration - 时间段
返回：
转换时间段，如果转换将负溢出，则返回 Long.MIN_VALUE；如果转换将正溢出，则返回 Long.MAX_VALUE。
另请参见：
convert(long, java.util.concurrent.TimeUnit)

toMillis

public long toMillis(long duration)
等效于 MILLISECONDS.convert(duration, this)。

参数：
duration - 时间段
返回：
转换时间段，如果转换将负溢出，则返回 Long.MIN_VALUE；如果转换将正溢出，则返回 Long.MAX_VALUE。
另请参见：
convert(long, java.util.concurrent.TimeUnit)

toSeconds

public long toSeconds(long duration)
等效于 SECONDS.convert(duration, this)。

参数：
duration - 时间段
返回：
转换时间段；如果转换将负溢出，则返回 Long.MIN_VALUE；如果转换将正溢出，则返回 Long.MAX_VALUE。
另请参见：
convert(long, java.util.concurrent.TimeUnit)

toMinutes

public long toMinutes(long duration)
等效于 MINUTES.convert(duration, this)。

参数：
duration - 时间段
返回：
转换时间段；如果转换将负溢出，则返回 Long.MIN_VALUE；如果转换将正溢出，则返回 Long.MAX_VALUE。
从以下版本开始：
1.6
另请参见：
convert(long, java.util.concurrent.TimeUnit)

toHours

public long toHours(long duration)
等效于 HOURS.convert(duration, this)。

参数：
duration - 时间段
返回：
转换时间段；如果转换将负溢出，则返回 Long.MIN_VALUE；如果转换将正溢出，则返回 Long.MAX_VALUE。
从以下版本开始：
1.6
另请参见：
convert(long, java.util.concurrent.TimeUnit)

toDays

public long toDays(long duration)
等效于 DAYS.convert(duration, this)。

参数：
duration - 时间段
返回：
转换时间段
从以下版本开始：
1.6
另请参见：
convert(long, java.util.concurrent.TimeUnit)

timedWait

public void timedWait(Object obj,
                      long timeout)
               throws InterruptedException
使用此时间单元执行计时的 Object.wait。这是将超时参数转换为 Object.wait 方法所需格式的便捷方法。

例如，可以使用以下代码实现阻塞 poll 方法（参见 BlockingQueue.poll）：

  public synchronized  Object poll(long timeout, TimeUnit unit) throws InterruptedException {
    while (empty) {
      unit.timedWait(this, timeout);
      ...
    }
  }

参数：
obj - 要等待的对象
timeout - 要等待的最长时间。如果小于等于 0，则根本不会等待。
抛出：
InterruptedException - 如果等待时中断。
另请参见：
Object.wait(long, int)

timedJoin

public void timedJoin(Thread thread,
                      long timeout)
               throws InterruptedException
使用此时间单元执行计时的 Thread.join。这是将时间参数转换为 Thread.join 方法所需格式的便捷方法。

参数：
thread - 要等待的线程
timeout - 要等待的最长时间。如果小于等于 0，则根本不会等待。
抛出：
InterruptedException - 如果等待时中断。
另请参见：
Thread.join(long, int)

sleep

public void sleep(long timeout)
           throws InterruptedException
使用此单元执行 Thread.sleep.这是将时间参数转换为 Thread.sleep 方法所需格式的便捷方法。

参数：
timeout - 休眠的最短时间。如果小于等于 0，则根本不会休眠。
抛出：
InterruptedException - 如果休眠时中断。
另请参见：
Thread.sleep(long)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 | 详细信息： 枚举常量 | 字段 | 方法


java.util.concurrent (Java 2 Platform SE 6)

 java.util.concurrent
接口
BlockingDeque
BlockingQueue
Callable
CompletionService
ConcurrentMap
ConcurrentNavigableMap
Delayed
Executor
ExecutorService
Future
RejectedExecutionHandler
RunnableFuture
RunnableScheduledFuture
ScheduledExecutorService
ScheduledFuture
ThreadFactory
类
AbstractExecutorService
ArrayBlockingQueue
ConcurrentHashMap
ConcurrentLinkedQueue
ConcurrentSkipListMap
ConcurrentSkipListSet
CopyOnWriteArrayList
CopyOnWriteArraySet
CountDownLatch
CyclicBarrier
DelayQueue
Exchanger
ExecutorCompletionService
Executors
FutureTask
LinkedBlockingDeque
LinkedBlockingQueue
PriorityBlockingQueue
ScheduledThreadPoolExecutor
Semaphore
SynchronousQueue
ThreadPoolExecutor
ThreadPoolExecutor.AbortPolicy
ThreadPoolExecutor.CallerRunsPolicy
ThreadPoolExecutor.DiscardOldestPolicy
ThreadPoolExecutor.DiscardPolicy
枚举
TimeUnit
异常
BrokenBarrierException
CancellationException
ExecutionException
RejectedExecutionException
TimeoutException


java.util.concurrent (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.concurrent

在并发编程中很常用的实用工具类。

请参见：
描述

接口摘要
BlockingDeque<E> | 支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
BlockingQueue<E> | 支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。
Callable<V> | 返回结果并且可能抛出异常的任务。
CompletionService<V> | 将生产新的异步任务与使用已完成任务的结果分离开来的服务。
ConcurrentMap<K,V> | 提供其他原子 putIfAbsent、remove、replace 方法的 Map。
ConcurrentNavigableMap<K,V> | 支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。
Delayed | 一种混合风格的接口，用来标记那些应该在给定延迟时间之后执行的对象。
Executor | 执行已提交的 Runnable 任务的对象。
ExecutorService | Executor 提供了管理终止的方法，以及可为跟踪一个或多个异步任务执行状况而生成 Future 的方法。
Future<V> | Future 表示异步计算的结果。
RejectedExecutionHandler | 无法由 ThreadPoolExecutor 执行的任务的处理程序。
RunnableFuture<V> | 作为 Runnable 的 Future。
RunnableScheduledFuture<V> | 作为 Runnable 的 ScheduledFuture。
ScheduledExecutorService | 一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。
ScheduledFuture<V> | 一个延迟的、结果可接受的操作，可将其取消。
ThreadFactory | 根据需要创建新线程的对象。

类摘要
AbstractExecutorService | 提供 ExecutorService 执行方法的默认实现。
ArrayBlockingQueue<E> | 一个由数组支持的有界阻塞队列。
ConcurrentHashMap<K,V> | 支持获取的完全并发和更新的所期望可调整并发的哈希表。
ConcurrentLinkedQueue<E> | 一个基于链接节点的无界线程安全队列。
ConcurrentSkipListMap<K,V> | 可缩放的并发 ConcurrentNavigableMap 实现。
ConcurrentSkipListSet<E> | 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
CopyOnWriteArrayList<E> | ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
CopyOnWriteArraySet<E> | 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
CountDownLatch | 一个同步辅助类，在完成一组正在其他线程中执行的操作之前，它允许一个或多个线程一直等待。
CyclicBarrier | 一个同步辅助类，它允许一组线程互相等待，直到到达某个公共屏障点 (common barrier point)。
DelayQueue<E extends Delayed> | Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
Exchanger<V> | 可以在对中对元素进行配对和交换的线程的同步点。
ExecutorCompletionService<V> | 使用提供的 Executor 来执行任务的 CompletionService。
Executors | 此包中所定义的 Executor、ExecutorService、ScheduledExecutorService、ThreadFactory 和 Callable 类的工厂和实用方法。
FutureTask<V> | 可取消的异步计算。
LinkedBlockingDeque<E> | 一个基于已链接节点的、任选范围的阻塞双端队列。
LinkedBlockingQueue<E> | 一个基于已链接节点的、范围任意的 blocking queue。
PriorityBlockingQueue<E> | 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
ScheduledThreadPoolExecutor | ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
Semaphore | 一个计数信号量。
SynchronousQueue<E> | 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。
ThreadPoolExecutor | 一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。
ThreadPoolExecutor.AbortPolicy | 用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.
ThreadPoolExecutor.CallerRunsPolicy | 用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。
ThreadPoolExecutor.DiscardOldestPolicy | 用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。
ThreadPoolExecutor.DiscardPolicy | 用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。

枚举摘要
TimeUnit TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

异常摘要
BrokenBarrierException | 当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
CancellationException | 如果某项值生成任务（如 FutureTask）的结果因为任务被取消而无法获取到，则抛出该异常。
ExecutionException | 当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
RejectedExecutionException | 当无法执行某个任务时,由 Executor 抛出的异常。
TimeoutException | 阻塞操作超时时，抛出该异常。

软件包 java.util.concurrent 的描述

在并发编程中很常用的实用工具类。此包包括了几个小的、已标准化的可扩展框架，以及一些提供有用功能的类，没有这些类，这些功能会很难实现或实现起来冗长乏味。下面简要描述主要的组件。另请参阅 locks 和 atomic 包。

执行程序

接口。 Executor 是一个简单的标准化接口，用于定义类似于线程的自定义子系统，包括线程池、异步 IO 和轻量级任务框架。根据所使用的具体 Executor 类的不同，可能在新创建的线程中，现有的任务执行线程中，或者调用 execute() 的线程中执行任务，并且可能顺序或并发执行。ExecutorService 提供了多个完整的异步任务执行框架。ExecutorService 管理任务的排队和安排，并允许受控制的关闭。ScheduledExecutorService 子接口及相关的接口添加了对延迟的和定期任务执行的支持。ExecutorService 提供了安排异步执行的方法，可执行由 Callable 表示的任何函数，结果类似于 Runnable。Future 返回函数的结果，允许确定执行是否完成，并提供取消执行的方法。RunnableFuture 是拥有 run 方法的 Future，run 方法执行时将设置其结果。

实现。类 ThreadPoolExecutor 和 ScheduledThreadPoolExecutor 提供可调的、灵活的线程池。Executors 类提供大多数 Executor 的常见类型和配置的工厂方法，以及使用它们的几种实用工具方法。其他基于 Executor 的实用工具包括具体类 FutureTask，它提供 Future 的常见可扩展实现，以及 ExecutorCompletionService，它有助于协调对异步任务组的处理。

队列

java.util.concurrent ConcurrentLinkedQueue 类提供了高效的、可伸缩的、线程安全的非阻塞 FIFO 队列。java.util.concurrent 中的五个实现都支持扩展的 BlockingQueue 接口，该接口定义了 put 和 take 的阻塞版本：LinkedBlockingQueue、ArrayBlockingQueue、SynchronousQueue、PriorityBlockingQueue 和 DelayQueue。这些不同的类覆盖了生产者-使用者、消息传递、并行任务执行和相关并发设计的大多数常见使用的上下文。BlockingDeque 接口扩展 BlockingQueue，以支持 FIFO 和 LIFO（基于堆栈）操作。LinkedBlockingDeque 类提供一个实现。

计时

TimeUnit 类为指定和控制基于超时的操作提供了多重粒度（包括纳秒级）。该包中的大多数类除了包含不确定的等待之外，还包含基于超时的操作。在使用超时的所有情况中，超时指定了在表明已超时前该方法应该等待的最少时间。在超时发生后，实现会“尽力”检测超时。但是，在检测超时与超时之后再次实际执行线程之间可能要经过不确定的时间。接受超时期参数的所有方法将小于等于 0 的值视为根本不会等待。要“永远”等待，可以使用 Long.MAX_VALUE 值。

同步器

四个类可协助实现常见的专用同步语句。Semaphore 是一个经典的并发工具。CountDownLatch 是一个极其简单但又极其常用的实用工具，用于在保持给定数目的信号、事件或条件前阻塞执行。CyclicBarrier 是一个可重置的多路同步点，在某些并行编程风格中很有用。Exchanger 允许两个线程在 collection 点交换对象，它在多流水线设计中是有用的。

并发 Collection

除队列外，此包还提供了设计用于多线程上下文中的 Collection 实现：ConcurrentHashMap、ConcurrentSkipListMap、ConcurrentSkipListSet、CopyOnWriteArrayList 和 CopyOnWriteArraySet。当期望许多线程访问一个给定 collection 时，ConcurrentHashMap 通常优于同步的 HashMap，ConcurrentSkipListMap 通常优于同步的 TreeMap。当期望的读数和遍历远远大于列表的更新数时，CopyOnWriteArrayList 优于同步的 ArrayList。

此包中与某些类一起使用的“Concurrent&rdquo前缀;是一种简写，表明与类似的“同步”类有所不同。例如，java.util.Hashtable 和 Collections.synchronizedMap(new HashMap()) 是同步的，但 ConcurrentHashMap 则是“并发的”。并发 collection 是线程安全的，但是不受单个排他锁的管理。在 ConcurrentHashMap 这一特定情况下，它可以安全地允许进行任意数目的并发读取，以及数目可调的并发写入。需要通过单个锁不允许对 collection 的所有访问时，“同步”类是很有用的，其代价是较差的可伸缩性。在期望多个线程访问公共 collection 的其他情况中，通常“并发”版本要更好一些。当 collection 是未共享的，或者仅保持其他锁时 collection 是可访问的情况下，非同步 collection 则要更好一些。

大多数并发 Collection 实现（包括大多数 Queue）与常规的 java.util 约定也不同，因为它们的迭代器提供了弱一致的，而不是快速失败的遍历。弱一致的迭代器是线程安全的，但是在迭代时没有必要冻结 collection，所以它不一定反映自迭代器创建以来的所有更新。

内存一致性属性

Java Language Specification 第 17 章定义了内存操作（如共享变量的读写）的 happen-before 关系。只有写入操作 happen-before 读取操作时，才保证一个线程写入的结果对另一个线程的读取是可视的。synchronized 和 volatile 构造 happen-before 关系，Thread.start() 和 Thread.join() 方法形成 happen-before 关系。尤其是：
  • 线程中的每个操作 happen-before 稍后按程序顺序传入的该线程中的每个操作。
  • 一个解除锁监视器的（synchronized 阻塞或方法退出）happen-before 相同监视器的每个后续锁（synchronized 阻塞或方法进入）。并且因为 happen-before 关系是可传递的，所以解除锁定之前的线程的所有操作 happen-before 锁定该监视器的任何线程后续的所有操作。
  • 写入 volatile 字段 happen-before 每个后续读取相同字段。volatile 字段的读取和写入与进入和退出监视器具有相似的内存一致性效果，但不 需要互斥锁。
  • 在线程上调用 start happen-before 已启动的线程中的任何线程。
  • 线程中的所有操作 happen-before 从该线程上的 join 成功返回的任何其他线程。
java.util.concurrent 中所有类的方法及其子包扩展了这些对更高级别同步的保证。尤其是：
  • 线程中将一个对象放入任何并发 collection 之前的操作 happen-before 从另一线程中的 collection 访问或移除该元素的后续操作。
  • 线程中向 Executor 提交 Runnable 之前的操作 happen-before 其执行开始。同样适用于向 ExecutorService 提交 Callables。
  • 异步计算（由 Future 表示）所采取的操作 happen-before 通过另一线程中 Future.get() 获取结果后续的操作。
  • “释放”同步储存方法（如 Lock.unlock、Semaphore.release 和 CountDownLatch.countDown）之前的操作 happen-before 另一线程中相同同步储存对象成功“获取”方法（如 Lock.lock、Semaphore.acquire、Condition.await 和 CountDownLatch.await）的后续操作。
  • 对于通过 Exchanger 成功交换对象的每个线程对，每个线程中 exchange() 之前的操作 happen-before 另一线程中对应 exchange() 后续的操作。
  • 调用 CyclicBarrier.await 之前的操作 happen-before 屏障操作所执行的操作，屏障操作所执行的操作 happen-before 从另一线程中对应 await 成功返回的后续操作。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.concurrent 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.concurrent 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractQueue<E> (implements java.util.Queue<E>)
        • java.util.concurrent.ArrayBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.ConcurrentLinkedQueue<E> (implements java.util.Queue<E>, java.io.Serializable)
        • java.util.concurrent.DelayQueue<E> (implements java.util.concurrent.BlockingQueue<E>)
        • java.util.concurrent.LinkedBlockingDeque<E> (implements java.util.concurrent.BlockingDeque<E>, java.io.Serializable)
        • java.util.concurrent.LinkedBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.PriorityBlockingQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
        • java.util.concurrent.SynchronousQueue<E> (implements java.util.concurrent.BlockingQueue<E>, java.io.Serializable)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.concurrent.ConcurrentSkipListSet<E> (implements java.lang.Cloneable, java.util.NavigableSet<E>, java.io.Serializable)
        • java.util.concurrent.CopyOnWriteArraySet<E> (implements java.io.Serializable)
    • java.util.concurrent.AbstractExecutorService (implements java.util.concurrent.ExecutorService)
      • java.util.concurrent.ThreadPoolExecutor
        • java.util.concurrent.ScheduledThreadPoolExecutor (implements java.util.concurrent.ScheduledExecutorService)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.concurrent.ConcurrentHashMap<K,V> (implements java.util.concurrent.ConcurrentMap<K,V>, java.io.Serializable)
      • java.util.concurrent.ConcurrentSkipListMap<K,V> (implements java.lang.Cloneable, java.util.concurrent.ConcurrentNavigableMap<K,V>, java.io.Serializable)
    • java.util.concurrent.CopyOnWriteArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
    • java.util.concurrent.CountDownLatch
    • java.util.concurrent.CyclicBarrier
    • java.util.concurrent.Exchanger<V>
    • java.util.concurrent.ExecutorCompletionService<V> (implements java.util.concurrent.CompletionService<V>)
    • java.util.concurrent.Executors
    • java.util.concurrent.FutureTask<V> (implements java.util.concurrent.RunnableFuture<V>)
    • java.util.concurrent.Semaphore (implements java.io.Serializable)
    • java.util.concurrent.ThreadPoolExecutor.AbortPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.util.concurrent.ThreadPoolExecutor.DiscardPolicy (implements java.util.concurrent.RejectedExecutionHandler)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.util.concurrent.BrokenBarrierException
        • java.util.concurrent.ExecutionException
        • java.lang.RuntimeException
          • java.lang.IllegalStateException
            • java.util.concurrent.CancellationException
          • java.util.concurrent.RejectedExecutionException
        • java.util.concurrent.TimeoutException

接口分层结构

  • java.util.concurrent.Callable<V>
  • java.lang.Comparable<T>
    • java.util.concurrent.Delayed
      • java.util.concurrent.ScheduledFuture<V> (并 extends java.util.concurrent.Future<V>)
        • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>)
  • java.util.concurrent.CompletionService<V>
  • java.util.concurrent.Executor
    • java.util.concurrent.ExecutorService
      • java.util.concurrent.ScheduledExecutorService
  • java.util.concurrent.Future<V>
    • java.util.concurrent.RunnableFuture<V> (并 extends java.lang.Runnable)
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.ScheduledFuture<V>)
    • java.util.concurrent.ScheduledFuture<V> (并 extends java.util.concurrent.Delayed)
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.RunnableFuture<V>)
  • java.lang.Iterable<T>
    • java.util.Collection<E>
      • java.util.Queue<E>
        • java.util.concurrent.BlockingQueue<E>
          • java.util.concurrent.BlockingDeque<E> (并 extends java.util.Deque<E>)
        • java.util.Deque<E>
          • java.util.concurrent.BlockingDeque<E> (并 extends java.util.concurrent.BlockingQueue<E>)
  • java.util.Map<K,V>
    • java.util.concurrent.ConcurrentMap<K,V>
      • java.util.concurrent.ConcurrentNavigableMap<K,V> (并 extends java.util.NavigableMap<K,V>)
    • java.util.SortedMap<K,V>
      • java.util.NavigableMap<K,V>
        • java.util.concurrent.ConcurrentNavigableMap<K,V> (并 extends java.util.concurrent.ConcurrentMap<K,V>)
  • java.util.concurrent.RejectedExecutionHandler
  • java.lang.Runnable
    • java.util.concurrent.RunnableFuture<V> (并 extends java.util.concurrent.Future<V>)
      • java.util.concurrent.RunnableScheduledFuture<V> (并 extends java.util.concurrent.ScheduledFuture<V>)
  • java.util.concurrent.ThreadFactory

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • java.util.concurrent.TimeUnit
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.concurrent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.concurrent
的使用

使用 java.util.concurrent 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.management | 提供 Java Management Extensions 的核心类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

java.util.concurrent 使用的 java.util.concurrent 中的类
AbstractExecutorService
提供 ExecutorService 执行方法的默认实现。
BlockingDeque
支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
BlockingQueue
支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。
BrokenBarrierException
当某个线程试图等待处于断开状态的 barrier 时，或者 barrier 进入断开状态而线程处于等待状态时，抛出该异常。
Callable
返回结果并且可能抛出异常的任务。
CompletionService
将生产新的异步任务与使用已完成任务的结果分离开来的服务。
ConcurrentMap
提供其他原子 putIfAbsent、remove、replace 方法的 Map。
ConcurrentNavigableMap
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。
ConcurrentSkipListMap
可缩放的并发 ConcurrentNavigableMap 实现。
ConcurrentSkipListSet
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
Delayed
一种混合风格的接口，用来标记那些应该在给定延迟时间之后执行的对象。
ExecutionException
当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
Executor
执行已提交的 Runnable 任务的对象。
ExecutorService
Executor 提供了管理终止的方法，以及可为跟踪一个或多个异步任务执行状况而生成 Future 的方法。
Future
Future 表示异步计算的结果。
RejectedExecutionHandler
无法由 ThreadPoolExecutor 执行的任务的处理程序。
RunnableFuture
作为 Runnable 的 Future。
RunnableScheduledFuture
作为 Runnable 的 ScheduledFuture。
ScheduledExecutorService
一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。
ScheduledFuture
一个延迟的、结果可接受的操作，可将其取消。
ThreadFactory
根据需要创建新线程的对象。
ThreadPoolExecutor
一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。
TimeoutException
阻塞操作超时时，抛出该异常。
TimeUnit
TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

java.util.concurrent.locks 使用的 java.util.concurrent 中的类
TimeUnit
TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

javax.management 使用的 java.util.concurrent 中的类
Executor
执行已提交的 Runnable 任务的对象。

javax.swing 使用的 java.util.concurrent 中的类
ExecutionException
当试图获取已通过抛出异常而中止的任务的结果时，抛出此异常。
Future
Future 表示异步计算的结果。
RunnableFuture
作为 Runnable 的 Future。
TimeoutException
阻塞操作超时时，抛出该异常。
TimeUnit
TimeUnit 表示给定单元粒度的时间段，它提供在这些单元中进行跨单元转换和执行计时及延迟操作的实用工具方法。

javax.tools 使用的 java.util.concurrent 中的类
Callable
返回结果并且可能抛出异常的任务。

javax.xml.ws 使用的 java.util.concurrent 中的类
Executor
执行已提交的 Runnable 任务的对象。
Future
Future 表示异步计算的结果。

javax.xml.ws.spi 使用的 java.util.concurrent 中的类
Executor
执行已提交的 Runnable 任务的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AtomicBoolean (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicBoolean

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicBoolean
所有已实现的接口：
Serializable
public class AtomicBoolean
extends Object
implements Serializable

可以用原子方式更新的 boolean 值。有关原子变量属性的描述，请参阅 java.util.concurrent.atomic 包规范。AtomicBoolean 可用在应用程序中（如以原子方式更新的标志），但不能用于替换 Boolean。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AtomicBoolean()
使用初始值 false 创建新的 AtomicBoolean。
AtomicBoolean(boolean initialValue)
使用给定的初始值创建新的 AtomicBoolean。
方法摘要
boolean | compareAndSet(boolean expect, boolean update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
boolean | get() 返回当前值。
boolean | getAndSet(boolean newValue) 以原子方式设置为给定值，并返回以前的值。
void | lazySet(boolean newValue) 最终设置为给定值。
void | set(boolean newValue) 无条件地设置为给定值。
String | toString() 返回当前值的字符串表示形式。
boolean | weakCompareAndSet(boolean expect, boolean update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AtomicBoolean

public AtomicBoolean(boolean initialValue)
使用给定的初始值创建新的 AtomicBoolean。

参数：
initialValue - 初始值

AtomicBoolean

public AtomicBoolean()
使用初始值 false 创建新的 AtomicBoolean。

方法详细信息

get

public final boolean get()
返回当前值。

返回：
当前值

compareAndSet

public final boolean compareAndSet(boolean expect,
                                   boolean update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 False 指示实际值与预期值不相等。

weakCompareAndSet

public boolean weakCompareAndSet(boolean expect,
                                 boolean update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

可能意外失败并且不提供排序保证，因此几乎只是 compareAndSet 的适当替代方法。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

set

public final void set(boolean newValue)
无条件地设置为给定值。

参数：
newValue - 新值

lazySet

public final void lazySet(boolean newValue)
最终设置为给定值。

参数：
newValue - 新值
从以下版本开始：
1.6

getAndSet

public final boolean getAndSet(boolean newValue)
以原子方式设置为给定值，并返回以前的值。

参数：
newValue - 新值
返回：
以前的值

toString

public String toString()
返回当前值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
当前值的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AtomicInteger (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicInteger

java.lang.Object
    继承者  java.lang.Number
        继承者  java.util.concurrent.atomic.AtomicInteger
所有已实现的接口：
Serializable
public class AtomicInteger
extends Number
implements Serializable

可以用原子方式更新的 int 值。有关原子变量属性的描述，请参阅 java.util.concurrent.atomic 包规范。AtomicInteger 可用在应用程序中（如以原子方式增加的计数器），并且不能用于替换 Integer。但是，此类确实扩展了 Number，允许那些处理基于数字类的工具和实用工具进行统一访问。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AtomicInteger()
创建具有初始值 0 的新 AtomicInteger。
AtomicInteger(int initialValue)
创建具有给定初始值的新 AtomicInteger。
方法摘要
int | addAndGet(int delta) 以原子方式将给定值与当前值相加。
boolean | compareAndSet(int expect, int update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
int | decrementAndGet() 以原子方式将当前值减 1。
double | doubleValue() 以 double 形式返回指定的数值。
float | floatValue() 以 float 形式返回指定的数值。
int | get() 获取当前值。
int | getAndAdd(int delta) 以原子方式将给定值与当前值相加。
int | getAndDecrement() 以原子方式将当前值减 1。
int | getAndIncrement() 以原子方式将当前值加 1。
int | getAndSet(int newValue) 以原子方式设置为给定值，并返回旧值。
int | incrementAndGet() 以原子方式将当前值加 1。
int | intValue() 以 int 形式返回指定的数值。
void | lazySet(int newValue) 最后设置为给定值。
long | longValue() 以 long 形式返回指定的数值。
void | set(int newValue) 设置为给定值。
String | toString() 返回当前值的字符串表示形式。
boolean | weakCompareAndSet(int expect, int update) 如果当前值 == 预期值，则以原子方式将该设置为给定的更新值。
从类 java.lang.Number 继承的方法
byteValue, shortValue
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AtomicInteger

public AtomicInteger(int initialValue)
创建具有给定初始值的新 AtomicInteger。

参数：
initialValue - 初始值

AtomicInteger

public AtomicInteger()
创建具有初始值 0 的新 AtomicInteger。

方法详细信息

get

public final int get()
获取当前值。

返回：
当前值

set

public final void set(int newValue)
设置为给定值。

参数：
newValue - 新值

lazySet

public final void lazySet(int newValue)
最后设置为给定值。

参数：
newValue - 新值
从以下版本开始：
1.6

getAndSet

public final int getAndSet(int newValue)
以原子方式设置为给定值，并返回旧值。

参数：
newValue - 新值
返回：
以前的值

compareAndSet

public final boolean compareAndSet(int expect,
                                   int update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 False 指示实际值与预期值不相等。

weakCompareAndSet

public final boolean weakCompareAndSet(int expect,
                                       int update)
如果当前值 == 预期值，则以原子方式将该设置为给定的更新值。

可能意外失败并且不提供排序保证，所以只有在很少的情况下才对 compareAndSet 进行适当地选择。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

getAndIncrement

public final int getAndIncrement()
以原子方式将当前值加 1。

返回：
以前的值

getAndDecrement

public final int getAndDecrement()
以原子方式将当前值减 1。

返回：
以前的值

getAndAdd

public final int getAndAdd(int delta)
以原子方式将给定值与当前值相加。

参数：
delta - 要加上的值
返回：
以前的值

incrementAndGet

public final int incrementAndGet()
以原子方式将当前值加 1。

返回：
更新的值

decrementAndGet

public final int decrementAndGet()
以原子方式将当前值减 1。

返回：
更新的值

addAndGet

public final int addAndGet(int delta)
以原子方式将给定值与当前值相加。

参数：
delta - 要加上的值
返回：
更新的值

toString

public String toString()
返回当前值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
当前值的字符串表示形式。

intValue

public int intValue()
从类 Number 复制的描述
以 int 形式返回指定的数值。这可能会涉及到舍入或取整。

指定者：
类 Number 中的 intValue
返回：
转换为 int 类型后该对象表示的数值。

longValue

public long longValue()
从类 Number 复制的描述
以 long 形式返回指定的数值。这可能涉及到舍入或取整。

指定者：
类 Number 中的 longValue
返回：
转换为 long 类型后该对象表示的数值。

floatValue

public float floatValue()
从类 Number 复制的描述
以 float 形式返回指定的数值。这可能会涉及到舍入。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 类型后该对象表示的数值。

doubleValue

public double doubleValue()
从类 Number 复制的描述
以 double 形式返回指定的数值。这可能会涉及到舍入。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 类型后该对象表示的数值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicIntegerArray (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicIntegerArray

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicIntegerArray
所有已实现的接口：
Serializable
public class AtomicIntegerArray
extends Object
implements Serializable

可以用原子方式更新其元素的 int 数组。有关原子变量属性的描述，请参阅 java.util.concurrent.atomic 包规范。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AtomicIntegerArray(int length)
创建给定长度的新 AtomicIntegerArray。
AtomicIntegerArray(int[] array)
创建与给定数组具有相同长度的新 AtomicIntegerArray，并从给定数组复制其所有元素。
方法摘要
int | addAndGet(int i, int delta) 以原子方式将给定值与索引 i 的元素相加。
boolean | compareAndSet(int i, int expect, int update) 如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
int | decrementAndGet(int i) 以原子方式将索引 i 的元素减 1。
int | get(int i) 获取位置 i 的当前值。
int | getAndAdd(int i, int delta) 以原子方式将给定值与索引 i 的元素相加。
int | getAndDecrement(int i) 以原子方式将索引 i 的元素减 1。
int | getAndIncrement(int i) 以原子方式将索引 i 的元素加 1。
int | getAndSet(int i, int newValue) 将位置 i 的元素以原子方式设置为给定值，并返回旧值。
int | incrementAndGet(int i) 以原子方式将索引 i 的元素加 1。
void | lazySet(int i, int newValue) 最后将位置 i 的元素设置为给定值。
int | length() 返回该数组的长度。
void | set(int i, int newValue) 将位置 i 的元素设置为给定值。
String | toString() 返回数组当前值的字符串表示形式。
boolean | weakCompareAndSet(int i, int expect, int update) 如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AtomicIntegerArray

public AtomicIntegerArray(int length)
创建给定长度的新 AtomicIntegerArray。

参数：
length - 该数组的长度

AtomicIntegerArray

public AtomicIntegerArray(int[] array)
创建与给定数组具有相同长度的新 AtomicIntegerArray，并从给定数组复制其所有元素。

参数：
array - 从中复制元素的数组
抛出：
NullPointerException - 如果数组为 null
方法详细信息

length

public final int length()
返回该数组的长度。

返回：
该数组的长度

get

public final int get(int i)
获取位置 i 的当前值。

参数：
i - 索引
返回：
当前值

set

public final void set(int i,
                      int newValue)
将位置 i 的元素设置为给定值。

参数：
i - 索引
newValue - 新值

lazySet

public final void lazySet(int i,
                          int newValue)
最后将位置 i 的元素设置为给定值。

参数：
i - 索引
newValue - 新值
从以下版本开始：
1.6

getAndSet

public final int getAndSet(int i,
                           int newValue)
将位置 i 的元素以原子方式设置为给定值，并返回旧值。

参数：
i - 索引
newValue - 新值
返回：
以前的值

compareAndSet

public final boolean compareAndSet(int i,
                                   int expect,
                                   int update)
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。

参数：
i - 索引
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 false 指示实际值与预期值不相等。

weakCompareAndSet

public final boolean weakCompareAndSet(int i,
                                       int expect,
                                       int update)
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。

可能意外失败并且不提供排序保证，所以只是在很少的情况下才对 compareAndSet 进行适当地选择。

参数：
i - 索引
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

getAndIncrement

public final int getAndIncrement(int i)
以原子方式将索引 i 的元素加 1。

参数：
i - 索引
返回：
以前的值

getAndDecrement

public final int getAndDecrement(int i)
以原子方式将索引 i 的元素减 1。

参数：
i - 索引
返回：
以前的值

getAndAdd

public final int getAndAdd(int i,
                           int delta)
以原子方式将给定值与索引 i 的元素相加。

参数：
i - 索引
delta - 要加上的值
返回：
以前的值

incrementAndGet

public final int incrementAndGet(int i)
以原子方式将索引 i 的元素加 1。

参数：
i - 索引
返回：
更新的值

decrementAndGet

public final int decrementAndGet(int i)
以原子方式将索引 i 的元素减 1。

参数：
i - 索引
返回：
更新的值

addAndGet

public final int addAndGet(int i,
                           int delta)
以原子方式将给定值与索引 i 的元素相加。

参数：
i - 索引
delta - 要加上的值
返回：
更新的值

toString

public String toString()
返回数组当前值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
数组当前值的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicIntegerFieldUpdater (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicIntegerFieldUpdater<T>

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicIntegerFieldUpdater<T>
类型参数：
T - 保持可更新字段的对象类型。
public abstract class AtomicIntegerFieldUpdater<T>
extends Object

基于反射的实用工具，可以对指定类的指定 volatile int 字段进行原子更新。此类用于原子数据结构，该结构中同一节点的几个字段都独立受原子更新控制。

注意，此类中 compareAndSet 方法的保证弱于其他原子类中该方法的保证。因为此类不能确保所有使用的字段都适合于原子访问目的，所以对于相同更新器上的 compareAndSet 和 set 的其他调用，它仅可以保证原子性和可变语义。

从以下版本开始：
1.5

构造方法摘要
protected AtomicIntegerFieldUpdater()
受保护的无操作构造方法，供子类使用。
方法摘要
 int addAndGet(T obj, int delta)
以原子方式将给定值添加到此更新器管理的给定对象的字段当前值。
abstract  boolean compareAndSet(T obj, int expect, int update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。
 int decrementAndGet(T obj)
以原子方式将此更新器管理的给定对象的字段的当前值减 1。
abstract  int get(T obj)
获取此更新器管理的在给定对象的字段中保持的当前值。
 int getAndAdd(T obj, int delta)
以原子方式将给定值添加到此更新器管理的给定对象的当前值。
 int getAndDecrement(T obj)
以原子方式将此更新器管理的给定对象的当前值减 1。
 int getAndIncrement(T obj)
以原子方式将此更新器管理的给定对象的当前值加 1。
 int getAndSet(T obj, int newValue)
以原子方式将此更新器管理的给定对象的字段设置为给定值，并返回旧值。
 int incrementAndGet(T obj)
以原子方式将此更新器管理的给定对象的字段的当前值加 1。
abstract  void lazySet(T obj, int newValue)
最后将此更新器管理的给定对象的字段设置为给定更新值。
static
<U> AtomicIntegerFieldUpdater<U>
newUpdater(Class<U> tclass, String fieldName)
使用给定字段为对象创建和返回一个更新器。
abstract  void set(T obj, int newValue)
将此更新器管理的给定对象的字段设置为给定更新值。
abstract  boolean weakCompareAndSet(T obj, int expect, int update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AtomicIntegerFieldUpdater

protected AtomicIntegerFieldUpdater()
受保护的无操作构造方法，供子类使用。

方法详细信息

newUpdater

public static <U> AtomicIntegerFieldUpdater<U> newUpdater(Class<U> tclass,
                                                          String fieldName)
使用给定字段为对象创建和返回一个更新器。需要 Class 参数来检查反射类型和一般类型是否匹配。

参数：
tclass - 保持字段的对象类
fieldName - 要更新的字段名称
返回：
更新器
抛出：
IllegalArgumentException - 如果该字段不是可变的整数类型
RuntimeException - 如果该类不保持字段，或者是错误的类型，则抛出 RuntimeException 和一个嵌套的基于反射的异常

compareAndSet

public abstract boolean compareAndSet(T obj,
                                      int expect,
                                      int update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。对 compareAndSet 和 set 的其他调用，此方法可以确保原子性，但对于字段中的其他更改则不一定确保原子性。

参数：
obj - 有条件地设置其字段的对象
expect - 预期值
update - 新值
返回：
如果成功，则返回 true
抛出：
ClassCastException - 如果 obj 不是类的实例（该类处理在构造方法中建立的字段）

weakCompareAndSet

public abstract boolean weakCompareAndSet(T obj,
                                          int expect,
                                          int update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段值设置为给定的更新值。对 compareAndSet 和 set 的其他调用，此方法可以确保原子性，但对于字段中的其他更改则不一定确保原子性，并且可能会意外失败。

可能意外失败并且不提供排序保证，所以只有在很少的情况下才对 compareAndSet 进行适当地选择。

参数：
obj - 有条件地设置其字段的对象
expect - 预期值
update - 新值
返回：
如果成功，则返回 true
抛出：
ClassCastException - 如果 obj 不是类的实例（该类处理在构造方法中建立的字段）

set

public abstract void set(T obj,
                         int newValue)
将此更新器管理的给定对象的字段设置为给定更新值。对于 compareAndSet 的后续调用，此操作可以确保充当可变存储。

参数：
obj - 要设置其字段的对象
newValue - 新值

lazySet

public abstract void lazySet(T obj,
                             int newValue)
最后将此更新器管理的给定对象的字段设置为给定更新值。

参数：
obj - 要设置其字段的对象
newValue - 新值
从以下版本开始：
1.6

get

public abstract int get(T obj)
获取此更新器管理的在给定对象的字段中保持的当前值。

参数：
obj - 要获取其字段的对象
返回：
当前值

getAndSet

public int getAndSet(T obj,
                     int newValue)
以原子方式将此更新器管理的给定对象的字段设置为给定值，并返回旧值。

参数：
obj - 要获取并设置其字段的对象
newValue - 新值
返回：
以前的值

getAndIncrement

public int getAndIncrement(T obj)
以原子方式将此更新器管理的给定对象的当前值加 1。

参数：
obj - 要获取并设置其字段的对象
返回：
以前的值

getAndDecrement

public int getAndDecrement(T obj)
以原子方式将此更新器管理的给定对象的当前值减 1。

参数：
obj - 要获取并设置其字段的对象
返回：
以前的值

getAndAdd

public int getAndAdd(T obj,
                     int delta)
以原子方式将给定值添加到此更新器管理的给定对象的当前值。

参数：
obj - 要获取并设置其字段的对象
delta - 要加上的值
返回：
以前的值

incrementAndGet

public int incrementAndGet(T obj)
以原子方式将此更新器管理的给定对象的字段的当前值加 1。

参数：
obj - 要获取并设置其字段的对象
返回：
更新的值

decrementAndGet

public int decrementAndGet(T obj)
以原子方式将此更新器管理的给定对象的字段的当前值减 1。

参数：
obj - 要获取并设置其字段的对象
返回：
更新的值

addAndGet

public int addAndGet(T obj,
                     int delta)
以原子方式将给定值添加到此更新器管理的给定对象的字段当前值。

参数：
obj - 要获取并设置其字段的对象
delta - 要加上的值
返回：
更新的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicLong (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicLong

java.lang.Object
    继承者  java.lang.Number
        继承者  java.util.concurrent.atomic.AtomicLong
所有已实现的接口：
Serializable
public class AtomicLong
extends Number
implements Serializable

可以用原子方式更新的 long 值。有关原子变量属性的描述，请参阅 java.util.concurrent.atomic 包规范。AtomicLong 可用在应用程序中（如以原子方式增加的序列号），并且不能用于替换 Long。但是，此类确实扩展了 Number，允许那些处理基于数字类的工具和实用工具进行统一访问。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AtomicLong()
创建具有初始值 0 的新 AtomicLong。
AtomicLong(long initialValue)
创建具有给定初始值的新 AtomicLong。
方法摘要
long | addAndGet(long delta) 以原子方式将给定值添加到当前值。
boolean | compareAndSet(long expect, long update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
long | decrementAndGet() 以原子方式将当前值减 1。
double | doubleValue() 以 double 形式返回指定的数值。
float | floatValue() 以 float 形式返回指定的数值。
long | get() 获取当前值。
long | getAndAdd(long delta) 以原子方式将给定值添加到当前值。
long | getAndDecrement() 以原子方式将当前值减 1。
long | getAndIncrement() 以原子方式将当前值加 1。
long | getAndSet(long newValue) 以原子方式设置为给定值，并返回旧值。
long | incrementAndGet() 以原子方式将当前值加 1。
int | intValue() 以 int 形式返回指定的数值。
void | lazySet(long newValue) 最后设置为给定值。
long | longValue() 以 long 形式返回指定的数值。
void | set(long newValue) 设置为给定值。
String | toString() 返回当前值的字符串表示形式。
boolean | weakCompareAndSet(long expect, long update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
从类 java.lang.Number 继承的方法
byteValue, shortValue
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AtomicLong

public AtomicLong(long initialValue)
创建具有给定初始值的新 AtomicLong。

参数：
initialValue - 初始值

AtomicLong

public AtomicLong()
创建具有初始值 0 的新 AtomicLong。

方法详细信息

get

public final long get()
获取当前值。

返回：
当前值

set

public final void set(long newValue)
设置为给定值。

参数：
newValue - 新值

lazySet

public final void lazySet(long newValue)
最后设置为给定值。

参数：
newValue - 新值
从以下版本开始：
1.6

getAndSet

public final long getAndSet(long newValue)
以原子方式设置为给定值，并返回旧值。

参数：
newValue - 新值
返回：
以前的值

compareAndSet

public final boolean compareAndSet(long expect,
                                   long update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 false 指示实际值与预期值不相等。

weakCompareAndSet

public final boolean weakCompareAndSet(long expect,
                                       long update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

可能意外失败并且不提供排序保证，所以只能在很少的情况下对 compareAndSet 进行适当地选择。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

getAndIncrement

public final long getAndIncrement()
以原子方式将当前值加 1。

返回：
以前的值

getAndDecrement

public final long getAndDecrement()
以原子方式将当前值减 1。

返回：
以前的值

getAndAdd

public final long getAndAdd(long delta)
以原子方式将给定值添加到当前值。

参数：
delta - 要添加的值
返回：
以前的值

incrementAndGet

public final long incrementAndGet()
以原子方式将当前值加 1。

返回：
更新的值

decrementAndGet

public final long decrementAndGet()
以原子方式将当前值减 1。

返回：
更新的值

addAndGet

public final long addAndGet(long delta)
以原子方式将给定值添加到当前值。

参数：
delta - 要添加的值
返回：
更新的值

toString

public String toString()
返回当前值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
当前值的字符串表示形式。

intValue

public int intValue()
从类 Number 复制的描述
以 int 形式返回指定的数值。这可能会涉及到舍入或取整。

指定者：
类 Number 中的 intValue
返回：
转换为 int 类型后该对象表示的数值。

longValue

public long longValue()
从类 Number 复制的描述
以 long 形式返回指定的数值。这可能涉及到舍入或取整。

指定者：
类 Number 中的 longValue
返回：
转换为 long 类型后该对象表示的数值。

floatValue

public float floatValue()
从类 Number 复制的描述
以 float 形式返回指定的数值。这可能会涉及到舍入。

指定者：
类 Number 中的 floatValue
返回：
转换为 float 类型后该对象表示的数值。

doubleValue

public double doubleValue()
从类 Number 复制的描述
以 double 形式返回指定的数值。这可能会涉及到舍入。

指定者：
类 Number 中的 doubleValue
返回：
转换为 double 类型后该对象表示的数值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicLongArray (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicLongArray

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicLongArray
所有已实现的接口：
Serializable
public class AtomicLongArray
extends Object
implements Serializable

可以用原子方式更新其元素的 long 数组。有关原子变量属性的描述，请参阅 java.util.concurrent.atomic 包规范。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AtomicLongArray(int length)
创建给定长度的新 AtomicLongArray。
AtomicLongArray(long[] array)
创建与给定数组具有相同长度的新 AtomicLongArray，并从给定数组复制其所有元素。
方法摘要
long | addAndGet(int i, long delta) 以原子方式将给定值添加到索引 i 的元素。
boolean | compareAndSet(int i, long expect, long update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
long | decrementAndGet(int i) 以原子方式将索引 i 的元素减1。
long | get(int i) 获取位置 i 的当前值。
long | getAndAdd(int i, long delta) 以原子方式将给定值与索引 i 的元素相加。
long | getAndDecrement(int i) 以原子方式将索引 i 的元素减 1。
long | getAndIncrement(int i) 以原子方式将索引 i 的元素加 1。
long | getAndSet(int i, long newValue) 以原子方式将位置 i 的元素设置为给定值，并返回旧值。
long | incrementAndGet(int i) 以原子方式将索引 i 的元素加1。
void | lazySet(int i, long newValue) 最终将位置 i 的元素设置为给定值。
int | length() 返回该数组的长度。
void | set(int i, long newValue) 将位置 i 的元素设置为给定值。
String | toString() 返回数组当前值的字符串表示形式。
boolean | weakCompareAndSet(int i, long expect, long update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AtomicLongArray

public AtomicLongArray(int length)
创建给定长度的新 AtomicLongArray。

参数：
length - 该数组的长度

AtomicLongArray

public AtomicLongArray(long[] array)
创建与给定数组具有相同长度的新 AtomicLongArray，并从给定数组复制其所有元素。

参数：
array - 从中复制元素的数组
抛出：
NullPointerException - 如果数组为 null
方法详细信息

length

public final int length()
返回该数组的长度。

返回：
该数组的长度

get

public final long get(int i)
获取位置 i 的当前值。

参数：
i - 索引
返回：
当前值

set

public final void set(int i,
                      long newValue)
将位置 i 的元素设置为给定值。

参数：
i - 索引
newValue - 新值

lazySet

public final void lazySet(int i,
                          long newValue)
最终将位置 i 的元素设置为给定值。

参数：
i - 索引
newValue - 新值
从以下版本开始：
1.6

getAndSet

public final long getAndSet(int i,
                            long newValue)
以原子方式将位置 i 的元素设置为给定值，并返回旧值。

参数：
i - 索引
newValue - 新值
返回：
以前的值

compareAndSet

public final boolean compareAndSet(int i,
                                   long expect,
                                   long update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

参数：
i - 索引
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 false 指示实际值与预期值不相等。

weakCompareAndSet

public final boolean weakCompareAndSet(int i,
                                       long expect,
                                       long update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

可能意外失败并且不提供排序保证，所以只能在很少的情况下对 compareAndSet 进行适当地选择。

参数：
i - 索引
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

getAndIncrement

public final long getAndIncrement(int i)
以原子方式将索引 i 的元素加 1。

参数：
i - 索引
返回：
以前的值

getAndDecrement

public final long getAndDecrement(int i)
以原子方式将索引 i 的元素减 1。

参数：
i - 索引
返回：
以前的值

getAndAdd

public final long getAndAdd(int i,
                            long delta)
以原子方式将给定值与索引 i 的元素相加。

参数：
i - 索引
delta - 要加上的值
返回：
以前的值

incrementAndGet

public final long incrementAndGet(int i)
以原子方式将索引 i 的元素加1。

参数：
i - 索引
返回：
更新的值

decrementAndGet

public final long decrementAndGet(int i)
以原子方式将索引 i 的元素减1。

参数：
i - 索引
返回：
更新的值

addAndGet

public long addAndGet(int i,
                      long delta)
以原子方式将给定值添加到索引 i 的元素。

参数：
i - 索引
delta - 要添加的值
返回：
更新的值

toString

public String toString()
返回数组当前值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
数组当前值的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicLongFieldUpdater (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicLongFieldUpdater<T>

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicLongFieldUpdater<T>
类型参数：
T - 保持可更新字段的对象类型
public abstract class AtomicLongFieldUpdater<T>
extends Object

基于反射的实用工具，可以对指定类的指定 volatile long 字段进行原子更新。此类用于原子数据结构，该结构中同一节点的几个字段都独立受原子更新控制。

注意，此类中 compareAndSet 方法的保证弱于其他原子类中该方法的保证。因为此类不能确保所有使用的字段都适合于原子访问目的，所以对于 compareAndSet 和 set 的其他调用，它仅可以保证原子性和可变语义。

从以下版本开始：
1.5

构造方法摘要
protected AtomicLongFieldUpdater()
受保护的无操作构造方法，供子类使用。
方法摘要
 long addAndGet(T obj, long delta)
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。
abstract  boolean compareAndSet(T obj, long expect, long update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。
 long decrementAndGet(T obj)
以原子方式将此更新器管理的给定对象字段当前值减 1。
abstract  long get(T obj)
获取此更新器管理的在给定对象的字段中保持的当前值。
 long getAndAdd(T obj, long delta)
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。
 long getAndDecrement(T obj)
以原子方式将此更新器管理的给定对象字段当前值减 1。
 long getAndIncrement(T obj)
以原子方式将此更新器管理的给定对象字段的当前值加 1。
 long getAndSet(T obj, long newValue)
将此更新器管理的给定对象的字段以原子方式设置为给定值，并返回旧值。
 long incrementAndGet(T obj)
以原子方式将此更新器管理的给定对象字段当前值加 1。
abstract  void lazySet(T obj, long newValue)
最后将此更新器管理的给定对象的字段设置为给定更新值。
static
<U> AtomicLongFieldUpdater<U>
newUpdater(Class<U> tclass, String fieldName)
为对象创建并返回一个具有给定字段的更新器。
abstract  void set(T obj, long newValue)
将此更新器管理的给定对象的字段设置为给定更新值。
abstract  boolean weakCompareAndSet(T obj, long expect, long update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AtomicLongFieldUpdater

protected AtomicLongFieldUpdater()
受保护的无操作构造方法，供子类使用。

方法详细信息

newUpdater

public static <U> AtomicLongFieldUpdater<U> newUpdater(Class<U> tclass,
                                                       String fieldName)
为对象创建并返回一个具有给定字段的更新器。需要 Class 参数检查反射类型和一般类型是否匹配。

参数：
tclass - 保持字段的对象类
fieldName - 要更新的字段名称
返回：
更新器
抛出：
IllegalArgumentException - 如果该字段不是可变的 long 类型
RuntimeException - 如果该类不保持字段，或者是错误的类型，将抛出 RuntimeException 和一个嵌套的基于反射的异常。

compareAndSet

public abstract boolean compareAndSet(T obj,
                                      long expect,
                                      long update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。对 compareAndSet 和 set 的其他调用，此方法可以确保原子性，但对于字段中的其他更改则不一定确保原子性。

参数：
obj - 有条件地设置其字段的对象
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。
抛出：
ClassCastException - 如果 obj 不是类的实例（该类处理在构造方法中建立的字段）。

weakCompareAndSet

public abstract boolean weakCompareAndSet(T obj,
                                          long expect,
                                          long update)
如果当前值 == 预期值，则以原子方式将此更新器所管理的给定对象的字段设置为给定的更新值。对 compareAndSet 和 set 的其他调用，此方法可以确保原子性，但对于字段中的其他更改则不一定确保原子性。

可能意外失败并且不提供排序保证，所以只有在很少的情况下才对 compareAndSet 进行适当地选择。

参数：
obj - 有条件地设置其字段的对象
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。
抛出：
ClassCastException - 如果 obj 不是类的实例（该类处理在构造方法中建立的字段）。

set

public abstract void set(T obj,
                         long newValue)
将此更新器管理的给定对象的字段设置为给定更新值。对于 compareAndSet 的后续调用，此操作可以确保充当可变存储。

参数：
obj - 要设置其字段的对象
newValue - 新值

lazySet

public abstract void lazySet(T obj,
                             long newValue)
最后将此更新器管理的给定对象的字段设置为给定更新值。

参数：
obj - 要设置其字段的对象
newValue - 新值
从以下版本开始：
1.6

get

public abstract long get(T obj)
获取此更新器管理的在给定对象的字段中保持的当前值。

参数：
obj - 要获取其字段的对象
返回：
当前值

getAndSet

public long getAndSet(T obj,
                      long newValue)
将此更新器管理的给定对象的字段以原子方式设置为给定值，并返回旧值。

参数：
obj - 要获取并设置其字段的对象
newValue - 新值
返回：
以前的值

getAndIncrement

public long getAndIncrement(T obj)
以原子方式将此更新器管理的给定对象字段的当前值加 1。

参数：
obj - 要获取并设置其字段的对象
返回：
以前的值

getAndDecrement

public long getAndDecrement(T obj)
以原子方式将此更新器管理的给定对象字段当前值减 1。

参数：
obj - 要获取并设置其字段的对象
返回：
以前的值

getAndAdd

public long getAndAdd(T obj,
                      long delta)
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。

参数：
obj - 要获取并设置其字段的对象
delta - 要添加的值
返回：
以前的值

incrementAndGet

public long incrementAndGet(T obj)
以原子方式将此更新器管理的给定对象字段当前值加 1。

参数：
obj - 要获取并设置其字段的对象
返回：
更新的值

decrementAndGet

public long decrementAndGet(T obj)
以原子方式将此更新器管理的给定对象字段当前值减 1。

参数：
obj - 要获取并设置其字段的对象
返回：
更新的值

addAndGet

public long addAndGet(T obj,
                      long delta)
以原子方式将给定值添加到此更新器管理的给定对象的字段的当前值。

参数：
obj - 要获取并设置其字段的对象
delta - 要添加的值
返回：
更新的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicMarkableReference (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicMarkableReference<V>

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicMarkableReference<V>
类型参数：
V - 此引用所引用的对象类型
public class AtomicMarkableReference<V>
extends Object

AtomicMarkableReference 维护带有标记位的对象引用，可以原子方式对其进行更新。

实现注意事项。通过创建表示“已装箱”的 [reference, boolean] 对的内部对象，此实现维持可标记的引用。

从以下版本开始：
1.5

构造方法摘要
AtomicMarkableReference(V initialRef, boolean initialMark)
创建具有给定初始值的新 AtomicMarkableReference。
方法摘要
boolean | attemptMark(V expectedReference, boolean newMark) 如果当前引用 == 预期引用，则以原子方式将该标记的值设置为给定的更新值。
boolean | compareAndSet(V expectedReference, V newReference, boolean expectedMark, boolean newMark) 如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。
V | get(boolean[] markHolder) 返回该引用和该标记的当前值。
V | getReference() 返回该引用的当前值。
boolean | isMarked() 返回该标记的当前值。
void | set(V newReference, boolean newMark) 无条件地同时设置该引用和标记的值。
boolean | weakCompareAndSet(V expectedReference, V newReference, boolean expectedMark, boolean newMark) 如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AtomicMarkableReference

public AtomicMarkableReference(V initialRef,
                               boolean initialMark)
创建具有给定初始值的新 AtomicMarkableReference。

参数：
initialRef - 初始引用
initialMark - 初始标记
方法详细信息

getReference

public V getReference()
返回该引用的当前值。

返回：
该引用的当前值

isMarked

public boolean isMarked()
返回该标记的当前值。

返回：
该标记的当前值

get

public V get(boolean[] markHolder)
返回该引用和该标记的当前值。典型的用法为 boolean[1] holder; ref = v.get(holder); 。

参数：
markHolder - 大小至少为 1 的数组。返回时，markholder[0] 将保存该标记的值。
返回：
该引用的当前值

weakCompareAndSet

public boolean weakCompareAndSet(V expectedReference,
                                 V newReference,
                                 boolean expectedMark,
                                 boolean newMark)
如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。

可能意外失败并且不提供排序保证，所以只有在很少的情况下才对 compareAndSet 进行适当地选择。

参数：
expectedReference - 该引用的预期值
newReference - 该引用的新值
expectedMark - 该标记的预期值
newMark - 该标记的新值
返回：
如果成功，则返回 true

compareAndSet

public boolean compareAndSet(V expectedReference,
                             V newReference,
                             boolean expectedMark,
                             boolean newMark)
如果当前引用 == 预期引用，并且当前标记等于预期标记，那么以原子方式将引用和标记的值设置为给定的更新值。

参数：
expectedReference - 该引用的预期值
newReference - 该引用的新值
expectedMark - 该标记的预期值
newMark - 该标记的新值
返回：
如果成功，则返回 true

set

public void set(V newReference,
                boolean newMark)
无条件地同时设置该引用和标记的值。

参数：
newReference - 该引用的新值
newMark - 该标记的新值

attemptMark

public boolean attemptMark(V expectedReference,
                           boolean newMark)
如果当前引用 == 预期引用，则以原子方式将该标记的值设置为给定的更新值。此操作的任何给定调用都可能会意外失败（返回 false），但是在当前值保持预期值而且没有其他线程也在尝试设置该值时，重复调用将最终获得成功。

参数：
expectedReference - 该引用的预期值
newMark - 该标记的新值
返回：
如果成功，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicReference (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicReference<V>

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicReference<V>
类型参数：
V - 此引用所引用的对象类型。
所有已实现的接口：
Serializable
public class AtomicReference<V>
extends Object
implements Serializable

可以用原子方式更新的对象引用。有关原子变量属性的描述，请参阅 java.util.concurrent.atomic 包规范。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AtomicReference()
使用 null 初始值创建新的 AtomicReference。
AtomicReference(V initialValue)
使用给定的初始值创建新的 AtomicReference。
方法摘要
boolean | compareAndSet(V expect, V update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
V | get() 获取当前值。
V | getAndSet(V newValue) 以原子方式设置为给定值，并返回旧值。
void | lazySet(V newValue) 最终设置为给定值。
void | set(V newValue) 设置为给定值。
String | toString() 返回当前值的字符串表示形式。
boolean | weakCompareAndSet(V expect, V update) 如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AtomicReference

public AtomicReference(V initialValue)
使用给定的初始值创建新的 AtomicReference。

参数：
initialValue - 初始值

AtomicReference

public AtomicReference()
使用 null 初始值创建新的 AtomicReference。

方法详细信息

get

public final V get()
获取当前值。

返回：
当前值

set

public final void set(V newValue)
设置为给定值。

参数：
newValue - 新值

lazySet

public final void lazySet(V newValue)
最终设置为给定值。

参数：
newValue - 新值
从以下版本开始：
1.6

compareAndSet

public final boolean compareAndSet(V expect,
                                   V update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 false 指示实际值与预期值不相等。

weakCompareAndSet

public final boolean weakCompareAndSet(V expect,
                                       V update)
如果当前值 == 预期值，则以原子方式将该值设置为给定的更新值。

可能意外失败并且不提供排序保证，因此几乎只是 compareAndSet 的适当替代方法。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

getAndSet

public final V getAndSet(V newValue)
以原子方式设置为给定值，并返回旧值。

参数：
newValue - 新值
返回：
以前的值

toString

public String toString()
返回当前值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
当前值的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicReferenceArray (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicReferenceArray<E>

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicReferenceArray<E>
类型参数：
E - 此数组中所保持元素的基类
所有已实现的接口：
Serializable
public class AtomicReferenceArray<E>
extends Object
implements Serializable

可以用原子方式更新其元素的对象引用数组。有关原子变量属性的描述，请参阅 java.util.concurrent.atomic 包规范。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AtomicReferenceArray(E[] array)
创建与给定数组具有相同长度的新 AtomicReferenceArray，并从给定数组复制其所有元素。
AtomicReferenceArray(int length)
创建给定长度的新 AtomicReferenceArray。
方法摘要
boolean | compareAndSet(int i, E expect, E update) 如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
E | get(int i) 获取位置 i 的当前值。
E | getAndSet(int i, E newValue) 以原子方式将位置 i 的元素设置为给定值，并返回旧值。
void | lazySet(int i, E newValue) 最终将位置 i 的元素设置为给定值。
int | length() 返回该数组的长度。
void | set(int i, E newValue) 将位置 i 的元素设置为给定值。
String | toString() 返回数组当前值的字符串表示形式。
boolean | weakCompareAndSet(int i, E expect, E update) 如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AtomicReferenceArray

public AtomicReferenceArray(int length)
创建给定长度的新 AtomicReferenceArray。

参数：
length - 该数组的长度

AtomicReferenceArray

public AtomicReferenceArray(E[] array)
创建与给定数组具有相同长度的新 AtomicReferenceArray，并从给定数组复制其所有元素。

参数：
array - 从中复制元素的数组
抛出：
NullPointerException - 如果数组为 null
方法详细信息

length

public final int length()
返回该数组的长度。

返回：
该数组的长度

get

public final E get(int i)
获取位置 i 的当前值。

参数：
i - 索引
返回：
当前值

set

public final void set(int i,
                      E newValue)
将位置 i 的元素设置为给定值。

参数：
i - 索引
newValue - 新值

lazySet

public final void lazySet(int i,
                          E newValue)
最终将位置 i 的元素设置为给定值。

参数：
i - 索引
newValue - 新值
从以下版本开始：
1.6

getAndSet

public final E getAndSet(int i,
                         E newValue)
以原子方式将位置 i 的元素设置为给定值，并返回旧值。

参数：
i - 索引
newValue - 新值
返回：
以前的值

compareAndSet

public final boolean compareAndSet(int i,
                                   E expect,
                                   E update)
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。

参数：
i - 索引
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 false 表示实际值与预期值不相等。

weakCompareAndSet

public final boolean weakCompareAndSet(int i,
                                       E expect,
                                       E update)
如果当前值 == 预期值，则以原子方式将位置 i 的元素设置为给定的更新值。

可能意外失败并且不提供排序保证，因此几乎只是 compareAndSet 的适当替换方法。

参数：
i - 索引
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

toString

public String toString()
返回数组当前值的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
数组当前值的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicReferenceFieldUpdater (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicReferenceFieldUpdater<T,V>

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicReferenceFieldUpdater<T,V>
类型参数：
T - 保持可更新字段的对象的类型
V - 字段的类型
public abstract class AtomicReferenceFieldUpdater<T,V>
extends Object

基于反射的实用工具，可以对指定类的指定 volatile 字段进行原子更新。该类用于原子数据结构，该结构中同一节点的几个引用字段都独立受原子更新控制。例如，树节点可能声明为

 class Node {
   private volatile Node left, right;

   private static final AtomicReferenceFieldUpdater leftUpdater =
     AtomicReferenceFieldUpdater.newUpdater(Node.class, Node.class, "left");
   private static AtomicReferenceFieldUpdater rightUpdater =
     AtomicReferenceFieldUpdater.newUpdater(Node.class, Node.class, "right");

   Node getLeft() { return left;  }
   boolean compareAndSetLeft(Node expect, Node update) {
     return leftUpdater.compareAndSet(this, expect, update);
   }
   // ... and so on
 }

注意，此类中 compareAndSet 方法的保证弱于其他原子类中该方法的保证。因为此类不能确保所有使用的字段都适合于原子访问目的，所以，对于 compareAndSet 和 set 的其他调用，它仅可以保证原子性和可变语义。

从以下版本开始：
1.5

构造方法摘要
protected AtomicReferenceFieldUpdater()
受保护的无操作构造方法，供子类使用。
方法摘要
abstract  boolean compareAndSet(T obj, V expect, V update)
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。
abstract  V get(T obj)
获取由此更新器管理的在给定对象的字段中保持的当前值。
 V getAndSet(T obj, V newValue)
将此更新器管理的给定对象的字段自动设置为给定值，并返回旧值。
abstract  void lazySet(T obj, V newValue)
最终将此更新器管理的给定对象的字段设置为给定更新值。
static
<U,W> AtomicReferenceFieldUpdater<U,W>
newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。
abstract  void set(T obj, V newValue)
将此更新器管理的给定对象的字段设置为给定更新值。
abstract  boolean weakCompareAndSet(T obj, V expect, V update)
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AtomicReferenceFieldUpdater

protected AtomicReferenceFieldUpdater()
受保护的无操作构造方法，供子类使用。

方法详细信息

newUpdater

public static <U,W> AtomicReferenceFieldUpdater<U,W> newUpdater(Class<U> tclass,
                                                                Class<W> vclass,
                                                                String fieldName)
使用给定的字段为对象创建和返回一个更新器。需要 Class 参数检查反射类型和一般类型是否匹配。

参数：
tclass - 保持字段的对象类。
vclass - 该字段的类
fieldName - 要更新的字段名称。
返回：
更新器
抛出：
IllegalArgumentException - 如果该字段不是可变引用类型。
RuntimeException - 如果该类不保持字段，或者是错误的类型，将抛出 RuntimeException 和一个嵌套的基于反射的异常。

compareAndSet

public abstract boolean compareAndSet(T obj,
                                      V expect,
                                      V update)
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。对 compareAndSet 和 set 的其他调用，此方法可以确保原子性，但对于字段中的其他更改则不一定确保原子性。

参数：
obj - 有条件地设置其字段的对象
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

weakCompareAndSet

public abstract boolean weakCompareAndSet(T obj,
                                          V expect,
                                          V update)
如果当前值 == 预期值，则以原子方式将此更新器管理的给定对象的字段设置为给定的更新值。对 compareAndSet 和 set 的其他调用，此方法可以确保原子性，但对于字段中的其他更改则不一定确保原子性。

可能意外失败并且不提供排序保证，所以只有在很少的情况下才对 compareAndSet 进行适当地选择。

参数：
obj - 有条件地设置其字段的对象
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。

set

public abstract void set(T obj,
                         V newValue)
将此更新器管理的给定对象的字段设置为给定更新值。对于 compareAndSet 的后续调用，此操作可以确保充当可变存储。

参数：
obj - 要设置其字段的对象
newValue - 新值

lazySet

public abstract void lazySet(T obj,
                             V newValue)
最终将此更新器管理的给定对象的字段设置为给定更新值。

参数：
obj - 要设置其字段的对象
newValue - 新值
从以下版本开始：
1.6

get

public abstract V get(T obj)
获取由此更新器管理的在给定对象的字段中保持的当前值。

参数：
obj - 要获取其字段的对象
返回：
当前值

getAndSet

public V getAndSet(T obj,
                   V newValue)
将此更新器管理的给定对象的字段自动设置为给定值，并返回旧值。

参数：
obj - 要获取并设置其字段的对象
newValue - 新值
返回：
以前的值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AtomicStampedReference (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.atomic
类 AtomicStampedReference<V>

java.lang.Object
    继承者  java.util.concurrent.atomic.AtomicStampedReference<V>
类型参数：
V - 此引用所引用的对象类型
public class AtomicStampedReference<V>
extends Object

AtomicStampedReference 维护带有整数“标志”的对象引用，可以用原子方式对其进行更新。

实现注意事项。通过创建表示“已装箱”的 [reference, integer] 对的内部对象，此实现维持带标志的引用。

从以下版本开始：
1.5

构造方法摘要
AtomicStampedReference(V initialRef, int initialStamp)
创建具有给定初始值的新 AtomicStampedReference。
方法摘要
boolean | attemptStamp(V expectedReference, int newStamp) 如果当前引用 == 预期引用，则以原子方式将该标志的值设置为给定的更新值。
boolean | compareAndSet(V expectedReference, V newReference, int expectedStamp, int newStamp) 如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。
V | get(int[] stampHolder) 返回该引用和该标志的当前值。
V | getReference() 返回该引用的当前值。
int | getStamp() 返回该标志的当前值。
void | set(V newReference, int newStamp) 无条件地同时设置该引用和标志的值。
boolean | weakCompareAndSet(V expectedReference, V newReference, int expectedStamp, int newStamp) 如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AtomicStampedReference

public AtomicStampedReference(V initialRef,
                              int initialStamp)
创建具有给定初始值的新 AtomicStampedReference。

参数：
initialRef - 初始引用
initialStamp - 初始标志
方法详细信息

getReference

public V getReference()
返回该引用的当前值。

返回：
该引用的当前值

getStamp

public int getStamp()
返回该标志的当前值。

返回：
该标志的当前值

get

public V get(int[] stampHolder)
返回该引用和该标志的当前值。典型的用法为 int[1] holder; ref = v.get(holder); 。

参数：
stampHolder - 大小至少为 1 的数组。返回时，stampholder[0] 将保存该标志的值。
返回：
该引用的当前值

weakCompareAndSet

public boolean weakCompareAndSet(V expectedReference,
                                 V newReference,
                                 int expectedStamp,
                                 int newStamp)
如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。

可能意外失败并且不提供排序保证，所以只有在很少的情况下才对 compareAndSet 进行适当的选择。

参数：
expectedReference - 该引用的预期值
newReference - 该引用的新值
expectedStamp - 该标志的预期值
newStamp - 该标志的新值
返回：
如果成功，则返回 true

compareAndSet

public boolean compareAndSet(V expectedReference,
                             V newReference,
                             int expectedStamp,
                             int newStamp)
如果当前引用 == 预期引用，并且当前标志等于预期标志，则以原子方式将该引用和该标志的值设置为给定的更新值。

参数：
expectedReference - 该引用的预期值
newReference - 该引用的新值
expectedStamp - 该标志的预期值
newStamp - 该标志的新值
返回：
如果成功，则返回 true

set

public void set(V newReference,
                int newStamp)
无条件地同时设置该引用和标志的值。

参数：
newReference - 该引用的新值
newStamp - 该标志的新值

attemptStamp

public boolean attemptStamp(V expectedReference,
                            int newStamp)
如果当前引用 == 预期引用，则以原子方式将该标志的值设置为给定的更新值。此操作的任何给定调用都可能会意外失败（返回 false），但是在当前值保持预期值而且没有其他线程也在尝试设置该值时，重复调用将最终获得成功。

参数：
expectedReference - 该引用的预期值
newStamp - 该标志的新值
返回：
如果成功，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.concurrent.atomic (Java 2 Platform SE 6)

 java.util.concurrent.atomic
类
AtomicBoolean
AtomicInteger
AtomicIntegerArray
AtomicIntegerFieldUpdater
AtomicLong
AtomicLongArray
AtomicLongFieldUpdater
AtomicMarkableReference
AtomicReference
AtomicReferenceArray
AtomicReferenceFieldUpdater
AtomicStampedReference


java.util.concurrent.atomic (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.concurrent.atomic

类的小工具包，支持在单个变量上解除锁的线程安全编程。

请参见：
描述

类摘要
AtomicBoolean | 可以用原子方式更新的 boolean 值。
AtomicInteger | 可以用原子方式更新的 int 值。
AtomicIntegerArray | 可以用原子方式更新其元素的 int 数组。
AtomicIntegerFieldUpdater<T> | 基于反射的实用工具，可以对指定类的指定 volatile int 字段进行原子更新。
AtomicLong | 可以用原子方式更新的 long 值。
AtomicLongArray | 可以用原子方式更新其元素的 long 数组。
AtomicLongFieldUpdater<T> | 基于反射的实用工具，可以对指定类的指定 volatile long 字段进行原子更新。
AtomicMarkableReference<V> | AtomicMarkableReference 维护带有标记位的对象引用，可以原子方式对其进行更新。
AtomicReference<V> | 可以用原子方式更新的对象引用。
AtomicReferenceArray<E> | 可以用原子方式更新其元素的对象引用数组。
AtomicReferenceFieldUpdater<T,V> | 基于反射的实用工具，可以对指定类的指定 volatile 字段进行原子更新。
AtomicStampedReference<V> | AtomicStampedReference 维护带有整数“标志”的对象引用，可以用原子方式对其进行更新。

软件包 java.util.concurrent.atomic 的描述

类的小工具包，支持在单个变量上解除锁的线程安全编程。事实上，此包中的类可将 volatile 值、字段和数组元素的概念扩展到那些也提供原子条件更新操作的类，其形式如下：

  boolean compareAndSet(expectedValue, updateValue);

如果此方法（在不同的类间参数类型也不同）当前保持 expectedValue，则以原子方式将变量设置为 updateValue，并在成功时报告 true。此包中的类还包含获取并无条件设置值的方法，以及以下描述的较弱条件的原子更新操作 weakCompareAndSet。

这些方法的规范使实现能够使用当代处理器上提供的高效机器级别原子指令。但是在某些平台上，该支持可能需要某种形式的内部锁。因而，该方法不能严格保证不被阻塞 - 执行操作之前可能暂时阻塞线程。

类 AtomicBoolean、AtomicInteger、AtomicLong 和 AtomicReference 的实例各自提供对相应类型单个变量的访问和更新。每个类也为该类型提供适当的实用工具方法。例如，类 AtomicLong 和 AtomicInteger 提供了原子增量方法。一个应用程序将按以下方式生成序列号：

class Sequencer {
  private final AtomicLong sequenceNumber
    = new AtomicLong(0);
  public long next() {
    return sequenceNumber.getAndIncrement();
  }
}

原子访问和更新的内存效果一般遵循以下可变规则，正如 The Java Language Specification, Third Edition (17.4 Memory Model) 中的声明：

  • get 具有读取 volatile 变量的内存效果。
  • set 具有写入（分配）volatile 变量的内存效果。
  • 除了允许使用后续（但不是以前的）内存操作，其自身不施加带有普通的非 volatile 写入的重新排序约束，lazySet 具有写入（分配）volatile 变量的内存效果。在其他使用上下文中，当为 null 时（为了垃圾回收），lazySet 可以应用不会再次访问的引用。
  • weakCompareAndSet 以原子方式读取和有条件地写入变量但不 创建任何 happen-before 排序，因此不提供与除 weakCompareAndSet 目标外任何变量以前或后续读取或写入操作有关的任何保证。
  • compareAndSet 和所有其他的读取和更新操作（如 getAndIncrement）都有读取和写入 volatile 变量的内存效果。

除了包含表示单个值的类之外，此包还包含 Updater 类，该类可用于获取任意选定类的任意选定 volatile 字段上的 compareAndSet 操作。AtomicReferenceFieldUpdater、AtomicIntegerFieldUpdater 和 AtomicLongFieldUpdater 是基于反射的实用工具，可以提供对关联字段类型的访问。它们主要用于原子数据结构中，该结构中同一节点（例如，树节点的链接）的几个 volatile 字段都独立受原子更新控制。这些类在如何以及何时使用原子更新方面具有更大的灵活性，但相应的弊端是基于映射的设置较为拙笨、使用不太方便，而且在保证方面也较差。

AtomicIntegerArray、AtomicLongArray 和 AtomicReferenceArray 类进一步扩展了原子操作，对这些类型的数组提供了支持。这些类在为其数组元素提供 volatile 访问语义方面也引人注目，这对于普通数组来说是不受支持的。

原子类也支持 weakCompareAndSet 方法，该方法具有受限制的适用性。在某些平台上，弱版本在正常情况下可能比 compareAndSet 更有效，但不同的是 weakCompareAndSet 方法的任何给定调用可能意外 返回 false（即没有明确的原因）。返回 false 仅意味着可以在需要时重新尝试操作，具体取决于重复执行调用的保证，当该变量保持 expectedValue 并且没有其他线程也在尝试设置该变量时，最终将获得成功。（例如，这样的虚假失败可能是由于内存争用的结果，该争用与期望值和当前值是否相等无关）。 此外，weakCompareAndSet 不提供通常需要同步控制的排序保证。但是，在这样的更新与程序的其他 happen-before 排序不相关时，该方法可用于更新计数器和统计数据。当一个线程看到对 weakCompareAndSet 导致的原子变量的更新时，它不一定能看到在 weakCompareAndSet 之前发生的对任何其他 变量的更新。例如，在更新性能统计数据时，这也许可以接受，但其他情况几乎不可以。

AtomicMarkableReference 类将单个布尔值与引用关联起来。例如，可以在数据结构内部使用此位，这意味着引用的对象在逻辑上已被删除。AtomicStampedReference 类将整数值与引用关联起来。例如，这可用于表示与更新系列对应的版本号。

设计原子类主要用作各种构造块，用于实现非阻塞数据结构和相关的基础结构类。compareAndSet 方法不是锁的常规替换方法。仅当对象的重要更新限定于单个 变量时才应用它。

原子类不是 java.lang.Integer 和相关类的通用替换方法。它们不 定义诸如 hashCode 和 compareTo 之类的方法。（因为原子变量是可变的，所以对于哈希表键来说，它们不是好的选择。）另外，仅为那些通常在预期应用程序中使用的类型提供类。例如，没有表示 byte 的原子类。这种情况不常见，如果要这样做，可以使用 AtomicInteger 来保持 byte 值，并进行适当的强制转换。也可以使用 Float.floatToIntBits 和 Float.intBitstoFloat 转换来保持 float 值，使用 Double.doubleToLongBits 和 Double.longBitsToDouble 转换来保持 double 值。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.concurrent.atomic 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.concurrent.atomic 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.concurrent.atomic.AtomicBoolean (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicIntegerFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicLongArray (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicLongFieldUpdater<T>
    • java.util.concurrent.atomic.AtomicMarkableReference<V>
    • java.util.concurrent.atomic.AtomicReference<V> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceArray<E> (implements java.io.Serializable)
    • java.util.concurrent.atomic.AtomicReferenceFieldUpdater<T,V>
    • java.util.concurrent.atomic.AtomicStampedReference<V>
    • java.lang.Number (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicInteger (implements java.io.Serializable)
      • java.util.concurrent.atomic.AtomicLong (implements java.io.Serializable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.concurrent.atomic 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.concurrent.atomic
的使用

使用 java.util.concurrent.atomic 的软件包
java.util.concurrent.atomic 类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.atomic 使用的 java.util.concurrent.atomic 中的类
AtomicIntegerFieldUpdater
基于反射的实用工具，可以对指定类的指定 volatile int 字段进行原子更新。
AtomicLongFieldUpdater
基于反射的实用工具，可以对指定类的指定 volatile long 字段进行原子更新。
AtomicReferenceFieldUpdater
基于反射的实用工具，可以对指定类的指定 volatile 字段进行原子更新。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicIntegerArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicIntegerArray
的使用

没有 java.util.concurrent.atomic.AtomicIntegerArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicIntegerFieldUpdater
的使用

使用 AtomicIntegerFieldUpdater 的软件包
java.util.concurrent.atomic 类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.atomic 中 AtomicIntegerFieldUpdater 的使用

返回 AtomicIntegerFieldUpdater 的 java.util.concurrent.atomic 中的方法
static
<U> AtomicIntegerFieldUpdater<U>
AtomicIntegerFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
使用给定字段为对象创建和返回一个更新器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicLongArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicLongArray
的使用

没有 java.util.concurrent.atomic.AtomicLongArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicLongFieldUpdater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicLongFieldUpdater
的使用

使用 AtomicLongFieldUpdater 的软件包
java.util.concurrent.atomic 类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.atomic 中 AtomicLongFieldUpdater 的使用

返回 AtomicLongFieldUpdater 的 java.util.concurrent.atomic 中的方法
static
<U> AtomicLongFieldUpdater<U>
AtomicLongFieldUpdater.newUpdater(Class<U> tclass, String fieldName)
为对象创建并返回一个具有给定字段的更新器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicMarkableReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicMarkableReference
的使用

没有 java.util.concurrent.atomic.AtomicMarkableReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicReference
的使用

没有 java.util.concurrent.atomic.AtomicReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicReferenceArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicReferenceArray
的使用

没有 java.util.concurrent.atomic.AtomicReferenceArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicStampedReference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicStampedReference
的使用

没有 java.util.concurrent.atomic.AtomicStampedReference 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicInteger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicInteger
的使用

没有 java.util.concurrent.atomic.AtomicInteger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicLong 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicLong
的使用

没有 java.util.concurrent.atomic.AtomicLong 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicBoolean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicBoolean
的使用

没有 java.util.concurrent.atomic.AtomicBoolean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.atomic.AtomicReferenceFieldUpdater
的使用

使用 AtomicReferenceFieldUpdater 的软件包
java.util.concurrent.atomic 类的小工具包，支持在单个变量上解除锁的线程安全编程。

java.util.concurrent.atomic 中 AtomicReferenceFieldUpdater 的使用

返回 AtomicReferenceFieldUpdater 的 java.util.concurrent.atomic 中的方法
static
<U,W> AtomicReferenceFieldUpdater<U,W>
AtomicReferenceFieldUpdater.newUpdater(Class<U> tclass, Class<W> vclass, String fieldName)
使用给定的字段为对象创建和返回一个更新器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractOwnableSynchronizer (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 AbstractOwnableSynchronizer

java.lang.Object
    继承者  java.util.concurrent.locks.AbstractOwnableSynchronizer
所有已实现的接口：
Serializable
直接已知子类：
AbstractQueuedLongSynchronizer, AbstractQueuedSynchronizer
public abstract class AbstractOwnableSynchronizer
extends Object
implements Serializable

可以由线程以独占方式拥有的同步器。此类为创建锁和相关同步器（伴随着所有权的概念）提供了基础。AbstractOwnableSynchronizer 类本身不管理或使用此信息。但是，子类和工具可以使用适当维护的值帮助控制和监视访问以及提供诊断。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
protected AbstractOwnableSynchronizer()
供子类使用的空构造方法。
方法摘要
protected Thread | getExclusiveOwnerThread() 返回由 setExclusiveOwnerThread 最后设置的线程；如果从未设置，则返回 null。
protected void | setExclusiveOwnerThread(Thread t) 设置当前拥有独占访问的线程。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractOwnableSynchronizer

protected AbstractOwnableSynchronizer()
供子类使用的空构造方法。

方法详细信息

setExclusiveOwnerThread

protected final void setExclusiveOwnerThread(Thread t)
设置当前拥有独占访问的线程。null 参数表示没有线程拥有访问。此方法不另外施加任何同步或 volatile 字段访问。

getExclusiveOwnerThread

protected final Thread getExclusiveOwnerThread()
返回由 setExclusiveOwnerThread 最后设置的线程；如果从未设置，则返回 null。此方法不另外施加任何同步或 volatile 字段访问。

返回：
所有者线程
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractQueuedLongSynchronizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 AbstractQueuedLongSynchronizer

java.lang.Object
    继承者  java.util.concurrent.locks.AbstractOwnableSynchronizer
        继承者  java.util.concurrent.locks.AbstractQueuedLongSynchronizer
所有已实现的接口：
Serializable
public abstract class AbstractQueuedLongSynchronizer
extends AbstractOwnableSynchronizer
implements Serializable

以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。此类具有的结构、属性和方法与 AbstractQueuedSynchronizer 完全相同，但所有与状态相关的参数和结果都定义为 long 而不是 int。当创建需要 64 位状态的多级别锁和屏障等同步器时，此类很有用。

有关用法说明和示例，请参阅 AbstractQueuedSynchronizer。

从以下版本开始：
1.6
另请参见：
序列化表格

嵌套类摘要
 class AbstractQueuedLongSynchronizer.ConditionObject
作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
构造方法摘要
protected AbstractQueuedLongSynchronizer()
创建一个初始同步状态为 0 的新 AbstractQueuedLongSynchronizer 实例。
方法摘要
void | acquire(long arg) 以独占模式获取，忽略中断。
void | acquireInterruptibly(long arg) 以独占模式获取，如果被中断则中止。
void | acquireShared(long arg) 以共享模式获取，忽略中断。
void | acquireSharedInterruptibly(long arg) 以共享模式获取，如果被中断则中止。
protected boolean | compareAndSetState(long expect, long update) 如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。
Collection<Thread> | getExclusiveQueuedThreads() 返回一个 collection，该 collection 包含正以独占模式等待获取的线程。
Thread | getFirstQueuedThread() 返回队列中第一个（等待时间最长的）线程；如果当前没有将任何线程加入队列，则返回 null。
Collection<Thread> | getQueuedThreads() 返回一个 collection，该 collection 包含正在等待获取的线程。
int | getQueueLength() 返回等待获取的线程估计数。
Collection<Thread> | getSharedQueuedThreads() 返回一个 collection，该 collection 包含正以共享模式等待获取的线程。
protected long | getState() 返回同步状态的当前值。
Collection<Thread> | getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
int | getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回正在与此同步器关联的给定条件上等待的线程估计数。
boolean | hasContended() 查询是否有线程曾经为获取此同步器而发生争用；也就是说，是否某个 acquire 方法曾被阻塞。
boolean | hasQueuedThreads() 查询是否有等待获取的线程。
boolean | hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject condition) 查询是否有线程正在与此同步器关联的给定条件上等待。
protected boolean | isHeldExclusively() 如果对于当前（调用的）线程，同步是以独占方式进行的，则返回 true。
boolean | isQueued(Thread thread) 如果给定线程当前已加入队列，则返回 true。
boolean | owns(AbstractQueuedLongSynchronizer.ConditionObject condition) 查询给定 ConditionObject 是否使用此同步器作为它的锁。
boolean | release(long arg) 以独占模式释放。
boolean | releaseShared(long arg) 以共享模式释放。
protected void | setState(long newState) 设置同步状态的值。
String | toString() 返回标识此同步器及其状态的字符串。
protected boolean | tryAcquire(long arg) 尝试在独占模式下获取。
boolean | tryAcquireNanos(long arg, long nanosTimeout) 尝试以独占模式获取，如果被中断则中止，如果超过给定超时期则失败。
protected long | tryAcquireShared(long arg) 尝试在共享模式下获取。
boolean | tryAcquireSharedNanos(long arg, long nanosTimeout) 尝试以共享模式获取，如果被中断则中止，如果超过给定超时期则失败。
protected boolean | tryRelease(long arg) 尝试设置状态来反映独占模式下的释放。
protected boolean | tryReleaseShared(long arg) 尝试设置状态来反映共享模式下的释放。
从类 java.util.concurrent.locks.AbstractOwnableSynchronizer 继承的方法
getExclusiveOwnerThread, setExclusiveOwnerThread
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractQueuedLongSynchronizer

protected AbstractQueuedLongSynchronizer()
创建一个初始同步状态为 0 的新 AbstractQueuedLongSynchronizer 实例。

方法详细信息

getState

protected final long getState()
返回同步状态的当前值。此操作的内存语义 (memory semantics) 为 volatile 读。

返回：
当前状态值

setState

protected final void setState(long newState)
设置同步状态的值。此操作的内存语义为 volatile 写。

参数：
newState - 新的状态值

compareAndSetState

protected final boolean compareAndSetState(long expect,
                                           long update)
如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。此操作的内存语义为 volatile 写和读。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 false 指示实际值与预期值不相等。

tryAcquire

protected boolean tryAcquire(long arg)
尝试在独占模式下获取。此方法应该查询是否允许在独占模式下获取对象状态，如果允许，则获取它。

此方法总是由执行获取的线程调用。如果此方法报告失败，则 acquire 方法可以将线程加入队列（如果它还没有加入队列），直到收到其他线程的释放信号为止。可以使用此方法来实现 Lock.tryLock() 方法。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - 获取参数。此值总是传递给 acquire 方法的那个值，或者是保存在某个条件等待条目上的值。该值在其他方面没有解释，可以表示任何内容。
返回：
如果成功，则返回 true。在成功时，此对象已经被获取。
抛出：
IllegalMonitorStateException - 如果获取操作会将此同步器变为非法状态。为了同步的正常运行，必须以统一的方式抛出此异常。
UnsupportedOperationException - 如果不支持独占模式

tryRelease

protected boolean tryRelease(long arg)
尝试设置状态来反映独占模式下的释放。

此方法总是由执行释放的线程调用。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - 释放参数。此值总是传递给 release 方法的那个值，或者是某个条件等待条目上的当前状态值。该值在其他方面没有解释，可以表示任何内容。
返回：
如果此对象现在处于完全释放状态，从而任何等待的线程都可以尝试获取，则返回 true；否则返回 false。
抛出：
IllegalMonitorStateException - 如果释放操作会将此同步器变为非法状态。为了同步的正常运行，必须以统一的方式抛出此异常。
UnsupportedOperationException - 如果不支持独占模式

tryAcquireShared

protected long tryAcquireShared(long arg)
尝试在共享模式下获取。此方法应该查询是否允许在共享模式下获取对象状态，如果允许，则获取它。

此方法总是由执行获取的线程调用。如果此方法报告失败，则 acquire 方法可以将线程加入队列（如果它还没有加入队列），直到收到其他线程的释放信号为止。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - 获取参数。此值总是传递给 acquire 方法的那个值，或者是保存在某个条件等待条目上的值。该值在其他方面没有解释，可以表示任何内容。
返回：
在失败时返回负值；如果在共享模式下获取成功，但后续共享模式下的获取无法成功，则返回 0；如果在共享模式下获取成功，并且后续共享模式下的获取也能成功（在这种情况下，后续等待线程必须检查可用性），则返回正值。（支持三个不同返回值使得此方法可以在偶尔以独占方式进行获取的上下文中使用。）在成功时，此对象已经被获取。
抛出：
IllegalMonitorStateException - 如果获取操作会将此同步器变为非法状态。为了同步的正常运行，必须以统一的方式抛出此异常。
UnsupportedOperationException - 如果不支持共享模式

tryReleaseShared

protected boolean tryReleaseShared(long arg)
尝试设置状态来反映共享模式下的释放。

此方法总是由执行释放的线程调用。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - 释放参数。此值总是传递给 release 方法的那个值，或者是某个条件等待条目上的当前状态值。该值在其他方面没有解释，可以表示任何内容。
返回：
如果此共享模式下的释放允许等待的获取（共享或独占）获得成功，则返回 true；否则返回 false
抛出：
IllegalMonitorStateException - 如果释放操作会将此同步器变为非法状态。为了同步的正常运行，必须以统一的方式抛出此异常。
UnsupportedOperationException - 如果不支持共享模式

isHeldExclusively

protected boolean isHeldExclusively()
如果对于当前（调用的）线程，同步是以独占方式进行的，则返回 true。此方法是在每次调用非等待 AbstractQueuedLongSynchronizer.ConditionObject 方法时调用的。（等待方法则调用 release(long)。）

默认实现将抛出 UnsupportedOperationException。此方法只在 AbstractQueuedLongSynchronizer.ConditionObject 方法中进行内部调用，因此，如果不使用条件，则不需要定义它。

返回：
如果同步是以独占方式进行的，则返回 true；否则返回 false
抛出：
UnsupportedOperationException - 如果不支持这些条件

acquire

public final void acquire(long arg)
以独占模式获取，忽略中断。实现此方法要至少调用一次 tryAcquire(long)，并在成功时返回。否则，在成功之前，线程将加入队列，可能反复处于阻塞或未阻塞状态，并一直调用 tryAcquire(long)。可以使用此方法来实现 Lock.lock() 方法。

参数：
arg - 获取参数。此值被传送给 tryAcquire(long)，但在其他方面没有解释，可以表示任何内容。

acquireInterruptibly

public final void acquireInterruptibly(long arg)
                                throws InterruptedException
以独占模式获取，如果被中断则中止。实现此方法首先要检查中断状态，然后至少调用一次 tryAcquire(long)，并在成功时返回。否则，在成功或线程中断之前，线程将加入队列，可能反复处于阻塞或未阻塞状态，并一直调用 tryAcquire(long)。可以使用此方法来实现 Lock.lockInterruptibly() 方法。

参数：
arg - 获取参数。此值被传送给 tryAcquire(long)，但在其他方面没有解释，可以表示任何内容。
抛出：
InterruptedException - 如果当前线程被中断

tryAcquireNanos

public final boolean tryAcquireNanos(long arg,
                                     long nanosTimeout)
                              throws InterruptedException
尝试以独占模式获取，如果被中断则中止，如果超过给定超时期则失败。实现此方法首先要检查中断状态，然后至少调用一次 tryAcquire(long)，并在成功时返回。否则，在成功、线程中断或超过超时期之前，线程将加入队列，可能反复处于阻塞或未阻塞状态，并一直调用 tryAcquire(long)。可以使用此方法来实现 Lock.tryLock(long, TimeUnit) 方法。

参数：
arg - 获取参数。此值被传送给 tryAcquire(long)，但在其他方面没有解释，可以表示任何内容。
nanosTimeout - 等待的最大毫微秒数
返回：
如果获取，则返回 true；如果超时，则返回 false
抛出：
InterruptedException - 如果当前线程被中断

release

public final boolean release(long arg)
以独占模式释放。如果 tryRelease(long) 返回 true，则通过取消一个或多个线程的阻塞来实现此方法。可以使用此方法来实现 Lock.unlock() 方法。

参数：
arg - 释放参数。此值被传送给 tryRelease(long)，但在其他方面没有解释，可以表示任何内容。
返回：
从 tryRelease(long) 返回的值

acquireShared

public final void acquireShared(long arg)
以共享模式获取，忽略中断。实现此方法要至少调用一次 tryAcquireShared(long)，并在成功时返回。否则，在成功之前，线程将加入队列，可能反复处于阻塞或未阻塞状态，并一直调用 tryAcquireShared(long)。

参数：
arg - 获取参数。此值被传送给 tryAcquireShared(long)，但在其他方面没有解释，可以表示任何内容。

acquireSharedInterruptibly

public final void acquireSharedInterruptibly(long arg)
                                      throws InterruptedException
以共享模式获取，如果被中断则中止。实现此方法首先要检查中断状态，然后至少调用一次 tryAcquireShared(long)，并在成功时返回。否则，在成功或线程中断之前，线程将加入队列，可能反复处于阻塞或未阻塞状态，并一直调用 tryAcquireShared(long)。

参数：
arg - 获取参数。此值被传送给 tryAcquireShared(long)，但在其他方面没有解释，可以表示任何内容。
抛出：
InterruptedException - 如果当前线程被中断

tryAcquireSharedNanos

public final boolean tryAcquireSharedNanos(long arg,
                                           long nanosTimeout)
                                    throws InterruptedException
尝试以共享模式获取，如果被中断则中止，如果超过给定超时期则失败。实现此方法首先要检查中断状态，然后至少调用一次 tryAcquireShared(long)，并在成功时返回。否则，在成功、线程中断或超过超时期之前，线程将加入队列，可能反复处于阻塞或未阻塞状态，并一直调用 tryAcquireShared(long)。

参数：
arg - 获取参数。此值被传送给 tryAcquireShared(long)，但在其他方面没有解释，可以表示任何内容。
nanosTimeout - 等待的最大毫微秒数
返回：
如果获取，则返回 true；如果超时，则返回 false
抛出：
InterruptedException - 如果当前线程被中断

releaseShared

public final boolean releaseShared(long arg)
以共享模式释放。如果 tryReleaseShared(long) 返回 true，则通过取消一个或多个线程的阻塞来实现此方法。

参数：
arg - 释放参数。此值被传送给 tryReleaseShared(long)，但在其他方面没有解释，可以表示任何内容。
返回：
从 tryReleaseShared(long) 中返回的值

hasQueuedThreads

public final boolean hasQueuedThreads()
查询是否有等待获取的线程。注意，随时可能因为中断和超时而导致取消操作，所以返回 true 并不能保证任何其他线程能一直获取。

在此实现中，此操作是以固定时间返回的。

返回：
如果有其他线程正在等待获取，则返回 true

hasContended

public final boolean hasContended()
查询是否有线程曾经为获取此同步器而发生争用；也就是说，是否某个 acquire 方法曾被阻塞。

在此实现中，此操作是以固定时间返回的。

返回：
如果曾经出现争用，则返回 true

getFirstQueuedThread

public final Thread getFirstQueuedThread()
返回队列中第一个（等待时间最长的）线程；如果当前没有将任何线程加入队列，则返回 null。

在此实现中，此操作通常是以固定时间返回的，但是，如果其他线程正在并发修改该队列，则可能出现循环争用。

返回：
队列中第一个（等待时间最长的）线程；如果当前没有将任何线程加入队列，则返回 null

isQueued

public final boolean isQueued(Thread thread)
如果给定线程当前已加入队列，则返回 true。

此实现将遍历队列，以确定给定线程是否存在。

参数：
thread - 线程
返回：
如果给定线程在队列中，则返回 true
抛出：
NullPointerException - 如果线程为 null

getQueueLength

public final int getQueueLength()
返回等待获取的线程估计数。该值只是一个估计值，因为在此方法遍历内部数据结构时，线程的数量可以动态地变化。此方法是为监视系统状态而设计的，不是为同步控制设计的。

返回：
等待获取的线程估计数

getQueuedThreads

public final Collection<Thread> getQueuedThreads()
返回一个 collection，该 collection 包含正在等待获取的线程。因为在构造此结果时，实际线程集可能动态地变化，所以返回的 collection 只是一个尽可能准确的估计值。所返回 collection 中的元素没有特定的顺序。设计此方法是为了便于构造子类，提供更多的监视设施。

返回：
线程 collection

getExclusiveQueuedThreads

public final Collection<Thread> getExclusiveQueuedThreads()
返回一个 collection，该 collection 包含正以独占模式等待获取的线程。此方法的属性与 getQueuedThreads() 相同，但它只返回那些因独占获取而等待的线程。

返回：
线程 collection

getSharedQueuedThreads

public final Collection<Thread> getSharedQueuedThreads()
返回一个 collection，该 collection 包含正以共享模式等待获取的线程。此方法的属性与 getQueuedThreads() 相同，但它只返回那些因共享获取而等待的线程。

返回：
线程 collection

toString

public String toString()
返回标识此同步器及其状态的字符串。该状态用括号括起来，包括 String &quot;State =&quot;，后跟 getState() 的当前值，再后面是 &quot;nonempty&quot; 或 &quot;empty&quot;，具体取决于队列是否为空。

覆盖：
类 Object 中的 toString
返回：
标识此同步器及其状态的字符串

owns

public final boolean owns(AbstractQueuedLongSynchronizer.ConditionObject condition)
查询给定 ConditionObject 是否使用此同步器作为它的锁。

参数：
condition - 条件
返回：
如果具备此条件，则返回 true
抛出：
NullPointerException - 如果 condition 为 null

hasWaiters

public final boolean hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject condition)
查询是否有线程正在与此同步器关联的给定条件上等待。注意，因为随时可能发生超时和中断，所以返回 true 并不能保证将来某个 signal 将唤醒任何线程。此方法主要是为了监视系统状态而设计的。

参数：
condition - 条件
返回：
如果有正在等待的线程，则返回 true。
抛出：
IllegalMonitorStateException - 如果不进行独占同步
IllegalArgumentException - 如果给定条件与此同步器没有关联
NullPointerException - 如果 condition 为 null

getWaitQueueLength

public final int getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject condition)
返回正在与此同步器关联的给定条件上等待的线程估计数。注意，因为随时可能发生超时和中断，所以估计值只是实际等待线程数的上限。此方法是为监视系统状态而设计的，不是为同步控制设计的。

参数：
condition - 条件
返回：
等待线程的估计数
抛出：
IllegalMonitorStateException - 如果不进行独占同步
IllegalArgumentException - 如果给定条件与此同步器没有关联
NullPointerException - 如果 condition 为 null

getWaitingThreads

public final Collection<Thread> getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition)
返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。因为在构造此结果时，实际线程集可能动态地变化，所以返回的 collection 只是一个尽可能准确的估计值。所返回 collection 中的元素没有特定的顺序。

参数：
condition - 条件
返回：
线程 collection
抛出：
IllegalMonitorStateException - 如果不进行独占同步
IllegalArgumentException - 如果给定条件与此同步器没有关联
NullPointerException - 如果 condition 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractQueuedLongSynchronizer.ConditionObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 AbstractQueuedLongSynchronizer.ConditionObject

java.lang.Object
    继承者  java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
所有已实现的接口：
Serializable, Condition
正在封闭类：
AbstractQueuedLongSynchronizer
public class AbstractQueuedLongSynchronizer.ConditionObject
extends Object
implements Condition, Serializable

作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。

此类的方法文档不是一个行为规范，而是从 Lock 和 Condition 用户的角度描述机制。此类的导出版本通常需要附带描述条件语义的文档，这些语义依赖关联 AbstractQueuedLongSynchronizer 的那些条件的语义。

此类是可序列化的，但所有字段都是瞬态的，因此序列化条件没有等待线程。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
AbstractQueuedLongSynchronizer.ConditionObject()
创建一个新的 ConditionObject 实例。
方法摘要
void | await() 实现可中断的条件等待。
boolean | await(long time, TimeUnit unit) 实现定时条件等待。
long | awaitNanos(long nanosTimeout) 实现定时条件等待。
void | awaitUninterruptibly() 实现不可中断的条件等待。
boolean | awaitUntil(Date deadline) 实现绝对定时条件等待。
protected Collection<Thread> | getWaitingThreads() 返回一个 collection，该 collection 包含那些正在此条件等待的线程。
protected int | getWaitQueueLength() 返回正在此条件等待的线程估计数。
protected boolean | hasWaiters() 查询是否有线程正在此条件等待。
void | signal() 将等待时间最长的线程（如果有）从此条件的等待队列移动到拥有锁的等待队列。
void | signalAll() 将所有线程从此条件的等待队列移动到拥有锁的等待队列。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractQueuedLongSynchronizer.ConditionObject

public AbstractQueuedLongSynchronizer.ConditionObject()
创建一个新的 ConditionObject 实例。

方法详细信息

signal

public final void signal()
将等待时间最长的线程（如果有）从此条件的等待队列移动到拥有锁的等待队列。

指定者：
接口 Condition 中的 signal
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively() 返回 false

signalAll

public final void signalAll()
将所有线程从此条件的等待队列移动到拥有锁的等待队列。

指定者：
接口 Condition 中的 signalAll
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively() 返回 false

awaitUninterruptibly

public final void awaitUninterruptibly()
实现不可中断的条件等待。
  1. 保存 AbstractQueuedLongSynchronizer.getState() 返回的锁定状态
  2. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.release(long)，如果调用失败，则抛出 IllegalMonitorStateException。
  3. 在收到信号之前，一直阻塞
  4. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.acquire(long) 的特定版本重新获取。

指定者：
接口 Condition 中的 awaitUninterruptibly

await

public final void await()
                 throws InterruptedException
实现可中断的条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedLongSynchronizer.getState() 返回的锁定状态
  3. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.release(long)，如果调用失败，则抛出 IllegalMonitorStateException。
  4. 在收到信号或中断之前，一直阻塞
  5. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.acquire(long) 的特定版本重新获取。
  6. 如果步骤 4 的阻塞过程中发生中断，则抛出异常

指定者：
接口 Condition 中的 await
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

awaitNanos

public final long awaitNanos(long nanosTimeout)
                      throws InterruptedException
实现定时条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedLongSynchronizer.getState() 返回的锁定状态
  3. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.release(long)，如果调用失败，则抛出 IllegalMonitorStateException。
  4. 在收到信号、中断或超时之前，一直阻塞
  5. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.acquire(long) 的特定版本重新获取。
  6. 如果步骤 4 的阻塞过程中发生中断，则抛出 InterruptedException

指定者：
接口 Condition 中的 awaitNanos
参数：
nanosTimeout - 等待的最长时间，以毫微秒为单位
返回：
nanosTimeout 值减去花费在等待此方法的返回结果的时间的估算。正值可以用作对此方法进行后续调用的参数，来完成等待所需时间结束。小于等于零的值表示没有剩余时间。
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

awaitUntil

public final boolean awaitUntil(Date deadline)
                         throws InterruptedException
实现绝对定时条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedLongSynchronizer.getState() 返回的锁定状态
  3. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.release(long)，如果调用失败，则抛出 IllegalMonitorStateException。
  4. 在收到信号、中断或超时之前，一直阻塞
  5. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.acquire(long) 的特定版本重新获取。
  6. 如果步骤 4 的阻塞过程中发生中断，则抛出 InterruptedException
  7. 如果步骤 4 的阻塞过程中发生超时，则返回 false，否则返回 true

指定者：
接口 Condition 中的 awaitUntil
参数：
deadline - 一直处于等待状态的绝对时间
返回：
如果在返回时已经到达最后期限，则返回 false，否则返回 true
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

await

public final boolean await(long time,
                           TimeUnit unit)
                    throws InterruptedException
实现定时条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedLongSynchronizer.getState() 返回的锁定状态
  3. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.release(long)，如果调用失败，则抛出 IllegalMonitorStateException。
  4. 在收到信号、中断或超时之前，一直阻塞
  5. 以保存的状态作为参数调用 AbstractQueuedLongSynchronizer.acquire(long) 的特定版本重新获取。
  6. 如果步骤 4 的阻塞过程中发生中断，则抛出 InterruptedException
  7. 如果步骤 4 的阻塞过程中发生超时，则返回 false，否则返回 true

指定者：
接口 Condition 中的 await
参数：
time - 最长等待时间
unit - time 参数的时间单位
返回：
如果在从此方法返回前检测到等待时间超时，则返回 false，否则返回 true
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

hasWaiters

protected final boolean hasWaiters()
查询是否有线程正在此条件等待。实现 AbstractQueuedLongSynchronizer.hasWaiters(java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject)。

返回：
true 如果没有任何正在等待的线程
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively() 返回 false

getWaitQueueLength

protected final int getWaitQueueLength()
返回正在此条件等待的线程估计数。实现 AbstractQueuedLongSynchronizer.getWaitQueueLength(java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject)。

返回：
等待线程的估计数
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively() 返回 false

getWaitingThreads

protected final Collection<Thread> getWaitingThreads()
返回一个 collection，该 collection 包含那些正在此条件等待的线程。实现 AbstractQueuedLongSynchronizer.getWaitingThreads(java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject)。

返回：
线程 collection
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedLongSynchronizer.isHeldExclusively() 返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractQueuedSynchronizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 AbstractQueuedSynchronizer

java.lang.Object
    继承者  java.util.concurrent.locks.AbstractOwnableSynchronizer
        继承者  java.util.concurrent.locks.AbstractQueuedSynchronizer
所有已实现的接口：
Serializable
public abstract class AbstractQueuedSynchronizer
extends AbstractOwnableSynchronizer
implements Serializable

为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。此类的设计目标是成为依靠单个原子 int 值来表示状态的大多数同步器的一个有用基础。子类必须定义更改此状态的受保护方法，并定义哪种状态对于此对象意味着被获取或被释放。假定这些条件之后，此类中的其他方法就可以实现所有排队和阻塞机制。子类可以维护其他状态字段，但只是为了获得同步而只追踪使用 getState()、setState(int) 和 compareAndSetState(int, int) 方法来操作以原子方式更新的 int 值。

应该将子类定义为非公共内部帮助器类，可用它们来实现其封闭类的同步属性。类 AbstractQueuedSynchronizer 没有实现任何同步接口。而是定义了诸如 acquireInterruptibly(int) 之类的一些方法，在适当的时候可以通过具体的锁和相关同步器来调用它们，以实现其公共方法。

此类支持默认的独占 模式和共享 模式之一，或者二者都支持。处于独占模式下时，其他线程试图获取该锁将无法取得成功。在共享模式下，多个线程获取某个锁可能（但不是一定）会获得成功。此类并不“了解”这些不同，除了机械地意识到当在共享模式下成功获取某一锁时，下一个等待线程（如果存在）也必须确定自己是否可以成功获取该锁。处于不同模式下的等待线程可以共享相同的 FIFO 队列。通常，实现子类只支持其中一种模式，但两种模式都可以在（例如）ReadWriteLock 中发挥作用。只支持独占模式或者只支持共享模式的子类不必定义支持未使用模式的方法。

此类通过支持独占模式的子类定义了一个嵌套的 AbstractQueuedSynchronizer.ConditionObject 类，可以将这个类用作 Condition 实现。isHeldExclusively() 方法将报告同步对于当前线程是否是独占的；使用当前 getState() 值调用 release(int) 方法则可以完全释放此对象；如果给定保存的状态值，那么 acquire(int) 方法可以将此对象最终恢复为它以前获取的状态。没有别的 AbstractQueuedSynchronizer 方法创建这样的条件，因此，如果无法满足此约束，则不要使用它。AbstractQueuedSynchronizer.ConditionObject 的行为当然取决于其同步器实现的语义。

此类为内部队列提供了检查、检测和监视方法，还为 condition 对象提供了类似方法。可以根据需要使用用于其同步机制的 AbstractQueuedSynchronizer 将这些方法导出到类中。

此类的序列化只存储维护状态的基础原子整数，因此已序列化的对象拥有空的线程队列。需要可序列化的典型子类将定义一个 readObject 方法，该方法在反序列化时将此对象恢复到某个已知初始状态。

使用

为了将此类用作同步器的基础，需要适当地重新定义以下方法，这是通过使用 getState()、setState(int) 和/或 compareAndSetState(int, int) 方法来检查和/或修改同步状态来实现的：

  • tryAcquire(int)
  • tryRelease(int)
  • tryAcquireShared(int)
  • tryReleaseShared(int)
  • isHeldExclusively()
默认情况下，每个方法都抛出 UnsupportedOperationException。这些方法的实现在内部必须是线程安全的，通常应该很短并且不被阻塞。定义这些方法是使用此类的唯一 受支持的方式。其他所有方法都被声明为 final，因为它们无法是各不相同的。

您也可以查找从 AbstractOwnableSynchronizer 继承的方法，用于跟踪拥有独占同步器的线程。鼓励使用这些方法，这允许监控和诊断工具来帮助用户确定哪个线程保持锁。

即使此类基于内部的某个 FIFO 队列，它也无法强行实施 FIFO 获取策略。独占同步的核心采用以下形式：

 Acquire:
     while (!tryAcquire(arg)) {
        enqueue thread if it is not already queued;
        possibly block current thread;
     }

 Release:
     if (tryRelease(arg))
        unblock the first queued thread;
（共享模式与此类似，但可能涉及级联信号。）

因为要在加入队列之前检查线程的获取状况，所以新获取的线程可能闯入 其他被阻塞的和已加入队列的线程之前。不过如果需要，可以内部调用一个或多个检查方法，通过定义 tryAcquire 和/或 tryAcquireShared 来禁用闯入。特别是 getFirstQueuedThread() 没有返回当前线程的时候，严格的 FIFO 锁定可以定义 tryAcquire 立即返回 false。只有 hasQueuedThreads() 返回 true 并且 getFirstQueuedThread 不是当前线程时，更好的非严格公平的版本才可能会立即返回 false；如果 getFirstQueuedThread 不为 null 并且不是当前线程，则产生的结果相同。出现进一步的变体也是有可能的。

对于默认闯入（也称为 greedy、renouncement 和 convoy-avoidance）策略，吞吐量和可伸缩性通常是最高的。尽管无法保证这是公平的或是无偏向的，但允许更早加入队列的线程先于更迟加入队列的线程再次争用资源，并且相对于传入的线程，每个参与再争用的线程都有平等的成功机会。此外，尽管从一般意义上说，获取并非“自旋”，它们可以在阻塞之前对用其他计算所使用的 tryAcquire 执行多次调用。在只保持独占同步时，这为自旋提供了最大的好处，但不是这种情况时，也不会带来最大的负担。如果需要这样做，那么可以使用“快速路径”检查来先行调用 acquire 方法，以这种方式扩充这一点，如果可能不需要争用同步器，则只能通过预先检查 hasContended() 和/或 hasQueuedThreads() 来确认这一点。

通过特殊化其同步器的使用范围，此类为部分同步化提供了一个有效且可伸缩的基础，同步器可以依赖于 int 型的 state、acquire 和 release 参数，以及一个内部的 FIFO 等待队列。这些还不够的时候，可以使用 atomic 类、自己的定制 Queue 类和 LockSupport 阻塞支持，从更低级别构建同步器。

使用示例

以下是一个非再进入的互斥锁类，它使用值 0 表示未锁定状态，使用 1 表示锁定状态。当非重入锁定不严格地需要当前拥有者线程的记录时，此类使得使用监视器更加方便。它还支持一些条件并公开了一个检测方法：

 class Mutex implements Lock, java.io.Serializable {

    // Our internal helper class
    private static class Sync extends AbstractQueuedSynchronizer {
      // Report whether in locked state
      protected boolean isHeldExclusively() {
        return getState() == 1;
      }

      // Acquire the lock if state is zero
      public boolean tryAcquire(int acquires) {
        assert acquires == 1; // Otherwise unused
       if (compareAndSetState(0, 1)) {
         setExclusiveOwnerThread(Thread.currentThread());
         return true;
       }
       return false;
      }

      // Release the lock by setting state to zero
      protected boolean tryRelease(int releases) {
        assert releases == 1; // Otherwise unused
        if (getState() == 0) throw new IllegalMonitorStateException();
        setExclusiveOwnerThread(null);
        setState(0);
        return true;
      }

      // Provide a Condition
      Condition newCondition() { return new ConditionObject(); }

      // Deserialize properly
      private void readObject(ObjectInputStream s)
        throws IOException, ClassNotFoundException {
        s.defaultReadObject();
        setState(0); // reset to unlocked state
      }
    }

    // The sync object does all the hard work. We just forward to it.
    private final Sync sync = new Sync();

    public void lock()                { sync.acquire(1); }
    public boolean tryLock()          { return sync.tryAcquire(1); }
    public void unlock()              { sync.release(1); }
    public Condition newCondition()   { return sync.newCondition(); }
    public boolean isLocked()         { return sync.isHeldExclusively(); }
    public boolean hasQueuedThreads() { return sync.hasQueuedThreads(); }
    public void lockInterruptibly() throws InterruptedException {
      sync.acquireInterruptibly(1);
    }
    public boolean tryLock(long timeout, TimeUnit unit)
        throws InterruptedException {
      return sync.tryAcquireNanos(1, unit.toNanos(timeout));
    }
 }

以下是一个锁存器类，它类似于 CountDownLatch，除了只需要触发单个 signal 之外。因为锁存器是非独占的，所以它使用 shared 的获取和释放方法。

 class BooleanLatch {

    private static class Sync extends AbstractQueuedSynchronizer {
      boolean isSignalled() { return getState() != 0; }

      protected int tryAcquireShared(int ignore) {
        return isSignalled()? 1 : -1;
      }

      protected boolean tryReleaseShared(int ignore) {
        setState(1);
        return true;
      }
    }

    private final Sync sync = new Sync();
    public boolean isSignalled() { return sync.isSignalled(); }
    public void signal()         { sync.releaseShared(1); }
    public void await() throws InterruptedException {
      sync.acquireSharedInterruptibly(1);
    }
 }

从以下版本开始：
1.5
另请参见：
序列化表格

嵌套类摘要
 class AbstractQueuedSynchronizer.ConditionObject
AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。
构造方法摘要
protected AbstractQueuedSynchronizer()
创建具有初始同步状态 0 的新 AbstractQueuedSynchronizer 实例。
方法摘要
void | acquire(int arg) 以独占模式获取对象，忽略中断。
void | acquireInterruptibly(int arg) 以独占模式获取对象，如果被中断则中止。
void | acquireShared(int arg) 以共享模式获取对象，忽略中断。
void | acquireSharedInterruptibly(int arg) 以共享模式获取对象，如果被中断则中止。
protected boolean | compareAndSetState(int expect, int update) 如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。
Collection<Thread> | getExclusiveQueuedThreads() 返回包含可能正以独占模式等待获取的线程 collection。
Thread | getFirstQueuedThread() 返回队列中第一个（等待时间最长的）线程，如果目前没有将任何线程加入队列，则返回 null. 在此实现中，该操作是以固定时间返回的，但是，如果其他线程目前正在并发修改该队列，则可能出现循环争用。
Collection<Thread> | getQueuedThreads() 返回包含可能正在等待获取的线程 collection。
int | getQueueLength() 返回等待获取的线程数估计值。
Collection<Thread> | getSharedQueuedThreads() 返回包含可能正以共享模式等待获取的线程 collection。
protected int | getState() 返回同步状态的当前值。
Collection<Thread> | getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition) 返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
int | getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject condition) 返回正在等待与此同步器有关的给定条件的线程数估计值。
boolean | hasContended() 查询是否其他线程也曾争着获取此同步器；也就是说，是否某个 acquire 方法已经阻塞。
boolean | hasQueuedThreads() 查询是否有正在等待获取的任何线程。
boolean | hasWaiters(AbstractQueuedSynchronizer.ConditionObject condition) 查询是否有线程正在等待给定的、与此同步器相关的条件。
protected boolean | isHeldExclusively() 如果对于当前（正调用的）线程，同步是以独占方式进行的，则返回 true。
boolean | isQueued(Thread thread) 如果给定线程的当前已加入队列，则返回 true。
boolean | owns(AbstractQueuedSynchronizer.ConditionObject condition) 查询给定的 ConditionObject 是否使用了此同步器作为其锁。
boolean | release(int arg) 以独占模式释放对象。
boolean | releaseShared(int arg) 以共享模式释放对象。
protected void | setState(int newState) 设置同步状态的值。
String | toString() 返回标识此同步器及其状态的字符串。
protected boolean | tryAcquire(int arg) 试图在独占模式下获取对象状态。
boolean | tryAcquireNanos(int arg, long nanosTimeout) 试图以独占模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
protected int | tryAcquireShared(int arg) 试图在共享模式下获取对象状态。
boolean | tryAcquireSharedNanos(int arg, long nanosTimeout) 试图以共享模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。
protected boolean | tryRelease(int arg) 试图设置状态来反映独占模式下的一个释放。
protected boolean | tryReleaseShared(int arg) 试图设置状态来反映共享模式下的一个释放。
从类 java.util.concurrent.locks.AbstractOwnableSynchronizer 继承的方法
getExclusiveOwnerThread, setExclusiveOwnerThread
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractQueuedSynchronizer

protected AbstractQueuedSynchronizer()
创建具有初始同步状态 0 的新 AbstractQueuedSynchronizer 实例。

方法详细信息

getState

protected final int getState()
返回同步状态的当前值。此操作具有 volatile 读的内存语义。

返回：
当前状态值

setState

protected final void setState(int newState)
设置同步状态的值。此操作具有 volatile 写的内存语义。

参数：
newState - 新的状态值

compareAndSetState

protected final boolean compareAndSetState(int expect,
                                           int update)
如果当前状态值等于预期值，则以原子方式将同步状态设置为给定的更新值。此操作具有 volatile 读和写的内存语义。

参数：
expect - 预期值
update - 新值
返回：
如果成功，则返回 true。返回 false 指示实际值与预期值不相等。

tryAcquire

protected boolean tryAcquire(int arg)
试图在独占模式下获取对象状态。此方法应该查询是否允许它在独占模式下获取对象状态，如果允许，则获取它。

此方法总是由执行 acquire 的线程来调用。如果此方法报告失败，则 acquire 方法可以将线程加入队列（如果还没有将它加入队列），直到获得其他某个线程释放了该线程的信号。可以用此方法来实现 Lock.tryLock() 方法。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - acquire 参数。该值总是传递给 acquire 方法的那个值，或者是因某个条件等待而保存在条目上的值。该值是不间断的，并且可以表示任何内容。
返回：
如果成功，则返回 true。在成功的时候，此对象已经被获取。
抛出：
IllegalMonitorStateException - 如果正在进行的获取操作将在非法状态下放置此同步器。必须以一致的方式抛出此异常，以便同步正确运行。
UnsupportedOperationException - 如果不支持独占模式

tryRelease

protected boolean tryRelease(int arg)
试图设置状态来反映独占模式下的一个释放。

此方法总是由正在执行释放的线程调用。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - release 参数。该值总是传递给 release 方法的那个值，或者是因某个条件等待而保存在条目上的当前状态值。该值是不间断的，并且可以表示任何内容。
返回：
如果此对象现在处于完全释放状态，从而使等待的线程都可以试图获得此对象，则返回 true；否则返回 false。
抛出：
IllegalMonitorStateException - 如果正在进行的释放操作将在非法状态下放置此同步器。必须以一致的方式抛出此异常，以便同步正确运行。
UnsupportedOperationException - 如果不支持独占模式

tryAcquireShared

protected int tryAcquireShared(int arg)
试图在共享模式下获取对象状态。此方法应该查询是否允许它在共享模式下获取对象状态，如果允许，则获取它。

此方法总是由执行 acquire 线程来调用。如果此方法报告失败，则 acquire 方法可以将线程加入队列（如果还没有将它加入队列），直到获得其他某个线程释放了该线程的信号。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - acquire 参数。该值总是传递给 acquire 方法的那个值，或者是因某个条件等待而保存在条目上的值。该值是不间断的，并且可以表示任何内容。
返回：
在失败时返回负值；如果共享模式下的获取成功但其后续共享模式下的获取不能成功，则返回 0；如果共享模式下的获取成功并且其后续共享模式下的获取可能够成功，则返回正值，在这种情况下，后续等待线程必须检查可用性。（对三种返回值的支持使得此方法可以在只是有时候以独占方式获取对象的上下文中使用。）在成功的时候，此对象已被获取。
抛出：
IllegalMonitorStateException - 如果正在进行的获取操作将在非法状态下放置此同步器。必须以一致的方式抛出此异常，以便同步正确运行。
UnsupportedOperationException - 如果不支持共享模式

tryReleaseShared

protected boolean tryReleaseShared(int arg)
试图设置状态来反映共享模式下的一个释放。

此方法总是由正在执行释放的线程调用。

默认实现将抛出 UnsupportedOperationException。

参数：
arg - release 参数。该值总是传递给 release 方法的那个值，或者是因某个条件等待而保存在条目上的当前状态值。该值是不间断的，并且可以表示任何内容。
返回：
如果此对象现在处于完全释放状态，从而使正在等待的线程都可以试图获得此对象，则返回 true；否则返回 false
抛出：
IllegalMonitorStateException - 如果正在进行的释放操作将在非法状态下放置此同步器。必须以一致的方式抛出此异常，以便同步正确运行
UnsupportedOperationException - 如果不支持共享模式

isHeldExclusively

protected boolean isHeldExclusively()
如果对于当前（正调用的）线程，同步是以独占方式进行的，则返回 true。此方法是在每次调用非等待 AbstractQueuedSynchronizer.ConditionObject 方法时调用的。（等待方法则调用 release(int)。）

默认实现将抛出 UnsupportedOperationException。此方法只是 AbstractQueuedSynchronizer.ConditionObject 方法内进行内部调用，因此，如果不使用条件，则不需要定义它。

返回：
如果同步是以独占方式进行的，则返回true；其他情况则返回 false
抛出：
UnsupportedOperationException - 如果不支持这些条件

acquire

public final void acquire(int arg)
以独占模式获取对象，忽略中断。通过至少调用一次 tryAcquire(int) 来实现此方法，并在成功时返回。否则在成功之前，一直调用 tryAcquire(int) 将线程加入队列，线程可能重复被阻塞或不被阻塞。可以使用此方法来实现 Lock.lock() 方法。

参数：
arg - acquire 参数。此值被传送给 tryAcquire(int)，但它是不间断的，并且可以表示任何内容。

acquireInterruptibly

public final void acquireInterruptibly(int arg)
                                throws InterruptedException
以独占模式获取对象，如果被中断则中止。通过先检查中断状态，然后至少调用一次 tryAcquire(int) 来实现此方法，并在成功时返回。否则在成功之前，或者线程被中断之前，一直调用 tryAcquire(int) 将线程加入队列，线程可能重复被阻塞或不被阻塞。可以使用此方法来实现 Lock.lockInterruptibly() 方法。

参数：
arg - acquire 参数。此值被传送给 tryAcquire(int)，但它是不间断的，并且可以表示任何内容。
抛出：
InterruptedException - 如果当前线程被中断

tryAcquireNanos

public final boolean tryAcquireNanos(int arg,
                                     long nanosTimeout)
                              throws InterruptedException
试图以独占模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。通过先检查中断状态，然后至少调用一次 tryAcquire(int) 来实现此方法，并在成功时返回。否则，在成功之前、线程被中断之前或者到达超时时间之前，一直调用 tryAcquire(int) 将线程加入队列，线程可能重复被阻塞或不被阻塞。可以用此方法来实现 Lock.tryLock(long, TimeUnit) 方法。

参数：
arg - acquire 参数。此值被传送给 tryAcquire(int)，但它是不间断的，并且可以表示任何内容。
nanosTimeout - 等待的最长时间，以毫微秒为单位
返回：
如果获取对象，则返回 true，如果超时，则返回 false
抛出：
InterruptedException - 如果当前线程被中断

release

public final boolean release(int arg)
以独占模式释放对象。如果 tryRelease(int) 返回 true，则通过消除一个或多个线程的阻塞来实现此方法。可以使用此方法来实现 Lock.unlock() 方法

参数：
arg - release 参数。此值被传送给 tryRelease(int)，但它是不间断的，并且可以表示任何内容。
返回：
从 tryRelease(int) 返回的值

acquireShared

public final void acquireShared(int arg)
以共享模式获取对象，忽略中断。通过至少先调用一次 tryAcquireShared(int) 来实现此方法，并在成功时返回。否则在成功之前，一直调用 tryAcquireShared(int) 将线程加入队列，线程可能重复被阻塞或不被阻塞。

参数：
arg - acquire 参数。此值被传送给 tryAcquireShared(int)，但它是不间断的，并且可以表示任何内容。

acquireSharedInterruptibly

public final void acquireSharedInterruptibly(int arg)
                                      throws InterruptedException
以共享模式获取对象，如果被中断则中止。通过先检查中断状态，然后至少调用一次 tryAcquireShared(int) 来实现此方法，并在成功时返回。否则在成功或线程被中断之前，一直调用 tryAcquireShared(int) 将线程加入队列，线程可能重复被阻塞或不被阻塞。

参数：
arg - acquire 参数。此值被传送给 tryAcquireShared(int)，但它是不间断的，并且可以表示任何内容。
抛出：
InterruptedException - 如果当前线程被中断

tryAcquireSharedNanos

public final boolean tryAcquireSharedNanos(int arg,
                                           long nanosTimeout)
                                    throws InterruptedException
试图以共享模式获取对象，如果被中断则中止，如果到了给定超时时间，则会失败。通过先检查中断状态，然后至少调用一次 tryAcquireShared(int) 来实现此方法，并在成功时返回。否则在成功之前、线程被中断之前或者到达超时时间之前，一直调用 tryAcquireShared(int) 将线程加入队列，线程可能重复被阻塞或不被阻塞。

参数：
arg - acquire 参数。此值被传送给 tryAcquireShared(int)，但它是不间断的，并且可以表示任何内容。
nanosTimeout - 等待的最长时间，以毫微秒为单位
返回：
如果获取对象，则返回 true，如果超时，则返回 false
抛出：
InterruptedException - 如果当前线程被中断

releaseShared

public final boolean releaseShared(int arg)
以共享模式释放对象。如果 tryReleaseShared(int) 返回 true，则通过消除一个或多个线程的阻塞来实现该方法。

参数：
arg - release 参数。此值被传送给 tryReleaseShared(int)，但它是不间断的，并且可以表示任何内容。
返回：
从 tryReleaseShared(int) 中返回的值

hasQueuedThreads

public final boolean hasQueuedThreads()
查询是否有正在等待获取的任何线程。注意，随时可能因为中断和超时而导致取消操作，返回 true 并不能保证其他任何线程都将获取对象。

在此实现中，该操作是以固定时间返回的。

返回：
如果可能有其他线程正在等待获取锁，则返回 true。

hasContended

public final boolean hasContended()
查询是否其他线程也曾争着获取此同步器；也就是说，是否某个 acquire 方法已经阻塞。

在此实现中，该操作是以固定时间返回的。

返回：
如果曾经出现争用，则返回 true

getFirstQueuedThread

public final Thread getFirstQueuedThread()
返回队列中第一个（等待时间最长的）线程，如果目前没有将任何线程加入队列，则返回 null.

在此实现中，该操作是以固定时间返回的，但是，如果其他线程目前正在并发修改该队列，则可能出现循环争用。

返回：
队列中第一个（等待时间最长的）线程，如果目前没有将任何线程加入队列，则返回 null

isQueued

public final boolean isQueued(Thread thread)
如果给定线程的当前已加入队列，则返回 true。

该实现将遍历队列，以确定给定线程是否存在。

参数：
thread - 线程
返回：
如果给定线程在队列中，则返回 true
抛出：
NullPointerException - 如果 thread 为 null

getQueueLength

public final int getQueueLength()
返回等待获取的线程数估计值。该值只能是一个估计值，因为在此方法遍历内部数据结构时，线程的数量可能发生大的变化。该方法是为用来监视系统状态而设计的，不是为同步控制设计的。

返回：
正等待获取的线程估计数

getQueuedThreads

public final Collection<Thread> getQueuedThreads()
返回包含可能正在等待获取的线程 collection。因为在构造该结果时，实际线程 set 可能发生大的变化，所以返回的 collection 只是尽最大努力获得的一个估计值。返回 collection 的元素并不是以特定顺序排列的。此方法是为促进子类的构造而设计的，这些子类提供了大量的监视设施。

返回：
线程的 collection

getExclusiveQueuedThreads

public final Collection<Thread> getExclusiveQueuedThreads()
返回包含可能正以独占模式等待获取的线程 collection。此方法具有与 getQueuedThreads() 相同的属性，除了它只返回那些因独占获取而等待的线程。

返回：
线程的 collection

getSharedQueuedThreads

public final Collection<Thread> getSharedQueuedThreads()
返回包含可能正以共享模式等待获取的线程 collection。此方法具有与 getQueuedThreads() 相同的属性，除了它只返回那些因共享获取而等待的线程。

返回：
线程的 collection

toString

public String toString()
返回标识此同步器及其状态的字符串。此状态被括号括起来，它包括字符串 "State ="，后面是 getState() 的当前值，再后面是 "nonempty" 或 "empty"，这取决于队列是否为空。

覆盖：
类 Object 中的 toString
返回：
标识此同步器及其状态的字符串

owns

public final boolean owns(AbstractQueuedSynchronizer.ConditionObject condition)
查询给定的 ConditionObject 是否使用了此同步器作为其锁。

参数：
condition - 条件
返回：
如果具备此条件，则返回 true
抛出：
NullPointerException - 如果 condition 为 null

hasWaiters

public final boolean hasWaiters(AbstractQueuedSynchronizer.ConditionObject condition)
查询是否有线程正在等待给定的、与此同步器相关的条件。注意，因为随时可能发生超时和中断，所以返回 true 并不能保证将来某个 signal 将唤醒任何线程。此方法主要是为了监视系统状态而设计的。

参数：
condition - 条件
返回：
如果有正在等待的线程，则返回 true
抛出：
IllegalMonitorStateException - 如果不进行独占同步
IllegalArgumentException - 如果给定的 condition 与此同步器无关
NullPointerException - 如果 condition 为 null

getWaitQueueLength

public final int getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject condition)
返回正在等待与此同步器有关的给定条件的线程数估计值。注意，因为随时可能发生超时和中断，所以估计值只是实际等待线程的数量上限。此方法是为监视系统状态而设计的，不是为同步控制设计的。

参数：
condition - 条件
返回：
等待线程的估计数
抛出：
IllegalMonitorStateException - 如果不进行独占同步
IllegalArgumentException - 如果给定的 condition 与此同步器无关
NullPointerException - 如果 condition 为 null

getWaitingThreads

public final Collection<Thread> getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition)
返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。因为在构造该结果时，实际线程 set 可能发生大的变化，所以返回的 collection 只是尽最大努力获得的一个估计值。返回 collection 的元素并不是以特定顺序排列的。

参数：
condition - 条件
返回：
线程的 collection
抛出：
IllegalMonitorStateException - 如果不进行独占同步
IllegalArgumentException - 如果给定的 condition 与此同步器无关
NullPointerException - 如果 condition 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractQueuedSynchronizer.ConditionObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 AbstractQueuedSynchronizer.ConditionObject

java.lang.Object
    继承者  java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
所有已实现的接口：
Serializable, Condition
正在封闭类：
AbstractQueuedSynchronizer
public class AbstractQueuedSynchronizer.ConditionObject
extends Object
implements Condition, Serializable

AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。

此类的方法文档描述了一些机制，但没有从 Lock 和 Condition 用户的角度描述行为规范。此类的发行版本通常必须和描述 condition 语义的文档一起提供，这些语义依赖于相关 AbstractQueuedSynchronizer 的那些语义。

此类是可序列化的，但所有字段都是瞬态的，所以已序列化的条件没有等待者。

另请参见：
序列化表格

构造方法摘要
AbstractQueuedSynchronizer.ConditionObject()
创建一个新的 ConditionObject 实例。
方法摘要
void | await() 实现不可中断的条件等待。
boolean | await(long time, TimeUnit unit) 实现定时的条件等待。
long | awaitNanos(long nanosTimeout) 实现定时的条件等待。
void | awaitUninterruptibly() 实现不可中断的条件等待。
boolean | awaitUntil(Date deadline) 实现绝对定时条件等待。
protected Collection<Thread> | getWaitingThreads() 返回包含那些可能正在等待此条件的线程 collection。
protected int | getWaitQueueLength() 返回正在等待此条件的线程数估计值。
protected boolean | hasWaiters() 查询是否有正在等待此条件的任何线程。
void | signal() 将等待时间最长的线程（如果存在）从此条件的等待队列中移动到拥有锁的等待队列。
void | signalAll() 将所有线程从此条件的等待队列移动到拥有锁的等待队列中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractQueuedSynchronizer.ConditionObject

public AbstractQueuedSynchronizer.ConditionObject()
创建一个新的 ConditionObject 实例。

方法详细信息

signal

public final void signal()
将等待时间最长的线程（如果存在）从此条件的等待队列中移动到拥有锁的等待队列。

指定者：
接口 Condition 中的 signal
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively() 返回 false

signalAll

public final void signalAll()
将所有线程从此条件的等待队列移动到拥有锁的等待队列中。

指定者：
接口 Condition 中的 signalAll
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively() 返回 false

awaitUninterruptibly

public final void awaitUninterruptibly()
实现不可中断的条件等待。
  1. 保存 AbstractQueuedSynchronizer.getState() 返回的锁定状态
  2. 调用将保存的状态用作参数的 AbstractQueuedSynchronizer.release(int)，如果失败则抛出 IllegalMonitorStateException。
  3. 在收到信号之前，会一直阻塞
  4. 通过调用将保存的状态用作参数的 AbstractQueuedSynchronizer.acquire(int) 特殊版本来重新获得线程。

指定者：
接口 Condition 中的 awaitUninterruptibly

await

public final void await()
                 throws InterruptedException
实现不可中断的条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedSynchronizer.getState() 返回的锁定状态
  3. 调用将保存的状态用作参数的 AbstractQueuedSynchronizer.release(int)，如果失败则抛出 IllegalMonitorStateException。
  4. 在收到信号或被中断之前，会一直阻塞
  5. 通过调用将保存的状态用作参数的 AbstractQueuedSynchronizer.acquire(int) 特殊版本来重新获得线程。
  6. 如果因为在步骤 4 中受阻而中断，则抛出异常

指定者：
接口 Condition 中的 await
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

awaitNanos

public final long awaitNanos(long nanosTimeout)
                      throws InterruptedException
实现定时的条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedSynchronizer.getState() 返回的锁定状态
  3. 调用将保存的状态用作参数的 AbstractQueuedSynchronizer.release(int)，如果失败则抛出 IllegalMonitorStateException。
  4. 在收到信号、被中断或超时之前，会一直阻塞
  5. 通过调用将保存的状态用作参数的 AbstractQueuedSynchronizer.acquire(int) 特殊版本来重新获得线程。
  6. 如果因为在步骤 4 中受阻而中断，则抛出 InterruptedException

指定者：
接口 Condition 中的 awaitNanos
参数：
nanosTimeout - 等待的最长时间，以毫微秒为单位
返回：
nanosTimeout 值减去花费在等待此方法的返回结果的时间的估算。正值可以用作对此方法进行后续调用的参数，来完成等待所需时间结束。小于等于零的值表示没有剩余时间。
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

awaitUntil

public final boolean awaitUntil(Date deadline)
                         throws InterruptedException
实现绝对定时条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedSynchronizer.getState() 返回的锁定状态
  3. 调用将保存的状态用作参数的 AbstractQueuedSynchronizer.release(int)，如果失败则抛出 IllegalMonitorStateException。
  4. 在收到信号、被中断或超时之前，会一直阻塞
  5. 通过调用将保存的状态用作参数的 AbstractQueuedSynchronizer.acquire(int) 特殊版本来重新获得线程。
  6. 如果因为在步骤 4 中受阻而中断，则抛出 InterruptedException
  7. 如果因为在步骤 4 中受阻而超时，则返回 false，其他情况返回 true

指定者：
接口 Condition 中的 awaitUntil
参数：
deadline - 一直处于等待状态的绝对时间
返回：
如果在返回时已经到达最后期限，则返回 false，否则返回 true
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

await

public final boolean await(long time,
                           TimeUnit unit)
                    throws InterruptedException
实现定时的条件等待。
  1. 如果当前线程被中断，则抛出 InterruptedException
  2. 保存 AbstractQueuedSynchronizer.getState() 返回的锁定状态
  3. 调用将保存的状态用作参数的 AbstractQueuedSynchronizer.release(int)，如果失败则抛出 IllegalMonitorStateException。
  4. 在收到信号、被中断或超时之前，会一直阻塞
  5. 通过调用将保存的状态用作参数的 AbstractQueuedSynchronizer.acquire(int) 特殊版本来重新获得线程。
  6. 如果因为在步骤 4 中受阻而中断，则抛出 InterruptedException
  7. 如果因为在步骤 4 中受阻而超时，则返回 false，其他情况返回 true

指定者：
接口 Condition 中的 await
参数：
time - 最长等待时间
unit - time 参数的时间单位
返回：
如果在从此方法返回前检测到等待时间超时，则返回 false，否则返回 true
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

hasWaiters

protected final boolean hasWaiters()
查询是否有正在等待此条件的任何线程。实现 AbstractQueuedSynchronizer.hasWaiters(java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject)。

返回：
如果有正在等待的任何线程，则返回 true
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively() 返回 false

getWaitQueueLength

protected final int getWaitQueueLength()
返回正在等待此条件的线程数估计值。实现 AbstractQueuedSynchronizer.getWaitQueueLength(java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject)。

返回：
正在等待的线程估计数
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively() 返回 false

getWaitingThreads

protected final Collection<Thread> getWaitingThreads()
返回包含那些可能正在等待此条件的线程 collection。实现 AbstractQueuedSynchronizer.getWaitingThreads(java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject)。

返回：
线程的 collection
抛出：
IllegalMonitorStateException - 如果 AbstractQueuedSynchronizer.isHeldExclusively() 返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Condition (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
接口 Condition

所有已知实现类：
AbstractQueuedLongSynchronizer.ConditionObject, AbstractQueuedSynchronizer.ConditionObject
public interface Condition

Condition 将 Object 监视器方法（wait、notify 和 notifyAll）分解成截然不同的对象，以便通过将这些对象与任意 Lock 实现组合使用，为每个对象提供多个等待 set（wait-set）。其中，Lock 替代了 synchronized 方法和语句的使用，Condition 替代了 Object 监视器方法的使用。

条件（也称为条件队列 或条件变量）为线程提供了一个含义，以便在某个状态条件现在可能为 true 的另一个线程通知它之前，一直挂起该线程（即让其“等待”）。因为访问此共享状态信息发生在不同的线程中，所以它必须受保护，因此要将某种形式的锁与该条件相关联。等待提供一个条件的主要属性是：以原子方式 释放相关的锁，并挂起当前线程，就像 Object.wait 做的那样。

Condition 实例实质上被绑定到一个锁上。要为特定 Lock 实例获得 Condition 实例，请使用其 newCondition() 方法。

作为一个示例，假定有一个绑定的缓冲区，它支持 put 和 take 方法。如果试图在空的缓冲区上执行 take 操作，则在某一个项变得可用之前，线程将一直阻塞；如果试图在满的缓冲区上执行 put 操作，则在有空间变得可用之前，线程将一直阻塞。我们喜欢在单独的等待 set 中保存 put 线程和 take 线程，这样就可以在缓冲区中的项或空间变得可用时利用最佳规划，一次只通知一个线程。可以使用两个 Condition 实例来做到这一点。

 class BoundedBuffer {
   final Lock lock = new ReentrantLock();
   final Condition notFull  = lock.newCondition();
   final Condition notEmpty = lock.newCondition();

   final Object[] items = new Object[100];
   int putptr, takeptr, count;

   public void put(Object x) throws InterruptedException {
     lock.lock();
     try {
       while (count == items.length)
         notFull.await();
       items[putptr] = x;
       if (++putptr == items.length) putptr = 0;
       ++count;
       notEmpty.signal();
     } finally {
       lock.unlock();
     }
   }

   public Object take() throws InterruptedException {
     lock.lock();
     try {
       while (count == 0)
         notEmpty.await();
       Object x = items[takeptr];
       if (++takeptr == items.length) takeptr = 0;
       --count;
       notFull.signal();
       return x;
     } finally {
       lock.unlock();
     }
   }
 }
（ArrayBlockingQueue 类提供了这项功能，因此没有理由去实现这个示例类。）

Condition 实现可以提供不同于 Object 监视器方法的行为和语义，比如受保证的通知排序，或者在执行通知时不需要保持一个锁。如果某个实现提供了这样特殊的语义，则该实现必须记录这些语义。

注意，Condition 实例只是一些普通的对象，它们自身可以用作 synchronized 语句中的目标，并且可以调用自己的 wait 和 notification 监视器方法。获取 Condition 实例的监视器锁或者使用其监视器方法，与获取和该 Condition 相关的 Lock 或使用其 waiting 和 signalling 方法没有什么特定的关系。为了避免混淆，建议除了在其自身的实现中之外，切勿以这种方式使用 Condition 实例。

除非另行说明，否则为任何参数传递 null 值将导致抛出 NullPointerException。

实现注意事项

在等待 Condition 时，允许发生“虚假唤醒”，这通常作为对基础平台语义的让步。对于大多数应用程序，这带来的实际影响很小，因为 Condition 应该总是在一个循环中被等待，并测试正被等待的状态声明。某个实现可以随意移除可能的虚假唤醒，但建议应用程序程序员总是假定这些虚假唤醒可能发生，因此总是在一个循环中等待。

三种形式的条件等待（可中断、不可中断和超时）在一些平台上的实现以及它们的性能特征可能会有所不同。尤其是它可能很难提供这些特性和维护特定语义，比如排序保证。更进一步地说，中断线程实际挂起的能力在所有平台上并不是总是可行的。

因此，并不要求某个实现为所有三种形式的等待定义完全相同的保证或语义，也不要求其支持中断线程的实际挂起。

要求实现清楚地记录每个等待方法提供的语义和保证，在某个实现不支持中断线程的挂起时，它必须遵从此接口中定义的中断语义。

由于中断通常意味着取消，而又通常很少进行中断检查，因此实现可以先于普通方法的返回来对中断进行响应。即使出现在另一个操作后的中断可能会释放线程锁时也是如此。实现应记录此行为。

从以下版本开始：
1.5

方法摘要
void | await() 造成当前线程在接到信号或被中断之前一直处于等待状态。
boolean | await(long time, TimeUnit unit) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
long | awaitNanos(long nanosTimeout) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
void | awaitUninterruptibly() 造成当前线程在接到信号之前一直处于等待状态。
boolean | awaitUntil(Date deadline) 造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。
void | signal() 唤醒一个等待线程。
void | signalAll() 唤醒所有等待线程。

方法详细信息

await

void await()
           throws InterruptedException
造成当前线程在接到信号或被中断之前一直处于等待状态。

与此 Condition 相关的锁以原子方式释放，并且出于线程调度的目的，将禁用当前线程，且在发生以下四种情况之一 以前，当前线程将一直处于休眠状态：

  • 其他某个线程调用此 Condition 的 signal() 方法，并且碰巧将当前线程选为被唤醒的线程；或者
  • 其他某个线程调用此 Condition 的 signalAll() 方法；或者
  • 其他某个线程中断当前线程，且支持中断线程的挂起；或者
  • 发生“虚假唤醒”

在所有情况下，在此方法可以返回当前线程之前，都必须重新获取与此条件有关的锁。在线程返回时，可以保证 它保持此锁。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在支持等待和中断线程挂起时，线程被中断，
则抛出 InterruptedException，并清除当前线程的中断状态。在第一种情况下，没有指定是否在释放锁之前发生中断测试。

实现注意事项

假定调用此方法时，当前线程保持了与此 Condition 有关联的锁。这取决于确定是否为这种情况以及不是时，如何对此作出响应的实现。通常，将抛出一个异常（比如 IllegalMonitorStateException）并且该实现必须对此进行记录。

与响应某个信号而返回的普通方法相比，实现可能更喜欢响应某个中断。在这种情况下，实现必须确保信号被重定向到另一个等待线程（如果有的话）。

抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

awaitUninterruptibly

void awaitUninterruptibly()
造成当前线程在接到信号之前一直处于等待状态。

与此条件相关的锁以原子方式释放，并且出于线程调度的目的，将禁用当前线程，且在发生以下三种情况之一 以前，当前线程将一直处于休眠状态：

  • 其他某个线程调用此 Condition 的 signal() 方法，并且碰巧将当前线程选为被唤醒的线程；或者
  • 其他某个线程调用此 Condition 的 signalAll() 方法；或者
  • 发生“虚假唤醒”

在所有情况下，在此方法可以返回当前线程之前，都必须重新获取与此条件有关的锁。在线程返回时，可以保证 它保持此锁。

如果在进入此方法时设置了当前线程的中断状态，或者在等待时，线程被中断，那么在接到信号之前，它将继续等待。当最终从此方法返回时，仍然将设置其中断状态。

实现注意事项

假定调用此方法时，当前线程保持了与此 Condition 有关联的锁。这取决于确定是否为这种情况以及不是时，如何对此作出响应的实现。通常，将抛出一个异常（比如 IllegalMonitorStateException）并且该实现必须对此进行记录。

awaitNanos

long awaitNanos(long nanosTimeout)
                throws InterruptedException
造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。

与此条件相关的锁以原子方式释放，并且出于线程调度的目的，将禁用当前线程，且在发生以下五种情况之一 以前，当前线程将一直处于休眠状态：

  • 其他某个线程调用此 Condition 的 signal() 方法，并且碰巧将当前线程选为被唤醒的线程；或者
  • 其他某个线程调用此 Condition 的 signalAll() 方法；或者
  • 其他某个线程中断当前线程，且支持中断线程的挂起；或者
  • 已超过指定的等待时间；或者
  • 发生“虚假唤醒”。

在所有情况下，在此方法可以返回当前线程之前，都必须重新获取与此条件有关的锁。在线程返回时，可以保证 它保持此锁。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在支持等待和中断线程挂起时，线程被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。在第一种情况下，没有指定是否在释放锁之前发生中断测试。

在返回时，该方法返回了所剩毫微秒数的一个估计值，以等待所提供的 nanosTimeout 值的时间，如果超时，则返回一个小于等于 0 的值。可以用此值来确定在等待返回但某一等待条件仍不具备的情况下，是否要再次等待，以及再次等待的时间。此方法的典型用法采用以下形式：

 synchronized boolean aMethod(long timeout, TimeUnit unit) {
   long nanosTimeout = unit.toNanos(timeout);
   while (!conditionBeingWaitedFor) {
     if (nanosTimeout > 0)
         nanosTimeout = theCondition.awaitNanos(nanosTimeout);
      else
        return false;
   }
   // ...
 }

设计注意事项：此方法需要一个 nanosecond 参数，以避免在报告剩余时间时出现截断错误。在发生重新等待时，这种精度损失使得程序员难以确保总的等待时间不少于指定等待时间。

实现注意事项

假定调用此方法时，当前线程保持了与此 Condition 有关联的锁。这取决于确定是否为这种情况以及不是时，如何对此作出响应的实现。通常会抛出一个异常（比如 IllegalMonitorStateException）并且该实现必须对此进行记录。

与响应某个信号而返回的普通方法相比，或者与指示所使用的指定等待时间相比，实现可能更喜欢响应某个中断。在任意一种情况下，实现必须确保信号被重定向到另一个等待线程（如果有的话）。

参数：
nanosTimeout - 等待的最长时间，以毫微秒为单位
返回：
nanosTimeout 值减去花费在等待此方法的返回结果的时间的估算。正值可以用作对此方法进行后续调用的参数，来完成等待所需时间结束。小于等于零的值表示没有剩余时间。
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

await

boolean await(long time,
              TimeUnit unit)
              throws InterruptedException
造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。此方法在行为上等效于：
   awaitNanos(unit.toNanos(time)) > 0

参数：
time - 最长等待时间
unit - time 参数的时间单位
返回：
如果在从此方法返回前检测到等待时间超时，则返回 false，否则返回 true
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

awaitUntil

boolean awaitUntil(Date deadline)
                   throws InterruptedException
造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。

与此条件相关的锁以原子方式释放，并且出于线程调度的目的，将禁用当前线程，且在发生以下五种情况之一 以前，当前线程将一直处于休眠状态：

  • 其他某个线程调用此 Condition 的 signal() 方法，并且碰巧将当前线程选为被唤醒的线程；或者
  • 其他某个线程调用此 Condition 的 signalAll() 方法；或者
  • 其他某个线程中断当前线程，且支持中断线程的挂起；或者
  • 指定的最后期限到了；或者
  • 发生“虚假唤醒”。

在所有情况下，在此方法可以返回当前线程之前，都必须重新获取与此条件有关的锁。在线程返回时，可以保证 它保持此锁。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在支持等待和中断线程挂起时，线程被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。在第一种情况下，没有指定是否在释放锁之前发生中断测试。

返回值指示是否到达最后期限，使用方式如下：

 synchronized boolean aMethod(Date deadline) {
   boolean stillWaiting = true;
   while (!conditionBeingWaitedFor) {
     if (stillWaiting)
         stillWaiting = theCondition.awaitUntil(deadline);
      else
        return false;
   }
   // ...
 }

实现注意事项

假定调用此方法时，当前线程保持了与此 Condition 有关联的锁。这取决于确定是否为这种情况以及不是时，如何对此作出响应的实现。通常，将抛出一个异常（比如 IllegalMonitorStateException）并且该实现必须对此进行记录。

与响应某个信号而返回的普通方法相比，或者与指示是否到达指定最终期限相比，实现可能更喜欢响应某个中断。在任意一种情况下，实现必须确保信号被重定向到另一个等待线程（如果有的话）。

参数：
deadline - 一直处于等待状态的绝对时间
返回：
如果在返回时已经到达最后期限，则返回 false，否则返回 true
抛出：
InterruptedException - 如果当前线程被中断（并且支持中断线程挂起）

signal

void signal()
唤醒一个等待线程。

如果所有的线程都在等待此条件，则选择其中的一个唤醒。在从 await 返回之前，该线程必须重新获取锁。

signalAll

void signalAll()
唤醒所有等待线程。

如果所有的线程都在等待此条件，则唤醒所有线程。在从 await 返回之前，每个线程都必须重新获取锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Lock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
接口 Lock

所有已知实现类：
ReentrantLock, ReentrantReadWriteLock.ReadLock, ReentrantReadWriteLock.WriteLock
public interface Lock

Lock 实现提供了比使用 synchronized 方法和语句可获得的更广泛的锁定操作。此实现允许更灵活的结构，可以具有差别很大的属性，可以支持多个相关的 Condition 对象。

锁是控制多个线程对共享资源进行访问的工具。通常，锁提供了对共享资源的独占访问。一次只能有一个线程获得锁，对共享资源的所有访问都需要首先获得锁。不过，某些锁可能允许对共享资源并发访问，如 ReadWriteLock 的读取锁。

synchronized 方法或语句的使用提供了对与每个对象相关的隐式监视器锁的访问，但却强制所有锁获取和释放均要出现在一个块结构中：当获取了多个锁时，它们必须以相反的顺序释放，且必须在与所有锁被获取时相同的词法范围内释放所有锁。

虽然 synchronized 方法和语句的范围机制使得使用监视器锁编程方便了很多，而且还帮助避免了很多涉及到锁的常见编程错误，但有时也需要以更为灵活的方式使用锁。例如，某些遍历并发访问的数据结果的算法要求使用 "hand-over-hand" 或 "chain locking"：获取节点 A 的锁，然后再获取节点 B 的锁，然后释放 A 并获取 C，然后释放 B 并获取 D，依此类推。Lock 接口的实现允许锁在不同的作用范围内获取和释放，并允许以任何顺序获取和释放多个锁，从而支持使用这种技术。

随着灵活性的增加，也带来了更多的责任。不使用块结构锁就失去了使用 synchronized 方法和语句时会出现的锁自动释放功能。在大多数情况下，应该使用以下语句：

     Lock l = ...;
     l.lock();
     try {
         // access the resource protected by this lock
     } finally {
         l.unlock();
     }
锁定和取消锁定出现在不同作用范围中时，必须谨慎地确保保持锁定时所执行的所有代码用 try-finally 或 try-catch 加以保护，以确保在必要时释放锁。

Lock 实现提供了使用 synchronized 方法和语句所没有的其他功能，包括提供了一个非块结构的获取锁尝试 (tryLock())、一个获取可中断锁的尝试 (lockInterruptibly()) 和一个获取超时失效锁的尝试 (tryLock(long, TimeUnit))。

Lock 类还可以提供与隐式监视器锁完全不同的行为和语义，如保证排序、非重入用法或死锁检测。如果某个实现提供了这样特殊的语义，则该实现必须对这些语义加以记录。

注意，Lock 实例只是普通的对象，其本身可以在 synchronized 语句中作为目标使用。获取 Lock 实例的监视器锁与调用该实例的任何 lock() 方法没有特别的关系。为了避免混淆，建议除了在其自身的实现中之外，决不要以这种方式使用 Lock 实例。

除非另有说明，否则为任何参数传递 null 值都将导致抛出 NullPointerException。

内存同步

所有 Lock 实现都必须 实施与内置监视器锁提供的相同内存同步语义，如 The Java Language Specification, Third Edition (17.4 Memory Model) 中所描述的:

  • 成功的 lock 操作与成功的 Lock 操作具有同样的内存同步效应。
  • 成功的 unlock 操作与成功的 Unlock 操作具有同样的内存同步效应。
不成功的锁定与取消锁定操作以及重入锁定/取消锁定操作都不需要任何内存同步效果。

实现注意事项

三种形式的锁获取（可中断、不可中断和定时）在其性能特征、排序保证或其他实现质量上可能会有所不同。而且，对于给定的 Lock 类，可能没有中断正在进行的 锁获取的能力。因此，并不要求实现为所有三种形式的锁获取定义相同的保证或语义，也不要求其支持中断正在进行的锁获取。实现必需清楚地对每个锁定方法所提供的语义和保证进行记录。还必须遵守此接口中定义的中断语义，以便为锁获取中断提供支持：完全支持中断，或仅在进入方法时支持中断。

由于中断通常意味着取消，而通常又很少进行中断检查，因此，相对于普通方法返回而言，实现可能更喜欢响应某个中断。即使出现在另一个操作后的中断可能会释放线程锁时也是如此。实现应记录此行为。

从以下版本开始：
1.5
另请参见：
ReentrantLock, Condition, ReadWriteLock

方法摘要
void | lock() 获取锁。
void | lockInterruptibly() 如果当前线程未被中断，则获取锁。
Condition | newCondition() 返回绑定到此 Lock 实例的新 Condition 实例。
boolean | tryLock() 仅在调用时锁为空闲状态才获取该锁。
boolean | tryLock(long time, TimeUnit unit) 如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。
void | unlock() 释放锁。

方法详细信息

lock

void lock()
获取锁。

如果锁不可用，出于线程调度目的，将禁用当前线程，并且在获得锁之前，该线程将一直处于休眠状态。

实现注意事项

Lock 实现可能能够检测到锁的错误使用，比如会导致死锁的调用，在那种环境下还可能抛出一个 (unchecked) 异常。Lock 实现必须对环境和异常类型进行记录。

lockInterruptibly

void lockInterruptibly()
                       throws InterruptedException
如果当前线程未被中断，则获取锁。

如果锁可用，则获取锁，并立即返回。

如果锁不可用，出于线程调度目的，将禁用当前线程，并且在发生以下两种情况之一以前，该线程将一直处于休眠状态：

  • 锁由当前线程获得；或者
  • 其他某个线程中断当前线程，并且支持对锁获取的中断。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在获取锁时被中断，并且支持对锁获取的中断，
则将抛出 InterruptedException，并清除当前线程的已中断状态。

实现注意事项

在某些实现中可能无法中断锁获取，即使可能，该操作的开销也很大。程序员应该知道可能会发生这种情况。在这种情况下，该实现应该对此进行记录。

相对于普通方法返回而言，实现可能更喜欢响应某个中断。

Lock 实现可能可以检测锁的错误用法，例如，某个调用可能导致死锁，在特定的环境中可能抛出（未经检查的）异常。该 Lock 实现必须对环境和异常类型进行记录。

抛出：
InterruptedException - 如果在获取锁时，当前线程被中断（并且支持对锁获取的中断）。

tryLock

boolean tryLock()
仅在调用时锁为空闲状态才获取该锁。

如果锁可用，则获取锁，并立即返回值 true。如果锁不可用，则此方法将立即返回值 false。

此方法的典型使用语句如下：

      Lock lock = ...;
      if (lock.tryLock()) {
          try {
              // manipulate protected state
          } finally {
              lock.unlock();
          }
      } else {
          // perform alternative actions
      }
此用法可确保如果获取了锁，则会释放锁，如果未获取锁，则不会试图将其释放。

返回：
如果获取了锁，则返回 true；否则返回 false。

tryLock

boolean tryLock(long time,
                TimeUnit unit)
                throws InterruptedException
如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。

如果锁可用，则此方法将立即返回值 true。如果锁不可用，出于线程调度目的，将禁用当前线程，并且在发生以下三种情况之一前，该线程将一直处于休眠状态：

  • 锁由当前线程获得；或者
  • 其他某个线程中断当前线程，并且支持对锁获取的中断；或者
  • 已超过指定的等待时间

如果获得了锁，则返回值 true。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在获取锁时被中断，并且支持对锁获取的中断，
则将抛出 InterruptedException，并会清除当前线程的已中断状态。

如果超过了指定的等待时间，则将返回值 false。如果 time 小于等于 0，该方法将完全不等待。

实现注意事项

在某些实现中可能无法中断锁获取，即使可能，该操作的开销也很大。程序员应该知道可能会发生这种情况。在这种情况下，该实现应该对此进行记录。

相对于普通方法返回而言，实现可能更喜欢响应某个中断，或者报告出现超时情况。

Lock 实现可能可以检测锁的错误用法，例如，某个调用可能导致死锁，在特定的环境中可能抛出（未经检查的）异常。该 Lock 实现必须对环境和异常类型进行记录。

参数：
time - 等待锁的最长时间
unit - time 参数的时间单位
返回：
如果获得了锁，则返回 true；如果在获取锁前超过了等待时间，则返回 false
抛出：
InterruptedException - 如果在获取锁时，当前线程被中断（并且支持对锁获取的中断）

unlock

void unlock()
释放锁。

实现注意事项

Lock 实现通常对哪个线程可以释放锁施加了限制（通常只有锁的保持者可以释放它），如果违背了这个限制，可能会抛出（未经检查的）异常。该 Lock 实现必须对所有限制和异常类型进行记录。

newCondition

Condition newCondition()
返回绑定到此 Lock 实例的新 Condition 实例。

在等待条件前，锁必须由当前线程保持。调用 Condition.await() 将在等待前以原子方式释放锁，并在等待返回前重新获取锁。

实现注意事项

Condition 实例的具体操作依赖于 Lock 实现，并且该实现必须对此加以记录。

返回：
用于此 Lock 实例的新 Condition 实例
抛出：
UnsupportedOperationException - 如果此 Lock 实现不支持条件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LockSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 LockSupport

java.lang.Object
    继承者  java.util.concurrent.locks.LockSupport

public class LockSupport
extends Object

用来创建锁和其他同步类的基本线程阻塞原语。

此类以及每个使用它的线程与一个许可关联（从 Semaphore 类的意义上说）。如果该许可可用，并且可在进程中使用，则调用 park 将立即返回；否则可能 阻塞。如果许可尚不可用，则可以调用 unpark 使其可用。（但与 Semaphore 不同的是，许可不能累积，并且最多只能有一个许可。）

park 和 unpark 方法提供了阻塞和解除阻塞线程的有效方法，并且不会遇到导致过时方法 Thread.suspend 和 Thread.resume 因为以下目的变得不可用的问题：由于许可的存在，调用 park 的线程和另一个试图将其 unpark 的线程之间的竞争将保持活性。此外，如果调用者线程被中断，并且支持超时，则 park 将返回。park 方法还可以在其他任何时间“毫无理由”地返回，因此通常必须在重新检查返回条件的循环里调用此方法。从这个意义上说，park 是“忙碌等待”的一种优化，它不会浪费这么多的时间进行自旋，但是必须将它与 unpark 配对使用才更高效。

三种形式的 park 还各自支持一个 blocker 对象参数。此对象在线程受阻塞时被记录，以允许监视工具和诊断工具确定线程受阻塞的原因。（这样的工具可以使用方法 getBlocker(java.lang.Thread) 访问 blocker。）建议最好使用这些形式，而不是不带此参数的原始形式。在锁实现中提供的作为 blocker 的普通参数是 this。

这些方法被设计用来作为创建高级同步实用工具的工具，对于大多数并发控制应用程序而言，它们本身并不是很有用。park 方法仅设计用于以下形式的构造：

while (!canProceed()) { ... LockSupport.park(this); }
在这里，在调用 park 之前，canProceed 和其他任何动作都不会锁定或阻塞。因为每个线程只与一个许可关联，park 的任何中间使用都可能干扰其预期效果。

示例用法。 以下是一个先进先出 (first-in-first-out) 非重入锁类的框架。

class FIFOMutex {
   private final AtomicBoolean locked = new AtomicBoolean(false);
   private final Queue<Thread> waiters
     = new ConcurrentLinkedQueue<Thread>();

   public void lock() {
     boolean wasInterrupted = false;
     Thread current = Thread.currentThread();
     waiters.add(current);

     // Block while not first in queue or cannot acquire lock
     while (waiters.peek() != current ||
            !locked.compareAndSet(false, true)) {
        LockSupport.park(this);
        if (Thread.interrupted()) // ignore interrupts while waiting
          wasInterrupted = true;
     }

     waiters.remove();
     if (wasInterrupted)          // reassert interrupt status on exit
        current.interrupt();
   }

   public void unlock() {
     locked.set(false);
     LockSupport.unpark(waiters.peek());
   }
 }

方法摘要
static Object | getBlocker(Thread t) 返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。
static void | park() 为了线程调度，禁用当前线程，除非许可可用。
static void | park(Object blocker) 为了线程调度，在许可可用之前禁用当前线程。
static void | parkNanos(long nanos) 为了线程调度禁用当前线程，最多等待指定的等待时间，除非许可可用。
static void | parkNanos(Object blocker, long nanos) 为了线程调度，在许可可用前禁用当前线程，并最多等待指定的等待时间。
static void | parkUntil(long deadline) 为了线程调度，在指定的时限前禁用当前线程，除非许可可用。
static void | parkUntil(Object blocker, long deadline) 为了线程调度，在指定的时限前禁用当前线程，除非许可可用。
static void | unpark(Thread thread) 如果给定线程的许可尚不可用，则使其可用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

unpark

public static void unpark(Thread thread)
如果给定线程的许可尚不可用，则使其可用。如果线程在 park 上受阻塞，则它将解除其阻塞状态。否则，保证下一次调用 park 不会受阻塞。如果给定线程尚未启动，则无法保证此操作有任何效果。

参数：
thread - 要执行 unpark 操作的线程；该参数为 null 表示此操作没有任何效果。

park

public static void park(Object blocker)
为了线程调度，在许可可用之前禁用当前线程。

如果许可可用，则使用该许可，并且该调用立即返回；否则，为线程调度禁用当前线程，并在发生以下三种情况之一前，使其处于休眠状态：

  • 其他某个线程调用将当前线程作为目标调用 unpark；或者
  • 其他某个线程中断当前线程；或者
  • 该调用不合逻辑地（即毫无理由地）返回。

此方法不 报告是哪个线程导致该方法返回。调用者应该重新检查最先导致线程暂停的条件。调用者还可以确定返回时该线程的中断状态。

参数：
blocker - 导致此线程暂停的同步对象
从以下版本开始：
1.6

parkNanos

public static void parkNanos(Object blocker,
                             long nanos)
为了线程调度，在许可可用前禁用当前线程，并最多等待指定的等待时间。

如果许可可用，则使用该许可，并且该调用立即返回；否则，为线程调度禁用当前线程，并在发生以下四种情况之一前，使其处于休眠状态：

  • 其他某个线程将当前线程作为目标调用 unpark；或者
  • 其他某个线程中断当前线程；或者
  • 已超过指定的等待时间；或者
  • 该调用不合逻辑地（即毫无理由地）返回。

此方法不 报告是哪个线程导致该方法返回。调用者应该重新检查最先导致线程暂停的条件。调用者还可以确定返回时该线程的中断状态或已过的时间。

参数：
blocker - 导致此线程暂停的同步对象
nanos - 要等待的最大毫秒数
从以下版本开始：
1.6

parkUntil

public static void parkUntil(Object blocker,
                             long deadline)
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。

如果许可可用，则使用该许可，并且该调用立即返回；否则，为线程调度禁用当前线程，并在发生以下四种情况之一前，使其处于休眠状态：

  • 其他某个线程将当前线程作为目标调用 unpark；或者
  • 其他某个线程中断当前线程；或者
  • 指定时限已过；或者
  • 该调用不合逻辑地（即毫无理由地）返回。

此方法不 报告是哪个线程导致该方法返回。调用者应该重新检查最先导致线程暂停的条件。调用者还可以确定返回时该线程的中断状态或当前时间。

参数：
blocker - 导致此线程暂停的同步对象
deadline - 要等待的绝对时间，用相对于历元 (Epoch) 的毫秒数值表示
从以下版本开始：
1.6

getBlocker

public static Object getBlocker(Thread t)
返回提供给最近一次尚未解除阻塞的 park 方法调用的 blocker 对象，如果该调用不受阻塞，则返回 null。返回的值只是一个瞬间快照，即由于未解除阻塞或者在不同的 blocker 对象上受阻而具有的线程。

返回：
blocker
从以下版本开始：
1.6

park

public static void park()
为了线程调度，禁用当前线程，除非许可可用。

如果许可可用，则使用该许可，并且该调用立即返回；否则，为线程调度禁用当前线程，并在发生以下三种情况之一以前，使其处于休眠状态：

  • 其他某个线程将当前线程作为目标调用 unpark；或者
  • 其他某个线程中断当前线程；或者
  • 该调用不合逻辑地（即毫无理由地）返回。

此方法并不 报告是哪个线程导致该方法返回。调用者应该重新检查最先导致线程暂停的条件。调用者还可以确定线程返回时的中断状态。

parkNanos

public static void parkNanos(long nanos)
为了线程调度禁用当前线程，最多等待指定的等待时间，除非许可可用。

如果许可可用，则使用该许可，并且该调用立即返回；否则，为线程调度禁用当前线程，并在发生以下四种情况之一以前，将其处于休眠状态：

  • 其他某个线程将当前线程作为目标调用 unpark；或者
  • 其他某个线程中断当前线程；或者
  • 已超过指定的等待时间；或者
  • 该调用不合逻辑地（即无缘无故地）返回。

此方法并不 报告是哪个线程导致该方法返回。调用者应该重新检查最先导致线程暂停的条件。调用者还可以确定线程返回时的中断状态或所用的时间。

参数：
nanos - 要等待的最大毫秒数

parkUntil

public static void parkUntil(long deadline)
为了线程调度，在指定的时限前禁用当前线程，除非许可可用。

如果许可可用，则使用该许可，并且调用立即返回；否则，为线程调度禁用当前线程，并在发生以下四种情况之一以前，将其处于休眠状态：

  • 其他某个线程将当前线程作为目标调用 unpark；或者
  • 其他某个线程中断当前线程；或者
  • 指定的最后期限已过；或者
  • 该调用不合逻辑地（即毫无理由地）返回。

此方法并不 报告是哪个线程导致该方法返回。调用者应该重新检查最先导致线程暂停的条件。调用者还可以确定线程返回时的中断状态或当前时间。

参数：
deadline - 要等待的绝对时间，用相对于历元的毫秒数值表示
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReadWriteLock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
接口 ReadWriteLock

所有已知实现类：
ReentrantReadWriteLock
public interface ReadWriteLock

ReadWriteLock 维护了一对相关的锁，一个用于只读操作，另一个用于写入操作。只要没有 writer，读取锁可以由多个 reader 线程同时保持。写入锁是独占的。

所有 ReadWriteLock 实现都必须保证 writeLock 操作的内存同步效果也要保持与相关 readLock 的联系。也就是说，成功获取读锁的线程会看到写入锁之前版本所做的所有更新。

与互斥锁相比，读-写锁允许对共享数据进行更高级别的并发访问。虽然一次只有一个线程（writer 线程）可以修改共享数据，但在许多情况下，任何数量的线程可以同时读取共享数据（reader 线程），读-写锁利用了这一点。从理论上讲，与互斥锁相比，使用读-写锁所允许的并发性增强将带来更大的性能提高。在实践中，只有在多处理器上并且只在访问模式适用于共享数据时，才能完全实现并发性增强。

与互斥锁相比，使用读-写锁能否提升性能则取决于读写操作期间读取数据相对于修改数据的频率，以及数据的争用——即在同一时间试图对该数据执行读取或写入操作的线程数。例如，某个最初用数据填充并且之后不经常对其进行修改的 collection，因为经常对其进行搜索（比如搜索某种目录），所以这样的 collection 是使用读-写锁的理想候选者。但是，如果数据更新变得频繁，数据在大部分时间都被独占锁，这时，就算存在并发性增强，也是微不足道的。更进一步地说，如果读取操作所用时间太短，则读-写锁实现（它本身就比互斥锁复杂）的开销将成为主要的执行成本，在许多读-写锁实现仍然通过一小段代码将所有线程序列化时更是如此。最终，只有通过分析和测量，才能确定应用程序是否适合使用读-写锁。

尽管读-写锁的基本操作是直截了当的，但实现仍然必须作出许多决策，这些决策可能会影响给定应用程序中读-写锁的效果。这些策略的例子包括：

  • 在 writer 释放写入锁时，reader 和 writer 都处于等待状态，在这时要确定是授予读取锁还是授予写入锁。Writer 优先比较普遍，因为预期写入所需的时间较短并且不那么频繁。Reader 优先不太普遍，因为如果 reader 正如预期的那样频繁和持久，那么它将导致对于写入操作来说较长的时延。公平或者“按次序”实现也是有可能的。
  • 在 reader 处于活动状态而 writer 处于等待状态时，确定是否向请求读取锁的 reader 授予读取锁。Reader 优先会无限期地延迟 writer，而 writer 优先会减少可能的并发。
  • 确定是否重新进入锁：可以使用带有写入锁的线程重新获取它吗？可以在保持写入锁的同时获取读取锁吗？可以重新进入写入锁本身吗？
  • 可以将写入锁在不允许其他 writer 干涉的情况下降级为读取锁吗？可以优先于其他等待的 reader 或 writer 将读取锁升级为写入锁吗？
当评估给定实现是否适合您的应用程序时，应该考虑所有这些情况。

从以下版本开始：
1.5
另请参见：
ReentrantReadWriteLock, Lock, ReentrantLock

方法摘要
Lock | readLock() 返回用于读取操作的锁。
Lock | writeLock() 返回用于写入操作的锁。

方法详细信息

readLock

Lock readLock()
返回用于读取操作的锁。

返回：
用于读取操作的锁。

writeLock

Lock writeLock()
返回用于写入操作的锁。

返回：
用于写入操作的锁。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReentrantLock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 ReentrantLock

java.lang.Object
    继承者  java.util.concurrent.locks.ReentrantLock
所有已实现的接口：
Serializable, Lock
public class ReentrantLock
extends Object
implements Lock, Serializable

一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。

ReentrantLock 将由最近成功获得锁，并且还没有释放该锁的线程所拥有。当锁没有被另一个线程所拥有时，调用 lock 的线程将成功获取该锁并返回。如果当前线程已经拥有该锁，此方法将立即返回。可以使用 isHeldByCurrentThread() 和 getHoldCount() 方法来检查此情况是否发生。

此类的构造方法接受一个可选的公平 参数。当设置为 true 时，在多个线程的争用下，这些锁倾向于将访问权授予等待时间最长的线程。否则此锁将无法保证任何特定访问顺序。与采用默认设置（使用不公平锁）相比，使用公平锁的程序在许多线程访问时表现为很低的总体吞吐量（即速度很慢，常常极其慢），但是在获得锁和保证锁分配的均衡性时差异较小。不过要注意的是，公平锁不能保证线程调度的公平性。因此，使用公平锁的众多线程中的一员可能获得多倍的成功机会，这种情况发生在其他活动线程没有被处理并且目前并未持有锁时。还要注意的是，未定时的 tryLock 方法并没有使用公平设置。因为即使其他线程正在等待，只要该锁是可用的，此方法就可以获得成功。

建议总是 立即实践，使用 lock 块来调用 try，在之前/之后的构造中，最典型的代码如下：

 class X {
   private final ReentrantLock lock = new ReentrantLock();
   // ...

   public void m() {
     lock.lock();  // block until condition holds
     try {
       // ... method body
     } finally {
       lock.unlock()
     }
   }
 }

除了实现 Lock 接口，此类还定义了 isLocked 和 getLockQueueLength 方法，以及一些相关的 protected 访问方法，这些方法对检测和监视可能很有用。

该类的序列化与内置锁的行为方式相同：一个反序列化的锁处于解除锁定状态，不管它被序列化时的状态是怎样的。

此锁最多支持同一个线程发起的 2147483648 个递归锁。试图超过此限制会导致由锁方法抛出的 Error。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ReentrantLock()
创建一个 ReentrantLock 的实例。
ReentrantLock(boolean fair)
创建一个具有给定公平策略的 ReentrantLock。
方法摘要
int | getHoldCount() 查询当前线程保持此锁的次数。
protected Thread | getOwner() 返回目前拥有此锁的线程，如果此锁不被任何线程拥有，则返回 null。
protected Collection<Thread> | getQueuedThreads() 返回一个 collection，它包含可能正等待获取此锁的线程。
int | getQueueLength() 返回正等待获取此锁的线程估计数。
protected Collection<Thread> | getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。
int | getWaitQueueLength(Condition condition) 返回等待与此锁相关的给定条件的线程估计数。
boolean | hasQueuedThread(Thread thread) 查询给定线程是否正在等待获取此锁。
boolean | hasQueuedThreads() 查询是否有些线程正在等待获取此锁。
boolean | hasWaiters(Condition condition) 查询是否有些线程正在等待与此锁有关的给定条件。
boolean | isFair() 如果此锁的公平设置为 true，则返回 true。
boolean | isHeldByCurrentThread() 查询当前线程是否保持此锁。
boolean | isLocked() 查询此锁是否由任意线程保持。
void | lock() 获取锁。
void | lockInterruptibly() 如果当前线程未被中断，则获取锁。
Condition | newCondition() 返回用来与此 Lock 实例一起使用的 Condition 实例。
String | toString() 返回标识此锁及其锁定状态的字符串。
boolean | tryLock() 仅在调用时锁未被另一个线程保持的情况下，才获取该锁。
boolean | tryLock(long timeout, TimeUnit unit) 如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。
void | unlock() 试图释放此锁。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReentrantLock

public ReentrantLock()
创建一个 ReentrantLock 的实例。这等同于使用 ReentrantLock(false)。

ReentrantLock

public ReentrantLock(boolean fair)
创建一个具有给定公平策略的 ReentrantLock。

参数：
fair - 如果此锁应该使用公平的排序策略，则该参数为 true
方法详细信息

lock

public void lock()
获取锁。

如果该锁没有被另一个线程保持，则获取该锁并立即返回，将锁的保持计数设置为 1。

如果当前线程已经保持该锁，则将保持计数加 1，并且该方法立即返回。

如果该锁被另一个线程保持，则出于线程调度的目的，禁用当前线程，并且在获得锁之前，该线程将一直处于休眠状态，此时锁保持计数被设置为 1。

指定者：
接口 Lock 中的 lock

lockInterruptibly

public void lockInterruptibly()
                       throws InterruptedException
如果当前线程未被中断，则获取锁。

如果该锁没有被另一个线程保持，则获取该锁并立即返回，将锁的保持计数设置为 1。

如果当前线程已经保持此锁，则将保持计数加 1，并且该方法立即返回。

如果锁被另一个线程保持，则出于线程调度目的，禁用当前线程，并且在发生以下两种情况之一以前，该线程将一直处于休眠状态：

  • 锁由当前线程获得；或者
  • 其他某个线程中断当前线程。

如果当前线程获得该锁，则将锁保持计数设置为 1。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在等待获取锁的同时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。

在此实现中，因为此方法是一个显式中断点，所以要优先考虑响应中断，而不是响应锁的普通获取或重入获取。

指定者：
接口 Lock 中的 lockInterruptibly
抛出：
InterruptedException - 如果当前线程已中断。

tryLock

public boolean tryLock()
仅在调用时锁未被另一个线程保持的情况下，才获取该锁。

如果该锁没有被另一个线程保持，并且立即返回 true 值，则将锁的保持计数设置为 1。即使已将此锁设置为使用公平排序策略，但是调用 tryLock() 仍将 立即获取锁（如果有可用的），而不管其他线程当前是否正在等待该锁。在某些情况下，此“闯入”行为可能很有用，即使它会打破公平性也如此。如果希望遵守此锁的公平设置，则使用 tryLock(0, TimeUnit.SECONDS) ，它几乎是等效的（也检测中断）。

如果当前线程已经保持此锁，则将保持计数加 1，该方法将返回 true。

如果锁被另一个线程保持，则此方法将立即返回 false 值。

指定者：
接口 Lock 中的 tryLock
返回：
如果锁是自由的并且被当前线程获取，或者当前线程已经保持该锁，则返回 true；否则返回 false

tryLock

public boolean tryLock(long timeout,
                       TimeUnit unit)
                throws InterruptedException
如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。

如果该锁没有被另一个线程保持，并且立即返回 true 值，则将锁的保持计数设置为 1。如果为了使用公平的排序策略，已经设置此锁，并且其他线程都在等待该锁，则不会 获取一个可用的锁。这与 tryLock() 方法相反。如果想使用一个允许闯入公平锁的定时 tryLock，那么可以将定时形式和不定时形式组合在一起：

if (lock.tryLock() || lock.tryLock(timeout, unit) ) { ... }

如果当前线程已经保持此锁，则将保持计数加 1，该方法将返回 true。

如果锁被另一个线程保持，则出于线程调度目的，禁用当前线程，并且在发生以下三种情况之一以前，该线程将一直处于休眠状态：

  • 锁由当前线程获得；或者
  • 其他某个线程中断 当前线程；或者
  • 已超过指定的等待时间

如果获得该锁，则返回 true 值，并将锁保持计数设置为 1。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在等待获取锁的同时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果超出了指定的等待时间，则返回值为 false。如果该时间小于等于 0，则此方法根本不会等待。

在此实现中，因为此方法是一个显式中断点，所以要优先考虑响应中断，而不是响应锁的普通获取或重入获取，或者报告所用的等待时间。

指定者：
接口 Lock 中的 tryLock
参数：
timeout - 等待锁的时间
unit - timeout 参数的时间单位
返回：
如果锁是自由的并且由当前线程获取，或者当前线程已经保持该锁，则返回 true；如果在获取该锁之前已经到达等待时间，则返回 false
抛出：
InterruptedException - 如果当前线程被中断
NullPointerException - 如果时间单位为 null

unlock

public void unlock()
试图释放此锁。

如果当前线程是此锁所有者，则将保持计数减 1。如果保持计数现在为 0，则释放该锁。如果当前线程不是此锁的持有者，则抛出 IllegalMonitorStateException。

指定者：
接口 Lock 中的 unlock
抛出：
IllegalMonitorStateException - 如果当前线程没有保持此锁

newCondition

public Condition newCondition()
返回用来与此 Lock 实例一起使用的 Condition 实例。

在使用内置监视器锁时，返回的 Condition 实例支持与 Object 的监视器方法（wait、notify 和 notifyAll）相同的用法。

  • 在调用 Condition、waiting 或 signalling 这些方法中的任意一个方法时，如果没有保持此锁，则将抛出 IllegalMonitorStateException。
  • 在调用 waiting 条件方法时，将释放锁，并在这些方法返回之前，重新获取该锁，将锁保持计数恢复为调用方法时所持有的值。
  • 如果线程在等待时被中断，则等待将终止，并将抛出 InterruptedException，清除线程的中断状态。
  • 等待线程按 FIFO 顺序收到信号。
  • 等待方法返回的线程重新获取锁的顺序与线程最初获取锁的顺序相同，在默认情况下，未指定此顺序，但对于公平 锁，它们更倾向于那些等待时间最长的线程。

指定者：
接口 Lock 中的 newCondition
返回：
Condition 对象

getHoldCount

public int getHoldCount()
查询当前线程保持此锁的次数。

对于与解除锁操作不匹配的每个锁操作，线程都会保持一个锁。

保持计数信息通常只用于测试和调试。例如，如果不应该使用已经保持的锁进入代码的某一部分，则可以声明如下：

 class X {
   ReentrantLock lock = new ReentrantLock();
   // ...
   public void m() {
     assert lock.getHoldCount() == 0;
     lock.lock();
     try {
       // ... method body
     } finally {
       lock.unlock();
     }
   }
 }

返回：
当前线程保持此锁的次数，如果此锁未被当前线程保持过，则返回 0

isHeldByCurrentThread

public boolean isHeldByCurrentThread()
查询当前线程是否保持此锁。

与内置监视器锁的 Thread.holdsLock(java.lang.Object) 方法类似，此方法通常用于调试和测试。例如，只在保持某个锁时才应调用的方法可以声明如下：

 class X {
   ReentrantLock lock = new ReentrantLock();
   // ...

   public void m() {
       assert lock.isHeldByCurrentThread();
       // ... method body
   }
 }

还可以用此方法来确保某个重入锁是否以非重入方式使用的，例如：

 class X {
   ReentrantLock lock = new ReentrantLock();
   // ...

   public void m() {
       assert !lock.isHeldByCurrentThread();
       lock.lock();
       try {
           // ... method body
       } finally {
           lock.unlock();
       }
   }
 }

返回：
如果当前线程保持此锁，则返回 true；否则返回 false

isLocked

public boolean isLocked()
查询此锁是否由任意线程保持。此方法用于监视系统状态，不用于同步控制。

返回：
如果任意线程保持此锁，则返回 true；否则返回 false

isFair

public final boolean isFair()
如果此锁的公平设置为 true，则返回 true。

返回：
如果此锁的公平设置为 true，则返回 true

getOwner

protected Thread getOwner()
返回目前拥有此锁的线程，如果此锁不被任何线程拥有，则返回 null。当此方法被不是拥有者的线程调用，返回值反映当前锁状态的最大近似值。 例如，拥有者可以暂时为 null，也就是说有些线程试图获取该锁，但还没有实现。此方法用于加快子类的构造速度，提供更多的锁监视设施。

返回：
拥有者，如果没有，则返回 null

hasQueuedThreads

public final boolean hasQueuedThreads()
查询是否有些线程正在等待获取此锁。注意，因为随时可能发生取消，所以返回 true 并不保证有其他线程将获取此锁。此方法主要用于监视系统状态。

返回：
如果可能有其他线程正在等待获取锁，则返回 true

hasQueuedThread

public final boolean hasQueuedThread(Thread thread)
查询给定线程是否正在等待获取此锁。注意，因为随时可能发生取消，所以返回 true 并不保证此线程将获取此锁。此方法主要用于监视系统状态。

参数：
thread - 线程
返回：
如果给定线程已加入队列并且正在等待此锁，则返回 true
抛出：
NullPointerException - 如果 thread 为 null

getQueueLength

public final int getQueueLength()
返回正等待获取此锁的线程估计数。该值仅是估计的数字，因为在此方法遍历内部数据结构的同时，线程的数目可能动态地变化。此方法用于监视系统状态，不用于同步控制。

返回：
正在等待此锁的线程估计数

getQueuedThreads

protected Collection<Thread> getQueuedThreads()
返回一个 collection，它包含可能正等待获取此锁的线程。因为在构造此结果的同时实际的线程 set 可能动态地变化，所以返回的 collection 仅是尽力的估计值。所返回 collection 中的元素没有特定的顺序。此方法用于加快子类的构造速度，以提供更多的监视设施。

返回：
线程的 collection

hasWaiters

public boolean hasWaiters(Condition condition)
查询是否有些线程正在等待与此锁有关的给定条件。注意，因为随时可能发生超时和中断，所以返回 true 并不保证将来某个 signal 将唤醒线程。此方法主要用于监视系统状态。

参数：
condition - 条件
返回：
如果有任何等待的线程，则返回 true
抛出：
IllegalMonitorStateException - 如果没有保持此锁
IllegalArgumentException - 如果给定 condition 与此锁无关
NullPointerException - 如果 condition 为 null

getWaitQueueLength

public int getWaitQueueLength(Condition condition)
返回等待与此锁相关的给定条件的线程估计数。注意，因为随时可能发生超时和中断，所以只能将估计值作为实际等待线程数的上边界。此方法用于监视系统状态，不用于同步控制。

参数：
condition - 条件
返回：
等待线程的估计数
抛出：
IllegalMonitorStateException - 如果没有保持此锁
IllegalArgumentException - 如果给定 condition 与此锁无关
NullPointerException - 如果 condition 为 null

getWaitingThreads

protected Collection<Thread> getWaitingThreads(Condition condition)
返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。因为在构造此结果的同时实际的线程 set 可能动态地变化，所以返回 collection 的元素只是尽力的估计值。所返回 collection 中的元素没有特定的顺序。此方法用于加快子类的构造速度，提供更多的条件监视设施。

参数：
condition - 条件
返回：
线程的 collection
抛出：
IllegalMonitorStateException - 如果没有保持此锁
IllegalArgumentException - 如果给定 condition 与此锁无关
NullPointerException - 如果 condition 为 null

toString

public String toString()
返回标识此锁及其锁定状态的字符串。该状态括在括号中，它包括字符串 "Unlocked" 或字符串 "Locked by"，后跟拥有线程的名称。

覆盖：
类 Object 中的 toString
返回：
标识此锁及其锁定状态的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReentrantReadWriteLock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 ReentrantReadWriteLock

java.lang.Object
    继承者  java.util.concurrent.locks.ReentrantReadWriteLock
所有已实现的接口：
Serializable, ReadWriteLock
public class ReentrantReadWriteLock
extends Object
implements ReadWriteLock, Serializable

支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。

此类具有以下属性：

  • 获取顺序

    此类不会将读取者优先或写入者优先强加给锁访问的排序。但是，它确实支持可选的公平 策略。

    非公平模式（默认）
    当非公平地（默认）构造时，未指定进入读写锁的顺序，受到 reentrancy 约束的限制。连续竞争的非公平锁可能无限期地推迟一个或多个 reader 或 writer 线程，但吞吐量通常要高于公平锁。

    公平模式
    当公平地构造线程时，线程利用一个近似到达顺序的策略来争夺进入。当释放当前保持的锁时，可以为等待时间最长的单个 writer 线程分配写入锁，如果有一组等待时间大于所有正在等待的 writer 线程 的 reader 线程，将为该组分配写入锁。

    如果保持写入锁，或者有一个等待的 writer 线程，则试图获得公平读取锁（非重入地）的线程将会阻塞。直到当前最旧的等待 writer 线程已获得并释放了写入锁之后，该线程才会获得读取锁。当然，如果等待 writer 放弃其等待，而保留一个或更多 reader 线程为队列中带有写入锁自由的时间最长的 waiter，则将为那些 reader 分配读取锁。

    试图获得公平写入锁的（非重入地）的线程将会阻塞，除非读取锁和写入锁都自由（这意味着没有等待线程）。（注意，非阻塞 ReentrantReadWriteLock.ReadLock.tryLock() 和 ReentrantReadWriteLock.WriteLock.tryLock() 方法不会遵守此公平设置，并将获得锁（如果可能），不考虑等待线程）。

  • 重入

    此锁允许 reader 和 writer 按照 ReentrantLock 的样式重新获取读取锁或写入锁。在写入线程保持的所有写入锁都已经释放后，才允许重入 reader 使用它们。

    此外，writer 可以获取读取锁，但反过来则不成立。在其他应用程序中，当在调用或回调那些在读取锁状态下执行读取操作的方法期间保持写入锁时，重入很有用。如果 reader 试图获取写入锁，那么将永远不会获得成功。

  • 锁降级

    重入还允许从写入锁降级为读取锁，其实现方式是：先获取写入锁，然后获取读取锁，最后释放写入锁。但是，从读取锁升级到写入锁是不可能的。

  • 锁获取的中断

    读取锁和写入锁都支持锁获取期间的中断。

  • Condition 支持

    写入锁提供了一个 Condition 实现，对于写入锁来说，该实现的行为与 ReentrantLock.newCondition() 提供的 Condition 实现对 ReentrantLock 所做的行为相同。当然，此 Condition 只能用于写入锁。

    读取锁不支持 Condition，readLock().newCondition() 会抛出 UnsupportedOperationException。

  • 监测

    此类支持一些确定是保持锁还是争用锁的方法。这些方法设计用于监视系统状态，而不是同步控制。

此类行为的序列化方式与内置锁的相同：反序列化的锁处于解除锁状态，无论序列化该锁时其状态如何。

示例用法。下面的代码展示了如何利用重入来执行升级缓存后的锁降级（为简单起见，省略了异常处理）：

 class CachedData {
   Object data;
   volatile boolean cacheValid;
   ReentrantReadWriteLock rwl = new ReentrantReadWriteLock();

   void processCachedData() {
     rwl.readLock().lock();
     if (!cacheValid) {
        // Must release read lock before acquiring write lock
        rwl.readLock().unlock();
        rwl.writeLock().lock();
        // Recheck state because another thread might have acquired
        //   write lock and changed state before we did.
        if (!cacheValid) {
          data = ...
          cacheValid = true;
        }
        // Downgrade by acquiring read lock before releasing write lock
        rwl.readLock().lock();
        rwl.writeLock().unlock(); // Unlock write, still hold read
     }

     use(data);
     rwl.readLock().unlock();
   }
 }
在使用某些种类的 Collection 时，可以使用 ReentrantReadWriteLock 来提高并发性。通常，在预期 collection 很大，读取者线程访问它的次数多于写入者线程，并且 entail 操作的开销高于同步开销时，这很值得一试。例如，以下是一个使用 TreeMap 的类，预期它很大，并且能被同时访问。
class RWDictionary {
    private final Map<String, Data> m = new TreeMap<String, Data>();
    private final ReentrantReadWriteLock rwl = new ReentrantReadWriteLock();
    private final Lock r = rwl.readLock();
    private final Lock w = rwl.writeLock();

    public Data get(String key) {
        r.lock();
        try { return m.get(key); }
        finally { r.unlock(); }
    }
    public String[] allKeys() {
        r.lock();
        try { return m.keySet().toArray(); }
        finally { r.unlock(); }
    }
    public Data put(String key, Data value) {
        w.lock();
        try { return m.put(key, value); }
        finally { w.unlock(); }
    }
    public void clear() {
        w.lock();
        try { m.clear(); }
        finally { w.unlock(); }
    }
 }

实现注意事项：

此锁最多支持 65535 个递归写入锁和 65535 个读取锁。试图超出这些限制将导致锁方法抛出 Error。

从以下版本开始：
1.5
另请参见：
序列化表格

嵌套类摘要
static class | ReentrantReadWriteLock.ReadLock readLock() 方法返回的锁。
static class | ReentrantReadWriteLock.WriteLock writeLock() 方法返回的锁。
构造方法摘要
ReentrantReadWriteLock()
使用默认（非公平）的排序属性创建一个新的 ReentrantReadWriteLock。
ReentrantReadWriteLock(boolean fair)
使用给定的公平策略创建一个新的 ReentrantReadWriteLock。
方法摘要
protected Thread | getOwner() 返回当前拥有写入锁的线程，如果没有这样的线程，则返回 null。
protected Collection<Thread> | getQueuedReaderThreads() 返回一个 collection，它包含可能正在等待获取读取锁的线程。
protected Collection<Thread> | getQueuedThreads() 返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。
protected Collection<Thread> | getQueuedWriterThreads() 返回一个 collection，它包含可能正在等待获取写入锁的线程。
int | getQueueLength() 返回等待获取读取或写入锁的线程估计数目。
int | getReadHoldCount() 查询当前线程在此锁上保持的重入读取锁数量。
int | getReadLockCount() 查询为此锁保持的读取锁数量。
protected Collection<Thread> | getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
int | getWaitQueueLength(Condition condition) 返回正等待与写入锁相关的给定条件的线程估计数目。
int | getWriteHoldCount() 查询当前线程在此锁上保持的重入写入锁数量。
boolean | hasQueuedThread(Thread thread) 查询是否给定线程正在等待获取读取或写入锁。
boolean | hasQueuedThreads() 查询是否所有的线程正在等待获取读取或写入锁。
boolean | hasWaiters(Condition condition) 查询是否有些线程正在等待与写入锁有关的给定条件。
boolean | isFair() 如果此锁将公平性设置为 ture，则返回 true。
boolean | isWriteLocked() 查询是否某个线程保持了写入锁。
boolean | isWriteLockedByCurrentThread() 查询当前线程是否保持了写入锁。
ReentrantReadWriteLock.ReadLock | readLock() 返回用于读取操作的锁。
String | toString() 返回标识此锁及其锁状态的字符串。
ReentrantReadWriteLock.WriteLock | writeLock() 返回用于写入操作的锁。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReentrantReadWriteLock

public ReentrantReadWriteLock()
使用默认（非公平）的排序属性创建一个新的 ReentrantReadWriteLock。

ReentrantReadWriteLock

public ReentrantReadWriteLock(boolean fair)
使用给定的公平策略创建一个新的 ReentrantReadWriteLock。

参数：
fair - 如果此锁应该使用公平排序策略，则该参数的值为 true
方法详细信息

writeLock

public ReentrantReadWriteLock.WriteLock writeLock()
从接口 ReadWriteLock 复制的描述
返回用于写入操作的锁。

指定者：
接口 ReadWriteLock 中的 writeLock
返回：
用于写入操作的锁。

readLock

public ReentrantReadWriteLock.ReadLock readLock()
从接口 ReadWriteLock 复制的描述
返回用于读取操作的锁。

指定者：
接口 ReadWriteLock 中的 readLock
返回：
用于读取操作的锁。

isFair

public final boolean isFair()
如果此锁将公平性设置为 ture，则返回 true。

返回：
如果此锁将公平性设置为 ture，则返回 true

getOwner

protected Thread getOwner()
返回当前拥有写入锁的线程，如果没有这样的线程，则返回 null。当通过不是所有者的线程调用此方法时，返回值反映当前锁状态的最接近近似值。例如，即使存在试图获得锁的线程，但是在它还没有获得前，所有者可能暂时为 null。设计此方法是为了便于构造提供更多扩展的锁监视设施的子类。

返回：
所有者；如果没有所有者，则返回 null

getReadLockCount

public int getReadLockCount()
查询为此锁保持的读取锁数量。此方法设计用于监视系统状态，而不是同步控制。

返回：
所保持的读取锁数量。

isWriteLocked

public boolean isWriteLocked()
查询是否某个线程保持了写入锁。此方法设计用于监视系统状态，而不是同步控制。

返回：
如果某个线程保持写入锁，则返回 true；否则返回 false

isWriteLockedByCurrentThread

public boolean isWriteLockedByCurrentThread()
查询当前线程是否保持了写入锁。

返回：
如果当前线程保持写入锁，则返回 true；否则返回 false

getWriteHoldCount

public int getWriteHoldCount()
查询当前线程在此锁上保持的重入写入锁数量。对于与解除锁操作不匹配的每个锁操作，writer 线程都会为其保持一个锁。

返回：
当前线程保持的写入锁数量，如果当前线程从未保持过写入锁，则返回 0

getReadHoldCount

public int getReadHoldCount()
查询当前线程在此锁上保持的重入读取锁数量。对于与解除锁操作不匹配的每个锁操作，reader 线程都会为其保持一个锁。

返回：
当前线程保持的读取锁数量；如果当前线程从未保持过读取锁，则返回 0
从以下版本开始：
1.6

getQueuedWriterThreads

protected Collection<Thread> getQueuedWriterThreads()
返回一个 collection，它包含可能正在等待获取写入锁的线程。因为在构成此结果的同时，实际的线程 set 可能不断发生变化，所以返回的 collection 仅是尽力而为获得的估计值。所返回 collection 的元素没有特定的顺序。设计此方法是为了便于构造提供更多扩展的锁监视器设施的子类。

返回：
线程的 collection

getQueuedReaderThreads

protected Collection<Thread> getQueuedReaderThreads()
返回一个 collection，它包含可能正在等待获取读取锁的线程。因为在构成此结果的同时，实际的线程 set 可能不断发生变化，所以返回的 collection 仅是尽力而为获得的估计值。所返回 collection 的元素没有特定的顺序。设计此方法是为了便于构造提供更多扩展的锁监视器设施的子类。

返回：
线程的 collection

hasQueuedThreads

public final boolean hasQueuedThreads()
查询是否所有的线程正在等待获取读取或写入锁。注意，因为随时可能发生取消操作，所以返回 true 并不保证任何其他线程将获取锁。此方法主要用于监视系统状态。

返回：
如果有其他线程正等待获取锁，则返回 true

hasQueuedThread

public final boolean hasQueuedThread(Thread thread)
查询是否给定线程正在等待获取读取或写入锁。注意，因为随时可能发生取消操作，所以返回 true 并不保证此线程将获取锁。此方法主要用于监视系统状态。

参数：
thread - 线程
返回：
如果将给定的线程加入等待此锁的队列，则返回 true
抛出：
NullPointerException - 如果线程为 null

getQueueLength

public final int getQueueLength()
返回等待获取读取或写入锁的线程估计数目。因为在此方法遍历内部数据结构时，可以动态地更改线程数，所以该值只能是一个估计值。此方法设计用于监视系统状态，而不是同步控制。

返回：
正在等待此锁的线程估计数目

getQueuedThreads

protected Collection<Thread> getQueuedThreads()
返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。因为在构造此结果的同时，实际的线程 set 可能不断发生变化，所以返回的 collection 仅是尽力而为获得的估计值。所返回 collection 中的元素没有特定的顺序。此方法用于加快子类的构造速度，提供更多的监视设施。

返回：
线程的 collection

hasWaiters

public boolean hasWaiters(Condition condition)
查询是否有些线程正在等待与写入锁有关的给定条件。注意，因为随时可能发生超时和中断，所以返回 true 并不保证将来某个 signal 将唤醒任何线程。此方法主要用于监视系统状态。

参数：
condition - 条件
返回：
如果有等待的线程，则返回 true
抛出：
IllegalMonitorStateException - 如果没有保持此锁
IllegalArgumentException - 如果给定的条件与此锁无关
NullPointerException - 如果条件为 null

getWaitQueueLength

public int getWaitQueueLength(Condition condition)
返回正等待与写入锁相关的给定条件的线程估计数目。注意，因为随时可能发生超时和中断，所以只能将估计值作为实际等待线程数的上限。此方法设计用于监视系统状态，而不是同步控制。

参数：
condition - 条件
返回：
等待线程的估计数
抛出：
IllegalMonitorStateException - 如果没有保持此锁
IllegalArgumentException - 如果给定的条件与此锁无关
NullPointerException - 如果条件为 null

getWaitingThreads

protected Collection<Thread> getWaitingThreads(Condition condition)
返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。因为在构造此结果的同时，实际的线程 set 可能不断发生变化，所以返回的 collection 仅是尽力而为获得的估计值。所返回 collection 中的元素没有特定的顺序。此方法用于加快子类的构造速度，提供更多的条件监视设施。

参数：
condition - 条件
返回：
线程的 collection
抛出：
IllegalMonitorStateException - 如果没有保持此锁
IllegalArgumentException - 如果给定 condition 与此锁无关
NullPointerException - 如果条件为 null

toString

public String toString()
返回标识此锁及其锁状态的字符串。该状态括在括号中，它包括字符串 "Write locks ="，后跟重入保持写入锁的数目，然后是字符串 "Read locks ="，后跟所保持读取锁的数目。

覆盖：
类 Object 中的 toString
返回：
标识此锁及其锁状态的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReentrantReadWriteLock.ReadLock (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 ReentrantReadWriteLock.ReadLock

java.lang.Object
    继承者  java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
所有已实现的接口：
Serializable, Lock
正在封闭类：
ReentrantReadWriteLock
public static class ReentrantReadWriteLock.ReadLock
extends Object
implements Lock, Serializable

ReentrantReadWriteLock.readLock() 方法返回的锁。

另请参见：
序列化表格

构造方法摘要
protected ReentrantReadWriteLock.ReadLock(ReentrantReadWriteLock lock)
子类使用的构造方法
方法摘要
void | lock() 获取读取锁。
void | lockInterruptibly() 获取读取锁，除非当前线程被中断。
Condition | newCondition() 因为 ReadLocks 不支持条件，所以将抛出 UnsupportedOperationException。
String | toString() 返回标识此锁及其锁状态的字符串。
boolean | tryLock() 仅当写入锁在调用期间未被另一个线程保持时获取读取锁。
boolean | tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。
void | unlock() 试图释放此锁。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReentrantReadWriteLock.ReadLock

protected ReentrantReadWriteLock.ReadLock(ReentrantReadWriteLock lock)
子类使用的构造方法

参数：
lock - 外部锁对象
抛出：
NullPointerException - 如果 lock 为 null
方法详细信息

lock

public void lock()
获取读取锁。

如果另一个线程没有保持写入锁，则获取读取锁并立即返回。

如果另一个线程保持该写入锁，出于线程调度目的，将禁用当前线程，并且在获取读取锁之前，该线程将一直处于休眠状态。

指定者：
接口 Lock 中的 lock

lockInterruptibly

public void lockInterruptibly()
                       throws InterruptedException
获取读取锁，除非当前线程被中断。

如果另一个线程没有保持写入锁，则获取读取锁并立即返回。

如果另一个线程保持了该写入锁，出于线程调度目的，将禁用当前线程，并且在发生以下两种情况之一以前，该线程将一直处于休眠状态：

  • 读取锁由当前线程获得；或者
  • 其他某个线程中断当前线程。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在获取读取锁时被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。

在此实现中，因为此方法是一个显式中断点，所以要优先考虑响应中断，而不是响应锁的普通获取或重入获取。

指定者：
接口 Lock 中的 lockInterruptibly
抛出：
InterruptedException - 如果当前线程是已中断的。

tryLock

public boolean tryLock()
仅当写入锁在调用期间未被另一个线程保持时获取读取锁。

如果另一个线程没有保持写入锁，则获取读取锁并立即返回 true 值。即使已将此锁设置为使用公平排序策略，但是调用 tryLock() 仍将 立即获取读取锁（如果有可用的），不管其他线程当前是否正在等待该读取锁。在某些情况下，此“闯入”行为可能很有用，即使它会打破公平性也如此。如果希望遵守此锁的公平设置，则使用 tryLock(0, TimeUnit.SECONDS) ，它几乎是等效的（它也检测中断）。

如果写入锁被另一个线程保持，则此方法将立即返回 false 值。

指定者：
接口 Lock 中的 tryLock
返回：
如果获取了读取锁，则返回 true

tryLock

public boolean tryLock(long timeout,
                       TimeUnit unit)
                throws InterruptedException
如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。

如果另一个线程没有保持写入锁，则获取读取锁并立即返回 true 值。如果已经设置此锁使用公平的排序策略，并且其他线程都在等待该锁，则不会 获取一个可用的锁。这与 tryLock() 方法相反。如果想使用一个允许闯入公平锁的定时 tryLock，那么可以将定时形式和不定时形式组合在一起：

if (lock.tryLock() || lock.tryLock(timeout, unit) ) { ... }

如果写入锁被另一个线程保持，则出于线程调度目的，禁用当前线程，并且在发生以下三种情况之一以前，该线程将一直处于休眠状态：

  • 读取锁由当前线程获得；或者
  • 其他某个线程中断当前线程；或者
  • 已超过指定的等待时间。

如果获得了读取锁，则返回 true 值。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在获取读取锁时被中断，
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果超出了指定的等待时间，则返回值为 false。如果该时间小于等于 0，则此方法根本不会等待。

在此实现中，因为此方法是一个显式中断点，所以要优先考虑响应中断，而不是响应锁的普通获取或重入获取，或者报告所用的等待时间。

指定者：
接口 Lock 中的 tryLock
参数：
timeou - 等待读取锁的时间
unit - timeout 参数的时间单位
返回：
如果获取了读取锁，则返回 true。
抛出：
InterruptedException - 如果当前线程被中断
NullPointerException - 如果时间单位为 null

unlock

public void unlock()
试图释放此锁。

如果读取者的数量目前为 0，则该锁可用于写入锁尝试。

指定者：
接口 Lock 中的 unlock

newCondition

public Condition newCondition()
因为 ReadLocks 不支持条件，所以将抛出 UnsupportedOperationException。

指定者：
接口 Lock 中的 newCondition
返回：
用于此 Lock 实例的新 Condition 实例
抛出：
UnsupportedOperationException - 总是如此

toString

public String toString()
返回标识此锁及其锁状态的字符串。括号中的状态包括字符串 "Read locks ="，后跟读取锁的数量。

覆盖：
类 Object 中的 toString
返回：
标识此锁及其锁状态的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


java.util.concurrent.locks (Java 2 Platform SE 6)

 java.util.concurrent.locks
接口
Condition
Lock
ReadWriteLock
类
AbstractOwnableSynchronizer
AbstractQueuedLongSynchronizer
AbstractQueuedSynchronizer
LockSupport
ReentrantLock
ReentrantReadWriteLock
ReentrantReadWriteLock.ReadLock
ReentrantReadWriteLock.WriteLock


ReentrantReadWriteLock.WriteLock (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.concurrent.locks
类 ReentrantReadWriteLock.WriteLock

java.lang.Object
    继承者  java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
所有已实现的接口：
Serializable, Lock
正在封闭类：
ReentrantReadWriteLock
public static class ReentrantReadWriteLock.WriteLock
extends Object
implements Lock, Serializable

ReentrantReadWriteLock.writeLock() 方法返回的锁。

另请参见：
序列化表格

构造方法摘要
protected ReentrantReadWriteLock.WriteLock(ReentrantReadWriteLock lock)
子类使用的构造方法
方法摘要
int | getHoldCount() 查询当前线程保持写入锁的数量。
boolean | isHeldByCurrentThread() 查询此写入锁是否由当前线程保持。
void | lock() 获取写入锁。
void | lockInterruptibly() 获取写入锁，除非当前线程被中断。
Condition | newCondition() 返回一个用来与此 Lock 实例一起使用的 Condition 实例。
String | toString() 返回标识此锁及其锁状态的字符串。
boolean | tryLock() 仅当写入锁在调用期间未被另一个线程保持时获取该锁。
boolean | tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。
void | unlock() 试图释放此锁。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReentrantReadWriteLock.WriteLock

protected ReentrantReadWriteLock.WriteLock(ReentrantReadWriteLock lock)
子类使用的构造方法

参数：
lock - 外部锁对象
抛出：
NullPointerException - 如果锁为 null
方法详细信息

lock

public void lock()
获取写入锁。

如果另一个线程既没有保持读取锁也没有保持写入锁，则获取写入锁并立即返回，并将写入锁保持计数设置为 1。

如果当前线程已经保持写入锁，则保持计数增加 1，该方法立即返回。

如果该锁被另一个线程保持，出于线程调度的目的，将禁用当前线程，并且在获得写入锁之前，该线程将一直处于休眠状态，此时写入锁保持计数设置为 1。

指定者：
接口 Lock 中的 lock

lockInterruptibly

public void lockInterruptibly()
                       throws InterruptedException
获取写入锁，除非当前线程被中断。

如果另一个线程既没有保持读取锁也没有保持写入锁，则获取写入锁并立即返回，并将写入锁保持计数设置为 1。

如果当前线程已经保持此锁，则将保持计数加 1，该方法立即返回。

如果锁被另一个线程保持，则出于线程调度目的，禁用当前线程，并且在发生以下两种情况之一以前，该线程将一直处于休眠状态：

  • 写入锁由当前线程获得；或者
  • 其他某个线程中断当前线程。

如果当前线程获得写入锁，则将锁保持计数设置为 1。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在获取写入锁的同时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。

在此实现中，因为此方法是一个显式中断点，所以要优先考虑响应中断，而不是响应锁的普通获取或重入获取。

指定者：
接口 Lock 中的 lockInterruptibly
抛出：
InterruptedException - 如果当前线程是已中断的。

tryLock

public boolean tryLock()
仅当写入锁在调用期间未被另一个线程保持时获取该锁。

如果另一个线程既没有保持读取锁也没有保持写入锁，则获取写入锁并立即返回 true 值，并将写入锁保持计数设置为 1。即使已将此锁设置为使用公平排序策略，但是调用 tryLock() 仍将 立即获取锁（如果有可用的），不管其他线程当前是否正在等待写入锁。在某些情况下，此“闯入”行为可能很有用，即使它会打破公平性也如此。如果希望遵守此锁的公平设置，则使用 tryLock(0, TimeUnit.SECONDS) ，它几乎是等效的（它也检测中断）。

如果当前线程已经保持此锁，则将保持计数加 1，该方法将返回 true。

如果锁被另一个线程保持，则此方法将立即返回 false 值。

指定者：
接口 Lock 中的 tryLock
返回：
如果锁是自由的并且被当前线程获取，或者当前线程已经保持写入锁，则返回 true；否则返回 false。

tryLock

public boolean tryLock(long timeout,
                       TimeUnit unit)
                throws InterruptedException
如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。

如果另一个线程既没有保持读取锁也没有保持写入锁，则获取写入锁并立即返回 true 值，并将写入锁保持计数设置为 1。如果为了使用公平的排序策略，已经设置此锁，并且其他线程都在等待写入锁，则不会 获取一个可用的锁。这与 tryLock() 方法相反。如果想使用一个允许闯入公平锁的定时 tryLock，那么可以将定时形式和不定时形式组合在一起：

if (lock.tryLock() || lock.tryLock(timeout, unit) ) { ... }

如果当前线程已经保持此锁，则将保持计数加 1，该方法将返回 true。

如果锁被另一个线程保持，则出于线程调度目的，禁用当前线程，并且在发生以下三种情况之一以前，该线程将一直处于休眠状态：

  • 写入锁由当前线程获得；或者
  • 其他某个线程中断当前线程；或者
  • 已超过指定的等待时间

如果获取了写入锁，则返回 true 值，并将写入锁保持计数设置为 1。

如果当前线程：

  • 在进入此方法时已经设置了该线程的中断状态；或者
  • 在获取写入锁的同时被中断。
则抛出 InterruptedException，并且清除当前线程的已中断状态。

如果超出了指定的等待时间，则返回值为 false。如果该时间小于等于 0，则此方法根本不会等待。

在此实现中，因为此方法是一个显式中断点，所以要优先考虑响应中断，而不是响应锁的普通获取或重入获取，或者报告所用的等待时间。

指定者：
接口 Lock 中的 tryLock
参数：
timeou - 等待写入锁的时间
unit - timeout 参数的时间单位
返回：
如果锁是自由的并且由当前线程获取，或者当前线程已经保持写入锁，则返回 true；如果在获取该锁之前已经到达等待时间，则返回 false。
抛出：
InterruptedException - 如果当前线程被中断
NullPointerException - 如果时间单位为 null

unlock

public void unlock()
试图释放此锁。

如果当前线程保持此锁，则将保持计数减 1。如果保持计数现在为 0，则释放该锁。如果当前线程不是此锁的持有者，则抛出 IllegalMonitorStateException。

指定者：
接口 Lock 中的 unlock
抛出：
IllegalMonitorStateException - 如果当前线程没有保持此锁。

newCondition

public Condition newCondition()
返回一个用来与此 Lock 实例一起使用的 Condition 实例。

在使用内置监视器锁时，返回的 Condition 实例支持与 Object 的监视器方法（wait、notify 和 notifyAll）相同的用法。

  • 如果当调用任何 Condition 方法时没有保持此写入锁，则抛出 IllegalMonitorStateException。（因为保持读取锁是独立于写入锁的，所以读取锁将不被检查或受影响。但是，在当前线程已经获取读取锁时，调用一个条件等待方法实质上一直是错误的做法，因为能够解除阻塞该方法的其他线程将无法获取写入锁。）
  • 当调用等待条件方法并释放写入锁时，在它们返回之前，会重新获取写入锁，并将锁保持计数恢复到调用该方法时的值。
  • 如果线程在等待时被中断，则等待将终止，并将抛出 InterruptedException，清除线程的已中断状态。
  • 等待线程按 FIFO 顺序收到信号。
  • 等待方法返回的线程重新获取锁的顺序与线程最初获取锁的顺序相同，在默认情况下，未指定此顺序，但对于公平 锁，它们更倾向于那些等待时间最长的线程。

指定者：
接口 Lock 中的 newCondition
返回：
Condition 对象

toString

public String toString()
返回标识此锁及其锁状态的字符串。该状态括在括号中，它包括字符串 "Unlocked" 或字符串 "Locked by"，后跟所拥有线程的名称。

覆盖：
类 Object 中的 toString
返回：
标识此锁及其锁状态的字符串

isHeldByCurrentThread

public boolean isHeldByCurrentThread()
查询此写入锁是否由当前线程保持。与 ReentrantReadWriteLock.isWriteLockedByCurrentThread() 效果相同。

返回：
如果当前线程保持此锁，则返回 true；否则返回 false
从以下版本开始：
1.6

getHoldCount

public int getHoldCount()
查询当前线程保持写入锁的数量。对于与解锁操作不匹配的每个锁操作，线程都会为其保持一个锁。与 ReentrantReadWriteLock.getWriteHoldCount() 效果相同。

返回：
当前线程保持的锁数量，如果当前线程没有保持此锁，则返回 0
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.concurrent.locks (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.concurrent.locks

为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

请参见：
描述

接口摘要
Condition | Condition 将 Object 监视器方法（wait、notify 和 notifyAll）分解成截然不同的对象，以便通过将这些对象与任意 Lock 实现组合使用，为每个对象提供多个等待 set（wait-set）。
Lock | Lock 实现提供了比使用 synchronized 方法和语句可获得的更广泛的锁定操作。
ReadWriteLock | ReadWriteLock 维护了一对相关的锁，一个用于只读操作，另一个用于写入操作。

类摘要
AbstractOwnableSynchronizer | 可以由线程以独占方式拥有的同步器。
AbstractQueuedLongSynchronizer | 以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。
AbstractQueuedSynchronizer | 为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。
LockSupport | 用来创建锁和其他同步类的基本线程阻塞原语。
ReentrantLock | 一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。
ReentrantReadWriteLock | 支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。
ReentrantReadWriteLock.ReadLock | ReentrantReadWriteLock.readLock() 方法返回的锁。
ReentrantReadWriteLock.WriteLock | ReentrantReadWriteLock.writeLock() 方法返回的锁。

软件包 java.util.concurrent.locks 的描述

为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。该框架允许更灵活地使用锁和条件，但以更难用的语法为代价。

Lock 接口支持那些语义不同（重入、公平等）的锁规则，可以在非阻塞式结构的上下文（包括 hand-over-hand 和锁重排算法）中使用这些规则。主要的实现是 ReentrantLock。

ReadWriteLock 接口以类似方式定义了一些读取者可以共享而写入者独占的锁。此包只提供了一个实现，即 ReentrantReadWriteLock，因为它适用于大部分的标准用法上下文。但程序员可以创建自己的、适用于非标准要求的实现。

Condition 接口描述了可能会与锁有关联的条件变量。这些变量在用法上与使用 Object.wait 访问的隐式监视器类似，但提供了更强大的功能。需要特别指出的是，单个 Lock 可能与多个 Condition 对象关联。为了避免兼容性问题，Condition 方法的名称与对应的 Object 版本中的不同。

AbstractQueuedSynchronizer 类是一个非常有用的超类，可用来定义锁以及依赖于排队阻塞线程的其他同步器。 AbstractQueuedLongSynchronizer 类提供相同的功能但扩展了对同步状态的 64 位的支持。两者都扩展了类 AbstractOwnableSynchronizer（一个帮助记录当前保持独占同步的线程的简单类）。LockSupport 类提供了更低级别的阻塞和解除阻塞支持，这对那些实现自己的定制锁类的开发人员很有用。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.concurrent.locks 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.concurrent.locks 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.concurrent.locks.AbstractOwnableSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedLongSynchronizer (implements java.io.Serializable)
      • java.util.concurrent.locks.AbstractQueuedSynchronizer (implements java.io.Serializable)
    • java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject (implements java.util.concurrent.locks.Condition, java.io.Serializable)
    • java.util.concurrent.locks.LockSupport
    • java.util.concurrent.locks.ReentrantLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock (implements java.util.concurrent.locks.ReadWriteLock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)
    • java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock (implements java.util.concurrent.locks.Lock, java.io.Serializable)

接口分层结构

  • java.util.concurrent.locks.Condition
  • java.util.concurrent.locks.Lock
  • java.util.concurrent.locks.ReadWriteLock
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.concurrent.locks 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.concurrent.locks
的使用

使用 java.util.concurrent.locks 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 使用的 java.util.concurrent.locks 中的类
AbstractOwnableSynchronizer
可以由线程以独占方式拥有的同步器。
AbstractQueuedLongSynchronizer.ConditionObject
作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
AbstractQueuedSynchronizer.ConditionObject
AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。
Condition
Condition 将 Object 监视器方法（wait、notify 和 notifyAll）分解成截然不同的对象，以便通过将这些对象与任意 Lock 实现组合使用，为每个对象提供多个等待 set（wait-set）。
Lock
Lock 实现提供了比使用 synchronized 方法和语句可获得的更广泛的锁定操作。
ReadWriteLock
ReadWriteLock 维护了一对相关的锁，一个用于只读操作，另一个用于写入操作。
ReentrantReadWriteLock
支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。
ReentrantReadWriteLock.ReadLock
ReentrantReadWriteLock.readLock() 方法返回的锁。
ReentrantReadWriteLock.WriteLock
ReentrantReadWriteLock.writeLock() 方法返回的锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer
的使用

没有 java.util.concurrent.locks.AbstractQueuedLongSynchronizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedLongSynchronizer.ConditionObject
的使用

使用 AbstractQueuedLongSynchronizer.ConditionObject 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 AbstractQueuedLongSynchronizer.ConditionObject 的使用

参数类型为 AbstractQueuedLongSynchronizer.ConditionObject 的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedLongSynchronizer.getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
int | AbstractQueuedLongSynchronizer.getWaitQueueLength(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回正在与此同步器关联的给定条件上等待的线程估计数。
boolean | AbstractQueuedLongSynchronizer.hasWaiters(AbstractQueuedLongSynchronizer.ConditionObject condition) 查询是否有线程正在与此同步器关联的给定条件上等待。
boolean | AbstractQueuedLongSynchronizer.owns(AbstractQueuedLongSynchronizer.ConditionObject condition) 查询给定 ConditionObject 是否使用此同步器作为它的锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.locks.ReadWriteLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.locks.ReadWriteLock
的使用

使用 ReadWriteLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReadWriteLock 的使用

实现 ReadWriteLock 的 java.util.concurrent.locks 中的类
 class ReentrantReadWriteLock
支持与 ReentrantLock 类似语义的 ReadWriteLock 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.ReentrantReadWriteLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantReadWriteLock
的使用

使用 ReentrantReadWriteLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReentrantReadWriteLock 的使用

参数类型为 ReentrantReadWriteLock 的 java.util.concurrent.locks 中的构造方法
ReentrantReadWriteLock.ReadLock(ReentrantReadWriteLock lock)
子类使用的构造方法
ReentrantReadWriteLock.WriteLock(ReentrantReadWriteLock lock)
子类使用的构造方法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantReadWriteLock.ReadLock
的使用

使用 ReentrantReadWriteLock.ReadLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReentrantReadWriteLock.ReadLock 的使用

返回 ReentrantReadWriteLock.ReadLock 的 java.util.concurrent.locks 中的方法
 ReentrantReadWriteLock.ReadLock ReentrantReadWriteLock.readLock()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantReadWriteLock.WriteLock
的使用

使用 ReentrantReadWriteLock.WriteLock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 ReentrantReadWriteLock.WriteLock 的使用

返回 ReentrantReadWriteLock.WriteLock 的 java.util.concurrent.locks 中的方法
 ReentrantReadWriteLock.WriteLock ReentrantReadWriteLock.writeLock()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.LockSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.LockSupport
的使用

没有 java.util.concurrent.locks.LockSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.locks.Condition 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.locks.Condition
的使用

使用 Condition 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 Condition 的使用

实现 Condition 的 java.util.concurrent.locks 中的类
class | AbstractQueuedLongSynchronizer.ConditionObject 作为 Lock 实现基础的 AbstractQueuedLongSynchronizer 的条件实现。
class | AbstractQueuedSynchronizer.ConditionObject AbstractQueuedSynchronizer 的 Condition 实现是 Lock 实现的基础。

返回 Condition 的 java.util.concurrent.locks 中的方法
Condition | ReentrantReadWriteLock.ReadLock.newCondition() 因为 ReadLocks 不支持条件，所以将抛出 UnsupportedOperationException。
Condition | ReentrantReadWriteLock.WriteLock.newCondition() 返回一个用来与此 Lock 实例一起使用的 Condition 实例。
Condition | ReentrantLock.newCondition() 返回用来与此 Lock 实例一起使用的 Condition 实例。
Condition | Lock.newCondition() 返回绑定到此 Lock 实例的新 Condition 实例。

参数类型为 Condition 的 java.util.concurrent.locks 中的方法
protected Collection<Thread> | ReentrantReadWriteLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
protected Collection<Thread> | ReentrantLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。
int | ReentrantReadWriteLock.getWaitQueueLength(Condition condition) 返回正等待与写入锁相关的给定条件的线程估计数目。
int | ReentrantLock.getWaitQueueLength(Condition condition) 返回等待与此锁相关的给定条件的线程估计数。
boolean | ReentrantReadWriteLock.hasWaiters(Condition condition) 查询是否有些线程正在等待与写入锁有关的给定条件。
boolean | ReentrantLock.hasWaiters(Condition condition) 查询是否有些线程正在等待与此锁有关的给定条件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.AbstractQueuedSynchronizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedSynchronizer
的使用

没有 java.util.concurrent.locks.AbstractQueuedSynchronizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractQueuedSynchronizer.ConditionObject
的使用

使用 AbstractQueuedSynchronizer.ConditionObject 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 AbstractQueuedSynchronizer.ConditionObject 的使用

参数类型为 AbstractQueuedSynchronizer.ConditionObject 的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedSynchronizer.getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition) 返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
int | AbstractQueuedSynchronizer.getWaitQueueLength(AbstractQueuedSynchronizer.ConditionObject condition) 返回正在等待与此同步器有关的给定条件的线程数估计值。
boolean | AbstractQueuedSynchronizer.hasWaiters(AbstractQueuedSynchronizer.ConditionObject condition) 查询是否有线程正在等待给定的、与此同步器相关的条件。
boolean | AbstractQueuedSynchronizer.owns(AbstractQueuedSynchronizer.ConditionObject condition) 查询给定的 ConditionObject 是否使用了此同步器作为其锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.AbstractOwnableSynchronizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.AbstractOwnableSynchronizer
的使用

使用 AbstractOwnableSynchronizer 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 AbstractOwnableSynchronizer 的使用

java.util.concurrent.locks 中 AbstractOwnableSynchronizer 的子类
class | AbstractQueuedLongSynchronizer 以 long 形式维护同步状态的一个 AbstractQueuedSynchronizer 版本。
class | AbstractQueuedSynchronizer 为实现依赖于先进先出 (FIFO) 等待队列的阻塞锁和相关同步器（信号量、事件，等等）提供一个框架。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.locks.ReentrantLock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.locks.ReentrantLock
的使用

没有 java.util.concurrent.locks.ReentrantLock 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.locks.Lock 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.locks.Lock
的使用

使用 Lock 的软件包
java.util.concurrent.locks 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。

java.util.concurrent.locks 中 Lock 的使用

实现 Lock 的 java.util.concurrent.locks 中的类
class | ReentrantLock 一个可重入的互斥锁 Lock，它具有与使用 synchronized 方法和语句所访问的隐式监视器锁相同的一些基本行为和语义，但功能更强大。
static class | ReentrantReadWriteLock.ReadLock ReentrantReadWriteLock.readLock() 方法返回的锁。
static class | ReentrantReadWriteLock.WriteLock ReentrantReadWriteLock.writeLock() 方法返回的锁。

返回 Lock 的 java.util.concurrent.locks 中的方法
Lock | ReadWriteLock.readLock() 返回用于读取操作的锁。
Lock | ReadWriteLock.writeLock() 返回用于写入操作的锁。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.AbstractExecutorService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.AbstractExecutorService
的使用

使用 AbstractExecutorService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 AbstractExecutorService 的使用

java.util.concurrent 中 AbstractExecutorService 的子类
class | ScheduledThreadPoolExecutor ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
class | ThreadPoolExecutor 一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ArrayBlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ArrayBlockingQueue
的使用

没有 java.util.concurrent.ArrayBlockingQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.BlockingDeque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.BlockingDeque
的使用

使用 BlockingDeque 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 BlockingDeque 的使用

实现 BlockingDeque 的 java.util.concurrent 中的类
 class LinkedBlockingDeque<E>
一个基于已链接节点的、任选范围的阻塞双端队列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.BlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.BlockingQueue
的使用

使用 BlockingQueue 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 BlockingQueue 的使用

java.util.concurrent 中 BlockingQueue 的子接口
 interface BlockingDeque<E>
支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。

实现 BlockingQueue 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

返回 BlockingQueue 的 java.util.concurrent 中的方法
BlockingQueue<Runnable> | ScheduledThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。
BlockingQueue<Runnable> | ThreadPoolExecutor.getQueue() 返回此执行程序使用的任务队列。

参数类型为 BlockingQueue 的 java.util.concurrent 中的构造方法
ExecutorCompletionService(Executor executor, BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.BrokenBarrierException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.BrokenBarrierException
的使用

使用 BrokenBarrierException 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 BrokenBarrierException 的使用

抛出 BrokenBarrierException 的 java.util.concurrent 中的方法
int | CyclicBarrier.await() 在所有参与者都已经在此 barrier 上调用 await 方法之前，将一直等待。
int | CyclicBarrier.await(long timeout, TimeUnit unit) 在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.Callable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Callable
的使用

使用 Callable 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

java.util.concurrent 中 Callable 的使用

返回 Callable 的 java.util.concurrent 中的方法
static Callable<Object> Executors.callable(PrivilegedAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的操作并返回其结果。
static Callable<Object> Executors.callable(PrivilegedExceptionAction<?> action)
返回 Callable 对象，调用它时可运行给定特权的异常操作并返回其结果。
static Callable<Object> Executors.callable(Runnable task)
返回 Callable 对象，调用它时可运行给定的任务并返回 null。
static
<T> Callable<T>
Executors.callable(Runnable task, T result)
返回 Callable 对象，调用它时可运行给定的任务并返回给定的结果。
static
<T> Callable<T>
Executors.privilegedCallable(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。
static
<T> Callable<T>
Executors.privilegedCallableUsingCurrentClassLoader(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。

参数类型为 Callable 的 java.util.concurrent 中的方法
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Callable<V> callable, RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Callable<T> callable)
为给定可调用任务返回一个 RunnableFuture。
static
<T> Callable<T>
Executors.privilegedCallable(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中执行给定的 callable 对象。
static
<T> Callable<T>
Executors.privilegedCallableUsingCurrentClassLoader(Callable<T> callable)
返回 Callable 对象，调用它时可在当前的访问控制上下文中，使用当前上下文类加载器作为上下文类加载器来执行给定的 callable 对象。
<V> ScheduledFuture<V>
ScheduledExecutorService.schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
<V> ScheduledFuture<V>
ScheduledThreadPoolExecutor.schedule(Callable<V> callable, long delay, TimeUnit unit)
<T> Future<T>
AbstractExecutorService.submit(Callable<T> task)
<T> Future<T>
ExecutorService.submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Callable<T> task)
 Future<V> CompletionService.submit(Callable<V> task)
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
 Future<V> ExecutorCompletionService.submit(Callable<V> task)

类型变量类型为 Callable 的 java.util.concurrent 中的方法参数
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。

参数类型为 Callable 的 java.util.concurrent 中的构造方法
FutureTask(Callable<V> callable)
创建一个 FutureTask，一旦运行就执行给定的 Callable。

javax.tools 中 Callable 的使用

javax.tools 中 Callable 的子接口
static interface JavaCompiler.CompilationTask
表示编译任务的 future 的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.CancellationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CancellationException
的使用

没有 java.util.concurrent.CancellationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.CompletionService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.CompletionService
的使用

使用 CompletionService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 CompletionService 的使用

实现 CompletionService 的 java.util.concurrent 中的类
 class ExecutorCompletionService<V>
使用提供的 Executor 来执行任务的 CompletionService。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ConcurrentLinkedQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentLinkedQueue
的使用

没有 java.util.concurrent.ConcurrentLinkedQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.ConcurrentNavigableMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ConcurrentNavigableMap
的使用

使用 ConcurrentNavigableMap 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentNavigableMap 的使用

实现 ConcurrentNavigableMap 的 java.util.concurrent 中的类
 class ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

返回 ConcurrentNavigableMap 的 java.util.concurrent 中的方法
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.descendingMap() 返回此映射中所包含映射关系的逆序视图。
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.descendingMap()
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.headMap(K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.headMap(K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.headMap(K toKey, boolean inclusive)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.headMap(K toKey, boolean inclusive)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.subMap(K fromKey, K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.subMap(K fromKey, K toKey)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.tailMap(K fromKey)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.tailMap(K fromKey)
ConcurrentNavigableMap<K,V> | ConcurrentNavigableMap.tailMap(K fromKey, boolean inclusive)
ConcurrentNavigableMap<K,V> | ConcurrentSkipListMap.tailMap(K fromKey, boolean inclusive)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ConcurrentSkipListMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentSkipListMap
的使用

使用 ConcurrentSkipListMap 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentSkipListMap 的使用

返回 ConcurrentSkipListMap 的 java.util.concurrent 中的方法
 ConcurrentSkipListMap<K,V> ConcurrentSkipListMap.clone()
返回此 ConcurrentSkipListMap 实例的浅表副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ConcurrentSkipListSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentSkipListSet
的使用

使用 ConcurrentSkipListSet 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentSkipListSet 的使用

返回 ConcurrentSkipListSet 的 java.util.concurrent 中的方法
 ConcurrentSkipListSet<E> ConcurrentSkipListSet.clone()
返回此 ConcurrentSkipListSet 实例的浅表副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.CopyOnWriteArrayList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CopyOnWriteArrayList
的使用

没有 java.util.concurrent.CopyOnWriteArrayList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.CopyOnWriteArraySet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CopyOnWriteArraySet
的使用

没有 java.util.concurrent.CopyOnWriteArraySet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.CountDownLatch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CountDownLatch
的使用

没有 java.util.concurrent.CountDownLatch 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.CyclicBarrier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.CyclicBarrier
的使用

没有 java.util.concurrent.CyclicBarrier 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.DelayQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.DelayQueue
的使用

没有 java.util.concurrent.DelayQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.Delayed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Delayed
的使用

使用 Delayed 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 Delayed 的使用

类型参数类型为 Delayed 的 java.util.concurrent 中的类
 class DelayQueue<E extends Delayed>
Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。

java.util.concurrent 中 Delayed 的子接口
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。
interface | ScheduledFuture<V> 一个延迟的、结果可接受的操作，可将其取消。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.Exchanger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.Exchanger
的使用

没有 java.util.concurrent.Exchanger 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ExecutionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ExecutionException
的使用

使用 ExecutionException 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 ExecutionException 的使用

抛出 ExecutionException 的 java.util.concurrent 中的方法
 V Future.get()
如有必要，等待计算完成，然后获取其结果。
 V FutureTask.get()
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。

javax.swing 中 ExecutionException 的使用

抛出 ExecutionException 的 javax.swing 中的方法
T | SwingWorker.get() 如有必要，等待计算完成，然后获取其结果。
T | SwingWorker.get(long timeout, TimeUnit unit) 如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.Executor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Executor
的使用

使用 Executor 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

java.util.concurrent 中 Executor 的使用

java.util.concurrent 中 Executor 的子接口
interface | ExecutorService Executor 提供了管理终止的方法，以及可为跟踪一个或多个异步任务执行状况而生成 Future 的方法。
interface | ScheduledExecutorService 一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。

实现 Executor 的 java.util.concurrent 中的类
class | AbstractExecutorService 提供 ExecutorService 执行方法的默认实现。
class | ScheduledThreadPoolExecutor ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
class | ThreadPoolExecutor 一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

参数类型为 Executor 的 java.util.concurrent 中的构造方法
ExecutorCompletionService(Executor executor)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将 LinkedBlockingQueue 作为完成队列。
ExecutorCompletionService(Executor executor, BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。

javax.management 中 Executor 的使用

参数类型为 Executor 的 javax.management 中的构造方法
NotificationBroadcasterSupport(Executor executor)
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(Executor executor, MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。

javax.xml.ws 中 Executor 的使用

返回 Executor 的 javax.xml.ws 中的方法
abstract Executor | Endpoint.getExecutor() 返回此 Endpoint 实例的执行程序。
Executor | Service.getExecutor() 返回此 Service 实例的执行程序。

参数类型为 Executor 的 javax.xml.ws 中的方法
abstract void | Endpoint.setExecutor(Executor executor) 设置此 Endpoint 实例的执行程序。
void | Service.setExecutor(Executor executor) 设置此 Service 实例的执行程序。

javax.xml.ws.spi 中 Executor 的使用

返回 Executor 的 javax.xml.ws.spi 中的方法
abstract  Executor ServiceDelegate.getExecutor()
返回此 Service 实例的执行程序。

参数类型为 Executor 的 javax.xml.ws.spi 中的方法
abstract  void ServiceDelegate.setExecutor(Executor executor)
设置此 Service 实例的执行程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ExecutorCompletionService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ExecutorCompletionService
的使用

没有 java.util.concurrent.ExecutorCompletionService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.ExecutorService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ExecutorService
的使用

使用 ExecutorService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ExecutorService 的使用

java.util.concurrent 中 ExecutorService 的子接口
 interface ScheduledExecutorService
一个 ExecutorService，可安排在给定的延迟后运行或定期执行的命令。

实现 ExecutorService 的 java.util.concurrent 中的类
class | AbstractExecutorService 提供 ExecutorService 执行方法的默认实现。
class | ScheduledThreadPoolExecutor ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。
class | ThreadPoolExecutor 一个 ExecutorService，它使用可能的几个池线程之一执行每个提交的任务，通常使用 Executors 工厂方法配置。

返回 ExecutorService 的 java.util.concurrent 中的方法
static ExecutorService | Executors.newCachedThreadPool() 创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们。
static ExecutorService | Executors.newCachedThreadPool(ThreadFactory threadFactory) 创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.newFixedThreadPool(int nThreads) 创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程。
static ExecutorService | Executors.newFixedThreadPool(int nThreads, ThreadFactory threadFactory) 创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.newSingleThreadExecutor() 创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程。
static ExecutorService | Executors.newSingleThreadExecutor(ThreadFactory threadFactory) 创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.unconfigurableExecutorService(ExecutorService executor) 返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

参数类型为 ExecutorService 的 java.util.concurrent 中的方法
static ExecutorService Executors.unconfigurableExecutorService(ExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.Executors 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.Executors
的使用

没有 java.util.concurrent.Executors 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.Future 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.Future
的使用

使用 Future 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.ws | 此包包含核心 JAX-WS API。

java.util.concurrent 中 Future 的使用

java.util.concurrent 中 Future 的子接口
interface | RunnableFuture<V> 作为 Runnable 的 Future。
interface | RunnableScheduledFuture<V> 作为 Runnable 的 ScheduledFuture。
interface | ScheduledFuture<V> 一个延迟的、结果可接受的操作，可将其取消。

实现 Future 的 java.util.concurrent 中的类
 class FutureTask<V>
可取消的异步计算。

返回 Future 的 java.util.concurrent 中的方法
 Future<V> CompletionService.poll()
获取并移除表示下一个已完成任务的 Future，如果不存在这样的任务，则返回 null。
 Future<V> ExecutorCompletionService.poll()
 Future<V> CompletionService.poll(long timeout, TimeUnit unit)
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
 Future<V> ExecutorCompletionService.poll(long timeout, TimeUnit unit)
<T> Future<T>
AbstractExecutorService.submit(Callable<T> task)
<T> Future<T>
ExecutorService.submit(Callable<T> task)
提交一个返回值的任务用于执行，返回一个表示任务的未决结果的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Callable<T> task)
 Future<V> CompletionService.submit(Callable<V> task)
提交要执行的值返回任务，并返回表示挂起的任务结果的 Future。
 Future<V> ExecutorCompletionService.submit(Callable<V> task)
 Future<?> AbstractExecutorService.submit(Runnable task)
 Future<?> ExecutorService.submit(Runnable task)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
 Future<?> ScheduledThreadPoolExecutor.submit(Runnable task)
<T> Future<T>
AbstractExecutorService.submit(Runnable task, T result)
<T> Future<T>
ExecutorService.submit(Runnable task, T result)
提交一个 Runnable 任务用于执行，并返回一个表示该任务的 Future。
<T> Future<T>
ScheduledThreadPoolExecutor.submit(Runnable task, T result)
 Future<V> CompletionService.submit(Runnable task, V result)
提交要执行的 Runnable 任务，并返回一个表示任务完成的 Future，可以提取或轮询此任务。
 Future<V> ExecutorCompletionService.submit(Runnable task, V result)
 Future<V> CompletionService.take()
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则等待。
 Future<V> ExecutorCompletionService.take()

返回变量类型为 Future 的类型的 java.util.concurrent 中的方法
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。

类型变量类型为 Future 的 java.util.concurrent 中的构造方法参数
ExecutorCompletionService(Executor executor, BlockingQueue<Future<V>> completionQueue)
使用为执行基本任务而提供的执行程序创建一个 ExecutorCompletionService，并将所提供的队列作为其完成队列。

javax.swing 中 Future 的使用

实现 Future 的 javax.swing 中的类
 class SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

javax.xml.ws 中 Future 的使用

javax.xml.ws 中 Future 的子接口
 interface Response<T>
Response 接口提供一些方法，用来获得为响应操作调用而发送的消息的净荷和上下文。

返回 Future 的 javax.xml.ws 中的方法
 Future<?> Dispatch.invokeAsync(T msg, AsyncHandler<T> handler)
异步调用服务操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.FutureTask 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.FutureTask
的使用

没有 java.util.concurrent.FutureTask 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.LinkedBlockingDeque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.LinkedBlockingDeque
的使用

没有 java.util.concurrent.LinkedBlockingDeque 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.LinkedBlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.LinkedBlockingQueue
的使用

没有 java.util.concurrent.LinkedBlockingQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.PriorityBlockingQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.PriorityBlockingQueue
的使用

没有 java.util.concurrent.PriorityBlockingQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.RejectedExecutionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.RejectedExecutionException
的使用

没有 java.util.concurrent.RejectedExecutionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.RejectedExecutionHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.RejectedExecutionHandler
的使用

使用 RejectedExecutionHandler 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 RejectedExecutionHandler 的使用

实现 RejectedExecutionHandler 的 java.util.concurrent 中的类
static class | ThreadPoolExecutor.AbortPolicy 用于被拒绝任务的处理程序，它将抛出 RejectedExecutionException.
static class | ThreadPoolExecutor.CallerRunsPolicy 用于被拒绝任务的处理程序，它直接在 execute 方法的调用线程中运行被拒绝的任务；如果执行程序已关闭，则会丢弃该任务。
static class | ThreadPoolExecutor.DiscardOldestPolicy 用于被拒绝任务的处理程序，它放弃最旧的未处理请求，然后重试 execute；如果执行程序已关闭，则会丢弃该任务。
static class | ThreadPoolExecutor.DiscardPolicy 用于被拒绝任务的处理程序，默认情况下它将丢弃被拒绝的任务。

返回 RejectedExecutionHandler 的 java.util.concurrent 中的方法
 RejectedExecutionHandler ThreadPoolExecutor.getRejectedExecutionHandler()
返回用于未执行任务的当前处理程序。

参数类型为 RejectedExecutionHandler 的 java.util.concurrent 中的方法
 void ThreadPoolExecutor.setRejectedExecutionHandler(RejectedExecutionHandler handler)
设置用于未执行任务的新处理程序。

参数类型为 RejectedExecutionHandler 的 java.util.concurrent 中的构造方法
ScheduledThreadPoolExecutor(int corePoolSize, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.RunnableFuture 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.RunnableFuture
的使用

使用 RunnableFuture 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 RunnableFuture 的使用

java.util.concurrent 中 RunnableFuture 的子接口
 interface RunnableScheduledFuture<V>
作为 Runnable 的 ScheduledFuture。

实现 RunnableFuture 的 java.util.concurrent 中的类
 class FutureTask<V>
可取消的异步计算。

返回 RunnableFuture 的 java.util.concurrent 中的方法
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Callable<T> callable)
为给定可调用任务返回一个 RunnableFuture。
protected
<T> RunnableFuture<T>
AbstractExecutorService.newTaskFor(Runnable runnable, T value)
为给定可运行任务和默认值返回一个 RunnableFuture。

javax.swing 中 RunnableFuture 的使用

实现 RunnableFuture 的 javax.swing 中的类
 class SwingWorker<T,V>
在专用线程中执行长时间 GUI 交互任务的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.RunnableScheduledFuture 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.RunnableScheduledFuture
的使用

使用 RunnableScheduledFuture 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 RunnableScheduledFuture 的使用

返回 RunnableScheduledFuture 的 java.util.concurrent 中的方法
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Callable<V> callable, RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Runnable runnable, RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。

参数类型为 RunnableScheduledFuture 的 java.util.concurrent 中的方法
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Callable<V> callable, RunnableScheduledFuture<V> task)
修改或替换用于执行 callable 的任务。
protected
<V> RunnableScheduledFuture<V>
ScheduledThreadPoolExecutor.decorateTask(Runnable runnable, RunnableScheduledFuture<V> task)
修改或替换用于执行 runnable 的任务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.ScheduledExecutorService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ScheduledExecutorService
的使用

使用 ScheduledExecutorService 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ScheduledExecutorService 的使用

实现 ScheduledExecutorService 的 java.util.concurrent 中的类
 class ScheduledThreadPoolExecutor
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。

返回 ScheduledExecutorService 的 java.util.concurrent 中的方法
static ScheduledExecutorService | Executors.newScheduledThreadPool(int corePoolSize) 创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.newScheduledThreadPool(int corePoolSize, ThreadFactory threadFactory) 创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.newSingleThreadScheduledExecutor() 创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.newSingleThreadScheduledExecutor(ThreadFactory threadFactory) 创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
static ScheduledExecutorService | Executors.unconfigurableScheduledExecutorService(ScheduledExecutorService executor) 返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

参数类型为 ScheduledExecutorService 的 java.util.concurrent 中的方法
static ScheduledExecutorService Executors.unconfigurableScheduledExecutorService(ScheduledExecutorService executor)
返回一个将所有已定义的 ExecutorService 方法委托给指定执行程序的对象，但是使用强制转换可能无法访问其他方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.ScheduledFuture 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ScheduledFuture
的使用

使用 ScheduledFuture 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ScheduledFuture 的使用

java.util.concurrent 中 ScheduledFuture 的子接口
 interface RunnableScheduledFuture<V>
作为 Runnable 的 ScheduledFuture。

返回 ScheduledFuture 的 java.util.concurrent 中的方法
<V> ScheduledFuture<V>
ScheduledExecutorService.schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
<V> ScheduledFuture<V>
ScheduledThreadPoolExecutor.schedule(Callable<V> callable, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.schedule(Runnable command, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ScheduledThreadPoolExecutor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ScheduledThreadPoolExecutor
的使用

没有 java.util.concurrent.ScheduledThreadPoolExecutor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.Semaphore 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.Semaphore
的使用

没有 java.util.concurrent.Semaphore 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.SynchronousQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.SynchronousQueue
的使用

没有 java.util.concurrent.SynchronousQueue 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.ThreadFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ThreadFactory
的使用

使用 ThreadFactory 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ThreadFactory 的使用

返回 ThreadFactory 的 java.util.concurrent 中的方法
static ThreadFactory | Executors.defaultThreadFactory() 返回用于创建新线程的默认线程工厂。
ThreadFactory | ThreadPoolExecutor.getThreadFactory() 返回用于创建新线程的线程工厂。
static ThreadFactory | Executors.privilegedThreadFactory() 返回用于创建新线程的线程工厂，这些新线程与当前线程具有相同的权限。

参数类型为 ThreadFactory 的 java.util.concurrent 中的方法
static ExecutorService | Executors.newCachedThreadPool(ThreadFactory threadFactory) 创建一个可根据需要创建新线程的线程池，但是在以前构造的线程可用时将重用它们，并在需要时使用提供的 ThreadFactory 创建新线程。
static ExecutorService | Executors.newFixedThreadPool(int nThreads, ThreadFactory threadFactory) 创建一个可重用固定线程数的线程池，以共享的无界队列方式来运行这些线程，在需要时使用提供的 ThreadFactory 创建新线程。
static ScheduledExecutorService | Executors.newScheduledThreadPool(int corePoolSize, ThreadFactory threadFactory) 创建一个线程池，它可安排在给定延迟后运行命令或者定期地执行。
static ExecutorService | Executors.newSingleThreadExecutor(ThreadFactory threadFactory) 创建一个使用单个 worker 线程的 Executor，以无界队列方式来运行该线程，并在需要时使用提供的 ThreadFactory 创建新线程。
static ScheduledExecutorService | Executors.newSingleThreadScheduledExecutor(ThreadFactory threadFactory) 创建一个单线程执行程序，它可安排在给定延迟后运行命令或者定期地执行。
void | ThreadPoolExecutor.setThreadFactory(ThreadFactory threadFactory) 设置用于创建新线程的线程工厂。

参数类型为 ThreadFactory 的 java.util.concurrent 中的构造方法
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory)
使用给定的初始参数创建一个新 ScheduledThreadPoolExecutor。
ScheduledThreadPoolExecutor(int corePoolSize, ThreadFactory threadFactory, RejectedExecutionHandler handler)
使用给定初始参数创建一个新 ScheduledThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ThreadPoolExecutor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor
的使用

使用 ThreadPoolExecutor 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ThreadPoolExecutor 的使用

java.util.concurrent 中 ThreadPoolExecutor 的子类
 class ScheduledThreadPoolExecutor
ThreadPoolExecutor，它可另行安排在给定的延迟后运行命令，或者定期执行命令。

参数类型为 ThreadPoolExecutor 的 java.util.concurrent 中的方法
void | RejectedExecutionHandler.rejectedExecution(Runnable r, ThreadPoolExecutor executor) 当 execute 不能接受某个任务时，可以由 ThreadPoolExecutor 调用的方法。
void | ThreadPoolExecutor.CallerRunsPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 执行调用者线程中的任务 r；如果执行程序已关闭，则会丢弃该任务。
void | ThreadPoolExecutor.AbortPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 总是抛出 RejectedExecutionException。
void | ThreadPoolExecutor.DiscardPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 不执行任何操作，在这种情况下将放弃任务 r。
void | ThreadPoolExecutor.DiscardOldestPolicy.rejectedExecution(Runnable r, ThreadPoolExecutor e) 获取并忽略下一个任务，否则如果该任务立即可用，执行程序将执行该任务，然后再试图重新执行任务 r；如果执行程序已关闭，则会丢弃任务 r。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.CallerRunsPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.AbortPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.AbortPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.DiscardPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy
的使用

没有 java.util.concurrent.ThreadPoolExecutor.DiscardOldestPolicy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.TimeUnit 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.TimeUnit
的使用

使用 TimeUnit 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 TimeUnit 的使用

返回 TimeUnit 的 java.util.concurrent 中的方法
static TimeUnit | TimeUnit.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TimeUnit[] | TimeUnit.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 TimeUnit 的 java.util.concurrent 中的方法
 boolean CountDownLatch.await(long timeout, TimeUnit unit)
使当前线程在锁存器倒计数至零之前一直等待，除非线程被中断或超出了指定的等待时间。
 int CyclicBarrier.await(long timeout, TimeUnit unit)
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
 boolean ExecutorService.awaitTermination(long timeout, TimeUnit unit)
请求关闭、发生超时或者当前线程中断，无论哪一个首先发生之后，都将导致阻塞，直到所有任务完成执行。
 boolean ThreadPoolExecutor.awaitTermination(long timeout, TimeUnit unit)
 long TimeUnit.convert(long sourceDuration, TimeUnit sourceUnit)
将给定单元的时间段转换到此单元。
 V Exchanger.exchange(V x, long timeout, TimeUnit unit)
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
 long Delayed.getDelay(TimeUnit unit)
返回与此对象相关的剩余延迟时间，以给定的时间单位表示。
 long ThreadPoolExecutor.getKeepAliveTime(TimeUnit unit)
返回线程保持活动的时间，该时间就是超过核心池大小的线程可以在终止前保持空闲的时间值。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
 boolean ArrayBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此队列的尾部，如果该队列已满，则在到达指定的等待时间之前等待可用的空间。
 boolean BlockingDeque.offer(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列表示的队列中（即此双端队列的尾部），必要时将在指定的等待时间内一直等待可用空间。
 boolean BlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此队列中，在到达指定的等待时间前等待可用的空间（如果有必要）。
 boolean DelayQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此延迟队列中。
 boolean LinkedBlockingDeque.offer(E e, long timeout, TimeUnit unit)
 boolean LinkedBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入到此队列的尾部，如有必要，则等待指定的时间以使空间变得可用。
 boolean PriorityBlockingQueue.offer(E e, long timeout, TimeUnit unit)
将指定元素插入此优先级队列。
 boolean SynchronousQueue.offer(E o, long timeout, TimeUnit unit)
将指定元素插入到此队列，如有必要则等待指定的时间，以便另一个线程接收它。
 boolean BlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的开头，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerFirst(E e, long timeout, TimeUnit unit)
 boolean BlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
将指定的元素插入此双端队列的末尾，必要时将在指定的等待时间内等待可用空间。
 boolean LinkedBlockingDeque.offerLast(E e, long timeout, TimeUnit unit)
 E ArrayBlockingQueue.poll(long timeout, TimeUnit unit)
 E BlockingDeque.poll(long timeout, TimeUnit unit)
获取并移除此双端队列表示的队列的头部（即此双端队列的第一个元素），如有必要将在指定的等待时间内等待可用元素。
 E BlockingQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在指定的等待时间前等待可用的元素（如果有必要）。
 Future<V> CompletionService.poll(long timeout, TimeUnit unit)
获取并移除表示下一个已完成任务的 Future，如果目前不存在这样的任务，则将等待指定的时间（如果有必要）。
 E DelayQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头部，在可从此队列获得到期延迟的元素，或者到达指定的等待时间之前一直等待（如有必要）。
 Future<V> ExecutorCompletionService.poll(long timeout, TimeUnit unit)
 E LinkedBlockingDeque.poll(long timeout, TimeUnit unit)
 E LinkedBlockingQueue.poll(long timeout, TimeUnit unit)
 E PriorityBlockingQueue.poll(long timeout, TimeUnit unit)
 E SynchronousQueue.poll(long timeout, TimeUnit unit)
获取并移除此队列的头，如有必要则等待指定的时间，以便另一个线程插入它。
 E BlockingDeque.pollFirst(long timeout, TimeUnit unit)
获取并移除此双端队列的第一个元素，必要时将在指定的等待时间等待可用元素。
 E LinkedBlockingDeque.pollFirst(long timeout, TimeUnit unit)
 E BlockingDeque.pollLast(long timeout, TimeUnit unit)
获取并移除此双端队列的最后一个元素，必要时将在指定的等待时间内等待可用元素。
 E LinkedBlockingDeque.pollLast(long timeout, TimeUnit unit)
<V> ScheduledFuture<V>
ScheduledExecutorService.schedule(Callable<V> callable, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的 ScheduledFuture。
<V> ScheduledFuture<V>
ScheduledThreadPoolExecutor.schedule(Callable<V> callable, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.schedule(Runnable command, long delay, TimeUnit unit)
创建并执行在给定延迟后启用的一次性操作。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.schedule(Runnable command, long delay, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，后续操作具有给定的周期；也就是将在 initialDelay 后开始执行，然后在 initialDelay+period 后执行，接着在 initialDelay + 2 * period 后执行，依此类推。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleAtFixedRate(Runnable command, long initialDelay, long period, TimeUnit unit)
 ScheduledFuture<?> ScheduledExecutorService.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
创建并执行一个在给定初始延迟后首次启用的定期操作，随后，在每一次执行终止和下一次执行开始之间都存在给定的延迟。
 ScheduledFuture<?> ScheduledThreadPoolExecutor.scheduleWithFixedDelay(Runnable command, long initialDelay, long delay, TimeUnit unit)
 void ThreadPoolExecutor.setKeepAliveTime(long time, TimeUnit unit)
设置线程在终止前可以保持空闲的时间限制。
 boolean Semaphore.tryAcquire(int permits, long timeout, TimeUnit unit)
如果在给定的等待时间内此信号量有可用的所有许可，并且当前线程未被中断，则从此信号量获取给定数目的许可。
 boolean Semaphore.tryAcquire(long timeout, TimeUnit unit)
如果在给定的等待时间内，此信号量有可用的许可并且当前线程未被中断，则从此信号量获取一个许可。

参数类型为 TimeUnit 的 java.util.concurrent 中的构造方法
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue)
用给定的初始参数和默认的线程工厂及被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, RejectedExecutionHandler handler)
用给定的初始参数和默认的线程工厂创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory)
用给定的初始参数和默认被拒绝的执行处理程序创建新的 ThreadPoolExecutor。
ThreadPoolExecutor(int corePoolSize, int maximumPoolSize, long keepAliveTime, TimeUnit unit, BlockingQueue<Runnable> workQueue, ThreadFactory threadFactory, RejectedExecutionHandler handler)
用给定的初始参数创建新的 ThreadPoolExecutor。

java.util.concurrent.locks 中 TimeUnit 的使用

参数类型为 TimeUnit 的 java.util.concurrent.locks 中的方法
boolean | AbstractQueuedLongSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时条件等待。
boolean | Condition.await(long time, TimeUnit unit) 造成当前线程在接到信号、被中断或到达指定等待时间之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.await(long time, TimeUnit unit) 实现定时的条件等待。
boolean | ReentrantReadWriteLock.ReadLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取读取锁。
boolean | ReentrantReadWriteLock.WriteLock.tryLock(long timeout, TimeUnit unit) 如果另一个线程在给定的等待时间内没有保持写入锁，并且当前线程未被中断，则获取写入锁。
boolean | ReentrantLock.tryLock(long timeout, TimeUnit unit) 如果锁在给定等待时间内没有被另一个线程保持，且当前线程未被中断，则获取该锁。
boolean | Lock.tryLock(long time, TimeUnit unit) 如果锁在给定的等待时间内空闲，并且当前线程未被中断，则获取锁。

javax.swing 中 TimeUnit 的使用

参数类型为 TimeUnit 的 javax.swing 中的方法
 T SwingWorker.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.TimeoutException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.TimeoutException
的使用

使用 TimeoutException 的软件包
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

java.util.concurrent 中 TimeoutException 的使用

抛出 TimeoutException 的 java.util.concurrent 中的方法
 int CyclicBarrier.await(long timeout, TimeUnit unit)
在所有参与者都已经在此屏障上调用 await 方法之前将一直等待,或者超出了指定的等待时间。
 V Exchanger.exchange(V x, long timeout, TimeUnit unit)
等待另一个线程到达此交换点（除非当前线程被中断，或者超出了指定的等待时间），然后将给定的对象传送给该线程，同时接收该线程的对象。
 V Future.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 V FutureTask.get(long timeout, TimeUnit unit)
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。

javax.swing 中 TimeoutException 的使用

抛出 TimeoutException 的 javax.swing 中的方法
 T SwingWorker.get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.concurrent.ConcurrentHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.concurrent.ConcurrentHashMap
的使用

没有 java.util.concurrent.ConcurrentHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.concurrent.ConcurrentMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.concurrent.ConcurrentMap
的使用

使用 ConcurrentMap 的软件包
java.util.concurrent 在并发编程中很常用的实用工具类。

java.util.concurrent 中 ConcurrentMap 的使用

java.util.concurrent 中 ConcurrentMap 的子接口
 interface ConcurrentNavigableMap<K,V>
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 ConcurrentMap 的 java.util.concurrent 中的类
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Attributes (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 Attributes

java.lang.Object
    继承者  java.util.jar.Attributes
所有已实现的接口：
Cloneable, Map<Object,Object>
public class Attributes
extends Object
implements Map<Object,Object>, Cloneable

Attributes 类将 Manifest 属性名称映射到关联的字符串值。有效的属性名称是区分大小写的，只能取 [0-9a-zA-Z_-] 集中的 ASCII 字符，且长度不能超过 70 个字符。属性值可以包含任意字符，当属性值被写入输出流时将进行 UTF8 编码。有关有效属性名称和值的更多信息，请参阅 JAR File Specification。

从以下版本开始：
1.2
另请参见：
Manifest

嵌套类摘要
static class Attributes.Name
Attributes.Name 类表示存储在此 Map 中的一个属性名称。
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
字段摘要
protected  Map<Object,Object> map
属性名称-值映射关系。
构造方法摘要
Attributes()
构造具有默认大小的新的空 Attributes 对象。
Attributes(Attributes attr)
构造新的 Attributes 对象，该对象与指定的 Attributes 具有相同的属性名称-值映射关系。
Attributes(int size)
构造具有指定初始大小的新的空 Attributes 对象。
方法摘要
 void clear()
从此 Map 中移除所有属性。
 Object clone()
返回 Attributes 的副本，实现方法如下: public Object clone() { return new Attributes(this); } 由于属性名称和值本身不可变，因此可以安全地修改返回的 Attributes，而不会影响原始值。
 boolean containsKey(Object name)
如果此 Map 包含指定的属性名称（键），则返回 true。
 boolean containsValue(Object value)
如果此 Map 将一个或多个属性名称（键）映射到指定值，则返回 true。
 Set<Map.Entry<Object,Object>> entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。
 boolean equals(Object o)
将指定的 Attributes 对象与此 Map 进行相等性比较。
 Object get(Object name)
返回指定的属性名称的值，如果未找到属性名称，则返回 null。
 String getValue(Attributes.Name name)
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。
 String getValue(String name)
返回指定属性名称的值，如果未找到，则返回 null。
 int hashCode()
返回此 Map 的哈希码值。
 boolean isEmpty()
如果此 Map 不包含属性，则返回 true。
 Set<Object> keySet()
返回此 Map 所包含的属性名称（键）的 Set 视图。
 Object put(Object name, Object value)
在此 Map 中将指定的值关联到指定的属性名称（键）。
 void putAll(Map<?,?> attr)
将所有的属性名称-值映射关系从指定的 Attributes 复制到此 Map。
 String putValue(String name, String value)
将指定的值作为一个 String 关联到指定的属性名称。
 Object remove(Object name)
从此 Map 中移除具有指定名称（键）的属性。
 int size()
返回此 Map 中的属性数目。
 Collection<Object> values()
返回此 Map 所包含的属性值的 Collection 视图。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

map

protected Map<Object,Object> map
属性名称-值映射关系。

构造方法详细信息

Attributes

public Attributes()
构造具有默认大小的新的空 Attributes 对象。

Attributes

public Attributes(int size)
构造具有指定初始大小的新的空 Attributes 对象。

参数：
size - 属性的初始数目

Attributes

public Attributes(Attributes attr)
构造新的 Attributes 对象，该对象与指定的 Attributes 具有相同的属性名称-值映射关系。

参数：
attr - 指定的 Attributes
方法详细信息

get

public Object get(Object name)
返回指定的属性名称的值，如果未找到属性名称，则返回 null。

指定者：
接口 Map<Object,Object> 中的 get
参数：
name - 属性名称
返回：
指定属性名称的值，如果未找到，则返回 null。

getValue

public String getValue(String name)
返回指定属性名称的值，如果未找到，则返回 null。属性名称是区分大小写的。

此方法定义如下:

            return (String)get(new Attributes.Name((String)name));

参数：
name - 作为字符串的属性名称
返回：
指定属性名称的 String 值，如果未找到，则返回 null。
抛出：
IllegalArgumentException - 如果属性名称无效

getValue

public String getValue(Attributes.Name name)
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。

此方法定义如下:

     return (String)get(name);

参数：
name - Attributes.Name 对象
返回：
指定的 Attribute.Name 的 String 值，如果未找到，则返回 null。

put

public Object put(Object name,
                  Object value)
在此 Map 中将指定的值关联到指定的属性名称（键）。如果此 Map 以前包含了属性名称的映射关系，则旧值将被替换。

指定者：
接口 Map<Object,Object> 中的 put
参数：
name - 属性名称
value - 属性值
返回：
以前的属性值；如果没有，则返回 null
抛出：
ClassCastException - 如果名称不是 Attributes.Name 或值不是一个 String

putValue

public String putValue(String name,
                       String value)
将指定的值作为一个 String 关联到指定的属性名称。属性名称是区分大小写的。如果此 Map 以前包含了属性名称的映射关系，则旧值将被替换。

此方法定义如下:

            return (String)put(new Attributes.Name(name), value);

参数：
name - 作为字符串的属性名称
value - 属性值
返回：
属性以前的值，如果没有，则返回 null
抛出：
IllegalArgumentException - 如果属性名称是无效的

remove

public Object remove(Object name)
从此 Map 中移除具有指定名称（键）的属性。返回以前的属性值；如果没有，则返回 null。

指定者：
接口 Map<Object,Object> 中的 remove
参数：
name - 属性名称
返回：
属性以前的值；如果没有，则返回 null

containsValue

public boolean containsValue(Object value)
如果此 Map 将一个或多个属性名称（键）映射到指定值，则返回 true。

指定者：
接口 Map<Object,Object> 中的 containsValue
参数：
value - 属性值
返回：
如果此 Map 将一个或多个属性名称映射到指定值，则返回 true

containsKey

public boolean containsKey(Object name)
如果此 Map 包含指定的属性名称（键），则返回 true。

指定者：
接口 Map<Object,Object> 中的 containsKey
参数：
name - 属性名称
返回：
如果此 Map 包含指定的属性名称，则返回 true

putAll

public void putAll(Map<?,?> attr)
将所有的属性名称-值映射关系从指定的 Attributes 复制到此 Map。重复的映射关系将被替换。

指定者：
接口 Map<Object,Object> 中的 putAll
参数：
attr - 要存储到此映射中的 Attributes
抛出：
ClassCastException - 如果 attr 不是一个 Attributes

clear

public void clear()
从此 Map 中移除所有属性。

指定者：
接口 Map<Object,Object> 中的 clear

size

public int size()
返回此 Map 中的属性数目。

指定者：
接口 Map<Object,Object> 中的 size
返回：
此映射中的键-值映射关系数

isEmpty

public boolean isEmpty()
如果此 Map 不包含属性，则返回 true。

指定者：
接口 Map<Object,Object> 中的 isEmpty
返回：
如果此映射未包含键-值映射关系，则返回 true

keySet

public Set<Object> keySet()
返回此 Map 所包含的属性名称（键）的 Set 视图。

指定者：
接口 Map<Object,Object> 中的 keySet
返回：
此映射中包含的键的 set 视图

values

public Collection<Object> values()
返回此 Map 所包含的属性值的 Collection 视图。

指定者：
接口 Map<Object,Object> 中的 values
返回：
此映射中包含的值的 collection 视图

entrySet

public Set<Map.Entry<Object,Object>> entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。

指定者：
接口 Map<Object,Object> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图

equals

public boolean equals(Object o)
将指定的 Attributes 对象与此 Map 进行相等性比较。如果给定对象也是 Attributes 的实例，且两个 Attributes 对象表示相同的映射关系，则返回 true。

指定者：
接口 Map<Object,Object> 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要比较的 Object
返回：
如果指定的 Object 与此 Map 相等，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 Map 的哈希码值。

指定者：
接口 Map<Object,Object> 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

clone

public Object clone()
返回 Attributes 的副本，实现方法如下:
     public Object clone() { return new Attributes(this); }
由于属性名称和值本身不可变，因此可以安全地修改返回的 Attributes，而不会影响原始值。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Attributes.Name (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 Attributes.Name

java.lang.Object
    继承者  java.util.jar.Attributes.Name
正在封闭类：
Attributes
public static class Attributes.Name
extends Object

Attributes.Name 类表示存储在此 Map 中的一个属性名称。有效的属性名称是区分大小写的，只能取 [0-9a-zA-Z_-] 集中的 ASCII 字符，且长度不能超过 70 个字符。属性值可以包含任意字符，当属性值被写入输出流时将进行 UTF8 编码。有关有效属性名称和值的更多信息，请参阅 JAR File Specification。

字段摘要
static Attributes.Name | CLASS_PATH Class-Path 的 Name 对象具有的属性。
static Attributes.Name | CONTENT_TYPE Content-Type 的 Name 对象具有的属性。
static Attributes.Name | EXTENSION_INSTALLATION Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | EXTENSION_LIST Extension-List 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | EXTENSION_NAME Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | IMPLEMENTATION_TITLE Implementation-Title 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | IMPLEMENTATION_URL Implementation-Vendor-URL 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | IMPLEMENTATION_VENDOR Implementation-Vendor 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | IMPLEMENTATION_VENDOR_ID Implementation-Vendor-Id 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | IMPLEMENTATION_VERSION Implementation-Version 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | MAIN_CLASS Main-Class 的 Name 对象具有的属性，用于启动打包在 JAR 文件中的应用程序。
static Attributes.Name | MANIFEST_VERSION Manifest-Version 的 Name 对象具有的属性。
static Attributes.Name | SEALED Sealed 的 Name 对象给出了用于密封的属性。
static Attributes.Name | SIGNATURE_VERSION Signature-Version 的 Name 对象给出了签名 JAR 文件时所使用的属性。
static Attributes.Name | SPECIFICATION_TITLE Specification-Title 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | SPECIFICATION_VENDOR Specification-Vendor 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | SPECIFICATION_VERSION Specification-Version 的 Name 对象给出了用于包的版本控制的属性。
构造方法摘要
Attributes.Name(String name)
用给定字符串名称构造一个新的属性名称。
方法摘要
boolean | equals(Object o) 将此属性名称与另一个属性名称进行相等性比较。
int | hashCode() 计算此属性名称的哈希值。
String | toString() 返回字符串形式的属性名称。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MANIFEST_VERSION

public static final Attributes.Name MANIFEST_VERSION
Manifest-Version 的 Name 对象具有的属性。此属性指示 JAR 文件清单所遵守的清单标准的版本号。

另请参见：
Manifest and Signature Specification

SIGNATURE_VERSION

public static final Attributes.Name SIGNATURE_VERSION
Signature-Version 的 Name 对象给出了签名 JAR 文件时所使用的属性。

另请参见：
Manifest and Signature Specification

CONTENT_TYPE

public static final Attributes.Name CONTENT_TYPE
Content-Type 的 Name 对象具有的属性。

CLASS_PATH

public static final Attributes.Name CLASS_PATH
Class-Path 的 Name 对象具有的属性。扩展包可以使用此属性来查找包含所需类的其他 JAR 文件。

另请参见：
Extensions Specification

MAIN_CLASS

public static final Attributes.Name MAIN_CLASS
Main-Class 的 Name 对象具有的属性，用于启动打包在 JAR 文件中的应用程序。Main-Class 属性与 java 应用程序启动器的 -jar 命令行选项一起使用。

SEALED

public static final Attributes.Name SEALED
Sealed 的 Name 对象给出了用于密封的属性。

另请参见：
Extension Sealing

EXTENSION_LIST

public static final Attributes.Name EXTENSION_LIST
Extension-List 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。

另请参见：
Installed extension dependency

EXTENSION_NAME

public static final Attributes.Name EXTENSION_NAME
Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。

另请参见：
Installed extension dependency

EXTENSION_INSTALLATION

public static final Attributes.Name EXTENSION_INSTALLATION
Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。

另请参见：
Installed extension dependency

IMPLEMENTATION_TITLE

public static final Attributes.Name IMPLEMENTATION_TITLE
Implementation-Title 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification

IMPLEMENTATION_VERSION

public static final Attributes.Name IMPLEMENTATION_VERSION
Implementation-Version 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification

IMPLEMENTATION_VENDOR

public static final Attributes.Name IMPLEMENTATION_VENDOR
Implementation-Vendor 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification

IMPLEMENTATION_VENDOR_ID

public static final Attributes.Name IMPLEMENTATION_VENDOR_ID
Implementation-Vendor-Id 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification

IMPLEMENTATION_URL

public static final Attributes.Name IMPLEMENTATION_URL
Implementation-Vendor-URL 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification

SPECIFICATION_TITLE

public static final Attributes.Name SPECIFICATION_TITLE
Specification-Title 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification

SPECIFICATION_VERSION

public static final Attributes.Name SPECIFICATION_VERSION
Specification-Version 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification

SPECIFICATION_VENDOR

public static final Attributes.Name SPECIFICATION_VENDOR
Specification-Vendor 的 Name 对象给出了用于包的版本控制的属性。

另请参见：
Java Product Versioning Specification
构造方法详细信息

Attributes.Name

public Attributes.Name(String name)
用给定字符串名称构造一个新的属性名称。

参数：
name - 属性字符串名称
抛出：
IllegalArgumentException - 如果属性名称无效
NullPointerException - 如果属性名称为 null
方法详细信息

equals

public boolean equals(Object o)
将此属性名称与另一个属性名称进行相等性比较。

覆盖：
类 Object 中的 equals
参数：
o - 要比较的对象
返回：
如果此属性名称与指定的属性对象相等，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
计算此属性名称的哈希值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回字符串形式的属性名称。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JarEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 JarEntry

java.lang.Object
    继承者  java.util.zip.ZipEntry
        继承者  java.util.jar.JarEntry
所有已实现的接口：
Cloneable
public class JarEntry
extends ZipEntry

此类用于表示 JAR 文件条目。

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
从类 java.util.zip.ZipEntry 继承的字段
DEFLATED, STORED
构造方法摘要
JarEntry(JarEntry je)
使用从指定的 JarEntry 对象获取的字段创建新的 JarEntry。
JarEntry(String name)
为指定的 JAR 文件条目名称创建新的 JarEntry。
JarEntry(ZipEntry ze)
使用从指定 ZipEntry 对象获取的字段创建新的 JarEntry。
方法摘要
Attributes | getAttributes() 返回此条目的 Manifest Attributes；如果没有，则返回 null。
Certificate[] | getCertificates() 返回此条目的 Certificate 对象；如果没有，则返回 null。
CodeSigner[] | getCodeSigners() 返回此条目的 CodeSigner 对象；如果没有，则返回 null。
从类 java.util.zip.ZipEntry 继承的方法
clone, getComment, getCompressedSize, getCrc, getExtra, getMethod, getName, getSize, getTime, hashCode, isDirectory, setComment, setCompressedSize, setCrc, setExtra, setMethod, setSize, setTime, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

JarEntry

public JarEntry(String name)
为指定的 JAR 文件条目名称创建新的 JarEntry。

参数：
name - JAR 文件条目名称
抛出：
NullPointerException - 如果条目名称为 null
IllegalArgumentException - 如果条目名称的长度大于 0xFFFF 字节。

JarEntry

public JarEntry(ZipEntry ze)
使用从指定 ZipEntry 对象获取的字段创建新的 JarEntry。

参数：
ze - 从其创建 JarEntry 的 ZipEntry 对象

JarEntry

public JarEntry(JarEntry je)
使用从指定的 JarEntry 对象获取的字段创建新的 JarEntry。

参数：
je - 要复制的 JarEntry
方法详细信息

getAttributes

public Attributes getAttributes()
                         throws IOException
返回此条目的 Manifest Attributes；如果没有，则返回 null。

返回：
此条目的 Manifest Attributes；如果没有，则返回 null
抛出：
IOException

getCertificates

public Certificate[] getCertificates()
返回此条目的 Certificate 对象；如果没有，则返回 null。只有从条目输入流读取一直读到流的结尾，这样在 JarEntry 经过完全验证之后，此方法才能被调用。否则，此方法将返回 null。

返回的证书数组由验证此条目的所有签名证书构成。每个签名证书后面跟着其支持证书链（可能为空）。每个签名证书及其支持证书链按从底到顶进行排序（即签名证书排在首位置，（根）证书授权排在末位置）。

返回：
返回此条目的 Certificate 对象；如果没有，则返回 null。

getCodeSigners

public CodeSigner[] getCodeSigners()
返回此条目的 CodeSigner 对象；如果没有，则返回 null。只有从条目输入流读取一直读到流的结尾，这样在 JarEntry 经过完全验证之后，此方法才能被调用。否则，此方法将返回 null。

返回的数组由签名此条目的所有代码签名者构成。

返回：
返回此条目的 CodeSigner 对象；如果没有，则返回 null。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JarException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 JarException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.util.zip.ZipException
                    继承者  java.util.jar.JarException
所有已实现的接口：
Serializable
public class JarException
extends ZipException

读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

从以下版本开始：
1.2
另请参见：
序列化表格

构造方法摘要
JarException()
构造不带详细消息的 JarException。
JarException(String s)
构造带指定详细消息的 JarException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JarException

public JarException()
构造不带详细消息的 JarException。

JarException

public JarException(String s)
构造带指定详细消息的 JarException。

参数：
s - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JarFile (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 JarFile

java.lang.Object
    继承者  java.util.zip.ZipFile
        继承者  java.util.jar.JarFile

public class JarFile
extends ZipFile

JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。它扩展了 java.util.zip.ZipFile 类，使之支持读取可选的 Manifest 条目。Manifest 可用于指定关于 jar 文件及其条目的元信息。

除非另行说明，否则将 null 参数传递给此类中的构造方法或方法都将抛出 NullPointerException。

从以下版本开始：
1.2
另请参见：
Manifest, ZipFile, JarEntry

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
static String | MANIFEST_NAME JAR 清单文件名称。
从类 java.util.zip.ZipFile 继承的字段
OPEN_DELETE, OPEN_READ
构造方法摘要
JarFile(File file)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify)
创建一个要从指定的 File 对象读取的新的 JarFile。
JarFile(File file, boolean verify, int mode)
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。
JarFile(String name)
创建一个要从指定的文件 name 读取的新的 JarFile。
JarFile(String name, boolean verify)
创建一个要从指定的文件 name 读取的新的 JarFile。
方法摘要
Enumeration<JarEntry> | entries() 返回 zip 文件条目的枚举。
ZipEntry | getEntry(String name) 返回给定条目名称的 ZipEntry；如果未找到，则返回 null。
InputStream | getInputStream(ZipEntry ze) 返回用于读取指定 zip 文件条目内容的输入流。
JarEntry | getJarEntry(String name) 返回给定条目名称的 JarEntry；如果未找到，则返回 null。
Manifest | getManifest() 返回 jar 文件清单；如果没有，则返回 null。
从类 java.util.zip.ZipFile 继承的方法
close, finalize, getName, size
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MANIFEST_NAME

public static final String MANIFEST_NAME
JAR 清单文件名称。

另请参见：
常量字段值

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

JarFile

public JarFile(String name)
        throws IOException
创建一个要从指定的文件 name 读取的新的 JarFile。如果文件是签名的，则将验证 JarFile。

参数：
name - 要打开供读取的 jar 文件名称
抛出：
IOException - 如果发生 I/O 错误
SecurityException - 如果对文件的访问被 SecurityManager 拒绝

JarFile

public JarFile(String name,
               boolean verify)
        throws IOException
创建一个要从指定的文件 name 读取的新的 JarFile。

参数：
name - 要打开供读取的 jar 文件名称
verify - 如果文件是签名的，是否验证 jar 文件
抛出：
IOException - 如果发生 I/O 错误
SecurityException - 如果对文件的访问被 SecurityManager 拒绝

JarFile

public JarFile(File file)
        throws IOException
创建一个要从指定的 File 对象读取的新的 JarFile。如果文件是签名的，则将验证 JarFile。

参数：
file - 要打开供读取的 jar 文件
抛出：
IOException - 如果发生 I/O 错误
SecurityException - 如果对文件的访问被 SecurityManager 拒绝

JarFile

public JarFile(File file,
               boolean verify)
        throws IOException
创建一个要从指定的 File 对象读取的新的 JarFile。

参数：
file - 要打开供读取的 jar 文件
verify - 如果文件是签名的，是否验证 jar 文件。
抛出：
IOException - 如果发生 I/O 错误
SecurityException - 如果对文件的访问被 SecurityManager 拒绝。

JarFile

public JarFile(File file,
               boolean verify,
               int mode)
        throws IOException
创建一个要从指定的 File 对象中以指定模式读取的新的 JarFile。模式参数必须是 OPEN_READ 或 OPEN_READ | OPEN_DELETE。

参数：
file - 要打开供读取的 jar 文件
verify - 如果文件是签名的，是否验证 jar 文件。
mode - 打开文件的模式
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果 mode 参数无效
SecurityException - 如果对文件的访问被 SecurityManager 拒绝
从以下版本开始：
1.3
方法详细信息

getManifest

public Manifest getManifest()
                     throws IOException
返回 jar 文件清单；如果没有，则返回 null。

返回：
jar 文件清单；如果没有，则返回 null
抛出：
IllegalStateException - 如果 jar 文件已关闭，则可能抛出此异常
IOException

getJarEntry

public JarEntry getJarEntry(String name)
返回给定条目名称的 JarEntry；如果未找到，则返回 null。

参数：
name - jar 文件条目名称
返回：
给定条目名称的 JarEntry；如果未找到，则返回 null。
抛出：
IllegalStateException - 如果 jar 文件已关闭，则可能抛出此异常
另请参见：
JarEntry

getEntry

public ZipEntry getEntry(String name)
返回给定条目名称的 ZipEntry；如果未找到，则返回 null。

覆盖：
类 ZipFile 中的 getEntry
参数：
name - jar 文件条目名称
返回：
给定条目名称的 ZipEntry；如果未找到，则返回 null
抛出：
IllegalStateException - 如果 jar 文件已关闭，则可能抛出此异常
另请参见：
ZipEntry

entries

public Enumeration<JarEntry> entries()
返回 zip 文件条目的枚举。

覆盖：
类 ZipFile 中的 entries
返回：
ZIP 文件条目的枚举

getInputStream

public InputStream getInputStream(ZipEntry ze)
                           throws IOException
返回用于读取指定 zip 文件条目内容的输入流。

覆盖：
类 ZipFile 中的 getInputStream
参数：
ze - zip 文件条目
返回：
用于读取指定 zip 文件条目内容的输入流
抛出：
ZipException - 如果出现 zip 文件格式错误
IOException - 如果发生 I/O 错误
SecurityException - 如果有任何未正确签名的 jar 文件条目。
IllegalStateException - 如果 jar 文件已关闭，则可能抛出此异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JarInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 JarInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.util.zip.InflaterInputStream
                继承者  java.util.zip.ZipInputStream
                    继承者  java.util.jar.JarInputStream
所有已实现的接口：
Closeable
public class JarInputStream
extends ZipInputStream

JarInputStream 类用于从任何输入流读取 JAR 文件内容。它扩展了 java.util.zip.ZipInputStream 类，使之支持读取可选的 Manifest 条目。Manifest 可用于存储有关 JAR 文件及其条目的元信息。

从以下版本开始：
1.2
另请参见：
Manifest, ZipInputStream

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
从类 java.util.zip.InflaterInputStream 继承的字段
buf, inf, len
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
JarInputStream(InputStream in)
创建新的 JarInputStream 并读取可选的清单。
JarInputStream(InputStream in, boolean verify)
创建新的 JarInputStream 并读取可选的清单。
方法摘要
protected ZipEntry | createZipEntry(String name) 为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。
Manifest | getManifest() 返回此 JAR 文件的 Manifest；如果没有，则返回 null。
ZipEntry | getNextEntry() 读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。
JarEntry | getNextJarEntry() 读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。
int | read(byte[] b, int off, int len) 从当前 JAR 文件条目读入字节数组。
从类 java.util.zip.ZipInputStream 继承的方法
available, close, closeEntry, skip
从类 java.util.zip.InflaterInputStream 继承的方法
fill, mark, markSupported, read, reset
从类 java.io.FilterInputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

JarInputStream

public JarInputStream(InputStream in)
               throws IOException
创建新的 JarInputStream 并读取可选的清单。如果清单存在，则若 JarInputStream 是签名的，还要试图验证签名。

参数：
in - 实际输入流
抛出：
IOException - 如果发生 I/O 错误

JarInputStream

public JarInputStream(InputStream in,
                      boolean verify)
               throws IOException
创建新的 JarInputStream 并读取可选的清单。如果清单存在并验证为 true，则若 JarInputStream 是签名的，还要试图验证签名。

参数：
in - 实际输入流
verify - 如果 JarInputStream 是签名的，是否需要验证。
抛出：
IOException - 如果发生 I/O 错误
方法详细信息

getManifest

public Manifest getManifest()
返回此 JAR 文件的 Manifest；如果没有，则返回 null。

返回：
此 JAR 文件的 Manifest；如果没有，则返回 null。

getNextEntry

public ZipEntry getNextEntry()
                      throws IOException
读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。如果已启用验证，则将流定位于下一个条目时所检测到的任何无效签名都将引发异常。

覆盖：
类 ZipInputStream 中的 getNextEntry
返回：
下一个 ZIP 文件条目；如果不存在更多条目，则返回 null
抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误
SecurityException - 如果有任何未正确签名的 jar 文件条目。

getNextJarEntry

public JarEntry getNextJarEntry()
                         throws IOException
读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。如果已启用验证，则将流定位于下一个条目时所检测到的任何无效签名都将引发异常。

返回：
下一个 ZIP 文件条目；如果已到最后一个条目，则返回 null
抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误
SecurityException - 如果有任何未正确签名的 jar 文件条目。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从当前 JAR 文件条目读入字节数组。如果 len 不为零，则在某个输入可用之前，此方法将阻塞；否则，不读取字节并且返回 0。如果已启用验证，则当前条目的任何无效签名将在到达条目末尾之前的某个点进行报告。

覆盖：
类 ZipInputStream 中的 read
参数：
b - 要读入数据的缓冲区
off - 目标数组 b 的初始偏移量
len - 读取的最大字节数
返回：
读取的实际字节数；如果到达条目末尾，则返回 -1
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，或者 len 为负或 len 大于 b.length - off
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误
SecurityException - 如果有任何未正确签名的 jar 文件条目。
另请参见：
FilterInputStream.in

createZipEntry

protected ZipEntry createZipEntry(String name)
为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。指定的 JAR 文件条目名称的清单属性将被复制到新的 JarEntry。

覆盖：
类 ZipInputStream 中的 createZipEntry
参数：
name - JAR/ZIP 文件条目的名称
返回：
刚创建的 JarEntry 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JarOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 JarOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.util.zip.DeflaterOutputStream
                继承者  java.util.zip.ZipOutputStream
                    继承者  java.util.jar.JarOutputStream
所有已实现的接口：
Closeable, Flushable
public class JarOutputStream
extends ZipOutputStream

JarOutputStream 类用于向任何输出流写入 JAR 文件内容。它扩展了 java.util.zip.ZipOutputStream 类，使之支持编写可选的 Manifest 条目。Manifest 可用于指定有关 JAR 文件及其条目的元信息。

从以下版本开始：
1.2
另请参见：
Manifest, ZipOutputStream

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
从类 java.util.zip.ZipOutputStream 继承的字段
DEFLATED, STORED
从类 java.util.zip.DeflaterOutputStream 继承的字段
buf, def
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
JarOutputStream(OutputStream out)
创建不带清单的新的 JarOutputStream。
JarOutputStream(OutputStream out, Manifest man)
使用指定的 Manifest 创建新的 JarOutputStream。
方法摘要
 void putNextEntry(ZipEntry ze)
开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。
从类 java.util.zip.ZipOutputStream 继承的方法
close, closeEntry, finish, setComment, setLevel, setMethod, write
从类 java.util.zip.DeflaterOutputStream 继承的方法
deflate, write
从类 java.io.FilterOutputStream 继承的方法
flush, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

JarOutputStream

public JarOutputStream(OutputStream out,
                       Manifest man)
                throws IOException
使用指定的 Manifest 创建新的 JarOutputStream。清单作为输出流的第一个条目被写入。

参数：
out - 实际输出流
man - 可选的 Manifest
抛出：
IOException - 如果发生 I/O 错误

JarOutputStream

public JarOutputStream(OutputStream out)
                throws IOException
创建不带清单的新的 JarOutputStream。

参数：
out - 实际输出流
抛出：
IOException - 如果发生 I/O 错误
方法详细信息

putNextEntry

public void putNextEntry(ZipEntry ze)
                  throws IOException
开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。此方法还将关闭以前的任何条目。如果没有指定条目的压缩方法，则使用默认压缩方法。如果条目没有设置修改时间，则使用当前时间。

覆盖：
类 ZipOutputStream 中的 putNextEntry
参数：
ze - 要写入的 ZIP/JAR 条目
抛出：
ZipException - 如果发生 ZIP 错误
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Manifest (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 Manifest

java.lang.Object
    继承者  java.util.jar.Manifest
所有已实现的接口：
Cloneable
public class Manifest
extends Object
implements Cloneable

Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。既有主 Manifest 的 Attributes，也有每个条目的 Attributes。有关 Manifest 格式的信息，请参阅 Manifest 格式规范。

从以下版本开始：
1.2
另请参见：
Attributes

构造方法摘要
Manifest()
构造新的空 Manifest。
Manifest(InputStream is)
从指定的输入流构造新的 Manifest。
Manifest(Manifest man)
构造新的 Manifest，它是指定 Manifest 的副本。
方法摘要
void | clear() 清除此 Manifest 中的主 Attributes 和条目。
Object | clone() 返回 Manifest 的浅表副本。
boolean | equals(Object o) 如果指定的 Object 也是一个 Manifest，并且具有相同的主 Attributes 和条目，则返回 true。
Attributes | getAttributes(String name) 返回指定条目名称的 Attributes。
Map<String,Attributes> | getEntries() 返回此 Manifest 中所包含条目的 Map。
Attributes | getMainAttributes() 返回 Manifest 的主 Attributes。
int | hashCode() 返回 Manifest 的哈希码。
void | read(InputStream is) 从指定的 InputStream 读取 Manifest。
void | write(OutputStream out) 将 Manifest 写入指定的 OutputStream。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Manifest

public Manifest()
构造新的空 Manifest。

Manifest

public Manifest(InputStream is)
         throws IOException
从指定的输入流构造新的 Manifest。

参数：
is - 包含清单数据的输入流
抛出：
IOException - 如果发生 I/O 错误

Manifest

public Manifest(Manifest man)
构造新的 Manifest，它是指定 Manifest 的副本。

参数：
man - 要复制的 Manifest
方法详细信息

getMainAttributes

public Attributes getMainAttributes()
返回 Manifest 的主 Attributes。

返回：
Manifest 的主 Attributes

getEntries

public Map<String,Attributes> getEntries()
返回此 Manifest 中所包含条目的 Map。每个条目由一个 String 名称（键）和相关的 Attributes（值）表示。Map 允许 null 键，但 read(java.io.InputStream) 并不创建带有 null 键的条目，也不创建使用 write(java.io.OutputStream) 编写的条目。

返回：
此 Manifest 中所包含条目的 Map

getAttributes

public Attributes getAttributes(String name)
返回指定条目名称的 Attributes。此方法定义为：
            return (Attributes)getEntries().get(name)
虽然 null 是有效的 name，当在 Manifest（从 jar 文件中获得）上调用 getAttributes(null) 时，将返回 null。尽管 jar 文件自身并不允许 null 命名的属性，则可以在 Manifest 上调用 getEntries()，然后在其结果之上调用带有 null 键和任意值的 put。getAttributes(null) 的后续调用将返回刚刚用 put 操作放入的值。

注意此方法不返回清单的主要属性；请参阅 getMainAttributes()。

参数：
name - 条目名称。
返回：
指定条目名称的 Attributes

clear

public void clear()
清除此 Manifest 中的主 Attributes 和条目。

write

public void write(OutputStream out)
           throws IOException
将 Manifest 写入指定的 OutputStream。在调用此方法前，必须在 MainAttributes 中设置 Attributes.Name.MANIFEST_VERSION。

参数：
out - 输出流。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
getMainAttributes()

read

public void read(InputStream is)
          throws IOException
从指定的 InputStream 读取 Manifest。读取的条目名称和属性将与当前的清单条目进行合并。

参数：
is - 输入流。
抛出：
IOException - 如果发生 I/O 错误

equals

public boolean equals(Object o)
如果指定的 Object 也是一个 Manifest，并且具有相同的主 Attributes 和条目，则返回 true。

覆盖：
类 Object 中的 equals
参数：
o - 要进行比较的对象
返回：
如果指定的 Object 也是一个 Manifest，并且具有相同的主 Attributes 和条目，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回 Manifest 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

clone

public Object clone()
返回 Manifest 的浅表副本。浅表副本的实现方式如下：
     public Object clone() { return new Manifest(this); }

覆盖：
类 Object 中的 clone
返回：
Manifest 的浅表副本
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Pack200 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
类 Pack200

java.lang.Object
    继承者  java.util.jar.Pack200

public abstract class Pack200
extends Object

以 Pack200 格式在 JAR 文件和打包的流之间进行转换。请参阅以下网址的 Network Transfer Format JSR 200 Specification:http://jcp.org/aboutJava/communityprocess/review/jsr200/index.html。

通常，应用程序开发人员使用打包器引擎在网站上部署或宿主 JAR 文件。部署应用程序则使用解包器引擎把字节流转换回 JAR 格式。

下面是使用打包器和解包器的一个示例：

    import java.util.jar.Pack200;
    import java.util.jar.Pack200.*;
    ...
    // Create the Packer object
    Packer packer = Pack200.newPacker();

    // Initialize the state by setting the desired properties
    Map p = packer.properties();
    // take more time choosing codings for better compression
    p.put(Packer.EFFORT, "7");  // default is "5"
    // use largest-possible archive segments (>10% better compression).
    p.put(Packer.SEGMENT_LIMIT, "-1");
    // reorder files for better compression.
    p.put(Packer.KEEP_FILE_ORDER, Packer.FALSE);
    // smear modification times to a single value.
    p.put(Packer.MODIFICATION_TIME, Packer.LATEST);
    // ignore all JAR deflation requests,
    // transmitting a single request to use "store" mode.
    p.put(Packer.DEFLATE_HINT, Packer.FALSE);
    // discard debug attributes
    p.put(Packer.CODE_ATTRIBUTE_PFX+"LineNumberTable", Packer.STRIP);
    // throw an error if an attribute is unrecognized
    p.put(Packer.UNKNOWN_ATTRIBUTE, Packer.ERROR);
    // pass one class file uncompressed:
    p.put(Packer.PASS_FILE_PFX+0, "mutants/Rogue.class");
    try {
        JarFile jarFile = new JarFile("/tmp/testref.jar");
        FileOutputStream fos = new FileOutputStream("/tmp/test.pack");
        // Call the packer
        packer.pack(jarFile, fos);
        jarFile.close();
        fos.close();

        File f = new File("/tmp/test.pack");
        FileOutputStream fostream = new FileOutputStream("/tmp/test.jar");
        JarOutputStream jostream = new JarOutputStream(fostream);
        Unpacker unpacker = Pack200.newUnpacker();
        // Call the unpacker
        unpacker.unpack(f, jostream);
        // Must explicitly close the output.
        jostream.close();
    } catch (IOException ioe) {
        ioe.printStackTrace();
    }

用 gzip 压缩的 Pack200 文件可以宿主在 HTTP/1.1 Web 服务器上。部署应用程序可以使用 "Accept-Encoding=pack200-gzip"。这向服务器指示客户机应用程序需要的是用 Pack200 编码并用 gzip 进一步压缩的文件版本。有关细节和技术的更多信息，请参阅 Java Deployment Guide。

除非另行说明，否则将 null 参数传递给此类中的构造方法或方法都会抛出 NullPointerException。

从以下版本开始：
1.5

嵌套类摘要
static interface | Pack200.Packer 打包器引擎把各种转换应用到输入 JAR 文件，从而可以通过压缩器（如 gzip 或 zip）高度压缩打包流。
static interface | Pack200.Unpacker 解包器引擎将打包的流转换为 JAR 文件。
方法摘要
static Pack200.Packer | newPacker() 获取一个实现 Packer 的新的类实例。
static Pack200.Unpacker | newUnpacker() 获取一个实现 Unpacker 的新的类实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

newPacker

public static Pack200.Packer newPacker()
获取一个实现 Packer 的新的类实例。

  • 如果定义了系统属性 java.util.jar.Pack200.Packer，那么该值将为具体实现类（必须实现 Packer）的完全限定名称。加载并实例化此类。如果此进程失败，则抛出未指定错误。

  • 如果尚未用系统属性指定实现，那么实例化系统默认的实现类并返回结果。

    • 注：如果多个线程同时使用返回的对象，则无法保证返回的对象操作正确。多线程应用程序应该分配多个打包器引擎，或者利用一个锁来顺序使用一个引擎。

    返回：
    新分配的 Packer 引擎。

    newUnpacker

    public static Pack200.Unpacker newUnpacker()
    获取一个实现 Unpacker 的新的类实例。

  • 如果定义了系统属性 java.util.jar.Pack200.Unpacker，那么该值将为具体实现类（必须实现 Unpacker）的完全限定名称。加载并实例化此类。如果此进程失败，则抛出未指定错误。

  • 如果尚未用系统属性指定实现，那么实例化系统默认的实现类并返回结果。

    • 注：如果多个线程同时使用返回的对象，则无法保证返回的对象操作正确。多线程应用程序应该分配多个解包器引擎，或者利用一个锁来顺序使用一个引擎。

    返回：
    新分配的 Unpacker 引擎。
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Pack200.Packer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.jar
接口 Pack200.Packer

正在封闭类：
Pack200
public static interface Pack200.Packer

打包器引擎把各种转换应用到输入 JAR 文件，从而可以通过压缩器（如 gzip 或 zip）高度压缩打包流。可使用 Pack200.newPacker() 获得该引擎的实例。高度压缩是通过使用 JSR 200 规范中描述的大量技术来实现的。一些技术包括排序、重排序和常量池的共处。

根据下面所述的打包引擎属性，将打包引擎初始化为初始状态。可以通过获取引擎属性（使用 properties()）并在映射上存储已修改属性来操作该初始状态。资源文件根本不做任何改动即可通过。类文件将不会包含相同的字节，因为解包器可以随意改变次要类文件的特性，比如常量池的顺序。但是类文件在语义上将是相同的，这在下面网址的 Java Virtual Machine Specification 中作了规定：http://java.sun.com/docs/books/vmspec/html/ClassFile.doc.html。

默认情况下，打包器不改变 JAR 元素的顺序。而且不改变每个 JAR 元素的修改时间和压缩提示。任何其他 ZIP 存档信息（如给出 Unix 文件权限的额外属性）将会丢失。

注意，打包和解包 JAR 通常将修改 JAR 中类文件的字节内容。这意味着打包和解包通常将使依赖于 JAR 元素字节图像的任何数字签名无效。为了签名并打包 JAR，您必须首先打包和解包 JAR 来“规范化”它，然后计算解包后 JAR 元素上签名，最后重新打包签名的 JAR。打包步骤应该准确地使用相同的选项，可能还需要把段范围设置为 "-1"，以防止在类文件大小有所改变时段边界的意外变化。

（其工作原理如下：打包器对任何类文件结构的任何重新排序是幂等的，因此，第二次打包不会改变第一次打包所生成的顺序。而且，JSR 200 规范保证解包器可为存档元素的任何给定传输顺序生成指定的字节图像。）

为了维护向后兼容性，如果输入 JAR 文件仅由 1.5（或更低版本）类文件组成，则生成 1.5 兼容的包文件。否则，生成 1.6 兼容的 pack200 文件。

从以下版本开始：
1.5

字段摘要
static String | CLASS_ATTRIBUTE_PFX 当与类属性名称连在一起时，使用 JSR 200 规范中指定的布局语言指出该属性的格式。
static String | CODE_ATTRIBUTE_PFX 当与代码属性名称连在一起时，指出该属性的格式。
static String | DEFLATE_HINT 如果将此属性设置为 TRUE 或 FALSE，则打包器将在输出存档中设置相应的压缩提示，并且不传输存档元素的单个压缩提示。
static String | EFFORT 如果将此属性设置为单个十进制数字，则打包器将在压缩存档时使用指定压缩级别。
static String | ERROR 字符串 "error"，某些属性的可能值。
static String | FALSE 字符串 "false"，某些属性的可能值。
static String | FIELD_ATTRIBUTE_PFX 当与字段属性名称连在一起时，指出该属性的格式。
static String | KEEP 字符串 "keep"，某些属性的可能值。
static String | KEEP_FILE_ORDER 如果将此属性设置为 TRUE，则打包器将按它们在源存档中的原始顺序传输所有元素。
static String | LATEST 字符串 "latest"，某些属性的可能值。
static String | METHOD_ATTRIBUTE_PFX 当与方法属性名称连在一起时，指出该属性的格式。
static String | MODIFICATION_TIME 如果将此属性设置为特殊的字符串 LATEST，则打包器将尝试在原始存档中的所有可用条目中确定最后修改时间，或者确定每个段中所有可用条目的最后修改时间。
static String | PASS 字符串 "pass"，某些属性的可能值。
static String | PASS_FILE_PFX 指出文件应该按字节传递（无压缩）。
static String | PROGRESS 解包器的百分比进度，由解包器定期更新。
static String | SEGMENT_LIMIT 此属性是一个数字，给出了每个存档段的估计目标大小 N（以字节为单位）。
static String | STRIP 字符串 "strip"，某些属性的可能值。
static String | TRUE 字符串 "true"，某些属性的可能值。
static String | UNKNOWN_ATTRIBUTE 指出遇到包含有未知属性的类文件时所采取的行动。
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 为属性映射上的 PropertyChange 事件注册一个侦听器。
void | pack(JarFile in, OutputStream out) 接收 JarFile 并将其转换为 Pack200 存档。
void | pack(JarInputStream in, OutputStream out) 接收 JarInputStream 并将其转换成 Pack200 存档。
SortedMap<String,String> | properties() 获取此引擎属性集。
void | removePropertyChangeListener(PropertyChangeListener listener) 移除由 addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。

字段详细信息

SEGMENT_LIMIT

static final String SEGMENT_LIMIT
此属性是一个数字，给出了每个存档段的估计目标大小 N（以字节为单位）。如果单个输入文件要求超过 N 字节，那么将给出它自己的存档段。

作为特殊情况，值 -1 将生成使用所有输入文件的单个大段，而值 0 将为每个类生成一个段。较大的存档段将带来较少的碎片和更好的压缩，但处理它们要求更多的内存。

每个段的大小是通过计算段中要传输的每个输入文件的大小，以及它的名称和其他要传输的属性的大小来估算的。

默认为 1000000（1 百万字节）。这允许在一个段中传输中等大小的输入 JAR 文件。它也限制了打包器和解包器的内存要求。

如果没有此限制，打包一个 10 Mb 的 JAR 通常要小 10%，但打包器可能要求较大的 Java 堆（大约是段范围的 10 倍）。

另请参见：
常量字段值

KEEP_FILE_ORDER

static final String KEEP_FILE_ORDER
如果将此属性设置为 TRUE，则打包器将按它们在源存档中的原始顺序传输所有元素。

如果将其设置为 FALSE，则打包器可能重新排序元素，并且移除携带无用信息（针对 Java 应用程序来说）的 JAR 目录条目。（通常这支持更好的压缩。）

默认为 TRUE，这保存了输入信息，但可能不必要地增大了所传输的存档。

另请参见：
常量字段值

EFFORT

static final String EFFORT
如果将此属性设置为单个十进制数字，则打包器将在压缩存档时使用指定压缩级别。1 级可能生成较大的尺寸但压缩速度较快，而 9 级将花费较长的时间，但可能生成更好的压缩。

特殊值 0 指示打包器直接复制原始的 JAR 文件（无压缩）。JSR 200 标准要求任何解包器将此特殊情况作为直接传输整个存档来理解。

默认为 5，花费适量的时间来生成合理的压缩。

另请参见：
常量字段值

DEFLATE_HINT

static final String DEFLATE_HINT
如果将此属性设置为 TRUE 或 FALSE，则打包器将在输出存档中设置相应的压缩提示，并且不传输存档元素的单个压缩提示。

如果将此属性设置为特殊字符串 KEEP，则打包器将尝试确定输入存档中每个可用元素的单个压缩提示，并单独传输此提示。

默认为 KEEP，这保存了输入信息，但可能不必要地增大了所传输的存档。

这取决于解包器实现在提示上采取的行动，以便合适地压缩得到的未打包 jar 的元素。

ZIP 或 JAR 元素的压缩提示指出元素是压缩的还是直接存储的。

另请参见：
常量字段值

MODIFICATION_TIME

static final String MODIFICATION_TIME
如果将此属性设置为特殊的字符串 LATEST，则打包器将尝试在原始存档中的所有可用条目中确定最后修改时间，或者确定每个段中所有可用条目的最后修改时间。此单值将作为段的一部分传输，并应用到每个段 (SEGMENT_LIMIT) 的所有条目。

这或多或少可以减少存档的传输大小，其代价是将所有已安装文件设置为单一日期。

如果将此属性设置为特殊字符串 KEEP，则打包器传输每个输入元素的单独修改时间。

默认为 KEEP，这保存了输入信息，但可能不必要地增大了所传输的存档。

这取决于解包器实现所采取的行动，以便合适地设置其输出文件中每个元素的修改时间。

另请参见：
SEGMENT_LIMIT, 常量字段值

PASS_FILE_PFX

static final String PASS_FILE_PFX
指出文件应该按字节传递（无压缩）。通过指定添加有不同字符串的其他属性，以生成具有公共前缀的属性系列，可以指定多个文件。

除了用 JAR 文件分隔符 '/' 替代系统文件分隔符以外，无任何路径名转换。

得到的文件名必须正好匹配其在 JAR 文件中出现的字符串。

如果属性值是一个目录名称，那么还将传递该目录下的所有文件。

示例：

     Map p = packer.properties();
     p.put(PASS_FILE_PFX+0, "mutants/Rogue.class");
     p.put(PASS_FILE_PFX+1, "mutants/Wolverine.class");
     p.put(PASS_FILE_PFX+2, "mutants/Storm.class");
     # Pass all files in an entire directory hierarchy:
     p.put(PASS_FILE_PFX+3, "police/");
.

另请参见：
常量字段值

UNKNOWN_ATTRIBUTE

static final String UNKNOWN_ATTRIBUTE
指出遇到包含有未知属性的类文件时所采取的行动。可能值为字符串 ERROR、STRIP 和 PASS。

字符串 ERROR 意味着整体打包操作将失败，并抛出 IOException 类型的异常。字符串 STRIP 意味着该属性将被删除。字符串 PASS 意味着整个类文件将在无压缩下通过（就像它是一个资源文件一样），并有合适的警告。这是此属性的默认值。

示例：

     Map p = pack200.getProperties();
     p.put(UNKNOWN_ATTRIBUTE, ERROR);
     p.put(UNKNOWN_ATTRIBUTE, STRIP);
     p.put(UNKNOWN_ATTRIBUTE, PASS);

另请参见：
常量字段值

CLASS_ATTRIBUTE_PFX

static final String CLASS_ATTRIBUTE_PFX
当与类属性名称连在一起时，使用 JSR 200 规范中指定的布局语言指出该属性的格式。

例如，此选项的效果内置于：pack.class.attribute.SourceFile=RUH。

还允许特殊字符串 ERROR、STRIP 和 PASS，与 UNKNOWN_ATTRIBUTE 具有相同的含义。这提供了一种方式，让用户可以请求按位拒绝、清除或传递特定的属性（不进行类压缩）。

下面的代码可用于支持 JCOV 属性：

     Map p = packer.properties();
     p.put(CODE_ATTRIBUTE_PFX+"CoverageTable",       "NH[PHHII]");
     p.put(CODE_ATTRIBUTE_PFX+"CharacterRangeTable", "NH[PHPOHIIH]");
     p.put(CLASS_ATTRIBUTE_PFX+"SourceID",           "RUH");
     p.put(CLASS_ATTRIBUTE_PFX+"CompilationID",      "RUH");

下面的代码可用于清除调试属性：

     Map p = packer.properties();
     p.put(CODE_ATTRIBUTE_PFX+"LineNumberTable",    STRIP);
     p.put(CODE_ATTRIBUTE_PFX+"LocalVariableTable", STRIP);
     p.put(CLASS_ATTRIBUTE_PFX+"SourceFile",        STRIP);

另请参见：
常量字段值

FIELD_ATTRIBUTE_PFX

static final String FIELD_ATTRIBUTE_PFX
当与字段属性名称连在一起时，指出该属性的格式。例如，此选项的效果内置于：pack.field.attribute.Deprecated=。还允许特殊字符串 ERROR、STRIP 和 PASS。

另请参见：
CLASS_ATTRIBUTE_PFX, 常量字段值

METHOD_ATTRIBUTE_PFX

static final String METHOD_ATTRIBUTE_PFX
当与方法属性名称连在一起时，指出该属性的格式。例如，此选项的效果内置于：pack.method.attribute.Exceptions=NH[RCH]。还允许特殊字符串 ERROR、STRIP 和 PASS。

另请参见：
CLASS_ATTRIBUTE_PFX, 常量字段值

CODE_ATTRIBUTE_PFX

static final String CODE_ATTRIBUTE_PFX
当与代码属性名称连在一起时，指出该属性的格式。例如，此选项的效果内置于：pack.code.attribute.LocalVariableTable=NH[PHOHRUHRSHH]。还允许特殊字符串 ERROR、STRIP 和 PASS。

另请参见：
CLASS_ATTRIBUTE_PFX, 常量字段值

PROGRESS

static final String PROGRESS
解包器的百分比进度，由解包器定期更新。值 0 - 100 是正常的，-1 指示停止。用 PropertyChangeListener 观察此属性。

至少，解包器必须在打包操作开始时把进度设置为 0，在结束时把进度设置为 100。

另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

KEEP

static final String KEEP
字符串 "keep"，某些属性的可能值。

另请参见：
DEFLATE_HINT, MODIFICATION_TIME, 常量字段值

PASS

static final String PASS
字符串 "pass"，某些属性的可能值。

另请参见：
UNKNOWN_ATTRIBUTE, CLASS_ATTRIBUTE_PFX, FIELD_ATTRIBUTE_PFX, METHOD_ATTRIBUTE_PFX, CODE_ATTRIBUTE_PFX, 常量字段值

STRIP

static final String STRIP
字符串 "strip"，某些属性的可能值。

另请参见：
UNKNOWN_ATTRIBUTE, CLASS_ATTRIBUTE_PFX, FIELD_ATTRIBUTE_PFX, METHOD_ATTRIBUTE_PFX, CODE_ATTRIBUTE_PFX, 常量字段值

ERROR

static final String ERROR
字符串 "error"，某些属性的可能值。

另请参见：
UNKNOWN_ATTRIBUTE, CLASS_ATTRIBUTE_PFX, FIELD_ATTRIBUTE_PFX, METHOD_ATTRIBUTE_PFX, CODE_ATTRIBUTE_PFX, 常量字段值

TRUE

static final String TRUE
字符串 "true"，某些属性的可能值。

另请参见：
KEEP_FILE_ORDER, DEFLATE_HINT, 常量字段值

FALSE

static final String FALSE
字符串 "false"，某些属性的可能值。

另请参见：
KEEP_FILE_ORDER, DEFLATE_HINT, 常量字段值

LATEST

static final String LATEST
字符串 "latest"，某些属性的可能值。

另请参见：
MODIFICATION_TIME, 常量字段值
方法详细信息

properties

SortedMap<String,String> properties()
获取此引擎属性集。此集合是“实时视图”，所以更改其内容可立即影响 Packer 引擎，并且在映射中可立即见到引擎中的变化（如进度指示）。

属性映射可能包含指定和默认属性的预定义实现。鼓励用户在修改已存在的属性前阅读该信息，并完全理解其含意。

特定实现的属性是用与实现者相关的包名称作前缀的，以 com. 或类似前缀开头。以 pack. 和 unpack. 开头的所有属性名称保留给此 API 使用。

未知属性可以用未指定的错误忽略或拒绝，并且无效的条目可能导致抛出未指定的错误。

返回的映射实现了所有可选的 SortedMap 操作。

返回：
属性键字符串到属性值的有序关联。

pack

void pack(JarFile in,
          OutputStream out)
          throws IOException
接收 JarFile 并将其转换为 Pack200 存档。

关闭其输入，但并不关闭其输出。（Pack200 存档是可添加的。）

参数：
in - 一个 JarFile
out - 一个 OutputStream
抛出：
IOException - 如果遇到错误

pack

void pack(JarInputStream in,
          OutputStream out)
          throws IOException
接收 JarInputStream 并将其转换成 Pack200 存档。

关闭其输入，但并不关闭其输出。（Pack200 存档是可添加的。）

对于 JAR 清单文件及其包含的目录，修改时间和压缩提示属性是不可用的。

参数：
in - 一个 JarInputStream
out - 一个 OutputStream
抛出：
IOException - 如果遇到错误
另请参见：
MODIFICATION_TIME, DEFLATE_HINT

addPropertyChangeListener

void addPropertyChangeListener(PropertyChangeListener listener)
为属性映射上的 PropertyChange 事件注册一个侦听器。通常应用程序使用它来更新进度条。

参数：
listener - 更改属性时要调用的对象。
另请参见：
properties(), PROGRESS

removePropertyChangeListener

void removePropertyChangeListener(PropertyChangeListener listener)
移除由 addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。

参数：
listener - 要移除的 PropertyChange 侦听器。
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Pack200.Unpacker (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.jar
接口 Pack200.Unpacker

正在封闭类：
Pack200
public static interface Pack200.Unpacker

解包器引擎将打包的流转换为 JAR 文件。可使用 Pack200.newUnpacker() 获得该引擎的实例。

此引擎所生成的每个 JAR 文件将包括字符串 "PACK200" 作为 zip 文件注释。这允许部署者检测 JAR 存档是否被打包或解包。

解包器的此版本与以前所有版本兼容。

从以下版本开始：
1.5

字段摘要
static String | DEFLATE_HINT 此属性指示解包器应该忽略 DEFLATE_HINT 的所有已传输的值，并用给定值 TRUE 或 FALSE 替换它们。
static String | FALSE 字符串 "false"，某些属性的可能值。
static String | KEEP 字符串 "keep"，某些属性的可能值。
static String | PROGRESS 解包器的百分比进度，由解包器定期更新。
static String | TRUE 字符串 "true"，某些属性的可能值。
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 为属性映射上的 PropertyChange 事件注册一个侦听器。
SortedMap<String,String> | properties() 获取此引擎属性集。
void | removePropertyChangeListener(PropertyChangeListener listener) 移除由 addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。
void | unpack(File in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
void | unpack(InputStream in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

字段详细信息

KEEP

static final String KEEP
字符串 "keep"，某些属性的可能值。

另请参见：
DEFLATE_HINT, 常量字段值

TRUE

static final String TRUE
字符串 "true"，某些属性的可能值。

另请参见：
DEFLATE_HINT, 常量字段值

FALSE

static final String FALSE
字符串 "false"，某些属性的可能值。

另请参见：
DEFLATE_HINT, 常量字段值

DEFLATE_HINT

static final String DEFLATE_HINT
此属性指示解包器应该忽略 DEFLATE_HINT 的所有已传输的值，并用给定值 TRUE 或 FALSE 替换它们。默认值为特殊字符串 KEEP，要求解包器保留所有已传输的压缩提示。

另请参见：
常量字段值

PROGRESS

static final String PROGRESS
解包器的百分比进度，由解包器定期更新。值 0 - 100 是正常的，-1 指示停止。用 PropertyChangeListener 观察此属性。

至少，解包器必须在打包操作开始时把进度设置为 0，在结束时把进度设置为 100。

另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值
方法详细信息

properties

SortedMap<String,String> properties()
获取此引擎属性集。此集合是“实时视图”，所以更改其内容可立即影响 Packer 引擎，并且在映射中可立即见到引擎中的变化（如进度指示）。

属性映射可能包含指定和默认属性的预定义实现。鼓励用户在修改已存在的属性前阅读该信息，并完全理解其含意。

特定实现的属性是用与实现者相关的包名称作前缀的，以 com. 或类似前缀开头。以 pack. 和 unpack. 开头的所有属性名称保留给此 API 使用。

未知的属性可以用未指定的错误忽略或拒绝，并且无效的条目可能导致抛出未指定的错误。

返回：
选项键字符串到选项值的有序关联。

unpack

void unpack(InputStream in,
            JarOutputStream out)
            throws IOException
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。将读取输入流的全部内容。使用下面描述的替代方法将 Pack200 存档读取到文件中并传递 File 对象可能更加高效。

关闭其输入，但并不关闭其输出。（输出可以累积更多元素。）

参数：
in - 一个 InputStream。
out - 一个 JarOutputStream。
抛出：
IOException - 如果遇到错误。

unpack

void unpack(File in,
            JarOutputStream out)
            throws IOException
读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

不关闭其输出。（输出可以累积更多元素。）

参数：
in - 一个 File。
out - 一个 JarOutputStream。
抛出：
IOException - 如果遇到错误。

addPropertyChangeListener

void addPropertyChangeListener(PropertyChangeListener listener)
为属性映射上的 PropertyChange 事件注册一个侦听器。通常应用程序使用它来更新进度条。

参数：
listener - 更改属性时要调用的对象。
另请参见：
properties(), PROGRESS

removePropertyChangeListener

void removePropertyChangeListener(PropertyChangeListener listener)
移除由 addPropertyChangeListener(java.beans.PropertyChangeListener) 所添加的 PropertyChange 事件侦听器。

参数：
listener - 要移除的 PropertyChange 侦听器。
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.jar (Java 2 Platform SE 6)

 java.util.jar
接口
Pack200.Packer
Pack200.Unpacker
类
Attributes
Attributes.Name
JarEntry
JarFile
JarInputStream
JarOutputStream
Manifest
Pack200
异常
JarException


java.util.jar (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.jar

提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

请参见：
描述

接口摘要
Pack200.Packer | 打包器引擎把各种转换应用到输入 JAR 文件，从而可以通过压缩器（如 gzip 或 zip）高度压缩打包流。
Pack200.Unpacker | 解包器引擎将打包的流转换为 JAR 文件。

类摘要
Attributes | Attributes 类将 Manifest 属性名称映射到关联的字符串值。
Attributes.Name | Attributes.Name 类表示存储在此 Map 中的一个属性名称。
JarEntry | 此类用于表示 JAR 文件条目。
JarFile | JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。
JarInputStream | JarInputStream 类用于从任何输入流读取 JAR 文件内容。
JarOutputStream | JarOutputStream 类用于向任何输出流写入 JAR 文件内容。
Manifest | Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。
Pack200 | 以 Pack200 格式在 JAR 文件和打包的流之间进行转换。

异常摘要
JarException 读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

软件包 java.util.jar 的描述

提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。清单存储与 JAR 文件内容有关的元信息，也用于签名 JAR 文件。

包规范

java.util.jar 包基于以下规范：
  • Info-ZIP 文件格式 - 基于 Info-ZIP 文件格式的 JAR 格式。参见 java.util.zip 包规范。

    在 JAR 文件中，所有文件名必须以 UTF-8 编码进行编码。

  • Manifest and Signature Specification - 清单格式规范。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.jar 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.jar 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.jar.Attributes (implements java.lang.Cloneable, java.util.Map<K,V>)
    • java.util.jar.Attributes.Name
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.ZipInputStream
            • java.util.jar.JarInputStream
    • java.util.jar.Manifest (implements java.lang.Cloneable)
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.ZipOutputStream
            • java.util.jar.JarOutputStream
    • java.util.jar.Pack200
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • java.util.zip.ZipException
            • java.util.jar.JarException
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
      • java.util.jar.JarEntry
    • java.util.zip.ZipFile
      • java.util.jar.JarFile

接口分层结构

  • java.util.jar.Pack200.Packer
  • java.util.jar.Pack200.Unpacker
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.jar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.jar
的使用

使用 java.util.jar 的软件包
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.lang.instrument 使用的 java.util.jar 中的类
JarFile
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。

java.net 使用的 java.util.jar 中的类
Attributes
Attributes 类将 Manifest 属性名称映射到关联的字符串值。
JarEntry
此类用于表示 JAR 文件条目。
JarFile
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。
Manifest
Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。

java.util.jar 使用的 java.util.jar 中的类
Attributes
Attributes 类将 Manifest 属性名称映射到关联的字符串值。
Attributes.Name
Attributes.Name 类表示存储在此 Map 中的一个属性名称。
JarEntry
此类用于表示 JAR 文件条目。
JarFile
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。
JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。
JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。
Manifest
Manifest 类用于维护 Manifest 条目名称及其相关的 Attributes。
Pack200.Packer
打包器引擎把各种转换应用到输入 JAR 文件，从而可以通过压缩器（如 gzip 或 zip）高度压缩打包流。
Pack200.Unpacker
解包器引擎将打包的流转换为 JAR 文件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.JarException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarException
的使用

没有 java.util.jar.JarException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.JarInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarInputStream
的使用

使用 JarInputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 JarInputStream 的使用

参数类型为 JarInputStream 的 java.util.jar 中的方法
 void Pack200.Packer.pack(JarInputStream in, OutputStream out)
接收 JarInputStream 并将其转换成 Pack200 存档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.JarOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarOutputStream
的使用

使用 JarOutputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 JarOutputStream 的使用

参数类型为 JarOutputStream 的 java.util.jar 中的方法
void | Pack200.Unpacker.unpack(File in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。
void | Pack200.Unpacker.unpack(InputStream in, JarOutputStream out) 读取 Pack200 存档，并将已编码的 JAR 写入 JarOutputStream。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.Pack200 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Pack200
的使用

没有 java.util.jar.Pack200 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.jar.Pack200.Packer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.jar.Pack200.Packer
的使用

使用 Pack200.Packer 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 Pack200.Packer 的使用

返回 Pack200.Packer 的 java.util.jar 中的方法
static Pack200.Packer Pack200.newPacker()
获取一个实现 Packer 的新的类实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.jar.Pack200.Unpacker 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.jar.Pack200.Unpacker
的使用

使用 Pack200.Unpacker 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 Pack200.Unpacker 的使用

返回 Pack200.Unpacker 的 java.util.jar 中的方法
static Pack200.Unpacker Pack200.newUnpacker()
获取一个实现 Unpacker 的新的类实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.Attributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Attributes
的使用

使用 Attributes 的软件包
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.net 中 Attributes 的使用

返回 Attributes 的 java.net 中的方法
Attributes | JarURLConnection.getAttributes() 如果此连接的 URL 指向 JAR 文件条目，则返回其 Attribute 对象；否则返回 null。
Attributes | JarURLConnection.getMainAttributes() 返回此连接的 JAR 文件的主要 Attribute。

java.util.jar 中 Attributes 的使用

返回 Attributes 的 java.util.jar 中的方法
Attributes | JarEntry.getAttributes() 返回此条目的 Manifest Attributes；如果没有，则返回 null。
Attributes | Manifest.getAttributes(String name) 返回指定条目名称的 Attributes。
Attributes | Manifest.getMainAttributes() 返回 Manifest 的主 Attributes。

返回变量类型为 Attributes 的类型的 java.util.jar 中的方法
 Map<String,Attributes> Manifest.getEntries()
返回此 Manifest 中所包含条目的 Map。

参数类型为 Attributes 的 java.util.jar 中的构造方法
Attributes(Attributes attr)
构造新的 Attributes 对象，该对象与指定的 Attributes 具有相同的属性名称-值映射关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.Attributes.Name 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Attributes.Name
的使用

使用 Attributes.Name 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 Attributes.Name 的使用

声明为 Attributes.Name 的 java.util.jar 中的字段
static Attributes.Name | Attributes.Name.CLASS_PATH Class-Path 的 Name 对象具有的属性。
static Attributes.Name | Attributes.Name.CONTENT_TYPE Content-Type 的 Name 对象具有的属性。
static Attributes.Name | Attributes.Name.EXTENSION_INSTALLATION Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | Attributes.Name.EXTENSION_LIST Extension-List 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | Attributes.Name.EXTENSION_NAME Extension-Name 的 Name 对象具有的属性，用于声明已安装扩展上的依赖项。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_TITLE Implementation-Title 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_URL Implementation-Vendor-URL 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_VENDOR Implementation-Vendor 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_VENDOR_ID Implementation-Vendor-Id 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.IMPLEMENTATION_VERSION Implementation-Version 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.MAIN_CLASS Main-Class 的 Name 对象具有的属性，用于启动打包在 JAR 文件中的应用程序。
static Attributes.Name | Attributes.Name.MANIFEST_VERSION Manifest-Version 的 Name 对象具有的属性。
static Attributes.Name | Attributes.Name.SEALED Sealed 的 Name 对象给出了用于密封的属性。
static Attributes.Name | Attributes.Name.SIGNATURE_VERSION Signature-Version 的 Name 对象给出了签名 JAR 文件时所使用的属性。
static Attributes.Name | Attributes.Name.SPECIFICATION_TITLE Specification-Title 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.SPECIFICATION_VENDOR Specification-Vendor 的 Name 对象给出了用于包的版本控制的属性。
static Attributes.Name | Attributes.Name.SPECIFICATION_VERSION Specification-Version 的 Name 对象给出了用于包的版本控制的属性。

参数类型为 Attributes.Name 的 java.util.jar 中的方法
 String Attributes.getValue(Attributes.Name name)
返回指定的 Attributes.Name 的值，如果未找到，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.Manifest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.Manifest
的使用

使用 Manifest 的软件包
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.net 中 Manifest 的使用

返回 Manifest 的 java.net 中的方法
 Manifest JarURLConnection.getManifest()
返回此连接的 Manifest；如果没有，则返回 null。

参数类型为 Manifest 的 java.net 中的方法
protected  Package URLClassLoader.definePackage(String name, Manifest man, URL url)
用该 ClassLoader 中的名称定义一个新包。

java.util.jar 中 Manifest 的使用

返回 Manifest 的 java.util.jar 中的方法
Manifest | JarInputStream.getManifest() 返回此 JAR 文件的 Manifest；如果没有，则返回 null。
Manifest | JarFile.getManifest() 返回 jar 文件清单；如果没有，则返回 null。

参数类型为 Manifest 的 java.util.jar 中的构造方法
JarOutputStream(OutputStream out, Manifest man)
使用指定的 Manifest 创建新的 JarOutputStream。
Manifest(Manifest man)
构造新的 Manifest，它是指定 Manifest 的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.JarEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarEntry
的使用

使用 JarEntry 的软件包
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.net 中 JarEntry 的使用

返回 JarEntry 的 java.net 中的方法
 JarEntry JarURLConnection.getJarEntry()
返回此连接的 JAR 条目对象（如果有）。

java.util.jar 中 JarEntry 的使用

返回 JarEntry 的 java.util.jar 中的方法
JarEntry | JarFile.getJarEntry(String name) 返回给定条目名称的 JarEntry；如果未找到，则返回 null。
JarEntry | JarInputStream.getNextJarEntry() 读取下一个 JAR 文件条目，并将流定位于此条目数据的开始处。

返回变量类型为 JarEntry 的类型的 java.util.jar 中的方法
 Enumeration<JarEntry> JarFile.entries()
返回 zip 文件条目的枚举。

参数类型为 JarEntry 的 java.util.jar 中的构造方法
JarEntry(JarEntry je)
使用从指定的 JarEntry 对象获取的字段创建新的 JarEntry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.jar.JarFile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.jar.JarFile
的使用

使用 JarFile 的软件包
java.lang.instrument | 提供允许 Java 编程语言代理检测运行在 JVM 上的程序的服务。
java.net | 为实现网络应用程序提供类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.lang.instrument 中 JarFile 的使用

参数类型为 JarFile 的 java.lang.instrument 中的方法
void | Instrumentation.appendToBootstrapClassLoaderSearch(JarFile jarfile) 指定 JAR 文件，检测类由引导类加载器定义。
void | Instrumentation.appendToSystemClassLoaderSearch(JarFile jarfile) 指定 JAR 文件，检测类由系统类加载器定义。

java.net 中 JarFile 的使用

返回 JarFile 的 java.net 中的方法
abstract  JarFile JarURLConnection.getJarFile()
返回此连接的 JAR 文件。

java.util.jar 中 JarFile 的使用

参数类型为 JarFile 的 java.util.jar 中的方法
 void Pack200.Packer.pack(JarFile in, OutputStream out)
接收 JarFile 并将其转换为 Pack200 存档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ConsoleHandler (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 ConsoleHandler

java.lang.Object
    继承者  java.util.logging.Handler
        继承者  java.util.logging.StreamHandler
            继承者  java.util.logging.ConsoleHandler

public class ConsoleHandler
extends StreamHandler

此 Handler 向 System.err 发布日志记录。默认情况下，使用 SimpleFormatter 生成简短的摘要。

配置: 默认情况下，每个 ConsoleHandler 都是使用以下 LogManager 配置属性执行初始化的。如果没有定义属性（或者属性具有非法值），则使用指定的默认值。

  • java.util.logging.ConsoleHandler.level 为 Handler 指定默认的级别（默认为 Level.INFO）。
  • java.util.logging.ConsoleHandler.filter 指定要使用的 Filter 类的名称（默认为无 Filter）。
  • java.util.logging.ConsoleHandler.formatter 指定要使用的 Formatter 类的名称（默认为 java.util.logging.SimpleFormatter）。
  • java.util.logging.ConsoleHandler.encoding 指定要使用的字符集编码的名称（默认为使用默认平台的编码）。

从以下版本开始：
1.4

构造方法摘要
ConsoleHandler()
为 System.err 创建一个 ConsoleHandler。
方法摘要
void | close() 重写 StreamHandler.close 以进行刷新，但是不关闭输出流。
void | publish(LogRecord record) 发布 LogRecord。
从类 java.util.logging.StreamHandler 继承的方法
flush, isLoggable, setEncoding, setOutputStream
从类 java.util.logging.Handler 继承的方法
getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConsoleHandler

public ConsoleHandler()
为 System.err 创建一个 ConsoleHandler。

根据 LogManager 属性（或其默认值）配置 ConsoleHandler。

方法详细信息

publish

public void publish(LogRecord record)
发布 LogRecord。

最初向 Logger 对象发出的日志请求，该请求初始化 LogRecord 并可在此转发这一日志记录。

覆盖：
类 StreamHandler 中的 publish
参数：
record - 日志事件的描述。忽略 null 记录，并且也不发布它。

close

public void close()
重写 StreamHandler.close 以进行刷新，但是不关闭输出流。也就是说不关闭 System.err。

覆盖：
类 StreamHandler 中的 close
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ErrorManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 ErrorManager

java.lang.Object
    继承者  java.util.logging.ErrorManager

public class ErrorManager
extends Object

可将 ErrorManager 对象附加到 Handler，以便处理日志记录过程中 Handler 上所发生的错误。

在处理日志记录输出时，如果 Handler 遇到问题，则 Handler 应该调用其相关的 ErrorManager，而不是抛出异常以返回到日志记录调用的发出方（其可能对此不感兴趣）。

字段摘要
static int | CLOSE_FAILURE CLOSE_FAILURE 用于对输出流的关闭失败时。
static int | FLUSH_FAILURE FLUSH_FAILURE 用于对输出流的刷新失败时。
static int | FORMAT_FAILURE FORMAT_FAILURE 用于因任何格式化问题导致的失败 。
static int | GENERIC_FAILURE GENERIC_FAILURE 用于不属于其他任何一类的失败。
static int | OPEN_FAILURE OPEN_FAILURE 用于对输出流的打开失败时。
static int | WRITE_FAILURE WRITE_FAILURE 用于对输出流的写入失败时。
构造方法摘要
ErrorManager()
方法摘要
 void error(String msg, Exception ex, int code)
在发生 Handler 失败时调用 error 方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GENERIC_FAILURE

public static final int GENERIC_FAILURE
GENERIC_FAILURE 用于不属于其他任何一类的失败。

另请参见：
常量字段值

WRITE_FAILURE

public static final int WRITE_FAILURE
WRITE_FAILURE 用于对输出流的写入失败时。

另请参见：
常量字段值

FLUSH_FAILURE

public static final int FLUSH_FAILURE
FLUSH_FAILURE 用于对输出流的刷新失败时。

另请参见：
常量字段值

CLOSE_FAILURE

public static final int CLOSE_FAILURE
CLOSE_FAILURE 用于对输出流的关闭失败时。

另请参见：
常量字段值

OPEN_FAILURE

public static final int OPEN_FAILURE
OPEN_FAILURE 用于对输出流的打开失败时。

另请参见：
常量字段值

FORMAT_FAILURE

public static final int FORMAT_FAILURE
FORMAT_FAILURE 用于因任何格式化问题导致的失败 。

另请参见：
常量字段值
构造方法详细信息

ErrorManager

public ErrorManager()
方法详细信息

error

public void error(String msg,
                  Exception ex,
                  int code)
在发生 Handler 失败时调用 error 方法。

可在子类中重写此方法。此基类中的默认行为是将第一个调用报告给 System.err，忽略随后的调用。

参数：
msg - 描述性的字符串（可能为 null）。
ex - 异常（可能为 null）。
code - ErrorManager 中所定义的错误代码。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 FileHandler

java.lang.Object
    继承者  java.util.logging.Handler
        继承者  java.util.logging.StreamHandler
            继承者  java.util.logging.FileHandler

public class FileHandler
extends StreamHandler

简单的文件日志记录 Handler。

FileHandler 可以写入指定的文件，也可以写入文件轮换集。

对于文件轮换集而言，到达每个文件的给定大小限制后，就关闭该文件，将其轮换出去，并打开新的文件。通过在基本文件名中添加 "0"、"1"、"2" 等来依次命名旧文件。

默认情况下，IO 库中启用了缓冲，但当缓冲完成时，每个日志记录都要被刷新。

默认情况下，XMLFormatter 类用于格式化。

配置: 默认情况下，每个 FileHandler 都是使用以下 LogManager 配置属性执行初始化的。如果没有定义属性（或者属性具有非法值），则使用指定的默认值。

  • java.util.logging.FileHandler.level 为 Handler 指定默认的级别（默认为 Level.ALL）。
  • java.util.logging.FileHandler.filter 指定要使用的 Filter 类的名称（默认为无 Filter）。
  • java.util.logging.FileHandler.formatter 指定要使用的 Formatter 类的名称（默认为 java.util.logging.XMLFormatter）。
  • java.util.logging.FileHandler.encoding 指定要使用的字符集编码的名称（默认使用默认的平台编码）。
  • java.util.logging.FileHandler.limit 指定要写入到任意文件的近似最大量（以字节为单位）。如果该数为 0，则没有限制（默认为无限制）。
  • java.util.logging.FileHandler.count 指定有多少输出文件参与循环（默认为 1）。
  • java.util.logging.FileHandler.pattern 为生成的输出文件名称指定一个模式。有关细节请参见以下内容（默认为 "%h/java%u.log"）。
  • java.util.logging.FileHandler.append 指定是否应该将 FileHandler 追加到任何现有文件上（默认为 false）。

模式由包括以下特殊组件的字符串组成，则运行时要替换这些组件：

  • "/" 本地路径名分隔符
  • "%t" 系统临时目录
  • "%h" "user.home" 系统属性的值
  • "%g" 区分循环日志的生成号
  • "%u" 解决冲突的唯一号码
  • "%%" 转换为单个百分数符号"%"
如果未指定 "%g" 字段，并且文件计数大于 1，那么生成号将被添加到所生成文件名末尾的小数点后面。

例如，文件计数为 2 的 "%t/java%g.log" 模式通常导致在 Solaris 系统中将日志文件写入 /var/tmp/java0.log 和 /var/tmp/java1.log，而在 Windows 95 中，则将其写入 C:\TEMP\java0.log 和 C:\TEMP\java1.log。

按照 0、1、2 等的序列安排生成号。

通常，将唯一字段 "%u" 设置为 0。但是如果 FileHandler 试图打开文件名并查找当前被另一个进程使用的文件，则增加唯一的字段号并再次重试。重复此操作直到 FileHandler 找到当前没有被使用的文件名。如果有冲突并且没有指定 "%u" 字段，则将该字段添加到文件名末尾的小数点后（它将位于所有自动添加的生成号后面）。

因此，如果三个进程都试图将日志记录到 fred%u.%g.txt，那么它们可能将 fred0.0.txt、fred1.0.txt、fred2.0.txt 作为其循环序列中的首个文件而结束。

注意，使用本地磁盘文件系统时，使用唯一的 id 以避免冲突是系统可靠运行的唯一保证。

从以下版本开始：
1.4

构造方法摘要
FileHandler()
构造一个默认的 FileHandler。
FileHandler(String pattern)
初始化要写入给定文件名的 FileHandler 。
FileHandler(String pattern, boolean append)
初始化要写入给定文件名的 FileHandler（使用可选的 append）。
FileHandler(String pattern, int limit, int count)
初始化要写入文件集的 FileHandler。
FileHandler(String pattern, int limit, int count, boolean append)
初始化要写入文件集的 FileHandler（使用可选的 append）。
方法摘要
void | close() 关闭所有文件。
void | publish(LogRecord record) 格式化并发布 LogRecord。
从类 java.util.logging.StreamHandler 继承的方法
flush, isLoggable, setEncoding, setOutputStream
从类 java.util.logging.Handler 继承的方法
getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileHandler

public FileHandler()
            throws IOException,
                   SecurityException
构造一个默认的 FileHandler。可完全从 LogManager 属性（或其默认值）进行配置。

抛出：
IOException - 如果打开文件时存在 IO 问题。
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control"))。
NullPointerException - 如果模式属性是一个空的 String。

FileHandler

public FileHandler(String pattern)
            throws IOException,
                   SecurityException
初始化要写入给定文件名的 FileHandler 。

根据 LogManager 属性（或其默认值）来配置 FileHandler（给定的模式参数用作文件名模式的情况除外），将文件限制设置为无限制，文件计数设置为 1。

由于对写入的数据量没有限制，因此要谨慎使用。

参数：
pattern - 输出文件的名称。
抛出：
IOException - 如果打开文件时存在 IO 问题。
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
IllegalArgumentException - 如果模式是一个空的 string。

FileHandler

public FileHandler(String pattern,
                   boolean append)
            throws IOException,
                   SecurityException
初始化要写入给定文件名的 FileHandler（使用可选的 append）。

根据 LogManager 属性（或其默认值）来配置 FileHandler（给定的模式参数用作文件名模式的情况除外），将文件限制设置为无限制，文件计数设置为 1，将 append 模式设置为给定的 append 参数。

由于对写入的数据量没有限制，因此要谨慎使用。

参数：
pattern - 输出文件的名称。
append - 指定 append 模式。
抛出：
IOException - 如果打开文件时存在 IO 问题。
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
IllegalArgumentException - 如果模式是一个空的 string。

FileHandler

public FileHandler(String pattern,
                   int limit,
                   int count)
            throws IOException,
                   SecurityException
初始化要写入文件集的 FileHandler。已向某个文件写入给定限制的数据量（近似）后，则打开另一个文件。输出将在计数文件集中进行循环。

根据 LogManager 属性（或其默认值）来配置 FileHandler（给定的模式参数用作文件名模式的情况除外），将文件限制设置为限制参数，将文件计数设置为给定的计数参数。

计数必须至少为 1。

参数：
pattern - 为输出文件命名的模式。
limit - 写入到任何一个文件的最大字节数。
count - 要使用的文件数。
抛出：
IOException - 如果打开文件时存在 IO 问题。
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
IllegalArgumentException - 如果 limit < 0，或 count < 1。
IllegalArgumentException - 如果模式是一个空的 string。

FileHandler

public FileHandler(String pattern,
                   int limit,
                   int count,
                   boolean append)
            throws IOException,
                   SecurityException
初始化要写入文件集的 FileHandler（使用可选的 append）。已向某个文件写入给定限制的数据量（近似）后，则打开另一个文件。输出将在计数文件集中进行循环。

根据 LogManager 属性（或其默认值）来配置 FileHandler（给定的模式参数用作文件名模式的情况除外），将文件限制设置为限制参数，将文件计数设置为给定的计数参数，将 append 模式设置为给定的 append 参数。

计数必须至少为 1。

参数：
pattern - 为输出文件命名的模式。
limit - 写入到任何一个文件的最大字节数。
count - 要使用的文件数。
append - 指定 append 模式。
抛出：
IOException - 如果打开文件时存在 IO 问题。
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
IllegalArgumentException - 如果 limit < 0，或 count < 1。
IllegalArgumentException - 如果模式是一个空的 string。
方法详细信息

publish

public void publish(LogRecord record)
格式化并发布 LogRecord。

覆盖：
类 StreamHandler 中的 publish
参数：
record - 日志事件的描述。忽略 null 记录，并且也不发布它。

close

public void close()
           throws SecurityException
关闭所有文件。

覆盖：
类 StreamHandler 中的 close
抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Filter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
接口 Filter

public interface Filter

Filter 可用于为记录内容提供比记录级别所提供的更细粒度的控制。

每个 Logger 和 Handler 都有一个关联的过滤器。Logger 或 Handler 可以调用 isLoggable 方法来检查是否应该发布给定的 LogRecord。如果 isLoggable 返回 false，则丢弃 LogRecord。

从以下版本开始：
1.4

方法摘要
 boolean isLoggable(LogRecord record)
检查是否应该发布给定的日志记录。

方法详细信息

isLoggable

boolean isLoggable(LogRecord record)
检查是否应该发布给定的日志记录。

参数：
record - 一个 LogRecord
返回：
如果应该发布日志记录，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Formatter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 Formatter

java.lang.Object
    继承者  java.util.logging.Formatter
直接已知子类：
SimpleFormatter, XMLFormatter
public abstract class Formatter
extends Object

Formatter 为格式化 LogRecords 提供支持。

一般来说，每个日志记录 Handler 都有关联的 Formatter。Formatter 接受 LogRecord，并将它转换为一个字符串。

有些 Formatter（如 XMLFormatter）需要围绕一组格式化记录来包装头部和尾部字符串。可以使用 getHeader 和 getTail 方法来获得这些字符串。

从以下版本开始：
1.4

构造方法摘要
protected Formatter()
构造一个新的 Formatter。
方法摘要
abstract String | format(LogRecord record) 格式化给定的日志记录，并返回格式化后的字符串。
String | formatMessage(LogRecord record) 本地化和格式化来自日志记录的消息字符串。
String | getHead(Handler h) 返回一组格式化记录的头部字符串。
String | getTail(Handler h) 返回一组格式化记录的尾部字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Formatter

protected Formatter()
构造一个新的 Formatter。

方法详细信息

format

public abstract String format(LogRecord record)
格式化给定的日志记录，并返回格式化后的字符串。

得到的格式化 String 通常包括 LogRecord 消息字段的本地化和格式化版本。Formatter.formatMessage 这个便捷方法可以（可选）用来本地化和格式化消息字段。

参数：
record - 要格式化的日志记录。
返回：
格式化的日志记录

getHead

public String getHead(Handler h)
返回一组格式化记录的头部字符串。

此基类返回一个空字符串，但是它可以通过子类进行重写。

参数：
h - 目标 handler（可以为 null）
返回：
头部字符串

getTail

public String getTail(Handler h)
返回一组格式化记录的尾部字符串。

此基类返回一个空字符串，但是它可以通过子类进行重写。

参数：
h - 目标 handler（可以为 null）
返回：
尾部字符串

formatMessage

public String formatMessage(LogRecord record)
本地化和格式化来自日志记录的消息字符串。在 Formatter 子类执行格式化时，此方法可以作为一种便捷方法使用。

首先使用记录的 ResourceBundle 将消息字符串本地化为格式字符串。（如果不存在 ResourceBundle，或没有找到消息键，则将该键用作格式字符串。）格式 String 使用 java.text 样式进行格式化。

  • 如果没有参数，则不使用 Formatter。
  • 否则，如果字符串包含 "{0"，则使用 java.text.MessageFormat 来格式化字符串。
  • 否则，不执行格式化。

参数：
record - 包含原始消息的日志记录
返回：
已本地化和格式化的消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Handler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 Handler

java.lang.Object
    继承者  java.util.logging.Handler
直接已知子类：
MemoryHandler, StreamHandler
public abstract class Handler
extends Object

Handler 对象从 Logger 中获取日志信息，并将这些信息导出。例如，它可将这些信息写入控制台或文件中，也可以将这些信息发送到网络日志服务中，或将其转发到操作系统日志中。

可通过执行 setLevel(Level.OFF) 来禁用 Handler，并可通过执行适当级别的 setLevel 来重新启用。

Handler 类通常使用 LogManager 属性来设置 Handler 的 Filter、Formatter 和 Level 的默认值。有关每个具体的 Handler 类，请参阅指定的文档。

从以下版本开始：
1.4

构造方法摘要
protected Handler()
默认构造方法。
方法摘要
abstract void | close() 关闭 Handler，并释放所有相关的资源。
abstract void | flush() 刷新所有的缓冲输出。
String | getEncoding() 返回该 Handler 的字符编码。
ErrorManager | getErrorManager() 获取该 Handler 的 ErrorManager。
Filter | getFilter() 获得该 Handler 的当前 Filter。
Formatter | getFormatter() 返回该 Handler 的 Formatter。
Level | getLevel() 获得用于指定该 Handler 所记录信息的日志级别。
boolean | isLoggable(LogRecord record) 检查该 Handler 是否实际记录给定的 LogRecord。
abstract void | publish(LogRecord record) 发布 LogRecord。
protected void | reportError(String msg, Exception ex, int code) 用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。
void | setEncoding(String encoding) 设置该 Handler 所用的字符编码。
void | setErrorManager(ErrorManager em) 为该 Handler 定义一个 ErrorManager。
void | setFilter(Filter newFilter) 设置 Filter，以控制该 Handler 的输出。
void | setFormatter(Formatter newFormatter) 设置 Formatter。
void | setLevel(Level newLevel) 设置日志级别，指定该 Handler 所记录的信息级别。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Handler

protected Handler()
默认构造方法。得到的 Handler 具有 Level.ALL 的日志级别，不具有 Formatter 和 Filter。作为 ErrorManager 安装默认的 ErrorManager 实例。

方法详细信息

publish

public abstract void publish(LogRecord record)
发布 LogRecord。

最初向 Logger 对象发出的日志请求，此请求可初始化 LogRecord 并可在此转发这一日志记录。

Handler 负责在必要时进行信息格式化。 格式化应该包括本地化。

参数：
record - 日志事件的描述。忽略 null 记录，并且也不发布它。

flush

public abstract void flush()
刷新所有的缓冲输出。

close

public abstract void close()
                    throws SecurityException
关闭 Handler，并释放所有相关的资源。

Close 方法将执行 flush，然后关闭 Handler。调用 close 方法后，就不应再使用该 Handler。要么默认忽略方法调用，要么抛出运行时异常。

抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

setFormatter

public void setFormatter(Formatter newFormatter)
                  throws SecurityException
设置 Formatter。将该 Formatter 用于格式化该 Handler 的 LogRecords。

某些 Handlers 不能使用 Formatters，在此情形下将记住而不是使用 Formatter。

参数：
newFormatter - Formatter 将使用（不可为空）
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

getFormatter

public Formatter getFormatter()
返回该 Handler 的 Formatter。

返回：
Formatter（可以为空）。

setEncoding

public void setEncoding(String encoding)
                 throws SecurityException,
                        UnsupportedEncodingException
设置该 Handler 所用的字符编码。

应在将任何 LogRecords 写入 Handler 之前设置编码。

参数：
encoding - 所支持字符编码的名称。可以为空，以表明应为默认平台编码。
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。
UnsupportedEncodingException - 如果不支持指定的编码。

getEncoding

public String getEncoding()
返回该 Handler 的字符编码。

返回：
编码名称。可以为空，以表明应使用默认编码。

setFilter

public void setFilter(Filter newFilter)
               throws SecurityException
设置 Filter，以控制该 Handler 的输出。

对于 publish 的每个调用，Handler 将调用该 Filter （如果不为空），以检查是否应发布或放弃 LogRecord。

参数：
newFilter - Filter 对象（可以为空）
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

getFilter

public Filter getFilter()
获得该 Handler 的当前 Filter。

返回：
Filter 对象（可以为空）

setErrorManager

public void setErrorManager(ErrorManager em)
为该 Handler 定义一个 ErrorManager。

如果使用该 Handler 时发生任何错误，将调用 ErrorManager 的 "error" 方法。

参数：
em - 新的 ErrorManager
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

getErrorManager

public ErrorManager getErrorManager()
获取该 Handler 的 ErrorManager。

抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

reportError

protected void reportError(String msg,
                           Exception ex,
                           int code)
用于向该 Handler 的 ErrorManager 报告错误的受保护便利方法。注意，该方法无需进行安全检查即可获取和使用 ErrorManager。因此，可在调用者无特权的环境下使用该方法。

参数：
msg - 描述性字符串（可以为空）
ex - 异常（可以为空）
code - 在 ErrorManager 中定义的错误代码

setLevel

public void setLevel(Level newLevel)
              throws SecurityException
设置日志级别，指定该 Handler 所记录的信息级别。将丢弃低于该值的信息级别。

其目的在于允许开发人员打开大多数日志，但是限制将信息发送到特定 Handlers。

参数：
newLevel - 日志级别的新值
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

getLevel

public Level getLevel()
获得用于指定该 Handler 所记录信息的日志级别。将丢弃低于该值的信息级别。

返回：
正在记录的信息级别。

isLoggable

public boolean isLoggable(LogRecord record)
检查该 Handler 是否实际记录给定的 LogRecord。

该方法检查 LogRecord 是否具有适当的 Level，以及是否满足任何 Filter。它也可进行其他 Handler 特定的检查，以防处理程序记录 LogRecord。如果 LogRecord 为 Null，将返回 False。

参数：
record - 一个 LogRecord
返回：
如果要记录 LogRecord，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Level (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 Level

java.lang.Object
    继承者  java.util.logging.Level
所有已实现的接口：
Serializable
public class Level
extends Object
implements Serializable

Level 类定义了一组可用来控制日志输出的标准日志级别。日志 Level 对象是有序的，并且是通过有序的整数来指定。在给定的级别上启用日志记录也就启用了所有较高级别的日志记录。

客户机一般应该使用预定义的 Level 常量（如 Level.SEVERE）。

各级别按降序排列如下：

  • SEVERE（最高值）
  • WARNING
  • INFO
  • CONFIG
  • FINE
  • FINER
  • FINEST（最低值）
此外，还有一个级别 OFF，可用来关闭日志记录，使用级别 ALL 启用所有消息的日志记录。

第三方可通过子类化 Level 来定义其他的日志级别。在这种情况下，子类应该注意选择唯一的整数级别值，并确保通过定义合适的 readResolve 方法，维护整个序列化过程的 Object 单值属性。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
static Level | ALL ALL 指示应该记录所有消息。
static Level | CONFIG CONFIG 是用于静态配置消息的消息级别。
static Level | FINE FINE 是提供跟踪信息的消息级别。
static Level | FINER FINER 指示一条相当详细的跟踪消息。
static Level | FINEST FINEST 指示一条最详细的跟踪消息。
static Level | INFO INFO 是报告消息的消息级别。
static Level | OFF OFF 是一个可用于关闭日志记录的特殊级别。
static Level | SEVERE SEVERE 是指示严重失败的消息级别。
static Level | WARNING WARNING 是指示潜在问题的消息级别。
构造方法摘要
protected | Level(String name, int value) 使用给定的整数值创建一个指定的 Level。
protected | Level(String name, int value, String resourceBundleName) 使用给定的整数值和给定的本地化资源名称创建一个指定的 Level。
方法摘要
boolean | equals(Object ox) 比较两个对象值的相等性。
String | getLocalizedName() 返回当前默认语言环境的 Level 的本地化字符串名称。
String | getName() 返回 Level 的非本地化字符串名称。
String | getResourceBundleName() 返回级别的本地化资源包名称；如果没有定义本地化包，则返回 null。
int | hashCode() 生成哈希码。
int | intValue() 获得此级别的整数值。
static Level | parse(String name) 将级别名称字符串解析成 Level。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

OFF

public static final Level OFF
OFF 是一个可用于关闭日志记录的特殊级别。此级别初始化为 Integer.MAX_VALUE。

SEVERE

public static final Level SEVERE
SEVERE 是指示严重失败的消息级别。

通常，SEVERE 消息应该描述相当重要的事件，这些事件会阻止正常程序的执行。它们对于最终用户和系统管理员来说应该是很容易理解的。此级别初始化为 1000。

WARNING

public static final Level WARNING
WARNING 是指示潜在问题的消息级别。

通常，WARNING 消息应该描述最终用户或系统管理员感兴趣的事件，或者那些指示潜在问题的事件。此级别初始化为 900。

INFO

public static final Level INFO
INFO 是报告消息的消息级别。

通常，INFO 消息被写入到控制台或与之相当的地方。因此，INFO 级别应该只用于相当重要的，对于最终用户和系统管理员有意义的消息。此级别初始化为 800。

CONFIG

public static final Level CONFIG
CONFIG 是用于静态配置消息的消息级别。

CONFIG 消息提供各种静态配置信息，并协助调试那些与特定配置有关的问题。例如，CONFIG 消息可能包括 CPU 类型、图形色深、GUI 外观等等。此级别初始化为 700。

FINE

public static final Level FINE
FINE 是提供跟踪信息的消息级别。

FINE、FINER 和 FINEST 都适合用于相对详细的跟踪。三个级别的准确意义在不同子系统间有所不同，但是通常来说，FINEST 应该用于最为详细的输出，FINER 用于不太详细的输出，FINE 用于极少量（且非常重要）的消息。

通常，FINE 级别应该用于开发人员比较感兴趣的信息，而这些开发人员对特定子系统则没有特别的兴趣。

FINE 消息可能包括诸如次要的（可恢复的）失败之类的信息。指示潜在性能问题的信息也可以作为 FINE 记录到日志。此级别初始化为 500。

FINER

public static final Level FINER
FINER 指示一条相当详细的跟踪消息。在默认情况下，对于输入、返回或抛出异常的日志记录调用在此级别进行跟踪。此级别初始化为 400。

FINEST

public static final Level FINEST
FINEST 指示一条最详细的跟踪消息。此级别初始化为 300。

ALL

public static final Level ALL
ALL 指示应该记录所有消息。此级别初始化为 Integer.MAX_VALUE。

构造方法详细信息

Level

protected Level(String name,
                int value)
使用给定的整数值创建一个指定的 Level。

注意，此构造方法是“受保护”的，允许子类化。通常，日志记录的客户机应该使用固定的 Level 对象之一，如 SEVERE 或 FINEST。但是，如果客户机需要添加新的日志级别，则它们可能子类化 Level，并定义新的常量。

参数：
name - Level 的名称，如 "SEVERE"。
value - 级别的整数值。
抛出：
NullPointerException - 如果名称为 null。

Level

protected Level(String name,
                int value,
                String resourceBundleName)
使用给定的整数值和给定的本地化资源名称创建一个指定的 Level。

参数：
name - Level 的名称，如 "SEVERE"。
value - 级别的整数值。
resourceBundleName - 本地化给定的名称时使用的资源包名称。如果 resourceBundleName 为 null 或是一个空字符串，则将其忽略。
抛出：
NullPointerException - 如果名称为 null。
方法详细信息

getResourceBundleName

public String getResourceBundleName()
返回级别的本地化资源包名称；如果没有定义本地化包，则返回 null。

返回：
本地化资源包的名称。

getName

public String getName()
返回 Level 的非本地化字符串名称。

返回：
非本地化名称。

getLocalizedName

public String getLocalizedName()
返回当前默认语言环境的 Level 的本地化字符串名称。

如果没有可用的本地化信息，则返回非本地化名称。

返回：
本地化名称。

toString

public final String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
返回 Level 的非本地化字符串名称，如 "INFO"。

intValue

public final int intValue()
获得此级别的整数值。此整数值可以用于在 Level 对象间进行有效的排序比较。

返回：
此级别的整数值。

parse

public static Level parse(String name)
                   throws IllegalArgumentException
将级别名称字符串解析成 Level。

参数字符串可能由级别名称或整数值组成。

例如：

  • "SEVERE"
  • "1000"

参数：
name - 要解析的字符串。
返回：
解析的值。传递对应于已知名称的整数（如 700）将返回相关的名称（如 CONFIG）。传递不对应已知名称的整数（如 1）将返回一个初始化为该值的新级别名称。
抛出：
NullPointerException - 如果名称为 null。
IllegalArgumentException - 如果该值是无效的。有效值是 Integer.MIN_VALUE 和 Integer.MAX_VALUE 之间的整数值，以及所有已知的级别名称。已知的名称是由此类（也就是 FINE、FINER、FINEST）所定义的级别，或者由此类使用适当的包访问所创建的级别，或者是由子类定义或创建的新级别。

equals

public boolean equals(Object ox)
比较两个对象值的相等性。

覆盖：
类 Object 中的 equals
参数：
ox - 要与之比较的引用对象。
返回：
当且仅当两个对象的级别值相同时才返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
生成哈希码。

覆盖：
类 Object 中的 hashCode
返回：
级别值的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Logger (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 Logger

java.lang.Object
    继承者  java.util.logging.Logger

public class Logger
extends Object

Logger 对象用来记录特定系统或应用程序组件的日志消息。一般使用圆点分隔的层次名称空间来命名 Logger。Logger 名称可以是任意的字符串，但是它们一般应该基于被记录组件的包名或类名，如 java.net 或 javax.swing。此外，可以创建“匿名”的 Logger，其名称未存储在 Logger 名称空间中。

可通过调用某个 getLogger 工厂方法来获得 Logger 对象。这些方法要么创建一个新 Logger，要么返回一个合适的现有 Logger。

日志消息被转发到已注册的 Handler 对象，该对象可以将消息转发到各种目的地，包括控制台、文件、OS 日志等等。

每个 Logger 都跟踪一个“父”Logger，也就是 Logger 名称空间中与其最近的现有祖先。

每个 Logger 都有一个与其相关的 "Level"。这反映了此 logger 所关心的最低 Level。如果将 Logger 的级别设置为 null，那么它的有效级别继承自父 Logger，这可以通过其父 Logger 一直沿树向上递归得到。

可以根据日志配置文件的属性来配置日志级别，在 LogManager 类的描述中对此有所说明。但是也可以通过调用 Logger.setLevel 方法动态地改变它。如果日志级别改变了，则此变化也会影响它的子 logger，因为任何级别为 null 的子 logger 的有效级别都继承自它的父 Logger。

对于每次日志记录调用，Logger 最初都依照 logger 的有效日志级别对请求级别（例如 SEVERE 或 FINE）进行简单的检查。如果请求级别低于日志级别，则日志记录调用将立即返回。

通过此初始（简单）测试后，Logger 将分配一个 LogRecord 来描述日志记录消息。接着调用 Filter（如果存在）进行更详细的检查，以确定是否应该发布该记录。如果检查通过，则将 LogRecord 发布到其输出 Handler。在默认情况下，logger 也将 LogRecord 沿树递推发布到其父 Handler。

每个 Logger 都有一个与其关联的 ResourceBundle 名称。该指定的包用于本地化日志消息。如果一个 Logger 没有自己的 ResourceBundle 名称，则它将通过其父 Logger 沿树递归继承到 ResourceBundle 名称。

大多数 logger 输出方法都带有 "msg" 参数。此 msg 参数可以是一个原始值，也可以是一个本地化的键。在格式化期间，如果 logger 具有（或继承）一个本地化 ResourceBundle，并且 ResourceBundle 包含 msg 字符串的映射关系，那么用本地化值替换 msg 字符串。否则使用原来的 msg 字符串。通常，格式器使用 java.text.MessageFormat 形式的格式来格式化参数，例如，格式字符串 "{0} {1}" 将两个参数格式化为字符串。

将 ResourceBundle 名称映射到 ResourceBundle 时，Logger 首先试图使用该线程的 ContextClassLoader。如果 ContextClassLoader 为 null，则 Logger 将尝试 SystemClassLoader。作为初始实现中的临时过渡功能，如果 Logger 无法从 ContextClassLoader 或 SystemClassLoaderis 中找到一个 ResourceBundle，则 Logger 将会向上搜索类堆栈并连续调用 ClassLoader 来试图找到 ResourceBundle（此调用堆栈搜索是为了允许容器过渡到使用 ContextClassLoader，该功能可能在以后版本中取消）。

格式化（包括本地化）是输出 Handler 的责任，它通常会调用格式器。

注意，格式化不必同步发生。它可以延迟，直到 LogRecord 被实际写入到外部接收器。

日志记录方法划分为 5 个主要类别：

  • 一系列的 "log" 方法，这种方法带有日志级别、消息字符串，以及可选的一些消息字符串参数。

  • 一系列的 "logp" 方法（即 "log precise"），其与 "log" 方法相似，但是带有显式的源类名称和方法名称。

  • 一系列的 "logrb" 方法（即 "log with resource bundle"），其与 "logp" 方法相似，但是带有显式的在本地化日志消息中使用的资源包名称。

  • 还有跟踪方法条目（"entering" 方法）、方法返回（"exiting" 方法）和抛出异常（"throwing" 方法）的便捷方法。

  • 最后，还有一系列在非常简单的情况下（如开发人员只想为给定的日志级别记录一条简单的字符串）使用的便捷方法。这些方法按标准级别名称命名（"severe"、"warning"、"info" 等等)，并带有单个参数，即一个消息字符串。

对于不带显式源名和方法名的方法，日志记录框架将尽可能确定日志记录方法中调用了哪个类和方法。但是应认识到，这样自动推断的信息可能只是近似的，甚至可能是完全错误的。这是因为允许虚拟机在 JIT 编译时可以进行广泛的优化，并且可以完全移除栈帧，导致它无法可靠地找到调用的类和方法。

Logger 上执行的所有方法都是多线程安全的。

子类化信息：注意，对于名称空间中的任意点，LogManager 类都可以提供自身的指定 Logger 实现。因此，Logger 的任何子类（它们与新的 LogManager 类一起实现的情况除外）要注意应该从 LogManager 类获得一个 Logger 实例，并应该将诸如 "isLoggable" 和 "log(LogRecord)" 这样的操作委托给该实例。注意，为了截取所有的日志记录输出，子类只需要重写 log(LogRecord) 方法。所有其他日志记录方法作为在此 log(LogRecord) 方法上的调用而实现。

从以下版本开始：
1.4

字段摘要
static Logger | global 已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。
static String | GLOBAL_LOGGER_NAME GLOBAL_LOGGER_NAME 是全局 logger 的一个名称。
构造方法摘要
protected Logger(String name, String resourceBundleName)
受保护的方法，它用于为一个指定子系统的构造 logger。
方法摘要
void | addHandler(Handler handler) 添加一个日志 Handler 以接收日志记录消息。
void | config(String msg) 记录一条 CONFIG 消息。
void | entering(String sourceClass, String sourceMethod) 记录一个方法条目。
void | entering(String sourceClass, String sourceMethod, Object param1) 记录一个方法条目，带有一个参数。
void | entering(String sourceClass, String sourceMethod, Object[] params) 记录一个方法条目，带有一组参数。
void | exiting(String sourceClass, String sourceMethod) 记录一个方法返回。
void | exiting(String sourceClass, String sourceMethod, Object result) 记录一个方法返回，带有结果对象。
void | fine(String msg) 记录一条 FINE 消息。
void | finer(String msg) 记录一条 FINER 消息。
void | finest(String msg) 记录一条 FINEST 消息。
static Logger | getAnonymousLogger() 创建一个匿名的 Logger。
static Logger | getAnonymousLogger(String resourceBundleName) 创建一个匿名的 Logger。
Filter | getFilter() 获取此 Logger 的当前过滤器。
Handler[] | getHandlers() 获得与此 logger 相关的 Handler。
Level | getLevel() 获取已为此 Logger 指定的日志级别（Level）。
static Logger | getLogger(String name) 为指定子系统查找或创建一个 logger。
static Logger | getLogger(String name, String resourceBundleName) 为指定子系统查找或创建一个 logger。
String | getName() 获取此 logger 的名称。
Logger | getParent() 返回此 Logger 的父 logger。
ResourceBundle | getResourceBundle() 获取此 logger 在当前默认语言环境的本地化资源包。
String | getResourceBundleName() 获取此 logger 的本地化资源包名称。
boolean | getUseParentHandlers() 获知此 logger 是否将其输出发送到它的父 logger。
void | info(String msg) 记录一条 INFO 消息。
boolean | isLoggable(Level level) 检查给定级别的消息实际上是否由此 logger 记录。
void | log(Level level, String msg) 记录一条不带参数的消息。
void | log(Level level, String msg, Object param1) 记录带有一个对象参数的消息。
void | log(Level level, String msg, Object[] params) 记录带有一组对象参数的消息。
void | log(Level level, String msg, Throwable thrown) 记录带有相关的可抛出信息的消息。
void | log(LogRecord record) 记录一条 LogRecord。
void | logp(Level level, String sourceClass, String sourceMethod, String msg) 记录一条消息，具有指定的源类和方法，不带参数。
void | logp(Level level, String sourceClass, String sourceMethod, String msg, Object param1) 记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。
void | logp(Level level, String sourceClass, String sourceMethod, String msg, Object[] params) 记录一条消息，具有指定的源类和方法，带有一组对象参数。
void | logp(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown) 记录一条消息，具有指定源类和方法，带有相关的可抛出信息。
void | logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg) 记录一条消息，具有指定的源类、方法和资源包名，不带参数。
void | logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1) 记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。
void | logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params) 记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。
void | logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown) 记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。
void | removeHandler(Handler handler) 移除一个日志 Handler。
void | setFilter(Filter newFilter) 设置过滤器以控制此 Logger 的输出。
void | setLevel(Level newLevel) 设置日志级别，指定此 logger 记录的消息级别。
void | setParent(Logger parent) 设置此 Logger 的父 Logger。
void | setUseParentHandlers(boolean useParentHandlers) 指定此 logger 是否应该将其输出发送到它的父 Logger。
void | severe(String msg) 记录一条 SEVERE 消息。
void | throwing(String sourceClass, String sourceMethod, Throwable thrown) 正抛出异常的记录。
void | warning(String msg) 记录一条 WARNING 消息。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GLOBAL_LOGGER_NAME

public static final String GLOBAL_LOGGER_NAME
GLOBAL_LOGGER_NAME 是全局 logger 的一个名称。此名称是向偶尔使用 Logging 包的开发人员提供的一种便捷方法。认真使用 logging 包（例如在产品中）的开发人员应创建并使用其自己的 Logger 对象（带合适的名称），这样才能在适合于每个 Logger 粒度的级别上控制日志记录。

获取全局 logger 的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。

从以下版本开始：
1.6
另请参见：
常量字段值

global

@Deprecated
public static final Logger global
已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。
“全局”Logger 对象是向偶尔使用 Logging 包的开发人员提供的一种便捷方法。对于经常使用 logging 包（如在产品中）的开发人员应创建和使用其自己的 Logger 对象（带合适的名称），这样才能在适合于每个 Logger 粒度的级别上控制日志记录。

构造方法详细信息

Logger

protected Logger(String name,
                 String resourceBundleName)
受保护的方法，它用于为一个指定子系统的构造 logger。

该 logger 初始配置的 Level 为 null，并且 useParentHandler 为 true。

参数：
name - logger 的名称。这应该是一个圆点分隔的名称，并且通常应该基于子系统的包名或类名（如 java.net 或 javax.swing）。对于匿名 Logger 来说，名称可以为 null。
resourceBundleName - 用来本地化此 logger 消息的 ResourceBundle 的名称。如果消息不需要本地化，则名称可能为 null。
抛出：
MissingResourceException - 如果 ResourceBundleName 不为 null，并且无法找到相应的资源。
方法详细信息

getLogger

public static Logger getLogger(String name)
为指定子系统查找或创建一个 logger。如果已经创建了具有给定名称的 logger，则返回该 logger。否则创建一个新的 logger。

如果创建了新的 logger，则根据 LogManager 的配置来配置其日志级别，并将日志输出发送到其父处理程序。日志配置注册在 LogManager 全局名称空间内。

参数：
name - logger 的名称。这应该是一个圆点分隔的名称，并且通常应该基于子系统的包名或类名（如 java.net 或 javax.swing）
返回：
适合的 Logger
抛出：
NullPointerException - 如果 name 为 null。

getLogger

public static Logger getLogger(String name,
                               String resourceBundleName)
为指定子系统查找或创建一个 logger。如果已经创建了具有给定名称的 logger，则返回该 logger。否则创建一个新的 logger。

如果创建了新的 logger，则根据 LogManager 来配置其日志级别，并将日志输出发送到其父处理程序。日志配置注册在 LogManager 全局名称空间内。

如果指定的 Logger 已经存在，并且没有本地化资源包，则使用给定的资源包名称。如果给定的 Logger 已经存在，并有不同的资源包名称，则抛出 IllegalArgumentException。

参数：
name - logger 的名称。这应该是一个圆点分隔的名称，并且通常应该基于子系统的包名或类名（如 java.net 或 javax.swing）。
resourceBundleName - 用来本地化此 logger 消息的 ResourceBundle 的名称。如果消息不需要本地化，则名称可以为 null。
返回：
合适的 Logger。
抛出：
MissingResourceException - 如果无法找到指定的 ResourceBundle。
IllegalArgumentException - 如果 Logger 已经存在，并使用了不同的资源包名称。
NullPointerException - 如果 name 为 null。

getAnonymousLogger

public static Logger getAnonymousLogger()
创建一个匿名的 Logger。新创建的 Logger 不是注册在 LogManager 名称空间内。不必对是否更新到 logger 进行访问检查。

此工厂方法主要适合从 applet 来使用。因为得到的 Logger 是匿名的，所以它可通过创建类而保持为私有的。这就不需要进行常规安全检查，从而允许不受信任的 applet 代码可更新 Logger 的控制状态。例如，applet 可以在匿名的 Logger 上执行 setLevel 或 addHandler 操作。

即使新的 logger 是匿名的，也要配置它将根 logger ("") 作为其父 logger。这意味着在默认情况下此 logger 从根 logger 继承有效级别和处理程序。

返回：
新创建的私有 Logger。

getAnonymousLogger

public static Logger getAnonymousLogger(String resourceBundleName)
创建一个匿名的 Logger。新创建的 Logger 不是注册在 LogManager 名称空间内。不会对 logger 是否更新进行访问检查。

此工厂方法主要适合从 applet 使用。因为得到的 Logger 是匿名的，所以它可通过创建类而保持为私有的。这就不需要进行常规安全检查，从而允许不受信任的 applet 代码可更新 Logger 的控制状态。例如，applet 可以在匿名的 Logger 上执行 setLevel 或 addHandler 操作。

即使新的 logger 是匿名的，也要把它配置为将根 logger ("") 作为其父 logger。这意味着在默认情况下此 logger 从根 logger 继承有效级别和处理程序。

参数：
resourceBundleName - 用来本地化此 logger 消息的 ResourceBundle 的名称。如果消息不需要本地化，则名称可以为 null。
返回：
新创建的私有 Logger。
抛出：
MissingResourceException - 如果无法找到指定的 ResourceBundle。

getResourceBundle

public ResourceBundle getResourceBundle()
获取此 logger 在当前默认语言环境的本地化资源包。注意，如果结果为 null，则 Logger 将使用从其父 Logger 继承的资源包。

返回：
本地化包（可能为 null）

getResourceBundleName

public String getResourceBundleName()
获取此 logger 的本地化资源包名称。注意，如果结果为 null，则 Logger 将使用从其父 Logger 继承的资源包名称。

返回：
本地化包名称（可能为 null）

setFilter

public void setFilter(Filter newFilter)
               throws SecurityException
设置过滤器以控制此 Logger 的输出。

通过初始的“级别”检查之后，Logger 将调用此 Filter 以检查是否确实应该发布某个日志记录。

参数：
newFilter - filter 对象（可能为 null）
抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。

getFilter

public Filter getFilter()
获取此 Logger 的当前过滤器。

返回：
过滤器对象（可能为 null）

log

public void log(LogRecord record)
记录一条 LogRecord。

此类中的其他所有日志记录方法都调用此方法以实际执行所有日志记录操作。子类可以重写此单个方法，从而捕获所有的日志活动。

参数：
record - 要发布的 LogRecord

log

public void log(Level level,
                String msg)
记录一条不带参数的消息。

如果当前对于给定的消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
level - 某个消息级别标识符，例如 SEVERE
msg - 字符串消息（或消息类别中的键）

log

public void log(Level level,
                String msg,
                Object param1)
记录带有一个对象参数的消息。

如果当前对于给定的消息级别而言 logger 是启用的，则创建相应的 LogRecord 并转发到所有已注册的输出 Handler 对象。

参数：
level - 某个消息级别标识符，例如 SEVERE
msg - 字符串消息（或消息类别中的键）
param1 - 消息的参数

log

public void log(Level level,
                String msg,
                Object[] params)
记录带有一组对象参数的消息。

如果当前对于给定的消息级别而言 logger 是启用的，则创建相应的 LogRecord 并转发到所有已注册的输出 Handler 对象。

参数：
level - 某个消息级别标识符，例如 SEVERE
msg - 字符串消息（或消息类别中的键）
params - 消息的一组参数

log

public void log(Level level,
                String msg,
                Throwable thrown)
记录带有相关的可抛出信息的消息。

如果当前对于给定的消息级别而言 logger 是启用的，那么将给定的参数存储在 LogRecord 中，而 LogRecord 则被转发到所有已注册的输出处理程序。

注意，抛出的参数存储在 LogRecord 抛出属性中，而不是存储在 LogRecord 参数属性中。因此特别通过输出 Formatter 来处理参数，而不是将其视为 LogRecord 消息属性的格式化参数。

参数：
level - 某个消息级别标识符，例如 SEVERE
msg - 字符串消息（或消息类别中的键）
thrown - 与日志消息相关的可抛出对象。

logp

public void logp(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg)
记录一条消息，具有指定的源类和方法，不带参数。

如果当前对于给定的消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
msg - 字符串消息（或消息类别中的键）

logp

public void logp(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg,
                 Object param1)
记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。

如果当前对于给定的消息级别而言 logger 是启用的，则创建相应的 LogRecord 并转发到所有已注册的输出 Handler 对象。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
msg - 字符串消息（或消息类别中的键）
param1 - 日志消息的参数。

logp

public void logp(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg,
                 Object[] params)
记录一条消息，具有指定的源类和方法，带有一组对象参数。

如果当前对于给定的消息级别而言 logger 是启用的，则创建相应的 LogRecord 并转发到所有已注册的输出 Handler 对象。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
msg - 字符串消息（或消息类别中的键）
params - 消息的一组参数

logp

public void logp(Level level,
                 String sourceClass,
                 String sourceMethod,
                 String msg,
                 Throwable thrown)
记录一条消息，具有指定源类和方法，带有相关的可抛出信息。

如果当前对于给定的消息级别而言 logger 是启用的，那么将给定的参数存储在 LogRecord 中，而 LogRecord 则被转发到所有已注册的输出处理程序。

注意，抛出的参数存储在 LogRecord 抛出属性中，而不是存储在 LogRecord 参数属性中。因此特别通过输出 Formatter 来处理参数，而不是将其视为 LogRecord 消息属性的格式化参数。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
msg - 字符串消息（或消息类别中的键）
thrown - 与日志消息相关的可抛出对象。

logrb

public void logrb(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg)
记录一条消息，具有指定的源类、方法和资源包名，不带参数。

如果当前对于给定的消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

使用指定的资源包本地化 msg 字符串。如果资源包名为 null，或者一个空 String 或无效，那么不本地化 msg 字符串。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
bundleName - 本地化 msg 的资源包名（可能为 null）
msg - 字符串消息（或消息类别中的键）

logrb

public void logrb(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg,
                  Object param1)
记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。

如果当前对于给定的消息级别而言 logger 是启用的，则创建相应的 LogRecord 并转发到所有已注册的输出 Handler 对象。

使用指定的资源包本地化 msg 字符串。如果资源包名为 null，或者一个空 String 或无效，那么不本地化 msg 字符串。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
bundleName - 本地化 msg 的资源包名，可以为 null
msg - 字符串消息（或消息类别中的键）
param1 - 日志消息的参数。

logrb

public void logrb(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg,
                  Object[] params)
记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。

如果当前对于给定的消息级别而言 logger 是启用的，则创建相应的 LogRecord 并转发到所有已注册的输出 Handler 对象。

使用指定的资源包本地化 msg 字符串。如果资源包名为 null，或者一个空 String 或无效，那么不本地化 msg 字符串。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
bundleName - 本地化 msg 的资源包名（可能为 null）
msg - 字符串消息（或消息类别中的键）
params - 消息的一组参数

logrb

public void logrb(Level level,
                  String sourceClass,
                  String sourceMethod,
                  String bundleName,
                  String msg,
                  Throwable thrown)
记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。

如果当前对于给定的消息级别而言 logger 是启用的，那么将给定的参数存储在 LogRecord 中，而 LogRecord 则被转发到所有已注册的输出处理程序。

使用指定的资源包本地化 msg 字符串。如果资源包名为 null，或者一个空 String 或无效，那么不本地化 msg 字符串。

注意，抛出的参数存储在 LogRecord 抛出属性中，而不是存储在 LogRecord 参数属性中。因此特别通过输出 Formatter 来处理参数，而不是将其视为 LogRecord 消息属性的格式化参数。

参数：
level - 某个消息级别标识符，例如 SEVERE
sourceClass - 发出日志记录请求的类名
sourceMethod - 发出日志记录请求的方法名
bundleName - 本地化 msg 的资源包名，可以为 null
msg - 字符串消息（或消息类别中的键）
thrown - 与日志消息相关的可抛出对象。

entering

public void entering(String sourceClass,
                     String sourceMethod)
记录一个方法条目。

这是一个可为方法记录条目的便捷方法。记录带消息 "ENTRY" 的 LogRecord、日志级别 FINER、给定的 sourceMethod 和 sourceClass。

参数：
sourceClass - 发出日志记录请求的类名
sourceMethod - 所输入的方法名

entering

public void entering(String sourceClass,
                     String sourceMethod,
                     Object param1)
记录一个方法条目，带有一个参数。

这是一个可为方法记录条目的便捷方法。记录带消息 "ENTRY {0}" 的 LogRecord、日志级别 FINER，以及给定的 sourceMethod、sourceClass 和参数。

参数：
sourceClass - 发出日志记录请求的类名
sourceMethod - 所输入的方法名
param1 - 所输入的方法参数

entering

public void entering(String sourceClass,
                     String sourceMethod,
                     Object[] params)
记录一个方法条目，带有一组参数。

这是一个可为方法记录条目的便捷方法。记录带消息 "ENTRY"（后跟格式 {N} 指示符表示参数数组中的每个条目）的 LogRecord、日志级别 FINER、给定的 sourceMethod、sourceClass 和参数。

参数：
sourceClass - 发出日志记录请求的类名
sourceMethod - 所输入的方法名
params - 所输入的一组方法参数

exiting

public void exiting(String sourceClass,
                    String sourceMethod)
记录一个方法返回。

这是一个便捷方法，可以用来记录一个方法的返回。记录带有消息 "RETURN" 的 LogRecord、日志级别 FINER、给定的 sourceMethod 和 sourceClass。

参数：
sourceClass - 发出日志记录请求的类名
sourceMethod - 方法名

exiting

public void exiting(String sourceClass,
                    String sourceMethod,
                    Object result)
记录一个方法返回，带有结果对象。

这是一个便捷方法，可以用来记录从方法返回对象。记录带消息 "RETURN {0}" 的 LogRecord、日志级别 FINER、给定的 sourceMethod、sourceClass 和结果对象。

参数：
sourceClass - 发出日志记录请求的类名
sourceMethod - 方法名
result - 所返回的 Object

throwing

public void throwing(String sourceClass,
                     String sourceMethod,
                     Throwable thrown)
正抛出异常的记录。

这是一个便捷方法，可以用来记录某个方法抛出了异常并终止。使用 FINER 级别进行日志记录。

如果当前对于给定的消息级别而言 logger 是启用的，那么将给定的参数存储在 LogRecord 中，而 LogRecord 则被转发到所有已注册的输出处理程序。将 LogRecord 的消息设置为 "THROW"。

注意，抛出的参数存储在 LogRecord 抛出属性中，而不是存储在 LogRecord 参数属性中。因此特别通过输出 Formatter 来处理参数，而不是将其视为 LogRecord 消息属性的格式化参数。

参数：
sourceClass - 发出日志记录请求的类名
sourceMethod - 方法名
thrown - 所抛出的可抛出对象

severe

public void severe(String msg)
记录一条 SEVERE 消息。

如果当前对于 SEVERE 消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
msg - 字符串消息（或消息类别中的键）

warning

public void warning(String msg)
记录一条 WARNING 消息。

如果当前对于 WARNING 消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
msg - 字符串消息（或消息类别中的键）

info

public void info(String msg)
记录一条 INFO 消息。

如果当前对于 INFO 消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
msg - 字符串消息（或消息类别中的键）

config

public void config(String msg)
记录一条 CONFIG 消息。

如果当前对于 CONFIG 消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
msg - 字符串消息（或消息类别中的键）

fine

public void fine(String msg)
记录一条 FINE 消息。

如果当前对于 FINE 消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
msg - 字符串消息（或消息类别中的键）

finer

public void finer(String msg)
记录一条 FINER 消息。

如果当前对于 FINER 消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
msg - 字符串消息（或消息类别中的键）

finest

public void finest(String msg)
记录一条 FINEST 消息。

如果当前对于 FINEST 消息级别而言 logger 是启用的，那么将给定的消息转发到所有已注册的输出 Handler 对象。

参数：
msg - 字符串消息（或消息类别中的键）

setLevel

public void setLevel(Level newLevel)
              throws SecurityException
设置日志级别，指定此 logger 记录的消息级别。将级别低于此值的消息丢弃。可以使用级别值 Level.OFF 来关闭日志记录。

如果新的级别为 null，则意味着此节点应该继承它最近的祖先（具有特定的非 null 级别值）的级别。

参数：
newLevel - 日志级别的新值。
抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。

getLevel

public Level getLevel()
获取已为此 Logger 指定的日志级别（Level）。结果可能为 null，这意味着此 logger 的有效级别将继承它的父 Logger。

返回：
此 Logger 的级别

isLoggable

public boolean isLoggable(Level level)
检查给定级别的消息实际上是否由此 logger 记录。此检查是根据 Logger 的有效级别（可能继承自它的父 Logger）进行的。

参数：
level - 消息日志记录的级别
返回：
如果当前正在记录给定的消息级别，则返回 true

getName

public String getName()
获取此 logger 的名称。

返回：
logger 的名称。对于匿名 Logger 来说，名称为 null

addHandler

public void addHandler(Handler handler)
                throws SecurityException
添加一个日志 Handler 以接收日志记录消息。

在默认情况下，Logger 还将其输出发送到它们的父 logger 中。通常，根 Logger 配置有一组 Handler，这些 Handler 本质上作为所有 logger 的默认处理程序。

参数：
handler - 日志记录 Handler
抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")

removeHandler

public void removeHandler(Handler handler)
                   throws SecurityException
移除一个日志 Handler。

如果无法找到给定的 Handler 或其为 null，则静默返回。

参数：
handler - 日志记录 Handler
抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。

getHandlers

public Handler[] getHandlers()
获得与此 logger 相关的 Handler。

返回：
一组已注册的 Handler

setUseParentHandlers

public void setUseParentHandlers(boolean useParentHandlers)
指定此 logger 是否应该将其输出发送到它的父 Logger。这意味着从名称空间向上递归，任何 LogRecord 都将被写入到其父 Handler，并且可能是祖父 Handler。

参数：
useParentHandlers - 如果要将输出发送到其父 logger，则为 true。
抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。

getUseParentHandlers

public boolean getUseParentHandlers()
获知此 logger 是否将其输出发送到它的父 logger。

返回：
如果要将输出发送到其父 logger，则返回 true

getParent

public Logger getParent()
返回此 Logger 的父 logger。

此方法返回名称空间中最近的现存父 logger。因此，如果一个 Logger 名为 "a.b.c.d"，并且已经创建了一个名为 "a.b" 的 logger，但是不存在名为 "a.b.c" 的 logger，那么对 Logger "a.b.c.d" 调用 getParent 将返回 Logger "a.b"。

如果对名称空间中的根 Logger 调用该方法，则结果为 null。

返回：
最近的现有父 Logger

setParent

public void setParent(Logger parent)
设置此 Logger 的父 Logger。名称空间改变时，由 LogManager 使用此方法来更新 Logger。

不应该从应用程序代码中调用此方法。

参数：
parent - 新的父 logger
抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoggingMXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
接口 LoggingMXBean

public interface LoggingMXBean

日志记录设施的管理接口。

存在单个 LoggingMXBean 的全局实例。此实例是一个 MXBean，可通过调用 LogManager.getLoggingMXBean() 得到，或者从 platform MBeanServer 方法得到。

在 MBeanServer 中唯一标识 LoggingMXBean 的 ObjectName 是：

java.util.logging:type=Logging

从以下版本开始：
1.5
另请参见：
ManagementFactory

方法摘要
String | getLoggerLevel(String loggerName) 获取与指定 logger 相关的日志级别名称。
List<String> | getLoggerNames() 返回当前已注册的 logger 列表。
String | getParentLoggerName(String loggerName) 返回指定 logger 的父 logger 名称。
void | setLoggerLevel(String loggerName, String levelName) 将指定 logger 设置为指定的新级别。

方法详细信息

getLoggerNames

List<String> getLoggerNames()
返回当前已注册的 logger 列表。此方法调用 LogManager.getLoggerNames()，并返回 logger 的名称列表。

返回：
String 列表，其中每一项都是一个当前已注册的 Logger 名称。

getLoggerLevel

String getLoggerLevel(String loggerName)
获取与指定 logger 相关的日志级别名称。如果指定 logger 不存在，则返回 null。此方法首先查找给定名称的 logger ，然后返回日志级别的名称，这通过调用以下方法来实现：
Logger.getLevel().getName();

如果指定 logger 的 Level 为 null（这意味着此 logger 的有效级别继承自它的父 logger），则返回一个空字符串。

参数：
loggerName - 要获取的 Logger 的名称。
返回：
指定 logger 的日志级别的名称；如果指定 logger 的日志级别为 null，则返回一个空字符串。如果指定 logger 不存在，则返回 null。
另请参见：
Logger.getLevel()

setLoggerLevel

void setLoggerLevel(String loggerName,
                    String levelName)
将指定 logger 设置为指定的新级别。如果 levelName 不为 null，则将指定 logger 的级别设置为与 levelName 匹配的、解析后的 Level。如果 levelName 为 null，则将指定 logger 的级别设置为 null，并且其有效级别继承自最近的祖先（带特定的非 null 级别值）。

参数：
loggerName - 要设置的 Logger 的名称。必须为非 null。
levelName - 指定 logger 所要设置的级别名称，如果设置该级别继承其最近的祖先，则为 null。
抛出：
IllegalArgumentException - 如果指定 logger 不存在，或 levelName 不是一个有效的级别名称。
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
另请参见：
Logger.setLevel(java.util.logging.Level)

getParentLoggerName

String getParentLoggerName(String loggerName)
返回指定 logger 的父 logger 名称。如果指定 logger 不存在，则返回 null。如果指定 logger 是名称空间中的根 Logger，则结果是一个空字符串。

参数：
loggerName - Logger 的名称。
返回：
最近的现有父 logger 的名称；如果指定的 logger 是根 logger ，则返回一个空字符串。如果指定 logger 不存在，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoggingPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 LoggingPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  java.util.logging.LoggingPermission
所有已实现的接口：
Serializable, Guard
public final class LoggingPermission
extends BasicPermission

当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。

当前只有一个指定 LoggingPermission。这就是 "control"，此权限授予了控制日志记录配置的能力，例如添加或移除 Handler、添加或移除 Filter 或改变日志级别。

程序员通常不会直接创建 LoggingPermission 对象。这些对象由安全策略代码根据读取的安全策略文件创建。

从以下版本开始：
1.4
另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
LoggingPermission(String name, String actions)
创建一个新的 LoggingPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

LoggingPermission

public LoggingPermission(String name,
                         String actions)
                  throws IllegalArgumentException
创建一个新的 LoggingPermission 对象。

参数：
name - 权限名称。必须为 "control"。
actions - 必须为 null 或空字符串。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空或者参数无效。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 LogManager

java.lang.Object
    继承者  java.util.logging.LogManager

public class LogManager
extends Object

存在一个单一的全局 LogManager 对象，它可用于维护 Logger 和日志服务的一组共享状态。

此 LogManager 对象：

  • 管理 Logger 对象的层次结构名称空间。所有指定的 Logger 均存储在此名称空间中。
  • 管理一组日志控制属性。这些是供 Handler 及其他日志对象用于自我配置的简单键-值对。

可以使用 LogManager.getLogManager() 获取全局 LogManager 对象。LogManager 对象是在类初始化过程中创建的，过后便不能更改。

在启动时，使用 java.util.logging.manager 系统属性定位 LogManager 类。

默认情况下，LogManager 从 JRE 目录的属性文件 "lib/logging.properties" 中读取其初始配置。如果编辑该属性文件，则可更改此 JRE 的所有用户的默认日志配置。

另外，LogManager 使用两个可选的允许更好地控制初始配置读取的系统属性：

  • "java.util.logging.config.class"
  • "java.util.logging.config.file"
这两个属性可以通过 Preferences API 来设置，既可作为 "java" 命令的命令行属性定义，也可作为传递到 JNI_CreateJavaVM 的系统属性定义。

如果设置了 "java.util.logging.config.class" 属性，则会把属性值当作类名。给定的类将会被加载，并会实例化一个对象，该对象的构造方法负责读取初始配置。（此对象可以使用其他系统属性来控制自己的配置。）此备用配置类可使用 readConfiguration(InputStream) 来定义 LogManager 中的属性。

如果未设置 "java.util.logging.config.class" 属性，则会使用 "java.util.logging.config.file" 系统属性来指定一个属性文件（以 java.util.Properties 格式）。从此文件读取初始日志配置。

如果这两个属性都没有定义，则如上所述，LogManager 将从 JRE 目录的属性文件 "lib/logging.properties" 中读取其初始配置。

Logger 和 Handler 的属性名称是以圆点分隔的 Logger 或 Handler 的名称开头。

全局日志属性可以包括：

  • 属性 "handlers"。该属性为 handler 类定义类名的空白或逗号分隔列表，以便作为处理程序在根 Logger（该 Logger 名为 ""）中加载和注册。每个类名必须用于具有默认构造方法的 Handler 类。注意，刚开始使用这些 Handler 时，它们可能是以延迟方式创建的。
  • 属性 "<logger>.handlers"。该属性为 handler 类定义空白分隔或逗号分隔的列表，以便作为处理程序加载和注册到指定的 logger。每个类名必须用于一个具有默认构造方法的 Handler 类。注意，刚开始使用这些 Handler 时，它们可能是以延迟方式创建的。
  • 属性 "<logger>.useParentHandlers"。该属性定义一个 boolean 值。默认情况下，每个 logger 除了自己处理日志消息外，还可能调用其父级来处理，这往往也会导致根 logger 来处理消息。将此属性设置为 false 时，需要为此 logger 配置 Handler，否则不传递任何消息。
  • 属性 "config"。此属性允许运行任意配置代码。该属性定义类名的空白或逗号分隔的列表。为每个指定类创建新实例。每个类的默认构造方法都可以执行任意代码来更新日志配置，如设置 logger 级别、添加处理程序、添加过滤器，等等。

注意，在 LogManager 配置期间加载的所有类，其搜索顺序是先从系统类路径中搜索，然后才从用户类中搜索。这包括 LogManager 类、任何 config 类和任何 handler 类。

Logger 是按其圆点分隔的名称被组织到命名层次结构中的。因此，"a.b.c" 是 "a.b" 的子级，但 "a.b1" 和 a.b2" 属于同一级。

假定所有以 ".level" 结尾的名称的属性为 Logger 定义日志级别。因此，"foo.level" 就为名称为 "foo" 的 logger 定义了日志级别，进而为指定层次结构中它的所有子级也逐个定义了日志级别。日志级别是按其在属性文件中的定义顺序应用的。因此，树中子节点的级别设置应该迟于其父级设置。属性名 ".level" 可用于设置树的根级。

LogManager 对象上的所有方法都是多线程安全的。

从以下版本开始：
1.4

字段摘要
static String LOGGING_MXBEAN_NAME
LoggingMXBean 的 ObjectName 的字符串表示形式。
构造方法摘要
protected LogManager()
受保护的构造方法。
方法摘要
boolean | addLogger(Logger logger) 添加指定的 logger。
void | addPropertyChangeListener(PropertyChangeListener l) 添加重读日志属性时调用的事件侦听器。
void | checkAccess() 检查使用当前上下文来修改日志配置是否受信任。
Logger | getLogger(String name) 查找指定 logger 的方法。
Enumeration<String> | getLoggerNames() 获取已知 logger 名称的枚举。
static LoggingMXBean | getLoggingMXBean() 返回管理 logger 的 LoggingMXBean。
static LogManager | getLogManager() 返回全局 LogManager 对象。
String | getProperty(String name) 获取日志属性的值。
void | readConfiguration() 重新初始化日志属性并重新读取日志配置。
void | readConfiguration(InputStream ins) 从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。
void | removePropertyChangeListener(PropertyChangeListener l) 移除属性更改事件的事件侦听器。
void | reset() 重置日志配置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LOGGING_MXBEAN_NAME

public static final String LOGGING_MXBEAN_NAME
LoggingMXBean 的 ObjectName 的字符串表示形式。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

LogManager

protected LogManager()
受保护的构造方法。保护此构造方法以便容器应用程序（如 J2EE 容器）可以子类化对象。此构造方法不是公共的，因为只有一个 LogManager 对象，其值是通过调用 Logmanager.getLogManager 来获取的。

方法详细信息

getLogManager

public static LogManager getLogManager()
返回全局 LogManager 对象。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
                               throws SecurityException
添加重读日志属性时调用的事件侦听器。添加同一个事件侦听器的多个实例将在属性事件侦听器表中产生多个条目。

参数：
l - 事件侦听器
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。
NullPointerException - 如果 PropertyChangeListener 为 null。

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
                                  throws SecurityException
移除属性更改事件的事件侦听器。如果通过多次调用 addPropertyChangeListener 在侦听器表中添加同一个侦听器实例，则需要调用相同数目的 removePropertyChangeListener 将该侦听器的所有实例从侦听器表中移除。

如果未找到给定的侦听器，则默认返回。

参数：
l - 事件侦听器（可以为 null）
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

addLogger

public boolean addLogger(Logger logger)
添加指定的 logger。如果已经注册了具有相同名称的 logger，则不执行任何操作而返回 false。

Logger 工厂方法调用此方法来注册每个新创建的 Logger。

此应用程序应该保留其自身对 Logger 对象的引用，以避免自己被作为无用信息收集。LogManager 仅可能保留弱引用。

参数：
logger - 新 logger。
返回：
如果成功注册参数 logger，则返回 true；如果该名称的 logger 已经存在，则返回 false。
抛出：
NullPointerException - 如果 logger 名称为 null。

getLogger

public Logger getLogger(String name)
查找指定 logger 的方法。

注意，由于不受信任的代码可能使用任意名称创建 logger，不能依赖于此方法为安全性敏感的日志查找 Logger。

参数：
name - logger 的名称
返回：
匹配 logger；如果未找到，则返回 null

getLoggerNames

public Enumeration<String> getLoggerNames()
获取已知 logger 名称的枚举。

注：加载新类时可能动态添加 Logger。此方法仅报告当前已注册的 logger。

返回：
logger 名称字符串的枚举

readConfiguration

public void readConfiguration()
                       throws IOException,
                              SecurityException
重新初始化日志属性并重新读取日志配置。

使用与启动时相同的规则查找配置属性。因此，通常从启动时使用过的文件重新读取日志属性。

如果目标 Logger 存在，则使用 Logger.setLevel() 来应用新配置文件中的所有日志级别定义。

读取这些属性后将激发 PropertyChangeEvent。

抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。
IOException - 如果读取配置时存在 IO 问题。

reset

public void reset()
           throws SecurityException
重置日志配置。

对于所有指定的 logger，重置操作移除并关闭全部 Handler（除了根 logger 之外），并将级别设置为 null。根 logger 的级别设置为 Level.INFO。

抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。

readConfiguration

public void readConfiguration(InputStream ins)
                       throws IOException,
                              SecurityException
从给定流重新初始化并重新读取日志配置，该配置为 java.util.Properties 格式。读取这些属性后将激发 PropertyChangeEvent。

如果目标 Logger 存在，则使用 Logger.setLevel() 来应用新配置文件中的所有日志级别定义。

参数：
ins - 从中读取属性的流
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。
IOException - 如果从流读取时存在问题。

getProperty

public String getProperty(String name)
获取日志属性的值。如果未找到属性，则此方法返回 null。

参数：
name - 属性名
返回：
属性值

checkAccess

public void checkAccess()
                 throws SecurityException
检查使用当前上下文来修改日志配置是否受信任。此操作需要 LoggingPermission("control")。

如果此检查失败，则抛出 SecurityException；否则，正常返回。

抛出：
SecurityException - 如果安全管理器存在并且调用者不具有 LoggingPermission("control")。

getLoggingMXBean

public static LoggingMXBean getLoggingMXBean()
返回管理 logger 的 LoggingMXBean。LoggingMXBean 还可以从平台的 MBeanServer 方法得到。

返回：
LoggingMXBean 对象。
从以下版本开始：
1.5
另请参见：
ManagementFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LogRecord (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 LogRecord

java.lang.Object
    继承者  java.util.logging.LogRecord
所有已实现的接口：
Serializable
public class LogRecord
extends Object
implements Serializable

LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。

将 LogRecord 传递到日志框架中后，它在逻辑上已经属于该框架，客户端应用程序不应再使用或更新它。

注意，如果客户端应用程序尚未显式指定源方法名和源类名，则 LogRecord 类将在第一次访问它们时通过解析调用堆栈来自动推导（根据对 getSourceMethodName 或 getSourceClassName 的调用）。因此，如果日志 Handler 要将 LogRecord 传递给另一个线程或者通过 RMI 传输它，并且如果它希望后续获取方法名或类名信息，则其应该调用 getSourceClassName 和 getSourceMethodName 的其中之一来强制将值填入。

序列化注意事项：

  • LogRecord 类是可序列化的。
  • 因为参数数组中的对象可能不可序列化，所以在序列化过程中，应该写入参数数组中所有对象的相应 String（使用 Object.toString）。
  • ResourceBundle 不是作为序列化形式的一部分传输的，但是资源包的名称是，而接收对象的 readObject 方法将尝试查找合适的资源包。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
LogRecord(Level level, String msg)
用给定级别和消息值构造 LogRecord。
方法摘要
Level | getLevel() 获取日志消息级别，例如 Level.SEVERE。
String | getLoggerName() 获取源 Logger 名称
String | getMessage() 获取本地化或格式化之前的“原始”日志消息。
long | getMillis() 获取自从 1970 年以毫秒为单位的事件时间。
Object[] | getParameters() 获取日志消息的参数。
ResourceBundle | getResourceBundle() 获取本地化资源包。
String | getResourceBundleName() 获取本地化资源包名称。
long | getSequenceNumber() 获取序列号。
String | getSourceClassName() 获取发出日志请求的类的名称。
String | getSourceMethodName() 获取（可能）发出日志请求的方法的名称。
int | getThreadID() 获取产生消息的线程的标识符。
Throwable | getThrown() 获取与日志记录相关联的所有 throwable。
void | setLevel(Level level) 设置日志消息级别，例如 Level.SEVERE。
void | setLoggerName(String name) 设置源 Logger 名称。
void | setMessage(String message) 设置本地化或格式化之前的“原始”日志消息。
void | setMillis(long millis) 设置事件时间。
void | setParameters(Object[] parameters) 设置日志消息的参数。
void | setResourceBundle(ResourceBundle bundle) 设置本地化资源包。
void | setResourceBundleName(String name) 设置本地化资源包名称。
void | setSequenceNumber(long seq) 设置序列号。
void | setSourceClassName(String sourceClassName) 设置（可能）发出日志请求的类的名称。
void | setSourceMethodName(String sourceMethodName) 设置（可能）发出日志请求的方法的名称。
void | setThreadID(int threadID) 设置产生消息的线程的标识符。
void | setThrown(Throwable thrown) 设置与日志事件相关联的 throwable。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LogRecord

public LogRecord(Level level,
                 String msg)
用给定级别和消息值构造 LogRecord。

使用新的唯一值初始化序列属性。这些序列值在 VM 中以升序进行分配。

将该 millis 属性初始化为当前时间。

使用当前线程的唯一 ID 初始化该线程的 ID 属性。

将所有其他属性初始化为 "null"。

参数：
level - 日志级别值
msg - 原始的非本地化日志消息（可以为 null）
方法详细信息

getLoggerName

public String getLoggerName()
获取源 Logger 名称

返回：
源 logger 名称（可以为 null）

setLoggerName

public void setLoggerName(String name)
设置源 Logger 名称。

参数：
name - 源 logger 名称（可以为 null）

getResourceBundle

public ResourceBundle getResourceBundle()
获取本地化资源包。

这是用于本地化消息字符串（格式化前）的 ResourceBundle。如果消息是不可本地化的或者没有合适的 ResourceBundle 可用，则结果可能为 null。

setResourceBundle

public void setResourceBundle(ResourceBundle bundle)
设置本地化资源包。

参数：
bundle - 本地化包（可以为 null）

getResourceBundleName

public String getResourceBundleName()
获取本地化资源包名称。

这是用于本地化消息字符串（格式化前）的 ResourceBundle 的名称。如果消息是不可本地化的，则结果可能为 null。

setResourceBundleName

public void setResourceBundleName(String name)
设置本地化资源包名称。

参数：
name - 本地化包名称（可以为 null）

getLevel

public Level getLevel()
获取日志消息级别，例如 Level.SEVERE。

返回：
日志消息级别

setLevel

public void setLevel(Level level)
设置日志消息级别，例如 Level.SEVERE。

参数：
level - 日志消息级别

getSequenceNumber

public long getSequenceNumber()
获取序列号。

序列号通常是在 LogRecord 构造方法中分配的，该构造方法按升序为每个新 LogRecord 分配一个唯一的序列号。

返回：
序列号

setSequenceNumber

public void setSequenceNumber(long seq)
设置序列号。

序列号通常是在 LogRecord 构造方法中分配的，所以一般不必使用这一方法。

getSourceClassName

public String getSourceClassName()
获取发出日志请求的类的名称。

注意，此 sourceClassName 未经过验证，可能是欺骗的。此信息可以作为日志调用的一部分提供，也可以通过日志框架自动推导。在后一种情况下，信息可能只是近似的，实际上可能描述的是堆栈帧上的较早调用。

如果未能获取任何信息，则返回 null。

返回：
源类名

setSourceClassName

public void setSourceClassName(String sourceClassName)
设置（可能）发出日志请求的类的名称。

参数：
sourceClassName - 源类名（可以为 null）

getSourceMethodName

public String getSourceMethodName()
获取（可能）发出日志请求的方法的名称。

注意，此 sourceMethodName 未经过验证，可能是欺骗的。此信息可以作为日志调用的一部分提供，也可以通过日志框架自动推导。在后一种情况下，信息可能只是近似的，实际上可能描述的是堆栈帧上的较早调用。

如果未能获取任何信息，则返回 null。

返回：
源方法名

setSourceMethodName

public void setSourceMethodName(String sourceMethodName)
设置（可能）发出日志请求的方法的名称。

参数：
sourceMethodName - 源方法名（可以为 null）

getMessage

public String getMessage()
获取本地化或格式化之前的“原始”日志消息。

可能为 null，该值等效于空字符串 ""。

此消息可能是最终文本或本地化键。

在格式化期间，如果源 logger 具有本地化 ResourceBundle 并且该 ResourceBundle 具有此消息字符串的条目，则使用本地化值替换该消息字符串。

返回：
原始消息字符串

setMessage

public void setMessage(String message)
设置本地化或格式化之前的“原始”日志消息。

参数：
message - 原始消息字符串（可以为 null）

getParameters

public Object[] getParameters()
获取日志消息的参数。

返回：
日志消息参数。如果没有参数，则可能为 null。

setParameters

public void setParameters(Object[] parameters)
设置日志消息的参数。

参数：
parameters - 日志消息参数。（可以为 null）

getThreadID

public int getThreadID()
获取产生消息的线程的标识符。

它是 Java VM 中的线程标识符，可能映射也可能不映射到任何操作系统 ID 中。

返回：
线程 ID

setThreadID

public void setThreadID(int threadID)
设置产生消息的线程的标识符。

参数：
threadID - 线程 ID

getMillis

public long getMillis()
获取自从 1970 年以毫秒为单位的事件时间。

返回：
自从 1970 年以 millis 为单位的事件时间

setMillis

public void setMillis(long millis)
设置事件时间。

参数：
自从 - 1970 年以 millis 为单位的事件时间

getThrown

public Throwable getThrown()
获取与日志记录相关联的所有 throwable。

如果涉及异常，则此为异常对象。否则为 null。

返回：
一个 throwable

setThrown

public void setThrown(Throwable thrown)
设置与日志事件相关联的 throwable。

参数：
thrown - throwable（可以为 null）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 MemoryHandler

java.lang.Object
    继承者  java.util.logging.Handler
        继承者  java.util.logging.MemoryHandler

public class MemoryHandler
extends Handler

Handler 在内存中的循环缓冲区中对请求进行缓冲处理。

通常，此 Handler 只将传入的 LogRecords 存储到内存缓冲区，并丢弃原来的记录。此缓冲非常经济，并且避免了格式化开销。在一定的触发条件下，MemoryHandler 将其当前的缓冲区内容 push 到目标 Handler 中，此 Handler 通常将内容发布到外界。

有三种主要模型用于触发缓冲区的 push 操作：

  • 传入的 LogRecord 类型大于预先定义的 pushLevel 级别。
  • 外部类显式地调用 push 方法。
  • 如果记录符合所需的某些标准，则子类重写 log 方法，并扫描每个传入的 LogRecord，调用 push。

配置：默认情况下，使用以下 LogManager 配置属性初始化每个 MemoryHandler。如果没有定义该属性（或者有无效的值），则使用指定的默认值。如果没有定义默认值，则抛出 RuntimeException。

  • java.util.logging.MemoryHandler.level 指定 Handler 的级别（默认为 Level.ALL）。
  • java.util.logging.MemoryHandler.filter 指定要使用的 Filter 类的名称（默认为无 Filter）。
  • java.util.logging.MemoryHandler.size 定义缓冲区的大小（默认为 1000）。
  • java.util.logging.MemoryHandler.push 定义 pushLevel（默认为 level.SEVERE）。
  • java.util.logging.MemoryHandler.target 指定目标 Handler 类的名称（无默认值）。

从以下版本开始：
1.4

构造方法摘要
MemoryHandler()
根据 LogManager 配置属性创建一个 MemoryHandler，并对其进行配置。
MemoryHandler(Handler target, int size, Level pushLevel)
创建一个 MemoryHandler。
方法摘要
void | close() 关闭 Handler，并释放所有相关的资源。
void | flush() 导致目标 Handler 上的刷新。
Level | getPushLevel() 获得 pushLevel。
boolean | isLoggable(LogRecord record) 检查此 Handler 是否实际将给定的 LogRecord 记录到其内部缓冲区。
void | publish(LogRecord record) 将 LogRecord 存储在内部缓冲区。
void | push() 将所有已缓冲的输出 push 到目标 Handler 中。
void | setPushLevel(Level newLevel) 设置 pushLevel。
从类 java.util.logging.Handler 继承的方法
getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setEncoding, setErrorManager, setFilter, setFormatter, setLevel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MemoryHandler

public MemoryHandler()
根据 LogManager 配置属性创建一个 MemoryHandler，并对其进行配置。

MemoryHandler

public MemoryHandler(Handler target,
                     int size,
                     Level pushLevel)
创建一个 MemoryHandler。

除了使用给定的 pushLevel 参数和缓冲区大小参数之外，其他都按 LogManager 的属性（或默认值）进行配置 MemoryHandler。

参数：
target - 将输出发布到的 Handler。
size - 缓冲区的日志记录数（必须大于 0）
pushLevel - 要 push 的消息级别。
抛出：
IllegalArgumentException - 如果 size <=0。
方法详细信息

publish

public void publish(LogRecord record)
将 LogRecord 存储在内部缓冲区。

如果有 Filter，则调用其 isLoggable 方法以检查给定的日志记录是否为 loggable。如果不是，则返回它。否则，将给定的记录复制到内部循环缓冲区。然后将该记录的级别属性与 pushLevel 进行比较。如果给定的级别大于等于 pushLevel，则调用 push 将所有已缓冲的记录写入到目标输出 Handler 中。

指定者：
类 Handler 中的 publish
参数：
record - 日志事件的描述。忽略 null 记录，并且也不发布它。

push

public void push()
将所有已缓冲的输出 push 到目标 Handler 中。

然后清空缓冲区。

flush

public void flush()
导致目标 Handler 上的刷新。

注意，不要将 MemoryHandler 缓冲区的当前内容全部写出。这样会要求进行 "push" 操作。

指定者：
类 Handler 中的 flush

close

public void close()
           throws SecurityException
关闭 Handler，并释放所有相关的资源。这也将关闭目标 Handler。

指定者：
类 Handler 中的 close
抛出：
SecurityException - 如果存在安全管理器并且调用者不具有 LoggingPermission("control")。

setPushLevel

public void setPushLevel(Level newLevel)
                  throws SecurityException
设置 pushLevel。将 LogRecord 复制到内部缓冲区后，如果它的级别大于等于 pushLevel，则调用 push。

参数：
newLevel - pushLevel 的新值。
抛出：
SecurityException - 如果存在安全管理器并且调用者不具有 LoggingPermission("control")。

getPushLevel

public Level getPushLevel()
获得 pushLevel。

返回：
pushLevel 的值。

isLoggable

public boolean isLoggable(LogRecord record)
检查此 Handler 是否实际将给定的 LogRecord 记录到其内部缓冲区。

此方法检查 LogRecord 是否有合适的级别，以及是否满足任何的 Filter。但是并不检查 LogRecord 是否导致 "push" 缓冲区的内容。如果 LogRecord 为 Null，则该方法返回 false。

覆盖：
类 Handler 中的 isLoggable
参数：
record - 一个 LogRecord。
返回：
如果记录 LogRecord，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleFormatter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 SimpleFormatter

java.lang.Object
    继承者  java.util.logging.Formatter
        继承者  java.util.logging.SimpleFormatter

public class SimpleFormatter
extends Formatter

以可读格式输出 LogRecord 的简单摘要。摘要通常为 1 或 2 行。

从以下版本开始：
1.4

构造方法摘要
SimpleFormatter()
方法摘要
 String format(LogRecord record)
格式化给定的 LogRecord。
从类 java.util.logging.Formatter 继承的方法
formatMessage, getHead, getTail
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SimpleFormatter

public SimpleFormatter()
方法详细信息

format

public String format(LogRecord record)
格式化给定的 LogRecord。

指定者：
类 Formatter 中的 format
参数：
record - 要格式化的日志记录。
返回：
格式化的日志记录
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SocketHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 SocketHandler

java.lang.Object
    继承者  java.util.logging.Handler
        继承者  java.util.logging.StreamHandler
            继承者  java.util.logging.SocketHandler

public class SocketHandler
extends StreamHandler

简单的网络日志 Handler。

将 LogRecords 发布到网络流连接。默认情况下，XMLFormatter 类用于格式化。

配置：默认情况下，每个 SocketHandler 是使用以下 LogManager 配置属性执行初始化的。如果未定义属性（或者属性具有无效值），则使用指定的默认值。

  • java.util.logging.SocketHandler.level 指定 Handler 的默认级别（默认值为 Level.ALL）。
  • java.util.logging.SocketHandler.filter 指定要使用的 Filter 类的名称（默认值非 Filter）。
  • java.util.logging.SocketHandler.formatter 指定要使用的 Formatter（默认值为 java.util.logging.XMLFormatter）。
  • java.util.logging.SocketHandler.encoding 要使用的字符集编码的名称（默认值为默认平台编码）。
  • java.util.logging.SocketHandler.host 指定要连接到的目标主机名（无默认值）。
  • java.util.logging.SocketHandler.port 指定要使用的目标 TCP 端口（无默认值）。

输出 IO 流是缓冲的，但是在每次写入 LogRecord 后都将刷新。

从以下版本开始：
1.4

构造方法摘要
SocketHandler()
仅使用 LogManager 属性（或其默认值）创建 SocketHandler。
SocketHandler(String host, int port)
构造一个带有指定主机和端口的 SocketHandler。
方法摘要
void | close() 关闭此输出流。
void | publish(LogRecord record) 格式化并发布 LogRecord。
从类 java.util.logging.StreamHandler 继承的方法
flush, isLoggable, setEncoding, setOutputStream
从类 java.util.logging.Handler 继承的方法
getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SocketHandler

public SocketHandler()
              throws IOException
仅使用 LogManager 属性（或其默认值）创建 SocketHandler。

抛出：
IllegalArgumentException - 如果主机或端口无效或者没有指定为 LogManager 属性。
IOException - 如果未能连接到目标主机和端口。

SocketHandler

public SocketHandler(String host,
                     int port)
              throws IOException
构造一个带有指定主机和端口的 SocketHandler。 SocketHandler 是基于 LogManager 属性（或其默认值）配置的，除非使用了给定的目标主机和端口参数。如果主机参数为空，但不是 null 字符串，则使用本地主机。

参数：
host - 目标主机。
port - 目标端口。
抛出：
IllegalArgumentException - 如果主机或端口无效。
IOException - 如果未能连接到目标主机和端口。
方法详细信息

close

public void close()
           throws SecurityException
关闭此输出流。

覆盖：
类 StreamHandler 中的 close
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

publish

public void publish(LogRecord record)
格式化并发布 LogRecord。

覆盖：
类 StreamHandler 中的 publish
参数：
record - 对日志事件的描述。默认忽略 null 记录，并且不进行发布。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StreamHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 StreamHandler

java.lang.Object
    继承者  java.util.logging.Handler
        继承者  java.util.logging.StreamHandler
直接已知子类：
ConsoleHandler, FileHandler, SocketHandler
public class StreamHandler
extends Handler

基于流的日志 Handler。

此类主要作为基类,或支持实现其他日志 Handlers 所用的类。

将 LogRecords 发布到给定 java.io.OutputStream。

配置：默认情况下，每个 SocketHandler 都是使用以下 StreamHandler 配置属性执行初始化的。如果未定义属性（或者属性具有无效值），则使用指定的默认值。

  • java.util.logging.StreamHandler.level 指定 Handler 的默认级别（默认值为 Level.INFO）。
  • java.util.logging.StreamHandler.filter 指定要使用的 Filter 类的名称（默认值非 Filter）。
  • java.util.logging.StreamHandler.formatter 指定要使用的 Formatter（默认值为 java.util.logging.SimpleFormatter）。
  • java.util.logging.StreamHandler.encoding 要使用的字符集编码的名称（默认值为默认平台编码）。

从以下版本开始：
1.4

构造方法摘要
StreamHandler()
创建不带当前输出流的 StreamHandler。
StreamHandler(OutputStream out, Formatter formatter)
创建带给定 Formatter 和输出流的 StreamHandler。
方法摘要
void | close() 关闭当前输出流。
void | flush() 刷新所有缓冲消息。
boolean | isLoggable(LogRecord record) 检查该 Handler 是否实际记录给定的 LogRecord。
void | publish(LogRecord record) 格式化并发布 LogRecord。
void | setEncoding(String encoding) 设置（或更改）该 Handler 所用的字符编码。
protected void | setOutputStream(OutputStream out) 更改输出流。
从类 java.util.logging.Handler 继承的方法
getEncoding, getErrorManager, getFilter, getFormatter, getLevel, reportError, setErrorManager, setFilter, setFormatter, setLevel
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StreamHandler

public StreamHandler()
创建不带当前输出流的 StreamHandler。

StreamHandler

public StreamHandler(OutputStream out,
                     Formatter formatter)
创建带给定 Formatter 和输出流的 StreamHandler。

参数：
out - 目标输出流
formatter - 用于格式化输出的 Formatter
方法详细信息

setOutputStream

protected void setOutputStream(OutputStream out)
                        throws SecurityException
更改输出流。

如果存在当前输出流，则编写 Formatter 的尾部字符串，刷新并关闭流。然后使用新的输出流替换该输出流。

参数：
out - 新输出流。不能为 null。
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。

setEncoding

public void setEncoding(String encoding)
                 throws SecurityException,
                        UnsupportedEncodingException
设置（或更改）该 Handler 所用的字符编码。

应在在任何 LogRecords 写入 Handler 之前设置编码。

覆盖：
类 Handler 中的 setEncoding
参数：
encoding - 所支持字符编码的名称。可以为 null，以指示默认的平台编码。
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。
UnsupportedEncodingException - 如果不支持指定的编码。

publish

public void publish(LogRecord record)
格式化并发布 LogRecord。

StreamHandler 首先检查是否存在 OutputStream 以及给定的 LogRecord 是否具有所需的最低日志级别。如果没有则默认返回。如果有，则调用所有关联的 Filter 来检查是否应该发布该记录。如果应该发布，则调用 Formatter 来格式化该记录，然后将结果写入当前输出流。

如果这是要写入给定 OutputStream 的第一个 LogRecord，则在写入 LogRecord 之前首先将 Formatter 的“头部”字符串写入流。

指定者：
类 Handler 中的 publish
参数：
record - 对日志事件的描述。默认忽略 null 记录，并且不进行发布。

isLoggable

public boolean isLoggable(LogRecord record)
检查该 Handler 是否实际记录给定的 LogRecord。

该方法检查 LogRecord 是否具有适当的级别，以及是否满足所有 Filter。如果尚未分配任何输出流或 LogRecord 为 Null，则返回 false。

覆盖：
类 Handler 中的 isLoggable
参数：
record - 一个 LogRecord
返回：
如果要记录 LogRecord，则返回 true。

flush

public void flush()
刷新所有缓冲消息。

指定者：
类 Handler 中的 flush

close

public void close()
           throws SecurityException
关闭当前输出流。

在关闭前，将 Formatter 的“尾部”字符串写入流。此外，如果尚未将 Formatter 的“头部”字符串写入流，则将其写入“尾部”字符串之前。

指定者：
类 Handler 中的 close
抛出：
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。
SecurityException - 如果存在安全管理器，且调用者不具有 LoggingPermission("control")。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLFormatter (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.logging
类 XMLFormatter

java.lang.Object
    继承者  java.util.logging.Formatter
        继承者  java.util.logging.XMLFormatter

public class XMLFormatter
extends Formatter

将 LogRecord 格式化为标准 XML 格式。

DTD 规范作为 Java Logging API 规范的附录 A 提供。

XMLFormatter 可用于任意字符编码，但是建议一般用于 UTF-8。字符编码可以在输出 Handler 中设置。

从以下版本开始：
1.4

构造方法摘要
XMLFormatter()
方法摘要
String | format(LogRecord record) 将给定消息格式化为 XML。
String | getHead(Handler h) 返回一组 XML 格式记录的头部字符串。
String | getTail(Handler h) 返回一组 XML 格式记录的尾部字符串。
从类 java.util.logging.Formatter 继承的方法
formatMessage
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

XMLFormatter

public XMLFormatter()
方法详细信息

format

public String format(LogRecord record)
将给定消息格式化为 XML。

指定者：
类 Formatter 中的 format
参数：
record - 要格式化的日志记录。
返回：
已格式化的日志记录

getHead

public String getHead(Handler h)
返回一组 XML 格式记录的头部字符串。

覆盖：
类 Formatter 中的 getHead
参数：
h - 目标处理程序（可以为 null）
返回：
有效的 XML 字符串

getTail

public String getTail(Handler h)
返回一组 XML 格式记录的尾部字符串。

覆盖：
类 Formatter 中的 getTail
参数：
h - 目标处理程序（可以为 null）
返回：
有效的 XML 字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.logging (Java 2 Platform SE 6)

 java.util.logging
接口
Filter
LoggingMXBean
类
ConsoleHandler
ErrorManager
FileHandler
Formatter
Handler
Level
Logger
LoggingPermission
LogManager
LogRecord
MemoryHandler
SimpleFormatter
SocketHandler
StreamHandler
XMLFormatter


java.util.logging (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.logging

提供 JavaTM 2 平台核心日志工具的类和接口。

请参见：
描述

接口摘要
Filter | Filter 可用于为记录内容提供比记录级别所提供的更细粒度的控制。
LoggingMXBean | 日志记录设施的管理接口。

类摘要
ConsoleHandler | 此 Handler 向 System.err 发布日志记录。
ErrorManager | 可将 ErrorManager 对象附加到 Handler，以便处理日志记录过程中 Handler 上所发生的错误。
FileHandler | 简单的文件日志记录 Handler。
Formatter | Formatter 为格式化 LogRecords 提供支持。
Handler | Handler 对象从 Logger 中获取日志信息，并将这些信息导出。
Level | Level 类定义了一组可用来控制日志输出的标准日志级别。
Logger | Logger 对象用来记录特定系统或应用程序组件的日志消息。
LoggingPermission | 当 SecurityManager 运行的代码调用某个日志记录控制方法（如 Logger.setLevel）时，SecurityManager 将要检查的权限。
LogManager | 存在一个单一的全局 LogManager 对象，它可用于维护 Logger 和日志服务的一组共享状态。
LogRecord | LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。
MemoryHandler | Handler 在内存中的循环缓冲区中对请求进行缓冲处理。
SimpleFormatter | 以可读格式输出 LogRecord 的简单摘要。
SocketHandler | 简单的网络日志 Handler。
StreamHandler | 基于流的日志 Handler。
XMLFormatter | 将 LogRecord 格式化为标准 XML 格式。

软件包 java.util.logging 的描述

提供 JavaTM 2 平台核心日志工具的类和接口。Logging API 的中心目标是支持在客户站点进行软件的维护和服务。

使用日志有 4 个主要目标：

  1. 由最终用户和系统管理员进行问题诊断。这由简单的常见问题日志组成，可在本地解决或跟踪这些问题，如资源不足、安全失败和简单的配置错误。
  2. 由现场服务工程师进行问题诊断。现场服务工程师使用的日志信息可以相当复杂和冗长，远超过系统管理员的要求。通常，这样的信息需要特定子系统中的额外日志记录。
  3. 由开发组织进行问题诊断。在现场出现问题时，必须将捕获的日志信息返回到原开发团队以供诊断。此日志信息可能非常详细，并且相当费解。这样的信息可能包括对特定子系统进行内部执行的详细跟踪。
  4. 由开发人员进行问题诊断。Logging API 还可以用来帮助调试正在开发的应用程序。这可能包括由目标应用程序产生的日志信息，以及由低级别的库产生的日志信息。但是要注意，虽然这样使用非常合理，但是 Logging API 并不用于代替开发环境中已经存在的调试和解析工具。

此包的关键元素包括：
  • Logger：应用程序进行 logging 调用的主要实体。Logger 对象用来记录特定系统或应用程序组件的日志消息。
  • LogRecord：用于在 logging 框架和单独的日志处理程序之间传递 logging 请求。
  • Handler：将 LogRecord 对象导出到各种目的地，包括内存、输出流、控制台、文件和套接字。为此有各种的 Handler 子类。其他 Handler 可能由第三方开发并在核心平台的顶层实现。
  • Level：定义一组可以用来控制 logging 输出的标准 logging 级别。可以配置程序为某些级别输出 logging，而同时忽略其他输出。
  • Filter：为所记录的日志提供日志级别控制以外的细粒度控制。Logging API 支持通用的过滤器机制，该机制允许应用程序代码附加任意的过滤器以控制 logging 输出。
  • Formatter：为格式化 LogRecord 对象提供支持。此包包括的两个格式器 SimpleFormatter 和 XMLFormatter 分别用于格式化纯文本或 XML 中的日志记录。与 Handler 一样，其他 Formatter 可能由第三方开发。

Logging API 提供静态和动态的配置控制。静态控制使现场服务人员可以建立特定的配置，然后重新启动带有新 logging 设置的应用程序。动态控制允许对当前正在运行的系统内的 logging 配置进行更新。API 也允许对不同的系统功能领域启用或禁用 logging。例如，现场服务工程师可能对跟踪所有 AWT 事件感兴趣，但是不会对套接字事件或内存管理感兴趣。

Null 指针

通常，除非在 javadoc 中另行注释，否则如果传递一个 null 参数，则方法和构造方法将抛出 NullPointerException。此规则的一个明显的例外是 Logger 类中的各种日志记录便捷方法（config、entering、exiting、fine、finer、finest、log、logp、logrb、severe、throwing 和 warning 方法）的所有参数，除了初始 Level 参数（如果有）之外，都接受 null 值。

相关文档

有关控制流的概述，请参阅 Java Logging Overview。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.logging 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.logging 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.logging.ErrorManager
    • java.util.logging.Formatter
      • java.util.logging.SimpleFormatter
      • java.util.logging.XMLFormatter
    • java.util.logging.Handler
      • java.util.logging.MemoryHandler
      • java.util.logging.StreamHandler
        • java.util.logging.ConsoleHandler
        • java.util.logging.FileHandler
        • java.util.logging.SocketHandler
    • java.util.logging.Level (implements java.io.Serializable)
    • java.util.logging.Logger
    • java.util.logging.LogManager
    • java.util.logging.LogRecord (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • java.util.logging.LoggingPermission

接口分层结构

  • java.util.logging.Filter
  • java.util.logging.LoggingMXBean
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.logging 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.logging
的使用

使用 java.util.logging 的软件包
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.util.logging 使用的 java.util.logging 中的类
ErrorManager
可将 ErrorManager 对象附加到 Handler，以便处理日志记录过程中 Handler 上所发生的错误。
Filter
Filter 可用于为记录内容提供比记录级别所提供的更细粒度的控制。
Formatter
Formatter 为格式化 LogRecords 提供支持。
Handler
Handler 对象从 Logger 中获取日志信息，并将这些信息导出。
Level
Level 类定义了一组可用来控制日志输出的标准日志级别。
Logger
Logger 对象用来记录特定系统或应用程序组件的日志消息。
LoggingMXBean
日志记录设施的管理接口。
LogManager
存在一个单一的全局 LogManager 对象，它可用于维护 Logger 和日志服务的一组共享状态。
LogRecord
LogRecord 对象用于在日志框架和单个日志 Handler 之间传递日志请求。
StreamHandler
基于流的日志 Handler。

javax.sql.rowset.spi 使用的 java.util.logging 中的类
Level
Level 类定义了一组可用来控制日志输出的标准日志级别。
Logger
Logger 对象用来记录特定系统或应用程序组件的日志消息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.ConsoleHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.ConsoleHandler
的使用

没有 java.util.logging.ConsoleHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.ErrorManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.ErrorManager
的使用

使用 ErrorManager 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 ErrorManager 的使用

返回 ErrorManager 的 java.util.logging 中的方法
 ErrorManager Handler.getErrorManager()
获取该 Handler 的 ErrorManager。

参数类型为 ErrorManager 的 java.util.logging 中的方法
 void Handler.setErrorManager(ErrorManager em)
为该 Handler 定义一个 ErrorManager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.FileHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.FileHandler
的使用

没有 java.util.logging.FileHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.logging.Filter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.logging.Filter
的使用

使用 Filter 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 Filter 的使用

返回 Filter 的 java.util.logging 中的方法
Filter | Handler.getFilter() 获得该 Handler 的当前 Filter。
Filter | Logger.getFilter() 获取此 Logger 的当前过滤器。

参数类型为 Filter 的 java.util.logging 中的方法
void | Handler.setFilter(Filter newFilter) 设置 Filter，以控制该 Handler 的输出。
void | Logger.setFilter(Filter newFilter) 设置过滤器以控制此 Logger 的输出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.Formatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Formatter
的使用

使用 Formatter 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 Formatter 的使用

java.util.logging 中 Formatter 的子类
class | SimpleFormatter 以可读格式输出 LogRecord 的简单摘要。
class | XMLFormatter 将 LogRecord 格式化为标准 XML 格式。

返回 Formatter 的 java.util.logging 中的方法
 Formatter Handler.getFormatter()
返回该 Handler 的 Formatter。

参数类型为 Formatter 的 java.util.logging 中的方法
 void Handler.setFormatter(Formatter newFormatter)
设置 Formatter。

参数类型为 Formatter 的 java.util.logging 中的构造方法
StreamHandler(OutputStream out, Formatter formatter)
创建带给定 Formatter 和输出流的 StreamHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.LogRecord 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.LogRecord
的使用

使用 LogRecord 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 LogRecord 的使用

参数类型为 LogRecord 的 java.util.logging 中的方法
abstract String | Formatter.format(LogRecord record) 格式化给定的日志记录，并返回格式化后的字符串。
String | SimpleFormatter.format(LogRecord record) 格式化给定的 LogRecord。
String | XMLFormatter.format(LogRecord record) 将给定消息格式化为 XML。
String | Formatter.formatMessage(LogRecord record) 本地化和格式化来自日志记录的消息字符串。
boolean | Filter.isLoggable(LogRecord record) 检查是否应该发布给定的日志记录。
boolean | MemoryHandler.isLoggable(LogRecord record) 检查此 Handler 是否实际将给定的 LogRecord 记录到其内部缓冲区。
boolean | StreamHandler.isLoggable(LogRecord record) 检查该 Handler 是否实际记录给定的 LogRecord。
boolean | Handler.isLoggable(LogRecord record) 检查该 Handler 是否实际记录给定的 LogRecord。
void | Logger.log(LogRecord record) 记录一条 LogRecord。
void | ConsoleHandler.publish(LogRecord record) 发布 LogRecord。
void | FileHandler.publish(LogRecord record) 格式化并发布 LogRecord。
void | MemoryHandler.publish(LogRecord record) 将 LogRecord 存储在内部缓冲区。
void | SocketHandler.publish(LogRecord record) 格式化并发布 LogRecord。
void | StreamHandler.publish(LogRecord record) 格式化并发布 LogRecord。
abstract void | Handler.publish(LogRecord record) 发布 LogRecord。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.logging.LoggingMXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.logging.LoggingMXBean
的使用

使用 LoggingMXBean 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 LoggingMXBean 的使用

返回 LoggingMXBean 的 java.util.logging 中的方法
static LoggingMXBean LogManager.getLoggingMXBean()
返回管理 logger 的 LoggingMXBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.MemoryHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.MemoryHandler
的使用

没有 java.util.logging.MemoryHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.SimpleFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.SimpleFormatter
的使用

没有 java.util.logging.SimpleFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.SocketHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.SocketHandler
的使用

没有 java.util.logging.SocketHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.StreamHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.StreamHandler
的使用

使用 StreamHandler 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 StreamHandler 的使用

java.util.logging 中 StreamHandler 的子类
class | ConsoleHandler 此 Handler 向 System.err 发布日志记录。
class | FileHandler 简单的文件日志记录 Handler。
class | SocketHandler 简单的网络日志 Handler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.XMLFormatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.XMLFormatter
的使用

没有 java.util.logging.XMLFormatter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.LoggingPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.LoggingPermission
的使用

没有 java.util.logging.LoggingPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.LogManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.LogManager
的使用

使用 LogManager 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 LogManager 的使用

返回 LogManager 的 java.util.logging 中的方法
static LogManager LogManager.getLogManager()
返回全局 LogManager 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.Level 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Level
的使用

使用 Level 的软件包
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.util.logging 中 Level 的使用

声明为 Level 的 java.util.logging 中的字段
static Level | Level.ALL ALL 指示应该记录所有消息。
static Level | Level.CONFIG CONFIG 是用于静态配置消息的消息级别。
static Level | Level.FINE FINE 是提供跟踪信息的消息级别。
static Level | Level.FINER FINER 指示一条相当详细的跟踪消息。
static Level | Level.FINEST FINEST 指示一条最详细的跟踪消息。
static Level | Level.INFO INFO 是报告消息的消息级别。
static Level | Level.OFF OFF 是一个可用于关闭日志记录的特殊级别。
static Level | Level.SEVERE SEVERE 是指示严重失败的消息级别。
static Level | Level.WARNING WARNING 是指示潜在问题的消息级别。

返回 Level 的 java.util.logging 中的方法
Level | LogRecord.getLevel() 获取日志消息级别，例如 Level.SEVERE。
Level | Handler.getLevel() 获得用于指定该 Handler 所记录信息的日志级别。
Level | Logger.getLevel() 获取已为此 Logger 指定的日志级别（Level）。
Level | MemoryHandler.getPushLevel() 获得 pushLevel。
static Level | Level.parse(String name) 将级别名称字符串解析成 Level。

参数类型为 Level 的 java.util.logging 中的方法
boolean | Logger.isLoggable(Level level) 检查给定级别的消息实际上是否由此 logger 记录。
void | Logger.log(Level level, String msg) 记录一条不带参数的消息。
void | Logger.log(Level level, String msg, Object param1) 记录带有一个对象参数的消息。
void | Logger.log(Level level, String msg, Object[] params) 记录带有一组对象参数的消息。
void | Logger.log(Level level, String msg, Throwable thrown) 记录带有相关的可抛出信息的消息。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg) 记录一条消息，具有指定的源类和方法，不带参数。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object param1) 记录一条消息，具有指定的源类和方法，带有单个日志消息的对象参数。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Object[] params) 记录一条消息，具有指定的源类和方法，带有一组对象参数。
void | Logger.logp(Level level, String sourceClass, String sourceMethod, String msg, Throwable thrown) 记录一条消息，具有指定源类和方法，带有相关的可抛出信息。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg) 记录一条消息，具有指定的源类、方法和资源包名，不带参数。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object param1) 记录一条消息，具有指定的源类、方法和资源包名，带有单个日志消息的对象参数。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Object[] params) 记录一条消息，具有指定的源类、方法和资源包名，带有一组对象参数。
void | Logger.logrb(Level level, String sourceClass, String sourceMethod, String bundleName, String msg, Throwable thrown) 记录一条消息，具有指定的源类、方法和资源包名，带有相关的可抛出对象。
void | LogRecord.setLevel(Level level) 设置日志消息级别，例如 Level.SEVERE。
void | Handler.setLevel(Level newLevel) 设置日志级别，指定该 Handler 所记录的信息级别。
void | Logger.setLevel(Level newLevel) 设置日志级别，指定此 logger 记录的消息级别。
void | MemoryHandler.setPushLevel(Level newLevel) 设置 pushLevel。

参数类型为 Level 的 java.util.logging 中的构造方法
LogRecord(Level level, String msg)
用给定级别和消息值构造 LogRecord。
MemoryHandler(Handler target, int size, Level pushLevel)
创建一个 MemoryHandler。

javax.sql.rowset.spi 中 Level 的使用

参数类型为 Level 的 javax.sql.rowset.spi 中的方法
static void SyncFactory.setLogger(Logger logger, Level level)
设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.Handler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Handler
的使用

使用 Handler 的软件包
java.util.logging 提供 JavaTM 2 平台核心日志工具的类和接口。

java.util.logging 中 Handler 的使用

java.util.logging 中 Handler 的子类
class | ConsoleHandler 此 Handler 向 System.err 发布日志记录。
class | FileHandler 简单的文件日志记录 Handler。
class | MemoryHandler Handler 在内存中的循环缓冲区中对请求进行缓冲处理。
class | SocketHandler 简单的网络日志 Handler。
class | StreamHandler 基于流的日志 Handler。

返回 Handler 的 java.util.logging 中的方法
 Handler[] Logger.getHandlers()
获得与此 logger 相关的 Handler。

参数类型为 Handler 的 java.util.logging 中的方法
void | Logger.addHandler(Handler handler) 添加一个日志 Handler 以接收日志记录消息。
String | Formatter.getHead(Handler h) 返回一组格式化记录的头部字符串。
String | XMLFormatter.getHead(Handler h) 返回一组 XML 格式记录的头部字符串。
String | Formatter.getTail(Handler h) 返回一组格式化记录的尾部字符串。
String | XMLFormatter.getTail(Handler h) 返回一组 XML 格式记录的尾部字符串。
void | Logger.removeHandler(Handler handler) 移除一个日志 Handler。

参数类型为 Handler 的 java.util.logging 中的构造方法
MemoryHandler(Handler target, int size, Level pushLevel)
创建一个 MemoryHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.logging.Logger 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.logging.Logger
的使用

使用 Logger 的软件包
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

java.util.logging 中 Logger 的使用

声明为 Logger 的 java.util.logging 中的字段
static Logger Logger.global
已过时。 此字段的初始化会容易出现死锁。必须由 Logger 类初始化来初始化字段，这可能会导致 LogManager 类初始化的死锁。在这种情况下，两个类初始化都要等待对方完成。从 JDK version 1.6 开始，获取全局 logger 对象的首选方法是通过调用 Logger.getLogger(Logger.GLOBAL_LOGGER_NAME)。

返回 Logger 的 java.util.logging 中的方法
static Logger | Logger.getAnonymousLogger() 创建一个匿名的 Logger。
static Logger | Logger.getAnonymousLogger(String resourceBundleName) 创建一个匿名的 Logger。
Logger | LogManager.getLogger(String name) 查找指定 logger 的方法。
static Logger | Logger.getLogger(String name) 为指定子系统查找或创建一个 logger。
static Logger | Logger.getLogger(String name, String resourceBundleName) 为指定子系统查找或创建一个 logger。
Logger | Logger.getParent() 返回此 Logger 的父 logger。

参数类型为 Logger 的 java.util.logging 中的方法
boolean | LogManager.addLogger(Logger logger) 添加指定的 logger。
void | Logger.setParent(Logger parent) 设置此 Logger 的父 Logger。

javax.sql.rowset.spi 中 Logger 的使用

返回 Logger 的 javax.sql.rowset.spi 中的方法
static Logger SyncFactory.getLogger()
返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。

参数类型为 Logger 的 javax.sql.rowset.spi 中的方法
static void | SyncFactory.setLogger(Logger logger) 设置 SyncFactory 提供的 SyncProvider 实现所使用的日志对象。
static void | SyncFactory.setLogger(Logger logger, Level level) 设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractPreferences (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
类 AbstractPreferences

java.lang.Object
    继承者  java.util.prefs.Preferences
        继承者  java.util.prefs.AbstractPreferences

public abstract class AbstractPreferences
extends Preferences

此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。

此类仅供 Preferences 实现者使用。Preferences 设施的普通用户无需参考此文档。Preferences 文档已经足够了。

实现者必须重写九个抽象服务提供者接口 (SPI) 方法：getSpi(String)、putSpi(String,String)、removeSpi(String)、childSpi(String)、removeNodeSpi()、keysSpi()、childrenNamesSpi()、syncSpi() 和 flushSpi()。所有的具体方法都精确指定它们如何在这些 SPI 方法上实现。如果出于某种考虑（如性能）对默认实现不满意，则实现者可能决定重写一个或多个具体方法。

SPI 方法按异常行为可分为三个组。getSpi 方法应该永远不抛出异常，但是对性能丝毫不会产生影响，因为 get(String,String) 会拦截此方法所抛出的任何异常，并对调用者返回指定的默认值。removeNodeSpi、keysSpi、childrenNamesSpi、syncSpi 和 flushSpi 方法被指定抛出 BackingStoreException；如果实现无法执行操作，则需要抛出此经过检查的异常。该异常向外传播，导致相应的 API 方法失败。

其余的 SPI 方法 putSpi(String,String)、removeSpi(String) 和 childSpi(String) 具有更加复杂的异常行为。未指定它们抛出 BackingStoreException，因为即使内部存储不可用，它们通常也遵守其协定。之所以这样是因为它们不返回任何信息，并且在进行对 Preferences.flush() 或 Preferences.sync() 的后续调用之前，不要求其结果是持久的。一般而言，这些 SPI 方法不应抛出异常。在某些实现中，可能存在这些调用甚至无法对后续处理的请求操作进行排队的情形。即使在这些情形下，最好的做法也是忽略该调用并返回，而不是抛出异常。但是，在这些情形下，所有 flush() 和 sync 的后续调用应该返回 false，因为返回 true 意味着以前的所有操作都已成功地成为持久性操作。

有一种情况下 putSpi、removeSpi 和 childSpi 应该 抛出异常：如果调用者在底层操作系统上不具备执行请求操作的足够权限。例如，如果非特权用户尝试修改系统首选项，则在大多数系统上都会发生这种情况。（这要求特权随实现而变化。在有些实现中，需要修改文件系统中某些目录内容的特权；而在另外一些实现中，则需要修改注册表中某些键的内容。）在上述任何情形下，通常让程序继续执行并不合乎需要，就好像这些操作在以后会成为持久操作一样。虽然在这些情形下不要求实现抛出异常，但还是鼓励这样做。SecurityException 就是合适的选择。

大多数 SPI 方法都要求实现在首选项节点上读取或写入信息。实现者需要注意一种情况，即另一个 VM 当前可能已经从内部存储删除了此节点。如果该节点已经删除了，则实现有责任重新创建它。

实现注意事项：在 Sun 的默认 Preferences 实现中，用户的身份是从底层操作系统继承的，在虚拟机的生命周期中不能更改。在服务器端的 Preferences 实现中，用户身份可以随请求而更改，并通过使用静态 ThreadLocal 实例隐式传递给 Preferences 方法。大力 提倡这种实现的设计者在访问首选项时确定用户（例如，使用 get(String,String) 或 put(String,String) 方法），而不是将用户与每个 Preferences 实例永久关联。后一种行为与通常的 Preferences 用法有冲突，将带来很大的混乱。

从以下版本开始：
1.4
另请参见：
Preferences

字段摘要
protected Object | lock 使用其监视器锁定此节点的对象。
protected boolean | newNode 如果在创建此对象前内部存储中不存在此节点，则该字段为 true。
从类 java.util.prefs.Preferences 继承的字段
MAX_KEY_LENGTH, MAX_NAME_LENGTH, MAX_VALUE_LENGTH
构造方法摘要
protected AbstractPreferences(AbstractPreferences parent, String name)
用指定的父节点和与其父节点相关的指定名称创建首选项节点。
方法摘要
 String absolutePath()
根据 Preferences.absolutePath() 中的规范实现 absolutePath 方法。
 void addNodeChangeListener(NodeChangeListener ncl)
注册指定侦听器以接收此节点的节点更改事件。
 void addPreferenceChangeListener(PreferenceChangeListener pcl)
注册指定侦听器以接收此首选项节点的首选项更改事件。
protected  AbstractPreferences[] cachedChildren()
返回此节点的所有已知未移除子节点。
 String[] childrenNames()
根据 Preferences.childrenNames() 中的规范实现 children 方法。
protected abstract  String[] childrenNamesSpi()
返回此首选项节点的子节点名称。
protected abstract  AbstractPreferences childSpi(String name)
返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。
 void clear()
根据 Preferences.clear() 中的规范实现 clear 方法。
 void exportNode(OutputStream os)
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
 void exportSubtree(OutputStream os)
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
 void flush()
根据 Preferences.flush() 中的规范实现 flush 方法。
protected abstract  void flushSpi()
此方法是在此节点被锁定的情况下调用的。
 String get(String key, String def)
根据 Preferences.get(String,String) 中的规范实现 get 方法。
 boolean getBoolean(String key, boolean def)
根据 Preferences.getBoolean(String,boolean) 中的规范实现 getBoolean 方法。
 byte[] getByteArray(String key, byte[] def)
根据 Preferences.getByteArray(String,byte[]) 中的规范实现 getByteArray 方法。
protected  AbstractPreferences getChild(String nodeName)
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。
 double getDouble(String key, double def)
根据 Preferences.getDouble(String,double) 中的规范实现 getDouble 方法。
 float getFloat(String key, float def)
根据 Preferences.getFloat(String,float) 中的规范实现 getFloat 方法。
 int getInt(String key, int def)
根据 Preferences.getInt(String,int) 中的规范实现 getInt 方法。
 long getLong(String key, long def)
根据 Preferences.getLong(String,long) 中的规范实现 getLong 方法。
protected abstract  String getSpi(String key)
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。
protected  boolean isRemoved()
当且仅当已经使用 removeNode() 方法移除此节点（或其祖先）时才返回 true。
 boolean isUserNode()
根据 Preferences.isUserNode() 中的规范实现 isUserNode 方法。
 String[] keys()
根据 Preferences.keys() 中的规范实现 keys 方法。
protected abstract  String[] keysSpi()
返回在此首选项节点中具有关联值的所有键。
 String name()
根据 Preferences.name() 中的规范实现 name 方法。
 Preferences node(String path)
根据 Preferences.node(String) 中的规范实现 node 方法。
 boolean nodeExists(String path)
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。
 Preferences parent()
根据 Preferences.parent() 中的规范实现 parent 方法。
 void put(String key, String value)
根据 Preferences.put(String,String) 中的规范实现 put 方法。
 void putBoolean(String key, boolean value)
根据 Preferences.putBoolean(String,boolean) 中的规范实现 putBoolean 方法。
 void putByteArray(String key, byte[] value)
根据 Preferences.putByteArray(String,byte[]) 中的规范实现 putByteArray 方法。
 void putDouble(String key, double value)
根据 Preferences.putDouble(String,double) 中的规范实现 putDouble 方法。
 void putFloat(String key, float value)
根据 Preferences.putFloat(String,float) 中的规范实现 putFloat 方法。
 void putInt(String key, int value)
根据 Preferences.putInt(String,int) 中的规范实现 putInt 方法。
 void putLong(String key, long value)
根据 Preferences.putLong(String,long) 中的规范实现 putLong 方法。
protected abstract  void putSpi(String key, String value)
将给定的键-值关联置于此首选项节点中。
 void remove(String key)
根据 Preferences.remove(String) 中的规范实现 remove(String) 方法。
 void removeNode()
根据 Preferences.removeNode() 中的规范实现 removeNode() 方法。
 void removeNodeChangeListener(NodeChangeListener ncl)
移除指定 NodeChangeListener，使其不再接收更改事件。
protected abstract  void removeNodeSpi()
移除此首选项节点，该首选项节点及其所包含的所有首选项都将失效。
 void removePreferenceChangeListener(PreferenceChangeListener pcl)
移除指定首选项更改侦听器，使其不再接收首选项更改事件。
protected abstract  void removeSpi(String key)
移除此首选项节点上指定键的关联值（如果有）。
 void sync()
根据 Preferences.sync() 中的规范实现 sync 方法。
protected abstract  void syncSpi()
此方法是在此节点被锁定的情况下调用的。
 String toString()
返回此首选项节点的绝对路径名称。
从类 java.util.prefs.Preferences 继承的方法
importPreferences, systemNodeForPackage, systemRoot, userNodeForPackage, userRoot
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

newNode

protected boolean newNode
如果在创建此对象前内部存储中不存在此节点，则该字段为 true。该字段被初始化为 false，但是子类构造方法可以将其设置为 true（并且以后不应再修改）。此字段指示创建完成时是否激活节点更改事件。

lock

protected final Object lock
使用其监视器锁定此节点的对象。使用此对象（优先于节点本身）来减少由于锁定节点而有意或无意拒绝服务的可能性。为了避免死锁，永远 不要让保持该节点后代上的锁定的线程锁定节点。

构造方法详细信息

AbstractPreferences

protected AbstractPreferences(AbstractPreferences parent,
                              String name)
用指定的父节点和与其父节点相关的指定名称创建首选项节点。

参数：
parent - 此首选项节点的父节点；如果此首选项是根，则为 null。
name - 此首选项节点相对于其父节点的名称，如果此首选项是根，则为 ""。
抛出：
IllegalArgumentException - 如果 name 包含一个斜杠 ('/') 或者 parent 为 null 且名称不是 ""。
方法详细信息

put

public void put(String key,
                String value)
根据 Preferences.put(String,String) 中的规范实现 put 方法。

此实现检查键和值是否合法，获取此首选项节点的锁定，检查该节点是否未被移除，调用 putSpi(String,String)，并且如果存在首选项更改侦听器，则将由事件指派线程所处理的通知事件加入队列。

指定者：
类 Preferences 中的 put
参数：
key - 指定的 value 将要关联的键。
value - 指定的 key 将要关联的值。
抛出：
NullPointerException - 如果 key 或 value 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH，或者 value.length 超过 MAX_VALUE_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

get

public String get(String key,
                  String def)
根据 Preferences.get(String,String) 中的规范实现 get 方法。

此实现首先检查 key 是否为 null；如果是，则抛出 NullPointerException。然后，它获取此首选项节点的锁，检查该节点是否未被移除，调用 getSpi(String) 并返回结果，除非 getSpi 调用返回 null 或抛出异常，在这种情况下此调用返回 def。

指定者：
类 Preferences 中的 get
参数：
key - 要返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值时所要返回的值。
返回：
与 key 相关联的值；如果没有与 key 相关联的值，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。（默认值 null 是 允许的。）

remove

public void remove(String key)
根据 Preferences.remove(String) 中的规范实现 remove(String) 方法。

此实现获取首选项节点的锁，检查该节点是否未被移除，调用 removeSpi(String)，并且如果存在首选项更改侦听器，则将由事件指派线程所处理的通知事件加入队列。

指定者：
类 Preferences 中的 remove
参数：
key - 从首选项节点中移除其映射关系的键。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

clear

public void clear()
           throws BackingStoreException
根据 Preferences.clear() 中的规范实现 clear 方法。

此实现获取首选项节点的锁，调用 keys() 以获取键的数组，并且对每个键调用 remove(String)，从而在数组上进行迭代。

指定者：
类 Preferences 中的 clear
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.removeNode()

putInt

public void putInt(String key,
                   int value)
根据 Preferences.putInt(String,int) 中的规范实现 putInt 方法。

此实现使用 Integer.toString(int) 将 value 转换为一个字符串，并在结果上调用 put(String,String)。

指定者：
类 Preferences 中的 putInt
参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.getInt(String,int)

getInt

public int getInt(String key,
                  int def)
根据 Preferences.getInt(String,int) 中的规范实现 getInt 方法。

此实现调用 get(key, null)。如果返回值为非 null，则实现尝试使用 Integer.parseInt(String) 将其转换为 int。如果尝试成功，则此方法返回得到的值。否则返回 def。

指定者：
类 Preferences 中的 getInt
参数：
key - 要作为 int 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或无法将该关联值解释为 int 时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 int 值；如果该关联值不存在或无法被解释为 int，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
Preferences.putInt(String,int), Preferences.get(String,String)

putLong

public void putLong(String key,
                    long value)
根据 Preferences.putLong(String,long) 中的规范实现 putLong 方法。

此实现使用 Long.toString(long) 将 value 转换为字符串，并在结果上调用 put(String,String)。

指定者：
类 Preferences 中的 putLong
参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.getLong(String,long)

getLong

public long getLong(String key,
                    long def)
根据 Preferences.getLong(String,long) 中的规范实现 getLong 方法。

此实现调用 get(key, null)。如果返回值为非 null，则实现尝试尝试使用 Long.parseLong(String) 将其转换为 long。如果尝试成功，则此方法返回得到的值。否则返回 def。

指定者：
类 Preferences 中的 getLong
参数：
key - 要作为 long 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或者无法将该关联值解释为 long 时要返回的值。
返回：
由与此首选项节点的 key 相关联的字符串所表示的 long 值；如果该关联值不存在或无法被解释为 long，则返回 def。
抛出：
IllegalStateException - 如果已使用 removeNode() 方法移除此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
Preferences.putLong(String,long), Preferences.get(String,String)

putBoolean

public void putBoolean(String key,
                       boolean value)
根据 Preferences.putBoolean(String,boolean) 中的规范实现 putBoolean 方法。

此实现使用 String.valueOf(boolean) 将 value 转换为字符串，并在结果上调用 put(String,String)。

指定者：
类 Preferences 中的 putBoolean
参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.getBoolean(String,boolean), Preferences.get(String,String)

getBoolean

public boolean getBoolean(String key,
                          boolean def)
根据 Preferences.getBoolean(String,boolean) 中的规范实现 getBoolean 方法。

此实现调用 get(key, null)。如果返回值为非 null，则使用 String.equalsIgnoreCase(String) 将其与 "true" 相比较。如果比较返回 true，则此调用返回 true。否则，再次使用 String.equalsIgnoreCase(String) 将初始值与 "false" 相比较。如果比较返回 true，则此调用返回 false。否则此调用返回 def。

指定者：
类 Preferences 中的 getBoolean
参数：
key - 要作为 boolean 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或无法将该关联值解释为 boolean 时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 boolean 值；如果该关联值不存在或无法被解释为 boolean，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
Preferences.get(String,String), Preferences.putBoolean(String,boolean)

putFloat

public void putFloat(String key,
                     float value)
根据 Preferences.putFloat(String,float) 中的规范实现 putFloat 方法。

此实现使用 Float.toString(float) 将 value 转换为字符串，并在结果上调用 put(String,String)。

指定者：
类 Preferences 中的 putFloat
参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.getFloat(String,float)

getFloat

public float getFloat(String key,
                      float def)
根据 Preferences.getFloat(String,float) 中的规范实现 getFloat 方法。

此实现调用 get(key, null)。如果返回值为非 null，则实现尝试使用 Float.parseFloat(String) 将其转换为 float。如果尝试成功，则此方法返回得到的值。否则返回 def。

指定者：
类 Preferences 中的 getFloat
参数：
key - 要作为 float 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或无法将该关联值解释为 float 时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 float 值；如果该关联值不存在或无法被解释为 float，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
Preferences.putFloat(String,float), Preferences.get(String,String)

putDouble

public void putDouble(String key,
                      double value)
根据 Preferences.putDouble(String,double) 中的规范实现 putDouble 方法。

此实现使用 Double.toString(double) 将 value 转换为字符串，并在结果上调用 put(String,String)。

指定者：
类 Preferences 中的 putDouble
参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.getDouble(String,double)

getDouble

public double getDouble(String key,
                        double def)
根据 Preferences.getDouble(String,double) 中的规范实现 getDouble 方法。

此实现调用 get(key, null)。如果返回值为非 null，则实现尝试使用 Double.parseDouble(String) 将其转换为 double。如果尝试成功，则此方法返回得到的值。否则返回 def。

指定者：
类 Preferences 中的 getDouble
参数：
key - 要作为 double 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或无法将该关联值解释为 double 时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 double 值；如果该关联值不存在或无法被解释为 double，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
Preferences.putDouble(String,double), Preferences.get(String,String)

putByteArray

public void putByteArray(String key,
                         byte[] value)
根据 Preferences.putByteArray(String,byte[]) 中的规范实现 putByteArray 方法。

指定者：
类 Preferences 中的 putByteArray
参数：
key - 要与字符串形式的 value 相关联的键。。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 或 value 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH 或者 value.length 超过 MAX_VALUE_LENGTH*3/4。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.getByteArray(String,byte[]), Preferences.get(String,String)

getByteArray

public byte[] getByteArray(String key,
                           byte[] def)
根据 Preferences.getByteArray(String,byte[]) 中的规范实现 getByteArray 方法。

指定者：
类 Preferences 中的 getByteArray
参数：
key - 要作为字节数组返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或无法将该关联值解释为字节数组时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的字节数组值；如果该关联值不存在或无法被解释为字节数组，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。（值 null 用于 def 是 允许的。）
另请参见：
Preferences.get(String,String), Preferences.putByteArray(String,byte[])

keys

public String[] keys()
              throws BackingStoreException
根据 Preferences.keys() 中的规范实现 keys 方法。

此实现获取首选项节点的锁，检查该节点是否未被移除并调用 keysSpi()。

指定者：
类 Preferences 中的 keys
返回：
在此首选项节点中具有关联值的键数组。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

childrenNames

public String[] childrenNames()
                       throws BackingStoreException
根据 Preferences.childrenNames() 中的规范实现 children 方法。

此实现获取首选项节点的锁，检查该节点是否未被移除，构造已初始化为已缓存的子节点名称（此节点“子缓存”中的子节点）的 TreeSet，调用 childrenNamesSpi() 并将所有返回的子名称添加到该 set 中。使用 toArray 方法将树 set 的元素转储到 String 数组中，并返回此数组。

指定者：
类 Preferences 中的 childrenNames
返回：
此首选项节点的子节点名称。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
cachedChildren()

cachedChildren

protected final AbstractPreferences[] cachedChildren()
返回此节点的所有已知未移除子节点。

返回：
此节点的所有已知未移除子节点。

parent

public Preferences parent()
根据 Preferences.parent() 中的规范实现 parent 方法。

此实现获取首选项节点的锁，检查该节点是否未被移除，并返回传递给此节点构造方法的父值。

指定者：
类 Preferences 中的 parent
返回：
首选项节点的父节点。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

node

public Preferences node(String path)
根据 Preferences.node(String) 中的规范实现 node 方法。

此实现获取首选项节点的锁并检查该节点是否未被移除。如果 path 为 ""，则返回此节点；如果 path 为 "/"，则返回此节点的根。如果 path 中的第一个字符不是 '/'，则此实现将 path 分解为标记，并从此节点到指定节点递归式遍历此路径，在遍历的每一个步骤都要“使用”path 中的名称和斜杠。在每一个步骤，都要锁定当前节点并为指定节点检查该节点的子缓存。如果未找到，则该名称已经过检查，以确保其长度不超过 MAX_NAME_LENGTH。然后，调用 childSpi(String) 方法并将结果存储在此节点的子缓存中。如果新创建的 Preferences 对象的 newNode 字段为 true，并且存在任一节点更改侦听器，则将由事件指派线程所处理的通知事件加入队列。

没有其他的标记时，此方法将返回在子缓存中找到的最后一个值或 childSpi 返回的值。如果在遍历过程中，连续出现两个 "/" 标记或者最后一个标记是 "/"（而不是名称），则抛出适当的 IllegalArgumentException。

如果 path 的第一个字符是 '/'（指示绝对路径名），则在将 path 分解为标记前，删除此首选项节点的锁，此方法从根（不是从此节点）开始递归式遍历此路径。该递归在其他方面与对相对路径名的描述相同。根据 locking invariant，从根节点开始遍历前删除此节点上的锁，这对于避免可能发生的死锁是至关重要的。

指定者：
类 Preferences 中的 node
参数：
path - 要返回的首选项节点的路径名。
返回：
指定的首选项节点。
抛出：
IllegalArgumentException - 如果路径名无效（即它包含多个连续的斜杠字符，或者以斜杠字符结束并且大于一个 long 字符）。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
Preferences.flush()

nodeExists

public boolean nodeExists(String path)
                   throws BackingStoreException
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。

此实现非常类似于 node(String)，不同之处是使用了 getChild(String) 而没有使用 childSpi(String)。

指定者：
类 Preferences 中的 nodeExists
参数：
path - 要检查其是否存在的节点的路径名。
返回：
如果指定的节点存在，则返回 true。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalArgumentException - 如果路径名无效（即它包含多个连续的斜杠字符，或者以斜杠字符结束并且大于一个 long 字符）。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先），并且 pathname 不是空字符串 ("")。

removeNode

public void removeNode()
                throws BackingStoreException
根据 Preferences.removeNode() 中的规范实现 removeNode() 方法。

此实现检查此节点是否为根；如果是，则抛出适当的异常。然后，它锁定此节点的父节点，并调用递归帮助器方法来遍历以此节点为根的子树。递归方法锁定其所调用的节点，检查它是否未被删除，然后确保已缓存其所有子节点：调用 childrenNamesSpi() 方法并检查每个返回的子节点名称是否已包含在子缓存中。如果没有缓存子节点，则会调用 childSpi(String) 方法为其创建一个 Preferences 实例并将此实例置于子缓存中。然后，帮助器方法在其子缓存所包含的每个节点上递归式自我调用。下一步，它调用 removeNodeSpi()，将其自身标记为已移除，并从其父节点的子缓存中自我移除。最后，如果存在任何节点更改侦听器，则其会将由事件指派线程所处理的通知事件加入队列。

注意，始终使用所有祖先来调用帮助器方法，直到锁定“未被移除的最近祖先”为止。

指定者：
类 Preferences 中的 removeNode
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
UnsupportedOperationException - 如果在根节点上调用此方法。
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
另请参见：
Preferences.flush()

name

public String name()
根据 Preferences.name() 中的规范实现 name 方法。

此实现仅返回传递给此节点构造方法的名称。

指定者：
类 Preferences 中的 name
返回：
此首选项节点的名称（相对于其父节点）。

absolutePath

public String absolutePath()
根据 Preferences.absolutePath() 中的规范实现 absolutePath 方法。

此实现仅返回构造此节点时计算出的绝对路径名（基于传递给此节点构造方法的名称和传递给此节点祖先构造方法的名称）。

指定者：
类 Preferences 中的 absolutePath
返回：
此首选项节点的绝对路径名。

isUserNode

public boolean isUserNode()
根据 Preferences.isUserNode() 中的规范实现 isUserNode 方法。

此实现将此节点的根节点（在 private 字段中存储）与 Preferences.userRoot() 返回的值相比较。如果两个对象引用相同，则此方法返回 true。

指定者：
类 Preferences 中的 isUserNode
返回：
如果此首选项节点位于用户首选项树中，则返回 true；如果其位于系统首选项树中，则返回 false。

addPreferenceChangeListener

public void addPreferenceChangeListener(PreferenceChangeListener pcl)
从类 Preferences 复制的描述
注册指定侦听器以接收此首选项节点的首选项更改事件。将首选项添加到此节点、从此节点移除首选项或者更改与首选项关联的值时都将生成首选项更改事件。（Preferences.removeNode() 方法不 生成首选项更改事件，该方法只生成节点更改事件。首选项更改事件是 由 clear 方法生成的。）

尽管有些实现可以为在 JVM 外进行的更改生成事件，但只有在已注册侦听器所在的 JVM 中所作的更改才能得到保证。事件可能是更改变得持久之前生成的。在此节点的子节点中修改首选项时不生成事件；需要此类事件的调用者必须在每个子节点中注册。

指定者：
类 Preferences 中的 addPreferenceChangeListener
参数：
pcl - 要添加的首选项更改侦听器。
另请参见：
Preferences.removePreferenceChangeListener(PreferenceChangeListener), Preferences.addNodeChangeListener(NodeChangeListener)

removePreferenceChangeListener

public void removePreferenceChangeListener(PreferenceChangeListener pcl)
从类 Preferences 复制的描述
移除指定首选项更改侦听器，使其不再接收首选项更改事件。

指定者：
类 Preferences 中的 removePreferenceChangeListener
参数：
pcl - 要移除的首选项更改侦听器。
另请参见：
Preferences.addPreferenceChangeListener(PreferenceChangeListener)

addNodeChangeListener

public void addNodeChangeListener(NodeChangeListener ncl)
从类 Preferences 复制的描述
注册指定侦听器以接收此节点的节点更改事件。在此节点中添加或删除子节点时，将生成节点更改事件。（单个 Preferences.removeNode() 调用即可产生多个节点更改事件，每个都对应于以已移除节点为根的子树中的一个节点。）

尽管有些实现可以为在 JVM 外进行的更改生成事件，但只有在注册侦听器所在的 JVM 中所作的更改才能得到保证。事件可能是更改变得持久之前生成的。添加或移除此节点的间接子节点时不生成事件；需要此类事件的调用者必须在每个子节点中注册。

节点的创建难以得到保证。因为节点是基于访问隐式创建的，实现无法确定访问前内部存储中是否存在子节点（例如，内部存储不可访问或已缓存信息过期）。在这些情形下，实现既不要求生成节点更改事件也不禁止这样做。

指定者：
类 Preferences 中的 addNodeChangeListener
参数：
ncl - 要添加的 NodeChangeListener。
另请参见：
Preferences.removeNodeChangeListener(NodeChangeListener), Preferences.addPreferenceChangeListener(PreferenceChangeListener)

removeNodeChangeListener

public void removeNodeChangeListener(NodeChangeListener ncl)
从类 Preferences 复制的描述
移除指定 NodeChangeListener，使其不再接收更改事件。

指定者：
类 Preferences 中的 removeNodeChangeListener
参数：
ncl - 要移除的 NodeChangeListener。
另请参见：
Preferences.addNodeChangeListener(NodeChangeListener)

putSpi

protected abstract void putSpi(String key,
                               String value)
将给定的键-值关联置于此首选项节点中。保证 key 和 value 均为非 null，并且具有合法的长度。此外，还要保证此节点未被移除。（实现者不必检查这些事情。）

利用此节点上保持的锁定调用此方法。

getSpi

protected abstract String getSpi(String key)
返回与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。保证 key 为非 null。此外，还要保证此节点未被移除。（实现者不必检查这两件事。）

一般而言，此方法在任何情形下也不应抛出异常。但是，如果它确实抛出了异常，则该异常将被解释为 null，并按 null 返回值对待。

利用此节点上保持的锁定调用此方法。

返回：
与此首选项节点上的指定键相关联的值；如果不存在此键的关联值或此时无法确定该关联值，则返回 null。

removeSpi

protected abstract void removeSpi(String key)
移除此首选项节点上指定键的关联值（如果有）。保证 key 为非 null。此外，还要保证此节点未被移除。（实现者不必检查这两件事。）

利用此节点上保持的锁定调用此方法。

removeNodeSpi

protected abstract void removeNodeSpi()
                               throws BackingStoreException
移除此首选项节点，该首选项节点及其所包含的所有首选项都将失效。进行此调用时，指定子节点不具有任何子节点（即 Preferences.removeNode() 方法以自下向上的方式重复调用此方法，在移除节点本身之前首先移除该节点的所有子节点）。

使用此节点及其父节点上保持的锁调用此方法（对 Preferences.removeNode() 的一次调用即可移除所有祖先）。

在此节点（或祖先）上调用 flush 方法之前对节点的移除不必是持久的。

如果此节点抛出 BackingStoreException，则该异常将会传播到封闭的 removeNode() 调用之外。

抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。

keysSpi

protected abstract String[] keysSpi()
                             throws BackingStoreException
返回在此首选项节点中具有关联值的所有键。（如果此节点不具有任何首选项，则返回数组的大小将为 0。）保证此节点未被移除。

利用此节点上保持的锁调用此方法。

如果此节点抛出 BackingStoreException，则该异常将会传播到封闭的 keys() 调用之外。

返回：
在此首选项节点中具有关联值的键数组。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。

childrenNamesSpi

protected abstract String[] childrenNamesSpi()
                                      throws BackingStoreException
返回此首选项节点的子节点名称。（如果此节点不具有任何子节点，则返回数组的大小将为 0。）此方法不必返回任何已缓存节点的名称，但是这样做也没有什么坏处。

利用此节点上保持的锁调用此方法。

如果此节点抛出 BackingStoreException，则该异常将会传播到封闭的 childrenNames() 调用之外。

返回：
包含此首选项节点的子节点名称的数组。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。

getChild

protected AbstractPreferences getChild(String nodeName)
                                throws BackingStoreException
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。保证 nodeName 为非 null、非空、不包含斜杠字符 ('/')，并且长度不超过 Preferences.MAX_NAME_LENGTH 个字符。此外，还要保证此节点未被移除。（如果选择重写此方法，则实现者不必检查这些事情。）

最后，保证最后一次将指定节点移除后此方法的以前调用或 childSpi(java.lang.String) 未曾返回它。换句话说，缓存的值始终在首选项中使用，以调用此方法。（如果选择重写此方法，则实现者不必维护它自己以前返回的子节点缓存。）

此实现获取首选项节点的锁，调用 childrenNames() 以获取此节点的子节点的名称数组，并在该数组上迭代，将每个子节点的名称与指定节点名称进行比较。如果子节点名称正确，则调用 childSpi(String) 方法并返回得到的节点。如果迭代完成时没有找到指定的名称，则返回 null。

参数：
nodeName - 要搜索的子节点的名称。
返回：
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。

childSpi

protected abstract AbstractPreferences childSpi(String name)
返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。保证 name 为非 null、非空、不包含斜杠字符 ('/')，并且长度不超过 Preferences.MAX_NAME_LENGTH 个字符。此外，还要保证此节点未被移除。（实现者不必检查这些事情。）

最后，保证最后一次将指定节点移除后此方法的以前调用或 getChild(String) 未曾返回它。换句话说，缓存的值始终在首选项中使用，以调用此方法。子类不必维护它们自己以前返回的子节点缓存。

实现者必须确保返回的节点没有被移除。如果以前移除了此节点的名称相同的子节点，则实现者必须返回一个新构建的 AbstractPreferences 节点；一旦移除，AbstractPreferences 节点便无法“再生”。

如果此方法导致创建了节点，则在此节点或其祖先之一（或子节点）上调用 flush 方法之前，不保证该节点是持久的。

利用此节点上保持的锁调用此方法。

参数：
name - 要返回的子节点的名称（相对于此首选项节点）。
返回：
指定的子节点。

toString

public String toString()
返回此首选项节点的绝对路径名称。

指定者：
类 Preferences 中的 toString
返回：
该对象的字符串表示形式。

sync

public void sync()
          throws BackingStoreException
根据 Preferences.sync() 中的规范实现 sync 方法。

此实现调用锁定此节点的递归帮助器方法，针对该方法调用 syncSpi() ，解除此节点的锁，并在每个“缓存子节点”上递归式调用这一方法。缓存子节点是此节点的子节点，已在此 VM 中创建并且后来没有被移除。实际上，此方法对以此节点为根的“缓存子树”进行深度优先遍历，针对该 subTree 中的每个节点调用 syncSpi()，这时只有该节点是锁定的。注意，是自上向下调用 syncSpi() 的。

指定者：
类 Preferences 中的 sync
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
flush()

syncSpi

protected abstract void syncSpi()
                         throws BackingStoreException
此方法是在此节点被锁定的情况下调用的。根据协定，此方法用于同步存储在此节点上的所有缓存首选项与存储在内部存储中的所有缓存首选项。（内部存储中不存在此节点是完全可能的，或者因为另一个 VM 删除了它或者因为还没有创建它。）注意，此方法不 应同步此节点的所有子节点中的首选项。如果内部存储自然地同步了整个子树，则鼓励实现者重写 sync()，而不是仅仅重写此方法。

如果此节点抛出 BackingStoreException，则该异常将会传播到封闭的 sync() 调用之外。

抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。

flush

public void flush()
           throws BackingStoreException
根据 Preferences.flush() 中的规范实现 flush 方法。

此实现调用锁定此节点的递归帮助器方法，针对该方法调用 flushSpi()，解除此节点的锁，并在每个“缓存子节点”上递归式调用这一方法。缓存子节点是此节点的子节点，已在此 VM 中创建并且后来没有被移除。实际上，此方法对以此节点为根的“缓存子树”进行深度优先遍历，针对该 subTree 中的每个节点调用 flushSpi()，这时只有该节点是锁定的。注意，是自上向下调用 flushSpi() 的。

如果在已经使用 removeNode() 方法移除的节点上调用此方法，则会在此节点（而非其他节点）上调用 flushSpi()。

指定者：
类 Preferences 中的 flush
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
另请参见：
flush()

flushSpi

protected abstract void flushSpi()
                          throws BackingStoreException
此方法是在此节点被锁定的情况下调用的。根据协定，此方法用于强制执行从此首选项节点到内部存储内容的缓存更改，以保证其持久性。（内部存储中不存在此节点是完全可能的，或者因为另一个 VM 删除了它或者因为还没有创建它。）注意，此方法不 应刷新此节点的所有子节点中的首选项。如果内部存储自然地刷新了整个子树，则鼓励实现者重写 flush()，而不是仅仅重写此方法。

如果此节点抛出 BackingStoreException，则该异常将会传播到封闭的 flush() 调用之外。

抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。

isRemoved

protected boolean isRemoved()
当且仅当已经使用 removeNode() 方法移除此节点（或其祖先）时才返回 true。此方法在返回用于跟踪此状态的 private 字段内容前锁定此节点。

返回：
当且仅当已经使用 removeNode() 方法移除了此节点（或其祖先）时才返回 true。

exportNode

public void exportNode(OutputStream os)
                throws IOException,
                       BackingStoreException
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。

指定者：
类 Preferences 中的 exportNode
参数：
os - 根据其内容发出 XML 文档的输出流。
抛出：
IOException - 如果写入指定的输出流导致一个 IOException。
BackingStoreException - 如果无法从内部存储读取首选项数据。
另请参见：
Preferences.importPreferences(InputStream)

exportSubtree

public void exportSubtree(OutputStream os)
                   throws IOException,
                          BackingStoreException
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。

指定者：
类 Preferences 中的 exportSubtree
参数：
os - 根据其内容发出 XML 文档的输出流。
抛出：
IOException - 如果写入指定的输出流导致一个 IOException。
BackingStoreException - 如果无法从内部存储读取首选项数据。
另请参见：
Preferences.importPreferences(InputStream), Preferences.exportNode(OutputStream)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BackingStoreException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
类 BackingStoreException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.util.prefs.BackingStoreException
所有已实现的接口：
Serializable
public class BackingStoreException
extends Exception

抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
BackingStoreException(String s)
构造带指定详细消息的 BackingStoreException。
BackingStoreException(Throwable cause)
构造带指定原因的 BackingStoreException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BackingStoreException

public BackingStoreException(String s)
构造带指定详细消息的 BackingStoreException。

参数：
s - 详细消息。

BackingStoreException

public BackingStoreException(Throwable cause)
构造带指定原因的 BackingStoreException。

参数：
cause - 原因
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidPreferencesFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
类 InvalidPreferencesFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.util.prefs.InvalidPreferencesFormatException
所有已实现的接口：
Serializable
public class InvalidPreferencesFormatException
extends Exception

抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

从以下版本开始：
1.4
另请参见：
Preferences, 序列化表格

构造方法摘要
InvalidPreferencesFormatException(String message)
构造带指定详细消息的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(String message, Throwable cause)
构造带指定详细消息和原因的 InvalidPreferencesFormatException。
InvalidPreferencesFormatException(Throwable cause)
构造带指定原因的 InvalidPreferencesFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidPreferencesFormatException

public InvalidPreferencesFormatException(Throwable cause)
构造带指定原因的 InvalidPreferencesFormatException。

参数：
cause - 原因（保存此原因，以便以后通过 Throwable#ggetCause 方法来获取）。

InvalidPreferencesFormatException

public InvalidPreferencesFormatException(String message)
构造带指定详细消息的 InvalidPreferencesFormatException。

参数：
message - 详细消息。保存该详细消息，以便以后通过 Throwable.getMessage() 方法来获取。

InvalidPreferencesFormatException

public InvalidPreferencesFormatException(String message,
                                         Throwable cause)
构造带指定详细消息和原因的 InvalidPreferencesFormatException。

参数：
message - 详细消息。保存该详细消息，以便以后通过 Throwable.getMessage() 方法来获取。
cause - 原因（保存此原因，以便以后通过 Throwable#ggetCause() 方法来获取）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NodeChangeEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
类 NodeChangeEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.util.prefs.NodeChangeEvent
所有已实现的接口：
Serializable
public class NodeChangeEvent
extends EventObject

Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。

注意，虽然 NodeChangeEvent 从 java.util.EventObject 继承了 Serializable 接口，但是它并非 Serializable。实现适当的序列化方法会抛出 NotSerializableException。

从以下版本开始：
1.4
另请参见：
Preferences, NodeChangeListener, PreferenceChangeEvent

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
NodeChangeEvent(Preferences parent, Preferences child)
构造新的 NodeChangeEvent 实例。
方法摘要
Preferences | getChild() 返回添加或移除的节点。
Preferences | getParent() 返回添加或移除节点的父节点。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NodeChangeEvent

public NodeChangeEvent(Preferences parent,
                       Preferences child)
构造新的 NodeChangeEvent 实例。

参数：
parent - 添加或移除节点的父节点。
child - 添加或移除的节点。
方法详细信息

getParent

public Preferences getParent()
返回添加或移除节点的父节点。

返回：
添加或移除其子节点的父级 Preferences 节点

getChild

public Preferences getChild()
返回添加或移除的节点。

返回：
添加或移除的节点。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NodeChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
接口 NodeChangeListener

所有超级接口：
EventListener
public interface NodeChangeListener
extends EventListener

用于接收首选项节点更改事件的侦听器。

从以下版本开始：
1.4
另请参见：
Preferences, NodeChangeEvent, PreferenceChangeListener

方法摘要
void | childAdded(NodeChangeEvent evt) 添加子节点时调用此方法。
void | childRemoved(NodeChangeEvent evt) 移除子节点时调用此方法。

方法详细信息

childAdded

void childAdded(NodeChangeEvent evt)
添加子节点时调用此方法。

参数：
evt - 描述父节点和子节点的节点更改事件对象。

childRemoved

void childRemoved(NodeChangeEvent evt)
移除子节点时调用此方法。

参数：
evt - 描述父节点和子节点的节点更改事件对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PreferenceChangeEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
类 PreferenceChangeEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.util.prefs.PreferenceChangeEvent
所有已实现的接口：
Serializable
public class PreferenceChangeEvent
extends EventObject

Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。

注意，虽然 PreferenceChangeEvent 从 EventObject 继承了 Serializable 接口，但是它并不是 Serializable。实现适当的序列化方法会抛出 NotSerializableException。

从以下版本开始：
1.4
另请参见：
Preferences, PreferenceChangeListener, NodeChangeEvent

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PreferenceChangeEvent(Preferences node, String key, String newValue)
构造新的 PreferenceChangeEvent 实例。
方法摘要
String | getKey() 返回已更改首选项的键。
String | getNewValue() 返回首选项的新值。
Preferences | getNode() 返回发出事件的首选项节点。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PreferenceChangeEvent

public PreferenceChangeEvent(Preferences node,
                             String key,
                             String newValue)
构造新的 PreferenceChangeEvent 实例。

参数：
node - 发出该事件的 Preferences 节点。
key - 已更改首选项的键。
newValue - 首选项的新值；如果要移除该首选项，则为 null。
方法详细信息

getNode

public Preferences getNode()
返回发出事件的首选项节点。

返回：
发出事件的首选项节点。

getKey

public String getKey()
返回已更改首选项的键。

返回：
已更改首选项的键。

getNewValue

public String getNewValue()
返回首选项的新值。

返回：
首选项的新值；如果已将该首选项移除，则为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PreferenceChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
接口 PreferenceChangeListener

所有超级接口：
EventListener
public interface PreferenceChangeListener
extends EventListener

用于接收首选项节点更改事件的侦听器。

从以下版本开始：
1.4
另请参见：
Preferences, PreferenceChangeEvent, NodeChangeListener

方法摘要
 void preferenceChange(PreferenceChangeEvent evt)
当添加、移除首选项或者更改首选项的值时，调用此方法。

方法详细信息

preferenceChange

void preferenceChange(PreferenceChangeEvent evt)
当添加、移除首选项或者更改首选项的值时，调用此方法。

参数：
evt - 描述事件源和已更改首选项的 PreferenceChangeEvent 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Preferences (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
类 Preferences

java.lang.Object
    继承者  java.util.prefs.Preferences
直接已知子类：
AbstractPreferences
public abstract class Preferences
extends Object

首选项数据的层次结构 collection 中的节点。此类允许应用程序存储和获取用户和系统首选项以及配置数据。此数据持久存储在依赖于实现的内部存储中。典型实现包括纯文本文件、特定于操作系统的注册表、目录服务器和 SQL 数据库。此类的用户无需关注内部存储的细节。

有两个独立的首选项节点树，一个用于用户首选项，一个用于系统首选项。每个用户都有一个单独的用户首选项树，而在给定系统中，所有用户都共享同一系统首选项树。对“用户”和“系统”的精确描述因实现而异。用户首选项树中存储的典型信息可能包括特定应用程序的字体选择、颜色选择和首选窗口的位置及大小。系统首选项树中存储的典型信息可能包括应用程序的安装配置数据。

使用类似的方式将首选项树中的节点命名为层次结构文件系统中的目录。首选项树的每个节点都具有一个节点名（不必是唯一的）、一个唯一的绝对路径名 和一个相对于 每个祖先（包括它自己）的路径名。

根节点的节点名为空字符串 ("")。每个其他节点的节点名可以在创建时任意指定。此名称的唯一限制是，它不能是空字符串，也不能包含斜杠字符 ('/')。

根节点的绝对路径名为 "/"。根节点的子节点的绝对路径名是 "/" + <节点名>。所有其他节点的绝对路径名是<父节点的绝对路径名> + "/" + <节点名>。注意，所有绝对路径名的第一个字符都是斜杠。

节点 n 相对于其祖先 a 的路径名只是为了形成 n 的绝对路径名，而必须添加到 a 的绝对路径名的字符串，同时移除开头的斜杠字符（如果存在）。注意：

  • 任何相对路径名的第一个字符都不能是斜杠。
  • 每个节点相对于自身的路径名都是空字符串。
  • 每个节点相对于父节点的路径名就是其节点名（根节点除外，因为它没有父节点）。
  • 每个节点相对于根的路径名都是其移除开头斜杠的绝对路径名。

最后注意：

  • 任何路径名均不能包含多个连续的斜杠字符。
  • 任何路径名均不能以斜杠字符结尾，根的绝对路径名除外。
  • 所有符合这两条规则的字符串都是有效的路径名。

修改首选项数据的所有方法都允许进行异步操作；它们可能立即返回，但是更改最终将传播到持久内部存储中，其延迟取决于实现。可以使用 flush 方法同步地将更新强制同步到内部存储中。Java 虚拟机的正常终止不会 导致挂起更新的丢失，即在终止时不 需要进行显式 flush 调用来使挂起更新变得持久。

从 Preferences 对象读取首选项的所有方法都要求调用者提供一个默认值。如果以前没有设置任何值或者内部存储不可用，则会返回默认值。此默认值的目的是，即使内部存储不可用，应用程序也可以运行，只是功能稍微下降一点。在内部存储不可用的情况下，多个方法（如 flush）均包含阻止应用程序操作的语义。普通应用程序不必调用这些方法中的任何一个，它们可能以抛出 BackingStoreException 而告终。

单个 JVM 中的多个线程可以同时调用此类中的方法，无需进行外部同步，其结果等效于某些顺序执行。如果在同一个内部存储中存储其首选项数据的多个 JVM 同时使用此类，则数据存储也不会遭到破坏，但首选项数据的一致性难以得到保证。

此类包含导出/导入设施，允许将首选项“导出”到 XML 文档，将表示首选项的 XML 文档再“导入”回系统。可以使用此设施备份全部或部分首选项树，并在以后从备份中还原。

XML 文档具有以下 DOCTYPE 声明：

 <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
注意，导入或导出首选项时不 访问系统 URI (http://java.sun.com/dtd/preferences.dtd)；该系统 URI 仅作为一个唯一标识 DTD 的字符串：
    <?xml version="1.0" encoding="UTF-8"?>

    <!-- DTD for a Preferences tree. -->

    <!-- The preferences element is at the root of an XML document
         representing a Preferences tree. -->
    <!ELEMENT preferences (root)>

    <!-- The preferences element contains an optional version attribute,
          which specifies version of DTD. -->
    <!ATTLIST preferences EXTERNAL_XML_VERSION CDATA "0.0" >

    <!-- The root element has a map representing the root's preferences
         (if any), and one node for each child of the root (if any). -->
    <!ELEMENT root (map, node*) >

    <!-- Additionally, the root contains a type attribute, which
         specifies whether it's the system or user root. -->
    <!ATTLIST root
              type (system|user) #REQUIRED >

    <!-- Each node has a map representing its preferences (if any),
         and one node for each child (if any). -->
    <!ELEMENT node (map, node*) >

    <!-- Additionally, each node has a name attribute -->
    <!ATTLIST node
              name CDATA #REQUIRED >

    <!-- A map represents the preferences stored at a node (if any). -->
    <!ELEMENT map (entry*) >

    <!-- An entry represents a single preference, which is simply
          a key-value pair. -->
    <!ELEMENT entry EMPTY >
    <!ATTLIST entry
              key   CDATA #REQUIRED
              value CDATA #REQUIRED >
每个 Preferences 实现都必须具有一个关联的 PreferencesFactory 实现。每个 Java(TM) SE 实现都必须提供一些方式，来指定将哪个 PreferencesFactory 实现用于生成根首选项节点。这允许管理员使用替代实现替换默认首选项实现。

实现注意事项：在 Sun 的 JRE 中，PreferencesFactory 实现的位置如下：

  1. 如果定义了系统属性 java.util.prefs.PreferencesFactory，则该属性名就会用作实现 PreferencesFactory 接口的类的完全限定名。加载并实例化该类；如果此进程失败，则抛出未指定的错误。

  2. 如果在对系统类加载器可见的 jar 文件中安装了 PreferencesFactory 实现类文件，并且该 jar 文件在资源目录 META-INF/services 中包含名为 java.util.prefs.PreferencesFactory 的提供者配置文件，则采用在该文件中指定的第一个类名称。如果提供了一个以上这样的 jar 文件，则使用找到的第一个文件。加载并实例化该类；如果此进程失败，则抛出未指定的错误。

  3. 最后，如果既没有提供上述系统属性也没有提供扩展 jar 文件，则加载和实例化底层平台的系统级默认 PreferencesFactory 实现。

从以下版本开始：
1.4

字段摘要
static int | MAX_KEY_LENGTH 允许作为键的字符串最大长度（80 个字符）。
static int | MAX_NAME_LENGTH 节点名的最大长度（80 个字符）。
static int | MAX_VALUE_LENGTH 允许作为值的字符串最大长度（8192 个字符）。
构造方法摘要
protected Preferences()
单独的构造方法。
方法摘要
abstract  String absolutePath()
返回此首选项节点的绝对路径名。
abstract  void addNodeChangeListener(NodeChangeListener ncl)
注册指定侦听器以接收此节点的节点更改事件。
abstract  void addPreferenceChangeListener(PreferenceChangeListener pcl)
注册指定侦听器以接收此首选项节点的首选项更改事件。
abstract  String[] childrenNames()
返回此首选项节点相对于此节点的子节点名称。
abstract  void clear()
移除此首选项节点中的所有首选项（键-值关联）。
abstract  void exportNode(OutputStream os)
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
abstract  void exportSubtree(OutputStream os)
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。
abstract  void flush()
强制进行从此首选项节点及其子节点到持久存储的内容更改。
abstract  String get(String key, String def)
返回与此首选项节点中指定键相关联的值。
abstract  boolean getBoolean(String key, boolean def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 boolean 值。
abstract  byte[] getByteArray(String key, byte[] def)
返回与此首选项节点中指定键相关联的、由字符串表示的字节数组。
abstract  double getDouble(String key, double def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 double 值。
abstract  float getFloat(String key, float def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 float 值。
abstract  int getInt(String key, int def)
返回与此首选项节点中与指定键相关联的、由字符串表示的 int 值。
abstract  long getLong(String key, long def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 long 值。
static void importPreferences(InputStream is)
导入指定输入流中由 XML 文档表示的所有首选项。
abstract  boolean isUserNode()
如果此首选项节点位于用户首选项树中，则返回 true；如果其位于系统首选项树中，则返回 false。
abstract  String[] keys()
返回在此首选项节点中具有关联值的所有键。
abstract  String name()
返回此首选项节点相对于父节点的名称。
abstract  Preferences node(String pathName)
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。
abstract  boolean nodeExists(String pathName)
如果此节点所在的树中存在指定首选项节点，则返回 true。
abstract  Preferences parent()
返回此首选项节点的父节点；如果此为根，则返回 null。
abstract  void put(String key, String value)
将指定值与此首选项节点中的指定键相关联。
abstract  void putBoolean(String key, boolean value)
将表示指定 boolean 值的字符串与此首选项节点中的指定键相关联。
abstract  void putByteArray(String key, byte[] value)
将表示指定字节数组的字符串与此首选项节点中的指定键相关联。
abstract  void putDouble(String key, double value)
将表示指定 double 值的字符串与此首选项节点中的指定键相关联。
abstract  void putFloat(String key, float value)
将表示指定 float 值的字符串与此首选项节点中的指定键相关联。
abstract  void putInt(String key, int value)
将表示指定 int 值的字符串与此首选项节点中的指定键相关联。
abstract  void putLong(String key, long value)
将表示指定 long 值的字符串与此首选项节点中的指定键相关联。
abstract  void remove(String key)
移除与此首选项节点中与指定键相关联的值（如果有）。
abstract  void removeNode()
移除此首选项节点及其所有子节点，移除的节点中所包含的全部首选项都将失效。
abstract  void removeNodeChangeListener(NodeChangeListener ncl)
移除指定 NodeChangeListener，使其不再接收更改事件。
abstract  void removePreferenceChangeListener(PreferenceChangeListener pcl)
移除指定首选项更改侦听器，使其不再接收首选项更改事件。
abstract  void sync()
确保在调用 sync 之前从此首选项节点及其子节点进行的后续读取能反映出提交到持久存储（从任何 VM）的所有更改。
static Preferences systemNodeForPackage(Class<?> c)
从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences systemRoot()
返回系统的根首选项节点。
abstract  String toString()
返回此首选项节点的字符串表示形式，与通过表达式：(this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 计算的结果一样。
static Preferences userNodeForPackage(Class<?> c)
从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences userRoot()
返回调用用户的根首选项节点。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

MAX_KEY_LENGTH

public static final int MAX_KEY_LENGTH
允许作为键的字符串最大长度（80 个字符）。

另请参见：
常量字段值

MAX_VALUE_LENGTH

public static final int MAX_VALUE_LENGTH
允许作为值的字符串最大长度（8192 个字符）。

另请参见：
常量字段值

MAX_NAME_LENGTH

public static final int MAX_NAME_LENGTH
节点名的最大长度（80 个字符）。

另请参见：
常量字段值
构造方法详细信息

Preferences

protected Preferences()
单独的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

userNodeForPackage

public static Preferences userNodeForPackage(Class<?> c)
从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。约定如下：节点的绝对路径名就是完全限定的包名，开头使用一个斜杠 ('/')，并将其中的每一个句点 ('.') 都替换为斜杠。例如，与类 com.acme.widget.Foo 关联的节点绝对路径名是 /com/acme/widget。

此约定不适用于未命名的包，未命名包的关联首选项节点是 <unnamed>。此节点只是为了方便程序的早期开发（而非长期使用）而存在的，它不属于任何包，只用于“一次性”程序。在此节点中不应该存储有价值的数据，因为使用它的所有程序都可以共享它。

希望访问与其包有关的首选项类 Foo 可以获得以下首选项节点：

    static Preferences prefs = Preferences.userNodeForPackage(Foo.class);
此语句消除了使用字符串描述首选项节点的需求，从而降低了发生运行时故障的可能性。（如果类名称拼写错误，则通常会导致编译时错误。）

调用此方法将导致返回节点及其祖先的创建（如果它们不存在）。如果在此调用之前返回的节点不存在，那么在对返回节点（或者其某个祖先或子节点）调用 flush 方法之前，不能保证由此调用所创建的节点及其所有祖先是永久性的。

参数：
c - 用户首选项节点需要其包的类。
返回：
与 c 成员所属包相关联的用户首选项节点。
抛出：
NullPointerException - 如果 c 为 null。
SecurityException - 如果安全管理器存在并且拒绝 RuntimePermission("preferences")。
另请参见：
RuntimePermission

systemNodeForPackage

public static Preferences systemNodeForPackage(Class<?> c)
从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。约定如下：节点的绝对路径名就是完全限定的包名，开头使用一个斜杠 ('/')，并将其中的每一个句点 ('.') 都替换为斜杠。例如，与类 com.acme.widget.Foo 关联的节点绝对路径名是 /com/acme/widget。

此约定不适用于未命名的包，未命名包的关联首选项节点是 <unnamed>。此节点只是为了方便程序的早期开发（而非长期使用）而存在的，它不属于任何包，只用于“一次性”程序。在此节点中不应该存储有价值的数据，因为使用它的所有程序都可以共享它。

希望访问与其包有关的首选项类 Foo 可以获得以下首选项节点：

  static Preferences prefs = Preferences.systemNodeForPackage(Foo.class);
此语句消除了使用字符串描述首选项节点的需求，从而降低了发生运行时故障的可能性。（如果类名称拼写错误，则通常会导致编译时错误。）

调用此方法将导致返回节点及其祖先的创建（如果它们不存在）。如果在此调用之前返回的节点不存在，那么在对返回节点（或者其某个祖先或子节点）调用 flush 方法之前，不能保证由此调用所创建的节点及其所有祖先是永久性的。

参数：
c - 系统首选项节点需要其包的类。
返回：
与 c 成员所属包相关联的用户首选项节点。
抛出：
NullPointerException - 如果 c 为 null。
SecurityException - 如果安全管理器存在并且拒绝 RuntimePermission("preferences")。
另请参见：
RuntimePermission

userRoot

public static Preferences userRoot()
返回调用用户的根首选项节点。

返回：
调用用户的根首选项节点。
抛出：
SecurityException - 如果安全管理器存在并且拒绝 RuntimePermission("preferences")。
另请参见：
RuntimePermission

systemRoot

public static Preferences systemRoot()
返回系统的根首选项节点。

返回：
系统的根首选项节点。
抛出：
SecurityException - 如果安全管理器存在并且拒绝 RuntimePermission("preferences")。
另请参见：
RuntimePermission

put

public abstract void put(String key,
                         String value)
将指定值与此首选项节点中的指定键相关联。

参数：
key - 指定的 value 将要关联的键。
value - 指定的 key 将要关联的值。
抛出：
NullPointerException - 如果 key 或 value 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH 或者 value.length 超过 MAX_VALUE_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

get

public abstract String get(String key,
                           String def)
返回与此首选项节点中指定键相关联的值。如果不存在与该键相关联的值或者内部存储不可访问，则返回指定的默认值。

有些实现可能将默认值存储在其内部存储中。如果不存在与指定键相关联的值，而只有存储的默认值，则系统优先返回存储的默认值（而不是指定的默认值）。

参数：
key - 要返回其相关值的键。
def - 此首选项节点不具有与 key 相关联的值时所要返回的值。
返回：
与 key 相关联的值；如果没有与 key 相关联的值或者内部存储不可用，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。（值 null 用于 def 是 允许的。）

remove

public abstract void remove(String key)
移除与此首选项节点中与指定键相关联的值（如果有）。

如果此实现支持存储的默认值，并且指定的首选项存在这样的默认值，则此调用将“公开”存储的默认值，这表示对 get 的后续调用将返回它。

参数：
key - 从首选项节点中移除其映射关系的键。
抛出：
NullPointerException - 如果 key 为 null。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

clear

public abstract void clear()
                    throws BackingStoreException
移除此首选项节点中的所有首选项（键-值关联）。此调用对此节点的所有子节点均没有影响。

如果此实现支持存储的默认值，并且首选项层次结构中的这一节点包含这样的默认值，则此调用将“公开”存储的默认值，这表示对 get 的后续调用将返回它。

抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
removeNode()

putInt

public abstract void putInt(String key,
                            int value)
将表示指定 int 值的字符串与此首选项节点中的指定键相关联。关联字符串是将 int 值传递给 Integer.toString(int) 时将返回的字符串。此方法与 getInt(java.lang.String, int) 一起使用。

参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
getInt(String,int)

getInt

public abstract int getInt(String key,
                           int def)
返回与此首选项节点中与指定键相关联的、由字符串表示的 int 值。该字符串由 Integer.parseInt(String) 转换为整数。如果不存在与该键相关联的值，内部存储不可用，或者传递关联值时 Integer.parseInt(String) 抛出 NumberFormatException，则返回指定的默认值。此方法与 putInt(java.lang.String, int) 一起使用。

如果该实现支持存储的默认值，并且这样的默认值存在且可访问，而且可以使用 Integer.parseInt 将其转换为 int，则优先返回此 int（而不是指定默认值）。

参数：
key - 要作为 int 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或者无法将该关联值解释为 int 或者内部存储不可访问时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 int 值；如果该关联值不存在或无法被解释为 int，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
putInt(String,int), get(String,String)

putLong

public abstract void putLong(String key,
                             long value)
将表示指定 long 值的字符串与此首选项节点中的指定键相关联。关联字符串是将 long 值传递给 Long.toString(long) 时将返回的字符串。此方法与 getLong(java.lang.String, long) 一起使用。

参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
getLong(String,long)

getLong

public abstract long getLong(String key,
                             long def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 long 值。该字符串由 Long.parseLong(String) 转换为 long。如果不存在与该键相关联的值，内部存储不可用，或者传递关联值时 Long.parseLong(String) 抛出 NumberFormatException，则返回指定的默认值。此方法与 putLong(java.lang.String, long) 一起使用。

如果该实现支持存储的默认值，这样的默认值存在且可访问，并且可以使用 Long.parseLong 转换为 long，则优先返回此 long（而不是指定默认值）。

参数：
key - 要作为 long 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或者无法将该关联值解释为 long 或者内部存储不可访问时要返回的值。
返回：
返回与此首选项节点的 key 相关联的字符串所表示的 long 值；如果关联值不存在或者无法将其解释为 long，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
putLong(String,long), get(String,String)

putBoolean

public abstract void putBoolean(String key,
                                boolean value)
将表示指定 boolean 值的字符串与此首选项节点中的指定键相关联。如果该值为 true，则关联字符串为 "true"；如果其为 false，则关联字符串为 "false"。此方法与 getBoolean(java.lang.String, boolean) 一起使用。

参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
getBoolean(String,boolean), get(String,String)

getBoolean

public abstract boolean getBoolean(String key,
                                   boolean def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 boolean 值。有效字符串是 "true"（表示真）和 "false"（表示假）。不区分大小写，例如，"TRUE" 和 "False" 也是有效的。此方法与 putBoolean(java.lang.String, boolean) 一起使用。

如果不存在与该键相关联的值或者内部存储不可访问或者关联值是 "true" 或 "false"（不区分大小写）之外的其他值，则返回指定默认值。

如果该实现支持存储的默认值，这样的默认值存在且可访问，则优先使用存储的默认值（而不是指定默认值）；但如果存储的默认值是 "true" 或 "false"（不区分大小写）之外的其他值，在这种情况下，则使用指定默认值。

参数：
key - 要作为 boolean 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或者无法将该关联值解释为 boolean 或者内部存储不可访问时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 boolean 值；如果该关联值不存在或无法被解释为 boolean，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
get(String,String), putBoolean(String,boolean)

putFloat

public abstract void putFloat(String key,
                              float value)
将表示指定 float 值的字符串与此首选项节点中的指定键相关联。关联字符串是将 float 值传递给 Float.toString(float) 时将返回的字符串。此方法与 getFloat(java.lang.String, float) 一起使用。

参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
getFloat(String,float)

getFloat

public abstract float getFloat(String key,
                               float def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 float 值。该字符串由 Float.parseFloat(String) 转换为整数。如果不存在与该键相关联的值，内部存储不可用，或者传递关联值时 Float.parseFloat(String) 抛出 NumberFormatException，则返回指定的默认值。此方法与 putFloat(java.lang.String, float) 一起使用。

如果该实现支持存储的默认值，这样的默认值存在且可访问，并且可以使用 Float.parseFloat 转换为 float，则优先返回此 float（而不是指定默认值）。

参数：
key - 要作为 float 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或者无法将该关联值解释为 float 或者内部存储不可访问时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 float 值；如果该关联值不存在或无法被解释为 float，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
putFloat(String,float), get(String,String)

putDouble

public abstract void putDouble(String key,
                               double value)
将表示指定 double 值的字符串与此首选项节点中的指定键相关联。关联字符串是将 double 值传递给 Double.toString(double) 时将返回的字符串。此方法与 getDouble(java.lang.String, double) 一起使用。

参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
getDouble(String,double)

getDouble

public abstract double getDouble(String key,
                                 double def)
返回与此首选项节点中指定的键相关联的、由字符串表示的 double 值。该字符串由 Double.parseDouble(String) 转换为整数。如果不存在与该键相关联的值，内部存储不可用，或者传递关联值时 Double.parseDouble(String) 抛出 NumberFormatException，则返回指定的默认值。此方法与 putDouble(java.lang.String, double) 一起使用。

如果该实现支持存储的默认值，这样的默认值存在且可访问，并且可以使用 Double.parseDouble 转换为 double，则优先返回此 double（而不是指定默认值）。

参数：
key - 要作为 double 返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或者无法将该关联值解释为 double 或者内部存储不可访问时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的 double 值；如果该关联值不存在或无法被解释为 double，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。
另请参见：
putDouble(String,double), get(String,String)

putByteArray

public abstract void putByteArray(String key,
                                  byte[] value)
将表示指定字节数组的字符串与此首选项节点中的指定键相关联。正如 RFC 2045，第 6.8 节中定义的那样，该关联字符串是 Base64 编码的字节数组，其中有一处小的改动：该字符串仅由 Base64 Alphabet 中的字符构成；它不包含任何新行符。注意，该字节数组的最大长度限制是 MAX_VALUE_LENGTH 的四分之三，因此，Base64 编码的 String 的长度不能超过 MAX_VALUE_LENGTH。此方法与 getByteArray(java.lang.String, byte[]) 一起使用。

参数：
key - 要与字符串形式的 value 相关联的键。
value - 要与 key 相关联的字符串形式的值。
抛出：
NullPointerException - 如果 key 或 value 为 null。
IllegalArgumentException - 如果 key.length() 超过 MAX_KEY_LENGTH 或者 value.length 超过 MAX_VALUE_LENGTH*3/4。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
getByteArray(String,byte[]), get(String,String)

getByteArray

public abstract byte[] getByteArray(String key,
                                    byte[] def)
返回与此首选项节点中指定键相关联的、由字符串表示的字节数组。正如 RFC 2045，第 6.8 节中定义的那样，有效的字符串是 Base64 编码的二进制数据，其中有一处小的改动：该字符串必须仅包含 Base64 Alphabet 中的字符；不允许使用任何新行符或额外字符。此方法与 putByteArray(java.lang.String, byte[]) 一起使用。

如果没有与该键相关联的值或者内部存储不可访问或者关联值不是有效的 Base64 编码字节数组（根据上面的定义），则返回指定默认值。

如果该实现支持存储的默认值，这样的默认值存在且可访问，则优先使用存储的默认值（而不是指定默认值）；但如果存储的默认值不是有效的 Base64 编码的字节数组（根据上面的定义），在这种情况下，则使用指定默认值。

参数：
key - 要作为字节数组返回其关联值的键。
def - 此首选项节点不具有与 key 相关联的值或者无法将该关联值解释为字节数组或者内部存储不可访问时要返回的值。
返回：
与此首选项节点的 key 相关联的字符串所表示的字节数组值；如果该关联值不存在或无法被解释为字节数组，则返回 def。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
NullPointerException - 如果 key 为 null。（值 null 用于 def 是 允许的。）
另请参见：
get(String,String), putByteArray(String,byte[])

keys

public abstract String[] keys()
                       throws BackingStoreException
返回在此首选项节点中具有关联值的所有键。（如果此节点不具有任何首选项，则返回数组的大小将为 0。）

如果该实现支持存储的默认值，此节点中存在这样的默认值并且没有被显式首选项重写，则在数组中除了返回所有显式首选项外，还返回默认值。

返回：
在此首选项节点中具有关联值的键数组。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

childrenNames

public abstract String[] childrenNames()
                                throws BackingStoreException
返回此首选项节点相对于此节点的子节点名称。（如果此节点不具有任何子节点，则返回数组的大小将为 0。）

返回：
此首选项节点的子节点名称。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

parent

public abstract Preferences parent()
返回此首选项节点的父节点；如果此为根，则返回 null。

返回：
首选项节点的父节点。
抛出：
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。

node

public abstract Preferences node(String pathName)
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。接受相对或绝对路径名。相对路径名（不以斜杠字符 ('/') 开头）是相对于此首选项节点解释的。

如果在此调用之前返回的节点不存在，那么在对返回节点（或者其某个祖先或子节点）调用 flush 方法之前，不能保证由此调用所创建的节点及其所有祖先是永久性的。

参数：
pathName - 要返回的首选项节点的路径名。
返回：
指定的首选项节点。
抛出：
IllegalArgumentException - 如果路径名无效（即它包含多个连续的斜杠字符，或者以斜杠字符结束并且大于一个 long 字符）。
NullPointerException - 如果路径名为 null。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
flush()

nodeExists

public abstract boolean nodeExists(String pathName)
                            throws BackingStoreException
如果此节点所在的树中存在指定首选项节点，则返回 true。相对路径名（不以斜杠字符 ('/') 开头）是相对于此首选项节点解释的。

如果已经使用 removeNode() 方法移除了此节点（及其祖先），则调用此方法也是 合法的，只是需要使用路径名 ""；该调用返回 false。因此，可以使用语句 p.nodeExists("") 测试 p 是否已被移除。

参数：
pathName - 要检查其是否存在的节点路径名。
返回：
如果指定的节点存在，则返回 true。
抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalArgumentException - 如果路径名无效（即它包含多个连续的斜杠字符，或者以斜杠字符结束并且大于一个 long 字符）。
NullPointerException - 如果路径名为 null。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先），并且 pathName 不是空字符串 ("")。

removeNode

public abstract void removeNode()
                         throws BackingStoreException
移除此首选项节点及其所有子节点，移除的节点中所包含的全部首选项都将失效。节点被移除后，针对相应 Preferences 实例尝试使用 name()、absolutePath()、isUserNode()、flush() 或 nodeExists("") 之外的任何方法都将失败并抛出 IllegalStateException。（节点被移除后，在该节点上仍然可以调用在 Object 上定义的方法，并且不抛出 IllegalStateException。）

在此节点（或其祖先）上调用 flush 方法之前移除操作不保证是持久的。

如果此实现支持存储的默认值，则移除节点将公开此节点的或此节点下的所有存储的默认值。因此，对此节点的路径名后续调用 nodeExists 将返回 true，而对此路径名后续调用 node 则返回表示首选项和/或子首选项的非空 collection 的（不同）Preferences 实例。

抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
UnsupportedOperationException - 如果在根节点上调用此方法。
另请参见：
flush()

name

public abstract String name()
返回此首选项节点相对于父节点的名称。

返回：
此首选项节点的名称（相对于其父节点）。

absolutePath

public abstract String absolutePath()
返回此首选项节点的绝对路径名。

返回：
此首选项节点的绝对路径名。

isUserNode

public abstract boolean isUserNode()
如果此首选项节点位于用户首选项树中，则返回 true；如果其位于系统首选项树中，则返回 false。

返回：
如果此首选项节点位于用户首选项树中，则返回 true；如果其位于系统首选项树中，则返回 false。

toString

public abstract String toString()
返回此首选项节点的字符串表示形式，与通过表达式：(this.isUserNode() ? "User" : "System") + " Preference Node: " + this.absolutePath() 计算的结果一样。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

flush

public abstract void flush()
                    throws BackingStoreException
强制进行从此首选项节点及其子节点到持久存储的内容更改。此方法成功返回后，即可安全地假定调用该方法前，在以此节点为根的子树中所作的全部更改都是永久性的。

实现可以在任何时间随意将更改刷新到持久存储中。它们无需等待此方法的调用。

对新创建的节点进行刷新后，它就变得持久了，同时其所有尚未变得持久的祖先（和子节点）也将变得持久。但是注意，不 保证其祖先中的所有首选项值的更改能变得持久。

如果在已经使用 removeNode() 方法移除的节点上调用此方法，则会在此节点（而非其他节点）上调用 flushSpi()。

抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
另请参见：
sync()

sync

public abstract void sync()
                   throws BackingStoreException
确保在调用 sync 之前从此首选项节点及其子节点进行的后续读取能反映出提交到持久存储（从任何 VM）的所有更改。另外，强制进行从此首选项节点及其子节点到持久存储的内容更改，与对此节点调用 flush 方法一样。

抛出：
BackingStoreException - 如果由于内部存储的故障或未能通信而无法完成此操作。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
flush()

addPreferenceChangeListener

public abstract void addPreferenceChangeListener(PreferenceChangeListener pcl)
注册指定侦听器以接收此首选项节点的首选项更改事件。将首选项添加到此节点、从此节点移除首选项或者更改与首选项关联的值时都将生成首选项更改事件。（removeNode() 方法不 生成首选项更改事件，该方法只生成节点更改事件。首选项更改事件是 由 clear 方法生成的。）

尽管有些实现可以为在 JVM 外进行的更改生成事件，但只有在已注册侦听器所在的 JVM 中所作的更改才能得到保证。事件可能是更改变得持久之前生成的。在此节点的子节点中修改首选项时不生成事件；需要此类事件的调用者必须在每个子节点中注册。

参数：
pcl - 要添加的首选项更改侦听器。
抛出：
NullPointerException - 如果 pcl 为 null。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
removePreferenceChangeListener(PreferenceChangeListener), addNodeChangeListener(NodeChangeListener)

removePreferenceChangeListener

public abstract void removePreferenceChangeListener(PreferenceChangeListener pcl)
移除指定首选项更改侦听器，使其不再接收首选项更改事件。

参数：
pcl - 要移除的首选项更改侦听器。
抛出：
IllegalArgumentException - 如果 pcl 不是此节点上的已注册首选项更改侦听器。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
addPreferenceChangeListener(PreferenceChangeListener)

addNodeChangeListener

public abstract void addNodeChangeListener(NodeChangeListener ncl)
注册指定侦听器以接收此节点的节点更改事件。在此节点中添加或删除子节点时，将生成节点更改事件。（单个 removeNode() 调用即可产生多个节点更改事件，每个都对应于以已移除节点为根的子树中的一个节点。）

尽管有些实现可以为在 JVM 外进行的更改生成事件，但只有在注册侦听器所在的 JVM 中所作的更改才能得到保证。事件可能是更改变得持久之前生成的。添加或移除此节点的间接子节点时不生成事件；需要此类事件的调用者必须在每个子节点中注册。

节点的创建难以得到保证。因为节点是基于访问隐式创建的，实现无法确定访问前内部存储中是否存在子节点（例如，内部存储不可访问或已缓存信息过期）。在这些情形下，实现既不要求生成节点更改事件也不禁止这样做。

参数：
ncl - 要添加的 NodeChangeListener。
抛出：
NullPointerException - 如果 ncl 为 null。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
removeNodeChangeListener(NodeChangeListener), addPreferenceChangeListener(PreferenceChangeListener)

removeNodeChangeListener

public abstract void removeNodeChangeListener(NodeChangeListener ncl)
移除指定 NodeChangeListener，使其不再接收更改事件。

参数：
ncl - 要移除的 NodeChangeListener。
抛出：
IllegalArgumentException - 如果 ncl 不是此节点上的已注册 NodeChangeListener。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
addNodeChangeListener(NodeChangeListener)

exportNode

public abstract void exportNode(OutputStream os)
                         throws IOException,
                                BackingStoreException
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。此 XML 文档实际上是节点的脱机备份。

该 XML 文档具有以下 DOCTYPE 声明：

 <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
使用 UTF-8 字符编码。

此方法对一般规则而言是个例外，在此类中并发执行多个方法将产生等效于某些顺序执行的结果。如果由于调用此方法而同时修改了此节点的多个首选项，则导出的首选项由该节点所包含的首选项的“模糊快照”组成；有些并发修改可能在导出数据中得到了反映，而有些则不然。

参数：
os - 根据其内容发出 XML 文档的输出流。
抛出：
IOException - 如果写入指定的输出流导致 IOException。
BackingStoreException - 如果无法从内部存储读取首选项数据。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
importPreferences(InputStream)

exportSubtree

public abstract void exportSubtree(OutputStream os)
                            throws IOException,
                                   BackingStoreException
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。此 XML 文档实际上是以该节点为根的子树的脱机备份。

该 XML 文档具有以下 DOCTYPE 声明：

 <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
使用 UTF-8 字符编码。

此方法对一般规则而言是个例外，在此类中并发执行多个方法将产生等效于某些顺序执行的结果。如果通过调用此方法同时修改了以此节点为根的子树中的首选项或节点，则导出的首选项由该子树的“模糊快照”组成；有些并发修改可能在导出数据中得到了反映，而有些则不然。

参数：
os - 根据其内容发出 XML 文档的输出流。
抛出：
IOException - 如果写入指定的输出流导致 IOException。
BackingStoreException - 如果无法从内部存储读取首选项数据。
IllegalStateException - 如果已经使用 removeNode() 方法移除了此节点（或其祖先）。
另请参见：
importPreferences(InputStream), exportNode(OutputStream)

importPreferences

public static void importPreferences(InputStream is)
                              throws IOException,
                                     InvalidPreferencesFormatException
导入指定输入流中由 XML 文档表示的所有首选项。该文档可能表示用户首选项或系统首选项。如果它表示用户首选项，则这些首选项将被导入到调用用户的首选项树（即使它们原先位于另外的用户首选项树）。如果该文档描述的某些首选项位于不存在的首选项节点，则创建这些节点。

该 XML 文档必须具有以下 DOCTYPE 声明：

 <!DOCTYPE preferences SYSTEM "http://java.sun.com/dtd/preferences.dtd">
（此方法与 exportNode(OutputStream) 和 exportSubtree(OutputStream) 一起使用。

此方法对一般规则而言是个例外，在此类中并发执行多个方法将产生等效于某些顺序执行的结果。该方法好像要在此类中其他公共方法之上实现，尤其是 node(String) 和 put(String, String)。

参数：
is - 从中读取 XML 文档的输入流。
抛出：
IOException - 如果读取指定的输入流导致 IOException。
InvalidPreferencesFormatException - 输入流中的数据没有按要求的文档类型组成有效的 XML 文档。
SecurityException - 如果安全管理器存在并且拒绝 RuntimePermission("preferences")。
另请参见：
RuntimePermission
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PreferencesFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.prefs
接口 PreferencesFactory

public interface PreferencesFactory

生成 Preferences 对象的 factory 对象。新的 Preferences 实现的提供者应该提供相应的 PreferencesFactory 实现，以安装新的 Preferences 实现来代替特定于平台的默认实现。

此类仅供 Preferences 实现者使用。Preferences 设施的普通用户无需参考此文档。

从以下版本开始：
1.4
另请参见：
Preferences

方法摘要
Preferences | systemRoot() 返回系统根首选项节点。
Preferences | userRoot() 返回与调用用户相对应的用户根首选项节点。

方法详细信息

systemRoot

Preferences systemRoot()
返回系统根首选项节点。（针对此方法的多个调用将返回相同的对象引用。）

userRoot

Preferences userRoot()
返回与调用用户相对应的用户根首选项节点。在服务器中，返回值通常依赖于某些隐式的客户机上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.prefs (Java 2 Platform SE 6)

 java.util.prefs
接口
NodeChangeListener
PreferenceChangeListener
PreferencesFactory
类
AbstractPreferences
NodeChangeEvent
PreferenceChangeEvent
Preferences
异常
BackingStoreException
InvalidPreferencesFormatException


java.util.prefs (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.prefs

此包允许应用程序存储并获取用户和系统首选项和配置数据。

请参见：
描述

接口摘要
NodeChangeListener | 用于接收首选项节点更改事件的侦听器。
PreferenceChangeListener | 用于接收首选项节点更改事件的侦听器。
PreferencesFactory | 生成 Preferences 对象的 factory 对象。

类摘要
AbstractPreferences | 此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。
NodeChangeEvent | Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
PreferenceChangeEvent | Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。
Preferences | 首选项数据的层次结构 collection 中的节点。

异常摘要
BackingStoreException | 抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
InvalidPreferencesFormatException | 抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。

软件包 java.util.prefs 的描述

此包允许应用程序存储并获取用户和系统首选项和配置数据。此数据持久存储在依赖于实现的内部存储中。有两个独立的首选项节点树，一个用于用户首选项，一个用于系统首选项。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.prefs 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.prefs 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • java.util.prefs.NodeChangeEvent
      • java.util.prefs.PreferenceChangeEvent
    • java.util.prefs.Preferences
      • java.util.prefs.AbstractPreferences
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.util.prefs.BackingStoreException
        • java.util.prefs.InvalidPreferencesFormatException

接口分层结构

  • java.util.EventListener
    • java.util.prefs.NodeChangeListener
    • java.util.prefs.PreferenceChangeListener
  • java.util.prefs.PreferencesFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.prefs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.prefs
的使用

使用 java.util.prefs 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 使用的 java.util.prefs 中的类
AbstractPreferences
此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。
BackingStoreException
抛出该异常表明由于内部存储故障或者不能联系内部存储而无法完成 preferences 操作。
InvalidPreferencesFormatException
抛出此异常表明根据 Preferences 规范，输入内容不符合 preferences 集的正确 XML 文档类型，从而无法完成操作。
NodeChangeEvent
Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
NodeChangeListener
用于接收首选项节点更改事件的侦听器。
PreferenceChangeEvent
Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。
PreferenceChangeListener
用于接收首选项节点更改事件的侦听器。
Preferences
首选项数据的层次结构 collection 中的节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.prefs.AbstractPreferences 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.AbstractPreferences
的使用

使用 AbstractPreferences 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 AbstractPreferences 的使用

返回 AbstractPreferences 的 java.util.prefs 中的方法
protected AbstractPreferences[] | AbstractPreferences.cachedChildren() 返回此节点的所有已知未移除子节点。
protected abstract AbstractPreferences | AbstractPreferences.childSpi(String name) 返回此首选项节点的指定子节点；如果该子节点尚未存在，则创建它。
protected AbstractPreferences | AbstractPreferences.getChild(String nodeName) 如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。

参数类型为 AbstractPreferences 的 java.util.prefs 中的构造方法
AbstractPreferences(AbstractPreferences parent, String name)
用指定的父节点和与其父节点相关的指定名称创建首选项节点。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.prefs.BackingStoreException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.BackingStoreException
的使用

使用 BackingStoreException 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 BackingStoreException 的使用

抛出 BackingStoreException 的 java.util.prefs 中的方法
 String[] AbstractPreferences.childrenNames()
根据 Preferences.childrenNames() 中的规范实现 children 方法。
abstract  String[] Preferences.childrenNames()
返回此首选项节点相对于此节点的子节点名称。
protected abstract  String[] AbstractPreferences.childrenNamesSpi()
返回此首选项节点的子节点名称。
 void AbstractPreferences.clear()
根据 Preferences.clear() 中的规范实现 clear 方法。
abstract  void Preferences.clear()
移除此首选项节点中的所有首选项（键-值关联）。
 void AbstractPreferences.exportNode(OutputStream os)
根据 Preferences.exportNode(OutputStream) 中的规范实现 exportNode 方法。
abstract  void Preferences.exportNode(OutputStream os)
在指定输出流上发出表示此节点（不是其子节点）中包含的所有首选项的 XML 文档。
 void AbstractPreferences.exportSubtree(OutputStream os)
根据 Preferences.exportSubtree(OutputStream) 中的规范实现 exportSubtree 方法。
abstract  void Preferences.exportSubtree(OutputStream os)
发出表示此节点及其所有子节点中包含的全部首选项的 XML 文档。
 void AbstractPreferences.flush()
根据 Preferences.flush() 中的规范实现 flush 方法。
abstract  void Preferences.flush()
强制进行从此首选项节点及其子节点到持久存储的内容更改。
protected abstract  void AbstractPreferences.flushSpi()
此方法是在此节点被锁定的情况下调用的。
protected  AbstractPreferences AbstractPreferences.getChild(String nodeName)
如果指定的子节点存在，则返回该子节点；如果它不存在，则返回 null。
 String[] AbstractPreferences.keys()
根据 Preferences.keys() 中的规范实现 keys 方法。
abstract  String[] Preferences.keys()
返回在此首选项节点中具有关联值的所有键。
protected abstract  String[] AbstractPreferences.keysSpi()
返回在此首选项节点中具有关联值的所有键。
 boolean AbstractPreferences.nodeExists(String path)
根据 Preferences.nodeExists(String) 中的规范实现 nodeExists 方法。
abstract  boolean Preferences.nodeExists(String pathName)
如果此节点所在的树中存在指定首选项节点，则返回 true。
 void AbstractPreferences.removeNode()
根据 Preferences.removeNode() 中的规范实现 removeNode() 方法。
abstract  void Preferences.removeNode()
移除此首选项节点及其所有子节点，移除的节点中所包含的全部首选项都将失效。
protected abstract  void AbstractPreferences.removeNodeSpi()
移除此首选项节点，该首选项节点及其所包含的所有首选项都将失效。
 void AbstractPreferences.sync()
根据 Preferences.sync() 中的规范实现 sync 方法。
abstract  void Preferences.sync()
确保在调用 sync 之前从此首选项节点及其子节点进行的后续读取能反映出提交到持久存储（从任何 VM）的所有更改。
protected abstract  void AbstractPreferences.syncSpi()
此方法是在此节点被锁定的情况下调用的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.prefs.InvalidPreferencesFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.InvalidPreferencesFormatException
的使用

使用 InvalidPreferencesFormatException 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 InvalidPreferencesFormatException 的使用

抛出 InvalidPreferencesFormatException 的 java.util.prefs 中的方法
static void Preferences.importPreferences(InputStream is)
导入指定输入流中由 XML 文档表示的所有首选项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.prefs.NodeChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.NodeChangeEvent
的使用

使用 NodeChangeEvent 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 NodeChangeEvent 的使用

参数类型为 NodeChangeEvent 的 java.util.prefs 中的方法
void | NodeChangeListener.childAdded(NodeChangeEvent evt) 添加子节点时调用此方法。
void | NodeChangeListener.childRemoved(NodeChangeEvent evt) 移除子节点时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.prefs.NodeChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.prefs.NodeChangeListener
的使用

使用 NodeChangeListener 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 NodeChangeListener 的使用

参数类型为 NodeChangeListener 的 java.util.prefs 中的方法
void | AbstractPreferences.addNodeChangeListener(NodeChangeListener ncl)
abstract void | Preferences.addNodeChangeListener(NodeChangeListener ncl) 注册指定侦听器以接收此节点的节点更改事件。
void | AbstractPreferences.removeNodeChangeListener(NodeChangeListener ncl)
abstract void | Preferences.removeNodeChangeListener(NodeChangeListener ncl) 移除指定 NodeChangeListener，使其不再接收更改事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.prefs.PreferenceChangeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.PreferenceChangeEvent
的使用

使用 PreferenceChangeEvent 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 PreferenceChangeEvent 的使用

参数类型为 PreferenceChangeEvent 的 java.util.prefs 中的方法
 void PreferenceChangeListener.preferenceChange(PreferenceChangeEvent evt)
当添加、移除首选项或者更改首选项的值时，调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.prefs.PreferenceChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.prefs.PreferenceChangeListener
的使用

使用 PreferenceChangeListener 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 PreferenceChangeListener 的使用

参数类型为 PreferenceChangeListener 的 java.util.prefs 中的方法
void | AbstractPreferences.addPreferenceChangeListener(PreferenceChangeListener pcl)
abstract void | Preferences.addPreferenceChangeListener(PreferenceChangeListener pcl) 注册指定侦听器以接收此首选项节点的首选项更改事件。
void | AbstractPreferences.removePreferenceChangeListener(PreferenceChangeListener pcl)
abstract void | Preferences.removePreferenceChangeListener(PreferenceChangeListener pcl) 移除指定首选项更改侦听器，使其不再接收首选项更改事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.prefs.Preferences 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.prefs.Preferences
的使用

使用 Preferences 的软件包
java.util.prefs 此包允许应用程序存储并获取用户和系统首选项和配置数据。

java.util.prefs 中 Preferences 的使用

java.util.prefs 中 Preferences 的子类
 class AbstractPreferences
此类提供了 Preferences 类的骨干实现，从而大大简化了实现此类的任务。

返回 Preferences 的 java.util.prefs 中的方法
 Preferences NodeChangeEvent.getChild()
返回添加或移除的节点。
 Preferences PreferenceChangeEvent.getNode()
返回发出事件的首选项节点。
 Preferences NodeChangeEvent.getParent()
返回添加或移除节点的父节点。
 Preferences AbstractPreferences.node(String path)
根据 node(String) 中的规范实现 node 方法。
abstract  Preferences Preferences.node(String pathName)
将指定首选项节点返回到此节点所在的同一树中，如果此节点及其祖先已经不存在，则创建它们。
 Preferences AbstractPreferences.parent()
根据 parent() 中的规范实现 parent 方法。
abstract  Preferences Preferences.parent()
返回此首选项节点的父节点；如果此为根，则返回 null。
static Preferences Preferences.systemNodeForPackage(Class<?> c)
从系统首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences Preferences.systemRoot()
返回系统的根首选项节点。
 Preferences PreferencesFactory.systemRoot()
返回系统根首选项节点。
static Preferences Preferences.userNodeForPackage(Class<?> c)
从调用用户首选项树（根据约定，它与指定类的包相关联）返回首选项节点。
static Preferences Preferences.userRoot()
返回调用用户的根首选项节点。
 Preferences PreferencesFactory.userRoot()
返回与调用用户相对应的用户根首选项节点。

参数类型为 Preferences 的 java.util.prefs 中的构造方法
NodeChangeEvent(Preferences parent, Preferences child)
构造新的 NodeChangeEvent 实例。
PreferenceChangeEvent(Preferences node, String key, String newValue)
构造新的 PreferenceChangeEvent 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.prefs.PreferencesFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.prefs.PreferencesFactory
的使用

没有 java.util.prefs.PreferencesFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Matcher (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.regex
类 Matcher

java.lang.Object
    继承者  java.util.regex.Matcher
所有已实现的接口：
MatchResult
public final class Matcher
extends Object
implements MatchResult

通过解释 Pattern 对 character sequence 执行匹配操作的引擎。

通过调用模式的 matcher 方法从模式创建匹配器。创建匹配器后，可以使用它执行三种不同的匹配操作：

  • matches 方法尝试将整个输入序列与该模式匹配。

  • lookingAt 尝试将输入序列从头开始与该模式匹配。

  • find 方法扫描输入序列以查找与该模式匹配的下一个子序列。

每个方法都返回一个表示成功或失败的布尔值。通过查询匹配器的状态可以获取关于成功匹配的更多信息。

匹配器在其输入的子集（称为区域）中查找匹配项。默认情况下，此区域包含全部的匹配器输入。可通过 region 方法修改区域，通过 regionStart 和 regionEnd 方法查询区域。区域边界与某些模式构造交互的方式是可以更改的。有关此内容更多的信息，请参阅 useAnchoringBounds 和 useTransparentBounds。

此类还定义使用新字符串替换匹配子序列的方法，需要时，可以从匹配结果计算出新字符串的内容。可以先后使用 appendReplacement 和 appendTail 方法将结果收集到现有的字符串缓冲区，或者使用更加便捷的 replaceAll 方法创建一个可以在其中替换输入序列中每个匹配子序列的字符串。

匹配器的显式状态包括最近成功匹配的开始和结束索引。它还包括模式中每个捕获组捕获的输入子序列的开始和结束索引以及该子序列的总数。出于方便的考虑，还提供了以字符串的形式返回这些已捕获子序列的方法。

匹配器的显式状态最初是未定义的；在成功匹配导致 IllegalStateException 抛出之前尝试查询其中的任何部分。每个匹配操作都将重新计算匹配器的显式状态。

匹配器的隐式状态包括输入字符序列和添加位置，添加位置最初是零，然后由 appendReplacement 方法更新。

可以通过调用匹配器的 reset() 方法来显式重置匹配器，如果需要新输入序列，则调用其 reset(CharSequence) 方法。重置匹配器将放弃其显式状态信息并将添加位置设置为零。

此类的实例用于多个并发线程是不安全的。

从以下版本开始：
1.4

方法摘要
Matcher | appendReplacement(StringBuffer sb, String replacement) 实现非终端添加和替换步骤。
StringBuffer | appendTail(StringBuffer sb) 实现终端添加和替换步骤。
int | end() 返回最后匹配字符之后的偏移量。
int | end(int group) 返回在以前的匹配操作期间，由给定组所捕获子序列的最后字符之后的偏移量。
boolean | find() 尝试查找与该模式匹配的输入序列的下一个子序列。
boolean | find(int start) 重置此匹配器，然后尝试查找匹配该模式、从指定索引开始的输入序列的下一个子序列。
String | group() 返回由以前匹配操作所匹配的输入子序列。
String | group(int group) 返回在以前匹配操作期间由给定组捕获的输入子序列。
int | groupCount() 返回此匹配器模式中的捕获组数。
boolean | hasAnchoringBounds() 查询此匹配器区域界限的定位。
boolean | hasTransparentBounds() 查询此匹配器区域边界的透明度。
boolean | hitEnd() 如果匹配器执行的最后匹配操作中搜索引擎遇到输入结尾，则返回 true。
boolean | lookingAt() 尝试将从区域开头开始的输入序列与该模式匹配。
boolean | matches() 尝试将整个区域与模式匹配。
Pattern | pattern() 返回由此匹配器解释的模式。
static String | quoteReplacement(String s) 返回指定 String 的字面值替换 String。
Matcher | region(int start, int end) 设置此匹配器的区域限制。
int | regionEnd() 报告此匹配器区域的结束索引（不包括）。
int | regionStart() 报告此匹配器区域的开始索引。
String | replaceAll(String replacement) 替换模式与给定替换字符串相匹配的输入序列的每个子序列。
String | replaceFirst(String replacement) 替换模式与给定替换字符串匹配的输入序列的第一个子序列。
boolean | requireEnd() 如果很多输入都可以将正匹配更改为负匹配，则返回 true。
Matcher | reset() 重置匹配器。
Matcher | reset(CharSequence input) 重置此具有新输入序列的匹配器。
int | start() 返回以前匹配的初始索引。
int | start(int group) 返回在以前的匹配操作期间，由给定组所捕获的子序列的初始索引。
MatchResult | toMatchResult() 作为 MatchResult 返回此匹配器的匹配状态。
String | toString() 返回匹配器的字符串表示形式。
Matcher | useAnchoringBounds(boolean b) 设置匹配器区域界限的定位。
Matcher | usePattern(Pattern newPattern) 更改此 Matcher 用于查找匹配项的 Pattern。
Matcher | useTransparentBounds(boolean b) 设置此匹配器区域边界的透明度。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

pattern

public Pattern pattern()
返回由此匹配器解释的模式。

返回：
为其创建此匹配器的模式。

toMatchResult

public MatchResult toMatchResult()
作为 MatchResult 返回此匹配器的匹配状态。该结果不受对此匹配器执行的后续操作的影响。

返回：
具有此匹配器状态的 MatchResult。
从以下版本开始：
1.5

usePattern

public Matcher usePattern(Pattern newPattern)
更改此 Matcher 用于查找匹配项的 Pattern。

此方法可导致匹配器丢失有关最后发生匹配的组的信息。维持了输入中匹配器的位置并且不影响其最后添加的位置。

参数：
newPattern - 匹配器使用的新模式。
返回：
匹配器。
抛出：
IllegalArgumentException - 如果 newPattern 为 null。
从以下版本开始：
1.5

reset

public Matcher reset()
重置匹配器。

重置匹配器将放弃其所有显式状态信息并将其添加位置设置为零。匹配器的区域被设置为默认区域，默认区域就是其整个字符序列。此匹配器的区域边界的定位和透明度都不受影响。

返回：
匹配器。

reset

public Matcher reset(CharSequence input)
重置此具有新输入序列的匹配器。

重置匹配器将放弃其所有显式状态信息并将其添加位置设置为零。匹配器的区域被设置为默认区域，默认区域就是其整个字符序列。此匹配器的区域边界的定位和透明度都不受影响。

参数：
input - 新的输入字符序列。
返回：
匹配器。

start

public int start()
返回以前匹配的初始索引。

指定者：
接口 MatchResult 中的 start
返回：
第一个匹配字符的索引。
抛出：
IllegalStateException - 如果没有尝试任何匹配，或者以前的匹配操作失败。

start

public int start(int group)
返回在以前的匹配操作期间，由给定组所捕获的子序列的初始索引。

捕获组是从 1 开始从左到右的索引。组零表示整个模式，因此表达式 m.start(0) 等效于 m.start()。

指定者：
接口 MatchResult 中的 start
参数：
group - 此匹配器模式中捕获组的索引。
返回：
组捕获的首个字符的索引；如果匹配成功但组本身没有任何匹配项，则返回 -1。
抛出：
IllegalStateException - 如果没有尝试任何匹配，或者以前的匹配操作失败。
IndexOutOfBoundsException - 如果在给定索引的模式中不存在捕获组。

end

public int end()
返回最后匹配字符之后的偏移量。

指定者：
接口 MatchResult 中的 end
返回：
最后匹配字符之后的偏移量。
抛出：
IllegalStateException - 如果没有尝试任何匹配，或者以前的匹配操作失败。

end

public int end(int group)
返回在以前的匹配操作期间，由给定组所捕获子序列的最后字符之后的偏移量。

捕获组是从 1 开始从左到右的索引。组零表示整个模式，因此表达式 m.end(0) 等效于 m.end()。

指定者：
接口 MatchResult 中的 end
参数：
group - 此匹配器模式中捕获组的索引。
返回：
组捕获的最后字符之后的偏移量；如果匹配成功但组本身没有任何匹配项，则返回 -1。
抛出：
IllegalStateException - 如果没有尝试任何匹配，或者以前的匹配操作失败。
IndexOutOfBoundsException - 如果在给定索引的模式中不存在捕获组。

group

public String group()
返回由以前匹配操作所匹配的输入子序列。

对于具有输入序列 s 的匹配器 m，表达式 m.group() 和 s.substring(m.start(), m.end()) 是等效的。

注意，某些模式（例如，a*）匹配空字符串。当模式成功匹配输入中的空字符串时，此方法将返回空字符串。

指定者：
接口 MatchResult 中的 group
返回：
以前匹配操作所匹配的字符串形式的子序列（可能为空）。
抛出：
IllegalStateException - 如果没有尝试任何匹配，或者以前的匹配操作失败。

group

public String group(int group)
返回在以前匹配操作期间由给定组捕获的输入子序列。

对于匹配器 m、输入序列 s 和组索引 g，表达式 m.group(g) 和 s.substring(m.start(g), m.end(g)) 是等效的。

捕获组是从 1 开始从左到右的索引。组零表示整个模式，因此表达式 m.group(0) 等效于 m.group()。

如果该匹配成功了，但指定组未能匹配输入序列的任何部分，则返回 null。注意，某些组（例如，(a*)）匹配空字符串。当这些的组成功匹配输入中的空字符串时，此方法将返回空字符串。

指定者：
接口 MatchResult 中的 group
参数：
group - 此匹配器模式中捕获组的索引。
返回：
在以前的匹配期间组所捕获的子序列（可能为空）；如果组未能匹配输入的部分，则返回 null。
抛出：
IllegalStateException - 如果没有尝试任何匹配，或者以前的匹配操作失败。
IndexOutOfBoundsException - 如果在给定索引的模式中不存在捕获组。

groupCount

public int groupCount()
返回此匹配器模式中的捕获组数。

根据惯例，零组表示整个模式。它不包括在此计数中。

任何小于等于此方法返回值的非负整数保证是此匹配器的有效组索引。

指定者：
接口 MatchResult 中的 groupCount
返回：
此匹配器模式中的捕获组数。

matches

public boolean matches()
尝试将整个区域与模式匹配。

如果匹配成功，则可以通过 start、end 和 group 方法获取更多信息。

返回：
当且仅当整个区域序列匹配此匹配器的模式时才返回 true。

find

public boolean find()
尝试查找与该模式匹配的输入序列的下一个子序列。

此方法从匹配器区域的开头开始，如果该方法的前一次调用成功了并且从那时开始匹配器没有被重置，则从以前匹配操作没有匹配的第一个字符开始。

如果匹配成功，则可以通过 start、end 和 group 方法获取更多信息。

返回：
当且仅当输入序列的子序列匹配此匹配器的模式时才返回 true。

find

public boolean find(int start)
重置此匹配器，然后尝试查找匹配该模式、从指定索引开始的输入序列的下一个子序列。

如果匹配成功，则可通过 start、end 和 group 方法获取更多信息，而 find() 方法的后续调用将从此匹配操作未匹配的第一个字符开始。

返回：
当且仅当从给定索引开始的输入序列的子序列匹配此匹配器的模式时才返回 true。
抛出：
IndexOutOfBoundsException - 如果开始点小于零或大于输入序列的长度。

lookingAt

public boolean lookingAt()
尝试将从区域开头开始的输入序列与该模式匹配。

与 matches 方法类似，此方法始终从区域的开头开始；与之不同的是，它不需要匹配整个区域。

如果匹配成功，则可以通过 start、end 和 group 方法获取更多信息。

返回：
当且仅当输入序列的前缀匹配此匹配器的模式时才返回 true。

quoteReplacement

public static String quoteReplacement(String s)
返回指定 String 的字面值替换 String。 此方法将生成一个 String，它将用作 Matcher 类的 appendReplacement 方法中的字面值替换 s。所产生的 String 将与作为字面值序列的 s 中的字符序列匹配。斜线 ('\') 和美元符号 ('$') 将不具有任何特殊意义。

参数：
s - 要字面值化的字符串。
返回：
字面值字符串替换。
从以下版本开始：
1.5

appendReplacement

public Matcher appendReplacement(StringBuffer sb,
                                 String replacement)
实现非终端添加和替换步骤。

此方法执行以下操作：

  1. 它从添加位置开始在输入序列读取字符，并将其添加到给定字符串缓冲区。在读取以前匹配之前的最后字符（即位于索引 start() - 1 处的字符）之后，它就会停止。

  2. 它将给定替换字符串添加到字符串缓冲区。

  3. 它将此匹配器的添加位置设置为最后匹配位置的索引加 1，即 end()。

替换字符串可能包含到以前匹配期间所捕获的子序列的引用：$g 每次出现时，都将被 group (g) 的计算结果替换。$ 之后的第一个数始终被视为组引用的一部分。如果后续的数可以形成合法组引用，则将被合并到 g 中。只有数字 '0' 到 '9' 被视为组引用的可能组件。例如，如果第二个组匹配字符串 "foo"，则传递替换字符串 "$2bar" 将导致 "foobar" 被添加到字符串缓冲区。可能将美元符号 ($) 作为替换字符串中的字面值（通过前面使用一个反斜线 (\$)）包括进来。

注意，在替换字符串中使用反斜线 (\) 和美元符号 ($) 可能导致与作为字面值替换字符串时所产生的结果不同。美元符号可视为到如上所述已捕获子序列的引用，反斜线可用于转义替换字符串中的字面值字符。

此方法设计用于循环以及 appendTail 和 find 方法中。例如，以下代码将 one dog two dogs in the yard 写入标准输出流中：

 Pattern p = Pattern.compile("cat");
 Matcher m = p.matcher("one cat two cats in the yard");
 StringBuffer sb = new StringBuffer();
 while (m.find()) {
     m.appendReplacement(sb, "dog");
 }
 m.appendTail(sb);
 System.out.println(sb.toString());

参数：
sb - 目标字符串缓冲区。
replacement - 替换字符串。
返回：
匹配器。
抛出：
IllegalStateException - 如果没有尝试任何匹配，或者以前的匹配操作失败。
IndexOutOfBoundsException - 如果替换字符串引用模式中不存在的捕获组。

appendTail

public StringBuffer appendTail(StringBuffer sb)
实现终端添加和替换步骤。

此方法从添加位置开始从输入序列读取字符，并将其添加到给定字符串缓冲区。可以在一次或多次调用 appendReplacement 方法后调用它来复制剩余的输入序列。

参数：
sb - 目标字符串缓冲区。
返回：
目标字符串缓冲区。

replaceAll

public String replaceAll(String replacement)
替换模式与给定替换字符串相匹配的输入序列的每个子序列。

此方法首先重置匹配器。然后，它将扫描输入序列以查找该模式的匹配项。不属于任何匹配的字符被直接添加到结果字符串；在结果中每个匹配都将被替换字符串所替换。替换字符串可能包含到已捕获子序列的引用，如在 appendReplacement 方法中一样。

注意，在替换字符串中使用反斜线 (\) 和美元符号 ($) 可能导致与作为字面值替换字符串时所产生的结果不同。美元符号可视为到如上所述已捕获子序列的引用，反斜线可用于转义替换字符串中的字面值字符。

在给定正则表达式 a*b、输入 "aabfooaabfooabfoob" 和替换字符串 "-" 的情况下，为该表达式针对匹配器调用此方法将产生字符串 "-foo-foo-foo-"。

调用此方法将更改此匹配器的状态。如果在将来的匹配操作中使用该匹配器，则应该首先重置它。

参数：
replacement - 替换字符串。
返回：
通过使用替换字符串替换每个匹配子序列，并在需要时取代已捕获子序列所构造的字符串。

replaceFirst

public String replaceFirst(String replacement)
替换模式与给定替换字符串匹配的输入序列的第一个子序列。

此方法首先重置匹配器。然后，它将扫描输入序列以查找该模式的匹配项。不是匹配一部分的字符被直接添加到结果字符串；在结果中匹配内容将被替换字符串替换。替换字符串可能包含到已捕获子序列的引用，如在 appendReplacement 方法中一样。

注意，在替换字符串中使用反斜线 (\) 和美元符号 ($) 可能导致与作为字面值替换字符串时所产生的结果不同。美元符号可视为到如上所述已捕获子序列的引用，反斜线可用于转义替换字符串中的字面值字符。

在给定正则表达式 dog、输入 "zzzdogzzzdogzzz" 和替换字符串 "cat" 的情况下，为该表达式针对匹配器调用此方法将产生字符串 "zzzcatzzzdogzzz"。

调用此方法将更改此匹配器的状态。如果在将来的匹配操作中使用该匹配器，则应该首先重置它。

参数：
replacement - 替换字符串。
返回：
通过使用替换字符串替换第一个匹配子序列，并在需要时取代已捕获子序列所构造的字符串。

region

public Matcher region(int start,
                      int end)
设置此匹配器的区域限制。区域是输入序列的一部分，搜索它可以查找匹配。调用此方法会重置匹配器，然后设置区域，使其从 start 参数指定的索引开始，到 end 参数指定的索引结束。

某些构造（如定位点）可能因所用的透明度和定位不同（参见 useTransparentBounds 和 useAnchoringBounds），从而在区域的边界上或边界四周的行为也有所不同。

参数：
start - 索引，从此索引（包括在内）开始搜索。
end - 到此（包括在内）结束搜索的索引。
返回：
匹配器。
抛出：
IndexOutOfBoundsException - 如果开始点或结束点小于零，并且开始点的长度大于输入序列的长度，结束点的长度大于输入序列的长度，或者开始点大于结束点。
从以下版本开始：
1.5

regionStart

public int regionStart()
报告此匹配器区域的开始索引。此匹配器所进行的搜索被限制在 regionStart（包括）和 regionEnd（不包括）中查找匹配。

返回：
匹配器区域的开始点。
从以下版本开始：
1.5

regionEnd

public int regionEnd()
报告此匹配器区域的结束索引（不包括）。此匹配器所进行的搜索被限制在 regionStart（包括）和 regionEnd（不包括）中查找匹配。

返回：
匹配器区域的结束点。
从以下版本开始：
1.5

hasTransparentBounds

public boolean hasTransparentBounds()
查询此匹配器区域边界的透明度。

如果此匹配器使用透明 边界，则此方法返回 true；如果使用不透明 边界，则返回 false。

有关透明和不透明边界的描述，请参阅 useTransparentBounds。

默认情况下，匹配器使用不透明区域边界。

返回：
当且仅当此匹配器使用透明边界时才返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
useTransparentBounds(boolean)

useTransparentBounds

public Matcher useTransparentBounds(boolean b)
设置此匹配器区域边界的透明度。

利用参数 true 调用此方法将设置此匹配器使用透明 边界。如果布尔参数为 false，则使用不透明 边界。

使用透明边界，此匹配器区域的边界对 lookahead、lookbehind 和边界匹配构造都是透明的。可以使用这些构造查看区域边界的外部，以了解匹配是否正确。

使用不透明边界，此匹配器区域的边界对 lookahead、lookbehind 和试图查看其外部的边界匹配构造都是不透明的。这些构造无法穿过边界查看，因此不能使用它们匹配区域之外的任何内容。

默认情况下，匹配器使用不透明边界。

参数：
b - 指示使用不透明还是透明区域的布尔值。
返回：
匹配器。
从以下版本开始：
1.5
另请参见：
hasTransparentBounds()

hasAnchoringBounds

public boolean hasAnchoringBounds()
查询此匹配器区域界限的定位。

如果此匹配器使用定位 界限，则此方法返回 true；否则返回 false。

有关获取定位界限的描述，请参阅 useAnchoringBounds。

默认情况下，匹配器使用定位区域边界。

返回：
当且仅当此匹配器使用定位界限时才返回 true；否则返回 false。
从以下版本开始：
1.5
另请参见：
useAnchoringBounds(boolean)

useAnchoringBounds

public Matcher useAnchoringBounds(boolean b)
设置匹配器区域界限的定位。

利用参数 true 调用此方法将设置此匹配器使用定位 界限。如果布尔参数为 false，则使用非定位 界限。

使用定位界限，此匹配器区域的边界与定位点（如 ^ 和 $）匹配。

不使用定位界限，此匹配器区域的边界将与定位点（如 ^ 和 $）不匹配。

默认情况下，匹配器使用定位区域边界。

参数：
b - 指示是否使用定位界限的布尔值。
返回：
匹配器。
从以下版本开始：
1.5
另请参见：
hasAnchoringBounds()

toString

public String toString()

返回匹配器的字符串表示形式。包含可用于调试的信息的 Matcher 字符串表示形式。未指定确切格式。

覆盖：
类 Object 中的 toString
返回：
匹配器的字符串表示形式。
从以下版本开始：
1.5

hitEnd

public boolean hitEnd()

如果匹配器执行的最后匹配操作中搜索引擎遇到输入结尾，则返回 true。

此方法返回 true 时，很多输入都可能更改最后搜索的结果。

返回：
当且仅当在最后匹配中遇到输入结尾时才返回 true；否则返回 false。
从以下版本开始：
1.5

requireEnd

public boolean requireEnd()

如果很多输入都可以将正匹配更改为负匹配，则返回 true。

如果此方法返回 true，并且找到了匹配，则很多输入可能导致匹配丢失。如果此方法返回 false，并且找到了匹配，则很多输入可能更改匹配，但是匹配不会丢失。如果未找到匹配，则 requireEnd 没有意义。

返回：
当且仅当很多输入都可以将正匹配更改为负匹配时才返回 true。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MatchResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.regex
接口 MatchResult

所有已知实现类：
Matcher
public interface MatchResult

匹配操作的结果。

此接口包含用于确定与正则表达式匹配结果的查询方法。通过 MatchResult 可以查看匹配边界、组和组边界，但是不能修改。

从以下版本开始：
1.5
另请参见：
Matcher

方法摘要
int | end() 返回最后匹配字符之后的偏移量。
int | end(int group) 返回在匹配期间由给定组所捕获子序列的最后字符之后的偏移量。
String | group() 返回由以前匹配所匹配的输入子序列。
String | group(int group) 返回在以前匹配操作期间由给定组捕获的输入子序列。
int | groupCount() 返回此匹配结果的模式中的捕获组数。
int | start() 返回匹配的初始索引。
int | start(int group) 返回在匹配期间由给定组捕获的子序列的初始索引。

方法详细信息

start

int start()
返回匹配的初始索引。

返回：
第一个匹配字符的索引
抛出：
IllegalStateException - 如果没有尝试任何匹配或者以前的匹配操作失败

start

int start(int group)
返回在匹配期间由给定组捕获的子序列的初始索引。

捕获组是从左到右的索引，从 1 开始。组零表示整个模式，因此表达式 m.start(0) 等效于 m.start()。

参数：
group - 此匹配器模式中捕获组的索引
返回：
组捕获的第一个字符的索引；如果匹配成功但组本身没有匹配项，则返回 -1
抛出：
IllegalStateException - 如果没有尝试任何匹配或者以前的匹配操作失败
IndexOutOfBoundsException - 如果在给定索引的模式中不存在捕获组

end

int end()
返回最后匹配字符之后的偏移量。

返回：
最后匹配字符之后的偏移量
抛出：
IllegalStateException - 如果没有尝试任何匹配或者以前的匹配操作失败

end

int end(int group)
返回在匹配期间由给定组所捕获子序列的最后字符之后的偏移量。

捕获组是从左到右的索引，从 1 开始。组零表示整个模式，因此表达式 m.end(0) 等效于 m.end()。

参数：
group - 此匹配器模式中捕获组的索引
返回：
组捕获的最后字符之后的偏移量；如果匹配成功但组本身没有匹配项，则返回 -1
抛出：
IllegalStateException - 如果没有尝试任何匹配或者以前的匹配操作失败
IndexOutOfBoundsException - 如果在给定索引的模式中不存在捕获组

group

String group()
返回由以前匹配所匹配的输入子序列。

对于具有输入序列 s 的匹配器 m，表达式 m.group() 和 s.substring(m.start(), m.end()) 是等效的。

注意，某些模式（例如，a*）匹配空字符串。当模式成功匹配输入中的空字符串时，此方法将返回空字符串。

返回：
以前匹配所匹配的字符串形式的子序列（可能为空）
抛出：
IllegalStateException - 如果没有尝试任何匹配或者以前的匹配操作失败

group

String group(int group)
返回在以前匹配操作期间由给定组捕获的输入子序列。

对于匹配器 m、输入序列 s 和组索引 g，表达式 m.group(g) 和 s.substring(m.start(g), m.end(g)) 是等效的。

捕获组是从左到右的索引，从 1 开始。组零表示整个模式，因此表达式 m.group(0) 等效于 m.group()。

如果该匹配成功了，但指定组未能匹配输入序列的任何部分，则返回 null。注意，某些组（例如，(a*)）匹配空字符串。当这种组成功匹配输入中的空字符串时，此方法将返回空字符串。

参数：
group - 此匹配器模式中捕获组的索引
返回：
在以前的匹配期间组所捕获的子序列（可能为空）；如果组未能匹配输入的部分，则返回 null
抛出：
IllegalStateException - 如果没有尝试任何匹配或者以前的匹配操作失败
IndexOutOfBoundsException - 如果在给定索引的模式中不存在捕获组

groupCount

int groupCount()
返回此匹配结果的模式中的捕获组数。

根据惯例，零组表示整个模式。它不包括在此计数中。

任何小于等于由此方法返回的值的非负整数保证是此匹配器的有效组索引。

返回：
此匹配器模式中的捕获组数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Pattern (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.regex
类 Pattern

java.lang.Object
    继承者  java.util.regex.Pattern
所有已实现的接口：
Serializable
public final class Pattern
extends Object
implements Serializable

正则表达式的编译表示形式。

指定为字符串的正则表达式必须首先被编译为此类的实例。然后，可将得到的模式用于创建 Matcher 对象，依照正则表达式，该对象可以与任意字符序列匹配。执行匹配所涉及的所有状态都驻留在匹配器中，所以多个匹配器可以共享同一模式。

因此，典型的调用顺序是

 Pattern p = Pattern.compile("a*b");
 Matcher m = p.matcher("aaaaab");
 boolean b = m.matches();

在仅使用一次正则表达式时，可以方便地通过此类定义 matches 方法。此方法编译表达式并在单个调用中将输入序列与其匹配。语句

 boolean b = Pattern.matches("a*b", "aaaaab");
等效于上面的三个语句，尽管对于重复的匹配而言它效率不高，因为它不允许重用已编译的模式。

此类的实例是不可变的，可供多个并发线程安全使用。Matcher 类的实例用于此目的则不安全。

正则表达式的构造摘要

的非捕获组
构造 | 匹配
字符
x | 字符 x
\\ | 反斜线字符
\0 n | 带有八进制值 0 的字符 n (0 <= n <= 7)
\0 nn | 带有八进制值 0 的字符 nn (0 <= n <= 7)
\0 mnn | 带有八进制值 0 的字符 mnn（0 <= m <= 3、0 <= n <= 7）
\x hh | 带有十六进制值 0x 的字符 hh
\u hhhh | 带有十六进制值 0x 的字符 hhhh
\t | 制表符 ('\u0009')
\n | 新行（换行）符 ('\u000A')
\r | 回车符 ('\u000D')
\f | 换页符 ('\u000C')
\a | 报警 (bell) 符 ('\u0007')
\e | 转义符 ('\u001B')
\c x | 对应于 x 的控制符
字符类
[abc] | a、b 或 c（简单类）
[^abc] | 任何字符，除了 a、b 或 c（否定）
[a-zA-Z] | a 到 z 或 A 到 Z，两头的字母包括在内（范围）
[a-d[m-p]] | a 到 d 或 m 到 p：[a-dm-p]（并集）
[a-z&&[def]] | d、e 或 f（交集）
[a-z&&[^bc]] | a 到 z，除了 b 和 c：[ad-z]（减去）
[a-z&&[^m-p]] | a 到 z，而非 m 到 p：[a-lq-z]（减去）
预定义字符类
. | 任何字符（与行结束符可能匹配也可能不匹配）
\d | 数字：[0-9]
\D | 非数字： [^0-9]
\s | 空白字符：[ \t\n\x0B\f\r]
\S | 非空白字符：[^\s]
\w | 单词字符：[a-zA-Z_0-9]
\W | 非单词字符：[^\w]
POSIX 字符类（仅 US-ASCII）
\p{Lower} | 小写字母字符：[a-z]
\p{Upper} | 大写字母字符：[A-Z]
\p{ASCII} | 所有 ASCII：[\x00-\x7F]
\p{Alpha} | 字母字符：[\p{Lower}\p{Upper}]
\p{Digit} | 十进制数字：[0-9]
\p{Alnum} | 字母数字字符：[\p{Alpha}\p{Digit}]
\p{Punct} | 标点符号：!"#$%&'()*+,-./:;<=>?@[\]^_`{|}~
\p{Graph} | 可见字符：[\p{Alnum}\p{Punct}]
\p{Print} | 可打印字符：[\p{Graph}\x20]
\p{Blank} | 空格或制表符：[ \t]
\p{Cntrl} | 控制字符：[\x00-\x1F\x7F]
\p{XDigit} | 十六进制数字：[0-9a-fA-F]
\p{Space} | 空白字符：[ \t\n\x0B\f\r]
java.lang.Character 类（简单的 java 字符类型）
\p{javaLowerCase} | 等效于 java.lang.Character.isLowerCase()
\p{javaUpperCase} | 等效于 java.lang.Character.isUpperCase()
\p{javaWhitespace} | 等效于 java.lang.Character.isWhitespace()
\p{javaMirrored} | 等效于 java.lang.Character.isMirrored()
Unicode 块和类别的类
\p{InGreek} | Greek 块（简单块）中的字符
\p{Lu} | 大写字母（简单类别）
\p{Sc} | 货币符号
\P{InGreek} | 所有字符，Greek 块中的除外（否定）
[\p{L}&&[^\p{Lu}]] | 所有字母，大写字母除外（减去）
边界匹配器
^ | 行的开头
$ | 行的结尾
\b | 单词边界
\B | 非单词边界
\A | 输入的开头
\G | 上一个匹配的结尾
\Z | 输入的结尾，仅用于最后的结束符（如果有的话）
\z | 输入的结尾
Greedy 数量词
X? | X，一次或一次也没有
X* | X，零次或多次
X+ | X，一次或多次
X{n} | X，恰好 n 次
X{n,} | X，至少 n 次
X{n,m} | X，至少 n 次，但是不超过 m 次
Reluctant 数量词
X?? | X，一次或一次也没有
X*? | X，零次或多次
X+? | X，一次或多次
X{n}? | X，恰好 n 次
X{n,}? | X，至少 n 次
X{n,m}? | X，至少 n 次，但是不超过 m 次
Possessive 数量词
X?+ | X，一次或一次也没有
X*+ | X，零次或多次
X++ | X，一次或多次
X{n}+ | X，恰好 n 次
X{n,}+ | X，至少 n 次
X{n,m}+ | X，至少 n 次，但是不超过 m 次
Logical 运算符
XY | X 后跟 Y
X|Y | X 或 Y
(X) | X，作为捕获组
Back 引用
\n | 任何匹配的 nth 捕获组
引用
\ | Nothing，但是引用以下字符
\Q | Nothing，但是引用所有字符，直到 \E
\E | Nothing，但是结束从 \Q 开始的引用
特殊构造（非捕获）
(?:X) | X，作为非捕获组
(?idmsux-idmsux) | Nothing，但是将匹配标志i d m s u x on - off
(?idmsux-idmsux:X) | X，作为带有给定标志 i d m s u x on - off
(?=X) | X，通过零宽度的正 lookahead
(?!X) | X，通过零宽度的负 lookahead
(?<=X) | X，通过零宽度的正 lookbehind
(?<!X) | X，通过零宽度的负 lookbehind
(?>X) | X，作为独立的非捕获组

反斜线、转义和引用

反斜线字符 ('\') 用于引用转义构造，如上表所定义的，同时还用于引用其他将被解释为非转义构造的字符。因此，表达式 \\ 与单个反斜线匹配，而 \{ 与左括号匹配。

在不表示转义构造的任何字母字符前使用反斜线都是错误的；它们是为将来扩展正则表达式语言保留的。可以在非字母字符前使用反斜线，不管该字符是否非转义构造的一部分。

根据 Java Language Specification 的要求，Java 源代码的字符串中的反斜线被解释为 Unicode 转义或其他字符转义。因此必须在字符串字面值中使用两个反斜线，表示正则表达式受到保护，不被 Java 字节码编译器解释。例如，当解释为正则表达式时，字符串字面值 "\b" 与单个退格字符匹配，而 "\\b" 与单词边界匹配。字符串字面值 "\(hello\)" 是非法的，将导致编译时错误；要与字符串 (hello) 匹配，必须使用字符串字面值 "\\(hello\\)"。

字符类

字符类可以出现在其他字符类中，并且可以包含并集运算符（隐式）和交集运算符 (&&)。并集运算符表示至少包含其某个操作数类中所有字符的类。交集运算符表示包含同时位于其两个操作数类中所有字符的类。

字符类运算符的优先级如下所示，按从最高到最低的顺序排列：

1 | 字面值转义 | \x
2 分组 [...]
3 | 范围 | a-z
4 | 并集 | [a-e][i-u]
5 | 交集 | [a-z&&[aeiou]]

注意，元字符的不同集合实际上位于字符类的内部，而非字符类的外部。例如，正则表达式 . 在字符类内部就失去了其特殊意义，而表达式 - 变成了形成元字符的范围。

行结束符

行结束符 是一个或两个字符的序列，标记输入字符序列的行结尾。以下代码被识别为行结束符：

  • 新行（换行）符 ('\n')、
  • 后面紧跟新行符的回车符 ("\r\n")、
  • 单独的回车符 ('\r')、
  • 下一行字符 ('\u0085')、
  • 行分隔符 ('\u2028') 或
  • 段落分隔符 ('\u2029)。

如果激活 UNIX_LINES 模式，则新行符是唯一识别的行结束符。

如果未指定 DOTALL 标志，则正则表达式 . 可以与任何字符（行结束符除外）匹配。

默认情况下，正则表达式 ^ 和 $ 忽略行结束符，仅分别与整个输入序列的开头和结尾匹配。如果激活 MULTILINE 模式，则 ^ 在输入的开头和行结束符之后（输入的结尾）才发生匹配。处于 MULTILINE 模式中时，$ 仅在行结束符之前或输入序列的结尾处匹配。

组和捕获

捕获组可以通过从左到右计算其开括号来编号。例如，在表达式 ((A)(B(C))) 中，存在四个这样的组：

1 | ((A)(B(C)))
2 | \A
3 | (B(C))
4 | (C)

组零始终代表整个表达式。

之所以这样命名捕获组是因为在匹配中，保存了与这些组匹配的输入序列的每个子序列。捕获的子序列稍后可以通过 Back 引用在表达式中使用，也可以在匹配操作完成后从匹配器获取。

与组关联的捕获输入始终是与组最近匹配的子序列。如果由于量化的缘故再次计算了组，则在第二次计算失败时将保留其以前捕获的值（如果有的话）例如，将字符串 "aba" 与表达式 (a(b)?)+ 相匹配，会将第二组设置为 "b"。在每个匹配的开头，所有捕获的输入都会被丢弃。

以 (?) 开头的组是纯的非捕获 组，它不捕获文本，也不针对组合计进行计数。

Unicode 支持

此类符合 Unicode Technical Standard #18:Unicode Regular Expression Guidelines 第 1 级和 RL2.1 Canonical Equivalents。

Java 源代码中的 Unicode 转义序列（如 \u2014）是按照 Java Language Specification 的 第 3.3 节中的描述处理的。这样的转义序列还可以由正则表达式解析器直接实现，以便在从文件或键盘击键读取的表达式中使用 Unicode 转义。因此，可以将不相等的字符串 "\u2014" 和 "\\u2014" 编译为相同的模式，从而与带有十六进制值 0x2014 的字符匹配。

与 Perl 中一样，Unicode 块和类别是使用 \p 和 \P 构造编写的。如果输入具有属性 prop，则与 \p{prop} 匹配，而输入具有该属性时与 \P{prop} 不匹配。块使用前缀 In 指定，与在 InMongolian 中一样。可以使用可选前缀 Is 指定类别：\p{L} 和 \p{IsL} 都表示 Unicode 字母的类别。块和类别在字符类的内部和外部都可以使用。

受支持的类别是由 Character 类指定版本中的 The Unicode Standard 的类别。类别名称是在 Standard 中定义的，即标准又丰富。Pattern 所支持的块名称是 UnicodeBlock.forName 所接受和定义的有效块名称。

行为类似 java.lang.Character boolean 是 methodname 方法（废弃的类别除外）的类别，可以通过相同的 \p{prop} 语法来提供，其中指定的属性具有名称 javamethodname。

与 Perl 5 相比较

Pattern 引擎用有序替换项执行传统上基于 NFA 的匹配，与 Perl 5 中进行的相同。

此类不支持 Perl 构造：

  • 条件构造 (?{X}) 和 (?(condition)X|Y)、

  • 嵌入式代码构造 (?{code}) 和 (??{code})、

  • 嵌入式注释语法 (?#comment) 和

  • 预处理操作 \l \u、\L 和 \U。

此类支持但 Perl 不支持的构造：

  • Possessive 数量词，它可以尽可能多地进行匹配，即使这样做导致所有匹配都成功时也如此。

  • 字符类并集和交集，如上文所述。

与 Perl 的显著不同点是：

  • 在 Perl 中，\1 到 \9 始终被解释为 Back 引用；如果至少存在多个子表达式，则大于 9 的反斜线转义数按 Back 引用对待，否则在可能的情况下，它将被解释为八进制转义。在此类中，八进制转义必须始终以零开头。在此类中，\1 到 \9 始终被解释为 Back 引用，较大的数被接受为 Back 引用，如果在正则表达式中至少存在多个子表达式的话；否则，解析器将删除数字，直到该数小于等于组的现有数或者其为一个数字。

  • Perl 使用 g 标志请求恢复最后匹配丢失的匹配。此功能是由 Matcher 类显式提供的：重复执行 find 方法调用可以恢复丢失的最后匹配，除非匹配器被重置。

  • 在 Perl 中，位于表达式顶级的嵌入式标记对整个表达式都有影响。在此类中，嵌入式标志始终在它们出现的时候才起作用，不管它们位于顶级还是组中；在后一种情况下，与在 Perl 中类似，标志在组的结尾处还原。

  • Perl 允许错误匹配构造，如在表达式 *a 中，以及不匹配的括号，如在在表达式 abc] 中，并将其作为字面值对待。此类还接受不匹配的括号，但对 +、? 和 * 不匹配元字符有严格限制；如果遇到它们，则抛出 PatternSyntaxException。

有关正则表达式构造行为更准确的描述，请参见 Mastering Regular Expressions, 2nd Edition，该书由 Jeffrey E. F. Friedl、O'Reilly 和 Associates 合著，于 2002 年出版。

从以下版本开始：
1.4
另请参见：
String.split(String, int), String.split(String), 序列化表格

字段摘要
static int | CANON_EQ 启用规范等价。
static int | CASE_INSENSITIVE 启用不区分大小写的匹配。
static int | COMMENTS 模式中允许空白和注释。
static int | DOTALL 启用 dotall 模式。
static int | LITERAL 启用模式的字面值解析。
static int | MULTILINE 启用多行模式。
static int | UNICODE_CASE 启用 Unicode 感知的大小写折叠。
static int | UNIX_LINES 启用 Unix 行模式。
方法摘要
static Pattern | compile(String regex) 将给定的正则表达式编译到模式中。
static Pattern | compile(String regex, int flags) 将给定的正则表达式编译到具有给定标志的模式中。
int | flags() 返回此模式的匹配标志。
Matcher | matcher(CharSequence input) 创建匹配给定输入与此模式的匹配器。
static boolean | matches(String regex, CharSequence input) 编译给定正则表达式并尝试将给定输入与其匹配。
String | pattern() 返回在其中编译过此模式的正则表达式。
static String | quote(String s) 返回指定 String 的字面值模式 String。
String[] | split(CharSequence input) 围绕此模式的匹配拆分给定输入序列。
String[] | split(CharSequence input, int limit) 围绕此模式的匹配拆分给定输入序列。
String | toString() 返回此模式的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

UNIX_LINES

public static final int UNIX_LINES
启用 Unix 行模式。

在此模式中，.、^ 和 $ 的行为中仅识别 '\n' 行结束符。

通过嵌入式标志表达式 (?d) 也可以启用 Unix 行模式。

另请参见：
常量字段值

CASE_INSENSITIVE

public static final int CASE_INSENSITIVE
启用不区分大小写的匹配。

默认情况下，不区分大小写的匹配假定仅匹配 US-ASCII 字符集中的字符。可以通过指定 UNICODE_CASE 标志连同此标志来启用 Unicode 感知的、不区分大小写的匹配。

通过嵌入式标志表达式 (?i) 也可以启用不区分大小写的匹配。

指定此标志可能对性能产生一些影响。

另请参见：
常量字段值

COMMENTS

public static final int COMMENTS
模式中允许空白和注释。

此模式将忽略空白和在结束行之前以 # 开头的嵌入式注释。

通过嵌入式标志表达式 (?x) 也可以启用注释模式。

另请参见：
常量字段值

MULTILINE

public static final int MULTILINE
启用多行模式。

在多行模式中，表达式 ^ 和 $ 仅分别在行结束符前后匹配，或者在输入序列的结尾处匹配。默认情况下，这些表达式仅在整个输入序列的开头和结尾处匹配。

通过嵌入式标志表达式 (?m) 也可以启用多行模式。

另请参见：
常量字段值

LITERAL

public static final int LITERAL
启用模式的字面值解析。

指定此标志后，指定模式的输入字符串就会作为字面值字符序列来对待。输入序列中的元字符或转义序列不具有任何特殊意义。

标志 CASE_INSENSITIVE 和 UNICODE_CASE 在与此标志一起使用时将对匹配产生影响。其他标志都变得多余了。

不存在可以启用字面值解析的嵌入式标志字符。

从以下版本开始：
1.5
另请参见：
常量字段值

DOTALL

public static final int DOTALL
启用 dotall 模式。

在 dotall 模式中，表达式 . 可以匹配任何字符，包括行结束符。默认情况下，此表达式不匹配行结束符。

通过嵌入式标志表达式 (?s) 也可以启用 dotall 模式（s 是 "single-line" 模式的助记符，在 Perl 中也使用它）。

另请参见：
常量字段值

UNICODE_CASE

public static final int UNICODE_CASE
启用 Unicode 感知的大小写折叠。

指定此标志后，由 CASE_INSENSITIVE 标志启用时，不区分大小写的匹配将以符合 Unicode Standard 的方式完成。默认情况下，不区分大小写的匹配假定仅匹配 US-ASCII 字符集中的字符。

通过嵌入式标志表达式 (?u) 也可以启用 Unicode 感知的大小写折叠。

指定此标志可能对性能产生影响。

另请参见：
常量字段值

CANON_EQ

public static final int CANON_EQ
启用规范等价。

指定此标志后，当且仅当其完整规范分解匹配时，两个字符才可视为匹配。例如，当指定此标志时，表达式 "a\u030A" 将与字符串 "\u00E5" 匹配。默认情况下，匹配不考虑采用规范等价。

不存在可以启用规范等价的嵌入式标志字符。

指定此标志可能对性能产生影响。

另请参见：
常量字段值
方法详细信息

compile

public static Pattern compile(String regex)
将给定的正则表达式编译到模式中。

参数：
regex - 要编译的表达式
抛出：
PatternSyntaxException - 如果表达式的语法无效

compile

public static Pattern compile(String regex,
                              int flags)
将给定的正则表达式编译到具有给定标志的模式中。

参数：
regex - 要编译的表达式
flags - 匹配标志，可能包括 CASE_INSENSITIVE、MULTILINE、DOTALL、UNICODE_CASE、 CANON_EQ、UNIX_LINES、LITERAL 和 COMMENTS 的位掩码
抛出：
IllegalArgumentException - 如果在 flags 中设置与定义的匹配标志不对应的位值
PatternSyntaxException - 如果表达式的语法无效

pattern

public String pattern()
返回在其中编译过此模式的正则表达式。

返回：
模式的源代码

toString

public String toString()

返回此模式的字符串表示形式。此为在其中编译过此模式的正则表达式。

覆盖：
类 Object 中的 toString
返回：
模式的字符串表示形式
从以下版本开始：
1.5

matcher

public Matcher matcher(CharSequence input)
创建匹配给定输入与此模式的匹配器。

参数：
input - 要匹配的字符序列
返回：
此模式的新匹配器

flags

public int flags()
返回此模式的匹配标志。

返回：
编译此模式时指定的匹配标志

matches

public static boolean matches(String regex,
                              CharSequence input)
编译给定正则表达式并尝试将给定输入与其匹配。

调用此便捷方法的形式

Pattern.matches(regex, input);
与表达式
Pattern.compile(regex).matcher(input).matches()
的行为完全相同。

如果要多次使用一种模式，编译一次后重用此模式比每次都调用此方法效率更高。

参数：
regex - 要编译的表达式
input - 要匹配的字符序列
抛出：
PatternSyntaxException - 如果表达式的语法无效

split

public String[] split(CharSequence input,
                      int limit)
围绕此模式的匹配拆分给定输入序列。

此方法返回的数组包含输入序列的子字符串，由匹配此模式的另一子序列或输入序列的结尾终止。数组中子字符串的顺序与其在输入中出现的顺序相同。如果此模式与输入的任何子序列都不匹配，那么得到的数组仅包含一个元素，即字符串形式的输入序列。

limit 参数控制应用模式的次数，从而影响结果数组的长度。如果限制 n 大于零，那么模式至多应用 n> - 1 次，数组的长度不大于 n，并且数组的最后条目将包含除最后的匹配定界符之外的所有输入。如果 n 非正，那么将应用模式的次数不受限制，并且数组可以为任意长度。如果 n 为零，那么应用模式的次数不受限制，数组可以为任意长度，并且将丢弃尾部空字符串。

例如，输入 "boo:and:foo" 将产生以下结果及参数：

Regex

Limit

Result

: 2 { "boo", "and:foo" }
: 5 { "boo", "and", "foo" }
: -2 { "boo", "and", "foo" }
o | 5 | { "b", "", ":and:f", "", "" }
o | -2 | { "b", "", ":and:f", "", "" }
o | 0 | { "b", "", ":and:f" }

参数：
input - 要拆分的字符序列
limit - 结果阈值，如上文中所述
返回：
根据围绕此模式的匹配来拆分输入后所计算的字符串数组

split

public String[] split(CharSequence input)
围绕此模式的匹配拆分给定输入序列。

此方法的工作方式类似于使用给定的输入序列和限制参数零调用两参数 (java.lang.CharSequence, int) split} 方法。因此，得到的数组中不包括尾部空字符串。

例如，输入 "boo:and:foo" 将产生以下结果及表达式：

Regex

Result

: { "boo", "and", "foo" }
o { "b", "", ":and:f" }

参数：
input - 要拆分的字符序列
返回：
根据围绕此模式的匹配来拆分输入后所计算的字符串数组

quote

public static String quote(String s)
返回指定 String 的字面值模式 String。

此方法产生一个 String，可以将其用于创建与字符串 s 匹配的 Pattern，就好像它是字面值模式一样。

输入序列中的元字符和转义序列不具有任何特殊意义。

参数：
s - 要字面值化的字符串
返回：
字面值字符串替换
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PatternSyntaxException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.regex
类 PatternSyntaxException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  java.util.regex.PatternSyntaxException
所有已实现的接口：
Serializable
public class PatternSyntaxException
extends IllegalArgumentException

抛出未经检查的异常，表明正则表达式模式中的语法错误。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
PatternSyntaxException(String desc, String regex, int index)
构造此类的新实例。
方法摘要
String | getDescription() 获取错误的描述。
int | getIndex() 获取错误的索引。
String | getMessage() 返回多行字符串，包含语法错误及其索引的描述、错误的正则表达式模式和模式中错误索引的可视化指示。
String | getPattern() 获取错误的正则表达式模式。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PatternSyntaxException

public PatternSyntaxException(String desc,
                              String regex,
                              int index)
构造此类的新实例。

参数：
desc - 错误的描述
regex - 错误的模式
index - 错误模式中的近似索引；如果索引未知，则为 -1
方法详细信息

getIndex

public int getIndex()
获取错误的索引。

返回：
错误模式中的近似索引；如果索引未知，则返回 -1

getDescription

public String getDescription()
获取错误的描述。

返回：
错误的描述

getPattern

public String getPattern()
获取错误的正则表达式模式。

返回：
错误的模式

getMessage

public String getMessage()
返回多行字符串，包含语法错误及其索引的描述、错误的正则表达式模式和模式中错误索引的可视化指示。

覆盖：
类 Throwable 中的 getMessage
返回：
完整的详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.regex (Java 2 Platform SE 6)

 java.util.regex
接口
MatchResult
类
Matcher
Pattern
异常
PatternSyntaxException


java.util.regex (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.regex

用于匹配字符序列与正则表达式指定模式的类。

请参见：
描述

接口摘要
MatchResult 匹配操作的结果。

类摘要
Matcher | 通过解释 Pattern 对 character sequence 执行匹配操作的引擎。
Pattern | 正则表达式的编译表示形式。

异常摘要
PatternSyntaxException 抛出未经检查的异常，表明正则表达式模式中的语法错误。

软件包 java.util.regex 的描述

用于匹配字符序列与正则表达式指定模式的类。

Pattern 类的实例采用类似于 Perl 的语法来表示以字符串形式指定的正则表达式。

Matcher 类的实例用于匹配字符序列与给定模式。通过 CharSequence 接口将输入提供给匹配器，以支持从多种输入源到字符的匹配。

除非另行说明，将 null 参数传递给此包中任意类或接口中的方法将导致抛出 NullPointerException。

相关文档

有关正则表达式的优秀教程和概述，请参阅 Mastering Regular Expressions 一书，作者：Jeffrey E. F. Friedl、O'Reilly 和 Associates，1997 年出版。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.regex 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.regex 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.regex.Matcher (implements java.util.regex.MatchResult)
    • java.util.regex.Pattern (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • java.util.regex.PatternSyntaxException

接口分层结构

  • java.util.regex.MatchResult
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.regex 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.regex
的使用

使用 java.util.regex 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。

java.util 使用的 java.util.regex 中的类
MatchResult
匹配操作的结果。
Pattern
正则表达式的编译表示形式。

java.util.regex 使用的 java.util.regex 中的类
Matcher
通过解释 Pattern 对 character sequence 执行匹配操作的引擎。
MatchResult
匹配操作的结果。
Pattern
正则表达式的编译表示形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.regex.PatternSyntaxException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.regex.PatternSyntaxException
的使用

没有 java.util.regex.PatternSyntaxException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.regex.Matcher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.regex.Matcher
的使用

使用 Matcher 的软件包
java.util.regex 用于匹配字符序列与正则表达式指定模式的类。

java.util.regex 中 Matcher 的使用

返回 Matcher 的 java.util.regex 中的方法
Matcher | Matcher.appendReplacement(StringBuffer sb, String replacement) 实现非终端添加和替换步骤。
Matcher | Pattern.matcher(CharSequence input) 创建匹配给定输入与此模式的匹配器。
Matcher | Matcher.region(int start, int end) 设置此匹配器的区域限制。
Matcher | Matcher.reset() 重置匹配器。
Matcher | Matcher.reset(CharSequence input) 重置此具有新输入序列的匹配器。
Matcher | Matcher.useAnchoringBounds(boolean b) 设置匹配器区域界限的定位。
Matcher | Matcher.usePattern(Pattern newPattern) 更改此 Matcher 用于查找匹配项的 Pattern。
Matcher | Matcher.useTransparentBounds(boolean b) 设置此匹配器区域边界的透明度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.regex.MatchResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.regex.MatchResult
的使用

使用 MatchResult 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。

java.util 中 MatchResult 的使用

返回 MatchResult 的 java.util 中的方法
 MatchResult Scanner.match()
返回此扫描器所执行的最后扫描操作的匹配结果。

java.util.regex 中 MatchResult 的使用

实现 MatchResult 的 java.util.regex 中的类
 class Matcher
通过解释 Pattern 对 character sequence 执行匹配操作的引擎。

返回 MatchResult 的 java.util.regex 中的方法
 MatchResult Matcher.toMatchResult()
作为 MatchResult 返回此匹配器的匹配状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.regex.Pattern 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.regex.Pattern
的使用

使用 Pattern 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.regex | 用于匹配字符序列与正则表达式指定模式的类。

java.util 中 Pattern 的使用

返回 Pattern 的 java.util 中的方法
 Pattern Scanner.delimiter()
返回此 Scanner 当前正在用于匹配分隔符的 Pattern。

参数类型为 Pattern 的 java.util 中的方法
String | Scanner.findInLine(Pattern pattern) 试图在忽略分隔符的情况下查找下一个指定模式。
String | Scanner.findWithinHorizon(Pattern pattern, int horizon) 试图查找下一个指定模式。
boolean | Scanner.hasNext(Pattern pattern) 如果下一个完整标记与指定模式匹配，则返回 true。
String | Scanner.next(Pattern pattern) 如果下一个标记与指定模式匹配，则返回下一个标记。
Scanner | Scanner.skip(Pattern pattern) 在忽略分隔符的情况下跳过与指定模式匹配的输入信息。
Scanner | Scanner.useDelimiter(Pattern pattern) 将此扫描器的分隔模式设置为指定模式。

java.util.regex 中 Pattern 的使用

返回 Pattern 的 java.util.regex 中的方法
static Pattern | Pattern.compile(String regex) 将给定的正则表达式编译到模式中。
static Pattern | Pattern.compile(String regex, int flags) 将给定的正则表达式编译到具有给定标志的模式中。
Pattern | Matcher.pattern() 返回由此匹配器解释的模式。

参数类型为 Pattern 的 java.util.regex 中的方法
 Matcher Matcher.usePattern(Pattern newPattern)
更改此 Matcher 用于查找匹配项的 Pattern。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


CurrencyNameProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.spi
类 CurrencyNameProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.util.spi.CurrencyNameProvider

public abstract class CurrencyNameProvider
extends LocaleServiceProvider

为 Currency 类提供本地化货币符号的服务提供者的抽象类。注意，在确定 LocaleServiceProvider 规范中描述的行为时，货币符号被视为名称。

从以下版本开始：
1.6

构造方法摘要
protected CurrencyNameProvider()
唯一的构造方法。
方法摘要
abstract  String getSymbol(String currencyCode, Locale locale)
获取指定语言环境的给定货币代码的符号。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CurrencyNameProvider

protected CurrencyNameProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getSymbol

public abstract String getSymbol(String currencyCode,
                                 Locale locale)
获取指定语言环境的给定货币代码的符号。例如，对于 "USD"（美元），如果指定语言环境是 US，则符号是 "$"，而对于其他语言环境，则可能是 "US$"。如果无法确定符号，则应返回 null。

参数：
currencyCode - ISO 4217 货币代码，由 'A' (U+0041) 和 'Z' (U+005A) 之间的三个大写字母组成
locale - 所需的语言环境
返回：
指定语言环境的给定货币代码的符号；如果该符号对于语言环境不可用，则返回 null
抛出：
NullPointerException - 如果 currencyCode 或 locale 为 null
IllegalArgumentException - 如果 currencyCode 不是以三个大写字母的形式表示，或者 locale 不是从 getAvailableLocales() 返回的语言环境之一。
另请参见：
Currency.getSymbol(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


LocaleNameProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.spi
类 LocaleNameProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.util.spi.LocaleNameProvider

public abstract class LocaleNameProvider
extends LocaleServiceProvider

为 Locale 类提供本地化名称的服务提供者的一个抽象类。

从以下版本开始：
1.6

构造方法摘要
protected LocaleNameProvider()
唯一的构造方法。
方法摘要
abstract String | getDisplayCountry(String countryCode, Locale locale) 返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。
abstract String | getDisplayLanguage(String languageCode, Locale locale) 返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。
abstract String | getDisplayVariant(String variant, Locale locale) 返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocaleNameProvider

protected LocaleNameProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getDisplayLanguage

public abstract String getDisplayLanguage(String languageCode,
                                          Locale locale)
返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。例如，如果 languageCode 是 "fr" 并且 locale 是 en_US，则 getDisplayLanguage() 将返回 "French"；如果 languageCode 是 "en" 并且 locale 是 fr_FR，则 getDisplayLanguage() 将返回 "anglais"。如果无法根据 locale 对返回的名称进行本地化（比方说提供者没有 Croatian 的日本名称），则此方法返回 null。

参数：
languageCode - ISO 639 语言代码字符串，用 'a' (U+0061) 和 'z' (U+007A) 之间的两个小写字母表示
locale - 所需的语言环境
返回：
指定语言环境的给定语言代码的名称；如果该名称不可用，则返回 null。
抛出：
NullPointerException - 如果 languageCode 或 locale 为 null
IllegalArgumentException - 如果 languageCode 不是以两个小写字母的形式表示，或者 locale 不是从 getAvailableLocales() 返回的语言环境之一。
另请参见：
Locale.getDisplayLanguage(java.util.Locale)

getDisplayCountry

public abstract String getDisplayCountry(String countryCode,
                                         Locale locale)
返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。例如，如果 countryCode 是 "FR" 并且 locale 是 en_US，则 getDisplayCountry() 将返回 "France"；如果 countryCode 是 "US" 并且 locale 是 fr_FR，则 getDisplayCountry() 将返回 "Etats-Unis"。如果无法根据 locale 对返回的名称进行本地化（比方说提供者没有 Croatia 的日本名称），则此方法返回 null。

参数：
countryCode - ISO 3166 国家代码字符串，用 'A' (U+0041) 和 'Z' (U+005A) 之间的两个大写字母表示
locale - 所需的语言环境
返回：
指定语言环境的给定国家代码的名称；如果该名称不可用，则返回 null。
抛出：
NullPointerException - 如果 countryCode 或 locale 为 null
IllegalArgumentException - 如果 countryCode 不是以两个大写字母的形式表示，或者 locale 不是从 getAvailableLocales() 返回的语言环境之一。
另请参见：
Locale.getDisplayCountry(java.util.Locale)

getDisplayVariant

public abstract String getDisplayVariant(String variant,
                                         Locale locale)
返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。如果无法根据 locale 对返回的名称进行本地化，则此方法返回 null。

参数：
variant - 变量字符串
locale - 所需的语言环境
返回：
指定语言环境的给定变量字符串的名称，如果该名称不可用，则返回 null。
抛出：
NullPointerException - 如果 variant 或 locale 为 null
IllegalArgumentException - 如果 locale 不是从 getAvailableLocales() 返回的语言环境之一。
另请参见：
Locale.getDisplayVariant(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LocaleServiceProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.spi
类 LocaleServiceProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
直接已知子类：
BreakIteratorProvider, CollatorProvider, CurrencyNameProvider, DateFormatProvider, DateFormatSymbolsProvider, DecimalFormatSymbolsProvider, LocaleNameProvider, NumberFormatProvider, TimeZoneNameProvider
public abstract class LocaleServiceProvider
extends Object

此类是所有与语言环境有关的服务提供者接口（SPI）的超类。

与语言环境有关的服务提供者接口是与 java.text 和 java.util 包中与语言环境有关的类相对应的接口。利用这些接口，可以构造与语言环境有关的对象，可以获取这些包的本地名称。对于 Java 运行时环境本身支持的语言环境集以外的语言环境，java.text 和 java.util 包中与语言环境有关的工厂方法以及获取名称的方法使用提供者接口的实现来提供支持。

打包与语言环境有关的服务提供者实现

使用 Java 扩展机制将这些与语言环境有关的服务的实现作为已安装的扩展打包。提供者使用资源目录 META-INF/services 中的提供者配置文件标识本身，使用完全限定的提供者接口类名称作为文件名。该文件应该包含一个完全限定的具体提供者类名称列表，每行一个。通过下列字符之一表示某行已终止：换行 ('\n')、回车 ('\r')或回车后紧跟换行。忽略各名称周围的空格、制表符和空行。注释字符是 '#' ('#')；每行的第一个注释字符后面的所有字符都被忽略。文件必须使用 UTF-8 编码。

如果在多个配置文件中指定了一个特定的具体提供者类，或在同一配置文件中多次被指定，则忽略重复的指定。指定特定提供者的配置文件不必像提供者本身一样位于同一个 jar 文件或其他的分布式单元中。提供者必须可从最初为了定位配置文件而查询的类加载器访问，而不一定是加载文件的类加载器。

例如，DateFormatProvider 类的实现应该采用包含以下文件的 jar 文件的形式：

META-INF/services/java.text.spi.DateFormatProvider
文件 java.text.spi.DateFormatProvider 应该具有如下的行：
com.foo.DateFormatProviderImpl
这是实现 DateFormatProvider 的类的完全限定类名称。

调用与语言环境有关的服务

在需要支持请求的语言环境时，java.text 和 java.util 包中与语言环境有关的工厂方法和获取名称的方法调用服务提供者方法。这些方法先检查 Java 运行时环境本身是否支持请求的语言环境，如果是则使用它来支持。否则，这些方法对适当接口调用已安装提供者的 getAvailableLocales() 方法，以查找支持所请求语言环境的提供者。如果找到了这种提供者，则调用它的其他方法获取请求的对象或名称。如果 Java 运行时环境本身和已安装的提供者都不支持所请求的语言环境，那么使用空字符串替换语言环境的第一个非空的变量、国家/地区或语言字符串，以此构造一个回退语言环境，然后重新启动查找进程。如果变量包含一个或多个 '_'，则使用取消最后一个 '_' 及其后面部分的新变量替换该变量，以此构造一个回退语言环境。即使发生回退，返回所请求对象或名称的方法仍然使用回退之前的原语言环境进行调用。为了保证此进程能够终止，Java 运行时环境必须支持所有与语言环境有关的服务的根语言环境。

允许名称提供者（但不是其他对象提供者）对某些名称请求，甚至对它们声称支持的语言环境（将其包括在 getAvailableLocales 的返回值中）环境返回 null。类似地，Java 运行时环境本身可能没有它所支持的所有语言环境的所有名称。这是因为其名称被请求的对象集可能很大，并可能随时变化，所以并非总是可以完全包括它们。如果 Java 运行时环境或提供者返回 null 而非名称，那么将按上述过程执行查找，就像该语言环境不受支持一样。

从以下版本开始：
1.6

构造方法摘要
protected LocaleServiceProvider()
唯一的构造方法。
方法摘要
abstract  Locale[] getAvailableLocales()
返回一个数组，它包含此语言环境服务提供者可以为其提供本地化对象或名称的所有语言环境。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LocaleServiceProvider

protected LocaleServiceProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getAvailableLocales

public abstract Locale[] getAvailableLocales()
返回一个数组，它包含此语言环境服务提供者可以为其提供本地化对象或名称的所有语言环境。

返回：
一个数组，它包含此语言环境服务提供者可以为其提供本地化对象或名称的所有语言环境。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimeZoneNameProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.spi
类 TimeZoneNameProvider

java.lang.Object
    继承者  java.util.spi.LocaleServiceProvider
        继承者  java.util.spi.TimeZoneNameProvider

public abstract class TimeZoneNameProvider
extends LocaleServiceProvider

为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。从此类的实现获得的本地化时区名称也是 DateFormatSymbols.getZoneStrings() 方法的源。

从以下版本开始：
1.6

构造方法摘要
protected TimeZoneNameProvider()
唯一的构造方法。
方法摘要
abstract  String getDisplayName(String ID, boolean daylight, int style, Locale locale)
返回适于展示给指定语言环境用户的给定时区 ID 名称。
从类 java.util.spi.LocaleServiceProvider 继承的方法
getAvailableLocales
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TimeZoneNameProvider

protected TimeZoneNameProvider()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getDisplayName

public abstract String getDisplayName(String ID,
                                      boolean daylight,
                                      int style,
                                      Locale locale)
返回适于展示给指定语言环境用户的给定时区 ID 名称。给定时区 ID 是 "GMT" 或使用“tz 数据库”中的 "Zone" 条目定义的名称之一，“tz 数据库”是一个公共域时区数据库，可从 ftp://elsie.nci.nih.gov/pub/ 获取。此数据库的数据包含在名称以 "tzdata" 开头的文件中，数据格式规范是 zic.8 手册页的一部分，它包含在名称以 "tzcode" 开头的文件中。

如果 daylight 为 true，该方法应返回适合夏令时的名称，即使指定的时区过去没有观测到夏令时。

参数：
ID - 时区 ID 字符串
daylight - 如果为 true，则返回夏令时名称。
style - TimeZone.LONG 或 TimeZone.SHORT
locale - 所需的语言环境
返回：
给定语言环境中给定时区的可读名称；如果不可用，则返回 null。
抛出：
IllegalArgumentException - 如果 style 无效，或者 locale 不是从 getAvailableLocales() 返回的语言环境之一。
NullPointerException - 如果 ID 或 locale 为 null
另请参见：
TimeZone.getDisplayName(boolean, int, java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.spi (Java 2 Platform SE 6)

 java.util.spi
类
CurrencyNameProvider
LocaleNameProvider
LocaleServiceProvider
TimeZoneNameProvider


java.util.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.spi

java.util 包中类的服务提供者类。

请参见：
描述

类摘要
CurrencyNameProvider | 为 Currency 类提供本地化货币符号的服务提供者的抽象类。
LocaleNameProvider | 为 Locale 类提供本地化名称的服务提供者的一个抽象类。
LocaleServiceProvider | 此类是所有与语言环境有关的服务提供者接口（SPI）的超类。
TimeZoneNameProvider | 为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。

软件包 java.util.spi 的描述

java.util 包中类的服务提供者类。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.spi.LocaleServiceProvider
      • java.util.spi.CurrencyNameProvider
      • java.util.spi.LocaleNameProvider
      • java.util.spi.TimeZoneNameProvider
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.spi
的使用

使用 java.util.spi 的软件包
java.text.spi | java.text 包中类的服务提供者类。
java.util.spi | java.util 包中类的服务提供者类。

java.text.spi 使用的 java.util.spi 中的类
LocaleServiceProvider
此类是所有与语言环境有关的服务提供者接口（SPI）的超类。

java.util.spi 使用的 java.util.spi 中的类
LocaleServiceProvider
此类是所有与语言环境有关的服务提供者接口（SPI）的超类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.spi.LocaleNameProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.LocaleNameProvider
的使用

没有 java.util.spi.LocaleNameProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.spi.CurrencyNameProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.CurrencyNameProvider
的使用

没有 java.util.spi.CurrencyNameProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.spi.TimeZoneNameProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.TimeZoneNameProvider
的使用

没有 java.util.spi.TimeZoneNameProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.spi.LocaleServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.spi.LocaleServiceProvider
的使用

使用 LocaleServiceProvider 的软件包
java.text.spi | java.text 包中类的服务提供者类。
java.util.spi | java.util 包中类的服务提供者类。

java.text.spi 中 LocaleServiceProvider 的使用

java.text.spi 中 LocaleServiceProvider 的子类
class | BreakIteratorProvider 提供 BreakIterator 类具体实现的服务提供者的抽象类。
class | CollatorProvider 提供 Collator 类具体实现的服务提供者的抽象类。
class | DateFormatProvider 提供 DateFormat 类具体实现的服务提供者的抽象类。
class | DateFormatSymbolsProvider 提供 DateFormatSymbols 类实例的服务提供者的抽象类。
class | DecimalFormatSymbolsProvider 提供 DecimalFormatSymbols 类实例的服务提供者的抽象类。
class | NumberFormatProvider 提供 NumberFormat 类具体实现的服务提供者的抽象类。

java.util.spi 中 LocaleServiceProvider 的使用

java.util.spi 中 LocaleServiceProvider 的子类
class | CurrencyNameProvider 为 Currency 类提供本地化货币符号的服务提供者的抽象类。
class | LocaleNameProvider 为 Locale 类提供本地化名称的服务提供者的一个抽象类。
class | TimeZoneNameProvider 为 TimeZone 类提供本地化时区名称的服务提供者的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Adler32 (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 Adler32

java.lang.Object
    继承者  java.util.zip.Adler32
所有已实现的接口：
Checksum
public class Adler32
extends Object
implements Checksum

可用于计算数据流的 Adler-32 校验和的类。Adler-32 校验和几乎与 CRC-32 一样可靠，但是能够更快地计算出来。

另请参见：
Checksum

构造方法摘要
Adler32()
创建新的 Adler32 对象。
方法摘要
long | getValue() 返回校验和值。
void | reset() 将校验和重置为初始值。
void | update(byte[] b) 使用指定的字节数组更新校验和。
void | update(byte[] b, int off, int len) 使用指定的字节数组更新校验和。
void | update(int b) 使用指定字节更新校验和。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Adler32

public Adler32()
创建新的 Adler32 对象。

方法详细信息

update

public void update(int b)
使用指定字节更新校验和。

指定者：
接口 Checksum 中的 update
参数：
b - 字节数组

update

public void update(byte[] b,
                   int off,
                   int len)
使用指定的字节数组更新校验和。

指定者：
接口 Checksum 中的 update
参数：
b - 更新校验和要使用的字节数组
off - 数据的初始偏移量
len - 用于更新的字节数

update

public void update(byte[] b)
使用指定的字节数组更新校验和。

reset

public void reset()
将校验和重置为初始值。

指定者：
接口 Checksum 中的 reset

getValue

public long getValue()
返回校验和值。

指定者：
接口 Checksum 中的 getValue
返回：
当前的校验和值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CheckedInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 CheckedInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.util.zip.CheckedInputStream
所有已实现的接口：
Closeable
public class CheckedInputStream
extends FilterInputStream

需要维护所读取数据校验和的输入流。校验和可用于验证输入数据的完整性。

另请参见：
Checksum

字段摘要
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
CheckedInputStream(InputStream in, Checksum cksum)
使用指定校验和创建输入流。
方法摘要
Checksum | getChecksum() 返回此输入流的校验和。
int | read() 读取字节。
int | read(byte[] buf, int off, int len) 读入字节数组。
long | skip(long n) 跳过指定的输入字节数。
从类 java.io.FilterInputStream 继承的方法
available, close, mark, markSupported, read, reset
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CheckedInputStream

public CheckedInputStream(InputStream in,
                          Checksum cksum)
使用指定校验和创建输入流。

参数：
in - 输入流
cksum - 校验和
方法详细信息

read

public int read()
         throws IOException
读取字节。如果不存在可用的输入，将发生阻塞。

覆盖：
类 FilterInputStream 中的 read
返回：
读取的字节；如果已到达流的结尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in

read

public int read(byte[] buf,
                int off,
                int len)
         throws IOException
读入字节数组。如果 len 不为零，则在某些输入可用之前，此方法将发生阻塞；否则不读取字节并且返回 0。

覆盖：
类 FilterInputStream 中的 read
参数：
buf - 将数据读入的缓冲区
off - 目标数组 b 中的初始偏移量
len - 读取字节的最大数
返回：
读取字节的实际数；如果已到达流的结尾，则返回 -1。
抛出：
NullPointerException - 如果 buf 为 null。
IndexOutOfBoundsException - 如果 off 为负，或者 len 为负或 len 大于 buf.length - off
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in

skip

public long skip(long n)
          throws IOException
跳过指定的输入字节数。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数
返回：
已跳过的实际字节数
抛出：
IOException - 如果发生 I/O 错误

getChecksum

public Checksum getChecksum()
返回此输入流的校验和。

返回：
校验和值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CheckedOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 CheckedOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.util.zip.CheckedOutputStream
所有已实现的接口：
Closeable, Flushable
public class CheckedOutputStream
extends FilterOutputStream

需要维护写入数据校验和的输出流。校验和可用于验证输出数据的完整性。

另请参见：
Checksum

字段摘要
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
CheckedOutputStream(OutputStream out, Checksum cksum)
使用指定校验和创建输出流。
方法摘要
Checksum | getChecksum() 返回此输出流的校验和。
void | write(byte[] b, int off, int len) 写入字节数组。
void | write(int b) 写入字节。
从类 java.io.FilterOutputStream 继承的方法
close, flush, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CheckedOutputStream

public CheckedOutputStream(OutputStream out,
                           Checksum cksum)
使用指定校验和创建输出流。

参数：
out - 输出流
cksum - 校验和
方法详细信息

write

public void write(int b)
           throws IOException
写入字节。在实际写入字节前将处于阻塞状态。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要写入的字节
抛出：
IOException - 如果发生 I/O 错误

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
写入字节数组。在实际写入字节前将处于阻塞状态。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要写入的数据
off - 数据的初始偏移量
len - 要写入的字节数
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterOutputStream.write(int)

getChecksum

public Checksum getChecksum()
返回此输出流的校验和。

返回：
校验和
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Checksum (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
接口 Checksum

所有已知实现类：
Adler32, CRC32
public interface Checksum

表示数据校验和的接口。

方法摘要
long | getValue() 返回当前的校验和值。
void | reset() 将校验和重置为其初始值。
void | update(byte[] b, int off, int len) 使用指定的字节数组更新当前校验和。
void | update(int b) 使用指定字节更新当前校验和。

方法详细信息

update

void update(int b)
使用指定字节更新当前校验和。

参数：
b - 更新校验和要使用的字节

update

void update(byte[] b,
            int off,
            int len)
使用指定的字节数组更新当前校验和。

参数：
b - 更新校验和要使用的字节数组
off - 数据的初始偏移量
len - 用于更新的字节数

getValue

long getValue()
返回当前的校验和值。

返回：
当前的校验和值

reset

void reset()
将校验和重置为其初始值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CRC32 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 CRC32

java.lang.Object
    继承者  java.util.zip.CRC32
所有已实现的接口：
Checksum
public class CRC32
extends Object
implements Checksum

可用于计算数据流的 CRC-32 的类。

另请参见：
Checksum

构造方法摘要
CRC32()
创建新的 CRC32 对象。
方法摘要
long | getValue() 返回 CRC-32 值。
void | reset() 将 CRC-32 重置为初始值。
void | update(byte[] b) 使用指定的字节数组更新校验和。
void | update(byte[] b, int off, int len) 使用指定的字节数组更新 CRC-32。
void | update(int b) 使用指定字节更新 CRC-32。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CRC32

public CRC32()
创建新的 CRC32 对象。

方法详细信息

update

public void update(int b)
使用指定字节更新 CRC-32。

指定者：
接口 Checksum 中的 update
参数：
b - 更新校验和要使用的字节

update

public void update(byte[] b,
                   int off,
                   int len)
使用指定的字节数组更新 CRC-32。

指定者：
接口 Checksum 中的 update
参数：
b - 更新校验和要使用的字节数组
off - 数据的初始偏移量
len - 用于更新的字节数

update

public void update(byte[] b)
使用指定的字节数组更新校验和。

参数：
b - 更新校验和使用的字节数组

reset

public void reset()
将 CRC-32 重置为初始值。

指定者：
接口 Checksum 中的 reset

getValue

public long getValue()
返回 CRC-32 值。

指定者：
接口 Checksum 中的 getValue
返回：
当前的校验和值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataFormatException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 DataFormatException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.util.zip.DataFormatException
所有已实现的接口：
Serializable
public class DataFormatException
extends Exception

当数据格式发生错误时，抛出此异常。

另请参见：
序列化表格

构造方法摘要
DataFormatException()
构造不带详细消息的 DataFormatException。
DataFormatException(String s)
构造带指定详细消息的 DataFormatException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DataFormatException

public DataFormatException()
构造不带详细消息的 DataFormatException。

DataFormatException

public DataFormatException(String s)
构造带指定详细消息的 DataFormatException。详细消息是描述这个特定异常的字符串。

参数：
s - 包含详细消息的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Deflater (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 Deflater

java.lang.Object
    继承者  java.util.zip.Deflater

public class Deflater
extends Object

此类使用流行的 ZLIB 压缩程序库为通用压缩提供支持。ZLIB 压缩程序库最初是作为 PNG 图形标准的一部分开发的，不受专利的保护。有关该规范的完整描述，请参见 java.util.zip 包描述。

以下代码片段演示使用 Deflater 和 Inflater 压缩和解压缩字符串的详细过程。

 try {
 // Encode a String into bytes
 String inputString = "blahblahblah??";
 byte[] input = inputString.getBytes("UTF-8");

 // Compress the bytes
 byte[] output = new byte[100];
 Deflater compresser = new Deflater();
 compresser.setInput(input);
 compresser.finish();
 int compressedDataLength = compresser.deflate(output);

 // Decompress the bytes
 Inflater decompresser = new Inflater();
 decompresser.setInput(output, 0, compressedDataLength);
 byte[] result = new byte[100];
 int resultLength = decompresser.inflate(result);
 decompresser.end();

 // Decode the bytes into a String
 String outputString = new String(result, 0, resultLength, "UTF-8");
 } catch(java.io.UnsupportedEncodingException ex) {
     // handle
 } catch (java.util.zip.DataFormatException ex) {
     // handle
 }

另请参见：
Inflater

字段摘要
static int | BEST_COMPRESSION 最佳压缩的压缩级别。
static int | BEST_SPEED 最快压缩的压缩级别。
static int | DEFAULT_COMPRESSION 默认压缩级别。
static int | DEFAULT_STRATEGY 默认压缩策略。
static int | DEFLATED deflate 算法（当前支持的唯一算法）的压缩方法。
static int | FILTERED 最适用于主要由小值组成并具有某种程度随意分布的数据的压缩策略。
static int | HUFFMAN_ONLY 仅适用于 Huffman 编码的压缩策略。
static int | NO_COMPRESSION 无压缩的压缩级别。
构造方法摘要
Deflater()
使用默认压缩级别创建新的压缩器。
Deflater(int level)
使用指定压缩级别创建新的压缩器。
Deflater(int level, boolean nowrap)
使用指定压缩级别创建新的压缩器。
方法摘要
 int deflate(byte[] b)
使用压缩数据填充指定缓冲区。
 int deflate(byte[] b, int off, int len)
使用压缩数据填充指定缓冲区。
 void end()
关闭解压缩器并放弃所有未处理的输入。
protected  void finalize()
回收垃圾时关闭压缩器。
 void finish()
调用时，指示压缩应当以输入缓冲区的当前内容结尾。
 boolean finished()
如果已到达压缩数据输出流的结尾，则返回 true。
 int getAdler()
返回未压缩数据的 ADLER-32 值。
 long getBytesRead()
返回到目前为止输入未压缩字节的总数。
 long getBytesWritten()
返回到目前为止输出压缩字节的总数。
 int getTotalIn()
返回到目前为止输入未压缩字节的总数。
 int getTotalOut()
返回到目前为止输出压缩字节的总数。
 boolean needsInput()
如果输入数据缓冲区为空，并且应调用 setInput() 以提供更多输入，则返回 true。
 void reset()
重置 deflater 以处理新的输入数据集。
 void setDictionary(byte[] b)
为压缩预置字典。
 void setDictionary(byte[] b, int off, int len)
为压缩设置预置字典。
 void setInput(byte[] b)
为压缩设置输入数据。
 void setInput(byte[] b, int off, int len)
为压缩设置输入数据。
 void setLevel(int level)
将当前压缩级别设置为指定值。
 void setStrategy(int strategy)
将压缩策略设置为指定值。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFLATED

public static final int DEFLATED
deflate 算法（当前支持的唯一算法）的压缩方法。

另请参见：
常量字段值

NO_COMPRESSION

public static final int NO_COMPRESSION
无压缩的压缩级别。

另请参见：
常量字段值

BEST_SPEED

public static final int BEST_SPEED
最快压缩的压缩级别。

另请参见：
常量字段值

BEST_COMPRESSION

public static final int BEST_COMPRESSION
最佳压缩的压缩级别。

另请参见：
常量字段值

DEFAULT_COMPRESSION

public static final int DEFAULT_COMPRESSION
默认压缩级别。

另请参见：
常量字段值

FILTERED

public static final int FILTERED
最适用于主要由小值组成并具有某种程度随意分布的数据的压缩策略。强制使用较多的 Huffman 编码和较少的字符串匹配。

另请参见：
常量字段值

HUFFMAN_ONLY

public static final int HUFFMAN_ONLY
仅适用于 Huffman 编码的压缩策略。

另请参见：
常量字段值

DEFAULT_STRATEGY

public static final int DEFAULT_STRATEGY
默认压缩策略。

另请参见：
常量字段值
构造方法详细信息

Deflater

public Deflater(int level,
                boolean nowrap)
使用指定压缩级别创建新的压缩器。如果 'nowrap' 为 true，则不使用 ZLIB 头和校验和字段，以便支持在 GZIP 和 PKZIP 中使用的压缩格式。

参数：
level - 压缩级别 (0-9)
nowrap - 如果为 true ，则使用 GZIP 兼容的压缩

Deflater

public Deflater(int level)
使用指定压缩级别创建新的压缩器。压缩的数据将以 ZLIB 格式生成。

参数：
level - 压缩级别 (0-9)

Deflater

public Deflater()
使用默认压缩级别创建新的压缩器。压缩的数据将以 ZLIB 格式生成。

方法详细信息

setInput

public void setInput(byte[] b,
                     int off,
                     int len)
为压缩设置输入数据。此方法应该在 needsInput() 返回 true 时调用，以指示需要更多的输入数据。

参数：
b - 输入数据字节
off - 数据的初始偏移量
len - 数据的长度
另请参见：
needsInput()

setInput

public void setInput(byte[] b)
为压缩设置输入数据。此方法应该在 needsInput() 返回 true 时调用，以指示需要更多的输入数据。

参数：
b - 输入数据字节
另请参见：
needsInput()

setDictionary

public void setDictionary(byte[] b,
                          int off,
                          int len)
为压缩设置预置字典。预置字典在历史缓冲区可预定时使用。当以后使用 Inflater.inflate() 取消压缩数据时，可以调用 Inflater.getAdler() 来获取解压缩所需字典的 Adler-32 值。

参数：
b - 字典数据字节
off - 数据的初始偏移量
len - 数据的长度
另请参见：
Inflater.inflate(byte[], int, int), Inflater.getAdler()

setDictionary

public void setDictionary(byte[] b)
为压缩预置字典。预置字典在历史缓冲区可预定时使用。当以后使用 Inflater.inflate() 取消压缩数据时，可以调用 Inflater.getAdler() 来获取解压缩所需字典的 Adler-32 值。

参数：
b - 字典数据字节
另请参见：
Inflater.inflate(byte[], int, int), Inflater.getAdler()

setStrategy

public void setStrategy(int strategy)
将压缩策略设置为指定值。

参数：
strategy - 新的压缩策略
抛出：
IllegalArgumentException - 如果压缩策略无效

setLevel

public void setLevel(int level)
将当前压缩级别设置为指定值。

参数：
level - 新的压缩级别 (0-9)
抛出：
IllegalArgumentException - 如果压缩级别无效

needsInput

public boolean needsInput()
如果输入数据缓冲区为空，并且应调用 setInput() 以提供更多输入，则返回 true。

返回：
如果输入数据缓冲区为空，并且应调用 setInput() 以提供更多输入，则返回 true

finish

public void finish()
调用时，指示压缩应当以输入缓冲区的当前内容结尾。

finished

public boolean finished()
如果已到达压缩数据输出流的结尾，则返回 true。

返回：
如果已到达压缩数据输出流的结尾，则返回 true

deflate

public int deflate(byte[] b,
                   int off,
                   int len)
使用压缩数据填充指定缓冲区。返回压缩数据的实际字节数。返回值为 0 指示应调用 needsInput() 来确定是否需要更多的输入数据。

参数：
b - 压缩数据的缓冲区
off - 数据的初始偏移量
len - 压缩数据的最大字节数
返回：
压缩数据的实际字节数

deflate

public int deflate(byte[] b)
使用压缩数据填充指定缓冲区。返回压缩数据的实际字节数。返回值为 0 指示应调用 needsInput() 来确定是否需要更多的输入数据。

参数：
b - 压缩数据的缓冲区
返回：
压缩数据的实际字节数

getAdler

public int getAdler()
返回未压缩数据的 ADLER-32 值。

返回：
未压缩数据的 ADLER-32 值

getTotalIn

public int getTotalIn()
返回到目前为止输入未压缩字节的总数。

由于该字节数可能大于 Integer.MAX_VALUE，因此 getBytesRead() 方法现在是获取此信息的首选方法。

返回：
到目前为止输入未压缩字节的总数

getBytesRead

public long getBytesRead()
返回到目前为止输入未压缩字节的总数。

返回：
到目前为止输入未压缩字节的总数（非负）
从以下版本开始：
1.5

getTotalOut

public int getTotalOut()
返回到目前为止输出压缩字节的总数。

由于该字节数可能大于 Integer.MAX_VALUE，因此 getBytesWritten() 方法现在是获取此信息的首选方法。

返回：
到目前为止输出压缩字节的总数

getBytesWritten

public long getBytesWritten()
返回到目前为止输出压缩字节的总数。

返回：
到目前为止输出压缩字节的总数（非负）
从以下版本开始：
1.5

reset

public void reset()
重置 deflater 以处理新的输入数据集。保持当前压缩级别和策略设置。

end

public void end()
关闭解压缩器并放弃所有未处理的输入。此方法应该在不再使用该压缩器时调用，但是也可以由 finalize() 方法自动调用。调用此方法后，Deflater 对象的行为将是不确定的。

finalize

protected void finalize()
回收垃圾时关闭压缩器。

覆盖：
类 Object 中的 finalize
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DeflaterInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 DeflaterInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.util.zip.DeflaterInputStream
所有已实现的接口：
Closeable
public class DeflaterInputStream
extends FilterInputStream

为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。

从以下版本开始：
1.6
另请参见：
DeflaterOutputStream, InflaterOutputStream, InflaterInputStream

字段摘要
protected byte[] | buf 读取压缩数据的输入缓冲区。
protected Deflater | def 此流的压缩器。
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
DeflaterInputStream(InputStream in)
创建一个带有默认压缩器和缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl)
创建一个带有指定压缩器和默认缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl, int bufLen)
创建一个带有指定压缩器和缓冲区大小的新输入流。
方法摘要
 int available()
在到达 EOF 后返回 0；否则始终返回 1。
 void close()
关闭此输入流和它的底层输入流，丢弃挂起的未压缩数据。
 void mark(int limit)
不支持此操作。
 boolean markSupported()
始终返回 false，因为此输入流不支持 mark() 和 reset() 方法。
 int read()
从输入流读取一个压缩数据的单个字节。
 int read(byte[] b, int off, int len)
将压缩数据读入 byte 数组。
 void reset()
不支持此操作。
 long skip(long n)
从输入流中跳过并丢弃数据。
从类 java.io.FilterInputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

def

protected final Deflater def
此流的压缩器。

buf

protected final byte[] buf
读取压缩数据的输入缓冲区。

构造方法详细信息

DeflaterInputStream

public DeflaterInputStream(InputStream in)
创建一个带有默认压缩器和缓冲区大小的新输入流。

参数：
in - 要读入未压缩数据的输入流
抛出：
NullPointerException - 如果 in 为 null

DeflaterInputStream

public DeflaterInputStream(InputStream in,
                           Deflater defl)
创建一个带有指定压缩器和默认缓冲区大小的新输入流。

参数：
in - 要读入未压缩数据的输入流
defl - 此流的压缩器 ("deflater")
抛出：
NullPointerException - 如果 in 或 defl 为 null

DeflaterInputStream

public DeflaterInputStream(InputStream in,
                           Deflater defl,
                           int bufLen)
创建一个带有指定压缩器和缓冲区大小的新输入流。

参数：
in - 要读入未压缩数据的输入流
defl - 此流的压缩器 ("deflater")
bufLen - 压缩缓冲区大小
抛出：
IllegalArgumentException - 如果 bufLen <= 0
NullPointerException - 如果 in 或 defl 为 null
方法详细信息

close

public void close()
           throws IOException
关闭此输入流和它的底层输入流，丢弃挂起的未压缩数据。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in

read

public int read()
         throws IOException
从输入流读取一个压缩数据的单个字节。在可以读取和压缩某些输入之前，此方法可能发生阻塞。

覆盖：
类 FilterInputStream 中的 read
返回：
压缩数据的单个字节；如果已到达未压缩输入流的末尾，则返回 -1
抛出：
IOException - 如果发生 I/O 错误或如果此流已经关闭
另请参见：
FilterInputStream.in

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
将压缩数据读入 byte 数组。在可以读取和压缩某些输入之前，此方法可能发生阻塞。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 要读入数据的缓冲区
off - b 中数据的起始偏移量
len - 要读入 b 的最大压缩字节数
返回：
读取的实际字节数；如果已到达未压缩输入流的末尾，则返回 -1
抛出：
IndexOutOfBoundsException - 如果 len > b.length - off
IOException - 如果发生 I/O 错误或者此输入流已经关闭
另请参见：
FilterInputStream.in

skip

public long skip(long n)
          throws IOException
从输入流中跳过并丢弃数据。在读取和跳过指定数量的字节前，此方法将阻塞。注： 当将 n 作为 long 给出时，可以跳过的最大字节数为 Integer.MAX_VALUE。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数
返回：
已跳过的实际字节数
抛出：
IOException - 如果发生 I/O 错误或者此流已经关闭

available

public int available()
              throws IOException
在到达 EOF 后返回 0；否则始终返回 1。

程序不应依靠此方法返回可以不受阻塞地读取的实际字节数。

覆盖：
类 FilterInputStream 中的 available
返回：
到达底层输入流的末尾之后返回 0；否则始终返回 1
抛出：
IOException - 如果发生 I/O 错误或者此流已经关闭

markSupported

public boolean markSupported()
始终返回 false，因为此输入流不支持 mark() 和 reset() 方法。

覆盖：
类 FilterInputStream 中的 markSupported
返回：
始终返回 false
另请参见：
FilterInputStream.in, InputStream.mark(int), InputStream.reset()

mark

public void mark(int limit)
不支持此操作。

覆盖：
类 FilterInputStream 中的 mark
参数：
limit - 在位置标记无效前可以读取的最大字节数
另请参见：
FilterInputStream.in, FilterInputStream.reset()

reset

public void reset()
           throws IOException
不支持此操作。

覆盖：
类 FilterInputStream 中的 reset
抛出：
IOException - 始终抛出
另请参见：
FilterInputStream.in, FilterInputStream.mark(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DeflaterOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 DeflaterOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.util.zip.DeflaterOutputStream
所有已实现的接口：
Closeable, Flushable
直接已知子类：
GZIPOutputStream, ZipOutputStream
public class DeflaterOutputStream
extends FilterOutputStream

此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。它还用作其他类型的压缩过滤器（如 GZIPOutputStream）的基础。

另请参见：
Deflater

字段摘要
protected byte[] | buf 写入压缩数据的输出缓冲区。
protected Deflater | def 此流的压缩器。
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
DeflaterOutputStream(OutputStream out)
使用默认压缩器和缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def)
使用指定压缩器和默认缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def, int size)
使用指定压缩器和缓冲区大小创建一个新输出流。
方法摘要
void | close() 将剩余压缩数据写入输出流并关闭底层流。
protected void | deflate() 将下一个压缩数据块写入输出流。
void | finish() 完成将压缩数据写入输出流的操作，无需关闭底层流。
void | write(byte[] b, int off, int len) 将字节数组写入压缩的输出流。
void | write(int b) 将字节写入压缩的输出流。
从类 java.io.FilterOutputStream 继承的方法
flush, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

def

protected Deflater def
此流的压缩器。

buf

protected byte[] buf
写入压缩数据的输出缓冲区。

构造方法详细信息

DeflaterOutputStream

public DeflaterOutputStream(OutputStream out,
                            Deflater def,
                            int size)
使用指定压缩器和缓冲区大小创建一个新输出流。

参数：
out - 输出流
def - 压缩器 ("deflater")
size - 输出缓冲区大小
抛出：
IllegalArgumentException - 如果大小为 <= 0

DeflaterOutputStream

public DeflaterOutputStream(OutputStream out,
                            Deflater def)
使用指定压缩器和默认缓冲区大小创建一个新输出流。

参数：
out - 输出流
def - 压缩器 ("deflater")

DeflaterOutputStream

public DeflaterOutputStream(OutputStream out)
使用默认压缩器和缓冲区大小创建一个新输出流。

参数：
out - 输出流
方法详细信息

write

public void write(int b)
           throws IOException
将字节写入压缩的输出流。在可写入字节前，此方法将阻塞。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要写入的字节
抛出：
IOException - 如果发生 I/O 错误

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将字节数组写入压缩的输出流。在写入所有字节前，此方法将阻塞。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 要写入的数据
off - 数据的初始偏移量
len - 数据的长度
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterOutputStream.write(int)

finish

public void finish()
            throws IOException
完成将压缩数据写入输出流的操作，无需关闭底层流。对同一输出流相继应用多个过滤器时使用此方法。

抛出：
IOException - 如果发生 I/O 错误

close

public void close()
           throws IOException
将剩余压缩数据写入输出流并关闭底层流。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterOutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterOutputStream.flush(), FilterOutputStream.out

deflate

protected void deflate()
                throws IOException
将下一个压缩数据块写入输出流。

抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GZIPInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 GZIPInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.util.zip.InflaterInputStream
                继承者  java.util.zip.GZIPInputStream
所有已实现的接口：
Closeable
public class GZIPInputStream
extends InflaterInputStream

此类为读取 GZIP 文件格式的压缩数据实现流过滤器。

另请参见：
InflaterInputStream

字段摘要
protected CRC32 | crc 未压缩数据的 CRC-32。
protected boolean | eos 指示输入流的结尾。
static int | GZIP_MAGIC GZIP 头幻数。
从类 java.util.zip.InflaterInputStream 继承的字段
buf, inf, len
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
GZIPInputStream(InputStream in)
使用默认缓冲区大小创建新的输入流。
GZIPInputStream(InputStream in, int size)
使用指定缓冲区大小创建新的输入流。
方法摘要
void | close() 关闭此输入流并释放与该流关联的所有系统资源。
int | read(byte[] buf, int off, int len) 将未压缩数据读入字节数组。
从类 java.util.zip.InflaterInputStream 继承的方法
available, fill, mark, markSupported, read, reset, skip
从类 java.io.FilterInputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

crc

protected CRC32 crc
未压缩数据的 CRC-32。

eos

protected boolean eos
指示输入流的结尾。

GZIP_MAGIC

public static final int GZIP_MAGIC
GZIP 头幻数。

另请参见：
常量字段值
构造方法详细信息

GZIPInputStream

public GZIPInputStream(InputStream in,
                       int size)
                throws IOException
使用指定缓冲区大小创建新的输入流。

参数：
in - 输入流
size - 输入缓冲区大小
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果大小为 <= 0

GZIPInputStream

public GZIPInputStream(InputStream in)
                throws IOException
使用默认缓冲区大小创建新的输入流。

参数：
in - 输入流
抛出：
IOException - 如果发生 I/O 错误
方法详细信息

read

public int read(byte[] buf,
                int off,
                int len)
         throws IOException
将未压缩数据读入字节数组。如果 len 不为零，则在可以解压缩某些输入之前，此方法将处于阻塞状态；否则，不读取字节并且返回 0。

覆盖：
类 InflaterInputStream 中的 read
参数：
buf - 要读入数据的缓冲区
off - 目标数组 b 中的初始偏移量
len - 读取字节的最大数
返回：
实际读取的字节数；如果已到达压缩输入流的结尾，则返回 -1
抛出：
NullPointerException - 如果 buf 为 null。
IndexOutOfBoundsException - 如果 off 为负，或者 len 为负或 len 大于 buf.length - off
IOException - 如果发生 I/O 错误或压缩输入数据损坏
另请参见：
FilterInputStream.in

close

public void close()
           throws IOException
关闭此输入流并释放与该流关联的所有系统资源。

指定者：
接口 Closeable 中的 close
覆盖：
类 InflaterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GZIPOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 GZIPOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.util.zip.DeflaterOutputStream
                继承者  java.util.zip.GZIPOutputStream
所有已实现的接口：
Closeable, Flushable
public class GZIPOutputStream
extends DeflaterOutputStream

此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。

字段摘要
protected  CRC32 crc
未压缩数据的 CRC-32 。
从类 java.util.zip.DeflaterOutputStream 继承的字段
buf, def
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
GZIPOutputStream(OutputStream out)
使用默认缓冲区大小创建新的输出流。
GZIPOutputStream(OutputStream out, int size)
使用指定缓冲区大小创建新的输出流。
方法摘要
void | finish() 完成将压缩数据写入输出流的操作，无需关闭底层流。
void | write(byte[] buf, int off, int len) 将字节数组写入压缩输出流。
从类 java.util.zip.DeflaterOutputStream 继承的方法
close, deflate, write
从类 java.io.FilterOutputStream 继承的方法
flush, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

crc

protected CRC32 crc
未压缩数据的 CRC-32 。

构造方法详细信息

GZIPOutputStream

public GZIPOutputStream(OutputStream out,
                        int size)
                 throws IOException
使用指定缓冲区大小创建新的输出流。

参数：
out - 输出流
size - 输出缓冲区大小
抛出：
IOException - 如果发生 I/O 错误。
IllegalArgumentException - 如果大小为 <= 0

GZIPOutputStream

public GZIPOutputStream(OutputStream out)
                 throws IOException
使用默认缓冲区大小创建新的输出流。

参数：
out - 输出流
抛出：
IOException - 如果发生 I/O 错误。
方法详细信息

write

public void write(byte[] buf,
                  int off,
                  int len)
           throws IOException
将字节数组写入压缩输出流。在写入所有字节前，此方法将阻塞。

覆盖：
类 DeflaterOutputStream 中的 write
参数：
buf - 要写入的数据
off - 数据的初始偏移量
len - 数据的长度
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterOutputStream.write(int)

finish

public void finish()
            throws IOException
完成将压缩数据写入输出流的操作，无需关闭底层流。对同一输出流相继应用多个过滤器时使用此方法。

覆盖：
类 DeflaterOutputStream 中的 finish
抛出：
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Inflater (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 Inflater

java.lang.Object
    继承者  java.util.zip.Inflater

public class Inflater
extends Object

此类使用流行的 ZLIB 压缩程序库为通用解压缩提供支持。ZLIB 压缩程序库最初是作为 PNG 图形标准的一部分开发的，不受专利的保护。有关该规范的完整描述，请参见 java.util.zip 包描述。

以下代码片段演示使用 Deflater 和 Inflater 压缩和解压缩字符串的详细过程。

 try {
 // Encode a String into bytes
 String inputString = "blahblahblah??";
 byte[] input = inputString.getBytes("UTF-8");

 // Compress the bytes
 byte[] output = new byte[100];
 Deflater compresser = new Deflater();
 compresser.setInput(input);
 compresser.finish();
 int compressedDataLength = compresser.deflate(output);

 // Decompress the bytes
 Inflater decompresser = new Inflater();
 decompresser.setInput(output, 0, compressedDataLength);
 byte[] result = new byte[100];
 int resultLength = decompresser.inflate(result);
 decompresser.end();

 // Decode the bytes into a String
 String outputString = new String(result, 0, resultLength, "UTF-8");
 } catch(java.io.UnsupportedEncodingException ex) {
     // handle
 } catch (java.util.zip.DataFormatException ex) {
     // handle
 }

另请参见：
Deflater

构造方法摘要
Inflater()
创建新的解压缩器。
Inflater(boolean nowrap)
创建新的解压缩器。
方法摘要
void | end() 关闭解压缩器并放弃所有未处理的输入。
protected void | finalize() 回收垃圾时关闭解压缩器。
boolean | finished() 如果已到达压缩数据流的结尾，则返回 true。
int | getAdler() 返回未压缩数据的 ADLER-32 值。
long | getBytesRead() 返回到目前为止输入压缩字节的总数。
long | getBytesWritten() 返回到目前为止输出未压缩字节的总数。
int | getRemaining() 返回输入缓冲区中剩余的字节总数。
int | getTotalIn() 返回到目前为止输入压缩字节的总数。
int | getTotalOut() 返回到目前为止输出未压缩字节的总数。
int | inflate(byte[] b) 将字节解压缩到指定的缓冲区。
int | inflate(byte[] b, int off, int len) 将字节解压缩到指定的缓冲区。
boolean | needsDictionary() 如果解压缩需要预置字典，则返回 true。
boolean | needsInput() 如果输入缓冲区中没有剩余数据，则返回 true。
void | reset() 重置 inflater 以处理新的输入数据集。
void | setDictionary(byte[] b) 为给定字节的数组设置预置字典。
void | setDictionary(byte[] b, int off, int len) 为给定的字节数组设置预置字典。
void | setInput(byte[] b) 为解压缩设置输入数据。
void | setInput(byte[] b, int off, int len) 为解压缩设置输入数据。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Inflater

public Inflater(boolean nowrap)
创建新的解压缩器。如果参数 'nowrap' 为 true，则不使用 ZLIB 头和校验和字段。这提供了与 GZIP 和 PKZIP 所用压缩格式的兼容性。

注：使用 'nowrap' 选项时，还需要提供额外的 "dummy" 字节作为输入。当 ZLIB 本机库需要支持某些优化时，这是必需的。

参数：
nowrap - 如果为 true，则支持 GZIP 兼容的压缩

Inflater

public Inflater()
创建新的解压缩器。

方法详细信息

setInput

public void setInput(byte[] b,
                     int off,
                     int len)
为解压缩设置输入数据。应该在 needsInput() 返回 true 时进行调用，以指示需要更多的输入数据。

参数：
b - 输入数据字节
off - 输入数据的初始偏移量
len - 输入数据的长度
另请参见：
needsInput()

setInput

public void setInput(byte[] b)
为解压缩设置输入数据。应该在 needsInput() 返回 true 时进行调用，以指示需要更多的输入数据。

参数：
b - 输入数据字节
另请参见：
needsInput()

setDictionary

public void setDictionary(byte[] b,
                          int off,
                          int len)
为给定的字节数组设置预置字典。应该在 inflate() 返回 0 且 needsDictionary() 返回 true 时进行调用，以指示需要预置字典。可以使用方法 getAdler() 获取所需字典的 Adler-32 值。

参数：
b - 字典数据字节
off - 数据的初始偏移量
len - 数据的长度
另请参见：
needsDictionary(), getAdler()

setDictionary

public void setDictionary(byte[] b)
为给定字节的数组设置预置字典。应该在 inflate() 返回 0 且 needsDictionary() 返回 true 时调用，以指示需要预置字典。可以使用方法 getAdler() 获取所需字典的 Adler-32 值。

参数：
b - 字典数据字节
另请参见：
needsDictionary(), getAdler()

getRemaining

public int getRemaining()
返回输入缓冲区中剩余的字节总数。该方法可用于查找在完成解压缩后输入缓冲区中还有哪些字节。

返回：
输入缓冲区中剩余的字节总数

needsInput

public boolean needsInput()
如果输入缓冲区中没有剩余数据，则返回 true。此方法用于确定是否调用 #setInputThis 以提供更多输入。

返回：
如果缓冲区中没有剩余数据，则返回 true

needsDictionary

public boolean needsDictionary()
如果解压缩需要预置字典，则返回 true。

返回：
如果解压缩需要预置字典，则返回 true
另请参见：
setDictionary(byte[], int, int)

finished

public boolean finished()
如果已到达压缩数据流的结尾，则返回 true。

返回：
如果已到达压缩数据流的结尾，则返回 true

inflate

public int inflate(byte[] b,
                   int off,
                   int len)
            throws DataFormatException
将字节解压缩到指定的缓冲区。返回实际的未压缩字节数。返回值为 0 指示应调用 needsInput() 或 needsDictionary()，以确定是否需要更多的输入数据或预置字典。在后一种情况下，getAdler() 可用于获取所需字典的 Adler-32 值。

参数：
b - 未压缩数据的缓冲区
off - 数据的初始偏移量
len - 最大未压缩字节数
返回：
实际未压缩字节数
抛出：
DataFormatException - 如果压缩数据格式无效
另请参见：
needsInput(), needsDictionary()

inflate

public int inflate(byte[] b)
            throws DataFormatException
将字节解压缩到指定的缓冲区。返回实际的未压缩字节数。返回值为 0 指示应调用 needsInput() 或 needsDictionary()，以确定是否需要更多的输入数据或预置字典。在后一种情况下，getAdler() 可用于获取所需字典的 Adler-32 值。

参数：
b - 未压缩数据的缓冲区
返回：
实际未压缩字节数
抛出：
DataFormatException - 如果压缩数据格式无效
另请参见：
needsInput(), needsDictionary()

getAdler

public int getAdler()
返回未压缩数据的 ADLER-32 值。

返回：
未压缩数据的 ADLER-32 值

getTotalIn

public int getTotalIn()
返回到目前为止输入压缩字节的总数。

由于该字节数可能大于 Integer.MAX_VALUE，因此 getBytesRead() 方法现在是获取此信息的首选方法。

返回：
到目前为止输入压缩字节的总数

getBytesRead

public long getBytesRead()
返回到目前为止输入压缩字节的总数。

返回：
到目前为止输入压缩字节的总数（非负）。
从以下版本开始：
1.5

getTotalOut

public int getTotalOut()
返回到目前为止输出未压缩字节的总数。

由于该字节数可能大于 Integer.MAX_VALUE，因此 getBytesWritten() 方法现在是获取此信息的首选方法。

返回：
到目前为止输出未压缩字节的总数

getBytesWritten

public long getBytesWritten()
返回到目前为止输出未压缩字节的总数。

返回：
到目前为止输出未压缩字节的总数（非负）
从以下版本开始：
1.5

reset

public void reset()
重置 inflater 以处理新的输入数据集。

end

public void end()
关闭解压缩器并放弃所有未处理的输入。此方法应该在不再使用该解压缩器时进行调用，但是也可以由 finalize() 方法自动调用。调用此方法后，Inflater 对象的行为将是不确定的。

finalize

protected void finalize()
回收垃圾时关闭解压缩器。

覆盖：
类 Object 中的 finalize
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InflaterInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 InflaterInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.util.zip.InflaterInputStream
所有已实现的接口：
Closeable
直接已知子类：
GZIPInputStream, ZipInputStream
public class InflaterInputStream
extends FilterInputStream

此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。它还用作其他解压缩过滤器（如 GZIPInputStream）的基础。

另请参见：
Inflater

字段摘要
protected byte[] | buf 用于解压缩的输入缓冲区。
protected Inflater | inf 流的解压缩器。
protected int | len 输入缓冲区的长度。
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
InflaterInputStream(InputStream in)
使用默认解压缩器和缓冲区大小创建一个新输入流。
InflaterInputStream(InputStream in, Inflater inf)
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。
InflaterInputStream(InputStream in, Inflater inf, int size)
使用指定解压缩器和缓冲区大小创建一个新输入流。
方法摘要
int | available() 在到达 EOF 后返回 0；否则始终返回 1。
void | close() 关闭此输入流并释放与该流关联的所有系统资源。
protected void | fill() 使用更多要解压缩的数据填充输入缓冲区。
void | mark(int readlimit) 标记此输入流中的当前位置。
boolean | markSupported() 测试此输入流是否支持 mark 和 reset 方法。
int | read() 读取未压缩数据的字节。
int | read(byte[] b, int off, int len) 将未压缩数据读入字节数组。
void | reset() 将此流重新定位到对此输入流最后调用 mark 方法时的位置。
long | skip(long n) 跳过指定的未压缩数据的字节数。
从类 java.io.FilterInputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

inf

protected Inflater inf
流的解压缩器。

buf

protected byte[] buf
用于解压缩的输入缓冲区。

len

protected int len
输入缓冲区的长度。

构造方法详细信息

InflaterInputStream

public InflaterInputStream(InputStream in,
                           Inflater inf,
                           int size)
使用指定解压缩器和缓冲区大小创建一个新输入流。

参数：
in - 输入流
inf - 解压缩器 ("inflater")
size - 输入缓冲区大小
抛出：
IllegalArgumentException - 如果大小为 <= 0

InflaterInputStream

public InflaterInputStream(InputStream in,
                           Inflater inf)
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。

参数：
in - 输入流
inf - 解压缩器 ("inflater")

InflaterInputStream

public InflaterInputStream(InputStream in)
使用默认解压缩器和缓冲区大小创建一个新输入流。

参数：
in - 输入流
方法详细信息

read

public int read()
         throws IOException
读取未压缩数据的字节。在足够的输入可用于解压缩之前，此方法将阻塞。

覆盖：
类 FilterInputStream 中的 read
返回：
如果到达已压缩输入的结尾，则返回所读取的字节
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
将未压缩数据读入字节数组。如果 len 不为零，则在可以解压缩某些输入之前，此方法将处于阻塞状态；否则不读取字节并且返回 0。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 读入数据的缓冲区
off - 目标数组 b 中的初始偏移量
len - 读取字节的最大数
返回：
读取字节的实际数；或者，如果到达已压缩输入的结尾或需要预置字典，则返回 -1
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，或者 len 为负或 len 大于 b.length - off
ZipException - 如果发生 ZIP 格式错误
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in

available

public int available()
              throws IOException
在到达 EOF 后返回 0；否则始终返回 1。

程序不应依靠此方法返回无阻塞读取的实际字节数。

覆盖：
类 FilterInputStream 中的 available
返回：
在到达 EOF 之前返回 1；在到达 EOF 之后返回 0。
抛出：
IOException - 如果发生 I/O 错误。

skip

public long skip(long n)
          throws IOException
跳过指定的未压缩数据的字节数。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数
返回：
实际跳过的字节数。
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果 n < 0

close

public void close()
           throws IOException
关闭此输入流并释放与该流关联的所有系统资源。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in

fill

protected void fill()
             throws IOException
使用更多要解压缩的数据填充输入缓冲区。

抛出：
IOException - 如果发生 I/O 错误

markSupported

public boolean markSupported()
测试此输入流是否支持 mark 和 reset 方法。InflaterInputStream 的 markSupported 方法返回 false。

覆盖：
类 FilterInputStream 中的 markSupported
返回：
一个 boolean 值，指示此流类型是否支持 mark 和 reset 方法。
另请参见：
InputStream.mark(int), InputStream.reset()

mark

public void mark(int readlimit)
标记此输入流中的当前位置。

InflaterInputStream 的 mark 方法不执行任何操作。

覆盖：
类 FilterInputStream 中的 mark
参数：
readlimit - 在标记位置变为无效前可以读取字节的最大限制。
另请参见：
InputStream.reset()

reset

public void reset()
           throws IOException
将此流重新定位到对此输入流最后调用 mark 方法时的位置。

除了抛出 IOException 之外，类 InflaterInputStream 的方法 reset 不执行任何操作。

覆盖：
类 FilterInputStream 中的 reset
抛出：
IOException - 如果调用此方法。
另请参见：
InputStream.mark(int), IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InflaterOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 InflaterOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.util.zip.InflaterOutputStream
所有已实现的接口：
Closeable, Flushable
public class InflaterOutputStream
extends FilterOutputStream

为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。

从以下版本开始：
1.6
另请参见：
InflaterInputStream, DeflaterInputStream, DeflaterOutputStream

字段摘要
protected byte[] | buf 写入未压缩数据的输出缓冲区。
protected Inflater | inf 此流的解压缩器。
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
InflaterOutputStream(OutputStream out)
创建一个带有默认解压缩器和缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl)
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl, int bufLen)
创建一个带有指定解压缩器和缓冲区大小的新输出流。
方法摘要
void | close() 将剩余未压缩数据写入输出流并关闭底层输出流。
void | finish() 完成将未压缩数据写入输出流的操作，无需关闭底层流。
void | flush() 刷新此输出流，并强制写出挂起的所有缓冲输出字节。
void | write(byte[] b, int off, int len) 将 byte 数组写入未压缩输出流。
void | write(int b) 将字节写入未压缩输出流。
从类 java.io.FilterOutputStream 继承的方法
write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

inf

protected final Inflater inf
此流的解压缩器。

buf

protected final byte[] buf
写入未压缩数据的输出缓冲区。

构造方法详细信息

InflaterOutputStream

public InflaterOutputStream(OutputStream out)
创建一个带有默认解压缩器和缓冲区大小的新输出流。

参数：
out - 要写入未压缩数据的输出流
抛出：
NullPointerException - 如果 out 为 null

InflaterOutputStream

public InflaterOutputStream(OutputStream out,
                            Inflater infl)
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。

参数：
out - 要读入未压缩数据的输出流
infl - 此流的解压缩器 ("inflater")
抛出：
NullPointerException - 如果 out 或 infl 为 null

InflaterOutputStream

public InflaterOutputStream(OutputStream out,
                            Inflater infl,
                            int bufLen)
创建一个带有指定解压缩器和缓冲区大小的新输出流。

参数：
out - 要写入未压缩数据的输出流
infl - 此流的解压缩器 ("inflater")
bufLen - 解压缩缓冲区大小
抛出：
IllegalArgumentException - 如果 bufLen <= 0
NullPointerException - 如果 out 或 infl 为 null
方法详细信息

close

public void close()
           throws IOException
将剩余未压缩数据写入输出流并关闭底层输出流。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterOutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误
另请参见：
FilterOutputStream.flush(), FilterOutputStream.out

flush

public void flush()
           throws IOException
刷新此输出流，并强制写出挂起的所有缓冲输出字节。

指定者：
接口 Flushable 中的 flush
覆盖：
类 FilterOutputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误或者此流已经关闭
另请参见：
FilterOutputStream.out

finish

public void finish()
            throws IOException
完成将未压缩数据写入输出流的操作，无需关闭底层流。对同一输出流连续应用多个过滤器时使用此方法。

抛出：
IOException - 如果发生 I/O 错误或者此流已经关闭

write

public void write(int b)
           throws IOException
将字节写入未压缩输出流。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 一个要解压缩并写入输出流的压缩数据字节
抛出：
IOException - 如果发生 I/O 错误或者此流已经关闭
ZipException - 如果发生压缩 (ZIP) 格式错误

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将 byte 数组写入未压缩输出流。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 包含要解压缩并写入输出流的压缩数据的缓冲区
off - b 中压缩数据的起始偏移量
len - 要从 b 中解压缩的字节数
抛出：
IndexOutOfBoundsException - 如果 off < 0、len < 0，或者 len > b.length - off
IOException - 如果发生 I/O 错误或者此流已经关闭
NullPointerException - 如果 b 为 null
ZipException - 如果发生压缩 (ZIP) 格式错误
另请参见：
FilterOutputStream.write(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 ZipEntry

java.lang.Object
    继承者  java.util.zip.ZipEntry
所有已实现的接口：
Cloneable
直接已知子类：
JarEntry
public class ZipEntry
extends Object
implements Cloneable

此类用于表示 ZIP 文件条目。

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | DEFLATED 用于已压缩 (deflated) 条目的压缩方法。
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
static int | STORED 用于未压缩条目的压缩方法。
构造方法摘要
ZipEntry(String name)
使用指定名称创建新的 ZIP 条目。
ZipEntry(ZipEntry e)
使用从指定 ZIP 条目获取的字段创建新的 ZIP 条目。
方法摘要
Object | clone() 返回此条目的副本。
String | getComment() 返回条目的注释字符串；如果没有，则返回 null。
long | getCompressedSize() 返回压缩条目数据的大小；如果未知，则返回 -1。
long | getCrc() 返回未压缩条目数据的 CRC-32 校验和；如果未知，则返回 -1。
byte[] | getExtra() 返回条目的额外字段数据；如果没有，则返回 null。
int | getMethod() 返回条目的压缩方法；如果未指定，则返回 -1。
String | getName() 返回条目名称。
long | getSize() 返回条目数据的未压缩大小；如果未知，则返回 -1。
long | getTime() 返回条目的修改时间；如果未指定，则返回 -1。
int | hashCode() 返回此条目的哈希码值。
boolean | isDirectory() 如果为目录条目，则返回 true。
void | setComment(String comment) 为条目设置可选的注释字符串。
void | setCompressedSize(long csize) 设置压缩条目数据的大小。
void | setCrc(long crc) 设置未压缩条目数据的 CRC-32 校验和。
void | setExtra(byte[] extra) 为条目设置可选的额外字段数据。
void | setMethod(int method) 设置条目的压缩方法。
void | setSize(long size) 设置条目数据的未压缩大小。
void | setTime(long time) 设置条目的修改时间。
String | toString() 返回 ZIP 条目的字符串表示形式。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

STORED

public static final int STORED
用于未压缩条目的压缩方法。

另请参见：
常量字段值

DEFLATED

public static final int DEFLATED
用于已压缩 (deflated) 条目的压缩方法。

另请参见：
常量字段值

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

ZipEntry

public ZipEntry(String name)
使用指定名称创建新的 ZIP 条目。

参数：
name - 条目名称
抛出：
NullPointerException - 如果条目名称为 null
IllegalArgumentException - 如果条目名称大于 0xFFFF 字节

ZipEntry

public ZipEntry(ZipEntry e)
使用从指定 ZIP 条目获取的字段创建新的 ZIP 条目。

参数：
e - ZIP Entry 对象
方法详细信息

getName

public String getName()
返回条目名称。

返回：
条目名称

setTime

public void setTime(long time)
设置条目的修改时间。

参数：
time - 自从出现以来以毫秒数表示的条目修改时间
另请参见：
getTime()

getTime

public long getTime()
返回条目的修改时间；如果未指定，则返回 -1。

返回：
条目的修改时间；如果未指定，则返回 -1
另请参见：
setTime(long)

setSize

public void setSize(long size)
设置条目数据的未压缩大小。

参数：
size - 以字节表示的未压缩大小
抛出：
IllegalArgumentException - 如果指定大小小于 0 或大于 0xFFFFFFFF 字节
另请参见：
getSize()

getSize

public long getSize()
返回条目数据的未压缩大小；如果未知，则返回 -1。

返回：
条目数据的未压缩大小；如果未知，则返回 -1
另请参见：
setSize(long)

getCompressedSize

public long getCompressedSize()
返回压缩条目数据的大小；如果未知，则返回 -1。对于 stored 条目，其压缩大小与该条目的未压缩大小相同。

返回：
压缩条目数据的大小；如果未知，则返回 -1
另请参见：
setCompressedSize(long)

setCompressedSize

public void setCompressedSize(long csize)
设置压缩条目数据的大小。

参数：
csize - 要设置的压缩大小
另请参见：
getCompressedSize()

setCrc

public void setCrc(long crc)
设置未压缩条目数据的 CRC-32 校验和。

参数：
crc - CRC-32 值
抛出：
IllegalArgumentException - 如果指定的 CRC-32 值小于 0 或大于 0xFFFFFFFF
另请参见：
getCrc()

getCrc

public long getCrc()
返回未压缩条目数据的 CRC-32 校验和；如果未知，则返回 -1。

返回：
未压缩条目数据的 CRC-32 校验和；如果未知，则返回 -1
另请参见：
setCrc(long)

setMethod

public void setMethod(int method)
设置条目的压缩方法。

参数：
method - 压缩方法，可以为 STORED 或 DEFLATED
抛出：
IllegalArgumentException - 如果指定压缩方法无效
另请参见：
getMethod()

getMethod

public int getMethod()
返回条目的压缩方法；如果未指定，则返回 -1。

返回：
条目的压缩方法；如果未指定，则返回 -1
另请参见：
setMethod(int)

setExtra

public void setExtra(byte[] extra)
为条目设置可选的额外字段数据。

参数：
extra - 额外字段数据字节
抛出：
IllegalArgumentException - 如果指定的额外字段数据的长度大于 0xFFFF 字节
另请参见：
getExtra()

getExtra

public byte[] getExtra()
返回条目的额外字段数据；如果没有，则返回 null。

返回：
条目的额外字段数据；如果没有，则返回 null
另请参见：
setExtra(byte[])

setComment

public void setComment(String comment)
为条目设置可选的注释字符串。

参数：
comment - 注释字符串
抛出：
IllegalArgumentException - 如果指定的注释字符串的长度大于 0xFFFF 字节
另请参见：
getComment()

getComment

public String getComment()
返回条目的注释字符串；如果没有，则返回 null。

返回：
条目的注释字符串；如果没有，则返回 null
另请参见：
setComment(String)

isDirectory

public boolean isDirectory()
如果为目录条目，则返回 true。目录条目定义为其名称以 '/' 结尾的条目。

返回：
如果为目录条目，则返回 true

toString

public String toString()
返回 ZIP 条目的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

hashCode

public int hashCode()
返回此条目的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

clone

public Object clone()
返回此条目的副本。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipError (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 ZipError

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Error
            继承者  java.lang.VirtualMachineError
                继承者  java.lang.InternalError
                    继承者  java.util.zip.ZipError
所有已实现的接口：
Serializable
public class ZipError
extends InternalError

发生不可恢复的错误时抛出。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
ZipError(String s)
构造带有给定详细消息的 ZipError。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ZipError

public ZipError(String s)
构造带有给定详细消息的 ZipError。

参数：
s - 包含详细消息的 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 ZipException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.util.zip.ZipException
所有已实现的接口：
Serializable
直接已知子类：
JarException
public class ZipException
extends IOException

如果某种 ZIP 异常发生，则抛出此错误。

从以下版本开始：
JDK1.0
另请参见：
IOException, 序列化表格

构造方法摘要
ZipException()
使用 null 作为错误详细消息构造 ZipException。
ZipException(String s)
构建带指定详细消息的 ZipException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ZipException

public ZipException()
使用 null 作为错误详细消息构造 ZipException。

ZipException

public ZipException(String s)
构建带指定详细消息的 ZipException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipFile (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 ZipFile

java.lang.Object
    继承者  java.util.zip.ZipFile
直接已知子类：
JarFile
public class ZipFile
extends Object

此类用于从 ZIP 文件读取条目。

除非另有说明，将 null 参数传入此类中的构造方法或方法将导致抛出 NullPointerException。

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
static int | OPEN_DELETE 打开 ZIP 文件并将其标记为删除的模式标志。
static int | OPEN_READ 打开 ZIP 文件进行阅读的模式标志。
构造方法摘要
ZipFile(File file)
打开供阅读的 ZIP 文件，由指定的 File 对象给出。
ZipFile(File file, int mode)
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。
ZipFile(String name)
打开 ZIP 文件进行阅读。
方法摘要
void | close() 关闭 ZIP 文件。
Enumeration<? extends ZipEntry> | entries() 返回 ZIP 文件条目的枚举。
protected void | finalize() 确保不再引用此 ZIP 文件时调用它的 close 方法。
ZipEntry | getEntry(String name) 返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。
InputStream | getInputStream(ZipEntry entry) 返回输入流以读取指定 ZIP 文件条目的内容。
String | getName() 返回 ZIP 文件的路径名。
int | size() 返回 ZIP 文件中的条目数。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OPEN_READ

public static final int OPEN_READ
打开 ZIP 文件进行阅读的模式标志。

另请参见：
常量字段值

OPEN_DELETE

public static final int OPEN_DELETE
打开 ZIP 文件并将其标记为删除的模式标志。在打开文件和关闭文件之间的某个时间，该文件将被删除，但是其内容仍可通过 ZipFile 对象访问，直到调用关闭方法或虚拟机退出为止。

另请参见：
常量字段值

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

ZipFile

public ZipFile(String name)
        throws IOException
打开 ZIP 文件进行阅读。

首先，如果存在安全管理器，则使用 name 作为其参数调用其 checkRead 方法，以确保允许阅读。

参数：
name - ZIP 文件的名称
抛出：
ZipException - 如果发生 ZIP 格式错误
IOException - 如果发生 I/O 错误
SecurityException - 如果存在安全管理器，并且其 checkRead 方法不允许对该文件进行阅读访问。
另请参见：
SecurityManager.checkRead(java.lang.String)

ZipFile

public ZipFile(File file,
               int mode)
        throws IOException
打开新的 ZipFile 以使用指定模式从指定 File 对象读取。模式参数必须为 OPEN_READ 或 OPEN_READ | OPEN_DELETE。

首先，如果存在安全管理器，则使用 name 作为其参数调用其 checkRead 方法，以确保允许阅读。

参数：
file - 要打开进行阅读的 ZIP 文件
mode - 要用于打开文件的模式
抛出：
ZipException - 如果发生 ZIP 格式错误
IOException - 如果发生 I/O 错误
SecurityException - 如果存在安全管理器，并且其 checkRead 方法不允许对该文件进行读取访问，或者当设置了 OPEN_DELETE 标志时，其 checkDelete 方法不允许删除该文件。
IllegalArgumentException - 如果 mode 参数无效
从以下版本开始：
1.3
另请参见：
SecurityManager.checkRead(java.lang.String)

ZipFile

public ZipFile(File file)
        throws ZipException,
               IOException
打开供阅读的 ZIP 文件，由指定的 File 对象给出。

参数：
file - 要打开供阅读的 ZIP 文件
抛出：
ZipException - 如果发生 ZIP 错误
IOException - 如果发生 I/O 错误
方法详细信息

getEntry

public ZipEntry getEntry(String name)
返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。

参数：
name - 条目名称
返回：
ZIP 文件条目；如果未找到，则返回 null
抛出：
IllegalStateException - 如果已关闭该 ZIP

getInputStream

public InputStream getInputStream(ZipEntry entry)
                           throws IOException
返回输入流以读取指定 ZIP 文件条目的内容。

关闭此 ZIP 文件将依次关闭调用此方法返回的所有输入流。

参数：
entry - ZIP 文件条目
返回：
读取指定 ZIP 文件条目内容的输入流。
抛出：
ZipException - 如果发生 ZIP 格式错误
IOException - 如果发生 I/O 错误
IllegalStateException - 如果已关闭 ZIP 文件

getName

public String getName()
返回 ZIP 文件的路径名。

返回：
ZIP 文件的路径名

entries

public Enumeration<? extends ZipEntry> entries()
返回 ZIP 文件条目的枚举。

返回：
ZIP 文件条目的枚举
抛出：
IllegalStateException - 如果已关闭 ZIP 文件

size

public int size()
返回 ZIP 文件中的条目数。

返回：
ZIP 文件中的条目数
抛出：
IllegalStateException - 如果已关闭 ZIP 文件

close

public void close()
           throws IOException
关闭 ZIP 文件。

关闭此 ZIP 文件将关闭以前调用 getInputStream 方法返回的所有输入流。

抛出：
IOException - 如果发生 I/O 错误

finalize

protected void finalize()
                 throws IOException
确保不再引用此 ZIP 文件时调用它的 close 方法。

由于不确定 GC 何时调用此方法，因此强烈建议应用程序一完成访问此 ZipFile 就调用 close 方法。这可防止不定期地保持系统资源。

覆盖：
类 Object 中的 finalize
抛出：
IOException - 如果发生 I/O 错误
另请参见：
close()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 ZipInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  java.util.zip.InflaterInputStream
                继承者  java.util.zip.ZipInputStream
所有已实现的接口：
Closeable
直接已知子类：
JarInputStream
public class ZipInputStream
extends InflaterInputStream

此类为读取 ZIP 文件格式的文件实现输入流过滤器。包括对已压缩和未压缩条目的支持。

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
从类 java.util.zip.InflaterInputStream 继承的字段
buf, inf, len
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
ZipInputStream(InputStream in)
创建新的 ZIP 输入流。
方法摘要
int | available() 在 EOF 到达当前条目数据后，返回 0；否则，始终返回 1。
void | close() 关闭此输入流并释放与此流关联的所有系统资源。
void | closeEntry() 关闭当前 ZIP 条目并定位流以读取下一个条目。
protected ZipEntry | createZipEntry(String name) 为指定条目名称创建一个新的 ZipEntry 对象。
ZipEntry | getNextEntry() 读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。
int | read(byte[] b, int off, int len) 从当前 ZIP 条目读入字节数组。
long | skip(long n) 跳过当前 ZIP 条目中指定的字节数。
从类 java.util.zip.InflaterInputStream 继承的方法
fill, mark, markSupported, read, reset
从类 java.io.FilterInputStream 继承的方法
read
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

ZipInputStream

public ZipInputStream(InputStream in)
创建新的 ZIP 输入流。

参数：
in - 实际输入流
方法详细信息

getNextEntry

public ZipEntry getNextEntry()
                      throws IOException
读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。

返回：
下一个 ZIP 文件条目；如果不存在更多条目，则返回 null
抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误

closeEntry

public void closeEntry()
                throws IOException
关闭当前 ZIP 条目并定位流以读取下一个条目。

抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误

available

public int available()
              throws IOException
在 EOF 到达当前条目数据后，返回 0；否则，始终返回 1。

程序不应依靠此方法返回无阻塞读取的实际字节数。

覆盖：
类 InflaterInputStream 中的 available
返回：
EOF 到达当前条目前，返回 1；EOF 到达当前条目后，返回 0。
抛出：
IOException - 如果发生 I/O 错误。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从当前 ZIP 条目读入字节数组。如果 len 不为零，则在某些输入可用之前，此方法将处于阻塞状态；否则，不读取字节并且返回 0。

覆盖：
类 InflaterInputStream 中的 read
参数：
b - 要读入数据的缓冲区
off - 目标数组 b 中的初始偏移量
len - 读入字节的最大数
返回：
读入字节的实际数；如果到达条目结尾，则返回 -1
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负，或者 len 为负或 len 大于 b.length - off
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误
另请参见：
FilterInputStream.in

skip

public long skip(long n)
          throws IOException
跳过当前 ZIP 条目中指定的字节数。

覆盖：
类 InflaterInputStream 中的 skip
参数：
n - 要跳过的字节数
返回：
跳过的实际字节数
抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果 n < 0

close

public void close()
           throws IOException
关闭此输入流并释放与此流关联的所有系统资源。

指定者：
接口 Closeable 中的 close
覆盖：
类 InflaterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in

createZipEntry

protected ZipEntry createZipEntry(String name)
为指定条目名称创建一个新的 ZipEntry 对象。

参数：
name - ZIP 文件条目名称
返回：
刚刚创建的 ZipEntry
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ZipOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

java.util.zip
类 ZipOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  java.util.zip.DeflaterOutputStream
                继承者  java.util.zip.ZipOutputStream
所有已实现的接口：
Closeable, Flushable
直接已知子类：
JarOutputStream
public class ZipOutputStream
extends DeflaterOutputStream

此类为以 ZIP 文件格式写入文件实现输出流过滤器。包括对已压缩和未压缩条目的支持。

字段摘要
static int | CENATT
static int | CENATX
static int | CENCOM
static int | CENCRC
static int | CENDSK
static int | CENEXT
static int | CENFLG
static int | CENHDR
static int | CENHOW
static int | CENLEN
static int | CENNAM
static int | CENOFF
static long | CENSIG
static int | CENSIZ
static int | CENTIM
static int | CENVEM
static int | CENVER
static int | DEFLATED 用于已压缩 (DEFLATED) 条目的压缩方法。
static int | ENDCOM
static int | ENDHDR
static int | ENDOFF
static long | ENDSIG
static int | ENDSIZ
static int | ENDSUB
static int | ENDTOT
static int | EXTCRC
static int | EXTHDR
static int | EXTLEN
static long | EXTSIG
static int | EXTSIZ
static int | LOCCRC
static int | LOCEXT
static int | LOCFLG
static int | LOCHDR
static int | LOCHOW
static int | LOCLEN
static int | LOCNAM
static long | LOCSIG
static int | LOCSIZ
static int | LOCTIM
static int | LOCVER
static int | STORED 用于未压缩 (STORED) 条目的压缩方法。
从类 java.util.zip.DeflaterOutputStream 继承的字段
buf, def
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
ZipOutputStream(OutputStream out)
创建新的 ZIP 输出流。
方法摘要
void | close() 关闭 ZIP 输出流和正在过滤的流。
void | closeEntry() 关闭当前 ZIP 条目并定位流以写入下一个条目。
void | finish() 完成写入 ZIP 输出流的内容，无需关闭底层流。
void | putNextEntry(ZipEntry e) 开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。
void | setComment(String comment) 设置 ZIP 文件注释。
void | setLevel(int level) 为后续的 DEFLATED 条目设置压缩级别。
void | setMethod(int method) 设置用于后续条目的默认压缩方法。
void | write(byte[] b, int off, int len) 将字节数组写入当前 ZIP 条目数据。
从类 java.util.zip.DeflaterOutputStream 继承的方法
deflate, write
从类 java.io.FilterOutputStream 继承的方法
flush, write
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STORED

public static final int STORED
用于未压缩 (STORED) 条目的压缩方法。

另请参见：
常量字段值

DEFLATED

public static final int DEFLATED
用于已压缩 (DEFLATED) 条目的压缩方法。

另请参见：
常量字段值

LOCSIG

public static final long LOCSIG
另请参见：
常量字段值

EXTSIG

public static final long EXTSIG
另请参见：
常量字段值

CENSIG

public static final long CENSIG
另请参见：
常量字段值

ENDSIG

public static final long ENDSIG
另请参见：
常量字段值

LOCHDR

public static final int LOCHDR
另请参见：
常量字段值

EXTHDR

public static final int EXTHDR
另请参见：
常量字段值

CENHDR

public static final int CENHDR
另请参见：
常量字段值

ENDHDR

public static final int ENDHDR
另请参见：
常量字段值

LOCVER

public static final int LOCVER
另请参见：
常量字段值

LOCFLG

public static final int LOCFLG
另请参见：
常量字段值

LOCHOW

public static final int LOCHOW
另请参见：
常量字段值

LOCTIM

public static final int LOCTIM
另请参见：
常量字段值

LOCCRC

public static final int LOCCRC
另请参见：
常量字段值

LOCSIZ

public static final int LOCSIZ
另请参见：
常量字段值

LOCLEN

public static final int LOCLEN
另请参见：
常量字段值

LOCNAM

public static final int LOCNAM
另请参见：
常量字段值

LOCEXT

public static final int LOCEXT
另请参见：
常量字段值

EXTCRC

public static final int EXTCRC
另请参见：
常量字段值

EXTSIZ

public static final int EXTSIZ
另请参见：
常量字段值

EXTLEN

public static final int EXTLEN
另请参见：
常量字段值

CENVEM

public static final int CENVEM
另请参见：
常量字段值

CENVER

public static final int CENVER
另请参见：
常量字段值

CENFLG

public static final int CENFLG
另请参见：
常量字段值

CENHOW

public static final int CENHOW
另请参见：
常量字段值

CENTIM

public static final int CENTIM
另请参见：
常量字段值

CENCRC

public static final int CENCRC
另请参见：
常量字段值

CENSIZ

public static final int CENSIZ
另请参见：
常量字段值

CENLEN

public static final int CENLEN
另请参见：
常量字段值

CENNAM

public static final int CENNAM
另请参见：
常量字段值

CENEXT

public static final int CENEXT
另请参见：
常量字段值

CENCOM

public static final int CENCOM
另请参见：
常量字段值

CENDSK

public static final int CENDSK
另请参见：
常量字段值

CENATT

public static final int CENATT
另请参见：
常量字段值

CENATX

public static final int CENATX
另请参见：
常量字段值

CENOFF

public static final int CENOFF
另请参见：
常量字段值

ENDSUB

public static final int ENDSUB
另请参见：
常量字段值

ENDTOT

public static final int ENDTOT
另请参见：
常量字段值

ENDSIZ

public static final int ENDSIZ
另请参见：
常量字段值

ENDOFF

public static final int ENDOFF
另请参见：
常量字段值

ENDCOM

public static final int ENDCOM
另请参见：
常量字段值
构造方法详细信息

ZipOutputStream

public ZipOutputStream(OutputStream out)
创建新的 ZIP 输出流。

参数：
out - 实际输出流
方法详细信息

setComment

public void setComment(String comment)
设置 ZIP 文件注释。

参数：
comment - 注释字符串
抛出：
IllegalArgumentException - 如果指定的 ZIP 文件注释的长度超过 0xFFFF 字节

setMethod

public void setMethod(int method)
设置用于后续条目的默认压缩方法。只要没有为单个 ZIP 文件条目指定压缩方法，并且其初始设置为 DEFLATED 时，就使用此默认值。

参数：
method - 默认压缩方法
抛出：
IllegalArgumentException - 如果指定的压缩方法无效

setLevel

public void setLevel(int level)
为后续的 DEFLATED 条目设置压缩级别。默认设置是 DEFAULT_COMPRESSION。

参数：
level - 压缩级别 (0-9)
抛出：
IllegalArgumentException - 如果压缩级别无效

putNextEntry

public void putNextEntry(ZipEntry e)
                  throws IOException
开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。如果仍处于活动状态，则关闭当前条目。如果没有为条目指定压缩方法，则使用默认的压缩方法；如果没有为条目设置修改时间，则使用当前时间。

参数：
e - 要写入的 ZIP 条目
抛出：
ZipException - 如果发生 ZIP 格式错误
IOException - 如果发生 I/O 错误

closeEntry

public void closeEntry()
                throws IOException
关闭当前 ZIP 条目并定位流以写入下一个条目。

抛出：
ZipException - 如果发生 ZIP 格式错误
IOException - 如果发生 I/O 错误

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将字节数组写入当前 ZIP 条目数据。在写入所有字节之前，此方法将阻塞。

覆盖：
类 DeflaterOutputStream 中的 write
参数：
b - 要写入的数据
off - 数据中的初始偏移量
len - 要写入的字节数
抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误
另请参见：
FilterOutputStream.write(int)

finish

public void finish()
            throws IOException
完成写入 ZIP 输出流的内容，无需关闭底层流。对同一输出流连续应用多个过滤器时使用此方法。

覆盖：
类 DeflaterOutputStream 中的 finish
抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 异常

close

public void close()
           throws IOException
关闭 ZIP 输出流和正在过滤的流。

指定者：
接口 Closeable 中的 close
覆盖：
类 DeflaterOutputStream 中的 close
抛出：
ZipException - 如果发生 ZIP 文件错误
IOException - 如果发生 I/O 错误
另请参见：
FilterOutputStream.flush(), FilterOutputStream.out
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


java.util.zip (Java 2 Platform SE 6)

 java.util.zip
接口
Checksum
类
Adler32
CheckedInputStream
CheckedOutputStream
CRC32
Deflater
DeflaterInputStream
DeflaterOutputStream
GZIPInputStream
GZIPOutputStream
Inflater
InflaterInputStream
InflaterOutputStream
ZipEntry
ZipFile
ZipInputStream
ZipOutputStream
异常
DataFormatException
ZipException
错误
ZipError


java.util.zip (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 java.util.zip

提供用于读写标准 ZIP 和 GZIP 文件格式的类。

请参见：
描述

接口摘要
Checksum 表示数据校验和的接口。

类摘要
Adler32 | 可用于计算数据流的 Adler-32 校验和的类。
CheckedInputStream | 需要维护所读取数据校验和的输入流。
CheckedOutputStream | 需要维护写入数据校验和的输出流。
CRC32 | 可用于计算数据流的 CRC-32 的类。
Deflater | 此类使用流行的 ZLIB 压缩程序库为通用压缩提供支持。
DeflaterInputStream | 为使用 "deflate" 压缩格式压缩数据实现输入流过滤器。
DeflaterOutputStream | 此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
GZIPInputStream | 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
GZIPOutputStream | 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
Inflater | 此类使用流行的 ZLIB 压缩程序库为通用解压缩提供支持。
InflaterInputStream | 此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
InflaterOutputStream | 为解压缩 "deflate" 压缩格式存储的数据实现输出流过滤器。
ZipEntry | 此类用于表示 ZIP 文件条目。
ZipFile | 此类用于从 ZIP 文件读取条目。
ZipInputStream | 此类为读取 ZIP 文件格式的文件实现输入流过滤器。
ZipOutputStream | 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

异常摘要
DataFormatException | 当数据格式发生错误时，抛出此异常。
ZipException | 如果某种 ZIP 异常发生，则抛出此错误。

错误摘要
ZipError 发生不可恢复的错误时抛出。

软件包 java.util.zip 的描述

提供用于读写标准 ZIP 和 GZIP 文件格式的类。还包括使用 DEFLATE 压缩算法（用于 ZIP 和 GZIP 文件格式）对数据进行压缩和解压缩的类。此外，还存在用于计算任意输入流的 CRC-32 和 Adler-32 校验和的实用工具类。

包规范

  • Info-ZIP Application Note 970311 - Info-ZIP 格式（java.util.zip 类的基础）的详细描述。

  • ZLIB Compressed Data Format Specification version 3.3 (PostScript) (RFC 1950)

  • DEFLATE Compressed Data Format Specification version 1.3 (PostScript) (RFC 1951)

  • GZIP file format specification version 4.3 (PostScript) (RFC 1952)

  • CRC-32 校验和在 RFC 1952（见上文）中描述

  • Adler-32 校验和在 RFC 1950（见上文）中描述

从以下版本开始：
JDK1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


java.util.zip 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.zip 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.zip.Adler32 (implements java.util.zip.Checksum)
    • java.util.zip.CRC32 (implements java.util.zip.Checksum)
    • java.util.zip.Deflater
    • java.util.zip.Inflater
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • java.util.zip.CheckedInputStream
        • java.util.zip.DeflaterInputStream
        • java.util.zip.InflaterInputStream
          • java.util.zip.GZIPInputStream
          • java.util.zip.ZipInputStream
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • java.util.zip.CheckedOutputStream
        • java.util.zip.DeflaterOutputStream
          • java.util.zip.GZIPOutputStream
          • java.util.zip.ZipOutputStream
        • java.util.zip.InflaterOutputStream
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Error
        • java.lang.VirtualMachineError
          • java.lang.InternalError
            • java.util.zip.ZipError
      • java.lang.Exception
        • java.util.zip.DataFormatException
        • java.io.IOException
          • java.util.zip.ZipException
    • java.util.zip.ZipEntry (implements java.lang.Cloneable)
    • java.util.zip.ZipFile

接口分层结构

  • java.util.zip.Checksum
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 java.util.zip 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 java.util.zip
的使用

使用 java.util.zip 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 使用的 java.util.zip 中的类
DeflaterOutputStream
此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
InflaterInputStream
此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
ZipEntry
此类用于表示 ZIP 文件条目。
ZipException
如果某种 ZIP 异常发生，则抛出此错误。
ZipFile
此类用于从 ZIP 文件读取条目。
ZipInputStream
此类为读取 ZIP 文件格式的文件实现输入流过滤器。
ZipOutputStream
此类为以 ZIP 文件格式写入文件实现输出流过滤器。

java.util.zip 使用的 java.util.zip 中的类
Checksum
表示数据校验和的接口。
CRC32
可用于计算数据流的 CRC-32 的类。
DataFormatException
当数据格式发生错误时，抛出此异常。
Deflater
此类使用流行的 ZLIB 压缩程序库为通用压缩提供支持。
DeflaterOutputStream
此类为使用 "deflate" 压缩格式压缩数据实现输出流过滤器。
Inflater
此类使用流行的 ZLIB 压缩程序库为通用解压缩提供支持。
InflaterInputStream
此类为解压缩 "deflate" 压缩格式的数据实现流过滤器。
ZipEntry
此类用于表示 ZIP 文件条目。
ZipException
如果某种 ZIP 异常发生，则抛出此错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.ZipError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipError
的使用

没有 java.util.zip.ZipError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.Adler32 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.Adler32
的使用

没有 java.util.zip.Adler32 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.CheckedInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.CheckedInputStream
的使用

没有 java.util.zip.CheckedInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.CheckedOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.CheckedOutputStream
的使用

没有 java.util.zip.CheckedOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.DataFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.DataFormatException
的使用

使用 DataFormatException 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 DataFormatException 的使用

抛出 DataFormatException 的 java.util.zip 中的方法
int | Inflater.inflate(byte[] b) 将字节解压缩到指定的缓冲区。
int | Inflater.inflate(byte[] b, int off, int len) 将字节解压缩到指定的缓冲区。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.Deflater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.Deflater
的使用

使用 Deflater 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 Deflater 的使用

声明为 Deflater 的 java.util.zip 中的字段
protected Deflater | DeflaterInputStream.def 此流的压缩器。
protected Deflater | DeflaterOutputStream.def 此流的压缩器。

参数类型为 Deflater 的 java.util.zip 中的构造方法
DeflaterInputStream(InputStream in, Deflater defl)
创建一个带有指定压缩器和默认缓冲区大小的新输入流。
DeflaterInputStream(InputStream in, Deflater defl, int bufLen)
创建一个带有指定压缩器和缓冲区大小的新输入流。
DeflaterOutputStream(OutputStream out, Deflater def)
使用指定压缩器和默认缓冲区大小创建一个新输出流。
DeflaterOutputStream(OutputStream out, Deflater def, int size)
使用指定压缩器和缓冲区大小创建一个新输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.DeflaterInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.DeflaterInputStream
的使用

没有 java.util.zip.DeflaterInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.GZIPOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.GZIPOutputStream
的使用

没有 java.util.zip.GZIPOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.InflaterOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.InflaterOutputStream
的使用

没有 java.util.zip.InflaterOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.ZipException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipException
的使用

使用 ZipException 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 ZipException 的使用

java.util.jar 中 ZipException 的子类
 class JarException
读取或写入 JAR 文件时，如果发生某种错误，则抛出此异常。

java.util.zip 中 ZipException 的使用

抛出 ZipException 的 java.util.zip 中的构造方法
ZipFile(File file)
打开供阅读的 ZIP 文件，由指定的 File 对象给出。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.ZipOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipOutputStream
的使用

使用 ZipOutputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 ZipOutputStream 的使用

java.util.jar 中 ZipOutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.DeflaterOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.DeflaterOutputStream
的使用

使用 DeflaterOutputStream 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 DeflaterOutputStream 的使用

java.util.jar 中 DeflaterOutputStream 的子类
 class JarOutputStream
JarOutputStream 类用于向任何输出流写入 JAR 文件内容。

java.util.zip 中 DeflaterOutputStream 的使用

java.util.zip 中 DeflaterOutputStream 的子类
class | GZIPOutputStream 此类为使用 GZIP 文件格式写入压缩数据实现流过滤器。
class | ZipOutputStream 此类为以 ZIP 文件格式写入文件实现输出流过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.GZIPInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.GZIPInputStream
的使用

没有 java.util.zip.GZIPInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.CRC32 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.CRC32
的使用

使用 CRC32 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 CRC32 的使用

声明为 CRC32 的 java.util.zip 中的字段
protected CRC32 | GZIPOutputStream.crc 未压缩数据的 CRC-32 。
protected CRC32 | GZIPInputStream.crc 未压缩数据的 CRC-32。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.zip.Checksum 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.zip.Checksum
的使用

使用 Checksum 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 Checksum 的使用

实现 Checksum 的 java.util.zip 中的类
class | Adler32 可用于计算数据流的 Adler-32 校验和的类。
class | CRC32 可用于计算数据流的 CRC-32 的类。

返回 Checksum 的 java.util.zip 中的方法
Checksum | CheckedInputStream.getChecksum() 返回此输入流的校验和。
Checksum | CheckedOutputStream.getChecksum() 返回此输出流的校验和。

参数类型为 Checksum 的 java.util.zip 中的构造方法
CheckedInputStream(InputStream in, Checksum cksum)
使用指定校验和创建输入流。
CheckedOutputStream(OutputStream out, Checksum cksum)
使用指定校验和创建输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.ZipInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipInputStream
的使用

使用 ZipInputStream 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 ZipInputStream 的使用

java.util.jar 中 ZipInputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.Inflater 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.Inflater
的使用

使用 Inflater 的软件包
java.util.zip 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.zip 中 Inflater 的使用

声明为 Inflater 的 java.util.zip 中的字段
protected Inflater | InflaterOutputStream.inf 此流的解压缩器。
protected Inflater | InflaterInputStream.inf 流的解压缩器。

参数类型为 Inflater 的 java.util.zip 中的构造方法
InflaterInputStream(InputStream in, Inflater inf)
创建一个带有指定解压缩器和默认缓冲区大小的新输入流。
InflaterInputStream(InputStream in, Inflater inf, int size)
使用指定解压缩器和缓冲区大小创建一个新输入流。
InflaterOutputStream(OutputStream out, Inflater infl)
创建一个带有指定解压缩器和默认缓冲区大小的新输出流。
InflaterOutputStream(OutputStream out, Inflater infl, int bufLen)
创建一个带有指定解压缩器和缓冲区大小的新输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.InflaterInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.InflaterInputStream
的使用

使用 InflaterInputStream 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 InflaterInputStream 的使用

java.util.jar 中 InflaterInputStream 的子类
 class JarInputStream
JarInputStream 类用于从任何输入流读取 JAR 文件内容。

java.util.zip 中 InflaterInputStream 的使用

java.util.zip 中 InflaterInputStream 的子类
class | GZIPInputStream 此类为读取 GZIP 文件格式的压缩数据实现流过滤器。
class | ZipInputStream 此类为读取 ZIP 文件格式的文件实现输入流过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.ZipEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipEntry
的使用

使用 ZipEntry 的软件包
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。

java.util.jar 中 ZipEntry 的使用

java.util.jar 中 ZipEntry 的子类
 class JarEntry
此类用于表示 JAR 文件条目。

返回 ZipEntry 的 java.util.jar 中的方法
protected ZipEntry | JarInputStream.createZipEntry(String name) 为指定的 JAR 文件条目名称创建新的 JarEntry (ZipEntry)。
ZipEntry | JarFile.getEntry(String name) 返回给定条目名称的 ZipEntry；如果未找到，则返回 null。
ZipEntry | JarInputStream.getNextEntry() 读取下一个 ZIP 文件条目，并将流定位于此条目数据的开始处。

参数类型为 ZipEntry 的 java.util.jar 中的方法
InputStream | JarFile.getInputStream(ZipEntry ze) 返回用于读取指定 zip 文件条目内容的输入流。
void | JarOutputStream.putNextEntry(ZipEntry ze) 开始写入新的 JAR 文件条目，并将流定位到条目数据的开始处。

参数类型为 ZipEntry 的 java.util.jar 中的构造方法
JarEntry(ZipEntry ze)
使用从指定 ZipEntry 对象获取的字段创建新的 JarEntry。

java.util.zip 中 ZipEntry 的使用

返回 ZipEntry 的 java.util.zip 中的方法
protected ZipEntry | ZipInputStream.createZipEntry(String name) 为指定条目名称创建一个新的 ZipEntry 对象。
ZipEntry | ZipFile.getEntry(String name) 返回指定名称的 ZIP 文件条目；如果未找到，则返回 null。
ZipEntry | ZipInputStream.getNextEntry() 读取下一个 ZIP 文件条目并将流定位到该条目数据的开始处。

返回变量类型为 ZipEntry 的类型的 java.util.zip 中的方法
 Enumeration<? extends ZipEntry> ZipFile.entries()
返回 ZIP 文件条目的枚举。

参数类型为 ZipEntry 的 java.util.zip 中的方法
InputStream | ZipFile.getInputStream(ZipEntry entry) 返回输入流以读取指定 ZIP 文件条目的内容。
void | ZipOutputStream.putNextEntry(ZipEntry e) 开始写入新的 ZIP 文件条目并将流定位到条目数据的开始处。

参数类型为 ZipEntry 的 java.util.zip 中的构造方法
ZipEntry(ZipEntry e)
使用从指定 ZIP 条目获取的字段创建新的 ZIP 条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.zip.ZipFile 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.zip.ZipFile
的使用

使用 ZipFile 的软件包
java.util.jar 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.util.jar 中 ZipFile 的使用

java.util.jar 中 ZipFile 的子类
 class JarFile
JarFile 类用于从任何可以使用 java.io.RandomAccessFile 打开的文件中读取 jar 文件的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractQueue
的使用

使用 AbstractQueue 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 AbstractQueue 的使用

java.util 中 AbstractQueue 的子类
 class PriorityQueue<E>
一个基于优先级堆的无界优先级队列。

java.util.concurrent 中 AbstractQueue 的使用

java.util.concurrent 中 AbstractQueue 的子类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ArrayDeque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ArrayDeque
的使用

使用 ArrayDeque 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 ArrayDeque 的使用

返回 ArrayDeque 的 java.util 中的方法
 ArrayDeque<E> ArrayDeque.clone()
返回此双端队列的副本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ConcurrentModificationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ConcurrentModificationException
的使用

没有 java.util.ConcurrentModificationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.DuplicateFormatFlagsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.DuplicateFormatFlagsException
的使用

没有 java.util.DuplicateFormatFlagsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.EnumMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EnumMap
的使用

使用 EnumMap 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 EnumMap 的使用

返回 EnumMap 的 java.util 中的方法
 EnumMap<K,V> EnumMap.clone()
返回此枚举映射的浅表副本。

参数类型为 EnumMap 的 java.util 中的构造方法
EnumMap(EnumMap<K,? extends V> m)
创建一个其键类型与指定枚举映射相同的枚举映射，最初包含相同的映射关系（如果有的话）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.EnumSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EnumSet
的使用

使用 EnumSet 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 EnumSet 的使用

返回 EnumSet 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.allOf(Class<E> elementType)
创建一个包含指定元素类型的所有元素的枚举 set。
 EnumSet<E> EnumSet.clone()
返回 set 的副本。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.noneOf(Class<E> elementType)
创建一个具有指定元素类型的空枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E first, E... rest)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.of(E e1, E e2, E e3, E e4, E e5)
创建一个最初包含指定元素的枚举 set。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.range(E from, E to)
创建一个最初包含由两个指定端点所定义范围内的所有元素的枚举 set。

参数类型为 EnumSet 的 java.util 中的方法
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.complementOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含指定 set 中所不 包含的此类型的所有元素。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(EnumSet<E> s)
创建一个其元素类型与指定枚举 set 相同的枚举 set，最初包含相同的元素（如果有的话）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.FormatFlagsConversionMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.FormatFlagsConversionMismatchException
的使用

没有 java.util.FormatFlagsConversionMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Formattable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Formattable
的使用

没有 java.util.Formattable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.FormattableFlags 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.FormattableFlags
的使用

没有 java.util.FormattableFlags 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Formatter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Formatter
的使用

使用 Formatter 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Formatter 的使用

返回 Formatter 的 java.util 中的方法
Formatter | Formatter.format(Locale l, String format, Object... args) 使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。
Formatter | Formatter.format(String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此对象的目标文件中。

参数类型为 Formatter 的 java.util 中的方法
 void Formattable.formatTo(Formatter formatter, int flags, int width, int precision)
使用提供的格式器来格式化对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Formatter.BigDecimalLayoutForm 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Formatter.BigDecimalLayoutForm
的使用

使用 Formatter.BigDecimalLayoutForm 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Formatter.BigDecimalLayoutForm 的使用

返回 Formatter.BigDecimalLayoutForm 的 java.util 中的方法
static Formatter.BigDecimalLayoutForm | Formatter.BigDecimalLayoutForm.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Formatter.BigDecimalLayoutForm[] | Formatter.BigDecimalLayoutForm.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.FormatterClosedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.FormatterClosedException
的使用

没有 java.util.FormatterClosedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.IllegalFormatCodePointException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatCodePointException
的使用

没有 java.util.IllegalFormatCodePointException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Observable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Observable
的使用

使用 Observable 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Observable 的使用

参数类型为 Observable 的 java.util 中的方法
 void Observer.update(Observable o, Object arg)
只要改变了 observable 对象就调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.IllegalFormatConversionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatConversionException
的使用

没有 java.util.IllegalFormatConversionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.IllegalFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatException
的使用

使用 IllegalFormatException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 IllegalFormatException 的使用

java.util 中 IllegalFormatException 的子类
class | DuplicateFormatFlagsException 格式说明符中提供重复标志时抛出的未经检查的异常。
class | FormatFlagsConversionMismatchException 转换与标志不兼容时抛出未经检查的异常。
class | IllegalFormatCodePointException 将具有 Character.isValidCodePoint(int) 所定义的无效 Unicode 代码点的字符传递给 Formatter 时，抛出未经检查的异常。
class | IllegalFormatConversionException 当对应于格式说明符的参数为不兼容的类型时，抛出未经检查的异常。
class | IllegalFormatFlagsException 当给出非法组合标志时，抛出未经检查的异常。
class | IllegalFormatPrecisionException 当精度为除 -1 以外的负值、转换类型不支持某个精度或者值在其他方面不受支持时，将抛出未经检查的异常。
class | IllegalFormatWidthException 当格式宽度为除 -1 以外的负值或其他不受支持的值时，将抛出未经检查的异常。
class | MissingFormatArgumentException 如果格式说明符没有相应的参数，或者参数索引引用了不存在的参数时，则抛出未经检查的异常。
class | MissingFormatWidthException 请求格式宽度时抛出未经检查的异常。
class | UnknownFormatConversionException 给定未知的转换时所抛出的未经检查的异常。
class | UnknownFormatFlagsException 给定未知标志时所抛出的未经检查的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.IllegalFormatFlagsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatFlagsException
的使用

没有 java.util.IllegalFormatFlagsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.IllegalFormatPrecisionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatPrecisionException
的使用

没有 java.util.IllegalFormatPrecisionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.IllegalFormatWidthException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IllegalFormatWidthException
的使用

没有 java.util.IllegalFormatWidthException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.InputMismatchException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.InputMismatchException
的使用

没有 java.util.InputMismatchException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.InvalidPropertiesFormatException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.InvalidPropertiesFormatException
的使用

使用 InvalidPropertiesFormatException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 InvalidPropertiesFormatException 的使用

抛出 InvalidPropertiesFormatException 的 java.util 中的方法
 void Properties.loadFromXML(InputStream in)
将指定输入流中由 XML 文档所表示的所有属性加载到此属性表中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.MissingFormatArgumentException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.MissingFormatArgumentException
的使用

没有 java.util.MissingFormatArgumentException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.MissingFormatWidthException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.MissingFormatWidthException
的使用

没有 java.util.MissingFormatWidthException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.NoSuchElementException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.NoSuchElementException
的使用

使用 NoSuchElementException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 NoSuchElementException 的使用

java.util 中 NoSuchElementException 的子类
 class InputMismatchException
由 Scanner 抛出，表明获取的标记与期望类型的模式不匹配，或者该标记超出期望类型的范围。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Observer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Observer
的使用

使用 Observer 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Observer 的使用

参数类型为 Observer 的 java.util 中的方法
void | Observable.addObserver(Observer o) 如果观察者与集合中已有的观察者不同，则向对象的观察者集中添加此观察者。
void | Observable.deleteObserver(Observer o) 从对象的观察者集合中删除某个观察者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.PriorityQueue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.PriorityQueue
的使用

使用 PriorityQueue 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 PriorityQueue 的使用

参数类型为 PriorityQueue 的 java.util 中的构造方法
PriorityQueue(PriorityQueue<? extends E> c)
创建包含指定优先级队列元素的 PriorityQueue。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Scanner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Scanner
的使用

使用 Scanner 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 Scanner 的使用

返回 Scanner 的 java.util 中的方法
Scanner | Scanner.reset() 重置此扫描器。
Scanner | Scanner.skip(Pattern pattern) 在忽略分隔符的情况下跳过与指定模式匹配的输入信息。
Scanner | Scanner.skip(String pattern) 跳过与从指定字符串构造的模式匹配的输入信息。
Scanner | Scanner.useDelimiter(Pattern pattern) 将此扫描器的分隔模式设置为指定模式。
Scanner | Scanner.useDelimiter(String pattern) 将此扫描器的分隔模式设置为从指定 String 构造的模式。
Scanner | Scanner.useLocale(Locale locale) 将此扫描器的语言环境设置为指定的语言环境。
Scanner | Scanner.useRadix(int radix) 将此扫描器的默认基数设置为指定基数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ServiceConfigurationError 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ServiceConfigurationError
的使用

没有 java.util.ServiceConfigurationError 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ServiceLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ServiceLoader
的使用

使用 ServiceLoader 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 ServiceLoader 的使用

返回 ServiceLoader 的 java.util 中的方法
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service)
针对给定服务类型创建新的服务加载器，使用当前线程的上下文类加载器。
static
<S> ServiceLoader<S>
ServiceLoader.load(Class<S> service, ClassLoader loader)
针对给定服务类型和类加载器创建新的服务加载器。
static
<S> ServiceLoader<S>
ServiceLoader.loadInstalled(Class<S> service)
针对给定服务类型创建新的服务加载器，使用扩展类加载器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.SimpleTimeZone 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.SimpleTimeZone
的使用

没有 java.util.SimpleTimeZone 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Timer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Timer
的使用

没有 java.util.Timer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.TimerTask 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TimerTask
的使用

使用 TimerTask 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 TimerTask 的使用

参数类型为 TimerTask 的 java.util 中的方法
void | Timer.schedule(TimerTask task, Date time) 安排在指定的时间执行指定的任务。
void | Timer.schedule(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定延迟执行。
void | Timer.schedule(TimerTask task, long delay) 安排在指定延迟后执行指定的任务。
void | Timer.schedule(TimerTask task, long delay, long period) 安排指定的任务从指定的延迟后开始进行重复的固定延迟执行。
void | Timer.scheduleAtFixedRate(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定速率执行。
void | Timer.scheduleAtFixedRate(TimerTask task, long delay, long period) 安排指定的任务在指定的延迟后开始进行重复的固定速率执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.TooManyListenersException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TooManyListenersException
的使用

使用 TooManyListenersException 的软件包
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。

java.awt.dnd 中 TooManyListenersException 的使用

抛出 TooManyListenersException 的 java.awt.dnd 中的方法
void | DragGestureRecognizer.addDragGestureListener(DragGestureListener dgl) 注册一个新的 DragGestureListener。
void | DragSourceContext.addDragSourceListener(DragSourceListener dsl) 如果尚未将 DragSourceListener 添加到此 DragSourceContext，则添加一个。
void | DropTarget.addDropTargetListener(DropTargetListener dtl) 添加一个新的 DropTargetListener (UNICAST SOURCE)。

java.beans.beancontext 中 TooManyListenersException 的使用

抛出 TooManyListenersException 的 java.beans.beancontext 中的方法
Object | BeanContextServices.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) BeanContextChild（或任意与 BeanContextChild 关联的对象）可以通过调用此方法从其嵌套 BeanContextServices 中获得对当前已注册服务的引用。
Object | BeanContextServicesSupport.getService(BeanContextChild child, Object requestor, Class serviceClass, Object serviceSelector, BeanContextServiceRevokedListener bcsrl) 获得一个可被委托的服务。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.UUID 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.UUID
的使用

使用 UUID 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 UUID 的使用

返回 UUID 的 java.util 中的方法
static UUID UUID.fromString(String name)
根据 toString() 方法中描述的字符串标准表示形式创建 UUID。
static UUID UUID.nameUUIDFromBytes(byte[] name)
根据指定的字节数组获取类型 3（基于名称的）UUID 的静态工厂。
static UUID UUID.randomUUID()
获取类型 4（伪随机生成的）UUID 的静态工厂。

参数类型为 UUID 的 java.util 中的方法
 int UUID.compareTo(UUID val)
将此 UUID 与指定的 UUID 比较。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.UnknownFormatConversionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.UnknownFormatConversionException
的使用

没有 java.util.UnknownFormatConversionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.UnknownFormatFlagsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.UnknownFormatFlagsException
的使用

没有 java.util.UnknownFormatFlagsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.PropertyPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.PropertyPermission
的使用

没有 java.util.PropertyPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Currency 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Currency
的使用

使用 Currency 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.text 中 Currency 的使用

返回 Currency 的 java.text 中的方法
Currency | DecimalFormat.getCurrency() 获取格式化货币值时，此十进制格式使用的货币。
Currency | DecimalFormatSymbols.getCurrency() 获得这些 DecimalFormatSymbols 的货币。
Currency | NumberFormat.getCurrency() 获取格式化货币值时此数值格式使用的货币。

参数类型为 Currency 的 java.text 中的方法
void | DecimalFormat.setCurrency(Currency currency) 设置格式化货币值时，此数字格式使用的货币。
void | DecimalFormatSymbols.setCurrency(Currency currency) 设置这些 DecimalFormatSymbols 的货币。
void | NumberFormat.setCurrency(Currency currency) 设置格式化货币值时此数值格式使用的货币。

java.util 中 Currency 的使用

返回 Currency 的 java.util 中的方法
static Currency | Currency.getInstance(Locale locale) 返回给定语言环境的国家/地区的 Currency 实例。
static Currency | Currency.getInstance(String currencyCode) 返回给定货币代码的 Currency 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.GregorianCalendar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.GregorianCalendar
的使用

使用 GregorianCalendar 的软件包
javax.xml.datatype XML/Java 类型映射关系。

javax.xml.datatype 中 GregorianCalendar 的使用

返回 GregorianCalendar 的 javax.xml.datatype 中的方法
abstract GregorianCalendar | XMLGregorianCalendar.toGregorianCalendar() 将此 XMLGregorianCalendar 转换为 GregorianCalendar。
abstract GregorianCalendar | XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults) 将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

参数类型为 GregorianCalendar 的 javax.xml.datatype 中的方法
abstract  XMLGregorianCalendar DatatypeFactory.newXMLGregorianCalendar(GregorianCalendar cal)
根据 GregorianCalendar 创建 XMLGregorianCalendar。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Calendar 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Calendar
的使用

使用 Calendar 的软件包
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.datatype | XML/Java 类型映射关系。

java.sql 中 Calendar 的使用

参数类型为 Calendar 的 java.sql 中的方法
Date | CallableStatement.getDate(int parameterIndex, Calendar cal) 以 java.sql.Date 对象的形式获取指定 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Date | CallableStatement.getDate(String parameterName, Calendar cal) 以 java.sql.Date 对象的形式获取 JDBC DATE 参数的值，使用给定 Calendar 对象构造日期。
Date | ResultSet.getDate(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Date 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(int parameterIndex, Calendar cal) 以 java.sql.Time 对象的形式获取指定 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Time | CallableStatement.getTime(String parameterName, Calendar cal) 以 java.sql.Time 对象的形式获取 JDBC TIME 参数的值，使用给定 Calendar 对象构造时间。
Time | ResultSet.getTime(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Time 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(int parameterIndex, Calendar cal) 以 java.sql.Timestamp 对象的形式获取指定 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(int columnIndex, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
Timestamp | CallableStatement.getTimestamp(String parameterName, Calendar cal) 以 java.sql.Timestamp 对象的形式获取 JDBC TIMESTAMP 参数的值，使用给定 Calendar 对象构造 Timestamp 对象。
Timestamp | ResultSet.getTimestamp(String columnLabel, Calendar cal) 以 Java 编程语言中 java.sql.Timestamp 对象的形式获取此 ResultSet 对象的当前行中指定列的值。
void | PreparedStatement.setDate(int parameterIndex, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | CallableStatement.setDate(String parameterName, Date x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Date 值。
void | PreparedStatement.setTime(int parameterIndex, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | CallableStatement.setTime(String parameterName, Time x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Time 值。
void | PreparedStatement.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。
void | CallableStatement.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定的 Calendar 对象将指定参数设置为给定 java.sql.Timestamp 值。

java.text 中 Calendar 的使用

声明为 Calendar 的 java.text 中的字段
protected  Calendar DateFormat.calendar
DateFormat 使用 calendar 来生成实现日期和时间格式化所需的时间字段值。

返回 Calendar 的 java.text 中的方法
 Calendar DateFormat.getCalendar()
获取与此日期/时间格式器关联的日历。

参数类型为 Calendar 的 java.text 中的方法
 void DateFormat.setCalendar(Calendar newCalendar)
设置此日期格式所使用的日历。

java.util 中 Calendar 的使用

java.util 中 Calendar 的子类
 class GregorianCalendar
GregorianCalendar 是 Calendar 的一个具体子类，提供了世界上大多数国家/地区使用的标准日历系统。

返回 Calendar 的 java.util 中的方法
static Calendar | Calendar.getInstance() 使用默认时区和语言环境获得一个日历。
static Calendar | Calendar.getInstance(Locale aLocale) 使用默认时区和指定语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone) 使用指定时区和默认语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone, Locale aLocale) 使用指定时区和语言环境获得一个日历。

参数类型为 Calendar 的 java.util 中的方法
 int Calendar.compareTo(Calendar anotherCalendar)
比较两个 Calendar 对象表示的时间值（从历元至现在的毫秒偏移量）。

javax.sql 中 Calendar 的使用

参数类型为 Calendar 的 javax.sql 中的方法
void | RowSet.setDate(int parameterIndex, Date x, Calendar cal) 使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | RowSet.setTime(int parameterIndex, Time x, Calendar cal) 使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | RowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
void | RowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.sql.rowset 中 Calendar 的使用

参数类型为 Calendar 的 javax.sql.rowset 中的方法
void | BaseRowSet.setDate(int parameterIndex, Date x, Calendar cal) 将指定参数设置为给定的 java.sql.Date 对象。
void | BaseRowSet.setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | BaseRowSet.setTime(int parameterIndex, Time x, Calendar cal) 将指定参数设置为给定的 java.sql.Time 对象。
void | BaseRowSet.setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | BaseRowSet.setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 将指定参数设置为给定的 java.sql.Timestamp 对象。
void | BaseRowSet.setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。

javax.xml.bind 中 Calendar 的使用

返回 Calendar 的 javax.xml.bind 中的方法
static Calendar | DatatypeConverter.parseDate(String lexicalXSDDate) 将字符串参数转换为一个 Calendar 值。
Calendar | DatatypeConverterInterface.parseDate(String lexicalXSDDate) 将字符串参数转换为一个 Calendar 值。
static Calendar | DatatypeConverter.parseDateTime(String lexicalXSDDateTime) 将字符串参数转换为一个 Calendar 值。
Calendar | DatatypeConverterInterface.parseDateTime(String lexicalXSDDateTime) 将字符串参数转换为一个 Calendar 值。
static Calendar | DatatypeConverter.parseTime(String lexicalXSDTime) 将字符串参数转换为一个 Calendar 值。
Calendar | DatatypeConverterInterface.parseTime(String lexicalXSDTime) 将字符串参数转换为一个 Calendar 值。

参数类型为 Calendar 的 javax.xml.bind 中的方法
static String | DatatypeConverter.printDate(Calendar val) 将 Calendar 值转换为一个字符串。
String | DatatypeConverterInterface.printDate(Calendar val) 将 Calendar 值转换为一个字符串。
static String | DatatypeConverter.printDateTime(Calendar val) 将 Calendar 值转换为一个字符串。
String | DatatypeConverterInterface.printDateTime(Calendar val) 将 Calendar 值转换为一个字符串。
static String | DatatypeConverter.printTime(Calendar val) 将 Calendar 值转换为一个字符串。
String | DatatypeConverterInterface.printTime(Calendar val) 将 Calendar 值转换为一个字符串。

javax.xml.datatype 中 Calendar 的使用

参数类型为 Calendar 的 javax.xml.datatype 中的方法
abstract void | Duration.addTo(Calendar calendar) 将此持续时间添加到 Calendar 对象。
long | Duration.getTimeInMillis(Calendar startInstant) 返回以毫秒为单位的持续时间的长度。
abstract Duration | Duration.normalizeWith(Calendar startTimeInstant) 通过使用特定的时间点作为参考点，将 years 和 months 字段转换为 days 字段。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.PropertyResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.PropertyResourceBundle
的使用

没有 java.util.PropertyResourceBundle 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Random 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Random
的使用

使用 Random 的软件包
java.math | 提供用于执行任意精度整数算法 (BigInteger) 和任意精度小数算法 (BigDecimal) 的类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.math 中 Random 的使用

参数类型为 Random 的 java.math 中的方法
static BigInteger BigInteger.probablePrime(int bitLength, Random rnd)
返回有可能是素数的、具有指定长度的正 BigInteger。

参数类型为 Random 的 java.math 中的构造方法
BigInteger(int bitLength, int certainty, Random rnd)
构造一个随机生成的正 BigInteger，它可能是一个具有指定 bitLength 的素数。
BigInteger(int numBits, Random rnd)
构造一个随机生成的 BigInteger，它是在 0 到 (2numBits - 1)（包括）范围内均匀分布的值。

java.security 中 Random 的使用

java.security 中 Random 的子类
 class SecureRandom
此类提供强加密随机数生成器 (RNG)。

java.util 中 Random 的使用

参数类型为 Random 的 java.util 中的方法
static void Collections.shuffle(List<?> list, Random rnd)
使用指定的随机源对指定列表进行置换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.TreeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TreeSet
的使用

没有 java.util.TreeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.NavigableSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.NavigableSet
的使用

使用 NavigableSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 NavigableSet 的使用

实现 NavigableSet 的 java.util 中的类
 class TreeSet<E>
基于 TreeMap 的 NavigableSet 实现。

返回 NavigableSet 的 java.util 中的方法
NavigableSet<K> | TreeMap.descendingKeySet()
NavigableSet<K> | NavigableMap.descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
NavigableSet<E> | TreeSet.descendingSet()
NavigableSet<E> | NavigableSet.descendingSet() 返回此 set 中所包含元素的逆序视图。
NavigableSet<E> | TreeSet.headSet(E toElement, boolean inclusive)
NavigableSet<E> | NavigableSet.headSet(E toElement, boolean inclusive) 返回此 set 的部分视图，其元素小于（或等于，如果 inclusive 为 true）toElement。
NavigableSet<K> | TreeMap.navigableKeySet()
NavigableSet<K> | NavigableMap.navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<E> | TreeSet.subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
NavigableSet<E> | NavigableSet.subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive) 返回此 set 的部分视图，其元素范围从 fromElement 到 toElement。
NavigableSet<E> | TreeSet.tailSet(E fromElement, boolean inclusive)
NavigableSet<E> | NavigableSet.tailSet(E fromElement, boolean inclusive) 返回此 set 的部分视图，其元素大于（或等于，如果 inclusive 为 true）fromElement。

java.util.concurrent 中 NavigableSet 的使用

实现 NavigableSet 的 java.util.concurrent 中的类
 class ConcurrentSkipListSet<E>
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。

返回 NavigableSet 的 java.util.concurrent 中的方法
NavigableSet<K> | ConcurrentNavigableMap.descendingKeySet() 返回此映射中所包含键的逆序 NavigableSet 视图。
NavigableSet<K> | ConcurrentSkipListMap.descendingKeySet()
NavigableSet<E> | ConcurrentSkipListSet.descendingSet() 返回此 set 中所包含元素的逆序视图。
NavigableSet<E> | ConcurrentSkipListSet.headSet(E toElement)
NavigableSet<E> | ConcurrentSkipListSet.headSet(E toElement, boolean inclusive)
NavigableSet<K> | ConcurrentNavigableMap.keySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<K> | ConcurrentSkipListMap.keySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<K> | ConcurrentNavigableMap.navigableKeySet() 返回此映射中所包含键的 NavigableSet 视图。
NavigableSet<K> | ConcurrentSkipListMap.navigableKeySet()
NavigableSet<E> | ConcurrentSkipListSet.subSet(E fromElement, boolean fromInclusive, E toElement, boolean toInclusive)
NavigableSet<E> | ConcurrentSkipListSet.subSet(E fromElement, E toElement)
NavigableSet<E> | ConcurrentSkipListSet.tailSet(E fromElement)
NavigableSet<E> | ConcurrentSkipListSet.tailSet(E fromElement, boolean inclusive)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.SortedSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.SortedSet
的使用

使用 SortedSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 SortedSet 的使用

java.util 中 SortedSet 的子接口
 interface NavigableSet<E>
扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。

实现 SortedSet 的 java.util 中的类
 class TreeSet<E>
基于 TreeMap 的 NavigableSet 实现。

返回 SortedSet 的 java.util 中的方法
static
<E> SortedSet<E>
Collections.checkedSortedSet(SortedSet<E> s, Class<E> type)
返回指定有序 set 的一个动态类型安全视图。
 SortedSet<E> TreeSet.headSet(E toElement)
 SortedSet<E> NavigableSet.headSet(E toElement)
返回此 set 的部分视图，其元素严格小于 toElement。
 SortedSet<E> SortedSet.headSet(E toElement)
返回此 set 的部分视图，其元素严格小于 toElement。
 SortedSet<E> TreeSet.subSet(E fromElement, E toElement)
 SortedSet<E> NavigableSet.subSet(E fromElement, E toElement)
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
 SortedSet<E> SortedSet.subSet(E fromElement, E toElement)
返回此 set 的部分视图，其元素从 fromElement（包括）到 toElement（不包括）。
static
<T> SortedSet<T>
Collections.synchronizedSortedSet(SortedSet<T> s)
返回指定有序 set 支持的同步（线程安全的）有序 set。
 SortedSet<E> TreeSet.tailSet(E fromElement)
 SortedSet<E> NavigableSet.tailSet(E fromElement)
返回此 set 的部分视图，其元素大于等于 fromElement。
 SortedSet<E> SortedSet.tailSet(E fromElement)
返回此 set 的部分视图，其元素大于等于 fromElement。
static
<T> SortedSet<T>
Collections.unmodifiableSortedSet(SortedSet<T> s)
返回指定有序 set 的不可修改视图。

参数类型为 SortedSet 的 java.util 中的方法
static
<E> SortedSet<E>
Collections.checkedSortedSet(SortedSet<E> s, Class<E> type)
返回指定有序 set 的一个动态类型安全视图。
static
<T> SortedSet<T>
Collections.synchronizedSortedSet(SortedSet<T> s)
返回指定有序 set 支持的同步（线程安全的）有序 set。
static
<T> SortedSet<T>
Collections.unmodifiableSortedSet(SortedSet<T> s)
返回指定有序 set 的不可修改视图。

参数类型为 SortedSet 的 java.util 中的构造方法
PriorityQueue(SortedSet<? extends E> c)
创建包含指定有序 set 元素的 PriorityQueue。
TreeSet(SortedSet<E> s)
构造一个与指定有序 set 具有相同映射关系和相同排序的新 TreeSet。

java.util.concurrent 中 SortedSet 的使用

实现 SortedSet 的 java.util.concurrent 中的类
 class ConcurrentSkipListSet<E>
一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。

参数类型为 SortedSet 的 java.util.concurrent 中的构造方法
ConcurrentSkipListSet(SortedSet<E> s)
构造一个新 set，该 set 所包含的元素与指定的有序 set 包含的元素相同，使用的顺序也相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.LinkedHashSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.LinkedHashSet
的使用

没有 java.util.LinkedHashSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.TimeZone 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TimeZone
的使用

使用 TimeZone 的软件包
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.xml.datatype | XML/Java 类型映射关系。

java.text 中 TimeZone 的使用

返回 TimeZone 的 java.text 中的方法
 TimeZone DateFormat.getTimeZone()
获取时区。

参数类型为 TimeZone 的 java.text 中的方法
 void DateFormat.setTimeZone(TimeZone zone)
为此 DateFormat 对象的日历设置时区。

java.util 中 TimeZone 的使用

java.util 中 TimeZone 的子类
 class SimpleTimeZone
SimpleTimeZone 是 TimeZone 的具体子类，表示一个使用格里高利历的时区。

返回 TimeZone 的 java.util 中的方法
static TimeZone | TimeZone.getDefault() 获取此主机的默认 TimeZone。
TimeZone | GregorianCalendar.getTimeZone()
TimeZone | Calendar.getTimeZone() 获得时区。
static TimeZone | TimeZone.getTimeZone(String ID) 获取给定 ID 的 TimeZone。

参数类型为 TimeZone 的 java.util 中的方法
static Calendar | Calendar.getInstance(TimeZone zone) 使用指定时区和默认语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone, Locale aLocale) 使用指定时区和语言环境获得一个日历。
boolean | SimpleTimeZone.hasSameRules(TimeZone other) 如果此时区与另一时区具有相同的规则和偏移量，则返回 true。
boolean | TimeZone.hasSameRules(TimeZone other) 如果此区域和另一个区域具有相同的规则和偏移量，也就是说，如果此区域只可能在 ID 上与另一个区域不同，则返回 true。
static void | TimeZone.setDefault(TimeZone zone) 设置由 getDefault 方法返回的 TimeZone。
void | GregorianCalendar.setTimeZone(TimeZone zone)
void | Calendar.setTimeZone(TimeZone value) 使用给定的时区值来设置时区。

参数类型为 TimeZone 的 java.util 中的构造方法
Calendar(TimeZone zone, Locale aLocale)
构造一个带有指定时区和语言环境的 Calendar。
GregorianCalendar(TimeZone zone)
在具有默认语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone zone, Locale aLocale)
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。

javax.xml.datatype 中 TimeZone 的使用

返回 TimeZone 的 javax.xml.datatype 中的方法
abstract  TimeZone XMLGregorianCalendar.getTimeZone(int defaultZoneoffset)
返回此类的 java.util.TimeZone。

参数类型为 TimeZone 的 javax.xml.datatype 中的方法
abstract  GregorianCalendar XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Date 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Date
的使用

使用 Date 的软件包
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.cert | 为公钥证书提供类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.datatype | XML/Java 类型映射关系。

java.security 中 Date 的使用

返回 Date 的 java.security 中的方法
abstract Date | KeyStoreSpi.engineGetCreationDate(String alias) 返回该别名标识的项的创建日期。
Date | KeyStore.getCreationDate(String alias) 返回给定别名标识的条目的创建日期。
Date | Timestamp.getTimestamp() 返回生成时间戳时的日期和时间。

参数类型为 Date 的 java.security 中的构造方法
Timestamp(Date timestamp, CertPath signerCertPath)
构造一个时间戳。

java.security.cert 中 Date 的使用

返回 Date 的 java.security.cert 中的方法
Date | X509CertSelector.getCertificateValid() 返回 certificateValid 标准。
Date | PKIXParameters.getDate() 返回应该确定证书路径有效性的时间。
Date | X509CRLSelector.getDateAndTime() 返回 dateAndTime 标准。
abstract Date | X509CRL.getNextUpdate() 获取 CRL 的 nextUpdate 日期。
abstract Date | X509Certificate.getNotAfter() 获取证书有效期的 notAfter 日期。
abstract Date | X509Certificate.getNotBefore() 获取证书有效期的 notBefore 日期。
Date | X509CertSelector.getPrivateKeyValid() 返回 privateKeyValid 标准。
abstract Date | X509CRLEntry.getRevocationDate() 获取此 X509CRLEntry 的撤消日期 revocationDate。
abstract Date | X509CRL.getThisUpdate() 获取 CRL 的 thisUpdate 日期。

参数类型为 Date 的 java.security.cert 中的方法
abstract void | X509Certificate.checkValidity(Date date) 检查给定的日期是否处于证书的有效期内。
void | X509CertSelector.setCertificateValid(Date certValid) 设置 certificateValid 标准。
void | PKIXParameters.setDate(Date date) 设置应该确定证书路径有效性的时间。
void | X509CRLSelector.setDateAndTime(Date dateAndTime) 设置 dateAndTime 标准。
void | X509CertSelector.setPrivateKeyValid(Date privateKeyValid) 设置 privateKeyValid 标准。

java.sql 中 Date 的使用

java.sql 中 Date 的子类
class | Date 一个包装了毫秒值的瘦包装器 (thin wrapper)，它允许 JDBC 将毫秒值标识为 SQL DATE 值。
class | Time 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC 将该类标识为 SQL TIME 值。
class | Timestamp 一个与 java.util.Date 类有关的瘦包装器 (thin wrapper)，它允许 JDBC API 将该类标识为 SQL TIMESTAMP 值。

参数类型为 Date 的 java.sql 中的方法
 int Timestamp.compareTo(Date o)
将此 Timestamp 对象与给定的 Date（必须为 Timestamp 对象）相比较。

java.text 中 Date 的使用

返回 Date 的 java.text 中的方法
Date | SimpleDateFormat.get2DigitYearStart() 返回在 100 年周期内被解释的两位数字年份的开始日期。
Date | DateFormat.parse(String source) 从给定字符串的开始解析文本，以生成一个日期。
Date | SimpleDateFormat.parse(String text, ParsePosition pos) 解析字符串的文本，生成 Date。
abstract Date | DateFormat.parse(String source, ParsePosition pos) 根据给定的解析位置开始解析日期/时间字符串。

参数类型为 Date 的 java.text 中的方法
String | DateFormat.format(Date date) 将一个 Date 格式化为日期/时间字符串。
StringBuffer | SimpleDateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition pos) 将给定的 Date 格式化为日期/时间字符串，并将结果添加到给定的 StringBuffer。
abstract StringBuffer | DateFormat.format(Date date, StringBuffer toAppendTo, FieldPosition fieldPosition) 将一个 Date 格式化为日期/时间字符串。
void | SimpleDateFormat.set2DigitYearStart(Date startDate) 设置 100 年周期的两位数年份，该年份将被解释为从用户指定的日期开始。

java.util 中 Date 的使用

返回 Date 的 java.util 中的方法
Date | GregorianCalendar.getGregorianChange() 获得格里高利历的更改日期。
Date | Calendar.getTime() 返回一个表示此 Calendar 时间值（从历元至现在的毫秒偏移量）的 Date 对象。

参数类型为 Date 的 java.util 中的方法
boolean | Date.after(Date when) 测试此日期是否在指定日期之后。
boolean | Date.before(Date when) 测试此日期是否在指定日期之前。
int | Date.compareTo(Date anotherDate) 比较两个日期的顺序。
boolean | SimpleTimeZone.inDaylightTime(Date date) 如果给定日期在夏令时期间，则执行查询。
abstract boolean | TimeZone.inDaylightTime(Date date) 查询给定的日期是否在此时区的夏令时中。
void | Timer.schedule(TimerTask task, Date time) 安排在指定的时间执行指定的任务。
void | Timer.schedule(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定延迟执行。
void | Timer.scheduleAtFixedRate(TimerTask task, Date firstTime, long period) 安排指定的任务在指定的时间开始进行重复的固定速率执行。
void | GregorianCalendar.setGregorianChange(Date date) 设置 GregorianCalendar 的更改日期。
void | Calendar.setTime(Date date) 使用给定的 Date 设置此 Calendar 的时间。

java.util.concurrent.locks 中 Date 的使用

参数类型为 Date 的 java.util.concurrent.locks 中的方法
boolean | AbstractQueuedLongSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。
boolean | Condition.awaitUntil(Date deadline) 造成当前线程在接到信号、被中断或到达指定最后期限之前一直处于等待状态。
boolean | AbstractQueuedSynchronizer.ConditionObject.awaitUntil(Date deadline) 实现绝对定时条件等待。

javax.management.openmbean 中 Date 的使用

类型参数类型为 Date 的 javax.management.openmbean 中的字段
static SimpleType<Date> SimpleType.DATE
SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。

javax.management.timer 中 Date 的使用

返回 Date 的 javax.management.timer 中的方法
Date | Timer.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Date | TimerMBean.getDate(Integer id) 获得与计时器通知关联的日期的一个副本。

参数类型为 Date 的 javax.management.timer 中的方法
Integer | Timer.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | Timer.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | TimerMBean.addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

javax.print.attribute 中 Date 的使用

返回 Date 的 javax.print.attribute 中的方法
 Date DateTimeSyntax.getValue()
返回此日期-时间属性的 java.util.Date 值。

参数类型为 Date 的 javax.print.attribute 中的构造方法
DateTimeSyntax(Date value)
构造具有给定 java.util.Date 值的新的日期-时间属性。

javax.print.attribute.standard 中 Date 的使用

参数类型为 Date 的 javax.print.attribute.standard 中的构造方法
DateTimeAtCompleted(Date dateTime)
构造具有给定 Date 值的新 date-time at completed 属性。
DateTimeAtCreation(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtCreation 属性。
DateTimeAtProcessing(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtProcessing 属性。
JobHoldUntil(Date dateTime)
构造具有给定 Date 值新 JobHoldUntil 属性。

javax.security.auth.kerberos 中 Date 的使用

返回 Date 的 javax.security.auth.kerberos 中的方法
Date | KerberosTicket.getAuthTime() 返回客户端进行验证的时间。
Date | KerberosTicket.getEndTime() 返回此票据有效期的期满时间。
Date | KerberosTicket.getRenewTill() 返回此票据最新的期满时间，包括所有的更新。
Date | KerberosTicket.getStartTime() 返回此票据有效期的开始时间。

参数类型为 Date 的 javax.security.auth.kerberos 中的构造方法
KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。

javax.security.cert 中 Date 的使用

返回 Date 的 javax.security.cert 中的方法
abstract Date | X509Certificate.getNotAfter() 获取证书有效期的 notAfter 日期。
abstract Date | X509Certificate.getNotBefore() 获取证书有效期的 notBefore 日期。

参数类型为 Date 的 javax.security.cert 中的方法
abstract  void X509Certificate.checkValidity(Date date)
检查指定的日期是否处于证书的有效期内。

javax.swing 中 Date 的使用

返回 Date 的 javax.swing 中的方法
 Date SpinnerDateModel.getDate()
返回此 Date 序列中的当前元素。

参数类型为 Date 的 javax.swing 中的方法
static
<M,I> RowFilter<M,I>
RowFilter.dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。

参数类型为 Date 的 javax.swing 中的构造方法
SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。

javax.xml.datatype 中 Date 的使用

参数类型为 Date 的 javax.xml.datatype 中的方法
void | Duration.addTo(Date date) 将此持续时间添加到 Date 对象。
long | Duration.getTimeInMillis(Date startInstant) 返回以毫秒为单位的持续时间的长度。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.IdentityHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.IdentityHashMap
的使用

没有 java.util.IdentityHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.EventListenerProxy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EventListenerProxy
的使用

使用 EventListenerProxy 的软件包
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。

java.awt.event 中 EventListenerProxy 的使用

java.awt.event 中 EventListenerProxy 的子类
 class AWTEventListenerProxy
扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。

java.beans 中 EventListenerProxy 的使用

java.beans 中 EventListenerProxy 的子类
class | PropertyChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。
class | VetoableChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.ListIterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.ListIterator
的使用

使用 ListIterator 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 ListIterator 的使用

返回 ListIterator 的 java.util 中的方法
ListIterator<E> | AbstractList.listIterator() 返回此列表元素的列表迭代器（按适当顺序）。
ListIterator<E> | List.listIterator() 返回此列表元素的列表迭代器（按适当顺序）。
ListIterator<E> | LinkedList.listIterator(int index) 返回此列表中的元素的列表迭代器（按适当顺序），从列表中指定位置开始。
abstract ListIterator<E> | AbstractSequentialList.listIterator(int index) 返回在此列表中的元素上进行迭代的列表迭代器（按适当顺序）。
ListIterator<E> | AbstractList.listIterator(int index) 返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。
ListIterator<E> | List.listIterator(int index) 返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。

java.util.concurrent 中 ListIterator 的使用

返回 ListIterator 的 java.util.concurrent 中的方法
ListIterator<E> | CopyOnWriteArrayList.listIterator() 返回此列表元素的列表迭代器（按适当顺序）。
ListIterator<E> | CopyOnWriteArrayList.listIterator(int index) 返回列表中元素的列表迭代器（按适当顺序），从列表的指定位置开始。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.LinkedList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.LinkedList
的使用

没有 java.util.LinkedList 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractSequentialList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractSequentialList
的使用

使用 AbstractSequentialList 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 AbstractSequentialList 的使用

java.util 中 AbstractSequentialList 的子类
 class LinkedList<E>
List 接口的链接列表实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Deque 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Deque
的使用

使用 Deque 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 Deque 的使用

实现 Deque 的 java.util 中的类
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。

参数类型为 Deque 的 java.util 中的方法
static
<T> Queue<T>
Collections.asLifoQueue(Deque<T> deque)
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。

java.util.concurrent 中 Deque 的使用

java.util.concurrent 中 Deque 的子接口
 interface BlockingDeque<E>
支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。

实现 Deque 的 java.util.concurrent 中的类
 class LinkedBlockingDeque<E>
一个基于已链接节点的、任选范围的阻塞双端队列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Queue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Queue
的使用

使用 Queue 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 Queue 的使用

java.util 中 Queue 的子接口
 interface Deque<E>
一个线性 collection，支持在两端插入和移除元素。

实现 Queue 的 java.util 中的类
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。

返回 Queue 的 java.util 中的方法
static
<T> Queue<T>
Collections.asLifoQueue(Deque<T> deque)
以后进先出 (Lifo) Queue 的形式返回某个 Deque 的视图。

java.util.concurrent 中 Queue 的使用

java.util.concurrent 中 Queue 的子接口
interface | BlockingDeque<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
interface | BlockingQueue<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。

实现 Queue 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.MissingResourceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.MissingResourceException
的使用

使用 MissingResourceException 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 MissingResourceException 的使用

抛出 MissingResourceException 的 java.util 中的方法
String | Locale.getISO3Country() 返回此语言环境国家/地区的三字母缩写。
String | Locale.getISO3Language() 返回此语言环境语言的三字母缩写。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.EmptyStackException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EmptyStackException
的使用

使用 EmptyStackException 的软件包
java.awt 包含用于创建用户界面和绘制图形图像的所有类。

java.awt 中 EmptyStackException 的使用

抛出 EmptyStackException 的 java.awt 中的方法
protected  void EventQueue.pop()
停止使用此 EventQueue 指派事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.TreeMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.TreeMap
的使用

没有 java.util.TreeMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.NavigableMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.NavigableMap
的使用

使用 NavigableMap 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。

java.util 中 NavigableMap 的使用

实现 NavigableMap 的 java.util 中的类
 class TreeMap<K,V>
基于红黑树（Red-Black tree）的 NavigableMap 实现。

返回 NavigableMap 的 java.util 中的方法
NavigableMap<K,V> | TreeMap.descendingMap()
NavigableMap<K,V> | NavigableMap.descendingMap() 返回此映射中所包含映射关系的逆序视图。
NavigableMap<K,V> | TreeMap.headMap(K toKey, boolean inclusive)
NavigableMap<K,V> | NavigableMap.headMap(K toKey, boolean inclusive) 返回此映射的部分视图，其键小于（或等于，如果 inclusive 为 true）toKey。
NavigableMap<K,V> | TreeMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive)
NavigableMap<K,V> | NavigableMap.subMap(K fromKey, boolean fromInclusive, K toKey, boolean toInclusive) 返回此映射的部分视图，其键的范围从 fromKey 到 toKey。
NavigableMap<K,V> | TreeMap.tailMap(K fromKey, boolean inclusive)
NavigableMap<K,V> | NavigableMap.tailMap(K fromKey, boolean inclusive) 返回此映射的部分视图，其键大于（或等于，如果 inclusive 为 true）fromKey。

java.util.concurrent 中 NavigableMap 的使用

java.util.concurrent 中 NavigableMap 的子接口
 interface ConcurrentNavigableMap<K,V>
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 NavigableMap 的 java.util.concurrent 中的类
 class ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.SortedMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.SortedMap
的使用

使用 SortedMap 的软件包
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。

java.nio.charset 中 SortedMap 的使用

返回 SortedMap 的 java.nio.charset 中的方法
static SortedMap<String,Charset> Charset.availableCharsets()
构造从规范 charset 名称到 charset 对象的有序映射。

java.util 中 SortedMap 的使用

java.util 中 SortedMap 的子接口
 interface NavigableMap<K,V>
扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。

实现 SortedMap 的 java.util 中的类
 class TreeMap<K,V>
基于红黑树（Red-Black tree）的 NavigableMap 实现。

返回 SortedMap 的 java.util 中的方法
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
 SortedMap<K,V> TreeMap.headMap(K toKey)
 SortedMap<K,V> NavigableMap.headMap(K toKey)
返回此映射的部分视图，其键值严格小于 toKey。
 SortedMap<K,V> SortedMap.headMap(K toKey)
返回此映射的部分视图，其键值严格小于 toKey。
 SortedMap<K,V> TreeMap.subMap(K fromKey, K toKey)
 SortedMap<K,V> NavigableMap.subMap(K fromKey, K toKey)
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
 SortedMap<K,V> SortedMap.subMap(K fromKey, K toKey)
返回此映射的部分视图，其键值的范围从 fromKey（包括）到 toKey（不包括）。
static
<K,V> SortedMap<K,V>
Collections.synchronizedSortedMap(SortedMap<K,V> m)
返回指定有序映射支持的同步（线程安全的）有序映射。
 SortedMap<K,V> TreeMap.tailMap(K fromKey)
 SortedMap<K,V> NavigableMap.tailMap(K fromKey)
返回此映射的部分视图，其键大于等于 fromKey。
 SortedMap<K,V> SortedMap.tailMap(K fromKey)
返回此映射的部分视图，其键大于等于 fromKey。
static
<K,V> SortedMap<K,V>
Collections.unmodifiableSortedMap(SortedMap<K,? extends V> m)
返回指定有序映射的不可修改视图。

参数类型为 SortedMap 的 java.util 中的方法
static
<K,V> SortedMap<K,V>
Collections.checkedSortedMap(SortedMap<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定有序映射的一个动态类型安全视图。
static
<K,V> SortedMap<K,V>
Collections.synchronizedSortedMap(SortedMap<K,V> m)
返回指定有序映射支持的同步（线程安全的）有序映射。
static
<K,V> SortedMap<K,V>
Collections.unmodifiableSortedMap(SortedMap<K,? extends V> m)
返回指定有序映射的不可修改视图。

参数类型为 SortedMap 的 java.util 中的构造方法
TreeMap(SortedMap<K,? extends V> m)
构造一个与指定有序映射具有相同映射关系和相同排序顺序的新的树映射。

java.util.concurrent 中 SortedMap 的使用

java.util.concurrent 中 SortedMap 的子接口
 interface ConcurrentNavigableMap<K,V>
支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 SortedMap 的 java.util.concurrent 中的类
 class ConcurrentSkipListMap<K,V>
可缩放的并发 ConcurrentNavigableMap 实现。

参数类型为 SortedMap 的 java.util.concurrent 中的构造方法
ConcurrentSkipListMap(SortedMap<K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与指定的有序映射包含的映射关系相同，使用的顺序也相同。

java.util.jar 中 SortedMap 的使用

返回 SortedMap 的 java.util.jar 中的方法
SortedMap<String,String> | Pack200.Packer.properties() 获取此引擎属性集。
SortedMap<String,String> | Pack200.Unpacker.properties() 获取此引擎属性集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.EventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.EventListener
的使用

使用 EventListener 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

java.awt 中 EventListener 的使用

实现 EventListener 的 java.awt 中的类
class | AWTEventMulticaster AWTEventMulticaster 实现对 java.awt.event 包中定义的 AWT 事件的指派，该指派是有效的、线程安全的多路广播事件指派。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | Component.AccessibleAWTComponent.AccessibleAWTComponentHandler 当发生显示/隐藏操作时，激活 PropertyChange 侦听器（如果注册了该侦听器）
protected class | Component.AccessibleAWTComponent.AccessibleAWTFocusHandler 当发生焦点事件时，激活 PropertyChange 侦听器（如果注册了该侦听器）
protected class | Container.AccessibleAWTContainer.AccessibleContainerHandler 添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

声明为 EventListener 的 java.awt 中的字段
protected EventListener | AWTEventMulticaster.a
protected EventListener | AWTEventMulticaster.b

类型参数类型为 EventListener 的 java.awt 中的方法
<T extends EventListener>
T[]
Button.getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Checkbox.getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
CheckboxMenuItem.getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Choice.getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
List.getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Scrollbar.getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
TextComponent.getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
TextField.getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
MenuItem.getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Window.getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
Container.getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Component.getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。

返回 EventListener 的 java.awt 中的方法
protected static EventListener AWTEventMulticaster.addInternal(EventListener a, EventListener b)
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。
<T extends EventListener>
T[]
Button.getListeners(Class<T> listenerType)
返回当前在此 Button 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Checkbox.getListeners(Class<T> listenerType)
返回目前已在此 Checkbox 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
CheckboxMenuItem.getListeners(Class<T> listenerType)
返回当前在此 CheckboxMenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Choice.getListeners(Class<T> listenerType)
返回目前已在此 Choice 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
List.getListeners(Class<T> listenerType)
返回目前已在此 List 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Scrollbar.getListeners(Class<T> listenerType)
返回目前已在此 Scrollbar 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
TextComponent.getListeners(Class<T> listenerType)
返回当前已在此 TextComponent 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
TextField.getListeners(Class<T> listenerType)
返回当前已在此 TextField 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
MenuItem.getListeners(Class<T> listenerType)
返回当前在此 MenuItem 上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Window.getListeners(Class<T> listenerType)
返回当前在此 Window 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
Container.getListeners(Class<T> listenerType)
返回当前已在此 Container 上注册为 FooListener 的所有对象的数组。
<T extends EventListener>
T[]
Component.getListeners(Class<T> listenerType)
返回一个当前在此 Component 上作为 FooListener 注册的所有对象的数组。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
protected  EventListener AWTEventMulticaster.remove(EventListener oldl)
从此多路广播器中移除一个侦听器。
protected static EventListener AWTEventMulticaster.removeInternal(EventListener l, EventListener oldl)
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。

参数类型为 EventListener 的 java.awt 中的方法
protected static EventListener AWTEventMulticaster.addInternal(EventListener a, EventListener b)
从正添加的侦听器 a 和侦听器 b 中一起返回得到的多路广播侦听器。
static
<T extends EventListener>
T[]
AWTEventMulticaster.getListeners(EventListener l, Class<T> listenerType)
返回通过指定的 java.util.EventListener 链接为 FooListener 的所有对象的数组。
protected  EventListener AWTEventMulticaster.remove(EventListener oldl)
从此多路广播器中移除一个侦听器。
protected static EventListener AWTEventMulticaster.removeInternal(EventListener l, EventListener oldl)
在从侦听器 l 中移除旧的侦听器之后，返回得到的多路广播侦听器。
protected static void AWTEventMulticaster.save(ObjectOutputStream s, String k, EventListener l)

参数类型为 EventListener 的 java.awt 中的构造方法
AWTEventMulticaster(EventListener a, EventListener b)
创建一个将侦听器 a 和侦听器 b 链接起来的事件多路广播器实例。

java.awt.datatransfer 中 EventListener 的使用

java.awt.datatransfer 中 EventListener 的子接口
 interface FlavorListener
定义侦听 FlavorEvent 的对象。

java.awt.dnd 中 EventListener 的使用

java.awt.dnd 中 EventListener 的子接口
interface | DragGestureListener 此接口源于 DragGestureRecognizer，当该（子）类的对象检测到拖动启动动作时，调用此接口。
interface | DragSourceListener DragSourceListener 定义了事件接口，Drag 和 Drop 操作的始发端使用它来跟踪用户操作的状态，并通过 Drag 和 Drop 操作为用户提供合适的“拖动结束”反馈。
interface | DragSourceMotionListener 用于接收拖动操作期间鼠标移动事件的侦听器接口。
interface | DropTargetListener DropTargetListener 接口是 DropTarget 类所使用的回调接口，用于提供所涉及的 DropTarget 的 DnD 操作的通知。

实现 EventListener 的 java.awt.dnd 中的类
class | DragSourceAdapter 用于接收拖动源事件的抽象适配器类。
class | DragSourceContext DragSourceContext 类负责管理 Drag 和 Drop 协议的起始端。
class | DropTarget 在 Drag 和 Drop 操作期间，当 Component 希望接受 drop 时，DropTarget 与 Component 有关联。
protected static class | DropTarget.DropTargetAutoScroller 此受保护的嵌套类实现自动滚动
class | DropTargetAdapter 接收放置目标事件的抽象适配器类。
class | MouseDragGestureRecognizer DragGestureRecognizer 的抽象子类，它定义了一个基于鼠标动作的 DragGestureRecognizer。

类型参数类型为 EventListener 的 java.awt.dnd 中的方法
<T extends EventListener>
T[]
DragSource.getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。

返回 EventListener 的 java.awt.dnd 中的方法
<T extends EventListener>
T[]
DragSource.getListeners(Class<T> listenerType)
获得目前已在此 DragSource 上注册为 FooListener 的所有对象。

java.awt.event 中 EventListener 的使用

java.awt.event 中 EventListener 的子接口
interface | ActionListener 用于接收操作事件的侦听器接口。
interface | AdjustmentListener 用于接收调整事件的侦听器接口。
interface | AWTEventListener 该侦听器接口用于接收指派给对象的事件的通知，这些对象是 Component、MenuComponent 或其子类的实例。
interface | ComponentListener 用于接收组件事件的侦听器接口。
interface | ContainerListener 用于接收容器事件的侦听器接口。
interface | FocusListener 用于接收组件上的键盘焦点事件的侦听器接口。
interface | HierarchyBoundsListener 用于接收祖先的移动和大小调整事件的侦听器接口。
interface | HierarchyListener 用于接收层次结构更改事件的侦听器接口。
interface | InputMethodListener 接收输入方法事件的侦听器接口。
interface | ItemListener 接收项事件的侦听器接口。
interface | KeyListener 用于接收键盘事件（击键）的侦听器接口。
interface | MouseListener 用于接收组件上“感兴趣”的鼠标事件（按下、释放、单击、进入或离开）的侦听器接口。
interface | MouseMotionListener 用于接收组件上的鼠标移动事件的侦听器接口。
interface | MouseWheelListener 用于接收组件上的鼠标滚轮事件的侦听器接口。
interface | TextListener 用于接收文本事件的侦听器接口。
interface | WindowFocusListener 用于接收 WindowEvent（包括 WINDOW_GAINED_FOCUS 和 WINDOW_LOST_FOCUS 事件）的侦听器接口。
interface | WindowListener 用于接收窗口事件的侦听器接口。
interface | WindowStateListener 用于接收窗口状态事件的侦听器接口。

实现 EventListener 的 java.awt.event 中的类
class | AWTEventListenerProxy 扩展 EventListenerProxy 的类，特别适用于为特定事件掩码添加 AWTEventListener。
class | ComponentAdapter 用于接收组件事件的抽象适配器类。
class | ContainerAdapter 用于接收容器事件的抽象适配器类。
class | FocusAdapter 用于接收键盘焦点事件的抽象适配器类。
class | HierarchyBoundsAdapter 用于接收祖先的移动和大小重调事件的抽象适配器类。
class | KeyAdapter 接收键盘事件的抽象适配器类。
class | MouseAdapter 接收鼠标事件的抽象适配器类。
class | MouseMotionAdapter 接收鼠标移动事件的抽象适配器类。
class | WindowAdapter 接收窗口事件的抽象适配器类。

java.beans 中 EventListener 的使用

java.beans 中 EventListener 的子接口
interface | PropertyChangeListener 无论 bean 何时更改 "bound" 属性，都会激发一个 "PropertyChange" 事件。
interface | VetoableChangeListener 只要 bean 更改 "constrained" 属性，都将会激发一个 VetoableChange 事件。

实现 EventListener 的 java.beans 中的类
class | PropertyChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于添加指定的 PropertyChangeListener。
class | VetoableChangeListenerProxy 扩展 EventListenerProxy 的类，特别适用于将 VetoableChangeListener 与 "constrained" 属性相关联。

java.beans.beancontext 中 EventListener 的使用

java.beans.beancontext 中 EventListener 的子接口
interface | BeanContextMembershipListener 当 BeanContext 的成员关系状态发生更改时，兼容的 BeanContext 在此接口上触发事件。
interface | BeanContextServiceRevokedListener 用于接收 BeanContextServiceRevokedEvent 对象的侦听器接口。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。
interface | BeanContextServicesListener 用于接收 BeanContextServiceAvailableEvent 对象的侦听器接口。

实现 EventListener 的 java.beans.beancontext 中的类
class | BeanContextChildSupport 这是一个为实现 BeanContextChild 协议提供支持的一般支持类。
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
protected class | BeanContextServicesSupport.BCSSProxyServiceProvider
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

java.util 中 EventListener 的使用

实现 EventListener 的 java.util 中的类
 class EventListenerProxy
将一组附加参数与侦听器关联的 EventListener 类的抽象包装器类。

返回 EventListener 的 java.util 中的方法
 EventListener EventListenerProxy.getListener()

参数类型为 EventListener 的 java.util 中的构造方法
EventListenerProxy(EventListener listener)

java.util.prefs 中 EventListener 的使用

java.util.prefs 中 EventListener 的子接口
interface | NodeChangeListener 用于接收首选项节点更改事件的侦听器。
interface | PreferenceChangeListener 用于接收首选项节点更改事件的侦听器。

javax.imageio.event 中 EventListener 的使用

javax.imageio.event 中 EventListener 的子接口
interface | IIOReadProgressListener 供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关进度的接口。
interface | IIOReadUpdateListener 供 ImageReader 实现用于通知其图像和缩略图的调用者相关像素更新的接口。
interface | IIOReadWarningListener 供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
interface | IIOWriteProgressListener 供 ImageWriter 实现用于通知其图像和缩略图写入方法的调用者相关进度的方法。
interface | IIOWriteWarningListener 供 ImageWriter 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。

javax.management 中 EventListener 的使用

javax.management 中 EventListener 的子接口
 interface NotificationListener
应该由想要接收通知的对象来实现。

javax.management.relation 中 EventListener 的使用

实现 EventListener 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.naming.event 中 EventListener 的使用

javax.naming.event 中 EventListener 的子接口
interface | NamespaceChangeListener 指定对名称空间更改感兴趣的侦听器必须实现的方法。
interface | NamingListener 此接口是处理 NamingEvent 的侦听器接口的根。
interface | ObjectChangeListener 指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。

javax.naming.ldap 中 EventListener 的使用

javax.naming.ldap 中 EventListener 的子接口
 interface UnsolicitedNotificationListener
此接口用于处理 UnsolicitedNotificationEvent。

javax.net.ssl 中 EventListener 的使用

javax.net.ssl 中 EventListener 的子接口
interface | HandshakeCompletedListener 任何希望接收有关给定 SSL 连接上 SSL 协议握手结束通知的类实现此接口。
interface | SSLSessionBindingListener 想知道何时将它们绑定到 SSLSession 或从 SSLSession 解除绑定的对象实现此接口。

javax.sound.midi 中 EventListener 的使用

javax.sound.midi 中 EventListener 的子接口
interface | ControllerEventListener ControllerEventListener 接口应由一个其实例需要在 Sequencer 处理了请求的 MIDI 控制更改事件类型时接收通知的类实现。
interface | MetaEventListener MetaEventListener 接口应由其实例需要在 Sequencer 处理了 MetaMessage 时接收通知的类实现。

javax.sound.sampled 中 EventListener 的使用

javax.sound.sampled 中 EventListener 的子接口
 interface LineListener
可以注册实现 LineListener 接口的类的实例来接收行状态更改时发生的事件。

javax.sql 中 EventListener 的使用

javax.sql 中 EventListener 的子接口
interface | ConnectionEventListener 注册该对象便可获得由 PooledConnection 对象生成的事件的通知。
interface | RowSetListener 要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。
interface | StatementEventListener 注册为能获得 Statement 池中 PreparedStatement 上所发生事件的通知的对象。

javax.swing 中 EventListener 的使用

javax.swing 中 EventListener 的子接口
 interface Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。

实现 EventListener 的 javax.swing 中的类
class | AbstractAction 此类提供 JFC Action 接口的默认实现。
protected class | AbstractButton.ButtonChangeListener 将 ChangeListener 扩展为可序列化的。
protected class | DefaultCellEditor.EditorDelegate 受保护的 (protected) EditorDelegate 类。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
protected class | JComponent.AccessibleJComponent.AccessibleContainerHandler 添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
protected class | JComponent.AccessibleJComponent.AccessibleFocusHandler 发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenu.WinListener 观察弹出窗口关闭的侦听器类。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTabbedPane.ModelListener 将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.TreeModelHandler 在移除或更改节点时，监听模型并相应地更新 expandedState。
protected class | JTree.TreeSelectionRedirector 使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
protected class | JViewport.ViewListener 视图的侦听器。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。
class | ToolTipManager 管理系统中的所有 ToolTips。
protected class | ToolTipManager.insideTimerAction
protected class | ToolTipManager.outsideTimerAction
protected class | ToolTipManager.stillInsideTimerAction

类型参数类型为 EventListener 的 javax.swing 中的方法
<T extends EventListener>
T[]
AbstractSpinnerModel.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
DefaultListSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractListModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultBoundedRangeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultSingleSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultButtonModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Timer.getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
JComponent.getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。

返回 EventListener 的 javax.swing 中的方法
<T extends EventListener>
T[]
AbstractSpinnerModel.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
DefaultListSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractListModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultBoundedRangeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultSingleSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultButtonModel.getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
Timer.getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
<T extends EventListener>
T[]
JComponent.getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。

javax.swing.event 中 EventListener 的使用

javax.swing.event 中 EventListener 的子接口
interface | AncestorListener AncestorListener 接口支持 JComponent 或其祖先之一发生更改时进行通知。
interface | CaretListener 用于侦听文本组件插入符的位置更改的侦听器。
interface | CellEditorListener CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
interface | ChangeListener 定义一个侦听 ChangeEvent 的对象。
interface | DocumentListener 观察者使用该接口注册以接收文本文档的更改通知。
interface | HyperlinkListener HyperlinkListener
interface | InternalFrameListener 用于接收内部窗体事件的侦听器接口。
interface | ListDataListener ListDataListener
interface | ListSelectionListener 列表选择值发生更改时收到通知的侦听器。
interface | MenuDragMouseListener 定义一个菜单鼠标拖动侦听器。
interface | MenuKeyListener MenuKeyListener
interface | MenuListener 定义一个菜单事件侦听器。
interface | MouseInputListener 实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。
interface | PopupMenuListener 弹出菜单侦听器
interface | RowSorterListener 通知 RowSorterListener 对 RowSorter 的更改。
interface | TableColumnModelListener TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。
interface | TableModelListener TableModelListener 定义侦听 TableModel 中更改的对象的接口。
interface | TreeExpansionListener 当树扩展或折叠某一节点时获得通知的侦听器。
interface | TreeModelListener 定义侦听 TreeModel 中更改的对象的接口。
interface | TreeSelectionListener 当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。
interface | TreeWillExpandListener 当树扩展或折叠某一节点时获得通知的侦听器。
interface | UndoableEditListener 该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。

实现 EventListener 的 javax.swing.event 中的类
class | InternalFrameAdapter 用于接收内部窗体事件的抽象适配器类。
class | MouseInputAdapter MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。

类型参数类型为 EventListener 的 javax.swing.event 中的方法
<T extends EventListener>
void
EventListenerList.add(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行添加。
<T extends EventListener>
T[]
EventListenerList.getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。
<T extends EventListener>
void
EventListenerList.remove(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行移除。

返回 EventListener 的 javax.swing.event 中的方法
<T extends EventListener>
T[]
EventListenerList.getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。

javax.swing.plaf.basic 中 EventListener 的使用

实现 EventListener 的 javax.swing.plaf.basic 中的类
class | BasicButtonListener 按钮侦听器。
class | BasicColorChooserUI.PropertyHandler 因编译器故障而被标记为 "public" 的内部类。
class | BasicComboBoxEditor 用于可编辑组合框的默认编辑器。
static class | BasicComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的子类。
class | BasicComboBoxUI.FocusHandler 失去焦点时，此侦听器将隐藏弹出部分。
class | BasicComboBoxUI.ItemHandler 此侦听器观察组合框中选择的更改。
class | BasicComboBoxUI.KeyHandler 此侦听器检查键事件是否不是导航键。
class | BasicComboBoxUI.ListDataHandler 此侦听器观察 ComboBoxModel 中的更改。
class | BasicComboBoxUI.PropertyChangeHandler 此侦听器观察在组合框中发生更改的绑定 (bound) 属性。
class | BasicComboPopup.InvocationKeyHandler 从 Java 2 平台 v 1.4 开始，现在已废弃此类，包括它仅为了具有向后 API 兼容性。
protected class | BasicComboPopup.InvocationMouseHandler 要在组合框（非 其弹出菜单）上注册的侦听器，该侦听器处理影响弹出菜单状态的鼠标事件。
protected class | BasicComboPopup.InvocationMouseMotionHandler 此侦听器观察拖动操作，如果是在列表上进行拖动，则它还更新列表中的当前选择。
protected class | BasicComboPopup.ItemHandler 此侦听器观察组合框中选择的更改。
class | BasicComboPopup.ListDataHandler 从 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
protected class | BasicComboPopup.ListMouseHandler 在列表中释放鼠标时，此侦听器隐藏弹出部分。
protected class | BasicComboPopup.ListMouseMotionHandler 在列表上移动鼠标时，此侦听器更改所选项。
protected class | BasicComboPopup.ListSelectionHandler 从 Java 2 平台 v 1.4 开始，此类已废弃，不再执行任何操作，包括它只是为了具有向后 API 兼容性。
protected class | BasicComboPopup.PropertyChangeHandler 此侦听器观察已在组合框中更改的绑定 (bound) 属性 希望侦听组合框属性更改的子类应该调用超类方法来确保组合框弹出部分正确处理属性更改。
class | BasicDesktopIconUI.MouseInputHandler 侦听鼠标移动及对其操作。
protected class | BasicDesktopPaneUI.CloseAction 处理关闭一个内部窗体。
protected class | BasicDesktopPaneUI.MaximizeAction 处理最大化一个内部窗体。
protected class | BasicDesktopPaneUI.MinimizeAction 处理最小化一个内部窗体。
protected class | BasicDesktopPaneUI.NavigateAction 处理导航到下一个内部窗体。
protected class | BasicDesktopPaneUI.OpenAction 处理恢复一个最小化或最大化的内部窗体。
class | BasicDirectoryModel 文件列表的基本实现。
protected class | BasicFileChooserUI.ApproveSelectionAction 响应 Open 或 Save 请求
protected class | BasicFileChooserUI.CancelSelectionAction 响应取消请求。
protected class | BasicFileChooserUI.ChangeToParentDirectoryAction
protected class | BasicFileChooserUI.DoubleClickListener
protected class | BasicFileChooserUI.GoHomeAction 基于“Home”键事件或等效事件的动作。
protected class | BasicFileChooserUI.NewFolderAction 创建新文件夹。
protected class | BasicFileChooserUI.SelectionListener
protected class | BasicFileChooserUI.UpdateAction 重新扫描当前目录中的文件。
class | BasicInternalFrameTitlePane.CloseAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.IconifyAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MaximizeAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.MoveAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.RestoreAction 此类应视为“受保护”内部类。
class | BasicInternalFrameTitlePane.SizeAction 此类应视为“受保护”内部类。
protected class | BasicInternalFrameUI.BasicInternalFrameListener
protected class | BasicInternalFrameUI.BorderListener 侦听边框调整。
protected class | BasicInternalFrameUI.ComponentHandler
protected class | BasicInternalFrameUI.GlassPaneDispatcher
class | BasicInternalFrameUI.InternalFramePropertyChangeListener
class | BasicLabelUI LabelUI 的 Windows L&F 实现。
class | BasicListUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicListUI.ListDataHandler 在 installUI 时和只要 JList.model 属性更改时就要添加到 JList 模型的 ListDataListener。
class | BasicListUI.ListSelectionHandler 在 installUI 时和只要 JList.selectionModel 属性更改时就要添加到 JList 模型的 ListSelectionListener。
class | BasicListUI.MouseInputHandler 鼠标输入和 JList 的焦点处理。
class | BasicListUI.PropertyChangeHandler 在 installUI 时添加到 JList 的 PropertyChangeListener。
protected class | BasicMenuItemUI.MouseInputHandler
class | BasicMenuUI.ChangeHandler 从 Java 2 平台 1.4 开始，已废弃这种以前没有记录的类。
protected class | BasicMenuUI.MouseInputHandler 实例化后供菜单项使用，用于处理鼠标事件的当前菜单选择。
class | BasicOptionPaneUI.ButtonActionListener 此内部类因编译器故障而被标记为“公开”。
class | BasicOptionPaneUI.PropertyChangeHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicProgressBarUI.ChangeHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicRootPaneUI RootPaneUI 的基本实现，在所有 JRootPane 实例中有一个是共享的。
protected class | BasicScrollBarUI.ArrowButtonListener 光标键的侦听器。
protected class | BasicScrollBarUI.ModelListener 侦听模型更改的侦听器。
class | BasicScrollBarUI.PropertyChangeHandler
protected class | BasicScrollBarUI.ScrollListener 在 ScrollPane 中发起的滚动事件的侦听器。
protected class | BasicScrollBarUI.TrackListener 跟踪鼠标拖动。
class | BasicScrollPaneUI.HSBChangeListener 水平滚动条侦听器。
protected class | BasicScrollPaneUI.MouseWheelHandler MouseWheelHandler 是实现 MouseWheelListener 接口的内部类。
class | BasicScrollPaneUI.PropertyChangeHandler
class | BasicScrollPaneUI.ViewportChangeHandler 视口事件的侦听器。
class | BasicScrollPaneUI.VSBChangeListener 垂直滚动条侦听器。
class | BasicSliderUI.ActionScroller 从 Java 2 平台 v1.3 开始，不再使用这种以前没有记录的类。
class | BasicSliderUI.ChangeHandler 数据模型侦听器。
class | BasicSliderUI.ComponentHandler 调整事件大小的侦听器。
class | BasicSliderUI.FocusHandler 焦点更改侦听器。
class | BasicSliderUI.PropertyChangeHandler
class | BasicSliderUI.ScrollListener 滚动事件侦听器。
class | BasicSliderUI.TrackListener 跟踪鼠标移动。
class | BasicSplitPaneDivider BasicSplitPaneUI 使用的分隔符。
protected class | BasicSplitPaneDivider.MouseHandler MouseHandler 负责将鼠标事件（释放、拖动……）转换为适当的 DragController 方法。
class | BasicSplitPaneUI.FocusHandler JSplitPane UI 使用的 FocusListener 的实现。
class | BasicSplitPaneUI.KeyboardDownRightHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardEndHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardHomeHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardResizeToggleHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.KeyboardUpLeftHandler ActionListener 的实现，JSplitPane UI 使用此实现处理特定键按下事件。
class | BasicSplitPaneUI.PropertyHandler JSplitPane UI 使用的 PropertyChangeListener 的实现。
class | BasicTabbedPaneUI.FocusHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.MouseHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.PropertyChangeHandler 此类应视为“受保护”内部类。
class | BasicTabbedPaneUI.TabSelectionHandler 此类应视为“受保护”内部类。
class | BasicTableHeaderUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.FocusHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.KeyHandler 此内部类因编译器故障而被标记为“公开”。
class | BasicTableUI.MouseInputHandler 此内部类因编译器故障而被标记为“公开”。
static class | BasicTextUI.BasicCaret
class | BasicToolBarUI.DockingListener 此类应视为“受保护”内部类。
protected class | BasicToolBarUI.FrameListener
protected class | BasicToolBarUI.PropertyListener
protected class | BasicToolBarUI.ToolBarContListener
protected class | BasicToolBarUI.ToolBarFocusListener
class | BasicTreeUI.CellEditorHandler 侦听器负责获取单元格编辑事件并相应地更新树。
class | BasicTreeUI.ComponentHandler 滚动时更新首选大小（如果需要）。
class | BasicTreeUI.FocusHandler 失去/获得焦点时重绘前导选择行。
class | BasicTreeUI.KeyHandler 用于获取多个按键事件以适当生成事件。
class | BasicTreeUI.MouseHandler TreeMouseListener 负责基于鼠标事件更新选择。
class | BasicTreeUI.MouseInputHandler 在将鼠标释放到用于构造 MouseInputHandler 的目的地之前，它一直负责传递所有鼠标事件，包括鼠标移动事件。
class | BasicTreeUI.PropertyChangeHandler 树的 PropertyChangeListener。
class | BasicTreeUI.SelectionModelPropertyChangeHandler TreeSelectionModel 上的侦听器，如果模型的任何属性发生更改，则重置行选择。
class | BasicTreeUI.TreeCancelEditingAction 执行操作时调用 cancelEditing 的 ActionListener。
class | BasicTreeUI.TreeExpansionHandler 更新 TreeState 以响应节点的展开/折叠。
class | BasicTreeUI.TreeHomeAction TreeHomeAction 用于处理 end/home 动作。
class | BasicTreeUI.TreeIncrementAction TreeIncrementAction 用于处理向上/向下操作。
class | BasicTreeUI.TreeModelHandler 将所有 TreeModel 事件转发到 TreeState。
class | BasicTreeUI.TreePageAction TreePageAction 处理向上翻页和向下翻页事件。
class | BasicTreeUI.TreeSelectionHandler 侦听选择模型中的更改并相应地更新显示。
class | BasicTreeUI.TreeToggleAction 对于第一个选定行展开将被切换。
class | BasicTreeUI.TreeTraverseAction TreeTraverseAction 是用于向左/向右方向键的动作。

javax.swing.plaf.metal 中 EventListener 的使用

实现 EventListener 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxEditor Metal 可编辑组合框的默认编辑器 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
static class | MetalComboBoxEditor.UIResource 实现 UIResource 的 BasicComboBoxEditor 的一个子类。
class | MetalComboBoxUI.MetalPropertyChangeListener 此内部类由于编译器故障而被标记为 "public"。
protected class | MetalFileChooserUI.DirectoryComboBoxAction 当 DirectoryComboBox 已更改所选项时调用。
protected class | MetalFileChooserUI.FilterComboBoxModel 字体选择组合框的数据模型。
protected class | MetalFileChooserUI.SingleClickListener
class | MetalLabelUI LabelUI 的 Windows L&F 实现。
class | MetalRootPaneUI 提供 RootPaneUI 的 metal 外观实现。
protected class | MetalSliderUI.MetalPropertyListener
protected class | MetalToolBarUI.MetalContainerListener
protected class | MetalToolBarUI.MetalDockingListener
protected class | MetalToolBarUI.MetalRolloverListener

javax.swing.table 中 EventListener 的使用

实现 EventListener 的 javax.swing.table 中的类
class | DefaultTableColumnModel JTable 的标准列处理程序。
class | JTableHeader 这是管理 JTable 的头的对象。

类型参数类型为 EventListener 的 javax.swing.table 中的方法
<T extends EventListener>
T[]
DefaultTableColumnModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractTableModel.getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。

返回 EventListener 的 javax.swing.table 中的方法
<T extends EventListener>
T[]
DefaultTableColumnModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
AbstractTableModel.getListeners(Class<T> listenerType)
返回一个包含当前注册为此 AbstractTableModel 上的 FooListener 的所有对象的数组。

javax.swing.text 中 EventListener 的使用

实现 EventListener 的 javax.swing.text 中的类
class | DefaultCaret 插入符的默认实现。
static class | DefaultEditorKit.BeepAction 创建蜂鸣声。
static class | DefaultEditorKit.CopyAction 复制选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.CutAction 剪切选定的区域并将其内容放入系统剪贴板中。
static class | DefaultEditorKit.DefaultKeyTypedAction 如果接收到键输入事件 并且无 keymap 输入，则默认执行该动作。
static class | DefaultEditorKit.InsertBreakAction 在文档中放置行/段落中断。
static class | DefaultEditorKit.InsertContentAction 将内容置于关联的文档中。
static class | DefaultEditorKit.InsertTabAction 将一个制表符置于文档中。
static class | DefaultEditorKit.PasteAction 将系统剪贴板内容粘贴到选定区域，如果未选中任何内容，则粘贴到插入符前面。
class | JTextComponent.AccessibleJTextComponent 此类实现 JTextComponent 类的可访问性支持。
static class | StyledEditorKit.AlignmentAction 设置段落对齐的操作。
static class | StyledEditorKit.BoldAction 切换粗体属性的操作。
static class | StyledEditorKit.FontFamilyAction 在相关的 JEditorPane 中设置字体系列的操作。
static class | StyledEditorKit.FontSizeAction 设置关联的 JEditorPane 中字体大小的操作。
static class | StyledEditorKit.ForegroundAction 设置前景色的操作。
static class | StyledEditorKit.ItalicAction 切换斜体属性的一种操作。
static class | StyledEditorKit.StyledTextAction 假定是在安装有 StyledEditorKit（或者子类）的 JEditorPane 上触发的操作。
static class | StyledEditorKit.UnderlineAction 切换下划线属性的操作。
class | TextAction 用于跨多个不同文本组件共享的键绑定的 Action 实现。

类型参数类型为 EventListener 的 javax.swing.text 中的方法
<T extends EventListener>
T[]
DefaultCaret.getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
StyleContext.NamedStyle.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
AbstractDocument.getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。

返回 EventListener 的 javax.swing.text 中的方法
<T extends EventListener>
T[]
DefaultCaret.getListeners(Class<T> listenerType)
返回目前已在此插入符上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
StyleContext.NamedStyle.getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
<T extends EventListener>
T[]
AbstractDocument.getListeners(Class<T> listenerType)
返回目前已在此文档上注册为 FooListener 的所有对象组成的数组。

javax.swing.text.html 中 EventListener 的使用

实现 EventListener 的 javax.swing.text.html 中的类
class | FormView 实现表单元素、<input>、<textarea> 和 <select> 的视图接口的组件装饰符。
protected class | FormView.MouseEventListener 当输入的类型等于被单击的图像类型时，MouseEventListener 类将用于处理表单提交。
static class | HTMLEditorKit.HTMLTextAction 提供某些便捷方法的抽象 Action，这些便捷方法对于将 HTML 插入现有文档可能很有用。
static class | HTMLEditorKit.InsertHTMLTextAction InsertHTMLTextAction 可用于将任意 HTML 字符串插入现有 HTML 文档。
static class | HTMLEditorKit.LinkController 此类用于观察关联组件并在适当的时候触发该组件上的超链接事件。

javax.swing.tree 中 EventListener 的使用

实现 EventListener 的 javax.swing.tree 中的类
 class DefaultTreeCellEditor
TreeCellEditor。

类型参数类型为 EventListener 的 javax.swing.tree 中的方法
<T extends EventListener>
T[]
DefaultTreeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultTreeSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。

返回 EventListener 的 javax.swing.tree 中的方法
<T extends EventListener>
T[]
DefaultTreeModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
<T extends EventListener>
T[]
DefaultTreeSelectionModel.getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。

javax.swing.undo 中 EventListener 的使用

实现 EventListener 的 javax.swing.undo 中的类
 class UndoManager
UndoManager 管理 UndoableEdit 列表，提供撤消或恢复适当编辑的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.WeakHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.WeakHashMap
的使用

没有 java.util.WeakHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ListResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ListResourceBundle
的使用

使用 ListResourceBundle 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 ListResourceBundle 的使用

javax.accessibility 中 ListResourceBundle 的子类
 class AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ResourceBundle
的使用

使用 ResourceBundle 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

java.awt 中 ResourceBundle 的使用

参数类型为 ResourceBundle 的 java.awt 中的方法
 void Window.applyResourceBundle(ResourceBundle rb)
已过时。 从 J2SE 1.4 开始，由 Component.applyComponentOrientation 取代。
static ComponentOrientation ComponentOrientation.getOrientation(ResourceBundle bdl)
已过时。 在 J2SE 1.4 中，使用 ComponentOrientation.getOrientation(java.util.Locale)。

java.util 中 ResourceBundle 的使用

java.util 中 ResourceBundle 的子类
class | ListResourceBundle ListResourceBundle 是 ResourceBundle 的一个抽象类，用于管理方便而又易于使用的列表中的语言环境资源。
class | PropertyResourceBundle PropertyResourceBundle 是 ResourceBundle 的一个具体子类，它使用属性文件中的静态字符串集来管理语言环境资源。

声明为 ResourceBundle 的 java.util 中的字段
protected  ResourceBundle ResourceBundle.parent
此包的父包。

返回 ResourceBundle 的 java.util 中的方法
static ResourceBundle | ResourceBundle.getBundle(String baseName) 使用指定的基本名称、默认的语言环境和调用者的类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale) 使用指定的基本名称、语言环境和调用者的类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader) 使用指定的基本名称、语言环境和类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control) 使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control) 使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, ResourceBundle.Control control) 使用指定基本名称、默认语言环境和指定控件返回一个资源包。
ResourceBundle | ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload) 针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。

参数类型为 ResourceBundle 的 java.util 中的方法
boolean | ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime) 确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
protected void | ResourceBundle.setParent(ResourceBundle parent) 设置此包的父包。

java.util.logging 中 ResourceBundle 的使用

返回 ResourceBundle 的 java.util.logging 中的方法
ResourceBundle | LogRecord.getResourceBundle() 获取本地化资源包。
ResourceBundle | Logger.getResourceBundle() 获取此 logger 在当前默认语言环境的本地化资源包。

参数类型为 ResourceBundle 的 java.util.logging 中的方法
 void LogRecord.setResourceBundle(ResourceBundle bundle)
设置本地化资源包。

javax.accessibility 中 ResourceBundle 的使用

javax.accessibility 中 ResourceBundle 的子类
 class AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ResourceBundle.Control 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ResourceBundle.Control
的使用

使用 ResourceBundle.Control 的软件包
java.util 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。

java.util 中 ResourceBundle.Control 的使用

返回 ResourceBundle.Control 的 java.util 中的方法
static ResourceBundle.Control | ResourceBundle.Control.getControl(List<String> formats) 返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。
static ResourceBundle.Control | ResourceBundle.Control.getNoFallbackControl(List<String> formats) 返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。

参数类型为 ResourceBundle.Control 的 java.util 中的方法
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control) 使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control) 使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, ResourceBundle.Control control) 使用指定基本名称、默认语言环境和指定控件返回一个资源包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.EventObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.EventObject
的使用

使用 EventObject 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.awt.event | 提供处理由 AWT 组件所激发的各类事件的接口和类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util.prefs | 此包允许应用程序存储并获取用户和系统首选项和配置数据。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt 中 EventObject 的使用

java.awt 中 EventObject 的子类
 class AWTEvent
所有 AWT 事件的根事件类。

java.awt.datatransfer 中 EventObject 的使用

java.awt.datatransfer 中 EventObject 的子类
 class FlavorEvent
FlavorEvent 用于通知感兴趣的参与者，可用的 DataFlavor 在 Clipboard（事件源）中已改变。

java.awt.dnd 中 EventObject 的使用

java.awt.dnd 中 EventObject 的子类
class | DragGestureEvent 当特定的 DragGestureRecognizer 检测到它正在跟踪的 Component 上已发生与平台相关的拖动启动动作时，将 DragGestureEvent 传递给 DragGestureListener 的 dragGestureRecognized() 方法。
class | DragSourceDragEvent 通过 DragSourceContext，将 DragSourceDragEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener。
class | DragSourceDropEvent 通过 DragSourceContext，将 DragSourceDropEvent 从 DragSourceContextPeer 传递给向 DragSourceContext 及其关联 DragSource 注册的 DragSourceListener 的 dragDropEnd 方法。
class | DragSourceEvent 此类是 DragSourceDragEvent 和 DragSourceDropEvent 的基类。
class | DropTargetDragEvent 通过 dragEnter() 和 dragOver() 方法将 DropTargetDragEvent 发送给 DropTargetListener。
class | DropTargetDropEvent 通过 DropTargetListener drop() 方法发送 DropTargetDropEvent。
class | DropTargetEvent DropTargetEvent 是 DropTargetDragEvent 和 DropTargetDropEvent 的基类。

java.awt.event 中 EventObject 的使用

java.awt.event 中 EventObject 的子类
class | ActionEvent 指示发生了组件定义的动作的语义事件。
class | AdjustmentEvent 由 Adjustable 对象所发出的调整事件。
class | ComponentEvent 指示组件被移动、大小被更改或可见性被更改的低级别事件（它也是其他组件级事件的根类）。
class | ContainerEvent 指示容器内容因为添加或移除组件而更改的低级别事件。
class | FocusEvent 指示 Component 已获得或失去输入焦点的低级别事件。
class | HierarchyEvent 指示 Component 所属的 Component 层次结构发生更改的事件。
class | InputEvent 所有组件级别输入事件的根事件类。
class | InputMethodEvent 输入方法事件包含有关使用输入方法进行撰写的文本的信息。
class | InvocationEvent 当通过 AWT 事件调度线程进行调度时，在 Runnable 上执行 run() 方法的事件。
class | ItemEvent 指示项被选定或取消选定的语义事件。
class | KeyEvent 表示组件中发生键击的事件。
class | MouseEvent 指示组件中发生鼠标动作的事件。
class | MouseWheelEvent 表示鼠标滚轮在组件中滚动的事件。
class | PaintEvent 组件级绘制事件。
class | TextEvent 指示对象文本已改变的语义事件。
class | WindowEvent 指示窗口状态改变的低级别事件。

java.beans 中 EventObject 的使用

java.beans 中 EventObject 的子类
class | IndexedPropertyChangeEvent 无论何时遵守 JavaBeans 规范的组件（"bean"）更改绑定 (bound) 索引 (indexed) 属性，都会提交一个 "IndexedPropertyChange" 事件。
class | PropertyChangeEvent 无论 bean 何时更改 "bound" 或 "constrained" 属性，都会提交一个 "PropertyChange" 事件。

java.beans.beancontext 中 EventObject 的使用

java.beans.beancontext 中 EventObject 的子类
class | BeanContextEvent BeanContextEvent 是所有从 BeanContext 发出并与其语义有关事件的抽象根事件类。
class | BeanContextMembershipEvent BeanContextMembershipEvent 封装添加到特定 BeanContext 成员关系中（或从中移除）子级的列表。
class | BeanContextServiceAvailableEvent BeanContextServicesListener 使用此事件类型来标识将被注册的服务。
class | BeanContextServiceRevokedEvent BeanContextServiceRevokedListener 使用此事件类型来标识将被取消的服务。

java.util.prefs 中 EventObject 的使用

java.util.prefs 中 EventObject 的子类
class | NodeChangeEvent Preferences 节点发出的事件，用于指示已添加或移除该节点的子节点。
class | PreferenceChangeEvent Preferences 节点发出的事件，用于指示已经添加或移除首选项，或者首选项的值已被更改。

javax.management 中 EventObject 的使用

javax.management 中 EventObject 的子类
class | AttributeChangeNotification 提供 MBean 所发送的属性更改通知的定义。
class | MBeanServerNotification 表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。
class | Notification Notification 类表示 MBean 所发出的通知。

javax.management.monitor 中 EventObject 的使用

javax.management.monitor 中 EventObject 的子类
 class MonitorNotification
提供对监视器 MBean 发送的通知的定义。

javax.management.relation 中 EventObject 的使用

javax.management.relation 中 EventObject 的子类
 class RelationNotification
Relation Service（关系服务）中的更改通知。

javax.management.remote 中 EventObject 的使用

javax.management.remote 中 EventObject 的子类
 class JMXConnectionNotification
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。

javax.management.timer 中 EventObject 的使用

javax.management.timer 中 EventObject 的子类
 class TimerNotification
此类定义了由计时器 MBean 发送的通知。

javax.naming.event 中 EventObject 的使用

javax.naming.event 中 EventObject 的子类
class | NamingEvent 此类表示命名/目录服务触发的事件。
class | NamingExceptionEvent 此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。

javax.naming.ldap 中 EventObject 的使用

javax.naming.ldap 中 EventObject 的子类
 class UnsolicitedNotificationEvent
此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

javax.net.ssl 中 EventObject 的使用

javax.net.ssl 中 EventObject 的子类
class | HandshakeCompletedEvent 此事件指示在给定的 SSL 连接上 SSL 握手结束。
class | SSLSessionBindingEvent 此事件向 SSLSessionBindingListener 传播。

javax.print.event 中 EventObject 的使用

javax.print.event 中 EventObject 的子类
class | PrintEvent 类 PrintEvent 是所有 Print Service API 事件的超类。
class | PrintJobAttributeEvent 类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
class | PrintJobEvent 类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
class | PrintServiceAttributeEvent 类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

javax.sound.sampled 中 EventObject 的使用

javax.sound.sampled 中 EventObject 的子类
 class LineEvent
LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。

javax.sql 中 EventObject 的使用

javax.sql 中 EventObject 的子类
class | ConnectionEvent 提供关于连接相关事件的源信息的 Event 对象。
class | RowSetEvent RowSet 对象发生事件时生成的 Event 对象。
class | StatementEvent StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。

javax.swing 中 EventObject 的使用

参数类型为 EventObject 的 javax.swing 中的方法
boolean | JTable.editCellAt(int row, int column, EventObject e) 如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
boolean | DefaultCellEditor.isCellEditable(EventObject anEvent) 将消息从 CellEditor 转发到 delegate。
boolean | DefaultCellEditor.EditorDelegate.isCellEditable(EventObject anEvent) 如果 anEvent 不是一个 MouseEvent，则返回 true。
boolean | AbstractCellEditor.isCellEditable(EventObject e) 返回 true。
boolean | CellEditor.isCellEditable(EventObject anEvent) 询问编辑器它是否可以使用 anEvent 开始进行编辑。
boolean | DefaultCellEditor.shouldSelectCell(EventObject anEvent) 将消息从 CellEditor 转发到 delegate。
boolean | DefaultCellEditor.EditorDelegate.shouldSelectCell(EventObject anEvent) 返回 true 指示可能选定正编辑的单元格。
boolean | AbstractCellEditor.shouldSelectCell(EventObject anEvent) 返回 true。
boolean | CellEditor.shouldSelectCell(EventObject anEvent) 如果应该选择正编辑的单元格，则返回 true，否则返回 false。
boolean | DefaultCellEditor.EditorDelegate.startCellEditing(EventObject anEvent) 返回 true 指示编辑已经开始。

javax.swing.event 中 EventObject 的使用

javax.swing.event 中 EventObject 的子类
class | AncestorEvent 报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
class | CaretEvent CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
class | ChangeEvent ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
class | HyperlinkEvent HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
class | InternalFrameEvent 以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
class | ListDataEvent 定义一个封装列表更改的事件。
class | ListSelectionEvent 表现选择中更改的特征的事件。
class | MenuDragMouseEvent MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
class | MenuEvent MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
class | MenuKeyEvent MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
class | PopupMenuEvent PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
class | RowSorterEvent RowSorterEvent 提供 RowSorter 的更改通知。
class | TableColumnModelEvent TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
class | TableModelEvent TableModelEvent 用于通知侦听器某一表模型已发生更改。
class | TreeExpansionEvent 用于标识树中的单个路径的事件。
class | TreeModelEvent 封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
class | TreeSelectionEvent 描述当前选择中的更改的事件。
class | UndoableEditEvent 指示发生了可撤消操作的事件。

javax.swing.text.html 中 EventObject 的使用

javax.swing.text.html 中 EventObject 的子类
class | FormSubmitEvent FormSubmitEvent 用于通知提交表单所需的参与者。
class | HTMLFrameHyperlinkEvent HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。

javax.swing.tree 中 EventObject 的使用

参数类型为 EventObject 的 javax.swing.tree 中的方法
protected boolean | DefaultTreeCellEditor.canEditImmediately(EventObject event) 如果 event 为 null，或者它是一个单击计数 > 2 的 MouseEvent，并且 inHitRegion 返回 true，则此方法返回 true。
boolean | DefaultTreeCellEditor.isCellEditable(EventObject event) 如果 realEditor 将 true 返回到此消息，则会通知 prepareForEditing，并返回 true。
boolean | DefaultTreeCellEditor.shouldSelectCell(EventObject event) 针对返回值，向 realEditor 发送消息。
protected boolean | DefaultTreeCellEditor.shouldStartEditingTimer(EventObject event) 如果 event 为 MouseEvent，并且单击计数为 1，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.HashSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.HashSet
的使用

使用 HashSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 HashSet 的使用

java.util 中 HashSet 的子类
 class LinkedHashSet<E>
具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。

javax.print.attribute.standard 中 HashSet 的使用

javax.print.attribute.standard 中 HashSet 的子类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Locale 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Locale
的使用

使用 Locale 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.im | 提供输入方法框架所需的类和接口。
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.text.spi | java.text 包中类的服务提供者类。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.spi | java.util 包中类的服务提供者类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.datatype | XML/Java 类型映射关系。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
org.xml.sax | 此包提供了核心 SAX API。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 Locale 的使用

返回 Locale 的 java.applet 中的方法
 Locale Applet.getLocale()
获取 applet 的语言环境。

java.awt 中 Locale 的使用

返回 Locale 的 java.awt 中的方法
Locale | List.AccessibleAWTList.AccessibleAWTListChild.getLocale() 获取组件的区域设置。
Locale | MenuComponent.AccessibleAWTMenuComponent.getLocale() 返回此对象的区域。
Locale | Window.getLocale() 如果设置了区域，则获取与此窗口关联的 Locale 对象。
Locale | Component.getLocale() 获取组件的语言环境。
Locale | Component.AccessibleAWTComponent.getLocale() 返回此对象的区域。

参数类型为 Locale 的 java.awt 中的方法
abstract String[] | GraphicsEnvironment.getAvailableFontFamilyNames(Locale l) 返回一个包含此 GraphicsEnvironment 中所有字体系列名称的数组，已针对默认语言环境对它进行了本地化。
String | Font.getFamily(Locale l) 返回此 Font 的系列名称（已经针对指定语言环境进行了本地化）。
String | Font.getFontName(Locale l) 返回此 Font 的字体外观名称（已经针对指定语言环境进行了本地化）。
static ComponentOrientation | ComponentOrientation.getOrientation(Locale locale) 返回适合于给定区域的方向。
void | Component.setLocale(Locale l) 设置组件的语言环境。

java.awt.im 中 Locale 的使用

返回 Locale 的 java.awt.im 中的方法
 Locale InputContext.getLocale()
返回当前输入方法或键盘布局的当前语言环境。

参数类型为 Locale 的 java.awt.im 中的方法
 boolean InputContext.selectInputMethod(Locale locale)
试图选择一个支持给定语言环境的输入方法或键盘布局，并返回指示是否成功选定此类输入方法或键盘布局的值。

java.awt.im.spi 中 Locale 的使用

返回 Locale 的 java.awt.im.spi 中的方法
Locale[] | InputMethodDescriptor.getAvailableLocales() 返回相应输入方法支持的语言环境。
Locale | InputMethod.getLocale() 返回当前的输入语言环境。

参数类型为 Locale 的 java.awt.im.spi 中的方法
String | InputMethodDescriptor.getInputMethodDisplayName(Locale inputLocale, Locale displayLanguage) 用将显示该名称的语言返回用户可视名称，该名称与给定的输入语言环境的输入方法相对应。
Image | InputMethodDescriptor.getInputMethodIcon(Locale inputLocale) 返回相应输入方法的图标。
boolean | InputMethod.setLocale(Locale locale) 试图设置输入语言环境。

java.beans.beancontext 中 Locale 的使用

声明为 Locale 的 java.beans.beancontext 中的字段
protected  Locale BeanContextSupport.locale
此 BeanContext 的当前语言环境。

返回 Locale 的 java.beans.beancontext 中的方法
 Locale BeanContextSupport.getLocale()
获得此 BeanContext 的语言环境。

参数类型为 Locale 的 java.beans.beancontext 中的方法
 void BeanContextSupport.setLocale(Locale newLocale)
设置此 BeanContext 的语言环境。

参数类型为 Locale 的 java.beans.beancontext 中的构造方法
BeanContextServicesSupport(BeanContextServices peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextServicesSupport(BeanContextServices peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextServicesSupport 实例
BeanContextSupport(BeanContext peer, Locale lcle)
使用指定语言环境创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dtime)
使用指定 Locale 和设计模式创建一个实例。
BeanContextSupport(BeanContext peer, Locale lcle, boolean dTime, boolean visible)
构造一个 BeanContextSupport 实例。

java.io 中 Locale 的使用

参数类型为 Locale 的 java.io 中的方法
PrintWriter | PrintWriter.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将一个格式化字符串写入此 writer 中。
PrintStream | PrintStream.format(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化字符串写入此输出流中。
PrintWriter | PrintWriter.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此 writer 的便捷方法。
PrintStream | PrintStream.printf(Locale l, String format, Object... args) 使用指定格式字符串和参数将格式化的字符串写入此输出流的便捷方法。

java.lang 中 Locale 的使用

参数类型为 Locale 的 java.lang 中的方法
static String | String.format(Locale l, String format, Object... args) 使用指定的语言环境、格式字符串和参数返回一个格式化字符串。
String | String.toLowerCase(Locale locale) 使用给定 Locale 的规则将此 String 中的所有字符都转换为小写。
String | String.toUpperCase(Locale locale) 使用给定 Locale 的规则将此 String 中的所有字符都转换为大写。

java.nio.charset 中 Locale 的使用

参数类型为 Locale 的 java.nio.charset 中的方法
 String Charset.displayName(Locale locale)
返回此 charset 用于给定语言环境的可读名称。

java.text 中 Locale 的使用

返回 Locale 的 java.text 中的方法
static Locale[] | BreakIterator.getAvailableLocales() 返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
static Locale[] | Collator.getAvailableLocales() 返回一个所有受支持语言环境的数组，此类的 getInstance 方法可为这些语言环境返回已本地化的实例。
static Locale[] | DecimalFormatSymbols.getAvailableLocales() 返回一个数组，它包括所有此类的 getInstance 方法可为之返回本地化实例的语言环境。
static Locale[] | NumberFormat.getAvailableLocales() 返回一个数组，它包含所有此类的 get*Instance 方法可以为其返回本地化实例的语言环境。
static Locale[] | DateFormatSymbols.getAvailableLocales() 返回一个数组，它由此类的 getInstance 方法可为之返回本地化实例的所有语言环境组成。
static Locale[] | DateFormat.getAvailableLocales() 返回所有语言环境的数组，此类的 get*Instance 方法可以为其返回已本地化的实例。
Locale | MessageFormat.getLocale() 获取创建或比较子格式时所使用的语言环境。

参数类型为 Locale 的 java.text 中的方法
static BreakIterator | BreakIterator.getCharacterInstance(Locale locale) 返回一个用于给定语言环境字符分解的新 BreakIterator 实例。
static NumberFormat | NumberFormat.getCurrencyInstance(Locale inLocale) 返回指定语言环境的货币格式。
static DateFormat | DateFormat.getDateInstance(int style, Locale aLocale) 获取日期格式器，该格式器具有给定语言环境的给定格式化风格。
static DateFormat | DateFormat.getDateTimeInstance(int dateStyle, int timeStyle, Locale aLocale) 获取日期/时间格式器，该格式器具有给定语言环境的给定格式化风格。
static Collator | Collator.getInstance(Locale desiredLocale) 获取所需语言环境的 Collator。
static DecimalFormatSymbols | DecimalFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DecimalFormatSymbols 实例。
static NumberFormat | NumberFormat.getInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static DateFormatSymbols | DateFormatSymbols.getInstance(Locale locale) 获取指定语言环境的 DateFormatSymbols 实例。
static NumberFormat | NumberFormat.getIntegerInstance(Locale inLocale) 返回指定语言环境的整数格式。
static BreakIterator | BreakIterator.getLineInstance(Locale locale) 返回一个用于给定语言环境行分解的新 BreakIterator 实例。
static NumberFormat | NumberFormat.getNumberInstance(Locale inLocale) 返回指定语言环境的通用数值格式。
static NumberFormat | NumberFormat.getPercentInstance(Locale inLocale) 返回指定语言环境的百分比格式。
static BreakIterator | BreakIterator.getSentenceInstance(Locale locale) 返回一个用于给定语言环境句子分解的新 BreakIterator 实例。
static DateFormat | DateFormat.getTimeInstance(int style, Locale aLocale) 获取时间格式器，该格式器具有给定语言环境的给定格式化风格。
static BreakIterator | BreakIterator.getWordInstance(Locale locale) 返回一个用于给定语言环境单词分解的新 BreakIterator 实例。
void | MessageFormat.setLocale(Locale locale) 设置创建或比较子格式时要使用的语言环境。

参数类型为 Locale 的 java.text 中的构造方法
DateFormatSymbols(Locale locale)
通过从给定语言环境资源加载格式数据，构造一个 DateFormatSymbols 对象。
DecimalFormatSymbols(Locale locale)
为给定的语言环境创建一个 DecimalFormatSymbols 对象。
MessageFormat(String pattern, Locale locale)
构造指定语言环境和模式的 MessageFormat。
SimpleDateFormat(String pattern, Locale locale)
用给定的模式和给定语言环境的默认日期格式符号构造 SimpleDateFormat。

java.text.spi 中 Locale 的使用

参数类型为 Locale 的 java.text.spi 中的方法
abstract BreakIterator | BreakIteratorProvider.getCharacterInstance(Locale locale) 为给定语言环境的字符分解返回新的 BreakIterator 实例。
abstract NumberFormat | NumberFormatProvider.getCurrencyInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化货币价值。
abstract DateFormat | DateFormatProvider.getDateInstance(int style, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期。
abstract DateFormat | DateFormatProvider.getDateTimeInstance(int dateStyle, int timeStyle, Locale locale) 返回新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化日期和时间。
abstract Collator | CollatorProvider.getInstance(Locale locale) 为指定语言环境返回新的 Collator 实例。
abstract DecimalFormatSymbols | DecimalFormatSymbolsProvider.getInstance(Locale locale) 为指定语言环境返回新的 DecimalFormatSymbols 实例。
abstract DateFormatSymbols | DateFormatSymbolsProvider.getInstance(Locale locale) 为指定语言环境返回一个新的 DateFormatSymbols 实例。
abstract NumberFormat | NumberFormatProvider.getIntegerInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定的语言环境格式化整数值。
abstract BreakIterator | BreakIteratorProvider.getLineInstance(Locale locale) 为给定语言环境的行分解返回新的 BreakIterator 实例。
abstract NumberFormat | NumberFormatProvider.getNumberInstance(Locale locale) 为指定语言环境返回新的通用 NumberFormat 实例。
abstract NumberFormat | NumberFormatProvider.getPercentInstance(Locale locale) 返回新的 NumberFormat 实例，此实例为指定语言环境格式化百分比值。
abstract BreakIterator | BreakIteratorProvider.getSentenceInstance(Locale locale) 为给定语言环境的句子分解返回新的 BreakIterator 实例。
abstract DateFormat | DateFormatProvider.getTimeInstance(int style, Locale locale) 返回一个新的 DateFormat 实例，此实例使用指定语言环境的给定格式化风格来格式化时间。
abstract BreakIterator | BreakIteratorProvider.getWordInstance(Locale locale) 为给定语言环境的单词分解返回一个新 BreakIterator 实例。

java.util 中 Locale 的使用

声明为 Locale 的 java.util 中的字段
static Locale | Locale.CANADA 用于表示国家/地区的有用常量。
static Locale | Locale.CANADA_FRENCH 用于表示国家/地区的有用常量。
static Locale | Locale.CHINA 用于表示国家/地区的有用常量。
static Locale | Locale.CHINESE 用于表示语言的有用常量。
static Locale | Locale.ENGLISH 用于表示语言的有用常量。
static Locale | Locale.FRANCE 用于表示国家/地区的有用常量。
static Locale | Locale.FRENCH 用于表示语言的有用常量。
static Locale | Locale.GERMAN 用于表示语言的有用常量。
static Locale | Locale.GERMANY 用于表示国家/地区的有用常量。
static Locale | Locale.ITALIAN 用于表示语言的有用常量。
static Locale | Locale.ITALY 用于表示国家/地区的有用常量。
static Locale | Locale.JAPAN 用于表示国家/地区的有用常量。
static Locale | Locale.JAPANESE 用于表示语言的有用常量。
static Locale | Locale.KOREA 用于表示国家/地区的有用常量。
static Locale | Locale.KOREAN 用于表示语言的有用常量。
static Locale | Locale.PRC 用于表示国家/地区的有用常量。
static Locale | Locale.ROOT 用于表示根语言环境的有用常量。
static Locale | Locale.SIMPLIFIED_CHINESE 用于表示语言的有用常量。
static Locale | Locale.TAIWAN 用于表示国家/地区的有用常量。
static Locale | Locale.TRADITIONAL_CHINESE 用于表示语言的有用常量。
static Locale | Locale.UK 用于表示国家/地区的有用常量。
static Locale | Locale.US 用于表示国家/地区的有用常量。

返回 Locale 的 java.util 中的方法
static Locale[] | Calendar.getAvailableLocales() 返回所有语言环境的数组，此类的 getInstance 方法可以为其返回本地化的实例。
static Locale[] | Locale.getAvailableLocales() 返回所有已安装语言环境的数组。
static Locale | Locale.getDefault() 获得此 Java 虚拟机实例的当前默认语言环境值。
Locale | ResourceBundle.Control.getFallbackLocale(String baseName, Locale locale) 返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。
Locale | ResourceBundle.getLocale() 返回此资源包的语言环境。
Locale | Formatter.locale() 返回构造此 formatter 时设置的语言环境。
Locale | Scanner.locale() 返回此扫描器的语言环境。

返回变量类型为 Locale 的类型的 java.util 中的方法
 List<Locale> ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale)
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。

参数类型为 Locale 的 java.util 中的方法
Formatter | Formatter.format(Locale l, String format, Object... args) 使用指定的语言环境、格式字符串和参数，将一个格式化字符串写入此对象的目标文件中。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale) 使用指定的基本名称、语言环境和调用者的类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale locale, ClassLoader loader) 使用指定的基本名称、语言环境和类加载器获取资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ClassLoader loader, ResourceBundle.Control control) 使用指定基本名称、目标语言环境、类加载器和控件返回资源包。
static ResourceBundle | ResourceBundle.getBundle(String baseName, Locale targetLocale, ResourceBundle.Control control) 使用指定基本名称、目标语言环境和控件、调用者的类加载器返回一个资源包。
List<Locale> | ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale) 返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。
String | Locale.getDisplayCountry(Locale inLocale) 返回适合向用户显示的语言环境国家/地区名。
String | Locale.getDisplayLanguage(Locale inLocale) 返回适合向用户显示的语言环境语言名。
String | TimeZone.getDisplayName(boolean daylight, int style, Locale locale) 返回适合于展示给指定区域的用户的时区名称。
String | Calendar.getDisplayName(int field, int style, Locale locale) 返回给定 style 和 locale 下的日历 field 值的字符串表示形式。
String | TimeZone.getDisplayName(Locale locale) 返回适合于展示给指定区域的用户的时区名称。
String | Locale.getDisplayName(Locale inLocale) 返回适合向用户显示的语言环境名。
Map<String,Integer> | Calendar.getDisplayNames(int field, int style, Locale locale) 返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。
String | Locale.getDisplayVariant(Locale inLocale) 返回适合向用户显示的语言环境变量代码名。
Locale | ResourceBundle.Control.getFallbackLocale(String baseName, Locale locale) 返回一个要用作回退语言环境的 Locale，用于 ResourceBundle.getBundle 工厂方法进行进一步资源包搜索。
static Currency | Currency.getInstance(Locale locale) 返回给定语言环境的国家/地区的 Currency 实例。
static Calendar | Calendar.getInstance(Locale aLocale) 使用默认时区和指定语言环境获得一个日历。
static Calendar | Calendar.getInstance(TimeZone zone, Locale aLocale) 使用指定时区和语言环境获得一个日历。
String | Currency.getSymbol(Locale locale) 获取指定语言环境的货币符号。
long | ResourceBundle.Control.getTimeToLive(String baseName, Locale locale) 返回在此 ResourceBundle.Control 下加载的资源包生存时间 (TTL) 值。
boolean | ResourceBundle.Control.needsReload(String baseName, Locale locale, String format, ClassLoader loader, ResourceBundle bundle, long loadTime) 确定是否需要根据 loadTime 或其他标准给出的加载时间重载缓存中已到期的 bundle。
ResourceBundle | ResourceBundle.Control.newBundle(String baseName, Locale locale, String format, ClassLoader loader, boolean reload) 针对给定格式和语言环境的给定包名称，实例化一个资源包，如有必要，可使用给定的类加载器。
static void | Locale.setDefault(Locale newLocale) 为此 Java 虚拟机实例设置默认语言环境。
String | ResourceBundle.Control.toBundleName(String baseName, Locale locale) 将给定 baseName 和 locale 转换为包名称。
Scanner | Scanner.useLocale(Locale locale) 将此扫描器的语言环境设置为指定的语言环境。

参数类型为 Locale 的 java.util 中的构造方法
Calendar(TimeZone zone, Locale aLocale)
构造一个带有指定时区和语言环境的 Calendar。
Formatter(Appendable a, Locale l)
构造一个带指定目标文件和语言环境的新 formatter。
Formatter(File file, String csn, Locale l)
构造一个带指定文件、字符集和语言环境的新 formatter。
Formatter(Locale l)
构造一个带指定语言环境的新 formatter。
Formatter(OutputStream os, String csn, Locale l)
构造一个带指定输出流、字符集和语言环境的新 formatter。
Formatter(String fileName, String csn, Locale l)
构造一个带指定文件名、字符集和语言环境的新 formatter。
GregorianCalendar(Locale aLocale)
在具有给定语言环境的默认时区内构造一个基于当前时间的 GregorianCalendar。
GregorianCalendar(TimeZone zone, Locale aLocale)
在具有给定语言环境的给定时区内构造一个基于当前时间的 GregorianCalendar。

java.util.spi 中 Locale 的使用

返回 Locale 的 java.util.spi 中的方法
abstract  Locale[] LocaleServiceProvider.getAvailableLocales()
返回一个数组，它包含此语言环境服务提供者可以为其提供本地化对象或名称的所有语言环境。

参数类型为 Locale 的 java.util.spi 中的方法
abstract String | LocaleNameProvider.getDisplayCountry(String countryCode, Locale locale) 返回适合向用户显示的给定 ISO 3166 国家代码和给定语言环境的本地化名称。
abstract String | LocaleNameProvider.getDisplayLanguage(String languageCode, Locale locale) 返回适合向用户显示的给定 ISO 639 语言代码和给定语言环境的本地化名称。
abstract String | TimeZoneNameProvider.getDisplayName(String ID, boolean daylight, int style, Locale locale) 返回适于展示给指定语言环境用户的给定时区 ID 名称。
abstract String | LocaleNameProvider.getDisplayVariant(String variant, Locale locale) 返回适合向用户显示的给定变量代码和给定语言环境的本地化名称。
abstract String | CurrencyNameProvider.getSymbol(String currencyCode, Locale locale) 获取指定语言环境的给定货币代码的符号。

javax.accessibility 中 Locale 的使用

返回 Locale 的 javax.accessibility 中的方法
abstract  Locale AccessibleContext.getLocale()
获取该组件的语言环境。

参数类型为 Locale 的 javax.accessibility 中的方法
String | AccessibleBundle.toDisplayString(Locale locale) 获取本地化字符串形式的键。
protected String | AccessibleBundle.toDisplayString(String resourceBundleName, Locale locale) 获取本地化字符串形式的键。

javax.annotation.processing 中 Locale 的使用

返回 Locale 的 javax.annotation.processing 中的方法
 Locale ProcessingEnvironment.getLocale()
返回当前语言环境；如果没有有效的语言环境，则返回 null。

javax.imageio 中 Locale 的使用

声明为 Locale 的 javax.imageio 中的字段
protected Locale[] | ImageReader.availableLocales 可以用来本地化警告消息的 Locale 组成的数组，如果不支持本地化，则为 null。
protected Locale[] | ImageWriter.availableLocales 可以用来本地化警告消息和压缩设置值的 Locale 组成的数组，如果本地化不受支持，则将它们初始化为 null。
protected Locale | ImageReader.locale 用于本地化的当前 Locale，如果没有设置，则为 null。
protected Locale | ImageWriteParam.locale 用于本地化压缩类型名称和质量描述的 Locale，null 表示使用默认 Locale。
protected Locale | ImageWriter.locale 用于本地化的当前 Locale，如果没有设置 Locale，则将它初始化为 null。

类型参数类型为 Locale 的 javax.imageio 中的字段
protected List<Locale> | ImageReader.warningLocales 与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<Locale> | ImageWriter.warningLocales Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。

返回 Locale 的 javax.imageio 中的方法
Locale[] | ImageReader.getAvailableLocales() 返回可用来初始化警告侦听器和压缩设置值的 Locale 所组成的数组。
Locale[] | ImageWriter.getAvailableLocales() 返回可用来初始化警告侦听器和压缩设置的 Locale 组成的数组。
Locale | ImageReader.getLocale() 返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
Locale | ImageWriteParam.getLocale() 返回当前设置的 Locale，如果仅支持默认 Locale，则返回 null。
Locale | ImageWriter.getLocale() 返回当前设置的 Locale，如果没有设置 Locale，则返回 null。

参数类型为 Locale 的 javax.imageio 中的方法
void | ImageReader.setLocale(Locale locale) 将此 ImageReader 的当前 Locale 设置为给定值。
void | ImageWriter.setLocale(Locale locale) 将此 ImageWriter 的当前 Locale 设置为给定值。

参数类型为 Locale 的 javax.imageio 中的构造方法
ImageWriteParam(Locale locale)
构造一个 ImageWriteParam 集，以使用给定 Locale。

javax.imageio.metadata 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.metadata 中的方法
String | IIOMetadataFormat.getAttributeDescription(String elementName, String attrName, Locale locale) 返回包含指定属性的描述的 String，或者 null。
String | IIOMetadataFormatImpl.getAttributeDescription(String elementName, String attrName, Locale locale) 返回包含指定属性的描述的 String，或者 null。
String | IIOMetadataFormat.getElementDescription(String elementName, Locale locale) 返回包含指定元素的描述的 String，或者 null。
String | IIOMetadataFormatImpl.getElementDescription(String elementName, Locale locale) 返回包含指定元素的描述的 String，或者 null。

javax.imageio.plugins.bmp 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.plugins.bmp 中的构造方法
BMPImageWriteParam(Locale locale)
构造一个设置为使用给定 Locale 并且所有参数都采用默认值的 BMPImageWriteParam。

javax.imageio.plugins.jpeg 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.plugins.jpeg 中的构造方法
JPEGImageWriteParam(Locale locale)
构造一个 JPEGImageWriteParam。

javax.imageio.spi 中 Locale 的使用

参数类型为 Locale 的 javax.imageio.spi 中的方法
abstract  String IIOServiceProvider.getDescription(Locale locale)
返回此服务提供者及其相关实现的一个简明的可读描述。

javax.print.attribute 中 Locale 的使用

返回 Locale 的 javax.print.attribute 中的方法
 Locale TextSyntax.getLocale()
返回此文本属性的文本字符串的自然语言（语言环境）。

参数类型为 Locale 的 javax.print.attribute 中的构造方法
TextSyntax(String value, Locale locale)
使用指定的字符串和语言环境构造 TextAttribute。

javax.print.attribute.standard 中 Locale 的使用

参数类型为 Locale 的 javax.print.attribute.standard 中的构造方法
DocumentName(String documentName, Locale locale)
构造具有给定文档名称和语言环境的新文档名称属性。
JobMessageFromOperator(String message, Locale locale)
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。
JobName(String jobName, Locale locale)
构造具有给定作业名称和语言环境的新JobName属性。
JobOriginatingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。
OutputDeviceAssigned(String deviceName, Locale locale)
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。
PrinterInfo(String info, Locale locale)
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。
PrinterLocation(String location, Locale locale)
构造具有给定位置和语言环境的新 PrinterLocation 属性。
PrinterMakeAndModel(String makeAndModel, Locale locale)
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。
PrinterMessageFromOperator(String message, Locale locale)
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。
PrinterName(String printerName, Locale locale)
构造具有给定名称和语言环境的新 PrinterName 属性。
RequestingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。

javax.security.auth.callback 中 Locale 的使用

返回 Locale 的 javax.security.auth.callback 中的方法
 Locale LanguageCallback.getLocale()
获取检索到的 Locale。

参数类型为 Locale 的 javax.security.auth.callback 中的方法
 void LanguageCallback.setLocale(Locale locale)
设置获取到的 Locale。

javax.swing 中 Locale 的使用

返回 Locale 的 javax.swing 中的方法
Locale | UIDefaults.getDefaultLocale() 返回该默认语言环境。
static Locale | JComponent.getDefaultLocale() 返回在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
Locale | ProgressMonitor.AccessibleProgressMonitor.getLocale() 获取该组件的语言环境。
Locale | JTree.AccessibleJTree.AccessibleJTreeNode.getLocale() 获取组件的区域。
Locale | JTable.AccessibleJTable.AccessibleJTableCell.getLocale() 获取该组件的语言环境。
Locale | JList.AccessibleJList.AccessibleJListChild.getLocale()
Locale | ImageIcon.AccessibleImageIcon.getLocale() 返回此对象的区域。

参数类型为 Locale 的 javax.swing 中的方法
Object | UIDefaults.get(Object key, Locale l) 返回与给定语言环境相关的那些键的值。
static Object | UIManager.get(Object key, Locale l) 从适合给定语言环境的默认值中返回一个对象。
boolean | UIDefaults.getBoolean(Object key, Locale l) 如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。
static boolean | UIManager.getBoolean(Object key, Locale l) 从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。
Border | UIDefaults.getBorder(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。
static Border | UIManager.getBorder(Object key, Locale l) 从适合给定语言环境的默认值中返回一个边框。
Color | UIDefaults.getColor(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。
static Color | UIManager.getColor(Object key, Locale l) 从适合给定语言环境的默认值中返回一种颜色。
Dimension | UIDefaults.getDimension(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
static Dimension | UIManager.getDimension(Object key, Locale l) 从适合给定语言环境的默认值中返回一个维数。
Font | UIDefaults.getFont(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。
static Font | UIManager.getFont(Object key, Locale l) 从适合给定语言环境的默认值中返回一种字体。
Icon | UIDefaults.getIcon(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。
static Icon | UIManager.getIcon(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Icon。
Insets | UIDefaults.getInsets(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。
static Insets | UIManager.getInsets(Object key, Locale l) 从适合给定语言环境的默认值中返回一个 Insets 对象。
int | UIDefaults.getInt(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。
static int | UIManager.getInt(Object key, Locale l) 从适合给定语言环境的默认值中返回一个整数。
String | UIDefaults.getString(Object key, Locale l) 如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。
static String | UIManager.getString(Object key, Locale l) 从适合给定语言环境的默认值中返回一个字符串。
void | UIDefaults.setDefaultLocale(Locale l) 设置默认语言环境。
static void | JComponent.setDefaultLocale(Locale l) 设置在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。

javax.swing.table 中 Locale 的使用

返回 Locale 的 javax.swing.table 中的方法
 Locale JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getLocale()

javax.tools 中 Locale 的使用

参数类型为 Locale 的 javax.tools 中的方法
String | Diagnostic.getMessage(Locale locale) 获取给定语言环境的本地化消息。
StandardJavaFileManager | JavaCompiler.getStandardFileManager(DiagnosticListener<? super JavaFileObject> diagnosticListener, Locale locale, Charset charset) 为此工具获取一个标准文件管理器实现的新实例。
void | JavaCompiler.CompilationTask.setLocale(Locale locale) 设置格式化诊断和其他本地化数据时要应用的语言环境。

javax.xml.datatype 中 Locale 的使用

参数类型为 Locale 的 javax.xml.datatype 中的方法
abstract  GregorianCalendar XMLGregorianCalendar.toGregorianCalendar(TimeZone timezone, Locale aLocale, XMLGregorianCalendar defaults)
将此 XMLGregorianCalendar 以及提供的参数转换为 GregorianCalendar 实例。

javax.xml.soap 中 Locale 的使用

返回 Locale 的 javax.xml.soap 中的方法
 Locale SOAPFault.getFaultStringLocale()
获取此 SOAPFault 对象错误字符串的语言环境。

参数类型为 Locale 的 javax.xml.soap 中的方法
SOAPFault | SOAPBody.addFault(Name faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
SOAPFault | SOAPBody.addFault(QName faultCode, String faultString, Locale locale) 创建新的 SOAPFault 对象，并将其添加到此 SOAPBody 对象。
void | SOAPFault.addFaultReasonText(String text, Locale locale) 追加或替换包含指定文本消息的 Reason Text 项，以及从 locale 派生的 xml:lang。
String | SOAPFault.getFaultReasonText(Locale locale) 返回与给定 Locale 关联的 Reason Text。
void | SOAPFault.setFaultString(String faultString, Locale locale) 将此 SOAPFault 对象的错误字符串设定为给定字符串，并本地化为给定语言环境。

org.xml.sax 中 Locale 的使用

参数类型为 Locale 的 org.xml.sax 中的方法
 void Parser.setLocale(Locale locale)
已过时。 允许应用程序请求错误和警告的环境。

org.xml.sax.helpers 中 Locale 的使用

参数类型为 Locale 的 org.xml.sax.helpers 中的方法
 void XMLReaderAdapter.setLocale(Locale locale)
设置错误报告的语言环境。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.BitSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.BitSet
的使用

使用 BitSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。

java.util 中 BitSet 的使用

返回 BitSet 的 java.util 中的方法
 BitSet BitSet.get(int fromIndex, int toIndex)
返回一个新的 BitSet，它由此 BitSet 中从 fromIndex（包括）到 toIndex（不包括）范围内的位组成。

参数类型为 BitSet 的 java.util 中的方法
void | BitSet.and(BitSet set) 对此目标位 set 和参数位 set 执行逻辑与操作。
void | BitSet.andNot(BitSet set) 清除此 BitSet 中所有的位，其相应的位在指定的 BitSet 中已设置。
boolean | BitSet.intersects(BitSet set) 如果指定的 BitSet 中有设置为 true 的位，并且在此 BitSet 中也将其设置为 true，则返回 ture。
void | BitSet.or(BitSet set) 对此位 set 和位 set 参数执行逻辑或操作。
void | BitSet.xor(BitSet set) 对此位 set 和位 set 参数执行逻辑异或操作。

javax.swing.text.html.parser 中 BitSet 的使用

声明为 BitSet 的 javax.swing.text.html.parser 中的字段
BitSet | Element.exclusions
BitSet | Element.inclusions

参数类型为 BitSet 的 javax.swing.text.html.parser 中的方法
 Element DTD.defineElement(String name, int type, boolean omitStart, boolean omitEnd, ContentModel content, BitSet exclusions, BitSet inclusions, AttributeList atts)
返回与指定参数匹配的 Element。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.ArrayList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.ArrayList
的使用

使用 ArrayList 的软件包
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。

java.awt.dnd 中 ArrayList 的使用

声明为 ArrayList 的 java.awt.dnd 中的字段
protected  ArrayList<InputEvent> DragGestureRecognizer.events
DragGestureRecognizer“识别”为触发拖动的“动作”事件列表（按顺序）。

java.beans.beancontext 中 ArrayList 的使用

声明为 ArrayList 的 java.beans.beancontext 中的字段
protected ArrayList | BeanContextSupport.bcmListeners protected ArrayList bcmListeners 字段的所有访问在该对象上都将是同步的。
protected ArrayList | BeanContextServicesSupport.bcsListeners BeanContextServicesListener 对象的列表。

java.util 中 ArrayList 的使用

返回 ArrayList 的 java.util 中的方法
static
<T> ArrayList<T>
Collections.list(Enumeration<T> e)
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。

javax.management 中 ArrayList 的使用

javax.management 中 ArrayList 的子类
 class AttributeList
表示 MBean 属性值的列表。

返回 ArrayList 的 javax.management 中的方法
static ArrayList<MBeanServer> MBeanServerFactory.findMBeanServer(String agentId)
返回已注册 MBeanServer 对象的列表。

javax.management.relation 中 ArrayList 的使用

javax.management.relation 中 ArrayList 的子类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.StringTokenizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.StringTokenizer
的使用

没有 java.util.StringTokenizer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.LinkedHashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.LinkedHashMap
的使用

没有 java.util.LinkedHashMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractSet
的使用

使用 AbstractSet 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 AbstractSet 的使用

java.util 中 AbstractSet 的子类
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。

java.util.concurrent 中 AbstractSet 的使用

java.util.concurrent 中 AbstractSet 的子类
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。

javax.print.attribute.standard 中 AbstractSet 的使用

javax.print.attribute.standard 中 AbstractSet 的子类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Set 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Set
的使用

使用 Set 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.nio.channels | 定义了各种通道，这些通道表示到能够执行 I/O 操作的实体（如文件和套接字）的连接；定义了用于多路复用的、非阻塞 I/O 操作的选择器。
java.nio.channels.spi | 用于 java.nio.channels 包的服务提供者类。
java.nio.charset | 定义用来在字节和 Unicode 字符之间转换的 charset、解码器和编码器。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.imageio | Java Image I/O API 的主要包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。
javax.xml.ws.soap | 该包定义特定于 SOAP 绑定的 API。

java.awt 中 Set 的使用

返回 Set 的 java.awt 中的方法
Set<Map.Entry<Object,Object>> | RenderingHints.entrySet() 返回此 RenderingHints 中所包含映射关系的 Set 视图。
Set<AWTKeyStroke> | KeyboardFocusManager.getDefaultFocusTraversalKeys(int id) 返回给定遍历操作的默认焦点遍历键的 Set。
Set<AWTKeyStroke> | Window.getFocusTraversalKeys(int id) 获取此窗口的焦点遍历键。
Set<AWTKeyStroke> | Container.getFocusTraversalKeys(int id) 为此 Container 的给定遍历操作返回焦点遍历键的 Set。
Set<AWTKeyStroke> | Component.getFocusTraversalKeys(int id) 返回此 Component 的给定遍历操作的焦点遍历键 Set。
Set<Object> | RenderingHints.keySet() 返回此 RenderingHints 中所包含键的 Set 视图。

参数类型为 Set 的 java.awt 中的方法
void | KeyboardFocusManager.setDefaultFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 设置给定遍历操作的默认焦点遍历键。
void | Container.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Container 的给定遍历操作设置焦点遍历键。
void | Component.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes) 为此 Component 的给定遍历操作设置焦点遍历键。

java.nio.channels 中 Set 的使用

返回 Set 的 java.nio.channels 中的方法
abstract Set<SelectionKey> | Selector.keys() 返回此选择器的键集。
abstract Set<SelectionKey> | Selector.selectedKeys() 返回此选择器的已选择键集。

java.nio.channels.spi 中 Set 的使用

返回 Set 的 java.nio.channels.spi 中的方法
protected  Set<SelectionKey> AbstractSelector.cancelledKeys()
获取此选择器的已取消键集。

java.nio.charset 中 Set 的使用

返回 Set 的 java.nio.charset 中的方法
 Set<String> Charset.aliases()
返回包含此 charset 各个别名的集合。

java.security 中 Set 的使用

返回 Set 的 java.security 中的方法
Set<Map.Entry<Object,Object>> | Provider.entrySet() 返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。
static Set<String> | Security.getAlgorithms(String serviceName) 返回字符串 Set，这些字符串包含了指定的 Java 加密服务的所有可用算法或类型的名称（例如，Signature、MessageDigest、Cipher、Mac、KeyStore）。
Set<Provider.Service> | Provider.getServices() 获取此 Provider 支持的所有服务的一个不可修改的 Set。
Set<Object> | Provider.keySet() 返回此 provider 中所包含的属性键的一个不可修改的 Set 视图。

java.security.cert 中 Set 的使用

返回 Set 的 java.security.cert 中的方法
Set<String> | X509Extension.getCriticalExtensionOIDs() 获取实现此接口的对象所管理的证书/CRL 中，被标记为 CRITICAL 的扩展的 OID 字符串 Set。
Set<String> | PolicyNode.getExpectedPolicies() 返回预期的策略集，其中的策略将满足下一个要处理证书中此节点的有效策略。
Set<String> | X509CertSelector.getExtendedKeyUsage() 返回 extendedKeyUsage 标准。
Set<String> | PKIXParameters.getInitialPolicies() 返回初始策略标识符（OID 字符串）的不可变 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
Set<String> | X509Extension.getNonCriticalExtensionOIDs() 获取实现此接口的对象所管理的证书/CRL 中，被标记为 NON-CRITICAL 的扩展的 OID 字符串 Set。
Set<String> | X509CertSelector.getPolicy() 返回策略标准。
Set<? extends PolicyQualifierInfo> | PolicyNode.getPolicyQualifiers() 返回与此节点所表示的有效策略相关联的策略限定符集。
abstract Set<? extends X509CRLEntry> | X509CRL.getRevokedCertificates() 获取此 CRL 中的所有项。
abstract Set<String> | PKIXCertPathChecker.getSupportedExtensions() 返回一个此 PKIXCertPathChecker 支持（也就是识别，即能够处理）的 X.509 证书扩展的不可变的 Set，如果不支持这些扩展，则返回 null。
Set<TrustAnchor> | PKIXParameters.getTrustAnchors() 返回不可变的、最受信任的 CA Set。

参数类型为 Set 的 java.security.cert 中的方法
void | X509CertSelector.setExtendedKeyUsage(Set<String> keyPurposeSet) 设置 extendedKeyUsage 标准。
void | PKIXParameters.setInitialPolicies(Set<String> initialPolicies) 设置初始策略标识符（OID 字符串）的 Set，指示出于证书路径处理的目的，所有这些策略都可被证书用户接受。
void | X509CertSelector.setPolicy(Set<String> certPolicySet) 设置策略限制。
void | PKIXParameters.setTrustAnchors(Set<TrustAnchor> trustAnchors) 设置最受信任的 CA Set。

参数类型为 Set 的 java.security.cert 中的构造方法
PKIXBuilderParameters(Set<TrustAnchor> trustAnchors, CertSelector targetConstraints)
创建具有指定最受信任 CA Set 的 PKIXBuilderParameters 的实例。
PKIXParameters(Set<TrustAnchor> trustAnchors)
创建具有指定最受信任 CA Set 的 PKIXParameters 的实例。

java.text 中 Set 的使用

返回 Set 的 java.text 中的方法
 Set<AttributedCharacterIterator.Attribute> AttributedCharacterIterator.getAllAttributeKeys()
返回定义于迭代器文本范围上的所有属性的键。

参数类型为 Set 的 java.text 中的方法
int | AttributedCharacterIterator.getRunLimit(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行之后的第一个字符的索引。
int | AttributedCharacterIterator.getRunStart(Set<? extends AttributedCharacterIterator.Attribute> attributes) 返回关于包含当前字符的给定多个属性的运行的第一个字符的索引。

java.util 中 Set 的使用

java.util 中 Set 的子接口
interface | NavigableSet<E> 扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
interface | SortedSet<E> 进一步提供关于元素的总体排序 的 Set。

实现 Set 的 java.util 中的类
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。

声明为 Set 的 java.util 中的字段
static Set Collections.EMPTY_SET
空的 set（不可变的）。

返回 Set 的 java.util 中的方法
static
<E> Set<E>
Collections.checkedSet(Set<E> s, Class<E> type)
返回指定 set 的一个动态类型安全视图。
static
<T> Set<T>
Collections.emptySet()
返回空的 set（不可变的）。
 Set<Map.Entry<K,V>> EnumMap.entrySet()
返回此映射中所包含映射关系的 Set 视图。
 Set<Map.Entry<K,V>> IdentityHashMap.entrySet()
返回此映射所包含映射关系的 Set 视图。
 Set<Map.Entry<K,V>> TreeMap.entrySet()
返回此映射中包含的映射关系的 Set 视图。
 Set<Map.Entry<K,V>> SortedMap.entrySet()
返回在此映射中包含的映射关系的 Set 视图。
 Set<Map.Entry<K,V>> WeakHashMap.entrySet()
返回此映射所包含的映射关系的 Set 视图。
 Set<Map.Entry<K,V>> HashMap.entrySet()
返回此映射所包含的映射关系的 Set 视图。
abstract  Set<Map.Entry<K,V>> AbstractMap.entrySet()
 Set<Map.Entry<K,V>> Hashtable.entrySet()
返回此映射中包含的键的 Set 视图。
 Set<Map.Entry<K,V>> Map.entrySet()
返回此映射中包含的映射关系的 Set 视图。
protected  Set<String> PropertyResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。
protected  Set<String> ListResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。
protected  Set<String> ResourceBundle.handleKeySet()
返回只 包含在此 ResourceBundle 中的键的 Set。
 Set<K> EnumMap.keySet()
返回此映射中所包含键的 Set 视图。
 Set<K> IdentityHashMap.keySet()
返回映射中所包含键的基于标识的 set 视图。
 Set<K> TreeMap.keySet()
返回此映射包含的键的 Set 视图。
 Set<K> SortedMap.keySet()
返回在此映射中所包含键的 Set 视图。
 Set<K> WeakHashMap.keySet()
返回此映射所包含的键的 Set 视图。
 Set<String> ResourceBundle.keySet()
返回此 ResourceBundle 及其父包中包含的所有键的 Set。
 Set<K> HashMap.keySet()
返回此映射中所包含的键的 Set 视图。
 Set<K> AbstractMap.keySet()
返回此映射中包含的键的 Set 视图。
 Set<K> Hashtable.keySet()
返回此映射中包含的键的 Set 视图。
 Set<K> Map.keySet()
返回此映射中包含的键的 Set 视图。
static
<E> Set<E>
Collections.newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。
static
<T> Set<T>
Collections.singleton(T o)
返回一个只包含指定对象的不可变 set。
 Set<String> Properties.stringPropertyNames()
返回此属性列表中的键集，其中该键及其对应值是字符串，如果在主属性列表中未找到同名的键，则还包括默认属性列表中不同的键。
static
<T> Set<T>
Collections.synchronizedSet(Set<T> s)
返回指定 set 支持的同步（线程安全的）set。
static
<T> Set<T>
Collections.unmodifiableSet(Set<? extends T> s)
返回指定 set 的不可修改视图。

参数类型为 Set 的 java.util 中的方法
static
<E> Set<E>
Collections.checkedSet(Set<E> s, Class<E> type)
返回指定 set 的一个动态类型安全视图。
static
<T> Set<T>
Collections.synchronizedSet(Set<T> s)
返回指定 set 支持的同步（线程安全的）set。
static
<T> Set<T>
Collections.unmodifiableSet(Set<? extends T> s)
返回指定 set 的不可修改视图。

java.util.concurrent 中 Set 的使用

实现 Set 的 java.util.concurrent 中的类
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。

返回 Set 的 java.util.concurrent 中的方法
Set<Map.Entry<K,V>> | ConcurrentSkipListMap.entrySet() 返回此映射中所包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | ConcurrentHashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。
Set<K> | ConcurrentHashMap.keySet() 返回此映射中包含的键的 Set 视图。

java.util.jar 中 Set 的使用

返回 Set 的 java.util.jar 中的方法
Set<Map.Entry<Object,Object>> | Attributes.entrySet() 返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。
Set<Object> | Attributes.keySet() 返回此 Map 所包含的属性名称（键）的 Set 视图。

javax.annotation.processing 中 Set 的使用

返回 Set 的 javax.annotation.processing 中的方法
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(TypeElement a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getRootElements() 返回以前的 round 生成的注释处理根元素。
Set<String> | AbstractProcessor.getSupportedAnnotationTypes() 如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
Set<String> | Processor.getSupportedAnnotationTypes() 返回此 Processor 支持的注释类型的名称。
Set<String> | AbstractProcessor.getSupportedOptions() 如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
Set<String> | Processor.getSupportedOptions() 返回此 Processor 识别的选项。

参数类型为 Set 的 javax.annotation.processing 中的方法
abstract boolean | AbstractProcessor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
boolean | Processor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。

javax.imageio 中 Set 的使用

参数类型为 Set 的 javax.imageio 中的方法
IIOMetadata | ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames) 返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames) 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

javax.lang.model.element 中 Set 的使用

返回 Set 的 javax.lang.model.element 中的方法
 Set<Modifier> Element.getModifiers()
返回此元素的修饰符，不包括注释。

javax.lang.model.util 中 Set 的使用

返回 Set 的 javax.lang.model.util 中的方法
static Set<ExecutableElement> | ElementFilter.constructorsIn(Set<? extends Element> elements) 返回 elements 中构造方法的集合。
static Set<VariableElement> | ElementFilter.fieldsIn(Set<? extends Element> elements) 返回 elements 中字段的集合。
static Set<ExecutableElement> | ElementFilter.methodsIn(Set<? extends Element> elements) 返回 elements 中方法的集合。
static Set<PackageElement> | ElementFilter.packagesIn(Set<? extends Element> elements) 返回 elements 中包的集合。
static Set<TypeElement> | ElementFilter.typesIn(Set<? extends Element> elements) 返回 elements 中类型的集合。

参数类型为 Set 的 javax.lang.model.util 中的方法
static Set<ExecutableElement> | ElementFilter.constructorsIn(Set<? extends Element> elements) 返回 elements 中构造方法的集合。
static Set<VariableElement> | ElementFilter.fieldsIn(Set<? extends Element> elements) 返回 elements 中字段的集合。
static Set<ExecutableElement> | ElementFilter.methodsIn(Set<? extends Element> elements) 返回 elements 中方法的集合。
static Set<PackageElement> | ElementFilter.packagesIn(Set<? extends Element> elements) 返回 elements 中包的集合。
static Set<TypeElement> | ElementFilter.typesIn(Set<? extends Element> elements) 返回 elements 中类型的集合。

javax.management 中 Set 的使用

返回 Set 的 javax.management 中的方法
Set<ObjectInstance> | MBeanServer.queryMBeans(ObjectName name, QueryExp query)
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。
Set<ObjectName> | MBeanServer.queryNames(ObjectName name, QueryExp query)
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。

javax.management.loading 中 Set 的使用

返回 Set 的 javax.management.loading 中的方法
Set<Object> | MLet.getMBeansFromURL(String url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(String url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLet.getMBeansFromURL(URL url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(URL url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

javax.management.openmbean 中 Set 的使用

返回 Set 的 javax.management.openmbean 中的方法
Set<Map.Entry<Object,Object>> | TabularDataSupport.entrySet() 返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。
Set<?> | OpenMBeanAttributeInfoSupport.getLegalValues() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的合法值的不可修改的 Set（如果已指定），否则返回 null。
Set<?> | OpenMBeanParameterInfo.getLegalValues() 返回此参数的合法值的集合（如果存在），否则返回 null。
Set<?> | OpenMBeanParameterInfoSupport.getLegalValues() 返回此 OpenMBeanParameterInfoSupport 实例描述的合法参数值的不可修改的 Set（如果指定），否则返回 null。
Set<String> | CompositeType.keySet() 返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。
Set<?> | TabularData.keySet() 返回此 TabularData 实例中包含的 CompositeData 值（即各行）的键（即索引值）的 set 视图。
Set<Object> | TabularDataSupport.keySet() 返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。

javax.management.remote.rmi 中 Set 的使用

返回 Set 的 javax.management.remote.rmi 中的方法
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

javax.print.attribute.standard 中 Set 的使用

实现 Set 的 javax.print.attribute.standard 中的类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

返回 Set 的 javax.print.attribute.standard 中的方法
 Set<PrinterStateReason> PrinterStateReasons.printerStateReasonSet(Severity severity)
在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。

javax.script 中 Set 的使用

返回 Set 的 javax.script 中的方法
Set<Map.Entry<String,Object>> | SimpleBindings.entrySet() 返回此映射中包含的映射关系的 Set 视图。
Set<String> | SimpleBindings.keySet() 返回此映射中包含的键的 Set 视图。

javax.security.auth 中 Set 的使用

返回 Set 的 javax.security.auth 中的方法
 Set<Principal> Subject.getPrincipals()
返回与此 Subject 关联的 Principal Set。
<T extends Principal>
Set<T>
Subject.getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。
 Set<Object> Subject.getPrivateCredentials()
返回此 Subject 中包含的私有证书 Set。
<T> Set<T>
Subject.getPrivateCredentials(Class<T> c)
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。
 Set<Object> Subject.getPublicCredentials()
返回此 Subject 中包含的公开证书 Set。
<T> Set<T>
Subject.getPublicCredentials(Class<T> c)
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。

参数类型为 Set 的 javax.security.auth 中的构造方法
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。

javax.swing 中 Set 的使用

参数类型为 Set 的 javax.swing 中的方法
 void JComponent.setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
设置针对此 Component 的给定遍历操作的焦点遍历键。

javax.tools 中 Set 的使用

返回 Set 的 javax.tools 中的方法
 Set<SourceVersion> Tool.getSourceVersions()
获取此工具支持的 Java™ 编程语言的源版本。

参数类型为 Set 的 javax.tools 中的方法
Iterable<JavaFileObject> | ForwardingJavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse)
Iterable<JavaFileObject> | JavaFileManager.list(JavaFileManager.Location location, String packageName, Set<JavaFileObject.Kind> kinds, boolean recurse) 列出给定位置处符合给定标准的所有文件对象。

javax.xml.ws.handler.soap 中 Set 的使用

返回 Set 的 javax.xml.ws.handler.soap 中的方法
Set<QName> | SOAPHandler.getHeaders() 获取可以由此处理程序实例处理的头块。
Set<String> | SOAPMessageContext.getRoles() 获取与执行处理程序链关联的 SOAP 参与者角色。

javax.xml.ws.soap 中 Set 的使用

返回 Set 的 javax.xml.ws.soap 中的方法
 Set<String> SOAPBinding.getRoles()
获取 SOAP 绑定实例所扮演的角色。

参数类型为 Set 的 javax.xml.ws.soap 中的方法
 void SOAPBinding.setRoles(Set<String> roles)
设置由 SOAP 绑定实例扮演的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Collections 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Collections
的使用

没有 java.util.Collections 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Arrays 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Arrays
的使用

没有 java.util.Arrays 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Iterator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Iterator
的使用

使用 Iterator 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.nio.charset.spi | java.nio.charset 包的服务提供者类。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.crypto | 用于 XML 加密的通用类。
javax.xml.crypto.dom | javax.xml.crypto 包的特定于 DOM 的类。
javax.xml.namespace | XML 名称空间处理。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。
javax.xml.stream |
javax.xml.stream.events |
javax.xml.stream.util |
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.spi | 该包定义用于 JAX-WS 2.0 的 SPI。

java.applet 中 Iterator 的使用

返回 Iterator 的 java.applet 中的方法
 Iterator<String> AppletContext.getStreamKeys()
找到此 applet 上下文中所有流对应的键。

java.awt.dnd 中 Iterator 的使用

返回 Iterator 的 java.awt.dnd 中的方法
 Iterator<InputEvent> DragGestureEvent.iterator()
返回组成动作的事件 Iterator。

java.beans.beancontext 中 Iterator 的使用

实现 Iterator 的 java.beans.beancontext 中的类
protected static class BeanContextSupport.BCSIterator
受保护的最终子类，它封装一个迭代器但实现无操作 remove() 方法。

返回 Iterator 的 java.beans.beancontext 中的方法
protected  Iterator BeanContextSupport.bcsChildren()
返回此 BeanContext 所有子级的迭代器。
 Iterator BeanContextServices.getCurrentServiceClasses()
获得此上下文的当前可用服务。
 Iterator BeanContextServicesSupport.getCurrentServiceClasses()
 Iterator BeanContextServiceAvailableEvent.getCurrentServiceSelectors()
获得与服务相关的选择器列表。
 Iterator BeanContextServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
由 BeanContextServices 调用，此方法获得指定服务的当前服务选择器。
 Iterator BeanContextServicesSupport.BCSSProxyServiceProvider.getCurrentServiceSelectors(BeanContextServices bcs, Class serviceClass)
 Iterator BeanContextServices.getCurrentServiceSelectors(Class serviceClass)
通过在基础 BeanContextServiceProvider 上调用 getCurrentServiceSelectors() 获得指定服务的与服务有关的服务参数列表（服务选择器）。
 Iterator BeanContextServicesSupport.getCurrentServiceSelectors(Class serviceClass)
 Iterator BeanContextMembershipEvent.iterator()
获得受此事件影响的子级的数组。
 Iterator BeanContextSupport.iterator()
获得当前嵌套在此 BeanContext 中的所有 JavaBean 或 BeanContext 实例。

java.lang 中 Iterator 的使用

返回 Iterator 的 java.lang 中的方法
 Iterator<T> Iterable.iterator()
返回一个在一组 T 类型的元素上进行迭代的迭代器。

java.nio.charset.spi 中 Iterator 的使用

返回 Iterator 的 java.nio.charset.spi 中的方法
abstract  Iterator<Charset> CharsetProvider.charsets()
创建在此提供者所支持的 charset 上进行迭代的迭代器。

java.security.cert 中 Iterator 的使用

返回 Iterator 的 java.security.cert 中的方法
Iterator<String> | CertificateFactorySpi.engineGetCertPathEncodings() 返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
Iterator<String> | CertificateFactory.getCertPathEncodings() 返回此 CertificateFactory 支持的 CertPath 编码的迭代器，默认编码方式优先。
Iterator<? extends PolicyNode> | PolicyNode.getChildren() 返回在此节点的子节点上进行迭代的迭代器。
abstract Iterator<String> | CertPath.getEncodings() 返回此证书路径支持的编码的迭代，默认编码方式优先。

java.sql 中 Iterator 的使用

返回 Iterator 的 java.sql 中的方法
 Iterator<Throwable> SQLException.iterator()
返回在链接的 SQLExceptions 上进行迭代的迭代器。

java.util 中 Iterator 的使用

java.util 中 Iterator 的子接口
 interface ListIterator<E>
系列表迭代器，允许程序员按任一方向遍历列表、迭代期间修改列表，并获得迭代器在列表中的当前位置。

实现 Iterator 的 java.util 中的类
 class Scanner
一个可以使用正则表达式来解析基本类型和字符串的简单文本扫描器。

返回 Iterator 的 java.util 中的方法
Iterator<E> | ArrayDeque.descendingIterator()
Iterator<E> | TreeSet.descendingIterator() 返回在此 set 元素上按降序进行迭代的迭代器。
Iterator<E> | NavigableSet.descendingIterator() 以降序返回在此 set 的元素上进行迭代的迭代器。
Iterator<E> | LinkedList.descendingIterator()
Iterator<E> | Deque.descendingIterator() 返回以逆向顺序在此双端队列的元素上进行迭代的迭代器。
Iterator<E> | ArrayDeque.iterator() 返回在此双端队列的元素上进行迭代的迭代器。
Iterator<E> | PriorityQueue.iterator() 返回在此队列中的元素上进行迭代的迭代器。
Iterator<S> | ServiceLoader.iterator() 以延迟方式加载此加载器服务的可用提供者。
Iterator<E> | TreeSet.iterator() 返回在此 set 中的元素上按升序进行迭代的迭代器。
Iterator<E> | NavigableSet.iterator() 以升序返回在此 set 的元素上进行迭代的迭代器。
Iterator<E> | AbstractSequentialList.iterator() 返回在此列表中的元素上进行迭代的迭代器（按适当顺序）。
Iterator<E> | Deque.iterator() 返回以恰当顺序在此双端队列的元素上进行迭代的迭代器。
Iterator<E> | HashSet.iterator() 返回对此 set 中元素进行迭代的迭代器。
Iterator<E> | Set.iterator() 返回在此 set 中的元素上进行迭代的迭代器。
Iterator<E> | AbstractList.iterator() 返回以恰当顺序在此列表的元素上进行迭代的迭代器。
abstract Iterator<E> | AbstractCollection.iterator() 返回在此 collection 中的元素上进行迭代的迭代器。
Iterator<E> | List.iterator() 返回按适当顺序在列表的元素上进行迭代的迭代器。
Iterator<E> | Collection.iterator() 返回在此 collection 的元素上进行迭代的迭代器。

java.util.concurrent 中 Iterator 的使用

返回 Iterator 的 java.util.concurrent 中的方法
Iterator<E> | ConcurrentSkipListSet.descendingIterator() 返回在此 set 的元素上以降序进行迭代的迭代器。
Iterator<E> | LinkedBlockingDeque.descendingIterator() 返回在此双端队列的元素上以逆向连续顺序进行迭代的迭代器。
Iterator<E> | ArrayBlockingQueue.iterator() 返回在此队列中的元素上按适当顺序进行迭代的迭代器。
Iterator<E> | BlockingDeque.iterator() 返回在此双端队列中的元素上以恰当顺序进行迭代的迭代器。
Iterator<E> | ConcurrentLinkedQueue.iterator() 返回在此队列元素上以恰当顺序进行迭代的迭代器。
Iterator<E> | ConcurrentSkipListSet.iterator() 返回在此 set 的元素上以升序进行迭代的迭代器。
Iterator<E> | CopyOnWriteArrayList.iterator() 返回以恰当顺序在此列表元素上进行迭代的迭代器。
Iterator<E> | CopyOnWriteArraySet.iterator() 返回按照元素添加顺序在此 set 中包含的元素上进行迭代的迭代器。
Iterator<E> | DelayQueue.iterator() 返回在此队列所有元素（既包括到期的，也包括未到期的）上进行迭代的迭代器。
Iterator<E> | LinkedBlockingDeque.iterator() 返回在此双端队列元素上以恰当顺序进行迭代的迭代器。
Iterator<E> | LinkedBlockingQueue.iterator() 返回在队列中的元素上按适当顺序进行迭代的迭代器。
Iterator<E> | PriorityBlockingQueue.iterator() 返回在此队列元素上进行迭代的迭代器。
Iterator<E> | SynchronousQueue.iterator() 返回一个空迭代器，其中 hasNext 始终返回 false。

javax.imageio 中 Iterator 的使用

返回 Iterator 的 javax.imageio 中的方法
static Iterator<ImageReader> | ImageIO.getImageReaders(Object input) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。
static Iterator<ImageReader> | ImageIO.getImageReadersByFormatName(String formatName) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。
static Iterator<ImageReader> | ImageIO.getImageReadersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。
static Iterator<ImageReader> | ImageIO.getImageReadersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。
static Iterator<ImageTranscoder> | ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer) 返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。
abstract Iterator<ImageTypeSpecifier> | ImageReader.getImageTypes(int imageIndex) 以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。
static Iterator<ImageWriter> | ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
static Iterator<ImageWriter> | ImageIO.getImageWritersByFormatName(String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。
static Iterator<ImageWriter> | ImageIO.getImageWritersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。
static Iterator<ImageWriter> | ImageIO.getImageWritersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。
Iterator<IIOImage> | ImageReader.readAll(Iterator<? extends ImageReadParam> params) 以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

参数类型为 Iterator 的 javax.imageio 中的方法
protected static BufferedImage | ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height) 返回应该在其中写入解码的像素数据的 BufferedImage。
Iterator<IIOImage> | ImageReader.readAll(Iterator<? extends ImageReadParam> params) 以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

javax.imageio.spi 中 Iterator 的使用

返回 Iterator 的 javax.imageio.spi 中的方法
 Iterator<Class<?>> ServiceRegistry.getCategories()
返回指示当前类别集的 Class 对象的 Iterator。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, boolean useOrdering)
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass)
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。
static
<T> Iterator<T>
ServiceRegistry.lookupProviders(Class<T> providerClass, ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。

参数类型为 Iterator 的 javax.imageio.spi 中的方法
 void ServiceRegistry.registerServiceProviders(Iterator<?> providers)
将一组取自 Iterator 的服务提供者对象添加到注册表。

参数类型为 Iterator 的 javax.imageio.spi 中的构造方法
ServiceRegistry(Iterator<Class<?>> categories)
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。

javax.tools 中 Iterator 的使用

参数类型为 Iterator 的 javax.tools 中的方法
boolean | ForwardingJavaFileManager.handleOption(String current, Iterator<String> remaining)
boolean | JavaFileManager.handleOption(String current, Iterator<String> remaining) 处理一个选项。

javax.xml.crypto 中 Iterator 的使用

返回 Iterator 的 javax.xml.crypto 中的方法
 Iterator NodeSetData.iterator()
返回可按照文档顺序在此 NodeSetData 中包含的节点上进行迭代的只读迭代器。

javax.xml.crypto.dom 中 Iterator 的使用

返回 Iterator 的 javax.xml.crypto.dom 中的方法
 Iterator DOMCryptoContext.iterator()
返回可在此 DOMCryptoContext 的 Id/Element 映射集上进行迭代的只读迭代器。

javax.xml.namespace 中 Iterator 的使用

返回 Iterator 的 javax.xml.namespace 中的方法
 Iterator NamespaceContext.getPrefixes(String namespaceURI)
获取绑定到当前范围中名称空间 URI 的所有前缀。

javax.xml.soap 中 Iterator 的使用

返回 Iterator 的 javax.xml.soap 中的方法
Iterator | SOAPHeader.examineAllHeaderElements() 返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator。
Iterator | SOAPHeader.examineHeaderElements(String actor) 返回可在此 SOAPHeader 对象中具有指定的 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator。
Iterator | SOAPHeader.examineMustUnderstandHeaderElements(String actor) 返回可在此 SOAPHeader 对象中所有符合以下条件的 SOAPHeaderElement 对象上进行迭代的 Iterator：具有指定的 actor 以及一个值等于 true 的 MustUnderstand 属性。
Iterator | SOAPHeader.extractAllHeaderElements() 返回可在此 SOAPHeader 对象中所有 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
Iterator | SOAPHeader.extractHeaderElements(String actor) 返回可在此 SOAPHeader 对象中所有具有指定 actor 的 SOAPHeaderElement 对象上进行迭代的 Iterator，并将这些 SOAPHeaderElement 对象从此 SOAPHeader 对象中分离出来。
Iterator | SOAPElement.getAllAttributes() 返回可在此 SOAPElement 对象中所有属性 Name 对象上进行迭代的 Iterator。
Iterator | SOAPElement.getAllAttributesAsQNames() 返回可在此 SOAPElement 对象（以 QName 对象的形式）中的所有属性上进行迭代的 Iterator。
Iterator | MimeHeaders.getAllHeaders() 返回此 MimeHeaders 对象中的所有 MimeHeader。
abstract Iterator | AttachmentPart.getAllMimeHeaders() 以 MimeHeader 对象上的迭代器形式，检索此 AttachmentPart 对象的所有头。
abstract Iterator | SOAPPart.getAllMimeHeaders() 以可在 MimeHeader 对象上进行迭代的迭代器形式，检索此 SOAPPart 对象的所有头。
abstract Iterator | SOAPMessage.getAttachments() 检索所有作为此 SOAPMessage 对象一部分的 AttachmentPart 对象。
abstract Iterator | SOAPMessage.getAttachments(MimeHeaders headers) 检索所有头条目匹配指定头的 AttachmentPart 对象。
Iterator | SOAPElement.getChildElements() 返回可在此元素的所有直接子 Node 上进行迭代的 Iterator。
Iterator | SOAPElement.getChildElements(Name name) 返回可在带有指定名称的此元素所有直接子 Node 上进行迭代的 Iterator。
Iterator | SOAPElement.getChildElements(QName qname) 返回可在带有指定 qname 的此元素所有直接子 Node 上进行迭代的 Iterator。
Iterator | Detail.getDetailEntries() 获取在此 Detail 对象中所有 DetailEntry 上进行迭代的迭代器。
Iterator | SOAPFault.getFaultReasonLocales() 返回一个 Iterator，它可以在与 Reason Text 项关联的 Locale 独特序列上进行迭代。
Iterator | SOAPFault.getFaultReasonTexts() 返回一个 Iterator，它可以在包含此 SOAPFault 所有 Reason Text 项的 String 对象序列上进行迭代。
Iterator | SOAPFault.getFaultSubcodes() 以 QNames 迭代器形式获取此 SOAPFault 的 Subcode。
Iterator | MimeHeaders.getMatchingHeaders(String[] names) 返回其名称与给定名称数组中的任一名称匹配的所有 MimeHeader 对象。
abstract Iterator | AttachmentPart.getMatchingMimeHeaders(String[] names) 检索匹配给定数组中名称的所有 MimeHeader 对象。
abstract Iterator | SOAPPart.getMatchingMimeHeaders(String[] names) 检索与给定数组中的名称匹配的所有 MimeHeader 对象。
Iterator | SOAPElement.getNamespacePrefixes() 返回可在此元素声明的名称空间前缀 String 上进行迭代的 Iterator。
Iterator | MimeHeaders.getNonMatchingHeaders(String[] names) 返回其名称与给定名称数组中的任何名称都不匹配的所有 MimeHeader 对象。
abstract Iterator | AttachmentPart.getNonMatchingMimeHeaders(String[] names) 检索所有名称不匹配给定数组中任一名称的 MimeHeader 对象。
abstract Iterator | SOAPPart.getNonMatchingMimeHeaders(String[] names) 检索名称与给定数组中任一名称不匹配的所有 MimeHeader 对象。
Iterator | SOAPElement.getVisibleNamespacePrefixes() 返回在此元素可见的名称空间前缀 String 上进行迭代的 Iterator。

参数类型为 Iterator 的 javax.xml.soap 中的方法
 SOAPHeaderElement SOAPHeader.addUpgradeHeaderElement(Iterator supportedSOAPURIs)
创建使用指定的 SOAP URI 支持列表初始化的新的 Upgrade SOAPHeaderElement 对象，并将其添加到此 SOAPHeader 对象。

javax.xml.stream 中 Iterator 的使用

javax.xml.stream 中 Iterator 的子接口
 interface XMLEventReader
此类是用于解析 XML 事件的顶层接口。

参数类型为 Iterator 的 javax.xml.stream 中的方法
abstract EndElement | XMLEventFactory.createEndElement(QName name, Iterator namespaces) 创建一个新 EndElement。
abstract EndElement | XMLEventFactory.createEndElement(String prefix, String namespaceUri, String localName, Iterator namespaces) 创建一个新 EndElement。
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(QName name, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。
abstract StartElement | XMLEventFactory.createStartElement(String prefix, String namespaceUri, String localName, Iterator attributes, Iterator namespaces, NamespaceContext context) 创建一个新 StartElement。

javax.xml.stream.events 中 Iterator 的使用

返回 Iterator 的 javax.xml.stream.events 中的方法
Iterator | StartElement.getAttributes() 返回在此 START_ELEMENT 上声明的已声明非名称空间属性的 Iterator；如果没有这样的属性，则返回空迭代器。
Iterator | EndElement.getNamespaces() 返回超出范围名称空间的 Iterator。
Iterator | StartElement.getNamespaces() 返回在此元素上声明的名称空间的 Iterator。

javax.xml.stream.util 中 Iterator 的使用

实现 Iterator 的 javax.xml.stream.util 中的类
 class EventReaderDelegate
该类是用于派生 XMLEventReader 过滤器的基类。

javax.xml.ws 中 Iterator 的使用

返回 Iterator 的 javax.xml.ws 中的方法
 Iterator<QName> Service.getPorts()
返回一个 Iterator，它用于此服务所组合的服务端点的 QName 列表。

javax.xml.ws.spi 中 Iterator 的使用

返回 Iterator 的 javax.xml.ws.spi 中的方法
abstract  Iterator<QName> ServiceDelegate.getPorts()
返回一个 Iterator，该迭代器用于根据此服务分组的服务端点的 QName 列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Enumeration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Enumeration
的使用

使用 Enumeration 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans | 包含与开发 beans 有关的类，即基于 JavaBeansTM 架构的组件。
java.io | 通过数据流、序列化和文件系统提供系统输入和输出。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.acl | 此包中的类和接口已经被 java.security 包中的类取代。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
java.util.zip | 提供用于读写标准 ZIP 和 GZIP 文件格式的类。
javax.activation |
javax.management.loading | 提供实现高级动态加载的类。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
org.xml.sax.helpers | 此包包含“帮助器”类，其中包括对引导基于 SAX 的应用程序的支持。

java.applet 中 Enumeration 的使用

返回 Enumeration 的 java.applet 中的方法
 Enumeration<Applet> AppletContext.getApplets()
找到此 applet 上下文表示的文档中的所有 applet。

java.awt 中 Enumeration 的使用

返回 Enumeration 的 java.awt 中的方法
 Enumeration<MenuShortcut> MenuBar.shortcuts()
获取此菜单栏正在管理的所有菜单快捷方式的枚举。

java.beans 中 Enumeration 的使用

返回 Enumeration 的 java.beans 中的方法
 Enumeration<String> FeatureDescriptor.attributeNames()
获得与语言环境无关的此特性名称的枚举。

java.io 中 Enumeration 的使用

参数类型为 Enumeration 的 java.io 中的构造方法
SequenceInputStream(Enumeration<? extends InputStream> e)
通过记住参数来初始化新创建的 SequenceInputStream，该参数必须是生成运行时类型为 InputStream 对象的 Enumeration 型参数。

java.lang 中 Enumeration 的使用

返回 Enumeration 的 java.lang 中的方法
protected Enumeration<URL> | ClassLoader.findResources(String name) 返回表示所有具有给定名称的资源的 URL 对象的枚举。
Enumeration<URL> | ClassLoader.getResources(String name) 查找所有给定名称的资源。
static Enumeration<URL> | ClassLoader.getSystemResources(String name) 从用来加载类的搜索路径中查找所有具有指定名称的资源。

java.net 中 Enumeration 的使用

返回 Enumeration 的 java.net 中的方法
Enumeration<URL> | URLClassLoader.findResources(String name) 返回表示 URL 搜索路径中具有指定名称的所有资源的 URL 枚举。
Enumeration<InetAddress> | NetworkInterface.getInetAddresses() 一个便捷方法，返回一个具有绑定到此网络接口全部或部分 InetAddress 的 Enumeration。
static Enumeration<NetworkInterface> | NetworkInterface.getNetworkInterfaces() 返回此机器上的所有接口。
Enumeration<NetworkInterface> | NetworkInterface.getSubInterfaces() 获取具有连接到此网络接口的所有子接口（也称虚拟接口）的 Enumeration。

java.security 中 Enumeration 的使用

返回 Enumeration 的 java.security 中的方法
Enumeration<String> | KeyStore.aliases() 列出此 keystore 的所有别名。
Enumeration<Object> | Provider.elements()
Enumeration<Permission> | Permissions.elements() 返回此 Permissions 对象中所有 PermissionCollection 中的所有 Permission 对象的枚举。
abstract Enumeration<Permission> | PermissionCollection.elements() 返回集合中所有 Permission 对象的枚举。
abstract Enumeration<String> | KeyStoreSpi.engineAliases() 列出此 keystore 的所有别名。
abstract Enumeration<Identity> | IdentityScope.identities() 已过时。 返回此身份作用域内所有身份的枚举。
Enumeration<Object> | Provider.keys()

java.security.acl 中 Enumeration 的使用

返回 Enumeration 的 java.security.acl 中的方法
Enumeration<AclEntry> | Acl.entries() 返回此 ACL 中各项的枚举。
Enumeration<Permission> | Acl.getPermissions(Principal user) 返回一个指定主体（表示一个实体，如个体或组）的许可权限集合的枚举。
Enumeration<? extends Principal> | Group.members() 返回此组中成员的枚举。
Enumeration<Permission> | AclEntry.permissions() 返回此 ACL 项中各个权限的枚举。

java.sql 中 Enumeration 的使用

返回 Enumeration 的 java.sql 中的方法
static Enumeration<Driver> DriverManager.getDrivers()
获取带有当前调用者可以访问的所有当前已加载 JDBC 驱动程序的 Enumeration。

java.util 中 Enumeration 的使用

实现 Enumeration 的 java.util 中的类
 class StringTokenizer
string tokenizer 类允许应用程序将字符串分解为标记。

返回 Enumeration 的 java.util 中的方法
 Enumeration<E> Vector.elements()
返回此向量的组件的枚举。
 Enumeration<V> Hashtable.elements()
返回此哈希表中的值的枚举。
abstract  Enumeration<V> Dictionary.elements()
返回此 dictionary 中值的枚举。
static
<T> Enumeration<T>
Collections.enumeration(Collection<T> c)
返回一个指定 collection 上的枚举。
 Enumeration<String> PropertyResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
 Enumeration<String> ListResourceBundle.getKeys()
返回包含在此 ResourceBundle 及其父包中的键的 Enumeration。
abstract  Enumeration<String> ResourceBundle.getKeys()
返回键的枚举。
 Enumeration<K> Hashtable.keys()
返回此哈希表中的键的枚举。
abstract  Enumeration<K> Dictionary.keys()
返回此 dictionary 中的键的枚举。
 Enumeration<?> Properties.propertyNames()
返回属性列表中所有键的枚举，如果在主属性列表中未找到同名的键，则包括默认属性列表中不同的键。

参数类型为 Enumeration 的 java.util 中的方法
static
<T> ArrayList<T>
Collections.list(Enumeration<T> e)
返回一个数组列表，它按返回顺序包含指定枚举返回的元素。

java.util.concurrent 中 Enumeration 的使用

返回 Enumeration 的 java.util.concurrent 中的方法
Enumeration<V> | ConcurrentHashMap.elements() 返回此表中值的枚举。
Enumeration<K> | ConcurrentHashMap.keys() 返回此表中键的枚举。

java.util.jar 中 Enumeration 的使用

返回 Enumeration 的 java.util.jar 中的方法
 Enumeration<JarEntry> JarFile.entries()
返回 zip 文件条目的枚举。

java.util.logging 中 Enumeration 的使用

返回 Enumeration 的 java.util.logging 中的方法
 Enumeration<String> LogManager.getLoggerNames()
获取已知 logger 名称的枚举。

java.util.zip 中 Enumeration 的使用

返回 Enumeration 的 java.util.zip 中的方法
 Enumeration<? extends ZipEntry> ZipFile.entries()
返回 ZIP 文件条目的枚举。

javax.activation 中 Enumeration 的使用

返回 Enumeration 的 javax.activation 中的方法
 Enumeration MimeTypeParameterList.getNames()
获取此列表中所有名称的枚举。

javax.management.loading 中 Enumeration 的使用

返回 Enumeration 的 javax.management.loading 中的方法
 Enumeration<URL> MLetMBean.getResources(String name)
查找所有具有给定名称的资源。

javax.naming 中 Enumeration 的使用

javax.naming 中 Enumeration 的子接口
 interface NamingEnumeration<T>
此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。

返回 Enumeration 的 javax.naming 中的方法
Enumeration<String> | CompositeName.getAll() 以字符串枚举的形式检索此复合名称的组件。
Enumeration<String> | CompoundName.getAll() 以字符串枚举的形式检索此组合名称的组件。
Enumeration<String> | Name.getAll() 以字符串枚举的形式检索此名称的组件。
Enumeration<RefAddr> | Reference.getAll() 返回此索引中的地址所组成的枚举。

参数类型为 Enumeration 的 javax.naming 中的构造方法
CompositeName(Enumeration<String> comps)
使用由 'comps' 指定的组件构造一个新的复合名称实例。
CompoundName(Enumeration<String> comps, Properties syntax)
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。

javax.naming.ldap 中 Enumeration 的使用

返回 Enumeration 的 javax.naming.ldap 中的方法
 Enumeration<String> LdapName.getAll()
以字符串枚举的形式检索此名称的组件。

javax.net.ssl 中 Enumeration 的使用

返回 Enumeration 的 javax.net.ssl 中的方法
 Enumeration SSLSessionContext.getIds()
返回在此 SSLSessionContext 下分组的所有会话 id 的 Enumeration。

javax.security.sasl 中 Enumeration 的使用

返回 Enumeration 的 javax.security.sasl 中的方法
static Enumeration<SaslClientFactory> | Sasl.getSaslClientFactories() 获得用于生成 SaslClient 的已知工厂的枚举。
static Enumeration<SaslServerFactory> | Sasl.getSaslServerFactories() 获得用于生成 SaslServer 的已知工厂的枚举。

javax.sql.rowset.spi 中 Enumeration 的使用

返回 Enumeration 的 javax.sql.rowset.spi 中的方法
static Enumeration<SyncProvider> SyncFactory.getRegisteredProviders()
返回当前已注册的同步提供者所组成的枚举。

javax.swing 中 Enumeration 的使用

返回 Enumeration 的 javax.swing 中的方法
Enumeration | JTree.DynamicUtilTreeNode.children() 必要时创建子类以加载此子节点。
Enumeration<?> | DefaultListModel.elements() 返回此列表的组件枚举。
protected Enumeration<TreePath> | JTree.getDescendantToggledPaths(TreePath parent) 返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
Enumeration<AbstractButton> | ButtonGroup.getElements() 返回此组中的所有按钮。
Enumeration<TreePath> | JTree.getExpandedDescendants(TreePath parent) 返回当前展开的 parent 路径的子路径的 Enumeration。

参数类型为 Enumeration 的 javax.swing 中的方法
protected  void JTree.removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
移除已展开的 toRemove 中 TreePath 的所有子路径。

javax.swing.table 中 Enumeration 的使用

返回 Enumeration 的 javax.swing.table 中的方法
Enumeration<TableColumn> | DefaultTableColumnModel.getColumns() 返回该模型中所有列的一个 Enumeration。
Enumeration<TableColumn> | TableColumnModel.getColumns() 返回该模型中所有列的 Enumeration。

javax.swing.text 中 Enumeration 的使用

返回 Enumeration 的 javax.swing.text 中的方法
abstract Enumeration | AbstractDocument.AbstractElement.children() 以 Enumeration 形式返回接收方的子级。
Enumeration | AbstractDocument.BranchElement.children() 以 Enumeration 的形式返回接收者的子级。
Enumeration | AbstractDocument.LeafElement.children() 以 Enumeration 的形式返回接收者的子级。
Enumeration<?> | SimpleAttributeSet.getAttributeNames() 获取集合中的属性名称。
Enumeration<?> | AttributeSet.getAttributeNames() 返回集合中本地定义的属性名称的枚举。
Enumeration<?> | StyleContext.SmallAttributeSet.getAttributeNames() 获取所有属性的名称。
Enumeration<?> | StyleContext.NamedStyle.getAttributeNames() 获取所有属性的名称。
Enumeration<?> | AbstractDocument.AbstractElement.getAttributeNames() 获取所有属性的名称。
Enumeration<?> | DefaultStyledDocument.getStyleNames() 获取样式名称列表。
Enumeration<?> | StyleContext.getStyleNames() 获取定义的样式名称。

参数类型为 Enumeration 的 javax.swing.text 中的方法
AttributeSet | StyleContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一个属性集。
AttributeSet | AbstractDocument.AttributeContext.removeAttributes(AttributeSet old, Enumeration<?> names) 移除元素的一组属性。
void | SimpleAttributeSet.removeAttributes(Enumeration<?> names) 从列表中移除属性集。
void | MutableAttributeSet.removeAttributes(Enumeration<?> names) 移除具有给定 name 的属性集。
void | StyleContext.NamedStyle.removeAttributes(Enumeration<?> names) 移除元素的属性集。
void | AbstractDocument.AbstractElement.removeAttributes(Enumeration<?> names) 移除该元素的属性集合。

javax.swing.text.html 中 Enumeration 的使用

参数类型为 Enumeration 的 javax.swing.text.html 中的方法
 AttributeSet StyleSheet.removeAttributes(AttributeSet old, Enumeration<?> names)
移除元素的属性集。

javax.swing.text.html.parser 中 Enumeration 的使用

返回 Enumeration 的 javax.swing.text.html.parser 中的方法
 Enumeration<?> AttributeList.getValues()

javax.swing.tree 中 Enumeration 的使用

声明为 Enumeration 的 javax.swing.tree 中的字段
static Enumeration<TreeNode> DefaultMutableTreeNode.EMPTY_ENUMERATION
始终为空的枚举。

返回 Enumeration 的 javax.swing.tree 中的方法
Enumeration | DefaultMutableTreeNode.breadthFirstEnumeration() 创建并返回一个枚举，该枚举按广度优先的顺序遍历以此节点为根的子树。
Enumeration | DefaultMutableTreeNode.children() 创建并返回此节点的子节点的正向枚举。
Enumeration | TreeNode.children() 以 Enumeration 的形式返回接收者的子节点。
Enumeration | DefaultMutableTreeNode.depthFirstEnumeration() 创建并返回一个枚举，该枚举按深度优先的顺序遍历以此节点为根的子树。
Enumeration<TreePath> | FixedHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回表示从传入位置开始的可见路径的增量的 Enumerator。
Enumeration<TreePath> | VariableHeightLayoutCache.getVisiblePathsFrom(TreePath path) 返回从传入位置开始的可见路径的增量的 Enumerator。
abstract Enumeration<TreePath> | AbstractLayoutCache.getVisiblePathsFrom(TreePath path) 返回一个 Enumerator，它列举从传入位置开始的可视路径的增量。
Enumeration | DefaultMutableTreeNode.pathFromAncestorEnumeration(TreeNode ancestor) 创建并返回沿着从 ancestor 到此节点的路径的一个枚举。
Enumeration | DefaultMutableTreeNode.postorderEnumeration() 创建并返回按后序遍历以此节点为根的树的一个枚举。
Enumeration | DefaultMutableTreeNode.preorderEnumeration() 创建并返回按前序遍历以此节点为根的子树的一个枚举。

org.xml.sax.helpers 中 Enumeration 的使用

返回 Enumeration 的 org.xml.sax.helpers 中的方法
Enumeration | NamespaceSupport.getDeclaredPrefixes() 返回此上下文中声明的所有前缀的枚举。
Enumeration | NamespaceSupport.getPrefixes() 返回所有前缀的枚举，其声明在当前上下文中是活动的。
Enumeration | NamespaceSupport.getPrefixes(String uri) 返回给定 URI 的 所有前缀的枚举，给定 URI 的声明在当前上下文中是活动的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Stack 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Stack
的使用

没有 java.util.Stack 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.HashMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.HashMap
的使用

使用 HashMap 的软件包
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.beans.beancontext 中 HashMap 的使用

声明为 HashMap 的 java.beans.beancontext 中的字段
protected HashMap | BeanContextSupport.children protected HashMap children 字段的所有访问在该对象上都将是同步的。
protected HashMap | BeanContextServicesSupport.services protected transient HashMap services 字段的所有访问在该对象上都应该是同步的。

java.util 中 HashMap 的使用

java.util 中 HashMap 的子类
 class LinkedHashMap<K,V>
Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。

javax.print.attribute.standard 中 HashMap 的使用

javax.print.attribute.standard 中 HashMap 的子类
 class PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractMap
的使用

使用 AbstractMap 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 AbstractMap 的使用

java.util 中 AbstractMap 的子类
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | WeakHashMap<K,V> 以弱键 实现的基于哈希表的 Map。

java.util.concurrent 中 AbstractMap 的使用

java.util.concurrent 中 AbstractMap 的子类
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。

javax.print.attribute.standard 中 AbstractMap 的使用

javax.print.attribute.standard 中 AbstractMap 的子类
 class PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Vector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Vector
的使用

使用 Vector 的软件包
java.awt.image | 提供创建和修改图像的各种类。
java.awt.image.renderable | 提供用于生成与呈现无关的图像的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

java.awt.image 中 Vector 的使用

返回 Vector 的 java.awt.image 中的方法
Vector<RenderedImage> | BufferedImage.getSources() 返回 RenderedImage 对象的 Vector，该对象是此 BufferedImage 图像数据的直接来源，而不是这些直接来源的来源。
Vector<RenderedImage> | RenderedImage.getSources() 返回作为此 RenderedImage 直接图像数据源的 RenderedImage 向量。

java.awt.image.renderable 中 Vector 的使用

声明为 Vector 的 java.awt.image.renderable 中的字段
protected Vector<Object> | ParameterBlock.parameters 一个非源参数的 Vector，存储为任意 Object。
protected Vector<Object> | ParameterBlock.sources 源的 Vector，存储为任意 Objects。

返回 Vector 的 java.awt.image.renderable 中的方法
Vector<Object> | ParameterBlock.getParameters() 返回参数的整个 Vector。
Vector<Object> | ParameterBlock.getSources() 返回源的整个 Vector。
Vector<RenderableImage> | RenderableImage.getSources() 返回作为此 RenderableImage 的图像数据源的 RenderableImage 的向量。
Vector<RenderableImage> | RenderableImageOp.getSources() 返回作为此 RenderableImage 图像数据源的 RenderableImage 的向量。

参数类型为 Vector 的 java.awt.image.renderable 中的方法
void | ParameterBlock.setParameters(Vector<Object> parameters) 将参数的整个 Vector 设置为给定 Vector。
void | ParameterBlock.setSources(Vector<Object> sources) 将源的整个 Vector 设置为给定 Vector。

参数类型为 Vector 的 java.awt.image.renderable 中的构造方法
ParameterBlock(Vector<Object> sources)
使用源的给定 Vector 构造一个 ParameterBlock。
ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。
ParameterBlock(Vector<Object> sources, Vector<Object> parameters)
使用源的给定 Vector 和参数的 Vector 构造一个 ParameterBlock。

java.util 中 Vector 的使用

java.util 中 Vector 的子类
 class Stack<E>
Stack 类表示后进先出（LIFO）的对象堆栈。

javax.accessibility 中 Vector 的使用

声明为 Vector 的 javax.accessibility 中的字段
protected Vector<AccessibleRelation> | AccessibleRelationSet.relations Vector 中的每个项表示一个 AccessibleRelation。
protected Vector<AccessibleState> | AccessibleStateSet.states Vector 中的每个项表示一个 AccessibleState。

javax.management 中 Vector 的使用

返回 Vector 的 javax.management 中的方法
Vector<String> | AttributeChangeNotificationFilter.getEnabledAttributes() 获得此过滤器的所有已启用属性名称。
Vector<String> | NotificationFilterSupport.getEnabledTypes() 获得此过滤器的所有允许通知类型。

javax.management.relation 中 Vector 的使用

返回 Vector 的 javax.management.relation 中的方法
Vector<ObjectName> | MBeanServerNotificationFilter.getDisabledObjectNames() 获取禁用的所有 ObjectName。
Vector<ObjectName> | MBeanServerNotificationFilter.getEnabledObjectNames() 获取所有已启用的 ObjectName。

javax.management.timer 中 Vector 的使用

返回 Vector 的 javax.management.timer 中的方法
Vector<Integer> | Timer.getAllNotificationIDs() 获得所有在通知列表中注册的计时器通知标识符。
Vector<Integer> | TimerMBean.getAllNotificationIDs() 获得所有在通知的列表中注册的计时器通知标识符。
Vector<Integer> | Timer.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。
Vector<Integer> | TimerMBean.getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。

javax.naming 中 Vector 的使用

声明为 Vector 的 javax.naming 中的字段
protected  Vector<RefAddr> Reference.addrs
包含此 Reference 中所包含的地址。

javax.naming.directory 中 Vector 的使用

声明为 Vector 的 javax.naming.directory 中的字段
protected  Vector<Object> BasicAttribute.values
保存属性的值。

javax.sound.midi 中 Vector 的使用

声明为 Vector 的 javax.sound.midi 中的字段
protected  Vector<Track> Sequence.tracks
此 sequence 中的 MIDI 轨道。

javax.sql.rowset.serial 中 Vector 的使用

参数类型为 Vector 的 javax.sql.rowset.serial 中的构造方法
SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.swing 中 Vector 的使用

声明为 Vector 的 javax.swing 中的字段
protected  Vector<AbstractButton> ButtonGroup.buttons

参数类型为 Vector 的 javax.swing 中的方法
 void JList.setListData(Vector<?> listData)
根据一个 Vector 构造只读 ListModel，然后对此模型调用 setModel。

参数类型为 Vector 的 javax.swing 中的构造方法
DefaultComboBoxModel(Vector<?> v)
构造一个用向量初始化的 DefaultComboBoxModel 对象。
JComboBox(Vector<?> items)
创建包含指定 Vector 中的元素的 JComboBox。
JList(Vector<?> listData)
构造一个 JList，使其显示指定 Vector 中的元素。
JTable(Vector rowData, Vector columnNames)
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。
JTable(Vector rowData, Vector columnNames)
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。
JTree(Vector<?> value)
返回 JTree，指定 Vector 的每个元素作为不被显示的新根节点的子节点。

javax.swing.plaf.basic 中 Vector 的使用

返回 Vector 的 javax.swing.plaf.basic 中的方法
Vector<File> | BasicDirectoryModel.getDirectories()
Vector<File> | BasicDirectoryModel.getFiles()

参数类型为 Vector 的 javax.swing.plaf.basic 中的方法
protected  void BasicDirectoryModel.sort(Vector<? extends File> v)

javax.swing.plaf.multi 中 Vector 的使用

声明为 Vector 的 javax.swing.plaf.multi 中的字段
protected Vector | MultiButtonUI.uis 包含实际 UI 的向量。
protected Vector | MultiColorChooserUI.uis 包含实际 UI 的向量。
protected Vector | MultiComboBoxUI.uis 包含实际 UI 的向量。
protected Vector | MultiDesktopIconUI.uis 包含实际 UI 的向量。
protected Vector | MultiDesktopPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiFileChooserUI.uis 包含实际 UI 的向量。
protected Vector | MultiInternalFrameUI.uis 包含实际 UI 的向量。
protected Vector | MultiLabelUI.uis 包含实际 UI 的向量。
protected Vector | MultiListUI.uis 包含实际 UI 的向量。
protected Vector | MultiMenuBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiMenuItemUI.uis 包含实际 UI 的向量。
protected Vector | MultiOptionPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiPanelUI.uis 包含实际 UI 的向量。
protected Vector | MultiPopupMenuUI.uis 包含实际 UI 的向量。
protected Vector | MultiProgressBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiRootPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiScrollBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiScrollPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiSeparatorUI.uis 包含实际 UI 的向量。
protected Vector | MultiSliderUI.uis 包含实际 UI 的向量。
protected Vector | MultiSpinnerUI.uis 包含实际 UI 的向量。
protected Vector | MultiSplitPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiTabbedPaneUI.uis 包含实际 UI 的向量。
protected Vector | MultiTableHeaderUI.uis 包含实际 UI 的向量。
protected Vector | MultiTableUI.uis 包含实际 UI 的向量。
protected Vector | MultiTextUI.uis 包含实际 UI 的向量。
protected Vector | MultiToolBarUI.uis 包含实际 UI 的向量。
protected Vector | MultiToolTipUI.uis 包含实际 UI 的向量。
protected Vector | MultiTreeUI.uis 包含实际 UI 的向量。
protected Vector | MultiViewportUI.uis 包含实际 UI 的向量。

参数类型为 Vector 的 javax.swing.plaf.multi 中的方法
static ComponentUI | MultiLookAndFeel.createUIs(ComponentUI mui, Vector uis, JComponent target) 创建表示 target 组件所需的 ComponentUI 对象，将对象放入 uis 向量中，并返回最能表示该组件 UI 的 ComponentUI 对象。
protected static ComponentUI[] | MultiLookAndFeel.uisToArray(Vector uis) 创建一个数组，使用来自传入向量的 UI 对象填充它并返回该数组。

javax.swing.table 中 Vector 的使用

声明为 Vector 的 javax.swing.table 中的字段
protected Vector | DefaultTableModel.columnIdentifiers Vector，由多个列标识符组成。
protected Vector | DefaultTableModel.dataVector Vector，由包含多个 Object 值的 Vector 组成。
protected Vector<TableColumn> | DefaultTableColumnModel.tableColumns 此模型中 TableColumn 对象组成的数组

返回 Vector 的 javax.swing.table 中的方法
protected static Vector | DefaultTableModel.convertToVector(Object[] anArray) 返回一个包含与该数组相同的对象的向量。
protected static Vector | DefaultTableModel.convertToVector(Object[][] anArray) 返回一个 vector，该 vector 由包含与该数组相同的对象的多个 vector 组成。
Vector | DefaultTableModel.getDataVector() 返回由多个包含表数据值的 Vector 组成的 Vector。

参数类型为 Vector 的 javax.swing.table 中的方法
void | DefaultTableModel.addColumn(Object columnName, Vector columnData) 将一列添加到模型中。
void | DefaultTableModel.addRow(Vector rowData) 添加一行到模型的结尾。
void | DefaultTableModel.insertRow(int row, Vector rowData) 在模型中的 row 位置插入一行。
void | DefaultTableModel.setColumnIdentifiers(Vector columnIdentifiers) 替换模型中的列标识符。
void | DefaultTableModel.setDataVector(Vector dataVector, Vector columnIdentifiers) 用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。
void | DefaultTableModel.setDataVector(Vector dataVector, Vector columnIdentifiers) 用新的行 Vector（dataVector）替换当前的 dataVector 实例变量。

参数类型为 Vector 的 javax.swing.table 中的构造方法
DefaultTableModel(Vector columnNames, int rowCount)
构造一个 DefaultTableModel，它的列数与 columnNames 中元素的数量相同，并具有 rowCount 行 null 对象值。
DefaultTableModel(Vector data, Vector columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。
DefaultTableModel(Vector data, Vector columnNames)
构造一个 DefaultTableModel，并通过将 data 和 columnNames 传递到 setDataVector 方法来初始化该表。

javax.swing.text 中 Vector 的使用

返回 Vector 的 javax.swing.text 中的方法
protected Vector | StringContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
protected Vector | GapContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。

参数类型为 Vector 的 javax.swing.text 中的方法
protected Vector | StringContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
protected Vector | GapContent.getPositionsInRange(Vector v, int offset, int length) 返回一个包含 UndoPosRef 实例的 Vector，其 Position 的范围从 offset 到 offset + length。
protected void | StringContent.updateUndoPositions(Vector positions) 在 positions 处重新设置所有 UndoPosRef 实例的位置。
protected void | GapContent.updateUndoPositions(Vector positions, int offset, int length) 重新设置处在 positions 的所有 UndoPosRef 实例的位置。

javax.swing.text.html 中 Vector 的使用

声明为 Vector 的 javax.swing.text.html 中的字段
protected  Vector<DefaultStyledDocument.ElementSpec> HTMLDocument.HTMLReader.parseBuffer

javax.swing.text.html.parser 中 Vector 的使用

声明为 Vector 的 javax.swing.text.html.parser 中的字段
Vector<Element> | DTD.elements
Vector<?> | AttributeList.values

参数类型为 Vector 的 javax.swing.text.html.parser 中的方法
 void ContentModel.getElements(Vector<Element> elemVec)
使用作为此 contentModel 一部分的元素列表更新 elemVec。

参数类型为 Vector 的 javax.swing.text.html.parser 中的构造方法
AttributeList(String name, int type, int modifier, String value, Vector<?> values, AttributeList next)
创建一个属性列表元素。

javax.swing.tree 中 Vector 的使用

声明为 Vector 的 javax.swing.tree 中的字段
protected  Vector DefaultMutableTreeNode.children
子节点的数组，如果此节点没有子节点，则可以为 null

参数类型为 Vector 的 javax.swing.tree 中的方法
protected  void DefaultTreeSelectionModel.notifyPathChange(Vector<javax.swing.tree.PathPlaceHolder> changedPaths, TreePath oldLeadSelection)
通知侦听器路径中的更改。

javax.swing.undo 中 Vector 的使用

声明为 Vector 的 javax.swing.undo 中的字段
protected Vector<UndoableEdit> | CompoundEdit.edits 由此 CompoundEdit 全部撤消/恢复的 UndoableEdit 的集合。
protected Vector<UndoableEditListener> | UndoableEditSupport.listeners

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractMap.SimpleEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractMap.SimpleEntry
的使用

没有 java.util.AbstractMap.SimpleEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractMap.SimpleImmutableEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractMap.SimpleImmutableEntry
的使用

没有 java.util.AbstractMap.SimpleImmutableEntry 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Comparator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Comparator
的使用

使用 Comparator 的软件包
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.lang 中 Comparator 的使用

声明为 Comparator 的 java.lang 中的字段
static Comparator<String> String.CASE_INSENSITIVE_ORDER
一个对 String 对象进行排序的 Comparator，作用与 compareToIgnoreCase 相同。

java.text 中 Comparator 的使用

实现 Comparator 的 java.text 中的类
class | Collator Collator 类执行区分语言环境的 String 比较。
class | RuleBasedCollator RuleBasedCollator 类是 Collator 的具体子类，它提供了一个简单的、数据驱动的表 collator。

java.util 中 Comparator 的使用

返回 Comparator 的 java.util 中的方法
 Comparator<? super E> PriorityQueue.comparator()
返回用来对此队列中的元素进行排序的比较器；如果此队列根据其元素的自然顺序进行排序，则返回 null。
 Comparator<? super E> TreeSet.comparator()
 Comparator<? super E> SortedSet.comparator()
返回对此 set 中的元素进行排序的比较器；如果此 set 使用其元素的自然顺序，则返回 null。
 Comparator<? super K> TreeMap.comparator()
 Comparator<? super K> SortedMap.comparator()
返回对此映射中的键进行排序的比较器；如果此映射使用键的自然顺序，则返回 null。
static
<T> Comparator<T>
Collections.reverseOrder()
返回一个比较器，它强行逆转实现了 Comparable 接口的对象 collection 的自然顺序。
static
<T> Comparator<T>
Collections.reverseOrder(Comparator<T> cmp)
返回一个比较器，它强行逆转指定比较器的顺序。

参数类型为 Comparator 的 java.util 中的方法
static
<T> int
Collections.binarySearch(List<? extends T> list, T key, Comparator<? super T> c)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<T> int
Arrays.binarySearch(T[] a, int fromIndex, int toIndex, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组的范围，以获得指定对象。
static
<T> int
Arrays.binarySearch(T[] a, T key, Comparator<? super T> c)
使用二分搜索法来搜索指定数组，以获得指定对象。
static
<T> T
Collections.max(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最大元素。
static
<T> T
Collections.min(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最小元素。
static
<T> Comparator<T>
Collections.reverseOrder(Comparator<T> cmp)
返回一个比较器，它强行逆转指定比较器的顺序。
static
<T> void
Collections.sort(List<T> list, Comparator<? super T> c)
根据指定比较器产生的顺序对指定列表进行排序。
static
<T> void
Arrays.sort(T[] a, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组进行排序。
static
<T> void
Arrays.sort(T[] a, int fromIndex, int toIndex, Comparator<? super T> c)
根据指定比较器产生的顺序对指定对象数组的指定范围进行排序。

参数类型为 Comparator 的 java.util 中的构造方法
PriorityQueue(int initialCapacity, Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityQueue，并根据指定的比较器对元素进行排序。
TreeMap(Comparator<? super K> comparator)
构造一个新的、空的树映射，该映射根据给定比较器进行排序。
TreeSet(Comparator<? super E> comparator)
构造一个新的空 TreeSet，它根据指定比较器进行排序。

java.util.concurrent 中 Comparator 的使用

返回 Comparator 的 java.util.concurrent 中的方法
Comparator<? super K> | ConcurrentSkipListMap.comparator()
Comparator<? super E> | ConcurrentSkipListSet.comparator()
Comparator<? super E> | PriorityBlockingQueue.comparator() 返回用于对此队列元素进行排序的比较器；如果此队列使用其元素的自然顺序，则返回 null。

参数类型为 Comparator 的 java.util.concurrent 中的构造方法
ConcurrentSkipListMap(Comparator<? super K> comparator)
构造一个新的空映射，该映射按照指定的比较器进行排序。
ConcurrentSkipListSet(Comparator<? super E> comparator)
构造一个新的空 set，该 set 按照指定的比较器对其元素进行排序。
PriorityBlockingQueue(int initialCapacity, Comparator<? super E> comparator)
使用指定的初始容量创建一个 PriorityBlockingQueue，并根据指定的比较器对其元素进行排序。

javax.swing 中 Comparator 的使用

返回 Comparator 的 javax.swing 中的方法
protected Comparator<? super Component> | SortingFocusTraversalPolicy.getComparator() 返回将用于对焦点遍历循环中的 Components 排序的 Comparator。
Comparator<?> | DefaultRowSorter.getComparator(int column) 返回指定列的 Comparator。

参数类型为 Comparator 的 javax.swing 中的方法
protected void | SortingFocusTraversalPolicy.setComparator(Comparator<? super Component> comparator) 设置将用于对焦点遍历循环中的 Components 排序的 Comparator。
void | DefaultRowSorter.setComparator(int column, Comparator<?> comparator) 设置对指定列进行排序时要使用的 Comparator。

参数类型为 Comparator 的 javax.swing 中的构造方法
SortingFocusTraversalPolicy(Comparator<? super Component> comparator)
构造具有指定 Comparator 的 SortingFocusTraversalPolicy。

javax.swing.table 中 Comparator 的使用

返回 Comparator 的 javax.swing.table 中的方法
 Comparator<?> TableRowSorter.getComparator(int column)
返回指定列的 Comparator。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractList
的使用

使用 AbstractList 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。

java.util 中 AbstractList 的使用

java.util 中 AbstractList 的子类
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | Vector<E> Vector 类可以实现可增长的对象数组。

javax.management 中 AbstractList 的使用

javax.management 中 AbstractList 的子类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 AbstractList 的使用

javax.management.relation 中 AbstractList 的子类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.AbstractCollection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.AbstractCollection
的使用

使用 AbstractCollection 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

java.util 中 AbstractCollection 的使用

java.util 中 AbstractCollection 的子类
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 AbstractCollection 的使用

java.util.concurrent 中 AbstractCollection 的子类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

javax.management 中 AbstractCollection 的使用

javax.management 中 AbstractCollection 的子类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 AbstractCollection 的使用

javax.management.relation 中 AbstractCollection 的子类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

javax.print.attribute.standard 中 AbstractCollection 的使用

javax.print.attribute.standard 中 AbstractCollection 的子类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.RandomAccess 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.RandomAccess
的使用

使用 RandomAccess 的软件包
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。

java.util 中 RandomAccess 的使用

实现 RandomAccess 的 java.util 中的类
class | ArrayList<E> List 接口的大小可变数组的实现。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | Vector<E> Vector 类可以实现可增长的对象数组。

java.util.concurrent 中 RandomAccess 的使用

实现 RandomAccess 的 java.util.concurrent 中的类
 class CopyOnWriteArrayList<E>
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

javax.management 中 RandomAccess 的使用

实现 RandomAccess 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

javax.management.relation 中 RandomAccess 的使用

实现 RandomAccess 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.List 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.List
的使用

使用 List 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.dnd | Drag 和 Drop 是一种直接操作动作，在许多图形用户界面系统中都会遇到它，它提供了一种机制，能够在两个与 GUI 中显示元素逻辑相关的实体之间传输信息。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.logging | 提供 JavaTM 2 平台核心日志工具的类和接口。
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。
javax.xml.crypto.dsig | 用于生成和验证 XML 数字签名的类。
javax.xml.crypto.dsig.keyinfo | 用来解析和处理 KeyInfo 元素和结构的类。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。
javax.xml.stream.events |
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.xpath | 此包提供了用于 XPath 表达式的计算和访问计算环境的 object-model neutral API。

java.awt 中 List 的使用

返回 List 的 java.awt 中的方法
List<Image> | Window.getIconImages() 返回要作为此窗口的图标显示的图像序列。
protected List<KeyEventDispatcher> | KeyboardFocusManager.getKeyEventDispatchers() 作为 List 返回此 KeyboardFocusManager 的 KeyEventDispatcher 链。
protected List<KeyEventPostProcessor> | KeyboardFocusManager.getKeyEventPostProcessors() 作为 List 返回此 KeyboardFocusManager 的 KeyEventPostProcessor 链。

参数类型为 List 的 java.awt 中的方法
 void Window.setIconImages(List<? extends Image> icons)
设置要作为此窗口的图标显示的图像序列。

java.awt.datatransfer 中 List 的使用

返回 List 的 java.awt.datatransfer 中的方法
List<DataFlavor> | SystemFlavorMap.getFlavorsForNative(String nat) 返回数据传输子系统可以将指定 String native 转换成的 DataFlavor 的 List。
List<DataFlavor> | FlavorTable.getFlavorsForNative(String nat) 返回与指定 String 对应的 DataFlavor 的 List。
List<String> | SystemFlavorMap.getNativesForFlavor(DataFlavor flav) 返回数据传输子系统可以将指定 DataFlavor 转换成的 String native 的 List。
List<String> | FlavorTable.getNativesForFlavor(DataFlavor flav) 返回与指定 DataFlavor 对应的 String native 的 List。

java.awt.dnd 中 List 的使用

返回 List 的 java.awt.dnd 中的方法
List<DataFlavor> | DropTargetDragEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前的 DataFlavor
List<DataFlavor> | DropTargetDropEvent.getCurrentDataFlavorsAsList() 此方法以 java.util.List 形式返回当前可用的 DataFlavor。
protected List<DataFlavor> | DropTargetContext.getCurrentDataFlavorsAsList() 此方法返回 Transferable 操作数当前可用的 DataFlavor，作为一个 java.util.List。

参数类型为 List 的 java.awt.dnd 中的构造方法
DragGestureEvent(DragGestureRecognizer dgr, int act, Point ori, List<? extends InputEvent> evs)
在给定激发此事件的 DragGestureRecognizer、表示用户首选操作的 int、指示拖动原点的 Point，以及组成动作的事件 List 的情况下，构造一个 DragGestureEvent。

java.lang 中 List 的使用

返回 List 的 java.lang 中的方法
 List<String> ProcessBuilder.command()
返回此进程生成器的操作系统程序和参数。

参数类型为 List 的 java.lang 中的方法
 ProcessBuilder ProcessBuilder.command(List<String> command)
设置此进程生成器的操作系统程序和参数。

参数类型为 List 的 java.lang 中的构造方法
ProcessBuilder(List<String> command)
利用指定的操作系统程序和参数构造一个进程生成器。

java.lang.management 中 List 的使用

返回 List 的 java.lang.management 中的方法
static List<GarbageCollectorMXBean> | ManagementFactory.getGarbageCollectorMXBeans() 返回 Java 虚拟机中的 GarbageCollectorMXBean 对象列表。
List<String> | RuntimeMXBean.getInputArguments() 返回传递给 Java 虚拟机的输入变量，其中不包括传递给 main 方法的变量。
static List<MemoryManagerMXBean> | ManagementFactory.getMemoryManagerMXBeans() 返回 Java 虚拟机中的 MemoryManagerMXBean 对象列表。
static List<MemoryPoolMXBean> | ManagementFactory.getMemoryPoolMXBeans() 返回 Java 虚拟机中的 MemoryPoolMXBean 对象列表。

java.net 中 List 的使用

返回 List 的 java.net 中的方法
List<HttpCookie> | CookieStore.get(URI uri) 获取与给定 URI 关联或其域与给定 URI 匹配的 cookie。
List<HttpCookie> | CookieStore.getCookies() 获取 cookie 存储区中所有未过期的 cookie。
List<InterfaceAddress> | NetworkInterface.getInterfaceAddresses() 获取此网络接口的全部或部分 InterfaceAddresses 所组成的列表。
abstract List<Certificate> | SecureCacheResponse.getLocalCertificateChain() 返回在获得了网络资源的初始连接的联络期间发送到服务器的证书链。
abstract List<Certificate> | SecureCacheResponse.getServerCertificateChain() 从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。
List<URI> | CookieStore.getURIs() 获取所有标识此 cookie 存储区中 cookie 的 URI。
static List<HttpCookie> | HttpCookie.parse(String header) 根据 set-cookie 或 set-cookie2 头字符串构造 cookie。
abstract List<Proxy> | ProxySelector.select(URI uri) 基于访问资源所需的协议和访问资源的目标地址选择所有可用的代理。

返回变量类型为 List 的类型的 java.net 中的方法
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
Map<String,List<String>> | URLConnection.getHeaderFields() 返回头字段的不可修改的 Map。
abstract Map<String,List<String>> | CacheResponse.getHeaders() 以 Map 的形式返回响应头。
Map<String,List<String>> | URLConnection.getRequestProperties() 返回一个由此连接的一般请求属性构成的不可修改的 Map。

类型变量类型为 List 的 java.net 中的方法参数
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract CacheResponse | ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders) 根据请求的 uri、请求方法和请求头获取缓存的响应。
abstract void | CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
void | CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

java.security 中 List 的使用

参数类型为 List 的 java.security 中的构造方法
Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

java.security.cert 中 List 的使用

返回 List 的 java.security.cert 中的方法
abstract List<? extends Certificate> | CertPath.getCertificates() 返回此证书路径中的证书列表。
List<PKIXCertPathChecker> | PKIXParameters.getCertPathCheckers() 返回证书路径检查器的 List。
List<CertStore> | PKIXParameters.getCertStores() 返回用于查找证书和 CRL 的不可变 CertStore List。
List<String> | X509Certificate.getExtendedKeyUsage() 获取一个不可修改的 String 列表，表示已扩展的密钥使用扩展 (OID = 2.5.29.37) 中 ExtKeyUsageSyntax 字段的对象标识符（OBJECT IDENTIFIER）。

返回变量类型为 List 的类型的 java.security.cert 中的方法
Collection<List<?>> | X509Certificate.getIssuerAlternativeNames() 从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
Collection<List<?>> | X509CertSelector.getPathToNames() 返回 pathToNames 标准的一个副本。
Collection<List<?>> | X509CertSelector.getSubjectAlternativeNames() 返回 subjectAlternativeNames 标准的一个副本。
Collection<List<?>> | X509Certificate.getSubjectAlternativeNames() 从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。

参数类型为 List 的 java.security.cert 中的方法
CertPath | CertificateFactorySpi.engineGenerateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象,并使用 Certificate 的 List 对它进行初始化。
CertPath | CertificateFactory.generateCertPath(List<? extends Certificate> certificates) 生成一个 CertPath 对象，并使用一个 Certificate 的 List 对它进行初始化。
void | PKIXParameters.setCertPathCheckers(List<PKIXCertPathChecker> checkers) 设置其他证书路径检查器的 List。
void | PKIXParameters.setCertStores(List<CertStore> stores) 设置在查找证书和 CRL 时所使用的 CertStore 列表。

类型变量类型为 List 的 java.security.cert 中的方法参数
void | X509CertSelector.setPathToNames(Collection<List<?>> names) 设置 pathToNames 标准。
void | X509CertSelector.setSubjectAlternativeNames(Collection<List<?>> names) 设置 subjectAlternativeNames 标准。

java.util 中 List 的使用

实现 List 的 java.util 中的类
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | LinkedList<E> List 接口的链接列表实现。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | Vector<E> Vector 类可以实现可增长的对象数组。

声明为 List 的 java.util 中的字段
static List | Collections.EMPTY_LIST 空的列表（不可变的）。
static List<String> | ResourceBundle.Control.FORMAT_CLASS 包含 "java.class" 的纯类 (class-only) 格式 List。
static List<String> | ResourceBundle.Control.FORMAT_DEFAULT 默认的格式 List，它包含字符串 "java.class" 和 "java.properties"（按此顺序）。
static List<String> | ResourceBundle.Control.FORMAT_PROPERTIES 包含 "java.properties" 的纯属性 (properties-only) 格式 List。

返回 List 的 java.util 中的方法
static
<T> List<T>
Arrays.asList(T... a)
返回一个受指定数组支持的固定大小的列表。
static
<E> List<E>
Collections.checkedList(List<E> list, Class<E> type)
返回指定列表的一个动态类型安全视图。
static
<T> List<T>
Collections.emptyList()
返回空的列表（不可变的）。
 List<Locale> ResourceBundle.Control.getCandidateLocales(String baseName, Locale locale)
返回 Locale 的 List，作为 baseName 和 locale 的候选语言环境。
 List<String> ResourceBundle.Control.getFormats(String baseName)
返回 String 的 List，它包含要用于加载给定 baseName 的资源包的格式。
static
<T> List<T>
Collections.nCopies(int n, T o)
返回由指定对象的 n 个副本组成的不可变列表。
static
<T> List<T>
Collections.singletonList(T o)
返回一个只包含指定对象的不可变列表。
 List<E> Vector.subList(int fromIndex, int toIndex)
返回此 List 的部分视图，元素范围为从 fromIndex（包括）到 toIndex（不包括）。
 List<E> AbstractList.subList(int fromIndex, int toIndex)
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
 List<E> List.subList(int fromIndex, int toIndex)
返回列表中指定的 fromIndex（包括 ）和 toIndex（不包括）之间的部分视图。
static
<T> List<T>
Collections.synchronizedList(List<T> list)
返回指定列表支持的同步（线程安全的）列表。
static
<T> List<T>
Collections.unmodifiableList(List<? extends T> list)
返回指定列表的不可修改视图。

参数类型为 List 的 java.util 中的方法
static
<T> int
Collections.binarySearch(List<? extends Comparable<? super T>> list, T key)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<T> int
Collections.binarySearch(List<? extends T> list, T key, Comparator<? super T> c)
使用二分搜索法搜索指定列表，以获得指定对象。
static
<E> List<E>
Collections.checkedList(List<E> list, Class<E> type)
返回指定列表的一个动态类型安全视图。
static
<T> void
Collections.copy(List<? super T> dest, List<? extends T> src)
将所有元素从一个列表复制到另一个列表。
static
<T> void
Collections.copy(List<? super T> dest, List<? extends T> src)
将所有元素从一个列表复制到另一个列表。
static
<T> void
Collections.fill(List<? super T> list, T obj)
使用指定元素替换指定列表中的所有元素。
static ResourceBundle.Control ResourceBundle.Control.getControl(List<String> formats)
返回 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats。
static ResourceBundle.Control ResourceBundle.Control.getNoFallbackControl(List<String> formats)
返回一个 ResourceBundle.Control，getFormats 方法在其中返回指定的 formats，getFallbackLocale 方法在其中返回 null。
static int Collections.indexOfSubList(List<?> source, List<?> target)
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static int Collections.indexOfSubList(List<?> source, List<?> target)
返回指定源列表中第一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static int Collections.lastIndexOfSubList(List<?> source, List<?> target)
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static int Collections.lastIndexOfSubList(List<?> source, List<?> target)
返回指定源列表中最后一次出现指定目标列表的起始位置；如果没有出现这样的列表，则返回 -1。
static
<T> boolean
Collections.replaceAll(List<T> list, T oldVal, T newVal)
使用另一个值替换列表中出现的所有某一指定值。
static void Collections.reverse(List<?> list)
反转指定列表中元素的顺序。
static void Collections.rotate(List<?> list, int distance)
根据指定的距离轮换指定列表中的元素。
static void Collections.shuffle(List<?> list)
使用默认随机源对指定列表进行置换。
static void Collections.shuffle(List<?> list, Random rnd)
使用指定的随机源对指定列表进行置换。
static
<T extends Comparable<? super T>>
void
Collections.sort(List<T> list)
根据元素的自然顺序 对指定列表按升序进行排序。
static
<T> void
Collections.sort(List<T> list, Comparator<? super T> c)
根据指定比较器产生的顺序对指定列表进行排序。
static void Collections.swap(List<?> list, int i, int j)
在指定列表的指定位置处交换元素。
static
<T> List<T>
Collections.synchronizedList(List<T> list)
返回指定列表支持的同步（线程安全的）列表。
static
<T> List<T>
Collections.unmodifiableList(List<? extends T> list)
返回指定列表的不可修改视图。

java.util.concurrent 中 List 的使用

实现 List 的 java.util.concurrent 中的类
 class CopyOnWriteArrayList<E>
ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。

返回 List 的 java.util.concurrent 中的方法
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
 List<Runnable> ExecutorService.shutdownNow()
试图停止所有正在执行的活动任务，暂停处理正在等待的任务，并返回等待执行的任务列表。
 List<Runnable> ScheduledThreadPoolExecutor.shutdownNow()
尝试停止所有正在执行的任务、暂停等待任务的处理，并返回等待执行的任务列表。
 List<Runnable> ThreadPoolExecutor.shutdownNow()
尝试停止所有的活动执行任务、暂停等待任务的处理，并返回等待执行的任务列表。
 List<E> CopyOnWriteArrayList.subList(int fromIndex, int toIndex)
返回此列表中 fromIndex（包括）和 toIndex（不包括）之间部分的视图。

java.util.logging 中 List 的使用

返回 List 的 java.util.logging 中的方法
 List<String> LoggingMXBean.getLoggerNames()
返回当前已注册的 logger 列表。

javax.imageio 中 List 的使用

声明为 List 的 javax.imageio 中的字段
protected List<IIOReadProgressListener> | ImageReader.progressListeners 当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<IIOWriteProgressListener> | ImageWriter.progressListeners 当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
protected List<? extends BufferedImage> | IIOImage.thumbnails BufferedImage 缩略图的 List，或为 null。
protected List<IIOReadUpdateListener> | ImageReader.updateListeners 当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<IIOReadWarningListener> | ImageReader.warningListeners 当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<IIOWriteWarningListener> | ImageWriter.warningListeners 当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
protected List<Locale> | ImageReader.warningLocales 与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<Locale> | ImageWriter.warningLocales Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。

返回 List 的 javax.imageio 中的方法
 List<? extends BufferedImage> IIOImage.getThumbnails()
返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。

参数类型为 List 的 javax.imageio 中的方法
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | IIOImage.setThumbnails(List<? extends BufferedImage> thumbnails) 将缩略图列表设置为 BufferedImage 的一个新 List 或 null。

参数类型为 List 的 javax.imageio 中的构造方法
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。

javax.imageio.metadata 中 List 的使用

参数类型为 List 的 javax.imageio.metadata 中的方法
protected  void IIOMetadataFormatImpl.addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。
protected
<T> void
IIOMetadataFormatImpl.addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。

javax.lang.model.element 中 List 的使用

返回 List 的 javax.lang.model.element 中的方法
List<? extends AnnotationMirror> | Element.getAnnotationMirrors() 返回直接存在于此元素上的注释。
List<? extends TypeMirror> | TypeParameterElement.getBounds() 返回此类型参数的边界。
List<? extends Element> | Element.getEnclosedElements() 返回此元素直接封装（非严格意义上）的元素。
List<? extends TypeMirror> | TypeElement.getInterfaces() 返回直接由此类实现或直接由此接口扩展的接口类型。
List<? extends VariableElement> | ExecutableElement.getParameters() 返回此 executable 的形参。
List<? extends TypeMirror> | ExecutableElement.getThrownTypes() 按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。
List<? extends TypeParameterElement> | ExecutableElement.getTypeParameters() 按照声明顺序返回此 executable 的形式类型参数。
List<? extends TypeParameterElement> | TypeElement.getTypeParameters() 按照声明顺序返回此类型元素的形式类型参数。

参数类型为 List 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

javax.lang.model.type 中 List 的使用

返回 List 的 javax.lang.model.type 中的方法
List<? extends TypeMirror> | ExecutableType.getParameterTypes() 返回此 executable 的形参类型。
List<? extends TypeMirror> | ExecutableType.getThrownTypes() 返回此 executable 的 throws 子句中列出的异常和其他 throwable。
List<? extends TypeMirror> | DeclaredType.getTypeArguments() 返回此类型的实际类型参数。
List<? extends TypeMirror> | MirroredTypesException.getTypeMirrors() 返回对应于要访问的类型的类型镜像。
List<? extends TypeVariable> | ExecutableType.getTypeVariables() 返回由此 executable 的形式类型参数所声明的类型变量。

参数类型为 List 的 javax.lang.model.type 中的构造方法
MirroredTypesException(List<? extends TypeMirror> types)
构造一个针对指定类型的新 MirroredTypesException。

javax.lang.model.util 中 List 的使用

返回 List 的 javax.lang.model.util 中的方法
static List<ExecutableElement> | ElementFilter.constructorsIn(Iterable<? extends Element> elements) elements 中构造方法的列表。
List<? extends TypeMirror> | Types.directSupertypes(TypeMirror t) 返回类型的直接超类型。
static List<VariableElement> | ElementFilter.fieldsIn(Iterable<? extends Element> elements) 返回 elements 中字段的列表。
List<? extends AnnotationMirror> | Elements.getAllAnnotationMirrors(Element e) 返回元素的所有注释，不管是继承的还是直接存在的。
List<? extends Element> | Elements.getAllMembers(TypeElement type) 返回类型元素的所有成员，不管是继承的还是直接声明的。
static List<ExecutableElement> | ElementFilter.methodsIn(Iterable<? extends Element> elements) 返回 elements 中方法的列表。
static List<PackageElement> | ElementFilter.packagesIn(Iterable<? extends Element> elements) 返回 elements 中包的列表。
static List<TypeElement> | ElementFilter.typesIn(Iterable<? extends Element> elements) 返回 elements 中类型的列表。

参数类型为 List 的 javax.lang.model.util 中的方法
 R SimpleAnnotationValueVisitor6.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

javax.management 中 List 的使用

实现 List 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

返回 List 的 javax.management 中的方法
 List<Attribute> AttributeList.asList()
以 List<Attribute> 的形式返回此列表的视图。

参数类型为 List 的 javax.management 中的构造方法
AttributeList(List<Attribute> list)
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。

javax.management.loading 中 List 的使用

返回 List 的 javax.management.loading 中的方法
List<String> | MLetContent.getParameterTypes() 获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。
List<String> | MLetContent.getParameterValues() 获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。

参数类型为 List 的 javax.management.loading 中的构造方法
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

javax.management.openmbean 中 List 的使用

声明为 List 的 javax.management.openmbean 中的字段
static List<String> OpenType.ALLOWED_CLASSNAMES_LIST
开放数据值允许的 Java 类的完全限定名称的列表。

返回 List 的 javax.management.openmbean 中的方法
 List<String> TabularType.getIndexNames()
按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。

javax.management.relation 中 List 的使用

实现 List 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

返回 List 的 javax.management.relation 中的方法
List<Role> | RoleList.asList() 以 List<Role> 的形式返回此列表的示图。
List<RoleUnresolved> | RoleUnresolvedList.asList() 以 List<RoleUnresolved> 的形式返回此列表的视图。
List<String> | RelationService.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationServiceMBean.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationService.getAllRelationIds() 返回由 Relation Service 处理的所有关系的所有关系 id。
List<String> | RelationServiceMBean.getAllRelationIds() 返回由 Relation Service 处理的所有关系的所有关系 id。
List<String> | RelationService.getAllRelationTypeNames() 检索所有已知关系类型的名称。
List<String> | RelationServiceMBean.getAllRelationTypeNames() 检索所有已知关系类型的名称。
List<ObjectName> | RelationNotification.getMBeansToUnregister() 返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。
List<ObjectName> | RelationNotification.getNewRoleValue() 返回更新的角色的新值（仅限于角色更新）。
List<ObjectName> | RelationNotification.getOldRoleValue() 返回更新的角色的旧值（仅限于角色更新）。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<RoleInfo> | RelationType.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationTypeSupport.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<ObjectName> | Role.getRoleValue() 检索角色值。
List<ObjectName> | RoleUnresolved.getRoleValue() 检索角色值。

返回变量类型为 List 的类型的 javax.management.relation 中的方法
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
Map<ObjectName,List<String>> | Relation.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationSupport.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。

参数类型为 List 的 javax.management.relation 中的方法
static String | Role.roleValueToString(List<ObjectName> roleValue) 返回给定角色值的字符串。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | Role.setRoleValue(List<ObjectName> roleValue) 设置角色值。
void | RoleUnresolved.setRoleValue(List<ObjectName> value) 设置角色值。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

参数类型为 List 的 javax.management.relation 中的构造方法
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。
RoleList(List<Role> list)
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。
RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。
RoleUnresolvedList(List<RoleUnresolved> list)
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。

javax.naming.ldap 中 List 的使用

返回 List 的 javax.naming.ldap 中的方法
 List<Rdn> LdapName.getRdns()
检索相对标识名列表。

参数类型为 List 的 javax.naming.ldap 中的方法
Name | LdapName.addAll(int posn, List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称中的指定位置。
Name | LdapName.addAll(List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称的末尾。
boolean | LdapName.endsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。
boolean | LdapName.startsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。

参数类型为 List 的 javax.naming.ldap 中的构造方法
LdapName(List<Rdn> rdns)
在给定已解析 RDN 组件的情况下构造 LDAP 名称。

javax.net.ssl 中 List 的使用

返回 List 的 javax.net.ssl 中的方法
 List KeyStoreBuilderParameters.getParameters()
返回此对象封装的不可修改的 KeyStore.Builder 列表。

参数类型为 List 的 javax.net.ssl 中的构造方法
KeyStoreBuilderParameters(List parameters)
根据 KeyStore.Builder 的列表构造新的 KeyStoreBuilderParameters。

javax.script 中 List 的使用

返回 List 的 javax.script 中的方法
List<ScriptEngineFactory> | ScriptEngineManager.getEngineFactories() 返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。
List<String> | ScriptEngineFactory.getExtensions() 返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。
List<String> | ScriptEngineFactory.getMimeTypes() 返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。
List<String> | ScriptEngineFactory.getNames() 返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。
List<Integer> | ScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。
List<Integer> | SimpleScriptContext.getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。

javax.sound.midi 中 List 的使用

返回 List 的 javax.sound.midi 中的方法
List<Receiver> | MidiDevice.getReceivers() 返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。
List<Transmitter> | MidiDevice.getTransmitters() 返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。

javax.swing 中 List 的使用

返回 List 的 javax.swing 中的方法
List<?> | SpinnerListModel.getList() 返回定义此模型的序列的 List。
List<? extends RowSorter.SortKey> | DefaultRowSorter.getSortKeys() 返回当前排序键。
abstract List<? extends RowSorter.SortKey> | RowSorter.getSortKeys() 返回当前排序键。

参数类型为 List 的 javax.swing 中的方法
protected void | SwingWorker.process(List<V> chunks) 在事件指派线程 上异步地从 publish 方法接收数据块。
void | SpinnerListModel.setList(List<?> list) 更改定义此序列的列表，并将该模型 value 的索引重新设置为零。
void | DefaultRowSorter.setSortKeys(List<? extends RowSorter.SortKey> sortKeys) 设置排序键。
abstract void | RowSorter.setSortKeys(List<? extends RowSorter.SortKey> keys) 设置当前排序键。

参数类型为 List 的 javax.swing 中的构造方法
SpinnerListModel(List<?> values)
构造一个由指定 List 定义其值序列的 SpinnerModel。

javax.tools 中 List 的使用

返回 List 的 javax.tools 中的方法
 List<Diagnostic<? extends S>> DiagnosticCollector.getDiagnostics()
获取此对象收集的诊断所组成的列表视图。

javax.xml.crypto.dsig 中 List 的使用

返回 List 的 javax.xml.crypto.dsig 中的方法
List | SignatureProperty.getContent() 返回一个不可修改的列表，由包含在此 SignatureProperty 中的一个或多个 XMLStructure 组成。
List | XMLObject.getContent() 返回一个可修改列表，由包含在此 XMLObject 中的 XMLStructure 组成，其中 XMLObject 表示来自任何命名空间的元素。
List | XMLSignature.getObjects() 返回一个可修改的列表，由包含在此 XMLSignature 中的 XMLObject 组成。
List | SignatureProperties.getProperties() 返回一个可修改的列表，由包含此在 SignatureProperties 中的一个或多个 SignatureProperty 组成。
List | Manifest.getReferences() 返回一个不可修改的列表，由包含在此 Manifest 中的一个或多个 Reference 组成。
List | SignedInfo.getReferences() 返回一个或多个 Reference 的不可修改的列表。
List | Reference.getTransforms() 返回一个 不可修改的列表，由包含在此 Reference 中的 Transform 组成。

参数类型为 List 的 javax.xml.crypto.dsig 中的方法
abstract Manifest | XMLSignatureFactory.newManifest(List references) 创建包含指定的 Reference 列表的 Manifest。
abstract Manifest | XMLSignatureFactory.newManifest(List references, String id) 创建包含指定的 Reference 列表和可选 id 的 Manifest。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List appliedTransforms, Data result, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id) 创建带指定参数的 Reference。
abstract Reference | XMLSignatureFactory.newReference(String uri, DigestMethod dm, List transforms, String type, String id, byte[] digestValue) 创建带指定参数和预计算的摘要值的 Reference。
abstract SignatureProperties | XMLSignatureFactory.newSignatureProperties(List properties, String id) 创建包含指定的 SignatureProperty 列表和可选 id 的 SignatureProperties。
abstract SignatureProperty | XMLSignatureFactory.newSignatureProperty(List content, String target, String id) 创建包含指定的 XMLStructure 列表、目标 URI 和可选 id 的SignatureProperty。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references) 创建带指定的规范化方法和签名方法、以及一个或多个引用的列表的 SignedInfo。
abstract SignedInfo | XMLSignatureFactory.newSignedInfo(CanonicalizationMethod cm, SignatureMethod sm, List references, String id) 创建带指定参数的 SignedInfo。
abstract XMLObject | XMLSignatureFactory.newXMLObject(List content, String id, String mimeType, String encoding) 根据指定参数创建 XMLObject。
abstract XMLSignature | XMLSignatureFactory.newXMLSignature(SignedInfo si, KeyInfo ki, List objects, String id, String signatureValueId) 创建一个 XMLSignature，并使用指定的参数对其进行初始化。

javax.xml.crypto.dsig.keyinfo 中 List 的使用

返回 List 的 javax.xml.crypto.dsig.keyinfo 中的方法
List | KeyInfo.getContent() 返回包含密钥信息的 unmodifiable list。
List | X509Data.getContent() 返回一个不可修改的列表，由此 X509Data 的内容组成。
List | PGPData.getExternalElements() 返回一个不可修改列表，由表示外部名称空间元素中的 XMLStructure 组成。
List | RetrievalMethod.getTransforms() 返回一个不可修改的列表，由此 RetrievalMethod 的 Transform 组成。

参数类型为 List 的 javax.xml.crypto.dsig.keyinfo 中的方法
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content) 创建包含指定的密钥信息类型列表的 KeyInfo。
abstract KeyInfo | KeyInfoFactory.newKeyInfo(List content, String id) 创建包含指定的密钥信息类型列表和可选 id 的 KeyInfo。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyId, byte[] keyPacket, List other) 根据指定的 PGP 公钥标识符、可选的密钥材料包和外部元素的列表，创建 PGPData。
abstract PGPData | KeyInfoFactory.newPGPData(byte[] keyPacket, List other) 根据指定的 PGP 密钥材料包和可选的外部元素列表创建 PGPData。
abstract RetrievalMethod | KeyInfoFactory.newRetrievalMethod(String uri, String type, List transforms) 根据指定的参数创建 RetrievalMethod。
abstract X509Data | KeyInfoFactory.newX509Data(List content) 创建包含指定的 X.509 内容列表的 X509Data。

javax.xml.crypto.dsig.spec 中 List 的使用

返回 List 的 javax.xml.crypto.dsig.spec 中的方法
List | ExcC14NParameterSpec.getPrefixList() 返回相容名称空间前缀列表。
List | XPathFilter2ParameterSpec.getXPathList() 返回一个列表，由一个或多个 XPathType 对象组成。

参数类型为 List 的 javax.xml.crypto.dsig.spec 中的构造方法
ExcC14NParameterSpec(List prefixList)
创建带有指定前缀列表的 ExcC14NParameterSpec。
XPathFilter2ParameterSpec(List xPathList)
创建一个 XPathFilter2ParameterSpec。

javax.xml.stream.events 中 List 的使用

返回 List 的 javax.xml.stream.events 中的方法
List | DTD.getEntities() 返回一个列表，其中包含在 DTD 中声明的外部和内部常规实体。
List | DTD.getNotations() 返回一个 List，其中包含在 DTD 中声明的注释。

javax.xml.ws 中 List 的使用

返回 List 的 javax.xml.ws 中的方法
List<Handler> | Binding.getHandlerChain() 获取协议绑定实例处理程序链的副本。
abstract List<Source> | Endpoint.getMetadata() 返回服务的元数据文档列表。

参数类型为 List 的 javax.xml.ws 中的方法
void | Binding.setHandlerChain(List<Handler> chain) 设置协议绑定实例的处理程序链。
abstract void | Endpoint.setMetadata(List<Source> metadata) 设置此端点的元数据。

javax.xml.ws.handler 中 List 的使用

返回 List 的 javax.xml.ws.handler 中的方法
 List<Handler> HandlerResolver.getHandlerChain(PortInfo portInfo)
获取指定端口的处理程序链。

javax.xml.xpath 中 List 的使用

参数类型为 List 的 javax.xml.xpath 中的方法
 Object XPathFunction.evaluate(List args)
计算带指定参数的函数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Collection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Collection
的使用

使用 Collection 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.beans.beancontext | 提供与 bean 上下文有关的类和接口。
java.security | 为安全框架提供类和接口。
java.security.cert | 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.concurrent.locks | 为锁和等待条件提供一个框架的接口和类，它不同于内置同步和监视器。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

java.awt 中 Collection 的使用

返回 Collection 的 java.awt 中的方法
 Collection<Object> RenderingHints.values()
返回此 RenderinHints 中所包含键的 Collection 视图。

java.beans.beancontext 中 Collection 的使用

java.beans.beancontext 中 Collection 的子接口
interface | BeanContext BeanContext 是 JavaBean 的逻辑层次容器。
interface | BeanContextServices BeanContextServices 接口为 BeanContext 提供某种机制，将一般的 "services" 向其中的 BeanContextChild 对象公开。

实现 Collection 的 java.beans.beancontext 中的类
class | BeanContextServicesSupport 此帮助器类提供 java.beans.beancontext.BeanContextServices 接口的实用工具实现。
class | BeanContextSupport 此帮助器类提供 java.beans.beancontext.BeanContext 接口的实用工具实现。

声明为 Collection 的 java.beans.beancontext 中的字段
protected  Collection BeanContextMembershipEvent.children
受此事件通知影响的子级的列表。

参数类型为 Collection 的 java.beans.beancontext 中的方法
boolean | BeanContextSupport.addAll(Collection c) 将 Collection 添加到 Children（不受支持的）实现的集合，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
boolean | BeanContextSupport.containsAll(Collection c) 测试以查看指定 Collection 中的所有对象是否是此 BeanContext 的子对象。
protected void | BeanContextSupport.deserialize(ObjectInputStream ois, Collection coll) readObject 使用此方法来反序列化一个 collection。
boolean | BeanContextSupport.removeAll(Collection c) 移除所有指定 Children（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
boolean | BeanContextSupport.retainAll(Collection c) 仅保留指定子对象（不受支持的）实现，这些实现在层次结构锁定和 "children" 受保护字段上必须是同步的
protected void | BeanContextSupport.serialize(ObjectOutputStream oos, Collection coll) writeObject 使用此方法来序列化一个 Collection。

参数类型为 Collection 的 java.beans.beancontext 中的构造方法
BeanContextMembershipEvent(BeanContext bc, Collection changes)
构造一个 BeanContextMembershipEvent

java.security 中 Collection 的使用

返回 Collection 的 java.security 中的方法
 Collection<Object> Provider.values()
返回此 provider 中所包含的属性值的一个不可修改的 Collection 视图。

java.security.cert 中 Collection 的使用

返回 Collection 的 java.security.cert 中的方法
abstract Collection<? extends Certificate> | CertificateFactorySpi.engineGenerateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
abstract Collection<? extends CRL> | CertificateFactorySpi.engineGenerateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
abstract Collection<? extends Certificate> | CertStoreSpi.engineGetCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
abstract Collection<? extends CRL> | CertStoreSpi.engineGetCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<? extends Certificate> | CertificateFactory.generateCertificates(InputStream inStream) 返回从给定输入流 inStream 中读取的证书的集合视图（可能为空）。
Collection<? extends CRL> | CertificateFactory.generateCRLs(InputStream inStream) 返回从给定输入流 inStream 中读取的 CRL 的集合视图（可能为空）。
Collection<? extends Certificate> | CertStore.getCertificates(CertSelector selector) 返回与指定选择器匹配的 Certificate 的 Collection。
Collection<?> | CollectionCertStoreParameters.getCollection() 返回从中获取 Certificate 和 CRL 的 Collection。
Collection<? extends CRL> | CertStore.getCRLs(CRLSelector selector) 返回与指定选择器匹配的 CRL 的 Collection。
Collection<List<?>> | X509Certificate.getIssuerAlternativeNames() 从 IssuerAltName 扩展 (OID = 2.5.29.18) 中获取一个发布方替换名称的不可变集合。
Collection<Object> | X509CRLSelector.getIssuerNames() 返回该 issuerNames 标准的一个副本。
Collection<X500Principal> | X509CRLSelector.getIssuers() 返回 issuerNames 标准。
Collection<List<?>> | X509CertSelector.getPathToNames() 返回 pathToNames 标准的一个副本。
Collection<List<?>> | X509CertSelector.getSubjectAlternativeNames() 返回 subjectAlternativeNames 标准的一个副本。
Collection<List<?>> | X509Certificate.getSubjectAlternativeNames() 从 SubjectAltName 扩展 (OID = 2.5.29.17) 中获取一个主体替换名称的不可变集合。

参数类型为 Collection 的 java.security.cert 中的方法
abstract  void PKIXCertPathChecker.check(Certificate cert, Collection<String> unresolvedCritExts)
使用其内部状态对指定的证书进行检查，并且将其处理的那些关键扩展从表示未解析的关键扩展的指定 OID 字符串集合中移除。
 void X509CRLSelector.setIssuerNames(Collection<?> names)
注意：请使用 X509CRLSelector.setIssuers(Collection) 方法，或者使用此方法时仅指定 byte 数组形式的标识名。
 void X509CRLSelector.setIssuers(Collection<X500Principal> issuers)
设置 issuerNames 标准。
 void X509CertSelector.setPathToNames(Collection<List<?>> names)
设置 pathToNames 标准。
 void X509CertSelector.setSubjectAlternativeNames(Collection<List<?>> names)
设置 subjectAlternativeNames 标准。

参数类型为 Collection 的 java.security.cert 中的构造方法
CollectionCertStoreParameters(Collection<?> collection)
创建 CollectionCertStoreParameters 的一个实例，它允许从指定的 Collection 中获取证书和 CRL。

java.util 中 Collection 的使用

java.util 中 Collection 的子接口
interface | Deque<E> 一个线性 collection，支持在两端插入和移除元素。
interface | List<E> 有序的 collection（也称为序列）。
interface | NavigableSet<E> 扩展的 SortedSet，具有了为给定搜索目标报告最接近匹配项的导航方法。
interface | Queue<E> 在处理元素前用于保存元素的 collection。
interface | Set<E> 一个不包含重复元素的 collection。
interface | SortedSet<E> 进一步提供关于元素的总体排序 的 Set。

实现 Collection 的 java.util 中的类
class | AbstractCollection<E> 此类提供 Collection 接口的骨干实现，以最大限度地减少了实现此接口所需的工作。
class | AbstractList<E> 此类提供 List 接口的骨干实现，以最大限度地减少实现“随机访问”数据存储（如数组）支持的该接口所需的工作。
class | AbstractQueue<E> 此类提供某些 Queue 操作的骨干实现。
class | AbstractSequentialList<E> 此类提供了 List 接口的骨干实现，从而最大限度地减少了实现受“连续访问”数据存储（如链接列表）支持的此接口所需的工作。
class | AbstractSet<E> 此类提供 Set 接口的骨干实现，从而最大限度地减少了实现此接口所需的工作。
class | ArrayDeque<E> Deque 接口的大小可变数组的实现。
class | ArrayList<E> List 接口的大小可变数组的实现。
class | EnumSet<E extends Enum<E>> 与枚举类型一起使用的专用 Set 实现。
class | HashSet<E> 此类实现 Set 接口，由哈希表（实际上是一个 HashMap 实例）支持。
class | LinkedHashSet<E> 具有可预知迭代顺序的 Set 接口的哈希表和链接列表实现。
class | LinkedList<E> List 接口的链接列表实现。
class | PriorityQueue<E> 一个基于优先级堆的无界优先级队列。
class | Stack<E> Stack 类表示后进先出（LIFO）的对象堆栈。
class | TreeSet<E> 基于 TreeMap 的 NavigableSet 实现。
class | Vector<E> Vector 类可以实现可增长的对象数组。

返回 Collection 的 java.util 中的方法
static
<E> Collection<E>
Collections.checkedCollection(Collection<E> c, Class<E> type)
返回指定 collection 的一个动态类型安全视图。
static
<T> Collection<T>
Collections.synchronizedCollection(Collection<T> c)
返回指定 collection 支持的同步（线程安全的）collection。
static
<T> Collection<T>
Collections.unmodifiableCollection(Collection<? extends T> c)
返回指定 collection 的不可修改视图。
 Collection<V> EnumMap.values()
返回此映射中所包含值的 Collection 视图。
 Collection<V> IdentityHashMap.values()
返回映射所包含值的 Collection 视图。
 Collection<V> TreeMap.values()
返回此映射包含的值的 Collection 视图。
 Collection<V> SortedMap.values()
返回在此映射中所包含值的 Collection 视图。
 Collection<V> WeakHashMap.values()
返回此映射所包含的值的 Collection 视图。
 Collection<V> HashMap.values()
返回此映射所包含的值的 Collection 视图。
 Collection<V> AbstractMap.values()
返回此映射中包含的值的 Collection 视图。
 Collection<V> Hashtable.values()
返回此映射中包含的键的 Collection 视图。
 Collection<V> Map.values()
返回此映射中包含的值的 Collection 视图。

参数类型为 Collection 的 java.util 中的方法
 boolean AbstractQueue.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此队列中。
 boolean TreeSet.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素添加到此 set 中。
 boolean LinkedList.addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序。
 boolean ArrayList.addAll(Collection<? extends E> c)
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
 boolean Set.addAll(Collection<? extends E> c)
如果 set 中没有指定 collection 中的所有元素，则将其添加到此 set 中（可选操作）。
 boolean Vector.addAll(Collection<? extends E> c)
将指定 Collection 中的所有元素添加到此向量的末尾，按照指定 collection 的迭代器所返回的顺序添加这些元素。
 boolean AbstractCollection.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
 boolean List.addAll(Collection<? extends E> c)
添加指定 collection 中的所有元素到此列表的结尾，顺序是指定 collection 的迭代器返回这些元素的顺序（可选操作）。
 boolean Collection.addAll(Collection<? extends E> c)
将指定 collection 中的所有元素都添加到此 collection 中（可选操作）。
static
<T> boolean
Collections.addAll(Collection<? super T> c, T... elements)
将所有指定元素添加到指定 collection 中。
 boolean LinkedList.addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素从指定位置开始插入此列表。
 boolean AbstractSequentialList.addAll(int index, Collection<? extends E> c)
在此列表中指定的位置上插入指定 collection 中的所有元素（可选操作）。
 boolean ArrayList.addAll(int index, Collection<? extends E> c)
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
 boolean Vector.addAll(int index, Collection<? extends E> c)
在指定位置将指定 Collection 中的所有元素插入到此向量中。
 boolean AbstractList.addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
 boolean List.addAll(int index, Collection<? extends E> c)
将指定 collection 中的所有元素都插入到列表中的指定位置（可选操作）。
static
<E> Collection<E>
Collections.checkedCollection(Collection<E> c, Class<E> type)
返回指定 collection 的一个动态类型安全视图。
 boolean Set.containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。
 boolean Vector.containsAll(Collection<?> c)
如果此向量包含指定 Collection 中的所有元素，则返回 true。
 boolean AbstractCollection.containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
 boolean List.containsAll(Collection<?> c)
如果列表包含指定 collection 的所有元素，则返回 true。
 boolean Collection.containsAll(Collection<?> c)
如果此 collection 包含指定 collection 中的所有元素，则返回 true。
static
<E extends Enum<E>>
EnumSet<E>
EnumSet.copyOf(Collection<E> c)
创建一个从指定 collection 初始化的枚举 set。
static boolean Collections.disjoint(Collection<?> c1, Collection<?> c2)
如果两个指定 collection 中没有相同的元素，则返回 true。
static boolean Collections.disjoint(Collection<?> c1, Collection<?> c2)
如果两个指定 collection 中没有相同的元素，则返回 true。
static
<T> Enumeration<T>
Collections.enumeration(Collection<T> c)
返回一个指定 collection 上的枚举。
static int Collections.frequency(Collection<?> c, Object o)
返回指定 collection 中等于指定对象的元素数。
static
<T extends Object & Comparable<? super T>>
T
Collections.max(Collection<? extends T> coll)
根据元素的自然顺序，返回给定 collection 的最大元素。
static
<T> T
Collections.max(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最大元素。
static
<T extends Object & Comparable<? super T>>
T
Collections.min(Collection<? extends T> coll)
根据元素的自然顺序 返回给定 collection 的最小元素。
static
<T> T
Collections.min(Collection<? extends T> coll, Comparator<? super T> comp)
根据指定比较器产生的顺序，返回给定 collection 的最小元素。
 boolean AbstractSet.removeAll(Collection<?> c)
从此 set 中移除包含在指定 collection 中的所有元素（可选操作）。
 boolean Set.removeAll(Collection<?> c)
移除 set 中那些包含在指定 collection 中的元素（可选操作）。
 boolean Vector.removeAll(Collection<?> c)
从此向量中移除包含在指定 Collection 中的所有元素。
 boolean AbstractCollection.removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
 boolean List.removeAll(Collection<?> c)
从列表中移除指定 collection 中包含的其所有元素（可选操作）。
 boolean Collection.removeAll(Collection<?> c)
移除此 collection 中那些也包含在指定 collection 中的所有元素（可选操作）。
 boolean Set.retainAll(Collection<?> c)
仅保留 set 中那些包含在指定 collection 中的元素（可选操作）。
 boolean Vector.retainAll(Collection<?> c)
在此向量中仅保留包含在指定 Collection 中的元素。
 boolean AbstractCollection.retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
 boolean List.retainAll(Collection<?> c)
仅在列表中保留指定 collection 中所包含的元素（可选操作）。
 boolean Collection.retainAll(Collection<?> c)
仅保留此 collection 中那些也包含在指定 collection 的元素（可选操作）。
static
<T> Collection<T>
Collections.synchronizedCollection(Collection<T> c)
返回指定 collection 支持的同步（线程安全的）collection。
static
<T> Collection<T>
Collections.unmodifiableCollection(Collection<? extends T> c)
返回指定 collection 的不可修改视图。

参数类型为 Collection 的 java.util 中的构造方法
ArrayDeque(Collection<? extends E> c)
构造一个包含指定 collection 的元素的双端队列，这些元素按 collection 的迭代器返回的顺序排列。
ArrayList(Collection<? extends E> c)
构造一个包含指定 collection 的元素的列表，这些元素是按照该 collection 的迭代器返回它们的顺序排列的。
HashSet(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的新 set。
LinkedHashSet(Collection<? extends E> c)
构造一个与指定 collection 中的元素相同的新链接哈希 set。
LinkedList(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的列表，这些元素按其 collection 的迭代器返回的顺序排列。
PriorityQueue(Collection<? extends E> c)
创建包含指定 collection 中元素的 PriorityQueue。
TreeSet(Collection<? extends E> c)
构造一个包含指定 collection 元素的新 TreeSet，它按照其元素的自然顺序进行排序。
Vector(Collection<? extends E> c)
构造一个包含指定 collection 中的元素的向量，这些元素按其 collection 的迭代器返回元素的顺序排列。

java.util.concurrent 中 Collection 的使用

java.util.concurrent 中 Collection 的子接口
interface | BlockingDeque<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待双端队列变为非空；存储元素时等待双端队列中的空间变得可用。
interface | BlockingQueue<E> 支持两个附加操作的 Queue，这两个操作是：获取元素时等待队列变为非空，以及存储元素时等待空间变得可用。

实现 Collection 的 java.util.concurrent 中的类
class | ArrayBlockingQueue<E> 一个由数组支持的有界阻塞队列。
class | ConcurrentLinkedQueue<E> 一个基于链接节点的无界线程安全队列。
class | ConcurrentSkipListSet<E> 一个基于 ConcurrentSkipListMap 的可缩放并发 NavigableSet 实现。
class | CopyOnWriteArrayList<E> ArrayList 的一个线程安全的变体，其中所有可变操作（add、set 等等）都是通过对底层数组进行一次新的复制来实现的。
class | CopyOnWriteArraySet<E> 对其所有操作使用内部 CopyOnWriteArrayList 的 Set。
class | DelayQueue<E extends Delayed> Delayed 元素的一个无界阻塞队列，只有在延迟期满时才能从中提取元素。
class | LinkedBlockingDeque<E> 一个基于已链接节点的、任选范围的阻塞双端队列。
class | LinkedBlockingQueue<E> 一个基于已链接节点的、范围任意的 blocking queue。
class | PriorityBlockingQueue<E> 一个无界阻塞队列，它使用与类 PriorityQueue 相同的顺序规则，并且提供了阻塞获取操作。
class | SynchronousQueue<E> 一种阻塞队列，其中每个插入操作必须等待另一个线程的对应移除操作 ，反之亦然。

返回 Collection 的 java.util.concurrent 中的方法
protected Collection<Thread> | Semaphore.getQueuedThreads() 返回一个 collection，包含可能等待获取的线程。
Collection<V> | ConcurrentSkipListMap.values() 返回此映射中所包含值的 Collection 视图。
Collection<V> | ConcurrentHashMap.values() 返回此映射中包含的值的 Collection 视图。

参数类型为 Collection 的 java.util.concurrent 中的方法
 boolean CopyOnWriteArrayList.addAll(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中的所有元素添加此列表的尾部。
 boolean CopyOnWriteArraySet.addAll(Collection<? extends E> c)
如果此 set 中没有指定 collection 中的所有元素，则将它们都添加到此 set 中。
 boolean CopyOnWriteArrayList.addAll(int index, Collection<? extends E> c)
从指定位置开始，将指定 collection 的所有元素插入此列表。
 int CopyOnWriteArrayList.addAllAbsent(Collection<? extends E> c)
按照指定 collection 的迭代器返回元素的顺序，将指定 collection 中尚未包含在此列表中的所有元素添加列表的尾部。
 boolean CopyOnWriteArrayList.containsAll(Collection<?> c)
如果此列表包含指定 collection 的所有元素，则返回 true。
 boolean CopyOnWriteArraySet.containsAll(Collection<?> c)
如果此 set 包含指定 collection 的所有元素，则返回 true。
 boolean SynchronousQueue.containsAll(Collection<?> c)
除非给定 collection 为空，否则返回 false。
 int ArrayBlockingQueue.drainTo(Collection<? super E> c)
 int BlockingQueue.drainTo(Collection<? super E> c)
移除此队列中所有可用的元素，并将它们添加到给定 collection 中。
 int DelayQueue.drainTo(Collection<? super E> c)
 int LinkedBlockingDeque.drainTo(Collection<? super E> c)
 int LinkedBlockingQueue.drainTo(Collection<? super E> c)
 int PriorityBlockingQueue.drainTo(Collection<? super E> c)
 int SynchronousQueue.drainTo(Collection<? super E> c)
 int ArrayBlockingQueue.drainTo(Collection<? super E> c, int maxElements)
 int BlockingQueue.drainTo(Collection<? super E> c, int maxElements)
最多从此队列中移除给定数量的可用元素，并将这些元素添加到给定 collection 中。
 int DelayQueue.drainTo(Collection<? super E> c, int maxElements)
 int LinkedBlockingDeque.drainTo(Collection<? super E> c, int maxElements)
 int LinkedBlockingQueue.drainTo(Collection<? super E> c, int maxElements)
 int PriorityBlockingQueue.drainTo(Collection<? super E> c, int maxElements)
 int SynchronousQueue.drainTo(Collection<? super E> c, int maxElements)
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks)
执行给定的任务，当所有任务完成时，返回保持任务状态和结果的 Future 列表。
<T> List<Future<T>>
AbstractExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> List<Future<T>>
ExecutorService.invokeAll(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，当所有任务完成或超时期满时（无论哪个首先发生），返回保持任务状态和结果的 Future 列表。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks)
执行给定的任务，如果某个任务已成功完成（也就是未抛出异常），则返回其结果。
<T> T
AbstractExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
<T> T
ExecutorService.invokeAny(Collection<? extends Callable<T>> tasks, long timeout, TimeUnit unit)
执行给定的任务，如果在给定的超时期满前某个任务已成功完成（也就是未抛出异常），则返回其结果。
 boolean ConcurrentSkipListSet.removeAll(Collection<?> c)
从此 set 中移除包含在指定 collection 中的所有元素。
 boolean CopyOnWriteArrayList.removeAll(Collection<?> c)
从此列表移除所有包含在指定 collection 中的元素。
 boolean CopyOnWriteArraySet.removeAll(Collection<?> c)
移除此 set 中包含在指定 collection 中的所有元素。
 boolean SynchronousQueue.removeAll(Collection<?> c)
始终返回 false。
 boolean CopyOnWriteArrayList.retainAll(Collection<?> c)
只保留此列表中包含在指定 collection 中的元素。
 boolean CopyOnWriteArraySet.retainAll(Collection<?> c)
仅保留此 set 中那些包含在指定 collection 中的元素。
 boolean SynchronousQueue.retainAll(Collection<?> c)
始终返回 false。

参数类型为 Collection 的 java.util.concurrent 中的构造方法
ArrayBlockingQueue(int capacity, boolean fair, Collection<? extends E> c)
创建一个具有给定的（固定）容量和指定访问策略的 ArrayBlockingQueue，它最初包含给定 collection 的元素，并以 collection 迭代器的遍历顺序添加元素。
ConcurrentLinkedQueue(Collection<? extends E> c)
创建一个最初包含给定 collection 元素的 ConcurrentLinkedQueue，按照此 collection 迭代器的遍历顺序来添加元素。
ConcurrentSkipListSet(Collection<? extends E> c)
构造一个包含指定 collection 中元素的新 set，这个新 set 按照元素的自然顺序对其进行排序。
CopyOnWriteArrayList(Collection<? extends E> c)
创建一个按 collection 的迭代器返回元素的顺序包含指定 collection 元素的列表。
CopyOnWriteArraySet(Collection<? extends E> c)
创建一个包含指定 collection 所有元素的 set。
DelayQueue(Collection<? extends E> c)
创建一个最初包含 Delayed 实例的给定 collection 元素的 DelayQueue。
LinkedBlockingDeque(Collection<? extends E> c)
创建一个容量为 Integer.MAX_VALUE 的 LinkedBlockingDeque，最初包含给定 collection 的元素，以该 collection 迭代器的遍历顺序添加。
LinkedBlockingQueue(Collection<? extends E> c)
创建一个容量是 Integer.MAX_VALUE 的 LinkedBlockingQueue，最初包含给定 collection 的元素，元素按该 collection 迭代器的遍历顺序添加。
PriorityBlockingQueue(Collection<? extends E> c)
创建一个包含指定 collection 元素的 PriorityBlockingQueue。

java.util.concurrent.locks 中 Collection 的使用

返回 Collection 的 java.util.concurrent.locks 中的方法
Collection<Thread> | AbstractQueuedLongSynchronizer.getExclusiveQueuedThreads() 返回一个 collection，该 collection 包含正以独占模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getExclusiveQueuedThreads() 返回包含可能正以独占模式等待获取的线程 collection。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedReaderThreads() 返回一个 collection，它包含可能正在等待获取读取锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getQueuedThreads() 返回一个 collection，该 collection 包含正在等待获取的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedThreads() 返回一个 collection，它包含可能正在等待获取读取或写入锁的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getQueuedThreads() 返回包含可能正在等待获取的线程 collection。
protected Collection<Thread> | ReentrantLock.getQueuedThreads() 返回一个 collection，它包含可能正等待获取此锁的线程。
protected Collection<Thread> | ReentrantReadWriteLock.getQueuedWriterThreads() 返回一个 collection，它包含可能正在等待获取写入锁的线程。
Collection<Thread> | AbstractQueuedLongSynchronizer.getSharedQueuedThreads() 返回一个 collection，该 collection 包含正以共享模式等待获取的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getSharedQueuedThreads() 返回包含可能正以共享模式等待获取的线程 collection。
protected Collection<Thread> | AbstractQueuedLongSynchronizer.ConditionObject.getWaitingThreads() 返回一个 collection，该 collection 包含那些正在此条件等待的线程。
protected Collection<Thread> | AbstractQueuedSynchronizer.ConditionObject.getWaitingThreads() 返回包含那些可能正在等待此条件的线程 collection。
Collection<Thread> | AbstractQueuedLongSynchronizer.getWaitingThreads(AbstractQueuedLongSynchronizer.ConditionObject condition) 返回一个 collection，该 collection 包含那些正在与此同步器关联的给定条件上等待的线程。
Collection<Thread> | AbstractQueuedSynchronizer.getWaitingThreads(AbstractQueuedSynchronizer.ConditionObject condition) 返回一个 collection，其中包含可能正在等待与此同步器有关的给定条件的那些线程。
protected Collection<Thread> | ReentrantReadWriteLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与写入锁相关的给定条件的那些线程。
protected Collection<Thread> | ReentrantLock.getWaitingThreads(Condition condition) 返回一个 collection，它包含可能正在等待与此锁相关给定条件的那些线程。

java.util.jar 中 Collection 的使用

返回 Collection 的 java.util.jar 中的方法
 Collection<Object> Attributes.values()
返回此 Map 所包含的属性值的 Collection 视图。

javax.management 中 Collection 的使用

实现 Collection 的 javax.management 中的类
 class AttributeList
表示 MBean 属性值的列表。

参数类型为 Collection 的 javax.management 中的方法
boolean | AttributeList.addAll(Collection<?> c)
boolean | AttributeList.addAll(int index, Collection<?> c)

javax.management.openmbean 中 Collection 的使用

返回 Collection 的 javax.management.openmbean 中的方法
Collection<?> | CompositeData.values() 返回此 CompositeData 实例中所包含项值的不可修改的 Collection 视图。
Collection<?> | CompositeDataSupport.values() 返回此 CompositeData 实例中包含的项值的不可修改的 Collection 视图。
Collection<?> | TabularData.values() 返回此 TabularData 实例中包含的 CompositeData 值（即各行）的 collection 视图。
Collection<Object> | TabularDataSupport.values() 返回包含在此 TabularDataSupport 实例中的行的 collection 视图。

javax.management.relation 中 Collection 的使用

实现 Collection 的 javax.management.relation 中的类
class | RoleList RoleList 表示角色（Role 对象）的列表。
class | RoleUnresolvedList RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

参数类型为 Collection 的 javax.management.relation 中的方法
boolean | RoleList.addAll(Collection<?> c)
boolean | RoleUnresolvedList.addAll(Collection<?> c)
boolean | RoleList.addAll(int index, Collection<?> c)
boolean | RoleUnresolvedList.addAll(int index, Collection<?> c)

javax.print.attribute.standard 中 Collection 的使用

实现 Collection 的 javax.print.attribute.standard 中的类
 class JobStateReasons
JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

参数类型为 Collection 的 javax.print.attribute.standard 中的构造方法
JobStateReasons(Collection<JobStateReason> collection)
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。

javax.script 中 Collection 的使用

返回 Collection 的 javax.script 中的方法
 Collection<Object> SimpleBindings.values()
返回此映射中包含的值的 Collection 视图。

javax.sql.rowset 中 Collection 的使用

返回 Collection 的 javax.sql.rowset 中的方法
Collection<?> | JoinRowSet.getRowSets() 返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。
Collection<?> | CachedRowSet.toCollection() 将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。
Collection<?> | CachedRowSet.toCollection(int column) 将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
Collection<?> | CachedRowSet.toCollection(String column) 将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Properties 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Properties
的使用

使用 Properties 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.rmi.activation | 为 RMI 对象激活提供支持。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.naming | 为访问命名服务提供类和接口。
javax.xml.transform | 此包定义了用于处理转换指令，以及执行从源到结果的转换的一般 API。
org.omg.CORBA | 提供 OMG CORBA API 到 JavaTM 编程语言的映射，包括 ORB 类，如果已实现该类，则程序员可以使用此类作为全功能对象请求代理（Object Request Broker，ORB）。

java.awt 中 Properties 的使用

参数类型为 Properties 的 java.awt 中的方法
abstract  PrintJob Toolkit.getPrintJob(Frame frame, String jobtitle, Properties props)
获取一个 PrintJob 对象，该对象是在工具包平台上初始化某个打印操作的结果。

java.lang 中 Properties 的使用

返回 Properties 的 java.lang 中的方法
static Properties System.getProperties()
确定当前的系统属性。

参数类型为 Properties 的 java.lang 中的方法
static void System.setProperties(Properties props)
将系统属性设置为 Properties 参数。

java.rmi.activation 中 Properties 的使用

返回 Properties 的 java.rmi.activation 中的方法
 Properties ActivationGroupDesc.getPropertyOverrides()
返回组的重写属性列表。

参数类型为 Properties 的 java.rmi.activation 中的构造方法
ActivationGroupDesc(Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
使用组实现的系统默认值和代码基来构造一个组描述符。
ActivationGroupDesc(String className, String location, MarshalledObject<?> data, Properties overrides, ActivationGroupDesc.CommandEnvironment cmd)
指定一个用于该组的替代组实现和执行环境。

java.security 中 Properties 的使用

java.security 中 Properties 的子类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.sql 中 Properties 的使用

返回 Properties 的 java.sql 中的方法
 Properties Connection.getClientInfo()
返回一个列表，它包含驱动程序支持的每个客户端信息属性的名称和当前值。

参数类型为 Properties 的 java.sql 中的方法
Connection | Driver.connect(String url, Properties info) 试图创建一个到给定 URL 的数据库连接。
static Connection | DriverManager.getConnection(String url, Properties info) 试图建立到给定数据库 URL 的连接。
DriverPropertyInfo[] | Driver.getPropertyInfo(String url, Properties info) 获得此驱动程序的可能属性信息。
void | Connection.setClientInfo(Properties properties) 设置连接的客户端信息属性的值。

java.util 中 Properties 的使用

声明为 Properties 的 java.util 中的字段
protected  Properties Properties.defaults
一个属性列表，包含属性列表中所有未找到值的键的默认值。

参数类型为 Properties 的 java.util 中的构造方法
Properties(Properties defaults)
创建一个带有指定默认值的空属性列表。

javax.naming 中 Properties 的使用

声明为 Properties 的 javax.naming 中的字段
protected  Properties CompoundName.mySyntax
此组合名称的语法属性。

参数类型为 Properties 的 javax.naming 中的构造方法
CompoundName(Enumeration<String> comps, Properties syntax)
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。
CompoundName(String n, Properties syntax)
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。

javax.xml.transform 中 Properties 的使用

返回 Properties 的 javax.xml.transform 中的方法
Properties | Templates.getOutputProperties() 获取对应于有效 xsl:output 元素的属性。
abstract Properties | Transformer.getOutputProperties() 获取转换的输出属性的副本。

参数类型为 Properties 的 javax.xml.transform 中的方法
abstract  void Transformer.setOutputProperties(Properties oformat)
设置转换的输出属性。

org.omg.CORBA 中 Properties 的使用

参数类型为 Properties 的 org.omg.CORBA 中的方法
static ORB | ORB.init(Applet app, Properties props) 为 applet 创建一个新的 ORB 实例。
static ORB | ORB.init(String[] args, Properties props) 为独立的应用程序创建一个新的 ORB 实例。
protected abstract void | ORB.set_parameters(Applet app, Properties props) 允许使用给定 applet 和参数初始化 ORB 实现。
protected abstract void | ORB.set_parameters(String[] args, Properties props) 允许使用给定的参数和属性初始化 ORB 实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Hashtable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Hashtable
的使用

使用 Hashtable 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.image | 提供创建和修改图像的各种类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.management | 提供 Java Management Extensions 的核心类。
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.text.html.parser | 提供默认的 HTML 解析器以及支持类。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

java.awt 中 Hashtable 的使用

声明为 Hashtable 的 java.awt 中的字段
protected  Hashtable<Component,GridBagConstraints> GridBagLayout.comptable
此哈希表维持组件与其网格包约束之间的关联。

java.awt.image 中 Hashtable 的使用

参数类型为 Hashtable 的 java.awt.image 中的方法
void | CropImageFilter.setProperties(Hashtable<?,?> props) 添加指示裁剪区域的属性后传递源对象的属性。
void | PixelGrabber.setProperties(Hashtable<?,?> props) setProperties 方法是 ImageConsumer API 的一部分，此类必需实现 ImageConsumer API 来检索像素。
void | ReplicateScaleFilter.setProperties(Hashtable<?,?> props) 在添加一个指示所应用的缩放比例的属性后传递来自源对象的属性。
void | ImageFilter.setProperties(Hashtable<?,?> props) 添加一个属性，来指示已通过的过滤器流，并在这之后从源对象传递这些属性。
void | ImageConsumer.setProperties(Hashtable<?,?> props) 设置与此图像关联的可扩展属性列表。

参数类型为 Hashtable 的 java.awt.image 中的构造方法
BufferedImage(ColorModel cm, WritableRaster raster, boolean isRasterPremultiplied, Hashtable<?,?> properties)
构造一个具有指定 ColorModel 和 Raster 的新 BufferedImage。
MemoryImageSource(int w, int h, ColorModel cm, byte[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用 byte 数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, ColorModel cm, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用整数数组为 Image 对象生成数据的 ImageProducer 对象。
MemoryImageSource(int w, int h, int[] pix, int off, int scan, Hashtable<?,?> props)
构造一个使用默认 RGB ColorModel 中的整数数组为 Image 对象生成数据的 ImageProducer 对象。

java.security 中 Hashtable 的使用

java.security 中 Hashtable 的子类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.util 中 Hashtable 的使用

java.util 中 Hashtable 的子类
 class Properties
Properties 类表示了一个持久的属性集。

javax.management 中 Hashtable 的使用

返回 Hashtable 的 javax.management 中的方法
 Hashtable<String,String> ObjectName.getKeyPropertyList()
以哈希表的形式返回键属性。

参数类型为 Hashtable 的 javax.management 中的方法
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。

参数类型为 Hashtable 的 javax.management 中的构造方法
ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。

javax.naming 中 Hashtable 的使用

声明为 Hashtable 的 javax.naming 中的字段
protected Hashtable<?,?> | CannotProceedException.environment 包含与无法继续进行的 Context 或 DirContext 方法有关的环境。
protected Hashtable<Object,Object> | InitialContext.myProps 与此 InitialContext 关联的环境。

返回 Hashtable 的 javax.naming 中的方法
Hashtable<?,?> | CannotProceedException.getEnvironment() 检索创建此异常时受影响的环境。
Hashtable<?,?> | Context.getEnvironment() 检索对此上下文有效的环境。
Hashtable<?,?> | InitialContext.getEnvironment()

参数类型为 Hashtable 的 javax.naming 中的方法
abstract  Context ReferralException.getReferralContext(Hashtable<?,?> env)
使用环境属性检索继续该方法的上下文。
protected  void InitialContext.init(Hashtable<?,?> environment)
使用所提供的环境初始化初始上下文。
 void CannotProceedException.setEnvironment(Hashtable<?,?> environment)
设置调用 getEnvironment() 时将返回的环境。

参数类型为 Hashtable 的 javax.naming 中的构造方法
InitialContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始上下文。

javax.naming.directory 中 Hashtable 的使用

参数类型为 Hashtable 的 javax.naming.directory 中的构造方法
InitialDirContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始 DirContext。

javax.naming.ldap 中 Hashtable 的使用

参数类型为 Hashtable 的 javax.naming.ldap 中的方法
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env) 使用环境属性（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。

参数类型为 Hashtable 的 javax.naming.ldap 中的构造方法
InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
使用环境属性或连接请求控件构造初始上下文。

javax.naming.spi 中 Hashtable 的使用

参数类型为 Hashtable 的 javax.naming.spi 中的方法
InitialContextFactory | InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment) 使用指定环境创建一个初始上下文工厂。
ObjectFactory | ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment) 使用所提供的环境创建一个新对象工厂。
Context | InitialContextFactory.getInitialContext(Hashtable<?,?> environment) 创建一个初始上下文，以便开始进行名称解析。
static Context | NamingManager.getInitialContext(Hashtable<?,?> env) 使用指定环境属性创建一个初始上下文工厂。
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。
static Context | NamingManager.getURLContext(String scheme, Hashtable<?,?> environment) 为给定的 URL 方案 id 创建一个上下文。

javax.swing 中 Hashtable 的使用

javax.swing 中 Hashtable 的子类
 class UIDefaults
Swing 组件的默认值表。

声明为 Hashtable 的 javax.swing 中的字段
protected Hashtable | JTable.defaultEditorsByColumnClass 一个由对象组成的表，它显示并编辑单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
protected Hashtable | JTable.defaultRenderersByColumnClass 一个由对象组成的表，它显示单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。

返回 Hashtable 的 javax.swing 中的方法
Hashtable | JSlider.createStandardLabels(int increment) 创建一个数字文本标签的 Hashtable，从滑块最小值处开始并使用指定的增量。
Hashtable | JSlider.createStandardLabels(int increment, int start) 创建一个数字文本标签的 Hashtable，从指定起始点处开始并使用指定的增量。
protected Hashtable<Component,Integer> | JLayeredPane.getComponentToLayer() 返回将组件映射到层的哈希表。

参数类型为 Hashtable 的 javax.swing 中的构造方法
JTree(Hashtable<?,?> value)
返回从 Hashtable 创建的 JTree，它不显示根。

javax.swing.plaf.basic 中 Hashtable 的使用

声明为 Hashtable 的 javax.swing.plaf.basic 中的字段
protected Hashtable<TreePath,Boolean> | BasicTreeUI.drawingCache 用于最小化垂直线的绘制。
protected Hashtable<File,Icon> | BasicFileChooserUI.BasicFileView.iconCache

javax.swing.text.html.parser 中 Hashtable 的使用

声明为 Hashtable 的 javax.swing.text.html.parser 中的字段
Hashtable<String,Element> | DTD.elementHash
Hashtable<Object,Entity> | DTD.entityHash

javax.swing.undo 中 Hashtable 的使用

声明为 Hashtable 的 javax.swing.undo 中的字段
protected Hashtable<Object,Object> | StateEdit.postState 编辑之后的状态信息
protected Hashtable<Object,Object> | StateEdit.preState 编辑之前的状态信息

参数类型为 Hashtable 的 javax.swing.undo 中的方法
void | StateEditable.restoreState(Hashtable<?,?> state) 收到此消息时，接收者应从 state 中提取任何相关状态。
void | StateEditable.storeState(Hashtable<Object,Object> state) 收到此消息时，接收者应把任何相关状态放置到 state 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 java.util.Dictionary 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 java.util.Dictionary
的使用

使用 Dictionary 的软件包
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.security 中 Dictionary 的使用

java.security 中 Dictionary 的子类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

java.util 中 Dictionary 的使用

java.util 中 Dictionary 的子类
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | Properties Properties 类表示了一个持久的属性集。

javax.swing 中 Dictionary 的使用

javax.swing 中 Dictionary 的子类
 class UIDefaults
Swing 组件的默认值表。

返回 Dictionary 的 javax.swing 中的方法
 Dictionary JSlider.getLabelTable()
返回哪些标签在哪些值处绘制的字典。

参数类型为 Dictionary 的 javax.swing 中的方法
 void JSlider.setLabelTable(Dictionary labels)
用于指定将在给定值处绘制哪个标签。

javax.swing.text 中 Dictionary 的使用

返回 Dictionary 的 javax.swing.text 中的方法
 Dictionary<Object,Object> AbstractDocument.getDocumentProperties()
支持管理属性集。

参数类型为 Dictionary 的 javax.swing.text 中的方法
 void AbstractDocument.setDocumentProperties(Dictionary<Object,Object> x)
替换此文档的文档属性字典。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Map 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Map
的使用

使用 Map 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.awt.datatransfer | 提供在应用程序之间和在应用程序内部传输数据的接口和类。
java.awt.font | 提供与字体相关的类和接口。
java.awt.im | 提供输入方法框架所需的类和接口。
java.lang | 提供利用 Java 编程语言进行程序设计的基础类。
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
java.net | 为实现网络应用程序提供类。
java.security | 为安全框架提供类和接口。
java.sql | 提供使用 JavaTM 编程语言访问并处理存储在数据源（通常是一个关系数据库）中的数据的 API。
java.text | 提供以与自然语言无关的方式来处理文本、日期、数字和消息的类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。
javax.security.sasl | 包含用于支持 SASL 的类和接口。
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.serial | 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.xml.bind | 为包含解组、编组和验证功能的客户端应用程序提供运行时绑定框架。
javax.xml.crypto.dsig.spec | XML 数字签名的参数类。
javax.xml.ws | 此包包含核心 JAX-WS API。
javax.xml.ws.handler | 该包定义用于消息处理程序的 API。
javax.xml.ws.handler.soap | 该包定义用于 SOAP 消息处理程序的 API。

java.awt 中 Map 的使用

实现 Map 的 java.awt 中的类
 class RenderingHints
RenderingHints 类定义和管理键和关联值的集合，它允许应用程序将输入提供给其他类使用的算法选择，这些类执行呈现和图像处理服务。

声明为 Map 的 java.awt 中的字段
protected  Map<String,Object> Toolkit.desktopProperties

返回 Map 的 java.awt 中的方法
Map<TextAttribute,?> | Font.getAttributes() 返回此 Font 中可用的字体属性的映射。
abstract Map<TextAttribute,?> | Toolkit.mapInputMethodHighlight(InputMethodHighlight highlight) 返回给定输入方法高亮区的抽象级别描述的可视属性映射，如果不存在映射关系，则返回 null。

参数类型为 Map 的 java.awt 中的方法
abstract void | Graphics2D.addRenderingHints(Map<?,?> hints) 为呈现算法设置任意数量的首选项值。
Font | Font.deriveFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 通过复制当前 Font 对象并应用新的字体属性集，创建一个新 Font 对象。
static Font | Font.getFont(Map<? extends AttributedCharacterIterator.Attribute,?> attributes) 返回适合于这些属性的 Font。
void | RenderingHints.putAll(Map<?,?> m) 将指定 Map 中所有映射关系复制到此 RenderingHints 中。
abstract void | Graphics2D.setRenderingHints(Map<?,?> hints) 使用指定的 hints 替换用于所有呈现算法首选项的值。

参数类型为 Map 的 java.awt 中的构造方法
Font(Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
创建一个具有指定属性的新 Font。
RenderingHints(Map<RenderingHints.Key,?> init)
构造一个新对象，该对象具有根据指定 Map 对象（可以为 null）初始化的键和值。

java.awt.datatransfer 中 Map 的使用

返回 Map 的 java.awt.datatransfer 中的方法
Map<String,DataFlavor> | SystemFlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其大多数首选 DataFlavor 的 Map。
Map<String,DataFlavor> | FlavorMap.getFlavorsForNatives(String[] natives) 返回指定 String native 到其相应 DataFlavor 的 Map。
Map<DataFlavor,String> | SystemFlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其大多数首选的 String native 的 Map。
Map<DataFlavor,String> | FlavorMap.getNativesForFlavors(DataFlavor[] flavors) 返回指定 DataFlavor 到其对应的 String native 的 Map。

java.awt.font 中 Map 的使用

参数类型为 Map 的 java.awt.font 中的构造方法
TextLayout(String string, Map<? extends AttributedCharacterIterator.Attribute,?> attributes, FontRenderContext frc)
根据 String 和属性集构造一个 TextLayout。

java.awt.im 中 Map 的使用

返回 Map 的 java.awt.im 中的方法
 Map<TextAttribute,?> InputMethodHighlight.getStyle()
返回文本范围的呈现样式属性，或 null。

参数类型为 Map 的 java.awt.im 中的构造方法
InputMethodHighlight(boolean selected, int state, int variation, Map<TextAttribute,?> style)
构造输入方法高亮显示记录。

java.lang 中 Map 的使用

返回 Map 的 java.lang 中的方法
Map<String,String> | ProcessBuilder.environment() 返回此进程生成器环境的字符串映射视图。
static Map<Thread,StackTraceElement[]> | Thread.getAllStackTraces() 返回所有活动线程的堆栈跟踪的一个映射。
static Map<String,String> | System.getenv() 返回一个不能修改的当前系统环境的字符串映射视图。

java.lang.management 中 Map 的使用

返回 Map 的 java.lang.management 中的方法
 Map<String,String> RuntimeMXBean.getSystemProperties()
返回所有系统属性的名称和值的映射。

java.net 中 Map 的使用

返回 Map 的 java.net 中的方法
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
Map<String,List<String>> | URLConnection.getHeaderFields() 返回头字段的不可修改的 Map。
abstract Map<String,List<String>> | CacheResponse.getHeaders() 以 Map 的形式返回响应头。
Map<String,List<String>> | URLConnection.getRequestProperties() 返回一个由此连接的一般请求属性构成的不可修改的 Map。

参数类型为 Map 的 java.net 中的方法
abstract Map<String,List<String>> | CookieHandler.get(URI uri, Map<String,List<String>> requestHeaders) 从请求头中指定 uri 的 cookie 缓存中获取所有可用的 cookie。
Map<String,List<String>> | CookieManager.get(URI uri, Map<String,List<String>> requestHeaders)
abstract CacheResponse | ResponseCache.get(URI uri, String rqstMethod, Map<String,List<String>> rqstHeaders) 根据请求的 uri、请求方法和请求头获取缓存的响应。
abstract void | CookieHandler.put(URI uri, Map<String,List<String>> responseHeaders) 将响应头中出现的所有可用 cookie（例如名为 Set-Cookie2 的响应头字段）设置到 cookie 缓存中。
void | CookieManager.put(URI uri, Map<String,List<String>> responseHeaders)

java.security 中 Map 的使用

实现 Map 的 java.security 中的类
class | AuthProvider 此类定义 provider 的登录和注销方法。
class | Provider 此类表示 Java 安全 API "provider"，这里 provider 实现了 Java 安全性的一部分或者全部。

参数类型为 Map 的 java.security 中的方法
static Provider[] | Security.getProviders(Map<String,String> filter) 返回包含可以满足指定的 * 选择标准的所有已安装的提供者的数组，如果尚未安装此类提供者，则返回 null。
void | Provider.putAll(Map<?,?> t) 将指定 Map 中所有映射关系复制到此 provider 中。

参数类型为 Map 的 java.security 中的构造方法
Provider.Service(Provider provider, String type, String algorithm, String className, List<String> aliases, Map<String,String> attributes)
构造新的服务。

java.sql 中 Map 的使用

返回 Map 的 java.sql 中的方法
Map<String,ClientInfoStatus> | SQLClientInfoException.getFailedProperties() 返回无法设置的客户端信息属性列表。
Map<String,Class<?>> | Connection.getTypeMap() 获取与此 Connection 对象关联的 Map 对象。

参数类型为 Map 的 java.sql 中的方法
Object | Array.getArray(long index, int count, Map<String,Class<?>> map) 获取由此 ARRAY 对象指定的 SQL Array 值的一部分，从指定 index 开始，包含 SQL 数组中 count 个连续元素。
Object | Array.getArray(Map<String,Class<?>> map) 获取由此 Array 对象指定的 SQL ARRAY 值的内容。
Object[] | Struct.getAttributes(Map<String,Class<?>> map) 生成此 Struct 对象所表示的 SQL 结构类型的属性的有序值。
Object | CallableStatement.getObject(int parameterIndex, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterIndex 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(int columnIndex, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
Object | Ref.getObject(Map<String,Class<?>> map) 获取引用对象并使用给定类型映射表将其映射到 Java 类型。
Object | CallableStatement.getObject(String parameterName, Map<String,Class<?>> map) 返回一个表示 OUT 参数 parameterName 值的对象，并将 map 用于该参数值的自定义映射关系。
Object | ResultSet.getObject(String columnLabel, Map<String,Class<?>> map) 以 Java 编程语言中 Object 的形式获取此 ResultSet 对象的当前行中指定列的值。
ResultSet | Array.getResultSet(long index, int count, Map<String,Class<?>> map) 获取保存子数组的元素的结果集合，从索引 index 开始，包含 count 个连续元素。
ResultSet | Array.getResultSet(Map<String,Class<?>> map) 获取包含由此 Array 对象指定的 SQL ARRAY 值的元素的结果集合。
void | Connection.setTypeMap(Map<String,Class<?>> map) 将给定的 TypeMap 对象安装为此 Connection 对象的类型映射。

参数类型为 Map 的 java.sql 中的构造方法
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, int vendorCode, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause、vendorCode 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties)
构造一个使用给定 reason、SQLState 和 failedProperties 初始化的 SQLClientInfoException 对象。
SQLClientInfoException(String reason, String SQLState, Map<String,ClientInfoStatus> failedProperties, Throwable cause)
构造一个使用给定 reason、SQLState、cause 和 failedProperties 初始化的 SQLClientInfoException 对象。

java.text 中 Map 的使用

返回 Map 的 java.text 中的方法
 Map<AttributedCharacterIterator.Attribute,Object> AttributedCharacterIterator.getAttributes()
返回具有定义于当前字符上的多个属性的映射。

参数类型为 Map 的 java.text 中的方法
 void AttributedString.addAttributes(Map<? extends AttributedCharacterIterator.Attribute,?> attributes, int beginIndex, int endIndex)
将属性集添加到字符串的子范围。

参数类型为 Map 的 java.text 中的构造方法
AttributedString(String text, Map<? extends AttributedCharacterIterator.Attribute,?> attributes)
构造带给定文本和属性的 AttributedString。

java.util 中 Map 的使用

java.util 中 Map 的子接口
interface | NavigableMap<K,V> 扩展的 SortedMap，具有了针对给定搜索目标返回最接近匹配项的导航方法。
interface | SortedMap<K,V> 进一步提供关于键的总体排序 的 Map。

实现 Map 的 java.util 中的类
class | AbstractMap<K,V> 此类提供 Map 接口的骨干实现，以最大限度地减少实现此接口所需的工作。
class | EnumMap<K extends Enum<K>,V> 与枚举类型键一起使用的专用 Map 实现。
class | HashMap<K,V> 基于哈希表的 Map 接口的实现。
class | Hashtable<K,V> 此类实现一个哈希表，该哈希表将键映射到相应的值。
class | IdentityHashMap<K,V> 此类利用哈希表实现 Map 接口，比较键（和值）时使用引用相等性代替对象相等性。
class | LinkedHashMap<K,V> Map 接口的哈希表和链接列表实现，具有可预知的迭代顺序。
class | Properties Properties 类表示了一个持久的属性集。
class | TreeMap<K,V> 基于红黑树（Red-Black tree）的 NavigableMap 实现。
class | WeakHashMap<K,V> 以弱键 实现的基于哈希表的 Map。

声明为 Map 的 java.util 中的字段
static Map Collections.EMPTY_MAP
空的映射（不可变的）。

返回 Map 的 java.util 中的方法
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<K,V> Map<K,V>
Collections.emptyMap()
返回空的映射（不可变的）。
 Map<String,Integer> Calendar.getDisplayNames(int field, int style, Locale locale)
返回给定 style 和 locale 下包含日历 field 所有名称的 Map 及其相应字段值。
static
<K,V> Map<K,V>
Collections.singletonMap(K key, V value)
返回一个不可变的映射，它只将指定键映射到指定值。
static
<K,V> Map<K,V>
Collections.synchronizedMap(Map<K,V> m)
返回由指定映射支持的同步（线程安全的）映射。
static
<K,V> Map<K,V>
Collections.unmodifiableMap(Map<? extends K,? extends V> m)
返回指定映射的不可修改视图。

参数类型为 Map 的 java.util 中的方法
static
<K,V> Map<K,V>
Collections.checkedMap(Map<K,V> m, Class<K> keyType, Class<V> valueType)
返回指定映射的一个动态类型安全视图。
static
<E> Set<E>
Collections.newSetFromMap(Map<E,Boolean> map)
返回指定映射支持的 set。
 void EnumMap.putAll(Map<? extends K,? extends V> m)
将指定映射中所有映射关系复制到此映射中。
 void IdentityHashMap.putAll(Map<? extends K,? extends V> m)
将指定映射的全部映射关系复制到此映射，这些映射关系将替换此映射目前针对指定映射的任何键的任何映射关系。
 void TreeMap.putAll(Map<? extends K,? extends V> map)
将指定映射中的所有映射关系复制到此映射中。
 void WeakHashMap.putAll(Map<? extends K,? extends V> m)
将指定映射的全部映射关系复制到此映射。
 void HashMap.putAll(Map<? extends K,? extends V> m)
将指定映射的所有映射关系复制到此映射中，这些映射关系将替换此映射目前针对指定映射中所有键的所有映射关系。
 void AbstractMap.putAll(Map<? extends K,? extends V> m)
从指定映射中将所有映射关系复制到此映射中（可选操作）。
 void Hashtable.putAll(Map<? extends K,? extends V> t)
将指定映射的所有映射关系复制到此哈希表中，这些映射关系将替换此哈希表拥有的、针对当前指定映射中所有键的所有映射关系。
 void Map.putAll(Map<? extends K,? extends V> m)
从指定映射中将所有映射关系复制到此映射中（可选操作）。
static
<K,V> Map<K,V>
Collections.synchronizedMap(Map<K,V> m)
返回由指定映射支持的同步（线程安全的）映射。
static
<K,V> Map<K,V>
Collections.unmodifiableMap(Map<? extends K,? extends V> m)
返回指定映射的不可修改视图。

参数类型为 Map 的 java.util 中的构造方法
EnumMap(Map<K,? extends V> m)
创建一个枚举映射，从指定映射对其初始化。
HashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定 Map 相同的新 HashMap。
Hashtable(Map<? extends K,? extends V> t)
构造一个与给定的 Map 具有相同映射关系的新哈希表。
IdentityHashMap(Map<? extends K,? extends V> m)
构造包含指定映射中键-值映射关系的新标识哈希映射。
LinkedHashMap(Map<? extends K,? extends V> m)
构造一个映射关系与指定映射相同的插入顺序 LinkedHashMap 实例。
TreeMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新的树映射，该映射根据其键的自然顺序 进行排序。
WeakHashMap(Map<? extends K,? extends V> m)
构造一个新 WeakHashMap，使其与指定的映射具有相同的映射关系。

java.util.concurrent 中 Map 的使用

java.util.concurrent 中 Map 的子接口
interface | ConcurrentMap<K,V> 提供其他原子 putIfAbsent、remove、replace 方法的 Map。
interface | ConcurrentNavigableMap<K,V> 支持 NavigableMap 操作，且以递归方式支持其可导航子映射的 ConcurrentMap。

实现 Map 的 java.util.concurrent 中的类
class | ConcurrentHashMap<K,V> 支持获取的完全并发和更新的所期望可调整并发的哈希表。
class | ConcurrentSkipListMap<K,V> 可缩放的并发 ConcurrentNavigableMap 实现。

参数类型为 Map 的 java.util.concurrent 中的方法
 void ConcurrentHashMap.putAll(Map<? extends K,? extends V> m)
将指定映射中所有映射关系复制到此映射中。

参数类型为 Map 的 java.util.concurrent 中的构造方法
ConcurrentHashMap(Map<? extends K,? extends V> m)
构造一个与给定映射具有相同映射关系的新映射。
ConcurrentSkipListMap(Map<? extends K,? extends V> m)
构造一个新映射，该映射所包含的映射关系与给定映射包含的映射关系相同，并按照键的自然顺序进行排序。

java.util.jar 中 Map 的使用

实现 Map 的 java.util.jar 中的类
 class Attributes
Attributes 类将 Manifest 属性名称映射到关联的字符串值。

声明为 Map 的 java.util.jar 中的字段
protected  Map<Object,Object> Attributes.map
属性名称-值映射关系。

返回 Map 的 java.util.jar 中的方法
 Map<String,Attributes> Manifest.getEntries()
返回此 Manifest 中所包含条目的 Map。

参数类型为 Map 的 java.util.jar 中的方法
 void Attributes.putAll(Map<?,?> attr)
将所有的属性名称-值映射关系从指定的 Attributes 复制到此 Map。

javax.annotation.processing 中 Map 的使用

返回 Map 的 javax.annotation.processing 中的方法
 Map<String,String> ProcessingEnvironment.getOptions()
返回传递给注释处理工具的特定于 processor 的选项。

javax.lang.model.element 中 Map 的使用

返回 Map 的 javax.lang.model.element 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues()
返回此注释元素的值。

javax.lang.model.util 中 Map 的使用

返回 Map 的 javax.lang.model.util 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults(AnnotationMirror a)
返回注释元素的值，包括默认值。

javax.management 中 Map 的使用

参数类型为 Map 的 javax.management 中的构造方法
ImmutableDescriptor(Map<String,?> fields)
构造一个描述符，其中字段名称和值是给定 Map 的键和值。

javax.management.loading 中 Map 的使用

返回 Map 的 javax.management.loading 中的方法
 Map<String,String> MLetContent.getAttributes()
获取 MLET 标记的属性。

参数类型为 Map 的 javax.management.loading 中的构造方法
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

javax.management.openmbean 中 Map 的使用

实现 Map 的 javax.management.openmbean 中的类
 class TabularDataSupport
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

参数类型为 Map 的 javax.management.openmbean 中的方法
 void TabularDataSupport.putAll(Map<?,?> t)
将包含在指定映射 t 中的所有值添加到此 TabularData 实例。

参数类型为 Map 的 javax.management.openmbean 中的构造方法
CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。

javax.management.relation 中 Map 的使用

返回 Map 的 javax.management.relation 中的方法
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
Map<ObjectName,List<String>> | Relation.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationSupport.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。

javax.management.remote 中 Map 的使用

返回 Map 的 javax.management.remote 中的方法
 Map<String,?> JMXConnectorServerMBean.getAttributes()
此连接器服务器的属性。

参数类型为 Map 的 javax.management.remote 中的方法
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
void | JMXConnector.connect(Map<String,?> env) 建立到连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。
JMXConnector | JMXConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
JMXConnector | JMXConnectorServerMBean.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

javax.management.remote.rmi 中 Map 的使用

返回 Map 的 javax.management.remote.rmi 中的方法
 Map<String,?> RMIConnectorServer.getAttributes()

参数类型为 Map 的 javax.management.remote.rmi 中的方法
void | RMIConnector.connect(Map<String,?> environment)
JMXConnector | RMIConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

参数类型为 Map 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。
RMIConnector(JMXServiceURL url, Map<String,?> environment)
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。
RMIConnector(RMIServer rmiServer, Map<String,?> environment)
用给定的 RMI stub 构造一个 RMIConnector。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIIIOPServerImpl(Map<String,?> env)
创建新的 RMIServerImpl。
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。
RMIServerImpl(Map<String,?> env)
构造一个新的 RMIServerImpl。

javax.print.attribute.standard 中 Map 的使用

实现 Map 的 javax.print.attribute.standard 中的类
 class PrinterStateReasons
PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

参数类型为 Map 的 javax.print.attribute.standard 中的构造方法
PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。

javax.script 中 Map 的使用

javax.script 中 Map 的子接口
 interface Bindings
所有键均为 String 的键/值对映射关系。

实现 Map 的 javax.script 中的类
 class SimpleBindings
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。

参数类型为 Map 的 javax.script 中的方法
void | Bindings.putAll(Map<? extends String,? extends Object> toMerge) 将给定 Map 中的所有映射关系添加到此 Bindings 中。
void | SimpleBindings.putAll(Map<? extends String,? extends Object> toMerge) putAll 是使用 Map.putAll 实现的。

参数类型为 Map 的 javax.script 中的构造方法
SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。

javax.security.auth.login 中 Map 的使用

返回 Map 的 javax.security.auth.login 中的方法
 Map<String,?> AppConfigurationEntry.getOptions()
获取为此 LoginModule 配置的选项。

参数类型为 Map 的 javax.security.auth.login 中的构造方法
AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

javax.security.auth.spi 中 Map 的使用

参数类型为 Map 的 javax.security.auth.spi 中的方法
void | LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options) 初始化此 LoginModule。
void | LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options) 初始化此 LoginModule。

javax.security.auth.x500 中 Map 的使用

参数类型为 Map 的 javax.security.auth.x500 中的方法
 String X500Principal.getName(String format, Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。

参数类型为 Map 的 javax.security.auth.x500 中的构造方法
X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。

javax.security.sasl 中 Map 的使用

参数类型为 Map 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。
String[] | SaslClientFactory.getMechanismNames(Map<String,?> props) 返回与指定的机制选择策略相符的机制的名称数组。
String[] | SaslServerFactory.getMechanismNames(Map<String,?> props) 返回与指定的机制选择策略相符的机制的名称数组。

javax.sound.midi 中 Map 的使用

返回 Map 的 javax.sound.midi 中的方法
 Map<String,Object> MidiFileFormat.properties()
获得属性的一个不可修改的映射。

参数类型为 Map 的 javax.sound.midi 中的构造方法
MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。

javax.sound.sampled 中 Map 的使用

返回 Map 的 javax.sound.sampled 中的方法
Map<String,Object> | AudioFileFormat.properties() 获得不可修改的属性映射。
Map<String,Object> | AudioFormat.properties() 获取不可修改的属性映射。

参数类型为 Map 的 javax.sound.sampled 中的构造方法
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sql 中 Map 的使用

返回 Map 的 javax.sql 中的方法
 Map<String,Class<?>> RowSet.getTypeMap()
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。

参数类型为 Map 的 javax.sql 中的方法
 void RowSet.setTypeMap(Map<String,Class<?>> map)
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。

javax.sql.rowset 中 Map 的使用

返回 Map 的 javax.sql.rowset 中的方法
 Map<String,Class<?>> BaseRowSet.getTypeMap()
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。

参数类型为 Map 的 javax.sql.rowset 中的方法
 void BaseRowSet.setTypeMap(Map<String,Class<?>> map)
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。

javax.sql.rowset.serial 中 Map 的使用

参数类型为 Map 的 javax.sql.rowset.serial 中的方法
Object | SerialArray.getArray(long index, int count, Map<String,Class<?>> map) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(Map<String,Class<?>> map) 返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
Object[] | SerialStruct.getAttributes(Map<String,Class<?>> map) 获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
Object | SerialRef.getObject(Map<String,Class<?>> map) 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。

参数类型为 Map 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。
SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。
SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。

javax.swing 中 Map 的使用

实现 Map 的 javax.swing 中的类
 class UIDefaults
Swing 组件的默认值表。

javax.xml.bind 中 Map 的使用

参数类型为 Map 的 javax.xml.bind 中的方法
static JAXBContext | JAXBContext.newInstance(Class[] classesToBeBound, Map<String,?> properties) 获得 JAXBContext 类的新实例。
static JAXBContext | JAXBContext.newInstance(String contextPath, ClassLoader classLoader, Map<String,?> properties) 获得 JAXBContext 类的新实例。

javax.xml.crypto.dsig.spec 中 Map 的使用

返回 Map 的 javax.xml.crypto.dsig.spec 中的方法
Map | XPathFilterParameterSpec.getNamespaceMap() 返回名称空间前缀的映射表。
Map | XPathType.getNamespaceMap() 返回名称空间前缀的映射表。

参数类型为 Map 的 javax.xml.crypto.dsig.spec 中的构造方法
XPathFilterParameterSpec(String xPath, Map namespaceMap)
创建带有指定 XPath 表达式和名称空间映射表的 XPathFilterParameterSpec。
XPathType(String expression, XPathType.Filter filter, Map namespaceMap)
创建带有指定 XPath 表达式、过滤器和名称空间映射表的 XPathType 实例。

javax.xml.ws 中 Map 的使用

返回 Map 的 javax.xml.ws 中的方法
Map<String,Object> | Response.getContext() 获取所含的响应上下文。
abstract Map<String,Object> | Endpoint.getProperties() 返回此 Endpoint 实例的属性包。
Map<String,Object> | BindingProvider.getRequestContext() 获取用于初始化请求消息的消息上下文的上下文。
Map<String,Object> | BindingProvider.getResponseContext() 获取处理响应消息所得的上下文。

参数类型为 Map 的 javax.xml.ws 中的方法
abstract  void Endpoint.setProperties(Map<String,Object> properties)
设置此 Endpoint 实例的属性包。

javax.xml.ws.handler 中 Map 的使用

javax.xml.ws.handler 中 Map 的子接口
interface | LogicalMessageContext LogicalMessageContext 接口扩展了 MessageContext，以访问以与协议无关的 LogicalMessage 形式包含的消息。
interface | MessageContext 接口 MessageContext 抽象化由 handle 方法中的处理程序处理的消息上下文。

javax.xml.ws.handler.soap 中 Map 的使用

javax.xml.ws.handler.soap 中 Map 的子接口
 interface SOAPMessageContext
接口 SOAPMessageContext 提供对 RPC 请求或响应的 SOAP 消息的访问。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 java.util.Map.Entry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 java.util.Map.Entry
的使用

使用 Map.Entry 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
java.security | 为安全框架提供类和接口。
java.util | 包含 collection 框架、遗留的 collection 类、事件模型、日期和时间设施、国际化和各种实用工具类（字符串标记生成器、随机数生成器和位数组）。
java.util.concurrent | 在并发编程中很常用的实用工具类。
java.util.jar | 提供读写 JAR (Java ARchive) 文件格式的类，该格式基于具有可选清单文件的标准 ZIP 文件格式。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.script | 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

java.awt 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 java.awt 中的方法
 Set<Map.Entry<Object,Object>> RenderingHints.entrySet()
返回此 RenderingHints 中所包含映射关系的 Set 视图。

java.security 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 java.security 中的方法
 Set<Map.Entry<Object,Object>> Provider.entrySet()
返回此 Provider 中所包含的属性项的一个不可修改的 Set 视图。

java.util 中 Map.Entry 的使用

实现 Map.Entry 的 java.util 中的类
static class | AbstractMap.SimpleEntry<K,V> 维护键和值的 Entry。
static class | AbstractMap.SimpleImmutableEntry<K,V> 维护不可变的键和值的 Entry。

返回 Map.Entry 的 java.util 中的方法
Map.Entry<K,V> | TreeMap.ceilingEntry(K key)
Map.Entry<K,V> | NavigableMap.ceilingEntry(K key) 返回一个键-值映射关系，它与大于等于给定键的最小键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.firstEntry()
Map.Entry<K,V> | NavigableMap.firstEntry() 返回一个与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | TreeMap.floorEntry(K key)
Map.Entry<K,V> | NavigableMap.floorEntry(K key) 返回一个键-值映射关系，它与小于等于给定键的最大键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.higherEntry(K key)
Map.Entry<K,V> | NavigableMap.higherEntry(K key) 返回一个键-值映射关系，它与严格大于给定键的最小键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.lastEntry()
Map.Entry<K,V> | NavigableMap.lastEntry() 返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | TreeMap.lowerEntry(K key)
Map.Entry<K,V> | NavigableMap.lowerEntry(K key) 返回一个键-值映射关系，它与严格小于给定键的最大键关联；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | TreeMap.pollFirstEntry()
Map.Entry<K,V> | NavigableMap.pollFirstEntry() 移除并返回与此映射中的最小键关联的键-值映射关系；如果映射为空，则返回 null。
Map.Entry<K,V> | TreeMap.pollLastEntry()
Map.Entry<K,V> | NavigableMap.pollLastEntry() 移除并返回与此映射中的最大键关联的键-值映射关系；如果映射为空，则返回 null。

返回变量类型为 Map.Entry 的类型的 java.util 中的方法
Set<Map.Entry<K,V>> | EnumMap.entrySet() 返回此映射中所包含映射关系的 Set 视图。
Set<Map.Entry<K,V>> | IdentityHashMap.entrySet() 返回此映射所包含映射关系的 Set 视图。
Set<Map.Entry<K,V>> | TreeMap.entrySet() 返回此映射中包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | SortedMap.entrySet() 返回在此映射中包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | WeakHashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | HashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。
abstract Set<Map.Entry<K,V>> | AbstractMap.entrySet()
Set<Map.Entry<K,V>> | Hashtable.entrySet() 返回此映射中包含的键的 Set 视图。
Set<Map.Entry<K,V>> | Map.entrySet() 返回此映射中包含的映射关系的 Set 视图。

参数类型为 Map.Entry 的 java.util 中的方法
protected  boolean LinkedHashMap.removeEldestEntry(Map.Entry<K,V> eldest)
如果此映射移除其最旧的条目，则返回 true。

参数类型为 Map.Entry 的 java.util 中的构造方法
AbstractMap.SimpleEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定的项相同。
AbstractMap.SimpleImmutableEntry(Map.Entry<? extends K,? extends V> entry)
创建一个项，它表示的映射关系与指定项相同。

java.util.concurrent 中 Map.Entry 的使用

返回 Map.Entry 的 java.util.concurrent 中的方法
Map.Entry<K,V> | ConcurrentSkipListMap.ceilingEntry(K key) 返回与大于等于给定键的最小键关联的键-值映射关系；如果不存在这样的条目，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.firstEntry() 返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.floorEntry(K key) 返回与小于等于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.higherEntry(K key) 返回与严格大于给定键的最小键关联的键-值映射关系；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.lastEntry() 返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.lowerEntry(K key) 返回与严格小于给定键的最大键关联的键-值映射关系；如果不存在这样的键，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.pollFirstEntry() 移除并返回与此映射中的最小键关联的键-值映射关系；如果该映射为空，则返回 null。
Map.Entry<K,V> | ConcurrentSkipListMap.pollLastEntry() 移除并返回与此映射中的最大键关联的键-值映射关系；如果该映射为空，则返回 null。

返回变量类型为 Map.Entry 的类型的 java.util.concurrent 中的方法
Set<Map.Entry<K,V>> | ConcurrentSkipListMap.entrySet() 返回此映射中所包含的映射关系的 Set 视图。
Set<Map.Entry<K,V>> | ConcurrentHashMap.entrySet() 返回此映射所包含的映射关系的 Set 视图。

java.util.jar 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 java.util.jar 中的方法
 Set<Map.Entry<Object,Object>> Attributes.entrySet()
返回此 Map 所包含的属性名称-值映射关系的 Collection 视图。

javax.management.openmbean 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 javax.management.openmbean 中的方法
 Set<Map.Entry<Object,Object>> TabularDataSupport.entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。

javax.script 中 Map.Entry 的使用

返回变量类型为 Map.Entry 的类型的 javax.script 中的方法
 Set<Map.Entry<String,Object>> SimpleBindings.entrySet()
返回此映射中包含的映射关系的 Set 视图。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Accessible (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 Accessible

所有已知实现类：
AbstractColorChooserPanel, Applet, BasicArrowButton, BasicComboBoxRenderer, BasicComboBoxRenderer.UIResource, BasicComboPopup, BasicInternalFrameTitlePane.SystemMenuBar, BasicToolBarUI.DragWindow, Box, Box.Filler, Button, Canvas, CellRendererPane, Checkbox, CheckboxMenuItem, Choice, DefaultListCellRenderer, DefaultListCellRenderer.UIResource, DefaultTableCellRenderer, DefaultTableCellRenderer.UIResource, DefaultTreeCellEditor.DefaultTextField, DefaultTreeCellRenderer, Dialog, FileDialog, Frame, HTMLEditorKit, ImageIcon, JApplet, JButton, JCheckBox, JCheckBoxMenuItem, JColorChooser, JComboBox, JDesktopPane, JDialog, JEditorPane, JFileChooser, JFormattedTextField, JFrame, JInternalFrame, JInternalFrame.JDesktopIcon, JLabel, JLayeredPane, JList, JList.AccessibleJList.AccessibleJListChild, JMenu, JMenuBar, JMenuItem, JOptionPane, JPanel, JPasswordField, JPopupMenu, JPopupMenu.Separator, JProgressBar, JRadioButton, JRadioButtonMenuItem, JRootPane, JScrollBar, JScrollPane, JScrollPane.ScrollBar, JSeparator, JSlider, JSpinner, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, JSplitPane, JTabbedPane, JTable, JTable.AccessibleJTable.AccessibleJTableCell, JTableHeader, JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry, JTextArea, JTextComponent, JTextField, JTextPane, JToggleButton, JToolBar, JToolBar.Separator, JToolTip, JTree, JTree.AccessibleJTree.AccessibleJTreeNode, JViewport, JWindow, Label, List, List.AccessibleAWTList.AccessibleAWTListChild, Menu, MenuBar, MenuItem, MetalComboBoxButton, MetalComboBoxUI.MetalComboPopup, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer, MetalScrollButton, Panel, PopupMenu, ProgressMonitor, Scrollbar, ScrollPane, TextArea, TextComponent, TextField, Window
public interface Accessible

Accessible 接口是可访问性包的主接口。所有支持可访问性包的组件都必须实现此接口。它包含单个方法 getAccessibleContext()，此方法返回 AccessibleContext 类的实例。

方法摘要
 AccessibleContext getAccessibleContext()
返回与此对象关联的 AccessibleContext。

方法详细信息

getAccessibleContext

AccessibleContext getAccessibleContext()
返回与此对象关联的 AccessibleContext。在大多数情况下，如果对象实现了 Accessible 接口，则返回值不应为 null。如果组件开发人员创建了实现 Accessible 的对象的子类，且该子类不是 Accessible，那么开发人员应该重写 getAccessibleContext 方法以返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AccessibleAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleAction

所有已知实现类：
AbstractButton.AccessibleAbstractButton, AccessibleHyperlink, Button.AccessibleAWTButton, Checkbox.AccessibleAWTCheckbox, CheckboxMenuItem.AccessibleAWTCheckboxMenuItem, Choice.AccessibleAWTChoice, JButton.AccessibleJButton, JCheckBox.AccessibleJCheckBox, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JComboBox.AccessibleJComboBox, JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink, JMenu.AccessibleJMenu, JMenuItem.AccessibleJMenuItem, JPasswordField.AccessibleJPasswordField, JRadioButton.AccessibleJRadioButton, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JSpinner.AccessibleJSpinner, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField, JToggleButton.AccessibleJToggleButton, JTree.AccessibleJTree.AccessibleJTreeNode, Menu.AccessibleAWTMenu, MenuItem.AccessibleAWTMenuItem, PopupMenu.AccessibleAWTPopupMenu
public interface AccessibleAction

任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。此接口为辅助技术提供标准机制，以确定这些动作是什么并通知对象执行它们。任何可操作的对象都应支持此接口。应用程序通过首先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext.getAccessibleAction() 方法，能够确定该对象是否支持 AccessibleAction 接口。如果返回值不为 null，则该对象支持此接口。

另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleAction()

字段摘要
static String | CLICK 导致某个组件执行其默认动作的动作。
static String | DECREMENT 减少某个值的动作。
static String | INCREMENT 增加某个值的动作。
static String | TOGGLE_EXPAND 如果树节点是展开的，则此动作将折叠它，如果是折叠的则展开它。
static String | TOGGLE_POPUP 如果某个弹出菜单是隐藏的，则此动作将使其可见，如果是可见的则将其隐藏。
方法摘要
boolean | doAccessibleAction(int i) 对对象执行指定的 Action
int | getAccessibleActionCount() 返回此对象中可用的可访问动作数。
String | getAccessibleActionDescription(int i) 返回对对象指定动作的描述。

字段详细信息

TOGGLE_EXPAND

static final String TOGGLE_EXPAND
如果树节点是展开的，则此动作将折叠它，如果是折叠的则展开它。

从以下版本开始：
1.5

INCREMENT

static final String INCREMENT
增加某个值的动作。

从以下版本开始：
1.5

DECREMENT

static final String DECREMENT
减少某个值的动作。

从以下版本开始：
1.5

CLICK

static final String CLICK
导致某个组件执行其默认动作的动作。

从以下版本开始：
1.6

TOGGLE_POPUP

static final String TOGGLE_POPUP
如果某个弹出菜单是隐藏的，则此动作将使其可见，如果是可见的则将其隐藏。

从以下版本开始：
1.6
方法详细信息

getAccessibleActionCount

int getAccessibleActionCount()
返回此对象中可用的可访问动作数。如果多于一个，则将第一个动作视为该对象的“默认”动作。

返回：
此对象中的 Action 数，从 0 开始

getAccessibleActionDescription

String getAccessibleActionDescription(int i)
返回对对象指定动作的描述。

参数：
i - 从 0 开始的动作索引
返回：
动作的 String 描述
另请参见：
getAccessibleActionCount()

doAccessibleAction

boolean doAccessibleAction(int i)
对对象执行指定的 Action

参数：
i - 从 0 开始的动作索引
返回：
如果执行了动作，则返回 true；否则返回 false。
另请参见：
getAccessibleActionCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleAttributeSequence (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleAttributeSequence

java.lang.Object
    继承者  javax.accessibility.AccessibleAttributeSequence

public class AccessibleAttributeSequence
extends Object

此类汇集共享相同连续属性集的文本的跨度，以及该属性集。此方法供 AccessibleContext 类的实现者使用，以便生成 ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED 事件。

另请参见：
AccessibleContext, AccessibleContext.ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED

字段摘要
AttributeSet | attributes 文本属性
int | endIndex 文本序列的结束索引
int | startIndex 文本序列的起始索引
构造方法摘要
AccessibleAttributeSequence(int start, int end, AttributeSet attr)
构造带有给定参数的 AccessibleAttributeSequence。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

startIndex

public int startIndex
文本序列的起始索引

endIndex

public int endIndex
文本序列的结束索引

attributes

public AttributeSet attributes
文本属性

构造方法详细信息

AccessibleAttributeSequence

public AccessibleAttributeSequence(int start,
                                   int end,
                                   AttributeSet attr)
构造带有给定参数的 AccessibleAttributeSequence。

参数：
start - 文本区域开始处的索引
end - 文本区域结束处的索引
attr - 此文本区域所共享的 AttributeSet
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleBundle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleBundle

java.lang.Object
    继承者  javax.accessibility.AccessibleBundle
直接已知子类：
AccessibleRelation, AccessibleRole, AccessibleState
public abstract class AccessibleBundle
extends Object

用于维护强类型枚举的基类。此类是 AccessibleState 和 AccessibleRole 的超类。

toDisplayString 方法允许从此类中定义的键的预定义 ResourceBundle 获取与语言环境无关的键的本地化字符串。此本地化字符串是可读的。

另请参见：
AccessibleRole, AccessibleState

字段摘要
protected  String key
与语言环境无关的状态名称。
构造方法摘要
AccessibleBundle()
方法摘要
String | toDisplayString() 获取使用默认语言环境来描述键的本地化字符串。
String | toDisplayString(Locale locale) 获取本地化字符串形式的键。
protected String | toDisplayString(String resourceBundleName, Locale locale) 获取本地化字符串形式的键。
String | toString() 获取使用默认语言环境来描述键的本地化字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

key

protected String key
与语言环境无关的状态名称。这是一个计划的名称，它不是可读的。

另请参见：
toDisplayString(java.lang.String, java.util.Locale)
构造方法详细信息

AccessibleBundle

public AccessibleBundle()
方法详细信息

toDisplayString

protected String toDisplayString(String resourceBundleName,
                                 Locale locale)
获取本地化字符串形式的键。如果无法找到键的本地化字符串，则将返回存储在任务中的与语言环境无关的键。此方法仅供子类使用，以便它们能够指定其自己的包含键的本地化字符串的资源包。

参数：
resourceBundleName - 要用于查找的资源包名称
locale - 要获取本地化字符串的语言环境
返回：
键的本地化 String。

toDisplayString

public String toDisplayString(Locale locale)
获取本地化字符串形式的键。如果无法找到键的本地化字符串，则将返回存储在任务中的与语言环境无关的键。

参数：
locale - 要获取本地化字符串的语言环境
返回：
键的本地化 String。

toDisplayString

public String toDisplayString()
获取使用默认语言环境来描述键的本地化字符串。

返回：
描述默认语言环境的键的本地化 String

toString

public String toString()
获取使用默认语言环境来描述键的本地化字符串。

覆盖：
类 Object 中的 toString
返回：
使用默认语言环境来描述键的本地化 String
另请参见：
toDisplayString(java.lang.String, java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleComponent

所有已知子接口：
AccessibleExtendedComponent
所有已知实现类：
AbstractButton.AccessibleAbstractButton, Applet.AccessibleApplet, Box.AccessibleBox, Box.Filler.AccessibleBoxFiller, Button.AccessibleAWTButton, Canvas.AccessibleAWTCanvas, CellRendererPane.AccessibleCellRendererPane, Checkbox.AccessibleAWTCheckbox, CheckboxMenuItem.AccessibleAWTCheckboxMenuItem, Choice.AccessibleAWTChoice, Component.AccessibleAWTComponent, Container.AccessibleAWTContainer, Dialog.AccessibleAWTDialog, Frame.AccessibleAWTFrame, JApplet.AccessibleJApplet, JButton.AccessibleJButton, JCheckBox.AccessibleJCheckBox, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JColorChooser.AccessibleJColorChooser, JComboBox.AccessibleJComboBox, JComponent.AccessibleJComponent, JDesktopPane.AccessibleJDesktopPane, JDialog.AccessibleJDialog, JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JFileChooser.AccessibleJFileChooser, JFrame.AccessibleJFrame, JInternalFrame.AccessibleJInternalFrame, JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon, JLabel.AccessibleJLabel, JLayeredPane.AccessibleJLayeredPane, JList.AccessibleJList, JList.AccessibleJList.AccessibleJListChild, JMenu.AccessibleJMenu, JMenuBar.AccessibleJMenuBar, JMenuItem.AccessibleJMenuItem, JOptionPane.AccessibleJOptionPane, JPanel.AccessibleJPanel, JPasswordField.AccessibleJPasswordField, JPopupMenu.AccessibleJPopupMenu, JProgressBar.AccessibleJProgressBar, JRadioButton.AccessibleJRadioButton, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JRootPane.AccessibleJRootPane, JScrollBar.AccessibleJScrollBar, JScrollPane.AccessibleJScrollPane, JSeparator.AccessibleJSeparator, JSlider.AccessibleJSlider, JSpinner.AccessibleJSpinner, JSplitPane.AccessibleJSplitPane, JTabbedPane.AccessibleJTabbedPane, JTable.AccessibleJTable, JTable.AccessibleJTable.AccessibleJTableCell, JTableHeader.AccessibleJTableHeader, JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField, JToggleButton.AccessibleJToggleButton, JToolBar.AccessibleJToolBar, JToolTip.AccessibleJToolTip, JTree.AccessibleJTree, JTree.AccessibleJTree.AccessibleJTreeNode, JViewport.AccessibleJViewport, JWindow.AccessibleJWindow, Label.AccessibleAWTLabel, List.AccessibleAWTList, List.AccessibleAWTList.AccessibleAWTListChild, Menu.AccessibleAWTMenu, MenuBar.AccessibleAWTMenuBar, MenuComponent.AccessibleAWTMenuComponent, MenuItem.AccessibleAWTMenuItem, Panel.AccessibleAWTPanel, PopupMenu.AccessibleAWTPopupMenu, Scrollbar.AccessibleAWTScrollBar, ScrollPane.AccessibleAWTScrollPane, TextArea.AccessibleAWTTextArea, TextComponent.AccessibleAWTTextComponent, TextField.AccessibleAWTTextField, Window.AccessibleAWTWindow
public interface AccessibleComponent

屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。此接口为辅助技术提供了标准机制，以确定和设置对象的图形表示形式。应用程序通过先获取某个对象的 AccessibleContext，然后调用 AccessibleContext.getAccessibleComponent() 方法，能够确定该对象是否支持 AccessibleComponent 接口。如果返回值不为 null，则该对象支持此接口。

另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleComponent()

方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
boolean | contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Point | getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否已启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定此对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | requestFocus() 请求此对象的焦点。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor cursor) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。

方法详细信息

getBackground

Color getBackground()
获取此对象的背景色。

返回：
如果支持的话，返回对象的背景色；否则返回 null
另请参见：
setBackground(java.awt.Color)

setBackground

void setBackground(Color c)
设置此对象的背景色。

参数：
c - 新的背景 Color
另请参见：
setBackground(java.awt.Color)

getForeground

Color getForeground()
获取此对象的前景色。

返回：
如果支持的话，返回对象的前景色；否则返回 null
另请参见：
setForeground(java.awt.Color)

setForeground

void setForeground(Color c)
设置此对象的前景色。

参数：
c - 新的前景 Color
另请参见：
getForeground()

getCursor

Cursor getCursor()
获取此对象的 Cursor。

返回：
如果支持的话，返回对象的 Cursor；否则返回 null
另请参见：
setCursor(java.awt.Cursor)

setCursor

void setCursor(Cursor cursor)
设置此对象的 Cursor。

参数：
cursor - 对象的新 Cursor
另请参见：
getCursor()

getFont

Font getFont()
获取此对象的 Font。

返回：
如果支持的话，返回对象的 Font；否则返回 null
另请参见：
setFont(java.awt.Font)

setFont

void setFont(Font f)
设置此对象的 Font。

参数：
f - 对象的新 Font
另请参见：
getFont()

getFontMetrics

FontMetrics getFontMetrics(Font f)
获取此对象的 FontMetrics。

参数：
f - Font
返回：
如果支持的话，返回对象的 FontMetrics；否则返回 null
另请参见：
getFont()

isEnabled

boolean isEnabled()
确定是否已启用该对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

void setEnabled(boolean b)
设置对象的启用状态。

参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
isEnabled()

isVisible

boolean isVisible()
确定此对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

void setVisible(boolean b)
设置对象的可见状态。

参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
isVisible()

isShowing

boolean isShowing()
确定是否正显示对象。通过检查该对象和祖先的可见性可确定这一点。注：即使该对象被另一对象屏蔽（例如，它是下拉菜单的下级），仍然返回 true。

返回：
如果正在显示对象，则返回 true；否则，返回 false

contains

boolean contains(Point p)
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。

参数：
p - 相对于对象的坐标系统的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
getBounds()

getLocationOnScreen

Point getLocationOnScreen()
返回对象在屏幕上的位置。

返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
getBounds(), getLocation()

getLocation

Point getLocation()
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

返回：
Point 的实例，该点表示屏幕坐标空间中对象边界的左上角 ；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
getBounds(), getLocationOnScreen()

setLocation

void setLocation(Point p)
设置对象相对于父级的位置。

参数：
p - 左上角的新位置
另请参见：
getLocation()

getBounds

Rectangle getBounds()
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
contains(java.awt.Point)

setBounds

void setBounds(Rectangle r)
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

参数：
r - 指示此组件边界的矩形
另请参见：
getBounds()

getSize

Dimension getSize()
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
setSize(java.awt.Dimension)

setSize

void setSize(Dimension d)
调整此对象，使其具有高度和宽度。

参数：
d - 指定对象新大小的维数。
另请参见：
getSize()

getAccessibleAt

Accessible getAccessibleAt(Point p)
返回本地坐标 Point 包含的可访问子级（如果存在）。

参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null

isFocusTraversable

boolean isFocusTraversable()
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

void requestFocus()
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

另请参见：
isFocusTraversable()

addFocusListener

void addFocusListener(FocusListener l)
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

参数：
l - 焦点侦听器
另请参见：
removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

void removeFocusListener(FocusListener l)
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

参数：
l - 焦点侦听器
另请参见：
addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleContext

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
直接已知子类：
Component.AccessibleAWTComponent, ImageIcon.AccessibleImageIcon, JList.AccessibleJList.AccessibleJListChild, JTable.AccessibleJTable.AccessibleJTableCell, JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry, JTree.AccessibleJTree.AccessibleJTreeNode, MenuComponent.AccessibleAWTMenuComponent, ProgressMonitor.AccessibleProgressMonitor
public abstract class AccessibleContext
extends Object

AccessibleContext 表示所有可访问对象返回的最少信息。此信息包括对象的可访问名称、描述、职责和状态，以及关于其父对象和子对象的信息。AccessibleContext 还包含用于获取更多关于组件的特定可访问信息的方法。如果组件支持这些方法，则它们将返回实现以下一个或多个接口的对象：

  • AccessibleAction － 可以执行一个或多个动作的对象。此接口为辅助技术提供了标准机制，以确定这些动作并通知对象执行它们。任何可以操作的对象都应支持此接口。
  • AccessibleComponent － 具有图形表示形式的对象。此接口为辅助技术提供了标准机制，以确定和设置对象的图形表示形式。屏幕上呈现的任何对象都应该支持此接口。
  • AccessibleSelection － 允许选择其子对象的对象。此接口为辅助技术提供了标准机制，以确定当前选定的子对象，并修改选择设置。任何具有可选子对象的对象都应支持此接口。
  • AccessibleText － 在显示器上显示可编辑文本信息的对象。此接口为辅助技术提供了标准机制，以通过文本的内容、属性和空间位置来访问该文本。任何包含可编辑文本的对象都应支持此接口。
  • AccessibleValue － 支持数字值的对象。此接口为辅助技术提供了标准机制，以确定和设置对象的当前值，以及最小值和最大值。任何支持数字值的对象都应支持此接口。

字段摘要
static String | ACCESSIBLE_ACTION_PROPERTY 用于指示支持的动作集已更改的常量。
static String | ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY 用于确定组件的活动子级已更改的常量。
static String | ACCESSIBLE_CARET_PROPERTY 用于确定 accessibleText 插入符已更改的常量。
static String | ACCESSIBLE_CHILD_PROPERTY 用于确定何时向对象添加或从对象移除 Accessible 子级的常量。
static String | ACCESSIBLE_COMPONENT_BOUNDS_CHANGED 指示组件边界已更改的 PropertyChangeEvent。
static String | ACCESSIBLE_DESCRIPTION_PROPERTY 用于确定 accessibleDescription 属性已更改的常量。
static String | ACCESSIBLE_HYPERTEXT_OFFSET 用于指示超文本元素已收到焦点的常量。
static String | ACCESSIBLE_INVALIDATE_CHILDREN 指示某个组件（例如树或文本）的子级已发生重要更改的 PropertyChangeEvent。
static String | ACCESSIBLE_NAME_PROPERTY 用于确定 accessibleName 属性已更改的常量。
static String | ACCESSIBLE_SELECTION_PROPERTY 用于确定 accessibleSelection 已更改的常量。
static String | ACCESSIBLE_STATE_PROPERTY 用于确定 accessibleStateSet 属性已更改的常量。
static String | ACCESSIBLE_TABLE_CAPTION_CHANGED 用于指示表标题已更改的常量。
static String | ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED 用于指示列描述已更改的常量。
static String | ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED 用于指示列标题已更改的常量。
static String | ACCESSIBLE_TABLE_MODEL_CHANGED 用于指示表数据已更改的常量。
static String | ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED 用于指示行描述已更改的常量。
static String | ACCESSIBLE_TABLE_ROW_HEADER_CHANGED 用于指示行标题已更改的常量。
static String | ACCESSIBLE_TABLE_SUMMARY_CHANGED 用于指示表摘要已更改的常量。
static String | ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED 指示文本属性已更改的 PropertyChangeEvent。
static String | ACCESSIBLE_TEXT_PROPERTY 指示文本已更改的 PropertyChangeEvent。
static String | ACCESSIBLE_VALUE_PROPERTY 用于确定 accessibleValue 属性已更改的常量。
static String | ACCESSIBLE_VISIBLE_DATA_PROPERTY 用于确定对象的可见外观已更改的常量。
protected String | accessibleDescription 包含对象描述的本地化 String。
protected String | accessibleName 包含对象名称的本地化 String。
protected Accessible | accessibleParent 此对象的可访问父级。
构造方法摘要
AccessibleContext()
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 将 PropertyChangeListener 添加到侦听器列表。
void | firePropertyChange(String propertyName, Object oldValue, Object newValue) 对报告 bound 属性更改的支持。
AccessibleAction | getAccessibleAction() 获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
abstract Accessible | getAccessibleChild(int i) 返回该对象的指定 Accessible 子级。
abstract int | getAccessibleChildrenCount() 返回该对象的可访问子级数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
String | getAccessibleDescription() 获取此对象的 accessibleDescription 属性。
AccessibleEditableText | getAccessibleEditableText() 获取与在显示器上显示可编辑文本的此对象关联的 AccessibleEditableText。
AccessibleIcon[] | getAccessibleIcon() 获取与此对象关联的具有一个或多个相关图标的 AccessibleIcons
abstract int | getAccessibleIndexInParent() 获取此对象在其可访问父级中的基于零的索引。
String | getAccessibleName() 获取此对象的 accessibleName 属性。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRelationSet | getAccessibleRelationSet() 获取与某个对象关联的 AccessibleRelationSet
abstract AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。
abstract AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集合。
AccessibleTable | getAccessibleTable() 获取与某个对象关联的 AccessibleTable
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的支持 Numerical 值的 AccessibleValue。
abstract Locale | getLocale() 获取该组件的语言环境。
void | removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除 PropertyChangeListener。
void | setAccessibleDescription(String s) 设置此对象的可访问描述。
void | setAccessibleName(String s) 设置此对象的可访问的本地化名称。
void | setAccessibleParent(Accessible a) 设置此对象的 Accessible 父对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ACCESSIBLE_NAME_PROPERTY

public static final String ACCESSIBLE_NAME_PROPERTY
用于确定 accessibleName 属性已更改的常量。PropertyChangeEvent 中原有的值将为原有的 accessibleName，新值将为新的 accessibleName。

另请参见：
getAccessibleName(), addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_DESCRIPTION_PROPERTY

public static final String ACCESSIBLE_DESCRIPTION_PROPERTY
用于确定 accessibleDescription 属性已更改的常量。PropertyChangeEvent 中原有的值将为原有的 accessibleDescription，新值将为新的 accessibleDescription。

另请参见：
getAccessibleDescription(), addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_STATE_PROPERTY

public static final String ACCESSIBLE_STATE_PROPERTY
用于确定 accessibleStateSet 属性已更改的常量。accessibleStateSet 中原有值将为原有的 AccessibleState，新值将为新的 AccessibleState。例如，如果支持垂直和水平状态的某组件从垂直方向更改为水平方向，则原有值将为 AccessibleState.VERTICAL，新值将为 AccessibleState.HORIZONTAL。请注意这两个值也可以为 null。例如，当某组件从启用状态更改为禁用状态，则原有值将为 AccessibleState.ENABLED，新值将为 null。

另请参见：
getAccessibleStateSet(), AccessibleState, AccessibleStateSet, addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_VALUE_PROPERTY

public static final String ACCESSIBLE_VALUE_PROPERTY
用于确定 accessibleValue 属性已更改的常量。PropertyChangeEvent 中原有的值将为表示原有值的 Number，新值将为表示新值的 Number

另请参见：
getAccessibleValue(), addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_SELECTION_PROPERTY

public static final String ACCESSIBLE_SELECTION_PROPERTY
用于确定 accessibleSelection 已更改的常量。当前保留 PropertyChangeEvent 中的原有值和新值，供将来使用。

另请参见：
getAccessibleSelection(), addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_CARET_PROPERTY

public static final String ACCESSIBLE_CARET_PROPERTY
用于确定 accessibleText 插入符已更改的常量。PropertyChangeEvent 中的原有值将为表示原有插入符位置的整数，新值将为表示新的/当前插入符位置的整数。

另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_VISIBLE_DATA_PROPERTY

public static final String ACCESSIBLE_VISIBLE_DATA_PROPERTY
用于确定对象的可见外观已更改的常量。当前保留 PropertyChangeEvent 中的原有值和新值，供将来使用。

另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_CHILD_PROPERTY

public static final String ACCESSIBLE_CHILD_PROPERTY
用于确定何时向对象添加或从对象移除 Accessible 子级的常量。如果要添加 Accessible 子级，则原有值将为 null，新值将为 Accessible 子级。如果要移除 Accessible 子级，则原有值将为 Accessible 子级，新值将为 null。

另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY

public static final String ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY
用于确定组件的活动子级已更改的常量。活动的子级用于列表、树和表这样的对象，这些对象可能有临时子级。当活动子级已更改时，属性更改事件的原有值将为表示以前活动子级的 Accessible，新值将为表示当前活动子级的 Accessible。

另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

ACCESSIBLE_TABLE_CAPTION_CHANGED

public static final String ACCESSIBLE_TABLE_CAPTION_CHANGED
用于指示表标题已更改的常量。PropertyChangeEvent 中的原有值将为表示以前表标题的 Accessible，新值将为表示新表标题的 Accessible。

另请参见：
Accessible, AccessibleTable, 常量字段值

ACCESSIBLE_TABLE_SUMMARY_CHANGED

public static final String ACCESSIBLE_TABLE_SUMMARY_CHANGED
用于指示表摘要已更改的常量。PropertyChangeEvent 中的原有值将为表示以前表摘要的 Accessible，新值将为表示新表摘要的 Accessible。

另请参见：
Accessible, AccessibleTable, 常量字段值

ACCESSIBLE_TABLE_MODEL_CHANGED

public static final String ACCESSIBLE_TABLE_MODEL_CHANGED
用于指示表数据已更改的常量。PropertyChangeEvent 中的原有值将为 null，新值将为表示表更改的 AccessibleTableModelChange。

另请参见：
AccessibleTable, AccessibleTableModelChange, 常量字段值

ACCESSIBLE_TABLE_ROW_HEADER_CHANGED

public static final String ACCESSIBLE_TABLE_ROW_HEADER_CHANGED
用于指示行标题已更改的常量。PropertyChangeEvent 中的原有值将为 null，新值将为表示标题更改的 AccessibleTableModelChange。

另请参见：
AccessibleTable, AccessibleTableModelChange, 常量字段值

ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED

public static final String ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED
用于指示行描述已更改的常量。PropertyChangeEvent 中的原有值将为 null，新值将为表示行索引的 Integer。

另请参见：
AccessibleTable, 常量字段值

ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED

public static final String ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED
用于指示列标题已更改的常量。PropertyChangeEvent 中的原有值将为 null，新值将为表示标题更改的 AccessibleTableModelChange。

另请参见：
AccessibleTable, AccessibleTableModelChange, 常量字段值

ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED

public static final String ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED
用于指示列描述已更改的常量。PropertyChangeEvent 中的原有值将为 null，新值将为表示列索引的 Integer。

另请参见：
AccessibleTable, 常量字段值

ACCESSIBLE_ACTION_PROPERTY

public static final String ACCESSIBLE_ACTION_PROPERTY
用于指示支持的动作集已更改的常量。PropertyChangeEvent 中的原有值将为表示所支持的原有动作数的 Integer，新值将为表示所支持的新动作数的 Integer。

另请参见：
AccessibleAction, 常量字段值

ACCESSIBLE_HYPERTEXT_OFFSET

public static final String ACCESSIBLE_HYPERTEXT_OFFSET
用于指示超文本元素已收到焦点的常量。PropertyChangeEvent 中的原有值将为表示以前具有焦点的元素在文档中的起始索引的 Integer，新值将为表示当前具有焦点的元素在文档中的起始索引的 Integer。值 -1 指示该元素现在不具有焦点或以前不具有焦点。

另请参见：
AccessibleHyperlink, 常量字段值

ACCESSIBLE_TEXT_PROPERTY

public static final String ACCESSIBLE_TEXT_PROPERTY
指示文本已更改的 PropertyChangeEvent。
对于文本插入来说，oldValue 为 null，newValue 为指定所插入文本的 AccessibleTextSequence。
对于文本删除来说，oldValue 为指定所删除文本的 AccessibleTextSequence，newValue 为 null。
对于文本替换来说，oldValue 为指定原有文本的 AccessibleTextSequence，newValue 为指定新文本的 AccessibleTextSequence。

另请参见：
getAccessibleText(), addPropertyChangeListener(java.beans.PropertyChangeListener), #AccessibleText.AccessibleTextSequence, 常量字段值

ACCESSIBLE_INVALIDATE_CHILDREN

public static final String ACCESSIBLE_INVALIDATE_CHILDREN
指示某个组件（例如树或文本）的子级已发生重要更改的 PropertyChangeEvent。此更改通知事件侦听器，需要重新获取子组件的状态。oldValue 为 null，newValue 为其子级已无效的组件。

从以下版本开始：
1.5
另请参见：
getAccessibleText(), addPropertyChangeListener(java.beans.PropertyChangeListener), #AccessibleText.AccessibleTextSequence, 常量字段值

ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED

public static final String ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED
指示文本属性已更改的 PropertyChangeEvent。
对于属性插入来说，oldValue 为 null，newValue 为指定所插入属性的 AccessibleAttributeSequence。
对于属性删除来说，oldValue 为指定所删除属性的 AccessibleAttributeSequence，newValue 为 null。
对于属性替换来说，oldValue 为指定原有属性的 AccessibleAttributeSequence，newValue 为指定新属性的 AccessibleAttributeSequence。

从以下版本开始：
1.5
另请参见：
getAccessibleText(), addPropertyChangeListener(java.beans.PropertyChangeListener), #AccessibleText.AccessibleAttributeSequence, 常量字段值

ACCESSIBLE_COMPONENT_BOUNDS_CHANGED

public static final String ACCESSIBLE_COMPONENT_BOUNDS_CHANGED
指示组件边界已更改的 PropertyChangeEvent。oldValue 为原有组件的边界，newValue 为新组件的界限。

从以下版本开始：
1.5
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener), 常量字段值

accessibleParent

protected Accessible accessibleParent
此对象的可访问父级。

另请参见：
getAccessibleParent(), setAccessibleParent(javax.accessibility.Accessible)

accessibleName

protected String accessibleName
包含对象名称的本地化 String。

另请参见：
getAccessibleName(), setAccessibleName(java.lang.String)

accessibleDescription

protected String accessibleDescription
包含对象描述的本地化 String。

另请参见：
getAccessibleDescription(), setAccessibleDescription(java.lang.String)
构造方法详细信息

AccessibleContext

public AccessibleContext()
方法详细信息

getAccessibleName

public String getAccessibleName()
获取此对象的 accessibleName 属性。对象的 accessibleName 属性是指定该对象功能的本地化 String。例如，标签和按钮的 accessibleName 属性可以是标签或按钮本身的文本。对于不显示其名称的对象，仍应设置 accessibleName。例如，对于用于输入城市名称的文本字段，在 en_US 语言环境下，accessibleName 可以为 "city"。

返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
设置此对象的可访问的本地化名称。更改名称将导致激发 ACCESSIBLE_NAME_PROPERTY 属性的 PropertyChangeEvent。

参数：
s - 对象的新本地化名称。
另请参见：
getAccessibleName(), addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的 accessibleDescription 属性。此对象的 accessibleDescription 属性是描述该对象功能的本地化短语。例如，对于 "Cancel" 按钮，accessibleDescription 可以是 "Ignore changes and close dialog box"（忽略更改并关闭对话框）。

返回：
该对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
设置此对象的可访问描述。更改名称将导致激发 ACCESSIBLE_DESCRIPTION_PROPERTY 属性的 PropertyChangeEvent。

参数：
s - 此对象的新的本地化描述
另请参见：
setAccessibleName(java.lang.String), addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public abstract AccessibleRole getAccessibleRole()
获取此对象的职责。对象的职责是此对象的类的一般功能或用途。例如，push 按钮的职责是 AccessibleRole.PUSH_BUTTON。AccessibleRole 中提供了一些职责，组件开发人员可以从一组预定义职责中进行选择。这就使辅助技术能为各种交互的组件子类（例如，对所有充当按钮的组件使用 AccessibleRole.PUSH_BUTTON）以及区分行为各异的子类（例如，复选框 AccessibleRole.CHECK_BOX 和单选框 AccessibleRole.RADIO_BUTTON）提供一致的接口。

注意，AccessibleRole 类也是可扩展的，因此如果预定义的职责集合不充分，则自定义组件的开发人员可以定义他们自己的 AccessibleRole。

返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public abstract AccessibleStateSet getAccessibleStateSet()
获取此对象的状态集合。对象的 AccessibleStateSet 由一组唯一的 AccessibleState 组成。对象的 AccessibleStateSet 中的更改将导致激发 ACCESSIBLE_STATE_PROPERTY 属性的 PropertyChangeEvent。

返回：
包含对象的当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。

返回：
此对象的 Accessible 父对象；如果此对象没有 Accessible 父对象，则返回 null

setAccessibleParent

public void setAccessibleParent(Accessible a)
设置此对象的 Accessible 父对象。这意味着此方法仅用于以下情形：即不应将实际组件的父级视为组件的可访问父级，并且此方法只应由可访问子级的父级调用。

参数：
a - - 要设置为父级的 Accessible

getAccessibleIndexInParent

public abstract int getAccessibleIndexInParent()
获取此对象在其可访问父级中的基于零的索引。

返回：
返回此对象在父级中从零开始的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
getAccessibleParent(),
getAccessibleChildrenCount(),
getAccessibleChild(int)

getAccessibleChildrenCount

public abstract int getAccessibleChildrenCount()
返回该对象的可访问子级数。

返回：
该对象的可访问子级数。

getAccessibleChild

public abstract Accessible getAccessibleChild(int i)
返回该对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从零开始的，因此 Accessible 对象的第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

参数：
i - 子级从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
getAccessibleChildrenCount()

getLocale

public abstract Locale getLocale()
                          throws IllegalComponentStateException
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

返回：
此组件的语言环境。如果此组件没有语言环境，则返回其父级的语言环境。
抛出：
IllegalComponentStateException - 如果该 Component 没有自己的语言环境，并且尚未被添加到可以从包含父级确定其语言环境的包含层次结构中。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。此侦听器为所有 Accessible 属性注册，并且将在这些属性发生更改时调用。

参数：
listener - 要添加的 PropertyChangeListener
另请参见：
ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。

参数：
listener - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

返回：
如果受对象支持，则返回 AccessibleAction；否则返回 null
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。

返回：
如果受对象支持，则返回 AccessibleComponent；否则返回 null
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。

返回：
如果受对象支持，则返回 AccessibleSelection；否则返回 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
获取与在显示器上显示文本的此对象关联的 AccessibleText。

返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getAccessibleEditableText

public AccessibleEditableText getAccessibleEditableText()
获取与在显示器上显示可编辑文本的此对象关联的 AccessibleEditableText。

返回：
如果受对象支持，则返回 AccessibleEditableText；否则返回 null
从以下版本开始：
1.4
另请参见：
AccessibleEditableText

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的支持 Numerical 值的 AccessibleValue。

返回：
如果受对象支持，则返回 AccessibleValue；否则返回 null
另请参见：
AccessibleValue

getAccessibleIcon

public AccessibleIcon[] getAccessibleIcon()
获取与此对象关联的具有一个或多个相关图标的 AccessibleIcons

返回：
如果受对象支持，则返回一个 AccessibleIcon 数组；否则返回 null
从以下版本开始：
1.3
另请参见：
AccessibleIcon

getAccessibleRelationSet

public AccessibleRelationSet getAccessibleRelationSet()
获取与某个对象关联的 AccessibleRelationSet

返回：
如果受对象支持，则返回 AccessibleRelationSet；否则返回 null
从以下版本开始：
1.3
另请参见：
AccessibleRelationSet

getAccessibleTable

public AccessibleTable getAccessibleTable()
获取与某个对象关联的 AccessibleTable

返回：
如果受对象支持，则返回 AccessibleTable；否则返回 null
从以下版本开始：
1.3
另请参见：
AccessibleTable

firePropertyChange

public void firePropertyChange(String propertyName,
                               Object oldValue,
                               Object newValue)
对报告 bound 属性更改的支持。如果 oldValue 和 newValue 不相等，且 PropertyChangeEvent 侦听器列表不为空，则对每个侦听器激发一个 PropertyChange 事件。通常，这由 Accessible 对象自己使用，而不应由应用程序调用。

参数：
propertyName - 已更改的属性的计划名称。
oldValue - 属性的原有值。
newValue - 属性的新值。
另请参见：
PropertyChangeSupport, addPropertyChangeListener(java.beans.PropertyChangeListener), removePropertyChangeListener(java.beans.PropertyChangeListener), ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleEditableText (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleEditableText

所有超级接口：
AccessibleText
所有已知实现类：
JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JPasswordField.AccessibleJPasswordField, JSpinner.AccessibleJSpinner, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField
public interface AccessibleEditableText
extends AccessibleText

在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。此接口与 AccessibleText 接口一起为辅助技术提供了标准机制，以通过文本的内容、属性和空间位置来访问该文本。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleEditableText() 方法，能够确定该对象是否支持 AccessibleEditableText 接口。如果返回值不为 null，则该对象支持此接口。

从以下版本开始：
1.4
另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleText(), AccessibleContext.getAccessibleEditableText()

字段摘要
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
方法摘要
void | cut(int startIndex, int endIndex) 将两个索引之间的文本剪切到系统剪贴板中。
void | delete(int startIndex, int endIndex) 删除两个索引之间的文本
String | getTextRange(int startIndex, int endIndex) 返回两个索引之间的文本字符串。
void | insertTextAtIndex(int index, String s) 在给定索引处插入指定的字符串。
void | paste(int startIndex) 将系统剪贴板中的文本粘贴到文本的指定索引开始处。
void | replaceText(int startIndex, int endIndex, String s) 用指定的字符串替换两个索引之间的文本。
void | selectText(int startIndex, int endIndex) 选中两个索引之间的文本
void | setAttributes(int startIndex, int endIndex, AttributeSet as) 设置两个索引之间文本的属性。
void | setTextContents(String s) 将文本内容设置为指定字符串。
从接口 javax.accessibility.AccessibleText 继承的方法
getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart

方法详细信息

setTextContents

void setTextContents(String s)
将文本内容设置为指定字符串。

参数：
s - 要设置文本内容的字符串

insertTextAtIndex

void insertTextAtIndex(int index,
                       String s)
在给定索引处插入指定的字符串。

参数：
index - 将要插入字符串的位置的文本索引
s - 要插入文本中的字符串

getTextRange

String getTextRange(int startIndex,
                    int endIndex)
返回两个索引之间的文本字符串。

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引
返回：
两个索引之间的文本字符串

delete

void delete(int startIndex,
            int endIndex)
删除两个索引之间的文本

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引

cut

void cut(int startIndex,
         int endIndex)
将两个索引之间的文本剪切到系统剪贴板中。

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引

paste

void paste(int startIndex)
将系统剪贴板中的文本粘贴到文本的指定索引开始处。

参数：
startIndex - 文本中的起始索引

replaceText

void replaceText(int startIndex,
                 int endIndex,
                 String s)
用指定的字符串替换两个索引之间的文本。

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引

selectText

void selectText(int startIndex,
                int endIndex)
选中两个索引之间的文本

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引

setAttributes

void setAttributes(int startIndex,
                   int endIndex,
                   AttributeSet as)
设置两个索引之间文本的属性。

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引
as - 属性集
另请参见：
AttributeSet
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleExtendedComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleExtendedComponent

所有超级接口：
AccessibleComponent
所有已知实现类：
AbstractButton.AccessibleAbstractButton, JButton.AccessibleJButton, JCheckBox.AccessibleJCheckBox, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JColorChooser.AccessibleJColorChooser, JComboBox.AccessibleJComboBox, JComponent.AccessibleJComponent, JDesktopPane.AccessibleJDesktopPane, JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JFileChooser.AccessibleJFileChooser, JInternalFrame.AccessibleJInternalFrame, JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon, JLabel.AccessibleJLabel, JLayeredPane.AccessibleJLayeredPane, JList.AccessibleJList, JMenu.AccessibleJMenu, JMenuBar.AccessibleJMenuBar, JMenuItem.AccessibleJMenuItem, JOptionPane.AccessibleJOptionPane, JPanel.AccessibleJPanel, JPasswordField.AccessibleJPasswordField, JPopupMenu.AccessibleJPopupMenu, JProgressBar.AccessibleJProgressBar, JRadioButton.AccessibleJRadioButton, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JRootPane.AccessibleJRootPane, JScrollBar.AccessibleJScrollBar, JScrollPane.AccessibleJScrollPane, JSeparator.AccessibleJSeparator, JSlider.AccessibleJSlider, JSpinner.AccessibleJSpinner, JSplitPane.AccessibleJSplitPane, JTabbedPane.AccessibleJTabbedPane, JTable.AccessibleJTable, JTableHeader.AccessibleJTableHeader, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField, JToggleButton.AccessibleJToggleButton, JToolBar.AccessibleJToolBar, JToolTip.AccessibleJToolTip, JTree.AccessibleJTree, JViewport.AccessibleJViewport
public interface AccessibleExtendedComponent
extends AccessibleComponent

屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。此接口为辅助技术提供了标准机制，以确定和扩展对象的图形表示形式。应用程序通过先获取某个对象的 AccessibleContext，然后调用 AccessibleContext.getAccessibleComponent() 方法，能够确定该对象是否支持 AccessibleExtendedComponent 接口。如果返回值不为 null，且返回值的类型为 AccessibleExtendedComponent，则该对象支持此接口。

从以下版本开始：
1.4
另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleComponent()

方法摘要
AccessibleKeyBinding | getAccessibleKeyBinding() 返回与此对象关联的键绑定。
String | getTitledBorderText() 返回有标题的边框文本
String | getToolTipText() 返回工具提示文本
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

方法详细信息

getToolTipText

String getToolTipText()
返回工具提示文本

返回：
对象的工具提示文本（如果支持）；否则返回 null

getTitledBorderText

String getTitledBorderText()
返回有标题的边框文本

返回：
对象的有标题边框文本（如果支持）；否则返回 null

getAccessibleKeyBinding

AccessibleKeyBinding getAccessibleKeyBinding()
返回与此对象关联的键绑定。

返回：
对象的键绑定（如果支持）；否则返回 null
另请参见：
AccessibleKeyBinding
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleExtendedTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleExtendedTable

所有超级接口：
AccessibleTable
所有已知实现类：
JTable.AccessibleJTable
public interface AccessibleExtendedTable
extends AccessibleTable

AccessibleExtendedTable 类提供了有关以二维表的格式呈现数据的用户界面组件的扩展信息。应用程序通过先获取某个对象的 AccessibleContext，然后调用 AccessibleContext.getAccessibleTable() 方法，能够确定该对象是否支持 AccessibleExtendedTable 接口。如果返回值不为 null，且返回值的类型为 AccessibleExtendedTable，则该对象支持此接口。

从以下版本开始：
1.4

方法摘要
int | getAccessibleColumn(int index) 返回表中一个索引的列号。
int | getAccessibleIndex(int r, int c)
int | getAccessibleRow(int index) 返回表中一个索引的行号。
从接口 javax.accessibility.AccessibleTable 继承的方法
getAccessibleAt, getAccessibleCaption, getAccessibleColumnCount, getAccessibleColumnDescription, getAccessibleColumnExtentAt, getAccessibleColumnHeader, getAccessibleRowCount, getAccessibleRowDescription, getAccessibleRowExtentAt, getAccessibleRowHeader, getAccessibleSummary, getSelectedAccessibleColumns, getSelectedAccessibleRows, isAccessibleColumnSelected, isAccessibleRowSelected, isAccessibleSelected, setAccessibleCaption, setAccessibleColumnDescription, setAccessibleColumnHeader, setAccessibleRowDescription, setAccessibleRowHeader, setAccessibleSummary

方法详细信息

getAccessibleRow

int getAccessibleRow(int index)
返回表中一个索引的行号。

参数：
index - 表中基于零的索引。行索引是表的单元格距离 row == 0 和 column == 0 的偏移量。
返回：
表的基于零的行（如果存在）；否则返回 -1。

getAccessibleColumn

int getAccessibleColumn(int index)
返回表中一个索引的列号。

参数：
index - 表中基于零的索引。行索引是表的单元格距离 row == 0 和 column == 0 的偏移量。
返回：
表的基于零的列（如果存在）；否则返回 -1。

getAccessibleIndex

int getAccessibleIndex(int r,
                       int c)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleExtendedText (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleExtendedText

所有已知实现类：
JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JPasswordField.AccessibleJPasswordField, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField
public interface AccessibleExtendedText

AccessibleExtendedText 接口包含 AccessibleText 接口所未提供的其他方法 应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleExtendedText 接口。如果返回值为 AccessibleExtendedText 的一个实例，则该对象支持此接口。

从以下版本开始：
1.5
另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleText(), AccessibleText.AccessibleTextChunk

字段摘要
static int | ATTRIBUTE_RUN 用于指示应被检索的文本部分是具有相同文本属性的连续文本的常量。
static int | LINE 用于指示应被检索的文本部分是单行文本的常量。
方法摘要
Rectangle | getTextBounds(int startIndex, int endIndex) 返回两个索引之间文本的边界矩形。
String | getTextRange(int startIndex, int endIndex) 返回两个索引之间的文本。
AccessibleTextSequence | getTextSequenceAfter(int part, int index) 返回给定索引后面的 AccessibleTextSequence。
AccessibleTextSequence | getTextSequenceAt(int part, int index) 返回给定索引处的 AccessibleTextSequence。
AccessibleTextSequence | getTextSequenceBefore(int part, int index) 返回给定索引前面的 AccessibleTextSequence。

字段详细信息

LINE

static final int LINE
用于指示应被检索的文本部分是单行文本的常量。

另请参见：
AccessibleText.getAtIndex(int, int),
AccessibleText.getAfterIndex(int, int),
AccessibleText.getBeforeIndex(int, int),
常量字段值

ATTRIBUTE_RUN

static final int ATTRIBUTE_RUN
用于指示应被检索的文本部分是具有相同文本属性的连续文本的常量。

另请参见：
AccessibleText.getAtIndex(int, int),
AccessibleText.getAfterIndex(int, int),
AccessibleText.getBeforeIndex(int, int),
常量字段值
方法详细信息

getTextRange

String getTextRange(int startIndex,
                    int endIndex)
返回两个索引之间的文本。

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引
返回：
如果索引有效，则返回文本字符串否则，返回 null。

getTextSequenceAt

AccessibleTextSequence getTextSequenceAt(int part,
                                         int index)
返回给定索引处的 AccessibleTextSequence。

参数：
part - 要检索的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果文本部分和索引有效，则返回指定该文本的 AccessibleTextSequence。否则，返回 null。
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

getTextSequenceAfter

AccessibleTextSequence getTextSequenceAfter(int part,
                                            int index)
返回给定索引后面的 AccessibleTextSequence。

参数：
part - 要检索的 code>CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果文本部分和索引有效，则返回指定该文本的 AccessibleTextSequence。否则，返回 null。
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

getTextSequenceBefore

AccessibleTextSequence getTextSequenceBefore(int part,
                                             int index)
返回给定索引前面的 AccessibleTextSequence。

参数：
part - 要检索的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果文本部分和索引有效，则返回指定该文本的 AccessibleTextSequence。否则，返回 null。
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

getTextBounds

Rectangle getTextBounds(int startIndex,
                        int endIndex)
返回两个索引之间文本的边界矩形。

参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引
返回：
如果索引有效，则返回文本的边界矩形。否则，返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleHyperlink (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleHyperlink

java.lang.Object
    继承者  javax.accessibility.AccessibleHyperlink
所有已实现的接口：
AccessibleAction
直接已知子类：
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
public abstract class AccessibleHyperlink
extends Object
implements AccessibleAction

Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。

另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleText, AccessibleContext.getAccessibleText()

字段摘要
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
AccessibleHyperlink()
方法摘要
abstract boolean | doAccessibleAction(int i) 对该对象执行指定的 Action
abstract Object | getAccessibleActionAnchor(int i) 返回表示适合于该链接的链接锚点的对象。
abstract int | getAccessibleActionCount() 返回此 Link 中可用的可访问动作数（如果有多个），不认为第一个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。
abstract String | getAccessibleActionDescription(int i) 返回此特定链接动作的 String 描述。
abstract Object | getAccessibleActionObject(int i) 返回表示适合于该链接的链接动作的对象。
abstract int | getEndIndex() 获得此链接结束处该超文本文档的索引
abstract int | getStartIndex() 获得此链接开始处该超文本文档的索引
abstract boolean | isValid() 因为与某个链接相关联的文档可能已更改，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）的信息。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AccessibleHyperlink

public AccessibleHyperlink()
方法详细信息

isValid

public abstract boolean isValid()
因为与某个链接相关联的文档可能已更改，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）的信息。

返回：
一个标志，指示此链接对于它所属的 AccessibleHypertext 而言是否仍然有效

getAccessibleActionCount

public abstract int getAccessibleActionCount()
返回此 Link 中可用的可访问动作数（如果有多个），不认为第一个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。通常，Link 中只有一个 AccessibleAction。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中从 0 开始的 Action 数

doAccessibleAction

public abstract boolean doAccessibleAction(int i)
对该对象执行指定的 Action

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 动作的从零开始的索引
返回：
如果执行了该动作，则返回 true；否则，返回 false。
另请参见：
getAccessibleActionCount()

getAccessibleActionDescription

public abstract String getAccessibleActionDescription(int i)
返回此特定链接动作的 String 描述。这应该是与定位文本关联的文本字符串，它应为锚文本。例如，从 HTML：<a HREF="http://www.sun.com/access">Accessibility</a> 此方法将返回 "Accessibility"。 类似地，从此 HTML：<a HREF="#top"><img src="top-hat.gif" alt="top hat"></a> 此方法将返回 "top hat"

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 动作的从零开始的索引
返回：
该动作的 String 描述
另请参见：
getAccessibleActionCount()

getAccessibleActionObject

public abstract Object getAccessibleActionObject(int i)
返回表示适合于该链接的链接动作的对象。例如，从 HTML：<a HREF="http://www.sun.com/access">Accessibility</a> 此方法将返回 java.net.URL("http://www.sun.com/access.html");

参数：
i - 动作的从零开始的的索引
返回：
表示超文本链接本身的 Object
另请参见：
getAccessibleActionCount()

getAccessibleActionAnchor

public abstract Object getAccessibleActionAnchor(int i)
返回表示适合于该链接的链接锚点的对象。例如，从 HTML：<a href="http://www.sun.com/access">Accessibility</a> 此方法将返回包含以下文本的 String："Accessibility"。 类似地，从此 HTML：<a HREF="#top"><img src="top-hat.gif" alt="top hat"></a> 中，此方法返回对象 ImageIcon("top-hat.gif", "top hat")。

参数：
i - 动作的从零开始的索引
返回：
表示该超文本锚点的 Object
另请参见：
getAccessibleActionCount()

getStartIndex

public abstract int getStartIndex()
获得此链接开始处该超文本文档的索引

返回：
链接开始处的索引

getEndIndex

public abstract int getEndIndex()
获得此链接结束处该超文本文档的索引

返回：
链接结束处的索引
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleHypertext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleHypertext

所有超级接口：
AccessibleText
所有已知实现类：
JEditorPane.JEditorPaneAccessibleHypertextSupport
public interface AccessibleHypertext
extends AccessibleText

AccessibleHypertext 类是在显示器上显示超文本信息的所有类的基类。此类为辅助技术提供了标准机制，以通过文本的内容、属性和空间位置来访问该文本。它还提供了操作超链接的标准机制。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleHypertext 接口。如果返回值是一个扩展了 AccessibleHypertext 的类，则该对象支持 AccessibleHypertext。

另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleText, AccessibleContext.getAccessibleText()

字段摘要
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
方法摘要
AccessibleHyperlink | getLink(int linkIndex) 返回此 Hypertext 文档中第 n 个链接。
int | getLinkCount() 返回此超文本文档中的链接数。
int | getLinkIndex(int charIndex) 返回超链接数组中与此字符索引关联的索引；如果没有与此索引关联的超链接，则返回 -1。
从接口 javax.accessibility.AccessibleText 继承的方法
getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart

方法详细信息

getLinkCount

int getLinkCount()
返回此超文本文档中的链接数。

返回：
此超文本文档中的链接数。

getLink

AccessibleHyperlink getLink(int linkIndex)
返回此 Hypertext 文档中第 n 个链接。

参数：
linkIndex - 在此 Hypertext 的链接中
返回：
Link 封装了第 n 个链接（或多个链接）的对象

getLinkIndex

int getLinkIndex(int charIndex)
返回超链接数组中与此字符索引关联的索引；如果没有与此索引关联的超链接，则返回 -1。

参数：
charIndex - 文本中的索引
返回：
超链接集合中此超文本文档的索引。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleIcon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleIcon

所有已知实现类：
ImageIcon.AccessibleImageIcon
public interface AccessibleIcon

任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon 接口。此接口为辅助技术提供了标准机制，以获取关于图标的描述信息。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext.getAccessibleIcon() 方法，能够确定该对象是否支持 AccessibleIcon 接口。如果返回值不为 null，则该对象支持此接口。

从以下版本开始：
1.3
另请参见：
Accessible, AccessibleContext

方法摘要
String | getAccessibleIconDescription() 获取此图标的描述。
int | getAccessibleIconHeight() 获取图标的高度。
int | getAccessibleIconWidth() 获取图标的宽度。
void | setAccessibleIconDescription(String description) 设置图标的描述。

方法详细信息

getAccessibleIconDescription

String getAccessibleIconDescription()
获取此图标的描述。此描述应该是对该对象的简明文本描述。例如，可以将它呈现给盲人用户，向他们指示该图标的用途。

返回：
图标的描述

setAccessibleIconDescription

void setAccessibleIconDescription(String description)
设置图标的描述。此描述应该是对该对象的简明文本描述。例如，可以将它呈现给盲人用户，向他们指示该图标的用途。

参数：
description - 图标的描述

getAccessibleIconWidth

int getAccessibleIconWidth()
获取图标的宽度。

返回：
图标的宽度。

getAccessibleIconHeight

int getAccessibleIconHeight()
获取图标的高度。

返回：
图标的高度。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleRelation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleRelation

java.lang.Object
    继承者  javax.accessibility.AccessibleBundle
        继承者  javax.accessibility.AccessibleRelation

public class AccessibleRelation
extends AccessibleBundle

AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。某个对象与其他对象所具有的实际关系被定义为 AccessibleRelationSet，它是由 AccessibleRelation 组成的集合。

toDisplayString 方法允许从此类中定义的键的预定义 ResourceBundle 获得与语言环境无关的键的本地化字符串。

此类中的常量存在一个公共对象职责的强类型的枚举。如果此类中没有足够的常量来描述对象的职责，则应从此类生成一个子类，此子类应以类似的方式提供常量。

从以下版本开始：
1.3

字段摘要
static String | CHILD_NODE_OF 指示某个对象是一个或多个对象的子节点。
static String | CHILD_NODE_OF_PROPERTY 指示两个或多个对象之间的 CHILD_NODE_OF 关系已更改。
static String | CONTROLLED_BY 指示某个对象由一个或多个目标对象控制。
static String | CONTROLLED_BY_PROPERTY 标识正在进行控制操作的目标对象已更改
static String | CONTROLLER_FOR 指示某个对象是一个或多个目标对象的控制器。
static String | CONTROLLER_FOR_PROPERTY 标识目标对象的控制器已更改
static String | EMBEDDED_BY 指示某个对象嵌入一个或多个对象。
static String | EMBEDDED_BY_PROPERTY 指示两个或多个对象之间的 EMBEDDED_BY 关系已更改。
static String | EMBEDS 指示某个对象具有一个或多个嵌入它的对象。
static String | EMBEDS_PROPERTY 指示两个或多个对象之间的 EMBEDS 关系已更改。
static String | FLOWS_FROM 指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象出现在该对象前面。
static String | FLOWS_FROM_PROPERTY 指示两个对象之间的 FLOWS_FROM 关系已更改。
static String | FLOWS_TO 指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象在该对象后面出现。
static String | FLOWS_TO_PROPERTY 指示两个对象之间的 FLOWS_TO 关系已更改。
static String | LABEL_FOR 指示某个对象是一个或多个目标对象的标签。
static String | LABEL_FOR_PROPERTY 标识某个标签的目标组已更改
static String | LABELED_BY 指示一个或多个目标对象作为某个对象的标签。
static String | LABELED_BY_PROPERTY 标识正在进行标签操作的对象已更改
static String | MEMBER_OF 指示某个对象是一个或多个目标对象集合的成员。
static String | MEMBER_OF_PROPERTY 标识组成员已更改。
static String | PARENT_WINDOW_OF 指示某个对象是一个或多个对象的父窗口。
static String | PARENT_WINDOW_OF_PROPERTY 指示两个或多个对象之间的 PARENT_WINDOW_OF 关系已更改。
static String | SUBWINDOW_OF 指示某个对象是一个或多个对象的子窗口。
static String | SUBWINDOW_OF_PROPERTY 指示两个或多个对象之间的 SUBWINDOW_OF 关系已更改。
从类 javax.accessibility.AccessibleBundle 继承的字段
key
构造方法摘要
AccessibleRelation(String key)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelation(String key, Object target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
AccessibleRelation(String key, Object[] target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。
方法摘要
String | getKey() 返回此关系的键
Object[] | getTarget() 返回此关系的目标对象
void | setTarget(Object target) 设置此关系的目标对象
void | setTarget(Object[] target) 设置此关系的目标对象
从类 javax.accessibility.AccessibleBundle 继承的方法
toDisplayString, toDisplayString, toDisplayString, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

LABEL_FOR

public static final String LABEL_FOR
指示某个对象是一个或多个目标对象的标签。

另请参见：
getTarget(), CONTROLLER_FOR, CONTROLLED_BY, LABELED_BY, MEMBER_OF

LABELED_BY

public static final String LABELED_BY
指示一个或多个目标对象作为某个对象的标签。

另请参见：
getTarget(), CONTROLLER_FOR, CONTROLLED_BY, LABEL_FOR, MEMBER_OF

MEMBER_OF

public static final String MEMBER_OF
指示某个对象是一个或多个目标对象集合的成员。

另请参见：
getTarget(), CONTROLLER_FOR, CONTROLLED_BY, LABEL_FOR, LABELED_BY

CONTROLLER_FOR

public static final String CONTROLLER_FOR
指示某个对象是一个或多个目标对象的控制器。

另请参见：
getTarget(), CONTROLLED_BY, LABEL_FOR, LABELED_BY, MEMBER_OF

CONTROLLED_BY

public static final String CONTROLLED_BY
指示某个对象由一个或多个目标对象控制。

另请参见：
getTarget(), CONTROLLER_FOR, LABEL_FOR, LABELED_BY, MEMBER_OF

FLOWS_TO

public static final String FLOWS_TO
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象在该对象后面出现。例如，一个文本段落到达一页的末尾，并继续在下页呈现，两页之间带有文本脚注和/或文本标题。此段落的两个部分是独立的文本元素，但因为第二个元素是第一个元素的继续而产生联系。换句话说，第一个元素“流向”第二个元素。

从以下版本开始：
1.5
另请参见：
常量字段值

FLOWS_FROM

public static final String FLOWS_FROM
指示某个对象与第二个对象在逻辑上是连续的，其中第二个对象出现在该对象前面。例如，一个文本段落到达一页的末尾，并继续在下页呈现，两页之间带有文本脚注和/或文本标题。此段落的两个部分是独立的文本元素，但因为第二个元素是第一个元素的继续而产生联系。换句话说，第一个元素从第二个元素“流出”。

从以下版本开始：
1.5
另请参见：
常量字段值

SUBWINDOW_OF

public static final String SUBWINDOW_OF
指示某个对象是一个或多个对象的子窗口。

从以下版本开始：
1.5
另请参见：
常量字段值

PARENT_WINDOW_OF

public static final String PARENT_WINDOW_OF
指示某个对象是一个或多个对象的父窗口。

从以下版本开始：
1.5
另请参见：
常量字段值

EMBEDS

public static final String EMBEDS
指示某个对象具有一个或多个嵌入它的对象。

从以下版本开始：
1.5
另请参见：
常量字段值

EMBEDDED_BY

public static final String EMBEDDED_BY
指示某个对象嵌入一个或多个对象。

从以下版本开始：
1.5
另请参见：
常量字段值

CHILD_NODE_OF

public static final String CHILD_NODE_OF
指示某个对象是一个或多个对象的子节点。

从以下版本开始：
1.5
另请参见：
常量字段值

LABEL_FOR_PROPERTY

public static final String LABEL_FOR_PROPERTY
标识某个标签的目标组已更改

另请参见：
常量字段值

LABELED_BY_PROPERTY

public static final String LABELED_BY_PROPERTY
标识正在进行标签操作的对象已更改

另请参见：
常量字段值

MEMBER_OF_PROPERTY

public static final String MEMBER_OF_PROPERTY
标识组成员已更改。

另请参见：
常量字段值

CONTROLLER_FOR_PROPERTY

public static final String CONTROLLER_FOR_PROPERTY
标识目标对象的控制器已更改

另请参见：
常量字段值

CONTROLLED_BY_PROPERTY

public static final String CONTROLLED_BY_PROPERTY
标识正在进行控制操作的目标对象已更改

另请参见：
常量字段值

FLOWS_TO_PROPERTY

public static final String FLOWS_TO_PROPERTY
指示两个对象之间的 FLOWS_TO 关系已更改。

从以下版本开始：
1.5
另请参见：
常量字段值

FLOWS_FROM_PROPERTY

public static final String FLOWS_FROM_PROPERTY
指示两个对象之间的 FLOWS_FROM 关系已更改。

从以下版本开始：
1.5
另请参见：
常量字段值

SUBWINDOW_OF_PROPERTY

public static final String SUBWINDOW_OF_PROPERTY
指示两个或多个对象之间的 SUBWINDOW_OF 关系已更改。

从以下版本开始：
1.5
另请参见：
常量字段值

PARENT_WINDOW_OF_PROPERTY

public static final String PARENT_WINDOW_OF_PROPERTY
指示两个或多个对象之间的 PARENT_WINDOW_OF 关系已更改。

从以下版本开始：
1.5
另请参见：
常量字段值

EMBEDS_PROPERTY

public static final String EMBEDS_PROPERTY
指示两个或多个对象之间的 EMBEDS 关系已更改。

从以下版本开始：
1.5
另请参见：
常量字段值

EMBEDDED_BY_PROPERTY

public static final String EMBEDDED_BY_PROPERTY
指示两个或多个对象之间的 EMBEDDED_BY 关系已更改。

从以下版本开始：
1.5
另请参见：
常量字段值

CHILD_NODE_OF_PROPERTY

public static final String CHILD_NODE_OF_PROPERTY
指示两个或多个对象之间的 CHILD_NODE_OF 关系已更改。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

AccessibleRelation

public AccessibleRelation(String key)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。String 键应是针对关系的与语言环境无关的键。它不是用作实际的 String 显示给用户的。要获取本地化字符串，请使用 toDisplayString。

参数：
key - 关系的与语言环境无关的名称。
另请参见：
AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)

AccessibleRelation

public AccessibleRelation(String key,
                          Object target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。String 键应是针对关系的与语言环境无关的键。它不是用作实际的 String 显示给用户的。要获取本地化字符串，请使用 toDisplayString。

参数：
key - 关系的与语言环境无关的名称。
target - 此关系的目标对象
另请参见：
AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)

AccessibleRelation

public AccessibleRelation(String key,
                          Object[] target)
使用给定的与语言环境无关的键创建新的 AccessibleRelation。String 键应是针对关系的与语言环境无关的键。它不是用作实际的 String 显示给用户的。要获取本地化字符串，请使用 toDisplayString。

参数：
key - 关系的与语言环境无关的名称。
target - 此关系的目标对象（或多个目标对象）
另请参见：
AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
方法详细信息

getKey

public String getKey()
返回此关系的键

返回：
此关系的键
另请参见：
CONTROLLER_FOR, CONTROLLED_BY, LABEL_FOR, LABELED_BY, MEMBER_OF

getTarget

public Object[] getTarget()
返回此关系的目标对象

返回：
包含此关系的目标对象的数组

setTarget

public void setTarget(Object target)
设置此关系的目标对象

参数：
target - 此关系的目标对象

setTarget

public void setTarget(Object[] target)
设置此关系的目标对象

参数：
target - 包含此关系的目标对象的数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleKeyBinding (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleKeyBinding

public interface AccessibleKeyBinding

任何具有键盘绑定（例如可用于选择对象的键盘助记符和/或键盘快捷键）功能的对象都应支持 AccessibleKeyBinding 接口。此接口为辅助技术提供了标准机制，以确定此对象存在的键绑定。任何具有这样的键绑定的对象都应支持此接口。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext#getAccessibleKeyBinding 方法，能够确定该对象是否支持 AccessibleKeyBinding 接口。如果返回值不为 null，则该对象支持此接口。

从以下版本开始：
1.4
另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext#getAccessibleKeyBinding

方法摘要
Object | getAccessibleKeyBinding(int i) 返回此对象的键绑定。
int | getAccessibleKeyBindingCount() 返回此对象的键绑定数。

方法详细信息

getAccessibleKeyBindingCount

int getAccessibleKeyBindingCount()
返回此对象的键绑定数。

返回：
此对象从 0 开始的键绑定数

getAccessibleKeyBinding

Object getAccessibleKeyBinding(int i)
返回此对象的键绑定。返回值为一个 java.lang.Object，必须根据键的底层实现将它强制转换为适当的类型。例如，如果返回的 Object 是一个 javax.swing.KeyStroke，则此方法的用户应执行以下操作：
Component c =
AccessibleContext ac = c.getAccessibleContext();
AccessibleKeyBinding akb = ac.getAccessibleKeyBinding();
for (int i = 0; i < akb.getAccessibleKeyBindingCount(); i++) {
    Object o = akb.getAccessibleKeyBinding(i);
    if (o instanceof javax.swing.KeyStroke) {
        javax.swing.KeyStroke keyStroke = (javax.swing.KeyStroke)o;

    }
}

参数：
i - 键绑定基于零的索引
返回：
指定了键绑定的 javax.lang.Object
另请参见：
getAccessibleKeyBindingCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleRelationSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleRelationSet

java.lang.Object
    继承者  javax.accessibility.AccessibleRelationSet

public class AccessibleRelationSet
extends Object

AccessibleRelationSet 类确定了组件的关系集。组件的关系集是描述该组件与其他组件的关系的 AccessibleRelation 对象的集合。

从以下版本开始：
1.3
另请参见：
AccessibleRelation

字段摘要
protected  Vector<AccessibleRelation> relations
Vector 中的每个项表示一个 AccessibleRelation。
构造方法摘要
AccessibleRelationSet()
创建新的空关系集。
AccessibleRelationSet(AccessibleRelation[] relations)
创建具有传入的关系数组中所包含的初始关系集的新关系。
方法摘要
boolean | add(AccessibleRelation relation) 将新关系添加到当前关系集中。
void | addAll(AccessibleRelation[] relations) 将所有关系添加到现有关系集中。
void | clear() 从当前关系集中移除所有关系。
boolean | contains(String key) 返回关系集是否包含与指定键匹配的关系。
AccessibleRelation | get(String key) 返回与指定键匹配的关系。
boolean | remove(AccessibleRelation relation) 从当前关系集中移除一个关系。
int | size() 返回关系集中的关系数。
AccessibleRelation[] | toArray() 返回作为 AccessibleRelation 数组的当前关系集
String | toString() 使用默认语言环境创建表示关系集中所有关系的本地化 String。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

relations

protected Vector<AccessibleRelation> relations
Vector 中的每个项表示一个 AccessibleRelation。

另请参见：
add(javax.accessibility.AccessibleRelation),
addAll(javax.accessibility.AccessibleRelation[]),
remove(javax.accessibility.AccessibleRelation),
contains(java.lang.String),
get(java.lang.String),
size(),
toArray(),
clear()
构造方法详细信息

AccessibleRelationSet

public AccessibleRelationSet()
创建新的空关系集。

AccessibleRelationSet

public AccessibleRelationSet(AccessibleRelation[] relations)
创建具有传入的关系数组中所包含的初始关系集的新关系。忽略重复项。

参数：
relations - 描述关系集的 AccessibleRelation 数组。
方法详细信息

add

public boolean add(AccessibleRelation relation)
将新关系添加到当前关系集中。如果该关系已在关系集中，则将目标（或多个目标）的指定关系与目标（或多个目标）的现有关系合并。否则，将新关系添加到关系集中。

参数：
relation - 要添加到关系集的关系
返回：
如果关系被添加到关系集中，则返回 true；如果关系集不发生更改，则返回 false

addAll

public void addAll(AccessibleRelation[] relations)
将所有关系添加到现有关系集中。忽略重复项。

参数：
relations - 描述关系集的 AccessibleRelation 数组。

remove

public boolean remove(AccessibleRelation relation)
从当前关系集中移除一个关系。如果该关系不在关系集中，则关系集将不发生更改，返回值将为 false。如果该关系在关系集中，则将它从关系集中移除，返回值将为 true。

参数：
relation - 要从关系集中移除的关系
返回：
如果此关系在关系集中，则返回 true；如果关系集不发生更改，则返回 false

clear

public void clear()
从当前关系集中移除所有关系。

size

public int size()
返回关系集中的关系数。

contains

public boolean contains(String key)
返回关系集是否包含与指定键匹配的关系。

参数：
key - AccessibleRelation 键
返回：
如果该关系在关系集中，则返回 true；否则返回 false

get

public AccessibleRelation get(String key)
返回与指定键匹配的关系。

参数：
key - AccessibleRelation 键
返回：
与指定键匹配的关系（如果存在）。否则，返回 null。

toArray

public AccessibleRelation[] toArray()
返回作为 AccessibleRelation 数组的当前关系集

返回：
连接当前关系的 AccessibleRelation 数组。

toString

public String toString()
使用默认语言环境创建表示关系集中所有关系的本地化 String。

覆盖：
类 Object 中的 toString
返回：
用逗号分隔的本地化 String
另请参见：
AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleResourceBundle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleResourceBundle

java.lang.Object
    继承者  java.util.ResourceBundle
        继承者  java.util.ListResourceBundle
            继承者  javax.accessibility.AccessibleResourceBundle
已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。

@Deprecated
public class AccessibleResourceBundle
extends ListResourceBundle

可访问性包中的包含本地化字符串的资源包。此方法仅供 Java Accessibility 在内部使用，而不能通过辅助技术或应用程序使用。

嵌套类摘要
从类 java.util.ResourceBundle 继承的嵌套类/接口
ResourceBundle.Control
字段摘要
从类 java.util.ResourceBundle 继承的字段
parent
构造方法摘要
AccessibleResourceBundle()
已过时。
方法摘要
 Object[][] getContents()
已过时。 返回编程键和本地化显示字符串之间的映射关系。
从类 java.util.ListResourceBundle 继承的方法
getKeys, handleGetObject, handleKeySet
从类 java.util.ResourceBundle 继承的方法
clearCache, clearCache, containsKey, getBundle, getBundle, getBundle, getBundle, getBundle, getBundle, getLocale, getObject, getString, getStringArray, keySet, setParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AccessibleResourceBundle

public AccessibleResourceBundle()
已过时。
方法详细信息

getContents

public Object[][] getContents()
已过时。
返回编程键和本地化显示字符串之间的映射关系。

指定者：
类 ListResourceBundle 中的 getContents
返回：
表示键-值对的 Object 数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleRole (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleRole

java.lang.Object
    继承者  javax.accessibility.AccessibleBundle
        继承者  javax.accessibility.AccessibleRole

public class AccessibleRole
extends AccessibleBundle

AccessibleRole 类确定组件的职责。组件职责描述组件的一般功能。（例如，"push button"、"table" 或 "list"）。

toDisplayString 方法允许获取与语言环境无关的键（取自此类中定义的键的预定义 ResourceBundle）的本地化字符串。

此类中的常量表示公共对象职责的强类型的枚举。此类的公共构造方法已被有意忽略，应用程序应该使用此类的一个常量。如果此类中没有足够的常量来描述对象的职责，则应从此类生成一个子类，此子类应以类似的方式提供常量。

字段摘要
static AccessibleRole | ALERT 可用于就某事向用户报警的对象。
static AccessibleRole | AWT_COMPONENT 一个 AWT 组件，但关于它的其他信息都是未知的。
static AccessibleRole | CANVAS 可用于绘制和捕获事件的对象。
static AccessibleRole | CHECK_BOX 可以被选中或不被选中的选项，它针对当前状态提供了单独的指示符。
static AccessibleRole | COLOR_CHOOSER 允许用户选择颜色的专用窗格。
static AccessibleRole | COLUMN_HEADER 数据列的头。
static AccessibleRole | COMBO_BOX 用户可以从中进行选择的选项列表。
static AccessibleRole | DATE_EDITOR DATE_EDITOR 是允许用户编辑 java.util.Date 和 java.util.Time 对象的组件。
static AccessibleRole | DESKTOP_ICON DESKTOP_PANE 中的图标化的内部 frame。
static AccessibleRole | DESKTOP_PANE 支持内部窗体和这些内部窗体的图标化形式的窗格。
static AccessibleRole | DIALOG 带有标题栏和边框的顶层窗口。
static AccessibleRole | DIRECTORY_PANE 允许用户在目录内容中导航并进行选择的窗格。
static AccessibleRole | EDITBAR 该职责表示充当一个求值公式的对象。
static AccessibleRole | FILE_CHOOSER 一个专用的对话框，它显示目录中的文件，并允许用户选择文件、浏览不同的目录，或指定一个文件名。
static AccessibleRole | FILLER 填补用户界面空间的对象。
static AccessibleRole | FONT_CHOOSER FONT_CHOOSER 是允许用户选择各种字体属性的组件。
static AccessibleRole | FOOTER 文本脚注
static AccessibleRole | FRAME 带有标题栏、边框、菜单栏等的顶层窗口。
static AccessibleRole | GLASS_PANE 一个窗格，保证此窗格在其所有下级窗格之上进行绘制。
static AccessibleRole | GROUP_BOX GROUP_BOX 是包含它周围的边框及其内部组件的简单容器。
static AccessibleRole | HEADER 文本标题
static AccessibleRole | HTML_CONTAINER 包含一起能表示 HTML 内容的 Accessible 集合的对象。
static AccessibleRole | HYPERLINK 超文本锚
static AccessibleRole | ICON 一个固定大小的小图片，通常用于装饰组件。
static AccessibleRole | INTERNAL_FRAME 通过桌面窗格剪切的类似于窗体的对象。
static AccessibleRole | LABEL 用于在界面中显示图标或短字符串的对象。
static AccessibleRole | LAYERED_PANE 允许其子级在各层中进行绘制的专用窗格，提供堆栈顺序的形式。
static AccessibleRole | LIST 呈现给用户一个对象列表的对象，它还允许用户从中选择一个或多个对象。
static AccessibleRole | LIST_ITEM 呈现列表元素的对象。
static AccessibleRole | MENU 通常出现在菜单栏中的对象，它包含一个用户可以从中选择的动作列表。
static AccessibleRole | MENU_BAR 通常被绘制在应用程序的主对话框顶部的对象，它包含用户可以从中进行选择的菜单列表。
static AccessibleRole | MENU_ITEM 通常包含在菜单中的对象，该对象呈现用户可以选择的动作。
static AccessibleRole | OPTION_PANE 主要用于 DIALOG 内部的专用窗格
static AccessibleRole | PAGE_TAB 作为页选项卡列表子级的对象。
static AccessibleRole | PAGE_TAB_LIST 通过所提供的某种机制一次可呈现一系列窗格（或页选项卡）的对象。
static AccessibleRole | PANEL 通常用于对对象进行分组的一般容器。
static AccessibleRole | PARAGRAPH 文本段落
static AccessibleRole | PASSWORD_TEXT 用于密码或文本内容不显示给用户的其他地方的文本对象。
static AccessibleRole | POPUP_MENU 一个临时窗口，通常用于为用户提供选项列表，当用户选中其中某个选项后，此窗口隐藏。
static AccessibleRole | PROGRESS_BAR 用于指示某项任务已完成多少的对象。
static AccessibleRole | PROGRESS_MONITOR 该职责表示监视某个操作进度的对象。
static AccessibleRole | PUSH_BUTTON 用户可以操作以通知应用程序执行某任务的对象。
static AccessibleRole | RADIO_BUTTON 一个专用复选框，当选中此复选框时，将导致取消选中同一组中的其他单选按钮。
static AccessibleRole | ROOT_PANE 一个专用窗格，带有玻璃窗格和作为其子窗格的分层窗格。
static AccessibleRole | ROW_HEADER 数据行的头。
static AccessibleRole | RULER RULER 是用于测量距离的对象
static AccessibleRole | SCROLL_BAR 通常用于允许用户逐渐查看大量数据的对象。
static AccessibleRole | SCROLL_PANE 允许用户逐渐查看大量信息的对象。
static AccessibleRole | SEPARATOR 通常包含在菜单中的对象，它对菜单中的内容进行可视和逻辑分离。
static AccessibleRole | SLIDER 允许用户在有限范围内进行选择的对象。
static AccessibleRole | SPIN_BOX SPIN_BOX 是简单的微调器组件，它主要用于简单数字。
static AccessibleRole | SPLIT_PANE 同时呈现两个其他窗格的专用窗格。
static AccessibleRole | STATUS_BAR STATUS_BAR 是可以包含多个用户状态信息标签的简单组件。
static AccessibleRole | SWING_COMPONENT 一个 Swing 组件，但关于它的其他信息都是未知的。
static AccessibleRole | TABLE 用于根据行和列来呈现信息的对象。
static AccessibleRole | TEXT 将文本呈现给用户的对象。
static AccessibleRole | TOGGLE_BUTTON 可以被选中或不被选中的专用按钮，但不针对当前状态提供单独的指示符。
static AccessibleRole | TOOL_BAR 通常由普通按钮或切换按钮组成的工具栏或调色板。
static AccessibleRole | TOOL_TIP 提供关于另一个对象信息的对象。
static AccessibleRole | TREE 用于将层次结构信息呈现给用户的对象。
static AccessibleRole | UNKNOWN 该对象包含某些 Accessible 信息，但其职责是未知的。
static AccessibleRole | VIEWPORT 通常在滚动窗格中使用的对象。
static AccessibleRole | WINDOW 不带标题或边框的顶层窗口。
从类 javax.accessibility.AccessibleBundle 继承的字段
key
构造方法摘要
protected AccessibleRole(String key)
使用与语言环境无关的给定键创建新的 AccessibleRole。
方法摘要
从类 javax.accessibility.AccessibleBundle 继承的方法
toDisplayString, toDisplayString, toDisplayString, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ALERT

public static final AccessibleRole ALERT
可用于就某事向用户报警的对象。

COLUMN_HEADER

public static final AccessibleRole COLUMN_HEADER
数据列的头。

CANVAS

public static final AccessibleRole CANVAS
可用于绘制和捕获事件的对象。

另请参见：
FRAME, GLASS_PANE, LAYERED_PANE

COMBO_BOX

public static final AccessibleRole COMBO_BOX
用户可以从中进行选择的选项列表。还允许用户输入他们自己的选项（可选）。

DESKTOP_ICON

public static final AccessibleRole DESKTOP_ICON
DESKTOP_PANE 中的图标化的内部 frame。

另请参见：
DESKTOP_PANE, INTERNAL_FRAME

HTML_CONTAINER

public static final AccessibleRole HTML_CONTAINER
包含一起能表示 HTML 内容的 Accessible 集合的对象。子 Accessible 可能包括实现 AccessibleText、AccessibleHypertext、AccessibleIcon 和其他接口的对象。

从以下版本开始：
1.6
另请参见：
HYPERLINK, AccessibleText, AccessibleHypertext, AccessibleHyperlink, AccessibleIcon

INTERNAL_FRAME

public static final AccessibleRole INTERNAL_FRAME
通过桌面窗格剪切的类似于窗体的对象。桌面窗格、内部窗体和桌面图标对象通常用来在应用程序中创建多文档界面。

另请参见：
DESKTOP_ICON, DESKTOP_PANE, FRAME

DESKTOP_PANE

public static final AccessibleRole DESKTOP_PANE
支持内部窗体和这些内部窗体的图标化形式的窗格。

另请参见：
DESKTOP_ICON, INTERNAL_FRAME

OPTION_PANE

public static final AccessibleRole OPTION_PANE
主要用于 DIALOG 内部的专用窗格

另请参见：
DIALOG

WINDOW

public static final AccessibleRole WINDOW
不带标题或边框的顶层窗口。

另请参见：
FRAME, DIALOG

FRAME

public static final AccessibleRole FRAME
带有标题栏、边框、菜单栏等的顶层窗口。它通常用作应用程序的主窗口。

另请参见：
DIALOG, CANVAS, WINDOW

DIALOG

public static final AccessibleRole DIALOG
带有标题栏和边框的顶层窗口。对话框类似于窗体，但它属性较少，通常用作应用程序的二级窗口。

另请参见：
FRAME, WINDOW

COLOR_CHOOSER

public static final AccessibleRole COLOR_CHOOSER
允许用户选择颜色的专用窗格。

DIRECTORY_PANE

public static final AccessibleRole DIRECTORY_PANE
允许用户在目录内容中导航并进行选择的窗格。文件选择器可以使用此窗格。

另请参见：
FILE_CHOOSER

FILE_CHOOSER

public static final AccessibleRole FILE_CHOOSER
一个专用的对话框，它显示目录中的文件，并允许用户选择文件、浏览不同的目录，或指定一个文件名。可以使用目录窗格来显示目录的内容。

另请参见：
DIRECTORY_PANE

FILLER

public static final AccessibleRole FILLER
填补用户界面空间的对象。它通常用于在界面中调整组件之间的空间，并无其他用途。

HYPERLINK

public static final AccessibleRole HYPERLINK
超文本锚

ICON

public static final AccessibleRole ICON
一个固定大小的小图片，通常用于装饰组件。

LABEL

public static final AccessibleRole LABEL
用于在界面中显示图标或短字符串的对象。

ROOT_PANE

public static final AccessibleRole ROOT_PANE
一个专用窗格，带有玻璃窗格和作为其子窗格的分层窗格。

另请参见：
GLASS_PANE, LAYERED_PANE

GLASS_PANE

public static final AccessibleRole GLASS_PANE
一个窗格，保证此窗格在其所有下级窗格之上进行绘制。

另请参见：
ROOT_PANE, CANVAS

LAYERED_PANE

public static final AccessibleRole LAYERED_PANE
允许其子级在各层中进行绘制的专用窗格，提供堆栈顺序的形式。这通常是保存菜单栏的窗格，以及包含窗口中大多数可见组件的窗格。

另请参见：
GLASS_PANE, ROOT_PANE

LIST

public static final AccessibleRole LIST
呈现给用户一个对象列表的对象，它还允许用户从中选择一个或多个对象。列表通常包含在滚动窗格中。

另请参见：
SCROLL_PANE, LIST_ITEM

LIST_ITEM

public static final AccessibleRole LIST_ITEM
呈现列表元素的对象。列表通常包含在滚动窗格中。

另请参见：
SCROLL_PANE, LIST

MENU_BAR

public static final AccessibleRole MENU_BAR
通常被绘制在应用程序的主对话框顶部的对象，它包含用户可以从中进行选择的菜单列表。例如，菜单栏可以包含 "File"、"Edit" 和 "Help" 菜单。

另请参见：
MENU, POPUP_MENU, LAYERED_PANE

POPUP_MENU

public static final AccessibleRole POPUP_MENU
一个临时窗口，通常用于为用户提供选项列表，当用户选中其中某个选项后，此窗口隐藏。

另请参见：
MENU, MENU_ITEM

MENU

public static final AccessibleRole MENU
通常出现在菜单栏中的对象，它包含一个用户可以从中选择的动作列表。菜单可以使用任何对象作为其子级，但这些对象通常都是菜单项、其他菜单或单选按钮、复选框或分隔栏这样的基本对象。例如，应用程序可能有 "Edit" 菜单，它包含 "Cut" 和 "Paste" 菜单项。

另请参见：
MENU_BAR, MENU_ITEM, SEPARATOR, RADIO_BUTTON, CHECK_BOX, POPUP_MENU

MENU_ITEM

public static final AccessibleRole MENU_ITEM
通常包含在菜单中的对象，该对象呈现用户可以选择的动作。例如，"Edit" 菜单中的 "Cut" 菜单项就是一个用户可以选择的动作，用于剪切文档中的选定文本区域。

另请参见：
MENU_BAR, SEPARATOR, POPUP_MENU

SEPARATOR

public static final AccessibleRole SEPARATOR
通常包含在菜单中的对象，它对菜单中的内容进行可视和逻辑分离。例如，应用程序的 "File" 菜单可能包含菜单项 "Open"、"Close" 和 "Exit"，在 "Close" 和 "Exit" 菜单项之间将有一个分隔符。

另请参见：
MENU, MENU_ITEM

PAGE_TAB_LIST

public static final AccessibleRole PAGE_TAB_LIST
通过所提供的某种机制一次可呈现一系列窗格（或页选项卡）的对象。最常见的机制是位于窗格顶部的选项卡列表。页选项卡列表的子级是所有页选项卡。

另请参见：
PAGE_TAB

PAGE_TAB

public static final AccessibleRole PAGE_TAB
作为页选项卡列表子级的对象。它的唯一子级是用户从页选项卡列表中选则页选项卡时，要呈现给用户的窗格。

另请参见：
PAGE_TAB_LIST

PANEL

public static final AccessibleRole PANEL
通常用于对对象进行分组的一般容器。

PROGRESS_BAR

public static final AccessibleRole PROGRESS_BAR
用于指示某项任务已完成多少的对象。

PASSWORD_TEXT

public static final AccessibleRole PASSWORD_TEXT
用于密码或文本内容不显示给用户的其他地方的文本对象。

PUSH_BUTTON

public static final AccessibleRole PUSH_BUTTON
用户可以操作以通知应用程序执行某任务的对象。

另请参见：
CHECK_BOX, TOGGLE_BUTTON, RADIO_BUTTON

TOGGLE_BUTTON

public static final AccessibleRole TOGGLE_BUTTON
可以被选中或不被选中的专用按钮，但不针对当前状态提供单独的指示符。

另请参见：
PUSH_BUTTON, CHECK_BOX, RADIO_BUTTON

CHECK_BOX

public static final AccessibleRole CHECK_BOX
可以被选中或不被选中的选项，它针对当前状态提供了单独的指示符。

另请参见：
PUSH_BUTTON, TOGGLE_BUTTON, RADIO_BUTTON

RADIO_BUTTON

public static final AccessibleRole RADIO_BUTTON
一个专用复选框，当选中此复选框时，将导致取消选中同一组中的其他单选按钮。

另请参见：
PUSH_BUTTON, TOGGLE_BUTTON, CHECK_BOX

ROW_HEADER

public static final AccessibleRole ROW_HEADER
数据行的头。

SCROLL_PANE

public static final AccessibleRole SCROLL_PANE
允许用户逐渐查看大量信息的对象。其子级可以包括滚动条和视口。

另请参见：
SCROLL_BAR, VIEWPORT

SCROLL_BAR

public static final AccessibleRole SCROLL_BAR
通常用于允许用户逐渐查看大量数据的对象。通常只供滚动窗格使用。

另请参见：
SCROLL_PANE

VIEWPORT

public static final AccessibleRole VIEWPORT
通常在滚动窗格中使用的对象。它表示用户能够看到的整个数据的一部分。当用户操作滚动条时，视口的内容可以发生更改。

另请参见：
SCROLL_PANE

SLIDER

public static final AccessibleRole SLIDER
允许用户在有限范围内进行选择的对象。例如，滑块可用于选择 0 到 100 之间的某个数字。

SPLIT_PANE

public static final AccessibleRole SPLIT_PANE
同时呈现两个其他窗格的专用窗格。两个窗格之间有一个分隔栏，用户可以操作分隔栏使一个窗格变大，并使另一个窗格变小。

TABLE

public static final AccessibleRole TABLE
用于根据行和列来呈现信息的对象。例如电子表格应用程序。

TEXT

public static final AccessibleRole TEXT
将文本呈现给用户的对象。与标签不同，文本通常可以由用户编辑。

另请参见：
LABEL

TREE

public static final AccessibleRole TREE
用于将层次结构信息呈现给用户的对象。可以将树中的各个节点折叠和展开，以选择性地显示树的内容。

TOOL_BAR

public static final AccessibleRole TOOL_BAR
通常由普通按钮或切换按钮组成的工具栏或调色板。它通常用于提供应用程序最常用的功能。

TOOL_TIP

public static final AccessibleRole TOOL_TIP
提供关于另一个对象信息的对象。当用户将鼠标停在与工具提示文本关联的对象上时，该工具提示文本的 accessibleDescription 属性通常以一个很小的 "help bubble" 的形式显示给用户。

AWT_COMPONENT

public static final AccessibleRole AWT_COMPONENT
一个 AWT 组件，但关于它的其他信息都是未知的。

另请参见：
SWING_COMPONENT, UNKNOWN

SWING_COMPONENT

public static final AccessibleRole SWING_COMPONENT
一个 Swing 组件，但关于它的其他信息都是未知的。

另请参见：
AWT_COMPONENT, UNKNOWN

UNKNOWN

public static final AccessibleRole UNKNOWN
该对象包含某些 Accessible 信息，但其职责是未知的。

另请参见：
AWT_COMPONENT, SWING_COMPONENT

STATUS_BAR

public static final AccessibleRole STATUS_BAR
STATUS_BAR 是可以包含多个用户状态信息标签的简单组件。

DATE_EDITOR

public static final AccessibleRole DATE_EDITOR
DATE_EDITOR 是允许用户编辑 java.util.Date 和 java.util.Time 对象的组件。

SPIN_BOX

public static final AccessibleRole SPIN_BOX
SPIN_BOX 是简单的微调器组件，它主要用于简单数字。

FONT_CHOOSER

public static final AccessibleRole FONT_CHOOSER
FONT_CHOOSER 是允许用户选择各种字体属性的组件。

GROUP_BOX

public static final AccessibleRole GROUP_BOX
GROUP_BOX 是包含它周围的边框及其内部组件的简单容器。

HEADER

public static final AccessibleRole HEADER
文本标题

从以下版本开始：
1.5

FOOTER

public static final AccessibleRole FOOTER
文本脚注

从以下版本开始：
1.5

PARAGRAPH

public static final AccessibleRole PARAGRAPH
文本段落

从以下版本开始：
1.5

RULER

public static final AccessibleRole RULER
RULER 是用于测量距离的对象

从以下版本开始：
1.5

EDITBAR

public static final AccessibleRole EDITBAR
该职责表示充当一个求值公式的对象。例如电子表格单元格中的公式。

从以下版本开始：
1.5

PROGRESS_MONITOR

public static final AccessibleRole PROGRESS_MONITOR
该职责表示监视某个操作进度的对象。

从以下版本开始：
1.5
构造方法详细信息

AccessibleRole

protected AccessibleRole(String key)
使用与语言环境无关的给定键创建新的 AccessibleRole。此方法不应该为公共方法。相反，它用于创建此文件中的常量以使其成为强类型的枚举。此类的子类应强制执行类似的策略。

String 键应该是针对职责的与语言环境无关的键。它不应该用作显示给用户的实际 String。要获得本地化字符串，请使用 toDisplayString。

参数：
key - 职责的与语言环境无关的键。
另请参见：
AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleSelection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleSelection

所有已知实现类：
CheckboxMenuItem.AccessibleAWTCheckboxMenuItem, JComboBox.AccessibleJComboBox, JList.AccessibleJList, JMenu.AccessibleJMenu, JMenuBar.AccessibleJMenuBar, JTabbedPane.AccessibleJTabbedPane, JTable.AccessibleJTable, JTree.AccessibleJTree, JTree.AccessibleJTree.AccessibleJTreeNode, List.AccessibleAWTList, Menu.AccessibleAWTMenu, MenuBar.AccessibleAWTMenuBar, MenuComponent.AccessibleAWTMenuComponent, MenuItem.AccessibleAWTMenuItem, PopupMenu.AccessibleAWTPopupMenu
public interface AccessibleSelection

此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。任何具有可以选择的子级的对象都应支持 AccessibleSelection 接口。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext.getAccessibleSelection() 方法，能够确定该对象是否支持 AccessibleSelection 接口。如果返回值不为 null，则该对象支持此接口。

另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleSelection()

方法摘要
void | addAccessibleSelection(int i) 将对象的指定 Accessible 子级添加到该对象的选项中。
void | clearAccessibleSelection() 清除对象中的选项，使该对象中没有选中的子对象。
Accessible | getAccessibleSelection(int i) 返回表示指定的所选对象子级的 Accessible。
int | getAccessibleSelectionCount() 返回当前选中的 Accessible 子级数。
boolean | isAccessibleChildSelected(int i) 确定此对象的当前子级是否已选中。
void | removeAccessibleSelection(int i) 从对象的选项中移除该对象的指定子对象。
void | selectAllAccessibleSelection() 如果该对象支持多项选择，则会导致该对象的每个子对象都被选中。

方法详细信息

getAccessibleSelectionCount

int getAccessibleSelectionCount()
返回当前选中的 Accessible 子级数。如果没有选定子对象，那么返回的值将为 0。

返回：
当前选定的项数。

getAccessibleSelection

Accessible getAccessibleSelection(int i)
返回表示指定的所选对象子级的 Accessible。如果没有选择，或者所选子级数少于传入的整数，则返回值为 null。

注意，该索引表示第 i 个选定的子对象，它不同于第 i 个子对象。

参数：
i - 所选子对象的从零开始的索引
返回：
第 i 个选定的子对象
另请参见：
getAccessibleSelectionCount()

isAccessibleChildSelected

boolean isAccessibleChildSelected(int i)
确定此对象的当前子级是否已选中。

参数：
i - 此 Accessible 对象的子对象的从零开始的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

void addAccessibleSelection(int i)
将对象的指定 Accessible 子级添加到该对象的选项中。如果该对象支持多项选择，则将指定的子对象添加到任何现有选项中，否则，它会替换该对象中的任何现有选项。如果指定的子对象已被选定，则此方法无效。

参数：
i - 子对象的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

void removeAccessibleSelection(int i)
从对象的选项中移除该对象的指定子对象。如果当前没有选择指定的项，则此方法无效。

参数：
i - 子对象的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

void clearAccessibleSelection()
清除对象中的选项，使该对象中没有选中的子对象。

selectAllAccessibleSelection

void selectAllAccessibleSelection()
如果该对象支持多项选择，则会导致该对象的每个子对象都被选中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleState (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleState

java.lang.Object
    继承者  javax.accessibility.AccessibleBundle
        继承者  javax.accessibility.AccessibleState

public class AccessibleState
extends AccessibleBundle

AccessibleState 类描述了组件的特殊状态。组件的实际状态定义为 AccessibleStateSet，它是由 AccessibleState 组成的集合。

toDisplayString 方法允许从此类中定义的键的预定义 ResourceBundle 获取与语言环境无关的键的本地化字符串。

此类中的常量表示公共对象职责的强类型的枚举。此类的公共构造方法已被有意忽略，应用程序应该使用此类的一个常量。如果此类中没有足够的常量来描述对象的职责，则应从此类生成一个子类，此子类应以类似的方式提供常量。

字段摘要
static AccessibleState | ACTIVE 指示某个窗口当前是活动窗口。
static AccessibleState | ARMED 指示选中了此对象。
static AccessibleState | BUSY 指示当前对象忙。
static AccessibleState | CHECKED 指示此对象当前被选中。
static AccessibleState | COLLAPSED 指示此对象是折叠的。
static AccessibleState | EDITABLE 指示用户可以更改此对象的内容。
static AccessibleState | ENABLED 指示此对象是启用的。
static AccessibleState | EXPANDABLE 指示此对象允许逐步显示其子级。
static AccessibleState | EXPANDED 指示此对象是展开的。
static AccessibleState | FOCUSABLE 指示此对象可以接受键盘焦点，这意味着当它具有焦点时，由键盘上的键入操作所产生的所有事件将被传递到此对象。
static AccessibleState | FOCUSED 指示此对象当前具有键盘焦点。
static AccessibleState | HORIZONTAL 指示此对象的方向为水平方向。
static AccessibleState | ICONIFIED 指示此对象是最小化的，并只通过一个图标来表示。
static AccessibleState | INDETERMINATE 指示对象状态是不确定的。
static AccessibleState | MANAGES_DESCENDANTS 指示此对象负责管理其子组件。
static AccessibleState | MODAL 指示在用户可以与不同窗口中的某个对象交互之前，必须对此对象采取某些操作。
static AccessibleState | MULTI_LINE 指示此（文本）对象可以包含多行文本
static AccessibleState | MULTISELECTABLE 指示此对象允许同时选定多个子级。
static AccessibleState | OPAQUE 指示此对象在其矩形区域内绘制每个像素。
static AccessibleState | PRESSED 指示此对象当前是按下的。
static AccessibleState | RESIZABLE 指示此对象的大小不固定。
static AccessibleState | SELECTABLE 指示此对象是某个允许选择子级的对象的子对象，并且此子对象就是这些可以被选择的子对象之一。
static AccessibleState | SELECTED 指示此对象是某个允许选择子级的对象的子对象，且此子对象是已被选定的子对象之一。
static AccessibleState | SHOWING 指示此对象、此对象的父对象、其父对象的父对象等都是可见的。
static AccessibleState | SINGLE_LINE 指示此（文本）对象只能包含单行文本
static AccessibleState | TRANSIENT 指示此对象是临时的。
static AccessibleState | TRUNCATED 该状态指示文本被边界矩形截取，并且有些文本不显示在屏幕上。
static AccessibleState | VERTICAL 指示此对象的方向为垂直方向。
static AccessibleState | VISIBLE 指示此对象是可见的。
从类 javax.accessibility.AccessibleBundle 继承的字段
key
构造方法摘要
protected AccessibleState(String key)
使用给定的与语言环境无关的键创建新的 AccessibleState。
方法摘要
从类 javax.accessibility.AccessibleBundle 继承的方法
toDisplayString, toDisplayString, toDisplayString, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ACTIVE

public static final AccessibleState ACTIVE
指示某个窗口当前是活动窗口。这包括窗口、对话框、窗体等等。此外，此状态用于指示组件（例如列表、表或树）的当前活动子级。例如，列表的活动子级是周围绘制了矩形框的子级。

另请参见：
AccessibleRole.WINDOW, AccessibleRole.FRAME, AccessibleRole.DIALOG

PRESSED

public static final AccessibleState PRESSED
指示此对象当前是按下的。这通常与按钮相关，它指示当鼠标指针停留在按钮上时，用户已按下鼠标按钮，并且尚未释放鼠标按钮。

另请参见：
AccessibleRole.PUSH_BUTTON

ARMED

public static final AccessibleState ARMED
指示选中了此对象。这通常用于已按下且尚未释放，并且鼠标指针仍然停留在其上的按钮。

另请参见：
AccessibleRole.PUSH_BUTTON

BUSY

public static final AccessibleState BUSY
指示当前对象忙。这通常用于进度条、滑块或滚动条这之类的对象，以指示这些对象正处于过渡状态。

另请参见：
AccessibleRole.PROGRESS_BAR, AccessibleRole.SCROLL_BAR, AccessibleRole.SLIDER

CHECKED

public static final AccessibleState CHECKED
指示此对象当前被选中。这通常用于切换按钮、单选按钮和复选框之类的对象。

另请参见：
AccessibleRole.TOGGLE_BUTTON, AccessibleRole.RADIO_BUTTON, AccessibleRole.CHECK_BOX

EDITABLE

public static final AccessibleState EDITABLE
指示用户可以更改此对象的内容。这通常主要用于允许用户输入文本的对象。对于其他对象（例如滚动条和滑块），如果它们是启用的，则它们自动是可编辑的。

另请参见：
ENABLED

EXPANDABLE

public static final AccessibleState EXPANDABLE
指示此对象允许逐步显示其子级。这通常用于诸如树之类的分层对象，并通常与 EXPANDED 或 COLLAPSED 状态成对使用。

另请参见：
EXPANDED, COLLAPSED, AccessibleRole.TREE

COLLAPSED

public static final AccessibleState COLLAPSED
指示此对象是折叠的。这通常与 EXPANDABLE 状态成对使用，用于诸如树之类的提供逐步显示功能的对象。

另请参见：
EXPANDABLE, EXPANDED, AccessibleRole.TREE

EXPANDED

public static final AccessibleState EXPANDED
指示此对象是展开的。这通常与 EXPANDABLE 状态成对使用，用于诸如树之类的提供逐步显示功能的对象。

另请参见：
EXPANDABLE, COLLAPSED, AccessibleRole.TREE

ENABLED

public static final AccessibleState ENABLED
指示此对象是启用的。如果对象的状态集中没有此状态，则指示此对象是未启用的。用户不能操作未启用的对象。在图形显示中，它通常呈现灰色。

FOCUSABLE

public static final AccessibleState FOCUSABLE
指示此对象可以接受键盘焦点，这意味着当它具有焦点时，由键盘上的键入操作所产生的所有事件将被传递到此对象。

另请参见：
FOCUSED

FOCUSED

public static final AccessibleState FOCUSED
指示此对象当前具有键盘焦点。

另请参见：
FOCUSABLE

ICONIFIED

public static final AccessibleState ICONIFIED
指示此对象是最小化的，并只通过一个图标来表示。这通常只与窗体和内部窗体关联。

另请参见：
AccessibleRole.FRAME, AccessibleRole.INTERNAL_FRAME

MODAL

public static final AccessibleState MODAL
指示在用户可以与不同窗口中的某个对象交互之前，必须对此对象采取某些操作。这通常只与对话框关联。

另请参见：
AccessibleRole.DIALOG

OPAQUE

public static final AccessibleState OPAQUE
指示此对象在其矩形区域内绘制每个像素。透明的组件则仅绘制其中某些像素，允许其下面的像素“透视出来”。因此，没有完全绘制其像素的组件则提供了一定程度的透明度。

另请参见：
Accessible.getAccessibleContext(),
AccessibleContext.getAccessibleComponent(),
AccessibleComponent.getBounds()

RESIZABLE

public static final AccessibleState RESIZABLE
指示此对象的大小不固定。

另请参见：
Accessible.getAccessibleContext(),
AccessibleContext.getAccessibleComponent(),
AccessibleComponent.getSize(),
AccessibleComponent.setSize(java.awt.Dimension)

MULTISELECTABLE

public static final AccessibleState MULTISELECTABLE
指示此对象允许同时选定多个子级。

另请参见：
Accessible.getAccessibleContext(), AccessibleContext.getAccessibleSelection(), AccessibleSelection

SELECTABLE

public static final AccessibleState SELECTABLE
指示此对象是某个允许选择子级的对象的子对象，并且此子对象就是这些可以被选择的子对象之一。

另请参见：
SELECTED, Accessible.getAccessibleContext(), AccessibleContext.getAccessibleSelection(), AccessibleSelection

SELECTED

public static final AccessibleState SELECTED
指示此对象是某个允许选择子级的对象的子对象，且此子对象是已被选定的子对象之一。

另请参见：
SELECTABLE, Accessible.getAccessibleContext(), AccessibleContext.getAccessibleSelection(), AccessibleSelection

SHOWING

public static final AccessibleState SHOWING
指示此对象、此对象的父对象、其父对象的父对象等都是可见的。注意，这不一定意味着在屏幕上绘制此对象。它可能包括在其他正在显示的对象中。

另请参见：
VISIBLE

VISIBLE

public static final AccessibleState VISIBLE
指示此对象是可见的。注：这意味着该对象是可见的；但是，它实际上不显示在屏幕上，因为包含此对象的对象中的一个对象不可见。

另请参见：
SHOWING

VERTICAL

public static final AccessibleState VERTICAL
指示此对象的方向为垂直方向。这通常与滚动条、滑块和进度条之类的对象关联。

另请参见：
VERTICAL, AccessibleRole.SCROLL_BAR, AccessibleRole.SLIDER, AccessibleRole.PROGRESS_BAR

HORIZONTAL

public static final AccessibleState HORIZONTAL
指示此对象的方向为水平方向。这通常与滚动条、滑块和进度条之类的对象关联。

另请参见：
HORIZONTAL, AccessibleRole.SCROLL_BAR, AccessibleRole.SLIDER, AccessibleRole.PROGRESS_BAR

SINGLE_LINE

public static final AccessibleState SINGLE_LINE
指示此（文本）对象只能包含单行文本

MULTI_LINE

public static final AccessibleState MULTI_LINE
指示此（文本）对象可以包含多行文本

TRANSIENT

public static final AccessibleState TRANSIENT
指示此对象是临时的。辅助技术不应将 PropertyChange 侦听器添加到具有临时状态的对象中 ，因为该对象永远不会生成任何事件。 创建临时对象的目的通常是为了应答 Java Accessibility 方法查询，否则不保持到底层对象的链接（例如，Swing 中的列表、表和树的下级对象，这里只有一个实际的 UI Component 为实际列表/表/树元素下的所有数据对象执行共享呈现职责）。

从以下版本开始：
1.5

MANAGES_DESCENDANTS

public static final AccessibleState MANAGES_DESCENDANTS
指示此对象负责管理其子组件。这通常用于带有大量子组件的树和表，并且只在需要对象时才创建对象，否则保持虚拟的状态。应用程序不应直接管理子组件。

从以下版本开始：
1.5

INDETERMINATE

public static final AccessibleState INDETERMINATE
指示对象状态是不确定的。例如，部分为粗体，部分不为粗体的选定文本。在这种情况下，与选定文本关联的属性是不确定的。

从以下版本开始：
1.5

TRUNCATED

public static final AccessibleState TRUNCATED
该状态指示文本被边界矩形截取，并且有些文本不显示在屏幕上。例如电子表格单元格中被单元格边界所截取的文本。

从以下版本开始：
1.5
构造方法详细信息

AccessibleState

protected AccessibleState(String key)
使用给定的与语言环境无关的键创建新的 AccessibleState。此方法不应该是公共方法。相反，它用于创建此文件中的常量以使其成为强类型的枚举。此类的子类应强制执行类似的策略。

String 键应该是针对状态的与语言环境无关的键。它不打算用作实际的 String 显示给用户。要获得本地化字符串，请使用 toDisplayString。

参数：
key - 状态的与语言环境无关的名称。
另请参见：
AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleStateSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleStateSet

java.lang.Object
    继承者  javax.accessibility.AccessibleStateSet

public class AccessibleStateSet
extends Object

AccessibleStateSet 类确定组件的状态集。组件的状态集是 AccessibleState 对象和描述的集合。例如，对象当前的总体状态，它是否是启用的，是否具有焦点等等。

另请参见：
AccessibleState

字段摘要
protected  Vector<AccessibleState> states
Vector 中的每个项表示一个 AccessibleState。
构造方法摘要
AccessibleStateSet()
创建新的空状态集。
AccessibleStateSet(AccessibleState[] states)
创建一个新状态，其初始状态集包含在传入的状态数组中。
方法摘要
boolean | add(AccessibleState state) 如果某个新状态不在当前状态集中，则将它添加到当前状态集中。
void | addAll(AccessibleState[] states) 将所有状态添加到现有状态集中。
void | clear() 从当前状态集中移除所有状态。
boolean | contains(AccessibleState state) 检查当前状态是否在状态集中。
boolean | remove(AccessibleState state) 从当前状态集中移除一个状态。
AccessibleState[] | toArray() 以 AccessibleState 数组形式返回当前状态集
String | toString() 使用默认语言环境创建表示状态集中所有状态的本地化 String。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

states

protected Vector<AccessibleState> states
Vector 中的每个项表示一个 AccessibleState。

另请参见：
add(javax.accessibility.AccessibleState),
addAll(javax.accessibility.AccessibleState[]),
remove(javax.accessibility.AccessibleState),
contains(javax.accessibility.AccessibleState),
toArray(),
clear()
构造方法详细信息

AccessibleStateSet

public AccessibleStateSet()
创建新的空状态集。

AccessibleStateSet

public AccessibleStateSet(AccessibleState[] states)
创建一个新状态，其初始状态集包含在传入的状态数组中。忽略重复项。

参数：
states - 描述状态集的 AccessibleState 数组。
方法详细信息

add

public boolean add(AccessibleState state)
如果某个新状态不在当前状态集中，则将它添加到当前状态集中。如果该状态已经在状态集中，则不更改状态集，并且返回值为 false。否则，将该状态添加到状态集中，并且返回值为 true。

参数：
state - 要添加到状态集中的状态
返回：
如果状态被添加到状态集中，则返回 true；如果不更改状态集，则返回 false

addAll

public void addAll(AccessibleState[] states)
将所有状态添加到现有状态集中。忽略重复项。

参数：
states - 描述状态集的 AccessibleState 数组。

remove

public boolean remove(AccessibleState state)
从当前状态集中移除一个状态。如果该状态不在状态集中，则不更改状态集，返回值将为 false。如果该状态在状态集中，则将它从状态集中移除，返回值将为 true。

参数：
state - 要从状态集中移除的状态
返回：
如果该状态在状态集中，则返回 true；如果不更改状态集，则返回 false

clear

public void clear()
从当前状态集中移除所有状态。

contains

public boolean contains(AccessibleState state)
检查当前状态是否在状态集中。

参数：
state - 状态
返回：
如果该状态在状态集中，则返回 true；否则返回 false

toArray

public AccessibleState[] toArray()
以 AccessibleState 数组形式返回当前状态集

返回：
包含当前状态的 AccessibleState 数组。

toString

public String toString()
使用默认语言环境创建表示状态集中所有状态的本地化 String。

覆盖：
类 Object 中的 toString
返回：
用逗号分隔的本地化 String
另请参见：
AccessibleBundle.toDisplayString(java.lang.String, java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleStreamable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleStreamable

public interface AccessibleStreamable

任何表示显示屏组件背后原始流的组件的 AccessibleContext 都必须实现 AccessibleStreamable 接口。 这些组件的示例有 HTML、位图图像和 MathML。 实现 AccessibleStreamable 的对象提供两项内容：该对象所支持的 MIME 类型的列表以及为每个 MIME 类型获取数据的流接口。

从以下版本开始：
1.5
另请参见：
AccessibleContext

方法摘要
DataFlavor[] | getMimeTypes() 返回此对象所支持的 MIME 类型的 DataFlavor 对象数组。
InputStream | getStream(DataFlavor flavor) 返回 DataFlavor 的 InputStream

方法详细信息

getMimeTypes

DataFlavor[] getMimeTypes()
返回此对象所支持的 MIME 类型的 DataFlavor 对象数组。

返回：
此对象所支持的 MIME 类型的 DataFlavor 对象数组。

getStream

InputStream getStream(DataFlavor flavor)
返回 DataFlavor 的 InputStream

参数：
flavor - DataFlavor
返回：
如果此 DataFlavor 的 ImputStream 存在，则返回它。否则，返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleTable

所有已知子接口：
AccessibleExtendedTable
所有已知实现类：
JTable.AccessibleJTable
public interface AccessibleTable

AccessibleTable 类描述了以二维表格式呈现数据的用户界面组件。

从以下版本开始：
1.3

方法摘要
Accessible | getAccessibleAt(int r, int c) 返回表中指定行和列处的 Accessible。
Accessible | getAccessibleCaption() 返回此表的标题。
int | getAccessibleColumnCount() 返回表中的列数。
Accessible | getAccessibleColumnDescription(int c) 返回表中指定列的描述文本。
int | getAccessibleColumnExtentAt(int r, int c) 返回表中指定行和列处 Accessible 占用的列数。
AccessibleTable | getAccessibleColumnHeader() 返回以 AccessibleTable 表示的列标题。
int | getAccessibleRowCount() 返回表中的行数。
Accessible | getAccessibleRowDescription(int r) 返回对表中指定行的描述。
int | getAccessibleRowExtentAt(int r, int c) 返回表中指定行和列处的 Accessible 所占用的行数。
AccessibleTable | getAccessibleRowHeader() 返回以 AccessibleTable 表示的行标题。
Accessible | getAccessibleSummary() 返回表的摘要描述。
int[] | getSelectedAccessibleColumns() 返回表中选中的列。
int[] | getSelectedAccessibleRows() 返回表中选中的行。
boolean | isAccessibleColumnSelected(int c) 返回一个布尔值，它指示指定列是否为选中的。
boolean | isAccessibleRowSelected(int r) 返回一个布尔值，它指示给定行是否已选中。
boolean | isAccessibleSelected(int r, int c) 返回一个布尔值，它指示在给定的行和列 accessible 是否选定。
void | setAccessibleCaption(Accessible a) 设置表的标题。
void | setAccessibleColumnDescription(int c, Accessible a) 设置表中指定列的描述文本。
void | setAccessibleColumnHeader(AccessibleTable table) 设置列标题。
void | setAccessibleRowDescription(int r, Accessible a) 设置表中指定行的描述文本。
void | setAccessibleRowHeader(AccessibleTable table) 设置行标题。
void | setAccessibleSummary(Accessible a) 设置表的摘要描述。

方法详细信息

getAccessibleCaption

Accessible getAccessibleCaption()
返回此表的标题。

返回：
表的标题

setAccessibleCaption

void setAccessibleCaption(Accessible a)
设置表的标题。

参数：
a - 表的标题

getAccessibleSummary

Accessible getAccessibleSummary()
返回表的摘要描述。

返回：
表的摘要描述

setAccessibleSummary

void setAccessibleSummary(Accessible a)
设置表的摘要描述。

参数：
a - 表的摘要描述

getAccessibleRowCount

int getAccessibleRowCount()
返回表中的行数。

返回：
该表中的行数

getAccessibleColumnCount

int getAccessibleColumnCount()
返回表中的列数。

返回：
该表中的列数

getAccessibleAt

Accessible getAccessibleAt(int r,
                           int c)
返回表中指定行和列处的 Accessible。

参数：
r - 表中基于零的行
c - 表中基于零的列
返回：
在指定行和列处的 Accessible

getAccessibleRowExtentAt

int getAccessibleRowExtentAt(int r,
                             int c)
返回表中指定行和列处的 Accessible 所占用的行数。

返回：
给定的 (row, column) 处的 Accessible 占用的行数

getAccessibleColumnExtentAt

int getAccessibleColumnExtentAt(int r,
                                int c)
返回表中指定行和列处 Accessible 占用的列数。

返回：
表中指定行和列处 Accessible 占用的列数

getAccessibleRowHeader

AccessibleTable getAccessibleRowHeader()
返回以 AccessibleTable 表示的行标题。

返回：
表示行标题的 AccessibleTable

setAccessibleRowHeader

void setAccessibleRowHeader(AccessibleTable table)
设置行标题。

参数：
table - 表示行标题的 AccessibleTable

getAccessibleColumnHeader

AccessibleTable getAccessibleColumnHeader()
返回以 AccessibleTable 表示的列标题。

返回：
表示列标题的 AccessibleTable

setAccessibleColumnHeader

void setAccessibleColumnHeader(AccessibleTable table)
设置列标题。

参数：
table - 表示列标题的 AccessibleTable

getAccessibleRowDescription

Accessible getAccessibleRowDescription(int r)
返回对表中指定行的描述。

参数：
r - 表的基于零的索引
返回：
行的描述

setAccessibleRowDescription

void setAccessibleRowDescription(int r,
                                 Accessible a)
设置表中指定行的描述文本。

参数：
r - 表的基于零的索引
a - 行的描述

getAccessibleColumnDescription

Accessible getAccessibleColumnDescription(int c)
返回表中指定列的描述文本。

参数：
c - 表中基于零的列
返回：
列的描述文本

setAccessibleColumnDescription

void setAccessibleColumnDescription(int c,
                                    Accessible a)
设置表中指定列的描述文本。

参数：
c - 表的基于零的列
a - 列的描述文本

isAccessibleSelected

boolean isAccessibleSelected(int r,
                             int c)
返回一个布尔值，它指示在给定的行和列 accessible 是否选定。

参数：
r - 表的基于零的行
c - 表的基于零的列
返回：
如果在该行和列选择了 accessible，则返回布尔值 true。否则，返回布尔值 false

isAccessibleRowSelected

boolean isAccessibleRowSelected(int r)
返回一个布尔值，它指示给定行是否已选中。

参数：
r - 表的基于零的行
返回：
如果指定行是选中的，则返回布尔值 true。否则，返回 false。

isAccessibleColumnSelected

boolean isAccessibleColumnSelected(int c)
返回一个布尔值，它指示指定列是否为选中的。

参数：
c - 表的基于零的列
返回：
如果指定列是选中的，则返回布尔值 true。否则，返回 false。

getSelectedAccessibleRows

int[] getSelectedAccessibleRows()
返回表中选中的行。

返回：
选中的行的数组，其中每个元素都是表中一个基于零的行

getSelectedAccessibleColumns

int[] getSelectedAccessibleColumns()
返回表中选中的列。

返回：
选中的列的数组，其中每个元素都是表中一个基于零的列
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleTableModelChange (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleTableModelChange

所有已知实现类：
JTable.AccessibleJTable.AccessibleJTableModelChange
public interface AccessibleTableModelChange

AccessibleTableModelChange 接口描述了表模型的更改。可以通过以下方法获得模型属性的更改：

  • public int getType()
  • public int getFirstRow();
  • public int getLastRow();
  • public int getFirstColumn();
  • public int getLastColumn();
getType() 所返回的模型更改类型为以下几种之一：
  • INSERT － 已插入一行或多行和/或一列或多列
  • UPDATE － 某些表数据已更改
  • DELETE － 已删除一行或多行和/或一列或多列
表的受影响区域可以通过其他四个方法确定，它们指定了行和列的范围

从以下版本开始：
1.3
另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleTable()

字段摘要
static int | DELETE 标识行和/或列的删除。
static int | INSERT 标识新行和/或新列的插入。
static int | UPDATE 标识现有数据的更改。
方法摘要
int | getFirstColumn() 返回已更改的第一列。
int | getFirstRow() 返回已更改的第一行。
int | getLastColumn() 返回已更改的最后一列。
int | getLastRow() 返回已更改的最后一行。
int | getType() 返回事件的类型

字段详细信息

INSERT

static final int INSERT
标识新行和/或新列的插入。

另请参见：
常量字段值

UPDATE

static final int UPDATE
标识现有数据的更改。

另请参见：
常量字段值

DELETE

static final int DELETE
标识行和/或列的删除。

另请参见：
常量字段值
方法详细信息

getType

int getType()
返回事件的类型

另请参见：
INSERT, UPDATE, DELETE

getFirstRow

int getFirstRow()
返回已更改的第一行。

getLastRow

int getLastRow()
返回已更改的最后一行。

getFirstColumn

int getFirstColumn()
返回已更改的第一列。

getLastColumn

int getLastColumn()
返回已更改的最后一列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleText (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleText

所有已知子接口：
AccessibleEditableText, AccessibleHypertext
所有已知实现类：
AbstractButton.AccessibleAbstractButton, JButton.AccessibleJButton, JCheckBox.AccessibleJCheckBox, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JLabel.AccessibleJLabel, JMenu.AccessibleJMenu, JMenuItem.AccessibleJMenuItem, JPasswordField.AccessibleJPasswordField, JRadioButton.AccessibleJRadioButton, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JSpinner.AccessibleJSpinner, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField, JToggleButton.AccessibleJToggleButton, ProgressMonitor.AccessibleProgressMonitor, TextArea.AccessibleAWTTextArea, TextComponent.AccessibleAWTTextComponent, TextField.AccessibleAWTTextField
public interface AccessibleText

所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。此接口为辅助技术提供了标准机制，以通过文本的内容、属性和空间位置来访问该文本。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleText 接口。如果返回值不为 null，则该对象支持此接口。

另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleText()

字段摘要
static int | CHARACTER 用于指示应获取的文本部分是一个字符的常量。
static int | SENTENCE 用于指示应获取的文本部分是一个语句的常量。
static int | WORD 用于指示应获取的文本部分是一个单词的常量。
方法摘要
String | getAfterIndex(int part, int index) 返回给定索引后面的 String。
String | getAtIndex(int part, int index) 返回给定索引处的 String。
String | getBeforeIndex(int part, int index) 返回给定索引前面的 String。
int | getCaretPosition() 返回插入符从 0 开始的偏移量。
AttributeSet | getCharacterAttribute(int i) 返回给定索引处给定字符的 AttributeSet
Rectangle | getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
int | getCharCount() 返回字符（有效索引）数
int | getIndexAtPoint(Point p) 给定本地坐标中的一点，返回在该点下的字符从 0 开始的索引。
String | getSelectedText() 返回选定的部分文本。
int | getSelectionEnd() 返回选定文本中的结束偏移量。
int | getSelectionStart() 返回选定文本中的起始偏移量。

字段详细信息

CHARACTER

static final int CHARACTER
用于指示应获取的文本部分是一个字符的常量。

另请参见：
getAtIndex(int, int),
getAfterIndex(int, int),
getBeforeIndex(int, int),
常量字段值

WORD

static final int WORD
用于指示应获取的文本部分是一个单词的常量。

另请参见：
getAtIndex(int, int),
getAfterIndex(int, int),
getBeforeIndex(int, int),
常量字段值

SENTENCE

static final int SENTENCE
用于指示应获取的文本部分是一个语句的常量。 句子是表示陈述、疑问、命令、希望、感叹或执行动作的单词字符串。在 English 语言环境下，该字符串通常以大写字母开始，以适当结束标点符号（如句号、问号或感叹号）结束。其他语言环境使用不同的大写和/或标点符号。

另请参见：
getAtIndex(int, int),
getAfterIndex(int, int),
getBeforeIndex(int, int),
常量字段值
方法详细信息

getIndexAtPoint

int getIndexAtPoint(Point p)
给定本地坐标中的一点，返回在该点下的字符从 0 开始的索引。如果该点无效，则此方法返回 -1。

参数：
p - 本地坐标中的点
返回：
点 p 处字符从 0 开始的索引；如果该点无效，则返回 -1。

getCharacterBounds

Rectangle getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。以本地坐标形式返回边界。如果索引无效，则返回一个空的矩形。

参数：
i - String 中的索引
返回：
字符边界框的屏幕坐标；如果索引无效，则返回一个空矩形。

getCharCount

int getCharCount()
返回字符（有效索引）数

返回：
字符数

getCaretPosition

int getCaretPosition()
返回插入符从 0 开始的偏移量。 注：这表示插入符的右边与偏移量有相同的索引值（插入符在两个字符之间）。

返回：
插入符从 0 开始的偏移量。

getAtIndex

String getAtIndex(int part,
                  int index)
返回给定索引处的 String。

参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getAfterIndex

String getAfterIndex(int part,
                     int index)
返回给定索引后面的 String。

参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getBeforeIndex

String getBeforeIndex(int part,
                      int index)
返回给定索引前面的 String。

参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getCharacterAttribute

AttributeSet getCharacterAttribute(int i)
返回给定索引处给定字符的 AttributeSet

参数：
i - 文本中从 0 开始的索引
返回：
字符的 AttributeSet

getSelectionStart

int getSelectionStart()
返回选定文本中的起始偏移量。如果没有选定的文本，但有一个插入符，则起始偏移量和结束偏移量将是相同的。

返回：
选定文本起始处的索引

getSelectionEnd

int getSelectionEnd()
返回选定文本中的结束偏移量。如果没有选定的文本，但有一个插入符，则起始偏移量和结束偏移量将是相同的。

返回：
选定文本结尾处的索引

getSelectedText

String getSelectedText()
返回选定的部分文本。

返回：
选定文本的 String 部分
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleTextSequence (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
类 AccessibleTextSequence

java.lang.Object
    继承者  javax.accessibility.AccessibleTextSequence

public class AccessibleTextSequence
extends Object

此类汇集文本区域的关键细节。此类供 AccessibleExtendedText 类的实现者使用，以返回所请求的三项内容：String、较大文本（String 取自该文本）正文中的起始和结束索引/偏移量。

另请参见：
AccessibleExtendedText

字段摘要
int | endIndex 文本序列的结束索引
int | startIndex
String | text 文本
构造方法摘要
AccessibleTextSequence(int start, int end, String txt)
构造带有给定参数的 AccessibleTextSequence。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

startIndex

public int startIndex

endIndex

public int endIndex
文本序列的结束索引

text

public String text
文本

构造方法详细信息

AccessibleTextSequence

public AccessibleTextSequence(int start,
                              int end,
                              String txt)
构造带有给定参数的 AccessibleTextSequence。

参数：
start - 文本区域开始处的索引
end - 文本区域结束处的索引
txt - 此文本区域所共享的 String
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccessibleValue (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.accessibility
接口 AccessibleValue

所有已知实现类：
AbstractButton.AccessibleAbstractButton, Button.AccessibleAWTButton, Checkbox.AccessibleAWTCheckbox, CheckboxMenuItem.AccessibleAWTCheckboxMenuItem, JButton.AccessibleJButton, JCheckBox.AccessibleJCheckBox, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JInternalFrame.AccessibleJInternalFrame, JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon, JMenu.AccessibleJMenu, JMenuItem.AccessibleJMenuItem, JProgressBar.AccessibleJProgressBar, JRadioButton.AccessibleJRadioButton, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JScrollBar.AccessibleJScrollBar, JSlider.AccessibleJSlider, JSpinner.AccessibleJSpinner, JSplitPane.AccessibleJSplitPane, JToggleButton.AccessibleJToggleButton, Menu.AccessibleAWTMenu, MenuItem.AccessibleAWTMenuItem, PopupMenu.AccessibleAWTPopupMenu, Scrollbar.AccessibleAWTScrollBar
public interface AccessibleValue

任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。此接口为辅助技术提供了标准机制，以确定和设置数字值，以及获取最小值和最大值。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext.getAccessibleValue() 方法，能够确定该对象是否支持 AccessibleValue 接口。如果返回值不为 null，则该对象支持此接口。

另请参见：
Accessible, Accessible.getAccessibleContext(), AccessibleContext, AccessibleContext.getAccessibleValue()

方法摘要
Number | getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | getMinimumAccessibleValue() 以 Number 形式设置此对象的最小值。
boolean | setCurrentAccessibleValue(Number n) 以 Number 形式设置此对象的值。

方法详细信息

getCurrentAccessibleValue

Number getCurrentAccessibleValue()
以 Number 形式获取此对象的值。如果没有设置值，则返回值为 null。

返回：
对象的值
另请参见：
setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

boolean setCurrentAccessibleValue(Number n)
以 Number 形式设置此对象的值。

返回：
如果设置了值，则返回 True，否则返回 False
另请参见：
getCurrentAccessibleValue()

getMinimumAccessibleValue

Number getMinimumAccessibleValue()
以 Number 形式设置此对象的最小值。

返回：
对象的最小值，如果此对象没有最小值，则返回 null
另请参见：
getMaximumAccessibleValue()

getMaximumAccessibleValue

Number getMaximumAccessibleValue()
以 Number 形式获取此对象的最大值。

返回：
对象的最大值，如果此对象没有最大值，则返回 null
另请参见：
getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.accessibility (Java 2 Platform SE 6)

 javax.accessibility
接口
Accessible
AccessibleAction
AccessibleComponent
AccessibleEditableText
AccessibleExtendedComponent
AccessibleExtendedTable
AccessibleExtendedText
AccessibleHypertext
AccessibleIcon
AccessibleKeyBinding
AccessibleSelection
AccessibleStreamable
AccessibleTable
AccessibleTableModelChange
AccessibleText
AccessibleValue
类
AccessibleAttributeSequence
AccessibleBundle
AccessibleContext
AccessibleHyperlink
AccessibleRelation
AccessibleRelationSet
AccessibleResourceBundle
AccessibleRole
AccessibleState
AccessibleStateSet
AccessibleTextSequence


javax.accessibility (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.accessibility

定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

请参见：
描述

接口摘要
Accessible | Accessible 接口是可访问性包的主接口。
AccessibleAction | 任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleComponent | 屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
AccessibleEditableText | 在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
AccessibleExtendedComponent | 屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。
AccessibleExtendedTable | AccessibleExtendedTable 类提供了有关以二维表的格式呈现数据的用户界面组件的扩展信息。
AccessibleExtendedText | AccessibleExtendedText 接口包含 AccessibleText 接口所未提供的其他方法 应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleExtendedText 接口。
AccessibleHypertext | AccessibleHypertext 类是在显示器上显示超文本信息的所有类的基类。
AccessibleIcon | 任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon 接口。
AccessibleKeyBinding | 任何具有键盘绑定（例如可用于选择对象的键盘助记符和/或键盘快捷键）功能的对象都应支持 AccessibleKeyBinding 接口。
AccessibleSelection | 此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。
AccessibleStreamable | 任何表示显示屏组件背后原始流的组件的 AccessibleContext 都必须实现 AccessibleStreamable 接口。
AccessibleTable | AccessibleTable 类描述了以二维表格式呈现数据的用户界面组件。
AccessibleTableModelChange | AccessibleTableModelChange 接口描述了表模型的更改。
AccessibleText | 所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleValue | 任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。

类摘要
AccessibleAttributeSequence | 此类汇集共享相同连续属性集的文本的跨度，以及该属性集。
AccessibleBundle | 用于维护强类型枚举的基类。
AccessibleContext | AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleHyperlink | Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。
AccessibleRelation | AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。
AccessibleRelationSet | AccessibleRelationSet 类确定了组件的关系集。
AccessibleResourceBundle | 已过时。 从 Java Platform 的 1.3 版开始，此类已废弃。
AccessibleRole | AccessibleRole 类确定组件的职责。
AccessibleState | AccessibleState 类描述了组件的特殊状态。
AccessibleStateSet | AccessibleStateSet 类确定组件的状态集。
AccessibleTextSequence | 此类汇集文本区域的关键细节。

软件包 javax.accessibility 的描述

定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。如果 Java 应用程序完全支持 Java Accessibility API，则它应该与屏幕读取器、屏幕放大器这样的辅助技术保持兼容和友好。使用完全支持 Java Accessibility API 的 Java 应用程序，将不再需要离屏模型的屏幕读取器 ，因为该 API 提供了离屏模型中通常所包含的所有信息。

Java Accessibility API 包由 8 个 Java 编程语言接口和 6 个 Java 编程语言类组成。以下是对这些接口和类的描述。

Interface Accessible

Interface Accessible 是 Java Accessibility API 的主接口。所有支持 Java Accessibility API 的组件都必须实现此接口。它包含单个方法 getAccessibleContext，此方法返回 AccessibleContext 类的一个实例。Sun 认为，如果 Java 应用程序要与辅助技术兼容，则对于作为该程序用户界面的一部分的每个对象来说，实现此接口是绝对的最低需求。

Class AccessibleContext

AccessibleContext 表示所有可访问对象所返回的最少信息，它是通过调用实现 Accessible 接口的对象上的 getAccessibleContext 方法获得的。此信息包括对象的可访问名称、描述、职责和状态，以及关于该对象的父对象和子对象的信息。此外，还包括对 JavaBeans TM 属性更改的支持，从而当可访问的属性值发生更改时，辅助技术能够获悉。AccessibleContext 还包含用于获取更多关于组件的特定可访问信息的方法。如果组件支持它，则这些方法将返回实现以下一个或多个接口的对象：
  • AccessibleAction － 可以执行一个或多个动作的对象。此接口为辅助技术提供了标准机制，以确定这些动作并通知对象执行它们。当调用 AccessibleContext 上的 getAccessibleAction 方法时，任何可以操作的对象都应返回实现此接口的对象。
  • AccessibleComponent － 具有图形表示形式的对象。此接口为辅助技术提供了标准机制，以确定和设置对象的图形表示形式。当调用 AccessibleContext 上的 getAccessibleComponent 方法时，任何在屏幕上呈现的对象都应返回实现此接口的对象。
  • AccessibleSelection － 允许选择其子对象的对象。此接口为辅助技术提供了标准机制，以确定当前选定的子对象，并修改选择设置。当调用 AccessibleContext 上的 getAccessibleSelection 方法时，任何具有可选子对象的对象都应返回实现此接口的对象。
  • AccessibleText － 在显示器上显示可编辑文本信息的对象。此接口为辅助技术提供了标准机制，用于通过文本的内容、属性和空间位置来访问该文本。当调用 AccessibleContext 上的 getAccessibleText 方法时，任何包含可编辑文本的对象都应返回实现此接口的对象。
  • AccessibleHypertext － 在显示器上显示超文本信息的对象。此接口为辅助技术提供了标准机制，用于通过超文本的内容、属性和空间位置来访问该超文本。当调用 AccessibleContext 上的 getAccessibleText 方法时，任何包含超文本的对象都应返回实现此接口的对象。
  • AccessibleValue － 支持数字值的对象。此接口为辅助技术提供了标准机制，以确定和设置对象的当前值，以及最小值和最大值。当调用 AccessibleContext 上的 getAccessibleValue 方法时，任何支持数字值的对象都应返回实现此接口的对象。

Class AccessibleRole

此类封装了 Accessible 对象职责，该类通过调用 AccessibleContext 上的 getAccessibleRole 方法获得。可访问的职责包括 “复选框”、“菜单项”、“面板”等等。这些职责由此类中的常量（如 AccessibleRole.CHECK_BOX、AccessibleRole.MENU_ITEM 和 AccessibleRole.PANEL）来标识。此类中的常量存在一个公共对象职责的强类型的枚举。我们有意忽略了此类的公共构造方法，应用程序应使用此类的一个常量。虽然此类预定义了一个大的标准职责列表，但它是可扩展的，这样可以在将来添加其他程序员所定义的职责，而无需修改基类。

Class AccessibleState

此类封装了 Accessible 对象的特殊状态。可访问的状态包括 "Armed"、"Busy"、"Checked"、"Focused"等等。这些职责由此类的常量（如 AccessibleState.ARMED、AccessibleState.BUSY、AccessibleState.CHECKED 和 AccessibleState.FOCUSED）来标识。Accessible 对象的所有状态的集合称为 AccessibleStateSet，它可以通过调用 AccessibleContext 上的 getAccessibleStateSet 方法获得。

此类中的常量存在一个公共对象职责的强类型的枚举。我们有意忽略了此类的公共构造方法，应用程序应使用此类的一个常量。虽然此类预定义了一个大的标准职责列表，但它是可扩展的，这样可以在将来添加其他程序员所定义的职责，而无需修改基类。

Class AccessibleStateSet

此类封装了 Accessible 对象的状态集合，此类通过调用 AccessibleContext 上的 getAccessibleStateSet 方法获得。因为一个对象可能有多个状态（例如，它可能同时处于 "Checked" 和 "Focused" 状态），因此此类需要封装这些状态的集合。此类中的方法可以在状态集上检索单个 AccessibleStates 。

Class AccessibleBundle

此类用于维护强类型枚举。它是 AccessibleRole 和 AccessibleState 类的超类。程序员一般不与此类直接进行交互，而是使用 AccessibleRole 和 AccessibleState 类。

Interface AccessibleAction

任何能够执行一个或多个动作的对象都应支持 AccessibleAction 接口。此接口为辅助技术提供了标准机制，以确定这些动作并通知对象执行它们。任何可以操作的对象都应支持此接口。

应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 上的 getAccessibleAction 方法，能够确定该对象是否支持 AccessibleAction 接口。如果返回值不为 null，则该对象支持此接口。

Interface AccessibleComponent

任何在屏幕上呈现的对象都应支持 AccessibleComponent 接口。此接口为辅助技术提供了标准机制，以确定和设置对象的图形表示形式。

应用程序通过先调用某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 上的 getAccessibleComponent 方法，能够确定该对象是否支持 AccessibleComponent 接口。如果返回值不为 null，则该对象支持此接口。

Interface AccessibleSelection

AccessibleSelection 接口为辅助技术提供了标准机制，以确定当前选定了哪些子对象，并修改选择设置。任何具有可选子对象的对象都应支持 AccessibleSelection 接口。

应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 上的 getAccessibleSelection 方法，能够确定该对象是否支持 AccessibleSelection 接口。如果返回值不为 null，则该对象支持此接口。

Interface AccessibleText

AccessibleText 接口是针对生成丰富的、可编辑的文本 Accessible 的协定。并不是屏幕上显示的所有文本都是富文本和可编辑的（例如对于按钮、标签和菜单中所包含的文本，用户就不能对其进行操作）。但是，如果包含可编辑文本的对象要与辅助技术进行互操作，则它们必须实现 AccessibleText 接口。

此接口支持在像素坐标和给定像素坐标处的文本之间进行转换，以及检索文本中给定位置处、给定位置前或给定位置后的字母、单词和句子。此接口支持对文本中给定位置处的字符属性（字体、字体大小、样式，等等）进行检索，以及获得选中的文本（如果有）、文本长度和文本插入符位置。

应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 getAccessibleText 方法，能够确定该对象是否支持 AccessibleText 接口。如果返回值不为 null，则该对象支持此接口。

Interface AccessibleHypertext

任何在显示器上显示超文本信息的对象都应支持 AccessibleHypertext 接口。此接口为辅助技术提供了标准机制，用于通过文本的内容、属性和空间位置来访问该文本。它还提供了操作超链接的标准机制。应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleHypertext 接口。如果返回值是一个扩展了 AccessibleHypertext 的类，则该对象支持 AccessibleHypertext。

Interface AccessibleHyperlink

超链接对象应支持 AccessibleHyperlink 接口。通过调用 AccessibleHypertext 对象上的 getLink 方法将返回实现此接口的对象。

Interface AccessibleValue

任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。此接口为辅助技术提供了标准机制，以确定和设置数字值，以及获取最小值和最大值。

应用程序通过先获取某对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 getAccessibleValue 方法，能够确定该对象是否支持 AccessibleValue 接口。如果返回值不为 null，则该对象支持此接口。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.accessibility 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.accessibility 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.accessibility.AccessibleAttributeSequence
    • javax.accessibility.AccessibleBundle
      • javax.accessibility.AccessibleRelation
      • javax.accessibility.AccessibleRole
      • javax.accessibility.AccessibleState
    • javax.accessibility.AccessibleContext
    • javax.accessibility.AccessibleHyperlink (implements javax.accessibility.AccessibleAction)
    • javax.accessibility.AccessibleRelationSet
    • javax.accessibility.AccessibleStateSet
    • javax.accessibility.AccessibleTextSequence
    • java.util.ResourceBundle
      • java.util.ListResourceBundle
        • javax.accessibility.AccessibleResourceBundle

接口分层结构

  • javax.accessibility.Accessible
  • javax.accessibility.AccessibleAction
  • javax.accessibility.AccessibleComponent
    • javax.accessibility.AccessibleExtendedComponent
  • javax.accessibility.AccessibleExtendedText
  • javax.accessibility.AccessibleIcon
  • javax.accessibility.AccessibleKeyBinding
  • javax.accessibility.AccessibleSelection
  • javax.accessibility.AccessibleStreamable
  • javax.accessibility.AccessibleTable
    • javax.accessibility.AccessibleExtendedTable
  • javax.accessibility.AccessibleTableModelChange
  • javax.accessibility.AccessibleText
    • javax.accessibility.AccessibleEditableText
    • javax.accessibility.AccessibleHypertext
  • javax.accessibility.AccessibleValue
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.accessibility 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.accessibility
的使用

使用 javax.accessibility 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleComponent
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleRole
AccessibleRole 类确定组件的职责。
AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。

java.awt 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleAction
任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleComponent
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleRole
AccessibleRole 类确定组件的职责。
AccessibleSelection
此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。
AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。
AccessibleText
所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleValue
任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。

javax.accessibility 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleAction
任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleBundle
用于维护强类型枚举的基类。
AccessibleComponent
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleEditableText
在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
AccessibleHyperlink
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。
AccessibleIcon
任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon 接口。
AccessibleKeyBinding
任何具有键盘绑定（例如可用于选择对象的键盘助记符和/或键盘快捷键）功能的对象都应支持 AccessibleKeyBinding 接口。
AccessibleRelation
AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。
AccessibleRelationSet
AccessibleRelationSet 类确定了组件的关系集。
AccessibleRole
AccessibleRole 类确定组件的职责。
AccessibleSelection
此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。
AccessibleState
AccessibleState 类描述了组件的特殊状态。
AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。
AccessibleTable
AccessibleTable 类描述了以二维表格式呈现数据的用户界面组件。
AccessibleText
所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleTextSequence
此类汇集文本区域的关键细节。
AccessibleValue
任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。

javax.swing 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleAction
任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleComponent
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleEditableText
在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
AccessibleExtendedComponent
屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。
AccessibleExtendedTable
AccessibleExtendedTable 类提供了有关以二维表的格式呈现数据的用户界面组件的扩展信息。
AccessibleExtendedText
AccessibleExtendedText 接口包含 AccessibleText 接口所未提供的其他方法 应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleExtendedText 接口。
AccessibleHyperlink
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。
AccessibleHypertext
AccessibleHypertext 类是在显示器上显示超文本信息的所有类的基类。
AccessibleIcon
任何具有关联图标（例如按钮）的对象都应支持 AccessibleIcon 接口。
AccessibleKeyBinding
任何具有键盘绑定（例如可用于选择对象的键盘助记符和/或键盘快捷键）功能的对象都应支持 AccessibleKeyBinding 接口。
AccessibleRelationSet
AccessibleRelationSet 类确定了组件的关系集。
AccessibleRole
AccessibleRole 类确定组件的职责。
AccessibleSelection
此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。
AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。
AccessibleTable
AccessibleTable 类描述了以二维表格式呈现数据的用户界面组件。
AccessibleTableModelChange
AccessibleTableModelChange 接口描述了表模型的更改。
AccessibleText
所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleTextSequence
此类汇集文本区域的关键细节。
AccessibleValue
任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。

javax.swing.colorchooser 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。

javax.swing.plaf 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。

javax.swing.plaf.basic 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。

javax.swing.plaf.metal 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。

javax.swing.plaf.multi 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。

javax.swing.table 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleAction
任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleComponent
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleExtendedComponent
屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。
AccessibleRole
AccessibleRole 类确定组件的职责。
AccessibleSelection
此 AccessibleSelection 接口提供了辅助技术的标准机制，以确定当前选定了哪些子级，以及修改选项集合。
AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。
AccessibleText
所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleValue
任何支持数字值的对象（例如滚动条）都应支持 AccessibleValue 接口。

javax.swing.text 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleAction
任何能够执行一个或多个动作的对象都应该支持 AccessibleAction 接口。
AccessibleComponent
屏幕上呈现的任何对象都应该支持 AccessibleComponent 接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。
AccessibleEditableText
在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
AccessibleExtendedComponent
屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。
AccessibleExtendedText
AccessibleExtendedText 接口包含 AccessibleText 接口所未提供的其他方法 应用程序通过先获取某个对象的 AccessibleContext（参见 Accessible），然后调用 AccessibleContext 的 AccessibleContext.getAccessibleText() 方法，能够确定该对象是否支持 AccessibleExtendedText 接口。
AccessibleRole
AccessibleRole 类确定组件的职责。
AccessibleStateSet
AccessibleStateSet 类确定组件的状态集。
AccessibleText
所有在显示器上显示文本信息的类都应该实现 AccessibleText 接口。
AccessibleTextSequence
此类汇集文本区域的关键细节。

javax.swing.text.html 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。
AccessibleContext
AccessibleContext 表示所有可访问对象返回的最少信息。

javax.swing.tree 使用的 javax.accessibility 中的类
Accessible
Accessible 接口是可访问性包的主接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleAttributeSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleAttributeSequence
的使用

没有 javax.accessibility.AccessibleAttributeSequence 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleEditableText 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleEditableText
的使用

使用 AccessibleEditableText 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.accessibility 中 AccessibleEditableText 的使用

返回 AccessibleEditableText 的 javax.accessibility 中的方法
 AccessibleEditableText AccessibleContext.getAccessibleEditableText()
获取与在显示器上显示可编辑文本的此对象关联的 AccessibleEditableText。

javax.swing 中 AccessibleEditableText 的使用

实现 AccessibleEditableText 的 javax.swing 中的类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

javax.swing.text 中 AccessibleEditableText 的使用

实现 AccessibleEditableText 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleEditableText 的 javax.swing.text 中的方法
 AccessibleEditableText JTextComponent.AccessibleJTextComponent.getAccessibleEditableText()
返回此文本组件的 AccessibleEditableText 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleExtendedTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleExtendedTable
的使用

使用 AccessibleExtendedTable 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AccessibleExtendedTable 的使用

实现 AccessibleExtendedTable 的 javax.swing 中的类
protected  class JTable.AccessibleJTable
此类实现对 JTable 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleExtendedText 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleExtendedText
的使用

使用 AccessibleExtendedText 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 AccessibleExtendedText 的使用

实现 AccessibleExtendedText 的 javax.swing 中的类
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。

javax.swing.text 中 AccessibleExtendedText 的使用

实现 AccessibleExtendedText 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleHyperlink 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleHyperlink
的使用

使用 AccessibleHyperlink 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleHyperlink 的使用

返回 AccessibleHyperlink 的 javax.accessibility 中的方法
 AccessibleHyperlink AccessibleHypertext.getLink(int linkIndex)
返回此 Hypertext 文档中第 n 个链接。

javax.swing 中 AccessibleHyperlink 的使用

javax.swing 中 AccessibleHyperlink 的子类
 class JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

返回 AccessibleHyperlink 的 javax.swing 中的方法
 AccessibleHyperlink JEditorPane.JEditorPaneAccessibleHypertextSupport.getLink(int linkIndex)
返回超链接数组中该索引处的链接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleHypertext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleHypertext
的使用

使用 AccessibleHypertext 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AccessibleHypertext 的使用

实现 AccessibleHypertext 的 javax.swing 中的类
protected  class JEditorPane.JEditorPaneAccessibleHypertextSupport
AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleIcon 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleIcon
的使用

使用 AccessibleIcon 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleIcon 的使用

返回 AccessibleIcon 的 javax.accessibility 中的方法
 AccessibleIcon[] AccessibleContext.getAccessibleIcon()
获取与此对象关联的具有一个或多个相关图标的 AccessibleIcons

javax.swing 中 AccessibleIcon 的使用

实现 AccessibleIcon 的 javax.swing 中的类
protected  class ImageIcon.AccessibleImageIcon
此类实现 ImageIcon 类的可访问性支持。

返回 AccessibleIcon 的 javax.swing 中的方法
AccessibleIcon[] | JList.AccessibleJList.AccessibleJListChild.getAccessibleIcon() 返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。
AccessibleIcon[] | AbstractButton.AccessibleAbstractButton.getAccessibleIcon() 获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
AccessibleIcon[] | JLabel.AccessibleJLabel.getAccessibleIcon() 获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleKeyBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleKeyBinding
的使用

使用 AccessibleKeyBinding 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleKeyBinding 的使用

返回 AccessibleKeyBinding 的 javax.accessibility 中的方法
 AccessibleKeyBinding AccessibleExtendedComponent.getAccessibleKeyBinding()
返回与此对象关联的键绑定。

javax.swing 中 AccessibleKeyBinding 的使用

返回 AccessibleKeyBinding 的 javax.swing 中的方法
AccessibleKeyBinding | AbstractButton.AccessibleAbstractButton.getAccessibleKeyBinding() 返回与此对象有关的键绑定。
AccessibleKeyBinding | JLabel.AccessibleJLabel.getAccessibleKeyBinding() 返回与此对象关联的键绑定
AccessibleKeyBinding | JComponent.AccessibleJComponent.getAccessibleKeyBinding() 返回与此对象关联的键绑定

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleRelation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleRelation
的使用

使用 AccessibleRelation 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 AccessibleRelation 的使用

类型参数类型为 AccessibleRelation 的 javax.accessibility 中的字段
protected  Vector<AccessibleRelation> AccessibleRelationSet.relations
Vector 中的每个项表示一个 AccessibleRelation。

返回 AccessibleRelation 的 javax.accessibility 中的方法
AccessibleRelation | AccessibleRelationSet.get(String key) 返回与指定键匹配的关系。
AccessibleRelation[] | AccessibleRelationSet.toArray() 返回作为 AccessibleRelation 数组的当前关系集

参数类型为 AccessibleRelation 的 javax.accessibility 中的方法
boolean | AccessibleRelationSet.add(AccessibleRelation relation) 将新关系添加到当前关系集中。
void | AccessibleRelationSet.addAll(AccessibleRelation[] relations) 将所有关系添加到现有关系集中。
boolean | AccessibleRelationSet.remove(AccessibleRelation relation) 从当前关系集中移除一个关系。

参数类型为 AccessibleRelation 的 javax.accessibility 中的构造方法
AccessibleRelationSet(AccessibleRelation[] relations)
创建具有传入的关系数组中所包含的初始关系集的新关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleResourceBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleResourceBundle
的使用

没有 javax.accessibility.AccessibleResourceBundle 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleRole 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleRole
的使用

使用 AccessibleRole 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleRole 的使用

返回 AccessibleRole 的 java.applet 中的方法
 AccessibleRole Applet.AccessibleApplet.getAccessibleRole()
获取此对象的职责。

java.awt 中 AccessibleRole 的使用

返回 AccessibleRole 的 java.awt 中的方法
AccessibleRole | Button.AccessibleAWTButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Checkbox.AccessibleAWTCheckbox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Choice.AccessibleAWTChoice.getAccessibleRole() 获取此对象的职责。
AccessibleRole | List.AccessibleAWTList.getAccessibleRole() 获取此对象的职责。
AccessibleRole | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleRole() 获取此对象的职责。
AccessibleRole | ScrollPane.AccessibleAWTScrollPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Scrollbar.AccessibleAWTScrollBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | TextComponent.AccessibleAWTTextComponent.getAccessibleRole() 获取此对象的职责。
AccessibleRole | MenuBar.AccessibleAWTMenuBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Panel.AccessibleAWTPanel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Canvas.AccessibleAWTCanvas.getAccessibleRole() 获取此对象的职责。
AccessibleRole | PopupMenu.AccessibleAWTPopupMenu.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Menu.AccessibleAWTMenu.getAccessibleRole() 获取此对象的职责。
AccessibleRole | MenuItem.AccessibleAWTMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | MenuComponent.AccessibleAWTMenuComponent.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Dialog.AccessibleAWTDialog.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Label.AccessibleAWTLabel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Frame.AccessibleAWTFrame.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Window.AccessibleAWTWindow.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Component.AccessibleAWTComponent.getAccessibleRole() 获取此对象的职责。

javax.accessibility 中 AccessibleRole 的使用

声明为 AccessibleRole 的 javax.accessibility 中的字段
static AccessibleRole | AccessibleRole.ALERT 可用于就某事向用户报警的对象。
static AccessibleRole | AccessibleRole.AWT_COMPONENT 一个 AWT 组件，但关于它的其他信息都是未知的。
static AccessibleRole | AccessibleRole.CANVAS 可用于绘制和捕获事件的对象。
static AccessibleRole | AccessibleRole.CHECK_BOX 可以被选中或不被选中的选项，它针对当前状态提供了单独的指示符。
static AccessibleRole | AccessibleRole.COLOR_CHOOSER 允许用户选择颜色的专用窗格。
static AccessibleRole | AccessibleRole.COLUMN_HEADER 数据列的头。
static AccessibleRole | AccessibleRole.COMBO_BOX 用户可以从中进行选择的选项列表。
static AccessibleRole | AccessibleRole.DATE_EDITOR DATE_EDITOR 是允许用户编辑 java.util.Date 和 java.util.Time 对象的组件。
static AccessibleRole | AccessibleRole.DESKTOP_ICON DESKTOP_PANE 中的图标化的内部 frame。
static AccessibleRole | AccessibleRole.DESKTOP_PANE 支持内部窗体和这些内部窗体的图标化形式的窗格。
static AccessibleRole | AccessibleRole.DIALOG 带有标题栏和边框的顶层窗口。
static AccessibleRole | AccessibleRole.DIRECTORY_PANE 允许用户在目录内容中导航并进行选择的窗格。
static AccessibleRole | AccessibleRole.EDITBAR 该职责表示充当一个求值公式的对象。
static AccessibleRole | AccessibleRole.FILE_CHOOSER 一个专用的对话框，它显示目录中的文件，并允许用户选择文件、浏览不同的目录，或指定一个文件名。
static AccessibleRole | AccessibleRole.FILLER 填补用户界面空间的对象。
static AccessibleRole | AccessibleRole.FONT_CHOOSER FONT_CHOOSER 是允许用户选择各种字体属性的组件。
static AccessibleRole | AccessibleRole.FOOTER 文本脚注
static AccessibleRole | AccessibleRole.FRAME 带有标题栏、边框、菜单栏等的顶层窗口。
static AccessibleRole | AccessibleRole.GLASS_PANE 一个窗格，保证此窗格在其所有下级窗格之上进行绘制。
static AccessibleRole | AccessibleRole.GROUP_BOX GROUP_BOX 是包含它周围的边框及其内部组件的简单容器。
static AccessibleRole | AccessibleRole.HEADER 文本标题
static AccessibleRole | AccessibleRole.HTML_CONTAINER 包含一起能表示 HTML 内容的 Accessible 集合的对象。
static AccessibleRole | AccessibleRole.HYPERLINK 超文本锚
static AccessibleRole | AccessibleRole.ICON 一个固定大小的小图片，通常用于装饰组件。
static AccessibleRole | AccessibleRole.INTERNAL_FRAME 通过桌面窗格剪切的类似于窗体的对象。
static AccessibleRole | AccessibleRole.LABEL 用于在界面中显示图标或短字符串的对象。
static AccessibleRole | AccessibleRole.LAYERED_PANE 允许其子级在各层中进行绘制的专用窗格，提供堆栈顺序的形式。
static AccessibleRole | AccessibleRole.LIST 呈现给用户一个对象列表的对象，它还允许用户从中选择一个或多个对象。
static AccessibleRole | AccessibleRole.LIST_ITEM 呈现列表元素的对象。
static AccessibleRole | AccessibleRole.MENU 通常出现在菜单栏中的对象，它包含一个用户可以从中选择的动作列表。
static AccessibleRole | AccessibleRole.MENU_BAR 通常被绘制在应用程序的主对话框顶部的对象，它包含用户可以从中进行选择的菜单列表。
static AccessibleRole | AccessibleRole.MENU_ITEM 通常包含在菜单中的对象，该对象呈现用户可以选择的动作。
static AccessibleRole | AccessibleRole.OPTION_PANE 主要用于 DIALOG 内部的专用窗格
static AccessibleRole | AccessibleRole.PAGE_TAB 作为页选项卡列表子级的对象。
static AccessibleRole | AccessibleRole.PAGE_TAB_LIST 通过所提供的某种机制一次可呈现一系列窗格（或页选项卡）的对象。
static AccessibleRole | AccessibleRole.PANEL 通常用于对对象进行分组的一般容器。
static AccessibleRole | AccessibleRole.PARAGRAPH 文本段落
static AccessibleRole | AccessibleRole.PASSWORD_TEXT 用于密码或文本内容不显示给用户的其他地方的文本对象。
static AccessibleRole | AccessibleRole.POPUP_MENU 一个临时窗口，通常用于为用户提供选项列表，当用户选中其中某个选项后，此窗口隐藏。
static AccessibleRole | AccessibleRole.PROGRESS_BAR 用于指示某项任务已完成多少的对象。
static AccessibleRole | AccessibleRole.PROGRESS_MONITOR 该职责表示监视某个操作进度的对象。
static AccessibleRole | AccessibleRole.PUSH_BUTTON 用户可以操作以通知应用程序执行某任务的对象。
static AccessibleRole | AccessibleRole.RADIO_BUTTON 一个专用复选框，当选中此复选框时，将导致取消选中同一组中的其他单选按钮。
static AccessibleRole | AccessibleRole.ROOT_PANE 一个专用窗格，带有玻璃窗格和作为其子窗格的分层窗格。
static AccessibleRole | AccessibleRole.ROW_HEADER 数据行的头。
static AccessibleRole | AccessibleRole.RULER RULER 是用于测量距离的对象
static AccessibleRole | AccessibleRole.SCROLL_BAR 通常用于允许用户逐渐查看大量数据的对象。
static AccessibleRole | AccessibleRole.SCROLL_PANE 允许用户逐渐查看大量信息的对象。
static AccessibleRole | AccessibleRole.SEPARATOR 通常包含在菜单中的对象，它对菜单中的内容进行可视和逻辑分离。
static AccessibleRole | AccessibleRole.SLIDER 允许用户在有限范围内进行选择的对象。
static AccessibleRole | AccessibleRole.SPIN_BOX SPIN_BOX 是简单的微调器组件，它主要用于简单数字。
static AccessibleRole | AccessibleRole.SPLIT_PANE 同时呈现两个其他窗格的专用窗格。
static AccessibleRole | AccessibleRole.STATUS_BAR STATUS_BAR 是可以包含多个用户状态信息标签的简单组件。
static AccessibleRole | AccessibleRole.SWING_COMPONENT 一个 Swing 组件，但关于它的其他信息都是未知的。
static AccessibleRole | AccessibleRole.TABLE 用于根据行和列来呈现信息的对象。
static AccessibleRole | AccessibleRole.TEXT 将文本呈现给用户的对象。
static AccessibleRole | AccessibleRole.TOGGLE_BUTTON 可以被选中或不被选中的专用按钮，但不针对当前状态提供单独的指示符。
static AccessibleRole | AccessibleRole.TOOL_BAR 通常由普通按钮或切换按钮组成的工具栏或调色板。
static AccessibleRole | AccessibleRole.TOOL_TIP 提供关于另一个对象信息的对象。
static AccessibleRole | AccessibleRole.TREE 用于将层次结构信息呈现给用户的对象。
static AccessibleRole | AccessibleRole.UNKNOWN 该对象包含某些 Accessible 信息，但其职责是未知的。
static AccessibleRole | AccessibleRole.VIEWPORT 通常在滚动窗格中使用的对象。
static AccessibleRole | AccessibleRole.WINDOW 不带标题或边框的顶层窗口。

返回 AccessibleRole 的 javax.accessibility 中的方法
abstract  AccessibleRole AccessibleContext.getAccessibleRole()
获取此对象的职责。

javax.swing 中 AccessibleRole 的使用

返回 AccessibleRole 的 javax.swing 中的方法
AccessibleRole | JColorChooser.AccessibleJColorChooser.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JDesktopPane.AccessibleJDesktopPane.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JFileChooser.AccessibleJFileChooser.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JOptionPane.AccessibleJOptionPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JPasswordField.AccessibleJPasswordField.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSpinner.AccessibleJSpinner.getAccessibleRole() 获取此对象的职责。
AccessibleRole | ProgressMonitor.AccessibleProgressMonitor.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSlider.AccessibleJSlider.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JToolTip.AccessibleJToolTip.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTree.AccessibleJTree.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTable.AccessibleJTable.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JProgressBar.AccessibleJProgressBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JCheckBox.AccessibleJCheckBox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTabbedPane.AccessibleJTabbedPane.getAccessibleRole() 获取此对象的功能。
AccessibleRole | JRadioButton.AccessibleJRadioButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JViewport.AccessibleJViewport.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JScrollPane.AccessibleJScrollPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JList.AccessibleJList.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JList.AccessibleJList.AccessibleJListChild.getAccessibleRole()
AccessibleRole | CellRendererPane.AccessibleCellRendererPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JScrollBar.AccessibleJScrollBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JComboBox.AccessibleJComboBox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSeparator.AccessibleJSeparator.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JPopupMenu.AccessibleJPopupMenu.getAccessibleRole() 获得此对象的职责。
AccessibleRole | JMenuBar.AccessibleJMenuBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Box.Filler.AccessibleBoxFiller.getAccessibleRole() 获取此对象的职责。
AccessibleRole | Box.AccessibleBox.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JToggleButton.AccessibleJToggleButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JSplitPane.AccessibleJSplitPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JToolBar.AccessibleJToolBar.getAccessibleRole() 获取此对象的职责。
AccessibleRole | ImageIcon.AccessibleImageIcon.getAccessibleRole() 获得此对象的职责。
AccessibleRole | JButton.AccessibleJButton.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JMenu.AccessibleJMenu.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JMenuItem.AccessibleJMenuItem.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JInternalFrame.AccessibleJInternalFrame.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JLayeredPane.AccessibleJLayeredPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JPanel.AccessibleJPanel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JRootPane.AccessibleJRootPane.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JLabel.AccessibleJLabel.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JComponent.AccessibleJComponent.getAccessibleRole() 获取此对象的功能。

javax.swing.table 中 AccessibleRole 的使用

返回 AccessibleRole 的 javax.swing.table 中的方法
AccessibleRole | JTableHeader.AccessibleJTableHeader.getAccessibleRole() 获取此对象的职责。
AccessibleRole | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleRole()

javax.swing.text 中 AccessibleRole 的使用

返回 AccessibleRole 的 javax.swing.text 中的方法
 AccessibleRole JTextComponent.AccessibleJTextComponent.getAccessibleRole()
获取此对象的职责。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleSelection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleSelection
的使用

使用 AccessibleSelection 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.awt 中 AccessibleSelection 的使用

实现 AccessibleSelection 的 java.awt 中的类
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

返回 AccessibleSelection 的 java.awt 中的方法
AccessibleSelection | List.AccessibleAWTList.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子对象。

javax.accessibility 中 AccessibleSelection 的使用

返回 AccessibleSelection 的 javax.accessibility 中的方法
 AccessibleSelection AccessibleContext.getAccessibleSelection()
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。

javax.swing 中 AccessibleSelection 的使用

实现 AccessibleSelection 的 javax.swing 中的类
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。

返回 AccessibleSelection 的 javax.swing 中的方法
AccessibleSelection | JTree.AccessibleJTree.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
AccessibleSelection | JTable.AccessibleJTable.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection。
AccessibleSelection | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
AccessibleSelection | JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection() 获取与此对象关联的 AccessibleSelection。
AccessibleSelection | JList.AccessibleJList.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JList.AccessibleJList.AccessibleJListChild.getAccessibleSelection()
AccessibleSelection | JComboBox.AccessibleJComboBox.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JMenuBar.AccessibleJMenuBar.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
AccessibleSelection | JMenu.AccessibleJMenu.getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。

javax.swing.table 中 AccessibleSelection 的使用

返回 AccessibleSelection 的 javax.swing.table 中的方法
 AccessibleSelection JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleSelection()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleStreamable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleStreamable
的使用

没有 javax.accessibility.AccessibleStreamable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.Accessible 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.Accessible
的使用

使用 Accessible 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.applet 中 Accessible 的使用

实现 Accessible 的 java.applet 中的类
 class Applet
applet 是一种不能单独运行但可嵌入在其他应用程序中的小程序。

java.awt 中 Accessible 的使用

实现 Accessible 的 java.awt 中的类
class | Button 此类创建一个标签按钮。
class | Canvas Canvas 组件表示屏幕上一个空白矩形区域，应用程序可以在该区域内绘图，或者可以从该区域捕获用户的输入事件。
class | Checkbox 复选框是一个可处于“开”(true) 或“关”(false) 状态的图形组件。
class | CheckboxMenuItem 此类表示一个可包括在菜单中的复选框。
class | Choice Choice 类表示一个弹出式选择菜单。
class | Dialog Dialog 是一个带标题和边界的顶层窗口，边界一般用于从用户处获得某种形式的输入。
class | FileDialog FileDialog 类显示一个对话框窗口，用户可以从中选择文件。
class | Frame Frame 是带有标题和边框的顶层窗口。
class | Label Label 对象是一个可在容器中放置文本的组件。
class | List List 组件为用户提供了一个可滚动的文本项列表。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
class | Menu Menu 对象是从菜单栏部署的下拉式菜单组件。
class | MenuBar MenuBar 类封装绑定到框架的菜单栏的平台概念。
class | MenuItem 菜单中的所有项必须属于类 MenuItem 或其子类之一。
class | Panel Panel 是最简单的容器类。
class | PopupMenu 此类实现能够在组件中的指定位置上动态弹出的菜单。
class | Scrollbar Scrollbar 类描述了一个滚动条，这是大家都很熟悉的用户界面对象。
class | ScrollPane 实现用于单个子组件的自动水平和/或垂直滚动的容器类。
class | TextArea TextArea 对象是显示文本的多行区域。
class | TextComponent TextComponent 类是所有允许编辑文本的组件的超类。
class | TextField TextField 对象是允许编辑单行文本的文本组件。
class | Window Window 对象是一个没有边界和菜单栏的顶层窗口。

返回 Accessible 的 java.awt 中的方法
Accessible | List.AccessibleAWTList.getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回该子级。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的 Accessible 子对象（如果存在）。
Accessible | Container.AccessibleAWTContainer.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | Component.AccessibleAWTComponent.getAccessibleAt(Point p) 返回包含在局部坐标 Point 上的 Accessible 子对象（如果存在这样的对象）。
Accessible | List.AccessibleAWTList.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
Accessible | Container.AccessibleAWTContainer.getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子容器。
Accessible | Component.AccessibleAWTComponent.getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | Component.AccessibleAWTComponent.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | List.AccessibleAWTList.getAccessibleSelection(int i) 返回表示对象中指定选项的 Accessible。
Accessible | MenuComponent.AccessibleAWTMenuComponent.getAccessibleSelection(int i) 返回 Accessible，它表示该对象中指定的已选择的子对象。

javax.accessibility 中 Accessible 的使用

声明为 Accessible 的 javax.accessibility 中的字段
protected  Accessible AccessibleContext.accessibleParent
此对象的可访问父级。

返回 Accessible 的 javax.accessibility 中的方法
Accessible | AccessibleTable.getAccessibleAt(int r, int c) 返回表中指定行和列处的 Accessible。
Accessible | AccessibleComponent.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | AccessibleTable.getAccessibleCaption() 返回此表的标题。
abstract Accessible | AccessibleContext.getAccessibleChild(int i) 返回该对象的指定 Accessible 子级。
Accessible | AccessibleTable.getAccessibleColumnDescription(int c) 返回表中指定列的描述文本。
Accessible | AccessibleContext.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | AccessibleTable.getAccessibleRowDescription(int r) 返回对表中指定行的描述。
Accessible | AccessibleSelection.getAccessibleSelection(int i) 返回表示指定的所选对象子级的 Accessible。
Accessible | AccessibleTable.getAccessibleSummary() 返回表的摘要描述。

参数类型为 Accessible 的 javax.accessibility 中的方法
void | AccessibleTable.setAccessibleCaption(Accessible a) 设置表的标题。
void | AccessibleTable.setAccessibleColumnDescription(int c, Accessible a) 设置表中指定列的描述文本。
void | AccessibleContext.setAccessibleParent(Accessible a) 设置此对象的 Accessible 父对象。
void | AccessibleTable.setAccessibleRowDescription(int r, Accessible a) 设置表中指定行的描述文本。
void | AccessibleTable.setAccessibleSummary(Accessible a) 设置表的摘要描述。

javax.swing 中 Accessible 的使用

实现 Accessible 的 javax.swing 中的类
class | Box 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
class | CellRendererPane 此类被插入在单元格渲染器与使用它们的组件之间。
class | DefaultListCellRenderer 呈现列表中的一个项。
static class | DefaultListCellRenderer.UIResource 实现 UIResource 的 DefaultListCellRenderer 的子类。
class | ImageIcon 一个 Icon 接口的实现，它根据 Image 绘制 Icon。
class | JApplet java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
class | JButton "push" 按钮的实现。
class | JCheckBox 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
class | JCheckBoxMenuItem 可以被选定或取消选定的菜单项。
class | JColorChooser JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
class | JComboBox 将按钮或可编辑字段与下拉列表组合的组件。
class | JDesktopPane 用于创建多文档界面或虚拟桌面的容器。
class | JDialog 创建对话框窗口的主要类。
class | JEditorPane 可编辑各种内容的文本组件。
class | JFileChooser JFileChooser 为用户选择文件提供了一种简单的机制。
class | JFormattedTextField JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
class | JFrame java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
class | JInternalFrame 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
class | JLabel 用于短文本字符串或图像或二者的显示区。
class | JLayeredPane JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
class | JList 显示对象列表并且允许用户选择一个或多个项的组件。
protected class | JList.AccessibleJList.AccessibleJListChild 此类实现供 List 子级使用的可访问性支持。
class | JMenu 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
class | JMenuBar 菜单栏的实现。
class | JMenuItem 菜单中的项的实现。
class | JOptionPane JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
class | JPanel JPanel 是一般轻量级容器。
class | JPasswordField JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
class | JPopupMenu 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
class | JProgressBar 以可视化形式显示某些任务进度的组件。
class | JRadioButton 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
class | JRadioButtonMenuItem 一个单选按钮菜单项的实现。
class | JRootPane 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
class | JScrollBar 滚动条的实现。
class | JScrollPane 提供轻量级组件的 scrollable 视图。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
class | JSeparator JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
class | JSlider 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
class | JSpinner 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
class | JSplitPane JSplitPane 用于分隔两个（只能两个）Component。
class | JTabbedPane 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
class | JTable JTable 用来显示和编辑常规二维单元表。
protected class | JTable.AccessibleJTable.AccessibleJTableCell 此类提供了适用于表单元格的 Java Accessibility API 实现。
class | JTextArea JTextArea 是一个显示纯文本的多行区域。
class | JTextField JTextField 是一个轻量级组件，它允许编辑单行文本。
class | JTextPane 可以用以图形方式表示的属性来标记的文本组件。
class | JToggleButton 具有两个状态的（two-state）按钮的实现。
class | JToolBar JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
class | JToolTip 用来显示 Component 的“提示”。
class | JTree 将分层数据集显示为轮廓的控件。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。
class | JViewport 用于查看底层信息的“视口”或“观察孔”。
class | JWindow JWindow 是一个容器，可以显示在用户桌面上的任何位置。
class | ProgressMonitor 监视某个操作的进度的类。

返回 Accessible 的 javax.swing 中的方法
static Accessible | SwingUtilities.getAccessibleAt(Component c, Point p) 如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
Accessible | JTable.AccessibleJTable.getAccessibleAt(int r, int c)
Accessible | JEditorPane.AccessibleJEditorPaneHTML.getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | JTree.AccessibleJTree.getAccessibleAt(Point p) 返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAt(Point p) 返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
Accessible | JTable.AccessibleJTable.getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。
Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAt(Point p)
Accessible | JTabbedPane.AccessibleJTabbedPane.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | JList.AccessibleJList.getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | JList.AccessibleJList.AccessibleJListChild.getAccessibleAt(Point p)
Accessible | JTable.AccessibleJTable.getAccessibleCaption() 返回此表的标题。
static Accessible | SwingUtilities.getAccessibleChild(Component c, int i) 返回对象的第 n 个可访问子对象。
Accessible | JEditorPane.AccessibleJEditorPaneHTML.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | JSpinner.AccessibleJSpinner.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | ProgressMonitor.AccessibleProgressMonitor.getAccessibleChild(int i) 返回该对象指定的 Accessible 子对象。
Accessible | JTree.AccessibleJTree.getAccessibleChild(int i) 返回对象的第 n 个可访问子对象。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleChild(int i) 返回对象的指定 Accessible 子对象。
Accessible | JTable.AccessibleJTable.getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleChild(int i) 返回此对象的指定的 Accessible 子对象。
Accessible | JTabbedPane.AccessibleJTabbedPane.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | JList.AccessibleJList.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | JList.AccessibleJList.AccessibleJListChild.getAccessibleChild(int i)
Accessible | JComboBox.AccessibleJComboBox.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | ImageIcon.AccessibleImageIcon.getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子对象。
Accessible | JMenu.AccessibleJMenu.getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子对象。
Accessible | JRootPane.AccessibleJRootPane.getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
Accessible | JComponent.AccessibleJComponent.getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
Accessible | JTable.AccessibleJTable.getAccessibleColumnDescription(int c) 返回对表中指定列的描述。
Accessible | ProgressMonitor.AccessibleProgressMonitor.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleParent() 获取此对象的 Accessible 父对象。
Accessible | ImageIcon.AccessibleImageIcon.getAccessibleParent() 获得此对象的 Accessible 父对象。
Accessible | JTable.AccessibleJTable.getAccessibleRowDescription(int r) 返回对表中指定行的描述。
Accessible | JTree.AccessibleJTree.getAccessibleSelection(int i) 返回表示对象中指定选择项的 Accessible。
Accessible | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleSelection(int i) 返回表示对象中指定选择项的 Accessible。
Accessible | JTable.AccessibleJTable.getAccessibleSelection(int i) 返回 Accessible，它表示该对象中指定的已选择的子对象。
Accessible | JTabbedPane.AccessibleJTabbedPane.getAccessibleSelection(int i)
Accessible | JList.AccessibleJList.getAccessibleSelection(int i) 返回表示对象中指定选项的 Accessible。
Accessible | JComboBox.AccessibleJComboBox.getAccessibleSelection(int i) 返回表示弹出对象中指定选择子级的 Accessible。
Accessible | JMenuBar.AccessibleJMenuBar.getAccessibleSelection(int i) 返回当前选择的菜单（如果选择了一个）；否则返回 null。
Accessible | JMenu.AccessibleJMenu.getAccessibleSelection(int i) 返回当前选择的子菜单（如果选择了），否则返回 null（只能选择一项并且只能选择子菜单，除非菜单项没有保持选中状态）。
Accessible | JTable.AccessibleJTable.getAccessibleSummary() 返回表的摘要描述。

参数类型为 Accessible 的 javax.swing 中的方法
void | JTable.AccessibleJTable.setAccessibleCaption(Accessible a) 设置表的标题。
void | JTable.AccessibleJTable.setAccessibleColumnDescription(int c, Accessible a) 设置表中指定列的描述文本。
void | JTable.AccessibleJTable.setAccessibleRowDescription(int r, Accessible a) 设置表中指定行的描述文本。
void | JTable.AccessibleJTable.setAccessibleSummary(Accessible a) 设置表的摘要描述。

参数类型为 Accessible 的 javax.swing 中的构造方法
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode

javax.swing.colorchooser 中 Accessible 的使用

实现 Accessible 的 javax.swing.colorchooser 中的类
 class AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

javax.swing.plaf 中 Accessible 的使用

返回 Accessible 的 javax.swing.plaf 中的方法
 Accessible ComponentUI.getAccessibleChild(JComponent c, int i)
返回对象的第 i 个 Accessible 子对象。

javax.swing.plaf.basic 中 Accessible 的使用

实现 Accessible 的 javax.swing.plaf.basic 中的类
class | BasicArrowButton 一个 JButton 对象，它绘制朝某个基本方向的缩放箭头。
class | BasicComboBoxRenderer ComboBox 渲染器 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
static class | BasicComboBoxRenderer.UIResource 实现 UIResource 的 BasicComboBoxRenderer 的子类。
class | BasicComboPopup 此为 ComboPopup 接口的基本实现。
class | BasicInternalFrameTitlePane.SystemMenuBar 此类应视为“受保护”内部类。
protected class | BasicToolBarUI.DragWindow

返回 Accessible 的 javax.swing.plaf.basic 中的方法
 Accessible BasicComboBoxUI.getAccessibleChild(JComponent c, int i)

javax.swing.plaf.metal 中 Accessible 的使用

实现 Accessible 的 javax.swing.plaf.metal 中的类
class | MetalComboBoxButton 协助 MetalComboBoxUI 的 JButton 子类 警告：此类的已序列化对象与以后的 Swing 版本不兼容。
class | MetalComboBoxUI.MetalComboPopup 已过时。 从 Java 2 platform v1.4 开始。
protected class | MetalFileChooserUI.FileRenderer
class | MetalFileChooserUI.FilterComboBoxRenderer 呈现不同的类型大小和风格。
class | MetalScrollButton Metal 滚动条箭头的 JButton 对象。

javax.swing.plaf.multi 中 Accessible 的使用

返回 Accessible 的 javax.swing.plaf.multi 中的方法
Accessible | MultiButtonUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiColorChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiComboBoxUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopIconUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiDesktopPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiFileChooserUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiInternalFrameUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiLabelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiListUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiMenuItemUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiOptionPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPanelUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiPopupMenuUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiProgressBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiRootPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiScrollPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSeparatorUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSliderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSpinnerUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiSplitPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTabbedPaneUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableHeaderUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTableUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTextUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolBarUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiToolTipUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiTreeUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。
Accessible | MultiViewportUI.getAccessibleChild(JComponent a, int b) 在由此对象处理的每个 UI 上调用 getAccessibleChild 方法。

javax.swing.table 中 Accessible 的使用

实现 Accessible 的 javax.swing.table 中的类
class | DefaultTableCellRenderer 呈现（显示） JTable 中每个单元格的标准类。
static class | DefaultTableCellRenderer.UIResource DefaultTableCellRenderer 的一个子类，它实现 UIResource。
class | JTableHeader 这是管理 JTable 的头的对象。
protected class | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

返回 Accessible 的 javax.swing.table 中的方法
Accessible | JTableHeader.AccessibleJTableHeader.getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAt(Point p)
Accessible | JTableHeader.AccessibleJTableHeader.getAccessibleChild(int i) 返回该对象的第 n 个可访问子对象。
Accessible | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleChild(int i)

javax.swing.text 中 Accessible 的使用

实现 Accessible 的 javax.swing.text 中的类
 class JTextComponent
JTextComponent 是 swing 文本组件的基类。

javax.swing.text.html 中 Accessible 的使用

实现 Accessible 的 javax.swing.text.html 中的类
 class HTMLEditorKit
Swing JEditorPane 文本组件通过称为 EditorKit 的插件机制来支持不同种类的内容。

javax.swing.tree 中 Accessible 的使用

实现 Accessible 的 javax.swing.tree 中的类
class | DefaultTreeCellEditor.DefaultTextField 不提供任何编辑器时所使用的 TextField。
class | DefaultTreeCellRenderer 显示树中的条目。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleTable
的使用

使用 AccessibleTable 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleTable 的使用

javax.accessibility 中 AccessibleTable 的子接口
 interface AccessibleExtendedTable
AccessibleExtendedTable 类提供了有关以二维表的格式呈现数据的用户界面组件的扩展信息。

返回 AccessibleTable 的 javax.accessibility 中的方法
AccessibleTable | AccessibleTable.getAccessibleColumnHeader() 返回以 AccessibleTable 表示的列标题。
AccessibleTable | AccessibleTable.getAccessibleRowHeader() 返回以 AccessibleTable 表示的行标题。
AccessibleTable | AccessibleContext.getAccessibleTable() 获取与某个对象关联的 AccessibleTable

参数类型为 AccessibleTable 的 javax.accessibility 中的方法
void | AccessibleTable.setAccessibleColumnHeader(AccessibleTable table) 设置列标题。
void | AccessibleTable.setAccessibleRowHeader(AccessibleTable table) 设置行标题。

javax.swing 中 AccessibleTable 的使用

实现 AccessibleTable 的 javax.swing 中的类
protected  class JTable.AccessibleJTable
此类实现对 JTable 类的可访问性支持。

返回 AccessibleTable 的 javax.swing 中的方法
AccessibleTable | JTable.AccessibleJTable.getAccessibleColumnHeader() 返回以 AccessibleTable 表示的列标题。
AccessibleTable | JTable.AccessibleJTable.getAccessibleRowHeader() 返回以 AccessibleTable 表示的行标题。
AccessibleTable | JTable.AccessibleJTable.getAccessibleTable() 获取与此对象关联的 AccessibleTable。

参数类型为 AccessibleTable 的 javax.swing 中的方法
void | JTable.AccessibleJTable.setAccessibleColumnHeader(AccessibleTable a) 设置以 AccessibleTable 表示的列标题。
void | JTable.AccessibleJTable.setAccessibleRowHeader(AccessibleTable a) 设置以 AccessibleTable 表示的列标题。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleTableModelChange 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleTableModelChange
的使用

使用 AccessibleTableModelChange 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 AccessibleTableModelChange 的使用

实现 AccessibleTableModelChange 的 javax.swing 中的类
protected  class JTable.AccessibleJTable.AccessibleJTableModelChange

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleTextSequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleTextSequence
的使用

使用 AccessibleTextSequence 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.accessibility 中 AccessibleTextSequence 的使用

返回 AccessibleTextSequence 的 javax.accessibility 中的方法
AccessibleTextSequence | AccessibleExtendedText.getTextSequenceAfter(int part, int index) 返回给定索引后面的 AccessibleTextSequence。
AccessibleTextSequence | AccessibleExtendedText.getTextSequenceAt(int part, int index) 返回给定索引处的 AccessibleTextSequence。
AccessibleTextSequence | AccessibleExtendedText.getTextSequenceBefore(int part, int index) 返回给定索引前面的 AccessibleTextSequence。

javax.swing 中 AccessibleTextSequence 的使用

返回 AccessibleTextSequence 的 javax.swing 中的方法
AccessibleTextSequence | JPasswordField.AccessibleJPasswordField.getTextSequenceAfter(int part, int index) 返回给定 index 之后的 AccessibleTextSequence。
AccessibleTextSequence | JPasswordField.AccessibleJPasswordField.getTextSequenceAt(int part, int index) 返回给定 index 处的 AccessibleTextSequence。
AccessibleTextSequence | JPasswordField.AccessibleJPasswordField.getTextSequenceBefore(int part, int index) 返回给定 index 之前的 AccessibleTextSequence。

javax.swing.text 中 AccessibleTextSequence 的使用

返回 AccessibleTextSequence 的 javax.swing.text 中的方法
AccessibleTextSequence | JTextComponent.AccessibleJTextComponent.getTextSequenceAfter(int part, int index) 返回给定 index 之后的 AccessibleTextSequence。
AccessibleTextSequence | JTextComponent.AccessibleJTextComponent.getTextSequenceAt(int part, int index) 返回给定 index 处的 AccessibleTextSequence。
AccessibleTextSequence | JTextComponent.AccessibleJTextComponent.getTextSequenceBefore(int part, int index) 返回给定 index 之前的 AccessibleTextSequence。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleState 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleState
的使用

使用 AccessibleState 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 AccessibleState 的使用

声明为 AccessibleState 的 javax.accessibility 中的字段
static AccessibleState | AccessibleState.ACTIVE 指示某个窗口当前是活动窗口。
static AccessibleState | AccessibleState.ARMED 指示选中了此对象。
static AccessibleState | AccessibleState.BUSY 指示当前对象忙。
static AccessibleState | AccessibleState.CHECKED 指示此对象当前被选中。
static AccessibleState | AccessibleState.COLLAPSED 指示此对象是折叠的。
static AccessibleState | AccessibleState.EDITABLE 指示用户可以更改此对象的内容。
static AccessibleState | AccessibleState.ENABLED 指示此对象是启用的。
static AccessibleState | AccessibleState.EXPANDABLE 指示此对象允许逐步显示其子级。
static AccessibleState | AccessibleState.EXPANDED 指示此对象是展开的。
static AccessibleState | AccessibleState.FOCUSABLE 指示此对象可以接受键盘焦点，这意味着当它具有焦点时，由键盘上的键入操作所产生的所有事件将被传递到此对象。
static AccessibleState | AccessibleState.FOCUSED 指示此对象当前具有键盘焦点。
static AccessibleState | AccessibleState.HORIZONTAL 指示此对象的方向为水平方向。
static AccessibleState | AccessibleState.ICONIFIED 指示此对象是最小化的，并只通过一个图标来表示。
static AccessibleState | AccessibleState.INDETERMINATE 指示对象状态是不确定的。
static AccessibleState | AccessibleState.MANAGES_DESCENDANTS 指示此对象负责管理其子组件。
static AccessibleState | AccessibleState.MODAL 指示在用户可以与不同窗口中的某个对象交互之前，必须对此对象采取某些操作。
static AccessibleState | AccessibleState.MULTI_LINE 指示此（文本）对象可以包含多行文本
static AccessibleState | AccessibleState.MULTISELECTABLE 指示此对象允许同时选定多个子级。
static AccessibleState | AccessibleState.OPAQUE 指示此对象在其矩形区域内绘制每个像素。
static AccessibleState | AccessibleState.PRESSED 指示此对象当前是按下的。
static AccessibleState | AccessibleState.RESIZABLE 指示此对象的大小不固定。
static AccessibleState | AccessibleState.SELECTABLE 指示此对象是某个允许选择子级的对象的子对象，并且此子对象就是这些可以被选择的子对象之一。
static AccessibleState | AccessibleState.SELECTED 指示此对象是某个允许选择子级的对象的子对象，且此子对象是已被选定的子对象之一。
static AccessibleState | AccessibleState.SHOWING 指示此对象、此对象的父对象、其父对象的父对象等都是可见的。
static AccessibleState | AccessibleState.SINGLE_LINE 指示此（文本）对象只能包含单行文本
static AccessibleState | AccessibleState.TRANSIENT 指示此对象是临时的。
static AccessibleState | AccessibleState.TRUNCATED 该状态指示文本被边界矩形截取，并且有些文本不显示在屏幕上。
static AccessibleState | AccessibleState.VERTICAL 指示此对象的方向为垂直方向。
static AccessibleState | AccessibleState.VISIBLE 指示此对象是可见的。

类型参数类型为 AccessibleState 的 javax.accessibility 中的字段
protected  Vector<AccessibleState> AccessibleStateSet.states
Vector 中的每个项表示一个 AccessibleState。

返回 AccessibleState 的 javax.accessibility 中的方法
 AccessibleState[] AccessibleStateSet.toArray()
以 AccessibleState 数组形式返回当前状态集

参数类型为 AccessibleState 的 javax.accessibility 中的方法
boolean | AccessibleStateSet.add(AccessibleState state) 如果某个新状态不在当前状态集中，则将它添加到当前状态集中。
void | AccessibleStateSet.addAll(AccessibleState[] states) 将所有状态添加到现有状态集中。
boolean | AccessibleStateSet.contains(AccessibleState state) 检查当前状态是否在状态集中。
boolean | AccessibleStateSet.remove(AccessibleState state) 从当前状态集中移除一个状态。

参数类型为 AccessibleState 的 javax.accessibility 中的构造方法
AccessibleStateSet(AccessibleState[] states)
创建一个新状态，其初始状态集包含在传入的状态数组中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleBundle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleBundle
的使用

使用 AccessibleBundle 的软件包
javax.accessibility 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。

javax.accessibility 中 AccessibleBundle 的使用

javax.accessibility 中 AccessibleBundle 的子类
class | AccessibleRelation AccessibleRelation 类描述了实现 AccessibleRelation 的对象与一个或多个其他对象之间的关系。
class | AccessibleRole AccessibleRole 类确定组件的职责。
class | AccessibleState AccessibleState 类描述了组件的特殊状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleRelationSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleRelationSet
的使用

使用 AccessibleRelationSet 的软件包
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.accessibility 中 AccessibleRelationSet 的使用

返回 AccessibleRelationSet 的 javax.accessibility 中的方法
 AccessibleRelationSet AccessibleContext.getAccessibleRelationSet()
获取与某个对象关联的 AccessibleRelationSet

javax.swing 中 AccessibleRelationSet 的使用

返回 AccessibleRelationSet 的 javax.swing 中的方法
AccessibleRelationSet | AbstractButton.AccessibleAbstractButton.getAccessibleRelationSet() 获得与此对象关联的 AccessibleRelationSet（如果存在）。
AccessibleRelationSet | JLabel.AccessibleJLabel.getAccessibleRelationSet() 获取与此对象关联的 AccessibleRelationSet（如果存在）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleExtendedComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleExtendedComponent
的使用

使用 AccessibleExtendedComponent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 AccessibleExtendedComponent 的使用

实现 AccessibleExtendedComponent 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。

javax.swing.table 中 AccessibleExtendedComponent 的使用

实现 AccessibleExtendedComponent 的 javax.swing.table 中的类
protected  class JTableHeader.AccessibleJTableHeader
此类实现对 JTableHeader 类的可访问性支持。

javax.swing.text 中 AccessibleExtendedComponent 的使用

实现 AccessibleExtendedComponent 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleComponent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleComponent
的使用

使用 AccessibleComponent 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 java.applet 中的类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

java.awt 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 java.awt 中的类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Component.AccessibleAWTComponent 用来为可访问性提供默认支持的 Component 的内部类。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

返回 AccessibleComponent 的 java.awt 中的方法
AccessibleComponent | MenuComponent.AccessibleAWTMenuComponent.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent（如果存在）。
AccessibleComponent | Component.AccessibleAWTComponent.getAccessibleComponent() 获取与此对象相关的 AccessibleComponent（如果存在一个这样的组件）。

javax.accessibility 中 AccessibleComponent 的使用

javax.accessibility 中 AccessibleComponent 的子接口
 interface AccessibleExtendedComponent
屏幕上呈现的任何对象都应该支持 AccessibleExtendedComponent 接口。

返回 AccessibleComponent 的 javax.accessibility 中的方法
 AccessibleComponent AccessibleContext.getAccessibleComponent()
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。

javax.swing 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JList.AccessibleJList.AccessibleJListChild 此类实现供 List 子级使用的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTable.AccessibleJTable.AccessibleJTableCell 此类提供了适用于表单元格的 Java Accessibility API 实现。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。

返回 AccessibleComponent 的 javax.swing 中的方法
AccessibleComponent | ProgressMonitor.AccessibleProgressMonitor.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
AccessibleComponent | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleComponent | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent（如果存在）。
AccessibleComponent | JList.AccessibleJList.AccessibleJListChild.getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。

javax.swing.table 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 javax.swing.table 中的类
protected class | JTableHeader.AccessibleJTableHeader 此类实现对 JTableHeader 类的可访问性支持。
protected class | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

返回 AccessibleComponent 的 javax.swing.table 中的方法
 AccessibleComponent JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。

javax.swing.text 中 AccessibleComponent 的使用

实现 AccessibleComponent 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleText 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleText
的使用

使用 AccessibleText 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 AccessibleText 的使用

实现 AccessibleText 的 java.awt 中的类
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。

返回 AccessibleText 的 java.awt 中的方法
 AccessibleText TextComponent.AccessibleAWTTextComponent.getAccessibleText()
获取与此对象相关的 AccessibleText。

javax.accessibility 中 AccessibleText 的使用

javax.accessibility 中 AccessibleText 的子接口
interface | AccessibleEditableText 在显示器上显示可编辑文本信息的所有类都应该实现 AccessibleEditableText 接口。
interface | AccessibleHypertext AccessibleHypertext 类是在显示器上显示超文本信息的所有类的基类。

返回 AccessibleText 的 javax.accessibility 中的方法
 AccessibleText AccessibleContext.getAccessibleText()
获取与在显示器上显示文本的此对象关联的 AccessibleText。

javax.swing 中 AccessibleText 的使用

实现 AccessibleText 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

返回 AccessibleText 的 javax.swing 中的方法
AccessibleText | JEditorPane.AccessibleJEditorPaneHTML.getAccessibleText()
AccessibleText | JPasswordField.AccessibleJPasswordField.getAccessibleText() 获取 JPasswordField 的 AccessibleText。
AccessibleText | JSpinner.AccessibleJSpinner.getAccessibleText() 获取与此对象相关联的可在显示器上表示的 AccessibleText。
AccessibleText | ProgressMonitor.AccessibleProgressMonitor.getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleText | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleText() 获取与此对象关联的 AccessibleText（如果存在）。
AccessibleText | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleText() 获取与此对象关联的 AccessibleText （如果存在）。
AccessibleText | JList.AccessibleJList.AccessibleJListChild.getAccessibleText()
AccessibleText | AbstractButton.AccessibleAbstractButton.getAccessibleText()
AccessibleText | JLabel.AccessibleJLabel.getAccessibleText()

javax.swing.table 中 AccessibleText 的使用

返回 AccessibleText 的 javax.swing.table 中的方法
 AccessibleText JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleText()

javax.swing.text 中 AccessibleText 的使用

实现 AccessibleText 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleText 的 javax.swing.text 中的方法
 AccessibleText JTextComponent.AccessibleJTextComponent.getAccessibleText()
获取与此对象关联的 AccessibleText。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleValue
的使用

使用 AccessibleValue 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。

java.awt 中 AccessibleValue 的使用

实现 AccessibleValue 的 java.awt 中的类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。

返回 AccessibleValue 的 java.awt 中的方法
AccessibleValue | Button.AccessibleAWTButton.getAccessibleValue() 获取与此对象相关的 AccessibleValue。
AccessibleValue | Checkbox.AccessibleAWTCheckbox.getAccessibleValue() 获取与此对象相关的 AccessibleValue。
AccessibleValue | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleValue() 获取与此对象相关的 AccessibleValue。
AccessibleValue | Scrollbar.AccessibleAWTScrollBar.getAccessibleValue() 获得与此对象相关的 AccessibleValue。
AccessibleValue | MenuItem.AccessibleAWTMenuItem.getAccessibleValue() 获取与此对象关联的 AccessibleValue。

javax.accessibility 中 AccessibleValue 的使用

返回 AccessibleValue 的 javax.accessibility 中的方法
 AccessibleValue AccessibleContext.getAccessibleValue()
获取与此对象关联的支持 Numerical 值的 AccessibleValue。

javax.swing 中 AccessibleValue 的使用

实现 AccessibleValue 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。

返回 AccessibleValue 的 javax.swing 中的方法
AccessibleValue | JSpinner.AccessibleJSpinner.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | ProgressMonitor.AccessibleProgressMonitor.getAccessibleValue() 获取与此对象关联的 AccessibleValue，该对象支持数值。
AccessibleValue | JSlider.AccessibleJSlider.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
AccessibleValue | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
AccessibleValue | JProgressBar.AccessibleJProgressBar.getAccessibleValue() 获得与此对象相关联的 AccessibleValue。
AccessibleValue | JList.AccessibleJList.AccessibleJListChild.getAccessibleValue()
AccessibleValue | JScrollBar.AccessibleJScrollBar.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JSplitPane.AccessibleJSplitPane.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | AbstractButton.AccessibleAbstractButton.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JInternalFrame.AccessibleJInternalFrame.getAccessibleValue() 获取与此对象关联的 AccessibleValue。
AccessibleValue | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon.getAccessibleValue() 获取与此对象关联的 AccessibleValue。

javax.swing.table 中 AccessibleValue 的使用

返回 AccessibleValue 的 javax.swing.table 中的方法
 AccessibleValue JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleValue()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.accessibility.AccessibleAction 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.accessibility.AccessibleAction
的使用

使用 AccessibleAction 的软件包
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt 中 AccessibleAction 的使用

实现 AccessibleAction 的 java.awt 中的类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。

返回 AccessibleAction 的 java.awt 中的方法
AccessibleAction | Button.AccessibleAWTButton.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | Checkbox.AccessibleAWTCheckbox.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | Choice.AccessibleAWTChoice.getAccessibleAction() 获取与此对象相关的 AccessibleAction。
AccessibleAction | MenuItem.AccessibleAWTMenuItem.getAccessibleAction() 获取与此对象关联的 AccessibleAction。

javax.accessibility 中 AccessibleAction 的使用

实现 AccessibleAction 的 javax.accessibility 中的类
 class AccessibleHyperlink
Hypertext 文档中的某个链接或一组链接（例如客户端 imagemap）的封装。

返回 AccessibleAction 的 javax.accessibility 中的方法
 AccessibleAction AccessibleContext.getAccessibleAction()
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

javax.swing 中 AccessibleAction 的使用

实现 AccessibleAction 的 javax.swing 中的类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
class | JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。

返回 AccessibleAction 的 javax.swing 中的方法
AccessibleAction | JSpinner.AccessibleJSpinner.getAccessibleAction() 获取与此对象关联的可支持一个或多个操作的 AccessibleAction。
AccessibleAction | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleAction() 获取与此对象关联的 AccessibleAction。
AccessibleAction | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleAction() 获取与此对象关联的 AccessibleAction（如果存在）。
AccessibleAction | JList.AccessibleJList.AccessibleJListChild.getAccessibleAction()
AccessibleAction | JComboBox.AccessibleJComboBox.getAccessibleAction() 获取与此对象关联的 AccessibleAction。
AccessibleAction | AbstractButton.AccessibleAbstractButton.getAccessibleAction() 获取与此对象关联的 AccessibleAction。

javax.swing.table 中 AccessibleAction 的使用

返回 AccessibleAction 的 javax.swing.table 中的方法
 AccessibleAction JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleAction()

javax.swing.text 中 AccessibleAction 的使用

实现 AccessibleAction 的 javax.swing.text 中的类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleAction 的 javax.swing.text 中的方法
 AccessibleAction JTextComponent.AccessibleJTextComponent.getAccessibleAction()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleStateSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleStateSet
的使用

使用 AccessibleStateSet 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 java.applet 中的方法
 AccessibleStateSet Applet.AccessibleApplet.getAccessibleStateSet()
获得此对象的状态。

java.awt 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 java.awt 中的方法
AccessibleStateSet | Checkbox.AccessibleAWTCheckbox.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | List.AccessibleAWTList.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | Scrollbar.AccessibleAWTScrollBar.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | TextArea.AccessibleAWTTextArea.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | TextComponent.AccessibleAWTTextComponent.getAccessibleStateSet() 获取 TextComponent 的状态设置。
AccessibleStateSet | TextField.AccessibleAWTTextField.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | MenuComponent.AccessibleAWTMenuComponent.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Dialog.AccessibleAWTDialog.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Frame.AccessibleAWTFrame.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Window.AccessibleAWTWindow.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | Component.AccessibleAWTComponent.getAccessibleStateSet() 获取此对象的状态。

javax.accessibility 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.accessibility 中的方法
abstract  AccessibleStateSet AccessibleContext.getAccessibleStateSet()
获取此对象的状态集合。

javax.swing 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.swing 中的方法
AccessibleStateSet | JEditorPane.AccessibleJEditorPane.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | ProgressMonitor.AccessibleProgressMonitor.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | JSlider.AccessibleJSlider.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JProgressBar.AccessibleJProgressBar.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JTextArea.AccessibleJTextArea.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JTextField.AccessibleJTextField.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JList.AccessibleJList.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JList.AccessibleJList.AccessibleJListChild.getAccessibleStateSet()
AccessibleStateSet | JScrollBar.AccessibleJScrollBar.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JComboBox.AccessibleJComboBox.getAccessibleStateSet() 获取此对象的状态设置。
AccessibleStateSet | JMenuBar.AccessibleJMenuBar.getAccessibleStateSet() 获得此对象的可访问性状态设置。
AccessibleStateSet | JSplitPane.AccessibleJSplitPane.getAccessibleStateSet() 获取此对象的状态集。
AccessibleStateSet | JToolBar.AccessibleJToolBar.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | JDialog.AccessibleJDialog.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | ImageIcon.AccessibleImageIcon.getAccessibleStateSet() 获得此对象的状态。
AccessibleStateSet | AbstractButton.AccessibleAbstractButton.getAccessibleStateSet() 获得此对象的状态设置。
AccessibleStateSet | JComponent.AccessibleJComponent.getAccessibleStateSet() 获取此对象的状态。
AccessibleStateSet | JFrame.AccessibleJFrame.getAccessibleStateSet() 获得此对象的状态。
static AccessibleStateSet | SwingUtilities.getAccessibleStateSet(Component c) 获取此对象的状态。

javax.swing.table 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.swing.table 中的方法
 AccessibleStateSet JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleStateSet()

javax.swing.text 中 AccessibleStateSet 的使用

返回 AccessibleStateSet 的 javax.swing.text 中的方法
 AccessibleStateSet JTextComponent.AccessibleJTextComponent.getAccessibleStateSet()
获取 JTextComponent 的状态设置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.accessibility.AccessibleContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.accessibility.AccessibleContext
的使用

使用 AccessibleContext 的软件包
java.applet | 提供创建 applet 所必需的类和 applet 用来与其 applet 上下文通信的类。
java.awt | 包含用于创建用户界面和绘制图形图像的所有类。
javax.accessibility | 定义了用户界面组件与提供对这些组件进行访问的辅助技术之间的协定。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.applet 中 AccessibleContext 的使用

java.applet 中 AccessibleContext 的子类
protected  class Applet.AccessibleApplet
此类实现对 Applet 类的可访问性支持。

返回 AccessibleContext 的 java.applet 中的方法
 AccessibleContext Applet.getAccessibleContext()
获取与此 Applet 关联的 AccessibleContext。

java.awt 中 AccessibleContext 的使用

java.awt 中 AccessibleContext 的子类
protected class | Button.AccessibleAWTButton 此类实现对 Button 类的可访问性支持。
protected class | Canvas.AccessibleAWTCanvas 此类实现对 Canvas 类的可访问性支持。
protected class | Checkbox.AccessibleAWTCheckbox 此类实现对 Checkbox 类的可访问性支持。
protected class | CheckboxMenuItem.AccessibleAWTCheckboxMenuItem 用来为可访问性提供默认支持的 CheckboxMenuItem 的内部类。
protected class | Choice.AccessibleAWTChoice 此类实现对 Choice 类的可访问性支持。
protected class | Component.AccessibleAWTComponent 用来为可访问性提供默认支持的 Component 的内部类。
protected class | Container.AccessibleAWTContainer 用于对可访问性提供默认支持的 Container 内部类。
protected class | Dialog.AccessibleAWTDialog 此类实现对 Dialog 类的可访问性支持。
protected class | Frame.AccessibleAWTFrame 此类实现对 Frame 类的可访问性支持。
protected class | Label.AccessibleAWTLabel 此类实现对 Label 类的可访问性支持。
protected class | List.AccessibleAWTList 此类实现 List 类的可访问性支持。
protected class | List.AccessibleAWTList.AccessibleAWTListChild 此类实现 List 子级的可访问性支持。
protected class | Menu.AccessibleAWTMenu 菜单的内部类，用于为可访问性提供默认支持。
protected class | MenuBar.AccessibleAWTMenuBar 菜单栏的内部类，用于为可访问性提供默认支持。
protected class | MenuComponent.AccessibleAWTMenuComponent 用于为可访问性提供默认支持的 MenuComponent 的内部类。
protected class | MenuItem.AccessibleAWTMenuItem 用于为可访问性提供默认支持的 MenuItem 的内部类。
protected class | Panel.AccessibleAWTPanel 此类实现 Panel 类的可访问性支持。
protected class | PopupMenu.AccessibleAWTPopupMenu 用于为可访问性提供默认支持的 PopupMenu 的内部类。
protected class | Scrollbar.AccessibleAWTScrollBar 此类实现 Scrollbar 类的可访问性支持。
protected class | ScrollPane.AccessibleAWTScrollPane 此类实现 ScrollPane 类的可访问性支持。
protected class | TextArea.AccessibleAWTTextArea 此类实现 TextArea 类的可访问性支持。
protected class | TextComponent.AccessibleAWTTextComponent 此类实现对 TextComponent 类的可访问性支持。
protected class | TextField.AccessibleAWTTextField 此类实现 TextField 类的可访问性支持。
protected class | Window.AccessibleAWTWindow 此类实现对 Window 类的可访问性支持。

返回 AccessibleContext 的 java.awt 中的方法
AccessibleContext | Button.getAccessibleContext() 获取与此 Button 相关的 AccessibleContext。
AccessibleContext | Checkbox.getAccessibleContext() 获取与此 Checkbox 相关的 AccessibleContext。
AccessibleContext | CheckboxMenuItem.getAccessibleContext() 获取与此 CheckboxMenuItem 相关的 AccessibleContext。
AccessibleContext | Choice.getAccessibleContext() 获取与此 Choice 相关的 AccessibleContext。
AccessibleContext | List.getAccessibleContext() 获取与此 List 关联的 AccessibleContext。
AccessibleContext | List.AccessibleAWTList.AccessibleAWTListChild.getAccessibleContext() 获取此对象的 AccessibleContext。
AccessibleContext | ScrollPane.getAccessibleContext() 获取与此 ScrollPane 相关的 AccessibleContext。
AccessibleContext | Scrollbar.getAccessibleContext() 获取与此 Scrollbar 相关的 AccessibleContext。
AccessibleContext | TextArea.getAccessibleContext() 返回与此 TextArea 相关的 AccessibleContext。
AccessibleContext | TextComponent.getAccessibleContext() 获取与此 TextComponent 关联的 AccessibleContext。
AccessibleContext | TextField.getAccessibleContext() 获取与此 TextField 关联的 AccessibleContext。
AccessibleContext | MenuBar.getAccessibleContext() 获取与此菜单栏关联的 AccessibleContext。
AccessibleContext | Panel.getAccessibleContext() 获取与 Panel 相关的 AccessibleContext。
AccessibleContext | Canvas.getAccessibleContext() 获取与此 Canvas 相关的 AccessibleContext。
AccessibleContext | PopupMenu.getAccessibleContext() 获取与此 PopupMenu 关联的 AccessibleContext。
AccessibleContext | Menu.getAccessibleContext() 获取与此菜单关联的 AccessibleContext。
AccessibleContext | MenuItem.getAccessibleContext() 获取与此菜单项关联的 AccessibleContext。
AccessibleContext | MenuComponent.getAccessibleContext() 获取与此 MenuComponent 关联的 AccessibleContext。
AccessibleContext | Dialog.getAccessibleContext() 获取与此 Dialog 有关的 AccessibleContext。
AccessibleContext | Label.getAccessibleContext() 获取与此标签相关的 AccessibleContext。
AccessibleContext | Frame.getAccessibleContext() 获取与此窗体有关的 AccessibleContext。
AccessibleContext | Window.getAccessibleContext() 获取与此窗口关联的 AccessibleContext。
AccessibleContext | Component.getAccessibleContext() 获取与此 Component 相关的 AccessibleContext。

javax.accessibility 中 AccessibleContext 的使用

返回 AccessibleContext 的 javax.accessibility 中的方法
 AccessibleContext Accessible.getAccessibleContext()
返回与此对象关联的 AccessibleContext。

javax.swing 中 AccessibleContext 的使用

javax.swing 中 AccessibleContext 的子类
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
protected class | Box.Filler.AccessibleBoxFiller 此类实现 Box.Filler 类的可访问性支持。
protected class | CellRendererPane.AccessibleCellRendererPane 此类实现 Panel 类的可访问性支持。
protected class | ImageIcon.AccessibleImageIcon 此类实现 ImageIcon 类的可访问性支持。
protected class | JApplet.AccessibleJApplet 此类实现对 JApplet 类的可访问性支持。
protected class | JButton.AccessibleJButton 此类实现对 JButton 类的可访问性支持。
protected class | JCheckBox.AccessibleJCheckBox 此类实现对 JCheckBox 类的可访问性支持。
protected class | JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem 此类实现对 JCheckBoxMenuItem 类的可访问性支持。
protected class | JColorChooser.AccessibleJColorChooser 此类实现对 JColorChooser 类的可访问性支持。
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
class | JComponent.AccessibleJComponent 用于为可访问性提供默认支持的 JComponent 内部类。
protected class | JDesktopPane.AccessibleJDesktopPane 此类实现对 JDesktopPane 类的可访问性支持。
protected class | JDialog.AccessibleJDialog 此类实现对 JDialog 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
protected class | JFileChooser.AccessibleJFileChooser 此类实现对 JFileChooser 类的可访问性支持。
protected class | JFrame.AccessibleJFrame 此类实现对 JFrame 类的可访问性支持。
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
protected class | JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon 此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
protected class | JLabel.AccessibleJLabel 该类用于获得此对象的可访问性职责。
protected class | JLayeredPane.AccessibleJLayeredPane 此类实现对 JLayeredPane 类的可访问性支持。
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
protected class | JList.AccessibleJList.AccessibleJListChild 此类实现供 List 子级使用的可访问性支持。
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenuBar.AccessibleJMenuBar 此类实现 JMenuBar 类的可访问性支持。
protected class | JMenuItem.AccessibleJMenuItem 此类实现 JMenuItem 类的可访问性支持。
protected class | JOptionPane.AccessibleJOptionPane 此类实现对 JOptionPane 类的可访问性支持。
protected class | JPanel.AccessibleJPanel 此类实现对 JPanel 类的可访问性支持。
protected class | JPasswordField.AccessibleJPasswordField 此类实现对 JPasswordField 类的可访问性支持。
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
protected class | JProgressBar.AccessibleJProgressBar 此类实现 JProgressBar 类的可访问性支持。
protected class | JRadioButton.AccessibleJRadioButton 此类实现对 JRadioButton 类的可访问性支持。
protected class | JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem 此类实现对 JRadioButtonMenuItem 类的可访问性支持。
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JScrollBar.AccessibleJScrollBar 此类实现 JScrollBar 类的可访问性支持。
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JSeparator.AccessibleJSeparator 此类实现 JSeparator 类的可访问性支持。
protected class | JSlider.AccessibleJSlider 此类实现 JSlider 类的可访问性支持。
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
protected class | JSplitPane.AccessibleJSplitPane 此类实现 JSplitPane 类的可访问性支持。
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
protected class | JTable.AccessibleJTable.AccessibleJTableCell 此类提供了适用于表单元格的 Java Accessibility API 实现。
protected class | JTextArea.AccessibleJTextArea 此类实现对 JTextArea 类的可访问性支持。
protected class | JTextField.AccessibleJTextField 此类实现对 JTextField 类的可访问性支持。
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
protected class | JToolTip.AccessibleJToolTip 此类实现对 JToolTip 类的可访问性支持。
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
protected class | JTree.AccessibleJTree.AccessibleJTreeNode 此类实现 JTree 子类的可访问性支持。
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JWindow.AccessibleJWindow 此类实现对 JWindow 类的可访问性支持。
protected class | ProgressMonitor.AccessibleProgressMonitor AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

声明为 AccessibleContext 的 javax.swing 中的字段
protected AccessibleContext | JColorChooser.accessibleContext
protected AccessibleContext | JFileChooser.accessibleContext
protected AccessibleContext | ProgressMonitor.accessibleContext ProgressMonitor 的 AccessibleContext
protected AccessibleContext | JApplet.accessibleContext
protected AccessibleContext | JWindow.accessibleContext 可访问的上下文属性。
protected AccessibleContext | CellRendererPane.accessibleContext
protected AccessibleContext | JDialog.accessibleContext
protected AccessibleContext | JComponent.accessibleContext 与此 JComponent 关联的 AccessibleContext。
protected AccessibleContext | JFrame.accessibleContext 可访问的上下文属性。

返回 AccessibleContext 的 javax.swing 中的方法
AccessibleContext | JColorChooser.getAccessibleContext() 获取与此 JColorChooser 关联的 AccessibleContext。
AccessibleContext | JDesktopPane.getAccessibleContext() 获取与此 JDesktopPane 关联的 AccessibleContext。
AccessibleContext | JEditorPane.getAccessibleContext() 获取与此 JEditorPane 关联的 AccessibleContext。
AccessibleContext | JFileChooser.getAccessibleContext() 获取与此 JFileChooser 关联的 AccessibleContext。
AccessibleContext | JOptionPane.getAccessibleContext() 返回与此 JOptionPane 相关联的 AccessibleContext。
AccessibleContext | JPasswordField.getAccessibleContext() 返回与此 JPasswordField 关联的 AccessibleContext。
AccessibleContext | JSpinner.getAccessibleContext() 获取此 JSpinner 的 AccessibleContext
AccessibleContext | ProgressMonitor.getAccessibleContext() 获得 ProgressMonitor 的 AccessibleContext。
AccessibleContext | JApplet.getAccessibleContext() 获取与此 JApplet 关联的 AccessibleContext。
AccessibleContext | JRadioButtonMenuItem.getAccessibleContext() 获取与此 JRadioButtonMenuItem 相关联的 AccessibleContext。
AccessibleContext | JSlider.getAccessibleContext() 获取与此 JSlider 关联的 AccessibleContext。
AccessibleContext | JToolTip.getAccessibleContext() 获取与此 JToolTip 关联的 AccessibleContext。
AccessibleContext | JTree.getAccessibleContext() 获取与此 JTree 关联的 AccessibleContext。
AccessibleContext | JTree.AccessibleJTree.AccessibleJTreeNode.getAccessibleContext() 获取与此树节点关联的 AccessibleContext。
AccessibleContext | JTable.getAccessibleContext() 获取与此 JTable 关联的 AccessibleContext。
AccessibleContext | JTable.AccessibleJTable.AccessibleJTableCell.getAccessibleContext() 获取与此组件关联的 AccessibleContext。
AccessibleContext | JProgressBar.getAccessibleContext() 获得与此 JProgressBar 关联的 AccessibleContext。
AccessibleContext | JCheckBox.getAccessibleContext() 获取与此 JCheckBox 关联的 AccessibleContext。
AccessibleContext | JTabbedPane.getAccessibleContext() 获取与此 JTabbedPane 关联的 AccessibleContext。
AccessibleContext | JRadioButton.getAccessibleContext() 获取与此 JRadioButton 相关联的 AccessibleContext。
AccessibleContext | JWindow.getAccessibleContext() 获取与此 JWindow 关联的 AccessibleContext。
AccessibleContext | JTextArea.getAccessibleContext() 获取与此 JTextArea 关联的 AccessibleContext。
AccessibleContext | JTextField.getAccessibleContext() 获取与此 JTextField 关联的 AccessibleContext。
AccessibleContext | JViewport.getAccessibleContext() 获取与此 JViewport 关联的 AccessibleContext。
AccessibleContext | JScrollPane.getAccessibleContext() 获取与此 JScrollPane 相关联的 AccessibleContext。
AccessibleContext | JList.getAccessibleContext() 获取与此 JList 关联的 AccessibleContext。
AccessibleContext | JList.AccessibleJList.AccessibleJListChild.getAccessibleContext() 获取此对象的 AccessibleContext。
AccessibleContext | CellRendererPane.getAccessibleContext() 获取与此 CellRendererPane 相关的 AccessibleContext。
AccessibleContext | JScrollBar.getAccessibleContext() 获取与此 JScrollBar 相关联的 AccessibleContext。
AccessibleContext | JComboBox.getAccessibleContext() 获取与此 JComboBox 关联的 AccessibleContext。
AccessibleContext | JSeparator.getAccessibleContext() 获取与此 JSeparator 相关的 AccessibleContext。
AccessibleContext | JPopupMenu.getAccessibleContext() 获取与此 JPopupMenu 关联的 AccessibleContext。
AccessibleContext | JMenuBar.getAccessibleContext() 获取与此 JMenuBar 相关联的 AccessibleContext。
AccessibleContext | Box.getAccessibleContext() 获取与此 Box 相关联的 AccessibleContext。
AccessibleContext | Box.Filler.getAccessibleContext() 获取与此 Box.Filler 相关联的 AccessibleContext。
AccessibleContext | JToggleButton.getAccessibleContext() 获取与此 JToggleButton 关联的 AccessibleContext。
AccessibleContext | JSplitPane.getAccessibleContext() 获取与 JSplitPane 关联的 AccessibleContext。
AccessibleContext | JToolBar.getAccessibleContext() 获取与此 JToolBar 关联的 AccessibleContext。
AccessibleContext | JDialog.getAccessibleContext() 获取与此 JDialog 关联的 AccessibleContext。
AccessibleContext | ImageIcon.getAccessibleContext() 获得与此 ImageIcon 关联的 AccessibleContext。
AccessibleContext | JButton.getAccessibleContext() 获取与此 JButton 关联的 AccessibleContext。
AccessibleContext | JCheckBoxMenuItem.getAccessibleContext() 获得与此 JCheckBoxMenuItem 关联的 AccessibleContext。
AccessibleContext | JMenu.getAccessibleContext() 获取与此 JMenu 关联的 AccessibleContext。
AccessibleContext | JMenuItem.getAccessibleContext() 返回与此 JMenuItem 关联的 AccessibleContext。
AccessibleContext | JInternalFrame.getAccessibleContext() 获得与此 JInternalFrame 关联的 AccessibleContext。
AccessibleContext | JInternalFrame.JDesktopIcon.getAccessibleContext() 获取与此 JDesktopIcon 关联的 AccessibleContext。
AccessibleContext | JLayeredPane.getAccessibleContext() 获得与此 JLayeredPane 关联的 AccessibleContext。
AccessibleContext | JPanel.getAccessibleContext() 获取与此 JPanel 关联的 AccessibleContext。
AccessibleContext | JRootPane.getAccessibleContext() 获取与此 JRootPane 相关联的 AccessibleContext。
AccessibleContext | JLabel.getAccessibleContext() 获得此对象的 AccessibleContext。
AccessibleContext | JComponent.getAccessibleContext() 返回与此 JComponent 关联的 AccessibleContext。
AccessibleContext | JFrame.getAccessibleContext() 获得与此 JFrame 关联的 AccessibleContext。
protected AccessibleContext | JTable.AccessibleJTable.AccessibleJTableCell.getCurrentAccessibleContext() 获取表单元格渲染器的 AccessibleContext。

javax.swing.plaf.basic 中 AccessibleContext 的使用

返回 AccessibleContext 的 javax.swing.plaf.basic 中的方法
 AccessibleContext BasicComboPopup.getAccessibleContext()
获取与此 BasicComboPopup 关联的 AccessibleContext。

javax.swing.table 中 AccessibleContext 的使用

javax.swing.table 中 AccessibleContext 的子类
protected class | JTableHeader.AccessibleJTableHeader 此类实现对 JTableHeader 类的可访问性支持。
protected class | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry 此类提供了适用于 JTableHeader 各条目的 Java Accessibility API 实现。

返回 AccessibleContext 的 javax.swing.table 中的方法
AccessibleContext | JTableHeader.getAccessibleContext() 获取与此 JTableHeader 关联的 AccessibleContext。
AccessibleContext | JTableHeader.AccessibleJTableHeader.AccessibleJTableHeaderEntry.getAccessibleContext() 获取与此对象关联的 AccessibleContext。

javax.swing.text 中 AccessibleContext 的使用

javax.swing.text 中 AccessibleContext 的子类
 class JTextComponent.AccessibleJTextComponent
此类实现 JTextComponent 类的可访问性支持。

返回 AccessibleContext 的 javax.swing.text 中的方法
 AccessibleContext JTextComponent.getAccessibleContext()
获取与此 JTextComponent 关联的 AccessibleContext。

javax.swing.text.html 中 AccessibleContext 的使用

返回 AccessibleContext 的 javax.swing.text.html 中的方法
 AccessibleContext HTMLEditorKit.getAccessibleContext()
返回与此编辑器工具包关联的 AccessibleContext。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ActivationDataFlavor (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 ActivationDataFlavor

java.lang.Object
    继承者  java.awt.datatransfer.DataFlavor
        继承者  javax.activation.ActivationDataFlavor
所有已实现的接口：
Externalizable, Serializable, Cloneable
public class ActivationDataFlavor
extends DataFlavor

ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。它允许 JAF 通过新的构造方法设置 DataFlavor 类所存储的所有三个值。它还包含 equals 方法中增强的 MIME 解析。除了增强的解析外，其语义与 JDK DataFlavor 类的语义相同。

从以下版本开始：
1.6
另请参见：
序列化表格

字段摘要
从类 java.awt.datatransfer.DataFlavor 继承的字段
imageFlavor, javaFileListFlavor, javaJVMLocalObjectMimeType, javaRemoteObjectMimeType, javaSerializedObjectMimeType, plainTextFlavor, stringFlavor
构造方法摘要
ActivationDataFlavor(Class representationClass, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。
ActivationDataFlavor(Class representationClass, String mimeType, String humanPresentableName)
构造一个表示任意 Java 对象的 DataFlavor。
ActivationDataFlavor(String mimeType, String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。
方法摘要
boolean | equals(DataFlavor dataFlavor) 将传入的 DataFlavor 与此 DataFlavor 进行比较；调用 isMimeTypeEqual 方法。
String | getHumanPresentableName() 返回得体的名称。
String | getMimeType() 返回此 DataFlavor 的 MIME 类型。
Class | getRepresentationClass() 返回表示形式类。
boolean | isMimeTypeEqual(String mimeType) 传入的 MIME 类型的字符串表示形式是否等效于此 DataFlavor 的 MIME 类型。
protected String | normalizeMimeType(String mimeType) 已过时。
protected String | normalizeMimeTypeParameter(String parameterName, String parameterValue) 已过时。
void | setHumanPresentableName(String humanPresentableName) 设置得体的名称。
从类 java.awt.datatransfer.DataFlavor 继承的方法
clone, equals, equals, getDefaultRepresentationClass, getDefaultRepresentationClassAsString, getParameter, getPrimaryType, getReaderForText, getSubType, getTextPlainUnicodeFlavor, hashCode, isFlavorJavaFileListType, isFlavorRemoteObjectType, isFlavorSerializedObjectType, isFlavorTextType, isMimeTypeEqual, isMimeTypeSerializedObject, isRepresentationClassByteBuffer, isRepresentationClassCharBuffer, isRepresentationClassInputStream, isRepresentationClassReader, isRepresentationClassRemote, isRepresentationClassSerializable, match, readExternal, selectBestTextFlavor, toString, tryToLoadClass, writeExternal
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ActivationDataFlavor

public ActivationDataFlavor(Class representationClass,
                            String mimeType,
                            String humanPresentableName)
构造一个表示任意 Java 对象的 DataFlavor。此构造方法是 JDK DataFlavor 的扩展，它允许显示设置所有三个 DataFlavor 属性。

返回的 DataFlavor 将具有以下特征：

representationClass = representationClass
mimeType = mimeType
humanName = humanName

参数：
representationClass - 此 DataFlavor 中使用的类
mimeType - 此类所表示数据的 MIME 类型
humanPresentableName - flavor 的得体的名称

ActivationDataFlavor

public ActivationDataFlavor(Class representationClass,
                            String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

返回的 DataFlavor 将具有以下特征：

如果 mimeType 为 "application/x-java-serialized-object; class="，则结果与调用新的 DataFlavor(Class:forName()) 相同（同上）。

否则：

representationClass = InputStream

mimeType = mimeType

参数：
representationClass - 此 DataFlavor 中使用的类
humanPresentableName - flavor 的得体的名称

ActivationDataFlavor

public ActivationDataFlavor(String mimeType,
                            String humanPresentableName)
构造一个表示 MimeType 的 DataFlavor。

返回的 DataFlavor 将具有以下特征：

如果 mimeType 为 "application/x-java-serialized-object; class="，则结果与调用新的 DataFlavor(Class:forName()) 相同（同上），否则：

representationClass = InputStream

mimeType = mimeType

参数：
mimeType - 此类表示的数据 MIME 类型
humanPresentableName - flavor 的得体的名称
方法详细信息

getMimeType

public String getMimeType()
返回此 DataFlavor 的 MIME 类型。

覆盖：
类 DataFlavor 中的 getMimeType
返回：
MIME 类型

getRepresentationClass

public Class getRepresentationClass()
返回表示形式类。

覆盖：
类 DataFlavor 中的 getRepresentationClass
返回：
表示形式类

getHumanPresentableName

public String getHumanPresentableName()
返回得体的名称。

覆盖：
类 DataFlavor 中的 getHumanPresentableName
返回：
得体的名称

setHumanPresentableName

public void setHumanPresentableName(String humanPresentableName)
设置得体的名称。

覆盖：
类 DataFlavor 中的 setHumanPresentableName
参数：
humanPresentableName - 要设置的名称。

equals

public boolean equals(DataFlavor dataFlavor)
将传入的 DataFlavor 与此 DataFlavor 进行比较；调用 isMimeTypeEqual 方法。

覆盖：
类 DataFlavor 中的 equals
参数：
dataFlavor - 要与之比较的 DataFlavor
返回：
如果 MIME 类型和表示形式类都相同，则返回 true
另请参见：
DataFlavor.selectBestTextFlavor(java.awt.datatransfer.DataFlavor[])

isMimeTypeEqual

public boolean isMimeTypeEqual(String mimeType)
传入的 MIME 类型的字符串表示形式是否等效于此 DataFlavor 的 MIME 类型。

ActivationDataFlavor 将 MIME 类型的比较委托给作为 JavaBeans Activation Framework 的一部分包含的 MimeType 类。相比 DataFlavor 类中通常可用的比较，此方法提供的比较更加健壮。

覆盖：
类 DataFlavor 中的 isMimeTypeEqual
参数：
mimeType - MIME 类型
返回：
如果 MIME 类型相同，则返回 true

normalizeMimeTypeParameter

protected String normalizeMimeTypeParameter(String parameterName,
                                            String parameterValue)
已过时。

针对每个 MIME 类型参数对 DataFlavor 调用此方法，以允许 DataFlavor 子类处理特定参数，如文本/纯文本 charset 参数，其值是不区分大小写的。（MIME 类型参数值应该区分大小写）。

为每个参数名/值对调用此方法，应该返回 parameterValue 的标准化表示形式。此实现不再调用此方法。

覆盖：
类 DataFlavor 中的 normalizeMimeTypeParameter
参数：
parameterName - 参数名称
parameterValue - 参数值
返回：
标准化的参数值

normalizeMimeType

protected String normalizeMimeType(String mimeType)
已过时。

为每个 MIME 类型字符串调用此方法，以使 DataFlavor 子类型能够更改实现 MIME 类型标准化的方式。一种可能的用法是，在传入的 MIME 类型字符串中不存在参数/值对的情况下添加默认的参数/值对。此实现不再调用此方法。

覆盖：
类 DataFlavor 中的 normalizeMimeType
参数：
mimeType - MIME 类型
返回：
标准化的 MIME 类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CommandInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 CommandInfo

java.lang.Object
    继承者  javax.activation.CommandInfo

public class CommandInfo
extends Object

CommandMap 实现使用 CommandInfo 类描述命令请求的结果。它为请求者提供所请求的动词，以及 bean 的一个实例。还有一个方法，它将返回实现命令的类的名称，但是它不保证返回有效值。原因是允许子类化 CommandInfo 的 CommandMap 实现提供特殊行为。例如，CommandMap 能够动态生成 JavaBean。在这种情况下，不太可能仅根据类名称便创建带有全部正确状态信息的对象。

从以下版本开始：
1.6

构造方法摘要
CommandInfo(String verb, String className)
CommandInfo 的构造方法。
方法摘要
String | getCommandClass() 返回命令的类名。
String | getCommandName() 返回命令动词。
Object | getCommandObject(DataHandler dh, ClassLoader loader) 返回已实例化的 JavaBean 组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CommandInfo

public CommandInfo(String verb,
                   String className)
CommandInfo 的构造方法。

参数：
verb - 此 CommandInfo 描述的命令动词。
className - 命令的完全限定类名。
方法详细信息

getCommandName

public String getCommandName()
返回命令动词。

返回：
命令动词。

getCommandClass

public String getCommandClass()
返回命令的类名。当 CommandMap 根据其目的子类化 CommandInfo 时，此方法可能返回 null。换句话说，仅知道其类名不太可能创建命令的正确状态。不要依赖此方法来返回有效值！

返回：
命令的类名，或 null

getCommandObject

public Object getCommandObject(DataHandler dh,
                               ClassLoader loader)
                        throws IOException,
                               ClassNotFoundException
返回已实例化的 JavaBean 组件。

从用 Beans.instantiate() 实例化组件开始。

如果 bean 实现了 javax.activation.CommandObject 接口，则调用其 setCommandContext 方法。

如果 DataHandler 参数为 null，则 bean 被实例化，且不带任何数据。注:如果由于某种原因，此方法试图访问其 InputStream 时传入的 DataHandler 抛出 IOExceptions，那么这将很有用。它将允许调用者获取对 bean 的引用（如果它可以被实例化）。

如果 bean 不实现 CommandObject 接口，那么此方法将检查它是否实现 java.io.Externalizable 接口。如果它实现 CommandObject 接口，若可以从 DataHandler 获取 InputStream，则将调用 bean 的 readExternal 方法。

参数：
dh - 描述要传递给命令的数据的 DataHandler。
loader - 将用于实例化 bean 的 ClassLoader。
返回：
bean
抛出：
IOException
ClassNotFoundException
另请参见：
Beans.instantiate(java.lang.ClassLoader, java.lang.String), CommandObject
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CommandMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 CommandMap

java.lang.Object
    继承者  javax.activation.CommandMap
直接已知子类：
MailcapCommandMap
public abstract class CommandMap
extends Object

CommandMap 类为系统中可用的命令对象注册表提供接口。期望开发人员使用此包 (MailcapCommandMap) 所包含的 CommandMap 实现，或者开发他们自己的实现。注意，此类中有些方法是抽象的。

从以下版本开始：
1.6

构造方法摘要
CommandMap()
方法摘要
abstract DataContentHandler | createDataContentHandler(String mimeType) 查找与 MIME 类型对应的 DataContentHandler。
DataContentHandler | createDataContentHandler(String mimeType, DataSource ds) 查找与 MIME 类型对应的 DataContentHandler。
abstract CommandInfo[] | getAllCommands(String mimeType) 获取此类型的所有可用命令。
CommandInfo[] | getAllCommands(String mimeType, DataSource ds) 获取此类型的所有可用命令。
abstract CommandInfo | getCommand(String mimeType, String cmdName) 获取与 MIME 类型对应的默认命令。
CommandInfo | getCommand(String mimeType, String cmdName, DataSource ds) 获取与 MIME 类型对应的默认命令。
static CommandMap | getDefaultCommandMap() 获取默认的 CommandMap。
String[] | getMimeTypes() 获取此命令映射已知的所有 MIME 类型。
abstract CommandInfo[] | getPreferredCommands(String mimeType) 从 MIME 类型获取首选命令表。
CommandInfo[] | getPreferredCommands(String mimeType, DataSource ds) 从 MIME 类型获取首选命令表。
static void | setDefaultCommandMap(CommandMap commandMap) 设置默认的 CommandMap。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CommandMap

public CommandMap()
方法详细信息

getDefaultCommandMap

public static CommandMap getDefaultCommandMap()
获取默认的 CommandMap。

  • 在 CommandMap 实例已经被设置为某值（通过setDefaultCommandMap）的情况下，返回该 CommandMap。
  • 在没有设置任何 CommandMap 的情况下，CommandMap 创建一个 MailcapCommandMap 的实例并将其设置为默认值，返回它的值。

返回：
CommandMap

setDefaultCommandMap

public static void setDefaultCommandMap(CommandMap commandMap)
设置默认的 CommandMap。通过用 null 调用此方法将 CommandMap 重置为默认值。

参数：
commandMap - 新的默认 CommandMap。
抛出：
SecurityException - 如果调用者不具有更改默认的权限

getPreferredCommands

public abstract CommandInfo[] getPreferredCommands(String mimeType)
从 MIME 类型获取首选命令表。实际语义由 CommandMap 的实现来确定。

参数：
mimeType - MIME 类型
返回：
表示命令 Bean 的 CommandInfo 类

getPreferredCommands

public CommandInfo[] getPreferredCommands(String mimeType,
                                          DataSource ds)
从 MIME 类型获取首选命令表。实际语义由 CommandMap 的实现来确定。

DataSource 提供额外信息，比如文件名，CommandMap 实现可以使用它进一步改进返回的命令表。此类中的实现调用 getPreferredCommands 方法，忽略此参数。

参数：
mimeType - MIME 类型
ds - 数据的 DataSource
返回：
表示命令 Bean 的 CommandInfo 类
从以下版本开始：
JAF 1.1

getAllCommands

public abstract CommandInfo[] getAllCommands(String mimeType)
获取此类型的所有可用命令。此方法应该返回此 MIME 类型的所有可能命令。

参数：
mimeType - MIME 类型
返回：
表示所有命令的 CommandInfo 对象

getAllCommands

public CommandInfo[] getAllCommands(String mimeType,
                                    DataSource ds)
获取此类型的所有可用命令。此方法应该返回此 MIME 类型的所有可能命令。

DataSource 提供额外信息，比如文件名，CommandMap 实现可以使用它进一步改进返回的命令表。此类中的实现调用 getAllCommands 方法，忽略此参数。

参数：
mimeType - MIME 类型
ds - 数据的 DataSource
返回：
表示所有命令的 CommandInfo 对象。
从以下版本开始：
JAF 1.1

getCommand

public abstract CommandInfo getCommand(String mimeType,
                                       String cmdName)
获取与 MIME 类型对应的默认命令。

参数：
mimeType - MIME 类型
cmdName - 命令名
返回：
与命令对应的 CommandInfo

getCommand

public CommandInfo getCommand(String mimeType,
                              String cmdName,
                              DataSource ds)
获取与 MIME 类型对应的默认命令。

DataSource 提供额外信息，比如文件名，CommandMap 实现可以使用它进一步改进选择的命令。此类中的实现调用 getCommand 方法，忽略此参数。

参数：
mimeType - MIME 类型
cmdName - 命令名
ds - 数据的 DataSource
返回：
与命令对应的 CommandInfo
从以下版本开始：
JAF 1.1

createDataContentHandler

public abstract DataContentHandler createDataContentHandler(String mimeType)
查找与 MIME 类型对应的 DataContentHandler。确定它的机制和语义由特定 CommandMap 的实现确定。

参数：
mimeType - MIME 类型
返回：
MIME 类型的 DataContentHandler

createDataContentHandler

public DataContentHandler createDataContentHandler(String mimeType,
                                                   DataSource ds)
查找与 MIME 类型对应的 DataContentHandler。确定它的机制和语义由特定 CommandMap 的实现确定。

DataSource 提供额外信息，比如文件名称，CommandMap 实现可以使用它进一步改进 DataContentHandler 的选择。此类中的实现调用 createDataContentHandler 方法，忽略此参数。

参数：
mimeType - MIME 类型
ds - 数据的 DataSource
返回：
MIME 类型的 DataContentHandler
从以下版本开始：
JAF 1.1

getMimeTypes

public String[] getMimeTypes()
获取此命令映射已知的所有 MIME 类型。如果命令映射不支持此操作，则返回 null。

返回：
以字符串形式返回 MIME 类型数组；如果不支持，则返回 null
从以下版本开始：
JAF 1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CommandObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
接口 CommandObject

public interface CommandObject

Activation Framework 所知的 JavaBean 组件实现此接口，以找出请求这些组件执行的命令动词，并获取表示这些组件要操作的数据的 DataHandler。不实现此接口的 JavaBean 也同样可以使用。这类命令可以使用 Externalizable 接口或特定于应用程序的方法来获取数据。

从以下版本开始：
1.6

方法摘要
 void setCommandContext(String verb, DataHandler dh)
用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。

方法详细信息

setCommandContext

void setCommandContext(String verb,
                       DataHandler dh)
                       throws IOException
用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。注：调用者为 DataHandler 传递 null 值是可以接受的。

参数：
verb - 此对象引用的 Command Verb。
dh - DataHandler。
抛出：
IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataContentHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
接口 DataContentHandler

public interface DataContentHandler

DataContentHandler 接口由可用于扩展 Transferable 接口的 DataHandler 实现性能的对象来实现。通过 DataContentHandlers 可扩展该框架，使它能够将流转入对象，并能将对象写入流。

应用程序通常不直接调用 DataContentHandler 中的方法。相反，应用程序调用 DataHandler 中的等效方法。DataHandler 将使用当前 DataContentHandlerFactory 尝试找到与其 MIME 类型对应的恰当 DataContentHandler。然后，DataHandler 调用到该 DataContentHandlerthen 中的方法。

从以下版本开始：
1.6

方法摘要
Object | getContent(DataSource ds) 返回一个对象，该对象表示其首选形式的数据。
Object | getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。
DataFlavor[] | getTransferDataFlavors() 返回一个 DataFlavor 对象数组，这些对象指示可用于提供数据的 flavor。
void | writeTo(Object obj, String mimeType, OutputStream os) 将对象转换为指定 MIME 类型的字节流，并将其写入输出流。

方法详细信息

getTransferDataFlavors

DataFlavor[] getTransferDataFlavors()
返回一个 DataFlavor 对象数组，这些对象指示可用于提供数据的 flavor。该数组应该根据提供数据的首选项来排序（从描述最多的到描述最少的）。

返回：
DataFlavor。

getTransferData

Object getTransferData(DataFlavor df,
                       DataSource ds)
                       throws UnsupportedFlavorException,
                              IOException
返回一个对象，该对象表示将要传输的数据。返回的对象的类是由该 flavor 的表示形式类定义的。

参数：
df - 表示所请求类型的 DataFlavor。
ds - 表示要转换的数据的 DataSource。
返回：
构造的对象
抛出：
UnsupportedFlavorException - 如果处理程序不支持所请求的 flavor
IOException - 如果数据不能被访问

getContent

Object getContent(DataSource ds)
                  throws IOException
返回一个对象，该对象表示其首选形式的数据。通常，这将是 getTransferDataFlavors 方法返回的第一个 DataFlavor 所描述的形式。

参数：
ds - 表示要转换的数据的 DataSource。
返回：
构造的对象。
抛出：
IOException - 如果数据不能被访问

writeTo

void writeTo(Object obj,
             String mimeType,
             OutputStream os)
             throws IOException
将对象转换为指定 MIME 类型的字节流，并将其写入输出流。

参数：
obj - 要转换的对象。
mimeType - 所请求的结果字节流的 MIME 类型。
os - 要写入转换的字节流的输出流。
抛出：
IOException - 写入流时出现错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataContentHandlerFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
接口 DataContentHandlerFactory

public interface DataContentHandlerFactory

此接口定义了 DataContentHandler 的工厂。此接口的实现应该将 MIME 类型映射到 ContentHandler 的实例中。类实现此接口的设计模式与 java.net.URL 中使用的 ContentHandler 机制相同。

从以下版本开始：
1.6

方法摘要
 DataContentHandler createDataContentHandler(String mimeType)
针对 MIME 类型创建一个新的 DataContentHandler 对象。

方法详细信息

createDataContentHandler

DataContentHandler createDataContentHandler(String mimeType)
针对 MIME 类型创建一个新的 DataContentHandler 对象。

参数：
mimeType - 要为其创建 DataContentHandler 的 MIME 类型。
返回：
新的 DataContentHandler；如果不存在，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 DataHandler

java.lang.Object
    继承者  javax.activation.DataHandler
所有已实现的接口：
Transferable
public class DataHandler
extends Object
implements Transferable

DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。它使用 DataContentHandler 管理简单流到字符串的转换以及相关操作。它提供对能够操作数据的命令的访问。使用 CommandMap 可以找到这些命令。

DataHandler 和 Transferable 接口

DataHandler 实现 Transferable 接口，以便数据能够用于 AWT 数据传输操作，比如，剪切、粘贴和拖放操作。Transferable 接口的实现依赖于已安装的 DataContentHandler 对象的可用性，该 DataContentHandler 对象与 DataHandler 的特定实例中所表示的数据的 MIME 类型相对应。

DataHandler 和 CommandMap

DataHandler 跟踪当前 CommandMap，它用于命令（getCommand、getAllCommands、getPreferredCommands）的服务请求。使用 setCommandMap 方法，DataHandler 的每个实例都可以有一个与其相关的 CommandMap。如果没有设置 CommandMap，则 DataHandler 调用 CommandMap 中的 getDefaultCommandMap 方法，并使用其返回值。有关更多信息，请参见 CommandMap。

DataHandler 和 URL

当用 URL 构造 DataHandler 时，当前 DataHandler 实现创建一个 URLDataSource 的私有实例。

从以下版本开始：
1.6
另请参见：
CommandMap, DataContentHandler, DataSource, URLDataSource

构造方法摘要
DataHandler(DataSource ds)
创建引用指定 DataSource 的 DataHandler 实例。
DataHandler(Object obj, String mimeType)
创建表示此 MIME 类型对象的 DataHandler 实例。
DataHandler(URL url)
创建引用 URL 的 DataHandler 实例。
方法摘要
CommandInfo[] | getAllCommands() 返回此数据类型的所有命令。
Object | getBean(CommandInfo cmdinfo) 一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。
CommandInfo | getCommand(String cmdName) 获取命令 cmdName。
Object | getContent() 以其首选 Object 的形式返回数据。
String | getContentType() 返回从源对象中获取的此对象的 MIME 类型。
DataSource | getDataSource() 返回与此 DataHandler 实例关联的 DataSource。
InputStream | getInputStream() 获取此对象的 InputSteam。
String | getName() 返回数据对象的名称。
OutputStream | getOutputStream() 获取此 DataHandler 的 OutputStream，以允许重写底层数据。
CommandInfo[] | getPreferredCommands() 返回此数据类型的首选 命令。
Object | getTransferData(DataFlavor flavor) 返回一个对象，该对象表示要传输的数据。
DataFlavor[] | getTransferDataFlavors() 返回此数据在其中可用的 DataFlavor。
boolean | isDataFlavorSupported(DataFlavor flavor) 返回此对象是否支持指定的数据 flavor。
void | setCommandMap(CommandMap commandMap) 设置此 DataHandler 使用的 CommandMap。
static void | setDataContentHandlerFactory(DataContentHandlerFactory newFactory) 设置 DataContentHandlerFactory。
void | writeTo(OutputStream os) 将数据写入 OutputStream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DataHandler

public DataHandler(DataSource ds)
创建引用指定 DataSource 的 DataHandler 实例。数据以字节流的形式存在。DataSource 将提供一个 InputStream 来访问数据。

参数：
ds - DataSource

DataHandler

public DataHandler(Object obj,
                   String mimeType)
创建表示此 MIME 类型对象的 DataHandler 实例。当应用程序已经有 Java Object 形式的数据内存表示形式 (in-memory representation) 时，使用此构造方法。

参数：
obj - Java Object
mimeType - 对象的 MIME 类型

DataHandler

public DataHandler(URL url)
创建引用 URL 的 DataHandler 实例。DataHandler 在内部创建一个 URLDataSource 实例来表示 URL。

参数：
url - URL 对象
方法详细信息

getDataSource

public DataSource getDataSource()
返回与此 DataHandler 实例关联的 DataSource。

对于已经用 DataSource 实例化的 DataHandler，此方法返回用来创建该 DataHandler 对象的 DataSource。在其他情况下，DataHandler 根据用来构造 DataHandler 的数据构造 DataSource。对于没有用 DataSource 实例化的 DataHandler，为其创建的 DataSource 将被缓存，以提高性能。

返回：
对此 DataHandler 有效的 DataSource 对象

getName

public String getName()
返回数据对象的名称。如果此 DataHandler 是用 DataSource 创建的，则此方法直接调用 DataSource.getName 方法；否则返回 null。

返回：
对象的名称

getContentType

public String getContentType()
返回从源对象中获取的此对象的 MIME 类型。注意，这是带有参数的完整 类型。

返回：
MIME 类型

getInputStream

public InputStream getInputStream()
                           throws IOException
获取此对象的 InputSteam。

对于用 DataSource 实例化的 DataHandler，该 DataHandler 调用 DataSource.getInputStream 方法，并将结果返回给调用者。

对于用 Object 实例化的 DataHandler，该 DataHandler 首先尝试找到 Object 的 DataContentHandler。如果 DataHandler 找不到此 MIME 类型的 DataContentHandler，则抛出 UnsupportedDataTypeException。如果能够找到，则它将创建一个管道和一个线程。该线程使用 DataContentHandler 的 writeTo 方法将流数据写入管道的一端。管道的另一端返回给调用者。由于为复制数据创建了一个线程，所以在复制过程中发生的 IOException 不能传送回调用者。结果将是一个空流。

返回：
表示此数据的 InputStream
抛出：
IOException - 如果发生 I/O 错误
另请参见：
DataContentHandler.writeTo(java.lang.Object, java.lang.String, java.io.OutputStream), UnsupportedDataTypeException

writeTo

public void writeTo(OutputStream os)
             throws IOException
将数据写入 OutputStream。

如果 DataHandler 是用 DataSource 创建的，那么 writeTo 获取 InputStream 并将字节从 Inputstream 复制到传入的 Outputstream。

如果 DataHandler 是用 Object 创建的，则 writeTo 获取对象类型的 DataContentHandler。如果找到了 DataContentHandler，则它对 DataContentHandler 调用 writeTo 方法。

参数：
os - 要写入的 OutputStream
抛出：
IOException - 如果发生 I/O 错误

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
获取此 DataHandler 的 OutputStream，以允许重写底层数据。如果 DataHandler 是用 DataSource 创建的，则调用 DataSource 的 getOutputStream 方法。否则，返回 null。

返回：
OutputStream
抛出：
IOException
另请参见：
DataSource.getOutputStream(), URLDataSource

getTransferDataFlavors

public DataFlavor[] getTransferDataFlavors()
返回此数据在其中可用的 DataFlavor。

返回能够提供数据的 flavor 的 DataFlavor 对象所组成的数组。该数组通常根据提供数据的首选项来排序（从描述最多的到描述最少的）。

DataHandler 尝试查找与数据的 MIME 类型对应的 DataContentHandler。如果找到，则该 DataHandler 调用 DataContentHandler 的 getTransferDataFlavors 方法。

如果不 能找到 DataContentHandler，并且 DataHandler 是用 DataSource （或 URL）创建的，则返回一个表示此对象 MIME 类型和 java.io.InputStream 类的 DataFlavor。如果 DataHandler 是用对象和 MIME 类型创建的，则 getTransferDataFlavors 返回一个表示此对象 MIME 类型和对象类的 DataFlavor。

指定者：
接口 Transferable 中的 getTransferDataFlavors
返回：
其中可以传输此数据的数据 flavor 所组成的数组
另请参见：
DataContentHandler.getTransferDataFlavors()

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor flavor)
返回此对象是否支持指定的数据 flavor。

此方法迭代 getTransferDataFlavors 返回的 DataFlavor，将每个 DataFlavor 与指定 flavor 进行比较。

指定者：
接口 Transferable 中的 isDataFlavorSupported
参数：
flavor - 为数据所请求的 flavor
返回：
如果支持该数据 flavor，则返回 true
另请参见：
getTransferDataFlavors()

getTransferData

public Object getTransferData(DataFlavor flavor)
                       throws UnsupportedFlavorException,
                              IOException
返回一个对象，该对象表示要传输的数据。返回对象的类是由该数据 flavor 的表示形式类定义的。

对于用 DataSource 或 URL 创建的 DataHandler：

DataHandler 尝试为此 MIME 类型查找一个 DataContentHandler。如果找到，则将传入的 DataFlavor 和数据的类型传递给其 getTransferData 方法。如果 DataHandler 没有找到 DataContentHandler，并且 flavor 指定了此对象的 MIME 类型和 java.io.InputStream 类，则返回此对象的 InputStream。否则，抛出 UnsupportedFlavorException。

对于用 Object 创建的 DataHandler：

DataHandler 尝试为此 MIME 类型查找一个 DataContentHandler。如果找到，则将传入的 DataFlavor 和数据的类型传递给其 getTransferData 方法。如果 DataHandler 没有找到 DataContentHandler，并且 flavor 指定了此对象的 MIME 类型和它的类，则返回此 DataHandler 的引用对象。否则，抛出 UnsupportedFlavorException。

指定者：
接口 Transferable 中的 getTransferData
参数：
flavor - 为数据所请求的 flavor
返回：
对象
抛出：
UnsupportedFlavorException - 如果不能将该数据转换为所请求的 flavor
IOException - 如果发生 I/O 错误
另请参见：
ActivationDataFlavor

setCommandMap

public void setCommandMap(CommandMap commandMap)
设置此 DataHandler 使用的 CommandMap。将其设置为 null 会使该 CommandMap 还原为 CommandMap.getDefaultCommandMap 方法所返回的 CommandMap。更改该 CommandMap 或将其设置为 null 将清除以前的 CommandMap 所缓存的所有数据。

参数：
commandMap - 此 DataHandler 中使用的 CommandMap
另请参见：
CommandMap.setDefaultCommandMap(javax.activation.CommandMap)

getPreferredCommands

public CommandInfo[] getPreferredCommands()
返回此数据类型的首选 命令。此方法调用 CommandMap 中与此 DataHandler 实例关联的 getPreferredCommands 方法。此方法返回一个表示可用命令子集的数组。如果存在由此 DataHandler 表示的 MIME 类型的多个命令，则已安装的 CommandMap 将选择适当的命令。

返回：
表示首选命令的 CommandInfo 对象
另请参见：
CommandMap.getPreferredCommands(java.lang.String)

getAllCommands

public CommandInfo[] getAllCommands()
返回此数据类型的所有命令。此方法返回一个数组，此数组包含此 DataHandler 所表示的数据类型的所有命令。此 DataHandler 所表示的底层数据的 MIME 类型用于调用与此 DataHandler 关联的 CommandMap 的 getAllCommands 方法。

返回：
表示所有命令的 CommandInfo 对象
另请参见：
CommandMap.getAllCommands(java.lang.String)

getCommand

public CommandInfo getCommand(String cmdName)
获取命令 cmdName。使用此 DataHandler 中已安装的 CommandMap 所定义的搜索语义。此 DataHandler 所表示的底层数据的 MIME 类型用于调用与此 DataHandler 关联的 CommandMap 的 getCommand 方法。

参数：
cmdName - 命令名
返回：
与命令对应的 CommandInfo
另请参见：
CommandMap.getCommand(java.lang.String, java.lang.String)

getContent

public Object getContent()
                  throws IOException
以其首选 Object 的形式返回数据。

如果 DataHandler 是用一个对象实例化的，则返回该对象。

如果 DataHandler 是用 DataSource 实例化的，则此方法使用 DataContentHandler 返回此 DataHandler 所表示数据的内容对象。如果找不到此数据类型的 DataContentHandler，则 DataHandler 返回数据的 InputStream。

返回：
内容。
抛出：
IOException - 如果此操作中发生 IOException。

getBean

public Object getBean(CommandInfo cmdinfo)
一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。

此方法调用 CommandInfo 的 getCommandObject 方法，带有用于加载 javax.activation.DataHandler 类本身的 ClassLoader。

参数：
cmdinfo - 与命令对应的 CommandInfo
返回：
已实例化的命令对象

setDataContentHandlerFactory

public static void setDataContentHandlerFactory(DataContentHandlerFactory newFactory)
设置 DataContentHandlerFactory。首先调用 DataContentHandlerFactory 来查找 DataContentHandler。DataContentHandlerFactory 只能被设置一次。

如果 DataContentHandlerFactory 已经被设置，则此方法抛出 Error。

参数：
newFactory - DataContentHandlerFactory
抛出：
Error - 如果工厂已经被定义。
另请参见：
DataContentHandlerFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
接口 DataSource

所有已知实现类：
FileDataSource, URLDataSource
public interface DataSource

DataSource 接口为 JavaBeans Activation Framework 提供任意数据集合的抽象。它提供该数据的类型，并在适当的时候以 InputStream 和 OutputStream 的形式提供对该数据的访问。

从以下版本开始：
1.6

方法摘要
String | getContentType() 此方法以字符串形式返回数据的 MIME 类型。
InputStream | getInputStream() 此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。
String | getName() 返回此对象的名称，其中对象的名称依赖于底层对象的特性。
OutputStream | getOutputStream() 此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。

方法详细信息

getInputStream

InputStream getInputStream()
                           throws IOException
此方法返回一个表示数据的 InputStream；如果无法提供，则抛出适当的异常。注意，每次调用此方法时都必须返回一个新的 InputStream 对象，并且流必须位于数据的开始位置。

返回：
一个 InputStream
抛出：
IOException

getOutputStream

OutputStream getOutputStream()
                             throws IOException
此方法返回一个可以写入数据的 OutputStream，如果无法返回，则抛出适当的异常。注意，每次调用此方法时都必须返回一个新的 OutputStream 对象，并且流必须位于要写入数据的位置。

返回：
一个 OutputStream
抛出：
IOException

getContentType

String getContentType()
此方法以字符串形式返回数据的 MIME 类型。应该始终返回有效类型。如果 DataSource 实现不能确定数据类型，则建议 getContentType 返回 "application/octet-stream"。

返回：
MIME 类型

getName

String getName()
返回此对象的名称，其中对象的名称依赖于底层对象的特性。封装文件的 DataSources 可以选择返回对象的文件名。(通常，这是文件名的最后部分，并不是完整路径名。)

返回：
对象的名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileDataSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 FileDataSource

java.lang.Object
    继承者  javax.activation.FileDataSource
所有已实现的接口：
DataSource
public class FileDataSource
extends Object
implements DataSource

FileDataSource 类实现一个封装文件的简单 DataSource 对象。它通过 FileTypeMap 对象提供数据分类服务。

FileDataSource 分类语义

FileDataSource 类将文件的数据分类委托给一个从 FileTypeMap 类子类化的对象。setFileTypeMap 方法可用于为 FileDataSource 实例显示地设置 FileTypeMap。如果没有设置任何 FileTypeMap，则 FileDataSource 将调用 FileTypeMap 的 getDefaultFileTypeMap 方法获取系统的默认 FileTypeMap。

从以下版本开始：
1.6
另请参见：
DataSource, FileTypeMap, MimetypesFileTypeMap

构造方法摘要
FileDataSource(File file)
根据 File 对象创建 FileDataSource。
FileDataSource(String name)
根据指定的路径名创建 FileDataSource。
方法摘要
String | getContentType() 此方法以字符串形式返回数据的 MIME 类型。
File | getFile() 返回与此 FileDataSource 对应的 File 对象。
InputStream | getInputStream() 此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。
String | getName() 返回此对象的名称。
OutputStream | getOutputStream() 此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。
void | setFileTypeMap(FileTypeMap map) 设置用于此 FileDataSource 的 FileTypeMap。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileDataSource

public FileDataSource(File file)
根据 File 对象创建 FileDataSource。注：在调用要求文件打开的方法之前，文件实际上不会打开。

参数：
file - 文件

FileDataSource

public FileDataSource(String name)
根据指定的路径名创建 FileDataSource。注：在调用要求文件打开的方法之前，文件实际上不会打开。

参数：
name - 与系统有关的文件名。
方法详细信息

getInputStream

public InputStream getInputStream()
                           throws IOException
此方法将返回一个表示数据的 InputStream；如果不能返回，则抛出 IOException。每次调用此方法都会返回一个新的 InputStream 实例。

指定者：
接口 DataSource 中的 getInputStream
返回：
一个 InputStream
抛出：
IOException

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
此方法将返回一个表示数据的 OutputStream；如果不能返回，则抛出 IOException。每次调用此方法都会返回一个新的 OutputStream 实例。

指定者：
接口 DataSource 中的 getOutputStream
返回：
一个 OutputStream
抛出：
IOException

getContentType

public String getContentType()
此方法以字符串形式返回数据的 MIME 类型。此方法使用当前安装的 FileTypeMap。如果没有显示地设置任何 FileTypeMap，FileDataSource 将对 FileTypeMap 调用 getDefaultFileTypeMap 方法获取默认的 FileTypeMap。注：默认情况下，使用的 FileTypeMap 是 MimetypesFileTypeMap。

指定者：
接口 DataSource 中的 getContentType
返回：
MIME 类型
另请参见：
FileTypeMap.getDefaultFileTypeMap()

getName

public String getName()
返回此对象的名称。FileDataSource 将返回对象的文件名。

指定者：
接口 DataSource 中的 getName
返回：
对象的名称。
另请参见：
DataSource

getFile

public File getFile()
返回与此 FileDataSource 对应的 File 对象。

返回：
此对象表示的文件的 File 对象。

setFileTypeMap

public void setFileTypeMap(FileTypeMap map)
设置用于此 FileDataSource 的 FileTypeMap。

参数：
map - 此对象的 FileTypeMap。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileTypeMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 FileTypeMap

java.lang.Object
    继承者  javax.activation.FileTypeMap
直接已知子类：
MimetypesFileTypeMap
public abstract class FileTypeMap
extends Object

FileTypeMap 是一个抽象类，它为文件提供数据分类接口。此类的实现将实现 getContentType 方法，该方法将从文件名或 File 对象得到内容类型。FileTypeMap 可以使用任一方案来确定数据类型，从检查文件的文件扩展名（如 MimetypesFileTypeMap）到打开文件并尝试从文件内容得到其类型。FileDataSource 类使用默认的 FileTypeMap（若无更改，则是 MimetypesFileTypeMap）来确定文件的内容类型。

从以下版本开始：
1.6
另请参见：
FileTypeMap, FileDataSource, MimetypesFileTypeMap

构造方法摘要
FileTypeMap()
默认的构造方法。
方法摘要
abstract String | getContentType(File file) 返回文件对象的类型。
abstract String | getContentType(String filename) 返回传入文件的类型。
static FileTypeMap | getDefaultFileTypeMap() 返回系统的默认 FileTypeMap。
static void | setDefaultFileTypeMap(FileTypeMap map) 设置系统的默认 FileTypeMap。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileTypeMap

public FileTypeMap()
默认的构造方法。

方法详细信息

getContentType

public abstract String getContentType(File file)
返回文件对象的类型。此方法应始终返回有效的 MIME 类型。

参数：
file - 要分类的文件。
返回：
内容类型。

getContentType

public abstract String getContentType(String filename)
返回传入文件的类型。此方法应始终返回有效的 MIME 类型。

参数：
filename - 文件的路径名。
返回：
内容类型。

setDefaultFileTypeMap

public static void setDefaultFileTypeMap(FileTypeMap map)
设置系统的默认 FileTypeMap。此实例将返回给 getDefaultFileTypeMap 的调用者。

参数：
map - FileTypeMap。
抛出：
SecurityException - 如果调用者不具有更改默认值的权限

getDefaultFileTypeMap

public static FileTypeMap getDefaultFileTypeMap()
返回系统的默认 FileTypeMap。如果调用了 setDefaultFileTypeMap，则返回该实例，否则返回 MimetypesFileTypeMap 的一个实例。

返回：
默认的 FileTypeMap
另请参见：
setDefaultFileTypeMap(javax.activation.FileTypeMap)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MailcapCommandMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 MailcapCommandMap

java.lang.Object
    继承者  javax.activation.CommandMap
        继承者  javax.activation.MailcapCommandMap

public class MailcapCommandMap
extends CommandMap

MailcapCommandMap 扩展 CommandMap 抽象类。它实现配置基于 mailcap 文件 (RFC 1524) 的 CommandMap。可以以编程方式和通过配置文件的方式来配置 MailcapCommandMap。

mailcap 文件搜索顺序：

MailcapCommandMap 在用户系统的各个位置查找 mailcap 文件条目。当发出请求以搜索 MailcapCommandMap 中的命令时，它以下面的顺序搜索 mailcap 文件：

  1. 以编程方式添加到 MailcapCommandMap 实例的条目。
  2. 用户主目录中的 .mailcap 文件。
  3. <java.home>/lib/mailcap 文件。
  4. 名为 META-INF/mailcap 的文件或资源。
  5. 名为 META-INF/mailcap.default 的文件或资源（通常只存在于 activation.jar 文件中）。

mailcap 文件格式：

mailcap 文件必须符合 mailcap 文件规范 (RFC 1524, A User Agent Configuration Mechanism For Multimedia Mail Format Information)。文件格式由与特定 MIME 类型对应的条目组成。一般情况下，当客户机本身不能对指定的 MIME 类型进行操作时，该规范为其指定使用的应用程序。MailcapCommandMap 扩展了此规范，它在 mailcap 文件中使用一个参数机制，该机制允许指定 JavaBeans(tm) 组件对应于 MIME 类型的特定命令。

解析一个 mailcap 文件时，MailcapCommandMap 识别出某些参数签名，特别是以 x-java- 开头的参数名称。MailcapCommandMap 使用此签名查找命令条目，以将其包含到注册表。用名称 name 标识一个命令时，MailcapCommandMap 读取 x-java-<name> 形式的参数名称。当 name 为 content-handler 时，MailcapCommandMap 将此参数所表示的类视为 DataContentHandler。所有其他命令的处理通常忽略其命令名。命令实现由 JavaBean(tm) 组件的一个完全限定类名指定。例如，查看某些数据的命令可以被指定为：x-java-view=com.foo.ViewBean。

当命令名是 fallback-entry 时，命令的值可以为 true 或 false。包含 x-java-fallback-entry=true 参数的 MIME 类型的条目定义了该 MIME 类型的回退 (fallback) 命令，只在找不到非回退条目的情况下才使用该命令。例如，形式为 text/*; ; x-java-fallback-entry=true; x-java-view=com.sun.TextViewer 的条目指定了用于任何文本 MIME 类型的查看命令。此查看命令只在找不到 MIME 类型的非回退查看命令的情况下使用。

支持 MailcapCommandMap 的 mailcap 文件的一般形式如下：

# 注释以 '#' 开头并延续到行的末尾。
<mime type>; ; <parameter list>
# 其中参数列表由一个或多个参数组成，
# 其中参数类似于：x-java-view=com.sun.TextViewer
# 参数列表类似于：
纯文本; ; x-java-view=com.sun.TextViewer; x-java-edit=com.sun.TextEdit
# 注意，不包含 'x-java' 参数的 mailcap 条目
# 和遵守 RFC 1524 的条目将被忽略：
image/gif; /usr/dt/bin/sdtimage %s

从以下版本开始：
1.6

构造方法摘要
MailcapCommandMap()
默认的构造方法。
MailcapCommandMap(InputStream is)
允许调用者指定一个包含 mailcap 文件的 InputStream 的构造方法。
MailcapCommandMap(String fileName)
允许调用者指定 mailcap 文件路径的构造方法。
方法摘要
void | addMailcap(String mail_cap) 将条目添加到注册表。
DataContentHandler | createDataContentHandler(String mimeType) 返回指定 MIME 类型的 DataContentHandler。
CommandInfo[] | getAllCommands(String mimeType) 针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。
CommandInfo | getCommand(String mimeType, String cmdName) 针对 MIME 类型获取与 cmdName 对应的命令。
String[] | getMimeTypes() 获取此命令映射已知的所有 MIME 类型。
String[] | getNativeCommands(String mimeType) 获取给定 MIME 类型的本地命令。
CommandInfo[] | getPreferredCommands(String mimeType) 获取 MIME 类型的首选命令列表。
从类 javax.activation.CommandMap 继承的方法
createDataContentHandler, getAllCommands, getCommand, getDefaultCommandMap, getPreferredCommands, setDefaultCommandMap
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MailcapCommandMap

public MailcapCommandMap()
默认的构造方法。

MailcapCommandMap

public MailcapCommandMap(String fileName)
                  throws IOException
允许调用者指定 mailcap 文件路径的构造方法。

参数：
fileName - 要打开的 mailcap 文件的名称
抛出：
IOException - 如果不能访问该文件

MailcapCommandMap

public MailcapCommandMap(InputStream is)
允许调用者指定一个包含 mailcap 文件的 InputStream 的构造方法。

参数：
is - 要打开的 mailcap 文件的 InputStream
方法详细信息

getPreferredCommands

public CommandInfo[] getPreferredCommands(String mimeType)
获取 MIME 类型的首选命令列表。MailcapCommandMap 以如上所述的 mailcap 文件搜索顺序 来搜索 mailcap 文件。

搜索的结果是此 MailcapCommandMap 实例已知的所有 mailmap 文件中可用命令的适当子集。特定命令的第一个条目被视为首选命令。

指定者：
类 CommandMap 中的 getPreferredCommands
参数：
mimeType - MIME 类型
返回：
表示首选命令的 CommandInfo 对象。

getAllCommands

public CommandInfo[] getAllCommands(String mimeType)
针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。

指定者：
类 CommandMap 中的 getAllCommands
参数：
mimeType - MIME 类型
返回：
表示所有命令的 CommandInfo 对象。

getCommand

public CommandInfo getCommand(String mimeType,
                              String cmdName)
针对 MIME 类型获取与 cmdName 对应的命令。

指定者：
类 CommandMap 中的 getCommand
参数：
mimeType - MIME 类型
cmdName - 命令名
返回：
与命令对应的 CommandInfo 对象。

addMailcap

public void addMailcap(String mail_cap)
将条目添加到注册表。搜索其他条目之前，先搜索以编程方式添加的条目。

传入的字符串应该是 mailcap 格式。

参数：
mail_cap - 已正确格式化的 mailcap 字符串

createDataContentHandler

public DataContentHandler createDataContentHandler(String mimeType)
返回指定 MIME 类型的 DataContentHandler。

指定者：
类 CommandMap 中的 createDataContentHandler
参数：
mimeType - MIME 类型
返回：
DataContentHandler

getMimeTypes

public String[] getMimeTypes()
获取此命令映射已知的所有 MIME 类型。

覆盖：
类 CommandMap 中的 getMimeTypes
返回：
字符串形式的 MIME 类型数组
从以下版本开始：
JAF 1.1

getNativeCommands

public String[] getNativeCommands(String mimeType)
获取给定 MIME 类型的本地命令。返回一个字符串数组，其中每个字符串都是一个完整的 mailcap 文件条目。应用程序需要解析条目以提取实际命令以及它需要的所有属性。关于 mailcap 条目语法的详细信息，请参阅 RFC 1524。只返回为指定的 MIME 类型指定查看命令的 mailcap 条目。

返回：
本地命令条目数组
从以下版本开始：
JAF 1.1
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MimeType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 MimeType

java.lang.Object
    继承者  javax.activation.MimeType
所有已实现的接口：
Externalizable, Serializable
public class MimeType
extends Object
implements Externalizable

RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
MimeType()
默认的构造方法。
MimeType(String rawdata)
根据 String 构建 MimeType 的构造方法。
MimeType(String primary, String sub)
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。
方法摘要
String | getBaseType() 返回此对象的 String 表示形式，不带参数列表。
String | getParameter(String name) 获取与给定名称关联的值；如果没有当前关联，则返回 null。
MimeTypeParameterList | getParameters() 获取此对象的参数列表。
String | getPrimaryType() 获取此对象的基本类型。
String | getSubType() 获取此对象的子类型。
boolean | match(MimeType type) 确定此对象的基本类型和子类型与给定类型中的类型是否相同。
boolean | match(String rawdata) 确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。
void | readExternal(ObjectInput in) 对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。
void | removeParameter(String name) 移除与给定名称关联的所有值。
void | setParameter(String name, String value) 将值设置为与给定的名称关联，替换以前的任何关联。
void | setPrimaryType(String primary) 将此对象的基本类型设置为给定的 String。
void | setSubType(String sub) 将此对象的子类型设置为给定的 String。
String | toString() 返回此对象的 String 表示形式。
void | writeExternal(ObjectOutput out) 对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MimeType

public MimeType()
默认的构造方法。

MimeType

public MimeType(String rawdata)
         throws MimeTypeParseException
根据 String 构建 MimeType 的构造方法。

参数：
rawdata - MIME 类型字符串
抛出：
MimeTypeParseException

MimeType

public MimeType(String primary,
                String sub)
         throws MimeTypeParseException
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。

参数：
primary - 基本 MIME 类型
sub - MIME 子类型
抛出：
MimeTypeParseException - 如果基本类型或子类型不是有效的标记
方法详细信息

getPrimaryType

public String getPrimaryType()
获取此对象的基本类型。

返回：
基本 MIME 类型

setPrimaryType

public void setPrimaryType(String primary)
                    throws MimeTypeParseException
将此对象的基本类型设置为给定的 String。

参数：
primary - 基本 MIME 类型
抛出：
MimeTypeParseException - 如果基本类型不是有效的标记

getSubType

public String getSubType()
获取此对象的子类型。

返回：
MIME 子类型

setSubType

public void setSubType(String sub)
                throws MimeTypeParseException
将此对象的子类型设置为给定的 String。

参数：
sub - MIME 子类型
抛出：
MimeTypeParseException - 如果子类型不是有效的标记

getParameters

public MimeTypeParameterList getParameters()
获取此对象的参数列表。

返回：
表示参数的 MimeTypeParameterList 对象

getParameter

public String getParameter(String name)
获取与给定名称关联的值；如果没有当前关联，则返回 null。

参数：
name - 参数名
返回：
参数的值

setParameter

public void setParameter(String name,
                         String value)
将值设置为与给定的名称关联，替换以前的任何关联。

参数：
name - 参数名
value - 参数的值

removeParameter

public void removeParameter(String name)
移除与给定名称关联的所有值。

参数：
name - 参数名

toString

public String toString()
返回此对象的 String 表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getBaseType

public String getBaseType()
返回此对象的 String 表示形式，不带参数列表。

返回：
MIME 类型和子类型

match

public boolean match(MimeType type)
确定此对象的基本类型和子类型与给定类型中的类型是否相同。

参数：
type - 要与之比较的 MimeType 对象
返回：
如果匹配，则返回 true

match

public boolean match(String rawdata)
              throws MimeTypeParseException
确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。

参数：
rawdata - 要与之比较的 MIME 类型字符串
返回：
如果匹配，则返回 true
抛出：
MimeTypeParseException

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException
对象可实现 writeExternal 方法来保存其内容：对于其基本值，调用 DataOutput 的方法；对于对象、字符串和数组，调用 ObjectOutput 的 writeObject 方法。

指定者：
接口 Externalizable 中的 writeExternal
参数：
out - 要写入的 ObjectOutput 对象
抛出：
IOException - 包括可能发生的所有 I/O 异常

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException
对象可实现 readExternal 方法来恢复其内容：对于基本类型，调用 DataInput 的方法；对于对象、字符串和数组，调用 readObject。readExternal 方法必须按照与 writeExternal 写入值时使用的相同顺序和类型来读取这些值。

指定者：
接口 Externalizable 中的 readExternal
参数：
in - 要从中读取的 ObjectInput 对象
抛出：
ClassNotFoundException - 如果找不到要恢复的对象的类。I
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MimeTypeParameterList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 MimeTypeParameterList

java.lang.Object
    继承者  javax.activation.MimeTypeParameterList

public class MimeTypeParameterList
extends Object

RFC 2045 和 2046 中定义的 MimeType 参数列表。必须已经去掉了对象的基本类型。

从以下版本开始：
1.6
另请参见：
MimeType

构造方法摘要
MimeTypeParameterList()
默认的构造方法。
MimeTypeParameterList(String parameterList)
用传入的数据构造新的 MimeTypeParameterList。
方法摘要
String | get(String name) 获取与给定名称关联的值；如果不存在当前关联，则返回 null。
Enumeration | getNames() 获取此列表中所有名称的枚举。
boolean | isEmpty() 确定此列表是否为空。
protected void | parse(String parameterList) 将参数列表从一个 String 解析出来的例程。
void | remove(String name) 移除与给定名称关联的所有值。
void | set(String name, String value) 将值设置为与给定名称关联，替换以前的任何关联。
int | size() 返回此列表中名称-值对的数量。
String | toString() 返回此对象的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MimeTypeParameterList

public MimeTypeParameterList()
默认的构造方法。

MimeTypeParameterList

public MimeTypeParameterList(String parameterList)
                      throws MimeTypeParseException
用传入的数据构造新的 MimeTypeParameterList。

参数：
parameterList - RFC 2045、2046 兼容参数列表。
抛出：
MimeTypeParseException
方法详细信息

parse

protected void parse(String parameterList)
              throws MimeTypeParseException
将参数列表从一个 String 解析出来的例程。

参数：
parameterList - RFC 2045、 2046 兼容参数列表。
抛出：
MimeTypeParseException

size

public int size()
返回此列表中名称-值对的数量。

返回：
参数的数量

isEmpty

public boolean isEmpty()
确定此列表是否为空。

返回：
如果没有参数，则返回 true

get

public String get(String name)
获取与给定名称关联的值；如果不存在当前关联，则返回 null。

参数：
name - 参数名
返回：
参数的值

set

public void set(String name,
                String value)
将值设置为与给定名称关联，替换以前的任何关联。

参数：
name - 参数名
value - 参数的值

remove

public void remove(String name)
移除与给定名称关联的所有值。

参数：
name - 参数名

getNames

public Enumeration getNames()
获取此列表中所有名称的枚举。

返回：
所有参数名的枚举

toString

public String toString()
返回此对象的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MimeTypeParseException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 MimeTypeParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.activation.MimeTypeParseException
所有已实现的接口：
Serializable
public class MimeTypeParseException
extends Exception

封装与 MimeType 解析相关的异常的类。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
MimeTypeParseException()
构造不带指定详细消息的 MimeTypeParseException。
MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MimeTypeParseException

public MimeTypeParseException()
构造不带指定详细消息的 MimeTypeParseException。

MimeTypeParseException

public MimeTypeParseException(String s)
构造带指定详细消息的 MimeTypeParseException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MimetypesFileTypeMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 MimetypesFileTypeMap

java.lang.Object
    继承者  javax.activation.FileTypeMap
        继承者  javax.activation.MimetypesFileTypeMap

public class MimetypesFileTypeMap
extends FileTypeMap

此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。它使用 .mime.types 格式。

MIME 类型文件搜索顺序：

MimetypesFileTypeMap 在用户系统的不同位置查找 MIME 类型文件条目。当发出在 MimetypesFileTypeMap 中搜索 MIME 类型的请求时，它将按以下顺序搜索 MIME 类型文件：

  1. 以编程方式添加到 MimetypesFileTypeMap 实例的条目。
  2. 用户主目录中的 .mime.types 文件。
  3. <java.home>/lib/mime.types 文件。
  4. 名为 META-INF/mime.types 的文件或资源。
  5. 名为 META-INF/mimetypes.default 的文件或资源（通常只存在于 activation.jar 文件中）。

MIME 类型文件格式：

# 注释以 '#' 开头
# 格式是 <mime 类型> <以空格分隔文件扩展名>
# 例如：
text/plain txt text TXT
# 这将 file.txt、file.text 和 file.TXT 映射到
# mime 类型 "text/plain"

从以下版本开始：
1.6

构造方法摘要
MimetypesFileTypeMap()
默认的构造方法。
MimetypesFileTypeMap(InputStream is)
用从 InputStream 中添加的编程条目构造 MimetypesFileTypeMap。
MimetypesFileTypeMap(String mimeTypeFileName)
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。
方法摘要
void | addMimeTypes(String mime_types) 将 MIME 类型值预先添加到注册表。
String | getContentType(File f) 返回该文件对象的 MIME 类型。
String | getContentType(String filename) 返回基于指定文件名的 MIME 类型。
从类 javax.activation.FileTypeMap 继承的方法
getDefaultFileTypeMap, setDefaultFileTypeMap
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MimetypesFileTypeMap

public MimetypesFileTypeMap()
默认的构造方法。

MimetypesFileTypeMap

public MimetypesFileTypeMap(String mimeTypeFileName)
                     throws IOException
用从指定文件中添加的编程条目构造 MimetypesFileTypeMap。

参数：
mimeTypeFileName - 文件名
抛出：
IOException

MimetypesFileTypeMap

public MimetypesFileTypeMap(InputStream is)
用从 InputStream 中添加的编程条目构造 MimetypesFileTypeMap。

参数：
is - 要从中读取的输入流
方法详细信息

addMimeTypes

public void addMimeTypes(String mime_types)
将 MIME 类型值预先添加到注册表。

参数：
mime_types - 条目的 .mime. 类型格式化字符串。

getContentType

public String getContentType(File f)
返回该文件对象的 MIME 类型。此类中的实现调用 getContentType(f.getName())。

指定者：
类 FileTypeMap 中的 getContentType
参数：
f - 文件
返回：
文件的 MIME 类型

getContentType

public String getContentType(String filename)
返回基于指定文件名的 MIME 类型。以如上所述的 MIME 类型文件搜索顺序 来搜索 MIME 类型条目。如果找不到任何条目，则返回 "application/octet-stream" 类型。

指定者：
类 FileTypeMap 中的 getContentType
参数：
filename - 文件名
返回：
文件的 MIME 类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URLDataSource (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 URLDataSource

java.lang.Object
    继承者  javax.activation.URLDataSource
所有已实现的接口：
DataSource
public class URLDataSource
extends Object
implements DataSource

URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。URLDataSource 简化了 JavaBeans Activation Framework 中 URL 描述的数据处理方法，因为此类可用于创建新的 DataHandler。注：当用 URL 构造 DataHandler 对象时，DataHandler 对象在内部创建一个 URLDataSource。

从以下版本开始：
1.6
另请参见：
DataSource, DataHandler

构造方法摘要
URLDataSource(URL url)
URLDataSource 构造方法。
方法摘要
String | getContentType() 返回 URL 内容-类型 (content-type) 头字段的值。
InputStream | getInputStream() URL 的 getInputStream 方法。
String | getName() 调用用于实例化对象的 URL 的 getFile 方法。
OutputStream | getOutputStream() URL 的 getOutputStream 方法。
URL | getURL() 返回用于创建此 DataSource 的 URL。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

URLDataSource

public URLDataSource(URL url)
URLDataSource 构造方法。在调用了要求打开到 URL 连接的方法之前，URLDataSource 类不会这样做。

参数：
url - 要封装在此对象中的 URL。
方法详细信息

getContentType

public String getContentType()
返回 URL 内容-类型 (content-type) 头字段的值。获取 URLConnection 对象后，它调用 URL 的 URLConnection.getContentType 方法。注：此方法尝试调用 URL 的 openConnection 方法。如果此方法失败，或内容类型不是从 URLConnection 返回的，则 getContentType 返回 "application/octet-stream" 作为内容类型。

指定者：
接口 DataSource 中的 getContentType
返回：
内容类型。

getName

public String getName()
调用用于实例化对象的 URL 的 getFile 方法。

指定者：
接口 DataSource 中的 getName
返回：
调用 URL 的 getFile 方法的结果。

getInputStream

public InputStream getInputStream()
                           throws IOException
URL 的 getInputStream 方法。调用 URL 的 openStream 方法。

指定者：
接口 DataSource 中的 getInputStream
返回：
InputStream。
抛出：
IOException

getOutputStream

public OutputStream getOutputStream()
                             throws IOException
URL 的 getOutputStream 方法。首先，尝试为 URL 获取 URLConnection 对象。如果成功，则返回 URLConnection 的 getOutputStream 方法。

指定者：
接口 DataSource 中的 getOutputStream
返回：
OutputStream。
抛出：
IOException

getURL

public URL getURL()
返回用于创建此 DataSource 的 URL。

返回：
URL。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


UnsupportedDataTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activation
类 UnsupportedDataTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.activation.UnsupportedDataTypeException
所有已实现的接口：
Serializable
public class UnsupportedDataTypeException
extends IOException

当请求操作不支持请求的数据类型时，抛出此异常。

从以下版本开始：
1.6
另请参见：
DataHandler, 序列化表格

构造方法摘要
UnsupportedDataTypeException()
构造不带详细消息的 UnsupportedDataTypeException。
UnsupportedDataTypeException(String s)
构造带指定消息的 UnsupportedDataTypeException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedDataTypeException

public UnsupportedDataTypeException()
构造不带详细消息的 UnsupportedDataTypeException。

UnsupportedDataTypeException

public UnsupportedDataTypeException(String s)
构造带指定消息的 UnsupportedDataTypeException。

参数：
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


javax.activation (Java 2 Platform SE 6)

 javax.activation
接口
CommandObject
DataContentHandler
DataContentHandlerFactory
DataSource
类
ActivationDataFlavor
CommandInfo
CommandMap
DataHandler
FileDataSource
FileTypeMap
MailcapCommandMap
MimeType
MimeTypeParameterList
MimetypesFileTypeMap
URLDataSource
异常
MimeTypeParseException
UnsupportedDataTypeException


javax.activation (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.activation

接口摘要
CommandObject | Activation Framework 所知的 JavaBean 组件实现此接口，以找出请求这些组件执行的命令动词，并获取表示这些组件要操作的数据的 DataHandler。
DataContentHandler | DataContentHandler 接口由可用于扩展 Transferable 接口的 DataHandler 实现性能的对象来实现。
DataContentHandlerFactory | 此接口定义了 DataContentHandler 的工厂。
DataSource | DataSource 接口为 JavaBeans Activation Framework 提供任意数据集合的抽象。

类摘要
ActivationDataFlavor | ActivationDataFlavor 类是 java.awt.datatransfer.DataFlavor 的一个特殊子类。
CommandInfo | CommandMap 实现使用 CommandInfo 类描述命令请求的结果。
CommandMap | CommandMap 类为系统中可用的命令对象注册表提供接口。
DataHandler | DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。
FileDataSource | FileDataSource 类实现一个封装文件的简单 DataSource 对象。
FileTypeMap | FileTypeMap 是一个抽象类，它为文件提供数据分类接口。
MailcapCommandMap | MailcapCommandMap 扩展 CommandMap 抽象类。
MimeType | RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。
MimeTypeParameterList | RFC 2045 和 2046 中定义的 MimeType 参数列表。
MimetypesFileTypeMap | 此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。
URLDataSource | URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。

异常摘要
MimeTypeParseException | 封装与 MimeType 解析相关的异常的类。
UnsupportedDataTypeException | 当请求操作不支持请求的数据类型时，抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.activation 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.activation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.activation.CommandInfo
    • javax.activation.CommandMap
      • javax.activation.MailcapCommandMap
    • java.awt.datatransfer.DataFlavor (implements java.lang.Cloneable, java.io.Externalizable)
      • javax.activation.ActivationDataFlavor
    • javax.activation.DataHandler (implements java.awt.datatransfer.Transferable)
    • javax.activation.FileDataSource (implements javax.activation.DataSource)
    • javax.activation.FileTypeMap
      • javax.activation.MimetypesFileTypeMap
    • javax.activation.MimeType (implements java.io.Externalizable)
    • javax.activation.MimeTypeParameterList
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.activation.UnsupportedDataTypeException
        • javax.activation.MimeTypeParseException
    • javax.activation.URLDataSource (implements javax.activation.DataSource)

接口分层结构

  • javax.activation.CommandObject
  • javax.activation.DataContentHandler
  • javax.activation.DataContentHandlerFactory
  • javax.activation.DataSource
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.activation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.activation
的使用

使用 javax.activation 的软件包
javax.activation |
javax.xml.bind.attachment | 此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

javax.activation 使用的 javax.activation 中的类
CommandInfo
CommandMap 实现使用 CommandInfo 类描述命令请求的结果。
CommandMap
CommandMap 类为系统中可用的命令对象注册表提供接口。
DataContentHandler
DataContentHandler 接口由可用于扩展 Transferable 接口的 DataHandler 实现性能的对象来实现。
DataContentHandlerFactory
此接口定义了 DataContentHandler 的工厂。
DataHandler
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。
DataSource
DataSource 接口为 JavaBeans Activation Framework 提供任意数据集合的抽象。
FileTypeMap
FileTypeMap 是一个抽象类，它为文件提供数据分类接口。
MimeType
RFC 2045 和 2046 中定义的多用途 Internet 邮件扩展（Multipurpose Internet Mail Extension，MIME）类型。
MimeTypeParameterList
RFC 2045 和 2046 中定义的 MimeType 参数列表。
MimeTypeParseException
封装与 MimeType 解析相关的异常的类。

javax.xml.bind.attachment 使用的 javax.activation 中的类
DataHandler
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。

javax.xml.soap 使用的 javax.activation 中的类
DataHandler
DataHandler 类为在多种不同源和格式下可用的数据提供一致的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.ActivationDataFlavor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.ActivationDataFlavor
的使用

没有 javax.activation.ActivationDataFlavor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.CommandInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.CommandInfo
的使用

使用 CommandInfo 的软件包
javax.activation

javax.activation 中 CommandInfo 的使用

返回 CommandInfo 的 javax.activation 中的方法
CommandInfo[] | DataHandler.getAllCommands() 返回此数据类型的所有命令。
abstract CommandInfo[] | CommandMap.getAllCommands(String mimeType) 获取此类型的所有可用命令。
CommandInfo[] | MailcapCommandMap.getAllCommands(String mimeType) 针对此 MIME 类型获取此 MailcapCommandMap 实例已知的所有 mailcap 文件中的所有可用命令。
CommandInfo[] | CommandMap.getAllCommands(String mimeType, DataSource ds) 获取此类型的所有可用命令。
CommandInfo | DataHandler.getCommand(String cmdName) 获取命令 cmdName。
abstract CommandInfo | CommandMap.getCommand(String mimeType, String cmdName) 获取与 MIME 类型对应的默认命令。
CommandInfo | MailcapCommandMap.getCommand(String mimeType, String cmdName) 针对 MIME 类型获取与 cmdName 对应的命令。
CommandInfo | CommandMap.getCommand(String mimeType, String cmdName, DataSource ds) 获取与 MIME 类型对应的默认命令。
CommandInfo[] | DataHandler.getPreferredCommands() 返回此数据类型的首选 命令。
abstract CommandInfo[] | CommandMap.getPreferredCommands(String mimeType) 从 MIME 类型获取首选命令表。
CommandInfo[] | MailcapCommandMap.getPreferredCommands(String mimeType) 获取 MIME 类型的首选命令列表。
CommandInfo[] | CommandMap.getPreferredCommands(String mimeType, DataSource ds) 从 MIME 类型获取首选命令表。

参数类型为 CommandInfo 的 javax.activation 中的方法
 Object DataHandler.getBean(CommandInfo cmdinfo)
一个便捷方法，它接受 CommandInfo 对象并且实例化相应的命令，通常是 JavaBean 组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.CommandMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.CommandMap
的使用

使用 CommandMap 的软件包
javax.activation

javax.activation 中 CommandMap 的使用

javax.activation 中 CommandMap 的子类
 class MailcapCommandMap
MailcapCommandMap 扩展 CommandMap 抽象类。

返回 CommandMap 的 javax.activation 中的方法
static CommandMap CommandMap.getDefaultCommandMap()
获取默认的 CommandMap。

参数类型为 CommandMap 的 javax.activation 中的方法
void | DataHandler.setCommandMap(CommandMap commandMap) 设置此 DataHandler 使用的 CommandMap。
static void | CommandMap.setDefaultCommandMap(CommandMap commandMap) 设置默认的 CommandMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.activation.CommandObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.CommandObject
的使用

没有 javax.activation.CommandObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.activation.DataContentHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.DataContentHandler
的使用

使用 DataContentHandler 的软件包
javax.activation

javax.activation 中 DataContentHandler 的使用

返回 DataContentHandler 的 javax.activation 中的方法
abstract DataContentHandler | CommandMap.createDataContentHandler(String mimeType) 查找与 MIME 类型对应的 DataContentHandler。
DataContentHandler | DataContentHandlerFactory.createDataContentHandler(String mimeType) 针对 MIME 类型创建一个新的 DataContentHandler 对象。
DataContentHandler | MailcapCommandMap.createDataContentHandler(String mimeType) 返回指定 MIME 类型的 DataContentHandler。
DataContentHandler | CommandMap.createDataContentHandler(String mimeType, DataSource ds) 查找与 MIME 类型对应的 DataContentHandler。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.activation.DataContentHandlerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.DataContentHandlerFactory
的使用

使用 DataContentHandlerFactory 的软件包
javax.activation

javax.activation 中 DataContentHandlerFactory 的使用

参数类型为 DataContentHandlerFactory 的 javax.activation 中的方法
static void DataHandler.setDataContentHandlerFactory(DataContentHandlerFactory newFactory)
设置 DataContentHandlerFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.DataHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.DataHandler
的使用

使用 DataHandler 的软件包
javax.activation |
javax.xml.bind.attachment | 此包由基于 MIME 的包处理器实现，该处理器能够解释并创建基于 MIME 的包格式的已优化的二进制数据。
javax.xml.soap | 提供用于创建和构建 SOAP 消息的 API。

javax.activation 中 DataHandler 的使用

参数类型为 DataHandler 的 javax.activation 中的方法
Object | CommandInfo.getCommandObject(DataHandler dh, ClassLoader loader) 返回已实例化的 JavaBean 组件。
void | CommandObject.setCommandContext(String verb, DataHandler dh) 用请求处理的动词和描述将要操作的数据的 DataHandler 来初始化 Command。

javax.xml.bind.attachment 中 DataHandler 的使用

返回 DataHandler 的 javax.xml.bind.attachment 中的方法
abstract  DataHandler AttachmentUnmarshaller.getAttachmentAsDataHandler(String cid)
通过内容 id（即 cid）查找 MIME 内容，并作为 DataHandler 返回。

参数类型为 DataHandler 的 javax.xml.bind.attachment 中的方法
abstract String | AttachmentMarshaller.addMtomAttachment(DataHandler data, String elementNamespace, String elementLocalName) 将用于优化二进制存储的 MIME 内容 data 作为附件。
abstract String | AttachmentMarshaller.addSwaRefAttachment(DataHandler data) 将 MIME data 作为附件添加，并返回附件的内容 id（即 cid）。

javax.xml.soap 中 DataHandler 的使用

返回 DataHandler 的 javax.xml.soap 中的方法
abstract  DataHandler AttachmentPart.getDataHandler()
获取针对此 AttachmentPart 对象的 DataHandler 对象。

参数类型为 DataHandler 的 javax.xml.soap 中的方法
AttachmentPart | SOAPMessage.createAttachmentPart(DataHandler dataHandler) 创建 AttachmentPart 对象并使用给定的 DataHandler 对象填充。
abstract void | AttachmentPart.setDataHandler(DataHandler dataHandler) 将给定的 DataHandler 对象设置为此 AttachmentPart 对象的数据处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.activation.DataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.activation.DataSource
的使用

使用 DataSource 的软件包
javax.activation

javax.activation 中 DataSource 的使用

实现 DataSource 的 javax.activation 中的类
class | FileDataSource FileDataSource 类实现一个封装文件的简单 DataSource 对象。
class | URLDataSource URLDataSource 类提供一个对象，此对象将 URL 对象包装在 DataSource 接口中。

返回 DataSource 的 javax.activation 中的方法
 DataSource DataHandler.getDataSource()
返回与此 DataHandler 实例关联的 DataSource。

参数类型为 DataSource 的 javax.activation 中的方法
DataContentHandler | CommandMap.createDataContentHandler(String mimeType, DataSource ds) 查找与 MIME 类型对应的 DataContentHandler。
CommandInfo[] | CommandMap.getAllCommands(String mimeType, DataSource ds) 获取此类型的所有可用命令。
CommandInfo | CommandMap.getCommand(String mimeType, String cmdName, DataSource ds) 获取与 MIME 类型对应的默认命令。
Object | DataContentHandler.getContent(DataSource ds) 返回一个对象，该对象表示其首选形式的数据。
CommandInfo[] | CommandMap.getPreferredCommands(String mimeType, DataSource ds) 从 MIME 类型获取首选命令表。
Object | DataContentHandler.getTransferData(DataFlavor df, DataSource ds) 返回一个对象，该对象表示将要传输的数据。

参数类型为 DataSource 的 javax.activation 中的构造方法
DataHandler(DataSource ds)
创建引用指定 DataSource 的 DataHandler 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.FileDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.FileDataSource
的使用

没有 javax.activation.FileDataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.FileTypeMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.FileTypeMap
的使用

使用 FileTypeMap 的软件包
javax.activation

javax.activation 中 FileTypeMap 的使用

javax.activation 中 FileTypeMap 的子类
 class MimetypesFileTypeMap
此类扩展 FileTypeMap 并通过其文件扩展名提供文件的数据分类。

返回 FileTypeMap 的 javax.activation 中的方法
static FileTypeMap FileTypeMap.getDefaultFileTypeMap()
返回系统的默认 FileTypeMap。

参数类型为 FileTypeMap 的 javax.activation 中的方法
static void | FileTypeMap.setDefaultFileTypeMap(FileTypeMap map) 设置系统的默认 FileTypeMap。
void | FileDataSource.setFileTypeMap(FileTypeMap map) 设置用于此 FileDataSource 的 FileTypeMap。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.MailcapCommandMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MailcapCommandMap
的使用

没有 javax.activation.MailcapCommandMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.MimeType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimeType
的使用

使用 MimeType 的软件包
javax.activation

javax.activation 中 MimeType 的使用

参数类型为 MimeType 的 javax.activation 中的方法
 boolean MimeType.match(MimeType type)
确定此对象的基本类型和子类型与给定类型中的类型是否相同。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.MimeTypeParameterList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimeTypeParameterList
的使用

使用 MimeTypeParameterList 的软件包
javax.activation

javax.activation 中 MimeTypeParameterList 的使用

返回 MimeTypeParameterList 的 javax.activation 中的方法
 MimeTypeParameterList MimeType.getParameters()
获取此对象的参数列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.MimeTypeParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimeTypeParseException
的使用

使用 MimeTypeParseException 的软件包
javax.activation

javax.activation 中 MimeTypeParseException 的使用

抛出 MimeTypeParseException 的 javax.activation 中的方法
boolean | MimeType.match(String rawdata) 确定此对象的基本类型和子类型与 rawdata 中描述的内容类型是否相同。
protected void | MimeTypeParameterList.parse(String parameterList) 将参数列表从一个 String 解析出来的例程。
void | MimeType.setPrimaryType(String primary) 将此对象的基本类型设置为给定的 String。
void | MimeType.setSubType(String sub) 将此对象的子类型设置为给定的 String。

抛出 MimeTypeParseException 的 javax.activation 中的构造方法
MimeType(String rawdata)
根据 String 构建 MimeType 的构造方法。
MimeType(String primary, String sub)
用给定的基本类型和子类型构建 MimeType 的构造方法，它的参数列表为空。
MimeTypeParameterList(String parameterList)
用传入的数据构造新的 MimeTypeParameterList。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.MimetypesFileTypeMap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.MimetypesFileTypeMap
的使用

没有 javax.activation.MimetypesFileTypeMap 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.URLDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.URLDataSource
的使用

没有 javax.activation.URLDataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activation.UnsupportedDataTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activation.UnsupportedDataTypeException
的使用

没有 javax.activation.UnsupportedDataTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ActivityCompletedException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.activity
类 ActivityCompletedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  javax.activity.ActivityCompletedException
所有已实现的接口：
Serializable
public class ActivityCompletedException
extends RemoteException

任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。这可能是因为已经通过 CompletionStatusFailOnly 指示完成了 Activity，或者已经作为超时的结果而结束。此异常将通过 org.omg.CORBA.ACTIVITY_COMPLETED 系统异常跨 ORB 边界进行传播。应用程序应通过试图结束 Activity 来处理此错误。

另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ActivityCompletedException()
构造一个新实例，其详细消息为 null。
ActivityCompletedException(String message)
构造带有指定详细消息的新实例。
ActivityCompletedException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
ActivityCompletedException(Throwable cause)
构造带有指定 cause 的新 throwable。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ActivityCompletedException

public ActivityCompletedException()
构造一个新实例，其详细消息为 null。

ActivityCompletedException

public ActivityCompletedException(String message)
构造带有指定详细消息的新实例。

参数：
message - 详细消息。

ActivityCompletedException

public ActivityCompletedException(Throwable cause)
构造带有指定 cause 的新 throwable。

参数：
cause - Throwable 类型的链异常

ActivityCompletedException

public ActivityCompletedException(String message,
                                  Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

参数：
message - 详细消息。
cause - Throwable 类型的链异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ActivityRequiredException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.activity
类 ActivityRequiredException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  javax.activity.ActivityRequiredException
所有已实现的接口：
Serializable
public class ActivityRequiredException
extends RemoteException

如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。此异常指示一个部署错误或应用程序配置错误。此异常将通过 org.omg.CORBA.ACTIVITY_REQUIRED 系统异常跨 ORB 边界进行传播。

另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
ActivityRequiredException()
构造一个新实例，其详细消息为 null。
ActivityRequiredException(String message)
构造带有指定详细消息的新实例。
ActivityRequiredException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
ActivityRequiredException(Throwable cause)
构造带有指定 cause 的新 throwable。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ActivityRequiredException

public ActivityRequiredException()
构造一个新实例，其详细消息为 null。

ActivityRequiredException

public ActivityRequiredException(String message)
构造带有指定详细消息的新实例。

参数：
message - 详细消息。

ActivityRequiredException

public ActivityRequiredException(Throwable cause)
构造带有指定 cause 的新 throwable。

参数：
cause - Throwable 类型的链异常

ActivityRequiredException

public ActivityRequiredException(String message,
                                 Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

参数：
message - 详细消息。
cause - Throwable 类型的链异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidActivityException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.activity
类 InvalidActivityException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  java.rmi.RemoteException
                    继承者  javax.activity.InvalidActivityException
所有已实现的接口：
Serializable
public class InvalidActivityException
extends RemoteException

任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。如果在禁用 Activity 上下文的方法上接收到 Activity 上下文，则某个容器也可能抛出此异常。此异常通过 org.omg.CORBA.INVALID_ACTIVITY 系统异常跨 J2EE Activity Service ORB 边界进行传播。应用程序应通过试图结束 Activity 来处理此错误。

另请参见：
序列化表格

字段摘要
从类 java.rmi.RemoteException 继承的字段
detail
构造方法摘要
InvalidActivityException()
构造一个新实例，其详细消息为 null。
InvalidActivityException(String message)
构造带有指定详细消息的新实例。
InvalidActivityException(String message, Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。
InvalidActivityException(Throwable cause)
构造带有指定 cause 的新 throwable。
方法摘要
从类 java.rmi.RemoteException 继承的方法
getCause, getMessage
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidActivityException

public InvalidActivityException()
构造一个新实例，其详细消息为 null。

InvalidActivityException

public InvalidActivityException(String message)
构造带有指定详细消息的新实例。

参数：
message - 详细消息。

InvalidActivityException

public InvalidActivityException(Throwable cause)
构造带有指定 cause 的新 throwable。

参数：
cause - Throwable 类型的链异常

InvalidActivityException

public InvalidActivityException(String message,
                                Throwable cause)
构造带有指定详细消息和 cause 的新 throwable。

参数：
message - 详细消息。
cause - Throwable 类型的链异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.activity (Java 2 Platform SE 6)

 javax.activity
异常
ActivityCompletedException
ActivityRequiredException
InvalidActivityException


javax.activity (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.activity

包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。

请参见：
描述

异常摘要
ActivityCompletedException | 任何访问 Activity 上下文的方法都可能抛出此异常，它指示不能继续在 Activity 内部执行操作。
ActivityRequiredException | 如果方法没有接收到它所要求的 Activity 上下文，则容器将抛出此异常。
InvalidActivityException | 任何访问 Activity 上下文的方法都可能抛出此异常，它指示尝试调用或与尝试调用相关的 Activity 上下文与 Activity 的当前状态不兼容。

软件包 javax.activity 的描述

包含解组期间通过 ORB 机制抛出的与 Activity 服务有关的异常。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.activity 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.activity 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • java.rmi.RemoteException
            • javax.activity.ActivityCompletedException
            • javax.activity.ActivityRequiredException
            • javax.activity.InvalidActivityException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.activity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.activity
的使用

没有 javax.activity 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activity.ActivityCompletedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activity.ActivityCompletedException
的使用

没有 javax.activity.ActivityCompletedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activity.ActivityRequiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activity.ActivityRequiredException
的使用

没有 javax.activity.ActivityRequiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.activity.InvalidActivityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.activity.InvalidActivityException
的使用

没有 javax.activity.InvalidActivityException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Generated (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.annotation
注释类型 Generated

@Documented
@Retention(value=SOURCE)
@Target(value={PACKAGE,TYPE,ANNOTATION_TYPE,METHOD,CONSTRUCTOR,FIELD,LOCAL_VARIABLE,PARAMETER})
public @interface Generated

Generated 注释用于标记已生成的源代码。它也可以用于区分单个文件中用户编写的代码和生成的代码。使用时，值元素必须有代码生成器的名称。建议的约定是在值字段中使用代码生成器的完全限定名。例如：com.company.package.classname。日期元素用于表示生成源代码的日期。日期元素必须遵循 ISO 8601 标准。例如，日期元素可能是值 2001-07-04T12:08:56.235-0700，它表示美国太平洋时区的本地时间 2001-07-04 12:08:56。注释元素是代码生成器想要在生成代码中包含的所有注释的占位符 (place holder)。

从以下版本开始：
Common Annotations 1.0

必需元素摘要
 String[] value
此方法由代码生成器使用，以标记生成的类和方法。
可选元素摘要
String | comments 代码生成器想要在生成代码中包含的所有注释的占位符。
String | date 生成源代码的日期。

元素详细信息

value

public abstract String[] value
此方法由代码生成器使用，以标记生成的类和方法。

date

public abstract String date
生成源代码的日期。

默认值：
""

comments

public abstract String comments
代码生成器想要在生成代码中包含的所有注释的占位符。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


PostConstruct (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.annotation
注释类型 PostConstruct

@Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface PostConstruct

PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。此方法必须在将类放入服务之前调用。支持依赖关系注入的所有类都必须支持此注释。即使类没有请求注入任何资源，用 PostConstruct 注释的方法也必须被调用。只有一个方法可以用此注释进行注释。应用 PostConstruct 注释的方法必须遵守以下所有标准：该方法不得有任何参数，除非是在 EJB 拦截器 (interceptor) 的情况下，根据 EJB 规范的定义，在这种情况下它将带有一个 InvocationContext 对象 ；该方法的返回类型必须为 void；该方法不得抛出已检查异常；应用 PostConstruct 的方法可以是 public、protected、package private 或 private；除了应用程序客户端之外，该方法不能是 static；该方法可以是 final；如果该方法抛出未检查异常，那么不得将类放入服务中，除非是能够处理异常并可从中恢复的 EJB。

从以下版本开始：
Common Annotations 1.0
另请参见：
PreDestroy, Resource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


PreDestroy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.annotation
注释类型 PreDestroy

@Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface PreDestroy

PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。用 PreDestroy 注释的方法通常用于释放它已持有的资源。除 Java EE 5 中的应用程序客户端容器之外，所有支持 PostConstruct 的容器管理对象都必须支持此注释。应用 PreDestroy 注释的方法必须遵守以下所有标准：该方法不得有任何参数，除非是在 EJB 拦截器 (interceptor) 的情况下，根据 EJB 规范的定义，在这种情况下它将带有一个 InvocationContext 对象；该方法的返回类型必须为 void；该方法不得抛出已检查异常；应用 PreDestroy 的方法可以是 public、protected、package private 或 private；该方法不得是 static；该方法可以是 final；如果该方法抛出未检查异常，则忽略此异常，除非是能够处理异常的 EJB。

从以下版本开始：
Common Annotations 1.0
另请参见：
PostConstruct, Resource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Resource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.annotation
注释类型 Resource

@Target(value={TYPE,FIELD,METHOD})
@Retention(value=RUNTIME)
public @interface Resource

Resource 注释标记应用程序所需的资源。此注释可以应用于应用程序组件类，或者该组件类的字段或方法。如果将该注释应用于一个字段或方法，那么初始化应用程序组件时容器将把所请求资源的一个实例注入其中。如果将该注释应用于组件类，则该注释将声明一个应用程序在运行时将查找的资源。

即使此注释没有被标记为 Inherited，部署工具仍然需要检查任意组件类的所有超类，以发现这些超类中所有使用此注释的地方。所有此类注释实例都指定了应用程序组件所需的资源。注意，此注释可能出现在超类的 private 字段和方法上；在这种情况下容器也需要执行注入操作。

从以下版本开始：
Common Annotations 1.0

可选元素摘要
Resource.AuthenticationType | authenticationType 用于此资源的验证类型。
String | description 此资源的描述。
String | mappedName 此资源应该映射到的特定于产品的名称。
String | name 资源的 JNDI 名称。
boolean | shareable 指示是否能在此组件与其他组件之间共享此资源。
Class | type 资源的 Java 类型。

name

public abstract String name
资源的 JNDI 名称。对于字段注释，默认值为字段名称。对于方法注释，默认值为与该方法对应的 JavaBean 属性名称。对于类注释，没有默认值，必须指定此项。

默认值：
""

type

public abstract Class type
资源的 Java 类型。对于字段注释，默认值为字段的类型。对于方法注释，默认值为 JavaBean 属性的类型。对于类注释，没有默认值，必须指定此项。

默认值：
java.lang.Object.class

authenticationType

public abstract Resource.AuthenticationType authenticationType
用于此资源的验证类型。可以为表示任何受支持类型的连接工厂的资源指定此方法，不得为其他类型的资源指定。

默认值：
javax.annotation.Resource.AuthenticationType.CONTAINER

shareable

public abstract boolean shareable
指示是否能在此组件与其他组件之间共享此资源。可以为表示任何受支持类型的连接工厂的资源指定此方法，不得为其他类型的资源指定。

默认值：
true

mappedName

public abstract String mappedName
此资源应该映射到的特定于产品的名称。此资源的名称（由 name 元素定义或为默认值）是使用该资源的应用程序组件的本地名称。（它的名称位于 JNDI java:comp/env 名称空间中。）许多应用程序服务器都提供一种方式将这些本地名称映射到应用程序服务器已知的资源名称。此映射的名称通常是全局 JNDI 名称，但也可以是任何形式的名称。

应用程序服务器不需要支持任何特殊形式或类型的映射名称，也不需要具有使用映射名称的能力。映射的名称与产品有关，并且通常与安装有关。任何对映射名称的使用都不可移植。

默认值：
""

description

public abstract String description
此资源的描述。描述应该使用部署应用程序的系统的默认语言。该描述能够呈现给部署者以帮助他们选择正确的资源。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


Resource.AuthenticationType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.annotation
枚举 Resource.AuthenticationType

java.lang.Object
    继承者  java.lang.Enum<Resource.AuthenticationType>
        继承者  javax.annotation.Resource.AuthenticationType
所有已实现的接口：
Serializable, Comparable<Resource.AuthenticationType>
正在封闭类：
Resource
public static enum Resource.AuthenticationType
extends Enum<Resource.AuthenticationType>

资源的两种可能验证类型。

枚举常量摘要
APPLICATION
CONTAINER
方法摘要
static Resource.AuthenticationType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Resource.AuthenticationType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

CONTAINER

public static final Resource.AuthenticationType CONTAINER

APPLICATION

public static final Resource.AuthenticationType APPLICATION
方法详细信息

values

public static final Resource.AuthenticationType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Resource.AuthenticationType c : Resource.AuthenticationType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Resource.AuthenticationType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Resources (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.annotation
注释类型 Resources

@Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface Resources

此类用于允许多个资源声明。

从以下版本开始：
Common Annotations 1.0
另请参见：
Resource

必需元素摘要
 Resource[] value
用于多个资源声明的数组。

元素详细信息

value

public abstract Resource[] value
用于多个资源声明的数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


javax.annotation (Java 2 Platform SE 6)

 javax.annotation
枚举
Resource.AuthenticationType
注释类型
Generated
PostConstruct
PreDestroy
Resource
Resources


javax.annotation (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.annotation

枚举摘要
Resource.AuthenticationType 资源的两种可能验证类型。

注释类型摘要
Generated | Generated 注释用于标记已生成的源代码。
PostConstruct | PostConstruct 注释用于在依赖关系注入完成之后需要执行的方法上，以执行任何初始化。
PreDestroy | PreDestroy 注释作为回调通知用于各方法，以表示该实例正处于被容器移除的过程中。
Resource | Resource 注释标记应用程序所需的资源。
Resources | 此类用于允许多个资源声明。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.annotation 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.annotation 的分层结构

软件包分层结构：
所有软件包

注释类型分层结构

  • javax.annotation.Generated (implements java.lang.annotation.Annotation)
  • javax.annotation.PostConstruct (implements java.lang.annotation.Annotation)
  • javax.annotation.PreDestroy (implements java.lang.annotation.Annotation)
  • javax.annotation.Resource (implements java.lang.annotation.Annotation)
  • javax.annotation.Resources (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.annotation.Resource.AuthenticationType
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.annotation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.annotation
的使用

使用 javax.annotation 的软件包
javax.annotation

javax.annotation 使用的 javax.annotation 中的类
Resource.AuthenticationType
资源的两种可能验证类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractProcessor (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
类 AbstractProcessor

java.lang.Object
    继承者  javax.annotation.processing.AbstractProcessor
所有已实现的接口：
Processor
public abstract class AbstractProcessor
extends Object
implements Processor

旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。此类检查注释值，以计算其子类型所支持的选项、注释和源版本。

在 processor 被初始化之后，获取方法可以使用可用设施来发出有关值得注意的条件的警告。

只要遵守该方法的常规 Processor 协定，子类可随意重写此类中任何方法的实现和规范。

从以下版本开始：
1.6

字段摘要
protected  ProcessingEnvironment processingEnv
工具框架提供的处理环境。
构造方法摘要
protected AbstractProcessor()
子类要调用的构造方法。
方法摘要
Iterable<? extends Completion> | getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Set<String> | getSupportedAnnotationTypes() 如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
Set<String> | getSupportedOptions() 如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。
SourceVersion | getSupportedSourceVersion() 如果 processor 类是使用 SupportedSourceVersion 注释的，则返回注释中的源版本。
void | init(ProcessingEnvironment processingEnv) 用处理环境初始化 processor，方法是将 processingEnv 字段设置为 processingEnv 参数的值。
protected boolean | isInitialized() 如果此对象已被初始化，则返回 true，否则返回 false。
abstract boolean | process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

processingEnv

protected ProcessingEnvironment processingEnv
工具框架提供的处理环境。

构造方法详细信息

AbstractProcessor

protected AbstractProcessor()
子类要调用的构造方法。

方法详细信息

getSupportedOptions

public Set<String> getSupportedOptions()
如果 processor 类是使用 SupportedOptions 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。如果类不是以这种方式注释的，则返回一个空集合。

指定者：
接口 Processor 中的 getSupportedOptions
返回：
由此 processor 识别的选项；如果没有这样的选项，则返回一个空集合
另请参见：
SupportedOptions

getSupportedAnnotationTypes

public Set<String> getSupportedAnnotationTypes()
如果 processor 类是使用 SupportedAnnotationTypes 注释的，则返回一个不可修改的集合，该集合具有与注释相同的字符串集。如果类不是以这种方式注释的，则返回一个空集合。

指定者：
接口 Processor 中的 getSupportedAnnotationTypes
返回：
此 processor 所支持的注释类型的名称；如果没有这样的类型，则返回一个空集合
另请参见：
SupportedAnnotationTypes

getSupportedSourceVersion

public SourceVersion getSupportedSourceVersion()
如果 processor 类是使用 SupportedSourceVersion 注释的，则返回注释中的源版本。如果类不是以这种方式注释的，则返回 SourceVersion.RELEASE_6。

指定者：
接口 Processor 中的 getSupportedSourceVersion
返回：
此 processor 所支持的最新的源版本
另请参见：
SupportedSourceVersion, ProcessingEnvironment.getSourceVersion()

init

public void init(ProcessingEnvironment processingEnv)
用处理环境初始化 processor，方法是将 processingEnv 字段设置为 processingEnv 参数的值。如果在同一对象上多次调用此方法，则抛出 IllegalStateException。

指定者：
接口 Processor 中的 init
参数：
processingEnv - 用来访问工具框架提供给 processor 的设施的环境
抛出：
IllegalStateException - 如果多次调用此方法。

process

public abstract boolean process(Set<? extends TypeElement> annotations,
                                RoundEnvironment roundEnv)
处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。如果返回 true，则这些注释已声明并且不要求后续 Processor 处理它们；如果返回 false，则这些注释未声明并且可能要求后续 Processor 处理它们。Processor 可能总是返回相同的 boolean 值，或者可能基于所选择的标准而返回不同的结果。

如果 Processor 支持 "*" 并且根元素没有注释，则输入集合将为空。Processor 必须妥善处理空注释集。

指定者：
接口 Processor 中的 process
参数：
annotations - 请求处理的注释类型
roundEnv - 有关当前和以前 round 的信息的环境
返回：
注释集是否由此 Processor 声明

getCompletions

public Iterable<? extends Completion> getCompletions(Element element,
                                                     AnnotationMirror annotation,
                                                     ExecutableElement member,
                                                     String userText)
返回一个空的 completion 迭代。

指定者：
接口 Processor 中的 getCompletions
参数：
element - 将被注释的元素
annotation - 将应用于元素的注释（可能是一部分）
member - 为其返回可能 completion 的注释成员
userText - 将补充完整的源代码文本
返回：
注释的建议 completion

isInitialized

protected boolean isInitialized()
如果此对象已被初始化，则返回 true，否则返回 false。

返回：
如果此对象已被初始化，则返回 true，否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Completion (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
接口 Completion

public interface Completion

某一注释的建议 completion。completion 是要作为注释的一部分插入程序的文本。

从以下版本开始：
1.6

方法摘要
String | getMessage() 返回包含许多有关 completion 信息的消息。
String | getValue() 返回建议 completion 的文本。

方法详细信息

getValue

String getValue()
返回建议 completion 的文本。

返回：
建议 completion 的文本。

getMessage

String getMessage()
返回包含许多有关 completion 信息的消息。

返回：
包含许多有关 completion 信息的消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Completions (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
类 Completions

java.lang.Object
    继承者  javax.annotation.processing.Completions

public class Completions
extends Object

用来组合 Completion 对象的实用工具类。

从以下版本开始：
1.6

方法摘要
static Completion | of(String value) 返回值和空消息的 completion。
static Completion | of(String value, String message) 返回值和消息的 completion。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

of

public static Completion of(String value,
                            String message)
返回值和消息的 completion。

参数：
value - completion 的文本
message - 有关 completion 的消息
返回：
所提供值和消息的 completion

of

public static Completion of(String value)
返回值和空消息的 completion。

参数：
value - completion 的文本
返回：
值和空消息的 completion
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Filer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
接口 Filer

public interface Filer

此接口支持通过注释处理器创建新文件。以这种方式创建的文件对于实现此接口的注释处理工具将是已知的，这比启用工具来管理它们更好。在对用来编写文件内容的 Writer 或 OutputStream 调用 close 方法之后，以这种方式创建的源文件和类文件被认为将由管理它们的工具处理。有三类文件要加以区分：源文件、类文件和辅助资源文件。

新创建的文件被放置在两个不同的受支持位置（逻辑文件系统中的子树）：一个用于新的源文件，一个用于新的类文件。（这可以在工具的命令行上指定，例如，使用 -s 和 -d 之类的标志。）新的源文件和类文件的实际位置在工具的特定运行时刻可能是不同的，也可能是相同的。资源文件可以在其中一个位置上创建。用来读取和写入资源的方法采用了一个相对名称参数。相对名称是用 '/' 分隔的、非 null、非空的路径段序列；'.' 和 '..' 都是无效的路径段。有效的相对名称必须符合 RFC 3986 的第 3.3 节的“无根路径”规则。

文件创建方法带有可变数量的参数，以允许提供原始元素 作为工具基础设施的提示，从而更好地管理依赖关系。原始元素是造成注释处理器试图创建新文件的类型或包（表示 package-info 文件）。例如，如果注释处理器试图创建一个源文件 GeneratedFromUserSource 以响应处理

@Generate
public class UserSource {}
那么 UserSource 的类型元素应该作为创建方法调用的一部分传入，如下所示：
filer.createSourceFile("GeneratedFromUserSource",
eltUtils.getTypeElement("UserSource"));
如果没有原始元素，则什么都不需要传递。此信息可以在增量环境中使用，以确定是需要重新运行处理器还是移除生成的文件。非增量环境可以忽略原始元素信息。

在每次运行注释处理工具期间，具有给定路径名的文件只能被创建一次。如果该文件在第一次试图创建它之前就已经存在，则将删除原有的内容。在运行期间，任何试图创建相同文件的后续尝试都将抛出 FilerException，试图针对相同的类型名称和相同的包名称创建类文件和源文件也将如此。工具的初始输入被认为是由第 0 个 round 创建的；因此，试图创建一个与那些输入之一对应的源文件或类文件将导致 FilerException。

通常，处理器不得有意尝试重写不是由某个处理器生成的现有文件。Filer 可能拒绝尝试打开与现有类型对应的文件，如 java.lang.Object。同样，注释处理工具的调用者不得有意配置该工具，使得已发现的处理器将尝试重写尚未生成的现有文件。

处理器可以通过包含 @Generated 注释来指示生成源文件或类文件。

注意，重写文件的某些效果可通过使用装饰 风格模式来实现。类被设计为其超类由注释处理生成，或者其子类由注释处理生成，而不是直接修改该类。如果生成子类，则父类可以被设计为使用工厂而不是公共构造方法，这样只有子类实例被呈现给父类的客户端。

从以下版本开始：
1.6

方法摘要
JavaFileObject | createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
FileObject | createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
JavaFileObject | createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。
FileObject | getResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName) 返回一个用于读取现有资源的对象。

方法详细信息

createSourceFile

JavaFileObject createSourceFile(CharSequence name,
                                Element... originatingElements)
                                throws IOException
创建一个新的源文件，并返回一个对象以允许写入它。文件的名称和路径（相对于源文件的根目录输出位置）基于该文件中声明的类型。如果声明的类型不止一个，则应该使用主要顶层类型的名称（例如，声明为 public 的那个）。还可以创建源文件来保存有关某个包的信息，包括包注释。要为指定包创建源文件，可以用 name 作为包名称，后跟 &quot;.package-info&quot;；要为未指定的包创建源文件，可以使用 &quot;package-info&quot;。

注意，若要使用特定 charset 来编码文件内容，可以从返回对象的 OutputStream 创建具有选定字符集的 OutputStreamWriter。如果将所返回对象中的 Writer 直接用于写入操作，则其字符集由实现确定。注释处理工具可以有一个用来指出这一点的 -encoding 标志或类似选项；否则，它通常将是平台的默认编码。

为了避免后续错误，源文件的内容应该与将用于此运行的源版本兼容。

参数：
name - 将在此文件中声明的主要类型的规范（完全限定）名称；对于包信息文件，则是后跟 &quot;.package-info&quot; 的包名称
originatingElements - 与此文件的创建有因果关联的类型或包元素，该参数可以省略或者为 null
返回：
写入新源文件的 JavaFileObject
抛出：
FilerException - 如果创建了相同的路径名，创建了相同的类型，或者名称对于某一类型无效
IOException - 如果无法创建文件

createClassFile

JavaFileObject createClassFile(CharSequence name,
                               Element... originatingElements)
                               throws IOException
创建一个新的类文件，并返回一个对象以允许写入它。文件的名称和路径（相对于类文件的根目录输出位置）基于将写入的类型名称。还可以创建类文件来保存有关某个包的信息，包括包注释。要为指定包创建类文件，可以用 name 作为包名称，后跟 &quot;.package-info&quot;；为未指定的包创建类文件不受支持。

为了避免后续错误，类文件的内容应该与将用于此运行的源版本兼容。

参数：
name - 将写入的类型的二进制名称；对于包信息文件，是后跟 &quot;.package-info&quot; 的包名称
originatingElements - 与此文件的创建有因果关联的类型或包元素，该参数可以省略或者为 null
返回：
写入新类文件的 JavaFileObject
抛出：
FilerException - 如果创建了相同的路径名，创建了相同的类型，或者名称对于某一类型无效
IOException - 如果无法创建文件

createResource

FileObject createResource(JavaFileManager.Location location,
                          CharSequence pkg,
                          CharSequence relativeName,
                          Element... originatingElements)
                          throws IOException
创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。该文件可以与新创建的源文件、新创建的二进制文件或者其他受支持的位置一起被查找。位置 CLASS_OUTPUT 和 SOURCE_OUTPUT 必须受支持。资源可以是相对于某个包（该包是源文件和类文件）指定的，并通过相对路径名从中取出。从不太严格的角度说，新文件的完全路径名将是 location、pkg 和 relativeName 的串联。

通过此方法创建的文件并不是为了进行注释处理而注册的，即使文件的完全路径名对应于新的源文件或类文件的完全路径名也是如此。

参数：
location - 新文件的位置
pkg - 文件将相对于其进行指定的包；如果没有这样的包，则该参数是一个空字符串
relativeName - 文件的最终路径名部分
originatingElements - 与此文件的创建有因果关联的类型或包元素，该参数可以忽略或者为 null
返回：
写入新资源的 FileObject
抛出：
IOException - 如果无法创建文件
FilerException - 如果创建了相同的路径名
IllegalArgumentException - 如果位置不受支持
IllegalArgumentException - 如果 relativeName 不是相对名称

getResource

FileObject getResource(JavaFileManager.Location location,
                       CharSequence pkg,
                       CharSequence relativeName)
                       throws IOException
返回一个用于读取现有资源的对象。位置 CLASS_OUTPUT 和 SOURCE_OUTPUT 必须受支持。

参数：
location - 文件的位置
pkg - 将相对于其进行文件搜索的包；如果没有这样的包，则该参数为一个空字符串
relativeName - 文件的最终路径名部分
返回：
读取文件的对象
抛出：
FilerException - 如果已经为写入操作打开相同的路径名
IOException - 如果无法打开文件
IllegalArgumentException - 如果位置不受支持
IllegalArgumentException - 如果 relativeName 不是相对名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilerException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
类 FilerException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.annotation.processing.FilerException
所有已实现的接口：
Serializable
public class FilerException
extends IOException

指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。这些保证包括不要多次创建相同的文件、不要创建对应于同一类型的多个文件，也不要为具有无效名称的类型创建文件。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
FilerException(String s)
构造带指定详细消息的异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FilerException

public FilerException(String s)
构造带指定详细消息的异常。

参数：
s - 详细消息，该消息应包括试图打开的文件的名称；该参数可以为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Messager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
接口 Messager

public interface Messager

Messager 提供注释处理器用来报告错误消息、警告和其他通知的方式。可以传递元素、注释和注释值，以提供消息的位置提示。不过，这类位置提示可能是不可用的，或者只是大概的提示。

打印带有错误种类的消息将产生一个错误。

注意，由此接口中的方法“打印”的消息可能作为某一位置的文本输出（如 System.out 或 System.err）出现，也可能不会这样。这些实现可以选择以不同的方式（比如窗口中的消息）表示此信息。

从以下版本开始：
1.6
另请参见：
ProcessingEnvironment.getLocale()

方法摘要
void | printMessage(Diagnostic.Kind kind, CharSequence msg) 打印指定种类的消息。
void | printMessage(Diagnostic.Kind kind, CharSequence msg, Element e) 在元素的位置上打印指定种类的消息。
void | printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

方法详细信息

printMessage

void printMessage(Diagnostic.Kind kind,
                  CharSequence msg)
打印指定种类的消息。

参数：
kind - 消息的种类
msg - 消息；如果没有消息，则该参数是一个空字符串

printMessage

void printMessage(Diagnostic.Kind kind,
                  CharSequence msg,
                  Element e)
在元素的位置上打印指定种类的消息。

参数：
kind - 消息的种类
msg - 消息；如果没有消息，则该参数是一个空字符串
e - 用作位置提示的元素

printMessage

void printMessage(Diagnostic.Kind kind,
                  CharSequence msg,
                  Element e,
                  AnnotationMirror a)
在已注释元素的注释镜像位置上打印指定种类的消息。

参数：
kind - 消息的种类
msg - 消息；如果没有消息，则该参数是一个空字符串
e - 已注释的元素
a - 用作位置提示的注释

printMessage

void printMessage(Diagnostic.Kind kind,
                  CharSequence msg,
                  Element e,
                  AnnotationMirror a,
                  AnnotationValue v)
在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

参数：
kind - 消息的种类
msg - 消息；如果没有消息，则该参数是一个空字符串
e - 已注释的元素
a - 包含注释值的注释
v - 用作位置提示的注释值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProcessingEnvironment (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
接口 ProcessingEnvironment

public interface ProcessingEnvironment

注释处理工具框架将提供一个具有实现此接口的对象的注释 processor，因此 processor 可以使用该框架提供的设施来编写新文件、报告错误消息并查找其他实用工具。

第三方可能希望提供能包装此接口设施对象的增值包装器，例如，允许多个 processor 协同写出单个源文件的 Filer 扩展。为了实现这一点，对于在其副作用可通过 API 相互可见的上下文中运行的 processor，工具基础设施必须提供相应的设施对象，这些对象是 .equals、作为 .equals 的 Filer 等等。此外，必须能够配置工具调用，使得从运行注释 processor 的角度来看，至少已选定的帮助 (helper) 类子集可视为由相同的类加载器加载。（因为设施对象管理共享状态，所以包装器类的实现必须知道以前是否包装过相同的基本设施对象。）

从以下版本开始：
1.6

方法摘要
Elements | getElementUtils() 返回用来在元素上进行操作的某些实用工具方法的实现。
Filer | getFiler() 返回用来创建新源、类或辅助文件的 Filer。
Locale | getLocale() 返回当前语言环境；如果没有有效的语言环境，则返回 null。
Messager | getMessager() 返回用来报告错误、警报和其他通知的 Messager。
Map<String,String> | getOptions() 返回传递给注释处理工具的特定于 processor 的选项。
SourceVersion | getSourceVersion() 返回任何生成的源和类文件应该符合的源版本。
Types | getTypeUtils() 返回用来在类型上进行操作的某些实用工具方法的实现。

方法详细信息

getOptions

Map<String,String> getOptions()
返回传递给注释处理工具的特定于 processor 的选项。选项是以从选项名称到选项值的映射形式返回的。对于不包含任何值的选项，映射中的对应值为 null。

关于如何传入特定于 processor 的选项的详细信息，请参阅特定工具基础设施的文档。例如，命令行实现可以通过使用已知字符串（如 &quot;-A&quot;）作为特定于 processor 的选项的前缀来区分它们；其他工具实现可能遵守不同的约定或提供替换机制。除了特定于 processor 的选项外，给定实现还可以提供特定于实现的方式来查找传递给该工具的选项。

返回：
传递给工具的特定于 processor 的选项

getMessager

Messager getMessager()
返回用来报告错误、警报和其他通知的 Messager。

返回：
Messager

getFiler

Filer getFiler()
返回用来创建新源、类或辅助文件的 Filer。

返回：
Filer

getElementUtils

Elements getElementUtils()
返回用来在元素上进行操作的某些实用工具方法的实现。

返回：
元素实用工具

getTypeUtils

Types getTypeUtils()
返回用来在类型上进行操作的某些实用工具方法的实现。

返回：
类型实用工具

getSourceVersion

SourceVersion getSourceVersion()
返回任何生成的源和类文件应该符合的源版本。

返回：
生成的源和类文件应该符合的源版本
另请参见：
Processor.getSupportedSourceVersion()

getLocale

Locale getLocale()
返回当前语言环境；如果没有有效的语言环境，则返回 null。该语言环境可用来提供本地化的消息。

返回：
当前语言环境；如果没有有效的语言环境，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Processor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
接口 Processor

所有已知实现类：
AbstractProcessor
public interface Processor

注释 Processor 的接口。

注释处理是按照 round 的顺序进行的。在每次进行 round 操作时，都会请求 Processor 处理在前一个处理轮次生成的源文件和类文件上找到的注释子集。第一轮次处理的输入是工具运行的初始输入值；这些初始输入值可视为虚拟的第 0 轮次处理的输出。如果请求 Processor 在给定轮次上进行处理，那么它将被要求处理后续轮次，包括最后的轮次，即使没有要处理的注释也一样。工具框架可能还会请求 Processor 处理由工具的操作隐式生成的文件。

Processor 的每次实现都必须提供一个公共的无参数构造方法，工具将使用该构造方法实例化 Processor。工具框架将与实现此接口的类交互，如下所示：

  1. 如果不使用现有 Processor 对象，若要创建 Processor 实例，则工具将调用 Processor 类的无参数构造方法。
  2. 接下来，工具调用具有适当 ProcessingEnvironment 的 init 方法。
  3. 然后，工具调用 getSupportedAnnotationTypes、getSupportedOptions 和 getSupportedSourceVersion。这些方法只在每次运行时调用一次，并非对每个处理轮次调用。
  4. 在适当的时候，工具在 Processor 对象上调用 process 方法；无需 为每个处理轮次创建新的 Processor 对象。
如果创建了一个 Processor 对象，并在没有遵循上述协议的情况下使用它，那么该 Processor 的行为将不是由此接口规范所定义的。

该工具使用一个搜索过程 来查找注释 Processor，并确定是否应该运行它们。通过配置该工具，可以控制潜在的 Processor 集合。例如，对于 JavaCompiler，要运行的候选 Processor 列表可以是直接设置的，也可以是通过用于服务样式查找的搜索路径所控制的 Processor 列表。其他工具实现可能有不同的配置机制，比如命令行选项；有关详细信息，请参考特定工具的文档。工具请求运行哪一个 Processor 取决于根元素上出现哪些注释、Processor 处理哪些注释类型以及 Processor 是否声明它所处理的注释。Processor 将被要求处理它所支持的注释类型的子集，该集合可能是一个空集。 对于给定的 round，工具计算根元素上的注释类型集。如果至少存在一个注释类型，那么当 Processor 声明注释类型时，将从不匹配的注释集移除它们。当该集合为空或者没有更多 Processor 可用时，round 将运行完成。如果不存在注释类型，注释处理仍然会发生，但只有支持处理 "*" 的通用 Processor 可以声明（空）注释类型集。

注意，如果 Processor 支持 "*" 并返回 true，则声明所有注释。因此，通用 Processor（例如，用来实现其他有效性检查的通用 Processor）应该返回 false，以便允许运行其他这类检查器。

如果 Processor 抛出一个未捕获的异常，那么工具可能停止其他活动的注释 Processor。如果某一 Processor 产生错误，那么当前 round 将运行完成，并且后续 round 将指示产生了错误。因为注释 Processor 是在协作环境下运行的，所以 Processor 只在错误恢复和报告都不可行的情况下才会抛出一个未捕获的异常。

不要求工具环境支持以多线程方式访问环境资源（每个 round 或跨 round）的注释 Processor。

如果返回有关注释 Processor 配置信息的方法返回 null、返回其他无效输入，或者抛出一个异常，则工具框架必须将此视为一种错误状态。

为了可靠起见，当在不同工具实现中运行时，注释 Processor 应该具有以下属性：

  1. 处理某一给定输入的结果不是其他输入存在或不存在的函数（正交性）。
  2. 处理相同的输入将产生相同的输出（一致性）。
  3. 处理输入 A 之后处理输入 B 等同于处理 B 然后处理 A（互换性）。
  4. 处理输入并不依赖于其他注释 Processor 输出的存在（独立性）。

Filer 接口讨论了关于 Processor 如何在文件上进行操作的限制。

注意，此接口的实现者可能会发现扩展 AbstractProcessor 比直接实现此接口更便捷。

从以下版本开始：
1.6

方法摘要
Iterable<? extends Completion> | getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。
Set<String> | getSupportedAnnotationTypes() 返回此 Processor 支持的注释类型的名称。
Set<String> | getSupportedOptions() 返回此 Processor 识别的选项。
SourceVersion | getSupportedSourceVersion() 返回此注释 Processor 支持的最新的源版本。
void | init(ProcessingEnvironment processingEnv) 用处理环境初始化 Processor。
boolean | process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。

方法详细信息

getSupportedOptions

Set<String> getSupportedOptions()
返回此 Processor 识别的选项。处理工具的实现必须提供一种方式来传递特定于 Processor 的选项，这些选项不同于传递给工具自身的选项，请参见 getOptions。

集合中返回的每个字符串都必须是句点分隔的标识符序列：

SupportedOptionString：
标识符

标识符：
标识符
标识符 .标识符

标识符：
语法标识符，包括关键字和字面值

工具可以使用此信息来确定用户提供的任意选项是否无法被任何 Processor 识别，在这种情况下，可能希望它报告警报。

返回：
此 Processor 识别的选项；如果没有这样的选项，则返回一个空集合
另请参见：
SupportedOptions

getSupportedAnnotationTypes

Set<String> getSupportedAnnotationTypes()
返回此 Processor 支持的注释类型的名称。结果元素可能是某一受支持注释类型的规范（完全限定）名称。它也可能是 "name.*" 形式的名称，表示所有以 "name." 开头的规范名称的注释类型集合。最后，"*" 自身表示所有注释类型的集合，包括空集。注意，Processor 不应声明 "*"，除非它实际处理了所有文件；声明不必要的注释可能导致在某些环境中的性能下降。

集合中返回的每个字符串必须符合以下语法：

SupportedAnnotationTypeString:
TypeName DotStaropt
*

DotStar:
. *
其中 TypeName 在 Java 语言规范 中定义。

返回：
此 Processor 所支持的注释类型的名称
另请参见：
SupportedAnnotationTypes

getSupportedSourceVersion

SourceVersion getSupportedSourceVersion()
返回此注释 Processor 支持的最新的源版本。

返回：
此注释 Processor 所支持的最新的源版本。
另请参见：
SupportedSourceVersion, ProcessingEnvironment.getSourceVersion()

init

void init(ProcessingEnvironment processingEnv)
用处理环境初始化 Processor。

参数：
processingEnv - 工具框架提供给 Processor 的设施的环境

process

boolean process(Set<? extends TypeElement> annotations,
                RoundEnvironment roundEnv)
处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。如果返回 true，则这些注释已声明并且不要求后续 Processor 处理它们；如果返回 false，则这些注释未声明并且可能要求后续 Processor 处理它们。Processor 可能总是返回相同的 boolean 值，或者可能基于所选择的标准而返回不同的结果。

如果 Processor 支持 "*" 并且根元素没有注释，则输入集合将为空。Processor 必须妥善处理空注释集。

参数：
annotations - 请求处理的注释类型
roundEnv - 有关当前和以前 round 的信息的环境
返回：
注释集是否由此 Processor 声明

getCompletions

Iterable<? extends Completion> getCompletions(Element element,
                                              AnnotationMirror annotation,
                                              ExecutableElement member,
                                              String userText)
向工具框架返回某一注释的建议 completion 迭代。因为要求 completion，所以提供的有关注释的信息可能是不完整的，就像用于源代码片段的信息一样。Processor 可能返回一个空迭代。注释 Processor 应该将其工作集中在提供注释成员的 completion 上，这些成员具有 Processor 已知的其他有效性约束，例如值应该在 1 和 10 之间的 int 成员，或者应该由已知语法识别的字符串成员，比如正则表达式或者 URL。

因为将为不完整的程序建立模型，所以某些参数可能只有部分信息，或者可能为 null。element 和 userText 中必须至少有一个不为 null。如果 element 不为 null，则 annotation 和 member 可以为 null。如果某些参数为 null，Processor 可能不会抛出 NullPointerException；如果 Processor 基于所提供的信息不提供 completion，则可能返回一个空迭代。Processor 也可能返回一个具有空值字符串的单个 completion，以及描述不提供 completion 的原因的消息。

completion 包含许多信息，它可以反映注释 Processor 执行的其他有效性检查。例如，考虑以下简单注释：

@MersennePrime {
int value();
 }
（素数 Mersenne 是 2n - 1 形式的素数。)如果给定此注释类型的 AnnotationMirror，则可以返回 int 范围内所有这类素数的列表，而无需检查 getCompletions 的其他任何参数：
import static javax.annotation.processing.Completions.*;
 ...
return Arrays.asList(of("3"),
of("7"),
of("31"),
of("127"),
of("8191"),
of("131071"),
of("524287"),
of("2147483647"));
包含更多信息的 completion 集合还包括每个素数的数量：
return Arrays.asList(of("3",          "M2"),
of("7",          "M3"),
of("31",         "M5"),
of("127",        "M7"),
of("8191",       "M13"),
of("131071",     "M17"),
of("524287",     "M19"),
of("2147483647", "M31"));
不过，如果 userText 是可用的，则可以检查它，以查看是否只有素数 Mersenne 的子集是有效的。例如，如果用户键入了以下内容
@MersennePrime(1
则 userText 的值将是 "1"；并且只有两个素数可能是 completion：
return Arrays.asList(of("127",        "M7"),
of("131071",     "M17"));
有时可能不是有效的 completion。例如，范围内没有以 9 开头的 Mersenne 素数：
@MersennePrime(9
在这种情况下，适当的响应是返回一个空的 completion 列表，
return Collections.emptyList();
或者返回一个包含帮助消息的单个空 completion
return Arrays.asList(of("", "No in-range Mersenne primes start with 9"));

参数：
element - 将被注释的元素
annotation - 将应用于元素的注释（可能是一部分）
member - 为其返回可能 completion 的注释成员
userText - 将补充完整的源代码文本
返回：
注释的建议 completion
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoundEnvironment (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.annotation.processing
接口 RoundEnvironment

public interface RoundEnvironment

注释处理工具框架将提供一个注释处理器和一个实现此接口的对象，这样处理器可以查询有关注释处理的 round 的信息。

从以下版本开始：
1.6

方法摘要
boolean | errorRaised() 如果在以前的处理 round 中发生错误，则返回 true；否则返回 false。
Set<? extends Element> | getElementsAnnotatedWith(Class<? extends Annotation> a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | getElementsAnnotatedWith(TypeElement a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | getRootElements() 返回以前的 round 生成的注释处理根元素。
boolean | processingOver() 如果此 round 生成的类型不是以注释处理的后续 round 为准，则返回 true；否则返回 false。

方法详细信息

processingOver

boolean processingOver()
如果此 round 生成的类型不是以注释处理的后续 round 为准，则返回 true；否则返回 false。

返回：
如果此 round 生成的类型不是以注释处理的后续 round 为准，则返回 true；否则返回 false

errorRaised

boolean errorRaised()
如果在以前的处理 round 中发生错误，则返回 true；否则返回 false。

返回：
如果在以前的处理 round 中发生错误，则返回 true；否则返回 false

getRootElements

Set<? extends Element> getRootElements()
返回以前的 round 生成的注释处理根元素。

返回：
返回以前的 round 生成的注释处理根元素；如果没有这样的元素，则返回一个空集

getElementsAnnotatedWith

Set<? extends Element> getElementsAnnotatedWith(TypeElement a)
返回使用给定注释类型注释的元素。该注释可能直接出现或者被继承。只返回注释处理的此 round 中包括 的 package 元素和 type 元素、成员声明、参数或者这些元素中声明的类型参数。所包括的 type 元素是根类型和嵌套在这些类型中的所有成员类型。包中的元素不认为被包含在内，因为已经为该包创建了一个 package-info 文件。

参数：
a - 将被请求的注释类型
返回：
使用给定注释类型注释的元素；如果没有这样的元素，则返回一个空集
抛出：
IllegalArgumentException - 如果参数不表示注释类型

getElementsAnnotatedWith

Set<? extends Element> getElementsAnnotatedWith(Class<? extends Annotation> a)
返回使用给定注释类型注释的元素。该注释可能直接出现或者被继承。只返回注释处理的此 round 中包括 的 package 元素和 type 元素、成员声明、参数或者这些元素中声明的类型参数。所包括的 type 元素是根类型和嵌套在这些类型中的所有成员类型。包中的元素不认为被包含在内，因为已经为该包创建了一个 package-info 文件。

参数：
a - 将被请求的注释类型
返回：
使用给定注释类型注释的元素；如果没有这样的元素，则返回一个空集
抛出：
IllegalArgumentException - 如果参数不表示注释类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SupportedAnnotationTypes (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.annotation.processing
注释类型 SupportedAnnotationTypes

@Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SupportedAnnotationTypes

用来指示注释处理器支持哪些注释类型的注释。Processor.getSupportedAnnotationTypes() 方法可以根据此注释的值构造它的结果，正如 AbstractProcessor.getSupportedAnnotationTypes() 所做的一样。只有符合语法的字符串才应该作为值来使用。

从以下版本开始：
1.6

必需元素摘要
 String[] value

元素详细信息

value

public abstract String[] value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


SupportedOptions (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.annotation.processing
注释类型 SupportedOptions

@Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SupportedOptions

用来指示注释处理器支持哪些选项的注释。Processor.getSupportedOptions() 方法可以根据此注释的值构造它的结果，正如 AbstractProcessor.getSupportedOptions() 所做的一样。只有符合语法的字符串才应该作为值来使用。

从以下版本开始：
1.6

必需元素摘要
 String[] value

元素详细信息

value

public abstract String[] value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


SupportedSourceVersion (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.annotation.processing
注释类型 SupportedSourceVersion

@Documented
@Target(value=TYPE)
@Retention(value=RUNTIME)
public @interface SupportedSourceVersion

用来指示注释处理器所支持的最新源版本的注释。Processor.getSupportedSourceVersion() 方法可以根据此注释的值构造它的结果，正如 AbstractProcessor.getSupportedSourceVersion() 所做的一样。

从以下版本开始：
1.6

必需元素摘要
 SourceVersion value

元素详细信息

value

public abstract SourceVersion value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


javax.annotation.processing (Java 2 Platform SE 6)

 javax.annotation.processing
接口
Completion
Filer
Messager
ProcessingEnvironment
Processor
RoundEnvironment
类
AbstractProcessor
Completions
异常
FilerException
注释类型
SupportedAnnotationTypes
SupportedOptions
SupportedSourceVersion


javax.annotation.processing (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.annotation.processing

用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

请参见：
描述

接口摘要
Completion | 某一注释的建议 completion。
Filer | 此接口支持通过注释处理器创建新文件。
Messager | Messager 提供注释处理器用来报告错误消息、警告和其他通知的方式。
ProcessingEnvironment | 注释处理工具框架将提供一个具有实现此接口的对象的注释 processor，因此 processor 可以使用该框架提供的设施来编写新文件、报告错误消息并查找其他实用工具。
Processor | 注释 Processor 的接口。
RoundEnvironment | 注释处理工具框架将提供一个注释处理器和一个实现此接口的对象，这样处理器可以查询有关注释处理的 round 的信息。

类摘要
AbstractProcessor | 旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。
Completions | 用来组合 Completion 对象的实用工具类。

异常摘要
FilerException 指示一个检测到试图打开某一文件的 Filer，该文件违反 Filer 提供的保证。

注释类型摘要
SupportedAnnotationTypes | 用来指示注释处理器支持哪些注释类型的注释。
SupportedOptions | 用来指示注释处理器支持哪些选项的注释。
SupportedSourceVersion | 用来指示注释处理器所支持的最新源版本的注释。

软件包 javax.annotation.processing 的描述

用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

除非在特定实现中另行指定，否则此包中的方法所返回的集合应该是不能由调用者修改的，并且对于并发访问是不安全的。

除非另行指定，否则，如果给定一个 null 参数，此包中的方法将抛出 NullPointerException。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.annotation.processing 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.annotation.processing 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.annotation.processing.AbstractProcessor (implements javax.annotation.processing.Processor)
    • javax.annotation.processing.Completions
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.annotation.processing.FilerException

接口分层结构

  • javax.annotation.processing.Completion
  • javax.annotation.processing.Filer
  • javax.annotation.processing.Messager
  • javax.annotation.processing.ProcessingEnvironment
  • javax.annotation.processing.Processor
  • javax.annotation.processing.RoundEnvironment

注释类型分层结构

  • javax.annotation.processing.SupportedAnnotationTypes (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedOptions (implements java.lang.annotation.Annotation)
  • javax.annotation.processing.SupportedSourceVersion (implements java.lang.annotation.Annotation)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.annotation.processing 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.annotation.processing
的使用

使用 javax.annotation.processing 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 使用的 javax.annotation.processing 中的类
Completion
某一注释的建议 completion。
Filer
此接口支持通过注释处理器创建新文件。
Messager
Messager 提供注释处理器用来报告错误消息、警告和其他通知的方式。
ProcessingEnvironment
注释处理工具框架将提供一个具有实现此接口的对象的注释 processor，因此 processor 可以使用该框架提供的设施来编写新文件、报告错误消息并查找其他实用工具。
Processor
注释 Processor 的接口。
RoundEnvironment
注释处理工具框架将提供一个注释处理器和一个实现此接口的对象，这样处理器可以查询有关注释处理的 round 的信息。

javax.lang.model.util 使用的 javax.annotation.processing 中的类
SupportedSourceVersion
用来指示注释处理器所支持的最新源版本的注释。

javax.tools 使用的 javax.annotation.processing 中的类
Processor
注释 Processor 的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.processing.AbstractProcessor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.AbstractProcessor
的使用

没有 javax.annotation.processing.AbstractProcessor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.annotation.processing.Completion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Completion
的使用

使用 Completion 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Completion 的使用

返回 Completion 的 javax.annotation.processing 中的方法
static Completion | Completions.of(String value) 返回值和空消息的 completion。
static Completion | Completions.of(String value, String message) 返回值和消息的 completion。

返回变量类型为 Completion 的类型的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.processing.Completions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.Completions
的使用

没有 javax.annotation.processing.Completions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.annotation.processing.Filer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Filer
的使用

使用 Filer 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Filer 的使用

返回 Filer 的 javax.annotation.processing 中的方法
 Filer ProcessingEnvironment.getFiler()
返回用来创建新源、类或辅助文件的 Filer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.processing.FilerException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.FilerException
的使用

没有 javax.annotation.processing.FilerException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.annotation.processing.Messager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Messager
的使用

使用 Messager 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Messager 的使用

返回 Messager 的 javax.annotation.processing 中的方法
 Messager ProcessingEnvironment.getMessager()
返回用来报告错误、警报和其他通知的 Messager。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.annotation.processing.ProcessingEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.ProcessingEnvironment
的使用

使用 ProcessingEnvironment 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 ProcessingEnvironment 的使用

声明为 ProcessingEnvironment 的 javax.annotation.processing 中的字段
protected  ProcessingEnvironment AbstractProcessor.processingEnv
工具框架提供的处理环境。

参数类型为 ProcessingEnvironment 的 javax.annotation.processing 中的方法
void | AbstractProcessor.init(ProcessingEnvironment processingEnv) 用处理环境初始化 processor，方法是将 processingEnv 字段设置为 processingEnv 参数的值。
void | Processor.init(ProcessingEnvironment processingEnv) 用处理环境初始化 Processor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.annotation.processing.Processor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.Processor
的使用

使用 Processor 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 Processor 的使用

实现 Processor 的 javax.annotation.processing 中的类
 class AbstractProcessor
旨在用作最具体注释 processor 的便捷超类的抽象注释 processor。

javax.tools 中 Processor 的使用

类型变量类型为 Processor 的 javax.tools 中的方法参数
 void JavaCompiler.CompilationTask.setProcessors(Iterable<? extends Processor> processors)
设置处理器（用于注释处理）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.annotation.processing.RoundEnvironment 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.annotation.processing.RoundEnvironment
的使用

使用 RoundEnvironment 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 RoundEnvironment 的使用

参数类型为 RoundEnvironment 的 javax.annotation.processing 中的方法
abstract boolean | AbstractProcessor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
boolean | Processor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.processing.SupportedAnnotationTypes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.SupportedAnnotationTypes
的使用

没有 javax.annotation.processing.SupportedAnnotationTypes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.processing.SupportedOptions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.SupportedOptions
的使用

没有 javax.annotation.processing.SupportedOptions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.processing.SupportedSourceVersion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.processing.SupportedSourceVersion
的使用

使用 SupportedSourceVersion 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 SupportedSourceVersion 的使用

注释类型为 SupportedSourceVersion 的 javax.lang.model.util 中的类
class | AbstractAnnotationValueVisitor6<R,P> 注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | AbstractElementVisitor6<R,P> 程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementKindVisitor6<R,P> 基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementScanner6<R,P> 程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleAnnotationValueVisitor6<R,P> 注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleElementVisitor6<R,P> 程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleTypeVisitor6<R,P> 类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | TypeKindVisitor6<R,P> 基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.Generated 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Generated
的使用

没有 javax.annotation.Generated 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.PostConstruct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.PostConstruct
的使用

没有 javax.annotation.PostConstruct 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.PreDestroy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.PreDestroy
的使用

没有 javax.annotation.PreDestroy 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.Resource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Resource
的使用

没有 javax.annotation.Resource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.Resource.AuthenticationType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Resource.AuthenticationType
的使用

使用 Resource.AuthenticationType 的软件包
javax.annotation

javax.annotation 中 Resource.AuthenticationType 的使用

返回 Resource.AuthenticationType 的 javax.annotation 中的方法
static Resource.AuthenticationType | Resource.AuthenticationType.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Resource.AuthenticationType[] | Resource.AuthenticationType.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.annotation.Resources 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.annotation.Resources
的使用

没有 javax.annotation.Resources 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BadPaddingException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 BadPaddingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.crypto.BadPaddingException
所有已实现的接口：
Serializable
public class BadPaddingException
extends GeneralSecurityException

当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
BadPaddingException()
构造不带详细消息的 BadPaddingException。
BadPaddingException(String msg)
构造带指定详细消息的 BadPaddingException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BadPaddingException

public BadPaddingException()
构造不带详细消息的 BadPaddingException。详细消息是描述此特定异常的String。

BadPaddingException

public BadPaddingException(String msg)
构造带指定详细消息的 BadPaddingException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Cipher (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 Cipher

java.lang.Object
    继承者  javax.crypto.Cipher
直接已知子类：
NullCipher
public class Cipher
extends Object

此类为加密和解密提供密码功能。它构成了 Java Cryptographic Extension (JCE) 框架的核心。

为创建 Cipher 对象，应用程序调用 Cipher 的 getInstance 方法并将所请求转换 的名称传递给它。还可以指定提供者的名称（可选）。

转换 是一个字符串，它描述为产生某种输出而在给定的输入上执行的操作（或一组操作）。转换始终包括加密算法的名称（例如，DES），后面可能跟有一个反馈模式和填充方案。

转换具有以下形式：

  • “算法/模式/填充”或

  • “算法”

（后一种情况下，使用模式和填充方案特定于提供者的默认值）。例如，以下是有效的转换：

     Cipher c = Cipher.getInstance("DES/CBC/PKCS5Padding");
使用 CFB 和 OFB 之类的模式，Cipher 块可以加密单元中小于该 Cipher 的实际块大小的数据。请求这样一个模式时，可以指定一次处理的位数（可选）：将此数添加到模式名称中，正如 "DES/CFB8/NoPadding" 和 "DES/OFB32/PKCS5Padding" 转换所示。如果未指定该数，则将使用特定于提供者的默认值。（例如，SunJCE 提供者对 DES 使用默认的 64 位）。因此，通过使用如 CFB8 或 OFB8 的 8 位模式，Cipher 块可以被转换为面向字节的 Cipher 流。

从以下版本开始：
1.4
另请参见：
KeyGenerator, SecretKey

字段摘要
static int | DECRYPT_MODE 用于将 Cipher 初始化为解密模式的常量。
static int | ENCRYPT_MODE 用于将 Cipher 初始化为加密模式的常量。
static int | PRIVATE_KEY 用于表示要解包的密钥为“私钥”的常量。
static int | PUBLIC_KEY 用于表示要解包的密钥为“公钥”的常量。
static int | SECRET_KEY 用于表示要解包的密钥为“秘密密钥”的常量。
static int | UNWRAP_MODE 用于将 Cipher 初始化为密钥解包模式的常量。
static int | WRAP_MODE 用于将 Cipher 初始化为密钥包装模式的常量。
构造方法摘要
protected Cipher(CipherSpi cipherSpi, Provider provider, String transformation)
创建 Cipher 对象。
方法摘要
byte[] | doFinal() 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | doFinal(byte[] input) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | doFinal(byte[] output, int outputOffset) 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | doFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | doFinal(byte[] input, int inputOffset, int inputLen, byte[] output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | doFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | doFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
String | getAlgorithm() 返回此 Cipher 对象的算法名称。
int | getBlockSize() 返回块的大小（以字节为单位）。
ExemptionMechanism | getExemptionMechanism() 返回此 Cipher 使用的豁免 (exemption) 机制对象。
static Cipher | getInstance(String transformation) 返回实现指定转换的 Cipher 对象。
static Cipher | getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static Cipher | getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。
byte[] | getIV() 返回新缓冲区中的初始化向量 (IV)。
static int | getMaxAllowedKeyLength(String transformation) 根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。
static AlgorithmParameterSpec | getMaxAllowedParameterSpec(String transformation) 根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。
int | getOutputSize(int inputLen) 根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度（以字节为单位）。
AlgorithmParameters | getParameters() 返回此 Cipher 使用的参数。
Provider | getProvider() 返回此 Cipher 对象的提供者。
void | init(int opmode, Certificate certificate) 用取自给定证书的公钥初始化此 Cipher。
void | init(int opmode, Certificate certificate, SecureRandom random) 用取自给定证书的公钥和随机源初始化此 Cipher。
void | init(int opmode, Key key) 用密钥初始化此 Cipher。
void | init(int opmode, Key key, AlgorithmParameters params) 用密钥和一组算法参数初始化此 Cipher。
void | init(int opmode, Key key, AlgorithmParameterSpec params) 用密钥和一组算法参数初始化此 Cipher。
void | init(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | init(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 Cipher。
void | init(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 Cipher。
Key | unwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 解包一个以前包装的密钥。
byte[] | update(byte[] input) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
byte[] | update(byte[] input, int inputOffset, int inputLen) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
int | update(byte[] input, int inputOffset, int inputLen, byte[] output) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
int | update(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
int | update(ByteBuffer input, ByteBuffer output) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
byte[] | wrap(Key key) 包装密钥。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ENCRYPT_MODE

public static final int ENCRYPT_MODE
用于将 Cipher 初始化为加密模式的常量。

另请参见：
常量字段值

DECRYPT_MODE

public static final int DECRYPT_MODE
用于将 Cipher 初始化为解密模式的常量。

另请参见：
常量字段值

WRAP_MODE

public static final int WRAP_MODE
用于将 Cipher 初始化为密钥包装模式的常量。

另请参见：
常量字段值

UNWRAP_MODE

public static final int UNWRAP_MODE
用于将 Cipher 初始化为密钥解包模式的常量。

另请参见：
常量字段值

PUBLIC_KEY

public static final int PUBLIC_KEY
用于表示要解包的密钥为“公钥”的常量。

另请参见：
常量字段值

PRIVATE_KEY

public static final int PRIVATE_KEY
用于表示要解包的密钥为“私钥”的常量。

另请参见：
常量字段值

SECRET_KEY

public static final int SECRET_KEY
用于表示要解包的密钥为“秘密密钥”的常量。

另请参见：
常量字段值
构造方法详细信息

Cipher

protected Cipher(CipherSpi cipherSpi,
                 Provider provider,
                 String transformation)
创建 Cipher 对象。

参数：
cipherSpi - 代理
provider - 提供者
transformation - 转换
方法详细信息

getInstance

public static final Cipher getInstance(String transformation)
                                throws NoSuchAlgorithmException,
                                       NoSuchPaddingException
返回实现指定转换的 Cipher 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 CipherSpi 实现的新 Cipher 对象，该实现取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
transformation - 转换的名称，例如 DES/CBC/PKCS5Padding。有关标准转换名称的信息，请参见 Java Cryptography Architecture Reference Guide 的附录 A。
返回：
实现所请求转换的 Cipher。
抛出：
NoSuchAlgorithmException - 如果 transformation 为 null、空、无效格式，或者没有 Provider 支持指定算法的 CipherSpi 实现。
NoSuchPaddingException - 如果 transformation 包含的填充方案不可用。
另请参见：
Provider

getInstance

public static final Cipher getInstance(String transformation,
                                       String provider)
                                throws NoSuchAlgorithmException,
                                       NoSuchProviderException,
                                       NoSuchPaddingException
返回实现指定转换的 Cipher 对象。

返回一个封装 CipherSpi 实现的新 Cipher 对象，该实现取自指定提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
transformation - 转换的名称，例如 DES/CBC/PKCS5Padding。有关标准转换名称的信息，请参见 Java Cryptography Architecture Reference Guide 的附录 A。
provider - 提供者的名称。
返回：
实现所请求转换的 Cipher。
抛出：
NoSuchAlgorithmException - 如果 transformation 为 null、空、无效格式，或者不能从指定提供者获得指定算法的 CipherSpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
NoSuchPaddingException - 如果 transformation 包含的填充方案不可用。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static final Cipher getInstance(String transformation,
                                       Provider provider)
                                throws NoSuchAlgorithmException,
                                       NoSuchPaddingException
返回实现指定转换的 Cipher 对象。

返回一个封装 CipherSpi 实现的新 Cipher 对象，该实现取自指定的 Provider 对象。 注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
transformation - 转换的名称，例如 DES/CBC/PKCS5Padding。有关标准转换名称的信息，请参见 Java Cryptography Architecture Reference Guide 的附录 A。
provider - 提供者。
返回：
实现所请求转换的 Cipher。
抛出：
NoSuchAlgorithmException - 如果 transformation 为 null、空、无效格式，或者不能从指定 Provider 对象获得指定算法的 CipherSpi 实现。
NoSuchPaddingException - 如果 transformation 包含的填充方案不可用。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 Cipher 对象的提供者。

返回：
此 Cipher 对象的提供者

getAlgorithm

public final String getAlgorithm()
返回此 Cipher 对象的算法名称。

这与创建此 Cipher 对象的 getInstance 调用之一指定的名称相同。

返回：
此 Cipher 对象的算法名称。

getBlockSize

public final int getBlockSize()
返回块的大小（以字节为单位）。

返回：
块的大小（以字节为单位）；如果底层算法不是 Cipher 块，则返回 0

getOutputSize

public final int getOutputSize(int inputLen)
根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度（以字节为单位）。

此调用还考虑到任何取自上一个 update 调用的未处理（已缓存）数据和填充。

下一个 update 或 doFinal 调用的实际输出长度可能小于此方法返回的长度。

参数：
inputLen - 输入长度（以字节为单位）
返回：
所需的输出缓冲区大小（以字节为单位）
抛出：
IllegalStateException - 如果此 Cipher 处于错误的状态（例如，尚未初始化）

getIV

public final byte[] getIV()
返回新缓冲区中的初始化向量 (IV)。

在创建随机 IV 的情况下，或者在基于密码加密或解密的上下文中（其中，IV 派生自用户提供的密码）此方法很有用。

返回：
新缓冲区中的初始化向量；如果底层算法不使用 IV，或者 IV 尚未设置，则返回 null。

getParameters

public final AlgorithmParameters getParameters()
返回此 Cipher 使用的参数。

返回的参数可能与初始化此 Cipher 所使用的参数相同；如果此 Cipher 需要算法参数但却未使用任何参数进行初始化，则返回的参数将由默认值和底层 Cipher 实现所使用的随机参数值组成。

返回：
此 Cipher 使用的参数；如果此 Cipher 不使用任何参数，则返回 null。

getExemptionMechanism

public final ExemptionMechanism getExemptionMechanism()
返回此 Cipher 使用的豁免 (exemption) 机制对象。

返回：
此 Cipher 使用的豁免机制对象，如果此 Cipher 不使用任何豁免机制，则返回 null。

init

public final void init(int opmode,
                       Key key)
                throws InvalidKeyException
用密钥初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果此 Cipher 需要任何无法从给定 key 派生的算法参数，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在为解密或密钥解包初始化时，将引发 InvalidKeyException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将使用具有最高优先级的已安装提供者的 SecureRandom 实现作为随机源获取这些字节。（如果已安装的提供者都不提供 SecureRandom 实现，则将使用系统提供的随机源）。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 密钥
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 Cipher；如果此 Cipher 为解密初始化，并且所需算法参数无法从给定的 key 确定；如果给定 key 的键大小超出所允许的最大值（由已配置的仲裁策略文件确定）。

init

public final void init(int opmode,
                       Key key,
                       SecureRandom random)
                throws InvalidKeyException
用密钥和随机源初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果此 Cipher 需要算法参数，而参数无法从给定的 key 派生，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在为解密或密钥解包初始化时，将引发 InvalidKeyException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将从 random 获取这些随机字节。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
random - 随机源
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 Cipher；如果此 Cipher 为解密初始化，并且所需算法参数无法从给定的 key 确定；如果给定 key 的键大小超出所允许的最大值（由已配置的仲裁策略文件确定）。

init

public final void init(int opmode,
                       Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
用密钥和一组算法参数初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果此 Cipher 需要算法参数，而 params 为 null，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在为解密或密钥解包初始化时，将引发 InvalidAlgorithmParameterException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将使用具有最高优先级的已安装提供者的 SecureRandom 实现作为随机源来获取这些字节。（如果已安装的提供者都不提供 SecureRandom 实现，则将使用系统提供的随机源）。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
params - 算法参数
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 Cipher，或其它的键大小超出所允许的最大（由已配置的仲裁策略文件确定）。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此 Cipher；此 Cipher 为解密初始化，并且需要算法参数而 params 为 null；给定的算法参数所含的加密强度超出了合法限制（由已配置的仲裁策略文件确定）。

init

public final void init(int opmode,
                       Key key,
                       AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
用一个密钥、一组算法参数和一个随机源初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果此 Cipher 需要算法参数，而 params 为 null，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在为解密或密钥解包初始化时，将引发 InvalidAlgorithmParameterException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将从 random 获取这些随机字节。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
params - 算法参数
random - 随机源
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 Cipher，或其键大小超出所允许的最大值（由已配置的仲裁策略文件确定）。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此 Cipher；此 Cipher 为解密初始化，并且需要算法参数而 params 为 null；给定的算法参数所含的加密强度超出了合法限制（由已配置的仲裁策略文件确定）。

init

public final void init(int opmode,
                       Key key,
                       AlgorithmParameters params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
用密钥和一组算法参数初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果此 Cipher 需要算法参数，而 params 为 null，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在初始化为解密或密钥解包时，将引发 InvalidAlgorithmParameterException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将使用具有最高优先级的已安装提供者的 SecureRandom 实现作为随机源来获取这些字节。（如果已安装的提供者都不提供 SecureRandom 实现，则将使用系统提供的随机源）。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
params - 算法参数
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 Cipher，或其键大小超出所允许的最大值（由已配置的仲裁策略文件确定）。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此 Cipher；此 Cipher 为解密初始化，并且需要算法参数而 params 为 null；给定的算法参数所含的加密强度超出了合法限制（由已配置的仲裁策略文件确定）。

init

public final void init(int opmode,
                       Key key,
                       AlgorithmParameters params,
                       SecureRandom random)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
用一个密钥、一组算法参数和一个随机源初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果此 Cipher 需要算法参数，而 params 为 null，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在为解密或密钥解包初始化时，将引发 InvalidAlgorithmParameterException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将从 random 获取这些随机字节。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
params - 算法参数
random - 随机源
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 Cipher，或其键大小超出所允许的最大值（由已配置的仲裁策略文件确定）。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此 Cipher；此 Cipher 为解密初始化，并且需要算法参数而 params 为 null；给定的算法参数所含的加密强度超出了合法限制（由已配置的仲裁策略文件确定）。

init

public final void init(int opmode,
                       Certificate certificate)
                throws InvalidKeyException
用取自给定证书的公钥初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果证书类型为 X.509 并有一个标记为关键的 key usage 扩展字段，且此 key usage 扩展字段的值表示在 opmode 值所代表的操作中不应该使用该证书中的公钥及其相应的私钥，则抛出 InvalidKeyException。

如果此 Cipher 需要算法参数，而此参数无法从给定证书中的公钥派生，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在为解密或密钥解包初始化时，将引发 InvalidKeyException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将使用具有最高优先级的已安装提供者的 SecureRandom 实现作为随机源获取这些字节。（如果已安装的提供者都不提供 SecureRandom 实现，则将使用系统提供的随机源）。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
certificate - 证书
抛出：
InvalidKeyException - 如果给定证书中的公钥不适合初始化此 Cipher；此 Cipher 为解密或解包密钥初始化，并且所需算法参数无法通过给定证书的公钥确定；给定证书中公钥的键大小超出所允许的最大值（由已配置的仲裁策略文件确定）。

init

public final void init(int opmode,
                       Certificate certificate,
                       SecureRandom random)
                throws InvalidKeyException
用取自给定证书的公钥和随机源初始化此 Cipher。

为以下 4 种操作之一初始化该 Cipher：加密、解密、密钥包装或密钥解包，具体取决于 opmode 的值。

如果证书类型为 X.509 并有一个标记为关键的 key usage 扩展字段，且此 key usage 扩展字段的值表示在 opmode 值所代表的操作中不应该使用该证书中的公钥及其相应的私钥，则抛出 InvalidKeyException。

如果此 Cipher 需要算法参数，而此参数无法从给定 certificate 中的公钥派生，则在为加密或密钥包装初始化时，底层 Cipher 实现应自己生成所需的参数（使用特定于提供者的默认值或随机值）；在为解密或密钥解包初始化时，将引发 InvalidKeyException。可以用 getParameters 或 getIV 获取生成的参数（如果该参数为 IV）。

如果此 Cipher（包括其底层反馈或填充方案）需要随机字节（例如，用于参数生成），那么它将从 random 获取这些随机字节。

注意，初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 Cipher 的操作模式（为以下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
certificate - 证书
random - 随机源
抛出：
InvalidKeyException - 如果给定证书中的公钥不适合初始化此 Cipher；此 Cipher 为解密或解包密钥初始化，并且所需算法参数无法通过给定证书的公钥确定；给定证书中公钥的键大小超出所允许的最大值（由已配置的仲裁策略文件确定）。

update

public final byte[] update(byte[] input)
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

处理 input 缓冲区中的字节，并将结果存储在新的缓冲区中。

如果 input 长度为 0，则此方法返回 null。

参数：
input - 输入缓冲区
返回：
包含结果的新缓冲区；如果底层 Cipher 为 Cipher 块并且输入数据太短而无法形成新的块，则返回 null。
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）

update

public final byte[] update(byte[] input,
                           int inputOffset,
                           int inputLen)
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，并将结果存储在新的缓冲区中。

如果 inputLen 为 0，则此方法返回 null。

参数：
input - 输入缓冲区
inputOffset - input 中输入起始处的偏移量
inputLen - 输入长度
返回：
包含结果的新缓冲区；如果底层 Cipher 为 Cipher 块并且输入数据太短而无法形成新的块，则返回 null。
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）

update

public final int update(byte[] input,
                        int inputOffset,
                        int inputLen,
                        byte[] output)
                 throws ShortBufferException
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，并将结果存储在 output 缓冲区中。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

如果 inputLen 为 0，则此方法返回的长度为 0。

注：此方法应该是复制安全 (copy-safe) 的，这意味着 input 和 output 缓冲区可引用相同的 byte 数组，并且在将结果复制到输出缓冲区时，不会覆盖任何未处理的输入数据。

参数：
input - 输入缓冲区
inputOffset - input 中输入起始处的偏移量
inputLen - 输入长度
output - 保存结果的缓冲区
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
ShortBufferException - 如果给定的输出缓冲区太小而无法保存结果

update

public final int update(byte[] input,
                        int inputOffset,
                        int inputLen,
                        byte[] output,
                        int outputOffset)
                 throws ShortBufferException
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，并将结果存储在 output 缓冲区中从 outputOffset 开始（包含）的位置。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

如果 inputLen 为 0，则此方法返回的长度为 0。

注：此方法应该是复制安全的，这意味着 input 和 output 缓冲区可引用相同的 byte 数组，并且在将结果复制到输出缓冲区时，不会覆盖任何未处理的输入数据。

参数：
input - 输入缓冲区
inputOffset - input 中输入起始处的偏移量
inputLen - 输入长度
output - 保存结果的缓冲区
outputOffset - output 中存储结果处的偏移量
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
ShortBufferException - 如果给定的输出缓冲区太小而无法保存结果

update

public final int update(ByteBuffer input,
                        ByteBuffer output)
                 throws ShortBufferException
继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

处理从 input.position() 开始的所有 input.remaining() 个字节。将结果存储在输出缓冲区中。返回时，输入缓冲区的位置将等于其限制；其限制不变。输出缓冲区的位置将前移 n，其中 n 为此方法返回的值；输出缓冲区的限制不变。

如果 output.remaining() 个字节还不够保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

注：此方法应该是复制安全的，这意味着 input 和 output 缓冲区可引用相同的内存块，并且在将结果复制到输出缓冲区时，不会覆盖任何未处理的输入数据。

参数：
input - 输入 ByteBuffer
output - 输出 ByteBuffer
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalArgumentException - 如果输入和输出为相同的对象
ReadOnlyBufferException - 如果输出缓冲区为只读
ShortBufferException - 如果输出缓冲区中没有足够的空间
从以下版本开始：
1.5

doFinal

public final byte[] doFinal()
                     throws IllegalBlockSizeException,
                            BadPaddingException
结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。

处理在上一次 update 操作中缓存的输入数据，其中应用了填充（如果请求）。结果将存储在新缓冲区中。

结束时，此方法将此 Cipher 对象重置为上一次调用 init 初始化得到的状态。即该对象被重置，并可用于加密或解密（具体取决于调用 init 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 Cipher 对象前需要将其重置。

返回：
包含结果的新缓冲区
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求任何填充（只针对加密模式），并且由此 Cipher 处理的数据总输入长度不是块大小的倍数；如果此加密算法无法处理所提供的输入数据。
BadPaddingException - 如果此 Cipher 为解密模式，并且未请求填充（或不填充），但解密的数据没有用适当的填充字节进行限制

doFinal

public final int doFinal(byte[] output,
                         int outputOffset)
                  throws IllegalBlockSizeException,
                         ShortBufferException,
                         BadPaddingException
结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。

处理在上一次 update 操作中缓存的输入数据，其中应用了填充（如果请求）。结果存储在 output 缓冲区中从 outputOffset（包含）开始的位置。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

结束时，此方法将此 Cipher 对象重置为上一次调用 init 初始化得到的状态。即该对象被重置，并可用于加密或解密（具体取决于调用 init 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 Cipher 对象前需要将其重置。

参数：
output - 用于保存结果的缓冲区
outputOffset - output 中保存结果处的偏移量
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求任何填充（只针对加密模式），并且由此 Cipher 处理的数据总输入长度不是块大小的倍数；如果此加密算法无法处理所提供的输入数据。
ShortBufferException - 如果给定的输出缓冲区太小无法保存结果
BadPaddingException - 如果 Cipher 为解密模式，并且未请求填充（或不填充），但解密的数据没有用适当的填充字节进行限制

doFinal

public final byte[] doFinal(byte[] input)
                     throws IllegalBlockSizeException,
                            BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据将被加密或解密（具体取决于此 Cipher 的初始化方式）。

处理 input 缓冲区中的字节以及在上一次 update 操作中缓存的任何输入字节，其中应用了填充（如果请求）。结果将存储在新缓冲区中。

结束时，此方法将此 Cipher 对象重置为上一次调用 init 初始化得到的状态。即该对象被重置，并可用于加密或解密（具体取决于调用 init 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 Cipher 对象前需要将其重置。

参数：
input - 输入缓冲区
返回：
包含结果的新缓冲区
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求任何填充（只针对加密模式），并且由此 Cipher 处理的数据总输入长度不是块大小的倍数；如果此加密算法无法处理所提供的输入数据。
BadPaddingException - 如果此 Cipher 为解密模式，并且未请求填充（或不填充），但解密的数据没有用适当的填充字节进行限制

doFinal

public final byte[] doFinal(byte[] input,
                            int inputOffset,
                            int inputLen)
                     throws IllegalBlockSizeException,
                            BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据将被加密或解密（具体取决于此 Cipher 的初始化方式）。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，以及在上一次 update 操作过程中缓存的任何输入字节，其中应用了填充（如果需要）。结果将存储在新缓冲区中。

结束时，此方法将此 Cipher 对象重置为上一次调用 init 初始化得到的状态。即该对象被重置，并可用于加密或解密（具体取决于调用 init 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 Cipher 对象前需要将其重置。

参数：
input - 输入缓冲区
inputOffset - input 中输入起始处的偏移量
inputLen - 输入长度
返回：
包含结果的新缓冲区
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求任何填充（只针对加密模式），并且由此 Cipher 处理的数据总输入长度不是块大小的倍数；如果此加密算法无法处理所提供的输入数据。
BadPaddingException - 如果此 Cipher 为解密模式，并且未请求填充（或不填充），但解密的数据没有用适当的填充字节进行限制

doFinal

public final int doFinal(byte[] input,
                         int inputOffset,
                         int inputLen,
                         byte[] output)
                  throws ShortBufferException,
                         IllegalBlockSizeException,
                         BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据将被加密或解密（具体取决于此 Cipher 的初始化方式）。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，以及在上一次 update 操作过程中缓存的任何输入字节，其中应用了填充（如果需要）。结果将存储在 output 缓冲区中。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

结束时，此方法将此 Cipher 对象重置为上一次调用 init 初始化得到的状态。即该对象被重置，并可用于加密或解密（具体取决于调用 init 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 Cipher 对象前需要将其重置。

注：此方法应该是复制安全的，这意味着 input 和 output 缓冲区可引用相同的 byte 数组，并且在将结果复制到输出缓冲区时，不会覆盖任何未处理的输入数据。

参数：
input - 输入缓冲区
inputOffset - input 中输入起始处的偏移量
inputLen - 输入长度
output - 保存结果的缓冲区
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求任何填充（只针对加密模式），并且由此 Cipher 处理的数据总输入长度不是块大小的倍数；如果此加密算法无法处理所提供的输入数据。
ShortBufferException - 如果给定的输出缓冲区太小无法保存结果
BadPaddingException - 如果 Cipher 为解密模式，并且未请求填充（或不填充），但解密的数据没有用适当的填充字节进行限制

doFinal

public final int doFinal(byte[] input,
                         int inputOffset,
                         int inputLen,
                         byte[] output,
                         int outputOffset)
                  throws ShortBufferException,
                         IllegalBlockSizeException,
                         BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据将被加密或解密（具体取决于此 Cipher 的初始化方式）。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，以及在上一次 update 操作过程中缓存的任何输入字节，其中应用了填充（如果需要）。结果将存储在 output 缓冲区中从 outputOffset（包含）开始的位置。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

结束时，此方法将此 Cipher 对象重置为上一次调用 init 初始化得到的状态。即该对象被重置，并可用于加密或解密（具体取决于调用 init 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 Cipher 对象前需要将其重置。

注：此方法应该是复制安全的，这意味着 input 和 output 缓冲区可引用相同的 byte 数组，并且在将结果复制到输出缓冲区时，不会覆盖任何未处理的输入数据。

参数：
input - 输入缓冲区
inputOffset - input 中输入起始处的偏移量
inputLen - 输入长度
output - 保存结果的缓冲区
outputOffset - output 中存储结果处的偏移量
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求任何填充（只针对加密模式），并且由此 Cipher 处理的数据总输入长度不是块大小的倍数；如果此加密算法无法处理所提供的输入数据。
ShortBufferException - 如果给定的输出缓冲区太小无法保存结果
BadPaddingException - 如果 Cipher 为解密模式，并且未请求填充（或不填充），但解密的数据没有用适当的填充字节进行限制

doFinal

public final int doFinal(ByteBuffer input,
                         ByteBuffer output)
                  throws ShortBufferException,
                         IllegalBlockSizeException,
                         BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据将被加密或解密（具体取决于此 Cipher 的初始化方式）。

处理从 input.position() 开始的所有 input.remaining() 个字节。结果将存储在输出缓冲区中。返回时，输入缓冲区的位置将等于其限制；其限制不变。输出缓冲区的位置将前移 n，其中 n 为此方法返回的值；输出缓冲区的限制不变。

如果 output.remaining() 个字节还不够保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

结束时，此方法将此 Cipher 对象重置为上一次调用 init 初始化得到的状态。即该对象被重置，并可用于加密或解密（具体取决于调用 init 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 Cipher 对象前需要将其重置。

注：此方法应该是复制安全的，这意味着 input 和 output 缓冲区可引用相同的 byte 数组，并且在将结果复制到输出缓冲区时，不会覆盖任何未处理的输入数据。

参数：
input - 输入 ByteBuffer
output - 输出 ByteBuffer
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalArgumentException - 如果输入和输出为相同的对象
ReadOnlyBufferException - 如果输出缓冲区为只读
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求任何填充（只针对加密模式），并且由此 Cipher 处理的数据总输入长度不是块大小的倍数；如果此加密算法无法处理所提供的输入数据。
ShortBufferException - 如果输出缓冲区没有足够的空间
BadPaddingException - 如果 Cipher 为解密模式，并且未请求填充（或不填充），但解密的数据没有用适当的填充字节进行限制
从以下版本开始：
1.5

wrap

public final byte[] wrap(Key key)
                  throws IllegalBlockSizeException,
                         InvalidKeyException
包装密钥。

参数：
key - 要包装的密钥。
返回：
已包装的密钥。
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
IllegalBlockSizeException - 如果此 Cipher 为 Cipher 块，未请求填充，并且要包装的密钥的编码长度不是块大小的倍数。
InvalidKeyException - 如果不能用此 Cipher 包装该密钥，或者这样做不安全（例如，将一个硬件保护的密钥传给只能用于软件保护的 Cipher）。

unwrap

public final Key unwrap(byte[] wrappedKey,
                        String wrappedKeyAlgorithm,
                        int wrappedKeyType)
                 throws InvalidKeyException,
                        NoSuchAlgorithmException
解包一个以前包装的密钥。

参数：
wrappedKey - 要解包的密钥。
wrappedKeyAlgorithm - 与此包装密钥关联的算法。
wrappedKeyType - 已包装密钥的类型。此类型必须为 SECRET_KEY、PRIVATE_KEY 或 PUBLIC_KEY 之一。
返回：
解包的密钥。
抛出：
IllegalStateException - 如果此 Cipher 处于错误状态（例如，尚未初始化）
NoSuchAlgorithmException - 如果没有一个已安装的提供者能够针对 wrappedKeyAlgorithm 创建类型为 wrappedKeyType 的密钥。
InvalidKeyException - 如果 wrappedKey 不表示针对 wrappedKeyAlgorithm 的类型为 wrappedKeyType 的已包装密钥。

getMaxAllowedKeyLength

public static final int getMaxAllowedKeyLength(String transformation)
                                        throws NoSuchAlgorithmException
根据所安装的 JCE 仲裁策略文件，返回指定转换的最大密钥长度。如果安装了 JCE 无限制强度仲裁策略文件，则返回 Integer.MAX_VALUE。有关 JCE 仲裁策略文件中的默认密钥大小的更多信息，请参见 Java Cryptography Architecture Reference Guide 中的附录 E。

参数：
transformation - Cipher 转换。
返回：
最大密钥长度（以位为单位） 或 Integer.MAX_VALUE。
抛出：
NullPointerException - 如果 transformation 为 null。
NoSuchAlgorithmException - 如果 transformation 不是有效的转换，即格式不为“算法”或“算法/模式/填充”。
从以下版本开始：
1.5

getMaxAllowedParameterSpec

public static final AlgorithmParameterSpec getMaxAllowedParameterSpec(String transformation)
                                                               throws NoSuchAlgorithmException
根据仲裁策略文件，返回包含最大 Cipher 参数值的 AlgorithmParameterSpec 对象。如果安装了 JCE 无限制强度仲裁策略文件，或者策略文件中对用于指定转换的参数没有最大限制，则返回 null。

参数：
transformation - Cipher 转换。
返回：
保存最大值的 AlgorithmParameterSpec，或者返回 null。
抛出：
NullPointerException - 如果 transformation 为 null。
NoSuchAlgorithmException - 如果 transformation 不是有效的转换，即格式不为“算法”或“算法/模式/填充”。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CipherInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 CipherInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  javax.crypto.CipherInputStream
所有已实现的接口：
Closeable
public class CipherInputStream
extends FilterInputStream

CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。在由 CipherInputStream 使用之前，该 Cipher 必须充分初始化。

例如，假设 Cipher 初始化为解密，在返回解密的数据之前，CipherInputStream 将尝试读入数据并将其解密。

此类严格遵守此语义，尤其是其祖先类 java.io.FilterInputStream 和 java.io.InputStream 的失败语义。此类具有在其祖先类中指定的所有方法，并且对所有的这些方法进行了重写。除此之外，此类还对其祖先类未抛出的所有异常进行捕获。特别地，skip 方法跳过，available 方法只计算已由封装的 Cipher 处理过的数据。

对程序员非常重要的一点是，请不要使用未在此类中定义或重写的方法（例如，后来加入到其超类之一中的新方法或构造方法），因为那些方法的设计和实现可能未考虑到对 CipherInputStream 的安全影响。

从以下版本开始：
1.4
另请参见：
InputStream, FilterInputStream, Cipher, CipherOutputStream

字段摘要
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
protected | CipherInputStream(InputStream is) 根据 InputStream 构造 CipherInputStream，不指定 Cipher。
 | CipherInputStream(InputStream is, Cipher c) 根据 InputStream 和 Cipher 构造 CipherInputStream。
方法摘要
int | available() 返回不发生阻塞地从此输入流读取的字节数。
void | close() 关闭该输入流并释放任何与该流关联的系统资源。
boolean | markSupported() 测试该输入流是否支持 mark 和 reset 方法以及哪一个方法确实不受支持。
int | read() 从该输入流读取下一数据字节。
int | read(byte[] b) 从该输入流将 b.length 个数据字节读入到字节数组中。
int | read(byte[] b, int off, int len) 从该输入流将 len 个字节数据读入到字节数组中。
long | skip(long n) 跳过不发生阻塞地从该输入流读取的字节中的 n 个字节的输入。
从类 java.io.FilterInputStream 继承的方法
mark, reset
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CipherInputStream

public CipherInputStream(InputStream is,
                         Cipher c)
根据 InputStream 和 Cipher 构造 CipherInputStream。
注：如果指定的输入流或密码为 null，则在后续使用输出流或密码时可能抛出 NullPointerException 异常。

参数：
is - 将被处理的输入流
c - 已初始化的 Cipher 对象

CipherInputStream

protected CipherInputStream(InputStream is)
根据 InputStream 构造 CipherInputStream，不指定 Cipher。它与使用 NullCipher 构造 CipherInputStream 具有相同的效果。
注：如果指定的输入流为 null，则在后续使用输出流时可能抛出 NullPointerException 异常。

参数：
is - 将被处理的输入流
方法详细信息

read

public int read()
         throws IOException
从该输入流读取下一数据字节。返回一个 0 到 255 范围内的 int 字节值。如果因为到达流末尾而没有可用的字节，则返回值 -1。在输入数据可用、检测到流末尾或抛出异常之前，此方法将一直阻塞。

覆盖：
类 FilterInputStream 中的 read
返回：
下一个数据字节；如果已到达流末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
FilterInputStream.in

read

public int read(byte[] b)
         throws IOException
从该输入流将 b.length 个数据字节读入到字节数组中。

InputStream 的 read 方法将 b、0 和 b.length 作为三个参数来调用 read 方法。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 存储读入数据的缓冲区。
返回：
读入缓冲区的总字节数，如果由于流末尾已到达而不再有数据，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
InputStream.read(byte[], int, int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从该输入流将 len 个字节数据读入到字节数组中。在某些输入可用之前，此方法将阻塞。如果第一个参数为 null，则读取和丢弃的字节数最多为 len 个。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 存储读入数据的缓冲区。
off - 目标数组 buf 中的起始偏移量
len - 读取的最大字节数。
返回：
读入缓冲区的总字节数，如果由于已到达流末尾而不再有数据，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
InputStream.read()

skip

public long skip(long n)
          throws IOException
跳过不发生阻塞地从该输入流读取的字节中的 n 个字节的输入。

可能跳过比请求更少的字节数。实际跳过的字节数等于 n 或等于调用 available 的结果，总之都较小。如果 n 为小于零，则不跳过任何字节。

返回实际跳过的字节数。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
实际跳过的字节数。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2

available

public int available()
              throws IOException
返回不发生阻塞地从此输入流读取的字节数。InputStream 的 markSupported 方法返回 false。此方法应该由子类重写。

覆盖：
类 FilterInputStream 中的 available
返回：
不发生阻塞地从此输入流读取的字节数。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2

close

public void close()
           throws IOException
关闭该输入流并释放任何与该流关联的系统资源。

CipherInputStream 的 close 方法调用底层输入流的 close 方法。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
FilterInputStream.in

markSupported

public boolean markSupported()
测试该输入流是否支持 mark 和 reset 方法以及哪一个方法确实不受支持。

覆盖：
类 FilterInputStream 中的 markSupported
返回：
因为此类不支持 mark 和 reset 方法，所以返回 false。
从以下版本开始：
JCE1.2
另请参见：
InputStream.mark(int), InputStream.reset()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CipherOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 CipherOutputStream

java.lang.Object
    继承者  java.io.OutputStream
        继承者  java.io.FilterOutputStream
            继承者  javax.crypto.CipherOutputStream
所有已实现的接口：
Closeable, Flushable
public class CipherOutputStream
extends FilterOutputStream

CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。在由 CipherOutputStream 使用之前，密码必须充分初始化。

例如，假设密码初始化为加密，CipherOutputStream 将在写出该加密数据之前，尝试加密数据。

此类严格遵守此语义，尤其是其祖先类 java.io.OutputStream 和 java.io.FilterOutputStream 的失败语义。此类具有在其祖先类中指定的所有方法，并且对所有的这些方法进行了重写。除此之外，此类还对其祖先类未抛出的所有异常进行捕获。

对程序员非常重要的一点是，不要使用未在此类中定义或重写的方法（例如，后来加入到某个超类的新方法或构造方法），因为那些方法的设计和实现有可能未考虑到对 CipherOutputStream 的安全影响。

从以下版本开始：
1.4
另请参见：
OutputStream, FilterOutputStream, Cipher, CipherInputStream

字段摘要
从类 java.io.FilterOutputStream 继承的字段
out
构造方法摘要
protected | CipherOutputStream(OutputStream os) 从 OutputStream 构造 CipherOutputStream，不指定 Cipher。
 | CipherOutputStream(OutputStream os, Cipher c) 从 OutputStream 和 Cipher 构造 CipherOutputStream。
方法摘要
void | close() 关闭此输出流并释放任何与此流关联的系统资源。
void | flush() 强制写出已由封装的密码对象处理的任何缓存输出字节来刷新此输出流。
void | write(byte[] b) 从指定的字节数组中将 b.length 个字节写入此输出流。
void | write(byte[] b, int off, int len) 将指定的字节数组中从 off 偏移量开始的 len 个字节写入此输出流。
void | write(int b) 将指定的字节写入此输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CipherOutputStream

public CipherOutputStream(OutputStream os,
                          Cipher c)
从 OutputStream 和 Cipher 构造 CipherOutputStream。
注：如果指定的输出流或密码为 null，则在后续使用输出流或密码时可能抛出 NullPointerException 异常。

参数：
os - OutputStream 对象
c - 已初始化的 Cipher 对象

CipherOutputStream

protected CipherOutputStream(OutputStream os)
从 OutputStream 构造 CipherOutputStream，不指定 Cipher。这与使用 NullCipher 构造 CipherOutputStream 具有相同的效果。
注：如果指定的输出流为 null，则在后续使用输出流时可能抛出 NullPointerException 异常。

参数：
os - OutputStream 对象
方法详细信息

write

public void write(int b)
           throws IOException
将指定的字节写入此输出流。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - byte。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2

write

public void write(byte[] b)
           throws IOException
从指定的字节数组中将 b.length 个字节写入此输出流。

CipherOutputStream 的 write 方法调用带三个参数的 write 方法，三个参数为 b、0 和 b.length。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 数据。
抛出：
NullPointerException - 如果 b 为 null。
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
write(byte[], int, int)

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
将指定的字节数组中从 off 偏移量开始的 len 个字节写入此输出流。

覆盖：
类 FilterOutputStream 中的 write
参数：
b - 数据。
off - 数据中的初始偏移量。
len - 要写入的字节数。
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
FilterOutputStream.write(int)

flush

public void flush()
           throws IOException
强制写出已由封装的密码对象处理的任何缓存输出字节来刷新此输出流。

由封装的密码缓存并等待由其处理的任何字节将不被写出。例如，假设封装的密码为块密码，并且使用某个 write 方法写入的总字节数小于密码的块大小，将不写出任何字节。

指定者：
接口 Flushable 中的 flush
覆盖：
类 FilterOutputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
FilterOutputStream.out

close

public void close()
           throws IOException
关闭此输出流并释放任何与此流关联的系统资源。

此方法调用封装密码对象的 doFinal 方法，它使得由该封装密码缓存的任何字节都被处理。通过调用此输出流的 flush 方法写出结果。

此方法将封装密码对象重置为其初始状态并调用底层输出流的 close 方法。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterOutputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
从以下版本开始：
JCE1.2
另请参见：
FilterOutputStream.flush(), FilterOutputStream.out
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CipherSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 CipherSpi

java.lang.Object
    继承者  javax.crypto.CipherSpi

public abstract class CipherSpi
extends Object

此类为 Cipher 类定义了服务提供者接口 (SPI)。此类中的所有抽象方法都必须由每个想要提供实现特定 cipher 算法的加密服务提供者实现。

为创建封装了此 CipherSpi 类实例的 Cipher 实例，应用程序调用 Cipher 引擎类的 getInstance 工厂方法之一并指定请求的转换。作为可选项，应用程序还可以指定提供者的名称。

转换 是描述为产生某种输出而在给定的输入上执行的操作（或一组操作）的字符串。转换始终包括加密算法的名称（例如，DES），后面可能跟有一个反馈模式和填充方案。

转换具有下面的形式：

  • "算法/模式/填充”或

  • "算法”

（后一种情况下，使用此模式和填充方案的特定于提供者的默认值）。例如，以下是有效的转换：

     Cipher c = Cipher.getInstance("DES/CBC/PKCS5Padding");

一个提供者可能为每个算法/模式/填充 组合提供一个单独的类，也有可能决定提供多个表示与算法 或算法/模式 或算法//填充 （注意，是双斜线）对应的子转换的一般类，在这种情况下，请求的模式和/或填充由 Cipher 的 getInstance 方法自动设置，它调用的是提供者的 CipherSpi 子类的 engineSetMode 和 engineSetPadding 方法。

提供者主类中的 Cipher 属性可能具有以下格式之一：

  •      // provider's subclass of "CipherSpi" implements "algName" with
     // pluggable mode and padding
     Cipher.algName

  •      // provider's subclass of "CipherSpi" implements "algName" in the
     // specified "mode", with pluggable padding
     Cipher.algName/mode

  •      // provider's subclass of "CipherSpi" implements "algName" with the
     // specified "padding", with pluggable mode
     Cipher.algName//padding

  •      // provider's subclass of "CipherSpi" implements "algName" with the
     // specified "mode" and "padding"
     Cipher.algName/mode/padding

例如，某提供者可能提供实现 DES/ECB/PKCS5Padding 的 CipherSpi 子类，以及实现 DES/CBC/PKCS5Padding、DES/CFB/PKCS5Padding 和 DES/OFB/PKCS5Padding 的 CipherSpi 子类。该提供者在其主类中将有以下 Cipher 属性：

  •      Cipher.DES/ECB/PKCS5Padding

  •      Cipher.DES/CBC/PKCS5Padding

  •      Cipher.DES/CFB/PKCS5Padding

  •      Cipher.DES/OFB/PKCS5Padding

另一个提供者可能实现一个用于以上每个模式的类（即一个用于 ECB 的类、一个用于 CBC 的类、一个用于 CFB 的类及一个用于 OFB 的类），一个用于 PKCS5Padding 的类，以及一个通过子类化 CipherSpi 所得到的通用 DES 类。该提供者在其主类中将有以下 Cipher 属性：

  •      Cipher.DES

Cipher 引擎类的 getInstance 工厂方法遵守这些规则，以便为“算法”形式的转换实例化提供者的 CipherSpi 实现：

  1. 检查提供者是否已为指定的“算法”注册了一个 CipherSpi 子类。

    如果已经注册，则实例化此类，使用其模式和填充方案的默认值（由提供者给出）。

    如果未注册，则抛出 NoSuchAlgorithmException。

Cipher 引擎类的 getInstance 工厂方法遵守这些规则，以便为“算法/模式/填充”形式的转换实例化提供者的 CipherSpi 实现：

  1. 检查提供者是否已为指定的“算法/模式/填充”转换注册了一个 CipherSpi 子类。

    如果已注册，则将其实例化。

    如果未注册，则转到下一步。

  2. 检查提供者是否已为“算法/模式”子转换注册了一个 CipherSpi 子类。

    如果已注册，则将其实例化，并在新实例上调用 engineSetPadding(padding)。

    如果未注册，则转到下一步。

  3. 检查提供者是否已为“算法//填充”子转换注册了一个 CipherSpi 子类(注意，是双斜线的)。

    如果已注册，则将其实例化，并在新实例上调用 engineSetMode(mode)。

    如果未注册，则转到下一步。

  4. 检查提供者是否已为“算法”子转换注册了一个 CipherSpi 子类。

    如果已注册，则将其实例化，并在新实例上调用 engineSetMode(mode) 和 engineSetPadding(padding)。

    如果未注册，则抛出 NoSuchAlgorithmException。

从以下版本开始：
1.4
另请参见：
KeyGenerator, SecretKey

构造方法摘要
CipherSpi()
方法摘要
protected abstract byte[] | engineDoFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | engineDoFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected int | engineDoFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | engineGetBlockSize() 返回块的大小（以字节为单位）。
protected abstract byte[] | engineGetIV() 返回新缓冲区中的初始化向量 (IV)。
protected int | engineGetKeySize(Key key) 返回给定密钥对象的密钥大小，以位为单位。
protected abstract int | engineGetOutputSize(int inputLen) 在给定了输入长度 inputLen（以字节为单位）的情况下，返回用于保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度的字节数。
protected abstract AlgorithmParameters | engineGetParameters() 返回此 cipher 使用的参数。
protected abstract void | engineInit(int opmode, Key key, AlgorithmParameterSpec params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | engineInit(int opmode, Key key, AlgorithmParameters params, SecureRandom random) 用一个密钥、一组算法参数和一个随机源初始化此 cipher。
protected abstract void | engineInit(int opmode, Key key, SecureRandom random) 用密钥和随机源初始化此 cipher。
protected abstract void | engineSetMode(String mode) 设置此 cipher 的模式。
protected abstract void | engineSetPadding(String padding) 设置此 cipher 的填充机制。
protected Key | engineUnwrap(byte[] wrappedKey, String wrappedKeyAlgorithm, int wrappedKeyType) 打开一个以前包装的密钥。
protected abstract byte[] | engineUpdate(byte[] input, int inputOffset, int inputLen) 继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
protected abstract int | engineUpdate(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
protected int | engineUpdate(ByteBuffer input, ByteBuffer output) 继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
protected byte[] | engineWrap(Key key) 将密钥包装。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CipherSpi

public CipherSpi()
方法详细信息

engineSetMode

protected abstract void engineSetMode(String mode)
                               throws NoSuchAlgorithmException
设置此 cipher 的模式。

参数：
mode - cipher 模式
抛出：
NoSuchAlgorithmException - 如果请求的 cipher 模式不存在

engineSetPadding

protected abstract void engineSetPadding(String padding)
                                  throws NoSuchPaddingException
设置此 cipher 的填充机制。

参数：
padding - 填充机制
抛出：
NoSuchPaddingException - 如果请求的填充机制不存在

engineGetBlockSize

protected abstract int engineGetBlockSize()
返回块的大小（以字节为单位）。

返回：
块的大小（以字节为单位），如果底层算法不是块 cipher，则返回 0

engineGetOutputSize

protected abstract int engineGetOutputSize(int inputLen)
在给定了输入长度 inputLen（以字节为单位）的情况下，返回用于保存下一个 update 或 doFinal 操作结果所需的输出缓冲区长度的字节数。

此调用还考虑到来自上一个 update 调用的任何未处理（已缓存）的数据和填充。

下一个 update 或 doFinal 调用的实际输出长度可能小于此方法返回的长度。

参数：
inputLen - 输入长度（以字节为单位）
返回：
所需的输出缓冲区大小（以字节为单位）

engineGetIV

protected abstract byte[] engineGetIV()
返回新缓冲区中的初始化向量 (IV)。

此方法在基于密码的加密或解密上下文中很有用，此时 IV 派生自用户提供的 passphrase。

返回：
新缓冲区中的初始化向量，如果底层算法不使用 IV，或 IV 尚未设置，则返回 null。

engineGetParameters

protected abstract AlgorithmParameters engineGetParameters()
返回此 cipher 使用的参数。

返回的参数可能与初始化此 cipher 所使用的参数相同；如果此 cipher 要求使用算法参数但却未使用任何参数进行初始化，则返回的参数可能会包含由默认值和底层 cipher 实现所使用的随机参数值的组合。

返回：
此 cipher 使用的参数，如果此 cipher 不使用任何参数，则返回 null。

engineInit

protected abstract void engineInit(int opmode,
                                   Key key,
                                   SecureRandom random)
                            throws InvalidKeyException
用密钥和随机源初始化此 cipher。

为以下 4 种操作之一初始化该 cipher：加密、解密、密钥包装或密钥打开，这取决于 opmode 的值。

如果此 cipher 要求使用任何算法参数，而此参数又无法从给定的 key 派生，则在被初始化为加密或密钥包装时，底层 cipher 实现将会自己生成所需的参数（使用特定于提供者的默认或随机值）；在初始化为解密或密钥打开时，将引发 InvalidKeyException。可以用 engineGetParameters 或 engineGetIV 获取生成的参数（如果该参数为 IV）。

如果此 cipher（包括其底层反馈或填充方案）要求使用任何随机字节（例如，用于参数生成），那么它将从 random 获取这些随机字节。

注意，当初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 cipher 的操作模式（其为如下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
random - 随机源
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 cipher，如果要将此 cipher 初始化为解密，并且它所要求的算法参数无法从给定的 key 确定。

engineInit

protected abstract void engineInit(int opmode,
                                   Key key,
                                   AlgorithmParameterSpec params,
                                   SecureRandom random)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
用一个密钥、一组算法参数和一个随机源初始化此 cipher。

为以下 4 种操作之一初始化该 cipher：加密、解密、密钥包装或密钥打开，这取决于 opmode 的值。

如果此 cipher 要求使用任何算法参数，而 params 为 null，则在被初始化为加密或密钥包装时，底层 cipher 实现将会自己生成所需的参数（使用特定于提供者的默认或随机值）；在初始化为解密或密钥打开时，将引发 InvalidAlgorithmParameterException。可以用 engineGetParameters 或 engineGetIV 获取生成的参数（如果该参数为 IV）。

如果此 cipher（包括其底层反馈或填充方案）要求使用任何随机字节（例如，用于参数生成），那么它将从 random 获取这些随机字节。

注意，当初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 cipher 的操作模式（其为如下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
params - 算法参数
random - 随机源
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 cipher
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此 cipher，如果要将此 cipher 初始化为解密，并且要求使用算法参数，而 params 为 null。

engineInit

protected abstract void engineInit(int opmode,
                                   Key key,
                                   AlgorithmParameters params,
                                   SecureRandom random)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
用一个密钥、一组算法参数和一个随机源初始化此 cipher。

为以下 4 种操作之一初始化该 cipher：加密、解密、密钥包装或密钥打开，这取决于 opmode 的值。

如果此 cipher 要求使用任何算法参数，而 params 为 null，则在被初始化为加密或密钥包装时，底层 cipher 实现将会自己生成所需的参数（使用特定于提供者的默认或随机值）；在初始化为解密或密钥打开时，将引发 InvalidAlgorithmParameterException。可以用 engineGetParameters 或 engineGetIV 获取生成的参数（如果该参数为 IV）。

如果此 cipher（包括其底层反馈或填充方案）要求使用任何随机字节（例如，用于参数生成），那么它将从 random 获取这些随机字节。

注意，当初始化 Cipher 对象时，它将失去所有以前获得的状态。换句话说，初始化 Cipher 相当于创建该 Cipher 的一个新实例并将其初始化。

参数：
opmode - 此 cipher 的操作模式（其为如下之一：ENCRYPT_MODE、DECRYPT_MODE、WRAP_MODE 或 UNWRAP_MODE）
key - 加密密钥
params - 算法参数
random - 随机源
抛出：
InvalidKeyException - 如果给定的 key 不适合初始化此 cipher
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此 cipher，如果要将此 cipher 初始化为解密，并且要求使用算法参数，而 params 为 null。

engineUpdate

protected abstract byte[] engineUpdate(byte[] input,
                                       int inputOffset,
                                       int inputLen)
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，并将结果存储在新的缓冲区中。

参数：
input - 输入缓冲区
inputOffset - input 中输入开始位置的偏移量
inputLen - 输入长度
返回：
包含结果的新缓冲区，如果底层 cipher 为块 cipher 并且输入数据太短而无法形成新的块时，则返回 null。

engineUpdate

protected abstract int engineUpdate(byte[] input,
                                    int inputOffset,
                                    int inputLen,
                                    byte[] output,
                                    int outputOffset)
                             throws ShortBufferException
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节，并将结果存储在 output 缓冲区中从 outputOffset 开始（包含）的位置。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。

参数：
input - 输入缓冲区
inputOffset - input 中输入开始位置的偏移量
inputLen - 输入长度
output - 保存结果的缓冲区
outputOffset - output 中存储结果的位置的偏移量
返回：
output 中存储的字节数
抛出：
ShortBufferException - 如果给定的输出缓冲区太小无法保存该结果

engineUpdate

protected int engineUpdate(ByteBuffer input,
                           ByteBuffer output)
                    throws ShortBufferException
继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。

处理从 input.position() 开始的所有 input.remaining() 字节。结果存储在输出缓冲区中。返回时，输入缓冲区的位置将等于其限制；其限制并未改变。输出缓冲区的位置将前移 n，其中 n 为此方法返回的值；输出缓冲区的限制并未改变。

如果 output.remaining() 个字节还不够保存该结果，则抛出 ShortBufferException。

如果能够比 byte 数组更有效地处理 ByteBuffer，子类应考虑重写此方法。

参数：
input - 输入 ByteBuffer
output - 输出 ByteBuffer
返回：
output 中存储的字节数
抛出：
ShortBufferException - 如果输出缓冲区中没有足够的空间
NullPointerException - 如果任一参数为 null
从以下版本开始：
1.5

engineDoFinal

protected abstract byte[] engineDoFinal(byte[] input,
                                        int inputOffset,
                                        int inputLen)
                                 throws IllegalBlockSizeException,
                                        BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据被加密还是解密取决于此 cipher 的初始化方式。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节以及可能在上一次 update 操作过程中已缓存的任何输入字节，其中应用了填充（如果需要）。结果存储在新缓冲区中。

结束时，此方法将把此 cipher 对象重置为上一次调用 engineInit 初始化得到的状态。即重置该对象，可供加密或解密（取决于调用 engineInit 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 cipher 对象前，可能需要将其重置。

参数：
input - 输入缓冲区
inputOffset - input 中输入开始位置的偏移量
inputLen - 输入长度
返回：
存储结果的新缓冲区
抛出：
IllegalBlockSizeException - 如果此 cipher 为块 cipher，未请求任何填充（只针对加密模式），并且由此 cipher 处理的数据总输入长度不是块大小的倍数，如果此加密算法无法处理所提供的输入数据。
BadPaddingException - 如果此 cipher 为解密模式，并且未请求填充或不填充，但解密的数据没有用适当的填充字节所限制

engineDoFinal

protected abstract int engineDoFinal(byte[] input,
                                     int inputOffset,
                                     int inputLen,
                                     byte[] output,
                                     int outputOffset)
                              throws ShortBufferException,
                                     IllegalBlockSizeException,
                                     BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据被加密还是解密取决于此 cipher 的初始化方式。

处理 input 缓冲区中从 inputOffset 开始（包含）的前 inputLen 个字节以及可能在上一次 update 操作过程中已缓存的任何输入字节，其中应用了填充（如果需要）。结果存储在 output 缓冲区中从 outputOffset（包含）开始的位置。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。

结束时，此方法将把此 cipher 对象重置为上一次调用 engineInit 初始化得到的状态。即重置该对象，可供加密或解密（取决于调用 engineInit 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 cipher 对象前，可能需要将其重置。

参数：
input - 输入缓冲区
inputOffset - input 中输入开始位置的偏移量
inputLen - 输入长度
output - 保存结果的缓冲区
outputOffset - output 中存储结果的位置的偏移量
返回：
output 中存储的字节数
抛出：
IllegalBlockSizeException - 如果此 cipher 为块 cipher，未请求任何填充（只针对加密模式），并且由此 cipher 处理的数据总输入长度不是块大小的倍数，如果此加密算法无法处理所提供的输入数据。
ShortBufferException - 如果给定的输出缓冲区太小无法保存结果
BadPaddingException - 如果 cipher 为解密模式，并且未请求填充或不填充，但解密的数据没有用适当的填充字节所限制

engineDoFinal

protected int engineDoFinal(ByteBuffer input,
                            ByteBuffer output)
                     throws ShortBufferException,
                            IllegalBlockSizeException,
                            BadPaddingException
按单部分操作加密或解密数据，或者结束一个多部分操作。数据被加密还是解密取决于此 cipher 的初始化方式。

处理从 input.position() 开始的所有 input.remaining() 字节。结果存储在输出缓冲区中。返回时，输入缓冲区的位置将等于其限制；其限制并未改变。输出缓冲区的位置将前移 n，其中 n 为此方法返回的值；输出缓冲区的限制并未改变。

如果 output.remaining() 个字节还不够保存该结果，则抛出 ShortBufferException。

结束时，此方法将把此 cipher 对象重置为上一次调用 engineInit 初始化得到的状态。即重置该对象，可供加密或解密（取决于调用 engineInit 时指定的操作模式）更多的数据。

注：如果抛出了任何异常，则再次使用此 cipher 对象前，可能需要将其重置。

如果能够比 byte 数组更有效地处理 ByteBuffer，子类应考虑重写此方法。

参数：
input - 输入 ByteBuffer
output - 输出 ByteBuffer
返回：
output 中存储的字节数
抛出：
IllegalBlockSizeException - 如果此 cipher 为块 cipher，未请求任何填充（只针对加密模式），并且由此 cipher 处理的数据总输入长度不是块大小的倍数，如果此加密算法无法处理所提供的输入数据。
ShortBufferException - 如果输出缓冲区没有足够的空间
BadPaddingException - 如果 cipher 为解密模式，并且未请求填充或不填充，但解密的数据没有用适当的填充字节所限制
NullPointerException - 如果任一参数为 null
从以下版本开始：
1.5

engineWrap

protected byte[] engineWrap(Key key)
                     throws IllegalBlockSizeException,
                            InvalidKeyException
将密钥包装。

已将此具体方法添加到了先前定义过的抽象类中。（为向后兼容，它不能为抽象方法）。可以由提供者重写以包装该密钥。如果给定的密钥无法被包装，则这样的重写可能会抛出 IllegalBlockSizeException 或 InvalidKeyException （在指定情况下）。如果不重写此方法，则它总是抛出 UnsupportedOperationException。

参数：
key - 要包装的密钥。
返回：
已包装的密钥。
抛出：
IllegalBlockSizeException - 如果此 cipher 为块 cipher，未请求填充，并且要包装的密钥的编码长度不是块大小的倍数。
InvalidKeyException - 如果不可能用此 cipher 包装该密钥，或这样做不安全（例如，将一个硬件保护的密钥传给只要求软件保护的 cipher）。

engineUnwrap

protected Key engineUnwrap(byte[] wrappedKey,
                           String wrappedKeyAlgorithm,
                           int wrappedKeyType)
                    throws InvalidKeyException,
                           NoSuchAlgorithmException
打开一个以前包装的密钥。

已将此具体方法添加到了先前定义过的抽象类中。（为向后兼容，它不能为抽象方法）。可以由提供者重写以打开以前包装的密钥。如果无法打开给定的包装密钥，则这样的重写可能会抛出 InvalidKeyException。如果不重写此方法，则它总是抛出 UnsupportedOperationException。

参数：
wrappedKey - 要打开的密钥。
wrappedKeyAlgorithm - 与此包装密钥关联的算法。
wrappedKeyType - 已包装密钥的类型。此类型为 SECRET_KEY、PRIVATE_KEY 或 PUBLIC_KEY 之一。
返回：
打开的密钥。
抛出：
NoSuchAlgorithmException - 如果没有一个已安装的提供者能够为 wrappedKeyAlgorithm 创建类型为 wrappedKeyType 的密钥。
InvalidKeyException - 如果 wrappedKey 并不为 wrappedKeyAlgorithm 表示类型为 wrappedKeyType 的已包装密钥。

engineGetKeySize

protected int engineGetKeySize(Key key)
                        throws InvalidKeyException
返回给定密钥对象的密钥大小，以位为单位。

已将此具体方法添加到了先前定义过的抽象类中。如果提供者未重写此方法，则将抛出 UnsupportedOperationException。

参数：
key - 密钥对象
返回：
给定密钥对象的密钥大小。
抛出：
InvalidKeyException - 如果 key 无效。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EncryptedPrivateKeyInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 EncryptedPrivateKeyInfo

java.lang.Object
    继承者  javax.crypto.EncryptedPrivateKeyInfo

public class EncryptedPrivateKeyInfo
extends Object

此类实现 EncryptedPrivateKeyInfo 类型，如在 PKCS #8 中定义的那样。

它的 ASN.1 定义如下：

 EncryptedPrivateKeyInfo ::=  SEQUENCE {
     encryptionAlgorithm   AlgorithmIdentifier,
     encryptedData   OCTET STRING }

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm              OBJECT IDENTIFIER,
     parameters             ANY DEFINED BY algorithm OPTIONAL  }

从以下版本开始：
1.4
另请参见：
PKCS8EncodedKeySpec

构造方法摘要
EncryptedPrivateKeyInfo(AlgorithmParameters algParams, byte[] encryptedData)
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(byte[] encoded)
根据其 ASN.1 编码构造（即解析）EncryptedPrivateKeyInfo。
EncryptedPrivateKeyInfo(String algName, byte[] encryptedData)
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。
方法摘要
String | getAlgName() 返回加密算法。
AlgorithmParameters | getAlgParameters() 返回加密算法使用的算法参数。
byte[] | getEncoded() 返回此对象的 ASN.1 编码。
byte[] | getEncryptedData() 返回加密的数据。
PKCS8EncodedKeySpec | getKeySpec(Cipher cipher) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | getKeySpec(Key decryptKey) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | getKeySpec(Key decryptKey, Provider provider) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
PKCS8EncodedKeySpec | getKeySpec(Key decryptKey, String providerName) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

EncryptedPrivateKeyInfo

public EncryptedPrivateKeyInfo(byte[] encoded)
                        throws IOException
根据其 ASN.1 编码构造（即解析）EncryptedPrivateKeyInfo。

参数：
encoded - 此对象的 ASN.1 编码。该数组的内容被复制，以免后续修改。
抛出：
NullPointerException - 如果 encoded 为 null。
IOException - 如果在解析 ASN.1 编码过程中出现错误。

EncryptedPrivateKeyInfo

public EncryptedPrivateKeyInfo(String algName,
                               byte[] encryptedData)
                        throws NoSuchAlgorithmException
根据加密算法名称和加密数据构造 EncryptedPrivateKeyInfo。

注：此构造方法将用 null 充当算法参数的值。如果加密算法所带的参数不为 null，则应换一种构造方法使用，例如，EncryptedPrivateKeyInfo(AlgorithmParameters, byte[])。

参数：
algName - 加密算法名称。有关标准 Cipher 算法名称的信息，请参见 Java Cryptography Architecture Reference Guide 中的附录 A。
encryptedData - 加密数据。encrypedData 的内容被复制，以免构造此对象时出现后续修改。
抛出：
NullPointerException - 如果 algName 或 encryptedData 为 null。
IllegalArgumentException - 如果 encryptedData 为空，即长度为 0。
NoSuchAlgorithmException - 如果指定的 algName 不受支持。

EncryptedPrivateKeyInfo

public EncryptedPrivateKeyInfo(AlgorithmParameters algParams,
                               byte[] encryptedData)
                        throws NoSuchAlgorithmException
根据加密算法参数和加密数据构造 EncryptedPrivateKeyInfo。

参数：
algParams - 供加密算法使用的算法参数。algParams.getEncoded() 应返回 EncryptedPrivateKeyInfo 类型的 AlgorithmIdentifer 部分的 parameters 字段的 ASN.1 编码字节。
encryptedData - 加密数据。encrypedData 的内容被复制，以免构造此对象时的后续修改。
抛出：
NullPointerException - 如果 algParams 或 encryptedData 为 null。
IllegalArgumentException - 如果 encryptedData 为空，即长度为 0。
NoSuchAlgorithmException - 如果的指定的 algParams 参数的指定 algName 不受支持。
方法详细信息

getAlgName

public String getAlgName()
返回加密算法。

注：如果有这样的映射可用，则返回标准名称而不是指定的名称。有关标准 Cipher 算法名称的信息，请参见 Java Cryptography Architecture Reference Guide 中的附录 A。

返回：
加密算法名称。

getAlgParameters

public AlgorithmParameters getAlgParameters()
返回加密算法使用的算法参数。

返回：
算法参数。

getEncryptedData

public byte[] getEncryptedData()
返回加密的数据。

返回：
加密的数据。每次调用此方法都返回一个新的数组。

getKeySpec

public PKCS8EncodedKeySpec getKeySpec(Cipher cipher)
                               throws InvalidKeySpecException
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
注：为成功获取该封闭的 PKCS8EncodedKeySpec 对象，需要使用与生成加密的数据时所用的密钥和参数相同的密钥和参数将 cipher 初始化为 Cipher.DECRYPT_MODE 或 Cipher.UNWRAP_MODE。

参数：
cipher - 将用于对加密的数据进行解密的初始化密码对象。
返回：
PKCS8EncodedKeySpec 对象。
抛出：
NullPointerException - 如果 cipher 为 null。
InvalidKeySpecException - 如果给定的密码不适合加密的数据，或者加密的数据已损坏，无法解密。

getKeySpec

public PKCS8EncodedKeySpec getKeySpec(Key decryptKey)
                               throws NoSuchAlgorithmException,
                                      InvalidKeyException
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

参数：
decryptKey - 在对加密的数据进行解密时所使用的密钥。
返回：
PKCS8EncodedKeySpec 对象。
抛出：
NullPointerException - 如果 decryptKey 为 null。
NoSuchAlgorithmException - 如果无法找到合适的密码对加密的数据进行解密。
InvalidKeyException - 如果无法用 decryptKey 对加密的数据进行解密，或者解密结果不是有效的 PKCS8KeySpec。
从以下版本开始：
1.5

getKeySpec

public PKCS8EncodedKeySpec getKeySpec(Key decryptKey,
                                      String providerName)
                               throws NoSuchProviderException,
                                      NoSuchAlgorithmException,
                                      InvalidKeyException
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

参数：
decryptKey - 在对加密的数据进行解密时所使用的密钥。
providerName - 其 Cipher 实现将被使用的提供者的名称。
返回：
PKCS8EncodedKeySpec 对象。
抛出：
NullPointerException - 如果 decryptKey 或 providerName 为 null。
NoSuchProviderException - 如果没有注册任何名称为 providerName 的提供者。
NoSuchAlgorithmException - 如果无法找到合适的密码对加密的数据进行解密。
InvalidKeyException - 如果无法用 decryptKey 对加密的数据进行解密，或者解密结果不是有效的 PKCS8KeySpec。
从以下版本开始：
1.5

getKeySpec

public PKCS8EncodedKeySpec getKeySpec(Key decryptKey,
                                      Provider provider)
                               throws NoSuchAlgorithmException,
                                      InvalidKeyException
将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。

参数：
decryptKey - 在对加密的数据进行解密时所使用的密钥。
provider - 其 Cipher 实现将被使用的提供者的名称。
返回：
PKCS8EncodedKeySpec 对象。
抛出：
NullPointerException - 如果 decryptKey 或 provider 为 null。
NoSuchAlgorithmException - 如果在 provider 中无法找到合适的密码对加密的数据进行解密。
InvalidKeyException - 如果无法用 decryptKey 对加密的数据进行解密，或者解密结果不是有效的 PKCS8KeySpec。
从以下版本开始：
1.5

getEncoded

public byte[] getEncoded()
                  throws IOException
返回此对象的 ASN.1 编码。

返回：
ASN.1 编码。每次调用此方法都返回一个新的数组。
抛出：
IOException - 如果在构造 ASN.1 编码过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExemptionMechanism (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 ExemptionMechanism

java.lang.Object
    继承者  javax.crypto.ExemptionMechanism

public class ExemptionMechanism
extends Object

此类提供了豁免 (exemption) 机制的功能，例如，密钥恢复、密钥唤醒 和密钥托管。

使用豁免机制的应用程序或 applet 比不使用豁免机制的应用程序或 applet 具有更强的加密性能。

从以下版本开始：
1.4

构造方法摘要
protected ExemptionMechanism(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
创建 ExemptionMechanism 对象。
方法摘要
protected void | finalize() 确保不存在对此 ExemptionMechanism 对象存储的密钥的引用时，该密钥将被除去。
byte[] | genExemptionBlob() 生成豁免机制密钥 blob。
int | genExemptionBlob(byte[] output) 生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
int | genExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
static ExemptionMechanism | getInstance(String algorithm) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static ExemptionMechanism | getInstance(String algorithm, Provider provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static ExemptionMechanism | getInstance(String algorithm, String provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
String | getName() 返回此 ExemptionMechanism 对象的豁免机制名称。
int | getOutputSize(int inputLen) 根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 genExemptionBlob 操作结果所需的输出缓冲区长度（以字节为单位）。
Provider | getProvider() 返回此 ExemptionMechanism 对象的提供者。
void | init(Key key) 用密钥初始化此豁免机制。
void | init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
boolean | isCryptoAllowed(Key key) 返回此豁免机制是否已成功生成结果 blob。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExemptionMechanism

protected ExemptionMechanism(ExemptionMechanismSpi exmechSpi,
                             Provider provider,
                             String mechanism)
创建 ExemptionMechanism 对象。

参数：
exmechSpi - 代理
provider - 提供者
mechanism - 豁免机制
方法详细信息

getName

public final String getName()
返回此 ExemptionMechanism 对象的豁免机制名称。

这与创建此 ExemptionMechanism 对象的 getInstance 调用之一指定的名称相同。

返回：
此 ExemptionMechanism 对象的豁免机制名称。

getInstance

public static final ExemptionMechanism getInstance(String algorithm)
                                            throws NoSuchAlgorithmException
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 ExemptionMechanismSpi 实现的新 ExemptionMechanism 对象，该实现取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求豁免机制的标准名称。有关标准豁免机制名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
返回：
新的 ExemptionMechanism 对象。
抛出：
NullPointerException - 如果 algorithm 为 null。
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 ExemptionMechanismSpi 实现。
另请参见：
Provider

getInstance

public static final ExemptionMechanism getInstance(String algorithm,
                                                   String provider)
                                            throws NoSuchAlgorithmException,
                                                   NoSuchProviderException
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

返回一个封装 ExemptionMechanismSpi 实现的新 ExemptionMechanism 对象，该实现取自指定的提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求豁免机制的标准名称。有关标准豁免机制名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者的名称。
返回：
新的 ExemptionMechanism 对象。
抛出：
NullPointerException - 如果 algorithm 为 null。
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 ExemptionMechanismSpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static final ExemptionMechanism getInstance(String algorithm,
                                                   Provider provider)
                                            throws NoSuchAlgorithmException
返回实现指定豁免机制算法的 ExemptionMechanism 对象。

返回一个封装 ExemptionMechanismSpi 实现的新 ExemptionMechanism 对象，该实现取自指定的 Provider 对象。 注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求豁免机制的标准名称。有关标准豁免机制名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者。
返回：
新的 ExemptionMechanism 对象。
抛出：
NullPointerException - 如果 algorithm 为 null。
NoSuchAlgorithmException - 如果不能从指定 Provider 对象获得指定算法的 ExemptionMechanismSpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 ExemptionMechanism 对象的提供者。

返回：
此 ExemptionMechanism 对象的提供者。

isCryptoAllowed

public final boolean isCryptoAllowed(Key key)
                              throws ExemptionMechanismException
返回此豁免机制是否已成功生成结果 blob。

该方法还确保了传入的密钥与此豁免机制在初始化和生成阶段所使用的密钥相同。

参数：
key - 加密将使用的密钥。
返回：
此豁免机制是否已成功生成了相同密钥的结果 blob；如果 key 为 null，则返回 false。
抛出：
ExemptionMechanismException - 如果在确定此豁免机制对象是否成功生成了结果 blob 的过程中遇到问题。

getOutputSize

public final int getOutputSize(int inputLen)
                        throws IllegalStateException
根据给定的输入长度 inputLen（以字节为单位），返回保存下一个 genExemptionBlob 操作结果所需的输出缓冲区长度（以字节为单位）。

下一个 genExemptionBlob 调用的实际输出长度可能小于此方法返回的长度。

参数：
inputLen - 输入长度（以字节为单位）
返回：
所需的输出缓冲区大小（以字节为单位）
抛出：
IllegalStateException - 如果此豁免机制处于错误状态（例如，尚未初始化）

init

public final void init(Key key)
                throws InvalidKeyException,
                       ExemptionMechanismException
用密钥初始化此豁免机制。

如果此豁免机制需要算法参数，而参数无法从给定的 key 派生，则底层豁免机制实现应自己生成所需的参数（使用特定于提供者的默认值）；如果算法参数必须由调用者指定，则会引发 InvalidKeyException。

参数：
key - 用于此豁免机制的密钥
抛出：
InvalidKeyException - 如果给定的密钥不适合此豁免机制。
ExemptionMechanismException - 如果初始化过程中遇到问题。

init

public final void init(Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException,
                       ExemptionMechanismException
用一个密钥和一组算法参数初始化此豁免机制。

如果此豁免机制需要算法参数，而 params 为 null，则底层豁免机制实现应自己生成所需的参数（使用特定于提供者的默认值）；如果算法参数必须由调用者指定，则会引发 InvalidAlgorithmParameterException。

参数：
key - 用于此豁免机制的密钥
params - 算法参数
抛出：
InvalidKeyException - 如果给定的密钥不适合此豁免机制。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此豁免机制。
ExemptionMechanismException - 如果初始化过程中遇到问题。

init

public final void init(Key key,
                       AlgorithmParameters params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException,
                       ExemptionMechanismException
用一个密钥和一组算法参数初始化此豁免机制。

如果此豁免机制需要算法参数，而 params 为 null，则底层豁免机制实现应自己生成所需的参数（使用特定于提供者的默认值）；如果算法参数必须由调用者指定，则会引发 InvalidAlgorithmParameterException。

参数：
key - 用于此豁免机制的密钥
params - 算法参数
抛出：
InvalidKeyException - 如果给定的密钥不适合此豁免机制。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此豁免机制。
ExemptionMechanismException - 如果初始化过程中遇到问题。

genExemptionBlob

public final byte[] genExemptionBlob()
                              throws IllegalStateException,
                                     ExemptionMechanismException
生成豁免机制密钥 blob。

返回：
包含结果密钥 blob 的新缓冲区。
抛出：
IllegalStateException - 如果此豁免机制处于错误状态（例如，尚未初始化）。
ExemptionMechanismException - 如果生成过程中遇到问题。

genExemptionBlob

public final int genExemptionBlob(byte[] output)
                           throws IllegalStateException,
                                  ShortBufferException,
                                  ExemptionMechanismException
生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

参数：
output - 用于保存结果的缓冲区
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此豁免机制处于错误状态（例如，尚未初始化）。
ShortBufferException - 如果给定的输出缓冲区太小无法保存该结果。
ExemptionMechanismException - 如果生成过程中遇到问题。

genExemptionBlob

public final int genExemptionBlob(byte[] output,
                                  int outputOffset)
                           throws IllegalStateException,
                                  ShortBufferException,
                                  ExemptionMechanismException
生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException。这种情况下，使用一个稍大的缓冲区再次调用。使用 getOutputSize 确定输出缓冲区应为多大。

参数：
output - 用于保存结果的缓冲区
outputOffset - output 中存储结果处的偏移量
返回：
output 中存储的字节数
抛出：
IllegalStateException - 如果此豁免机制处于错误状态（例如，尚未初始化）。
ShortBufferException - 如果给定的输出缓冲区太小无法保存该结果。
ExemptionMechanismException - 如果生成过程中遇到问题。

finalize

protected void finalize()
确保不存在对此 ExemptionMechanism 对象存储的密钥的引用时，该密钥将被除去。

覆盖：
类 Object 中的 finalize
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExemptionMechanismException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 ExemptionMechanismException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.crypto.ExemptionMechanismException
所有已实现的接口：
Serializable
public class ExemptionMechanismException
extends GeneralSecurityException

此为一般 ExemptionMechanism 异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ExemptionMechanismException()
构造不带详细消息的 ExemptionMechanismException。
ExemptionMechanismException(String msg)
构造带指定详细消息的 ExemptionMechanismException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ExemptionMechanismException

public ExemptionMechanismException()
构造不带详细消息的 ExemptionMechanismException。（详细消息是描述此特定异常的字符串）。

ExemptionMechanismException

public ExemptionMechanismException(String msg)
构造带指定详细消息的 ExemptionMechanismException。（详细消息是描述此特定异常的字符串）。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExemptionMechanismSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 ExemptionMechanismSpi

java.lang.Object
    继承者  javax.crypto.ExemptionMechanismSpi

public abstract class ExemptionMechanismSpi
extends Object

此类为 ExemptionMechanism 类定义了服务提供者接口 (SPI)。此类中的所有抽象方法都必须由希望提供特定豁免机制实现的各个加密服务提供者来实现。

从以下版本开始：
1.4

构造方法摘要
ExemptionMechanismSpi()
方法摘要
protected abstract byte[] | engineGenExemptionBlob() 生成豁免机制密钥 blob。
protected abstract int | engineGenExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
protected abstract int | engineGetOutputSize(int inputLen) 给定了输入长度 inputLen （以字节为单位）的情况下，返回用于保存下一个 engineGenExemptionBlob 操作结果所需的输出缓冲区长度的字节长度。
protected abstract void | engineInit(Key key) 用密钥初始化此豁免机制。
protected abstract void | engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ExemptionMechanismSpi

public ExemptionMechanismSpi()
方法详细信息

engineGetOutputSize

protected abstract int engineGetOutputSize(int inputLen)
给定了输入长度 inputLen （以字节为单位）的情况下，返回用于保存下一个 engineGenExemptionBlob 操作结果所需的输出缓冲区长度的字节长度。

下一个 engineGenExemptionBlob 调用的实际输出长度可能小于此方法返回的长度。

参数：
inputLen - 输入长度（以字节为单位）
返回：
所需的输出缓冲区大小（以字节为单位）

engineInit

protected abstract void engineInit(Key key)
                            throws InvalidKeyException,
                                   ExemptionMechanismException
用密钥初始化此豁免机制。

如果此豁免机制需要的任何算法参数无法从给定的 key 派生，底层豁免机制实现将自己生成所需的参数（使用特定于提供者的默认值）；如果算法参数必须由调用者指定，则会引发 InvalidKeyException 异常。

参数：
key - 用于此豁免机制的密钥
抛出：
InvalidKeyException - 如果给定的密钥不适合此豁免机制。
ExemptionMechanismException - 如果初始化过程中出现问题。

engineInit

protected abstract void engineInit(Key key,
                                   AlgorithmParameterSpec params)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException,
                                   ExemptionMechanismException
用一个密钥和一组算法参数初始化此豁免机制。

如果此豁免机制需要使用任何算法参数，而 params 为 null，底层豁免机制实现将自己生成所需的参数（使用特定于提供者的默认值）；如果算法参数必须由调用者指定，则会引发 InvalidAlgorithmParameterException 异常。

参数：
key - 用于此豁免机制的密钥
params - 算法参数
抛出：
InvalidKeyException - 如果给定的密钥不适合此豁免机制。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此豁免机制。
ExemptionMechanismException - 如果初始化过程中出现问题。

engineInit

protected abstract void engineInit(Key key,
                                   AlgorithmParameters params)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException,
                                   ExemptionMechanismException
用一个密钥和一组算法参数初始化此豁免机制。

如果此豁免机制需要使用任何算法参数，而 params 为 null，底层豁免机制实现将自己生成所需的参数（使用特定于提供者的默认值）；如果算法参数必须由调用者指定，则会引发 InvalidAlgorithmParameterException 异常。

参数：
key - 用于此豁免机制的密钥
params - 算法参数
抛出：
InvalidKeyException - 如果给定的密钥不适合此豁免机制。
InvalidAlgorithmParameterException - 如果给定的算法参数不适合此豁免机制。
ExemptionMechanismException - 如果初始化过程中出现问题。

engineGenExemptionBlob

protected abstract byte[] engineGenExemptionBlob()
                                          throws ExemptionMechanismException
生成豁免机制密钥 blob。

返回：
具有结果密钥 blob 的新缓冲区。
抛出：
ExemptionMechanismException - 如果生成过程中出现问题。

engineGenExemptionBlob

protected abstract int engineGenExemptionBlob(byte[] output,
                                              int outputOffset)
                                       throws ShortBufferException,
                                              ExemptionMechanismException
生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。

如果 output 缓冲区太小无法保存该结果，则抛出 ShortBufferException 异常。这种情况下，使用一个稍大的缓冲区再次调用。使用 engineGetOutputSize 确定输出缓冲区应为多大。

参数：
output - 用于保存结果的缓冲区
outputOffset - output 中的偏移量，即结果保存的位置
返回：
output 中存储的字节数
抛出：
ShortBufferException - 如果给定的输出缓冲区太小无法保存该结果。
ExemptionMechanismException - 如果生成过程中出现问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IllegalBlockSizeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 IllegalBlockSizeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.crypto.IllegalBlockSizeException
所有已实现的接口：
Serializable
public class IllegalBlockSizeException
extends GeneralSecurityException

如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
IllegalBlockSizeException()
构造不带详细信息的 IllegalBlockSizeException。
IllegalBlockSizeException(String msg)
构造带指定详细信息的 IllegalBlockSizeException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IllegalBlockSizeException

public IllegalBlockSizeException()
构造不带详细信息的 IllegalBlockSizeException。详细消息是描述此特定异常的String。

IllegalBlockSizeException

public IllegalBlockSizeException(String msg)
构造带指定详细信息的 IllegalBlockSizeException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyAgreement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 KeyAgreement

java.lang.Object
    继承者  javax.crypto.KeyAgreement

public class KeyAgreement
extends Object

此类提供密钥协定（或密钥交换）协议的功能。

建立共享秘密所涉及的密钥由某个密钥生成器（KeyPairGenerator 或 KeyGenerator）或一个 KeyFactory 来创建，或者在密钥协定协议的中间阶段创建。

对于密钥交换中的每个相关方，需要调用 doPhase。例如，如果此密钥交换是与其他一个参与者进行的，则需要调用一次 doPhase，调用时将 lastPhase 标志设置为 true。如果此密钥交换是与其他两个参与者进行的，则需要调用两次 doPhase，第一次将 lastPhase 标志设置为 false，第二次将它设置为 true。密钥交换可以涉及任意数量的参与者。

从以下版本开始：
1.4
另请参见：
KeyGenerator, SecretKey

构造方法摘要
protected KeyAgreement(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
创建一个 KeyAgreement 对象。
方法摘要
Key | doPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。
byte[] | generateSecret() 生成共享秘密并在新的缓冲区中返回它。
int | generateSecret(byte[] sharedSecret, int offset) 生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。
SecretKey | generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
String | getAlgorithm() 返回此 KeyAgreement 对象的算法名称。
static KeyAgreement | getInstance(String algorithm) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyAgreement | getInstance(String algorithm, Provider provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyAgreement | getInstance(String algorithm, String provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
Provider | getProvider() 返回此 KeyAgreement 对象的提供者。
void | init(Key key) 用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。
void | init(Key key, AlgorithmParameterSpec params) 用给定密钥和算法参数集初始化此密钥协定。
void | init(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
void | init(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协议。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyAgreement

protected KeyAgreement(KeyAgreementSpi keyAgreeSpi,
                       Provider provider,
                       String algorithm)
创建一个 KeyAgreement 对象。

参数：
keyAgreeSpi - 委托
provider - 提供者
algorithm - 算法
方法详细信息

getAlgorithm

public final String getAlgorithm()
返回此 KeyAgreement 对象的算法名称。

此名称与在某个创建此 KeyAgreement 对象的 getInstance 调用中指定的名称相同。

返回：
此 KeyAgreement 对象的算法名称。

getInstance

public static final KeyAgreement getInstance(String algorithm)
                                      throws NoSuchAlgorithmException
返回实现指定密钥协定算法的 KeyAgreement 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 KeyAgreementSpi 实现的新 KeyAgreement 对象，该实现取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求密钥协定算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
返回：
新的 KeyAgreement 对象。
抛出：
NullPointerException - 如果指定的算法为 null。
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 KeyAgreementSpi 实现。
另请参见：
Provider

getInstance

public static final KeyAgreement getInstance(String algorithm,
                                             String provider)
                                      throws NoSuchAlgorithmException,
                                             NoSuchProviderException
返回实现指定密钥协定算法的 KeyAgreement 对象。

返回一个封装 KeyAgreementSpi 实现的新 KeyAgreement 对象，该实现取自指定的提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求密钥协定算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者的名称。
返回：
新的 KeyAgreement 对象。
抛出：
NullPointerException - 如果指定的算法为 null。
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 KeyAgreementSpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static final KeyAgreement getInstance(String algorithm,
                                             Provider provider)
                                      throws NoSuchAlgorithmException
返回实现指定密钥协定算法的 KeyAgreement 对象。

返回一个封装 KeyAgreementSpi 实现的新 KeyAgreement 对象，该实现取自指定的 Provider 对象。 注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求密钥协定算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者。
返回：
新的 KeyAgreement 对象。
抛出：
NullPointerException - 如果指定的算法为 null。
NoSuchAlgorithmException - 如果不能从指定的 Provider 对象获得指定算法的 KeyAgreementSpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 KeyAgreement 对象的提供者。

返回：
此 KeyAgreement 对象的提供者

init

public final void init(Key key)
                throws InvalidKeyException
用给定密钥初始化此密钥协定，给定密钥需要包含此密钥协定所需的所有算法参数。

如果此密钥协定需要随机字节，则它将使用具有高优先级的已安装提供者的 SecureRandom 实现获取它们以作为随机源。（如果已安装的提供者没有一个提供 SecureRandom 实现，则将使用系统提供的随机源。）

参数：
key - 参与者的私有信息。例如，对于 Diffie-Hellman 密钥协定，此参数将是参与者自己的 Diffie-Hellman 私钥。
抛出：
InvalidKeyException - 如果给定的密钥不适合此密钥协定，例如，属于错误类型或算法类型不一致。

init

public final void init(Key key,
                       SecureRandom random)
                throws InvalidKeyException
用给定密钥和随机源初始化此密钥协议。给定密钥需要包含此密钥协议所需的所有算法参数。

如果该密钥协定算法需要随机字节，则从给定的随机源 random 中获取它们。但是，如果底层算法实现不需要任何随机字节，则忽略 random。

参数：
key - 参与者的私有信息。例如，对于 Diffie-Hellman 密钥协定，此参数将是参与者自己的 Diffie-Hellman 私钥。
random - 随机源
抛出：
InvalidKeyException - 如果给定的密钥不适合此密钥协定，例如，属于错误类型或算法类型不一致。

init

public final void init(Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
用给定密钥和算法参数集初始化此密钥协定。

如果此密钥协定需要随机字节，则它将使用具有高优先级的已安装提供者的 SecureRandom 实现获取它们以作为随机源。（如果已安装的提供者没有一个提供 SecureRandom 实现，则将使用系统提供的随机源。）

参数：
key - 参与者的私有信息。例如，对于 Diffie-Hellman 密钥协定，此参数将是参与者自己的 Diffie-Hellman 私钥。
params - 密钥协定参数
抛出：
InvalidKeyException - 如果给定的密钥不适合此密钥协定，例如，属于错误类型或算法类型不一致。
InvalidAlgorithmParameterException - 如果给定算法不适合此密钥协定。

init

public final void init(Key key,
                       AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
用给定密钥、算法参数集和随机源初始化此密钥协定。

参数：
key - 参与者的私有信息。例如，对于 Diffie-Hellman 密钥协定，此参数将是参与者自己的 Diffie-Hellman 私钥。
params - 密钥协定参数
random - 随机源
抛出：
InvalidKeyException - 如果给定的密钥不适合此密钥协定，例如，属于错误类型或算法类型不一致。
InvalidAlgorithmParameterException - 如果给定算法不适合此密钥协定。

doPhase

public final Key doPhase(Key key,
                         boolean lastPhase)
                  throws InvalidKeyException,
                         IllegalStateException
用给定密钥执行此密钥协定的下一个阶段，给定密钥是从此密钥协定所涉及的其他某个参与者那里接收的。

参数：
key - 此阶段的密钥。例如，对于两个参与者之间的 Diffie-Hellman，此密钥将是另一个参与者的 Diffie-Hellman 公钥。
lastPhase - 表示这是否是此密钥协定最后阶段的标志。
返回：
从此阶段得到的（中间）密钥；如果此阶段不产生密钥，则返回 null
抛出：
InvalidKeyException - 如果给定密钥不适合此阶段。
IllegalStateException - 如果尚未初始化此密钥协定。

generateSecret

public final byte[] generateSecret()
                            throws IllegalStateException
生成共享秘密并在新的缓冲区中返回它。

此方法重置此 KeyAgreement 对象，以便能够将它重用于进一步的密钥协定。如果没有使用某个 init 方法重新初始化此密钥协定，则将相同的私有信息和算法参数用于后续密钥协定。

返回：
包含共享秘密的新缓冲区
抛出：
IllegalStateException - 如果尚未完成此密钥协定

generateSecret

public final int generateSecret(byte[] sharedSecret,
                                int offset)
                         throws IllegalStateException,
                                ShortBufferException
生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。

如果 sharedSecret 缓冲区太小而无法保存该结果，则抛出 ShortBufferException。在此情况下，应该用更大的输出缓冲区再次调用此方法。

此方法重置此 KeyAgreement 对象，以便能够将它重用于进一步的密钥协定。如果没有使用某个 init 方法重新初始化此密钥协定，则将相同的私有信息和算法参数用于后续密钥协定。

参数：
sharedSecret - 共享秘密的缓冲区
offset - sharedSecret 中将存储共享秘密处的偏移量
返回：
放入 sharedSecret 中的字节数
抛出：
IllegalStateException - 如果尚未完成此密钥协定
ShortBufferException - 如果给定输出缓冲区太小而无法保存该秘密

generateSecret

public final SecretKey generateSecret(String algorithm)
                               throws IllegalStateException,
                                      NoSuchAlgorithmException,
                                      InvalidKeyException
创建共享秘密并将其作为指定算法的 SecretKey 对象返回。

此方法重置此 KeyAgreement 对象，以便能够将它重用于进一步的密钥协定。如果没有使用某个 init 方法重新初始化此密钥协定，则将相同的私有信息和算法参数用于后续密钥协定。

参数：
algorithm - 所请求秘密密钥的算法
返回：
共享的秘密密钥
抛出：
IllegalStateException - 如果尚未完成此密钥协定
NoSuchAlgorithmException - 如果指定的秘密密钥算法不可用
InvalidKeyException - 如果无法使用共享秘密密钥材料生成指定算法的秘密密钥（例如，密钥材料太短）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyAgreementSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 KeyAgreementSpi

java.lang.Object
    继承者  javax.crypto.KeyAgreementSpi

public abstract class KeyAgreementSpi
extends Object

此类为 KeyAgreement 类定义了服务提供者接口 (SPI)。此类中的所有抽象方法必须由希望提供特定密钥一致算法实现的每个加密服务提供者来实现。

建立共享秘密所涉及的密钥由某个密钥生成器（KeyPairGenerator 或 KeyGenerator，一个 KeyFactory）来创建，或从密钥协定协议的中间阶段来创建 (engineDoPhase)。

对于密钥交换中的每个对应物，需要调用 engineDoPhase。例如，如果密钥交换是与其他一个参与者进行的，则需要调用一次 engineDoPhase，将 lastPhase 标志设置为 true。如果密钥交换是与其他两个参与者进行的，则需要调用两次 engineDoPhase，第一次将 lastPhase 标志设置为 false，第二次将它设置为 true。密钥交换可能涉及任意数量的参与者。

从以下版本开始：
1.4
另请参见：
KeyGenerator, SecretKey

构造方法摘要
KeyAgreementSpi()
方法摘要
protected abstract Key | engineDoPhase(Key key, boolean lastPhase) 用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。
protected abstract byte[] | engineGenerateSecret() 生成共享秘密密钥并在新的缓冲区中返回它。
protected abstract int | engineGenerateSecret(byte[] sharedSecret, int offset) 生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。
protected abstract SecretKey | engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
protected abstract void | engineInit(Key key, AlgorithmParameterSpec params, SecureRandom random) 用给定密钥、算法参数集和随机源初始化此密钥协定。
protected abstract void | engineInit(Key key, SecureRandom random) 用给定密钥和随机源初始化此密钥协定。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyAgreementSpi

public KeyAgreementSpi()
方法详细信息

engineInit

protected abstract void engineInit(Key key,
                                   SecureRandom random)
                            throws InvalidKeyException
用给定密钥和随机源初始化此密钥协定。给定密钥需要包含此密钥协定所需的所有算法参数。

如果该密钥一致算法需要随机字节，则从给定的随机源 random 中获取它们。不过，如果底层算法实现不需要任何随机字节，则忽略 random。

参数：
key - 参与者的私有信息。例如，对于 Diffie-Hellman 密钥协定，这应是参与者自己的 Diffie-Hellman 私钥。
random - 随机源
抛出：
InvalidKeyException - 如果给定的密钥不适合此密钥协定，即属于错误类型或有一个不一致的算法类型。

engineInit

protected abstract void engineInit(Key key,
                                   AlgorithmParameterSpec params,
                                   SecureRandom random)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
用给定密钥、算法参数集和随机源初始化此密钥协定。

参数：
key - 参与者的私有信息。例如，对于 Diffie-Hellman 密钥协定，这应是参与者自己的 Diffie-Hellman 私钥。
params - 密钥协定参数
random - 随机源
抛出：
InvalidKeyException - 如果给定的密钥不适合此密钥协定，即属于错误类型或有一个不一致的算法类型。
InvalidAlgorithmParameterException - 如果给定算法不适合此密钥协定。

engineDoPhase

protected abstract Key engineDoPhase(Key key,
                                     boolean lastPhase)
                              throws InvalidKeyException,
                                     IllegalStateException
用给定密钥执行此密钥协定的下一个阶段，该给定密钥是从此密钥协定中涉及的其他某个参与者那里接收的。

参数：
key - 此阶段的密钥。例如，对于两个参与者之间的 Diffie-Hellman，此密钥应是其他参与者的 Diffie-Hellman 公钥。
lastPhase - 指示这是否是此密钥协定的最后阶段的标志。
返回：
从此阶段得到的（中间）密钥；如果此阶段不产生密钥，则返回 null
抛出：
InvalidKeyException - 如果给定密钥不适合此阶段。
IllegalStateException - 如果尚未初始化此密钥协定。

engineGenerateSecret

protected abstract byte[] engineGenerateSecret()
                                        throws IllegalStateException
生成共享秘密密钥并在新的缓冲区中返回它。

此方法重新设置此 KeyAgreementSpi 对象，以便能够将它重新用于进一步的密钥协定。如果没有使用某个 engineInit 方法重新初始化此密钥协定，则将相同的私有信息和算法参数用于后续密钥协定。

返回：
带有共享秘密密钥的新缓冲区
抛出：
IllegalStateException - 如果尚未实现此密钥协定

engineGenerateSecret

protected abstract int engineGenerateSecret(byte[] sharedSecret,
                                            int offset)
                                     throws IllegalStateException,
                                            ShortBufferException
生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。

如果 sharedSecret 缓冲区太小而无法保存该结果，则抛出 ShortBufferException。在此情况下，应该用更大的输出缓冲区重复进行此调用。

此方法重新设置此 KeyAgreementSpi 对象，以便能够将它重新用于进一步的密钥协定。如果没有使用某个 engineInit 方法重新初始化此密钥协定，则将相同的私有信息和算法参数用于后续密钥协定。

参数：
sharedSecret - 共享秘密密钥的缓冲区
offset - 将存储共享秘密密钥的 sharedSecret 中的偏移量
返回：
放入 sharedSecret 中的字节数
抛出：
IllegalStateException - 如果尚未实现此密钥协定
ShortBufferException - 如果给定输出缓冲区太小而无法保存该秘密密钥

engineGenerateSecret

protected abstract SecretKey engineGenerateSecret(String algorithm)
                                           throws IllegalStateException,
                                                  NoSuchAlgorithmException,
                                                  InvalidKeyException
创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。

此方法重新设置此 KeyAgreementSpi 对象，以便能够将它重新用于进一步的密钥协定。如果没有使用某个 engineInit 方法重新初始化此密钥协定，则将相同的私有信息和算法参数用于后续密钥协定。

参数：
algorithm - 所请求秘密密钥的算法
返回：
共享的秘密密钥
抛出：
IllegalStateException - 如果此密钥协定尚未实现
NoSuchAlgorithmException - 如果所请求的秘密密钥算法不可用
InvalidKeyException - 如果无法使用共享秘密密钥材料生成所请求算法类型的秘密密钥（例如，密钥材料太短缺）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyGenerator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 KeyGenerator

java.lang.Object
    继承者  javax.crypto.KeyGenerator

public class KeyGenerator
extends Object

此类提供（对称）密钥生成器的功能。

密钥生成器是使用此类的某个 getInstance 类方法构造的。

KeyGenerator 对象可重复使用，也就是说，在生成密钥后，可以重复使用同一个 KeyGenerator 对象来生成更多的密钥。

生成密钥的方式有两种：与算法无关的方式和特定于算法的方式。两者之间的唯一不同是对象的初始化：

  • 与算法无关的初始化

    所有密钥生成器都具有密钥大小 和随机源 的概念。此 KeyGenerator 类中有一个 init 方法，它带有这两个通用共享类型的参数。还有一个只带有 keysize 参数的 init 方法，它使用具有最高优先级的已安装提供者的 SecureRandom 实现作为随机源（如果已安装的提供者都不提供 SecureRandom 实现，则使用系统提供的随机源）。此 KeyGenerator 类还提供一个只带随机源参数的 inti 方法。

    因为调用上述与算法无关的 init 方法时未指定其他参数，所以由提供者决定如何处理要与每个密钥关联的特定于算法的参数（如果有）。

  • 特定于算法的初始化

    在已经存在特定于算法的参数集的情况下，有两个带 AlgorithmParameterSpec 参数的 init 方法。其中一个方法还有一个 SecureRandom 参数，而另一个方法将具有高优先级的已安装提供者的 SecureRandom 实现作为随机源（如果安装的提供者都不提供 SecureRandom 实现，则使用系统提供的随机源）。

如果客户端没有显式地初始化 KeyGenerator（通过调用 init 方法），那么每个提供者都必须提供（并记录）默认初始化。

从以下版本开始：
1.4
另请参见：
SecretKey

构造方法摘要
protected KeyGenerator(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
创建一个 KeyGenerator 对象。
方法摘要
SecretKey | generateKey() 生成一个密钥。
String | getAlgorithm() 返回此 KeyGenerator 对象的算法名称。
static KeyGenerator | getInstance(String algorithm) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static KeyGenerator | getInstance(String algorithm, Provider provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static KeyGenerator | getInstance(String algorithm, String provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
Provider | getProvider() 返回此 KeyGenerator 对象的提供者。
void | init(AlgorithmParameterSpec params) 用指定参数集初始化此密钥生成器。
void | init(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化此密钥生成器。
void | init(int keysize) 初始化此密钥生成器，使其具有确定的密钥大小。
void | init(int keysize, SecureRandom random) 使用用户提供的随机源初始化此密钥生成器，使其具有确定的密钥大小。
void | init(SecureRandom random) 初始化此密钥生成器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyGenerator

protected KeyGenerator(KeyGeneratorSpi keyGenSpi,
                       Provider provider,
                       String algorithm)
创建一个 KeyGenerator 对象。

参数：
keyGenSpi - 委托
provider - 提供者
algorithm - 算法
方法详细信息

getAlgorithm

public final String getAlgorithm()
返回此 KeyGenerator 对象的算法名称。

此名称与创建此 KeyGenerator 对象的 getInstance 调用之一中指定的名称相同。

返回：
此 KeyGenerator 对象的算法名称。

getInstance

public static final KeyGenerator getInstance(String algorithm)
                                      throws NoSuchAlgorithmException
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 KeyGeneratorSpi 实现的新 KeyGenerator 对象，该实现取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求密钥算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
返回：
新的 KeyGenerator 对象。
抛出：
NullPointerException - 如果指定算法为 null。
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 KeyGeneratorSpi 实现。
另请参见：
Provider

getInstance

public static final KeyGenerator getInstance(String algorithm,
                                             String provider)
                                      throws NoSuchAlgorithmException,
                                             NoSuchProviderException
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

返回一个封装 KeyGeneratorSpi 实现的新 KeyGenerator 对象，该实现取自指定的提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求密钥算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者的名称。
返回：
新的 KeyGenerator 对象。
抛出：
NullPointerException - 如果指定算法为 null。
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 KeyGeneratorSpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static final KeyGenerator getInstance(String algorithm,
                                             Provider provider)
                                      throws NoSuchAlgorithmException
返回生成指定算法的秘密密钥的 KeyGenerator 对象。

返回一个封装 KeyGeneratorSpi 实现的新 KeyGenerator 对象，该实现取自指定的 Provider 对象。 注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求密钥算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者。
返回：
新的 KeyGenerator 对象。
抛出：
NullPointerException - 如果指定算法为 null。
NoSuchAlgorithmException - 如果不能从指定 Provider 对象获得指定算法的 KeyGeneratorSpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 KeyGenerator 对象的提供者。

返回：
此 KeyGenerator 对象的提供者

init

public final void init(SecureRandom random)
初始化此密钥生成器。

参数：
random - 此生成器的随机源

init

public final void init(AlgorithmParameterSpec params)
                throws InvalidAlgorithmParameterException
用指定参数集初始化此密钥生成器。

如果此密钥生成器需要随机字节，则它将使用具有最高优先级的已安装提供者的 SecureRandom 实现作为随机源来获取这些字节。（如果已安装的提供者都不提供 SecureRandom 实现，则将使用系统提供的随机源。）

参数：
params - 密钥生成参数
抛出：
InvalidAlgorithmParameterException - 如果给定算法不适合此密钥生成器

init

public final void init(AlgorithmParameterSpec params,
                       SecureRandom random)
                throws InvalidAlgorithmParameterException
用指定参数集和用户提供的随机源初始化此密钥生成器。

参数：
params - 密钥生成参数
random - 此密钥生成器的随机源
抛出：
InvalidAlgorithmParameterException - 如果 params 不适合此密钥生成器

init

public final void init(int keysize)
初始化此密钥生成器，使其具有确定的密钥大小。

如果此密钥生成器需要随机字节，则它将使用具有最高优先级的已安装提供者的 SecureRandom 实现作为随机源来获取这些字节。（如果已安装的提供者都不提供 SecureRandom 实现，则将使用系统提供的随机源。）

参数：
keysize - 密钥大小。这是特定于算法的一种规格，是以位数为单位指定的。
抛出：
InvalidParameterException - 如果密钥大小错误或不受支持。

init

public final void init(int keysize,
                       SecureRandom random)
使用用户提供的随机源初始化此密钥生成器，使其具有确定的密钥大小。

参数：
keysize - 密钥大小。这是特定于算法的一种规格，是以位数为单位指定的。
random - 此密钥生成器的随机源
抛出：
InvalidParameterException - 如果密钥大小错误或不受支持。

generateKey

public final SecretKey generateKey()
生成一个密钥。

返回：
新的密钥
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyGeneratorSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 KeyGeneratorSpi

java.lang.Object
    继承者  javax.crypto.KeyGeneratorSpi

public abstract class KeyGeneratorSpi
extends Object

此类为 KeyGenerator 类定义了服务提供者接口 (SPI)。每个希望为特定算法提供密钥生成器实现的加密服务提供者都必须实现此类中的所有抽象方法。

从以下版本开始：
1.4
另请参见：
SecretKey

构造方法摘要
KeyGeneratorSpi()
方法摘要
protected abstract SecretKey | engineGenerateKey() 生成一个秘密密钥。
protected abstract void | engineInit(AlgorithmParameterSpec params, SecureRandom random) 用指定参数集和用户提供的随机源初始化密钥生成器。
protected abstract void | engineInit(int keysize, SecureRandom random) 使用给定随机源初始化此密钥生成器，以获取确定的密钥长度。
protected abstract void | engineInit(SecureRandom random) 初始化该密钥生成器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyGeneratorSpi

public KeyGeneratorSpi()
方法详细信息

engineInit

protected abstract void engineInit(SecureRandom random)
初始化该密钥生成器。

参数：
random - 此生成器的随机源

engineInit

protected abstract void engineInit(AlgorithmParameterSpec params,
                                   SecureRandom random)
                            throws InvalidAlgorithmParameterException
用指定参数集和用户提供的随机源初始化密钥生成器。

参数：
params - 密钥生成参数
random - 此密钥生成器的随机源
抛出：
InvalidAlgorithmParameterException - 如果 params 不适合此密钥生成器

engineInit

protected abstract void engineInit(int keysize,
                                   SecureRandom random)
使用给定随机源初始化此密钥生成器，以获取确定的密钥长度。

参数：
keysize - 密钥长度。此长度是特定于算法的一种规格，是按位数指定的。
random - 此密钥生成器的随机源
抛出：
InvalidParameterException - 如果密钥长度错误或不受支持。

engineGenerateKey

protected abstract SecretKey engineGenerateKey()
生成一个秘密密钥。

返回：
新的密钥
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Mac (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 Mac

java.lang.Object
    继承者  javax.crypto.Mac
所有已实现的接口：
Cloneable
public class Mac
extends Object
implements Cloneable

此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。

MAC 基于秘密密钥提供一种方式来检查在不可靠介质上进行传输或存储的信息的完整性。通常，消息验证码在共享秘密密钥的两个参与者之间使用，以验证这两者之间传输的信息。

基于加密哈希函数的 MAC 机制也叫作 HMAC。结合秘密共享密钥，HMAC 可以用于任何加密哈希函数（如 MD5 或 SHA-1）。HMAC 在 RFC 2104 中指定。

从以下版本开始：
1.4

构造方法摘要
protected Mac(MacSpi macSpi, Provider provider, String algorithm)
创建一个 MAC 对象。
方法摘要
Object | clone() 如果提供者实现可以复制，则返回一个副本。
byte[] | doFinal() 完成 MAC 操作。
byte[] | doFinal(byte[] input) 处理给定的 byte 数组并完成 MAC 操作。
void | doFinal(byte[] output, int outOffset) 完成 MAC 操作。
String | getAlgorithm() 返回此 Mac 对象的算法名称。
static Mac | getInstance(String algorithm) 返回实现指定 MAC 算法的 Mac 对象。
static Mac | getInstance(String algorithm, Provider provider) 返回实现指定 MAC 算法的 Mac 对象。
static Mac | getInstance(String algorithm, String provider) 返回实现指定 MAC 算法的 Mac 对象。
int | getMacLength() 返回 MAC 的长度，以字节为单位。
Provider | getProvider() 返回此 Mac 对象的提供者。
void | init(Key key) 用给定的密钥初始化此 Mac 对象。
void | init(Key key, AlgorithmParameterSpec params) 用给定的密钥和算法参数初始化此 Mac 对象。
void | reset() 重置此 Mac 对象。
void | update(byte input) 处理给定的字节。
void | update(byte[] input) 处理给定的 byte 数组。
void | update(byte[] input, int offset, int len) 从 offset（包含）开始，处理 input 中的前 len 个字节。
void | update(ByteBuffer input) 从 input.position() 开始，处理 ByteBuffer input 中的 input.remaining() 个字节。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Mac

protected Mac(MacSpi macSpi,
              Provider provider,
              String algorithm)
创建一个 MAC 对象。

参数：
macSpi - 代理
provider - 提供者
algorithm - 算法
方法详细信息

getAlgorithm

public final String getAlgorithm()
返回此 Mac 对象的算法名称。

此名称与创建此 Mac 对象的 getInstance 调用之一中指定的名称相同。

返回：
此 Mac 对象的算法名称。

getInstance

public static final Mac getInstance(String algorithm)
                             throws NoSuchAlgorithmException
返回实现指定 MAC 算法的 Mac 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 MacSpi 实现的新 Mac 对象，该实现取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求 MAC 算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
返回：
新的 Mac 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 MacSpi 实现。
另请参见：
Provider

getInstance

public static final Mac getInstance(String algorithm,
                                    String provider)
                             throws NoSuchAlgorithmException,
                                    NoSuchProviderException
返回实现指定 MAC 算法的 Mac 对象。

返回一个封装 MacSpi 实现的新 Mac 对象，该实现自指定的提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求 MAC 算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者的名称。
返回：
新的 Mac 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 MacSpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static final Mac getInstance(String algorithm,
                                    Provider provider)
                             throws NoSuchAlgorithmException
返回实现指定 MAC 算法的 Mac 对象。

返回一个封装 MacSpi 实现的新 Mac 对象，该实现取自指定的 Provider 对象。注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求 MAC 算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者。
返回：
新的 Mac 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定 Provider 对象获得指定算法的 MacSpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 Mac 对象的提供者。

返回：
此 Mac 对象的提供者。

getMacLength

public final int getMacLength()
返回 MAC 的长度，以字节为单位。

返回：
MAC 长度，以字节为单位。

init

public final void init(Key key)
                throws InvalidKeyException
用给定的密钥初始化此 Mac 对象。

参数：
key - 密钥。
抛出：
InvalidKeyException - 如果给定密钥不适合初始化此 MAC。

init

public final void init(Key key,
                       AlgorithmParameterSpec params)
                throws InvalidKeyException,
                       InvalidAlgorithmParameterException
用给定的密钥和算法参数初始化此 Mac 对象。

参数：
key - 密钥。
params - 算法参数。
抛出：
InvalidKeyException - 如果给定密钥不适合初始化此 MAC。
InvalidAlgorithmParameterException - 如果给定算法参数不适合此 MAC。

update

public final void update(byte input)
                  throws IllegalStateException
处理给定的字节。

参数：
input - 要处理的输入字节。
抛出：
IllegalStateException - 如果尚未初始化此 Mac。

update

public final void update(byte[] input)
                  throws IllegalStateException
处理给定的 byte 数组。

参数：
input - 要处理的 byte 数组。
抛出：
IllegalStateException - 如果尚未初始化此 Mac。

update

public final void update(byte[] input,
                         int offset,
                         int len)
                  throws IllegalStateException
从 offset（包含）开始，处理 input 中的前 len 个字节。

参数：
input - 输入缓冲区。
offset - input 中输入起始处的偏移量。
len - 要处理的字节数。
抛出：
IllegalStateException - 如果尚未初始化此 Mac。

update

public final void update(ByteBuffer input)
从 input.position() 开始，处理 ByteBuffer input 中的 input.remaining() 个字节。返回时，缓冲区的位置将等于其限制；其限制不变。

参数：
input - ByteBuffer
抛出：
IllegalStateException - 如果尚未初始化此 Mac。
从以下版本开始：
1.5

doFinal

public final byte[] doFinal()
                     throws IllegalStateException
完成 MAC 操作。

对此方法的调用将此 Mac 对象重置为上一次调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 初始化的状态。也就是说，该对象被重置，并可通过重新调用 update 和 doFinal（如果需要）从同一个密钥生成另一个 MAC。（若要用不同的密钥重用此 Mac 对象，则必须通过调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 对其重新初始化）。

返回：
MAC 的结果。
抛出：
IllegalStateException - 如果尚未初始化此 Mac。

doFinal

public final void doFinal(byte[] output,
                          int outOffset)
                   throws ShortBufferException,
                          IllegalStateException
完成 MAC 操作。

对此方法的调用将此 Mac 对象重置为上一次调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 初始化的状态。也就是说，该对象被重置，并可通过重新调用 update 和 doFinal（如果需要）从同一个密钥生成另一个 MAC。（若要用不同的密钥重用此 Mac 对象，则必须通过调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 对其重新初始化）。

MAC 结果将存储在 output 中，从 outputOffset（包含）开始。

参数：
output - 存储 MAC 结果的缓冲区
outOffset - output 中存储 MAC 处的偏移量
抛出：
ShortBufferException - 如果给定输出缓冲区太小不能存储该结果
IllegalStateException - 如果尚未初始化此 Mac。

doFinal

public final byte[] doFinal(byte[] input)
                     throws IllegalStateException
处理给定的 byte 数组并完成 MAC 操作。

对此方法的调用将此 Mac 对象重置为上一次调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 初始化的状态。也就是说，该对象被重置，并可通过重新调用 update 和 doFinal（如果需要）从同一个密钥生成另一个 MAC。（若要用不同的密钥重用此 Mac 对象，则必须通过调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 对其重新初始化）。

参数：
input - 字节中的数据
返回：
MAC 的结果。
抛出：
IllegalStateException - 如果尚未初始化此 Mac。

reset

public final void reset()
重置此 Mac 对象。

对此方法的调用将此 Mac 对象重置为上一次调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 初始化的状态。也就是说，该对象被重置，并可通过重新调用 update 和 doFinal（如果需要）从同一个密钥生成另一个 MAC。（若要用不同的密钥重用此 Mac 对象，则必须通过调用 init(Key) 或 init(Key, AlgorithmParameterSpec) 对其重新初始化）。

clone

public final Object clone()
                   throws CloneNotSupportedException
如果提供者实现可以复制，则返回一个副本。

覆盖：
类 Object 中的 clone
返回：
如果提供者实现可以复制，则返回一个副本。
抛出：
CloneNotSupportedException - 如果对不支持 Cloneable 的代理调用此方法。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MacSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 MacSpi

java.lang.Object
    继承者  javax.crypto.MacSpi

public abstract class MacSpi
extends Object

此类为 Mac 类定义服务提供者接口 (SPI)。 此类中的所有抽象方法都必须由每个希望提供实现特定 MAC 算法的加密服务提供者实现。

该实现可以随意实现 Cloneable 接口。

从以下版本开始：
1.4

构造方法摘要
MacSpi()
方法摘要
Object | clone() 如果此实现可以复制，则返回一个副本。
protected abstract byte[] | engineDoFinal() 完成 MAC 计算并且重新设置 MAC 以便进一步使用，维护 MAC 初始化所用的秘密密钥。
protected abstract int | engineGetMacLength() 返回以字节为单位的 MAC 的长度。
protected abstract void | engineInit(Key key, AlgorithmParameterSpec params) 用给定的（秘密）密钥和算法参数初始化 MAC。
protected abstract void | engineReset() 为了进一步使用而重新设置 MAC，维护 MAC 初始化所用的秘密密钥。
protected abstract void | engineUpdate(byte input) 处理给定的字节。
protected abstract void | engineUpdate(byte[] input, int offset, int len) 从 offset 开始处（包含），处理 input 中的前len 个字节。
protected void | engineUpdate(ByteBuffer input) 从 input.position() 开始处，处理 ByteBuffer input 中的 input.remaining() 字节。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MacSpi

public MacSpi()
方法详细信息

engineGetMacLength

protected abstract int engineGetMacLength()
返回以字节为单位的 MAC 的长度。

返回：
以字节为单位的 MAC 长度。

engineInit

protected abstract void engineInit(Key key,
                                   AlgorithmParameterSpec params)
                            throws InvalidKeyException,
                                   InvalidAlgorithmParameterException
用给定的（秘密）密钥和算法参数初始化 MAC。

参数：
key - （秘密）密钥。
params - 算法参数。
抛出：
InvalidKeyException - 如果给定密钥不适合初始化此 MAC。
InvalidAlgorithmParameterException - 如果给定算法参数不适合此 MAC。

engineUpdate

protected abstract void engineUpdate(byte input)
处理给定的字节。

参数：
input - 要处理的输入字节。

engineUpdate

protected abstract void engineUpdate(byte[] input,
                                     int offset,
                                     int len)
从 offset 开始处（包含），处理 input 中的前len 个字节。

参数：
input - 输入缓冲区。
offset - input 中输入开始处的偏移量。
len - 要处理的字节数。

engineUpdate

protected void engineUpdate(ByteBuffer input)
从 input.position() 开始处，处理 ByteBuffer input 中的 input.remaining() 字节。 返回时，缓冲区的位置将等于其限制；其限制并未改变。

如果能够比byte数组更有效地处理 ByteBuffer，子类应考虑重写此方法。

参数：
input - ByteBuffer
从以下版本开始：
1.5

engineDoFinal

protected abstract byte[] engineDoFinal()
完成 MAC 计算并且重新设置 MAC 以便进一步使用，维护 MAC 初始化所用的秘密密钥。

返回：
MAC 的结果。

engineReset

protected abstract void engineReset()
为了进一步使用而重新设置 MAC，维护 MAC 初始化所用的秘密密钥。

clone

public Object clone()
             throws CloneNotSupportedException
如果此实现可以复制，则返回一个副本。

覆盖：
类 Object 中的 clone
返回：
如果此实现可以复制，则返回一个副本。
抛出：
CloneNotSupportedException - 如果调用一个不支持 Cloneable 的实现。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchPaddingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 NoSuchPaddingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.crypto.NoSuchPaddingException
所有已实现的接口：
Serializable
public class NoSuchPaddingException
extends GeneralSecurityException

当请求特定填充机制但该环境中未提供时，抛出此异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
NoSuchPaddingException()
构造不带详细消息的 NoSuchPaddingException。
NoSuchPaddingException(String msg)
构造带指定详细消息的 NoSuchPaddingException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchPaddingException

public NoSuchPaddingException()
构造不带详细消息的 NoSuchPaddingException。详细消息是描述此特定异常的String。

NoSuchPaddingException

public NoSuchPaddingException(String msg)
构造带指定详细消息的 NoSuchPaddingException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NullCipher (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 NullCipher

java.lang.Object
    继承者  javax.crypto.Cipher
        继承者  javax.crypto.NullCipher

public class NullCipher
extends Cipher

NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。因此，密码文本与纯文本相同。将块大小设置为 1 个字节时，所有初始化方法都不执行任何操作。

从以下版本开始：
1.4

字段摘要
从类 javax.crypto.Cipher 继承的字段
DECRYPT_MODE, ENCRYPT_MODE, PRIVATE_KEY, PUBLIC_KEY, SECRET_KEY, UNWRAP_MODE, WRAP_MODE
构造方法摘要
NullCipher()
方法摘要
从类 javax.crypto.Cipher 继承的方法
doFinal, doFinal, doFinal, doFinal, doFinal, doFinal, doFinal, getAlgorithm, getBlockSize, getExemptionMechanism, getInstance, getInstance, getInstance, getIV, getMaxAllowedKeyLength, getMaxAllowedParameterSpec, getOutputSize, getParameters, getProvider, init, init, init, init, init, init, init, init, unwrap, update, update, update, update, update, wrap
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NullCipher

public NullCipher()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SealedObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 SealedObject

java.lang.Object
    继承者  javax.crypto.SealedObject
所有已实现的接口：
Serializable
public class SealedObject
extends Object
implements Serializable

此类使程序员能够用加密算法创建对象并保护其机密性。

在给定任何 Serializable 对象的情况下，程序员可以序列化格式（即“深层复制”）封装原始对象的 SealedObject，并使用 DES 一类的加密算法密封（加密）其序列化的内容，以保护其机密性。加密的内容以后可以解密（使用相应的算法和正确的解密密钥）和反序列化，并生成原始对象。

注意，该 Cipher 对象在应用于 SealedObject 之前必须使用正确的算法、密钥、填充方案等进行完全初始化。

已密封的原始对象可以用以下两种不同的方式恢复：

  • 使用采用 Cipher 对象的 getObject 方法。

    此方法需要一个完全初始化的 Cipher 对象，用极其相同、用来密封对象的算法、密钥、填充方案等进行初始化。

    这样做的好处是解封密封对象的一方不需要知道解密密钥。例如，一方用所需的解密密钥初始化 cipher 对象之后，它就会将 cipher 对象移交给以后要解封密封对象的另一方。

  • 使用采用 Key 对象的 getObject 方法。

    在此方法中，getObject 方法创建一个用于适当解密算法的 cipher 对象，并用给定的解密密钥和存储在密封对象中的算法参数（如果有）对其进行初始化。

    这样做的好处是解封此对象的一方不需要跟踪用来密封该对象的参数（如 IV）。

从以下版本开始：
1.4
另请参见：
Cipher, 序列化表格

字段摘要
protected  byte[] encodedParams
由密封 Cipher 使用的加密参数，以默认格式进行编码。
构造方法摘要
protected | SealedObject(SealedObject so) 根据传入的 SealedObject 构造一个 SealedObject 对象。
 | SealedObject(Serializable object, Cipher c) 从任何 Serializable 对象构造一个 SealedObject。
方法摘要
String | getAlgorithm() 返回用于密封此对象的算法。
Object | getObject(Cipher c) 获取原始（封装的）对象。
Object | getObject(Key key) 获取原始（封装的）对象。
Object | getObject(Key key, String provider) 获取原始（封装的）对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

encodedParams

protected byte[] encodedParams
由密封 Cipher 使用的加密参数，以默认格式进行编码。

即 cipher.getParameters().getEncoded()。

构造方法详细信息

SealedObject

public SealedObject(Serializable object,
                    Cipher c)
             throws IOException,
                    IllegalBlockSizeException
从任何 Serializable 对象构造一个 SealedObject。

序列化给定的对象，并使用给定的 Cipher 加密其序列化的内容，其必须完全序列化。

在加密操作中可能使用到的所有算法参数都存储在新的 SealedObject 内。

参数：
object - 要密封的对象；可以为 null。
c - 用于密封对象的密码。
抛出：
NullPointerException - 如果给定的密码为 null。
IOException - 如果在序列化过程中发生错误
IllegalBlockSizeException - 如果给定的密码是块密码、或者该块密码不需要填充，或者总输入长度（即序列化对象内容的长度）不是该密码的块大小的倍数

SealedObject

protected SealedObject(SealedObject so)
根据传入的 SealedObject 构造一个 SealedObject 对象。

参数：
so - SealedObject 对象
抛出：
NullPointerException - 如果给定的密封对象为 null。
方法详细信息

getAlgorithm

public final String getAlgorithm()
返回用于密封此对象的算法。

返回：
用于密封此对象的算法。

getObject

public final Object getObject(Key key)
                       throws IOException,
                              ClassNotFoundException,
                              NoSuchAlgorithmException,
                              InvalidKeyException
获取原始（封装的）对象。

此方法为密封操作中已使用的算法创建一个密码。如果默认提供者包提供该算法的一个实现，则使用一个包含该实现的 Cipher 实例。如果在默认的包中未提供该算法，则将搜索其他的包。使用给定的 key 和密封操作中已使用的参数（如果有）初始化用于解密的 Cipher 对象。

在返回已封装的对象之前将其解封和反序列化。

参数：
key - 用于解封对象的密钥。
返回：
原始对象。
抛出：
IOException - 如果在反序列化过程中发生错误。
ClassNotFoundException - 如果在反序列化过程中发生错误。
NoSuchAlgorithmException - 如果解封对象的算法不可用。
InvalidKeyException - 如果无法使用给定密钥解封对象（例如其算法错误）。
NullPointerException - 如果 key 为 null。

getObject

public final Object getObject(Cipher c)
                       throws IOException,
                              ClassNotFoundException,
                              IllegalBlockSizeException,
                              BadPaddingException
获取原始（封装的）对象。

在返回已封装的对象之前将其解封（使用给定的 Cipher，假定该 Cipher 已正确初始化）和反序列化。

参数：
c - 用于解封该对象的密码
返回：
原始对象。
抛出：
NullPointerException - 如果给定的密码为 null。
IOException - 如果反序列化过程中发生错误
ClassNotFoundException - 如果在反序列化过程中发生错误
IllegalBlockSizeException - 如果给定密码是块密码、或者不需要填充该块密码，或者总输入长度不是该密码块大小的倍数
BadPaddingException - 如果已初始化用于解密的给定密码，并且指定了填充，但输入数据没有适当的所需填充字节

getObject

public final Object getObject(Key key,
                              String provider)
                       throws IOException,
                              ClassNotFoundException,
                              NoSuchAlgorithmException,
                              NoSuchProviderException,
                              InvalidKeyException
获取原始（封装的）对象。

此方法使用给定 provider 中的算法的实现，为密封操作中已使用的此算法创建一个密码。使用给定的 key 和密封操作中已使用的参数（如果有）初始化用于解密的 Cipher 对象。

返回已封装的对象之前将其解封和反序列化。

参数：
key - 用于解封对象的密钥。
provider - 要解封对象的算法的提供者名称。
返回：
原始对象。
抛出：
IllegalArgumentException - 如果给定提供者为 null 或空。
IOException - 如果在反序列化过程中发生错误。
ClassNotFoundException - 如果在反序列化过程中发生错误。
NoSuchAlgorithmException - 如果解封对象的算法不可用。
NoSuchProviderException - 如果未配置给定提供者。
InvalidKeyException - 如果无法使用给定密钥解封对象（例如其算法错误）。
NullPointerException - 如果 key 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecretKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
接口 SecretKey

所有超级接口：
Key, Serializable
所有已知子接口：
PBEKey
所有已知实现类：
KerberosKey, SecretKeySpec
public interface SecretKey
extends Key

秘密（对称）密钥。

此接口不包含方法或常量。其唯一目的是分组秘密密钥（并为其提供类型安全）。

此接口的提供者实现必须改写继承自 java.lang.Object 的 equals 和 hashCode 方法，以便根据底层密钥材料而不是根据引用进行秘密密钥比较。

实现此接口的密钥以其编码格式（请参阅 getFormat）返回字符串 RAW，并返回作为 getEncoded 方法调用结果的原始密钥字节。（getFormat 和 getEncoded 方法继承自 java.security.Key 父接口。）

从以下版本开始：
1.4
另请参见：
SecretKeyFactory, Cipher

字段摘要
static long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
方法摘要
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecretKeyFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 SecretKeyFactory

java.lang.Object
    继承者  javax.crypto.SecretKeyFactory

public class SecretKeyFactory
extends Object

此类表示秘密密钥的工厂。

密钥工厂用来将密钥（类型 Key 的不透明加密密钥）转换为密钥规范（底层密钥材料的透明表示形式），反之亦然。秘密密钥工厂只对秘密（对称）密钥进行操作。

密钥工厂为双工模式，即其允许根据给定密钥规范（密钥材料）构建不透明密钥对象，或以适当格式获取密钥对象的底层密钥材料。

应用程序开发人员应参阅其提供者文档，找出 generateSecret 和 getKeySpec 方法所支持的密钥规范。例如，"SunJCE" 提供者提供的 DES 秘密密钥工厂支持 DESKeySpec 作为 DES 密钥的透明表示形式，并且该提供者的 Triple DES 密钥的秘密密钥工厂支持 DESedeKeySpec 作为 Triple DES 密钥的透明表示形式。

从以下版本开始：
1.4
另请参见：
SecretKey, DESKeySpec, DESedeKeySpec, PBEKeySpec

构造方法摘要
protected SecretKeyFactory(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 SecretKeyFactory 对象。
方法摘要
SecretKey | generateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
String | getAlgorithm() 返回此 SecretKeyFactory 对象的算法名称。
static SecretKeyFactory | getInstance(String algorithm) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static SecretKeyFactory | getInstance(String algorithm, Provider provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static SecretKeyFactory | getInstance(String algorithm, String provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
KeySpec | getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。
Provider | getProvider() 返回此 SecretKeyFactory 对象的提供者。
SecretKey | translateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecretKeyFactory

protected SecretKeyFactory(SecretKeyFactorySpi keyFacSpi,
                           Provider provider,
                           String algorithm)
创建一个 SecretKeyFactory 对象。

参数：
keyFacSpi - 委托
provider - 提供者
algorithm - 秘密密钥算法
方法详细信息

getInstance

public static final SecretKeyFactory getInstance(String algorithm)
                                          throws NoSuchAlgorithmException
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 SecretKeyFactorySpi 实现的新 SecretKeyFactory 对象，该实现取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求的秘密密钥算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
返回：
新的 SecretKeyFactory 对象。
抛出：
NullPointerException - 如果指定的算法为 null。
NoSuchAlgorithmException - 如果没有任何 Provider 支持指定算法的 SecretKeyFactorySpi 实现。
另请参见：
Provider

getInstance

public static final SecretKeyFactory getInstance(String algorithm,
                                                 String provider)
                                          throws NoSuchAlgorithmException,
                                                 NoSuchProviderException
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

返回一个封装 SecretKeyFactorySpi 实现的新 SecretKeyFactory 对象，该实现取自指定的提供者。指定提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求的秘密密钥算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者的名称。
返回：
新的 SecretKeyFactory 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 SecretKeyFactorySpi 实现。
NullPointerException - 如果指定的算法为 null。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果 provider 为 null 或空。
另请参见：
Provider

getInstance

public static final SecretKeyFactory getInstance(String algorithm,
                                                 Provider provider)
                                          throws NoSuchAlgorithmException
返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

返回一个封装 SecretKeyFactorySpi 实现的新 SecretKeyFactory 对象，该实现取自指定的 Provider 对象。注意，指定 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求的秘密密钥算法的标准名称。有关标准算法名称的信息，请参阅 Java Cryptography Architecture Reference Guide 中的附录 A。
provider - 提供者。
返回：
新的 SecretKeyFactory 对象。
抛出：
NullPointerException - 如果指定的算法为 null。
NoSuchAlgorithmException - 如果不能从指定的 Provider 对象获得指定算法的 SecretKeyFactorySpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 SecretKeyFactory 对象的提供者。

返回：
此 SecretKeyFactory 对象的提供者

getAlgorithm

public final String getAlgorithm()
返回此 SecretKeyFactory 对象的算法名称。

此名称与在某个创建此 SecretKeyFactory 对象的 getInstance 调用中指定的名称相同。

返回：
此 SecretKeyFactory 对象的算法名称。

generateSecret

public final SecretKey generateSecret(KeySpec keySpec)
                               throws InvalidKeySpecException
根据提供的密钥规范（密钥材料）生成 SecretKey 对象。

参数：
keySpec - 秘密密钥的规范（密钥材料）
返回：
秘密密钥
抛出：
InvalidKeySpecException - 如果给定密钥规范不适合生成秘密密钥的秘密密钥工厂。

getKeySpec

public final KeySpec getKeySpec(SecretKey key,
                                Class keySpec)
                         throws InvalidKeySpecException
以请求的格式返回给定密钥对象的规范（密钥材料）。

参数：
key - 密钥
keySpec - 所请求的格式，密钥材料将以此格式返回
返回：
所请求格式的底层密钥规范（密钥材料）
抛出：
InvalidKeySpecException - 如果所请求的密钥规范不适合给定的密钥（例如，与 key 和 keySpec 关联的算法不匹配，或者 key 在加密硬件设备上引用一个密钥而 keySpec 是基于软件的密钥规范），或者无法处理给定的密钥（例如，给定的密钥具有此秘密密钥工厂不支持的算法或格式）。

translateKey

public final SecretKey translateKey(SecretKey key)
                             throws InvalidKeyException
将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。

参数：
key - 其提供者未知或不受信任的密钥
返回：
已转换的密钥
抛出：
InvalidKeyException - 如果此秘密密钥工厂无法处理给定的密钥。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecretKeyFactorySpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 SecretKeyFactorySpi

java.lang.Object
    继承者  javax.crypto.SecretKeyFactorySpi

public abstract class SecretKeyFactorySpi
extends Object

此类定义 SecretKeyFactory 类的服务提供者接口 (SPI)。此类中的所有抽象方法必须由希望为特定算法提供秘密密钥工厂实现的各个加密服务提供者来实现。

提供者应当对其秘密密钥工厂支持的所有密钥规范加以注释。例如，"SunJCE" 提供者提供的 DES 秘密密钥工厂支持 DESKeySpec 作为 DES 密钥的透明表示形式，并且该提供者的 Triple DES 密钥的秘密密钥工厂支持 DESedeKeySpec 作为 Triple DES 密钥的透明表示形式。

从以下版本开始：
1.4
另请参见：
SecretKey, DESKeySpec, DESedeKeySpec

构造方法摘要
SecretKeyFactorySpi()
方法摘要
protected abstract SecretKey | engineGenerateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
protected abstract KeySpec | engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
protected abstract SecretKey | engineTranslateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecretKeyFactorySpi

public SecretKeyFactorySpi()
方法详细信息

engineGenerateSecret

protected abstract SecretKey engineGenerateSecret(KeySpec keySpec)
                                           throws InvalidKeySpecException
根据提供的密钥规范（密钥材料）生成 SecretKey 对象。

参数：
keySpec - 秘密密钥的规范（密钥材料）
返回：
秘密密钥
抛出：
InvalidKeySpecException - 如果给定密钥规范不适合生成秘密密钥的秘密密钥工厂。

engineGetKeySpec

protected abstract KeySpec engineGetKeySpec(SecretKey key,
                                            Class keySpec)
                                     throws InvalidKeySpecException
以所需格式返回给定密钥对象的规范（密钥材料）。

参数：
key - 密钥
keySpec - 返回密钥材料的所需格式
返回：
以所需格式返回底层密钥规范（密钥材料）
抛出：
InvalidKeySpecException - 如果所需密钥规范不适合给定的密钥（例如，与 key 和 keySpec 相关的算法不匹配，或者 key 在加密硬件设备上引用一个密钥而 keySpec 是基于软件的密钥规范），或者无法处理给定的密钥（例如，给定的密钥具有此秘密密钥工厂不支持的算法或格式）。

engineTranslateKey

protected abstract SecretKey engineTranslateKey(SecretKey key)
                                         throws InvalidKeyException
将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。

参数：
key - 其提供者未知或不受信任的密钥
返回：
已转换的密钥
抛出：
InvalidKeyException - 如果此秘密密钥工厂无法处理给定的密钥。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShortBufferException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.crypto
类 ShortBufferException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.crypto.ShortBufferException
所有已实现的接口：
Serializable
public class ShortBufferException
extends GeneralSecurityException

当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ShortBufferException()
构造不带详细信息的 ShortBufferException。
ShortBufferException(String msg)
构造带指定详细信息的 ShortBufferException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ShortBufferException

public ShortBufferException()
构造不带详细信息的 ShortBufferException。详细消息是描述此特定异常的String。

ShortBufferException

public ShortBufferException(String msg)
构造带指定详细信息的 ShortBufferException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.crypto (Java 2 Platform SE 6)

 javax.crypto
接口
SecretKey
类
Cipher
CipherInputStream
CipherOutputStream
CipherSpi
EncryptedPrivateKeyInfo
ExemptionMechanism
ExemptionMechanismSpi
KeyAgreement
KeyAgreementSpi
KeyGenerator
KeyGeneratorSpi
Mac
MacSpi
NullCipher
SealedObject
SecretKeyFactory
SecretKeyFactorySpi
异常
BadPaddingException
ExemptionMechanismException
IllegalBlockSizeException
NoSuchPaddingException
ShortBufferException


javax.crypto (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.crypto

为加密操作提供类和接口。

请参见：
描述

接口摘要
SecretKey 秘密（对称）密钥。

类摘要
Cipher | 此类为加密和解密提供密码功能。
CipherInputStream | CipherInputStream 由一个 InputStream 和一个 Cipher 组成，这样 read() 方法才能返回从底层 InputStream 读入但已经由该 Cipher 另外处理过的数据。
CipherOutputStream | CipherOutputStream 由一个 OutputStream 和一个 Cipher 组成，这样 write() 方法才能在将数据写出到底层 OutputStream 之前先对该数据进行处理。
CipherSpi | 此类为 Cipher 类定义了服务提供者接口 (SPI)。
EncryptedPrivateKeyInfo | 此类实现 EncryptedPrivateKeyInfo 类型，如在 PKCS #8 中定义的那样。
ExemptionMechanism | 此类提供了豁免 (exemption) 机制的功能，例如，密钥恢复、密钥唤醒 和密钥托管。
ExemptionMechanismSpi | 此类为 ExemptionMechanism 类定义了服务提供者接口 (SPI)。
KeyAgreement | 此类提供密钥协定（或密钥交换）协议的功能。
KeyAgreementSpi | 此类为 KeyAgreement 类定义了服务提供者接口 (SPI)。
KeyGenerator | 此类提供（对称）密钥生成器的功能。
KeyGeneratorSpi | 此类为 KeyGenerator 类定义了服务提供者接口 (SPI)。
Mac | 此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。
MacSpi | 此类为 Mac 类定义服务提供者接口 (SPI)。
NullCipher | NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。
SealedObject | 此类使程序员能够用加密算法创建对象并保护其机密性。
SecretKeyFactory | 此类表示秘密密钥的工厂。
SecretKeyFactorySpi | 此类定义 SecretKeyFactory 类的服务提供者接口 (SPI)。

异常摘要
BadPaddingException | 当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
ExemptionMechanismException | 此为一般 ExemptionMechanism 异常。
IllegalBlockSizeException | 如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
NoSuchPaddingException | 当请求特定填充机制但该环境中未提供时，抛出此异常。
ShortBufferException | 当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

软件包 javax.crypto 的描述

为加密操作提供类和接口。在此包中定义的加密操作包括加密、密钥生成和密钥协商，以及消息验证码（Message Authentication Code，MAC）生成。

加密支持包括对称密码、不对称密码、块密码和流密码。此包还支持安全流和密封的对象。

此包中提供的许多类都是基于提供者的。该类本身定义可以写入应用程序的编程接口。然后可由独立的第三方供应商编写实现本身，并根据需要无缝嵌入。因此，应用程序开发人员可以利用任意数量的基于提供者的实现，而无需添加或重写代码。

相关文档

有关更多文档信息，请参阅：
  • JavaTM Cryptography Architecture API Specification and Reference
  • How to Implement a Provider for the JavaTM Cryptography Architecture

从以下版本开始：
JCE1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.crypto 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.crypto 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.crypto.Cipher
      • javax.crypto.NullCipher
    • javax.crypto.CipherSpi
    • javax.crypto.EncryptedPrivateKeyInfo
    • javax.crypto.ExemptionMechanism
    • javax.crypto.ExemptionMechanismSpi
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • javax.crypto.CipherInputStream
    • javax.crypto.KeyAgreement
    • javax.crypto.KeyAgreementSpi
    • javax.crypto.KeyGenerator
    • javax.crypto.KeyGeneratorSpi
    • javax.crypto.Mac (implements java.lang.Cloneable)
    • javax.crypto.MacSpi
    • java.io.OutputStream (implements java.io.Closeable, java.io.Flushable)
      • java.io.FilterOutputStream
        • javax.crypto.CipherOutputStream
    • javax.crypto.SealedObject (implements java.io.Serializable)
    • javax.crypto.SecretKeyFactory
    • javax.crypto.SecretKeyFactorySpi
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.crypto.BadPaddingException
          • javax.crypto.ExemptionMechanismException
          • javax.crypto.IllegalBlockSizeException
          • javax.crypto.NoSuchPaddingException
          • javax.crypto.ShortBufferException

接口分层结构

  • java.io.Serializable
    • java.security.Key
      • javax.crypto.SecretKey
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.crypto 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.crypto
的使用

使用 javax.crypto 的软件包
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

java.security 使用的 javax.crypto 中的类
SecretKey
秘密（对称）密钥。

javax.crypto 使用的 javax.crypto 中的类
BadPaddingException
当输入数据期望特定的填充机制而数据又未正确填充时，抛出此异常。
Cipher
此类为加密和解密提供密码功能。
CipherSpi
此类为 Cipher 类定义了服务提供者接口 (SPI)。
ExemptionMechanism
此类提供了豁免 (exemption) 机制的功能，例如，密钥恢复、密钥唤醒 和密钥托管。
ExemptionMechanismException
此为一般 ExemptionMechanism 异常。
ExemptionMechanismSpi
此类为 ExemptionMechanism 类定义了服务提供者接口 (SPI)。
IllegalBlockSizeException
如果提供给块密码的数据长度不正确（即与密码的块大小不匹配），则抛出此异常。
KeyAgreement
此类提供密钥协定（或密钥交换）协议的功能。
KeyAgreementSpi
此类为 KeyAgreement 类定义了服务提供者接口 (SPI)。
KeyGenerator
此类提供（对称）密钥生成器的功能。
KeyGeneratorSpi
此类为 KeyGenerator 类定义了服务提供者接口 (SPI)。
Mac
此类提供“消息验证码”（Message Authentication Code，MAC）算法的功能。
MacSpi
此类为 Mac 类定义服务提供者接口 (SPI)。
NoSuchPaddingException
当请求特定填充机制但该环境中未提供时，抛出此异常。
SealedObject
此类使程序员能够用加密算法创建对象并保护其机密性。
SecretKey
秘密（对称）密钥。
SecretKeyFactory
此类表示秘密密钥的工厂。
SecretKeyFactorySpi
此类定义 SecretKeyFactory 类的服务提供者接口 (SPI)。
ShortBufferException
当用户提供的输出缓冲区太小而不能存储操作结果时，抛出此异常。

javax.crypto.interfaces 使用的 javax.crypto 中的类
SecretKey
秘密（对称）密钥。

javax.crypto.spec 使用的 javax.crypto 中的类
SecretKey
秘密（对称）密钥。

javax.security.auth.kerberos 使用的 javax.crypto 中的类
SecretKey
秘密（对称）密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


DHKey (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.crypto.interfaces
接口 DHKey

所有已知子接口：
DHPrivateKey, DHPublicKey
public interface DHKey

Diffie-Hellman 密钥的接口。

从以下版本开始：
1.4
另请参见：
DHParameterSpec, DHPublicKey, DHPrivateKey

方法摘要
 DHParameterSpec getParams()
返回密钥参数。

方法详细信息

getParams

DHParameterSpec getParams()
返回密钥参数。

返回：
密钥参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DHPrivateKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.interfaces
接口 DHPrivateKey

所有超级接口：
DHKey, Key, PrivateKey, Serializable
public interface DHPrivateKey
extends DHKey, PrivateKey

Diffie-Hellman 私钥接口。

从以下版本开始：
1.4
另请参见：
DHKey, DHPublicKey

字段摘要
static long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
方法摘要
 BigInteger getX()
返回私钥值 x。
从接口 javax.crypto.interfaces.DHKey 继承的方法
getParams
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。

另请参见：
常量字段值
方法详细信息

getX

BigInteger getX()
返回私钥值 x。

返回：
私钥值 x
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DHPublicKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.interfaces
接口 DHPublicKey

所有超级接口：
DHKey, Key, PublicKey, Serializable
public interface DHPublicKey
extends DHKey, PublicKey

Diffie-Hellman 公钥接口。

从以下版本开始：
1.4
另请参见：
DHKey, DHPrivateKey

字段摘要
static long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
方法摘要
 BigInteger getY()
返回公钥值 y。
从接口 javax.crypto.interfaces.DHKey 继承的方法
getParams
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。

另请参见：
常量字段值
方法详细信息

getY

BigInteger getY()
返回公钥值 y。

返回：
公钥值 y
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PBEKey (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.crypto.interfaces
接口 PBEKey

所有超级接口：
Key, SecretKey, Serializable
public interface PBEKey
extends SecretKey

调用者 PBE 密钥接口。

从以下版本开始：
1.4
另请参见：
PBEKeySpec, SecretKey

字段摘要
static long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。
方法摘要
int | getIterationCount() 返回迭代计数；如果未指定，则返回 0。
char[] | getPassword() 返回密码。
byte[] | getSalt() 返回 salt；如果未指定，则返回 null。
从接口 java.security.Key 继承的方法
getAlgorithm, getEncoded, getFormat

字段详细信息

serialVersionUID

static final long serialVersionUID
已设置的类指纹表示从 J2SE 1.4 起连续兼容。

另请参见：
常量字段值
方法详细信息

getPassword

char[] getPassword()
返回密码。

注：此方法应该返回该密码的一个副本。当不再需要密码信息时，调用者负责清空这些信息。

返回：
密码。

getSalt

byte[] getSalt()
返回 salt；如果未指定，则返回 null。

注：此方法应该返回该 salt 的一个副本。当不再需要 salt 信息时，调用者负责清空这些信息。

返回：
该 salt。

getIterationCount

int getIterationCount()
返回迭代计数；如果未指定，则返回 0。

返回：
迭代计数。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.crypto.interfaces (Java 2 Platform SE 6)

 javax.crypto.interfaces
接口
DHKey
DHPrivateKey
DHPublicKey
PBEKey


javax.crypto.interfaces (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.crypto.interfaces

根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。

请参见：
描述

接口摘要
DHKey | Diffie-Hellman 密钥的接口。
DHPrivateKey | Diffie-Hellman 私钥接口。
DHPublicKey | Diffie-Hellman 公钥接口。
PBEKey | 调用者 PBE 密钥接口。

软件包 javax.crypto.interfaces 的描述

根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。

注意，这些接口仅用于其密钥材料可访问并且可用的密钥实现。这些接口不用于其密钥材料驻留在不可访问、受保护的存储器中（如在硬件设备中）的密钥实现。

有关如何使用这些接口的开发人员详细信息（包括如何为硬件设备设计 Key 类的信息），请参阅这些加密提供者开发人员指南：

  • How to Implement a Provider for the JavaTM Cryptography Architecture

包规范

  • PKCS #3: Diffie-Hellman Key-Agreement Standard, Version 1.4, November 1993。

相关文档

有关更多文档信息，请参阅：
  • JavaTM Cryptography Architecture API Specification and Reference

从以下版本开始：
JCE1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.crypto.interfaces 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.crypto.interfaces 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • javax.crypto.interfaces.DHKey
    • javax.crypto.interfaces.DHPrivateKey (并 extends java.security.PrivateKey)
    • javax.crypto.interfaces.DHPublicKey (并 extends java.security.PublicKey)
  • java.io.Serializable
    • java.security.Key
      • java.security.PrivateKey
        • javax.crypto.interfaces.DHPrivateKey (并 extends javax.crypto.interfaces.DHKey)
      • java.security.PublicKey
        • javax.crypto.interfaces.DHPublicKey (并 extends javax.crypto.interfaces.DHKey)
      • javax.crypto.SecretKey
        • javax.crypto.interfaces.PBEKey
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.crypto.interfaces 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.crypto.interfaces
的使用

使用 javax.crypto.interfaces 的软件包
javax.crypto.interfaces 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。

javax.crypto.interfaces 使用的 javax.crypto.interfaces 中的类
DHKey
Diffie-Hellman 密钥的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.crypto.interfaces.DHKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.DHKey
的使用

使用 DHKey 的软件包
javax.crypto.interfaces 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。

javax.crypto.interfaces 中 DHKey 的使用

javax.crypto.interfaces 中 DHKey 的子接口
interface | DHPrivateKey Diffie-Hellman 私钥接口。
interface | DHPublicKey Diffie-Hellman 公钥接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.crypto.interfaces.DHPublicKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.DHPublicKey
的使用

没有 javax.crypto.interfaces.DHPublicKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.crypto.interfaces.DHPrivateKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.DHPrivateKey
的使用

没有 javax.crypto.interfaces.DHPrivateKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.crypto.interfaces.PBEKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.interfaces.PBEKey
的使用

没有 javax.crypto.interfaces.PBEKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


DESedeKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 DESedeKeySpec

java.lang.Object
    继承者  javax.crypto.spec.DESedeKeySpec
所有已实现的接口：
KeySpec
public class DESedeKeySpec
extends Object
implements KeySpec

此类指定一个 DES-EDE ("triple-DES") 密钥。

从以下版本开始：
1.4

字段摘要
static int DES_EDE_KEY_LEN
定义以 byte 为单位的 DESede 密钥长度的常量。
构造方法摘要
DESedeKeySpec(byte[] key)
创建一个 DESedeKeySpec 对象，使用 key 中的前 24 个字节作为 DES-EDE 密钥的密钥内容。
DESedeKeySpec(byte[] key, int offset)
创建一个 DESedeKeySpec 对象，使用 key 中始于且包含 offset 的前 24 个字节作为 DES-EDE 密钥的密钥内容。
方法摘要
byte[] | getKey() 返回 DES-EDE 密钥。
static boolean | isParityAdjusted(byte[] key, int offset) 确定给定的始于且包含 offset 的 DES-EDE 密钥是否是奇偶校验的 (parity-adjusted)。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DES_EDE_KEY_LEN

public static final int DES_EDE_KEY_LEN
定义以 byte 为单位的 DESede 密钥长度的常量。

另请参见：
常量字段值
构造方法详细信息

DESedeKeySpec

public DESedeKeySpec(byte[] key)
              throws InvalidKeyException
创建一个 DESedeKeySpec 对象，使用 key 中的前 24 个字节作为 DES-EDE 密钥的密钥内容。

组成 DES-EDE 密钥的字节在 key[0] 和 key[23] 范围内（包含两者）

参数：
key - 具有 DES-EDE 密钥内容的缓冲区。复制该缓冲区的前 24 个字节来防止后续修改。
抛出：
NullPointerException - 如果 key 为 null。
InvalidKeyException - 如果给定的密钥内容短于 24 个字节。

DESedeKeySpec

public DESedeKeySpec(byte[] key,
                     int offset)
              throws InvalidKeyException
创建一个 DESedeKeySpec 对象，使用 key 中始于且包含 offset 的前 24 个字节作为 DES-EDE 密钥的密钥内容。

组成 DES-EDE 密钥的字节在 key[offset] 和 key[offset+23] 范围内（包含两者）。

参数：
key - 具有 DES-EDE 密钥内容的缓冲区。复制该缓冲区始于且包含 offset 的前 24 个字节来防止后续修改。
offset - key 中的偏移量，DES-EDE 密钥内容从此处开始。
抛出：
NullPointerException - 如果 key 为 null。
InvalidKeyException - 如果给定的始于且包含 offset 的密钥内容短于 24 个字节
方法详细信息

getKey

public byte[] getKey()
返回 DES-EDE 密钥。

返回：
DES-EDE 密钥。每一次调用此方法都返回一个新数组。

isParityAdjusted

public static boolean isParityAdjusted(byte[] key,
                                       int offset)
                                throws InvalidKeyException
确定给定的始于且包含 offset 的 DES-EDE 密钥是否是奇偶校验的 (parity-adjusted)。

参数：
key - 保存密钥值的 byte 数组
offset - byte 数组中的偏移量
返回：
如果 DES-EDE 密钥是奇偶校验的，则返回 true；否则返回 false
抛出：
NullPointerException - 如果 key 为 null。
InvalidKeyException - 如果给定的始于且包含 offset 的密钥内容短于 24 个字节
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DESKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 DESKeySpec

java.lang.Object
    继承者  javax.crypto.spec.DESKeySpec
所有已实现的接口：
KeySpec
public class DESKeySpec
extends Object
implements KeySpec

此类指定一个 DES 密钥。

从以下版本开始：
1.4

字段摘要
static int DES_KEY_LEN
定义以字节为单位的 DES 密钥长度的常量。
构造方法摘要
DESKeySpec(byte[] key)
创建一个 DESKeySpec 对象，使用 key 中的前 8 个字节作为 DES 密钥的密钥内容。
DESKeySpec(byte[] key, int offset)
创建一个 DESKeySpec 对象，使用 key 中始于且包含 offset 的前 8 个字节作为 DES-EDE 密钥的密钥内容。
方法摘要
byte[] | getKey() 返回 DES 密钥内容。
static boolean | isParityAdjusted(byte[] key, int offset) 确定给定的始于且包含 offset 的 DES 密钥内容是否是奇偶校验的 (parity-adjusted)。
static boolean | isWeak(byte[] key, int offset) 确定给定的 DES 密钥内容是否是全弱或者半弱的。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DES_KEY_LEN

public static final int DES_KEY_LEN
定义以字节为单位的 DES 密钥长度的常量。

另请参见：
常量字段值
构造方法详细信息

DESKeySpec

public DESKeySpec(byte[] key)
           throws InvalidKeyException
创建一个 DESKeySpec 对象，使用 key 中的前 8 个字节作为 DES 密钥的密钥内容。

组成 DES 密钥的字节在 key[0] 和 key[7] 范围内（包含两者）

参数：
key - 具有 DES 密钥内容的缓冲区。复制该缓冲区的前 8 个字节来防止后续修改。
抛出：
NullPointerException - 如果给定的密钥内容为 null
InvalidKeyException - 如果给定的密钥内容短于 8 个字节。

DESKeySpec

public DESKeySpec(byte[] key,
                  int offset)
           throws InvalidKeyException
创建一个 DESKeySpec 对象，使用 key 中始于且包含 offset 的前 8 个字节作为 DES-EDE 密钥的密钥内容。

组成 DES 密钥的字节在 key[offset] 和 key[offset+7] 范围内（包含两者）。

参数：
key - 具有 DES 密钥内容的缓冲区。复制该缓冲区始于且包含 offset 的前 8 个字节来防止后续修改。
offset - key 中的偏移量，DES 密钥内容从此处开始。
抛出：
NullPointerException - 如果给定的密钥内容为 null
InvalidKeyException - 如果给定的始于且包含 offset 的密钥内容短于 8 个字节。
方法详细信息

getKey

public byte[] getKey()
返回 DES 密钥内容。

返回：
返回 DES 密钥内容。每一次调用此方法都返回一个新数组。

isParityAdjusted

public static boolean isParityAdjusted(byte[] key,
                                       int offset)
                                throws InvalidKeyException
确定给定的始于且包含 offset 的 DES 密钥内容是否是奇偶校验的 (parity-adjusted)。

参数：
key - 具有 DES 密钥内容的缓冲区。
offset - key 中的偏移量，DES 密钥内容从此处开始。
返回：
如果给定的 DES 密钥内容是奇偶校验的，则返回 true，否则返回 false。
抛出：
InvalidKeyException - 如果给定的密钥内容为 null，或者始于且包含 offset 的密钥内容短于 8 个字节。

isWeak

public static boolean isWeak(byte[] key,
                             int offset)
                      throws InvalidKeyException
确定给定的 DES 密钥内容是否是全弱或者半弱的。

参数：
key - 具有 DES 密钥内容的缓冲区。
offset - key 中的偏移量，DES 密钥内容从此处开始。
返回：
如果给定的 DES 密钥内容是全弱或者半弱的，则返回 true，否则返回 false。
抛出：
InvalidKeyException - 如果给定的密钥内容为 null，或者始于且包含 offset 的密钥内容短于 8 个字节。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DHGenParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 DHGenParameterSpec

java.lang.Object
    继承者  javax.crypto.spec.DHGenParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class DHGenParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。这通常通过一个中央机构完成。

在参数计算完成后，中央机构必须将此消息发送给期望在密钥上达成一致的那一方。

从以下版本开始：
1.4
另请参见：
DHParameterSpec

构造方法摘要
DHGenParameterSpec(int primeSize, int exponentSize)
为生成 Diffie-Hellman（系统）参数构造一个参数集。
方法摘要
int | getExponentSize() 以位为单位返回随机指数的大小（私有值）。
int | getPrimeSize() 以位为单位返回质数模数的大小。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DHGenParameterSpec

public DHGenParameterSpec(int primeSize,
                          int exponentSize)
为生成 Diffie-Hellman（系统）参数构造一个参数集。构造好的参数集可用来初始化一个生成 Diffie-Hellman 参数的 AlgorithmParameterGenerator 对象。

参数：
primeSize - 质数模数的大小（以位为单位）
exponentSize - 随机指数的大小（以位为单位）
方法详细信息

getPrimeSize

public int getPrimeSize()
以位为单位返回质数模数的大小。

返回：
以位为单位的质数模数大小

getExponentSize

public int getExponentSize()
以位为单位返回随机指数的大小（私有值）。

返回：
以位为单位的随机指数的大小（私有值）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DHParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 DHParameterSpec

java.lang.Object
    继承者  javax.crypto.spec.DHParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class DHParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。

一个中央机构生成参数并且把其发送给寻求生成密钥的两个实体。这些参数是：一个主参数 p，一个基参数 g，以及以位为单位的私有值的任意长度 l。

给定的中央机构有可能生成多个参数实例，并且有可能不止一个中央机构。实际上，每一个个体都可能是其自己的中央机构，其具有不同参数的不同实体。

注意，此类不在任何指定的参数上执行任何验证。因此，即使给定的值为 null 也会被直接返回。

从以下版本开始：
1.4
另请参见：
KeyAgreement

构造方法摘要
DHParameterSpec(BigInteger p, BigInteger g)
使用质数模数 p 和基生成器 g 为 Diffie-Hellman 构造一个参数集。
DHParameterSpec(BigInteger p, BigInteger g, int l)
使用质数模数 p、基生成器 g 以及以位为单位的随机指数大小 l（私有值）为 Diffie-Hellman 构造一个参数集。
方法摘要
BigInteger | getG() 返回基生成器 g。
int | getL() 返回以位为单位的随机指数的大小 l（私有值）。
BigInteger | getP() 返回质数模数 p。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DHParameterSpec

public DHParameterSpec(BigInteger p,
                       BigInteger g)
使用质数模数 p 和基生成器 g 为 Diffie-Hellman 构造一个参数集。

参数：
p - 质数模数
g - 基生成器

DHParameterSpec

public DHParameterSpec(BigInteger p,
                       BigInteger g,
                       int l)
使用质数模数 p、基生成器 g 以及以位为单位的随机指数大小 l（私有值）为 Diffie-Hellman 构造一个参数集。

参数：
p - 质数模数
g - 基生成器
l - 以位为单位的随机指数的大小（私有值）
方法详细信息

getP

public BigInteger getP()
返回质数模数 p。

返回：
质数模数 p

getG

public BigInteger getG()
返回基生成器 g。

返回：
基生成器 g

getL

public int getL()
返回以位为单位的随机指数的大小 l（私有值）。

返回：
以位为单位的随机指数的大小 l（私有值），如果尚未设置此大小则返回 0。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DHPrivateKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 DHPrivateKeySpec

java.lang.Object
    继承者  javax.crypto.spec.DHPrivateKeySpec
所有已实现的接口：
KeySpec
public class DHPrivateKeySpec
extends Object
implements KeySpec

此类使用其关联的参数指定一个 Diffie-Hellman 私钥。

注意，此类不在任何指定的参数上执行任何验证。因此，即使给定的值为 null 也会被直接返回。

从以下版本开始：
1.4
另请参见：
DHPublicKeySpec

构造方法摘要
DHPrivateKeySpec(BigInteger x, BigInteger p, BigInteger g)
带有一个私有值 x、一个质数模数 p 以及一个基生成器 g 的构造方法。
方法摘要
BigInteger | getG() 返回基生成器 g。
BigInteger | getP() 返回质数模数 p。
BigInteger | getX() 返回私有值 x。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DHPrivateKeySpec

public DHPrivateKeySpec(BigInteger x,
                        BigInteger p,
                        BigInteger g)
带有一个私有值 x、一个质数模数 p 以及一个基生成器 g 的构造方法。

参数：
x - 私有值 x
p - 质数模数 p
g - 基生成器 g
方法详细信息

getX

public BigInteger getX()
返回私有值 x。

返回：
私有值 x

getP

public BigInteger getP()
返回质数模数 p。

返回：
质数模数 p

getG

public BigInteger getG()
返回基生成器 g。

返回：
基生成器 g
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DHPublicKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 DHPublicKeySpec

java.lang.Object
    继承者  javax.crypto.spec.DHPublicKeySpec
所有已实现的接口：
KeySpec
public class DHPublicKeySpec
extends Object
implements KeySpec

此类使用关联的参数指定一个 Diffie-Hellman 公钥。

注意，此类不在任何指定的参数上执行任何验证。因此，即使给定的值为 null 也会被直接返回。

从以下版本开始：
1.4
另请参见：
DHPrivateKeySpec

构造方法摘要
DHPublicKeySpec(BigInteger y, BigInteger p, BigInteger g)
带有一个公有值 y、一个质数模数 p 以及一个基生成器 g 的构造方法。
方法摘要
BigInteger | getG() 返回基生成器 g。
BigInteger | getP() 返回质数模数 p。
BigInteger | getY() 返回公有值 y。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DHPublicKeySpec

public DHPublicKeySpec(BigInteger y,
                       BigInteger p,
                       BigInteger g)
带有一个公有值 y、一个质数模数 p 以及一个基生成器 g 的构造方法。

参数：
y - 公有值 y
p - 质数模数 p
g - 基生成器 g
方法详细信息

getY

public BigInteger getY()
返回公有值 y。

返回：
公有值 y

getP

public BigInteger getP()
返回质数模数 p。

返回：
质数模数 p

getG

public BigInteger getG()
返回基生成器 g。

返回：
基生成器 g
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IvParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 IvParameterSpec

java.lang.Object
    继承者  javax.crypto.spec.IvParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class IvParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定一个初始化向量 (IV)。使用 IV 的例子是反馈模式中的密码，如，CBC 模式中的 DES 和使用 OAEP 编码操作的 RSA 密码。

从以下版本开始：
1.4

构造方法摘要
IvParameterSpec(byte[] iv)
使用 iv 中的字节作为 IV 来构造一个 IvParameterSpec 对象。
IvParameterSpec(byte[] iv, int offset, int len)
使用 iv 中始于且包含 offset 的前 len 个字节作为 IV 来构造一个 IvParameterSpec 对象。
方法摘要
 byte[] getIV()
返回初始化向量 (IV)。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IvParameterSpec

public IvParameterSpec(byte[] iv)
使用 iv 中的字节作为 IV 来构造一个 IvParameterSpec 对象。

参数：
iv - 具有 IV 的缓冲区。复制该缓冲区的内容来防止后续修改。
抛出：
NullPointerException - 如果 iv 为 null

IvParameterSpec

public IvParameterSpec(byte[] iv,
                       int offset,
                       int len)
使用 iv 中始于且包含 offset 的前 len 个字节作为 IV 来构造一个 IvParameterSpec 对象。

组成 IV 的字节在 iv[offset] 和 iv[offset+len-1] 范围内（包含两者）。

参数：
iv - 具有 IV 的缓冲区。复制该缓冲区始于且包含 offset 的前 len 个字节来防止后续修改。
offset - iv 中的偏移量，IV 从此处开始。
len - IV 字节的数目。
抛出：
IllegalArgumentException - 如果 iv 为 null 或者 (iv.length - offset < len)
ArrayIndexOutOfBoundsException - 如果 offset 或 len 索引字节超出 iv 范围，则抛出该异常。
方法详细信息

getIV

public byte[] getIV()
返回初始化向量 (IV)。

返回：
初始化向量 (IV)。每次调用此方法都返回一个新数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OAEPParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 OAEPParameterSpec

java.lang.Object
    继承者  javax.crypto.spec.OAEPParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class OAEPParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。 PKCS#1 标准的 ASN.1 定义描述如下：

 RSAES-OAEP-params ::= SEQUENCE {
   hashAlgorithm      [0] OAEP-PSSDigestAlgorithms     DEFAULT sha1,
   maskGenAlgorithm   [1] PKCS1MGFAlgorithms  DEFAULT mgf1SHA1,
   pSourceAlgorithm   [2] PKCS1PSourceAlgorithms  DEFAULT pSpecifiedEmpty
 }
其中
 OAEP-PSSDigestAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-sha1 PARAMETERS NULL   }|
   { OID id-sha256 PARAMETERS NULL }|
   { OID id-sha384 PARAMETERS NULL }|
   { OID id-sha512 PARAMETERS NULL },
   ...  -- Allows for future expansion --
 }
 PKCS1MGFAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-mgf1 PARAMETERS OAEP-PSSDigestAlgorithms },
   ...  -- Allows for future expansion --
 }
 PKCS1PSourceAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-pSpecified PARAMETERS OCTET STRING },
   ...  -- Allows for future expansion --
 }

注：OAEPParameterSpec.DEFAULT 所使用的如下所示：信息摘要 -- "SHA-1" 掩码生成函数 (mgf) -- "MGF1" mgf 的参数-- MGF1ParameterSpec.SHA1 编码输入源 -- PSource.PSpecified.DEFAULT

从以下版本开始：
1.5
另请参见：
MGF1ParameterSpec, PSource

字段摘要
static OAEPParameterSpec DEFAULT
使用所有默认值的 OAEP 参数设置。
构造方法摘要
OAEPParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。
方法摘要
String | getDigestAlgorithm() 返回信息摘要算法名称。
String | getMGFAlgorithm() 返回掩码生成函数算法名称。
AlgorithmParameterSpec | getMGFParameters() 返回掩码生成函数的参数。
PSource | getPSource() 返回编码输入 P 的源。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT

public static final OAEPParameterSpec DEFAULT
使用所有默认值的 OAEP 参数设置。

构造方法详细信息

OAEPParameterSpec

public OAEPParameterSpec(String mdName,
                         String mgfName,
                         AlgorithmParameterSpec mgfSpec,
                         PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。

参数：
mdName - 信息摘要的算法名称。
mgfName - 掩码生成函数的算法名称。
mgfSpec - 掩码生成函数的参数。如果指定为 null，则 getMGFParameters() 将返回 null。
pSrc - 编码输入 P 的源。
抛出：
NullPointerException - 如果 mdName、mgfName 或 pSrc 为 null。
方法详细信息

getDigestAlgorithm

public String getDigestAlgorithm()
返回信息摘要算法名称。

返回：
信息摘要算法名称。

getMGFAlgorithm

public String getMGFAlgorithm()
返回掩码生成函数算法名称。

返回：
掩码生成函数算法名称。

getMGFParameters

public AlgorithmParameterSpec getMGFParameters()
返回掩码生成函数的参数。

返回：
掩码生成函数的参数。

getPSource

public PSource getPSource()
返回编码输入 P 的源。

返回：
编码输入 P 的源。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PBEKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 PBEKeySpec

java.lang.Object
    继承者  javax.crypto.spec.PBEKeySpec
所有已实现的接口：
KeySpec
public class PBEKeySpec
extends Object
implements KeySpec

可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。

可以将密码视为某种原始密钥内容，由此加密机制使用其导出一个密钥。

不同的 PBE 机制可能对每一个密码字符使用不同的位数。例如，在 PKCS #5 中定义的 PEB 机制仅仅关注每一个字符的低 8 位，而 PKCS #12 关注每一个字符的全 16 位。

通过创建一个合适的密钥工厂实例来将密码转换成为一个 PBE 密钥。例如，PKCS #5 的密钥工厂仅根据每个密码字符的低 8 位来构造 PBE 密钥，而 PKCS #12 的密钥工厂将使用每个字符的全 16 位。

还要注意，此类以 char 数组而不是 String 对象的形式存储密码（这可能更具逻辑性），因为 String 类是不可变的，当不再需要存储在其中的密码时没有任何途径来重写其内部值。因此，此类需要以 char 数组作密码，以便在完成后进行重写。

从以下版本开始：
1.4
另请参见：
SecretKeyFactory, PBEParameterSpec

构造方法摘要
PBEKeySpec(char[] password)
带有一个密码的构造方法。
PBEKeySpec(char[] password, byte[] salt, int iterationCount)
带有生成固定密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代数的构造方法。
PBEKeySpec(char[] password, byte[] salt, int iterationCount, int keyLength)
带有生成可变密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代计数以及导出密钥长度的构造方法。
方法摘要
void | clearPassword() 清空密码的内部副本。
int | getIterationCount() 返回迭代计数，如果未指定则返回 0。
int | getKeyLength() 返回要导出的密钥长度，如果未指定则返回 0。
char[] | getPassword() 返回密码的一份副本。
byte[] | getSalt() 返回 salt 的一份副本，如果未指定则返回 null。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PBEKeySpec

public PBEKeySpec(char[] password)
带有一个密码的构造方法。如果指定了 null,则使用一个空 char[]。

注：在将 password 存储进新的 PBEKeySpec 对象前将其复制。

参数：
password - 密码。

PBEKeySpec

public PBEKeySpec(char[] password,
                  byte[] salt,
                  int iterationCount,
                  int keyLength)
带有生成可变密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代计数以及导出密钥长度的构造方法。如果指定 password 为 null，则使用一个空 char[]。

注：在将 password 和 salt 存储进新的 PBEKeySpec 对象前将其复制。

参数：
password - 密码。
salt - salt。
iterationCount - 迭代计数。
keyLength - 要导出的密钥长度。
抛出：
NullPointerException - 如果 salt 为 null。
IllegalArgumentException - 如果 salt 为空（即 0 长度）、iterationCount 或 keyLength 不为正。

PBEKeySpec

public PBEKeySpec(char[] password,
                  byte[] salt,
                  int iterationCount)
带有生成固定密钥大小的 PBE 密码的 PBEKey 时使用的一个密码、salt、迭代数的构造方法。如果指定 password 为 null，则使用一个空 char[]。

注：在将 password 和 salt 存储进新的 PBEKeySpec 对象前将其复制。

参数：
password - 密码。
salt - salt。
iterationCount - 迭代计数。
抛出：
NullPointerException - 如果 salt 为 null。
IllegalArgumentException - 如果 salt 为空（即 0 长度），或者 iterationCount 不为正。
方法详细信息

clearPassword

public final void clearPassword()
清空密码的内部副本。

getPassword

public final char[] getPassword()
返回密码的一份副本。

注：此方法返回密码的一份副本。调用者负责在不再需要密码后清空密码信息。

返回：
密码。
抛出：
IllegalStateException - 如果密码已通过调用 clearPassword 方法被清除。

getSalt

public final byte[] getSalt()
返回 salt 的一份副本，如果未指定则返回 null。

注：此方法应返回 salt 的一份副本。调用者负责在不再需要 salt 后清空 salt 信息。

返回：
salt。

getIterationCount

public final int getIterationCount()
返回迭代计数，如果未指定则返回 0。

返回：
迭代计数。

getKeyLength

public final int getKeyLength()
返回要导出的密钥长度，如果未指定则返回 0。

注：此方法用于指出可变密钥大小密码的首选密钥长度。实际的密钥大小依赖于每一个提供者的实现。

返回：
要导出的密钥长度。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PBEParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 PBEParameterSpec

java.lang.Object
    继承者  javax.crypto.spec.PBEParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class PBEParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。

从以下版本开始：
1.4

构造方法摘要
PBEParameterSpec(byte[] salt, int iterationCount)
为 PKCS #5 标准中所定义的基于密码的加密法构造一个参数集合。
方法摘要
int | getIterationCount() 返回迭代计数。
byte[] | getSalt() 返回 salt。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PBEParameterSpec

public PBEParameterSpec(byte[] salt,
                        int iterationCount)
为 PKCS #5 标准中所定义的基于密码的加密法构造一个参数集合。

参数：
salt - salt。复制该 salt 的内容来防止后续修改。
iterationCount - 迭代计数。
抛出：
NullPointerException - 如果 salt 为 null。
方法详细信息

getSalt

public byte[] getSalt()
返回 salt。

返回：
salt。每次调用此方法都返回一个新数组。

getIterationCount

public int getIterationCount()
返回迭代计数。

返回：
迭代计数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 PSource

java.lang.Object
    继承者  javax.crypto.spec.PSource
直接已知子类：
PSource.PSpecified
public class PSource
extends Object

此类为在 OAEP 冗余中的编码输入 P 指定源，OAEP 冗余在 PKCS #1 标准中定义。

 PKCS1PSourceAlgorithms    ALGORITHM-IDENTIFIER ::= {
   { OID id-pSpecified PARAMETERS OCTET STRING },
   ...  -- Allows for future expansion --
 }

从以下版本开始：
1.5

嵌套类摘要
static class PSource.PSpecified
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。
构造方法摘要
protected PSource(String pSrcName)
使用指定的 PSource 算法为 PKCS #1 标准中定义的 OAEP 冗余构造一个编码输入 P 的源。
方法摘要
 String getAlgorithm()
返回 PSource 算法名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PSource

protected PSource(String pSrcName)
使用指定的 PSource 算法为 PKCS #1 标准中定义的 OAEP 冗余构造一个编码输入 P 的源。

参数：
pSrcName - 编码输入 P 的源的算法。
抛出：
NullPointerException - 如果 pSrcName 为 null。
方法详细信息

getAlgorithm

public String getAlgorithm()
返回 PSource 算法名称。

返回：
PSource 算法名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PSource.PSpecified (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 PSource.PSpecified

java.lang.Object
    继承者  javax.crypto.spec.PSource
        继承者  javax.crypto.spec.PSource.PSpecified
正在封闭类：
PSource
public static final class PSource.PSpecified
extends PSource

此类用于显式地指定 OAEP 冗余中编码输入 P 的值。

从以下版本开始：
1.5

嵌套类摘要
从类 javax.crypto.spec.PSource 继承的嵌套类/接口
PSource.PSpecified
字段摘要
static PSource.PSpecified DEFAULT
其值与 byte[0] 相等的编码输入 P。
构造方法摘要
PSource.PSpecified(byte[] p)
将指定的值 p 作为编码输入 P 显式地构造源。
方法摘要
 byte[] getValue()
返回编码输入 P 的值。
从类 javax.crypto.spec.PSource 继承的方法
getAlgorithm
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT

public static final PSource.PSpecified DEFAULT
其值与 byte[0] 相等的编码输入 P。

构造方法详细信息

PSource.PSpecified

public PSource.PSpecified(byte[] p)
将指定的值 p 作为编码输入 P 显式地构造源。 注：

参数：
p - 编码输入的值。复制该数组的内容来防止后续修改。
抛出：
NullPointerException - 如果 q 为 null。
方法详细信息

getValue

public byte[] getValue()
返回编码输入 P 的值。

返回：
编码输入 P 的值。每次调用此方法都返回一个新数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RC2ParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 RC2ParameterSpec

java.lang.Object
    继承者  javax.crypto.spec.RC2ParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class RC2ParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定随同 RC2 算法使用的参数。

参数由一个有效密钥大小和一个任意 8 字节初始化向量 (IV)（仅用在反馈模式）组成。

可以用此类来初始化一个实现了 RC2 算法的 Cipher 对象。

从以下版本开始：
1.4

构造方法摘要
RC2ParameterSpec(int effectiveKeyBits)
根据给定的有效密钥大小（以位为单位）为 RC2 构造一个参数集合。
RC2ParameterSpec(int effectiveKeyBits, byte[] iv)
根据给定的有效密钥大小（以位为单位）和一个 8 字节的 IV 为 RC2 构造一个参数集合。
RC2ParameterSpec(int effectiveKeyBits, byte[] iv, int offset)
根据给定的有效密钥大小（以位为单位）和 IV 为 RC2 构造一个参数集合。
方法摘要
boolean | equals(Object obj) 测试给定对象与此对象的相等性。
int | getEffectiveKeyBits() 返回以位为单位的有效密钥大小。
byte[] | getIV() 返回 IV，如果此参数集没有包含 IV 则返回 null。
int | hashCode() 计算此对象的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RC2ParameterSpec

public RC2ParameterSpec(int effectiveKeyBits)
根据给定的有效密钥大小（以位为单位）为 RC2 构造一个参数集合。

参数：
effectiveKeyBits - 以位为单位的有效密钥大小。

RC2ParameterSpec

public RC2ParameterSpec(int effectiveKeyBits,
                        byte[] iv)
根据给定的有效密钥大小（以位为单位）和一个 8 字节的 IV 为 RC2 构造一个参数集合。

组成 IV 的字节在 iv[0] 和 iv[7] 范围内（包含两者）。

参数：
effectiveKeyBits - 以位为单位的有效密钥大小。
iv - 具有 8 字节 IV 的缓冲区。复制该缓冲区的前 8 个字节来防止后续修改。
抛出：
IllegalArgumentException - 如果 iv 为 null。

RC2ParameterSpec

public RC2ParameterSpec(int effectiveKeyBits,
                        byte[] iv,
                        int offset)
根据给定的有效密钥大小（以位为单位）和 IV 为 RC2 构造一个参数集合。

此 IV 取自 iv，始于且包含 offset。组成 IV 的字节在 iv[offset] 和 iv[offset+7] 范围内（包含两者）。

参数：
effectiveKeyBits - 以位为单位的有效密钥大小。
iv - 具有 IV 的缓冲区。复制该缓冲始于且包含 offset 的前 8 个字节来防止后续修改。
offset - iv 中的偏移量，8 字节的 IV 从此处开始。
抛出：
IllegalArgumentException - 如果 iv 为 null。
方法详细信息

getEffectiveKeyBits

public int getEffectiveKeyBits()
返回以位为单位的有效密钥大小。

返回：
以位为单位的有效密钥大小。

getIV

public byte[] getIV()
返回 IV，如果此参数集没有包含 IV 则返回 null。

返回：
IV，如果此参数集没有包含 IV 则返回 null。每次调用此方法都返回一个新数组。

equals

public boolean equals(Object obj)
测试给定对象与此对象的相等性。如果两个 RC2ParameterSpec 对象的有效密钥大小和 IV 相等，则认为这两个对象相等。（都为 null 的两个 IV 引用视为相等。）

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果认为对象相等则返回 true；如果 obj 为 null 或其他情况则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
计算此对象的哈希码值。相等的对象也将具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RC5ParameterSpec (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 RC5ParameterSpec

java.lang.Object
    继承者  javax.crypto.spec.RC5ParameterSpec
所有已实现的接口：
AlgorithmParameterSpec
public class RC5ParameterSpec
extends Object
implements AlgorithmParameterSpec

此类指定随同 RC5 算法使用的参数。

参数由一个版本号、一个 round 计数、一个 word 大小以及一个任意初始化向量 (IV)（仅用于反馈模式）组成。

可以使用此类来初始化一个实现了 RSA Security Inc. 或 RSA Security 授权的任何参与方所提供的 RC5 算法的 Cipher 对象。

从以下版本开始：
1.4

构造方法摘要
RC5ParameterSpec(int version, int rounds, int wordSize)
根据给定的版本、round 的数量以及 word 大小（以位为单位）为 RC5 构造一个参数集合。
RC5ParameterSpec(int version, int rounds, int wordSize, byte[] iv)
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。
RC5ParameterSpec(int version, int rounds, int wordSize, byte[] iv, int offset)
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。
方法摘要
boolean | equals(Object obj) 测试给定对象与此对象的相等性。
byte[] | getIV() 返回 IV，如果此参数集没有包含 IV 则返回 null。
int | getRounds() 返回 rounds 的数量。
int | getVersion() 返回版本。
int | getWordSize() 返回以位为单位的 word 大小。
int | hashCode() 计算此对象的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RC5ParameterSpec

public RC5ParameterSpec(int version,
                        int rounds,
                        int wordSize)
根据给定的版本、round 的数量以及 word 大小（以位为单位）为 RC5 构造一个参数集合。

参数：
version - 版本。
rounds - rounds 的数量。
wordSize - 以位为单位的 word 大小。

RC5ParameterSpec

public RC5ParameterSpec(int version,
                        int rounds,
                        int wordSize,
                        byte[] iv)
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。

注意，IV 的大小（块大小）必须是 word 大小的两倍。组成 IV 的字节在 iv[0] 和 iv[2*(wordSize/8)-1]] 范围内（包含两者）。

参数：
version - 版本。
rounds - rounds 的数量。
wordSize - 以位为单位的 word 大小。
iv - 具有 IV 的缓冲区。复制该缓冲区的前 2*(wordSize/8) 个字节来防止后续修改。
抛出：
IllegalArgumentException - 如果 iv 为 null 或者 (iv.length < 2 * (wordSize / 8))

RC5ParameterSpec

public RC5ParameterSpec(int version,
                        int rounds,
                        int wordSize,
                        byte[] iv,
                        int offset)
根据给定的版本、round 的数量、word 大小（以位为单位）以及 IV 为 RC5 构造一个参数集合。

此 IV 取自 iv，始于且包含 offset。注意，始于且包含 offset 的 IV 的大小（块大小）必须是 word 大小的两倍。组成 IV 的字节在 iv[offset] 和 iv[offset+2*(wordSize/8)-1] 范围内（包含两者）。

参数：
version - 版本。
rounds - rounds 的数量。
wordSize - 以位为单位的 word 大小。
iv - 具有 IV 的缓冲区。复制该缓冲区的始于且包含 offset 的前 2*(wordSize/8) 个字节来防止后续修改。
offset - iv 中的偏移量，IV 从此处开始。
抛出：
IllegalArgumentException - 如果 iv 为 null 或者 (iv.length - offset < 2 * (wordSize / 8))
方法详细信息

getVersion

public int getVersion()
返回版本。

返回：
版本。

getRounds

public int getRounds()
返回 rounds 的数量。

返回：
rounds 的数量。

getWordSize

public int getWordSize()
返回以位为单位的 word 大小。

返回：
以位为单位的 word 大小。

getIV

public byte[] getIV()
返回 IV，如果此参数集没有包含 IV 则返回 null。

返回：
IV，如果此参数集没有包含 IV 则返回 null。每次调用此方法都返回一个新数组。

equals

public boolean equals(Object obj)
测试给定对象与此对象的相等性。如果两个 RC5ParameterSpec 对象的版本号、round 的数量、word 大小以及 IV 相等，则认为这两者相等。（都为 null 的两个 IV 引用视为相等。）

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果认为对象相等则返回 true；如果 obj 为 null 或其他情况则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
计算此对象的哈希码值。相等的对象也将具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SecretKeySpec (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.crypto.spec
类 SecretKeySpec

java.lang.Object
    继承者  javax.crypto.spec.SecretKeySpec
所有已实现的接口：
Serializable, Key, KeySpec, SecretKey
public class SecretKeySpec
extends Object
implements KeySpec, SecretKey

此类以与 provider 无关的方式指定一个密钥。

可以使用此类来根据一个字节数组构造一个 SecretKey，而无须通过一个（基于 provider 的）SecretKeyFactory。

此类仅对能表示为一个字节数组并且没有任何与之相关联的钥参数的原始密钥有用，如，DES 或者 Triple DES 密钥。

从以下版本开始：
1.4
另请参见：
SecretKey, SecretKeyFactory, 序列化表格

字段摘要
从接口 javax.crypto.SecretKey 继承的字段
serialVersionUID
构造方法摘要
SecretKeySpec(byte[] key, int offset, int len, String algorithm)
根据给定的字节数组构造一个密钥，使用 key 中的始于且包含 offset 的前 len 个字节。
SecretKeySpec(byte[] key, String algorithm)
根据给定的字节数组构造一个密钥。
方法摘要
boolean | equals(Object obj) 测试给定对象与此对象的相等性。
String | getAlgorithm() 返回与此密钥关联的算法的名称。
byte[] | getEncoded() 返回此密钥的密钥内容。
String | getFormat() 返回此密钥编码格式的名称。
int | hashCode() 计算此对象的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SecretKeySpec

public SecretKeySpec(byte[] key,
                     String algorithm)
根据给定的字节数组构造一个密钥。

此构造方法不检查给定的字节实际上是否指定了一个指定算法的密钥。例如，如果算法是 DES，此构造方法不检查 key 是否是 8 字节长，并且也不检查是否是全弱或者半弱密钥。为了执行这些检查，应当使用一个特定于算法的密钥规范（在此情况下是：DESKeySpec）。

参数：
key - 密钥的密钥内容。复制该数组的内容来防止后续修改。
algorithm - 与给定的密钥内容相关联的密钥算法的名称。有关标准算法名称的信息请参见 Java Cryptography Architecture Reference Guide 中的附录 A。
抛出：
IllegalArgumentException - 如果 algorithm 为 null 或者 key 为 null 或空。

SecretKeySpec

public SecretKeySpec(byte[] key,
                     int offset,
                     int len,
                     String algorithm)
根据给定的字节数组构造一个密钥，使用 key 中的始于且包含 offset 的前 len 个字节。

组成密钥的字节在 key[offset] 和 key[offset+len-1] 范围内（包含两者）。

此构造方法不检查给定的字节实际上是否指定了一个指定算法的密钥。例如，如果算法是 DES，此构造方法不检查 key 是否是 8 字节长，并且也不检查是否是全弱或者半弱密钥。为了执行这些检查，必须使用一个特定于算法的密钥规范（在此情况下是：DESKeySpec）。

参数：
key - 密钥的密钥内容。复制该数组始于且包含 offset 的前 len 个字节来防止后续修改。
offset - key 中的偏移量，密钥内容从此处开始。
len - 密钥内容的长度。
algorithm - 与给定的密钥内容相关联的密钥算法的名称。有关标准算法名称的信息请参见 Java Cryptography Architecture Reference Guide 中的附录 A。
抛出：
IllegalArgumentException - 如果 algorithm 为 null 或者 key 为 null、空或太短（即 key.length-offset 小于 len）。
ArrayIndexOutOfBoundsException - 如果 offset 或者 len 索引字节在 key 范围外，则抛出该异常。
方法详细信息

getAlgorithm

public String getAlgorithm()
返回与此密钥关联的算法的名称。

指定者：
接口 Key 中的 getAlgorithm
返回：
密钥算法。

getFormat

public String getFormat()
返回此密钥编码格式的名称。

指定者：
接口 Key 中的 getFormat
返回：
字符串 "RAW"。

getEncoded

public byte[] getEncoded()
返回此密钥的密钥内容。

指定者：
接口 Key 中的 getEncoded
返回：
密钥内容。每次调用此方法都返回一个新数组。

hashCode

public int hashCode()
计算此对象的哈希码值。相等的对象也将具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
测试给定对象与此对象的相等性。如果两个 SecretKeySpec 对象都是具有相同的区分大小写的算法名称和密钥编码的 SecretKey 实例，则认为这两者相等。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果认为对象相等则返回 true；如果 obj 为 null 或其他情况则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.crypto.spec (Java 2 Platform SE 6)

 javax.crypto.spec
类
DESedeKeySpec
DESKeySpec
DHGenParameterSpec
DHParameterSpec
DHPrivateKeySpec
DHPublicKeySpec
IvParameterSpec
OAEPParameterSpec
PBEKeySpec
PBEParameterSpec
PSource
PSource.PSpecified
RC2ParameterSpec
RC5ParameterSpec
SecretKeySpec


javax.crypto.spec (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.crypto.spec

为密钥规范和算法参数规范提供类和接口。

请参见：
描述

类摘要
DESedeKeySpec | 此类指定一个 DES-EDE ("triple-DES") 密钥。
DESKeySpec | 此类指定一个 DES 密钥。
DHGenParameterSpec | 此类指定用于生成在 Diffie-Hellman 密钥协议中使用的 Diffie-Hellman（系统）参数的参数集合。
DHParameterSpec | 此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。
DHPrivateKeySpec | 此类使用其关联的参数指定一个 Diffie-Hellman 私钥。
DHPublicKeySpec | 此类使用关联的参数指定一个 Diffie-Hellman 公钥。
IvParameterSpec | 此类指定一个初始化向量 (IV)。
OAEPParameterSpec | 此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。
PBEKeySpec | 可随同基于密码的加密法 (PBE) 使用的供用户选择的密码。
PBEParameterSpec | 此类指定随同以密码为基础的加密法 (PBE) 使用的参数集合，该加密法在 PKCS #5 标准中定义。
PSource | 此类为在 OAEP 冗余中的编码输入 P 指定源，OAEP 冗余在 PKCS #1 标准中定义。
PSource.PSpecified | 此类用于显式地指定 OAEP 冗余中编码输入 P 的值。
RC2ParameterSpec | 此类指定随同 RC2 算法使用的参数。
RC5ParameterSpec | 此类指定随同 RC5 算法使用的参数。
SecretKeySpec | 此类以与 provider 无关的方式指定一个密钥。

软件包 javax.crypto.spec 的描述

为密钥规范和算法参数规范提供类和接口。

密钥规范是组成一个密钥的密钥内容的透明表示形式。可以用特定于算法的方式或与算法无关的编码格式（如 ASN.1）来指定一个密钥。此包包含 Diffie-Hellman 公有和私钥的密钥规范，也包含 DES、Triple DES 以及 PBE 密钥的密钥规范。

算法参数规范是随同算法使用的参数集合的透明表示形式。此包包含随同 Diffie-Hellman、DES、Triple DES、PBE、RC2 以及 RC5 算法使用的那些参数的参数规范。

包规范

  • PKCS #3: Diffie-Hellman Key-Agreement Standard, Version 1.4, November 1993
  • PKCS #5: Password-Based Encryption Standard, Version 1.5, November 1993
  • Federal Information Processing Standards Publication (FIPS PUB) 46-2: Data Encryption Standard (DES)

相关文档

有关包含关于算法参数和密钥规范的文档，请参阅：
  • JavaTM Cryptography Architecture API Specification and Reference
  • How to Implement a Provider for the JavaTM Cryptography Architecture

从以下版本开始：
JCE1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.crypto.spec 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.crypto.spec 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.crypto.spec.DESedeKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DESKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DHGenParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.DHPrivateKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.DHPublicKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.IvParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.OAEPParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.PBEKeySpec (implements java.security.spec.KeySpec)
    • javax.crypto.spec.PBEParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.PSource
      • javax.crypto.spec.PSource.PSpecified
    • javax.crypto.spec.RC2ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.RC5ParameterSpec (implements java.security.spec.AlgorithmParameterSpec)
    • javax.crypto.spec.SecretKeySpec (implements java.security.spec.KeySpec, javax.crypto.SecretKey)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.crypto.spec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.crypto.spec
的使用

使用 javax.crypto.spec 的软件包
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。

javax.crypto.interfaces 使用的 javax.crypto.spec 中的类
DHParameterSpec
此类指定随同 Diffie-Hellman 算法使用的参数集合，该算法在 PKCS #3：Diffie-Hellman Key-Agreement Standard 中指定。

javax.crypto.spec 使用的 javax.crypto.spec 中的类
OAEPParameterSpec
此类指定随同 OAEP 冗余使用的参数集合，OAEP 冗余在 PKCS #1 标准中定义。
PSource
此类为在 OAEP 冗余中的编码输入 P 指定源，OAEP 冗余在 PKCS #1 标准中定义。
PSource.PSpecified
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.DHParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHParameterSpec
的使用

使用 DHParameterSpec 的软件包
javax.crypto.interfaces 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。

javax.crypto.interfaces 中 DHParameterSpec 的使用

返回 DHParameterSpec 的 javax.crypto.interfaces 中的方法
 DHParameterSpec DHKey.getParams()
返回密钥参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.DESKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DESKeySpec
的使用

没有 javax.crypto.spec.DESKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.IvParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.IvParameterSpec
的使用

没有 javax.crypto.spec.IvParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.RC2ParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.RC2ParameterSpec
的使用

没有 javax.crypto.spec.RC2ParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.RC5ParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.RC5ParameterSpec
的使用

没有 javax.crypto.spec.RC5ParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.DESedeKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DESedeKeySpec
的使用

没有 javax.crypto.spec.DESedeKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.DHGenParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHGenParameterSpec
的使用

没有 javax.crypto.spec.DHGenParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.DHPrivateKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHPrivateKeySpec
的使用

没有 javax.crypto.spec.DHPrivateKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.DHPublicKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.DHPublicKeySpec
的使用

没有 javax.crypto.spec.DHPublicKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.PBEKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PBEKeySpec
的使用

没有 javax.crypto.spec.PBEKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.PBEParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PBEParameterSpec
的使用

没有 javax.crypto.spec.PBEParameterSpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.SecretKeySpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.SecretKeySpec
的使用

没有 javax.crypto.spec.SecretKeySpec 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.PSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PSource
的使用

使用 PSource 的软件包
javax.crypto.spec 为密钥规范和算法参数规范提供类和接口。

javax.crypto.spec 中 PSource 的使用

javax.crypto.spec 中 PSource 的子类
static class PSource.PSpecified
此类用于显式地指定 OAEP 冗余中编码输入 P 的值。

返回 PSource 的 javax.crypto.spec 中的方法
 PSource OAEPParameterSpec.getPSource()
返回编码输入 P 的源。

参数类型为 PSource 的 javax.crypto.spec 中的构造方法
OAEPParameterSpec(String mdName, String mgfName, AlgorithmParameterSpec mgfSpec, PSource pSrc)
使用指定的信息摘要算法 mdName、掩码生成函数算法 mgfName、掩码生成函数参数 mgfSpec 以及编码输入 P 源 pSrc 来为 PKCS #1 标准中定义的 OAEP 冗余构造一个参数集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.PSource.PSpecified 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.PSource.PSpecified
的使用

使用 PSource.PSpecified 的软件包
javax.crypto.spec 为密钥规范和算法参数规范提供类和接口。

javax.crypto.spec 中 PSource.PSpecified 的使用

声明为 PSource.PSpecified 的 javax.crypto.spec 中的字段
static PSource.PSpecified PSource.PSpecified.DEFAULT
其值与 byte[0] 相等的编码输入 P。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.spec.OAEPParameterSpec 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.spec.OAEPParameterSpec
的使用

使用 OAEPParameterSpec 的软件包
javax.crypto.spec 为密钥规范和算法参数规范提供类和接口。

javax.crypto.spec 中 OAEPParameterSpec 的使用

声明为 OAEPParameterSpec 的 javax.crypto.spec 中的字段
static OAEPParameterSpec OAEPParameterSpec.DEFAULT
使用所有默认值的 OAEP 参数设置。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.crypto.SecretKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.crypto.SecretKey
的使用

使用 SecretKey 的软件包
java.security | 为安全框架提供类和接口。
javax.crypto | 为加密操作提供类和接口。
javax.crypto.interfaces | 根据 RSA Laboratories' PKCS #3 的定义，提供 Diffie-Hellman 密钥接口。
javax.crypto.spec | 为密钥规范和算法参数规范提供类和接口。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

java.security 中 SecretKey 的使用

返回 SecretKey 的 java.security 中的方法
 SecretKey KeyStore.SecretKeyEntry.getSecretKey()
从此项中获取 SecretKey。

参数类型为 SecretKey 的 java.security 中的构造方法
KeyStore.SecretKeyEntry(SecretKey secretKey)
用 SecretKey 构造 SecretKeyEntry。

javax.crypto 中 SecretKey 的使用

返回 SecretKey 的 javax.crypto 中的方法
protected abstract SecretKey | KeyGeneratorSpi.engineGenerateKey() 生成一个秘密密钥。
protected abstract SecretKey | SecretKeyFactorySpi.engineGenerateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
protected abstract SecretKey | KeyAgreementSpi.engineGenerateSecret(String algorithm) 创建共享秘密密钥，并将它作为所请求算法类型的秘密密钥对象返回。
protected abstract SecretKey | SecretKeyFactorySpi.engineTranslateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
SecretKey | KeyGenerator.generateKey() 生成一个密钥。
SecretKey | SecretKeyFactory.generateSecret(KeySpec keySpec) 根据提供的密钥规范（密钥材料）生成 SecretKey 对象。
SecretKey | KeyAgreement.generateSecret(String algorithm) 创建共享秘密并将其作为指定算法的 SecretKey 对象返回。
SecretKey | SecretKeyFactory.translateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。

参数类型为 SecretKey 的 javax.crypto 中的方法
protected abstract KeySpec | SecretKeyFactorySpi.engineGetKeySpec(SecretKey key, Class keySpec) 以所需格式返回给定密钥对象的规范（密钥材料）。
protected abstract SecretKey | SecretKeyFactorySpi.engineTranslateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此密钥工厂的相应密钥对象。
KeySpec | SecretKeyFactory.getKeySpec(SecretKey key, Class keySpec) 以请求的格式返回给定密钥对象的规范（密钥材料）。
SecretKey | SecretKeyFactory.translateKey(SecretKey key) 将一个密钥对象（其提供者未知或可能不受信任）转换为此秘密密钥工厂的相应密钥对象。

javax.crypto.interfaces 中 SecretKey 的使用

javax.crypto.interfaces 中 SecretKey 的子接口
 interface PBEKey
调用者 PBE 密钥接口。

javax.crypto.spec 中 SecretKey 的使用

实现 SecretKey 的 javax.crypto.spec 中的类
 class SecretKeySpec
此类以与 provider 无关的方式指定一个密钥。

javax.security.auth.kerberos 中 SecretKey 的使用

实现 SecretKey 的 javax.security.auth.kerberos 中的类
 class KerberosKey
此类为 Kerberos 主体封装一个长期秘密密钥。

返回 SecretKey 的 javax.security.auth.kerberos 中的方法
 SecretKey KerberosTicket.getSessionKey()
返回与此票据有关联的会话密钥。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.Cipher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.Cipher
的使用

使用 Cipher 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 Cipher 的使用

javax.crypto 中 Cipher 的子类
 class NullCipher
NullCipher 类是一个提供“标识密码”的类，其不转换纯文本。

返回 Cipher 的 javax.crypto 中的方法
static Cipher | Cipher.getInstance(String transformation) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。

参数类型为 Cipher 的 javax.crypto 中的方法
PKCS8EncodedKeySpec | EncryptedPrivateKeyInfo.getKeySpec(Cipher cipher) 将密封的 PKCS8EncodedKeySpec 对象从加密的数据中抽取出来并将其返回。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。

参数类型为 Cipher 的 javax.crypto 中的构造方法
CipherInputStream(InputStream is, Cipher c)
根据 InputStream 和 Cipher 构造 CipherInputStream。
CipherOutputStream(OutputStream os, Cipher c)
从 OutputStream 和 Cipher 构造 CipherOutputStream。
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.CipherSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.CipherSpi
的使用

使用 CipherSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 CipherSpi 的使用

参数类型为 CipherSpi 的 javax.crypto 中的构造方法
Cipher(CipherSpi cipherSpi, Provider provider, String transformation)
创建 Cipher 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.ExemptionMechanism 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ExemptionMechanism
的使用

使用 ExemptionMechanism 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ExemptionMechanism 的使用

返回 ExemptionMechanism 的 javax.crypto 中的方法
ExemptionMechanism | Cipher.getExemptionMechanism() 返回此 Cipher 使用的豁免 (exemption) 机制对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, Provider provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。
static ExemptionMechanism | ExemptionMechanism.getInstance(String algorithm, String provider) 返回实现指定豁免机制算法的 ExemptionMechanism 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.ShortBufferException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ShortBufferException
的使用

使用 ShortBufferException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ShortBufferException 的使用

抛出 ShortBufferException 的 javax.crypto 中的方法
int | Cipher.doFinal(byte[] output, int outputOffset) 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
void | Mac.doFinal(byte[] output, int outOffset) 完成 MAC 操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected int | CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | KeyAgreementSpi.engineGenerateSecret(byte[] sharedSecret, int offset) 生成共享秘密密钥，并将从 offset 开始（包括）的部分放入缓冲区 sharedSecret。
protected abstract int | ExemptionMechanismSpi.engineGenExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
protected abstract int | CipherSpi.engineUpdate(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
protected int | CipherSpi.engineUpdate(ByteBuffer input, ByteBuffer output) 继续多部分加密或解密操作（取决于此 cipher 的初始化方式），以处理其他数据部分。
int | KeyAgreement.generateSecret(byte[] sharedSecret, int offset) 生成共享秘密，并将其放入缓冲区 sharedSecret，从 offset（包括）开始。
int | ExemptionMechanism.genExemptionBlob(byte[] output) 生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
int | ExemptionMechanism.genExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
int | Cipher.update(byte[] input, int inputOffset, int inputLen, byte[] output) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
int | Cipher.update(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。
int | Cipher.update(ByteBuffer input, ByteBuffer output) 继续多部分加密或解密操作（具体取决于此 Cipher 的初始化方式），以处理其他数据部分。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.NoSuchPaddingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.NoSuchPaddingException
的使用

使用 NoSuchPaddingException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 NoSuchPaddingException 的使用

抛出 NoSuchPaddingException 的 javax.crypto 中的方法
protected abstract void | CipherSpi.engineSetPadding(String padding) 设置此 cipher 的填充机制。
static Cipher | Cipher.getInstance(String transformation) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, Provider provider) 返回实现指定转换的 Cipher 对象。
static Cipher | Cipher.getInstance(String transformation, String provider) 返回实现指定转换的 Cipher 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.ExemptionMechanismException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ExemptionMechanismException
的使用

使用 ExemptionMechanismException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ExemptionMechanismException 的使用

抛出 ExemptionMechanismException 的 javax.crypto 中的方法
protected abstract byte[] | ExemptionMechanismSpi.engineGenExemptionBlob() 生成豁免机制密钥 blob。
protected abstract int | ExemptionMechanismSpi.engineGenExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob 并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key) 用密钥初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
protected abstract void | ExemptionMechanismSpi.engineInit(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
byte[] | ExemptionMechanism.genExemptionBlob() 生成豁免机制密钥 blob。
int | ExemptionMechanism.genExemptionBlob(byte[] output) 生成豁免机制密钥 blob，并将结果存储在 output 缓冲区中。
int | ExemptionMechanism.genExemptionBlob(byte[] output, int outputOffset) 生成豁免机制密钥 blob，并将结果存储在从 outputOffset（包括）开始的 output 缓冲区中。
void | ExemptionMechanism.init(Key key) 用密钥初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameters params) 用一个密钥和一组算法参数初始化此豁免机制。
void | ExemptionMechanism.init(Key key, AlgorithmParameterSpec params) 用一个密钥和一组算法参数初始化此豁免机制。
boolean | ExemptionMechanism.isCryptoAllowed(Key key) 返回此豁免机制是否已成功生成结果 blob。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.CipherInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.CipherInputStream
的使用

没有 javax.crypto.CipherInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.CipherOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.CipherOutputStream
的使用

没有 javax.crypto.CipherOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.KeyAgreement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyAgreement
的使用

使用 KeyAgreement 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyAgreement 的使用

返回 KeyAgreement 的 javax.crypto 中的方法
static KeyAgreement | KeyAgreement.getInstance(String algorithm) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, Provider provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。
static KeyAgreement | KeyAgreement.getInstance(String algorithm, String provider) 返回实现指定密钥协定算法的 KeyAgreement 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.KeyAgreementSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyAgreementSpi
的使用

使用 KeyAgreementSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyAgreementSpi 的使用

参数类型为 KeyAgreementSpi 的 javax.crypto 中的构造方法
KeyAgreement(KeyAgreementSpi keyAgreeSpi, Provider provider, String algorithm)
创建一个 KeyAgreement 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.KeyGenerator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyGenerator
的使用

使用 KeyGenerator 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyGenerator 的使用

返回 KeyGenerator 的 javax.crypto 中的方法
static KeyGenerator | KeyGenerator.getInstance(String algorithm) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, Provider provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。
static KeyGenerator | KeyGenerator.getInstance(String algorithm, String provider) 返回生成指定算法的秘密密钥的 KeyGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.KeyGeneratorSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.KeyGeneratorSpi
的使用

使用 KeyGeneratorSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 KeyGeneratorSpi 的使用

参数类型为 KeyGeneratorSpi 的 javax.crypto 中的构造方法
KeyGenerator(KeyGeneratorSpi keyGenSpi, Provider provider, String algorithm)
创建一个 KeyGenerator 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.Mac 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.Mac
的使用

使用 Mac 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 Mac 的使用

返回 Mac 的 javax.crypto 中的方法
static Mac | Mac.getInstance(String algorithm) 返回实现指定 MAC 算法的 Mac 对象。
static Mac | Mac.getInstance(String algorithm, Provider provider) 返回实现指定 MAC 算法的 Mac 对象。
static Mac | Mac.getInstance(String algorithm, String provider) 返回实现指定 MAC 算法的 Mac 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.MacSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.MacSpi
的使用

使用 MacSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 MacSpi 的使用

参数类型为 MacSpi 的 javax.crypto 中的构造方法
Mac(MacSpi macSpi, Provider provider, String algorithm)
创建一个 MAC 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.SecretKeyFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.SecretKeyFactory
的使用

使用 SecretKeyFactory 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 SecretKeyFactory 的使用

返回 SecretKeyFactory 的 javax.crypto 中的方法
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, Provider provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。
static SecretKeyFactory | SecretKeyFactory.getInstance(String algorithm, String provider) 返回转换指定算法的秘密密钥的 SecretKeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.SecretKeyFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.SecretKeyFactorySpi
的使用

使用 SecretKeyFactorySpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 SecretKeyFactorySpi 的使用

参数类型为 SecretKeyFactorySpi 的 javax.crypto 中的构造方法
SecretKeyFactory(SecretKeyFactorySpi keyFacSpi, Provider provider, String algorithm)
创建一个 SecretKeyFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.EncryptedPrivateKeyInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.EncryptedPrivateKeyInfo
的使用

没有 javax.crypto.EncryptedPrivateKeyInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.ExemptionMechanismSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.ExemptionMechanismSpi
的使用

使用 ExemptionMechanismSpi 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 ExemptionMechanismSpi 的使用

参数类型为 ExemptionMechanismSpi 的 javax.crypto 中的构造方法
ExemptionMechanism(ExemptionMechanismSpi exmechSpi, Provider provider, String mechanism)
创建 ExemptionMechanism 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.SealedObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.SealedObject
的使用

使用 SealedObject 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 SealedObject 的使用

参数类型为 SealedObject 的 javax.crypto 中的构造方法
SealedObject(SealedObject so)
根据传入的 SealedObject 构造一个 SealedObject 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.IllegalBlockSizeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.IllegalBlockSizeException
的使用

使用 IllegalBlockSizeException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 IllegalBlockSizeException 的使用

抛出 IllegalBlockSizeException 的 javax.crypto 中的方法
byte[] | Cipher.doFinal() 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] output, int outputOffset) 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract byte[] | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected int | CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected byte[] | CipherSpi.engineWrap(Key key) 将密钥包装。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。
byte[] | Cipher.wrap(Key key) 包装密钥。

抛出 IllegalBlockSizeException 的 javax.crypto 中的构造方法
SealedObject(Serializable object, Cipher c)
从任何 Serializable 对象构造一个 SealedObject。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.BadPaddingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.BadPaddingException
的使用

使用 BadPaddingException 的软件包
javax.crypto 为加密操作提供类和接口。

javax.crypto 中 BadPaddingException 的使用

抛出 BadPaddingException 的 javax.crypto 中的方法
byte[] | Cipher.doFinal() 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] output, int outputOffset) 结束多部分加密或解密操作（具体取决于此 Cipher 的初始化方式）。
byte[] | Cipher.doFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
int | Cipher.doFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract byte[] | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected abstract int | CipherSpi.engineDoFinal(byte[] input, int inputOffset, int inputLen, byte[] output, int outputOffset) 按单部分操作加密或解密数据，或者结束一个多部分操作。
protected int | CipherSpi.engineDoFinal(ByteBuffer input, ByteBuffer output) 按单部分操作加密或解密数据，或者结束一个多部分操作。
Object | SealedObject.getObject(Cipher c) 获取原始（封装的）对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.crypto.NullCipher 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.crypto.NullCipher
的使用

没有 javax.crypto.NullCipher 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


IIOException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 IIOException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.imageio.IIOException
所有已实现的接口：
Serializable
直接已知子类：
IIOInvalidTreeException
public class IIOException
extends IOException

该异常类用于发出关于读取和写入操作的运行时故障的信号。

除了消息字符串以外，也维护对另一个 Throwable（Error 或 Exception）的引用。此引用（如果为非 null）引用导致此异常发生的事件。例如，从 File 中进行读取时发生的 IOException 将存储在这里。

另请参见：
序列化表格

构造方法摘要
IIOException(String message)
构造带有给定消息 String 的 IIOException。
IIOException(String message, Throwable cause)
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IIOException

public IIOException(String message)
构造带有给定消息 String 的 IIOException。没有设置任何底层 cause；getCause 将返回 null。

参数：
message - 错误消息。
另请参见：
Throwable.getMessage()

IIOException

public IIOException(String message,
                    Throwable cause)
构造一个 IIOException，使其带有给定消息 String 以及作为其底层 cause 的 Throwable。

参数：
message - 错误消息。
cause - 造成此异常发生的 Throwable（Error 或 Exception）。
另请参见：
Throwable.getCause(), Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IIOImage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 IIOImage

java.lang.Object
    继承者  javax.imageio.IIOImage

public class IIOImage
extends Object

一个聚集图像、缩略（预览）图像集和表示与图像关联的元数据的对象的简单容器类。

图像数据可以采用 RenderedImage 或 Raster 的形式。返回 IIOImage 的 reader 方法将总是返回一个使用 RenderedImage 引用的 BufferedImage。接受 IIOImage 的 writer 方法将总是接受 RenderedImage，并且可能有选择地接受 Raster。

getRenderedImage 和 getRaster 中只有一个将返回非 null 值。子类负责确保此行为。

另请参见：
ImageReader.readAll(int, ImageReadParam),
ImageReader.readAll(java.util.Iterator),
ImageWriter.write(javax.imageio.metadata.IIOMetadata, IIOImage, ImageWriteParam),
ImageWriter.write(IIOImage),
ImageWriter.writeToSequence(IIOImage, ImageWriteParam),
ImageWriter.writeInsert(int, IIOImage, ImageWriteParam)

字段摘要
protected RenderedImage | image 正被引用的 RenderedImage。
protected IIOMetadata | metadata 包含与图像关联的元数据的 IIOMetadata 对象。
protected Raster | raster 正被引用的 Raster。
protected List<? extends BufferedImage> | thumbnails BufferedImage 缩略图的 List，或为 null。
构造方法摘要
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。
方法摘要
IIOMetadata | getMetadata() 返回对当前 IIOMetadata 对象的引用，如果没有设置任何这样的对象，则返回 null。
int | getNumThumbnails() 返回此 IIOImage 中存储的缩略图的数量。
Raster | getRaster() 返回当前设置好的 Raster，如果只有一个 RenderedImage 可用，则返回 null。
RenderedImage | getRenderedImage() 返回当前设置好的 RenderedImage，如果只有一个 Raster 可用，则返回 null。
BufferedImage | getThumbnail(int index) 返回与主图像关联的缩略图。
List<? extends BufferedImage> | getThumbnails() 返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。
boolean | hasRaster() 如果此 IIOImage 存储了一个 Raster 而不是 RenderedImage，则返回 true。
void | setMetadata(IIOMetadata metadata) 将 IIOMetadata 设置为一个新对象或 null。
void | setRaster(Raster raster) 设置当前 Raster。
void | setRenderedImage(RenderedImage image) 设置当前 RenderedImage。
void | setThumbnails(List<? extends BufferedImage> thumbnails) 将缩略图列表设置为 BufferedImage 的一个新 List 或 null。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

image

protected RenderedImage image
正被引用的 RenderedImage。

raster

protected Raster raster
正被引用的 Raster。

thumbnails

protected List<? extends BufferedImage> thumbnails
BufferedImage 缩略图的 List，或为 null。非 BufferedImage 对象一定不能存储在此 List 中。

metadata

protected IIOMetadata metadata
包含与图像关联的元数据的 IIOMetadata 对象。

构造方法详细信息

IIOImage

public IIOImage(RenderedImage image,
                List<? extends BufferedImage> thumbnails,
                IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。

所有参数都是通过引用进行存储的。

thumbnails 参数必须为 null 或者只包含 BufferedImage 对象。

参数：
image - 一个 RenderedImage。
thumbnails - BufferedImage 的 List，或者为 null。
metadata - IIOMetadata 对象，或者为 null。
抛出：
IllegalArgumentException - 如果 image 为 null。

IIOImage

public IIOImage(Raster raster,
                List<? extends BufferedImage> thumbnails,
                IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。

所有参数都是通过引用进行存储的。

参数：
raster - 一个 Raster。
thumbnails - BufferedImage 的 List，或者为 null。
metadata - IIOMetadata 对象，或者为 null。
抛出：
IllegalArgumentException - 如果 raster 为 null。
方法详细信息

getRenderedImage

public RenderedImage getRenderedImage()
返回当前设置好的 RenderedImage，如果只有一个 Raster 可用，则返回 null。

返回：
RenderedImage 或 null。
另请参见：
setRenderedImage(java.awt.image.RenderedImage)

setRenderedImage

public void setRenderedImage(RenderedImage image)
设置当前 RenderedImage。该值是通过引用进行存储的。任何现有 Raster 都被丢弃。

参数：
image - 一个 RenderedImage。
抛出：
IllegalArgumentException - 如果 image 为 null。
另请参见：
getRenderedImage()

hasRaster

public boolean hasRaster()
如果此 IIOImage 存储了一个 Raster 而不是 RenderedImage，则返回 true。

返回：
如果 Raster 可用，则返回 true。

getRaster

public Raster getRaster()
返回当前设置好的 Raster，如果只有一个 RenderedImage 可用，则返回 null。

返回：
Raster 或 null。
另请参见：
setRaster(java.awt.image.Raster)

setRaster

public void setRaster(Raster raster)
设置当前 Raster。该值是通过引用进行存储的。任何现有 RenderedImage 都被丢弃。

参数：
raster - 一个 Raster。
抛出：
IllegalArgumentException - 如果 raster 为 null。
另请参见：
getRaster()

getNumThumbnails

public int getNumThumbnails()
返回此 IIOImage 中存储的缩略图的数量。

返回：
以 int 值形式返回缩略图的数量。

getThumbnail

public BufferedImage getThumbnail(int index)
返回与主图像关联的缩略图。

参数：
index - 所需缩略图图像的索引。
返回：
以 BufferedImage 形式返回缩略图图像。
抛出：
IndexOutOfBoundsException - 如果所提供的索引为负或大于最大有效索引。
ClassCastException - 如果在缩略图列表中的给定索引处遇到一个非 BufferedImage 对象。
另请参见：
getThumbnails(), setThumbnails(java.util.List)

getThumbnails

public List<? extends BufferedImage> getThumbnails()
返回缩略图 BufferedImage 的当前 List，如果没有设置任何缩略图，则返回 null。返回一个激活的引用。

返回：
BufferedImage 缩略图的当前 List；或者 null。
另请参见：
getThumbnail(int), setThumbnails(java.util.List)

setThumbnails

public void setThumbnails(List<? extends BufferedImage> thumbnails)
将缩略图列表设置为 BufferedImage 的一个新 List 或 null。丢弃对以前 List 的引用。

thumbnails 参数必须为 null 或者只包含 BufferedImage 对象。

参数：
thumbnails - BufferedImage 缩略图的 List，或者为 null。
另请参见：
getThumbnail(int), getThumbnails()

getMetadata

public IIOMetadata getMetadata()
返回对当前 IIOMetadata 对象的引用，如果没有设置任何这样的对象，则返回 null。

返回：
IIOMetadata 对象或者 null。
另请参见：
setMetadata(javax.imageio.metadata.IIOMetadata)

setMetadata

public void setMetadata(IIOMetadata metadata)
将 IIOMetadata 设置为一个新对象或 null。

参数：
metadata - IIOMetadata 对象，或者为 null。
另请参见：
getMetadata()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOParam (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 IIOParam

java.lang.Object
    继承者  javax.imageio.IIOParam
直接已知子类：
ImageReadParam, ImageWriteParam
public abstract class IIOParam
extends Object

所有描述应该如何对流进行编码和解码的类的超类。此类包含由 ImageReadParam 和 ImageWriteParam 共享的所有变量和方法。

此类提供指定源区域和目标区域的机制。在进行读取操作时，源区域是流，内存储图像是目标区域。进行写入操作时则正好相反。在进行写入时，目标区域只能伴随支持像素替换的 writer 使用。

使用可移动的二次取样网格，可以为 reader 和 writer 指定抽取十分之一的二次取样。

可以选定源 band 和目标 band 的子集。

字段摘要
protected IIOParamController | controller 调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的 IIOParamController。
protected IIOParamController | defaultController 调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的默认 IIOParamController。
protected Point | destinationOffset 目标区域中的偏移量，应将左上部解码像素置于此处。
protected ImageTypeSpecifier | destinationType 一个 ImageTypeSpecifier，用来在进行读取操作时生成目标图像，或者在进行写入操作时设置输出颜色类型。
protected int[] | sourceBands 指示将使用的源 band 的 int 数组，或为 null。
protected Rectangle | sourceRegion 源区域；如果没有设置源区域，则为 null。
protected int | sourceXSubsampling 在水平方向应用抽取十分之一的二次取样。
protected int | sourceYSubsampling 在垂直方向应用抽取十分之一的二次取样。
protected int | subsamplingXOffset 在进行二次取样之前，将水平偏移量应用于二次取样网格。
protected int | subsamplingYOffset 在进行二次取样之前，将垂直偏移量应用于二次取样网格。
构造方法摘要
protected IIOParam()
受保护的构造方法，只能由子类调用。
方法摘要
boolean | activateController() 激活为此 IIOParam 对象安装的 IIOParamController，并返回得到的值。
IIOParamController | getController() 返回当前已安装的所有 IIOParamController。
IIOParamController | getDefaultController() 返回默认 IIOParamController（如果有），不考虑当前安装的控制器。
Point | getDestinationOffset() 返回目标图像中的偏移量，像素将置于该处。
ImageTypeSpecifier | getDestinationType() 以 ImageTypeSpecifier 的形式返回将由读取操作返回的图像类型，如果通过调用 setDestination(ImageTypeSpecifier) 设置了类型的话。
int[] | getSourceBands() 返回要使用的源 band 的集合。
Rectangle | getSourceRegion() 返回将使用的源区域。
int | getSourceXSubsampling() 返回对于每个像素要前进的源列数。
int | getSourceYSubsampling() 返回对于每个像素要前进的行数。
int | getSubsamplingXOffset() 返回二次取样网格的水平偏移量。
int | getSubsamplingYOffset() 返回二次取样网格的垂直偏移量。
boolean | hasController() 如果有一个为此 IIOParam 对象安装的控制器，则返回 true。
void | setController(IIOParamController controller) 设置在调用 activateController 方法时用来为 IIOParam 对象提供设置值的 IIOParamController，重写所有默认控制器。
void | setDestinationOffset(Point destinationOffset) 指定目标图像中的偏移量。
void | setDestinationType(ImageTypeSpecifier destinationType) 使用 ImageTypeSpecifier 设置目标图像的所需图像类型。
void | setSourceBands(int[] sourceBands) 设置将要使用的源 band 的索引。
void | setSourceRegion(Rectangle sourceRegion) 设置感兴趣的源区域。
void | setSourceSubsampling(int sourceXSubsampling, int sourceYSubsampling, int subsamplingXOffset, int subsamplingYOffset) 指定进行 I/O 时应用的抽取十分之一的二次取样。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

sourceRegion

protected Rectangle sourceRegion
源区域；如果没有设置源区域，则为 null。

sourceXSubsampling

protected int sourceXSubsampling
在水平方向应用抽取十分之一的二次取样。默认情况下，该值为 1。该值一定不能为负数或 0。

sourceYSubsampling

protected int sourceYSubsampling
在垂直方向应用抽取十分之一的二次取样。默认情况下，该值为 1。该值一定不能为负数或 0。

subsamplingXOffset

protected int subsamplingXOffset
在进行二次取样之前，将水平偏移量应用于二次取样网格。要使用的第一个像素将距区域或图像（如果没有指定区域）的原点偏移此量。

subsamplingYOffset

protected int subsamplingYOffset
在进行二次取样之前，将垂直偏移量应用于二次取样网格。要使用的第一个像素将距区域或图像（如果没有指定区域）的起点偏移此量。

sourceBands

protected int[] sourceBands
指示将使用的源 band 的 int 数组，或为 null。如果为 null，则将使用的源 band 集合如 setSourceBands 方法的注释所述。不允许任何为负。

destinationType

protected ImageTypeSpecifier destinationType
一个 ImageTypeSpecifier，用来在进行读取操作时生成目标图像，或者在进行写入操作时设置输出颜色类型。如果没有设置，则该值将为 null。默认情况下，该值为 null。

destinationOffset

protected Point destinationOffset
目标区域中的偏移量，应将左上部解码像素置于此处。默认情况下，该值为 (0, 0)。

defaultController

protected IIOParamController defaultController
调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的默认 IIOParamController。此默认控制器应该由子类设置，这些子类可以选择提供自己的默认控制器（通常是一个 GUI）来设置参数。

另请参见：
IIOParamController, getDefaultController(), activateController()

controller

protected IIOParamController controller
调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的 IIOParamController。此值重写任何默认控制器，即使为 null 时也是如此。

另请参见：
IIOParamController, setController(IIOParamController), hasController(), activateController()
构造方法详细信息

IIOParam

protected IIOParam()
受保护的构造方法，只能由子类调用。

方法详细信息

setSourceRegion

public void setSourceRegion(Rectangle sourceRegion)
设置感兴趣的源区域。感兴趣的区域被描述为一个矩形，源图像左上角为像素 (0, 0)，该值向下向右递增。所使用的实际像素数将取决于由 setSourceSubsampling 设置的二次取样因子。如果已经在二次取样中将此像素数设置为零，则将抛出 IllegalStateException。

将根据需要限制此方法指定的感兴趣的源区域，使其适合源区域边界，以及在实际 I/O 时符合目标偏移量、宽度和高度。

sourceRegion 值为 null 表示将取消所有区域限制，这将导致使用整个图像。

参数：
sourceRegion - 指定感兴趣的源区域的 Rectangle；或为 null。
抛出：
IllegalArgumentException - 如果 sourceRegion 不为 null 且 sourceRegion.x 或 sourceRegion.y 为负。
IllegalArgumentException - 如果 sourceRegion 不为 null 且 sourceRegion.width 或 sourceRegion.height 为负数或 0。
IllegalStateException - 如果二次取样将使此区域有一个为零的二次取样宽度或高度。
另请参见：
getSourceRegion(),
setSourceSubsampling(int, int, int, int),
setDestinationOffset(java.awt.Point),
getDestinationOffset()

getSourceRegion

public Rectangle getSourceRegion()
返回将使用的源区域。返回的值是通过最近一次调用 setSourceRegion 设置的值，如果没有设置区域，则返回值将为 null。

返回：
Rectangle 形式的感兴趣源区域；或者 null。
另请参见：
setSourceRegion(java.awt.Rectangle)

setSourceSubsampling

public void setSourceSubsampling(int sourceXSubsampling,
                                 int sourceYSubsampling,
                                 int subsamplingXOffset,
                                 int subsamplingYOffset)
指定进行 I/O 时应用的抽取十分之一的二次取样。sourceXSubsampling 和 sourceYSubsampling 参数指定二次取样的周期（即 每个源像素之后前进的行数和列数）。具体地说，周期为 1 将对每行或每列使用二次取样；周期为 2 则每隔一行或一列使用。subsamplingXOffset 和 subsamplingYOffset 参数指定距离第一个二次取样像素的区域（或图像）原点的偏移量。在将一个非常大的源图像二次取样到将组合成一个完整的二次取样图像的目标区域中时，调整二次取样网格的原点对避免裂缝很有用。大多数用户只要让这些参数为 0 即可。

要使用的像素行和扫描行数量的计算如下所示。

扫描行中二次取样像素数的计算方式如下

truncate[(width - subsamplingXOffset + sourceXSubsampling - 1) / sourceXSubsampling]。

如果在该区域中此宽度为零，则抛出 IllegalStateException。

可以用类似的方法计算要使用的扫描行数。

可以将二次取样网格设置为从源区域原点以外的其他某个地方开始，如果正使用源区域创建大型图像的二次取样 tile，其中 tile 的宽度和高度不是二次取样周期的倍数，这将非常有用。如果在二次取样网格中不能使 tile 保持一致，则在 tile 的边界上会出现某些误差产物。通过调整每个 tile 的二次取样网格偏移量来校正，可避免这些误差产物。权宜之计是，为了避免出现误差产物，tile 的大小并不都是相同的。在这种情况下使用的网格偏移量的计算方式如下：
grid offset = [period - (region offset modulo period)] modulo period)

如果 sourceXSubsampling 或 sourceYSubsampling 为 0 或负数，则将抛出 IllegalArgumentException。

如果 subsamplingXOffset 或 subsamplingYOffset 为负数或大于等于相应的周期，则将抛出 IllegalArgumentException。

没有 unsetSourceSubsampling 方法；调用 setSourceSubsampling(1, 1, 0, 0) 来恢复默认值即可。

参数：
sourceXSubsampling - 要在像素之间前进的列数。
sourceYSubsampling - 要在像素之间前进的行数。
subsamplingXOffset - 该区域或图像（如果没有设置区域）中第一次二次取样的水平偏移量。
subsamplingYOffset - 该区域或图像（如果没有设置区域）中第一次二次取样的水平偏移量。
抛出：
IllegalArgumentException - 如果任意一个周期为负数或 0，或者任意一个网格偏移量为负数或大于相应的周期。
IllegalStateException - 如果源区域中二次取样输出不包含任何像素。

getSourceXSubsampling

public int getSourceXSubsampling()
返回对于每个像素要前进的源列数。

如果尚未调用 setSourceSubsampling，则返回 1（此为修正值）。

返回：
源二次取样的 X 周期。
另请参见：
setSourceSubsampling(int, int, int, int), getSourceYSubsampling()

getSourceYSubsampling

public int getSourceYSubsampling()
返回对于每个像素要前进的行数。

如果尚未调用 setSourceSubsampling，则返回 1（此为修正值）。

返回：
源二次取样的 Y 周期。
另请参见：
setSourceSubsampling(int, int, int, int), getSourceXSubsampling()

getSubsamplingXOffset

public int getSubsamplingXOffset()
返回二次取样网格的水平偏移量。

如果尚未调用 setSourceSubsampling，则返回 0（此为修正值）。

返回：
源二次取样网格的 X 偏移量。
另请参见：
setSourceSubsampling(int, int, int, int), getSubsamplingYOffset()

getSubsamplingYOffset

public int getSubsamplingYOffset()
返回二次取样网格的垂直偏移量。

如果尚未调用 setSourceSubsampling，则返回 0（此为修正值）。

返回：
源二次取样网格的 Y 偏移量。
另请参见：
setSourceSubsampling(int, int, int, int), getSubsamplingXOffset()

setSourceBands

public void setSourceBands(int[] sourceBands)
设置将要使用的源 band 的索引。索引不能重复。

null 值指示所有源 band 都将被使用。

在进行读取时，如果指定大于最大可用源 band 索引的值，或者要使用的源 band 的数量与目标 band 的数量不同，则 reader 或 writer 将抛出 IllegalArgumentException。可以使用 ImageReader.checkReadParamBandSettings 方法自动进行此测试。

根据语义，为该数组生成一个副本；调用此方法后对数组内容进行的更改对此 IIOParam 没有影响。

参数：
sourceBands - 将要使用的整数 band 索引组成的数组。
抛出：
IllegalArgumentException - 如果 sourceBands 包含一个负数或重复的值。
另请参见：
getSourceBands(),
ImageReadParam.setDestinationBands(int[]),
ImageReader.checkReadParamBandSettings(javax.imageio.ImageReadParam, int, int)

getSourceBands

public int[] getSourceBands()
返回要使用的源 band 的集合。返回的值是通过最近一次调用 setSourceBands 设置的值，如果没有调用过 setSourceBands，则返回 null。

根据语义，返回的数组是一个副本；调用此方法后对数组内容进行的更改对此 IIOParam 没有影响。

返回：
要使用的源 band 的集合；或者 null。
另请参见：
setSourceBands(int[])

setDestinationType

public void setDestinationType(ImageTypeSpecifier destinationType)
使用 ImageTypeSpecifier 设置目标图像的所需图像类型。

在读取时，如果已经使用此方法设置目标区域的布局，则每次调用 ImageReader 的 read 方法都将返回一个新的 BufferedImage，它使用由所提供的类型说明符指定的格式。此方法的一个副作用是，任何由 ImageReadParam.setDestination(BufferedImage) 设置的目标 BufferedImage 将不再被设置为目标。换句话说，在调用 setDestination((BufferedImage)null) 时可以考虑此方法。

在写入时，或许会使用目标类型确定图像的颜色类型。SampleModel 信息将被忽略，其可以为 null。例如，一个 4 band 的图像可以表示 CMYK 或 RGBA 数据。如果设置了目标类型，则其 ColorModel 将重写该图像自身的所有 ColorModel。这在使用 setSourceBands 时极其重要，因为该图像的 ColorModel 将引用整个图像，而不是被写入的 band 的子集。

参数：
destinationType - 用来确定目标布局和颜色类型的 ImageTypeSpecifier。
另请参见：
getDestinationType()

getDestinationType

public ImageTypeSpecifier getDestinationType()
以 ImageTypeSpecifier 的形式返回将由读取操作返回的图像类型，如果通过调用 setDestination(ImageTypeSpecifier) 设置了类型的话。如果没有设置类型，则返回 null。

返回：
描述目标类型的 ImageTypeSpecifier；或者 null。
另请参见：
setDestinationType(javax.imageio.ImageTypeSpecifier)

setDestinationOffset

public void setDestinationOffset(Point destinationOffset)
指定目标图像中的偏移量。在进行读取操作时，将在该处放置以后解码的像素；在进行写入操作时，将在该处写入一个区域。

在读取时，写入目标 BufferedImage 中的区域将从此偏移量开始，并且其宽度和高度是通过感兴趣的源区域、二次取样参数和目标边界确定的。

普通写入操作不受此方法的影响，只有使用 ImageWriter.replacePixels 执行的写入操作会受影响。对于此类写入操作，指定的偏移量位于其像素正被修改的输出流图像中。

没有 unsetDestinationOffset 方法；调用 setDestinationOffset(new Point(0, 0)) 来恢复默认值即可。

参数：
destinationOffset - 目标中 Point 形式的偏移量。
抛出：
IllegalArgumentException - 如果 destinationOffset 为 null。
另请参见：
getDestinationOffset(), ImageWriter.replacePixels(java.awt.image.RenderedImage, javax.imageio.ImageWriteParam)

getDestinationOffset

public Point getDestinationOffset()
返回目标图像中的偏移量，像素将置于该处。

如果尚未调用 setDestinationOffsets，则返回 X 和 Y 值为零的 Point（此为修正值）。

返回：
Point 形式的目标偏移量。
另请参见：
setDestinationOffset(java.awt.Point)

setController

public void setController(IIOParamController controller)
设置在调用 activateController 方法时用来为 IIOParam 对象提供设置值的 IIOParamController，重写所有默认控制器。如果该参数为 null，则不使用任何控制器，包括所有默认控制器。要恢复默认值，请使用 setController(getDefaultController())。

参数：
controller - 一个适当的 IIOParamController，或者为 null。
另请参见：
IIOParamController,
getController(),
getDefaultController(),
hasController(),
activateController()

getController

public IIOParamController getController()
返回当前已安装的所有 IIOParamController。返回值可以是默认控制器（如果有）、null 或最近一次调用 setController 时使用的参数。

返回：
当前安装的 IIOParamController；或者 null。
另请参见：
IIOParamController,
setController(javax.imageio.IIOParamController),
getDefaultController(),
hasController(),
activateController()

getDefaultController

public IIOParamController getDefaultController()
返回默认 IIOParamController（如果有），不考虑当前安装的控制器。如果没有默认安装器，则返回 null。

返回：
默认 IIOParamController 或 null。
另请参见：
IIOParamController,
setController(IIOParamController),
getController(),
hasController(),
activateController()

hasController

public boolean hasController()
如果有一个为此 IIOParam 对象安装的控制器，则返回 true。如果 getController 不返回 null，则此方法将返回 true。

返回：
如果安装了一个控制器，则返回 true。
另请参见：
IIOParamController,
setController(IIOParamController),
getController(),
getDefaultController(),
activateController()

activateController

public boolean activateController()
激活为此 IIOParam 对象安装的 IIOParamController，并返回得到的值。当此方法返回 true 时，此 IIOParam 对象的所有值都已准备好进行下一次读取或写入操作。如果返回 false，则此对象中没有任何设置会被干扰（也就是说，用户取消了该操作）。

通常，控制器将是一个 GUI，为特定插件的 IIOParam 的子类提供用户界面。不过，控制器不必一定是 GUI。

返回：
如果控制器完全正常，则返回 true。
抛出：
IllegalStateException - 如果当前没有安装控制器。
另请参见：
IIOParamController,
setController(IIOParamController),
getController(),
getDefaultController(),
hasController()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOParamController (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
接口 IIOParamController

public interface IIOParamController

该接口将由可以确定 IIOParam 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。此接口只指定调用控制器的一般 activate 方法，不考虑该控制器获得值的方式（也就是说，该控制器是提供一个 GUI 还是只计算一个值的集合与此接口无关）。

在 activate 方法中，控制器通过查询 IIOParam 对象的 get 方法获得初始值，通过所有的方法修改这些值，然后调用 IIOParam 对象的 set 方法修改适当的设置。通常，在最终提交时，将马上调用所有这些 set 方法，以便删除操作不会干扰现有值。总之，应用程序可能期望在 activate 方法返回 true 时，IIOParam 对象已经准备好用于读取或写入操作。

供应商可以选择为他们针对特定插件定义的 IIOParam 子类提供 GUI。其可以作为相应 IIOParam 子类中的默认控制器。

应用程序可以重写任何默认 GUI，提供嵌套在其框架中属于自己的控制器。需要的所有事物就是 activate 方法有模式地运转（直到被取消或提交时才返回），尽管不需要提供一个显式的有模式对话框。这种无模式 GUI 组件大致将按如下方式进行编码：

 class MyGUI extends SomeComponent implements IIOParamController {

    public MyGUI() {
        // ...
        setEnabled(false);
    }

    public boolean activate(IIOParam param) {
        // disable other components if desired
        setEnabled(true);
        // go to sleep until either cancelled or committed
        boolean ret = false;
        if (!cancelled) {
            // set values on param
            ret = true;
        }
        setEnabled(false);
        // enable any components disabled above
        return ret;
    }

作为选择，可以将算法过程（比如数据库查找或解析命令行）用作控制器，在这种情况下，activate 方法将只查找或计算设置值、调用 IIOParam.setXXX 方法以及返回 true。

另请参见：
IIOParam.setController(javax.imageio.IIOParamController),
IIOParam.getController(),
IIOParam.getDefaultController(),
IIOParam.hasController(),
IIOParam.activateController()

方法摘要
 boolean activate(IIOParam param)
激活控制器。

方法详细信息

activate

boolean activate(IIOParam param)
激活控制器。如果返回 true，则 IIOParam 对象中的所有设置值都应该已经准备好用于读取或写入操作。如果返回 false，则不会干扰 IIOParam 对象中的任何设置值（也就是说，用户取消了该操作）。

参数：
param - 要修改的 IIOParam 对象。
返回：
如果已经修改了 IIOParam，则返回 true，否则返回 false。
抛出：
IllegalArgumentException - 如果 param 为 null 或者不是正确类的实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageIO (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 ImageIO

java.lang.Object
    继承者  javax.imageio.ImageIO

public final class ImageIO
extends Object

该类包含一些用来查找 ImageReader 和 ImageWriter 以及执行简单编码和解码的静态便捷方法。

方法摘要
static ImageInputStream | createImageInputStream(Object input) 返回一个 ImageInputStream，它将从给定 Object 中获取输入。
static ImageOutputStream | createImageOutputStream(Object output) 返回一个 ImageOutputStream，它将其输出发送到给定 Object。
static File | getCacheDirectory() 返回由 setCacheDirectory 设置的当前值；如果没有显式设置该值，则返回 null。
static ImageReader | getImageReader(ImageWriter writer) 返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。
static Iterator<ImageReader> | getImageReaders(Object input) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。
static Iterator<ImageReader> | getImageReadersByFormatName(String formatName) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。
static Iterator<ImageReader> | getImageReadersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。
static Iterator<ImageReader> | getImageReadersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。
static Iterator<ImageTranscoder> | getImageTranscoders(ImageReader reader, ImageWriter writer) 返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。
static ImageWriter | getImageWriter(ImageReader reader) 返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。
static Iterator<ImageWriter> | getImageWriters(ImageTypeSpecifier type, String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
static Iterator<ImageWriter> | getImageWritersByFormatName(String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。
static Iterator<ImageWriter> | getImageWritersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。
static Iterator<ImageWriter> | getImageWritersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。
static String[] | getReaderFileSuffixes() 返回一个 String 数组，该数组列出与当前已注册 reader 集合所理解的格式关联的所有文件后缀。
static String[] | getReaderFormatNames() 返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有非正式格式名称。
static String[] | getReaderMIMETypes() 返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有 MIME 类型。
static boolean | getUseCache() 返回由 setUseCache 设置的当前值；如果没有显式设置该值，则返回 true。
static String[] | getWriterFileSuffixes() 返回一个 String 数组，该数组列出与当前已注册 writer 集合所理解的格式关联的所有文件后缀。
static String[] | getWriterFormatNames() 返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有非正式格式名称。
static String[] | getWriterMIMETypes() 返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有 MIME 类型。
static BufferedImage | read(File input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。
static BufferedImage | read(ImageInputStream stream) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。
static BufferedImage | read(InputStream input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。
static BufferedImage | read(URL input) 返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。
static void | scanForPlugins() 扫描应用程序类路径上的插件，加载其服务提供者类，并使用 IIORegistry 为每一个找到的插件注册一个服务提供者实例。
static void | setCacheDirectory(File cacheDirectory) 设置将在其中创建缓存文件的目录。
static void | setUseCache(boolean useCache) 设置一个标记，指示在创建 ImageInputStream 和 ImageOutputStream 时是否应该使用基于磁盘的缓存文件。
static boolean | write(RenderedImage im, String formatName, File output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 File。
static boolean | write(RenderedImage im, String formatName, ImageOutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。
static boolean | write(RenderedImage im, String formatName, OutputStream output) 使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

scanForPlugins

public static void scanForPlugins()
扫描应用程序类路径上的插件，加载其服务提供者类，并使用 IIORegistry 为每一个找到的插件注册一个服务提供者实例。

需要此方法是因为应用程序类路径在理论上是可以更改的，或者说附加的插件可以变得可用。不需要每次调用 API 时都重新扫描类路径，可以只在第一次调用时自动扫描。客户端可以调用此方法来启动重新扫描。因此，只有在运行时使新插件动态可用的复杂应用程序才需要调用此方法。

上下文 ClassLoader 的 getResources 方法被用来沿应用程序类路径查找包含名为 META-INF/services/javax.imageio.spi.classname 的文件的 JAR 文件，其中 classname 是 ImageReaderSpi、ImageWriterSpi、ImageTranscoderSpi、ImageInputStreamSpi 或 ImageOutputStreamSpi 之一。

所查找文件的内容表示实际实现类的名称，这些类实现上述服务提供者接口；然后可以使用默认类加载器加载每个类并实例化每个类的实例，然后将其放入注册表中供以后获取。

确切的搜索位置集合取决于 Java 运行时环境的实现。

另请参见：
ClassLoader.getResources(java.lang.String)

setUseCache

public static void setUseCache(boolean useCache)
设置一个标记，指示在创建 ImageInputStream 和 ImageOutputStream 时是否应该使用基于磁盘的缓存文件。

在从标准 InputStream 中读取数据时，有必要在缓存中保存以前读取的信息，因为底层流不允许重新读取数据。类似地，在将数据写入标准 OutputStream 时，可以使用某一缓存来允许以前写入的值在被刷新并转到最终目标前可以被更改。

该缓存可以驻留在主存或磁盘上。如果将此标记设置为 false，则不允许将磁盘用于将来的流，这在使用小图像时很有利，因为可以免除创建和销毁文件所带来的开销。

在启动时，该值被设置为 true。

参数：
useCache - 指示是否应使用缓存文件（在可选的情况下）的 boolean。
另请参见：
getUseCache()

getUseCache

public static boolean getUseCache()
返回由 setUseCache 设置的当前值；如果没有显式设置该值，则返回 true。

返回：
如果可以将基于磁盘的缓存用于 ImageInputStream 和 ImageOutputStream，则返回 true。
另请参见：
setUseCache(boolean)

setCacheDirectory

public static void setCacheDirectory(File cacheDirectory)
设置将在其中创建缓存文件的目录。值为 null 表示将使用与系统有关的默认临时文件目录。如果 getUseCache 返回 false，则忽略此值。

参数：
cacheDirectory - 指定目录的 File。
抛出：
SecurityException - 如果安全管理器拒绝对该目录的访问。
IllegalArgumentException - 如果 cacheDir 为非 null 但它不是一个目录。
另请参见：
File.createTempFile(String, String, File), getCacheDirectory()

getCacheDirectory

public static File getCacheDirectory()
返回由 setCacheDirectory 设置的当前值；如果没有显式设置该值，则返回 null。

返回：
一个 File，表示将在其中创建缓存文件的目录；null 指示与系统有关的默认临时文件目录。
另请参见：
setCacheDirectory(java.io.File)

createImageInputStream

public static ImageInputStream createImageInputStream(Object input)
                                               throws IOException
返回一个 ImageInputStream，它将从给定 Object 中获取输入。查询使用 IIORegistry 类注册的 ImageInputStreamSpi 集合，能够从所提供的对象中获取输入的第一个 ImageInputStreamSpi 将被用来创建返回的 ImageInputStream。如果没有合适的 ImageInputStreamSpi 存在，则返回 null。

getUseCache 和 getCacheDirectory 返回的当前缓存设置将被用来控制缓存。

参数：
input - 用作输入源的 Object，比如 File、可读取的 RandomAccessFile 或 InputStream。
返回：
一个 ImageInputStream 或 null。
抛出：
IllegalArgumentException - 如果 input 为 null。
IOException - 如果需要缓存文件但无法创建。
另请参见：
ImageInputStreamSpi

createImageOutputStream

public static ImageOutputStream createImageOutputStream(Object output)
                                                 throws IOException
返回一个 ImageOutputStream，它将其输出发送到给定 Object。查询使用 IIORegistry 类注册的 ImageOutputStreamSpi 集合，能够从所提供的对象发送输出的第一个 ImageOutputStreamSpi 将被用来创建返回的 ImageOutputStream。如果没有合适的 ImageOutputStreamSpi 存在，则返回 null。

getUseCache 和 getCacheDirectory 返回的当前缓存设置将被用来控制缓存。

参数：
output - 用作输出目标的 Object，比如 File、可写入的 RandomAccessFile 或 OutputStream。
返回：
一个 ImageOutputStream 或 null。
抛出：
IllegalArgumentException - 如果 output 为 null。
IOException - 如果需要缓存文件但无法创建。
另请参见：
ImageOutputStreamSpi

getReaderFormatNames

public static String[] getReaderFormatNames()
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有非正式格式名称。

返回：
String 数组。

getReaderMIMETypes

public static String[] getReaderMIMETypes()
返回一个 String 数组，该数组列出被当前已注册 reader 集合所理解的所有 MIME 类型。

返回：
String 数组。

getReaderFileSuffixes

public static String[] getReaderFileSuffixes()
返回一个 String 数组，该数组列出与当前已注册 reader 集合所理解的格式关联的所有文件后缀。

返回：
String 数组。
从以下版本开始：
1.6

getImageReaders

public static Iterator<ImageReader> getImageReaders(Object input)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。

在从此方法退出时，该流的位置仍然是它以前的位置。

参数：
input - ImageInputStream 或包含解码图像数据的其他 Object。
返回：
包含 ImageReader 的 Iterator。
抛出：
IllegalArgumentException - 如果 input 为 null。
另请参见：
ImageReaderSpi.canDecodeInput(java.lang.Object)

getImageReadersByFormatName

public static Iterator<ImageReader> getImageReadersByFormatName(String formatName)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。

参数：
formatName - 包含非正式格式名称的 String（例如 "jpeg" 或 "tiff"）。
返回：
包含 ImageReader 的 Iterator。
抛出：
IllegalArgumentException - 如果 formatName 为 null。
另请参见：
ImageReaderWriterSpi.getFormatNames()

getImageReadersBySuffix

public static Iterator<ImageReader> getImageReadersBySuffix(String fileSuffix)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。

参数：
fileSuffix - 包含文件后缀的 String（例如 "jpg" 或 "tiff"）。
返回：
包含 ImageReader 的 Iterator。
抛出：
IllegalArgumentException - 如果 fileSuffix 为 null。
另请参见：
ImageReaderWriterSpi.getFileSuffixes()

getImageReadersByMIMEType

public static Iterator<ImageReader> getImageReadersByMIMEType(String MIMEType)
返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。

参数：
MIMEType - 包含文件后缀的 String（例如 "image/jpeg" 或 "image/x-bmp"）。
返回：
包含 ImageReader 的 Iterator。
抛出：
IllegalArgumentException - 如果 MIMEType 为 null。
另请参见：
ImageReaderWriterSpi.getMIMETypes()

getWriterFormatNames

public static String[] getWriterFormatNames()
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有非正式格式名称。

返回：
String 数组。

getWriterMIMETypes

public static String[] getWriterMIMETypes()
返回一个 String 数组，该数组列出当前已注册 writer 集合所理解的所有 MIME 类型。

返回：
String 数组。

getWriterFileSuffixes

public static String[] getWriterFileSuffixes()
返回一个 String 数组，该数组列出与当前已注册 writer 集合所理解的格式关联的所有文件后缀。

返回：
String 数组。
从以下版本开始：
1.6

getImageWritersByFormatName

public static Iterator<ImageWriter> getImageWritersByFormatName(String formatName)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。

参数：
formatName - 包含非正式格式名称的 String（例如 "jpeg" 或 "tiff"）。
返回：
包含 ImageWriter 的 Iterator。
抛出：
IllegalArgumentException - 如果 formatName 为 null。
另请参见：
ImageReaderWriterSpi.getFormatNames()

getImageWritersBySuffix

public static Iterator<ImageWriter> getImageWritersBySuffix(String fileSuffix)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。

参数：
fileSuffix - 包含文件后缀的 String（例如 "jpg" 或 "tiff"）。
返回：
包含 ImageWriter 的 Iterator。
抛出：
IllegalArgumentException - 如果 fileSuffix 为 null。
另请参见：
ImageReaderWriterSpi.getFileSuffixes()

getImageWritersByMIMEType

public static Iterator<ImageWriter> getImageWritersByMIMEType(String MIMEType)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。

参数：
MIMEType - 包含文件后缀的 String（例如 "image/jpeg" 或 "image/x-bmp"）。
返回：
包含 ImageWriter 的 Iterator。
抛出：
IllegalArgumentException - 如果 MIMEType 为 null。
另请参见：
ImageReaderWriterSpi.getMIMETypes()

getImageWriter

public static ImageWriter getImageWriter(ImageReader reader)
返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。可以使用此机制获取一个 ImageWriter，它将理解由 ImageReader 生成的非像素元数据（由 IIOMetadata 对象编码）的内部结构。通过从 ImageReader 获取此数据并将其传给使用此方法获取的 ImageWriter，客户端程序可以读取图像，以某种方式修改图像，然后将其写回，并保留所有的元数据，而不需要理解有关元数据结构甚至图像格式的任何信息。注意，此方法返回“首选”writer，它是 javax.imageio.spi.ImageReaderSpi.getImageWriterSpiNames() 返回的列表中列出的第一个 writer。

参数：
reader - 已注册 ImageReader 的实例。
返回：
一个 ImageWriter 或 null。
抛出：
IllegalArgumentException - 如果 reader 为 null。
另请参见：
getImageReader(ImageWriter), ImageReaderSpi.getImageWriterSpiNames()

getImageReader

public static ImageReader getImageReader(ImageWriter writer)
返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。提供此方法主要是为了与 getImageWriter(ImageReader) 对称。注意，此方法返回“首选”reader，它是 javax.imageio.spi.ImageWriterSpi.getImageReaderSpiNames() 返回的列表中列出的第一个 reader。

参数：
writer - 已注册 ImageWriter 的实例。
返回：
一个 ImageReader 或 null。
抛出：
IllegalArgumentException - 如果 writer 为 null。
另请参见：
getImageWriter(ImageReader), ImageWriterSpi.getImageReaderSpiNames()

getImageWriters

public static Iterator<ImageWriter> getImageWriters(ImageTypeSpecifier type,
                                                    String formatName)
返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。

参数：
type - 指示将写入的图像布局的 ImageTypeSpecifier。
formatName - format 的非正式名称。
返回：
包含 ImageWriter 的 Iterator。
抛出：
IllegalArgumentException - 如果任何参数为 null。
另请参见：
ImageWriterSpi.canEncodeImage(ImageTypeSpecifier)

getImageTranscoders

public static Iterator<ImageTranscoder> getImageTranscoders(ImageReader reader,
                                                            ImageWriter writer)
返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。

参数：
reader - 一个 ImageReader。
writer - 一个 ImageWriter。
返回：
包含 ImageTranscoder 的 Iterator。
抛出：
IllegalArgumentException - 如果 reader 或 writer 为 null。

read

public static BufferedImage read(File input)
                          throws IOException
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 File 的结果。该 File 被包装在一个 ImageInputStream 中。如果没有已注册的 ImageReader 声称能够读取得到的流，则返回 null。

使用 getUseCache 和 getCacheDirectory 返回的当前缓存设置控制所创建的 ImageInputStream 中的缓存。

注意，不存在将 String 形式的文件名作为参数的 read 方法；在根据文件名创建 File 之后使用此方法代替。

此方法不会试图查找可以直接从 File 中读取的 ImageReader；这可以使用 IIORegistry 和 ImageReaderSpi 来完成。

参数：
input - 将从中读取数据的 File。
返回：
包含解码的输入内容的 BufferedImage，或者返回 null。
抛出：
IllegalArgumentException - 如果 input 为 null。
IOException - 如果在读取过程中发生错误。

read

public static BufferedImage read(InputStream input)
                          throws IOException
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 InputStream 的结果。该 InputStream 被包装在一个 ImageInputStream 中。如果没有已注册的 ImageReader 声称能够读取得到的流，则返回 null。

使用 getUseCache 和 getCacheDirectory 返回的当前缓存设置控制所创建的 ImageInputStream 中的缓存。

此方法不会试图查找可以直接从 InputStream 中读取的 ImageReader；这可以使用 IIORegistry 和 ImageReaderSpi 来完成。

此方法在读取操作完成后不会 关闭提供的 InputStream；如果需要，调用者负责关闭该流。

参数：
input - 将从中读取数据的 InputStream。
返回：
包含解码的输入内容的 BufferedImage，或者返回 null。
抛出：
IllegalArgumentException - 如果 input 为 null。
IOException - 如果在读取过程中发生错误。

read

public static BufferedImage read(URL input)
                          throws IOException
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 URL 的结果。InputStream 是从 URL 中获得的，它被包装在 ImageInputStream 中。如果没有已注册的 ImageReader 声称能够读取得到的流，则返回 null。

使用 getUseCache 和 getCacheDirectory 返回的当前缓存设置控制所创建的 ImageInputStream 中的缓存。

此方法不会试图查找可以直接从 URL 中读取的 ImageReader；这可以使用 IIORegistry 和 ImageReaderSpi 来完成。

参数：
input - 将从中读取数据的 URL。
返回：
包含解码的输入内容的 BufferedImage，或者返回 null。
抛出：
IllegalArgumentException - 如果 input 为 null。
IOException - 如果在读取过程中发生错误。

read

public static BufferedImage read(ImageInputStream stream)
                          throws IOException
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。如果没有已注册的 ImageReader 声称能够读取该流，则返回 null。

与此类中大多数其他方法不同，此方法在读取操作完成后会 关闭提供的 ImageInputStream，除非返回 null，在这种情况下，此方法不会 关闭该流。

参数：
stream - 将从中读取数据的 ImageInputStream。
返回：
包含解码的输入内容的 BufferedImage，或者返回 null。
抛出：
IllegalArgumentException - 如果 stream 为 null。
IOException - 如果在读取过程中发生错误。

write

public static boolean write(RenderedImage im,
                            String formatName,
                            ImageOutputStream output)
                     throws IOException
使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。从当前流指针开始将图像写入 ImageOutputStream，并覆盖该点之后的现有流数据（如果有）。

此方法在写入操作完成后不会 关闭提供的 ImageOutputStream；如果需要，调用者负责关闭该流。

参数：
im - 要写入的 RenderedImage。
formatName - 包含格式非正式名称的 String。
output - 将在其中写入数据的 ImageOutputStream。
返回：
如果没有找到合适的 writer，则返回 false。
抛出：
IllegalArgumentException - 如果任何参数为 null。
IOException - 如果在写入过程中发生错误。

write

public static boolean write(RenderedImage im,
                            String formatName,
                            File output)
                     throws IOException
使用支持给定格式的任意 ImageWriter 将一个图像写入 File。如果已经有一个 File 存在，则丢弃其内容。

参数：
im - 要写入的 RenderedImage。
formatName - 包含格式非正式名称的 String。
output - 将在其中写入数据的 File。
返回：
如果没有找到合适的 writer，则返回 false。
抛出：
IllegalArgumentException - 如果任何参数为 null。
IOException - 如果在写入过程中发生错误。

write

public static boolean write(RenderedImage im,
                            String formatName,
                            OutputStream output)
                     throws IOException
使用支持给定格式的任意 ImageWriter 将一个图像写入 OutputStream。

此方法在写入操作完成后不会 关闭提供的 OutputStream；如果需要，调用者负责关闭该流。

getUseCache 和 getCacheDirectory 返回的当前缓存设置将被用来控制缓存。

参数：
im - 要写入的 RenderedImage。
formatName - 包含格式非正式名称的 String。
output - 将在其中写入数据的 OutputStream。
返回：
如果没有找到合适的 writer，则返回 false。
抛出：
IllegalArgumentException - 如果任何参数为 null。
IOException - 如果在写入过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 ImageReader

java.lang.Object
    继承者  javax.imageio.ImageReader

public abstract class ImageReader
extends Object

用来解析和解码图像的抽象超类。在 Java Image I/O 框架的上下文中读入图像的类必须创建此类的子类。

ImageReader 对象通常由特定格式的服务提供者接口 (SPI) 类实例化。服务提供者类（例如 ImageReaderSpi 的实例）向 IIORegistry 注册，后者使用前者进行格式识别和表示可用格式 reader 和 writer。

在设置输入源时（使用 setInput 方法），可以将它标记为“只向前搜索”。此设置意味着包含在输入源中的图像将只按顺序读取，可能允许 reader 避免缓存包含与以前已经读取的图像关联的数据的那些输入部分。

另请参见：
ImageWriter, IIORegistry, ImageReaderSpi

字段摘要
protected Locale[] | availableLocales 可以用来本地化警告消息的 Locale 组成的数组，如果不支持本地化，则为 null。
protected boolean | ignoreMetadata 如果当前输入源已经被 setInput 标记为允许忽略元数据，则为 true。
protected Object | input 由 setInput 设置并由 getInput 获取的 ImageInputStream 或其他 Object。
protected Locale | locale 用于本地化的当前 Locale，如果没有设置，则为 null。
protected int | minIndex 用来读取的最小有效索引，最初为 0。
protected ImageReaderSpi | originatingProvider 实例化此对象的 ImageReaderSpi，如果其身份未知或不存在，则为 null。
protected List<IIOReadProgressListener> | progressListeners 当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected boolean | seekForwardOnly 如果当前输入源已经被 setInput 标记为允许只向前搜索，则为 true。
protected List<IIOReadUpdateListener> | updateListeners 当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<IIOReadWarningListener> | warningListeners 当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。
protected List<Locale> | warningLocales 与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。
构造方法摘要
protected ImageReader(ImageReaderSpi originatingProvider)
构造一个 ImageReader，并将其 originatingProvider 字段设置为所提供的值。
方法摘要
void | abort() 请求中止当前所有读取操作。
protected boolean | abortRequested() 如果从实例化 reader 或调用 clearAbortRequest 时起，已经请求了中止当前读取操作，则返回 true。
void | addIIOReadProgressListener(IIOReadProgressListener listener) 将 IIOReadProgressListener 添加到已注册的进度侦听器列表中。
void | addIIOReadUpdateListener(IIOReadUpdateListener listener) 将 IIOReadUpdateListener 添加到已注册的更新侦听器列表中。
void | addIIOReadWarningListener(IIOReadWarningListener listener) 将 IIOReadWarningListener 添加到已注册的警告侦听器的列表中。
boolean | canReadRaster() 如果此插件支持只读取像素数据的 Raster，则返回 true。
protected static void | checkReadParamBandSettings(ImageReadParam param, int numSrcBands, int numDstBands) reader 可用来测试 ImageReadParam 的源和目标 band 设置的有效性的实用方法。
protected void | clearAbortRequest() 清除任何以前的中止请求。
protected static void | computeRegions(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion) 计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
void | dispose() 允许释放此对象占用的所有资源。
float | getAspectRatio(int imageIndex) 以 float 的形式返回给定图像的高宽比（即宽度除以高度）。
Locale[] | getAvailableLocales() 返回可用来初始化警告侦听器和压缩设置值的 Locale 所组成的数组。
ImageReadParam | getDefaultReadParam() 返回一个适合此格式的默认 ImageReadParam 对象。
protected static BufferedImage | getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height) 返回应该在其中写入解码的像素数据的 BufferedImage。
String | getFormatName() 返回一个标识输入源格式的 String。
abstract int | getHeight(int imageIndex) 返回输入源中的给定图像的高度，以像素为单位。
abstract IIOMetadata | getImageMetadata(int imageIndex) 返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames) 返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
abstract Iterator<ImageTypeSpecifier> | getImageTypes(int imageIndex) 以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。
Object | getInput() 返回以前设置为输入源的 ImageInputStream 或其他 Object。
Locale | getLocale() 返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
int | getMinIndex() 返回用于读取图像、缩略图或图像元数据的最低有效索引。
abstract int | getNumImages(boolean allowSearch) 返回当前输入源中可用的图像数，不包括缩略图。
int | getNumThumbnails(int imageIndex) 返回与给定图像关联的缩略图预览图像的数量。
ImageReaderSpi | getOriginatingProvider() 返回传入构造方法的 ImageReaderSpi。
ImageTypeSpecifier | getRawImageType(int imageIndex) 返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。
protected static Rectangle | getSourceRegion(ImageReadParam param, int srcWidth, int srcHeight) reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。
abstract IIOMetadata | getStreamMetadata() 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | getStreamMetadata(String formatName, Set<String> nodeNames) 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。
int | getThumbnailHeight(int imageIndex, int thumbnailIndex) 返回通过索引 thumbnailIndex 指定的缩略图预览图像的高度，其与通过索引 ImageIndex 指定的图像关联。
int | getThumbnailWidth(int imageIndex, int thumbnailIndex) 返回通过索引 thumbnailIndex 指定的缩略图预览图像的宽度，其与通过索引 ImageIndex 指定的图像关联。
int | getTileGridXOffset(int imageIndex) 返回给定图像中 tile (0, 0) 的左上角的 X 坐标。
int | getTileGridYOffset(int imageIndex) 返回给定图像中 tile (0, 0) 的左上角的 Y 坐标。
int | getTileHeight(int imageIndex) 返回给定图像中 tile 的高度。
int | getTileWidth(int imageIndex) 返回给定图像中 tile 的宽度。
abstract int | getWidth(int imageIndex) 返回输入源中的给定图像的宽度，以像素为单位。
boolean | hasThumbnails(int imageIndex) 如果给定图像具有与之关联的缩略图预览图像，则返回 true。
boolean | isIgnoringMetadata() 如果已经通过传递 true 作为 setInput 方法的 ignoreMetadata 参数将当前输入源标记为允许忽略元数据，则返回 true。
boolean | isImageTiled(int imageIndex) 如果图像被组织成 tile（即等大小的非重叠矩形），则返回 true。
boolean | isRandomAccessEasy(int imageIndex) 如果给定图像的存储格式不会给像素的随机访问带来内在妨碍，则返回 true。
boolean | isSeekForwardOnly() 如果已经通过传递 true 作为 setInput 方法的 seekForwardOnly 参数将当前输入源标记为只向前搜索，则返回 true。
protected void | processImageComplete() 通过调用所有已注册 IIOReadProgressListener 的 imageComplete 方法向其广播图像读取的完成。
protected void | processImageProgress(float percentageDone) 通过调用所有已注册 IIOReadProgressListener 的 imageProgress 方法向其广播图像完成的当前百分比。
protected void | processImageStarted(int imageIndex) 通过调用所有已注册 IIOReadProgressListener 的 imageStarted 方法向其广播图像读取起始处。
protected void | processImageUpdate(BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 imageUpdate 方法向其广播样本集合的更新。
protected void | processPassComplete(BufferedImage theImage) 通过调用所有已注册 IIOReadUpdateListener 的 passComplete 方法向其广播逐步传递的结束。
protected void | processPassStarted(BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 passStarted 方法向其广播逐步传递的开始。
protected void | processReadAborted() 通过调用所有已注册 IIOReadProgressListener 的 readAborted 方法向其广播读取已经中止。
protected void | processSequenceComplete() 通过调用所有已注册 IIOReadProgressListener 的 sequenceComplete 方法向其广播图像读取序列的完成。
protected void | processSequenceStarted(int minIndex) 通过调用所有已注册 IIOReadProgressListener 的 sequenceStarted 方法向其广播图像读取序列的起始处。
protected void | processThumbnailComplete() 通过调用所有已注册 IIOReadProgressListener 的 thumbnailComplete 方法向其广播缩略图读取的完成。
protected void | processThumbnailPassComplete(BufferedImage theThumbnail) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassComplete 方法向其广播缩略图逐步传递的结束。
protected void | processThumbnailPassStarted(BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassStarted 方法向其广播缩略图逐步传递的开始。
protected void | processThumbnailProgress(float percentageDone) 通过调用所有已注册 IIOReadProgressListener 的 thumbnailProgress 方法向其广播缩略图完成的当前百分比。
protected void | processThumbnailStarted(int imageIndex, int thumbnailIndex) 通过调用所有已注册 IIOReadProgressListener 的 thumbnailStarted 方法向其广播缩略图读取的起始处。
protected void | processThumbnailUpdate(BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 通过调用所有已注册 IIOReadUpdateListener 的 thumbnailUpdate 方法向其广播缩略图图像中样本集合的更新。
protected void | processWarningOccurred(String warning) 通过调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播警告消息。
protected void | processWarningOccurred(String baseName, String keyword) 通过使用取自 ResourceBundle 的字符串调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播本地化警告消息。
BufferedImage | read(int imageIndex) 使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。
abstract BufferedImage | read(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
IIOImage | readAll(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。
Iterator<IIOImage> | readAll(Iterator<? extends ImageReadParam> params) 以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。
RenderedImage | readAsRenderedImage(int imageIndex, ImageReadParam param) 返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。
boolean | readerSupportsThumbnails() 如果此 reader 所理解的图像格式支持与之关联的缩略图预览图像，则返回 true。
Raster | readRaster(int imageIndex, ImageReadParam param) 返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。
BufferedImage | readThumbnail(int imageIndex, int thumbnailIndex) 以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。
BufferedImage | readTile(int imageIndex, int tileX, int tileY) 读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。
Raster | readTileRaster(int imageIndex, int tileX, int tileY) 返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。
void | removeAllIIOReadProgressListeners() 移除所有当前已注册的 IIOReadProgressListener 对象。
void | removeAllIIOReadUpdateListeners() 移除所有当前已注册的 IIOReadUpdateListener 对象。
void | removeAllIIOReadWarningListeners() 移除所有当前已注册的 IIOReadWarningListener 对象。
void | removeIIOReadProgressListener(IIOReadProgressListener listener) 从已注册的进度侦听器列表中移除 IIOReadProgressListener。
void | removeIIOReadUpdateListener(IIOReadUpdateListener listener) 从已注册的更新侦听器列表中移除 IIOReadUpdateListener。
void | removeIIOReadWarningListener(IIOReadWarningListener listener) 从已注册的错误侦听器列表中移除 IIOReadWarningListener。
void | reset() 将 ImageReader 恢复到其初始状态。
void | setInput(Object input) 设置用于给定的 ImageInputStream 或其他 Object 的输入源。
void | setInput(Object input, boolean seekForwardOnly) 设置用于给定的 ImageInputStream 或其他 Object 的输入源。
void | setInput(Object input, boolean seekForwardOnly, boolean ignoreMetadata) 设置用于给定的 ImageInputStream 或其他 Object 的输入源。
void | setLocale(Locale locale) 将此 ImageReader 的当前 Locale 设置为给定值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

originatingProvider

protected ImageReaderSpi originatingProvider
实例化此对象的 ImageReaderSpi，如果其身份未知或不存在，则为 null。默认情况下初始化为 null。

input

protected Object input
由 setInput 设置并由 getInput 获取的 ImageInputStream 或其他 Object。默认情况下初始化为 null。

seekForwardOnly

protected boolean seekForwardOnly
如果当前输入源已经被 setInput 标记为允许只向前搜索，则为 true。默认情况下，该值为 false。

另请参见：
minIndex, setInput(java.lang.Object, boolean, boolean)

ignoreMetadata

protected boolean ignoreMetadata
如果当前输入源已经被 setInput 标记为允许忽略元数据，则为 true。默认情况下，该值为 false。

另请参见：
setInput(java.lang.Object, boolean, boolean)

minIndex

protected int minIndex
用来读取的最小有效索引，最初为 0。如果 seekForwardOnly 为 true ，各种方法在试图访问与拥有更低索引的图像关联的数据时将抛出 IndexOutOfBoundsException。

另请参见：
seekForwardOnly, setInput(java.lang.Object, boolean, boolean)

availableLocales

protected Locale[] availableLocales
可以用来本地化警告消息的 Locale 组成的数组，如果不支持本地化，则为 null。

locale

protected Locale locale
用于本地化的当前 Locale，如果没有设置，则为 null。

warningListeners

protected List<IIOReadWarningListener> warningListeners
当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

warningLocales

protected List<Locale> warningLocales
与每个当前已注册 IIOReadWarningListener 关联的 Locale 组成的 List，默认情况下初始化为 null，它与空 List 同义。

progressListeners

protected List<IIOReadProgressListener> progressListeners
当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

updateListeners

protected List<IIOReadUpdateListener> updateListeners
当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

构造方法详细信息

ImageReader

protected ImageReader(ImageReaderSpi originatingProvider)
构造一个 ImageReader，并将其 originatingProvider 字段设置为所提供的值。

利用扩展的子类应该为提供具有签名 (ImageReaderSpi, Object) 的构造方法来获取扩展对象。如果扩展对象不合适，则将抛出 IllegalArgumentException。

参数：
originatingProvider - 调用此构造方法的 ImageReaderSpi，或者为 null。
方法详细信息

getFormatName

public String getFormatName()
                     throws IOException
返回一个标识输入源格式的 String。

默认实现返回 originatingProvider.getFormatNames()[0]。没有原始服务提供者的实现或者希望使用不同命名策略的实现应该重写此方法。

返回：
String 形式的格式名称。
抛出：
IOException - 如果从输入源中读取信息时发生错误。

getOriginatingProvider

public ImageReaderSpi getOriginatingProvider()
返回传入构造方法的 ImageReaderSpi。注意，此值可能为 null。

返回：
一个 ImageReaderSpi 或 null。
另请参见：
ImageReaderSpi

setInput

public void setInput(Object input,
                     boolean seekForwardOnly,
                     boolean ignoreMetadata)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。输入源必须在使用任何查询或读取方法之前设置。如果 input 为 null，则将移除所有当前设置的输入源。无论是哪种情况，minIndex 的值都将被初始化为 0。

seekForwardOnly 参数控制在读取每个图像（或者缩略图或图像元数据）时，由 getMinIndex 返回的值是否增加。如果 seekForwardOnly 为 true，则在 index < this.minIndex 的情况下调用 read(index) 将抛出 IndexOutOfBoundsException；否则 minIndex 的值将被设置为 index。如果 seekForwardOnly 为 false，则 minIndex 的值将仍然为 0，不考虑任何读取操作。

如果将 ignoreMetadata 参数设置为 true，则允许 reader 忽略读取操作期间遇到的任何元数据。后续调用 getStreamMetadata 和 getImageMetadata 方法可能返回 null，从 readAll 返回的 IIOImage 的 getMetadata 方法可能返回 null。设置此参数可允许 reader 更有效地工作。reader 可以选择忽略此设置值，正常地返回元数据。

子类应该注意移除任何基于以前的流缓存的信息，比如标题信息或部分解码的图像数据。

直接与捕获设备或图像协议交互的 reader 应该使用一般的 Object，而不是 ImageInputStream。合法类的集合由 reader 的服务提供者的 getInputTypes 方法公开。大多数 reader 将返回一个只包含 ImageInputStream.class 的单元素数组，指示其只接受 ImageInputStream。

默认实现根据 originatingProvider.getInputTypes() 返回的列表检查 input 参数，如果该参数不是列表中某个类的实例，则操作失败。如果将原始提供者设置为 null，则只在 input 是一个 ImageInputStream 时接受输入。

参数：
input - 将来解码时用到的 ImageInputStream 或其他 Object。
seekForwardOnly - 如果为 true，则只能按升序从此输入源中读取图像和元数据。
ignoreMetadata - 如果为 true，则可以在读取期间忽略元数据。
抛出：
IllegalArgumentException - 如果 input 不是原始服务提供者的 getInputTypes 方法返回的某个类的实例，或者不是一个 ImageInputStream。
另请参见：
ImageInputStream, getInput(), ImageReaderSpi.getInputTypes()

setInput

public void setInput(Object input,
                     boolean seekForwardOnly)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。输入源必须在使用任何查询或读取方法之前设置。如果 input 为 null，则将移除所有当前设置的输入源。无论是哪种情况，minIndex 的值都将被初始化为 0。

seekForwardOnly 参数控制在读取每个图像（或者缩略图或图像元数据）时，由 getMinIndex 返回的值是否增加。如果 seekForwardOnly 为 true，则在 index < this.minIndex 的情况下调用 read(index) 将抛出 IndexOutOfBoundsException；否则 minIndex 的值将被设置为 index。如果 seekForwardOnly 为 false，则 minIndex 的值将仍然为 0，不考虑任何读取操作。

此方法等效于 setInput(input, seekForwardOnly, false)。

参数：
input - 将来解码时用到的 ImageInputStream 或其他 Object。
seekForwardOnly - 如果为 true，则只能按升序从此输入源中读取图像和元数据。
抛出：
IllegalArgumentException - 如果 input 不是原始服务提供者的 getInputTypes 方法返回的某个类的实例，或者不是一个 ImageInputStream。
另请参见：
getInput()

setInput

public void setInput(Object input)
设置用于给定的 ImageInputStream 或其他 Object 的输入源。输入源必须在使用任何查询或读取方法之前设置。如果 input 为 null，则将移除所有当前设置的输入源。无论是哪种情况，minIndex 的值都将被初始化为 0。

此方法等效于 setInput(input, false, false)。

参数：
input - 将来解码时用到的 ImageInputStream 或其他 Object。
抛出：
IllegalArgumentException - 如果 input 不是原始服务提供者的 getInputTypes 方法返回的某个类的实例，或者不是一个 ImageInputStream。
另请参见：
getInput()

getInput

public Object getInput()
返回以前设置为输入源的 ImageInputStream 或其他 Object。如果没有设置输入源，则返回 null。

返回：
将来解码时用到的 Object；或者 null。
另请参见：
ImageInputStream, setInput(java.lang.Object, boolean, boolean)

isSeekForwardOnly

public boolean isSeekForwardOnly()
如果已经通过传递 true 作为 setInput 方法的 seekForwardOnly 参数将当前输入源标记为只向前搜索，则返回 true。

返回：
如果输入源是只向前搜索的，则返回 true。
另请参见：
setInput(java.lang.Object, boolean, boolean)

isIgnoringMetadata

public boolean isIgnoringMetadata()
如果已经通过传递 true 作为 setInput 方法的 ignoreMetadata 参数将当前输入源标记为允许忽略元数据，则返回 true。

返回：
如果可以忽略元数据，则返回 true。
另请参见：
setInput(java.lang.Object, boolean, boolean)

getMinIndex

public int getMinIndex()
返回用于读取图像、缩略图或图像元数据的最低有效索引。如果 seekForwardOnly() 为 false，此值通常仍然为 0，指示可能进行随机访问。否则，它将包含最近一次访问的索引值，并单调递增。

返回：
可读取的最小合法索引。

getAvailableLocales

public Locale[] getAvailableLocales()
返回可用来初始化警告侦听器和压缩设置值的 Locale 所组成的数组。返回 null 值指示不支持本地化。

如果 availableLocales 实例变量是非 null 的，则默认实现返回该变量的副本，否则返回 null。

返回：
可以用作 setLocale 的参数的 Locale 所组成的数组，或者返回 null。

setLocale

public void setLocale(Locale locale)
将此 ImageReader 的当前 Locale 设置为给定值。值为 null 则移除所有以前的设置值，并指示 reader 应该根据需要对其进行本地化。

参数：
locale - 所需的 Locale，或者为 null。
抛出：
IllegalArgumentException - 如果 locale 为非 null，但它不是 getAvailableLocales 返回的值之一。
另请参见：
getLocale()

getLocale

public Locale getLocale()
返回当前设置的 Locale，如果没有设置 Locale，则返回 null。

返回：
当前 Locale 或 null。
另请参见：
setLocale(java.util.Locale)

getNumImages

public abstract int getNumImages(boolean allowSearch)
                          throws IOException
返回当前输入源中可用的图像数，不包括缩略图。

注意，一些图像格式（比如动画 GIF）并不指定流中存在多少图像。因此，确定图像数就需要扫描整个流，并且可能需要内存用来缓冲。如果图像是按顺序处理的，则可能更有效的方法是：使用递增的索引来调用 read，直到抛出 IndexOutOfBoundsException 指示不再有图像可用。可以将 allowSearch 参数设置为 false，指示不需要进行彻底搜索；返回值为 -1 则指示搜索是必要的。如果已在 seekForwardOnly 设置为 true 的情况下指定输入，则此方法在 allowSearch 被设置为 true 时将抛出 IllegalStateException。

参数：
allowSearch - 如果为 true，则将返回真实的图像数，即使需要进行搜索。如果该参数为 false，则 reader 返回 -1，不执行搜索。
返回：
int 形式的图像数，如果 allowSearch 为 false，则返回 -1，并且将需要搜索。
抛出：
IllegalStateException - 如果没有设置输入源，或者已在 seekForwardOnly 设置为 true 的情况下指定了输入。
IOException - 如果从输入源中读取信息时发生错误。
另请参见：
setInput(java.lang.Object, boolean, boolean)

getWidth

public abstract int getWidth(int imageIndex)
                      throws IOException
返回输入源中的给定图像的宽度，以像素为单位。

如果可以将图像呈现为用户指定大小，则此方法将返回默认宽度。

参数：
imageIndex - 要查询的图像的索引。
返回：
int 形式的图像宽度。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果从输入源中读取宽度信息时发生错误。

getHeight

public abstract int getHeight(int imageIndex)
                       throws IOException
返回输入源中的给定图像的高度，以像素为单位。

如果可以将图像呈现为用户指定大小，则此方法将返回默认高度。

参数：
imageIndex - 要查询的图像的索引。
返回：
int 形式的图像高度。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果从输入源中读取高度信息时发生错误。

isRandomAccessEasy

public boolean isRandomAccessEasy(int imageIndex)
                           throws IOException
如果给定图像的存储格式不会给像素的随机访问带来内在妨碍，则返回 true。对于大多数压缩格式（比如 JPEG），此方法应该返回 false，因为除了感兴趣的区域以外，可能还需要对图像的绝大部分进行解码。

对于希望更加有效的程序而言，这只是一个提示。所有 reader 必须能够读取在 ImageReadParam 中指定的任意区域。

注意，从此方法返回 false 的格式可能仍然允许进行平铺（例如，JPEG 格式的 Restart Marker），随机访问对于 tile 可能相当有效。参见 isImageTiled。

对于保证所有图像都支持轻松随机访问或者都不支持轻松随机访问的 reader，分别返回 true 或 false，而不必访问任何图像数据。在这种情况下，即使输入源没有设置或者图像索引超出范围，也未必抛出异常。

默认实现返回 false。

参数：
imageIndex - 要查询的图像的索引。
返回：
如果读取给定图像的感兴趣区域可能是有效的，则返回 true。
抛出：
IllegalStateException - 如果需要输入源来确定返回值，但没有设置输入源。
IndexOutOfBoundsException - 如果必须访问某一图像来确定返回值，但所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getAspectRatio

public float getAspectRatio(int imageIndex)
                     throws IOException
以 float 的形式返回给定图像的高宽比（即宽度除以高度）。对于本来就可以调整大小的图像，此方法提供了一个在已知所需高度的情况下确定适当宽度的方法，反之亦然。对于不可调整大小的图像，则使用真实宽度和高度。

默认实现只是返回 (float)getWidth(imageIndex)/getHeight(imageIndex)。

参数：
imageIndex - 要查询的图像的索引。
返回：
指示给定图像高宽比的 float 值。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getRawImageType

public ImageTypeSpecifier getRawImageType(int imageIndex)
                                   throws IOException
返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。例如，对于 JPEG 图像，原始类型可能有一个 YCbCr 颜色空间，即使该图像在显示之前会按照惯例被转换为一个 RGB 颜色空间。返回值还应该包含在 getImageTypes 返回的值所组成的列表中。

默认实现只返回 getImageType 所提供列表中的第一项。

参数：
imageIndex - 要查询的图像的索引。
返回：
一个 ImageTypeSpecifier。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果从输入源中读取格式信息时发生错误。

getImageTypes

public abstract Iterator<ImageTypeSpecifier> getImageTypes(int imageIndex)
                                                    throws IOException
以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。至少将返回一个合法图像类型。

迭代器的第一个元素应该是用于解码图像的最“自然的”类型，所带来的损失尽可能的少。例如，对于 JPEG 图像，第一项应该是 RGB 图像，即使图像数据内部存储在 YCbCr 颜色空间中。

参数：
imageIndex - 将被 retrieved 的图像的索引。
返回：
一个 Iterator，它至少包含一个表示用来解码当前给定图像的荐图像类型的 ImageTypeSpecifier。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果从输入源中读取格式信息时发生错误。
另请参见：
ImageReadParam.setDestination(BufferedImage), ImageReadParam.setDestinationType(ImageTypeSpecifier)

getDefaultReadParam

public ImageReadParam getDefaultReadParam()
返回一个适合此格式的默认 ImageReadParam 对象。所有子类都应该定义一个用于所有参数的默认值集合，并使用此调用返回这些值。可以在设置输入源之前调用此方法。

默认实现构造并返回一个新的 ImageReadParam 对象，该对象不允许源进行缩放（也就是说，它返回 new ImageReadParam()）。

返回：
一个可以使用一组默认设置控制解码过程的 ImageReadParam 对象。

getStreamMetadata

public abstract IIOMetadata getStreamMetadata()
                                       throws IOException
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。

返回：
IIOMetadata 对象或者 null。
抛出：
IOException - 如果在读取过程中发生错误。

getStreamMetadata

public IIOMetadata getStreamMetadata(String formatName,
                                     Set<String> nodeNames)
                              throws IOException
返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。如果不存在这样的数据，则返回 null。

得到的元数据对象只负责以 formatName 指定的格式返回文档。在所有返回的文档中，只需要返回其名称是 nodeNames 成员的节点。这样，基于实际需要的信息，由 reader 处理的元数据数量可以保持在最低限度。

如果 formatName 不是受支持的元数据格式的名称，则返回 null。

在所有情况下，返回一个功能强于确实必需的元数据对象是合法的。格式名称和节点名称仅仅是用来减少 reader 工作负荷的提示。

默认实现在检查格式名称是否受支持之后返回调用 getStreamMetadata() 的结果。如果不受支持，则返回 null。

参数：
formatName - 可用来从返回的 IIOMetadata 对象中获取文档的元数据格式名称。
nodeNames - 包含可包含在获取到的文档中的节点名称所组成的 Set。
返回：
IIOMetadata 对象或者 null。
抛出：
IllegalArgumentException - 如果 formatName 为 null。
IllegalArgumentException - 如果 nodeNames 为 null。
IOException - 如果在读取过程中发生错误。

getImageMetadata

public abstract IIOMetadata getImageMetadata(int imageIndex)
                                      throws IOException
返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。

参数：
imageIndex - 其元数据将被获取的图像的索引。
返回：
IIOMetadata 对象或者 null。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getImageMetadata

public IIOMetadata getImageMetadata(int imageIndex,
                                    String formatName,
                                    Set<String> nodeNames)
                             throws IOException
返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。

得到的元数据对象只负责以 formatName 指定的格式返回文档。在所有返回的文档中，只需要返回其名称是 nodeNames 成员的节点。这样，基于实际需要的信息，由 reader 处理的元数据数量可以保持在最低限度。

如果 formatName 不是受支持的元数据格式的名称，则返回 null。

在所有情况下，返回一个功能强于确实必需的元数据对象是合法的。格式名称和节点名称仅仅是用来减少 reader 工作负荷的提示。

默认实现在检查格式名称是否受支持之后返回调用 getImageMetadata(imageIndex) 的结果。如果不受支持，则返回 null。

参数：
imageIndex - 其元数据将被获取的图像的索引。
formatName - 可用来从返回的 IIOMetadata 对象中获取文档的元数据格式名称。
nodeNames - 包含可包含在获取到的文档中的节点名称所组成的 Set。
返回：
IIOMetadata 对象或者 null。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IllegalArgumentException - 如果 formatName 为 null。
IllegalArgumentException - 如果 nodeNames 为 null。
IOException - 如果在读取过程中发生错误。

read

public BufferedImage read(int imageIndex)
                   throws IOException
使用默认 ImageReadParam 读取通过索引 imageIndex 指定的图像，并将其作为一个完整的 BufferedImage 返回。这是一个调用 read(imageIndex, null) 的便捷方法。

返回的图像将根据从 getImageTypes 中返回的第一个 ImageTypeSpecifier 进行格式化。

所有已注册的 IIOReadProgressListener 对象将通过以下方式获得通知：首先调用其 imageStarted 方法，然后在读取过程中调用其 imageProgress 方法。最后，将调用其 imageComplete 方法。解码像素时，IIOReadUpdateListener 对象可以在读取期间的其他时间更新。最后，IIOReadWarningListener 对象将接收解码期间发生的所有非致命警告。

参数：
imageIndex - 将被获取的图像的索引。
返回：
BufferedImage 形式的所需图像部分。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

read

public abstract BufferedImage read(int imageIndex,
                                   ImageReadParam param)
                            throws IOException
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。

实际返回的 BufferedImage 将使用 getDestination 方法定义的算法来选择。

所有已注册的 IIOReadProgressListener 对象将通过以下方式获得通知：首先调用其 imageStarted 方法，然后在读取过程中调用其 imageProgress 方法。最后，将调用其 imageComplete 方法。解码像素时，IIOReadUpdateListener 对象可以在读取期间的其他时间更新。最后，IIOReadWarningListener 对象将接收解码期间发生的所有非致命警告。

要读取的源 band 和要写入的目标 band 的集合通过在所提供的 ImageReadParam 上调用 getSourceBands 和 getDestinationBands 确定。如果这些方法返回的数组的长度不同、源 band 集合包含一个比最大可用源索引更大的索引，或者目标 band 集合包含一个比最大的合法目标索引更大的索引，则抛出 IllegalArgumentException。

如果所提供的 ImageReadParam 包含不受此 reader 支持的可选设置值（例如 源呈现大小或任何特定于格式的设置），则将忽略这些设置。

参数：
imageIndex - 将被获取的图像的索引。
param - 用来控制读取过程的 ImageReadParam，或者为 null。
返回：
BufferedImage 形式的所需图像部分。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IllegalArgumentException - 如果由 param.getSourceBands 和 param.getDestinationBands 指定的源 band 和目标 band 的集合在长度上不同，或者包含超出范围的索引。
IllegalArgumentException - 如果所得图像的宽度或高度小于 1。
IOException - 如果读取期间发生错误。

readAll

public IIOImage readAll(int imageIndex,
                        ImageReadParam param)
                 throws IOException
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。

由返回的 IIOImage 实际引用的 BufferedImage 将使用 getDestination 方法定义的算法来选择。

所有已注册的 IIOReadProgressListener 对象将通过以下方式获得通知：首先调用其 imageStarted 方法，然后在读取过程中调用其 imageProgress 方法。最后，将调用其 imageComplete 方法。解码像素时，IIOReadUpdateListener 对象可以在读取期间的其他时间更新。最后，IIOReadWarningListener 对象将接收解码期间发生的所有非致命警告。

要读取的源 band 和要写入的目标 band 的集合通过在所提供的 ImageReadParam 上调用 getSourceBands 和 getDestinationBands 确定。如果这些方法返回的数组的长度不同、源 band 集合包含一个比最大可用源索引更大的索引，或者目标 band 集合包含一个比最大的合法目标索引更大的索引，则抛出 IllegalArgumentException。

无论怎样设置区域，缩略图都将以其完整形式返回。

如果所提供的 ImageReadParam 包含不受此 reader 支持的可选设置值（例如 源呈现大小或任何特定于格式的设置），则将忽略这些设置。

参数：
imageIndex - 将被获取的图像的索引。
param - 用来控制读取过程的 ImageReadParam，或者为 null。
返回：
一个 IIOImage，包含所需图像部分、一个缩略图集合和关联的图像元数据。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IllegalArgumentException - 如果由 param.getSourceBands 和 param.getDestinationBands 指定的源 band 和目标 band 的集合在长度上不同，或者包含超出范围的索引。
IllegalArgumentException - 如果所得图像的宽度或高度小于 1。
IOException - 如果读取期间发生错误。

readAll

public Iterator<IIOImage> readAll(Iterator<? extends ImageReadParam> params)
                           throws IOException
以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。提供一个包含 ImageReadParam 对象的 Iterator，从输入源中读取的每个图像使用一个元素，直到不再有图像可用。如果 read 参数的 Iterator 超出了元素的范围，但输入源中仍然有更多的可用图像，则将默认 read 参数用于剩余的图像。

如果 params 为 null，则将默认 read 参数用于所有图像。

由返回的 IIOImage 实际引用的 BufferedImage 将使用 getDestination 方法定义的算法来选择。

所有已注册 IIOReadProgressListener 对象都将通过调用其 sequenceStarted 方法一次获得通知。然后，对于每个解码图像，都将调用 imageStarted，随后在读取过程中调用 imageProgress，最后调用 imageComplete。sequenceComplete 方法将在解码最后一幅图像后调用。解码像素时，IIOReadUpdateListener 对象可以在读取期间的其他时间更新。最后，IIOReadWarningListener 对象将接收解码期间发生的所有非致命警告。

要读取的源 band 和要写入的目标 band 的集合通过在所提供的 ImageReadParam 上调用 getSourceBands 和 getDestinationBands 确定。如果这些方法返回的数组的长度不同、源 band 集合包含一个比最大可用源索引更大的索引，或者目标 band 集合包含一个比最大的合法目标索引更大的索引，则抛出 IllegalArgumentException。

无论怎样设置区域，缩略图都将以其完整形式返回。

如果任何所提供的 ImageReadParam 都包含不受此 reader 支持的可选设置值（例如 源呈现大小或任何特定于格式的设置），则将忽略这些设置。

参数：
params - 包含 ImageReadParam 对象的 Iterator。
返回：
将输入源的内容表示为 IIOImage 的 Iterator。
抛出：
IllegalStateException - 如果尚未设置输入源。
IllegalArgumentException - 如果 params 的非 null 元素不是一个 ImageReadParam。
IllegalArgumentException - 如果由 param.getSourceBands 和 param.getDestinationBands 指定的源 band 和目标 band 的集合在长度上不同，或者包含超出范围的索引。
IllegalArgumentException - 如果所得图像的宽度或高度小于 1。
IOException - 如果读取期间发生错误。
另请参见：
ImageReadParam, IIOImage

canReadRaster

public boolean canReadRaster()
如果此插件支持只读取像素数据的 Raster，则返回 true。如果此方法返回 false，则调用 readRaster 或 readTileRaster 将抛出 UnsupportedOperationException。

默认实现返回 false。

返回：
如果此插件支持读取原始 Raster，则返回 true。
另请参见：
readRaster(int, javax.imageio.ImageReadParam), readTileRaster(int, int, int)

readRaster

public Raster readRaster(int imageIndex,
                         ImageReadParam param)
                  throws IOException
返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。应用程序必须确定如何通过其他方法解释像素数据。所提供的 ImageReadParam 对象中的任何 destination 或 image-type 参数都被忽略，但其他所有参数的使用与 read 方法完全相同，唯一的不同在于所有的目标偏移量被用作逻辑偏移量而不是物理偏移量。所返回的 Raster 的大小将始终是裁剪为实际图像的源区域大小。忽略流自身中的逻辑偏移量。

此方法允许使用通常应用颜色转换的格式（比如 JPEG）以及通常没有关联颜色空间的格式（比如遥感数据或医学成像数据）来提供对原始像素数据的访问。

所有已注册的 readUpdateListener 都被忽略，因为没有 BufferedImage，但会调用其他所有侦听器，就像将它们用于 read 方法那样。

如果 canReadRaster() 返回 false，则此方法抛出 UnsupportedOperationException。

如果所提供的 ImageReadParam 包含不受此 reader 支持的可选设置值（例如 源呈现大小或任何特定于格式的设置），则将忽略这些设置。

默认的实现抛出 UnsupportedOperationException。

参数：
imageIndex - 要读取的图像的索引。
param - 用来控制读取过程的 ImageReadParam，或者为 null。
返回：
Raster 形式的所需图像部分。
抛出：
UnsupportedOperationException - 如果此插件不支持读取原始 Raster。
IllegalStateException - 如果输入源尚未设置。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。
另请参见：
canReadRaster(), read(int), Raster

isImageTiled

public boolean isImageTiled(int imageIndex)
                     throws IOException
如果图像被组织成 tile（即等大小的非重叠矩形），则返回 true。

reader 插件可以选择是否将图像中出现的 tiling 按其存储时的原样公开。甚至可以选择图像中没有显式存在 tiling 时公开 tiling。通常，只有在对访问单独的 tile 有利（在速度或空间方面）时才应该公开 tiling。不管 reader 是否公开 tiling，它必须能够读取 ImageReadParam 中指定的任意矩形区域。

对于可以保证所有平铺所有图像或者不平铺图像的 reader，分别返回 true 或 false，而不必访问任何图像数据。在这种情况下，即使输入源没有设置或者图像索引超出范围，也未必抛出异常。

默认实现返回 false。

参数：
imageIndex - 要查询的图像的索引。
返回：
如果图像被平铺，则返回 true。
抛出：
IllegalStateException - 如果需要输入源来确定返回值，但没有设置输入源。
IndexOutOfBoundsException - 如果必须访问某一图像来确定返回值，但所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getTileWidth

public int getTileWidth(int imageIndex)
                 throws IOException
返回给定图像中 tile 的宽度。

默认实现返回 getWidth(imageIndex)，对于非平铺图像也是如此。支持 tiling 的 reader 应该重写此方法。

参数：
imageIndex - 要查询的图像的索引。
返回：
tile 的宽度。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getTileHeight

public int getTileHeight(int imageIndex)
                  throws IOException
返回给定图像中 tile 的高度。

默认实现返回 getHeight(imageIndex)，对于非平铺图像也是如此。支持 tiling 的 reader 应该重写此方法。

参数：
imageIndex - 要查询的图像的索引。
返回：
tile 的高度。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getTileGridXOffset

public int getTileGridXOffset(int imageIndex)
                       throws IOException
返回给定图像中 tile (0, 0) 的左上角的 X 坐标。

对于 tile 网格 X 偏移量总是具有相同值（通常为 0）的 reader，返回该值，而不必访问任何图像数据。在这种情况下，即使输入源没有设置或者图像索引超出范围，也未必抛出异常。

默认实现返回 0，对于大多数格式的非平铺图像和平铺图像也是如此。支持 tiling、具有非 (0, 0) 偏移量的 reader 应该重写此方法。

参数：
imageIndex - 要查询的图像的索引。
返回：
tile 网格的 X 偏移量。
抛出：
IllegalStateException - 如果需要输入源来确定返回值，但没有设置输入源。
IndexOutOfBoundsException - 如果必须访问某一图像来确定返回值，但所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getTileGridYOffset

public int getTileGridYOffset(int imageIndex)
                       throws IOException
返回给定图像中 tile (0, 0) 的左上角的 Y 坐标。

对于 tile 网格 Y 偏移量总是具有相同值（通常为 0）的 reader，返回该值，而不必访问任何图像数据。在这种情况下，即使输入源没有设置或者图像索引超出范围，也未必抛出异常。

默认实现返回 0，对于大多数格式的非平铺图像和平铺图像也是如此。支持 tiling、具有非 (0, 0) 偏移量的 reader 应该重写此方法。

参数：
imageIndex - 要查询的图像的索引。
返回：
tile 网格的 Y 偏移量。
抛出：
IllegalStateException - 如果需要输入源来确定返回值，但没有设置输入源。
IndexOutOfBoundsException - 如果必须访问某一图像来确定返回值，但所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

readTile

public BufferedImage readTile(int imageIndex,
                              int tileX,
                              int tileY)
                       throws IOException
读取由 tileX 和 tileY 参数指示的 tile，并以 BufferedImage 形式返回。如果参数超出范围，则抛出 IllegalArgumentException。如果图像是非平铺的，则 0, 0 值将返回整个图像；其他值都将导致抛出 IllegalArgumentException。

此方法只是一个便捷方法，它等效于调用带有一个 read 参数的 read(int, ImageReadParam)，该参数指定源区域的偏移量为 tileX*getTileWidth(imageIndex), tileY*getTileHeight(imageIndex)，宽度和高度为 getTileWidth(imageIndex) 和 getTileHeight(imageIndex)；并在因子为 1 和偏移量为 0 的情况下进行二次取样。要对 tile 进行二次取样，需要使用指定此区域的 read 参数和不同的二次取样参数调用 read。

默认实现在 tileX 和 tileY 为 0 时返回整个图像，其他情况则抛出 IllegalArgumentException。

参数：
imageIndex - 将被获取的图像的索引。
tileX - 将被获取的 tile 的列索引（从 0 开始）。
tileY - 将被获取的 tile 的行索引（从 0 开始）。
返回：
BufferedImage 形式的 tile。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果 imageIndex 超出范围。
IllegalArgumentException - 如果 tile 的索引超出范围。
IOException - 如果在读取过程中发生错误。

readTileRaster

public Raster readTileRaster(int imageIndex,
                             int tileX,
                             int tileY)
                      throws IOException
返回包含 tile 中的原始像素数据的新 Raster 对象，不应用任何颜色转换。应用程序必须确定如何通过其他方法解释像素数据。

如果 canReadRaster() 返回 false，则此方法抛出 UnsupportedOperationException。

默认实现检查是否支持读取 Raster，如果支持且 tileX 和 tileY 为 0，则调用 readRaster(imageIndex, null)，否则抛出 IllegalArgumentException。

参数：
imageIndex - 将被获取的图像的索引。
tileX - 将被获取的 tile 的列索引（从 0 开始）。
tileY - 将被获取的 tile 的行索引（从 0 开始）。
返回：
Raster 形式的 tile。
抛出：
UnsupportedOperationException - 如果此插件不支持读取原始 Raster。
IllegalArgumentException - 如果 tile 索引超出范围。
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果 imageIndex 超出范围。
IOException - 如果在读取过程中发生错误。
另请参见：
readTile(int, int, int), readRaster(int, javax.imageio.ImageReadParam), Raster

readAsRenderedImage

public RenderedImage readAsRenderedImage(int imageIndex,
                                         ImageReadParam param)
                                  throws IOException
返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。默认情况下，返回的图像是由 read(imageIndex, param) 返回的 BufferedImage。

此方法的语义在某些方面可能不同于其他 read 方法的语义。首先，可以忽略 ImageReadParam 中设置的任何目标图像和/或图像类型。其次，不保证进行一般的侦听器调用，或者进行这些调用时不保证它们是有意义的。这是因为在返回时（甚至任何时候）返回的图像可能并不完全由像素数据填充。

如果所提供的 ImageReadParam 包含不受此 reader 支持的可选设置值（例如 源呈现大小或任何特定于格式的设置），则将忽略这些设置。

默认实现调用 read(imageIndex, param)。

参数：
imageIndex - 将被获取的图像的索引。
param - 用来控制读取过程的 ImageReadParam，或者为 null。
返回：
提供图像视图的 RenderedImage 对象。
抛出：
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果所提供的索引超出范围。
IllegalArgumentException - 如果由 param.getSourceBands 和 param.getDestinationBands 指定的源 band 和目标 band 的集合在长度上不同，或者包含超出范围的索引。
IllegalArgumentException - 如果所得图像的宽度或高度小于 1。
IOException - 如果读取期间发生错误。

readerSupportsThumbnails

public boolean readerSupportsThumbnails()
如果此 reader 所理解的图像格式支持与之关联的缩略图预览图像，则返回 true。默认实现返回 false。

如果此方法返回 false，hasThumbnails 和 getNumThumbnails 将分别返回 false 和 0，而 readThumbnail 将抛出 UnsupportedOperationException（不管其参数如何）。

不支持缩略图的 reader 不需要实现任何与缩略图有关的方法。

返回：
如果支持缩略图，则返回 true。

hasThumbnails

public boolean hasThumbnails(int imageIndex)
                      throws IOException
如果给定图像具有与之关联的缩略图预览图像，则返回 true。如果该格式不支持缩略图（readerSupportsThumbnails 返回 false），则无论是否已经设置了输入源或者 imageIndex 是否在范围内，其都将将返回 false。

默认实现在 getNumThumbnails 的返回值大于 0 的情况下返回 true。

参数：
imageIndex - 要查询的图像的索引。
返回：
如果给定图像具有缩略图，则返回 true。
抛出：
IllegalStateException - 如果 reader 支持缩略图但尚未设置输入源。
IndexOutOfBoundsException - 如果 reader 支持缩略图但 imageIndex 超出范围。
IOException - 如果在读取过程中发生错误。

getNumThumbnails

public int getNumThumbnails(int imageIndex)
                     throws IOException
返回与给定图像关联的缩略图预览图像的数量。如果该格式不支持缩略图（readerSupportsThumbnails 返回 false），则无论是否已经设置了输入源或者 imageIndex 是否在范围内，其都将将返回 0。

默认实现返回 0，不检查其参数。

参数：
imageIndex - 要查询的图像的索引。
返回：
与给定图像关联的缩略图的数量。
抛出：
IllegalStateException - 如果 reader 支持缩略图但尚未设置输入源。
IndexOutOfBoundsException - 如果 reader 支持缩略图但 imageIndex 超出范围。
IOException - 如果在读取过程中发生错误。

getThumbnailWidth

public int getThumbnailWidth(int imageIndex,
                             int thumbnailIndex)
                      throws IOException
返回通过索引 thumbnailIndex 指定的缩略图预览图像的宽度，其与通过索引 ImageIndex 指定的图像关联。

如果 reader 不支持缩略图（readerSupportsThumbnails 返回 false），则将抛出 UnsupportedOperationException。

默认实现返回 readThumbnail(imageindex, thumbnailIndex).getWidth()。所以，为了避免强行读取缩略图，子类应该重写此方法（如果有可能）。

参数：
imageIndex - 将被获取的图像的索引。
thumbnailIndex - 将被获取的缩略图的索引。
返回：
int 形式的所需缩略图宽度。
抛出：
UnsupportedOperationException - 如果不支持缩略图。
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果任何一个所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

getThumbnailHeight

public int getThumbnailHeight(int imageIndex,
                              int thumbnailIndex)
                       throws IOException
返回通过索引 thumbnailIndex 指定的缩略图预览图像的高度，其与通过索引 ImageIndex 指定的图像关联。

如果 reader 不支持缩略图（readerSupportsThumbnails 返回 false），则将抛出 UnsupportedOperationException。

默认实现返回 readThumbnail(imageindex, thumbnailIndex).getHeight()。所以，为了避免强行读取缩略图，子类应该重写此方法（如果有可能）。

参数：
imageIndex - 将被获取的图像的索引。
thumbnailIndex - 将被获取的缩略图的索引。
返回：
int 形式的所需缩略图高度。
抛出：
UnsupportedOperationException - 如果不支持缩略图。
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果任何一个所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

readThumbnail

public BufferedImage readThumbnail(int imageIndex,
                                   int thumbnailIndex)
                            throws IOException
以 BufferedImage 形式返回通过索引 thumbnailIndex 指定的缩略图预览图像，其与通过索引 ImageIndex 指定的图像关联。

所有已注册 IIOReadProgressListener 对象都将通过调用其 thumbnailStarted、thumbnailProgress 和 thumbnailComplete 方法获得通知。

如果 reader 不支持缩略图（readerSupportsThumbnails 返回 false），则无论是否已经设置了输入源或者索引是否在范围内，其都将抛出 UnsupportedOperationException。

默认的实现抛出 UnsupportedOperationException。

参数：
imageIndex - 将被获取的图像的索引。
thumbnailIndex - 将被获取的缩略图的索引。
返回：
BufferedImage 形式的所需缩略图。
抛出：
UnsupportedOperationException - 如果不支持缩略图。
IllegalStateException - 如果尚未设置输入源。
IndexOutOfBoundsException - 如果任何一个所提供的索引超出范围。
IOException - 如果在读取过程中发生错误。

abort

public void abort()
请求中止当前所有读取操作。中止后图像的内容将是不确定的。

reader 应该在开始每个读取操作时调用 clearAbortRequest，并在读取期间定期轮询 abortRequested 的值。

abortRequested

protected boolean abortRequested()
如果从实例化 reader 或调用 clearAbortRequest 时起，已经请求了中止当前读取操作，则返回 true。

返回：
如果应该中止当前读取操作，则返回 true。
另请参见：
abort(), clearAbortRequest()

clearAbortRequest

protected void clearAbortRequest()
清除任何以前的中止请求。在已调用此方法之后，abortRequested 将返回 false。

另请参见：
abort(), abortRequested()

addIIOReadWarningListener

public void addIIOReadWarningListener(IIOReadWarningListener listener)
将 IIOReadWarningListener 添加到已注册的警告侦听器的列表中。如果 listener 为 null，则不会抛出任何异常并且不执行任何操作。将本地化发送到给定侦听器的消息（如果可能）以匹配当前 Locale。如果没有设置 Locale，则可将警告消息本地化为适合 reader 的形式。

参数：
listener - 要注册的 IIOReadWarningListener。
另请参见：
removeIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener)

removeIIOReadWarningListener

public void removeIIOReadWarningListener(IIOReadWarningListener listener)
从已注册的错误侦听器列表中移除 IIOReadWarningListener。如果以前没有注册侦听器，或者 listener 为 null，则不会抛出任何异常并且不执行任何操作。

参数：
listener - 要取消注册的 IIOReadWarningListener。
另请参见：
addIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener)

removeAllIIOReadWarningListeners

public void removeAllIIOReadWarningListeners()
移除所有当前已注册的 IIOReadWarningListener 对象。

默认实现将 warningListeners 和 warningLocales 实例变量设置为 null。

addIIOReadProgressListener

public void addIIOReadProgressListener(IIOReadProgressListener listener)
将 IIOReadProgressListener 添加到已注册的进度侦听器列表中。如果 listener 为 null，则不会抛出任何异常并且不执行任何操作。

参数：
listener - 要注册的 IIOReadProgressListener。
另请参见：
removeIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener)

removeIIOReadProgressListener

public void removeIIOReadProgressListener(IIOReadProgressListener listener)
从已注册的进度侦听器列表中移除 IIOReadProgressListener。如果以前没有注册侦听器，或者 listener 为 null，则不会抛出任何异常并且不执行任何操作。

参数：
listener - 要取消注册的 IIOReadProgressListener。
另请参见：
addIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener)

removeAllIIOReadProgressListeners

public void removeAllIIOReadProgressListeners()
移除所有当前已注册的 IIOReadProgressListener 对象。

默认实现将 progressListeners 实例变量设置为 null。

addIIOReadUpdateListener

public void addIIOReadUpdateListener(IIOReadUpdateListener listener)
将 IIOReadUpdateListener 添加到已注册的更新侦听器列表中。如果 listener 为 null，则不会抛出任何异常并且不执行任何操作。在解码图像和缩略图时，侦听器将接收像素更新的通知，该通知中包括逐步传递的起始处和结束处。

如果不存在更新侦听器，则 reader 可以选择对目标图像和/或缩略图的像素执行较少的更新，这能促使更加有效的解码。

例如，在逐步 JPEG 解码过程中，每个传递都包含对一个系数集合的更新数据，如果侦听器存在，则必须将这些系数变换成像素值并转换为用于每个传递的 RGB 颜色空间。如果不存在侦听器，则可以累计这些系数，并只变换最终结果和转换颜色一次。

无论是否执行中间的更新，解码的最终结果都相同。因此，如果只需要最终图像，则最好不注册任何 IIOReadUpdateListener。通常，在通过与本地 CPU 处理相比非常慢的网络连接获取图像时，逐步更新是最有效的；而通过快速连接时，逐步更新实际上会降低图像的显示速度。

参数：
listener - 要注册的 IIOReadUpdateListener。
另请参见：
removeIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener)

removeIIOReadUpdateListener

public void removeIIOReadUpdateListener(IIOReadUpdateListener listener)
从已注册的更新侦听器列表中移除 IIOReadUpdateListener。如果以前没有注册侦听器，或者 listener 为 null，则不会抛出任何异常并且不执行任何操作。

参数：
listener - 要取消注册的 IIOReadUpdateListener。
另请参见：
addIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener)

removeAllIIOReadUpdateListeners

public void removeAllIIOReadUpdateListeners()
移除所有当前已注册的 IIOReadUpdateListener 对象。

默认实现将 updateListeners 实例变量设置为 null。

processSequenceStarted

protected void processSequenceStarted(int minIndex)
通过调用所有已注册 IIOReadProgressListener 的 sequenceStarted 方法向其广播图像读取序列的起始处。子类可以将此方法用作一个便捷方法。

参数：
minIndex - 将读取的最低索引。

processSequenceComplete

protected void processSequenceComplete()
通过调用所有已注册 IIOReadProgressListener 的 sequenceComplete 方法向其广播图像读取序列的完成。子类可以将此方法用作一个便捷方法。

processImageStarted

protected void processImageStarted(int imageIndex)
通过调用所有已注册 IIOReadProgressListener 的 imageStarted 方法向其广播图像读取起始处。子类可以将此方法用作一个便捷方法。

参数：
imageIndex - 即将读取的图像的索引。

processImageProgress

protected void processImageProgress(float percentageDone)
通过调用所有已注册 IIOReadProgressListener 的 imageProgress 方法向其广播图像完成的当前百分比。子类可以将此方法用作一个便捷方法。

参数：
percentageDone - float 值形式的当前完成百分比。

processImageComplete

protected void processImageComplete()
通过调用所有已注册 IIOReadProgressListener 的 imageComplete 方法向其广播图像读取的完成。子类可以将此方法用作一个便捷方法。

processThumbnailStarted

protected void processThumbnailStarted(int imageIndex,
                                       int thumbnailIndex)
通过调用所有已注册 IIOReadProgressListener 的 thumbnailStarted 方法向其广播缩略图读取的起始处。子类可以将此方法用作一个便捷方法。

参数：
imageIndex - 与该缩略图关联的图像的索引。
thumbnailIndex - 缩略图的索引。

processThumbnailProgress

protected void processThumbnailProgress(float percentageDone)
通过调用所有已注册 IIOReadProgressListener 的 thumbnailProgress 方法向其广播缩略图完成的当前百分比。子类可以将此方法用作一个便捷方法。

参数：
percentageDone - float 值形式的当前完成百分比。

processThumbnailComplete

protected void processThumbnailComplete()
通过调用所有已注册 IIOReadProgressListener 的 thumbnailComplete 方法向其广播缩略图读取的完成。子类可以将此方法用作一个便捷方法。

processReadAborted

protected void processReadAborted()
通过调用所有已注册 IIOReadProgressListener 的 readAborted 方法向其广播读取已经中止。子类可以将此方法用作一个便捷方法。

processPassStarted

protected void processPassStarted(BufferedImage theImage,
                                  int pass,
                                  int minPass,
                                  int maxPass,
                                  int minX,
                                  int minY,
                                  int periodX,
                                  int periodY,
                                  int[] bands)
通过调用所有已注册 IIOReadUpdateListener 的 passStarted 方法向其广播逐步传递的开始。子类可以将此方法用作一个便捷方法。

参数：
theImage - 将被更新的 BufferedImage。
pass - 当前传递的索引，从 0 开始。
minPass - 将被解码的第一个传递的索引。
maxPass - 将要解码的最后一个传递的索引。
minX - 包含在该传递中的左上角像素的 X 坐标。
minY - 包含在该传递中的左上角像素的 Y 坐标。
periodX - 像素间的水平间距。
periodY - 像素间的垂直间距。
bands - 指示受影响目标 band 集合的 int 数组。

processImageUpdate

protected void processImageUpdate(BufferedImage theImage,
                                  int minX,
                                  int minY,
                                  int width,
                                  int height,
                                  int periodX,
                                  int periodY,
                                  int[] bands)
通过调用所有已注册 IIOReadUpdateListener 的 imageUpdate 方法向其广播样本集合的更新。子类可以将此方法用作一个便捷方法。

参数：
theImage - 将被更新的 BufferedImage。
minX - 包含在该传递中的左上角像素的 X 坐标。
minY - 包含在该传递中的左上角像素的 Y 坐标。
width - 将被更新的区域的总宽度，包括将跳过的像素（如果 periodX > 1）。
height - 将被更新的区域的总高度，包括将跳过的像素（如果 periodY > 1）。
periodX - 像素间的水平间距。
periodY - 像素间的垂直间距。
bands - 指示受影响目标 band 集合的 int 数组。

processPassComplete

protected void processPassComplete(BufferedImage theImage)
通过调用所有已注册 IIOReadUpdateListener 的 passComplete 方法向其广播逐步传递的结束。子类可以将此方法用作一个便捷方法。

参数：
theImage - 将被更新的 BufferedImage。

processThumbnailPassStarted

protected void processThumbnailPassStarted(BufferedImage theThumbnail,
                                           int pass,
                                           int minPass,
                                           int maxPass,
                                           int minX,
                                           int minY,
                                           int periodX,
                                           int periodY,
                                           int[] bands)
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassStarted 方法向其广播缩略图逐步传递的开始。子类可以将此方法用作一个便捷方法。

参数：
theThumbnail - 将被更新的 BufferedImage 缩略图。
pass - 当前传递的索引，从 0 开始。
minPass - 将被解码的第一个传递的索引。
maxPass - 将要解码的最后一个传递的索引。
minX - 包含在该传递中的左上角像素的 X 坐标。
minY - 包含在该传递中的左上角像素的 Y 坐标。
periodX - 像素间的水平间距。
periodY - 像素间的垂直间距。
bands - 指示受影响目标 band 集合的 int 数组。

processThumbnailUpdate

protected void processThumbnailUpdate(BufferedImage theThumbnail,
                                      int minX,
                                      int minY,
                                      int width,
                                      int height,
                                      int periodX,
                                      int periodY,
                                      int[] bands)
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailUpdate 方法向其广播缩略图图像中样本集合的更新。子类可以将此方法用作一个便捷方法。

参数：
theThumbnail - 将被更新的 BufferedImage 缩略图。
minX - 包含在该传递中的左上角像素的 X 坐标。
minY - 包含在该传递中的左上角像素的 Y 坐标。
width - 将被更新的区域的总宽度，包括将跳过的像素（如果 periodX > 1）。
height - 将被更新的区域的总高度，包括将跳过的像素（如果 periodY > 1）。
periodX - 像素间的水平间距。
periodY - 像素间的垂直间距。
bands - 指示受影响目标 band 集合的 int 数组。

processThumbnailPassComplete

protected void processThumbnailPassComplete(BufferedImage theThumbnail)
通过调用所有已注册 IIOReadUpdateListener 的 thumbnailPassComplete 方法向其广播缩略图逐步传递的结束。子类可以将此方法用作一个便捷方法。

参数：
theThumbnail - 将被更新的 BufferedImage 缩略图。

processWarningOccurred

protected void processWarningOccurred(String warning)
通过调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播警告消息。子类可以将此方法用作一个便捷方法。

参数：
warning - 要发送的警告消息。
抛出：
IllegalArgumentException - 如果 warning 为 null。

processWarningOccurred

protected void processWarningOccurred(String baseName,
                                      String keyword)
通过使用取自 ResourceBundle 的字符串调用所有已注册 IIOReadWarningListener 的 warningOccurred 方法向其广播本地化警告消息。子类可以将此方法用作一个便捷方法。

参数：
baseName - 包含本地化警告消息的 ResourceBundle 集合的基本名称。
keyword - 用来搜索 ResourceBundle 集合中的警告消息的关键字。
抛出：
IllegalArgumentException - 如果 baseName 为 null。
IllegalArgumentException - 如果 keyword 为 null。
IllegalArgumentException - 如果无法定位合适的 ResourceBundle。
IllegalArgumentException - 如果在定位的 ResourceBundle 中无法找到指定的资源。
IllegalArgumentException - 如果从 ResourceBundle 中获取到的对象不是 String。

reset

public void reset()
将 ImageReader 恢复到其初始状态。

默认实现调用 setInput(null, false)、setLocale(null)、removeAllIIOReadUpdateListeners()、removeAllIIOReadWarningListeners()、removeAllIIOReadProgressListeners() 和 clearAbortRequest。

dispose

public void dispose()
允许释放此对象占用的所有资源。在调用此方法后调用其他任何方法（finalize 除外）所产生的结果都是不确定的。

应用程序在确信不再使用此 ImageReader 时，调用此方法非常重要。否则，reader 将继续无限期地占用这些资源。

在超类中，此方法的默认实现不执行任何操作。子类实现应该确保所有资源（特别是本机资源）被释放。

getSourceRegion

protected static Rectangle getSourceRegion(ImageReadParam param,
                                           int srcWidth,
                                           int srcHeight)
reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。实际二次取样因子、目标大小和目标偏移量都没有 考虑，因此必须进行进一步的裁剪。computeRegions 方法执行所有必要的裁剪。

参数：
param - 将使用的 ImageReadParam，或者为 null。
srcWidth - 源图像的宽度。
srcHeight - 源图像的高度。
返回：
Rectangle 形式的源区域。

computeRegions

protected static void computeRegions(ImageReadParam param,
                                     int srcWidth,
                                     int srcHeight,
                                     BufferedImage image,
                                     Rectangle srcRegion,
                                     Rectangle destRegion)
计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。源区域从整个源图像开始。如果指定了一感兴趣的区域，则其将裁剪在 ImageReadParam 中指定的源区域。

如果任何区域的目标偏移量都为负，则裁剪源区域，使其左上部与目标图像的左上部一致，裁剪时将二次取样考虑在内。然后裁剪结果，使其与目标图像（如果指定了目标图像）右下部一致，将二次取样和目标偏移量考虑在内。

类似地，从源图像开始的目标区域被转换成 ImageReadParam 中给定的目标偏移量（如果有），并最终被裁剪成目标图像（如果有）。

如果源区域或目标区域的最终宽度或高度为 0，则抛出 IllegalArgumentException。

只有需要对源区域进行裁剪时，才能使用 getSourceRegion 方法。

参数：
param - 一个 ImageReadParam，或者为 null。
srcWidth - 源图像的宽度。
srcHeight - 源图像的高度。
image - 将成为目标图像的 BufferedImage，或者为 null。
srcRegion - 将使用感兴趣的源区域填充的 Rectangle。
destRegion - 将使用感兴趣的目标区域填充的 Rectangle。
抛出：
IllegalArgumentException - 如果 srcRegion 为 null。
IllegalArgumentException - 如果 dstRegion 为 null。
IllegalArgumentException - 如果所得到的源区域或目标区域为空。

checkReadParamBandSettings

protected static void checkReadParamBandSettings(ImageReadParam param,
                                                 int numSrcBands,
                                                 int numDstBands)
reader 可用来测试 ImageReadParam 的源和目标 band 设置的有效性的实用方法。只要 reader 一确定输入流中存在的目标图像的 band 数，以及将写入的目标图像的 band 数，就可以调用此方法。

该方法根据参数使用 getSourceBands 和 getDestinationBands 方法获取源和目标 band 设置值数组（如果 param 为 null ，则将其视为 null）。如果源 band 设置值数组为 null，则认为其等同于数组 { 0, 1, ..., numSrcBands - 1 }，对于目标 band 设置值数组情况类似。

然后该方法测试两个数组的长度是否相等，以及是否两个数组都没有包含大于最大可用 band 索引的值。

任何失败都将导致抛出 IllegalArgumentException；而成功则导致方法正常返回。

参数：
param - 将用来读取图像 ImageReadParam。
numSrcBands - 输入源中存在的图像的 band 数。
numDstBands - 将被写入的目标图像中的 band 数。
抛出：
IllegalArgumentException - 如果 param 包含源和/或目标 band 子集的无效规范。

getDestination

protected static BufferedImage getDestination(ImageReadParam param,
                                              Iterator<ImageTypeSpecifier> imageTypes,
                                              int width,
                                              int height)
                                       throws IIOException
返回应该在其中写入解码的像素数据的 BufferedImage。通过检查所提供的 ImageReadParam（如果非 null）来确定图像；如果其 getDestination 方法返回一个非 null 值，则返回该图像。否则，调用 param.getDestinationType 方法来确定是否指定了某一特定图像类型。如果已指定，则在检查其是否等于 imageTypes 中包含的类型之一后使用所返回的 ImageTypeSpecifier。

如果 param 为 null 或者上述步骤没有生成一幅图像或 ImageTypeSpecifier，则使用从 imageTypes 参数获得的第一个值。通常，调用者会将 imageTypes 设置为 getImageTypes(imageIndex) 的值。

接下来，通过调用 computeRegions 确定图像的维数。将被解码的图像的实际宽度和高度以 width 和 height 参数的形式传入。

参数：
param - 将用来获得目标图像或图像类型的 ImageReadParam，或者为 null。
imageTypes - 指示合法图像类型的 ImageTypeSpecifier 的 Iterator（默认类型最先使用）。
width - 开始解码的图像或 tile 的实际宽度。
height - 开始解码的图像或 tile 的实际高度。
返回：
应该在其中写入解码的像素数据的 BufferedImage。
抛出：
IIOException - 如果由 param 指定的 ImageTypeSpecifier 与来自 imageTypes 的任何合法类型不匹配。
IllegalArgumentException - 如果 imageTypes 为 null 或空，或者从中获取到的对象类型不是 ImageTypeSpecifier。
IllegalArgumentException - 如果得到的图像宽度或高度小于 1。
IllegalArgumentException - 如果 width 和 height 的值大于 Integer.MAX_VALUE。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageReadParam (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 ImageReadParam

java.lang.Object
    继承者  javax.imageio.IIOParam
        继承者  javax.imageio.ImageReadParam
直接已知子类：
JPEGImageReadParam
public class ImageReadParam
extends IIOParam

描述如何对流进行解码的类。此类的实例或其子类用于提供 ImageReader 实例的规定“入门”信息。

编码为文件或流的一部分的图像可以被认为是向多维扩展的：宽度和高度的空间维数、band 的数量以及逐步解码传递。此类允许选中所有这些维数中的图像的相邻（不相邻）矩形子区域来进行解码。此外，可以不连续地对空间维数进行二次取样。最后，颜色和格式转换可以通过控制目标图像的 ColorModel 和 SampleModel 来指定，或者通过提供 BufferedImage 或使用 ImageTypeSpecifier 来指定。

ImageReadParam 对象用于指定如何在输入时从 Java Image I/O 框架的上下文中的流转换一幅图像或一组图像。用于特定图像格式的插件将从其 ImageReader 实现的 getDefaultReadParam 方法中返回 ImageReadParam 的实例。

由 ImageReadParam 实例维护的状态与将被解码的任何特定图像无关。在进行实际解码时，read 参数中设置的值与将解码的图像的实际属性组合在一起，这些属性来自将接收解码像素数据的流和目标 BufferedImage。例如，使用 setSourceRegion 设置的源区域将首先与实际有效源区域相交。结果将由 getDestinationOffset 返回的值转换，得到的矩形与实际有效目标区域相交，从而产生将被写入的目标区域。

由 ImageReadParam 指定的参数将被应用于图像，如下所示。首先，如果已经通过 setSourceRenderSize 设置呈现大小，则整个解码图像将按 getSourceRenderSize 给出的大小来呈现。否则，图像的实际大小将由 ImageReader.getWidth 和 ImageReader.getHeight 给定。

接下来，将根据 getSourceXOffset、getSourceYOffset、getSourceWidth 和 getSourceHeight 指定的源区域裁剪图像。

然后根据 IIOParam.setSourceSubsampling 中给出的因子对得到的区域进行二次取样。第一个像素、每一行的像素数和行数都取决于二次取样设置值。调用所得矩形的最小 X 和 Y 坐标 (minX, minY)、其宽度 w 及其高度 h。

将此矩形偏移 (getDestinationOffset().x, getDestinationOffset().y)，并根据目标边界进行裁剪。如果没有设置目标图像，则定义目标图像的宽度为 getDestinationOffset().x + w，高度为 getDestinationOffset().y + h，以便源区域的所有像素都可以写入目标区域中。

二次取样之后放入目标图像中的像素以及写入由 getSourceMinProgressivePass 和 getSourceNumProgressivePasses 指定的某一逐步传递中的那些像素都传递给下一步骤。

最后，根据 setDestinationBands 的注释中描述的算法，将每个像素的源样本映射到目标 band。

插件 writer 可以通过提供实现额外的、特定于插件的接口来扩展 ImageReadParam 的功能。由插件负责记录哪些接口可用以及如何使用。reader 将安静地忽略所有其未知的 ImageReadParam 子类扩展功能。此外，将忽略通常在通过 getDefaultReadParam 创建自己的 ImageReadParam 实例时禁用的所有可选功能。

注意，如果不存在针对某一功能的查询方法，所有 ImageReader 实现就必须都支持该功能（例如，源呈现大小是可选的，但二次取样必须受支持）。

另请参见：
ImageReader, ImageWriter, ImageWriteParam

字段摘要
protected boolean | canSetSourceRenderSize 如果此 ImageReadParam 允许设置源呈现维数，则为 true。
protected BufferedImage | destination 当前目标 BufferedImage；如果没有设置目标图像，则为 null。
protected int[] | destinationBands 要使用的目标 band 集合（int 数组的形式）。
protected int | minProgressivePass 从源中读取的逐步传递的最小索引。
protected int | numProgressivePasses 从源中读取的逐步传递的最大数量。
protected Dimension | sourceRenderSize 如果 canSetSourceRenderSize 为 true，则为源的所需呈现宽度和高度；或者为 null。
从类 javax.imageio.IIOParam 继承的字段
controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset
构造方法摘要
ImageReadParam()
构造一个 ImageReadParam。
方法摘要
boolean | canSetSourceRenderSize() 如果此 reader 允许通过使用 setSourceRenderSize 方法以任意大小将源图像呈现为解码过程的一部分，则返回 true。
BufferedImage | getDestination() 返回当前由 setDestination 方法设置的 BufferedImage，如果没有设置，则返回 null。
int[] | getDestinationBands() 返回 band 索引的集合，数据将置于该集合中。
int | getSourceMaxProgressivePass() 如果 getSourceNumProgressivePasses 等于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。
int | getSourceMinProgressivePass() 返回将被解码的第一个逐步传递的索引。
int | getSourceNumProgressivePasses() 返回将被解码的逐步传递的数量。
Dimension | getSourceRenderSize() 返回解码期间将呈现的源图像的宽度和高度，如果已经通过 setSourceRenderSize 方法设置了的话。
void | setDestination(BufferedImage destination) 提供一个 BufferedImage，将其用作解码像素数据的目标。
void | setDestinationBands(int[] destinationBands) 设置将在其中放置数据的目标 band 的索引。
void | setDestinationType(ImageTypeSpecifier destinationType) 使用 ImageTypeSpecifier 设置目标图像的所需图像类型。
void | setSourceProgressivePasses(int minPass, int numPasses) 设置将被解码的逐步传递的范围。
void | setSourceRenderSize(Dimension size) 如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。
从类 javax.imageio.IIOParam 继承的方法
activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setSourceBands, setSourceRegion, setSourceSubsampling
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

canSetSourceRenderSize

protected boolean canSetSourceRenderSize
如果此 ImageReadParam 允许设置源呈现维数，则为 true。默认情况下，该值为 false。子类必须手工设置此值。

不支持设置源呈现大小的 ImageReader 应该将该值设置为 false。

sourceRenderSize

protected Dimension sourceRenderSize
如果 canSetSourceRenderSize 为 true，则为源的所需呈现宽度和高度；或者为 null。

不支持设置源呈现大小的 ImageReader 可以忽略此值。

destination

protected BufferedImage destination
当前目标 BufferedImage；如果没有设置目标图像，则为 null。默认情况下，该值为 null。

destinationBands

protected int[] destinationBands
要使用的目标 band 集合（int 数组的形式）。默认情况下，该值为 null，指示应该按顺序写入的所有目标 band。

minProgressivePass

protected int minProgressivePass
从源中读取的逐步传递的最小索引。默认情况下，该值被设置为 0，指示应该解码从第一个可用传递开始的传递。

子类应该确保此值为非负。

numProgressivePasses

protected int numProgressivePasses
从源中读取的逐步传递的最大数量。默认情况下，该值被设置为 Integer.MAX_VALUE，指示应该解码直至最后一个可用传递（包括）的传递。

子类应该确保此值为正数。此外，如果该值不是 Integer.MAX_VALUE，则 minProgressivePass + numProgressivePasses - 1 不应该超过 Integer.MAX_VALUE。

构造方法详细信息

ImageReadParam

public ImageReadParam()
构造一个 ImageReadParam。

方法详细信息

setDestinationType

public void setDestinationType(ImageTypeSpecifier destinationType)
从类 IIOParam 复制的描述
使用 ImageTypeSpecifier 设置目标图像的所需图像类型。

在读取时，如果已经使用此方法设置目标区域的布局，则每次调用 ImageReader 的 read 方法都将返回一个新的 BufferedImage，它使用由所提供的类型说明符指定的格式。此方法的一个副作用是，任何由 ImageReadParam.setDestination(BufferedImage) 设置的目标 BufferedImage 将不再被设置为目标。换句话说，在调用 setDestination((BufferedImage)null) 时可以考虑此方法。

在写入时，或许会使用目标类型确定图像的颜色类型。SampleModel 信息将被忽略，其可以为 null。例如，一个 4 band 的图像可以表示 CMYK 或 RGBA 数据。如果设置了目标类型，则其 ColorModel 将重写该图像自身的所有 ColorModel。这在使用 setSourceBands 时极其重要，因为该图像的 ColorModel 将引用整个图像，而不是被写入的 band 的子集。

覆盖：
类 IIOParam 中的 setDestinationType
参数：
destinationType - 用来确定目标布局和颜色类型的 ImageTypeSpecifier。
另请参见：
IIOParam.getDestinationType()

setDestination

public void setDestination(BufferedImage destination)
提供一个 BufferedImage，将其用作解码像素数据的目标。当前设置的图像将由 read、readAll 和 readRaster 方法写入，对该图像的引用将由这些方法返回。

来自上述那些方法的像素数据将从 getDestinationOffset 指定的偏移量开始写入。

如果 destination 为 null，则新创建的 BufferedImage 将由这些方法返回。

在读取时，检查该图像来验证其 ColorModel 和 SampleModel 是否对应于从 ImageReader 的 getImageTypes 方法返回的 ImageTypeSpecifier 之一。如果不对应，则 reader 将抛出 IIOException。

参数：
destination - 要写入数据的 BufferedImage，或者为 null。
另请参见：
getDestination()

getDestination

public BufferedImage getDestination()
返回当前由 setDestination 方法设置的 BufferedImage，如果没有设置，则返回 null。

返回：
要写入数据的 BufferedImage。
另请参见：
setDestination(java.awt.image.BufferedImage)

setDestinationBands

public void setDestinationBands(int[] destinationBands)
设置将在其中放置数据的目标 band 的索引。索引不能重复。

null 值指示所有目标 band 都将被使用。

如果没有指定目标图像，选择目标 band 子集不会影响某一读取操作的输出图像中的 band 数；所创建的目标图像仍然拥有相同的 band 数，就像从未调用此方法一样。如果需要目标图像中不同数量的 band，则必须使用 ImageReadParam.setDestination 方法提供一幅图像。

在读取或写入时，如果指定了大于最大目标 band 索引的值，或者要使用的源 band 的数量和目标 band 的数量不同，则 reader 或 writer 将抛出 IllegalArgumentException。可以使用 ImageReader.checkReadParamBandSettings 方法自动进行此测试。

参数：
destinationBands - 将要使用的整数 band 索引组成的数组。
抛出：
IllegalArgumentException - 如果 destinationBands 包含一个负数或重复的值。
另请参见：
getDestinationBands(),
IIOParam.getSourceBands(),
ImageReader.checkReadParamBandSettings(javax.imageio.ImageReadParam, int, int)

getDestinationBands

public int[] getDestinationBands()
返回 band 索引的集合，数据将置于该集合中。如果没有设置任何值，则返回 null，指示将使用所有目标 band。

返回：
要使用的目标 band 的索引；或者 null。
另请参见：
setDestinationBands(int[])

canSetSourceRenderSize

public boolean canSetSourceRenderSize()
如果此 reader 允许通过使用 setSourceRenderSize 方法以任意大小将源图像呈现为解码过程的一部分，则返回 true。如果此方法返回 false，那么调用 setSourceRenderSize 将抛出 UnsupportedOperationException。

返回：
如果支持设置源呈现大小，则返回 true。
另请参见：
setSourceRenderSize(java.awt.Dimension)

setSourceRenderSize

public void setSourceRenderSize(Dimension size)
                         throws UnsupportedOperationException
如果能够以任意大小呈现图像，则将源宽度和高度设置为所提供的值。注意，从 ImageReader 上的 getWidth 和 getHeight 方法返回的值不受此方法的影响；它们将继续返回图像的默认大小。类似地，如果图像被平铺，那么平铺宽度和高度也是根据默认大小给出的。

通常应该选定宽度和高度，使宽度与高度的比率接近近似的图像高宽比（从 ImageReader.getAspectRatio 中返回）。

如果此插件不允许设置呈现大小，则抛出 UnsupportedOperationException。

要移除呈现大小设置值，为 size 传入一个 null 值。

参数：
size - 指示所需宽度和高度 Dimension。
抛出：
IllegalArgumentException - 如果宽度或高度为负数或 0。
UnsupportedOperationException - 如果此插件不支持重新设置图像大小。
另请参见：
getSourceRenderSize(),
ImageReader.getWidth(int),
ImageReader.getHeight(int),
ImageReader.getAspectRatio(int)

getSourceRenderSize

public Dimension getSourceRenderSize()
返回解码期间将呈现的源图像的宽度和高度，如果已经通过 setSourceRenderSize 方法设置了的话。null 值指示没有进行设置。

返回：
源图像的呈现宽度和高度（Dimension 的形式）。
另请参见：
setSourceRenderSize(java.awt.Dimension)

setSourceProgressivePasses

public void setSourceProgressivePasses(int minPass,
                                       int numPasses)
设置将被解码的逐步传递的范围。此范围之外的传递将被忽略。

逐步传递是整个图像的重新编码，通常以逐步变高的有效分辨率进行，但要求有更高的传输带宽。最常使用的逐步编码是以 JPEG 格式进行的，其中连续的传递包括高频图像内容的更详细的表示形式。

将被解码的传递的实际数量是在解码期间根据流中可用的实际传递数来确定的。因此，如果 minPass + numPasses - 1 大于最后一个可用传递的索引，则解码将在该传递结束。

Integer.MAX_VALUE 的值为 numPasses 指示应该读取从 minPass 开始的所有传递。否则，最后一个传递的索引（即 minPass + numPasses - 1）一定不能超过 Integer.MAX_VALUE。

如果没有 unsetSourceProgressivePasses 方法，通过调用 setSourceProgressivePasses(0, Integer.MAX_VALUE) 可以达到相同的效果。

参数：
minPass - 要解码的第一个传递的索引。
numPasses - 要解码的传递的最大数量。
抛出：
IllegalArgumentException - 如果 minPass 为负数，numPasses 为负数或 0，或者 numPasses 小于 Integer.MAX_VALUE，但 minPass + numPasses - 1 大于 INTEGER.MAX_VALUE。
另请参见：
getSourceMinProgressivePass(), getSourceMaxProgressivePass()

getSourceMinProgressivePass

public int getSourceMinProgressivePass()
返回将被解码的第一个逐步传递的索引。如果没有设置任何值，则返回 0（此为修正值）。

返回：
将被解码的第一个传递的索引。
另请参见：
setSourceProgressivePasses(int, int), getSourceNumProgressivePasses()

getSourceMaxProgressivePass

public int getSourceMaxProgressivePass()
如果 getSourceNumProgressivePasses 等于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。否则返回 getSourceMinProgressivePass() + getSourceNumProgressivePasses() - 1。

返回：
将被读取的最后一个传递的索引；或者 Integer.MAX_VALUE。

getSourceNumProgressivePasses

public int getSourceNumProgressivePasses()
返回将被解码的逐步传递的数量。如果没有设置任何值，则返回 Integer.MAX_VALUE（此为修正值）。

返回：
将被解码的传递的数量。
另请参见：
setSourceProgressivePasses(int, int), getSourceMinProgressivePass()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageTranscoder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
接口 ImageTranscoder

所有已知实现类：
ImageWriter
public interface ImageTranscoder

提供元数据代码转换功能的接口。

只要先执行读取操作，然后执行写入操作，任何图像都可以进行代码转换（写入为一种与原存储格式不同的格式）。不过，由于格式的不同，这一过程中可能会丢失数据。

通常，如果可以创建特定于格式的元数据对象来封装尽可能多的有关图像及其关联元数据的信息（以能被用来执行编码的特定 ImageWriter 所理解的形式），则可以获得最好的结果。

ImageTranscoder 可以用来将 ImageReader 所提供的 IIOMetadata 对象（表示每流和每图像元数据）转换成适合特定 ImageWriter 编码的相应对象。在直接对 ImageWriter 调用此接口方法的情况下，输出将适合该 writer。

将 IIOMetadata 对象转换成特定于 writer 的格式的内部细节将根据操作上下文的不同而不同。通常，ImageWriter 将检查传入的对象，查看它是否实现了该 writer 熟悉的其他接口。这种情况是有可能的，例如，如果该对象是通过在 reader 插件上使用读取操作获得的，而该插件由与 writer 相同的供应商写入。在这种情况下，writer 可以通过使用其特定于插件的接口来访问传入的对象。在这种情况下，如果图像文件格式保持不变，重新编码可能接近于无损失。如果格式是变化的，则 writer 仍然可以试着保留尽可能多的信息。

如果传入对象没有实现 writer 已知的任何其他接口，则该 writer 别无选择，只能通过标准 IIOMetadata 接口（比如 IIOMetadata.getAsTree 提供的树型视图）访问它。在这种情况下，很可能会有信息的严重丢失。

独立的 ImageTranscoder 实质上与上例中的 writer 插件起着相同的作用。它必须熟悉由 reader 和 writer 插件使用的私有接口，并手工实例化可由 writer 使用的对象。得到的元数据对象可由 writer 直接使用。

该标准 API 中不提供任何 ImageTranscoder 的独立实现。相反，此接口的用途是在需要时为将由应用程序创建和开发的实现提供一种方法。

方法摘要
IIOMetadata | convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
IIOMetadata | convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。

方法详细信息

convertStreamMetadata

IIOMetadata convertStreamMetadata(IIOMetadata inData,
                                  ImageWriteParam param)
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。

可以提供一个可选的 ImageWriteParam，用于其能影响流元数据的结构的情况。

如果所提供的 ImageWriteParam 包含可选的、不被此 writer 或 transcoder 理解的设置值，则忽略这些值。

参数：
inData - 表示流元数据的 IIOMetadata 对象，用于初始化所返回对象的状态。
param - 将用于对图像进行编码的 ImageWriteParam，或者为 null。
返回：
一个 IIOMetadata 对象，如果插件没有提供元数据编码功能，则返回 null。
抛出：
IllegalArgumentException - 如果 inData 为 null。

convertImageMetadata

IIOMetadata convertImageMetadata(IIOMetadata inData,
                                 ImageTypeSpecifier imageType,
                                 ImageWriteParam param)
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。

可以提供一个可选的 ImageWriteParam，用于其能影响图像元数据的结构的情况。

如果所提供的 ImageWriteParam 包含可选的、不被此 writer 或 transcoder 理解的设置值，则忽略这些值。

参数：
inData - 表示图像元数据的 IIOMetadata 对象，用于初始化所返回对象的状态。
imageType - 指示将与元数据关联的图像的布局和颜色信息的 ImageTypeSpecifier。
param - 将用于对图像进行编码的 ImageWriteParam，或者为 null。
返回：
一个 IIOMetadata 对象，如果插件没有提供元数据编码功能，则返回 null。
抛出：
IllegalArgumentException - 如果 inData 或 imageType 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageTypeSpecifier (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 ImageTypeSpecifier

java.lang.Object
    继承者  javax.imageio.ImageTypeSpecifier

public class ImageTypeSpecifier
extends Object

允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。

字段摘要
protected ColorModel | colorModel 将用作原型的 ColorModel。
protected SampleModel | sampleModel 将用作原型的 SampleModel。
构造方法摘要
ImageTypeSpecifier(ColorModel colorModel, SampleModel sampleModel)
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。
ImageTypeSpecifier(RenderedImage image)
根据 RenderedImage 构造一个 ImageTypeSpecifier。
方法摘要
static ImageTypeSpecifier | createBanded(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。
BufferedImage | createBufferedImage(int width, int height) 根据此对象中包含的规范创建一个具有给定宽度和高度的 BufferedImage。
static ImageTypeSpecifier | createFromBufferedImageType(int bufferedImageType) 返回一个 ImageTypeSpecifier，它将对某一标准 BufferedImage 类型（而不是 TYPE_CUSTOM）进行编码。
static ImageTypeSpecifier | createFromRenderedImage(RenderedImage image) 返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。
static ImageTypeSpecifier | createGrayscale(int bits, int dataType, boolean isSigned) 返回灰度级图像格式的说明符，它会将给定位深 (bit depth) 的像素压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | createGrayscale(int bits, int dataType, boolean isSigned, boolean isAlphaPremultiplied) 返回灰度级图像格式和 alpha 图像格式的说明符，它会将给定位深的像素压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | createIndexed(byte[] redLUT, byte[] greenLUT, byte[] blueLUT, byte[] alphaLUT, int bits, int dataType) 返回索引颜色图像格式的说明符，它将给定位深的索引值压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | createInterleaved(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。
static ImageTypeSpecifier | createPacked(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied) 返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。
boolean | equals(Object o) 如果给定 Object 是一个 ImageTypeSpecifier 并且具有与此对象相同的 SampleModel 和 ColorModel，则返回 true。
int | getBitsPerBand(int band) 返回用来表示给定 band 样本的位数。
int | getBufferedImageType() 返回一个 int 值，它包含某一来自 BufferedImage 的描述图像的枚举常量值。
ColorModel | getColorModel() 返回此对象指定的 ColorModel。
int | getNumBands() 返回此对象指定的 band 数。
int | getNumComponents() 返回此对象指定的颜色组件的数量。
SampleModel | getSampleModel() 根据此对象中封装的设置返回一个 SampleModel。
SampleModel | getSampleModel(int width, int height) 根据此对象中封装的设置值返回一个 SampleModel。
int | hashCode() 返回此 ImageTypeSpecifier 的哈希码。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

colorModel

protected ColorModel colorModel
将用作原型的 ColorModel。

sampleModel

protected SampleModel sampleModel
将用作原型的 SampleModel。

构造方法详细信息

ImageTypeSpecifier

public ImageTypeSpecifier(ColorModel colorModel,
                          SampleModel sampleModel)
直接根据 ColorModel 和 SampleModel 构造一个 ImageTypeSpecifier。由调用者负责提供兼容的参数。

参数：
colorModel - 一个 ColorModel。
sampleModel - 一个 SampleModel。
抛出：
IllegalArgumentException - 如果任意一个参数为 null。
IllegalArgumentException - 如果 sampleModel 与 colorModel 不兼容。

ImageTypeSpecifier

public ImageTypeSpecifier(RenderedImage image)
根据 RenderedImage 构造一个 ImageTypeSpecifier。如果使用的是 BufferedImage，为了获得更精确的结果，应该使用 createFromRenderedImage 或 createFromBufferedImageType 这两个工厂方法之一。

参数：
image - 一个 RenderedImage。
抛出：
IllegalArgumentException - 如果该参数为 null。
方法详细信息

createPacked

public static ImageTypeSpecifier createPacked(ColorSpace colorSpace,
                                              int redMask,
                                              int greenMask,
                                              int blueMask,
                                              int alphaMask,
                                              int transferType,
                                              boolean isAlphaPremultiplied)
返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。

参数：
colorSpace - 所需的 ColorSpace。
redMask - 指示红色通道位置的邻接掩码。
greenMask - 指示绿色通道位置的邻接掩码。
blueMask - 指示蓝色通道位置的邻接掩码。
alphaMask - 指示 alpha 通道位置的邻接掩码。
transferType - 所需的 SampleModel 传输类型。
isAlphaPremultiplied - 如果颜色通道将预乘以 alpha 通道，则该参数为 true。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 colorSpace 为 null。
IllegalArgumentException - 如果 colorSpace 的类型不是 TYPE_RGB。
IllegalArgumentException - 如果没有掩码至少有一个位集。
IllegalArgumentException - 如果 transferType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之一。

createInterleaved

public static ImageTypeSpecifier createInterleaved(ColorSpace colorSpace,
                                                   int[] bandOffsets,
                                                   int dataType,
                                                   boolean hasAlpha,
                                                   boolean isAlphaPremultiplied)
返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。

参数：
colorSpace - 所需的 ColorSpace。
bandOffsets - 指示每个 band 的偏移量的 int 数组。
dataType - 所需的数据类型，它是 DataBuffer 类中的枚举之一。
hasAlpha - 如果需要 alpha 通道，则该参数为 true。
isAlphaPremultiplied - 如果颜色通道将预乘以 alpha 通道，则该参数为 true。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 colorSpace 为 null。
IllegalArgumentException - 如果 bandOffsets 为 null。
IllegalArgumentException - 如果 dataType 不是合法的 DataBuffer.TYPE_* 常量之一。
IllegalArgumentException - 如果 bandOffsets.length 不等于颜色空间组件的数量；如果 hasAlpha 为 true 时，该长度不等于组件数量加 1。

createBanded

public static ImageTypeSpecifier createBanded(ColorSpace colorSpace,
                                              int[] bankIndices,
                                              int[] bandOffsets,
                                              int dataType,
                                              boolean hasAlpha,
                                              boolean isAlphaPremultiplied)
返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。

参数：
colorSpace - 所需的 ColorSpace。
bankIndices - 一个 int 数组，指示用来存储每个 band 的库。
bandOffsets - 一个 int 数组，指示其库中每个 band 的起始偏移量。
dataType - 所需的数据类型，它是 DataBuffer 类中的枚举之一。
hasAlpha - 如果需要 alpha 通道，则该参数为 true。
isAlphaPremultiplied - 如果颜色通道将预乘以 alpha 通道，则该参数为 true。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 colorSpace 为 null。
IllegalArgumentException - 如果 bankIndices 为 null。
IllegalArgumentException - 如果 bandOffsets 为 null。
IllegalArgumentException - 如果 bankIndices 和 bandOffsets 的长度不同。
IllegalArgumentException - 如果 bandOffsets.length 不等于颜色空间组件的数量；如果 hasAlpha 为 true 时，该长度不等于组件数量加 1。
IllegalArgumentException - 如果 dataType 不是合法的 DataBuffer.TYPE_* 常量之一。

createGrayscale

public static ImageTypeSpecifier createGrayscale(int bits,
                                                 int dataType,
                                                 boolean isSigned)
返回灰度级图像格式的说明符，它会将给定位深 (bit depth) 的像素压缩成指定数据类型的数组元素。

参数：
bits - 每个灰度值的位数（1、2、4、8 或 16）。
dataType - 所需的数据类型，它是 DataBuffer 类中的枚举之一。
isSigned - 如果要表示负值，则该参数为 true。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 bits 不是 1、2、4、8 或 16 之一。
IllegalArgumentException - 如果 dataType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_SHORT 或 DataBuffer.TYPE_USHORT 之一。
IllegalArgumentException - 如果 bits 大于给定 dataType 的位大小。

createGrayscale

public static ImageTypeSpecifier createGrayscale(int bits,
                                                 int dataType,
                                                 boolean isSigned,
                                                 boolean isAlphaPremultiplied)
返回灰度级图像格式和 alpha 图像格式的说明符，它会将给定位深的像素压缩成指定数据类型的数组元素。

参数：
bits - 每个灰度值的位数（1、2、4、8 或 16）。
dataType - 所需的数据类型，它是 DataBuffer 类中的枚举之一。
isSigned - 如果要表示负值，则该参数为 true。
isAlphaPremultiplied - 如果亮度通道将乘以 alpha 通道，则该参数为 true。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 bits 不是 1、2、4、8 或 16 之一。
IllegalArgumentException - 如果 dataType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_SHORT 或 DataBuffer.TYPE_USHORT 之一。
IllegalArgumentException - 如果 bits 大于给定 dataType 的位大小。

createIndexed

public static ImageTypeSpecifier createIndexed(byte[] redLUT,
                                               byte[] greenLUT,
                                               byte[] blueLUT,
                                               byte[] alphaLUT,
                                               int bits,
                                               int dataType)
返回索引颜色图像格式的说明符，它将给定位深的索引值压缩成指定数据类型的数组元素。

参数：
redLUT - 一个 byte 数组，包含每个索引的 red 值。
greenLUT - 一个 byte 数组，包含每个索引的 green 值。
blueLUT - 一个 byte 数组，包含每个索引的 blue 值。
alphaLUT - 一个 byte 数组，包含每个索引的 alpha 值；或者为 null，表示创建一个完全不透明的 LUT。
bits - 每个索引中的位数。
dataType - 所需的输出类型，它是 DataBuffer 类中的枚举之一。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 redLUT 为 null。
IllegalArgumentException - 如果 greenLUT 为 null。
IllegalArgumentException - 如果 blueLUT 为 null。
IllegalArgumentException - 如果 bits 不是 1、2、4、8 或 16 之一。
IllegalArgumentException - 如果非 null LUT 参数的长度不能正好满足 1 << bits。
IllegalArgumentException - 如果 dataType 不是 DataBuffer.TYPE_BYTE、DataBuffer.TYPE_SHORT、DataBuffer.TYPE_USHORT 或 DataBuffer.TYPE_INT 之一。
IllegalArgumentException - 如果 bits 大于给定 dataType 的位大小。

createFromBufferedImageType

public static ImageTypeSpecifier createFromBufferedImageType(int bufferedImageType)
返回一个 ImageTypeSpecifier，它将对某一标准 BufferedImage 类型（而不是 TYPE_CUSTOM）进行编码。

参数：
bufferedImageType - 表示某一标准 BufferedImage 类型的 int 值。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 bufferedImageType 不是标准类型之一，或者它等于 TYPE_CUSTOM。
另请参见：
BufferedImage, BufferedImage.TYPE_INT_RGB, BufferedImage.TYPE_INT_ARGB, BufferedImage.TYPE_INT_ARGB_PRE, BufferedImage.TYPE_INT_BGR, BufferedImage.TYPE_3BYTE_BGR, BufferedImage.TYPE_4BYTE_ABGR, BufferedImage.TYPE_4BYTE_ABGR_PRE, BufferedImage.TYPE_USHORT_565_RGB, BufferedImage.TYPE_USHORT_555_RGB, BufferedImage.TYPE_BYTE_GRAY, BufferedImage.TYPE_USHORT_GRAY, BufferedImage.TYPE_BYTE_BINARY, BufferedImage.TYPE_BYTE_INDEXED

createFromRenderedImage

public static ImageTypeSpecifier createFromRenderedImage(RenderedImage image)
返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。

参数：
image - 一个 RenderedImage。
返回：
具有所需特征的 ImageTypeSpecifier。
抛出：
IllegalArgumentException - 如果 image 为 null。

getBufferedImageType

public int getBufferedImageType()
返回一个 int 值，它包含某一来自 BufferedImage 的描述图像的枚举常量值。

返回：
表示 BufferedImage 类型的 int。
另请参见：
BufferedImage, BufferedImage.TYPE_CUSTOM, BufferedImage.TYPE_INT_RGB, BufferedImage.TYPE_INT_ARGB, BufferedImage.TYPE_INT_ARGB_PRE, BufferedImage.TYPE_INT_BGR, BufferedImage.TYPE_3BYTE_BGR, BufferedImage.TYPE_4BYTE_ABGR, BufferedImage.TYPE_4BYTE_ABGR_PRE, BufferedImage.TYPE_USHORT_565_RGB, BufferedImage.TYPE_USHORT_555_RGB, BufferedImage.TYPE_BYTE_GRAY, BufferedImage.TYPE_USHORT_GRAY, BufferedImage.TYPE_BYTE_BINARY, BufferedImage.TYPE_BYTE_INDEXED

getNumComponents

public int getNumComponents()
返回此对象指定的颜色组件的数量。该数量等于 ColorModel.getNumComponents 返回的值。

返回：
图像中的组件数。

getNumBands

public int getNumBands()
返回此对象指定的 band 数。该数量等于 SampleModel.getNumBands 返回的值。

返回：
图像中的 band 数。

getBitsPerBand

public int getBitsPerBand(int band)
返回用来表示给定 band 样本的位数。

参数：
band - 将被查询的 band 的索引（int 值形式）。
返回：
指定位数的 int 值。
抛出：
IllegalArgumentException - 如果 band 为负或大于最大 band 索引。

getSampleModel

public SampleModel getSampleModel()
根据此对象中封装的设置返回一个 SampleModel。SampleModel 的宽度和高度将被设置为任意值。

返回：
具有任意维数的 SampleModel。

getSampleModel

public SampleModel getSampleModel(int width,
                                  int height)
根据此对象中封装的设置值返回一个 SampleModel。SampleModel 的宽度和高度将被设置为所提供的值。

参数：
width - 返回的 SampleModel 的所需宽度。
height - 返回的 SampleModel 的所需高度。
返回：
具有给定维数的 SampleModel。
抛出：
IllegalArgumentException - 如果 width 或 height 为负数或零。
IllegalArgumentException - 如果 width 和 height 的值大于 Integer.MAX_VALUE

getColorModel

public ColorModel getColorModel()
返回此对象指定的 ColorModel。

返回：
一个 ColorModel。

createBufferedImage

public BufferedImage createBufferedImage(int width,
                                         int height)
根据此对象中包含的规范创建一个具有给定宽度和高度的 BufferedImage。

参数：
width - 返回的 BufferedImage 的所需宽度。
height - 返回的 BufferedImage 的所需高度。
返回：
一个新的 BufferedImage
抛出：
IllegalArgumentException - 如果 width 或 height 为负数或零。
IllegalArgumentException - 如果 width 和 height 的值大于 Integer.MAX_VALUE，或者存储图像所需的数组元素数大于 Integer.MAX_VALUE。

equals

public boolean equals(Object o)
如果给定 Object 是一个 ImageTypeSpecifier 并且具有与此对象相同的 SampleModel 和 ColorModel，则返回 true。

覆盖：
类 Object 中的 equals
参数：
o - 将用于相等性比较的 Object。
返回：
如果给定对象是一个等价的 ImageTypeSpecifier，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 ImageTypeSpecifier 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 ImageTypeSpecifier 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageWriteParam (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 ImageWriteParam

java.lang.Object
    继承者  javax.imageio.IIOParam
        继承者  javax.imageio.ImageWriteParam
直接已知子类：
BMPImageWriteParam, JPEGImageWriteParam
public class ImageWriteParam
extends IIOParam

描述如何对流进行编码的类。此类的实例或其子类用于提供 ImageWriter 实例的规定“入门”信息。

用于特定图像格式的插件可以定义此类的一个子类，并从其 ImageWriter 实现的 getDefaultWriteParam 方法返回该类的对象。例如，内置 JPEG writer 插件将返回 javax.imageio.plugins.jpeg.JPEGImageWriteParam 的实例。

要写入的图像区域通过第一次将图像的实际边界与 IIOParam.setSourceRegion 指定的矩形（如果有）的相交来确定。如果所得矩形的宽度或高度为零，则该 writer 将抛出 IIOException。如果相交区域为非空，则写入操作将从第一个二次取样的像素开始，并根据 IIOParam.setSourceSubsampling 指定的水平和垂直二次取样因子包含相交边界内额外的像素。

个别特征（比如 tiling、逐步编码和压缩）可以用以下四种模式之一设置。MODE_DISABLED 禁用这些特征；MODE_DEFAULT 使用带有受控于 writer 的参数值启用这些特征；MODE_EXPLICIT 启用这些特定并允许使用 set 方法提供额外的参数；MODE_COPY_FROM_METADATA 则从流以及传递给 writer 的图像元数据对象中复制相关的参数值。所有特征的默认模式是 MODE_COPY_FROM_METADATA。鼓励使用子类中提供的非标准特征，但不要求使用类似的方案。

插件 writer 可以通过提供实现额外的、特定于插件的接口来扩展 ImageWriteParam 的功能。由插件负责记录哪些接口可用以及如何使用。writer 将安静地忽略所有其未知的 ImageWriteParam 子类扩展功能。此外，将忽略通常在通过 getDefaultWriteParam 创建自己的 ImageWriteParam 实例时禁用的所有可选功能。

注意，如果不存在针对某一功能的查询方法，所有 ImageWriter 实现就必须都支持该功能（例如，逐步编码是可选的，但二次取样必须受支持）。

另请参见：
ImageReadParam

字段摘要
protected boolean | canOffsetTiles 如果此 ImageWriteParam 允许使用 tiling 网格偏移量参数，则返回为 true 的 boolean 值。
protected boolean | canWriteCompressed 如果此 writer 可以使用压缩写入图像，则返回为 true 的 boolean 值。
protected boolean | canWriteProgressive 如果此 ImageWriteParam 允许以一个质量递增传递的逐步序列的方式写入图像，则返回为 true 的 boolean 值。
protected boolean | canWriteTiles 如果此 ImageWriteParam 允许设置 tile 的宽度和高度参数，则返回为 true 的 boolean 值。
protected int | compressionMode 控制压缩设置的模式，必须将它设置为四个 MODE_* 值之一。
protected float | compressionQuality 包含当前压缩质量设置的 float 值。
protected String | compressionType 包含当前压缩类型名称的 String，如果没有设置压缩类型，则返回 null。
protected String[] | compressionTypes 包含可用压缩类型名称的 String 数组。
protected Locale | locale 用于本地化压缩类型名称和质量描述的 Locale，null 表示使用默认 Locale。
static int | MODE_COPY_FROM_METADATA 一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
static int | MODE_DEFAULT 一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
static int | MODE_DISABLED 一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以禁用用于以后的写入操作的某个特征。
static int | MODE_EXPLICIT 一个常量值，可以传入诸如 setTilingMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。
protected Dimension[] | preferredTileSizes 首选 tile 大小范围对组成的数组。
protected int | progressiveMode 控制逐步编码的模式，必须将它设置为除 MODE_EXPLICIT 以外的四个 MODE_* 值之一。
protected int | tileGridXOffset 如果已经设置 tiling，则返回 tile 网格原点应该从图像原点水平偏移的量。
protected int | tileGridYOffset 如果已经设置 tiling，则返回 tile 网格原点应该从图像原点垂直偏移的量。
protected int | tileHeight 如果已经设置 tiling，则返回每个 tile 的高度，否则返回 0。
protected int | tileWidth 如果已经设置 tiling，则返回每个 tile 的宽度，否则返回 0。
protected int | tilingMode 控制 tiling 设置的模式，必须将它设置为以下四个 MODE_* 值之一。
protected boolean | tilingSet 如果已经指定 tiling 参数，则返回一个为 true 的 boolean 值。
从类 javax.imageio.IIOParam 继承的字段
controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset
构造方法摘要
protected | ImageWriteParam() 构造一个空的 ImageWriteParam。
 | ImageWriteParam(Locale locale) 构造一个 ImageWriteParam 集，以使用给定 Locale。
方法摘要
boolean | canOffsetTiles() 如果 writer 在执行写入操作的同时可以使用非零网格偏移量进行平铺，则返回 true。
boolean | canWriteCompressed() 如果此 writer 支持压缩，则返回 true。
boolean | canWriteProgressive() 如果 writer 能够以一系列质量逐渐递增的传递的方式将图像写出，则返回 true。
boolean | canWriteTiles() 如果 writer 在执行写入操作的同时可以进行平铺，则返回 true。
float | getBitRate(float quality) 返回一个 float 值，该值指示对给定质量级别上用于输入图像数据的每个位的输出数据位数的估计。
int | getCompressionMode() 如果支持压缩，则返回当前压缩模式。
float | getCompressionQuality() 返回当前压缩质量设置。
String[] | getCompressionQualityDescriptions() 返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。
float[] | getCompressionQualityValues() 返回一个 float 数组，可作为用户界面的一部分与 getCompressionQualityDescriptions 一起使用，以设置或显示压缩质量级别。
String | getCompressionType() 返回当前设置的压缩类型，如果没有设置任何压缩类型，则返回 null。
String[] | getCompressionTypes() 以数组或 String 形式返回可用压缩类型的列表，如果不能使用这些接口选择压缩类型，则返回 null。
Locale | getLocale() 返回当前设置的 Locale，如果仅支持默认 Locale，则返回 null。
String | getLocalizedCompressionTypeName() 返回当前压缩类型的本地化名称，使用 getLocale 返回的 Locale。
Dimension[] | getPreferredTileSizes() 返回一个 Dimension 数组，指示在输出文件或流中进行编码时 tile 的合法大小范围。
int | getProgressiveMode() 返回以逐步方式将数据写入流的当前模式。
int | getTileGridXOffset() 返回图像的水平 tile 网格偏移量，将根据该偏移量对输出流进行写入。
int | getTileGridYOffset() 返回图像的垂直 tile 网格偏移量，将根据该偏移量对输出流进行写入。
int | getTileHeight() 返回图像中每个 tile 的高度，将根据该高度对输出流进行写入。
int | getTileWidth() 返回图像中每个 tile 的宽度，将根据该宽度对输出流进行写入。
int | getTilingMode() 如果支持平铺，则返回当前平铺模式。
boolean | isCompressionLossless() 如果当前压缩类型提供无损失的压缩，则返回 true。
void | setCompressionMode(int mode) 指定是否执行压缩，如果执行压缩，将如何确定 compression 参数。
void | setCompressionQuality(float quality) 将压缩质量设置为 0 和 1 之间的某个值。
void | setCompressionType(String compressionType) 将压缩类型设置为 getCompressionTypes 指示的值之一。
void | setProgressiveMode(int mode) 指定 writer 使用逐步模式写出图像，从而输出流将包含一系列质量递增的扫描。
void | setTiling(int tileWidth, int tileHeight, int tileGridXOffset, int tileGridYOffset) 指定应该在输出流中平铺图像。
void | setTilingMode(int mode) 确定图像在输出流中是否将被平铺，如果将被平铺，将如何确定 tiling 参数。
void | unsetCompression() 移除所有以前的压缩类型和质量设置。
void | unsetTiling() 移除通过调用 setTiling 指定的所有以前的 tile 网格参数。
从类 javax.imageio.IIOParam 继承的方法
activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setDestinationType, setSourceBands, setSourceRegion, setSourceSubsampling
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MODE_DISABLED

public static final int MODE_DISABLED
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以禁用用于以后的写入操作的某个特征。也就是说，在设置此模式时，该流将不被平铺、逐步编码或压缩，相关的访问器方法将抛出 IllegalStateException。

另请参见：
MODE_EXPLICIT, MODE_COPY_FROM_METADATA, MODE_DEFAULT, setProgressiveMode(int), getProgressiveMode(), setTilingMode(int), getTilingMode(), setCompressionMode(int), getCompressionMode(), 常量字段值

MODE_DEFAULT

public static final int MODE_DEFAULT
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 和 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。也就是说，在启用此模式时，将根据 writer 以与插件有关的方式内部选择的明智默认值来平铺、逐步编码和压缩该流，相关的访问器方法将抛出 IllegalStateException。

另请参见：
MODE_DISABLED, MODE_EXPLICIT, MODE_COPY_FROM_METADATA, setProgressiveMode(int), getProgressiveMode(), setTilingMode(int), getTilingMode(), setCompressionMode(int), getCompressionMode(), 常量字段值

MODE_EXPLICIT

public static final int MODE_EXPLICIT
一个常量值，可以传入诸如 setTilingMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。也就是说，在设置此模式时，将根据为此类中的相应 set 方法提供的额外信息和可以从相应 get 方法中获取到的信息来平铺或压缩该流。注意，此模式不支持逐步输出。

另请参见：
MODE_DISABLED, MODE_COPY_FROM_METADATA, MODE_DEFAULT, setProgressiveMode(int), getProgressiveMode(), setTilingMode(int), getTilingMode(), setCompressionMode(int), getCompressionMode(), 常量字段值

MODE_COPY_FROM_METADATA

public static final int MODE_COPY_FROM_METADATA
一个常量值，可以传入诸如 setTilingMode、setProgressiveMode 或 setCompressionMode 之类的方法中，以启用用于以后的写入操作的特征。也就是说，在启用此模式时，将根据传入写入操作的流内容和/或图像元数据来平铺、逐步编码和压缩该流，所有相关访问器方法都将抛出 IllegalStateException。

这是所有特征的默认模式，因此，如果一个包括元数据的读取操作之后将进行包括元数据的写入操作，则读取操作将保留尽可能多的信息。

另请参见：
MODE_DISABLED, MODE_EXPLICIT, MODE_DEFAULT, setProgressiveMode(int), getProgressiveMode(), setTilingMode(int), getTilingMode(), setCompressionMode(int), getCompressionMode(), 常量字段值

canWriteTiles

protected boolean canWriteTiles
如果此 ImageWriteParam 允许设置 tile 的宽度和高度参数，则返回为 true 的 boolean 值。默认情况下，该值为 false。子类必须手工设置该值。

不支持写入 tile 的子类应该确保此值被设置为 false。

tilingMode

protected int tilingMode
控制 tiling 设置的模式，必须将它设置为以下四个 MODE_* 值之一。默认值为 MODE_COPY_FROM_METADATA。

不支持写入 tile 的子类可以忽略此值。

另请参见：
MODE_DISABLED, MODE_EXPLICIT, MODE_COPY_FROM_METADATA, MODE_DEFAULT, setTilingMode(int), getTilingMode()

preferredTileSizes

protected Dimension[] preferredTileSizes
首选 tile 大小范围对组成的数组。默认值为 null，指示没有首选大小。如果该值为非 null 值，则首选大小的平均长度必须至少为 2。

不支持写入 tile 的子类可以忽略此值。

另请参见：
getPreferredTileSizes()

tilingSet

protected boolean tilingSet
如果已经指定 tiling 参数，则返回一个为 true 的 boolean 值。

不支持写入 tile 的子类可以忽略此值。

tileWidth

protected int tileWidth
如果已经设置 tiling，则返回每个 tile 的宽度，否则返回 0。

不支持 tiling 的子类可以忽略此值。

tileHeight

protected int tileHeight
如果已经设置 tiling，则返回每个 tile 的高度，否则返回 0。初始值为 0。

不支持 tiling 的子类可以忽略此值。

canOffsetTiles

protected boolean canOffsetTiles
如果此 ImageWriteParam 允许使用 tiling 网格偏移量参数，则返回为 true 的 boolean 值。默认情况下，该值为 false。子类必须手工设置该值。

不支持写入 tile 的子类或支持写入 tile 但不支持将 tile 偏移的子类必须确保此值被设置为 false。

tileGridXOffset

protected int tileGridXOffset
如果已经设置 tiling，则返回 tile 网格原点应该从图像原点水平偏移的量。否则返回 0。初始值为 0。

不支持将 tile 偏移的子类可以忽略此值。

tileGridYOffset

protected int tileGridYOffset
如果已经设置 tiling，则返回 tile 网格原点应该从图像原点垂直偏移的量。否则返回 0。初始值为 0。

不支持将 tile 偏移的子类可以忽略此值。

canWriteProgressive

protected boolean canWriteProgressive
如果此 ImageWriteParam 允许以一个质量递增传递的逐步序列的方式写入图像，则返回为 true 的 boolean 值。默认情况下，该值为 false。子类必须手工设置该值。

不支持逐步编码的子类必须确保此值被设置为 false。

progressiveMode

protected int progressiveMode
控制逐步编码的模式，必须将它设置为除 MODE_EXPLICIT 以外的四个 MODE_* 值之一。默认值为 MODE_COPY_FROM_METADATA。

不支持逐步编码的子类可以忽略此值。

另请参见：
MODE_DISABLED, MODE_EXPLICIT, MODE_COPY_FROM_METADATA, MODE_DEFAULT, setProgressiveMode(int), getProgressiveMode()

canWriteCompressed

protected boolean canWriteCompressed
如果此 writer 可以使用压缩写入图像，则返回为 true 的 boolean 值。默认情况下，该值为 false。子类必须手工设置该值。

不支持压缩的子类必须确保此值被设置为 false。

compressionMode

protected int compressionMode
控制压缩设置的模式，必须将它设置为四个 MODE_* 值之一。默认值为 MODE_COPY_FROM_METADATA。

不支持压缩的子类可以忽略此值。

另请参见：
MODE_DISABLED, MODE_EXPLICIT, MODE_COPY_FROM_METADATA, MODE_DEFAULT, setCompressionMode(int), getCompressionMode()

compressionTypes

protected String[] compressionTypes
包含可用压缩类型名称的 String 数组。子类必须手工设置该值。

不支持压缩的子类可以忽略此值。

compressionType

protected String compressionType
包含当前压缩类型名称的 String，如果没有设置压缩类型，则返回 null。

不支持压缩的子类可以忽略此值。

compressionQuality

protected float compressionQuality
包含当前压缩质量设置的 float 值。初始值为 1.0F。

不支持压缩的子类可以忽略此值。

locale

protected Locale locale
用于本地化压缩类型名称和质量描述的 Locale，null 表示使用默认 Locale。子类必须手工设置该值。

构造方法详细信息

ImageWriteParam

protected ImageWriteParam()
构造一个空的 ImageWriteParam。由子类负责恰当地设置实例变量。

ImageWriteParam

public ImageWriteParam(Locale locale)
构造一个 ImageWriteParam 集，以使用给定 Locale。

参数：
locale - 将用于本地化压缩类型名称和质量描述的 Locale，或者为 null。
方法详细信息

getLocale

public Locale getLocale()
返回当前设置的 Locale，如果仅支持默认 Locale，则返回 null。

返回：
当前 Locale 或 null。

canWriteTiles

public boolean canWriteTiles()
如果 writer 在执行写入操作的同时可以进行平铺，则返回 true。如果此方法返回 false，则 setTiling 将抛出 UnsupportedOperationException。

返回：
如果 writer 支持平铺，则返回 true。
另请参见：
canOffsetTiles(), setTiling(int, int, int, int)

canOffsetTiles

public boolean canOffsetTiles()
如果 writer 在执行写入操作的同时可以使用非零网格偏移量进行平铺，则返回 true。如果此方法返回 false，则 setTiling 将抛出 UnsupportedOperationException，如果网格偏移量参数不同时为零的话。如果 canWriteTiles 返回 false，则此方法也将返回 false。

返回：
如果 writer 支持非零 tile 偏移量，则返回 true。
另请参见：
canWriteTiles(), setTiling(int, int, int, int)

setTilingMode

public void setTilingMode(int mode)
确定图像在输出流中是否将被平铺，如果将被平铺，将如何确定 tiling 参数。对这些模式的解释如下：
  • MODE_DISABLED - 图像不会被平铺，setTiling 将抛出 IllegalStateException。
  • MODE_DEFAULT - 将使用默认参数平铺图像。setTiling 将抛出 IllegalStateException。
  • MODE_EXPLICIT - 将根据 setTiling 方法中给定的参数平铺图像。任何以前设置的 tiling 参数都将被丢弃。
  • MODE_COPY_FROM_METADATA - 图像将与传入某一写入操作中的元数据对象一致。setTiling 将抛出 IllegalStateException。

参数：
mode - 用于 tiling 的模式。
抛出：
UnsupportedOperationException - 如果 canWriteTiles 返回 false。
IllegalArgumentException - 如果 mode 不是上面列出的模式之一。
另请参见：
setTiling(int, int, int, int), getTilingMode()

getTilingMode

public int getTilingMode()
如果支持平铺，则返回当前平铺模式。否则抛出 UnsupportedOperationException。

返回：
当前平铺模式。
抛出：
UnsupportedOperationException - 如果 canWriteTiles 返回 false。
另请参见：
setTilingMode(int)

getPreferredTileSizes

public Dimension[] getPreferredTileSizes()
返回一个 Dimension 数组，指示在输出文件或流中进行编码时 tile 的合法大小范围。返回的数组是一个副本。

信息以对集合的形式返回；对的第一个元素包含最小宽度和高度（包括在内），第二个元素包含最大宽度和高度（包括在内）。将其放到一起，每个对便定义了一个有效大小范围。要定义固定大小，则对两个元素使用相同的宽度和高度。要定义任意范围，则使用 null 值替代实际 Dimension 数组。

如果构造方法上没有指定数组，但允许进行平铺，则此方法返回 null。

返回：
一个 Dimension 数组，其平均长度至少为 2；或者 null。
抛出：
UnsupportedOperationException - 如果插件不支持平铺。

setTiling

public void setTiling(int tileWidth,
                      int tileHeight,
                      int tileGridXOffset,
                      int tileGridYOffset)
指定应该在输出流中平铺图像。tileWidth 和 tileHeight 参数指定文件中 tile 的宽度和高度。如果 tile 的宽度或高度大于图像的宽度或高度，则图像无法使用该维数平铺。

如果 canOffsetTiles 返回 false，则 tileGridXOffset 和 tileGridYOffset 参数必须为零。

参数：
tileWidth - 每个 tile 的宽度。
tileHeight - 每个 tile 的高度。
tileGridXOffset - tile 网格的水平偏移量。
tileGridYOffset - tile 网格的垂直偏移量。
抛出：
UnsupportedOperationException - 如果插件不支持平铺。
IllegalStateException - 如果平铺模式不为 MODE_EXPLICIT。
UnsupportedOperationException - 如果插件不支持网格偏移量，且网格偏移量并不都为零。
IllegalArgumentException - 如果 tile 大小不在 getPreferredTileSizes 返回的某个所允许范围内。
IllegalArgumentException - 如果 tileWidth 或 tileHeight 小于等于 0。
另请参见：
canWriteTiles,
canOffsetTiles,
getTileWidth(),
getTileHeight(),
getTileGridXOffset(),
getTileGridYOffset()

unsetTiling

public void unsetTiling()
移除通过调用 setTiling 指定的所有以前的 tile 网格参数。

默认实现将实例变量 tileWidth、tileHeight、tileGridXOffset 和 tileGridYOffset 都设置为 0。

抛出：
UnsupportedOperationException - 如果插件不支持平铺。
IllegalStateException - 如果平铺模式不为 MODE_EXPLICIT。
另请参见：
setTiling(int, int, int, int)

getTileWidth

public int getTileWidth()
返回图像中每个 tile 的宽度，将根据该宽度对输出流进行写入。如果没有设置 tiling 参数，则抛出 IllegalStateException。

返回：
将用于编码的 tile 宽度。
抛出：
UnsupportedOperationException - 如果插件不支持平铺。
IllegalStateException - 如果平铺模式不为 MODE_EXPLICIT。
IllegalStateException - 如果尚未设置 tiling 参数。
另请参见：
setTiling(int, int, int, int), getTileHeight()

getTileHeight

public int getTileHeight()
返回图像中每个 tile 的高度，将根据该高度对输出流进行写入。如果没有设置 tiling 参数，则抛出 IllegalStateException。

返回：
将用于编码的 tile 高度。
抛出：
UnsupportedOperationException - 如果插件不支持平铺。
IllegalStateException - 如果平铺模式不为 MODE_EXPLICIT。
IllegalStateException - 如果尚未设置 tiling 参数。
另请参见：
setTiling(int, int, int, int), getTileWidth()

getTileGridXOffset

public int getTileGridXOffset()
返回图像的水平 tile 网格偏移量，将根据该偏移量对输出流进行写入。如果没有设置 tiling 参数，则抛出 IllegalStateException。

返回：
将用于编码的 tile 网格 X 偏移量。
抛出：
UnsupportedOperationException - 如果插件不支持平铺。
IllegalStateException - 如果平铺模式不为 MODE_EXPLICIT。
IllegalStateException - 如果尚未设置 tiling 参数。
另请参见：
setTiling(int, int, int, int), getTileGridYOffset()

getTileGridYOffset

public int getTileGridYOffset()
返回图像的垂直 tile 网格偏移量，将根据该偏移量对输出流进行写入。如果没有设置 tiling 参数，则抛出 IllegalStateException。

返回：
将用于编码的 tile 网格 Y 偏移量。
抛出：
UnsupportedOperationException - 如果插件不支持平铺。
IllegalStateException - 如果平铺模式不为 MODE_EXPLICIT。
IllegalStateException - 如果尚未设置 tiling 参数。
另请参见：
setTiling(int, int, int, int), getTileGridXOffset()

canWriteProgressive

public boolean canWriteProgressive()
如果 writer 能够以一系列质量逐渐递增的传递的方式将图像写出，则返回 true。

返回：
如果 writer 支持逐步编码，则返回 true。
另请参见：
setProgressiveMode(int), getProgressiveMode()

setProgressiveMode

public void setProgressiveMode(int mode)
指定 writer 使用逐步模式写出图像，从而输出流将包含一系列质量递增的扫描。如果不支持逐步编码，则将抛出 UnsupportedOperationException。

mode 参数确定如何选择 progression 参数，并且必须是 MODE_DISABLED、MODE_COPY_FROM_METADATA 或 MODE_DEFAULT。否则抛出 IllegalArgumentException。

对这些模式的解释如下：

  • MODE_DISABLED - 不前进。使用此模式则停止前进。
  • MODE_COPY_FROM_METADATA - 输出图像将使用在传入 writer 的元数据对象中找到的任何 progression 参数。
  • MODE_DEFAULT - 该图像将被逐步写入，参数由 writer 选择。

默认值为 MODE_COPY_FROM_METADATA。

参数：
mode - 用来在输出流中设置进度的模式。
抛出：
UnsupportedOperationException - 如果 writer 不支持逐步编码。
IllegalArgumentException - 如果 mode 不是上面列出的模式之一。
另请参见：
getProgressiveMode()

getProgressiveMode

public int getProgressiveMode()
返回以逐步方式将数据写入流的当前模式。

返回：
逐步编码的当前模式。
抛出：
UnsupportedOperationException - 如果 writer 不支持逐步编码。
另请参见：
setProgressiveMode(int)

canWriteCompressed

public boolean canWriteCompressed()
如果此 writer 支持压缩，则返回 true。

返回：
如果 writer 支持压缩，则返回 true。

setCompressionMode

public void setCompressionMode(int mode)
指定是否执行压缩，如果执行压缩，将如何确定 compression 参数。mode 参数必须是四种模式之一，对它们的解释如下：
  • MODE_DISABLED - 如果该模式被设置为 MODE_DISABLED，则查询或修改压缩类型或参数的方法将会抛出 IllegalStateException（如果插件通常支持压缩）。一些 writer（比如 JPEG）通常不提供未压缩的输出。在这种情况下，试图将模式设置为 MODE_DISABLED 将会抛出 UnsupportedOperationException 并且将不更改该模式。
  • MODE_EXPLICIT - 使用此 ImageWriteParam 中指定的压缩类型和质量设置进行压缩。任何以前设置的 compression 参数都将被丢弃。
  • MODE_COPY_FROM_METADATA - 使用传入 writer 的元数据对象中指定的 compression 参数。
  • MODE_DEFAULT - 使用默认 compression 参数。

默认值为 MODE_COPY_FROM_METADATA。

参数：
mode - 用来在输出流中设置压缩的模式。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩，或者不支持所请求的模式。
IllegalArgumentException - 如果 mode 不是上面列出的模式之一。
另请参见：
getCompressionMode()

getCompressionMode

public int getCompressionMode()
如果支持压缩，则返回当前压缩模式。

返回：
当前压缩模式。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
另请参见：
setCompressionMode(int)

getCompressionTypes

public String[] getCompressionTypes()
以数组或 String 形式返回可用压缩类型的列表，如果不能使用这些接口选择压缩类型，则返回 null。返回的数组是一个副本。

如果 writer 只提供某一强制形式的压缩，则没有必要提供所有指定的压缩类型。指定压缩类型只应该在用户能够在不同方案之间作出有意义选择的情况下使用。

默认实现检查是否支持压缩，如果不支持，则抛出 UnsupportedOperationException。否则，如果 compressionTypes 实例变量为非 null，则返回该变量的副本，否则返回 null。

返回：
包含可用压缩类型的（非本地化）名称的 String 数组，或者返回 null。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。

setCompressionType

public void setCompressionType(String compressionType)
将压缩类型设置为 getCompressionTypes 指示的值之一。如果传入的是 null 值，则移除所有以前的设置。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是，则调用 getCompressionTypes 并检查 compressionType 是否是合法值之一。如果是合法值，则设置 compressionType 实例变量。如果 compressionType 为 null，则设置该实例变量而不执行任何检查。

参数：
compressionType - 由 getCompressionTypes 返回的 String 之一；或者为 null，表示移除所有以前的设置。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
UnsupportedOperationException - 如果没有可设置的压缩类型。
IllegalArgumentException - 如果 compressionType 为非 null 但不是 getCompressionTypes 返回的值之一。
另请参见：
getCompressionTypes(),
getCompressionType(),
unsetCompression()

getCompressionType

public String getCompressionType()
返回当前设置的压缩类型，如果没有设置任何压缩类型，则返回 null。以 String 的形式返回该类型，它是 getCompressionTypes 返回的那些类型之一。如果没有设置压缩类型，则返回 null。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，则返回 compressionType 实例变量的值。

返回：
String 形式的当前压缩类型，如果没有设置压缩类型，则返回 null。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
另请参见：
setCompressionType(java.lang.String)

unsetCompression

public void unsetCompression()
移除所有以前的压缩类型和质量设置。

默认实现将实例变量 compressionType 设置为 null，并将实例变量 compressionQuality 设置为 1.0F。

抛出：
UnsupportedOperationException - 如果插件不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
另请参见：
setCompressionType(java.lang.String), setCompressionQuality(float)

getLocalizedCompressionTypeName

public String getLocalizedCompressionTypeName()
返回当前压缩类型的本地化名称，使用 getLocale 返回的 Locale。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，或者 compressionType 为非 null，则作为一种便捷方式返回 getCompressionType 的值。

返回：
包含当前压缩类型的本地化名称的 String。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
IllegalStateException - 如果没有设置压缩类型。

isCompressionLossless

public boolean isCompressionLossless()
如果当前压缩类型提供无损失的压缩，则返回 true。如果插件只提供一个强制压缩类型，则可以在不先调用 setCompressionType 的情况下调用此方法。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 为 null 或 getCompressionType() 为非 null，则作为一种便捷方式返回 true。

返回：
如果当前压缩类型是无损失的，则返回 true。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
IllegalStateException - 如果合法压缩类型集为非 null 并且当前压缩类型为 null。

setCompressionQuality

public void setCompressionQuality(float quality)
将压缩质量设置为 0 和 1 之间的某个值。默认情况下，只支持一种压缩质量设置；writer 可以提供扩展的 ImageWriteParam，其提供了更多控制。对于有损失的压缩方案，压缩质量应该控制文件大小与图像质量之间的权衡（例如，通过在写入 JPEG 图像时选择量化表）。对于无损失方案，可以使用压缩质量控制文件大小与执行压缩所用时间之间的权衡（例如，通过在写入 PNG 图像时优化行过滤器并设置 ZLIB 压缩级别）。

压缩质量为 0.0 通常被解释为“高度压缩很重要”，而该设置为 1.0 通常被解释为“高图像质量很重要”。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 返回 null 或 compressionType 为非 null，则设置 compressionQuality 实例变量。

参数：
quality - 指示所需质量级别的 0 与 1 之间的一个 float 值。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
IllegalStateException - 如果合法压缩类型集为非 null 并且当前压缩类型为 null。
IllegalArgumentException - 如果 quality 不在 0 与 1（包括两者）之间。
另请参见：
getCompressionQuality()

getCompressionQuality

public float getCompressionQuality()
返回当前压缩质量设置。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 为 null 或 getCompressionType() 为非 null，则返回 compressionQuality 实例变量的值。

返回：
当前压缩质量设置。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
IllegalStateException - 如果合法压缩类型集为非 null 并且当前压缩类型为 null。
另请参见：
setCompressionQuality(float)

getBitRate

public float getBitRate(float quality)
返回一个 float 值，该值指示对给定质量级别上用于输入图像数据的每个位的输出数据位数的估计。该值通常位于 0 与 1 之间，值越小则压缩得越紧。特殊值 -1.0F 用于指示没有估计数可用。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 为 null 或 getCompressionType() 为非 null，并且 quality 在适当范围内，则返回 -1.0。

参数：
quality - 将查询其位率 (bit rate) 的查询设置。
返回：
压缩位率的估计数，如果没有估计数可用，则返回 -1.0F。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
IllegalStateException - 如果合法压缩类型集为非 null 并且当前压缩类型为 null。
IllegalArgumentException - 如果 quality 不在 0 与 1（包括两者）之间。

getCompressionQualityDescriptions

public String[] getCompressionQualityDescriptions()
返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。索引为 i 的 String 提供对质量级别范围的描述，该范围在 getCompressionQualityValues[i] 与 getCompressionQualityValues[i + 1] 之间。注意，从 getCompressionQualityValues 返回的数组长度将总是大于从 getCompressionQualityDescriptions 返回的数组长度。

例如，字符串 "Good"、"Better" 和 "Best" 可以与范围 [0, .33)、[.33, .66) 和 [.66, 1.0] 关联。在这种情况下，getCompressionQualityDescriptions 将返回 { "Good", "Better", "Best" }，getCompressionQualityValues 将返回 { 0.0F, .33F, .66F, 1.0F }。

如果没有描述可用，则返回 null。如果从 getCompressionQualityValues 返回 null，则此方法也必须返回 null。

应该为由 getLocale 返回的 Locale 将描述本地化，如果 Locale 为非 null 的话。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 为 null 或 getCompressionType() 为非 null，则返回 null。

返回：
包含压缩质量级别的本地化描述的 String 数组。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
IllegalStateException - 如果合法压缩类型集为非 null 并且当前压缩类型为 null。
另请参见：
getCompressionQualityValues()

getCompressionQualityValues

public float[] getCompressionQualityValues()
返回一个 float 数组，可作为用户界面的一部分与 getCompressionQualityDescriptions 一起使用，以设置或显示压缩质量级别。有关更多信息，请参阅 getCompressionQualityDescriptions。

如果没有描述可用，则返回 null。如果从 getCompressionQualityDescriptions 返回 null，则此方法也必须返回 null。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 为 null 或 getCompressionType() 为非 null，则返回 null。

返回：
一个 float 数组，指示 getCompressionQualityDescriptions 中的 String 描述的压缩质量级别之间的分界线。
抛出：
UnsupportedOperationException - 如果 writer 不支持压缩。
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
IllegalStateException - 如果合法压缩类型集为非 null 并且当前压缩类型为 null。
另请参见：
getCompressionQualityDescriptions()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageWriter (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio
类 ImageWriter

java.lang.Object
    继承者  javax.imageio.ImageWriter
所有已实现的接口：
ImageTranscoder
public abstract class ImageWriter
extends Object
implements ImageTranscoder

用来编码和写入图像的抽象超类。此类必须由在 Java Image I/O 框架的上下文中写出图像的类为其创建子类。

通常由特定格式的服务提供者类对 ImageWriter 对象进行实例化。服务提供者类在 IIORegistry 中注册，后者使用前者进行格式识别和表示可用格式 reader 和 writer。

另请参见：
ImageReader, ImageWriteParam, IIORegistry, ImageWriterSpi

字段摘要
protected Locale[] | availableLocales 可以用来本地化警告消息和压缩设置值的 Locale 组成的数组，如果本地化不受支持，则将它们初始化为 null。
protected Locale | locale 用于本地化的当前 Locale，如果没有设置 Locale，则将它初始化为 null。
protected ImageWriterSpi | originatingProvider 实例化此对象的 ImageWriterSpi，如果 ImageWriterSpi 的标识是未知的或不存在，则将此对象实例化为 null。
protected Object | output 由 setOutput 设置并由 getOutput 获取的 ImageOutputStream 或其他 Object。
protected List<IIOWriteProgressListener> | progressListeners 当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
protected List<IIOWriteWarningListener> | warningListeners 当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。
protected List<Locale> | warningLocales Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。
构造方法摘要
protected ImageWriter(ImageWriterSpi originatingProvider)
构造一个 ImageWriter，并将其 originatingProvider 实例变量设置为所提供的值。
方法摘要
void | abort() 请求中止任何当前写入操作。
protected boolean | abortRequested() 如果自从 writer 被实例化或 clearAbortRequest 被调用开始，已经发出中止当前写入操作的请求，则返回 true。
void | addIIOWriteProgressListener(IIOWriteProgressListener listener) 将 IIOWriteProgressListener 添加到已注册的进度侦听器列表中。
void | addIIOWriteWarningListener(IIOWriteWarningListener listener) 将 IIOWriteWarningListener 添加到已注册的警告侦听器的列表中。
boolean | canInsertEmpty(int imageIndex) 如果 writer 支持在给定索引处插入新的空图像，则返回 true。
boolean | canInsertImage(int imageIndex) 如果 writer 支持在给定索引处插入新图像，则返回 true。
boolean | canRemoveImage(int imageIndex) 如果 writer 支持在给定索引处移除现有图像，则返回 true。
boolean | canReplaceImageMetadata(int imageIndex) 如果有可能使用索引 imageIndex 替换与现有图像有关的图像元数据，则返回 true。
boolean | canReplacePixels(int imageIndex) 如果 writer 允许使用 replacePixels 方法替换给定图像的索引，则返回 true。
boolean | canReplaceStreamMetadata() 如果有可能替换已存在于输出中的流元数据，则返回 true。
boolean | canWriteEmpty() 如果 writer 支持写入由单个图像组成的完整图像流，则返回 true，这些对象带有要输出的不确定像素值、有关元数据和缩略图。
boolean | canWriteRasters() 如果采用 IIOImage 参数的方法能够处理 Raster（相对于 RenderedImage）源图像，则返回 true。
boolean | canWriteSequence() 如果 writer 能够将图像添加到已经包含头信息和可能的以前图像的图像流中，则返回 true。
protected void | clearAbortRequest() 清除任何以前的中止请求。
abstract IIOMetadata | convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
void | dispose() 允许释放此对象保存的所有资源。
void | endInsertEmpty() 完成对新图像的插入，该操作是从以前调用 prepareInsertEmpty 开始的。
void | endReplacePixels() 终止调用 replacePixels 的序列。
void | endWriteEmpty() 完成对新图像的写入，该操作是从优先调用 prepareWriteEmpty 开始的。
void | endWriteSequence() 完成以 prepareWriteSequence 开头的一系列图像的写入。
Locale[] | getAvailableLocales() 返回可用来初始化警告侦听器和压缩设置的 Locale 组成的数组。
abstract IIOMetadata | getDefaultImageMetadata(ImageTypeSpecifier imageType, ImageWriteParam param) 返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
abstract IIOMetadata | getDefaultStreamMetadata(ImageWriteParam param) 返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。
ImageWriteParam | getDefaultWriteParam() 返回适用于此文件格式的适当类型的新 ImageWriteParam 对象，该对象包含默认值，即那些将在没有指定 ImageWriteParam 对象时使用的值。
Locale | getLocale() 返回当前设置的 Locale，如果没有设置 Locale，则返回 null。
int | getNumThumbnailsSupported(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
ImageWriterSpi | getOriginatingProvider() 返回创建此 ImageWriter 的 ImageWriterSpi 对象，如果此对象不是通过 IIORegistry 创建的，则返回 null。
Object | getOutput() 返回 ImageOutputStream 或最近一次调用 setOutput 方法设置的其他 Object如果没有设置目标，则返回 null。
Dimension[] | getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
void | prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | prepareReplacePixels(int imageIndex, Rectangle region) 准备好 writer，处理一系列对 replacePixels 方法的调用。
void | prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | prepareWriteSequence(IIOMetadata streamMetadata) 使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。
protected void | processImageComplete() 通过调用 imageComplete 方法向所有已注册 IIOWriteProgressListener 广播图像写入的完成。
protected void | processImageProgress(float percentageDone) 通过调用 imageProgress 方法向所有已注册 IIOWriteProgressListener 广播图像完成的当前百分比。
protected void | processImageStarted(int imageIndex) 通过调用 imageStarted 方法向所有已注册 IIOWriteProgressListener 广播开始写入图像的起始处。
protected void | processThumbnailComplete() 通过调用 thumbnailComplete 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的完成。
protected void | processThumbnailProgress(float percentageDone) 通过调用 thumbnailProgress 方法向所有已注册 IIOWriteProgressListener 广播缩略图完成的当前百分比。
protected void | processThumbnailStarted(int imageIndex, int thumbnailIndex) 通过调用 thumbnailStarted 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的起始处。
protected void | processWarningOccurred(int imageIndex, String warning) 通过调用 warningOccurred 方法向所有已注册 IIOWriteWarningListener 广播一条警告消息。
protected void | processWarningOccurred(int imageIndex, String baseName, String keyword) 通过使用取自 ResourceBundle 的字符串调用 warningOccurred 方法来向所有已注册 IIOWriteWarningListener 广播一条本地化警告消息。
protected void | processWriteAborted() 通过调用 readAborted 方法向对所有已注册 IIOWriteProgressListener 广播写入已经中止。
void | removeAllIIOWriteProgressListeners() 移除所有当前已注册的 IIOWriteProgressListener 对象。
void | removeAllIIOWriteWarningListeners() 移除所有当前已注册的 IIOWriteWarningListener 对象。
void | removeIIOWriteProgressListener(IIOWriteProgressListener listener) 从已注册的进度侦听器列表中移除 IIOWriteProgressListener。
void | removeIIOWriteWarningListener(IIOWriteWarningListener listener) 从已注册的警告侦听器列表中移除 IIOWriteWarningListener。
void | removeImage(int imageIndex) 从流中移除图像。
void | replaceImageMetadata(int imageIndex, IIOMetadata imageMetadata) 替换与现有图像有关的图像元数据。
void | replacePixels(Raster raster, ImageWriteParam param) 用给定 Raster 部分替换已出现在输出中的图像部分。
void | replacePixels(RenderedImage image, ImageWriteParam param) 用给定图像部分替换已出现在输出中的图像部分。
void | replaceStreamMetadata(IIOMetadata streamMetadata) 使用新信息替换输出中的流元数据。
void | reset() 将 ImageWriter 恢复到其初始状态。
void | setLocale(Locale locale) 将此 ImageWriter 的当前 Locale 设置为给定值。
void | setOutput(Object output) 将目标设置为给定 ImageOutputStream 或其他 Object。
void | write(IIOImage image) 将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。
abstract void | write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
void | write(RenderedImage image) 将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。
void | writeInsert(int imageIndex, IIOImage image, ImageWriteParam param) 将新的图像插入现有图像流。
void | writeToSequence(IIOImage image, ImageWriteParam param) 将单幅图像、可能相关的元数据和缩略图添加到输出中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

originatingProvider

protected ImageWriterSpi originatingProvider
实例化此对象的 ImageWriterSpi，如果 ImageWriterSpi 的标识是未知的或不存在，则将此对象实例化为 null。默认情况下，将此对象实例化为 null。

output

protected Object output
由 setOutput 设置并由 getOutput 获取的 ImageOutputStream 或其他 Object。默认情况下，将此对象实例化为 null。

availableLocales

protected Locale[] availableLocales
可以用来本地化警告消息和压缩设置值的 Locale 组成的数组，如果本地化不受支持，则将它们初始化为 null。默认情况下，将它们初始化为 null。

locale

protected Locale locale
用于本地化的当前 Locale，如果没有设置 Locale，则将它初始化为 null。默认情况下，将 Locale 初始化为 null。

warningListeners

protected List<IIOWriteWarningListener> warningListeners
当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。

warningLocales

protected List<Locale> warningLocales
Locale 的 List，warningListeners 的每个元素都有一个 Locale 列表，默认情况下该列表被初始化为 null，它与空 List 同义。

progressListeners

protected List<IIOWriteProgressListener> progressListeners
当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。

构造方法详细信息

ImageWriter

protected ImageWriter(ImageWriterSpi originatingProvider)
构造一个 ImageWriter，并将其 originatingProvider 实例变量设置为所提供的值。

为了获取扩展对象，利用扩展的子类应该为构造方法提供签名 (ImageWriterSpi, Object)。如果扩展对象不合适，则将抛出 IllegalArgumentException。

参数：
originatingProvider - 构造此对象的 ImageWriterSpi，或者为 null。
方法详细信息

getOriginatingProvider

public ImageWriterSpi getOriginatingProvider()
返回创建此 ImageWriter 的 ImageWriterSpi 对象，如果此对象不是通过 IIORegistry 创建的，则返回 null。

默认的实现返回 originatingProvider 实例变量的值。

返回：
一个 ImageWriterSpi 或 null。
另请参见：
ImageWriterSpi

setOutput

public void setOutput(Object output)
将目标设置为给定 ImageOutputStream 或其他 Object。假定目标已准备接受数据，并将在结束每次写入时关闭。这允许受干扰的图像处理应用程序通过单独的网络连接传输一系列图像。如果 output 为 null，则将移除所有当前已设置的输出。

如果 output 是一个 ImageOutputStream，则调用 write、writeToSequence 和 prepareWriteEmpty/endWriteEmpty 方法将保留流的现有内容。其他写入方法，比如 writeInsert、replaceStreamMetadata、replaceImageMetadata、replacePixels、prepareInsertEmpty/endInsertEmpty 和 endWriteSequence，要求可读取和写入该流的全部内容，并且可以更改该流的任何部分。

对于直接与输出设备或图像协议交互的 writer，打算使用一般的 Object，而不是使用 ImageOutputStream。合法类集是由 writer 的服务提供者的 getOutputTypes 方法公开的。大多数 writer 将返回一个单个元素组成的数组，该数组只包含指示它们只接受 ImageOutputStream 的 ImageOutputStream.class。

在根据原始提供者（如果有）公开的类集合检查 output 之后，默认实现将 output 实例变量设置为 output 的值。

参数：
output - 用于以后的写入的 ImageOutputStream 或其他 Object。
抛出：
IllegalArgumentException - 如果 output 不是原始服务提供者的 getOutputTypes 方法返回的某个类的实例。
另请参见：
getOutput()

getOutput

public Object getOutput()
返回 ImageOutputStream 或最近一次调用 setOutput 方法设置的其他 Object如果没有设置目标，则返回 null。

默认实现返回 output 实例变量的值。

返回：
使用 setOutput 指定的 Object，或者返回 null。
另请参见：
setOutput(java.lang.Object)

getAvailableLocales

public Locale[] getAvailableLocales()
返回可用来初始化警告侦听器和压缩设置的 Locale 组成的数组。返回 null 值指示初始化不受支持。

如果 availableLocales 实例变量是非 null 的，则默认实现返回该变量的副本，否则返回 null。

返回：
可能用作 setLocale 的参数的 Locale 组成的数组，或者返回 null。

setLocale

public void setLocale(Locale locale)
将此 ImageWriter 的当前 Locale 设置为给定值。值为 null 则移除所有以前的设置，并指示 writer 应该根据需要对其进行初始化。

默认实现根据 getAvailableLocales 返回的值检查 locale，并设置 locale 实例变量（如果查找到的话）。如果 locale 为 null，则将该实例变量设置为 null，不必执行任何检查。

参数：
locale - 所需的 Locale，或者为 null。
抛出：
IllegalArgumentException - 如果 locale 为非 null，但它不是 getAvailableLocales 返回的值之一。
另请参见：
getLocale()

getLocale

public Locale getLocale()
返回当前设置的 Locale，如果没有设置 Locale，则返回 null。

默认实现返回 locale 实例变量的值。

返回：
当前 Locale 或 null。
另请参见：
setLocale(java.util.Locale)

getDefaultWriteParam

public ImageWriteParam getDefaultWriteParam()
返回适用于此文件格式的适当类型的新 ImageWriteParam 对象，该对象包含默认值，即那些将在没有指定 ImageWriteParam 对象时使用的值。将此作为只调整少数几个参数并不管默认设置的起点很有用。

默认设置构造并返回一个新的 ImageWriteParam 对象，该对象不允许平铺、逐步编码或压缩，并且将针对当前 Locale（即 通过调用 new ImageWriteParam(getLocale()) 获得的 Locale）对该对象进行本地化。

个别插件可能在启用额外可选特性的情况下返回 ImageWriteParam 的实例，或者它们可以返回 ImageWriteParam 的特定于插件的子类的实例。

返回：
包含默认值的新的 ImageWriteParam 对象。

getDefaultStreamMetadata

public abstract IIOMetadata getDefaultStreamMetadata(ImageWriteParam param)
返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。该对象的内容可以使用由 IIOMetadata.getAsTree 方法返回的 XML 树型结构（一个 IIOMetadataController 对象）来操作，或者通过特定于插件的接口以及提供给某一带有流元数据参数的 write 方法的所得数据来操作。

可以对可能影响流元数据结构的情况提供一个可选的 ImageWriteParam。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

不使用流元数据的 writer（例如 用于单一图像格式的 writer）应该返回 null。

参数：
param - 将用于对图像进行编码的 ImageWriteParam，或者为 null。
返回：
IIOMetadata 对象。

getDefaultImageMetadata

public abstract IIOMetadata getDefaultImageMetadata(ImageTypeSpecifier imageType,
                                                    ImageWriteParam param)
返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。该对象的内容可以使用由 IIOMetadata.getAsTree 方法返回的 XML 树型结构（一个 IIOMetadataController 对象）来操作，或者通过特定于插件的接口以及提供给某一带有流元数据参数的 write 方法的所得数据来操作。

可以对可能影响图像元数据结构的情况提供一个可选的 ImageWriteParam。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

参数：
imageType - 指示稍后将写入的图像格式的 ImageTypeSpecifier。
param - 将用于对图像进行编码的 ImageWriteParam，或者为 null。
返回：
IIOMetadata 对象。

convertStreamMetadata

public abstract IIOMetadata convertStreamMetadata(IIOMetadata inData,
                                                  ImageWriteParam param)
从接口 ImageTranscoder 复制的描述
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。

可以提供一个可选的 ImageWriteParam，用于其能影响流元数据的结构的情况。

如果所提供的 ImageWriteParam 包含可选的、不被此 writer 或 transcoder 理解的设置值，则忽略这些值。

指定者：
接口 ImageTranscoder 中的 convertStreamMetadata
参数：
inData - 表示流元数据的 IIOMetadata 对象，用于初始化所返回对象的状态。
param - 将用于对图像进行编码的 ImageWriteParam，或者为 null。
返回：
一个 IIOMetadata 对象，如果插件没有提供元数据编码功能，则返回 null。

convertImageMetadata

public abstract IIOMetadata convertImageMetadata(IIOMetadata inData,
                                                 ImageTypeSpecifier imageType,
                                                 ImageWriteParam param)
从接口 ImageTranscoder 复制的描述
返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。

可以提供一个可选的 ImageWriteParam，用于其能影响图像元数据的结构的情况。

如果所提供的 ImageWriteParam 包含可选的、不被此 writer 或 transcoder 理解的设置值，则忽略这些值。

指定者：
接口 ImageTranscoder 中的 convertImageMetadata
参数：
inData - 表示图像元数据的 IIOMetadata 对象，用于初始化所返回对象的状态。
imageType - 指示将与元数据关联的图像的布局和颜色信息的 ImageTypeSpecifier。
param - 将用于对图像进行编码的 ImageWriteParam，或者为 null。
返回：
一个 IIOMetadata 对象，如果插件没有提供元数据编码功能，则返回 null。

getNumThumbnailsSupported

public int getNumThumbnailsSupported(ImageTypeSpecifier imageType,
                                     ImageWriteParam param,
                                     IIOMetadata streamMetadata,
                                     IIOMetadata imageMetadata)
返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。返回 -1 值指示可用信息不足。

可以对可能影响缩略图处理的情况有选择地提供 ImageWriteParam。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

默认实现返回 0。

参数：
imageType - 指示将写入的图像类型的 ImageTypeSpecifier，或者该参数为 null。
param - 将用于写入操作的 ImageWriteParam，或者为 null。
streamMetadata - 将用于写入操作的 IIOMetadata 对象，或者为 null。
imageMetadata - 将用于写入操作的 IIOMetadata 对象，或者为 null。
返回：
可能在已知所提供参数的情况下写入的缩略图数，如果可用信息不足，则返回 -1。

getPreferredThumbnailSizes

public Dimension[] getPreferredThumbnailSizes(ImageTypeSpecifier imageType,
                                              ImageWriteParam param,
                                              IIOMetadata streamMetadata,
                                              IIOMetadata imageMetadata)
返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。此信息只是建议性的；writer 将根据需要重新调整所提供缩略图的大小。

信息是作为 pair 的集合返回的；pair 的第一个元素包含最小宽度和高度，第二个元素包含最大宽度和高度。同时，每个 pair 定义一个有效大小范围。要定义固定大小，将对两个元素显示相同的宽度和高度。返回值为 null 指示大小是任意的或未知的。

可以对可能影响缩略图处理的情况有选择地提供 ImageWriteParam。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

默认实现返回 null。

参数：
imageType - 指示将写入的图像类型的 ImageTypeSpecifier，或者该参数为 null。
param - 将用于写入操作的 ImageWriteParam，或者为 null。
streamMetadata - 将用于写入操作的 IIOMetadata 对象，或者为 null。
imageMetadata - 将用于写入操作的 IIOMetadata 对象，或者为 null。
返回：
平均长度至少为 2 的 Dimension 组成的数组，或者返回 null。

canWriteRasters

public boolean canWriteRasters()
如果采用 IIOImage 参数的方法能够处理 Raster（相对于 RenderedImage）源图像，则返回 true。如果此方法返回 false，则这些方法将在包含 Raster 的 IIOImage 中抛出一个 UnsupportedOperationException（如果提供）。

默认实现返回 false。

返回：
如果 Raster 源受支持，则返回 true。

write

public abstract void write(IIOMetadata streamMetadata,
                           IIOImage image,
                           ImageWriteParam param)
                    throws IOException
添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。还包括任何必要的头信息。如果输出是一个 ImageOutputStream，则位于当前寻找位置之前的现有内容不受影响，并且这些内容不必是可读或可写的。

必须使用 setOutput 方法提前设置输出。

流元数据可以有选择地提供；如果它为 null，则使用默认元数据。

如果 canWriteRasters 返回 true，则 IIOImage 可以包含一个 Raster 源。否则，它必须包含一个 RenderedImage 源。

所提供的缩略图将被重新调整大小（如果需要），并且超过所支持数量的所有缩略图都将被忽略。如果该格式需要没有提供的额外缩略图，则 writer 应该在内部生成这些缩略图。

可以有选择地提供 ImageWriteParam 来控制写入过程。如果 param 为 null，则将使用默认 write 参数。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

参数：
streamMetadata - 表示流元数据的 IIOMetadata 对象，或者为 null，表示使用默认值。
image - 包含要写入的图像、缩略图和元数据的 IIOImage 对象。
param - 一个 ImageWriteParam，或者为 null，表示使用默认 ImageWriteParam。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 image 包含一个 Raster，并且 canWriteRasters 返回 false。
IllegalArgumentException - 如果 image 为 null。
IOException - 如果在写入过程中发生错误。

write

public void write(IIOImage image)
           throws IOException
将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。此方法是 write(null, image, null) 的简略表达方式。

参数：
image - 包含要写入的图像、缩略图和元数据的 IIOImage 对象。
抛出：
IllegalStateException - 如果尚未设置输出。
IllegalArgumentException - 如果 image 为 null。
UnsupportedOperationException - 如果 image 包含一个 Raster，并且 canWriteRasters 返回 false。
IOException - 如果在写入过程中发生错误。

write

public void write(RenderedImage image)
           throws IOException
将由带有默认元数据和缩略图的单个图像组成的完整图像流添加到输出中。此方法是 write(null, new IIOImage(image, null, null), null) 的简略表达方式。

参数：
image - 要写入的 RenderedImage。
抛出：
IllegalStateException - 如果尚未设置输出。
IllegalArgumentException - 如果 image 为 null。
IOException - 如果在写入过程中发生错误。

canWriteSequence

public boolean canWriteSequence()
如果 writer 能够将图像添加到已经包含头信息和可能的以前图像的图像流中，则返回 true。

如果 canWriteSequence 返回 false，writeToSequence 和 endWriteSequence 将抛出 UnsupportedOperationException。

默认实现返回 false。

返回：
如果可以按顺序添加图像，则返回 true。

prepareWriteSequence

public void prepareWriteSequence(IIOMetadata streamMetadata)
                          throws IOException
使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。如果应该先于图像数据，则应该将元数据写入流中。如果该参数为 null，则使用默认流元数据。

如果输出是一个 ImageOutputStream，则不刷新位于当前寻找位置之前的输出的现有内容，并且这些内容不必是可读或可写的。如果该格式要求 endWriteSequence 能够重新修补头信息，比如用于单个 TIFF 文件中的一系列图像的头信息，则此方法写入的元数据必须仍然位于流的可写部分中。其他格式可以在此方法之后和每幅图像之后刷新流。

如果 canWriteSequence 返回 false，则此方法将抛出 UnsupportedOperationException。

必须使用 setOutput 方法提前设置输出。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
streamMetadata - 一个流元数据对象，或者为 null。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canWriteSequence 返回 false。
IOException - 如果在写入流元数据过程中发生错误。

writeToSequence

public void writeToSequence(IIOImage image,
                            ImageWriteParam param)
                     throws IOException
将单幅图像、可能相关的元数据和缩略图添加到输出中。如果输出是 ImageOutputStream，则可能刷新当前寻找位置之前的输出的现有内容，并且这些内容不必是可读的或可写的，除非插件必须能够在调用 endWriteSequence 时修补头信息（例如 TIFF）。

如果 canWriteSequence 返回 false，则此方法将抛出 UnsupportedOperationException。

必须使用 setOutput 方法提前设置输出。

prepareWriteSequence 必须提前调用，否则将抛出 IllegalStateException。

如果 canWriteRasters 返回 true，则 IIOImage 可以包含一个 Raster 源。否则，它必须包含一个 RenderedImage 源。

所提供的缩略图将被重新调整大小（如果需要），并且超过所支持数量的所有缩略图都将被忽略。如果该格式需要没有提供的其他缩略图，则 writer 将在内部生成这些缩略图。

可以有选择地提供 ImageWriteParam 来控制写入过程。如果 param 为 null，则将使用默认 write 参数。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
image - 包含要写入的图像、缩略图和元数据的 IIOImage 对象。
param - 一个 ImageWriteParam；或者为 null，表示使用默认 ImageWriteParam。
抛出：
IllegalStateException - 如果没有设置输出，或者没有调用 prepareWriteSequence。
UnsupportedOperationException - 如果 canWriteSequence 返回 false。
IllegalArgumentException - 如果 image 为 null。
UnsupportedOperationException - 如果 image 包含一个 Raster，并且 canWriteRasters 返回 false。
IOException - 如果写入过程中发生错误。

endWriteSequence

public void endWriteSequence()
                      throws IOException
完成以 prepareWriteSequence 开头的一系列图像的写入。应该出现在这一系列图像的末尾的所有流元数据都被写出，如果需要，可修补位于该序列的开始处的任何头信息。如果输出是 ImageOutputStream，则一直到序列末尾处的流元数据的那些数据将被刷新，它们不必是可读的或可写的。

如果 canWriteSequence 返回 false，则此方法将抛出 UnsupportedOperationException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

抛出：
IllegalStateException - 如果没有设置输出，或者没有调用 prepareWriteSequence。
UnsupportedOperationException - 如果 canWriteSequence 返回 false。
IOException - 如果在写入过程中发生错误。

canReplaceStreamMetadata

public boolean canReplaceStreamMetadata()
                                 throws IOException
如果有可能替换已存在于输出中的流元数据，则返回 true。

如果输出为 null，则默认实现抛出 IllegalStateException，否则返回 false。

返回：
如果允许替换流元数据，则返回 true。
抛出：
IllegalStateException - 如果尚未设置输出。
IOException - 如果在查询期间发生 I/O 错误。

replaceStreamMetadata

public void replaceStreamMetadata(IIOMetadata streamMetadata)
                           throws IOException
使用新信息替换输出中的流元数据。如果输出为 ImageOutputStream，则检查该流以前的内容，并且可能对它们进行编辑，为新的数据腾出空间。该输出以前的所有内容必须可用于读取和写入。

如果 canReplaceStreamMetadata 返回 false，则将抛出 UnsupportedOperationException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
streamMetadata - 表示流元数据的 IIOMetadata 对象；或者为 null，表示使用默认值。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canReplaceStreamMetadata 返回 false。模式不包括在内
IOException - 如果写入期间发生错误。

canReplaceImageMetadata

public boolean canReplaceImageMetadata(int imageIndex)
                                throws IOException
如果有可能使用索引 imageIndex 替换与现有图像有关的图像元数据，则返回 true。如果此方法返回 false，那么调用 replaceImageMetadata(imageIndex) 将抛出 UnsupportedOperationException。

不支持任何图像元数据替换的 writer 可以返回 false，而不必对索引执行范围检查。

如果输出为 null，则默认实现抛出 IllegalStateException，否则返回 false，而不必检查 imageIndex 的值。

参数：
imageIndex - 其元数据将被替换的图像的索引。
返回：
如果可以替换给定图像的图像元数据，则返回 true。
抛出：
IllegalStateException - 如果尚未设置输出。
IndexOutOfBoundsException - 如果 writer 在一般情况下支持图像元数据替换，但 imageIndex 小于 0 或大于最大可用索引。
IOException - 如果在查询期间发生 I/O 错误。

replaceImageMetadata

public void replaceImageMetadata(int imageIndex,
                                 IIOMetadata imageMetadata)
                          throws IOException
替换与现有图像有关的图像元数据。

如果 canReplaceImageMetadata(imageIndex) 返回 false，则将抛出 UnsupportedOperationException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
imageIndex - 其元数据将被替换的图像的索引。
imageMetadata - 表示图像元数据的 IIOMetadata 对象，或者为 null。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canReplaceImageMetadata 返回 false。
IndexOutOfBoundsException - 如果 imageIndex 小于 0 或大于最大可用索引。
IOException - 如果在写入过程中发生错误。

canInsertImage

public boolean canInsertImage(int imageIndex)
                       throws IOException
如果 writer 支持在给定索引处插入新图像，则返回 true。索引等于或大于插入索引的现有图像会将其索引加 1。值为 -1 的 imageIndex 可用于表示大于当前最大索引的索引。

不支持任何图像插入的 writer 可以返回 false，而不必对索引执行范围检查。

如果输出为 null，则默认实现抛出 IllegalStateException，否则返回 false，而不必检查 imageIndex 的值。

参数：
imageIndex - 将在其所在位置处插入图像的索引。
返回：
如果可以在给定索引处插入图像，则返回 true。
抛出：
IllegalStateException - 如果尚未设置输出。
IndexOutOfBoundsException - 如果 writer 在一般情况下支持图像插入，但 imageIndex 小于 -1 或大于最大可用索引。
IOException - 如果在查询期间发生 I/O 错误。

writeInsert

public void writeInsert(int imageIndex,
                        IIOImage image,
                        ImageWriteParam param)
                 throws IOException
将新的图像插入现有图像流。索引大于 imageIndex 的现有图像被保留，其索引均被加 1。为 -1 的 imageIndex 值可用于表示大于以前最大索引的索引；也就是说，它将导致图像按逻辑添加到序列的末尾。如果输出是一个 ImageOutputStream，则整个流都必须是可读并且可写的。

如果 canInsertImage(imageIndex) 返回 false，则将抛出 UnsupportedOperationException。

可以有选择地提供 ImageWriteParam 来控制写入过程。如果 param 为 null，则将使用默认 write 参数。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
imageIndex - 将在其所在位置处写入图像的索引。
image - 包含要写入的图像、缩略图和元数据的 IIOImage 对象。
param - 一个 ImageWriteParam，或者为 null，表示使用默认 ImageWriteParam。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canInsertImage(imageIndex) 返回 false。
IllegalArgumentException - 如果 image 为 null。
IndexOutOfBoundsException - 如果 imageIndex 小于 -1 或大于最大可用索引。
UnsupportedOperationException - 如果 image 包含一个 Raster，并且 canWriteRasters 返回 false。
IOException - 如果在写入过程中发生错误。

canRemoveImage

public boolean canRemoveImage(int imageIndex)
                       throws IOException
如果 writer 支持在给定索引处移除现有图像，则返回 true。对于索引大于插入索引的图像，其索引将增加 1。

不支持任何图像移除的 writer 可以返回 false，而不必对索引执行范围检查。

如果输出为 null，则默认实现抛出 IllegalStateException，否则返回 false，而不必检查 imageIndex 的值。

参数：
imageIndex - 要移除的图像的索引。
返回：
如果能够移除给定图像，则返回 true。
抛出：
IllegalStateException - 如果尚未设置输出。
IndexOutOfBoundsException - 如果 writer 在一般情况下支持图像移除，但 imageIndex 小于 0 或大于最大可用索引。
IOException - 如果在查询期间发生 I/O 错误。

removeImage

public void removeImage(int imageIndex)
                 throws IOException
从流中移除图像。

如果 canRemoveImage(imageIndex) 返回 false，则将抛出 UnsupportedOperationException。

移除可能导致实际文件大小减小，也可能不会。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
imageIndex - 要移除的图像的索引。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canRemoveImage(imageIndex) 返回 false。
IndexOutOfBoundsException - 如果 imageIndex 小于 0 或大于最大可用索引。
IOException - 如果在移除期间发生 I/O 错误。

canWriteEmpty

public boolean canWriteEmpty()
                      throws IOException
如果 writer 支持写入由单个图像组成的完整图像流，则返回 true，这些对象带有要输出的不确定像素值、有关元数据和缩略图。像素值可通过以后调用 replacePixels 方法来确定。如果输出是一个 ImageOutputStream，则位于当前寻找位置之前的现有内容不受影响，并且这些内容不必是可读或可写的。

如果输出为 null，则默认实现抛出 IllegalStateException，否则返回 false。

返回：
如果写入内容以后再定义的完整图像流是受支持的，则返回 true。
抛出：
IllegalStateException - 如果尚未设置输出。
IOException - 如果在查询期间发生 I/O 错误。

prepareWriteEmpty

public void prepareWriteEmpty(IIOMetadata streamMetadata,
                              ImageTypeSpecifier imageType,
                              int width,
                              int height,
                              IIOMetadata imageMetadata,
                              List<? extends BufferedImage> thumbnails,
                              ImageWriteParam param)
                       throws IOException
从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。像素值可通过以后调用 replacePixels 方法来确定。如果输出是一个 ImageOutputStream，则位于当前寻找位置之前的现有内容不受影响，并且这些内容不必是可读或可写的。

直到调用 endWriteEmpty 才完成写入操作。调用 prepareReplacePixels、replacePixels 和 endReplacePixels 可能发生在调用 prepareWriteEmpty 和 endWriteEmpty 之间。不过，调用 prepareWriteEmpty 是不可嵌套的，调用 prepareWriteEmpty 和 prepareInsertEmpty 不能被散置。

如果 canWriteEmpty 返回 false，则将抛出 UnsupportedOperationException。

可以有选择地提供 ImageWriteParam 来控制写入过程。如果 param 为 null，则将使用默认 write 参数。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
streamMetadata - 表示流元数据的 IIOMetadata 对象；或者为 null，表示使用默认值。
imageType - 描述图像布局的 ImageTypeSpecifier。
width - 图像的宽度。
height - 图像的高度。
imageMetadata - 表示图像元数据的 IIOMetadata 对象，或者为 null。
thumbnails - 此图像的 BufferedImage 缩略图的 List，或者为 null。
param - 一个 ImageWriteParam，或者为 null，表示使用默认 ImageWriteParam。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canWriteEmpty 返回 false。
IllegalStateException - 如果以前已经调用 prepareWriteEmpty，但没有相应地调用 endWriteEmpty。
IllegalStateException - 如果以前已经调用 prepareInsertEmpty，但没有相应地调用 endInsertEmpty。
IllegalArgumentException - 如果 imageType 为 null，或者 thumbnails 包含 null 引用或对象，而不是 BufferedImage。
IllegalArgumentException - 如果宽度或高度小于 1。
IOException - 如果在写期间发生 I/O 错误。

endWriteEmpty

public void endWriteEmpty()
                   throws IOException
完成对新图像的写入，该操作是从优先调用 prepareWriteEmpty 开始的。

如果 canWriteEmpty() 返回 false，则将抛出 UnsupportedOperationException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canWriteEmpty(imageIndex) 返回 false。
IllegalStateException - 如果以前已经调用 prepareWriteEmpty，但没有相应地调用 endWriteEmpty。
IllegalStateException - 如果以前已经调用 prepareInsertEmpty，但没有相应地调用 endInsertEmpty。
IllegalStateException - 如果以前已经调用 prepareReiplacePixels，但没有相应地调用 endReplacePixels。
IOException - 如果在写入期间发生 I/O 错误。

canInsertEmpty

public boolean canInsertEmpty(int imageIndex)
                       throws IOException
如果 writer 支持在给定索引处插入新的空图像，则返回 true。图像的像素值是不确定的，并且可以使用 replacePixels 方法各个部分地指定它们。索引等于或大于插入索引的现有图像会将其索引加 1。值为 -1 的 imageIndex 可用于表示大于当前最大索引的索引。

不支持插入空图像的 writer 可以返回 false，而不必对索引执行范围检查。

如果输出为 null，则默认实现抛出 IllegalStateException，否则返回 false，而不必检查 imageIndex 的值。

参数：
imageIndex - 将在其所在位置处插入图像的索引。
返回：
如果可以在给定索引处插入空图像，则返回 true。
抛出：
IllegalStateException - 如果尚未设置输出。
IndexOutOfBoundsException - 如果 writer 在一般情况下支持插入空图像，但 imageIndex 小于 -1 或大于最大可用索引。
IOException - 如果在查询期间发生 I/O 错误。

prepareInsertEmpty

public void prepareInsertEmpty(int imageIndex,
                               ImageTypeSpecifier imageType,
                               int width,
                               int height,
                               IIOMetadata imageMetadata,
                               List<? extends BufferedImage> thumbnails,
                               ImageWriteParam param)
                        throws IOException
从将带有不确定像素值的新图像插入现有图像流中开始。索引大于 imageIndex 的现有图像被保留，其索引均被加 1。为 -1 的 imageIndex 值可用于表示大于以前最大索引的索引；也就是说，它将导致图像按逻辑添加到序列的末尾。如果输出是一个 ImageOutputStream，则整个流都必须是可读并且可写的。

图像内容可由稍后使用的 replacePixels 方法提供。直到调用 endInsertEmpty 才完成插入操作。调用 prepareReplacePixels、replacePixels 和 endReplacePixels 可能发生在调用 prepareInsertEmpty 和 endInsertEmpty 之间。不过，调用 prepareInsertEmpty 是不可嵌套的，调用 prepareWriteEmpty 和 prepareInsertEmpty 不能被散置。

如果 canInsertEmpty(imageIndex) 返回 false，则将抛出 UnsupportedOperationException。

可以有选择地提供 ImageWriteParam 来控制写入过程。如果 param 为 null，则将使用默认 write 参数。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
imageIndex - 将在其所在位置处写入图像的索引。
imageType - 描述图像布局的 ImageTypeSpecifier。
width - 图像的宽度。
height - 图像的高度。
imageMetadata - 表示图像元数据的 IIOMetadata 对象，或者为 null。
thumbnails - 此图像的 BufferedImage 缩略图的 List，或者为 null。
param - 一个 ImageWriteParam，或者为 null，表示使用默认 ImageWriteParam。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canInsertEmpty(imageIndex) 返回 false。
IndexOutOfBoundsException - 如果 imageIndex 小于 -1 或大于最大可用索引。
IllegalStateException - 如果以前已经调用 prepareInsertEmpty，但没有相应地调用 endInsertEmpty。
IllegalStateException - 如果以前已经调用 prepareWriteEmpty，但没有相应地调用 endWriteEmpty。
IllegalArgumentException - 如果 imageType 为 null，或者 thumbnails 包含 null 引用或对象，而不是 BufferedImage。
IllegalArgumentException - 如果宽度或高度小于 1。
IOException - 如果在写期间发生 I/O 错误。

endInsertEmpty

public void endInsertEmpty()
                    throws IOException
完成对新图像的插入，该操作是从以前调用 prepareInsertEmpty 开始的。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canInsertEmpty(imageIndex) 返回 false。
IllegalStateException - 如果以前已经调用 prepareInsertEmpty，但没有相应地调用 endInsertEmpty。
IllegalStateException - 如果以前已经调用 prepareWriteEmpty，但没有相应地调用 endWriteEmpty。
IllegalStateException - 如果以前已经调用 prepareReplacePixels，但没有相应地调用 endReplacePixels。
IOException - 如果在写入期间发生 I/O 错误。

canReplacePixels

public boolean canReplacePixels(int imageIndex)
                         throws IOException
如果 writer 允许使用 replacePixels 方法替换给定图像的索引，则返回 true。

不支持任何像素替换的 writer 可以返回 false，而不必对索引执行范围检查。

如果输出为 null，则默认实现抛出 IllegalStateException，否则返回 false，而不必检查 imageIndex 的值。

参数：
imageIndex - 其像素将被替换的图像的索引。
返回：
如果可以替换给定图像的像素，则返回 true。
抛出：
IllegalStateException - 如果尚未设置输出。
IndexOutOfBoundsException - 如果 writer 在一般情况下支持像素替换，但 imageIndex 小于 0 或大于最大可用索引。
IOException - 如果在查询期间发生 I/O 错误。

prepareReplacePixels

public void prepareReplacePixels(int imageIndex,
                                 Rectangle region)
                          throws IOException
准备好 writer，处理一系列对 replacePixels 方法的调用。将根据所提供的数据来剪切受影响的像素区域。

如果 canReplacePixels 返回 false，则将抛出 UnsupportedOperationException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
imageIndex - 其像素将被替换的图像的索引。
region - 将用来剪切将来的像素区域的 Rectangle。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canReplacePixels(imageIndex) 返回 false。
IndexOutOfBoundsException - 如果 imageIndex 小于 0 或大于最大可用索引。
IllegalStateException - 如果以前调用了 prepareReplacePixels 但没有相应地调用 endReplacePixels（也就是说 不允许进行嵌套）。
IllegalArgumentException - 如果 region 为 null 或者宽度或高度小于 1。
IOException - 如果在准备期间发生 I/O 错误。

replacePixels

public void replacePixels(RenderedImage image,
                          ImageWriteParam param)
                   throws IOException
用给定图像部分替换已出现在输出中的图像部分。图像数据必须匹配，或者可转化为现有图像布局。

目标区域是在 param 参数中指定的，并且将被剪切成图像边界和提供给 prepareReplacePixels 的区域。至少有一个源像素不能剪切，否则抛出一个异常。

可以有选择地提供 ImageWriteParam 来控制写入过程。如果 param 为 null，则将使用默认 write 参数。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

此方法只能在调用 prepareReplacePixels 之后调用，否则将抛出 IllegalStateException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
image - 一个包含源像素的 RenderedImage。
param - 一个 ImageWriteParam，或者为 null，表示使用默认 ImageWriteParam。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canReplacePixels(imageIndex) 返回 false。
IllegalStateException - 如果在以前调用 prepareReplacePixels 时没有相应地调用 endReplacePixels。
IllegalArgumentException - 如果以下任意一项为 true：
  • image 为 null。
  • param 为 null。
  • 相交区域并没有包含至少一个像素。
  • image 的布局与现有图像布局不匹配，或者此 writer 无法将它转换成现有图像布局。
IOException - 如果在写入期间发生 I/O 错误。

replacePixels

public void replacePixels(Raster raster,
                          ImageWriteParam param)
                   throws IOException
用给定 Raster 部分替换已出现在输出中的图像部分。图像数据必须匹配，或者可转化为现有图像布局。

可以有选择地提供 ImageWriteParam 来控制写入过程。如果 param 为 null，则将使用默认 write 参数。

目标区域是在 param 参数中指定的，并且将被剪切成图像边界和提供给 prepareReplacePixels 的区域。至少有一个源像素不能剪切，否则抛出一个异常。

如果所提供的 ImageWriteParam 包含不受此 writer 支持的可选设置值（例如 逐步编码或任何特定于格式的设置），则将忽略这些设置。

此方法只能在调用 prepareReplacePixels 之后调用，否则将抛出 IllegalStateException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

参数：
raster - 一个包含源像素的 Raster。
param - 一个 ImageWriteParam，或者为 null，表示使用默认 ImageWriteParam。
抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canReplacePixels(imageIndex) 返回 false。
IllegalStateException - 如果在以前调用 prepareReplacePixels 时没有相应地调用 endReplacePixels。
UnsupportedOperationException - 如果 canWriteRasters 返回 false。
IllegalArgumentException - 如果以下任意一项为 true：
  • raster 为 null。
  • param 为 null。
  • 相交区域并没有包含至少一个像素。
  • raster 的布局与现有图像布局不匹配，或者此 writer 无法将它转换成现有图像布局。
IOException - 如果在写入期间发生 I/O 错误。

endReplacePixels

public void endReplacePixels()
                      throws IOException
终止调用 replacePixels 的序列。

如果 canReplacePixels 返回 false，则将抛出 UnsupportedOperationException。

如果输出为 null，则默认实现抛出 IllegalStateException，否则抛出 UnsupportedOperationException。

抛出：
IllegalStateException - 如果尚未设置输出。
UnsupportedOperationException - 如果 canReplacePixels(imageIndex) 返回 false。
IllegalStateException - 如果在以前调用 prepareReplacePixels 时没有相应地调用 endReplacePixels。
IOException - 如果在写入期间发生 I/O 错误。

abort

public void abort()
请求中止任何当前写入操作。将中止的输出的内容是不确定的。

weader 应该在开始每个写入操作时调用 clearAbortRequest，并在写入期间定期轮询 abortRequested 的值。

abortRequested

protected boolean abortRequested()
如果自从 writer 被实例化或 clearAbortRequest 被调用开始，已经发出中止当前写入操作的请求，则返回 true。

返回：
如果应该中止当前写入操作，则返回 true。
另请参见：
abort(), clearAbortRequest()

clearAbortRequest

protected void clearAbortRequest()
清除任何以前的中止请求。在已调用此方法之后，abortRequested 将返回 false。

另请参见：
abort(), abortRequested()

addIIOWriteWarningListener

public void addIIOWriteWarningListener(IIOWriteWarningListener listener)
将 IIOWriteWarningListener 添加到已注册的警告侦听器的列表中。如果 listener 为 null，则不会抛出异常并且不执行操作。发送到给定侦听器的消息将被初始化，如果有可能，会将该消息与当前 Locale 匹配。如果没有设置 Locale，则可将警告消息初始化为 writer 认为合适的形式。

参数：
listener - 要注册的 IIOWriteWarningListener。
另请参见：
removeIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener)

removeIIOWriteWarningListener

public void removeIIOWriteWarningListener(IIOWriteWarningListener listener)
从已注册的警告侦听器列表中移除 IIOWriteWarningListener。如果以前没有注册侦听器，或者 listener 为 null，则不会抛出异常并且不执行操作。

参数：
listener - 要取消注册的 IIOWriteWarningListener。
另请参见：
addIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener)

removeAllIIOWriteWarningListeners

public void removeAllIIOWriteWarningListeners()
移除所有当前已注册的 IIOWriteWarningListener 对象。

默认实现将 warningListeners 和 warningLocales 实例变量设置为 null。

addIIOWriteProgressListener

public void addIIOWriteProgressListener(IIOWriteProgressListener listener)
将 IIOWriteProgressListener 添加到已注册的进度侦听器列表中。如果 listener 为 null，则不会抛出异常并且不执行操作。

参数：
listener - 要注册的 IIOWriteProgressListener。
另请参见：
removeIIOWriteProgressListener(javax.imageio.event.IIOWriteProgressListener)

removeIIOWriteProgressListener

public void removeIIOWriteProgressListener(IIOWriteProgressListener listener)
从已注册的进度侦听器列表中移除 IIOWriteProgressListener。如果以前没有注册侦听器，或者 listener 为 null，则不会抛出异常并且不执行操作。

参数：
listener - 要取消注册的 IIOWriteProgressListener。
另请参见：
addIIOWriteProgressListener(javax.imageio.event.IIOWriteProgressListener)

removeAllIIOWriteProgressListeners

public void removeAllIIOWriteProgressListeners()
移除所有当前已注册的 IIOWriteProgressListener 对象。

默认实现将 progressListeners 实例变量设置为 null。

processImageStarted

protected void processImageStarted(int imageIndex)
通过调用 imageStarted 方法向所有已注册 IIOWriteProgressListener 广播开始写入图像的起始处。子类可以将此方法用作一个便捷方法。

参数：
imageIndex - 即将写入的图像的索引。

processImageProgress

protected void processImageProgress(float percentageDone)
通过调用 imageProgress 方法向所有已注册 IIOWriteProgressListener 广播图像完成的当前百分比。子类可以将此方法用作一个便捷方法。

参数：
percentageDone - float 值形式的当前完整的百分比。

processImageComplete

protected void processImageComplete()
通过调用 imageComplete 方法向所有已注册 IIOWriteProgressListener 广播图像写入的完成。子类可以将此方法用作一个便捷方法。

processThumbnailStarted

protected void processThumbnailStarted(int imageIndex,
                                       int thumbnailIndex)
通过调用 thumbnailStarted 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的起始处。子类可以将此方法用作一个便捷方法。

参数：
imageIndex - 与该缩略图有关的图像的索引。
thumbnailIndex - 缩略图的索引。

processThumbnailProgress

protected void processThumbnailProgress(float percentageDone)
通过调用 thumbnailProgress 方法向所有已注册 IIOWriteProgressListener 广播缩略图完成的当前百分比。子类可以将此方法用作一个便捷方法。

参数：
percentageDone - float 值形式的当前完整的百分比。

processThumbnailComplete

protected void processThumbnailComplete()
通过调用 thumbnailComplete 方法向所有已注册 IIOWriteProgressListener 广播缩略图写入的完成。子类可以将此方法用作一个便捷方法。

processWriteAborted

protected void processWriteAborted()
通过调用 readAborted 方法向对所有已注册 IIOWriteProgressListener 广播写入已经中止。子类可以将此方法用作一个便捷方法。

processWarningOccurred

protected void processWarningOccurred(int imageIndex,
                                      String warning)
通过调用 warningOccurred 方法向所有已注册 IIOWriteWarningListener 广播一条警告消息。子类可以将此方法用作一个便捷方法。

参数：
imageIndex - 与发生的警告有关的图像的索引。
warning - 警告消息。
抛出：
IllegalArgumentException - 如果 warning 为 null。

processWarningOccurred

protected void processWarningOccurred(int imageIndex,
                                      String baseName,
                                      String keyword)
通过使用取自 ResourceBundle 的字符串调用 warningOccurred 方法来向所有已注册 IIOWriteWarningListener 广播一条本地化警告消息。子类可以将此方法用作一个便捷方法。

参数：
imageIndex - 与发生的警告有关的图像的索引。
baseName - 一组包含本地化警告消息的 ResourceBundle 的基本名称。
keyword - 用来为 ResourceBundle 集合中的警告消息建立索引的关键字。
抛出：
IllegalArgumentException - 如果 baseName 为 null。
IllegalArgumentException - 如果 keyword 为 null。
IllegalArgumentException - 如果无法找到合适的 ResourceBundle。
IllegalArgumentException - 如果在定位的 ResourceBundle 中无法找到指定的资源。
IllegalArgumentException - 如果从 ResourceBundle 中获取的对象不是一个 String。

reset

public void reset()
将 ImageWriter 恢复到其初始状态。

默认实现调用 setOutput(null)、setLocale(null)、removeAllIIOWriteWarningListeners()、removeAllIIOWriteProgressListeners() 和 clearAbortRequest。

dispose

public void dispose()
允许释放此对象保存的所有资源。调用其他任何方法（而不是 finalize）以及对此方法的后续调用的结果都是不确定的。

对应用程序而言，在知道它们不再使用此 ImageWriter 时，调用此方法非常重要。否则，writer 可能继续无限期地保存这些资源。

在超类中，此方法的默认实现不执行任何操作。子类实现应该确保所有资源（特别是本机资源）被释放。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.imageio (Java 2 Platform SE 6)

 javax.imageio
接口
IIOParamController
ImageTranscoder
类
IIOImage
IIOParam
ImageIO
ImageReader
ImageReadParam
ImageTypeSpecifier
ImageWriteParam
ImageWriter
异常
IIOException


javax.imageio (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.imageio

Java Image I/O API 的主要包。

请参见：
描述

接口摘要
IIOParamController | 该接口将由可以确定 IIOParam 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
ImageTranscoder | 提供元数据代码转换功能的接口。

类摘要
IIOImage | 一个聚集图像、缩略（预览）图像集和表示与图像关联的元数据的对象的简单容器类。
IIOParam | 所有描述应该如何对流进行编码和解码的类的超类。
ImageIO | 该类包含一些用来查找 ImageReader 和 ImageWriter 以及执行简单编码和解码的静态便捷方法。
ImageReader | 用来解析和解码图像的抽象超类。
ImageReadParam | 描述如何对流进行解码的类。
ImageTypeSpecifier | 允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。
ImageWriteParam | 描述如何对流进行编码的类。
ImageWriter | 用来编码和写入图像的抽象超类。

异常摘要
IIOException 该异常类用于发出关于读取和写入操作的运行时故障的信号。

软件包 javax.imageio 的描述

Java Image I/O API 的主要包。

使用 ImageIO 类的静态方法可以执行许多常见的图像 I/O 操作。

此包包含一些基本类和接口，有的用来描述图像文件内容（包括元数据和缩略图）(IIOImage)；有的用来控制图像读取过程（ImageReader、ImageReadParam 和 ImageTypeSpecifier）和图像写入过程（ImageWriter 和 ImageWriteParam）；还有的用来执行格式之间的代码转换 (ImageTranscoder) 和报告错误 (IIOException)。

javax.imageio 的所有实现都提供以下标准图像格式插件：

 | 读取 | 写入 | 注意事项 | 元数据
JPEG | 是 | 是 | 无 | JPEG 元数据格式
PNG | 是 | 是 | 无 | PNG 元数据格式
BMP | 是 | 是 | 无 | BMP 元数据格式
WBMP | 是 | 是 | 无 | WBMP 元数据格式
GIF | 是 | 是 | GIF 插件注意事项 | GIF 元数据格式

标准插件注意事项

GIF 图像格式的标准插件

ImageIO 为图形交换格式 (GIF) 图像格式提供 ImageReader 和 ImageWriter 插件。 这些是“标准”GIF 插件（意味着 JRE 中包含的插件与标准扩展中包含的插件不同）或是第三方插件。下列注意事项和元数据规范适用于标准插件。

写入 GIF 图像

GIF 图像 writer 插件保证满足以下要求的图像能无损失地写入：
  • band 数是 1；
  • 每个采样的位数不大于 8；
  • 颜色分量的大小不大于 8。

默认情况下，GIF writer 插件创建 "89a" 版本的图像。这可以更改为 "87a"，将该版本在流元数据中显式设置即可（请参阅 GIF 流元数据格式规范）。

GIF writer 插件通过写入 ImageWriter 类中定义方法的标准序列，可支持创建动画 GIF 图像。

如果满足以下条件之一，全局颜色表将被写入输出流：

  • 提供包含 GlobalColorTable 元素的流元数据；
  • 序列正被写入，并且为序列中第一个图像提供包含 LocalColorTable 元素的图像元数据；
  • 没有提供图像元数据或者图像元数据不包含 LocalColorTable 元素。

在第一种情况下，使用流元数据中的全局颜色表，在第二种情况下，使用图像元数据中的局部颜色表，在第三种情况下，根据 ColorModel 或（第一个）图像的 SampleModel 创建全局颜色表。

只有将包含 LocalColorTable 元素的图像元数据提供给 writer，或者没有图像元数据提供给 writer 并且根据其图像本身生成的局部颜色表不等于全局颜色表时，局部颜色表才写入输出流。

只有将包含 GraphicControlExtension 元素的图像元数据提供给 writer，或者不提供图像元数据并且根据图像生成的局部颜色表要求透明索引时，图形控制扩展 (Graphic Control Extension) 块才写入输出流。应用程序 (Application)、纯文本 (Plain Text) 和注释扩展 (Comment Extension) 块只有通过图像元数据提供给 writer 时才写入。

交错图像的写入可通过提供的 ImageWriteParam 实例的逐步模式控制。如果逐步模式是 MODE_DISABLED，则写入非交错图像。如果逐步模式是 MODE_DEFAULT，则写入交错图像。如果逐步模式是 MODE_COPY_FROM_METADATA，则使用元数据设置（如果提供了元数据设置，否则写入交错图像）。

GIF 图像 writer 插件支持根据提供给本机 GIF 流元数据格式 javax_imageio_gif_stream_1.0 或标准元数据格式 javax_imageio_1.0 中 writer 的元数据设置输出流元数据，还支持根据提供给本机 GIF 图像元数据格式 javax_imageio_gif_image_1.0 或标准元数据格式 javax_imageio_1.0 中 writer 的元数据设置输出图像元数据。 标准元数据格式到 GIF 本机流以及图像元数据格式的映射在此表中给出。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.imageio 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.imageio.IIOImage
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
      • javax.imageio.ImageWriteParam
    • javax.imageio.ImageIO
    • javax.imageio.ImageReader
    • javax.imageio.ImageTypeSpecifier
    • javax.imageio.ImageWriter (implements javax.imageio.ImageTranscoder)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.imageio.IIOException

接口分层结构

  • javax.imageio.IIOParamController
  • javax.imageio.ImageTranscoder
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.imageio 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio
的使用

使用 javax.imageio 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 使用的 javax.imageio 中的类
IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。
IIOImage
一个聚集图像、缩略（预览）图像集和表示与图像关联的元数据的对象的简单容器类。
IIOParam
所有描述应该如何对流进行编码和解码的类的超类。
IIOParamController
该接口将由可以确定 IIOParam 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
ImageReader
用来解析和解码图像的抽象超类。
ImageReadParam
描述如何对流进行解码的类。
ImageTranscoder
提供元数据代码转换功能的接口。
ImageTypeSpecifier
允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。
ImageWriteParam
描述如何对流进行编码的类。
ImageWriter
用来编码和写入图像的抽象超类。

javax.imageio.event 使用的 javax.imageio 中的类
ImageReader
用来解析和解码图像的抽象超类。
ImageWriter
用来编码和写入图像的抽象超类。

javax.imageio.metadata 使用的 javax.imageio 中的类
IIOException
该异常类用于发出关于读取和写入操作的运行时故障的信号。
ImageTypeSpecifier
允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。

javax.imageio.plugins.bmp 使用的 javax.imageio 中的类
IIOParam
所有描述应该如何对流进行编码和解码的类的超类。
ImageWriteParam
描述如何对流进行编码的类。

javax.imageio.plugins.jpeg 使用的 javax.imageio 中的类
IIOParam
所有描述应该如何对流进行编码和解码的类的超类。
ImageReadParam
描述如何对流进行解码的类。
ImageWriteParam
描述如何对流进行编码的类。

javax.imageio.spi 使用的 javax.imageio 中的类
ImageReader
用来解析和解码图像的抽象超类。
ImageTranscoder
提供元数据代码转换功能的接口。
ImageTypeSpecifier
允许以便捷方式指定图像格式（尤其是其 SampleModel 和 ColorModel）的类。
ImageWriter
用来编码和写入图像的抽象超类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


IIOReadProgressListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.event
接口 IIOReadProgressListener

所有超级接口：
EventListener
public interface IIOReadProgressListener
extends EventListener

供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关进度的接口。

此接口接收解码进度的通用指示（通过 imageProgress 和 thumbnailProgress 方法）和指示何时整个图像已经更新的事件（通过 imageStarted、imageComplete、thumbnailStarted 和 thumbnailComplete 方法）。希望在像素更新发生时得到通知的应用程序（例如，在逐步解码过程中）应该提供 IIOReadUpdateListener。

另请参见：
IIOReadUpdateListener, ImageReader.addIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener), ImageReader.removeIIOReadProgressListener(javax.imageio.event.IIOReadProgressListener)

方法摘要
void | imageComplete(ImageReader source) 报告当前图像读操作已经完成。
void | imageProgress(ImageReader source, float percentageDone) 报告对关联 ImageReader 的 read 当前调用的近似完成程度。
void | imageStarted(ImageReader source, int imageIndex) 报告图像读操作将要开始。
void | readAborted(ImageReader source) 报告已通过 reader 的 abort 方法中止读操作。
void | sequenceComplete(ImageReader source) 报告读操作序列已经完成。
void | sequenceStarted(ImageReader source, int minIndex) 报告读操作序列将要开始。
void | thumbnailComplete(ImageReader source) 报告缩略图读操作已经完成。
void | thumbnailProgress(ImageReader source, float percentageDone) 报告在关联的 ImageReader 中完成当前 getThumbnail 调用的近似程度。
void | thumbnailStarted(ImageReader source, int imageIndex, int thumbnailIndex) 报告缩略图读操作将要开始。

方法详细信息

sequenceStarted

void sequenceStarted(ImageReader source,
                     int minIndex)
报告读操作序列将要开始。ImageReader 实现需要从其 readAll(Iterator) 方法仅调用此方法一次。

参数：
source - 调用此方法的 ImageReader 对象。
minIndex - 要读取的第一个图像的索引。

sequenceComplete

void sequenceComplete(ImageReader source)
报告读操作序列已经完成。ImageReader 实现需要从其 readAll(Iterator) 方法仅调用此方法一次。

参数：
source - 调用此方法的 ImageReader 对象。

imageStarted

void imageStarted(ImageReader source,
                  int imageIndex)
报告图像读操作将要开始。所有 ImageReader 实现均需在开始图像读操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageReader 对象。
imageIndex - 图像的索引，该图像将从包含其的输入文件或流中读取。

imageProgress

void imageProgress(ImageReader source,
                   float percentageDone)
报告对关联 ImageReader 的 read 当前调用的近似完成程度。

完成程度以百分比表示，变动范围从 0.0F 到 100.0F。在理想情况下，应该按照完成的剩余时间来计算百分比，但使用定义更加明确的度量标准（如解码的像素或输入流的消耗部分）往往更为实际。无论如何，在给定读操作过程中调用此方法的序列都应该提供一个百分比值的单调渐增序列。没有必要提供确切值 0 和 100，因为来自其他方法的被调用者可以推导出这些值。

每个特定 ImageReader 实现可以用所需的任何频率调用此方法。单凭经验的方法是每 5 个百分点调用该方法一次。

参数：
source - 调用此方法的 ImageReader 对象。
percentageDone - 已经完成的解码的近似百分比。

imageComplete

void imageComplete(ImageReader source)
报告当前图像读操作已经完成。所有 ImageReader 实现均需在完成每个图像读操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageReader 对象。

thumbnailStarted

void thumbnailStarted(ImageReader source,
                      int imageIndex,
                      int thumbnailIndex)
报告缩略图读操作将要开始。所有 ImageReader 实现均需在开始缩略图读操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageReader 对象。
imageIndex - 图像的索引，该图像将从包含其的输入文件或流中读取。
thumbnailIndex - 要读取的缩略图的索引。

thumbnailProgress

void thumbnailProgress(ImageReader source,
                       float percentageDone)
报告在关联的 ImageReader 中完成当前 getThumbnail 调用的近似程度。该语义与 imageProgress 中的相同。

参数：
source - 调用此方法的 ImageReader 对象。
percentageDone - 已经完成的解码的近似百分比。

thumbnailComplete

void thumbnailComplete(ImageReader source)
报告缩略图读操作已经完成。所有 ImageReader 实现均需在完成每个缩略图读操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageReader 对象。

readAborted

void readAborted(ImageReader source)
报告已通过 reader 的 abort 方法中止读操作。没有给出进一步的通知。

参数：
source - 调用此方法的 ImageReader 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IIOReadUpdateListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.event
接口 IIOReadUpdateListener

所有超级接口：
EventListener
public interface IIOReadUpdateListener
extends EventListener

供 ImageReader 实现用于通知其图像和缩略图的调用者相关像素更新的接口。

另请参见：
ImageReader.addIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener), ImageReader.removeIIOReadUpdateListener(javax.imageio.event.IIOReadUpdateListener)

方法摘要
void | imageUpdate(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新图像的给定区域。
void | passComplete(ImageReader source, BufferedImage theImage) 报告当前读操作已经完成一个逐步传递。
void | passStarted(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的读操作将开始逐步传递 (progressive pass)。
void | thumbnailPassComplete(ImageReader source, BufferedImage theThumbnail) 报告当前缩略图读操作已经完成一个逐步传递。
void | thumbnailPassStarted(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的缩略图读操作将开始逐步传递。
void | thumbnailUpdate(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新缩略图图像的给定区域。

方法详细信息

passStarted

void passStarted(ImageReader source,
                 BufferedImage theImage,
                 int pass,
                 int minPass,
                 int maxPass,
                 int minX,
                 int minY,
                 int periodX,
                 int periodY,
                 int[] bands)
报告当前的读操作将开始逐步传递 (progressive pass)。读取支持逐步编码的图像时，支持逐步编码的格式 Reader 应该在完成每个传递时使用此方法通知客户端。

minX、minY、width 和 height 参数指示对将通过传递更新的区域的估计。如果传递交错进行，即仅更新所选行或列，则 periodX 和 periodY 参数将指示二次抽样的进行程度。bands 的值指示可能受影响的 band 集合。

参数：
source - 调用此方法的 ImageReader 对象。
theImage - 将被更新的 BufferedImage。
pass - 将要开始的传递的编号（从 0 开始）。
minPass - 将要解码的第一个传递的索引。
maxPass - 将要解码的最后一个传递的索引。
minX - 最左边的更新像素列的 X 坐标。
minY - 最上边的更新像素行的 Y 坐标。
periodX - 更新像素之间的水平间隔；值 1 表示没有间距。
periodY - 更新像素之间的垂直间隔；值 1 表示没有间距。
bands - 指示可能更新的 band 集合的 int 数组。

imageUpdate

void imageUpdate(ImageReader source,
                 BufferedImage theImage,
                 int minX,
                 int minY,
                 int width,
                 int height,
                 int periodX,
                 int periodY,
                 int[] bands)
报告已更新图像的给定区域。应用程序可能选择重新显示指定区域，例如，为了提供逐步显示效果或执行其他增量处理。

注意，不同的图像格式 reader 可能产生以多种不同顺序排列的解码像素。多数 reader 将生成以简单的从上到下、从左到右顺序排列的像素，而另一此则可能使用交错、平铺等多种传递。例如，调用时更新顺序甚至会由于网络速度的不同而相同。调用此方法并不能保证所有指定的像素都已经实际被更新，只保证在指定像素的某个子区域发生了更新。

特定的 ImageReader 实现可以选择提供更新的频率。每次更新都指定自上次更新以来已经更新了图像的给定区域。区域由其空间边界框（minX、minY、width 和 height）、X 和 Y 子二次抽样因子（periodX 和 periodY）以及更新的 band 集合（bands）来描述。例如，更新：

 minX = 10
 minY = 20
 width = 3
 height = 4
 periodX = 2
 periodY = 3
 bands = { 1, 3 }
指示以下像素的 band 1 和 band 3 已更新：
 (10, 20) (12, 20) (14, 20)
 (10, 23) (12, 23) (14, 23)
 (10, 26) (12, 26) (14, 26)
 (10, 29) (12, 29) (14, 29)

参数：
source - 调用此方法的 ImageReader 对象。
theImage - 将被更新的 BufferedImage。
minX - 最左边的更新像素列的 X 坐标。
minY - 最上边的更新像素行的 Y 坐标。
width - 水平更新的像素数。
height - 垂直更新的像素数。
periodX - 更新像素之间的水平间隔；值 1 表示没有间距。
periodY - 更新像素之间的垂直间隔；值 1 表示没有间距。
bands - 指示要更新的 band 的 int 数组。

passComplete

void passComplete(ImageReader source,
                  BufferedImage theImage)
报告当前读操作已经完成一个逐步传递。读取逐步编码的图像时，支持逐步编码格式的 Reader 应该在完成每个传递时使用此方法通知客户端。

参数：
source - 调用此方法的 ImageReader 对象。
theImage - 将被更新的 BufferedImage。
另请参见：
ImageReadParam.setSourceProgressivePasses(int, int)

thumbnailPassStarted

void thumbnailPassStarted(ImageReader source,
                          BufferedImage theThumbnail,
                          int pass,
                          int minPass,
                          int maxPass,
                          int minX,
                          int minY,
                          int periodX,
                          int periodY,
                          int[] bands)
报告当前的缩略图读操作将开始逐步传递。读取逐步编码的缩略图像时，支持逐步编码格式的 Reader 应该在完成每个传递时使用此方法通知客户端。

参数：
source - 调用此方法的 ImageReader 对象。
theThumbnail - 将被更新的 BufferedImage 缩略图。
pass - 将要开始的传递的编号（从 0 开始）。
minPass - 将要解码的第一个传递的索引。
maxPass - 将要解码的最后一个传递的索引。
minX - 最左边的更新像素列的 X 坐标。
minY - 最上边的更新像素行的 Y 坐标。
periodX - 更新像素之间的水平间隔；值 1 表示没有间距。
periodY - 更新像素之间的垂直间隔；值 1 表示没有间距。
bands - 指示可能更新的 band 集合的 int 数组。
另请参见：
passStarted(javax.imageio.ImageReader, java.awt.image.BufferedImage, int, int, int, int, int, int, int, int[])

thumbnailUpdate

void thumbnailUpdate(ImageReader source,
                     BufferedImage theThumbnail,
                     int minX,
                     int minY,
                     int width,
                     int height,
                     int periodX,
                     int periodY,
                     int[] bands)
报告已更新缩略图图像的给定区域。应用程序可能选择重新显示指定区域，例如，为了提供逐步显示效果或执行其他增量处理。

参数：
source - 调用此方法的 ImageReader 对象。
theThumbnail - 将被更新的 BufferedImage 缩略图。
minX - 最左边的更新像素列的 X 坐标。
minY - 最上边的更新像素行的 Y 坐标。
width - 水平更新的像素数。
height - 垂直更新的像素数。
periodX - 更新像素之间的水平间隔；值 1 表示没有间距。
periodY - 更新像素之间的垂直间隔；值 1 表示没有间距。
bands - 指示要更新的 band 的 int 数组。
另请参见：
imageUpdate(javax.imageio.ImageReader, java.awt.image.BufferedImage, int, int, int, int, int, int, int[])

thumbnailPassComplete

void thumbnailPassComplete(ImageReader source,
                           BufferedImage theThumbnail)
报告当前缩略图读操作已经完成一个逐步传递。读取逐步编码的缩略图像时，具有支持逐步编码格式的 Reader 应该在完成每个传递时使用此方法通知客户端。

参数：
source - 调用此方法的 ImageReader 对象。
theThumbnail - 将被更新的 BufferedImage 缩略图。
另请参见：
passComplete(javax.imageio.ImageReader, java.awt.image.BufferedImage)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOReadWarningListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.event
接口 IIOReadWarningListener

所有超级接口：
EventListener
public interface IIOReadWarningListener
extends EventListener

供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。严重错误导致相关读取方法抛出 IIOException。

本地化的处理方法是，在 ImageReader 中注册每个 IIOReadWarningListener 时，将 Locale 与之关联。ImageReader 负责提供本地化的消息。

另请参见：
ImageReader.addIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener), ImageReader.removeIIOReadWarningListener(javax.imageio.event.IIOReadWarningListener)

方法摘要
 void warningOccurred(ImageReader source, String warning)
报告在解码中发生非严重错误。

方法详细信息

warningOccurred

void warningOccurred(ImageReader source,
                     String warning)
报告在解码中发生非严重错误。解码过程将继续调用此方法。应用程序可以选择显示对话框、将警告打印到控制台、忽略警告或者采取它选择的任何其他措施。

参数：
source - 调用此方法的 ImageReader 对象。
warning - 包含警告的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOWriteProgressListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.event
接口 IIOWriteProgressListener

所有超级接口：
EventListener
public interface IIOWriteProgressListener
extends EventListener

供 ImageWriter 实现用于通知其图像和缩略图写入方法的调用者相关进度的方法。

另请参见：
ImageWriter.write(javax.imageio.metadata.IIOMetadata, javax.imageio.IIOImage, javax.imageio.ImageWriteParam)

方法摘要
void | imageComplete(ImageWriter source) 报告图像写操作已经完成。
void | imageProgress(ImageWriter source, float percentageDone) 报告在关联的 ImageWriter 中完成当前 write 调用的近似程度。
void | imageStarted(ImageWriter source, int imageIndex) 报告图像写操作将要开始。
void | thumbnailComplete(ImageWriter source) 报告缩略图写操作已经完成。
void | thumbnailProgress(ImageWriter source, float percentageDone) 报告在关联的 ImageWriter 中完成当前缩略图写操作的近似程度。
void | thumbnailStarted(ImageWriter source, int imageIndex, int thumbnailIndex) 报告缩略图写操作将要开始。
void | writeAborted(ImageWriter source) 报告已通过 writer 的 abort 方法中止写操作。

方法详细信息

imageStarted

void imageStarted(ImageWriter source,
                  int imageIndex)
报告图像写操作将要开始。所有 ImageWriter 实现均需在开始图像写操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageWriter 对象。
imageIndex - 图像的索引，该图像将写入包含其的输入文件或流。

imageProgress

void imageProgress(ImageWriter source,
                   float percentageDone)
报告在关联的 ImageWriter 中完成当前 write 调用的近似程度。

完成程度以指示要写入的图像的索引以及指示已输出当前图像量的百分比（变动范围从 0.0F 到 100.0F）表示。在理想情况下，应该按照完成的剩余时间来计算百分比，但使用定义更加明确的度量标准（如解码的像素或输入流的消耗部分）往往更为实际。无论如何，在给定读操作过程中调用此方法的序列都应该提供一个百分比值的单调渐增序列。没有必要提供确切值 0 和 100，因为来自其他方法的被调用者可以推导出这些值。

每个特定 ImageWriter 实现可以用所需的任何频率调用此方法。单凭经验的方法是每 5 个百分点调用该方法一次。

参数：
source - 调用此方法的 ImageWriter 对象。
percentageDone - 已经完成的解码的近似百分比。

imageComplete

void imageComplete(ImageWriter source)
报告图像写操作已经完成。所有 ImageWriter 实现均需在完成每个图像写操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageWriter 对象。

thumbnailStarted

void thumbnailStarted(ImageWriter source,
                      int imageIndex,
                      int thumbnailIndex)
报告缩略图写操作将要开始。所有 ImageWriter 实现均需在开始缩略图写操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageWrite 对象。
imageIndex - 图像的索引，该图像将写入包含其的输入文件或流。
thumbnailIndex - 要写入的缩略图的索引。

thumbnailProgress

void thumbnailProgress(ImageWriter source,
                       float percentageDone)
报告在关联的 ImageWriter 中完成当前缩略图写操作的近似程度。该语义与 imageProgress 中的相同。

参数：
source - 调用此方法的 ImageWriter 对象。
percentageDone - 已经完成的解码的近似百分比。

thumbnailComplete

void thumbnailComplete(ImageWriter source)
报告缩略图写操作已经完成。所有 ImageWriter 实现均需在完成每个缩略图写操作时仅调用此方法一次。

参数：
source - 调用此方法的 ImageWriter 对象。

writeAborted

void writeAborted(ImageWriter source)
报告已通过 writer 的 abort 方法中止写操作。没有给出进一步的通知。

参数：
source - 调用此方法的 ImageWriter 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOWriteWarningListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.event
接口 IIOWriteWarningListener

所有超级接口：
EventListener
public interface IIOWriteWarningListener
extends EventListener

供 ImageWriter 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。严重错误导致相关读取方法抛出 IIOException。

本地化的处理方法是，在 ImageWriter 中注册每个 IIOWriteWarningListener 时，将 Locale 与之关联。ImageWriter 负责提供本地化的消息。

另请参见：
ImageWriter.addIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener), ImageWriter.removeIIOWriteWarningListener(javax.imageio.event.IIOWriteWarningListener)

方法摘要
 void warningOccurred(ImageWriter source, int imageIndex, String warning)
报告在编码中发生非严重错误。

方法详细信息

warningOccurred

void warningOccurred(ImageWriter source,
                     int imageIndex,
                     String warning)
报告在编码中发生非严重错误。编码过程将继续调用此方法。应用程序可以选择显示对话框、将警告打印到控制台、忽略警告或者采取它选择的任何其他措施。

参数：
source - 调用此方法的 ImageWriter 对象。
imageIndex - 生成警告的图像的索引（从 0 开始）。
warning - 包含警告的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.imageio.event (Java 2 Platform SE 6)

 javax.imageio.event
接口
IIOReadProgressListener
IIOReadUpdateListener
IIOReadWarningListener
IIOWriteProgressListener
IIOWriteWarningListener


javax.imageio.event (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.imageio.event

Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。

请参见：
描述

接口摘要
IIOReadProgressListener | 供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关进度的接口。
IIOReadUpdateListener | 供 ImageReader 实现用于通知其图像和缩略图的调用者相关像素更新的接口。
IIOReadWarningListener | 供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
IIOWriteProgressListener | 供 ImageWriter 实现用于通知其图像和缩略图写入方法的调用者相关进度的方法。
IIOWriteWarningListener | 供 ImageWriter 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。

软件包 javax.imageio.event 的描述

Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。

IIOReadProgressListener 接口允许通知已成功读取图像的百分比。

IIOReadUpdateListener 接口允许通知已读取的图像部分。此接口很有用，例如，在加载图像时用于实现图像的动态显示。

IIOReadWarningListener 接口允许通知读取过程中的非严重错误。

IIOWriteWarningListener 和 IIOWriteProgressListener 接口实现与 writer 类似的功能。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.imageio.event 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.event 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • java.util.EventListener
    • javax.imageio.event.IIOReadProgressListener
    • javax.imageio.event.IIOReadUpdateListener
    • javax.imageio.event.IIOReadWarningListener
    • javax.imageio.event.IIOWriteProgressListener
    • javax.imageio.event.IIOWriteWarningListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.imageio.event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.event
的使用

使用 javax.imageio.event 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 使用的 javax.imageio.event 中的类
IIOReadProgressListener
供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关进度的接口。
IIOReadUpdateListener
供 ImageReader 实现用于通知其图像和缩略图的调用者相关像素更新的接口。
IIOReadWarningListener
供 ImageReader 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。
IIOWriteProgressListener
供 ImageWriter 实现用于通知其图像和缩略图写入方法的调用者相关进度的方法。
IIOWriteWarningListener
供 ImageWriter 实现用于通知其图像和缩略图读取方法的调用者相关警告（非严重错误）的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.event.IIOReadProgressListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOReadProgressListener
的使用

使用 IIOReadProgressListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOReadProgressListener 的使用

类型参数类型为 IIOReadProgressListener 的 javax.imageio 中的字段
protected  List<IIOReadProgressListener> ImageReader.progressListeners
当前已注册 IIOReadProgressListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

参数类型为 IIOReadProgressListener 的 javax.imageio 中的方法
void | ImageReader.addIIOReadProgressListener(IIOReadProgressListener listener) 将 IIOReadProgressListener 添加到已注册的进度侦听器列表中。
void | ImageReader.removeIIOReadProgressListener(IIOReadProgressListener listener) 从已注册的进度侦听器列表中移除 IIOReadProgressListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.event.IIOReadUpdateListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOReadUpdateListener
的使用

使用 IIOReadUpdateListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOReadUpdateListener 的使用

类型参数类型为 IIOReadUpdateListener 的 javax.imageio 中的字段
protected  List<IIOReadUpdateListener> ImageReader.updateListeners
当前已注册 IIOReadUpdateListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

参数类型为 IIOReadUpdateListener 的 javax.imageio 中的方法
void | ImageReader.addIIOReadUpdateListener(IIOReadUpdateListener listener) 将 IIOReadUpdateListener 添加到已注册的更新侦听器列表中。
void | ImageReader.removeIIOReadUpdateListener(IIOReadUpdateListener listener) 从已注册的更新侦听器列表中移除 IIOReadUpdateListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.event.IIOReadWarningListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOReadWarningListener
的使用

使用 IIOReadWarningListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOReadWarningListener 的使用

类型参数类型为 IIOReadWarningListener 的 javax.imageio 中的字段
protected  List<IIOReadWarningListener> ImageReader.warningListeners
当前已注册 IIOReadWarningListener 组成的 List，默认情况下初始化为 null，它与空 List 同义。

参数类型为 IIOReadWarningListener 的 javax.imageio 中的方法
void | ImageReader.addIIOReadWarningListener(IIOReadWarningListener listener) 将 IIOReadWarningListener 添加到已注册的警告侦听器的列表中。
void | ImageReader.removeIIOReadWarningListener(IIOReadWarningListener listener) 从已注册的错误侦听器列表中移除 IIOReadWarningListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.event.IIOWriteProgressListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOWriteProgressListener
的使用

使用 IIOWriteProgressListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOWriteProgressListener 的使用

类型参数类型为 IIOWriteProgressListener 的 javax.imageio 中的字段
protected  List<IIOWriteProgressListener> ImageWriter.progressListeners
当前已注册 IIOWriteProgressListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。

参数类型为 IIOWriteProgressListener 的 javax.imageio 中的方法
void | ImageWriter.addIIOWriteProgressListener(IIOWriteProgressListener listener) 将 IIOWriteProgressListener 添加到已注册的进度侦听器列表中。
void | ImageWriter.removeIIOWriteProgressListener(IIOWriteProgressListener listener) 从已注册的进度侦听器列表中移除 IIOWriteProgressListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.event.IIOWriteWarningListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.event.IIOWriteWarningListener
的使用

使用 IIOWriteWarningListener 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOWriteWarningListener 的使用

类型参数类型为 IIOWriteWarningListener 的 javax.imageio 中的字段
protected  List<IIOWriteWarningListener> ImageWriter.warningListeners
当前已注册 IIOWriteWarningListener 的 List，默认情况下将它初始化为 null，它与空 List 同义。

参数类型为 IIOWriteWarningListener 的 javax.imageio 中的方法
void | ImageWriter.addIIOWriteWarningListener(IIOWriteWarningListener listener) 将 IIOWriteWarningListener 添加到已注册的警告侦听器的列表中。
void | ImageWriter.removeIIOWriteWarningListener(IIOWriteWarningListener listener) 从已注册的警告侦听器列表中移除 IIOWriteWarningListener。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


IIOInvalidTreeException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.metadata
类 IIOInvalidTreeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.imageio.IIOException
                    继承者  javax.imageio.metadata.IIOInvalidTreeException
所有已实现的接口：
Serializable
public class IIOInvalidTreeException
extends IIOException

当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。导致解析错误的节点可能被存储起来。与任何解析错误一样，实际错误发生点可能不同于检测到的错误发生点。getOffendingNode 返回的节点只能视为问题实质的线索。

另请参见：
IIOMetadata.setFromTree(java.lang.String, org.w3c.dom.Node), IIOMetadata.mergeTree(java.lang.String, org.w3c.dom.Node), IIOMetadataNode, 序列化表格

字段摘要
protected  Node offendingNode
导致解析错误的 Node，或 null。
构造方法摘要
IIOInvalidTreeException(String message, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。
IIOInvalidTreeException(String message, Throwable cause, Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。
方法摘要
 Node getOffendingNode()
返回导致解析错误的 Node。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

offendingNode

protected Node offendingNode
导致解析错误的 Node，或 null。

构造方法详细信息

IIOInvalidTreeException

public IIOInvalidTreeException(String message,
                               Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串和对导致解析错误的 Node 的引用。

参数：
message - 包含解析错误的原因的 String。
offendingNode - 导致异常的 DOM Node，或 null。

IIOInvalidTreeException

public IIOInvalidTreeException(String message,
                               Throwable cause,
                               Node offendingNode)
构造一个 IIOInvalidTreeException，使其具有消息字符串、对导致此异常的异常的引用和导致解析错误的 Node 的引用。

参数：
message - 包含解析错误的原因的 String。
cause - 导致发生此异常的 Throwable（Error 或 Exception），或 null。
offendingNode - 导致异常的 DOM Node，或 null。
方法详细信息

getOffendingNode

public Node getOffendingNode()
返回导致解析错误的 Node。

返回：
损坏的 Node。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IIOMetadata (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.metadata
类 IIOMetadata

java.lang.Object
    继承者  javax.imageio.metadata.IIOMetadata

public abstract class IIOMetadata
extends Object

将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。插件表示使用不透明、特定于插件的对象的元数据。但是这些对象提供以 IIOMetadataNode 对象的树的形式访问其内部信息的能力，IIOMetadataNode 对象支持 XML DOM 接口以及用于存储非文本数据和获取关于合法数据值的信息的其他接口。这种树的格式是依赖于插件的，但插件可以选择支持下述插件无关的格式。单个插件可能支持多个元数据格式，这些格式的名称可以通过调用 getMetadataFormatNames 确定。插件还可支持单个特殊格式（叫做“本机”格式），设计用于无损耗地编码其元数据。通常，此格式专门设计用于与特定文件格式一起使用，以便以同一种格式加载和保存图像而不丢失元数据，但是对于在不同图像格式的 ImageReader 和 ImageWriter 之间传输元数据没有多大用途。要像图像文件格式所允许的那样无损耗地在两个本机格式之间转换元数据，必须使用 ImageTranscoder 对象。

另请参见：
ImageReader.getImageMetadata(int),
ImageReader.getStreamMetadata(),
ImageReader.readAll(int, javax.imageio.ImageReadParam),
ImageWriter.getDefaultStreamMetadata(javax.imageio.ImageWriteParam),
ImageWriter.getDefaultImageMetadata(javax.imageio.ImageTypeSpecifier, javax.imageio.ImageWriteParam),
ImageWriter.write(javax.imageio.metadata.IIOMetadata, javax.imageio.IIOImage, javax.imageio.ImageWriteParam),
ImageWriter.convertImageMetadata(javax.imageio.metadata.IIOMetadata, javax.imageio.ImageTypeSpecifier, javax.imageio.ImageWriteParam),
ImageWriter.convertStreamMetadata(javax.imageio.metadata.IIOMetadata, javax.imageio.ImageWriteParam),
IIOImage,
ImageTranscoder

字段摘要
protected IIOMetadataController | controller 调用 activateController 方法时，将用来为此 IIOMetadataController 对象提供设置值的 IIOParamController。
protected IIOMetadataController | defaultController 建议用作此 IIOMetadata 对象的控制器的 IIOMetadataController。
protected String[] | extraMetadataFormatClassNames 实现 IIOMetadataFormat 和表示此插件支持的元数据格式（标准格式和本机格式除外）的类的名称所组成的数组，初始化为 null，通过构造方法设置。
protected String[] | extraMetadataFormatNames 此插件支持的格式（标准格式和本机格式除外）的名称所组成的数组，初始化为 null，通过构造方法设置。
protected String | nativeMetadataFormatClassName 实现 IIOMetadataFormat 和表示本机元数据格式的类的名称，初始化为 null，通过构造方法设置。
protected String | nativeMetadataFormatName 此对象本机元数据格式的名称，初始化为 null，通过构造方法设置。
protected boolean | standardFormatSupported 指示具体子类是否支持标准元数据格式的 boolean 值，通过构造方法设置。
构造方法摘要
protected | IIOMetadata() 构造一个空的 IIOMetadata 对象。
protected | IIOMetadata(boolean standardMetadataFormatSupported, String nativeMetadataFormatName, String nativeMetadataFormatClassName, String[] extraMetadataFormatNames, String[] extraMetadataFormatClassNames) 构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。
方法摘要
boolean | activateController() 激活为此 IIOMetadata 对象安装的 IIOMetadataController，并返回所得到的值。
abstract Node | getAsTree(String formatName) 返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。
IIOMetadataController | getController() 返回当前已安装的所有 IIOMetadataController。
IIOMetadataController | getDefaultController() 返回默认 IIOMetadataController（如果有），不考虑当前安装的控制器。
String[] | getExtraMetadataFormatNames() 返回一个 String 数组，包含此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的其他元数据格式（本机格式和标准格式除外）的名称。
IIOMetadataFormat | getMetadataFormat(String formatName) 返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
String[] | getMetadataFormatNames() 返回一个 String 数组，包含包括此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的所有元数据格式（包括本机格式和标准格式）的名称。
String | getNativeMetadataFormatName() 返回此插件的“本机”元数据格式的名称，该格式通常允许无损失地编码和传输以此插件处理的格式存储的元数据。
protected IIOMetadataNode | getStandardChromaNode() 返回表示标准 javax_imageio_1.0 元数据格式的色度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardCompressionNode() 返回表示标准 javax_imageio_1.0 元数据格式的压缩信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardDataNode() 返回表示标准 javax_imageio_1.0 元数据格式的数据格式信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardDimensionNode() 返回表示标准 javax_imageio_1.0 元数据格式的维度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardDocumentNode() 返回表示标准 javax_imageio_1.0 元数据格式的文档信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardTextNode() 返回表示标准 javax_imageio_1.0 元数据格式的文本信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardTileNode() 返回表示标准 javax_imageio_1.0 元数据格式的平铺信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardTransparencyNode() 返回表示标准 javax_imageio_1.0 元数据格式的透明度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | getStandardTree() 返回表示此对象中所包含元数据的 IIOMetadataNode 的树（根据标准 javax_imageio_1.0 元数据格式的约定）的实用方法。
boolean | hasController() 如果存在为此 IIOMetadata 对象安装的控制器，则返回 true。
abstract boolean | isReadOnly() 如果此对象不支持 mergeTree、setFromTree 和 reset 方法，则返回 true。
boolean | isStandardMetadataFormatSupported() 如果 getMetadataFormat、getAsTree、setFromTree 和 mergeTree 支持标准元数据格式，则返回 true。
abstract void | mergeTree(String formatName, Node root) 根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。
abstract void | reset() 将此对象中存储的所有数据重置为默认值，通常为此对象构造后立即处于的状态，尽管精确的语义是特定于插件的。
void | setController(IIOMetadataController controller) 设置在调用 activateController 方法时用来为此 IIOParam 对象提供设置值的 IIOMetadataController，重写任何默认控制器。
void | setFromTree(String formatName, Node root) 根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

standardFormatSupported

protected boolean standardFormatSupported
指示具体子类是否支持标准元数据格式的 boolean 值，通过构造方法设置。

nativeMetadataFormatName

protected String nativeMetadataFormatName
此对象本机元数据格式的名称，初始化为 null，通过构造方法设置。

nativeMetadataFormatClassName

protected String nativeMetadataFormatClassName
实现 IIOMetadataFormat 和表示本机元数据格式的类的名称，初始化为 null，通过构造方法设置。

extraMetadataFormatNames

protected String[] extraMetadataFormatNames
此插件支持的格式（标准格式和本机格式除外）的名称所组成的数组，初始化为 null，通过构造方法设置。

extraMetadataFormatClassNames

protected String[] extraMetadataFormatClassNames
实现 IIOMetadataFormat 和表示此插件支持的元数据格式（标准格式和本机格式除外）的类的名称所组成的数组，初始化为 null，通过构造方法设置。

defaultController

protected IIOMetadataController defaultController
建议用作此 IIOMetadata 对象的控制器的 IIOMetadataController。它可以通过 getDefaultController 获取。要安装默认控制器，请调用 setController(getDefaultController())。此实例变量应该由子类设置，这些子类可以选择提供自己的默认控制器（通常是一个 GUI）来设置参数。

另请参见：
IIOMetadataController, getDefaultController()

controller

protected IIOMetadataController controller
调用 activateController 方法时，将用来为此 IIOMetadataController 对象提供设置值的 IIOParamController。此值重写任何默认控制器，即使为 null 时也是如此。

另请参见：
IIOMetadataController, setController(IIOMetadataController), hasController(), activateController()
构造方法详细信息

IIOMetadata

protected IIOMetadata()
构造一个空的 IIOMetadata 对象。子类负责为所有受保护的实例变量提供值，这将使方法的未重写默认实现符合其协定。例如，extraMetadataFormatNames 的长度不应为 0。

IIOMetadata

protected IIOMetadata(boolean standardMetadataFormatSupported,
                      String nativeMetadataFormatName,
                      String nativeMetadataFormatClassName,
                      String[] extraMetadataFormatNames,
                      String[] extraMetadataFormatClassNames)
构造一个 IIOMetadata 对象，使其带有给定格式名称和格式类名称，以及指示是否支持标准格式的 boolean 值。

此构造方法不会试图检查类名称的有效性。无效的类名称在后续调用 getMetadataFormat 时可能导致异常。

参数：
standardMetadataFormatSupported - 如果此对象可返回或接受使用标准元数据格式的 DOM 树，则该参数为 true。
nativeMetadataFormatName - String 形式的本机元数据格式的名称；如果不存在本机格式，则为 null。
nativeMetadataFormatClassName - 本机元数据格式的类名称；如果不存在本机格式，则为 null。
extraMetadataFormatNames - 指示此对象所支持的其他格式的 String 数组；如果不支持任何其他格式，则为 null。
extraMetadataFormatClassNames - 指示此对象所支持的所有其他格式的类名称的 String 数组；如果不支持任何其他格式，则为 null。
抛出：
IllegalArgumentException - 如果 extraMetadataFormatNames 的长度为 0。
IllegalArgumentException - 如果 extraMetadataFormatNames 和 extraMetadataFormatClassNames 既不同时为 null 也不具有相同长度。
方法详细信息

isStandardMetadataFormatSupported

public boolean isStandardMetadataFormatSupported()
如果 getMetadataFormat、getAsTree、setFromTree 和 mergeTree 支持标准元数据格式，则返回 true。

默认实现返回 standardFormatSupported 实例变量的值。

返回：
如果支持标准元数据格式，则返回 true。
另请参见：
getAsTree(java.lang.String),
setFromTree(java.lang.String, org.w3c.dom.Node),
mergeTree(java.lang.String, org.w3c.dom.Node),
getMetadataFormat(java.lang.String)

isReadOnly

public abstract boolean isReadOnly()
如果此对象不支持 mergeTree、setFromTree 和 reset 方法，则返回 true。

返回：
如果无法修改此 IIOMetadata 对象，则返回 true。

getNativeMetadataFormatName

public String getNativeMetadataFormatName()
返回此插件的“本机”元数据格式的名称，该格式通常允许无损失地编码和传输以此插件处理的格式存储的元数据。如果不支持这种格式，则将返回 null。

创建此 IIOMetadata 对象的插件定义“本机”元数据格式的结构和内容。用于简单格式的插件通常先为根创建一个虚拟节点，然后再创建一系列表示个别标记、存储块和关键字/值对的子节点。插件可以选择是否记录其本机格式。

默认实现返回 nativeMetadataFormatName 实例变量的值。

返回：
本机格式的名称；或 null。
另请参见：
getExtraMetadataFormatNames(), getMetadataFormatNames()

getExtraMetadataFormatNames

public String[] getExtraMetadataFormatNames()
返回一个 String 数组，包含此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的其他元数据格式（本机格式和标准格式除外）的名称。如果不存在这样的其他格式，则返回 null。

默认实现返回 extraMetadataFormatNames 实例变量的副本。

返回：
长度至少为 1 的 String 数组；或 null。
另请参见：
getAsTree(java.lang.String),
setFromTree(java.lang.String, org.w3c.dom.Node),
mergeTree(java.lang.String, org.w3c.dom.Node),
getNativeMetadataFormatName(),
getMetadataFormatNames()

getMetadataFormatNames

public String[] getMetadataFormatNames()
返回一个 String 数组，包含包括此插件的 getAsTree、setFromTree 和 mergeTree 方法可识别的所有元数据格式（包括本机格式和标准格式）的名称。如果不存在这样的格式，则返回 null。

默认实现调用 getNativeMetadataFormatName、isStandardMetadataFormatSupported 和 getExtraMetadataFormatNames 并返回组合结果。

返回：
String 数组。
另请参见：
getNativeMetadataFormatName(),
isStandardMetadataFormatSupported(),
getExtraMetadataFormatNames()

getMetadataFormat

public IIOMetadataFormat getMetadataFormat(String formatName)
返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。提供的名称必须为 getMetadataFormatNames 返回的名称之一（即，本机格式名称、标准格式名称或 getExtraMetadataFormatNames 返回的名称之一）。

默认实现凭借全局标准元数据格式名称进行名称检查，如果支持则返回该格式。否则，它将凭借本机格式名称然后是任何其他格式名称进行检查。如果发现匹配项，则其从 nativeMetadataFormatClassName 或 extraMetadataFormatClassNames 获取相应的 IIOMetadataFormat 类的名称，并使用其 getInstance 方法构造该类的实例。

参数：
formatName - 所需的元数据格式。
返回：
IIOMetadataFormat 对象。
抛出：
IllegalArgumentException - 如果 formatName 为 null，或者不是插件可识别的名称之一。
IllegalStateException - 如果无法加载与格式名称对应的类。

getAsTree

public abstract Node getAsTree(String formatName)
返回 XML DOM Node 对象，该对象表示此对象所包含的元数据树的根（根据给定元数据格式定义的约定）。

使用 getMetadataFormatNames 方法可以查询可用元数据格式的名称。

参数：
formatName - 所需的元数据格式。
返回：
形成树的根的 XML DOM Node 对象。
抛出：
IllegalArgumentException - 如果 formatName 为 null，或者不是 getMetadataFormatNames 返回的名称之一。
另请参见：
getMetadataFormatNames(),
setFromTree(java.lang.String, org.w3c.dom.Node),
mergeTree(java.lang.String, org.w3c.dom.Node)

mergeTree

public abstract void mergeTree(String formatName,
                               Node root)
                        throws IIOInvalidTreeException
根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。只在存在于给定树中的节点需要时才改变以前的状态。如果树结构或内容无效，则抛出 IIOInvalidTreeException。

由于如何将一个树或子树与另一个树合并的语义完全特定于格式，因此插件设计者可以使用最适合格式的方式实现此方法，包括使用给定树的内容取代所有的现有状态。

参数：
formatName - 所需的元数据格式。
root - 形成树的根的 XML DOM Node 对象。
抛出：
IllegalStateException - 如果此对象是只读的。
IllegalArgumentException - 如果 formatName 为 null，或者不是 getMetadataFormatNames 返回的名称之一。
IllegalArgumentException - 如果 root 为 null。
IIOInvalidTreeException - 如果使用给定格式的规则无法成功地解析树。
另请参见：
getMetadataFormatNames(),
getAsTree(java.lang.String),
setFromTree(java.lang.String, org.w3c.dom.Node)

getStandardChromaNode

protected IIOMetadataNode getStandardChromaNode()
返回表示标准 javax_imageio_1.0 元数据格式的色度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。
另请参见：
getStandardTree()

getStandardCompressionNode

protected IIOMetadataNode getStandardCompressionNode()
返回表示标准 javax_imageio_1.0 元数据格式的压缩信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。
另请参见：
getStandardTree()

getStandardDataNode

protected IIOMetadataNode getStandardDataNode()
返回表示标准 javax_imageio_1.0 元数据格式的数据格式信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。
另请参见：
getStandardTree()

getStandardDimensionNode

protected IIOMetadataNode getStandardDimensionNode()
返回表示标准 javax_imageio_1.0 元数据格式的维度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。
另请参见：
getStandardTree()

getStandardDocumentNode

protected IIOMetadataNode getStandardDocumentNode()
返回表示标准 javax_imageio_1.0 元数据格式的文档信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。
另请参见：
getStandardTree()

getStandardTextNode

protected IIOMetadataNode getStandardTextNode()
返回表示标准 javax_imageio_1.0 元数据格式的文本信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。
另请参见：
getStandardTree()

getStandardTileNode

protected IIOMetadataNode getStandardTileNode()
返回表示标准 javax_imageio_1.0 元数据格式的平铺信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。
另请参见：
getStandardTree()

getStandardTransparencyNode

protected IIOMetadataNode getStandardTransparencyNode()
返回表示标准 javax_imageio_1.0 元数据格式的透明度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。此方法将由实用例行程序 getStandardTree 调用。

默认实现返回 null。

如果子类希望支持标准元数据格式，则其应该重写此方法以生成适当的子树。

返回：
IIOMetadataNode，或者 null。

getStandardTree

protected final IIOMetadataNode getStandardTree()
返回表示此对象中所包含元数据的 IIOMetadataNode 的树（根据标准 javax_imageio_1.0 元数据格式的约定）的实用方法。

此方法调用各种 getStandard*Node 方法提供每个以根节点的子节点为根的子树。如果这些方法中任意一个返回 null，则省略相应的子树。如果它们都返回 null，则返回由单个根节点组成的树。

返回：
表示 javax_imageio_1.0 格式的元数据树的根的 IIOMetadataNode。
另请参见：
getStandardChromaNode(),
getStandardCompressionNode(),
getStandardDataNode(),
getStandardDimensionNode(),
getStandardDocumentNode(),
getStandardTextNode(),
getStandardTileNode(),
getStandardTransparencyNode()

setFromTree

public void setFromTree(String formatName,
                        Node root)
                 throws IIOInvalidTreeException
根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。丢弃以前的状态。如果树结构或内容无效，则抛出 IIOInvalidTreeException。

默认实现先调用 reset，然后调用 mergeTree(formatName, root)。

参数：
formatName - 所需的元数据格式。
root - 形成树的根的 XML DOM Node 对象。
抛出：
IllegalStateException - 如果此对象是只读的。
IllegalArgumentException - 如果 formatName 为 null，或者不是 getMetadataFormatNames 返回的名称之一。
IllegalArgumentException - 如果 root 为 null。
IIOInvalidTreeException - 如果使用给定格式的规则无法成功地解析树。
另请参见：
getMetadataFormatNames(),
getAsTree(java.lang.String),
mergeTree(java.lang.String, org.w3c.dom.Node)

reset

public abstract void reset()
将此对象中存储的所有数据重置为默认值，通常为此对象构造后立即处于的状态，尽管精确的语义是特定于插件的。注意，因创建对象的方式不同而存在多种可能的默认值。

抛出：
IllegalStateException - 如果此对象是只读的。
另请参见：
ImageReader.getStreamMetadata(),
ImageReader.getImageMetadata(int),
ImageWriter.getDefaultStreamMetadata(javax.imageio.ImageWriteParam),
ImageWriter.getDefaultImageMetadata(javax.imageio.ImageTypeSpecifier, javax.imageio.ImageWriteParam)

setController

public void setController(IIOMetadataController controller)
设置在调用 activateController 方法时用来为此 IIOParam 对象提供设置值的 IIOMetadataController，重写任何默认控制器。如果该参数为 null，则不使用任何控制器，包括所有默认控制器。要恢复默认值，请使用 setController(getDefaultController())。

默认实现将 controller 实例变量设置为提供的值。

参数：
controller - 一个适当的 IIOMetadataController，或者为 null。
另请参见：
IIOMetadataController,
getController(),
getDefaultController(),
hasController(),
activateController()

getController

public IIOMetadataController getController()
返回当前已安装的所有 IIOMetadataController。返回值可以是默认控制器（如果有）、null 或最近一次调用 setController 时使用的参数。

默认实现返回 controller 实例变量的值。

返回：
当前安装的 IIOMetadataController；或者 null。
另请参见：
IIOMetadataController,
setController(javax.imageio.metadata.IIOMetadataController),
getDefaultController(),
hasController(),
activateController()

getDefaultController

public IIOMetadataController getDefaultController()
返回默认 IIOMetadataController（如果有），不考虑当前安装的控制器。如果没有默认安装器，则返回 null。

默认实现返回 defaultController 实例变量的值。

返回：
默认 IIOMetadataController 或 null。
另请参见：
IIOMetadataController,
setController(IIOMetadataController),
getController(),
hasController(),
activateController()

hasController

public boolean hasController()
如果存在为此 IIOMetadata 对象安装的控制器，则返回 true。

如果 getController 方法返回非 null 值，则默认实现返回 true。

返回：
如果安装了一个控制器，则返回 true。
另请参见：
IIOMetadataController,
setController(IIOMetadataController),
getController(),
getDefaultController(),
activateController()

activateController

public boolean activateController()
激活为此 IIOMetadata 对象安装的 IIOMetadataController，并返回所得到的值。当此方法返回 true 时，此 IIOMetadata 对象的所有值都已准备好进行下一次写入操作。如果返回 false，则此对象中没有任何设置会被干扰（也就是说，用户取消了该操作）。

通常，控制器将是一个 GUI，为特定插件的 IIOMetadata 的子类提供用户界面。不过，控制器不必一定是 GUI。

默认实现调用 getController，如果 hasController 返回 true，则对返回对象调用 activate。

返回：
如果控制器完全正常，则返回 true。
抛出：
IllegalStateException - 如果当前没有安装控制器。
另请参见：
IIOMetadataController,
setController(IIOMetadataController),
getController(),
getDefaultController(),
hasController()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOMetadataController (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.metadata
接口 IIOMetadataController

public interface IIOMetadataController

该接口将由可以确定 IIOMetadata 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。此接口只指定调用控制器的一般 activate 方法，不考虑该控制器获得值的方式（也就是说，该控制器是提供一个 GUI 还是只计算一个值的集合与此接口无关）。

在 activate 方法中，控制器通过查询 IIOMetadata 对象的设置（使用 XML DOM 树或特定于插件的接口）获取初始值，通过所有方法修改值，然后再使用 setFromTree 或 mergeTree 方法抑或特定于插件的接口修改 IIOMetadata 对象的设置值。通常，应用程序可能期望在 activate 方法返回 true 时，IIOMetadata 对象已经准备好用于写入操作。

供应商可以选择为他们针对特定插件定义的 IIOMetadata 子类提供 GUI。其可以作为相应 IIOParam 子类中的默认控制器。

作为选择，可以将算法过程（比如数据库查找或解析命令行）用作控制器，在这种情况下，activate 方法将只查找或计算设置值，调用 IIOMetadata 上的方法设置其状态以及返回 true。

另请参见：
IIOMetadata.setController(javax.imageio.metadata.IIOMetadataController),
IIOMetadata.getController(),
IIOMetadata.getDefaultController(),
IIOMetadata.hasController(),
IIOMetadata.activateController()

方法摘要
 boolean activate(IIOMetadata metadata)
激活控制器。

方法详细信息

activate

boolean activate(IIOMetadata metadata)
激活控制器。如果返回 true，则 IIOMetadata 对象中的所有设置都应该已经准备好用于写入操作。如果返回 false，则 IIOMetadata 对象中没有任何设置会被干扰（也就是说，用户取消了该操作）。

参数：
metadata - 要修改的 IIOMetadata 对象。
返回：
如果已经修改了 IIOMetadata，则返回 true，否则返回 false。
抛出：
IllegalArgumentException - 如果 metadata 为 null 或者不是正确类的实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOMetadataFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.metadata
接口 IIOMetadataFormat

所有已知实现类：
IIOMetadataFormatImpl
public interface IIOMetadataFormat

描述从 IIOMetadata.getAsTree 返回并传递给 IIOMetadata.setFromTree 和 mergeTree 的元数据文档结构的对象。文档结构通过以下事物描述：一个关于可能属于某个给定父元素类型的子元素类型和数目的限制条件集合、可能属于某个元素的属性的名称、类型和值、以及可能存储在节点中的 Object 引用的类型和值。

N.B：实现此接口的类应该包含声明为 public static getInstance() 的方法，该方法返回该类的实例。通常，实现将仅构造单个实例并将其缓存以备将来调用 getInstance 时使用。

可由此类描述的结构是一个可以使用 XML 文档类型定义 (DTD) 表示的子集，再加上一些关于属性的数据类型的基本信息和在节点中存储 Object 引用的能力。将来，使用 XML 模式即可表示这些结构及其他结构。

IIOMetadataFormat 描述的结构与 DTD 之间的区别如下所示：

  • 元素不包含嵌入了标记的文本和混合文本。
  • 元素的子元素必须符合几个简单模式之一，这些简单模式在 CHILD_* 常量的文档中描述。
  • 元素的内存表示形式可能包含对 Object 的引用。没有提供对这些对象的文本表示。

字段摘要
static int | CHILD_POLICY_ALL getChildPolicy 返回的常量，指示某个元素必须具有按顺序排列的其每个合法子元素的单个实例。
static int | CHILD_POLICY_CHOICE getChildPolicy 返回的常量，指示元素必须具有从其合法子元素中选择的零个或一个子元素。
static int | CHILD_POLICY_EMPTY getChildPolicy 返回的常量，指示某个元素不具有任何子元素。
static int | CHILD_POLICY_MAX 最大有效 CHILD_POLICY_* 常量，将用于范围检查。
static int | CHILD_POLICY_REPEAT getChildPolicy 返回的常量，指示元素必须具有其唯一合法子元素的零个或多个实例。
static int | CHILD_POLICY_SEQUENCE getChildPolicy 返回的常量，指示元素必须具有其所有合法子元素的实例序列。
static int | CHILD_POLICY_SOME getChildPolicy 返回的常量，指示元素必须具有按顺序排列的其每个合法子元素的零个或一个实例。
static int | DATATYPE_BOOLEAN getAttributeDataType 返回的常量，指示属性的值为 'true' 或 'false'。
static int | DATATYPE_DOUBLE 由 getAttributeDataType 返回的常量，指示属性的值为双精度十进制浮点数的字符串表示形式。
static int | DATATYPE_FLOAT 由 getAttributeDataType 返回的常量，指示属性的值为十进制浮点数的字符串表示形式。
static int | DATATYPE_INTEGER getAttributeDataType 返回的常量，指示属性的值为整数的字符串表示形式。
static int | DATATYPE_STRING getAttributeDataType 返回的常量，指示属性的值为通用的 Unicode 字符串。
static int | VALUE_ARBITRARY getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为单个任意值。
static int | VALUE_ENUMERATION getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为许多枚举值之一。
static int | VALUE_LIST getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为一个值的列表或数组。
static int | VALUE_NONE getObjectValueType 返回的常量，指示缺少用户对象。
static int | VALUE_RANGE getAttributeValueType 和 getObjectValueType 返回的常量，指示可能将属性或用户对象设置为某个值范围。
static int | VALUE_RANGE_MAX_INCLUSIVE getAttributeValueType 和 getObjectValueType 返回的常量，指示可将属性或用户对象设置为某个值范围。
static int | VALUE_RANGE_MAX_INCLUSIVE_MASK 该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MAX_INCLUSIVE，可以与 VALUE_RANGE_MIN_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。
static int | VALUE_RANGE_MIN_INCLUSIVE getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。
static int | VALUE_RANGE_MIN_INCLUSIVE_MASK 该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MIN_INCLUSIVE，可以与 VALUE_RANGE_MAX_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。
static int | VALUE_RANGE_MIN_MAX_INCLUSIVE getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。
方法摘要
boolean | canNodeAppear(String elementName, ImageTypeSpecifier imageType) 如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。
int | getAttributeDataType(String elementName, String attrName) 返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。
String | getAttributeDefaultValue(String elementName, String attrName) 如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。
String | getAttributeDescription(String elementName, String attrName, Locale locale) 返回包含指定属性的描述的 String，或者 null。
String[] | getAttributeEnumerations(String elementName, String attrName) 返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。
int | getAttributeListMaxLength(String elementName, String attrName) 返回可用于定义此属性的最大列表项数。
int | getAttributeListMinLength(String elementName, String attrName) 返回可用于定义此属性的最小列表项数。
String | getAttributeMaxValue(String elementName, String attrName) 返回属性的最大合法值。
String | getAttributeMinValue(String elementName, String attrName) 返回属性的最小合法值。
String[] | getAttributeNames(String elementName) 返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。
int | getAttributeValueType(String elementName, String attrName) 返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。
String[] | getChildNames(String elementName) 返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。
int | getChildPolicy(String elementName) 返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。
String | getElementDescription(String elementName, Locale locale) 返回包含指定元素的描述的 String，或者 null。
int | getElementMaxChildren(String elementName) 返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。
int | getElementMinChildren(String elementName) 返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。
int | getObjectArrayMaxLength(String elementName) 返回指定元素中可用于定义 Object 引用的最大数组元素数。
int | getObjectArrayMinLength(String elementName) 返回指定元素中可用于定义 Object 引用的最小数组元素数。
Class<?> | getObjectClass(String elementName) 返回存储在元素中的 Class 类型的 Object 引用。
Object | getObjectDefaultValue(String elementName) 返回包含指定元素中 Object 引用的默认值的 Object。
Object[] | getObjectEnumerations(String elementName) 返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。
Comparable<?> | getObjectMaxValue(String elementName) 返回指定元素中 Object 引用的最大合法值。
Comparable<?> | getObjectMinValue(String elementName) 返回指定元素中 Object 引用的最小合法值。
int | getObjectValueType(String elementName) 返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。
String | getRootName() 返回格式的根元素的名称。
boolean | isAttributeRequired(String elementName, String attrName) 如果指定属性必须在指定元素中存在，则返回 true。

字段详细信息

CHILD_POLICY_EMPTY

static final int CHILD_POLICY_EMPTY
getChildPolicy 返回的常量，指示某个元素不具有任何子元素。换句话说，要求其为叶节点。

另请参见：
常量字段值

CHILD_POLICY_ALL

static final int CHILD_POLICY_ALL
getChildPolicy 返回的常量，指示某个元素必须具有按顺序排列的其每个合法子元素的单个实例。在使用 DTD 的情况下，元素的内容由序列 a,b,c,d,... 定义。

另请参见：
常量字段值

CHILD_POLICY_SOME

static final int CHILD_POLICY_SOME
getChildPolicy 返回的常量，指示元素必须具有按顺序排列的其每个合法子元素的零个或一个实例。在使用 DTD 的情况下，元素的内容由序列 a?,b?,c?,d?,... 定义。

另请参见：
常量字段值

CHILD_POLICY_CHOICE

static final int CHILD_POLICY_CHOICE
getChildPolicy 返回的常量，指示元素必须具有从其合法子元素中选择的零个或一个子元素。在使用 DTD 的情况下，元素的内容由选择 a|b|c|d|... 定义。

另请参见：
常量字段值

CHILD_POLICY_SEQUENCE

static final int CHILD_POLICY_SEQUENCE
getChildPolicy 返回的常量，指示元素必须具有其所有合法子元素的实例序列。在使用 DTD 的情况下，元素的内容由序列 (a|b|c|d|...)* 定义。

另请参见：
常量字段值

CHILD_POLICY_REPEAT

static final int CHILD_POLICY_REPEAT
getChildPolicy 返回的常量，指示元素必须具有其唯一合法子元素的零个或多个实例。在使用 DTD 的情况下，元素的内容由带有星号的表达式 a* 定义。

另请参见：
常量字段值

CHILD_POLICY_MAX

static final int CHILD_POLICY_MAX
最大有效 CHILD_POLICY_* 常量，将用于范围检查。

另请参见：
常量字段值

VALUE_NONE

static final int VALUE_NONE
getObjectValueType 返回的常量，指示缺少用户对象。

另请参见：
常量字段值

VALUE_ARBITRARY

static final int VALUE_ARBITRARY
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为单个任意值。

另请参见：
常量字段值

VALUE_RANGE

static final int VALUE_RANGE
getAttributeValueType 和 getObjectValueType 返回的常量，指示可能将属性或用户对象设置为某个值范围。范围的最小值和最大值都不包括在内。建议对于整数范围包括两端的值，只在使用浮点数据范围时才不包括两端的值。

另请参见：
VALUE_RANGE_MIN_MAX_INCLUSIVE, 常量字段值

VALUE_RANGE_MIN_INCLUSIVE_MASK

static final int VALUE_RANGE_MIN_INCLUSIVE_MASK
该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MIN_INCLUSIVE，可以与 VALUE_RANGE_MAX_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。

类似地，可以将该值与 getAttributeValueType 或 getObjectValueType 的值进行“与”运算来确定是否包括范围的最小值。

另请参见：
常量字段值

VALUE_RANGE_MAX_INCLUSIVE_MASK

static final int VALUE_RANGE_MAX_INCLUSIVE_MASK
该值可以与 VALUE_RANGE 进行“或”运算来获取 VALUE_RANGE_MAX_INCLUSIVE，可以与 VALUE_RANGE_MIN_INCLUSIVE 进行“或”运算来获取 VALUE_RANGE_MIN_MAX_INCLUSIVE。

类似地，可以将该值与 getAttributeValueType 或 getObjectValueType 的值进行“与”运算来确定是否包括范围的最大值。

另请参见：
常量字段值

VALUE_RANGE_MIN_INCLUSIVE

static final int VALUE_RANGE_MIN_INCLUSIVE
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。范围的最小值包括在内（但不包括最大值）。

另请参见：
常量字段值

VALUE_RANGE_MAX_INCLUSIVE

static final int VALUE_RANGE_MAX_INCLUSIVE
getAttributeValueType 和 getObjectValueType 返回的常量，指示可将属性或用户对象设置为某个值范围。范围的最大值包括在内（但不包括最小值）。

另请参见：
常量字段值

VALUE_RANGE_MIN_MAX_INCLUSIVE

static final int VALUE_RANGE_MIN_MAX_INCLUSIVE
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为某个值范围。范围的最小值和最大值都包括在内。建议对于整数范围包括两端的值，只在使用浮点数据范围时才不包括两端的值。

另请参见：
常量字段值

VALUE_ENUMERATION

static final int VALUE_ENUMERATION
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为许多枚举值之一。对于属性来说，这些值为 String；对于对象，其为实现给定类或接口的 Object。

应该将 DATATYPE_BOOLEAN 类型的属性值标记为枚举。

另请参见：
常量字段值

VALUE_LIST

static final int VALUE_LIST
getAttributeValueType 和 getObjectValueType 返回的常量，指示可以将属性或用户对象设置为一个值的列表或数组。对于属性来说，列表将由在 String 中由空白分隔的值组成；对于对象，将使用数组。

另请参见：
常量字段值

DATATYPE_STRING

static final int DATATYPE_STRING
getAttributeDataType 返回的常量，指示属性的值为通用的 Unicode 字符串。

另请参见：
常量字段值

DATATYPE_BOOLEAN

static final int DATATYPE_BOOLEAN
getAttributeDataType 返回的常量，指示属性的值为 'true' 或 'false'。

另请参见：
常量字段值

DATATYPE_INTEGER

static final int DATATYPE_INTEGER
getAttributeDataType 返回的常量，指示属性的值为整数的字符串表示形式。

另请参见：
常量字段值

DATATYPE_FLOAT

static final int DATATYPE_FLOAT
由 getAttributeDataType 返回的常量，指示属性的值为十进制浮点数的字符串表示形式。

另请参见：
常量字段值

DATATYPE_DOUBLE

static final int DATATYPE_DOUBLE
由 getAttributeDataType 返回的常量，指示属性的值为双精度十进制浮点数的字符串表示形式。

另请参见：
常量字段值
方法详细信息

getRootName

String getRootName()
返回格式的根元素的名称。

返回：
String。

canNodeAppear

boolean canNodeAppear(String elementName,
                      ImageTypeSpecifier imageType)
如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。例如，元数据文档格式可能包含描述图像原色的元素，该元素在写入灰度级图像时是不允许出现的。

参数：
elementName - 要查询的元素的名称。
imageType - 指示将与元数据关联的图像类型的 ImageTypeSpecifier。
返回：
如果节点对于给定类型的图像有意义，则返回 true。

getElementMinChildren

int getElementMinChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。例如，表示原色信息的元素可能需要具有至少 3 个子元素，每种原色一个子元素。

参数：
elementName - 要查询的元素的名称。
返回：
int。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素不具有子策略 CHILD_POLICY_REPEAT。

getElementMaxChildren

int getElementMaxChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。例如，表示 8 位调色板条目的元素可能允许重复多达 256 次。Integer.MAX_VALUE 的值可用于指定不存在上限。

参数：
elementName - 要查询的元素的名称。
返回：
int。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素不具有子策略 CHILD_POLICY_REPEAT。

getElementDescription

String getElementDescription(String elementName,
                             Locale locale)
返回包含指定元素的描述的 String，或者 null。如果可能，应将该描述本地化为提供的 Locale。

如果 locale 为 null，则使用 Locale.getLocale 返回的当前默认 Locale。

参数：
elementName - 元素的名称。
locale - 尝试进行本地化的 Locale。
返回：
元素描述。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。

getChildPolicy

int getChildPolicy(String elementName)
返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。

参数：
elementName - 要查询的元素的名称。
返回：
CHILD_POLICY_* 常量之一。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。

getChildNames

String[] getChildNames(String elementName)
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。如果元素不能有子元素，则返回 null。

参数：
elementName - 要查询的元素的名称。
返回：
String 数组，或 null。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。

getAttributeNames

String[] getAttributeNames(String elementName)
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。

参数：
elementName - 要查询的元素的名称。
返回：
String 数组。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。

getAttributeValueType

int getAttributeValueType(String elementName,
                          String attrName)
返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
VALUE_* 常量之一。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。

getAttributeDataType

int getAttributeDataType(String elementName,
                         String attrName)
返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。如果 getAttributeValueType 返回 VALUE_LIST，则合法值为返回数据类型的值的以空白分隔的列表。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
DATATYPE_* 常量之一。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。

isAttributeRequired

boolean isAttributeRequired(String elementName,
                            String attrName)
如果指定属性必须在指定元素中存在，则返回 true。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
如果属性必须存在，则返回 true。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。

getAttributeDefaultValue

String getAttributeDefaultValue(String elementName,
                                String attrName)
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
包含默认值的 String，或者 null。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。

getAttributeEnumerations

String[] getAttributeEnumerations(String elementName,
                                  String attrName)
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。只应在 getAttributeValueType 返回 VALUE_ENUMERATION的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
String 数组。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。
IllegalArgumentException - 如果没有将给定属性定义为枚举。

getAttributeMinValue

String getAttributeMinValue(String elementName,
                            String attrName)
返回属性的最小合法值。是否包括此值可由 getAttributeValueType 的值确定。该值以 String 的形式返回；其解释依赖于 getAttributeDataType 的值。只应在 getAttributeValueType 返回 VALUE_RANGE_* 的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
包含属性的最小合法值的 String。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。
IllegalArgumentException - 如果没有将给定属性定义为范围。

getAttributeMaxValue

String getAttributeMaxValue(String elementName,
                            String attrName)
返回属性的最大合法值。是否包括此值可由 getAttributeValueType 的值确定。该值以 String 的形式返回；其解释依赖于 getAttributeDataType 的值。只应在 getAttributeValueType 返回 VALUE_RANGE_* 的情况下调用此方法。

参数：
elementName - 要查询的 String 形式的元素名称。
attrName - 要查询的属性的名称。
返回：
包含属性的最大合法值的 String。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。
IllegalArgumentException - 如果没有将给定属性定义为范围。

getAttributeListMinLength

int getAttributeListMinLength(String elementName,
                              String attrName)
返回可用于定义此属性的最小列表项数。属性本身被定义为一个包含多个由空白分隔的项的 String。只应在 getAttributeValueType 返回 VALUE_LIST 的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
属性的列表项的最小合法数。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。
IllegalArgumentException - 如果没有将给定属性定义为列表。

getAttributeListMaxLength

int getAttributeListMaxLength(String elementName,
                              String attrName)
返回可用于定义此属性的最大列表项数。Integer.MAX_VALUE 的值可用于指定不存在上限。属性本身被定义为一个包含多个由空白分隔的项的 String。只应在 getAttributeValueType 返回 VALUE_LIST 的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
属性的列表项的最大合法数。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。
IllegalArgumentException - 如果没有将给定属性定义为列表。

getAttributeDescription

String getAttributeDescription(String elementName,
                               String attrName,
                               Locale locale)
返回包含指定属性的描述的 String，或者 null。如果可能，应将该描述本地化为提供的 Locale。

如果 locale 为 null，则使用 Locale.getLocale 返回的当前默认 Locale。

参数：
elementName - 元素的名称。
attrName - 属性的名称。
locale - 尝试进行本地化的 Locale。
返回：
属性描述。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。

getObjectValueType

int getObjectValueType(String elementName)
返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。如果在给定元素中无法存储任何对象值，则此方法的结果将为 VALUE_NONE。

合法值被定义为范围的 Object 引用必须实现 Comparable 接口。

参数：
elementName - 要查询的元素的名称。
返回：
VALUE_* 常量之一。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
另请参见：
Comparable

getObjectClass

Class<?> getObjectClass(String elementName)
返回存储在元素中的 Class 类型的 Object 引用。如果此元素不能包含 Object 引用，则抛出 IllegalArgumentException。如果类类型为数组，则此字段指示底层类类型（例如，对于 int 的数组，此方法将返回 int.class）。

合法值被定义为范围的 Object 引用必须实现 Comparable 接口。

参数：
elementName - 要查询的元素的名称。
返回：
Class 对象。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素无法包含对象值（即，如果 getObjectValueType(elementName) == VALUE_NONE）。

getObjectDefaultValue

Object getObjectDefaultValue(String elementName)
返回包含指定元素中 Object 引用的默认值的 Object。

参数：
elementName - 要查询的元素的名称。
返回：
Object 对象。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素无法包含对象值（即，如果 getObjectValueType(elementName) == VALUE_NONE）。

getObjectEnumerations

Object[] getObjectEnumerations(String elementName)
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。只应在 getObjectValueType 返回 VALUE_ENUMERATION的情况下调用此方法。

与接受枚举值的节点关联的 Object 必须等于此方法返回的值之一，这里的等于是由 == 运算符（而不是 Object.equals 方法）定义的。

参数：
elementName - 要查询的元素的名称。
返回：
Object 数组。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素无法包含对象值（即，如果 getObjectValueType(elementName) == VALUE_NONE）。
IllegalArgumentException - 如果没有将 Object 定义为枚举。

getObjectMinValue

Comparable<?> getObjectMinValue(String elementName)
返回指定元素中 Object 引用的最小合法值。是否包括此值可由 getObjectValueType 的值确定。只应在 getObjectValueType 返回以 VALUE_RANGE 开头的常量之一的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
返回：
属性的最小合法值。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素无法包含对象值（即，如果 getObjectValueType(elementName) == VALUE_NONE）。
IllegalArgumentException - 如果没有将 Object 定义为范围。

getObjectMaxValue

Comparable<?> getObjectMaxValue(String elementName)
返回指定元素中 Object 引用的最大合法值。是否包括此值可由 getObjectValueType 的值确定。只应在 getObjectValueType 返回以 VALUE_RANGE 开头的常量之一的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
返回：
属性的最小合法值。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素无法包含对象值（即，如果 getObjectValueType(elementName) == VALUE_NONE）。
IllegalArgumentException - 如果没有将 Object 定义为范围。

getObjectArrayMinLength

int getObjectArrayMinLength(String elementName)
返回指定元素中可用于定义 Object 引用的最小数组元素数。只应在 getObjectValueType 返回 VALUE_LIST 的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
返回：
Object 引用的最小有效数组长度。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素无法包含对象值（即，如果 getObjectValueType(elementName) == VALUE_NONE）。
IllegalArgumentException - 如果 Object 不是数组。

getObjectArrayMaxLength

int getObjectArrayMaxLength(String elementName)
返回指定元素中可用于定义 Object 引用的最大数组元素数。Integer.MAX_VALUE 的值可用于指定不存在上限。只应在 getObjectValueType 返回 VALUE_LIST 的情况下调用此方法。

参数：
elementName - 要查询的元素的名称。
返回：
Object 引用的最大有效数组长度。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果指定元素无法包含对象值（即，如果 getObjectValueType(elementName) == VALUE_NONE）。
IllegalArgumentException - 如果 Object 不是数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOMetadataFormatImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.metadata
类 IIOMetadataFormatImpl

java.lang.Object
    继承者  javax.imageio.metadata.IIOMetadataFormatImpl
所有已实现的接口：
IIOMetadataFormat
public abstract class IIOMetadataFormatImpl
extends Object
implements IIOMetadataFormat

提供 IIOMetadataFormat 接口的可重用实现的具体类。此外，通过 getStandardFormatInstance 方法提供一个表示标准的、插件无关的 javax_imageio_1.0 格式的静态实例。

为了提供元素和属性的本地化的描述，应该通过 ResourceBundle.getBundle 使用的常规机制来提供基本名称为 this.getClass().getName() + "Resources" 的 ResourceBundle。简单地说，子类根据命名约定（默认情况下为扩展 IIMetadataFormatImpl 的子类的完全限定名，加上字符串 "Resources"，加上国家/地区、语言和由下划线分隔的变体代码）提供一个或多个其他类。在运行期间，调用 getElementDescription 或 getAttributeDescription 将尝试根据提供的语言环境动态加载这些类，并将使用元素名称或者后跟 '/' 字符再后跟作为键的属性名的元素名称。此键将提供给 ResourceBundle 的 getString 方法，并返回所得到的节点或属性的本地化描述。

子类可以使用 setResourceBaseName 方法为资源包提供另外的基本名称。

在需要时，子类可以通过重写提供的 getElementDescription 和 getAttributeDescription 实现来选择它自己的本地化机制。

另请参见：
ResourceBundle.getBundle(String,Locale)

字段摘要
static String standardMetadataFormatName
包含标准格式名称 "javax_imageio_1.0" 的 String 常量。
从接口 javax.imageio.metadata.IIOMetadataFormat 继承的字段
CHILD_POLICY_ALL, CHILD_POLICY_CHOICE, CHILD_POLICY_EMPTY, CHILD_POLICY_MAX, CHILD_POLICY_REPEAT, CHILD_POLICY_SEQUENCE, CHILD_POLICY_SOME, DATATYPE_BOOLEAN, DATATYPE_DOUBLE, DATATYPE_FLOAT, DATATYPE_INTEGER, DATATYPE_STRING, VALUE_ARBITRARY, VALUE_ENUMERATION, VALUE_LIST, VALUE_NONE, VALUE_RANGE, VALUE_RANGE_MAX_INCLUSIVE, VALUE_RANGE_MAX_INCLUSIVE_MASK, VALUE_RANGE_MIN_INCLUSIVE, VALUE_RANGE_MIN_INCLUSIVE_MASK, VALUE_RANGE_MIN_MAX_INCLUSIVE
构造方法摘要
IIOMetadataFormatImpl(String rootName, int childPolicy)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略（CHILD_POLICY_REPEAT 除外）。
IIOMetadataFormatImpl(String rootName, int minChildren, int maxChildren)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略 CHILD_POLICY_REPEAT。
方法摘要
protected  void addAttribute(String elementName, String attrName, int dataType, boolean required, int listMinLength, int listMaxLength)
将新属性添加到以前定义的元素中，该元素将由值的列表定义。
protected  void addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue)
将新属性添加到以前定义的可以被设置为任意值的元素中。
protected  void addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。
protected  void addAttribute(String elementName, String attrName, int dataType, boolean required, String defaultValue, String minValue, String maxValue, boolean minInclusive, boolean maxInclusive)
将新属性添加到以前定义的元素中，该元素将由一系列值定义。
protected  void addBooleanAttribute(String elementName, String attrName, boolean hasDefaultValue, boolean defaultValue)
将新属性添加到以前定义的元素中，该元素将由枚举值 TRUE 和 FALSE 定义，数据类型为 DATATYPE_BOOLEAN。
protected  void addChildElement(String elementName, String parentName)
将现有元素添加到给定父节点类型的合法子节点的列表中。
protected  void addElement(String elementName, String parentName, int childPolicy)
使用某个子策略（CHILD_POLICY_REPEAT 除外）将新元素类型添加到此元数据文档格式中。
protected  void addElement(String elementName, String parentName, int minChildren, int maxChildren)
使用子策略 CHILD_POLICY_REPEAT 将新元素类型添加到此元数据文档格式中。
protected  void addObjectValue(String elementName, Class<?> classType, int arrayMinLength, int arrayMaxLength)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T> void
addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T> void
addObjectValue(String elementName, Class<T> classType, boolean required, T defaultValue, List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
protected
<T extends Object & Comparable<? super T>>
void
addObjectValue(String elementName, Class<T> classType, T defaultValue, Comparable<? super T> minValue, Comparable<? super T> maxValue, boolean minInclusive, boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。
abstract  boolean canNodeAppear(String elementName, ImageTypeSpecifier imageType)
如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。
 int getAttributeDataType(String elementName, String attrName)
返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。
 String getAttributeDefaultValue(String elementName, String attrName)
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。
 String getAttributeDescription(String elementName, String attrName, Locale locale)
返回包含指定属性的描述的 String，或者 null。
 String[] getAttributeEnumerations(String elementName, String attrName)
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。
 int getAttributeListMaxLength(String elementName, String attrName)
返回可用于定义此属性的最大列表项数。
 int getAttributeListMinLength(String elementName, String attrName)
返回可用于定义此属性的最小列表项数。
 String getAttributeMaxValue(String elementName, String attrName)
返回属性的最大合法值。
 String getAttributeMinValue(String elementName, String attrName)
返回属性的最小合法值。
 String[] getAttributeNames(String elementName)
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。
 int getAttributeValueType(String elementName, String attrName)
返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。
 String[] getChildNames(String elementName)
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。
 int getChildPolicy(String elementName)
返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。
 String getElementDescription(String elementName, Locale locale)
返回包含指定元素的描述的 String，或者 null。
 int getElementMaxChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。
 int getElementMinChildren(String elementName)
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。
 int getObjectArrayMaxLength(String elementName)
返回指定元素中可用于定义 Object 引用的最大数组元素数。
 int getObjectArrayMinLength(String elementName)
返回指定元素中可用于定义 Object 引用的最小数组元素数。
 Class<?> getObjectClass(String elementName)
返回存储在元素中的 Class 类型的 Object 引用。
 Object getObjectDefaultValue(String elementName)
返回包含指定元素中 Object 引用的默认值的 Object。
 Object[] getObjectEnumerations(String elementName)
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。
 Comparable<?> getObjectMaxValue(String elementName)
返回指定元素中 Object 引用的最大合法值。
 Comparable<?> getObjectMinValue(String elementName)
返回指定元素中 Object 引用的最小合法值。
 int getObjectValueType(String elementName)
返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。
protected  String getResourceBaseName()
返回当前设置的用于查找 ResourceBundle 的基本名称。
 String getRootName()
返回格式的根元素的名称。
static IIOMetadataFormat getStandardFormatInstance()
返回描述标准、插件无关的 javax.imageio_1.0 元数据文档格式的 IIOMetadataFormat 对象，该文档格式在 javax.imageio.metadata 包的注释中描述。
 boolean isAttributeRequired(String elementName, String attrName)
如果指定属性必须在指定元素中存在，则返回 true。
protected  void removeAttribute(String elementName, String attrName)
从以前定义的元素中移除属性。
protected  void removeElement(String elementName)
从格式中移除元素。
protected  void removeObjectValue(String elementName)
禁止将 Object 引用存储在实现指定元素的节点中。
protected  void setResourceBaseName(String resourceBaseName)
设置用于查找包含此格式的元素和属性描述的 ResourceBundle 新基本名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

standardMetadataFormatName

public static final String standardMetadataFormatName
包含标准格式名称 "javax_imageio_1.0" 的 String 常量。

另请参见：
常量字段值
构造方法详细信息

IIOMetadataFormatImpl

public IIOMetadataFormatImpl(String rootName,
                             int childPolicy)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略（CHILD_POLICY_REPEAT 除外）。其他元素及其属性以及 Object 引用信息可以使用各种 add 方法添加。

参数：
rootName - 根元素的名称。
childPolicy - CHILD_POLICY_REPEAT 之外的 CHILD_POLICY_* 常量之一。
抛出：
IllegalArgumentException - 如果 rootName 为 null。
IllegalArgumentException - 如果 childPolicy 不是预定义的常量之一。

IIOMetadataFormatImpl

public IIOMetadataFormatImpl(String rootName,
                             int minChildren,
                             int maxChildren)
构造一个空的 IIOMetadataFormatImpl 实例，使其具有给定根元素名称和子策略 CHILD_POLICY_REPEAT。其他元素及其属性以及 Object 引用信息可以使用各种 add 方法添加。

参数：
rootName - 根元素的名称。
minChildren - 节点的最小子节点数。
maxChildren - 节点的最大子节点数。
抛出：
IllegalArgumentException - 如果 rootName 为 null。
IllegalArgumentException - 如果 minChildren 为负或大于 maxChildren。
方法详细信息

setResourceBaseName

protected void setResourceBaseName(String resourceBaseName)
设置用于查找包含此格式的元素和属性描述的 ResourceBundle 新基本名称。

在首次调用此方法之前，基本名称将等于 this.getClass().getName() + "Resources"。

参数：
resourceBaseName - 包含新基本名称的 String。
抛出：
IllegalArgumentException - 如果 resourceBaseName 为 null。
另请参见：
getResourceBaseName()

getResourceBaseName

protected String getResourceBaseName()
返回当前设置的用于查找 ResourceBundle 的基本名称。

返回：
包含基本名称的 String。
另请参见：
setResourceBaseName(java.lang.String)

addElement

protected void addElement(String elementName,
                          String parentName,
                          int childPolicy)
使用某个子策略（CHILD_POLICY_REPEAT 除外）将新元素类型添加到此元数据文档格式中。

参数：
elementName - 新元素的名称。
parentName - 将作为新元素的父元素的元素的名称。
childPolicy - CHILD_POLICY_REPEAT 之外的 CHILD_POLICY_* 常量之一，指示新元素的子策略。
抛出：
IllegalArgumentException - 如果 parentName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 childPolicy 不是预定义的常量之一。

addElement

protected void addElement(String elementName,
                          String parentName,
                          int minChildren,
                          int maxChildren)
使用子策略 CHILD_POLICY_REPEAT 将新元素类型添加到此元数据文档格式中。

参数：
elementName - 新元素的名称。
parentName - 将作为新元素的父元素的元素的名称。
minChildren - 节点的最小子节点数。
maxChildren - 节点的最大子节点数。
抛出：
IllegalArgumentException - 如果 parentName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 minChildren 为负或大于 maxChildren。

addChildElement

protected void addChildElement(String elementName,
                               String parentName)
将现有元素添加到给定父节点类型的合法子节点的列表中。

参数：
parentName - 将作为元素的新父元素的元素的名称。
elementName - 要作为子元素添加的元素的名称。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 parentName 为 null 或者不是此格式的合法元素名称。

removeElement

protected void removeElement(String elementName)
从格式中移除元素。如果不存在使用给定名字的元素，则不执行任何操作并且不会抛出任何异常。

参数：
elementName - 要移除的元素的名称。

addAttribute

protected void addAttribute(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            String defaultValue)
将新属性添加到以前定义的可以被设置为任意值的元素中。

参数：
elementName - 元素的名称。
attrName - 要添加的属性的名称。
dataType - 属性的数据类型（字符串格式），DATATYPE_* 常量之一。
required - 如果属性必须存在，则为 true。
defaultValue - 属性的默认值，或者为 null。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null。
IllegalArgumentException - 如果 dataType 不是预定义的常量之一。

addAttribute

protected void addAttribute(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            String defaultValue,
                            List<String> enumeratedValues)
将新属性添加到以前定义的元素中，该元素将由一组枚举值定义。

参数：
elementName - 元素的名称。
attrName - 要添加的属性的名称。
dataType - 属性的数据类型（字符串格式），DATATYPE_* 常量之一。
required - 如果属性必须存在，则为 true。
defaultValue - 属性的默认值，或者为 null。
enumeratedValues - 包含属性合法值的 String 组成的 List。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null。
IllegalArgumentException - 如果 dataType 不是预定义的常量之一。
IllegalArgumentException - 如果 enumeratedValues 为 null。
IllegalArgumentException - 如果 enumeratedValues 不包含至少一项。
IllegalArgumentException - 如果 enumeratedValues 包含不为 String 的元素或者为 null。

addAttribute

protected void addAttribute(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            String defaultValue,
                            String minValue,
                            String maxValue,
                            boolean minInclusive,
                            boolean maxInclusive)
将新属性添加到以前定义的元素中，该元素将由一系列值定义。

参数：
elementName - 元素的名称。
attrName - 要添加的属性的名称。
dataType - 属性的数据类型（字符串格式），DATATYPE_* 常量之一。
required - 如果属性必须存在，则为 true。
defaultValue - 属性的默认值，或者为 null。
minValue - 属性的最小（是否包括两端的值取决于 minInclusive 的值）合法值（String 形式）。
maxValue - 属性的最大（是否包括两端的值取决于 minInclusive 的值）合法值（String 形式）。
minInclusive - 如果包括 minValue，则为 true。
maxInclusive - 如果包括 maxValue，则为 true。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null。
IllegalArgumentException - 如果 dataType 不是预定义的常量之一。

addAttribute

protected void addAttribute(String elementName,
                            String attrName,
                            int dataType,
                            boolean required,
                            int listMinLength,
                            int listMaxLength)
将新属性添加到以前定义的元素中，该元素将由值的列表定义。

参数：
elementName - 元素的名称。
attrName - 要添加的属性的名称。
dataType - 属性的数据类型（字符串格式），DATATYPE_* 常量之一。
required - 如果属性必须存在，则为 true。
listMinLength - 列表项的最小合法数。
listMaxLength - 列表项的最大合法数。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null。
IllegalArgumentException - 如果 dataType 不是预定义的常量之一。
IllegalArgumentException - 如果 listMinLength 为负或大于 listMaxLength。

addBooleanAttribute

protected void addBooleanAttribute(String elementName,
                                   String attrName,
                                   boolean hasDefaultValue,
                                   boolean defaultValue)
将新属性添加到以前定义的元素中，该元素将由枚举值 TRUE 和 FALSE 定义，数据类型为 DATATYPE_BOOLEAN。

参数：
elementName - 元素的名称。
attrName - 要添加的属性的名称。
hasDefaultValue - 如果默认值应该存在，则为 true。
defaultValue - boolean 值形式的属性默认值；如果 hasDefaultValue 为 false，则忽略该参数。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null。

removeAttribute

protected void removeAttribute(String elementName,
                               String attrName)
从以前定义的元素中移除属性。如果在给定元素中不存在使用给定名字的属性，则不执行任何操作并且不会抛出任何异常。

参数：
elementName - 元素的名称。
attrName - 要移除的属性的名称。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。

addObjectValue

protected <T> void addObjectValue(String elementName,
                                  Class<T> classType,
                                  boolean required,
                                  T defaultValue)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。Object 的值是不受约束的（其类类型除外）。

如果以前允许 Object 引用，则重写以前的设置值。

参数：
elementName - 元素的名称。
classType - 指示对象值的合法类类型的 Class 变量。
required - 如果对象值必须存在，则为 true。
defaultValue - Object 引用的默认值，或者为 null。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。

addObjectValue

protected <T> void addObjectValue(String elementName,
                                  Class<T> classType,
                                  boolean required,
                                  T defaultValue,
                                  List<? extends T> enumeratedValues)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。Object 的值必须为 enumeratedValues 给出的值之一。

如果以前允许 Object 引用，则重写以前的设置值。

参数：
elementName - 元素的名称。
classType - 指示对象值的合法类类型的 Class 变量。
required - 如果对象值必须存在，则为 true。
defaultValue - Object 引用的默认值，或者为 null。
enumeratedValues - 包含对象引用的合法值的 Object 组成的 List。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 enumeratedValues 为 null。
IllegalArgumentException - 如果 enumeratedValues 不包含至少一项。
IllegalArgumentException - 如果 enumeratedValues 包含不为 classType 指定的类类型的实例或者为 null。

addObjectValue

protected <T extends Object & Comparable<? super T>> void addObjectValue(String elementName,
                                                                        Class<T> classType,
                                                                        T defaultValue,
                                                                        Comparable<? super T> minValue,
                                                                        Comparable<? super T> maxValue,
                                                                        boolean minInclusive,
                                                                        boolean maxInclusive)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。Object 的值必须在 minValue 和 maxValue 给出的范围中。此外，类类型必须实现 Comparable 接口。

如果以前允许 Object 引用，则重写以前的设置值。

参数：
elementName - 元素的名称。
classType - 指示对象值的合法类类型的 Class 变量。
defaultValue - 默认值
minValue - 对象值的最小（是否包括两端的值取决于 minInclusive 的值）合法值（String 形式）。
maxValue - 对象值的最大（是否包括两端的值取决于 minInclusive 的值）合法值（String 形式）。
minInclusive - 如果包括 minValue，则为 true。
maxInclusive - 如果包括 maxValue，则为 true。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。

addObjectValue

protected void addObjectValue(String elementName,
                              Class<?> classType,
                              int arrayMinLength,
                              int arrayMaxLength)
允许将给定类类型的 Object 引用存储在实现指定元素的节点中。Object 的值必须为 classType 给出的类类型的对象数组，该数组的元素至少为 arrayMinLength 至多为 arrayMaxLength。

如果以前允许 Object 引用，则重写以前的设置值。

参数：
elementName - 元素的名称。
classType - 指示对象值的合法类类型的 Class 变量。
arrayMinLength - 数组的最小合法长度。
arrayMaxLength - 数组的最大合法长度。
抛出：
IllegalArgumentException - 如果 elementName 不是此格式的合法元素名称。

removeObjectValue

protected void removeObjectValue(String elementName)
禁止将 Object 引用存储在实现指定元素的节点中。

参数：
elementName - 元素的名称。
抛出：
IllegalArgumentException - 如果 elementName 不是此格式的合法元素名称。

getRootName

public String getRootName()
从接口 IIOMetadataFormat 复制的描述
返回格式的根元素的名称。

指定者：
接口 IIOMetadataFormat 中的 getRootName
返回：
String。

canNodeAppear

public abstract boolean canNodeAppear(String elementName,
                                      ImageTypeSpecifier imageType)
从接口 IIOMetadataFormat 复制的描述
如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。例如，元数据文档格式可能包含描述图像原色的元素，该元素在写入灰度级图像时是不允许出现的。

指定者：
接口 IIOMetadataFormat 中的 canNodeAppear
参数：
elementName - 要查询的元素的名称。
imageType - 指示将与元数据关联的图像类型的 ImageTypeSpecifier。
返回：
如果节点对于给定类型的图像有意义，则返回 true。

getElementMinChildren

public int getElementMinChildren(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最小子元素数。例如，表示原色信息的元素可能需要具有至少 3 个子元素，每种原色一个子元素。

指定者：
接口 IIOMetadataFormat 中的 getElementMinChildren
参数：
elementName - 要查询的元素的名称。
返回：
int。

getElementMaxChildren

public int getElementMaxChildren(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回使用子策略 CHILD_POLICY_REPEAT 的指定元素的最大子元素数。例如，表示 8 位调色板条目的元素可能允许重复多达 256 次。Integer.MAX_VALUE 的值可用于指定不存在上限。

指定者：
接口 IIOMetadataFormat 中的 getElementMaxChildren
参数：
elementName - 要查询的元素的名称。
返回：
int。

getElementDescription

public String getElementDescription(String elementName,
                                    Locale locale)
返回包含指定元素的描述的 String，或者 null。如果可能，应将描述本地化为提供的 Locale。

默认实现利用在 ResourceBundle.getBundle 的注释中描述的应变机制 (fallback mechanism)，首先使用由 setResourceBaseName 设置的当前资源基本名称以及所提供的 Locale 查找 ResourceBundle。如果找到 ResourceBundle，则将元素名称用作其 getString 方法的键并返回结果。如果未找到 ResourceBundle 或者不存在这样的键，则返回 null。

如果 locale 为 null，则使用 Locale.getLocale 返回的当前默认 Locale。

指定者：
接口 IIOMetadataFormat 中的 getElementDescription
参数：
elementName - 元素的名称。
locale - 尝试进行本地化的 Locale。
返回：
元素描述。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
另请参见：
setResourceBaseName(java.lang.String)

getChildPolicy

public int getChildPolicy(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回以 CHILD_POLICY_ 开头的常量之一，指示指定元素子元素的合法模式。

指定者：
接口 IIOMetadataFormat 中的 getChildPolicy
参数：
elementName - 要查询的元素的名称。
返回：
CHILD_POLICY_* 常量之一。

getChildNames

public String[] getChildNames(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回一个按出现顺序排列的 String 数组，指示允许作为指定元素子元素的元素的名称。如果元素不能有子元素，则返回 null。

指定者：
接口 IIOMetadataFormat 中的 getChildNames
参数：
elementName - 要查询的元素的名称。
返回：
String 数组，或 null。

getAttributeNames

public String[] getAttributeNames(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回一个 String 数组，该数组列出了与指定元素关联的属性的名称。

指定者：
接口 IIOMetadataFormat 中的 getAttributeNames
参数：
elementName - 要查询的元素的名称。
返回：
String 数组。

getAttributeValueType

public int getAttributeValueType(String elementName,
                                 String attrName)
从接口 IIOMetadataFormat 复制的描述
返回以 VALUE_ 开头的常量之一，指示指定元素中给定属性的值是任意值、被限制在指定范围中的值、被限制为一组枚举值之一，还是一个任意值的以空白分隔的列表。

指定者：
接口 IIOMetadataFormat 中的 getAttributeValueType
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
VALUE_* 常量之一。

getAttributeDataType

public int getAttributeDataType(String elementName,
                                String attrName)
从接口 IIOMetadataFormat 复制的描述
返回以 DATATYPE_ 开头的常量之一，指示指定元素中给定属性的值的格式和解释。如果 getAttributeValueType 返回 VALUE_LIST，则合法值为返回数据类型的值的以空白分隔的列表。

指定者：
接口 IIOMetadataFormat 中的 getAttributeDataType
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
DATATYPE_* 常量之一。

isAttributeRequired

public boolean isAttributeRequired(String elementName,
                                   String attrName)
从接口 IIOMetadataFormat 复制的描述
如果指定属性必须在指定元素中存在，则返回 true。

指定者：
接口 IIOMetadataFormat 中的 isAttributeRequired
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
如果属性必须存在，则返回 true。

getAttributeDefaultValue

public String getAttributeDefaultValue(String elementName,
                                       String attrName)
从接口 IIOMetadataFormat 复制的描述
如果指定属性不显式存在于指定元素中，则以 String 的形式返回其默认值；如果不存在可用的默认值，则返回 null。

指定者：
接口 IIOMetadataFormat 中的 getAttributeDefaultValue
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
包含默认值的 String，或者 null。

getAttributeEnumerations

public String[] getAttributeEnumerations(String elementName,
                                         String attrName)
从接口 IIOMetadataFormat 复制的描述
返回一个 String 数组，其包含指定元素中给定属性的合法枚举值。只应在 getAttributeValueType 返回 VALUE_ENUMERATION的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getAttributeEnumerations
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
String 数组。

getAttributeMinValue

public String getAttributeMinValue(String elementName,
                                   String attrName)
从接口 IIOMetadataFormat 复制的描述
返回属性的最小合法值。是否包括此值可由 getAttributeValueType 的值确定。该值以 String 的形式返回；其解释依赖于 getAttributeDataType 的值。只应在 getAttributeValueType 返回 VALUE_RANGE_* 的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getAttributeMinValue
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
包含属性的最小合法值的 String。

getAttributeMaxValue

public String getAttributeMaxValue(String elementName,
                                   String attrName)
从接口 IIOMetadataFormat 复制的描述
返回属性的最大合法值。是否包括此值可由 getAttributeValueType 的值确定。该值以 String 的形式返回；其解释依赖于 getAttributeDataType 的值。只应在 getAttributeValueType 返回 VALUE_RANGE_* 的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getAttributeMaxValue
参数：
elementName - 要查询的 String 形式的元素名称。
attrName - 要查询的属性的名称。
返回：
包含属性的最大合法值的 String。

getAttributeListMinLength

public int getAttributeListMinLength(String elementName,
                                     String attrName)
从接口 IIOMetadataFormat 复制的描述
返回可用于定义此属性的最小列表项数。属性本身被定义为一个包含多个由空白分隔的项的 String。只应在 getAttributeValueType 返回 VALUE_LIST 的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getAttributeListMinLength
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
属性的列表项的最小合法数。

getAttributeListMaxLength

public int getAttributeListMaxLength(String elementName,
                                     String attrName)
从接口 IIOMetadataFormat 复制的描述
返回可用于定义此属性的最大列表项数。Integer.MAX_VALUE 的值可用于指定不存在上限。属性本身被定义为一个包含多个由空白分隔的项的 String。只应在 getAttributeValueType 返回 VALUE_LIST 的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getAttributeListMaxLength
参数：
elementName - 要查询的元素的名称。
attrName - 要查询的属性的名称。
返回：
属性的列表项的最大合法数。

getAttributeDescription

public String getAttributeDescription(String elementName,
                                      String attrName,
                                      Locale locale)
返回包含指定属性的描述的 String，或者 null。如果可能，应将描述本地化为提供的 Locale。

默认实现利用在 ResourceBundle.getBundle 的注释中描述的应变机制，首先使用由 setResourceBaseName 设置的当前资源基本名称以及所提供的 Locale 查找 ResourceBundle。如果找到 ResourceBundle，则将后跟 "/" 字符再后跟属性名 (elementName + "/" + attrName) 的元素名称用作其 getString 方法的键，并返回结果。如果未找到 ResourceBundle 或者不存在这样的键，则返回 null。

如果 locale 为 null，则使用 Locale.getLocale 返回的当前默认 Locale。

指定者：
接口 IIOMetadataFormat 中的 getAttributeDescription
参数：
elementName - 元素的名称。
attrName - 属性的名称。
locale - 尝试进行本地化的 Locale，或者为 null。
返回：
属性描述。
抛出：
IllegalArgumentException - 如果 elementName 为 null 或者不是此格式的合法元素名称。
IllegalArgumentException - 如果 attrName 为 null 或者不是此元素的合法属性名称。
另请参见：
setResourceBaseName(java.lang.String)

getObjectValueType

public int getObjectValueType(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回以 VALUE_ 开头的枚举值之一，指示允许用于 Object 引用的值（枚举、范围或数组）的类型。如果在给定元素中无法存储任何对象值，则此方法的结果将为 VALUE_NONE。

合法值被定义为范围的 Object 引用必须实现 Comparable 接口。

指定者：
接口 IIOMetadataFormat 中的 getObjectValueType
参数：
elementName - 要查询的元素的名称。
返回：
VALUE_* 常量之一。
另请参见：
Comparable

getObjectClass

public Class<?> getObjectClass(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回存储在元素中的 Class 类型的 Object 引用。如果此元素不能包含 Object 引用，则抛出 IllegalArgumentException。如果类类型为数组，则此字段指示底层类类型（例如，对于 int 的数组，此方法将返回 int.class）。

合法值被定义为范围的 Object 引用必须实现 Comparable 接口。

指定者：
接口 IIOMetadataFormat 中的 getObjectClass
参数：
elementName - 要查询的元素的名称。
返回：
Class 对象。

getObjectDefaultValue

public Object getObjectDefaultValue(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回包含指定元素中 Object 引用的默认值的 Object。

指定者：
接口 IIOMetadataFormat 中的 getObjectDefaultValue
参数：
elementName - 要查询的元素的名称。
返回：
Object 对象。

getObjectEnumerations

public Object[] getObjectEnumerations(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回一个 Object 数组，该数组包含指定元素中 Object 引用的合法枚举值。只应在 getObjectValueType 返回 VALUE_ENUMERATION的情况下调用此方法。

与接受枚举值的节点关联的 Object 必须等于此方法返回的值之一，这里的等于是由 == 运算符（而不是 Object.equals 方法）定义的。

指定者：
接口 IIOMetadataFormat 中的 getObjectEnumerations
参数：
elementName - 要查询的元素的名称。
返回：
Object 数组。

getObjectMinValue

public Comparable<?> getObjectMinValue(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回指定元素中 Object 引用的最小合法值。是否包括此值可由 getObjectValueType 的值确定。只应在 getObjectValueType 返回以 VALUE_RANGE 开头的常量之一的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getObjectMinValue
参数：
elementName - 要查询的元素的名称。
返回：
属性的最小合法值。

getObjectMaxValue

public Comparable<?> getObjectMaxValue(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回指定元素中 Object 引用的最大合法值。是否包括此值可由 getObjectValueType 的值确定。只应在 getObjectValueType 返回以 VALUE_RANGE 开头的常量之一的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getObjectMaxValue
参数：
elementName - 要查询的元素的名称。
返回：
属性的最小合法值。

getObjectArrayMinLength

public int getObjectArrayMinLength(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回指定元素中可用于定义 Object 引用的最小数组元素数。只应在 getObjectValueType 返回 VALUE_LIST 的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getObjectArrayMinLength
参数：
elementName - 要查询的元素的名称。
返回：
Object 引用的最小有效数组长度。

getObjectArrayMaxLength

public int getObjectArrayMaxLength(String elementName)
从接口 IIOMetadataFormat 复制的描述
返回指定元素中可用于定义 Object 引用的最大数组元素数。Integer.MAX_VALUE 的值可用于指定不存在上限。只应在 getObjectValueType 返回 VALUE_LIST 的情况下调用此方法。

指定者：
接口 IIOMetadataFormat 中的 getObjectArrayMaxLength
参数：
elementName - 要查询的元素的名称。
返回：
Object 引用的最大有效数组长度。

getStandardFormatInstance

public static IIOMetadataFormat getStandardFormatInstance()
返回描述标准、插件无关的 javax.imageio_1.0 元数据文档格式的 IIOMetadataFormat 对象，该文档格式在 javax.imageio.metadata 包的注释中描述。

返回：
预定义的 IIOMetadataFormat 实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOMetadataNode (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.metadata
类 IIOMetadataNode

java.lang.Object
    继承者  javax.imageio.metadata.IIOMetadataNode
所有已实现的接口：
Element, Node, NodeList
public class IIOMetadataNode
extends Object
implements Element, NodeList

表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

此类不用于进行通用 XML 处理。尤其是，在 Image I/O API 中创建的 Element 节点与 SUN 的 org.w3.dom API 标准实现创建的节点不兼容。特别是该实现经过调整只能用于一些简单用途，它不能很好地进行密集处理。

在此实现中名称空间将被忽略。术语“标记名称”和“节点名称”始终被视为同义。

另请参见：
IIOMetadata.getAsTree(java.lang.String),
IIOMetadata.setFromTree(java.lang.String, org.w3c.dom.Node),
IIOMetadata.mergeTree(java.lang.String, org.w3c.dom.Node)

字段摘要
从接口 org.w3c.dom.Node 继承的字段
ATTRIBUTE_NODE, CDATA_SECTION_NODE, COMMENT_NODE, DOCUMENT_FRAGMENT_NODE, DOCUMENT_NODE, DOCUMENT_POSITION_CONTAINED_BY, DOCUMENT_POSITION_CONTAINS, DOCUMENT_POSITION_DISCONNECTED, DOCUMENT_POSITION_FOLLOWING, DOCUMENT_POSITION_IMPLEMENTATION_SPECIFIC, DOCUMENT_POSITION_PRECEDING, DOCUMENT_TYPE_NODE, ELEMENT_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, NOTATION_NODE, PROCESSING_INSTRUCTION_NODE, TEXT_NODE
构造方法摘要
IIOMetadataNode()
构造一个空的 IIOMetadataNode。
IIOMetadataNode(String nodeName)
构造一个具有给定节点名称的 IIOMetadataNode。
方法摘要
 Node appendChild(Node newChild)
将节点 newChild 添加到此节点子节点列表的末尾。
 Node cloneNode(boolean deep)
返回此节点的副本。
 short compareDocumentPosition(Node other)
就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。
 String getAttribute(String name)
通过名称获得属性值。
 Attr getAttributeNode(String name)
通过名称获得属性节点。
 Attr getAttributeNodeNS(String namespaceURI, String localName)
等效于 getAttributeNode(localName)。
 String getAttributeNS(String namespaceURI, String localName)
等效于 getAttribute(localName)。
 NamedNodeMap getAttributes()
包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。
 String getBaseURI()
此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。
 NodeList getChildNodes()
包含此节点的所有子节点的 NodeList。
 NodeList getElementsByTagName(String name)
以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。
 NodeList getElementsByTagNameNS(String namespaceURI, String localName)
等效于 getElementsByTagName(localName)。
 Object getFeature(String feature, String version)
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。
 Node getFirstChild()
此节点的第一个子节点；如果该节点没有子节点，则返回 null。
 Node getLastChild()
返回此节点的最后一个子节点；如果该节点没有子节点，则返回 null。
 int getLength()
列表中的节点数。
 String getLocalName()
等效于 getNodeName。
 String getNamespaceURI()
返回 null，因为不支持名称空间。
 Node getNextSibling()
返回此节点的下一个兄弟节点；如果该节点没有下一个兄弟节点，则返回 null。
 String getNodeName()
返回与此节点关联的节点名称。
 short getNodeType()
返回节点类型，其始终为 ELEMENT_NODE。
 String getNodeValue()
此节点的值，取决于其类型；参见上表。
 Document getOwnerDocument()
返回 null，因为 IIOMetadataNode 不属于任何 Document。
 Node getParentNode()
返回此节点的父节点。
 String getPrefix()
返回 null，因为不支持名称空间。
 Node getPreviousSibling()
返回此节点的上一个兄弟节点；如果该节点没有上一个兄弟节点，则返回 null。
 TypeInfo getSchemaTypeInfo()
与此元素相关的类型信息。
 String getTagName()
元素的名称。
 String getTextContent()
此属性返回此节点及其后代的文本内容。
 Object getUserData(String key)
检索与此节点上的某个键相关联的对象。
 Object getUserObject()
返回与此节点关联的 Object 值。
 boolean hasAttribute(String name)
当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。
 boolean hasAttributeNS(String namespaceURI, String localName)
等效于 hasAttribute(localName)。
 boolean hasAttributes()
返回此节点（如果它是一个元素）是否具有任何属性。
 boolean hasChildNodes()
如果此节点有子节点，则返回 true。
 Node insertBefore(Node newChild, Node refChild)
在现有子节点 refChild 之前插入节点 newChild。
 boolean isDefaultNamespace(String namespaceURI)
此方法检查指定的 namespaceURI 是否是默认名称空间。
 boolean isEqualNode(Node node)
测试两个节点是否相等。
 boolean isSameNode(Node node)
返回此节点是否是与给定节点相同的节点。
 boolean isSupported(String feature, String version)
返回 false，因为不支持 DOM 功能。
 Node item(int index)
返回集合中的第 index 个项。
 String lookupNamespaceURI(String prefix)
从此节点开始，查找与给定前缀相关的名称空间 URI。
 String lookupPrefix(String namespaceURI)
从此节点开始，查找与给定名称空间 URI 相关的前缀。
 void normalize()
不执行任何操作，因为 IIOMetadataNode 不包含 Text 子节点。
 void removeAttribute(String name)
通过名称移除一个属性。
 Attr removeAttributeNode(Attr oldAttr)
移除指定的属性节点。
 void removeAttributeNS(String namespaceURI, String localName)
等效于 removeAttribute(localName)。
 Node removeChild(Node oldChild)
从子节点列表中移除 oldChild 所指示的子节点，并将其返回。
 Node replaceChild(Node newChild, Node oldChild)
将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。
 void setAttribute(String name, String value)
添加一个新属性。
 Attr setAttributeNode(Attr newAttr)
添加新的属性节点。
 Attr setAttributeNodeNS(Attr newAttr)
等效于 setAttributeNode(newAttr)。
 void setAttributeNS(String namespaceURI, String qualifiedName, String value)
等效于 setAttribute(qualifiedName, value)。
 void setIdAttribute(String name, boolean isId)
如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。
 void setIdAttributeNode(Attr idAttr, boolean isId)
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
 void setIdAttributeNS(String namespaceURI, String localName, boolean isId)
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。
 void setNodeValue(String nodeValue)
此节点的值，取决于其类型；参见上表。
 void setPrefix(String prefix)
不执行任何操作，因为不支持名称空间。
 void setTextContent(String textContent)
此属性返回此节点及其后代的文本内容。
 Object setUserData(String key, Object data, UserDataHandler handler)
将对象与此节点上的键相关联。
 void setUserObject(Object userObject)
设置与此节点关联的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IIOMetadataNode

public IIOMetadataNode()
构造一个空的 IIOMetadataNode。

IIOMetadataNode

public IIOMetadataNode(String nodeName)
构造一个具有给定节点名称的 IIOMetadataNode。

参数：
nodeName - 以 String 形式表示的节点名称。
方法详细信息

getNodeName

public String getNodeName()
返回与此节点关联的节点名称。

指定者：
接口 Node 中的 getNodeName
返回：
以 String 形式表示的节点名称。

getNodeValue

public String getNodeValue()
                    throws DOMException
从接口 Node 复制的描述
此节点的值，取决于其类型；参见上表。当将它定义为 null 时，设置它无效，包括节点为只读的情况。

指定者：
接口 Node 中的 getNodeValue
抛出：
DOMException - DOMSTRING_SIZE_ERR: 在它返回的字符多于实现平台上 DOMString 变量中适合的字符时引发此异常。

setNodeValue

public void setNodeValue(String nodeValue)
                  throws DOMException
从接口 Node 复制的描述
此节点的值，取决于其类型；参见上表。当将它定义为 null 时，设置它无效，包括节点为只读的情况。

指定者：
接口 Node 中的 setNodeValue
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 当节点为只读且未将它定义为 null 时引发此异常。

getNodeType

public short getNodeType()
返回节点类型，其始终为 ELEMENT_NODE。

指定者：
接口 Node 中的 getNodeType
返回：
short 值 ELEMENT_NODE。

getParentNode

public Node getParentNode()
返回此节点的父节点。null 值指示该节点是它自己的树的根。要在现有树中添加节点，请使用 insertBefore、replaceChild 或 appendChild 方法之一。

指定者：
接口 Node 中的 getParentNode
返回：
以 Node 形式表示的父节点。
另请参见：
insertBefore(org.w3c.dom.Node, org.w3c.dom.Node),
replaceChild(org.w3c.dom.Node, org.w3c.dom.Node),
appendChild(org.w3c.dom.Node)

getChildNodes

public NodeList getChildNodes()
从接口 Node 复制的描述
包含此节点的所有子节点的 NodeList。如果不存在子节点，则这是不包含节点的 NodeList。

指定者：
接口 Node 中的 getChildNodes

getFirstChild

public Node getFirstChild()
此节点的第一个子节点；如果该节点没有子节点，则返回 null。

指定者：
接口 Node 中的 getFirstChild
返回：
以 Node 形式表示的第一个子节点；或者 null

getLastChild

public Node getLastChild()
返回此节点的最后一个子节点；如果该节点没有子节点，则返回 null。

指定者：
接口 Node 中的 getLastChild
返回：
以 Node 形式表示的最后一个子节点；或者 null。

getPreviousSibling

public Node getPreviousSibling()
返回此节点的上一个兄弟节点；如果该节点没有上一个兄弟节点，则返回 null。

指定者：
接口 Node 中的 getPreviousSibling
返回：
以 Node 形式表示的上一个兄弟节点；或者 null。

getNextSibling

public Node getNextSibling()
返回此节点的下一个兄弟节点；如果该节点没有下一个兄弟节点，则返回 null。

指定者：
接口 Node 中的 getNextSibling
返回：
以 Node 形式表示的下一个兄弟节点；或者 null。

getAttributes

public NamedNodeMap getAttributes()
从接口 Node 复制的描述
包含此节点的属性的 NamedNodeMap（如果它是 Element）；否则为 null。

指定者：
接口 Node 中的 getAttributes

getOwnerDocument

public Document getOwnerDocument()
返回 null，因为 IIOMetadataNode 不属于任何 Document。

指定者：
接口 Node 中的 getOwnerDocument
返回：
null。

insertBefore

public Node insertBefore(Node newChild,
                         Node refChild)
在现有子节点 refChild 之前插入节点 newChild。如果 refChild 为 null，则将 newChild 插入到子节点列表的末尾。

指定者：
接口 Node 中的 insertBefore
参数：
newChild - 要插入的 Node。
refChild - 引用 Node。
返回：
要插入的节点。
抛出：
IllegalArgumentException - 如果 newChild 为 null。

replaceChild

public Node replaceChild(Node newChild,
                         Node oldChild)
将子节点 oldChild 替换为子节点列表中的 newChild，并返回 oldChild 节点。

指定者：
接口 Node 中的 replaceChild
参数：
newChild - 要插入的 Node。
oldChild - 要替换的 Node。
返回：
替换的节点。
抛出：
IllegalArgumentException - 如果 newChild 为 null。

removeChild

public Node removeChild(Node oldChild)
从子节点列表中移除 oldChild 所指示的子节点，并将其返回。

指定者：
接口 Node 中的 removeChild
参数：
oldChild - 要移除的 Node。
返回：
移除的节点。
抛出：
IllegalArgumentException - 如果 oldChild 为 null。

appendChild

public Node appendChild(Node newChild)
将节点 newChild 添加到此节点子节点列表的末尾。

指定者：
接口 Node 中的 appendChild
参数：
newChild - 要插入的 Node。
返回：
添加的节点。
抛出：
IllegalArgumentException - 如果 newChild 为 null。

hasChildNodes

public boolean hasChildNodes()
如果此节点有子节点，则返回 true。

指定者：
接口 Node 中的 hasChildNodes
返回：
如果此节点有子节点，则返回 true。

cloneNode

public Node cloneNode(boolean deep)
返回此节点的副本。副本节点没有父节点（getParentNode 返回 null）。如果正在执行浅表复制（deep 为 false），则新节点将没有任何子节点或兄弟节点。如果正在执行深层复制，则新节点将形成完整复制的子树的根。

指定者：
接口 Node 中的 cloneNode
参数：
deep - 如果为 true，则在指定节点下递归式复制子树；如果为 false，则仅复制节点本身。
返回：
副本节点。

normalize

public void normalize()
不执行任何操作，因为 IIOMetadataNode 不包含 Text 子节点。

指定者：
接口 Node 中的 normalize

isSupported

public boolean isSupported(String feature,
                           String version)
返回 false，因为不支持 DOM 功能。

指定者：
接口 Node 中的 isSupported
参数：
feature - 一个 String，忽略该参数。
version - 一个 String，忽略该参数。
返回：
false。

getNamespaceURI

public String getNamespaceURI()
                       throws DOMException
返回 null，因为不支持名称空间。

指定者：
接口 Node 中的 getNamespaceURI
抛出：
DOMException

getPrefix

public String getPrefix()
返回 null，因为不支持名称空间。

指定者：
接口 Node 中的 getPrefix
返回：
null。
另请参见：
setPrefix(java.lang.String)

setPrefix

public void setPrefix(String prefix)
不执行任何操作，因为不支持名称空间。

指定者：
接口 Node 中的 setPrefix
参数：
prefix - 一个 String，忽略该参数。
另请参见：
getPrefix()

getLocalName

public String getLocalName()
等效于 getNodeName。

指定者：
接口 Node 中的 getLocalName
返回：
以 String 形式表示的节点名称。

getTagName

public String getTagName()
从接口 Element 复制的描述
元素的名称。如果 Node.localName 与 null 不同，则此属性为一个限定名称。例如，在以下示例中：
 <elementExample id="demo"> ...
 </elementExample> ,
tagName 具有值 "elementExample"。注意，这在 XML 中是保留大小写的，DOM 中的所有操作也是这样。HTML DOM 以规范的大写形式返回 HTML 元素的 tagName，而不考虑源 HTML 文档中的大小写形式。

指定者：
接口 Element 中的 getTagName

getAttribute

public String getAttribute(String name)
从接口 Element 复制的描述
通过名称获得属性值。

指定者：
接口 Element 中的 getAttribute
参数：
name - 要获得的属性名称。
返回：
字符串形式的 Attr 值；如果该属性没有指定值或默认值，则返回空字符串。

getAttributeNS

public String getAttributeNS(String namespaceURI,
                             String localName)
等效于 getAttribute(localName)。

指定者：
接口 Element 中的 getAttributeNS
参数：
namespaceURI - 要获得的属性的名称空间 URI。
localName - 要获得的属性的本地名称。
返回：
字符串形式的 Attr 值；如果该属性没有指定值或默认值，则返回空字符串。
另请参见：
setAttributeNS(java.lang.String, java.lang.String, java.lang.String)

setAttribute

public void setAttribute(String name,
                         String value)
从接口 Element 复制的描述
添加一个新属性。如果具有该名称的属性已经出现在元素中，则将其值更改为值参数的值。此值为简单的字符串；在设置它时没有对它进行解析。因此，将任何标记（如作为实体引用而被识别的语法）视为字面值文本，并且需要在写出时由实现适当转义。为了分配包含实体引用的属性值，用户必须创建一个 Attr 节点，加上所有 Text 和 EntityReference 节点，构建适当的子树，并将它作为属性值，通过 setAttributeNode 方法来分配。
要设置具有限定名称和名称空间 URI 的属性，使用 setAttributeNS 方法。

指定者：
接口 Element 中的 setAttribute
参数：
name - 要创建或更改的属性名称。
value - 以字符串形式设置的值。

setAttributeNS

public void setAttributeNS(String namespaceURI,
                           String qualifiedName,
                           String value)
等效于 setAttribute(qualifiedName, value)。

指定者：
接口 Element 中的 setAttributeNS
参数：
namespaceURI - 要创建或更改的属性的名称空间 URI。
qualifiedName - 要创建或更改的属性的限定名称。
value - 以字符串形式设置的值。
另请参见：
getAttributeNS(java.lang.String, java.lang.String)

removeAttribute

public void removeAttribute(String name)
从接口 Element 复制的描述
通过名称移除一个属性。如果被移除属性的默认值在 DTD 中定义，则新的属性值将在可用时随该默认值以及相应名称空间 URI、本地名称和前缀立即出现。类似地，实现可以处理其他模式的默认值，但应用程序应该使用 Document.normalizeDocument() 来保证此信息最新。
如果找不到具有此名称的属性，则此方法无效。
要通过本地名称和名称空间 URI 移除属性，使用 removeAttributeNS 方法。

指定者：
接口 Element 中的 removeAttribute
参数：
name - 要移除的属性的名称。

removeAttributeNS

public void removeAttributeNS(String namespaceURI,
                              String localName)
等效于 removeAttribute(localName)。

指定者：
接口 Element 中的 removeAttributeNS
参数：
namespaceURI - 要移除的属性的名称空间 URI。
localName - 要移除的属性的本地名称。

getAttributeNode

public Attr getAttributeNode(String name)
从接口 Element 复制的描述
通过名称获得属性节点。
要通过限定名称和名称空间 URI 获得属性节点，使用 getAttributeNodeNS 方法。

指定者：
接口 Element 中的 getAttributeNode
参数：
name - 要获得的属性名称 (nodeName)。
返回：
返回具有指定名称 (nodeName) 的 Attr 节点；如果没有这样的属性，则返回 null。

getAttributeNodeNS

public Attr getAttributeNodeNS(String namespaceURI,
                               String localName)
等效于 getAttributeNode(localName)。

指定者：
接口 Element 中的 getAttributeNodeNS
参数：
namespaceURI - 要获得的属性的名称空间 URI。
localName - 要获得的属性的本地名称。
返回：
具有特定属性名称和名称空间 URI 的 Attr 节点；如果没有这样的属性，则返回 null。
另请参见：
setAttributeNodeNS(org.w3c.dom.Attr)

setAttributeNode

public Attr setAttributeNode(Attr newAttr)
                      throws DOMException
从接口 Element 复制的描述
添加新的属性节点。如果具有该名称 (nodeName) 的属性已经出现在元素中，则用新属性替换它。用自身替换属性节点无效。
要添加具有限定名称和名称空间 URI 的新属性节点，使用 setAttributeNodeNS 方法。

指定者：
接口 Element 中的 setAttributeNode
参数：
newAttr - 要添加到属性列表的 Attr 节点。
返回：
如果用 newAttr 属性替换现有属性，则返回被替换的 Attr 节点；否则返回 null。
抛出：
DOMException - WRONG_DOCUMENT_ERR: 如果 newAttr 是从不同的文档创建的，不是从创建该元素的文档创建的，则引发此异常。
NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。
INUSE_ATTRIBUTE_ERR: 如果 newAttr 已经是另一个 Element 对象的属性，则引发此异常。DOM 用户必须显式地克隆 Attr 节点，以便在其他元素中重新使用它们。

setAttributeNodeNS

public Attr setAttributeNodeNS(Attr newAttr)
等效于 setAttributeNode(newAttr)。

指定者：
接口 Element 中的 setAttributeNodeNS
参数：
newAttr - 要添加到属性列表的 Attr 节点。
返回：
如果用 newAttr 属性替换具有相同本地名称和名称空间 URI 的现有属性，则返回被替换的 Attr 节点；否则返回 null。
另请参见：
getAttributeNodeNS(java.lang.String, java.lang.String)

removeAttributeNode

public Attr removeAttributeNode(Attr oldAttr)
从接口 Element 复制的描述
移除指定的属性节点。如果在 DTD 中定义了被移除 Attr 节点的默认值，则新的节点将在可用时随该默认值以及相应名称空间 URI、本地名称和前缀一起立即出现。类似地，实现可以处理其他模式的默认值，但应用程序应该使用 Document.normalizeDocument() 来保证此信息最新。

指定者：
接口 Element 中的 removeAttributeNode
参数：
oldAttr - 从属性列表中移除的 Attr 节点。
返回：
被移除的 Attr 节点。

getElementsByTagName

public NodeList getElementsByTagName(String name)
从接口 Element 复制的描述
以文档顺序返回具有给定标记名称的所有后代 Elements 的 NodeList。

指定者：
接口 Element 中的 getElementsByTagName
参数：
name - 要匹配的标记的名称。特殊值 "*" 匹配所有标记。
返回：
匹配的 Element 节点列表。

getElementsByTagNameNS

public NodeList getElementsByTagNameNS(String namespaceURI,
                                       String localName)
等效于 getElementsByTagName(localName)。

指定者：
接口 Element 中的 getElementsByTagNameNS
参数：
namespaceURI - 要匹配的元素的名称空间 URI。特殊值 "*" 匹配所有名称空间。
localName - 要匹配的元素的本地名称。特殊值 "*" 匹配所有本地名称。
返回：
包含所有匹配的 Elements 的新 NodeList 对象。

hasAttributes

public boolean hasAttributes()
从接口 Node 复制的描述
返回此节点（如果它是一个元素）是否具有任何属性。

指定者：
接口 Node 中的 hasAttributes
返回：
如果此节点具有任何属性，则返回 true；否则返回 false。

hasAttribute

public boolean hasAttribute(String name)
从接口 Element 复制的描述
当具有给定名称的属性在此元素上被指定一个值或具有默认值时，返回 true；否则返回 false。

指定者：
接口 Element 中的 hasAttribute
参数：
name - 要查找的属性名称。
返回：
如果具有给定名称的属性在此元素上被指定一个值或具有默认值，则返回 true；否则返回 false。

hasAttributeNS

public boolean hasAttributeNS(String namespaceURI,
                              String localName)
等效于 hasAttribute(localName)。

指定者：
接口 Element 中的 hasAttributeNS
参数：
namespaceURI - 要查找的属性的名称空间 URI。
localName - 要查找的属性的本地名称。
返回：
如果具有给定本地名称和名称空间 URI 的属性在此元素上被指定一个值或具有默认值，则返回 true；否则返回 false。

getLength

public int getLength()
从接口 NodeList 复制的描述
列表中的节点数。有效子节点索引的范围是 0 到 length-1（包含此值）。

指定者：
接口 NodeList 中的 getLength

item

public Node item(int index)
从接口 NodeList 复制的描述
返回集合中的第 index 个项。如果 index 大于或等于此列表中的节点数，则返回 null。

指定者：
接口 NodeList 中的 item
参数：
index - 集合中的索引。
返回：
返回该 NodeList 中 index 位置处的节点；如果索引是无效索引，则返回 null。

getUserObject

public Object getUserObject()
返回与此节点关联的 Object 值。

返回：
用户 Object。
另请参见：
setUserObject(java.lang.Object)

setUserObject

public void setUserObject(Object userObject)
设置与此节点关联的值。

参数：
userObject - 用户 Object。
另请参见：
getUserObject()

setIdAttribute

public void setIdAttribute(String name,
                           boolean isId)
                    throws DOMException
从接口 Element 复制的描述
如果参数 isId 为 true，则此方法将指定的属性声明为用于确定用户的 ID 属性。此方法影响 Attr.isId 的值和 Document.getElementById 的行为，但不更改可能正在使用的任何模式；需要特别指出的是，此方法不影响指定 Attr 节点的 Attr.schemaTypeInfo。使用参数 isId 的值 false 来取消将属性声明为用户确定的 ID 属性。
要通过本地名称和名称空间 URI 指定属性，使用 setIdAttributeNS 方法。

指定者：
接口 Element 中的 setIdAttribute
参数：
name - 属性名称。
isId - 属性是否是 ID 类型。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR:如果指定的节点不是此元素的属性，则引发此异常。

setIdAttributeNS

public void setIdAttributeNS(String namespaceURI,
                             String localName,
                             boolean isId)
                      throws DOMException
从接口 Element 复制的描述
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。此方法影响 Attr.isId 的值和 Document.getElementById 的行为，但不更改可能正在使用的任何模式；需要特别指出的是，此方法不影响指定 Attr 节点的 Attr.schemaTypeInfo。使用参数 isId 的值 false 来取消将属性声明为用户确定的 ID 属性。

指定者：
接口 Element 中的 setIdAttributeNS
参数：
namespaceURI - 属性的名称空间 URI。
isId - 属性是否是 ID 类型。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR:如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果指定的节点不是此元素的属性，则引发此异常。

setIdAttributeNode

public void setIdAttributeNode(Attr idAttr,
                               boolean isId)
                        throws DOMException
从接口 Element 复制的描述
如果参数 isId 为 true，则此方法将指定的属性声明为用户确定的 ID 属性。此方法影响 Attr.isId 的值和 Document.getElementById 的行为，但不更改可能正在使用的任何模式；需要特别指出的是，此方法不影响指定 Attr 节点的 Attr.schemaTypeInfo。使用参数 isId 的值 false 来取消将属性声明为用户确定的 ID 属性。

指定者：
接口 Element 中的 setIdAttributeNode
参数：
idAttr - 属性节点。
isId - 属性是否是 ID 类型。
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 如果此节点为只读的，则引发此异常。
NOT_FOUND_ERR: 如果指定的节点不是此元素的属性，则引发此异常。

getSchemaTypeInfo

public TypeInfo getSchemaTypeInfo()
从接口 Element 复制的描述
与此元素相关的类型信息。

指定者：
接口 Element 中的 getSchemaTypeInfo

setUserData

public Object setUserData(String key,
                          Object data,
                          UserDataHandler handler)
从接口 Node 复制的描述
将对象与此节点上的键相关联。该对象以后可以通过使用相同键的调用 getUserData 从此节点检索到。

指定者：
接口 Node 中的 setUserData
参数：
key - 将该对象与其关联的键。
data - 与给定键相关联的对象；为 null 时表示移除与任何现有的与该键的关联。
handler - 与该键关联的处理程序，或 null。
返回：
返回以前与此节点上的给定键关联的 DOMUserData；如果没有，则返回 null。

getUserData

public Object getUserData(String key)
从接口 Node 复制的描述
检索与此节点上的某个键相关联的对象。必须首先通过使用相同键的调用 setUserData 将该对象设置到此节点。

指定者：
接口 Node 中的 getUserData
参数：
key - 该对象所关联的键。
返回：
返回与此节点上的给定键关联的 DOMUserData；如果没有，则返回 null。

getFeature

public Object getFeature(String feature,
                         String version)
从接口 Node 复制的描述
此方法返回一个特定的对象，该对象实现指定功能或版本的特定 API，如下所述。该特殊对象也可以通过使用特定于绑定的强制转换方法获得，但不是必须期望这样，如文中讨论的那样。此方法还允许实现提供不支持 Node 接口的特殊对象。

指定者：
接口 Node 中的 getFeature
参数：
feature - 所请求的功能的名称。注意，追加到功能名称的任何加号 "+" 将被忽略，因为它在此方法的上下文中无关紧要。
version - 这是要测试的功能版本号。
返回：
返回实现指定功能和版本的特定 API 的对象（如果有）；如果不存在实现与该功能相关的接口的对象，则返回 null。如果此方法返回的 DOMObject 实现 Node 接口，则它必须委托给主要核心 Node 且不返回与主要核心 Node 不一致的结果，如属性、子节点，等等。

isSameNode

public boolean isSameNode(Node node)
从接口 Node 复制的描述
返回此节点是否是与给定节点相同的节点。
此方法提供一种方法来确定由实现返回的两个 Node 引用是否引用同一个对象。当两个 Node 引用引用同一个对象时，即使是通过代理，也可能完全可交换地使用这些引用，例如所有属性都有相同的值且在任何引用上调用同一个 DOM 方法总是起完全相同的作用。

指定者：
接口 Node 中的 isSameNode
参数：
node - 要测试的节点。
返回：
如果节点相同，则返回 true；否则，返回 false。

isEqualNode

public boolean isEqualNode(Node node)
从接口 Node 复制的描述
测试两个节点是否相等。
此方法测试节点的相等性，不是测试是否相同（即两个节点是否为对同一对象的引用），相同性可以使用 Node.isSameNode() 测试。所有相同的节点也将相等，尽管反之则不然。
当且仅当满足以下条件时，两个节点才相等：
  • 这两个节点属于同一类型。
  • 以下字符串属性相等：nodeName、localName、namespaceURI、prefix、nodeValue。也就是说：它们都为 null，或者它们具有相同的长度且是字符相等的字符。
  • attributes NamedNodeMaps 相等。也就是说：它们都为 null，或者它们具有相同的长度，且对于一个映射中存在的每个节点来说，相应在另一个映射中有一个节点并且相等，尽管不是必须在同一个索引处。
  • childNodes NodeLists 相等。也就是说：它们都为 null，或者它们具有相同的长度且在同一索引处包含相等的节点。注意，规范化可以影响相等性；要避免这种情况，应该在比较之前标准化这些节点。

两个 DocumentType 节点要是相等，还必须满足以下条件：
  • 以下字符串属性相等：publicId、systemId、internalSubset。
  • entities NamedNodeMaps 相等。
  • notations NamedNodeMaps 相等。

另一方面，以下内容不影响相等性：ownerDocument、baseURI 和 parentNode 属性；Attr 节点的 specified 属性；Attr 和 Element 节点的 schemaTypeInfo 属性；Text 节点的 Text.isElementContentWhitespace 属性；以及在节点上注册的任何用户数据和事件侦听器。

注：通常，在相等性检查的考虑中，上面描述中未提到的任何情况都是无关紧要的。注意，此规范的未来版本可能考虑更多属性，并且期望遵守此规范的实现进行相应的更新。

指定者：
接口 Node 中的 isEqualNode
参数：
node - 与其比较相等性的节点。
返回：
如果节点相等，则返回 true；否则，返回 false。

lookupNamespaceURI

public String lookupNamespaceURI(String prefix)
从接口 Node 复制的描述
从此节点开始，查找与给定前缀相关的名称空间 URI。
有关此方法使用的算法的详细信息，请参见。

指定者：
接口 Node 中的 lookupNamespaceURI
参数：
prefix - 要查找的前缀。如果此参数为 null，则此方法将返回默认的名称空间 URI（如果有）。
返回：
返回相关的名称空间 URI；如果未找到，则返回 null。

isDefaultNamespace

public boolean isDefaultNamespace(String namespaceURI)
从接口 Node 复制的描述
此方法检查指定的 namespaceURI 是否是默认名称空间。

指定者：
接口 Node 中的 isDefaultNamespace
参数：
namespaceURI - 要查找的名称空间 URI。
返回：
如果指定的 namespaceURI 为默认名称空间，则返回 true；否则，返回 false。

lookupPrefix

public String lookupPrefix(String namespaceURI)
从接口 Node 复制的描述
从此节点开始，查找与给定名称空间 URI 相关的前缀。此方法忽略默认名称空间声明。
参见此方法使用的算法的详细信息。

指定者：
接口 Node 中的 lookupPrefix
参数：
namespaceURI - 要查找的名称空间 URI。
返回：
如果已找到，则返回相关的名称空间前缀；如果未找到任何前缀，则返回 null。如果一个以上的前缀与名称空间前缀相关，则返回的名称空间前缀与实现有关。

getTextContent

public String getTextContent()
                      throws DOMException
从接口 Node 复制的描述
此属性返回此节点及其后代的文本内容。将它定义为 null 时，设置它无效。设置后，移除此节点可能有的任何可能的子节点，并且如果新字符串不为空或 null，则用包含此属性设置的字符串的单个 Text 节点替换。
获取后，不执行序列化，且返回的字符串不包含任何标记。不执行空白规范化且在元素内容中返回的字符串不包含空白（参见属性 Text.isElementContentWhitespace）。类似地，设置后，也不执行解析，且以纯文本内容形式采用输入字符串。
根据下面定义的节点类型，返回的字符串由此节点的文本内容生成：
节点类型 | 内容
ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | 串接每个子节点的 textContent 属性值，不包括 COMMENT_NODE 和 PROCESSING_INSTRUCTION_NODE 节点。如果该节点没有子节点，则这是空字符串。
TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null

指定者：
接口 Node 中的 getTextContent
抛出：
DOMException - DOMSTRING_SIZE_ERR:在它返回的字符多于实现平台上 DOMString 变量中适合的字符时引发此异常。

setTextContent

public void setTextContent(String textContent)
                    throws DOMException
从接口 Node 复制的描述
此属性返回此节点及其后代的文本内容。将它定义为 null 时，设置它无效。设置后，移除此节点可能有的任何可能的子节点，并且，如果新字符串不为空或 null，则用包含此属性设置的字符串的单个 Text 节点替换。
获取后，不执行序列化，且返回的字符串不包含任何标记。不执行空白规范化，且返回的字符串在元素内容中不包含空白（参见属性 Text.isElementContentWhitespace）。类似地，设置后，也不执行解析，且以纯文本内容形式采用输入字符串。
根据下面定义的节点类型，返回的字符串由此节点的文本内容生成：
节点类型 | 内容
ELEMENT_NODE, ATTRIBUTE_NODE, ENTITY_NODE, ENTITY_REFERENCE_NODE, DOCUMENT_FRAGMENT_NODE | 串接每个子节点的 textContent 属性值，不包括 COMMENT_NODE 和 PROCESSING_INSTRUCTION_NODE 节点。如果该节点没有子节点，则这是空字符串。
TEXT_NODE, CDATA_SECTION_NODE, COMMENT_NODE, PROCESSING_INSTRUCTION_NODE | nodeValue
DOCUMENT_NODE, DOCUMENT_TYPE_NODE, NOTATION_NODE | null

指定者：
接口 Node 中的 setTextContent
抛出：
DOMException - NO_MODIFICATION_ALLOWED_ERR: 节点为只读的时引发此异常。

compareDocumentPosition

public short compareDocumentPosition(Node other)
                              throws DOMException
从接口 Node 复制的描述
就节点在文档中的位置并按照文档的顺序，比较引用节点（即在其上调用此方法的节点）与作为参数传递的节点。

指定者：
接口 Node 中的 compareDocumentPosition
参数：
other - 与引用节点比较的节点。
返回：
返回相对于引用节点如何定位节点。
抛出：
DOMException - NOT_SUPPORTED_ERR: 当被比较的节点来自不同的 DOM 实现，未调整该 DOM 实现以返回一致的特定于实现的结果时。

getBaseURI

public String getBaseURI()
从接口 Node 复制的描述
此节点的绝对基 URI；如果实现不能获得绝对 URI，则为 null。此值如描述的那样计算。但是，当 Document 支持功能 "HTML" [DOM Level 2 HTML] 时，首先使用 HTML BASE 元素（如果有）的 href 属性的值计算基 URI；否则，使用 Document 接口中的 documentURI 属性的值计算。

指定者：
接口 Node 中的 getBaseURI
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.imageio.metadata (Java 2 Platform SE 6)

 javax.imageio.metadata
接口
IIOMetadataController
IIOMetadataFormat
类
IIOMetadata
IIOMetadataFormatImpl
IIOMetadataNode
异常
IIOInvalidTreeException


javax.imageio.metadata (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.imageio.metadata

用于处理读写元数据的 Java Image I/O API 的包。

请参见：
描述

接口摘要
IIOMetadataController | 该接口将由可以确定 IIOMetadata 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
IIOMetadataFormat | 描述从 IIOMetadata.getAsTree 返回并传递给 IIOMetadata.setFromTree 和 mergeTree 的元数据文档结构的对象。

类摘要
IIOMetadata | 将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。
IIOMetadataFormatImpl | 提供 IIOMetadataFormat 接口的可重用实现的具体类。
IIOMetadataNode | 表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

异常摘要
IIOInvalidTreeException 当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

软件包 javax.imageio.metadata 的描述

用于处理读写元数据的 Java Image I/O API 的包。

读取图像时，其每个流和每个图像元数据都可以作为 IIOMetadata 对象使用。此对象的内部特定于创建它的插件。其内容能够以作为 IIOMetadataNode 对象的树实现的 XML Document 的形式访问。

写入图像时，其元数据可以通过定义或修改 IIOMetadata 对象设置。这种对象可以从（javax.imageio 包中的）ImageWriter 或 ImageTranscoder 获得。获得这种对象后，就可以通过修改由 IIOMetadataNode 组成的 Document 来设置其内容。可以选择是否使用 IIOMetadataFormat 对象来描述文档格式。

XML Document 中所含元数据的格式由一个字符串标识，该字符串作为 IIOMetadataNode 对象的树的根节点出现。此字符串包含版本号，例如，"javax_imageio_jpeg_image_1.0"。Reader 和 writer 可能支持同一基本格式的多个版本号，Image I/O API 的方法可以通过将字符串传递给用于获取 IIOMetadata 对象的方法/构造方法来指定要使用的版本。在某些情况下，较新的版本可能与按较旧版本编写的程序不完全兼容（有关示例，请参见下文 JPEG 元数据用法说明的 Native Metadata Format 一节）。

插件可以选择支持标准（插件无关）格式。此格式不提供元数据的无损耗编码，但是允许以通用方式访问部分元数据。

每个标准插件都支持所谓的“本机”元数据格式，该格式以无损耗的方式编码其元数据：

  • GIF 元数据
  • JPEG 元数据
  • PNG 元数据
  • BMP 元数据
  • WBMP 元数据

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.imageio.metadata 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.metadata 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.imageio.metadata.IIOMetadata
    • javax.imageio.metadata.IIOMetadataFormatImpl (implements javax.imageio.metadata.IIOMetadataFormat)
    • javax.imageio.metadata.IIOMetadataNode (implements org.w3c.dom.Element, org.w3c.dom.NodeList)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.imageio.IIOException
            • javax.imageio.metadata.IIOInvalidTreeException

接口分层结构

  • javax.imageio.metadata.IIOMetadataController
  • javax.imageio.metadata.IIOMetadataFormat
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.imageio.metadata 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.metadata
的使用

使用 javax.imageio.metadata 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 使用的 javax.imageio.metadata 中的类
IIOMetadata
将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。

javax.imageio.metadata 使用的 javax.imageio.metadata 中的类
IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。
IIOMetadata
将由表示与图像和流关联的元数据（非图像数据）的对象扩展的抽象类。
IIOMetadataController
该接口将由可以确定 IIOMetadata 对象设置值（通过提供一个 GUI 来从用户那里获取值或其他方式）的对象实现。
IIOMetadataFormat
描述从 IIOMetadata.getAsTree 返回并传递给 IIOMetadata.setFromTree 和 mergeTree 的元数据文档结构的对象。
IIOMetadataNode
表示元数据树中节点的类，该类实现 org.w3c.dom.Element 接口，还允许通过 getUserObject 和 setUserObject 方法存储非文本对象。

javax.imageio.spi 使用的 javax.imageio.metadata 中的类
IIOMetadataFormat
描述从 IIOMetadata.getAsTree 返回并传递给 IIOMetadata.setFromTree 和 mergeTree 的元数据文档结构的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BMP Metadata Format Specification

The XML schema for the native image metadata format is as follows:
<?xml version="1.0" encoding="UTF-8"?>

<!-- Schema for BMP native image metadata format. -->

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            xmlns="http://javax.imageio.plugins"
            targetNamespace="http://javax.imageio.plugins">

  <!-- Coordinates of a point in the CIE XYZ color space. -->
  <xsd:complexType name="XYZPoint">
    <xsd:sequence>
      <xsd:element name="X" type="xsd:double"/>
      <xsd:element name="Y" type="xsd:double"/>
      <xsd:element name="Z" type="xsd:double"/>
    </xsd:sequence>
  </xsd:complexType>

  <!-- BMP Schema 1.0 root element. -->
  <xsd:element name="javax_imageio_bmp_1.0">
    <xsd:complexType>
      <xsd:sequence>

        <!-- BMP version string -->
        <xsd:element name="BMPVersion" type="xsd:string"/>

        <!-- Bitmap width -->
        <xsd:element name="Width" type="xsd:unsignedInt"/>

        <!-- Bitmap height -->
        <xsd:element name="Height" type="xsd:unsignedInt"/>

        <!-- Number of bits per pixel -->
        <xsd:element name="BitsPerPixel" type="xsd:unsignedShort"/>

        <!-- Compression type -->
        <xsd:element name="Compression" type="xsd:unsignedInt" minOccurs="0"/>

        <!-- Image size in bytes -->
        <xsd:element name="ImageSize" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- Resolution in pixels per unit distance -->
        <xsd:element name="PixelsPerMeter" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="X" type="xsd:unsignedInt"/>
              <xsd:element name="Y" type="xsd:unsignedInt"/>
            </xsd:sequence>
      </xsd:complexType>
        </xsd:element> <!-- PixelsPerMeter -->

    <!-- Number of color indexes in the color table actually used -->
        <xsd:element name="ColorsUsed" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- Number of color indexes considered important for display -->
        <xsd:element name="ColorsImportant" type="xsd:unsignedInt"
             minOccurs="0"/>

    <!-- Color masks; present for BI_BITFIELDS compression only -->
        <xsd:element name="Mask" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="xsd:unsignedInt"/>
              <xsd:element name="Green" type="xsd:unsignedInt"/>
              <xsd:element name="Blue" type="xsd:unsignedInt"/>
              <xsd:element name="Alpha" type="xsd:unsignedInt" minOccurs="0"/>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

        <!-- Color space  -->
        <xsd:element name="ColorSpaceType" type="xsd:unsignedInt"
             minOccurs="0"/>

    <!-- CIE XYZ for the LCS_CALIBRATED_RGB color space -->
        <xsd:element name="CIEXYZEndpoints" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="XYZPoint"/>
              <xsd:element name="Green" type="XYZPoint"/>
              <xsd:element name="Blue" type="XYZPoint"/>
            </xsd:sequence>
      </xsd:complexType>
        </xsd:element>

    <!-- Gamma values for the LCS_CALIBRATED_RGB color space -->
        <xsd:element name="Gamma" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="Red" type="xsd:unsignedInt"/>
              <xsd:element name="Green" type="xsd:unsignedInt"/>
              <xsd:element name="Blue" type="xsd:unsignedInt"/>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

    <!-- Rendering intent -->
        <xsd:element name="Intent" type="xsd:unsignedInt" minOccurs="0"/>

    <!-- The image colormap -->
        <xsd:element name="Palette" minOccurs="0">
      <xsd:complexType>
            <xsd:sequence>
              <xsd:element name="PaletteEntry">
            <xsd:complexType>
                  <xsd:sequence>
                    <xsd:element name="Red" type="xsd:unsignedByte"/>
                    <xsd:element name="Green" type="xsd:unsignedByte"/>
                    <xsd:element name="Blue" type="xsd:unsignedByte"/>
                    <xsd:element name="Alpha" type="xsd:unsignedByte" minOccurs="0"/>
                  </xsd:sequence>
            </xsd:complexType>
              </xsd:element>
            </xsd:sequence>
      </xsd:complexType>
    </xsd:element>

      </xsd:sequence>
    </xsd:complexType>
  </xsd:element> <!-- bmp_image_1.0 -->

</xsd:schema>
@since 1.5


GIF Metadata Format Specification

GIF Stream Metadata Format Specification

The GIF stream metadata format encodes the information stored in the per-file header, namely the file version, logical screen descriptor, and the global color table.

The logical screen descriptor describes the overall width and height of an animated file, as well as information about the color resolution (number of bits per pixel) and pixel aspect ratio.

The global color table contains a color lookup table that is used for images that do not have their own local color table.

<!DOCTYPE "javax_imageio_gif_stream_1.0" [

  <!ELEMENT "javax_imageio_gif_stream_1.0" (Version?,
    LogicalScreenDescriptor?, GlobalColorTable?)>

    <!ELEMENT "Version" EMPTY>
      <!-- The file version, either 87a or 89a -->
      <!ATTLIST "Version" "value" ("87a" | "89a") #REQUIRED>
        <!-- The version string -->

    <!ELEMENT "LogicalScreenDescriptor" EMPTY>
      <!-- The logical screen descriptor, except for the global color table -->
      <!ATTLIST "LogicalScreenDescriptor" "logicalScreenWidth" #CDATA
         #REQUIRED>
        <!-- The width in pixels of the whole picture -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "logicalScreenHeight" #CDATA
         #REQUIRED>
        <!-- The height in pixels of the whole picture -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "colorResolution" #CDATA
         #REQUIRED>
        <!-- The number of bits of color resolution, beteen 1 and 8 -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 8 (inclusive) -->
      <!ATTLIST "LogicalScreenDescriptor" "pixelAspectRatio" #CDATA
         #REQUIRED>
        <!-- If 0, indicates square pixels, else W/H = (value + 16)/64 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "GlobalColorTable" (ColorTableEntry)*>
      <!-- The global color table -->
      <!-- Min children: 2 -->
      <!-- Max children: 256 -->
      <!ATTLIST "GlobalColorTable" "sizeOfGlobalColorTable" ("2" |
        "4" | "8" | "16" | "32" | "64" | "128" | "256") #REQUIRED>
        <!-- The number of entries in the global color table -->
      <!ATTLIST "GlobalColorTable" "backgroundColorIndex" #CDATA
         #REQUIRED>
        <!-- The index of the color table entry to be used as a background -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->
      <!ATTLIST "GlobalColorTable" "sortFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the global color table is sorted by frequency -->

      <!ELEMENT "ColorTableEntry" EMPTY>
        <!-- A global color table entry -->
        <!ATTLIST "ColorTableEntry" "index" #CDATA #REQUIRED>
          <!-- The index of the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "red" #CDATA #REQUIRED>
          <!-- The red value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "green" #CDATA #REQUIRED>
          <!-- The green value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
]>

GIF Image Metadata Format Specification

The GIF image metadata format encodes the image descriptor, local color table, and extension information assciated with a single image within a GIF file, typically a frame of an animation.

The image description contains the offset of the frame within the logical screen described in the stream metadata, as well as the width and height of the frame and whether it is used interlaced encoding.

The local color table, if present, supersedes the global color table for the frame at hand.

The graphic control extension contains information on how the frame is to be incorporated into the animation. The disposal method indicates whether the current frame should remain in place (doNotDispose), be restored to the backgound color as specified in the stream metadata (restoreToBackgroundColor), or be restored to the previous frame contents (restoreToPrevious) prior to displaying the subsequent frame.

The user input flag indicates whether the animation should pause for user input before advancing to the next frame. The transparent color flag and index indicate a color index for which pixels of the frame should not be drawn. The delay time indicates how long the frame should be displayed, in hundredths of a second. If the user input flag is set and the delay time is 0, the frame is intended to be advanced only on user input.

<!DOCTYPE "javax_imageio_gif_image_1.0" [

  <!ELEMENT "javax_imageio_gif_image_1.0" (ImageDescriptor?,
    LocalColorTable?, GraphicControlExtension?, PlainTextExtension?,
    ApplicationExtensions?, CommentExtensions?)>

    <!ELEMENT "ImageDescriptor" EMPTY>
      <!-- The image descriptor -->
      <!ATTLIST "ImageDescriptor" "imageLeftPosition" #CDATA #REQUIRED>
        <!-- The X offset of the image relative to the screen origin -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageTopPosition" #CDATA #REQUIRED>
        <!-- The Y offset of the image relative to the screen origin -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageWidth" #CDATA #REQUIRED>
        <!-- The width of the image -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "imageHeight" #CDATA #REQUIRED>
        <!-- The height of the image -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "ImageDescriptor" "interlaceFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the image is stored using interlacing -->

    <!ELEMENT "LocalColorTable" (ColorTableEntry)*>
      <!-- The local color table -->
      <!-- Min children: 2 -->
      <!-- Max children: 256 -->
      <!ATTLIST "LocalColorTable" "sizeOfLocalColorTable" ("2" |
        "4" | "8" | "16" | "32" | "64" | "128" | "256") #REQUIRED>
        <!-- The number of entries in the local color table -->
      <!ATTLIST "LocalColorTable" "sortFlag" ("TRUE" | "FALSE")
         #REQUIRED>
        <!-- True if the local color table is sorted by frequency -->

      <!ELEMENT "ColorTableEntry" EMPTY>
        <!-- A local color table entry -->
        <!ATTLIST "ColorTableEntry" "index" #CDATA #REQUIRED>
          <!-- The index of the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "red" #CDATA #REQUIRED>
          <!-- The red value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "green" #CDATA #REQUIRED>
          <!-- The green value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "ColorTableEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value for the color table entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "GraphicControlExtension" EMPTY>
      <!-- A graphic control extension -->
      <!ATTLIST "GraphicControlExtension" "disposalMethod" ("none" |
        "doNotDispose" | "restoreToBackgroundColor" |
        "restoreToPrevious" | "undefinedDisposalMethod4" |
        "undefinedDisposalMethod5" | "undefinedDisposalMethod6" |
        "undefinedDisposalMethod7") #REQUIRED>
        <!-- The disposal method for this frame -->
      <!ATTLIST "GraphicControlExtension" "userInputFlag" ("TRUE" |
        "FALSE") #REQUIRED>
        <!-- True if the frame should be advanced based on user input -->
      <!ATTLIST "GraphicControlExtension" "transparentColorFlag" (
        "TRUE" | "FALSE") #REQUIRED>
        <!-- True if a transparent color exists -->
      <!ATTLIST "GraphicControlExtension" "delayTime" #CDATA #REQUIRED>
        <!-- The time to delay between frames, in hundredths of a second -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "GraphicControlExtension" "transparentColorIndex"
         #CDATA #REQUIRED>
        <!-- The transparent color, if transparentColorFlag is true -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "PlainTextExtension" EMPTY>
      <!-- A plain text (text grid) extension -->
      <!ATTLIST "PlainTextExtension" "textGridLeft" #CDATA #REQUIRED>
        <!-- The X offset of the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridTop" #CDATA #REQUIRED>
        <!-- The Y offset of the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridWidth" #CDATA #REQUIRED>
        <!-- The number of columns in the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textGridHeight" #CDATA #REQUIRED>
        <!-- The number of rows in the text grid -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "characterCellWidth" #CDATA
         #REQUIRED>
        <!-- The width of a character cell -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "characterCellHeight" #CDATA
         #REQUIRED>
        <!-- The height of a character cell -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textForegroundColor" #CDATA
         #REQUIRED>
        <!-- The text foreground color index -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->
      <!ATTLIST "PlainTextExtension" "textBackgroundColor" #CDATA
         #REQUIRED>
        <!-- The text background color index -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "ApplicationExtensions" (ApplicationExtension)*>
      <!-- A set of application extensions -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "ApplicationExtension" EMPTY>
        <!-- An application extension -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "ApplicationExtension" "applicationID" #CDATA
           #REQUIRED>
          <!-- The application ID -->
          <!-- Data type: String -->
        <!ATTLIST "ApplicationExtension" "authenticationCode" #CDATA
           #REQUIRED>
          <!-- The authentication code -->
          <!-- Data type: String -->

    <!ELEMENT "CommentExtensions" (CommentExtension)*>
      <!-- A set of comments -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "CommentExtension" EMPTY>
        <!-- A comment -->
        <!ATTLIST "CommentExtension" "value" #CDATA #REQUIRED>
          <!-- The comment -->
          <!-- Data type: String -->
]>

Mapping of Standard to GIF Native Stream Metadata
Standard Metadata Component | GIF Native Stream Metadata Component
/Chroma/Palette/PaletteEntry@index | /GlobalColorTable/ColorTableEntry@index
/Chroma/Palette/PaletteEntry@red | /GlobalColorTable/ColorTableEntry@red
/Chroma/Palette/PaletteEntry@green | /GlobalColorTable/ColorTableEntry@green
/Chroma/Palette/PaletteEntry@blue | /GlobalColorTable/ColorTableEntry@blue
/Chroma/BackgroundIndex@value | /GlobalColorTable@backgroundColorIndex
/Data/BitsPerSample@value | /LogicalScreenDescriptor@colorResolution
/Dimension/PixelAspectRatio@value | /LogicalScreenDescriptor@pixelAspectRatio
/Dimension/HorizontalScreenSize@value | /LogicalScreenDescriptor@logicalScreenWidth
/Dimension/VerticalScreenSize@value | /LogicalScreenDescriptor@logicalScreenHeight
/Document/FormatVersion@value | /Version@value

Mapping of Standard to GIF Native Image Metadata
Standard Metadata Component | GIF Native Image Metadata Component
/Chroma/Palette/PaletteEntry@index | /LocalColorTable/ColorTableEntry@index
/Chroma/Palette/PaletteEntry@red | /LocalColorTable/ColorTableEntry@red
/Chroma/Palette/PaletteEntry@green | /LocalColorTable/ColorTableEntry@green
/Chroma/Palette/PaletteEntry@blue | /LocalColorTable/ColorTableEntry@blue
/Dimension/HorizontalPixelOffset@value | /ImageDescriptor@imageLeftPosition
/Dimension/VerticalPixelOffset@value | /ImageDescriptor@imageTopPosition
/Text/TextEntry@value | /CommentExtensions/CommentExtension@value
/Transparency/TransparentIndex@value | /GraphicControlExtension@transparentColorIndex (/GraphicControlExtension@transparentColorFlag is also set to "TRUE")


WBMP Metadata Format Specification

The XML schema for the native image metadata format is as follows:
<?xml version="1.0" encoding="UTF-8"?>
<!-- Schema for WBMP native image metadata format. -->

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            xmlns="http://javax.imageio.plugins"
            targetNamespace="http://javax.imageio.plugins">

  <!-- WBMP Schema 1.0 root element. -->
  <xsd:element name="javax_imageio_wbmp_1.0">
    <xsd:sequence>

      <!-- WBMP image type -->
      <xsd:element name="WBMPType" type="xsd:unsignedInt"/>

      <!-- Bitmap width -->
      <xsd:element name="Width" type="xsd:unsignedInt"/>

      <!-- Bitmap height -->
      <xsd:element name="Height" type="xsd:unsignedInt"/>

     </xsd:sequence>
  </xsd:element> <!-- wbmp_image_1.0 -->

</xsd:schema>
@since 1.5


JPEG Metadata Format Specification and Usage Notes

JPEG Metadata
Abbreviated Streams
Sources of Tables
Colorspace Transformations and Conventional Markers
Thumbnail Images
Progressive Encoding
Native Metadata Format Tree Structure and Editing
Image Metadata DTD
Stream Metadata DTD

NOTE: It is important to call dispose() on the JPEG reader and writer objects when they are no longer needed, as they consume significant native resources which are not adequately recovered by garbage collection. Both reader and writer call dispose() in their finalizers, but those finalizers may not be called before the native code has exhausted native memory.

The JPEG writer does not support replacing pixels.

JPEG Metadata

JPEG metadata consists of the data contained in marker segments in a JPEG stream. The image metadata object returned from a read describes the contents of the marker segments between the SOI marker and the EOI marker for that image. The image metadata object passed into a write determines the contents of the stream between the SOI marker and the EOI marker for that image, subject to the controls in any ImageWriteParam.

Stream metadata is used only for tables-only images found (or to be placed) at the beginning of a stream containing abbreviated images. Tables-only images are not treated as images and do not consume an image index. The stream metadata object returned from a read describes the contents of the marker segments between the SOI marker and the EOI marker for the single tables-only image at the beginning of the stream, if one is present. If no tables-only image is present at the front of the stream, the getStreamMetadata method of ImageReader returns null. If stream metadata is provided to the writer, a single tables-only image containing the tables from the stream metadata object will be written at the beginning of the stream. If the stream metadata object contains no tables, default tables will be written. As the sole purpose of stream metadata is for specifying tables-only images at the front of abbreviated streams, the stream metadata argument is useful only on the ImageWriter.prepareWriteSequence method. It is ignored on all other methods.

The ImageWriter.getDefaultStreamMetadata method returns an object containing the tables from the ImageWriteParam argument, if it is a JPEGImageWriteParam and contains tables. Otherwise, the returned object will contain default tables.

The ImageWriter.getDefaultImageMetadata method returns a metadata object containing no tables if the ImageWriteParam argument contains tables. Otherwise the returned metadata object will contain default visually lossless tables. Of course, only a JPEGImageWriteParam may contain tables.

If ignoreMetadata is set to true when the input is set on the reader, stream metadata will not be available, but image metadata will.

Abbreviated Streams

Both the reader and the writer retain their tables from one operation to the next, thus permitting the use of abbreviated streams quite naturally, with a few minor restrictions:
  1. Abbreviated streams may contain only one tables-only image, which must come first in the stream. Subsequent tables-only images will cause undefined behavior.
  2. Abbreviated streams must be read fully and in order. No random access is allowed, in either direction. The same image may be read multiple times. If a call is made with an image index that is not the same as or one greater than the most recent call (or 0 if no calls have been made), then an IllegalArgumentException is thrown.
These restrictions mean that streams may contain abbreviated images interspersed with images containing tables. As required by JPEG, any tables appearing in the stream override previous tables, regardless of the source of the previous tables.

Note that once a tables-only image has been read, it's contents is available as stream metadata from the reader until either another tables-only image is read from another stream or the reader is reset. Changing the input does not reset the stream metadata. This is useful for reading the tables from one file, then changing the input to read an abbreviated stream containing a sequence of images. The tables will be used automatically, and will remain available as "stream" metadata.

Abbreviated streams are written using the sequence methods of ImageWriter. Stream metadata is used to write a tables-only image at the beginning of the stream, and the tables are set up for use, using ImageWriter.prepareWriteSequence. If no stream metadata is supplied to ImageWriter.prepareWriteSequence, then no tables-only image is written. If stream metadata containing no tables is supplied to ImageWriter.prepareWriteSequence, then a tables-only image containing default visually lossless tables is written.

Sources of Tables

Images are written with tables if tables are present in their metadata objects or without them if no tables are present in their metadata objects. If no metadata object is present then the tables are written. The tables used for compression are taken from one of the following sources, which are consulted in order:

  1. If there is an ImageWriteParam and the compression mode is set to EXPLICIT, default tables constructed using the quality setting are used. They are written only if the metadata contains tables or if there is no metadata, but they replace the tables in the metadata.
  2. If there is an ImageWriteParam and the compression mode is set to DEFAULT, default visually lossles tables are used. They are written only if the metadata contains tables or if there is no metadata, but they replace the tables in the metadata.
  3. Otherwise the compression mode on the ImageWriteParam must be MODE_COPY_FROM_METADATA, in which case the following are used:
    1. the tables in the image metadata, if present
    2. the tables in the stream metadata, if present
    3. the tables in the JPEGImageWriteParam, if present
    4. default visually lossless tables
    Tables are written only if they are taken from image metadata.
This ordering implements the design intention that tables should be included in JPEGImageWriteParams only as a means of specifying tables when no other source is available, and this can occur only when writing to an abbreviated stream without tables using known non-standard tables for compression.

When reading, tables in a JPEGImageReadParam are consulted only if tables have not been set by any previous read. Tables set from a JPEGImageReadParam are overridden by any tables present in the stream being read.

Note that if no image metadata object is specified for a particular image, a default object is used, which includes default tables.

Colorspace Transformations and Conventional Markers

Colorspace transformations are controlled by the destination type for both reading and writing of images. When Rasters are read, no colorspace transformation is performed, and any destination type is ignored. A warning is sent to any listeners if a destination type is specified in this case. When Rasters are written, any destination type is used to interpret the bands. This might result in a JFIF or Adobe header being written, or different component ids being written to the frame and scan headers. If values present in a metadata object do not match the destination type, the destination type is used and a warning is sent to any listeners.

When reading, the contents of the stream are interpreted by the usual JPEG conventions, as follows:

  • If a JFIF APP0 marker segment is present, the colorspace is known to be either grayscale or YCbCr. If an APP2 marker segment containing an embedded ICC profile is also present, then the YCbCr is converted to RGB according to the formulas given in the JFIF spec, and the ICC profile is assumed to refer to the resulting RGB space.

  • If an Adobe APP14 marker segment is present, the colorspace is determined by consulting the transform flag. The transform flag takes one of three values:
    • 2 - The image is encoded as YCCK (implicitly converted from CMYK on encoding).
    • 1 - The image is encoded as YCbCr (implicitly converted from RGB on encoding).
    • 0 - Unknown. 3-channel images are assumed to be RGB, 4-channel images are assumed to be CMYK.

  • If neither marker segment is present, the following procedure is followed: Single-channel images are assumed to be grayscale, and 2-channel images are assumed to be grayscale with an alpha channel. For 3- and 4-channel images, the component ids are consulted. If these values are 1-3 for a 3-channel image, then the image is assumed to be YCbCr. If these values are 1-4 for a 4-channel image, then the image is assumed to be YCbCrA. If these values are > 4, they are checked against the ASCII codes for 'R', 'G', 'B', 'A', 'C', 'c'. These can encode the following colorspaces:

    RGB
    RGBA
    YCC (as 'Y','C','c'), assumed to be PhotoYCC
    YCCA (as 'Y','C','c','A'), assumed to be PhotoYCCA

    Otherwise, 3-channel subsampled images are assumed to be YCbCr, 3-channel non-subsampled images are assumed to be RGB, 4-channel subsampled images are assumed to be YCCK, and 4-channel, non-subsampled images are assumed to be CMYK.

  • All other images are declared uninterpretable and an exception is thrown if an attempt is made to read one as a BufferedImage. Such an image may be read only as a Raster. If an image is interpretable but there is no Java ColorSpace available corresponding to the encoded colorspace (e.g. YCbCr), then ImageReader.getRawImageType will return null.
Once an encoded colorspace is determined, then the target colorspace is determined as follows:
  • If a destination type is not set, then the following default transformations take place after upsampling: YCbCr (and YCbCrA) images are converted to RGB (and RGBA) using the conversion provided by the underlying IJG library and either the built-in sRGB ColorSpace or a custom RGB ColorSpace object based on an embedded ICC profile is used to create the output ColorModel. PhotoYCC and PhotoYCCA images are not converted. CMYK and YCCK images are currently not supported.
  • If a destination image or type is set, it is used as follows: If the IJG library provides an appropriate conversion, it is used. Otherwise the default library conversion is followed by a colorspace conversion in Java.
  • Bands are selected AFTER any library colorspace conversion. If a subset of either source or destination bands is used, then the default library conversions are used with no further conversion in Java, regardless of any destination type.
  • An exception is thrown if an attempt is made to read an image in an unsupported jpeg colorspace as a BufferedImage (e.g. CMYK). Such images may be read as Rasters. If an image colorspace is unsupported or uninterpretable, then ImageReader.getImageTypes will return an empty Iterator. If a subset of the raw bands are required, a Raster must be obtained first and the bands obtained from that.

For writing, the color transformation to apply is determined as follows:

If a subset of the source bands is to be written, no color conversion is performed. Any destination, if set, must match the number of bands that will be written, and serves as an interpretation of the selected bands, rather than a conversion request. This behavior is identical to that for Rasters. If all the bands are to be written and an image (as opposed to a Raster) is being written, any destination type is ignored and a warning is sent to any listeners.

If a destination type is used and any aspect of the metadata object, if there is one, is not compatible with that type, the destination type is used, the metadata written is modified from that provided, and a warning is sent to listeners. This includes the app0JFIF and app14Adobe nodes. The component ids in the sof and sos nodes are not modified, however, as unless a app0JFIF node is present, any values may be used.

When a full image is written, a destination colorspace will be chosen based on the image contents and the metadata settings, according to the following algorithm:

If no metadata object is specified, then the following defaults apply:

  • Grayscale images are written with a JFIF APP0 marker segment. Grayscale images with alpha are written with no special marker. As required by JFIF, the component ids in the frame and scan header is set to 1.
  • RGB images are converted to YCbCr, subsampled in the chrominance channels by half both vertically and horizontally, and written with a JFIF APP0 marker segment. If the ColorSpace of the image is based on an ICCProfile (it is an instance of ICC_ColorSpace, but is not one of the standard built-in ColorSpaces), then that profile is embedded in an APP2 marker segment. As required by JFIF, the component ids in the frame and scan headers are set to 1, 2, and 3.
  • RGBA images are converted to YCbCrA, subsampled in the chrominance channels by half both vertically and horizontally, and written without any special marker segments. The component ids in the frame and scan headers are set to 1, 2, 3, and 4.
  • PhotoYCC and YCCAimages are subsampled by half in the chrominance channels both vertically and horizontally and written with an Adobe APP14 marker segment and 'Y','C', and 'c' (and 'A' if an alpha channel is present) as component ids in the frame and scan headers.
Default metadata objects for these image types will reflect these settings.

If a metadata object is specified, then the number of channels in the frame and scan headers must always match the number of bands to be written, or an exception is thrown. app0JFIF and app14Adobe nodes may appear in the same metadata object only if the app14Adobe node indicates YCbCr, and the component ids are JFIF compatible (0-2). The various image types are processed in the following ways:
(All multi-channel images are subsampled according to the sampling factors in the frame header node of the metadata object, regardless of color space.)

  • Grayscale Images:
    • If an app0JFIF node is present in the metadata object, a JFIF APP0 marker segment is written.
    • If an app14Adobe node is present in the metadata object, it is checked for validity (transform must be UNKNOWN) and written.
    • If neither node is present in the metadata object, no special marker segment is written.
  • Grayscale Images with an Alpha Channel:
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 2-channel images.
    • If an app14Adobe node is present in the metadata object, it is checked for validity (transform must be UNKNOWN) and written. If transform is not UNKNOWN, a warning is sent to listeners and the correct transform is written.
    • If neither node is present in the metadata object, no special marker segment is written.
  • RGB Images:
    • If an app0JFIF node is present in the metadata object, the image is converted to YCbCr and written with a JFIF APP0 marker segment. If the ColorSpace of the image is based on a non-standard ICC Profile, then that profile is embedded in an APP2 marker segment. If the ColorSpace is not based on a non-standard ICC Profile, but an app2ICC node appears in the metadata, then an APP2 marker segment is written with the appropriate standard profile. Note that the profile must specify an RGB color space, as the file must be JFIF compliant.
    • If an app14Adobe node is present in the metadata object, the image is converted according to the color transform setting and written with an Adobe APP14 marker segment. Component ids are written just as they appear in the frame and scan headers. The color transform must be either YCbCr or UNKNOWN. If it is UNKNOWN, the image is not color converted.
    • If neither node is present, the component ids in the frame header are consulted. If these indicate a colorspace as described above, then the image is converted to that colorspace if possible. If the component ids do not indicate a colorspace, then the sampling factors are consulted. If the image is to be subsampled, it is converted to YCbCr first. If the image is not to be subsampled, then no conversion is applied. No special marker segmentss are written.
  • RGBA images:
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 4-channel images.
    • If an app14Adobe node is present in the metadata object, the image is written with an Adobe APP14 marker segment. No colorspace conversion is performed. Component ids are written just as they appear in the frame and scan headers. The color transform must be UNKNOWN. If it is not, a warning is sent to listeners.
    • If no app14Adobe node is present, the component ids in the frame header are consulted. If these indicate a colorspace as described above, then the image is converted to that colorspace if possible. If the component ids do not indicate a colorspace, then the sampling factors are consulted. If the image is to be subsampled, it is converted to YCbCrA. If the image is not to be subsampled, then no conversion is applied. No special marker segments are written.
  • PhotoYCC Images:
    • If an app0JFIF node is present in the metadata object, the image is converted to sRGB, and then to YCbCr during encoding, and a JFIF APP0 marker segment is written.
    • If an app14Adobe node is present in the metadata object, no conversion is applied, and an Adobe APP14 marker segment is written. The color transform must be YCC. If it is not, a warning is sent to listeners.
    • If neither node is present in the metadata object, no conversion is applied, and no special marker segment is written.
  • PhotoYCCA Images:
    • If an app0JFIF node is present in the metadata object, it is ignored and a warning is sent to listeners, as JFIF does not support 4-channel images.
    • If an app14Adobe node is present in the metadata object, no conversion is applied, and an Adobe APP14 marker segment is written. The color transform must be UNKNOWN. If it is not, a warning is sent to listeners.
    • If neither node is present in the metadata object, no conversion is applied, and no special marker segment is written.

Thumbnail Images

Thumbnails are supported by the use of JFIF and JFIF extension marker segments. Thumbnails provided on the write methods determine the thumbnails that will be included. app0JFIF and app0JFXX nodes present in the metadata do not contain any thumbnail pixel data. However, the kinds of thumbnails written depend on the contents of the metadata object, as follows. Any thumbnail which is to be written as an indexed or RGB image and which is larger than 255 by 255 will be clipped, not scaled, to 255 by 255. Thumbnails written as JPEG images may be any size. A warning is sent to any listeners whenever a thumbnail is clipped.
  • If there is a single thumbnail, it is processed as follows:
    • If the thumbnail image is an RGB palette image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, or the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, a palette thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains another thumbnail form (RGB or JPEG), the palette image is expanded to RGB and the indicated thumbnail form is written.
    • If the thumbnail image is an RGB image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, the thumbnail is written as part of the JFIF APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbRGB element, an RGB thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbJPEG element, a JPEG thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, an RGB thumbnail is written in a JFXX APP0 marker segment and a warning is sent to any listeners.
    • If the thumbnail image is a grayscale image, it is processed as follows:
      • If no app0JFXX node is present in the metadata, the thumbnail is expanded to RGB and written as part of the JFIF APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbRGB element, the thumbnail is expanded to RGB and written in a separate JFXX RGB marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbJPEG element, a JPEG thumbnail is written in a JFXX APP0 marker segment.
      • If the first app0JFXX node present in the metadata contains a JFIFthumbPalette element, a JPEG thumbnail is written in a JFXX APP0 marker segment and a warning is sent to any listeners.
    • Any other thumbnail image types are ignored and a warning is sent to any listeners.
  • If there are multiple thumbnails, each one is processed as above, except that no thumbnail is placed in the JFIF APP0 segment, and the app0JFXX node consulted for each thumbnail is the app0JFXX node from the metadata that occurs in the same sequence as the thumbnail. I.e. the first app0JFXX node applies to the first thumbnail, the second node to the second thumbnail, and so on. If there are fewer app0JFXX nodes in the metadata than thumbnails, then those thumbnails are considered to have no matching app0JFXX node. An RGB thumbnail with no matching app0JFXX node is written in a JFXX APP0 marker segment. A grayscale thumbnail with no matching app0JFXX node is written as a JPEG image to a JFXX APP0 marker segment.

Note that as the only mechanism for storing thumbnails is via the JFIF or JFIF extension marker segments, only grayscale or RGB images may have thumbnails. If thumbnails are present when writing any other type of image, the thumbnails are ignored and a warning is sent to any warning listeners.

Progressive Encoding

Progressive encoding must be enabled on the ImageWriteParam passed in to a write operation, or the image will be written sequentially, regardless of the scan headers included in the metadata object. If progressive encoding is enabled and set to copy from metadata, then the sequence of scan headers from the metadata is used to write the image. If progressive encoding is enabled and set to use a default, then the scans in the metadata are ignored and a default set of scans is used. Progressive encoding always forces optimized Huffman tables to be used. Any Huffman tables present in the metadata will be ignored, and a warning will be sent to any warning listeners. If Huffman-table optimization is requested on the ImageWriteParam, all Huffman tables in the metadata or in the ImageWriteParam itself are ignored, and a warning will be sent to any warning listeners if any such tables are present.

Native Metadata Format Tree Structure and Editing

The DTDs below describe just the trees of metadata objects actually returned by the IIOMetadata object. They do not include nodes corresponding to SOI, EOI, or RST markers, as these parsing delimiters do not carry any meaningful metadata.

The first node is always a JPEGvariety node. In the javax_imageio_jpeg_image_1.0 version of the JPEG metadata format, this node may have one child, an app0JFIF node, indicating that the JPEG stream contains a JFIF marker segment and related data, or no children, indicating that the stream contains no JFIF marker. In future versions of the JPEG metadata format, other varieties of JPEG metadata may be supported (e.g. Exif) by defining other types of nodes which may appear as a child of the JPEGvariety node.

(Note that an application wishing to interpret Exif metadata given a metadata tree structure in the javax_imageio_jpeg_image_1.0 format must check for an unknown marker segment with a tag indicating an APP1 marker and containing data identifying it as an Exif marker segment. Then it may use application-specific code to interpret the data in the marker segment. If such an application were to encounter a metadata tree formatted according to a future version of the JPEG metadata format, the Exif marker segment might not be unknown in that format - it might be structured as a child node of the JPEGvariety node. Thus, it is important for an application to specify which version to use by passing the string identifying the version to the method/constructor used to obtain an IIOMetadata object.)

On reading, JFXX and app2ICC nodes occur as children of an app0JFIF node. This is true regardless of where the JFXX APP0 and APP2 marker segments actually occur in the stream. The ordering of nodes within the markerSequence node corresponds to the ordering of marker segments found in the JPEG stream.

On writing, any JFXX and app2ICC nodes must occur as children of an app0JFIF node, itself a child of a JPEGvariety node, which must always be the first node. (If the stream is not to be JFIF compliant, no app0JFIF node should be provided, and the JPEGvariety node should have no children.) Any JFIF APP0, JFXX APP0, and APP2 marker segments are written first, followed by all Adobe APP14, APPn, COM and unknown segments in the order in which their corresponding nodes appear in the markerSequence node, followed by DQT (and DHT for non-progressive writes) marker segments, followed by the SOF and SOS marker segments. For progressive writes using metadata to control progression, the SOS segments are used in the order in which their corresponding nodes occur in the markerSequence node.

The reset, mergeTree and setFromTree operations have the following semantics for the JPEG plug-in metadata object:

reset - A call to reset will restore the metadata object to the same state it had immediately after creation, whether this came about from reading a stream or by obtaining a default object from the ImageWriter. This is true regardless of how many times the metadata object has been modified since creation.

mergeTree - Native Format
The mergeTree operation accepts valid trees conforming to the DTD below, and merges the nodes using the following ordering rules. In all cases, only data present in the new node is changed in a corresponding existing node, if any. This means that nodes cannot be removed using mergeTree. To remove nodes, use setFromTree. The tree must consist of IIOMetadataNodes.

  • app0JFIF
    • If an app0JFIF node already exists, the contents of the new one modify the existing one.
    • If there is no such node, a new one is created and inserted in the appropriate position.
  • dqt
    • If there already exist dqt nodes in the sequence, then each table in the node replaces the first table, in any dqt node, with the same table id.
    • If none of the existing dqt nodes contain a table with the same id, then the table is added to the last existing dqt node.
    • If there are no dqt nodes, then a new one is created and added as follows:
      • If there are dht nodes, the new dqt node is inserted before the first one.
      • If there are no dht nodes, the new dqt node is inserted before an sof node, if there is one.
      • If there is no sof node, the new dqt node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dqt node is added to the end of the sequence.
  • dht
    • If there already exist dht nodes in the sequence, then each table in the node replaces the first table, in any dht node, with the same table class and table id.
    • If none of the existing dht nodes contain a table with the same class and id, then the table is added to the last existing dht node.
    • If there are no dht nodes, then a new one is created and added as follows:
      • If there are dqt nodes, the new dht node is inserted immediately following the last dqt node.
      • If there are no dqt nodes, the new dht node is inserted before an sof node, if there is one.
      • If there is no sof node, the new dht node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dht node is added to the end of the sequence.
  • dri
    • If there already exists a dri node, the restart interval value is updated.
    • If there is no dri node, then a new one is created and added as follows:
      • If there is an sof node, the new dri node is inserted before it.
      • If there is no sof node, the new dri node is inserted before the first sos node, if there is one.
      • If there is no sos node, the new dri node is added to the end of the sequence.
  • com
    A new com node is created and inserted as follows:
    • If there already exist com nodes, the new one is inserted after the last one.
    • If there are no com nodes, the new com node is inserted after the app14Adobe node, if there is one.
    • If there is no app14Adobe node, the new com node is inserted at the beginning of the sequence.
  • app14Adobe
    • If there already exists an app14Adobe node, then its attributes are updated from the node.
    • If there is no app14Adobe node, then a new one is created and added as follows:
      • The new app14Adobe node is inserted after the last unknown node, if there are any.
      • If there are no unknown nodes, the new app14Adobe node is inserted at the beginning of the sequence.
  • unknown
    A new unknown node is created and added to the sequence as follows:
    • If there already exist unknown marker nodes, the new one is inserted after the last one.
    • If there are no unknown nodes, the new unknown node is inserted before the app14Adobe node, if there is one.
    • If there is no app14Adobe node, the new unknown node is inserted at the beginning of the sequence.
  • sof
    • If there already exists an sof node in the sequence, then its values are updated from the node.
    • If there is no sof node, then a new one is created and added as follows:
      • If there are any sos nodes, the new sof node is inserted before the first one.
      • If there is no sos node, the new sof node is added to the end of the sequence.
  • sos
    • If there already exists a single sos node, then the values are updated from the node.
    • If there are more than one existing sos nodes, then an IIOInvalidTreeException is thrown, as sos nodes cannot be merged into a set of progressive scans.
    • If there are no sos nodes, a new one is created and added to the end of the sequence.

mergeTree - Standard Format
The mergeTree operation, when given a tree in the standard format, will modify the native tree in the following ways:

  • Chroma - The ColorSpaceType subnode of a Chroma node may change the target colorspace of the compressed image. The selection of a new colorspace can cause a number of changes, in keeping with the algorithms described above: app0JFIF and app14Adobe nodes may be added or removed, subsampling may be added or removed, component ids may be changed, and sof and sos nodes will be updated accordingly. If necessary, additional quantization and huffman tables are added. In the case of quantization tables, the default will be scaled to match the quality level of any existing tables. No tables are added to metadata that does not already contain tables. If the existing metadata specifies progressive encoding, then the number of channels must not change. Any Transparency node is also taken into account, as an explicit value of none for the Alpha subnode can cause the removal of an alpha channel, and anything other than none can cause the addition of an alpha channel.
  • Dimension - A PixelAspectRatio specification can cause the contents of an app0JFIF node to change, if there is one present, or the addition of an app0JFIF node containing appropriate values, if there can be one. An appropriate pair of integers is computed from the floating-point ratio for inclusion in the node.
  • Text - Each uncompressed text item is converted to a com node and inserted according to the rules above for merging com nodes.

setFromTree - Native Format
The setFromTree operation, when given a tree in the native format described below, will simply replace the existing tree in its entirety with the new one. The tree must consist of IIOMetadataNodes.

setFromTree - Standard Format
The setFromTree operation, when given a tree in the standard format, performs a reset followed by a merge of the new tree.

Image Metadata DTD

<!DOCTYPE "javax_imageio_jpeg_image_1.0" [

  <!ELEMENT "javax_imageio_jpeg_image_1.0" (JPEGvariety, markerSequence)>

    <!ELEMENT "JPEGvariety" (app0JFIF)>
      <!-- A node grouping all marker segments specific to the variety of
              stream being read/written (e.g. JFIF) - may be empty -->

      <!ELEMENT "app0JFIF" (JFXX?, app2ICC?)>
        <!ATTLIST "app0JFIF" "majorVersion" #CDATA "1">
          <!-- The major JFIF version number -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "minorVersion" #CDATA "2">
          <!-- The minor JFIF version number -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "resUnits" ("0" | "1" | "2") "0">
          <!-- The resolution units for Xdensisty and Ydensity (0 = no
               units, just aspect ratio; 1 = dots/inch; 2 = dots/cm) -->
        <!ATTLIST "app0JFIF" "Xdensity" #CDATA "1">
          <!-- The horizontal density or aspect ratio numerator -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app0JFIF" "Ydensity" #CDATA "1">
          <!-- The vertical density or aspect ratio denominator -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app0JFIF" "thumbWidth" #CDATA "0">
          <!-- The width of the thumbnail, or 0 if there isn't one -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app0JFIF" "thumbHeight" #CDATA "0">
          <!-- The height of the thumbnail, or 0 if there isn't one -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

        <!ELEMENT "JFXX" (app0JFXX)*>
          <!-- Min children: 1 -->

        <!ELEMENT "app0JFXX" (JFIFthumbJPEG | JFIFthumbPalette |
          JFIFthumbRGB)>
          <!-- A JFIF extension marker segment -->
          <!ATTLIST "app0JFXX" "extensionCode" ("16" | "17" | "19")
             #IMPLIED>
            <!-- The JFXX extension code identifying thumbnail type: (16 =
                 JPEG, 17 = indexed, 19 = RGB -->

          <!ELEMENT "JFIFthumbJPEG" (markerSequence?)>
            <!-- A JFIF thumbnail in JPEG format (no JFIF segments
                 permitted) -->

          <!ELEMENT "JFIFthumbPalette" EMPTY>
            <!-- A JFIF thumbnail as an RGB indexed image -->
            <!ATTLIST "JFIFthumbPalette" "thumbWidth" #CDATA #IMPLIED>
              <!-- The width of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->
            <!ATTLIST "JFIFthumbPalette" "thumbHeight" #CDATA #IMPLIED>
              <!-- The height of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->

          <!ELEMENT "JFIFthumbRGB" EMPTY>
            <!-- A JFIF thumbnail as an RGB image -->
            <!ATTLIST "JFIFthumbRGB" "thumbWidth" #CDATA #IMPLIED>
              <!-- The width of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->
            <!ATTLIST "JFIFthumbRGB" "thumbHeight" #CDATA #IMPLIED>
              <!-- The height of the thumbnail -->
              <!-- Data type: Integer -->
              <!-- Min value: 0 (inclusive) -->
              <!-- Max value: 255 (inclusive) -->

        <!ELEMENT "app2ICC" EMPTY>
          <!-- An ICC profile APP2 marker segment -->
          <!-- Optional User object: java.awt.color.ICC_Profile -->

    <!ELEMENT "markerSequence" (dqt | dht | dri | com | unknown |
      app14Adobe | sof | sos)*>
      <!-- A node grouping all non-jfif marker segments -->

      <!ELEMENT "dqt" (dqtable)*>
        <!-- A Define Quantization Table(s) marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->

        <!ELEMENT "dqtable" EMPTY>
          <!-- A single quantization table -->
          <!-- User object: javax.imageio.plugins.jpeg.JPEGQTable -->
          <!ATTLIST "dqtable" "elementPrecision" #CDATA "0">
            <!-- The number of bits in each table element (0 = 8, 1 = 16)
                 -->
            <!-- Data type: Integer -->
          <!ATTLIST "dqtable" "qtableId" ("0" | "1" | "2" | "3") #REQUIRED>

      <!ELEMENT "dht" (dhtable)*>
        <!-- A Define Huffman Table(s) marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->

        <!ELEMENT "dhtable" EMPTY>
          <!-- A single Huffman table -->
          <!-- User object: javax.imageio.plugins.jpeg.JPEGHuffmanTable -->
          <!ATTLIST "dhtable" "class" ("0" | "1") #REQUIRED>
            <!-- Indicates whether this is a DC (0) or an AC (1) table -->
          <!ATTLIST "dhtable" "htableId" ("0" | "1" | "2" | "3") #REQUIRED>
            <!-- The table id -->

      <!ELEMENT "dri" EMPTY>
        <!-- A Define Restart Interval marker segment -->
        <!ATTLIST "dri" "interval" #CDATA #REQUIRED>
          <!-- The restart interval in MCUs -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "com" EMPTY>
        <!-- A Comment marker segment. The user object contains the actual
             bytes. -->
        <!-- User object: array of [B -->
        <!-- Min length: 1 -->
        <!-- Max length: 65533 -->
        <!ATTLIST "com" "comment" #CDATA #IMPLIED>
          <!-- The comment as a string (used only if user object is null)
               -->
          <!-- Data type: String -->

      <!ELEMENT "unknown" EMPTY>
        <!-- An unrecognized marker segment. The user object contains the
             data not including length. -->
        <!-- User object: array of [B -->
        <!-- Min length: 1 -->
        <!-- Max length: 65533 -->
        <!ATTLIST "unknown" "MarkerTag" #CDATA #REQUIRED>
          <!-- The tag identifying this marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "app14Adobe" EMPTY>
        <!-- An Adobe APP14 marker segment -->
        <!ATTLIST "app14Adobe" "version" #CDATA "100">
          <!-- The version of Adobe APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 100 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "app14Adobe" "flags0" #CDATA "0">
          <!-- The flags0 variable of an APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app14Adobe" "flags1" #CDATA "0">
          <!-- The flags1 variable of an APP14 marker segment -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "app14Adobe" "transform" ("0" | "1" | "2") #REQUIRED>
          <!-- The color transform applied to the image (0 = Unknown, 1 =
               YCbCr, 2 = YCCK) -->

      <!ELEMENT "sof" (componentSpec)*>
        <!-- A Start Of Frame marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->
        <!ATTLIST "sof" "process" ("0" | "1" | "2") #IMPLIED>
          <!-- The JPEG process (0 = Baseline sequential, 1 = Extended
               sequential, 2 = Progressive) -->
        <!ATTLIST "sof" "samplePrecision" #CDATA "8">
          <!-- The number of bits per sample -->
          <!-- Data type: Integer -->
        <!ATTLIST "sof" "numLines" #CDATA #IMPLIED>
          <!-- The number of lines in the image -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "sof" "samplesPerLine" #CDATA #IMPLIED>
          <!-- The number of samples per line -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "sof" "numFrameComponents" ("1" | "2" | "3" | "4")
           #IMPLIED>
          <!-- The number of components in the image -->

        <!ELEMENT "componentSpec" EMPTY>
          <!-- A component specification for a frame -->
          <!ATTLIST "componentSpec" "componentId" #CDATA #REQUIRED>
            <!-- The id for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 0 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "HsamplingFactor" #CDATA #REQUIRED>
            <!-- The horizontal sampling factor for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 1 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "VsamplingFactor" #CDATA #REQUIRED>
            <!-- The vertical sampling factor for this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 1 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "componentSpec" "QtableSelector" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The quantization table to use for this component -->

      <!ELEMENT "sos" (scanComponentSpec)*>
        <!-- A Start Of Scan marker segment -->
        <!-- Min children: 1 -->
        <!-- Max children: 4 -->
        <!ATTLIST "sos" "numScanComponents" ("1" | "2" | "3" | "4")
           #REQUIRED>
          <!-- The number of components in the scan -->
        <!ATTLIST "sos" "startSpectralSelection" #CDATA "0">
          <!-- The first spectral band included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 63 (inclusive) -->
        <!ATTLIST "sos" "endSpectralSelection" #CDATA "63">
          <!-- The last spectral band included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 63 (inclusive) -->
        <!ATTLIST "sos" "approxHigh" #CDATA "0">
          <!-- The highest bit position included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 15 (inclusive) -->
        <!ATTLIST "sos" "approxLow" #CDATA "0">
          <!-- The lowest bit position included in this scan -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 15 (inclusive) -->

        <!ELEMENT "scanComponentSpec" EMPTY>
          <!-- A component specification for a scan -->
          <!ATTLIST "scanComponentSpec" "componentSelector" #CDATA
             #REQUIRED>
            <!-- The id of this component -->
            <!-- Data type: Integer -->
            <!-- Min value: 0 (inclusive) -->
            <!-- Max value: 255 (inclusive) -->
          <!ATTLIST "scanComponentSpec" "dcHuffTable" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The huffman table to use for encoding DC coefficients -->
          <!ATTLIST "scanComponentSpec" "acHuffTable" ("0" | "1" | "2" |
            "3") #REQUIRED>
            <!-- The huffman table to use for encoding AC coefficients -->
]>

Stream Metadata DTD

<!DOCTYPE "javax_imageio_jpeg_stream_1.0" [
  <!ELEMENT "javax_imageio_jpeg_stream_1.0" (dqt |
                      dht |
                      dri |
                      com |
                      unknown)*>

  <!-- All elements are as defined above for image metadata -->
]>


PNG Metadata Format Specification

The PNG native format encodes the complete contents of a PNG file chunk by chunk, except for the IDAT chunks that contain the actual image data. Chunks that are not defined in the PNG 1.2 specification are stored under the UnknownChunks element. Note that it is the responsibility of application software to implement the rules for PNG readers, writers, and editors (e.g., the rules concerning unsafe-to-copy chunks) described in the PNG specification. The Image I/O library is not, in and of itself, a PNG reader, writer, or editor in the sense of the specification. Rather, it is a tool that may be used to build PNG readers, writers, and editors.

The image's actual width, height, bit depth, and color type will override any values passed to the writer via metadata, with one exception. If the image has an IndexColorModel, the color table entries will be checked to determine if they form a uniform grayscale ramp. If so, the image will normally be encoded using as grayscale instead of palette color. However, if the color type set in the metadata is "Palette", palette color will be used.

If no metadata is supplied when encoding an image, the header is initialized from the image being encoded, and no optional chunks are included.

The semantics of the standard chunks are described in the PNG specification. Note that there are some restrictions on which chunks may appear for each color type. In particular,

  • A PLTE chunk may not appear in a Gray or GrayAlpha image
  • hIST and tRNS chunks require a prior PLTE chunk
  • A tRNS chunk may not appear in GrayAlpha and RGBA images
The child nodes of the bKGD, sBIT, and tRNS chunks must match the image's color type.

Certain chunks may meaningfully appear multiple times in a PNG file, in particular the text-related chunks. In order to simplify the metadata format, multiple instances of these chunks are consolidated under a single parent node (e.g., the tEXt node), which may have zero or more children (e.g., tEXtEntry nodes). If no children are present, no chunk will be written. Similarly, unknown chunks are stored as children of a single UnknownChunks node.

It is not possible to control the ordering of the chunks as they are written, or to determine the order of the chunks in a file being read.

<!DOCTYPE "javax_imageio_png_1.0" [

  <!ELEMENT "javax_imageio_png_1.0" (IHDR?, PLTE?, bKGD?, cHRM?,
    gAMA?, hIST?, iCCP?, iTXt?, pHYS?, sBIT?, sPLT?, sRGB?, tEXt?,
    tIME?, tRNS?, zTXt?, UnknownChunks?)>

    <!ELEMENT "IHDR" EMPTY>
      <!-- The IHDR chunk, containing the header -->
      <!ATTLIST "IHDR" "width" #CDATA #REQUIRED>
        <!-- The width of the image in pixels -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "IHDR" "height" #CDATA #REQUIRED>
        <!-- The height of the image in pixels -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "IHDR" "bitDepth" ("1" | "2" | "4" | "8" | "16")
         #REQUIRED>
        <!-- The bit depth of the image samples -->
      <!ATTLIST "IHDR" "colorType" ("Grayscale" | "RGB" | "Palette" |
        "GrayAlpha" | "RGBAlpha") #REQUIRED>
        <!-- The color type of the image -->
      <!ATTLIST "IHDR" "compressionMethod" ("deflate") #REQUIRED>
        <!-- The compression used for image data, always "deflate" -->
      <!ATTLIST "IHDR" "filterMethod" ("adaptive") #REQUIRED>
        <!-- The filtering method used for compression, always "adaptive" -->
      <!ATTLIST "IHDR" "interlaceMethod" ("none" | "adam7") #REQUIRED>
        <!-- The interlacing method, "none" or "adam7" -->

    <!ELEMENT "PLTE" (PLTEEntry)*>
      <!-- The PLTE chunk, containing the palette -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "PLTEEntry" EMPTY>
        <!-- A palette entry -->
        <!ATTLIST "PLTEEntry" "index" #CDATA #REQUIRED>
          <!-- The index of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "red" #CDATA #REQUIRED>
          <!-- The red value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "green" #CDATA #REQUIRED>
          <!-- The green value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "PLTEEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value of a palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "bKGD" (bKGD_Grayscale | bKGD_RGB | bKGD_Palette)>
      <!-- The bKGD chunk, containing the background color -->

      <!ELEMENT "bKGD_Grayscale" EMPTY>
        <!-- A grayscale background color, for Gray and GrayAlpha images -->
        <!ATTLIST "bKGD_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- A gray value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "bKGD_RGB" EMPTY>
        <!-- An RGB background color, for RGB and RGBAlpha images -->
        <!ATTLIST "bKGD_RGB" "red" #CDATA #REQUIRED>
          <!-- A red value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "bKGD_RGB" "green" #CDATA #REQUIRED>
          <!-- A green value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "bKGD_RGB" "blue" #CDATA #REQUIRED>
          <!-- A blue value to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "bKGD_Palette" EMPTY>
        <!-- A background palette index -->
        <!ATTLIST "bKGD_Palette" "index" #CDATA #REQUIRED>
          <!-- A palette index to be used as a background -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "cHRM" EMPTY>
      <!-- The cHRM chunk, containing color calibration -->
      <!ATTLIST "cHRM" "whitePointX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the white point, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "whitePointY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the white point, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "redX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the red primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "redY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the red primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "greenX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the green primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "greenY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the green primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "blueX" #CDATA #REQUIRED>
        <!-- The CIE x coordinate of the blue primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "cHRM" "blueY" #CDATA #REQUIRED>
        <!-- The CIE y coordinate of the blue primary, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->

    <!ELEMENT "gAMA" EMPTY>
      <!-- The gAMA chunk, containing the image gamma -->
      <!ATTLIST "gAMA" "value" #CDATA #REQUIRED>
        <!-- The image gamma, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->

    <!ELEMENT "hIST" (hISTEntry)*>
      <!-- The hIST chunk, containing histogram information  -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "hISTEntry" EMPTY>
        <!-- A histogram entry -->
        <!ATTLIST "hISTEntry" "index" #CDATA #REQUIRED>
          <!-- The palette index of this histogram entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "hISTEntry" "value" #CDATA #REQUIRED>
          <!-- The frequency of this histogram entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

    <!ELEMENT "iCCP" EMPTY>
      <!-- The iCCP chunk, containing an ICC color profile -->
      <!-- User object: array of byte -->
      <!-- Min length: 0 -->
      <!-- Max length: 2147483647 -->
      <!ATTLIST "iCCP" "profileName" #CDATA #REQUIRED>
        <!-- The name of this ICC profile -->
        <!-- Data type: String -->
      <!ATTLIST "iCCP" "compressionMethod" ("deflate") #REQUIRED>
        <!-- The compression method used to store this ICC profile -->

    <!ELEMENT "iTXt" (iTXtEntry)*>
      <!-- The iTXt chunk, containing internationalized text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "iTXtEntry" EMPTY>
        <!-- A localized text entry -->
        <!ATTLIST "iTXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "compressionFlag" ("TRUE" | "FALSE")
           #REQUIRED>
        <!ATTLIST "iTXtEntry" "compressionMethod" #CDATA #REQUIRED>
          <!-- The compression method used to store this iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "languageTag" #CDATA #REQUIRED>
          <!-- The ISO tag describing the language this iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "translatedKeyword" #CDATA #REQUIRED>
          <!-- The translated keyword for iTXt entry -->
          <!-- Data type: String -->
        <!ATTLIST "iTXtEntry" "text" #CDATA #REQUIRED>
          <!-- The localized text -->
          <!-- Data type: String -->

    <!ELEMENT "pHYS" EMPTY>
      <!-- The pHYS chunk, containing the pixel size and aspect ratio -->
      <!ATTLIST "pHYS" "pixelsPerUnitXAxis" #CDATA #REQUIRED>
        <!-- The number of horizontal pixels per unit, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "pHYS" "pixelsPerUnitYAxis" #CDATA #REQUIRED>
        <!-- The number of vertical pixels per unit, multiplied by 1e5 -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 2147483647 (inclusive) -->
      <!ATTLIST "pHYS" "unitSpecifier" ("unknown" | "meter") #REQUIRED>
        <!-- The unit specifier for this chunk (i.e., meters) -->

    <!ELEMENT "sBIT" (sBIT_Grayscale | sBIT_GrayAlpha | sBIT_RGB |
      sBIT_RGBAlpha | sBIT_Palette)>
      <!-- The sBIT chunk, containing significant bit information -->

      <!ELEMENT "sBIT_Grayscale" EMPTY>
        <!-- Significant bit information for gray samples -->
        <!ATTLIST "sBIT_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- The number of significant bits of the gray samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_GrayAlpha" EMPTY>
        <!-- Significant bit information for gray and alpha samples -->
        <!ATTLIST "sBIT_GrayAlpha" "gray" #CDATA #REQUIRED>
          <!-- The number of significant bits of the gray samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_GrayAlpha" "alpha" #CDATA #REQUIRED>
          <!-- The number of significant bits of the alpha samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_RGB" EMPTY>
        <!-- Significant bit information for RGB samples -->
        <!ATTLIST "sBIT_RGB" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGB" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGB" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_RGBAlpha" EMPTY>
        <!-- Significant bit information for RGBA samples -->
        <!ATTLIST "sBIT_RGBAlpha" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_RGBAlpha" "alpha" #CDATA #REQUIRED>
          <!-- The number of significant bits of the alpha samples -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

      <!ELEMENT "sBIT_Palette" EMPTY>
        <!-- Significant bit information for RGB palette entries -->
        <!ATTLIST "sBIT_Palette" "red" #CDATA #REQUIRED>
          <!-- The number of significant bits of the red palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_Palette" "green" #CDATA #REQUIRED>
          <!-- The number of significant bits of the green palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sBIT_Palette" "blue" #CDATA #REQUIRED>
          <!-- The number of significant bits of the blue palette entries -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "sPLT" (sPLTEntry)*>
      <!-- The sPLT chunk, containing a suggested palette -->
      <!-- Min children: 1 -->
      <!-- Max children: 256 -->

      <!ELEMENT "sPLTEntry" EMPTY>
        <!-- A suggested palette entry -->
        <!ATTLIST "sPLTEntry" "index" #CDATA #REQUIRED>
          <!-- The index of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "red" #CDATA #REQUIRED>
          <!-- The red value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "green" #CDATA #REQUIRED>
          <!-- The green value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "blue" #CDATA #REQUIRED>
          <!-- The blue value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "sPLTEntry" "alpha" #CDATA #REQUIRED>
          <!-- The blue value of a suggested palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "sRGB" EMPTY>
      <!-- The sRGB chunk, containing rendering intent information -->
      <!ATTLIST "sRGB" "renderingIntent" ("Perceptual" |
        "Relative colorimetric" | "Saturation" |
        "Absolute colorimetric") #REQUIRED>
        <!-- The rendering intent -->

    <!ELEMENT "tEXt" (tEXtEntry)*>
      <!-- The tEXt chunk, containing text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "tEXtEntry" EMPTY>
        <!-- A text entry -->
        <!ATTLIST "tEXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "tEXtEntry" "value" #CDATA #REQUIRED>
          <!-- The text -->
          <!-- Data type: String -->

    <!ELEMENT "tIME" EMPTY>
      <!-- The tIME chunk, containing the image modification time -->
      <!ATTLIST "tIME" "year" #CDATA #REQUIRED>
        <!-- The year when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 65535 (inclusive) -->
      <!ATTLIST "tIME" "month" #CDATA #REQUIRED>
        <!-- The month when the image was last modified, 1 = January -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 12 (inclusive) -->
      <!ATTLIST "tIME" "day" #CDATA #REQUIRED>
        <!-- The day of the month when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 1 (inclusive) -->
        <!-- Max value: 31 (inclusive) -->
      <!ATTLIST "tIME" "hour" #CDATA #REQUIRED>
        <!-- The hour when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 23 (inclusive) -->
      <!ATTLIST "tIME" "minute" #CDATA #REQUIRED>
        <!-- The minute when the image was last modified -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 59 (inclusive) -->
      <!ATTLIST "tIME" "second" #CDATA #REQUIRED>
        <!-- The second when the image was last modified, 60 = leap second -->
        <!-- Data type: Integer -->
        <!-- Min value: 0 (inclusive) -->
        <!-- Max value: 60 (inclusive) -->

    <!ELEMENT "tRNS" (tRNS_Grayscale | tRNS_RGB | tRNS_Palette)>
      <!-- The tRNS chunk, containing transparency information -->

      <!ELEMENT "tRNS_Grayscale" EMPTY>
        <!-- A grayscale value that should be considered transparent -->
        <!ATTLIST "tRNS_Grayscale" "gray" #CDATA #REQUIRED>
          <!-- The gray value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "tRNS_RGB" EMPTY>
        <!-- An RGB value that should be considered transparent -->
        <!ATTLIST "tRNS_RGB" "red" #CDATA #REQUIRED>
          <!-- The red value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "tRNS_RGB" "green" #CDATA #REQUIRED>
          <!-- The green value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->
        <!ATTLIST "tRNS_RGB" "blue" #CDATA #REQUIRED>
          <!-- The blure value to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 65535 (inclusive) -->

      <!ELEMENT "tRNS_Palette" EMPTY>
        <!-- A palette index that should be considered transparent -->
        <!ATTLIST "tRNS_Palette" "index" #CDATA #REQUIRED>
          <!-- A palette index to be considered transparent -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->
        <!ATTLIST "tRNS_Palette" "alpha" #CDATA #REQUIRED>
          <!-- The transparency associated with the palette entry -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 255 (inclusive) -->

    <!ELEMENT "zTXt" (zTXtEntry)*>
      <!-- The zTXt chunk, containing compressed text -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "zTXtEntry" EMPTY>
        <!-- A compressed text entry -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "zTXtEntry" "keyword" #CDATA #REQUIRED>
          <!-- The keyword -->
          <!-- Data type: String -->
        <!ATTLIST "zTXtEntry" "compressionMethod" ("deflate")
           #REQUIRED>
          <!-- The compressed text -->

    <!ELEMENT "UnknownChunks" (UnknownChunk)*>
      <!-- A set of unknown chunks -->
      <!-- Min children: 1 -->
      <!-- Max children: 2147483647 -->

      <!ELEMENT "UnknownChunk" EMPTY>
        <!-- Unknown chunk data stored as a byte array -->
        <!-- User object: array of byte -->
        <!-- Min length: 0 -->
        <!-- Max length: 2147483647 -->
        <!ATTLIST "UnknownChunk" "type" #CDATA #REQUIRED>
          <!-- The 4-character type of the unknown chunk -->
          <!-- Data type: String -->
]>


Standard Metadata Format Specification

Standard (Plug-in Neutral) Metadata Format Specification

The plug-in neutral "javax_imageio_1.0" format consists of a root node named "javax_imageio_1.0" which has child nodes "chroma", "compression", "dimension", "document", "text", "tile", and "transparency". The format is described by the following DTD:

<!DOCTYPE "javax_imageio_1.0" [

  <!ELEMENT "javax_imageio_1.0" (Chroma?, Compression?, Data?, Dimension?,
    Document?, Text?, Transparency?)>

    <!ELEMENT "Chroma" (ColorSpaceType?, NumChannels?, Gamma?,
      BlackIsZero?, Palette?, BackgroundIndex?, BackgroundColor?)>
      <!-- Chroma (color) information -->

      <!ELEMENT "ColorSpaceType" EMPTY>
        <!-- The raw color space of the image -->
        <!ATTLIST "ColorSpaceType" "name" ("XYZ" | "Lab" | "Luv" |
          "YCbCr" | "Yxy" | "YCCK" | "PhotoYCC" | "RGB" | "GRAY" | "HSV" |
          "HLS" | "CMYK" | "CMY" | "2CLR" | "3CLR" | "4CLR" | "5CLR" |
          "6CLR" | "7CLR" | "8CLR" | "9CLR" | "ACLR" | "BCLR" | "CCLR" |
          "DCLR" | "ECLR" | "FCLR") #REQUIRED>

      <!ELEMENT "NumChannels" EMPTY>
        <!-- The number of channels in the raw image, including alpha -->
        <!ATTLIST "NumChannels" "value" #CDATA #REQUIRED>
          <!-- Data type: List of Integer -->

      <!ELEMENT "Gamma" EMPTY>
        <!-- The image gamma -->
        <!ATTLIST "Gamma" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "BlackIsZero" EMPTY>
        <!-- True if smaller values represent darker shades -->
        <!ATTLIST "BlackIsZero" "value" ("TRUE" | "FALSE") "TRUE">

      <!ELEMENT "Palette" (PaletteEntry)*>
        <!-- Palette-color information -->

        <!ELEMENT "PaletteEntry" EMPTY>
          <!-- A palette entry -->
          <!ATTLIST "PaletteEntry" "index" #CDATA #REQUIRED>
            <!-- The index of the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "red" #CDATA #REQUIRED>
            <!-- The red value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "green" #CDATA #REQUIRED>
            <!-- The green value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "blue" #CDATA #REQUIRED>
            <!-- The blue value for the palette entry -->
            <!-- Data type: Integer -->
          <!ATTLIST "PaletteEntry" "alpha" #CDATA "255">
            <!-- The alpha value for the palette entry -->
            <!-- Data type: Integer -->

      <!ELEMENT "BackgroundIndex" EMPTY>
        <!-- A palette index to be used as a background -->
        <!ATTLIST "BackgroundIndex" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "BackgroundColor" EMPTY>
        <!-- An RGB triple to be used as a background -->
        <!ATTLIST "BackgroundColor" "red" #CDATA #REQUIRED>
          <!-- The red background value -->
          <!-- Data type: Integer -->
        <!ATTLIST "BackgroundColor" "green" #CDATA #REQUIRED>
          <!-- The green background value -->
          <!-- Data type: Integer -->
        <!ATTLIST "BackgroundColor" "blue" #CDATA #REQUIRED>
          <!-- The blue background value -->
          <!-- Data type: Integer -->

    <!ELEMENT "Compression" (CompressionTypeName?, Lossless?,
      NumProgressiveScans?, BitRate?)>
      <!-- Compression information -->

      <!ELEMENT "CompressionTypeName" EMPTY>
        <!-- The name of the compression scheme in use -->
        <!ATTLIST "CompressionTypeName" "value" #CDATA #REQUIRED>
          <!-- Data type: String -->

      <!ELEMENT "Lossless" EMPTY>
        <!-- True if the compression scheme is lossless -->
        <!ATTLIST "Lossless" "value" ("TRUE" | "FALSE") "TRUE">

      <!ELEMENT "NumProgressiveScans" EMPTY>
        <!-- The number of progressive scans used in the image encoding -->
        <!ATTLIST "NumProgressiveScans" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "BitRate" EMPTY>
        <!-- The estimated bit rate of the compression scheme -->
        <!ATTLIST "BitRate" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

    <!ELEMENT "Data" (PlanarConfiguration?, SampleFormat?, BitsPerSample?,
      SignificantBitsPerSample?, SampleMSB?)>
      <!-- Information on the image layout -->

      <!ELEMENT "PlanarConfiguration" EMPTY>
        <!-- The organization of image samples in the stream -->
        <!ATTLIST "PlanarConfiguration" "value" ("PixelInterleaved" |
          "PlaneInterleaved" | "LineInterleaved" | "TileInterleaved")
           #REQUIRED>

      <!ELEMENT "SampleFormat" EMPTY>
        <!-- The numeric format of image samples -->
        <!ATTLIST "SampleFormat" "value" ("SignedIntegral" |
          "UnsignedIntegral" | "Real" | "Index") #REQUIRED>

      <!ELEMENT "BitsPerSample" EMPTY>
        <!-- The number of bits per sample -->
        <!ATTLIST "BitsPerSample" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

      <!ELEMENT "SignificantBitsPerSample" EMPTY>
        <!-- The number of significant bits per sample -->
        <!ATTLIST "SignificantBitsPerSample" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

      <!ELEMENT "SampleMSB" EMPTY>
        <!-- The position of the most significant bit of each sample -->
        <!ATTLIST "SampleMSB" "value" #CDATA #REQUIRED>
          <!-- A list of integers, one per channel -->
          <!-- Data type: List of Integer -->
          <!-- Min length: 1 -->

    <!ELEMENT "Dimension" (PixelAspectRatio?, ImageOrientation?,
      HorizontalPixelSize?, VerticalPixelSize?,
      HorizontalPhysicalPixelSpacing?, VerticalPhysicalPixelSpacing?,
      HorizontalPosition?, VerticalPosition?, HorizontalPixelOffset?,
      VerticalPixelOffset?, HorizontalScreenSize?, VerticalScreenSize?)>
      <!-- Dimension information -->

      <!ELEMENT "PixelAspectRatio" EMPTY>
        <!-- The width of a pixel divided by its height -->
        <!ATTLIST "PixelAspectRatio" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "ImageOrientation" EMPTY>
        <!-- The desired orientation of the image in terms of flips and
             counter-clockwise rotations -->
        <!ATTLIST "ImageOrientation" "value" ("Normal" | "Rotate90" |
          "Rotate180" | "Rotate270" | "FlipH" | "FlipV" |
          "FlipHRotate90" | "FlipVRotate90") #REQUIRED>

      <!ELEMENT "HorizontalPixelSize" EMPTY>
        <!-- The width of a pixel, in millimeters, as it should be rendered
             on media -->
        <!ATTLIST "HorizontalPixelSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPixelSize" EMPTY>
        <!-- The height of a pixel, in millimeters, as it should be
             rendered on media -->
        <!ATTLIST "VerticalPixelSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPhysicalPixelSpacing" EMPTY>
        <!-- The horizontal distance in the subject of the image, in
             millimeters, represented by one pixel at the center of the
             image -->
        <!ATTLIST "HorizontalPhysicalPixelSpacing" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPhysicalPixelSpacing" EMPTY>
        <!-- The vertical distance in the subject of the image, in
             millimeters, represented by one pixel at the center of the
             image -->
        <!ATTLIST "VerticalPhysicalPixelSpacing" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPosition" EMPTY>
        <!-- The horizontal position, in millimeters, where the image
             should be rendered on media -->
        <!ATTLIST "HorizontalPosition" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "VerticalPosition" EMPTY>
        <!-- The vertical position, in millimeters, where the image should
             be rendered on media -->
        <!ATTLIST "VerticalPosition" "value" #CDATA #REQUIRED>
          <!-- Data type: Float -->

      <!ELEMENT "HorizontalPixelOffset" EMPTY>
        <!-- The horizonal position, in pixels, where the image should be
             rendered onto a raster display -->
        <!ATTLIST "HorizontalPixelOffset" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "VerticalPixelOffset" EMPTY>
        <!-- The vertical position, in pixels, where the image should be
             rendered onto a raster display -->
        <!ATTLIST "VerticalPixelOffset" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "HorizontalScreenSize" EMPTY>
        <!-- The width, in pixels, of the raster display into which the
             image should be rendered -->
        <!ATTLIST "HorizontalScreenSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "VerticalScreenSize" EMPTY>
        <!-- The height, in pixels, of the raster display into which the
             image should be rendered -->
        <!ATTLIST "VerticalScreenSize" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

    <!ELEMENT "Document" (FormatVersion?, SubimageInterpretation?,
      ImageCreationTime?, ImageModificationTime?)>
      <!-- Document information -->

      <!ELEMENT "FormatVersion" EMPTY>
        <!-- The version of the format used by the stream -->
        <!ATTLIST "FormatVersion" "value" #CDATA #REQUIRED>
          <!-- Data type: String -->

      <!ELEMENT "SubimageInterpretation" EMPTY>
        <!-- The interpretation of this image in relation to the other
             images stored in the same stream -->
        <!ATTLIST "SubimageInterpretation" "value" ("Standalone" |
          "SinglePage" | "FullResolution" | "ReducedResolution" |
          "PyramidLayer" | "Preview" | "VolumeSlice" | "ObjectView" |
          "Panorama" | "AnimationFrame" | "TransparencyMask" |
          "CompositingLayer" | "SpectralSlice" | "Unknown") #REQUIRED>

      <!ELEMENT "ImageCreationTime" EMPTY>
        <!-- The time of image creation -->
        <!ATTLIST "ImageCreationTime" "year" #CDATA #REQUIRED>
          <!-- The full year (e.g., 1967, not 67) -->
          <!-- Data type: Integer -->
        <!ATTLIST "ImageCreationTime" "month" #CDATA #REQUIRED>
          <!-- The month, with January = 1 -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 12 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "day" #CDATA #REQUIRED>
          <!-- The day of the month -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 31 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "hour" #CDATA "0">
          <!-- The hour from 0 to 23 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 23 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "minute" #CDATA "0">
          <!-- The minute from 0 to 59 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 59 (inclusive) -->
        <!ATTLIST "ImageCreationTime" "second" #CDATA "0">
          <!-- The second from 0 to 60 (60 = leap second) -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 60 (inclusive) -->

      <!ELEMENT "ImageModificationTime" EMPTY>
        <!-- The time of the last image modification -->
        <!ATTLIST "ImageModificationTime" "year" #CDATA #REQUIRED>
          <!-- The full year (e.g., 1967, not 67) -->
          <!-- Data type: Integer -->
        <!ATTLIST "ImageModificationTime" "month" #CDATA #REQUIRED>
          <!-- The month, with January = 1 -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 12 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "day" #CDATA #REQUIRED>
          <!-- The day of the month -->
          <!-- Data type: Integer -->
          <!-- Min value: 1 (inclusive) -->
          <!-- Max value: 31 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "hour" #CDATA "0">
          <!-- The hour from 0 to 23 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 23 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "minute" #CDATA "0">
          <!-- The minute from 0 to 59 -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 59 (inclusive) -->
        <!ATTLIST "ImageModificationTime" "second" #CDATA "0">
          <!-- The second from 0 to 60 (60 = leap second) -->
          <!-- Data type: Integer -->
          <!-- Min value: 0 (inclusive) -->
          <!-- Max value: 60 (inclusive) -->

    <!ELEMENT "Text" (TextEntry)*>
      <!-- Text information -->

      <!ELEMENT "TextEntry" EMPTY>
        <!-- A text entry -->
        <!ATTLIST "TextEntry" "keyword" #CDATA #IMPLIED>
          <!-- A keyword associated with the text entry -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "value" #CDATA #REQUIRED>
          <!-- the text entry -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "language" #CDATA #IMPLIED>
          <!-- The language of the text -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "encoding" #CDATA #IMPLIED>
          <!-- The encoding of the text -->
          <!-- Data type: String -->
        <!ATTLIST "TextEntry" "compression" ("none" | "lzw" | "zip" |
          "bzip" | "other") "none">
          <!-- The method used to compress the text -->

    <!ELEMENT "Transparency" (Alpha?, TransparentIndex?,
      TransparentColor?, TileTransparencies?, TileOpacities?)>
      <!-- Transparency information -->

      <!ELEMENT "Alpha" EMPTY>
        <!-- The type of alpha information contained in the image -->
        <!ATTLIST "Alpha" "value" ("none" | "premultiplied" |
          "nonpremultiplied") "none">

      <!ELEMENT "TransparentIndex" EMPTY>
        <!-- A palette index to be treated as transparent -->
        <!ATTLIST "TransparentIndex" "value" #CDATA #REQUIRED>
          <!-- Data type: Integer -->

      <!ELEMENT "TransparentColor" EMPTY>
        <!-- An RGB color to be treated as transparent -->
        <!ATTLIST "TransparentColor" "value" #CDATA #REQUIRED>
          <!-- Data type: List of Integer -->

      <!ELEMENT "TileTransparencies" (TransparentTile)*>
        <!-- A list of completely transparent tiles -->

        <!ELEMENT "TransparentTile" EMPTY>
          <!-- The index of a completely transparent tile -->
          <!ATTLIST "TransparentTile" "x" #CDATA #REQUIRED>
            <!-- The tile's X index -->
            <!-- Data type: Integer -->
          <!ATTLIST "TransparentTile" "y" #CDATA #REQUIRED>
            <!-- The tile's Y index -->
            <!-- Data type: Integer -->

      <!ELEMENT "TileOpacities" (OpaqueTile)*>
        <!-- A list of completely opaque tiles -->

        <!ELEMENT "OpaqueTile" EMPTY>
          <!-- The index of a completely opaque tile -->
          <!ATTLIST "OpaqueTile" "x" #CDATA #REQUIRED>
            <!-- The tile's X index -->
            <!-- Data type: Integer -->
          <!ATTLIST "OpaqueTile" "y" #CDATA #REQUIRED>
            <!-- The tile's Y index -->
            <!-- Data type: Integer -->
]>


类 javax.imageio.metadata.IIOInvalidTreeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOInvalidTreeException
的使用

使用 IIOInvalidTreeException 的软件包
javax.imageio.metadata 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.metadata 中 IIOInvalidTreeException 的使用

抛出 IIOInvalidTreeException 的 javax.imageio.metadata 中的方法
abstract void | IIOMetadata.mergeTree(String formatName, Node root) 根据 XML DOM Node 树（其语法由给定元数据格式定义）改变此 IIOMetadata 对象的内部状态。
void | IIOMetadata.setFromTree(String formatName, Node root) 根据 XML DOM Node 的树（其语法由给定元数据格式定义）设置此 IIOMetadata 对象的内部状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.metadata.IIOMetadata 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOMetadata
的使用

使用 IIOMetadata 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio 中 IIOMetadata 的使用

声明为 IIOMetadata 的 javax.imageio 中的字段
protected  IIOMetadata IIOImage.metadata
包含与图像关联的元数据的 IIOMetadata 对象。

返回 IIOMetadata 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
IIOMetadata | ImageTranscoder.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param)
abstract IIOMetadata | ImageWriter.getDefaultImageMetadata(ImageTypeSpecifier imageType, ImageWriteParam param) 返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
abstract IIOMetadata | ImageWriter.getDefaultStreamMetadata(ImageWriteParam param) 返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。
abstract IIOMetadata | ImageReader.getImageMetadata(int imageIndex) 返回包含与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getImageMetadata(int imageIndex, String formatName, Set<String> nodeNames) 返回表示与给定图像关联的元数据的 IIOMetadata 对象，如果 reader 不支持读取元数据或者没有元数据可用，则返回 null。
IIOMetadata | IIOImage.getMetadata() 返回对当前 IIOMetadata 对象的引用，如果没有设置任何这样的对象，则返回 null。
abstract IIOMetadata | ImageReader.getStreamMetadata() 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）；如果 reader 不支持读取元数据、被设置为忽略元数据，或者没有元数据可用，则返回 null。
IIOMetadata | ImageReader.getStreamMetadata(String formatName, Set<String> nodeNames) 返回一个 IIOMetadata 对象，它表示作为一个整体与输入源关联的元数据（即不与任何特定图像关联）。

参数类型为 IIOMetadata 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
IIOMetadata | ImageTranscoder.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param)
int | ImageWriter.getNumThumbnailsSupported(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | ImageWriter.prepareWriteSequence(IIOMetadata streamMetadata) 使用提供的流元数据对象准备一个流，以接受一系列的后续 writeToSequence 调用。
void | ImageWriter.replaceImageMetadata(int imageIndex, IIOMetadata imageMetadata) 替换与现有图像有关的图像元数据。
void | ImageWriter.replaceStreamMetadata(IIOMetadata streamMetadata) 使用新信息替换输出中的流元数据。
void | IIOImage.setMetadata(IIOMetadata metadata) 将 IIOMetadata 设置为一个新对象或 null。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。

参数类型为 IIOMetadata 的 javax.imageio 中的构造方法
IIOImage(Raster raster, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 Raster 以及与之关联的缩略图和元数据。
IIOImage(RenderedImage image, List<? extends BufferedImage> thumbnails, IIOMetadata metadata)
构造一个 IIOImage，它包含 RenderedImage 以及与之关联的缩略图和元数据。

javax.imageio.metadata 中 IIOMetadata 的使用

参数类型为 IIOMetadata 的 javax.imageio.metadata 中的方法
 boolean IIOMetadataController.activate(IIOMetadata metadata)
激活控制器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.metadata.IIOMetadataController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.metadata.IIOMetadataController
的使用

使用 IIOMetadataController 的软件包
javax.imageio.metadata 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.metadata 中 IIOMetadataController 的使用

声明为 IIOMetadataController 的 javax.imageio.metadata 中的字段
protected IIOMetadataController | IIOMetadata.controller 调用 activateController 方法时，将用来为此 IIOMetadataController 对象提供设置值的 IIOParamController。
protected IIOMetadataController | IIOMetadata.defaultController 建议用作此 IIOMetadata 对象的控制器的 IIOMetadataController。

返回 IIOMetadataController 的 javax.imageio.metadata 中的方法
IIOMetadataController | IIOMetadata.getController() 返回当前已安装的所有 IIOMetadataController。
IIOMetadataController | IIOMetadata.getDefaultController() 返回默认 IIOMetadataController（如果有），不考虑当前安装的控制器。

参数类型为 IIOMetadataController 的 javax.imageio.metadata 中的方法
 void IIOMetadata.setController(IIOMetadataController controller)
设置在调用 activateController 方法时用来为此 IIOParam 对象提供设置值的 IIOMetadataController，重写任何默认控制器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.metadata.IIOMetadataFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.metadata.IIOMetadataFormat
的使用

使用 IIOMetadataFormat 的软件包
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.metadata 中 IIOMetadataFormat 的使用

实现 IIOMetadataFormat 的 javax.imageio.metadata 中的类
 class IIOMetadataFormatImpl
提供 IIOMetadataFormat 接口的可重用实现的具体类。

返回 IIOMetadataFormat 的 javax.imageio.metadata 中的方法
IIOMetadataFormat | IIOMetadata.getMetadataFormat(String formatName) 返回描述给定元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
static IIOMetadataFormat | IIOMetadataFormatImpl.getStandardFormatInstance() 返回描述标准、插件无关的 javax.imageio_1.0 元数据文档格式的 IIOMetadataFormat 对象，该文档格式在 javax.imageio.metadata 包的注释中描述。

javax.imageio.spi 中 IIOMetadataFormat 的使用

返回 IIOMetadataFormat 的 javax.imageio.spi 中的方法
IIOMetadataFormat | ImageReaderWriterSpi.getImageMetadataFormat(String formatName) 返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
IIOMetadataFormat | ImageReaderWriterSpi.getStreamMetadataFormat(String formatName) 返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.metadata.IIOMetadataFormatImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOMetadataFormatImpl
的使用

没有 javax.imageio.metadata.IIOMetadataFormatImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.metadata.IIOMetadataNode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.metadata.IIOMetadataNode
的使用

使用 IIOMetadataNode 的软件包
javax.imageio.metadata 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio.metadata 中 IIOMetadataNode 的使用

返回 IIOMetadataNode 的 javax.imageio.metadata 中的方法
protected IIOMetadataNode | IIOMetadata.getStandardChromaNode() 返回表示标准 javax_imageio_1.0 元数据格式的色度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardCompressionNode() 返回表示标准 javax_imageio_1.0 元数据格式的压缩信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardDataNode() 返回表示标准 javax_imageio_1.0 元数据格式的数据格式信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardDimensionNode() 返回表示标准 javax_imageio_1.0 元数据格式的维度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardDocumentNode() 返回表示标准 javax_imageio_1.0 元数据格式的文档信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTextNode() 返回表示标准 javax_imageio_1.0 元数据格式的文本信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTileNode() 返回表示标准 javax_imageio_1.0 元数据格式的平铺信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTransparencyNode() 返回表示标准 javax_imageio_1.0 元数据格式的透明度信息的 IIOMetadataNode；如果没有可用的此类信息，则返回 null。
protected IIOMetadataNode | IIOMetadata.getStandardTree() 返回表示此对象中所包含元数据的 IIOMetadataNode 的树（根据标准 javax_imageio_1.0 元数据格式的约定）的实用方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


JPEGHuffmanTable (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.plugins.jpeg
类 JPEGHuffmanTable

java.lang.Object
    继承者  javax.imageio.plugins.jpeg.JPEGHuffmanTable

public class JPEGHuffmanTable
extends Object

封装单个 JPEG Huffman 表的类。提供了一些字段，供从 JPEG 规范的 Annex K 中得到的“标准”表使用。这些表在默认情况下使用。此类与过去不受支持的 com.sun.image.codec.jpeg.JPEGHuffmanTable 有以下两个不同点：

  1. 此类的长度数组不包含被忽略的第 0 项。JPEG 流中的长度数组不包含额外项，此类用于表示 JPEG 流的内容。
  2. 过去的类在期望编码一个值的数组时不正确地引用 Huffman“符号”。此类使用 getValues 方法代替 getSymbols 方法。

有关内置 JPEG 插件的操作的更新信息，请参见 JPEG metadata format specification and usage notes。

字段摘要
static JPEGHuffmanTable | StdACChrominance 标准 AC 色度 Huffman 表。
static JPEGHuffmanTable | StdACLuminance 标准 AC 亮度 Huffman 表。
static JPEGHuffmanTable | StdDCChrominance 标准 DC 色度 Huffman 表。
static JPEGHuffmanTable | StdDCLuminance 标准 DC 亮度 Huffman 表。
构造方法摘要
JPEGHuffmanTable(short[] lengths, short[] values)
创建一个 Huffman 表并将其初始化。
方法摘要
short[] | getLengths() 返回 short 数组，该数组包含 Huffman 表每个长度的值数。
short[] | getValues() 返回 short 数组，该数组包含按其相应代码的长度递增排序的值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

StdDCLuminance

public static final JPEGHuffmanTable StdDCLuminance
标准 DC 亮度 Huffman 表。

StdDCChrominance

public static final JPEGHuffmanTable StdDCChrominance
标准 DC 色度 Huffman 表。

StdACLuminance

public static final JPEGHuffmanTable StdACLuminance
标准 AC 亮度 Huffman 表。

StdACChrominance

public static final JPEGHuffmanTable StdACChrominance
标准 AC 色度 Huffman 表。

构造方法详细信息

JPEGHuffmanTable

public JPEGHuffmanTable(short[] lengths,
                        short[] values)
创建一个 Huffman 表并将其初始化。复制输入数组。这些数组必须描述可能的 Huffman 表。例如，不能使用单个位表达 3 个代码。

参数：
lengths - short 数组，其中 lengths[k] 等于具有长度为 k + 1 位的相应代码的值的数量。
values - short 数组，该数组包含按代码长度递增排序的值。
抛出：
IllegalArgumentException - 如果 lengths 或 values 为 null、lengths 的长度大于 16、values 的长度大于 256；如果 lengths 或 values 中的任何值小于零；如果数组不描述有效的 Huffman 表。
方法详细信息

getLengths

public short[] getLengths()
返回 short 数组，该数组包含 Huffman 表每个长度的值数。返回的数组为副本。

返回：
short 数组，其中 array[k-1] 等于长度为 k 的表中的值数。
另请参见：
getValues()

getValues

public short[] getValues()
返回 short 数组，该数组包含按其相应代码的长度递增排序的值。对数组的解释依赖于从 getLengths 返回的值。返回的数组为副本。

返回：
值的 short 数组。
另请参见：
getLengths()

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


JPEGImageReadParam (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.plugins.jpeg
类 JPEGImageReadParam

java.lang.Object
    继承者  javax.imageio.IIOParam
        继承者  javax.imageio.ImageReadParam
            继承者  javax.imageio.plugins.jpeg.JPEGImageReadParam

public class JPEGImageReadParam
extends ImageReadParam

此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。此类的实例将从内置 JPEG ImageReader 的 getDefaultImageReadParam 方法返回。

这些新增功能的唯一目的是允许在解码简写流中使用表的规范。内置 JPEG reader 还将接受普通 ImageReadParam，这足以满足解码非简写流的需要。

简写流的表常常通过首先读取另一个仅包含表的简写流来获取，在有些应用程序中，这些表是提前准备好的。此类允许直接从客户端代码指定表。如果在流和 JPEGImageReadParam 中都没有指定任何表，则假定流使用“标准”视觉上无损失表。有关默认表的更多信息，请参见 JPEGQTable 和 JPEGHuffmanTable。

内置 JPEG reader 的 getDefaultReadParam 方法返回的默认 JPEGImageReadParam 不包含任何表。默认表可以从表类 JPEGQTable 和 JPEGHuffmanTable 获取。

如果流包含表，则忽略 JPEGImageReadParam 中给定的表。此外，如果流中的第一个图像包含表而后续图像不包含表，则在第一个图像中给定的表将用于所有简写图像。从流中读取表后，只有从相同流中后续读取的表才能重写它们。要指定新表，必须调用 reader 的 setInput 方法来更改流。

注意，此类不提供用来获取流中的表的方法。可以通过考虑使用 reader 返回的 IIOMetadata 对象从流中提取表。

有关内置 JPEG 插件的操作的更新信息，请参见 JPEG metadata format specification and usage notes。

字段摘要
从类 javax.imageio.ImageReadParam 继承的字段
canSetSourceRenderSize, destination, destinationBands, minProgressivePass, numProgressivePasses, sourceRenderSize
从类 javax.imageio.IIOParam 继承的字段
controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset
构造方法摘要
JPEGImageReadParam()
构造一个 JPEGImageReadParam。
方法摘要
boolean | areTablesSet() 如果表是当前设置的，则返回 true。
JPEGHuffmanTable[] | getACHuffmanTables() 返回最近一次调用 setDecodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGHuffmanTable[] | getDCHuffmanTables() 返回最近一次调用 setDecodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGQTable[] | getQTables() 返回最近一次调用 setDecodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
void | setDecodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在解码简写流中使用。
void | unsetDecodeTables() 移除当前设置的所有量化表和 Huffman 表。
从类 javax.imageio.ImageReadParam 继承的方法
canSetSourceRenderSize, getDestination, getDestinationBands, getSourceMaxProgressivePass, getSourceMinProgressivePass, getSourceNumProgressivePasses, getSourceRenderSize, setDestination, setDestinationBands, setDestinationType, setSourceProgressivePasses, setSourceRenderSize
从类 javax.imageio.IIOParam 继承的方法
activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setSourceBands, setSourceRegion, setSourceSubsampling
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JPEGImageReadParam

public JPEGImageReadParam()
构造一个 JPEGImageReadParam。

方法详细信息

areTablesSet

public boolean areTablesSet()
如果表是当前设置的，则返回 true。

返回：
如果表存在，则返回 true。

setDecodeTables

public void setDecodeTables(JPEGQTable[] qTables,
                            JPEGHuffmanTable[] DCHuffmanTables,
                            JPEGHuffmanTable[] ACHuffmanTables)
设置量化表和 Huffman 表以在解码简写流中使用。每个类型可能至多有 4 个表。在流中遇到表后，将忽略这些表。所有参数都必须为非 null。两个 Huffman 表的数组必须具有相同的元素数。假定流中的帧和扫描标题的表说明符等效于这些数组中的索引。使用此方法复制参数数组。

参数：
qTables - 量化表对象所组成的数组。
DCHuffmanTables - Huffman 表对象所组成的数组。
ACHuffmanTables - Huffman 表对象所组成的数组。
抛出：
IllegalArgumentException - 如果这些参数中的任何一个为 null、具有 4 个以上的元素，或者 DC 和 AC 的表数不同。
另请参见：
unsetDecodeTables()

unsetDecodeTables

public void unsetDecodeTables()
移除当前设置的所有量化表和 Huffman 表。

另请参见：
setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

getQTables

public JPEGQTable[] getQTables()
返回最近一次调用 setDecodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。

返回：
JPEGQTable 对象所组成的数组；或者 null。
另请参见：
setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

getDCHuffmanTables

public JPEGHuffmanTable[] getDCHuffmanTables()
返回最近一次调用 setDecodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。

返回：
JPEGHuffmanTable 对象所组成的数组；或者 null。
另请参见：
setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

getACHuffmanTables

public JPEGHuffmanTable[] getACHuffmanTables()
返回最近一次调用 setDecodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。

返回：
JPEGHuffmanTable 对象所组成的数组；或者 null。
另请参见：
setDecodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPEGImageWriteParam (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.plugins.jpeg
类 JPEGImageWriteParam

java.lang.Object
    继承者  javax.imageio.IIOParam
        继承者  javax.imageio.ImageWriteParam
            继承者  javax.imageio.plugins.jpeg.JPEGImageWriteParam

public class JPEGImageWriteParam
extends ImageWriteParam

此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。此类的实例将从内置 ImageWriter 的 getDefaultImageWriteParam 方法返回。

这些新增功能的主要目的是允许在编码简写流中使用表的规范。内置 JPEG writer 还将接受普通 ImageWriteParam，在这种情况下，writer 将在内部构造所需的表。

无论是哪种情况，在 ImageWriteParam 中设置的质量对于底层库而言意义都是相同的：1.00 表示全部为 1 的量化表，0.75 表示“标准”量化表（即视觉上无损失量化表），而 0.00 则表示全部为 255 的量化表。

简写流的表常常通过首先写入仅包含表的简写流来指定，在有些应用程序中，这些表是提前准备好的。此类允许直接从客户端代码指定表。

通常，表是在传入 writer 的 IIOMetadata 对象中指定的，这些对象中包括的所有表都会写入流中。如果没有在元数据中指定表，则写入简写流。如果元数据中不包括任何表并且也没有在 JPEGImageWriteParam 中指定任何表，则使用“标准”视觉上无损失表编码简写流。当某个简写流必须在没有首先向流中写入任何表的情况下进行写入时，需要使用此类来指定表。要使用此类，传入 writer 的元数据对象不能包含任何表，并且不能提供任何流元数据。有关默认表的更多信息，请参见 JPEGQTable 和 JPEGHuffmanTable。

writer 的 getDefaultWriteParam 方法返回的默认 JPEGImageWriteParam 不包含任何表。默认表包括在 writer 返回的默认 IIOMetadata 对象中。

如果元数据包含表，则忽略 JPEGImageWriteParam 中给定的表。此外，写入一组表后，只有元数据中的表可以重写它们来进行后续写入，不管写入相同的流还是不同的流。为了使用此类指定新表，必须调用 writer 的 reset 方法。

有关内置 JPEG 插件的操作的更新信息，请参见 JPEG metadata format specification and usage notes。

字段摘要
从类 javax.imageio.ImageWriteParam 继承的字段
canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, compressionMode, compressionQuality, compressionType, compressionTypes, locale, MODE_COPY_FROM_METADATA, MODE_DEFAULT, MODE_DISABLED, MODE_EXPLICIT, preferredTileSizes, progressiveMode, tileGridXOffset, tileGridYOffset, tileHeight, tileWidth, tilingMode, tilingSet
从类 javax.imageio.IIOParam 继承的字段
controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset
构造方法摘要
JPEGImageWriteParam(Locale locale)
构造一个 JPEGImageWriteParam。
方法摘要
boolean | areTablesSet() 如果表是当前设置的，则返回 true。
JPEGHuffmanTable[] | getACHuffmanTables() 返回最近一次调用 setEncodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
String[] | getCompressionQualityDescriptions() 返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。
float[] | getCompressionQualityValues() 返回一个 float 数组，可作为用户界面的一部分与 getCompressionQualityDescriptions 一起使用，以设置或显示压缩质量级别。
JPEGHuffmanTable[] | getDCHuffmanTables() 返回最近一次调用 setEncodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
boolean | getOptimizeHuffmanTables() 返回传入对 setOptimizeHuffmanTables 的最近一次调用中的值；如果从未调用 setOptimizeHuffmanTables，则返回 false。
JPEGQTable[] | getQTables() 返回最近一次调用 setEncodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
boolean | isCompressionLossless() 返回 false，因为 JPEG 插件仅支持有损失的压缩。
void | setEncodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在编码简写流中使用。
void | setOptimizeHuffmanTables(boolean optimize) 告知 writer 是否作为写入过程的一部分为图像生成最佳 Huffman 表。
void | unsetCompression() 移除所有以前的压缩质量设置值。
void | unsetEncodeTables() 移除当前设置的所有量化表和 Huffman 表。
从类 javax.imageio.ImageWriteParam 继承的方法
canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, getBitRate, getCompressionMode, getCompressionQuality, getCompressionType, getCompressionTypes, getLocale, getLocalizedCompressionTypeName, getPreferredTileSizes, getProgressiveMode, getTileGridXOffset, getTileGridYOffset, getTileHeight, getTileWidth, getTilingMode, setCompressionMode, setCompressionQuality, setCompressionType, setProgressiveMode, setTiling, setTilingMode, unsetTiling
从类 javax.imageio.IIOParam 继承的方法
activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setDestinationType, setSourceBands, setSourceRegion, setSourceSubsampling
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JPEGImageWriteParam

public JPEGImageWriteParam(Locale locale)
构造一个 JPEGImageWriteParam。不支持平铺。支持逐步编码。默认的逐步模式为 MODE_DISABLED。支持名为 "JPEG" 的单个压缩形式。默认的压缩质量为 0.75。

参数：
locale - 要由超类用于本地化压缩类型名称和质量描述的 Locale，或者为 null。
方法详细信息

unsetCompression

public void unsetCompression()
移除所有以前的压缩质量设置值。

默认实现将压缩质量重置为 0.75F。

覆盖：
类 ImageWriteParam 中的 unsetCompression
抛出：
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。
另请参见：
ImageWriteParam.setCompressionType(java.lang.String), ImageWriteParam.setCompressionQuality(float)

isCompressionLossless

public boolean isCompressionLossless()
返回 false，因为 JPEG 插件仅支持有损失的压缩。

覆盖：
类 ImageWriteParam 中的 isCompressionLossless
返回：
false。
抛出：
IllegalStateException - 如果压缩模式不是 MODE_EXPLICIT。

getCompressionQualityDescriptions

public String[] getCompressionQualityDescriptions()
从类 ImageWriteParam 复制的描述
返回一个 String 数组，可作为用户界面的一部分与 getCompressionQualityValues 一起使用，以设置或显示压缩质量级别。索引为 i 的 String 提供对质量级别范围的描述，该范围在 getCompressionQualityValues[i] 与 getCompressionQualityValues[i + 1] 之间。注意，从 getCompressionQualityValues 返回的数组长度将总是大于从 getCompressionQualityDescriptions 返回的数组长度。

例如，字符串 "Good"、"Better" 和 "Best" 可以与范围 [0, .33)、[.33, .66) 和 [.66, 1.0] 关联。在这种情况下，getCompressionQualityDescriptions 将返回 { "Good", "Better", "Best" }，getCompressionQualityValues 将返回 { 0.0F, .33F, .66F, 1.0F }。

如果没有描述可用，则返回 null。如果从 getCompressionQualityValues 返回 null，则此方法也必须返回 null。

应该为由 getLocale 返回的 Locale 将描述本地化，如果 Locale 为非 null 的话。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 为 null 或 getCompressionType() 为非 null，则返回 null。

覆盖：
类 ImageWriteParam 中的 getCompressionQualityDescriptions
返回：
包含压缩质量级别的本地化描述的 String 数组。
另请参见：
ImageWriteParam.getCompressionQualityValues()

getCompressionQualityValues

public float[] getCompressionQualityValues()
从类 ImageWriteParam 复制的描述
返回一个 float 数组，可作为用户界面的一部分与 getCompressionQualityDescriptions 一起使用，以设置或显示压缩质量级别。有关更多信息，请参阅 getCompressionQualityDescriptions。

如果没有描述可用，则返回 null。如果从 getCompressionQualityDescriptions 返回 null，则此方法也必须返回 null。

如果有多个压缩类型，但没有设置任何一种压缩类型，则抛出 IllegalStateException。

默认实现检查是否支持压缩，以及压缩模式是否为 MODE_EXPLICIT。如果是这样，而 getCompressionTypes() 为 null 或 getCompressionType() 为非 null，则返回 null。

覆盖：
类 ImageWriteParam 中的 getCompressionQualityValues
返回：
一个 float 数组，指示 getCompressionQualityDescriptions 中的 String 描述的压缩质量级别之间的分界线。
另请参见：
ImageWriteParam.getCompressionQualityDescriptions()

areTablesSet

public boolean areTablesSet()
如果表是当前设置的，则返回 true。

返回：
如果表存在，则返回 true。

setEncodeTables

public void setEncodeTables(JPEGQTable[] qTables,
                            JPEGHuffmanTable[] DCHuffmanTables,
                            JPEGHuffmanTable[] ACHuffmanTables)
设置量化表和 Huffman 表以在编码简写流中使用。每个类型可能至多有 4 个表。如果在元数据中指定了表，则忽略这些表。所有参数都必须为非 null。两个 Huffman 表的数组必须具有相同的元素数。假定元数据中的帧和扫描标题的表说明符等效于这些数组中的索引。使用此方法复制参数数组。

参数：
qTables - 量化表对象所组成的数组。
DCHuffmanTables - Huffman 表对象所组成的数组。
ACHuffmanTables - Huffman 表对象所组成的数组。
抛出：
IllegalArgumentException - 如果这些参数中的任何一个为 null 或者具有 4 个以上的元素，或者 DC 和 AC 的表数不同。
另请参见：
unsetEncodeTables()

unsetEncodeTables

public void unsetEncodeTables()
移除当前设置的所有量化表和 Huffman 表。

另请参见：
setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

getQTables

public JPEGQTable[] getQTables()
返回最近一次调用 setEncodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。

返回：
JPEGQTable 对象所组成的数组；或者 null。
另请参见：
setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

getDCHuffmanTables

public JPEGHuffmanTable[] getDCHuffmanTables()
返回最近一次调用 setEncodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。

返回：
JPEGHuffmanTable 对象所组成的数组；或者 null。
另请参见：
setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

getACHuffmanTables

public JPEGHuffmanTable[] getACHuffmanTables()
返回最近一次调用 setEncodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。

返回：
JPEGHuffmanTable 对象所组成的数组；或者 null。
另请参见：
setEncodeTables(javax.imageio.plugins.jpeg.JPEGQTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[], javax.imageio.plugins.jpeg.JPEGHuffmanTable[])

setOptimizeHuffmanTables

public void setOptimizeHuffmanTables(boolean optimize)
告知 writer 是否作为写入过程的一部分为图像生成最佳 Huffman 表。默认值为 false。如果将此标志设置为 true，则其重写在元数据中指定的所有表。注意，这意味着通过将此标志设置为 true 而写入的任何图像总是包含 Huffman 表。

参数：
optimize - 一个 boolean 值，指示是否在写入时生成最佳 Huffman 表。
另请参见：
getOptimizeHuffmanTables()

getOptimizeHuffmanTables

public boolean getOptimizeHuffmanTables()
返回传入对 setOptimizeHuffmanTables 的最近一次调用中的值；如果从未调用 setOptimizeHuffmanTables，则返回 false。

返回：
如果 writer 将生成最佳 Huffman 表，则返回 true。
另请参见：
setOptimizeHuffmanTables(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPEGQTable (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.plugins.jpeg
类 JPEGQTable

java.lang.Object
    继承者  javax.imageio.plugins.jpeg.JPEGQTable

public class JPEGQTable
extends Object

封装单个 JPEG 量化表的类。元素以自然顺序（而不是 Z 字形顺序）显示。提供了一些静态变量，供从 JPEG 规范的 Annex K 中得到的“标准”表和按照惯例用于视觉上无损失编码的默认表使用。

有关内置 JPEG 插件的操作的更新信息，请参见 JPEG metadata format specification and usage notes。

字段摘要
static JPEGQTable | K1Div2Luminance 在 JPEG 规范的表 K.1 中给出的样本亮度量化表，其中所有元素都除以 2。
static JPEGQTable | K1Luminance 在 JPEG 规范的表 K.1 中给出的样本亮度量化表。
static JPEGQTable | K2Chrominance 在 JPEG 规范的表 K.2 中给出的样本色度量化表。
static JPEGQTable | K2Div2Chrominance 在 JPEG 规范的表 K.2 中给出的样本色度量化表，其中所有元素都除以 2。
构造方法摘要
JPEGQTable(int[] table)
根据参数构造一个量化表，该参数必须包含以自然顺序（非 Z 字形顺序）显示的 64 个元素。
方法摘要
JPEGQTable | getScaledInstance(float scaleFactor, boolean forceBaseline) 返回新的量化表，其中所有值都乘以 scaleFactor，然后取 1 到 32767（如果 forceBaseline 为 true，则使用 1 到 255）范围中的值。
int[] | getTable() 以 int 数组的形式按自然（非 Z 字形）顺序返回当前量化表的副本。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

K1Luminance

public static final JPEGQTable K1Luminance
在 JPEG 规范的表 K.1 中给出的样本亮度量化表。根据该规范，这些值将产生“良好的”质量输出。

另请参见：
K1Div2Luminance

K1Div2Luminance

public static final JPEGQTable K1Div2Luminance
在 JPEG 规范的表 K.1 中给出的样本亮度量化表，其中所有元素都除以 2。根据该规范，这些表将产生“很好的”质量输出。此表通常用于进行“视觉上无损失”编码，如果使用默认表和质量设置，则此为默认亮度表。

另请参见：
K1Luminance

K2Chrominance

public static final JPEGQTable K2Chrominance
在 JPEG 规范的表 K.2 中给出的样本色度量化表。根据该规范，这些值将产生“良好的”质量输出。

另请参见：
K2Div2Chrominance

K2Div2Chrominance

public static final JPEGQTable K2Div2Chrominance
在 JPEG 规范的表 K.2 中给出的样本色度量化表，其中所有元素都除以 2。根据规范，这些表将产生“很好的”质量输出。此表通常用于进行“视觉上无损失”编码，如果使用默认表和质量设置，则此为默认色度表。

另请参见：
K2Chrominance
构造方法详细信息

JPEGQTable

public JPEGQTable(int[] table)
根据参数构造一个量化表，该参数必须包含以自然顺序（非 Z 字形顺序）显示的 64 个元素。副本由输入数组生成。

参数：
table - 以 int 数组形式表示的量化表。
抛出：
IllegalArgumentException - 如果 table 为 null 或者 table.length 不等于 64。
方法详细信息

getTable

public int[] getTable()
以 int 数组的形式按自然（非 Z 字形）顺序返回当前量化表的副本。

返回：
当前量化表的副本。

getScaledInstance

public JPEGQTable getScaledInstance(float scaleFactor,
                                    boolean forceBaseline)
返回新的量化表，其中所有值都乘以 scaleFactor，然后取 1 到 32767（如果 forceBaseline 为 true，则使用 1 到 255）范围中的值。

scaleFactorless 的值小于 1 能提高表的质量水平；值大于 1.0 则降低表的质量水平。

参数：
scaleFactor - 表的乘法因子。
forceBaseline - 如果为 true，则取 1 到 255 范围内的值。
返回：
一个新量化表，它是当前表的线性倍数。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.imageio.plugins.jpeg (Java 2 Platform SE 6)

 javax.imageio.plugins.jpeg
类
JPEGHuffmanTable
JPEGImageReadParam
JPEGImageWriteParam
JPEGQTable


javax.imageio.plugins.jpeg (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.imageio.plugins.jpeg

支持内置 JPEG 插件的类。

请参见：
描述

类摘要
JPEGHuffmanTable | 封装单个 JPEG Huffman 表的类。
JPEGImageReadParam | 此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。
JPEGImageWriteParam | 此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。
JPEGQTable | 封装单个 JPEG 量化表的类。

软件包 javax.imageio.plugins.jpeg 的描述

支持内置 JPEG 插件的类。

此包包含一些支持内置 JPEG reader 和 writer 插件的类。提供了一些类来表示量化表和 Huffman 表，还提供 ImageReadParam 和 ImageWriteParam 的扩展以在读取和写入过程中提供表格。有关内置 JPEG 插件的操作的更新信息，请参见 JPEG metadata format specification and usage notes。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.imageio.plugins.jpeg 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.plugins.jpeg 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageReadParam
        • javax.imageio.plugins.jpeg.JPEGImageReadParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.jpeg.JPEGImageWriteParam
    • javax.imageio.plugins.jpeg.JPEGHuffmanTable
    • javax.imageio.plugins.jpeg.JPEGQTable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.imageio.plugins.jpeg 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.plugins.jpeg
的使用

使用 javax.imageio.plugins.jpeg 的软件包
javax.imageio.plugins.jpeg 支持内置 JPEG 插件的类。

javax.imageio.plugins.jpeg 使用的 javax.imageio.plugins.jpeg 中的类
JPEGHuffmanTable
封装单个 JPEG Huffman 表的类。
JPEGQTable
封装单个 JPEG 量化表的类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.plugins.jpeg.JPEGHuffmanTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGHuffmanTable
的使用

使用 JPEGHuffmanTable 的软件包
javax.imageio.plugins.jpeg 支持内置 JPEG 插件的类。

javax.imageio.plugins.jpeg 中 JPEGHuffmanTable 的使用

声明为 JPEGHuffmanTable 的 javax.imageio.plugins.jpeg 中的字段
static JPEGHuffmanTable | JPEGHuffmanTable.StdACChrominance 标准 AC 色度 Huffman 表。
static JPEGHuffmanTable | JPEGHuffmanTable.StdACLuminance 标准 AC 亮度 Huffman 表。
static JPEGHuffmanTable | JPEGHuffmanTable.StdDCChrominance 标准 DC 色度 Huffman 表。
static JPEGHuffmanTable | JPEGHuffmanTable.StdDCLuminance 标准 DC 亮度 Huffman 表。

返回 JPEGHuffmanTable 的 javax.imageio.plugins.jpeg 中的方法
JPEGHuffmanTable[] | JPEGImageReadParam.getACHuffmanTables() 返回最近一次调用 setDecodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGHuffmanTable[] | JPEGImageWriteParam.getACHuffmanTables() 返回最近一次调用 setEncodeTables 设置的 AC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGHuffmanTable[] | JPEGImageReadParam.getDCHuffmanTables() 返回最近一次调用 setDecodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGHuffmanTable[] | JPEGImageWriteParam.getDCHuffmanTables() 返回最近一次调用 setEncodeTables 设置的 DC Huffman 表所组成数组的一个副本；如果当前没有设置表，则返回 null。

参数类型为 JPEGHuffmanTable 的 javax.imageio.plugins.jpeg 中的方法
void | JPEGImageReadParam.setDecodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在解码简写流中使用。
void | JPEGImageReadParam.setDecodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在解码简写流中使用。
void | JPEGImageWriteParam.setEncodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在编码简写流中使用。
void | JPEGImageWriteParam.setEncodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在编码简写流中使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.plugins.jpeg.JPEGImageReadParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGImageReadParam
的使用

没有 javax.imageio.plugins.jpeg.JPEGImageReadParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.plugins.jpeg.JPEGImageWriteParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGImageWriteParam
的使用

没有 javax.imageio.plugins.jpeg.JPEGImageWriteParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.plugins.jpeg.JPEGQTable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.jpeg.JPEGQTable
的使用

使用 JPEGQTable 的软件包
javax.imageio.plugins.jpeg 支持内置 JPEG 插件的类。

javax.imageio.plugins.jpeg 中 JPEGQTable 的使用

声明为 JPEGQTable 的 javax.imageio.plugins.jpeg 中的字段
static JPEGQTable | JPEGQTable.K1Div2Luminance 在 JPEG 规范的表 K.1 中给出的样本亮度量化表，其中所有元素都除以 2。
static JPEGQTable | JPEGQTable.K1Luminance 在 JPEG 规范的表 K.1 中给出的样本亮度量化表。
static JPEGQTable | JPEGQTable.K2Chrominance 在 JPEG 规范的表 K.2 中给出的样本色度量化表。
static JPEGQTable | JPEGQTable.K2Div2Chrominance 在 JPEG 规范的表 K.2 中给出的样本色度量化表，其中所有元素都除以 2。

返回 JPEGQTable 的 javax.imageio.plugins.jpeg 中的方法
JPEGQTable[] | JPEGImageReadParam.getQTables() 返回最近一次调用 setDecodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGQTable[] | JPEGImageWriteParam.getQTables() 返回最近一次调用 setEncodeTables 设置的量化表所组成数组的一个副本；如果当前没有设置表，则返回 null。
JPEGQTable | JPEGQTable.getScaledInstance(float scaleFactor, boolean forceBaseline) 返回新的量化表，其中所有值都乘以 scaleFactor，然后取 1 到 32767（如果 forceBaseline 为 true，则使用 1 到 255）范围中的值。

参数类型为 JPEGQTable 的 javax.imageio.plugins.jpeg 中的方法
void | JPEGImageReadParam.setDecodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在解码简写流中使用。
void | JPEGImageWriteParam.setEncodeTables(JPEGQTable[] qTables, JPEGHuffmanTable[] DCHuffmanTables, JPEGHuffmanTable[] ACHuffmanTables) 设置量化表和 Huffman 表以在编码简写流中使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BMPImageWriteParam (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.plugins.bmp
类 BMPImageWriteParam

java.lang.Object
    继承者  javax.imageio.IIOParam
        继承者  javax.imageio.ImageWriteParam
            继承者  javax.imageio.plugins.bmp.BMPImageWriteParam

public class BMPImageWriteParam
extends ImageWriteParam

用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

此类允许在编写 BMP 格式图像文件时使用各种参数规范。默认情况下，数据布局是从下到上的，这样像素以从下到上的顺序存储，第一个扫描行存储在最后。

通过使用 setCompressionType() 方法结合适当的类型字符串，可以指定使用特定的压缩方案。当且仅当指定的压缩方案与要编写的图像的类型兼容时，指定的压缩方案才能实施。如果指定的压缩方案与要编写的图像的类型不兼容，则 BMP 图像 writer 将抛出 IOException。如果压缩类型不是显式设置的，则 getCompressionType() 将返回 null。在这种情况下，BMP 图像 writer 将选择支持给定图像的编码而不损失颜色分辨率的压缩类型。

下表列出了压缩类型字符串以及各自支持的图像类型：

压缩类型
类型字符串 | 描述 | 图像类型
BI_RGB | Uncompressed RLE | <= 8-bits/sample
BI_RLE8 | 8-bit Run Length Encoding | <= 8-bits/sample
BI_RLE4 | 4-bit Run Length Encoding | <= 4-bits/sample
BI_BITFIELDS | Packed data | 16 or 32 bits/sample

字段摘要
从类 javax.imageio.ImageWriteParam 继承的字段
canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, compressionMode, compressionQuality, compressionType, compressionTypes, locale, MODE_COPY_FROM_METADATA, MODE_DEFAULT, MODE_DISABLED, MODE_EXPLICIT, preferredTileSizes, progressiveMode, tileGridXOffset, tileGridYOffset, tileHeight, tileWidth, tilingMode, tilingSet
从类 javax.imageio.IIOParam 继承的字段
controller, defaultController, destinationOffset, destinationType, sourceBands, sourceRegion, sourceXSubsampling, sourceYSubsampling, subsamplingXOffset, subsamplingYOffset
构造方法摘要
BMPImageWriteParam()
构造一个所有参数均为默认值并具有为 null 的 Locale 的 BMPImageWriteParam 对象。
BMPImageWriteParam(Locale locale)
构造一个设置为使用给定 Locale 并且所有参数都采用默认值的 BMPImageWriteParam。
方法摘要
boolean | isTopDown() 返回 topDown 参数的值。
void | setTopDown(boolean topDown) 如果设置，则数据以从上到下的方式写出，首先写出第一个扫描行。
从类 javax.imageio.ImageWriteParam 继承的方法
canOffsetTiles, canWriteCompressed, canWriteProgressive, canWriteTiles, getBitRate, getCompressionMode, getCompressionQuality, getCompressionQualityDescriptions, getCompressionQualityValues, getCompressionType, getCompressionTypes, getLocale, getLocalizedCompressionTypeName, getPreferredTileSizes, getProgressiveMode, getTileGridXOffset, getTileGridYOffset, getTileHeight, getTileWidth, getTilingMode, isCompressionLossless, setCompressionMode, setCompressionQuality, setCompressionType, setProgressiveMode, setTiling, setTilingMode, unsetCompression, unsetTiling
从类 javax.imageio.IIOParam 继承的方法
activateController, getController, getDefaultController, getDestinationOffset, getDestinationType, getSourceBands, getSourceRegion, getSourceXSubsampling, getSourceYSubsampling, getSubsamplingXOffset, getSubsamplingYOffset, hasController, setController, setDestinationOffset, setDestinationType, setSourceBands, setSourceRegion, setSourceSubsampling
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

BMPImageWriteParam

public BMPImageWriteParam(Locale locale)
构造一个设置为使用给定 Locale 并且所有参数都采用默认值的 BMPImageWriteParam。

参数：
locale - 要用于本地化压缩类型名称和质量描述的 Locale，或者为 null。

BMPImageWriteParam

public BMPImageWriteParam()
构造一个所有参数均为默认值并具有为 null 的 Locale 的 BMPImageWriteParam 对象。

方法详细信息

setTopDown

public void setTopDown(boolean topDown)
如果设置，则数据以从上到下的方式写出，首先写出第一个扫描行。

参数：
topDown - 是否以从上到下的顺序写出数据。

isTopDown

public boolean isTopDown()
返回 topDown 参数的值。默认值为 false。

返回：
是否以从上到下的顺序写出数据。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.imageio.plugins.bmp (Java 2 Platform SE 6)

 javax.imageio.plugins.bmp
类
BMPImageWriteParam


javax.imageio.plugins.bmp (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.imageio.plugins.bmp

包含供内置 BMP 插件使用的公共类的包。

请参见：
描述

类摘要
BMPImageWriteParam 用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

软件包 javax.imageio.plugins.bmp 的描述

包含供内置 BMP 插件使用的公共类的包。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.imageio.plugins.bmp 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.plugins.bmp 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.imageio.IIOParam
      • javax.imageio.ImageWriteParam
        • javax.imageio.plugins.bmp.BMPImageWriteParam
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.imageio.plugins.bmp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.plugins.bmp
的使用

没有 javax.imageio.plugins.bmp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.plugins.bmp.BMPImageWriteParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.plugins.bmp.BMPImageWriteParam
的使用

没有 javax.imageio.plugins.bmp.BMPImageWriteParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


IIORegistry (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 IIORegistry

java.lang.Object
    继承者  javax.imageio.spi.ServiceRegistry
        继承者  javax.imageio.spi.IIORegistry

public final class IIORegistry
extends ServiceRegistry

用于服务提供者实例的注册表。使用包含服务提供者类的 JAR 文件中的元信息可在运行时检测服务提供者。这是一种相对划算的加载和检查所有可用的服务提供者类的方式。然后可使用这些类定位和实例化更具重量级的将执行实际工作的类，这里指 ImageReader、ImageWriter、ImageTranscoder、ImageInputStream 和 ImageOutputStream 的实例。

在系统类路径（例如，Sun 的 JDK 实现中的 jre/lib/ext 目录）中找到的服务提供者在此类实例化后即自动加载。

调用 registerApplicationClasspathSpis 方法时，在应用程序类路径中的 JAR 文件的元信息部分声明的服务提供者实例将被加载。为声明服务提供者，在每个 JAR 文件都有的 META-INF 目录中加入一个 services 子目录。此目录针对每个在 JAR 文件中具有一个或多个实现类的服务提供者接口都包含一个文件。例如，假设 JAR 文件包含了一个名为 com.mycompany.imageio.MyFormatReaderSpi 的类，它实现 ImageReaderSpi 接口，则此 JAR 文件将包含一个名称如下所示的文件：

 META-INF/services/javax.imageio.spi.ImageReaderSpi
包含行：
 com.mycompany.imageio.MyFormatReaderSpi

服务提供者类为轻量级的，可快速加载。这些接口的实现应避免复杂化其他类和本地代码的依赖关系。

还可以手动添加无法自动找到的服务提供者，也可以手动移除那些使用 ServiceRegistry 类的接口的服务提供者。因此，应用程序可根据需要自定义注册表的内容。

有关声明服务提供者和通用 JAR 格式的更详细的信息，请参见 JAR File Specification。

嵌套类摘要
从类 javax.imageio.spi.ServiceRegistry 继承的嵌套类/接口
ServiceRegistry.Filter
方法摘要
static IIORegistry | getDefaultInstance() 返回 Image I/O API 使用的默认 IIORegistry 实例。
void | registerApplicationClasspathSpis() 使用默认的 ClassLoader 注册应用程序类路径中找到的所有可用的服务提供者。
从类 javax.imageio.spi.ServiceRegistry 继承的方法
contains, deregisterAll, deregisterAll, deregisterServiceProvider, deregisterServiceProvider, finalize, getCategories, getServiceProviderByClass, getServiceProviders, getServiceProviders, lookupProviders, lookupProviders, registerServiceProvider, registerServiceProvider, registerServiceProviders, setOrdering, unsetOrdering
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getDefaultInstance

public static IIORegistry getDefaultInstance()
返回 Image I/O API 使用的默认 IIORegistry 实例。此实例应该用于所有注册表功能。

每个 ThreadGroup 将收到其自身的实例；这样同一个浏览器（举例）中的每个不同的 Applet 都将有其自己的注册表。

返回：
当前 ThreadGroup 的默认注册表。

registerApplicationClasspathSpis

public void registerApplicationClasspathSpis()
使用默认的 ClassLoader 注册应用程序类路径中找到的所有可用的服务提供者。此方法通常由 ImageIO.scanForPlugins 方法调用。

另请参见：
ImageIO.scanForPlugins(), ClassLoader.getResources(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


IIOServiceProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 IIOServiceProvider

java.lang.Object
    继承者  javax.imageio.spi.IIOServiceProvider
所有已实现的接口：
RegisterableService
直接已知子类：
ImageInputStreamSpi, ImageOutputStreamSpi, ImageReaderWriterSpi, ImageTranscoderSpi
public abstract class IIOServiceProvider
extends Object
implements RegisterableService

一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。有关服务提供者类的更多信息，请参见 IIORegistry 类的注释。

另请参见：
IIORegistry, ImageReaderSpi, ImageWriterSpi, ImageTranscoderSpi, ImageInputStreamSpi

字段摘要
protected String | vendorName 将从 getVendorName 返回的一个 String，初始值为 null。
protected String | version 将从 getVersion 返回的一个 String，初始值为 null。
构造方法摘要
IIOServiceProvider()
构造一个空的 IIOServiceProvider。
IIOServiceProvider(String vendorName, String version)
构造一个具有给定供应商名称和版本标识符的 IIOServiceProvider。
方法摘要
abstract String | getDescription(Locale locale) 返回此服务提供者及其相关实现的一个简明的可读描述。
String | getVendorName() 返回负责创建此服务提供者及其相关实现的供应商名称。
String | getVersion() 返回描述此服务提供者版本号及其相关实现的字符串。
void | onDeregistration(ServiceRegistry registry, Class<?> category) Spi 类一从 ServiceRegistry 中注销即执行的回调。
void | onRegistration(ServiceRegistry registry, Class<?> category) 在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

vendorName

protected String vendorName
将从 getVendorName 返回的一个 String，初始值为 null。构造方法应将此字符串设置为一个非 null 的值。

version

protected String version
将从 getVersion 返回的一个 String，初始值为 null。构造方法应将此字符串设置为一个非 null 的值。

构造方法详细信息

IIOServiceProvider

public IIOServiceProvider(String vendorName,
                          String version)
构造一个具有给定供应商名称和版本标识符的 IIOServiceProvider。

参数：
vendorName - 供应商名称。
version - 版本标识符。
抛出：
IllegalArgumentException - 如果 vendorName 为 null。
IllegalArgumentException - 如果 version 为 null。

IIOServiceProvider

public IIOServiceProvider()
构造一个空的 IIOServiceProvider。为确保 getVendorName 和 getVersion 方法返回非 null 值，子类需负责初始化实例变量和/或重写方法实现。

方法详细信息

onRegistration

public void onRegistration(ServiceRegistry registry,
                           Class<?> category)
在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。可用它来验证环境是否适合此服务，例如验证本地库是否可加载。如果服务无法在找到其自身的环境中正常工作，则它将从注册表中取消其自身的注册。

此方法只应由注册表调用。

默认实现不执行任何操作。

指定者：
接口 RegisterableService 中的 onRegistration
参数：
registry - 此对象已注册的 ServiceRegistry 位置。
category - 指示此对象注册所在的注册表类别的 Class 对象。
另请参见：
ServiceRegistry.registerServiceProvider(Object provider)

onDeregistration

public void onDeregistration(ServiceRegistry registry,
                             Class<?> category)
Spi 类一从 ServiceRegistry 中注销即执行的回调。

此方法只应由注册表调用。

默认实现不执行任何操作。

指定者：
接口 RegisterableService 中的 onDeregistration
参数：
registry - 从其（部分或完全）注销此对象的 ServiceRegistry。
category - 指示此对象从其注销的注册表类别的 Class 对象。
另请参见：
ServiceRegistry.deregisterServiceProvider(Object provider)

getVendorName

public String getVendorName()
返回负责创建此服务提供者及其相关实现的供应商名称。供应商名称可用于选择服务提供者，不要对其进行本地化。

默认的实现返回 vendorName 实例变量的值。

返回：
包含供应商名称的一个非 null 的 String。

getVersion

public String getVersion()
返回描述此服务提供者版本号及其相关实现的字符串。版本可能由代码转换程序用来标识它们所理解的服务提供者，因此不对此方法本地化。

默认的实现返回 version 实例变量的值。

返回：
包含此服务提供者的版本的一个非 null 的 String。

getDescription

public abstract String getDescription(Locale locale)
返回此服务提供者及其相关实现的一个简明的可读描述。如果可能，应将结果字符串本地化为指定的 Locale。

参数：
locale - 应将返回的值本地化的目标 Locale。
返回：
包含对此服务提供者描述的 String。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageInputStreamSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 ImageInputStreamSpi

java.lang.Object
    继承者  javax.imageio.spi.IIOServiceProvider
        继承者  javax.imageio.spi.ImageInputStreamSpi
所有已实现的接口：
RegisterableService
public abstract class ImageInputStreamSpi
extends IIOServiceProvider

用于 ImageInputStream 的服务提供者接口 (SPI)。有关服务提供者接口的更多信息，请参见 IIORegistry 类的类注释。

此接口允许由 ImageInputStream 的实例“包装”任意对象。例如，一个特定的 ImageInputStreamSpi 可能允许使用一般的 InputStream 充当输入源；另一个可能使用来自 URL 的输入。

通过将 ImageInputStream 的创建作为一个可插入的服务，实现了在不更改 API 的情况下对后续的输入源的处理。另外，应用程序可以透明的方式安装和使用 ImageInputStream 的高性能实现（例如，用于特定平台的本地实现）。

另请参见：
IIORegistry, ImageInputStream

字段摘要
protected  Class<?> inputClass
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
从类 javax.imageio.spi.IIOServiceProvider 继承的字段
vendorName, version
构造方法摘要
protected | ImageInputStreamSpi() 构造一个空的 ImageInputStreamSpi。
 | ImageInputStreamSpi(String vendorName, String version, Class<?> inputClass) 用给定的一组值构造 ImageInputStreamSpi。
方法摘要
boolean | canUseCacheFile() 如果与此服务提供者关联的 ImageInputStream 实现可选择利用缓存文件改善性能和/或内存占用，则返回 true。
ImageInputStream | createInputStreamInstance(Object input) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
abstract ImageInputStream | createInputStreamInstance(Object input, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
Class<?> | getInputClass() 返回表示必须由输入源实现（以便使用 createInputStreamInstance 方法在 ImageInputStream 中“包装”）的类或接口的类型的 Class 对象。
boolean | needsCacheFile() 如果与此服务提供者关联的 ImageInputStream 实现要求使用缓存 File，则返回 true。
从类 javax.imageio.spi.IIOServiceProvider 继承的方法
getDescription, getVendorName, getVersion, onDeregistration, onRegistration
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

inputClass

protected Class<?> inputClass
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。

构造方法详细信息

ImageInputStreamSpi

protected ImageInputStreamSpi()
构造一个空的 ImageInputStreamSpi。为提供所有方法的可用版本，由子类负责初始化实例变量和/或重写方法实现。

ImageInputStreamSpi

public ImageInputStreamSpi(String vendorName,
                           String version,
                           Class<?> inputClass)
用给定的一组值构造 ImageInputStreamSpi。

参数：
vendorName - 供应商名称。
version - 版本标识符。
inputClass - 指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
抛出：
IllegalArgumentException - 如果 vendorName 为 null。
IllegalArgumentException - 如果 version 为 null。
方法详细信息

getInputClass

public Class<?> getInputClass()
返回表示必须由输入源实现（以便使用 createInputStreamInstance 方法在 ImageInputStream 中“包装”）的类或接口的类型的 Class 对象。

通常的返回值可能包含 InputStream.class 或 URL.class，但可能使用任何类。

返回：
一个 Class 变量。
另请参见：
createInputStreamInstance(Object, boolean, File)

canUseCacheFile

public boolean canUseCacheFile()
如果与此服务提供者关联的 ImageInputStream 实现可选择利用缓存文件改善性能和/或内存占用，则返回 true。如果为 false，则忽略 createInputStreamInstance 的 useCache 参数的值。

默认实现返回 false。

返回：
如果此服务提供者创建的输入流有可使用的缓存文件，则返回 true。

needsCacheFile

public boolean needsCacheFile()
如果与此服务提供者关联的 ImageInputStream 实现要求使用缓存 File，则返回 true。如果为 true，将忽略 createInputStreamInstance 的 useCache 变量的值。

默认实现返回 false。

返回：
如果此服务提供者创建的输入流需要使用缓存文件，则返回 true。

createInputStreamInstance

public abstract ImageInputStream createInputStreamInstance(Object input,
                                                           boolean useCache,
                                                           File cacheDir)
                                                    throws IOException
返回与此服务提供者关联的 ImageInputStream 实现的实例。如果使用缓存文件为可选项，则将参考 useCache 参数。在要求使用缓存，或缓存不适用时，将忽略 useCache 的值。

参数：
input - 一个由 getInputClass 返回的类类型的对象。
useCache - 在可选的情况下指示是否应使用缓存文件的 boolean。
cacheDir - 指示创建缓存文件的位置的 File，或者为 null，以指示使用系统目录。
返回：
一个 ImageInputStream 实例。
抛出：
IllegalArgumentException - 如果 input 不是一个正确的类的实例，或者为 null。
IllegalArgumentException - 如果需要缓存文件但 cacheDir 为非 null 并且也不是一个目录。
IOException - 如果需要缓存文件但无法创建。
另请参见：
getInputClass(),
canUseCacheFile(),
needsCacheFile()

createInputStreamInstance

public ImageInputStream createInputStreamInstance(Object input)
                                           throws IOException
返回与此服务提供者关联的 ImageInputStream 实现的实例。如果需要，将在系统相应的默认临时文件目录中创建缓存文件。

参数：
input - 一个由 getInputClass 返回的类类型的对象。
返回：
一个 ImageInputStream 实例。
抛出：
IllegalArgumentException - 如果 input 不是一个正确的类的实例，或者为 null。
IOException - 如果需要缓存文件但无法创建。
另请参见：
getInputClass()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageOutputStreamSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 ImageOutputStreamSpi

java.lang.Object
    继承者  javax.imageio.spi.IIOServiceProvider
        继承者  javax.imageio.spi.ImageOutputStreamSpi
所有已实现的接口：
RegisterableService
public abstract class ImageOutputStreamSpi
extends IIOServiceProvider

用于 ImageOutputStream 的服务提供者接口 (SPI)。有关服务提供者接口的更多信息，请参见 IIORegistry 类的注释。

此接口允许由 ImageOutputStream 的实例“包装”任意对象。例如，特定的 ImageOutputStreamSpi 可能允许使用一般的 OutputStream 充当目标位置；另一个可能输出到一个 File 或类似串行端口的设备。

通过将 ImageOutputStream 的创建作为一个可插入的服务，实现了在不更改 API 的情况下对后续的输出目标位置的处理。另外，应用程序可以透明的方式安装和使用 ImageOutputStream 的高性能实现（例如，用于特定平台的本地实现）。

另请参见：
IIORegistry, ImageOutputStream

字段摘要
protected  Class<?> outputClass
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。
从类 javax.imageio.spi.IIOServiceProvider 继承的字段
vendorName, version
构造方法摘要
protected | ImageOutputStreamSpi() 构造一个空的 ImageOutputStreamSpi。
 | ImageOutputStreamSpi(String vendorName, String version, Class<?> outputClass) 用给定的一组值构造 ImageOutputStreamSpi。
方法摘要
boolean | canUseCacheFile() 如果与此服务提供者关联的 ImageOutputStream 实现可选择利用缓存 File 改善性能和/或内存占用，则返回 true。
ImageOutputStream | createOutputStreamInstance(Object output) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
abstract ImageOutputStream | createOutputStreamInstance(Object output, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
Class<?> | getOutputClass() 返回表示必须由输出目标位置实现（以便使用 createOutputStreamInstance 方法在 ImageOutputStream 中“包装”）的类或接口的类型的 Class 对象。
boolean | needsCacheFile() 如果与此服务提供者关联的 ImageOutputStream 实现要求使用缓存 File，则返回 true。
从类 javax.imageio.spi.IIOServiceProvider 继承的方法
getDescription, getVendorName, getVersion, onDeregistration, onRegistration
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

outputClass

protected Class<?> outputClass
指示供 createInputStreamInstance 方法使用的合法对象类型的 Class 对象。

构造方法详细信息

ImageOutputStreamSpi

protected ImageOutputStreamSpi()
构造一个空的 ImageOutputStreamSpi。为提供所有方法的可用版本，由子类负责初始化实例变量和/或重写方法实现。

ImageOutputStreamSpi

public ImageOutputStreamSpi(String vendorName,
                            String version,
                            Class<?> outputClass)
用给定的一组值构造 ImageOutputStreamSpi。

参数：
vendorName - 供应商名称。
version - 版本标识符。
outputClass - 指示供 createOutputStreamInstance 方法使用的合法对象类型的 Class 对象。
抛出：
IllegalArgumentException - 如果 vendorName 为 null。
IllegalArgumentException - 如果 version 为 null。
方法详细信息

getOutputClass

public Class<?> getOutputClass()
返回表示必须由输出目标位置实现（以便使用 createOutputStreamInstance 方法在 ImageOutputStream 中“包装”）的类或接口的类型的 Class 对象。

通常的返回值可能包含 OutputStream.class 或 File.class，但可能使用任何类。

返回：
一个 Class 变量。
另请参见：
createOutputStreamInstance(Object, boolean, File)

canUseCacheFile

public boolean canUseCacheFile()
如果与此服务提供者关联的 ImageOutputStream 实现可选择利用缓存 File 改善性能和/或内存占用，则返回 true。如果为 false，将忽略 createOutputStreamInstance 的 cacheFile 参数的值。

默认实现返回 false。

返回：
如果此服务提供者创建的输出流有可使用的缓存文件，则返回 true。

needsCacheFile

public boolean needsCacheFile()
如果与此服务提供者关联的 ImageOutputStream 实现要求使用缓存 File，则返回 true。

默认实现返回 false。

返回：
如果此服务提供者创建的输出流需要使用缓存文件，则返回 true。

createOutputStreamInstance

public abstract ImageOutputStream createOutputStreamInstance(Object output,
                                                             boolean useCache,
                                                             File cacheDir)
                                                      throws IOException
返回与此服务提供者关联的 ImageOutputStream 实现的实例。如果使用缓存文件为可选项，则将参考 useCache 参数。在要求使用缓存，或缓存不适用时，将忽略 useCache 的值。

参数：
output - 一个由 getOutputClass 返回的类类型的对象。
useCache - 在可选的情况下指示是否应使用缓存文件的 boolean。
cacheDir - 指示创建缓存文件的位置的 File，或者为 null，以指示使用系统目录。
返回：
一个 ImageOutputStream 实例。
抛出：
IllegalArgumentException - 如果 output 不是一个正确的类的实例，或者为 null。
IllegalArgumentException - 如果需要缓存文件，但 cacheDir 为非 null 并且也不是一个目录。
IOException - 如果需要缓存文件但无法创建。
另请参见：
getOutputClass()

createOutputStreamInstance

public ImageOutputStream createOutputStreamInstance(Object output)
                                             throws IOException
返回与此服务提供者关联的 ImageOutputStream 实现的实例。如果需要，将在系统相应的默认临时文件目录中创建缓存文件。

参数：
output - 一个由 getOutputClass 返回的类类型的对象。
返回：
一个 ImageOutputStream 实例。
抛出：
IllegalArgumentException - 如果 output 不是一个正确的类的实例，或者为 null。
IOException - 如果需要缓存文件但无法创建。
另请参见：
getOutputClass()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageReaderSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 ImageReaderSpi

java.lang.Object
    继承者  javax.imageio.spi.IIOServiceProvider
        继承者  javax.imageio.spi.ImageReaderWriterSpi
            继承者  javax.imageio.spi.ImageReaderSpi
所有已实现的接口：
RegisterableService
public abstract class ImageReaderSpi
extends ImageReaderWriterSpi

用于 ImageReader 的服务提供者接口 (SPI)。有关服务提供者类的更多信息，请参见 IIORegistry 类的注释。

每个 ImageReaderSpi 都提供了有关与之关联的 ImageReader 类的几种类型的信息。

使用 getVendorName、getDescription 和 getVersion 方法可获得定义 SPI 类和此类简明描述的供应商的名称。可将这些方法进行国际化以提供特定于语言环境的输出。这些方法主要用于提供可用于组织弹出菜单或其他列表的简短可读信息。

使用 getFormatNames、getFileSuffixes 和 getMIMETypes 方法可获得与此服务有关联的格式名称、文件后缀和 MIME 类型的列表。可以使用这些方法来标识候选 ImageReader，从而基于手动格式选择、文件命名或 MIME 关联（例如，通过 HTTP 访问文件或文件作为电子邮件附件）对特定的文件或流进行解码。

canDecodeInput 方法提供了确定哪些 ImageReader 最有可能解析特定数据流的一条更可靠途径。此方法允许服务提供者检查实际的流内容。

最后，通过调用 createReaderInstance 方法，可获得与此服务提供者关联的 ImageReader 类的实例。任何重量级的初始化，例如加载本地库或创建大型表，都应推迟，至少应该推迟到完成此方法的第一次调用。

另请参见：
IIORegistry, ImageReader

字段摘要
protected Class[] | inputTypes 将从 getInputTypes 返回的 Class 对象数组，该数组最初为 null。
static Class[] | STANDARD_INPUT_TYPE 将从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
protected String[] | writerSpiNames 将从 getImageWriterSpiNames 返回的字符串数组，该数组最初为 null。
从类 javax.imageio.spi.ImageReaderWriterSpi 继承的字段
extraImageMetadataFormatClassNames, extraImageMetadataFormatNames, extraStreamMetadataFormatClassNames, extraStreamMetadataFormatNames, MIMETypes, names, nativeImageMetadataFormatClassName, nativeImageMetadataFormatName, nativeStreamMetadataFormatClassName, nativeStreamMetadataFormatName, pluginClassName, suffixes, supportsStandardImageMetadataFormat, supportsStandardStreamMetadataFormat
从类 javax.imageio.spi.IIOServiceProvider 继承的字段
vendorName, version
构造方法摘要
protected | ImageReaderSpi() 构造一个空的 ImageReaderSpi。
 | ImageReaderSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String readerClassName, Class[] inputTypes, String[] writerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames) 用给定的一组值构造 ImageReaderSpi。
方法摘要
abstract boolean | canDecodeInput(Object source) 如果给定的源对象看起来是此 reader 支持的格式，则返回 true。
ImageReader | createReaderInstance() 返回与此服务提供者关联的 ImageReader 实现的实例。
abstract ImageReader | createReaderInstance(Object extension) 返回与此服务提供者关联的 ImageReader 实现的实例。
String[] | getImageWriterSpiNames() 返回一个 String 数组，其包含所有能够理解由与此服务提供者关联的 ImageReader 使用的内部元数据表示形式的 ImageWriterSpi 类的完全限定名。
Class[] | getInputTypes() 返回 Class 对象数组，指示可用作 reader 的 setInput 方法参数的对象类型。
boolean | isOwnReader(ImageReader reader) 如果传入的 ImageReader 对象为与此服务提供者关联的 ImageReader 的实例，则返回 true。
从类 javax.imageio.spi.ImageReaderWriterSpi 继承的方法
getExtraImageMetadataFormatNames, getExtraStreamMetadataFormatNames, getFileSuffixes, getFormatNames, getImageMetadataFormat, getMIMETypes, getNativeImageMetadataFormatName, getNativeStreamMetadataFormatName, getPluginClassName, getStreamMetadataFormat, isStandardImageMetadataFormatSupported, isStandardStreamMetadataFormatSupported
从类 javax.imageio.spi.IIOServiceProvider 继承的方法
getDescription, getVendorName, getVersion, onDeregistration, onRegistration
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STANDARD_INPUT_TYPE

public static final Class[] STANDARD_INPUT_TYPE
将从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。

inputTypes

protected Class[] inputTypes
将从 getInputTypes 返回的 Class 对象数组，该数组最初为 null。

writerSpiNames

protected String[] writerSpiNames
将从 getImageWriterSpiNames 返回的字符串数组，该数组最初为 null。

构造方法详细信息

ImageReaderSpi

protected ImageReaderSpi()
构造一个空的 ImageReaderSpi。为提供所有方法的可用版本，由子类负责初始化实例变量和/或重写方法实现。

ImageReaderSpi

public ImageReaderSpi(String vendorName,
                      String version,
                      String[] names,
                      String[] suffixes,
                      String[] MIMETypes,
                      String readerClassName,
                      Class[] inputTypes,
                      String[] writerSpiNames,
                      boolean supportsStandardStreamMetadataFormat,
                      String nativeStreamMetadataFormatName,
                      String nativeStreamMetadataFormatClassName,
                      String[] extraStreamMetadataFormatNames,
                      String[] extraStreamMetadataFormatClassNames,
                      boolean supportsStandardImageMetadataFormat,
                      String nativeImageMetadataFormatName,
                      String nativeImageMetadataFormatClassName,
                      String[] extraImageMetadataFormatNames,
                      String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderSpi。

参数：
vendorName - 供应商名称，它是一个非 null 的 String。
version - 版本标识符，它是一个非 null 的 String。
names - 指示格式名称的一个非 null 的 String 数组。必须至少有一个项。
suffixes - 指示常用文件后缀的 String 数组。如果没有定义后缀，则应将其指定为 null。长度为 0 的数组将被标准化为 null。
MIMETypes - 指示格式的 MIME 类型的 String 数组。如果没有定义 MIME 类型，则应将其指定为 null。长度为 0 的数组将被标准化为 null。
readerClassName - 所关联的 ImageReader 类的完全限定名，它为一个非 null 的 String。
inputTypes - 指示合法输入类型的长度至少为 1 的 Class 对象的非 null 数组。
writerSpiNames - 命名所有与 ImageWriter 关联的类的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
supportsStandardStreamMetadataFormat - 一个 boolean 值，指示流元数据对象是否可使用由标准元数据格式描述的树。
nativeStreamMetadataFormatName - 从 getNativeStreamMetadataFormatName 返回的一个 String，或者为 null。
nativeStreamMetadataFormatClassName - 将用于实例化从 getNativeStreamMetadataFormat 返回的元数据格式对象的 String，或者为 null。
extraStreamMetadataFormatNames - 从 getExtraStreamMetadataFormatNames 返回的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
extraStreamMetadataFormatClassNames - 用于实例化从 getStreamMetadataFormat 返回的元数据格式对象的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
supportsStandardImageMetadataFormat - 一个 boolean 值，指示图像元数据对象是否可使用由标准元数据格式描述的树。
nativeImageMetadataFormatName - 从 getNativeImageMetadataFormatName 返回的一个 String，或者为 null。
nativeImageMetadataFormatClassName - 用于实例化从 getNativeImageMetadataFormat 返回的元数据格式对象的 String，或者为 null。
extraImageMetadataFormatNames - 从 getExtraImageMetadataFormatNames 返回的 String 数组。长度为 0 的数组将被标准化为 null。
extraImageMetadataFormatClassNames - 用于实例化从 getImageMetadataFormat 返回的元数据格式对象的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
抛出：
IllegalArgumentException - 如果 vendorName 为 null。
IllegalArgumentException - 如果 version 为 null。
IllegalArgumentException - 如果 names 为 null 或长度为 0。
IllegalArgumentException - 如果 readerClassName 为 null。
IllegalArgumentException - 如果 inputTypes 为 null 或长度为 0。
方法详细信息

getInputTypes

public Class[] getInputTypes()
返回 Class 对象数组，指示可用作 reader 的 setInput 方法参数的对象类型。

对于大多数只接受来自 ImageInputStream 的输入的 reader，应返回一个包含 ImageInputStream.class 的单元素数组。

返回：
非 null 的长度至少为 1 的 Class 对象数组。

canDecodeInput

public abstract boolean canDecodeInput(Object source)
                                throws IOException
如果给定的源对象看起来是此 reader 支持的格式，则返回 true。从此方法返回 true 并不保证将成功读取，只表示基于对流内容的简明检查应该有机会成功。如果此源为 ImageInputStream，实现通常将首先检查流的前几个字节以获取与格式关联的“幻数”。实际的读取已开始后，在解码完成之前的任何时间 reader 仍有可能指示失败。

对象的状态不受影响非常重要，这样其他的 ImageReaderSpi 才能够正确确定它们是否能解码此对象。特别地，如果该源为 ImageInputStream，应使用 mark/reset 对保护此流的位置。

对于可能尝试读取几乎所有流的格式（比如“原始”格式），为避免因采用更相近的匹配而引起调用，应返回 false。

如果 source 不是由 getInputTypes 返回的类之一的实例，此方法应只返回 false。

参数：
source - 要解码的对象（通常是一个 ImageInputStream）。
返回：
如果此流可能解码，则返回 true。
抛出：
IllegalArgumentException - 如果 source 为 null。
IOException - 如果读取该流时发生 I/O 错误。

createReaderInstance

public ImageReader createReaderInstance()
                                 throws IOException
返回与此服务提供者关联的 ImageReader 实现的实例。返回的对象初始时处于初始状态，好像调用过其 reset 方法。

默认实现只返回 createReaderInstance(null)。

返回：
一个 ImageReader 实例。
抛出：
IOException - 如果加载或初始化 reader 类时发生错误，或在初始化或实例化 reader 对象时发生错误。

createReaderInstance

public abstract ImageReader createReaderInstance(Object extension)
                                          throws IOException
返回与此服务提供者关联的 ImageReader 实现的实例。返回的对象初始时处于初始状态，好像调用过其 reset 方法。

可以在构造时向插件提供 Object。对象的本质完全由插件决定。

通常情况下，插件将使用类似 return new MyImageReader(this) 的代码实现此方法。

参数：
extension - 特定于插件的扩展对象，它可以为 null。
返回：
一个 ImageReader 实例。
抛出：
IOException - 如果实例化此 reader 的尝试失败。
IllegalArgumentException - 如果 ImageReader 构造方法抛出一个 IllegalArgumentException，以指示此扩展对象不适合在这里使用。

isOwnReader

public boolean isOwnReader(ImageReader reader)
如果传入的 ImageReader 对象为与此服务提供者关联的 ImageReader 的实例，则返回 true。

默认的实现将 reader 参数的完全限定类名与传给构造方法的类名进行比较。如果需要更复杂的检查，可重写此方法。

参数：
reader - 一个 ImageReader 实例。
返回：
如果 reader 可识别，则返回 true。
抛出：
IllegalArgumentException - 如果 reader 为 null。

getImageWriterSpiNames

public String[] getImageWriterSpiNames()
返回一个 String 数组，其包含所有能够理解由与此服务提供者关联的 ImageReader 使用的内部元数据表示形式的 ImageWriterSpi 类的完全限定名。或者如果没有指定这样的 ImageWriter，则返回 null。如果返回了非 null 的值，则其长度一定不为零。

数组中的第一项必须是“首选”writer 的服务提供者的名称，因为它将用于实例化由 ImageIO.getImageWriter(ImageReader) 返回的 ImageWriter。

使用此机制可获取将能够理解由 ImageReader 生成的非像素元数据的内部结构（请参见 IIOTreeInfo）的 ImageWriters。通过从 ImageReader 获取此数据并将其传给使用此方法获取的 ImageWriters 之一，客户端程序可读取图像、进行某些修改并写回图像，同时保留所有的元数据，而不需要理解有关此元数据的任何事情，甚至图像的格式都不需知道。

返回：
包含 ImageWriterSpi 名称的长度至少为 1 的 String 数组，或者返回 null。
另请参见：
ImageIO.getImageWriter(ImageReader)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageReaderWriterSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 ImageReaderWriterSpi

java.lang.Object
    继承者  javax.imageio.spi.IIOServiceProvider
        继承者  javax.imageio.spi.ImageReaderWriterSpi
所有已实现的接口：
RegisterableService
直接已知子类：
ImageReaderSpi, ImageWriterSpi
public abstract class ImageReaderWriterSpi
extends IIOServiceProvider

包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。

另请参见：
IIORegistry, ImageReaderSpi, ImageWriterSpi

字段摘要
protected String[] | extraImageMetadataFormatClassNames 包含此插件支持的其他任何图像元数据格式的类名称的 String 数组，该数组最初为 null。
protected String[] | extraImageMetadataFormatNames 包含此插件支持的其他任何图像元数据格式的名称的 String 数组，该数组最初为 null。
protected String[] | extraStreamMetadataFormatClassNames 包含此插件支持的其他任何流元数据格式的类名称的 String 数组，该数组最初为 null。
protected String[] | extraStreamMetadataFormatNames 包含此插件支持的其他任何流元数据格式的名称的 String 数组，该字符串最初为 null。
protected String[] | MIMETypes 从 getMIMETypes 返回的字符串数组，该数组最初为 null。
protected String[] | names 从 getFormatNames 返回的字符串数组，该数组最初为 null。
protected String | nativeImageMetadataFormatClassName 包含此插件支持的本地流元数据格式的类名称的 String，该字符串最初为 null。
protected String | nativeImageMetadataFormatName 包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。
protected String | nativeStreamMetadataFormatClassName 包含此插件支持的本地流元数据格式的类名称的 String，初始为 null。
protected String | nativeStreamMetadataFormatName 包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。
protected String | pluginClassName 包含关联的插件类名称的 String，该字符串最初为 null。
protected String[] | suffixes 从 getFileSuffixes 返回的字符串数组，该数组最初为 null。
protected boolean | supportsStandardImageMetadataFormat 指示此插件是否支持图像元数据的标准元数据格式的 boolean 值，该值最初为 false。
protected boolean | supportsStandardStreamMetadataFormat 指示此插件是否支持流元数据的标准元数据格式的 boolean 值，该值最初为 false。
从类 javax.imageio.spi.IIOServiceProvider 继承的字段
vendorName, version
构造方法摘要
ImageReaderWriterSpi()
构造一个空的 ImageReaderWriterSpi。
ImageReaderWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String pluginClassName, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。
方法摘要
String[] | getExtraImageMetadataFormatNames() 返回包含其他文档格式名称，而不是此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。
String[] | getExtraStreamMetadataFormatNames() 返回包含其他文档格式名称，而不是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。
String[] | getFileSuffixes() 返回一个包含通常可由与此服务提供者关联的 ImageReader 或 ImageWriter 实现所用格式所关联文件后缀列表的 String 数组。
String[] | getFormatNames() 返回一个 String 数组，该数组包含通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的那些格式的可读名称。
IIOMetadataFormat | getImageMetadataFormat(String formatName) 返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
String[] | getMIMETypes() 返回一个 String 数组，该数组包含与通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的格式有关的 MIME 类型的列表。
String | getNativeImageMetadataFormatName() 返回此插件的“本地”图像元数据格式的名称，它通常允许无损失地编码或传输按照由此插件处理的格式存储的图像元数据。
String | getNativeStreamMetadataFormatName() 返回此插件的“本地”流元数据格式的名称，它通常允许无损失地编码和传输按照由此插件处理的格式存储的流元数据。
String | getPluginClassName() 返回与此服务提供者关联的 ImageReader 或 ImageWriter 插件的完全限定类名称。
IIOMetadataFormat | getStreamMetadataFormat(String formatName) 返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。
boolean | isStandardImageMetadataFormatSupported() 如果标准元数据格式为此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的文档格式之一，则返回 true。
boolean | isStandardStreamMetadataFormatSupported() 如果标准元数据格式是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法能够识别的文档格式之一，则返回 true。
从类 javax.imageio.spi.IIOServiceProvider 继承的方法
getDescription, getVendorName, getVersion, onDeregistration, onRegistration
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

names

protected String[] names
从 getFormatNames 返回的字符串数组，该数组最初为 null。构造方法应将此字符串设置为一个非 null 值。

suffixes

protected String[] suffixes
从 getFileSuffixes 返回的字符串数组，该数组最初为 null。

MIMETypes

protected String[] MIMETypes
从 getMIMETypes 返回的字符串数组，该数组最初为 null。

pluginClassName

protected String pluginClassName
包含关联的插件类名称的 String，该字符串最初为 null。

supportsStandardStreamMetadataFormat

protected boolean supportsStandardStreamMetadataFormat
指示此插件是否支持流元数据的标准元数据格式的 boolean 值，该值最初为 false。

nativeStreamMetadataFormatName

protected String nativeStreamMetadataFormatName
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。

nativeStreamMetadataFormatClassName

protected String nativeStreamMetadataFormatClassName
包含此插件支持的本地流元数据格式的类名称的 String，初始为 null。

extraStreamMetadataFormatNames

protected String[] extraStreamMetadataFormatNames
包含此插件支持的其他任何流元数据格式的名称的 String 数组，该字符串最初为 null。

extraStreamMetadataFormatClassNames

protected String[] extraStreamMetadataFormatClassNames
包含此插件支持的其他任何流元数据格式的类名称的 String 数组，该数组最初为 null。

supportsStandardImageMetadataFormat

protected boolean supportsStandardImageMetadataFormat
指示此插件是否支持图像元数据的标准元数据格式的 boolean 值，该值最初为 false。

nativeImageMetadataFormatName

protected String nativeImageMetadataFormatName
包含此插件支持的本地流元数据格式名称的 String，该字符串最初为 null。

nativeImageMetadataFormatClassName

protected String nativeImageMetadataFormatClassName
包含此插件支持的本地流元数据格式的类名称的 String，该字符串最初为 null。

extraImageMetadataFormatNames

protected String[] extraImageMetadataFormatNames
包含此插件支持的其他任何图像元数据格式的名称的 String 数组，该数组最初为 null。

extraImageMetadataFormatClassNames

protected String[] extraImageMetadataFormatClassNames
包含此插件支持的其他任何图像元数据格式的类名称的 String 数组，该数组最初为 null。

构造方法详细信息

ImageReaderWriterSpi

public ImageReaderWriterSpi(String vendorName,
                            String version,
                            String[] names,
                            String[] suffixes,
                            String[] MIMETypes,
                            String pluginClassName,
                            boolean supportsStandardStreamMetadataFormat,
                            String nativeStreamMetadataFormatName,
                            String nativeStreamMetadataFormatClassName,
                            String[] extraStreamMetadataFormatNames,
                            String[] extraStreamMetadataFormatClassNames,
                            boolean supportsStandardImageMetadataFormat,
                            String nativeImageMetadataFormatName,
                            String nativeImageMetadataFormatClassName,
                            String[] extraImageMetadataFormatNames,
                            String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageReaderWriterSpi。

参数：
vendorName - 供应商名称，它是一个非 null 的 String。
version - 版本标识符，它是一个非 null 的 String。
names - 指示格式名称的一个非 null 的 String 数组。必须至少有一个项。
suffixes - 指示常用文件后缀的 String 数组。如果未定义后缀，则应指定为 null。长度为 0 的数组将被标准化为 null。
MIMETypes - 指示格式的 MIME 类型的 String 数组。如果未定义 MIME 类型，则应指定为 null。长度为 0 的数组将被标准化为 null。
pluginClassName - 所关联的 ImageReader 或 ImageWriter 类的完全限定名，它为一个非 null 的 String。
supportsStandardStreamMetadataFormat - 一个 boolean 值，指示流元数据对象是否可使用由标准元数据格式描述的树。
nativeStreamMetadataFormatName - 将从 getNativeStreamMetadataFormatName 返回的一个 String，或者为 null。
nativeStreamMetadataFormatClassName - 将用于实例化从 getNativeStreamMetadataFormat 返回的元数据格式对象的 String，或者为 null。
extraStreamMetadataFormatNames - 将从 getExtraStreamMetadataFormatNames 返回的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
extraStreamMetadataFormatClassNames - 将用于实例化从 getStreamMetadataFormat 返回的元数据格式对象的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
supportsStandardImageMetadataFormat - 一个 boolean 值，指示图像元数据对象是否可使用由标准元数据格式描述的树。
nativeImageMetadataFormatName - 将从 getNativeImageMetadataFormatName 返回的一个 String，或者为 null。
nativeImageMetadataFormatClassName - 将用于实例化从 getNativeImageMetadataFormat 返回的元数据格式对象的 String，或者为 null。
extraImageMetadataFormatNames - 将从 getExtraImageMetadataFormatNames 返回的 String 数组。长度为 0 的数组将被标准化为 null。
extraImageMetadataFormatClassNames - 将用于实例化从 getImageMetadataFormat 返回的元数据格式对象的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
抛出：
IllegalArgumentException - 如果 vendorName 为 null。
IllegalArgumentException - 如果 version 为 null。
IllegalArgumentException - 如果 names 为 null 或长度为 0。
IllegalArgumentException - 如果 pluginClassName 为 null。

ImageReaderWriterSpi

public ImageReaderWriterSpi()
构造一个空的 ImageReaderWriterSpi。为提供所有方法的可用版本，由子类负责初始化实例变量和/或重写方法实现。

方法详细信息

getFormatNames

public String[] getFormatNames()
返回一个 String 数组，该数组包含通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的那些格式的可读名称。例如，单独一个 ImageReader 就可以处理 PBM 和 PNM 文件。

返回：
非 null 的 String 数组，或者返回一个长度至少为 1 的、包含与此 reader 或 writer 关联的非正式格式名称的数组。

getFileSuffixes

public String[] getFileSuffixes()
返回一个包含通常可由与此服务提供者关联的 ImageReader 或 ImageWriter 实现所用格式所关联文件后缀列表的 String 数组。例如，单独一个 ImageReader 就可以处理带 '.pbm' 和 '.pnm' 或 '.jpg' 和 '.jpeg' 后缀的文件。如果没有已知的文件后缀，则返回 null。

返回一个特定的后缀并不保证能够处理具有此后缀的文件；它仅仅指示值得尝试使用此服务提供者解码或编码这样的文件。

返回：
String 数组，或者返回一个长度至少为 1 的、包含与此 reader 或 writer 关联的常用文件后缀的数组，抑或返回 null。

getMIMETypes

public String[] getMIMETypes()
返回一个 String 数组，该数组包含与通常由与此服务提供者关联的 ImageReader 或 ImageWriter 实现使用的格式有关的 MIME 类型的列表。

理想的情况下，描述一个特定的格式只需要单独某一 MIME 类型。但是，由于种种原因，有必要为每个服务提供者关联一个类型列表。首先，许多常见图像文件不具有标准的 MIME 类型，所以需要一个常用的非正式名称列表，例如 image/x-pbm 和 image/x-portable-bitmap。有些文件格式虽然具有正式的 MIME 类型，但有时被指示使用它们以前的非正式指定，例如使用 image/x-png 而不使用正式的 image/png。最后，从 MIME 的角度来讲，单个服务提供者能够分析多个不同的类型，例如 image/x-xbitmap 和 image/x-xpixmap。

返回一个特定的 MIME 类型并不保证能够处理声明为此类型的文件；它仅仅指示值得尝试使用此服务提供者解码或编码这样的文件。

返回：
String 数组或长度至少为 1 的、包含与此 reader 或 writer 关联的 MIME 类型的数组，或者返回 null。

getPluginClassName

public String getPluginClassName()
返回与此服务提供者关联的 ImageReader 或 ImageWriter 插件的完全限定类名称。

返回：
类名，它是一个非 null 的 String。

isStandardStreamMetadataFormatSupported

public boolean isStandardStreamMetadataFormatSupported()
如果标准元数据格式是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法能够识别的文档格式之一，则返回 true。

返回：
如果标准格式是流元数据支持的格式，则返回 true。

getNativeStreamMetadataFormatName

public String getNativeStreamMetadataFormatName()
返回此插件的“本地”流元数据格式的名称，它通常允许无损失地编码和传输按照由此插件处理的格式存储的流元数据。如果不支持这样的格式，将返回 null。

默认实现返回 nativeStreamMetadataFormatName 实例变量，这通常由构造方法设置。

返回：
本地流元数据格式的名称，或返回 null。

getExtraStreamMetadataFormatNames

public String[] getExtraStreamMetadataFormatNames()
返回包含其他文档格式名称，而不是此插件生成或使用的流元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。

如果插件不处理元数据，则应返回 null。

格式集可能因读取或写入的特定图像而不同；此方法应指示插件在任何情况下都支持的其他所有格式。

默认实现返回 extraStreamMetadataFormatNames 实例变量的副本，该变量通常由构造方法设置。

返回：
String 数组，或返回 null。
另请参见：
IIOMetadata.getMetadataFormatNames(),
getExtraImageMetadataFormatNames(),
getNativeStreamMetadataFormatName()

isStandardImageMetadataFormatSupported

public boolean isStandardImageMetadataFormatSupported()
如果标准元数据格式为此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的文档格式之一，则返回 true。

返回：
如果标准格式支持图像元数据，则返回 true。

getNativeImageMetadataFormatName

public String getNativeImageMetadataFormatName()
返回此插件的“本地”图像元数据格式的名称，它通常允许无损失地编码或传输按照由此插件处理的格式存储的图像元数据。如果不支持这样的格式，将返回 null。

默认实现返回 nativeImageMetadataFormatName 实例变量，该变量通常由构造方法设置。

返回：
本地图像元数据格式的名称，或返回 null。
另请参见：
getExtraImageMetadataFormatNames()

getExtraImageMetadataFormatNames

public String[] getExtraImageMetadataFormatNames()
返回包含其他文档格式名称，而不是此插件生成或使用的图像元数据对象的 getAsTree 和 setFromTree 方法可识别的本地和标准格式的 String 数组。

如果插件不处理图像元数据，则应返回 null。

格式集可能因读取或写入的特定图像而有所不同；此方法应指示插件在任何情况下都支持的其他所有格式。

默认的实现返回 extraImageMetadataFormatNames 实例变量的副本，该变量通常由构造方法设置。

返回：
String 数组，或返回 null。
另请参见：
IIOMetadata.getMetadataFormatNames(),
getExtraStreamMetadataFormatNames(),
getNativeImageMetadataFormatName()

getStreamMetadataFormat

public IIOMetadataFormat getStreamMetadataFormat(String formatName)
返回描述给定的流元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。给定的名称必须是本地流元数据格式名称、标准元数据格式名称或由 getExtraStreamMetadataFormatNames 返回的格式名称之一。

参数：
formatName - 需要的流元数据格式。
返回：
IIOMetadataFormat 对象。
抛出：
IllegalArgumentException - 如果 formatName 为 null 或者是不受支持的名称。

getImageMetadataFormat

public IIOMetadataFormat getImageMetadataFormat(String formatName)
返回描述给定的图像元数据格式的 IIOMetadataFormat 对象，如果没有可用的描述，则返回 null。给定的名称必须是本地图像元数据格式名称、标准元数据格式名称或由 getExtraImageMetadataFormatNames 返回的格式名称之一。

参数：
formatName - 需要的图像元数据格式。
返回：
IIOMetadataFormat 对象。
抛出：
IllegalArgumentException - 如果 formatName 为 null 或者是不受支持的名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageTranscoderSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 ImageTranscoderSpi

java.lang.Object
    继承者  javax.imageio.spi.IIOServiceProvider
        继承者  javax.imageio.spi.ImageTranscoderSpi
所有已实现的接口：
RegisterableService
public abstract class ImageTranscoderSpi
extends IIOServiceProvider

用于 ImageTranscoder 的服务提供者接口 (SPI)。有关服务提供者类的更多信息，请参见 IIORegistry 类的注释。

另请参见：
IIORegistry, ImageTranscoder

字段摘要
从类 javax.imageio.spi.IIOServiceProvider 继承的字段
vendorName, version
构造方法摘要
protected | ImageTranscoderSpi() 构造一个空的 ImageTranscoderSpi。
 | ImageTranscoderSpi(String vendorName, String version) 用给定的一组值构造 ImageTranscoderSpi。
方法摘要
abstract ImageTranscoder | createTranscoderInstance() 返回与此服务提供者关联的 ImageTranscoder 实现的实例。
abstract String | getReaderServiceProviderName() 返回 ImageReaderSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。
abstract String | getWriterServiceProviderName() 返回 ImageWriterSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。
从类 javax.imageio.spi.IIOServiceProvider 继承的方法
getDescription, getVendorName, getVersion, onDeregistration, onRegistration
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageTranscoderSpi

protected ImageTranscoderSpi()
构造一个空的 ImageTranscoderSpi。为提供所有方法的可用版本，由子类负责初始化实例变量和/或重写方法实现。

ImageTranscoderSpi

public ImageTranscoderSpi(String vendorName,
                          String version)
用给定的一组值构造 ImageTranscoderSpi。

参数：
vendorName - 供应商名称。
version - 版本标识符。
方法详细信息

getReaderServiceProviderName

public abstract String getReaderServiceProviderName()
返回 ImageReaderSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。

返回：
包含 ImageReaderSpi 实现类的完全限定类名的 String。
另请参见：
ImageReaderSpi

getWriterServiceProviderName

public abstract String getWriterServiceProviderName()
返回 ImageWriterSpi 类的完全限定类名称，该类生成可充当此代码转换程序的输入的 IIOMetadata 对象。

返回：
包含 ImageWriterSpi 实现类的完全限定类名的 String。
另请参见：
ImageWriterSpi

createTranscoderInstance

public abstract ImageTranscoder createTranscoderInstance()
返回与此服务提供者关联的 ImageTranscoder 实现的实例。

返回：
一个 ImageTranscoder 实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageWriterSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 ImageWriterSpi

java.lang.Object
    继承者  javax.imageio.spi.IIOServiceProvider
        继承者  javax.imageio.spi.ImageReaderWriterSpi
            继承者  javax.imageio.spi.ImageWriterSpi
所有已实现的接口：
RegisterableService
public abstract class ImageWriterSpi
extends ImageReaderWriterSpi

用于 ImageWriter 的服务提供者接口 (SPI)。有关服务提供者类的更多信息，请参见 IIORegistry 类的注释。

每个 ImageWriterSpi 都提供了有关与之关联的 ImageWriter 类的几种类型的信息。

使用 getVendorName、getDescription 和 getVersion 方法可获得定义 SPI 类和此类简明描述的供应商的名称。可将这些方法进行国际化，以提供特对于语言环境的输出。这些方法主要用于提供可用于组织弹出菜单或其他列表的简短可写信息。

使用 getFormatNames、getFileSuffixes 和 getMIMEType 方法可获得与服务有关联的格式名称、文件后缀和 MIME 类型的列表。使用这些方法可识别候选 ImageWriter，从而基于手动格式选择、文件命名或 MIME 关联写入特定文件或流。

canEncodeImage 方法提供了确定最有可能解析特定数据流的 ImageWriter 的更可靠途径。此方法允许服务提供者检查实际的图像内容。

最后，通过调用 createWriterInstance 方法，可获得与此服务提供者关联的 ImageWriter 类的实例。任何重量级的初始化，例如加载本地库或创建大的表，都应推迟，至少应该推迟到完成此方法的第一次调用。

另请参见：
IIORegistry, ImageTypeSpecifier, ImageWriter

字段摘要
protected Class[] | outputTypes 将从 getOutputTypes 返回的 Class 对象的数组，该数组最初为 null。
protected String[] | readerSpiNames 将从 getImageReaderSpiNames 返回的字符串数组，该数组最初为 null。
static Class[] | STANDARD_OUTPUT_TYPE 从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。
从类 javax.imageio.spi.ImageReaderWriterSpi 继承的字段
extraImageMetadataFormatClassNames, extraImageMetadataFormatNames, extraStreamMetadataFormatClassNames, extraStreamMetadataFormatNames, MIMETypes, names, nativeImageMetadataFormatClassName, nativeImageMetadataFormatName, nativeStreamMetadataFormatClassName, nativeStreamMetadataFormatName, pluginClassName, suffixes, supportsStandardImageMetadataFormat, supportsStandardStreamMetadataFormat
从类 javax.imageio.spi.IIOServiceProvider 继承的字段
vendorName, version
构造方法摘要
protected | ImageWriterSpi() 构造一个空的 ImageWriterSpi。
 | ImageWriterSpi(String vendorName, String version, String[] names, String[] suffixes, String[] MIMETypes, String writerClassName, Class[] outputTypes, String[] readerSpiNames, boolean supportsStandardStreamMetadataFormat, String nativeStreamMetadataFormatName, String nativeStreamMetadataFormatClassName, String[] extraStreamMetadataFormatNames, String[] extraStreamMetadataFormatClassNames, boolean supportsStandardImageMetadataFormat, String nativeImageMetadataFormatName, String nativeImageMetadataFormatClassName, String[] extraImageMetadataFormatNames, String[] extraImageMetadataFormatClassNames) 用给定的一组值构造 ImageWriterSpi。
方法摘要
abstract boolean | canEncodeImage(ImageTypeSpecifier type) 如果与此服务提供者关联的 ImageWriter 实现能够使用给定的布局编码图像，则返回 true。
boolean | canEncodeImage(RenderedImage im) 如果与此服务提供者关联的 ImageWriter 实现能够编码给定的 RenderedImage 实例，则返回 true。
ImageWriter | createWriterInstance() 返回与此服务提供者关联的 ImageWriter 实现的实例。
abstract ImageWriter | createWriterInstance(Object extension) 返回与此服务提供者关联的 ImageWriter 实现的实例。
String[] | getImageReaderSpiNames() 返回一个 String 数组，该数组包含所有能够理解由与此服务提供者关联的 ImageWriter 使用的内部元数据表示形式的 ImageReaderSpi 类的完全限定名。
Class[] | getOutputTypes() 返回 Class 对象数组，指示可用作 setOutput 方法参数的对象类型。
boolean | isFormatLossless() 如果此 writer 输出的格式准确保留了像素数据位，则返回 true。
boolean | isOwnWriter(ImageWriter writer) 如果传入的 ImageWriter 对象是与此服务提供者关联的 ImageWriter 的实例，则返回 true。
从类 javax.imageio.spi.ImageReaderWriterSpi 继承的方法
getExtraImageMetadataFormatNames, getExtraStreamMetadataFormatNames, getFileSuffixes, getFormatNames, getImageMetadataFormat, getMIMETypes, getNativeImageMetadataFormatName, getNativeStreamMetadataFormatName, getPluginClassName, getStreamMetadataFormat, isStandardImageMetadataFormatSupported, isStandardStreamMetadataFormatSupported
从类 javax.imageio.spi.IIOServiceProvider 继承的方法
getDescription, getVendorName, getVersion, onDeregistration, onRegistration
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

STANDARD_OUTPUT_TYPE

public static final Class[] STANDARD_OUTPUT_TYPE
从 getInputTypes 返回的单元素数组，该数组最初包含 ImageInputStream.class。

outputTypes

protected Class[] outputTypes
将从 getOutputTypes 返回的 Class 对象的数组，该数组最初为 null。

readerSpiNames

protected String[] readerSpiNames
将从 getImageReaderSpiNames 返回的字符串数组，该数组最初为 null。

构造方法详细信息

ImageWriterSpi

protected ImageWriterSpi()
构造一个空的 ImageWriterSpi。为提供所有方法的可用版本，由子类负责初始化实例变量和/或重写方法实现。

ImageWriterSpi

public ImageWriterSpi(String vendorName,
                      String version,
                      String[] names,
                      String[] suffixes,
                      String[] MIMETypes,
                      String writerClassName,
                      Class[] outputTypes,
                      String[] readerSpiNames,
                      boolean supportsStandardStreamMetadataFormat,
                      String nativeStreamMetadataFormatName,
                      String nativeStreamMetadataFormatClassName,
                      String[] extraStreamMetadataFormatNames,
                      String[] extraStreamMetadataFormatClassNames,
                      boolean supportsStandardImageMetadataFormat,
                      String nativeImageMetadataFormatName,
                      String nativeImageMetadataFormatClassName,
                      String[] extraImageMetadataFormatNames,
                      String[] extraImageMetadataFormatClassNames)
用给定的一组值构造 ImageWriterSpi。

参数：
vendorName - 供应商名称，它是一个非 null 的 String。
version - 版本标识符，它是一个非 null 的 String。
names - 指示格式名称的一个非 null 的 String 数组。必须至少有一个项。
suffixes - 指示常用文件后缀的 String 数组。如果没有定义后缀，则应指定为 null。长度为 0 的数组将被标准化为 null。
MIMETypes - 指示格式的 MIME 类型的 String 数组。如果没有定义后缀，则应指定为 null。长度为 0 的数组将被标准化为 null。
writerClassName - 所关联的 ImageWriterSpi 类的完全限定名，它为一个非 null 的 String。
outputTypes - 指示合法的输出类型的长度至少为 1 的 Class 对象的数组。
readerSpiNames - 命名所有与 ImageReader 关联的类的长度至少为 1 的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
supportsStandardStreamMetadataFormat - 一个 boolean 值，指示流元数据对象是否可使用由标准元数据格式描述的树。
nativeStreamMetadataFormatName - 从 getNativeStreamMetadataFormatName 返回的一个 String，或者为 null。
nativeStreamMetadataFormatClassName - 将用于实例化从 getNativeStreamMetadataFormat 返回的元数据格式对象的 String，或者为 null。
extraStreamMetadataFormatNames - 从 getExtraStreamMetadataFormatNames 返回的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
extraStreamMetadataFormatClassNames - 用于实例化从 getStreamMetadataFormat 返回的元数据格式对象的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
supportsStandardImageMetadataFormat - 一个 boolean 值，指示图像元数据对象是否可使用由标准元数据格式描述的树。
nativeImageMetadataFormatName - 从 getNativeImageMetadataFormatName 返回的一个 String，或者为 null。
nativeImageMetadataFormatClassName - 用于实例化从 getNativeImageMetadataFormat 返回的元数据格式对象的 String，或者为 null。
extraImageMetadataFormatNames - 从 getExtraImageMetadataFormatNames 返回的 String 数组。长度为 0 的数组将被标准化为 null。
extraImageMetadataFormatClassNames - 用于实例化从 getImageMetadataFormat 返回的元数据格式对象的 String 数组，或者为 null。长度为 0 的数组将被标准化为 null。
抛出：
IllegalArgumentException - 如果 vendorName 为 null。
IllegalArgumentException - 如果 version 为 null。
IllegalArgumentException - 如果 names 为 null 或长度为 0。
IllegalArgumentException - 如果 writerClassName 为 null。
IllegalArgumentException - 如果 outputTypes 为 null 或长度为 0。
方法详细信息

isFormatLossless

public boolean isFormatLossless()
如果此 writer 输出的格式准确保留了像素数据位，则返回 true。默认实现返回 true。

返回：
如果格式完全保留了像素的准确性，则返回 true。

getOutputTypes

public Class[] getOutputTypes()
返回 Class 对象数组，指示可用作 setOutput 方法参数的对象类型。

对于大多数只输出到 ImageOutputStream 的 writer，应返回一个包含 ImageOutputStream.class 的单元素数组。

返回：
长度至少为 1 的、非 null 的 Class 对象数组。

canEncodeImage

public abstract boolean canEncodeImage(ImageTypeSpecifier type)
如果与此服务提供者关联的 ImageWriter 实现能够使用给定的布局编码图像，则返回 true。布局（即 图像的 SampleModel 和 ColorModel）由 ImageTypeSpecifier 对象描述。

返回的值为 true 并不能绝对保证成功地编码；编码过程中仍有可能因为类似 I/O 错误、不一致或错误的数据结构等而产生错误。执行对图像的基本结构的合理检查是为了确定图像是否处在编码格式范围内。例如，如果要求一个只能编码灰度格式的服务提供者处理 RGB BufferedImage，将返回 false。类似地，能够编码 8 位 RGB 图像格式的服务提供者可能拒绝编码与 alpha 通道关联的图像。

不同的 ImageWriter 以及由此导致的不同的服务提供者，可以更严格或更松散。例如，即使为了存储而不得不减少每个图像的像素，从而使精度下降，也有可能接受预乘 alpha 的图像。

参数：
type - 指定将要写入的图像的布局的 ImageTypeSpecifier。
返回：
如果 writer 看起来能够按给定的布局编码此图像，则返回 true。
抛出：
IllegalArgumentException - 如果 type 为 null。

canEncodeImage

public boolean canEncodeImage(RenderedImage im)
如果与此服务提供者关联的 ImageWriter 实现能够编码给定的 RenderedImage 实例，则返回 true。注意，这包括 java.awt.image.BufferedImage 的实例。

有关此方法的语义信息，请参见对 canEncodeImage(ImageTypeSpecifier) 的讨论。

参数：
im - 要编码的 RenderedImage 的实例。
返回：
如果 writer 看起来能够编码此图像，则返回 true。
抛出：
IllegalArgumentException - 如果 im 为 null。

createWriterInstance

public ImageWriter createWriterInstance()
                                 throws IOException
返回与此服务提供者关联的 ImageWriter 实现的实例。返回的对象最初处于初始状态，就像是调用过其 reset 方法。

默认实现只返回 createWriterInstance(null)。

返回：
一个 ImageWriter 实例。
抛出：
IOException - 如果加载或初始化 writer 类时发生错误，或在实例化或初始化 writer 对象时发生错误。

createWriterInstance

public abstract ImageWriter createWriterInstance(Object extension)
                                          throws IOException
返回与此服务提供者关联的 ImageWriter 实现的实例。返回的对象最初处于初始状态，就像是调用过其 reset 方法。

可以在构造时向插件提供 Object。对象的本质完全由插件决定。

通常情况下，插件将使用类似 return new MyImageWriter(this) 的代码来实现此方法。

参数：
extension - 特定于插件的扩展对象，该对象可为 null。
返回：
一个 ImageWriter 实例。
抛出：
IOException - 如果实例化此 writer 的尝试失败。
IllegalArgumentException - 如果 ImageWriter 的构造方法抛出一个 IllegalArgumentException 指示此扩展对象不适合在这里使用。

isOwnWriter

public boolean isOwnWriter(ImageWriter writer)
如果传入的 ImageWriter 对象是与此服务提供者关联的 ImageWriter 的实例，则返回 true。

参数：
writer - 一个 ImageWriter 实例。
返回：
如果 writer 可识别，则返回 true。
抛出：
IllegalArgumentException - 如果 writer 为 null。

getImageReaderSpiNames

public String[] getImageReaderSpiNames()
返回一个 String 数组，该数组包含所有能够理解由与此服务提供者关联的 ImageWriter 使用的内部元数据表示形式的 ImageReaderSpi 类的完全限定名。如果没有指定这样的 ImageReaders，则返回 null。如果返回了非 null 的值，则其长度一定不能为零。

数组中的第一项必须是“首选”reader 的服务提供者的名称，因为它将用于实例化由 ImageIO.getImageReader(ImageWriter) 返回的 ImageReader。

此机制可用于获取将以 ImageWriter 能够理解的结构生成非像素元数据的 ImageReaders（请参见 IIOExtraDataInfo）。通过读取此图像并从使用此方法获取的 ImageReaders 之一获取此数据并将其传给 ImageWriter，客户端程序可读取图像、进行某些修改并写回图像，同时保留所有的元数据，而不需要理解有关此元数据内部结构的任何事情，甚至图像的格式也不需知道。

返回：
一个长度至少为 1 的、包含 ImageReaderSpi 名称的 String 数组，或者返回 null。
另请参见：
ImageIO.getImageReader(ImageWriter), ImageReaderSpi.getImageWriterSpiNames()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RegisterableService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
接口 RegisterableService

所有已知实现类：
IIOServiceProvider, ImageInputStreamSpi, ImageOutputStreamSpi, ImageReaderSpi, ImageReaderWriterSpi, ImageTranscoderSpi, ImageWriterSpi
public interface RegisterableService

一个可选接口，它可能是由向 ServiceRegistry 注册的服务提供者对象提供的。如果存在此接口，则将执行注册和注销的通知。

另请参见：
ServiceRegistry

方法摘要
void | onDeregistration(ServiceRegistry registry, Class<?> category) 将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。
void | onRegistration(ServiceRegistry registry, Class<?> category) 将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。

方法详细信息

onRegistration

void onRegistration(ServiceRegistry registry,
                    Class<?> category)
将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。此对象可能已经在另外的类别或多个类别中注册。

参数：
registry - 此对象已注册的 ServiceRegistry 位置。
category - 指示此对象注册所在的注册表类别的 Class 对象。

onDeregistration

void onDeregistration(ServiceRegistry registry,
                      Class<?> category)
将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。此对象可能仍在另外的类或多个类中注册。

参数：
registry - 从其（部分或完全）注销此对象的 ServiceRegistry。
category - 指示此对象从其注销的注册表类别的 Class 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceRegistry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
类 ServiceRegistry

java.lang.Object
    继承者  javax.imageio.spi.ServiceRegistry
直接已知子类：
IIORegistry
public class ServiceRegistry
extends Object

用于服务提供者实例的注册表。

服务 是一组熟知的接口和类（通常为抽象类）。服务提供者 是服务的具体实现。提供者中的类通常实现由服务自身定义的类的接口或子类。

服务提供者存储在一个或多个类别 中，每个类别都由所有成员都必须实现的（由一个 Class 对象描述）一个接口的类定义。类别集可动态更改。

只能注册给定叶类的单一实例（即，由 getClass() 返回的实际类，相对于继承的类或接口而言）。即，假定 com.mycompany.mypkg.GreenServiceProvider 类实现 com.mycompany.mypkg.MyService 接口。如果注册了 GreenServiceProvider 实例，则其将存储在由 MyService 类定义的类别中。如果注册了 GreenServiceProvider 的新实例，它将替换以前的实例。在实践中，服务提供者对象通常只有一个，所有此行为是适当的。

为声明服务提供者，在每个 JAR 文件都有的 META-INF 目录中加入一个 services 子目录。此目录针对每个在 JAR 文件中具有一个或多个实现类的服务提供者接口都包含一个文件。例如，假设 JAR 文件包含了一个名称为 com.mycompany.mypkg.MyServiceImpl 的类，它实现 javax.someapi.SomeService 接口，则此 JAR 将包含一个名称如下所示的文件：

 META-INF/services/javax.someapi.SomeService
包含行：
 com.mycompany.mypkg.MyService

服务提供者类应为轻量级的，可快速加载。这些接口的实现应避免复杂化其他类和本地代码的依赖关系。更复杂的服务的常用模式是为重量级服务注册一个轻量级的代理。

只要具有适当的运行时权限，应用程序即可根据需要定制注册表的内容。

有关声明服务提供者和通用 JAR 格式的更详细的信息，请参见 JAR File Specification。

另请参见：
RegisterableService

嵌套类摘要
static interface ServiceRegistry.Filter
ServiceRegistry.getServiceProviders 使用的一个简单过滤器接口，用来选择与任意条件匹配的提供者。
构造方法摘要
ServiceRegistry(Iterator<Class<?>> categories)
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。
方法摘要
 boolean contains(Object provider)
如果当前注册了 provider，则返回 true。
 void deregisterAll()
从所有类别注销所有当前注册的服务提供者。
 void deregisterAll(Class<?> category)
注销给定类别下当前注册的所有服务提供者对象。
 void deregisterServiceProvider(Object provider)
从包含它的所有类别中移除服务提供者对象。
<T> boolean
deregisterServiceProvider(T provider, Class<T> category)
从给定的类别中移除服务提供者对象。
 void finalize()
在垃圾回收前终止此对象。
 Iterator<Class<?>> getCategories()
返回指示当前类别集的 Class 对象的 Iterator。
<T> T
getServiceProviderByClass(Class<T> providerClass)
返回当前注册的属于给定类类型的服务提供者对象。
<T> Iterator<T>
getServiceProviders(Class<T> category, boolean useOrdering)
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。
<T> Iterator<T>
getServiceProviders(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。
static
<T> Iterator<T>
lookupProviders(Class<T> providerClass)
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。
static
<T> Iterator<T>
lookupProviders(Class<T> providerClass, ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。
 void registerServiceProvider(Object provider)
将一个服务提供者对象添加到注册表。
<T> boolean
registerServiceProvider(T provider, Class<T> category)
将一个服务提供者对象添加到注册表。
 void registerServiceProviders(Iterator<?> providers)
将一组取自 Iterator 的服务提供者对象添加到注册表。
<T> boolean
setOrdering(Class<T> category, T firstProvider, T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。
<T> boolean
unsetOrdering(Class<T> category, T firstProvider, T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceRegistry

public ServiceRegistry(Iterator<Class<?>> categories)
使用取自 categories 参数的一组类别构造 ServiceRegistry 实例。

参数：
categories - 包含将用于定义类别的 Class 对象的 Iterator。
抛出：
IllegalArgumentException - 如果 categories 为 null。
方法详细信息

lookupProviders

public static <T> Iterator<T> lookupProviders(Class<T> providerClass,
                                              ClassLoader loader)
使用给定的类加载器搜索特定服务类的实现。

此方法根据类注释的描述将给定服务类的名称转换为一个提供者配置文件名，然后使用给定类加载器的 getResources 方法查找所有可用的具有此名称的文件。然后读取并分析这些文件以生成一个提供者类名称列表。返回的迭代器使用给定的类加载器查找并实例化列表中的每个元素。

由于能将扩展安装到一个运行的 Java 虚拟机中，此方法在每次调用时可能返回不同的结果。

参数：
providerClass - 指示所检测的服务提供者的类或接口的 Class 对象。
loader - 将用于加载提供者配置文件和实例化提供者类的类加载器，如果将使用系统类加载器（或，系统类加载器失败时使用引导类加载器），则为 null。
返回：
以任意顺序生成给定服务的提供者对象的 Iterator。如果提供者配置文件违反指定的格式，或者无法找到和实例化提供者类，则迭代器将抛出一个 Error。
抛出：
IllegalArgumentException - 如果 providerClass 为 null。

lookupProviders

public static <T> Iterator<T> lookupProviders(Class<T> providerClass)
使用上下文类加载器定位和递增地实例化给定服务的可用的提供者。此便捷方法等效于：
   ClassLoader cl = Thread.currentThread().getContextClassLoader();
   return Service.providers(service, cl);

参数：
providerClass - 指示所检测的服务提供者的类或接口的 Class 对象。
返回：
以任意顺序生成给定服务的提供者对象的 Iterator。如果提供者配置文件违反指定的格式，或者无法找到和实例化提供者类，则迭代器将抛出一个 Error。
抛出：
IllegalArgumentException - 如果 providerClass 为 null。

getCategories

public Iterator<Class<?>> getCategories()
返回指示当前类别集的 Class 对象的 Iterator。如果不存在任何类别，则此迭代器将为空。

返回：
包含 Class 对象的 Iterator。

registerServiceProvider

public <T> boolean registerServiceProvider(T provider,
                                           Class<T> category)
将一个服务提供者对象添加到注册表。此提供者与给定的类别关联。

如果 provider 实现了 RegisterableService 接口，则将调用其 onRegistration 方法。每次将提供者从某个类别注销时都将调用其 onDeregistration 方法，例如，移除类别或垃圾回收注册表时都要调用该方法。

参数：
provider - 要注册的服务提供者对象。
category - 要在其中注册提供者的类别。
返回：
如果相同的类别中以前未注册相同类的提供者，则返回 true。
抛出：
IllegalArgumentException - 如果 provider 为 null。
IllegalArgumentException - 如果没有与 category 对应的类别。
ClassCastException - 如果提供者未实现由 category 定义的 Class。

registerServiceProvider

public void registerServiceProvider(Object provider)
将一个服务提供者对象添加到注册表。此提供者与注册表中出现的实现了其 Class 的每个类别关联。

如果 provider 实现了 RegisterableService 接口，则将对其注册的每个类别调用一次 onRegistration 方法。每次当提供者从类别注销或注册表终止时，将调用提供者的 onDeregistration 方法。

参数：
provider - 要注册的服务提供者对象。
抛出：
IllegalArgumentException - 如果 provider 为 null。

registerServiceProviders

public void registerServiceProviders(Iterator<?> providers)
将一组取自 Iterator 的服务提供者对象添加到注册表。每个提供者与注册表中出现的实现了其 Class 的每个类别关联。

对于实现了 RegisterableService 接口的每个 providers 项，将对其注册的每个类别调用一次 onRegistration 方法。每次当提供者从类别注销或注册表终止时，将调用提供者的 onDeregistration 方法。

参数：
providers - 包含要注册的服务提供者对象的迭代器。
抛出：
IllegalArgumentException - 如果 providers 为 null，或包含一个 null 项。

deregisterServiceProvider

public <T> boolean deregisterServiceProvider(T provider,
                                             Class<T> category)
从给定的类别中移除服务提供者对象。如果以前未注册提供者，则不执行任何操作并返回 false。否则，返回 true。如果注册了与 provider 具有相同的类但又不等于（使用 ==）provider 的对象，则不注销此对象。

如果 provider 实现了 RegisterableService 接口，则将调用其 onDeregistration 方法。

参数：
provider - 要注销的服务提供者对象。
category - 要从其注销提供者的类别。
返回：
如果提供者以前已注册在相同的类别中，则返回 true，否则返回 false。
抛出：
IllegalArgumentException - 如果 provider 为 null。
IllegalArgumentException - 如果没有与 category 对应的类别。
ClassCastException - 如果提供者未实现由 category 定义的类。

deregisterServiceProvider

public void deregisterServiceProvider(Object provider)
从包含它的所有类别中移除服务提供者对象。

参数：
provider - 要注销的服务提供者对象。
抛出：
IllegalArgumentException - 如果 provider 为 null。

contains

public boolean contains(Object provider)
如果当前注册了 provider，则返回 true。

参数：
provider - 要查询的服务提供者对象。
返回：
如果给定的提供者已注册，则返回 true。
抛出：
IllegalArgumentException - 如果 provider 为 null。

getServiceProviders

public <T> Iterator<T> getServiceProviders(Class<T> category,
                                           boolean useOrdering)
返回一个包含给定类别中的所有已注册的服务提供者的 Iterator。如果 useOrdering 为 false，则迭代器将以任意顺序返回所有的服务提供者对象。否则，排序将遵照已设置的任何配对顺序。如果配对顺序的图形包含圆，则将不返回任何属于圆的提供者。

参数：
category - 将从其检索的类别。
useOrdering - 如果在对返回对象排序时应考虑配对顺序，则为 true。
返回：
包含给定类别的服务提供者的 Iterator（有可能按顺序返回）。
抛出：
IllegalArgumentException - 如果没有与 category 对应的类别。

getServiceProviders

public <T> Iterator<T> getServiceProviders(Class<T> category,
                                           ServiceRegistry.Filter filter,
                                           boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。

useOrdering 参数使用与 getServiceProviders(Class, boolean) 相同的规则控制着结果的排序。

参数：
category - 将从其检索的类别。
filter - 将调用其 filter 方法的 ServiceRegistry.Filter 的实例。
useOrdering - 如果在对返回对象排序时应考虑配对顺序，则为 true。
返回：
包含给定类别的服务提供者的 Iterator（有可能按顺序返回）。
抛出：
IllegalArgumentException - 如果没有与 category 对应的类别。

getServiceProviderByClass

public <T> T getServiceProviderByClass(Class<T> providerClass)
返回当前注册的属于给定类类型的服务提供者对象。任何给定时间最多只允许注册给定类的一个对象。如果没有注册的对象具有需要的类类型，则返回 null。

参数：
providerClass - 需要的服务提供者对象的 Class。
返回：
当前注册的具有所需 Class 类型的服务提供者对象，如果没有，则返回 null。
抛出：
IllegalArgumentException - 如果 providerClass 为 null。

setOrdering

public <T> boolean setOrdering(Class<T> category,
                               T firstProvider,
                               T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。如果其中一个或两个对象当前都未在给定的类别中注册，或者需要的排序已设置，则不执行任何操作并返回 false。如果提供者以前以相反的顺序排序，则将此排序移除。

此排序将由 getServiceProviders 方法在其 useOrdering 参数为 true 时使用。

参数：
category - 指示将在其中建立首选项的类别的 Class 对象。
firstProvider - 首选提供者。
secondProvider - 与其比较而言，firstProvider 为首选提供者。
返回：
如果建立了以前取消设置的排序，则返回 true。
抛出：
IllegalArgumentException - 如果提供者为 null 或为相同的对象。
IllegalArgumentException - 如果没有与 category 对应的类别。

unsetOrdering

public <T> boolean unsetOrdering(Class<T> category,
                                 T firstProvider,
                                 T secondProvider)
为给定类别中的两个服务提供者对象设置配对排序。如果其中一个或两个对象当前都未在给定的类别中注册，或者它们之间当前未设置任何排序，则不执行任何操作并返回 false。

此排序将由 getServiceProviders 方法在其 useOrdering 参数为 true 时使用。

参数：
category - 指示将在其中取消建立首选项的类别的 Class 对象。
firstProvider - 以前的首选提供者。
secondProvider - 与其比较而言，firstProvider 为以前的首选提供者。
返回：
如果取消建立以前设置的排序，则返回 true。
抛出：
IllegalArgumentException - 如果提供者为 null 或为相同的对象。
IllegalArgumentException - 如果没有与 category 对应的类别。

deregisterAll

public void deregisterAll(Class<?> category)
注销给定类别下当前注册的所有服务提供者对象。

参数：
category - 将清空的类别。
抛出：
IllegalArgumentException - 如果没有与 category 对应的类别。

deregisterAll

public void deregisterAll()
从所有类别注销所有当前注册的服务提供者。

finalize

public void finalize()
              throws Throwable
在垃圾回收前终止此对象。调用 deregisterAll 方法注销所有当前注册的服务提供者。不应该从应用程序代码中调用此方法。

覆盖：
类 Object 中的 finalize
抛出：
Throwable - 如果在超类终止过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceRegistry.Filter (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.spi
接口 ServiceRegistry.Filter

正在封闭类：
ServiceRegistry
public static interface ServiceRegistry.Filter

ServiceRegistry.getServiceProviders 使用的一个简单过滤器接口，用来选择与任意条件匹配的提供者。应该对实现此接口的类应进行定义，只有这样才能使用 ServiceRegistry 的带 Filter 的 getServiceProviders 方法。

另请参见：
ServiceRegistry.getServiceProviders(Class, ServiceRegistry.Filter, boolean)

方法摘要
 boolean filter(Object provider)
如果给定的 provider 对象与由此 Filter 定义的条件匹配，则返回 true。

方法详细信息

filter

boolean filter(Object provider)
如果给定的 provider 对象与由此 Filter 定义的条件匹配，则返回 true。

参数：
provider - 服务提供者 Object。
返回：
如果提供者与条件匹配，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.imageio.spi (Java 2 Platform SE 6)

 javax.imageio.spi
接口
RegisterableService
ServiceRegistry.Filter
类
IIORegistry
IIOServiceProvider
ImageInputStreamSpi
ImageOutputStreamSpi
ImageReaderSpi
ImageReaderWriterSpi
ImageTranscoderSpi
ImageWriterSpi
ServiceRegistry


javax.imageio.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.imageio.spi

包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

请参见：
描述

接口摘要
RegisterableService | 一个可选接口，它可能是由向 ServiceRegistry 注册的服务提供者对象提供的。
ServiceRegistry.Filter | ServiceRegistry.getServiceProviders 使用的一个简单过滤器接口，用来选择与任意条件匹配的提供者。

类摘要
IIORegistry | 用于服务提供者实例的注册表。
IIOServiceProvider | 一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。
ImageInputStreamSpi | 用于 ImageInputStream 的服务提供者接口 (SPI)。
ImageOutputStreamSpi | 用于 ImageOutputStream 的服务提供者接口 (SPI)。
ImageReaderSpi | 用于 ImageReader 的服务提供者接口 (SPI)。
ImageReaderWriterSpi | 包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
ImageTranscoderSpi | 用于 ImageTranscoder 的服务提供者接口 (SPI)。
ImageWriterSpi | 用于 ImageWriter 的服务提供者接口 (SPI)。
ServiceRegistry | 用于服务提供者实例的注册表。

软件包 javax.imageio.spi 的描述

包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

此 javax.imageio.spi 包包含了用于图像的读取、写入和代码转换、流的输入和输出获取，以及用于查找所安装的服务提供者实例和动态注册新实例的运行时注册表。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.imageio.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.imageio.spi.IIOServiceProvider (implements javax.imageio.spi.RegisterableService)
      • javax.imageio.spi.ImageInputStreamSpi
      • javax.imageio.spi.ImageOutputStreamSpi
      • javax.imageio.spi.ImageReaderWriterSpi
        • javax.imageio.spi.ImageReaderSpi
        • javax.imageio.spi.ImageWriterSpi
      • javax.imageio.spi.ImageTranscoderSpi
    • javax.imageio.spi.ServiceRegistry
      • javax.imageio.spi.IIORegistry

接口分层结构

  • javax.imageio.spi.RegisterableService
  • javax.imageio.spi.ServiceRegistry.Filter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.imageio.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.spi
的使用

使用 javax.imageio.spi 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 使用的 javax.imageio.spi 中的类
ImageReaderSpi
用于 ImageReader 的服务提供者接口 (SPI)。
ImageWriterSpi
用于 ImageWriter 的服务提供者接口 (SPI)。

javax.imageio.spi 使用的 javax.imageio.spi 中的类
IIORegistry
用于服务提供者实例的注册表。
IIOServiceProvider
一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。
ImageReaderWriterSpi
包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
RegisterableService
一个可选接口，它可能是由向 ServiceRegistry 注册的服务提供者对象提供的。
ServiceRegistry
用于服务提供者实例的注册表。
ServiceRegistry.Filter
ServiceRegistry.getServiceProviders 使用的一个简单过滤器接口，用来选择与任意条件匹配的提供者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.IIORegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.IIORegistry
的使用

使用 IIORegistry 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 IIORegistry 的使用

返回 IIORegistry 的 javax.imageio.spi 中的方法
static IIORegistry IIORegistry.getDefaultInstance()
返回 Image I/O API 使用的默认 IIORegistry 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.IIOServiceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.IIOServiceProvider
的使用

使用 IIOServiceProvider 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 IIOServiceProvider 的使用

javax.imageio.spi 中 IIOServiceProvider 的子类
class | ImageInputStreamSpi 用于 ImageInputStream 的服务提供者接口 (SPI)。
class | ImageOutputStreamSpi 用于 ImageOutputStream 的服务提供者接口 (SPI)。
class | ImageReaderSpi 用于 ImageReader 的服务提供者接口 (SPI)。
class | ImageReaderWriterSpi 包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
class | ImageTranscoderSpi 用于 ImageTranscoder 的服务提供者接口 (SPI)。
class | ImageWriterSpi 用于 ImageWriter 的服务提供者接口 (SPI)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.ImageInputStreamSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageInputStreamSpi
的使用

没有 javax.imageio.spi.ImageInputStreamSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.ImageOutputStreamSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageOutputStreamSpi
的使用

没有 javax.imageio.spi.ImageOutputStreamSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.ImageReaderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageReaderSpi
的使用

使用 ImageReaderSpi 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 ImageReaderSpi 的使用

声明为 ImageReaderSpi 的 javax.imageio 中的字段
protected  ImageReaderSpi ImageReader.originatingProvider
实例化此对象的 ImageReaderSpi，如果其身份未知或不存在，则为 null。

返回 ImageReaderSpi 的 javax.imageio 中的方法
 ImageReaderSpi ImageReader.getOriginatingProvider()
返回传入构造方法的 ImageReaderSpi。

参数类型为 ImageReaderSpi 的 javax.imageio 中的构造方法
ImageReader(ImageReaderSpi originatingProvider)
构造一个 ImageReader，并将其 originatingProvider 字段设置为所提供的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.ImageReaderWriterSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageReaderWriterSpi
的使用

使用 ImageReaderWriterSpi 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 ImageReaderWriterSpi 的使用

javax.imageio.spi 中 ImageReaderWriterSpi 的子类
class | ImageReaderSpi 用于 ImageReader 的服务提供者接口 (SPI)。
class | ImageWriterSpi 用于 ImageWriter 的服务提供者接口 (SPI)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.ImageTranscoderSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageTranscoderSpi
的使用

没有 javax.imageio.spi.ImageTranscoderSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.ImageWriterSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ImageWriterSpi
的使用

使用 ImageWriterSpi 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 ImageWriterSpi 的使用

声明为 ImageWriterSpi 的 javax.imageio 中的字段
protected  ImageWriterSpi ImageWriter.originatingProvider
实例化此对象的 ImageWriterSpi，如果 ImageWriterSpi 的标识是未知的或不存在，则将此对象实例化为 null。

返回 ImageWriterSpi 的 javax.imageio 中的方法
 ImageWriterSpi ImageWriter.getOriginatingProvider()
返回创建此 ImageWriter 的 ImageWriterSpi 对象，如果此对象不是通过 IIORegistry 创建的，则返回 null。

参数类型为 ImageWriterSpi 的 javax.imageio 中的构造方法
ImageWriter(ImageWriterSpi originatingProvider)
构造一个 ImageWriter，并将其 originatingProvider 实例变量设置为所提供的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.spi.RegisterableService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.spi.RegisterableService
的使用

使用 RegisterableService 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 RegisterableService 的使用

实现 RegisterableService 的 javax.imageio.spi 中的类
class | IIOServiceProvider 一个常用于所有 Image I/O 服务提供者接口 (SPI) 的功能性超接口。
class | ImageInputStreamSpi 用于 ImageInputStream 的服务提供者接口 (SPI)。
class | ImageOutputStreamSpi 用于 ImageOutputStream 的服务提供者接口 (SPI)。
class | ImageReaderSpi 用于 ImageReader 的服务提供者接口 (SPI)。
class | ImageReaderWriterSpi 包含 ImageReaderSpi 和 ImageWriterSpi 常用实例变量和方法的一个超类。
class | ImageTranscoderSpi 用于 ImageTranscoder 的服务提供者接口 (SPI)。
class | ImageWriterSpi 用于 ImageWriter 的服务提供者接口 (SPI)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.spi.ServiceRegistry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.spi.ServiceRegistry
的使用

使用 ServiceRegistry 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 ServiceRegistry 的使用

javax.imageio.spi 中 ServiceRegistry 的子类
 class IIORegistry
用于服务提供者实例的注册表。

参数类型为 ServiceRegistry 的 javax.imageio.spi 中的方法
void | IIOServiceProvider.onDeregistration(ServiceRegistry registry, Class<?> category) Spi 类一从 ServiceRegistry 中注销即执行的回调。
void | RegisterableService.onDeregistration(ServiceRegistry registry, Class<?> category) 将一个实现此接口的对象从给定的 registry 的给定 category 移除时调用此方法。
void | IIOServiceProvider.onRegistration(ServiceRegistry registry, Class<?> category) 在 ServiceRegistry 中实例化和注册 Spi 类后即执行的回调。
void | RegisterableService.onRegistration(ServiceRegistry registry, Class<?> category) 将一个实现此接口的对象添加到给定 registry 的给定 category 时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.spi.ServiceRegistry.Filter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.spi.ServiceRegistry.Filter
的使用

使用 ServiceRegistry.Filter 的软件包
javax.imageio.spi 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio.spi 中 ServiceRegistry.Filter 的使用

参数类型为 ServiceRegistry.Filter 的 javax.imageio.spi 中的方法
<T> Iterator<T>
ServiceRegistry.getServiceProviders(Class<T> category, ServiceRegistry.Filter filter, boolean useOrdering)
返回一个 Iterator，其包含给定类别中满足由指定的 ServiceRegistry.Filter 对象的 filter 方法定义的条件的服务提供者对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


FileCacheImageInputStream (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 FileCacheImageInputStream

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
        继承者  javax.imageio.stream.FileCacheImageInputStream
所有已实现的接口：
DataInput, ImageInputStream
public class FileCacheImageInputStream
extends ImageInputStreamImpl

从常规 InputStream 获取其输入的 ImageInputStream 的实现。使用文件缓存以前读取的数据。

字段摘要
从类 javax.imageio.stream.ImageInputStreamImpl 继承的字段
bitOffset, byteOrder, flushedPos, streamPos
构造方法摘要
FileCacheImageInputStream(InputStream stream, File cacheDir)
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。
方法摘要
void | close() 关闭此 FileCacheImageInputStream，关闭并移除缓存文件。
protected void | finalize() 在垃圾回收前结束此对象。
boolean | isCached() 返回 true，因为此 ImageInputStream 为了允许逆向查找而缓存了数据。
boolean | isCachedFile() 返回 true，因为此 ImageInputStream 维护文件缓存。
boolean | isCachedMemory() 返回 false，因为此 ImageInputStream 不维护主存缓存。
int | read() 从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
从类 javax.imageio.stream.ImageInputStreamImpl 继承的方法
checkClosed, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, length, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileCacheImageInputStream

public FileCacheImageInputStream(InputStream stream,
                                 File cacheDir)
                          throws IOException
构造一个将从给定 InputStream 进行读取的 FileCacheImageInputStream。

将临时文件用作缓存。如果 cacheDir 不为 null 且是一个目录，则在该处创建文件。如果为 null，则使用与系统相关的默认临时文件目录（有关详细资料，请参阅 File.createTempFile 的文档）。

参数：
stream - 要从其进行读取的 InputStream。
cacheDir - 一个指示缓存文件创建目录的 File；或 null，指示使用系统目录。
抛出：
IllegalArgumentException - 如果 stream 为 null。
IllegalArgumentException - 如果 cacheDir 不为 null 但不是一个目录。
IOException - 如果无法创建缓存文件。
方法详细信息

read

public int read()
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。 如果到达 EOF，则返回 -1。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

在发生读取前，流中的位偏移量必须被重置为 0。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
返回：
流中下一个字节的值；如果到达 EOF，则返回 -1。
抛出：
IOException - 如果流已经被关闭。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。如果由于到达流末尾而没有读取任何字节，则返回 -1。

在发生读取前，流中的位偏移量必须被重置为 0。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
参数：
b - 用来接收写入的字节数组。
off - b 中要写入的起始位置。
len - 要读取的最大字节数。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
IOException - 如果发生 I/O 错误。

isCached

public boolean isCached()
返回 true，因为此 ImageInputStream 为了允许逆向查找而缓存了数据。

指定者：
接口 ImageInputStream 中的 isCached
覆盖：
类 ImageInputStreamImpl 中的 isCached
返回：
true。
另请参见：
isCachedMemory(), isCachedFile()

isCachedFile

public boolean isCachedFile()
返回 true，因为此 ImageInputStream 维护文件缓存。

指定者：
接口 ImageInputStream 中的 isCachedFile
覆盖：
类 ImageInputStreamImpl 中的 isCachedFile
返回：
true。
另请参见：
isCached(), isCachedMemory()

isCachedMemory

public boolean isCachedMemory()
返回 false，因为此 ImageInputStream 不维护主存缓存。

指定者：
接口 ImageInputStream 中的 isCachedMemory
覆盖：
类 ImageInputStreamImpl 中的 isCachedMemory
返回：
false。
另请参见：
isCached(), isCachedFile()

close

public void close()
           throws IOException
关闭此 FileCacheImageInputStream，关闭并移除缓存文件。但不关闭源 InputStream。

指定者：
接口 ImageInputStream 中的 close
覆盖：
类 ImageInputStreamImpl 中的 close
抛出：
IOException - 如果发生错误。

finalize

protected void finalize()
                 throws Throwable
在垃圾回收前结束此对象。调用 close 方法来关闭所有开启的输入源。不应该从应用程序代码调用此方法。

覆盖：
类 ImageInputStreamImpl 中的 finalize
抛出：
Throwable - 如果在超类终止过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FileCacheImageOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 FileCacheImageOutputStream

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
        继承者  javax.imageio.stream.ImageOutputStreamImpl
            继承者  javax.imageio.stream.FileCacheImageOutputStream
所有已实现的接口：
DataInput, DataOutput, ImageInputStream, ImageOutputStream
public class FileCacheImageOutputStream
extends ImageOutputStreamImpl

将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。在将数据刷新到输出流前用于缓存数据的文件。

字段摘要
从类 javax.imageio.stream.ImageInputStreamImpl 继承的字段
bitOffset, byteOrder, flushedPos, streamPos
构造方法摘要
FileCacheImageOutputStream(OutputStream stream, File cacheDir)
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。
方法摘要
void | close() 关闭此 FileCacheImageOututStream。
void | flushBefore(long pos) 丢弃所指示位置之前的流初始部分。
boolean | isCached() 返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。
boolean | isCachedFile() 返回 true，因为此 ImageOutputStream 维护文件缓存。
boolean | isCachedMemory() 返回 false，因为此 ImageOutputStream 不维护主存缓存。
long | length() 返回 -1L，指示流的长度未知。
int | read() 从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
void | seek(long pos) 设置当前流位置并将位偏移量重置为 0。
void | write(byte[] b, int off, int len) 将字节序列写入到流中的当前位置。
void | write(int b) 将单个字节写入到流中的当前位置。
从类 javax.imageio.stream.ImageOutputStreamImpl 继承的方法
flushBits, write, writeBit, writeBits, writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeChars, writeDouble, writeDoubles, writeFloat, writeFloats, writeInt, writeInts, writeLong, writeLongs, writeShort, writeShorts, writeUTF
从类 javax.imageio.stream.ImageInputStreamImpl 继承的方法
checkClosed, finalize, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.imageio.stream.ImageInputStream 继承的方法
flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes

构造方法详细信息

FileCacheImageOutputStream

public FileCacheImageOutputStream(OutputStream stream,
                                  File cacheDir)
                           throws IOException
构造一个将向给定 outputStream 进行写入的 FileCacheImageOutputStream。

将临时文件用作缓存。如果 cacheDir 不为 null 且是一个目录，则在该处创建文件。如果为 null，则将使用与系统相关的默认临时文件目录（有关详细资料，请参阅 File.createTempFile 的文档）。

参数：
stream - 将写入到的 OutputStream。
cacheDir - 一个指示缓存文件创建目录的 File；或 null，指示使用系统目录。
抛出：
IllegalArgumentException - 如果 stream 为 null。
IllegalArgumentException - 如果 cacheDir 不为 null 但不是一个目录。
IOException - 如果无法创建缓存文件。
方法详细信息

read

public int read()
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。 如果到达 EOF，则返回 -1。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

在发生读取前，流中的位偏移量必须被重置为 0。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
返回：
流中下一个字节的值；如果到达 EOF，则返回 -1。
抛出：
IOException - 如果流已经被关闭。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。如果由于到达流末尾而没有读取任何字节，则返回 -1。

在发生读取前，流中的位偏移量必须被重置为 0。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
参数：
b - 用来接收写入的字节数组。
off - b 中要写入的起始位置。
len - 要读取的最大字节数。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(int b)
           throws IOException
从接口 ImageOutputStream 复制的描述
将单个字节写入到流中的当前位置。b 的 24 个高位将被忽略。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
指定者：
类 ImageOutputStreamImpl 中的 write
参数：
b - 一个 int，其低 8 位将被写入。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
从接口 ImageOutputStream 复制的描述
将字节序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入字节 b[off]，然后写入字节 b[off + 1]，依此类推。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
指定者：
类 ImageOutputStreamImpl 中的 write
参数：
b - 要写入的 byte 数组。
off - 数据中的初始偏移量。
len - 要写入的 byte 数。
抛出：
IOException - 如果发生 I/O 错误。

length

public long length()
从类 ImageInputStreamImpl 复制的描述
返回 -1L，指示流的长度未知。子类必须重写此方法来提供实际的长度信息。

指定者：
接口 ImageInputStream 中的 length
覆盖：
类 ImageInputStreamImpl 中的 length
返回：
指示不知道长度的 -1L。

seek

public void seek(long pos)
          throws IOException
设置当前流位置并将位偏移量重置为 0。查找文件末尾的后面是合法的；仅当在该处执行读取时才抛出 EOFException。在执行写入前，文件长度不会增加。

指定者：
接口 ImageInputStream 中的 seek
覆盖：
类 ImageInputStreamImpl 中的 seek
参数：
pos - 一个 long，它包含所需的文件指针位置。
抛出：
IndexOutOfBoundsException - 如果 pos 小于刷新的位置。
IOException - 如果发生任何其他 I/O 错误。

isCached

public boolean isCached()
返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。

指定者：
接口 ImageInputStream 中的 isCached
覆盖：
类 ImageInputStreamImpl 中的 isCached
返回：
true。
另请参见：
isCachedMemory(), isCachedFile()

isCachedFile

public boolean isCachedFile()
返回 true，因为此 ImageOutputStream 维护文件缓存。

指定者：
接口 ImageInputStream 中的 isCachedFile
覆盖：
类 ImageInputStreamImpl 中的 isCachedFile
返回：
true。
另请参见：
isCached(), isCachedMemory()

isCachedMemory

public boolean isCachedMemory()
返回 false，因为此 ImageOutputStream 不维护主存缓存。

指定者：
接口 ImageInputStream 中的 isCachedMemory
覆盖：
类 ImageInputStreamImpl 中的 isCachedMemory
返回：
false。
另请参见：
isCached(), isCachedFile()

close

public void close()
           throws IOException
关闭此 FileCacheImageOututStream。所有的挂起数据都将被刷新到输出，关闭并移除该缓存。但不关闭目标 OutputStream。

指定者：
接口 ImageInputStream 中的 close
覆盖：
类 ImageInputStreamImpl 中的 close
抛出：
IOException - if an error occurs.

flushBefore

public void flushBefore(long pos)
                 throws IOException
从接口 ImageInputStream 复制的描述
丢弃所指示位置之前的流初始部分。试图查找流的刷新部分中的偏移量将导致抛出 IndexOutOfBoundsException。

调用 flushBefore 可允许实现此接口的类释放存储流中的数据所使用的资源，如内存和磁盘空间。

指定者：
接口 ImageInputStream 中的 flushBefore
指定者：
接口 ImageOutputStream 中的 flushBefore
覆盖：
类 ImageInputStreamImpl 中的 flushBefore
参数：
pos - 一个 long，它包含要刷新的流前缀的长度。
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileImageInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 FileImageInputStream

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
        继承者  javax.imageio.stream.FileImageInputStream
所有已实现的接口：
DataInput, ImageInputStream
public class FileImageInputStream
extends ImageInputStreamImpl

从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。假定文件内容在对象的生存期内是稳定的。

字段摘要
从类 javax.imageio.stream.ImageInputStreamImpl 继承的字段
bitOffset, byteOrder, flushedPos, streamPos
构造方法摘要
FileImageInputStream(File f)
构造一个将从给定 File 进行读取的 FileImageInputStream。
FileImageInputStream(RandomAccessFile raf)
构造一个将从给定 RandomAccessFile 进行读取的 FileImageInputStream。
方法摘要
void | close() 关闭流。
protected void | finalize() 在垃圾回收前结束此对象。
long | length() 返回底层文件的长度，如果其为未知，则返回 -1。
int | read() 从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
void | seek(long pos) 将当前流位置设置为所需的位置。
从类 javax.imageio.stream.ImageInputStreamImpl 继承的方法
checkClosed, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileImageInputStream

public FileImageInputStream(File f)
                     throws FileNotFoundException,
                            IOException
构造一个将从给定 File 进行读取的 FileImageInputStream。

在构造此对象和最后一次调用 read 方法之间的时间内，一定不能更改文件内容。

参数：
f - 要从其进行读取的 File。
抛出：
IllegalArgumentException - 如果 f 为 null。
SecurityException - 如果存在安全管理器，且不允许对文件进行读取访问。
FileNotFoundException - 如果 f 是目录，或者由于任何其他原因不能打开以进行读取。
IOException - 如果发生 I/O 错误。

FileImageInputStream

public FileImageInputStream(RandomAccessFile raf)
构造一个将从给定 RandomAccessFile 进行读取的 FileImageInputStream。

在构造此对象和最后一次调用 read 方法之间的时间内，一定不能更改文件内容。

参数：
raf - 要从其进行读取的 RandomAccessFile。
抛出：
IllegalArgumentException - 如果 raf 为 null。
方法详细信息

read

public int read()
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。 如果到达 EOF，则返回 -1。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

在发生读取前，流中的位偏移量必须被重置为 0。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
返回：
流中下一个字节的值；如果到达 EOF，则返回 -1。
抛出：
IOException - 如果流已经被关闭。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。如果由于到达流末尾而没有读取任何字节，则返回 -1。

在发生读取前，流中的位偏移量必须被重置为 0。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
参数：
b - 用来接收写入的字节数组。
off - b 中要写入的起始位置。
len - 要读取的最大字节数。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
IOException - 如果发生 I/O 错误。

length

public long length()
返回底层文件的长度，如果其为未知，则返回 -1。

指定者：
接口 ImageInputStream 中的 length
覆盖：
类 ImageInputStreamImpl 中的 length
返回：
以 long 形式返回文件的长度，或者返回 -1。

seek

public void seek(long pos)
          throws IOException
从接口 ImageInputStream 复制的描述
将当前流位置设置为所需的位置。下一次读取将在此位置上进行。位偏移量被设置为 0。

如果 pos 小于刷新位置（由 getflushedPosition 返回），那么将抛出 IndexOutOfBoundsException。

查找文件结束标记的后面是合法的，只有在该处执行读取时才抛出 EOFException。

指定者：
接口 ImageInputStream 中的 seek
覆盖：
类 ImageInputStreamImpl 中的 seek
参数：
pos - 一个 long，它包含所需的文件指针位置。
抛出：
IOException - 如果发生任何 I/O 错误。

close

public void close()
           throws IOException
从接口 ImageInputStream 复制的描述
关闭流。试图访问已经关闭的流将导致 IOException 或错误行为。调用此方法可允许实现此接口的类释放与流关联的资源，如内存、磁盘空间或文件描述符。

指定者：
接口 ImageInputStream 中的 close
覆盖：
类 ImageInputStreamImpl 中的 close
抛出：
IOException - 如果发生 I/O 错误。

finalize

protected void finalize()
                 throws Throwable
在垃圾回收前结束此对象。调用 close 方法来关闭所有开启的输入源。不应该从应用程序代码调用此方法。

覆盖：
类 ImageInputStreamImpl 中的 finalize
抛出：
Throwable - 如果在超类终止过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileImageOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 FileImageOutputStream

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
        继承者  javax.imageio.stream.ImageOutputStreamImpl
            继承者  javax.imageio.stream.FileImageOutputStream
所有已实现的接口：
DataInput, DataOutput, ImageInputStream, ImageOutputStream
public class FileImageOutputStream
extends ImageOutputStreamImpl

将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。

字段摘要
从类 javax.imageio.stream.ImageInputStreamImpl 继承的字段
bitOffset, byteOrder, flushedPos, streamPos
构造方法摘要
FileImageOutputStream(File f)
构造一个将向给定 File 进行写入的 FileImageOutputStream。
FileImageOutputStream(RandomAccessFile raf)
构造一个向给定 FileImageOutputStream 进行写入的 RandomAccessFile。
方法摘要
void | close() 关闭流。
protected void | finalize() 在垃圾回收前结束此对象。
long | length() 返回 -1L，指示流的长度未知。
int | read() 从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
void | seek(long pos) 设置当前流位置并将位偏移量重置为 0。
void | write(byte[] b, int off, int len) 将字节序列写入到流中的当前位置。
void | write(int b) 将单个字节写入到流中的当前位置。
从类 javax.imageio.stream.ImageOutputStreamImpl 继承的方法
flushBits, write, writeBit, writeBits, writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeChars, writeDouble, writeDoubles, writeFloat, writeFloats, writeInt, writeInts, writeLong, writeLongs, writeShort, writeShorts, writeUTF
从类 javax.imageio.stream.ImageInputStreamImpl 继承的方法
checkClosed, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.imageio.stream.ImageOutputStream 继承的方法
flushBefore
从接口 javax.imageio.stream.ImageInputStream 继承的方法
flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, setBitOffset, setByteOrder, skipBytes, skipBytes

构造方法详细信息

FileImageOutputStream

public FileImageOutputStream(File f)
                      throws FileNotFoundException,
                             IOException
构造一个将向给定 File 进行写入的 FileImageOutputStream。

参数：
f - 要写入到的 File。
抛出：
IllegalArgumentException - 如果 f 为 null。
SecurityException - 如果存在安全管理器，且不允许对文件进行写入访问。
FileNotFoundException - 如果 f 不指示常规文件，或者由于任何其他原因不能打开以进行读写。
IOException - 如果发生 I/O 错误。

FileImageOutputStream

public FileImageOutputStream(RandomAccessFile raf)
构造一个向给定 FileImageOutputStream 进行写入的 RandomAccessFile。

参数：
raf - 要写入到的 RandomAccessFile。
抛出：
IllegalArgumentException - 如果 raf 为 null。
方法详细信息

read

public int read()
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。 如果到达 EOF，则返回 -1。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

在发生读取前，流中的位偏移量必须被重置为 0。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
返回：
流中下一个字节的值；如果到达 EOF，则返回 -1。
抛出：
IOException - 如果流已经被关闭。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。如果由于到达流末尾而没有读取任何字节，则返回 -1。

在发生读取前，流中的位偏移量必须被重置为 0。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
参数：
b - 用来接收写入的字节数组。
off - b 中要写入的起始位置。
len - 要读取的最大字节数。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(int b)
           throws IOException
从接口 ImageOutputStream 复制的描述
将单个字节写入到流中的当前位置。b 的 24 个高位将被忽略。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
指定者：
类 ImageOutputStreamImpl 中的 write
参数：
b - 一个 int，其低 8 位将被写入。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
从接口 ImageOutputStream 复制的描述
将字节序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入字节 b[off]，然后写入字节 b[off + 1]，依此类推。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
指定者：
类 ImageOutputStreamImpl 中的 write
参数：
b - 要写入的 byte 数组。
off - 数据中的初始偏移量。
len - 要写入的 byte 数。
抛出：
IOException - 如果发生 I/O 错误。

length

public long length()
从类 ImageInputStreamImpl 复制的描述
返回 -1L，指示流的长度未知。子类必须重写此方法来提供实际的长度信息。

指定者：
接口 ImageInputStream 中的 length
覆盖：
类 ImageInputStreamImpl 中的 length
返回：
指示不知道长度的 -1L。

seek

public void seek(long pos)
          throws IOException
设置当前流位置并将位偏移量重置为 0。查找文件末尾的后面是合法的；仅当在该处执行读取时才抛出 EOFException。在执行写入前，文件长度不会增加。

指定者：
接口 ImageInputStream 中的 seek
覆盖：
类 ImageInputStreamImpl 中的 seek
参数：
pos - 一个 long，它包含所需的文件指针位置。
抛出：
IndexOutOfBoundsException - 如果 pos 小于刷新缓存的位置。
IOException - 如果发生任何其他 I/O 错误。

close

public void close()
           throws IOException
从接口 ImageInputStream 复制的描述
关闭流。试图访问已经关闭的流将导致 IOException 或错误行为。调用此方法可允许实现此接口的类释放与流关联的资源，如内存、磁盘空间或文件描述符。

指定者：
接口 ImageInputStream 中的 close
覆盖：
类 ImageInputStreamImpl 中的 close
抛出：
IOException - 如果发生 I/O 错误。

finalize

protected void finalize()
                 throws Throwable
在垃圾回收前结束此对象。调用 close 方法来关闭所有开启的输入源。不应该从应用程序代码调用此方法。

覆盖：
类 ImageInputStreamImpl 中的 finalize
抛出：
Throwable - 如果在超类终止过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IIOByteBuffer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 IIOByteBuffer

java.lang.Object
    继承者  javax.imageio.stream.IIOByteBuffer

public class IIOByteBuffer
extends Object

表示对某个字节数组及该数组中偏移量和长度的可变引用的类。ImageInputStream 使用 IIOByteBuffer 来向调用者提供字节序列，与使用采用用户提供的字节数组的传统 read 方法相比，这需要的副本可能更少。

IIOByteBuffer 引用的字节数组通常是属于 ImageReader 实现的内部数据结构的一部分；其内容应视为只读的且一定不能被修改。

构造方法摘要
IIOByteBuffer(byte[] data, int offset, int length)
构造一个引用给定字节数组、偏移量和长度的 IIOByteBuffer。
方法摘要
byte[] | getData() 返回对字节数组的引用。
int | getLength() 返回 getData 返回的字节数组中感兴趣的数据长度。
int | getOffset() 返回 getData 返回的字节数组中的偏移量，感兴趣的数据从该处开始。
void | setData(byte[] data) 更新对 getData 方法的后续调用将返回的数组引用。
void | setLength(int length) 更新对 getLength 方法的后续调用将返回的值。
void | setOffset(int offset) 更新对 getOffset 方法的后续调用将返回的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

IIOByteBuffer

public IIOByteBuffer(byte[] data,
                     int offset,
                     int length)
构造一个引用给定字节数组、偏移量和长度的 IIOByteBuffer。

参数：
data - 一个字节数组。
offset - 数组中的 int 偏移量。
length - 一个 int，指示字节数组中感兴趣的数据长度，以字节为单位。
方法详细信息

getData

public byte[] getData()
返回对字节数组的引用。应将返回值视为只读，且应该只使用 getOffset 和 getLength 的值指定部分。

返回：
字节数组引用。
另请参见：
getOffset(),
getLength(),
setData(byte[])

setData

public void setData(byte[] data)
更新对 getData 方法的后续调用将返回的数组引用。

参数：
data - 包含新数据值的字节数组引用。
另请参见：
getData()

getOffset

public int getOffset()
返回 getData 返回的字节数组中的偏移量，感兴趣的数据从该处开始。

返回：
int 偏移量。
另请参见：
getData(),
getLength(),
setOffset(int)

setOffset

public void setOffset(int offset)
更新对 getOffset 方法的后续调用将返回的值。

参数：
offset - 包含新偏移量值的 int。
另请参见：
getOffset()

getLength

public int getLength()
返回 getData 返回的字节数组中感兴趣的数据长度。

返回：
int 长度.
另请参见：
getData(),
getOffset(),
setLength(int)

setLength

public void setLength(int length)
更新对 getLength 方法的后续调用将返回的值。

参数：
length - 包含新长度值的 int。
另请参见：
getLength()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
接口 ImageInputStream

所有超级接口：
DataInput
所有已知子接口：
ImageOutputStream
所有已知实现类：
FileCacheImageInputStream, FileCacheImageOutputStream, FileImageInputStream, FileImageOutputStream, ImageInputStreamImpl, ImageOutputStreamImpl, MemoryCacheImageInputStream, MemoryCacheImageOutputStream
public interface ImageInputStream
extends DataInput

供 ImageReader 使用的可查找输入流接口。各种输入源（如 InputStream、File 以及将来的快速 I/O 源）都可以通过此接口的恰当实现进行“包装”，供 Image I/O API 使用。

另请参见：
ImageInputStreamImpl, FileImageInputStream, FileCacheImageInputStream, MemoryCacheImageInputStream

方法摘要
void | close() 关闭流。
void | flush() 丢弃当前流位置之前的流初始部分。
void | flushBefore(long pos) 丢弃所指示位置之前的流初始部分。
int | getBitOffset() 以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。
ByteOrder | getByteOrder() 以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。
long | getFlushedPosition() 返回流中可以执行查找的最早位置。
long | getStreamPosition() 返回流的当前字节位置。
boolean | isCached() 如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，则返回 true。
boolean | isCachedFile() 如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并且将其保存在临时文件中，则返回 true。
boolean | isCachedMemory() 如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并将其保存在主存中，则返回 true。
long | length() 返回流的总长度（如果已知）。
void | mark() 标记流中某个位置，供后续调用 reset 时返回。
int | read() 从流中读取单个字节，并以整数（0 到 255 之间）形式返回该字节。
int | read(byte[] b) 从流中读取至多 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从索引 off 开始）。
int | readBit() 从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。
long | readBits(int numBits) 从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。
boolean | readBoolean() 从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。
byte | readByte() 从流中读取一个字节，并以 byte 值的形式返回该字节。
void | readBytes(IIOByteBuffer buf, int len) 从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
char | readChar() 与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。
double | readDouble() 从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。
float | readFloat() 从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。
void | readFully(byte[] b) 从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
void | readFully(byte[] b, int off, int len) 从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。
void | readFully(char[] c, int off, int len) 根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。
void | readFully(double[] d, int off, int len) 根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。
void | readFully(float[] f, int off, int len) 根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。
void | readFully(int[] i, int off, int len) 根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。
void | readFully(long[] l, int off, int len) 根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。
void | readFully(short[] s, int off, int len) 根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。
int | readInt() 从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。
String | readLine() 从输入流中读取文本的下一行。
long | readLong() 从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。
short | readShort() 从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。
int | readUnsignedByte() 从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。
long | readUnsignedInt() 从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。
int | readUnsignedShort() 从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。
String | readUTF() 读入一个已使用 UTF-8 修改版格式编码的字符串。
void | reset() 返回在最近一次非匹配地调用 mark 时指向上一个位置（包括位偏移量）的流指针。
void | seek(long pos) 将当前流位置设置为所需的位置。
void | setBitOffset(int bitOffset) 将位偏移量设置为 0 到 7 之间（包含两者）的整数。
void | setByteOrder(ByteOrder byteOrder) 设置希望以后从此流中读取数据值时使用的字节顺序。
int | skipBytes(int n) 将流位置向前移动给定的字节数。
long | skipBytes(long n) 将流位置向前移动给定的字节数。

方法详细信息

setByteOrder

void setByteOrder(ByteOrder byteOrder)
设置希望以后从此流中读取数据值时使用的字节顺序。例如，如果以 4 字节整数形式读取字节序列 '0x01 0x02 0x03 0x04'，则使用网络字节顺序时结果为值 '0x01020304'，使用逆向字节顺序时为值 '0x04030201'。

枚举类 java.nio.ByteOrder 用于指定字节顺序。值 ByteOrder.BIG_ENDIAN 指定所谓的 big-endian 或网络字节顺序，该顺序中高位字节在前。Motorola 和 Sparc 处理器用此格式存储数据，而 Intel 处理器使用与之相反的 ByteOrder.LITTLE_ENDIAN 顺序存储数据。

字节顺序对 readBits 方法返回的结果（或 ImageOutputStream.writeBits 写入的值）没有任何影响。

参数：
byteOrder - ByteOrder.BIG_ENDIAN 或 java.nio.ByteOrder.LITTLE_ENDIAN，指示以后读取时是使用网络顺序还是使用与之相反的顺序。
另请参见：
ByteOrder, getByteOrder(), readBits(int)

getByteOrder

ByteOrder getByteOrder()
以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。

返回：
ByteOrder.BIG_ENDIAN 或 ByteOrder.LITTLE_ENDIAN，指示要使用的字节顺序。
另请参见：
ByteOrder, setByteOrder(java.nio.ByteOrder)

read

int read()
         throws IOException
从流中读取单个字节，并以整数（0 到 255 之间）形式返回该字节。如果到达流末尾，则返回 -1。

在进行读取前，流中的位偏移量被重置为 0。

返回：
流中 int 形式的字节值；或者返回 -1，指示 EOF（文件结束标记）。
抛出：
IOException - 如果发生 I/O 错误。

read

int read(byte[] b)
         throws IOException
从流中读取至多 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。返回读取的字节数。如果因到达流末尾而无法读取任何字节，则返回 -1。

在进行读取前，流中的位偏移量被重置为 0。

参数：
b - 用来接收写入的 byte 数组。
返回：
实际读取的字节数；或者返回 -1，指示 EOF。
抛出：
NullPointerException - 如果 b 为 null。
IOException - 如果发生 I/O 错误。

read

int read(byte[] b,
         int off,
         int len)
         throws IOException
从流中读取至多 len 个字节，并将其存储到 b 中（从索引 off 开始）。返回读取的字节数。如果因到达流末尾而无法读取任何字节，则返回 -1。

在进行读取前，流中的位偏移量被重置为 0。

参数：
b - 用来接收写入的 byte 数组。
off - 向 b 进行写入的开始位置。
len - 要读取的最大 byte 数。
返回：
实际读取的字节数；或者返回 -1，指示 EOF。
抛出：
NullPointerException - 如果 b 为 null。
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 b.length。
IOException - 如果发生 I/O 错误。

readBytes

void readBytes(IIOByteBuffer buf,
               int len)
               throws IOException
从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。调用者不应该试图修改 IIOByteBuffer 中找到的数据。

在进行读取前，流中的位偏移量被重置为 0。

参数：
buf - 要修改的 IIOByteBuffer 对象。
len - 要读取的最大 byte 数。
抛出：
IndexOutOfBoundsException - 如果 len 为负。
NullPointerException - 如果 buf 为 null。
IOException - 如果发生 I/O 错误。

readBoolean

boolean readBoolean()
                    throws IOException
从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readBoolean
返回：
取自流的 boolean 值。
抛出：
EOFException - 如果到达流末尾。
IOException - 如果发生 I/O 错误。

readByte

byte readByte()
              throws IOException
从流中读取一个字节，并以 byte 值的形式返回该字节。0x00 到 0x7f 之间的字节值表示 0 到 127 之间的整数值。0x80 到 0xff 之间的字节值表示 -128 到 -1 之间的负整数值。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readByte
返回：
取自流的单个字节值。
抛出：
EOFException - 如果到达流末尾。
IOException - 如果发生 I/O 错误。

readUnsignedByte

int readUnsignedByte()
                     throws IOException
从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。

于是，0x00 到 0x7f 之间的字节值便作为 0 到 127 之间的整数值返回。0x80 到 0xff 之间的字节值通常表示为负的 byte 值，它们将被映射成 128 到 255 之间的正整数。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readUnsignedByte
返回：
取自流的无符号 byte 值。
抛出：
EOFException - 如果到达流末尾。
IOException - 如果发生 I/O 错误。

readShort

short readShort()
                throws IOException
从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readShort
返回：
取自流的有符号 short 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
getByteOrder()

readUnsignedShort

int readUnsignedShort()
                      throws IOException
从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readUnsignedShort
返回：
取自流的无符号 short 值（int 形式）。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
getByteOrder()

readChar

char readChar()
              throws IOException
与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readChar
返回：
取自流的无符号 char 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
readUnsignedShort()

readInt

int readInt()
            throws IOException
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。

忽略流中的位偏移量，将其视为 0。

指定者：
接口 DataInput 中的 readInt
返回：
取自流的有符号 int 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
getByteOrder()

readUnsignedInt

long readUnsignedInt()
                     throws IOException
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

返回：
取自流的无符号 int 值（long 形式）。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
getByteOrder()

readLong

long readLong()
              throws IOException
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readLong
返回：
取自流的有符号 long 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
getByteOrder()

readFloat

float readFloat()
                throws IOException
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readFloat
返回：
取自流的 float 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
getByteOrder()

readDouble

double readDouble()
                  throws IOException
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readDouble
返回：
取自流的 double 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
getByteOrder()

readLine

String readLine()
                throws IOException
从输入流中读取文本的下一行。该方法读取连续的字节，将每个字节分别转换成一个字符，直到遇到行结尾符或文件结束标记；然后以 String 形式返回读取的字符。注意，因为此方法处理字符，所以它不支持整个 Unicode 字符集的输入。

如果在一个字节都没有读取的时候就遇到文件结束标记，则返回 null。否则，通过左侧补 0 将读取的每个字节转换成 char 类型的值。如果遇到字符 '\n'，则丢弃它并且停止读取。如果遇到字符 '\r'，则丢弃它；如果它后面的那个字节转变成字符 '\n'，则同样丢弃它，并且停止读取。如果在遇到字符 '\n' 和 '\r' 之一前遇到文件结束标记，则停止读取。一旦已停止读取，则返回一个 String，它按顺序包含所有已读取且未丢弃的字符。注意，此字符串中的每个字符的值都将小于 \u0100（即 (char)256）的值。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readLine
返回：
一个 String，它包含取自流的一行文本。
抛出：
IOException - 如果发生 I/O 错误。

readUTF

String readUTF()
               throws IOException
读入一个已使用 UTF-8 修改版格式编码的字符串。readUTF 的常规协定是：该方法读取使用 UTF-8 修改版格式编码的 Unicode 字符串的表示形式；然后以 String 的形式返回此字符串。

首先，读取两个字节并按 readUnsignedShort 方法的方式使用这两个字节构造一个无符号 16 位整数，使用的是网络字节顺序（无论当前设置的是哪种字节顺序）。该整数值被称为 UTF 长度，它指定要读取的额外字节数。然后成组地将这些字节转换为字符。每组的长度根据该组第一个字节的值计算。紧跟在某个组后面的字节（如果有）是下一组的第一个字节。

如果组的第一个字节与位模式 0xxxxxxx（其中 x 表示“可能为 0 或 1”）匹配，则该组只有这一个字节。该字节被左侧补 0，转换成一个字符。

如果组的第一个字节与位模式 110xxxxx 匹配，则该组只由字节 a 和另一个字节 b 组成。如果没有字节 b（因为字节 a 是要读取的最后一个字节），或者字节 b 与位模式 10xxxxxx 不匹配，则抛出 UTFDataFormatException。否则，将该组转换成字符：

 (char)(((a& 0x1F) << 6) | (b & 0x3F))
如果组的第一个字节与位模式 1110xxxx 匹配，则该组由字节 a 和另外两个字节 b 和 c 组成。如果没有字节 c（因为字节 a 是要读取的最后两个字节之一），或者字节 b 或字节 c 与位模式 10xxxxxx 不匹配，则抛出 UTFDataFormatException。否则，将该组转换成字符：

 (char)(((a & 0x0F) << 12) | ((b & 0x3F) << 6) | (c & 0x3F))
如果组的第一个字节与模式 1111xxxx 或模式 10xxxxxx 匹配，则抛出 UTFDataFormatException。

如果在整个执行过程中的任意时间遇到文件结束标记，则抛出 EOFException。

在通过此过程将每个组转换成字符后，按照从输入流中读取相应组的顺序，将这些字符收集在一起，形成一个 String，然后该字符串将被返回。

忽略当前设置的字节顺序。

在进行读取前，流中的位偏移量被重置为 0。

注：在使用标准 UTF-8 图像格式的实现中不应该使用此方法，因为此处使用的 UTF-8 修改版与标准 UTF-8 不兼容。

指定者：
接口 DataInput 中的 readUTF
返回：
从流中读取的 String。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
UTFDataFormatException - 如果这些字节不表示一个有效的、UTF-8 修改版编码的字符串。
IOException - 如果发生 I/O 错误。

readFully

void readFully(byte[] b,
               int off,
               int len)
               throws IOException
从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readFully
参数：
b - 用来接收写入的 byte 数组。
off - 向 b 进行写入的开始位置。
len - 要读取的最大 byte 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 b.length。
NullPointerException - 如果 b 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(byte[] b)
               throws IOException
从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readFully
参数：
b - 一个 byte 数组。
抛出：
NullPointerException - 如果 b 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(short[] s,
               int off,
               int len)
               throws IOException
根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

参数：
s - 用来接收写入的 short 数组。
off - 向 s 进行写入的开始位置。
len - 要读取的最大 short 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 s.length。
NullPointerException - 如果 s 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(char[] c,
               int off,
               int len)
               throws IOException
根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

参数：
c - 用来接收写入的 char 数组。
off - 向 c 进行写入的开始位置。
len - 要读取的最大 char 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 c.length。
NullPointerException - 如果 c 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(int[] i,
               int off,
               int len)
               throws IOException
根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

参数：
i - 用来接收写入的 int 数组。
off - 向 i 进行写入的开始位置。
len - 要读取的最大 int 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 i.length。
NullPointerException - 如果 i 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(long[] l,
               int off,
               int len)
               throws IOException
根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

参数：
l - 用来接收写入的 long 数组。
off - 向 l 进行写入的开始位置。
len - 要读取的最大 long 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 l.length。
NullPointerException - 如果 l 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(float[] f,
               int off,
               int len)
               throws IOException
根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

参数：
f - 用来接收写入的 float 数组。
off - 向 f 进行写入的开始位置。
len - 要读取的最大 float 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 f.length。
NullPointerException - 如果 f 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

void readFully(double[] d,
               int off,
               int len)
               throws IOException
根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

参数：
d - 用来接收写入的 double 数组。
off - 向 d 进行写入的开始位置。
len - 要读取的最大 double 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 d.length。
NullPointerException - 如果 d 为 null。
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

getStreamPosition

long getStreamPosition()
                       throws IOException
返回流的当前字节位置。下一次读取将从此偏移量开始。

返回：
一个包含流位置 long 值。
抛出：
IOException - 如果发生 I/O 错误。

getBitOffset

int getBitOffset()
                 throws IOException
以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。位偏移量通过调用 readBits 方法隐式地更新。值 0 表示所读取字节的最高有效位，值 7 表示所读取字节的最低有效位。

第一次打开流时位偏移量被设置为 0，以后可以通过调用 seek、skipBytes、或者任何 read 或 readFully 方法将其重置为 0。

返回：
一个 int，包含 0 到 7 之间（包含两者）的位偏移量。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
setBitOffset(int)

setBitOffset

void setBitOffset(int bitOffset)
                  throws IOException
将位偏移量设置为 0 到 7 之间（包含两者）的整数。不改变流中由 getStreamPosition 返回的位偏移量。值 0 表示所读取字节的最高有效位，值 7 表示所读取字节的最低有效位。

参数：
bitOffset - 所需的偏移量，为 0 到 7 之间（包括两者）的 int 的形式。
抛出：
IllegalArgumentException - 如果 bitOffset 不在 0 和 7（包括两者）之间。
IOException - 如果发生 I/O 错误。
另请参见：
getBitOffset()

readBit

int readBit()
            throws IOException
从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。位偏移量将加 1，模数将减 8。

返回：
一个 int，包含 0 或 1。
抛出：
EOFException - 如果该流在读取所有位之前到达末尾。
IOException - 如果发生 I/O 错误。

readBits

long readBits(int numBits)
              throws IOException
从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。在 getStreamPosition 指示的字节中从 getBitOffset 给定的位开始读取。位偏移量将增加 numBits，模数将减 8。

流的字节顺序对此方法没有任何影响。此方法返回值的构造方式相当于每次读取一个位，然后将其移到返回值的右边。如以下伪代码所示：

 long accum = 0L;
 for (int i = 0; i < numBits; i++) {
   accum <<= 1; // Shift left one bit to make room
   accum |= readBit();
 }
注意，如果使用了与网络字节顺序相反的顺序（即 getByteOrder() == false），那么 readBits(32) 的结果可能因此而不等于 readInt() 的结果。

如果在读取了所有位前遇到流末尾，则抛出 EOFException。

参数：
numBits - 要读取的位数，为 0 到 64 之间（包含两者）的 int 形式。
返回：
long 形式的位串，最后读取的位存储在最低有效位中。
抛出：
IllegalArgumentException - 如果 numBits 不在 0 和 64 之间（包括两者）。
EOFException - 如果该流在读取所有位之前到达末尾。
IOException - 如果发生 I/O 错误。

length

long length()
            throws IOException
返回流的总长度（如果已知）。否则，返回 -1。

返回：
一个 long，包含流的长度（如果已知）；否则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。

skipBytes

int skipBytes(int n)
              throws IOException
将流位置向前移动给定的字节数。此方法向前跳过的字节数可能小于所请求的字节数，例如，在到达流末尾时。无论如何，将返回实际跳过的字节数。在推进位置前，位偏移量被设置为 0。

指定者：
接口 DataInput 中的 skipBytes
参数：
n - 一个 int，它包含要跳过的字节数。
返回：
一个 int，表示跳过的字节数。
抛出：
IOException - 如果发生 I/O 错误。

skipBytes

long skipBytes(long n)
               throws IOException
将流位置向前移动给定的字节数。此方法等同于 skipBytes(int)，唯一的不同在于它允许更大的跳跃距离。

参数：
n - 一个 long，它包含要跳过的字节数。
返回：
表示跳过的字节数的 long。
抛出：
IOException - 如果发生 I/O 错误。

seek

void seek(long pos)
          throws IOException
将当前流位置设置为所需的位置。下一次读取将在此位置上进行。位偏移量被设置为 0。

如果 pos 小于刷新位置（由 getflushedPosition 返回），那么将抛出 IndexOutOfBoundsException。

查找文件结束标记的后面是合法的，只有在该处执行读取时才抛出 EOFException。

参数：
pos - 一个 long，它包含所需的文件指针位置。
抛出：
IndexOutOfBoundsException - 如果 pos 小于刷新位置。
IOException - 如果发生任何 I/O 错误。

mark

void mark()
标记流中某个位置，供后续调用 reset 时返回。与标准 InputStream 不同的是，所有的 ImageInputStream 都支持标记操作。此外，还可以随意嵌套对 mark 和 reset 的调用。

与 Reader 和 InputStream 接口声明的 mark 方法不同，此方法不使用任何 readLimit 参数。调用 mark 后可以读取任意数量的数据。

readBits 方法使用的位位置可通过每次调用 mark 和 reset 来保存和恢复。

注意，ImageReader 调用 flushBefore 作为读取操作的一部分是有效的。因此，如果应用程序向 ImageReader 传递该流前调用 mark，则应用程序不应该假定标记位置在读取操作完成后仍保持有效。

reset

void reset()
           throws IOException
返回在最近一次非匹配地调用 mark 时指向上一个位置（包括位偏移量）的流指针。

调用 reset 而没有相应地调用 mark 没有任何效果。

如果上一个标记位置位于流的丢弃部分，则抛出 IOException。

抛出：
IOException - 如果发生 I/O 错误。

flushBefore

void flushBefore(long pos)
                 throws IOException
丢弃所指示位置之前的流初始部分。试图查找流的刷新部分中的偏移量将导致抛出 IndexOutOfBoundsException。

调用 flushBefore 可允许实现此接口的类释放存储流中的数据所使用的资源，如内存和磁盘空间。

参数：
pos - 一个 long，它包含要刷新的流前缀的长度。
抛出：
IndexOutOfBoundsException - 如果 pos 位于流的刷新部分或当前流位置的后面。
IOException - 如果发生 I/O 错误。

flush

void flush()
           throws IOException
丢弃当前流位置之前的流初始部分。等效于 flushBefore(getStreamPosition())。

抛出：
IOException - 如果发生 I/O 错误。

getFlushedPosition

long getFlushedPosition()
返回流中可以执行查找的最早位置。返回值将是所有传入 flushBefore 上一次调用的值中的最大值。

返回：
用于查找的最早的合法位置（long 形式）。

isCached

boolean isCached()
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，则返回 true。应用程序可以根据此方法来决定刷新的频率以及是否刷新以保留缓存资源。

返回：
如果此 ImageInputStream 缓存数据，则返回 true。
另请参见：
isCachedMemory(), isCachedFile()

isCachedMemory

boolean isCachedMemory()
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并将其保存在主存中，则返回 true。应用程序可以根据此方法来决定刷新的频率以及是否刷新以保留缓存资源。

返回：
如果此 ImageInputStream 在主存中缓存数据，则返回 true。
另请参见：
isCached(), isCachedFile()

isCachedFile

boolean isCachedFile()
如果此 ImageInputStream 本身为了允许逆向查找而缓存了数据，并且将其保存在临时文件中，则返回 true。应用程序可以根据此方法来决定刷新的频率以及是否刷新以保留缓存资源。

返回：
如果此 ImageInputStream 在临时文件中缓存数据，则返回 true。
另请参见：
isCached(), isCachedMemory()

close

void close()
           throws IOException
关闭流。试图访问已经关闭的流将导致 IOException 或错误行为。调用此方法可允许实现此接口的类释放与流关联的资源，如内存、磁盘空间或文件描述符。

抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageInputStreamImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 ImageInputStreamImpl

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
所有已实现的接口：
DataInput, ImageInputStream
直接已知子类：
FileCacheImageInputStream, FileImageInputStream, ImageOutputStreamImpl, MemoryCacheImageInputStream
public abstract class ImageInputStreamImpl
extends Object
implements ImageInputStream

实现 ImageInputStream 接口的抽象类。此类设计用于减少必须由子类实现的方法数。

需要特别指出的是，此类处理大部分或全部关于字节顺序解释、缓冲、标记/重置、丢弃、关闭和释放的详细资料。

字段摘要
protected int | bitOffset 流中的当前位偏移量。
protected ByteOrder | byteOrder 流的字节顺序，其为枚举类 java.nio.ByteOrder 的实例，其中 ByteOrder.BIG_ENDIAN 指示网络字节顺序，ByteOrder.LITTLE_ENDIAN 指示反向顺序。
protected long | flushedPos 可能丢弃的数据前面的那个位置。
protected long | streamPos 流中的当前读取位置。
构造方法摘要
ImageInputStreamImpl()
构造一个 ImageInputStreamImpl。
方法摘要
protected void | checkClosed() 如果已经关闭流，则抛出 IOException。
void | close() 关闭流。
protected void | finalize() 在垃圾回收前结束此对象。
void | flush() 丢弃当前流位置之前的流初始部分。
void | flushBefore(long pos) 丢弃所指示位置之前的流初始部分。
int | getBitOffset() 以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。
ByteOrder | getByteOrder() 以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。
long | getFlushedPosition() 返回流中可以执行查找的最早位置。
long | getStreamPosition() 返回流的当前字节位置。
boolean | isCached() 默认实现返回 false。
boolean | isCachedFile() 默认实现返回 false。
boolean | isCachedMemory() 默认实现返回 false。
long | length() 返回 -1L，指示流的长度未知。
void | mark() 将当前流位置推进到标记位置的堆栈上。
abstract int | read() 从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
int | read(byte[] b) 调用 read(b, 0, b.length) 的便捷方法。
abstract int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
int | readBit() 从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。
long | readBits(int numBits) 从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。
boolean | readBoolean() 从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。
byte | readByte() 从流中读取一个字节，并以 byte 值的形式返回该字节。
void | readBytes(IIOByteBuffer buf, int len) 从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
char | readChar() 与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。
double | readDouble() 从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。
float | readFloat() 从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。
void | readFully(byte[] b) 从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。
void | readFully(byte[] b, int off, int len) 从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。
void | readFully(char[] c, int off, int len) 根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。
void | readFully(double[] d, int off, int len) 根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。
void | readFully(float[] f, int off, int len) 根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。
void | readFully(int[] i, int off, int len) 根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。
void | readFully(long[] l, int off, int len) 根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。
void | readFully(short[] s, int off, int len) 根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。
int | readInt() 从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。
String | readLine() 从输入流中读取文本的下一行。
long | readLong() 从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。
short | readShort() 从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。
int | readUnsignedByte() 从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。
long | readUnsignedInt() 从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。
int | readUnsignedShort() 从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。
String | readUTF() 读入一个已使用 UTF-8 修改版格式编码的字符串。
void | reset() 根据标记的堆栈重置当前流字节和位位置。
void | seek(long pos) 将当前流位置设置为所需的位置。
void | setBitOffset(int bitOffset) 将位偏移量设置为 0 到 7 之间（包含两者）的整数。
void | setByteOrder(ByteOrder byteOrder) 设置希望以后从此流中读取数据值时使用的字节顺序。
int | skipBytes(int n) 通过调用 seek(getStreamPosition() + n) 推进当前流位置。
long | skipBytes(long n) 通过调用 seek(getStreamPosition() + n) 推进当前流位置。
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

byteOrder

protected ByteOrder byteOrder
流的字节顺序，其为枚举类 java.nio.ByteOrder 的实例，其中 ByteOrder.BIG_ENDIAN 指示网络字节顺序，ByteOrder.LITTLE_ENDIAN 指示反向顺序。默认情况下，该值为 ByteOrder.BIG_ENDIAN。

streamPos

protected long streamPos
流中的当前读取位置。子类负责根据其重写的任何会改变读取位置的方法保持此值最新。

bitOffset

protected int bitOffset
流中的当前位偏移量。子类负责根据其重写的任何会改变位偏移量的方法保持此值最新。

flushedPos

protected long flushedPos
可能丢弃的数据前面的那个位置。不允许查找较小的位置。flushedPos 将总是 >= 0。

构造方法详细信息

ImageInputStreamImpl

public ImageInputStreamImpl()
构造一个 ImageInputStreamImpl。

方法详细信息

checkClosed

protected final void checkClosed()
                          throws IOException
如果已经关闭流，则抛出 IOException。子类可以从其任何要求不关闭流的方法中调用此方法。

抛出：
IOException - 如果已关闭流。

setByteOrder

public void setByteOrder(ByteOrder byteOrder)
从接口 ImageInputStream 复制的描述
设置希望以后从此流中读取数据值时使用的字节顺序。例如，如果以 4 字节整数形式读取字节序列 '0x01 0x02 0x03 0x04'，则使用网络字节顺序时结果为值 '0x01020304'，使用逆向字节顺序时为值 '0x04030201'。

枚举类 java.nio.ByteOrder 用于指定字节顺序。值 ByteOrder.BIG_ENDIAN 指定所谓的 big-endian 或网络字节顺序，该顺序中高位字节在前。Motorola 和 Sparc 处理器用此格式存储数据，而 Intel 处理器使用与之相反的 ByteOrder.LITTLE_ENDIAN 顺序存储数据。

字节顺序对 readBits 方法返回的结果（或 ImageOutputStream.writeBits 写入的值）没有任何影响。

指定者：
接口 ImageInputStream 中的 setByteOrder
参数：
byteOrder - ByteOrder.BIG_ENDIAN 或 java.nio.ByteOrder.LITTLE_ENDIAN，指示以后读取时是使用网络顺序还是使用与之相反的顺序。
另请参见：
ByteOrder, ImageInputStream.getByteOrder(), ImageInputStream.readBits(int)

getByteOrder

public ByteOrder getByteOrder()
从接口 ImageInputStream 复制的描述
以 java.nio.ByteOrder 枚举实例的形式返回从此流中读取数据值时所使用的字节顺序。

指定者：
接口 ImageInputStream 中的 getByteOrder
返回：
ByteOrder.BIG_ENDIAN 或 ByteOrder.LITTLE_ENDIAN，指示要使用的字节顺序。
另请参见：
ByteOrder, ImageInputStream.setByteOrder(java.nio.ByteOrder)

read

public abstract int read()
                  throws IOException
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。 如果到达 EOF，则返回 -1。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

在发生读取前，流中的位偏移量必须被重置为 0。

指定者：
接口 ImageInputStream 中的 read
返回：
流中下一个字节的值；如果到达 EOF，则返回 -1。
抛出：
IOException - 如果流已经被关闭。

read

public int read(byte[] b)
         throws IOException
调用 read(b, 0, b.length) 的便捷方法。

在发生读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 read
参数：
b - 用来接收写入的 byte 数组。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
NullPointerException - 如果 b 为 null。
IOException - 如果发生 I/O 错误。

read

public abstract int read(byte[] b,
                         int off,
                         int len)
                  throws IOException
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。如果由于到达流末尾而没有读取任何字节，则返回 -1。

在发生读取前，流中的位偏移量必须被重置为 0。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

指定者：
接口 ImageInputStream 中的 read
参数：
b - 用来接收写入的字节数组。
off - b 中要写入的起始位置。
len - 要读取的最大字节数。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 b.length。
NullPointerException - 如果 b 为 null。
IOException - 如果发生 I/O 错误。

readBytes

public void readBytes(IIOByteBuffer buf,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。调用者不应该试图修改 IIOByteBuffer 中找到的数据。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readBytes
参数：
buf - 要修改的 IIOByteBuffer 对象。
len - 要读取的最大 byte 数。
抛出：
IOException - 如果发生 I/O 错误。

readBoolean

public boolean readBoolean()
                    throws IOException
从接口 ImageInputStream 复制的描述
从流中读取一个字节，如果其不为 0，则返回 boolean 值 true；如果为 0，则返回 false。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readBoolean
指定者：
接口 ImageInputStream 中的 readBoolean
返回：
取自流的 boolean 值。
抛出：
EOFException - 如果到达流末尾。
IOException - 如果发生 I/O 错误。

readByte

public byte readByte()
              throws IOException
从接口 ImageInputStream 复制的描述
从流中读取一个字节，并以 byte 值的形式返回该字节。0x00 到 0x7f 之间的字节值表示 0 到 127 之间的整数值。0x80 到 0xff 之间的字节值表示 -128 到 -1 之间的负整数值。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readByte
指定者：
接口 ImageInputStream 中的 readByte
返回：
取自流的单个字节值。
抛出：
EOFException - 如果到达流末尾。
IOException - 如果发生 I/O 错误。

readUnsignedByte

public int readUnsignedByte()
                     throws IOException
从接口 ImageInputStream 复制的描述
从流中读取一个字节，将其转换为 int（概念上），使用 0xff 屏蔽以便去掉所有符号扩展位，然后以 byte 值的形式返回。

于是，0x00 到 0x7f 之间的字节值便作为 0 到 127 之间的整数值返回。0x80 到 0xff 之间的字节值通常表示为负的 byte 值，它们将被映射成 128 到 255 之间的正整数。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readUnsignedByte
指定者：
接口 ImageInputStream 中的 readUnsignedByte
返回：
取自流的无符号 byte 值。
抛出：
EOFException - 如果到达流末尾。
IOException - 如果发生 I/O 错误。

readShort

public short readShort()
                throws IOException
从接口 ImageInputStream 复制的描述
从流中读取两个字节，根据当前字节顺序将其连接（概念上），然后以 short 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readShort
指定者：
接口 ImageInputStream 中的 readShort
返回：
取自流的有符号 short 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getByteOrder()

readUnsignedShort

public int readUnsignedShort()
                      throws IOException
从接口 ImageInputStream 复制的描述
从流中读取两个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 int，使用 0xffff 屏蔽以便去掉所有符号扩展位，然后以无符号 int 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readUnsignedShort
指定者：
接口 ImageInputStream 中的 readUnsignedShort
返回：
取自流的无符号 short 值（int 形式）。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getByteOrder()

readChar

public char readChar()
              throws IOException
从接口 ImageInputStream 复制的描述
与 readUnsignedShort 等效，唯一的不同在于它的结果使用 char 数据类型返回。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readChar
指定者：
接口 ImageInputStream 中的 readChar
返回：
取自流的无符号 char 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.readUnsignedShort()

readInt

public int readInt()
            throws IOException
从接口 ImageInputStream 复制的描述
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 int 值的形式返回结果。

忽略流中的位偏移量，将其视为 0。

指定者：
接口 DataInput 中的 readInt
指定者：
接口 ImageInputStream 中的 readInt
返回：
取自流的有符号 int 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getByteOrder()

readUnsignedInt

public long readUnsignedInt()
                     throws IOException
从接口 ImageInputStream 复制的描述
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），将得到的值转换为 long，使用 0xffffffffL 屏蔽以便去掉所有符号扩展位，然后以无符号 long 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readUnsignedInt
返回：
取自流的无符号 int 值（long 形式）。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getByteOrder()

readLong

public long readLong()
              throws IOException
从接口 ImageInputStream 复制的描述
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 long 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readLong
指定者：
接口 ImageInputStream 中的 readLong
返回：
取自流的有符号 long 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getByteOrder()

readFloat

public float readFloat()
                throws IOException
从接口 ImageInputStream 复制的描述
从流中读取 4 个字节，根据当前字节顺序将其连接（概念上），然后以 float 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readFloat
指定者：
接口 ImageInputStream 中的 readFloat
返回：
取自流的 float 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getByteOrder()

readDouble

public double readDouble()
                  throws IOException
从接口 ImageInputStream 复制的描述
从流中读取 8 个字节，根据当前字节顺序将其连接（概念上），然后以 double 值的形式返回结果。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readDouble
指定者：
接口 ImageInputStream 中的 readDouble
返回：
取自流的 double 值。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getByteOrder()

readLine

public String readLine()
                throws IOException
从接口 ImageInputStream 复制的描述
从输入流中读取文本的下一行。该方法读取连续的字节，将每个字节分别转换成一个字符，直到遇到行结尾符或文件结束标记；然后以 String 形式返回读取的字符。注意，因为此方法处理字符，所以它不支持整个 Unicode 字符集的输入。

如果在一个字节都没有读取的时候就遇到文件结束标记，则返回 null。否则，通过左侧补 0 将读取的每个字节转换成 char 类型的值。如果遇到字符 '\n'，则丢弃它并且停止读取。如果遇到字符 '\r'，则丢弃它；如果它后面的那个字节转变成字符 '\n'，则同样丢弃它，并且停止读取。如果在遇到字符 '\n' 和 '\r' 之一前遇到文件结束标记，则停止读取。一旦已停止读取，则返回一个 String，它按顺序包含所有已读取且未丢弃的字符。注意，此字符串中的每个字符的值都将小于 \u0100（即 (char)256）的值。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readLine
指定者：
接口 ImageInputStream 中的 readLine
返回：
一个 String，它包含取自流的一行文本。
抛出：
IOException - 如果发生 I/O 错误。

readUTF

public String readUTF()
               throws IOException
从接口 ImageInputStream 复制的描述
读入一个已使用 UTF-8 修改版格式编码的字符串。readUTF 的常规协定是：该方法读取使用 UTF-8 修改版格式编码的 Unicode 字符串的表示形式；然后以 String 的形式返回此字符串。

首先，读取两个字节并按 readUnsignedShort 方法的方式使用这两个字节构造一个无符号 16 位整数，使用的是网络字节顺序（无论当前设置的是哪种字节顺序）。该整数值被称为 UTF 长度，它指定要读取的额外字节数。然后成组地将这些字节转换为字符。每组的长度根据该组第一个字节的值计算。紧跟在某个组后面的字节（如果有）是下一组的第一个字节。

如果组的第一个字节与位模式 0xxxxxxx（其中 x 表示“可能为 0 或 1”）匹配，则该组只有这一个字节。该字节被左侧补 0，转换成一个字符。

如果组的第一个字节与位模式 110xxxxx 匹配，则该组只由字节 a 和另一个字节 b 组成。如果没有字节 b（因为字节 a 是要读取的最后一个字节），或者字节 b 与位模式 10xxxxxx 不匹配，则抛出 UTFDataFormatException。否则，将该组转换成字符：

 (char)(((a& 0x1F) << 6) | (b & 0x3F))
如果组的第一个字节与位模式 1110xxxx 匹配，则该组由字节 a 和另外两个字节 b 和 c 组成。如果没有字节 c（因为字节 a 是要读取的最后两个字节之一），或者字节 b 或字节 c 与位模式 10xxxxxx 不匹配，则抛出 UTFDataFormatException。否则，将该组转换成字符：

 (char)(((a & 0x0F) << 12) | ((b & 0x3F) << 6) | (c & 0x3F))
如果组的第一个字节与模式 1111xxxx 或模式 10xxxxxx 匹配，则抛出 UTFDataFormatException。

如果在整个执行过程中的任意时间遇到文件结束标记，则抛出 EOFException。

在通过此过程将每个组转换成字符后，按照从输入流中读取相应组的顺序，将这些字符收集在一起，形成一个 String，然后该字符串将被返回。

忽略当前设置的字节顺序。

在进行读取前，流中的位偏移量被重置为 0。

注：在使用标准 UTF-8 图像格式的实现中不应该使用此方法，因为此处使用的 UTF-8 修改版与标准 UTF-8 不兼容。

指定者：
接口 DataInput 中的 readUTF
指定者：
接口 ImageInputStream 中的 readUTF
返回：
从流中读取的 String。
抛出：
EOFException - 如果此流在读取所有字节之前到达末尾。
UTFDataFormatException - 如果这些字节不表示一个有效的、UTF-8 修改版编码的字符串。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(byte[] b,
                      int off,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
从流中读取 len 个字节，并将其存储到 b 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readFully
指定者：
接口 ImageInputStream 中的 readFully
参数：
b - 用来接收写入的 byte 数组。
off - 向 b 进行写入的开始位置。
len - 要读取的最大 byte 数。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(byte[] b)
               throws IOException
从接口 ImageInputStream 复制的描述
从流中读取 b.length 个字节，并将其存储到 b 中（从索引 0 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 DataInput 中的 readFully
指定者：
接口 ImageInputStream 中的 readFully
参数：
b - 一个 byte 数组。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(short[] s,
                      int off,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
根据当前字节顺序从流中读取 len 个 short（有符号 16 位整数），并将其存储到 s 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readFully
参数：
s - 用来接收写入的 short 数组。
off - 向 s 进行写入的开始位置。
len - 要读取的最大 short 数。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(char[] c,
                      int off,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
根据当前字节顺序从流中读取 len 个 char（无符号 16 位整数），并将其存储到 c 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readFully
参数：
c - 用来接收写入的 char 数组。
off - 向 c 进行写入的开始位置。
len - 要读取的最大 char 数。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(int[] i,
                      int off,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
根据当前字节顺序从流中读取 len 个 int（有符号 32 位整数），并将其存储到 i 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readFully
参数：
i - 用来接收写入的 int 数组。
off - 向 i 进行写入的开始位置。
len - 要读取的最大 int 数。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(long[] l,
                      int off,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
根据当前字节顺序从流中读取 len 个 long（有符号 64 位整数），并将其存储到 l 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readFully
参数：
l - 用来接收写入的 long 数组。
off - 向 l 进行写入的开始位置。
len - 要读取的最大 long 数。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(float[] f,
                      int off,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
根据当前字节顺序从流中读取 len 个 float（32 位 IEEE 单精度浮点值），并将其存储到 f 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readFully
参数：
f - 用来接收写入的 float 数组。
off - 向 f 进行写入的开始位置。
len - 要读取的最大 float 数。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

readFully

public void readFully(double[] d,
                      int off,
                      int len)
               throws IOException
从接口 ImageInputStream 复制的描述
根据当前字节顺序从流中读取 len 个 double（64 位 IEEE 双精度浮点值），并将其存储到 d 中（从索引 off 开始）。如果到达流末尾，则将抛出 EOFException。

在进行读取前，流中的位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 readFully
参数：
d - 用来接收写入的 double 数组。
off - 向 d 进行写入的开始位置。
len - 要读取的最大 double 数。
抛出：
EOFException - 如果该流在读取所有字节之前到达末尾。
IOException - 如果发生 I/O 错误。

getStreamPosition

public long getStreamPosition()
                       throws IOException
从接口 ImageInputStream 复制的描述
返回流的当前字节位置。下一次读取将从此偏移量开始。

指定者：
接口 ImageInputStream 中的 getStreamPosition
返回：
一个包含流位置 long 值。
抛出：
IOException - 如果发生 I/O 错误。

getBitOffset

public int getBitOffset()
                 throws IOException
从接口 ImageInputStream 复制的描述
以整数的形式返回当前位偏移量，该整数在 0 到 7 之间（包含两者）。位偏移量通过调用 readBits 方法隐式地更新。值 0 表示所读取字节的最高有效位，值 7 表示所读取字节的最低有效位。

第一次打开流时位偏移量被设置为 0，以后可以通过调用 seek、skipBytes、或者任何 read 或 readFully 方法将其重置为 0。

指定者：
接口 ImageInputStream 中的 getBitOffset
返回：
一个 int，包含 0 到 7 之间（包含两者）的位偏移量。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.setBitOffset(int)

setBitOffset

public void setBitOffset(int bitOffset)
                  throws IOException
从接口 ImageInputStream 复制的描述
将位偏移量设置为 0 到 7 之间（包含两者）的整数。不改变流中由 getStreamPosition 返回的位偏移量。值 0 表示所读取字节的最高有效位，值 7 表示所读取字节的最低有效位。

指定者：
接口 ImageInputStream 中的 setBitOffset
参数：
bitOffset - 所需的偏移量，为 0 到 7 之间（包括两者）的 int 的形式。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
ImageInputStream.getBitOffset()

readBit

public int readBit()
            throws IOException
从接口 ImageInputStream 复制的描述
从流中读取单个字节，并以 int（0 或 1）的形式返回该字节。位偏移量将加 1，模数将减 8。

指定者：
接口 ImageInputStream 中的 readBit
返回：
一个 int，包含 0 或 1。
抛出：
EOFException - 如果该流在读取所有位之前到达末尾。
IOException - 如果发生 I/O 错误。

readBits

public long readBits(int numBits)
              throws IOException
从接口 ImageInputStream 复制的描述
从流中读取位串 (bitstring) 并以 long 的形式返回，使第一个读取的位成为输出的最高有效位。在 getStreamPosition 指示的字节中从 getBitOffset 给定的位开始读取。位偏移量将增加 numBits，模数将减 8。

流的字节顺序对此方法没有任何影响。此方法返回值的构造方式相当于每次读取一个位，然后将其移到返回值的右边。如以下伪代码所示：

 long accum = 0L;
 for (int i = 0; i < numBits; i++) {
   accum <<= 1; // Shift left one bit to make room
   accum |= readBit();
 }
注意，如果使用了与网络字节顺序相反的顺序（即 getByteOrder() == false），那么 readBits(32) 的结果可能因此而不等于 readInt() 的结果。

如果在读取了所有位前遇到流末尾，则抛出 EOFException。

指定者：
接口 ImageInputStream 中的 readBits
参数：
numBits - 要读取的位数，为 0 到 64 之间（包含两者）的 int 形式。
返回：
long 形式的位串，最后读取的位存储在最低有效位中。
抛出：
EOFException - 如果该流在读取所有位之前到达末尾。
IOException - 如果发生 I/O 错误。

length

public long length()
返回 -1L，指示流的长度未知。子类必须重写此方法来提供实际的长度信息。

指定者：
接口 ImageInputStream 中的 length
返回：
指示不知道长度的 -1L。

skipBytes

public int skipBytes(int n)
              throws IOException
通过调用 seek(getStreamPosition() + n) 推进当前流位置。

位偏移量被重置为 0。

指定者：
接口 DataInput 中的 skipBytes
指定者：
接口 ImageInputStream 中的 skipBytes
参数：
n - 要逆向查找的字节数。
返回：
一个 int，表示跳过的字节数。
抛出：
IOException - 如果 getStreamPosition 计算起始或结束位置时抛出 IOException。

skipBytes

public long skipBytes(long n)
               throws IOException
通过调用 seek(getStreamPosition() + n) 推进当前流位置。

位偏移量被重置为 0。

指定者：
接口 ImageInputStream 中的 skipBytes
参数：
n - 要逆向查找的字节数。
返回：
一个 long，表示跳过的字节数。
抛出：
IOException - 如果 getStreamPosition 计算起始或结束位置时抛出 IOException。

seek

public void seek(long pos)
          throws IOException
从接口 ImageInputStream 复制的描述
将当前流位置设置为所需的位置。下一次读取将在此位置上进行。位偏移量被设置为 0。

如果 pos 小于刷新位置（由 getflushedPosition 返回），那么将抛出 IndexOutOfBoundsException。

查找文件结束标记的后面是合法的，只有在该处执行读取时才抛出 EOFException。

指定者：
接口 ImageInputStream 中的 seek
参数：
pos - 一个 long，它包含所需的文件指针位置。
抛出：
IOException - 如果发生任何 I/O 错误。

mark

public void mark()
将当前流位置推进到标记位置的堆栈上。

指定者：
接口 ImageInputStream 中的 mark

reset

public void reset()
           throws IOException
根据标记的堆栈重置当前流字节和位位置。

如果以前的标记位置位于流的丢弃部分，则抛出 IOException。

指定者：
接口 ImageInputStream 中的 reset
抛出：
IOException - 如果发生 I/O 错误。

flushBefore

public void flushBefore(long pos)
                 throws IOException
从接口 ImageInputStream 复制的描述
丢弃所指示位置之前的流初始部分。试图查找流的刷新部分中的偏移量将导致抛出 IndexOutOfBoundsException。

调用 flushBefore 可允许实现此接口的类释放存储流中的数据所使用的资源，如内存和磁盘空间。

指定者：
接口 ImageInputStream 中的 flushBefore
参数：
pos - 一个 long，它包含要刷新的流前缀的长度。
抛出：
IOException - 如果发生 I/O 错误。

flush

public void flush()
           throws IOException
从接口 ImageInputStream 复制的描述
丢弃当前流位置之前的流初始部分。等效于 flushBefore(getStreamPosition())。

指定者：
接口 ImageInputStream 中的 flush
抛出：
IOException - 如果发生 I/O 错误。

getFlushedPosition

public long getFlushedPosition()
从接口 ImageInputStream 复制的描述
返回流中可以执行查找的最早位置。返回值将是所有传入 flushBefore 上一次调用的值中的最大值。

指定者：
接口 ImageInputStream 中的 getFlushedPosition
返回：
用于查找的最早的合法位置（long 形式）。

isCached

public boolean isCached()
默认实现返回 false。如果子类缓存数据，则其应该重写此方法。

指定者：
接口 ImageInputStream 中的 isCached
返回：
如果此 ImageInputStream 缓存数据，则返回 true。
另请参见：
ImageInputStream.isCachedMemory(), ImageInputStream.isCachedFile()

isCachedMemory

public boolean isCachedMemory()
默认实现返回 false。如果子类在主存中缓存数据，则其应该重写此方法。

指定者：
接口 ImageInputStream 中的 isCachedMemory
返回：
如果此 ImageInputStream 在主存中缓存数据，则返回 true。
另请参见：
ImageInputStream.isCached(), ImageInputStream.isCachedFile()

isCachedFile

public boolean isCachedFile()
默认实现返回 false。如果子类在临时文件中缓存数据，则其应该重写此方法。

指定者：
接口 ImageInputStream 中的 isCachedFile
返回：
如果此 ImageInputStream 在临时文件中缓存数据，则返回 true。
另请参见：
ImageInputStream.isCached(), ImageInputStream.isCachedMemory()

close

public void close()
           throws IOException
从接口 ImageInputStream 复制的描述
关闭流。试图访问已经关闭的流将导致 IOException 或错误行为。调用此方法可允许实现此接口的类释放与流关联的资源，如内存、磁盘空间或文件描述符。

指定者：
接口 ImageInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。

finalize

protected void finalize()
                 throws Throwable
在垃圾回收前结束此对象。调用 close 方法来关闭所有开启的输入源。不应该从应用程序代码调用此方法。

覆盖：
类 Object 中的 finalize
抛出：
Throwable - 如果在超类终止过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
接口 ImageOutputStream

所有超级接口：
DataInput, DataOutput, ImageInputStream
所有已知实现类：
FileCacheImageOutputStream, FileImageOutputStream, ImageOutputStreamImpl, MemoryCacheImageOutputStream
public interface ImageOutputStream
extends ImageInputStream, DataOutput

供 ImageWriter 使用的可查找输出流接口。各种输出目标（如 OutputStream、File 以及将来的快速 I/O 目标）都可以通过此接口的恰当实现进行“包装”，供 Image I/O API 使用。

与标准 OutputStream 不同的是，ImageOutputStream 扩展其对应方 ImageInputStream。因此它能够在对流进行写入的同时从该流进行读取。尽管处理字节定位写入操作之前非零位偏移量的语义一定不同于处理字节定位读取操作之前非零位偏移量的语义，但读取操作和写入操作使用相同的查找和刷新位置。读取字节时，任何位偏移量在读取前都被设置为 0；写入字节时，如果位偏移量不为零，则字节中的剩余位将被写入 0。然后，字节定位写入开始于下一个字节位置。

另请参见：
ImageInputStream

方法摘要
void | flushBefore(long pos) 刷新给定位置之前所有数据的缓冲并转到底层目标（如 OutputStream 或 File）。
void | write(byte[] b) 将字节序列写入到流中的当前位置。
void | write(byte[] b, int off, int len) 将字节序列写入到流中的当前位置。
void | write(int b) 将单个字节写入到流中的当前位置。
void | writeBit(int bit) 将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。
void | writeBits(long bits, int numBits) 将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。
void | writeBoolean(boolean v) 将一个 boolean 值写入到流中。
void | writeByte(int v) 将 v 的 8 个低位写入到流中。
void | writeBytes(String s) 将一个字符串写入输出流。
void | writeChar(int v) 此方法与 writeShort 同义。
void | writeChars(char[] c, int off, int len) 将 char 序列写入到流中的当前位置。
void | writeChars(String s) 将一个字符串写入输出流。
void | writeDouble(double v) 将一个 double 值写入输出流，该值由四个字节组成。
void | writeDoubles(double[] d, int off, int len) 将 double 序列写入到流中的当前位置。
void | writeFloat(float v) 将一个 float 值（由四个字节组成）写入输出流。
void | writeFloats(float[] f, int off, int len) 将 float 序列写入到流中的当前位置。
void | writeInt(int v) 将 v 的 32 个位写入到流中。
void | writeInts(int[] i, int off, int len) 将 int 序列写入到流中的当前位置。
void | writeLong(long v) 将 v 的 64 个位写入到流中。
void | writeLongs(long[] l, int off, int len) 将 long 序列写入到流中的当前位置。
void | writeShort(int v) 将 v 的 16 个低位写入到流中。
void | writeShorts(short[] s, int off, int len) 将 short 序列写入到流中的当前位置。
void | writeUTF(String s) 将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
从接口 javax.imageio.stream.ImageInputStream 继承的方法
close, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, length, mark, read, read, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

方法详细信息

write

void write(int b)
           throws IOException
将单个字节写入到流中的当前位置。b 的 24 个高位将被忽略。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
参数：
b - 一个 int，其低 8 位将被写入。
抛出：
IOException - 如果发生 I/O 错误。

write

void write(byte[] b)
           throws IOException
将字节序列写入到流中的当前位置。如果 b.length 为 0，则不写入任何字节。首先写入字节 b[0]，然后写入字节 b[1]，依此类推。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 write
参数：
b - 要写入的 byte 数组。
抛出：
NullPointerException - 如果 b 为 null。
IOException - 如果发生 I/O 错误。

write

void write(byte[] b,
           int off,
           int len)
           throws IOException
将字节序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入字节 b[off]，然后写入字节 b[off + 1]，依此类推。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
参数：
b - 要写入的 byte 数组。
off - 数据中的初始偏移量。
len - 要写入的 byte 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 b.length。
NullPointerException - 如果 b 为 null。
IOException - 如果发生 I/O 错误。

writeBoolean

void writeBoolean(boolean v)
                  throws IOException
将一个 boolean 值写入到流中。如果 v 为 true，则写入值 (byte)1；如果 v 为 false，则写入值 (byte)0。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeBoolean
参数：
v - 要写入的 boolean 值。
抛出：
IOException - 如果发生 I/O 错误。

writeByte

void writeByte(int v)
               throws IOException
将 v 的 8 个低位写入到流中。忽略 v 的 24 个高位。（这意味着 writeByte 的作用与使用整数做参数的 write 完全相同。）

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeByte
参数：
v - 一个 int，包含要写入的 byte 值。
抛出：
IOException - 如果发生 I/O 错误。

writeShort

void writeShort(int v)
                throws IOException
将 v 的 16 个低位写入到流中。忽略 v 的 16 个高位。如果流使用网络字节顺序，则写入的字节将依次为：
(byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
否则，写入的字节将为：
 (byte)(v & 0xff)
(byte)((v >> 8) & 0xff)

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeShort
参数：
v - 一个 int，包含要写入的 short 值。
抛出：
IOException - 如果发生 I/O 错误。

writeChar

void writeChar(int v)
               throws IOException
此方法与 writeShort 同义。

指定者：
接口 DataOutput 中的 writeChar
参数：
v - 一个 int，它包含要写入的 char（无符号 short）值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
writeShort(int)

writeInt

void writeInt(int v)
              throws IOException
将 v 的 32 个位写入到流中。如果流使用网络字节顺序，则写入的字节将依次为：
(byte)((v >> 24) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
否则，写入的字节将为：
 (byte)(v & 0xff)
(byte)((v >> 8) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 24) & 0xff)

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeInt
参数：
v - 一个 int，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeLong

void writeLong(long v)
               throws IOException
将 v 的 64 个位写入到流中。如果流使用网络字节顺序，则写入的字节将依次为：
(byte)((v >> 56) & 0xff)
(byte)((v >> 48) & 0xff)
(byte)((v >> 40) & 0xff)
(byte)((v >> 32) & 0xff)
(byte)((v >> 24) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
否则，写入的字节将为：
 (byte)(v & 0xff)
(byte)((v >> 8) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 24) & 0xff)
(byte)((v >> 32) & 0xff)
(byte)((v >> 40) & 0xff)
(byte)((v >> 48) & 0xff)
(byte)((v >> 56) & 0xff)

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeLong
参数：
v - 一个 long，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeFloat

void writeFloat(float v)
                throws IOException
将一个 float 值（由四个字节组成）写入输出流。实现方式是：首先使用与 Float.floatToIntBits 方法完全相同的方式将此 float 值转换为一个 int 值，然后使用与 writeInt 方法完全相同的方式写入该 int 值。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeFloat
参数：
v - 一个 float，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeDouble

void writeDouble(double v)
                 throws IOException
将一个 double 值写入输出流，该值由四个字节组成。实现这一点的方式是：首先使用与 Double.doubleToLongBits 方法相同的方式将此 double 值转换为一个 long 值，然后使用与 writeLong 方法完全相同的方式写入该 long 值。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeDouble
参数：
v - 一个 double，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeBytes

void writeBytes(String s)
                throws IOException
将一个字符串写入输出流。字符串 s 中的每一个字符被依次写入输出流，每个字符用一个字节表示。如果 s 为 null，则抛出 NullPointerException。

如果 s.length 为零，则不写入任何字节。否则，首先写入字符 s[0]，然后写入字符 s[1]，依此类推；最后一个写入字符是 s[s.length-1]。对于每个字符，将使用与 writeByte 方法完全相同的方式把字符的低位写入一个低位字节。字符串中每个字符的八个高位将被忽略。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeBytes
参数：
s - 一个 String，它包含要写入的值。
抛出：
NullPointerException - 如果 s 为 null。
IOException - 如果发生 I/O 错误。

writeChars

void writeChars(String s)
                throws IOException
将一个字符串写入输出流。字符串 s 中的每个字符将根据当前字节顺序设置依次写入输出流，每个字符用两个字节表示。如果使用网络字节顺序，则首先写入高位字节；否则相反。如果 s 为 null，则抛出 NullPointerException。

如果 s.length 为零，则不写入字节。否则，首先写入字符 s[0]，然后写入字符 s[1]，依此类推；最后一个写入字符是 s[s.length-1]。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeChars
参数：
s - 一个 String，它包含要写入的值。
抛出：
NullPointerException - 如果 s 为 null。
IOException - 如果发生 I/O 错误。

writeUTF

void writeUTF(String s)
              throws IOException
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。如果 s 为 null，则抛出 NullPointerException。根据字符的值，将字符串 s 中每个字符转换成一个字节、两个字节或三个字节的字节组。

如果字符 c 在 \u0001 到 \u007f 的范围内，则用一个字节表示：

(byte)(b)

如果字符 c 是 \u0000 或者它在 \u0080 到 \u07ff 的范围内，则用两个字节表示，写入顺序如下：

 (byte)(0xc0 | (0x1f & (c >> 6)))
 (byte)(0x80 | (0x3f & c))

如果字符 c 在 \u0800 到 \uffff 的范围内，则用三个字节表示，写入顺序如下：

 (byte)(0xe0 | (0x0f & (c >> 12)))
 (byte)(0x80 | (0x3f & (c >> 6)))
 (byte)(0x80 | (0x3f & c))

首先，要计算表示 s 中所有字符所需的字节总数。如果总数大于 65535，则抛出 UTFDataFormatException。否则，使用与 writeShort 方法完全相同的方式将此长度写入输出流，然后写入字符串 s 中所有字符的 1 字节、2 字节或 3 字节表示形式。

忽略当前字节顺序设置。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

注：使用标准 UTF-8 图像格式的实现不应该使用此方法，因为此处使用的 UTF-8 修改版与标准 UTF-8 不兼容。

指定者：
接口 DataOutput 中的 writeUTF
参数：
s - 一个 String，它包含要写入的值。
抛出：
NullPointerException - 如果 s 为 null。
UTFDataFormatException - 如果 s 的 UTF-8 修改版表示形式要求的字节数大于 65536。
IOException - 如果发生 I/O 错误。

writeShorts

void writeShorts(short[] s,
                 int off,
                 int len)
                 throws IOException
将 short 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 short s[off]，然后写入 short s[off + 1]，依此类推。流的字节顺序用来确定写入各个字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

参数：
s - 要写入的 short 数组。
off - 数据中的初始偏移量。
len - 要写入的 short 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 s.length。
NullPointerException - 如果 s 为 null。
IOException - 如果发生 I/O 错误。

writeChars

void writeChars(char[] c,
                int off,
                int len)
                throws IOException
将 char 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 char c[off]，然后写入 char c[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

参数：
c - 要写入的 char 数组。
off - 数据中的初始偏移量。
len - 要写入的 char 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 c.length。
NullPointerException - 如果 c 为 null。
IOException - 如果发生 I/O 错误。

writeInts

void writeInts(int[] i,
               int off,
               int len)
               throws IOException
将 int 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 int i[off]，然后写入 int i[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

参数：
i - 要写入的 int 数组。
off - 数据中的初始偏移量。
len - 要写入的 int 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 i.length。
NullPointerException - 如果 i 为 null。
IOException - 如果发生 I/O 错误。

writeLongs

void writeLongs(long[] l,
                int off,
                int len)
                throws IOException
将 long 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 long l[off]，然后写入 long l[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

参数：
l - 要写入的 long 数组。
off - 数据中的初始偏移量。
len - 要写入的 long 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 l.length。
NullPointerException - 如果 l 为 null。
IOException - 如果发生 I/O 错误。

writeFloats

void writeFloats(float[] f,
                 int off,
                 int len)
                 throws IOException
将 float 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 float f[off]，然后写入 float f[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

参数：
f - 要写入的 float 数组。
off - 数据中的初始偏移量。
len - 要写入的 float 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 f.length。
NullPointerException - 如果 f 为 null。
IOException - 如果发生 I/O 错误。

writeDoubles

void writeDoubles(double[] d,
                  int off,
                  int len)
                  throws IOException
将 double 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 double d[off]，然后写入 double d[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

参数：
d - 要写入的 double 数组。
off - 数据中的初始偏移量。
len - 要写入的 double 数。
抛出：
IndexOutOfBoundsException - 如果 off 为负、len 为负或者 off + len 大于 d.length。
NullPointerException - 如果 d 为 null。
IOException - 如果发生 I/O 错误。

writeBit

void writeBit(int bit)
              throws IOException
将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。忽略参数的高 31 位。给定位将替代之前位于该位置的位。将位偏移量加 1 并将其模数减 8。

如果在刷新某个字节的缓冲并转送到目标时一直没有设置过该字节的某些位，则这些位将被自动设置为 0。

参数：
bit - 一个 int，其最低有效位将被写入到流中。
抛出：
IOException - 如果发生 I/O 错误。

writeBits

void writeBits(long bits,
               int numBits)
               throws IOException
将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。忽略参数的高 64 - numBits 位。位偏移量将加 numBits 并减少模数 8。注意，位偏移量 0 总是指示字节的最高有效位，位字节按照遇到它们的顺序依次被写入。因此以网络字节顺序进行位的写入总是有效的。忽略实际流字节顺序设置。

在调用 flushBefore 之前，位数据可以在内存中无限累积。调用时将写入刷新位置之前的所有位数据。

如果在刷新字节缓冲并转到目标时特定字节的某些位一直没有被设置，则这些位将自动设置为 0。

参数：
bits - 一个 long，它包含要写入的位（从 numBits - 1 开始下至最低有效位）。
numBits - 一个 0 到 64 之间（包括两者）的 int。
抛出：
IllegalArgumentException - 如果 numBits 不在 0 到 64 之间（包括两者）。
IOException - 如果发生 I/O 错误。

flushBefore

void flushBefore(long pos)
                 throws IOException
刷新给定位置之前所有数据的缓冲并转到底层目标（如 OutputStream 或 File）。试图查找流的刷新部分将导致抛出 IndexOutOfBoundsException。

指定者：
接口 ImageInputStream 中的 flushBefore
参数：
pos - 一个 long，它包含可能被刷新并转到目标的流前缀的长度。
抛出：
IndexOutOfBoundsException - 如果 pos 位于流缓冲的刷新部分或当前流位置之后。
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageOutputStreamImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 ImageOutputStreamImpl

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
        继承者  javax.imageio.stream.ImageOutputStreamImpl
所有已实现的接口：
DataInput, DataOutput, ImageInputStream, ImageOutputStream
直接已知子类：
FileCacheImageOutputStream, FileImageOutputStream, MemoryCacheImageOutputStream
public abstract class ImageOutputStreamImpl
extends ImageInputStreamImpl
implements ImageOutputStream

实现 ImageOutputStream 接口的抽象类。此类设计用于减少必须由子类实现的方法数。

字段摘要
从类 javax.imageio.stream.ImageInputStreamImpl 继承的字段
bitOffset, byteOrder, flushedPos, streamPos
构造方法摘要
ImageOutputStreamImpl()
构造一个 ImageOutputStreamImpl。
方法摘要
protected void | flushBits() 如果位偏移量为非零，则将当前字节中的剩余位强制归 0，并将流位置前移一个字节。
void | write(byte[] b) 将字节序列写入到流中的当前位置。
abstract void | write(byte[] b, int off, int len) 将字节序列写入到流中的当前位置。
abstract void | write(int b) 将单个字节写入到流中的当前位置。
void | writeBit(int bit) 将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。
void | writeBits(long bits, int numBits) 将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。
void | writeBoolean(boolean v) 将一个 boolean 值写入到流中。
void | writeByte(int v) 将 v 的 8 个低位写入到流中。
void | writeBytes(String s) 将一个字符串写入输出流。
void | writeChar(int v) 此方法与 writeShort 同义。
void | writeChars(char[] c, int off, int len) 将 char 序列写入到流中的当前位置。
void | writeChars(String s) 将一个字符串写入输出流。
void | writeDouble(double v) 将一个 double 值写入输出流，该值由四个字节组成。
void | writeDoubles(double[] d, int off, int len) 将 double 序列写入到流中的当前位置。
void | writeFloat(float v) 将一个 float 值（由四个字节组成）写入输出流。
void | writeFloats(float[] f, int off, int len) 将 float 序列写入到流中的当前位置。
void | writeInt(int v) 将 v 的 32 个位写入到流中。
void | writeInts(int[] i, int off, int len) 将 int 序列写入到流中的当前位置。
void | writeLong(long v) 将 v 的 64 个位写入到流中。
void | writeLongs(long[] l, int off, int len) 将 long 序列写入到流中的当前位置。
void | writeShort(int v) 将 v 的 16 个低位写入到流中。
void | writeShorts(short[] s, int off, int len) 将 short 序列写入到流中的当前位置。
void | writeUTF(String s) 将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。
从类 javax.imageio.stream.ImageInputStreamImpl 继承的方法
checkClosed, close, finalize, flush, flushBefore, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, length, mark, read, read, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.imageio.stream.ImageOutputStream 继承的方法
flushBefore
从接口 javax.imageio.stream.ImageInputStream 继承的方法
close, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, isCached, isCachedFile, isCachedMemory, length, mark, read, read, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

构造方法详细信息

ImageOutputStreamImpl

public ImageOutputStreamImpl()
构造一个 ImageOutputStreamImpl。

方法详细信息

write

public abstract void write(int b)
                    throws IOException
从接口 ImageOutputStream 复制的描述
将单个字节写入到流中的当前位置。b 的 24 个高位将被忽略。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
参数：
b - 一个 int，其低 8 位将被写入。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b)
           throws IOException
从接口 ImageOutputStream 复制的描述
将字节序列写入到流中的当前位置。如果 b.length 为 0，则不写入任何字节。首先写入字节 b[0]，然后写入字节 b[1]，依此类推。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
参数：
b - 要写入的 byte 数组。
抛出：
IOException - 如果发生 I/O 错误。

write

public abstract void write(byte[] b,
                           int off,
                           int len)
                    throws IOException
从接口 ImageOutputStream 复制的描述
将字节序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入字节 b[off]，然后写入字节 b[off + 1]，依此类推。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
参数：
b - 要写入的 byte 数组。
off - 数据中的初始偏移量。
len - 要写入的 byte 数。
抛出：
IOException - 如果发生 I/O 错误。

writeBoolean

public void writeBoolean(boolean v)
                  throws IOException
从接口 ImageOutputStream 复制的描述
将一个 boolean 值写入到流中。如果 v 为 true，则写入值 (byte)1；如果 v 为 false，则写入值 (byte)0。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeBoolean
指定者：
接口 ImageOutputStream 中的 writeBoolean
参数：
v - 要写入的 boolean 值。
抛出：
IOException - 如果发生 I/O 错误。

writeByte

public void writeByte(int v)
               throws IOException
从接口 ImageOutputStream 复制的描述
将 v 的 8 个低位写入到流中。忽略 v 的 24 个高位。（这意味着 writeByte 的作用与使用整数做参数的 write 完全相同。）

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeByte
指定者：
接口 ImageOutputStream 中的 writeByte
参数：
v - 一个 int，包含要写入的 byte 值。
抛出：
IOException - 如果发生 I/O 错误。

writeShort

public void writeShort(int v)
                throws IOException
从接口 ImageOutputStream 复制的描述
将 v 的 16 个低位写入到流中。忽略 v 的 16 个高位。如果流使用网络字节顺序，则写入的字节将依次为：
(byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
否则，写入的字节将为：
 (byte)(v & 0xff)
(byte)((v >> 8) & 0xff)

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeShort
指定者：
接口 ImageOutputStream 中的 writeShort
参数：
v - 一个 int，包含要写入的 short 值。
抛出：
IOException - 如果发生 I/O 错误。

writeChar

public void writeChar(int v)
               throws IOException
从接口 ImageOutputStream 复制的描述
此方法与 writeShort 同义。

指定者：
接口 DataOutput 中的 writeChar
指定者：
接口 ImageOutputStream 中的 writeChar
参数：
v - 一个 int，它包含要写入的 char（无符号 short）值。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
ImageOutputStream.writeShort(int)

writeInt

public void writeInt(int v)
              throws IOException
从接口 ImageOutputStream 复制的描述
将 v 的 32 个位写入到流中。如果流使用网络字节顺序，则写入的字节将依次为：
(byte)((v >> 24) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
否则，写入的字节将为：
 (byte)(v & 0xff)
(byte)((v >> 8) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 24) & 0xff)

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeInt
指定者：
接口 ImageOutputStream 中的 writeInt
参数：
v - 一个 int，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeLong

public void writeLong(long v)
               throws IOException
从接口 ImageOutputStream 复制的描述
将 v 的 64 个位写入到流中。如果流使用网络字节顺序，则写入的字节将依次为：
(byte)((v >> 56) & 0xff)
(byte)((v >> 48) & 0xff)
(byte)((v >> 40) & 0xff)
(byte)((v >> 32) & 0xff)
(byte)((v >> 24) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 8) & 0xff)
 (byte)(v & 0xff)
否则，写入的字节将为：
 (byte)(v & 0xff)
(byte)((v >> 8) & 0xff)
(byte)((v >> 16) & 0xff)
(byte)((v >> 24) & 0xff)
(byte)((v >> 32) & 0xff)
(byte)((v >> 40) & 0xff)
(byte)((v >> 48) & 0xff)
(byte)((v >> 56) & 0xff)

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeLong
指定者：
接口 ImageOutputStream 中的 writeLong
参数：
v - 一个 long，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeFloat

public void writeFloat(float v)
                throws IOException
从接口 ImageOutputStream 复制的描述
将一个 float 值（由四个字节组成）写入输出流。实现方式是：首先使用与 Float.floatToIntBits 方法完全相同的方式将此 float 值转换为一个 int 值，然后使用与 writeInt 方法完全相同的方式写入该 int 值。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeFloat
指定者：
接口 ImageOutputStream 中的 writeFloat
参数：
v - 一个 float，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeDouble

public void writeDouble(double v)
                 throws IOException
从接口 ImageOutputStream 复制的描述
将一个 double 值写入输出流，该值由四个字节组成。实现这一点的方式是：首先使用与 Double.doubleToLongBits 方法相同的方式将此 double 值转换为一个 long 值，然后使用与 writeLong 方法完全相同的方式写入该 long 值。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeDouble
指定者：
接口 ImageOutputStream 中的 writeDouble
参数：
v - 一个 double，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeBytes

public void writeBytes(String s)
                throws IOException
从接口 ImageOutputStream 复制的描述
将一个字符串写入输出流。字符串 s 中的每一个字符被依次写入输出流，每个字符用一个字节表示。如果 s 为 null，则抛出 NullPointerException。

如果 s.length 为零，则不写入任何字节。否则，首先写入字符 s[0]，然后写入字符 s[1]，依此类推；最后一个写入字符是 s[s.length-1]。对于每个字符，将使用与 writeByte 方法完全相同的方式把字符的低位写入一个低位字节。字符串中每个字符的八个高位将被忽略。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeBytes
指定者：
接口 ImageOutputStream 中的 writeBytes
参数：
s - 一个 String，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeChars

public void writeChars(String s)
                throws IOException
从接口 ImageOutputStream 复制的描述
将一个字符串写入输出流。字符串 s 中的每个字符将根据当前字节顺序设置依次写入输出流，每个字符用两个字节表示。如果使用网络字节顺序，则首先写入高位字节；否则相反。如果 s 为 null，则抛出 NullPointerException。

如果 s.length 为零，则不写入字节。否则，首先写入字符 s[0]，然后写入字符 s[1]，依此类推；最后一个写入字符是 s[s.length-1]。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 DataOutput 中的 writeChars
指定者：
接口 ImageOutputStream 中的 writeChars
参数：
s - 一个 String，它包含要写入的值。
抛出：
IOException - 如果发生 I/O 错误。

writeUTF

public void writeUTF(String s)
              throws IOException
从接口 ImageOutputStream 复制的描述
将表示长度信息的两个字节按网络字节顺序写入输出流，后跟字符串 s 中每个字符的 UTF-8 修改版表示形式。如果 s 为 null，则抛出 NullPointerException。根据字符的值，将字符串 s 中每个字符转换成一个字节、两个字节或三个字节的字节组。

如果字符 c 在 \u0001 到 \u007f 的范围内，则用一个字节表示：

(byte)(b)

如果字符 c 是 \u0000 或者它在 \u0080 到 \u07ff 的范围内，则用两个字节表示，写入顺序如下：

 (byte)(0xc0 | (0x1f & (c >> 6)))
 (byte)(0x80 | (0x3f & c))

如果字符 c 在 \u0800 到 \uffff 的范围内，则用三个字节表示，写入顺序如下：

 (byte)(0xe0 | (0x0f & (c >> 12)))
 (byte)(0x80 | (0x3f & (c >> 6)))
 (byte)(0x80 | (0x3f & c))

首先，要计算表示 s 中所有字符所需的字节总数。如果总数大于 65535，则抛出 UTFDataFormatException。否则，使用与 writeShort 方法完全相同的方式将此长度写入输出流，然后写入字符串 s 中所有字符的 1 字节、2 字节或 3 字节表示形式。

忽略当前字节顺序设置。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

注：使用标准 UTF-8 图像格式的实现不应该使用此方法，因为此处使用的 UTF-8 修改版与标准 UTF-8 不兼容。

指定者：
接口 DataOutput 中的 writeUTF
指定者：
接口 ImageOutputStream 中的 writeUTF
参数：
s - 一个 String，它包含要写入的值。
抛出：
UTFDataFormatException - 如果 s 的 UTF-8 修改版表示形式要求的字节数大于 65536。
IOException - 如果发生 I/O 错误。

writeShorts

public void writeShorts(short[] s,
                        int off,
                        int len)
                 throws IOException
从接口 ImageOutputStream 复制的描述
将 short 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 short s[off]，然后写入 short s[off + 1]，依此类推。流的字节顺序用来确定写入各个字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 ImageOutputStream 中的 writeShorts
参数：
s - 要写入的 short 数组。
off - 数据中的初始偏移量。
len - 要写入的 short 数。
抛出：
IOException - 如果发生 I/O 错误。

writeChars

public void writeChars(char[] c,
                       int off,
                       int len)
                throws IOException
从接口 ImageOutputStream 复制的描述
将 char 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 char c[off]，然后写入 char c[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 ImageOutputStream 中的 writeChars
参数：
c - 要写入的 char 数组。
off - 数据中的初始偏移量。
len - 要写入的 char 数。
抛出：
IOException - 如果发生 I/O 错误。

writeInts

public void writeInts(int[] i,
                      int off,
                      int len)
               throws IOException
从接口 ImageOutputStream 复制的描述
将 int 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 int i[off]，然后写入 int i[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 ImageOutputStream 中的 writeInts
参数：
i - 要写入的 int 数组。
off - 数据中的初始偏移量。
len - 要写入的 int 数。
抛出：
IOException - 如果发生 I/O 错误。

writeLongs

public void writeLongs(long[] l,
                       int off,
                       int len)
                throws IOException
从接口 ImageOutputStream 复制的描述
将 long 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 long l[off]，然后写入 long l[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 ImageOutputStream 中的 writeLongs
参数：
l - 要写入的 long 数组。
off - 数据中的初始偏移量。
len - 要写入的 long 数。
抛出：
IOException - 如果发生 I/O 错误。

writeFloats

public void writeFloats(float[] f,
                        int off,
                        int len)
                 throws IOException
从接口 ImageOutputStream 复制的描述
将 float 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 float f[off]，然后写入 float f[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 ImageOutputStream 中的 writeFloats
参数：
f - 要写入的 float 数组。
off - 数据中的初始偏移量。
len - 要写入的 float 数。
抛出：
IOException - 如果发生 I/O 错误。

writeDoubles

public void writeDoubles(double[] d,
                         int off,
                         int len)
                  throws IOException
从接口 ImageOutputStream 复制的描述
将 double 序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入 double d[off]，然后写入 double d[off + 1]，依此类推。流的字节顺序用来确定写入个别字节的顺序。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。

指定者：
接口 ImageOutputStream 中的 writeDoubles
参数：
d - 要写入的 double 数组。
off - 数据中的初始偏移量。
len - 要写入的 double 数。
抛出：
IOException - 如果发生 I/O 错误。

writeBit

public void writeBit(int bit)
              throws IOException
从接口 ImageOutputStream 复制的描述
将单个位（由参数的最低有效位给定）写入到流的当前字节位置中的当前位偏移量。忽略参数的高 31 位。给定位将替代之前位于该位置的位。将位偏移量加 1 并将其模数减 8。

如果在刷新某个字节的缓冲并转送到目标时一直没有设置过该字节的某些位，则这些位将被自动设置为 0。

指定者：
接口 ImageOutputStream 中的 writeBit
参数：
bit - 一个 int，其最低有效位将被写入到流中。
抛出：
IOException - 如果发生 I/O 错误。

writeBits

public void writeBits(long bits,
                      int numBits)
               throws IOException
从接口 ImageOutputStream 复制的描述
将一个位序列（由 bits 参数的 numBits 个最低有效位按从左到右的顺序给定）写入到流的当前字节位置中的当前位偏移量。忽略参数的高 64 - numBits 位。位偏移量将加 numBits 并减少模数 8。注意，位偏移量 0 总是指示字节的最高有效位，位字节按照遇到它们的顺序依次被写入。因此以网络字节顺序进行位的写入总是有效的。忽略实际流字节顺序设置。

在调用 flushBefore 之前，位数据可以在内存中无限累积。调用时将写入刷新位置之前的所有位数据。

如果在刷新字节缓冲并转到目标时特定字节的某些位一直没有被设置，则这些位将自动设置为 0。

指定者：
接口 ImageOutputStream 中的 writeBits
参数：
bits - 一个 long，它包含要写入的位（从 numBits - 1 开始下至最低有效位）。
numBits - 一个 0 到 64 之间（包括两者）的 int。
抛出：
IOException - 如果发生 I/O 错误。

flushBits

protected final void flushBits()
                        throws IOException
如果位偏移量为非零，则将当前字节中的剩余位强制归 0，并将流位置前移一个字节。子类在开始执行 write(int) 和 write(byte[], int, int) 方法时应该调用此方法。

抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryCacheImageInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 MemoryCacheImageInputStream

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
        继承者  javax.imageio.stream.MemoryCacheImageInputStream
所有已实现的接口：
DataInput, ImageInputStream
public class MemoryCacheImageInputStream
extends ImageInputStreamImpl

从常规 InputStream 获取输入的 ImageInputStream 的实现。内存缓冲区用于缓存（至少）丢弃位置和当前读取位置之间的数据。

一般而言，从常规 InputStream 进行读取时最好使用 FileCacheImageInputStream。提供此类用于不可能创建可写入临时文件的情况。

字段摘要
从类 javax.imageio.stream.ImageInputStreamImpl 继承的字段
bitOffset, byteOrder, flushedPos, streamPos
构造方法摘要
MemoryCacheImageInputStream(InputStream stream)
构造一个将从给定 InputStream 进行读取的 MemoryCacheImageInputStream。
方法摘要
void | close() 关闭此 MemoryCacheImageInputStream，释放缓存。
protected void | finalize() 在垃圾回收前结束此对象。
void | flushBefore(long pos) 丢弃所指示位置之前的流初始部分。
boolean | isCached() 返回 true，因为此 ImageInputStream为了允许逆向查找而缓存了数据。
boolean | isCachedFile() 返回 false，因为此 ImageInputStream 不维护文件缓存。
boolean | isCachedMemory() 返回 true，因为此 ImageInputStream 维护主存缓存。
int | read() 从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
从类 javax.imageio.stream.ImageInputStreamImpl 继承的方法
checkClosed, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, length, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MemoryCacheImageInputStream

public MemoryCacheImageInputStream(InputStream stream)
构造一个将从给定 InputStream 进行读取的 MemoryCacheImageInputStream。

参数：
stream - 要从其进行读取的 InputStream。
抛出：
IllegalArgumentException - 如果 stream 为 null。
方法详细信息

read

public int read()
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。 如果到达 EOF，则返回 -1。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

在发生读取前，流中的位偏移量必须被重置为 0。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
返回：
流中下一个字节的值；如果到达 EOF，则返回 -1。
抛出：
IOException - 如果流已经被关闭。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。如果由于到达流末尾而没有读取任何字节，则返回 -1。

在发生读取前，流中的位偏移量必须被重置为 0。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
参数：
b - 用来接收写入的字节数组。
off - b 中要写入的起始位置。
len - 要读取的最大字节数。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
IOException - 如果发生 I/O 错误。

flushBefore

public void flushBefore(long pos)
                 throws IOException
从接口 ImageInputStream 复制的描述
丢弃所指示位置之前的流初始部分。试图查找流的刷新部分中的偏移量将导致抛出 IndexOutOfBoundsException。

调用 flushBefore 可允许实现此接口的类释放存储流中的数据所使用的资源，如内存和磁盘空间。

指定者：
接口 ImageInputStream 中的 flushBefore
覆盖：
类 ImageInputStreamImpl 中的 flushBefore
参数：
pos - 一个 long，它包含要刷新的流前缀的长度。
抛出：
IOException - 如果发生 I/O 错误。

isCached

public boolean isCached()
返回 true，因为此 ImageInputStream为了允许逆向查找而缓存了数据。

指定者：
接口 ImageInputStream 中的 isCached
覆盖：
类 ImageInputStreamImpl 中的 isCached
返回：
true。
另请参见：
isCachedMemory(), isCachedFile()

isCachedFile

public boolean isCachedFile()
返回 false，因为此 ImageInputStream 不维护文件缓存。

指定者：
接口 ImageInputStream 中的 isCachedFile
覆盖：
类 ImageInputStreamImpl 中的 isCachedFile
返回：
false。
另请参见：
isCached(), isCachedMemory()

isCachedMemory

public boolean isCachedMemory()
返回 true，因为此 ImageInputStream 维护主存缓存。

指定者：
接口 ImageInputStream 中的 isCachedMemory
覆盖：
类 ImageInputStreamImpl 中的 isCachedMemory
返回：
true。
另请参见：
isCached(), isCachedFile()

close

public void close()
           throws IOException
关闭此 MemoryCacheImageInputStream，释放缓存。但不关闭源 InputStream。

指定者：
接口 ImageInputStream 中的 close
覆盖：
类 ImageInputStreamImpl 中的 close
抛出：
IOException - 如果发生 I/O 错误。

finalize

protected void finalize()
                 throws Throwable
在垃圾回收前结束此对象。调用 close 方法来关闭所有开启的输入源。不应该从应用程序代码调用此方法。

覆盖：
类 ImageInputStreamImpl 中的 finalize
抛出：
Throwable - 如果在超类终止过程中发生错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MemoryCacheImageOutputStream (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.imageio.stream
类 MemoryCacheImageOutputStream

java.lang.Object
    继承者  javax.imageio.stream.ImageInputStreamImpl
        继承者  javax.imageio.stream.ImageOutputStreamImpl
            继承者  javax.imageio.stream.MemoryCacheImageOutputStream
所有已实现的接口：
DataInput, DataOutput, ImageInputStream, ImageOutputStream
public class MemoryCacheImageOutputStream
extends ImageOutputStreamImpl

将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。内存缓冲区用于缓存（至少）丢弃位置和当前写入位置之间的数据。唯一的构造方法带有一个 OutputStream，因此此类不能用于读取/修改/写入操作。读取操作只能发生在那些已经被写入到缓存且尚未被刷新的流部分。

字段摘要
从类 javax.imageio.stream.ImageInputStreamImpl 继承的字段
bitOffset, byteOrder, flushedPos, streamPos
构造方法摘要
MemoryCacheImageOutputStream(OutputStream stream)
构造将向给定 OutputStream 进行写入的 MemoryCacheImageOutputStream。
方法摘要
void | close() 关闭此 MemoryCacheImageOutputStream。
void | flushBefore(long pos) 丢弃所指示位置之前的流初始部分。
boolean | isCached() 返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。
boolean | isCachedFile() 返回 false，因为此 ImageOutputStream 不维护文件缓存。
boolean | isCachedMemory() 返回 true，因为此 ImageOutputStream 维护主存缓存。
long | length() 返回 -1L，指示流的长度未知。
int | read() 从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。
int | read(byte[] b, int off, int len) 从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。
void | write(byte[] b, int off, int len) 将字节序列写入到流中的当前位置。
void | write(int b) 将单个字节写入到流中的当前位置。
从类 javax.imageio.stream.ImageOutputStreamImpl 继承的方法
flushBits, write, writeBit, writeBits, writeBoolean, writeByte, writeBytes, writeChar, writeChars, writeChars, writeDouble, writeDoubles, writeFloat, writeFloats, writeInt, writeInts, writeLong, writeLongs, writeShort, writeShorts, writeUTF
从类 javax.imageio.stream.ImageInputStreamImpl 继承的方法
checkClosed, finalize, flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.imageio.stream.ImageInputStream 继承的方法
flush, getBitOffset, getByteOrder, getFlushedPosition, getStreamPosition, mark, read, readBit, readBits, readBoolean, readByte, readBytes, readChar, readDouble, readFloat, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readFully, readInt, readLine, readLong, readShort, readUnsignedByte, readUnsignedInt, readUnsignedShort, readUTF, reset, seek, setBitOffset, setByteOrder, skipBytes, skipBytes

构造方法详细信息

MemoryCacheImageOutputStream

public MemoryCacheImageOutputStream(OutputStream stream)
构造将向给定 OutputStream 进行写入的 MemoryCacheImageOutputStream。

参数：
stream - 将写入到的 OutputStream。
抛出：
IllegalArgumentException - 如果 stream 为 null。
方法详细信息

read

public int read()
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取单个字节，并以 int（0 到 255 之间）形式返回该字节。 如果到达 EOF，则返回 -1。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

在发生读取前，流中的位偏移量必须被重置为 0。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
返回：
流中下一个字节的值；如果到达 EOF，则返回 -1。
抛出：
IOException - 如果流已经被关闭。

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从类 ImageInputStreamImpl 复制的描述
从流中读取至多 len 个字节，并将其存储到 b 中（从 off 索引处开始）。如果由于到达流末尾而没有读取任何字节，则返回 -1。

在发生读取前，流中的位偏移量必须被重置为 0。

子类必须提供此方法的实现。子类实现在退出前应该更新流位置。

指定者：
接口 ImageInputStream 中的 read
指定者：
类 ImageInputStreamImpl 中的 read
参数：
b - 用来接收写入的字节数组。
off - b 中要写入的起始位置。
len - 要读取的最大字节数。
返回：
实际读取的字节数；或者 -1，指示 EOF。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(int b)
           throws IOException
从接口 ImageOutputStream 复制的描述
将单个字节写入到流中的当前位置。b 的 24 个高位将被忽略。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
指定者：
类 ImageOutputStreamImpl 中的 write
参数：
b - 一个 int，其低 8 位将被写入。
抛出：
IOException - 如果发生 I/O 错误。

write

public void write(byte[] b,
                  int off,
                  int len)
           throws IOException
从接口 ImageOutputStream 复制的描述
将字节序列写入到流中的当前位置。如果 len 为 0，则不写入任何字节。首先写入字节 b[off]，然后写入字节 b[off + 1]，依此类推。

如果流中的位偏移量不为零，则首先将当前字节的余项用 0 填充并将其写出。写出后位偏移量将为 0。实现方可使用 ImageOutputStreamImpl 的 flushBits 方法来保证这一点。

指定者：
接口 DataOutput 中的 write
指定者：
接口 ImageOutputStream 中的 write
指定者：
类 ImageOutputStreamImpl 中的 write
参数：
b - 要写入的 byte 数组。
off - 数据中的初始偏移量。
len - 要写入的 byte 数。
抛出：
IOException - 如果发生 I/O 错误。

length

public long length()
从类 ImageInputStreamImpl 复制的描述
返回 -1L，指示流的长度未知。子类必须重写此方法来提供实际的长度信息。

指定者：
接口 ImageInputStream 中的 length
覆盖：
类 ImageInputStreamImpl 中的 length
返回：
指示不知道长度的 -1L。

isCached

public boolean isCached()
返回 true，因为此 ImageOutputStream为了允许逆向查找而缓存了数据。

指定者：
接口 ImageInputStream 中的 isCached
覆盖：
类 ImageInputStreamImpl 中的 isCached
返回：
true。
另请参见：
isCachedMemory(), isCachedFile()

isCachedFile

public boolean isCachedFile()
返回 false，因为此 ImageOutputStream 不维护文件缓存。

指定者：
接口 ImageInputStream 中的 isCachedFile
覆盖：
类 ImageInputStreamImpl 中的 isCachedFile
返回：
false。
另请参见：
isCached(), isCachedMemory()

isCachedMemory

public boolean isCachedMemory()
返回 true，因为此 ImageOutputStream 维护主存缓存。

指定者：
接口 ImageInputStream 中的 isCachedMemory
覆盖：
类 ImageInputStreamImpl 中的 isCachedMemory
返回：
true。
另请参见：
isCached(), isCachedFile()

close

public void close()
           throws IOException
关闭此 MemoryCacheImageOutputStream。所有的挂起数据都将被刷新到输出，释放该缓存。但不关闭目标 OutputStream。

指定者：
接口 ImageInputStream 中的 close
覆盖：
类 ImageInputStreamImpl 中的 close
抛出：
IOException - 如果发生 I/O 错误。

flushBefore

public void flushBefore(long pos)
                 throws IOException
从接口 ImageInputStream 复制的描述
丢弃所指示位置之前的流初始部分。试图查找流的刷新部分中的偏移量将导致抛出 IndexOutOfBoundsException。

调用 flushBefore 可允许实现此接口的类释放存储流中的数据所使用的资源，如内存和磁盘空间。

指定者：
接口 ImageInputStream 中的 flushBefore
指定者：
接口 ImageOutputStream 中的 flushBefore
覆盖：
类 ImageInputStreamImpl 中的 flushBefore
参数：
pos - 一个 long，它包含要刷新的流前缀的长度。
抛出：
IOException - 如果发生 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.imageio.stream (Java 2 Platform SE 6)

 javax.imageio.stream
接口
ImageInputStream
ImageOutputStream
类
FileCacheImageInputStream
FileCacheImageOutputStream
FileImageInputStream
FileImageOutputStream
IIOByteBuffer
ImageInputStreamImpl
ImageOutputStreamImpl
MemoryCacheImageInputStream
MemoryCacheImageOutputStream


javax.imageio.stream (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.imageio.stream

Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

请参见：
描述

接口摘要
ImageInputStream | 供 ImageReader 使用的可查找输入流接口。
ImageOutputStream | 供 ImageWriter 使用的可查找输出流接口。

类摘要
FileCacheImageInputStream | 从常规 InputStream 获取其输入的 ImageInputStream 的实现。
FileCacheImageOutputStream | 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
FileImageInputStream | 从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
FileImageOutputStream | 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
IIOByteBuffer | 表示对某个字节数组及该数组中偏移量和长度的可变引用的类。
ImageInputStreamImpl | 实现 ImageInputStream 接口的抽象类。
ImageOutputStreamImpl | 实现 ImageOutputStream 接口的抽象类。
MemoryCacheImageInputStream | 从常规 InputStream 获取输入的 ImageInputStream 的实现。
MemoryCacheImageOutputStream | 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

软件包 javax.imageio.stream 的描述

Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

ImageInputStream 接口统一了流操作和基于文件的操作。提供抽象基类 ImageInputStreamImpl 来简化新 ImageInputStream 类的编写。提供的具体实现类（FileImageInputStream、FileCacheImageInputStream、和 MemoryCacheImageInputStream）允许使用（或不使用）临时缓存文件从 File 或 InputStream 进行输入。

ImageOutputStream 接口执行输出模拟功能。提供抽象基类 ImageOutputStreamImpl 以及一些具体实现类（FileImageOutputStream、FileCacheImageOutputStream 和 MemoryCacheImageOutputStream）来允许使用（或不使用）临时缓存文件向 File 或 OutputStream 进行输出。

IIOByteBuffer 类提供一种可选择的方式来执行字节序列的读取，从而减少了内部数据复制量。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.imageio.stream 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.stream 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.imageio.stream.IIOByteBuffer
    • javax.imageio.stream.ImageInputStreamImpl (implements javax.imageio.stream.ImageInputStream)
      • javax.imageio.stream.FileCacheImageInputStream
      • javax.imageio.stream.FileImageInputStream
      • javax.imageio.stream.ImageOutputStreamImpl (implements javax.imageio.stream.ImageOutputStream)
        • javax.imageio.stream.FileCacheImageOutputStream
        • javax.imageio.stream.FileImageOutputStream
        • javax.imageio.stream.MemoryCacheImageOutputStream
      • javax.imageio.stream.MemoryCacheImageInputStream

接口分层结构

  • java.io.DataInput
    • javax.imageio.stream.ImageInputStream
      • javax.imageio.stream.ImageOutputStream (并 extends java.io.DataOutput)
  • java.io.DataOutput
    • javax.imageio.stream.ImageOutputStream (并 extends javax.imageio.stream.ImageInputStream)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.imageio.stream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.imageio.stream
的使用

使用 javax.imageio.stream 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio 使用的 javax.imageio.stream 中的类
ImageInputStream
供 ImageReader 使用的可查找输入流接口。
ImageOutputStream
供 ImageWriter 使用的可查找输出流接口。

javax.imageio.spi 使用的 javax.imageio.stream 中的类
ImageInputStream
供 ImageReader 使用的可查找输入流接口。
ImageOutputStream
供 ImageWriter 使用的可查找输出流接口。

javax.imageio.stream 使用的 javax.imageio.stream 中的类
IIOByteBuffer
表示对某个字节数组及该数组中偏移量和长度的可变引用的类。
ImageInputStream
供 ImageReader 使用的可查找输入流接口。
ImageInputStreamImpl
实现 ImageInputStream 接口的抽象类。
ImageOutputStream
供 ImageWriter 使用的可查找输出流接口。
ImageOutputStreamImpl
实现 ImageOutputStream 接口的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.FileCacheImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileCacheImageInputStream
的使用

没有 javax.imageio.stream.FileCacheImageInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.FileCacheImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileCacheImageOutputStream
的使用

没有 javax.imageio.stream.FileCacheImageOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.FileImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileImageInputStream
的使用

没有 javax.imageio.stream.FileImageInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.FileImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.FileImageOutputStream
的使用

没有 javax.imageio.stream.FileImageOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.IIOByteBuffer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.IIOByteBuffer
的使用

使用 IIOByteBuffer 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 IIOByteBuffer 的使用

参数类型为 IIOByteBuffer 的 javax.imageio.stream 中的方法
void | ImageInputStream.readBytes(IIOByteBuffer buf, int len) 从流中读取至多 len 个字节，并修改提供的 IIOByteBuffer 以指示可以找到数据的 byte 数组、偏移量和长度。
void | ImageInputStreamImpl.readBytes(IIOByteBuffer buf, int len)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.stream.ImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.stream.ImageInputStream
的使用

使用 ImageInputStream 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio 中 ImageInputStream 的使用

返回 ImageInputStream 的 javax.imageio 中的方法
static ImageInputStream ImageIO.createImageInputStream(Object input)
返回一个 ImageInputStream，它将从给定 Object 中获取输入。

参数类型为 ImageInputStream 的 javax.imageio 中的方法
static BufferedImage ImageIO.read(ImageInputStream stream)
返回一个 BufferedImage，作为使用 ImageReader（它是从当前已注册 ImageReader 中自动选择的）解码所提供 ImageInputStream 的结果。

javax.imageio.spi 中 ImageInputStream 的使用

返回 ImageInputStream 的 javax.imageio.spi 中的方法
ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input) 返回与此服务提供者关联的 ImageInputStream 实现的实例。
abstract ImageInputStream | ImageInputStreamSpi.createInputStreamInstance(Object input, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageInputStream 实现的实例。

javax.imageio.stream 中 ImageInputStream 的使用

javax.imageio.stream 中 ImageInputStream 的子接口
 interface ImageOutputStream
供 ImageWriter 使用的可查找输出流接口。

实现 ImageInputStream 的 javax.imageio.stream 中的类
class | FileCacheImageInputStream 从常规 InputStream 获取其输入的 ImageInputStream 的实现。
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageInputStream 从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageInputStreamImpl 实现 ImageInputStream 接口的抽象类。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageInputStream 从常规 InputStream 获取输入的 ImageInputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.ImageInputStreamImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.ImageInputStreamImpl
的使用

使用 ImageInputStreamImpl 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 ImageInputStreamImpl 的使用

javax.imageio.stream 中 ImageInputStreamImpl 的子类
class | FileCacheImageInputStream 从常规 InputStream 获取其输入的 ImageInputStream 的实现。
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageInputStream 从 File 或 RandomAccessFile 中获取输入的 ImageInputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageInputStream 从常规 InputStream 获取输入的 ImageInputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.stream.ImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.stream.ImageOutputStream
的使用

使用 ImageOutputStream 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。
javax.imageio.stream | Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio 中 ImageOutputStream 的使用

返回 ImageOutputStream 的 javax.imageio 中的方法
static ImageOutputStream ImageIO.createImageOutputStream(Object output)
返回一个 ImageOutputStream，它将其输出发送到给定 Object。

参数类型为 ImageOutputStream 的 javax.imageio 中的方法
static boolean ImageIO.write(RenderedImage im, String formatName, ImageOutputStream output)
使用支持给定格式的任意 ImageWriter 将一个图像写入 ImageOutputStream。

javax.imageio.spi 中 ImageOutputStream 的使用

返回 ImageOutputStream 的 javax.imageio.spi 中的方法
ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。
abstract ImageOutputStream | ImageOutputStreamSpi.createOutputStreamInstance(Object output, boolean useCache, File cacheDir) 返回与此服务提供者关联的 ImageOutputStream 实现的实例。

javax.imageio.stream 中 ImageOutputStream 的使用

实现 ImageOutputStream 的 javax.imageio.stream 中的类
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | ImageOutputStreamImpl 实现 ImageOutputStream 接口的抽象类。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.ImageOutputStreamImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.ImageOutputStreamImpl
的使用

使用 ImageOutputStreamImpl 的软件包
javax.imageio.stream Java Image I/O API 的一个包，用来处理从文件和流中产生的低级别 I/O。

javax.imageio.stream 中 ImageOutputStreamImpl 的使用

javax.imageio.stream 中 ImageOutputStreamImpl 的子类
class | FileCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。
class | FileImageOutputStream 将输出直接写入 File 或 RandomAccessFile 的 ImageOutputStream 的实现。
class | MemoryCacheImageOutputStream 将输出写入常规 OutputStream 中的 ImageOutputStream 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.MemoryCacheImageInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.MemoryCacheImageInputStream
的使用

没有 javax.imageio.stream.MemoryCacheImageInputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.stream.MemoryCacheImageOutputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.stream.MemoryCacheImageOutputStream
的使用

没有 javax.imageio.stream.MemoryCacheImageOutputStream 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.IIOException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.IIOException
的使用

使用 IIOException 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。

javax.imageio 中 IIOException 的使用

抛出 IIOException 的 javax.imageio 中的方法
protected static BufferedImage ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
返回应该在其中写入解码的像素数据的 BufferedImage。

javax.imageio.metadata 中 IIOException 的使用

javax.imageio.metadata 中 IIOException 的子类
 class IIOInvalidTreeException
当 IIOMetadata 对象尝试解析 IIOMetadataNode 的树失败时，将抛出 IIOInvalidTreeException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.IIOImage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.IIOImage
的使用

使用 IIOImage 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOImage 的使用

返回 IIOImage 的 javax.imageio 中的方法
 IIOImage ImageReader.readAll(int imageIndex, ImageReadParam param)
使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。

返回变量类型为 IIOImage 的类型的 javax.imageio 中的方法
 Iterator<IIOImage> ImageReader.readAll(Iterator<? extends ImageReadParam> params)
以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

参数类型为 IIOImage 的 javax.imageio 中的方法
void | ImageWriter.write(IIOImage image) 将包含带有默认元数据和缩略图的单个图像的完整图像流添加到输出中。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
void | ImageWriter.writeInsert(int imageIndex, IIOImage image, ImageWriteParam param) 将新的图像插入现有图像流。
void | ImageWriter.writeToSequence(IIOImage image, ImageWriteParam param) 将单幅图像、可能相关的元数据和缩略图添加到输出中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.IIOParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.IIOParam
的使用

使用 IIOParam 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。

javax.imageio 中 IIOParam 的使用

javax.imageio 中 IIOParam 的子类
class | ImageReadParam 描述如何对流进行解码的类。
class | ImageWriteParam 描述如何对流进行编码的类。

参数类型为 IIOParam 的 javax.imageio 中的方法
 boolean IIOParamController.activate(IIOParam param)
激活控制器。

javax.imageio.plugins.bmp 中 IIOParam 的使用

javax.imageio.plugins.bmp 中 IIOParam 的子类
 class BMPImageWriteParam
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

javax.imageio.plugins.jpeg 中 IIOParam 的使用

javax.imageio.plugins.jpeg 中 IIOParam 的子类
class | JPEGImageReadParam 此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。
class | JPEGImageWriteParam 此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.IIOParamController 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.IIOParamController
的使用

使用 IIOParamController 的软件包
javax.imageio Java Image I/O API 的主要包。

javax.imageio 中 IIOParamController 的使用

声明为 IIOParamController 的 javax.imageio 中的字段
protected IIOParamController | IIOParam.controller 调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的 IIOParamController。
protected IIOParamController | IIOParam.defaultController 调用 activateController 方法时，将用来为此 IIOParam 对象提供设置值的默认 IIOParamController。

返回 IIOParamController 的 javax.imageio 中的方法
IIOParamController | IIOParam.getController() 返回当前已安装的所有 IIOParamController。
IIOParamController | IIOParam.getDefaultController() 返回默认 IIOParamController（如果有），不考虑当前安装的控制器。

参数类型为 IIOParamController 的 javax.imageio 中的方法
 void IIOParam.setController(IIOParamController controller)
设置在调用 activateController 方法时用来为 IIOParam 对象提供设置值的 IIOParamController，重写所有默认控制器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.ImageIO 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageIO
的使用

没有 javax.imageio.ImageIO 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.ImageReadParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageReadParam
的使用

使用 ImageReadParam 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。

javax.imageio 中 ImageReadParam 的使用

返回 ImageReadParam 的 javax.imageio 中的方法
 ImageReadParam ImageReader.getDefaultReadParam()
返回一个适合此格式的默认 ImageReadParam 对象。

参数类型为 ImageReadParam 的 javax.imageio 中的方法
protected static void | ImageReader.checkReadParamBandSettings(ImageReadParam param, int numSrcBands, int numDstBands) reader 可用来测试 ImageReadParam 的源和目标 band 设置的有效性的实用方法。
protected static void | ImageReader.computeRegions(ImageReadParam param, int srcWidth, int srcHeight, BufferedImage image, Rectangle srcRegion, Rectangle destRegion) 计算感兴趣的源区域和目标区域，将源图像的宽度和高度、可选目标图像和可选 ImageReadParam 都考虑在内。
protected static BufferedImage | ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height) 返回应该在其中写入解码的像素数据的 BufferedImage。
protected static Rectangle | ImageReader.getSourceRegion(ImageReadParam param, int srcWidth, int srcHeight) reader 可用来计算应该读取的源图像区域的一个实用方法，计算时考虑任何源区域，并在所提供的 ImageReadParam 中对偏移量设置进行二次取样。
abstract BufferedImage | ImageReader.read(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的对象，并将它作为一个完整的 BufferedImage 返回。
IIOImage | ImageReader.readAll(int imageIndex, ImageReadParam param) 使用所提供的 ImageReadParam 读取通过索引 imageIndex 指定的图像，并返回包含图像、缩略图和相关图像元数据的 IIOImage。
RenderedImage | ImageReader.readAsRenderedImage(int imageIndex, ImageReadParam param) 返回一个 RenderedImage 对象，该对象包含通过索引 imageIndex 指定的图像的内容。
Raster | ImageReader.readRaster(int imageIndex, ImageReadParam param) 返回包含图像流中原始像素数据的新 Raster 对象，不应用任何颜色转换。

类型变量类型为 ImageReadParam 的 javax.imageio 中的方法参数
 Iterator<IIOImage> ImageReader.readAll(Iterator<? extends ImageReadParam> params)
以 IIOImage 对象形式返回包含输入源中所有图像、缩略图和元数据的 Iterator，从 getMinIndex 给定的索引开始。

javax.imageio.plugins.jpeg 中 ImageReadParam 的使用

javax.imageio.plugins.jpeg 中 ImageReadParam 的子类
 class JPEGImageReadParam
此类添加了使用内置 JPEG reader 插件时设置 JPEG 量化表和 Huffman 表的能力。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.ImageReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageReader
的使用

使用 ImageReader 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageReader 的使用

返回 ImageReader 的 javax.imageio 中的方法
static ImageReader ImageIO.getImageReader(ImageWriter writer)
返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。

返回变量类型为 ImageReader 的类型的 javax.imageio 中的方法
static Iterator<ImageReader> | ImageIO.getImageReaders(Object input) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码所提供的 Object（通常是一个 ImageInputStream）。
static Iterator<ImageReader> | ImageIO.getImageReadersByFormatName(String formatName) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码指定格式。
static Iterator<ImageReader> | ImageIO.getImageReadersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定 MIME 类型的文件。
static Iterator<ImageReader> | ImageIO.getImageReadersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageReader 的 Iterator，这些 ImageReader 声称能够解码具有给定后缀的文件。

参数类型为 ImageReader 的 javax.imageio 中的方法
static Iterator<ImageTranscoder> | ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer) 返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。
static ImageWriter | ImageIO.getImageWriter(ImageReader reader) 返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。

javax.imageio.event 中 ImageReader 的使用

参数类型为 ImageReader 的 javax.imageio.event 中的方法
void | IIOReadProgressListener.imageComplete(ImageReader source) 报告当前图像读操作已经完成。
void | IIOReadProgressListener.imageProgress(ImageReader source, float percentageDone) 报告对关联 ImageReader 的 read 当前调用的近似完成程度。
void | IIOReadProgressListener.imageStarted(ImageReader source, int imageIndex) 报告图像读操作将要开始。
void | IIOReadUpdateListener.imageUpdate(ImageReader source, BufferedImage theImage, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新图像的给定区域。
void | IIOReadUpdateListener.passComplete(ImageReader source, BufferedImage theImage) 报告当前读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.passStarted(ImageReader source, BufferedImage theImage, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的读操作将开始逐步传递 (progressive pass)。
void | IIOReadProgressListener.readAborted(ImageReader source) 报告已通过 reader 的 abort 方法中止读操作。
void | IIOReadProgressListener.sequenceComplete(ImageReader source) 报告读操作序列已经完成。
void | IIOReadProgressListener.sequenceStarted(ImageReader source, int minIndex) 报告读操作序列将要开始。
void | IIOReadProgressListener.thumbnailComplete(ImageReader source) 报告缩略图读操作已经完成。
void | IIOReadUpdateListener.thumbnailPassComplete(ImageReader source, BufferedImage theThumbnail) 报告当前缩略图读操作已经完成一个逐步传递。
void | IIOReadUpdateListener.thumbnailPassStarted(ImageReader source, BufferedImage theThumbnail, int pass, int minPass, int maxPass, int minX, int minY, int periodX, int periodY, int[] bands) 报告当前的缩略图读操作将开始逐步传递。
void | IIOReadProgressListener.thumbnailProgress(ImageReader source, float percentageDone) 报告在关联的 ImageReader 中完成当前 getThumbnail 调用的近似程度。
void | IIOReadProgressListener.thumbnailStarted(ImageReader source, int imageIndex, int thumbnailIndex) 报告缩略图读操作将要开始。
void | IIOReadUpdateListener.thumbnailUpdate(ImageReader source, BufferedImage theThumbnail, int minX, int minY, int width, int height, int periodX, int periodY, int[] bands) 报告已更新缩略图图像的给定区域。
void | IIOReadWarningListener.warningOccurred(ImageReader source, String warning) 报告在解码中发生非严重错误。

javax.imageio.spi 中 ImageReader 的使用

返回 ImageReader 的 javax.imageio.spi 中的方法
ImageReader | ImageReaderSpi.createReaderInstance() 返回与此服务提供者关联的 ImageReader 实现的实例。
abstract ImageReader | ImageReaderSpi.createReaderInstance(Object extension) 返回与此服务提供者关联的 ImageReader 实现的实例。

参数类型为 ImageReader 的 javax.imageio.spi 中的方法
 boolean ImageReaderSpi.isOwnReader(ImageReader reader)
如果传入的 ImageReader 对象为与此服务提供者关联的 ImageReader 的实例，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.imageio.ImageTranscoder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.imageio.ImageTranscoder
的使用

使用 ImageTranscoder 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageTranscoder 的使用

实现 ImageTranscoder 的 javax.imageio 中的类
 class ImageWriter
用来编码和写入图像的抽象超类。

返回变量类型为 ImageTranscoder 的类型的 javax.imageio 中的方法
static Iterator<ImageTranscoder> ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer)
返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。

javax.imageio.spi 中 ImageTranscoder 的使用

返回 ImageTranscoder 的 javax.imageio.spi 中的方法
abstract  ImageTranscoder ImageTranscoderSpi.createTranscoderInstance()
返回与此服务提供者关联的 ImageTranscoder 实现的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.ImageWriteParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageWriteParam
的使用

使用 ImageWriteParam 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.plugins.bmp | 包含供内置 BMP 插件使用的公共类的包。
javax.imageio.plugins.jpeg | 支持内置 JPEG 插件的类。

javax.imageio 中 ImageWriteParam 的使用

返回 ImageWriteParam 的 javax.imageio 中的方法
 ImageWriteParam ImageWriter.getDefaultWriteParam()
返回适用于此文件格式的适当类型的新 ImageWriteParam 对象，该对象包含默认值，即那些将在没有指定 ImageWriteParam 对象时使用的值。

参数类型为 ImageWriteParam 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
IIOMetadata | ImageTranscoder.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertStreamMetadata(IIOMetadata inData, ImageWriteParam param)
abstract IIOMetadata | ImageWriter.getDefaultImageMetadata(ImageTypeSpecifier imageType, ImageWriteParam param) 返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
abstract IIOMetadata | ImageWriter.getDefaultStreamMetadata(ImageWriteParam param) 返回包含用来对图像流进行编码的默认值的 IIOMetadata 对象。
int | ImageWriter.getNumThumbnailsSupported(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | ImageWriter.replacePixels(Raster raster, ImageWriteParam param) 用给定 Raster 部分替换已出现在输出中的图像部分。
void | ImageWriter.replacePixels(RenderedImage image, ImageWriteParam param) 用给定图像部分替换已出现在输出中的图像部分。
abstract void | ImageWriter.write(IIOMetadata streamMetadata, IIOImage image, ImageWriteParam param) 添加一个完整的图像流，该图像流包含一幅图像、相关的流、图像元数据和要输出的缩略图。
void | ImageWriter.writeInsert(int imageIndex, IIOImage image, ImageWriteParam param) 将新的图像插入现有图像流。
void | ImageWriter.writeToSequence(IIOImage image, ImageWriteParam param) 将单幅图像、可能相关的元数据和缩略图添加到输出中。

javax.imageio.plugins.bmp 中 ImageWriteParam 的使用

javax.imageio.plugins.bmp 中 ImageWriteParam 的子类
 class BMPImageWriteParam
用于以 BMP 格式编码图像的 ImageWriteParam 的子类。

javax.imageio.plugins.jpeg 中 ImageWriteParam 的使用

javax.imageio.plugins.jpeg 中 ImageWriteParam 的子类
 class JPEGImageWriteParam
此类添加了使用内置 JPEG writer 插件时设置 JPEG 量化表和 Huffman 表以及请求为图像计算最佳 Huffman 表的能力。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.ImageWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageWriter
的使用

使用 ImageWriter 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.event | Java Image I/O API 的一个包，用于在读取和写入图像期间处理事件的同步通知。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageWriter 的使用

返回 ImageWriter 的 javax.imageio 中的方法
static ImageWriter ImageIO.getImageWriter(ImageReader reader)
返回对应于给定 ImageReader 的 ImageWriter（如果有）；如果此 ImageReader 的插件没有指定相应的 ImageWriter，或者给定的 ImageReader 没有注册，则返回 null。

返回变量类型为 ImageWriter 的类型的 javax.imageio 中的方法
static Iterator<ImageWriter> | ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
static Iterator<ImageWriter> | ImageIO.getImageWritersByFormatName(String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码指定格式。
static Iterator<ImageWriter> | ImageIO.getImageWritersByMIMEType(String MIMEType) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定 MIME 类型的文件。
static Iterator<ImageWriter> | ImageIO.getImageWritersBySuffix(String fileSuffix) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageReader 声称能够编码具有给定后缀的文件。

参数类型为 ImageWriter 的 javax.imageio 中的方法
static ImageReader | ImageIO.getImageReader(ImageWriter writer) 返回对应于给定 ImageWriter 的 ImageReader（如果有）；如果此 ImageWriter 的插件没有指定相应的 ImageReader，或者给定 ImageWriter 没有注册，则返回 null。
static Iterator<ImageTranscoder> | ImageIO.getImageTranscoders(ImageReader reader, ImageWriter writer) 返回包含所有当前已注册 ImageTranscoder 的 Iterator，这些 ImageTranscoder 声称能够在给定 ImageReader 和 ImageWriter 的元数据之间进行代码转换。

javax.imageio.event 中 ImageWriter 的使用

参数类型为 ImageWriter 的 javax.imageio.event 中的方法
void | IIOWriteProgressListener.imageComplete(ImageWriter source) 报告图像写操作已经完成。
void | IIOWriteProgressListener.imageProgress(ImageWriter source, float percentageDone) 报告在关联的 ImageWriter 中完成当前 write 调用的近似程度。
void | IIOWriteProgressListener.imageStarted(ImageWriter source, int imageIndex) 报告图像写操作将要开始。
void | IIOWriteProgressListener.thumbnailComplete(ImageWriter source) 报告缩略图写操作已经完成。
void | IIOWriteProgressListener.thumbnailProgress(ImageWriter source, float percentageDone) 报告在关联的 ImageWriter 中完成当前缩略图写操作的近似程度。
void | IIOWriteProgressListener.thumbnailStarted(ImageWriter source, int imageIndex, int thumbnailIndex) 报告缩略图写操作将要开始。
void | IIOWriteWarningListener.warningOccurred(ImageWriter source, int imageIndex, String warning) 报告在编码中发生非严重错误。
void | IIOWriteProgressListener.writeAborted(ImageWriter source) 报告已通过 writer 的 abort 方法中止写操作。

javax.imageio.spi 中 ImageWriter 的使用

返回 ImageWriter 的 javax.imageio.spi 中的方法
ImageWriter | ImageWriterSpi.createWriterInstance() 返回与此服务提供者关联的 ImageWriter 实现的实例。
abstract ImageWriter | ImageWriterSpi.createWriterInstance(Object extension) 返回与此服务提供者关联的 ImageWriter 实现的实例。

参数类型为 ImageWriter 的 javax.imageio.spi 中的方法
 boolean ImageWriterSpi.isOwnWriter(ImageWriter writer)
如果传入的 ImageWriter 对象是与此服务提供者关联的 ImageWriter 的实例，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.imageio.ImageTypeSpecifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.imageio.ImageTypeSpecifier
的使用

使用 ImageTypeSpecifier 的软件包
javax.imageio | Java Image I/O API 的主要包。
javax.imageio.metadata | 用于处理读写元数据的 Java Image I/O API 的包。
javax.imageio.spi | 包含用于 reader、writer、transcoder 和流的插件接口以及一个运行时注册表的 Java Image I/O API 包。

javax.imageio 中 ImageTypeSpecifier 的使用

声明为 ImageTypeSpecifier 的 javax.imageio 中的字段
protected  ImageTypeSpecifier IIOParam.destinationType
一个 ImageTypeSpecifier，用来在进行读取操作时生成目标图像，或者在进行写入操作时设置输出颜色类型。

返回 ImageTypeSpecifier 的 javax.imageio 中的方法
static ImageTypeSpecifier | ImageTypeSpecifier.createBanded(ColorSpace colorSpace, int[] bankIndices, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回带状图像格式的说明符，它将使用 ComponentColorModel 和 BandedSampleModel 来存储单独数组中的每个通道。
static ImageTypeSpecifier | ImageTypeSpecifier.createFromBufferedImageType(int bufferedImageType) 返回一个 ImageTypeSpecifier，它将对某一标准 BufferedImage 类型（而不是 TYPE_CUSTOM）进行编码。
static ImageTypeSpecifier | ImageTypeSpecifier.createFromRenderedImage(RenderedImage image) 返回一个 ImageTypeSpecifier，它将对 RenderedImage（可能是 BufferedImage）的布局进行编码。
static ImageTypeSpecifier | ImageTypeSpecifier.createGrayscale(int bits, int dataType, boolean isSigned) 返回灰度级图像格式的说明符，它会将给定位深 (bit depth) 的像素压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | ImageTypeSpecifier.createGrayscale(int bits, int dataType, boolean isSigned, boolean isAlphaPremultiplied) 返回灰度级图像格式和 alpha 图像格式的说明符，它会将给定位深的像素压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | ImageTypeSpecifier.createIndexed(byte[] redLUT, byte[] greenLUT, byte[] blueLUT, byte[] alphaLUT, int bits, int dataType) 返回索引颜色图像格式的说明符，它将给定位深的索引值压缩成指定数据类型的数组元素。
static ImageTypeSpecifier | ImageTypeSpecifier.createInterleaved(ColorSpace colorSpace, int[] bandOffsets, int dataType, boolean hasAlpha, boolean isAlphaPremultiplied) 返回交错图像格式的说明符，它将使用 ComponentColorModel 和 PixelInterleavedSampleModel 来存储单个 byte、short 或 int 值形式的每个像素组件。
static ImageTypeSpecifier | ImageTypeSpecifier.createPacked(ColorSpace colorSpace, int redMask, int greenMask, int blueMask, int alphaMask, int transferType, boolean isAlphaPremultiplied) 返回压缩图像格式的说明符，它将使用 DirectColorModel 和一个压缩的 SampleModel 来存储压缩成单个 byte、short 或 int 值的像素。
ImageTypeSpecifier | IIOParam.getDestinationType() 以 ImageTypeSpecifier 的形式返回将由读取操作返回的图像类型，如果通过调用 setDestination(ImageTypeSpecifier) 设置了类型的话。
ImageTypeSpecifier | ImageReader.getRawImageType(int imageIndex) 返回一个 ImageTypeSpecifier，指示最能代表图像“原始”内部格式的 SampleModel 和 ColorModel。

返回变量类型为 ImageTypeSpecifier 的类型的 javax.imageio 中的方法
abstract  Iterator<ImageTypeSpecifier> ImageReader.getImageTypes(int imageIndex)
以 ImageTypeSpecifier 形式返回包含可能的图像类型的 Iterator，给定图像可能被解码成这些类型。

参数类型为 ImageTypeSpecifier 的 javax.imageio 中的方法
IIOMetadata | ImageTranscoder.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param) 返回一个 IIOMetadata 对象，该对象可用于编码，并且可以使用其文档接口或特定于将用于编码的 writer 插件的其他接口有选择地对其进行修改。
abstract IIOMetadata | ImageWriter.convertImageMetadata(IIOMetadata inData, ImageTypeSpecifier imageType, ImageWriteParam param)
abstract IIOMetadata | ImageWriter.getDefaultImageMetadata(ImageTypeSpecifier imageType, ImageWriteParam param) 返回包含用来编码给定类型图像的默认值的 IIOMetadata 对象。
static Iterator<ImageWriter> | ImageIO.getImageWriters(ImageTypeSpecifier type, String formatName) 返回包含所有当前已注册 ImageWriter 的 Iterator，这些 ImageWriter 声称能够编码使用给定格式的、具有给定布局（使用 ImageTypeSpecifier 指定）的图像。
int | ImageWriter.getNumThumbnailsSupported(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回受将写入的格式、给定图像类型和任何其他 write 参数支持的缩略图，以及将在编码期间使用的元数据对象。
Dimension[] | ImageWriter.getPreferredThumbnailSizes(ImageTypeSpecifier imageType, ImageWriteParam param, IIOMetadata streamMetadata, IIOMetadata imageMetadata) 返回一个 Dimension 数组，指示在输出文件或流中进行编码时合法的缩略图大小范围。
void | ImageWriter.prepareInsertEmpty(int imageIndex, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从将带有不确定像素值的新图像插入现有图像流中开始。
void | ImageWriter.prepareWriteEmpty(IIOMetadata streamMetadata, ImageTypeSpecifier imageType, int width, int height, IIOMetadata imageMetadata, List<? extends BufferedImage> thumbnails, ImageWriteParam param) 从写入完整图像流开始，该图像流由带有要输出的不确定像素值、有关元数据和缩略图的单个图像组成。
void | IIOParam.setDestinationType(ImageTypeSpecifier destinationType) 使用 ImageTypeSpecifier 设置目标图像的所需图像类型。
void | ImageReadParam.setDestinationType(ImageTypeSpecifier destinationType)

类型变量类型为 ImageTypeSpecifier 的 javax.imageio 中的方法参数
protected static BufferedImage ImageReader.getDestination(ImageReadParam param, Iterator<ImageTypeSpecifier> imageTypes, int width, int height)
返回应该在其中写入解码的像素数据的 BufferedImage。

javax.imageio.metadata 中 ImageTypeSpecifier 的使用

参数类型为 ImageTypeSpecifier 的 javax.imageio.metadata 中的方法
boolean | IIOMetadataFormat.canNodeAppear(String elementName, ImageTypeSpecifier imageType) 如果允许元素（和它下面的子树）在给定类型（由 ImageTypeSpecifier 定义）的图像的元数据文档中出现，则返回 true。
abstract boolean | IIOMetadataFormatImpl.canNodeAppear(String elementName, ImageTypeSpecifier imageType)

javax.imageio.spi 中 ImageTypeSpecifier 的使用

参数类型为 ImageTypeSpecifier 的 javax.imageio.spi 中的方法
abstract  boolean ImageWriterSpi.canEncodeImage(ImageTypeSpecifier type)
如果与此服务提供者关联的 ImageWriter 实现能够使用给定的布局编码图像，则返回 true。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


HandlerChain (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.jws
注释类型 HandlerChain

@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD,FIELD})
public @interface HandlerChain

将 Web Service 与外部定义的处理程序链关联。此注释通常用于不适合将处理程序配置直接嵌入 Java 源的情况；例如，需要在多个 Web Service 之间共享处理程序配置的地方，或者处理程序链由多个传输的处理程序组成的地方。 将此注释与 @SOAPMessageHandlers 注释组合在一起是错误的。

必需元素摘要
 String file
处理程序链文件的位置。
可选元素摘要
 String name
已过时。 从 JSR-181 2.0 开始，无替代版本。

元素详细信息

file

public abstract String file
处理程序链文件的位置。

该位置支持两种格式：

  1. externalForm 形式的绝对 java.net.URL（例如：http://myhandlers.foo.com/handlerfile1.xml）。
  2. 相对于源文件或类文件的相对路径（例如：bar/handlerfile1.xml）。

name

@Deprecated
public abstract String name
已过时。 从 JSR-181 2.0 开始，无替代版本。

配置文件中的处理程序链的名称。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


Oneway (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.jws
注释类型 Oneway

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface Oneway

指示给定 @WebMethod 只有一条输入消息并且没有输出。通常，在执行实际业务方法之前，单向的方法返回调用的应用程序的控件线程。如果标记了 @Oneway 的操作具有返回值或 Holder 参数，或者声明了任何已检查的异常，则 181 处理器应该报告错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebMethod (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.jws
注释类型 WebMethod

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface WebMethod

定制一个公开为 Web Service 操作的方法。关联方法必须是公共方法且其参数可以返回值，并且异常必须遵循 JAX-RPC 1.1 的第 5 节中定义的规则。 该方法不需要抛出 java.rmi.RemoteException。

可选元素摘要
String | action 此操作的动作。
boolean | exclude 将某一方法标记为不作为一个 web 方法公开。
String | operationName 与此方法匹配的 wsdl:operation 的名称。

operationName

public abstract String operationName
与此方法匹配的 wsdl:operation 的名称。

默认值：
""

action

public abstract String action
此操作的动作。

对于 SOAP 绑定，此方法可确定 soap 动作的值。

默认值：
""

exclude

public abstract boolean exclude
将某一方法标记为不作为一个 web 方法公开。

此方法用于阻止将某一继承方法公开为此 web 服务的一部分。如果指定此元素，则不得为

从以下版本开始：
2.0
默认值：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebParam (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.jws
注释类型 WebParam

@Retention(value=RUNTIME)
@Target(value=PARAMETER)
public @interface WebParam

定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。

可选元素摘要
boolean | header 如果为 true，则参数是从消息头而不是消息正文获取的。
WebParam.Mode | mode 参数的流向（IN、OUT 或 INOUT 之一）。
String | name 参数名称。
String | partName 表示此参数的 wsdl:part 的名称。
String | targetNamespace 参数的 XML 名称空间。

name

public abstract String name
参数名称。

如果该操作是 rpc 样式的，并且尚未指定 @WebParam.partName，则此名称是表示参数的 wsdl:part 的名称。
如果该操作是文档样式的，或者参数映射到某一个头，则此名称是表示参数的 XML 元素的本地名称。

如果操作是文档样式的，参数样式为 BARE 并且模式为 OUT 或 INOUT，则必须指定一个名称。

默认值：
""

partName

public abstract String partName
表示此参数的 wsdl:part 的名称。

此名称仅在操作是 rpc 样式，或者操作是文档样式且参数样式为 BARE 时使用。

从以下版本开始：
2.0
默认值：
""

targetNamespace

public abstract String targetNamespace
参数的 XML 名称空间。

仅在操作是文档样式或者参数映射到某一个头时使用。如果目标名称空间被设置为 ""，则此名称空间表示空名称空间。

默认值：
""

mode

public abstract WebParam.Mode mode
参数的流向（IN、OUT 或 INOUT 之一）。

OUT 和 INOUT 模式只是为那些符合 Holder 类型定义（JAX-WS 2.0 [5] 的第 2.3.3 节）的参数类型所指定的。Holder 类型的参数必须为 OUT 或 INOUT。

默认值：
javax.jws.WebParam.Mode.IN

header

public abstract boolean header
如果为 true，则参数是从消息头而不是消息正文获取的。

默认值：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebParam.Mode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws
枚举 WebParam.Mode

java.lang.Object
    继承者  java.lang.Enum<WebParam.Mode>
        继承者  javax.jws.WebParam.Mode
所有已实现的接口：
Serializable, Comparable<WebParam.Mode>
正在封闭类：
WebParam
public static enum WebParam.Mode
extends Enum<WebParam.Mode>

参数的流向。

枚举常量摘要
IN
INOUT
OUT
方法摘要
static WebParam.Mode | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static WebParam.Mode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

IN

public static final WebParam.Mode IN

OUT

public static final WebParam.Mode OUT

INOUT

public static final WebParam.Mode INOUT
方法详细信息

values

public static final WebParam.Mode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(WebParam.Mode c : WebParam.Mode.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static WebParam.Mode valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


WebResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.jws
注释类型 WebResult

@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface WebResult

定制返回值到 WSDL 部分和 XML 元素的映射关系。

可选元素摘要
boolean | header 如果为 true，则结果是从消息头而不是消息正文获取的。
String | name 返回值的名称。
String | partName 表示此返回值的 wsdl:part 的名称。
String | targetNamespace 返回值的 XML 名称空间。

name

public abstract String name
返回值的名称。

如果操作是 rpc 样式，并且尚未指定

默认值：
""

partName

public abstract String partName
表示此返回值的 wsdl:part 的名称。

此名称只在操作是 rpc 样式，或者操作是文档样式且参数样式为 BARE 时使用。

从以下版本开始：
2.0
默认值：
""

targetNamespace

public abstract String targetNamespace
返回值的 XML 名称空间。

只在操作是文档样式或者返回值映射到某一个头时使用。如果目标名称空间被设置为 ""，则此名称空间表示空名称空间。

默认值：
""

header

public abstract boolean header
如果为 true，则结果是从消息头而不是消息正文获取的。

从以下版本开始：
2.0
默认值：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


WebService (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.jws
注释类型 WebService

@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface WebService

将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

可选元素摘要
String | endpointInterface 定义服务抽象 Web Service 协定的服务端点接口的完整名称。
String | name Web Service 的名称。
String | portName Web Service 的端口名称。
String | serviceName Web Service 的服务名称。
String | targetNamespace 如果 @WebService.targetNamespace 注释是关于某一服务端点接口的，则 targetNamespace 用于 wsdl:portType（以及关联的 XML 元素）的名称空间。
String | wsdlLocation 描述服务的预定义 WSDL 的位置。

name

public abstract String name
Web Service 的名称。

当映射到 WSDL 1.1 时，该名称被用作 wsdl:portType 的名称。

默认值：
""

targetNamespace

public abstract String targetNamespace
如果 @WebService.targetNamespace 注释是关于某一服务端点接口的，则 targetNamespace 用于 wsdl:portType（以及关联的 XML 元素）的名称空间。

如果 @WebService.targetNamespace 注释是关于某个没有引用服务端点接口（通过 endpointInterface 属性）的服务实现 bean 的，则 targetNamespace 既可以用于 wsdl:portType 也可以用于 wsdl:service（以及关联的 XML 元素）。

如果 @WebService.targetNamespace 注释是关于某个引用服务端点接口（通过 endpointInterface 属性）的服务实现 bean 的，则 targetNamespace 仅用于 wsdl:service（以及关联的 XML 元素）。

默认值：
""

serviceName

public abstract String serviceName
Web Service 的服务名称。

当映射到 WSDL 1.1 时，此名称被用作 wsdl:service 的名称。

不允许在端点接口上使用此成员值。

默认值：
""

portName

public abstract String portName
Web Service 的端口名称。

当映射到 WSDL 1.1 时，此名称被用作 wsdl:port 的名称。

不允许在端点接口上使用此成员值。

从以下版本开始：
2.0
默认值：
""

wsdlLocation

public abstract String wsdlLocation
描述服务的预定义 WSDL 的位置。

wsdlLocation 是引用预先存在的 WSDL 文件的 URL（相对或绝对）。wsdlLocation 值的存在指示服务实现 bean 将实现预先定义的 WSDL 协定。如果服务实现 bean 与此 WSDL 中声明的 portType 和绑定不一致，则 JSR-181 工具必须提供反馈。注意，单个 WSDL 文件可能包含多个 portType 和多个绑定。服务实现 bean 上的注释确定对应于 Web Service 的特定 portType 和绑定。

默认值：
""

endpointInterface

public abstract String endpointInterface
定义服务抽象 Web Service 协定的服务端点接口的完整名称。

此注释允许开发人员将接口协定与实现分离。如果此注释存在，则使用服务端点接口来确定抽象 WSDL 协定（portType 和绑定）。服务端点接口可以包含用来定制 Java 到 WSDL 的映射关系的 JSR-181 注释。
服务实现 bean 可以实现服务端点接口，但并不要求这样做。
如果此成员值不存在，则 Web Service 协定是根据服务实现 bean 上的注释生成的。如果目标环境需要一个服务端点接口，则将生成一个由实现定义的包，该包具有由实现定义的名称。

不允许在端点接口上使用此成员值。

默认值：
""
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


javax.jws (Java 2 Platform SE 6)

 javax.jws
枚举
WebParam.Mode
注释类型
HandlerChain
Oneway
WebMethod
WebParam
WebResult
WebService


javax.jws (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.jws

枚举摘要
WebParam.Mode 参数的流向。

注释类型摘要
HandlerChain | 将 Web Service 与外部定义的处理程序链关联。
Oneway | 指示给定 @WebMethod 只有一条输入消息并且没有输出。
WebMethod | 定制一个公开为 Web Service 操作的方法。
WebParam | 定制单个参数到 Web Service 消息部分和 XML 元素的映射关系。
WebResult | 定制返回值到 WSDL 部分和 XML 元素的映射关系。
WebService | 将 Java 类标记为实现 Web Service，或者将 Java 接口标记为定义 Web Service 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.jws 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.jws 的分层结构

软件包分层结构：
所有软件包

注释类型分层结构

  • javax.jws.HandlerChain (implements java.lang.annotation.Annotation)
  • javax.jws.Oneway (implements java.lang.annotation.Annotation)
  • javax.jws.WebMethod (implements java.lang.annotation.Annotation)
  • javax.jws.WebParam (implements java.lang.annotation.Annotation)
  • javax.jws.WebResult (implements java.lang.annotation.Annotation)
  • javax.jws.WebService (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.WebParam.Mode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.jws 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.jws
的使用

使用 javax.jws 的软件包
javax.jws

javax.jws 使用的 javax.jws 中的类
WebParam.Mode
参数的流向。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


InitParam (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.jws.soap
注释类型 InitParam

已过时。 从 JSR-181 2.0 开始，无替代版本。

@Deprecated
public @interface InitParam

一个初始化参数。

必需元素摘要
String | name 已过时。 初始化参数的名称。
String | value 已过时。 初始化参数的值。

元素详细信息

name

public abstract String name
已过时。
初始化参数的名称。

value

public abstract String value
已过时。
初始化参数的值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


SOAPBinding (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.jws.soap
注释类型 SOAPBinding

@Retention(value=RUNTIME)
@Target(value={TYPE,METHOD})
public @interface SOAPBinding

指定 Web Service 到 SOAP 消息协议的映射关系。

可选元素摘要
SOAPBinding.ParameterStyle | parameterStyle 确定方法参数是否表示整个消息正文，或者参数是否是包装在以操作命名的顶层元素中的元素。
SOAPBinding.Style | style 定义发送到 Web Service 的消息和从 Web Service 发送的消息的编码样式。
SOAPBinding.Use | use 定义发送到 Web Service 的消息和从 Web Service 发送的消息的格式样式。

style

public abstract SOAPBinding.Style style
定义发送到 Web Service 的消息和从 Web Service 发送的消息的编码样式。

默认值：
javax.jws.soap.SOAPBinding.Style.DOCUMENT

use

public abstract SOAPBinding.Use use
定义发送到 Web Service 的消息和从 Web Service 发送的消息的格式样式。

默认值：
javax.jws.soap.SOAPBinding.Use.LITERAL

parameterStyle

public abstract SOAPBinding.ParameterStyle parameterStyle
确定方法参数是否表示整个消息正文，或者参数是否是包装在以操作命名的顶层元素中的元素。

默认值：
javax.jws.soap.SOAPBinding.ParameterStyle.WRAPPED
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


SOAPBinding.ParameterStyle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws.soap
枚举 SOAPBinding.ParameterStyle

java.lang.Object
    继承者  java.lang.Enum<SOAPBinding.ParameterStyle>
        继承者  javax.jws.soap.SOAPBinding.ParameterStyle
所有已实现的接口：
Serializable, Comparable<SOAPBinding.ParameterStyle>
正在封闭类：
SOAPBinding
public static enum SOAPBinding.ParameterStyle
extends Enum<SOAPBinding.ParameterStyle>

参数到 SOAP 消息的映射关系的样式。

枚举常量摘要
BARE
WRAPPED
方法摘要
static SOAPBinding.ParameterStyle | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.ParameterStyle[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

BARE

public static final SOAPBinding.ParameterStyle BARE

WRAPPED

public static final SOAPBinding.ParameterStyle WRAPPED
方法详细信息

values

public static final SOAPBinding.ParameterStyle[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.ParameterStyle c : SOAPBinding.ParameterStyle.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SOAPBinding.ParameterStyle valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SOAPBinding.Style (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws.soap
枚举 SOAPBinding.Style

java.lang.Object
    继承者  java.lang.Enum<SOAPBinding.Style>
        继承者  javax.jws.soap.SOAPBinding.Style
所有已实现的接口：
Serializable, Comparable<SOAPBinding.Style>
正在封闭类：
SOAPBinding
public static enum SOAPBinding.Style
extends Enum<SOAPBinding.Style>

SOAP 绑定样式。

枚举常量摘要
DOCUMENT
RPC
方法摘要
static SOAPBinding.Style | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Style[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

DOCUMENT

public static final SOAPBinding.Style DOCUMENT

RPC

public static final SOAPBinding.Style RPC
方法详细信息

values

public static final SOAPBinding.Style[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.Style c : SOAPBinding.Style.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SOAPBinding.Style valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SOAPBinding.Use (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.jws.soap
枚举 SOAPBinding.Use

java.lang.Object
    继承者  java.lang.Enum<SOAPBinding.Use>
        继承者  javax.jws.soap.SOAPBinding.Use
所有已实现的接口：
Serializable, Comparable<SOAPBinding.Use>
正在封闭类：
SOAPBinding
public static enum SOAPBinding.Use
extends Enum<SOAPBinding.Use>

SOAP 绑定的使用。

枚举常量摘要
ENCODED
LITERAL
方法摘要
static SOAPBinding.Use | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Use[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

LITERAL

public static final SOAPBinding.Use LITERAL

ENCODED

public static final SOAPBinding.Use ENCODED
方法详细信息

values

public static final SOAPBinding.Use[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SOAPBinding.Use c : SOAPBinding.Use.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SOAPBinding.Use valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SOAPMessageHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.jws.soap
注释类型 SOAPMessageHandler

已过时。 从 JSR-181 2.0 开始，无替代版本。

@Deprecated
public @interface SOAPMessageHandler

单个 SOAP 消息处理程序。

必需元素摘要
 String className
已过时。 处理程序类的名称。
可选元素摘要
String[] | headers 已过时。 由处理程序处理的 SOAP 头所组成的列表。
InitParam[] | initParams 已过时。 应该在初始化期间传递给处理程序的名称/值对所组成的数组。
String | name 已过时。 处理程序的名称。
String[] | roles 已过时。 由处理程序实现的 SOAP 角色/参与者所组成的列表。

元素详细信息

className

public abstract String className
已过时。
处理程序类的名称。

name

public abstract String name
已过时。
处理程序的名称。默认为处理程序类的名称。

默认值：
""

initParams

public abstract InitParam[] initParams
已过时。
应该在初始化期间传递给处理程序的名称/值对所组成的数组。

默认值：
{}

roles

public abstract String[] roles
已过时。
由处理程序实现的 SOAP 角色/参与者所组成的列表。

默认值：
{}

headers

public abstract String[] headers
已过时。
由处理程序处理的 SOAP 头所组成的列表。此数组中的每个元素都包含一个 QName，该 QName 定义处理程序所处理的头元素。该 QName 是使用 javax.xml.namespace.QName.valueOf(String qNameAsString) 文档中所描述的字符串表示法指定的。

默认值：
{}
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


SOAPMessageHandlers (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素

javax.jws.soap
注释类型 SOAPMessageHandlers

已过时。 从 JSR-181 2.0 开始，无替代版本。

@Retention(value=RUNTIME)
@Target(value=TYPE)
@Deprecated
public @interface SOAPMessageHandlers

指定一个 SOAP 协议处理程序列表，这些处理程序在业务方法之前和之后在 Web Service 上运行。调用这些处理程序来响应以服务为目标的 SOAP 消息。

@SOAPMessageHandlers 注释是一个 SOAPMessageHandler 类型的数组。处理程序按照它们在注释中出现的顺序运行，从数组中的第一个处理程序开始。

必需元素摘要
 SOAPMessageHandler[] value
已过时。

元素详细信息

value

public abstract SOAPMessageHandler[] value
已过时。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 必需 | 可选 | 详细信息： 元素


javax.jws.soap (Java 2 Platform SE 6)

 javax.jws.soap
枚举
SOAPBinding.ParameterStyle
SOAPBinding.Style
SOAPBinding.Use
注释类型
InitParam
SOAPBinding
SOAPMessageHandler
SOAPMessageHandlers


javax.jws.soap (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.jws.soap

枚举摘要
SOAPBinding.ParameterStyle | 参数到 SOAP 消息的映射关系的样式。
SOAPBinding.Style | SOAP 绑定样式。
SOAPBinding.Use | SOAP 绑定的使用。

注释类型摘要
InitParam | 已过时。 从 JSR-181 2.0 开始，无替代版本。
SOAPBinding | 指定 Web Service 到 SOAP 消息协议的映射关系。
SOAPMessageHandler | 已过时。 从 JSR-181 2.0 开始，无替代版本。
SOAPMessageHandlers | 已过时。 从 JSR-181 2.0 开始，无替代版本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.jws.soap 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.jws.soap 的分层结构

软件包分层结构：
所有软件包

注释类型分层结构

  • javax.jws.soap.InitParam (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPBinding (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandler (implements java.lang.annotation.Annotation)
  • javax.jws.soap.SOAPMessageHandlers (implements java.lang.annotation.Annotation)

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.jws.soap.SOAPBinding.Style
      • javax.jws.soap.SOAPBinding.Use
      • javax.jws.soap.SOAPBinding.ParameterStyle
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.jws.soap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.jws.soap
的使用

使用 javax.jws.soap 的软件包
javax.jws.soap

javax.jws.soap 使用的 javax.jws.soap 中的类
SOAPBinding.ParameterStyle
参数到 SOAP 消息的映射关系的样式。
SOAPBinding.Style
SOAP 绑定样式。
SOAPBinding.Use
SOAP 绑定的使用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.soap.InitParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.InitParam
的使用

没有 javax.jws.soap.InitParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.soap.SOAPBinding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding
的使用

没有 javax.jws.soap.SOAPBinding 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.soap.SOAPBinding.Style 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding.Style
的使用

使用 SOAPBinding.Style 的软件包
javax.jws.soap

javax.jws.soap 中 SOAPBinding.Style 的使用

返回 SOAPBinding.Style 的 javax.jws.soap 中的方法
static SOAPBinding.Style | SOAPBinding.Style.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Style[] | SOAPBinding.Style.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.soap.SOAPBinding.Use 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding.Use
的使用

使用 SOAPBinding.Use 的软件包
javax.jws.soap

javax.jws.soap 中 SOAPBinding.Use 的使用

返回 SOAPBinding.Use 的 javax.jws.soap 中的方法
static SOAPBinding.Use | SOAPBinding.Use.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.Use[] | SOAPBinding.Use.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.soap.SOAPBinding.ParameterStyle 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPBinding.ParameterStyle
的使用

使用 SOAPBinding.ParameterStyle 的软件包
javax.jws.soap

javax.jws.soap 中 SOAPBinding.ParameterStyle 的使用

返回 SOAPBinding.ParameterStyle 的 javax.jws.soap 中的方法
static SOAPBinding.ParameterStyle | SOAPBinding.ParameterStyle.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SOAPBinding.ParameterStyle[] | SOAPBinding.ParameterStyle.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.soap.SOAPMessageHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPMessageHandler
的使用

没有 javax.jws.soap.SOAPMessageHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.soap.SOAPMessageHandlers 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.soap.SOAPMessageHandlers
的使用

没有 javax.jws.soap.SOAPMessageHandlers 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.HandlerChain 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.HandlerChain
的使用

没有 javax.jws.HandlerChain 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.Oneway 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.Oneway
的使用

没有 javax.jws.Oneway 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.WebMethod 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebMethod
的使用

没有 javax.jws.WebMethod 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.WebParam 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebParam
的使用

没有 javax.jws.WebParam 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.WebParam.Mode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebParam.Mode
的使用

使用 WebParam.Mode 的软件包
javax.jws

javax.jws 中 WebParam.Mode 的使用

返回 WebParam.Mode 的 javax.jws 中的方法
static WebParam.Mode | WebParam.Mode.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static WebParam.Mode[] | WebParam.Mode.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.WebResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebResult
的使用

没有 javax.jws.WebResult 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.jws.WebService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.jws.WebService
的使用

没有 javax.jws.WebService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


SourceVersion (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 | 详细信息： 枚举常量 | 字段 | 方法

javax.lang.model
枚举 SourceVersion

java.lang.Object
    继承者  java.lang.Enum<SourceVersion>
        继承者  javax.lang.model.SourceVersion
所有已实现的接口：
Serializable, Comparable<SourceVersion>
public enum SourceVersion
extends Enum<SourceVersion>

Java™ 编程语言的源版本。 有关 The Java™ Language Specification 版本（包括更新和说明）的信息，请参见 http://java.sun.com/docs/books/jls/。

注意，其他源版本常量将添加到将来的语言模型版本中。

从以下版本开始：
1.6

枚举常量摘要
RELEASE_0
初始版本。
RELEASE_1
Java Platform 1.1 所识别的版本。
RELEASE_2
Java 2 Platform, Standard Edition, v 1.2 所识别的版本。
RELEASE_3
Java 2 Platform, Standard Edition, v 1.3 所识别的版本。
RELEASE_4
Java 2 Platform, Standard Edition, v 1.4 所识别的版本。
RELEASE_5
Java 2 Platform, Standard Edition 5.0 所识别的版本。
RELEASE_6
Java Platform, Standard Edition 6 所识别的版本。
方法摘要
static boolean | isIdentifier(CharSequence name) 返回 name 是否是语法上有效的标识符（简单名称）或最新源版本中的关键字。
static boolean | isKeyword(CharSequence s) 返回 s 是否是最新源版本中的关键字或字面值。
static boolean | isName(CharSequence name) 返回 name 是否是最新源版本中语法上有效的限定名称。
static SourceVersion | latest() 返回可以建模的最新源版本。
static SourceVersion | latestSupported() 返回完全受当前执行环境支持的最新源版本。
static SourceVersion | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SourceVersion[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

RELEASE_0

public static final SourceVersion RELEASE_0
初始版本。 The Java™ Language Specification 的第一个版本中描述的语言。

RELEASE_1

public static final SourceVersion RELEASE_1
Java Platform 1.1 所识别的版本。 该语言是使用嵌套类扩充的 RELEASE_0。

RELEASE_2

public static final SourceVersion RELEASE_2
Java 2 Platform, Standard Edition, v 1.2 所识别的版本。 The Java™ Language Specification, Second Edition 中描述的语言，包括 strictfp 修饰符。

RELEASE_3

public static final SourceVersion RELEASE_3
Java 2 Platform, Standard Edition, v 1.3 所识别的版本。 与 RELEASE_2 没有太大区别。

RELEASE_4

public static final SourceVersion RELEASE_4
Java 2 Platform, Standard Edition, v 1.4 所识别的版本。 添加了一个简单的断言工具。

RELEASE_5

public static final SourceVersion RELEASE_5
Java 2 Platform, Standard Edition 5.0 所识别的版本。 The Java™ Language Specification, Third Edition 中描述的语言。第一个支持泛型、注释、自动装箱、可变参数、增强的 for 循环和十六进制浮点字面值的版本。

RELEASE_6

public static final SourceVersion RELEASE_6
Java Platform, Standard Edition 6 所识别的版本。 与 RELEASE_5 没有太大区别。

方法详细信息

values

public static final SourceVersion[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SourceVersion c : SourceVersion.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SourceVersion valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

latest

public static SourceVersion latest()
返回可以建模的最新源版本。

返回：
可以建模的最新源版本

latestSupported

public static SourceVersion latestSupported()
返回完全受当前执行环境支持的最新源版本。必须返回 RELEASE_5 或更高版本。

返回：
完全受支持的最新源版本

isIdentifier

public static boolean isIdentifier(CharSequence name)
返回 name 是否是语法上有效的标识符（简单名称）或最新源版本中的关键字。如果 name 开头是一个 Character.isJavaIdentifierStart(int) 返回 true 的初始字符，且后面只跟有 Character.isJavaIdentifierPart(int) 返回 true 的字符，那么该方法返回 true。此模式匹配常规标识符、关键字以及字面值 &quot;true&quot;、&quot;false&quot; 和 &quot;null&quot;。该方法对其他所有字符串返回 false。

参数：
name - 要检查的字符串
返回：
如果此字符串是语法上有效的标识符或关键字，则返回 true，否则返回 false。

isName

public static boolean isName(CharSequence name)
返回 name 是否是最新源版本中语法上有效的限定名称。与 isIdentifier 不同，此方法对关键字和字面值返回 false。

参数：
name - 要检查的字符串
返回：
如果此字符串是语法上有效的名称，则返回 true，否则返回 false。

isKeyword

public static boolean isKeyword(CharSequence s)
返回 s 是否是最新源版本中的关键字或字面值。

参数：
s - 要检查的字符串
返回：
如果 s 是关键字或字面值，则返回 true，否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 | 详细信息： 枚举常量 | 字段 | 方法


javax.lang.model (Java 2 Platform SE 6)

 javax.lang.model
枚举
SourceVersion


javax.lang.model (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.lang.model

用来为 Java 编程语言建立模型的包的类和层次结构。

请参见：
描述

枚举摘要
SourceVersion Java™ 编程语言的源版本。

软件包 javax.lang.model 的描述

用来为 Java 编程语言建立模型的包的类和层次结构。 此包及其子包的成员适用于语言建模、语言处理任务和 API（包括但并不仅限于注释处理框架）。

此语言模型使用基于镜像 的设计；请参阅

Gilad Bracha 和 David Ungar 的Mirrors:Design Principles for Meta-level Facilities of Object-Oriented Programming Languages。发表于 2004 年 10 月召开的关于面向对象编程、系统、语言和应用程序的 ACM 程序会议（Proc. of the ACM Conf.）。
具体来说，该模型使静态语言构造（比如表示 java.util.Set 的元素）与某一元素所关联的类型系列（比如原始类型 java.util.Set、java.util.Set<String> 和 java.util.Set<T>）之间有所区别。

除非另行指定，否则，如果给定一个 null 参数，此包中的方法将抛出 NullPointerException。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.lang.model 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model 的分层结构

软件包分层结构：
所有软件包

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.lang.model.SourceVersion
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.lang.model 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model
的使用

使用 javax.lang.model 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 使用的 javax.lang.model 中的类
SourceVersion
Java™ 编程语言的源版本。

javax.lang.model 使用的 javax.lang.model 中的类
SourceVersion
Java™ 编程语言的源版本。

javax.tools 使用的 javax.lang.model 中的类
SourceVersion
Java™ 编程语言的源版本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AnnotationMirror (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 AnnotationMirror

public interface AnnotationMirror

表示一个注释。注释将值与注释类型的每个元素关联。

注释应该使用 equals 方法进行比较。不保证总是使用相同的对象表示某个特定的注释。

从以下版本开始：
1.6

方法摘要
DeclaredType | getAnnotationType() 返回此注释的类型。
Map<? extends ExecutableElement,? extends AnnotationValue> | getElementValues() 返回此注释元素的值。

方法详细信息

getAnnotationType

DeclaredType getAnnotationType()
返回此注释的类型。

返回：
此注释的类型

getElementValues

Map<? extends ExecutableElement,? extends AnnotationValue> getElementValues()
返回此注释元素的值。此值是以映射的形式返回的，该映射将元素与其相应的值关联。只包括那些注释中明确存在其值的元素，不包括那些隐式假定其默认值的元素。映射的顺序与值出现在注释源中的顺序匹配。

注意，标记注释类型的注释镜像将被定义为有一个空映射。

要使用默认值进行填充，可以使用 getElementValuesWithDefaults。

返回：
此注释元素的值；如果没有，则返回一个空映射
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AnnotationValue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 AnnotationValue

public interface AnnotationValue

表示注释类型元素的值。该值是以下类型之一：

  • 基本类型的包装类（例如 Integer）
  • String
  • TypeMirror
  • VariableElement（表示一个枚举常量）
  • AnnotationMirror
  • List<? extends AnnotationValue>（如果值是一个数组，则表示按声明顺序排列的元素）

从以下版本开始：
1.6

方法摘要
<R,P> R
accept(AnnotationValueVisitor<R,P> v, P p)
将一个 visitor 应用到此值。
 Object getValue()
返回值。
 String toString()
返回此值的字符串表示形式。

方法详细信息

getValue

Object getValue()
返回值。

返回：
值

toString

String toString()
返回此值的字符串表示形式。以适合于表示注释源代码中此值的形式返回。

覆盖：
类 Object 中的 toString
返回：
此值的字符串表示形式

accept

<R,P> R accept(AnnotationValueVisitor<R,P> v,
               P p)
将一个 visitor 应用到此值。

类型参数：
R - visitor 的方法的返回类型
参数：
v - 对此值进行操作的 visitor
p - visitor 的附加参数
返回：
特定于 visitor 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AnnotationValueVisitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 AnnotationValueVisitor<R,P>

类型参数：
R - 此 visitor 的方法的返回类型
所有已知实现类：
AbstractAnnotationValueVisitor6, SimpleAnnotationValueVisitor6
public interface AnnotationValueVisitor<R,P>

注释类型元素值的 visitor，使用 visitor 设计模式的变体。标准 visitor 基于类型层次结构成员的具体类型进行调度，与它不同，此 visitor 基于存储数据的类型进行调度；对于存储，没有不同的子类，例如 boolean 值和 int 值。在编译时某个值的类型未知时，实现此接口的类被用来对该值进行操作。在将 visitor 传递给某个值的 accept 方法时，适用于该值的 visitXYZ 方法将被调用。

如果附加参数 p 为 null，则实现此接口的类有可能抛出 NullPointerException；有关详细信息，请参阅实现类的文档。

警告： 以后可能会向此接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，直接实现此接口的 visitor 类可能与平台的未来版本不兼容。为了避免这种不兼容性，建议 visitor 实现扩展实现此接口的抽象 visitor 类。不过，API 通常应该使用此 visitor 接口作为参数类型、返回类型等，而不是将它作为抽象类之一。

从以下版本开始：
1.6

方法摘要
R | visit(AnnotationValue av) 等效于 v.visit(av, null) 的便捷方法。
R | visit(AnnotationValue av, P p) 访问注释值。
R | visitAnnotation(AnnotationMirror a, P p) 访问注释中的 annotation 值。
R | visitArray(List<? extends AnnotationValue> vals, P p) 访问注释中的 array 值。
R | visitBoolean(boolean b, P p) 访问注释中的 boolean 值。
R | visitByte(byte b, P p) 访问注释中的 byte 值。
R | visitChar(char c, P p) 访问注释中的 char 值。
R | visitDouble(double d, P p) 访问注释中的 double 值。
R | visitEnumConstant(VariableElement c, P p) 访问注释中的 enum 值。
R | visitFloat(float f, P p) 访问注释中的 float 值。
R | visitInt(int i, P p) 访问注释中的 int 值。
R | visitLong(long i, P p) 访问注释中的 long 值。
R | visitShort(short s, P p) 访问注释中的 short 值。
R | visitString(String s, P p) 访问注释中的 string 值。
R | visitType(TypeMirror t, P p) 访问注释中的 type 值。
R | visitUnknown(AnnotationValue av, P p) 访问未知种类的注释值。

方法详细信息

visit

R visit(AnnotationValue av,
        P p)
访问注释值。

参数：
av - 要访问的值
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visit

R visit(AnnotationValue av)
等效于 v.visit(av, null) 的便捷方法。

参数：
av - 要访问的值
返回：
特定于 visitor 的结果

visitBoolean

R visitBoolean(boolean b,
               P p)
访问注释中的 boolean 值。

参数：
b - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitByte

R visitByte(byte b,
            P p)
访问注释中的 byte 值。

参数：
b - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitChar

R visitChar(char c,
            P p)
访问注释中的 char 值。

参数：
c - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitDouble

R visitDouble(double d,
              P p)
访问注释中的 double 值。

参数：
d - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitFloat

R visitFloat(float f,
             P p)
访问注释中的 float 值。

参数：
f - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitInt

R visitInt(int i,
           P p)
访问注释中的 int 值。

参数：
i - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitLong

R visitLong(long i,
            P p)
访问注释中的 long 值。

参数：
i - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitShort

R visitShort(short s,
             P p)
访问注释中的 short 值。

参数：
s - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitString

R visitString(String s,
              P p)
访问注释中的 string 值。

参数：
s - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitType

R visitType(TypeMirror t,
            P p)
访问注释中的 type 值。

参数：
t - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitEnumConstant

R visitEnumConstant(VariableElement c,
                    P p)
访问注释中的 enum 值。

参数：
c - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitAnnotation

R visitAnnotation(AnnotationMirror a,
                  P p)
访问注释中的 annotation 值。

参数：
a - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitArray

R visitArray(List<? extends AnnotationValue> vals,
             P p)
访问注释中的 array 值。

参数：
vals - 要访问的值
p - 特定于 visitor 的参数
返回：
访问结果

visitUnknown

R visitUnknown(AnnotationValue av,
               P p)
访问未知种类的注释值。如果语言有所发展并且新类型的值可以存储在注释中，则会发生这种情况。

参数：
av - 要访问的未知值
p - 特定于 visitor 的参数
返回：
访问结果
抛出：
UnknownAnnotationValueException - visitor 实现可以有选择地抛出此异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Element (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 Element

所有已知子接口：
ExecutableElement, PackageElement, TypeElement, TypeParameterElement, VariableElement
public interface Element

表示一个程序元素，比如包、类或者方法。每个元素都表示一个静态的语言级构造（不表示虚拟机的运行时构造）。

元素应该使用 equals(Object) 方法进行比较。不保证总是使用相同的对象表示某个特定的元素。

要实现基于 Element 对象类的操作，可以使用 visitor 或者使用 getKind() 方法的结果。使用 instanceof 确定此建模层次结构中某一对象的有效类 未必 可靠，因为一个实现可以选择让单个对象实现多个 Element 子接口。

从以下版本开始：
1.6
另请参见：
Elements, TypeMirror

方法摘要
<R,P> R
accept(ElementVisitor<R,P> v, P p)
将一个 visitor 应用到此元素。
 TypeMirror asType()
返回此元素定义的类型。
 boolean equals(Object obj)
如果参数表示与此元素相同的元素，则返回 true；否则返回 false。
<A extends Annotation>
A
getAnnotation(Class<A> annotationType)
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。
 List<? extends AnnotationMirror> getAnnotationMirrors()
返回直接存在于此元素上的注释。
 List<? extends Element> getEnclosedElements()
返回此元素直接封装（非严格意义上）的元素。
 Element getEnclosingElement()
返回封装此元素（非严格意义上）的最里层元素。
 ElementKind getKind()
返回此元素的类型。
 Set<Modifier> getModifiers()
返回此元素的修饰符，不包括注释。
 Name getSimpleName()
返回此元素的简单（未限定）名称。
 int hashCode()
遵守 Object.hashCode 的常规协定。

方法详细信息

asType

TypeMirror asType()
返回此元素定义的类型。

一般元素会定义一个类型系列，而不是只定义一个类型。如果此元素是一般元素，则返回原型 类型。此方法是元素在对应于它自己的形式类型参数的类型变量上的调用。例如，对于一般类元素 C<N extends Number>，返回参数化类型 C<N>。Types 实用工具接口有更多的一般方法来获取某一元素定义的整个范围的类型。

返回：
此元素定义的类型
另请参见：
Types

getKind

ElementKind getKind()
返回此元素的类型。

返回：
此元素的类型

getAnnotationMirrors

List<? extends AnnotationMirror> getAnnotationMirrors()
返回直接存在于此元素上的注释。

要获得继承的注释，可使用 getAllAnnotationMirrors。

返回：
直接存在于此元素上的注释；如果没有，则返回一个空列表
另请参见：
ElementFilter

getAnnotation

<A extends Annotation> A getAnnotation(Class<A> annotationType)
返回此元素针对指定类型的注释（如果存在这样的注释），否则返回 null。注释可以是继承的，也可以是直接存在于此元素上的。

此方法返回的注释可以包含其值类型为 Class 的元素。此值无法直接返回：查找并加载某个类的必要信息（比如要使用的类加载器）不可用，该类可能根本无法加载。试图通过对所返回的注释调用相关方法读取 Class 对象将导致一个 MirroredTypeException，从中可以提取相应的 TypeMirror。类似地，试图读取一个值为 Class[] 的元素将导致 MirroredTypesException。

注： 此方法与此接口及相关接口中的那些方法不同。它对运行时反射信息（当前已加载到 VM 中的注释类型的表示形式）进行操作，而不是对通过这些接口定义和使用的表示形式进行操作。因此，调用返回注释对象上的方法可能会抛出许多异常，这些异常在调用核心反射所返回的注释对象上的方法时抛出。此方法由被编写为对已知的固定注释类型集上进行操作的调用者使用。

类型参数：
A - 注释类型
参数：
annotationType - 对应于注释类型的 Class 对象
返回：
此元素针对指定注释类型的注释（如果此元素上存在这样的注释），否则返回 null
另请参见：
getAnnotationMirrors(), AnnotatedElement.getAnnotation(java.lang.Class), EnumConstantNotPresentException, AnnotationTypeMismatchException, IncompleteAnnotationException, MirroredTypeException, MirroredTypesException

getModifiers

Set<Modifier> getModifiers()
返回此元素的修饰符，不包括注释。但包括显式修饰符，比如接口成员的 public 和 static 修饰符。

返回：
此元素的修饰符；如果没有，则返回一个空集

getSimpleName

Name getSimpleName()
返回此元素的简单（未限定）名称。一般类型的名称不包括对其形式类型参数的任何引用。例如，类型元素 java.util.Set<E> 的简单名称是 "Set"。如果此元素表示一个未指定的包，则返回一个空名称。如果它表示一个构造方法，则返回名称 "<init>"。如果它表示一个静态初始化程序，则返回名称 "<clinit>"。如果它表示一个匿名类或者实例初始化程序，则返回一个空名称。

返回：
此元素的简单名称

getEnclosingElement

Element getEnclosingElement()
返回封装此元素（非严格意义上）的最里层元素。
  • 如果此元素的声明在词法上直接封装在另一个元素的声明中，则返回那个封装元素。
  • 如果此元素是顶层类型，则返回它的包。
  • 如果此元素是一个包，则返回 null。
  • 如果此元素是一个类型参数，则返回 null。

返回：
封装元素；如果没有，则返回 null
另请参见：
Elements.getPackageOf(javax.lang.model.element.Element)

getEnclosedElements

List<? extends Element> getEnclosedElements()
返回此元素直接封装（非严格意义上）的元素。 类或接口被认为用于封装它直接声明的字段、方法、构造方法和成员类型。这包括所有（隐式）默认构造方法和枚举类型的隐式 values 和 valueOf 方法。 包封装位于其中的顶层类和接口，但不认为它封装了子包。 当前不认为其他种类的元素封装了任何元素；但是，随着此 API 或编程语言的发展，这种情况可能发生改变。

注意，使用 ElementFilter 中的方法可以隔离某一种类的元素。

返回：
封装的元素；如果没有，则返回一个空列表
另请参见：
Elements.getAllMembers(javax.lang.model.element.TypeElement)

equals

boolean equals(Object obj)
如果参数表示与此元素相同的元素，则返回 true；否则返回 false。

注意，元素的身份包括无法直接从元素方法获得的隐式状态，包括反映无关类型存在性的状态。这些接口的不同实现所创建的元素对象不 应该是相等的，即使将为“相同的”元素建模；这正如通过不同类加载器加载的相同类文件的 Class 对象是不相等的。

覆盖：
类 Object 中的 equals
参数：
obj - 将与此元素进行比较的对象
返回：
如果指定对象表示与此元素相同的元素，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
遵守 Object.hashCode 的常规协定。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
equals(java.lang.Object)

accept

<R,P> R accept(ElementVisitor<R,P> v,
               P p)
将一个 visitor 应用到此元素。

类型参数：
R - visitor 的方法的返回类型
P - visitor 的方法的附加参数类型
参数：
v - 对此元素进行操作的 visitor
p - visitor 的附加参数
返回：
特定于 visitor 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ElementKind (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.lang.model.element
枚举 ElementKind

java.lang.Object
    继承者  java.lang.Enum<ElementKind>
        继承者  javax.lang.model.element.ElementKind
所有已实现的接口：
Serializable, Comparable<ElementKind>
public enum ElementKind
extends Enum<ElementKind>

元素的 kind。

注意，以后可能会添加一些新的元素种类，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。

从以下版本开始：
1.6
另请参见：
Element

枚举常量摘要
ANNOTATION_TYPE
一个注释类型。
CLASS
没有用更特殊的种类（如 ENUM）描述的类。
CONSTRUCTOR
一个构造方法。
ENUM
一个枚举类型。
ENUM_CONSTANT
一个枚举常量。
EXCEPTION_PARAMETER
异常处理程序的参数。
FIELD
没有用更特殊的种类（如 ENUM_CONSTANT）描述的字段。
INSTANCE_INIT
一个常量初始化程序。
INTERFACE
没有用更特殊的种类（如 ANNOTATION_TYPE）描述的接口。
LOCAL_VARIABLE
局部变量。
METHOD
一个方法。
OTHER
一个为实现保留的元素。
PACKAGE
一个包。
PARAMETER
方法或构造方法的参数。
STATIC_INIT
一个静态初始化程序。
TYPE_PARAMETER
一个类型参数。
方法摘要
boolean | isClass() 如果此元素是以下种类的类，则返回 true：CLASS 或 ENUM。
boolean | isField() 如果此元素是以下种类的字段，则返回 true：FIELD 或 ENUM_CONSTANT。
boolean | isInterface() 如果此元素是以下种类的接口，则返回 true：INTERFACE 或 ANNOTATION_TYPE。
static ElementKind | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ElementKind[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

PACKAGE

public static final ElementKind PACKAGE
一个包。

ENUM

public static final ElementKind ENUM
一个枚举类型。

CLASS

public static final ElementKind CLASS
没有用更特殊的种类（如 ENUM）描述的类。

ANNOTATION_TYPE

public static final ElementKind ANNOTATION_TYPE
一个注释类型。

INTERFACE

public static final ElementKind INTERFACE
没有用更特殊的种类（如 ANNOTATION_TYPE）描述的接口。

ENUM_CONSTANT

public static final ElementKind ENUM_CONSTANT
一个枚举常量。

FIELD

public static final ElementKind FIELD
没有用更特殊的种类（如 ENUM_CONSTANT）描述的字段。

PARAMETER

public static final ElementKind PARAMETER
方法或构造方法的参数。

LOCAL_VARIABLE

public static final ElementKind LOCAL_VARIABLE
局部变量。

EXCEPTION_PARAMETER

public static final ElementKind EXCEPTION_PARAMETER
异常处理程序的参数。

METHOD

public static final ElementKind METHOD
一个方法。

CONSTRUCTOR

public static final ElementKind CONSTRUCTOR
一个构造方法。

STATIC_INIT

public static final ElementKind STATIC_INIT
一个静态初始化程序。

INSTANCE_INIT

public static final ElementKind INSTANCE_INIT
一个常量初始化程序。

TYPE_PARAMETER

public static final ElementKind TYPE_PARAMETER
一个类型参数。

OTHER

public static final ElementKind OTHER
一个为实现保留的元素。此元素不能是正在查找的元素。

方法详细信息

values

public static final ElementKind[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(ElementKind c : ElementKind.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static ElementKind valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

isClass

public boolean isClass()
如果此元素是以下种类的类，则返回 true：CLASS 或 ENUM。

返回：
如果此元素是某种类，则返回 true

isInterface

public boolean isInterface()
如果此元素是以下种类的接口，则返回 true：INTERFACE 或 ANNOTATION_TYPE。

返回：
如果此元素是某种接口，则返回 true

isField

public boolean isField()
如果此元素是以下种类的字段，则返回 true：FIELD 或 ENUM_CONSTANT。

返回：
如果此元素是某种字段，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


ElementVisitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 ElementVisitor<R,P>

类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已知实现类：
AbstractElementVisitor6, ElementKindVisitor6, ElementScanner6, SimpleElementVisitor6
public interface ElementVisitor<R,P>

程序元素的 visitor，使用 visitor 设计模式的样式。在编译时某个元素的种类未知时，实现此接口的类被用来对该元素进行操作。在将 visitor 传递给某个元素的 accept 方法时，调用适用于该元素的 visitXYZ 方法。

如果附加参数 p 为 null，则实现此接口的类有可能抛出 NullPointerException；有关详细信息，请参阅实现类的文档。

警告： 以后可能会向此接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，直接实现此接口的 visitor 类可能与平台的未来版本不兼容。为了避免这种不兼容性，建议 visitor 实现扩展实现此接口的抽象 visitor 类。不过，API 通常应该使用此 visitor 接口作为参数类型、返回类型等，而不是将它作为抽象类之一。

从以下版本开始：
1.6
另请参见：
AbstractElementVisitor6

方法摘要
R | visit(Element e) 等效于 v.visit(e, null) 的便捷方法。
R | visit(Element e, P p) 访问一个元素。
R | visitExecutable(ExecutableElement e, P p) 访问 executable 元素。
R | visitPackage(PackageElement e, P p) 访问包元素。
R | visitType(TypeElement e, P p) 访问类型元素。
R | visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | visitUnknown(Element e, P p) 访问未知种类的元素。
R | visitVariable(VariableElement e, P p) 访问变量元素。

方法详细信息

visit

R visit(Element e,
        P p)
访问一个元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visit

R visit(Element e)
等效于 v.visit(e, null) 的便捷方法。

参数：
e - 要访问的元素
返回：
特定于 visitor 的结果

visitPackage

R visitPackage(PackageElement e,
               P p)
访问包元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitType

R visitType(TypeElement e,
            P p)
访问类型元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitVariable

R visitVariable(VariableElement e,
                P p)
访问变量元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitExecutable

R visitExecutable(ExecutableElement e,
                  P p)
访问 executable 元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitTypeParameter

R visitTypeParameter(TypeParameterElement e,
                     P p)
访问类型参数元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitUnknown

R visitUnknown(Element e,
               P p)
访问未知种类的元素。如果语言有所发展并且向 Element 层次结构中添加了新种类的元素，则会发生这种情况。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果
抛出：
UnknownElementException - visitor 实现可以有选择地抛出此异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExecutableElement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 ExecutableElement

所有超级接口：
Element
public interface ExecutableElement
extends Element

表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。

从以下版本开始：
1.6
另请参见：
ExecutableType

方法摘要
AnnotationValue | getDefaultValue() 如果此 executable 是一个注释类型元素，则返回默认值。
List<? extends VariableElement> | getParameters() 返回此 executable 的形参。
TypeMirror | getReturnType() 返回此 executable 的返回类型。
List<? extends TypeMirror> | getThrownTypes() 按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。
List<? extends TypeParameterElement> | getTypeParameters() 按照声明顺序返回此 executable 的形式类型参数。
boolean | isVarArgs() 如果此方法或构造方法接受可变数量的参数，则返回 true，否则返回 false。
从接口 javax.lang.model.element.Element 继承的方法
accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, getSimpleName, hashCode

方法详细信息

getTypeParameters

List<? extends TypeParameterElement> getTypeParameters()
按照声明顺序返回此 executable 的形式类型参数。

返回：
形式类型参数；如果没有，则返回一个空列表

getReturnType

TypeMirror getReturnType()
返回此 executable 的返回类型。如果此 executable 不是一个方法或者是一个不返回值的方法，则返回一个种类为 VOID 的 NoType。

返回：
此 executable 的返回类型

getParameters

List<? extends VariableElement> getParameters()
返回此 executable 的形参。按声明顺序返回这些参数。

返回：
形参；如果没有，则返回一个空列表

isVarArgs

boolean isVarArgs()
如果此方法或构造方法接受可变数量的参数，则返回 true，否则返回 false。

返回：
如果此方法或构造方法接受可变数量的参数，则返回 true，否则返回 false

getThrownTypes

List<? extends TypeMirror> getThrownTypes()
按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。

返回：
throws 子句中所列出的异常和其他 throwable；如果没有，则返回一个空列表

getDefaultValue

AnnotationValue getDefaultValue()
如果此 executable 是一个注释类型元素，则返回默认值。如果此方法不是注释类型元素，或者它是一个没有默认值的注释类型元素，则返回 null。

返回：
默认值；如果没有，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Modifier (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.lang.model.element
枚举 Modifier

java.lang.Object
    继承者  java.lang.Enum<Modifier>
        继承者  javax.lang.model.element.Modifier
所有已实现的接口：
Serializable, Comparable<Modifier>
public enum Modifier
extends Enum<Modifier>

表示程序元素（如类、方法或字段）上的修饰符。

并非所有修饰符都适用于所有种类的元素。当两个或多个修饰符出现在某一元素的源代码中时，那么按照惯例（尽管没有要求），它们出现的顺序与以下详细内容中列出常量的顺序相同。

注意，在平台的未来版本中可能添加其他修饰符。

从以下版本开始：
1.6

枚举常量摘要
ABSTRACT
修饰符 abstract
FINAL
修饰符 final
NATIVE
修饰符 native
PRIVATE
修饰符 private
PROTECTED
修饰符 protected
PUBLIC
修饰符 public
STATIC
修饰符 static
STRICTFP
修饰符 strictfp
SYNCHRONIZED
修饰符 synchronized
TRANSIENT
修饰符 transient
VOLATILE
修饰符 volatile
方法摘要
String | toString() 返回此修饰符的小写名称。
static Modifier | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Modifier[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

PUBLIC

public static final Modifier PUBLIC
修饰符 public

PROTECTED

public static final Modifier PROTECTED
修饰符 protected

PRIVATE

public static final Modifier PRIVATE
修饰符 private

ABSTRACT

public static final Modifier ABSTRACT
修饰符 abstract

STATIC

public static final Modifier STATIC
修饰符 static

FINAL

public static final Modifier FINAL
修饰符 final

TRANSIENT

public static final Modifier TRANSIENT
修饰符 transient

VOLATILE

public static final Modifier VOLATILE
修饰符 volatile

SYNCHRONIZED

public static final Modifier SYNCHRONIZED
修饰符 synchronized

NATIVE

public static final Modifier NATIVE
修饰符 native

STRICTFP

public static final Modifier STRICTFP
修饰符 strictfp

方法详细信息

values

public static final Modifier[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(Modifier c : Modifier.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static Modifier valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

toString

public String toString()
返回此修饰符的小写名称。

覆盖：
类 Enum<Modifier> 中的 toString
返回：
枚举常量的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Name (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 Name

所有超级接口：
CharSequence
public interface Name
extends CharSequence

字符的不可变序列。当由相同实现创建时，实现此接口的对象在相互比较时必须遵守常规 equals 约定。所以，取自相同实现中的 Name 对象可在集合中使用，而取自不同实现的 Name 可能无法在集合中正常使用。

空 Name 的长度为 0。

在注释处理的上下文中，对“相同”实现的保证必须包括处理器的API 间接副作用在其中彼此可见的上下文，包括连续的注释处理 round。

从以下版本开始：
1.6
另请参见：
Elements.getName(java.lang.CharSequence)

方法摘要
boolean | contentEquals(CharSequence cs) 将此名称与指定的 CharSequence 进行比较。
boolean | equals(Object obj) 如果参数表示与 this 相同的名称，则返回 true，否则返回 false。
int | hashCode() 遵守 Object.hashCode 的常规协定。
从接口 java.lang.CharSequence 继承的方法
charAt, length, subSequence, toString

方法详细信息

equals

boolean equals(Object obj)
如果参数表示与 this 相同的名称，则返回 true，否则返回 false。

注意，Name 的身份由其内容（字符序列）及创建它的实现共同决定。

覆盖：
类 Object 中的 equals
参数：
obj - 将与此元素进行比较的对象
返回：
如果指定对象表示与此名称相同的名称，则返回 true
另请参见：
Element.equals(java.lang.Object)

hashCode

int hashCode()
遵守 Object.hashCode 的常规协定。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
equals(java.lang.Object)

contentEquals

boolean contentEquals(CharSequence cs)
将此名称与指定的 CharSequence 进行比较。当且仅当此名称表示与指定序列相同的 char 值序列时，结果为 true。

参数：
cs - 将与此名称进行比较的序列
返回：
如果此名称表示与指定序列相同的 char 值序列时，则返回 true，否则返回 false
另请参见：
String.contentEquals(CharSequence)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NestingKind (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.lang.model.element
枚举 NestingKind

java.lang.Object
    继承者  java.lang.Enum<NestingKind>
        继承者  javax.lang.model.element.NestingKind
所有已实现的接口：
Serializable, Comparable<NestingKind>
public enum NestingKind
extends Enum<NestingKind>

某一类型元素的嵌套种类 (nesting kind)。类型元素的种类有四种：top-level（顶层）、member（成员）、local（局部）和 anonymous（匿名）。嵌套种类 是一个非标准术语，在这里使用它是为了表示这种分类。

注意，在平台的未来版本中可能添加其他嵌套种类。

示例： 以下类是使用其嵌套种类注释的。

import java.lang.annotation.*;
 import static java.lang.annotation.RetentionPolicy.*;
 import javax.lang.model.element.*;
 import static javax.lang.model.element.NestingKind.*;

 @Nesting(TOP_LEVEL)
 public class NestingExamples {
     @Nesting(MEMBER)
     static class MemberClass1{}

     @Nesting(MEMBER)
     class MemberClass2{}

     public static void main(String... argv) {
         @Nesting(LOCAL)
         class LocalClass{};

         Class<?>[] classes = {
             NestingExamples.class,
             MemberClass1.class,
             MemberClass2.class,
             LocalClass.class
         };

         for(Class<?> clazz : classes) {
             System.out.format("%s is %s%n",
                               clazz.getName(),
                               clazz.getAnnotation(Nesting.class).value());
         }
     }
 }

 @Retention(RUNTIME)
 @interface Nesting {
     NestingKind value();
 }

从以下版本开始：
1.6

枚举常量摘要
ANONYMOUS
LOCAL
MEMBER
TOP_LEVEL
方法摘要
boolean | isNested() 此常量是否对应于嵌套类型元素？嵌套 (nested) 类型元素是任何非顶层的元素。
static NestingKind | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static NestingKind[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

TOP_LEVEL

public static final NestingKind TOP_LEVEL

MEMBER

public static final NestingKind MEMBER

LOCAL

public static final NestingKind LOCAL

ANONYMOUS

public static final NestingKind ANONYMOUS
方法详细信息

values

public static final NestingKind[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(NestingKind c : NestingKind.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static NestingKind valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

isNested

public boolean isNested()
此常量是否对应于嵌套类型元素？嵌套 (nested) 类型元素是任何非顶层的元素。内部 (inner) 类型元素是任何非 static 的嵌套类型元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


PackageElement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 PackageElement

所有超级接口：
Element
public interface PackageElement
extends Element

表示一个包程序元素。提供对有关包及其成员的信息的访问。

从以下版本开始：
1.6
另请参见：
Elements.getPackageOf(javax.lang.model.element.Element)

方法摘要
Name | getQualifiedName() 返回此包的完全限定名称。
boolean | isUnnamed() 如果此包是一个未命名的包，则返回 true，否则返回 false。
从接口 javax.lang.model.element.Element 继承的方法
accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, getSimpleName, hashCode

方法详细信息

getQualifiedName

Name getQualifiedName()
返回此包的完全限定名称。该名称也是包的规范 名称。

返回：
此包的完全限定名称；如果此包是一个未命名的包，则返回一个空名称

isUnnamed

boolean isUnnamed()
如果此包是一个未命名的包，则返回 true，否则返回 false。

返回：
如果此包一个未命名的包，则返回 true，否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeElement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 TypeElement

所有超级接口：
Element
public interface TypeElement
extends Element

表示一个类或接口程序元素。提供对有关类型及其成员的信息的访问。注意，枚举类型是一种类，而注释类型是一种接口。

TypeElement 表示一个类或接口元素，而 DeclaredType 表示一个类或接口类型，后者将成为前者的一种使用（或调用）。这种区别对于一般的类型是最明显的，对于这些类型，单个元素可以定义一系列完整的类型。例如，元素 java.util.Set 对应于参数化类型 java.util.Set<String> 和 java.util.Set<Number>（以及其他许多类型），还对应于原始类型 java.util.Set。

此接口每一个都返回元素列表的方法都将按照这些元素在程序信息底层源代码中的自然顺序返回它们。例如，如果信息的底层源代码是 Java 源代码，则按照源代码顺序返回这些元素。

从以下版本开始：
1.6
另请参见：
DeclaredType

方法摘要
List<? extends TypeMirror> | getInterfaces() 返回直接由此类实现或直接由此接口扩展的接口类型。
NestingKind | getNestingKind() 返回此类型元素的嵌套种类 (nesting kind)。
Name | getQualifiedName() 返回此类型元素的完全限定名称。
TypeMirror | getSuperclass() 返回此类型元素的直接超类。
List<? extends TypeParameterElement> | getTypeParameters() 按照声明顺序返回此类型元素的形式类型参数。
从接口 javax.lang.model.element.Element 继承的方法
accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, getSimpleName, hashCode

方法详细信息

getNestingKind

NestingKind getNestingKind()
返回此类型元素的嵌套种类 (nesting kind)。

返回：
此类型元素的嵌套种类

getQualifiedName

Name getQualifiedName()
返回此类型元素的完全限定名称。更准确地说，返回规范 名称。对于没有规范名称的局部类和匿名类，返回一个空名称。

一般类型的名称不包括对其形式类型参数的任何引用。例如，接口 java.util.Set<E> 的完全限定名称是 "java.util.Set"。嵌套类型使用 "." 作为分隔符，如 "java.util.Map.Entry" 中所示。

返回：
此类或接口的完全限定名称；如果没有，则返回一个空名称
另请参见：
Elements.getBinaryName(javax.lang.model.element.TypeElement)

getSuperclass

TypeMirror getSuperclass()
返回此类型元素的直接超类。如果此类型元素表示一个接口或者类 java.lang.Object，则返回一个种类为 NONE 的 NoType。

返回：
直接超类；如果没有，则返回 NoType

getInterfaces

List<? extends TypeMirror> getInterfaces()
返回直接由此类实现或直接由此接口扩展的接口类型。

返回：
直接由此类实现或直接由此接口扩展的接口类型；如果没有，则返回一个空列表

getTypeParameters

List<? extends TypeParameterElement> getTypeParameters()
按照声明顺序返回此类型元素的形式类型参数。

返回：
形式类型参数；如果没有，则返回一个空列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeParameterElement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 TypeParameterElement

所有超级接口：
Element
public interface TypeParameterElement
extends Element

表示一般类、接口、方法或构造方法元素的形式类型参数。类型参数声明一个 TypeVariable。

从以下版本开始：
1.6
另请参见：
TypeVariable

方法摘要
List<? extends TypeMirror> | getBounds() 返回此类型参数的边界。
Element | getGenericElement() 返回由此类型参数参数化的一般类、接口、方法或构造方法。
从接口 javax.lang.model.element.Element 继承的方法
accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, getSimpleName, hashCode

方法详细信息

getGenericElement

Element getGenericElement()
返回由此类型参数参数化的一般类、接口、方法或构造方法。

返回：
由此类型参数参数化的一般类、接口、方法或构造方法

getBounds

List<? extends TypeMirror> getBounds()
返回此类型参数的边界。它们是用来声明此类型参数的 extends 子句所指定的类型。如果没有使用显式的 extends 子句，则认为 java.lang.Object 是唯一的边界。

返回：
此类型参数的边界；如果没有，则返回一个空列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownAnnotationValueException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
类 UnknownAnnotationValueException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.lang.model.element.UnknownAnnotationValueException
所有已实现的接口：
Serializable
public class UnknownAnnotationValueException
extends RuntimeException

指示遇到一个未知种类的注释值。如果语言有所发展并且新种类的注释值可以存储在注释中，则会发生这种情况。该异常可能由注释值 visitor 抛出，指示已经为以前的语言版本创建了 visitor。

从以下版本开始：
1.6
另请参见：
AnnotationValueVisitor.visitUnknown(javax.lang.model.element.AnnotationValue, P), 序列化表格

构造方法摘要
UnknownAnnotationValueException(AnnotationValue av, Object p)
创建一个新的 UnknownAnnotationValueException。
方法摘要
Object | getArgument() 返回附加参数。
AnnotationValue | getUnknownAnnotationValue() 返回未知注释值。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownAnnotationValueException

public UnknownAnnotationValueException(AnnotationValue av,
                                       Object p)
创建一个新的 UnknownAnnotationValueException。可以使用 p 参数传入一个带有上下文（在该上下文中遇到未知元素）信息的附加参数；例如，AnnotationValueVisitor 的 visit 方法可以传入其附加参数。

参数：
av - 未知注释值，可以为 null
p - 附加参数，可以为 null
方法详细信息

getUnknownAnnotationValue

public AnnotationValue getUnknownAnnotationValue()
返回未知注释值。如果已经序列化此异常并随后将其读回，则该值将不可用。

返回：
未知元素；如果不可用，则返回 null

getArgument

public Object getArgument()
返回附加参数。

返回：
附加参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownElementException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
类 UnknownElementException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.lang.model.element.UnknownElementException
所有已实现的接口：
Serializable
public class UnknownElementException
extends RuntimeException

指示遇到一个未知种类的元素。如果语言有所发展并且向 Element 层次结构中添加了新种类的元素，则会发生这种情况。该异常可能由元素 visitor 抛出，指示已经为以前的语言版本创建了 visitor。

从以下版本开始：
1.6
另请参见：
ElementVisitor.visitUnknown(javax.lang.model.element.Element, P), 序列化表格

构造方法摘要
UnknownElementException(Element e, Object p)
创建一个新的 UnknownElementException。
方法摘要
Object | getArgument() 返回附加参数。
Element | getUnknownElement() 返回未知元素。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownElementException

public UnknownElementException(Element e,
                               Object p)
创建一个新的 UnknownElementException。可以使用 p 参数传入一个带有上下文（在该上下文中遇到未知元素）信息的附加参数；例如，ElementVisitor 的 visit 方法可以传入其附加参数。

参数：
e - 未知元素，可以为 null
p - 附加参数，可以为 null
方法详细信息

getUnknownElement

public Element getUnknownElement()
返回未知元素。如果已经序列化此异常并随后将其读回，则该值将不可用。

返回：
未知元素；如果不可用，则返回 null

getArgument

public Object getArgument()
返回附加参数。

返回：
附加参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VariableElement (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.element
接口 VariableElement

所有超级接口：
Element
public interface VariableElement
extends Element

表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。

从以下版本开始：
1.6

方法摘要
 Object getConstantValue()
如果此变量是一个被初始化为编译时常量的 static final 字段，则返回此变量的值。
从接口 javax.lang.model.element.Element 继承的方法
accept, asType, equals, getAnnotation, getAnnotationMirrors, getEnclosedElements, getEnclosingElement, getKind, getModifiers, getSimpleName, hashCode

方法详细信息

getConstantValue

Object getConstantValue()
如果此变量是一个被初始化为编译时常量的 static final 字段，则返回此变量的值。否则返回 null。该值为基本类型或 String。如果该值为基本类型，则它被包装在适当的包装类中（比如 Integer）。

注意，并非所有的 static final 字段都将具有常量值。特别是，enum 常量不 被认为是编译时常量。要获得一个常量值，字段的类型必须是基本类型或 String。

返回：
如果此变量是一个被初始化为编译时常量的 static final 字段，则返回此变量的值，否则返回 null
另请参见：
Elements.getConstantExpression(Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.lang.model.element (Java 2 Platform SE 6)

 javax.lang.model.element
接口
AnnotationMirror
AnnotationValue
AnnotationValueVisitor
Element
ElementVisitor
ExecutableElement
Name
PackageElement
TypeElement
TypeParameterElement
VariableElement
枚举
ElementKind
Modifier
NestingKind
异常
UnknownAnnotationValueException
UnknownElementException


javax.lang.model.element (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.lang.model.element

用于 Java 编程语言的模型元素的接口。

请参见：
描述

接口摘要
AnnotationMirror | 表示一个注释。
AnnotationValue | 表示注释类型元素的值。
AnnotationValueVisitor<R,P> | 注释类型元素值的 visitor，使用 visitor 设计模式的变体。
Element | 表示一个程序元素，比如包、类或者方法。
ElementVisitor<R,P> | 程序元素的 visitor，使用 visitor 设计模式的样式。
ExecutableElement | 表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
Name | 字符的不可变序列。
PackageElement | 表示一个包程序元素。
TypeElement | 表示一个类或接口程序元素。
TypeParameterElement | 表示一般类、接口、方法或构造方法元素的形式类型参数。
VariableElement | 表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。

枚举摘要
ElementKind | 元素的 kind。
Modifier | 表示程序元素（如类、方法或字段）上的修饰符。
NestingKind | 某一类型元素的嵌套种类 (nesting kind)。

异常摘要
UnknownAnnotationValueException | 指示遇到一个未知种类的注释值。
UnknownElementException | 指示遇到一个未知种类的元素。

软件包 javax.lang.model.element 的描述

用于 Java 编程语言的模型元素的接口。

当在注释处理的上下文中使用时，必须返回要表示的元素的准确模型。因为这是一个语言模型，所以源代码提供相关构造的基准（引用）表示形式，而不是 executable 输出（如类文件）中的表示形式。executable 输出可作为创建建模元素的基础。不过，将源代码转换为 executable 输出的过程中可能不允许恢复源代码表示形式的某些方面。例如，无法从类文件恢复带有 source retention 的注释，并且类文件无法提供源位置信息。某一元素上的修饰符在某些情况下可能有所不同，这些情况包括：

  • 某个类或接口上的 strictfp
  • 某个参数上的 final
  • 类和接口上的 protected、private 和 static
此外，类文件中的复合构造方法（例如，用来实现嵌套类的存取方法和用来实现协变返回的 bridge 方法）是此模型以外的转换产物。

进行注释处理期间，必然会在不完整或错误的程序上进行操作；但是，有关所得模型特性的保证更少。如果源代码在语法结构上不是很好，则可能会提供一个模型作为实现问题的质量。如果某一程序在语法上是有效的，但在其他某些方面有问题，则返回模型包含的信息不得少于程序中所有方法正文被 "throw new RuntimeException();" 替代时所包含的信息。如果某一程序引用缺失类型 XYZ，则返回模型包含的信息不得少于类型 XYZ 的声明被假定为 "class XYZ {}"、"interface XYZ {}"、"enum XYZ {}" 或 "@interface XYZ {}" 时所包含的信息。如果某一程序引用缺失类型 XYZ<K1, ... ,Kn>，则返回模型包含的信息不得少于 XYZ 的声明被假定为 "class XYZ<T1, ... ,Tn> {}" 或 "interface XYZ<T1, ... ,Tn> {}" 时所包含的信息。

除非在特定实现中另行指定，否则此包中的方法所返回的集合应该是不能由调用者修改的，并且对于并发访问是不安全的。

除非另行指定，否则，如果给定一个 null 参数，此包中的方法将抛出 NullPointerException。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.lang.model.element 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model.element 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.lang.model.element.UnknownAnnotationValueException
          • javax.lang.model.element.UnknownElementException

接口分层结构

  • javax.lang.model.element.AnnotationMirror
  • javax.lang.model.element.AnnotationValue
  • javax.lang.model.element.AnnotationValueVisitor<R,P>
  • java.lang.CharSequence
    • javax.lang.model.element.Name
  • javax.lang.model.element.Element
    • javax.lang.model.element.ExecutableElement
    • javax.lang.model.element.PackageElement
    • javax.lang.model.element.TypeElement
    • javax.lang.model.element.TypeParameterElement
    • javax.lang.model.element.VariableElement
  • javax.lang.model.element.ElementVisitor<R,P>

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.lang.model.element.ElementKind
      • javax.lang.model.element.Modifier
      • javax.lang.model.element.NestingKind
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.lang.model.element 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model.element
的使用

使用 javax.lang.model.element 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 使用的 javax.lang.model.element 中的类
AnnotationMirror
表示一个注释。
AnnotationValue
表示注释类型元素的值。
Element
表示一个程序元素，比如包、类或者方法。
ExecutableElement
表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
TypeElement
表示一个类或接口程序元素。

javax.lang.model.element 使用的 javax.lang.model.element 中的类
AnnotationMirror
表示一个注释。
AnnotationValue
表示注释类型元素的值。
AnnotationValueVisitor
注释类型元素值的 visitor，使用 visitor 设计模式的变体。
Element
表示一个程序元素，比如包、类或者方法。
ElementKind
元素的 kind。
ElementVisitor
程序元素的 visitor，使用 visitor 设计模式的样式。
ExecutableElement
表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
Modifier
表示程序元素（如类、方法或字段）上的修饰符。
Name
字符的不可变序列。
NestingKind
某一类型元素的嵌套种类 (nesting kind)。
PackageElement
表示一个包程序元素。
TypeElement
表示一个类或接口程序元素。
TypeParameterElement
表示一般类、接口、方法或构造方法元素的形式类型参数。
VariableElement
表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。

javax.lang.model.type 使用的 javax.lang.model.element 中的类
Element
表示一个程序元素，比如包、类或者方法。

javax.lang.model.util 使用的 javax.lang.model.element 中的类
AnnotationMirror
表示一个注释。
AnnotationValue
表示注释类型元素的值。
AnnotationValueVisitor
注释类型元素值的 visitor，使用 visitor 设计模式的变体。
Element
表示一个程序元素，比如包、类或者方法。
ElementVisitor
程序元素的 visitor，使用 visitor 设计模式的样式。
ExecutableElement
表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
Name
字符的不可变序列。
PackageElement
表示一个包程序元素。
TypeElement
表示一个类或接口程序元素。
TypeParameterElement
表示一般类、接口、方法或构造方法元素的形式类型参数。
VariableElement
表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。

javax.tools 使用的 javax.lang.model.element 中的类
Modifier
表示程序元素（如类、方法或字段）上的修饰符。
NestingKind
某一类型元素的嵌套种类 (nesting kind)。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.Name 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.Name
的使用

使用 Name 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 Name 的使用

返回 Name 的 javax.lang.model.element 中的方法
Name | PackageElement.getQualifiedName() 返回此包的完全限定名称。
Name | TypeElement.getQualifiedName() 返回此类型元素的完全限定名称。
Name | Element.getSimpleName() 返回此元素的简单（未限定）名称。

javax.lang.model.util 中 Name 的使用

返回 Name 的 javax.lang.model.util 中的方法
Name | Elements.getBinaryName(TypeElement type) 返回类型元素的二进制名称。
Name | Elements.getName(CharSequence cs) 返回与参数具有相同字符序列的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.AnnotationMirror 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.AnnotationMirror
的使用

使用 AnnotationMirror 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 AnnotationMirror 的使用

参数类型为 AnnotationMirror 的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model.element 中 AnnotationMirror 的使用

返回变量类型为 AnnotationMirror 的类型的 javax.lang.model.element 中的方法
 List<? extends AnnotationMirror> Element.getAnnotationMirrors()
返回直接存在于此元素上的注释。

参数类型为 AnnotationMirror 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visitAnnotation(AnnotationMirror a, P p)
访问注释中的 annotation 值。

javax.lang.model.util 中 AnnotationMirror 的使用

返回变量类型为 AnnotationMirror 的类型的 javax.lang.model.util 中的方法
 List<? extends AnnotationMirror> Elements.getAllAnnotationMirrors(Element e)
返回元素的所有注释，不管是继承的还是直接存在的。

参数类型为 AnnotationMirror 的 javax.lang.model.util 中的方法
Map<? extends ExecutableElement,? extends AnnotationValue> | Elements.getElementValuesWithDefaults(AnnotationMirror a) 返回注释元素的值，包括默认值。
R | SimpleAnnotationValueVisitor6.visitAnnotation(AnnotationMirror a, P p) 访问注释中的 annotation 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.AnnotationValue 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.AnnotationValue
的使用

使用 AnnotationValue 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 AnnotationValue 的使用

参数类型为 AnnotationValue 的 javax.annotation.processing 中的方法
 void Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v)
在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model.element 中 AnnotationValue 的使用

返回 AnnotationValue 的 javax.lang.model.element 中的方法
AnnotationValue | ExecutableElement.getDefaultValue() 如果此 executable 是一个注释类型元素，则返回默认值。
AnnotationValue | UnknownAnnotationValueException.getUnknownAnnotationValue() 返回未知注释值。

返回变量类型为 AnnotationValue 的类型的 javax.lang.model.element 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues()
返回此注释元素的值。

参数类型为 AnnotationValue 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visit(AnnotationValue av)
等效于 v.visit(av, null) 的便捷方法。
 R AnnotationValueVisitor.visit(AnnotationValue av, P p)
访问注释值。
 R AnnotationValueVisitor.visitUnknown(AnnotationValue av, P p)
访问未知种类的注释值。

类型变量类型为 AnnotationValue 的 javax.lang.model.element 中的方法参数
 R AnnotationValueVisitor.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

参数类型为 AnnotationValue 的 javax.lang.model.element 中的构造方法
UnknownAnnotationValueException(AnnotationValue av, Object p)
创建一个新的 UnknownAnnotationValueException。

javax.lang.model.util 中 AnnotationValue 的使用

返回变量类型为 AnnotationValue 的类型的 javax.lang.model.util 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> Elements.getElementValuesWithDefaults(AnnotationMirror a)
返回注释元素的值，包括默认值。

参数类型为 AnnotationValue 的 javax.lang.model.util 中的方法
R | AbstractAnnotationValueVisitor6.visit(AnnotationValue av) 访问注释值，这与将自身传递给该值的 accept 方法，并为附加参数传递 null 一样。
R | AbstractAnnotationValueVisitor6.visit(AnnotationValue av, P p) 访问注释值，这与将自身传递给该值的 accept 方法一样。
R | AbstractAnnotationValueVisitor6.visitUnknown(AnnotationValue av, P p) 访问未知种类的注释值。

类型变量类型为 AnnotationValue 的 javax.lang.model.util 中的方法参数
 R SimpleAnnotationValueVisitor6.visitArray(List<? extends AnnotationValue> vals, P p)
访问注释中的 array 值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.AnnotationValueVisitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.AnnotationValueVisitor
的使用

使用 AnnotationValueVisitor 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 AnnotationValueVisitor 的使用

参数类型为 AnnotationValueVisitor 的 javax.lang.model.element 中的方法
<R,P> R
AnnotationValue.accept(AnnotationValueVisitor<R,P> v, P p)
将一个 visitor 应用到此值。

javax.lang.model.util 中 AnnotationValueVisitor 的使用

实现 AnnotationValueVisitor 的 javax.lang.model.util 中的类
class | AbstractAnnotationValueVisitor6<R,P> 注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleAnnotationValueVisitor6<R,P> 注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.Element 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.Element
的使用

使用 Element 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 Element 的使用

返回变量类型为 Element 的类型的 javax.annotation.processing 中的方法
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(Class<? extends Annotation> a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getElementsAnnotatedWith(TypeElement a) 返回使用给定注释类型注释的元素。
Set<? extends Element> | RoundEnvironment.getRootElements() 返回以前的 round 生成的注释处理根元素。

参数类型为 Element 的 javax.annotation.processing 中的方法
JavaFileObject | Filer.createClassFile(CharSequence name, Element... originatingElements) 创建一个新的类文件，并返回一个对象以允许写入它。
FileObject | Filer.createResource(JavaFileManager.Location location, CharSequence pkg, CharSequence relativeName, Element... originatingElements) 创建一个用于写入操作的新辅助资源文件，并为它返回一个文件对象。
JavaFileObject | Filer.createSourceFile(CharSequence name, Element... originatingElements) 创建一个新的源文件，并返回一个对象以允许写入它。
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e) 在元素的位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a) 在已注释元素的注释镜像位置上打印指定种类的消息。
void | Messager.printMessage(Diagnostic.Kind kind, CharSequence msg, Element e, AnnotationMirror a, AnnotationValue v) 在已注释元素的注释镜像内部注释值的位置上打印指定种类的消息。

javax.lang.model.element 中 Element 的使用

javax.lang.model.element 中 Element 的子接口
interface | ExecutableElement 表示某个类或接口的方法、构造方法或初始化程序（静态或实例），包括注释类型元素。
interface | PackageElement 表示一个包程序元素。
interface | TypeElement 表示一个类或接口程序元素。
interface | TypeParameterElement 表示一般类、接口、方法或构造方法元素的形式类型参数。
interface | VariableElement 表示一个字段、enum 常量、方法或构造方法参数、局部变量或异常参数。

返回 Element 的 javax.lang.model.element 中的方法
Element | Element.getEnclosingElement() 返回封装此元素（非严格意义上）的最里层元素。
Element | TypeParameterElement.getGenericElement() 返回由此类型参数参数化的一般类、接口、方法或构造方法。
Element | UnknownElementException.getUnknownElement() 返回未知元素。

返回变量类型为 Element 的类型的 javax.lang.model.element 中的方法
 List<? extends Element> Element.getEnclosedElements()
返回此元素直接封装（非严格意义上）的元素。

参数类型为 Element 的 javax.lang.model.element 中的方法
 R ElementVisitor.visit(Element e)
等效于 v.visit(e, null) 的便捷方法。
 R ElementVisitor.visit(Element e, P p)
访问一个元素。
 R ElementVisitor.visitUnknown(Element e, P p)
访问未知种类的元素。

参数类型为 Element 的 javax.lang.model.element 中的构造方法
UnknownElementException(Element e, Object p)
创建一个新的 UnknownElementException。

javax.lang.model.type 中 Element 的使用

返回 Element 的 javax.lang.model.type 中的方法
Element | DeclaredType.asElement() 返回对应于此类型的元素。
Element | TypeVariable.asElement() 返回对应于此类型变量的元素。

javax.lang.model.util 中 Element 的使用

返回 Element 的 javax.lang.model.util 中的方法
 Element Types.asElement(TypeMirror t)
返回对应于类型的元素。

返回变量类型为 Element 的类型的 javax.lang.model.util 中的方法
 List<? extends Element> Elements.getAllMembers(TypeElement type)
返回类型元素的所有成员，不管是继承的还是直接声明的。

参数类型为 Element 的 javax.lang.model.util 中的方法
 TypeMirror Types.asMemberOf(DeclaredType containing, Element element)
当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
protected  R SimpleElementVisitor6.defaultAction(Element e, P p)
visit 方法的默认动作。
 List<? extends AnnotationMirror> Elements.getAllAnnotationMirrors(Element e)
返回元素的所有注释，不管是继承的还是直接存在的。
 String Elements.getDocComment(Element e)
返回元素的文档（"Javadoc"）注释文本。
 PackageElement Elements.getPackageOf(Element type)
返回元素的包。
 boolean Elements.hides(Element hider, Element hidden)
测试一个类型、方法或字段是否隐藏了另一个类型、方法或字段。
 boolean Elements.isDeprecated(Element e)
如果元素已过时，则返回 true，否则返回 false。
 void Elements.printElements(Writer w, Element... elements)
按指定顺序将元素的表示形式打印到给定 writer。
 R ElementScanner6.scan(Element e)
等效于 v.scan(e, null) 的便捷方法。
 R ElementScanner6.scan(Element e, P p)
通过调用 e.accept(this, p) 处理元素；此方法可被子类重写。
 R AbstractElementVisitor6.visit(Element e)
访问任何程序元素，这与将自身传递给该元素的 accept 方法，并为附加参数传递 null 一样。
 R AbstractElementVisitor6.visit(Element e, P p)
访问任何程序元素，这与将自身传递给该元素的 accept 方法一样。
 R AbstractElementVisitor6.visitUnknown(Element e, P p)
访问未知种类的元素。

类型变量类型为 Element 的 javax.lang.model.util 中的方法参数
static List<ExecutableElement> ElementFilter.constructorsIn(Iterable<? extends Element> elements)
elements 中构造方法的列表。
static Set<ExecutableElement> ElementFilter.constructorsIn(Set<? extends Element> elements)
返回 elements 中构造方法的集合。
static List<VariableElement> ElementFilter.fieldsIn(Iterable<? extends Element> elements)
返回 elements 中字段的列表。
static Set<VariableElement> ElementFilter.fieldsIn(Set<? extends Element> elements)
返回 elements 中字段的集合。
static List<ExecutableElement> ElementFilter.methodsIn(Iterable<? extends Element> elements)
返回 elements 中方法的列表。
static Set<ExecutableElement> ElementFilter.methodsIn(Set<? extends Element> elements)
返回 elements 中方法的集合。
static List<PackageElement> ElementFilter.packagesIn(Iterable<? extends Element> elements)
返回 elements 中包的列表。
static Set<PackageElement> ElementFilter.packagesIn(Set<? extends Element> elements)
返回 elements 中包的集合。
 R ElementScanner6.scan(Iterable<? extends Element> iterable, P p)
迭代给定元素并对每个元素调用 scan(Element, P)。
static List<TypeElement> ElementFilter.typesIn(Iterable<? extends Element> elements)
返回 elements 中类型的列表。
static Set<TypeElement> ElementFilter.typesIn(Set<? extends Element> elements)
返回 elements 中类型的集合。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.element.ElementKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.ElementKind
的使用

使用 ElementKind 的软件包
javax.lang.model.element 用于 Java 编程语言的模型元素的接口。

javax.lang.model.element 中 ElementKind 的使用

返回 ElementKind 的 javax.lang.model.element 中的方法
ElementKind | Element.getKind() 返回此元素的类型。
static ElementKind | ElementKind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static ElementKind[] | ElementKind.values() Returns an array containing the constants of this enum type, in the order they are declared.

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.ElementVisitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.ElementVisitor
的使用

使用 ElementVisitor 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 ElementVisitor 的使用

参数类型为 ElementVisitor 的 javax.lang.model.element 中的方法
<R,P> R
Element.accept(ElementVisitor<R,P> v, P p)
将一个 visitor 应用到此元素。

javax.lang.model.util 中 ElementVisitor 的使用

实现 ElementVisitor 的 javax.lang.model.util 中的类
class | AbstractElementVisitor6<R,P> 程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementKindVisitor6<R,P> 基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementScanner6<R,P> 程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleElementVisitor6<R,P> 程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.ExecutableElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.ExecutableElement
的使用

使用 ExecutableElement 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 ExecutableElement 的使用

参数类型为 ExecutableElement 的 javax.annotation.processing 中的方法
Iterable<? extends Completion> | AbstractProcessor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 返回一个空的 completion 迭代。
Iterable<? extends Completion> | Processor.getCompletions(Element element, AnnotationMirror annotation, ExecutableElement member, String userText) 向工具框架返回某一注释的建议 completion 迭代。

javax.lang.model.element 中 ExecutableElement 的使用

返回变量类型为 ExecutableElement 的类型的 javax.lang.model.element 中的方法
 Map<? extends ExecutableElement,? extends AnnotationValue> AnnotationMirror.getElementValues()
返回此注释元素的值。

参数类型为 ExecutableElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitExecutable(ExecutableElement e, P p)
访问 executable 元素。

javax.lang.model.util 中 ExecutableElement 的使用

返回变量类型为 ExecutableElement 的类型的 javax.lang.model.util 中的方法
static List<ExecutableElement> | ElementFilter.constructorsIn(Iterable<? extends Element> elements) elements 中构造方法的列表。
static Set<ExecutableElement> | ElementFilter.constructorsIn(Set<? extends Element> elements) 返回 elements 中构造方法的集合。
Map<? extends ExecutableElement,? extends AnnotationValue> | Elements.getElementValuesWithDefaults(AnnotationMirror a) 返回注释元素的值，包括默认值。
static List<ExecutableElement> | ElementFilter.methodsIn(Iterable<? extends Element> elements) 返回 elements 中方法的列表。
static Set<ExecutableElement> | ElementFilter.methodsIn(Set<? extends Element> elements) 返回 elements 中方法的集合。

参数类型为 ExecutableElement 的 javax.lang.model.util 中的方法
boolean | Elements.overrides(ExecutableElement overrider, ExecutableElement overridden, TypeElement type) 测试一个方法（作为给定类型的成员）是否重写了另一个方法。
R | ElementKindVisitor6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。
R | ElementScanner6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素。
R | SimpleElementVisitor6.visitExecutable(ExecutableElement e, P p) 访问 executable 元素。
R | ElementKindVisitor6.visitExecutableAsConstructor(ExecutableElement e, P p) 通过调用 defaultAction 访问 CONSTRUCTOR executable 元素。
R | ElementKindVisitor6.visitExecutableAsInstanceInit(ExecutableElement e, P p) 通过调用 defaultAction 访问 INSTANCE_INIT executable 元素。
R | ElementKindVisitor6.visitExecutableAsMethod(ExecutableElement e, P p) 通过调用 defaultAction 访问 METHOD executable 元素。
R | ElementKindVisitor6.visitExecutableAsStaticInit(ExecutableElement e, P p) 通过调用 defaultAction 访问 STATIC_INIT executable 元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.element.Modifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.Modifier
的使用

使用 Modifier 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.lang.model.element 中 Modifier 的使用

返回 Modifier 的 javax.lang.model.element 中的方法
static Modifier | Modifier.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static Modifier[] | Modifier.values() Returns an array containing the constants of this enum type, in the order they are declared.

返回变量类型为 Modifier 的类型的 javax.lang.model.element 中的方法
 Set<Modifier> Element.getModifiers()
返回此元素的修饰符，不包括注释。

javax.tools 中 Modifier 的使用

返回 Modifier 的 javax.tools 中的方法
Modifier | ForwardingJavaFileObject.getAccessLevel()
Modifier | JavaFileObject.getAccessLevel() 提供有关此文件对象表示的类的访问级别的提示。
Modifier | SimpleJavaFileObject.getAccessLevel() 此实现返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.element.NestingKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.NestingKind
的使用

使用 NestingKind 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.lang.model.element 中 NestingKind 的使用

返回 NestingKind 的 javax.lang.model.element 中的方法
NestingKind | TypeElement.getNestingKind() 返回此类型元素的嵌套种类 (nesting kind)。
static NestingKind | NestingKind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static NestingKind[] | NestingKind.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.tools 中 NestingKind 的使用

返回 NestingKind 的 javax.tools 中的方法
NestingKind | ForwardingJavaFileObject.getNestingKind()
NestingKind | JavaFileObject.getNestingKind() 提供有关此文件对象表示的类的嵌套层次的提示。
NestingKind | SimpleJavaFileObject.getNestingKind() 此实现返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.PackageElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.PackageElement
的使用

使用 PackageElement 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 PackageElement 的使用

参数类型为 PackageElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitPackage(PackageElement e, P p)
访问包元素。

javax.lang.model.util 中 PackageElement 的使用

返回 PackageElement 的 javax.lang.model.util 中的方法
PackageElement | Elements.getPackageElement(CharSequence name) 返回已给出其完全限定名称的包。
PackageElement | Elements.getPackageOf(Element type) 返回元素的包。

返回变量类型为 PackageElement 的类型的 javax.lang.model.util 中的方法
static List<PackageElement> | ElementFilter.packagesIn(Iterable<? extends Element> elements) 返回 elements 中包的列表。
static Set<PackageElement> | ElementFilter.packagesIn(Set<? extends Element> elements) 返回 elements 中包的集合。

参数类型为 PackageElement 的 javax.lang.model.util 中的方法
R | ElementKindVisitor6.visitPackage(PackageElement e, P p) 访问包元素。
R | ElementScanner6.visitPackage(PackageElement e, P p) 访问包元素。
R | SimpleElementVisitor6.visitPackage(PackageElement e, P p) 访问包元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.TypeElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.TypeElement
的使用

使用 TypeElement 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 中 TypeElement 的使用

参数类型为 TypeElement 的 javax.annotation.processing 中的方法
 Set<? extends Element> RoundEnvironment.getElementsAnnotatedWith(TypeElement a)
返回使用给定注释类型注释的元素。

类型变量类型为 TypeElement 的 javax.annotation.processing 中的方法参数
abstract boolean | AbstractProcessor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。
boolean | Processor.process(Set<? extends TypeElement> annotations, RoundEnvironment roundEnv) 处理先前 round 产生的类型元素上的注释类型集，并返回这些注释是否由此 Processor 声明。

javax.lang.model.element 中 TypeElement 的使用

参数类型为 TypeElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitType(TypeElement e, P p)
访问类型元素。

javax.lang.model.util 中 TypeElement 的使用

返回 TypeElement 的 javax.lang.model.util 中的方法
TypeElement | Types.boxedClass(PrimitiveType p) 返回给定基本类型的装箱 (boxed) 值类型的类。
TypeElement | Elements.getTypeElement(CharSequence name) 返回已给出其规范名称的类型元素。

返回变量类型为 TypeElement 的类型的 javax.lang.model.util 中的方法
static List<TypeElement> | ElementFilter.typesIn(Iterable<? extends Element> elements) 返回 elements 中类型的列表。
static Set<TypeElement> | ElementFilter.typesIn(Set<? extends Element> elements) 返回 elements 中类型的集合。

参数类型为 TypeElement 的 javax.lang.model.util 中的方法
List<? extends Element> | Elements.getAllMembers(TypeElement type) 返回类型元素的所有成员，不管是继承的还是直接声明的。
Name | Elements.getBinaryName(TypeElement type) 返回类型元素的二进制名称。
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
DeclaredType | Types.getDeclaredType(TypeElement typeElem, TypeMirror... typeArgs) 返回对应于类型元素和实际类型参数的类型。
boolean | Elements.overrides(ExecutableElement overrider, ExecutableElement overridden, TypeElement type) 测试一个方法（作为给定类型的成员）是否重写了另一个方法。
R | ElementKindVisitor6.visitType(TypeElement e, P p) 访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。
R | ElementScanner6.visitType(TypeElement e, P p) 访问类型元素。
R | SimpleElementVisitor6.visitType(TypeElement e, P p) 访问类型元素。
R | ElementKindVisitor6.visitTypeAsAnnotationType(TypeElement e, P p) 通过调用 defaultAction 访问 ANNOTATION_TYPE 类型元素。
R | ElementKindVisitor6.visitTypeAsClass(TypeElement e, P p) 通过调用 defaultAction 访问 CLASS 类型元素。
R | ElementKindVisitor6.visitTypeAsEnum(TypeElement e, P p) 通过调用 defaultAction 访问 ENUM 类型元素。
R | ElementKindVisitor6.visitTypeAsInterface(TypeElement e, P p) 通过调用 defaultAction 访问 INTERFACE 类型元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.TypeParameterElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.TypeParameterElement
的使用

使用 TypeParameterElement 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 TypeParameterElement 的使用

返回变量类型为 TypeParameterElement 的类型的 javax.lang.model.element 中的方法
List<? extends TypeParameterElement> | ExecutableElement.getTypeParameters() 按照声明顺序返回此 executable 的形式类型参数。
List<? extends TypeParameterElement> | TypeElement.getTypeParameters() 按照声明顺序返回此类型元素的形式类型参数。

参数类型为 TypeParameterElement 的 javax.lang.model.element 中的方法
 R ElementVisitor.visitTypeParameter(TypeParameterElement e, P p)
访问类型参数元素。

javax.lang.model.util 中 TypeParameterElement 的使用

参数类型为 TypeParameterElement 的 javax.lang.model.util 中的方法
R | ElementKindVisitor6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | ElementScanner6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | SimpleElementVisitor6.visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.element.UnknownAnnotationValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.UnknownAnnotationValueException
的使用

没有 javax.lang.model.element.UnknownAnnotationValueException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.element.UnknownElementException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.element.UnknownElementException
的使用

没有 javax.lang.model.element.UnknownElementException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.element.VariableElement 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.element.VariableElement
的使用

使用 VariableElement 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 VariableElement 的使用

返回变量类型为 VariableElement 的类型的 javax.lang.model.element 中的方法
 List<? extends VariableElement> ExecutableElement.getParameters()
返回此 executable 的形参。

参数类型为 VariableElement 的 javax.lang.model.element 中的方法
R | AnnotationValueVisitor.visitEnumConstant(VariableElement c, P p) 访问注释中的 enum 值。
R | ElementVisitor.visitVariable(VariableElement e, P p) 访问变量元素。

javax.lang.model.util 中 VariableElement 的使用

返回变量类型为 VariableElement 的类型的 javax.lang.model.util 中的方法
static List<VariableElement> | ElementFilter.fieldsIn(Iterable<? extends Element> elements) 返回 elements 中字段的列表。
static Set<VariableElement> | ElementFilter.fieldsIn(Set<? extends Element> elements) 返回 elements 中字段的集合。

参数类型为 VariableElement 的 javax.lang.model.util 中的方法
R | SimpleAnnotationValueVisitor6.visitEnumConstant(VariableElement c, P p) 访问注释中的 enum 值。
R | ElementKindVisitor6.visitVariable(VariableElement e, P p) 访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。
R | ElementScanner6.visitVariable(VariableElement e, P p) 访问变量元素。
R | SimpleElementVisitor6.visitVariable(VariableElement e, P p) 访问变量元素。
R | ElementKindVisitor6.visitVariableAsEnumConstant(VariableElement e, P p) 通过调用 defaultAction 访问 ENUM_CONSTANT 变量元素。
R | ElementKindVisitor6.visitVariableAsExceptionParameter(VariableElement e, P p) 通过调用 defaultAction 访问 EXCEPTION_PARAMETER 变量元素。
R | ElementKindVisitor6.visitVariableAsField(VariableElement e, P p) 通过调用 defaultAction 访问 FIELD 变量元素。
R | ElementKindVisitor6.visitVariableAsLocalVariable(VariableElement e, P p) 通过调用 defaultAction 访问 LOCAL_VARIABLE 变量元素。
R | ElementKindVisitor6.visitVariableAsParameter(VariableElement e, P p) 通过调用 defaultAction 访问 PARAMETER 变量元素。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ArrayType (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 ArrayType

所有超级接口：
ReferenceType, TypeMirror
public interface ArrayType
extends ReferenceType

表示一个数组类型。多维数组类型被表示为组件类型也是数组类型的数组类型。

从以下版本开始：
1.6

方法摘要
 TypeMirror getComponentType()
返回此数组类型的组件类型。
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

方法详细信息

getComponentType

TypeMirror getComponentType()
返回此数组类型的组件类型。

返回：
此数组类型的组件类型
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DeclaredType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 DeclaredType

所有超级接口：
ReferenceType, TypeMirror
所有已知子接口：
ErrorType
public interface DeclaredType
extends ReferenceType

表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。这包括参数化的类型（比如 java.util.Set<String>）和原始类型。

TypeElement 表示一个类或接口元素，而 DeclaredType 表示一个类或接口类型，后者将成为前者的一种使用（或调用）。有关这种区别的更多信息，请参见 TypeElement。

可以使用 Types.directSupertypes(TypeMirror) 方法找到已声明类型的超类型（类类型和接口类型）。此方法返回所有类型参数都被替换的超类型。

还可以使用此接口表示交集 (intersection) 类型。交集类型在程序中是隐式声明的，而不是显式声明。例如，类型参数 <T extends Number & Runnable> 的边界是一个交集类型。它由 DeclaredType 表示，使用 Number 作为其超类并使用 Runnable 作为其独立超接口。

从以下版本开始：
1.6
另请参见：
TypeElement

方法摘要
Element | asElement() 返回对应于此类型的元素。
TypeMirror | getEnclosingType() 返回封装实例的最里层类型；如果没有任何封装实例，则返回种类为 NONE 的 NoType。
List<? extends TypeMirror> | getTypeArguments() 返回此类型的实际类型参数。
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

方法详细信息

asElement

Element asElement()
返回对应于此类型的元素。

返回：
对应于此类型的元素

getEnclosingType

TypeMirror getEnclosingType()
返回封装实例的最里层类型；如果没有任何封装实例，则返回种类为 NONE 的 NoType。只有对应于内部类的类型才具有封装实例。

返回：
封装类型的类型镜像

getTypeArguments

List<? extends TypeMirror> getTypeArguments()
返回此类型的实际类型参数。对于嵌套在已参数化类型中的类型（比如 Outer<String>.Inner<Number>），只包括最里层类型的类型参数。

返回：
此类型的实际类型参数；如果没有，则返回一个空列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ErrorType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 ErrorType

所有超级接口：
DeclaredType, ReferenceType, TypeMirror
public interface ErrorType
extends DeclaredType

表示无法正常建模的类或接口类型。这可能是处理错误（比如一个缺失的类文件或者错误源代码）的结果。大多数对于派生于这种类型（比如其成员或其超类型）的信息的查询通常不会返回有意义的结果。

从以下版本开始：
1.6

方法摘要
从接口 javax.lang.model.type.DeclaredType 继承的方法
asElement, getEnclosingType, getTypeArguments
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExecutableType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 ExecutableType

所有超级接口：
TypeMirror
public interface ExecutableType
extends TypeMirror

表示 executable 的类型。executable 是一个方法、构造方法或初始化程序。

当 executable 被视为某种引用类型的方法（或者构造方法或初始值）时，executable 被表示为它们。如果该引用类型已被参数化，则其实际类型参数将被替换为此接口的方法所返回的任何类型。

从以下版本开始：
1.6
另请参见：
ExecutableElement

方法摘要
List<? extends TypeMirror> | getParameterTypes() 返回此 executable 的形参类型。
TypeMirror | getReturnType() 返回此 executable 的返回类型。
List<? extends TypeMirror> | getThrownTypes() 返回此 executable 的 throws 子句中列出的异常和其他 throwable。
List<? extends TypeVariable> | getTypeVariables() 返回由此 executable 的形式类型参数所声明的类型变量。
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

方法详细信息

getTypeVariables

List<? extends TypeVariable> getTypeVariables()
返回由此 executable 的形式类型参数所声明的类型变量。

返回：
形式类型参数所声明的类型变量；如果没有，则返回一个空列表

getReturnType

TypeMirror getReturnType()
返回此 executable 的返回类型。如果此 executable 不是一个方法或者是一个不返回值的方法，则返回一个种类为 VOID 的 NoType。

返回：
此 executable 的返回类型

getParameterTypes

List<? extends TypeMirror> getParameterTypes()
返回此 executable 的形参类型。

返回：
此 executable 的形参类型；如果没有，则返回一个空列表

getThrownTypes

List<? extends TypeMirror> getThrownTypes()
返回此 executable 的 throws 子句中列出的异常和其他 throwable。

返回：
此 executable 的 throws 子句中列出的异常和其他 throwable；如果没有，则返回一个空列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MirroredTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
类 MirroredTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.lang.model.type.MirroredTypeException
所有已实现的接口：
Serializable
public class MirroredTypeException
extends RuntimeException

当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。

从以下版本开始：
1.6
另请参见：
MirroredTypesException, Element.getAnnotation(Class), 序列化表格

构造方法摘要
MirroredTypeException(TypeMirror type)
构造一个针对指定类型的新 MirroredTypeException。
方法摘要
 TypeMirror getTypeMirror()
返回对应于要访问类型的类型镜像。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MirroredTypeException

public MirroredTypeException(TypeMirror type)
构造一个针对指定类型的新 MirroredTypeException。

参数：
type - 要访问的类型
方法详细信息

getTypeMirror

public TypeMirror getTypeMirror()
返回对应于要访问类型的类型镜像。如果已经序列化此异常并随后将其读回，则该类型镜像将不可用。

返回：
类型镜像；如果不可用，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MirroredTypesException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
类 MirroredTypesException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.lang.model.type.MirroredTypesException
所有已实现的接口：
Serializable
public class MirroredTypesException
extends RuntimeException

当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。

从以下版本开始：
1.6
另请参见：
MirroredTypeException, Element.getAnnotation(Class), 序列化表格

构造方法摘要
MirroredTypesException(List<? extends TypeMirror> types)
构造一个针对指定类型的新 MirroredTypesException。
方法摘要
 List<? extends TypeMirror> getTypeMirrors()
返回对应于要访问的类型的类型镜像。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MirroredTypesException

public MirroredTypesException(List<? extends TypeMirror> types)
构造一个针对指定类型的新 MirroredTypesException。

参数：
types - 要访问的类型
方法详细信息

getTypeMirrors

public List<? extends TypeMirror> getTypeMirrors()
返回对应于要访问的类型的类型镜像。如果已经序列化此异常并随后将其读回，则此类型镜像将不可用。

返回：
按构造顺序排列的类型镜像；如果不可用，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 NoType

所有超级接口：
TypeMirror
public interface NoType
extends TypeMirror

在实际类型不适合的地方使用的伪类型。NoType 的种类有：

  • VOID - 对应于关键字 void。
  • PACKAGE - 包元素的伪类型。
  • NONE - 用于实际类型不适合的其他情况中；例如，java.lang.Object 的超类。

从以下版本开始：
1.6
另请参见：
ExecutableElement.getReturnType()

方法摘要
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NullType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 NullType

所有超级接口：
ReferenceType, TypeMirror
public interface NullType
extends ReferenceType

表示 null 类型。此类表达式 null 的类型。

从以下版本开始：
1.6

方法摘要
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrimitiveType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 PrimitiveType

所有超级接口：
TypeMirror
public interface PrimitiveType
extends TypeMirror

表示一个基本类型。这些类型包括 boolean、byte、short、int、long、char、float 和 double。

从以下版本开始：
1.6

方法摘要
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReferenceType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 ReferenceType

所有超级接口：
TypeMirror
所有已知子接口：
ArrayType, DeclaredType, ErrorType, NullType, TypeVariable
public interface ReferenceType
extends TypeMirror

表示一个引用类型。这些类型包括类和接口类型、数组类型、类型变量和 null 类型。

从以下版本开始：
1.6

方法摘要
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeKind (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.lang.model.type
枚举 TypeKind

java.lang.Object
    继承者  java.lang.Enum<TypeKind>
        继承者  javax.lang.model.type.TypeKind
所有已实现的接口：
Serializable, Comparable<TypeKind>
public enum TypeKind
extends Enum<TypeKind>

类型镜像的种类。

注意，以后可能会添加一些新的类型种类，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。

从以下版本开始：
1.6
另请参见：
TypeMirror

枚举常量摘要
ARRAY
数组类型。
BOOLEAN
基本类型 boolean。
BYTE
基本类型 byte。
CHAR
基本类型 char。
DECLARED
类或接口类型。
DOUBLE
基本类型 double。
ERROR
无法解析的类或接口类型。
EXECUTABLE
方法、构造方法或初始化程序。
FLOAT
基本类型 float。
INT
基本类型 int。
LONG
基本类型 long。
NONE
在实际类型不适合的地方使用的伪类型。
NULL
null 类型。
OTHER
为实现保留的类型。
PACKAGE
对应于包元素的伪类型。
SHORT
基本类型 short。
TYPEVAR
类型变量。
VOID
对应于关键字 void 的伪类型。
WILDCARD
通配符类型参数。
方法摘要
boolean | isPrimitive() 如果此种类对应于某一基本类型，则返回 true，否则返回 false。
static TypeKind | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TypeKind[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

BOOLEAN

public static final TypeKind BOOLEAN
基本类型 boolean。

BYTE

public static final TypeKind BYTE
基本类型 byte。

SHORT

public static final TypeKind SHORT
基本类型 short。

INT

public static final TypeKind INT
基本类型 int。

LONG

public static final TypeKind LONG
基本类型 long。

CHAR

public static final TypeKind CHAR
基本类型 char。

FLOAT

public static final TypeKind FLOAT
基本类型 float。

DOUBLE

public static final TypeKind DOUBLE
基本类型 double。

VOID

public static final TypeKind VOID
对应于关键字 void 的伪类型。

另请参见：
NoType

NONE

public static final TypeKind NONE
在实际类型不适合的地方使用的伪类型。

另请参见：
NoType

NULL

public static final TypeKind NULL
null 类型。

ARRAY

public static final TypeKind ARRAY
数组类型。

DECLARED

public static final TypeKind DECLARED
类或接口类型。

ERROR

public static final TypeKind ERROR
无法解析的类或接口类型。

TYPEVAR

public static final TypeKind TYPEVAR
类型变量。

WILDCARD

public static final TypeKind WILDCARD
通配符类型参数。

PACKAGE

public static final TypeKind PACKAGE
对应于包元素的伪类型。

另请参见：
NoType

EXECUTABLE

public static final TypeKind EXECUTABLE
方法、构造方法或初始化程序。

OTHER

public static final TypeKind OTHER
为实现保留的类型。此类型不能是正在查找的类型。

方法详细信息

values

public static final TypeKind[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(TypeKind c : TypeKind.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static TypeKind valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException

isPrimitive

public boolean isPrimitive()
如果此种类对应于某一基本类型，则返回 true，否则返回 false。

返回：
如果此种类对应于某一基本类型，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


TypeMirror (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 TypeMirror

所有已知子接口：
ArrayType, DeclaredType, ErrorType, ExecutableType, NoType, NullType, PrimitiveType, ReferenceType, TypeVariable, WildcardType
public interface TypeMirror

表示 Java 编程语言中的类型。这些类型包括基本类型、声明类型（类和接口类型）、数组类型、类型变量和 null 类型。还可以表示通配符类型参数、executable 的签名和返回类型，以及对应于包和关键字 void 的伪类型。

应该使用 Types 中的实用工具方法比较这些类型。不保证总是使用相同的对象表示某个特定的类型。

要实现基于 TypeMirror 对象类的操作，可以使用 visitor 或者使用 getKind() 方法的结果。使用 instanceof 确定此建模层次结构中某一对象的有效类 未必 可靠，因为一个实现可以选择让单个对象实现多个 TypeMirror 子接口。

从以下版本开始：
1.6
另请参见：
Element, Types

方法摘要
<R,P> R
accept(TypeVisitor<R,P> v, P p)
将一个 visitor 应用于此类型。
 boolean equals(Object obj)
遵守 Object.equals 的常规协定。
 TypeKind getKind()
返回此类型的 kind。
 int hashCode()
遵守 Object.hashCode 的常规协定。
 String toString()
返回包含此类型许多信息的字符串表示形式。

方法详细信息

getKind

TypeKind getKind()
返回此类型的 kind。

返回：
此类型的种类

equals

boolean equals(Object obj)
遵守 Object.equals 的常规协定。但是，此方法并不指示两个类型是否表示相同的类型。类型相等性的语义比较应该使用 Types.isSameType(TypeMirror, TypeMirror)。t1.equals(t2) 和 Types.isSameType(t1, t2) 的结果可能有所不同。

覆盖：
类 Object 中的 equals
参数：
obj - 将与此类型进行比较的对象
返回：
如果指定的对象与此对象相等，则返回 true
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
遵守 Object.hashCode 的常规协定。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
equals(java.lang.Object)

toString

String toString()
返回包含此类型许多信息的字符串表示形式。如果可能，字符串应该是适用于表示源代码中此类型的一种形式。结果中嵌套的任何名称都应该是限定名称（如果有）。

覆盖：
类 Object 中的 toString
返回：
此类型的字符串表示形式

accept

<R,P> R accept(TypeVisitor<R,P> v,
               P p)
将一个 visitor 应用于此类型。

类型参数：
R - visitor 的方法的返回类型
参数：
v - 在此类型上操作的 visitor
p - visitor 的附加参数
返回：
特定于 visitor 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeVariable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 TypeVariable

所有超级接口：
ReferenceType, TypeMirror
public interface TypeVariable
extends ReferenceType

表示一个类型变量。类型变量可由某一类型、方法或构造方法的类型参数显式声明。类型变量也可以通过通配符类型参数的捕获转换（请参阅 The Java Language Specification, Third Edition 的第 5 章）隐式声明。

从以下版本开始：
1.6
另请参见：
TypeParameterElement

方法摘要
Element | asElement() 返回对应于此类型变量的元素。
TypeMirror | getLowerBound() 返回此类型变量的下边界。
TypeMirror | getUpperBound() 返回此类型变量的上边界。
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

方法详细信息

asElement

Element asElement()
返回对应于此类型变量的元素。

返回：
对应于此类型变量的元素

getUpperBound

TypeMirror getUpperBound()
返回此类型变量的上边界。

如果此类型变量被声明为没有明确上边界，则结果为 java.lang.Object。如果此类型变量被声明为有多个上边界，则结果是一个交集类型（建模为 DeclaredType）。通过检查结果的超类型，可以发现个别边界。

返回：
此类型变量的上边界

getLowerBound

TypeMirror getLowerBound()
返回此类型变量的下边界。当某一类型参数无法包含显式的下边界声明时，捕获转换可以生成一个具有非平凡（non-trivial）下边界的类型变量。否则，类型变量的下边界为 NullType。

返回：
此类型变量的下边界
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeVisitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 TypeVisitor<R,P>

类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已知实现类：
AbstractTypeVisitor6, SimpleTypeVisitor6, TypeKindVisitor6
public interface TypeVisitor<R,P>

类型的 visitor，使用 visitor 设计模式的样式。在编译时某个类型的种类未知时，实现此接口的类被用来对该类型进行操作。在将 visitor 传递给某个类型的 accept 方法时，最适用于该类型的 visitXYZ 方法将被调用。

如果附加参数 p 为 null，则实现此接口的类有可能抛出 NullPointerException；有关详细信息，请参阅实现类的文档。

警告： 以后可能会向此接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，直接实现此接口的 visitor 类可能与平台的未来版本不兼容。为了避免这种不兼容性，建议 visitor 实现扩展实现此接口的抽象 visitor 类。不过，API 通常应该使用此 visitor 接口作为参数类型、返回类型等，而不是将它作为抽象类之一。

从以下版本开始：
1.6

方法摘要
R | visit(TypeMirror t) 等效于 v.visit(t, null) 的便捷方法。
R | visit(TypeMirror t, P p) 访问一个类型。
R | visitArray(ArrayType t, P p) 访问数组类型。
R | visitDeclared(DeclaredType t, P p) 访问已声明的类型。
R | visitError(ErrorType t, P p) 访问错误类型。
R | visitExecutable(ExecutableType t, P p) 访问 executable 类型。
R | visitNoType(NoType t, P p) 访问 NoType 实例。
R | visitNull(NullType t, P p) 访问 null 类型。
R | visitPrimitive(PrimitiveType t, P p) 访问基本类型。
R | visitTypeVariable(TypeVariable t, P p) 访问类型变量。
R | visitUnknown(TypeMirror t, P p) 访问未知种类的类型。
R | visitWildcard(WildcardType t, P p) 访问通配符类型。

方法详细信息

visit

R visit(TypeMirror t,
        P p)
访问一个类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visit

R visit(TypeMirror t)
等效于 v.visit(t, null) 的便捷方法。

参数：
t - 要访问的元素
返回：
特定于 visitor 的结果

visitPrimitive

R visitPrimitive(PrimitiveType t,
                 P p)
访问基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitNull

R visitNull(NullType t,
            P p)
访问 null 类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitArray

R visitArray(ArrayType t,
             P p)
访问数组类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitDeclared

R visitDeclared(DeclaredType t,
                P p)
访问已声明的类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitError

R visitError(ErrorType t,
             P p)
访问错误类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitTypeVariable

R visitTypeVariable(TypeVariable t,
                    P p)
访问类型变量。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitWildcard

R visitWildcard(WildcardType t,
                P p)
访问通配符类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitExecutable

R visitExecutable(ExecutableType t,
                  P p)
访问 executable 类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitNoType

R visitNoType(NoType t,
              P p)
访问 NoType 实例。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visitUnknown

R visitUnknown(TypeMirror t,
               P p)
访问未知种类的类型。如果语言有所发展并且向 TypeMirror 层次结构中添加了新种类的类型，则会发生这种情况。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果
抛出：
UnknownTypeException - visitor 实现可以有选择地抛出此异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnknownTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
类 UnknownTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.lang.model.type.UnknownTypeException
所有已实现的接口：
Serializable
public class UnknownTypeException
extends RuntimeException

指示遇到未知种类的类型。如果语言有所发展并且向 TypeMirror 层次结构中添加了新种类的类型，则会发生这种情况。该异常可能由类型 visitor 抛出，指示已经为以前的语言版本创建了 visitor。

从以下版本开始：
1.6
另请参见：
TypeVisitor.visitUnknown(javax.lang.model.type.TypeMirror, P), 序列化表格

构造方法摘要
UnknownTypeException(TypeMirror t, Object p)
创建一个新的 UnknownTypeException。
方法摘要
Object | getArgument() 返回附加参数。
TypeMirror | getUnknownType() 返回未知类型。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnknownTypeException

public UnknownTypeException(TypeMirror t,
                            Object p)
创建一个新的 UnknownTypeException。可以使用 p 参数传入一个带有上下文（在该上下文中遇到未知元素）信息的附加参数；例如，TypeVisitor 的 visit 方法可以传入其附加参数。

参数：
t - 未知类型，可以为 null
p - 附加参数，可以为 null
方法详细信息

getUnknownType

public TypeMirror getUnknownType()
返回未知类型。如果已经序列化此异常并随后将其读回，则该值将不可用。

返回：
未知类型；如果不可用，则返回 null

getArgument

public Object getArgument()
返回附加参数。

返回：
附加参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WildcardType (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.type
接口 WildcardType

所有超级接口：
TypeMirror
public interface WildcardType
extends TypeMirror

表示通配符类型参数。示例包括：

   ?
? extends Number
? super T

通配符的上边界可通过 extends 子句显式设置,下边界可通过 super 子句显式设置，或者都没有显示设置（但不能同时显示设置）。

从以下版本开始：
1.6

方法摘要
TypeMirror | getExtendsBound() 返回此通配符的上边界。
TypeMirror | getSuperBound() 返回此通配符的下边界。
从接口 javax.lang.model.type.TypeMirror 继承的方法
accept, equals, getKind, hashCode, toString

方法详细信息

getExtendsBound

TypeMirror getExtendsBound()
返回此通配符的上边界。如果没有显式声明上边界，则返回 null。

返回：
此通配符的上边界

getSuperBound

TypeMirror getSuperBound()
返回此通配符的下边界。如果没有显式声明下边界，则返回 null。

返回：
此通配符的下边界
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.lang.model.type (Java 2 Platform SE 6)

 javax.lang.model.type
接口
ArrayType
DeclaredType
ErrorType
ExecutableType
NoType
NullType
PrimitiveType
ReferenceType
TypeMirror
TypeVariable
TypeVisitor
WildcardType
枚举
TypeKind
异常
MirroredTypeException
MirroredTypesException
UnknownTypeException


javax.lang.model.type (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.lang.model.type

用来为 Java 编程语言类型建立模型的接口。

请参见：
描述

接口摘要
ArrayType | 表示一个数组类型。
DeclaredType | 表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
ErrorType | 表示无法正常建模的类或接口类型。
ExecutableType | 表示 executable 的类型。
NoType | 在实际类型不适合的地方使用的伪类型。
NullType | 表示 null 类型。
PrimitiveType | 表示一个基本类型。
ReferenceType | 表示一个引用类型。
TypeMirror | 表示 Java 编程语言中的类型。
TypeVariable | 表示一个类型变量。
TypeVisitor<R,P> | 类型的 visitor，使用 visitor 设计模式的样式。
WildcardType | 表示通配符类型参数。

枚举摘要
TypeKind 类型镜像的种类。

异常摘要
MirroredTypeException | 当应用程序试图访问对应于 TypeMirror 的 Class 对象时，抛出此异常。
MirroredTypesException | 当应用程序试图访问每个对应于 TypeMirror 的 Class 对象的序列时，抛出此异常。
UnknownTypeException | 指示遇到未知种类的类型。

软件包 javax.lang.model.type 的描述

用来为 Java 编程语言类型建立模型的接口。

除非在特定实现中另行指定，否则此包中的方法所返回的集合应该是不能由调用者修改的，并且对于并发访问是不安全的。

除非另行指定，否则，如果给定一个 null 参数，此包中的方法将抛出 NullPointerException。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.lang.model.type 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model.type 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.lang.model.type.MirroredTypeException
          • javax.lang.model.type.MirroredTypesException
          • javax.lang.model.type.UnknownTypeException

接口分层结构

  • javax.lang.model.type.TypeMirror
    • javax.lang.model.type.ExecutableType
    • javax.lang.model.type.NoType
    • javax.lang.model.type.PrimitiveType
    • javax.lang.model.type.ReferenceType
      • javax.lang.model.type.ArrayType
      • javax.lang.model.type.DeclaredType
        • javax.lang.model.type.ErrorType
      • javax.lang.model.type.NullType
      • javax.lang.model.type.TypeVariable
    • javax.lang.model.type.WildcardType
  • javax.lang.model.type.TypeVisitor<R,P>

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.lang.model.type.TypeKind
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.lang.model.type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model.type
的使用

使用 javax.lang.model.type 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 使用的 javax.lang.model.type 中的类
DeclaredType
表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
TypeMirror
表示 Java 编程语言中的类型。

javax.lang.model.type 使用的 javax.lang.model.type 中的类
ArrayType
表示一个数组类型。
DeclaredType
表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
ErrorType
表示无法正常建模的类或接口类型。
ExecutableType
表示 executable 的类型。
NoType
在实际类型不适合的地方使用的伪类型。
NullType
表示 null 类型。
PrimitiveType
表示一个基本类型。
ReferenceType
表示一个引用类型。
TypeKind
类型镜像的种类。
TypeMirror
表示 Java 编程语言中的类型。
TypeVariable
表示一个类型变量。
TypeVisitor
类型的 visitor，使用 visitor 设计模式的样式。
WildcardType
表示通配符类型参数。

javax.lang.model.util 使用的 javax.lang.model.type 中的类
ArrayType
表示一个数组类型。
DeclaredType
表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
ErrorType
表示无法正常建模的类或接口类型。
ExecutableType
表示 executable 的类型。
NoType
在实际类型不适合的地方使用的伪类型。
NullType
表示 null 类型。
PrimitiveType
表示一个基本类型。
TypeKind
类型镜像的种类。
TypeMirror
表示 Java 编程语言中的类型。
TypeVariable
表示一个类型变量。
TypeVisitor
类型的 visitor，使用 visitor 设计模式的样式。
WildcardType
表示通配符类型参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.NoType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.NoType
的使用

使用 NoType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 NoType 的使用

参数类型为 NoType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitNoType(NoType t, P p)
访问 NoType 实例。

javax.lang.model.util 中 NoType 的使用

返回 NoType 的 javax.lang.model.util 中的方法
 NoType Types.getNoType(TypeKind kind)
返回在实际类型不适用的地方所使用的伪类型。

参数类型为 NoType 的 javax.lang.model.util 中的方法
R | SimpleTypeVisitor6.visitNoType(NoType t, P p) 访问 NoType 实例。
R | TypeKindVisitor6.visitNoType(NoType t, P p) 访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。
R | TypeKindVisitor6.visitNoTypeAsNone(NoType t, P p) 通过调用 defaultAction 访问 NONE 伪类型。
R | TypeKindVisitor6.visitNoTypeAsPackage(NoType t, P p) 通过调用 defaultAction 访问 PACKAGE 伪类型。
R | TypeKindVisitor6.visitNoTypeAsVoid(NoType t, P p) 通过调用 defaultAction 访问 VOID 伪类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.ArrayType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ArrayType
的使用

使用 ArrayType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 ArrayType 的使用

参数类型为 ArrayType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitArray(ArrayType t, P p)
访问数组类型。

javax.lang.model.util 中 ArrayType 的使用

返回 ArrayType 的 javax.lang.model.util 中的方法
 ArrayType Types.getArrayType(TypeMirror componentType)
返回具有指定组件类型的数组类型。

参数类型为 ArrayType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitArray(ArrayType t, P p)
访问数组类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.DeclaredType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.DeclaredType
的使用

使用 DeclaredType 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 DeclaredType 的使用

返回 DeclaredType 的 javax.lang.model.element 中的方法
 DeclaredType AnnotationMirror.getAnnotationType()
返回此注释的类型。

javax.lang.model.type 中 DeclaredType 的使用

javax.lang.model.type 中 DeclaredType 的子接口
 interface ErrorType
表示无法正常建模的类或接口类型。

参数类型为 DeclaredType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitDeclared(DeclaredType t, P p)
访问已声明的类型。

javax.lang.model.util 中 DeclaredType 的使用

返回 DeclaredType 的 javax.lang.model.util 中的方法
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
DeclaredType | Types.getDeclaredType(TypeElement typeElem, TypeMirror... typeArgs) 返回对应于类型元素和实际类型参数的类型。

参数类型为 DeclaredType 的 javax.lang.model.util 中的方法
TypeMirror | Types.asMemberOf(DeclaredType containing, Element element) 当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
R | SimpleTypeVisitor6.visitDeclared(DeclaredType t, P p) 访问已声明的类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.ErrorType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ErrorType
的使用

使用 ErrorType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 ErrorType 的使用

参数类型为 ErrorType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitError(ErrorType t, P p)
访问错误类型。

javax.lang.model.util 中 ErrorType 的使用

参数类型为 ErrorType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitError(ErrorType t, P p)
访问错误类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.ExecutableType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ExecutableType
的使用

使用 ExecutableType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 ExecutableType 的使用

参数类型为 ExecutableType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitExecutable(ExecutableType t, P p)
访问 executable 类型。

javax.lang.model.util 中 ExecutableType 的使用

参数类型为 ExecutableType 的 javax.lang.model.util 中的方法
boolean | Types.isSubsignature(ExecutableType m1, ExecutableType m2) 测试一个方法的签名是否是另一个方法的子签名。
R | SimpleTypeVisitor6.visitExecutable(ExecutableType t, P p) 访问 executable 类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.type.MirroredTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.MirroredTypeException
的使用

没有 javax.lang.model.type.MirroredTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.type.MirroredTypesException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.MirroredTypesException
的使用

没有 javax.lang.model.type.MirroredTypesException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.NullType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.NullType
的使用

使用 NullType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 NullType 的使用

参数类型为 NullType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitNull(NullType t, P p)
访问 null 类型。

javax.lang.model.util 中 NullType 的使用

返回 NullType 的 javax.lang.model.util 中的方法
 NullType Types.getNullType()
返回 null 类型。

参数类型为 NullType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitNull(NullType t, P p)
访问 null 类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.PrimitiveType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.PrimitiveType
的使用

使用 PrimitiveType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 PrimitiveType 的使用

参数类型为 PrimitiveType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitPrimitive(PrimitiveType t, P p)
访问基本类型。

javax.lang.model.util 中 PrimitiveType 的使用

返回 PrimitiveType 的 javax.lang.model.util 中的方法
PrimitiveType | Types.getPrimitiveType(TypeKind kind) 返回基本类型。
PrimitiveType | Types.unboxedType(TypeMirror t) 返回给定类型的拆箱 (unboxed) 值类型（基本类型）。

参数类型为 PrimitiveType 的 javax.lang.model.util 中的方法
TypeElement | Types.boxedClass(PrimitiveType p) 返回给定基本类型的装箱 (boxed) 值类型的类。
R | SimpleTypeVisitor6.visitPrimitive(PrimitiveType t, P p) 访问基本类型。
R | TypeKindVisitor6.visitPrimitive(PrimitiveType t, P p) 访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。
R | TypeKindVisitor6.visitPrimitiveAsBoolean(PrimitiveType t, P p) 通过调用 defaultAction 访问 BOOLEAN 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsByte(PrimitiveType t, P p) 通过调用 defaultAction 访问 BYTE 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsChar(PrimitiveType t, P p) 通过调用 defaultAction 访问 CHAR 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsDouble(PrimitiveType t, P p) 通过调用 defaultAction 访问 DOUBLE 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsFloat(PrimitiveType t, P p) 通过调用 defaultAction 访问 FLOAT 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsInt(PrimitiveType t, P p) 通过调用 defaultAction 访问 INT 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsLong(PrimitiveType t, P p) 通过调用 defaultAction 访问 LONG 基本类型。
R | TypeKindVisitor6.visitPrimitiveAsShort(PrimitiveType t, P p) 通过调用 defaultAction 访问 SHORT 基本类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.ReferenceType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.ReferenceType
的使用

使用 ReferenceType 的软件包
javax.lang.model.type 用来为 Java 编程语言类型建立模型的接口。

javax.lang.model.type 中 ReferenceType 的使用

javax.lang.model.type 中 ReferenceType 的子接口
interface | ArrayType 表示一个数组类型。
interface | DeclaredType 表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
interface | ErrorType 表示无法正常建模的类或接口类型。
interface | NullType 表示 null 类型。
interface | TypeVariable 表示一个类型变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.type.TypeKind 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.TypeKind
的使用

使用 TypeKind 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 TypeKind 的使用

返回 TypeKind 的 javax.lang.model.type 中的方法
TypeKind | TypeMirror.getKind() 返回此类型的 kind。
static TypeKind | TypeKind.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static TypeKind[] | TypeKind.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.lang.model.util 中 TypeKind 的使用

参数类型为 TypeKind 的 javax.lang.model.util 中的方法
NoType | Types.getNoType(TypeKind kind) 返回在实际类型不适用的地方所使用的伪类型。
PrimitiveType | Types.getPrimitiveType(TypeKind kind) 返回基本类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.TypeMirror 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.TypeMirror
的使用

使用 TypeMirror 的软件包
javax.lang.model.element | 用于 Java 编程语言的模型元素的接口。
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.element 中 TypeMirror 的使用

返回 TypeMirror 的 javax.lang.model.element 中的方法
TypeMirror | Element.asType() 返回此元素定义的类型。
TypeMirror | ExecutableElement.getReturnType() 返回此 executable 的返回类型。
TypeMirror | TypeElement.getSuperclass() 返回此类型元素的直接超类。

返回变量类型为 TypeMirror 的类型的 javax.lang.model.element 中的方法
List<? extends TypeMirror> | TypeParameterElement.getBounds() 返回此类型参数的边界。
List<? extends TypeMirror> | TypeElement.getInterfaces() 返回直接由此类实现或直接由此接口扩展的接口类型。
List<? extends TypeMirror> | ExecutableElement.getThrownTypes() 按声明顺序返回此方法或构造方法的 throws 子句中所列出的异常和其他 throwable。

参数类型为 TypeMirror 的 javax.lang.model.element 中的方法
 R AnnotationValueVisitor.visitType(TypeMirror t, P p)
访问注释中的 type 值。

javax.lang.model.type 中 TypeMirror 的使用

javax.lang.model.type 中 TypeMirror 的子接口
interface | ArrayType 表示一个数组类型。
interface | DeclaredType 表示某一声明类型，是一个类 (class) 类型或接口 (interface) 类型。
interface | ErrorType 表示无法正常建模的类或接口类型。
interface | ExecutableType 表示 executable 的类型。
interface | NoType 在实际类型不适合的地方使用的伪类型。
interface | NullType 表示 null 类型。
interface | PrimitiveType 表示一个基本类型。
interface | ReferenceType 表示一个引用类型。
interface | TypeVariable 表示一个类型变量。
interface | WildcardType 表示通配符类型参数。

返回 TypeMirror 的 javax.lang.model.type 中的方法
TypeMirror | ArrayType.getComponentType() 返回此数组类型的组件类型。
TypeMirror | DeclaredType.getEnclosingType() 返回封装实例的最里层类型；如果没有任何封装实例，则返回种类为 NONE 的 NoType。
TypeMirror | WildcardType.getExtendsBound() 返回此通配符的上边界。
TypeMirror | TypeVariable.getLowerBound() 返回此类型变量的下边界。
TypeMirror | ExecutableType.getReturnType() 返回此 executable 的返回类型。
TypeMirror | WildcardType.getSuperBound() 返回此通配符的下边界。
TypeMirror | MirroredTypeException.getTypeMirror() 返回对应于要访问类型的类型镜像。
TypeMirror | UnknownTypeException.getUnknownType() 返回未知类型。
TypeMirror | TypeVariable.getUpperBound() 返回此类型变量的上边界。

返回变量类型为 TypeMirror 的类型的 javax.lang.model.type 中的方法
List<? extends TypeMirror> | ExecutableType.getParameterTypes() 返回此 executable 的形参类型。
List<? extends TypeMirror> | ExecutableType.getThrownTypes() 返回此 executable 的 throws 子句中列出的异常和其他 throwable。
List<? extends TypeMirror> | DeclaredType.getTypeArguments() 返回此类型的实际类型参数。
List<? extends TypeMirror> | MirroredTypesException.getTypeMirrors() 返回对应于要访问的类型的类型镜像。

参数类型为 TypeMirror 的 javax.lang.model.type 中的方法
 R TypeVisitor.visit(TypeMirror t)
等效于 v.visit(t, null) 的便捷方法。
 R TypeVisitor.visit(TypeMirror t, P p)
访问一个类型。
 R TypeVisitor.visitUnknown(TypeMirror t, P p)
访问未知种类的类型。

参数类型为 TypeMirror 的 javax.lang.model.type 中的构造方法
MirroredTypeException(TypeMirror type)
构造一个针对指定类型的新 MirroredTypeException。
UnknownTypeException(TypeMirror t, Object p)
创建一个新的 UnknownTypeException。

类型变量类型为 TypeMirror 的 javax.lang.model.type 中的构造方法参数
MirroredTypesException(List<? extends TypeMirror> types)
构造一个针对指定类型的新 MirroredTypesException。

javax.lang.model.util 中 TypeMirror 的使用

返回 TypeMirror 的 javax.lang.model.util 中的方法
TypeMirror | Types.asMemberOf(DeclaredType containing, Element element) 当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
TypeMirror | Types.capture(TypeMirror t) 对类型应用 capture 转换。
TypeMirror | Types.erasure(TypeMirror t) 返回删除状态的类型。

返回变量类型为 TypeMirror 的类型的 javax.lang.model.util 中的方法
 List<? extends TypeMirror> Types.directSupertypes(TypeMirror t)
返回类型的直接超类型。

参数类型为 TypeMirror 的 javax.lang.model.util 中的方法
Element | Types.asElement(TypeMirror t) 返回对应于类型的元素。
TypeMirror | Types.capture(TypeMirror t) 对类型应用 capture 转换。
boolean | Types.contains(TypeMirror t1, TypeMirror t2) 测试一个类型参数是否包含 另一个类型参数。
protected R | SimpleTypeVisitor6.defaultAction(TypeMirror e, P p) visit 方法的默认动作。
List<? extends TypeMirror> | Types.directSupertypes(TypeMirror t) 返回类型的直接超类型。
TypeMirror | Types.erasure(TypeMirror t) 返回删除状态的类型。
ArrayType | Types.getArrayType(TypeMirror componentType) 返回具有指定组件类型的数组类型。
DeclaredType | Types.getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
DeclaredType | Types.getDeclaredType(TypeElement typeElem, TypeMirror... typeArgs) 返回对应于类型元素和实际类型参数的类型。
WildcardType | Types.getWildcardType(TypeMirror extendsBound, TypeMirror superBound) 返回新的通配符类型参数。
boolean | Types.isAssignable(TypeMirror t1, TypeMirror t2) 测试一种类型是否可以指派给另一种类型。
boolean | Types.isSameType(TypeMirror t1, TypeMirror t2) 测试两个 TypeMirror 对象是否表示同一类型。
boolean | Types.isSubtype(TypeMirror t1, TypeMirror t2) 测试一种类型是否是另一个类型的子类型。
PrimitiveType | Types.unboxedType(TypeMirror t) 返回给定类型的拆箱 (unboxed) 值类型（基本类型）。
R | AbstractTypeVisitor6.visit(TypeMirror t) 访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法，并为附加参数传递 null 一样。
R | AbstractTypeVisitor6.visit(TypeMirror t, P p) 访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法一样。
R | SimpleAnnotationValueVisitor6.visitType(TypeMirror t, P p) 访问注释中的 type 值。
R | AbstractTypeVisitor6.visitUnknown(TypeMirror t, P p) 访问未知种类的类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.TypeVariable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.TypeVariable
的使用

使用 TypeVariable 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 TypeVariable 的使用

返回变量类型为 TypeVariable 的类型的 javax.lang.model.type 中的方法
 List<? extends TypeVariable> ExecutableType.getTypeVariables()
返回由此 executable 的形式类型参数所声明的类型变量。

参数类型为 TypeVariable 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitTypeVariable(TypeVariable t, P p)
访问类型变量。

javax.lang.model.util 中 TypeVariable 的使用

参数类型为 TypeVariable 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitTypeVariable(TypeVariable t, P p)
访问类型变量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.TypeVisitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.TypeVisitor
的使用

使用 TypeVisitor 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 TypeVisitor 的使用

参数类型为 TypeVisitor 的 javax.lang.model.type 中的方法
<R,P> R
TypeMirror.accept(TypeVisitor<R,P> v, P p)
将一个 visitor 应用于此类型。

javax.lang.model.util 中 TypeVisitor 的使用

实现 TypeVisitor 的 javax.lang.model.util 中的类
class | AbstractTypeVisitor6<R,P> 类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。
class | SimpleTypeVisitor6<R,P> 类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | TypeKindVisitor6<R,P> 基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.type.UnknownTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.type.UnknownTypeException
的使用

没有 javax.lang.model.type.UnknownTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.type.WildcardType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.type.WildcardType
的使用

使用 WildcardType 的软件包
javax.lang.model.type | 用来为 Java 编程语言类型建立模型的接口。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.type 中 WildcardType 的使用

参数类型为 WildcardType 的 javax.lang.model.type 中的方法
 R TypeVisitor.visitWildcard(WildcardType t, P p)
访问通配符类型。

javax.lang.model.util 中 WildcardType 的使用

返回 WildcardType 的 javax.lang.model.util 中的方法
 WildcardType Types.getWildcardType(TypeMirror extendsBound, TypeMirror superBound)
返回新的通配符类型参数。

参数类型为 WildcardType 的 javax.lang.model.util 中的方法
 R SimpleTypeVisitor6.visitWildcard(WildcardType t, P p)
访问通配符类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractAnnotationValueVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 AbstractAnnotationValueVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractAnnotationValueVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型
所有已实现的接口：
AnnotationValueVisitor<R,P>
直接已知子类：
SimpleAnnotationValueVisitor6
@SupportedSourceVersion(value=RELEASE_6)
public abstract class AbstractAnnotationValueVisitor6<R,P>
extends Object
implements AnnotationValueVisitor<R,P>

注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。

警告： 以后可能会向此类实现的 AnnotationValueVisitor 接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的抽象注释值 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

构造方法摘要
protected AbstractAnnotationValueVisitor6()
要调用的具体子类的构造方法。
方法摘要
R | visit(AnnotationValue av) 访问注释值，这与将自身传递给该值的 accept 方法，并为附加参数传递 null 一样。
R | visit(AnnotationValue av, P p) 访问注释值，这与将自身传递给该值的 accept 方法一样。
R | visitUnknown(AnnotationValue av, P p) 访问未知种类的注释值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.lang.model.element.AnnotationValueVisitor 继承的方法
visitAnnotation, visitArray, visitBoolean, visitByte, visitChar, visitDouble, visitEnumConstant, visitFloat, visitInt, visitLong, visitShort, visitString, visitType

构造方法详细信息

AbstractAnnotationValueVisitor6

protected AbstractAnnotationValueVisitor6()
要调用的具体子类的构造方法。

方法详细信息

visit

public final R visit(AnnotationValue av,
                     P p)
访问注释值，这与将自身传递给该值的 accept 方法一样。调用 v.visit(av) 等效于调用 av.accept(v, p)。

指定者：
接口 AnnotationValueVisitor<R,P> 中的 visit
参数：
av - 要访问的值
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visit

public final R visit(AnnotationValue av)
访问注释值，这与将自身传递给该值的 accept 方法，并为附加参数传递 null 一样。调用 v.visit(av) 等效于调用 av.accept(v, null)。

指定者：
接口 AnnotationValueVisitor<R,P> 中的 visit
参数：
av - 要访问的值
返回：
特定于 visitor 的结果

visitUnknown

public R visitUnknown(AnnotationValue av,
                      P p)
访问未知种类的注释值。如果语言有所发展并且新类型的值可以存储在注释中，则会发生这种情况。

AbstractAnnotationValueVisitor6 中此方法的默认实现将总是抛出 UnknownAnnotationValueException。子类不需要此行为。

指定者：
接口 AnnotationValueVisitor<R,P> 中的 visitUnknown
参数：
av - 要访问的未知值
p - 特定于 visitor 的参数
返回：
访问结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractElementVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 AbstractElementVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractElementVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已实现的接口：
ElementVisitor<R,P>
直接已知子类：
ElementScanner6, SimpleElementVisitor6
@SupportedSourceVersion(value=RELEASE_6)
public abstract class AbstractElementVisitor6<R,P>
extends Object
implements ElementVisitor<R,P>

程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。

警告： 以后可能会向此类实现的 ElementVisitor 接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的抽象元素 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

构造方法摘要
protected AbstractElementVisitor6()
要调用的具体子类的构造方法。
方法摘要
R | visit(Element e) 访问任何程序元素，这与将自身传递给该元素的 accept 方法，并为附加参数传递 null 一样。
R | visit(Element e, P p) 访问任何程序元素，这与将自身传递给该元素的 accept 方法一样。
R | visitUnknown(Element e, P p) 访问未知种类的元素。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.lang.model.element.ElementVisitor 继承的方法
visitExecutable, visitPackage, visitType, visitTypeParameter, visitVariable

构造方法详细信息

AbstractElementVisitor6

protected AbstractElementVisitor6()
要调用的具体子类的构造方法。

方法详细信息

visit

public final R visit(Element e,
                     P p)
访问任何程序元素，这与将自身传递给该元素的 accept 方法一样。调用 v.visit(elem) 等效于调用 elem.accept(v, p)。

指定者：
接口 ElementVisitor<R,P> 中的 visit
参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visit

public final R visit(Element e)
访问任何程序元素，这与将自身传递给该元素的 accept 方法，并为附加参数传递 null 一样。调用 v.visit(elem) 等效于调用 elem.accept(v, null)。

指定者：
接口 ElementVisitor<R,P> 中的 visit
参数：
e - 要访问的元素
返回：
特定于 visitor 的结果

visitUnknown

public R visitUnknown(Element e,
                      P p)
访问未知种类的元素。如果语言有所发展并且向 Element 层次结构中添加了新种类的元素，则会发生这种情况。

AbstractElementVisitor6 中此方法的默认实现将总是抛出 UnknownElementException。子类不需要此行为。

指定者：
接口 ElementVisitor<R,P> 中的 visitUnknown
参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果
抛出：
UnknownElementException - visitor 实现可以有选择地抛出此异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractTypeVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 AbstractTypeVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractTypeVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已实现的接口：
TypeVisitor<R,P>
直接已知子类：
SimpleTypeVisitor6
public abstract class AbstractTypeVisitor6<R,P>
extends Object
implements TypeVisitor<R,P>

类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。

警告： 以后可能会向此类实现的 TypeVisitor 接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 &quot;visit&quot; 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 &quot;visit&quot; 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的抽象类型 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

构造方法摘要
protected AbstractTypeVisitor6()
要调用的具体子类的构造方法。
方法摘要
R | visit(TypeMirror t) 访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法，并为附加参数传递 null 一样。
R | visit(TypeMirror t, P p) 访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法一样。
R | visitUnknown(TypeMirror t, P p) 访问未知种类的类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.lang.model.type.TypeVisitor 继承的方法
visitArray, visitDeclared, visitError, visitExecutable, visitNoType, visitNull, visitPrimitive, visitTypeVariable, visitWildcard

构造方法详细信息

AbstractTypeVisitor6

protected AbstractTypeVisitor6()
要调用的具体子类的构造方法。

方法详细信息

visit

public final R visit(TypeMirror t,
                     P p)
访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法一样。调用 v.visit(t, p) 等效于调用 t.accept(v, p)。

指定者：
接口 TypeVisitor<R,P> 中的 visit
参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果

visit

public final R visit(TypeMirror t)
访问任何类型镜像，如同将自身传递给该类型镜像的 accept 方法，并为附加参数传递 null 一样。调用 v.visit(t) 等效于调用 t.accept(v, null)。

指定者：
接口 TypeVisitor<R,P> 中的 visit
参数：
t - 要访问的类型
返回：
特定于 visitor 的结果

visitUnknown

public R visitUnknown(TypeMirror t,
                      P p)
访问未知种类的类型。如果语言有所发展并且向 TypeMirror 层次结构中添加了新种类的类型，则会发生这种情况。

AbstractTypeVisitor6 中此方法的默认实现将总是抛出 UnknownTypeException。子类不需要此行为。

指定者：
接口 TypeVisitor<R,P> 中的 visitUnknown
参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定于 visitor 的结果
抛出：
UnknownTypeException - visitor 实现可以有选择地抛出此异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ElementFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 ElementFilter

java.lang.Object
    继承者  javax.lang.model.util.ElementFilter

public class ElementFilter
extends Object

用来从元素集合中只选择所需元素的过滤器。返回的集合和列表是新的集合，它将使用该参数作为后备存储。此类中的方法不会尝试阻止对参数进行当前修改。返回的集合和列表是可变的，但对于并发访问是不安全的。返回的集合与为方法设置的参数具有相同的迭代顺序。

如果将包含 null 的 iterable 和 set 作为参数传递给此类中的方法，那么将抛出 NullPointerException。

注意，static import 语句可以使此类中方法的调用文本更具体；例如：

import static javax.lang.model.util.ElementFilter.*;
     ...
List<VariableElement> fs = fieldsIn(someClass.getEnclosedElements());

从以下版本开始：
1.6

方法摘要
static List<ExecutableElement> | constructorsIn(Iterable<? extends Element> elements) elements 中构造方法的列表。
static Set<ExecutableElement> | constructorsIn(Set<? extends Element> elements) 返回 elements 中构造方法的集合。
static List<VariableElement> | fieldsIn(Iterable<? extends Element> elements) 返回 elements 中字段的列表。
static Set<VariableElement> | fieldsIn(Set<? extends Element> elements) 返回 elements 中字段的集合。
static List<ExecutableElement> | methodsIn(Iterable<? extends Element> elements) 返回 elements 中方法的列表。
static Set<ExecutableElement> | methodsIn(Set<? extends Element> elements) 返回 elements 中方法的集合。
static List<PackageElement> | packagesIn(Iterable<? extends Element> elements) 返回 elements 中包的列表。
static Set<PackageElement> | packagesIn(Set<? extends Element> elements) 返回 elements 中包的集合。
static List<TypeElement> | typesIn(Iterable<? extends Element> elements) 返回 elements 中类型的列表。
static Set<TypeElement> | typesIn(Set<? extends Element> elements) 返回 elements 中类型的集合。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

fieldsIn

public static List<VariableElement> fieldsIn(Iterable<? extends Element> elements)
返回 elements 中字段的列表。

参数：
elements - 要过滤的元素
返回：
elements 中字段的列表

fieldsIn

public static Set<VariableElement> fieldsIn(Set<? extends Element> elements)
返回 elements 中字段的集合。

参数：
elements - 要过滤的元素
返回：
elements 中字段的集合

constructorsIn

public static List<ExecutableElement> constructorsIn(Iterable<? extends Element> elements)
elements 中构造方法的列表。

参数：
elements - 要过滤的元素
返回：
elements 中构造方法的列表

constructorsIn

public static Set<ExecutableElement> constructorsIn(Set<? extends Element> elements)
返回 elements 中构造方法的集合。

参数：
elements - 要过滤的元素
返回：
elements 中构造方法的集合

methodsIn

public static List<ExecutableElement> methodsIn(Iterable<? extends Element> elements)
返回 elements 中方法的列表。

参数：
elements - 要过滤的元素
返回：
elements 中方法的列表

methodsIn

public static Set<ExecutableElement> methodsIn(Set<? extends Element> elements)
返回 elements 中方法的集合。

参数：
elements - 要过滤的元素
返回：
elements 中方法的集合

typesIn

public static List<TypeElement> typesIn(Iterable<? extends Element> elements)
返回 elements 中类型的列表。

参数：
elements - 要过滤的元素
返回：
elements 中类型的列表

typesIn

public static Set<TypeElement> typesIn(Set<? extends Element> elements)
返回 elements 中类型的集合。

参数：
elements - 要过滤的元素
返回：
elements 中类型的集合

packagesIn

public static List<PackageElement> packagesIn(Iterable<? extends Element> elements)
返回 elements 中包的列表。

参数：
elements - 要过滤的元素
返回：
elements 中包的列表

packagesIn

public static Set<PackageElement> packagesIn(Set<? extends Element> elements)
返回 elements 中包的集合。

参数：
elements - 要过滤的元素
返回：
elements 中包的集合
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ElementKindVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 ElementKindVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractElementVisitor6<R,P>
        继承者  javax.lang.model.util.SimpleElementVisitor6<R,P>
            继承者  javax.lang.model.util.ElementKindVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已实现的接口：
ElementVisitor<R,P>
@SupportedSourceVersion(value=RELEASE_6)
public class ElementKindVisitor6<R,P>
extends SimpleElementVisitor6<R,P>

基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。对于可能有多个种类的元素 XYZ，此类中的 visitXYZ 方法委托给对应于第一个参数种类的 visitXYZKind 方法。visitXYZKind 方法调用 defaultAction，并将其参数传递给 defaultAction 的对应参数。

根据常规协定，可以重写此类中的方法。注意，具有 @Override 的具体子类中的注释方法可以帮助确定那些打算重写的方法。

警告： 以后可能会向此类实现的 ElementVisitor 接口添加一些方法，或者向在这里使用的 ElementKind enum 添加一些常量，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的抽象元素种类 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

字段摘要
从类 javax.lang.model.util.SimpleElementVisitor6 继承的字段
DEFAULT_VALUE
构造方法摘要
protected | ElementKindVisitor6() 具体子类的构造方法；使用 null 作为默认值。
protected | ElementKindVisitor6(R defaultValue) 具体子类的构造方法；使用参数作为默认值。
方法摘要
R | visitExecutable(ExecutableElement e, P p) 访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。
R | visitExecutableAsConstructor(ExecutableElement e, P p) 通过调用 defaultAction 访问 CONSTRUCTOR executable 元素。
R | visitExecutableAsInstanceInit(ExecutableElement e, P p) 通过调用 defaultAction 访问 INSTANCE_INIT executable 元素。
R | visitExecutableAsMethod(ExecutableElement e, P p) 通过调用 defaultAction 访问 METHOD executable 元素。
R | visitExecutableAsStaticInit(ExecutableElement e, P p) 通过调用 defaultAction 访问 STATIC_INIT executable 元素。
R | visitPackage(PackageElement e, P p) 访问包元素。
R | visitType(TypeElement e, P p) 访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。
R | visitTypeAsAnnotationType(TypeElement e, P p) 通过调用 defaultAction 访问 ANNOTATION_TYPE 类型元素。
R | visitTypeAsClass(TypeElement e, P p) 通过调用 defaultAction 访问 CLASS 类型元素。
R | visitTypeAsEnum(TypeElement e, P p) 通过调用 defaultAction 访问 ENUM 类型元素。
R | visitTypeAsInterface(TypeElement e, P p) 通过调用 defaultAction 访问 INTERFACE 类型元素。
R | visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | visitVariable(VariableElement e, P p) 访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。
R | visitVariableAsEnumConstant(VariableElement e, P p) 通过调用 defaultAction 访问 ENUM_CONSTANT 变量元素。
R | visitVariableAsExceptionParameter(VariableElement e, P p) 通过调用 defaultAction 访问 EXCEPTION_PARAMETER 变量元素。
R | visitVariableAsField(VariableElement e, P p) 通过调用 defaultAction 访问 FIELD 变量元素。
R | visitVariableAsLocalVariable(VariableElement e, P p) 通过调用 defaultAction 访问 LOCAL_VARIABLE 变量元素。
R | visitVariableAsParameter(VariableElement e, P p) 通过调用 defaultAction 访问 PARAMETER 变量元素。
从类 javax.lang.model.util.SimpleElementVisitor6 继承的方法
defaultAction
从类 javax.lang.model.util.AbstractElementVisitor6 继承的方法
visit, visit, visitUnknown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ElementKindVisitor6

protected ElementKindVisitor6()
具体子类的构造方法；使用 null 作为默认值。

ElementKindVisitor6

protected ElementKindVisitor6(R defaultValue)
具体子类的构造方法；使用参数作为默认值。

参数：
defaultValue - 为 SimpleElementVisitor6.DEFAULT_VALUE 分配的值
方法详细信息

visitPackage

public R visitPackage(PackageElement e,
                      P p)
访问包元素。 此实现调用 defaultAction。 元素参数的种类为 PACKAGE。

指定者：
接口 ElementVisitor<R,P> 中的 visitPackage
覆盖：
类 SimpleElementVisitor6<R,P> 中的 visitPackage
参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitType

public R visitType(TypeElement e,
                   P p)
访问类型元素，指派给用于特定的类型种类 ANNOTATION_TYPE、CLASS、ENUM 或 INTERFACE 的 visit 方法。

指定者：
接口 ElementVisitor<R,P> 中的 visitType
覆盖：
类 SimpleElementVisitor6<R,P> 中的 visitType
参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于种类的 visit 方法的结果

visitTypeAsAnnotationType

public R visitTypeAsAnnotationType(TypeElement e,
                                   P p)
通过调用 defaultAction 访问 ANNOTATION_TYPE 类型元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitTypeAsClass

public R visitTypeAsClass(TypeElement e,
                          P p)
通过调用 defaultAction 访问 CLASS 类型元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitTypeAsEnum

public R visitTypeAsEnum(TypeElement e,
                         P p)
通过调用 defaultAction 访问 ENUM 类型元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitTypeAsInterface

public R visitTypeAsInterface(TypeElement e,
                              P p)
通过调用 defaultAction 访问 INTERFACE 类型元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitVariable

public R visitVariable(VariableElement e,
                       P p)
访问变量元素，指派给用于特定的变量种类 ENUM_CONSTANT、EXCEPTION_PARAMETER、FIELD、LOCAL_VARIABLE 或 PARAMETER 的 visit 方法。

指定者：
接口 ElementVisitor<R,P> 中的 visitVariable
覆盖：
类 SimpleElementVisitor6<R,P> 中的 visitVariable
参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于种类的 visit 方法的结果

visitVariableAsEnumConstant

public R visitVariableAsEnumConstant(VariableElement e,
                                     P p)
通过调用 defaultAction 访问 ENUM_CONSTANT 变量元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitVariableAsExceptionParameter

public R visitVariableAsExceptionParameter(VariableElement e,
                                           P p)
通过调用 defaultAction 访问 EXCEPTION_PARAMETER 变量元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitVariableAsField

public R visitVariableAsField(VariableElement e,
                              P p)
通过调用 defaultAction 访问 FIELD 变量元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitVariableAsLocalVariable

public R visitVariableAsLocalVariable(VariableElement e,
                                      P p)
通过调用 defaultAction 访问 LOCAL_VARIABLE 变量元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitVariableAsParameter

public R visitVariableAsParameter(VariableElement e,
                                  P p)
通过调用 defaultAction 访问 PARAMETER 变量元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitExecutable

public R visitExecutable(ExecutableElement e,
                         P p)
访问 executable 元素，指派给用于特定的 executable 种类 CONSTRUCTOR、INSTANCE_INIT、METHOD 或 STATIC_INIT 的 visit 方法。

指定者：
接口 ElementVisitor<R,P> 中的 visitExecutable
覆盖：
类 SimpleElementVisitor6<R,P> 中的 visitExecutable
参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
特定于种类的 visit 方法的结果

visitExecutableAsConstructor

public R visitExecutableAsConstructor(ExecutableElement e,
                                      P p)
通过调用 defaultAction 访问 CONSTRUCTOR executable 元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitExecutableAsInstanceInit

public R visitExecutableAsInstanceInit(ExecutableElement e,
                                       P p)
通过调用 defaultAction 访问 INSTANCE_INIT executable 元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitExecutableAsMethod

public R visitExecutableAsMethod(ExecutableElement e,
                                 P p)
通过调用 defaultAction 访问 METHOD executable 元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitExecutableAsStaticInit

public R visitExecutableAsStaticInit(ExecutableElement e,
                                     P p)
通过调用 defaultAction 访问 STATIC_INIT executable 元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitTypeParameter

public R visitTypeParameter(TypeParameterElement e,
                            P p)
访问类型参数元素。 此实现调用 defaultAction。 元素参数的种类为 TYPE_PARAMETER。

指定者：
接口 ElementVisitor<R,P> 中的 visitTypeParameter
覆盖：
类 SimpleElementVisitor6<R,P> 中的 visitTypeParameter
参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Elements (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
接口 Elements

public interface Elements

用来对程序元素进行操作的实用工具方法。

兼容性注意事项： 在将来的平台版本中可能会向此接口添加一些方法。

从以下版本开始：
1.6
另请参见：
ProcessingEnvironment.getElementUtils()

方法摘要
List<? extends AnnotationMirror> | getAllAnnotationMirrors(Element e) 返回元素的所有注释，不管是继承的还是直接存在的。
List<? extends Element> | getAllMembers(TypeElement type) 返回类型元素的所有成员，不管是继承的还是直接声明的。
Name | getBinaryName(TypeElement type) 返回类型元素的二进制名称。
String | getConstantExpression(Object value) 返回表示基本值或字符串的常量表达式 文本。
String | getDocComment(Element e) 返回元素的文档（"Javadoc"）注释文本。
Map<? extends ExecutableElement,? extends AnnotationValue> | getElementValuesWithDefaults(AnnotationMirror a) 返回注释元素的值，包括默认值。
Name | getName(CharSequence cs) 返回与参数具有相同字符序列的名称。
PackageElement | getPackageElement(CharSequence name) 返回已给出其完全限定名称的包。
PackageElement | getPackageOf(Element type) 返回元素的包。
TypeElement | getTypeElement(CharSequence name) 返回已给出其规范名称的类型元素。
boolean | hides(Element hider, Element hidden) 测试一个类型、方法或字段是否隐藏了另一个类型、方法或字段。
boolean | isDeprecated(Element e) 如果元素已过时，则返回 true，否则返回 false。
boolean | overrides(ExecutableElement overrider, ExecutableElement overridden, TypeElement type) 测试一个方法（作为给定类型的成员）是否重写了另一个方法。
void | printElements(Writer w, Element... elements) 按指定顺序将元素的表示形式打印到给定 writer。

方法详细信息

getPackageElement

PackageElement getPackageElement(CharSequence name)
返回已给出其完全限定名称的包。

参数：
name - 完全限定的包名称；对于未命名的包，该参数为 ""
返回：
指定的包；如果没有找到这样的包，则返回 null

getTypeElement

TypeElement getTypeElement(CharSequence name)
返回已给出其规范名称的类型元素。

参数：
name - 规范名称
返回：
指定的类型元素；如果没有找到这样的元素，则返回 null

getElementValuesWithDefaults

Map<? extends ExecutableElement,? extends AnnotationValue> getElementValuesWithDefaults(AnnotationMirror a)
返回注释元素的值，包括默认值。

参数：
a - 要检查的注释
返回：
注释元素的值，包括默认值
另请参见：
AnnotationMirror.getElementValues()

getDocComment

String getDocComment(Element e)
返回元素的文档（"Javadoc"）注释文本。

参数：
e - 将被检查的元素
返回：
元素的文档注释；如果没有，则返回 null

isDeprecated

boolean isDeprecated(Element e)
如果元素已过时，则返回 true，否则返回 false。

参数：
e - 将被检查的元素
返回：
如果元素已过时，则返回 true，否则返回 false

getBinaryName

Name getBinaryName(TypeElement type)
返回类型元素的二进制名称。

参数：
type - 将被检查的类型元素
返回：
二进制名称
另请参见：
TypeElement.getQualifiedName()

getPackageOf

PackageElement getPackageOf(Element type)
返回元素的包。包的包是它本身。

参数：
type - 将被检查的元素
返回：
元素的包

getAllMembers

List<? extends Element> getAllMembers(TypeElement type)
返回类型元素的所有成员，不管是继承的还是直接声明的。对于一个类，结果还包括其构造方法，但不包括局部类或匿名类。

注意，使用 ElementFilter 中的方法可以隔离某个种类的元素。

参数：
type - 将被检查的类型
返回：
类型的所有成员
另请参见：
Element.getEnclosedElements()

getAllAnnotationMirrors

List<? extends AnnotationMirror> getAllAnnotationMirrors(Element e)
返回元素的所有注释，不管是继承的还是直接存在的。

参数：
e - 将被检查的元素
返回：
元素的所有注释
另请参见：
Element.getAnnotationMirrors()

hides

boolean hides(Element hider,
              Element hidden)
测试一个类型、方法或字段是否隐藏了另一个类型、方法或字段。

参数：
hider - 第一个元素
hidden - 第二个元素
返回：
当且仅当第一个元素隐藏了第二个元素时返回 true

overrides

boolean overrides(ExecutableElement overrider,
                  ExecutableElement overridden,
                  TypeElement type)
测试一个方法（作为给定类型的成员）是否重写了另一个方法。当非抽象方法重写抽象方法时，还可以说成是前者实现 了后者。

在最简单且最典型的用法中，type 参数的值就是直接封装 overrider（可能重写的方法）的类或接口。例如，假设 m1 表示方法 String.hashCode，而 m2 表示 Object.hashCode。可以询问 m1 是否重写了 String 类中的 m2（它的确重写了该方法）：

assert elements.overrides(m1, m2, elements.getTypeElement(&quot;java.lang.String&quot;));
下例描述了一种更有趣的情况，在这种情况下，类型 A 中的方法没有重写类型 B 中名称类似的方法：
class A { public void m() {} }
interface B { void m(); }
...
m1 = ...; // A.m
m2 = ...; // B.m
assert ! elements.overrides(m1, m2, elements.getTypeElement(&quot;A&quot;));
当时，当被视为第三种类型 C 的成员时，A 中的方法重写了 B 中的方法：
class C extends A implements B {}
...
assert elements.overrides(m1, m2, elements.getTypeElement(&quot;C&quot;));

参数：
overrider - 第一个方法，可能是 overrider
overridden - 第二个方法，可能被重写
type - 第一个方法是其成员的类型
返回：
当且仅当第一个方法重写第二个方法时返回 true

getConstantExpression

String getConstantExpression(Object value)
返回表示基本值或字符串的常量表达式 文本。返回文本的形式是一种适合于表示源代码中的值的形式。

参数：
value - 基本值或字符串
返回：
常量表达式的文本
抛出：
IllegalArgumentException - 如果参数不是基本值或字符串
另请参见：
VariableElement.getConstantValue()

printElements

void printElements(Writer w,
                   Element... elements)
按指定顺序将元素的表示形式打印到给定 writer。此方法的主要用途是诊断。输出的具体格式没有 指定并且是可以更改的。

参数：
w - 输出打印到的 writer
elements - 要打印的元素

getName

Name getName(CharSequence cs)
返回与参数具有相同字符序列的名称。

参数：
cs - 将以名称形式返回的字符序列
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ElementScanner6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 ElementScanner6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractElementVisitor6<R,P>
        继承者  javax.lang.model.util.ElementScanner6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已实现的接口：
ElementVisitor<R,P>
@SupportedSourceVersion(value=RELEASE_6)
public class ElementScanner6<R,P>
extends AbstractElementVisitor6<R,P>

程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。此类中的 visitXYZ 方法通过对其 封装元素、参数等调用 scan 来扫描其组件元素，正如其各自的方法规范所指示的那样。子类可以通过重写 visitXYZ 方法控制元素的访问顺序。注意，scanner 的客户端可通过对相关根元素调用 v.scan(e, p) 而不是 v.visit(e, p) 来获得所需行为。

当子类重写 visitXYZ 方法时，新方法可以通过调用 super.visitXYZ 按默认方式扫描封装的元素。使用这种方式，就附加处理而言，具体 visitor 可以控制遍历组件元素的顺序；例如，在重写方法的开始处以一致的方式调用 super.visitXYZ 将产生先序遍历 (preorder traversal)。如果应该以其他顺序遍历组件元素，那么重写的 visit 方法应该使用按所需顺序排列的元素调用 scan，而不是调用 super.visitXYZ。

根据常规协定，可以重写此类中的方法。注意，具有 @Override 的具体子类中的注释方法可以帮助确定那些打算重写的方法。

警告： 以后可能会向此类实现的 ElementVisitor 接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的元素 scanner visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

字段摘要
protected  R DEFAULT_VALUE
指定的默认值。
构造方法摘要
protected | ElementScanner6() 具体子类的构造方法；使用 null 作为默认值。
protected | ElementScanner6(R defaultValue) 具体子类的构造方法；使用参数作为默认值。
方法摘要
 R scan(Element e)
等效于 v.scan(e, null) 的便捷方法。
 R scan(Element e, P p)
通过调用 e.accept(this, p) 处理元素；此方法可被子类重写。
 R scan(Iterable<? extends Element> iterable, P p)
迭代给定元素并对每个元素调用 scan(Element, P)。
 R visitExecutable(ExecutableElement e, P p)
访问 executable 元素。
 R visitPackage(PackageElement e, P p)
访问包元素。
 R visitType(TypeElement e, P p)
访问类型元素。
 R visitTypeParameter(TypeParameterElement e, P p)
访问类型参数元素。
 R visitVariable(VariableElement e, P p)
访问变量元素。
从类 javax.lang.model.util.AbstractElementVisitor6 继承的方法
visit, visit, visitUnknown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_VALUE

protected final R DEFAULT_VALUE
指定的默认值。

构造方法详细信息

ElementScanner6

protected ElementScanner6()
具体子类的构造方法；使用 null 作为默认值。

ElementScanner6

protected ElementScanner6(R defaultValue)
具体子类的构造方法；使用参数作为默认值。

方法详细信息

scan

public final R scan(Iterable<? extends Element> iterable,
                    P p)
迭代给定元素并对每个元素调用 scan(Element, P)。返回最后一次调用 scan 的结果；对于空 iterable，则返回 DEFAULT_VALUE。

参数：
iterable - 要扫描的元素
p - 附加参数
返回：
最后一个元素的扫描；如果没有元素，则返回 DEFAULT_VALUE

scan

public R scan(Element e,
              P p)
通过调用 e.accept(this, p) 处理元素；此方法可被子类重写。

返回：
访问 e 的结果。

scan

public final R scan(Element e)
等效于 v.scan(e, null) 的便捷方法。

返回：
扫描 e 的结果。

visitPackage

public R visitPackage(PackageElement e,
                      P p)
访问包元素。 此实现扫描封装的元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
扫描的结果

visitType

public R visitType(TypeElement e,
                   P p)
访问类型元素。 此实现扫描封装的元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
扫描的结果

visitVariable

public R visitVariable(VariableElement e,
                       P p)
访问变量元素。 此实现扫描封装的元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
扫描的结果

visitExecutable

public R visitExecutable(ExecutableElement e,
                         P p)
访问 executable 元素。 此实现扫描参数。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
扫描的结果

visitTypeParameter

public R visitTypeParameter(TypeParameterElement e,
                            P p)
访问类型参数元素。 此实现扫描封装的元素。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
扫描的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleAnnotationValueVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 SimpleAnnotationValueVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractAnnotationValueVisitor6<R,P>
        继承者  javax.lang.model.util.SimpleAnnotationValueVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型
所有已实现的接口：
AnnotationValueVisitor<R,P>
@SupportedSourceVersion(value=RELEASE_6)
public class SimpleAnnotationValueVisitor6<R,P>
extends AbstractAnnotationValueVisitor6<R,P>

注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。Visit 方法调用 defaultAction(java.lang.Object, P)，并将其参数传递给 defaultAction 的对应参数。

根据常规协定，可以重写此类中的方法。注意，具有 @Override 的具体子类中的注释方法可以帮助确定那些打算重写的方法。

警告： 以后可能会向此类实现的 AnnotationValueVisitor 接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的简单注释值 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

字段摘要
protected  R DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
构造方法摘要
protected | SimpleAnnotationValueVisitor6() 具体子类的构造方法；使用 null 作为默认值。
protected | SimpleAnnotationValueVisitor6(R defaultValue) 具体子类的构造方法；使用参数作为默认值。
方法摘要
protected R | defaultAction(Object o, P p) visit 方法的默认动作。
R | visitAnnotation(AnnotationMirror a, P p) 访问注释中的 annotation 值。
R | visitArray(List<? extends AnnotationValue> vals, P p) 访问注释中的 array 值。
R | visitBoolean(boolean b, P p) 访问注释中的 boolean 值。
R | visitByte(byte b, P p) 访问注释中的 byte 值。
R | visitChar(char c, P p) 访问注释中的 char 值。
R | visitDouble(double d, P p) 访问注释中的 double 值。
R | visitEnumConstant(VariableElement c, P p) 访问注释中的 enum 值。
R | visitFloat(float f, P p) 访问注释中的 float 值。
R | visitInt(int i, P p) 访问注释中的 int 值。
R | visitLong(long i, P p) 访问注释中的 long 值。
R | visitShort(short s, P p) 访问注释中的 short 值。
R | visitString(String s, P p) 访问注释中的 string 值。
R | visitType(TypeMirror t, P p) 访问注释中的 type 值。
从类 javax.lang.model.util.AbstractAnnotationValueVisitor6 继承的方法
visit, visit, visitUnknown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_VALUE

protected final R DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

构造方法详细信息

SimpleAnnotationValueVisitor6

protected SimpleAnnotationValueVisitor6()
具体子类的构造方法；使用 null 作为默认值。

SimpleAnnotationValueVisitor6

protected SimpleAnnotationValueVisitor6(R defaultValue)
具体子类的构造方法；使用参数作为默认值。

参数：
defaultValue - 为 DEFAULT_VALUE 分配的值
方法详细信息

defaultAction

protected R defaultAction(Object o,
                          P p)
visit 方法的默认动作。此类中的实现仅返回 DEFAULT_VALUE；子类通常会重写此方法。

参数：
o - 注释的值
p - 特定于 visitor 的参数
返回：
DEFAULT_VALUE，除非被重写

visitBoolean

public R visitBoolean(boolean b,
                      P p)
访问注释中的 boolean 值。 此实现调用 defaultAction。

参数：
b - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitByte

public R visitByte(byte b,
                   P p)
访问注释中的 byte 值。 此实现调用 defaultAction。

参数：
b - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitChar

public R visitChar(char c,
                   P p)
访问注释中的 char 值。 此实现调用 defaultAction。

参数：
c - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitDouble

public R visitDouble(double d,
                     P p)
访问注释中的 double 值。 此实现调用 defaultAction。

参数：
d - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitFloat

public R visitFloat(float f,
                    P p)
访问注释中的 float 值。 此实现调用 defaultAction。

参数：
f - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitInt

public R visitInt(int i,
                  P p)
访问注释中的 int 值。 此实现调用 defaultAction。

参数：
i - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitLong

public R visitLong(long i,
                   P p)
访问注释中的 long 值。 此实现调用 defaultAction。

参数：
i - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitShort

public R visitShort(short s,
                    P p)
访问注释中的 short 值。 此实现调用 defaultAction。

参数：
s - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitString

public R visitString(String s,
                     P p)
访问注释中的 string 值。 此实现调用 defaultAction。

参数：
s - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitType

public R visitType(TypeMirror t,
                   P p)
访问注释中的 type 值。 此实现调用 defaultAction。

参数：
t - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitEnumConstant

public R visitEnumConstant(VariableElement c,
                           P p)
访问注释中的 enum 值。 此实现调用 defaultAction。

参数：
c - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitAnnotation

public R visitAnnotation(AnnotationMirror a,
                         P p)
访问注释中的 annotation 值。 此实现调用 defaultAction。

参数：
a - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitArray

public R visitArray(List<? extends AnnotationValue> vals,
                    P p)
访问注释中的 array 值。 此实现调用 defaultAction。

参数：
vals - 要访问的值
p - 特定于 visitor 的参数
返回：
defaultAction 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleElementVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 SimpleElementVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractElementVisitor6<R,P>
        继承者  javax.lang.model.util.SimpleElementVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已实现的接口：
ElementVisitor<R,P>
直接已知子类：
ElementKindVisitor6
@SupportedSourceVersion(value=RELEASE_6)
public class SimpleElementVisitor6<R,P>
extends AbstractElementVisitor6<R,P>

程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。 对应于 RELEASE_6 语言结构的 visit 方法调用 defaultAction(javax.lang.model.element.Element, P)，并将其参数传递给 defaultAction 的相应参数。

根据常规协定，可以重写此类中的方法。注意，具有 @Override 的具体子类中的注释方法可以帮助确定那些打算重写的方法。

警告： 以后可能会向此类实现的 ElementVisitor 接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的简单元素 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

字段摘要
protected  R DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
构造方法摘要
protected | SimpleElementVisitor6() 具体子类的构造方法；使用 null 作为默认值。
protected | SimpleElementVisitor6(R defaultValue) 具体子类的构造方法；使用参数作为默认值。
方法摘要
protected R | defaultAction(Element e, P p) visit 方法的默认动作。
R | visitExecutable(ExecutableElement e, P p) 访问 executable 元素。
R | visitPackage(PackageElement e, P p) 访问包元素。
R | visitType(TypeElement e, P p) 访问类型元素。
R | visitTypeParameter(TypeParameterElement e, P p) 访问类型参数元素。
R | visitVariable(VariableElement e, P p) 访问变量元素。
从类 javax.lang.model.util.AbstractElementVisitor6 继承的方法
visit, visit, visitUnknown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_VALUE

protected final R DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

构造方法详细信息

SimpleElementVisitor6

protected SimpleElementVisitor6()
具体子类的构造方法；使用 null 作为默认值。

SimpleElementVisitor6

protected SimpleElementVisitor6(R defaultValue)
具体子类的构造方法；使用参数作为默认值。

参数：
defaultValue - 为 DEFAULT_VALUE 分配的值
方法详细信息

defaultAction

protected R defaultAction(Element e,
                          P p)
visit 方法的默认动作。此类中的实现仅返回 DEFAULT_VALUE；子类通常会重写此方法。

参数：
e - 要处理的元素
p - 特定于 visitor 的参数
返回：
DEFAULT_VALUE，除非被重写

visitPackage

public R visitPackage(PackageElement e,
                      P p)
访问包元素。 此实现调用 defaultAction。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitType

public R visitType(TypeElement e,
                   P p)
访问类型元素。 此实现调用 defaultAction。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitVariable

public R visitVariable(VariableElement e,
                       P p)
访问变量元素。 此实现调用 defaultAction。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitExecutable

public R visitExecutable(ExecutableElement e,
                         P p)
访问 executable 元素。 此实现调用 defaultAction。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitTypeParameter

public R visitTypeParameter(TypeParameterElement e,
                            P p)
访问类型参数元素。 此实现调用 defaultAction。

参数：
e - 要访问的元素
p - 特定于 visitor 的参数
返回：
defaultAction 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleTypeVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 SimpleTypeVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractTypeVisitor6<R,P>
        继承者  javax.lang.model.util.SimpleTypeVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已实现的接口：
TypeVisitor<R,P>
直接已知子类：
TypeKindVisitor6
@SupportedSourceVersion(value=RELEASE_6)
public class SimpleTypeVisitor6<R,P>
extends AbstractTypeVisitor6<R,P>

类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。 对应于 RELEASE_6 语言结构的 visit 方法调用 defaultAction(javax.lang.model.type.TypeMirror, P)，并将其参数传递给 defaultAction 的相应参数。

根据常规协定，可以重写此类中的方法。注意，具有 @Override 的具体子类中的注释方法可以帮助确定那些打算重写的方法。

警告： 以后可能会向此类实现的 TypeVisitor 接口添加的一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的简单类型 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

字段摘要
protected  R DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。
构造方法摘要
protected | SimpleTypeVisitor6() 具体子类的构造方法；使用 null 作为默认值。
protected | SimpleTypeVisitor6(R defaultValue) 具体子类的构造方法；使用参数作为默认值。
方法摘要
protected R | defaultAction(TypeMirror e, P p) visit 方法的默认动作。
R | visitArray(ArrayType t, P p) 访问数组类型。
R | visitDeclared(DeclaredType t, P p) 访问已声明的类型。
R | visitError(ErrorType t, P p) 访问错误类型。
R | visitExecutable(ExecutableType t, P p) 访问 executable 类型。
R | visitNoType(NoType t, P p) 访问 NoType 实例。
R | visitNull(NullType t, P p) 访问 null 类型。
R | visitPrimitive(PrimitiveType t, P p) 访问基本类型。
R | visitTypeVariable(TypeVariable t, P p) 访问类型变量。
R | visitWildcard(WildcardType t, P p) 访问通配符类型。
从类 javax.lang.model.util.AbstractTypeVisitor6 继承的方法
visit, visit, visitUnknown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_VALUE

protected final R DEFAULT_VALUE
要返回的默认值；defaultAction 返回此值，除非该方法被重写。

构造方法详细信息

SimpleTypeVisitor6

protected SimpleTypeVisitor6()
具体子类的构造方法；使用 null 作为默认值。

SimpleTypeVisitor6

protected SimpleTypeVisitor6(R defaultValue)
具体子类的构造方法；使用参数作为默认值。

参数：
defaultValue - 为 DEFAULT_VALUE 分配的值
方法详细信息

defaultAction

protected R defaultAction(TypeMirror e,
                          P p)
visit 方法的默认动作。此类中的实现仅返回 DEFAULT_VALUE；子类通常会重写此方法。

visitPrimitive

public R visitPrimitive(PrimitiveType t,
                        P p)
访问基本类型。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitNull

public R visitNull(NullType t,
                   P p)
访问 null 类型。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitArray

public R visitArray(ArrayType t,
                    P p)
访问数组类型。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitDeclared

public R visitDeclared(DeclaredType t,
                       P p)
访问已声明的类型。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitError

public R visitError(ErrorType t,
                    P p)
访问错误类型。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitTypeVariable

public R visitTypeVariable(TypeVariable t,
                           P p)
访问类型变量。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitWildcard

public R visitWildcard(WildcardType t,
                       P p)
访问通配符类型。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitExecutable

public R visitExecutable(ExecutableType t,
                         P p)
访问 executable 类型。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitNoType

public R visitNoType(NoType t,
                     P p)
访问 NoType 实例。 此实现调用 defaultAction。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TypeKindVisitor6 (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
类 TypeKindVisitor6<R,P>

java.lang.Object
    继承者  javax.lang.model.util.AbstractTypeVisitor6<R,P>
        继承者  javax.lang.model.util.SimpleTypeVisitor6<R,P>
            继承者  javax.lang.model.util.TypeKindVisitor6<R,P>
类型参数：
R - 此 visitor 的方法的返回类型。对于不需要返回结果的 visitor，使用 Void。
所有已实现的接口：
TypeVisitor<R,P>
@SupportedSourceVersion(value=RELEASE_6)
public class TypeKindVisitor6<R,P>
extends SimpleTypeVisitor6<R,P>

基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。对于可能有多个种类的类型 XYZ，此类中的 visitXYZ 方法委托给对应于第一个参数种类的 visitXYZKind 方法。visitXYZKind 方法调用 defaultAction，并将其参数传递给 defaultAction 的对应参数。

根据常规协定，可以重写此类中的方法。注意，具有 @Override 的具体子类中的注释方法可以帮助确定那些打算重写的方法。

警告： 以后可能会向此类实现的 TypeVisitor 接口添加一些方法，以适应添加到 Java™ 编程语言未来版本中的新（当前未知的）语言结构。所以，将来可能会向此类添加名称以 "visit" 开头的方法；为了避免不兼容，扩展此类的类不应该声明任何名称以 "visit" 开头的实例方法。

在添加一个这样的新 visit 方法时，此类中的默认实现将调用 visitUnknown 方法。还将引入新的类型种类 visitor 类，以对应新的语言级别；此 visitor 针对相关 visit 方法有不同的默认行为。在引入新的 visitor 时，此 visitor 的全部或部分可能过时。

从以下版本开始：
1.6

字段摘要
从类 javax.lang.model.util.SimpleTypeVisitor6 继承的字段
DEFAULT_VALUE
构造方法摘要
protected | TypeKindVisitor6() 要调用的具体子类的构造方法；使用 null 作为默认值。
protected | TypeKindVisitor6(R defaultValue) 要调用的具体子类的构造方法；使用参数作为默认值。
方法摘要
R | visitNoType(NoType t, P p) 访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。
R | visitNoTypeAsNone(NoType t, P p) 通过调用 defaultAction 访问 NONE 伪类型。
R | visitNoTypeAsPackage(NoType t, P p) 通过调用 defaultAction 访问 PACKAGE 伪类型。
R | visitNoTypeAsVoid(NoType t, P p) 通过调用 defaultAction 访问 VOID 伪类型。
R | visitPrimitive(PrimitiveType t, P p) 访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。
R | visitPrimitiveAsBoolean(PrimitiveType t, P p) 通过调用 defaultAction 访问 BOOLEAN 基本类型。
R | visitPrimitiveAsByte(PrimitiveType t, P p) 通过调用 defaultAction 访问 BYTE 基本类型。
R | visitPrimitiveAsChar(PrimitiveType t, P p) 通过调用 defaultAction 访问 CHAR 基本类型。
R | visitPrimitiveAsDouble(PrimitiveType t, P p) 通过调用 defaultAction 访问 DOUBLE 基本类型。
R | visitPrimitiveAsFloat(PrimitiveType t, P p) 通过调用 defaultAction 访问 FLOAT 基本类型。
R | visitPrimitiveAsInt(PrimitiveType t, P p) 通过调用 defaultAction 访问 INT 基本类型。
R | visitPrimitiveAsLong(PrimitiveType t, P p) 通过调用 defaultAction 访问 LONG 基本类型。
R | visitPrimitiveAsShort(PrimitiveType t, P p) 通过调用 defaultAction 访问 SHORT 基本类型。
从类 javax.lang.model.util.SimpleTypeVisitor6 继承的方法
defaultAction, visitArray, visitDeclared, visitError, visitExecutable, visitNull, visitTypeVariable, visitWildcard
从类 javax.lang.model.util.AbstractTypeVisitor6 继承的方法
visit, visit, visitUnknown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TypeKindVisitor6

protected TypeKindVisitor6()
要调用的具体子类的构造方法；使用 null 作为默认值。

TypeKindVisitor6

protected TypeKindVisitor6(R defaultValue)
要调用的具体子类的构造方法；使用参数作为默认值。

参数：
defaultValue - 为 SimpleTypeVisitor6.DEFAULT_VALUE 分配的值
方法详细信息

visitPrimitive

public R visitPrimitive(PrimitiveType t,
                        P p)
访问基本类型，指派给用于以下特定的基本类型种类的 visit 方法：BOOLEAN、BYTE 等。

指定者：
接口 TypeVisitor<R,P> 中的 visitPrimitive
覆盖：
类 SimpleTypeVisitor6<R,P> 中的 visitPrimitive
参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定种类的 visit 方法的结果

visitPrimitiveAsBoolean

public R visitPrimitiveAsBoolean(PrimitiveType t,
                                 P p)
通过调用 defaultAction 访问 BOOLEAN 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitPrimitiveAsByte

public R visitPrimitiveAsByte(PrimitiveType t,
                              P p)
通过调用 defaultAction 访问 BYTE 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitPrimitiveAsShort

public R visitPrimitiveAsShort(PrimitiveType t,
                               P p)
通过调用 defaultAction 访问 SHORT 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitPrimitiveAsInt

public R visitPrimitiveAsInt(PrimitiveType t,
                             P p)
通过调用 defaultAction 访问 INT 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitPrimitiveAsLong

public R visitPrimitiveAsLong(PrimitiveType t,
                              P p)
通过调用 defaultAction 访问 LONG 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitPrimitiveAsChar

public R visitPrimitiveAsChar(PrimitiveType t,
                              P p)
通过调用 defaultAction 访问 CHAR 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitPrimitiveAsFloat

public R visitPrimitiveAsFloat(PrimitiveType t,
                               P p)
通过调用 defaultAction 访问 FLOAT 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitPrimitiveAsDouble

public R visitPrimitiveAsDouble(PrimitiveType t,
                                P p)
通过调用 defaultAction 访问 DOUBLE 基本类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitNoType

public R visitNoType(NoType t,
                     P p)
访问 NoType 实例，指派给用于以下特定的伪类型种类的 visit 方法：VOID、PACKAGE 或 NONE。

指定者：
接口 TypeVisitor<R,P> 中的 visitNoType
覆盖：
类 SimpleTypeVisitor6<R,P> 中的 visitNoType
参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
特定种类的 visit 方法的结果

visitNoTypeAsVoid

public R visitNoTypeAsVoid(NoType t,
                           P p)
通过调用 defaultAction 访问 VOID 伪类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitNoTypeAsPackage

public R visitNoTypeAsPackage(NoType t,
                              P p)
通过调用 defaultAction 访问 PACKAGE 伪类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果

visitNoTypeAsNone

public R visitNoTypeAsNone(NoType t,
                           P p)
通过调用 defaultAction 访问 NONE 伪类型。

参数：
t - 要访问的类型
p - 特定于 visitor 的参数
返回：
defaultAction 的结果
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Types (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.lang.model.util
接口 Types

public interface Types

用来对类型进行操作的实用工具方法。

兼容性注意事项： 在将来的平台版本中可能会向此接口添加一些方法。

从以下版本开始：
1.6
另请参见：
ProcessingEnvironment.getTypeUtils()

方法摘要
Element | asElement(TypeMirror t) 返回对应于类型的元素。
TypeMirror | asMemberOf(DeclaredType containing, Element element) 当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。
TypeElement | boxedClass(PrimitiveType p) 返回给定基本类型的装箱 (boxed) 值类型的类。
TypeMirror | capture(TypeMirror t) 对类型应用 capture 转换。
boolean | contains(TypeMirror t1, TypeMirror t2) 测试一个类型参数是否包含 另一个类型参数。
List<? extends TypeMirror> | directSupertypes(TypeMirror t) 返回类型的直接超类型。
TypeMirror | erasure(TypeMirror t) 返回删除状态的类型。
ArrayType | getArrayType(TypeMirror componentType) 返回具有指定组件类型的数组类型。
DeclaredType | getDeclaredType(DeclaredType containing, TypeElement typeElem, TypeMirror... typeArgs) 根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。
DeclaredType | getDeclaredType(TypeElement typeElem, TypeMirror... typeArgs) 返回对应于类型元素和实际类型参数的类型。
NoType | getNoType(TypeKind kind) 返回在实际类型不适用的地方所使用的伪类型。
NullType | getNullType() 返回 null 类型。
PrimitiveType | getPrimitiveType(TypeKind kind) 返回基本类型。
WildcardType | getWildcardType(TypeMirror extendsBound, TypeMirror superBound) 返回新的通配符类型参数。
boolean | isAssignable(TypeMirror t1, TypeMirror t2) 测试一种类型是否可以指派给另一种类型。
boolean | isSameType(TypeMirror t1, TypeMirror t2) 测试两个 TypeMirror 对象是否表示同一类型。
boolean | isSubsignature(ExecutableType m1, ExecutableType m2) 测试一个方法的签名是否是另一个方法的子签名。
boolean | isSubtype(TypeMirror t1, TypeMirror t2) 测试一种类型是否是另一个类型的子类型。
PrimitiveType | unboxedType(TypeMirror t) 返回给定类型的拆箱 (unboxed) 值类型（基本类型）。

方法详细信息

asElement

Element asElement(TypeMirror t)
返回对应于类型的元素。该类型可能是 DeclaredType 或 TypeVariable。如果该类型没有对应元素，则返回 null。

返回：
对应于给定类型的元素

isSameType

boolean isSameType(TypeMirror t1,
                   TypeMirror t2)
测试两个 TypeMirror 对象是否表示同一类型。

警告：如果此方法两个参数中有一个表示通配符，那么此方法将返回 false。因此，通配符与其本身的类型不同。初看起来这可能让人感到很奇怪，但考虑到编译器一定会拒绝以下示例时，这就很合理了：

List<?> list = new ArrayList<Object>();
list.add(list.get(0));

参数：
t1 - 第一种类型
t2 - 第二种类型
返回：
当且仅当两种类型相同时返回 true

isSubtype

boolean isSubtype(TypeMirror t1,
                  TypeMirror t2)
测试一种类型是否是另一个类型的子类型。任何类型都被认为是其本身的子类型。

参数：
t1 - 第一种类型
t2 - 第二种类型
返回：
当且仅当第一种类型是第二种类型的子类型时返回 true
抛出：
IllegalArgumentException - 如果给定一个 executable 或 package 类型

isAssignable

boolean isAssignable(TypeMirror t1,
                     TypeMirror t2)
测试一种类型是否可以指派给另一种类型。

参数：
t1 - 第一种类型
t2 - 第二种类型
返回：
当且仅当第一种类型可以指派给第二种类型时返回 true
抛出：
IllegalArgumentException - 如果给定一个 executable 或 package 类型

contains

boolean contains(TypeMirror t1,
                 TypeMirror t2)
测试一个类型参数是否包含 另一个类型参数。

参数：
t1 - 第一种类型
t2 - 第二种类型
返回：
当且仅当第一种类型包含第二种类型时返回 true
抛出：
IllegalArgumentException - 如果给定一个 executable 或 package 类型

isSubsignature

boolean isSubsignature(ExecutableType m1,
                       ExecutableType m2)
测试一个方法的签名是否是另一个方法的子签名。

参数：
m1 - 第一个方法
m2 - 第二个方法
返回：
当且仅当第一个签名是第二个签名的子签名时返回 true

directSupertypes

List<? extends TypeMirror> directSupertypes(TypeMirror t)
返回类型的直接超类型。interface 类型将出现在列表的最后（如果有）。

参数：
t - 将被检查的类型
返回：
直接超类型；如果没有，则返回一个空列表
抛出：
IllegalArgumentException - 如果给定一个 executable 或 package 类型

erasure

TypeMirror erasure(TypeMirror t)
返回删除状态的类型。

参数：
t - 要删除的类型
返回：
删除状态的给定类型
抛出：
IllegalArgumentException - 如果给定一个 package 类型

boxedClass

TypeElement boxedClass(PrimitiveType p)
返回给定基本类型的装箱 (boxed) 值类型的类。即应用 boxing 转换。

参数：
p - 要转换的基本类型
返回：
类型 p 的装箱值类型的类

unboxedType

PrimitiveType unboxedType(TypeMirror t)
返回给定类型的拆箱 (unboxed) 值类型（基本类型）。即应用 unboxing 转换。

参数：
t - 要拆箱的类型
返回：
类型 t 的拆箱值类型
抛出：
IllegalArgumentException - 如果给定类型无法进行 unboxing 转换

capture

TypeMirror capture(TypeMirror t)
对类型应用 capture 转换。

参数：
t - 要转换的类型
返回：
应用 capture 转换的结果
抛出：
IllegalArgumentException - 如果给定 executable 或 package 类型

getPrimitiveType

PrimitiveType getPrimitiveType(TypeKind kind)
返回基本类型。

参数：
kind - 要返回的基本类型的种类
返回：
一个基本类型
抛出：
IllegalArgumentException - 如果 kind 不是基本种类

getNullType

NullType getNullType()
返回 null 类型。该类型是 null 的类型。

返回：
null 类型

getNoType

NoType getNoType(TypeKind kind)
返回在实际类型不适用的地方所使用的伪类型。要返回的类型的种类可以是 VOID 或 NONE。对于包，可以使用 Elements.getPackageElement(CharSequence) .asType() 替代。

参数：
kind - 要返回的类型的种类
返回：
种类 VOID 或 NONE 的伪类型
抛出：
IllegalArgumentException - 如果 kind 无效

getArrayType

ArrayType getArrayType(TypeMirror componentType)
返回具有指定组件类型的数组类型。

参数：
componentType - 组件类型
返回：
具有指定组件类型的数组类型。
抛出：
IllegalArgumentException - 如果组件类型对于数组无效

getWildcardType

WildcardType getWildcardType(TypeMirror extendsBound,
                             TypeMirror superBound)
返回新的通配符类型参数。可以指定通配符边界中的一个，也可以都不指定，但不能都指定。

参数：
extendsBound - 扩展（上）边界；如果没有，则该参数为 null
superBound - 超（下）边界；如果没有，则该参数为 null
返回：
新的通配符
抛出：
IllegalArgumentException - 如果边界无效

getDeclaredType

DeclaredType getDeclaredType(TypeElement typeElem,
                             TypeMirror... typeArgs)
返回对应于类型元素和实际类型参数的类型。例如，如果给定 Set 的类型元素和 String 的类型镜像，那么可以使用此方法获取参数化类型 Set<String>。

类型参数的数量必须等于类型元素的形式类型参数的数量，或者等于 0。如果等于 0，并且类型元素是泛型，则返回该类型元素的原始类型。

如果返回一个参数化类型，则其类型元素不得包含在一般外部类中。例如，首先使用此方法获取类型 Outer<String>，然后调用 getDeclaredType(DeclaredType, TypeElement, TypeMirror...)，可以构造参数化类型 Outer<String>.Inner<Number>。

参数：
typeElem - 类型元素
typeArgs - 实际类型参数
返回：
对应于类型元素和实际类型参数的类型
抛出：
IllegalArgumentException - 如果给定的类型参数太多或太少，或者提供不合适的类型参数或类型元素

getDeclaredType

DeclaredType getDeclaredType(DeclaredType containing,
                             TypeElement typeElem,
                             TypeMirror... typeArgs)
根据给定的包含类型，返回对应于类型元素和实际类型参数的类型（它是给定包含类型的成员）。例如，通过首先使用 getDeclaredType(TypeElement, TypeMirror...) 获取类型 Outer<String>，然后调用此方法，可以构造参数化类型 Outer<String>.Inner<Number>。

如果包含类型是一个参数化类型，则类型参数的数量必须等于 typeElem 的形式类型参数的数量。如果包含类型不是参数化的，或者为 null，则此方法等效于 getDeclaredType(typeElem, typeArgs)。

参数：
containing - 包含类型；如果没有，则该参数为 null
typeElem - 类型元素
typeArgs - 实际类型参数
返回：
对应于类型元素和实际类型参数的类型，该类型包含在给定类型中
抛出：
IllegalArgumentException - 如果给定的类型参数太多或太少，或者提供了不合适的类型参数、类型元素或包含类型

asMemberOf

TypeMirror asMemberOf(DeclaredType containing,
                      Element element)
当元素被视为给定类型的成员或者直接由给定类型包含时，返回该元素的类型。例如，被视为参数化类型 Set<String> 的成员时，Set.add 方法是参数类型为 String 的 ExecutableType。

参数：
containing - 包含类型
element - 元素
返回：
从包含类型来看的元素的类型
抛出：
IllegalArgumentException - 如果元素对于给定类型无效
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.lang.model.util (Java 2 Platform SE 6)

 javax.lang.model.util
接口
Elements
Types
类
AbstractAnnotationValueVisitor6
AbstractElementVisitor6
AbstractTypeVisitor6
ElementFilter
ElementKindVisitor6
ElementScanner6
SimpleAnnotationValueVisitor6
SimpleElementVisitor6
SimpleTypeVisitor6
TypeKindVisitor6


javax.lang.model.util (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.lang.model.util

用来帮助处理程序元素和类型的实用工具。

请参见：
描述

接口摘要
Elements | 用来对程序元素进行操作的实用工具方法。
Types | 用来对类型进行操作的实用工具方法。

类摘要
AbstractAnnotationValueVisitor6<R,P> | 注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractElementVisitor6<R,P> | 程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractTypeVisitor6<R,P> | 类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。
ElementFilter | 用来从元素集合中只选择所需元素的过滤器。
ElementKindVisitor6<R,P> | 基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
ElementScanner6<R,P> | 程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleAnnotationValueVisitor6<R,P> | 注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleElementVisitor6<R,P> | 程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleTypeVisitor6<R,P> | 类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
TypeKindVisitor6<R,P> | 基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

软件包 javax.lang.model.util 的描述

用来帮助处理程序元素和类型的实用工具。

除非在特定实现中另行指定，否则此包中的方法所返回的集合应该是不能由调用者修改的，并且对于并发访问是不安全的。

除非另行指定，否则，如果给定一个 null 参数，此包中的方法将抛出 NullPointerException。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.lang.model.util 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model.util 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.lang.model.util.AbstractAnnotationValueVisitor6<R,P> (implements javax.lang.model.element.AnnotationValueVisitor<R,P>)
      • javax.lang.model.util.SimpleAnnotationValueVisitor6<R,P>
    • javax.lang.model.util.AbstractElementVisitor6<R,P> (implements javax.lang.model.element.ElementVisitor<R,P>)
      • javax.lang.model.util.ElementScanner6<R,P>
      • javax.lang.model.util.SimpleElementVisitor6<R,P>
        • javax.lang.model.util.ElementKindVisitor6<R,P>
    • javax.lang.model.util.AbstractTypeVisitor6<R,P> (implements javax.lang.model.type.TypeVisitor<R,P>)
      • javax.lang.model.util.SimpleTypeVisitor6<R,P>
        • javax.lang.model.util.TypeKindVisitor6<R,P>
    • javax.lang.model.util.ElementFilter

接口分层结构

  • javax.lang.model.util.Elements
  • javax.lang.model.util.Types
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.lang.model.util 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.lang.model.util
的使用

使用 javax.lang.model.util 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model.util | 用来帮助处理程序元素和类型的实用工具。

javax.annotation.processing 使用的 javax.lang.model.util 中的类
Elements
用来对程序元素进行操作的实用工具方法。
Types
用来对类型进行操作的实用工具方法。

javax.lang.model.util 使用的 javax.lang.model.util 中的类
AbstractAnnotationValueVisitor6
注释值的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractElementVisitor6
程序元素的骨干 visitor，具有适用于 RELEASE_6 源版本的默认行为。
AbstractTypeVisitor6
类型的骨干 visitor，具有适用于第 6 版语言级别的默认行为。
SimpleElementVisitor6
程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
SimpleTypeVisitor6
类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.AbstractAnnotationValueVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.AbstractAnnotationValueVisitor6
的使用

使用 AbstractAnnotationValueVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 AbstractAnnotationValueVisitor6 的使用

javax.lang.model.util 中 AbstractAnnotationValueVisitor6 的子类
 class SimpleAnnotationValueVisitor6<R,P>
注释值的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.AbstractElementVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.AbstractElementVisitor6
的使用

使用 AbstractElementVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 AbstractElementVisitor6 的使用

javax.lang.model.util 中 AbstractElementVisitor6 的子类
class | ElementKindVisitor6<R,P> 基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | ElementScanner6<R,P> 程序元素的扫描 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | SimpleElementVisitor6<R,P> 程序元素的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.AbstractTypeVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.AbstractTypeVisitor6
的使用

使用 AbstractTypeVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 AbstractTypeVisitor6 的使用

javax.lang.model.util 中 AbstractTypeVisitor6 的子类
class | SimpleTypeVisitor6<R,P> 类型的简单 visitor，具有适用于 RELEASE_6 源版本的默认行为。
class | TypeKindVisitor6<R,P> 基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.ElementFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.ElementFilter
的使用

没有 javax.lang.model.util.ElementFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.ElementKindVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.ElementKindVisitor6
的使用

没有 javax.lang.model.util.ElementKindVisitor6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.ElementScanner6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.ElementScanner6
的使用

没有 javax.lang.model.util.ElementScanner6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.util.Elements 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.util.Elements
的使用

使用 Elements 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Elements 的使用

返回 Elements 的 javax.annotation.processing 中的方法
 Elements ProcessingEnvironment.getElementUtils()
返回用来在元素上进行操作的某些实用工具方法的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.SimpleAnnotationValueVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.SimpleAnnotationValueVisitor6
的使用

没有 javax.lang.model.util.SimpleAnnotationValueVisitor6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.SimpleElementVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.SimpleElementVisitor6
的使用

使用 SimpleElementVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 SimpleElementVisitor6 的使用

javax.lang.model.util 中 SimpleElementVisitor6 的子类
 class ElementKindVisitor6<R,P>
基于其 kind 的程序元素的 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.SimpleTypeVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.SimpleTypeVisitor6
的使用

使用 SimpleTypeVisitor6 的软件包
javax.lang.model.util 用来帮助处理程序元素和类型的实用工具。

javax.lang.model.util 中 SimpleTypeVisitor6 的使用

javax.lang.model.util 中 SimpleTypeVisitor6 的子类
 class TypeKindVisitor6<R,P>
基于其种类的类型 visitor，具有适用于 RELEASE_6 源版本的默认行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.util.TypeKindVisitor6 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.util.TypeKindVisitor6
的使用

没有 javax.lang.model.util.TypeKindVisitor6 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.lang.model.util.Types 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.lang.model.util.Types
的使用

使用 Types 的软件包
javax.annotation.processing 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。

javax.annotation.processing 中 Types 的使用

返回 Types 的 javax.annotation.processing 中的方法
 Types ProcessingEnvironment.getTypeUtils()
返回用来在类型上进行操作的某些实用工具方法的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.lang.model.SourceVersion 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.lang.model.SourceVersion
的使用

使用 SourceVersion 的软件包
javax.annotation.processing | 用来声明注释处理器并允许注释处理器与注释处理工具环境通信的工具。
javax.lang.model | 用来为 Java 编程语言建立模型的包的类和层次结构。
javax.tools | 为能够从程序（例如，编译器）中调用的工具提供接口。

javax.annotation.processing 中 SourceVersion 的使用

返回 SourceVersion 的 javax.annotation.processing 中的方法
SourceVersion | ProcessingEnvironment.getSourceVersion() 返回任何生成的源和类文件应该符合的源版本。
SourceVersion | AbstractProcessor.getSupportedSourceVersion() 如果 processor 类是使用 SupportedSourceVersion 注释的，则返回注释中的源版本。
SourceVersion | Processor.getSupportedSourceVersion() 返回此注释 Processor 支持的最新的源版本。

javax.lang.model 中 SourceVersion 的使用

返回 SourceVersion 的 javax.lang.model 中的方法
static SourceVersion | SourceVersion.latest() 返回可以建模的最新源版本。
static SourceVersion | SourceVersion.latestSupported() 返回完全受当前执行环境支持的最新源版本。
static SourceVersion | SourceVersion.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SourceVersion[] | SourceVersion.values() Returns an array containing the constants of this enum type, in the order they are declared.

javax.tools 中 SourceVersion 的使用

返回变量类型为 SourceVersion 的类型的 javax.tools 中的方法
 Set<SourceVersion> Tool.getSourceVersions()
获取此工具支持的 Java™ 编程语言的源版本。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Attribute (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management
类 Attribute

java.lang.Object
    继承者  javax.management.Attribute
所有已实现的接口：
Serializable
public class Attribute
extends Object
implements Serializable

通过将 MBean 属性名与其值相关联来表示 MBean 属性。MBean 服务器和其他对象使用此类来获得并设置属性值。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
Attribute(String name, Object value)
构造将给定的属性名与给定值相关联的 Attribute 对象。
方法摘要
boolean | equals(Object object) 比较当前的 Attribute Object 与另一个 Attribute Object。
String | getName() 返回包含该 Attribute 的名称的 String。
Object | getValue() 返回此 Attribute 值的 Object。
int | hashCode() 返回此属性的哈希码值。
String | toString() 返回一个表示此 Attribute 值 String 对象。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Attribute

public Attribute(String name,
                 Object value)
构造将给定的属性名与给定值相关联的 Attribute 对象。

参数：
name - 一个 String，包含要创建的属性的名称。不可以为 null。
value - 分配给属性的 Object。此对象必须与该属性的类型相同。
方法详细信息

getName

public String getName()
返回包含该 Attribute 的名称的 String。

返回：
Attribute 的名称。

getValue

public Object getValue()
返回此 Attribute 值的 Object。

返回：
Attribute 的值。

equals

public boolean equals(Object object)
比较当前的 Attribute Object 与另一个 Attribute Object。

覆盖：
类 Object 中的 equals
参数：
object - 要与当前 Attribute 进行比较的 Attribute。
返回：
如果两个 Attribute 对象相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此属性的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此属性的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回一个表示此 Attribute 值 String 对象。此字符串的格式是未指定的，但当且仅当两个 Attributes 相等时，才返回相同的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AttributeChangeNotification (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 AttributeChangeNotification

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.management.Notification
            继承者  javax.management.AttributeChangeNotification
所有已实现的接口：
Serializable
public class AttributeChangeNotification
extends Notification

提供 MBean 所发送的属性更改通知的定义。

当属性发生更改时，由拥有相关属性的 MBean 负责创建并发送属性更改通知。所以必须由发生属性更改的 MBean 来实现 NotificationBroadcaster 接口。

示例：如果一个称为 myMbean 的 MBean 在其属性

String myString
被修改时通知已注册的侦听器，则 myMbean 创建并忽略以下通知：new AttributeChangeNotification(myMbean, sequenceNumber, timeStamp, msg, "myString", "String", oldValue, newValue);

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static String ATTRIBUTE_CHANGE
通知类型，指示所观察的 MBean 属性值已更改。
从类 javax.management.Notification 继承的字段
source
构造方法摘要
AttributeChangeNotification(Object source, long sequenceNumber, long timeStamp, String msg, String attributeName, String attributeType, Object oldValue, Object newValue)
构造一个 AttributeChangeNotification 对象。
方法摘要
String | getAttributeName() 获得已更改属性的名称。
String | getAttributeType() 获得已更改属性的类型。
Object | getNewValue() 获得已更改属性的新值。
Object | getOldValue() 获得已更改属性的旧值。
从类 javax.management.Notification 继承的方法
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ATTRIBUTE_CHANGE

public static final String ATTRIBUTE_CHANGE
通知类型，指示所观察的 MBean 属性值已更改。
此类型字符串的值是 jmx.attribute.change。

另请参见：
常量字段值
构造方法详细信息

AttributeChangeNotification

public AttributeChangeNotification(Object source,
                                   long sequenceNumber,
                                   long timeStamp,
                                   String msg,
                                   String attributeName,
                                   String attributeType,
                                   Object oldValue,
                                   Object newValue)
构造一个 AttributeChangeNotification 对象。除了所有通知共有的信息外，调用者还必须提供属性的名称和类型，以及属性的旧值和新值。

参数：
source - 通知生成者，也就是该属性所属的 MBean。
sequenceNumber - 源对象内的通知序列号。
timeStamp - 发送通知的日期。
msg - 包含通知消息的 String。
attributeName - 提供属性名称的 String。
attributeType - 包含属性类型的 String。
oldValue - 表示更改属性前该属性值的对象。
newValue - 表示更改属性后该属性值的对象。
方法详细信息

getAttributeName

public String getAttributeName()
获得已更改属性的名称。

返回：
包含属性名称的 String。

getAttributeType

public String getAttributeType()
获得已更改属性的类型。

返回：
包含属性类型的 String。

getOldValue

public Object getOldValue()
获得已更改属性的旧值。

返回：
包含属性旧值的 Object。

getNewValue

public Object getNewValue()
获得已更改属性的新值。

返回：
包含属性新值的 Object。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeChangeNotificationFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 AttributeChangeNotificationFilter

java.lang.Object
    继承者  javax.management.AttributeChangeNotificationFilter
所有已实现的接口：
Serializable, NotificationFilter
public class AttributeChangeNotificationFilter
extends Object
implements NotificationFilter

此类实现 attribute change notification 的 NotificationFilter 接口。根据所观察属性的名称进行过滤。

它管理已启用的属性名称列表。方法允许用户启用/禁用所需数量的属性名称。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AttributeChangeNotificationFilter()
方法摘要
void | disableAllAttributes() 禁用所有属性名称。
void | disableAttribute(String name) 禁用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定属性名称。
void | enableAttribute(String name) 启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。
Vector<String> | getEnabledAttributes() 获得此过滤器的所有已启用属性名称。
boolean | isNotificationEnabled(Notification notification) 向侦听器发送指定的通知之前调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AttributeChangeNotificationFilter

public AttributeChangeNotificationFilter()
方法详细信息

isNotificationEnabled

public boolean isNotificationEnabled(Notification notification)
向侦听器发送指定的通知之前调用。
此过滤器将指定属性更改通知的属性名称与每个已启用属性名称进行比较。如果该属性名称等于某个已启用属性名称，则必须将该通知发送到侦听器，并且此方法返回 true。

指定者：
接口 NotificationFilter 中的 isNotificationEnabled
参数：
notification - 要发送的属性更改通知。
返回：
如果必须将通知发送到侦听器，则返回 true；否则返回 false。

enableAttribute

public void enableAttribute(String name)
                     throws IllegalArgumentException
启用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定名称。
如果指定的名称已在已启用属性名称列表中，则此方法无效。

参数：
name - 属性名称。
抛出：
IllegalArgumentException - 如果属性名称的参数为 null。

disableAttribute

public void disableAttribute(String name)
禁用所有属性更改通知，这些通知的属性名称等于要发送到侦听器的指定属性名称。
如果指定的名称不在已启用属性名称列表中，则此方法无效。

参数：
name - 属性名称。

disableAllAttributes

public void disableAllAttributes()
禁用所有属性名称。

getEnabledAttributes

public Vector<String> getEnabledAttributes()
获得此过滤器的所有已启用属性名称。

返回：
包含所有已启用属性名称的列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 AttributeList

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.ArrayList<Object>
                继承者  javax.management.AttributeList
所有已实现的接口：
Serializable, Cloneable, Iterable<Object>, Collection<Object>, List<Object>, RandomAccess
public class AttributeList
extends ArrayList<Object>

表示 MBean 属性值的列表。用于在 AttributeList 中插入 Attribute 对象的方法应重写超类 ArrayList 中的相应方法。为了确保 AttributeList 中所包含的对象只是 Attribute 对象，这是必需的。这可避免在检索 AttributeList 中的元素时出现异常。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
AttributeList()
构造一个空 AttributeList。
AttributeList(AttributeList list)
构造一个包含指定 AttributeList 元素的 AttributeList，元素的顺序是该 AttributeList 的迭代器所返回的顺序。
AttributeList(int initialCapacity)
构造一个具有指定初始容量的空 AttributeList。
AttributeList(List<Attribute> list)
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。
方法摘要
void | add(Attribute object) 添加指定的 Attribute 作为列表的最后一个元素。
void | add(int index, Attribute object) 插入指定的属性作为指定位置处的元素。
void | add(int index, Object element) 将指定的元素插入此列表中的指定位置。
boolean | add(Object o) 将指定的元素添加到此列表的尾部。
boolean | addAll(AttributeList list) 将指定 AttributeList 中的所有元素追加到列表的末尾，元素的顺序是指定 AttributeList 的 Iterator 所返回的顺序。
boolean | addAll(Collection<?> c) 按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
boolean | addAll(int index, AttributeList list) 将指定 AttributeList 中的所有元素插入此列表，从指定的位置开始插入，元素的顺序是指定 Attribute 的 Iterator 所返回的顺序。
boolean | addAll(int index, Collection<?> c) 从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
List<Attribute> | asList() 以 List<Attribute> 的形式返回此列表的视图。
void | set(int index, Attribute object) 将指定位置的元素设置为指定的属性。
Object | set(int index, Object element) 用指定的元素替代此列表中指定位置上的元素。
从类 java.util.ArrayList 继承的方法
clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, size, toArray, toArray, trimToSize
从类 java.util.AbstractList 继承的方法
equals, hashCode, iterator, listIterator, listIterator, subList
从类 java.util.AbstractCollection 继承的方法
containsAll, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

构造方法详细信息

AttributeList

public AttributeList()
构造一个空 AttributeList。

AttributeList

public AttributeList(int initialCapacity)
构造一个具有指定初始容量的空 AttributeList。

参数：
initialCapacity - AttributeList 的初始容量，正如 ArrayList.ArrayList(int) 所指定的那样。

AttributeList

public AttributeList(AttributeList list)
构造一个包含指定 AttributeList 元素的 AttributeList，元素的顺序是该 AttributeList 的迭代器所返回的顺序。AttributeList 实例的初始容量是指定 AttributeList 大小的 110％。

参数：
list - 定义新 AttributeList 的初始内容的 AttributeList。
另请参见：
ArrayList.ArrayList(java.util.Collection)

AttributeList

public AttributeList(List<Attribute> list)
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。

参数：
list - 定义新 AttributeList 初始内容的 List。
抛出：
IllegalArgumentException - 如果 list 参数为 null 或者 list 参数包含任何非 Attribute 对象。
从以下版本开始：
1.6
另请参见：
ArrayList.ArrayList(java.util.Collection)
方法详细信息

asList

public List<Attribute> asList()
以 List<Attribute> 的形式返回此列表的视图。对返回值的更改将通过对原 AttributeList 的更改反映出来，反之亦然。

返回：
一个 List<Attribute>，其内容反映此 AttributeList 的内容。

如果给定的 AttributeList 实例曾经调用过此方法，则之后试图对该实例添加非 Attribute 对象的操作将会失败，并抛出 IllegalArgumentException。出于兼容性原因，允许向从未调用过此方法的 AttributeList 添加非 Attribute 对象。

抛出：
IllegalArgumentException - 如果此 AttributeList 包含非 Attribute 元素。
从以下版本开始：
1.6

add

public void add(Attribute object)
添加指定的 Attribute 作为列表的最后一个元素。

参数：
object - 要添加的属性。

add

public void add(int index,
                Attribute object)
插入指定的属性作为指定位置处的元素。其索引大于等于当前位置索引的元素会向上移动。如果 index 超出范围 (index < 0 || index > size())，则将引发 RuntimeOperationsException，并包装所抛出的 java.lang.IndexOutOfBoundsException。

参数：
object - 要插入的 Attribute 对象。
index - 列表中插入新 Attribute 对象的位置。

set

public void set(int index,
                Attribute object)
将指定位置的元素设置为指定的属性。丢弃该位置以前的元素。如果 index 超出范围 (index < 0 || index > size())，则将引发 RuntimeOperationsException，并包装所抛出的 java.lang.IndexOutOfBoundsException。

参数：
object - 属性元素应该被设置的值。
index - 指定的位置。

addAll

public boolean addAll(AttributeList list)
将指定 AttributeList 中的所有元素追加到列表的末尾，元素的顺序是指定 AttributeList 的 Iterator 所返回的顺序。

参数：
list - 要插入该列表的元素。
返回：
如果此列表由于调用而更改，则返回 true。
另请参见：
ArrayList.addAll(java.util.Collection)

addAll

public boolean addAll(int index,
                      AttributeList list)
将指定 AttributeList 中的所有元素插入此列表，从指定的位置开始插入，元素的顺序是指定 Attribute 的 Iterator 所返回的顺序。如果 index 超出范围 (index < 0 || index > size())，则将引发 RuntimeOperationsException，并包装所抛出的 java.lang.IndexOutOfBoundsException。

参数：
list - 要插入该列表的元素。
index - 插入指定 AttributeList 中首个元素的位置。
返回：
如果此列表由于调用而更改，则返回 true。
另请参见：
ArrayList.addAll(int, java.util.Collection)

add

public boolean add(Object o)
从类 ArrayList 复制的描述
将指定的元素添加到此列表的尾部。

指定者：
接口 Collection<Object> 中的 add
指定者：
接口 List<Object> 中的 add
覆盖：
类 ArrayList<Object> 中的 add
参数：
o - 要添加到此列表中的元素
返回：
true（按照 Collection.add(E) 的指定）

add

public void add(int index,
                Object element)
从类 ArrayList 复制的描述
将指定的元素插入此列表中的指定位置。向右移动当前位于该位置的元素（如果有）以及所有后续元素（将其索引加 1）。

指定者：
接口 List<Object> 中的 add
覆盖：
类 ArrayList<Object> 中的 add
参数：
index - 指定元素所插入位置的索引
element - 要插入的元素

addAll

public boolean addAll(Collection<?> c)
从类 ArrayList 复制的描述
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。如果正在进行此操作时修改指定的 collection ，那么此操作的行为是不确定的。（这意味着如果指定的 collection 是此列表且此列表是非空的，那么此调用的行为是不确定的）。

指定者：
接口 Collection<Object> 中的 addAll
指定者：
接口 List<Object> 中的 addAll
覆盖：
类 ArrayList<Object> 中的 addAll
参数：
c - 包含要添加到此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
另请参见：
AbstractCollection.add(Object)

addAll

public boolean addAll(int index,
                      Collection<?> c)
从类 ArrayList 复制的描述
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。向右移动当前位于该位置的元素（如果有）以及所有后续元素（增加其索引）。新元素将按照指定 collection 的迭代器所返回的元素顺序出现在列表中。

指定者：
接口 List<Object> 中的 addAll
覆盖：
类 ArrayList<Object> 中的 addAll
参数：
index - 插入指定 collection 中的首个元素的位置索引
c - 包含要添加到此列表中元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true

set

public Object set(int index,
                  Object element)
从类 ArrayList 复制的描述
用指定的元素替代此列表中指定位置上的元素。

指定者：
接口 List<Object> 中的 set
覆盖：
类 ArrayList<Object> 中的 set
参数：
index - 要替代的元素的索引
element - 存储在指定位置上的元素
返回：
以前位于该指定位置上的元素
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 AttributeNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.AttributeNotFoundException
所有已实现的接口：
Serializable
public class AttributeNotFoundException
extends OperationsException

指定的属性不存在或无法检索。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AttributeNotFoundException()
默认的构造方法。
AttributeNotFoundException(String message)
允许指定具体错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AttributeNotFoundException

public AttributeNotFoundException()
默认的构造方法。

AttributeNotFoundException

public AttributeNotFoundException(String message)
允许指定具体错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeValueExp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 AttributeValueExp

java.lang.Object
    继承者  javax.management.AttributeValueExp
所有已实现的接口：
Serializable, ValueExp
public class AttributeValueExp
extends Object
implements ValueExp

表示用作关系约束参数的属性。可在需要 ValueExp 的任何地方使用 AttributeValueExp。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AttributeValueExp()
已过时。 在查询中不能使用此构造方法所创建的实例。
AttributeValueExp(String attr)
创建一个表示指定对象属性 attr 的新 AttributeValueExp。
方法摘要
ValueExp | apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
protected Object | getAttribute(ObjectName name) 返回指定的 MBean 中给定属性的值。
String | getAttributeName() 返回该属性名称的字符串表示形式。
void | setMBeanServer(MBeanServer s) 设置要在其上执行查询的 MBean 服务器。
String | toString() 返回表示其值的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AttributeValueExp

@Deprecated
public AttributeValueExp()
已过时。 在查询中不能使用此构造方法所创建的实例。

具有 null 属性的 AttributeValueExp。

AttributeValueExp

public AttributeValueExp(String attr)
创建一个表示指定对象属性 attr 的新 AttributeValueExp。

参数：
attr - 属性名称，该属性的值是此 ValueExp 的值。
方法详细信息

getAttributeName

public String getAttributeName()
返回该属性名称的字符串表示形式。

返回：
属性名称。

apply

public ValueExp apply(ObjectName name)
               throws BadStringOperationException,
                      BadBinaryOpValueExpException,
                      BadAttributeValueExpException,
                      InvalidApplicationException
在 MBean 上应用 AttributeValueExp。

指定者：
接口 ValueExp 中的 apply
参数：
name - MBean 的名称，将在该 MBean 上应用 AttributeValueExp。
返回：
ValueExp。
抛出：
BadAttributeValueExpException
InvalidApplicationException
BadStringOperationException
BadBinaryOpValueExpException

toString

public String toString()
返回表示其值的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

setMBeanServer

public void setMBeanServer(MBeanServer s)
设置要在其上执行查询的 MBean 服务器。

指定者：
接口 ValueExp 中的 setMBeanServer
参数：
s - 要在其上执行查询的 MBean 服务器。

getAttribute

protected Object getAttribute(ObjectName name)
返回指定的 MBean 中给定属性的值。如果试图访问属性时生成异常，则返回 null。

参数：
name - 要返回其属性的 MBean 名称。
返回：
属性的值，如果无法获得，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BadAttributeValueExpException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 BadAttributeValueExpException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.BadAttributeValueExpException
所有已实现的接口：
Serializable
public class BadAttributeValueExpException
extends Exception

向构造的查询方法传递无效的 MBean 属性时，抛出此异常。在查询计算期间，由 JMX 在内部使用此异常。用户代码通常无法看到它。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
BadAttributeValueExpException(Object val)
构造带指定 Object 的 BadAttributeValueExpException。
方法摘要
 String toString()
返回该对象的字符串表示形式。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BadAttributeValueExpException

public BadAttributeValueExpException(Object val)
构造带指定 Object 的 BadAttributeValueExpException。

参数：
val - 不合适的值。
方法详细信息

toString

public String toString()
返回该对象的字符串表示形式。

覆盖：
类 Throwable 中的 toString
返回：
该 throwable 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BadBinaryOpValueExpException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 BadBinaryOpValueExpException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.BadBinaryOpValueExpException
所有已实现的接口：
Serializable
public class BadBinaryOpValueExpException
extends Exception

向构造查询的方法传递无效的表达式时，抛出此异常。在查询计算期间，由 JMX 在内部使用此异常。用户代码通常无法看到它。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
BadBinaryOpValueExpException(ValueExp exp)
构造带指定 ValueExp 的 BadBinaryOpValueExpException。
方法摘要
ValueExp | getExp() 返回产生该异常的 ValueExp。
String | toString() 返回该对象的字符串表示形式。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BadBinaryOpValueExpException

public BadBinaryOpValueExpException(ValueExp exp)
构造带指定 ValueExp 的 BadBinaryOpValueExpException。

参数：
exp - 其值不合适的表达式。
方法详细信息

getExp

public ValueExp getExp()
返回产生该异常的 ValueExp。

返回：
导致问题的 ValueExp。

toString

public String toString()
返回该对象的字符串表示形式。

覆盖：
类 Throwable 中的 toString
返回：
该 throwable 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BadStringOperationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 BadStringOperationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.BadStringOperationException
所有已实现的接口：
Serializable
public class BadStringOperationException
extends Exception

向构造查询的方法传递无效的字符串操作时，抛出此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
BadStringOperationException(String message)
构造带指定详细消息的 BadStringOperationException。
方法摘要
 String toString()
返回该对象的字符串表示形式。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BadStringOperationException

public BadStringOperationException(String message)
构造带指定详细消息的 BadStringOperationException。

参数：
message - 详细消息。
方法详细信息

toString

public String toString()
返回该对象的字符串表示形式。

覆盖：
类 Throwable 中的 toString
返回：
该 throwable 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultLoaderRepository (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 DefaultLoaderRepository

java.lang.Object
    继承者  javax.management.DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。

@Deprecated
public class DefaultLoaderRepository
extends Object

保存 MBean 服务器中已注册的 Class Loader 列表。它提供了必需的方法，以便使用已注册的 Class Loader 加载类。

维护这个过时的类是出于兼容性考虑。在以前的 JMX API 版本中，有一个所有 MBean 服务器共享的 DefaultLoaderRepository。从 JMX API 1.2 开始，该功能近似于使用 MBeanServerFactory.findMBeanServer(java.lang.String) 来查找所有已知的 MBean 服务器，并参考每个服务器的 ClassLoaderRepository。强烈推荐重写引用 DefaultLoaderRepository 的代码。

从以下版本开始：
1.5

构造方法摘要
DefaultLoaderRepository()
已过时。
方法摘要
static Class | loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
static Class | loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultLoaderRepository

public DefaultLoaderRepository()
已过时。
方法详细信息

loadClass

public static Class loadClass(String className)
                       throws ClassNotFoundException
已过时。
仔细检查类加载器列表，并尝试加载所请求的类。一旦找到该类，就立即停止此方法。如果找不到该类，则此方法将抛出 ClassNotFoundException 异常。

参数：
className - 要被加载的类名称。
返回：
加载的类。
抛出：
ClassNotFoundException - 如果找不到指定的类。

loadClassWithout

public static Class loadClassWithout(ClassLoader loader,
                                     String className)
                              throws ClassNotFoundException
已过时。
仔细检查除了给定类加载器之外的类加载器列表，然后尝试加载所请求的类。一旦找到该类，就立即停止此方法。如果找不到该类，则此方法将抛出 ClassNotFoundException 异常。

参数：
className - 要被加载的类名称。
loader - 不包括的类加载器。
返回：
加载的类。
抛出：
ClassNotFoundException - 如果找不到指定的类。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Descriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 Descriptor

所有超级接口：
Cloneable, Serializable
所有已知实现类：
DescriptorSupport, ImmutableDescriptor
public interface Descriptor
extends Serializable, Cloneable

JMX 元素的附加元数据。Descriptor 与 MBeanInfo、MBeanAttributeInfo 等关联。它由一个字段集合组成。字段由一个名称和一个关联值组成。

字段名称不区分大小写。名称 descriptorType、descriptortype 和 DESCRIPTORTYPE 都是等效的。但是，第一次设置字段时所使用的大小写将保留在 getFields() 和 getFieldNames() 方法的结果中。

并非所有的字段名称和值都可以预定义。任何程序都可以定义和添加新字段。

描述符可以是可变的，也可以是不可变的。不可变的描述符一旦创建就不能更改。对于不可变的描述符，可以修改描述符内容的 Descriptor 方法将抛出异常。不可变的描述符通常是 ImmutableDescriptor 或子类的实例。可变描述符通常是 DescriptorSupport 或子类的实例。

某些字段由 JMX 实现使用。这意味着这类字段的存在可以改变 JMX API 的行为，或者可以在 JMX API 返回的描述符中设置这类字段。这些字段在下表中将以斜体 形式出现，每个字段在 JMX 类中都有一个相应的常量。例如，字段 defaultValue 由常量 JMX.DEFAULT_VALUE_FIELD 表示。

在下表中描述了某些其他字段的常规含意，但 JMX 实现不必了解或设置它们。

在此版本或所有未来版本中由 JMX 规范定义的字段名称将永远不会包含句点 (.)。通过在名称中包含句点，用户可以安全地创建自己的字段，并能确保这些名称不会与任何将来的 JMX API 版本相冲突。建议遵循 Java 包命名约定以避免不同来源的字段名称发生冲突。例如，由 example.com 创建的字段可能有名称 com.example.interestLevel。

注意，defaultValue、legalValues、maxValue 和 minValue 字段中的值应该与对关联的 MBeanAttributeInfo 或 MBeanParameterInfo 调用 getType() 方法所返回的类型一致。对于 MXBean，这意味着它们应该属于映射的 Java 类型，该类型在 MXBean 类型映射规则中称作 opendata(J)。

名称 | 类型 | 使用范围 | 含义
defaultValue | Object | MBeanAttributeInfo MBeanParameterInfo | 属性或参数的默认值。请参阅 javax.management.openmbean。
deprecated | String | 所有 | 建议不再使用此信息模型元素的指示。应用程序定义的一组 MBean 总称为信息模型。此字段值的惯例是包含一个字符串，该字符串中首先是元素第一次被废弃时的模型版本，后跟空格，然后是对废弃的解释，例如 &quot;1.3 Replaced by the Capacity attribute&quot;。
descriptionResource BundleBaseName | String | 所有 | ResourceBundle 的基本名称，可以在该 ResourceBundle 中找到在 descriptionResourceKey 字段中给定的键，例如 &quot;com.example.myapp.MBeanResources&quot;。此字段的含义由此规范定义，但 JMX API 本身不会设置或使用该字段。
descriptionResourceKey | String | 所有 | 描述此元素的资源键。它可以与 descriptionResourceBundleBaseName 一起使用来查找描述的本地化版本。此字段的含义由此规范定义，但 JMX API 本身不会设置或使用该字段。
enabled | String | MBeanAttributeInfo MBeanNotificationInfo MBeanOperationInfo | 根据此项启用与否，决定字符串为 &quot;true&quot; 或 &quot;false&quot;。不启用属性或操作时，它仍存在，但当前无法访问。用户界面可能将其表示为灰色项。例如，只有调用了 MBean 的 start() 方法后属性才可能有意义，否则它将被禁用。同样，如果当前无法发出通知但其他情况下可以发出时，则它可能被禁用。
immutableInfo | String | MBeanInfo | 根据此 MBean 的 MBeanInfo 是否为不可变，决定字符串为 &quot;true&quot; 或 &quot;false&quot;。此字段为 true 时，可以保证给定 MBean 的 MBeanInfo 不会随 MBean 的生存期而更改。因此，客户端可以对其进行一次读取并缓存读取值。此字段为 false 或不存在时，则无法提供这样的保证，虽然这并不意味着 MBeanInfo 一定发生变化。
infoTimeout | String Long | MBeanInfo | MBeanInfo 理应不会更改的时间，以毫秒为单位。该值可以是 Long，也可以是十进制字符串。这从 DynamicMBean 或任何没有将 immutableInfo 定义为 true 的 MBean 中得出一个提示，MBeanInfo 不可能在此期间发生变化，因此可以缓存。此字段丢失或具有 0 值时，不建议缓存 MBeanInfo，除非它将 immutableInfo 设置为 true。
interfaceClassName | String | MBeanInfo | Standard MBean 或 MXBean 的 Java 接口名称，由 Class.getName() 返回。直接在 MBean Server 中注册或使用 StandardMBean 类创建的 Standard MBean 或 MXBean 将在其 MBeanInfo Descriptor 中包含此字段。
legalValues | Set<?> | MBeanAttributeInfo MBeanParameterInfo | 属性或参数的合法值。请参阅 javax.management.openmbean。
maxValue | Object | MBeanAttributeInfo MBeanParameterInfo | 属性或参数的最大合法值。请参阅 javax.management.openmbean。
metricType | String | MBeanAttributeInfo MBeanOperationInfo | 规格的类型，字符串 "counter" 或 "gauge" 之一。规格是由 MBean 导出的尺度，通常是一个属性，但有时是操作的结果。作为 counter 的规格有一个永远不会减少的值，除了将其重置为初始值之外。计数器规格几乎总是为非负整数。例如接收到的请求数。作为 gauge 的规格有一个可以增加或减少的数字值。例如打开的连接数、缓存命中率、读取的温度。
minValue | Object | MBeanAttributeInfo MBeanParameterInfo | 属性或参数的最小合法值。请参阅 javax.management.openmbean。
mxbean | String | MBeanInfo | 根据此 MBean 是否为 MXBean，决定字符串为 &quot;true&quot; 或 &quot;false&quot;。直接在 MBean Server 中注册或使用 StandardMBean 类创建的 Standard MBean 或 MXBean 将在其 MBeanInfo Descriptor 中包含此字段。
openType | OpenType | MBeanAttributeInfo MBeanOperationInfo MBeanParameterInfo | 此元素的开放类型。在 MBeanAttributeInfo 和 MBeanParameterInfo 的情况下，它是属性或参数的开放类型。在 MBeanOperationInfo 的情况下，它是返回值的开放类型。此字段在 OpenMBeanAttributeInfoSupport、OpenMBeanOperationInfoSupport 和 OpenMBeanParameterInfoSupport 的所有实例的 Descriptor 中设置。它还可以为 MXBean 的属性、操作和参数进行设置。 此字段可以为 MBeanNotificationInfo 进行设置，在此情况下，它指示用户数据将具有的开放类型。
originalType | String | MBeanAttributeInfo MBeanOperationInfo MBeanParameterInfo | 此元素的原始 Java 类型，在生成此 MBeanAttributeInfo（等）的 MXBean 接口方法中显示。例如，MXBean 接口中的方法 public MemoryUsage getHeapMemoryUsage(); 定义称为 HeapMemoryUsage 的类型为 CompositeData 的属性。此属性的 Descriptor 中的 originalType 字段将包含值 &quot;java.lang.management.MemoryUsage&quot;。 此字符串的格式将在 MXBean 规范的类型名称一节中描述。
severity | String Integer | MBeanNotificationInfo | 此通知的严重性。它可以为 0，表示严重性未知；也可以为 1 到 6 之间的值，表示递减的严重性级别。它可以表示为十进制字符串或 Integer。
since | String | 所有 | 引入此元素的信息模型的版本。应用程序定义的一组 MBean 总称为信息模型。应用程序也可以定义此模型的版本，并且使用 &quot;since&quot; 字段来记录元素第一次出现的版本。
units | String | MBeanAttributeInfo MBeanParameterInfo MBeanOperationInfo | 测量属性、参数或操作返回值的单位，如 &quot;bytes&quot; 或 &quot;seconds&quot;。

某些附加字段由 Model MBean 定义。请参阅 ModelMBeanInfo 和相关的类，以及 JMX 规范中的 "Model MBean" 一章。

从以下版本开始：
1.5

方法摘要
Object | clone() 返回一个与此描述符相等的描述符。
boolean | equals(Object obj) 将此描述符与给定对象比较。
String[] | getFieldNames() 返回描述符中的所有字段名。
String[] | getFields() 以 string 数组的形式返回此 descriptor 中所包含的所有字段。
Object | getFieldValue(String fieldName) 返回指定字段名的值，如果该名称不存在任何值，则返回 null。
Object[] | getFieldValues(String... fieldNames) 以 Object 数组的形式返回该 descriptor 中的所有字段值。
int | hashCode() 返回此描述符的哈希码值。
boolean | isValid() 如果所有字段在给定其名称的情况下都有合法值，则返回 true。
void | removeField(String fieldName) 从该 descriptor 中删除字段。
void | setField(String fieldName, Object fieldValue) 设置特定字段名的值。
void | setFields(String[] fieldNames, Object[] fieldValues) 将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。

方法详细信息

getFieldValue

Object getFieldValue(String fieldName)
                     throws RuntimeOperationsException
返回指定字段名的值，如果该名称不存在任何值，则返回 null。

参数：
fieldName - 字段名称。
返回：
相应的值，如果字段不存在，则返回 null。
抛出：
RuntimeOperationsException - 如果字段名称不合法。

setField

void setField(String fieldName,
              Object fieldValue)
              throws RuntimeOperationsException

设置特定字段名的值。这将修改现有的字段或添加一个新字段。

设置前将验证该字段值。如果该值无效，则将抛出一个异常。有效性的含义依赖于描述符实现。

参数：
fieldName - 要设置的字段的名称。不能为 null 或空。
fieldValue - 针对该字段名称所设置的字段值。如果 null 是字段的有效值，则可以为 null。
抛出：
RuntimeOperationsException - 如果字段名或字段值不合法（包装的异常为 IllegalArgumentException）；或者描述符不可变（包装的异常为 UnsupportedOperationException）。

getFields

String[] getFields()
以 string 数组的形式返回此 descriptor 中所包含的所有字段。

返回：
各字段的 String 数组，格式为 fieldName=fieldValue。
如果字段值不是一个 String，则对该值调用 toString() 方法并将返回值（用圆括号括起来）用作所返回数组中字段的值。如果字段的值为 null，则返回数组中的字段值将为空。如果描述符为空，则将得到一个空数组。
另请参见：
setFields(java.lang.String[], java.lang.Object[])

getFieldNames

String[] getFieldNames()
返回描述符中的所有字段名。

返回：
字段名称的 String 数组。如果描述符为空，则将得到一个空数组。

getFieldValues

Object[] getFieldValues(String... fieldNames)
以 Object 数组的形式返回该 descriptor 中的所有字段值。返回值的顺序与 fieldNames String 数组参数的顺序相同。

参数：
fieldNames - 字段名称的 String 数组，应该返回这些字段的值。如果该数组为空，则将返回一个空数组。如果数组为 null，则将返回所有值，如同参数是 getFieldNames() 返回的数组一样。如果数组中某个字段名不存在（包括字段名为 null 或空字符串的情况），则对于要返回的匹配数组元素，将返回 null。
返回：
字段值的 Object 数组。如果 fieldNames 列表为空，则将得到一个空数组。

removeField

void removeField(String fieldName)
从该 descriptor 中删除字段。

参数：
fieldName - 要移除的字段的 String 名称。如果字段名不合法或找不到字段，则不抛出任何异常。
抛出：
RuntimeOperationsException - 如果存在给定名称的字段且描述符不可变。包装的异常将是一个 UnsupportedOperationException。

setFields

void setFields(String[] fieldNames,
               Object[] fieldValues)
               throws RuntimeOperationsException

将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。数组大小必须是匹配的。

设置前将验证该字段值。如果该值无效，则将抛出一个异常。如果数组为空，则所有更改都将无效。

参数：
fieldNames - 字段名称的 String 数组。数组和数组元素不能为 null。
fieldValues - 对应字段值的 Object 数组。数组不能为 null。数组的元素可以为 null。
抛出：
RuntimeOperationsException - 如果由于某种原因更改失败。如果 fieldNames 或 fieldValues 为 null，或者数组的长度不同，或者其中一个数组存在非法值，则包装的异常为 IllegalArgumentException。如果描述符不可变，且调用将更改其内容，则包装的异常为 UnsupportedOperationException。
另请参见：
getFields()

clone

Object clone()
             throws RuntimeOperationsException

返回一个与此描述符相等的描述符。对返回的描述符进行的更改不影响此描述符，反之亦然。如果此描述符不可变，则将通过返回其本身来完成此条件。

返回：
一个与此描述符相等的描述符。
抛出：
RuntimeOperationsException - 如果字段名或字段值为非法值。如果描述符构造由于任何原因而失败，都将抛出此异常。

isValid

boolean isValid()
                throws RuntimeOperationsException
如果所有字段在给定其名称的情况下都有合法值，则返回 true。

返回：
如果值是合法的，则返回 true。
抛出：
RuntimeOperationsException - 如果有效性检查由于任何原因而失败，都将抛出此异常。如果描述符无效，则该方法返回 false，但如果确定有效性的尝试失败，则将抛出此异常。

equals

boolean equals(Object obj)
将此描述符与给定对象比较。如果给定对象也是一个 Descriptor，并且如果两个 Descriptor 具有相同的字段名（可能有不同的情况）且有相同的关联值，则对象相等。如果具备下列条件，则两个 Descriptor 中字段的各个值都相等：

  • 如果一个值为 null，则其他值也必须为 null。
  • 如果一个值是基本类型数组，则其他值必须是同一类型的基本类型数组，且具有相同的元素。
  • 如果一个值是对象数组，则其他值也必须是对象数组，并且 Arrays.deepEquals(Object[],Object[]) 必须返回 true。
  • 其他情况下，Object.equals(Object) 必须返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象。
返回：
如果对象相等，则返回 true；否则，返回 false。
从以下版本开始：
1.6
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()

返回此描述符的哈希码值。该哈希码是描述符中每个字段的哈希码的总和。具有名称 n 和值 v 的字段的哈希码是 n.toLowerCase().hashCode() ^ h。此处 h 是 v 的哈希码，计算方式如下：

  • 如果 v 为 null，则 h 为 0。
  • 如果 v 是基本类型数组，则使用 java.util.Arrays.hashCode 的适当重载形式计算 h。
  • 如果 v 是对象数组，则使用 Arrays.deepHashCode(Object[]) 计算 h。
  • 否则，h 为 v.hashCode()。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
从以下版本开始：
1.6
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DescriptorAccess (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 DescriptorAccess

所有超级接口：
DescriptorRead
所有已知实现类：
ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, ModelMBeanNotificationInfo, ModelMBeanOperationInfo
public interface DescriptorAccess
extends DescriptorRead

此接口用于获得对 Descriptor 类的描述符的访问，这些 Descriptor 类与某个 JMX 组件相关联，比如 MBean、MBeanInfo、MBeanAttributeInfo、MBeanNotificationInfo、MBeanOperationInfo 和 MBeanParameterInfo。

ModelMBean 在 ModelMBeanInfo 类中大量使用此接口。

从以下版本开始：
1.5

方法摘要
 void setDescriptor(Descriptor inDescriptor)
设置 Descriptor（完全替换）。
从接口 javax.management.DescriptorRead 继承的方法
getDescriptor

方法详细信息

setDescriptor

void setDescriptor(Descriptor inDescriptor)
设置 Descriptor（完全替换）。

参数：
inDescriptor - 替换与实现此接口的组件相关联的 Descriptor。如果 inDescriptor 对于要被设置的 Info 对象类型而言无效，则抛出异常。如果 inDescriptor 为 null，则将该 Descriptor 恢复到其默认值，该默认值至少应该包含 Descriptor 名称和 descriptorType。
另请参见：
DescriptorRead.getDescriptor()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DescriptorKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.management
注释类型 DescriptorKey

@Documented
@Retention(value=RUNTIME)
@Target(value=METHOD)
public @interface DescriptorKey

描述注释元素与 Descriptor 中字段之间关联方式的元注释。它可以是 MBean 的 Descriptor，也可以是 MBean 中属性、操作或构造方法的 Descriptor，还可以是操作或构造方法的参数的 Descriptor。

考虑下例中的注释：

 @Documented
 @Target(ElementType.METHOD)
 @Retention(RetentionPolicy.RUNTIME)
 public @interface Units {
     @DescriptorKey("units")
     String value();
 }

以及注释的这种用法：

public interface CacheControlMBean {
@Units("bytes")
public long getCacheSize();
 }

当 Standard MBean 由 CacheControlMBean 生成时，通常的规则意味着它将有一个称为 CacheSize 的类型为 long 的属性。在给定上述定义的情况下，@Units 属性将确保此属性的 MBeanAttributeInfo 将具有一个 Descriptor，该 Descriptor 有一个称为 units 的字段，且其相应的值为 bytes。

类似地，如果注释的形式如下：

 @Documented
 @Target(ElementType.METHOD)
 @Retention(RetentionPolicy.RUNTIME)
 public @interface Units {
     @DescriptorKey("units")
     String value();

     @DescriptorKey("descriptionResourceKey")
     String resourceKey() default "";

     @DescriptorKey("descriptionResourceBundleBaseName")
     String resourceBundleBaseName() default "";
 }

且用法如下：

public interface CacheControlMBean {
@Units("bytes",
resourceKey="bytes.key",
resourceBundleBaseName="com.example.foo.MBeanResources")
public long getCacheSize();
 }

则得到的 Descriptor 将包含以下字段：

名称 | 值
units | "bytes"
descriptionResourceKey | "bytes.key"
descriptionResourceBundleBaseName | "com.example.foo.MBeanResources"

@Units 之类的注释可以应用于：

  • Standard MBean 或 MXBean 接口；
  • 此类接口中的方法；
  • 当某方法是一个操作（不是属性的获取方法或设置方法）时，Standard MBean 或 MXBean 接口中该方法的参数；
  • 在实现 Standard MBean 或 MXBean 的类中的公共构造方法；
  • 此类构造方法中的参数。

忽略注释的其他用途。

只在定义 Standard MBean 或 MXBean 的管理接口的具体接口上检查接口注释，而不在其父接口上检查。只在方法出现的最具体的接口中检查方法注释；换句话说，如果子接口重写了父接口中的方法，则只考虑子接口中该方法中的 @DescriptorKey 注释。

由同一个程序元素上的不同注释提供的 Descriptor 字段必须一致。也就是说，两个不同注释或同一注释的两个成员不得为同一 Descriptor 字段定义不同的值。获取方法上的注释字段也必须与相应设置方法上的注释字段一致。

从这些注释中得到的 Descriptor 将与实现提供的任何 Descriptor 字段合并，如 MBean 的 immutableInfo 字段。注释中的字段必须与实现提供的这些字段一致。

要转换为描述符字段的注释元素可以是 Java 语言允许的任何类型，注释或注释数组除外。字段值由以下注释元素的值导出：

注释元素 | 描述符字段
基本类型值（5、false 等） | 包装值（Integer.valueOf(5)、Boolean.FALSE 等）
类常量（如 Thread.class） | Class.getName() 得到的类名称（如 &quot;java.lang.Thread&quot;）
枚举常量（如 ElementType.FIELD） | Enum.name() 得到的常量名称（如 &quot;FIELD&quot;）
类常量或枚举常量组成的数组 | 将这些规则应用于每个元素而派生的字符串数组
任何其他类型的值 （String、String[]、int[] 等） | 相同的值

从以下版本开始：
1.6

必需元素摘要
 String value

元素详细信息

value

public abstract String value
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


DescriptorRead (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 DescriptorRead

所有已知子接口：
DescriptorAccess
所有已知实现类：
MBeanAttributeInfo, MBeanConstructorInfo, MBeanFeatureInfo, MBeanInfo, MBeanNotificationInfo, MBeanOperationInfo, MBeanParameterInfo, ModelMBeanAttributeInfo, ModelMBeanConstructorInfo, ModelMBeanInfoSupport, ModelMBeanNotificationInfo, ModelMBeanOperationInfo, OpenMBeanAttributeInfoSupport, OpenMBeanConstructorInfoSupport, OpenMBeanInfoSupport, OpenMBeanOperationInfoSupport, OpenMBeanParameterInfoSupport
public interface DescriptorRead

读取管理接口元素（如 MBeanInfo）的 Descriptor 的接口。

从以下版本开始：
1.6

方法摘要
 Descriptor getDescriptor()
返回 Descriptor 的副本。

方法详细信息

getDescriptor

Descriptor getDescriptor()
返回 Descriptor 的副本。

返回：
与实现此接口的组件关联的 Descriptor。返回值永远不能为 null，但返回的描述符可以为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DynamicMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 DynamicMBean

所有已知子接口：
ModelMBean
所有已知实现类：
RequiredModelMBean, StandardEmitterMBean, StandardMBean
public interface DynamicMBean

定义了 Dynamic MBean（公开了动态管理接口的 MBean）应该实现的各个方法。

从以下版本开始：
1.5

方法摘要
Object | getAttribute(String attribute) 获得 Dynamic MBean 的特定属性的值。
AttributeList | getAttributes(String[] attributes) 获得 Dynamic MBean 多个属性的值。
MBeanInfo | getMBeanInfo() 使用 MBeanInfo 对象提供该 Dynamic MBean 已公开的属性和操作。
Object | invoke(String actionName, Object[] params, String[] signature) 允许在 Dynamic MBean 上调用某个操作。
void | setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
AttributeList | setAttributes(AttributeList attributes) 设置 Dynamic MBean 多个属性的值。

方法详细信息

getAttribute

Object getAttribute(String attribute)
                    throws AttributeNotFoundException,
                           MBeanException,
                           ReflectionException
获得 Dynamic MBean 的特定属性的值。

参数：
attribute - 要检索的属性名
返回：
所检索属性的值。
抛出：
AttributeNotFoundException
MBeanException - 包装由 MBean 的获取方法所抛出的 java.lang.Exception。
ReflectionException - 包装试图调用获取方法时所抛出的 java.lang.Exception。
另请参见：
setAttribute(javax.management.Attribute)

setAttribute

void setAttribute(Attribute attribute)
                  throws AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
设置 Dynamic MBean 的特定属性的值。

参数：
attribute - 要设置的属性的标识及其要设置成的值。
抛出：
AttributeNotFoundException
InvalidAttributeValueException
MBeanException - 包装由 MBean 的设置方法所抛出的 java.lang.Exception。
ReflectionException - 包装试图调用设置方法时所抛出的 java.lang.Exception。
另请参见：
getAttribute(java.lang.String)

getAttributes

AttributeList getAttributes(String[] attributes)
获得 Dynamic MBean 多个属性的值。

参数：
attributes - 要检索的属性列表。
返回：
已检索的属性列表。
另请参见：
setAttributes(javax.management.AttributeList)

setAttributes

AttributeList setAttributes(AttributeList attributes)
设置 Dynamic MBean 多个属性的值。

参数：
attributes - 属性列表：要设置的属性的标识及其要设置成的值。
返回：
已设置的属性的列表，以及它们的新值。
另请参见：
getAttributes(java.lang.String[])

invoke

Object invoke(String actionName,
              Object[] params,
              String[] signature)
              throws MBeanException,
                     ReflectionException
允许在 Dynamic MBean 上调用某个操作。

参数：
actionName - 要调用的操作的名称。
params - 一个数组，包含调用该操作时所要设置的参数。
signature - 包含操作签名的数组。加载类对象时，使用的类加载器与加载在其上调用操作的 MBean 所用的类加载器相同。
返回：
该操作返回的对象，表示在指定 MBean 上调用该操作的结果。
抛出：
MBeanException - 包装由 MBean 上所调用的方法抛出的 java.lang.Exception。
ReflectionException - 包装试图调用该方法时所抛出的 java.lang.Exception。

getMBeanInfo

MBeanInfo getMBeanInfo()
使用 MBeanInfo 对象提供该 Dynamic MBean 已公开的属性和操作。

返回：
一个 MBeanInfo 实例，允许检索此 Dynamic MBean 已公开的所有属性和操作。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImmutableDescriptor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 ImmutableDescriptor

java.lang.Object
    继承者  javax.management.ImmutableDescriptor
所有已实现的接口：
Serializable, Cloneable, Descriptor
public class ImmutableDescriptor
extends Object
implements Descriptor

不可变的描述符。

从以下版本开始：
1.6
另请参见：
序列化表格

字段摘要
static ImmutableDescriptor EMPTY_DESCRIPTOR
空描述符。
构造方法摘要
ImmutableDescriptor(Map<String,?> fields)
构造一个描述符，其中字段名称和值是给定 Map 的键和值。
ImmutableDescriptor(String... fields)
构造包含给定字段的描述符。
ImmutableDescriptor(String[] fieldNames, Object[] fieldValues)
构造包含给定字段和值的描述符。
方法摘要
Descriptor | clone() 返回一个与此描述符相等的描述符。
boolean | equals(Object o) 将此描述符与给定对象进行比较。
String[] | getFieldNames() 返回描述符中的所有字段名。
String[] | getFields() 以 string 数组的形式返回此 descriptor 中所包含的所有字段。
Object | getFieldValue(String fieldName) 返回指定字段名的值，如果该名称不存在任何值，则返回 null。
Object[] | getFieldValues(String... fieldNames) 以 Object 数组的形式返回该 descriptor 中的所有字段值。
int | hashCode() 返回此描述符的哈希码值。
boolean | isValid() 如果所有字段在给定其名称的情况下都有合法值，则返回 true。
void | removeField(String fieldName) 从描述符移除字段。
void | setField(String fieldName, Object fieldValue) 因为此类不可变，所以不支持此操作。
void | setFields(String[] fieldNames, Object[] fieldValues) 因为此类不可变，所以不支持此操作。
String | toString() 返回该对象的字符串表示。
static ImmutableDescriptor | union(Descriptor... descriptors) 返回一个 ImmutableDescriptor，其内容是给定描述符的并集。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

EMPTY_DESCRIPTOR

public static final ImmutableDescriptor EMPTY_DESCRIPTOR
空描述符。

构造方法详细信息

ImmutableDescriptor

public ImmutableDescriptor(String[] fieldNames,
                           Object[] fieldValues)
构造包含给定字段和值的描述符。

抛出：
IllegalArgumentException - 如果数组为 null、数组的大小不同、字段名称为 null 或空，或者相同的字段名称出现多次。

ImmutableDescriptor

public ImmutableDescriptor(String... fields)
构造包含给定字段的描述符。每个 String 都必须是 fieldName=fieldValue 的形式。字段名称在第一个 = 字符处结束；例如，如果 String 为 a=b=c，则字段名称为 a 且其值为 b=c。

抛出：
IllegalArgumentException - 如果参数为 null、字段名称为空、相同字段名称出现多次或者其中一个字符串不包含 = 字符。

ImmutableDescriptor

public ImmutableDescriptor(Map<String,?> fields)

构造一个描述符，其中字段名称和值是给定 Map 的键和值。

抛出：
IllegalArgumentException - 如果参数为 null、字段名称为 null 或空，或者相同字段名称出现多次（可能因为字段名称不区分大小写所致）。
方法详细信息

union

public static ImmutableDescriptor union(Descriptor... descriptors)

返回一个 ImmutableDescriptor，其内容是给定描述符的并集。出现在任何描述符中的每个字段名称都将出现在结果中，并具有调用方法时字段名称所具有的值。对任何描述符的后续更改不影响此处返回的 ImmutableDescriptor。

在最简单的情况下，只有一个描述符，且返回的 ImmutableDescriptor 是在调用此方法时该描述符中字段的副本：

Descriptor d = something();
ImmutableDescriptor copy = ImmutableDescriptor.union(d);

参数：
descriptors - 要合并的描述符。任何描述符都可以为 null，在此情况下可以将其跳过。
返回：
作为给定描述符并集的 ImmutableDescriptor。如果它是一个包含所有所需字段的 ImmutableDescriptor，则返回的对象可以与某个输入描述符相同。
抛出：
IllegalArgumentException - 如果两个 Descriptor 包含具有不同关联值的相同字段名称。如果基本类型数组值是具有相同元素的同一类型的值，则将其视为相同。如果 Arrays.deepEquals(Object[],Object[]) 返回 true，则将对象数组值视为相同。

getFieldValue

public final Object getFieldValue(String fieldName)
从接口 Descriptor 复制的描述
返回指定字段名的值，如果该名称不存在任何值，则返回 null。

指定者：
接口 Descriptor 中的 getFieldValue
参数：
fieldName - 字段名称。
返回：
相应的值，如果字段不存在，则返回 null。

getFields

public final String[] getFields()
从接口 Descriptor 复制的描述
以 string 数组的形式返回此 descriptor 中所包含的所有字段。

指定者：
接口 Descriptor 中的 getFields
返回：
各字段的 String 数组，格式为 fieldName=fieldValue。
如果字段值不是一个 String，则对该值调用 toString() 方法并将返回值（用圆括号括起来）用作所返回数组中字段的值。如果字段的值为 null，则返回数组中的字段值将为空。如果描述符为空，则将得到一个空数组。
另请参见：
Descriptor.setFields(java.lang.String[], java.lang.Object[])

getFieldValues

public final Object[] getFieldValues(String... fieldNames)
从接口 Descriptor 复制的描述
以 Object 数组的形式返回该 descriptor 中的所有字段值。返回值的顺序与 fieldNames String 数组参数的顺序相同。

指定者：
接口 Descriptor 中的 getFieldValues
参数：
fieldNames - 字段名称的 String 数组，应该返回这些字段的值。如果该数组为空，则将返回一个空数组。如果数组为 null，则将返回所有值，如同参数是 Descriptor.getFieldNames() 返回的数组一样。如果数组中某个字段名不存在（包括字段名为 null 或空字符串的情况），则对于要返回的匹配数组元素，将返回 null。
返回：
字段值的 Object 数组。如果 fieldNames 列表为空，则将得到一个空数组。

getFieldNames

public final String[] getFieldNames()
从接口 Descriptor 复制的描述
返回描述符中的所有字段名。

指定者：
接口 Descriptor 中的 getFieldNames
返回：
字段名称的 String 数组。如果描述符为空，则将得到一个空数组。

equals

public boolean equals(Object o)
将此描述符与给定对象进行比较。如果给定对象也是一个 Descriptor，并且两个 Descriptor 具有相同的字段名（可能有不同的情况）且有相同的关联值，则对象相等。如果具备下列条件，则两个 Descriptor 中字段的各个值都相等：

  • 如果一个值为 null，则其他值也必须为 null。
  • 如果一个值是基本类型数组，则其他值必须是同一类型的基本类型数组，且具有相同的元素。
  • 如果一个值是对象数组，则其他值也必须是对象数组，并且 Arrays.deepEquals(Object[],Object[]) 必须返回 true。
  • 其他情况下，Object.equals(Object) 必须返回 true。

指定者：
接口 Descriptor 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与之比较的对象。
返回：
如果对象相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此描述符的哈希码值。该哈希码是描述符中每个字段的哈希码的总和。名称为 n 且值为 v 的字段的哈希码是 n.toLowerCase().hashCode() ^ h。这里的 h 是 v 的哈希码，计算方式如下：

  • 如果 v 为 null，则 h 为 0。
  • 如果 v 是基本类型数组，则使用 java.util.Arrays.hashCode 的适当重载形式计算 h。
  • 如果 v 是对象数组，则使用 Arrays.deepHashCode(Object[]) 计算 h。
  • 否则，h 为 v.hashCode()。

指定者：
接口 Descriptor 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

isValid

public boolean isValid()
如果所有字段在给定其名称的情况下都有合法值，则返回 true。此方法总是返回 true，但子类可以重写它，以便在适当的时候返回 false。

指定者：
接口 Descriptor 中的 isValid
返回：
如果值是合法的，则返回 true。
抛出：
RuntimeOperationsException - 如果有效性检查失败。如果描述符无效，则该方法返回 false，但如果尝试确定有效性失败，则将抛出此异常。

clone

public Descriptor clone()

返回一个与此描述符相等的描述符。对返回的描述符进行的更改不影响此描述符，反之亦然。

此方法返回它调用的对象。子类可以重写此方法，以便在符合条件的情况下返回另一个对象。

指定者：
接口 Descriptor 中的 clone
覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
RuntimeOperationsException - 如果 Names 或 Values 字段的值为非法值。如果描述符构造由于任何原因而失败，都将抛出此异常。
另请参见：
Cloneable

setFields

public final void setFields(String[] fieldNames,
                            Object[] fieldValues)
                     throws RuntimeOperationsException
因为此类不可变，所以不支持此操作。如果此调用此方法会更改具有相同内容的可变描述符，则抛出包装 UnsupportedOperationException 的 RuntimeOperationsException。否则，其行为将与可变描述符的行为相同：要么因为非法参数而抛出异常，要么无效。

指定者：
接口 Descriptor 中的 setFields
参数：
fieldNames - 字段名称的 String 数组。数组和数组元素不能为 null。
fieldValues - 对应字段值的 Object 数组。数组不能为 null。数组的元素可以为 null。
抛出：
RuntimeOperationsException - 如果由于某种原因更改失败。如果 fieldNames 或 fieldValues 为 null，或者数组的长度不同，或者其中一个数组存在非法值，则包装的异常为 IllegalArgumentException。如果描述符不可变，且调用将更改其内容，则包装的异常为 UnsupportedOperationException。
另请参见：
Descriptor.getFields()

setField

public final void setField(String fieldName,
                           Object fieldValue)
                    throws RuntimeOperationsException
因为此类不可变，所以不支持此操作。如果此调用此方法会更改具有相同内容的可变描述符，则抛出包装 UnsupportedOperationException 的 RuntimeOperationsException。否则，其行为将与可变描述符的行为相同：要么因为非法参数而抛出异常，要么无效。

指定者：
接口 Descriptor 中的 setField
参数：
fieldName - 要设置的字段的名称。不能为 null 或空。
fieldValue - 针对该字段名称所设置的字段值。如果 null 是字段的有效值，则可以为 null。
抛出：
RuntimeOperationsException - 如果字段名或字段值不合法（包装的异常为 IllegalArgumentException）；或者描述符不可变（包装的异常为 UnsupportedOperationException）。

removeField

public final void removeField(String fieldName)
从描述符移除字段。

指定者：
接口 Descriptor 中的 removeField
参数：
fieldName - 要移除的字段的 String 名称。如果字段名不合法或找不到字段，则不抛出任何异常。
抛出：
RuntimeOperationsException - 如果存在给定名称的字段且描述符不可变。包装的异常将是一个 UnsupportedOperationException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InstanceAlreadyExistsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 InstanceAlreadyExistsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.InstanceAlreadyExistsException
所有已实现的接口：
Serializable
public class InstanceAlreadyExistsException
extends OperationsException

已经在存储库中注册了 MBean。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InstanceAlreadyExistsException()
默认的构造方法。
InstanceAlreadyExistsException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InstanceAlreadyExistsException

public InstanceAlreadyExistsException()
默认的构造方法。

InstanceAlreadyExistsException

public InstanceAlreadyExistsException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InstanceNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 InstanceNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.InstanceNotFoundException
所有已实现的接口：
Serializable
public class InstanceNotFoundException
extends OperationsException

存储库中不存在指定的 MBean。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InstanceNotFoundException()
默认的构造方法。
InstanceNotFoundException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InstanceNotFoundException

public InstanceNotFoundException()
默认的构造方法。

InstanceNotFoundException

public InstanceNotFoundException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IntrospectionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 IntrospectionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.IntrospectionException
所有已实现的接口：
Serializable
public class IntrospectionException
extends OperationsException

在 MBean 的 introspection 期间出现的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
IntrospectionException()
默认的构造方法。
IntrospectionException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

IntrospectionException

public IntrospectionException()
默认的构造方法。

IntrospectionException

public IntrospectionException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidApplicationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 InvalidApplicationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.InvalidApplicationException
所有已实现的接口：
Serializable
public class InvalidApplicationException
extends Exception

试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。在查询计算期间由 JMX 在内部使用此异常。用户代码通常无法看到它。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidApplicationException(Object val)
构造具有指定 Object 的 InvalidApplicationException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidApplicationException

public InvalidApplicationException(Object val)
构造具有指定 Object 的 InvalidApplicationException。

参数：
val - 此异常的详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidAttributeValueException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 InvalidAttributeValueException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.InvalidAttributeValueException
所有已实现的接口：
Serializable
public class InvalidAttributeValueException
extends OperationsException

指定的值对该属性无效。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidAttributeValueException()
默认的构造方法。
InvalidAttributeValueException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidAttributeValueException

public InvalidAttributeValueException()
默认的构造方法。

InvalidAttributeValueException

public InvalidAttributeValueException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 JMException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
所有已实现的接口：
Serializable
直接已知子类：
MBeanException, OpenDataException, OperationsException, ReflectionException, RelationException
public class JMException
extends Exception

由 JMX 实现所抛出的异常。它不包括运行时异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
JMException()
默认的构造方法。
JMException(String msg)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMException

public JMException()
默认的构造方法。

JMException

public JMException(String msg)
允许指定特定错误消息的构造方法。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMRuntimeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 JMRuntimeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.management.JMRuntimeException
所有已实现的接口：
Serializable
直接已知子类：
MonitorSettingException, RuntimeErrorException, RuntimeMBeanException, RuntimeOperationsException
public class JMRuntimeException
extends RuntimeException

由 JMX 实现所发出的运行时异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
JMRuntimeException()
默认的构造方法。
JMRuntimeException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMRuntimeException

public JMRuntimeException()
默认的构造方法。

JMRuntimeException

public JMRuntimeException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMX (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 JMX

java.lang.Object
    继承者  javax.management.JMX

public class JMX
extends Object

JMX API 提供的静态方法。该类没有实例。

从以下版本开始：
1.6

字段摘要
static String | DEFAULT_VALUE_FIELD defaultValue 字段的名称。
static String | IMMUTABLE_INFO_FIELD immutableInfo 字段的名称。
static String | INTERFACE_CLASS_NAME_FIELD interfaceClassName 字段的名称。
static String | LEGAL_VALUES_FIELD legalValues 字段的名称。
static String | MAX_VALUE_FIELD maxValue 字段的名称。
static String | MIN_VALUE_FIELD minValue 字段的名称。
static String | MXBEAN_FIELD mxbean 字段的名称。
static String | OPEN_TYPE_FIELD openType 字段的名称。
static String | ORIGINAL_TYPE_FIELD originalType 字段的名称。
方法摘要
static boolean isMXBeanInterface(Class<?> interfaceClass)
测试某接口是否是 MXBean 接口。
static
<T> T
newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_VALUE_FIELD

public static final String DEFAULT_VALUE_FIELD
defaultValue 字段的名称。

另请参见：
常量字段值

IMMUTABLE_INFO_FIELD

public static final String IMMUTABLE_INFO_FIELD
immutableInfo 字段的名称。

另请参见：
常量字段值

INTERFACE_CLASS_NAME_FIELD

public static final String INTERFACE_CLASS_NAME_FIELD
interfaceClassName 字段的名称。

另请参见：
常量字段值

LEGAL_VALUES_FIELD

public static final String LEGAL_VALUES_FIELD
legalValues 字段的名称。

另请参见：
常量字段值

MAX_VALUE_FIELD

public static final String MAX_VALUE_FIELD
maxValue 字段的名称。

另请参见：
常量字段值

MIN_VALUE_FIELD

public static final String MIN_VALUE_FIELD
minValue 字段的名称。

另请参见：
常量字段值

MXBEAN_FIELD

public static final String MXBEAN_FIELD
mxbean 字段的名称。

另请参见：
常量字段值

OPEN_TYPE_FIELD

public static final String OPEN_TYPE_FIELD
openType 字段的名称。

另请参见：
常量字段值

ORIGINAL_TYPE_FIELD

public static final String ORIGINAL_TYPE_FIELD
originalType 字段的名称。

另请参见：
常量字段值
方法详细信息

newMBeanProxy

public static <T> T newMBeanProxy(MBeanServerConnection connection,
                                  ObjectName objectName,
                                  Class<T> interfaceClass)

在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。

如果 MBean 服务器 mbs 包含 ObjectName 为 name 的 MBean，并且如果该 MBean 的管理接口由 Java 接口 MyMBean 描述，则可以像下面这样为该 MBean 构造一个代理：

MyMBean proxy = JMX.newMBeanProxy(mbs, name, MyMBean.class);

例如，假定 MyMBean 如下所示：

public interface MyMBean {
public String getSomeAttribute();
public void setSomeAttribute(String value);
public void someOperation(String param1, int param2);
 }

那么可以执行：

  • 将导致调用 mbs. getAttribute (name, &quot;SomeAttribute&quot;) 的 proxy.getSomeAttribute()。
  • 将导致调用 mbs. setAttribute (name, new Attribute(&quot;SomeAttribute&quot;, &quot;whatever&quot;)) 的 proxy.setSomeAttribute(&quot;whatever&quot;)。
  • 将转换为对 mbs. invoke (name, &quot;someOperation&quot;, <etc>) 的调用的 proxy.someOperation(&quot;param1&quot;, 2)。

此方法返回的对象是一个其 InvocationHandler 为 MBeanServerInvocationHandler 的 Proxy。

此方法等效于 newMBeanProxy(connection, objectName, interfaceClass, false)。

类型参数：
T - 让编译器知道如果 interfaceClass 参数为 MyMBean.class，则返回类型为 MyMBean。
参数：
connection - 作为转发目的地的目标 MBean 服务器。
objectName - 作为转发目的地的 connection 中的 MBean 名。
interfaceClass - MBean 输出的管理接口，也由返回的代理来实现。
返回：
新的代理实例。

newMBeanProxy

public static <T> T newMBeanProxy(MBeanServerConnection connection,
                                  ObjectName objectName,
                                  Class<T> interfaceClass,
                                  boolean notificationBroadcaster)

在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。

此方法的行为与 newMBeanProxy(MBeanServerConnection, ObjectName, Class) 相同，但除此以外，如果 notificationBroadcaster 为 true，则假定 MBean 为 NotificationBroadcaster 或 NotificationEmitter，并且返回的代理将实现 NotificationEmitter 和 interfaceClass。在该代理上调用 NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object) 将导致对 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 的调用，对于 NotificationBroadcaster 和 NotificationEmitter 的其他方法也是如此。

类型参数：
T - 让编译器知道如果 interfaceClass 参数为 MyMBean.class，则返回类型为 MyMBean。
参数：
connection - 作为转发目的地的目标 MBean 服务器。
objectName - 作为转发目的地的 connection 中的 MBean 名。
interfaceClass - MBean 输出的管理接口，也由返回的代理来实现。
notificationBroadcaster - 使返回的代理实现 NotificationEmitter，方法是通过 connection 转发其方法。
返回：
新的代理实例。

newMXBeanProxy

public static <T> T newMXBeanProxy(MBeanServerConnection connection,
                                   ObjectName objectName,
                                   Class<T> interfaceClass)

在本地或远程 MBean Server 中为 MXBean 构造一个代理。

如果 MBean 服务器 mbs 包含 ObjectName 为 name 的 MXBean，并且如果该 MXBean 的管理接口由 Java 接口 MyMXBean 所描述，则可以像下面这样为该 MXBean 构造一个代理：

MyMXBean proxy = JMX.newMXBeanProxy(mbs, name, MyMXBean.class);

例如，假定 MyMXBean 如下所示：

public interface MyMXBean {
public String getSimpleAttribute();
public void setSimpleAttribute(String value);
public MemoryUsage getMappedAttribute();
public void setMappedAttribute(MemoryUsage memoryUsage);
public MemoryUsage someOperation(String param1, MemoryUsage param2);
 }

那么：

  • proxy.getSimpleAttribute() 将导致调用 mbs. getAttribute (name, &quot;SimpleAttribute&quot;)。

  • proxy.setSimpleAttribute(&quot;whatever&quot;) 将导致调用 mbs. setAttribute (name, new Attribute("SimpleAttribute", "whatever"))。

    因为 String 是一个简单类型（即 SimpleType），所以不会在 MXBean 的上下文中更改它。MXBean 代理的行为与属性 SimpleAttribute 的 Standard MBean 代理（请参阅 newMBeanProxy）的行为相同。

  • proxy.getMappedAttribute() 将导致调用 mbs.getAttribute(&quot;MappedAttribute&quot;)。MXBean 映射规则意味着属性 MappedAttribute 的实际类型将是 CompositeData，并且这是 mbs.getAttribute 调用将返回的内容。该代理然后会使用 MXBean 映射规则将 CompositeData 转换回所期望类型的 MemoryUsage。

  • 类似地，proxy.setMappedAttribute(memoryUsage) 将在调用 mbs.setAttribute 之前将 MemoryUsage 参数转换为 CompositeData。

  • proxy.someOperation(&quot;whatever&quot;, memoryUsage) 将 MemoryUsage 参数转换为 CompositeData 并调用 mbs.invoke。mbs.invoke 返回的值也将是 CompositeData，并且代理会使用 MXBean 映射规则将此值转换为所期望类型的 MemoryUsage。

此方法返回的对象是一个 InvocationHandler 为 MBeanServerInvocationHandler 的 Proxy。

此方法等效于 newMXBeanProxy(connection, objectName, interfaceClass, false)。

类型参数：
T - 让编译器知道如果 interfaceClass 参数为 MyMXBean.class，则返回类型为 MyMXBean。
参数：
connection - 作为转发目的地的目标 MBean 服务器。
objectName - 作为转发目的地的 connection 中的 MBean 名。
interfaceClass - MXBean 接口，也由返回的代理来实现。
返回：
新的代理实例。

newMXBeanProxy

public static <T> T newMXBeanProxy(MBeanServerConnection connection,
                                   ObjectName objectName,
                                   Class<T> interfaceClass,
                                   boolean notificationBroadcaster)

在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。

此方法的行为与 newMXBeanProxy(MBeanServerConnection, ObjectName, Class) 相同，但除此以外，如果 notificationBroadcaster 为 true，则假定 MXBean 为 NotificationBroadcaster 或 NotificationEmitter，并且返回的代理将实现 NotificationEmitter 和 interfaceClass。在该代理上调用 NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object) 将导致对 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 的调用，对于 NotificationBroadcaster 和 NotificationEmitter 的其他方法也是如此。

类型参数：
T - 让编译器知道如果 interfaceClass 参数为 MyMXBean.class，则返回类型为 MyMXBean。
参数：
connection - 作为转发目的地的目标 MBean 服务器。
objectName - 作为转发目的地的 connection 中的 MBean 名。
interfaceClass - MXBean 接口，也由返回的代理来实现。
notificationBroadcaster - 使返回的代理实现 NotificationEmitter，方法是通过 connection 转发它的方法。
返回：
新的代理实例。

isMXBeanInterface

public static boolean isMXBeanInterface(Class<?> interfaceClass)

测试某接口是否是 MXBean 接口。如果接口为已注释的 @MXBean 或 @MXBean(true)，或者接口没有 @MXBean 注释且其名称以 "MXBean" 结尾，则该接口为 MXBean 接口。

参数：
interfaceClass - 侯选接口。
返回：
如果 interfaceClass 是一个接口且满足所描述的条件，则返回 true。
抛出：
NullPointerException - 如果 interfaceClass 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListenerNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 ListenerNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.ListenerNotFoundException
所有已实现的接口：
Serializable
public class ListenerNotFoundException
extends OperationsException

存储库中不存在指定的 MBean 侦听器。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ListenerNotFoundException()
默认的构造方法。
ListenerNotFoundException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ListenerNotFoundException

public ListenerNotFoundException()
默认的构造方法。

ListenerNotFoundException

public ListenerNotFoundException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MalformedObjectNameException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MalformedObjectNameException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.MalformedObjectNameException
所有已实现的接口：
Serializable
public class MalformedObjectNameException
extends OperationsException

字符串的格式不对应于有效的 ObjectName。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MalformedObjectNameException()
默认的构造方法。
MalformedObjectNameException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MalformedObjectNameException

public MalformedObjectNameException()
默认的构造方法。

MalformedObjectNameException

public MalformedObjectNameException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanAttributeInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanAttributeInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanAttributeInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorRead
直接已知子类：
ModelMBeanAttributeInfo, OpenMBeanAttributeInfoSupport
public class MBeanAttributeInfo
extends MBeanFeatureInfo
implements Cloneable

描述出于管理目的而公开的 MBean 属性。此类的实例是不可变的。子类可以是可变的，但是不推荐使用此功能。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
MBeanAttributeInfo(String name, String description, Method getter, Method setter)
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。
MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 MBeanAttributeInfo 对象。
MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 MBeanAttributeInfo 对象。
方法摘要
Object | clone() 返回此实例的浅表副本。
boolean | equals(Object o) 比较此 MBeanAttributeInfo 与另一个 MBeanAttributeInfo。
String | getType() 返回该属性的类名。
int | hashCode() 返回该对象的哈希码值。
boolean | isIs() 指示此属性是否有一个 "is" 获取方法。
boolean | isReadable() 该属性的值是否可读。
boolean | isWritable() 是否可将新值写入该属性。
String | toString() 返回该对象的字符串表示。
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanAttributeInfo

public MBeanAttributeInfo(String name,
                          String type,
                          String description,
                          boolean isReadable,
                          boolean isWritable,
                          boolean isIs)
构造一个 MBeanAttributeInfo 对象。

参数：
name - 属性的名称。
type - 属性的类型或类名。
description - 该属性的可读描述。
isReadable - 如果该属性具有获取方法，则为 True；否则为 false。
isWritable - 如果该属性具有设置方法，则为 True；否则为 false。
isIs - 如果该属性具有 "is" 获取方法，则为 True；否则为 false。
抛出：
IllegalArgumentException - 如果 isIs 为 true 而 isReadable 不为 true，或者 isIs 为 true 且 type 不为 boolean 或 java.lang.Boolean。（新代码始终使用 boolean 而不是 java.lang.Boolean。）

MBeanAttributeInfo

public MBeanAttributeInfo(String name,
                          String type,
                          String description,
                          boolean isReadable,
                          boolean isWritable,
                          boolean isIs,
                          Descriptor descriptor)
构造一个 MBeanAttributeInfo 对象。

参数：
name - 属性的名称。
type - 属性的类型或类名。
description - 属性的可读描述。
isReadable - True 如果该属性有获取方法，则此参数为 true，否则为 false。
isWritable - True 如果该属性有设置方法，则此参数为 true，否则为 false。
isIs - True 如果该属性有一个 "is" 获取方法，则此参数为 True；否则为 false。
descriptor - 属性的描述符。此参数可以为 null，它等效于一个空描述符。
抛出：
IllegalArgumentException - 如果 isIs 为 true 而 isReadable 不为 true，或者 isIs 为 true 且 type 不为 boolean 或 java.lang.Boolean。（新代码始终使用 boolean 而不是使用 java.lang.Boolean。）
从以下版本开始：
1.6

MBeanAttributeInfo

public MBeanAttributeInfo(String name,
                          String description,
                          Method getter,
                          Method setter)
                   throws IntrospectionException

此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。已构造对象的 Descriptor 包括 Method 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
name - 属性的编程名称。
description - 该属性的可读描述。
getter - 用于读取属性值的方法。如果该属性是只写的，则可以为 null。
setter - 用于写入属性值的方法。如果该属性是只读的，则可以为 null。
抛出：
IntrospectionException - 如果在此属性的定义中存在一致性问题。
方法详细信息

clone

public Object clone()

返回此实例的浅表副本。可通过调用 super.clone() 来获得该副本，因此要调用 Object.clone() 所实现的默认本机浅表复制机制。不进行任何内部字段的更深层复制。

因为此类是不可变的，所以主要对子类进行复制。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getType

public String getType()
返回该属性的类名。

返回：
类名。

isReadable

public boolean isReadable()
该属性的值是否可读。

返回：
如果该属性可读，则返回 True；否则返回 false。

isWritable

public boolean isWritable()
是否可将新值写入该属性。

返回：
如果可写入该属性，则返回 True；否则返回 false。

isIs

public boolean isIs()
指示此属性是否有一个 "is" 获取方法。

返回：
如果此属性有一个 "is" 获取方法，则返回 true。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

equals

public boolean equals(Object o)
比较此 MBeanAttributeInfo 与另一个 MBeanAttributeInfo。

覆盖：
类 MBeanFeatureInfo 中的 equals
参数：
o - 要比较的对象。
返回：
当且仅当 o 是一个 MBeanAttributeInfo，它的 MBeanFeatureInfo.getName()、getType()、MBeanFeatureInfo.getDescription()、isReadable()、isWritable() 和 isIs() 值与此 MBeanAttributeInfo 的这些值相等（不必完全一样）时，才返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 MBeanFeatureInfo 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanConstructorInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanConstructorInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanConstructorInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorRead
直接已知子类：
ModelMBeanConstructorInfo, OpenMBeanConstructorInfoSupport
public class MBeanConstructorInfo
extends MBeanFeatureInfo
implements Cloneable

描述 MBean 所公开的构造方法。此类的实例是不可变的。子类可以是可变的，但是不推荐使用此特性。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
MBeanConstructorInfo(String description, Constructor constructor)
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。
方法摘要
Object | clone() 返回此实例的浅表副本。
boolean | equals(Object o) 比较此 MBeanConstructorInfo 与另一个 MBeanConstructorInfo。
MBeanParameterInfo[] | getSignature() 返回此构造方法的参数列表。
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanConstructorInfo

public MBeanConstructorInfo(String description,
                            Constructor constructor)
构造一个 MBeanConstructorInfo 对象。已构造对象的 Descriptor 包括 Constructor 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
description - 该操作的可读描述。
constructor - 描述 MBean 构造方法的 java.lang.reflect.Constructor 对象。

MBeanConstructorInfo

public MBeanConstructorInfo(String name,
                            String description,
                            MBeanParameterInfo[] signature)
构造一个 MBeanConstructorInfo 对象。

参数：
name - 该构造方法的名称。
signature - 描述该构造方法的参数（变量）的 MBeanParameterInfo 对象。该参数可以为 null，与零长度数组的效果相同。
description - 该该构造方法的可读描述。

MBeanConstructorInfo

public MBeanConstructorInfo(String name,
                            String description,
                            MBeanParameterInfo[] signature,
                            Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。

参数：
name - 构造方法名称。
signature - 描述该构造方法的参数（变量）的 MBeanParameterInfo 对象。该参数可以为 null，与零长度数组的效果相同。
description - 构造方法的可读描述。
descriptor - 构造方法的描述符。该参数可以为 null，它等效于一个空描述符。
从以下版本开始：
1.6
方法详细信息

clone

public Object clone()

返回此实例的浅表副本。可通过调用 super.clone() 来获得该副本，因此要调用 Object.clone() 所实现的默认本机浅表复制机制。不进行任何内部字段的更深层复制。

因为此类是不可变的，所以主要对子类进行复制。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getSignature

public MBeanParameterInfo[] getSignature()

返回此构造方法的参数列表。每个参数都由一个 MBeanParameterInfo 对象来描述。

返回的数组是内部数组的一个浅表副本，这意味着它是对 MBeanParameterInfo 对象引用的一个内部数组副本，但是未复制每个被引用的 MBeanParameterInfo 对象。

返回：
MBeanParameterInfo 对象的数组。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

equals

public boolean equals(Object o)
比较此 MBeanConstructorInfo 与另一个 MBeanConstructorInfo。

覆盖：
类 MBeanFeatureInfo 中的 equals
参数：
o - 要比较的对象。
返回：
当且仅当 o 是一个 MBeanConstructorInfo，并且其 MBeanFeatureInfo.getName()、MBeanFeatureInfo.getDescription()、getSignature() 和 MBeanFeatureInfo.getDescriptor() 值与此 MBeanConstructorInfo 的这些值相等（不必完全一样）时，才返回 true。如果两个签名数组的元素是成对相等，则这两个数组相等。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 MBeanFeatureInfo 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.MBeanException
所有已实现的接口：
Serializable
直接已知子类：
MBeanRegistrationException
public class MBeanException
extends JMException

表示由代理的 MBean 方法所抛出的“用户定义的”异常。它会“包装”所抛出的实际“用户定义的”异常。当调用 MBean 方法导致未知异常时由 MBeanServer 构建此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MBeanException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanException。
MBeanException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。
方法摘要
Throwable | getCause() 返回实际抛出的 Exception。
Exception | getTargetException() 返回实际抛出的 Exception。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanException

public MBeanException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanException。

参数：
e - 被包装的异常。

MBeanException

public MBeanException(Exception e,
                      String message)
创建一个包装实际 java.lang.Exception 的 MBeanException（带有详细消息）。

参数：
e - 被包装的异常。
message - 详细消息。
方法详细信息

getTargetException

public Exception getTargetException()
返回实际抛出的 Exception。

返回：
已包装的异常。

getCause

public Throwable getCause()
返回实际抛出的 Exception。

覆盖：
类 Throwable 中的 getCause
返回：
已包装的异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanFeatureInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanFeatureInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
所有已实现的接口：
Serializable, DescriptorRead
直接已知子类：
MBeanAttributeInfo, MBeanConstructorInfo, MBeanNotificationInfo, MBeanOperationInfo, MBeanParameterInfo
public class MBeanFeatureInfo
extends Object
implements Serializable, DescriptorRead

提供 MBean 描述符对象的常规信息。所描述的功能可以是属性、操作、参数或通知。此类的实例是不可变的。子类可以是可变的，但是不推荐使用此功能。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
protected String | description 该功能的可读描述。
protected String | name 该功能的名称。
构造方法摘要
MBeanFeatureInfo(String name, String description)
构造一个 MBeanFeatureInfo 对象。
MBeanFeatureInfo(String name, String description, Descriptor descriptor)
构造一个 MBeanFeatureInfo 对象。
方法摘要
boolean | equals(Object o) 比较此 MBeanFeatureInfo 与另一个 MBeanFeatureInfo。
String | getDescription() 返回该功能的可读描述。
Descriptor | getDescriptor() 返回该功能的描述符。
String | getName() 返回该功能的名称。
int | hashCode() 返回该对象的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

字段详细信息

name

protected String name
该功能的名称。推荐子类调用 getName() 方法，而不是读取此字段，并且子类不能更改该字段。

description

protected String description
该功能的可读描述。推荐子类调用 getDescription() 方法，而不是读取此字段，并且子类不能更改该字段。

构造方法详细信息

MBeanFeatureInfo

public MBeanFeatureInfo(String name,
                        String description)
构造一个 MBeanFeatureInfo 对象。此构造方法等同于 MBeanFeatureInfo(name, description, (Descriptor) null。

参数：
name - 该功能的名称。
description - 该功能的可读描述。

MBeanFeatureInfo

public MBeanFeatureInfo(String name,
                        String description,
                        Descriptor descriptor)
构造一个 MBeanFeatureInfo 对象。

参数：
name - 该功能的名称。
description - 该功能的可读描述。
descriptor - 该功能的描述符。此参数可以为 null，它等效于一个空描述符。
从以下版本开始：
1.6
方法详细信息

getName

public String getName()
返回该功能的名称。

返回：
该功能的名称。

getDescription

public String getDescription()
返回该功能的可读描述。

返回：
该功能的可读描述。

getDescriptor

public Descriptor getDescriptor()
返回该功能的描述符。更改返回值对原描述符没有影响。

指定者：
接口 DescriptorRead 中的 getDescriptor
返回：
一个描述符，可能是不可变的，也可能是原描述符的副本。
从以下版本开始：
1.6

equals

public boolean equals(Object o)
比较此 MBeanFeatureInfo 与另一个 MBeanFeatureInfo。

覆盖：
类 Object 中的 equals
参数：
o - 要比较的对象。
返回：
当且仅当 o 是一个 MBeanFeatureInfo，其 getName()、getDescription() 和 getDescriptor()值与此 MBeanFeatureInfo 的这些值相等（不必完全一样）时，才返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanInfo

java.lang.Object
    继承者  javax.management.MBeanInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorRead
直接已知子类：
ModelMBeanInfoSupport, OpenMBeanInfoSupport
public class MBeanInfo
extends Object
implements Cloneable, Serializable, DescriptorRead

描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。此类的实例是不可变的。子类可以是可变的，但是不推荐使用此功能。

Dynamic MBean 的 MBeanInfo 内容由其 getMBeanInfo() 方法确定。这包括 Open MBean 和 Model MBean，它们都属于 Dynamic MBean。

Standard MBean 的 MBeanInfo 内容由 MBean 服务器按如下方式确定：

  • getClassName() 返回 MBean 对象的 Java 类名；
  • getConstructors() 返回该对象中所有公共构造方法的列表；
  • getAttributes() 返回所有属性的列表，这些属性的存在是根据 MBean 接口中是否存在 getName、isName 或 setName 方法（符合 Standard MBean 的约定）来推断的；
  • getOperations() 返回 MBean 接口中不表示属性的所有方法的列表；
  • 如果 MBean 未实现 NotificationBroadcaster 接口，则 getNotifications() 返回一个空数组；否则它返回在该接口上调用 NotificationBroadcaster.getNotificationInfo() 的结果；
  • getDescriptor() 返回一个描述符，其包含的内容是 MBean 接口中的所有描述符注释。

getDescription() 返回的描述以及所含属性和操作的描述由相应的 Description 注释（如果有）确定；其他情况下，其内容没有指定。

没有指定 Standard MBean 的 MBeanInfo 的其余细节。这包括所有包含的构造方法、通知的描述；构造方法和操作的参数的名称，以及构造方法参数的描述。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。
方法摘要
Object | clone() 返回此实例的浅表副本。
boolean | equals(Object o) 比较此 MBeanInfo 与另一个 MBeanInfo。
MBeanAttributeInfo[] | getAttributes() 返回为了便于管理而公开的属性的列表。
String | getClassName() 返回此 MBeanInfo 描述的 MBean 的 Java 类名。
MBeanConstructorInfo[] | getConstructors() 返回 MBean 的公共构造方法列表。
String | getDescription() 返回该 MBean 的可读描述。
Descriptor | getDescriptor() 获取此 MBean 的描述符。
MBeanNotificationInfo[] | getNotifications() 返回 MBean 所发出的通知列表。
MBeanOperationInfo[] | getOperations() 返回 MBean 的操作列表。
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanInfo

public MBeanInfo(String className,
                 String description,
                 MBeanAttributeInfo[] attributes,
                 MBeanConstructorInfo[] constructors,
                 MBeanOperationInfo[] operations,
                 MBeanNotificationInfo[] notifications)
          throws IllegalArgumentException
构造一个 MBeanInfo。

参数：
className - 此 MBeanInfo 所描述的 MBean 的 Java 类名。此值可以是任何语法上合法的 Java 类名。它不必是 MBean 服务器或 MBean 的 ClassLoader 已知的 Java 类。如果它是 MBean 的 ClassLoader 已知的 Java 类，则建议但并不要求该类的公共方法包括此 MBeanInfo 中的属性和操作，而这些属性和操作将出现在 Standard MBean 实现中。
description - MBean 的可读描述（可选）。
attributes - MBean 已公开的属性的列表。此参数可以为 null，与零长度数组的效果相同。
constructors - MBean 的公共构造方法列表。此参数可以为 null，与零长度数组的效果相同。
operations - MBean 的操作列表。此参数可以为 null，与零长度数组的效果相同。
notifications - 已发出的那些通知的列表。此参数可以为 null，与零长度数组的效果相同。
抛出：
IllegalArgumentException

MBeanInfo

public MBeanInfo(String className,
                 String description,
                 MBeanAttributeInfo[] attributes,
                 MBeanConstructorInfo[] constructors,
                 MBeanOperationInfo[] operations,
                 MBeanNotificationInfo[] notifications,
                 Descriptor descriptor)
          throws IllegalArgumentException
构造一个 MBeanInfo。

参数：
className - 此 MBeanInfo 所描述的 MBean 的 Java 类名。此值可以是任何语法上合法的 Java 类名。它不必是 MBean 服务器或 MBean 的 ClassLoader 已知的 Java 类。如果它是 MBean 的 ClassLoader 已知的 Java 类，则建议但并不要求该类的公共方法包括此 MBeanInfo 中的属性和操作，而这些属性和操作将出现在 Standard MBean 实现中。
description - MBean 的可读描述（可选）。
attributes - MBean 已公开的属性的列表。此参数可以为 null，与零长度数组的效果相同。
constructors - MBean 的公共构造方法列表。此参数可以为 null，与零长度数组的效果相同。
operations - MBean 的操作列表。此参数可以为 null，与零长度数组的效果相同。
notifications - 已发出的那些通知的列表。此参数可以为 null，与零长度数组的效果相同。
descriptor - MBean 的描述符。此参数可以为 null，其等效于一个空描述符。
抛出：
IllegalArgumentException
从以下版本开始：
1.6
方法详细信息

clone

public Object clone()

返回此实例的浅表副本。可通过调用 super.clone() 来获得该副本，因此要调用 Object.clone() 所实现的默认本机浅表复制机制。不进行任何内部字段的更深层复制。

因为此类是不可变的，所以主要针对子类使用该 clone 方法。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getClassName

public String getClassName()
返回此 MBeanInfo 描述的 MBean 的 Java 类名。

返回：
类名。

getDescription

public String getDescription()
返回该 MBean 的可读描述。

返回：
描述。

getAttributes

public MBeanAttributeInfo[] getAttributes()
返回为了便于管理而公开的属性的列表。每个属性由一个 MBeanAttributeInfo 对象描述。返回的数组是内部数组的一个浅表副本，这意味着它是 MBeanAttributeInfo 对象引用的一个内部数组副本，但它没有复制每个被引用的 MBeanAttributeInfo 对象。

返回：
MBeanAttributeInfo 对象的数组。

getOperations

public MBeanOperationInfo[] getOperations()
返回 MBean 的操作列表。每个操作由一个 MBeanOperationInfo 对象描述。返回的数组是内部数组的一个浅表副本，这意味着它是 MBeanOperationInfo 对象引用的一个内部数组副本，但它没有复制每个被引用的 MBeanOperationInfo 对象。

返回：
MBeanOperationInfo 对象的数组。

getConstructors

public MBeanConstructorInfo[] getConstructors()

返回 MBean 的公共构造方法列表。每个构造方法都由一个 MBeanConstructorInfo 对象描述。

返回的数组是内部数组的一个浅表副本，这意味着它是 MBeanConstructorInfo 对象引用的一个内部数组副本，但它没有复制每个被引用的 MBeanConstructorInfo 对象。

该返回的列表不必包括全部的构造方法。也就是说，该 MBean 具有的公共构造方法可能不在该列表中。在这种情况下，MBean 服务器可以使用该构造方法构造此 MBean 类的另一个实例，即使该构造方法不在列表中也是如此。

返回：
MBeanConstructorInfo 对象的数组。

getNotifications

public MBeanNotificationInfo[] getNotifications()
返回 MBean 所发出的通知列表。每个通知由一个 MBeanNotificationInfo 对象描述。返回的数组是内部数组的一个浅表副本，这意味着它是 MBeanNotificationInfo 对象引用的一个内部数组副本，但它没有复制每个被引用的 MBeanNotificationInfo 对象。

返回：
MBeanNotificationInfo 对象的数组。

getDescriptor

public Descriptor getDescriptor()
获取此 MBean 的描述符。更改返回值对原描述符没有影响。

指定者：
接口 DescriptorRead 中的 getDescriptor
返回：
一个描述符，可能是不可变的，也可能是原描述符的副本。
从以下版本开始：
1.6

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

equals

public boolean equals(Object o)

比较此 MBeanInfo 与另一个 MBeanInfo。当且仅当两个 MBeanInfo 对象的 getClassName()、getDescription() 和 getDescriptor() 返回相等值，并且两个对象的 getAttributes()、getOperations()、getConstructors() 和 getNotifications() 所返回的数组是成对相等时，这两个 MBeanInfo 才是相等的。其中“相等”指的是 Object.equals(Object)，而不是相同。

如果两个 MBeanInfo 对象返回的数组中的值相同，但是顺序不同，则这两个对象不是相等的。

覆盖：
类 Object 中的 equals
参数：
o - 要比较的对象。
返回：
当且仅当根据上述规则 o 等于此 MBeanInfo 时才返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanNotificationInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanNotificationInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanNotificationInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorRead
直接已知子类：
ModelMBeanNotificationInfo
public class MBeanNotificationInfo
extends MBeanFeatureInfo
implements Cloneable

MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。如果 MBean 发出的通知可以是不同 Java 类的实例，则该 MBean 的元数据应该为这些 Java 通知类中的每一个提供 MBeanNotificationInfo 对象。

此类的实例是不可变的。子类可以是可变的，但是推荐不这样做。

此类扩展了 javax.management.MBeanFeatureInfo，因此提供了 name 和 description 字段。name 字段应该是此列所描述的通知对象的完全限定 Java 类名。

getNotifTypes 方法返回一个 string 数组，其中包含 MBean 可以发出的通知类型。通知类型是一个用点表示的 string，它描述了已发出的通知是关于什么的，而不是描述 Java 通知类。可使用一个普通的通知类来发送多种类型的通知。所有这些类型都以 getNotifTypes 方法所得到的字符串数组形式返回。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
MBeanNotificationInfo(String[] notifTypes, String name, String description)
构造一个 MBeanNotificationInfo 对象。
MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。
方法摘要
Object | clone() 返回此实例的浅表副本。
boolean | equals(Object o) 把此 MBeanNotificationInfo 与另一个 MBeanNotificationInfo 进行比较。
String[] | getNotifTypes() 返回包含 MBean 可发出的通知类型的字符串数组（用点表示）。
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanNotificationInfo

public MBeanNotificationInfo(String[] notifTypes,
                             String name,
                             String description)
构造一个 MBeanNotificationInfo 对象。

参数：
notifTypes - 包含 MBean 可发出的通知类型的字符串数组（用点表示）。该参数可以为 null，与零长度数组的效果相同。
name - 所描述通知的完全限定 Java 类名。
description - 数据的可读描述。

MBeanNotificationInfo

public MBeanNotificationInfo(String[] notifTypes,
                             String name,
                             String description,
                             Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。

参数：
notifTypes - 包含 MBean 可发出的通知类型的字符串数组（用点表示）。该参数可以为 null，与零长度数组的效果相同。
name - 所描述通知的完全限定 Java 类名。
description - 数据的可读描述。
descriptor - 通知的描述符。该参数可以为 null，其等效于一个空描述符。
从以下版本开始：
1.6
方法详细信息

clone

public Object clone()
返回此实例的浅表副本。可通过调用 super.clone() 来获得该副本，因此要调用 Object.clone() 所实现的默认本机浅表复制机制。不进行任何内部字段的更深层复制。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getNotifTypes

public String[] getNotifTypes()
返回包含 MBean 可发出的通知类型的字符串数组（用点表示）。

返回：
字符串数组。更改返回的数组对此 MBeanNotificationInfo 没有影响。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

equals

public boolean equals(Object o)
把此 MBeanNotificationInfo 与另一个 MBeanNotificationInfo 进行比较。

覆盖：
类 MBeanFeatureInfo 中的 equals
参数：
o - 要比较的对象。
返回：
当且仅当 o 是一个 MBeanNotificationInfo，这样其 MBeanFeatureInfo.getName()、MBeanFeatureInfo.getDescriptor()、MBeanFeatureInfo.getDescription() 和 getNotifTypes() 值与此 MBeanNotificationInfo 的这些值相等时（不必完全一样）才返回 true。如果两个通知类型数组的对应元素是相等的，则这两个数组相等。如果包含的元素相同但顺序不同，则不是相等的。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 MBeanFeatureInfo 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanOperationInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanOperationInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanOperationInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorRead
直接已知子类：
ModelMBeanOperationInfo, OpenMBeanOperationInfoSupport
public class MBeanOperationInfo
extends MBeanFeatureInfo
implements Cloneable

描述由 MBean 公开的管理操作。此类的实例是不可变的。子类可以是可变的，但是不推荐使用此功能。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static int | ACTION 指示该操作与写入操作类似，并将以某种方式修改 MBean，通常是写入某个值或更改某个配置。
static int | ACTION_INFO 指示该操作与读取和写入操作类似。
static int | INFO 指示该操作与读取操作类似，它主要返回一些信息。
static int | UNKNOWN 指示操作具有“未知”的特性。
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
MBeanOperationInfo(String description, Method method)
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。
方法摘要
Object | clone() 返回此实例的浅表副本。
boolean | equals(Object o) 比较此 MBeanOperationInfo 与另一个 MBeanOperationInfo。
int | getImpact() 返回该方法所产生的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。
String | getReturnType() 返回该方法的返回值的类型。
MBeanParameterInfo[] | getSignature() 返回此操作的参数列表。
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

INFO

public static final int INFO
指示该操作与读取操作类似，它主要返回一些信息。

另请参见：
常量字段值

ACTION

public static final int ACTION
指示该操作与写入操作类似，并将以某种方式修改 MBean，通常是写入某个值或更改某个配置。

另请参见：
常量字段值

ACTION_INFO

public static final int ACTION_INFO
指示该操作与读取和写入操作类似。

另请参见：
常量字段值

UNKNOWN

public static final int UNKNOWN
指示操作具有“未知”的特性。

另请参见：
常量字段值
构造方法详细信息

MBeanOperationInfo

public MBeanOperationInfo(String description,
                          Method method)
构造一个 MBeanOperationInfo 对象。已构造对象的 Descriptor 包括 Method 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
method - 描述 MBean 操作的 java.lang.reflect.Method 对象。
description - 该操作的可读描述。

MBeanOperationInfo

public MBeanOperationInfo(String name,
                          String description,
                          MBeanParameterInfo[] signature,
                          String type,
                          int impact)
构造一个 MBeanOperationInfo 对象。

参数：
name - 该方法的名称。
description - 该操作的可读描述。
signature - 描述该方法的参数（变量）的 MBeanParameterInfo 对象。该参数可以为 null，与零长度数组的效果相同。
type - 方法返回值的类型。
impact - 该方法的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。

MBeanOperationInfo

public MBeanOperationInfo(String name,
                          String description,
                          MBeanParameterInfo[] signature,
                          String type,
                          int impact,
                          Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。

参数：
name - 方法名称。
description - 操作的可读描述。
signature - 描述该方法的参数（变量）的 MBeanParameterInfo 对象。该参数可以为 null，与零长度数组的效果相同。
type - 方法返回值的类型。
impact - 该方法的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。
descriptor - 操作的描述符。此参数可以为 null，它等效于一个空描述符。
从以下版本开始：
1.6
方法详细信息

clone

public Object clone()

返回此实例的浅表副本。可通过调用 super.clone() 来获得该副本，因此要调用 Object.clone() 所实现的默认本机浅表复制机制。不进行任何内部字段的更深层复制。

因为此类是不可变的，所以主要对子类进行复制。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getReturnType

public String getReturnType()
返回该方法的返回值的类型。

返回：
返回类型。

getSignature

public MBeanParameterInfo[] getSignature()

返回此操作的参数列表。每个参数都由一个 MBeanParameterInfo 对象来描述。

返回的数组是内部数组的一个浅表副本，这意味着它是 MBeanParameterInfo 对象引用的一个内部数组副本，但它没有复制每个被引用的 MBeanParameterInfo 对象。

返回：
MBeanParameterInfo 对象的数组。

getImpact

public int getImpact()
返回该方法所产生的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。

返回：
描述影响的代码。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

equals

public boolean equals(Object o)
比较此 MBeanOperationInfo 与另一个 MBeanOperationInfo。

覆盖：
类 MBeanFeatureInfo 中的 equals
参数：
o - 要比较的对象。
返回：
当且仅当 o 是一个 MBeanOperationInfo，其 MBeanFeatureInfo.getName()、getReturnType()、MBeanFeatureInfo.getDescription()、getImpact()、MBeanFeatureInfo.getDescriptor() 和 getSignature() 值与此 MBeanOperationInfo 的这些值相等（不必完全一样）时，才返回 true。如果两个签名数组的元素是成对相等的，则这两个数组相等。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 MBeanFeatureInfo 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanParameterInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanParameterInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanParameterInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorRead
直接已知子类：
OpenMBeanParameterInfoSupport
public class MBeanParameterInfo
extends MBeanFeatureInfo
implements Cloneable

描述由 MBean 公开的操作的参数。此类的实例是不可变的。子类可以是可变的，但是不推荐使用此功能。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
MBeanParameterInfo(String name, String type, String description)
构造一个 MBeanParameterInfo 对象。
MBeanParameterInfo(String name, String type, String description, Descriptor descriptor)
构造一个 MBeanParameterInfo 对象。
方法摘要
Object | clone() 返回此实例的浅表副本。
boolean | equals(Object o) 比较此 MBeanParameterInfo 与另一个 MBeanParameterInfo。
String | getType() 返回该数据的类型或类名。
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回该对象的字符串表示。
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanParameterInfo

public MBeanParameterInfo(String name,
                          String type,
                          String description)
构造一个 MBeanParameterInfo 对象。

参数：
name - 数据的名称
type - 数据的类型或类名
description - 该数据的可读描述。这是一个可选参数。

MBeanParameterInfo

public MBeanParameterInfo(String name,
                          String type,
                          String description,
                          Descriptor descriptor)
构造一个 MBeanParameterInfo 对象。

参数：
name - 数据的名称
type - 数据的类型或类名
description - 数据的可读描述。这是一个可选参数。
descriptor - 操作的描述符。该参数可以为 null，它等效于一个空描述符。
从以下版本开始：
1.6
方法详细信息

clone

public Object clone()

返回此实例的浅表副本。可通过调用 super.clone() 来获得该副本，因此要调用 Object.clone() 所实现的默认本机浅表复制机制。不进行任何内部字段的更深层复制。

因为此类是不可变的，所以主要对子类进行复制。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getType

public String getType()
返回该数据的类型或类名。

返回：
类型 string。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

equals

public boolean equals(Object o)
比较此 MBeanParameterInfo 与另一个 MBeanParameterInfo。

覆盖：
类 MBeanFeatureInfo 中的 equals
参数：
o - 要比较的对象。
返回：
当且仅当 o 是一个 MBeanParameterInfo，其 MBeanFeatureInfo.getName()、getType()、MBeanFeatureInfo.getDescriptor() 和 MBeanFeatureInfo.getDescription() 值与此 MBeanParameterInfo 的这些值相等（不必完全一样）时，才返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 MBeanFeatureInfo 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  javax.management.MBeanPermission
所有已实现的接口：
Serializable, Guard
public class MBeanPermission
extends Permission

权限控制对 MBeanServer 操作的访问。如果已使用 System.setSecurityManager(java.lang.SecurityManager) 设置了安全管理器，则 MBeanServer 上的多数操作都需要调用者的权限隐含了适用于该操作的 MBeanPermission。MBeanServer 接口的文档中对此进行了详细描述。

与其他 Permission 对象一样，MBeanPermission 可以表示所拥有 的权限，或者是所需要 的权限。当检查某个敏感操作的权限时，会构造一个表示所需权限的 MBeanPermission。仅在所拥有的权限隐含所需的权限时才允许该操作。

MBeanPermission 包含四项信息：

  • 操作。对于所需的权限，这是下面列表中的某种操作。对于所拥有的权限，则是这些操作的列表，各项以逗号分隔，或者是 *，表示所有操作。

    通过 getActions() 返回操作。

  • 类名。

    对于所需的权限，这是正在访问的 MBean 的类名，正如 MBeanServer.getMBeanInfo(name) 和 getClassName() 所返回的一样。某些操作不引用类名，在这种情况下类名为 null。

    对于所拥有的权限，这是空或一个类名模式。类名模式是一个服从 Java 对点分类名约定的 string。该模式可以以 ".*" 结尾，意味着该权限允许对名称以 ".*" 前面的字符串开始的类的访问。例如，"javax.management.*" 允许对其他类中的 javax.management.MBeanServerDelegate 和 javax.management.timer.Timer 进行访问。

    类名模式也可以为空，或者只有单个字符 "*"，这两种情况都允许对任何类的访问。

  • 成员。

    对于所需的权限，这是正在访问的属性或操作名。对于没有引用属性或操作的操作，该成员为 null。

    对于所拥有的权限，这要么是可以访问的属性或操作名，要么是空或单个字符 "*"，后面这两种情况都允许对任意成员的访问。

  • 对象名。

    对于所需的权限，这是正在访问的 MBean 的 ObjectName。对于不引用单个 MBean 的操作而言，对象名为 null。它永远不会是对象名模式。

    对于所拥有的权限，这是可访问的 MBean 或 MBeans 的 ObjectName。可以是一个对象名模式，以允许访问其名称匹配该模式的所有 MBean。还可以为空，这样可访问所有 MBean 而不管其名称是什么。

如果拥有 MBeanPermission，则它只允许这四项都匹配的操作。

可将类名、成员和对象名一同写入单个字符串，这就是此权限的名称。权限的名称是 getName() 所返回的字符串。该字符串的格式为：

className#member[objectName]

使用常规的 ObjectName 语法写对象名称。它可包含任意合法字符，包括 ]。由字符串中最后一个 ] 字符终止该字符串。

可省略一个或多个 className、member 或 objectName。如果省略的 member，则 # 也可省略（但并非必须如此）。如果省略 objectName，则 [] 也可省略（但并非必须如此）。省略所有三项是不合法的，也就是说只有一个空字符串的名称 是不合法的。

className、member 或 objectName 中的一个或多个可以是字符 "-"，这等同于 null 值。任意值隐含 null 值（包括另一个 null 值），但是 null 值并不隐含任意其他值。

可能的操作有：

  • addNotificationListener
  • getAttribute
  • getClassLoader
  • getClassLoaderFor
  • getClassLoaderRepository
  • getDomains
  • getMBeanInfo
  • getObjectInstance
  • instantiate
  • invoke
  • isInstanceOf
  • queryMBeans
  • queryNames
  • registerMBean
  • removeNotificationListener
  • setAttribute
  • unregisterMBean

在逗号分隔的操作列表中，每个操作的前后允许有空格。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MBeanPermission(String name, String actions)
创建具有指定目标名称和操作的新 MBeanPermission 对象。
MBeanPermission(String className, String member, ObjectName objectName, String actions)
创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。
方法摘要
boolean | equals(Object obj) 检查两个 MBeanPermission 对象的相等性。
String | getActions() 返回操作的“规范化字符串表示形式”。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此 MBeanPermission 对象是否“隐含”指定的权限。
从类 java.security.Permission 继承的方法
checkGuard, getName, newPermissionCollection, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanPermission

public MBeanPermission(String name,
                       String actions)

创建具有指定目标名称和操作的新 MBeanPermission 对象。

目标名称的形式为 "className#member[objectName]"，其中每部分都是可选的。不可以为空或 null。

actions 参数包含在目标名称上所允许的所需操作列表，该列表用逗号分隔。不可以为空或 null。

参数：
name - 三部分的 "className#member[objectName]"。
actions - 操作字符串。
抛出：
IllegalArgumentException - 如果 name 或 actions 无效。

MBeanPermission

public MBeanPermission(String className,
                       String member,
                       ObjectName objectName,
                       String actions)

创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。

className、member、objectName 参数定义了 "className#member[objectName]" 形式的目标名称，其中每个部分都是可选的。这将是在结果 MBeanPermission 上调用 Permission.getName() 得到的结果。

actions 参数包含在目标名称上所允许的所需操作列表，该列表用逗号分隔。不可以为空或 null。

参数：
className - 应用此权限的类名。可以为 null 或 "-"，这表示一个由任何类名所隐含的类名，但是并不隐含任意其他类名。
member - 应用此权限的成员。可以为 null 或 "-"，这表示一个由任何成员所隐含的成员，但是并不隐含任意其他成员。
objectName - 应用此权限的对象名。可以为 null，这表示一个由任何对象名所隐含的对象名，但是并不隐含任意其他对象名。
actions - 操作字符串。
方法详细信息

getActions

public String getActions()
返回操作的“规范化字符串表示形式”。也就是说，此方法总是以字母顺序返回存在的操作：

指定者：
类 Permission 中的 getActions
返回：
操作的规范化字符串表示形式。

hashCode

public int hashCode()
返回此对象的哈希码值。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

implies

public boolean implies(Permission p)

检查此 MBeanPermission 对象是否“隐含”指定的权限。

更明确地说，如果此方法满足以下条件，则返回 true：

  • p 是 MBeanPermission 的一个实例；并且
  • p 具有 null className 或者 p 的 className 与此对象的 className 相符；并且
  • p 具有 null 成员或者 p 的成员与此对象的成员相符；并且
  • p 具有 null 对象名或者 p 的对象名与此对象的 对象名相符；并且
  • p 的动作是此对象动作的一个子集

如果此对象的 className 是 "*"，则 p 的 className 始终与其相符。如果是 "a.*"，则 p 的 className 与开头是 "a." 的 className 相符。

如果此对象的成员是 "*"，则 p 的成员始终与其相符。

如果此对象的 objectName n1 是一个对象名模式，则在 n1.equals(n2) 或者 n1.apply(n2) 的情况下，p 的 objectName n2 与其相符。

将包括 queryMBeans 操作的权限视为还包括 queryNames。

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果此对象隐含指定的权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 MBeanPermission 对象的相等性。检查 obj 是否为一个 MBeanPermission，并且检查是否和此对象具有相同的名称和操作。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 是一个 MBeanPermission，并且与此 MBeanPermission 对象具有相同的名称和操作，则返回 true。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanRegistration (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 MBeanRegistration

所有已知实现类：
CounterMonitor, GaugeMonitor, JMXConnectorServer, MLet, Monitor, PrivateMLet, RelationService, RelationSupport, RequiredModelMBean, RMIConnectorServer, StandardEmitterMBean, StandardMBean, StringMonitor, Timer
public interface MBeanRegistration

可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。

从以下版本开始：
1.5

方法摘要
void | postDeregister() 允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。
void | postRegister(Boolean registrationDone) 允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
void | preDeregister() 允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。
ObjectName | preRegister(MBeanServer server, ObjectName name) 允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。

方法详细信息

preRegister

ObjectName preRegister(MBeanServer server,
                       ObjectName name)
                       throws Exception
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。如果未指定 MBean 的名称，则该 MBean 可以提供一个注册名称。如果引发任何异常，则该 MBean 不会被注册到 MBean 服务器中。

参数：
server - 将要在其中注册该 MBean 的 MBean 服务器。
name - 该 MBean 的对象名。如果 MBeanServer 接口中的某个 createMBean 方法或 registerMBean 方法的 name 参数为 null，则此 name 也为 null。在这种情况下，此方法必须为新 MBean 返回非 null 的 ObjectName。
返回：
MBean 要被注册的名称。此值必须不为 null。如果 name 参数不为 null，则它通常但并非一定为返回值。
抛出：
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postRegister

void postRegister(Boolean registrationDone)
允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。

参数：
registrationDone - 指示该 MBean 是否已在 MBean 服务器中成功注册。false 值意味着注册阶段已失败。

preDeregister

void preDeregister()
                   throws Exception
允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。

抛出：
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postDeregister

void postDeregister()
允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanRegistrationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanRegistrationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.MBeanException
                    继承者  javax.management.MBeanRegistrationException
所有已实现的接口：
Serializable
public class MBeanRegistrationException
extends MBeanException

包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MBeanRegistrationException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException。
MBeanRegistrationException(Exception e, String message)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。
方法摘要
从类 javax.management.MBeanException 继承的方法
getCause, getTargetException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanRegistrationException

public MBeanRegistrationException(Exception e)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException。

参数：
e - 被包装的异常。

MBeanRegistrationException

public MBeanRegistrationException(Exception e,
                                  String message)
创建一个包装实际 java.lang.Exception 的 MBeanRegistrationException（带有详细消息）。

参数：
e - 被包装的异常。
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 MBeanServer

所有超级接口：
MBeanServerConnection
所有已知子接口：
MBeanServerForwarder
public interface MBeanServer
extends MBeanServerConnection

这是在代理端进行 MBean 操作的接口。它包含创建、注册和删除 MBean 所需的方法，以及用于已注册 MBean 的存取方法。这是 JMX 基础设施的核心组件。

用户代码通常不实现此接口。相反，应该使用 MBeanServerFactory 类中的某个方法获得实现此接口的对象。

添加到 MBean 服务器中的所有 MBean 都会变成得可以管理：通过连接到该 MBeanServer 的连接器/适配器可以远程访问其属性和操作。Java 对象不能在 MBean 服务器中进行注册，除非它是兼容 JMX 的 MBean。

在 MBean 服务器中注册或注销 MBean 时，会发出一个 MBeanServerNotification Notification。要将一个对象注册为 MBeanServerNotifications 的侦听器，则应该使用 MBeanServerDelegate 的 ObjectName 作为 ObjectName 参数调用 MBean 服务器方法 addNotificationListener。此 ObjectName 是：
JMImplementation:type=MBeanServerDelegate。

从 MBeanServerFactory 类的 createMBeanServer 或 newMBeanServer 方法所获得的对象会对其方法进行安全检查，如下所示：

首先，如果没有安全管理器（System.getSecurityManager() 为 null），则此接口的实现可以不进行任何检查。

假定存在安全管理器，或者实现选择进行检查，则按照以下内容进行检查；className 是目标 MBean 的 MBeanInfo.getClassName() 所返回的字符串。

如果安全检查失败，则该方法将抛出 SecurityException。

对于可抛出 InstanceNotFoundException 的方法，它会为不存在的 MBean 抛出此异常，而不管权限如何。这是因为不存在的 MBean 没有 className。

  • 对于 invoke 方法，调用者的权限必须隐含 MBeanPermission(className, operationName, name, "invoke")。

  • 对于 getAttribute 方法，调用者的权限必须隐含 MBeanPermission(className, attribute, name, "getAttribute")。

  • 对于 getAttributes 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "getAttribute")。另外，对于 AttributeList 中的每个属性 a，如果调用者的权限没有隐含 MBeanPermission(className, a, name, "getAttribute")，则 MBean 服务器的行为与所提供列表中不包含该属性时一样。

  • 对于 setAttribute 方法，调用者的权限必须隐含 MBeanPermission(className, attrName, name, "setAttribute")，其中 attrName 是 attribute.getName()。

  • 对于 setAttributes 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "setAttribute")。另外，对于 AttributeList 中的每个属性 a，如果调用者的权限并没有隐含 MBeanPermission(className, a, name, "setAttribute")，则 MBean 服务器的行为与所提供列表中不包含该属性时一样。

  • 对于 addNotificationListener 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "addNotificationListener")。

  • 对于 removeNotificationListener 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "removeNotificationListener")。

  • 对于 getMBeanInfo 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "getMBeanInfo")。

  • 对于 getObjectInstance 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "getObjectInstance")。

  • 对于 isInstanceOf 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "isInstanceOf")。

  • 对于 queryMBeans 方法，调用者的权限必须隐含 MBeanPermission(null, null, name, "queryMBeans")。另外，对于与 name 匹配的每个 MBean，如果调用者的权限没有隐含 MBeanPermission(className, null, name, "queryMBeans")，则 MBean 服务器的行为与该 MBean 不存在时一样。

    某些查询元素在 MBean 服务器上执行操作。如果调用者不具有针对给定 MBean 的所需权限，则查询结果中不包括该 MBean。受此影响的标准查询元素是 Query.attr(String)、Query.attr(String,String) 和 Query.classattr()。

  • 对于 queryNames 方法，执行的检查与 queryMBeans 方法相同，除了在 MBeanPermission 对象中使用 "queryNames" 而不是 "queryMBeans"。注意，"queryMBeans" 权限隐含相应的 "queryNames" 权限。

  • 对于 getDomains 方法，调用者的权限必须隐含 MBeanPermission(null, null, name, "getDomains")。另外，对于返回数组中的每个域 d，如果调用者的权限没有隐含 MBeanPermission(null, null, new ObjectName("d:x=x"), "getDomains")，则从数组中消除该域。其中 x=x 是任意键=值 对，需要满足 ObjectName 的构造方法的要求，但与其他内容无关。

  • 对于 getClassLoader 方法，调用者的权限必须隐含 MBeanPermission(className, null, loaderName, "getClassLoader")。

  • 对于 getClassLoaderFor 方法，调用者的权限必须隐含 MBeanPermission(className, null, mbeanName, "getClassLoaderFor")。

  • 对于 getClassLoaderRepository 方法，调用者的权限必须隐含 MBeanPermission(null, null, null, "getClassLoaderRepository")。

  • 对于已过时的 deserialize 方法，所需的权限与替换它们的方法的权限相同。

  • 对于 instantiate 方法，调用者的权限必须隐含 MBeanPermission(className, null, null, "instantiate")。

  • 对于 registerMBean 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "registerMBean")。其中 className 是 MBeanInfo.getClassName() 为此类某个对象返回的字符串。

    如果 MBeanPermission 检查成功，则验证该 MBean 的类，方法是检查其 ProtectionDomain 是否隐含 MBeanTrustPermission("register")。

    最后，如果 name 参数为 null，则使用 MBeanRegistration.preRegister 返回的 ObjectName 进行另一次 MBeanPermission 检查。

  • 对于 createMBean 方法，调用者的权限必须隐含等效的 instantiate，后跟 registerMBean 所需的权限。

  • 对于 unregisterMBean 方法，调用者的权限必须隐含 MBeanPermission(className, null, name, "unregisterMBean")。

从以下版本开始：
1.5

方法摘要
 void addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。
 void addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。
 ObjectInstance createMBean(String className, ObjectName name)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInputStream deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream deserialize(String className, byte[] data)
已过时。 使用 getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。
 Object getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。
 AttributeList getAttributes(ObjectName name, String[] attributes)
获得指定 MBean 的多个属性值。
 ClassLoader getClassLoader(ObjectName loaderName)
返回指定的 ClassLoader。
 ClassLoader getClassLoaderFor(ObjectName mbeanName)
返回用于加载指定 MBean 的类的 ClassLoader。
 ClassLoaderRepository getClassLoaderRepository()
返回此 MBeanServer 的 ClassLoaderRepository。
 String getDefaultDomain()
返回对 MBean 命名时使用的默认域。
 String[] getDomains()
返回其中所有 MBean 当前已注册的域的列表。
 Integer getMBeanCount()
返回 MBean 服务器中已注册的 MBean 的数目。
 MBeanInfo getMBeanInfo(ObjectName name)
此方法发现了 MBean 为管理而公开的属性和操作。
 ObjectInstance getObjectInstance(ObjectName name)
获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
 Object instantiate(String className)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。
 Object instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。
 Object instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
 Object instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。
 Object invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。
 boolean isInstanceOf(ObjectName name, String className)
如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
 boolean isRegistered(ObjectName name)
检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
 Set<ObjectInstance> queryMBeans(ObjectName name, QueryExp query)
获得该 MBean 服务器所控制的 MBean。
 Set<ObjectName> queryNames(ObjectName name, QueryExp query)
获得该 MBean 服务器所控制的 MBean 的名称。
 ObjectInstance registerMBean(Object object, ObjectName name)
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
 void removeNotificationListener(ObjectName name, NotificationListener listener)
从已注册的 MBean 中移除一个侦听器。
 void removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。
 void removeNotificationListener(ObjectName name, ObjectName listener)
从已注册的 MBean 中移除一个侦听器。
 void removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。
 void setAttribute(ObjectName name, Attribute attribute)
设置指定 MBean 的特定属性值。
 AttributeList setAttributes(ObjectName name, AttributeList attributes)
设置指定 MBean 的多个属性值。
 void unregisterMBean(ObjectName name)
从 MBean 服务器中注销一个 MBean。

方法详细信息

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException
从接口 MBeanServerConnection 复制的描述

在 MBean 服务器中实例化并注册一个 MBean。MBean 服务器将使用其默认的 Loader Repository 来加载 MBean 的类。对象名与该 MBean 相关联。如果给定的对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

此方法等效于 createMBean(className, name, (Object[]) null, (String[]) null)。

指定者：
接口 MBeanServerConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           ObjectName loaderName)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException
从接口 MBeanServerConnection 复制的描述

在 MBean 服务器中实例化并注册一个 MBean。通过其对象名标识使用的类加载器。对象名与该 MBean 相关联。如果加载器的对象名为 null，则将使用加载 MBean 服务器的 ClassLoader。如果给定的 MBean 对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

此方法等效于 createMBean(className, name, loaderName, (Object[]) null, (String[]) null)。

指定者：
接口 MBeanServerConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
loaderName - 要使用的类加载器的对象名。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常。
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean。
InstanceNotFoundException - 如果未在 MBean 服务器中注册指定的类加载器。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           Object[] params,
                           String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException
从接口 MBeanServerConnection 复制的描述
在 MBean 服务器中实例化并注册一个 MBean。MBean 服务器将使用其默认的 Loader Repository 来加载 MBean 的类。对象名与该 MBean 相关联。如果给定的对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

指定者：
接口 MBeanServerConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
params - 一个数组，包含要调用的构造方法的参数。
signature - 一个数组，包含要调用的构造方法的签名。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           ObjectName loaderName,
                           Object[] params,
                           String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException
从接口 MBeanServerConnection 复制的描述
在 MBean 服务器中实例化并注册一个 MBean。通过其对象名标识使用的类加载器。对象名与该 MBean 相关联。如果未指定加载器的对象名，则将使用加载 MBean 服务器的 ClassLoader。如果给定的 MBean 对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

指定者：
接口 MBeanServerConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
loaderName - 要使用的类加载器的对象名。
params - 一个数组，包含要调用的构造方法的参数。
signature - 一个数组，包含要调用的构造方法的签名。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean
InstanceNotFoundException - 如果未在 MBean 服务器中注册指定的类加载器。

registerMBean

ObjectInstance registerMBean(Object object,
                             ObjectName name)
                             throws InstanceAlreadyExistsException,
                                    MBeanRegistrationException,
                                    NotCompliantMBeanException
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。如果给定的对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

参数：
object - 要作为 MBean 注册的 MBean。
name - MBean 的对象名。可以为 null。
返回：
一个 ObjectInstance，它包含新注册的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不要注册该 MBean。
NotCompliantMBeanException - 如果此对象不是兼容 JMX 的 MBean
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的对象为 null 或者未指定对象名。

unregisterMBean

void unregisterMBean(ObjectName name)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException
从接口 MBeanServerConnection 复制的描述
从 MBean 服务器中注销一个 MBean。通过 MBean 的对象名来标识 MBean。一旦调用了该方法，就无法再通过 MBean 的对象名来访问该 MBean。

指定者：
接口 MBeanServerConnection 中的 unregisterMBean
参数：
name - 要注销的 MBean 的对象名。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
MBeanRegistrationException - 如果 MBean 的 preDeregister（MBeanRegistration 接口）方法已经抛出异常。

getObjectInstance

ObjectInstance getObjectInstance(ObjectName name)
                                 throws InstanceNotFoundException
从接口 MBeanServerConnection 复制的描述
获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。

指定者：
接口 MBeanServerConnection 中的 getObjectInstance
参数：
name - MBean 的对象名。
返回：
与 name 所指定的 MBean 相关联的 ObjectInstance。包含的 ObjectName 是 name， 且所包含的类名是 getMBeanInfo(name).getClassName()。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。

queryMBeans

Set<ObjectInstance> queryMBeans(ObjectName name,
                                QueryExp query)
从接口 MBeanServerConnection 复制的描述
获得该 MBean 服务器所控制的 MBean。此方法允许获得下列任意内容：所有 MBean、由与 ObjectName 和/或 Query 表达式相匹配的模式所指定的一组 MBean、一个特定的 MBean。当对象名为 null 并且未指定域和键属性时，会选中所有对象（如果指定了查询，则进行过滤）。它返回已选中 MBean 的 ObjectInstance 对象集（包含 ObjectName 和 Java 类名）

指定者：
接口 MBeanServerConnection 中的 queryMBeans
参数：
name - 对象名模式，标识要检索的 MBean。如果为 null 或未指定域和键属性，则检索所有已注册的 MBean。
query - 应用到所选 MBean 的查询表达式。如果为 null，则不对所选的 MBean 应用查询表达式。
返回：
包含所选的 MBean 的 ObjectInstance 对象的集合。如果没有满足该查询的 MBean，则返回一个空列表。

queryNames

Set<ObjectName> queryNames(ObjectName name,
                           QueryExp query)
从接口 MBeanServerConnection 复制的描述
获得该 MBean 服务器所控制的 MBean 的名称。此方法允许获得下列任意内容：所有 MBean 的名称、由与 ObjectName 和/或 Query 表达式相匹配的模式所指定的一组 MBean 的名称、一个特定 MBean 的名称（等效于测试是否已注册某个 MBean）。当对象名为 null 并且未指定域和键属性时，会选中所有对象（如果指定了查询，则进行过滤）。它返回已选中的 MBean 的 ObjectNames 集合。

指定者：
接口 MBeanServerConnection 中的 queryNames
参数：
name - 对象名模式，标识要检索的 MBean 名称。如果为 null 或未指定域和键属性，则检索所有已注册的 MBean 的名称。
query - 应用到所选 MBean 的查询表达式。如果为 null，则不对选中 MBean 应用查询表达式。
返回：
一个集合，包含已选中 MBean 的 ObjectNames。如果没有满足该查询的 MBean，则返回一个空列表。

isRegistered

boolean isRegistered(ObjectName name)
从接口 MBeanServerConnection 复制的描述
检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。

指定者：
接口 MBeanServerConnection 中的 isRegistered
参数：
name - 要检查的 MBean 的对象名。
返回：
如果已在 MBean 服务器中注册了该 MBean，则返回 True；否则返回 false。

getMBeanCount

Integer getMBeanCount()
返回 MBean 服务器中已注册的 MBean 的数目。

指定者：
接口 MBeanServerConnection 中的 getMBeanCount
返回：
已注册的 MBean 数，包装在一个 Integer 中。如果调用者的权限是受限制的，则此数可能大于调用者可访问的 MBean 数。

getAttribute

Object getAttribute(ObjectName name,
                    String attribute)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException
从接口 MBeanServerConnection 复制的描述
获得指定 MBean 的特定属性值。通过 MBean 的对象名来标识 MBean。

指定者：
接口 MBeanServerConnection 中的 getAttribute
参数：
name - MBean 的对象名，要通过该对象名检索 MBean 的属性。
attribute - 指定要检索的属性名的 String。
返回：
检索到的属性值。
抛出：
MBeanException - 包装 MBean 的获取方法所抛出的异常。
AttributeNotFoundException - 如果指定的属性在 MBean 中是不可访问的。
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
ReflectionException - 包装试图调用设置方法时所抛出的 java.lang.Exception。
另请参见：
MBeanServerConnection.setAttribute(javax.management.ObjectName, javax.management.Attribute)

getAttributes

AttributeList getAttributes(ObjectName name,
                            String[] attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException
从接口 MBeanServerConnection 复制的描述
获得指定 MBean 的多个属性值。通过 MBean 的对象名来标识 MBean。

指定者：
接口 MBeanServerConnection 中的 getAttributes
参数：
name - MBean 的对象名，通过该对象名检索该 MBean 的属性。
attributes - 要检索的属性列表。
返回：
检索到的属性列表。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
ReflectionException - 试图调用 Dynamic MBean 的 getAttributes 方法时抛出的异常。
另请参见：
MBeanServerConnection.setAttributes(javax.management.ObjectName, javax.management.AttributeList)

setAttribute

void setAttribute(ObjectName name,
                  Attribute attribute)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
从接口 MBeanServerConnection 复制的描述
设置指定 MBean 的特定属性值。通过 MBean 的对象名来标识 MBean。

指定者：
接口 MBeanServerConnection 中的 setAttribute
参数：
name - 要设置其属性的 MBean 的名称。
attribute - 要设置的属性的标识及其要设置成的值。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
AttributeNotFoundException - 如果指定的属性在 MBean 中是不可访问的。
InvalidAttributeValueException - 如果为该属性指定的值无效。
MBeanException - 包装 MBean 的设置方法所抛出的异常。
ReflectionException - 包装试图调用设置方法时所抛出的 java.lang.Exception。
另请参见：
MBeanServerConnection.getAttribute(javax.management.ObjectName, java.lang.String)

setAttributes

AttributeList setAttributes(ObjectName name,
                            AttributeList attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException
从接口 MBeanServerConnection 复制的描述
设置指定 MBean 的多个属性值。通过 MBean 的对象名来标识 MBean。

指定者：
接口 MBeanServerConnection 中的 setAttributes
参数：
name - 要设置其属性的 MBean 的对象名。
attributes - 属性列表：要设置的属性的标识及其要设置成的值。
返回：
已设置的属性的列表，以及它们的新值。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
ReflectionException - 试图调用 Dynamic MBean 的 getAttributes 方法时抛出的异常。
另请参见：
MBeanServerConnection.getAttributes(javax.management.ObjectName, java.lang.String[])

invoke

Object invoke(ObjectName name,
              String operationName,
              Object[] params,
              String[] signature)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException
从接口 MBeanServerConnection 复制的描述
在 MBean 上调用某个操作。

指定者：
接口 MBeanServerConnection 中的 invoke
参数：
name - MBean 的对象名，要在该 MBean 上调用方法。
operationName - 要调用的操作名。
params - 一个数组，包含调用操作时要设置的参数
signature - 包含操作签名的数组。用于加载类对象的类加载器与用于加载 MBean（要在其上调用操作）的类加载器相同。
返回：
该操作返回的对象，表示在指定 MBean 上调用该操作的结果。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
MBeanException - 包装在 MBean 上调用的方法所抛出的异常。
ReflectionException - 包装试图调用该方法时所抛出的 java.lang.Exception。

getDefaultDomain

String getDefaultDomain()
从接口 MBeanServerConnection 复制的描述
返回对 MBean 命名时使用的默认域。如果用户未指定域，则将默认域名用作 MBean 的 ObjectName 的域部分。

指定者：
接口 MBeanServerConnection 中的 getDefaultDomain
返回：
默认域。

getDomains

String[] getDomains()
从接口 MBeanServerConnection 复制的描述

返回其中所有 MBean 当前已注册的域的列表。当且仅当至少有一个已注册的 MBean 并且其 ObjectName 的 getDomain() 等于某个字符串时，返回的数组中才有该字符串。返回数组中各个字符串的顺序是未定义的。

指定者：
接口 MBeanServerConnection 中的 getDomains
返回：
域列表。

addNotificationListener

void addNotificationListener(ObjectName name,
                             NotificationListener listener,
                             NotificationFilter filter,
                             Object handback)
                             throws InstanceNotFoundException
从接口 MBeanServerConnection 复制的描述

向已注册的 MBean 添加一个侦听器。

MBeanServer 将 MBean 发出的通知转发到该侦听器。如果通知源是对 MBean 对象的引用，则 MBean 服务器将根据 MBean 的 ObjectName 替换它。否则不更改通知源。

指定者：
接口 MBeanServerConnection 中的 addNotificationListener
参数：
name - MBean 的名称，将在该 MBean 上添加侦听器。
listener - 侦听器对象，它将处理已注册的 MBean 所发出的通知。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送到侦听器的上下文。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
另请参见：
MBeanServerConnection.removeNotificationListener(ObjectName, NotificationListener), MBeanServerConnection.removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

addNotificationListener

void addNotificationListener(ObjectName name,
                             ObjectName listener,
                             NotificationFilter filter,
                             Object handback)
                             throws InstanceNotFoundException
从接口 MBeanServerConnection 复制的描述

向已注册的 MBean 添加一个侦听器。

MBeanServer 将 MBean 发出的通知转发到该侦听器。如果通知源是对 MBean 对象的引用，则 MBean 服务器将根据 MBean 的 ObjectName 替换它。否则不更改通知源。

接收通知的侦听器对象是在调用此方法时使用给定名称注册的。即使之后注销了该侦听器，它也将继续接收通知。

指定者：
接口 MBeanServerConnection 中的 addNotificationListener
参数：
name - MBean 的名称，将在该 MBean 上添加侦听器。
listener - 侦听器的对象名，它将处理已注册的 MBean 所发出的通知。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送到侦听器的上下文。
抛出：
InstanceNotFoundException - 如果通知侦听器或者通知广播器的 MBean 名与任何已注册的 MBean 都不匹配。
另请参见：
MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName), MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                ObjectName listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException
从接口 MBeanServerConnection 复制的描述
从已注册的 MBean 中移除一个侦听器。

如果可能使用不同过滤器或回调多次注册了该侦听器，则此方法将移除所有这些注册关系。

指定者：
接口 MBeanServerConnection 中的 removeNotificationListener
参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器的对象名。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果该侦听器未在 MBean 中注册。
另请参见：
MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                ObjectName listener,
                                NotificationFilter filter,
                                Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException
从接口 MBeanServerConnection 复制的描述

从已注册的 MBean 中移除一个侦听器。

该 MBean 必须具有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果存在多个这样的侦听器，则只移除一个。

当且仅当 filter 和 handback 在要移除的侦听器中为 null 时，这两个参数才可以为 null。

指定者：
接口 MBeanServerConnection 中的 removeNotificationListener
参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器的对象名。
filter - 添加侦听器时所指定的过滤器。
handback - 添加侦听器时所指定的回调。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果侦听器未在 MBean 中注册，或者没有用给定的过滤器和回调注册它。
另请参见：
MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                NotificationListener listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException
从接口 MBeanServerConnection 复制的描述

从已注册的 MBean 中移除一个侦听器。

如果可能使用不同过滤器或回调多次注册了该侦听器，则此方法将移除所有这些注册关系。

指定者：
接口 MBeanServerConnection 中的 removeNotificationListener
参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果该侦听器未在 MBean 中注册。
另请参见：
MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                NotificationListener listener,
                                NotificationFilter filter,
                                Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException
从接口 MBeanServerConnection 复制的描述

从已注册的 MBean 中移除一个侦听器。

该 MBean 必须具有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果存在多个这样的侦听器，则只移除一个。

当且仅当 filter 和 handback 在要移除的侦听器中为 null 时，这两个参数才可以为 null。

指定者：
接口 MBeanServerConnection 中的 removeNotificationListener
参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器。
filter - 添加侦听器时所指定的过滤器。
handback - 添加侦听器时所指定的回调。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果侦听器未在 MBean 中注册，或者没有用给定的过滤器和回调注册它。
另请参见：
MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

getMBeanInfo

MBeanInfo getMBeanInfo(ObjectName name)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException
从接口 MBeanServerConnection 复制的描述
此方法发现了 MBean 为管理而公开的属性和操作。

指定者：
接口 MBeanServerConnection 中的 getMBeanInfo
参数：
name - 要分析的 MBean 名称
返回：
一个 MBeanInfo 实例，允许检索此 MBean 的所有属性和操作。
抛出：
InstanceNotFoundException - 如果未找到指定的 MBean。
IntrospectionException - 如果在 introspection 期间出现异常。
ReflectionException - 试图调用 Dynamic MBean 的 getMBeanInfo 方法时抛出的异常。

isInstanceOf

boolean isInstanceOf(ObjectName name,
                     String className)
                     throws InstanceNotFoundException
从接口 MBeanServerConnection 复制的描述

如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。

如果 name 不是 MBean 的名称，则此方法抛出 InstanceNotFoundException。

否则，假定
X 是 name 所命名的 MBean、
L 是 X 的 ClassLoader、
N 是 X 的 MBeanInfo 中的类名。

如果 N 等于 className，则结果为 true。

如果 L 成功加载了 className，并且 X 是此类的一个实例，则结果为 true。

如果 L 成功加载了 N 和 className，并且由于第一个类而使第二个类是可分配的，则结果为 true。

否则结果为 false。

指定者：
接口 MBeanServerConnection 中的 isInstanceOf
参数：
name - MBean 的 ObjectName。
className - 类名。
返回：
如果根据上述规则，指定的 MBean 是指定类的实例，则返回 true；否则返回 false。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
另请参见：
Class.isInstance(java.lang.Object)

instantiate

Object instantiate(String className)
                   throws ReflectionException,
                          MBeanException

使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。该对象的类应该具有公共构造方法。此方法返回对新创建对象的引用。新创建的对象未在该 MBean 服务器中注册。

此方法等效于 instantiate(className, (Object[]) null, (String[]) null)。

参数：
className - 要实例化的对象的类名。
返回：
新实例化的对象。
抛出：
ReflectionException - 包装在试图调用该对象的构造方法时出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
MBeanException - 如果该对象的构造方法已经抛出异常
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null。

instantiate

Object instantiate(String className,
                   ObjectName loaderName)
                   throws ReflectionException,
                          MBeanException,
                          InstanceNotFoundException

使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。如果加载器名为 null，则将使用加载 MBean 服务器的 ClassLoader。该对象的类应该具有公共构造方法。方法返回对新创建对象的引用。新创建的对象未在该 MBean 服务器中注册。

此方法等效于 instantiate(className, loaderName, (Object[]) null, (String[]) null)。

参数：
className - 要实例化的 MBean 的类名。
loaderName - 要使用的类加载器的对象名。
返回：
新实例化的对象。
抛出：
ReflectionException - 包装在试图调用该对象的构造方法时出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
MBeanException - 如果该对象的构造方法已抛出异常。
InstanceNotFoundException - 如果指定的类加载器未在该 MBeanServer 中注册。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null。

instantiate

Object instantiate(String className,
                   Object[] params,
                   String[] signature)
                   throws ReflectionException,
                          MBeanException

使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。该对象的类应该具有公共构造方法。该调用返回对新创建对象的引用。新创建的对象未在该 MBean 服务器中注册。

参数：
className - 要实例化的对象的类名。
params - 一个数组，包含要调用的构造方法的参数。
signature - 一个数组，包含要调用的构造方法的签名。
返回：
新实例化的对象。
抛出：
ReflectionException - 包装在试图调用该对象的构造方法时出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
MBeanException - 如果该对象的构造方法已经抛出异常
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null。

instantiate

Object instantiate(String className,
                   ObjectName loaderName,
                   Object[] params,
                   String[] signature)
                   throws ReflectionException,
                          MBeanException,
                          InstanceNotFoundException

实例化一个对象。用该对象的对象名标识要使用的类加载器。如果加载器的对象名为 null，则将使用加载 MBean 服务器的 ClassLoader。该对象的类应该具有公共构造方法。该调用返回对新创建对象的引用。新创建的对象未在该 MBean 服务器中注册。

参数：
className - 要实例化的对象的类名。
params - 一个数组，包含要调用的构造方法的参数。
signature - 一个数组，包含要调用的构造方法的签名。
loaderName - 要使用的类加载器的对象名。
返回：
新实例化的对象。
抛出：
ReflectionException - 包装在试图调用该对象的构造方法时出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
MBeanException - 如果该对象的构造方法已经抛出异常
InstanceNotFoundException - 如果指定的类加载器未在该 MBean 服务器中注册。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null。

deserialize

@Deprecated
ObjectInputStream deserialize(ObjectName name,
                                         byte[] data)
                              throws InstanceNotFoundException,
                                     OperationsException
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。

在 MBean 的类加载器上下文中反序列化一个字节数组。

参数：
name - MBean 名，该 MBean 的类加载器应该用于反序列化。
data - 要被反序列化的字节数组。
返回：
反序列化后的对象流。
抛出：
InstanceNotFoundException - 如果未找到指定的 MBean。
OperationsException - 任何常规的输入/输出相关的异常。

deserialize

@Deprecated
ObjectInputStream deserialize(String className,
                                         byte[] data)
                              throws OperationsException,
                                     ReflectionException
已过时。 使用 getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。

在给定的 MBean 类加载器上下文中反序列化一个字节数组。通过 Class Loader Repository 加载类 className 来找到该类加载器。结果类的类加载器就是要使用的类加载器。

参数：
className - 类名，该类的类加载器应该用于反序列化。
data - 要被反序列化的字节数组。
返回：
反序列化后的对象流。
抛出：
OperationsException - 任何常规的输入/输出相关的异常。
ReflectionException - 如果无法由类加载器存储库加载指定的类

deserialize

@Deprecated
ObjectInputStream deserialize(String className,
                                         ObjectName loaderName,
                                         byte[] data)
                              throws InstanceNotFoundException,
                                     OperationsException,
                                     ReflectionException
已过时。 使用 getClassLoader 为反序列化获得类加载器。

在给定的 MBean 类加载器上下文中反序列化一个字节数组。该类加载器是加载名为 "className" 的类的类加载器。用于加载指定类的类加载器的名称是指定的。如果为 null，则使用 MBean 服务器的类加载器。

参数：
className - 类名，该类的类加载器应该用于反序列化。
data - 将被反序列化的字节数组。
loaderName - 用于加载指定类的类加载器的名称。如果为 null，则使用 MBean 服务器的类加载器。
返回：
反序列化后的对象流。
抛出：
InstanceNotFoundException - 如果未找到指定的类加载器 MBean。
OperationsException - 任何常规的输入/输出相关的异常。
ReflectionException - 无法由指定类加载器加载指定的类。

getClassLoaderFor

ClassLoader getClassLoaderFor(ObjectName mbeanName)
                              throws InstanceNotFoundException

返回用于加载指定 MBean 的类的 ClassLoader。

参数：
mbeanName - MBean 的 ObjectName。
返回：
用于该 MBean 的 ClassLoader。如果 l 是该 MBean 的实际 ClassLoader，且 r 是返回的值，则：
  • r 与 l 相同；或者
  • 对于字符串 s 而言，r .loadClass(s) 的结果与 l .loadClass(s) 的结果相同。
这意味着出于安全或其他原因考虑，该 ClassLoader 可能被包装在另一个 ClassLoader 中。
抛出：
InstanceNotFoundException - 如果未找到指定的 MBean。

getClassLoader

ClassLoader getClassLoader(ObjectName loaderName)
                           throws InstanceNotFoundException

返回指定的 ClassLoader。

参数：
loaderName - ClassLoader 的 ObjectName。可以为 null，在这种情况下，则返回该 MBean 服务器自己的 ClassLoader。
返回：
指定的 ClassLoader。如果 l 是具有该名称的实际 ClassLoader，且 r 是返回值，则如下所示：
  • r 与 l 相同；或者
  • 对于字符串 s 而言，r .loadClass(s) 的结果与 l .loadClass(s) 的结果相同。
这意味着出于安全或其他原因考虑，该 ClassLoader 可能被包装在另一个 ClassLoader 中。
抛出：
InstanceNotFoundException - 如果未找到指定的 ClassLoader。

getClassLoaderRepository

ClassLoaderRepository getClassLoaderRepository()

返回此 MBeanServer 的 ClassLoaderRepository。

返回：
此 MBeanServer 的 ClassLoaderRepository。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerBuilder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanServerBuilder

java.lang.Object
    继承者  javax.management.MBeanServerBuilder

public class MBeanServerBuilder
extends Object

此类表示创建默认 MBeanServer 实现的生成器。JMX MBeanServerFactory 通过提供此类的子类，从而允许应用程序提供其自定义的 MBeanServer 实现。

从以下版本开始：
1.5
另请参见：
MBeanServer, MBeanServerFactory

构造方法摘要
MBeanServerBuilder()
公共的默认构造方法。
方法摘要
MBeanServer | newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate) 此方法创建一个新的 MBeanServer 实现对象。
MBeanServerDelegate | newMBeanServerDelegate() 此方法为新的 MBeanServer 创建新的 MBeanServerDelegate。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MBeanServerBuilder

public MBeanServerBuilder()
公共的默认构造方法。

方法详细信息

newMBeanServerDelegate

public MBeanServerDelegate newMBeanServerDelegate()
此方法为新的 MBeanServer 创建新的 MBeanServerDelegate。为了创建新的 MBeanServerDelegate，在创建新的 MBeanServer 时，MBeanServerFactory 首先调用此方法。
然后它调用 newMBeanServer(defaultDomain,outer,delegate)，传入 MBeanServer 实现应该使用的 delegate。

注意，传递的 delegate 可能并非直接就是此方法所返回的 MBeanServerDelegate。例如，它可能是一个包装了以前返回的对象的新对象。

返回：
新的 MBeanServerDelegate。

newMBeanServer

public MBeanServer newMBeanServer(String defaultDomain,
                                  MBeanServer outer,
                                  MBeanServerDelegate delegate)
此方法创建一个新的 MBeanServer 实现对象。为了获得新的 MBeanServer 的新 MBeanServerDelegate，创建新的 MBeanServer 时，MBeanServerFactory 首先调用 newMBeanServerDelegate()。然后它调用 newMBeanServer(defaultDomain,outer,delegate)，传入 MBeanServer 实现应该使用的 delegate。

注意，传递的 delegate 可能并非直接就是此实现所返回的 MBeanServerDelegate。例如，它可能是一个包装了以前返回的委托的新对象。

outer 参数是一个指向 MBeanServer 的指针，在 MBeanServer 内注册 MBean 时，应该将该指针传递到 MBeanRegistration 接口。如果 outer 为 null，则在调用 MBeanRegistration 接口时，该 MBeanServer 实现必须使用其自己的 this 引用。

这就使 MBeanServer 实现包装另一个 MBeanServer 实现成为可能，例如为了实现安全检查，或者通过返回到包装对象的指针，从而阻止对实际 MBeanServer 实现的访问。

参数：
defaultDomain - 新 MBeanServer 的默认域。
outer - 到 MBeanServer 对象的指针，调用其 MBeanRegistration 接口时必须将该指针传递到 MBean。
delegate - 指向与新 MBeanServer 相关联的 MBeanServerDelegate 的指针。新的 MBeanServer 必须在其 MBean 存储库中注册此 MBean。
返回：
MBeanServer 的新的私有实现。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerConnection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 MBeanServerConnection

所有已知子接口：
MBeanServer, MBeanServerForwarder
public interface MBeanServerConnection

此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。表示本地 MBean 服务器的 MBeanServer 接口扩展了此接口。

从以下版本开始：
1.5

方法摘要
void | addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
ObjectInstance | createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
Object | getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
AttributeList | getAttributes(ObjectName name, String[] attributes) 获得指定 MBean 的多个属性值。
String | getDefaultDomain() 返回对 MBean 命名时使用的默认域。
String[] | getDomains() 返回其中所有 MBean 当前已注册的域的列表。
Integer | getMBeanCount() 返回 MBean 服务器中已注册的 MBean 数目。
MBeanInfo | getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。
ObjectInstance | getObjectInstance(ObjectName name) 获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
Object | invoke(ObjectName name, String operationName, Object[] params, String[] signature) 在 MBean 上调用某个操作。
boolean | isInstanceOf(ObjectName name, String className) 如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
boolean | isRegistered(ObjectName name) 检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
Set<ObjectInstance> | queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。
Set<ObjectName> | queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。
void | removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | removeNotificationListener(ObjectName name, ObjectName listener) 从已注册的 MBean 中移除一个侦听器。
void | removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。
AttributeList | setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。
void | unregisterMBean(ObjectName name) 从 MBean 服务器中注销一个 MBean。

方法详细信息

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException

在 MBean 服务器中实例化并注册一个 MBean。MBean 服务器将使用其默认的 Loader Repository 来加载 MBean 的类。对象名与该 MBean 相关联。如果给定的对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

此方法等效于 createMBean(className, name, (Object[]) null, (String[]) null)。

参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null，传入参数中的 ObjectName 包含一个模式或者没有为该 MBean 指定 ObjectName。
IOException - 如果与 MBean 服务器通信时出现通信问题。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           ObjectName loaderName)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException

在 MBean 服务器中实例化并注册一个 MBean。通过其对象名标识使用的类加载器。对象名与该 MBean 相关联。如果加载器的对象名为 null，则将使用加载 MBean 服务器的 ClassLoader。如果给定的 MBean 对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

此方法等效于 createMBean(className, name, loaderName, (Object[]) null, (String[]) null)。

参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
loaderName - 要使用的类加载器的对象名。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常。
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean。
InstanceNotFoundException - 如果未在 MBean 服务器中注册指定的类加载器。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null，传入参数中的 ObjectName 包含一个模式或者没有为该 MBean 指定 ObjectName。
IOException - 如果与 MBean 服务器通信时出现通信问题。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           Object[] params,
                           String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
在 MBean 服务器中实例化并注册一个 MBean。MBean 服务器将使用其默认的 Loader Repository 来加载 MBean 的类。对象名与该 MBean 相关联。如果给定的对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
params - 一个数组，包含要调用的构造方法的参数。
signature - 一个数组，包含要调用的构造方法的签名。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null，传入参数中的 ObjectName 包含一个模式或者没有为该 MBean 指定 ObjectName。
IOException - 如果与 MBean 服务器通信时出现通信问题。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           ObjectName loaderName,
                           Object[] params,
                           String[] signature)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
在 MBean 服务器中实例化并注册一个 MBean。通过其对象名标识使用的类加载器。对象名与该 MBean 相关联。如果未指定加载器的对象名，则将使用加载 MBean 服务器的 ClassLoader。如果给定的 MBean 对象名为 null，则该 MBean 必须提供自己的名称，方法是实现 MBeanRegistration 接口并从 preRegister 方法中返回名称。

参数：
className - 要实例化的 MBean 的类名。
name - 该 MBean 的对象名。可以为 null。
params - 一个数组，包含要调用的构造方法的参数。
signature - 一个数组，包含要调用的构造方法的签名。
loaderName - 要使用的类加载器的对象名。
返回：
一个 ObjectInstance，包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果包含的 ObjectName 是 n，则所包含的 Java 类名是 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 包装在试图调用 MBean 的构造方法时所出现的 java.lang.ClassNotFoundException 或 java.lang.Exception。
InstanceAlreadyExistsException - 如果该 MBean 已经处于 MBean 服务器的控制之下。
MBeanRegistrationException - 如果 MBean 的 preRegister（MBeanRegistration 接口）方法已经抛出异常。不注册该 MBean。
MBeanException - 如果 MBean 的构造方法已经抛出异常
NotCompliantMBeanException - 如果此类不是符合 JMX 的 MBean
InstanceNotFoundException - 如果未在 MBean 服务器中注册指定的类加载器。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果传入参数中的 className 为 null，传入参数中的 ObjectName 包含一个模式或者没有为该 MBean 指定 ObjectName。
IOException - 如果与 MBean 服务器通信时出现通信问题。

unregisterMBean

void unregisterMBean(ObjectName name)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException,
                            IOException
从 MBean 服务器中注销一个 MBean。通过 MBean 的对象名来标识 MBean。一旦调用了该方法，就无法再通过 MBean 的对象名来访问该 MBean。

参数：
name - 要注销的 MBean 的对象名。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
MBeanRegistrationException - 如果 MBean 的 preDeregister（MBeanRegistration 接口）方法已经抛出异常。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果参数中的对象名为 null，或者试图注销的 MBean 是 MBeanServerDelegate MBean。
IOException - 如果与 MBean 服务器通信时出现通信问题。

getObjectInstance

ObjectInstance getObjectInstance(ObjectName name)
                                 throws InstanceNotFoundException,
                                        IOException
获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。

参数：
name - MBean 的对象名。
返回：
与 name 所指定的 MBean 相关联的 ObjectInstance。包含的 ObjectName 是 name， 且所包含的类名是 getMBeanInfo(name).getClassName()。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
IOException - 如果与 MBean 服务器通信时出现通信问题。

queryMBeans

Set<ObjectInstance> queryMBeans(ObjectName name,
                                QueryExp query)
                                throws IOException
获得该 MBean 服务器所控制的 MBean。此方法允许获得下列任意内容：所有 MBean、由与 ObjectName 和/或 Query 表达式相匹配的模式所指定的一组 MBean、一个特定的 MBean。当对象名为 null 并且未指定域和键属性时，会选中所有对象（如果指定了查询，则进行过滤）。它返回已选中 MBean 的 ObjectInstance 对象集（包含 ObjectName 和 Java 类名）

参数：
name - 对象名模式，标识要检索的 MBean。如果为 null 或未指定域和键属性，则检索所有已注册的 MBean。
query - 应用到所选 MBean 的查询表达式。如果为 null，则不对所选的 MBean 应用查询表达式。
返回：
包含所选的 MBean 的 ObjectInstance 对象的集合。如果没有满足该查询的 MBean，则返回一个空列表。
抛出：
IOException - 如果与 MBean 服务器通信时出现通信问题。

queryNames

Set<ObjectName> queryNames(ObjectName name,
                           QueryExp query)
                           throws IOException
获得该 MBean 服务器所控制的 MBean 的名称。此方法允许获得下列任意内容：所有 MBean 的名称、由与 ObjectName 和/或 Query 表达式相匹配的模式所指定的一组 MBean 的名称、一个特定 MBean 的名称（等效于测试是否已注册某个 MBean）。当对象名为 null 并且未指定域和键属性时，会选中所有对象（如果指定了查询，则进行过滤）。它返回已选中的 MBean 的 ObjectNames 集合。

参数：
name - 对象名模式，标识要检索的 MBean 名称。如果为 null 或未指定域和键属性，则检索所有已注册的 MBean 的名称。
query - 应用到所选 MBean 的查询表达式。如果为 null，则不对选中 MBean 应用查询表达式。
返回：
一个集合，包含已选中 MBean 的 ObjectNames。如果没有满足该查询的 MBean，则返回一个空列表。
抛出：
IOException - 如果与 MBean 服务器通信时出现通信问题。

isRegistered

boolean isRegistered(ObjectName name)
                     throws IOException
检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。

参数：
name - 要检查的 MBean 的对象名。
返回：
如果已在 MBean 服务器中注册了该 MBean，则返回 True；否则返回 false。
抛出：
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果参数中的对象名为 null。
IOException - 如果与 MBean 服务器通信时出现通信问题。

getMBeanCount

Integer getMBeanCount()
                      throws IOException
返回 MBean 服务器中已注册的 MBean 数目。

返回：
已注册的 MBean 数。
抛出：
IOException - 如果与 MBean 服务器通信时出现通信问题。

getAttribute

Object getAttribute(ObjectName name,
                    String attribute)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           IOException
获得指定 MBean 的特定属性值。通过 MBean 的对象名来标识 MBean。

参数：
name - MBean 的对象名，要通过该对象名检索 MBean 的属性。
attribute - 指定要检索的属性名的 String。
返回：
检索到的属性值。
抛出：
AttributeNotFoundException - 如果指定的属性在 MBean 中是不可访问的。
MBeanException - 包装 MBean 的获取方法所抛出的异常。
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
ReflectionException - 包装试图调用设置方法时所抛出的 java.lang.Exception。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果参数中的对象名为 null 或者参数中的属性为 null。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
setAttribute(javax.management.ObjectName, javax.management.Attribute)

getAttributes

AttributeList getAttributes(ObjectName name,
                            String[] attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
获得指定 MBean 的多个属性值。通过 MBean 的对象名来标识 MBean。

参数：
name - MBean 的对象名，通过该对象名检索该 MBean 的属性。
attributes - 要检索的属性列表。
返回：
检索到的属性列表。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
ReflectionException - 试图调用 Dynamic MBean 的 getAttributes 方法时抛出的异常。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果参数中的对象名为 null 或者参数中的属性为 null。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
setAttributes(javax.management.ObjectName, javax.management.AttributeList)

setAttribute

void setAttribute(ObjectName name,
                  Attribute attribute)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         IOException
设置指定 MBean 的特定属性值。通过 MBean 的对象名来标识 MBean。

参数：
name - 要设置其属性的 MBean 的名称。
attribute - 要设置的属性的标识及其要设置成的值。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
AttributeNotFoundException - 如果指定的属性在 MBean 中是不可访问的。
InvalidAttributeValueException - 如果为该属性指定的值无效。
MBeanException - 包装 MBean 的设置方法所抛出的异常。
ReflectionException - 包装试图调用设置方法时所抛出的 java.lang.Exception。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果参数中的对象名为 null 或者参数中的属性为 null。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
getAttribute(javax.management.ObjectName, java.lang.String)

setAttributes

AttributeList setAttributes(ObjectName name,
                            AttributeList attributes)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
设置指定 MBean 的多个属性值。通过 MBean 的对象名来标识 MBean。

参数：
name - 要设置其属性的 MBean 的对象名。
attributes - 属性列表：要设置的属性的标识及其要设置成的值。
返回：
已设置的属性的列表，以及它们的新值。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
ReflectionException - 试图调用 Dynamic MBean 的 getAttributes 方法时抛出的异常。
RuntimeOperationsException - 包装 java.lang.IllegalArgumentException：如果参数中的对象名为 null 或者参数中的属性为 null。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
getAttributes(javax.management.ObjectName, java.lang.String[])

invoke

Object invoke(ObjectName name,
              String operationName,
              Object[] params,
              String[] signature)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     IOException
在 MBean 上调用某个操作。

参数：
name - MBean 的对象名，要在该 MBean 上调用方法。
operationName - 要调用的操作名。
params - 一个数组，包含调用操作时要设置的参数
signature - 包含操作签名的数组。用于加载类对象的类加载器与用于加载 MBean（要在其上调用操作）的类加载器相同。
返回：
该操作返回的对象，表示在指定 MBean 上调用该操作的结果。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
MBeanException - 包装在 MBean 上调用的方法所抛出的异常。
ReflectionException - 包装试图调用该方法时所抛出的 java.lang.Exception。
IOException - 如果与 MBean 服务器通信时出现通信问题。

getDefaultDomain

String getDefaultDomain()
                        throws IOException
返回对 MBean 命名时使用的默认域。如果用户未指定域，则将默认域名用作 MBean 的 ObjectName 的域部分。

返回：
默认域。
抛出：
IOException - 如果与 MBean 服务器通信时出现通信问题。

getDomains

String[] getDomains()
                    throws IOException

返回其中所有 MBean 当前已注册的域的列表。当且仅当至少有一个已注册的 MBean 并且其 ObjectName 的 getDomain() 等于某个字符串时，返回的数组中才有该字符串。返回数组中各个字符串的顺序是未定义的。

返回：
域列表。
抛出：
IOException - 如果与 MBean 服务器通信时出现通信问题。

addNotificationListener

void addNotificationListener(ObjectName name,
                             NotificationListener listener,
                             NotificationFilter filter,
                             Object handback)
                             throws InstanceNotFoundException,
                                    IOException

向已注册的 MBean 添加一个侦听器。

MBeanServer 将 MBean 发出的通知转发到该侦听器。如果通知源是对 MBean 对象的引用，则 MBean 服务器将根据 MBean 的 ObjectName 替换它。否则不更改通知源。

参数：
name - MBean 的名称，将在该 MBean 上添加侦听器。
listener - 侦听器对象，它将处理已注册的 MBean 所发出的通知。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送到侦听器的上下文。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
removeNotificationListener(ObjectName, NotificationListener), removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

addNotificationListener

void addNotificationListener(ObjectName name,
                             ObjectName listener,
                             NotificationFilter filter,
                             Object handback)
                             throws InstanceNotFoundException,
                                    IOException

向已注册的 MBean 添加一个侦听器。

MBeanServer 将 MBean 发出的通知转发到该侦听器。如果通知源是对 MBean 对象的引用，则 MBean 服务器将根据 MBean 的 ObjectName 替换它。否则不更改通知源。

接收通知的侦听器对象是在调用此方法时使用给定名称注册的。即使之后注销了该侦听器，它也将继续接收通知。

参数：
name - MBean 的名称，将在该 MBean 上添加侦听器。
listener - 侦听器的对象名，它将处理已注册的 MBean 所发出的通知。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送到侦听器的上下文。
抛出：
InstanceNotFoundException - 如果通知侦听器或者通知广播器的 MBean 名与任何已注册的 MBean 都不匹配。
RuntimeOperationsException - 包装 IllegalArgumentException。如果 listener 指定的 MBean 存在但是未实现 NotificationListener 接口。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
removeNotificationListener(ObjectName, ObjectName), removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                ObjectName listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
从已注册的 MBean 中移除一个侦听器。

如果可能使用不同过滤器或回调多次注册了该侦听器，则此方法将移除所有这些注册关系。

参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器的对象名。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果该侦听器未在 MBean 中注册。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                ObjectName listener,
                                NotificationFilter filter,
                                Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException

从已注册的 MBean 中移除一个侦听器。

该 MBean 必须具有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果存在多个这样的侦听器，则只移除一个。

当且仅当 filter 和 handback 在要移除的侦听器中为 null 时，这两个参数才可以为 null。

参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器的对象名。
filter - 添加侦听器时所指定的过滤器。
handback - 添加侦听器时所指定的回调。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果侦听器未在 MBean 中注册，或者没有用给定的过滤器和回调注册它。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                NotificationListener listener)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException

从已注册的 MBean 中移除一个侦听器。

如果可能使用不同过滤器或回调多次注册了该侦听器，则此方法将移除所有这些注册关系。

参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果该侦听器未在 MBean 中注册。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                NotificationListener listener,
                                NotificationFilter filter,
                                Object handback)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException

从已注册的 MBean 中移除一个侦听器。

该 MBean 必须具有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果存在多个这样的侦听器，则只移除一个。

当且仅当 filter 和 handback 在要移除的侦听器中为 null 时，这两个参数才可以为 null。

参数：
name - MBean 的名称，将移除该 MBean 上的侦听器。
listener - 要移除的侦听器。
filter - 添加侦听器时所指定的过滤器。
handback - 添加侦听器时所指定的回调。
抛出：
InstanceNotFoundException - 如果提供的 MBean 与任何已注册 MBean 都不匹配。
ListenerNotFoundException - 如果侦听器未在 MBean 中注册，或者没有用给定的过滤器和回调注册它。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object)

getMBeanInfo

MBeanInfo getMBeanInfo(ObjectName name)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException,
                              IOException
此方法发现了 MBean 为管理而公开的属性和操作。

参数：
name - 要分析的 MBean 名称
返回：
一个 MBeanInfo 实例，允许检索此 MBean 的所有属性和操作。
抛出：
IntrospectionException - 如果在 introspection 期间出现异常。
InstanceNotFoundException - 如果未找到指定的 MBean。
ReflectionException - 试图调用 Dynamic MBean 的 getMBeanInfo 方法时抛出的异常。
IOException - 如果与 MBean 服务器通信时出现通信问题。

isInstanceOf

boolean isInstanceOf(ObjectName name,
                     String className)
                     throws InstanceNotFoundException,
                            IOException

如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。

如果 name 不是 MBean 的名称，则此方法抛出 InstanceNotFoundException。

否则，假定
X 是 name 所命名的 MBean、
L 是 X 的 ClassLoader、
N 是 X 的 MBeanInfo 中的类名。

如果 N 等于 className，则结果为 true。

如果 L 成功加载了 className，并且 X 是此类的一个实例，则结果为 true。

如果 L 成功加载了 N 和 className，并且由于第一个类而使第二个类是可分配的，则结果为 true。

否则结果为 false。

参数：
name - MBean 的 ObjectName。
className - 类名。
返回：
如果根据上述规则，指定的 MBean 是指定类的实例，则返回 true；否则返回 false。
抛出：
InstanceNotFoundException - 如果指定的 MBean 未在该 MBean 服务器中注册。
IOException - 如果与 MBean 服务器通信时出现通信问题。
另请参见：
Class.isInstance(java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerDelegate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanServerDelegate

java.lang.Object
    继承者  javax.management.MBeanServerDelegate
所有已实现的接口：
MBeanServerDelegateMBean, NotificationBroadcaster, NotificationEmitter
public class MBeanServerDelegate
extends Object
implements MBeanServerDelegateMBean, NotificationEmitter

从管理的角度表示 MBean 服务器。在 MBean 服务器中注册/注销 MBean 时，MBeanServerDelegate MBean 发出 MBeanServerNotifications。

从以下版本开始：
1.5

字段摘要
static ObjectName DELEGATE_NAME
定义 MBeanServerDelegate 的默认 ObjectName。
构造方法摘要
MBeanServerDelegate()
创建一个 MBeanServerDelegate 对象。
方法摘要
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
String | getImplementationName() 返回 JMX 实现的名称（此产品的名称）。
String | getImplementationVendor() 返回 JMX 实现供应商（此产品的供应商）。
String | getImplementationVersion() 返回 JMX 实现的版本（此产品的版本）。
String | getMBeanServerId() 返回 MBean 服务器代理标识。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
String | getSpecificationName() 返回此产品实现的 JMX 规范的全名。
String | getSpecificationVendor() 返回此产品实现的 JMX 规范的供应商。
String | getSpecificationVersion() 返回此产品实现的 JMX 规范的版本。
void | removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。
void | removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | sendNotification(Notification notification) 允许 MBean 服务器发送通知。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DELEGATE_NAME

public static final ObjectName DELEGATE_NAME
定义 MBeanServerDelegate 的默认 ObjectName。

从以下版本开始：
1.6
构造方法详细信息

MBeanServerDelegate

public MBeanServerDelegate()
创建一个 MBeanServerDelegate 对象。

方法详细信息

getMBeanServerId

public String getMBeanServerId()
返回 MBean 服务器代理标识。

指定者：
接口 MBeanServerDelegateMBean 中的 getMBeanServerId
返回：
标识。

getSpecificationName

public String getSpecificationName()
返回此产品实现的 JMX 规范的全名。

指定者：
接口 MBeanServerDelegateMBean 中的 getSpecificationName
返回：
规范的名称。

getSpecificationVersion

public String getSpecificationVersion()
返回此产品实现的 JMX 规范的版本。

指定者：
接口 MBeanServerDelegateMBean 中的 getSpecificationVersion
返回：
规范的版本。

getSpecificationVendor

public String getSpecificationVendor()
返回此产品实现的 JMX 规范的供应商。

指定者：
接口 MBeanServerDelegateMBean 中的 getSpecificationVendor
返回：
规范的供应商。

getImplementationName

public String getImplementationName()
返回 JMX 实现的名称（此产品的名称）。

指定者：
接口 MBeanServerDelegateMBean 中的 getImplementationName
返回：
实现的名称。

getImplementationVersion

public String getImplementationVersion()
返回 JMX 实现的版本（此产品的版本）。

指定者：
接口 MBeanServerDelegateMBean 中的 getImplementationVersion
返回：
实现版本。

getImplementationVendor

public String getImplementationVendor()
返回 JMX 实现供应商（此产品的供应商）。

指定者：
接口 MBeanServerDelegateMBean 中的 getImplementationVendor
返回：
实现供应商。

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
从接口 NotificationBroadcaster 复制的描述

返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。

MBean 发送此数组中未描述的通知是合法的。但是，某些 MBean 服务器的客户端要想正常运行，可能要依赖完整的数组。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
返回：
可能的通知数组。

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws IllegalArgumentException
从接口 NotificationBroadcaster 复制的描述
在此 MBean 中添加一个侦听器。

指定者：
接口 NotificationBroadcaster 中的 addNotificationListener
参数：
listener - 将处理广播者发出的通知的侦听器对象。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送回侦听器的不透明对象。Notification 广播者对象不能使用此对象。应该将通知不作更改地重新发送到侦听器。
抛出：
IllegalArgumentException - 如果 Listener 参数为 null。
另请参见：
NotificationBroadcaster.removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException
从接口 NotificationEmitter 复制的描述

从此 MBean 移除一个侦听器。该 MBean 必须有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果有多个此类侦听器，则只移除一个侦听器。

当且仅当在要移除的侦听器中 filter 和 handback 参数为 null 时，这两个参数才可以为 null。

指定者：
接口 NotificationEmitter 中的 removeNotificationListener
参数：
listener - 以前添加到此 MBean 中的侦听器。
filter - 添加侦听器时指定的过滤器。
handback - 添加侦听器时指定的回送。
抛出：
ListenerNotFoundException - 如果没有在该 MBean 中注册侦听器，或者没有用给定的过滤器和回送注册它。

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
从接口 NotificationBroadcaster 复制的描述
从此 MBean 移除一个侦听器。如果已向不同的 handback 对象或通知过滤器注册了该侦听器，则移除与该侦听器有关的所有项。

指定者：
接口 NotificationBroadcaster 中的 removeNotificationListener
参数：
listener - 以前添加到此 MBean 中的侦听器。
抛出：
ListenerNotFoundException - 如果没有在 MBean 中注册该侦听器。
另请参见：
NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

sendNotification

public void sendNotification(Notification notification)
允许 MBean 服务器发送通知。如果传递的 notification 的序列号小于或等于 0，则用该委托自己的序列号替换它。

参数：
notification - 要发送的通知。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerDelegateMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 MBeanServerDelegateMBean

所有已知实现类：
MBeanServerDelegate
public interface MBeanServerDelegateMBean

定义类 MBeanServerDelegate 的对象的管理接口。

从以下版本开始：
1.5

方法摘要
String | getImplementationName() 返回 JMX 实现名（此产品的名称）。
String | getImplementationVendor() 返回 JMX 实现供应商（此产品的供应商）。
String | getImplementationVersion() 返回 JMX 实现版本（此产品的版本）。
String | getMBeanServerId() 返回 MBean 服务器代理标识。
String | getSpecificationName() 返回此产品实现的 JMX 规范的全名。
String | getSpecificationVendor() 返回此产品实现的 JMX 规范的供应商。
String | getSpecificationVersion() 返回此产品实现的 JMX 规范的版本。

方法详细信息

getMBeanServerId

String getMBeanServerId()
返回 MBean 服务器代理标识。

返回：
代理标识。

getSpecificationName

String getSpecificationName()
返回此产品实现的 JMX 规范的全名。

返回：
规范名称。

getSpecificationVersion

String getSpecificationVersion()
返回此产品实现的 JMX 规范的版本。

返回：
规范版本。

getSpecificationVendor

String getSpecificationVendor()
返回此产品实现的 JMX 规范的供应商。

返回：
规范供应商。

getImplementationName

String getImplementationName()
返回 JMX 实现名（此产品的名称）。

返回：
实现名称。

getImplementationVersion

String getImplementationVersion()
返回 JMX 实现版本（此产品的版本）。

返回：
实现版本。

getImplementationVendor

String getImplementationVendor()
返回 JMX 实现供应商（此产品的供应商）。

返回：
实现供应商。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanServerFactory

java.lang.Object
    继承者  javax.management.MBeanServerFactory

public class MBeanServerFactory
extends Object

提供 MBean 服务器引用。没有此类的实例。

从 JMX 1.2 开始，此类使替换默认的 MBeanServer 实现成为可能。使用 MBeanServerBuilder 类实现此替换。可通过 javax.management.builder.initial 系统属性指定要实例化的初始 MBeanServerBuilder 的类。指定的类必须是 MBeanServerBuilder 的公共子类，并且必须具有公共的空构造方法。

默认情况下，如果未指定该属性的值，则创建一个 javax.management.MBeanServerBuilder 的实例。否则，MBeanServerFactory 会试图使用 Thread.currentThread().getContextClassLoader() 加载指定的类，如果该属性值为 null，则使用 Class.forName() 加载指定的类。然后它使用 Class.newInstance() 创建该 Class 的初始实例。如果在此过程中（例如 ClassNotFoundException、InstantiationException）引发已检查异常，则该 MBeanServerFactory 将从 RuntimeException 内传播此异常。

每次需要创建新的 MBeanServer 时都会查询 javax.management.builder.initial 系统属性，并加载该属性所指向的类。如果该类与当前的 MBeanServerBuilder 的类不同，则创建一个新的 MBeanServerBuilder。否则，MBeanServerFactory 可能创建一个新的 MBeanServerBuilder 或重用当前的 MBeanServerBuilder。

如果无法加载该属性所指向的类，或者该属性所指向的类不对应于有效的 MBeanServerBuilder 子类，则抛出一个异常，并且在将 javax.management.builder.initial 系统属性重置为有效值之前，不能创建任何 MBeanServer。

出于某种目的，例如添加一个额外的安全层，MBeanServerBuilder 使得包装默认 MBeanServerBuilder 实现所返回的 MBeanServer 成为可能。

从以下版本开始：
1.5

方法摘要
static MBeanServer | createMBeanServer() 返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口。
static MBeanServer | createMBeanServer(String domain) 返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。
static ArrayList<MBeanServer> | findMBeanServer(String agentId) 返回已注册 MBeanServer 对象的列表。
static ClassLoaderRepository | getClassLoaderRepository(MBeanServer server) 返回给定 MBeanServer 使用的 ClassLoaderRepository。
static MBeanServer | newMBeanServer() 返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
static MBeanServer | newMBeanServer(String domain) 返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
static void | releaseMBeanServer(MBeanServer mbeanServer) 移除对已创建 MBeanServer 的内部 MBeanServerFactory 引用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

releaseMBeanServer

public static void releaseMBeanServer(MBeanServer mbeanServer)
移除对已创建 MBeanServer 的内部 MBeanServerFactory 引用。这允许垃圾回收器移除该 MBeanServer 对象。

参数：
mbeanServer - 要移除的 MBeanServer 对象。
抛出：
IllegalArgumentException - 如果未通过某个 createMBeanServer 方法生成 mbeanServer，或者如果已在该 mbeanServer 上调用 releaseMBeanServer。
SecurityException - 如果有 SecurityManager 且调用者的权限不包括或隐含 MBeanServerPermission("releaseMBeanServer")。

createMBeanServer

public static MBeanServer createMBeanServer()

返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口。如果用户指定的域为 null，则将默认域名用作 MBean 的 ObjectName 的域部分。

标准的默认域名是 DefaultDomain。

内部保存该 MBeanServer 引用。这就允许 findMBeanServer 返回对此 MBeanServer 对象的引用。

此方法等效于 createMBeanServer(null)。

返回：
新创建的 MBeanServer。
抛出：
SecurityException - 如果有 SecurityManager 且调用者的权限不包括或隐含 MBeanServerPermission("createMBeanServer")。
JMRuntimeException - 如果属性 javax.management.builder.initial 存在，但是无法通过公共的无参数构造方法实例化它所指定的类；如果已实例化的生成器从其 newMBeanServerDelegate 或 newMBeanServer 方法中返回 null。
ClassCastException - 如果属性 javax.management.builder.initial 存在并且可以被实例化，但是它的分配与 MBeanServerBuilder 不兼容。

createMBeanServer

public static MBeanServer createMBeanServer(String domain)

返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。如果用户指定的域为 null，则将给定的域名用作 MBean 的 ObjectName 的域部分。

内部保存该 MBeanServer 引用。这就允许 findMBeanServer 返回对此 MBeanServer 对象的引用。

参数：
domain - 所创建的 MBeanServer 的默认域名。这是 MBeanServer.getDefaultDomain() 所返回的值。
返回：
新创建的 MBeanServer。
抛出：
SecurityException - 如果有 SecurityManager 且调用者的权限不包括或隐含 MBeanServerPermission("createMBeanServer")。
JMRuntimeException - 如果属性 javax.management.builder.initial 存在，但是无法通过公共的无参数构造方法实例化它所指定的类；如果已实例化的生成器从其 newMBeanServerDelegate 或 newMBeanServer 方法中返回 null。
ClassCastException - 如果属性 javax.management.builder.initial 存在并且可以被实例化，但是它的分配与 MBeanServerBuilder 不兼容。

newMBeanServer

public static MBeanServer newMBeanServer()

返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。如果用户指定的域为 null，则将默认域名用作 MBean 的 ObjectName 的域部分。

标准的默认域名是 DefaultDomain。

不保存引用。findMBeanServer 无法返回对此 MBeanServer 对象的引用，但是没有对该 MBeanServer 的引用时，垃圾回收器能够移除该 MBeanServer 对象。

此方法等效于 newMBeanServer(null)。

返回：
新创建的 MBeanServer。
抛出：
SecurityException - 如果有 SecurityManager 且调用者的权限不包括或隐含 MBeanServerPermission("newMBeanServer")。
JMRuntimeException - 如果属性 javax.management.builder.initial 存在，但是无法通过公共的无参数构造方法实例化它所指定的类；如果已实例化的生成器从其 newMBeanServerDelegate 或 newMBeanServer 方法中返回 null。
ClassCastException - 如果属性 javax.management.builder.initial 存在并且可以被实例化，但是它的分配与 MBeanServerBuilder 不兼容。

newMBeanServer

public static MBeanServer newMBeanServer(String domain)

返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。如果用户指定的域为 null，则将给定的域名用作 MBean 的 ObjectName 的域部分。

不保存引用。findMBeanServer 无法返回对此 MBeanServer 对象的引用，但是没有对该 MBeanServer 的引用时，垃圾回收器能够移除该 MBeanServer 对象。

参数：
domain - 所创建的 MBeanServer 的默认域名。这是 MBeanServer.getDefaultDomain() 将要返回的值。
返回：
新创建的 MBeanServer。
抛出：
SecurityException - 如果有 SecurityManager 且调用者的权限不包括或隐含 MBeanServerPermission("newMBeanServer")。
JMRuntimeException - 如果属性 javax.management.builder.initial 存在，但是无法通过公共的无参数构造方法实例化它所指定的类；如果已实例化的生成器从其 newMBeanServerDelegate 或 newMBeanServer 方法中返回 null。
ClassCastException - 如果属性 javax.management.builder.initial 存在并且可以被实例化，但是它的分配与 MBeanServerBuilder 不兼容。

findMBeanServer

public static ArrayList<MBeanServer> findMBeanServer(String agentId)

返回已注册 MBeanServer 对象的列表。已注册的 MBeanServer 对象是通过某个 createMBeanServer 方法创建并且随后未使用 releaseMBeanServer 释放的 MBeanServer。

参数：
agentId - 要检索的 MBeanServer 的代理标识符。如果此参数为 null，则返回此 JVM 中的所有已注册 MBeanServer。否则只返回其 id 等于 agentId 的 MBeanServer。MBeanServer 的 id 是其委托 MBean 的 MBeanServerId 属性。
返回：
MBeanServer 对象的列表。
抛出：
SecurityException - 如果有 SecurityManager 且调用者的权限不包括或隐含 MBeanServerPermission("findMBeanServer")。

getClassLoaderRepository

public static ClassLoaderRepository getClassLoaderRepository(MBeanServer server)
返回给定 MBeanServer 使用的 ClassLoaderRepository。此方法等效于 server.getClassLoaderRepository()。

参数：
server - 要检查的 MBeanServer。从 JMX 1.2 开始，如果 server 为 null，则结果是 NullPointerException。此行为与 JMX 1.1 中相应实现的行为不同 - 已不再使用 null 值。
返回：
给定 MBeanServer 使用的 ClassLoaderRepository。
抛出：
SecurityException - 如果有 SecurityManager 且调用者的权限不包括或隐含 MBeanPermission("getClassLoaderRepository")。
NullPointerException - 如果 server 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerInvocationHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanServerInvocationHandler

java.lang.Object
    继承者  javax.management.MBeanServerInvocationHandler
所有已实现的接口：
InvocationHandler
public class MBeanServerInvocationHandler
extends Object
implements InvocationHandler

通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。

在给出 MBeanServerConnection、MBean 服务器中某个 MBean 的 ObjectName，以及一个 Java 接口 Intf（它使用用于 Standard MBean 或 MXBean 的模式描述 MBean 的管理接口）的情况下，可以使用此类构造 MBean 的代理。该代理实现了接口 Intf，这样就可以通过 MBean 服务器向 MBean 转发其所有方法。

如果将 InvocationHandler 用于 MXBean，那么方法的参数会从 MXBean 接口中声明的类型转换为相应的映射类型，并将返回值从映射类型转换为声明的类型。例如，在使用了方法
public List<String> reverse(List<String> list);
并且已经知道 List<String> 的映射类型为 String[] 的情况下，调用 proxy.reverse(someList) 会将 someList 从 List<String> 转换为 String[]，调用 MBean 操作 reverse，然后将返回的 String[] 转换为 List<String>。

当使用此调用处理程序对代理调用方法 Object.toString()、Object.hashCode() 和 Object.equals(Object) 时，仅当这些方法出现在一个代理接口中时，才将它们转发到 MBean 服务器。对于使用 JMX.newMBeanProxy 或 JMX.newMXBeanProxy 创建的代理而言，这意味着这些方法必须出现在 Standard MBean 或 MXBean 接口中。否则，这些方法具有以下行为：

  • toString() 返回该代理的字符串表示形式
  • hashCode() 返回代理的哈希码，因此两个相等的代理具有相同的哈希码
  • 当且仅当 Object 参数的代理类型与此代理相同时（带有具有相同 MBeanServerConnection 和 ObjectName 的 MBeanServerInvocationHandler），equals(Object) 才返回 true；如果其中一个 MBeanServerInvocationHandler 是使用 Class 参数构造的，则要 equals 返回 true，另一个 MBeanServerInvocationHandler 必须是使用相同的 Class 参数构造的。

从以下版本开始：
1.5

构造方法摘要
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName, boolean isMXBean)
可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。
方法摘要
 MBeanServerConnection getMBeanServerConnection()
MBean 服务器连接，使用此处理程序的代理的方法是通过此连接转发的。
 ObjectName getObjectName()
MBean 服务器中 MBean 的名称，一些方法将转发到该 MBean。
 Object invoke(Object proxy, Method method, Object[] args)
在代理实例上处理方法调用并返回结果。
 boolean isMXBean()
如果为 true，则该代理适用于 MXBean，并将适当映射应用于方法参数和返回值。
static
<T> T
newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MBeanServerInvocationHandler

public MBeanServerInvocationHandler(MBeanServerConnection connection,
                                    ObjectName objectName)

通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。此构造方法可能被调用，而不是依赖于 JMX.newMBeanProxy，例如在需要为 Proxy.newProxyInstance 提供一个不同的 ClassLoader 的情况下。

此构造方法不适合 MXBean。为此请使用 MBeanServerInvocationHandler(MBeanServerConnection, ObjectName, boolean)。此构造方法等效于 new MBeanServerInvocationHandler(connection, objectName, false)。

参数：
connection - MBean 服务器连接，通过此连接转发所有使用此处理程序的代理方法。
objectName - MBean 服务器中的 MBean 名称，一些方法将转发到该 MBean。

MBeanServerInvocationHandler

public MBeanServerInvocationHandler(MBeanServerConnection connection,
                                    ObjectName objectName,
                                    boolean isMXBean)

可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。此构造方法可能被调用，而不是依赖于 JMX.newMXBeanProxy，例如在需要为 Proxy.newProxyInstance 提供一个不同的 ClassLoader 的情况下。

参数：
connection - MBean 服务器连接，通过此连接转发所有使用此处理程序的代理方法。
objectName - MBean 服务器中的 MBean 的名称，一些方法将转发到该 MBean。
isMXBean - 如果为 true，则代理适用于 MXBean，并且将适当映射应用于方法参数和返回值。
从以下版本开始：
1.6
方法详细信息

getMBeanServerConnection

public MBeanServerConnection getMBeanServerConnection()

MBean 服务器连接，使用此处理程序的代理的方法是通过此连接转发的。

返回：
MBean 服务器连接。
从以下版本开始：
1.6

getObjectName

public ObjectName getObjectName()

MBean 服务器中 MBean 的名称，一些方法将转发到该 MBean。

返回：
对象名。
从以下版本开始：
1.6

isMXBean

public boolean isMXBean()

如果为 true，则该代理适用于 MXBean，并将适当映射应用于方法参数和返回值。

返回：
对该代理是否适用于 MXBean 的判断。
从以下版本开始：
1.6

newProxyInstance

public static <T> T newProxyInstance(MBeanServerConnection connection,
                                     ObjectName objectName,
                                     Class<T> interfaceClass,
                                     boolean notificationBroadcaster)

返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。从 1.6 版本开始，方法 JMX.newMBeanProxy(MBeanServerConnection, ObjectName, Class) 和 JMX.newMBeanProxy(MBeanServerConnection, ObjectName, Class, boolean) 优先于此方法。

此方法等效于 Proxy.newProxyInstance (interfaceClass.getClassLoader(), interfaces, handler)。其中 handler 是 new MBeanServerInvocationHandler(connection, objectName) 的结果，而 interfaces 是一个数组，如果 notificationBroadcaster 为 false，则该数组有一个元素，如果为 true，则该数组有两个元素。interfaces 的第一个元素是 interfaceClass，第二个（如果存在）是 NotificationEmitter.class。

类型参数：
T - 允许编译器知道如果 interfaceClass 参数为 MyMBean.class 则返回类型为 MyMBean。
参数：
connection - 要转发到的目标 MBean 服务器。
objectName - connection 中的 MBean 的名称，各个方法将转发到该 MBean。
interfaceClass - MBean 输出的管理接口，也由返回的代理来实现。
notificationBroadcaster - 通过 connection 转发所返回代理的方法，使该代理实现 NotificationEmitter。在该代理上调用 NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object) 将导致对 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 的调用，对于 NotificationBroadcaster 和 NotificationEmitter 的其他方法也是如此。
返回：
新的代理实例。
另请参见：
JMX.newMBeanProxy(MBeanServerConnection, ObjectName, Class)

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
从接口 InvocationHandler 复制的描述
在代理实例上处理方法调用并返回结果。在与方法关联的代理实例上调用方法时，将在调用处理程序上调用此方法。

指定者：
接口 InvocationHandler 中的 invoke
参数：
proxy - 在其上调用方法的代理实例
method - 对应于在代理实例上调用的接口方法的 Method 实例。Method 对象的声明类将是在其中声明方法的接口，该接口可以是代理类赖以继承方法的代理接口的超接口。
args - 包含传入代理实例上方法调用的参数值的对象数组，如果接口方法不使用参数，则为 null。基本类型的参数被包装在适当基本包装器类（如 java.lang.Integer 或 java.lang.Boolean）的实例中。
返回：
从代理实例的方法调用返回的值。如果接口方法的声明返回类型是基本类型，则此方法返回的值一定是相应基本包装对象类的实例；否则，它一定是可分配到声明返回类型的类型。如果此方法返回的值为 null 并且接口方法的返回类型是基本类型，则代理实例上的方法调用将抛出 NullPointerException。否则，如果此方法返回的值与上述接口方法的声明返回类型不兼容，则代理实例上的方法调用将抛出 ClassCastException。
抛出：
Throwable - 从代理实例上的方法调用抛出的异常。该异常的类型必须可以分配到在接口方法的 throws 子句中声明的任一异常类型或未经检查的异常类型 java.lang.RuntimeException 或 java.lang.Error。如果此方法抛出经过检查的异常，该异常不可分配到在接口方法的 throws 子句中声明的任一异常类型，代理实例的方法调用将抛出包含此方法曾抛出的异常的 UndeclaredThrowableException。
另请参见：
UndeclaredThrowableException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerNotification (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanServerNotification

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.management.Notification
            继承者  javax.management.MBeanServerNotification
所有已实现的接口：
Serializable
public class MBeanServerNotification
extends Notification

表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。MBean 服务器发出下列类型的通知：MBean 注册、MBean 注销。

要想接收 MBeanServerNotifications，需要声明为表示 MBeanServer 的 javax.management.MBeanServerDelegate MBean 的侦听器。MBeanServerDelegate 的 ObjectName 是：JMImplementation:type=MBeanServerDelegate。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static String | REGISTRATION_NOTIFICATION 表示已注册该 MBean 的通知类型。
static String | UNREGISTRATION_NOTIFICATION 表示已注销该 MBean 的通知类型。
从类 javax.management.Notification 继承的字段
source
构造方法摘要
MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。
方法摘要
 ObjectName getMBeanName()
返回导致该通知的 MBean 的对象名。
从类 javax.management.Notification 继承的方法
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

REGISTRATION_NOTIFICATION

public static final String REGISTRATION_NOTIFICATION
表示已注册该 MBean 的通知类型。其值是 "JMX.mbean.registered"。

另请参见：
常量字段值

UNREGISTRATION_NOTIFICATION

public static final String UNREGISTRATION_NOTIFICATION
表示已注销该 MBean 的通知类型。其值是 "JMX.mbean.unregistered"。

另请参见：
常量字段值
构造方法详细信息

MBeanServerNotification

public MBeanServerNotification(String type,
                               Object source,
                               long sequenceNumber,
                               ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。

参数：
type - 表示通知类型的字符串。设置为下列某个值：REGISTRATION_NOTIFICATION, UNREGISTRATION_NOTIFICATION。
source - 负责转发 MBean 服务器通知的 MBeanServerNotification 对象。
sequenceNumber - 用于排序已接收通知的序列号。
objectName - 导致该通知的 MBean 的对象名。
方法详细信息

getMBeanName

public ObjectName getMBeanName()
返回导致该通知的 MBean 的对象名。

返回：
导致该通知的 MBean 的对象名。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanServerPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.management.MBeanServerPermission
所有已实现的接口：
Serializable, Guard
public class MBeanServerPermission
extends BasicPermission

执行与 MBeanServer 关联的操作的 Permission。权限名称 指定了所请求的操作或该权限允许的操作。对于某项目已授予的权限，该名称可以是 *，表示允许下面指定的所有 MBeanServer 操作。否则，对于授予的权限或请求的权限，它必须是下列之一：

createMBeanServer
使用方法 MBeanServerFactory.createMBeanServer() 或 MBeanServerFactory.createMBeanServer(java.lang.String) 创建新的 MBeanServer 对象。
findMBeanServer
使用方法 MBeanServerFactory.findMBeanServer(java.lang.String) 查找此 JVM 中具有给定名称的 MBeanServer 或所有 MBeanServer。
newMBeanServer
使用方法 MBeanServerFactory.newMBeanServer() 或 MBeanServerFactory.newMBeanServer(java.lang.String) 创建新的 MBeanServer 对象，并且不保持对该对象的引用。
releaseMBeanServer
使用方法 MBeanServerFactory.releaseMBeanServer(javax.management.MBeanServer) 移除 MBeanServerFactory 对 MBeanServer 的引用。
权限名称 也可表示一个或多个逗号分隔的操作列表。该名称 的开始和结束以及逗号前后都允许使用空格。

MBeanServerPermission("createMBeanServer") 隐含 MBeanServerPermission("newMBeanServer")。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MBeanServerPermission(String name)
创建具有给定名称的新 MBeanServerPermission。
MBeanServerPermission(String name, String actions)
创建具有给定名称的新 MBeanServerPermission。
方法摘要
boolean | equals(Object obj) 检查两个 MBeanServerPermission 对象的相等性。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此 MBeanServerPermission 对象是否“隐含”指定的权限。
PermissionCollection | newPermissionCollection() 用于存储 BasicPermission 对象的新 PermissionCollection 对象。
从类 java.security.BasicPermission 继承的方法
getActions
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanServerPermission

public MBeanServerPermission(String name)

创建具有给定名称的新 MBeanServerPermission。

此构造方法等效于 MBeanServerPermission(name,null)。

参数：
name - 所授予权限的名称。它必须服从 MBeanServerPermission 类的描述中所声明的约束。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 不是 * 或者某个允许的名称或逗号分隔的允许名称列表。

MBeanServerPermission

public MBeanServerPermission(String name,
                             String actions)

创建具有给定名称的新 MBeanServerPermission。

参数：
name - 所授予权限的名称。它必须服从 MBeanServerPermission 类的描述中所声明的约束。
actions - 关联的操作。目前未使用此参数，必须为 null 或空字符串。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 不是 * 或某个允许的名称或逗号分隔的允许名称列表，或者如果 actions 是非 null 非空的字符串。
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空或者参数无效。
方法详细信息

hashCode

public int hashCode()
从类 BasicPermission 复制的描述
返回此对象的哈希码值。所用的哈希码是名称的哈希码，也就是 getName().hashCode()，其中 getName 来自 Permission 超类。

覆盖：
类 BasicPermission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

implies

public boolean implies(Permission p)

检查此 MBeanServerPermission 对象是否“隐含”指定的权限。

更确切地说，如果此方法满足以下条件，则返回 true：

  • p 是一个 MBeanServerPermission 实例，
  • p 的目标名是此对象目标名的一个子集

createMBeanServer 权限隐含 newMBeanServer 权限。

覆盖：
类 BasicPermission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果此对象隐含指定的权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 MBeanServerPermission 对象的相等性。检查该 obj 是否为 MBeanServerPermission 且表示与此对象相同的可允许操作列表。

覆盖：
类 BasicPermission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果两个对象是相等的，返回 true。
另请参见：
Object.hashCode(), Hashtable

newPermissionCollection

public PermissionCollection newPermissionCollection()
从类 BasicPermission 复制的描述
用于存储 BasicPermission 对象的新 PermissionCollection 对象。

BasicPermissionCollection 存储 BasicPermission 权限的集合。

BasicPermission 对象必须以允许将它们按任意顺序插入的方式来存储，但同时也允许以有效（并一致）的方式实现 PermissionCollection 的 implies 方法。

覆盖：
类 BasicPermission 中的 newPermissionCollection
返回：
适合存储 BasicPermissions 的新 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanTrustPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 MBeanTrustPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.management.MBeanTrustPermission
所有已实现的接口：
Serializable, Guard
public class MBeanTrustPermission
extends BasicPermission

此权限表示“信任”签名者或代码基。

MBeanTrustPermission 包含目标名但不包含操作列表。为此权限定义了单个目标名 "register"。还允许目标 "*"，这允许 "register" 和以后可能定义的所有目标。要允许策略对象创建策略文件中指定的权限，只允许为操作指定 null 值或空字符串。

如果签名者或代码源被授予此权限，则将其认为是 MBean 的可信任源。只有来自可信任源的 MBean 才能在 MBeanServer 中注册。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MBeanTrustPermission(String name)
创建具有给定名称的新 MBeanTrustPermission。
MBeanTrustPermission(String name, String actions)
创建具有给定名称的新 MBeanTrustPermission。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MBeanTrustPermission

public MBeanTrustPermission(String name)

创建具有给定名称的新 MBeanTrustPermission。

此构造方法等效于 MBeanTrustPermission(name,null)。

参数：
name - 权限名称。对于此权限而言，它必须是 "register" 或 "*"。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 不是 "register" 或 "*"。

MBeanTrustPermission

public MBeanTrustPermission(String name,
                            String actions)

创建具有给定名称的新 MBeanTrustPermission。

参数：
name - 权限名称。对于此权限而言，它必须是 "register" 或 "*"。
actions - 该权限的操作。它必须为 null 或 ""。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 不是 "register" 也不是 "*"；如果 actions 是非 null 非空的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MXBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素

javax.management
注释类型 MXBean

@Documented
@Retention(value=RUNTIME)
@Target(value=TYPE)
public @interface MXBean

显式地标记某一接口是否为 MXBean 接口的注释。默认情况下，如果接口的名称以 MXBean 结尾（如 SomethingMXBean），则该接口为 MXBean 接口。以下接口是 MXBean 接口：

    public interface WhatsitMXBean {}

    @MXBean
    public interface Whatsit1Interface {}

    @MXBean(true)
    public interface Whatsit2Interface {}

以下接口不是 MXBean 接口：

    public interface Whatsit3Interface{}

    @MXBean(false)
    public interface MisleadingMXBean {}

MXBean 规范

MXBean 概念提供了一种对 MBean 进行编码的简单方式，这种方式只引用一组预定义的类型，这些类型由 javax.management.openmbean 定义。使用这种方式可以确保任何客户端（包括远程客户端）都可以使用您的 MBean，无需客户端具有访问表示 MBean 类型的特定于模型的类 的权限。

与 Standard MBean 概念相比，这些概念更容易理解一些。以下是将管理对象表示为 Standard MBean 和 MXBean 的方式：

Standard MBean MXBean
public interface MemoryPoolMBean {
String getName();
MemoryUsage getUsage();
    // ...
}

public interface MemoryPoolMXBean {
String getName();
MemoryUsage getUsage();
    // ...
}

如您所见，这些定义非常相似。唯一的不同是命名接口的约定将使用 MXBean 的 Something MXBean，而不是 Standard MBean 的 Something MBean。

在此管理对象中，有一种类型为 MemoryUsage 的称作 Usage 的属性。此类属性的要点是，它给出了一组数据项的统一快照。例如，它可能包括内存池中目前已使用的内存量，以及内存池的当前最大量。如果这些是单独的项（通过单独的 getAttribute 调用获得），那么我们可以在不同时间查看不一致的值。我们可能获得大于 max 值的 used 值。

因此，可以按如下形式定义 MemoryUsage：

Standard MBean MXBean
public class MemoryUsage implements Serializable {
// standard JavaBean conventions with getters

public MemoryUsage(long init, long used,
long committed, long max) {...}
long getInit() {...}
long getUsed() {...}
long getCommitted() {...}
long getMax() {...}
}

public class MemoryUsage {
// standard JavaBean conventions with getters
@ConstructorProperties({"init", "used", "committed", "max"})
public MemoryUsage(long init, long used,
long committed, long max) {...}
long getInit() {...}
long getUsed() {...}
long getCommitted() {...}
long getMax() {...}
}

两种情况下的定义是相同的（使用 MXBean 的情况除外），不再需要将 MemoryUsage 标记为 Serializable（尽管可以这样做）。另一方面，我们添加了一个 @ConstructorProperties 注释，以便将构造方法参数链接到相应的获取方法。下面将看到更多这方面的信息。

MemoryUsage 是一个特定于模型的类。使用 Standard MBean 时，如果 MemoryUsage 类对于 MBean Server 的客户端为未知类，那么该客户端将无法访问 Usage 属性。假定该客户端是一个基于 JMX 技术的通用控制台。那么必须使用该控制台可以连接到的每个应用程序的特定于模型的类来配置此控制台。对于未用 Java 语言编写的客户端，问题甚至更为严重。此时可能无法通知客户端 MemoryUsage 是什么样的。

这就是 MXBean 与 Standard MBean 的不同之处。尽管我们以几乎完全相同的方式定义了管理接口，但 MXBean 框架会从 Java 平台将特定于模型的类转换 为标准类。使用数组以及标准 javax.management.openmbean 包中的 CompositeData 和 TabularData 类，就有可能只使用标准类来构建任意复杂度的数据结构。

如果比较两种模型的客户端的外观，这将变得更清楚：

Standard MBean MXBean
String name = (String)
mbeanServer.getAttribute(objectName, "Name");
MemoryUsage usage = (MemoryUsage)
mbeanServer.getAttribute(objectName, "Usage");
long used = usage.getUsed();

String name = (String)
mbeanServer.getAttribute(objectName, "Name");
CompositeData usage = (CompositeData)
mbeanServer.getAttribute(objectName, "Usage");
long used = (Long) usage.get("used");

对于具有简单类型（如 String）的属性，代码是相同的。但对于具有复杂类型的属性，Standard MBean 代码要求客户端知道特定于模型的类 MemoryUsage，而 MXBean 代码则不需要任何非标准类。

此处显示的客户端代码对于 MXBean 客户端而言更加复杂。但是，如果客户端确实知道该模型、此处的接口 MemoryPoolMXBean 和 MemoryUsage 类，则该客户端可以构造一个代理。在预先知道模型的情况下，建议您使用这种方式与管理对象进行交互，不必考虑正在使用的是 Standard MBean 还是 MXBean：

Standard MBean MXBean
MemoryPoolMBean proxy =
JMX.newMBeanProxy(
mbeanServer,
objectName,
MemoryPoolMBean.class);
String name = proxy.getName();
MemoryUsage usage = proxy.getUsage();
long used = usage.getUsed();

MemoryPoolMXBean proxy =
JMX.newMXBeanProxy(
mbeanServer,
objectName,
MemoryPoolMXBean.class);
String name = proxy.getName();
MemoryUsage usage = proxy.getUsage();
long used = usage.getUsed();

对于 Standard MBean 和 MXBean 而言，实现 MemoryPool 对象的方式是类似的。

Standard MBean MXBean
public class MemoryPool
implements MemoryPoolMBean {
public String getName() {...}
public MemoryUsage getUsage() {...}
    // ...
}

public class MemoryPool
implements MemoryPoolMXBean {
public String getName() {...}
public MemoryUsage getUsage() {...}
    // ...
}

在两种情况下，在 MBean Server 中注册 MBean 的方式是相同的：

Standard MBean MXBean
{
MemoryPoolMBean pool = new MemoryPool();
mbeanServer.registerMBean(pool, objectName);
}

{
MemoryPoolMXBean pool = new MemoryPool();
mbeanServer.registerMBean(pool, objectName);
}

MXBean 的定义

MXBean 是一种 MBean。MXBean 对象可以直接在 MBean Server 中注册，也可以用作在 MBean Server 中注册的 StandardMBean 和结果 MBean 的参数。

当使用 MBeanServer 接口的 registerMBean 或 createMBean 方法在 MBean Server 中注册某个对象时，要检查该对象的类来确定 MBean 的类型：

  • 如果该类实现了接口 DynamicMBean，则 MBean 是一个 Dynamic MBean。注意，因为 StandardMBean 类实现了此接口，所以这种情况可应用于使用 StandardMBean 类创建的 Standard MBean 或 MXBean。
  • 否则，如果该类与 Standard MBean 命名约定匹配，则 MBean 是一个 Standard MBean。
  • 否则它可能是一个 MXBean。检查由对象实现的那组接口，以获得具有以下特性的接口：
    • 具有一个类名称 SMXBean（其中的 S 为非空字符串），且没有注释 @MXBean(false)；
    • 具有注释 @MXBean(true) 或只有 @MXBean。
    如果确实有这样一个接口，或者如果有一个作为其他所有接口的子接口的接口，则该对象是一个 MXBean。相关接口是 MXBean 接口。在上述示例中，MXBean 接口是 MemoryPoolMXBean。
  • 如果这些条件都不满足，则 MBean 无效，并且试图对其进行注册将生成 NotCompliantMBeanException。

作为参数出现的每个 Java 类型或 MXBean 接口中某一方法的返回类型在使用下面的规则进行转换时，必须是可转换的。此外，参数必须是可重新构造的，正如下面所定义的那样。

尝试构造不符合上述规则的 MXBean 将产生一个异常。

命名约定

与在 Standard MBean 中一样，相同的命名约定可应用于 MXBean 中的各种方法：

  1. 方法 T getN() 明确说明存在一个名为 N 的可读属性，该方法中的 T 是一种 Java 类型（不可以为 void），N 为非空字符串。该属性的 Java 类型和 Open 类型是根据下面的映射规则确定的。在查找获取方法时，将忽略从 Object 继承的方法 final Class getClass()。
  2. 方法 boolean isN() 明确说明存在一个名为 N 的可读属性，且该属性的 Java 类型为 boolean，Open 类型为 SimpleType.Boolean。
  3. 方法 void setN(T x) 明确说明存在一个名为 N 的可写属性。该属性的 Java 类型和 Open 类型是根据下面的映射规则确定的。（当然，参数的名称 x 无关紧要。）
  4. 其他每个方法都明确说明存在一个名称与该方法相同的操作。返回值和每个参数的 Java 类型和 Open 类型是根据下面的映射规则确定的。

getN 和 isN 的规则共同定义了 getter 的概念。setN 的规则定义了 setter 的概念。

两个获取方法具有相同名称或者两个设置方法具有相同名称是一种错误。如果一个获取方法和一个设置方法具有相同的名称，则二者的类型 T 必须相同。在这种情况下，属性为 read/write。如果只有一个获取方法或只有一个设置方法，则属性分别为 read-only 或 write-only。

类型映射规则

MXBean 是一种 Open MBean，由 javax.management.openmbean 包定义。这意味着属性类型、操作参数和操作返回值都必须是可以使用 Open Types（即 OpenType 的四个标准子类）描述的。MXBean 通过将 Java 类型映射为 Open Types 来实现此操作。

对于每个 Java 类型 J，MXBean 映射关系根据以下信息来描述：

  • 相应的 Open Type，即 opentype(J)。这是 OpenType 的子类的一个实例。
  • 映射的 Java 类型（opendata(J)）对于任何给定的 opentype(J) 都是相同的。这是一个 Java 类。
  • 将值从类型 J 转换为类型 opendata(J) 的方式。
  • 将值从类型 opendata(J) 转换为类型 J 的方式（如果可以转换）。

例如，对于 Java 类型 List<String>：

  • Open Type opentype(List<String>) 是 ArrayType (1, SimpleType.STRING )，表示 String 的一个一维数组。
  • 映射的 Java 类型 opendata(List<String>) 是 String[]。
  • 使用 List.toArray(new String[0]) 可以将 List<String> 转换为 String[]。
  • 使用 Arrays.asList 可以将 String[] 转换为 List<String>。

如果没有用来从 J 中派生 opentype(J) 的映射规则，则 J 不能是 MXBean 接口中方法参数或返回值的类型。

如果有办法将 opendata(J) 转换回 J，则我们说 J 是可重新构造的。MXBean 接口中的所有方法参数必须是可重新构造的，这是因为当 MXBean 框架调用某一方法时，它需要将这些参数从 opendata(J) 转换为 J。在由 JMX.newMXBeanProxy 生成的代理中，MXBean 接口中方法的返回值必须是可重新构造的。

所有 Java 类型和 Open Types 都允许使用 null 值，不可能使用 null 值的一些基本 Java 类型除外。当从类型 J 转换为类型 opendata(J) 或从类型 opendata(J) 转换为类型 J 时，null 值被映射为一个 null 值。

下表总结了类型映射规则。

Java 类型 J opentype(J) opendata(J)
int、boolean 等
（8 个基本 Java 类型） 		SimpleType.INTEGER、
SimpleType.BOOLEAN 等 		Integer、Boolean 等
（相应的 boxed 类型）
Integer、ObjectName 等
（SimpleType 包含的类型） 		相应的 SimpleType J，相同类型
int[] 等
（具有
基本元素类型的一维数组） 		ArrayType.getPrimitiveArrayType(int[].class) 等 J，相同类型
E[]
（具有非基本元素类型 E 的数组；这包括 int[][]，其中 E 为 int[]） 		ArrayType.getArrayType(opentype(E)) opendata(E)[]
List&lt;E&gt;
Set&lt;E&gt;
SortedSet&lt;E&gt;（参见以下内容） 		与 E[] 相同 与 E[] 相同
枚举 E
（在 Java 中被声明为 enum E {...}） 		SimpleType.STRING String
Map&lt;K,V&gt;
SortedMap&lt;K,V&gt; 		TabularType
（参见以下内容） 		TabularData
（参见以下内容）
MXBean 接口 SimpleType.OBJECTNAME
（参见以下内容） 		ObjectName
（参见以下内容）
任何其他类型 CompositeType，如果可能
（参见以下内容） 		CompositeData

以下几节将详细解释这些规则。

基本类型的映射

8 种基本 Java 类型（boolean、byte、short、int、long、float、double、char）都可映射到 java.lang 中的相应 boxed 类型，即 Boolean、Byte 等。Open Type 是相应的 SimpleType。因此，opentype(long) 是 SimpleType.LONG，opendata(long) 是 java.lang.Long。

诸如 long[] 之类的基本类型的数组可以直接表示为一种 Open Type。因此，openType(long[]) 是 ArrayType.getPrimitiveArrayType(long[].class)，opendata(long[]) 是 long[]。

实际上，普通 int 和 Integer 等之间的差异不会显现出来，因为 JMX API 中的操作总是在 Java 对象上进行，而不是在基本类型上进行。但是，数组中确实 存在这种差异。

集合的映射（List&lt;E&gt; 等）

List&lt;E&gt; 或 Set&lt;E&gt;（如 List<String> 或 Set<ObjectName>）以相同方式映射为相同元素类型的数组，如 String[] 或 ObjectName[]。

也可以用相同方式将 SortedSet&lt;E&gt; 映射为 E[]，但是只有在 E 是实现 Comparable 的类或接口时，它才是可转换的。因此，SortedSet<String> 或 SortedSet<Integer> 是可转换的，但 SortedSet<int[]> 或 SortedSet<List<String>&gt; 是不可转换的。如果 SortedSet 实例包含一个非 null comparator()，那么对该实例的转换将失败，并抛出 IllegalArgumentException。

List&lt;E&gt; 被重新构造为一个 java.util.ArrayList&lt;E&gt;；Set&lt;E&gt; 被重新构造为一个 java.util.HashSet&lt;E&gt;；SortedSet&lt;E&gt; 被重新构造为一个 java.util.TreeSet&lt;E&gt;。

映射的映射关系（Map&lt;K,V&gt; 等）

Map&lt;K,V&gt; 或 SortedMap&lt;K,V&gt;（如 Map<String,ObjectName>）包含 Open Type TabularType，并且可映射为一个 TabularData。TabularType 有两个称为 key 和 value 的项。key 的 Open Type 为 opentype(K)，value 的 Open Type 为 opentype(V)。TabularType 的索引是单个项 key。

例如，用于 Map<String,ObjectName> 的 TabularType 可以使用如下代码构造：

String typeName =
"java.util.Map<java.lang.String, javax.management.ObjectName>";
String[] keyValue =
new String[] {"key", "value"};
OpenType[] openTypes =
new OpenType[] {SimpleType.STRING, SimpleType.OBJECTNAME};
CompositeType rowType =
new CompositeType(typeName, typeName, keyValue, keyValue, openTypes);
TabularType tabularType =
new TabularType(typeName, typeName, rowType, new String[] {"key"});

此处的 typeName 由下面将详细介绍的类型名称规则确定。

SortedMap&lt;K,V&gt; 以相同的方式映射，但只有在 K 是实现 Comparable 的类或接口时才是可转换的。因此，SortedMap<String,int[]> 是可转换的，但 SortedMap<int[],String> 是不可转换的。如果 SortedMap 实例包含一个非 null comparator()，那么该实例的转换将失败，并将抛出 IllegalArgumentException。

Map&lt;K,V&gt; 被重新构造为一个 java.util.HashMap&lt;K,V&gt;；SortedMap&lt;K,V&gt; 被重新构造为一个 java.util.TreeMap&lt;K,V&gt;。

TabularData 是一个接口。用于将 Map&lt;K,V&gt; 表示为 Open Data 的具体类是 TabularDataSupport，或是实现作为 TabularDataSupport 序列化的 TabularData 的另一个类。

MXBean 接口的映射

MXBean 接口（或 MXBean 接口中引用的类型）可以引用另一个 MXBean 接口 J。这时 opentype(J) 是 SimpleType.OBJECTNAME，opendata(J) 是 ObjectName。

例如，假设您有两个如下所示的 MXBean 接口：

public interface ProductMXBean {
public ModuleMXBean[] getModules();
}

public interface ModuleMXBean {
public ProductMXBean getProduct();
}

实现 ModuleMXBean 接口的对象从其 getProduct 方法返回一个实现 ProductMXBean 接口的对象。ModuleMXBean 对象和返回的 ProductMXBean 对象都必须注册为相同 MBean Server 中的 MXBean。

方法 ModuleMXBean.getProduct() 定义了一个称为 Product 的属性。此属性的 Open Type 为 SimpleType.OBJECTNAME，并且相应的 ObjectName 值将是所引用的 ProductMXBean 在 MBean Server 中注册的名称。

如果为 ModuleMXBean 构造一个 MXBean 代理，并调用其 getProduct() 方法，则该代理将通过构造另一个 MXBean 代理将 ObjectName 映射回 ProductMXBean。更正式地说，当使用 JMX.newMXBeanProxy(mbeanServerConnection, objectNameX, interfaceX) 构造一个代理需要将 objectNameY 映射回 interfaceY（另一个 MXBean 接口）时，可以使用 JMX.newMXBeanProxy(mbeanServerConnection, objectNameY, interfaceY) 来完成此操作。该实现可以返回一个以前通过使用相同参数调用 JMX.newMXBeanProxy 创建的代理，或创建一个新代理。

通过对 ModuleMXBean 接口进行以下更改来解释反向映射：

public interface ModuleMXBean {
public ProductMXBean getProduct();
public void setProduct(ProductMXBean c);
}

setProduct 方法的存在现在意味着 Product 属性为 read/write。与以前一样，该属性的值是一个 ObjectName。设置属性时，必须将 ObjectName 转换成 setProduct 方法所需要的 ProductMXBean 对象。此对象将是相同 MBean Server 中给定 ObjectName 的 MXBean 代理。

如果为 ModuleMXBean 构造一个 MXBean 代理并调用其 setProduct 方法，则该代理会将其 ProductMXBean 参数映射回 ObjectName。只有在该参数实际上是另一代理时，才能如此操作，这也可用于相同 MBeanServerConnection 中的 ProductMXBean。可以从另一代理（如返回 ProductMXBean 的代理的 ModuleMXBean.getProduct()）返回代理；或由 JMX.newMXBeanProxy 创建代理；或使用带有调用处理程序的 Proxy 创建，该调用处理程序是 MBeanServerInvocationHandler 或一个子类。

如果相同的 MXBean 在两个不同的 ObjectName 下注册，那么对哪个 MXBean 进行引用将是不明确的。因此，如果某个 MXBean 对象已经在 MBean Server 中注册并且尝试在相同 MBean Server 的另一名称下对其进行注册，结果将是抛出 InstanceAlreadyExistsException。通常不鼓励在多个名称下注册同一 MBean 对象，因为它显然不适合那些是 NotificationBroadcaster 的 MBean。

其他类型的映射

如果给定的 Java 类或接口 J 与上述表中的其他规则不匹配，则 MXBean 框架会尝试按照以下方式将其映射到 CompositeType。此 CompositeType 的类型名称是根据以下类型名称规则确定的。

使用上述约定检查获取方法的类。（Getter 必须是公共实例方法。）如果没有获取方法，或任何获取方法都有一个不可转换的类型，则 J 是不可转换的。

如果至少有一个获取方法并且每个获取方法都有一个可转换的类型，则 opentype(J) 是一个 CompositeType，它对于每个获取方法都有一个项。如果获取方法为

T getName()
则 CompositeType 中的项被称为 name，且类型为 opentype(T)。例如，如果该项为
String getOwner()
则该项被称为 owner，且 Open Type 为 SimpleType.STRING。如果该获取方法为
boolean isName()
则 CompositeType 中的项被称为 name，且类型为 SimpleType.BOOLEAN。

注意，第一个字符（或代码点）要转换为小写。这遵守 Java Bean 约定，由于历史原因，该约定与 Standard MBean 约定不同。在 Standard MBean 或 MXBean 接口中，方法 getOwner 定义了名为 Owner 的属性，而在 Java Bean 或映射的 CompositeType 中，方法 getOwner 定义了名为 owner 的属性或项。

如果两个方法生成了相同的项名称（如 getOwner 和 isOwner，或 getOwner 和 getowner），则该类型是不可转换的。

当 Open Type 为 CompositeType 时，相应的映射 Java 类型 (opendata(J)) 是 CompositeData。从 J 的实例到对应于刚描述的 CompositeType 的 CompositeData 的映射是按以下方式完成的。首先，如果 J 实现了接口 CompositeDataView，则调用该接口的 toCompositeData 方法来完成转换。否则，通过对每个项调用获取方法并将其转换为相应的 Open Data 类型来构造 CompositeData。因此，如下所示的获取方法

List<String> getNames()

将被映射到名称为 "names" 且 Open Type 为 ArrayType(1, SimpleType.STRING) 的项。对 CompositeData 的转换将调用 getNames()，并将结果 List<String> 转换为项 "names" 的 String[]。

CompositeData 是一个接口。用于将类型表示为 Open Data 的具体类是 CompositeDataSupport，或者是实现作为 CompositeDataSupport 序列化的 CompositeData 的另一个类。

从 CompositeData 重新构造 Java 类型 J 的实例

如果 opendata(J) 是 Java 类型 J 的 CompositeData，则要么从 CompositeData 重新构造 J 的实例，要么 J 是不可重新构造的。如果 CompositeData 中的任何项都是不可重新构造的，则 J 也是不可重新构造的。

对于任何给定的 J，都可参考以下规则来确定如何从 CompositeData 重新构造 J 的实例。列表中的第一个适用规则是将被使用的规则。

  1. 如果 J 拥有方法
    public static J from(CompositeData cd)
    ，则调用该方法来重新构造一个 J 实例。

  2. 否则，如果 J 至少有一个带有 ConstructorProperties 注释的公共构造方法，则将调用这些构造方法之一（不一定总是同一个构造方法）来重新构造一个 J 实例。每个这样的注释都必须列出与构造方法的参数数量相同的字符串；每个字符串必须命名一个对应于 J 的获取方法的属性；此获取方法的类型必须与对应构造方法参数的类型相同。如果存在 ConstructorProperties 注释中未提到的获取方法（这些获取方法可能对应于重新构造对象所不需要的信息），这不算是一种错误。

    通过使用 CompositeData 中经过适当重新构造的项来调用构造方法，可以重新构造一个 J 实例。要调用的构造方法将在运行的时候根据实际出现在 CompositeData 中的项来确定，在这种情况下，此 CompositeData 可能来自 J 的较早版本，该版本中没有包含所有的项。如果在构造方法的 ConstructorProperties 注释中命名的所有属性都作为项出现在 CompositeData 中，则该构造方法是适用的。如果没有构造方法是适用的，则尝试重新构造 J 将失败。

    对于任何可能的属性组合，必须是以下情况：(a) 没有适用的构造方法，或 (b) 恰恰有一个适用的构造方法，或 (c) 适用的构造方法之一命名了由其他每个适用构造方法命名的属性的适当超集。（换句话说，在选择构造方法时永远不应该有混淆现象。）如果此条件不为 true，则 J 是不可重新构造的。

  3. 否则，如果 J 具有不带参数的公共构造方法，并且对于类型为 T 且名称为 N 的 J 中的每个获取方法，都有一个具有相同名称和类型的相应设置方法，则 J 的实例是使用不带参数的构造方法构造的 ，并使用 CompositeData 中经过重新构造的项来调用这些设置方法，以恢复某些值。例如，如果具有方法
    public List<String> getNames()
    ，则还必须有一个应用此规则的方法
    public void setNames(List<String> names)
    。

    如果 CompositeData 来自 J 的较早版本，则有些项可能不会出现。在这种情况下，不会调用相应的设置方法。

  4. 否则，如果 J 是一个除了获取方法之外没有其他方法的接口，则使用具有 CompositeDataInvocationHandler（受正在转换的 CompositeData 支持）的 Proxy 来构造一个 J 实例。

  5. 否则，J 是不可重新构造的。

下面的示例显示了对那些由 int 和 String 组成的类型 NamedNumber 进行编码的不同方式。CompositeType 在各种情况下的形式如下：

CompositeType(
"NamedNumber",                        // typeName
"NamedNumber",                        // description
new String[] {"number", "name"},    // itemNames
new String[] {"number", "name"},    // itemDescriptions
new OpenType[] {SimpleType.INTEGER,
SimpleType.STRING}  // itemTypes
);
  1. 静态 from 方法：
    public class NamedNumber {
public int getNumber() {return number;}
public String getName() {return name;}
private NamedNumber(int number, String name) {
this.number = number;
this.name = name;
    }
public static NamedNumber from(CompositeData cd) {
return new NamedNumber((Integer) cd.get("number"),
(String) cd.get("name"));
    }
private final int number;
private final String name;
}
  2. 带有 @ConstructorProperties 注释的公共构造方法：
    public class NamedNumber {
public int getNumber() {return number;}
public String getName() {return name;}
@ConstructorProperties({"number", "name"})
public NamedNumber(int number, String name) {
this.number = number;
this.name = name;
    }
private final int number;
private final String name;
}
  3. 针对每个获取方法的设置方法：
    public class NamedNumber {
public int getNumber() {return number;}
public void setNumber(int number) {this.number = number;}
public String getName() {return name;}
public void setName(String name) {this.name = name;}
public NamedNumber() {}
private int number;
private String name;
}
  4. 只带有获取方法的接口：
    public interface NamedNumber {
public int getNumber();
public String getName();
}

通常，它更适合只将数据集合表示为不可变 的类。不可变类的实例在被构造之后无法进行更改。注意，CompositeData 本身是不可变的。不可变性有许多优点，最为明显的是线程安全和安全性。因此，如有可能，通常应该采用避免使用设置方法的方式。

递归类型

递归（自引用）类型不能在 MXBean 接口中使用。这是 CompositeType 的不变性导致的。例如，以下类型不能是属性的类型，因为属性引用了自身：

public interface Node {
    public String getName();
    public int getPriority();
    public Node getNext();
}

总是可以像这样重写递归接口，使之不再递归。重写可能需要引入新类型。例如：

public interface NodeList {
    public List<Node> getNodes();
}

public interface Node {
    public String getName();
    public int getPriority();
}

MXBean 的 MBeanInfo 内容

MXBean 是 Open MBean 的一种类型。但是，出于兼容性考虑，其 MBeanInfo 不是一个 OpenMBeanInfo。需要特别指出的是，如果属性、参数或操作返回值的类型是 int 之类的基本类型，或者是 void（针对返回类型），则属性、参数或操作将被分别表示为其 getType() 或 getReturnType() 返回基本名称（"int" 等）的 MBeanAttributeInfo、MBeanParameterInfo 或 MBeanOperationInfo。即使上面的映射规则指定 opendata 映射是包装类型（Integer 等），情况也是这样。

由直接在 MBean Server 中注册的 MXBean 的 MBeanInfo.getConstructors() 返回的公共构造方法数组，将包含该 MXBean 的所有公共构造方法。如果 MXBean 的类不是公共类，则其构造方法也被视为非公共构造方法。MXBean 的返回列表是使用 StandardMBean 类构造的，其派生方式与 Standard MBean 的相同。不管 MXBean 是如何构造的，其构造方法参数都不服从 MXBean 映射规则，且没有对应的 OpenType。

如果直接在 MBean Server 中注册的 MXBean 没有实现 NotificationBroadcaster 接口，则由其 MBeanInfo.getNotifications() 返回的通知类型的数组将为空。否则，它将是在注册 MXBean 时调用 NotificationBroadcaster.getNotificationInfo() 的结果。即使此方法的结果以后发生更改，MBeanInfo.getNotifications() 的结果也不会发生更改。MXBean 的返回列表是使用 StandardMBean 或 StandardEmitterMBean 类构造的，其派生方式与 Standard MBean 的相同。

MBeanInfo 中包含的所有 MBeanAttributeInfo、MBeanParameterInfo 和 MBeanOperationInfo 对象的 Descriptor 都将包含一个字段 openType，其值为由上述映射规则指定的 OpenType。因此，即使在 getType() 为 "int" 时，getDescriptor().getField(&quot;openType&quot;) 仍将是 SimpleType.INTEGER。

每个对象的 Descriptor 还有一个 originalType 字段，该字段是一个表示 MXBean 接口中出现的 Java 类型的字符串。此字符串的格式将在下面的类型名称一节中描述。

MBeanInfo 的 Descriptor 将包含一个 mxbean 字段，该字段值是字符串 "true"。

类型名称

有时必须将 MXBean 中方法参数或返回值的未映射类型 T 表示为一个字符串。如果 T 是非一般类型，则此字符串是由 Class.getName() 返回的值。否则，它是 genericstring(T) 的值，定义方式如下：

  • 如果 T 为特殊的非数组类型，则 genericstring(T) 是由 Class.getName() 返回的值，如 &quot;int&quot; 或 &quot;java.lang.String&quot;。
  • 如果 T 是数组 E[]，则 genericstring(T) 是后跟 &quot;[]&quot; 的 genericstring(E)。例如，genericstring(int[]) 是 &quot;int[]&quot;，而 genericstring(List<String>[][]) 是 &quot;java.util.List<java.lang.String>[][]&quot;。
  • 否则，T 是一个参数化类型（如 List<String>）并且 genericstring(T) 由以下内容组成：由 Class.getName() 返回的参数化类型的完全限定名称；左尖角括号 (&quot;&lt;&quot;)；genericstring(A)（其中 A 是第一个类型参数）；如果存在第二个类型参数 B，则是一个后跟 genericstring(B) 的 &quot;, &quot;（即逗号加一个空格）；右尖角括号 (&quot;&gt;&quot;)。

注意，如果某一方法返回 int[]，则这将由 Class.getName() 返回的字符串 &quot;[I&quot; 表示，但如果某一方法返回 List<int[]>，则这将由字符串 &quot;java.util.List<int[]>&quot; 表示。

异常

从 Java 类型映射到 Open 类型时存在的一个问题是会出现 OpenDataException 信号。这可能发生在分析 MXBean 接口时，例如，如果它引用一个类似于没有获取方法的 java.util.Random 的类型。或者发生在转换实例（将返回值从 MXBean 中的方法或参数转换为 MXBean 代理中的方法）时，例如在 SortedSet 拥有非 null Comparator 的情况下从 SortedSet<String> 转换为 String[] 时。

从 Open 类型映射到 Java 类型时存在的一个问题是会出现 InvalidObjectException 信号。这可能发生在分析 MXBean 接口时，例如，当上下文需要可重新构造的类型时，根据上述规则引用了一个不可重新构造的 类型。或者发生在转换实例（MXBean 中某一方法的参数或 MXBean 代理中某一方法的返回值）时，例如在没有具备该名称的 Enum 常量的情况下将 String 转换为 Enum 时。

根据上下文，OpenDataException 或 InvalidObjectException 可以包装在另一个异常（如 RuntimeMBeanException 或 UndeclaredThrowableException）中。 对于每个抛出的异常，条件 C 将为 true："e 为 OpenDataException 或 InvalidObjectException（如果合适），或者 C 在 e.getCause()" 中为 ture。

从以下版本开始：
1.6

可选元素摘要
 boolean value
如果被注释的接口是一个 MXBean 接口，则为 true。

value

public abstract boolean value
如果被注释的接口是一个 MXBean 接口，则为 true。

返回：
如果被注释的接口是一个 MXBean 接口，则返回 true。
默认值：
true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 必需 | 可选 详细信息： 元素


NotCompliantMBeanException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 NotCompliantMBeanException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.NotCompliantMBeanException
所有已实现的接口：
Serializable
public class NotCompliantMBeanException
extends OperationsException

尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
NotCompliantMBeanException()
默认的构造方法。
NotCompliantMBeanException(String message)
允许指定具体错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotCompliantMBeanException

public NotCompliantMBeanException()
默认的构造方法。

NotCompliantMBeanException

public NotCompliantMBeanException(String message)
允许指定具体错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Notification (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 Notification

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.management.Notification
所有已实现的接口：
Serializable
直接已知子类：
AttributeChangeNotification, JMXConnectionNotification, MBeanServerNotification, MonitorNotification, RelationNotification, TimerNotification
public class Notification
extends EventObject

Notification 类表示 MBean 所发出的通知。它包含对源 MBean 的引用：如果已通过 MBean 服务器转发了该通知，且该通知的初始源是对发出通知的 MBean 对象的引用，则 MBean 服务器根据该 MBean 的 ObjectName 来替换初始源。如果已直接使用 MBean 注册了侦听器，则初始源要么是该 MBean 的 ObjectName，要么是对该 MBean 的直接引用。

强烈建议该通知的发送方使用 MBean 的 ObjectName 而不是对该 MBean 对象的引用来作为通知的源。

此类的 serialVersionUID 为 -7516092053498031989L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
protected  Object source
此域隐藏了父类中的 EventObject.source 域，使其成为非 transient 的，并因此成为序列化形式的一部分。
构造方法摘要
Notification(String type, Object source, long sequenceNumber)
创建一个 Notification 对象。
Notification(String type, Object source, long sequenceNumber, long timeStamp)
创建一个 Notification 对象。
Notification(String type, Object source, long sequenceNumber, long timeStamp, String message)
创建一个 Notification 对象。
Notification(String type, Object source, long sequenceNumber, String message)
创建一个 Notification 对象。
方法摘要
String | getMessage() 获得通知消息。
long | getSequenceNumber() 获得通知序列号。
long | getTimeStamp() 获得通知时间戳。
String | getType() 获得通知类型。
Object | getUserData() 获得用户数据。
void | setSequenceNumber(long sequenceNumber) 设置通知序列号。
void | setSource(Object source) 设置源。
void | setTimeStamp(long timeStamp) 设置通知时间戳。
void | setUserData(Object userData) 设置用户数据。
String | toString() 返回此通知的字符串表示形式。
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

source

protected Object source

此域隐藏了父类中的 EventObject.source 域，使其成为非 transient 的，并因此成为序列化形式的一部分。

构造方法详细信息

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber)
创建一个 Notification 对象。将通知的 timeStamp 设置为当前日期。

参数：
type - 通知类型。
source - 通知源。
sequenceNumber - 源对象内的通知序列号。

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber,
                    String message)
创建一个 Notification 对象。将通知的 timeStamp 设置为当前日期。

参数：
type - 通知类型。
source - 通知源。
sequenceNumber - 源对象内的通知序列号。
message - 详细消息。

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber,
                    long timeStamp)
创建一个 Notification 对象。

参数：
type - 通知类型。
source - 通知源。
sequenceNumber - 源对象内的通知序列号。
timeStamp - 通知发出日期。

Notification

public Notification(String type,
                    Object source,
                    long sequenceNumber,
                    long timeStamp,
                    String message)
创建一个 Notification 对象。

参数：
type - 通知类型。
source - 通知源。
sequenceNumber - 源对象内的通知序列号。
timeStamp - 通知发出日期。
message - 详细消息。
方法详细信息

setSource

public void setSource(Object source)
设置源。

参数：
source - 此对象的新源。
另请参见：
EventObject.getSource()

getSequenceNumber

public long getSequenceNumber()
获得通知序列号。

返回：
源对象内的通知序列号。这是在通知源上下文中标识特定通知实例的序列号。通知模型并不假定会以和发送通知时相同的顺序接收这些通知。该序列号可帮助侦听器对接收到的通知进行排序。
另请参见：
setSequenceNumber(long)

setSequenceNumber

public void setSequenceNumber(long sequenceNumber)
设置通知序列号。

参数：
sequenceNumber - 源对象内的通知序列号。这是标识在通知源的上下文中的特定通知实例的序列号。
另请参见：
getSequenceNumber()

getType

public String getType()
获得通知类型。

返回：
通知类型。这是用和 Java 属性类似的点标注法所表示的 string。通知类型示例：network.alarm.router。

getTimeStamp

public long getTimeStamp()
获得通知时间戳。

返回：
通知时间戳。
另请参见：
setTimeStamp(long)

setTimeStamp

public void setTimeStamp(long timeStamp)
设置通知时间戳。

参数：
timeStamp - 通知时间戳。它指示通知的生成时间。
另请参见：
getTimeStamp()

getMessage

public String getMessage()
获得通知消息。

返回：
此通知对象的消息字符串。该消息包含在一个字符串中，可以是显示给用户的通知解释。

getUserData

public Object getUserData()
获得用户数据。

返回：
用户数据对象。它用于通知源希望与其使用者所交流的所有其他数据。
另请参见：
setUserData(java.lang.Object)

setUserData

public void setUserData(Object userData)
设置用户数据。

参数：
userData - 用户数据对象。它用于通知源希望与其使用者所交流的所有其他数据。
另请参见：
getUserData()

toString

public String toString()
返回此通知的字符串表示形式。

覆盖：
类 EventObject 中的 toString
返回：
此通知的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationBroadcaster (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 NotificationBroadcaster

所有已知子接口：
ModelMBean, ModelMBeanNotificationBroadcaster, NotificationEmitter
所有已知实现类：
CounterMonitor, GaugeMonitor, JMXConnectorServer, MBeanServerDelegate, Monitor, NotificationBroadcasterSupport, RelationService, RequiredModelMBean, RMIConnectorServer, StandardEmitterMBean, StringMonitor, Timer
public interface NotificationBroadcaster

由发出 Notifications 的 MBean 实现的接口。它允许某个侦听器在该 MBean 中注册为通知侦听器。

通知调度

MBean 发出通知时，它会考虑每个已经使用 addNotificationListener 添加、且之后没有使用 removeNotificationListener 移除的侦听器。如果该侦听器同时提供一个过滤器，且过滤器的 isNotificationEnabled 方法返回 false，则忽略该侦听器。否则，将利用通知调用侦听器的 handleNotification 方法，同时向 addNotificationListener 提供 handback 对象。

如果多次添加同一个侦听器，则认为该侦听器被添加的次数等于实际被添加的次数。在添加相同的侦听器的同时使用不同的过滤器或 handback 对象常常很有用。

根据调用过滤器和侦听器方法的线程，此接口的实现可能有所不同。

如果过滤器或侦听器的方法调用抛出 Exception，则该异常不应该阻止调用其他侦听器。但是，如果方法调用抛出 Error，则建议在此处停止对通知的处理，如果 Error 可以传播到通知的发送方，则更应该这样做。

新的代码应该使用 NotificationEmitter 接口。

应该注意保持此接口的实现与 NotificationEmitter 的实现之间同步。需要特别指出的是，让某个实现在调用侦听器时持有锁不是一个好主意。侦听器列表在调度通知时可能发生更改，处理这种可能性的一个好的策略是对列表使用 CopyOnWriteArrayList。

从以下版本开始：
1.5

方法摘要
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
void | removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。

方法详细信息

addNotificationListener

void addNotificationListener(NotificationListener listener,
                             NotificationFilter filter,
                             Object handback)
                             throws IllegalArgumentException
在此 MBean 中添加一个侦听器。

参数：
listener - 将处理广播者发出的通知的侦听器对象。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送回侦听器的不透明对象。Notification 广播者对象不能使用此对象。应该将通知不作更改地重新发送到侦听器。
抛出：
IllegalArgumentException - 如果 Listener 参数为 null。
另请参见：
removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
从此 MBean 移除一个侦听器。如果已向不同的 handback 对象或通知过滤器注册了该侦听器，则移除与该侦听器有关的所有项。

参数：
listener - 以前添加到此 MBean 中的侦听器。
抛出：
ListenerNotFoundException - 如果没有在 MBean 中注册该侦听器。
另请参见：
addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

getNotificationInfo

MBeanNotificationInfo[] getNotificationInfo()

返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。

MBean 发送此数组中未描述的通知是合法的。但是，某些 MBean 服务器的客户端要想正常运行，可能要依赖完整的数组。

返回：
可能的通知数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationBroadcasterSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 NotificationBroadcasterSupport

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
所有已实现的接口：
NotificationBroadcaster, NotificationEmitter
直接已知子类：
JMXConnectorServer, Monitor, RelationService, Timer
public class NotificationBroadcasterSupport
extends Object
implements NotificationEmitter

提供 NotificationEmitter 接口的实现。该类可以用作发送通知的 MBean 的超类。

默认情况下，通知调度模型是同步的。也就是说，当某一线程调用 sendNotification 时，将在该线程中调用每个侦听器的 NotificationListener.handleNotification 方法。可以通过重写子类中的 handleNotification 或者通过将 Executor 传递给构造方法来重写此默认值。

如果过滤器或侦听器的方法调用抛出 Exception，则该异常不会阻止调用其他侦听器。不过，如果过滤器、Executor.execute 或 handleNotification 的方法调用（未指定任何 Excecutor 时）抛出 Error，则将该 Error 传播到 sendNotification 的调用者。

通常不会同步调用使用 JMX Remote API 添加的远程侦听器（请参阅 JMXConnector）。也就是说，当 sendNotification 返回时，不保证任何远程侦听器都已经收到通知。

从以下版本开始：
1.5

构造方法摘要
NotificationBroadcasterSupport()
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都由发送通知的线程调用。
NotificationBroadcasterSupport(Executor executor)
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(Executor executor, MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport。
方法摘要
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个侦听器。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
protected void | handleNotification(NotificationListener listener, Notification notif, Object handback) 为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。
void | removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。
void | removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | sendNotification(Notification notification) 发送一个通知。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NotificationBroadcasterSupport

public NotificationBroadcasterSupport()
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都由发送通知的线程调用。此构造方法等效于 NotificationBroadcasterSupport(null, null)。

NotificationBroadcasterSupport

public NotificationBroadcasterSupport(Executor executor)
构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。在调用 sendNotification 时，如果使用 null NotificationFilter 添加了某个侦听器，或者如果 isNotificationEnabled 为正在发送的通知返回 true，则选择该侦听器。对 NotificationFilter.isNotificationEnabled 的调用发生在调用了 sendNotification 的线程中。然后使用调用 handleNotification 方法的命令为每个选定的侦听器调用 executor.execute。此构造方法等效于 NotificationBroadcasterSupport(executor, null)。

参数：
executor - 由方法 sendNotification 用来发送每个通知的执行程序。如果该参数为 null，则调用 sendNotification 的线程将调用 handleNotification 方法本身。
从以下版本开始：
1.6

NotificationBroadcasterSupport

public NotificationBroadcasterSupport(MBeanNotificationInfo... info)

使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport。每个侦听器都由发送通知的线程调用。此构造方法等效于 NotificationBroadcasterSupport(null, info)。

如果 info 数组不为空，则由该构造方法复制它，这类似于使用 info.clone()，并且对 getNotificationInfo() 的每次调用都返回一个新副本。

参数：
info - 一个数组，指示此 MBean 可能发送的每个通知、这些通知的 Java 类的名称和通知类型。该数组可以为 null，它等效于一个空数组。
从以下版本开始：
1.6

NotificationBroadcasterSupport

public NotificationBroadcasterSupport(Executor executor,
                                      MBeanNotificationInfo... info)

使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。

在调用 sendNotification 时，如果使用 null NotificationFilter 添加了某个侦听器，或者如果 isNotificationEnabled 为正在发送的通知返回 true，则选择该侦听器。对 NotificationFilter.isNotificationEnabled 的调用发生在调用了 sendNotification 的线程中。然后使用调用 handleNotification 方法的命令为每个选定的侦听器调用 executor.execute。

如果 info 数组不为空，则由该构造方法复制它，这类似于使用 info.clone()，并且对 getNotificationInfo() 的每次调用都返回一个新副本。

参数：
executor - 由方法 sendNotification 用来发送每个通知的执行程序。如果该参数为 null，则调用 sendNotification 的线程将调用 handleNotification 方法本身。
info - 一个数组，指示此 MBean 可能发送的每个通知、这些通知的 Java 类的名称和通知类型。该数组可以为 null，它等效于一个空数组。
从以下版本开始：
1.6
方法详细信息

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
添加一个侦听器。

指定者：
接口 NotificationBroadcaster 中的 addNotificationListener
参数：
listener - 要接收通知的侦听器。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送到侦听器的不透明对象。Notification 广播者对象不能使用此对象。应该不作更改地将通知重新发送到侦听器。
抛出：
IllegalArgumentException - 如果 listener 为 null。
另请参见：
removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
从接口 NotificationBroadcaster 复制的描述
从此 MBean 移除一个侦听器。如果已向不同的 handback 对象或通知过滤器注册了该侦听器，则移除与该侦听器有关的所有项。

指定者：
接口 NotificationBroadcaster 中的 removeNotificationListener
参数：
listener - 以前添加到此 MBean 中的侦听器。
抛出：
ListenerNotFoundException - 如果没有在 MBean 中注册该侦听器。
另请参见：
NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException
从接口 NotificationEmitter 复制的描述

从此 MBean 移除一个侦听器。该 MBean 必须有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果有多个此类侦听器，则只移除一个侦听器。

当且仅当在要移除的侦听器中 filter 和 handback 参数为 null 时，这两个参数才可以为 null。

指定者：
接口 NotificationEmitter 中的 removeNotificationListener
参数：
listener - 以前添加到此 MBean 中的侦听器。
filter - 添加侦听器时指定的过滤器。
handback - 添加侦听器时指定的回送。
抛出：
ListenerNotFoundException - 如果没有在该 MBean 中注册侦听器，或者没有用给定的过滤器和回送注册它。

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
从接口 NotificationBroadcaster 复制的描述

返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。

MBean 发送此数组中未描述的通知是合法的。但是，某些 MBean 服务器的客户端要想正常运行，可能要依赖完整的数组。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
返回：
可能的通知数组。

sendNotification

public void sendNotification(Notification notification)
发送一个通知。如果在构造方法中指定了一个 Executor，则为每个选定的侦听器提供一项任务，以便将通知发送给该侦听器。

参数：
notification - 要发送的通知。

handleNotification

protected void handleNotification(NotificationListener listener,
                                  Notification notif,
                                  Object handback)

为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。在子类中可重写此方法，以更改通知传递的行为，例如在一个单独的线程中传递该通知。

此方法的默认实现等效于

listener.handleNotification(notif, handback);

参数：
listener - 要接收通知的侦听器。
notif - 传递给侦听器的通知。
handback - 添加侦听器时提供的回调对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationEmitter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 NotificationEmitter

所有超级接口：
NotificationBroadcaster
所有已知实现类：
CounterMonitor, GaugeMonitor, JMXConnectorServer, MBeanServerDelegate, Monitor, NotificationBroadcasterSupport, RelationService, RequiredModelMBean, RMIConnectorServer, StandardEmitterMBean, StringMonitor, Timer
public interface NotificationEmitter
extends NotificationBroadcaster

由发出 Notifications 的 MBean 实现的接口。它允许某个侦听器向该 MBean 注册为通知侦听器。

通知调度

MBean 发出通知时，它会考虑每个已经使用 addNotificationListener 添加、且之后没有使用 removeNotificationListener 移除的侦听器。如果该侦听器同时提供一个过滤器，且过滤器的 isNotificationEnabled 方法返回 false，则忽略该侦听器。否则，将利用通知调用侦听器的 handleNotification 方法，同时向 addNotificationListener 提供 handback 对象。

如果多次添加同一个侦听器，则认为该侦听器被添加的次数等于实际被添加的次数。在添加相同的侦听器的同时使用不同的过滤器或 handback 对象常常很有用。

根据调用过滤器和侦听器方法的线程，此接口的实现可能有所不同。

如果过滤器或侦听器的方法调用抛出 Exception，则该异常不应该阻止调用其他侦听器。但是，如果方法调用抛出 Error，则建议在此处停止对通知的处理，如果 Error 可以传播到通知的发送方，则更应该这样做。

新代码应该优先使用此接口，而不是 NotificationBroadcaster 接口。

应该注意保持此接口的实现与 NotificationBroadcaster 的实现之间的同步。需要特别指出的是，让某个实现在调用侦听器时持有锁定不是一个好主意。侦听器列表在调度通知时可能发生更改，处理这种可能性的一个好的策略是对列表使用 CopyOnWriteArrayList。

从以下版本开始：
1.5

方法摘要
 void removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
从此 MBean 移除一个侦听器。
从接口 javax.management.NotificationBroadcaster 继承的方法
addNotificationListener, getNotificationInfo, removeNotificationListener

方法详细信息

removeNotificationListener

void removeNotificationListener(NotificationListener listener,
                                NotificationFilter filter,
                                Object handback)
                                throws ListenerNotFoundException

从此 MBean 移除一个侦听器。该 MBean 必须有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果有多个此类侦听器，则只移除一个侦听器。

当且仅当在要移除的侦听器中 filter 和 handback 参数为 null 时，这两个参数才可以为 null。

参数：
listener - 以前添加到此 MBean 中的侦听器。
filter - 添加侦听器时指定的过滤器。
handback - 添加侦听器时指定的回送。
抛出：
ListenerNotFoundException - 如果没有在该 MBean 中注册侦听器，或者没有用给定的过滤器和回送注册它。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 NotificationFilter

所有超级接口：
Serializable
所有已知实现类：
AttributeChangeNotificationFilter, MBeanServerNotificationFilter, NotificationFilterSupport
public interface NotificationFilter
extends Serializable

可由作为通知过滤器的任何类来实现。它允许已注册的通知侦听器过滤感兴趣的通知。

从以下版本开始：
1.5

方法摘要
 boolean isNotificationEnabled(Notification notification)
向侦听器发送指定通知前调用。

方法详细信息

isNotificationEnabled

boolean isNotificationEnabled(Notification notification)
向侦听器发送指定通知前调用。

参数：
notification - 要发送的通知。
返回：
如果必须将通知发送到侦听器，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationFilterSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 NotificationFilterSupport

java.lang.Object
    继承者  javax.management.NotificationFilterSupport
所有已实现的接口：
Serializable, NotificationFilter
直接已知子类：
MBeanServerNotificationFilter
public class NotificationFilterSupport
extends Object
implements NotificationFilter

提供 NotificationFilter 接口的实现。针对通知类型这一属性执行过滤。

管理一个已启用的通知类型列表。方法允许用户根据需要启用/禁用多个通知类型。

然后在向侦听器（已向某个过滤器注册过）发送通知前，该通知广播器会比较此通知类型和该过滤器所允许的所有通知类型。仅在该侦听器的过滤器允许此通知类型的情况下才将通知发送到该侦听器。

示例：

 NotificationFilterSupport myFilter = new NotificationFilterSupport();
 myFilter.enableType("my_example.my_type");
 myBroadcaster.addListener(myListener, myFilter, null);
侦听器 myListener 仅接收类型等于 "my_example.my_type" 或以其开头的通知。

从以下版本开始：
1.5
另请参见：
NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), 序列化表格

构造方法摘要
NotificationFilterSupport()
方法摘要
void | disableAllTypes() 禁止所有通知类型。
void | disableType(String prefix) 从前缀列表中移除给定的前缀。
void | enableType(String prefix) 允许将其类型以指定前缀开始的所有通知发送到该侦听器。
Vector<String> | getEnabledTypes() 获得此过滤器的所有允许通知类型。
boolean | isNotificationEnabled(Notification notification) 向侦听器发送指定的通知前调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NotificationFilterSupport

public NotificationFilterSupport()
方法详细信息

isNotificationEnabled

public boolean isNotificationEnabled(Notification notification)
向侦听器发送指定的通知前调用。
此过滤器把指定的通知的类型和所有允许的类型相比较。如果通知类型与某个允许类型匹配，则应该将该通知发送到侦听器并且此方法返回 true。

指定者：
接口 NotificationFilter 中的 isNotificationEnabled
参数：
notification - 要发送的通知。
返回：
如果应该将通知发送到侦听器，则返回 true；否则返回 false。

enableType

public void enableType(String prefix)
                throws IllegalArgumentException
允许将其类型以指定前缀开始的所有通知发送到该侦听器。
如果指定的前缀已经在允许通知类型的列表中，则此方法无效。

示例：

 // Enables all notifications the type of which starts with "my_example" to be sent.
 myFilter.enableType("my_example");
 // Enables all notifications the type of which is "my_example.my_type" to be sent.
 myFilter.enableType("my_example.my_type");
注：
myFilter.enableType("my_example.*");
不匹配任何通知类型。

参数：
prefix - 前缀。
抛出：
IllegalArgumentException - 如果 prefix 参数为 null。

disableType

public void disableType(String prefix)
从前缀列表中移除给定的前缀。
如果指定的前缀不在允许的通知类型的列表中，则此方法无效。

参数：
prefix - 前缀。

disableAllTypes

public void disableAllTypes()
禁止所有通知类型。

getEnabledTypes

public Vector<String> getEnabledTypes()
获得此过滤器的所有允许通知类型。

返回：
包含所有允许的通知类型的列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 NotificationListener

所有超级接口：
EventListener
所有已知实现类：
RelationService
public interface NotificationListener
extends EventListener

应该由想要接收通知的对象来实现。

从以下版本开始：
1.5

方法摘要
 void handleNotification(Notification notification, Object handback)
出现 JMX 通知时调用。

方法详细信息

handleNotification

void handleNotification(Notification notification,
                        Object handback)
出现 JMX 通知时调用。此方法的实现应该尽快返回，以避免阻塞其通知广播者。

参数：
notification - 通知。
handback - 一个不透明对象，用于帮助侦听器关联关于 MBean 发出者的信息。在 addListener 调用期间将此对象传递到 MBean，并在不经修改的情况下重发到侦听器。MBean 对象不应使用或修改该对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectInstance (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 ObjectInstance

java.lang.Object
    继承者  javax.management.ObjectInstance
所有已实现的接口：
Serializable
public class ObjectInstance
extends Object
implements Serializable

用于表示 MBean 对象名及其类名。如果 MBean 是一个 Dynamic MBean，则应该从该 MBean 提供的 MBeanInfo 中检索其类名。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ObjectInstance(ObjectName objectName, String className)
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。
ObjectInstance(String objectName, String className)
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。
方法摘要
boolean | equals(Object object) 比较当前的 ObjectInstance 与另一个 ObjectInstance 是否相等。
String | getClassName() 返回类部分。
ObjectName | getObjectName() 返回对象名部分。
int | hashCode() 返回该对象的哈希码值。
String | toString() 返回表示此 ObjectInstance 对象字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ObjectInstance

public ObjectInstance(String objectName,
                      String className)
               throws MalformedObjectNameException
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。

参数：
objectName - 对象名的字符串表示形式。
className - ObjectInstance 的完整类名（包括包名）。如果该 MBean 是一个 Dynamic MBean，则类名对应于其 getMBeanInfo() .getClassName()。
抛出：
MalformedObjectNameException - 如果作为参数传递的 string 格式不正确。

ObjectInstance

public ObjectInstance(ObjectName objectName,
                      String className)
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。

参数：
objectName - 对象名。
className - ObjectInstance 的完整类名(包括包名)。如果该 MBean 是一个 Dynamic MBean，则类名对应于其 getMBeanInfo() .getClassName()。如果 MBean 是一个 Dynamic MBean，则应该从该 MBean 提供的 MBeanInfo 中检索其类名。
方法详细信息

equals

public boolean equals(Object object)
比较当前的 ObjectInstance 与另一个 ObjectInstance 是否相等。

覆盖：
类 Object 中的 equals
参数：
object - 将与当前 ObjectInstance 进行比较的 ObjectInstance。
返回：
如果两个 ObjectInstance 相等，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getObjectName

public ObjectName getObjectName()
返回对象名部分。

返回：
对象名。

getClassName

public String getClassName()
返回类部分。

返回：
类名。

toString

public String toString()
返回表示此 ObjectInstance 对象字符串。未指定此字符串的格式，但是当且仅当两个 ObjectInstance 相等时才会返回相同的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 ObjectName

java.lang.Object
    继承者  javax.management.ObjectName
所有已实现的接口：
Serializable, Comparable<ObjectName>, QueryExp
public class ObjectName
extends Object
implements Comparable<ObjectName>, QueryExp

表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。此类的实例是不可变的。

可使用此类的实例表示：

  • 对象名
  • 查询的上下文中的对象名模式

由两部分（域和键属性）组成的对象名。

域 是一个不包括冒号字符 (:) 的由字符组成的字符串。建议域不要包含字符串 "//"，该字符串保留供将来使用。

如果域至少包括一个通配符星号 (*) 或问号 (?)，则该对象名就是一个模式。星号匹配任意零或多个字符的序列，而问号则匹配任意单个字符。

如果域为空，则由 MBean 服务器（在其中使用 ObjectName）的默认域 在特定的上下文中替换它。

键属性 是一个无序的键和关联值的集合。

每个键 都是一个由字符组成的非空字符串，不可以包含任何逗号 (,)、等号 (=)、冒号、星号或问号字符。在一个给定的 ObjectName 中，同一个键不能出现两次。

每个与键关联的值 都是由字符组成的字符串，或者由引号括起来或者不括起来。

无引号值 可能是一个空的字符串，不包含任意逗号、等号、冒号和引号。

如果无引号值 包括至少一个通配符星号或问号，则该对象名就是一个属性值模式。

有引号值 由一个引号 (")，后跟可能为空的字符串，然后是另一个引号所组成。在字符串中，反斜线 (\) 具有特殊的含义，它后面必须是下列某个字符：

  • 另一个反斜线。第二个反斜线不具有特殊的含义，两个字符表示单个反斜线。
  • 字符 'n'。这两个字符表示新行（Java 中的 '\n'）。
    • \Z
  • 引号。这两个字符表示一个引号，并且不将该引号视为有引号值的终止。为了使有引号值有效，必须有结束的闭合引号。
  • 问号 (?) 或星号 (*)。这两个字符分别表示一个问号或一个星号。

引号可能不出现在有引号值中，但紧跟在奇数个连续反斜线后的情况除外。

括住有引号值的引号和该值中的所有反斜线都被视为该值的一部分。

如果引号值 包括至少一个星号或问号，且星号或问号之前没有反斜杠，则将其视为通配符，并且该对象名是一个属性值模式。星号匹配任意零或多个字符的序列，而问号则匹配任意单个字符。

ObjectName 可能是一种属性列表模式。在这种情况下，它可以有零个或多个键和关联值。它与非模式的 ObjectName 匹配，该 ObjectName 的域与相同的键和关联值匹配且包含它们，并且可能包括其他键和值。

当至少有一个 ObjectName 的有引号 或无引号 键属性值包含通配符星号或问号（如上所述）时，ObjectName 是一个属性值模式。在这种情况下，它有一个或多个键以及关联值，并至少有一个值包含通配符。它与一个无模式 ObjectName 相匹配，该 ObjectName 的域与之匹配，或者包含值与之匹配的相同键；如果属性值模式也是属性列表模式，则无模式 ObjectName 也可以包含其他键和值。

如果 ObjectName 是属性列表模式 或属性值模式，或者两者都是，则它是一个属性模式。

如果某个 ObjectName 的域包含通配符或者 ObjectName 是一个属性模式，则该 ObjectName 是一个模式。

如果某个 ObjectName 不是一个模式，那么它必须至少包含一个键及其关联值。

ObjectName 模式的示例有：

  • *:type=Foo,name=Bar 匹配键的具体设置为 type=Foo,name=Bar 的任何域中的名称。
  • d:type=Foo,name=Bar,* 匹配具有键 type=Foo,name=Bar 以及 0 或其他键的域 d 中的名称。
  • *:type=Foo,name=Bar,* 匹配具有键 type=Foo,name=Bar 以及 0 或其他键的域中的名称。
  • d:type=F?o,name=Bar 将与诸如 d:type=Foo,name=Bar 和 d:type=Fro,name=Bar 之类的键和名称匹配。
  • d:type=F*o,name=Bar 将与诸如 d:type=Fo,name=Bar 和 d:type=Frodo,name=Bar 之类的键和名称匹配。
  • d:type=Foo,name="B*" 将与诸如 d:type=Foo,name="Bling" 之类的键和名称匹配。通配符在引号中也能被识别，并且像其他特殊字符一样可以使用 \ 转义。

按顺序使用下列元素可将 ObjectName 写为 String：

  • 域。
  • 一个冒号 (:)。
  • 如下定义的键属性列表。

写为 String 的键属性列表是一个逗号分隔的元素列表。每个元素都是一个星号或一个键属性。键属性由键、等号 (=) 和关联值组成。

键属性列表中最多只能有一个元素为星号。如果键属性列表包含星号元素，则该 ObjectName 是一个属性列表模式。

在表示 ObjectName 的 String 中，空格没有任何特殊含意。例如，String：

 domain: key1 = value1 , key2 = value2
表示具有两个键的 ObjectName。每个键的名字包含 6 个字符，其中第一个和最后一个都是空格。与键 " key1 " 相关联的值同样以空格开头和结尾。

除了上述提及的字符限制外，ObjectName 的任何部分都不能包含换行符 ('\n')，无论这些部分是域、键还是值（无引号值和有引号值）。可使用序列 \n 将换行符表示为有引号值。

不管使用何种构造方法构建 ObjectName，关于特殊字符和引号的规则都适用。

为了避免不同供应商所提供的 MBean 之间出现冲突，提供了一个有用的约定：域名由指定该 MBean 的企业的反向 DNS 名开始，后跟一个句点和一个字符串，由该企业决定该字符串的解释。例如，由 Sun Microsystems Inc.（DNS 名是 sun.com）所指定的 MBean 将有 com.sun.MyDomain 这样的域。这基本上与 Java 语言包名的约定相同。

此类的 serialVersionUID 为 1081892073854801359L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static ObjectName WILDCARD
定义通配符 "*:*" ObjectName。
构造方法摘要
ObjectName(String name)
根据给定的字符串构造一个对象名。
ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。
ObjectName(String domain, String key, String value)
构造只具有一个键属性的对象名。
方法摘要
 boolean apply(ObjectName name)
测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。
 int compareTo(ObjectName name)
比较两个 ObjectName 实例。
 boolean equals(Object object)
比较当前的对象名与另一个对象名是否相等。
 String getCanonicalKeyPropertyListString()
返回键属性列表的字符串表示形式，其中键属性按词汇顺序排序。
 String getCanonicalName()
返回该名称的规范形式；也就是说，一种字符串表示形式，其中属性按词汇顺序排序。
 String getDomain()
返回域部分。
static ObjectName getInstance(ObjectName name)
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
static ObjectName getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
static ObjectName getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
static ObjectName getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。
 String getKeyProperty(String property)
获得与键属性中某个键相关联的值。
 Hashtable<String,String> getKeyPropertyList()
以哈希表的形式返回键属性。
 String getKeyPropertyListString()
返回创建时指定的键属性列表的字符串表示形式。
 int hashCode()
返回此 ObjectName 的哈希码。
 boolean isDomainPattern()
根据对象名的域部分检查对象名是否为一个模式。
 boolean isPattern()
检查该对象名是否为一个模式。
 boolean isPropertyListPattern()
检查对象名是否为一个键属性列表模式。
 boolean isPropertyPattern()
检查对象名是否为一个键属性模式。
 boolean isPropertyValuePattern()
检查对象名是否为值部分至少有一个键属性的模式。
 boolean isPropertyValuePattern(String property)
检查键属性中与值关联的值是否为一个模式。
static String quote(String s)
返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。
 void setMBeanServer(MBeanServer mbs)
设置将在其上执行查询的 MBean 服务器。
 String toString()
返回该对象名的字符串表示形式。
static String unquote(String q)
返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

WILDCARD

public static final ObjectName WILDCARD
定义通配符 "*:*" ObjectName。

从以下版本开始：
1.6
构造方法详细信息

ObjectName

public ObjectName(String name)
           throws MalformedObjectNameException,
                  NullPointerException
根据给定的字符串构造一个对象名。

参数：
name - 对象名的字符串表示形式。
抛出：
MalformedObjectNameException - 如果作为参数传递的字符串格式不正确。
NullPointerException - 如果 name 参数为 null。

ObjectName

public ObjectName(String domain,
                  String key,
                  String value)
           throws MalformedObjectNameException,
                  NullPointerException
构造只具有一个键属性的对象名。

参数：
domain - 对象名的域部分。
key - 对象名键属性中的属性。
value - 对象名键属性中的值。
抛出：
MalformedObjectNameException - 如果 domain、key 或 value 包含非法字符，如果 value 未遵循有关引号使用的规则。
NullPointerException - 如果某个参数为 null。

ObjectName

public ObjectName(String domain,
                  Hashtable<String,String> table)
           throws MalformedObjectNameException,
                  NullPointerException
构造一个对象名，它具有根据哈希表获得的多个键属性。

参数：
domain - 对象名的域部分。
table - 包含一个或多个键属性的哈希表。表中每项的键都是对象名中键属性的键。表中的关联值是对象名中的关联值。
抛出：
MalformedObjectNameException - 如果 domain 包含非法字符，或者 table 中的某个键或值包含非法字符，或者 table 中的某个值未遵循有关引号使用的规则。
NullPointerException - 如果某个参数为 null。
方法详细信息

getInstance

public static ObjectName getInstance(String name)
                              throws MalformedObjectNameException,
                                     NullPointerException

返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。返回的对象可以是 ObjectName 的子类。使用相同的参数调用此方法两次可能会返回相同的对象，或者两个等效但是不同的对象。

参数：
name - 对象名的字符串表示形式。
返回：
与给定 String 相对应的 ObjectName。
抛出：
MalformedObjectNameException - 如果作为参数传递的字符串格式不正确。
NullPointerException - 如果 name 参数为 null。

getInstance

public static ObjectName getInstance(String domain,
                                     String key,
                                     String value)
                              throws MalformedObjectNameException,
                                     NullPointerException

返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。返回的对象可以是 ObjectName 的子类。使用相同的参数调用此方法两次可能会返回相同的对象，或者两个等效但是不同的对象。

参数：
domain - 对象名的域部分。
key - 对象名键属性中的属性。
value - 对象名键属性中的值。
返回：
与给定域、键和值相对应的 ObjectName。
抛出：
MalformedObjectNameException - 如果 domain、key 或 value 包含非法字符，如果 value 未遵循有关引号使用的规则。
NullPointerException - 如果某个参数为 null。

getInstance

public static ObjectName getInstance(String domain,
                                     Hashtable<String,String> table)
                              throws MalformedObjectNameException,
                                     NullPointerException

返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。返回的对象可以是 ObjectName 的子类。使用相同的参数调用此方法两次可能会返回相同的对象，或者两个等效但是不同的对象。

参数：
domain - 对象名的域部分。
table - 包含一个或多个键属性的哈希表。表中每项的键都是对象名中键属性的键。表中的关联值是对象名中的关联值。
返回：
与给定域和键映射关系相对应的 ObjectName。
抛出：
MalformedObjectNameException - 如果 domain 包含非法字符，或者 table 中的某个键或值包含非法字符，或者 table 中的某个值未遵循有关引号使用的规则。
NullPointerException - 如果某个参数为 null。

getInstance

public static ObjectName getInstance(ObjectName name)
                              throws NullPointerException

返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。返回的对象可以是 ObjectName 的子类。如果 name 是 ObjectName 子类的名称，则无法保证返回的对象属于同一个类。

返回的值可能与 name 相同，也可能不相同。使用相同的参数调用此方法两次可能会返回相同的对象，或者两个等效但是不同的对象。

因为 ObjectName 是不可变的，所以制作 ObjectName 的副本通常没有用。此方法的主要用途是用于防止恶意的调用者，它可能向敏感代码传递具有可疑行为的子类实例。这种代码可以调用此方法来获得一个已知没有可疑行为的 ObjectName。

参数：
name - ObjectName 类或子类的一个实例
返回：
ObjectName 或已知具有相同语义的子类的实例。如果 name 符合 ObjectName 的语义，则返回的对象等于（尽管不必相同）name。
抛出：
NullPointerException - 如果 name 为 null。

isPattern

public boolean isPattern()
检查该对象名是否为一个模式。

如果某个对象名的域包含通配符或者它是一个属性模式，则该对象名是一个模式。

返回：
如果该名称是一个模式，则返回 true；否则返回 false。

isDomainPattern

public boolean isDomainPattern()
根据对象名的域部分检查对象名是否为一个模式。

返回：
如果该名称是一个域模式，则返回 true；否则返回 false。

isPropertyPattern

public boolean isPropertyPattern()
检查对象名是否为一个键属性模式。

如果对象名是键属性列表模式（例如 "d:k=v,*"）或属性值模式（例如 "d:k=*"），或者两者都是（例如 "d:k=*,*"），则它是一个键属性模式。

返回：
如果该名称是一个属性模式，则返回 true；否则返回 false。

isPropertyListPattern

public boolean isPropertyListPattern()
检查对象名是否为一个键属性列表模式。

例如，"d:k=v,*" 和 "d:k=*,*" 是键属性列表模式，而 "d:k=*" 则不是。

返回：
如果该名称是一个属性列表模式，则返回 true；否则返回 false。
从以下版本开始：
1.6

isPropertyValuePattern

public boolean isPropertyValuePattern()
检查对象名是否为值部分至少有一个键属性的模式。

例如，"d:k=*" 和 "d:k=*,*" 是属性值模式，而 "d:k=*" 则不是。

返回：
如果该名称是一个属性值模式，则返回 true；否则返回 false。
从以下版本开始：
1.6

isPropertyValuePattern

public boolean isPropertyValuePattern(String property)
                               throws NullPointerException,
                                      IllegalArgumentException
检查键属性中与值关联的值是否为一个模式。

参数：
property - 要检查值的属性。
返回：
如果与给定键关联的值是一个模式，则返回 true；否则返回 false。
抛出：
NullPointerException - 如果 property 为 null。
IllegalArgumentException - 如果 property 对于此 ObjectName 不是有效值。
从以下版本开始：
1.6

getCanonicalName

public String getCanonicalName()

返回该名称的规范形式；也就是说，一种字符串表示形式，其中属性按词汇顺序排序。

更准确地说，该名称的规范形式是一个由域部分、冒号 (:)、规范的键属性列表 和一个模式指示 组成的 String。

规范的键属性列表 是与 getCanonicalKeyPropertyListString() 所述相同的字符串。

模式指示 是：

  • 对于不是属性列表模式的 ObjectName 而言为空；
  • 对于是属性列表模式但没有键的 ObjectName 而言是一个星号；或者
  • 对于是属性列表模式并且至少有一个键的 ObjectName 而言是逗号和星号 (,*)。

返回：
该名称的规范形式。

getDomain

public String getDomain()
返回域部分。

返回：
域。

getKeyProperty

public String getKeyProperty(String property)
                      throws NullPointerException
获得与键属性中某个键相关联的值。

参数：
property - 要返回其值的属性。
返回：
属性值，如果此 ObjectName 中没有此种属性，则返回 null。
抛出：
NullPointerException - 如果 property 为 null。

getKeyPropertyList

public Hashtable<String,String> getKeyPropertyList()

以哈希表的形式返回键属性。返回值是一个哈希表，其中每个键是 ObjectName 的键属性列表中的键，并且每个值都是与键关联的值。

返回值可以是不可修改的。如果是可修改的，则更改它对此 ObjectName 没有影响。

返回：
键属性表。

getKeyPropertyListString

public String getKeyPropertyListString()

返回创建时指定的键属性列表的字符串表示形式。如果使用构造方法 ObjectName(String) 构造了此 ObjectName，则返回 String 中的键属性顺序与该构造方法参数中的顺序相同。

返回：
键属性列表字符串。此字符串与 ObjectName 是否为模式无关。

getCanonicalKeyPropertyListString

public String getCanonicalKeyPropertyListString()
返回键属性列表的字符串表示形式，其中键属性按词汇顺序排序。为了根据 MBean 的键属性列表来选择 MBean，在执行字典式比较中使用此方法。词汇顺序就是 String.compareTo(String) 所暗指的顺序。

返回：
规范的键属性列表字符串。此字符串与 ObjectName 是否为模式无关。

toString

public String toString()

返回该对象名的字符串表示形式。未指定此字符串的格式，但是当且仅当两个 ObjectName 相等时才会返回相同的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象名的字符串表示形式。

equals

public boolean equals(Object object)
比较当前的对象名与另一个对象名是否相等。当且仅当两个 ObjectName 实例的规范形式相等时它们才相等。规范形式是 getCanonicalName() 所描述的字符串。

覆盖：
类 Object 中的 equals
参数：
object - 要与当前对象名进行比较的对象名。
返回：
如果 object 是一个 ObjectName 并且其规范形式与此 ObjectName 的规范形式相同，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 ObjectName 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

quote

public static String quote(String s)
                    throws NullPointerException

返回给定 String 的有引号形式，使之适合包含在 ObjectName 中。返回的值可用作与 ObjectName 中某个键相关联的值。String s 可包含任何字符。适当使用引号可确保返回的值在 ObjectName 中是合法的。

返回值由引号 ('"')、对应于 s 中字符的字符序列和另一个引号所组成。s 中的字符会不加更改地出现在返回值中，但下列内容除外：

  • 引号 ('"') 被一个反斜线 (\) 后跟一个引号所替换。
  • 星号 ('*') 由一个反斜线 (\) 后跟一个星号所替换。
  • 问号 ('?') 由一个反斜线 (\) 后跟一个问号所替换。
  • 反斜线 ('\') 由两个反斜线所替换
    • 。
  • 换行符（Java 中的 字符 '\n'）由一个反斜线后跟字符 '\n' 所替换。

参数：
S - 要用引号形式表示的 String。
返回：
有引号形式的 String。
抛出：
NullPointerException - 如果 s 为 null。

unquote

public static String unquote(String q)
                      throws IllegalArgumentException,
                             NullPointerException

返回给定 String 的无引号形式，如果 q 是 quote(s) 返回的 String，则 unquote(q).equals(s)。如果没有满足 quote(s).equals(q) 的 String s，则 unquote(q) 抛出 IllegalArgumentException。

这些规则意味着在有引号和无引号形式之间存在一对一的映射关系。

参数：
q - 要用无引号形式表示的 String。
返回：
无引号形式的 String。
抛出：
IllegalArgumentException - 如果不能由 quote(java.lang.String) 方法返回 q，例如它没有以引号 (") 开始和结束。
NullPointerException - 如果 q 为 null。

apply

public boolean apply(ObjectName name)
              throws NullPointerException

测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。如果 name 是一个模式，则结果是 false。如果此 ObjectName 是一个模式，则当且仅当 name 与该模式匹配时结果才是 true。如果此 ObjectName 和 name 都不是模式，则当且仅当两个 ObjectName 按 equals(Object) 方法的描述相等时结果才是 true。

指定者：
接口 QueryExp 中的 apply
参数：
name - 要进行比较的 MBean 名。
返回：
如果 name 与此 ObjectName 匹配，则返回 true。
抛出：
NullPointerException - 如果 name 为 null。

setMBeanServer

public void setMBeanServer(MBeanServer mbs)
从接口 QueryExp 复制的描述
设置将在其上执行查询的 MBean 服务器。

指定者：
接口 QueryExp 中的 setMBeanServer
参数：
mbs - 将在其上执行查询的 MBean 服务器。

compareTo

public int compareTo(ObjectName name)

比较两个 ObjectName 实例。没有完整地指定 ObjectName 之间的顺序关系，但是存储的 ObjectName 列表一般按照便于阅读的顺序出现。

特别要指出的是，如果两个 ObjectName 实例的域不同，则其顺序为域的字典顺序。键属性列表的顺序仍然没有指定。

例如，以下 ObjectName 实例：

  • Shapes:type=Square,name=3
  • Colors:type=Red,name=2
  • Shapes:type=Triangle,side=isosceles,name=2
  • Colors:type=Red,name=1
  • Shapes:type=Square,name=1
  • Colors:type=Blue,name=1
  • Shapes:type=Square,name=2
  • JMImplementation:type=MBeanServerDelegate
  • Shapes:type=Triangle,side=scalene,name=1

将按以下方式排序：

  • Colors:type=Blue,name=1
  • Colors:type=Red,name=1
  • Colors:type=Red,name=2
  • JMImplementation:type=MBeanServerDelegate
  • Shapes:type=Square,name=1
  • Shapes:type=Square,name=2
  • Shapes:type=Square,name=3
  • Shapes:type=Triangle,side=scalene,name=1
  • Shapes:type=Triangle,side=isosceles,name=2

指定者：
接口 Comparable<ObjectName> 中的 compareTo
参数：
name - 要比较的 ObjectName。
返回：
根据此 ObjectName 小于、等于或大于给定 ObjectName 分别返回负整数、零或正整数。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperationsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 OperationsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
所有已实现的接口：
Serializable
直接已知子类：
AttributeNotFoundException, InstanceAlreadyExistsException, InstanceNotFoundException, IntrospectionException, InvalidAttributeValueException, ListenerNotFoundException, MalformedObjectNameException, NotCompliantMBeanException, ServiceNotFoundException
public class OperationsException
extends JMException

表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
OperationsException()
默认的构造方法。
OperationsException(String message)
允许指定具体错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OperationsException

public OperationsException()
默认的构造方法。

OperationsException

public OperationsException(String message)
允许指定具体错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PersistentMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 PersistentMBean

所有已知子接口：
ModelMBean
所有已知实现类：
RequiredModelMBean
public interface PersistentMBean

此类是一个由希望是持久性的 MBean 实现的接口。在构造期间，支持此接口的 MBean 必须调用加载方法，以便为构造准备好持久存储中的 MBean。对于 ModelMBean 来说，必须基于 ModelMBean 中的描述符由 MBeanServer 调用 store 方法，或者在常规处理 ModelMBean 期间由 MBean 自身调用。

从以下版本开始：
1.5

方法摘要
void | load() 使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
void | store() 捕获此 MBean 实例的当前状态并将其写出到持久存储中。

方法详细信息

load

void load()
          throws MBeanException,
                 RuntimeOperationsException,
                 InstanceNotFoundException
使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。加载的数据可以包括属性和操作值。 必须在构造或初始化此实例期间以及在 MBean 向 MBeanServer 注册之前调用此方法。

抛出：
MBeanException - 包装另一个异常或不受支持的持久性
RuntimeOperationsException - 包装持久性机制中的异常
InstanceNotFoundException - 无法从持久存储中找到或加载此 MBean

store

void store()
           throws MBeanException,
                  RuntimeOperationsException,
                  InstanceNotFoundException
捕获此 MBean 实例的当前状态并将其写出到持久存储中。存储的状态可以包括属性和操作值。如果这些持久方法中有一种不受支持，则将抛出 "serviceNotFound" 异常。

MBean 和属性描述符中的持久策略可用来控制此方法的异常。如果 'persistPolicy' 字段是如下形式，则必须存储 MBean：

  != "never"
   = "always"
   = "onTimer" and now > 'lastPersistTime' + 'persistPeriod'
   = "NoMoreOftenThan" and now > 'lastPersistTime' + 'persistPeriod'
   = "onUnregister"

 Do not store the MBean if 'persistPolicy' field is:
    = "never"
    = "onUpdate"
    = "onTimer" && now < 'lastPersistTime' + 'persistPeriod'

抛出：
MBeanException - 包装另一个异常或不受支持的持久性
RuntimeOperationsException - 包装持久性机制中的异常
InstanceNotFoundException - 无法查找/访问持久存储
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Query (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 Query

java.lang.Object
    继承者  javax.management.Query

public class Query
extends Object

构造查询对象约束。提供的 static 方法返回可用来列出和枚举 MBean 的查询表达式。每种约束构造方法仅允许使用适当的类型作为参数。如下例所述，混合调用可以构造约束的随意嵌套：

 QueryExp exp = Query.and(Query.gt(Query.attr("age"),Query.value(5)),
                          Query.match(Query.attr("name"),
                                      Query.value("Smith")));

从以下版本开始：
1.5

字段摘要
static int | DIV 表示 div(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
static int | EQ 表示 eq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
static int | GE 表示 geq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
static int | GT 表示 gt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
static int | LE 表示 leq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
static int | LT 表示 lt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。
static int | MINUS 表示 minus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
static int | PLUS 表示 plus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
static int | TIMES 表示 times(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。
构造方法摘要
Query()
基本构造方法。
方法摘要
static QueryExp | and(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“与”。
static QueryExp | anySubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static AttributeValueExp | attr(String name) 返回新的属性表达式。
static AttributeValueExp | attr(String className, String name) 返回新的限定属性表达式。
static QueryExp | between(ValueExp v1, ValueExp v2, ValueExp v3) 返回一个查询表达式，表示一个值在其他两个值之间的约束条件。
static AttributeValueExp | classattr() 返回一个新的类属性表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | div(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的商。
static QueryExp | eq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的等于约束条件。
static QueryExp | finalSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | geq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。
static QueryExp | gt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于”约束条件。
static QueryExp | in(ValueExp val, ValueExp[] valueList) 返回一个表达式，限制某个值为显式列表中的一项。
static QueryExp | initialSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | isInstanceOf(StringValueExp classNameValue) 返回一个查询表达式，表示基于 MBean 类的继承约束条件。
static QueryExp | leq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。
static QueryExp | lt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示 基于两个值的“小于”约束条件。
static QueryExp | match(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的匹配约束条件。
static ValueExp | minus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的差。
static QueryExp | not(QueryExp queryExp) 返回一个与其参数相反的约束条件。
static QueryExp | or(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“或”。
static ValueExp | plus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。
static ValueExp | times(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的乘积。
static ValueExp | value(boolean val) 返回一个 boolean 值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | value(double val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | value(float val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | value(int val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | value(long val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | value(Number val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static StringValueExp | value(String val) 返回一个新的字符串表达式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GT

public static final int GT
表示 gt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

LT

public static final int LT
表示 lt(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

GE

public static final int GE
表示 geq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

LE

public static final int LE
表示 leq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

EQ

public static final int EQ
表示 eq(javax.management.ValueExp, javax.management.ValueExp) 查询的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

PLUS

public static final int PLUS
表示 plus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

MINUS

public static final int MINUS
表示 minus(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

TIMES

public static final int TIMES
表示 times(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值

DIV

public static final int DIV
表示 div(javax.management.ValueExp, javax.management.ValueExp) 表达式的代码。此方法主要用于序列化形式的查询。

另请参见：
常量字段值
构造方法详细信息

Query

public Query()
基本构造方法。

方法详细信息

and

public static QueryExp and(QueryExp q1,
                           QueryExp q2)
返回一个查询表达式，它是其他两个查询表达式的“与”。

参数：
q1 - 查询表达式。
q2 - 另一个查询表达式。
返回：
两个参数的“与”。返回对象将被序列化为非公共类 javax.management.AndQueryExp 的实例。

or

public static QueryExp or(QueryExp q1,
                          QueryExp q2)
返回一个查询表达式，它是其他两个查询表达式的“或”。

参数：
q1 - 查询表达式。
q2 - 另一个查询表达式。
返回：
两个参数的“或”。返回对象将被序列化为非公共类 javax.management.OrQueryExp 的实例。

gt

public static QueryExp gt(ValueExp v1,
                          ValueExp v2)
返回一个查询表达式，表示基于两个值的“大于”约束条件。

参数：
v1 - 值表达式。
v2 - 另一个值表达式。
返回：
基于参数的“大于”约束条件。返回对象将被序列化为非公共类 javax.management.BinaryRelQueryExp 的实例，其中 relOp 等于 GT。

geq

public static QueryExp geq(ValueExp v1,
                           ValueExp v2)
返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。

参数：
v1 - 值表达式。
v2 - 另一个值表达式。
返回：
基于参数的“大于或等于”约束条件。返回对象将被序列化为非公共类 javax.management.BinaryRelQueryExp 的实例，其中 relOp 等于 GE。

leq

public static QueryExp leq(ValueExp v1,
                           ValueExp v2)
返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。

参数：
v1 - 值表达式。
v2 - 另一个值表达式。
返回：
基于参数的“小于或等于”约束条件。返回对象将被序列化为非公共类 javax.management.BinaryRelQueryExp 的实例，其中 relOp 等于 LE。

lt

public static QueryExp lt(ValueExp v1,
                          ValueExp v2)
返回一个查询表达式，表示 基于两个值的“小于”约束条件。

参数：
v1 - 值表达式。
v2 - 另一个值表达式。
返回：
基于参数的“小于”约束条件。返回对象将被序列化为非公共类 javax.management.BinaryRelQueryExp 的实例，其中 relOp 等于 LT。

eq

public static QueryExp eq(ValueExp v1,
                          ValueExp v2)
返回一个查询表达式，表示基于两个值的等于约束条件。

参数：
v1 - 值表达式。
v2 - 另一个值表达式。
返回：
基于参数的“等于”约束条件。返回对象将被序列化为非公共类 javax.management.BinaryRelQueryExp 的实例，其中 relOp 等于 EQ。

between

public static QueryExp between(ValueExp v1,
                               ValueExp v2,
                               ValueExp v3)
返回一个查询表达式，表示一个值在其他两个值之间的约束条件。

参数：
v1 - 在 v2 和 v3“之间”的值表达式。
v2 - 表示约束条件范围的值表达式。
v3 - 表示约束条件范围的值表达式。
返回：
v1 在 v2 和 v3 之间的约束条件。返回对象将被序列化为非公共类 javax.management.BetweenQueryExp 的实例。

match

public static QueryExp match(AttributeValueExp a,
                             StringValueExp s)
返回一个查询表达式，表示基于字符串参数的匹配约束条件。匹配的语法与文件 globbing 一致：支持 "?"、"*" 和 "["，其中的每一项都可以使用 "\" 转义；字符类可以使用 "!" 来否定，使用 "-" 来划定范围。(* 用于任何字符序列，? 用于任意单个字符，[...] 用于字符序列）。例如：与 a*b?c 匹配的将是以字符 a 开头，后跟任意数量的字符，再接 b、任意单个字符，然后接 c 的一个字符串。

参数：
a - 属性表达式
s - 表示匹配约束条件的字符串值表达式
返回：
一个查询表达式，表示基于字符串参数的匹配约束条件。返回对象将被序列化为非公共类 javax.management.MatchQueryExp 的实例。

attr

public static AttributeValueExp attr(String name)

返回新的属性表达式。

针对给定的 objectName 计算此表达式，包括执行 MBeanServer.getAttribute（objectName、name）。

参数：
name - 属性的名称。
返回：
指定名称的属性的属性表达式。

attr

public static AttributeValueExp attr(String className,
                                     String name)

返回新的限定属性表达式。

针对给定的 objectName 计算此表达式，包括执行 MBeanServer.getObjectInstance(objectName) 和 MBeanServer.getAttribute（objectName、name）。

参数：
className - 拥有属性的类的名称。
name - 属性的名称。
返回：
指定名称的属性的属性表达式。返回对象将被序列化为非公共类 javax.management.QualifiedAttributeValueExp 的实例。

classattr

public static AttributeValueExp classattr()

返回一个新的类属性表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

针对给定的 objectName 计算此表达式，包括执行 MBeanServer.getObjectInstance(objectName)。

返回：
类属性表达式。返回对象将被序列化为非公共类 javax.management.ClassAttributeValueExp 的实例。

not

public static QueryExp not(QueryExp queryExp)
返回一个与其参数相反的约束条件。

参数：
queryExp - 将要“求反”的约束条件。
返回：
已“求反”的约束条件。返回对象将被序列化为非公共类 javax.management.NotQueryExp 的实例。

in

public static QueryExp in(ValueExp val,
                          ValueExp[] valueList)
返回一个表达式，限制某个值为显式列表中的一项。

参数：
val - 要限制的值。
valueList - ValueExp 数组。
返回：
一个表示约束条件的 QueryExp。返回对象将被序列化为非公共类 javax.management.InQueryExp 的实例。

value

public static StringValueExp value(String val)
返回一个新的字符串表达式。

参数：
val - 字符串值。
返回：
包含字符串参数的 ValueExp 对象。

value

public static ValueExp value(Number val)
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数：
val - Number 的实例。
返回：
包含参数的 ValueExp 对象。返回对象将被序列化为非公共类 javax.management.NumericValueExp 的实例。

value

public static ValueExp value(int val)
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数：
val - 一个 int 值。
返回：
包含参数的 ValueExp 对象。返回对象将被序列化为非公共类 javax.management.NumericValueExp 的实例。

value

public static ValueExp value(long val)
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数：
val - 一个 long 值。
返回：
包含参数的 ValueExp 对象。返回对象将被序列化为非公共类 javax.management.NumericValueExp 的实例。

value

public static ValueExp value(float val)
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数：
val - 一个 float 值。
返回：
包含参数的 ValueExp 对象。返回对象将被序列化为非公共类 javax.management.NumericValueExp 的实例。

value

public static ValueExp value(double val)
返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数：
val - 一个 double 值。
返回：
包含参数的 ValueExp 对象。返回对象将被序列化为非公共类 javax.management.NumericValueExp 的实例。

value

public static ValueExp value(boolean val)
返回一个 boolean 值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数：
val - 一个 boolean 值。
返回：
包含参数的 ValueExp 对象。返回对象将被序列化为非公共类 javax.management.BooleanValueExp 的实例。

plus

public static ValueExp plus(ValueExp value1,
                            ValueExp value2)
返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。

参数：
value1 - 第一个 '+' 操作数。
value2 - 第二个 '+' 操作数。
返回：
表示两个参数的和或者它们的串接的 ValueExp。返回对象将被序列化为非公共类 javax.management.BinaryOpValueExp 的实例，其中 op 等于 PLUS。

times

public static ValueExp times(ValueExp value1,
                             ValueExp value2)
返回一个二进制表达式，表示两个数值的乘积。

参数：
value1 - 第一个 '*' 操作数。
value2 - 第二个 '*' 操作数。
返回：
表示乘积的 ValueExp。返回对象将被序列化为非公共类 javax.management.BinaryOpValueExp 的实例，其中 op 等于 TIMES。

minus

public static ValueExp minus(ValueExp value1,
                             ValueExp value2)
返回一个二进制表达式，表示两个数值的差。

参数：
value1 - 第一个 '-' 操作数。
value2 - 第二个 '-' 操作数。
返回：
表示两个参数的差的 ValueExp。返回对象将被序列化为非公共类 javax.management.BinaryOpValueExp 的实例，其中 op 等于 MINUS。

div

public static ValueExp div(ValueExp value1,
                           ValueExp value2)
返回一个二进制表达式，表示两个数值的商。

参数：
value1 - 第一个 '/' 操作数。
value2 - 第二个 '/' 操作数。
返回：
表示两个参数的商的 ValueExp。返回对象将被序列化为非公共类 javax.management.BinaryOpValueExp 的实例，其中 op 等于 DIV。

initialSubString

public static QueryExp initialSubString(AttributeValueExp a,
                                        StringValueExp s)
返回一个查询表达式，表示基于字符串参数的约束条件。该值必须以给定的字面值字符串值开头。

参数：
a - 属性表达式。
s - 表示以字符串值开头的字符串值表达式。
返回：
a 与 s 匹配这一约束条件。返回对象将被序列化为非公共类 javax.management.MatchQueryExp 的实例。

anySubString

public static QueryExp anySubString(AttributeValueExp a,
                                    StringValueExp s)
返回一个查询表达式，表示基于字符串参数的约束条件。该值必须包含给定的字符串值。

参数：
a - 属性表达式。
s - 表示子字符串的字符串值表达式。
返回：
a 与 s 匹配这一约束条件。返回对象将被序列化为非公共类 javax.management.MatchQueryExp 的实例。

finalSubString

public static QueryExp finalSubString(AttributeValueExp a,
                                      StringValueExp s)
返回一个查询表达式，表示基于字符串参数的约束条件。该值必须包含给定的字面值字符串值。

参数：
a - 属性表达式。
s - 表示以字符串值结束的字符串值表达式。
返回：
a 与 s 匹配这一约束条件。返回对象将被序列化为非公共类 javax.management.MatchQueryExp 的实例。

isInstanceOf

public static QueryExp isInstanceOf(StringValueExp classNameValue)
返回一个查询表达式，表示基于 MBean 类的继承约束条件。

示例：要找到作为 NotificationBroadcaster 实例的 MBean，使用 Query.isInstanceOf(Query.value(NotificationBroadcaster.class.getName()))。

针对给定的 objectName 计算此表达式，包括执行 MBeanServer.isInstanceOf(objectName, ((StringValueExp)classNameValue.apply(objectName)).getValue()。

参数：
classNameValue - StringValueExp，返回所选 MBean 应该是一个实例的类的名称。
返回：
一个查询表达式，表示基于 MBean 类的继承约束条件。返回对象将被序列化为非公共类 javax.management.InstanceOfQueryExp 的实例。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


QueryEval (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 QueryEval

java.lang.Object
    继承者  javax.management.QueryEval
所有已实现的接口：
Serializable
public abstract class QueryEval
extends Object
implements Serializable

允许在特定的 MBean 服务器上下文中执行查询。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
QueryEval()
方法摘要
static MBeanServer | getMBeanServer() 返回此线程最近一次提供给 setMBeanServer 方法的 MBean 服务器。
void | setMBeanServer(MBeanServer s) 设置将在其上执行查询的 MBean 服务器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

QueryEval

public QueryEval()
方法详细信息

setMBeanServer

public void setMBeanServer(MBeanServer s)

设置将在其上执行查询的 MBean 服务器。该设置对于执行该设置的线程有效。在线程创建期间，它被复制到由该线程创建的任何线程。

由于历史原因，此方法不是静态的，但是其行为不依赖于调用它的实例。

参数：
s - 将在其上执行查询的 MBean 服务器。
另请参见：
getMBeanServer()

getMBeanServer

public static MBeanServer getMBeanServer()

返回此线程最近一次提供给 setMBeanServer 方法的 MBean 服务器。如果此线程从未调用过该方法，则结果将是创建此线程时其父线程从 getMBeanServer 中获得的值，如果没有父线程，则结果将为 null。

返回：
MBean 服务器。
另请参见：
setMBeanServer(javax.management.MBeanServer)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


QueryExp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 QueryExp

所有超级接口：
Serializable
所有已知实现类：
ObjectName
public interface QueryExp
extends Serializable

表示可在数据库查询“where 子句”中使用的相关约束。QueryExp 实例将由 Query 类的静态方法返回。

可以通过实现此接口创建自定义查询，但不建议使用。创建自定义查询最好扩展 QueryEval 类，而不是直接实现该接口，以便 setMBeanServer(javax.management.MBeanServer) 方法能够正确运行。

从以下版本开始：
1.5

方法摘要
boolean | apply(ObjectName name) 在 MBean 上应用 QueryExp。
void | setMBeanServer(MBeanServer s) 设置将在其上执行查询的 MBean 服务器。

方法详细信息

apply

boolean apply(ObjectName name)
              throws BadStringOperationException,
                     BadBinaryOpValueExpException,
                     BadAttributeValueExpException,
                     InvalidApplicationException
在 MBean 上应用 QueryExp。

参数：
name - 将在其上应用 QueryExp 的 MBean 的名称。
返回：
如果将查询成功应用到了 MBean，则返回 true，否则返回 false。
抛出：
BadStringOperationException
BadBinaryOpValueExpException
BadAttributeValueExpException
InvalidApplicationException

setMBeanServer

void setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。

参数：
s - 将在其上执行查询的 MBean 服务器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReflectionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 ReflectionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.ReflectionException
所有已实现的接口：
Serializable
public class ReflectionException
extends JMException

表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。它可以“包装”抛出的实际 java.lang.Exception。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ReflectionException(Exception e)
创建包装实际 java.lang.Exception 的 ReflectionException。
ReflectionException(Exception e, String message)
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。
方法摘要
Throwable | getCause() 返回抛出的实际 Exception。
Exception | getTargetException() 返回抛出的实际 Exception。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReflectionException

public ReflectionException(Exception e)
创建包装实际 java.lang.Exception 的 ReflectionException。

参数：
e - 包装的异常。

ReflectionException

public ReflectionException(Exception e,
                           String message)
创建包装带有详细消息的实际 java.lang.Exception 的 ReflectionException。

参数：
e - 包装的异常。
message - 详细消息。
方法详细信息

getTargetException

public Exception getTargetException()
返回抛出的实际 Exception。

返回：
包装的 Exception。

getCause

public Throwable getCause()
返回抛出的实际 Exception。

覆盖：
类 Throwable 中的 getCause
返回：
包装的 Exception。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RuntimeErrorException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 RuntimeErrorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.management.JMRuntimeException
                    继承者  javax.management.RuntimeErrorException
所有已实现的接口：
Serializable
public class RuntimeErrorException
extends JMRuntimeException

当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RuntimeErrorException(Error e)
默认的构造方法。
RuntimeErrorException(Error e, String message)
允许指定特定错误消息的构造方法。
方法摘要
Throwable | getCause() 返回抛出的实际 Error。
Error | getTargetError() 返回抛出的实际 Error。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RuntimeErrorException

public RuntimeErrorException(Error e)
默认的构造方法。

参数：
e - 包装的错误。

RuntimeErrorException

public RuntimeErrorException(Error e,
                             String message)
允许指定特定错误消息的构造方法。

参数：
e - 包装的错误。
message - 详细消息。
方法详细信息

getTargetError

public Error getTargetError()
返回抛出的实际 Error。

返回：
包装的 Error。

getCause

public Throwable getCause()
返回抛出的实际 Error。

覆盖：
类 Throwable 中的 getCause
返回：
包装的 Error。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RuntimeMBeanException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 RuntimeMBeanException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.management.JMRuntimeException
                    继承者  javax.management.RuntimeMBeanException
所有已实现的接口：
Serializable
public class RuntimeMBeanException
extends JMRuntimeException

表示由代理中的 MBean 方法抛出的运行时异常。它“包装”抛出的实际 java.lang.RuntimeException 异常。此异常将由 MBeanServer 在调用 MBean 方法抛出运行时异常时构建。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RuntimeMBeanException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeMBeanException。
RuntimeMBeanException(RuntimeException e, String message)
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。
方法摘要
Throwable | getCause() 返回抛出的实际 RuntimeException。
RuntimeException | getTargetException() 返回抛出的实际 RuntimeException。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RuntimeMBeanException

public RuntimeMBeanException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeMBeanException。

参数：
e - 包装的异常。

RuntimeMBeanException

public RuntimeMBeanException(RuntimeException e,
                             String message)
创建带有详细信息的实际 java.lang.RuntimeException 的 RuntimeMBeanException。

参数：
e - 包装的异常。
message - 详细消息。
方法详细信息

getTargetException

public RuntimeException getTargetException()
返回抛出的实际 RuntimeException。

返回：
包装的 RuntimeException。

getCause

public Throwable getCause()
返回抛出的实际 RuntimeException。

覆盖：
类 Throwable 中的 getCause
返回：
包装的 RuntimeException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RuntimeOperationsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 RuntimeOperationsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.management.JMRuntimeException
                    继承者  javax.management.RuntimeOperationsException
所有已实现的接口：
Serializable
public class RuntimeOperationsException
extends JMRuntimeException

表示在 MBean 上执行操作时代理中抛出的运行时异常。它包装抛出的实际 java.lang.RuntimeException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RuntimeOperationsException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeOperationsException。
RuntimeOperationsException(RuntimeException e, String message)
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。
方法摘要
Throwable | getCause() 返回抛出的实际 RuntimeException。
RuntimeException | getTargetException() 返回抛出的实际 RuntimeException。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RuntimeOperationsException

public RuntimeOperationsException(RuntimeException e)
创建包装实际 java.lang.RuntimeException 的 RuntimeOperationsException。

参数：
e - 包装的异常。

RuntimeOperationsException

public RuntimeOperationsException(RuntimeException e,
                                  String message)
创建包装带有详细信息的实际 java.lang.RuntimeException 的 RuntimeOperationsException。

参数：
e - 包装的异常。
message - 详细消息。
方法详细信息

getTargetException

public RuntimeException getTargetException()
返回抛出的实际 RuntimeException。

返回：
包装的 RuntimeException。

getCause

public Throwable getCause()
返回抛出的实际 RuntimeException。

覆盖：
类 Throwable 中的 getCause
返回：
包装的 RuntimeException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 ServiceNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.OperationsException
                    继承者  javax.management.ServiceNotFoundException
所有已实现的接口：
Serializable
public class ServiceNotFoundException
extends OperationsException

表示请求的服务不受支持时引发的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ServiceNotFoundException()
默认的构造方法。
ServiceNotFoundException(String message)
允许指定特定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServiceNotFoundException

public ServiceNotFoundException()
默认的构造方法。

ServiceNotFoundException

public ServiceNotFoundException(String message)
允许指定特定错误消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StandardEmitterMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 StandardEmitterMBean

java.lang.Object
    继承者  javax.management.StandardMBean
        继承者  javax.management.StandardEmitterMBean
所有已实现的接口：
DynamicMBean, MBeanRegistration, NotificationBroadcaster, NotificationEmitter
public class StandardEmitterMBean
extends StandardMBean
implements NotificationEmitter

一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

以下示例显示了如何使用公共构造方法 StandardEmitterMBean(implementation, mbeanInterface, emitter) 创建一个 MBean，使之能使用实现类名称 Impl、接口 Intf（对于当前标准 MBean）定义的管理接口，以及接口 NotificationEmitter 的实现来发送消息。该示例使用类 NotificationBroadcasterSupport 作为接口 NotificationEmitter 的实现。

     MBeanServer mbs;
     ...
     final String[] types = new String[] {"sun.disc.space","sun.disc.alarm"};
     final MBeanNotificationInfo info = new MBeanNotificationInfo(
                                          types,
                                          Notification.class.getName(),
                                          "Notification about disc info.");
     final NotificationEmitter emitter =
                    new NotificationBroadcasterSupport(info);

     final Intf impl = new Impl(...);
     final Object mbean = new StandardEmitterMBean(
                                     impl, Intf.class, emitter);
     mbs.registerMBean(mbean, objectName);

从以下版本开始：
1.6
另请参见：
StandardMBean

构造方法摘要
protected | StandardEmitterMBean(Class<?> mbeanInterface, boolean isMXBean, NotificationEmitter emitter) 构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
protected | StandardEmitterMBean(Class<?> mbeanInterface, NotificationEmitter emitter) 构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
 | StandardEmitterMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean, NotificationEmitter emitter) 构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
 | StandardEmitterMBean(T implementation, Class<T> mbeanInterface, NotificationEmitter emitter) 构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
方法摘要
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
void | removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。
void | removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | sendNotification(Notification n) 发送通知。
从类 javax.management.StandardMBean 继承的方法
cacheMBeanInfo, getAttribute, getAttributes, getCachedMBeanInfo, getClassName, getConstructors, getDescription, getDescription, getDescription, getDescription, getDescription, getDescription, getDescription, getImpact, getImplementation, getImplementationClass, getMBeanInfo, getMBeanInterface, getParameterName, getParameterName, invoke, postDeregister, postRegister, preDeregister, preRegister, setAttribute, setAttributes, setImplementation
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StandardEmitterMBean

public StandardEmitterMBean(T implementation,
                            Class<T> mbeanInterface,
                            NotificationEmitter emitter)

构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。结果 MBean 通过将其方法转发给 emitter 来实现 NotificationEmitter 接口。这是合法的，并且在将 implementation 和 emitter 用于相同对象时很有用。

如果 emitter 是 NotificationBroadcasterSupport 的实例，则该 MBean 的 sendNotification 方法将调用 emitter. sendNotification。

由新 MBean 上的 getNotificationInfo() 返回的数组是进行构造时由 emitter. getNotificationInfo() 返回的数组的副本。如果由 emitter.getNotificationInfo() 返回的数组之后发生变化，那么这种变化不会影响到此对象的 getNotificationInfo()。

参数：
implementation - MBean 接口的实现。
mbeanInterface - Standard MBean 接口。
emitter - 将处理通知的对象。
抛出：
IllegalArgumentException - 如果 mbeanInterface 不遵守管理接口的 JMX 设计模式，或者给定的 implementation 没有实现指定的接口，抑或 emitter 为 null。

StandardEmitterMBean

public StandardEmitterMBean(T implementation,
                            Class<T> mbeanInterface,
                            boolean isMXBean,
                            NotificationEmitter emitter)

构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。此构造方法可以用于构造 Standard MBean 或 MXBean。结果 MBean 通过将其方法转发给 emitter 来实现 NotificationEmitter 接口。这是合法的，并且在将 implementation 和 emitter 用于相同对象时很有用。

如果 emitter 是 NotificationBroadcasterSupport 的实例，则该 MBean 的 sendNotification 方法将调用 emitter. sendNotification。

由新 MBean 上的 getNotificationInfo() 返回的数组是进行构造时由 emitter. getNotificationInfo() 返回的数组的副本。如果由 emitter.getNotificationInfo() 返回的数组之后发生变化，那么这种变化不会影响到此对象的 getNotificationInfo()。

参数：
implementation - MBean 接口的实现。
mbeanInterface - Standard MBean 接口。
isMXBean - 如果为 true，则 mbeanInterface 参数会对 MXBean 接口进行命名，并且结果 MBean 是一个 MXBean。
emitter - 将处理通知的对象。
抛出：
IllegalArgumentException - 如果 mbeanInterface 不遵守管理接口的 JMX 设计模式，或者给定的 implementation 没有实现指定的接口，抑或 emitter 为 null。

StandardEmitterMBean

protected StandardEmitterMBean(Class<?> mbeanInterface,
                               NotificationEmitter emitter)

构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。结果 MBean 通过将其方法转发给 emitter 来实现 NotificationEmitter 接口。

如果 emitter 是 NotificationBroadcasterSupport 的实例，则该 MBean 的 sendNotification 方法将调用 emitter. sendNotification。

由新 MBean 上的 getNotificationInfo() 返回的数组是进行构造时由 emitter. getNotificationInfo() 返回的数组的副本。如果由 emitter.getNotificationInfo() 返回的数组之后发生变化，那么这种变化不会影响到此对象的 getNotificationInfo()。

此构造方法必须从实现给定 mbeanInterface 的子类调用。

参数：
mbeanInterface - StandardMBean 接口。
emitter - 将处理通知的对象。
抛出：
IllegalArgumentException - 如果 mbeanInterface 不遵守管理接口的 JMX 设计模式，或者给定的 this 没有实现指定的接口，抑或 emitter 为 null。

StandardEmitterMBean

protected StandardEmitterMBean(Class<?> mbeanInterface,
                               boolean isMXBean,
                               NotificationEmitter emitter)

构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。此构造方法可以用于构造 Standard MBean 或 MXBean。结果 MBean 通过将其方法转发给 emitter 来实现 NotificationEmitter 接口。

如果 emitter 是 NotificationBroadcasterSupport 的实例，则该 MBean 的 sendNotification 方法将调用 emitter. sendNotification。

由新 MBean 上的 getNotificationInfo() 返回的数组是进行构造时由 emitter. getNotificationInfo() 返回的数组的副本。如果由 emitter.getNotificationInfo() 返回的数组之后发生变化，那么这种变化不会影响到此对象的 getNotificationInfo()。

此构造方法必须从实现给定 mbeanInterface 的子类调用。

参数：
mbeanInterface - StandardMBean 接口。
isMXBean - 如果为 true，则 mbeanInterface 参数会对 MXBean 接口进行命名，并且结果 MBean 是一个 MXBean。
emitter - 将处理通知的对象。
抛出：
IllegalArgumentException - 如果 mbeanInterface 不遵守管理接口的 JMX 设计模式，或者给定的 this 没有实现指定的接口，抑或 emitter 为 null。
方法详细信息

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
从接口 NotificationBroadcaster 复制的描述
从此 MBean 移除一个侦听器。如果已向不同的 handback 对象或通知过滤器注册了该侦听器，则移除与该侦听器有关的所有项。

指定者：
接口 NotificationBroadcaster 中的 removeNotificationListener
参数：
listener - 以前添加到此 MBean 中的侦听器。
抛出：
ListenerNotFoundException - 如果没有在 MBean 中注册该侦听器。
另请参见：
NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException
从接口 NotificationEmitter 复制的描述

从此 MBean 移除一个侦听器。该 MBean 必须有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果有多个此类侦听器，则只移除一个侦听器。

当且仅当在要移除的侦听器中 filter 和 handback 参数为 null 时，这两个参数才可以为 null。

指定者：
接口 NotificationEmitter 中的 removeNotificationListener
参数：
listener - 以前添加到此 MBean 中的侦听器。
filter - 添加侦听器时指定的过滤器。
handback - 添加侦听器时指定的回送。
抛出：
ListenerNotFoundException - 如果没有在该 MBean 中注册侦听器，或者没有用给定的过滤器和回送注册它。

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
从接口 NotificationBroadcaster 复制的描述
在此 MBean 中添加一个侦听器。

指定者：
接口 NotificationBroadcaster 中的 addNotificationListener
参数：
listener - 将处理广播者发出的通知的侦听器对象。
filter - 过滤器对象。如果 filter 为 null，则处理通知前不执行过滤。
handback - 发出通知时要发送回侦听器的不透明对象。Notification 广播者对象不能使用此对象。应该将通知不作更改地重新发送到侦听器。
另请参见：
NotificationBroadcaster.removeNotificationListener(javax.management.NotificationListener)

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
从接口 NotificationBroadcaster 复制的描述

返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。

MBean 发送此数组中未描述的通知是合法的。但是，某些 MBean 服务器的客户端要想正常运行，可能要依赖完整的数组。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
返回：
可能的通知数组。

sendNotification

public void sendNotification(Notification n)

发送通知。

如果构造方法的 emitter 参数是一个 NotificationBroadcasterSupport 实例，则此方法将调用 emitter. sendNotification。

参数：
n - 要发送的通知。
抛出：
ClassCastException - 如果构造方法的 emitter 参数不是 NotificationBroadcasterSupport。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StandardMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 StandardMBean

java.lang.Object
    继承者  javax.management.StandardMBean
所有已实现的接口：
DynamicMBean, MBeanRegistration
直接已知子类：
StandardEmitterMBean
public class StandardMBean
extends Object
implements DynamicMBean, MBeanRegistration

一个管理接口由 Java 接口上的反射确定的 MBean。

在 Standard MBean 的使用中，此类为“管理接口”这一概念提供了更多灵活性。直接使用 JMX 规范中介绍的 Standard MBean 模式意味着在 MBean 的实现类与其管理接口之间存在着固定的关系（即如果实现类是 Thing，则管理接口必须是 ThingMBean）。此类能够保留指定带有 Java 接口的管理接口这一便捷性，同时无需在实现与接口类之间存在任何命名关系。

通过从 MBean 中生成 DynamicMBean，此类能够选择任何由 MBean 实现的接口作为其管理接口，但前提是它必须遵守 JMX 模式（即由获取方法/设置方法等定义的属性）。

此类还提供了一些钩子，从而能够为由 DynamicMBean 接口返回的 MBeanInfo 提供自定义描述和名称。

通过使用此类，可以使用以下两种常规方法之一创建 MBean，使用任何实现类名 Impl、由任何接口 Intf 定义的管理接口（就当前 Standard MBean 而言）作为参数：

  • 使用公共构造方法 StandardMBean（impl、interface）：
         MBeanServer mbs;
     ...
     Impl impl = new Impl(...);
     StandardMBean mbean = new StandardMBean(impl, Intf.class, false);
     mbs.registerMBean(mbean, objectName);
  • 创建 StandardMBean 子类：
         public class Impl extends StandardMBean implements Intf {
        public Impl() {
         super(Intf.class, false);
       }
       // implement methods of Intf
     }

     [...]

     MBeanServer mbs;
     ....
     Impl impl = new Impl();
     mbs.registerMBean(impl, objectName);

在任何一种情况下，类 Impl 都必须实现接口 Intf。

当然，基于实现和接口类之间的命名关系的 Standard MBean 仍然可用。

此类也可以用来构造 MXBean。用法与构造 Standard MBean 完全相同，唯一的不同之处在于，上例中的构造方法或 super(...) 调用使用的是 false 参数，而不是 true 参数。

从以下版本开始：
1.5

构造方法摘要
protected | StandardMBean(Class<?> mbeanInterface) 使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
protected | StandardMBean(Class<?> mbeanInterface, boolean isMXBean) 使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
 | StandardMBean(T implementation, Class<T> mbeanInterface) 使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
 | StandardMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean) 使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。
方法摘要
protected void | cacheMBeanInfo(MBeanInfo info) 自定义钩子：缓存为此对象构建的 MBeanInfo。
Object | getAttribute(String attribute) 获得 Dynamic MBean 的特定属性的值。
AttributeList | getAttributes(String[] attributes) 获得 Dynamic MBean 多个属性的值。
protected MBeanInfo | getCachedMBeanInfo() 自定义钩子：返回为此对象缓存的 MBeanInfo。
protected String | getClassName(MBeanInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。
protected MBeanConstructorInfo[] | getConstructors(MBeanConstructorInfo[] ctors, Object impl) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。
protected String | getDescription(MBeanAttributeInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。
protected String | getDescription(MBeanConstructorInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。
protected String | getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
protected String | getDescription(MBeanFeatureInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。
protected String | getDescription(MBeanInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。
protected String | getDescription(MBeanOperationInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。
protected String | getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
protected int | getImpact(MBeanOperationInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的操作的 impact 标志。
Object | getImplementation() 获取此 Standard MBean（或 MXBean）的实现。
Class<?> | getImplementationClass() 获取此 Standard MBean（或 MXBean）的实现类。
MBeanInfo | getMBeanInfo() 获取此 MBean 的 MBeanInfo。
Class<?> | getMBeanInterface() 获取此 Standard MBean（或 MXBean）的管理接口。
protected String | getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。
protected String | getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。
Object | invoke(String actionName, Object[] params, String[] signature) 允许在 Dynamic MBean 上调用某个操作。
void | postDeregister() 允许 MBean 在 MBean 服务器中取消注册后执行任何它所需要的操作。
void | postRegister(Boolean registrationDone) 允许 MBean 在已注册到 MBean 服务器之后或注册已失败之后执行任何它所需要的操作。
void | preDeregister() 允许 MBean 由 MBean 服务器取消注册前执行任何它所需要的操作。
ObjectName | preRegister(MBeanServer server, ObjectName name) 允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。
void | setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
AttributeList | setAttributes(AttributeList attributes) 设置 Dynamic MBean 多个属性的值。
void | setImplementation(Object implementation) 替换包装在此对象中的实现对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StandardMBean

public StandardMBean(T implementation,
                     Class<T> mbeanInterface)
              throws NotCompliantMBeanException

使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。

类型参数：
T - 允许编译器检查 implementation 是否确实实现了 mbeanInterface 描述的类。编译器只在 mbeanInterface 是 MyMBean.class 之类的类字面值时才能进行检查。
参数：
implementation - 此 MBean 的实现。
mbeanInterface - 由此 MBean 实现导出的管理接口。如果为 null，则此对象将使用标准 JMX 设计模式来确定与指定实现关联的管理接口。
抛出：
IllegalArgumentException - 如果给定的 implementation 为 null
NotCompliantMBeanException - 如果 mbeanInterface 不遵守管理接口的 JMX 设计模式，或者给定的 implementation 没有实现指定的接口。

StandardMBean

protected StandardMBean(Class<?> mbeanInterface)
                 throws NotCompliantMBeanException

使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。

调用 this（this、mbeanInterface）。此构造方法是为子类保留的。

参数：
mbeanInterface - 由此 MBean 导出的管理接口。
抛出：
NotCompliantMBeanException - 如果 mbeanInterface 不遵从管理接口的 JMX 设计模式，或者 this 没有实现指定的接口。

StandardMBean

public StandardMBean(T implementation,
                     Class<T> mbeanInterface,
                     boolean isMXBean)

使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。此构造方法可以用来生成 Standard MBean 或 MXBean。与构造方法 StandardMBean(Object, Class) 不同，它不抛出 NotCompliantMBeanException。

类型参数：
T - 允许编译器查看 implementation 是否确实实现了 mbeanInterface 描述的类。编译器只在 mbeanInterface 是 MyMBean.class 之类的类字面值时才能进行检查。
参数：
implementation - 此 MBean 的实现。
mbeanInterface - 由此 MBean 实现导出的管理接口。如果为 null，则此对象将使用标准 JMX 设计模式来确定与指定实现关联的管理接口。
isMXBean - 如果为 true，则 mbeanInterface 参数表示 MXBean 接口，得到的 MBean 是一个 MXBean。
抛出：
IllegalArgumentException - 如果给定的 implementation 为 null；或者 mbeanInterface 不遵守管理接口的 JMX 设计模式；或者给定的 implementation 没有实现指定的接口。
从以下版本开始：
1.6

StandardMBean

protected StandardMBean(Class<?> mbeanInterface,
                        boolean isMXBean)

使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。此构造方法可以用来生成 Standard MBean 或 MXBean。与构造方法 StandardMBean(Object, Class) 不同，它不抛出 NotCompliantMBeanException。

调用 this(this, mbeanInterface, isMXBean)。此构造方法是为子类保留的。

参数：
mbeanInterface - 由此 MBean 导出的管理接口。
isMXBean - 如果为 true，则 mbeanInterface 参数表示 MXBean 接口，得到的 MBean 是一个 MXBean。
抛出：
IllegalArgumentException - 如果 mbeanInterface 不遵从管理接口的 JMX 设计模式，或者 this 没有实现指定的接口。
从以下版本开始：
1.6
方法详细信息

setImplementation

public void setImplementation(Object implementation)
                       throws NotCompliantMBeanException

替换包装在此对象中的实现对象。

参数：
implementation - 此 Standard MBean（或 MXBean）的新实现。implementation 对象必须实现构造此 StandardMBean 时提供的 Standard MBean（或 MXBean）接口。
抛出：
IllegalArgumentException - 如果给定的 implementation 为 null
NotCompliantMBeanException - 如果给定的 implementation 没有实现构造时提供的 Standard MBean（或 MXBean）接口。
另请参见：
getImplementation()

getImplementation

public Object getImplementation()
获取此 Standard MBean（或 MXBean）的实现。

返回：
此 Standard MBean（或 MXBean）的实现。
另请参见：
setImplementation(java.lang.Object)

getMBeanInterface

public final Class<?> getMBeanInterface()
获取此 Standard MBean（或 MXBean）的管理接口。

返回：
此 Standard MBean（或 MXBean）的管理接口。

getImplementationClass

public Class<?> getImplementationClass()
获取此 Standard MBean（或 MXBean）的实现类。

返回：
此 Standard MBean（或 MXBean）的实现类。

getAttribute

public Object getAttribute(String attribute)
                    throws AttributeNotFoundException,
                           MBeanException,
                           ReflectionException
从接口 DynamicMBean 复制的描述
获得 Dynamic MBean 的特定属性的值。

指定者：
接口 DynamicMBean 中的 getAttribute
参数：
attribute - 要检索的属性名
返回：
所检索属性的值。
抛出：
AttributeNotFoundException
MBeanException - 包装由 MBean 的获取方法所抛出的 java.lang.Exception。
ReflectionException - 包装试图调用获取方法时所抛出的 java.lang.Exception。
另请参见：
DynamicMBean.setAttribute(javax.management.Attribute)

setAttribute

public void setAttribute(Attribute attribute)
                  throws AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
从接口 DynamicMBean 复制的描述
设置 Dynamic MBean 的特定属性的值。

指定者：
接口 DynamicMBean 中的 setAttribute
参数：
attribute - 要设置的属性的标识及其要设置成的值。
抛出：
AttributeNotFoundException
InvalidAttributeValueException
MBeanException - 包装由 MBean 的设置方法所抛出的 java.lang.Exception。
ReflectionException - 包装试图调用设置方法时所抛出的 java.lang.Exception。
另请参见：
DynamicMBean.getAttribute(java.lang.String)

getAttributes

public AttributeList getAttributes(String[] attributes)
从接口 DynamicMBean 复制的描述
获得 Dynamic MBean 多个属性的值。

指定者：
接口 DynamicMBean 中的 getAttributes
参数：
attributes - 要检索的属性列表。
返回：
已检索的属性列表。
另请参见：
DynamicMBean.setAttributes(javax.management.AttributeList)

setAttributes

public AttributeList setAttributes(AttributeList attributes)
从接口 DynamicMBean 复制的描述
设置 Dynamic MBean 多个属性的值。

指定者：
接口 DynamicMBean 中的 setAttributes
参数：
attributes - 属性列表：要设置的属性的标识及其要设置成的值。
返回：
已设置的属性的列表，以及它们的新值。
另请参见：
DynamicMBean.getAttributes(java.lang.String[])

invoke

public Object invoke(String actionName,
                     Object[] params,
                     String[] signature)
              throws MBeanException,
                     ReflectionException
从接口 DynamicMBean 复制的描述
允许在 Dynamic MBean 上调用某个操作。

指定者：
接口 DynamicMBean 中的 invoke
参数：
actionName - 要调用的操作的名称。
params - 一个数组，包含调用该操作时所要设置的参数。
signature - 包含操作签名的数组。加载类对象时，使用的类加载器与加载在其上调用操作的 MBean 所用的类加载器相同。
返回：
该操作返回的对象，表示在指定 MBean 上调用该操作的结果。
抛出：
MBeanException - 包装由 MBean 上所调用的方法抛出的 java.lang.Exception。
ReflectionException - 包装试图调用该方法时所抛出的 java.lang.Exception。

getMBeanInfo

public MBeanInfo getMBeanInfo()
获取此 MBean 的 MBeanInfo。

此方法实现了 DynamicMBean.getMBeanInfo()。

此方法首先调用 getCachedMBeanInfo()，以便检索此 MBean 的缓存 MBeanInfo（如果有）。如果由 getCachedMBeanInfo() 返回的 MBeanInfo 不为 null，则将其返回。
否则，此方法将使用为此 MBean 指定的管理接口构建此 MBean 的默认 MBeanInfo。

在构建 MBeanInfo 时，此方法将调用一些自定义钩子，这些钩子使子类能够提供其自定义描述、参数名称等。
最后，它将调用 cacheMBeanInfo()，以便缓存新的 MBeanInfo。

指定者：
接口 DynamicMBean 中的 getMBeanInfo
返回：
如果不为 null，则返回缓存的该 MBean 的 MBeanInfo，如果没有缓存它，则返回新构建的 MBeanInfo。

getClassName

protected String getClassName(MBeanInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。
子类可以重定义此方法来提供其自定义类名称。默认实现返回 info.getClassName()。

参数：
info - 通过反射派生的默认 MBeanInfo。
返回：
新 MBeanInfo 的类名称。

getDescription

protected String getDescription(MBeanInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。
子类可以重定义此方法来提供其自定义 MBean 描述。默认实现返回 info.getDescription()。

参数：
info - 通过反射派生的默认 MBeanInfo。
返回：
对新 MBeanInfo 的描述。

getDescription

protected String getDescription(MBeanFeatureInfo info)

自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。

子类可以重定义此方法来提供其自定义描述。默认实现返回 info.getDescription()。

此方法将由 getDescription(MBeanAttributeInfo)、getDescription(MBeanOperationInfo)、getDescription(MBeanConstructorInfo) 调用。

参数：
info - 通过反射派生的默认 MBeanFeatureInfo。
返回：
对给定 MBeanFeatureInfo 的描述。

getDescription

protected String getDescription(MBeanAttributeInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。

子类可以重定义此方法来提供其自定义描述。默认实现返回 getDescription((MBeanFeatureInfo) info)。

参数：
info - 通过反射派生的默认 MBeanAttributeInfo。
返回：
对给定 MBeanAttributeInfo 的描述。

getDescription

protected String getDescription(MBeanConstructorInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。
子类可以重定义此方法来提供其自定义描述。默认实现返回 getDescription((MBeanFeatureInfo) info)。

参数：
info - 通过反射派生的默认 MBeanConstructorInfo。
返回：
对给定 MBeanConstructorInfo 的描述。

getDescription

protected String getDescription(MBeanConstructorInfo ctor,
                                MBeanParameterInfo param,
                                int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
子类可以重定义此方法来提供其自定义描述。默认实现返回 param.getDescription()。

参数：
ctor - 通过反射派生的默认 MBeanConstructorInfo。
param - 通过反射派生的默认 MBeanParameterInfo。
sequence - 要考虑的参数序列号（"0" 是第一个参数，"1" 是第二个参数，依此类推）。
返回：
对给定 MBeanParameterInfo 的描述。

getParameterName

protected String getParameterName(MBeanConstructorInfo ctor,
                                  MBeanParameterInfo param,
                                  int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。
子类可以重定义此方法来提供其自定义参数名称。默认实现返回 param.getName()。

参数：
ctor - 通过反射派生的默认 MBeanConstructorInfo。
param - 通过反射派生的默认 MBeanParameterInfo。
sequence - 要考虑的参数序列号（"0" 是第一个参数，"1" 是第二个参数，依此类推）。
返回：
给定 MBeanParameterInfo 的名称。

getDescription

protected String getDescription(MBeanOperationInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。
子类可以重定义此方法来提供其自定义描述。默认实现返回 getDescription((MBeanFeatureInfo) info)。

参数：
info - 通过反射派生的默认 MBeanOperationInfo。
返回：
对给定 MBeanOperationInfo 的描述。

getImpact

protected int getImpact(MBeanOperationInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的操作的 impact 标志。
子类可重定义此方法来提供其自定义 impact 标志。默认实现返回 info.getImpact()。

参数：
info - 通过反射派生的默认 MBeanOperationInfo。
返回：
给定 MBeanOperationInfo 的 impact 标志。

getParameterName

protected String getParameterName(MBeanOperationInfo op,
                                  MBeanParameterInfo param,
                                  int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。
子类可以重定义此方法来提供其自定义参数名称。默认实现返回 param.getName()。

参数：
op - 通过反射派生的默认 MBeanOperationInfo。
param - 通过反射派生的默认 MBeanParameterInfo。
sequence - 要考虑的参数序列号（"0" 是第一个参数，"1" 是第二个参数，依此类推）。
返回：
将用于给定 MBeanParameterInfo 的名称。

getDescription

protected String getDescription(MBeanOperationInfo op,
                                MBeanParameterInfo param,
                                int sequence)
自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
子类可以重定义此方法来提供其自定义描述。默认实现返回 param.getDescription()。

参数：
op - 通过反射派生的默认 MBeanOperationInfo。
param - 通过反射派生的默认 MBeanParameterInfo。
sequence - 要考虑的参数序列号（"0" 是第一个参数，"1" 是第二个参数，依此类推）。
返回：
对给定 MBeanParameterInfo 的描述。

getConstructors

protected MBeanConstructorInfo[] getConstructors(MBeanConstructorInfo[] ctors,
                                                 Object impl)
自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。
默认情况下，如果包装实现不是 this，则此方法返回 null。实际上，如果包装实现不是此对象自身，则不可能通过 MBeanServer.createMBean(...) 调用实现构造方法来重新创建一个包装实现。
换句话说，如果包装实现为 this，则返回 ctors。
子类可以重新定义此方法来修改此行为（如果需要）。

参数：
ctors - 通过反射派生的默认 MBeanConstructorInfo[]。
impl - 包装实现。如果传递了 null，则包装实现将被忽略，并且返回 ctors。
返回：
新 MBeanInfo 的 MBeanConstructorInfo[]。

getCachedMBeanInfo

protected MBeanInfo getCachedMBeanInfo()
自定义钩子：返回为此对象缓存的 MBeanInfo。

子类可以重定义此方法来实现自己的缓存策略。默认实现为每个实例存储一个 MBeanInfo 对象。

返回：
缓存的 MBeanInfo，如果没有缓存 MBeanInfo，则返回 null。
另请参见：
cacheMBeanInfo(MBeanInfo)

cacheMBeanInfo

protected void cacheMBeanInfo(MBeanInfo info)
自定义钩子：缓存为此对象构建的 MBeanInfo。

子类可以重定义此方法来实现自己的缓存策略。默认实现将 info 存储在此实例中。子类可以定义其他策略，如不保存 info（从而每次调用 getMBeanInfo() 时都将重新构造它）或者当几个 StandardMBean 实例具有相等的 MBeanInfo 值时共享唯一的 MBeanInfo 对象。

参数：
info - 要缓存的新 MBeanInfo。丢弃任何以前缓存的值。此参数可以为 null，在此情况下，没有任何新的缓存值。

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception

允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。如果未指定 MBean 的名称，则该 MBean 可以提供一个注册名称。如果引发任何异常，则该 MBean 不会被注册到 MBean 服务器中。

此方法的默认实现返回默认 name 参数。对于 Standard MBean，它不再执行其他操作。对于 MXBean，它记录 MBeanServer 和 ObjectName 参数，以供转换内部 MXBean 引用时使用。

对于子类，一个很好的做法是重写此方法，从而通过 super.preRegister(...) 调用重写的方法。如果此对象是其他 MXBean 中的属性或操作所引用的 MXBean，则此操作是必需的。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
server - 将在其中注册该 MBean 的 MBean 服务器。
name - MBean 的对象名。如果 MBeanServer 接口中的某个 createMBean 方法或 registerMBean 方法的 name 参数为 null，则此 name 也为 null。在这种情况下，此方法必须为新 MBean 返回非 null 的 ObjectName。
返回：
MBean 要被注册的名称。此值不得为 null。如果 name 参数不为 null，则它通常（但并非一定）为返回值。
抛出：
IllegalArgumentException - 如果此对象为 MXBean 且 name 为 null。
InstanceAlreadyExistsException - 如果此对象为 MXBean，且已经用（此 MBean Server 或其他 MBean Server 中的）另一个名称注册。
Exception - 此方法不抛出其他经过检查的异常，在这里声明 Exception 是为了供子类重写该方法并抛出它们的异常。
从以下版本开始：
1.6

postRegister

public void postRegister(Boolean registrationDone)

允许 MBean 在已注册到 MBean 服务器之后或注册已失败之后执行任何它所需要的操作。

对于 Standard MBean，此方法的默认实现不再执行任何操作。对于 MXBean，如果注册失败，它取消所有 preRegister 已完成的操作。

对于子类，一个很好的做法是重写此方法，从而通过 super.postRegister(...) 调用重写的方法。 如果此对象是其他 MXBean 中的属性或操作所引用的 MXBean，则此操作是必需的。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示该 MBean 是否已在 MBean 服务器中成功注册。false 值意味着注册阶段已失败。
从以下版本开始：
1.6

preDeregister

public void preDeregister()
                   throws Exception

允许 MBean 由 MBean 服务器取消注册前执行任何它所需要的操作。

此方法的默认实现不执行任何操作。

对于子类，一个很好的做法是重写此方法，从而通过 super.preDeegister(...) 调用重写的方法。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
Exception - 此方法不抛出经过检查的异常，这里声明 Exception 是为了供子类重写该方法并抛出它们的异常。
从以下版本开始：
1.6

postDeregister

public void postDeregister()

允许 MBean 在 MBean 服务器中取消注册后执行任何它所需要的操作。

对于 Standard MBean，此方法的默认实现不再执行任何操作。对于 MXBean，它移除 preRegister 方法记录的所有信息。

对于子类，一个很好的做法是重写此方法，从而通过 super.postRegister(...) 调用重写的方法。如果此对象是其他 MXBean 中的属性或操作所引用的 MXBean，则此操作是必需的。

指定者：
接口 MBeanRegistration 中的 postDeregister
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringValueExp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management
类 StringValueExp

java.lang.Object
    继承者  javax.management.StringValueExp
所有已实现的接口：
Serializable, ValueExp
public class StringValueExp
extends Object
implements ValueExp

表示作为关系约束变量的字符串。StringValueExp 可用于需要 ValueExp 的任何地方。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
StringValueExp()
基本构造方法。
StringValueExp(String val)
创建表示给定字符串的新 StringValueExp。
方法摘要
ValueExp | apply(ObjectName name) 在 MBean 上应用 ValueExp。
String | getValue() 返回由 StringValueExp 实例表示的字符串。
void | setMBeanServer(MBeanServer s) 设置将在其上执行查询的 MBean 服务器。
String | toString() 返回表示对象的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StringValueExp

public StringValueExp()
基本构造方法。

StringValueExp

public StringValueExp(String val)
创建表示给定字符串的新 StringValueExp。

参数：
val - 将作为此表达式值的字符串
方法详细信息

getValue

public String getValue()
返回由 StringValueExp 实例表示的字符串。

返回：
字符串。

toString

public String toString()
返回表示对象的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

setMBeanServer

public void setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。

指定者：
接口 ValueExp 中的 setMBeanServer
参数：
s - 将在其上执行查询的 MBean 服务器。

apply

public ValueExp apply(ObjectName name)
               throws BadStringOperationException,
                      BadBinaryOpValueExpException,
                      BadAttributeValueExpException,
                      InvalidApplicationException
在 MBean 上应用 ValueExp。

指定者：
接口 ValueExp 中的 apply
参数：
name - 将在其上应用 ValueExp 的 MBean 的名称。
返回：
ValueExp。
抛出：
BadStringOperationException
BadBinaryOpValueExpException
BadAttributeValueExpException
InvalidApplicationException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueExp (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management
接口 ValueExp

所有超级接口：
Serializable
所有已知实现类：
AttributeValueExp, StringValueExp
public interface ValueExp
extends Serializable

表示可以作为参数传递给关系表达式的值。字符串、数字、属性都是有效值，必须由 ValueExp 的实现表示。

从以下版本开始：
1.5

方法摘要
ValueExp | apply(ObjectName name) 在 MBean 上应用 ValueExp。
void | setMBeanServer(MBeanServer s) 已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。

方法详细信息

apply

ValueExp apply(ObjectName name)
               throws BadStringOperationException,
                      BadBinaryOpValueExpException,
                      BadAttributeValueExpException,
                      InvalidApplicationException
在 MBean 上应用 ValueExp。

参数：
name - 将在其上应用 ValueExp 的 MBean 的名称。
返回：
ValueExp。
抛出：
BadStringOperationException
BadBinaryOpValueExpException
BadAttributeValueExpException
InvalidApplicationException

setMBeanServer

@Deprecated
void setMBeanServer(MBeanServer s)
已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。

设置将在其上执行查询的 MBean 服务器。

参数：
s - 将在其上执行查询的 MBean 服务器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management (Java 2 Platform SE 6)

 javax.management
接口
Descriptor
DescriptorAccess
DescriptorRead
DynamicMBean
MBeanRegistration
MBeanServer
MBeanServerConnection
MBeanServerDelegateMBean
NotificationBroadcaster
NotificationEmitter
NotificationFilter
NotificationListener
PersistentMBean
QueryExp
ValueExp
类
Attribute
AttributeChangeNotification
AttributeChangeNotificationFilter
AttributeList
AttributeValueExp
DefaultLoaderRepository
ImmutableDescriptor
JMX
MBeanAttributeInfo
MBeanConstructorInfo
MBeanFeatureInfo
MBeanInfo
MBeanNotificationInfo
MBeanOperationInfo
MBeanParameterInfo
MBeanPermission
MBeanServerBuilder
MBeanServerDelegate
MBeanServerFactory
MBeanServerInvocationHandler
MBeanServerNotification
MBeanServerPermission
MBeanTrustPermission
Notification
NotificationBroadcasterSupport
NotificationFilterSupport
ObjectInstance
ObjectName
Query
QueryEval
StandardEmitterMBean
StandardMBean
StringValueExp
异常
AttributeNotFoundException
BadAttributeValueExpException
BadBinaryOpValueExpException
BadStringOperationException
InstanceAlreadyExistsException
InstanceNotFoundException
IntrospectionException
InvalidApplicationException
InvalidAttributeValueException
JMException
JMRuntimeException
ListenerNotFoundException
MalformedObjectNameException
MBeanException
MBeanRegistrationException
NotCompliantMBeanException
OperationsException
ReflectionException
RuntimeErrorException
RuntimeMBeanException
RuntimeOperationsException
ServiceNotFoundException
注释类型
DescriptorKey
MXBean


javax.management (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management

提供 Java Management Extensions 的核心类。

请参见：
描述

接口摘要
Descriptor | JMX 元素的附加元数据。
DescriptorAccess | 此接口用于获得对 Descriptor 类的描述符的访问，这些 Descriptor 类与某个 JMX 组件相关联，比如 MBean、MBeanInfo、MBeanAttributeInfo、MBeanNotificationInfo、MBeanOperationInfo 和 MBeanParameterInfo。
DescriptorRead | 读取管理接口元素（如 MBeanInfo）的 Descriptor 的接口。
DynamicMBean | 定义了 Dynamic MBean（公开了动态管理接口的 MBean）应该实现的各个方法。
MBeanRegistration | 可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanServer | 这是在代理端进行 MBean 操作的接口。
MBeanServerConnection | 此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。
MBeanServerDelegateMBean | 定义类 MBeanServerDelegate 的对象的管理接口。
NotificationBroadcaster | 由发出 Notifications 的 MBean 实现的接口。
NotificationEmitter | 由发出 Notifications 的 MBean 实现的接口。
NotificationFilter | 可由作为通知过滤器的任何类来实现。
NotificationListener | 应该由想要接收通知的对象来实现。
PersistentMBean | 此类是一个由希望是持久性的 MBean 实现的接口。
QueryExp | 表示可在数据库查询“where 子句”中使用的相关约束。
ValueExp | 表示可以作为参数传递给关系表达式的值。

类摘要
Attribute | 通过将 MBean 属性名与其值相关联来表示 MBean 属性。
AttributeChangeNotification | 提供 MBean 所发送的属性更改通知的定义。
AttributeChangeNotificationFilter | 此类实现 attribute change notification 的 NotificationFilter 接口。
AttributeList | 表示 MBean 属性值的列表。
AttributeValueExp | 表示用作关系约束参数的属性。
DefaultLoaderRepository | 已过时。 使用 MBeanServer.getClassLoaderRepository() 取代。
ImmutableDescriptor | 不可变的描述符。
JMX | JMX API 提供的静态方法。
MBeanAttributeInfo | 描述出于管理目的而公开的 MBean 属性。
MBeanConstructorInfo | 描述 MBean 所公开的构造方法。
MBeanFeatureInfo | 提供 MBean 描述符对象的常规信息。
MBeanInfo | 描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
MBeanNotificationInfo | MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanOperationInfo | 描述由 MBean 公开的管理操作。
MBeanParameterInfo | 描述由 MBean 公开的操作的参数。
MBeanPermission | 权限控制对 MBeanServer 操作的访问。
MBeanServerBuilder | 此类表示创建默认 MBeanServer 实现的生成器。
MBeanServerDelegate | 从管理的角度表示 MBean 服务器。
MBeanServerFactory | 提供 MBean 服务器引用。
MBeanServerInvocationHandler | 通过 MBean 服务器将 MBean 的管理接口中的方法转发到 MBean 的 InvocationHandler。
MBeanServerNotification | 表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。
MBeanServerPermission | 执行与 MBeanServer 关联的操作的 Permission。
MBeanTrustPermission | 此权限表示“信任”签名者或代码基。
Notification | Notification 类表示 MBean 所发出的通知。
NotificationBroadcasterSupport | 提供 NotificationEmitter 接口的实现。
NotificationFilterSupport | 提供 NotificationFilter 接口的实现。
ObjectInstance | 用于表示 MBean 对象名及其类名。
ObjectName | 表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
Query | 构造查询对象约束。
QueryEval | 允许在特定的 MBean 服务器上下文中执行查询。
StandardEmitterMBean | 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。
StandardMBean | 一个管理接口由 Java 接口上的反射确定的 MBean。
StringValueExp | 表示作为关系约束变量的字符串。

异常摘要
AttributeNotFoundException | 指定的属性不存在或无法检索。
BadAttributeValueExpException | 向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
BadBinaryOpValueExpException | 向构造查询的方法传递无效的表达式时，抛出此异常。
BadStringOperationException | 向构造查询的方法传递无效的字符串操作时，抛出此异常。
InstanceAlreadyExistsException | 已经在存储库中注册了 MBean。
InstanceNotFoundException | 存储库中不存在指定的 MBean。
IntrospectionException | 在 MBean 的 introspection 期间出现的异常。
InvalidApplicationException | 试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
InvalidAttributeValueException | 指定的值对该属性无效。
JMException | 由 JMX 实现所抛出的异常。
JMRuntimeException | 由 JMX 实现所发出的运行时异常。
ListenerNotFoundException | 存储库中不存在指定的 MBean 侦听器。
MalformedObjectNameException | 字符串的格式不对应于有效的 ObjectName。
MBeanException | 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
MBeanRegistrationException | 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
NotCompliantMBeanException | 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
OperationsException | 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
ReflectionException | 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
RuntimeErrorException | 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
RuntimeMBeanException | 表示由代理中的 MBean 方法抛出的运行时异常。
RuntimeOperationsException | 表示在 MBean 上执行操作时代理中抛出的运行时异常。
ServiceNotFoundException | 表示请求的服务不受支持时引发的异常。

注释类型摘要
DescriptorKey | 描述注释元素与 Descriptor 中字段之间关联方式的元注释。
MXBean | 显式地标记某一接口是否为 MXBean 接口的注释。

软件包 javax.management 的描述

提供 Java Management Extensions 的核心类。

Java Management Extensions (JMXTM) API 是一个用于管理和监视的标准 API。典型用途包括：

  • 查询并更改应用程序配置
  • 累积有关应用程序行为的统计数据并使其可用
  • 通知状态更改及错误状况。

JMX API 还可以作为解决方案的一部分来管理系统、网络等。

API 包括远程访问，因此，远程管理程序可以基于这些目的与正在运行的应用程序进行交互。

MBean

JMX API 的基本概念是 MBean。MBean 是表示资源的指定管理对象。它有一个管理接口，该接口包括以下内容：

  • 可以读取和/或写入的指定名称和类型的属性
  • 可以调用的指定名称和类型的操作
  • 可以由 MBean 发送的指定类型的通知。

例如，一个表示应用程序配置的 MBean 可以有一些表示不同配置项的属性。读取 CacheSize 属性可以返回该项的当前值。写入该属性可以更新该项，从而可能会更改正在运行的应用程序的行为。诸如 save 之类的操作可以持久保存当前配置。每次更改配置时都会发送 ConfigurationChangedNotification 之类的通知。

在 JMX API 的标准用法中，可以像实现 Java 对象那样来实现 MBean。不过，如下所述，通常不直接引用这些对象。

Standard MBean

为了简化 MBean 实现，JMX API 包括 Standard MBean 这一概念。Standard MBean 的属性和操作来源于 Java 接口，使用特定的命名模式，与 JavaBeansTM 使用的属性和操作类似。例如，假定具有如下所示接口：

    public interface ConfigurationMBean {
        public int getCacheSize();
        public void setCacheSize(int size);
        public long getLastChangedTime();
        public void save();
    }

方法 getCacheSize 和 setCacheSize 定义了名为 CacheSize 的 int 类型的读写属性（首字母大写，这与 JavaBeans 惯例不同）。

方法 getLastChangedTime 定义了名为 LastChangedTime 的 long 类型的属性。这是一种只读属性，原因是没有方法 setLastChangedTime。

方法 save 定义了名为 save 的操作。它不是属性，原因是它的名称没有以 get、set 或 is 开头。

Standard MBean 的准确命名模式将在 JMX 规范中详述。

制做作为带有此管理接口的 MBean 的 Java 对象的方法有两种。一种用于具有与 Java 接口完全相同的名称、但没有 MBean 后缀的类的对象。因此，在该示例中，对象将是 Configuration 类的对象，与 ConfigurationMBean 在相同的 Java 包中。第二种方法是使用 StandardMBean 类。

MXBean

MXBean 是标准 MBean 的一个变体，其中复合类型将映射到 javax.management.openmbean 包中定义的标准类型集。如果需要引用 MBean 接口中特定于应用程序的类，则可以使用 MXBean。在 MXBean 规范中有 MXBean 的详细描述。

Dynamic MBean

Dynamic MBean 是一种在运行时定义其管理接口的 MBean。例如，配置 MBean 可以通过解析 XML 文件来确定它所公开的属性名称和类型。

任何实现 DynamicMBean 接口的类的 Java 对象都是 Dynamic MBean。

Open MBean

Open MBean 是一种 Dynamic MBean，在这种 MBean 中，属性类型、操作参数类型和返回值都是使用一个预定义 Java 类的小集合来构建的。Open MBean 使用其远程管理程序加快了操作，这些远程管理程序不必使用特定于应用程序的类型，其中包括非 Java 程序。Open MBean 由包 javax.management.openmbean 定义。

Model MBean

Model MBean 是一种 Dynamic MBean，它充当管理接口和基础托管资源之间的桥梁。管理接口和托管资源都被指定为 Java 对象。相同的 Model MBean 实现可以重复多次用于不同的管理接口和托管资源，并且还可以提供诸如持久性和缓存之类的共有功能。Model MBean 由包 javax.management.modelmbean 定义。

MBean 服务器

要想让 MBean 有用，必须在 MBean 服务器中注册它。MBean 服务器是一个 MBean 存储库。通常情况下，只能通过 MBean 服务器访问 MBean。换句话说，代码不再直接访问实现 MBean 的 Java 对象，而是通过 MBean 服务器根据名称访问该 MBean。每个 MBean 在 MBean 服务器内都有一个由 ObjectName 类定义的唯一名称。

MBean 服务器是一个实现了接口 MBeanServer 的对象。最便于使用的 MBean Server 是 Platform MBean Server。这是可以由相同 Java 虚拟机中运行的不同托管组件共享的单独 MBean 服务器。平台 MBean 服务器可以通过方法 ManagementFactory.getPlatformMBeanServer() 访问。

使用 MBeanServerFactory 类，应用程序代码还可以创建一个新的 MBean 服务器，或者访问已经创建的 MBean 服务器。

在 MBean 服务器中创建 MBean

创建 MBean 有两种方法。一种方法是构造将作为 MBean 的 Java 对象，然后使用 registerMBean 方法在 MBean 服务器中注册它。另一种方法是使用其中一个 createMBean 方法在单一操作中创建并注册 MBean。

registerMBean 方法对于本地使用较为简单，但不能远程使用。createMBean 方法可以远程使用，但有时需要注意类加载问题。

如果实现了 MBeanRegistration 接口，则 MBean 可以在向 MBean 服务器注册或从中注销时执行操作。

在 MBean 服务器中访问 MBean

在给定一个 ObjectName name 和一个 MBeanServer mbs 的情况下，可以访问一些属性和操作，如下所示：

    int cacheSize = mbs.getAttribute(name, "CacheSize");
    Attribute newCacheSize =
        new Attribute("CacheSize", new Integer(2000));
    mbs.setAttribute(name, newCacheSize);
    mbs.invoke(name, "save", new Object[0], new Class[0]);

另外，如果有一个与 MBean 管理接口对应的 Java 接口，那么可以使用 MBean 代理，如下所示：

     ConfigurationMBean conf =
        JMX.newMBeanProxy(mbs, name, ConfigurationMBean.class);

    int cacheSize = conf.getCacheSize();
    conf.setCacheSize(2000);
    conf.save();

使用 MBean 代理只是为了方便。与第一个示例相同，第二个示例的结尾同样调用了 MBeanServer 操作。

可以通过查询 MBean 服务器查找其名称与特定模式匹配和/或其属性满足特定约束的 MBean。名称模式可以使用 ObjectName 类构造，而约束可以使用 Query 类构造。然后方法 queryNames 和 queryMBeans 将执行查询。

通知

通知 是 Notification 类或子类的一个实例。除其 Java 类之外，它还有一个可以将它与相同类的其他通知区分开的类型 字符串。

一个将发送通知的 MBean 必须实现 NotificationBroadcaster 或 NotificationEmitter 接口。通常情况下，它通过创建 NotificationBroadcasterSupport 子类或委派该类的一个实例来实现这一点。

通知可以由侦听器 接收，该侦听器是一个实现了 NotificationListener 接口的对象。可以使用方法 javax.management.MBeanServer#addNotificationListener（ObjectName、NotificationListener、NotificationFilter、Object） 将侦听器添加到 MBean 中。可以选择向此方法提供过滤器，以便只选择感兴趣的通知。过滤器是一个实现了 NotificationFilter 接口的对象。

MBean 可以是由同一个 MBean 服务器中其他 MBean 发出的通知的侦听器。在此情况下，它实现 NotificationListener，并使用方法 javax.management.MBeanServer#addNotificationListener（ObjectName、ObjectName、NotificationFilter、Object） 来侦听。

远程访问 MBean

可以通过连接器 远程访问 Bean 服务器。连接器允许远程 Java 应用程序以实质上与本地 Java 应用程序相同的方式访问 MBean 服务器。包 javax.management.remote 定义了连接器。

JMX 规范还定义了适配器 的概念。适配器可以在协议中（如 SNMP 或 HTML ）的请求与对 MBean 服务器的访问之间进行转换。所以，像 SNMP GET 这样的操作可能会导致对 MBean 服务器 getAttribute。

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology，尤其是 JMX Specification, version 1.4(pdf)。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • javax.management.AttributeList
    • javax.management.Attribute (implements java.io.Serializable)
    • javax.management.AttributeChangeNotificationFilter (implements javax.management.NotificationFilter)
    • javax.management.AttributeValueExp (implements javax.management.ValueExp)
    • javax.management.DefaultLoaderRepository
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.AttributeChangeNotification
        • javax.management.MBeanServerNotification
    • javax.management.ImmutableDescriptor (implements javax.management.Descriptor)
    • javax.management.JMX
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
      • javax.management.MBeanNotificationInfo (implements java.lang.Cloneable)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
      • javax.management.MBeanParameterInfo (implements java.lang.Cloneable)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
    • javax.management.MBeanServerBuilder
    • javax.management.MBeanServerDelegate (implements javax.management.MBeanServerDelegateMBean, javax.management.NotificationEmitter)
    • javax.management.MBeanServerFactory
    • javax.management.MBeanServerInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
    • javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter)
    • javax.management.ObjectInstance (implements java.io.Serializable)
    • javax.management.ObjectName (implements java.lang.Comparable<T>, javax.management.QueryExp)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.management.MBeanServerPermission
        • javax.management.MBeanTrustPermission
      • javax.management.MBeanPermission
    • javax.management.Query
    • javax.management.QueryEval (implements java.io.Serializable)
    • javax.management.StandardMBean (implements javax.management.DynamicMBean, javax.management.MBeanRegistration)
      • javax.management.StandardEmitterMBean (implements javax.management.NotificationEmitter)
    • javax.management.StringValueExp (implements javax.management.ValueExp)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.management.BadAttributeValueExpException
        • javax.management.BadBinaryOpValueExpException
        • javax.management.BadStringOperationException
        • javax.management.InvalidApplicationException
        • javax.management.JMException
          • javax.management.MBeanException
            • javax.management.MBeanRegistrationException
          • javax.management.OperationsException
            • javax.management.AttributeNotFoundException
            • javax.management.InstanceAlreadyExistsException
            • javax.management.InstanceNotFoundException
            • javax.management.IntrospectionException
            • javax.management.InvalidAttributeValueException
            • javax.management.ListenerNotFoundException
            • javax.management.MalformedObjectNameException
            • javax.management.NotCompliantMBeanException
            • javax.management.ServiceNotFoundException
          • javax.management.ReflectionException
        • java.lang.RuntimeException
          • javax.management.JMRuntimeException
            • javax.management.RuntimeErrorException
            • javax.management.RuntimeMBeanException
            • javax.management.RuntimeOperationsException

接口分层结构

  • java.lang.Cloneable
    • javax.management.Descriptor (并 extends java.io.Serializable)
  • javax.management.DescriptorRead
    • javax.management.DescriptorAccess
  • javax.management.DynamicMBean
  • java.util.EventListener
    • javax.management.NotificationListener
  • javax.management.MBeanRegistration
  • javax.management.MBeanServerConnection
    • javax.management.MBeanServer
  • javax.management.MBeanServerDelegateMBean
  • javax.management.NotificationBroadcaster
    • javax.management.NotificationEmitter
  • javax.management.PersistentMBean
  • java.io.Serializable
    • javax.management.Descriptor (并 extends java.lang.Cloneable)
    • javax.management.NotificationFilter
    • javax.management.QueryExp
    • javax.management.ValueExp

注释类型分层结构

  • javax.management.DescriptorKey (implements java.lang.annotation.Annotation)
  • javax.management.MXBean (implements java.lang.annotation.Annotation)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management
的使用

使用 javax.management 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

java.lang.management 使用的 javax.management 中的类
MBeanServer
这是在代理端进行 MBean 操作的接口。
MBeanServerConnection
此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。

javax.management 使用的 javax.management 中的类
Attribute
通过将 MBean 属性名与其值相关联来表示 MBean 属性。
AttributeList
表示 MBean 属性值的列表。
AttributeNotFoundException
指定的属性不存在或无法检索。
AttributeValueExp
表示用作关系约束参数的属性。
BadAttributeValueExpException
向构造的查询方法传递无效的 MBean 属性时，抛出此异常。
BadBinaryOpValueExpException
向构造查询的方法传递无效的表达式时，抛出此异常。
BadStringOperationException
向构造查询的方法传递无效的字符串操作时，抛出此异常。
Descriptor
JMX 元素的附加元数据。
DescriptorRead
读取管理接口元素（如 MBeanInfo）的 Descriptor 的接口。
DynamicMBean
定义了 Dynamic MBean（公开了动态管理接口的 MBean）应该实现的各个方法。
ImmutableDescriptor
不可变的描述符。
InstanceAlreadyExistsException
已经在存储库中注册了 MBean。
InstanceNotFoundException
存储库中不存在指定的 MBean。
IntrospectionException
在 MBean 的 introspection 期间出现的异常。
InvalidApplicationException
试图应用下列任一内容时抛出此异常：对 MBean 应用子查询表达式或对错误类的 MBean 应用完全限定属性表达式。
InvalidAttributeValueException
指定的值对该属性无效。
JMException
由 JMX 实现所抛出的异常。
JMRuntimeException
由 JMX 实现所发出的运行时异常。
ListenerNotFoundException
存储库中不存在指定的 MBean 侦听器。
MalformedObjectNameException
字符串的格式不对应于有效的 ObjectName。
MBeanAttributeInfo
描述出于管理目的而公开的 MBean 属性。
MBeanConstructorInfo
描述 MBean 所公开的构造方法。
MBeanException
表示由代理的 MBean 方法所抛出的“用户定义的”异常。
MBeanFeatureInfo
提供 MBean 描述符对象的常规信息。
MBeanInfo
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanOperationInfo
描述由 MBean 公开的管理操作。
MBeanParameterInfo
描述由 MBean 公开的操作的参数。
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanRegistrationException
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
MBeanServer
这是在代理端进行 MBean 操作的接口。
MBeanServerConnection
此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。
MBeanServerDelegate
从管理的角度表示 MBean 服务器。
MBeanServerDelegateMBean
定义类 MBeanServerDelegate 的对象的管理接口。
NotCompliantMBeanException
尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
Notification
Notification 类表示 MBean 所发出的通知。
NotificationBroadcaster
由发出 Notifications 的 MBean 实现的接口。
NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。
NotificationFilter
可由作为通知过滤器的任何类来实现。
NotificationListener
应该由想要接收通知的对象来实现。
ObjectInstance
用于表示 MBean 对象名及其类名。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
OperationsException
表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
QueryExp
表示可在数据库查询“where 子句”中使用的相关约束。
ReflectionException
表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
RuntimeOperationsException
表示在 MBean 上执行操作时代理中抛出的运行时异常。
StandardMBean
一个管理接口由 Java 接口上的反射确定的 MBean。
StringValueExp
表示作为关系约束变量的字符串。
ValueExp
表示可以作为参数传递给关系表达式的值。

javax.management.loading 使用的 javax.management 中的类
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanServer
这是在代理端进行 MBean 操作的接口。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
ServiceNotFoundException
表示请求的服务不受支持时引发的异常。

javax.management.modelmbean 使用的 javax.management 中的类
Attribute
通过将 MBean 属性名与其值相关联来表示 MBean 属性。
AttributeChangeNotification
提供 MBean 所发送的属性更改通知的定义。
AttributeList
表示 MBean 属性值的列表。
AttributeNotFoundException
指定的属性不存在或无法检索。
Descriptor
JMX 元素的附加元数据。
DescriptorAccess
此接口用于获得对 Descriptor 类的描述符的访问，这些 Descriptor 类与某个 JMX 组件相关联，比如 MBean、MBeanInfo、MBeanAttributeInfo、MBeanNotificationInfo、MBeanOperationInfo 和 MBeanParameterInfo。
DescriptorRead
读取管理接口元素（如 MBeanInfo）的 Descriptor 的接口。
DynamicMBean
定义了 Dynamic MBean（公开了动态管理接口的 MBean）应该实现的各个方法。
InstanceNotFoundException
存储库中不存在指定的 MBean。
IntrospectionException
在 MBean 的 introspection 期间出现的异常。
InvalidAttributeValueException
指定的值对该属性无效。
ListenerNotFoundException
存储库中不存在指定的 MBean 侦听器。
MBeanAttributeInfo
描述出于管理目的而公开的 MBean 属性。
MBeanConstructorInfo
描述 MBean 所公开的构造方法。
MBeanException
表示由代理的 MBean 方法所抛出的“用户定义的”异常。
MBeanFeatureInfo
提供 MBean 描述符对象的常规信息。
MBeanInfo
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanOperationInfo
描述由 MBean 公开的管理操作。
MBeanParameterInfo
描述由 MBean 公开的操作的参数。
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanServer
这是在代理端进行 MBean 操作的接口。
Notification
Notification 类表示 MBean 所发出的通知。
NotificationBroadcaster
由发出 Notifications 的 MBean 实现的接口。
NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。
NotificationFilter
可由作为通知过滤器的任何类来实现。
NotificationListener
应该由想要接收通知的对象来实现。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
PersistentMBean
此类是一个由希望是持久性的 MBean 实现的接口。
ReflectionException
表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
RuntimeOperationsException
表示在 MBean 上执行操作时代理中抛出的运行时异常。

javax.management.monitor 使用的 javax.management 中的类
JMRuntimeException
由 JMX 实现所发出的运行时异常。
MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanServer
这是在代理端进行 MBean 操作的接口。
Notification
Notification 类表示 MBean 所发出的通知。
NotificationBroadcaster
由发出 Notifications 的 MBean 实现的接口。
NotificationBroadcasterSupport
提供 NotificationEmitter 接口的实现。
NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

javax.management.openmbean 使用的 javax.management 中的类
Descriptor
JMX 元素的附加元数据。
DescriptorRead
读取管理接口元素（如 MBeanInfo）的 Descriptor 的接口。
JMException
由 JMX 实现所抛出的异常。
MBeanAttributeInfo
描述出于管理目的而公开的 MBean 属性。
MBeanConstructorInfo
描述 MBean 所公开的构造方法。
MBeanFeatureInfo
提供 MBean 描述符对象的常规信息。
MBeanInfo
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanOperationInfo
描述由 MBean 公开的管理操作。
MBeanParameterInfo
描述由 MBean 公开的操作的参数。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

javax.management.relation 使用的 javax.management 中的类
InstanceNotFoundException
存储库中不存在指定的 MBean。
JMException
由 JMX 实现所抛出的异常。
MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanServer
这是在代理端进行 MBean 操作的接口。
NotCompliantMBeanException
尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
Notification
Notification 类表示 MBean 所发出的通知。
NotificationBroadcaster
由发出 Notifications 的 MBean 实现的接口。
NotificationBroadcasterSupport
提供 NotificationEmitter 接口的实现。
NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。
NotificationFilter
可由作为通知过滤器的任何类来实现。
NotificationFilterSupport
提供 NotificationFilter 接口的实现。
NotificationListener
应该由想要接收通知的对象来实现。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

javax.management.remote 使用的 javax.management 中的类
ListenerNotFoundException
存储库中不存在指定的 MBean 侦听器。
MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanServer
这是在代理端进行 MBean 操作的接口。
MBeanServerConnection
此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。
Notification
Notification 类表示 MBean 所发出的通知。
NotificationBroadcaster
由发出 Notifications 的 MBean 实现的接口。
NotificationBroadcasterSupport
提供 NotificationEmitter 接口的实现。
NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。
NotificationFilter
可由作为通知过滤器的任何类来实现。
NotificationListener
应该由想要接收通知的对象来实现。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

javax.management.remote.rmi 使用的 javax.management 中的类
AttributeList
表示 MBean 属性值的列表。
AttributeNotFoundException
指定的属性不存在或无法检索。
InstanceAlreadyExistsException
已经在存储库中注册了 MBean。
InstanceNotFoundException
存储库中不存在指定的 MBean。
IntrospectionException
在 MBean 的 introspection 期间出现的异常。
InvalidAttributeValueException
指定的值对该属性无效。
ListenerNotFoundException
存储库中不存在指定的 MBean 侦听器。
MBeanException
表示由代理的 MBean 方法所抛出的“用户定义的”异常。
MBeanInfo
描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanRegistrationException
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
MBeanServer
这是在代理端进行 MBean 操作的接口。
MBeanServerConnection
此接口表示了与 MBean 服务器（无论是本地的还是远程的）进行通信的一种方式。
NotCompliantMBeanException
尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
NotificationBroadcaster
由发出 Notifications 的 MBean 实现的接口。
NotificationBroadcasterSupport
提供 NotificationEmitter 接口的实现。
NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。
NotificationFilter
可由作为通知过滤器的任何类来实现。
NotificationListener
应该由想要接收通知的对象来实现。
ObjectInstance
用于表示 MBean 对象名及其类名。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。
ReflectionException
表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。

javax.management.timer 使用的 javax.management 中的类
InstanceNotFoundException
存储库中不存在指定的 MBean。
MBeanNotificationInfo
MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
MBeanRegistration
可以由 MBean 实现，以便在向 MBean 服务器注册或从其注销之前和之后执行操作。
MBeanServer
这是在代理端进行 MBean 操作的接口。
Notification
Notification 类表示 MBean 所发出的通知。
NotificationBroadcaster
由发出 Notifications 的 MBean 实现的接口。
NotificationBroadcasterSupport
提供 NotificationEmitter 接口的实现。
NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。
ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ClassLoaderRepository (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.loading
接口 ClassLoaderRepository

public interface ClassLoaderRepository

此接口的实例用于保持在 MBean Server 中注册的 ClassLoader 的列表。它们提供了使用注册的 ClassLoader 来加载类所必需的方法。

ClassLoaderRepository 中的首个 ClassLoader 始终是 MBean Server 本身的 ClassLoader。

当在 MBean Server 中注册 MBean 时，如果它是 ClassLoader 的一个子类，并且它不实现 PrivateClassLoader 接口，那么将它添加到 MBean Server 的 ClassLoaderRepository 的末尾。如果以后从 MBean Server 注销它，则它将从 ClassLoaderRepository 中移除。

ClassLoaderRepository 中的 MBean 顺序是很重要的。对于 ClassLoaderRepository 中的任意两个 MBean X 和 Y，如果在 Y 的注册开始之前已完成 X 的注册，则 X 必须出现在 Y 的前面。如果 X 和 Y 是同时注册的，则它们的顺序是不确定的。注册 MBean 对应于调用 MBeanServer.registerMBean(java.lang.Object, javax.management.ObjectName) 或某个 MBeanServer .createMBean 方法。

从以下版本开始：
1.5
另请参见：
MBeanServerFactory

方法摘要
Class<?> | loadClass(String className) 通过类加载器列表加载给定的类名称。
Class<?> | loadClassBefore(ClassLoader stop, String className) 通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。
Class<?> | loadClassWithout(ClassLoader exclude, String className) 通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。

方法详细信息

loadClass

Class<?> loadClass(String className)
                   throws ClassNotFoundException

通过类加载器列表加载给定的类名称。依次请求 ClassLoaderRepository 的每个 ClassLoader 通过其 ClassLoader.loadClass(String) 方法来加载类。如果它成功返回一个 Class 对象，则该对象就是此方法的结果。如果抛出 ClassNotFoundException，则继续搜索下一个 ClassLoader。如果抛出另一个异常，则从此方法传播该异常。如果到达列表的末尾，则抛出 ClassNotFoundException。

参数：
className - 要被加载的类名称。
返回：
加载的类。
抛出：
ClassNotFoundException - 如果找不到指定的类。

loadClassWithout

Class<?> loadClassWithout(ClassLoader exclude,
                          String className)
                          throws ClassNotFoundException

通过类加载器列表加载给定的类名称，不包括某个给定的类加载器。依次请求 ClassLoaderRepository 的每个 ClassLoader（除 exclude 之外）通过其 ClassLoader.loadClass(String) 方法来加载类。如果它成功返回一个 Class 对象，则该对象就是此方法的结果。如果抛出 ClassNotFoundException，则继续搜索下一个 ClassLoader。如果抛出另一个异常，则从此方法传播该异常。如果到达列表的末尾，则抛出 ClassNotFoundException。

注意，如果 ClassLoaderRepository 中的某个 ClassLoader 从其 loadClass 方法调用此方法，那么如果 ClassLoaderRepository 中的另一个 ClassLoader 同时也在执行相同操作，则该 ClassLoader 将发生死锁。推荐使用 loadClassBefore(java.lang.ClassLoader, java.lang.String) 方法以避免死锁风险。

参数：
className - 要被加载的类名称。
exclude - 不包括的类加载器。可能为 null，在这种情况下此方法等效于 loadClass(className)。
返回：
加载的类。
抛出：
ClassNotFoundException - 如果找不到指定的类。

loadClassBefore

Class<?> loadClassBefore(ClassLoader stop,
                         String className)
                         throws ClassNotFoundException

通过类加载器列表加载给定的类名称，在某个给定的类加载器处停止。依次请求 ClassLoaderRepository 的每个 ClassLoader 通过其 ClassLoader.loadClass(String) 方法来加载类。如果它成功返回一个 Class 对象，则该对象就是此方法的结果。如果抛出 ClassNotFoundException，则继续搜索下一个 ClassLoader。如果抛出另一个异常，则从此方法传播该异常。如果搜索到达 stop 或列表的末尾，则抛出 ClassNotFoundException。

通常从 stop 处的 loadClass 方法调用此方法，以参考 ClassLoaderRepository 中出现在它之前的的加载器。一旦遇到 stop，搜索立即停止，这样就避免了可能出现的并发类加载死锁。

参数：
className - 要被加载的类名称。
stop - 停止处的类加载器。可能为 null，在这种情况下此方法等效于 loadClass(className)。
返回：
加载的类。
抛出：
ClassNotFoundException - 如果找不到指定的类。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DefaultLoaderRepository (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.loading
类 DefaultLoaderRepository

java.lang.Object
    继承者  javax.management.loading.DefaultLoaderRepository
已过时。 使用 MBeanServer.getClassLoaderRepository()} 替代。

@Deprecated
public class DefaultLoaderRepository
extends Object

保持 MBean Server 中所注册的 Class Loader 的列表。它提供了使用注册的 Class Loader 来加载类所必需的方法。

维护这个过时的类是出于兼容性考虑。在以前的 JMX 版本中，有一个被所有 MBean 服务器共享的 DefaultLoaderRepository。从 JMX 1.2 开始，该功能近似于使用 MBeanServerFactory.findMBeanServer(java.lang.String) 来查找所有已知的 MBean 服务器，并参考每个 MBean 服务器的 ClassLoaderRepository。强烈推荐重写引用 DefaultLoaderRepository 的代码。

从以下版本开始：
1.5

构造方法摘要
DefaultLoaderRepository()
已过时。
方法摘要
static Class | loadClass(String className) 已过时。 仔细检查类加载器列表，并尝试加载所请求的类。
static Class | loadClassWithout(ClassLoader loader, String className) 已过时。 仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultLoaderRepository

public DefaultLoaderRepository()
已过时。
方法详细信息

loadClass

public static Class loadClass(String className)
                       throws ClassNotFoundException
已过时。
仔细检查类加载器列表，并尝试加载所请求的类。一旦找到类，就立即停止此方法。如果找不到类，则此方法将抛出 ClassNotFoundException 异常。

参数：
className - 要被加载的类名称。
返回：
加载的类。
抛出：
ClassNotFoundException - 如果找不到指定的类。

loadClassWithout

public static Class loadClassWithout(ClassLoader loader,
                                     String className)
                              throws ClassNotFoundException
已过时。
仔细检查除了给定的类加载器的类加载器列表，然后尝试加载所请求的类。一旦找到类，就立即停止此方法。如果找不到类，则此方法将抛出 ClassNotFoundException 异常。

参数：
className - 要被加载的类名称。
loader - 不包括的类加载器。
返回：
加载的类。
抛出：
ClassNotFoundException - 如果找不到指定的类。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MLet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.loading
类 MLet

java.lang.Object
    继承者  java.lang.ClassLoader
        继承者  java.security.SecureClassLoader
            继承者  java.net.URLClassLoader
                继承者  javax.management.loading.MLet
所有已实现的接口：
Externalizable, Serializable, MLetMBean, MBeanRegistration
直接已知子类：
PrivateMLet
public class MLet
extends URLClassLoader
implements MLetMBean, MBeanRegistration, Externalizable

允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。M-let 是管理 applet 的捷径。m-let 服务通过加载一个 m-let 文本文件来实现此功能，该文本文件指定了要获取的 MBean 上的信息。每个 MBean 上的信息都是在某个标记的单个实例中指定的，该标记称为 MLET 标记。m-let 文本文件的位置由 URL 指定。

MLET 标记具有以下语法：

<MLET
CODE = class | OBJECT = serfile
ARCHIVE = "archiveList"
[CODEBASE = codebaseURL]
[NAME = mbeanname]
[VERSION = version]
>
[arglist]
</MLET>

其中：

CODE = class
此属性指定了要获取的 MBean 的 Java 类的全名，包括包名称。编译后的 MBean 的 .class 文件必须包含在 ARCHIVE 属性指定的 .jar 文件中。CODE 或 OBJECT 必须存在。
OBJECT = serfile
此属性指定了 .ser 文件，该文件包含要获取的 MBean 的序列化表示形式。此文件必须包含在 ARCHIVE 属性指定的 .jar 文件中。如果 .jar 文件包含目录层次结构，则需要指定此层次结构中的文件路径。否则将找不到匹配项。CODE 或 OBJECT 必须存在。
ARCHIVE = "archiveList"
此属性是必需的，它指定了一个或多个 .jar 文件，这些文件包含要获取的 MBean 使用的 MBean 或其他资源。.jar 文件之一必须包含 CODE 或 OBJECT 属性所指定的文件。如果 archivelist 包含多个文件：
  • 必须用逗号 (,) 将每个文件与它后面的文件隔开。
  • archivelist 必须用双引号引起来。
archivelist 中的所有 .jar 文件必须存储在代码基 URL 指定的目录中。
CODEBASE = codebaseURL
此可选属性指定了要获取的 MBean 的代码基 URL。它标识了包含 ARCHIVE 指定的 .jar 文件的目录。仅当 .jar 文件与 m-let 文本文件不在同一目录中时，指定此属性。如果不指定此属性，则使用 m-let 文本文件的基本 URL。
NAME = mbeanname
当 m-let 已注册 MBean 实例时，此可选属性指定了要分配给 MBean 实例的对象名称。如果 mbeanname 以冒号字符 (:) 开始，则对象名称的域部分是 MBean 服务器的默认域，可由 MBeanServer.getDefaultDomain() 返回。
VERSION = version
此可选属性指定了要获取的 MBean 版本号和关联的 .jar 文件。此版本号可用于指定从服务器加载 .jar 文件，以便在下次调用 m-let 文本文件时更新存储在本地缓存中的文件。version 必须是一系列非负的十进制整数，每个整数都通过句点与它前面的整数隔开。
arglist
此可选属性指定了将被实例化的 MBean 的一个或多个参数的列表。此列表描述了要传递给 MBean 的构造方法的参数。使用以下语法指定 arglist 中的每一项：

<ARG TYPE=argumentType VALUE=value>

其中：
  • argumentType 是将作为参数传递给 MBean 的构造方法的参数类型。

参数列表中的参数类型应为 Java 基本类型（java.lang.Boolean、java.lang.Byte、 java.lang.Short、java.lang.Long、java.lang.Integer、java.lang.Float、java.lang.Double 和 java.lang.String）。

当加载一个 m-let 文本文件时，创建并注册该文件中所指定的每个 MBean 的实例。

m-let 服务扩展了 java.net.URLClassLoader，可以用它加载代理的 VM 中的远程类和 jar 文件。

注意 － MLet 类加载器使用 MBeanServerFactory.getClassLoaderRepository(javax.management.MBeanServer) 来加载在已加载 jar 文件中找不到的类。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MLet()
使用默认的代理父类加载器构造新的 MLet。
MLet(URL[] urls)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[] urls, boolean delegateToCLR)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
MLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。
方法摘要
void | addURL(String url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
void | addURL(URL url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
protected URL | check(String version, URL codebase, String jarfile, MLetContent mlet) 当扩展此服务来支持缓存和版本控制时，要重写此方法。
protected Class<?> | findClass(String name) 这是要重新定义的类加载器的主要方法。
protected String | findLibrary(String libname) 返回本机库的绝对路径名称。
String | getLibraryDirectory() 获取库加载器在将本机库加载到内存中之前用于存储这些本机库的当前目录。
Set<Object> | getMBeansFromURL(String url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | getMBeansFromURL(URL url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
URL[] | getURLs() 返回用于加载类和资源的 URL 搜索路径。
Class<?> | loadClass(String name, ClassLoaderRepository clr) 如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。
void | postDeregister() 允许 m-let 在已从 MBean 服务器注销之后执行任何所需要的操作。
void | postRegister(Boolean registrationDone) 允许 m-let 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。
void | preDeregister() 允许 m-let 在由 MBean 服务器注销之前执行任何所需要的操作。
ObjectName | preRegister(MBeanServer server, ObjectName name) 允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。
void | readExternal(ObjectInput in) 从给定的 ObjectInput 恢复此 MLet 的内容。
void | setLibraryDirectory(String libdir) 设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。
void | writeExternal(ObjectOutput out) 将此 MLet 的内容保存到给定的 ObjectOutput。
从类 java.net.URLClassLoader 继承的方法
definePackage, findResource, findResources, getPermissions, newInstance, newInstance
从类 java.security.SecureClassLoader 继承的方法
defineClass, defineClass
从类 java.lang.ClassLoader 继承的方法
clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.management.loading.MLetMBean 继承的方法
getResource, getResourceAsStream, getResources

构造方法详细信息

MLet

public MLet()
使用默认的代理父类加载器构造新的 MLet。

MLet

public MLet(URL[] urls)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。首先在父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。

参数：
urls - 从其位置加载类和资源的 URL。

MLet

public MLet(URL[] urls,
            ClassLoader parent)
为给定的 URL 构造新的 MLet。首先在指定的父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。该父参数将用作代理的父类加载器。

参数：
urls - 从其指示的位置加载类和资源的 URL。
parent - 代理的父类加载器。

MLet

public MLet(URL[] urls,
            ClassLoader parent,
            URLStreamHandlerFactory factory)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。该父参数将用作代理的父类加载器。在创建新 URL 时，该工厂参数将用作获取协议处理程序的流处理程序工厂。

参数：
urls - 从其指示的位置加载类和资源的 URL。
parent - 代理的父类加载器。
factory - 创建 URL 时要使用的 URLStreamHandlerFactory。

MLet

public MLet(URL[] urls,
            boolean delegateToCLR)
使用默认的代理父类加载器为指定的 URL 构造新的 MLet。首先在父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。

参数：
urls - 从其指示的位置加载类和资源的 URL。
delegateToCLR - 如果该参数为 true，则当在父类加载器或 URL 中均未找到某个类时，MLet 应该委托给该类的包含 MBeanServer 的 ClassLoaderRepository。

MLet

public MLet(URL[] urls,
            ClassLoader parent,
            boolean delegateToCLR)
为给定的 URL 构造新的 MLet。首先在指定的父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。该父参数将用作代理的父类加载器。

参数：
urls - 从其指示的位置加载类和资源的 URL。
parent - 代理的父类加载器。
delegateToCLR - 如果该参数为 true，则当在父类加载器或 URL 中均未找到某个类时，MLet 应该委托给该类的包含 MBeanServer 的 ClassLoaderRepository。

MLet

public MLet(URL[] urls,
            ClassLoader parent,
            URLStreamHandlerFactory factory,
            boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新的 MLet。该父参数将用作代理的父类加载器。在创建新 URL 时，该工厂参数将用作获取协议处理程序的流处理程序工厂。

参数：
urls - 从其指示的位置加载类和资源的 URL。
parent - 代理的父类加载器。
factory - 创建 URL 时要使用的 URLStreamHandlerFactory。
delegateToCLR - 如果该参数为 true，则当在父类加载器或 URL 中均未找到某个类时，MLet 应该委托给该类的包含 MBeanServer 的 ClassLoaderRepository。
方法详细信息

addURL

public void addURL(URL url)
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

指定者：
接口 MLetMBean 中的 addURL
覆盖：
类 URLClassLoader 中的 addURL
参数：
url - 将添加到 URL 搜索路径中的 URL

addURL

public void addURL(String url)
            throws ServiceNotFoundException
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

指定者：
接口 MLetMBean 中的 addURL
参数：
url - 要添加的 URL。
抛出：
ServiceNotFoundException - 如果指定的 URL 错误。

getURLs

public URL[] getURLs()
返回用于加载类和资源的 URL 搜索路径。这包括为构造方法指定的原始 URL 列表，以及 addURL() 方法后来添加的 URL。

指定者：
接口 MLetMBean 中的 getURLs
覆盖：
类 URLClassLoader 中的 getURLs
返回：
用于加载类和资源的 URL 搜索路径。

getMBeansFromURL

public Set<Object> getMBeansFromURL(URL url)
                             throws ServiceNotFoundException
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。文本文件的位置由 URL 指定。MLET 文件中指定的 MBean 将被实例化并在 MBean 服务器中注册。

指定者：
接口 MLetMBean 中的 getMBeansFromURL
参数：
url - 以 URL 对象形式加载的文本文件的 URL。
返回：
一个集合，在所加载的 m-let 文本文件中，每个 MLET 标记都对应该集合中的一项。每一项要么指定了所创建的 MBean 的 ObjectInstance，要么在无法创建 MBean 时指定一个 throwable 对象（即一个错误或异常）。
抛出：
ServiceNotFoundException - 如果发生以下错误之一：m-let 文本文件不包含 MLET 标记；未找到 m-let 文本文件；未指定 MLET 标记的必需的属性；url 的值为 null。
IllegalStateException - 如果没有在 MBeanServer 中注册 MLet MBean。

getMBeansFromURL

public Set<Object> getMBeansFromURL(String url)
                             throws ServiceNotFoundException
加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。文本文件的位置由 URL 指定。MLET 文件中指定的 MBean 将被实例化并在 MBean 服务器中注册。

指定者：
接口 MLetMBean 中的 getMBeansFromURL
参数：
url - 以 String 对象形式加载的文本文件的 URL。
返回：
一个集合，在所加载的 m-let 文本文件中，每个 MLET 标记都对应该集合中的一项。每一项要么指定了所创建的 MBean 的 ObjectInstance，要么在无法创建 MBean 时指定一个 throwable 对象（即一个错误或异常）。
抛出：
ServiceNotFoundException - 如果发生以下错误之一：m-let 文本文件不包含 MLET 标记；未找到 m-let 文本文件；未指定 MLET 标记的必需的属性，url 错误。
IllegalStateException - 如果没有在 MBeanServer 中注册 MLet MBean。

getLibraryDirectory

public String getLibraryDirectory()
获取库加载器在将本机库加载到内存中之前用于存储这些本机库的当前目录。

指定者：
接口 MLetMBean 中的 getLibraryDirectory
返回：
库加载器使用的当前目录。
抛出：
UnsupportedOperationException - 如果此实现不支持以这种方式存储本机库。
另请参见：
setLibraryDirectory(java.lang.String)

setLibraryDirectory

public void setLibraryDirectory(String libdir)
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。

指定者：
接口 MLetMBean 中的 setLibraryDirectory
参数：
libdir - 库加载器使用的目录。
抛出：
UnsupportedOperationException - 如果此实现不支持以这种方式存储本机库。
另请参见：
getLibraryDirectory()

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。如果 ObjectName 为 null，则 m-let 为它的注册 <defaultDomain>:type=MLet 提供了一个默认名称。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
server - 将在其中注册 m-let 的 MBean 服务器。
name - m-let 的对象名称。
返回：
所注册的 m-let 名称。
抛出：
Exception - 此异常应由 MBean 服务器捕获，并以 MBeanRegistrationException 的形式重新抛出。

postRegister

public void postRegister(Boolean registrationDone)
允许 m-let 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示 m-let 是否已经成功注册到 MBean 服务器。值 false 意味着注册失败。

preDeregister

public void preDeregister()
                   throws Exception
允许 m-let 在由 MBean 服务器注销之前执行任何所需要的操作。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
java.langException - 此异常应由 MBean 服务器捕获，并以 MBeanRegistrationException 的形式重新抛出它。
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postDeregister

public void postDeregister()
允许 m-let 在已从 MBean 服务器注销之后执行任何所需要的操作。

指定者：
接口 MBeanRegistration 中的 postDeregister

writeExternal

public void writeExternal(ObjectOutput out)
                   throws IOException,
                          UnsupportedOperationException

将此 MLet 的内容保存到给定的 ObjectOutput。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改写入数据的格式。

写入数据的格式是未指定的，但如果某个实现支持 writeExternal(java.io.ObjectOutput)，则它必须也支持 readExternal(java.io.ObjectInput)，以便后者可以读取前者所写入的内容。

指定者：
接口 Externalizable 中的 writeExternal
参数：
out - 要写入的对象输出流。
抛出：
IOException - 如果在写入时发生问题。
UnsupportedOperationException - 如果此实现不支持此操作。

readExternal

public void readExternal(ObjectInput in)
                  throws IOException,
                         ClassNotFoundException,
                         UnsupportedOperationException

从给定的 ObjectInput 恢复此 MLet 的内容。不是所有的实现都支持此方法。不支持此方法的实现将抛出 UnsupportedOperationException。子类可以重写此方法以支持它或更改读取数据的格式。

读取数据的格式是未指定的，但如果某个实现支持 readExternal(java.io.ObjectInput)，则它必须也支持 writeExternal(java.io.ObjectOutput)，以便前者可以读取后者所写入的内容。

指定者：
接口 Externalizable 中的 readExternal
参数：
in - 要从中读取的对象输入流。
抛出：
IOException - 如果在读取时出现问题。
ClassNotFoundException - 如果找不到要恢复的对象的类。
UnsupportedOperationException - 如果此实现不支持此操作。

loadClass

public Class<?> loadClass(String name,
                          ClassLoaderRepository clr)
                   throws ClassNotFoundException

如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。给定的 ClassLoaderRepository 可以为 null，在这种情况下, 如果在此 MLet 的 URL 中找不到该类，则立即发生 ClassNotFoundException。

参数：
name - 想要加载的类名称。
clr - 在此类加载器中未找到给定类时用于搜索给定类的 ClassLoaderRepository。可以为 null。
返回：
得到的 Class 对象。
抛出：
ClassNotFoundException - 如果在此类加载器和给定的 ClassLoaderRepository 中均找不到指定的类。

findClass

protected Class<?> findClass(String name)
                      throws ClassNotFoundException
这是要重新定义的类加载器的主要方法。

覆盖：
类 URLClassLoader 中的 findClass
参数：
name - 类的名称。
返回：
得到的 Class 对象。
抛出：
ClassNotFoundException - 如果找不到指定的类。

findLibrary

protected String findLibrary(String libname)
返回本机库的绝对路径名称。虚拟机 (VM) 调用此方法查找属于利用此类加载器加载的类的本机库。首先只使用第一个本机库名称在 JAR 文件中搜索库，如果未找到这样的本机库，则使用本机库名称连同特定于架构的路径名（OSName/OSArch/OSVersion/lib/nativelibname）来搜索，即

Solaris SPARC 5.7 上的库 stat 将按照以下方式在 JAR 文件中进行搜索：

  1. libstat.so
  2. SunOS/sparc/5.7/lib/libstat.so
Windows NT 4.0 上的库 stat 将按照以下方式在 JAR 文件中进行搜索：
  1. stat.dll
  2. WindowsNT/x86/4.0/lib/stat.dll

更明确地说，可以设 nativelibname 为 System.mapLibraryName (libname) 的结果。这样将在 JAR 文件中依次搜索以下名称：
nativelibname
<os.name>/<os.arch>/<os.version>/lib/nativelibname
其中 <X> 表示 System.getProperty(X)（结果中不带空格）；/ 代表文件分隔符 (File.separator)。

如果此方法返回 null，即在任何使用此类加载器加载的 JAR 文件中都找不到库，则 VM 根据指定为 java.library.path 属性的路径搜索库。

覆盖：
类 ClassLoader 中的 findLibrary
参数：
libname - 库名称。
返回：
本机库的绝对路径。
另请参见：
System.loadLibrary(String), System.mapLibraryName(String)

check

protected URL check(String version,
                    URL codebase,
                    String jarfile,
                    MLetContent mlet)
             throws Exception

当扩展此服务来支持缓存和版本控制时，要重写此方法。当已经从 MLet 文件提取出版本、代码基和 jarfile 时，从 getMBeansFromURL 调用此方法，可以用它验证是否可以正确加载给定的 MBean，或者用不同的 URL 替换给定的 URL。

此方法的默认实现返回未更改的 codebase。

参数：
version - 本地存储的 .jar 文件的版本号。
codebase - 远程 .jar 文件的基本 URL。
jarfile - 要加载的 .jar 文件名称。
mlet - 表示 MLET 标记的 MLetContent 实例。
返回：
用于已加载 MBean 的代码基。返回值应该不为 null。
抛出：
Exception - 如果由于某种原因未加载 MBean。该异常将被添加到 getMBeansFromURL 返回的集合中。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MLetContent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.loading
类 MLetContent

java.lang.Object
    继承者  javax.management.loading.MLetContent

public class MLetContent
extends Object

此类表示 MLET 标记的内容。可以参考重写 MLet.check 方法的 MLet 的子类。

从以下版本开始：
1.6

构造方法摘要
MLetContent(URL url, Map<String,String> attributes, List<String> types, List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。
方法摘要
Map<String,String> | getAttributes() 获取 MLET 标记的属性。
String | getCode() 获取 MLET 标记的 CODE 属性的值。
URL | getCodeBase() 获取代码基 URL。
URL | getDocumentBase() 获取 MLet 文本文件的基本 URL。
String | getJarFiles() 获取由 MLET 标记的 ARCHIVE 属性指定的 .jar 文件的列表。
String | getName() 获取 MLET 标记的 NAME 属性的值。
List<String> | getParameterTypes() 获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。
List<String> | getParameterValues() 获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。
String | getSerializedObject() 获取 MLET 标记的 OBJECT 属性的值。
String | getVersion() 获取 MLET 标记的 VERSION 属性的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MLetContent

public MLetContent(URL url,
                   Map<String,String> attributes,
                   List<String> types,
                   List<String> values)
创建一个使用从 MLet 文本文件中的 MLET 标记读取的属性初始化的 MLet 实例。

参数：
url - 包含 MLET 标记的 MLet 文本文件的 URL。
attributes - MLET 标记的属性的映射。此映射中的键是小写字母形式的属性名称，例如 codebase。这些值是一些关联的属性值。
types - 在嵌套的 <PARAM> 标记中出现的 TYPE 属性的列表。
values - 在嵌套的 <PARAM> 标记中出现的 VALUE 属性的列表。
方法详细信息

getAttributes

public Map<String,String> getAttributes()
获取 MLET 标记的属性。所返回映射中的键是小写字母形式的属性名称，例如 codebase。这些值是一些相关的属性值。

返回：
MLET 标记的属性以及属性值的映射。

getDocumentBase

public URL getDocumentBase()
获取 MLet 文本文件的基本 URL。

返回：
MLet 文本文件的基本 URL。

getCodeBase

public URL getCodeBase()
获取代码基 URL。

返回：
代码基 URL。

getJarFiles

public String getJarFiles()
获取由 MLET 标记的 ARCHIVE 属性指定的 .jar 文件的列表。

返回：
逗号分隔的 .jar 文件名列表。

getCode

public String getCode()
获取 MLET 标记的 CODE 属性的值。

返回：
MLET 标记的 CODE 属性的值。

getSerializedObject

public String getSerializedObject()
获取 MLET 标记的 OBJECT 属性的值。

返回：
MLET 标记的 OBJECT 属性的值。

getName

public String getName()
获取 MLET 标记的 NAME 属性的值。

返回：
MLET 标记的 NAME 属性的值。

getVersion

public String getVersion()
获取 MLET 标记的 VERSION 属性的值。

返回：
MLET 标记的 VERSION 属性的值。

getParameterTypes

public List<String> getParameterTypes()
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 TYPE 属性值的列表。

返回：
类型列表。

getParameterValues

public List<String> getParameterValues()
获取 MLET 标记中每个嵌套 <PARAM> 标记中的 VALUE 属性值的列表。

返回：
值的列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MLetMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.loading
接口 MLetMBean

所有已知实现类：
MLet, PrivateMLet
public interface MLetMBean

公开 MLet MBean 的远程管理接口。

从以下版本开始：
1.5

方法摘要
void | addURL(String url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
void | addURL(URL url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
String | getLibraryDirectory() 获取在将本机库加载到内存中之前库加载器用来存储这些本机库的当前目录。
Set<Object> | getMBeansFromURL(String url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | getMBeansFromURL(URL url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
URL | getResource(String name) 查找具有给定名称的资源。
InputStream | getResourceAsStream(String name) 返回读取指定资源的输入流。
Enumeration<URL> | getResources(String name) 查找所有具有给定名称的资源。
URL[] | getURLs() 返回用于加载类和资源的 URL 搜索路径。
void | setLibraryDirectory(String libdir) 设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。

方法详细信息

getMBeansFromURL

Set<Object> getMBeansFromURL(String url)
                             throws ServiceNotFoundException
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。文本文件的位置由 URL 指定。使用 UTF-8 编码来读取文本文件。MLET 文件中指定的 MBean 将被实例化并在 MBean 服务器中注册。

参数：
url - 以 String 对象形式加载的文本文件的 URL。
返回：
一个集合，在所加载的 m-let 文本文件中，每个 MLET 标记都对应该集合中的一项。每一项要么指定了所创建的 MBean 的 ObjectInstance，要么在无法创建 MBean 时指定一个 throwable 对象（即一个错误或异常）。
抛出：
ServiceNotFoundException - 如果发生以下错误之一：m-let 文本文件不包含 MLET 标记；未找到 m-let 文本文件；未指定 MLET 标记的必需的属性；url 的值错误。

getMBeansFromURL

Set<Object> getMBeansFromURL(URL url)
                             throws ServiceNotFoundException
加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。文本文件的位置由 URL 指定。使用 UTF-8 编码来读取文本文件。MLET 文件中指定的 MBean 将被实例化并在 MBean 服务器中注册。

参数：
url - 以 URL 对象形式加载的文本文件的 URL。
返回：
一个集合，在所加载的 m-let 文本文件中，每个 MLET 标记都对应该集合中的一项。每一项要么指定了所创建的 MBean 的 ObjectInstance，要么在无法创建 MBean 时指定一个 throwable 对象（即一个错误或异常）。
抛出：
ServiceNotFoundException - 如果发生以下错误之一：m-let 文本文件不包含 MLET 标记；未找到 m-let 文本文件；未指定 MLET 标记的必需的属性；url 的值为 null。

addURL

void addURL(URL url)
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

参数：
url - 要添加的 URL。

addURL

void addURL(String url)
            throws ServiceNotFoundException
将指定的 URL 追加到 URL 列表中，以便搜索类和资源。

参数：
url - 要添加的 URL。
抛出：
ServiceNotFoundException - 如果指定的 URL 不正确。

getURLs

URL[] getURLs()
返回用于加载类和资源的 URL 搜索路径。这包括为构造方法指定的原始 URL 列表，以及 addURL() 方法后来添加的 URL。

返回：
URL 列表。

getResource

URL getResource(String name)
查找具有给定名称的资源。资源是能够用与代码基无关的方式通过类代码访问的一些数据（图像、声音、文本等）。资源名称是以 '/' 分隔的标识资源的路径名称。

参数：
name - 资源名称
返回：
读取资源的 URL，如果找不到该资源或者调用程序没有获取该资源的足够权限，则返回 null。

getResourceAsStream

InputStream getResourceAsStream(String name)
返回读取指定资源的输入流。getResource(String) 的文档中描述了搜索顺序。

参数：
name - 资源名称
返回：
用于读取资源的输入流，如果找不到该资源，则返回 null。

getResources

Enumeration<URL> getResources(String name)
                              throws IOException
查找所有具有给定名称的资源。资源是能够用与代码基无关的方式通过类代码访问的一些数据（图像、声音、文本等）。资源名称是以 '/' 分隔的标识资源的路径名称。

参数：
name - 资源名称。
返回：
指向资源的 URL 的枚举。如果找不到资源，则枚举为空。无法访问的资源将不在枚举中。
抛出：
IOException - 如果搜索资源时发生 I/O 异常。

getLibraryDirectory

String getLibraryDirectory()
获取在将本机库加载到内存中之前库加载器用来存储这些本机库的当前目录。

返回：
库加载器使用的当前目录。
抛出：
UnsupportedOperationException - 如果此实现不支持以这种方式存储本机库。
另请参见：
setLibraryDirectory(java.lang.String)

setLibraryDirectory

void setLibraryDirectory(String libdir)
设置在将本机库加载到内存中之前库加载器用来存储这些本机库的目录。

参数：
libdir - 库加载器使用的目录。
抛出：
UnsupportedOperationException - 如果此实现不支持以这种方式存储本机库。
另请参见：
getLibraryDirectory()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrivateClassLoader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.loading
接口 PrivateClassLoader

所有已知实现类：
PrivateMLet
public interface PrivateClassLoader

指示不应将某个 ClassLoader 添加到 ClassLoaderRepository 的标记接口。当将某个 ClassLoader 注册为 MBean 服务器中的 MBean 时，如果它没有实现此接口，则将它添加到 MBean 服务器的 ClassLoaderRepository 中。

从以下版本开始：
1.5

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrivateMLet (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.loading
类 PrivateMLet

java.lang.Object
    继承者  java.lang.ClassLoader
        继承者  java.security.SecureClassLoader
            继承者  java.net.URLClassLoader
                继承者  javax.management.loading.MLet
                    继承者  javax.management.loading.PrivateMLet
所有已实现的接口：
Externalizable, Serializable, MLetMBean, PrivateClassLoader, MBeanRegistration
public class PrivateMLet
extends MLet
implements PrivateClassLoader

不添加到 ClassLoaderRepository 的 MLet。此类的行为除一点之外，其余行为与其父类 MLet 完全相同。当在 MBean 服务器中注册 PrivateMLet 时，不将它添加到该 MBean 服务器的 ClassLoaderRepository 中。这是因为此类实现了 PrivateClassLoader 接口。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
PrivateMLet(URL[] urls, boolean delegateToCLR)
使用默认的委托父 ClassLoader 为指定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, boolean delegateToCLR)
为给定的 URL 构造新 PrivateMLet。
PrivateMLet(URL[] urls, ClassLoader parent, URLStreamHandlerFactory factory, boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。
方法摘要
从类 javax.management.loading.MLet 继承的方法
addURL, addURL, check, findClass, findLibrary, getLibraryDirectory, getMBeansFromURL, getMBeansFromURL, getURLs, loadClass, postDeregister, postRegister, preDeregister, preRegister, readExternal, setLibraryDirectory, writeExternal
从类 java.net.URLClassLoader 继承的方法
definePackage, findResource, findResources, getPermissions, newInstance, newInstance
从类 java.security.SecureClassLoader 继承的方法
defineClass, defineClass
从类 java.lang.ClassLoader 继承的方法
clearAssertionStatus, defineClass, defineClass, defineClass, defineClass, definePackage, findLoadedClass, findSystemClass, getPackage, getPackages, getParent, getResource, getResourceAsStream, getResources, getSystemClassLoader, getSystemResource, getSystemResourceAsStream, getSystemResources, loadClass, loadClass, resolveClass, setClassAssertionStatus, setDefaultAssertionStatus, setPackageAssertionStatus, setSigners
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.management.loading.MLetMBean 继承的方法
getResource, getResourceAsStream, getResources

构造方法详细信息

PrivateMLet

public PrivateMLet(URL[] urls,
                   boolean delegateToCLR)
使用默认的委托父 ClassLoader 为指定的 URL 构造新 PrivateMLet。首先在父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。

参数：
urls - 从其位置加载类和资源的 URL。
delegateToCLR - 当某个类在父 ClassLoader 或 URL 中均未找到时，如果 MLet 应该委托给其包含的 MBeanServer 的 ClassLoaderRepository，则为 true。

PrivateMLet

public PrivateMLet(URL[] urls,
                   ClassLoader parent,
                   boolean delegateToCLR)
为给定的 URL 构造新 PrivateMLet。首先在指定的父类加载器中搜索 URL，然后按照为类和资源指定的顺序搜索 URL。该父参数将用作委托的父类加载器。

参数：
urls - 从其位置加载类和资源的 URL。
parent - 委托的父类加载器。
delegateToCLR - 当某个类在父 ClassLoader 或 URL 中均未找到时，如果 MLet 应该委托给其包含的 MBeanServer 的 ClassLoaderRepository，则为 true。

PrivateMLet

public PrivateMLet(URL[] urls,
                   ClassLoader parent,
                   URLStreamHandlerFactory factory,
                   boolean delegateToCLR)
为指定的 URL、父类加载器和 URLStreamHandlerFactory 构造新 PrivateMLet。该父参数将用作委托的父类加载器。该工厂参数将用作创建新 URL 时获取协议处理程序的流处理程序工厂。

参数：
urls - 从其位置加载类和资源的 URL。
parent - 委托的父类加载器。
factory - 创建 URL 时要使用的 URLStreamHandlerFactory。
delegateToCLR - 当某个类在父 ClassLoader 或 URL 中均未找到时，如果 MLet 应该委托给其包含的 MBeanServer 的 ClassLoaderRepository，则为 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.loading (Java 2 Platform SE 6)

 javax.management.loading
接口
ClassLoaderRepository
MLetMBean
PrivateClassLoader
类
DefaultLoaderRepository
MLet
MLetContent
PrivateMLet


javax.management.loading (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.loading

提供实现高级动态加载的类。

请参见：
描述

接口摘要
ClassLoaderRepository | 此接口的实例用于保持在 MBean Server 中注册的 ClassLoader 的列表。
MLetMBean | 公开 MLet MBean 的远程管理接口。
PrivateClassLoader | 指示不应将某个 ClassLoader 添加到 ClassLoaderRepository 的标记接口。

类摘要
DefaultLoaderRepository | 已过时。 使用 MBeanServer.getClassLoaderRepository()} 替代。
MLet | 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
MLetContent | 此类表示 MLET 标记的内容。
PrivateMLet | 不添加到 ClassLoaderRepository 的 MLet。

软件包 javax.management.loading 的描述

提供实现高级动态加载的类。请参阅 JMX 规范中的高级动态加载 一章。

作为 ClassLoader 子类的 MBean 可用作类加载器，它通过 MBeanServer.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法创建其他 MBean，并且通过 MBeanServer.instantiate(String, ObjectName, Object[], String[]) 方法实例化任意对象。MLet 类是这种 MBean 的一个示例。因为它是一个 URLClassLoader，所以可以配置将从哪个 URL 列表加载类。

此外，MLet 可以读取一个配置文件，该文件指定了将在 MLet 所在的相同 MBean Server 中注册的 MBean 集合。

每个 MBean Server 都有一个包含注册到该 MBean Server 中的所有 MBean 的类加载器存储库，该 MBean Server 是 ClassLoader 的子类。类加载器存储库是以 MBeanServer 接口中的 createMBean 和 instantiate 方法的形式被使用，该接口没有显式的加载器参数。当在自己的 URL 集中找不到类时，还可以通过 MLet 类使用类加载器存储库。

如果某个 MBean 实现了 PrivateClassLoader 接口，那么不用将它添加到类加载器存储库中。PrivateMLet 类是实现了 PrivateClassLoader 的 MLet 的一个子类。

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology， 特别是 JMX Specification, version 1.4(pdf)。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.loading 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.loading 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.lang.ClassLoader
      • java.security.SecureClassLoader
        • java.net.URLClassLoader
          • javax.management.loading.MLet (implements java.io.Externalizable, javax.management.MBeanRegistration, javax.management.loading.MLetMBean)
            • javax.management.loading.PrivateMLet (implements javax.management.loading.PrivateClassLoader)
    • javax.management.loading.DefaultLoaderRepository
    • javax.management.loading.MLetContent

接口分层结构

  • javax.management.loading.ClassLoaderRepository
  • javax.management.loading.MLetMBean
  • javax.management.loading.PrivateClassLoader
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.loading 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.loading
的使用

使用 javax.management.loading 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 使用的 javax.management.loading 中的类
ClassLoaderRepository
此接口的实例用于保持在 MBean Server 中注册的 ClassLoader 的列表。

javax.management.loading 使用的 javax.management.loading 中的类
ClassLoaderRepository
此接口的实例用于保持在 MBean Server 中注册的 ClassLoader 的列表。
MLet
允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
MLetContent
此类表示 MLET 标记的内容。
MLetMBean
公开 MLet MBean 的远程管理接口。
PrivateClassLoader
指示不应将某个 ClassLoader 添加到 ClassLoaderRepository 的标记接口。

javax.management.modelmbean 使用的 javax.management.loading 中的类
ClassLoaderRepository
此接口的实例用于保持在 MBean Server 中注册的 ClassLoader 的列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.loading.ClassLoaderRepository 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.loading.ClassLoaderRepository
的使用

使用 ClassLoaderRepository 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 ClassLoaderRepository 的使用

返回 ClassLoaderRepository 的 javax.management 中的方法
ClassLoaderRepository | MBeanServer.getClassLoaderRepository() 返回此 MBeanServer 的 ClassLoaderRepository。
static ClassLoaderRepository | MBeanServerFactory.getClassLoaderRepository(MBeanServer server) 返回给定 MBeanServer 使用的 ClassLoaderRepository。

javax.management.loading 中 ClassLoaderRepository 的使用

参数类型为 ClassLoaderRepository 的 javax.management.loading 中的方法
 Class<?> MLet.loadClass(String name, ClassLoaderRepository clr)
如果在此 MLet 的 URL 中找不到某个类，则使用给定的 ClassLoaderRepository 加载该类。

javax.management.modelmbean 中 ClassLoaderRepository 的使用

返回 ClassLoaderRepository 的 javax.management.modelmbean 中的方法
protected  ClassLoaderRepository RequiredModelMBean.getClassLoaderRepository()
返回用于执行类加载的 Class Loader Repository。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.loading.DefaultLoaderRepository 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.DefaultLoaderRepository
的使用

没有 javax.management.loading.DefaultLoaderRepository 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.loading.MLet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.MLet
的使用

使用 MLet 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 MLet 的使用

javax.management.loading 中 MLet 的子类
 class PrivateMLet
不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.loading.MLetContent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.MLetContent
的使用

使用 MLetContent 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 MLetContent 的使用

参数类型为 MLetContent 的 javax.management.loading 中的方法
protected  URL MLet.check(String version, URL codebase, String jarfile, MLetContent mlet)
当扩展此服务来支持缓存和版本控制时，要重写此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.loading.MLetMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.loading.MLetMBean
的使用

使用 MLetMBean 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 MLetMBean 的使用

实现 MLetMBean 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.loading.PrivateClassLoader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.loading.PrivateClassLoader
的使用

使用 PrivateClassLoader 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 PrivateClassLoader 的使用

实现 PrivateClassLoader 的 javax.management.loading 中的类
 class PrivateMLet
不添加到 ClassLoaderRepository 的 MLet。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.loading.PrivateMLet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.loading.PrivateMLet
的使用

没有 javax.management.loading.PrivateMLet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


CounterMonitor (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
类 CounterMonitor

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.monitor.Monitor
            继承者  javax.management.monitor.CounterMonitor
所有已实现的接口：
MBeanRegistration, CounterMonitorMBean, MonitorMBean, NotificationBroadcaster, NotificationEmitter
public class CounterMonitor
extends Monitor
implements CounterMonitorMBean

定义专门用来观察计数器属性值的监视器 MBean。

当计数器的值达到或超过已知比较级别阈值时，计数器监视器将发送一个阈值通知。必须将通知标志设置为 true。

另外，偏移量机制支持对特定计数区间的检测。如果偏移量值不为零，则每当计数器值达到比较级别而触发该阈值时，比较级别都将递增该偏移量值。这是在瞬间完成的，即在增加计数前完成。因此，对于每个级别，每当计数增加的区间等于偏移值时，阈值都将触发一个事件通知。

如果计数器能够包含其最大值，则必须指定模。模是将计数器重置为零时的值。

如果使用了计数器差分模式，则派生的尺度值将被视为两次连续观察到的计数器值之间的差分。如果此差分为负值，则派生的尺度值将增加该模的值。派生的尺度值 (V[t]) 是使用以下方法计算的：

  • if (counter[t] - counter[t-GP]) is positive then V[t] = counter[t] - counter[t-GP]
  • if (counter[t] - counter[t-GP]) is negative then V[t] = counter[t] - counter[t-GP] + MODULUS
计数器监视器的这一实现要求 observed 属性的类型为整数（Byte、Integer、Short 和 Long）。

从以下版本开始：
1.5

字段摘要
从类 javax.management.monitor.Monitor 继承的字段
alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server
构造方法摘要
CounterMonitor()
默认的构造方法。
方法摘要
Number | getDerivedGauge() 已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代
Number | getDerivedGauge(ObjectName object) 如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
long | getDerivedGaugeTimeStamp() 已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代
long | getDerivedGaugeTimeStamp(ObjectName object) 如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
boolean | getDifferenceMode() 获取所有观察到的 MBeans 的共同的差分模式标志值。
Number | getInitThreshold() 获取所有观察对象的公共初始阈值。
Number | getModulus() 获取所有观察到的 MBeans 共同的模值。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由计数器监视器发送的通知类型。
boolean | getNotify() 获取所有观察到的 MBeans 共同的通知的开/关切换值。
Number | getOffset() 获取所有观察到的 MBeans 共同的偏移量值。
Number | getThreshold() 已过时。 从 JMX 1.2 开始，由 getThreshold(ObjectName) 取代
Number | getThreshold(ObjectName object) 如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。
void | setDifferenceMode(boolean value) 设置所有观察到的 MBeans 的共同的差分模式标志值。
void | setInitThreshold(Number value) 设置所有观察对象的共同初始阈值。
void | setModulus(Number value) 设置所有观察到的 MBeans 共同的模值。
void | setNotify(boolean value) 设置所有观察到的 MBeans 共同的通知的开/关切换值。
void | setOffset(Number value) 设置所有观察到的 MBeans 共同的偏移量值。
void | setThreshold(Number value) 已过时。 从 JMX 1.2 开始，由 setInitThreshold(java.lang.Number) 取代
void | start() 启动计数器监视器。
void | stop() 停止计数器监视器。
从类 javax.management.monitor.Monitor 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.management.monitor.MonitorMBean 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

构造方法详细信息

CounterMonitor

public CounterMonitor()
默认的构造方法。

方法详细信息

start

public void start()
启动计数器监视器。

指定者：
接口 MonitorMBean 中的 start
指定者：
类 Monitor 中的 start

stop

public void stop()
停止计数器监视器。

指定者：
接口 MonitorMBean 中的 stop
指定者：
类 Monitor 中的 stop

getDerivedGauge

public Number getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。

指定者：
接口 CounterMonitorMBean 中的 getDerivedGauge
参数：
object - 将返回其派生尺度的对象的名称。
返回：
指定对象的派生尺度。

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。

指定者：
接口 CounterMonitorMBean 中的 getDerivedGaugeTimeStamp
参数：
object - 将返回其派生尺度时间戳的对象的名称。
返回：
指定对象的派生尺度时间戳。

getThreshold

public Number getThreshold(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。

指定者：
接口 CounterMonitorMBean 中的 getThreshold
参数：
object - 将返回其阈值的对象的名称。
返回：
指定对象的阈值。
另请参见：
CounterMonitorMBean.setThreshold(java.lang.Number)

getInitThreshold

public Number getInitThreshold()
获取所有观察对象的公共初始阈值。

指定者：
接口 CounterMonitorMBean 中的 getInitThreshold
返回：
初始阈值。
另请参见：
setInitThreshold(java.lang.Number)

setInitThreshold

public void setInitThreshold(Number value)
                      throws IllegalArgumentException
设置所有观察对象的共同初始阈值。
所观察 MBeans 集中每个对象的当前阈值都将因此得到更新。

指定者：
接口 CounterMonitorMBean 中的 setInitThreshold
参数：
value - 初始阈值。
抛出：
IllegalArgumentException - 指定的阈值为 null，或者阈值小于零。
另请参见：
getInitThreshold()

getDerivedGauge

@Deprecated
public Number getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代

返回所观察 MBeans 集中第一个对象的派生尺度。

指定者：
接口 CounterMonitorMBean 中的 getDerivedGauge
返回：
派生的尺度。

getDerivedGaugeTimeStamp

@Deprecated
public long getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代

获取所观察 MBeans 集中第一个对象的派生尺度时间戳。

指定者：
接口 CounterMonitorMBean 中的 getDerivedGaugeTimeStamp
返回：
派生的尺度时间戳。

getThreshold

@Deprecated
public Number getThreshold()
已过时。 从 JMX 1.2 开始，由 getThreshold(ObjectName) 取代

返回所观察 MBeans 集中第一个对象的阈值。

指定者：
接口 CounterMonitorMBean 中的 getThreshold
返回：
阈值。
另请参见：
setThreshold(java.lang.Number)

setThreshold

@Deprecated
public void setThreshold(Number value)
                  throws IllegalArgumentException
已过时。 从 JMX 1.2 开始，由 setInitThreshold(java.lang.Number) 取代

设置初始阈值。

指定者：
接口 CounterMonitorMBean 中的 setThreshold
参数：
value - 初始阈值。
抛出：
IllegalArgumentException - 指定的阈值为 null，或者该阈值小于零。
另请参见：
getThreshold()

getOffset

public Number getOffset()
获取所有观察到的 MBeans 共同的偏移量值。

指定者：
接口 CounterMonitorMBean 中的 getOffset
返回：
偏移量值。
另请参见：
setOffset(java.lang.Number)

setOffset

public void setOffset(Number value)
               throws IllegalArgumentException
设置所有观察到的 MBeans 共同的偏移量值。

指定者：
接口 CounterMonitorMBean 中的 setOffset
参数：
value - 偏移量值。
抛出：
IllegalArgumentException - 指定的偏移量值为 null，或者该偏移量值小于零。
另请参见：
getOffset()

getModulus

public Number getModulus()
获取所有观察到的 MBeans 共同的模值。

指定者：
接口 CounterMonitorMBean 中的 getModulus
返回：
模值。
另请参见：
setModulus(java.lang.Number)

setModulus

public void setModulus(Number value)
                throws IllegalArgumentException
设置所有观察到的 MBeans 共同的模值。

指定者：
接口 CounterMonitorMBean 中的 setModulus
参数：
value - 模值。
抛出：
IllegalArgumentException - 指定的模为 null，或者该模小于零。
另请参见：
getModulus()

getNotify

public boolean getNotify()
获取所有观察到的 MBeans 共同的通知的开/关切换值。

指定者：
接口 CounterMonitorMBean 中的 getNotify
返回：
如果超出阈值时计数器监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotify(boolean)

setNotify

public void setNotify(boolean value)
设置所有观察到的 MBeans 共同的通知的开/关切换值。

指定者：
接口 CounterMonitorMBean 中的 setNotify
参数：
value - 通知的开/关切换值。
另请参见：
getNotify()

getDifferenceMode

public boolean getDifferenceMode()
获取所有观察到的 MBeans 的共同的差分模式标志值。

指定者：
接口 CounterMonitorMBean 中的 getDifferenceMode
返回：
如果使用了差分模式，则返回 true；否则返回 false。
另请参见：
setDifferenceMode(boolean)

setDifferenceMode

public void setDifferenceMode(boolean value)
设置所有观察到的 MBeans 的共同的差分模式标志值。

指定者：
接口 CounterMonitorMBean 中的 setDifferenceMode
参数：
value - 差分模式标志值。
另请参见：
getDifferenceMode()

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由计数器监视器发送的通知类型。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
覆盖：
类 NotificationBroadcasterSupport 中的 getNotificationInfo
返回：
可能的通知数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CounterMonitorMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
接口 CounterMonitorMBean

所有超级接口：
MonitorMBean
所有已知实现类：
CounterMonitor
public interface CounterMonitorMBean
extends MonitorMBean

公开计数器监视器 MBean 的远程管理接口。

从以下版本开始：
1.5

方法摘要
Number | getDerivedGauge() 已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代
Number | getDerivedGauge(ObjectName object) 获取指定的 MBean 的派生尺度。
long | getDerivedGaugeTimeStamp() 已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代
long | getDerivedGaugeTimeStamp(ObjectName object) 获取指定 MBean 的派生尺度时间戳。
boolean | getDifferenceMode() 获取差分模式标志值。
Number | getInitThreshold() 获取所有 observed 对象的公共初始阈值。
Number | getModulus() 获取模值。
boolean | getNotify() 获取通知的开/关切换值。
Number | getOffset() 获取偏移值。
Number | getThreshold() 已过时。 从 JMX 1.2 开始，由 getThreshold(ObjectName) 取代
Number | getThreshold(ObjectName object) 获取指定 MBean 的阈值。
void | setDifferenceMode(boolean value) 设置差分模式标志值。
void | setInitThreshold(Number value) 设置所有观察到的 MBeans 的公共初始阈值。
void | setModulus(Number value) 设置模值。
void | setNotify(boolean value) 设置通知的开/关切换值。
void | setOffset(Number value) 设置偏移量值。
void | setThreshold(Number value) 已过时。 从 JMX 1.2 开始，由 setInitThreshold(java.lang.Number) 取代
从接口 javax.management.monitor.MonitorMBean 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

方法详细信息

getDerivedGauge

@Deprecated
Number getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代

获取派生的尺度。

返回：
派生的尺度。

getDerivedGaugeTimeStamp

@Deprecated
long getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代

获取派生的尺度时间戳。

返回：
派生的尺度时间戳。

getThreshold

@Deprecated
Number getThreshold()
已过时。 从 JMX 1.2 开始，由 getThreshold(ObjectName) 取代

获取阈值。

返回：
阈值。
另请参见：
setThreshold(Number)

setThreshold

@Deprecated
void setThreshold(Number value)
                  throws IllegalArgumentException
已过时。 从 JMX 1.2 开始，由 setInitThreshold(java.lang.Number) 取代

设置阈值。

参数：
value - 阈值。
抛出：
IllegalArgumentException - 指定的阈值为 null，或者阈值小于零。
另请参见：
getThreshold()

getDerivedGauge

Number getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。

参数：
object - 将为其返回派生尺度的 MBean
返回：
如果指定的 MBean 在所观察的 MBean 集中，则返回该 MBeans 的派生尺度，否则，返回 null。

getDerivedGaugeTimeStamp

long getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。

参数：
object - 将为其返回派生的尺度时间戳的 MBean
返回：
如果指定的 MBean 在所观察的 MBean 集中，则返回该 MBeans 的派生尺度时间戳，否则返回 null。

getThreshold

Number getThreshold(ObjectName object)
获取指定 MBean 的阈值。

参数：
object - 将为其返回阈值的 MBean
返回：
如果指定 MBean 在所观察的 MBean 集中，则返回该 MBeans 的阈值，否则返回 null。
另请参见：
setThreshold(java.lang.Number)

getInitThreshold

Number getInitThreshold()
获取所有 observed 对象的公共初始阈值。

返回：
初始阈值。
另请参见：
setInitThreshold(java.lang.Number)

setInitThreshold

void setInitThreshold(Number value)
                      throws IllegalArgumentException
设置所有观察到的 MBeans 的公共初始阈值。

参数：
value - 初始阈值。
抛出：
IllegalArgumentException - 指定的阈值为 null，或者阈值小于零。
另请参见：
getInitThreshold()

getOffset

Number getOffset()
获取偏移值。

返回：
偏移量值。
另请参见：
setOffset(Number)

setOffset

void setOffset(Number value)
               throws IllegalArgumentException
设置偏移量值。

参数：
value - 偏移量值。
抛出：
IllegalArgumentException - 指定的偏移量值为 null，或者该偏移量值小于零。
另请参见：
getOffset()

getModulus

Number getModulus()
获取模值。

返回：
模值。
另请参见：
setModulus(java.lang.Number)

setModulus

void setModulus(Number value)
                throws IllegalArgumentException
设置模值。

参数：
value - 模值。
抛出：
IllegalArgumentException - 指定的模为 null，或者该模小于零。
另请参见：
getModulus()

getNotify

boolean getNotify()
获取通知的开/关切换值。

返回：
如果超出阈值时计数器监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotify(boolean)

setNotify

void setNotify(boolean value)
设置通知的开/关切换值。

参数：
value - 通知的开/关切换值。
另请参见：
getNotify()

getDifferenceMode

boolean getDifferenceMode()
获取差分模式标志值。

返回：
如果使用了差分模式，则返回 true；否则返回 false。
另请参见：
setDifferenceMode(boolean)

setDifferenceMode

void setDifferenceMode(boolean value)
设置差分模式标志值。

参数：
value - 差分模式标志值。
另请参见：
getDifferenceMode()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GaugeMonitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
类 GaugeMonitor

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.monitor.Monitor
            继承者  javax.management.monitor.GaugeMonitor
所有已实现的接口：
MBeanRegistration, GaugeMonitorMBean, MonitorMBean, NotificationBroadcaster, NotificationEmitter
public class GaugeMonitor
extends Monitor
implements GaugeMonitorMBean

定义专门用来观察尺度属性值的监视器 MBean。

尺度监视器观察随着时间发展而不断变化的属性。尺度监视器将根据以下情况发送通知：

  • 如果属性值增加，变得与高阈值相等或大于高阈值，则发送一个阈值过高通知。必须将 notify high 标志设置为 true。
    除非属性值变得与低阈值相等或小于低阈值，否则高阈值的后续超出不会引发更多通知。
  • 如果属性值减小，变得与低阈值相等或小于低阈值，则将发送一个阈值过低通知。必须将 notify low 标志设置为 true。
    除非属性值变得等于或大于高阈值，否则后续低于阈值的超出不会引发更多通知。
这提供了一种滞后机制，可以避免属性值围绕高、低阈值小幅度摆动时重复触发通知。

如果使用了尺度差分模式，则派生的尺度值将被视为两次连续观察到的观察尺度值之间的差分。
派生的尺度值 (V[t]) 是使用以下方法计算的：

  • V[t] = gauge[t] - gauge[t-GP]
尺度监视器的这一实现需要 observed 属性的类型为整数或浮点型（Byte、Integer、Short、Long、Float 和 Double）。

从以下版本开始：
1.5

字段摘要
从类 javax.management.monitor.Monitor 继承的字段
alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server
构造方法摘要
GaugeMonitor()
默认的构造方法。
方法摘要
Number | getDerivedGauge() 已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代
Number | getDerivedGauge(ObjectName object) 如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
long | getDerivedGaugeTimeStamp() 已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代
long | getDerivedGaugeTimeStamp(ObjectName object) 如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
boolean | getDifferenceMode() 获取所有观察到的 MBean 的公共差分模式标志值。
Number | getHighThreshold() 获取所有所观察的 MBean 的公共高阈值。
Number | getLowThreshold() 获取所有观察到的 MBean 的公共低阈值。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由尺度监视器发送的通知类型。
boolean | getNotifyHigh() 获取所有观察到的 MBean 的公共高阈值通知 (high notification) 的开/关切换值。
boolean | getNotifyLow() 获取所有观察到的 MBean 的公共低阈值通知 (low notification) 的开/关切换值。
void | setDifferenceMode(boolean value) 设置所有观察到的 MBean 的公共差分模式标志值。
void | setNotifyHigh(boolean value) 设置所有观察到的 MBean 的公共高阈值通知的开/关切换值。
void | setNotifyLow(boolean value) 设置所有观察到的 MBean 的公共低阈值通知的开/关切换值。
void | setThresholds(Number highValue, Number lowValue) 设置所有观察到的 MBean 的公共高、低阈值。
void | start() 启用尺度监视器。
void | stop() 停止尺度监视器。
从类 javax.management.monitor.Monitor 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.management.monitor.MonitorMBean 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

构造方法详细信息

GaugeMonitor

public GaugeMonitor()
默认的构造方法。

方法详细信息

start

public void start()
启用尺度监视器。

指定者：
接口 MonitorMBean 中的 start
指定者：
类 Monitor 中的 start

stop

public void stop()
停止尺度监视器。

指定者：
接口 MonitorMBean 中的 stop
指定者：
类 Monitor 中的 stop

getDerivedGauge

public Number getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。

指定者：
接口 GaugeMonitorMBean 中的 getDerivedGauge
参数：
object - MBean 的名称。
返回：
指定对象的派生尺度。

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。

指定者：
接口 GaugeMonitorMBean 中的 getDerivedGaugeTimeStamp
参数：
object - 将返回其派生尺度时间戳的对象的名称。
返回：
指定对象的派生尺度时间戳。

getDerivedGauge

@Deprecated
public Number getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代

返回所观察的 MBean 集中第一个对象的派生尺度。

指定者：
接口 GaugeMonitorMBean 中的 getDerivedGauge
返回：
派生的尺度。

getDerivedGaugeTimeStamp

@Deprecated
public long getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代

获取所观察的 MBeans 集中第一个对象的派生尺度时间戳。

指定者：
接口 GaugeMonitorMBean 中的 getDerivedGaugeTimeStamp
返回：
派生的尺度时间戳。

getHighThreshold

public Number getHighThreshold()
获取所有所观察的 MBean 的公共高阈值。

指定者：
接口 GaugeMonitorMBean 中的 getHighThreshold
返回：
高阈值。
另请参见：
setThresholds(java.lang.Number, java.lang.Number)

getLowThreshold

public Number getLowThreshold()
获取所有观察到的 MBean 的公共低阈值。

指定者：
接口 GaugeMonitorMBean 中的 getLowThreshold
返回：
低阈值。
另请参见：
setThresholds(java.lang.Number, java.lang.Number)

setThresholds

public void setThresholds(Number highValue,
                          Number lowValue)
                   throws IllegalArgumentException
设置所有观察到的 MBean 的公共高、低阈值。

指定者：
接口 GaugeMonitorMBean 中的 setThresholds
参数：
highValue - 高阈值。
lowValue - 低阈值。
抛出：
IllegalArgumentException - 指定的高/低阈值为 null，或者低阈值大于高阈值，或者高、低阈值不属于同一类型。
另请参见：
getHighThreshold(), getLowThreshold()

getNotifyHigh

public boolean getNotifyHigh()
获取所有观察到的 MBean 的公共高阈值通知 (high notification) 的开/关切换值。

指定者：
接口 GaugeMonitorMBean 中的 getNotifyHigh
返回：
如果超出高阈值时尺度监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotifyHigh(boolean)

setNotifyHigh

public void setNotifyHigh(boolean value)
设置所有观察到的 MBean 的公共高阈值通知的开/关切换值。

指定者：
接口 GaugeMonitorMBean 中的 setNotifyHigh
参数：
value - 高阈值通知的开/关切换值。
另请参见：
getNotifyHigh()

getNotifyLow

public boolean getNotifyLow()
获取所有观察到的 MBean 的公共低阈值通知 (low notification) 的开/关切换值。

指定者：
接口 GaugeMonitorMBean 中的 getNotifyLow
返回：
如果超过低阈值时尺度监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotifyLow(boolean)

setNotifyLow

public void setNotifyLow(boolean value)
设置所有观察到的 MBean 的公共低阈值通知的开/关切换值。

指定者：
接口 GaugeMonitorMBean 中的 setNotifyLow
参数：
value - 低阈值通知的开/关切换值。
另请参见：
getNotifyLow()

getDifferenceMode

public boolean getDifferenceMode()
获取所有观察到的 MBean 的公共差分模式标志值。

指定者：
接口 GaugeMonitorMBean 中的 getDifferenceMode
返回：
如果使用了差分模式，则返回 true；否则返回 false。
另请参见：
setDifferenceMode(boolean)

setDifferenceMode

public void setDifferenceMode(boolean value)
设置所有观察到的 MBean 的公共差分模式标志值。

指定者：
接口 GaugeMonitorMBean 中的 setDifferenceMode
参数：
value - 差分模式标志值。
另请参见：
getDifferenceMode()

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由尺度监视器发送的通知类型。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
覆盖：
类 NotificationBroadcasterSupport 中的 getNotificationInfo
返回：
可能的通知数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GaugeMonitorMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
接口 GaugeMonitorMBean

所有超级接口：
MonitorMBean
所有已知实现类：
GaugeMonitor
public interface GaugeMonitorMBean
extends MonitorMBean

公开尺度监视器 MBean 的远程管理接口。

从以下版本开始：
1.5

方法摘要
Number | getDerivedGauge() 已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代
Number | getDerivedGauge(ObjectName object) 获取指定的 MBean 的派生尺度。
long | getDerivedGaugeTimeStamp() 已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代
long | getDerivedGaugeTimeStamp(ObjectName object) 获取指定 MBean 的派生尺度时间戳。
boolean | getDifferenceMode() 获取差分模式标志值。
Number | getHighThreshold() 获取高阈值。
Number | getLowThreshold() 获取低阈值。
boolean | getNotifyHigh() 获取高阈值通知的开/关切换值。
boolean | getNotifyLow() 获取低阈值通知的开/关切换值。
void | setDifferenceMode(boolean value) 设置差分模式标志值。
void | setNotifyHigh(boolean value) 设置高阈值通知的开/关切换值。
void | setNotifyLow(boolean value) 设置低阈值通知的开/关切换值。
void | setThresholds(Number highValue, Number lowValue) 设置高、低阈值。
从接口 javax.management.monitor.MonitorMBean 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

方法详细信息

getDerivedGauge

@Deprecated
Number getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代

获取派生的尺度。

返回：
派生的尺度。

getDerivedGaugeTimeStamp

@Deprecated
long getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代

获取派生的尺度时间戳。

返回：
派生的尺度时间戳。

getDerivedGauge

Number getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。

参数：
object - 将为其返回派生的尺度的 MBean
返回：
如果指定的 MBean 在所观察的 MBean 集中，则返回该 MBeans 的派生尺度，否则返回 null。

getDerivedGaugeTimeStamp

long getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。

参数：
object - 将为其返回派生的尺度时间戳的 MBean
返回：
如果指定的 MBean 在所观察的 MBean 集中，则返回该 MBeans 的派生尺度时间戳，否则返回 null。

getHighThreshold

Number getHighThreshold()
获取高阈值。

返回：
高阈值。

getLowThreshold

Number getLowThreshold()
获取低阈值。

返回：
低阈值。

setThresholds

void setThresholds(Number highValue,
                   Number lowValue)
                   throws IllegalArgumentException
设置高、低阈值。

参数：
highValue - 高阈值。
lowValue - 低阈值。
抛出：
IllegalArgumentException - 指定的高/低阈值为 null，或者低阈值大于高阈值，或者高、低阈值不属于同一类型。

getNotifyHigh

boolean getNotifyHigh()
获取高阈值通知的开/关切换值。

返回：
如果超出高阈值时尺度监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotifyHigh(boolean)

setNotifyHigh

void setNotifyHigh(boolean value)
设置高阈值通知的开/关切换值。

参数：
value - 高阈值通知的开/关切换值。
另请参见：
getNotifyHigh()

getNotifyLow

boolean getNotifyLow()
获取低阈值通知的开/关切换值。

返回：
如果超过低阈值时尺度监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotifyLow(boolean)

setNotifyLow

void setNotifyLow(boolean value)
设置低阈值通知的开/关切换值。

参数：
value - 低阈值通知的开/关切换值。
另请参见：
getNotifyLow()

getDifferenceMode

boolean getDifferenceMode()
获取差分模式标志值。

返回：
如果使用了差分模式，则返回 true；否则返回 false。
另请参见：
setDifferenceMode(boolean)

setDifferenceMode

void setDifferenceMode(boolean value)
设置差分模式标志值。

参数：
value - 差分模式标志值。
另请参见：
getDifferenceMode()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Monitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
类 Monitor

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.monitor.Monitor
所有已实现的接口：
MBeanRegistration, MonitorMBean, NotificationBroadcaster, NotificationEmitter
直接已知子类：
CounterMonitor, GaugeMonitor, StringMonitor
public abstract class Monitor
extends NotificationBroadcasterSupport
implements MonitorMBean, MBeanRegistration

定义所有监视器 MBean 的公共部分。监视器 MBean 监视所观察的 MBean 集的共同属性值。将根据粒度周期指定的区间监视 observed 属性。尺度值（派生尺度）从 observed 属性的值中派生。

从以下版本开始：
1.5

字段摘要
protected int | alreadyNotified 已过时。 等效于 alreadyNotifieds[0]。
protected int[] | alreadyNotifieds 已经通知的选定监视器错误。
protected static int | capacityIncrement 监视器数组的大小大于其容量时，容量自动递增的量。
protected String | dbgTag 已过时。 无替代版本。
protected int | elementCount 被观察对象的向量中的有效组件数。
protected static int | OBSERVED_ATTRIBUTE_ERROR_NOTIFIED 表示已在更改被观察属性之后发出了通知的标志。
protected static int | OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED 表示已在更改被观察对象或被观察属性之后发出了通知的标志。
protected static int | OBSERVED_OBJECT_ERROR_NOTIFIED 表示在更改被观察对象之后已发出通知的标志。
protected static int | RESET_FLAGS_ALREADY_NOTIFIED 此标志用来重新设置 alreadyNotifieds 监视器属性。
protected static int | RUNTIME_ERROR_NOTIFIED 表示已在更改被观察对象或被观察属性之后发出了通知的标志。
protected MBeanServer | server 对 MBean 服务器的引用。
构造方法摘要
Monitor()
方法摘要
 void addObservedObject(ObjectName object)
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。
 boolean containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。
 long getGranularityPeriod()
获取粒度周期（以毫秒为单位）。
 String getObservedAttribute()
获取要观察的属性。
 ObjectName getObservedObject()
已过时。 从 JMX 1.2 开始，由 getObservedObjects() 取代
 ObjectName[] getObservedObjects()
返回一个包含要观察的对象的数组。
 boolean isActive()
测试监视器 MBean 是否处于激活状态。
 void postDeregister()
允许在 MBean 服务器注销监视器 MBean 之前执行所需的任何操作。
 void postRegister(Boolean registrationDone)
允许在 MBean 服务器中注册监视器 MBean 后或注册失败后执行所需的任何操作。
 void preDeregister()
允许在 MBean 服务器注销监视器 MBean 之前执行监视器 MBean 所需要的任何操作。
 ObjectName preRegister(MBeanServer server, ObjectName name)
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。
 void removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。
 void setGranularityPeriod(long period)
设置粒度周期（以毫秒为单位）。
 void setObservedAttribute(String attribute)
设置要观察的属性。
 void setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 addObservedObject(javax.management.ObjectName) 取代
abstract  void start()
启动监视器。
abstract  void stop()
停止监视器。
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, getNotificationInfo, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

capacityIncrement

protected static final int capacityIncrement
监视器数组的大小大于其容量时，容量自动递增的量。

另请参见：
常量字段值

elementCount

protected int elementCount
被观察对象的向量中的有效组件数。

alreadyNotified

@Deprecated
protected int alreadyNotified
已过时。 等效于 alreadyNotifieds[0]。
已经通知的监视器错误。

alreadyNotifieds

protected int[] alreadyNotifieds

已经通知的选定监视器错误。

此数组中的每个元素都对应于向量中的某个被观察对象。它包含标志 OBSERVED_OBJECT_ERROR_NOTIFIED 等的位掩码，表示是否已经为要监视的 MBean 发送了相应的通知。

server

protected MBeanServer server
对 MBean 服务器的引用。如果没有在 MBean 服务器中注册监视器 MBean，则此引用将为 null。在 MBean 服务器中注册监视器 MBean 之前，要先初始化此引用。

另请参见：
preRegister(MBeanServer server, ObjectName name)

RESET_FLAGS_ALREADY_NOTIFIED

protected static final int RESET_FLAGS_ALREADY_NOTIFIED
此标志用来重新设置 alreadyNotifieds 监视器属性。

另请参见：
常量字段值

OBSERVED_OBJECT_ERROR_NOTIFIED

protected static final int OBSERVED_OBJECT_ERROR_NOTIFIED
表示在更改被观察对象之后已发出通知的标志。此标志用来检查在初次发出通知时是否已在 MBean 服务器中注册了新的被观察对象。

另请参见：
常量字段值

OBSERVED_ATTRIBUTE_ERROR_NOTIFIED

protected static final int OBSERVED_ATTRIBUTE_ERROR_NOTIFIED
表示已在更改被观察属性之后发出了通知的标志。此标志用来检查在初次发出通知时新的被观察属性是否属于被观察对象。

另请参见：
常量字段值

OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED

protected static final int OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED
表示已在更改被观察对象或被观察属性之后发出了通知的标志。此标志用来检查被观察属性的类型在初次发出通知时是否正确（取决正在使用的监视器）。

另请参见：
常量字段值

RUNTIME_ERROR_NOTIFIED

protected static final int RUNTIME_ERROR_NOTIFIED
表示已在更改被观察对象或被观察属性之后发出了通知的标志。此标志用来在初次发出通知后尝试获得被观察属性的值时通知任何异常（上述情况除外）。

另请参见：
常量字段值

dbgTag

@Deprecated
protected String dbgTag
已过时。 无替代版本。
出于兼容的目的，对此字段进行了保留，但不建议引用它。

构造方法详细信息

Monitor

public Monitor()
方法详细信息

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。

初始化对 MBean 服务器的引用。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
server - 将在其中注册监视器 MBean 的 MBean 服务器。
name - 监视器 MBean 的对象名称。
返回：
注册的监视器 MBean 的名称。
抛出：
Exception

postRegister

public void postRegister(Boolean registrationDone)
允许在 MBean 服务器中注册监视器 MBean 后或注册失败后执行所需的任何操作。

未在此上下文中使用。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示该 MBean 是否已在 MBean 服务器中成功注册。false 值意味着注册阶段已失败。

preDeregister

public void preDeregister()
                   throws Exception
允许在 MBean 服务器注销监视器 MBean 之前执行监视器 MBean 所需要的任何操作。

停止监视器。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
Exception

postDeregister

public void postDeregister()
允许在 MBean 服务器注销监视器 MBean 之前执行所需的任何操作。

未在此上下文中使用。

指定者：
接口 MBeanRegistration 中的 postDeregister

start

public abstract void start()
启动监视器。

指定者：
接口 MonitorMBean 中的 start

stop

public abstract void stop()
停止监视器。

指定者：
接口 MonitorMBean 中的 stop

getObservedObject

@Deprecated
public ObjectName getObservedObject()
已过时。 从 JMX 1.2 开始，由 getObservedObjects() 取代

返回观察到的 MBean 集中第一个对象的名称，如果没有此对象，则返回 null。

指定者：
接口 MonitorMBean 中的 getObservedObject
返回：
要观察的对象。
另请参见：
setObservedObject(ObjectName)

setObservedObject

@Deprecated
public void setObservedObject(ObjectName object)
                       throws IllegalArgumentException
已过时。 从 JMX 1.2 开始，由 addObservedObject(javax.management.ObjectName) 取代

从 observed 对象集中移除所有的对象，然后添加指定的对象。

指定者：
接口 MonitorMBean 中的 setObservedObject
参数：
object - 要观察的对象。
抛出：
IllegalArgumentException - 指定的对象为 null。
另请参见：
getObservedObject()

addObservedObject

public void addObservedObject(ObjectName object)
                       throws IllegalArgumentException
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。

指定者：
接口 MonitorMBean 中的 addObservedObject
参数：
object - 要观察的对象。
抛出：
IllegalArgumentException - 指定的对象为 null。

removeObservedObject

public void removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。

指定者：
接口 MonitorMBean 中的 removeObservedObject
参数：
object - 要移除的对象。

containsObservedObject

public boolean containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。

指定者：
接口 MonitorMBean 中的 containsObservedObject
参数：
object - 要检查的对象。
返回：
如果指定的对象存在，则返回 true；否则返回 false。

getObservedObjects

public ObjectName[] getObservedObjects()
返回一个包含要观察的对象的数组。

指定者：
接口 MonitorMBean 中的 getObservedObjects
返回：
要观察的对象。

getObservedAttribute

public String getObservedAttribute()
获取要观察的属性。
默认情况下被观察属性未被初始化（设置为 null）。

指定者：
接口 MonitorMBean 中的 getObservedAttribute
返回：
要观察的属性。
另请参见：
setObservedAttribute(java.lang.String)

setObservedAttribute

public void setObservedAttribute(String attribute)
                          throws IllegalArgumentException
设置要观察的属性。
默认情况下被观察属性未被初始化（设置为 null）。

指定者：
接口 MonitorMBean 中的 setObservedAttribute
参数：
attribute - 要观察的属性。
抛出：
IllegalArgumentException - 指定的属性为 null。
另请参见：
getObservedAttribute()

getGranularityPeriod

public long getGranularityPeriod()
获取粒度周期（以毫秒为单位）。
粒度周期的默认值是 10 秒。

指定者：
接口 MonitorMBean 中的 getGranularityPeriod
返回：
粒度周期值。
另请参见：
setGranularityPeriod(long)

setGranularityPeriod

public void setGranularityPeriod(long period)
                          throws IllegalArgumentException
设置粒度周期（以毫秒为单位）。
粒度周期的默认值是 10 秒。

指定者：
接口 MonitorMBean 中的 setGranularityPeriod
参数：
period - 粒度周期值。
抛出：
IllegalArgumentException - 粒度周期小于或等于零。
另请参见：
getGranularityPeriod()

isActive

public boolean isActive()
测试监视器 MBean 是否处于激活状态。当调用 start 方法时，监视器 MBean 被标记为激活。当调用 stop 方法时，该标记变为非激活。

指定者：
接口 MonitorMBean 中的 isActive
返回：
如果监视器 MBean 处于激活状态，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MonitorMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
接口 MonitorMBean

所有已知子接口：
CounterMonitorMBean, GaugeMonitorMBean, StringMonitorMBean
所有已知实现类：
CounterMonitor, GaugeMonitor, Monitor, StringMonitor
public interface MonitorMBean

公开监视器 MBean 的远程管理接口。

从以下版本开始：
1.5

方法摘要
 void addObservedObject(ObjectName object)
将指定的对象添加到所观察的 MBean 集中。
 boolean containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。
 long getGranularityPeriod()
获取粒度时段（以毫秒为单位）。
 String getObservedAttribute()
获取要观察的属性。
 ObjectName getObservedObject()
已过时。 从 JMX 1.2 开始，由 getObservedObjects() 取代
 ObjectName[] getObservedObjects()
返回一个包含要观察的对象的数组。
 boolean isActive()
测试监视器 MBean 是否处于激活状态。
 void removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。
 void setGranularityPeriod(long period)
设置粒度时段（以毫秒为单位）。
 void setObservedAttribute(String attribute)
设置要观察的属性。
 void setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 addObservedObject(javax.management.ObjectName) 取代
 void start()
启动监视器。
 void stop()
停止监视器。

方法详细信息

start

void start()
启动监视器。

stop

void stop()
停止监视器。

addObservedObject

void addObservedObject(ObjectName object)
                       throws IllegalArgumentException
将指定的对象添加到所观察的 MBean 集中。

参数：
object - 要观察的对象。
抛出：
IllegalArgumentException - 指定的对象为 null。

removeObservedObject

void removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。

参数：
object - 要移除的对象。

containsObservedObject

boolean containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。

参数：
object - 要检查的对象。
返回：
如果指定的对象在该集中，则返回 true；否则返回 false。

getObservedObjects

ObjectName[] getObservedObjects()
返回一个包含要观察的对象的数组。

返回：
要观察的对象。

getObservedObject

@Deprecated
ObjectName getObservedObject()
已过时。 从 JMX 1.2 开始，由 getObservedObjects() 取代

获取要观察的对象的对象名称。

返回：
要观察的对象。
另请参见：
setObservedObject(javax.management.ObjectName)

setObservedObject

@Deprecated
void setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 addObservedObject(javax.management.ObjectName) 取代

设置由其对象名称标识的要观察的对象。

参数：
object - 要观察的对象。
另请参见：
getObservedObject()

getObservedAttribute

String getObservedAttribute()
获取要观察的属性。

返回：
要观察的属性。
另请参见：
setObservedAttribute(java.lang.String)

setObservedAttribute

void setObservedAttribute(String attribute)
设置要观察的属性。

参数：
attribute - 要观察的属性。
另请参见：
getObservedAttribute()

getGranularityPeriod

long getGranularityPeriod()
获取粒度时段（以毫秒为单位）。

返回：
粒度时段。
另请参见：
setGranularityPeriod(long)

setGranularityPeriod

void setGranularityPeriod(long period)
                          throws IllegalArgumentException
设置粒度时段（以毫秒为单位）。

参数：
period - 粒度时段。
抛出：
IllegalArgumentException - 粒度时段小于或等于零。
另请参见：
getGranularityPeriod()

isActive

boolean isActive()
测试监视器 MBean 是否处于激活状态。在调用 start 方法时，监视器 MBean 被标记为激活状态。在调用 stop 方法时，该标记变为非激活状态。

返回：
如果监视器 MBean 处于激活状态，则返回 true；否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MonitorNotification (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
类 MonitorNotification

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.management.Notification
            继承者  javax.management.monitor.MonitorNotification
所有已实现的接口：
Serializable
public class MonitorNotification
extends Notification

提供对监视器 MBean 发送的通知的定义。

当创建此类的新对象时，需要指定与监视器 MBean 的状态有关的通知源和参数集。 以下是由监视器 MBean 触发的通知列表：

  • 通用于所有种类的监视器：
    • 被观察对象未在 MBean 服务器中注册。
    • 被观察属性未包含在被观察对象中。
    • 被观察属性的类型不正确。
    • 当尝试获取被观察属性的值时，会发生任何异常（上述情况除外）。
  • 通用于计数器和尺度监视器：
    • 阈值高或阈值低与尺度（尺度监视器）不属于同一类型。
    • 阈值、偏移量或模与计数器（计数器监视器）不属于同一类型。
  • 对于计数器监视器：
    • observed 属性已达到阈值。
  • 对于尺度监视器：
    • observed 属性已超出高阈值。
    • observed 属性已超出低阈值。
  • 对于字符串监视器：
    • 被观察属性与“要比较的字符串”值匹配。
    • 被观察属性与“要比较的字符串”值不同。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static String | OBSERVED_ATTRIBUTE_ERROR 表示被观察属性未包含在被观察对象中的通知类型。
static String | OBSERVED_ATTRIBUTE_TYPE_ERROR 表示被观察属性的类型不正确的通知类型。
static String | OBSERVED_OBJECT_ERROR 表示被观察对象未在 MBean 服务器中注册的通知类型。
static String | RUNTIME_ERROR 表示在尝试获取被观察属性的值时发生未预定义的错误类型的通知类型。
static String | STRING_TO_COMPARE_VALUE_DIFFERED 表示被观察属性与“要比较的字符串”值不同的通知类型。
static String | STRING_TO_COMPARE_VALUE_MATCHED 表示被观察属性与“要比较的字符串”值匹配的通知类型。
static String | THRESHOLD_ERROR 表示阈值类型、偏移量或模不正确的通知类型。
static String | THRESHOLD_HIGH_VALUE_EXCEEDED 表示被观察属性已超出高阈值的通知类型。
static String | THRESHOLD_LOW_VALUE_EXCEEDED 表示被观察属性已超出低阈值的通知类型。
static String | THRESHOLD_VALUE_EXCEEDED 表示被观察属性已达到阈值的通知类型。
从类 javax.management.Notification 继承的字段
source
方法摘要
Object | getDerivedGauge() 获取此监视器通知的派生尺度。
String | getObservedAttribute() 获取此监视器通知的被观察属性。
ObjectName | getObservedObject() 获取此监视器通知的被观察对象。
Object | getTrigger() 获取触发此监视器通知的阈值/字符串（取决于监视器类型）。
从类 javax.management.Notification 继承的方法
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBSERVED_OBJECT_ERROR

public static final String OBSERVED_OBJECT_ERROR
表示被观察对象未在 MBean 服务器中注册的通知类型。此通知可由所有种类的监视器触发。
此通知类型的值是 jmx.monitor.error.mbean。

另请参见：
常量字段值

OBSERVED_ATTRIBUTE_ERROR

public static final String OBSERVED_ATTRIBUTE_ERROR
表示被观察属性未包含在被观察对象中的通知类型。此通知可由所有种类的监视器触发。
此通知类型的值是 jmx.monitor.error.attribute。

另请参见：
常量字段值

OBSERVED_ATTRIBUTE_TYPE_ERROR

public static final String OBSERVED_ATTRIBUTE_TYPE_ERROR
表示被观察属性的类型不正确的通知类型。此通知可由所有种类的监视器触发。
此通知类型的值是 jmx.monitor.error.type。

另请参见：
常量字段值

THRESHOLD_ERROR

public static final String THRESHOLD_ERROR
表示阈值类型、偏移量或模不正确的通知类型。此通知可由计数器和尺度监视器触发。
此通知类型的值是 jmx.monitor.error.threshold。

另请参见：
常量字段值

RUNTIME_ERROR

public static final String RUNTIME_ERROR
表示在尝试获取被观察属性的值时发生未预定义的错误类型的通知类型。此通知可由所有种类的监视器触发。
此通知类型的值是 jmx.monitor.error.runtime。

另请参见：
常量字段值

THRESHOLD_VALUE_EXCEEDED

public static final String THRESHOLD_VALUE_EXCEEDED
表示被观察属性已达到阈值的通知类型。此通知仅由计数器监视器触发。
此通知类型的值是 jmx.monitor.counter.threshold。

另请参见：
常量字段值

THRESHOLD_HIGH_VALUE_EXCEEDED

public static final String THRESHOLD_HIGH_VALUE_EXCEEDED
表示被观察属性已超出高阈值的通知类型。此通知仅由尺度监视器触发。
此通知类型的值是 jmx.monitor.gauge.high。

另请参见：
常量字段值

THRESHOLD_LOW_VALUE_EXCEEDED

public static final String THRESHOLD_LOW_VALUE_EXCEEDED
表示被观察属性已超出低阈值的通知类型。此通知仅由尺度监视器触发。
此通知类型的值是 jmx.monitor.gauge.low。

另请参见：
常量字段值

STRING_TO_COMPARE_VALUE_MATCHED

public static final String STRING_TO_COMPARE_VALUE_MATCHED
表示被观察属性与“要比较的字符串”值匹配的通知类型。此通知仅由字符串监视器触发。
此通知类型的值是 jmx.monitor.string.matches。

另请参见：
常量字段值

STRING_TO_COMPARE_VALUE_DIFFERED

public static final String STRING_TO_COMPARE_VALUE_DIFFERED
表示被观察属性与“要比较的字符串”值不同的通知类型。此通知仅由字符串监视器触发。
此通知类型的值是 jmx.monitor.string.differs。

另请参见：
常量字段值
方法详细信息

getObservedObject

public ObjectName getObservedObject()
获取此监视器通知的被观察对象。

返回：
被观察对象。

getObservedAttribute

public String getObservedAttribute()
获取此监视器通知的被观察属性。

返回：
被观察属性。

getDerivedGauge

public Object getDerivedGauge()
获取此监视器通知的派生尺度。

返回：
派生的尺度。

getTrigger

public Object getTrigger()
获取触发此监视器通知的阈值/字符串（取决于监视器类型）。

返回：
触发器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MonitorSettingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
类 MonitorSettingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.management.JMRuntimeException
                    继承者  javax.management.monitor.MonitorSettingException
所有已实现的接口：
Serializable
public class MonitorSettingException
extends JMRuntimeException

当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

由于监视器属性可能在运行时发生更改，所以将在进行每次观察之前执行检查。如果监视器属性变为无效，则将抛出监视器设置异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MonitorSettingException()
默认的构造方法。
MonitorSettingException(String message)
允许指定错误消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MonitorSettingException

public MonitorSettingException()
默认的构造方法。

MonitorSettingException

public MonitorSettingException(String message)
允许指定错误消息的构造方法。

参数：
message - 具体的错误消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringMonitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
类 StringMonitor

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.monitor.Monitor
            继承者  javax.management.monitor.StringMonitor
所有已实现的接口：
MBeanRegistration, MonitorMBean, StringMonitorMBean, NotificationBroadcaster, NotificationEmitter
public class StringMonitor
extends Monitor
implements StringMonitorMBean

定义设计用于观察字符串属性值的监视器 MBean。

字符串监视器将根据以下情况发送通知：

  • 如果属性值与要比较的字符串值匹配，则发送一个匹配通知。必须将 notify match 标志设置为 true。
    除非属性值与要比较的字符串值不同，否则要比较值的后续字符串匹配不会引起更多的通知。
  • 如果属性值与要比较的字符串的值不同，则发送一个不同通知。必须将 notify differ 标志设置为 true。
    除非属性值与要比较的字符串的值匹配，否则要比较值的字符串后续差别不会引起更多的通知。

从以下版本开始：
1.5

字段摘要
从类 javax.management.monitor.Monitor 继承的字段
alreadyNotified, alreadyNotifieds, capacityIncrement, dbgTag, elementCount, OBSERVED_ATTRIBUTE_ERROR_NOTIFIED, OBSERVED_ATTRIBUTE_TYPE_ERROR_NOTIFIED, OBSERVED_OBJECT_ERROR_NOTIFIED, RESET_FLAGS_ALREADY_NOTIFIED, RUNTIME_ERROR_NOTIFIED, server
构造方法摘要
StringMonitor()
默认构造方法。
方法摘要
String | getDerivedGauge() 已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代
String | getDerivedGauge(ObjectName object) 如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。
long | getDerivedGaugeTimeStamp() 已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代
long | getDerivedGaugeTimeStamp(ObjectName object) 如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由字符串监视器发送的通知类型。
boolean | getNotifyDiffer() 获取所有观察到的 MBeans 共同的不同通知的开/关切换值。
boolean | getNotifyMatch() 获取所有观察到的 MBeans 共同的匹配通知的开/关切换值。
String | getStringToCompare() 获取要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
void | setNotifyDiffer(boolean value) 设置所有观察到的 MBeans 共同的不同通知的开/关切换值。
void | setNotifyMatch(boolean value) 设置所有观察到的 MBeans 共同的匹配通知的开/关切换值。
void | setStringToCompare(String value) 设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。
void | start() 启动字符串监视器。
void | stop() 停止字符串监视器。
从类 javax.management.monitor.Monitor 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, postDeregister, postRegister, preDeregister, preRegister, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.management.monitor.MonitorMBean 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject

构造方法详细信息

StringMonitor

public StringMonitor()
默认构造方法。

方法详细信息

start

public void start()
启动字符串监视器。

指定者：
接口 MonitorMBean 中的 start
指定者：
类 Monitor 中的 start

stop

public void stop()
停止字符串监视器。

指定者：
接口 MonitorMBean 中的 stop
指定者：
类 Monitor 中的 stop

getDerivedGauge

public String getDerivedGauge(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。

指定者：
接口 StringMonitorMBean 中的 getDerivedGauge
参数：
object - 需要其派生尺度的 MBean 的名称。
返回：
指定对象的派生尺度。

getDerivedGaugeTimeStamp

public long getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。

指定者：
接口 StringMonitorMBean 中的 getDerivedGaugeTimeStamp
参数：
object - 将返回其派生尺度时间戳的对象的名称。
返回：
指定对象的派生尺度时间戳。

getDerivedGauge

@Deprecated
public String getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代

返回观察到的 MBeans 集中第一个对象的派生尺度。

指定者：
接口 StringMonitorMBean 中的 getDerivedGauge
返回：
派生的尺度。

getDerivedGaugeTimeStamp

@Deprecated
public long getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代

获取观察到的 MBeans 集中第一个对象的派生尺度时间戳。

指定者：
接口 StringMonitorMBean 中的 getDerivedGaugeTimeStamp
返回：
派生尺度时间戳。

getStringToCompare

public String getStringToCompare()
获取要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。

指定者：
接口 StringMonitorMBean 中的 getStringToCompare
返回：
字符串值。
另请参见：
setStringToCompare(java.lang.String)

setStringToCompare

public void setStringToCompare(String value)
                        throws IllegalArgumentException
设置要与所有观察到的 MBeans 的共同 observed 属性进行比较的字符串。

指定者：
接口 StringMonitorMBean 中的 setStringToCompare
参数：
value - 字符串值。
抛出：
IllegalArgumentException - 要比较的指定字符串为 null。
另请参见：
getStringToCompare()

getNotifyMatch

public boolean getNotifyMatch()
获取所有观察到的 MBeans 共同的匹配通知的开/关切换值。

指定者：
接口 StringMonitorMBean 中的 getNotifyMatch
返回：
如果与要比较的字符串匹配时字符串监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotifyMatch(boolean)

setNotifyMatch

public void setNotifyMatch(boolean value)
设置所有观察到的 MBeans 共同的匹配通知的开/关切换值。

指定者：
接口 StringMonitorMBean 中的 setNotifyMatch
参数：
value - 匹配通知的开/关切换值。
另请参见：
getNotifyMatch()

getNotifyDiffer

public boolean getNotifyDiffer()
获取所有观察到的 MBeans 共同的不同通知的开/关切换值。

指定者：
接口 StringMonitorMBean 中的 getNotifyDiffer
返回：
如果与要比较的字符串不同时字符串监视器发出了通知，则返回 true，否则返回 false。
另请参见：
setNotifyDiffer(boolean)

setNotifyDiffer

public void setNotifyDiffer(boolean value)
设置所有观察到的 MBeans 共同的不同通知的开/关切换值。

指定者：
接口 StringMonitorMBean 中的 setNotifyDiffer
参数：
value - 不同通知的开/关切换值。
另请参见：
getNotifyDiffer()

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由字符串监视器发送的通知类型。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
覆盖：
类 NotificationBroadcasterSupport 中的 getNotificationInfo
返回：
可能的通知数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringMonitorMBean (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.monitor
接口 StringMonitorMBean

所有超级接口：
MonitorMBean
所有已知实现类：
StringMonitor
public interface StringMonitorMBean
extends MonitorMBean

公开字符串监视器 MBean 的远程管理接口。

从以下版本开始：
1.5

方法摘要
String | getDerivedGauge() 已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代
String | getDerivedGauge(ObjectName object) 获取指定 MBean 的派生尺度。
long | getDerivedGaugeTimeStamp() 已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代
long | getDerivedGaugeTimeStamp(ObjectName object) 获取指定 MBean 的派生尺度时间戳。
boolean | getNotifyDiffer() 获取不同通知的开/关切换值。
boolean | getNotifyMatch() 获取匹配的通知的开/关切换值。
String | getStringToCompare() 获取要与 observed 属性进行比较的字符串。
void | setNotifyDiffer(boolean value) 设置不同通知的开/关切换值。
void | setNotifyMatch(boolean value) 设置匹配的通知的开/关切换值。
void | setStringToCompare(String value) 设置要与 observed 属性进行比较的字符串。
从接口 javax.management.monitor.MonitorMBean 继承的方法
addObservedObject, containsObservedObject, getGranularityPeriod, getObservedAttribute, getObservedObject, getObservedObjects, isActive, removeObservedObject, setGranularityPeriod, setObservedAttribute, setObservedObject, start, stop

方法详细信息

getDerivedGauge

@Deprecated
String getDerivedGauge()
已过时。 从 JMX 1.2 开始，由 getDerivedGauge(ObjectName) 取代

获取派生的尺度。

返回：
派生的尺度。

getDerivedGaugeTimeStamp

@Deprecated
long getDerivedGaugeTimeStamp()
已过时。 从 JMX 1.2 开始，由 getDerivedGaugeTimeStamp(ObjectName) 取代

获取派生的尺度时间戳。

返回：
派生的尺度时间戳。

getDerivedGauge

String getDerivedGauge(ObjectName object)
获取指定 MBean 的派生尺度。

参数：
object - 将为其返回派生的尺度的 MBean
返回：
如果指定的 MBean 在观察的 MBean 集中，则返回该 MBeans 的派生尺度，否则，返回 null。

getDerivedGaugeTimeStamp

long getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。

参数：
object - 将为其返回派生的尺度时间戳的 MBean
返回：
如果指定的 MBean 在观察的 MBean 集中，则返回该 MBeans 的派生尺度时间戳，否则，返回 null。

getStringToCompare

String getStringToCompare()
获取要与 observed 属性进行比较的字符串。

返回：
字符串值。
另请参见：
setStringToCompare(java.lang.String)

setStringToCompare

void setStringToCompare(String value)
                        throws IllegalArgumentException
设置要与 observed 属性进行比较的字符串。

参数：
value - 字符串值。
抛出：
IllegalArgumentException - 如果要比较的指定字符串为 null。
另请参见：
getStringToCompare()

getNotifyMatch

boolean getNotifyMatch()
获取匹配的通知的开/关切换值。

返回：
如果匹配时字符串监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotifyMatch(boolean)

setNotifyMatch

void setNotifyMatch(boolean value)
设置匹配的通知的开/关切换值。

参数：
value - 匹配通知的开/关切换值。
另请参见：
getNotifyMatch()

getNotifyDiffer

boolean getNotifyDiffer()
获取不同通知的开/关切换值。

返回：
如果不一样时字符串监视器发出通知，则返回 true，否则返回 false。
另请参见：
setNotifyDiffer(boolean)

setNotifyDiffer

void setNotifyDiffer(boolean value)
设置不同通知的开/关切换值。

参数：
value - 不同通知的开/关切换值。
另请参见：
getNotifyDiffer()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.monitor (Java 2 Platform SE 6)

 javax.management.monitor
接口
CounterMonitorMBean
GaugeMonitorMBean
MonitorMBean
StringMonitorMBean
类
CounterMonitor
GaugeMonitor
Monitor
MonitorNotification
StringMonitor
异常
MonitorSettingException


javax.management.monitor (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.monitor

提供 monitor 类的定义。

请参见：
描述

接口摘要
CounterMonitorMBean | 公开计数器监视器 MBean 的远程管理接口。
GaugeMonitorMBean | 公开尺度监视器 MBean 的远程管理接口。
MonitorMBean | 公开监视器 MBean 的远程管理接口。
StringMonitorMBean | 公开字符串监视器 MBean 的远程管理接口。

类摘要
CounterMonitor | 定义专门用来观察计数器属性值的监视器 MBean。
GaugeMonitor | 定义专门用来观察尺度属性值的监视器 MBean。
Monitor | 定义所有监视器 MBean 的公共部分。
MonitorNotification | 提供对监视器 MBean 发送的通知的定义。
StringMonitor | 定义设计用于观察字符串属性值的监视器 MBean。

异常摘要
MonitorSettingException 当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

软件包 javax.management.monitor 的描述

提供 monitor 类的定义。Monitor 是一个 MBeans，它定期观察一个或多个其他 MBeans 中的属性值。如果某个属性满足特定的条件，则 Monitor 将发出一个 MonitorNotification。当监视器 MBean 定期调用 getAttribute 检索被监视的属性值时，它在 Monitor.start() 调用者的访问控制上下文中执行该操作。

被监视的值可以是一个包含在复合类型中的简单值。例如，java.lang.management 中定义的 MemoryMXBean 具有一个类型为 MemoryUsage 的 HeapMemoryUsage 属性。要监视已用 内存量（由 MemoryUsage 的 used 属性描述），您可以监视 "HeapMemoryUsage.used"。该字符串应该做为 setObservedAttribute 的参数。

用来解释 "HeapMemoryUsage.used" 之类的 ObservedAttribute 的规则如下。假设字符串为 A.e（因此在该例中 A 为 "HeapMemoryUsage"，e 为 "used"）。

首先获得属性 A 的值。称之为 v。按以下方式从 v 中提取值 x：

  • 如果 v 为 CompositeData 且 v.get(e) 返回一个值，则 x 就是返回的那个值。
  • 如果 v 是数组且 e 为字符串 "length"，则 x 为该数组的长度。
  • 如果以上规则无法生成一个值，且类 v (v.getClass()) Introspector.getBeanInfo 包含一个具有名称 e 的 PropertyDescriptor，则 x 为对 v 调用属性读取方法的结果。

第三个规则意味着，如果属性 HeapMemoryUsage 为 MemoryUsage，则监视 "HeapMemoryUsage.used" 将获得调用 MemoryUsage.getUsed() 观察到的值。

如果 ObservedAttribute 包含一个以上的句号 (".")，例如 "ConnectionPool.connectionStats.length"，则迭代地应用上述规则。其中 v 最初是属性 ConnectionPool 的值，x 是在 e 等于 "connectionStats" 的情况下应用上述规则导出的。然后 v 将被设置为此 x，并将在 e 等于 "length" 的情况下导出一个新的 x。

建议使用有效的 Java 标识符作为属性名称，但将属性取名为 HeapMemoryUsage.used 也是可能的。这意味着作为 HeapMemoryUsage.used 的 ObservedAttribute 表示要观察的值可能是该名称的属性，也可能是一个名为 HeapMemoryUsage 的属性内部的属性 used。故出于兼容性原因，当 ObservedAttribute 包含一个句号 (.) 时，监视器将检查是否存在一个名称为完整 ObservedAttribute 字符串（示例中的 HeapMemoryUsage.used）的属性。它实现这一点的方式如下：对被观察的 MBean 调用 getMBeanInfo，并使用给定名称查询被包含的 MBeanAttributeInfo。如果能找到，则它就是被监视的内容。如果正观察多个 MBean，且其中一些有 HeapMemoryUsage.used 属性而另一些却没有时，行为是不确定的。在这种情况下，一个实现可能因此只对其中一个 MBean 调用 getMBeanInfo。如果在监视器激活的情况下检查的结果发生更改，则行为也是不确定的。

《JMX 规范》中详细叙述了监视器的具体行为。下面是有关的概述。

共有三种监视器：

  • CounterMonitor 观察整数类型的属性。假定这些属性为非负数，并且单调递增（以指定的模 进行的可能回滚 除外）。每个 observed 属性都具有相关的阈值。当属性超过其阈值时将发出一个通知。

    可以指定一个偏移量 值。当被观察值超过其阈值时，该阈值应按偏移量递增，或者按偏移量的倍数递增，以使其阈值足大于新的被观察值。

    CounterMonitor 可以在不同的模式 下操作。在本模式中，与阈值比较所得的值就是对属性的两次连续观察值之间的差分。

  • GaugeMonitor 观察数字类型的属性。每个被观察属性都具有相关的高阈值 和低阈值。

    当 observed 属性超过高阈值时，如果 notify high 标记为 true，则发送一个通知。在尺度值变得小于或等于低阈值之前，后续的超出高阈值的情况不会触发更多的通知。

    当 observed 属性低于低阈值时，如果 notify low 标记为 true，则发送一个通知。在尺度值变得小于或等于高阈值之前，后续的超出低阈值的情况不会触发更多的通知。

    一般情况下，仅设置 notify high 和 notify low 标志中的一个。使用其他阈值来提供滞后 机制，以避免属性值在阈值附近进行小幅度摆动时重复触发通知。

    GaugeMonitor 可以在不同的模式 操作。在本模式中，与高、低阈值相比得出的值就是对属性的两次连续观察值之间的差分。

  • StringMonitor 观察类型为 String 的属性。当 observed 属性变得等于和/或不等于指定的字符串时，将发出一个通知。

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology， 特别是 JMX Specification, version 1.4(pdf)。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.monitor 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.monitor 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.monitor.MonitorNotification
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.monitor.Monitor (implements javax.management.MBeanRegistration, javax.management.monitor.MonitorMBean)
        • javax.management.monitor.CounterMonitor (implements javax.management.monitor.CounterMonitorMBean)
        • javax.management.monitor.GaugeMonitor (implements javax.management.monitor.GaugeMonitorMBean)
        • javax.management.monitor.StringMonitor (implements javax.management.monitor.StringMonitorMBean)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.management.JMRuntimeException
            • javax.management.monitor.MonitorSettingException

接口分层结构

  • javax.management.monitor.MonitorMBean
    • javax.management.monitor.CounterMonitorMBean
    • javax.management.monitor.GaugeMonitorMBean
    • javax.management.monitor.StringMonitorMBean
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.monitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.monitor
的使用

使用 javax.management.monitor 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 使用的 javax.management.monitor 中的类
CounterMonitorMBean
公开计数器监视器 MBean 的远程管理接口。
GaugeMonitorMBean
公开尺度监视器 MBean 的远程管理接口。
Monitor
定义所有监视器 MBean 的公共部分。
MonitorMBean
公开监视器 MBean 的远程管理接口。
StringMonitorMBean
公开字符串监视器 MBean 的远程管理接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.monitor.CounterMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.CounterMonitor
的使用

没有 javax.management.monitor.CounterMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.monitor.CounterMonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.CounterMonitorMBean
的使用

使用 CounterMonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 CounterMonitorMBean 的使用

实现 CounterMonitorMBean 的 javax.management.monitor 中的类
 class CounterMonitor
定义专门用来观察计数器属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.monitor.GaugeMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.GaugeMonitor
的使用

没有 javax.management.monitor.GaugeMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.monitor.GaugeMonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.GaugeMonitorMBean
的使用

使用 GaugeMonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 GaugeMonitorMBean 的使用

实现 GaugeMonitorMBean 的 javax.management.monitor 中的类
 class GaugeMonitor
定义专门用来观察尺度属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.monitor.Monitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.Monitor
的使用

使用 Monitor 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 Monitor 的使用

javax.management.monitor 中 Monitor 的子类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.monitor.MonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.MonitorMBean
的使用

使用 MonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 MonitorMBean 的使用

javax.management.monitor 中 MonitorMBean 的子接口
interface | CounterMonitorMBean 公开计数器监视器 MBean 的远程管理接口。
interface | GaugeMonitorMBean 公开尺度监视器 MBean 的远程管理接口。
interface | StringMonitorMBean 公开字符串监视器 MBean 的远程管理接口。

实现 MonitorMBean 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.monitor.MonitorNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.MonitorNotification
的使用

没有 javax.management.monitor.MonitorNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.monitor.MonitorSettingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.MonitorSettingException
的使用

没有 javax.management.monitor.MonitorSettingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.monitor.StringMonitor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.monitor.StringMonitor
的使用

没有 javax.management.monitor.StringMonitor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.monitor.StringMonitorMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.monitor.StringMonitorMBean
的使用

使用 StringMonitorMBean 的软件包
javax.management.monitor 提供 monitor 类的定义。

javax.management.monitor 中 StringMonitorMBean 的使用

实现 StringMonitorMBean 的 javax.management.monitor 中的类
 class StringMonitor
定义设计用于观察字符串属性值的监视器 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Timer (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.timer
类 Timer

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.timer.Timer
所有已实现的接口：
MBeanRegistration, NotificationBroadcaster, NotificationEmitter, TimerMBean
public class Timer
extends NotificationBroadcasterSupport
implements TimerMBean, MBeanRegistration

提供对计时器 MBean 的实现。计时器 MBean 将在指定的时间发出警告，以唤醒所有注册的侦听器来接收计时器通知。

此类管理一个过期的计时器通知列表。这是一种允许用户根据需要任意添加/移除通知的方法。当计时器发出计时器通知并过时后，会将该通知自动从计时器通知列表中移除。
可以将其他计时器通知添加到常规重复发送的通知中。

注：

  1. 当发送计时器通知时，计时器将更新通知序列号，而不考虑通知类型。
  2. 计时器服务依赖于加载 Timer 类的主机的系统日期。如果侦听器主机具有不同的系统日期，则侦听器可能会不合时宜地接收到通知。为了避免此类问题，要同步所有需要计时的主机的系统日期。
  3. 定期通知的默认行为是固定延迟执行，这一点已在 Timer 中指定。为了使用固定速率执行，要使用重载的 addNotification(String, String, Object, Date, long, long, boolean) 方法。
  4. 可能会在同一线程中执行所有这些通知侦听器。因此，必须快速执行以避免阻止其他侦听器或者打乱固定延迟执行的规律。请参见 NotificationBroadcasterSupport。

从以下版本开始：
1.5

字段摘要
static long | ONE_DAY 一天内的毫秒数。
static long | ONE_HOUR 一小时内的毫秒数。
static long | ONE_MINUTE 一分钟内的毫秒数。
static long | ONE_SECOND 一秒钟内的毫秒数。
static long | ONE_WEEK 一周内的毫秒数。
构造方法摘要
Timer()
默认的构造方法。
方法摘要
Integer | addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Vector<Integer> | getAllNotificationIDs() 获得所有在通知列表中注册的计时器通知标识符。
Date | getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Boolean | getFixedRate(Integer id) 获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
int | getNbNotifications() 获得在通知列表中注册的计时器通知数。
Long | getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Vector<Integer> | getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
String | getNotificationMessage(Integer id) 获得与指定标识符对应的计时器通知的详细消息。
String | getNotificationType(Integer id) 获得与指定标识符对应的计时器通知类型。
Object | getNotificationUserData(Integer id) 获得与指定标识符对应的计时器通知用户数据对象。
Long | getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
boolean | getSendPastNotifications() 获得一个指示计时器是否发送过期通知的标志。
boolean | isActive() 测试计时器 MBean 是否处于激活状态。
boolean | isEmpty() 测试计时器通知列表是否为空。
void | postDeregister() 允许计时器 MBean 在 MBean 服务器注销它之后执行任何所需的操作。
void | postRegister(Boolean registrationDone) 允许计时器 MBean 在 MBean 服务器中注册后或注册失败后执行任何所需的操作。
void | preDeregister() 允许计时器 MBean 在 MBean 服务器注销它之前执行任何所需的操作。
ObjectName | preRegister(MBeanServer server, ObjectName name) 允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。
void | removeAllNotifications() 从通知列表中删除所有计时器通知并重置用来更新计时器通知标识符的计数器。
void | removeNotification(Integer id) 从通知列表中移除与指定标识符对应的计时器通知。
void | removeNotifications(String type) 从通知列表中移除与指定类型对应的所有计时器通知。
void | setSendPastNotifications(boolean value) 设置指示计时器是否发送过期通知的标志。
void | start() 启动计时器。
void | stop() 停止计时器。
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ONE_SECOND

public static final long ONE_SECOND
一秒钟内的毫秒数。addNotification 方法的有用常量。

另请参见：
常量字段值

ONE_MINUTE

public static final long ONE_MINUTE
一分钟内的毫秒数。addNotification 方法的有用常量。

另请参见：
常量字段值

ONE_HOUR

public static final long ONE_HOUR
一小时内的毫秒数。addNotification 方法的有用常量。

另请参见：
常量字段值

ONE_DAY

public static final long ONE_DAY
一天内的毫秒数。addNotification 方法的有用常量。

另请参见：
常量字段值

ONE_WEEK

public static final long ONE_WEEK
一周内的毫秒数。addNotification 方法的有用常量。

另请参见：
常量字段值
构造方法详细信息

Timer

public Timer()
默认的构造方法。

方法详细信息

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

未在此上下文中使用。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
server - 将在其中注册计时器 MBean 的 MBean 服务器。
name - 计时器 MBean 的对象名。
返回：
已注册的计时器 MBean 的名称。
抛出：
Exception

postRegister

public void postRegister(Boolean registrationDone)
允许计时器 MBean 在 MBean 服务器中注册后或注册失败后执行任何所需的操作。

未在此上下文中使用。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示该 MBean 是否已在 MBean 服务器中成功注册。false 值意味着注册阶段已失败。

preDeregister

public void preDeregister()
                   throws Exception
允许计时器 MBean 在 MBean 服务器注销它之前执行任何所需的操作。

停止计时器。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
Exception

postDeregister

public void postDeregister()
允许计时器 MBean 在 MBean 服务器注销它之后执行任何所需的操作。

未在此上下文中使用。

指定者：
接口 MBeanRegistration 中的 postDeregister

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
从接口 NotificationBroadcaster 复制的描述

返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。

MBean 发送此数组中未描述的通知是合法的。但是，某些 MBean 服务器的客户端要想正常运行，可能要依赖完整的数组。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
覆盖：
类 NotificationBroadcasterSupport 中的 getNotificationInfo
返回：
可能的通知数组。

start

public void start()
启动计时器。

如果有一个或多个计时器通知早于通知列表中的时间，则将根据 sendPastNotifications 标志发送通知，然后根据其周期和剩余出现数量更新通知。如果计时器通知日期早于当前日期，则仅从通知列表中移除此通知。

指定者：
接口 TimerMBean 中的 start

stop

public void stop()
停止计时器。

指定者：
接口 TimerMBean 中的 stop

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period,
                               long nbOccurences,
                               boolean fixedRate)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为。
对于“一次性”通知，将立即发出该通知。
对于定期通知，将立即发出第一个通知，而后续通知将根据 period 参数指定的间隔提供。

注意，一旦将计时器通知添加到通知列表中，将不能更新其相关的日期、时段和出现数量。

如果是定期通知，则参数 fixedRate 的值将用来指定执行方案，如在 Timer 中指定的那样。

指定者：
接口 TimerMBean 中的 addNotification
参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
period - 计时器通知的时段（以毫秒为单位）。
nbOccurences - 将发出的计时器通知的总数。
fixedRate - 如果为 true 并且通知是定期的，则使用固定速率 执行方案安排该通知。如果为 false 并且通知是定期的，则使用固定延迟 执行方案安排通知。如果通知不是定期的，则将被忽略。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null 或者 period 或出现的数量为负数。
另请参见：
addNotification(String, String, Object, Date, long, long)

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period,
                               long nbOccurences)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为。
对于“一次性”通知，将立即发出该通知。
对于定期通知，将立即发出第一个通知，而后续通知将根据 period 参数指定的间隔提供。

注意，一旦将计时器通知添加到通知列表中，将不能更新其相关的日期、时段和出现数量。

如果是定期通知，则使用固定延迟 执行方案，如在 Timer 中指定的那样。为了使用固定速率 执行方案，要使用 addNotification(String, String, Object, Date, long, long, boolean)。

指定者：
接口 TimerMBean 中的 addNotification
参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
period - 计时器通知的时段（以毫秒为单位）。
nbOccurences - 将发出的计时器通知的总数。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null 或者 period 或出现的数量为负数。
另请参见：
addNotification(String, String, Object, Date, long, long, boolean)

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date,
                               long period)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

通过使用固定延迟 执行方案，计时器通知将持续重复使用计时器时段，如在 Timer 中指定的那样。为了使用固定速率 执行方案，要使用 addNotification(String, String, Object, Date, long, long, boolean)。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为。将立即发出第一个通知，而后续通知将根据 period 参数指定的间隔提供。

指定者：
接口 TimerMBean 中的 addNotification
参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
period - 计时器通知的时段（以毫秒为单位）。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null 或者 period 或出现的数量为负数。

addNotification

public Integer addNotification(String type,
                               String message,
                               Object userData,
                               Date date)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

计时器通知将在指定的日期一次性处理。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为，并且将立即发出通知。

指定者：
接口 TimerMBean 中的 addNotification
参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null。

removeNotification

public void removeNotification(Integer id)
                        throws InstanceNotFoundException
从通知列表中移除与指定标识符对应的计时器通知。

指定者：
接口 TimerMBean 中的 removeNotification
参数：
id - 计时器通知标识符。
抛出：
InstanceNotFoundException - 如果指定的标识符不能与此计时器 MBean 通知列表中的任何计时器通知对应。

removeNotifications

public void removeNotifications(String type)
                         throws InstanceNotFoundException
从通知列表中移除与指定类型对应的所有计时器通知。

指定者：
接口 TimerMBean 中的 removeNotifications
参数：
type - 计时器通知类型。
抛出：
InstanceNotFoundException - 如果指定类型不能与此计时器 MBean 通知列表中的任何计时器通知对应。

removeAllNotifications

public void removeAllNotifications()
从通知列表中删除所有计时器通知并重置用来更新计时器通知标识符的计数器。

指定者：
接口 TimerMBean 中的 removeAllNotifications

getNbNotifications

public int getNbNotifications()
获得在通知列表中注册的计时器通知数。

指定者：
接口 TimerMBean 中的 getNbNotifications
返回：
计时器通知数。

getAllNotificationIDs

public Vector<Integer> getAllNotificationIDs()
获得所有在通知列表中注册的计时器通知标识符。

指定者：
接口 TimerMBean 中的 getAllNotificationIDs
返回：
一个包含所有计时器通知标识符的 Integer 对象的向量。
如果不存在向此计时器 MBean 注册的计时器通知，则该向量为空。

getNotificationIDs

public Vector<Integer> getNotificationIDs(String type)
获得所有与指定类型对应的计时器通知的标识符。

指定者：
接口 TimerMBean 中的 getNotificationIDs
参数：
type - 计时器通知类型。
返回：
一个 Integer 对象的向量，该对象包含所有带指定 type 的计时器通知的标识符。
如果不存在向此带指定 type 的计时器 MBean 注册的计时器通知，则该向量为空。

getNotificationType

public String getNotificationType(Integer id)
获得与指定标识符对应的计时器通知类型。

指定者：
接口 TimerMBean 中的 getNotificationType
参数：
id - 计时器通知标识符。
返回：
计时器通知类型，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getNotificationMessage

public String getNotificationMessage(Integer id)
获得与指定标识符对应的计时器通知的详细消息。

指定者：
接口 TimerMBean 中的 getNotificationMessage
参数：
id - 计时器通知标识符。
返回：
计时器通知详细消息，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getNotificationUserData

public Object getNotificationUserData(Integer id)
获得与指定标识符对应的计时器通知用户数据对象。

指定者：
接口 TimerMBean 中的 getNotificationUserData
参数：
id - 计时器通知标识符。
返回：
计时器通知用户数据对象，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getDate

public Date getDate(Integer id)
获得与计时器通知关联的日期的一个副本。

指定者：
接口 TimerMBean 中的 getDate
参数：
id - 计时器通知标识符。
返回：
日期的一个副本，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getPeriod

public Long getPeriod(Integer id)
获得与计时器通知关联的时段（以毫秒为单位）的一个副本。

指定者：
接口 TimerMBean 中的 getPeriod
参数：
id - 计时器通知标识符。
返回：
时段的一个副本，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getNbOccurences

public Long getNbOccurences(Integer id)
获得与计时器通知关联的剩余出现数量的一个副本。

指定者：
接口 TimerMBean 中的 getNbOccurences
参数：
id - 计时器通知标识符。
返回：
剩余出现数量的一个副本，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getFixedRate

public Boolean getFixedRate(Integer id)
获得此种标志的一个副本：该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。

指定者：
接口 TimerMBean 中的 getFixedRate
参数：
id - 计时器通知标识符。
返回：
指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行的标志的一个副本。

getSendPastNotifications

public boolean getSendPastNotifications()
获得一个指示计时器是否发送过期通知的标志。
过期通知发送开/关标志的默认值为 false。

指定者：
接口 TimerMBean 中的 getSendPastNotifications
返回：
过期通知发送开/关标志值。
另请参见：
setSendPastNotifications(boolean)

setSendPastNotifications

public void setSendPastNotifications(boolean value)
设置指示计时器是否发送过期通知的标志。
过期通知发送开/关标志的默认值为 false。

指定者：
接口 TimerMBean 中的 setSendPastNotifications
参数：
value - 过期通知发送开/关标志值。
另请参见：
getSendPastNotifications()

isActive

public boolean isActive()
测试计时器 MBean 是否处于激活状态。当调用 start 方法时，计时器 MBean 被标记为激活。当调用 stop 方法时，该标记变为非激活。
激活开/关标志的默认值为 false。

指定者：
接口 TimerMBean 中的 isActive
返回：
如果计时器 MBean 处于激活状态，则返回 true；否则返回 false。

isEmpty

public boolean isEmpty()
测试计时器通知列表是否为空。

指定者：
接口 TimerMBean 中的 isEmpty
返回：
如果计时器通知列表为空，则返回 true，否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


TimerMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.timer
接口 TimerMBean

所有已知实现类：
Timer
public interface TimerMBean

公开计时器 MBean 的管理接口。

从以下版本开始：
1.5

方法摘要
Integer | addNotification(String type, String message, Object userData, Date date) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。
Integer | addNotification(String type, String message, Object userData, Date date, long period) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Integer | addNotification(String type, String message, Object userData, Date date, long period, long nbOccurences, boolean fixedRate) 创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。
Vector<Integer> | getAllNotificationIDs() 获得所有在通知的列表中注册的计时器通知标识符。
Date | getDate(Integer id) 获得与计时器通知关联的日期的一个副本。
Boolean | getFixedRate(Integer id) 获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。
int | getNbNotifications() 获得在通知的列表中注册的计时器通知数。
Long | getNbOccurences(Integer id) 获得与计时器通知关联的剩余出现数量的一个副本。
Vector<Integer> | getNotificationIDs(String type) 获得所有与指定类型对应的计时器通知的标识符。
String | getNotificationMessage(Integer id) 获得与指定的标识符对应的计时器通知的详细消息。
String | getNotificationType(Integer id) 获得与指定标识符对应的计时器通知类型。
Object | getNotificationUserData(Integer id) 获得与指定的标识符对应的计时器通知用户数据对象。
Long | getPeriod(Integer id) 获得与计时器通知关联的时段（以毫秒为单位）的一个副本。
boolean | getSendPastNotifications() 获得一个指示计时器是否发送过期通知的标志。
boolean | isActive() 测试计时器 MBean 是否处于激活状态。
boolean | isEmpty() 测试计时器通知列表是否为空。
void | removeAllNotifications() 从通知列表中删除所有的计时器通知并重置用来更新计时器通知标识符的计数器。
void | removeNotification(Integer id) 从通知列表中移除与指定的标识符对应的计时器通知。
void | removeNotifications(String type) 从通知列表中移除与指定的类型对应的所有计时器通知。
void | setSendPastNotifications(boolean value) 设置指示计时器是否发送过期通知的标志。
void | start() 启动计时器。
void | stop() 停止计时器。

方法详细信息

start

void start()
启动计时器。

如果有一个或多个计时器通知早于通知列表中的时间，则将根据 sendPastNotifications 标志发送通知，然后根据其周期和其余的出现数量更新通知。如果计时器通知日期早于当前日期，则仅从通知列表中移除此通知。

stop

void stop()
停止计时器。

addNotification

Integer addNotification(String type,
                        String message,
                        Object userData,
                        Date date,
                        long period,
                        long nbOccurences,
                        boolean fixedRate)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为。
对于“一次性”通知，将立即发出该通知。
对于定期通知，将立即发出第一个通知，而后续通知将根据 period 参数指定的间隔提供。

注意，一旦将计时器通知添加到通知列表中，将不能更新其相关的日期、时段和出现数量。

如果是定期通知，则参数 fixedRate 的值将用来指定执行方案，如在 Timer 中指定的那样。

参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
period - 计时器通知的时段（以毫秒为单位）。
nbOccurences - 将发出的计时器通知的总数。
fixedRate - 如果为 true 并且通知是定期的，则使用固定速率 执行方案安排该通知。如果为 false 并且通知是定期的，则使用固定延迟 执行方案安排通知。如果通知不是定期的，则将被忽略。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null 或者 period 或出现的数量为负数。
另请参见：
addNotification(String, String, Object, Date, long, long)

addNotification

Integer addNotification(String type,
                        String message,
                        Object userData,
                        Date date,
                        long period,
                        long nbOccurences)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期、时段和出现数量的通知列表中。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为。
对于“一次性”通知，将立即发出该通知。
对于定期通知，将立即发出第一个通知，而后续通知将根据 period 参数指定的间隔提供。

注意，一旦将计时器通知添加到通知列表中，将不能更新其相关的日期、时段和出现数量。

如果是定期通知，则使用固定延迟 执行方案，如在 Timer 中指定的那样。为了使用固定速率 执行方案，要使用 addNotification(String, String, Object, Date, long, long, boolean)。

参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
period - 计时器通知的时段（以毫秒为单位）。
nbOccurences - 将发出的计时器通知的总数。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null 或者 period 或出现的数量为负数。
另请参见：
addNotification(String, String, Object, Date, long, long, boolean)

addNotification

Integer addNotification(String type,
                        String message,
                        Object userData,
                        Date date,
                        long period)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期和时段，以及 null 出现数量的通知列表中。

通过使用固定延迟 执行方案，计时器通知将持续重复使用计时器时段，如在 Timer 中指定的那样。为了使用固定速率 执行方案，要使用 addNotification(String, String, Object, Date, long, long, boolean)。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为。将立即发出第一个通知，而后续通知将根据 period 参数指定的间隔提供。

参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
period - 计时器通知的时段（以毫秒为单位）。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null 或者 period 或出现的数量为负数。

addNotification

Integer addNotification(String type,
                        String message,
                        Object userData,
                        Date date)
                        throws IllegalArgumentException
创建具有指定 type、message 和 userData 的新计时器通知，并将其插入到带有给定日期以及 null 时段和出现数量的通知列表中。

计时器通知将在指定的日期一次性处理。

如果要插入的计时器通知其日期早于当前的日期，则该方法具有把指定的日期当做当前日期的行为，并且将立即发出通知。

参数：
type - 计时器通知类型。
message - 计时器通知详细消息。
userData - 计时器通知用户数据对象。
date - 发出通知时的日期。
返回：
新创建的计时器通知的标识符。
抛出：
IllegalArgumentException - 如果 date 为 null。

removeNotification

void removeNotification(Integer id)
                        throws InstanceNotFoundException
从通知列表中移除与指定的标识符对应的计时器通知。

参数：
id - 计时器通知标识符。
抛出：
InstanceNotFoundException - 如果指定的标识符不能与此计时器 MBean 通知列表中的任何计时器通知对应。

removeNotifications

void removeNotifications(String type)
                         throws InstanceNotFoundException
从通知列表中移除与指定的类型对应的所有计时器通知。

参数：
type - 计时器通知类型。
抛出：
InstanceNotFoundException - 如果指定的类型不能与此计时器 MBean 通知列表中的任何计时器通知对应。

removeAllNotifications

void removeAllNotifications()
从通知列表中删除所有的计时器通知并重置用来更新计时器通知标识符的计数器。

getNbNotifications

int getNbNotifications()
获得在通知的列表中注册的计时器通知数。

返回：
计时器通知数。

getAllNotificationIDs

Vector<Integer> getAllNotificationIDs()
获得所有在通知的列表中注册的计时器通知标识符。

返回：
一个包含所有计时器通知标识符的 Integer 对象的向量。
如果不存在向此计时器 MBean 注册的计时器通知，则该向量为空。

getNotificationIDs

Vector<Integer> getNotificationIDs(String type)
获得所有与指定类型对应的计时器通知的标识符。

参数：
type - 计时器通知类型。
返回：
一个 Integer 对象的向量，该对象包含所有带指定 type 的计时器通知的标识符。
如果不存在向此带指定 type 的计时器 MBean 注册的计时器通知，则该向量为空。

getNotificationType

String getNotificationType(Integer id)
获得与指定标识符对应的计时器通知类型。

参数：
id - 计时器通知标识符。
返回：
计时器通知类型，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getNotificationMessage

String getNotificationMessage(Integer id)
获得与指定的标识符对应的计时器通知的详细消息。

参数：
id - 计时器通知标识符。
返回：
计时器通知详细消息，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getNotificationUserData

Object getNotificationUserData(Integer id)
获得与指定的标识符对应的计时器通知用户数据对象。

参数：
id - 计时器通知标识符。
返回：
计时器通知用户数据对象，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getDate

Date getDate(Integer id)
获得与计时器通知关联的日期的一个副本。

参数：
id - 计时器通知标识符。
返回：
日期的一个副本，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getPeriod

Long getPeriod(Integer id)
获得与计时器通知关联的时段（以毫秒为单位）的一个副本。

参数：
id - 计时器通知标识符。
返回：
时段的一个副本，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getNbOccurences

Long getNbOccurences(Integer id)
获得与计时器通知关联的剩余出现数量的一个副本。

参数：
id - 计时器通知标识符。
返回：
剩余出现数量的一个副本，如果标识符不与向此计时器 MBean 注册的任何计时器通知对应，则返回 null。

getFixedRate

Boolean getFixedRate(Integer id)
获得此种标志的一个副本，该标志指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行。

参数：
id - 计时器通知标识符。
返回：
指示是以固定延迟 方式执行定期通知，还是以固定速率 方式执行的标志的一个副本。

getSendPastNotifications

boolean getSendPastNotifications()
获得一个指示计时器是否发送过期通知的标志。

返回：
过期通知发送开/关标志值。
另请参见：
setSendPastNotifications(boolean)

setSendPastNotifications

void setSendPastNotifications(boolean value)
设置指示计时器是否发送过期通知的标志。

参数：
value - 过期通知发送开/关标志值。
另请参见：
getSendPastNotifications()

isActive

boolean isActive()
测试计时器 MBean 是否处于激活状态。当调用 start 方法时，计时器 MBean 被标记为激活。当调用 stop 方法时，该标记变为非激活。

返回：
如果计时器 MBean 处于激活状态，则返回 true；否则返回 false。

isEmpty

boolean isEmpty()
测试计时器通知列表是否为空。

返回：
如果计时器通知列表为空，则返回 true，否则返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimerNotification (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.timer
类 TimerNotification

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.management.Notification
            继承者  javax.management.timer.TimerNotification
所有已实现的接口：
Serializable
public class TimerNotification
extends Notification

此类定义了由计时器 MBean 发送的通知。
它定义了计时器通知标识符，以允许从计时器 MBean 的通知列表中检索计时器通知。

计时器通知由计时器 MBean 创建，并由它来处理。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.Notification 继承的字段
source
构造方法摘要
TimerNotification(String type, Object source, long sequenceNumber, long timeStamp, String msg, Integer id)
创建计时器通知对象。
方法摘要
 Integer getNotificationID()
获取此计时器通知的标识符。
从类 javax.management.Notification 继承的方法
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TimerNotification

public TimerNotification(String type,
                         Object source,
                         long sequenceNumber,
                         long timeStamp,
                         String msg,
                         Integer id)
创建计时器通知对象。

参数：
type - 通知类型。
source - 通知生成器。
sequenceNumber - 源对象中的通知序列号。
timeStamp - 通知发出日期。
msg - 通知消息。
id - 通知标识符。
方法详细信息

getNotificationID

public Integer getNotificationID()
获取此计时器通知的标识符。

返回：
标识符。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.timer (Java 2 Platform SE 6)

 javax.management.timer
接口
TimerMBean
类
Timer
TimerNotification


javax.management.timer (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.timer

提供对 Timer MBean（计时器 MBean）的定义。

请参见：
描述

接口摘要
TimerMBean 公开计时器 MBean 的管理接口。

类摘要
Timer | 提供对计时器 MBean 的实现。
TimerNotification | 此类定义了由计时器 MBean 发送的通知。

软件包 javax.management.timer 的描述

提供对 Timer MBean（计时器 MBean）的定义。Timer MBean 维护计划通知的列表，并且由于它是 NotificationBroadcaster，所以它还维护着一个用于这些通知的侦听器列表。每当到达其中的一个计划通知时间时，各侦听器都将接收到该通知。可以以固定的时间间隔重复通知，并可绑定重复的次数。

用于 Timer MBean 的侦听器本身可以是使用方法 javax.management.MBeanServer#addNotificationListener（ObjectName、ObjectName、NotificationFilter、Object） 的 MBean。这样，管理应用程序可以创建表示某项任务的 MBean，然后使用 Timer MBean 计划该任务。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.timer 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.timer 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.timer.TimerNotification
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.timer.Timer (implements javax.management.MBeanRegistration, javax.management.timer.TimerMBean)

接口分层结构

  • javax.management.timer.TimerMBean
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.timer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.timer
的使用

使用 javax.management.timer 的软件包
javax.management.timer 提供对 Timer MBean（计时器 MBean）的定义。

javax.management.timer 使用的 javax.management.timer 中的类
TimerMBean
公开计时器 MBean 的管理接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.timer.Timer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.timer.Timer
的使用

没有 javax.management.timer.Timer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.timer.TimerMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.timer.TimerMBean
的使用

使用 TimerMBean 的软件包
javax.management.timer 提供对 Timer MBean（计时器 MBean）的定义。

javax.management.timer 中 TimerMBean 的使用

实现 TimerMBean 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.timer.TimerNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.timer.TimerNotification
的使用

没有 javax.management.timer.TimerNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


InvalidRelationIdException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 InvalidRelationIdException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.InvalidRelationIdException
所有已实现的接口：
Serializable
public class InvalidRelationIdException
extends RelationException

为关系提供的关系 id 已使用时引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidRelationIdException()
默认的构造方法，其异常中未放置任何消息。
InvalidRelationIdException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidRelationIdException

public InvalidRelationIdException()
默认的构造方法，其异常中未放置任何消息。

InvalidRelationIdException

public InvalidRelationIdException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InvalidRelationServiceException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 InvalidRelationServiceException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.InvalidRelationServiceException
所有已实现的接口：
Serializable
public class InvalidRelationServiceException
extends RelationException

提供无效 Relation Service（关系服务）时引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidRelationServiceException()
默认的构造方法，其异常中未放置任何消息。
InvalidRelationServiceException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidRelationServiceException

public InvalidRelationServiceException()
默认的构造方法，其异常中未放置任何消息。

InvalidRelationServiceException

public InvalidRelationServiceException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidRelationTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 InvalidRelationTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.InvalidRelationTypeException
所有已实现的接口：
Serializable
public class InvalidRelationTypeException
extends RelationException

无效的关系类型。在关系类型中，如果已经存在一个具有该名称的关系类型，或者两个不同的角色信息使用了相同的名称，或者没有提供角色信息，或者提供一个 null 角色信息时，引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidRelationTypeException()
默认的构造方法，其异常中未放置任何消息。
InvalidRelationTypeException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidRelationTypeException

public InvalidRelationTypeException()
默认的构造方法，其异常中未放置任何消息。

InvalidRelationTypeException

public InvalidRelationTypeException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidRoleInfoException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 InvalidRoleInfoException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.InvalidRoleInfoException
所有已实现的接口：
Serializable
public class InvalidRoleInfoException
extends RelationException

在角色信息中，其最小程度大于其最大程度时，引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidRoleInfoException()
默认的构造方法，其异常中未放置任何消息。
InvalidRoleInfoException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidRoleInfoException

public InvalidRoleInfoException()
默认的构造方法，其异常中未放置任何消息。

InvalidRoleInfoException

public InvalidRoleInfoException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidRoleValueException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 InvalidRoleValueException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.InvalidRoleValueException
所有已实现的接口：
Serializable
public class InvalidRoleValueException
extends RelationException

角色值无效。在角色中，如果给定值中引用的 MBean 数小于期望的最小程度，或者提供的值中引用的 MBean 数超过了最大程度，或者该值中的引用 MBean 没有一个是该角色所期望的 MBean 类的对象，或者不存在为该角色提供的 MBean 时，引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidRoleValueException()
默认的构造方法，其异常中未放置任何消息。
InvalidRoleValueException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidRoleValueException

public InvalidRoleValueException()
默认的构造方法，其异常中未放置任何消息。

InvalidRoleValueException

public InvalidRoleValueException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerNotificationFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 MBeanServerNotificationFilter

java.lang.Object
    继承者  javax.management.NotificationFilterSupport
        继承者  javax.management.relation.MBeanServerNotificationFilter
所有已实现的接口：
Serializable, NotificationFilter
public class MBeanServerNotificationFilter
extends NotificationFilterSupport

MBeanServerNotification 的过滤器。此过滤器通过选择感兴趣的 ObjectName 和感兴趣的操作（包括注册和注销）（对应于通知类型）对 MBeanServerNotification 通知进行过滤。

此类的 serialVersionUID 为 2605900539589789736L。

此类的 serialVersionUID 为 2605900539589789736L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
MBeanServerNotificationFilter()
创建一个选中所有 ObjectName 的所有 MBeanServerNotification 通知的过滤器。
方法摘要
void | disableAllObjectNames() 禁用任何 MBeanServerNotification（取消选中所有的 ObjectName）。
void | disableObjectName(ObjectName objectName) 禁用与给定 ObjectName 有关的 MBeanServerNotification。
void | enableAllObjectNames() 启用所有 MBeanServerNotification（选中所有 ObjectName）。
void | enableObjectName(ObjectName objectName) 启用与给定 ObjectName 有关的 MBeanServerNotification。
Vector<ObjectName> | getDisabledObjectNames() 获取禁用的所有 ObjectName。
Vector<ObjectName> | getEnabledObjectNames() 获取所有已启用的 ObjectName。
boolean | isNotificationEnabled(Notification notif) 向侦听器发送指定通知之前调用。
从类 javax.management.NotificationFilterSupport 继承的方法
disableAllTypes, disableType, enableType, getEnabledTypes
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MBeanServerNotificationFilter

public MBeanServerNotificationFilter()
创建一个选中所有 ObjectName 的所有 MBeanServerNotification 通知的过滤器。

方法详细信息

disableAllObjectNames

public void disableAllObjectNames()
禁用任何 MBeanServerNotification（取消选中所有的 ObjectName）。

disableObjectName

public void disableObjectName(ObjectName objectName)
                       throws IllegalArgumentException
禁用与给定 ObjectName 有关的 MBeanServerNotification。

参数：
objectName - 不再感兴趣的 ObjectName
抛出：
IllegalArgumentException - 如果给定的 ObjectName 为 null

enableAllObjectNames

public void enableAllObjectNames()
启用所有 MBeanServerNotification（选中所有 ObjectName）。

enableObjectName

public void enableObjectName(ObjectName objectName)
                      throws IllegalArgumentException
启用与给定 ObjectName 有关的 MBeanServerNotification。

参数：
objectName - 感兴趣的 ObjectName
抛出：
IllegalArgumentException - 如果给定的 ObjectName 为 null

getEnabledObjectNames

public Vector<ObjectName> getEnabledObjectNames()
获取所有已启用的 ObjectName。

返回：
ObjectName 的向量：

- null 意味着隐式选中所有 ObjectName，除了显式取消选中的 ObjectName 之外

- 空意味着取消选中所有 ObjectName，即不选中任何 ObjectName。

getDisabledObjectNames

public Vector<ObjectName> getDisabledObjectNames()
获取禁用的所有 ObjectName。

返回：
ObjectName 的向量：

- null 意味着隐式取消选中所有 ObjectName，除了显式选中的 ObjectName 之外

- 空意味着选中所有 ObjectName，即不取消选中任何 ObjectName。

isNotificationEnabled

public boolean isNotificationEnabled(Notification notif)
                              throws IllegalArgumentException
向侦听器发送指定通知之前调用。

如果：

- 选中与 MBean 相关的 ObjectName（显式，或者（隐式但不显式地取消选中））

并且

- 选中操作类型（注册或注销）

则向侦听器发送通知。

指定者：
接口 NotificationFilter 中的 isNotificationEnabled
覆盖：
类 NotificationFilterSupport 中的 isNotificationEnabled
参数：
notif - 将发送的通知。
返回：
如果必须将通知发送到侦听器，则返回 true；否则，返回 false。
抛出：
IllegalArgumentException - 如果是 null 参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Relation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
接口 Relation

所有已知子接口：
RelationSupportMBean
所有已知实现类：
RelationSupport
public interface Relation

此接口必须由任何 MBean 类（期望表示为一种使用 Relation Service 管理的关系）来实现。

简单的关系（即只有角色，没有属性或方法）可以由 Relation Service 直接创建（表示为 RelationSupport 对象，由 Relation Service 内部处理）。

如果用户希望表示更复杂的关系（包括属性和/或方法），则其必须提供自己实现 Relation 接口的类。这可以通过从 RelationSupport 类继承得到，也可以通过实现该接口得到（全权或者委托给 RelationSupport 对象成员）。

指定这样的用户关系类是为了引入属性和/或方法。这些都要向远程管理公开。因此，这意味着任何用户关系类都必须是一个 MBean 类。

从以下版本开始：
1.5

方法摘要
RoleResult | getAllRoles() 返回该关系中存在的所有角色。
Map<ObjectName,List<String>> | getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
String | getRelationId() 返回关系标识符（用于唯一标识 Relation Service 内的关系）。
ObjectName | getRelationServiceName() 返回处理关系的 Relation Service 的 ObjectName。
String | getRelationTypeName() 返回相关关系类型的名称。
List<ObjectName> | getRole(String roleName) 检索给定角色名称的角色值。
Integer | getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
RoleResult | getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
void | handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
RoleList | retrieveAllRoles() 返回关系中的所有角色，不检查读取模式。
void | setRole(Role role) 设置给定角色。
RoleResult | setRoles(RoleList roleList) 设置给定的角色。

方法详细信息

getRole

List<ObjectName> getRole(String roleName)
                         throws IllegalArgumentException,
                                RoleNotFoundException,
                                RelationServiceNotRegisteredException
检索给定角色名称的角色值。

按照关系类型检查角色是否存在及是否可读。

参数：
roleName - 角色名称
返回：
作为角色值的 ObjectName 对象的 ArrayList
抛出：
IllegalArgumentException - 如果为 null 角色名称
RoleNotFoundException - 如果：

- 不存在具有给定名称的角色

- 角色不可读。

RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
另请参见：
setRole(javax.management.relation.Role)

getRoles

RoleResult getRoles(String[] roleNameArray)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException
检索具有给定名称的角色值。

按照关系类型检查每个角色是否存在及是否可读。

参数：
roleNameArray - 要检索的角色名称的数组
返回：
RoleResult 对象，包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对未检索到的角色）。
抛出：
IllegalArgumentException - 如果是 null 角色名称
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册。
另请参见：
setRoles(javax.management.relation.RoleList)

getRoleCardinality

Integer getRoleCardinality(String roleName)
                           throws IllegalArgumentException,
                                  RoleNotFoundException
返回当前在给定角色中引用的 MBean 数。

参数：
roleName - 角色名称
返回：
当前在此角色中引用的 MBean 数
抛出：
IllegalArgumentException - 如果是 null 角色名称
RoleNotFoundException - 如果不存在具有给定名称的角色

getAllRoles

RoleResult getAllRoles()
                       throws RelationServiceNotRegisteredException
返回该关系中存在的所有角色。

返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对不可读的角色）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册

retrieveAllRoles

RoleList retrieveAllRoles()
返回关系中的所有角色，不检查读取模式。

返回：
一个 RoleList。

setRole

void setRole(Role role)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationTypeNotFoundException,
                    InvalidRoleValueException,
                    RelationServiceNotRegisteredException,
                    RelationNotFoundException
设置给定角色。

将按照其在关系的关系类型中提供的相应角色定义检查角色

将发送通知（带类型 RELATION_BASIC_UPDATE 或 RELATION_MBEAN_UPDATE 的 RelationNotification，具体取决于该关系是否为 MBean）

参数：
role - 要设置的角色（名称和新值）
抛出：
IllegalArgumentException - 如果是 null 角色。
RoleNotFoundException - 如果不存在具有指定名称的角色，或者该角色不可写（初始化角色时未执行写入访问模式测试）。
InvalidRoleValueException - 如果为角色提供的值无效，例如：

- 给定值中引用的 MBean 数小于期望的最小程度；

- 提供的值中引用的 MBean 数超过期望的最大程度；

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象；

- 如果不存在为该角色提供的 MBean。

RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册。
RelationTypeNotFoundException - 如果在 Relation Service 中尚未声明该关系类型。
RelationNotFoundException - 如果尚未在 Relation Service 中添加关系。
另请参见：
getRole(java.lang.String)

setRoles

RoleResult setRoles(RoleList roleList)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException,
                           RelationTypeNotFoundException,
                           RelationNotFoundException
设置给定的角色。

将按照其在关系的关系类型中提供的相应角色定义检查角色

每个更新的角色将发送一个通知（带类型 RELATION_BASIC_UPDATE 或 RELATION_MBEAN_UPDATE 的 RelationNotification，具体取决于该关系是否为 MBean）。

参数：
roleList - 要设置的角色列表
返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功设置的角色）和一个 RoleUnresolvedList（针对未成功设置的角色）。
抛出：
IllegalArgumentException - 如果是 null 角色列表；
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册；
RelationTypeNotFoundException - 如果在 Relation Service 中尚未声明该关系类型；
RelationNotFoundException - 如果尚未在 Relation Service 中添加关系 MBean。
另请参见：
getRoles(java.lang.String[])

handleMBeanUnregistration

void handleMBeanUnregistration(ObjectName objectName,
                               String roleName)
                               throws IllegalArgumentException,
                                      RoleNotFoundException,
                                      InvalidRoleValueException,
                                      RelationServiceNotRegisteredException,
                                      RelationTypeNotFoundException,
                                      RelationNotFoundException
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。

Relation Service 将调用此方法，以让该关系采取行动来反映这种注销的影响。

小心，不期望用户调用此方法。

当前实现是为了用其当前值（引用的 MBean 的 ObjectName 列表）而不用注销的值设置角色。

参数：
objectName - 注销的 MBean 的 ObjectName
roleName - 在其中引用 MBean 的角色名称
抛出：
IllegalArgumentException - 如果是 null 参数；
RoleNotFoundException - 如果角色不在关系中或不可写；
InvalidRoleValueException - 如果角色值不遵循相关角色信息（这永远不会在从 Relation Service 中调用时发生）；
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 注册；
RelationTypeNotFoundException - 如果在 Relation Service 中尚未声明该关系类型；
RelationNotFoundException - 如果未在 Relation Service 中添加的关系 MBean 调用此方法。

getReferencedMBeans

Map<ObjectName,List<String>> getReferencedMBeans()
检索在该关系的各种角色中引用的 MBean。

返回：
一个 HashMap 映射：

ObjectName -> ArrayList of String（角色名）

getRelationTypeName

String getRelationTypeName()
返回相关关系类型的名称。

返回：
关系类型的名称。

getRelationServiceName

ObjectName getRelationServiceName()
返回处理关系的 Relation Service 的 ObjectName。

返回：
Relation Service 的 ObjectName。

getRelationId

String getRelationId()
返回关系标识符（用于唯一标识 Relation Service 内的关系）。

返回：
关系 id。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
所有已实现的接口：
Serializable
直接已知子类：
InvalidRelationIdException, InvalidRelationServiceException, InvalidRelationTypeException, InvalidRoleInfoException, InvalidRoleValueException, RelationNotFoundException, RelationServiceNotRegisteredException, RelationTypeNotFoundException, RoleInfoNotFoundException, RoleNotFoundException
public class RelationException
extends JMException

此类是关系管理过程中引发的任何异常的超类。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RelationException()
默认的构造方法，其异常中未放置任何消息。
RelationException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RelationException

public RelationException()
默认的构造方法，其异常中未放置任何消息。

RelationException

public RelationException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.RelationNotFoundException
所有已实现的接口：
Serializable
public class RelationNotFoundException
extends RelationException

Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RelationNotFoundException()
默认的构造方法，其异常中未放置任何消息。
RelationNotFoundException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RelationNotFoundException

public RelationNotFoundException()
默认的构造方法，其异常中未放置任何消息。

RelationNotFoundException

public RelationNotFoundException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationNotification (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationNotification

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.management.Notification
            继承者  javax.management.relation.RelationNotification
所有已实现的接口：
Serializable
public class RelationNotification
extends Notification

Relation Service（关系服务）中的更改通知。当通过 Relation Service 创建关系时，或者在 Relation Service 中作为关系添加 MBean 时，或者在关系中更新角色时，或者从 Relation Service 移除关系时，将发送 RelationNotification 通知。

此类的 serialVersionUID 为 -6871117877523310399L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static String | RELATION_BASIC_CREATION 内部关系的创建类型。
static String | RELATION_BASIC_REMOVAL 从内部关系的 Relation Service 中移除的类型。
static String | RELATION_BASIC_UPDATE 内部关系的更新类型。
static String | RELATION_MBEAN_CREATION 添加到 Relation Service 中的关系 MBean 的类型。
static String | RELATION_MBEAN_REMOVAL 从关系 MBean 的 Relation Service 中移除的类型。
static String | RELATION_MBEAN_UPDATE 关系 MBean 的更新类型。
从类 javax.management.Notification 继承的字段
source
构造方法摘要
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
方法摘要
List<ObjectName> | getMBeansToUnregister() 返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。
List<ObjectName> | getNewRoleValue() 返回更新的角色的新值（仅限于角色更新）。
ObjectName | getObjectName() 返回创建/移除/更新的关系的 ObjectName。
List<ObjectName> | getOldRoleValue() 返回更新的角色的旧值（仅限于角色更新）。
String | getRelationId() 返回创建/移除/更新的关系的关系标识符。
String | getRelationTypeName() 返回创建/移除/更新的关系的关系类型名称。
String | getRoleName() 返回更新关系的更新角色的名称（仅限于角色更新）。
从类 javax.management.Notification 继承的方法
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

RELATION_BASIC_CREATION

public static final String RELATION_BASIC_CREATION
内部关系的创建类型。

另请参见：
常量字段值

RELATION_MBEAN_CREATION

public static final String RELATION_MBEAN_CREATION
添加到 Relation Service 中的关系 MBean 的类型。

另请参见：
常量字段值

RELATION_BASIC_UPDATE

public static final String RELATION_BASIC_UPDATE
内部关系的更新类型。

另请参见：
常量字段值

RELATION_MBEAN_UPDATE

public static final String RELATION_MBEAN_UPDATE
关系 MBean 的更新类型。

另请参见：
常量字段值

RELATION_BASIC_REMOVAL

public static final String RELATION_BASIC_REMOVAL
从内部关系的 Relation Service 中移除的类型。

另请参见：
常量字段值

RELATION_MBEAN_REMOVAL

public static final String RELATION_MBEAN_REMOVAL
从关系 MBean 的 Relation Service 中移除的类型。

另请参见：
常量字段值
构造方法详细信息

RelationNotification

public RelationNotification(String notifType,
                            Object sourceObj,
                            long sequence,
                            long timeStamp,
                            String message,
                            String id,
                            String typeName,
                            ObjectName objectName,
                            List<ObjectName> unregMBeanList)
                     throws IllegalArgumentException
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。

参数：
notifType - 通知的类型；以下几种皆可：

- RELATION_BASIC_CREATION

- RELATION_MBEAN_CREATION

- RELATION_BASIC_REMOVAL

- RELATION_MBEAN_REMOVAL

sourceObj - 发送通知的源对象。此参数要么是 ObjectName 对象，要么是 RelationService 对象。在后一种情况下，它必须是发出通知的 MBean；MBean Server 将把源对象重写为注册 MBean 的 ObjectName。
sequence - 要标识通知的序列号
timeStamp - 时间戳
message - 描述通知的可读消息
id - 在 Relation Service 中标识关系的关系 id
typeName - 关系类型的名称
objectName - 如果它是 MBean，则是该关系对象的 ObjectName（对于由 Relation Service 内部处理的关系，则为 null）
unregMBeanList - 因为关系移除而需要注销的引用 MBean 的 ObjectName 列表（仅限于因 CIM 限定符进行的移除，可以为 null）
抛出：
IllegalArgumentException - 如果：

- 通知类型没有值

- 通知类型不是 RELATION_BASIC_CREATION、RELATION_MBEAN_CREATION、RELATION_BASIC_REMOVAL 或 RELATION_MBEAN_REMOVAL

- 没有源对象

- 源对象不是 Relation Service

- 没有关系 id

- 没有关系类型名称

RelationNotification

public RelationNotification(String notifType,
                            Object sourceObj,
                            long sequence,
                            long timeStamp,
                            String message,
                            String id,
                            String typeName,
                            ObjectName objectName,
                            String name,
                            List<ObjectName> newValue,
                            List<ObjectName> oldValue)
                     throws IllegalArgumentException
为关系中的角色更新创建通知。

参数：
notifType - 通知的类型；以下几种皆可：

- RELATION_BASIC_UPDATE

- RELATION_MBEAN_UPDATE

sourceObj - 发送通知的源对象。此参数要么是 ObjectName 对象，要么是 RelationService 对象。在后一种情况下，它必须是发出通知的 MBean；MBean Server 将把源对象重写为注册 MBean 的 ObjectName。
sequence - 要标识通知的序列号
timeStamp - 时间戳
message - 描述通知的可读消息
id - 在 Relation Service 中标识关系的关系 id
typeName - 关系类型的名称
objectName - 如果它是 MBean，则是该关系对象的 ObjectName（对于由 Relation Service 内部处理的关系，则为 null）
name - 更新的角色名称
newValue - 新角色值（ObjectName 对象的列表）
oldValue - 旧角色值（ObjectName 对象的列表）
抛出：
IllegalArgumentException - 如果是 null 参数
方法详细信息

getRelationId

public String getRelationId()
返回创建/移除/更新的关系的关系标识符。

返回：
关系 id。

getRelationTypeName

public String getRelationTypeName()
返回创建/移除/更新的关系的关系类型名称。

返回：
关系类型名称。

getObjectName

public ObjectName getObjectName()
返回创建/移除/更新的关系的 ObjectName。

返回：
如果关系是 MBean，则返回 ObjectName；否则返回 null。

getMBeansToUnregister

public List<ObjectName> getMBeansToUnregister()
返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。

返回：
ObjectName 的 List。

getRoleName

public String getRoleName()
返回更新关系的更新角色的名称（仅限于角色更新）。

返回：
更新的角色名称。

getOldRoleValue

public List<ObjectName> getOldRoleValue()
返回更新的角色的旧值（仅限于角色更新）。

返回：
更新的角色的旧值。

getNewRoleValue

public List<ObjectName> getNewRoleValue()
返回更新的角色的新值（仅限于角色更新）。

返回：
更新的角色的新值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationService

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.relation.RelationService
所有已实现的接口：
EventListener, MBeanRegistration, NotificationBroadcaster, NotificationEmitter, NotificationListener, RelationServiceMBean
public class RelationService
extends NotificationBroadcasterSupport
implements RelationServiceMBean, MBeanRegistration, NotificationListener

Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

它通过扩展 NotificationBroadcasterSupport 实现 NotificationBroadcaster，以便在从中移除关系时发送通知。

它实现 NotificationListener 接口，以便能够接收有关注销关系角色中引用的 MBean 的通知以及注销关系 MBean 的通知。

它实现 MBeanRegistration 接口，以便能够检索其 ObjectName 和 MBean Server。

从以下版本开始：
1.5

构造方法摘要
RelationService(boolean immediatePurgeFlag)
构造方法。
方法摘要
void | addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
Integer | checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否以给定类型的关系进行读取。
Integer | checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
void | createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
Map<ObjectName,List<String>> | findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
List<String> | findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | getAllRelationIds() 返回由 Relation Service 处理的所有关系的所有关系 id。
List<String> | getAllRelationTypeNames() 检索所有已知关系类型的名称。
RoleResult | getAllRoles(String relationId) 返回关系中存在的所有角色。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和发送的通知类型。
boolean | getPurgeFlag() 返回一个标志，以指示何时接收注销关系中引用的 MBean 的通知，指示是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在将显式调用 purgeRelations 方法时执行该操作。
Map<ObjectName,List<String>> | getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
String | getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
List<ObjectName> | getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
RoleInfo | getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
List<RoleInfo> | getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
RoleResult | getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
void | handleNotification(Notification notif, Object handback) 出现 JMX 通知时调用。
Boolean | hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
void | isActive() 检查该 Relation Service 是否处于活动状态。
String | isRelation(ObjectName objectName) 如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。
ObjectName | isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
void | postDeregister() 允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。
void | postRegister(Boolean registrationDone) 允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
void | preDeregister() 允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。
ObjectName | preRegister(MBeanServer server, ObjectName name) 允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
void | purgeRelations() 肃清关系。
void | removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | setPurgeFlag(boolean purgeFlag) 设置一个标志，以指示注销关系中引用的 MBean 时是否接收通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
void | setRole(String relationId, Role role) 设置给定关系中的给定角色。
RoleResult | setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
void | updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RelationService

public RelationService(boolean immediatePurgeFlag)
构造方法。

参数：
immediatePurgeFlag - 指示何时接收注销关系中引用的 MBean 的通知，指示是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。

true 表示立即肃清。

方法详细信息

isActive

public void isActive()
              throws RelationServiceNotRegisteredException
检查该 Relation Service 是否处于活动状态。当前的条件是，Relation Service 必须在 MBean Server 中注册。

指定者：
接口 RelationServiceMBean 中的 isActive
抛出：
RelationServiceNotRegisteredException - 如果未注册 Relation Service

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
从接口 MBeanRegistration 复制的描述
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。如果未指定 MBean 的名称，则该 MBean 可以提供一个注册名称。如果引发任何异常，则该 MBean 不会被注册到 MBean 服务器中。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
server - 将要在其中注册该 MBean 的 MBean 服务器。
name - 该 MBean 的对象名。如果 MBeanServer 接口中的某个 createMBean 方法或 registerMBean 方法的 name 参数为 null，则此 name 也为 null。在这种情况下，此方法必须为新 MBean 返回非 null 的 ObjectName。
返回：
MBean 要被注册的名称。此值必须不为 null。如果 name 参数不为 null，则它通常但并非一定为返回值。
抛出：
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postRegister

public void postRegister(Boolean registrationDone)
从接口 MBeanRegistration 复制的描述
允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示该 MBean 是否已在 MBean 服务器中成功注册。false 值意味着注册阶段已失败。

preDeregister

public void preDeregister()
                   throws Exception
从接口 MBeanRegistration 复制的描述
允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postDeregister

public void postDeregister()
从接口 MBeanRegistration 复制的描述
允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。

指定者：
接口 MBeanRegistration 中的 postDeregister

getPurgeFlag

public boolean getPurgeFlag()
返回一个标志，以指示何时接收注销关系中引用的 MBean 的通知，指示是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在将显式调用 purgeRelations 方法时执行该操作。

true 表示立即肃清。

指定者：
接口 RelationServiceMBean 中的 getPurgeFlag
返回：
如果肃清是自动进行的，则返回 true。
另请参见：
setPurgeFlag(boolean)

setPurgeFlag

public void setPurgeFlag(boolean purgeFlag)
设置一个标志，以指示注销关系中引用的 MBean 时是否接收通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。

true 表示立即肃清。

指定者：
接口 RelationServiceMBean 中的 setPurgeFlag
参数：
purgeFlag - 标志
另请参见：
getPurgeFlag()

createRelationType

public void createRelationType(String relationTypeName,
                               RoleInfo[] roleInfoArray)
                        throws IllegalArgumentException,
                               InvalidRelationTypeException
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

指定者：
接口 RelationServiceMBean 中的 createRelationType
参数：
relationTypeName - 关系类型的名称
roleInfoArray - 角色信息的数组
抛出：
IllegalArgumentException - 如果参数为 null
InvalidRelationTypeException - 如果：

- 具有该名称的关系类型已经存在

- 两个不同的角色信息使用了同一个名称

- 未提供角色信息

- 提供了一个 null 角色信息

addRelationType

public void addRelationType(RelationType relationTypeObj)
                     throws IllegalArgumentException,
                            InvalidRelationTypeException
作为关系类型添加给定的对象。该对象期望实现 RelationType 接口。

指定者：
接口 RelationServiceMBean 中的 addRelationType
参数：
relationTypeObj - 关系类型对象（实现该 RelationType 接口）
抛出：
IllegalArgumentException - 如果参数为 null或者 relationTypeObj.getRelationTypeName() 返回 null。
InvalidRelationTypeException - 如果：

- 两个不同的角色用了同一个名称

- 未提供角色信息

- 提供了一个 null 角色信息

- 具有该名称的关系类型已经存在

getAllRelationTypeNames

public List<String> getAllRelationTypeNames()
检索所有已知关系类型的名称。

指定者：
接口 RelationServiceMBean 中的 getAllRelationTypeNames
返回：
关系类型名称的 ArrayList（字符串）

getRoleInfos

public List<RoleInfo> getRoleInfos(String relationTypeName)
                            throws IllegalArgumentException,
                                   RelationTypeNotFoundException
检索给定关系类型的角色信息（RoleInfo 对象）的列表。

指定者：
接口 RelationServiceMBean 中的 getRoleInfos
参数：
relationTypeName - 关系类型的名称
返回：
RoleInfo 的 ArrayList。
抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果不存在具有该名称的关系类型。

getRoleInfo

public RoleInfo getRoleInfo(String relationTypeName,
                            String roleInfoName)
                     throws IllegalArgumentException,
                            RelationTypeNotFoundException,
                            RoleInfoNotFoundException
检索给定关系类型的给定角色名称的角色信息。

指定者：
接口 RelationServiceMBean 中的 getRoleInfo
参数：
relationTypeName - 关系类型的名称
roleInfoName - 角色的名称
返回：
RoleInfo 对象。
抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果在 Relation Service 中的关系类型未知
RoleInfoNotFoundException - 如果该角色不是该关系类型的一部分。

removeRelationType

public void removeRelationType(String relationTypeName)
                        throws RelationServiceNotRegisteredException,
                               IllegalArgumentException,
                               RelationTypeNotFoundException
从 Relation Service 中移除给定的关系类型。

此类型的关系对象将要从 Relation Service 中移除。

指定者：
接口 RelationServiceMBean 中的 removeRelationType
参数：
relationTypeName - 要移除的关系类型名称
抛出：
RelationServiceNotRegisteredException - 如果该 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果不存在具有该名称的关系类型

createRelation

public void createRelation(String relationId,
                           String relationTypeName,
                           RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RoleNotFoundException,
                           InvalidRelationIdException,
                           RelationTypeNotFoundException,
                           InvalidRoleValueException
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

按照在参数中提供的角色列表初始化角色。将未按此方法初始化的角色设置为 ObjectName 的空 ArrayList。

发送类型为 RELATION_BASIC_CREATION 的 RelationNotification。

指定者：
接口 RelationServiceMBean 中的 createRelation
参数：
relationId - 关系标识符，用来唯一地标识 Relation Service 中的关系
relationTypeName - 关系类型的名称（必须在 Relation Service 中创建）
roleList - 要初始化该关系的角色的角色列表（可以为 null）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null（角色列表除外，它在未进行角色初始化时可以为 null）
RoleNotFoundException - 如果为关系类型中不存在的角色提供值
InvalidRelationIdException - 如果关系 id 已经使用
RelationTypeNotFoundException - 如果在 Relation Service 中关系类型未知
InvalidRoleValueException - 如果：

- 两个不同的角色使用了同一个角色名称

- 给定值中引用的 MBean 数小于期望的最小程度

- 提供的值中引用的 MBean 数超过期望的最大程度

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象

- 如果不存在为该角色提供的 MBean

addRelation

public void addRelation(ObjectName relationObjectName)
                 throws IllegalArgumentException,
                        RelationServiceNotRegisteredException,
                        NoSuchMethodException,
                        InvalidRelationIdException,
                        InstanceNotFoundException,
                        InvalidRelationServiceException,
                        RelationTypeNotFoundException,
                        RoleNotFoundException,
                        InvalidRoleValueException
作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

将作为关系添加 MBean，它必须遵循以下做法：

- 实现该 Relation 接口

- 具有 RelationService ObjectName，即当前 Relation Service 的 ObjectName

- 具有在当前 Relation Service 中唯一且未使用的关系 id

- 具有关系类型，即在 Relation Service 中创建的关系类型

- 具有遵循在关系类型中提供的角色信息的角色。

指定者：
接口 RelationServiceMBean 中的 addRelation
参数：
relationObjectName - 要添加的关系 MBean 的 ObjectName。
抛出：
IllegalArgumentException - 如果参数为 null
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
NoSuchMethodException - 如果 MBean 没有实现 Relation 接口
InvalidRelationIdException - 如果：

- MBean 中没有关系标识符

- 在 Relation Service 中已经使用关系标识符

InstanceNotFoundException - 如果尚未注册给定 ObjectName 的 MBean
InvalidRelationServiceException - 如果：

- MBean 中没有 Relation Service 名称

- MBean 中的 Relation Service 名称不是当前 Relation Service 的名称

RelationTypeNotFoundException - 如果：

- MBean 中没有关系类型名称

- MBean 中的关系类型名称与 Relation Service 中创建的关系类型不对应

InvalidRoleValueException - 如果：

- 角色中引用的 MBean 数小于期望的最小程度

- 角色中引用的 MBean 数超过期望的最大程度

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象

- 为角色提供的 MBean 不存在

RoleNotFoundException - 如果为关系类型中不存在的角色提供了值

isRelationMBean

public ObjectName isRelationMBean(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。

指定者：
接口 RelationServiceMBean 中的 isRelationMBean
参数：
relationId - 标识关系的关系 id
返回：
相应关系 MBean 的 ObjectName；如果该关系不是 MBean，则返回 null。
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在与该 id 相关的关系

isRelation

public String isRelation(ObjectName objectName)
                  throws IllegalArgumentException
如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。

指定者：
接口 RelationServiceMBean 中的 isRelation
参数：
objectName - 假定关系的 ObjectName
返回：
关系 id（字符串）；或返回 null（如果 ObjectName 不是由 Relation Service 处理的关系）
抛出：
IllegalArgumentException - 如果参数为 null

hasRelation

public Boolean hasRelation(String relationId)
                    throws IllegalArgumentException
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。

指定者：
接口 RelationServiceMBean 中的 hasRelation
参数：
relationId - 标识关系的关系 id
返回：
boolean： 如果存在关系，则返回 true；否则返回 false
抛出：
IllegalArgumentException - 如果参数为 null

getAllRelationIds

public List<String> getAllRelationIds()
返回由 Relation Service 处理的所有关系的所有关系 id。

指定者：
接口 RelationServiceMBean 中的 getAllRelationIds
返回：
String 的 ArrayList

checkRoleReading

public Integer checkRoleReading(String roleName,
                                String relationTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
检查给定 Role 能否以给定类型的关系进行读取。

指定者：
接口 RelationServiceMBean 中的 checkRoleReading
参数：
roleName - 要检查的角色名称
relationTypeName - 关系类型的名称
返回：
包装整数的 Integer，该整数对应于 RoleUnresolved 中用常量表示的可能问题：

- 如果角色可读，则用 0 表示

- 对应于 RoleStatus.NO_ROLE_WITH_NAME 的整数

- 对应于 RoleStatus.ROLE_NOT_READABLE 的整数

抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果 Relation Service 中的关系类型未知

checkRoleWriting

public Integer checkRoleWriting(Role role,
                                String relationTypeName,
                                Boolean initFlag)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
检查给定 Role 能否以给定类型的关系进行设置。

指定者：
接口 RelationServiceMBean 中的 checkRoleWriting
参数：
role - 要检查的角色
relationTypeName - 关系类型的名称
initFlag - 指定已完成角色的初始化检查，并且不验证写入访问的标志。
返回：
包装整数的 Integer，该整数对应于 RoleUnresolved 中用常量表示的可能问题：

- 如果角色可以设置，则用 0 表示

- 对应于 RoleStatus.NO_ROLE_WITH_NAME 的整数

- 对应于 RoleStatus.ROLE_NOT_WRITABLE 的整数

- 对应于 RoleStatus.LESS_THAN_MIN_ROLE_DEGREE 的整数

- 对应于 RoleStatus.MORE_THAN_MAX_ROLE_DEGREE 的整数

- 对应于 RoleStatus.REF_MBEAN_OF_INCORRECT_CLASS 的整数

- 对应于 RoleStatus.REF_MBEAN_NOT_REGISTERED 的整数

抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果是未知关系类型

sendRelationCreationNotification

public void sendRelationCreationNotification(String relationId)
                                      throws IllegalArgumentException,
                                             RelationNotFoundException
发送关系创建通知 (RelationNotification)。通知类型是：

- RelationNotification.RELATION_BASIC_CREATION，如果该关系是 Relation Service 内部的一个对象

- RelationNotification.RELATION_MBEAN_CREATION，如果该关系是作为关系添加的 MBean。

源对象是 Relation Service 本身。

它在 Relation Service createRelation() 和 addRelation() 方法中调用。

指定者：
接口 RelationServiceMBean 中的 sendRelationCreationNotification
参数：
relationId - 更新的关系的关系标识符
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

sendRoleUpdateNotification

public void sendRoleUpdateNotification(String relationId,
                                       Role newRole,
                                       List<ObjectName> oldValue)
                                throws IllegalArgumentException,
                                       RelationNotFoundException
发送给定关系中的角色更新通知 (RelationNotification)。通知类型是：

- RelationNotification.RELATION_BASIC_UPDATE，如果该关系是 Relation Service 内部的一个对象

- RelationNotification.RELATION_MBEAN_UPDATE，如果该关系是作为关系添加的 MBean。

源对象是 Relation Service 本身。

它在关系 MBean setRole()（针对给定角色）和 setRoles()（针对每个角色）方法（RelationSupport 类中提供的实现）中调用。

它还在 Relation Service setRole()（针对给定角色）和 setRoles()（针对每个角色）方法中调用。

指定者：
接口 RelationServiceMBean 中的 sendRoleUpdateNotification
参数：
relationId - 已更新关系的关系标识符
newRole - 新的角色（名称和新值）
oldValue - 旧角色值（ObjectName 对象的列表）
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

sendRelationRemovalNotification

public void sendRelationRemovalNotification(String relationId,
                                            List<ObjectName> unregMBeanList)
                                     throws IllegalArgumentException,
                                            RelationNotFoundException
发送关系移除通知 (RelationNotification)。通知类型是：

- RelationNotification.RELATION_BASIC_REMOVAL，如果该关系是 Relation Service 内部的一个对象

- RelationNotification.RELATION_MBEAN_REMOVAL，如果该关系是作为关系添加的 MBean。

源对象是 Relation Service 本身。

它在 Relation Service removeRelation() 方法中调用。

指定者：
接口 RelationServiceMBean 中的 sendRelationRemovalNotification
参数：
relationId - 已更新关系的关系标识符
unregMBeanList - 期望因为关系移除而注销的 MBean 的 ObjectName 列表（可以为 null）
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

updateRoleMap

public void updateRoleMap(String relationId,
                          Role newRole,
                          List<ObjectName> oldValue)
                   throws IllegalArgumentException,
                          RelationServiceNotRegisteredException,
                          RelationNotFoundException
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

它在关系 MBean setRole()（针对给定角色）和 setRoles()（针对每个角色）方法（RelationSupport 类中提供的实现）中调用。

它还在 Relation Service setRole()（针对给定角色）和 setRoles()（针对每个角色）方法中调用。

为了允许 Relation Service 维护一致性（MBean 注销时）以及能够执行查询，更新角色时必须调用此方法。

指定者：
接口 RelationServiceMBean 中的 updateRoleMap
参数：
relationId - 已更新关系的关系标识符
newRole - 新的角色（名称和新的值）
oldValue - 旧角色值（ObjectName 对象的列表）
抛出：
IllegalArgumentException - 如果参数为 null
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
RelationNotFoundException - 如果没有给定 id 的关系。

removeRelation

public void removeRelation(String relationId)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
从 Relation Service 移除给定的关系。

发送 RelationNotification 通知，其类型是：

- RelationNotification.RELATION_BASIC_REMOVAL，如果该关系只在 Relation Service 内部

- RelationNotification.RELATION_MBEAN_REMOVAL，如果该关系作为 MBean 注册。

对于在这样的关系中引用的 MBean，将不执行任何操作。

指定者：
接口 RelationServiceMBean 中的 removeRelation
参数：
relationId - 要移除的关系的关系 id
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有对应于给定关系 id 的关系

purgeRelations

public void purgeRelations()
                    throws RelationServiceNotRegisteredException
肃清关系。

根据 purgeFlag 值，此方法即可以在接收到关系中引用的 MBean 的注销通知时自动调用（如果将该标志设置为 true），也可以不调用（如果将该标志设置为 false）。

在此情况下，用户负责调用它来维护关系的一致性。一定要记住：如果注销 MBean 但没立即执行肃清，这时如果重新使用 ObjectName 并将其指派给关系中另一个引用的 MBean，那么手动调用此 purgeRelations() 就会出现问题，因为这样会认为此 ObjectName 就是已注销的 MBean，不把它看作新的 MBean。

该行为取决于在其中引用注销的 MBean 的角色数量：

- 如果移除角色中的一个 MBean 引用使其引用数少于最小程度，则必须移除该关系。

- 如果移除 MBean 引用后剩余的引用数仍然在该容量范围内，则保持该关系并在调用其 handleMBeanUnregistration() 回调时更新。

指定者：
接口 RelationServiceMBean 中的 purgeRelations
抛出：
RelationServiceNotRegisteredException - 如果该 Relation Service 未在 MBean Server 中注册。

findReferencingRelations

public Map<String,List<String>> findReferencingRelations(ObjectName mbeanName,
                                                         String relationTypeName,
                                                         String roleName)
                                                  throws IllegalArgumentException
检索在引用给定 MBean 的引用关系。

这对应于 CIM "Reference" 和 "ReferenceName" 操作。

指定者：
接口 RelationServiceMBean 中的 findReferencingRelations
参数：
mbeanName - MBean 的 ObjectName
relationTypeName - 可以为 null；如果已指定，则将只在搜索时考虑该类型的关系。其他情况下将考虑所有关系类型。
roleName - 可以为 null；如果已指定，则只返回将在该角色中引用的 MBean 关系。其他情况要考虑所有角色。
返回：
HashMap，密钥为在其中引用 MBean 的关系的关系 id，并且每个密钥的值是角色名称的 ArrayList（因为 MBean 可以在同一关系中的几个角色中引用）。
抛出：
IllegalArgumentException - 如果参数为 null

findAssociatedMBeans

public Map<ObjectName,List<String>> findAssociatedMBeans(ObjectName mbeanName,
                                                         String relationTypeName,
                                                         String roleName)
                                                  throws IllegalArgumentException
检索与关系中给定关系相关的 MBean。

这对应于 CIM Associator 和 AssociatorName 操作。

指定者：
接口 RelationServiceMBean 中的 findAssociatedMBeans
参数：
mbeanName - MBean 的 ObjectName
relationTypeName - 可以为 null；如果已指定，则将只在搜索时考虑该类型的关系。其他情况下将考虑所有关系类型。
roleName - 可以为 null；如果已指定，则只返回将在该角色中引用的 MBean 关系。其他情况要考虑所有角色。
返回：
HashMap，密钥是与给定 MBean 相关的 MBean 的 ObjectName，而对于每个密钥而言，该值是这种关系的关系 id 的 ArrayList：密钥 MBean 与给定的 MBean 相关（因为它们可以与几个不同的关系相关）。
抛出：
IllegalArgumentException - 如果参数为 null

findRelationsOfType

public List<String> findRelationsOfType(String relationTypeName)
                                 throws IllegalArgumentException,
                                        RelationTypeNotFoundException
返回给定类型的关系的关系 id。

指定者：
接口 RelationServiceMBean 中的 findRelationsOfType
参数：
relationTypeName - 关系类型名称
返回：
关系 id 的 ArrayList。
抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果不存在具有该名称的关系类型。

getRole

public List<ObjectName> getRole(String relationId,
                                String roleName)
                         throws RelationServiceNotRegisteredException,
                                IllegalArgumentException,
                                RelationNotFoundException,
                                RoleNotFoundException
检索给定关系中给定角色名称的角色值。

指定者：
接口 RelationServiceMBean 中的 getRole
参数：
relationId - 关系 id
roleName - 角色名称
返回：
作为角色值的 ObjectName 对象的 ArrayList
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带给定 id 的关系
RoleNotFoundException - 如果：

- 不存在具有给定名称的角色

或者

- 角色不可读。

另请参见：
setRole(java.lang.String, javax.management.relation.Role)

getRoles

public RoleResult getRoles(String relationId,
                           String[] roleNameArray)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
检索给定关系中具有给定名称的角色值。

指定者：
接口 RelationServiceMBean 中的 getRoles
参数：
relationId - 关系 id
roleNameArray - 要检索的角色名称的数组
返回：
RoleResult 对象，包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对未检索到的角色）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带给定 id 的关系
另请参见：
setRoles(java.lang.String, javax.management.relation.RoleList)

getAllRoles

public RoleResult getAllRoles(String relationId)
                       throws IllegalArgumentException,
                              RelationNotFoundException,
                              RelationServiceNotRegisteredException
返回关系中存在的所有角色。

指定者：
接口 RelationServiceMBean 中的 getAllRoles
参数：
relationId - 关系 id
返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对不可读的角色）。
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有指定 id 的关系
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册

getRoleCardinality

public Integer getRoleCardinality(String relationId,
                                  String roleName)
                           throws IllegalArgumentException,
                                  RelationNotFoundException,
                                  RoleNotFoundException
检索给定角色中当前引用的 MBean 数。

指定者：
接口 RelationServiceMBean 中的 getRoleCardinality
参数：
relationId - 关系 id
roleName - 角色名称
返回：
当前在此角色中引用的 MBean 数
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带指定 id 的关系
RoleNotFoundException - 如果不存在具有指定名称的角色

setRole

public void setRole(String relationId,
                    Role role)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException,
                    InvalidRoleValueException
设置给定关系中的给定角色。

将按照其在关系的关系类型中提供的相应角色定义检查角色

通过处理引用的 MBean 注销，Relation Service 将跟踪更改来保持关系的一致性。

指定者：
接口 RelationServiceMBean 中的 setRole
参数：
relationId - 关系 id
role - 要设置的角色（名称和新值）
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在具有给定 id 的关系
RoleNotFoundException - 如果角色不存在或不可写
InvalidRoleValueException - 如果为角色提供的值无效：

- 给定值中引用的 MBean 数小于期望的最小程度

或者

- 提供的值中引用的 MBean 数超过期望的最大程度

或者

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象

或者

- 如果不存在为该角色提供的 MBean

另请参见：
getRole(java.lang.String, java.lang.String)

setRoles

public RoleResult setRoles(String relationId,
                           RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
设置给定关系中的给定角色。

将按照其在关系的关系类型中提供的相应角色定义来检查角色

通过处理引用的 MBean 注销，Relation Service 跟踪更改来保持关系的一致性。

指定者：
接口 RelationServiceMBean 中的 setRoles
参数：
relationId - 关系 id
roleList - 要设置的角色列表
返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功设置的角色）和一个 RoleUnresolvedList（针对未成功设置的角色）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带给定 id 的关系
另请参见：
getRoles(java.lang.String, java.lang.String[])

getReferencedMBeans

public Map<ObjectName,List<String>> getReferencedMBeans(String relationId)
                                                 throws IllegalArgumentException,
                                                        RelationNotFoundException
检索关系的各种角色中引用的 MBean。

指定者：
接口 RelationServiceMBean 中的 getReferencedMBeans
参数：
relationId - 关系 id
返回：
一个 HashMap 映射：

ObjectName -> ArrayList of String（角色名）

抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

getRelationTypeName

public String getRelationTypeName(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
返回给定关系的相关关系类型的名称。

指定者：
接口 RelationServiceMBean 中的 getRelationTypeName
参数：
relationId - 关系 id
返回：
相关关系类型的名称。
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

handleNotification

public void handleNotification(Notification notif,
                               Object handback)
出现 JMX 通知时调用。当前处理 MBean 的注销通知，该 MBean 可以是关系类型中引用，也可以是关系本身。

指定者：
接口 NotificationListener 中的 handleNotification
参数：
notif - 通知。
handback - 一个不透明的对象，可帮助侦听器将有关 MBean 发出者的信息（可以为 null）联系在一起。

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和发送的通知类型。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
覆盖：
类 NotificationBroadcasterSupport 中的 getNotificationInfo
返回：
可能的通知数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationServiceMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
接口 RelationServiceMBean

所有已知实现类：
RelationService
public interface RelationServiceMBean

Relation Service 负责创建和删除关系类型和关系，还负责处理一致性和提供查询机制。

从以下版本开始：
1.5

方法摘要
void | addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
Integer | checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否在给定类型的关系中读取。
Integer | checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
Map<ObjectName,List<String>> | findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
List<String> | findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | getAllRelationIds() 返回由 Relation Service 处理的所有关系的所有关系 id。
List<String> | getAllRelationTypeNames() 检索所有已知关系类型的名称。
RoleResult | getAllRoles(String relationId) 返回关系中存在的所有角色。
boolean | getPurgeFlag() 返回一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
Map<ObjectName,List<String>> | getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
String | getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
List<ObjectName> | getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
RoleInfo | getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。
List<RoleInfo> | getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
RoleResult | getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
Boolean | hasRelation(String relationId) 用给定的关系 id 检查是否存在 Relation Service 中标识的关系。
void | isActive() 检查该 Relation Service 是否处于活动状态。
String | isRelation(ObjectName objectName) 如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。
ObjectName | isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
void | purgeRelations() 肃清关系。
void | removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | setPurgeFlag(boolean purgeFlag) 设置一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。
void | setRole(String relationId, Role role) 以给定关系设置给定角色。
RoleResult | setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。
void | updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

方法详细信息

isActive

void isActive()
              throws RelationServiceNotRegisteredException
检查该 Relation Service 是否处于活动状态。当前的条件是，Relation Service 必须在 MBean Server 中注册。

抛出：
RelationServiceNotRegisteredException - 如果尚未注册 Relation Service

getPurgeFlag

boolean getPurgeFlag()
返回一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。

true 表示立即肃清。

返回：
如果是直接肃清，则返回 true。
另请参见：
setPurgeFlag(boolean)

setPurgeFlag

void setPurgeFlag(boolean purgeFlag)
设置一个标志，以指示注销关系中引用的 MBean 时是否接收到通知，是否必须执行关系的直接“肃清”（查找不再有效的关系），或者是否只在显式调用 purgeRelations 方法时执行该操作。

true 表示立即肃清。

参数：
purgeFlag - 标志
另请参见：
getPurgeFlag()

createRelationType

void createRelationType(String relationTypeName,
                        RoleInfo[] roleInfoArray)
                        throws IllegalArgumentException,
                               InvalidRelationTypeException
用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

参数：
relationTypeName - 关系类型的名称
roleInfoArray - 角色信息的数组
抛出：
IllegalArgumentException - 如果参数为 null
InvalidRelationTypeException - 如果：

- 具有该名称的关系类型已经存在

- 两个不同的角色信息使用了同一个名称

- 未提供角色信息

- 提供了一个 null 角色信息

addRelationType

void addRelationType(RelationType relationTypeObj)
                     throws IllegalArgumentException,
                            InvalidRelationTypeException
作为关系类型添加给定的对象。该对象期望实现 RelationType 接口。

参数：
relationTypeObj - 关系类型对象（实现该 RelationType 接口）
抛出：
IllegalArgumentException - 如果参数为 null或者 relationTypeObj.getRelationTypeName() 返回 null。
InvalidRelationTypeException - 如果已经存在具有该名称的关系类型

getAllRelationTypeNames

List<String> getAllRelationTypeNames()
检索所有已知关系类型的名称。

返回：
关系类型名称的 ArrayList（字符串）

getRoleInfos

List<RoleInfo> getRoleInfos(String relationTypeName)
                            throws IllegalArgumentException,
                                   RelationTypeNotFoundException
检索给定关系类型的角色信息（RoleInfo 对象）的列表。

参数：
relationTypeName - 关系类型的名称
返回：
RoleInfo 的 ArrayList。
抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果不存在具有该名称的关系类型。

getRoleInfo

RoleInfo getRoleInfo(String relationTypeName,
                     String roleInfoName)
                     throws IllegalArgumentException,
                            RelationTypeNotFoundException,
                            RoleInfoNotFoundException
检索给定关系类型的给定角色的角色信息。

参数：
relationTypeName - 关系类型的名称
roleInfoName - 角色的名称
返回：
RoleInfo 对象。
抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果在 Relation Service 中的关系类型未知
RoleInfoNotFoundException - 如果该角色不是该关系类型的一部分。

removeRelationType

void removeRelationType(String relationTypeName)
                        throws RelationServiceNotRegisteredException,
                               IllegalArgumentException,
                               RelationTypeNotFoundException
从 Relation Service 中移除给定的关系类型。

此类型的关系对象将从 Relation Service 中移除。

参数：
relationTypeName - 要移除的关系类型名称
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果不存在具有该名称的关系类型

createRelation

void createRelation(String relationId,
                    String relationTypeName,
                    RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RoleNotFoundException,
                           InvalidRelationIdException,
                           RelationTypeNotFoundException,
                           InvalidRoleValueException
创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

按照在参数中提供的角色列表初始化角色。将未按此方法初始化的角色设置为 ObjectName 的空 ArrayList。

发送带类型 RELATION_BASIC_CREATION 的 RelationNotification。

参数：
relationId - 关系标识符，用来唯一地标识 Relation Service 中的关系
relationTypeName - 关系类型的名称（必须在 Relation Service 中创建）
roleList - 要初始化该关系的角色的角色列表（可以为 null）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RoleNotFoundException - 如果为关系类型中不存在的角色提供值
InvalidRelationIdException - 如果关系 id 已经使用
RelationTypeNotFoundException - 如果在 Relation Service 中关系类型是未知的
InvalidRoleValueException - 如果：

- 两个不同的角色使用了同一个角色名称

- 给定值中引用的 MBean 数小于期望的最小程度

- 提供的值中引用的 MBean 数超过期望的最大程度

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象

- 如果不存在为该角色提供的 MBean

addRelation

void addRelation(ObjectName relationObjectName)
                 throws IllegalArgumentException,
                        RelationServiceNotRegisteredException,
                        NoSuchMethodException,
                        InvalidRelationIdException,
                        InstanceNotFoundException,
                        InvalidRelationServiceException,
                        RelationTypeNotFoundException,
                        RoleNotFoundException,
                        InvalidRoleValueException
作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

要作为关系添加 MBean，其必须遵循以下做法：

- 实现该 Relation 接口

- 具有 RelationService ObjectName，即当前 Relation Service 的 ObjectName

- 具有在当前 Relation Service 中唯一且未使用的关系 id

- 具有关系类型，即在 Relation Service 中创建的关系类型

- 具有遵循在关系类型中提供的角色信息的角色。

参数：
relationObjectName - 要添加的关系 MBean 的 ObjectName。
抛出：
IllegalArgumentException - 如果参数为 null
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
NoSuchMethodException - 如果 MBean 未实现 Relation 接口
InvalidRelationIdException - 如果：

- MBean 中没有关系标识符

- 在 Relation Service 中已经使用关系标识符

InstanceNotFoundException - 如果尚未注册给定 ObjectName 的 MBean
InvalidRelationServiceException - 如果：

- MBean 中没有 Relation Service 名称

- MBean 中的 Relation Service 名称不是当前 Relation Service 的名称

RelationTypeNotFoundException - 如果：

- MBean 中没有关系类型名称

- MBean 中的关系类型名称与 Relation Service 中创建的关系类型不对应

InvalidRoleValueException - 如果：

- 角色中引用的 MBean 数小于期望的最小程度

- 角色中引用的 MBean 数超过期望的最大程度

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象

- 为角色提供的 MBean 不存在

RoleNotFoundException - 如果为关系类型中不存在的角色提供了值

isRelationMBean

ObjectName isRelationMBean(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。

参数：
relationId - 标识关系的关系 id
返回：
相应关系 MBean 的 ObjectName；如果该关系不是 MBean，则返回 null。
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在与该 id 相关的关系

isRelation

String isRelation(ObjectName objectName)
                  throws IllegalArgumentException
如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。

参数：
objectName - 假定关系的 ObjectName
返回：
关系 id（字符串）；或返回 null（如果 ObjectName 不是由 Relation Service 处理的关系）
抛出：
IllegalArgumentException - 如果参数为 null

hasRelation

Boolean hasRelation(String relationId)
                    throws IllegalArgumentException
用给定的关系 id 检查是否存在 Relation Service 中标识的关系。

参数：
relationId - 标识关系的关系 id
返回：
boolean： 如果存在关系，则返回 true；否则返回 false
抛出：
IllegalArgumentException - 如果参数为 null

getAllRelationIds

List<String> getAllRelationIds()
返回由 Relation Service 处理的所有关系的所有关系 id。

返回：
String 的 ArrayList

checkRoleReading

Integer checkRoleReading(String roleName,
                         String relationTypeName)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
检查给定 Role 能否在给定类型的关系中读取。

参数：
roleName - 要检查的角色名称
relationTypeName - 关系类型的名称
返回：
包装整数的 Integer，该整数对应于 RoleUnresolved 中用常量表示的可能问题：

- 如果角色可读，则用 0 表示

- 对应于 RoleStatus.NO_ROLE_WITH_NAME 的整数

- 对应于 RoleStatus.ROLE_NOT_READABLE 的整数

抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果 Relation Service 中的关系类型是未知的

checkRoleWriting

Integer checkRoleWriting(Role role,
                         String relationTypeName,
                         Boolean initFlag)
                         throws IllegalArgumentException,
                                RelationTypeNotFoundException
检查给定 Role 能否在给定类型的关系中设置。

参数：
role - 要检查的角色
relationTypeName - 关系类型的名称
initFlg - 指定已完成角色的初始化检查，并且不验证写入访问的标志。
返回：
包装整数的 Integer，该整数对应于 RoleUnresolved 中用常量表示的可能问题：

- 如果角色可以设置，则用 0 表示

- 对应于 RoleStatus.NO_ROLE_WITH_NAME 的整数

- 对应于 RoleStatus.ROLE_NOT_WRITABLE 的整数

- 对应于 RoleStatus.LESS_THAN_MIN_ROLE_DEGREE 的整数

- 对应于 RoleStatus.MORE_THAN_MAX_ROLE_DEGREE 的整数

- 对应于 RoleStatus.REF_MBEAN_OF_INCORRECT_CLASS 的整数

- 对应于 RoleStatus.REF_MBEAN_NOT_REGISTERED 的整数

抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果是未知关系类型

sendRelationCreationNotification

void sendRelationCreationNotification(String relationId)
                                      throws IllegalArgumentException,
                                             RelationNotFoundException
发送关系创建通知 (RelationNotification)。通知类型是：

- RelationNotification.RELATION_BASIC_CREATION，如果该关系是 Relation Service 内部的一个对象

- RelationNotification.RELATION_MBEAN_CREATION，如果该关系是作为关系添加的 MBean。

源对象是 Relation Service 本身。

它在 Relation Service createRelation() 和 addRelation() 方法中调用。

参数：
relationId - 更新的关系的关系标识符
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

sendRoleUpdateNotification

void sendRoleUpdateNotification(String relationId,
                                Role newRole,
                                List<ObjectName> oldRoleValue)
                                throws IllegalArgumentException,
                                       RelationNotFoundException
发送给定关系中的角色更新通知 (RelationNotification)。通知类型是：

- RelationNotification.RELATION_BASIC_UPDATE，如果该关系是 Relation Service 内部的一个对象

- RelationNotification.RELATION_MBEAN_UPDATE，如果该关系是作为关系添加的 MBean。

源对象是 Relation Service 本身。

它在关系 MBean setRole()（针对给定角色）和 setRoles()（针对每个角色）方法（RelationSupport 类中提供的实现）中调用。

它还在 Relation Service setRole()（针对给定角色）和 setRoles()（针对每个角色）方法中调用。

参数：
relationId - 更新的关系的关系标识符
newRole - 新的角色（名称和新的值）
oldRoleValue - 旧角色值（ObjectName 对象的列表）
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

sendRelationRemovalNotification

void sendRelationRemovalNotification(String relationId,
                                     List<ObjectName> unregMBeanList)
                                     throws IllegalArgumentException,
                                            RelationNotFoundException
发送关系移除通知 (RelationNotification)。通知类型是：

- RelationNotification.RELATION_BASIC_REMOVAL，如果该关系是 Relation Service 内部的一个对象

- RelationNotification.RELATION_MBEAN_REMOVAL，如果该关系是作为关系添加的 MBean。

源对象是 Relation Service 本身。

它在 Relation Service removeRelation() 方法中调用。

参数：
relationId - 更新的关系的关系标识符
unregMBeanList - 期望因为关系移除而注销的 MBean 的 ObjectName 列表（可以为 null）
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

updateRoleMap

void updateRoleMap(String relationId,
                   Role newRole,
                   List<ObjectName> oldRoleValue)
                   throws IllegalArgumentException,
                          RelationServiceNotRegisteredException,
                          RelationNotFoundException
针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

它在关系 MBean setRole()（针对给定角色）和 setRoles()（针对每个角色）方法（RelationSupport 类中提供的实现）中调用。

它还在 Relation Service setRole()（针对给定角色）和 setRoles()（针对每个角色）方法中调用。

为了允许 Relation Service 维护一致性（MBean 注销时）以及能够执行查询，更新角色时必须调用此方法。

参数：
relationId - 已更新关系的关系标识符
newRole - 新的角色（名称和新值）
oldRoleValue - 旧角色值（ObjectName 对象的列表）
抛出：
IllegalArgumentException - 如果参数为 null
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
RelationNotFoundException - 如果没有给定 id 的关系。

removeRelation

void removeRelation(String relationId)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
从 Relation Service 移除给定的关系。

发送 RelationNotification 通知，其类型是：

- RelationNotification.RELATION_BASIC_REMOVAL，如果该关系只在 Relation Service 内部

- RelationNotification.RELATION_MBEAN_REMOVAL，如果该关系作为 MBean 注册。

对于在这样的关系中引用的 MBean，将不执行任何操作，

参数：
relationId - 要移除的关系的关系 id
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有对应于给定关系 id 的关系

purgeRelations

void purgeRelations()
                    throws RelationServiceNotRegisteredException
肃清关系。

根据 purgeFlag 值，此方法即可以在接收到关系中引用的 MBean 的注销通知时自动调用（如果将该标志设置为 true），也可以不调用（如果将该标志设置为 false）。

在此情况下，用户负责调用它来维护关系的一致性。一定要记住：如果注销 MBean 但没立即执行肃清，这时如果重新使用 ObjectName 并将其指派给关系中另一个引用的 MBean，那么手动调用此 purgeRelations() 就会出现问题，因为这样会认为此 ObjectName 就是已注销的 MBean，不把它看作新的 MBean。

该行为取决于在其中引用注销的 MBean 的角色数量：

- 如果移除角色中的一个 MBean 引用使其引用数少于最小程度，则必须移除该关系。

- 如果移除 MBean 引用后剩余的引用数仍然在该容量范围内，则保持该关系并在调用其 handleMBeanUnregistration() 回调时更新。

抛出：
RelationServiceNotRegisteredException - 如果该 Relation Service 未在 MBean Server 中注册。

findReferencingRelations

Map<String,List<String>> findReferencingRelations(ObjectName mbeanName,
                                                  String relationTypeName,
                                                  String roleName)
                                                  throws IllegalArgumentException
检索在其中引用给定 MBean 的关系。

这对应于 CIM "Reference" 和 "ReferenceName" 操作。

参数：
mbeanName - MBean 的 ObjectName
relationTypeName - 可以为 null；如果已指定，则将只在搜索时考虑该类型的关系。其他情况下将考虑所有关系类型。
roleName - 可以为 null；如果已指定，则只返回将在该角色中引用的 MBean 关系。其他情况要考虑所有角色。
返回：
HashMap，密钥为在其中引用 MBean 的关系的关系 id，并且每个密钥的值是角色名称的 ArrayList（因为 MBean 可以在同一关系中的几个角色中引用）。
抛出：
IllegalArgumentException - 如果参数为 null

findAssociatedMBeans

Map<ObjectName,List<String>> findAssociatedMBeans(ObjectName mbeanName,
                                                  String relationTypeName,
                                                  String roleName)
                                                  throws IllegalArgumentException
检索与关系中给定关系相关的 MBean。

这对应于 CIM Associator 和 AssociatorName 操作。

参数：
mbeanName - MBean 的 ObjectName
relationTypeName - 可以为 null；如果已指定，则将只在搜索时考虑该类型的关系。其他情况下将考虑所有关系类型。
roleName - 可以为 null；如果已指定，则只返回将在该角色中引用的 MBean 关系。其他情况要考虑所有角色。
返回：
HashMap，密钥是与给定 MBean 相关的 MBean 的 ObjectName，而对于每个密钥而言，该值是这种关系的关系 id 的 ArrayList：密钥 MBean 与给定的 MBean 相关（因为它们可以与几个不同的关系相关）。
抛出：
IllegalArgumentException - 如果参数为 null

findRelationsOfType

List<String> findRelationsOfType(String relationTypeName)
                                 throws IllegalArgumentException,
                                        RelationTypeNotFoundException
返回给定类型的关系的关系 id。

参数：
relationTypeName - 关系类型名称
返回：
关系 id 的 ArrayList。
抛出：
IllegalArgumentException - 如果参数为 null
RelationTypeNotFoundException - 如果不存在具有该名称的关系类型。

getRole

List<ObjectName> getRole(String relationId,
                         String roleName)
                         throws RelationServiceNotRegisteredException,
                                IllegalArgumentException,
                                RelationNotFoundException,
                                RoleNotFoundException
检索给定关系中给定角色名称的角色值。

参数：
relationId - 关系 id
roleName - 角色名称
返回：
作为角色值的 ObjectName 对象的 ArrayList
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带给定 id 的关系
RoleNotFoundException - 如果：

- 不存在具有给定名称的角色

或者

- 角色不可读。

另请参见：
setRole(java.lang.String, javax.management.relation.Role)

getRoles

RoleResult getRoles(String relationId,
                    String[] roleNameArray)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
检索给定关系中具有给定名称的角色值。

参数：
relationId - 关系 id
roleNameArray - 要检索的角色名称的数组
返回：
RoleResult 对象，包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对未检索到的角色）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带给定 id 的关系
另请参见：
setRoles(java.lang.String, javax.management.relation.RoleList)

getAllRoles

RoleResult getAllRoles(String relationId)
                       throws IllegalArgumentException,
                              RelationNotFoundException,
                              RelationServiceNotRegisteredException
返回关系中存在的所有角色。

参数：
relationId - 关系 id
返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对不可读的角色）。
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有指定 id 的关系
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册

getRoleCardinality

Integer getRoleCardinality(String relationId,
                           String roleName)
                           throws IllegalArgumentException,
                                  RelationNotFoundException,
                                  RoleNotFoundException
检索给定角色中当前引用的 MBean 数。

参数：
relationId - 关系 id
roleName - 角色名称
返回：
当前在此角色中引用的 MBean 数
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带指定 id 的关系
RoleNotFoundException - 如果不存在具有指定名称的角色

setRole

void setRole(String relationId,
             Role role)
             throws RelationServiceNotRegisteredException,
                    IllegalArgumentException,
                    RelationNotFoundException,
                    RoleNotFoundException,
                    InvalidRoleValueException,
                    RelationTypeNotFoundException
以给定关系设置给定角色。

将按照其在关系的关系类型中提供的相应角色定义检查角色

通过处理引用的 MBean 注销，Relation Service 将跟踪更改来保持关系的一致性。

参数：
relationId - 关系 id
role - 要设置的角色（名称和新值）
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带给定 id 的关系
RoleNotFoundException - 如果：

- 内部关系

以及

- 角色不存在或不可写

InvalidRoleValueException - 如果为内部关系且为角色提供的值无效：

- 给定值中引用的 MBean 数小于期望的最小程度

或者

- 提供的值中引用的 MBean 数超过期望的最大程度

或者

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象

或者

- 为该角色提供的 MBean 不存在

RelationTypeNotFoundException - 如果为未知关系类型
另请参见：
getRole(java.lang.String, java.lang.String)

setRoles

RoleResult setRoles(String relationId,
                    RoleList roleList)
                    throws RelationServiceNotRegisteredException,
                           IllegalArgumentException,
                           RelationNotFoundException
以给定关系设置给定角色。

将按照其在关系的关系类型中提供的相应角色定义检查角色

通过处理引用的 MBean 注销，Relation Service 跟踪更改来保持关系的一致性。

参数：
relationId - 关系 id
roleList - 要设置的角色列表
返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功设置的角色）和一个 RoleUnresolvedList（针对未成功设置的角色）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果没有带给定 id 的关系
另请参见：
getRoles(java.lang.String, java.lang.String[])

getReferencedMBeans

Map<ObjectName,List<String>> getReferencedMBeans(String relationId)
                                                 throws IllegalArgumentException,
                                                        RelationNotFoundException
检索关系的各种角色中引用的 MBean。

参数：
relationId - 关系 id
返回：
一个 HashMap 映射：

ObjectName -> ArrayList of String（角色名）

抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系

getRelationTypeName

String getRelationTypeName(String relationId)
                           throws IllegalArgumentException,
                                  RelationNotFoundException
返回给定关系的相关关系类型的名称。

参数：
relationId - 关系 id
返回：
相关关系类型的名称。
抛出：
IllegalArgumentException - 如果参数为 null
RelationNotFoundException - 如果不存在给定关系 id 的关系
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationSupport

java.lang.Object
    继承者  javax.management.relation.RelationSupport
所有已实现的接口：
MBeanRegistration, Relation, RelationSupportMBean
public class RelationSupport
extends Object
implements RelationSupportMBean, MBeanRegistration

RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。作为内部表示形式，不会向用户公开它。

RelationSupport 类遵循标准的 MBean 设计模式。因此，用户可以决定将 RelationSupport 对象本身实例化为 MBean（因为它遵循 MBean 设计模式），以便在 MBean Server 中注册，然后将其添加到 Relation Service 中。

用户还可以在创建自己的 MBean 关系类时让其扩展 RelationSupport，以检索所需接口的实现（请参见下面内容）。

它还可以在用户关系 MBean 类中让一个成员成为 RelationSupport 对象，并通过将所有接口委托给此成员来实现所需接口。

RelationSupport 实现 Relation 接口（将由 Relation Service 处理）。

它还实现 MBeanRegistration 接口，以便能够检索它在其中注册的 MBean Server（如果注册为 MBean），从而访问其 Relation Service。

从以下版本开始：
1.5

构造方法摘要
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
方法摘要
RoleResult | getAllRoles() 返回关系中存在的所有角色。
Map<ObjectName,List<String>> | getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
String | getRelationId() 返回关系标识符（用于唯一标识 Relation Service 中的关系）。
ObjectName | getRelationServiceName() 返回处理关系的 Relation Service 的 ObjectName。
String | getRelationTypeName() 返回相关关系类型的名称。
List<ObjectName> | getRole(String roleName) 检索给定角色名称的角色值。
Integer | getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
RoleResult | getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
void | handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
Boolean | isInRelationService() 返回指定该对象是否仍然由 Relation Service 处理的内部标志。
void | postDeregister() 允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。
void | postRegister(Boolean registrationDone) 允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
void | preDeregister() 允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。
ObjectName | preRegister(MBeanServer server, ObjectName name) 允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
RoleList | retrieveAllRoles() 返回关系中的所有角色，不检查读取模式。
void | setRelationServiceManagementFlag(Boolean flag) 指定此关系是否由 Relation Service 处理。
void | setRole(Role role) 设置给定的角色。
RoleResult | setRoles(RoleList list) 设置给定的角色。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RelationSupport

public RelationSupport(String relationId,
                       ObjectName relationServiceName,
                       String relationTypeName,
                       RoleList list)
                throws InvalidRoleValueException,
                       IllegalArgumentException
创建一个 RelationSupport 对象。

在用户要将 RelationSupport 对象注册为 MBean 时，或者在创建扩展 RelationSupport 的用户关系 MBean 类时，必须使用此构造方法。

在 Relation Service 级别不执行任何操作，既不向 RelationService 添加 RelationSupport 对象，也不查看提供的值是否正确。始终创建该对象，除以下情况外：

- 任何所需的参数为 null。

- 两个角色使用了同一名称。

为了将该对象作为关系处理，务必使用 Relation Service 方法 addRelation() 将 RelationSupport 对象添加到 Relation Service 中。

参数：
relationId - 关系标识符，用来在 Relation Service 中标识关系。

期望在给定的 Relation Service 中唯一。

relationServiceName - 将在其中注册关系的 Relation Service 的 ObjectName。

此参数是必需的，因为这是知道给定关系的关系类型定义的 Relation Service，所以将能够检查更新操作（集）。

relationTypeName - 关系类型的名称。

期望已在给定的 Relation Service 中创建。

list - 要初始化关系的角色（Role 对象）的列表。可以为 null。

期望遵循相关关系类型中的关系信息。

抛出：
InvalidRoleValueException - 如果两个角色使用了同一个名称。
IllegalArgumentException - 如果任何所需参数（关系 id、关系服务 ObjectName、关系服务 MBeanServer 或者关系类型名称）为 null。

RelationSupport

public RelationSupport(String relationId,
                       ObjectName relationServiceName,
                       MBeanServer relationServiceMBeanServer,
                       String relationTypeName,
                       RoleList list)
                throws InvalidRoleValueException,
                       IllegalArgumentException
创建一个 RelationSupport 对象。

在用户关系 MBean 实现期望通过委托给 RelationSupport 对象受关系支持的接口时，务必使用此构造方法。

此对象需要知道期望处理该关系的 Relation Service。所以它必须知道 Relation Service 在其中注册的 MBean Server。

按照限制，必须像期望处理它的 Relation Service 一样在同一 MBean Server 中注册关系 MBean。所以必须创建并注册用户关系 MBean，然后可以使用标识的 MBean Server 创建包装的 RelationSupport 对象。

在 Relation Service 级别不执行任何操作，既不向 RelationService 添加 RelationSupport 对象，也不查看提供的值是否正确。始终创建该对象，除以下情况外：

- 任何所需的参数为 null。

- 两个角色使用了同一个名称。

为了将该对象作为关系处理，务必使用 Relation Service 方法 addRelation() 将 RelationSupport 对象添加到 Relation Service 中。

参数：
relationId - 关系标识符，用来在 Relation Service 中标识关系。

期望在给定的 Relation Service 中唯一。

relationServiceName - 将在其中注册关系的 Relation Service 的 ObjectName。

此参数是必需的，因为这是知道给定关系的关系类型定义的 Relation Service，所以将能够检查更新操作（集合）。

relationServiceMBeanServer - 该包装 MBean 在其中或将在其中注册的 MBean Server。

期望是 Relation Service 在其中或将在其中注册的 MBean Server。

relationTypeName - 关系类型的名称。

期望已在给定的 Relation Service 中创建该名称。

list - 要初始化关系的角色（Role 对象）的列表。可以为 null。

期望遵循相关关系类型中的关系信息。

抛出：
InvalidRoleValueException - 如果两个角色使用了同一个名称。
IllegalArgumentException - 如果任何所需参数（关系 id、关系服务 ObjectName 或者关系类型名称）为 null。
方法详细信息

getRole

public List<ObjectName> getRole(String roleName)
                         throws IllegalArgumentException,
                                RoleNotFoundException,
                                RelationServiceNotRegisteredException
检索给定角色名称的角色值。

按照关系类型检查角色是否存在以及是否可读。

指定者：
接口 Relation 中的 getRole
参数：
roleName - 角色名称
返回：
作为角色值的 ObjectName 对象的 ArrayList
抛出：
IllegalArgumentException - 如果为 null 角色名称
RoleNotFoundException - 如果：

- 不存在具有给定名称的角色

- 角色不可读。

RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
另请参见：
setRole(javax.management.relation.Role)

getRoles

public RoleResult getRoles(String[] roleNameArray)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException
检索具有给定名称的角色值。

按照关系类型检查每个角色是否存在以及是否可读。

指定者：
接口 Relation 中的 getRoles
参数：
roleNameArray - 要检索的角色名称的数组
返回：
RoleResult 对象，包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对未检索到的角色）。
抛出：
IllegalArgumentException - 如果角色名称为 null
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册。
另请参见：
setRoles(javax.management.relation.RoleList)

getAllRoles

public RoleResult getAllRoles()
                       throws RelationServiceNotRegisteredException
返回关系中存在的所有角色。

指定者：
接口 Relation 中的 getAllRoles
返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功检索到的角色）和一个 RoleUnresolvedList（针对不可读的角色）。
抛出：
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册

retrieveAllRoles

public RoleList retrieveAllRoles()
返回关系中的所有角色，不检查读取模式。

指定者：
接口 Relation 中的 retrieveAllRoles
返回：
一个 RoleList

getRoleCardinality

public Integer getRoleCardinality(String roleName)
                           throws IllegalArgumentException,
                                  RoleNotFoundException
返回当前在给定角色中引用的 MBean 数。

指定者：
接口 Relation 中的 getRoleCardinality
参数：
roleName - 角色名称
返回：
当前在此角色中引用的 MBean 数
抛出：
IllegalArgumentException - 如果角色名称为 null
RoleNotFoundException - 如果不存在具有给定名称的角色

setRole

public void setRole(Role role)
             throws IllegalArgumentException,
                    RoleNotFoundException,
                    RelationTypeNotFoundException,
                    InvalidRoleValueException,
                    RelationServiceNotRegisteredException,
                    RelationNotFoundException
设置给定的角色。

将按照其在关系的关系类型中提供的相应角色定义检查角色

将发送通知（带类型 RELATION_BASIC_UPDATE 或 RELATION_MBEAN_UPDATE 的 RelationNotification，具体取决于该关系是否为 MBean）

指定者：
接口 Relation 中的 setRole
参数：
role - 要设置的角色（名称和新值）
抛出：
IllegalArgumentException - 如果角色是 null
RoleNotFoundException - 如果不存在具有指定名称的角色，或者该角色不可写该角色不可写（初始化角色时未执行写入访问模式测试）
InvalidRoleValueException - 如果为角色提供的值无效，即

- 给定值中引用的 MBean 数小于期望的最小程度

- 提供的值中引用的 MBean 数超过期望的最大程度

- 该值中引用的 MBean 的一个对象不是该角色期望的 MBean 类的对象

- 不存在为该角色提供的 MBean

RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
RelationTypeNotFoundException - 如果尚未在 Relation Service 中声明该关系类型
RelationNotFoundException - 如果尚未在 Relation Service 中添加关系。
另请参见：
getRole(java.lang.String)

setRoles

public RoleResult setRoles(RoleList list)
                    throws IllegalArgumentException,
                           RelationServiceNotRegisteredException,
                           RelationTypeNotFoundException,
                           RelationNotFoundException
设置给定的角色。

将按照其在关系的关系类型中提供的相应角色定义检查角色。

每个更新的角色将发送一个通知（带类型 RELATION_BASIC_UPDATE 或 RELATION_MBEAN_UPDATE 的 RelationNotification，具体取决于该关系是否为 MBean）。

指定者：
接口 Relation 中的 setRoles
参数：
list - 要设置的角色列表
返回：
RoleResult 对象，该对象包括一个 RoleList（针对成功设置的角色）和一个 RoleUnresolvedList（针对未成功设置的角色）。
抛出：
IllegalArgumentException - 如果角色列表为 null
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 中注册
RelationTypeNotFoundException - 如果在 Relation Service 中尚未声明该关系类型。
RelationNotFoundException - 如果尚未在 Relation Service 中添加关系 MBean。
另请参见：
getRoles(java.lang.String[])

handleMBeanUnregistration

public void handleMBeanUnregistration(ObjectName objectName,
                                      String roleName)
                               throws IllegalArgumentException,
                                      RoleNotFoundException,
                                      InvalidRoleValueException,
                                      RelationServiceNotRegisteredException,
                                      RelationTypeNotFoundException,
                                      RelationNotFoundException
在注销角色中引用的 MBean 时由 Relation Service 使用的回调。

Relation Service 将调用此方法，以让该关系采取行动来反映这种注销的影响。

小心，不要期望用户调用此方法。

当前实现是为了用其当前值（引用的 MBean 的 ObjectName 列表）而不用注销的值设置角色。

指定者：
接口 Relation 中的 handleMBeanUnregistration
参数：
objectName - 注销的 MBean 的 ObjectName
roleName - 在其中引用 MBean 的角色名称
抛出：
IllegalArgumentException - 如果参数为 null
RoleNotFoundException - 如果角色不在关系中或不可写
InvalidRoleValueException - 如果角色值不遵循相关角色信息（这永远不会在从 Relation Service 中调用时发生）
RelationServiceNotRegisteredException - 如果 Relation Service 未在 MBean Server 注册
RelationTypeNotFoundException - 如果在 Relation Service 中尚未声明该关系类型。
RelationNotFoundException - 如果未在 Relation Service 中添加的关系 MBean 调用此方法。

getReferencedMBeans

public Map<ObjectName,List<String>> getReferencedMBeans()
检索在该关系的各种角色中引用的 MBean。

指定者：
接口 Relation 中的 getReferencedMBeans
返回：
一个 HashMap 映射：

ObjectName -> String 的 ArrayList（角色名）

getRelationTypeName

public String getRelationTypeName()
返回相关关系类型的名称。

指定者：
接口 Relation 中的 getRelationTypeName
返回：
关系类型的名称。

getRelationServiceName

public ObjectName getRelationServiceName()
返回处理关系的 Relation Service 的 ObjectName。

指定者：
接口 Relation 中的 getRelationServiceName
返回：
Relation Service 的 ObjectName。

getRelationId

public String getRelationId()
返回关系标识符（用于唯一标识 Relation Service 中的关系）。

指定者：
接口 Relation 中的 getRelationId
返回：
关系 id。

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
从接口 MBeanRegistration 复制的描述
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。如果未指定 MBean 的名称，则该 MBean 可以提供一个注册名称。如果引发任何异常，则该 MBean 不会被注册到 MBean 服务器中。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
server - 将要在其中注册该 MBean 的 MBean 服务器。
name - 该 MBean 的对象名。如果 MBeanServer 接口中的某个 createMBean 方法或 registerMBean 方法的 name 参数为 null，则此 name 也为 null。在这种情况下，此方法必须为新 MBean 返回非 null 的 ObjectName。
返回：
MBean 要被注册的名称。此值必须不为 null。如果 name 参数不为 null，则它通常但并非一定为返回值。
抛出：
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postRegister

public void postRegister(Boolean registrationDone)
从接口 MBeanRegistration 复制的描述
允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示该 MBean 是否已在 MBean 服务器中成功注册。false 值意味着注册阶段已失败。

preDeregister

public void preDeregister()
                   throws Exception
从接口 MBeanRegistration 复制的描述
允许该 MBean 在从 MBean 服务器注销之前执行它所需要的任何操作。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postDeregister

public void postDeregister()
从接口 MBeanRegistration 复制的描述
允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。

指定者：
接口 MBeanRegistration 中的 postDeregister

isInRelationService

public Boolean isInRelationService()
返回指定该对象是否仍然由 Relation Service 处理的内部标志。

指定者：
接口 RelationSupportMBean 中的 isInRelationService
返回：
如果该对象仍然由 Relation Service 处理，则返回等于 Boolean.TRUE 的 Boolean 值；否则，返回等于 Boolean.FALSE 的 Boolean 值。

setRelationServiceManagementFlag

public void setRelationServiceManagementFlag(Boolean flag)
                                      throws IllegalArgumentException
从接口 RelationSupportMBean 复制的描述

指定此关系是否由 Relation Service 处理。

注意，当 Relation Service 通过其管理接口访问该关系时，此方法必须公开。强烈建议不要使用此方法。使用此方法不影响 Relation Service 中的关系对象的注册，但会提供有关它的错误信息！

指定者：
接口 RelationSupportMBean 中的 setRelationServiceManagementFlag
参数：
flag - 该关系是否由 Relation Service 处理的标志。
抛出：
IllegalArgumentException - 如果是 null 参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationServiceNotRegisteredException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationServiceNotRegisteredException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.RelationServiceNotRegisteredException
所有已实现的接口：
Serializable
public class RelationServiceNotRegisteredException
extends RelationException

在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RelationServiceNotRegisteredException()
默认的构造方法，其异常中未放置任何消息。
RelationServiceNotRegisteredException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RelationServiceNotRegisteredException

public RelationServiceNotRegisteredException()
默认的构造方法，其异常中未放置任何消息。

RelationServiceNotRegisteredException

public RelationServiceNotRegisteredException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationSupportMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
接口 RelationSupportMBean

所有超级接口：
Relation
所有已知实现类：
RelationSupport
public interface RelationSupportMBean
extends Relation

RelationSupport 对象由 Relation Service 内部使用，表示任何关系类型的具有无限量角色的简单关系（只有角色，没有属性或方法）。作为内部表示形式，它不会向用户公开。

RelationSupport 类遵循标准的 MBean 设计模式。因此，用户可以决定将 RelationSupport 对象本身实例化为 MBean（因为它遵循 MBean 设计模式），以便在 MBean Server 中注册，然后将其添加到 Relation Service 中。

用户还可以在创建自己的 MBean 关系类时让其扩展 RelationSupport，以检索所需接口的实现（请参见下面内容）。

它还可以在用户关系 MBean 类中让一个成员成为 RelationSupport 对象，并通过将所有接口委托给此成员来实现所需接口。

RelationSupport 实现 Relation 接口（将由 Relation Service 处理）。

从以下版本开始：
1.5

方法摘要
Boolean | isInRelationService() 返回指定该对象是否仍然由 Relation Service 处理的内部标志。
void | setRelationServiceManagementFlag(Boolean flag) 指定此关系是否由 Relation Service 处理。
从接口 javax.management.relation.Relation 继承的方法
getAllRoles, getReferencedMBeans, getRelationId, getRelationServiceName, getRelationTypeName, getRole, getRoleCardinality, getRoles, handleMBeanUnregistration, retrieveAllRoles, setRole, setRoles

方法详细信息

isInRelationService

Boolean isInRelationService()
返回指定该对象是否仍然由 Relation Service 处理的内部标志。

返回：
如果该对象仍然由 Relation Service 处理，则返回等于 Boolean.TRUE 的 Boolean 值；否则，返回等于 Boolean.FALSE 的 Boolean 值。

setRelationServiceManagementFlag

void setRelationServiceManagementFlag(Boolean flag)
                                      throws IllegalArgumentException

指定此关系是否由 Relation Service 处理。

注意，当 Relation Service 通过其管理接口访问该关系时，此方法必须公开。强烈建议不要使用此方法。使用此方法不影响 Relation Service 中的关系对象的注册，但会提供有关它的错误信息！

参数：
flag - 该关系是否由 Relation Service 处理的标志。
抛出：
IllegalArgumentException - 如果是 null 参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
接口 RelationType

所有超级接口：
Serializable
所有已知实现类：
RelationTypeSupport
public interface RelationType
extends Serializable

该 RelationType 接口必须由期望表示关系类型的任何类来实现。

从以下版本开始：
1.5

方法摘要
String | getRelationTypeName() 返回关系类型名称。
RoleInfo | getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
List<RoleInfo> | getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。

方法详细信息

getRelationTypeName

String getRelationTypeName()
返回关系类型名称。

返回：
关系类型名称。

getRoleInfos

List<RoleInfo> getRoleInfos()
返回角色定义的列表（RoleInfo 对象的 ArrayList）。

返回：
RoleInfo 的 ArrayList。

getRoleInfo

RoleInfo getRoleInfo(String roleInfoName)
                     throws IllegalArgumentException,
                            RoleInfoNotFoundException
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。

参数：
roleInfoName - 角色信息名称
返回：
如果提供角色定义的对象不存在，则返回 RoleInfo 对象
抛出：
IllegalArgumentException - 如果为 null 参数
RoleInfoNotFoundException - 如果在关系类型中没有带该名称的角色信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationTypeNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationTypeNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.RelationTypeNotFoundException
所有已实现的接口：
Serializable
public class RelationTypeNotFoundException
extends RelationException

Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RelationTypeNotFoundException()
默认的构造方法，其异常中未放置任何消息。
RelationTypeNotFoundException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RelationTypeNotFoundException

public RelationTypeNotFoundException()
默认的构造方法，其异常中未放置任何消息。

RelationTypeNotFoundException

public RelationTypeNotFoundException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RelationTypeSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RelationTypeSupport

java.lang.Object
    继承者  javax.management.relation.RelationTypeSupport
所有已实现的接口：
Serializable, RelationType
public class RelationTypeSupport
extends Object
implements RelationType

RelationTypeSupport 对象实现 RelationType 接口。

它表示一个关系类型，提供期望在该类型的每个关系中受支持的各角色的角色实现。

关系类型包括关系类型名称和角色信息（由 RoleInfo 对象表示）的列表。

关系类型必须在 Relation Service（关系服务）中声明：

- 可以使用 createRelationType() 方法，在此情况下，将在 Relation Service 中创建和保存 RelationTypeSupport 对象

- 也可以使用 addRelationType() 方法，在此情况下，用户必须创建一个实现 RelationType 接口的对象，并将此对象用于表示 Relation Service 中的关系类型。

此类的 serialVersionUID 为 4611072955724144607L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
protected | RelationTypeSupport(String relationTypeName) 用于子类的构造方法。
 | RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray) 所有角色定义在其中动态创建并作为参数传递的构造方法。
方法摘要
protected void | addRoleInfo(RoleInfo roleInfo) 添加角色信息。
String | getRelationTypeName() 返回关系类型名称。
RoleInfo | getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
List<RoleInfo> | getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RelationTypeSupport

public RelationTypeSupport(String relationTypeName,
                           RoleInfo[] roleInfoArray)
                    throws IllegalArgumentException,
                           InvalidRelationTypeException
所有角色定义在其中动态创建并作为参数传递的构造方法。

参数：
relationTypeName - 关系类型的名称
roleInfoArray - 角色定义（RoleInfo 对象）的列表
抛出：
IllegalArgumentException - 如果是 null 参数
InvalidRelationTypeException - 如果：

- 两个不同的角色用了同一个名称

- 未提供角色信息

- 提供了一个 null 角色信息

RelationTypeSupport

protected RelationTypeSupport(String relationTypeName)
用于子类的构造方法。

参数：
relationTypeName - 关系类型的名称。
抛出：
IllegalArgumentException - 如果是 null 参数。
方法详细信息

getRelationTypeName

public String getRelationTypeName()
返回关系类型名称。

指定者：
接口 RelationType 中的 getRelationTypeName
返回：
关系类型名称。

getRoleInfos

public List<RoleInfo> getRoleInfos()
返回角色定义的列表（RoleInfo 对象的 ArrayList）。

指定者：
接口 RelationType 中的 getRoleInfos
返回：
RoleInfo 的 ArrayList。

getRoleInfo

public RoleInfo getRoleInfo(String roleInfoName)
                     throws IllegalArgumentException,
                            RoleInfoNotFoundException
返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。

指定者：
接口 RelationType 中的 getRoleInfo
参数：
roleInfoName - 角色信息名称
返回：
如果提供角色定义的对象不存在，则返回 RoleInfo 对象
抛出：
IllegalArgumentException - 如果是 null 参数
RoleInfoNotFoundException - 如果在关系类型中没有带该名称的角色信息。

addRoleInfo

protected void addRoleInfo(RoleInfo roleInfo)
                    throws IllegalArgumentException,
                           InvalidRelationTypeException
添加角色信息。创建关系类型后当然不应使用此方法，因为更新这种关系类型将无效，已创建的与该类型关联的关系仍然遵循这种关系类型。如果试图更新在 Relation Service 中声明的关系类型，则可能抛出 RuntimeException。

参数：
roleInfo - 要添加的角色信息。
抛出：
IllegalArgumentException - 如果是 null 参数。
InvalidRelationTypeException - 如果在当前具有同一名称的关系类型中已经存在角色信息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Role (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 Role

java.lang.Object
    继承者  javax.management.relation.Role
所有已实现的接口：
Serializable
public class Role
extends Object
implements Serializable

表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。角色值总是表示为 ObjectName 的 ArrayList 集合，以均衡访问。

此类的 serialVersionUID 为 -279985518429862552L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。
方法摘要
Object | clone() 复制角色对象。
String | getRoleName() 检索角色名称。
List<ObjectName> | getRoleValue() 检索角色值。
static String | roleValueToString(List<ObjectName> roleValue) 返回给定角色值的字符串。
void | setRoleName(String roleName) 设置角色名称。
void | setRoleValue(List<ObjectName> roleValue) 设置角色值。
String | toString() 返回描述角色的字符串。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Role

public Role(String roleName,
            List<ObjectName> roleValue)
     throws IllegalArgumentException

创建一个新的 Role 对象。不用检查角色值中的 ObjectName 是否在 MBean 服务器中存在。在关系中设置角色时将进行该项检查。

参数：
roleName - 角色名称
roleValue - 角色值（ObjectName 对象的列表）
抛出：
IllegalArgumentException - 如果是 null 参数
方法详细信息

getRoleName

public String getRoleName()
检索角色名称。

返回：
角色名称。
另请参见：
setRoleName(java.lang.String)

getRoleValue

public List<ObjectName> getRoleValue()
检索角色值。

返回：
引用的 MBean 的 ObjectName 对象的 ArrayList。
另请参见：
setRoleValue(java.util.List)

setRoleName

public void setRoleName(String roleName)
                 throws IllegalArgumentException
设置角色名称。

参数：
roleName - 角色名称
抛出：
IllegalArgumentException - 如果是 null 参数
另请参见：
getRoleName()

setRoleValue

public void setRoleValue(List<ObjectName> roleValue)
                  throws IllegalArgumentException
设置角色值。

参数：
roleValue - 引用的 MBean 的 ObjectName 对象的列表。
抛出：
IllegalArgumentException - 如果是 null 参数
另请参见：
getRoleValue()

toString

public String toString()
返回描述角色的字符串。

覆盖：
类 Object 中的 toString
返回：
角色的描述。

clone

public Object clone()
复制角色对象。

覆盖：
类 Object 中的 clone
返回：
当前 Role 对象的独立副本的 Role。
另请参见：
Cloneable

roleValueToString

public static String roleValueToString(List<ObjectName> roleValue)
                                throws IllegalArgumentException
返回给定角色值的字符串。

参数：
roleValue - ObjectName 对象的列表
返回：
由新行 (\n) 分隔的 ObjectName 组成的字符串。
抛出：
IllegalArgumentException - 如果是 null 参数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleInfo

java.lang.Object
    继承者  javax.management.relation.RoleInfo
所有已实现的接口：
Serializable
public class RoleInfo
extends Object
implements Serializable

RoleInfo 概括介绍关系类型中的角色。

此类的 serialVersionUID 为 2504952983494636987L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static int ROLE_CARDINALITY_INFINITY
指定无限的容量。
构造方法摘要
RoleInfo(RoleInfo roleInfo)
复制构造方法。
RoleInfo(String roleName, String mbeanClassName)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。
方法摘要
boolean | checkMaxDegree(int value) 如果 value 参数小于或等于期望的最大程度，则返回 true；否则返回 false。
boolean | checkMinDegree(int value) 如果 value 参数大于或等于期望的最小程度，则返回 true；否则返回 false。
String | getDescription() 返回角色的描述文本。
int | getMaxDegree() 返回相应角色引用的最大程度。
int | getMinDegree() 返回相应角色引用的最小程度。
String | getName() 返回角色名称。
String | getRefMBeanClassName() 返回期望在相应角色中引用的 MBean 的类型名称。
boolean | isReadable() 返回角色的读取访问模式（如果可读，则返回 true）。
boolean | isWritable() 返回角色的写入访问模式（如果可写，则返回 true）。
String | toString() 返回描述角色信息的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ROLE_CARDINALITY_INFINITY

public static final int ROLE_CARDINALITY_INFINITY
指定无限的容量。

另请参见：
常量字段值
构造方法详细信息

RoleInfo

public RoleInfo(String roleName,
                String mbeanClassName,
                boolean read,
                boolean write,
                int min,
                int max,
                String descr)
         throws IllegalArgumentException,
                InvalidRoleInfoException,
                ClassNotFoundException,
                NotCompliantMBeanException
构造方法。

参数：
roleName - 角色的名称。
mbeanClassName - 期望在相应角色中引用的 MBean 的类名称。如果 MBean M 在此角色中，则对于 isInstanceOf(M, mbeanClassName)，MBean 服务器必须返回 true。
read - 指示相应角色是否可读的标志
write - 指示相应角色是否可设置的标志
min - 角色的最小程度，即要在相应角色提供的 MBean 的最小数必须小于或等于 max。（ROLE_CARDINALITY_INFINITY 不受限制）
max - 角色的最大程度，即要在相应角色中提供的 MBean 的最大数必须大于或等于 min（ROLE_CARDINALITY_INFINITY 不受限制）
descr - 角色的描述（可以为 null）
抛出：
IllegalArgumentException - 如果参数为 null
InvalidRoleInfoException - 如果最小程度大于最大程度。
ClassNotFoundException - 从 JMX 1.2 开始，不再抛出此异常。它将保留在此类的声明中，以便与现有代码兼容。
NotCompliantMBeanException - 如果类 mbeanClassName 不是 MBean 类。

RoleInfo

public RoleInfo(String roleName,
                String mbeanClassName,
                boolean read,
                boolean write)
         throws IllegalArgumentException,
                ClassNotFoundException,
                NotCompliantMBeanException
构造方法。

参数：
roleName - 角色的名称
mbeanClassName - 期望在相应角色中引用的 MBean 的类名称。如果 MBean M 在此角色中，则对于 isInstanceOf(M, mbeanClassName)，MBean 服务器必须返回 true。
read - 指示相应角色是否可读的标志
write - 指示相应角色是否可设置的标志

默认为 1 的最小和最大程度。

默认为 null 的角色描述。

抛出：
IllegalArgumentException - 如果参数为 null
ClassNotFoundException - 从 JMX 1.2 开始，不再抛出此异常。它将保留在此类的声明中，以便与现有代码兼容。
NotCompliantMBeanException - 从 JMX 1.2 开始，不再抛出此异常。它将保留在此类的声明中，以便与现有代码兼容。

RoleInfo

public RoleInfo(String roleName,
                String mbeanClassName)
         throws IllegalArgumentException,
                ClassNotFoundException,
                NotCompliantMBeanException
构造方法。

参数：
roleName - 角色的名称
mbeanClassName - 期望在相应角色中引用的 MBean 的类名称。如果 MBean M 在此角色中，则对于 isInstanceOf(M, mbeanClassName)，MBean 服务器必须返回 true。

默认为 true 的 IsReadable 和 IsWritable。

默认为 1 的最小和最大程度。

默认为 null 的角色描述。

抛出：
IllegalArgumentException - 如果参数为 null
ClassNotFoundException - 从 JMX 1.2 开始，不再抛出此异常。它将保留在此类的声明中，以便与现有代码兼容。
NotCompliantMBeanException - 从 JMX 1.2 开始，不再抛出此异常。它将保留在此类的声明中，以便与现有代码兼容。

RoleInfo

public RoleInfo(RoleInfo roleInfo)
         throws IllegalArgumentException
复制构造方法。

参数：
roleInfo - 要复制的 RoleInfo 实例。
抛出：
IllegalArgumentException - 如果参数为 null
方法详细信息

getName

public String getName()
返回角色名称。

返回：
角色名称。

isReadable

public boolean isReadable()
返回角色的读取访问模式（如果可读，则返回 true）。

返回：
如果角色可读，则返回 true

isWritable

public boolean isWritable()
返回角色的写入访问模式（如果可写，则返回 true）。

返回：
如果角色可写，则返回 true。

getDescription

public String getDescription()
返回角色的描述文本。

返回：
角色的描述。

getMinDegree

public int getMinDegree()
返回相应角色引用的最小程度。

返回：
最小程度。

getMaxDegree

public int getMaxDegree()
返回相应角色引用的最大程度。

返回：
最大程度。

getRefMBeanClassName

public String getRefMBeanClassName()

返回期望在相应角色中引用的 MBean 的类型名称。

返回：
引用的类型名称。

checkMinDegree

public boolean checkMinDegree(int value)
如果 value 参数大于或等于期望的最小程度，则返回 true；否则返回 false。

参数：
value - 要检查的值
返回：
如果大于或等于最小程度，则返回 true；否则返回 false。

checkMaxDegree

public boolean checkMaxDegree(int value)
如果 value 参数小于或等于期望的最大程度，则返回 true；否则返回 false。

参数：
value - 要检查的值
返回：
如果小于或等于最大程度，则返回 true；否则返回 false。

toString

public String toString()
返回描述角色信息的字符串。

覆盖：
类 Object 中的 toString
返回：
角色信息的描述。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleInfoNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleInfoNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.RoleInfoNotFoundException
所有已实现的接口：
Serializable
public class RoleInfoNotFoundException
extends RelationException

给定的关系类型中不存在带指定名称的角色信息时引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RoleInfoNotFoundException()
默认的构造方法，其异常中未放置任何消息。
RoleInfoNotFoundException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RoleInfoNotFoundException

public RoleInfoNotFoundException()
默认的构造方法，其异常中未放置任何消息。

RoleInfoNotFoundException

public RoleInfoNotFoundException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleList

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.ArrayList<Object>
                继承者  javax.management.relation.RoleList
所有已实现的接口：
Serializable, Cloneable, Iterable<Object>, Collection<Object>, List<Object>, RandomAccess
public class RoleList
extends ArrayList<Object>

RoleList 表示角色（Role 对象）的列表。它在创建关系和试图在关系中设置几个角色（通过 'setRoles()'方法）时用作参数。它将作为 RoleResult 的一部分返回，以提供成功检索的角色。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
RoleList()
构造一个空的 RoleList。
RoleList(int initialCapacity)
构造一个具有指定初始容量的空 RoleList。
RoleList(List<Role> list)
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。
方法摘要
void | add(int index, Object element) 将指定的元素插入此列表中的指定位置。
void | add(int index, Role role) 插入指定为指定位置处的元素的角色。
boolean | add(Object o) 将指定的元素添加到此列表的尾部。
void | add(Role role) 添加指定为列表中最后一个元素的 Role。
boolean | addAll(Collection<?> c) 按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
boolean | addAll(int index, Collection<?> c) 从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
boolean | addAll(int index, RoleList roleList) 从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | addAll(RoleList roleList) 将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。
List<Role> | asList() 以 List<Role> 的形式返回此列表的示图。
Object | set(int index, Object element) 用指定的元素替代此列表中指定位置上的元素。
void | set(int index, Role role) 将指定位置处的元素设置为指定角色。
从类 java.util.ArrayList 继承的方法
clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, size, toArray, toArray, trimToSize
从类 java.util.AbstractList 继承的方法
equals, hashCode, iterator, listIterator, listIterator, subList
从类 java.util.AbstractCollection 继承的方法
containsAll, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

构造方法详细信息

RoleList

public RoleList()
构造一个空的 RoleList。

RoleList

public RoleList(int initialCapacity)
构造一个具有指定初始容量的空 RoleList。

参数：
initialCapacity - 初始容量

RoleList

public RoleList(List<Role> list)
         throws IllegalArgumentException
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。RoleList 实例的初始容量是指定 List 大小的 110％。

参数：
list - 定义新 RoleList 初始内容的 List。
抛出：
IllegalArgumentException - 如果 list 参数为 null 或者 list 参数包含任何非 Role 对象。
另请参见：
ArrayList.ArrayList(java.util.Collection)
方法详细信息

asList

public List<Role> asList()
以 List<Role> 的形式返回此列表的示图。对返回值的更改将通过对原 RoleList 的更改反映出来，反之亦然。

返回：
一个 List<Role>，其内容反映此 RoleList 的内容。

如果曾经对给定的 RoleList 实例调用过此方法，则之后试图对该实例添加非 Role 对象的操作将会失败，并抛出 IllegalArgumentException。出于兼容性原因，允许向从未调用过此方法的 RoleList 添加非 Role 对象。

抛出：
IllegalArgumentException - 如果此 RoleList 包含非 Role 元素。
从以下版本开始：
1.6

add

public void add(Role role)
         throws IllegalArgumentException
添加指定为列表中最后一个元素的 Role。

参数：
role - 要添加的角色。
抛出：
IllegalArgumentException - 如果角色为 null。

add

public void add(int index,
                Role role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
插入指定为指定位置处的元素的角色。将其索引大于或等于当前位置的元素上移。

参数：
index - 在列表中要插入新 Role 对象的位置。
role - 要插入的 Role 对象。
抛出：
IllegalArgumentException - 如果角色为 null。
IndexOutOfBoundsException - 如果用列表之外的索引访问。

set

public void set(int index,
                Role role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
将指定位置处的元素设置为指定角色。丢弃该位置以前的元素。

参数：
index - 指定的位置。
role - 角色元素应该设置为的值。
抛出：
IllegalArgumentException - 如果角色为 null。
IndexOutOfBoundsException - 如果用列表之外的索引访问。

addAll

public boolean addAll(RoleList roleList)
               throws IndexOutOfBoundsException
将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。

参数：
roleList - 要插入列表的元素（可以为 null）
返回：
如果此列表由于调用而更改，则返回 true。
抛出：
IndexOutOfBoundsException - 如果用列表之外的索引访问。
另请参见：
ArrayList.addAll(Collection)

addAll

public boolean addAll(int index,
                      RoleList roleList)
               throws IllegalArgumentException,
                      IndexOutOfBoundsException
从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。

参数：
index - 插入指定 RoleList 中第一个元素的位置。
roleList - 要插入该列表的元素。
返回：
如果此列表由于调用而更改，则返回 true。
抛出：
IllegalArgumentException - 如果角色为 null。
IndexOutOfBoundsException - 如果用列表之外的索引访问。
另请参见：
ArrayList.addAll(int, Collection)

add

public boolean add(Object o)
从类 ArrayList 复制的描述
将指定的元素添加到此列表的尾部。

指定者：
接口 Collection<Object> 中的 add
指定者：
接口 List<Object> 中的 add
覆盖：
类 ArrayList<Object> 中的 add
参数：
o - 要添加到此列表中的元素
返回：
true（按照 Collection.add(E) 的指定）

add

public void add(int index,
                Object element)
从类 ArrayList 复制的描述
将指定的元素插入此列表中的指定位置。向右移动当前位于该位置的元素（如果有）以及所有后续元素（将其索引加 1）。

指定者：
接口 List<Object> 中的 add
覆盖：
类 ArrayList<Object> 中的 add
参数：
index - 指定元素所插入位置的索引
element - 要插入的元素

addAll

public boolean addAll(Collection<?> c)
从类 ArrayList 复制的描述
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。如果正在进行此操作时修改指定的 collection ，那么此操作的行为是不确定的。（这意味着如果指定的 collection 是此列表且此列表是非空的，那么此调用的行为是不确定的）。

指定者：
接口 Collection<Object> 中的 addAll
指定者：
接口 List<Object> 中的 addAll
覆盖：
类 ArrayList<Object> 中的 addAll
参数：
c - 包含要添加到此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
另请参见：
AbstractCollection.add(Object)

addAll

public boolean addAll(int index,
                      Collection<?> c)
从类 ArrayList 复制的描述
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。向右移动当前位于该位置的元素（如果有）以及所有后续元素（增加其索引）。新元素将按照指定 collection 的迭代器所返回的元素顺序出现在列表中。

指定者：
接口 List<Object> 中的 addAll
覆盖：
类 ArrayList<Object> 中的 addAll
参数：
index - 插入指定 collection 中的首个元素的位置索引
c - 包含要添加到此列表中元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true

set

public Object set(int index,
                  Object element)
从类 ArrayList 复制的描述
用指定的元素替代此列表中指定位置上的元素。

指定者：
接口 List<Object> 中的 set
覆盖：
类 ArrayList<Object> 中的 set
参数：
index - 要替代的元素的索引
element - 存储在指定位置上的元素
返回：
以前位于该指定位置上的元素
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.relation.RelationException
                    继承者  javax.management.relation.RoleNotFoundException
所有已实现的接口：
Serializable
public class RoleNotFoundException
extends RelationException

关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RoleNotFoundException()
默认的构造方法，其异常中未放置任何消息。
RoleNotFoundException(String message)
异常中放置了给定消息的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RoleNotFoundException

public RoleNotFoundException()
默认的构造方法，其异常中未放置任何消息。

RoleNotFoundException

public RoleNotFoundException(String message)
异常中放置了给定消息的构造方法。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleResult

java.lang.Object
    继承者  javax.management.relation.RoleResult
所有已实现的接口：
Serializable
public class RoleResult
extends Object
implements Serializable

表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。

此类的 serialVersionUID 为 -6304063118040985512L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
构造方法。
方法摘要
RoleList | getRoles() 检索成功访问的角色列表。
RoleUnresolvedList | getRolesUnresolved() 检索未成功访问的角色列表。
void | setRoles(RoleList list) 设置成功访问的角色列表。
void | setRolesUnresolved(RoleUnresolvedList unresolvedList) 设置未成功访问的角色列表。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RoleResult

public RoleResult(RoleList list,
                  RoleUnresolvedList unresolvedList)
构造方法。

参数：
list - 成功访问的角色列表。
unresolvedList - 未成功访问的角色列表（具有问题描述）。
方法详细信息

getRoles

public RoleList getRoles()
检索成功访问的角色列表。

返回：
一个 RoleList
另请参见：
setRoles(javax.management.relation.RoleList)

getRolesUnresolved

public RoleUnresolvedList getRolesUnresolved()
检索未成功访问的角色列表。

返回：
一个 RoleUnresolvedList。
另请参见：
setRolesUnresolved(javax.management.relation.RoleUnresolvedList)

setRoles

public void setRoles(RoleList list)
设置成功访问的角色列表。

参数：
list - 成功访问的角色列表
另请参见：
getRoles()

setRolesUnresolved

public void setRolesUnresolved(RoleUnresolvedList unresolvedList)
设置未成功访问的角色列表。

参数：
unresolvedList - 未成功访问的角色列表
另请参见：
getRolesUnresolved()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleStatus (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleStatus

java.lang.Object
    继承者  javax.management.relation.RoleStatus

public class RoleStatus
extends Object

此类描述访问某个角色时可能遇到的各种问题。

从以下版本开始：
1.5

字段摘要
static int | LESS_THAN_MIN_ROLE_DEGREE 试图用比最小期望容量更少的 ObjectName 设置角色值时的问题类型。
static int | MORE_THAN_MAX_ROLE_DEGREE 试图用比最大期望容量更多的 ObjectName 设置角色值时的问题类型。
static int | NO_ROLE_WITH_NAME 试图访问未知角色时的问题类型。
static int | REF_MBEAN_NOT_REGISTERED 试图设置角色值时的问题类型，包括未在 MBean Server 中注册的 MBean 的 ObjectName。
static int | REF_MBEAN_OF_INCORRECT_CLASS 试图设置角色值时的问题类型，包括不属于该角色所期望类的 MBean 的 ObjectName。
static int | ROLE_NOT_READABLE 试图读取不可读属性时的问题类型。
static int | ROLE_NOT_WRITABLE 试图更新不可写属性时的问题类型。
构造方法摘要
RoleStatus()
方法摘要
static boolean isRoleStatus(int status)
如果给定值对应于已知角色状态，则返回 true；否则，返回 false。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NO_ROLE_WITH_NAME

public static final int NO_ROLE_WITH_NAME
试图访问未知角色时的问题类型。

另请参见：
常量字段值

ROLE_NOT_READABLE

public static final int ROLE_NOT_READABLE
试图读取不可读属性时的问题类型。

另请参见：
常量字段值

ROLE_NOT_WRITABLE

public static final int ROLE_NOT_WRITABLE
试图更新不可写属性时的问题类型。

另请参见：
常量字段值

LESS_THAN_MIN_ROLE_DEGREE

public static final int LESS_THAN_MIN_ROLE_DEGREE
试图用比最小期望容量更少的 ObjectName 设置角色值时的问题类型。

另请参见：
常量字段值

MORE_THAN_MAX_ROLE_DEGREE

public static final int MORE_THAN_MAX_ROLE_DEGREE
试图用比最大期望容量更多的 ObjectName 设置角色值时的问题类型。

另请参见：
常量字段值

REF_MBEAN_OF_INCORRECT_CLASS

public static final int REF_MBEAN_OF_INCORRECT_CLASS
试图设置角色值时的问题类型，包括不属于该角色所期望类的 MBean 的 ObjectName。

另请参见：
常量字段值

REF_MBEAN_NOT_REGISTERED

public static final int REF_MBEAN_NOT_REGISTERED
试图设置角色值时的问题类型，包括未在 MBean Server 中注册的 MBean 的 ObjectName。

另请参见：
常量字段值
构造方法详细信息

RoleStatus

public RoleStatus()
方法详细信息

isRoleStatus

public static boolean isRoleStatus(int status)
如果给定值对应于已知角色状态，则返回 true；否则，返回 false。

参数：
status - 状态代码。
返回：
如果此值为已知角色状态，则返回 true。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleUnresolved (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleUnresolved

java.lang.Object
    继承者  javax.management.relation.RoleUnresolved
所有已实现的接口：
Serializable
public class RoleUnresolved
extends Object
implements Serializable

表示未解析的角色：由于存在问题而无法从关系中检索到的角色。它提供该角色名称、值（如果试图设置该角色时出现问题）和定义问题的整数（在 RoleStatus 中定义的常量）。

此类的 serialVersionUID 为 -48350262537070138L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。
方法摘要
Object | clone() 复制此对象。
int | getProblemType() 检索问题类型。
String | getRoleName() 检索角色名称。
List<ObjectName> | getRoleValue() 检索角色值。
void | setProblemType(int pbType) 设置问题类型。
void | setRoleName(String name) 设置角色名称。
void | setRoleValue(List<ObjectName> value) 设置角色值。
String | toString() 返回描述此对象的字符串。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RoleUnresolved

public RoleUnresolved(String name,
                      List<ObjectName> value,
                      int pbType)
               throws IllegalArgumentException
构造方法。

参数：
name - 角色的名称；
value - 角色的值（设置角色时是否存在问题）；
pbType - 问题的类型（依据已知的问题类型，作为静态最终成员列出）。
抛出：
IllegalArgumentException - 如果参数为 null 或问题类型不正确
方法详细信息

getRoleName

public String getRoleName()
检索角色名称。

返回：
角色名称。
另请参见：
setRoleName(java.lang.String)

getRoleValue

public List<ObjectName> getRoleValue()
检索角色值。

返回：
ObjectName 对象的 ArrayList，即将在给定角色中进行设置的一个数组列表。如果读取访问返回未解析的角色，则返回 null。
另请参见：
setRoleValue(java.util.List)

getProblemType

public int getProblemType()
检索问题类型。

返回：
对应于问题的整数，即描述为当前类的静态最终成员的整数。
另请参见：
setProblemType(int)

setRoleName

public void setRoleName(String name)
                 throws IllegalArgumentException
设置角色名称。

参数：
name - 新角色名称。
抛出：
IllegalArgumentException - 如果是 null 参数
另请参见：
getRoleName()

setRoleValue

public void setRoleValue(List<ObjectName> value)
设置角色值。

参数：
value - 未在角色中设置的引用 MBean 的 ObjectName 对象列表。
另请参见：
getRoleValue()

setProblemType

public void setProblemType(int pbType)
                    throws IllegalArgumentException
设置问题类型。

参数：
pbType - 对应于问题的整数。必须是描述为当前类的静态最终成员的某个整数。
抛出：
IllegalArgumentException - 如果问题类型不正确
另请参见：
getProblemType()

clone

public Object clone()
复制此对象。

覆盖：
类 Object 中的 clone
返回：
独立的副本。
另请参见：
Cloneable

toString

public String toString()
返回描述此对象的字符串。

覆盖：
类 Object 中的 toString
返回：
此 RoleUnresolved 对象的描述。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RoleUnresolvedList (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.relation
类 RoleUnresolvedList

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractList<E>
            继承者  java.util.ArrayList<Object>
                继承者  javax.management.relation.RoleUnresolvedList
所有已实现的接口：
Serializable, Cloneable, Iterable<Object>, Collection<Object>, List<Object>, RandomAccess
public class RoleUnresolvedList
extends ArrayList<Object>

RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 java.util.AbstractList 继承的字段
modCount
构造方法摘要
RoleUnresolvedList()
构造一个空的 RoleUnresolvedList。
RoleUnresolvedList(int initialCapacity)
构造一个具有指定初始容量的空 RoleUnresolvedList。
RoleUnresolvedList(List<RoleUnresolved> list)
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。
方法摘要
void | add(int index, Object element) 将指定的元素插入此列表中的指定位置。
void | add(int index, RoleUnresolved role) 在指定位置处插入指定为元素的未解析角色。
boolean | add(Object o) 将指定的元素添加到此列表的尾部。
void | add(RoleUnresolved role) 添加指定为列表中最后一个元素的 RoleUnresolved。
boolean | addAll(Collection<?> c) 按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。
boolean | addAll(int index, Collection<?> c) 从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。
boolean | addAll(int index, RoleUnresolvedList roleList) 从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
boolean | addAll(RoleUnresolvedList roleList) 将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
List<RoleUnresolved> | asList() 以 List<RoleUnresolved> 的形式返回此列表的视图。
Object | set(int index, Object element) 用指定的元素替代此列表中指定位置上的元素。
void | set(int index, RoleUnresolved role) 将指定位置处的元素设置为指定的未解析角色。
从类 java.util.ArrayList 继承的方法
clear, clone, contains, ensureCapacity, get, indexOf, isEmpty, lastIndexOf, remove, remove, removeRange, size, toArray, toArray, trimToSize
从类 java.util.AbstractList 继承的方法
equals, hashCode, iterator, listIterator, listIterator, subList
从类 java.util.AbstractCollection 继承的方法
containsAll, removeAll, retainAll, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.List 继承的方法
containsAll, equals, hashCode, iterator, listIterator, listIterator, removeAll, retainAll, subList

构造方法详细信息

RoleUnresolvedList

public RoleUnresolvedList()
构造一个空的 RoleUnresolvedList。

RoleUnresolvedList

public RoleUnresolvedList(int initialCapacity)
构造一个具有指定初始容量的空 RoleUnresolvedList。

参数：
initialCapacity - 初始容量

RoleUnresolvedList

public RoleUnresolvedList(List<RoleUnresolved> list)
                   throws IllegalArgumentException
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。RoleUnresolvedList 实例的初始容量是指定 List 大小的 110％。

参数：
list - 定义新 RoleUnresolvedList 初始内容的 List。
抛出：
IllegalArgumentException - 如果 list 参数为 null 或者 list 参数包含任何非 RoleUnresolved 对象。
另请参见：
ArrayList.ArrayList(java.util.Collection)
方法详细信息

asList

public List<RoleUnresolved> asList()
以 List<RoleUnresolved> 的形式返回此列表的视图。对返回值的更改将通过对原 RoleUnresolvedList 的更改反映出来，反之亦然。

返回：
一个 List<RoleUnresolved>，其内容反映此 RoleUnresolvedList 的内容。

如果曾经对给定的 RoleUnresolvedList 实例调用过此方法，则之后试图对该实例添加非 RoleUnresolved 对象的操作将会失败，并抛出 IllegalArgumentException。出于兼容性原因，允许向从未调用过此方法的 RoleUnresolvedList 添加非 RoleUnresolved 对象。

抛出：
IllegalArgumentException - 如果此 RoleUnresolvedList 包含非 RoleUnresolved 元素。
从以下版本开始：
1.6

add

public void add(RoleUnresolved role)
         throws IllegalArgumentException
添加指定为列表中最后一个元素的 RoleUnresolved。

参数：
role - - 要添加的未解析角色。
抛出：
IllegalArgumentException - 如果未解析角色为 null。

add

public void add(int index,
                RoleUnresolved role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
在指定位置处插入指定为元素的未解析角色。将其索引大于或等于当前位置的元素上移。

参数：
index - - 在列表中要插入新 RoleUnresolved 对象的位置。
role - - 要插入的 RoleUnresolved 对象。
抛出：
IllegalArgumentException - 如果未解析角色为 null。
IndexOutOfBoundsException - 如果索引不在 (index < 0 || index > size()) 范围内。

set

public void set(int index,
                RoleUnresolved role)
         throws IllegalArgumentException,
                IndexOutOfBoundsException
将指定位置处的元素设置为指定的未解析角色。丢弃该位置以前的元素。

参数：
index - - 指定的位置。
role - - 应该将未解析角色元素设置成的值。
抛出：
IllegalArgumentException - 如果未解析角色为 null。
IndexOutOfBoundsException - 如果索引不在 (index < 0 || index > size()) 范围内。

addAll

public boolean addAll(RoleUnresolvedList roleList)
               throws IndexOutOfBoundsException
将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。

参数：
roleList - 要插入到列表中的元素（可以为 null）。
返回：
如果此列表由于调用而更改，则返回 true。
抛出：
IndexOutOfBoundsException - 如果用列表外面的索引访问。

addAll

public boolean addAll(int index,
                      RoleUnresolvedList roleList)
               throws IllegalArgumentException,
                      IndexOutOfBoundsException
从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。

参数：
index - 插入指定 RoleUnresolvedList 中第一个元素的位置。
roleList - 要插入该列表的元素。
返回：
如果此列表由于调用而更改，则返回 true。
抛出：
IllegalArgumentException - 如果角色为 null。
IndexOutOfBoundsException - 如果索引不在 (index < 0 || index > size()) 范围内。

add

public boolean add(Object o)
从类 ArrayList 复制的描述
将指定的元素添加到此列表的尾部。

指定者：
接口 Collection<Object> 中的 add
指定者：
接口 List<Object> 中的 add
覆盖：
类 ArrayList<Object> 中的 add
参数：
o - 要添加到此列表中的元素
返回：
true（按照 Collection.add(E) 的指定）

add

public void add(int index,
                Object element)
从类 ArrayList 复制的描述
将指定的元素插入此列表中的指定位置。向右移动当前位于该位置的元素（如果有）以及所有后续元素（将其索引加 1）。

指定者：
接口 List<Object> 中的 add
覆盖：
类 ArrayList<Object> 中的 add
参数：
index - 指定元素所插入位置的索引
element - 要插入的元素

addAll

public boolean addAll(Collection<?> c)
从类 ArrayList 复制的描述
按照指定 collection 的迭代器所返回的元素顺序，将该 collection 中的所有元素添加到此列表的尾部。如果正在进行此操作时修改指定的 collection ，那么此操作的行为是不确定的。（这意味着如果指定的 collection 是此列表且此列表是非空的，那么此调用的行为是不确定的）。

指定者：
接口 Collection<Object> 中的 addAll
指定者：
接口 List<Object> 中的 addAll
覆盖：
类 ArrayList<Object> 中的 addAll
参数：
c - 包含要添加到此列表中的元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true
另请参见：
AbstractCollection.add(Object)

addAll

public boolean addAll(int index,
                      Collection<?> c)
从类 ArrayList 复制的描述
从指定的位置开始，将指定 collection 中的所有元素插入到此列表中。向右移动当前位于该位置的元素（如果有）以及所有后续元素（增加其索引）。新元素将按照指定 collection 的迭代器所返回的元素顺序出现在列表中。

指定者：
接口 List<Object> 中的 addAll
覆盖：
类 ArrayList<Object> 中的 addAll
参数：
index - 插入指定 collection 中的首个元素的位置索引
c - 包含要添加到此列表中元素的 collection
返回：
如果此列表由于调用而发生更改，则返回 true

set

public Object set(int index,
                  Object element)
从类 ArrayList 复制的描述
用指定的元素替代此列表中指定位置上的元素。

指定者：
接口 List<Object> 中的 set
覆盖：
类 ArrayList<Object> 中的 set
参数：
index - 要替代的元素的索引
element - 存储在指定位置上的元素
返回：
以前位于该指定位置上的元素
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.relation (Java 2 Platform SE 6)

 javax.management.relation
接口
Relation
RelationServiceMBean
RelationSupportMBean
RelationType
类
MBeanServerNotificationFilter
RelationNotification
RelationService
RelationSupport
RelationTypeSupport
Role
RoleInfo
RoleList
RoleResult
RoleStatus
RoleUnresolved
RoleUnresolvedList
异常
InvalidRelationIdException
InvalidRelationServiceException
InvalidRelationTypeException
InvalidRoleInfoException
InvalidRoleValueException
RelationException
RelationNotFoundException
RelationServiceNotRegisteredException
RelationTypeNotFoundException
RoleInfoNotFoundException
RoleNotFoundException


javax.management.relation (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.relation

提供 Relation Service 的定义。

请参见：
描述

接口摘要
Relation | 此接口必须由任何 MBean 类（期望表示为一种使用 Relation Service 管理的关系）来实现。
RelationServiceMBean | Relation Service 负责创建和删除关系类型和关系，还负责处理一致性和提供查询机制。
RelationSupportMBean | RelationSupport 对象由 Relation Service 内部使用，表示任何关系类型的具有无限量角色的简单关系（只有角色，没有属性或方法）。
RelationType | 该 RelationType 接口必须由期望表示关系类型的任何类来实现。

类摘要
MBeanServerNotificationFilter | MBeanServerNotification 的过滤器。
RelationNotification | Relation Service（关系服务）中的更改通知。
RelationService | Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。
RelationSupport | RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。
RelationTypeSupport | RelationTypeSupport 对象实现 RelationType 接口。
Role | 表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。
RoleInfo | RoleInfo 概括介绍关系类型中的角色。
RoleList | RoleList 表示角色（Role 对象）的列表。
RoleResult | 表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。
RoleStatus | 此类描述访问某个角色时可能遇到的各种问题。
RoleUnresolved | 表示未解析的角色：由于存在问题而无法从关系中检索到的角色。
RoleUnresolvedList | RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

异常摘要
InvalidRelationIdException | 为关系提供的关系 id 已使用时引发此异常。
InvalidRelationServiceException | 提供无效 Relation Service（关系服务）时引发此异常。
InvalidRelationTypeException | 无效的关系类型。
InvalidRoleInfoException | 在角色信息中，其最小程度大于其最大程度时，引发此异常。
InvalidRoleValueException | 角色值无效。
RelationException | 此类是关系管理过程中引发的任何异常的超类。
RelationNotFoundException | Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
RelationServiceNotRegisteredException | 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
RelationTypeNotFoundException | Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
RoleInfoNotFoundException | 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
RoleNotFoundException | 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

软件包 javax.management.relation 的描述

提供 Relation Service 的定义。Relation Service 用于记录 MBean Server 中各个 MBean 之间的关系。Relation Service 本身就是一个 MBean。在一个 MBean Server 中可以注册多个 RelationService MBean 实例。

关系类型 定义各个 MBean 之间的关系。它包含各个 MBean 在关系中充当的角色。通常，在一个关系类型中至少有两个角色。

关系 是关系类型的命名实例，其中具体的 MBean 将出现在由其 ObjectName 表示的角色中。

例如，假定存在表示应用程序中的模块的 Module MBean。DependsOn 关系类型可以表达一些模块依赖于其他模块（这些模块可以用于定义模块开始和停止的顺序）的关系。DependsOn 关系类型应有两个角色，dependent 和 dependedOn。

每个角色都经过了类型化，这意味着在该角色中出现的 MBean 必须是该角色类型的实例。在 DependsOn 示例中，两个角色都属于类型 Module。

每个角色都有一个容量，它为给定关系实例的角色中出现的 MBean 的数量提供上下边界。通常，上下边界都是 1，这样可保证在此角色中只出现一个 MBean。该容量只限制每个关系实例的角色中的 MBean 的数量。同一个 MBean 可以在任意数量的关系类型实例中的同一个角色中出现。在 DependsOn 示例中，给定模块可能依赖于许多其他模块，也可以被许多其他模块所依赖，但是任何给定关系实例都只能将一个 dependent 模块与唯一对应的那个 dependedOn 模块连接。

关系类型可以作为实现 RelationType 接口的对象显式地创建，此对象通常为 RelationTypeSupport。或者，它可以使用 Relation Service 的 createRelationType 方法隐式地创建。

关系类型可以作为实现 Relation 接口的对象显式地创建，此对象通常是为 RelationSupport。（RelationSupport 本身是一个有效的 MBean，因此它可以在 MBean Server 中注册，但不要求这样做。）或者，关系类型可以使用 Relation Service 的 createRelation 方法隐式地创建。

DependsOn 示例可以按以下方式进行编码。

import java.util.*;
import javax.management.*;
import javax.management.relation.*;

// ...
MBeanServer mbs = ...;

// Create the Relation Service MBean
ObjectName relSvcName = new ObjectName(":type=RelationService");
RelationService relSvcObject = new RelationService(true);
mbs.registerMBean(relSvcObject, relSvcName);

// Create an MBean proxy for easier access to the Relation Service
RelationServiceMBean relSvc =
    MBeanServerInvocationHandler.newProxyInstance(mbs, relSvcName,
                                                  RelationServiceMBean.class,
                                                  false);

// Define the DependsOn relation type
RoleInfo[] dependsOnRoles = {
    new RoleInfo("dependent", Module.class.getName()),
    new RoleInfo("dependedOn", Module.class.getName())
};
relSvc.createRelationType("DependsOn", dependsOnRoles);

// Now define a relation instance "moduleA DependsOn moduleB"

ObjectName moduleA = new ObjectName(":type=Module,name=A");
ObjectName moduleB = new ObjectName(":type=Module,name=B");

Role dependent = new Role("dependent", Collections.singletonList(moduleA));
Role dependedOn = new Role("dependedOn", Collections.singletonList(moduleB));
Role[] roleArray = {dependent, dependedOn};
RoleList roles = new RoleList(Arrays.asList(roleArray));
relSvc.createRelation("A-DependsOn-B", "DependsOn", roles);

// Query the Relation Service to find what modules moduleA depends on
Map<ObjectName,List<String>> dependentAMap =
    relSvc.findAssociatedMBeans(moduleA, "DependsOn", "dependent");
Set<ObjectName> dependentASet = dependentAMap.keySet();
// Set of ObjectName containing moduleB

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology， 特别是 JMX Specification, version 1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.relation 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.relation 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractList<E> (implements java.util.List<E>)
        • java.util.ArrayList<E> (implements java.lang.Cloneable, java.util.List<E>, java.util.RandomAccess, java.io.Serializable)
          • javax.management.relation.RoleList
          • javax.management.relation.RoleUnresolvedList
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.relation.RelationNotification
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.relation.RelationService (implements javax.management.MBeanRegistration, javax.management.NotificationListener, javax.management.relation.RelationServiceMBean)
    • javax.management.NotificationFilterSupport (implements javax.management.NotificationFilter)
      • javax.management.relation.MBeanServerNotificationFilter
    • javax.management.relation.RelationSupport (implements javax.management.MBeanRegistration, javax.management.relation.RelationSupportMBean)
    • javax.management.relation.RelationTypeSupport (implements javax.management.relation.RelationType)
    • javax.management.relation.Role (implements java.io.Serializable)
    • javax.management.relation.RoleInfo (implements java.io.Serializable)
    • javax.management.relation.RoleResult (implements java.io.Serializable)
    • javax.management.relation.RoleStatus
    • javax.management.relation.RoleUnresolved (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.relation.RelationException
            • javax.management.relation.InvalidRelationIdException
            • javax.management.relation.InvalidRelationServiceException
            • javax.management.relation.InvalidRelationTypeException
            • javax.management.relation.InvalidRoleInfoException
            • javax.management.relation.InvalidRoleValueException
            • javax.management.relation.RelationNotFoundException
            • javax.management.relation.RelationServiceNotRegisteredException
            • javax.management.relation.RelationTypeNotFoundException
            • javax.management.relation.RoleInfoNotFoundException
            • javax.management.relation.RoleNotFoundException

接口分层结构

  • javax.management.relation.Relation
    • javax.management.relation.RelationSupportMBean
  • javax.management.relation.RelationServiceMBean
  • java.io.Serializable
    • javax.management.relation.RelationType
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.relation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.relation
的使用

使用 javax.management.relation 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 使用的 javax.management.relation 中的类
InvalidRelationIdException
为关系提供的关系 id 已使用时引发此异常。
InvalidRelationServiceException
提供无效 Relation Service（关系服务）时引发此异常。
InvalidRelationTypeException
无效的关系类型。
InvalidRoleInfoException
在角色信息中，其最小程度大于其最大程度时，引发此异常。
InvalidRoleValueException
角色值无效。
Relation
此接口必须由任何 MBean 类（期望表示为一种使用 Relation Service 管理的关系）来实现。
RelationException
此类是关系管理过程中引发的任何异常的超类。
RelationNotFoundException
Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
RelationServiceMBean
Relation Service 负责创建和删除关系类型和关系，还负责处理一致性和提供查询机制。
RelationServiceNotRegisteredException
在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
RelationSupportMBean
RelationSupport 对象由 Relation Service 内部使用，表示任何关系类型的具有无限量角色的简单关系（只有角色，没有属性或方法）。
RelationType
该 RelationType 接口必须由期望表示关系类型的任何类来实现。
RelationTypeNotFoundException
Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
Role
表示角色：包括角色名称和引用的 MBean（通过其 ObjectName）。
RoleInfo
RoleInfo 概括介绍关系类型中的角色。
RoleInfoNotFoundException
给定的关系类型中不存在带指定名称的角色信息时引发此异常。
RoleList
RoleList 表示角色（Role 对象）的列表。
RoleNotFoundException
关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。
RoleResult
表示对一个关系的几个角色多个访问的结果（可以是读取，也可以是写入）。
RoleUnresolved
表示未解析的角色：由于存在问题而无法从关系中检索到的角色。
RoleUnresolvedList
RoleUnresolvedList 表示 RoleUnresolved 对象的列表，这些对象代表在试图访问角色（进行读取或写入）时遇到问题而无法从关系检索到的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.InvalidRelationIdException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRelationIdException
的使用

使用 InvalidRelationIdException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRelationIdException 的使用

抛出 InvalidRelationIdException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.InvalidRelationServiceException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRelationServiceException
的使用

使用 InvalidRelationServiceException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRelationServiceException 的使用

抛出 InvalidRelationServiceException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.InvalidRelationTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRelationTypeException
的使用

使用 InvalidRelationTypeException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRelationTypeException 的使用

抛出 InvalidRelationTypeException 的 javax.management.relation 中的方法
void | RelationService.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
void | RelationServiceMBean.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
protected void | RelationTypeSupport.addRoleInfo(RoleInfo roleInfo) 添加角色信息。
void | RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

抛出 InvalidRelationTypeException 的 javax.management.relation 中的构造方法
RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.InvalidRoleInfoException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRoleInfoException
的使用

使用 InvalidRoleInfoException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRoleInfoException 的使用

抛出 InvalidRoleInfoException 的 javax.management.relation 中的构造方法
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.InvalidRoleValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.InvalidRoleValueException
的使用

使用 InvalidRoleValueException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 InvalidRoleValueException 的使用

抛出 InvalidRoleValueException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。

抛出 InvalidRoleValueException 的 javax.management.relation 中的构造方法
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.MBeanServerNotificationFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.MBeanServerNotificationFilter
的使用

没有 javax.management.relation.MBeanServerNotificationFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.relation.Relation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.Relation
的使用

使用 Relation 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 Relation 的使用

javax.management.relation 中 Relation 的子接口
 interface RelationSupportMBean
RelationSupport 对象由 Relation Service 内部使用，表示任何关系类型的具有无限量角色的简单关系（只有角色，没有属性或方法）。

实现 Relation 的 javax.management.relation 中的类
 class RelationSupport
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationException
的使用

使用 RelationException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationException 的使用

javax.management.relation 中 RelationException 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationNotFoundException
的使用

使用 RelationNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationNotFoundException 的使用

抛出 RelationNotFoundException 的 javax.management.relation 中的方法
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
String | RelationService.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
String | RelationServiceMBean.getRelationTypeName(String relationId) 返回给定关系的相关关系类型的名称。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
ObjectName | RelationService.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationServiceMBean.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
void | RelationService.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationServiceMBean.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationService.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationCreationNotification(String relationId) 发送关系创建通知 (RelationNotification)。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationNotification
的使用

没有 javax.management.relation.RelationNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationService
的使用

没有 javax.management.relation.RelationService 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.relation.RelationServiceMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.RelationServiceMBean
的使用

使用 RelationServiceMBean 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationServiceMBean 的使用

实现 RelationServiceMBean 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationSupport
的使用

没有 javax.management.relation.RelationSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationServiceNotRegisteredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationServiceNotRegisteredException
的使用

使用 RelationServiceNotRegisteredException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationServiceNotRegisteredException 的使用

抛出 RelationServiceNotRegisteredException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
RoleResult | Relation.getAllRoles() 返回该关系中存在的所有角色。
RoleResult | RelationSupport.getAllRoles() 返回关系中存在的所有角色。
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
RoleResult | Relation.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationSupport.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationService.isActive() 检查该 Relation Service 是否处于活动状态。
void | RelationServiceMBean.isActive() 检查该 Relation Service 是否处于活动状态。
void | RelationService.purgeRelations() 肃清关系。
void | RelationServiceMBean.purgeRelations() 肃清关系。
void | RelationService.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationServiceMBean.removeRelation(String relationId) 从 Relation Service 移除给定的关系。
void | RelationService.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | RelationServiceMBean.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.relation.RelationSupportMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.RelationSupportMBean
的使用

使用 RelationSupportMBean 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationSupportMBean 的使用

实现 RelationSupportMBean 的 javax.management.relation 中的类
 class RelationSupport
RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.relation.RelationType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.relation.RelationType
的使用

使用 RelationType 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationType 的使用

实现 RelationType 的 javax.management.relation 中的类
 class RelationTypeSupport
RelationTypeSupport 对象实现 RelationType 接口。

参数类型为 RelationType 的 javax.management.relation 中的方法
void | RelationService.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。
void | RelationServiceMBean.addRelationType(RelationType relationTypeObj) 作为关系类型添加给定的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationTypeNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationTypeNotFoundException
的使用

使用 RelationTypeNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RelationTypeNotFoundException 的使用

抛出 RelationTypeNotFoundException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
Integer | RelationService.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否以给定类型的关系进行读取。
Integer | RelationServiceMBean.checkRoleReading(String roleName, String relationTypeName) 检查给定 Role 能否在给定类型的关系中读取。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
List<String> | RelationService.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
List<String> | RelationServiceMBean.findRelationsOfType(String relationTypeName) 返回给定类型的关系的关系 id。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationService.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | RelationServiceMBean.removeRelationType(String relationTypeName) 从 Relation Service 中移除给定的关系类型。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RelationTypeSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RelationTypeSupport
的使用

没有 javax.management.relation.RelationTypeSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.Role 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.Role
的使用

使用 Role 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 Role 的使用

返回变量类型为 Role 的类型的 javax.management.relation 中的方法
 List<Role> RoleList.asList()
以 List<Role> 的形式返回此列表的示图。

参数类型为 Role 的 javax.management.relation 中的方法
void | RoleList.add(int index, Role role) 插入指定为指定位置处的元素的角色。
void | RoleList.add(Role role) 添加指定为列表中最后一个元素的 Role。
Integer | RelationService.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否以给定类型的关系进行设置。
Integer | RelationServiceMBean.checkRoleWriting(Role role, String relationTypeName, Boolean initFlag) 检查给定 Role 能否在给定类型的关系中设置。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RoleList.set(int index, Role role) 将指定位置处的元素设置为指定角色。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

类型变量类型为 Role 的 javax.management.relation 中的构造方法参数
RoleList(List<Role> list)
构造一个包含指定 List 元素的 RoleList，这些元素按 List 迭代器返回的顺序排列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleInfo
的使用

使用 RoleInfo 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleInfo 的使用

返回 RoleInfo 的 javax.management.relation 中的方法
RoleInfo | RelationType.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
RoleInfo | RelationTypeSupport.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。

返回变量类型为 RoleInfo 的类型的 javax.management.relation 中的方法
List<RoleInfo> | RelationType.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationTypeSupport.getRoleInfos() 返回角色定义的列表（RoleInfo 对象的 ArrayList）。
List<RoleInfo> | RelationService.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。
List<RoleInfo> | RelationServiceMBean.getRoleInfos(String relationTypeName) 检索给定关系类型的角色信息（RoleInfo 对象）的列表。

参数类型为 RoleInfo 的 javax.management.relation 中的方法
protected void | RelationTypeSupport.addRoleInfo(RoleInfo roleInfo) 添加角色信息。
void | RelationService.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelationType(String relationTypeName, RoleInfo[] roleInfoArray) 用给定的角色信息（由 RoleInfo 对象提供）创建一个关系类型（RelationTypeSupport 对象），并将其添加到 Relation Service 中。

参数类型为 RoleInfo 的 javax.management.relation 中的构造方法
RelationTypeSupport(String relationTypeName, RoleInfo[] roleInfoArray)
所有角色定义在其中动态创建并作为参数传递的构造方法。
RoleInfo(RoleInfo roleInfo)
复制构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleInfoNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleInfoNotFoundException
的使用

使用 RoleInfoNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleInfoNotFoundException 的使用

抛出 RoleInfoNotFoundException 的 javax.management.relation 中的方法
RoleInfo | RelationType.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到给定角色信息名称，则返回 null）。
RoleInfo | RelationTypeSupport.getRoleInfo(String roleInfoName) 返回给定角色信息名称的角色信息（RoleInfo 对象）（如果找不到，则返回 null）。
RoleInfo | RelationService.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色名称的角色信息。
RoleInfo | RelationServiceMBean.getRoleInfo(String relationTypeName, String roleInfoName) 检索给定关系类型的给定角色的角色信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleList
的使用

使用 RoleList 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleList 的使用

返回 RoleList 的 javax.management.relation 中的方法
RoleList | RoleResult.getRoles() 检索成功访问的角色列表。
RoleList | Relation.retrieveAllRoles() 返回关系中的所有角色，不检查读取模式。
RoleList | RelationSupport.retrieveAllRoles() 返回关系中的所有角色，不检查读取模式。

参数类型为 RoleList 的 javax.management.relation 中的方法
boolean | RoleList.addAll(int index, RoleList roleList) 从指定位置开始，将指定 RoleList 中的所有元素插入此列表，这些元素按指定 RoleList 的迭代器返回的顺序排列。
boolean | RoleList.addAll(RoleList roleList) 将指定 RoleList 中的所有元素追加到列表末尾，这些元素按指定 RoleList 的迭代器返回的顺序排列。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
void | RoleResult.setRoles(RoleList list) 设置成功访问的角色列表。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。

参数类型为 RoleList 的 javax.management.relation 中的构造方法
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleNotFoundException
的使用

使用 RoleNotFoundException 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleNotFoundException 的使用

抛出 RoleNotFoundException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationService.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
void | RelationServiceMBean.createRelation(String relationId, String relationTypeName, RoleList roleList) 创建给定关系类型的简单关系（由 RelationSupport 对象表示），并将其添加到 Relation Service 中。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
Integer | Relation.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationSupport.getRoleCardinality(String roleName) 返回当前在给定角色中引用的 MBean 数。
Integer | RelationService.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
Integer | RelationServiceMBean.getRoleCardinality(String relationId, String roleName) 检索给定角色中当前引用的 MBean 数。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | Relation.setRole(Role role) 设置给定角色。
void | RelationSupport.setRole(Role role) 设置给定的角色。
void | RelationService.setRole(String relationId, Role role) 设置给定关系中的给定角色。
void | RelationServiceMBean.setRole(String relationId, Role role) 以给定关系设置给定角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleResult
的使用

使用 RoleResult 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleResult 的使用

返回 RoleResult 的 javax.management.relation 中的方法
RoleResult | Relation.getAllRoles() 返回该关系中存在的所有角色。
RoleResult | RelationSupport.getAllRoles() 返回关系中存在的所有角色。
RoleResult | RelationService.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | RelationServiceMBean.getAllRoles(String relationId) 返回关系中存在的所有角色。
RoleResult | Relation.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationSupport.getRoles(String[] roleNameArray) 检索具有给定名称的角色值。
RoleResult | RelationService.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | RelationServiceMBean.getRoles(String relationId, String[] roleNameArray) 检索给定关系中具有给定名称的角色值。
RoleResult | Relation.setRoles(RoleList roleList) 设置给定的角色。
RoleResult | RelationSupport.setRoles(RoleList list) 设置给定的角色。
RoleResult | RelationService.setRoles(String relationId, RoleList roleList) 设置给定关系中的给定角色。
RoleResult | RelationServiceMBean.setRoles(String relationId, RoleList roleList) 以给定关系设置给定角色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleStatus
的使用

没有 javax.management.relation.RoleStatus 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleUnresolved 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleUnresolved
的使用

使用 RoleUnresolved 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleUnresolved 的使用

返回变量类型为 RoleUnresolved 的类型的 javax.management.relation 中的方法
 List<RoleUnresolved> RoleUnresolvedList.asList()
以 List<RoleUnresolved> 的形式返回此列表的视图。

参数类型为 RoleUnresolved 的 javax.management.relation 中的方法
void | RoleUnresolvedList.add(int index, RoleUnresolved role) 在指定位置处插入指定为元素的未解析角色。
void | RoleUnresolvedList.add(RoleUnresolved role) 添加指定为列表中最后一个元素的 RoleUnresolved。
void | RoleUnresolvedList.set(int index, RoleUnresolved role) 将指定位置处的元素设置为指定的未解析角色。

类型变量类型为 RoleUnresolved 的 javax.management.relation 中的构造方法参数
RoleUnresolvedList(List<RoleUnresolved> list)
构造一个包含指定 List 元素的 RoleUnresolvedList，这些元素按 List 迭代器返回的顺序排列。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.relation.RoleUnresolvedList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.relation.RoleUnresolvedList
的使用

使用 RoleUnresolvedList 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 RoleUnresolvedList 的使用

返回 RoleUnresolvedList 的 javax.management.relation 中的方法
 RoleUnresolvedList RoleResult.getRolesUnresolved()
检索未成功访问的角色列表。

参数类型为 RoleUnresolvedList 的 javax.management.relation 中的方法
boolean | RoleUnresolvedList.addAll(int index, RoleUnresolvedList roleList) 从指定位置开始，将指定 RoleUnresolvedList 中的所有元素插入此列表，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
boolean | RoleUnresolvedList.addAll(RoleUnresolvedList roleList) 将指定 RoleUnresolvedList 中的所有元素追加到列表末尾，这些元素按指定 RoleUnresolvedList 的迭代器返回的顺序排列。
void | RoleResult.setRolesUnresolved(RoleUnresolvedList unresolvedList) 设置未成功访问的角色列表。

参数类型为 RoleUnresolvedList 的 javax.management.relation 中的构造方法
RoleResult(RoleList list, RoleUnresolvedList unresolvedList)
构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ArrayType (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 ArrayType<T>

java.lang.Object
    继承者  javax.management.openmbean.OpenType<T>
        继承者  javax.management.openmbean.ArrayType<T>
所有已实现的接口：
Serializable
public class ArrayType<T>
extends OpenType<T>

ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。

有效 ArrayType 实例的示例有：

 // 2-dimension array of java.lang.String
 ArrayType a1 = new ArrayType(2, SimpleType.STRING);

 // 1-dimension array of int
 ArrayType a2 = new ArrayType(SimpleType.INTEGER, true);

 // 1-dimension array of java.lang.Integer
 ArrayType a3 = new ArrayType(SimpleType.INTEGER, false);

 // 4-dimension array of int
 ArrayType a4 = new ArrayType(3, a2);

 // 4-dimension array of java.lang.Integer
 ArrayType a5 = new ArrayType(3, a3);

 // 1-dimension array of java.lang.String
 ArrayType a6 = new ArrayType(SimpleType.STRING, false);

 // 1-dimension array of long
 ArrayType a7 = new ArrayType(SimpleType.LONG, true);

 // 1-dimension array of java.lang.Integer
 ArrayType a8 = ArrayType.getArrayType(SimpleType.INTEGER);

 // 2-dimension array of java.lang.Integer
 ArrayType a9 = ArrayType.getArrayType(a8);

 // 2-dimension array of int
 ArrayType a10 = ArrayType.getPrimitiveArrayType(int[][].class);

 // 3-dimension array of int
 ArrayType a11 = ArrayType.getArrayType(a10);

 // 1-dimension array of float
 ArrayType a12 = ArrayType.getPrimitiveArrayType(float[].class);

 // 2-dimension array of float
 ArrayType a13 = ArrayType.getArrayType(a12);

 // 1-dimension array of javax.management.ObjectName
 ArrayType a14 = ArrayType.getArrayType(SimpleType.OBJECTNAME);

 // 2-dimension array of javax.management.ObjectName
 ArrayType a15 = ArrayType.getArrayType(a14);

 // 3-dimension array of java.lang.String
 ArrayType a16 = new ArrayType(3, SimpleType.STRING);

 // 1-dimension array of java.lang.String
 ArrayType a17 = new ArrayType(1, SimpleType.STRING);

 // 2-dimension array of java.lang.String
 ArrayType a18 = new ArrayType(1, a17);

 // 3-dimension array of java.lang.String
 ArrayType a19 = new ArrayType(1, a18);

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.openmbean.OpenType 继承的字段
ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST
构造方法摘要
ArrayType(int dimension, OpenType<?> elementType)
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。
ArrayType(SimpleType<?> elementType, boolean primitiveArray)
为提供的 SimpleType 构造一个一维 ArrayType 实例。
方法摘要
 boolean equals(Object obj)
比较指定的 obj 参数与此 ArrayType 实例的相等性。
static
<E> ArrayType<E[]>
getArrayType(OpenType<E> elementType)
以类型安全的方式创建一个 ArrayType 实例。
 int getDimension()
返回此 ArrayType 实例描述的数组的维度。
 OpenType<?> getElementOpenType()
返回此 ArrayType 实例描述的数组中包含的元素值的开放类型。
static
<T> ArrayType<T>
getPrimitiveArrayType(Class<T> arrayClass)
以类型安全的方式创建一个 ArrayType 实例。
 int hashCode()
返回此 ArrayType 实例的哈希码值。
 boolean isPrimitiveArray()
如果此开放类型描述的开放数据值是基本类型数组，则返回 true；否则返回 false。
 boolean isValue(Object obj)
测试 obj 是否为此 ArrayType 实例的值。
 String toString()
返回此 ArrayType 实例的字符串表示形式。
从类 javax.management.openmbean.OpenType 继承的方法
getClassName, getDescription, getTypeName, isArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ArrayType

public ArrayType(int dimension,
                 OpenType<?> elementType)
          throws OpenDataException
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。

在 ArrayType 实例上调用时，getClassName 方法会返回它所描述的数组实例的类名（按照 java.lang.Class 的 getName 方法定义的规则），而不是数组元素的类名（由对 getElementOpenType().getClassName() 的调用返回）。

还可以将对应于此 ArrayType 实例类型名称的内部字段设置为它描述的数组实例的类名。换句话说，方法 getClassName 和 getTypeName 返回相同的字符串值。将对应于此 ArrayType 实例的描述的内部字段设置为符合以下模板的字符串值：

  • 如果是非基本类型数组：<dimension>-dimension array of <element_class_name>
  • 如果是基本类型数组：<dimension>-dimension array of <primitive_type_of_the_element_class_name>

例如，以下代码片段：

 ArrayType t = new ArrayType(3, SimpleType.STRING);
 System.out.println("array class name       = "+ t.getClassName());
 System.out.println("element class name     = "+ t.getElementOpenType().getClassName());
 System.out.println("array type name        = "+ t.getTypeName());
 System.out.println("array type description = "+ t.getDescription());
将得到以下输出：
 array class name       = [[[Ljava.lang.String;
 element class name     = java.lang.String
 array type name        = [[[Ljava.lang.String;
 array type description = 3-dimension array of java.lang.String
以下代码片段（与上述代码片段等效）也能得到相同的输出：
 ArrayType t1 = new ArrayType(1, SimpleType.STRING);
 ArrayType t2 = new ArrayType(1, t1);
 ArrayType t3 = new ArrayType(1, t2);
 System.out.println("array class name       = " + t3.getClassName());
 System.out.println("element class name     = " + t3.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t3.getTypeName());
 System.out.println("array type description = " + t3.getDescription());

参数：
dimension - 此 ArrayType 实例描述的数组的维度；必须大于或等于 1。
elementType - 此 ArrayType 实例描述的数组中包含的元素值的开放类型；必须是 SimpleType、CompositeType、TabularType 的一个实例，或者另一个以 SimpleType、CompositeType 或 TabularType 作为其 elementType 的 ArrayType。
抛出：
IllegalArgumentException - 如果 dimension 不是一个正整数。
OpenDataException - 如果 elementType 的 className 不是一个受允许的开放数据 Java 类名称。

ArrayType

public ArrayType(SimpleType<?> elementType,
                 boolean primitiveArray)
          throws OpenDataException
为提供的 SimpleType 构造一个一维 ArrayType 实例。

primitiveArray 为 true 时此构造方法支持创建基本类型数组。

对于基本类型数组，getElementOpenType() 方法返回对应于基本类型数组的包装器类型的 SimpleType。

在 ArrayType 实例上调用时，getClassName 方法会返回它描述的数组实例的类名（按照 java.lang.Class 的 getName 方法定义的规则），而不是数组元素的类名（由对 getElementOpenType().getClassName() 的调用返回）。

还可以将对应于此 ArrayType 实例类型名称的内部字段设置为它描述的数组实例的类名。换句话说，方法 getClassName 和 getTypeName 返回相同的字符串值。将对应于此 ArrayType 实例的描述的内部字段设置为符合以下模板的字符串值：

  • 如果是非基本类型数组：1-dimension array of <element_class_name>
  • 如果是基本类型数组：1-dimension array of <primitive_type_of_the_element_class_name>

例如，以下代码片段：

 ArrayType t = new ArrayType(SimpleType.INTEGER, true);
 System.out.println("array class name       = " + t.getClassName());
 System.out.println("element class name     = " + t.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t.getTypeName());
 System.out.println("array type description = " + t.getDescription());
将得到以下输出：
 array class name       = [I
 element class name     = java.lang.Integer
 array type name        = [I
 array type description = 1-dimension array of int

参数：
elementType - 此 ArrayType 实例描述的数组所包含的元素值的 SimpleType。
primitiveArray - 此数组描述基本类型数组时为 true。
抛出：
IllegalArgumentException - 如果 dimension 不是正整数。
OpenDataException - 如果 primitiveArray 为 true，且 elementType 不是有效的基本类型 SimpleType。
从以下版本开始：
1.6
方法详细信息

getDimension

public int getDimension()
返回此 ArrayType 实例描述的数组的维度。

返回：
维度。

getElementOpenType

public OpenType<?> getElementOpenType()
返回此 ArrayType 实例描述的数组中包含的元素值的开放类型。

返回：
元素类型。

isPrimitiveArray

public boolean isPrimitiveArray()
如果此开放类型描述的开放数据值是基本类型数组，则返回 true；否则返回 false。

返回：
如果此为基本类型数组，则返回 true。
从以下版本开始：
1.6

isValue

public boolean isValue(Object obj)
测试 obj 是否为此 ArrayType 实例的值。

当且仅当 obj 不为 null，obj 是一个数组，并且下面任何一个条件为 true 时，此方法才返回 true：

  • 如果此 ArrayType 实例描述 SimpleType 元素或其对应基本类型的数组，则 obj 的类名与此 ArrayType 实例定义的 className 字段相同（即 getClassName 方法返回的类名，它包括维度信息）
  • 如果此 ArrayType 实例描述实现 TabularData 接口或 CompositeData 接口的类的数组，则 obj 可分配给这样的声明数组，obj 中包含的每个元素或者为 null，或者为此 ArrayType 实例指定元素的开放类型的有效值。

指定者：
类 OpenType<T> 中的 isValue
参数：
obj - 要测试的对象。
返回：
如果 obj 是此 ArrayType 实例的一个值，则返回 true。

equals

public boolean equals(Object obj)
比较指定的 obj 参数与此 ArrayType 实例的相等性。

当且仅当两个 ArrayType 实例描述具有相同维度、元素的开放类型以及基本类型数组标记的数组实例时，它们才相等。

指定者：
类 OpenType<T> 中的 equals
参数：
obj - 与此 ArrayType 实例比较相等性的对象；如果 obj 为 null，或者不是类 ArrayType 的一个实例，则此方法返回 false。
返回：
如果指定的对象等于此 ArrayType 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 ArrayType 实例的哈希码值。

ArrayType 实例的哈希码是在 equals 比较中使用的信息的所有元素的哈希码总和（即维度、元素的开放类型和基本类型数组标记）。基本类型值的哈希码是其对应装箱对象的哈希码（例如，true 的哈希码为 Boolean.TRUE.hashCode()）。这确保 t1.equals(t2) 意味着对于任何两个 ArrayType 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

由于 ArrayType 实例是不可变的，此实例的哈希码在首次调用 hashCode 时计算一次，然后对于后续的调用返回相同的值。

指定者：
类 OpenType<T> 中的 hashCode
返回：
此 ArrayType 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 ArrayType 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.ArrayType）的名称，以及为此实例定义的类型名称、维度、元素的开放类型和基本类型数组标记组成。

由于 ArrayType 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时计算一次，然后对于后续的调用返回相同的值。

指定者：
类 OpenType<T> 中的 toString
返回：
此 ArrayType 实例的字符串表示形式

getArrayType

public static <E> ArrayType<E[]> getArrayType(OpenType<E> elementType)
                                   throws OpenDataException
以类型安全的方式创建一个 ArrayType 实例。

根据需要多次调用此方法可以创建多维数组。

使用相同的参数调用此方法两次可以返回相同的对象，或者相等但不同的两个对象。

例如，以下代码片段：

 ArrayType t1 = ArrayType.getArrayType(SimpleType.STRING);
 ArrayType t2 = ArrayType.getArrayType(t1);
 ArrayType t3 = ArrayType.getArrayType(t2);
 System.out.println("array class name       = " + t3.getClassName());
 System.out.println("element class name     = " + t3.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t3.getTypeName());
 System.out.println("array type description = " + t3.getDescription());
将得到以下输出：
 array class name       = [[[Ljava.lang.String;
 element class name     = java.lang.String
 array type name        = [[[Ljava.lang.String;
 array type description = 3-dimension array of java.lang.String

参数：
elementType - 此 ArrayType 实例描述的数组中包含的元素值的开放类型；必须是 SimpleType、CompositeType、TabularType 的一个实例，或者另一个以 SimpleType、CompositeType 或 TabularType 作为其 elementType 的 ArrayType。
抛出：
OpenDataException - 如果 elementType 的 className 不是一个受允许的开放数据 Java 类名称。
从以下版本开始：
1.6

getPrimitiveArrayType

public static <T> ArrayType<T> getPrimitiveArrayType(Class<T> arrayClass)
以类型安全的方式创建一个 ArrayType 实例。

使用相同的参数调用此方法两次可以返回相同的对象，或者相等但不同的两个对象。

例如，以下代码片段：

 ArrayType t = ArrayType.getPrimitiveArrayType(int[][][].class);
 System.out.println("array class name       = " + t.getClassName());
 System.out.println("element class name     = " + t.getElementOpenType().getClassName());
 System.out.println("array type name        = " + t.getTypeName());
 System.out.println("array type description = " + t.getDescription());
将得到以下输出：
 array class name       = [[[I
 element class name     = java.lang.Integer
 array type name        = [[[I
 array type description = 3-dimension array of int

参数：
arrayClass - 基本类型数组类，如 int[].class、boolean[][].class 等等。返回 ArrayType 的 getElementOpenType() 方法将返回对应于基本类型数组包装器类型的 SimpleType。
抛出：
IllegalArgumentException - 如果 arrayClass 不是基本类型数组。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CompositeData (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 CompositeData

所有已知实现类：
CompositeDataSupport
public interface CompositeData

CompositeData 接口指定表示复合数据 结构的复杂开放数据 对象的特定类型的行为。

从以下版本开始：
1.5

方法摘要
boolean | containsKey(String key) 当且仅当此 CompositeData 实例包含名称为 key 的项时，返回 true。
boolean | containsValue(Object value) 当且仅当此 CompositeData 实例包含值为 value 的项时，返回 true。
boolean | equals(Object obj) 比较指定 obj 参数与此 CompositeData 实例的相等性。
Object | get(String key) 返回名称为 key 的项的值。
Object[] | getAll(String[] keys) 返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。
CompositeType | getCompositeType() 返回此复合数据 实例的复合类型。
int | hashCode() 返回此 CompositeData 实例的哈希码值。
String | toString() 返回此 CompositeData 实例的字符串表示形式。
Collection<?> | values() 返回此 CompositeData 实例中所包含项值的不可修改的 Collection 视图。

方法详细信息

getCompositeType

CompositeType getCompositeType()
返回此复合数据 实例的复合类型。

返回：
此 CompositeData 的类型。

get

Object get(String key)
返回名称为 key 的项的值。

参数：
key - 项的名称。
返回：
与此键关联的值。
抛出：
IllegalArgumentException - 如果 key 为 null 或空字符串。
InvalidKeyException - 如果 key 不是此 CompositeData 实例的现有项的名称。

getAll

Object[] getAll(String[] keys)
返回通过 keys 指定其项名称的值组成的数组，值排列的顺序与 keys 相同。

参数：
key - 项的名称。
返回：
与键对应的值。
抛出：
IllegalArgumentException - 如果 keys 中的元素为 null 或空字符串。
InvalidKeyException - 如果 keys 中的元素不是此 CompositeData 实例的现有项的名称。

containsKey

boolean containsKey(String key)
当且仅当此 CompositeData 实例包含名称为 key 的项时，返回 true。如果 key 为 null 或空字符串，则此方法只返回 false。

参数：
key - 要测试的键。
返回：
如果此 CompositeData 包含该键，则返回 true。

containsValue

boolean containsValue(Object value)
当且仅当此 CompositeData 实例包含值为 value 的项时，返回 true。

参数：
value - 要测试的值。
返回：
如果此 CompositeData 包含该值，则返回 true。

values

Collection<?> values()
返回此 CompositeData 实例中所包含项值的不可修改的 Collection 视图。返回集合的迭代器将按相应项名称的升序字典顺序返回值。

返回：
值。

equals

boolean equals(Object obj)
比较指定 obj 参数与此 CompositeData 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null，
  • obj 还实现 CompositeData 接口
  • 它们的复合类型相等
  • 它们的内容（即（名称，值）对）相等。如果内容中包含的值是一个数组，则对于对象引用类型数组，值比较操作的执行方式类似于调用 deepEquals 方法；对于基本类型数组，则类似于调用恰当的 Arrays.equals(e1,e2) 重载形式。

这确保了此 equals 方法对 obj 参数正常工作，该参数是 CompositeData 接口的不同实现，具有 java.util.Collection 接口的 equals 方法中提到的约束限制。

覆盖：
类 Object 中的 equals
参数：
obj - 与此 CompositeData 实例进行相等性比较的对象。
返回：
如果指定的对象等于此 CompositeData 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 CompositeData 实例的哈希码值。

CompositeData 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即其复合类型 和所有项值）。

这确保了 t1.equals(t2) 意味着对于任何两个 CompositeData 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

每项值的哈希码将被添加到返回的哈希码中。如果项值是一个数组，则对于对象引用类型数组，其哈希码的获取方式类似于调用 deepHashCode 方法；对于基本类型数组，则类似于调用恰当的 Arrays.hashCode(e) 重载形式。

覆盖：
类 Object 中的 hashCode
返回：
此 CompositeData 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 CompositeData 实例的字符串表示形式。

字符串表示形式由实现类的名称、此实例的复合类型的字符串表示形式以及内容的字符串表示形式组成，即列出 itemName=itemValue 映射关系。

覆盖：
类 Object 中的 toString
返回：
此 CompositeData 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompositeDataInvocationHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 CompositeDataInvocationHandler

java.lang.Object
    继承者  javax.management.openmbean.CompositeDataInvocationHandler
所有已实现的接口：
InvocationHandler
public class CompositeDataInvocationHandler
extends Object
implements InvocationHandler

将获取方法转发给 CompositeData 的 InvocationHandler。如果有只包含获取方法（如 String getName() 或 boolean isActive()）的接口，则可以将此类与 Proxy 类一起使用，以产生一个接口实现，在该接口中，每个设置方法都返回 CompositeData 中对应项的值。

例如，假定您有如下所示接口：

public interface NamedNumber {
public int getNumber();
public String getName();
   }
以及使用以下方式构造的 CompositeData：
CompositeData cd =
new CompositeDataSupport(
someCompositeType,
new String[] {"number", "name"},
new Object[] {5, "five"}
       );
那么您可以构造一个实现 NamedNumber 且受对象 cd 支持的对象，如下所示：
InvocationHandler handler =
new CompositeDataInvocationHandler(cd);
NamedNumber nn = (NamedNumber)
Proxy.newProxyInstance(NamedNumber.class.getClassLoader(),
new Class[] {NamedNumber.class},
handler);
对 nn.getNumber() 的调用将返回 5。

如果设置方法定义的属性的第一个字母是大写字母，则此处理程序将首先在 CompositeData 中查找以大写字母开头的项，然后，如果找不到这样的项，则查找以相应的小写字母或代码点开头的项。对于名为 getNumber() 的获取方法，该处理程序将首先查找名为 Number 的项，然后查找名为 number 的项。如果设置方法名为 getnumber()，则查找项必须名为 number。

如果为 invoke 提供的方法是从 Object 继承的方法 boolean equals(Object)，则当且仅当参数是一个其 InvocationHandler 也是 CompositeDataInvocationHandler 且其后备 CompositeData 等于（不必相同）此对象的 CompositeData 的 Proxy 时，它将返回 true。如果为 invoke 提供的方法是从 Object 继承的方法 int hashCode()，那么它将返回一个与 equals 的定义一致的值：如果根据 equals 判断两个对象是相等的，则它们将具有相同的 hashCode。

从以下版本开始：
1.6

构造方法摘要
CompositeDataInvocationHandler(CompositeData compositeData)
构造一个受给定 CompositeData 支持的处理程序。
方法摘要
CompositeData | getCompositeData() 返回提供给构造方法的 CompositeData。
Object | invoke(Object proxy, Method method, Object[] args) 在代理实例上处理方法调用并返回结果。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CompositeDataInvocationHandler

public CompositeDataInvocationHandler(CompositeData compositeData)

构造一个受给定 CompositeData 支持的处理程序。

参数：
compositeData - 将为设置方法提供信息的 CompositeData。
抛出：
IllegalArgumentException - 如果 compositeData 为 null。
方法详细信息

getCompositeData

public CompositeData getCompositeData()
返回提供给构造方法的 CompositeData。

返回：
返回支持此处理程序的 CompositeData。返回值永远不可以为 null。

invoke

public Object invoke(Object proxy,
                     Method method,
                     Object[] args)
              throws Throwable
从接口 InvocationHandler 复制的描述
在代理实例上处理方法调用并返回结果。在与方法关联的代理实例上调用方法时，将在调用处理程序上调用此方法。

指定者：
接口 InvocationHandler 中的 invoke
参数：
proxy - 在其上调用方法的代理实例
method - 对应于在代理实例上调用的接口方法的 Method 实例。Method 对象的声明类将是在其中声明方法的接口，该接口可以是代理类赖以继承方法的代理接口的超接口。
args - 包含传入代理实例上方法调用的参数值的对象数组，如果接口方法不使用参数，则为 null。基本类型的参数被包装在适当基本包装器类（如 java.lang.Integer 或 java.lang.Boolean）的实例中。
返回：
从代理实例的方法调用返回的值。如果接口方法的声明返回类型是基本类型，则此方法返回的值一定是相应基本包装对象类的实例；否则，它一定是可分配到声明返回类型的类型。如果此方法返回的值为 null 并且接口方法的返回类型是基本类型，则代理实例上的方法调用将抛出 NullPointerException。否则，如果此方法返回的值与上述接口方法的声明返回类型不兼容，则代理实例上的方法调用将抛出 ClassCastException。
抛出：
Throwable - 从代理实例上的方法调用抛出的异常。该异常的类型必须可以分配到在接口方法的 throws 子句中声明的任一异常类型或未经检查的异常类型 java.lang.RuntimeException 或 java.lang.Error。如果此方法抛出经过检查的异常，该异常不可分配到在接口方法的 throws 子句中声明的任一异常类型，代理实例的方法调用将抛出包含此方法曾抛出的异常的 UndeclaredThrowableException。
另请参见：
UndeclaredThrowableException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompositeDataSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 CompositeDataSupport

java.lang.Object
    继承者  javax.management.openmbean.CompositeDataSupport
所有已实现的接口：
Serializable, CompositeData
public class CompositeDataSupport
extends Object
implements CompositeData, Serializable

CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。
CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。
方法摘要
boolean | containsKey(String key) 当且仅当此 CompositeData 实例包含名称是 key 的项时，才返回 true。
boolean | containsValue(Object value) 当且仅当此 CompositeData 实例包含其值是 value 的项时，返回 true。
boolean | equals(Object obj) 比较指定的 obj 参数与此 CompositeDataSupport 实例的相等性。
Object | get(String key) 返回其名称是 key 的项的值。
Object[] | getAll(String[] keys) 返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。
CompositeType | getCompositeType() 返回此复合数据 实例的复合类型。
int | hashCode() 返回此 CompositeDataSupport 实例的哈希码值。
String | toString() 返回此 CompositeDataSupport 实例的字符串表示形式。
Collection<?> | values() 返回此 CompositeData 实例中包含的项值的不可修改的 Collection 视图。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CompositeDataSupport

public CompositeDataSupport(CompositeType compositeType,
                            String[] itemNames,
                            Object[] itemValues)
                     throws OpenDataException

使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。由于 CompositeType 未对其项指定任何顺序，所以使用 itemNames[] 参数指定在 itemValues[] 中给出的值的顺序。此 CompositeDataSupport 实例中包含的项内部存储在 TreeMap 中，并且按它们名称的升序字典顺序进行存储，以便于对各个项值进行较快速的检索。

构造方法检查是否满足下面为每个参数列出的所有约束条件，如果无法满足，则抛出适当的异常。

参数：
compositeType - 此复合数据 实例的复合类型；不可以为 null。

itemNames - itemNames 必须以任一顺序列出在 compositeType 中定义的所有项名称；使用列出名称的顺序来匹配 itemValues[] 中的值；不可以为 null 或空。

itemValues - 按与 itemNames 中它们各自名称相同的顺序列出的项的值；每个项值可以为 null，但是，如果为非 null，则它必须是在 compositeType 中为对应的项定义的开放类型的有效值；大小必须与 itemNames 相同；不可以为 null 或空。

抛出：
IllegalArgumentException - compositeType 为 null，或者 itemNames[] 或 itemValues[] 为 null 或空，或者 itemNames[] 中的元素之一为 null 或空字符串，或者 itemNames[] 和 itemValues[] 的大小不相同。

OpenDataException - itemNames[] 或 itemValues[] 的大小与 compositeType 中定义的项数不同，或者 itemNames[] 中的元素之一不作为在 compositeType 中定义的项名称存在，或者 itemValues[] 中的元素之一不是 compositeType 中定义的相应项的有效值。

CompositeDataSupport

public CompositeDataSupport(CompositeType compositeType,
                            Map<String,?> items)
                     throws OpenDataException

使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。此构造方法将键转换为一个字符串数组，将值转换为一个对象数组，并调用 CompositeDataSupport(javax.management.openmbean.CompositeType, java.lang.String[], java.lang.Object[])。

参数：
compositeType - 此复合数据 实例的复合类型；不可以为 null。

items - 所有项名称到它们的值的映射；items 必须包含 compositeType 中定义的所有项名称；不可以为 null 或空。

抛出：
IllegalArgumentException - compositeType 为 null，或者 items 为 null 或空，或者 items 中的键之一为 null 或空字符串，或者 items 中的值之一为 null。

OpenDataException - items 的大小与 compositeType 中定义的项数不同，或者 items 中的键之一不作为 compositeType 中定义的项名称存在，或者 items 中的值之一不是 compositeType 中定义的相应项的有效值。

ArrayStoreException - items 中的一个或多个键不是 java.lang.String 类。

方法详细信息

getCompositeType

public CompositeType getCompositeType()
返回此复合数据 实例的复合类型。

指定者：
接口 CompositeData 中的 getCompositeType
返回：
此 CompositeData 的类型。

get

public Object get(String key)
返回其名称是 key 的项的值。

指定者：
接口 CompositeData 中的 get
参数：
key - 项的名称。
返回：
与此键关联的值。
抛出：
IllegalArgumentException - 如果 key 为 null 或空字符串。
InvalidKeyException - 如果 key 不是此 CompositeData 实例的现有项名称。

getAll

public Object[] getAll(String[] keys)
返回由 keys 指定其项名称的值的数组，顺序与 keys 相同。

指定者：
接口 CompositeData 中的 getAll
返回：
与键对应的值。
抛出：
IllegalArgumentException - 如果 keys 中的元素为 null 或空字符串。
InvalidKeyException - 如果 keys 中的元素不是此 CompositeData 实例的现有项名称。

containsKey

public boolean containsKey(String key)
当且仅当此 CompositeData 实例包含名称是 key 的项时，才返回 true。如果 key 为 null 或空字符串，则此方法只返回 false。

指定者：
接口 CompositeData 中的 containsKey
参数：
key - 要测试的键。
返回：
如果此 CompositeData 包含该键，则返回 true。

containsValue

public boolean containsValue(Object value)
当且仅当此 CompositeData 实例包含其值是 value 的项时，返回 true。

指定者：
接口 CompositeData 中的 containsValue
参数：
value - 要测试的值。
返回：
如果此 CompositeData 包含该值，则返回 true。

values

public Collection<?> values()
返回此 CompositeData 实例中包含的项值的不可修改的 Collection 视图。返回集合的迭代器将按相应项名称的升序字典顺序返回该值。

指定者：
接口 CompositeData 中的 values
返回：
值。

equals

public boolean equals(Object obj)
比较指定的 obj 参数与此 CompositeDataSupport 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null，
  • obj 还实现 CompositeData 接口，
  • 它们的复合类型相等
  • 它们的内容（即（名称，值）对）相等。如果内容中包含的值是一个数组，则对于对象引用类型数组，值比较操作的执行方式类似于调用 deepEquals 方法；对于基本类型数组，则类似于调用恰当的 Arrays.equals(e1,e2) 重载形式。

这确保了此 equals 方法对 obj 参数正常工作，该参数是 CompositeData 接口（具有 java.util.Collection 接口的 equals 方法中提到的限制）的不同实现。

指定者：
接口 CompositeData 中的 equals
覆盖：
类 Object 中的 equals
参数：
obj - 与此 CompositeDataSupport 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 CompositeDataSupport 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 CompositeDataSupport 实例的哈希码值。

CompositeDataSupport 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即其复合类型 和所有项值）。

这确保了 t1.equals(t2) 意味着对于任何两个 CompositeDataSupport 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

每项值的哈希码将被添加到返回的哈希码中。如果项值是一个数组，则对于对象引用类型数组，其哈希码的获取方式类似于调用 deepHashCode 方法；对于基本类型数组，则类似于调用恰当的 Arrays.hashCode(e) 重载形式。

指定者：
接口 CompositeData 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 CompositeDataSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 CompositeDataSupport 实例的字符串表示形式。

字符串表示形式由此类（即javax.management.openmbean.CompositeDataSupport）的名称、此实例的复合类型的字符串表示形式以及内容（即列出 itemName=itemValue 映射关系）的字符串表示形式组成。

指定者：
接口 CompositeData 中的 toString
覆盖：
类 Object 中的 toString
返回：
此 CompositeDataSupport 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompositeDataView (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 CompositeDataView

public interface CompositeDataView

Java 类可以实现此接口，以指示如何通过 MXBean 框架将其转换为 CompositeData。

使用此类的典型方式是，除了已经在 MXBean 框架提供的 CompositeType 中声明的项外，还要向 CompositeData 添加额外的项。要做到这一点，必须创建另一个 CompositeType，其中包含所有相同的项以及额外的项。

例如，假定您有一个由名为 units 的 String 和一个 value（可以是 long 或 double）组成的 Measure 类。其形式可能如下所示：

public class Measure implements CompositeDataView {
private String units;
private Number value; // a Long or a Double

public Measure(String units, Number value) {
this.units = units;
this.value = value;
     }

public static Measure from(CompositeData cd) {
return new Measure((String) cd.get("units"),
(Number) cd.get("value"));
     }

public String getUnits() {
return units;
     }

// Can't be called getValue(), because Number is not a valid type
// in an MXBean, so the implied "value" property would be rejected.
public Number _getValue() {
return value;
     }

public CompositeData toCompositeData(CompositeType ct) {
try {
List<String> itemNames = new ArrayList<String>(ct.keySet());
List<String> itemDescriptions = new ArrayList<String>();
List<OpenType&lt;?&gt;&gt; itemTypes = new ArrayList<OpenType&lt;?&gt;&gt;();
for (String item :itemNames) {
itemDescriptions.add(ct.getDescription(item));
itemTypes.add(ct.getType(item));
             }
itemNames.add("value");
itemDescriptions.add("long or double value of the measure");
itemTypes.add((value instanceof Long) ?SimpleType.LONG :
SimpleType.DOUBLE);
CompositeType xct =
new CompositeType(ct.getTypeName(),
ct.getDescription(),
itemNames.toArray(new String[0]),
itemDescriptions.toArray(new String[0]),
itemTypes.toArray(new OpenType<?>[0]));
CompositeData cd =
new CompositeDataSupport(xct,
new String[] {"units", "value"},
new Object[] {units, value});
assert ct.isValue(cd);  // check we've done it right
return cd;
} catch (Exception e) {
throw new RuntimeException(e);
         }
     }
 }

将出现在用于此类型的属性或操作的 Descriptor 的 openType 字段中的 CompositeType 将只显示 units 项，但生成的实际 CompositeData 将既包含 units 又包含 value。

从以下版本开始：
1.6
另请参见：
MXBean

方法摘要
 CompositeData toCompositeData(CompositeType ct)
返回对应于此对象中的值的 CompositeData。

方法详细信息

toCompositeData

CompositeData toCompositeData(CompositeType ct)

返回对应于此对象中的值的 CompositeData。返回的值通常应该是一个 CompositeDataSupport 实例，或通过 writeReplace 方法序列化为一个 CompositeDataSupport 的类。否则，接收对象的远程客户端可能无法重新构造它。

参数：
ct - 返回值的期望 CompositeType。如果返回值是 cd，则 cd.getCompositeType().equals(ct) 应该为 true。通常这是因为 cd 是一个通过将 ct 作为其 CompositeType 构造而成的 CompositeDataSupport。
返回：
CompositeData。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompositeType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 CompositeType

java.lang.Object
    继承者  javax.management.openmbean.OpenType<CompositeData>
        继承者  javax.management.openmbean.CompositeType
所有已实现的接口：
Serializable
public class CompositeType
extends OpenType<CompositeData>

CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.openmbean.OpenType 继承的字段
ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST
构造方法摘要
CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。
方法摘要
boolean | containsKey(String itemName) 如果此 CompositeType 实例定义了名称为 itemName 的项，则返回 true。
boolean | equals(Object obj) 比较指定的 obj 参数与此 CompositeType 实例的相等性。
String | getDescription(String itemName) 返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。
OpenType<?> | getType(String itemName) 返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。
int | hashCode() 返回此 CompositeType 实例的哈希码值。
boolean | isValue(Object obj) 测试 obj 是否为此 CompositeType 实例可以描述的值。
Set<String> | keySet() 返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。
String | toString() 返回此 CompositeType 实例的字符串表示形式。
从类 javax.management.openmbean.OpenType 继承的方法
getClassName, getDescription, getTypeName, isArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CompositeType

public CompositeType(String typeName,
                     String description,
                     String[] itemNames,
                     String[] itemDescriptions,
                     OpenType<?>[] itemTypes)
              throws OpenDataException
构造一个 CompositeType 实例，检查给定参数的有效性。下面描述了每个参数的有效性约束。

注意，三个数组参数（itemNames、itemDescriptions 和 itemTypes）的内容是内部复制的，因此此构造方法的调用者对这些数组的任何后续修改不会影响构造的 CompositeType 实例。

此复合类型表示的复合数据值的 Java 类名（即 getClassName 方法返回的类名）设置为 CompositeData.class.getName() 返回的字符串值。

参数：
typeName - 为此实例表示的复合类型给出的名称；不可以为 null 或空字符串。
description - 此实例表示的复合类型的可读描述；不可以为 null 或空字符串。
itemNames - 此 CompositeType 实例描述的复合数据值中包含的项名称；不可以为 null，并且至少应包含一个元素；任何元素不可以为 null 或空字符串。注意，所给出的项名称的顺序对于区分 CompositeType 实例并不重要；项名称按升序字典顺序排序进行内部存储。
itemDescriptions - 此 CompositeType 实例描述的复合数据值中已包含项的描述（与 itemNames 的顺序相同）；应与 itemNames 的大小相同；任何元素不可以为 null 或空字符串。
itemTypes - 描述此 CompositeType 实例描述的复合数据值中已包含项的开放类型实例（与 itemNames 的顺序相同）；应与 itemNames 的大小相同；任何元素不可以为 null。
抛出：
IllegalArgumentException - 如果 typeName 或 description 为 null 或空字符串；如果 itemNames、itemDescriptions 或 itemTypes 为 null；如果 itemNames 或 itemDescriptions 的任何元素为 null 或空字符串；如果 itemTypes 的任何元素为 null；如果 itemNames、itemDescriptions 或 itemTypes 的大小不同。
OpenDataException - 如果 itemNames 包含重复的项名称（区分大小写，但是移除了前导和尾部空格）。
方法详细信息

containsKey

public boolean containsKey(String itemName)
如果此 CompositeType 实例定义了名称为 itemName 的项，则返回 true。

参数：
itemName - 项的名称。
返回：
如果此名称的项存在，则返回 true。

getDescription

public String getDescription(String itemName)
返回名称是 itemName 的项的描述，如果此 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

参数：
itemName - 项的名称。
返回：
描述。

getType

public OpenType<?> getType(String itemName)
返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

参数：
itemName - 项的名称。
返回：
类型。

keySet

public Set<String> keySet()
返回此 CompositeType 实例定义的所有项名称的不可修改的 Set 视图。集合的迭代器将按升序返回项名称。

返回：
String 的 Set。

isValue

public boolean isValue(Object obj)
测试 obj 是否为此 CompositeType 实例可以描述的值。

如果 obj 为 null，或者不是 javax.management.openmbean.CompositeData 的实例，则 isValue 返回 false。

如果 obj 是 javax.management.openmbean.CompositeData 的实例，然后设 ct 为其 CompositeType（由 CompositeData.getCompositeType() 返回）。那么如果 this 可以通过 ct 进行分配，则结果为 true。可以通过 ct 进行分配的含义是：

  • this.getTypeName() 等于 ct.getTypeName()
  • this 中不存在的项名称在 ct 中也不存在
  • 对于 this 中每一项，其类型都可以通过 ct 中的对应项进行分配

如果 typeName 和索引名称列表相同，且前者的行类型可以通过后者的行类型进行分配，则 TabularType 可以通过另一个 TabularType 进行分配。

如果维数相同；都是基本数组或者都不是；前者的元素类型可以通过后者的元素类型进行分配，则 ArrayType 可以通过另一个 ArrayType 进行分配。

在其他情况下，只有两者相等时 OpenType 才可以通过另一个 OpenType 进行分配。

这些规则意味着，可以将额外的项添加到 CompositeData 中，而不会使之对于没有这些项的 CompositeType 无效。

指定者：
类 OpenType<CompositeData> 中的 isValue
参数：
obj - 要测试其开放类型与此 CompositeType 的相等性的值。
返回：
如果 obj 是此复合类型的值，则返回 true，否则返回 false。

equals

public boolean equals(Object obj)
比较指定的 obj 参数与此 CompositeType 实例的相等性。

当且仅当以下所有语句为 true 时，两个 CompositeType 实例才相等：

  • 它们的类型名称相同
  • 它们的项名称和类型相同

指定者：
类 OpenType<CompositeData> 中的 equals
参数：
obj - 与此 CompositeType 实例比较相等性的对象；如果 obj 为 null，则 equals 返回 false。
返回：
如果指定的对象等于此 CompositeType 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 CompositeType 实例的哈希码值。

CompositeType 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即名称、项名称和项类型）。这确保了 t1.equals(t2) 意味着对于任何两个 CompositeType 实例 t1 和 t2 而言，都存在 t21.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

由于 CompositeType 实例是不可变的，此实例的哈希码在首次调用 hashCode 时被计算一次，然后对后续调用返回相同的值。

指定者：
类 OpenType<CompositeData> 中的 hashCode
返回：
此 CompositeType 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 CompositeType 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.CompositeType）的名称、此实例的类型名称和项名称的列表以及此实例的类型字符串表示形式组成。

由于 CompositeType 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时被计算一次，然后对后续调用返回相同的值。

指定者：
类 OpenType<CompositeData> 中的 toString
返回：
此 CompositeType 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidKeyException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 InvalidKeyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  javax.management.openmbean.InvalidKeyException
所有已实现的接口：
Serializable
public class InvalidKeyException
extends IllegalArgumentException

当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidKeyException()
不带详细消息的 InvalidKeyException。
InvalidKeyException(String msg)
带详细消息的 InvalidKeyException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidKeyException

public InvalidKeyException()
不带详细消息的 InvalidKeyException。

InvalidKeyException

public InvalidKeyException(String msg)
带详细消息的 InvalidKeyException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidOpenTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 InvalidOpenTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  javax.management.openmbean.InvalidOpenTypeException
所有已实现的接口：
Serializable
public class InvalidOpenTypeException
extends IllegalArgumentException

当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidOpenTypeException()
不带详细消息的 InvalidOpenTypeException。
InvalidOpenTypeException(String msg)
带详细消息的 InvalidOpenTypeException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidOpenTypeException

public InvalidOpenTypeException()
不带详细消息的 InvalidOpenTypeException。

InvalidOpenTypeException

public InvalidOpenTypeException(String msg)
带详细消息的 InvalidOpenTypeException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyAlreadyExistsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 KeyAlreadyExistsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  java.lang.IllegalArgumentException
                    继承者  javax.management.openmbean.KeyAlreadyExistsException
所有已实现的接口：
Serializable
public class KeyAlreadyExistsException
extends IllegalArgumentException

当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
KeyAlreadyExistsException()
不带详细消息的 KeyAlreadyExistsException。
KeyAlreadyExistsException(String msg)
带详细消息的 KeyAlreadyExistsException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

KeyAlreadyExistsException

public KeyAlreadyExistsException()
不带详细消息的 KeyAlreadyExistsException。

KeyAlreadyExistsException

public KeyAlreadyExistsException(String msg)
带详细消息的 KeyAlreadyExistsException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenDataException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 OpenDataException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.JMException
                继承者  javax.management.openmbean.OpenDataException
所有已实现的接口：
Serializable
public class OpenDataException
extends JMException

因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
OpenDataException()
不带详细消息的 OpenDataException。
OpenDataException(String msg)
带详细消息的 OpenDataException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OpenDataException

public OpenDataException()
不带详细消息的 OpenDataException。

OpenDataException

public OpenDataException(String msg)
带详细消息的 OpenDataException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanAttributeInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 OpenMBeanAttributeInfo

所有超级接口：
OpenMBeanParameterInfo
所有已知实现类：
OpenMBeanAttributeInfoSupport
public interface OpenMBeanAttributeInfo
extends OpenMBeanParameterInfo

描述 open MBean 的属性。

此接口声明的方法与类 MBeanAttributeInfo 相同。实现此接口的类（通常为 OpenMBeanAttributeInfoSupport）应扩展 MBeanAttributeInfo。

从以下版本开始：
1.5

方法摘要
boolean | equals(Object obj) 比较指定的 obj 参数与此 OpenMBeanAttributeInfo 实例的相等性。
int | hashCode() 返回此 OpenMBeanAttributeInfo 实例的哈希码值。
boolean | isIs() 如果通过 isXXX 获取方法（仅适用于 boolean 和 Boolean 值）访问此 OpenMBeanAttributeInfo 实例描述的属性，则返回 true，否则返回 false。
boolean | isReadable() 如果此 OpenMBeanAttributeInfo 实例描述的属性为可读的，则返回 true，否则返回 false。
boolean | isWritable() 如果此 OpenMBeanAttributeInfo 实例描述的属性是可写的，则返回 true，否则返回 false。
String | toString() 返回此 OpenMBeanAttributeInfo 实例的字符串表示形式。
从接口 javax.management.openmbean.OpenMBeanParameterInfo 继承的方法
getDefaultValue, getDescription, getLegalValues, getMaxValue, getMinValue, getName, getOpenType, hasDefaultValue, hasLegalValues, hasMaxValue, hasMinValue, isValue

方法详细信息

isReadable

boolean isReadable()
如果此 OpenMBeanAttributeInfo 实例描述的属性为可读的，则返回 true，否则返回 false。

返回：
如果属性可读，则返回 true。

isWritable

boolean isWritable()
如果此 OpenMBeanAttributeInfo 实例描述的属性是可写的，则返回 true，否则返回 false。

返回：
如果属性是可写的，则返回 true。

isIs

boolean isIs()
如果通过 isXXX 获取方法（仅适用于 boolean 和 Boolean 值）访问此 OpenMBeanAttributeInfo 实例描述的属性，则返回 true，否则返回 false。

返回：
如果通过 isXXX 访问属性，则返回 true。

equals

boolean equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanAttributeInfo 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null；
  • obj 还实现 OpenMBeanAttributeInfo 接口；
  • 它们的名称相等；
  • 它们的开放类型相等；
  • 它们的访问属性（isReadable、isWritable 和 isIs）相等；
  • 它们的默认值、最小值、最大值和合法值相等。
这确保了此 equals 方法对作为 OpenMBeanAttributeInfo 接口的不同实现的 obj 参数正常工作。

指定者：
接口 OpenMBeanParameterInfo 中的 equals
覆盖：
类 Object 中的 equals
参数：
obj - 与此 OpenMBeanAttributeInfo 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanAttributeInfo 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 OpenMBeanAttributeInfo 实例的哈希码值。

OpenMBeanAttributeInfo 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即其名称、其开放类型 及其默认值、最小值、最大值和合法值）。

这确保了 t1.equals(t2) 意味着对于任何两个 OpenMBeanAttributeInfo 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

指定者：
接口 OpenMBeanParameterInfo 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 OpenMBeanAttributeInfo 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 OpenMBeanAttributeInfo 实例的字符串表示形式。

字符串表示形式由此类（即javax.management.openmbean.OpenMBeanAttributeInfo）的名称、名称的字符串表示形式和描述属性的开放类型，以及其默认值、最小值、最大值和合法值的字符串表示形式组成。

指定者：
接口 OpenMBeanParameterInfo 中的 toString
覆盖：
类 Object 中的 toString
返回：
此 OpenMBeanAttributeInfo 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanAttributeInfoSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 OpenMBeanAttributeInfoSupport

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanAttributeInfo
            继承者  javax.management.openmbean.OpenMBeanAttributeInfoSupport
所有已实现的接口：
Serializable, Cloneable, DescriptorRead, OpenMBeanAttributeInfo, OpenMBeanParameterInfo
public class OpenMBeanAttributeInfoSupport
extends MBeanAttributeInfo
implements OpenMBeanAttributeInfo

描述 open MBean 的一个属性。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。
方法摘要
boolean | equals(Object obj) 比较指定 obj 参数与此 OpenMBeanAttributeInfoSupport 实例的相等性。
Object | getDefaultValue() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的默认值（如果已指定），否则返回 null。
Set<?> | getLegalValues() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的合法值的不可修改的 Set（如果已指定），否则返回 null。
Comparable<?> | getMaxValue() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最大值（如果已指定），否则返回 null。
Comparable<?> | getMinValue() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最小值（如果已指定），否则返回 null。
OpenType<?> | getOpenType() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性值的开放类型。
boolean | hasDefaultValue() 如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 默认值，则返回 true，否则返回 false。
int | hashCode() 返回此 OpenMBeanAttributeInfoSupport 实例的哈希码值。
boolean | hasLegalValues() 如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的合法值集，则返回 true，否则返回 false。
boolean | hasMaxValue() 如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最大值，则返回 true，否则返回 false。
boolean | hasMinValue() 如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最小值，则返回 true，否则返回 false。
boolean | isValue(Object obj) 测试 obj 是否为此 OpenMBeanAttributeInfoSupport 实例描述的属性的有效值。
String | toString() 返回此 OpenMBeanAttributeInfoSupport 实例的字符串表示形式。
从类 javax.management.MBeanAttributeInfo 继承的方法
clone, getType, isIs, isReadable, isWritable
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.management.openmbean.OpenMBeanAttributeInfo 继承的方法
isIs, isReadable, isWritable
从接口 javax.management.openmbean.OpenMBeanParameterInfo 继承的方法
getDescription, getName

构造方法详细信息

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType<?> openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。

参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
openType - 不可以为 null。
isReadable - 如果该属性有一个为了便于管理而公开的获取方法，则此参数为 true。
isWritable - 如果该属性有一个为了便于管理而公开的设置方法，则此参数为 true。
isIs - 如果该属性的获取方法的形式是 isXXX，则此参数为 true。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType<?> openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs,
                                     Descriptor descriptor)

构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。

正如包描述中所解释的，descriptor 可以包含那些定义此类某些方法的返回值的项。

参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
openType - 不可以为 null。
isReadable - 如果该属性有一个为了便于管理而公开的获取方法，则此参数为 true。
isWritable - 如果该属性有一个为了便于管理而公开的设置方法，则此参数为 true。
isIs - 如果该属性的获取方法的形式是 isXXX，则此参数为 true。
descriptor - 属性的描述符。此参数可以为 null，它等效于一个空描述符。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串；或者 openType 为 null；或者根据包描述中的描述，描述符项无效。
从以下版本开始：
1.6

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType<T> openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs,
                                     T defaultValue)
                              throws OpenDataException
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。

类型参数：
T - 允许编译器查看 defaultValue（如果不为 null）是否具有对应 openType 的正确 Java 类型。
参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
openType - 不可以为 null。
isReadable - 如果该属性有一个为了便于管理而公开的获取方法，则此参数为 true。
isWritable - 如果该属性有一个为了便于管理而公开的设置方法，则此参数为 true。
isIs - 如果该属性的获取方法的形式是 isXXX，则此参数为 true。
defaultValue - 必须是为此属性指定的 @code openType} 的有效值；默认值不支持 ArrayType 和 TabularType；可以为 null，在这种情况下，它意味着不设置任何默认值。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。
OpenDataException - 如果 defaultValue 不是指定 openType 的有效值，或者 defaultValue 不为 null 且 openType 为 ArrayType 或 TabularType。

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType<T> openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs,
                                     T defaultValue,
                                     T[] legalValues)
                              throws OpenDataException

构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。

复制 legalValues 的内容，因此对 legalValues 引用的数组进行后续修改不会影响此 OpenMBeanAttributeInfoSupport 实例。

类型参数：
T - 允许编译器查看 defaultValue 和 legalValues（如果不为 null）是否具有对应 openType 的正确 Java 类型。
参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
openType - 不可以为 null。
isReadable - 如果该属性有一个为了便于管理而公开的获取方法，则此参数为 true。
isWritable - 如果该属性有一个为了便于管理而公开的设置方法，则此参数为 true。
isIs - 如果该属性的获取方法的形式是 isXXX，则此参数为 true。
defaultValue - 必须是为此属性指定的 openType 的有效值；默认值不支持 ArrayType 和 TabularType；可以为 null，在这种情况下，它意味着不设置任何默认值。
legalValues - 包含的每个值对于为此属性指定的 openType 必须是有效的；ArrayType 和 TabularType 不支持的合法值；可以为 null 或空。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。
OpenDataException - 如果 defaultValue 对指定的 openType 无效；如果 legalValues 中的一个值对指定的 openType 无效；如果 defaultValue 为非 null 且 openType 为 ArrayType 或 TabularType；如果 legalValues 为非 null 和非空且 openType 为 ArrayType 或 TabularType；如果 legalValues 为非 null 和非空且 legalValues 中不包含 defaultValue。

OpenMBeanAttributeInfoSupport

public OpenMBeanAttributeInfoSupport(String name,
                                     String description,
                                     OpenType<T> openType,
                                     boolean isReadable,
                                     boolean isWritable,
                                     boolean isIs,
                                     T defaultValue,
                                     Comparable<T> minValue,
                                     Comparable<T> maxValue)
                              throws OpenDataException
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。只有值为 Comparable 的开放类型才能指定最小值和最大值。

类型参数：
T - 允许编译器查看 defaultValue、minValue 和 maxValue（如果不为 null）是否具有对应 openType 的正确 Java 类型。
参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
openType - 不可以为 null。
isReadable - 如果该属性有一个为了便于管理而公开的获取方法，则此参数为 true。
isWritable - 如果该属性有一个为了便于管理而公开的设置方法，则此参数为 true。
isIs - 如果该属性的获取方法的形式是 isXXX，则此参数为 true。
defaultValue - 必须是为此属性指定的 openType 的有效值；默认值不支持 ArrayType 和 TabularType；可以为 null，在这种情况下，它意味着不设置任何默认值。
minValue - 对于为此属性指定的 openType 必须有效；可以为 null，在这种情况下，它意味着不设置任何最小值。
maxValue - 对于为此属性指定的 openType 必须有效；可以为 null，在这种情况下，它意味着不设置任何最大值。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。
OpenDataException - 如果 defaultValue、minValue 或 maxValue 不是对应指定 openType 的有效值；如果 defaultValue 不为 null 且 openType 是 ArrayType 或 TabularType；如果 minValue 和 maxValue 都不为 null 且 minValue.compareTo(maxValue) > 0 为 true；如果 defaultValue 和 minValue 都不为 null 且 minValue.compareTo(defaultValue) > 0 为 true；如果 defaultValue 和 maxValue 都不为 null 且 defaultValue.compareTo(maxValue) > 0 为 true。
方法详细信息

getOpenType

public OpenType<?> getOpenType()
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性值的开放类型。

指定者：
接口 OpenMBeanParameterInfo 中的 getOpenType
返回：
开放类型。

getDefaultValue

public Object getDefaultValue()
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的默认值（如果已指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getDefaultValue
返回：
默认值。

getLegalValues

public Set<?> getLegalValues()
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的合法值的不可修改的 Set（如果已指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getLegalValues
返回：
合法值的集合。

getMinValue

public Comparable<?> getMinValue()
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最小值（如果已指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getMinValue
返回：
最小值。

getMaxValue

public Comparable<?> getMaxValue()
返回此 OpenMBeanAttributeInfoSupport 实例描述的属性的最大值（如果已指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getMaxValue
返回：
最大值。

hasDefaultValue

public boolean hasDefaultValue()
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 默认值，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasDefaultValue
返回：
如果存在默认值，则返回 true。

hasLegalValues

public boolean hasLegalValues()
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的合法值集，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasLegalValues
返回：
如果存在合法值的集合，则返回 true。

hasMinValue

public boolean hasMinValue()
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最小值，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasMinValue
返回：
如果存在最小值，则返回 true。

hasMaxValue

public boolean hasMaxValue()
如果此 OpenMBeanAttributeInfoSupport 实例指定所描述属性的非 null 的最大值，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasMaxValue
返回：
如果存在最大值，则返回 true。

isValue

public boolean isValue(Object obj)
测试 obj 是否为此 OpenMBeanAttributeInfoSupport 实例描述的属性的有效值。

指定者：
接口 OpenMBeanParameterInfo 中的 isValue
参数：
obj - 要测试的对象。
返回：
如果 obj 是此 OpenMBeanAttributeInfoSupport 实例描述的参数的有效值，则返回 true，否则返回 false。

equals

public boolean equals(Object obj)
比较指定 obj 参数与此 OpenMBeanAttributeInfoSupport 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null，
  • obj 还实现 OpenMBeanAttributeInfo 接口，
  • 它们的名称相等
  • 它们的开放类型相等
  • 它们的访问属性（isReadable、isWritable 和 isIs）相等
  • 它们的默认值、最小值、最大值和合法值相等。
这确保了此 equals 方法对作为 OpenMBeanAttributeInfo 接口的不同实现的 obj 参数正常工作。

如果 obj 还实现 DescriptorRead，则其 getDescriptor() 必须为此对象返回相同的值。

指定者：
接口 OpenMBeanAttributeInfo 中的 equals
指定者：
接口 OpenMBeanParameterInfo 中的 equals
覆盖：
类 MBeanAttributeInfo 中的 equals
参数：
obj - 与此 OpenMBeanAttributeInfoSupport 实例进行相等性比较的对象。
返回：
如果指定的对象等于此 OpenMBeanAttributeInfoSupport 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此 OpenMBeanAttributeInfoSupport 实例的哈希码值。

OpenMBeanAttributeInfoSupport 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即它的名称、开放类型、默认值、最小值、最大值、合法值和 Descriptor）。

这确保 t1.equals(t2) 意味着对于任何两个 OpenMBeanAttributeInfoSupport 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

不过请注意，根据 equals(java.lang.Object) 中的定义，实现 OpenMBeanAttributeInfo 接口的类的其他实例可能与此 OpenMBeanAttributeInfoSupport 实例相等，但是如果它的计算方法不同，可能会有不同的哈希码。

由于 OpenMBeanAttributeInfoSupport 实例是不可变的，此实例的哈希码在首次调用 hashCode 时被计算一次，然后对后续调用返回相同的值。

指定者：
接口 OpenMBeanAttributeInfo 中的 hashCode
指定者：
接口 OpenMBeanParameterInfo 中的 hashCode
覆盖：
类 MBeanAttributeInfo 中的 hashCode
返回：
此 OpenMBeanAttributeInfoSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 OpenMBeanAttributeInfoSupport 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.OpenMBeanAttributeInfoSupport）的名称、名称的字符串表示形式和描述参数的开放类型，以及它的默认值、最小值、最大值和合法值和描述符的字符串表示形式组成。

由于 OpenMBeanAttributeInfoSupport 实例是不可变的，所以此实例的字符串表示形式在首次调用 toString 时被计算一次，然后对后续调用返回相同的值。

指定者：
接口 OpenMBeanAttributeInfo 中的 toString
指定者：
接口 OpenMBeanParameterInfo 中的 toString
覆盖：
类 MBeanAttributeInfo 中的 toString
返回：
此 OpenMBeanAttributeInfoSupport 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanConstructorInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 OpenMBeanConstructorInfo

所有已知实现类：
OpenMBeanConstructorInfoSupport
public interface OpenMBeanConstructorInfo

描述 Open MBean 的构造方法。

此接口声明的方法与类 MBeanConstructorInfo 相同。实现此接口的类（通常为 OpenMBeanConstructorInfoSupport）应扩展 MBeanConstructorInfo。

getSignature() 方法应在运行时返回实现 OpenMBeanParameterInfo 接口（通常为 OpenMBeanParameterInfoSupport）的 MBeanParameterInfo 的子类的实例数组。

从以下版本开始：
1.5

方法摘要
boolean | equals(Object obj) 比较指定的 obj 参数与此 OpenMBeanConstructorInfo 实例的相等性。
String | getDescription() 返回此 OpenMBeanConstructorInfo 实例描述的构造方法的可读描述。
String | getName() 返回此 OpenMBeanConstructorInfo 实例描述的构造方法名称。
MBeanParameterInfo[] | getSignature() 返回 OpenMBeanParameterInfo 实例的数组，该实例描述此 OpenMBeanConstructorInfo 实例描述的构造方法签名中的每个参数。
int | hashCode() 返回此 OpenMBeanConstructorInfo 实例的哈希码值。
String | toString() 返回此 OpenMBeanConstructorInfo 实例的字符串表示形式。

方法详细信息

getDescription

String getDescription()
返回此 OpenMBeanConstructorInfo 实例描述的构造方法的可读描述。

返回：
描述。

getName

String getName()
返回此 OpenMBeanConstructorInfo 实例描述的构造方法名称。

返回：
名称。

getSignature

MBeanParameterInfo[] getSignature()
返回 OpenMBeanParameterInfo 实例的数组，该实例描述此 OpenMBeanConstructorInfo 实例描述的构造方法签名中的每个参数。

返回：
签名。

equals

boolean equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanConstructorInfo 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null；
  • obj 还实现 OpenMBeanConstructorInfo 接口；
  • 它们的名称相等；
  • 它们的签名相等。
这确保了此 equals 方法对作为 OpenMBeanConstructorInfo 接口的不同实现的 obj 参数正常工作。

覆盖：
类 Object 中的 equals
参数：
obj - 与此 OpenMBeanConstructorInfo 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanConstructorInfo 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 OpenMBeanConstructorInfo 实例的哈希码值。

OpenMBeanConstructorInfo 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总数（即名称和签名，其中签名 hashCode 由对 java.util.Arrays.asList(this.getSignature).hashCode() 的调用计算）。

这确保了 t1.equals(t2) 意味着对于任何两个 OpenMBeanConstructorInfo 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
此 OpenMBeanConstructorInfo 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 OpenMBeanConstructorInfo 实例的字符串表示形式。

字符串表示形式由此类（即javax.management.openmbean.OpenMBeanConstructorInfo）的名称和所描述构造方法的名称和签名组成。

覆盖：
类 Object 中的 toString
返回：
此 OpenMBeanConstructorInfo 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 OpenMBeanInfo

所有已知实现类：
OpenMBeanInfoSupport
public interface OpenMBeanInfo

描述一个 Open MBean：Open MBean 的识别方式为，如果 Open MBean 的 getMBeanInfo() 方法返回实现 OpenMBeanInfo 接口（通常为 OpenMBeanInfoSupport）的类的实例，则可识别 Open MBean。

此接口声明的方法与类 MBeanInfo 相同。实现此接口的类（通常为 OpenMBeanInfoSupport）应扩展 MBeanInfo。

实现类的 getAttributes()、getOperations() 和 getConstructors() 方法在运行时应分别返回分别实现 OpenMBeanAttributeInfo、OpenMBeanOperationInfo 或 OpenMBeanConstructorInfo 接口的 MBeanAttributeInfo、MBeanOperationInfo 或 MBeanConstructorInfo 的子类实例的数组。

从以下版本开始：
1.5

方法摘要
boolean | equals(Object obj) 比较指定 obj 参数与此 OpenMBeanInfo 实例的相等性。
MBeanAttributeInfo[] | getAttributes() 返回 OpenMBeanAttributeInfo 实例的数组，该实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个属性。
String | getClassName() 返回此 OpenMBeanInfo 描述的 open MBean 实例的完全限定的 Java 类名。
MBeanConstructorInfo[] | getConstructors() 返回 OpenMBeanConstructorInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个构造方法。
String | getDescription() 返回此 OpenMBeanInfo 描述的 open MBean 实例的类型的可读描述。
MBeanNotificationInfo[] | getNotifications() 返回 MBeanNotificationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 所发出的每个通知。
MBeanOperationInfo[] | getOperations() 返回 OpenMBeanOperationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例所描述的 open MBean 中的每个操作。
int | hashCode() 返回此 OpenMBeanInfo 实例的哈希码值。
String | toString() 返回此 OpenMBeanInfo 实例的字符串表示形式。

方法详细信息

getClassName

String getClassName()
返回此 OpenMBeanInfo 描述的 open MBean 实例的完全限定的 Java 类名。

返回：
类名。

getDescription

String getDescription()
返回此 OpenMBeanInfo 描述的 open MBean 实例的类型的可读描述。

返回：
描述。

getAttributes

MBeanAttributeInfo[] getAttributes()
返回 OpenMBeanAttributeInfo 实例的数组，该实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个属性。返回数组中的每个实例实际上是实现 OpenMBeanAttributeInfo 接口（通常为 OpenMBeanAttributeInfoSupport）的 MBeanAttributeInfo 的一个子类。

返回：
属性数组。

getOperations

MBeanOperationInfo[] getOperations()
返回 OpenMBeanOperationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例所描述的 open MBean 中的每个操作。返回数组中的每个实例实际上是实现 OpenMBeanOperationInfo 接口（通常为 OpenMBeanOperationInfoSupport）的 MBeanOperationInfo 的一个子类。

返回：
操作数组。

getConstructors

MBeanConstructorInfo[] getConstructors()
返回 OpenMBeanConstructorInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个构造方法。返回数组中的每个实例实际上是实现 OpenMBeanConstructorInfo 接口（通常为 OpenMBeanConstructorInfoSupport）的 MBeanConstructorInfo 的一个子类。

返回：
构造方法数组。

getNotifications

MBeanNotificationInfo[] getNotifications()
返回 MBeanNotificationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 所发出的每个通知。

返回：
通知数组。

equals

boolean equals(Object obj)
比较指定 obj 参数与此 OpenMBeanInfo 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null；
  • obj 还实现 OpenMBeanInfo 接口；
  • 它们的类名相等；
  • 它们的关于属性、构造方法、操作和通知的信息相等。
这确保了此 equals 方法对作为 OpenMBeanInfo 接口的不同实现的 obj 参数正常工作。

覆盖：
类 Object 中的 equals
参数：
obj - 与此 OpenMBeanInfo 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanInfo 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 OpenMBeanInfo 实例的哈希码值。

OpenMBeanInfo 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即类名及其关于属性、构造方法、操作和通知的信息，其中每个数组的 hashCode 都通过调用 new java.util.HashSet(java.util.Arrays.asList(this.getSignature)).hashCode() 计算）。

这确保 t1.equals(t2) 意味着对于任何两个 OpenMBeanInfo 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
此 OpenMBeanInfo 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 OpenMBeanInfo 实例的字符串表示形式。

字符串表示形式由此类（即javax.management.openmbean.OpenMBeanInfo）的名称、MBean 类名和关于所描述 MBean 的属性、构造方法、操作和通知信息的字符串表示形式组成。

覆盖：
类 Object 中的 toString
返回：
此 OpenMBeanInfo 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanConstructorInfoSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 OpenMBeanConstructorInfoSupport

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanConstructorInfo
            继承者  javax.management.openmbean.OpenMBeanConstructorInfoSupport
所有已实现的接口：
Serializable, Cloneable, DescriptorRead, OpenMBeanConstructorInfo
public class OpenMBeanConstructorInfoSupport
extends MBeanConstructorInfo
implements OpenMBeanConstructorInfo

描述 Open MBean 的构造方法。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。
方法摘要
boolean | equals(Object obj) 比较指定 obj 参数与此 OpenMBeanConstructorInfoSupport 实例的相等性。
int | hashCode() 返回此 OpenMBeanConstructorInfoSupport 实例的哈希码值。
String | toString() 返回此 OpenMBeanConstructorInfoSupport 实例的字符串表示形式。
从类 javax.management.MBeanConstructorInfo 继承的方法
clone, getSignature
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.management.openmbean.OpenMBeanConstructorInfo 继承的方法
getDescription, getName, getSignature

构造方法详细信息

OpenMBeanConstructorInfoSupport

public OpenMBeanConstructorInfoSupport(String name,
                                       String description,
                                       OpenMBeanParameterInfo[] signature)

构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。

signature 数组参数是被内部复制的，因此对 signature 引用的数组的后续更改不影响此实例。

参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
signature - 如果没有要描述的任何参数，可以为 null 或空。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串。
ArrayStoreException - 如果 signature 不是 MBeanParameterInfo 的子类实例的数组。

OpenMBeanConstructorInfoSupport

public OpenMBeanConstructorInfoSupport(String name,
                                       String description,
                                       OpenMBeanParameterInfo[] signature,
                                       Descriptor descriptor)

构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。

signature 数组参数是被内部复制的，因此对 signature 引用的数组的后续更改不影响此实例。

参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
signature - 如果没有要描述的任何参数，可以为 null 或空。
descriptor - 构造方法的描述符。此参数可以为 null，它等效于一个空描述符。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串。
ArrayStoreException - 如果 signature 不是 MBeanParameterInfo 的子类实例的数组。
从以下版本开始：
1.6
方法详细信息

equals

public boolean equals(Object obj)

比较指定 obj 参数与此 OpenMBeanConstructorInfoSupport 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null，
  • obj 还实现 OpenMBeanConstructorInfoSupport 接口，
  • 它们的名称相等
  • 它们的签名相等。
这确保了此 equals 方法对作为 OpenMBeanConstructorInfoSupport 接口的不同实现的 obj 参数正常工作。

指定者：
接口 OpenMBeanConstructorInfo 中的 equals
覆盖：
类 MBeanConstructorInfo 中的 equals
参数：
obj - 与此 OpenMBeanConstructorInfoSupport 实例进行相等性比较的对象。
返回：
如果指定的对象等于此 OpenMBeanConstructorInfoSupport 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此 OpenMBeanConstructorInfoSupport 实例的哈希码值。

OpenMBeanConstructorInfoSupport 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即名称和签名，其中签名通过调用 java.util.Arrays.asList(this.getSignature).hashCode() 来计算）。

这确保 t1.equals(t2) 意味着对于任何两个 OpenMBeanConstructorInfoSupport 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

不过请注意，根据 equals(java.lang.Object) 中的定义，实现 OpenMBeanConstructorInfoSupport 接口的类的其他实例可能与此 OpenMBeanConstructorInfoSupport 实例相等，但是如果它的计算方法不同，可能会有不同的哈希码。

由于 OpenMBeanConstructorInfoSupport 实例是不可变的，此实例的哈希码在首次调用 hashCode 时计算一次，然后对于后续的调用返回相同的值。

指定者：
接口 OpenMBeanConstructorInfo 中的 hashCode
覆盖：
类 MBeanConstructorInfo 中的 hashCode
返回：
此 OpenMBeanConstructorInfoSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()

返回此 OpenMBeanConstructorInfoSupport 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.OpenMBeanConstructorInfoSupport）的名称、所描述构造方法的名称和签名及其描述符的字符串表示形式组成。

由于 OpenMBeanConstructorInfoSupport 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时被计算一次，然后对后续调用返回相同的值。

指定者：
接口 OpenMBeanConstructorInfo 中的 toString
覆盖：
类 MBeanConstructorInfo 中的 toString
返回：
此 OpenMBeanConstructorInfoSupport 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanInfoSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 OpenMBeanInfoSupport

java.lang.Object
    继承者  javax.management.MBeanInfo
        继承者  javax.management.openmbean.OpenMBeanInfoSupport
所有已实现的接口：
Serializable, Cloneable, DescriptorRead, OpenMBeanInfo
public class OpenMBeanInfoSupport
extends MBeanInfo
implements OpenMBeanInfo

OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。注意，open MBean 的识别方式是，如果其 getMBeanInfo() 方法返回实现 OpenMBeanInfo 接口（通常为 OpenMBeanInfoSupport）的类的实例，则可识别 open MBean。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类
方法摘要
boolean | equals(Object obj) 比较指定 obj 参数与此 OpenMBeanInfoSupport 实例的相等性。
int | hashCode() 返回此 OpenMBeanInfoSupport 实例的哈希码值。
String | toString() 返回此 OpenMBeanInfoSupport 实例的字符串表示形式。
从类 javax.management.MBeanInfo 继承的方法
clone, getAttributes, getClassName, getConstructors, getDescription, getDescriptor, getNotifications, getOperations
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.management.openmbean.OpenMBeanInfo 继承的方法
getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations

构造方法详细信息

OpenMBeanInfoSupport

public OpenMBeanInfoSupport(String className,
                            String description,
                            OpenMBeanAttributeInfo[] openAttributes,
                            OpenMBeanConstructorInfo[] openConstructors,
                            OpenMBeanOperationInfo[] openOperations,
                            MBeanNotificationInfo[] notifications)

构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。

openAttributes、openConstructors、openOperations 和 notifications 数组参数是被内部复制的，因此对这些参数引用的数组的后续更改不影响此实例。

参数：
className - 此 OpenMBeanInfoSupport 实例描述的 open MBean 的完全限定的 Java 类名。
description - 此 OpenMBeanInfoSupport 实例描述的 open MBean 的可读描述。
openAttributes - 所描述的 open MBean 的公开属性的列表；必须是 MBeanAttributeInfo（通常为 OpenMBeanAttributeInfoSupport）的子类的实例组成的数组。
openConstructors - 所描述的 open MBean 的公开的公用构造方法的列表；必须是 MBeanConstructorInfo（通常为 OpenMBeanConstructorInfoSupport）的子类的实例组成的数组。
openOperations - 所描述的 open MBean 的公开操作的列表。必须是 MBeanOperationInfo（通常为 OpenMBeanOperationInfoSupport）的子类的实例组成的数组。
notifications - 所描述的 open MBean 发出的通知列表。
抛出：
ArrayStoreException - 如果 openAttributes、openConstructors、openOperations 分别不是 MBeanAttributeInfo、MBeanConstructorInfo、MBeanOperationInfo 子类的实例组成的数组。

OpenMBeanInfoSupport

public OpenMBeanInfoSupport(String className,
                            String description,
                            OpenMBeanAttributeInfo[] openAttributes,
                            OpenMBeanConstructorInfo[] openConstructors,
                            OpenMBeanOperationInfo[] openOperations,
                            MBeanNotificationInfo[] notifications,
                            Descriptor descriptor)

构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

openAttributes、openConstructors、openOperations 和 notifications 数组参数是被内部复制的，因此对这些参数引用的数组的后续更改不影响此实例

参数：
className - 此 OpenMBeanInfoSupport 实例描述的 open MBean 的完全限定的 Java 类名。
description - 此 OpenMBeanInfoSupport 实例描述的 open MBean 的可读描述。
openAttributes - 所描述的 open MBean 的公开属性的列表；必须是 MBeanAttributeInfo（通常为 OpenMBeanAttributeInfoSupport）的子类的实例组成的数组。
openConstructors - 所描述的 open MBean 的公开的公用构造方法的列表；必须是 MBeanConstructorInfo（通常为 OpenMBeanConstructorInfoSupport）的子类的实例组成的数组。
openOperations - 所描述的 open MBean 的公开操作的列表。必须是 MBeanOperationInfo（通常为 OpenMBeanOperationInfoSupport）的子类的实例组成的数组。
notifications - 所描述的 open MBean 发出的通知列表。
descriptor - MBean 的描述符。此参数可以为 null，等效于空描述符。
抛出：
ArrayStoreException - 如果 openAttributes、openConstructors、openOperations 分别不是 MBeanAttributeInfo、MBeanConstructorInfo、MBeanOperationInfo 子类的实例组成的数组。
从以下版本开始：
1.6
方法详细信息

equals

public boolean equals(Object obj)
比较指定 obj 参数与此 OpenMBeanInfoSupport 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null，
  • obj 还实现 OpenMBeanInfo 接口，
  • 它们的类名相等
  • 它们的关于属性、构造方法、操作和通知的信息相等
这确保了此 equals 方法对作为 OpenMBeanInfo 接口的不同实现的 obj 参数正常工作。

指定者：
接口 OpenMBeanInfo 中的 equals
覆盖：
类 MBeanInfo 中的 equals
参数：
obj - 与此 OpenMBeanInfoSupport 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanInfoSupport 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此 OpenMBeanInfoSupport 实例的哈希码值。

OpenMBeanInfoSupport 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即类名和关于属性、构造方法、操作和通知的信息，其中每个数组的 hashCode 都通过调用 new java.util.HashSet(java.util.Arrays.asList(this.getSignature)).hashCode() 来计算）。

这确保 t1.equals(t2) 意味着对于任何两个 OpenMBeanInfoSupport 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

不过请注意，根据 equals(java.lang.Object) 中的定义，实现 OpenMBeanInfo 接口的类的其他实例可能与此 OpenMBeanInfoSupport 实例相等，但是如果它的计算方法不同，可能会有不同的哈希码。

由于 OpenMBeanInfoSupport 实例是不可变的，此实例的哈希码在首次调用 hashCode 时被计算，因此对后续调用返回相同的值。

指定者：
接口 OpenMBeanInfo 中的 hashCode
覆盖：
类 MBeanInfo 中的 hashCode
返回：
此 OpenMBeanInfoSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()

返回此 OpenMBeanInfoSupport 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.OpenMBeanInfoSupport）的名称、MBean 类名、关于所描述 MBean 的属性、构造方法、操作、通知信息的字符串表示形式以及描述符的字符串表示形式组成。

由于 OpenMBeanInfoSupport 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时被计算一次，然后对后续调用返回相同的值。

指定者：
接口 OpenMBeanInfo 中的 toString
覆盖：
类 MBeanInfo 中的 toString
返回：
此 OpenMBeanInfoSupport 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanOperationInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 OpenMBeanOperationInfo

所有已知实现类：
OpenMBeanOperationInfoSupport
public interface OpenMBeanOperationInfo

描述 Open MBean 的操作。

此接口声明的方法与类 MBeanOperationInfo 相同。实现此接口的类（通常为 OpenMBeanOperationInfoSupport）应扩展 MBeanOperationInfo。

getSignature() 方法应在运行时返回实现 OpenMBeanParameterInfo 接口的 MBeanParameterInfo 的子类的实例数组（通常为 OpenMBeanParameterInfoSupport）。

从以下版本开始：
1.5

方法摘要
boolean | equals(Object obj) 比较指定 obj 参数与此 OpenMBeanOperationInfo 实例的相等性。
String | getDescription() 返回此 OpenMBeanOperationInfo 实例描述的操作的可读描述。
int | getImpact() 返回一个 int 常量，该常量限定此 OpenMBeanOperationInfo 实例描述的操作的效果。
String | getName() 返回此 OpenMBeanOperationInfo 实例描述的操作名称。
OpenType<?> | getReturnOpenType() 返回此 OpenMBeanOperationInfo 描述的操作所返回的值的开放类型。
String | getReturnType() 返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的完全限定的 Java 类名。
MBeanParameterInfo[] | getSignature() 返回 OpenMBeanOperationInfo 实例的数组，该实例描述此 OpenMBeanParameterInfo 实例所描述操作的签名中的每个参数。
int | hashCode() 返回此 OpenMBeanOperationInfo 实例的哈希码值。
String | toString() 返回此 OpenMBeanOperationInfo 实例的字符串表示形式。

方法详细信息

getDescription

String getDescription()
返回此 OpenMBeanOperationInfo 实例描述的操作的可读描述。

返回：
描述。

getName

String getName()
返回此 OpenMBeanOperationInfo 实例描述的操作名称。

返回：
名称。

getSignature

MBeanParameterInfo[] getSignature()
返回 OpenMBeanOperationInfo 实例的数组，该实例描述此 OpenMBeanParameterInfo 实例所描述操作的签名中的每个参数。返回数组中的每个实例实际上是实现 OpenMBeanParameterInfo 接口（通常为 OpenMBeanParameterInfoSupport）的 MBeanParameterInfo 的一个子类。

返回：
签名。

getImpact

int getImpact()
返回一个 int 常量，该常量限定此 OpenMBeanOperationInfo 实例描述的操作的效果。 返回的常量是 MBeanOperationInfo.INFO、MBeanOperationInfo.ACTION 或 MBeanOperationInfo.ACTION_INFO 之一。

返回：
效果代码。

getReturnType

String getReturnType()
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的完全限定的 Java 类名。此方法应返回与调用 getReturnOpenType().getClassName() 相同的值。

返回：
返回类型。

getReturnOpenType

OpenType<?> getReturnOpenType()
返回此 OpenMBeanOperationInfo 描述的操作所返回的值的开放类型。

返回：
返回类型。

equals

boolean equals(Object obj)
比较指定 obj 参数与此 OpenMBeanOperationInfo 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null；
  • obj 还实现 OpenMBeanOperationInfo 接口；
  • 它们的名称相等；
  • 它们的签名相等；
  • 它们的返回开放类型相等；
  • 它们的效果相等。
这确保了此 equals 方法对作为 OpenMBeanOperationInfo 接口的不同实现的 obj 参数正常工作。

覆盖：
类 Object 中的 equals
参数：
obj - 与此 OpenMBeanOperationInfo 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanOperationInfo 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 OpenMBeanOperationInfo 实例的哈希码值。

OpenMBeanOperationInfo 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即其名称、返回开放类型、效果和签名，其中签名哈希码通过调用 java.util.Arrays.asList(this.getSignature).hashCode() 来计算）。

这确保了 t1.equals(t2) 意味着对于任何两个 OpenMBeanOperationInfo 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
此 OpenMBeanOperationInfo 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 OpenMBeanOperationInfo 实例的字符串表示形式。

字符串表示形式由此类（即javax.management.openmbean.OpenMBeanOperationInfo）的名称和所描述操作的名称、签名、返回开放类型和效果组成。

覆盖：
类 Object 中的 toString
返回：
此 OpenMBeanOperationInfo 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanOperationInfoSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 OpenMBeanOperationInfoSupport

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanOperationInfo
            继承者  javax.management.openmbean.OpenMBeanOperationInfoSupport
所有已实现的接口：
Serializable, Cloneable, DescriptorRead, OpenMBeanOperationInfo
public class OpenMBeanOperationInfoSupport
extends MBeanOperationInfo
implements OpenMBeanOperationInfo

描述 Open MBean 的一个操作。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanOperationInfo 继承的字段
ACTION, ACTION_INFO, INFO, UNKNOWN
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。
方法摘要
boolean | equals(Object obj) 比较指定的 obj 参数与此 OpenMBeanOperationInfoSupport 实例的相等性。
OpenType<?> | getReturnOpenType() 返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。
int | hashCode() 返回此 OpenMBeanOperationInfoSupport 实例的哈希码值。
String | toString() 返回此 OpenMBeanOperationInfoSupport 实例的字符串表示形式。
从类 javax.management.MBeanOperationInfo 继承的方法
clone, getImpact, getReturnType, getSignature
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.management.openmbean.OpenMBeanOperationInfo 继承的方法
getDescription, getImpact, getName, getReturnType, getSignature

构造方法详细信息

OpenMBeanOperationInfoSupport

public OpenMBeanOperationInfoSupport(String name,
                                     String description,
                                     OpenMBeanParameterInfo[] signature,
                                     OpenType<?> returnOpenType,
                                     int impact)

构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。

signature 数组参数是被内部复制的，因此对 signature 引用的数组的后续更改不影响此实例。

参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
signature - 如果没有要描述的任何参数，可以为 null 或空。
returnOpenType - 不可以为 null：将 SimpleType.VOID 用于不返回任何内容的操作。
impact - 只能是 ACTION、ACTION_INFO、INFO 或 UNKNOWN 之一。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串；如果 returnOpenType 为 null；如果 impact 不是 ACTION、ACTION_INFO、INFO 或 UNKNOWN 之一。
ArrayStoreException - 如果 signature 不是 MBeanParameterInfo 的子类实例的数组。

OpenMBeanOperationInfoSupport

public OpenMBeanOperationInfoSupport(String name,
                                     String description,
                                     OpenMBeanParameterInfo[] signature,
                                     OpenType<?> returnOpenType,
                                     int impact,
                                     Descriptor descriptor)

构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。

signature 数组参数是被内部复制的，因此对 signature 引用的数组的后续更改不影响此实例。

参数：
name - 不可以为 null 或空字符串。
description - 不可以为 null 或空字符串。
signature - 如果没有要描述的任何参数，可以为 null 或空。
returnOpenType - 不可以为 null：将 SimpleType.VOID 用于不返回任何内容的操作。
impact - 必须为 ACTION、ACTION_INFO、INFO 或 UNKNOWN 之一。
descriptor - 操作的描述符。此参数可以为 null，其等效于一个空描述符。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或 空字符串；如果 returnOpenType 为 null；如果 impact 不是 ACTION、ACTION_INFO、INFO 或 UNKNOWN 之一。
ArrayStoreException - 如果 signature 不是 MBeanParameterInfo 的子类实例的数组。
从以下版本开始：
1.6
方法详细信息

getReturnOpenType

public OpenType<?> getReturnOpenType()
返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。

指定者：
接口 OpenMBeanOperationInfo 中的 getReturnOpenType
返回：
返回类型。

equals

public boolean equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanOperationInfoSupport 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null，
  • obj 还实现 OpenMBeanOperationInfo 接口，
  • 它们的名称相等
  • 它们的签名相等
  • 它们的返回开放类型相等
  • 它们的效果相等
这确保了此 equals 方法对作为 OpenMBeanOperationInfo 接口的不同实现的 obj 参数正常工作。

指定者：
接口 OpenMBeanOperationInfo 中的 equals
覆盖：
类 MBeanOperationInfo 中的 equals
参数：
obj - 与此 OpenMBeanOperationInfoSupport 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanOperationInfoSupport 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此 OpenMBeanOperationInfoSupport 实例的哈希码值。

OpenMBeanOperationInfoSupport 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即它的名称、返回开放类型、效果和签名，其中签名哈希码通过调用 java.util.Arrays.asList(this.getSignature).hashCode() 来计算）。

这确保 t1.equals(t2) 意味着对于任何两个 OpenMBeanOperationInfoSupport 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

不过请注意，根据 equals(java.lang.Object) 中的定义，实现 OpenMBeanOperationInfo 接口的类的其他实例可能与此 OpenMBeanOperationInfoSupport 实例相等，但是如果它的计算方法不同，可能会有不同的哈希码。

由于 OpenMBeanOperationInfoSupport 实例是不可变的，此实例的哈希码在首次调用 hashCode 时被计算，因此对后续调用返回相同的值。

指定者：
接口 OpenMBeanOperationInfo 中的 hashCode
覆盖：
类 MBeanOperationInfo 中的 hashCode
返回：
此 OpenMBeanOperationInfoSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()

返回此 OpenMBeanOperationInfoSupport 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.OpenMBeanOperationInfoSupport）的名称和所描述操作的名称、签名、返回开放类型和效果组成。

由于 OpenMBeanOperationInfoSupport 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时被计算一次，然后对后续调用返回相同的值。

指定者：
接口 OpenMBeanOperationInfo 中的 toString
覆盖：
类 MBeanOperationInfo 中的 toString
返回：
此 OpenMBeanOperationInfoSupport 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanParameterInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 OpenMBeanParameterInfo

所有已知子接口：
OpenMBeanAttributeInfo
所有已知实现类：
OpenMBeanAttributeInfoSupport, OpenMBeanParameterInfoSupport
public interface OpenMBeanParameterInfo

描述用于 open MBean 的一个或多个操作或构造方法的参数。

此接口声明的方法与类 MBeanParameterInfo 相同。实现此接口的类（通常为 OpenMBeanParameterInfoSupport）应扩展 MBeanParameterInfo。

从以下版本开始：
1.5

方法摘要
boolean | equals(Object obj) 比较指定的 obj 参数与此 OpenMBeanParameterInfo 实例的相等性。
Object | getDefaultValue() 返回此参数的默认值（如果存在），否则返回 null。
String | getDescription() 返回此 OpenMBeanParameterInfo 实例描述的参数的可读描述。
Set<?> | getLegalValues() 返回此参数的合法值的集合（如果存在），否则返回 null。
Comparable<?> | getMaxValue() 返回此参数的最大值（如果存在），否则返回 null。
Comparable<?> | getMinValue() 返回此参数的最小值（如果存在），否则返回 null。
String | getName() 返回此 OpenMBeanParameterInfo 实例描述的参数名称。
OpenType<?> | getOpenType() 返回此 OpenMBeanParameterInfo 实例描述的参数值的开放类型。
boolean | hasDefaultValue() 如果此参数存在指定的默认值，则返回 true，否则返回 false。
int | hashCode() 返回此 OpenMBeanParameterInfo 实例的哈希码值。
boolean | hasLegalValues() 如果此参数存在指定的合法值的集合，则返回 true，否则返回 false。
boolean | hasMaxValue() 如果此参数存在指定的最大值，则返回 true，否则返回 false。
boolean | hasMinValue() 如果此参数存在指定的最小值，则返回 true，否则返回 false。
boolean | isValue(Object obj) 测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。
String | toString() 返回此 OpenMBeanParameterInfo 实例的字符串表示形式。

方法详细信息

getDescription

String getDescription()
返回此 OpenMBeanParameterInfo 实例描述的参数的可读描述。

返回：
描述。

getName

String getName()
返回此 OpenMBeanParameterInfo 实例描述的参数名称。

返回：
名称。

getOpenType

OpenType<?> getOpenType()
返回此 OpenMBeanParameterInfo 实例描述的参数值的开放类型。

返回：
开放类型。

getDefaultValue

Object getDefaultValue()
返回此参数的默认值（如果存在），否则返回 null。

返回：
默认值。

getLegalValues

Set<?> getLegalValues()
返回此参数的合法值的集合（如果存在），否则返回 null。

返回：
合法值的集合。

getMinValue

Comparable<?> getMinValue()
返回此参数的最小值（如果存在），否则返回 null。

返回：
最小值。

getMaxValue

Comparable<?> getMaxValue()
返回此参数的最大值（如果存在），否则返回 null。

返回：
最大值。

hasDefaultValue

boolean hasDefaultValue()
如果此参数存在指定的默认值，则返回 true，否则返回 false。

返回：
如果存在默认值，则返回 true。

hasLegalValues

boolean hasLegalValues()
如果此参数存在指定的合法值的集合，则返回 true，否则返回 false。

返回：
如果存在合法值的集合，则返回 true。

hasMinValue

boolean hasMinValue()
如果此参数存在指定的最小值，则返回 true，否则返回 false。

返回：
如果存在最小值，则返回 true。

hasMaxValue

boolean hasMaxValue()
如果此参数存在指定的最大值，则返回 true，否则返回 false。

返回：
如果存在最大值，则返回 true。

isValue

boolean isValue(Object obj)
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。

参数：
obj - 要测试的对象。
返回：
如果 obj 是此 OpenMBeanParameterInfo 实例描述的参数的有效值，则返回 true，否则返回 false。

equals

boolean equals(Object obj)
比较指定的 obj 参数与此 OpenMBeanParameterInfo 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null；
  • obj 还实现 OpenMBeanParameterInfo 接口；
  • 它们的名称相等；
  • 它们的开放类型相等；
  • 它们的默认值、最小值、最大值和合法值相等。
这确保了此 equals 方法对作为 OpenMBeanParameterInfo 接口的不同实现的 obj 参数正常工作。

覆盖：
类 Object 中的 equals
参数：
obj - 与 OpenMBeanParameterInfo 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanParameterInfo 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 OpenMBeanParameterInfo 实例的哈希码值。

OpenMBeanParameterInfo 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即其名称、其开放类型 及其默认值、最小值、最大值和合法值）。

这确保 t1.equals(t2) 意味着对于任何两个 OpenMBeanParameterInfo 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
此 OpenMBeanParameterInfo 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 OpenMBeanParameterInfo 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.OpenMBeanParameterInfo）的名称、名称的字符串表示形式和描述参数的开放类型，以及其默认值、最小值、最大值和合法值的字符串表示形式组成。

覆盖：
类 Object 中的 toString
返回：
此 OpenMBeanParameterInfo 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenMBeanParameterInfoSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 OpenMBeanParameterInfoSupport

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanParameterInfo
            继承者  javax.management.openmbean.OpenMBeanParameterInfoSupport
所有已实现的接口：
Serializable, Cloneable, DescriptorRead, OpenMBeanParameterInfo
public class OpenMBeanParameterInfoSupport
extends MBeanParameterInfo
implements OpenMBeanParameterInfo

描述用于 open MBean 的一个或多个操作或构造方法的参数。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。
方法摘要
boolean | equals(Object obj) 比较指定的 obj 参数与此 OpenMBeanParameterInfoSupport 实例的相等性。
Object | getDefaultValue() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数的默认值（如果指定），否则返回 null。
Set<?> | getLegalValues() 返回此 OpenMBeanParameterInfoSupport 实例描述的合法参数值的不可修改的 Set（如果指定），否则返回 null。
Comparable<?> | getMaxValue() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最大值（如果指定），否则返回 null。
Comparable<?> | getMinValue() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最小值（如果指定），否则返回 null。
OpenType<?> | getOpenType() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数值的开放类型。
boolean | hasDefaultValue() 如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的默认值，则返回 true，否则返回 false。
int | hashCode() 返回此 OpenMBeanParameterInfoSupport 实例的哈希码值。
boolean | hasLegalValues() 如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的合法值集，则返回 true，否则返回 false。
boolean | hasMaxValue() 如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最大值，则返回 true，否则返回 false。
boolean | hasMinValue() 如果此 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最小值，则返回 true，否则返回 false。
boolean | isValue(Object obj) 测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。
String | toString() 返回此 OpenMBeanParameterInfoSupport 实例的字符串表示形式。
从类 javax.management.MBeanParameterInfo 继承的方法
clone, getType
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getDescriptor, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.management.openmbean.OpenMBeanParameterInfo 继承的方法
getDescription, getName

构造方法详细信息

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType<?> openType)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

参数：
name - 不可为 null 或空字符串。
description - 不可为 null 或空字符串。
openType - 不可为 null。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType<?> openType,
                                     Descriptor descriptor)

构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

正如包描述中所解释的那样，descriptor 可以包含将定义此类某些方法返回值的项。

参数：
name - 不可为 null 或空字符串。
description - 不可为 null 或空字符串。
openType - 不可为 null。
descriptor - 参数的描述符。此参数可以为 null，其等效于一个空描述符。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串；或者 openType 为 null；或者根据包描述中的描述，描述符项无效。
从以下版本开始：
1.6

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType<T> openType,
                                     T defaultValue)
                              throws OpenDataException
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

类型参数：
T - 允许编译器查看 defaultValue（如果不为 null）是否具有对应 openType 的正确 Java 类型。
参数：
name - 不可为 null 或空字符串。
description - 不可为 null 或空字符串。
openType - 不可为 null。
defaultValue - 必须是为此参数指定的 openType 的有效值；默认值不支持 ArrayType 和 TabularType；可以为 null，在这种情况下，它意味着不设置任何默认值。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。
OpenDataException - 如果 defaultValue 不是指定 openType 的有效值，或者 defaultValue 不为 null 且 openType 为 ArrayType 或 TabularType。

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType<T> openType,
                                     T defaultValue,
                                     T[] legalValues)
                              throws OpenDataException

构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。

复制 legalValues 的内容，因此对 legalValues 引用的数组进行后续修改不会影响此 OpenMBeanParameterInfoSupport 实例。

类型参数：
T - 允许编译器查看 defaultValue 和 legalValues（如果不为 null）是否具有对应 openType 的正确 Java 类型。
参数：
name - 不可为 null 或空字符串。
description - 不可为 null 或空字符串。
openType - 不可为 null。
defaultValue - 必须是为此参数指定的 openType 的有效值；默认值不支持 ArrayType 和 TabularType；可以为 null，在这种情况下，它意味着不设置任何默认值。
legalValues - 包含的每个值对于为此参数指定的 openType 必须是有效的；ArrayType 和 TabularType 不支持的合法值；可以为 null 或空。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。
OpenDataException - 如果 defaultValue 对指定的 openType 无效；如果 legalValues 中的一个值对指定的 openType 无效；如果 defaultValue 为非 null 且 openType 为 ArrayType 或 TabularType；如果 legalValues 为非 null 和非空且 openType 为 ArrayType 或 TabularType；如果 legalValues 为非 null 和非空且 legalValues 中不包含 defaultValue。

OpenMBeanParameterInfoSupport

public OpenMBeanParameterInfoSupport(String name,
                                     String description,
                                     OpenType<T> openType,
                                     T defaultValue,
                                     Comparable<T> minValue,
                                     Comparable<T> maxValue)
                              throws OpenDataException
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。只有值是 Comparable 的开放类型才能指定最小值和最大值。

类型参数：
T - 允许编译器查看 defaultValue、minValue 和 maxValue（如果不为 null）是否具有对应 openType 的正确 Java 类型。
参数：
name - 不可为 null 或空字符串。
description - 不可为 null 或空字符串。
openType - 不可为 null。
defaultValue - 必须是为此参数指定的 openType 的有效值；默认值不支持 ArrayType 和 TabularType；可以为 null，在这种情况下，它意味着不设置任何默认值。
minValue - 必须对为此参数指定的 openType 有效；可以为 null，在这种情况下，它意味着不设置任何最小值。
maxValue - 必须对为此参数指定的 openType 有效；可以为 null，在这种情况下，它意味着不设置任何最大值。
抛出：
IllegalArgumentException - 如果 name 或 description 为 null 或空字符串，或者 openType 为 null。
OpenDataException - 如果 defaultValue、minValue 或 maxValue 不是对应指定 openType 的有效值；如果 defaultValue 不为 null 且 openType 是 ArrayType 或 TabularType；如果 minValue 和 maxValue 都不为 null 且 minValue.compareTo(maxValue) > 0 为 true；如果 defaultValue 和 minValue 都不为 null 且 minValue.compareTo(defaultValue) > 0 为 true；如果 defaultValue 和 maxValue 都不为 null 且 defaultValue.compareTo(maxValue) > 0 为 true。
方法详细信息

getOpenType

public OpenType<?> getOpenType()
返回此 OpenMBeanParameterInfoSupport 实例描述的参数值的开放类型。

指定者：
接口 OpenMBeanParameterInfo 中的 getOpenType
返回：
开放类型。

getDefaultValue

public Object getDefaultValue()
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的默认值（如果指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getDefaultValue
返回：
默认值。

getLegalValues

public Set<?> getLegalValues()
返回此 OpenMBeanParameterInfoSupport 实例描述的合法参数值的不可修改的 Set（如果指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getLegalValues
返回：
合法值的集合。

getMinValue

public Comparable<?> getMinValue()
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最小值（如果指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getMinValue
返回：
最小值。

getMaxValue

public Comparable<?> getMaxValue()
返回此 OpenMBeanParameterInfoSupport 实例描述的参数的最大值（如果指定），否则返回 null。

指定者：
接口 OpenMBeanParameterInfo 中的 getMaxValue
返回：
最大值。

hasDefaultValue

public boolean hasDefaultValue()
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的默认值，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasDefaultValue
返回：
如果存在默认值，则返回 true。

hasLegalValues

public boolean hasLegalValues()
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的合法值集，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasLegalValues
返回：
如果存在合法值的集合，则返回 true。

hasMinValue

public boolean hasMinValue()
如果此 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最小值，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasMinValue
返回：
如果存在最小值，则返回 true。

hasMaxValue

public boolean hasMaxValue()
如果 OpenMBeanParameterInfoSupport 实例指定所描述参数的非 null 的最大值，则返回 true，否则返回 false。

指定者：
接口 OpenMBeanParameterInfo 中的 hasMaxValue
返回：
如果存在最大值，则返回 true。

isValue

public boolean isValue(Object obj)
测试 obj 是否为此 OpenMBeanParameterInfo 实例描述的参数的有效值。

指定者：
接口 OpenMBeanParameterInfo 中的 isValue
参数：
obj - 要测试的对象。
返回：
如果 obj 是此 OpenMBeanParameterInfo 实例描述的参数的有效值，则返回 true，否则返回 false。

equals

public boolean equals(Object obj)

比较指定的 obj 参数与此 OpenMBeanParameterInfoSupport 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null
  • obj 还实现 OpenMBeanParameterInfo 接口
  • 它们的名称相等
  • 它们的开放类型相等
  • 它们的默认值、最小值、最大值和合法值相等。
这确保了此 equals 方法对作为 OpenMBeanParameterInfo 接口的不同实现的 obj 参数正常工作。

如果 obj 还实现 DescriptorRead，则其 getDescriptor() 必须为此对象返回相同的值。

指定者：
接口 OpenMBeanParameterInfo 中的 equals
覆盖：
类 MBeanParameterInfo 中的 equals
参数：
obj - 与 OpenMBeanParameterInfoSupport 实例进行相等性比较的对象；
返回：
如果指定的对象等于此 OpenMBeanParameterInfoSupport 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此 OpenMBeanParameterInfoSupport 实例的哈希码值。

OpenMBeanParameterInfoSupport 实例的哈希码是在 equals 比较中使用的所有信息元素的哈希码的总和（即其名称、开放类型、默认值、最小值、最大值、合法值和描述符）。

这确保 t1.equals(t2) 意味着对于任何两个 OpenMBeanParameterInfoSupport 实例 t1 和 t2 而言，都存在 @code t1.hashCode()==t2.hashCode()}，这是方法 Object.hashCode() 的通用协定所要求的。

不过请注意，根据 equals(java.lang.Object) 中的定义，实现 OpenMBeanParameterInfo 接口的类的其他实例可能与此 OpenMBeanParameterInfoSupport 实例相等，但是如果它的计算方法不同，可能会有不同的哈希码。

由于 OpenMBeanParameterInfoSupport 实例是不可变的，此实例的哈希码在首次调用 hashCode 时被计算一次，然后对后续调用返回相同的值。

指定者：
接口 OpenMBeanParameterInfo 中的 hashCode
覆盖：
类 MBeanParameterInfo 中的 hashCode
返回：
此 OpenMBeanParameterInfoSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 OpenMBeanParameterInfoSupport 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.OpenMBeanParameterInfoSupport）的名称、名称的字符串表示形式和所描述参数的开放类型、默认值、最小值、最大值、合法值的字符串表示形式以及其描述符的字符串表示形式组成。

由于 OpenMBeanParameterInfoSupport 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时被计算一次，然后对后续调用返回相同的值。

指定者：
接口 OpenMBeanParameterInfo 中的 toString
覆盖：
类 MBeanParameterInfo 中的 toString
返回：
此 OpenMBeanParameterInfoSupport 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OpenType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 OpenType<T>

java.lang.Object
    继承者  javax.management.openmbean.OpenType<T>
类型参数：
T - Java 类型，本类描述的实例必须具有这一类型。例如，SimpleType.INTEGER 是 SimpleType<Integer>，而后者是 OpenType<Integer> 的子类，这意味着描述为 SimpleType.INTEGER 的属性、参数或者返回值必须具有 Java 类型 Integer。
所有已实现的接口：
Serializable
直接已知子类：
ArrayType, CompositeType, SimpleType, TabularType
public abstract class OpenType<T>
extends Object
implements Serializable

OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。

开放类型 定义如下：

  • 此类型描述的开放数据值的完全限定的 Java 类名；注意，对于开放数据值，仅考虑有限的 Java 类集合（请参阅 LIST ALLOWED_CLASSNAMES LIST）。
  • 开放类型的名称。
  • 开放类型的描述。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static String[] | ALLOWED_CLASSNAMES 已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。
static List<String> | ALLOWED_CLASSNAMES_LIST 开放数据值允许的 Java 类的完全限定名称的列表。
构造方法摘要
protected OpenType(String className, String typeName, String description)
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。
方法摘要
abstract boolean | equals(Object obj) 比较指定的 obj 参数与此开放类型实例的相等性。
String | getClassName() 返回此开放类型描述的开放数据值的完全限定的 Java 类名。
String | getDescription() 返回此 OpenType 实例的文本描述。
String | getTypeName() 返回此 OpenType 实例的名称。
abstract int | hashCode() 返回该对象的哈希码值。
boolean | isArray() 如果此开放类型描述的开放数据值是数组，则返回 true，否则返回 false。
abstract boolean | isValue(Object obj) 测试 obj 是否为此开放类型的值。
abstract String | toString() 返回此开放类型实例的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ALLOWED_CLASSNAMES_LIST

public static final List<String> ALLOWED_CLASSNAMES_LIST
开放数据值允许的 Java 类的完全限定名称的列表。这些类的任何一个类的多维数组也是开放数据值允许的数组。
ALLOWED_CLASSNAMES_LIST = {
        "java.lang.Void",
        "java.lang.Boolean",
        "java.lang.Character",
        "java.lang.Byte",
        "java.lang.Short",
        "java.lang.Integer",
"java.lang.Long",
        "java.lang.Float",
        "java.lang.Double",
        "java.lang.String",
        "java.math.BigDecimal",
        "java.math.BigInteger",
        "java.util.Date",
        "javax.management.ObjectName",
        CompositeData.class.getName(),
        TabularData.class.getName() } ;

ALLOWED_CLASSNAMES

@Deprecated
public static final String[] ALLOWED_CLASSNAMES
已过时。 使用 ALLOWED_CLASSNAMES_LIST 取代。
构造方法详细信息

OpenType

protected OpenType(String className,
                   String typeName,
                   String description)
            throws OpenDataException
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。下面描述了每个参数的有效性约束。

参数：
className - 此开放类型描述的开放数据值的完全限定的 Java 类名。在 ALLOWED_CLASSNAMES_LIST 中列出了开放数据值允许的有效 Java 类名。这些类或其相应的基本类型中任何一个类的多维数组也是一个允许的类，在这种情况下，类名遵循 java.lang.Class 的 getName() 方法定义的规则。例如，字符串的 3 维数组的类名是 "[[[Ljava.lang.String;"（不带引号）。
typeName - 为此实例表示的开放类型给出的名称；不可为 null 或空字符串。
description - 此实例表示的开放类型的可读描述；不可为 null 或空字符串。
抛出：
IllegalArgumentException - 如果 className、typeName 或 description 为 null 或空字符串
OpenDataException - 如果 className 不是开放数据允许的 Java 类名之一
方法详细信息

getClassName

public String getClassName()
返回此开放类型描述的开放数据值的完全限定的 Java 类名。在 ALLOWED_CLASSNAMES_LIST 中仅列出了开放数据值可能的 Java 类名。这些类或其相应的基本类型中任何一个类的多维数组也是一个允许的类，在这种情况下，类名遵循 java.lang.Class 的 getName() 方法定义的规则。例如，一个 String 三维数组的类名是 "[[[Ljava.lang.String;"（不包括引号）；一个 Integer 三维数组的类名是 "[[[Ljava.lang.Integer;"（不包括引号）；一个 int 三维数组的类名是 "[[[I"（不包括引号）。

返回：
类名。

getTypeName

public String getTypeName()
返回此 OpenType 实例的名称。

返回：
类型名称。

getDescription

public String getDescription()
返回此 OpenType 实例的文本描述。

返回：
描述。

isArray

public boolean isArray()
如果此开放类型描述的开放数据值是数组，则返回 true，否则返回 false。

返回：
如果这是一个数组类型，则返回 true。

isValue

public abstract boolean isValue(Object obj)
测试 obj 是否为此开放类型的值。

参数：
obj - 要测试其有效性的对象。
返回：
如果 obj 是此开放类型的值，则返回 true，否则返回 false。

equals

public abstract boolean equals(Object obj)
比较指定的 obj 参数与此开放类型实例的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的对象。
返回：
如果此对象与 obj 相等，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public abstract int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public abstract String toString()
返回此开放类型实例的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 SimpleType<T>

java.lang.Object
    继承者  javax.management.openmbean.OpenType<T>
        继承者  javax.management.openmbean.SimpleType<T>
所有已实现的接口：
Serializable
public final class SimpleType<T>
extends OpenType<T>

SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。它将其所有可能的实例预定义为 static 字段，而且没有 public 构造方法。

给定一个 SimpleType 实例，该实例描述其 Java 类名称为 className 的值，与此 SimpleType 实例的名称和描述相对应的内部字段也设置为 className。换句话说，其方法 getClassName、getTypeName 和 getDescription 都返回相同的字符串值 className。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static SimpleType<BigDecimal> | BIGDECIMAL SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。
static SimpleType<BigInteger> | BIGINTEGER SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。
static SimpleType<Boolean> | BOOLEAN SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。
static SimpleType<Byte> | BYTE SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。
static SimpleType<Character> | CHARACTER SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。
static SimpleType<Date> | DATE SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。
static SimpleType<Double> | DOUBLE SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。
static SimpleType<Float> | FLOAT SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。
static SimpleType<Integer> | INTEGER SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。
static SimpleType<Long> | LONG SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。
static SimpleType<ObjectName> | OBJECTNAME SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。
static SimpleType<Short> | SHORT SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。
static SimpleType<String> | STRING SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。
static SimpleType<Void> | VOID SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。
从类 javax.management.openmbean.OpenType 继承的字段
ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST
方法摘要
boolean | equals(Object obj) 比较指定 obj 参数与此 SimpleType 实例的相等性。
int | hashCode() 返回此 SimpleType 实例的哈希码值。
boolean | isValue(Object obj) 测试 obj 是否为此 SimpleType 实例的值。
Object | readResolve() 使用该值的唯一实例替换从 ObjectInputStream 读取的对象。
String | toString() 返回此 SimpleType 实例的字符串表示形式。
从类 javax.management.openmbean.OpenType 继承的方法
getClassName, getDescription, getTypeName, isArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

VOID

public static final SimpleType<Void> VOID
SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。

BOOLEAN

public static final SimpleType<Boolean> BOOLEAN
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。

CHARACTER

public static final SimpleType<Character> CHARACTER
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。

BYTE

public static final SimpleType<Byte> BYTE
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。

SHORT

public static final SimpleType<Short> SHORT
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。

INTEGER

public static final SimpleType<Integer> INTEGER
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。

LONG

public static final SimpleType<Long> LONG
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。

FLOAT

public static final SimpleType<Float> FLOAT
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。

DOUBLE

public static final SimpleType<Double> DOUBLE
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。

STRING

public static final SimpleType<String> STRING
SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。

BIGDECIMAL

public static final SimpleType<BigDecimal> BIGDECIMAL
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。

BIGINTEGER

public static final SimpleType<BigInteger> BIGINTEGER
SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。

DATE

public static final SimpleType<Date> DATE
SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。

OBJECTNAME

public static final SimpleType<ObjectName> OBJECTNAME
SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。

方法详细信息

isValue

public boolean isValue(Object obj)
测试 obj 是否为此 SimpleType 实例的值。

当且仅当 obj 不为 null，并且 obj 的类名称与为此 SimpleType 实例定义的 className 字段相同（即 getClassName 方法返回的类名称）时，此方法返回 true。

指定者：
类 OpenType<T> 中的 isValue
参数：
obj - 要测试的对象。
返回：
如果 obj 是此 SimpleType 实例的一个值，则返回 true。

equals

public boolean equals(Object obj)
比较指定 obj 参数与此 SimpleType 实例的相等性。

当且仅当两个 SimpleType 实例的 getClassName 方法返回相同的值时，这两个实例才相等。

指定者：
类 OpenType<T> 中的 equals
参数：
obj - 与此 SimpleType 实例进行相等性比较的对象；如果 obj 为 null 或者不是类 SimpleType 的实例，则 equals 返回 false。
返回：
如果指定的对象等于此 SimpleType 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 SimpleType 实例的哈希码值。SimpleType 实例的哈希码是 getClassName 方法返回的字符串值的哈希码。

由于 SimpleType 实例是不可变的，此实例的哈希码在首次调用 hashCode 时计算一次，然后对于后续的调用返回相同的值。

指定者：
类 OpenType<T> 中的 hashCode
返回：
此 SimpleType 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 SimpleType 实例的字符串表示形式。

该字符串表示形式由此类的名称（即 javax.management.openmbean.SimpleType）和此实例的类型名称（即此 SimpleType 实例表示的值的 Java 类名称）组成。

由于 SimpleType 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时计算一次，然后对于后续的调用返回相同的值。

指定者：
类 OpenType<T> 中的 toString
返回：
此 SimpleType 实例的字符串表示形式

readResolve

public Object readResolve()
                   throws ObjectStreamException
使用该值的唯一实例替换从 ObjectInputStream 读取的对象。

返回：
替换对象。
抛出：
ObjectStreamException - 如果读取对象不能被解析。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabularData (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
接口 TabularData

所有已知实现类：
TabularDataSupport
public interface TabularData

TabularData 接口指定特定类型的复杂开放数据 对象的行为，该对象表示了表格数据 结构。

从以下版本开始：
1.5

方法摘要
Object[] | calculateIndex(CompositeData value) 计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。
void | clear() 从此 TabularData 实例中移除所有 CompositeData 值（即各行）。
boolean | containsKey(Object[] key) 当且仅当此 TabularData 实例包含其索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
boolean | containsValue(CompositeData value) 当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
boolean | equals(Object obj) 比较指定的 obj 参数与此 TabularData 实例的相等性。
CompositeData | get(Object[] key) 返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
TabularType | getTabularType() 返回描述此 TabularData 实例的表格类型。
int | hashCode() 返回此 TabularData 实例的哈希码值。
boolean | isEmpty() 如果此 TabularData 实例中包含的 CompositeData 值的数目（即行数）为零，则返回 true。
Set<?> | keySet() 返回此 TabularData 实例中包含的 CompositeData 值（即各行）的键（即索引值）的 set 视图。
void | put(CompositeData value) 将 value 添加到此 TabularData 实例。
void | putAll(CompositeData[] values) 将 values 中的所有元素添加到此 TabularData 实例。
CompositeData | remove(Object[] key) 从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
int | size() 返回此 TabularData 实例中包含的 CompositeData 值的数目（即行数）。
String | toString() 返回此 TabularData 实例的字符串表示形式。
Collection<?> | values() 返回此 TabularData 实例中包含的 CompositeData 值（即各行）的 collection 视图。

方法详细信息

getTabularType

TabularType getTabularType()
返回描述此 TabularData 实例的表格类型。

返回：
表格类型。

calculateIndex

Object[] calculateIndex(CompositeData value)
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。此方法检查指定 value 的类型有效性，但不检查计算的索引是否已用于引用此 TabularData 实例中的值。

参数：
value - 要计算其在此 TabularData 实例中索引的复合数据值；必须是与此实例的行类型相同的复合类型；而且不可以为 null。
返回：
此 TabularData 实例中指定的 value 将具有的索引。
抛出：
NullPointerException - 如果 value 为 null
InvalidOpenTypeException - 如果 value 不符合此 TabularData 实例的行类型定义。

size

int size()
返回此 TabularData 实例中包含的 CompositeData 值的数目（即行数）。

返回：
包含的值的数目。

isEmpty

boolean isEmpty()
如果此 TabularData 实例中包含的 CompositeData 值的数目（即行数）为零，则返回 true。

返回：
如果此 TabularData 为空，则返回 true。

containsKey

boolean containsKey(Object[] key)
当且仅当此 TabularData 实例包含其索引为指定 key 的 CompositeData 值（即行）时，才返回 true。如果 key 为 null 或者不符合此 TabularData 实例的 TabularType 定义，则此方法仅返回 false。

参数：
key - 将测试其是否存在于此 TabularData 实例中的索引值。
返回：
如果此 TabularData 使用指定的键来索引一个行值，则返回 true。

containsValue

boolean containsValue(CompositeData value)
当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。如果 value 为 null 或者不符合此 TabularData 实例的行类型定义，则此方法仅返回 false。

参数：
value - 将测试其在此 TabularData 实例中的存在性的行值。
返回：
如果此 TabularData 实例包含指定的行值，则返回 true。

get

CompositeData get(Object[] key)
返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。

参数：
key - 要返回的行的键。
返回：
与 key 对应的值。
抛出：
NullPointerException - 如果 key 为 null
InvalidKeyException - 如果 key 不符合此 TabularData 实例的 * TabularType 定义

put

void put(CompositeData value)
将 value 添加到此 TabularData 实例。value 的复合类型必须与此实例的行类型（即 this.getTabularType().getRowType() 返回的复合类型）相同，并且此 TabularData 实例中现有值的索引不能与要添加的 value 计算的索引相同。value 的索引是根据此 TabularData 实例的 TabularType 定义计算的（请参见 TabularType.getIndexNames()）。

参数：
value - 要作为新行添加到此 TabularData 实例中的复合数据值；必须是与此实例的行类型相同的复合类型；并且不可以为 null。
抛出：
NullPointerException - 如果 value 为 null
InvalidOpenTypeException - 如果 value 不符合此 TabularData 实例的行类型定义。
KeyAlreadyExistsException - 如果根据此 TabularData 实例的 TabularType 定义计算的 value 的索引已经映射到基础 HashMap 中现有的值。

remove

CompositeData remove(Object[] key)
从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。

参数：
key - 要获取的此 TabularData 实例中值的索引；必须对此 TabularData 实例的行类型定义有效；并且不可以为 null。
返回：
以前与指定键相关联的值，如果没有该键的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null
InvalidKeyException - 如果 key 不符合此 TabularData 实例的 TabularType 定义

putAll

void putAll(CompositeData[] values)
将 values 中的所有元素添加到此 TabularData 实例。如果根据此 TabularData 实例的 TabularType 定义计算的 values 中的任何元素都不满足 put 中定义的约束，或者 values 中的任何两个元素具有相同的索引，则抛出一个描述失败的异常，并且不添加 values 的任何元素，因此，此 TabularData 实例保持不变。

参数：
values - 作为新行添加到此 TabularData 实例的复合数据值的数组；如果 values 为 null 或者为空，则此方法直接返回且不执行任何操作。
抛出：
NullPointerException - 如果 values 的一个元素为 null
InvalidOpenTypeException - 如果 values 的某个元素不符合此 TabularData 实例的行类型定义
KeyAlreadyExistsException - 如果根据此 TabularData 实例的 TabularType 定义计算的 values 的某个元素的索引已经映射到此实例中现有的值，或者 values 的两个元素具有相同的索引。

clear

void clear()
从此 TabularData 实例中移除所有 CompositeData 值（即各行）。

keySet

Set<?> keySet()
返回此 TabularData 实例中包含的 CompositeData 值（即各行）的键（即索引值）的 set 视图。返回的 Set 是一个 Set<List<?>>，但出于兼容性原因被声明为 Set<?>。然后可以使用返回的 Set 对键进行迭代。

返回：
此 TabularData 实例中使用的索引值的 set 视图 (Set<List<?>>)。

values

Collection<?> values()
返回此 TabularData 实例中包含的 CompositeData 值（即各行）的 collection 视图。返回的 Collection 是一个 Collection<CompositeData><?>>，但出于兼容性原因被声明为 Collection<?>。然后可以使用返回的 collection 对值进行迭代。

返回：
此 TabularData 实例中包含的行的 collection 视图 (Collection<CompositeData>)。

equals

boolean equals(Object obj)
比较指定的 obj 参数与此 TabularData 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null
  • obj 还实现 TabularData 接口
  • 它们的行类型相同
  • 它们的内容（即值映射的索引）相等
这确保了此 equals 方法对作为 TabularData 接口的不同实现的 obj 参数正常工作。

覆盖：
类 Object 中的 equals
参数：
obj - 与此 TabularData 实例进行相等性比较的对象。
返回：
如果指定的对象等于此 TabularData 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此 TabularData 实例的哈希码值。

TabularData 实例的哈希码是在 equals 比较中使用的信息的所有元素的哈希码总和（即其表格类型 及其内容，其中内容被定义为值映射的所有索引）。

这确保 t1.equals(t2) 意味着对于任何两个 TabularDataSupport 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
此 TabularDataSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

String toString()
返回此 TabularData 实例的字符串表示形式。

该字符串表示形式由实现类的名称和此实例的表格类型组成。

覆盖：
类 Object 中的 toString
返回：
此 TabularData 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabularDataSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 TabularDataSupport

java.lang.Object
    继承者  javax.management.openmbean.TabularDataSupport
所有已实现的接口：
Serializable, Cloneable, Map<Object,Object>, TabularData
public class TabularDataSupport
extends Object
implements TabularData, Map<Object,Object>, Cloneable, Serializable

TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

从以下版本开始：
1.5
另请参见：
序列化表格

嵌套类摘要
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
构造方法摘要
TabularDataSupport(TabularType tabularType)
创建一个空 TabularDataSupport 实例，其开放类型是 tabularType，并且它的基础 HashMap 具有默认初始容量 (101) 和默认加载因子 (0.75)。
TabularDataSupport(TabularType tabularType, int initialCapacity, float loadFactor)
创建一个空 TabularDataSupport 实例，其开放类型为 tabularType，它的基础 HashMap 具有指定的初始容量和加载因子。
方法摘要
 Object[] calculateIndex(CompositeData value)
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。
 void clear()
从此 TabularDataSupport 实例中移除所有行。
 Object clone()
返回此 TabularDataSupport 实例的一个副本：通过调用 super.clone()，然后副本此基础映射，即可得到该副本。
 boolean containsKey(Object key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
 boolean containsKey(Object[] key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。
 boolean containsValue(CompositeData value)
当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
 boolean containsValue(Object value)
当且仅当此 TabularData 实例包含指定的值时，才返回 true。
 Set<Map.Entry<Object,Object>> entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。
 boolean equals(Object obj)
比较指定的 obj 参数与此 TabularDataSupport 实例的相等性。
 Object get(Object key)
此方法仅调用 get((Object[]) key)。
 CompositeData get(Object[] key)
返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
 TabularType getTabularType()
返回描述此 TabularData 实例的表格类型。
 int hashCode()
返回此 TabularDataSupport 实例的哈希码值。
 boolean isEmpty()
如果此 TabularDataSupport 实例不包含任何行，则返回 true。
 Set<Object> keySet()
返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。
 void put(CompositeData value)
将 value 添加到此 TabularData 实例。
 Object put(Object key, Object value)
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。
 void putAll(CompositeData[] values)
将 values 中的所有元素添加到此 TabularData 实例。
 void putAll(Map<?,?> t)
将包含在指定映射 t 中的所有值添加到此 TabularData 实例。
 Object remove(Object key)
此方法仅调用 remove((Object[]) key)。
 CompositeData remove(Object[] key)
从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
 int size()
返回此 TabularDataSupport 实例中的行数。
 String toString()
返回此 TabularDataSupport 实例的字符串表示形式。
 Collection<Object> values()
返回包含在此 TabularDataSupport 实例中的行的 collection 视图。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

TabularDataSupport

public TabularDataSupport(TabularType tabularType)
创建一个空 TabularDataSupport 实例，其开放类型是 tabularType，并且它的基础 HashMap 具有默认初始容量 (101) 和默认加载因子 (0.75)。

此构造方法仅调用 this(tabularType, 101, 0.75f);

参数：
tabularType - 描述此 TabularData 实例的表格类型；不可以为 null。
抛出：
IllegalArgumentException - 如果表格类型为 null。

TabularDataSupport

public TabularDataSupport(TabularType tabularType,
                          int initialCapacity,
                          float loadFactor)
创建一个空 TabularDataSupport 实例，其开放类型为 tabularType，它的基础 HashMap 具有指定的初始容量和加载因子。

参数：
tabularType - 描述此 TabularData 实例的表格类型；不可以为 null。
initialCapacity - HashMap 的初始容量。
loadFactor - HashMap 的加载因子
抛出：
IllegalArgumentException - 如果初始容量小于零或者加载因子为非正数，或者表格类型为 null。
方法详细信息

getTabularType

public TabularType getTabularType()
返回描述此 TabularData 实例的表格类型。

指定者：
接口 TabularData 中的 getTabularType
返回：
表格类型。

calculateIndex

public Object[] calculateIndex(CompositeData value)
计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。此方法检查指定 value 的类型有效性，但不检查计算的索引是否已用于引用此 TabularData 实例中的值。

指定者：
接口 TabularData 中的 calculateIndex
参数：
value - 要计算其在此 TabularData 实例中的索引的复合数据值；必须是与此实例的行类型相同的复合类型；而且不可以为 null。
返回：
此 TabularData 实例中指定的 value 将具有的索引。
抛出：
NullPointerException - 如果 value 为 null。
InvalidOpenTypeException - 如果 value 不符合此 TabularData 实例的行类型定义。

containsKey

public boolean containsKey(Object key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。如果 key 不能被强制转换成 Object 实例的一维数组，则此方法仅返回 false；否则此方法返回对 this.containsKey((Object[]) key) 调用的结果。

指定者：
接口 Map<Object,Object> 中的 containsKey
参数：
key - 将测试其是否存在于此 TabularData 实例中的索引值。
返回：
如果此 TabularData 使用指定的键索引一个行值，则返回 true。

containsKey

public boolean containsKey(Object[] key)
当且仅当此 TabularData 实例包含索引为指定 key 的 CompositeData 值（即行）时，才返回 true。如果 key 为 null 或者不符合此 TabularData 实例的 TabularType 定义，则此方法仅返回 false。

指定者：
接口 TabularData 中的 containsKey
参数：
key - 将测试其是否存在于此 TabularData 实例中的索引值。
返回：
如果此 TabularData 使用指定的键来索引一个行值，则返回 true。

containsValue

public boolean containsValue(CompositeData value)
当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。如果 value 为 null 或者不符合此 TabularData 实例的行类型定义，则此方法仅返回 false。

指定者：
接口 TabularData 中的 containsValue
参数：
value - 将测试其是否存在于此 TabularData 实例中的行值。
返回：
如果此 TabularData 实例包含指定的行值，则返回 true。

containsValue

public boolean containsValue(Object value)
当且仅当此 TabularData 实例包含指定的值时，才返回 true。

指定者：
接口 Map<Object,Object> 中的 containsValue
参数：
value - 将测试其是否存在于此 TabularData 实例中的行值。
返回：
如果此 TabularData 实例包含指定的行值，则返回 true。

get

public Object get(Object key)
此方法仅调用 get((Object[]) key)。

指定者：
接口 Map<Object,Object> 中的 get
参数：
key - 要返回其关联值的键
返回：
指定键所映射的值；如果此映射不包含该键的映射关系，则返回 null
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不属于 Object[] 类型
InvalidKeyException - 如果 key 不符合此 TabularData 实例的 TabularType 定义。

get

public CompositeData get(Object[] key)
返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。

指定者：
接口 TabularData 中的 get
参数：
key - 要获取的此 TabularData 实例中值的索引；*必须对此 TabularData 实例的行类型定义有效；*并且不可以为 null。
返回：
与 key 对应的值。
抛出：
NullPointerException - 如果 key 为 null
InvalidKeyException - 如果 key 不符合此 TabularData 实例的 TabularType 类型定义。

put

public Object put(Object key,
                  Object value)
此方法仅调用 put((CompositeData) value)，因此忽略其可能为 null 的 key 参数。

指定者：
接口 Map<Object,Object> 中的 put
参数：
key - 被忽略的参数。
value - 要放入的 CompositeData。
返回：
被放入的值
抛出：
NullPointerException - 如果 value 为 null
ClassCastException - 如果 value 不属于 CompositeData 类型
InvalidOpenTypeException - 如果 value 不符合此 TabularData 实例的 TabularType 定义
KeyAlreadyExistsException - 如果根据此 TabularData 实例的 TabularType 定义计算的 value 参数的键已经映射到一个现有的值。

put

public void put(CompositeData value)
从接口 TabularData 复制的描述
将 value 添加到此 TabularData 实例。value 的复合类型必须与此实例的行类型（即 this.getTabularType().getRowType() 返回的复合类型）相同，并且此 TabularData 实例中现有值的索引不能与要添加的 value 计算的索引相同。value 的索引是根据此 TabularData 实例的 TabularType 定义计算的（请参见 TabularType.getIndexNames()）。

指定者：
接口 TabularData 中的 put
参数：
value - 要作为新行添加到此 TabularData 实例中的复合数据值；必须是与此实例的行类型相同的复合类型；并且不可以为 null。

remove

public Object remove(Object key)
此方法仅调用 remove((Object[]) key)。

指定者：
接口 Map<Object,Object> 中的 remove
参数：
key - 表示要移除键的 Object[]。
返回：
以前与指定键相关联的值，如果没有该键的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不属于 Object[] 类型
InvalidKeyException - 如果 key 不符合此 TabularData 实例的 TabularType 定义。

remove

public CompositeData remove(Object[] key)
从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。

指定者：
接口 TabularData 中的 remove
参数：
key - 要获取的此 TabularData 实例中值的索引；必须对此 TabularData 实例的行类型定义有效；并且不可以为 null。
返回：
以前与指定键相关联的值，如果没有该键的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null
InvalidKeyException - 如果 key 不符合此 TabularData 实例的 TabularType 定义

putAll

public void putAll(Map<?,?> t)
将包含在指定映射 t 中的所有值添加到此 TabularData 实例。此方法把包含在此映射中的值的集合转换为 CompositeData 值的数组（如果可能），然后调用方法 putAll(CompositeData[])。注意，在指定映射 t 中使用的键被忽略。例如，此方法允许将具有相同行类型（但是可能有不同的索引名称）的其他 TabularData 实例的内容添加到此实例中。

指定者：
接口 Map<Object,Object> 中的 putAll
参数：
t - 其值作为新行添加到此 TabularData 实例中的映射；如果 t 为 null 或空，则此方法直接返回而不执行任何操作。
抛出：
NullPointerException - 如果 t 中的值为 null。
ClassCastException - 如果 t 中的值不是 CompositeData 的实例。
InvalidOpenTypeException - 如果 t 中的值不符合此 TabularData 实例的行类型定义。
KeyAlreadyExistsException - 如果根据此 TabularData 实例的 TabularType 定义计算的 t 中的值的索引已经映射到此实例中现有的值，或者 t 中的两个值具有相同的索引。

putAll

public void putAll(CompositeData[] values)
将 values 中的所有元素添加到此 TabularData 实例。如果根据此 TabularData 实例的 TabularType 定义计算的 values 中的任何元素都不满足 put 中定义的约束，或者 values 中的任何两个元素具有相同的索引，则抛出一个描述失败的异常，并且不添加 values 的任何元素，因此，此 TabularData 实例保持不变。

指定者：
接口 TabularData 中的 putAll
参数：
values - 作为新行添加到此 TabularData 实例的复合数据值的数组；如果 values 为 null 或者为空，则此方法直接返回且不执行任何操作。
抛出：
NullPointerException - 如果 values 的一个元素为 null
InvalidOpenTypeException - 如果 values 的某个元素不符合此 TabularData 实例的行类型定义（即其 TabularType 定义）
KeyAlreadyExistsException - 如果根据此 TabularData 实例的 TabularType 定义计算的 values 的某个元素的索引已经映射到此实例中现有的值，或者 values 的两个元素具有相同的索引

clear

public void clear()
从此 TabularDataSupport 实例中移除所有行。

指定者：
接口 Map<Object,Object> 中的 clear
指定者：
接口 TabularData 中的 clear

size

public int size()
返回此 TabularDataSupport 实例中的行数。

指定者：
接口 Map<Object,Object> 中的 size
指定者：
接口 TabularData 中的 size
返回：
此 TabularDatasupport 实例中的行数。

isEmpty

public boolean isEmpty()
如果此 TabularDataSupport 实例不包含任何行，则返回 true。

指定者：
接口 Map<Object,Object> 中的 isEmpty
指定者：
接口 TabularData 中的 isEmpty
返回：
如果此 TabularDataSupport 实例不包含任何行，则返回 true。

keySet

public Set<Object> keySet()
返回包含在此 TabularDataSupport 实例的基础映射中的键的 set 视图，并用于索引行。此 Set 中包含的每个键都是一个不可修改的 List<?>。因此返回的 set 示图是一个 Set<List<?>>，但出于兼容性原因被声明为 Set<Object>。该 set 受此 TabularDataSupport 实例的基础映射支持，所以对 TabularDataSupport 实例的更改可在此 set 中反映出来，反之亦然。该 set 支持元素的移除，通过 Iterator.remove()、Set.remove(java.lang.Object)、Set#removeAll、{@link Set#retainAll} 和 {@link Set#clear} 操作，从此 {@code TabularDataSupport} 实例中移除相应的行。它不支持 {@link Set#add} 或 {@link Set#addAll} 操作。

指定者：
接口 Map<Object,Object> 中的 keySet
指定者：
接口 TabularData 中的 keySet
返回：
用于对此 TabularDataSupport 实例的行进行索引的键的 set 视图 (Set<List<?>>)。

values

public Collection<Object> values()
返回包含在此 TabularDataSupport 实例中的行的 collection 视图。返回的 Collection 是一个 Collection<CompositeData><?>>，但出于兼容性原因被声明为 Collection<?>。该 collection 受基础映射支持，所以对 TabularDataSupport 实例的更改可在此 collection 中反映出来，反之亦然。 该集合支持元素的移除，通过 Iterator.remove()、Collection.remove(java.lang.Object)、Collection.removeAll(java.util.Collection)、Collection.retainAll(java.util.Collection) 和 Collection.clear() 操作，从此 TabularDataSupport 实例中移除相应的行映射索引。它不支持 Collection.add(E) 或 Collection.addAll(java.util.Collection) 操作。

指定者：
接口 Map<Object,Object> 中的 values
指定者：
接口 TabularData 中的 values
返回：
此 TabularDataSupport 实例中包含的值的 collection 视图 (Collection<CompositeData>)。

entrySet

public Set<Map.Entry<Object,Object>> entrySet()
返回此 TabularDataSupport 实例中包含的行映射的索引的 collection 视图。在返回的集合中，每个元素都是一个 Map.Entry<List<?>,CompositeData>，但出于兼容性原因被声明为 Map.Entry<Object,Object>。 每个映射项键都是一个不可修改的 List<?>。该 collection 受此 TabularDataSupport 实例的基础映射支持，因此对 TabularDataSupport 实例的更改会在该集合中反映出来，反之亦然。该集合支持元素的移除，通过 Iterator.remove()、Collection.remove(java.lang.Object)、Collection.removeAll(java.util.Collection)、Collection.retainAll(java.util.Collection) 和 Collection.clear() 操作，从该映射中移除相应的映射关系。它不支持 Collection.add(E) 或 Collection.addAll(java.util.Collection) 操作。

重要注意事项：不要使用返回的 collection 视图中包含的 Map.Entry 元素的 setValue 方法。这样做会破坏此 TabularDataSupport 实例中包含的行映射的索引。

指定者：
接口 Map<Object,Object> 中的 entrySet
返回：
此映射所包含的映射关系的 collection 视图 (Set<Map.Entry<List<?>,CompositeData>>)。
另请参见：
Map.Entry

clone

public Object clone()
返回此 TabularDataSupport 实例的一个副本：通过调用 super.clone()，然后副本此基础映射，即可得到该副本。仅对此基础映射进行浅表复制，也就是说，由于索引和行值是不可改变的，因此不复制它们。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

equals

public boolean equals(Object obj)
比较指定的 obj 参数与此 TabularDataSupport 实例的相等性。

当且仅当下面的所有语句均为 true 时，才返回 true：

  • obj 为非 null
  • obj 还实现 TabularData 接口
  • 它们的表格类型相同
  • 它们的内容（即所有的 CompositeData 值）相等
这确保了此 equals 方法对作为 TabularData 接口的不同实现的 obj 参数正常工作。

指定者：
接口 Map<Object,Object> 中的 equals
指定者：
接口 TabularData 中的 equals
覆盖：
类 Object 中的 equals
参数：
obj - 与此 TabularDataSupport 实例进行相等性比较的对象。
返回：
如果指定的对象等于此 TabularDataSupport 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 TabularDataSupport 实例的哈希码值。

TabularDataSupport 实例的哈希码是 equals 比较中使用的信息的所有元素的哈希码总和（即其表格类型 和内容，其中内容被定义为所有 CompositeData 值）。

这确保 t1.equals(t2) 意味着对于任何两个 TabularDataSupport 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

不过请注意，根据 equals(java.lang.Object) 中的定义，实现 TabularData 接口的类的其他实例可能与此 TabularDataSupport 实例相等，但是如果它的计算方法不同，可能会有不同的哈希码。

指定者：
接口 Map<Object,Object> 中的 hashCode
指定者：
接口 TabularData 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 TabularDataSupport 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 TabularDataSupport 实例的字符串表示形式。

该字符串表示形式由此类（即 javax.management.openmbean.TabularDataSupport）的名称、此实例的表格类型的字符串表示形式、内容的字符串表示形式（即列出按照对 dataMap. toString() 的调用所返回的 key=value 映射关系）组成。

指定者：
接口 TabularData 中的 toString
覆盖：
类 Object 中的 toString
返回：
此 TabularDataSupport 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TabularType (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.openmbean
类 TabularType

java.lang.Object
    继承者  javax.management.openmbean.OpenType<TabularData>
        继承者  javax.management.openmbean.TabularType
所有已实现的接口：
Serializable
public class TabularType
extends OpenType<TabularData>

TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.openmbean.OpenType 继承的字段
ALLOWED_CLASSNAMES, ALLOWED_CLASSNAMES_LIST
构造方法摘要
TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。
方法摘要
boolean | equals(Object obj) 比较指定的 obj 参数与此 TabularType 实例的相等性。
List<String> | getIndexNames() 按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。
CompositeType | getRowType() 返回此 TabularType 实例描述的表格数据值的行元素的类型。
int | hashCode() 返回此 TabularType 实例的哈希码值。
boolean | isValue(Object obj) 测试 obj 是否为此 TabularType 实例可以描述的值。
String | toString() 返回此 TabularType 实例的字符串表示形式。
从类 javax.management.openmbean.OpenType 继承的方法
getClassName, getDescription, getTypeName, isArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

TabularType

public TabularType(String typeName,
                   String description,
                   CompositeType rowType,
                   String[] indexNames)
            throws OpenDataException
构造一个 TabularType 实例，检查给定参数的有效性。下面描述了每个参数的有效性约束。

此表格类型表示的表格数据值的 Java 类名称（即 getClassName 方法返回的类名称）被设置为 TabularData.class.getName() 返回的字符串值。

参数：
typeName - 此实例表示的表格类型所给定的名称；不可以为 null 或空字符串。
description - 此实例表示的表格类型的可读描述；不可以为 null 或空字符串。
rowType - 此表格类型实例所描述的表格数据值的行元素类型；不可以为 null。
indexNames - 项名称，可以使用它的值唯一地索引此表格类型实例所描述的表格数据值中的每个行元素；不可以为 null 或空。每个元素都应该是 rowType 中定义的项名称（不允许为 null 或空字符串）。需要特别注意的是，TabularData 类的方法 get 和 remove 使用 indexNames 中项名称的顺序来匹配值参数数组和项。
抛出：
IllegalArgumentException - 如果 rowType 为 null；如果 indexNames 为 null 或者为空数组；如果 indexNames 中的元素为 null 或者空字符串；如果 typeName 或 description 为 null 或者空字符串。
OpenDataException - 如果 indexNames 的元素值不是 rowType 中定义的项名称。
方法详细信息

getRowType

public CompositeType getRowType()
返回此 TabularType 实例描述的表格数据值的行元素的类型。

返回：
每一行的类型。

getIndexNames

public List<String> getIndexNames()

按照提供此实例的构造方法的顺序返回一个不可修改的项名称列表，可以使用该列表的值唯一地索引此 TabularType 实例所描述的表格数据值的每个行元素。

返回：
表示索引项名称的字符串列表。

isValue

public boolean isValue(Object obj)
测试 obj 是否为此 TabularType 实例可以描述的值。

如果 obj 为 null 或者不是 javax.management.openmbean.TabularData 的实例，则 isValue 返回 false。

如果 obj 是一个 javax.management.openmbean.TabularData 的实例（如 td），则当此 TabularType 根据 CompositeType.isValue 中的定义可通过 td.getTabularType() 进行分配时，结果为 true。

指定者：
类 OpenType<TabularData> 中的 isValue
参数：
obj - 将测试其开放类型与此 TabularType 实例的相等性的值。
返回：
如果 obj 是此表格类型的值，则返回 true，否则返回 false。

equals

public boolean equals(Object obj)
比较指定的 obj 参数与此 TabularType 实例的相等性。

当且仅当下面的语句均为 true 时，两个 TabularType 实例才相等：

  • 它们的类型名称相同
  • 它们的行类型相同
  • 它们以相同的顺序使用相同的索引名称

指定者：
类 OpenType<TabularData> 中的 equals
参数：
obj - 与此 TabularType 实例进行相等性比较的对象；如果 obj 为 null，则 equals 返回 false。
返回：
如果指定的对象等于此 TabularType 实例，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 TabularType 实例的哈希码值。

TabularType 实例的哈希码是在 equals 比较中使用的信息的所有元素的哈希码总和（即名称、行类型、索引名称）。这确保了 t1.equals(t2) 意味着对于任何两个 TabularType 实例 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是方法 Object.hashCode() 的通用协定所要求的。

由于 TabularType 实例是不可变的，此实例的哈希码在首次调用 hashCode 时被计算一次，然后对后续调用返回相同的值。

指定者：
类 OpenType<TabularData> 中的 hashCode
返回：
此 TabularType 实例的哈希码值
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此 TabularType 实例的字符串表示形式。

字符串表示形式由此类（即 javax.management.openmbean.TabularType）的名称、此实例的类型名称、此实例的行类型字符串表示形式以及此实例的索引名称组成。

由于 TabularType 实例是不可变的，此实例的字符串表示形式在首次调用 toString 时被计算一次，然后对后续调用返回相同的值。

指定者：
类 OpenType<TabularData> 中的 toString
返回：
此 TabularType 实例的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.openmbean (Java 2 Platform SE 6)

 javax.management.openmbean
接口
CompositeData
CompositeDataView
OpenMBeanAttributeInfo
OpenMBeanConstructorInfo
OpenMBeanInfo
OpenMBeanOperationInfo
OpenMBeanParameterInfo
TabularData
类
ArrayType
CompositeDataInvocationHandler
CompositeDataSupport
CompositeType
OpenMBeanAttributeInfoSupport
OpenMBeanConstructorInfoSupport
OpenMBeanInfoSupport
OpenMBeanOperationInfoSupport
OpenMBeanParameterInfoSupport
OpenType
SimpleType
TabularDataSupport
TabularType
异常
InvalidKeyException
InvalidOpenTypeException
KeyAlreadyExistsException
OpenDataException


javax.management.openmbean (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.openmbean

提供开放数据类型和 Open MBean 描述符类。

请参见：
描述

接口摘要
CompositeData | CompositeData 接口指定表示复合数据 结构的复杂开放数据 对象的特定类型的行为。
CompositeDataView | Java 类可以实现此接口，以指示如何通过 MXBean 框架将其转换为 CompositeData。
OpenMBeanAttributeInfo | 描述 open MBean 的属性。
OpenMBeanConstructorInfo | 描述 Open MBean 的构造方法。
OpenMBeanInfo | 描述一个 Open MBean：Open MBean 的识别方式为，如果 Open MBean 的 getMBeanInfo() 方法返回实现 OpenMBeanInfo 接口（通常为 OpenMBeanInfoSupport）的类的实例，则可识别 Open MBean。
OpenMBeanOperationInfo | 描述 Open MBean 的操作。
OpenMBeanParameterInfo | 描述用于 open MBean 的一个或多个操作或构造方法的参数。
TabularData | TabularData 接口指定特定类型的复杂开放数据 对象的行为，该对象表示了表格数据 结构。

类摘要
ArrayType<T> | ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
CompositeDataInvocationHandler | 将获取方法转发给 CompositeData 的 InvocationHandler。
CompositeDataSupport | CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。
CompositeType | CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
OpenMBeanAttributeInfoSupport | 描述 open MBean 的一个属性。
OpenMBeanConstructorInfoSupport | 描述 Open MBean 的构造方法。
OpenMBeanInfoSupport | OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
OpenMBeanOperationInfoSupport | 描述 Open MBean 的一个操作。
OpenMBeanParameterInfoSupport | 描述用于 open MBean 的一个或多个操作或构造方法的参数。
OpenType<T> | OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。
SimpleType<T> | SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
TabularDataSupport | TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。
TabularType | TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

异常摘要
InvalidKeyException | 当方法参数作为复合数据 的项名称或表格数据 的行索引时，如果其无效，则抛出此运行时异常。
InvalidOpenTypeException | 当开放数据 值的开放类型 不是期望的类型时，抛出此运行时异常。
KeyAlreadyExistsException | 当添加到表格数据 实例的行索引已用于引用此表格数据 实例中的另一行时，抛出此运行时异常。
OpenDataException | 因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

软件包 javax.management.openmbean 的描述

提供开放数据类型和 Open MBean 描述符类。Open MBean 是一种 MBean，其中的属性和操作参数的类型和返回值是使用预定义的 Java 类的小集合构建的。Open MBeans 通过远程管理程序简化了操作，无需访问特定于应用程序的类型（包括非 Java 程序）。

每个 MBean 都有一个 MBeanInfo，它包含关于 MBean 本身、其属性、操作、构造方法和通知的信息。在 Open MBean 中，此 MBeanInfo 实现 OpenMBeanInfo 接口，通常通过作为 OpenMBeanInfoSupport 的实例来实现。

由 MBeanInfo.getAttributes 为 Open MBean 返回的属性信息是实现 OpenMBeanAttributeInfo 的对象的数组，通常为 OpenMBeanAttributeInfoSupport 的实例。除关于属性的一般信息外，OpenMBeanAttributeInfo 还指定属性的 OpenType。可能的 OpenType 值是预定义的，这可以确保远程管理人员能够理解它们。

类似的注释可应用于操作和构造方法的参数类型，以及操作的返回类型。

getType() 返回的属性的 Java 语言类型和 getOpenType() 返回的 OpenType 之间存在差别。例如，如果 Java 语言类型为 java.lang.String，则 OpenType 将为 SimpleType.String。如果 Java 语言类型为 CompositeData，则 OpenType 将为 CompositeType，它描述属性的 CompositeData 实例中的项。

默认值和约束条件

在 Open MBean 中，属性和参数可以在 OpenMBeanAttributeInfo 或 OpenMBeanParameterInfo 中拥有默认值和/或与之相关的约束条件。有两种指定这些约束条件的方法。一种是将值直接指定为 OpenMBeanAttributeInfoSupport 或 OpenMBeanParameterInfoSupport 的构造方法的一个参数，例如，OpenMBeanParameterInfoSupport.OpenMBeanParameterInfoSupport( String, String, OpenType, Object, Object[])；另一种是在作为构造方法的参数给定的 Descriptor 中指定值。

当使用 Descriptor 时，相关的字段有：

  • defaultValue 定义 getDefaultValue() 返回的值。
  • minValue 定义 getMinValue() 返回的值。
  • maxValue 定义 getMaxValue() 返回的值。
  • legalValues 定义 getLegalValues() 返回的值。

对于 defaultValue、minValue 和 maxValue，关联值必须是对应于 openType 的 Java 类型，或者是可转换为该类型的字符串。转换使用的是静态方法 valueOf(String)（如果有）；否则使用带单个 String 参数的构造方法（如果有这样的构造方法）；或者转换将失败。

对于 legalValues，关联值必须是一个数组或 Set，并且数组或 set 的元素必须能够根据对 defaultValue 等的描述进行转换。

对于这些字段必须满足以下约束条件：

  • 如上所述，值必须是恰当类型，或者是可以转换为恰当类型的字符串；
  • 如果存在 legalValues，则无须存在 minValue 和 maxValue；
  • 如果 defaultValue 存在，则当 legalValues、minValue 或 maxValue 也存在时 defaultValue 必须满足它们所定义的约束条件。
  • 如果 minValue 和 maxValue 都存在，则 minValue 不得大于 maxValue。

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology， 特别是 JMX Specification, version 1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.openmbean 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.openmbean 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.management.openmbean.CompositeDataInvocationHandler (implements java.lang.reflect.InvocationHandler)
    • javax.management.openmbean.CompositeDataSupport (implements javax.management.openmbean.CompositeData, java.io.Serializable)
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanAttributeInfoSupport (implements javax.management.openmbean.OpenMBeanAttributeInfo)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanConstructorInfoSupport (implements javax.management.openmbean.OpenMBeanConstructorInfo)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanOperationInfoSupport (implements javax.management.openmbean.OpenMBeanOperationInfo)
      • javax.management.MBeanParameterInfo (implements java.lang.Cloneable)
        • javax.management.openmbean.OpenMBeanParameterInfoSupport (implements javax.management.openmbean.OpenMBeanParameterInfo)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.openmbean.OpenMBeanInfoSupport (implements javax.management.openmbean.OpenMBeanInfo)
    • javax.management.openmbean.OpenType<T> (implements java.io.Serializable)
      • javax.management.openmbean.ArrayType<T>
      • javax.management.openmbean.CompositeType
      • javax.management.openmbean.SimpleType<T>
      • javax.management.openmbean.TabularType
    • javax.management.openmbean.TabularDataSupport (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable, javax.management.openmbean.TabularData)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.management.JMException
          • javax.management.openmbean.OpenDataException
        • java.lang.RuntimeException
          • java.lang.IllegalArgumentException
            • javax.management.openmbean.InvalidKeyException
            • javax.management.openmbean.InvalidOpenTypeException
            • javax.management.openmbean.KeyAlreadyExistsException

接口分层结构

  • javax.management.openmbean.CompositeData
  • javax.management.openmbean.CompositeDataView
  • javax.management.openmbean.OpenMBeanConstructorInfo
  • javax.management.openmbean.OpenMBeanInfo
  • javax.management.openmbean.OpenMBeanOperationInfo
  • javax.management.openmbean.OpenMBeanParameterInfo
    • javax.management.openmbean.OpenMBeanAttributeInfo
  • javax.management.openmbean.TabularData
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.openmbean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.openmbean
的使用

使用 javax.management.openmbean 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang.management 使用的 javax.management.openmbean 中的类
CompositeData
CompositeData 接口指定表示复合数据 结构的复杂开放数据 对象的特定类型的行为。

javax.management.openmbean 使用的 javax.management.openmbean 中的类
ArrayType
ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
CompositeData
CompositeData 接口指定表示复合数据 结构的复杂开放数据 对象的特定类型的行为。
CompositeType
CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
OpenDataException
因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。
OpenMBeanAttributeInfo
描述 open MBean 的属性。
OpenMBeanConstructorInfo
描述 Open MBean 的构造方法。
OpenMBeanInfo
描述一个 Open MBean：Open MBean 的识别方式为，如果 Open MBean 的 getMBeanInfo() 方法返回实现 OpenMBeanInfo 接口（通常为 OpenMBeanInfoSupport）的类的实例，则可识别 Open MBean。
OpenMBeanOperationInfo
描述 Open MBean 的操作。
OpenMBeanParameterInfo
描述用于 open MBean 的一个或多个操作或构造方法的参数。
OpenType
OpenType 类是所有类的父抽象类，它描述开放数据值的实际开放类型。
SimpleType
SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
TabularData
TabularData 接口指定特定类型的复杂开放数据 对象的行为，该对象表示了表格数据 结构。
TabularType
TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.ArrayType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.ArrayType
的使用

使用 ArrayType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 ArrayType 的使用

返回 ArrayType 的 javax.management.openmbean 中的方法
static
<E> ArrayType<E[]>
ArrayType.getArrayType(OpenType<E> elementType)
以类型安全的方式创建一个 ArrayType 实例。
static
<T> ArrayType<T>
ArrayType.getPrimitiveArrayType(Class<T> arrayClass)
以类型安全的方式创建一个 ArrayType 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.CompositeData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.CompositeData
的使用

使用 CompositeData 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

java.lang.management 中 CompositeData 的使用

参数类型为 CompositeData 的 java.lang.management 中的方法
static MemoryNotificationInfo | MemoryNotificationInfo.from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryNotificationInfo 对象。
static MemoryUsage | MemoryUsage.from(CompositeData cd) 返回由给定 CompositeData 表示的 MemoryUsage 对象。
static MonitorInfo | MonitorInfo.from(CompositeData cd) 返回给定 CompositeData 表示的 MonitorInfo 对象。
static ThreadInfo | ThreadInfo.from(CompositeData cd) 返回由给定 CompositeData 表示的 ThreadInfo 对象。

javax.management.openmbean 中 CompositeData 的使用

实现 CompositeData 的 javax.management.openmbean 中的类
 class CompositeDataSupport
CompositeDataSupport 类是实现 CompositeData 接口的开放数据 类。

返回 CompositeData 的 javax.management.openmbean 中的方法
CompositeData | TabularData.get(Object[] key) 返回此 TabularData 实例中其索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
CompositeData | TabularDataSupport.get(Object[] key) 返回此 TabularData 实例中索引为 key 的 CompositeData 值，如果没有映射到 key 的值，则返回 null。
CompositeData | CompositeDataInvocationHandler.getCompositeData() 返回提供给构造方法的 CompositeData。
CompositeData | TabularData.remove(Object[] key) 从此 TabularData 实例中移除其索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
CompositeData | TabularDataSupport.remove(Object[] key) 从此 TabularData 实例中移除索引为 key 的 CompositeData 值，并返回被移除的值，如果不存在索引为 key 的值，则返回 null。
CompositeData | CompositeDataView.toCompositeData(CompositeType ct) 返回对应于此对象中的值的 CompositeData。

参数类型为 CompositeData 的 javax.management.openmbean 中的方法
Object[] | TabularData.calculateIndex(CompositeData value) 计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例中后引用该参数。
Object[] | TabularDataSupport.calculateIndex(CompositeData value) 计算将在此 TabularData 实例中使用的索引，以便在指定的复合数据 value 参数添加到此实例后引用该参数。
boolean | TabularData.containsValue(CompositeData value) 当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
boolean | TabularDataSupport.containsValue(CompositeData value) 当且仅当此 TabularData 实例包含指定的 CompositeData 值时才返回 true。
void | TabularData.put(CompositeData value) 将 value 添加到此 TabularData 实例。
void | TabularDataSupport.put(CompositeData value)
void | TabularData.putAll(CompositeData[] values) 将 values 中的所有元素添加到此 TabularData 实例。
void | TabularDataSupport.putAll(CompositeData[] values) 将 values 中的所有元素添加到此 TabularData 实例。

参数类型为 CompositeData 的 javax.management.openmbean 中的构造方法
CompositeDataInvocationHandler(CompositeData compositeData)
构造一个受给定 CompositeData 支持的处理程序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.CompositeDataInvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.CompositeDataInvocationHandler
的使用

没有 javax.management.openmbean.CompositeDataInvocationHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.CompositeDataSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.CompositeDataSupport
的使用

没有 javax.management.openmbean.CompositeDataSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.CompositeDataView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.CompositeDataView
的使用

没有 javax.management.openmbean.CompositeDataView 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.CompositeType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.CompositeType
的使用

使用 CompositeType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 CompositeType 的使用

返回 CompositeType 的 javax.management.openmbean 中的方法
CompositeType | CompositeData.getCompositeType() 返回此复合数据 实例的复合类型。
CompositeType | CompositeDataSupport.getCompositeType() 返回此复合数据 实例的复合类型。
CompositeType | TabularType.getRowType() 返回此 TabularType 实例描述的表格数据值的行元素的类型。

参数类型为 CompositeType 的 javax.management.openmbean 中的方法
 CompositeData CompositeDataView.toCompositeData(CompositeType ct)
返回对应于此对象中的值的 CompositeData。

参数类型为 CompositeType 的 javax.management.openmbean 中的构造方法
CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。
CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。
TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.InvalidKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.InvalidKeyException
的使用

没有 javax.management.openmbean.InvalidKeyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.InvalidOpenTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.InvalidOpenTypeException
的使用

没有 javax.management.openmbean.InvalidOpenTypeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.KeyAlreadyExistsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.KeyAlreadyExistsException
的使用

没有 javax.management.openmbean.KeyAlreadyExistsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.OpenDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenDataException
的使用

使用 OpenDataException 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenDataException 的使用

抛出 OpenDataException 的 javax.management.openmbean 中的方法
static
<E> ArrayType<E[]>
ArrayType.getArrayType(OpenType<E> elementType)
以类型安全的方式创建一个 ArrayType 实例。

抛出 OpenDataException 的 javax.management.openmbean 中的构造方法
ArrayType(int dimension, OpenType<?> elementType)
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。
ArrayType(SimpleType<?> elementType, boolean primitiveArray)
为提供的 SimpleType 构造一个一维 ArrayType 实例。
CompositeDataSupport(CompositeType compositeType, Map<String,?> items)
使用指定的 compositeType（其项名称和对应值由 items 映射中的映射关系给出）构造一个 CompositeDataSupport 实例。
CompositeDataSupport(CompositeType compositeType, String[] itemNames, Object[] itemValues)
使用指定的 compositeType（其项值由 itemValues[] 按照与 itemNames[] 中相同的顺序指定）构造一个 CompositeDataSupport 实例。
CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。
OpenType(String className, String typeName, String description)
构造一个 OpenType 实例（实际上是一个子类实例，因为 OpenType 是抽象的），检查给定参数的有效性。
TabularType(String typeName, String description, CompositeType rowType, String[] indexNames)
构造一个 TabularType 实例，检查给定参数的有效性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.OpenMBeanAttributeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanAttributeInfo
的使用

使用 OpenMBeanAttributeInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanAttributeInfo 的使用

实现 OpenMBeanAttributeInfo 的 javax.management.openmbean 中的类
 class OpenMBeanAttributeInfoSupport
描述 open MBean 的一个属性。

参数类型为 OpenMBeanAttributeInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanAttributeInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanAttributeInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.OpenMBeanConstructorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanConstructorInfo
的使用

使用 OpenMBeanConstructorInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanConstructorInfo 的使用

实现 OpenMBeanConstructorInfo 的 javax.management.openmbean 中的类
 class OpenMBeanConstructorInfoSupport
描述 Open MBean 的构造方法。

参数类型为 OpenMBeanConstructorInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.OpenMBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanInfo
的使用

使用 OpenMBeanInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanInfo 的使用

实现 OpenMBeanInfo 的 javax.management.openmbean 中的类
 class OpenMBeanInfoSupport
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanConstructorInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanConstructorInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.OpenMBeanInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.OpenMBeanOperationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanOperationInfo
的使用

使用 OpenMBeanOperationInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanOperationInfo 的使用

实现 OpenMBeanOperationInfo 的 javax.management.openmbean 中的类
 class OpenMBeanOperationInfoSupport
描述 Open MBean 的一个操作。

参数类型为 OpenMBeanOperationInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.OpenMBeanOperationInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanOperationInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanOperationInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.OpenMBeanParameterInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.OpenMBeanParameterInfo
的使用

使用 OpenMBeanParameterInfo 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenMBeanParameterInfo 的使用

javax.management.openmbean 中 OpenMBeanParameterInfo 的子接口
 interface OpenMBeanAttributeInfo
描述 open MBean 的属性。

实现 OpenMBeanParameterInfo 的 javax.management.openmbean 中的类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。

参数类型为 OpenMBeanParameterInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description 和 signature 描述 open MBeans 的类的构造方法。
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.OpenMBeanParameterInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenMBeanParameterInfoSupport
的使用

没有 javax.management.openmbean.OpenMBeanParameterInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.OpenType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.OpenType
的使用

使用 OpenType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 OpenType 的使用

javax.management.openmbean 中 OpenType 的子类
class | ArrayType<T> ArrayType 类是一种开放类型 类，其实例描述了作为开放数据 值的 n 维数组的所有开放数据 值。
class | CompositeType CompositeType 类是开放类型 类，它的实例描述了 CompositeData 值的类型。
class | SimpleType<T> SimpleType 类是开放类型 类，其实例描述所有开放数据 值，这些值既不是数组，也不是 CompositeData 值，更不是 TabularData 值。
class | TabularType TabularType 类是开放类型 类，它的实例描述了 TabularData 值的类型。

返回 OpenType 的 javax.management.openmbean 中的方法
OpenType<?> | ArrayType.getElementOpenType() 返回此 ArrayType 实例描述的数组中包含的元素值的开放类型。
OpenType<?> | OpenMBeanAttributeInfoSupport.getOpenType() 返回此 OpenMBeanAttributeInfoSupport 实例描述的属性值的开放类型。
OpenType<?> | OpenMBeanParameterInfo.getOpenType() 返回此 OpenMBeanParameterInfo 实例描述的参数值的开放类型。
OpenType<?> | OpenMBeanParameterInfoSupport.getOpenType() 返回此 OpenMBeanParameterInfoSupport 实例描述的参数值的开放类型。
OpenType<?> | OpenMBeanOperationInfo.getReturnOpenType() 返回此 OpenMBeanOperationInfo 描述的操作所返回的值的开放类型。
OpenType<?> | OpenMBeanOperationInfoSupport.getReturnOpenType() 返回此 OpenMBeanOperationInfo 实例描述的操作所返回的值的开放类型。
OpenType<?> | CompositeType.getType(String itemName) 返回名称是 itemName 的项的开放类型，如果 CompositeType 实例未定义任何名称是 itemName 的项，则返回 null。

参数类型为 OpenType 的 javax.management.openmbean 中的方法
static
<E> ArrayType<E[]>
ArrayType.getArrayType(OpenType<E> elementType)
以类型安全的方式创建一个 ArrayType 实例。

参数类型为 OpenType 的 javax.management.openmbean 中的构造方法
ArrayType(int dimension, OpenType<?> elementType)
构造一个描述开放数据 值的 ArrayType 实例，该值是其元素的开放类型 为 elementType、元素的维度为 dimension 的数组。
CompositeType(String typeName, String description, String[] itemNames, String[] itemDescriptions, OpenType<?>[] itemTypes)
构造一个 CompositeType 实例，检查给定参数的有效性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、<openType 和 description 以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue，以及制定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 来描述 open MBean 的属性。
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<T> openType, boolean isReadable, boolean isWritable, boolean isIs, T defaultValue, T[] legalValues)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、legalValues，以及指定的读/写访问属性来描述 open MBean 的属性。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType 和 impact 描述 open MBeans 的类的操作。
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType 和 description 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 defaultValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, Comparable<T> minValue, Comparable<T> maxValue)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue、minValue 和 maxValue 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<T> openType, T defaultValue, T[] legalValues)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description、defaultValue 和 legalValues 来描述一个或多个操作或 open MBean 类的构造方法所使用的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.SimpleType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.SimpleType
的使用

使用 SimpleType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 SimpleType 的使用

声明为 SimpleType 的 javax.management.openmbean 中的字段
static SimpleType<BigDecimal> | SimpleType.BIGDECIMAL SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigDecimal 的值。
static SimpleType<BigInteger> | SimpleType.BIGINTEGER SimpleType 实例，该实例描述其 Java 类名称为 java.math.BigInteger 的值。
static SimpleType<Boolean> | SimpleType.BOOLEAN SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Boolean 的值。
static SimpleType<Byte> | SimpleType.BYTE SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Byte 的值。
static SimpleType<Character> | SimpleType.CHARACTER SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Character 的值。
static SimpleType<Date> | SimpleType.DATE SimpleType 实例，该实例描述其 Java 类名称为 java.util.Date 的值。
static SimpleType<Double> | SimpleType.DOUBLE SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Double 的值。
static SimpleType<Float> | SimpleType.FLOAT SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Float 的值。
static SimpleType<Integer> | SimpleType.INTEGER SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Integer 的值。
static SimpleType<Long> | SimpleType.LONG SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Long 的值。
static SimpleType<ObjectName> | SimpleType.OBJECTNAME SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。
static SimpleType<Short> | SimpleType.SHORT SimpleType 实例，该实例描述其 Java 类名称为 java.lang.Short 的值。
static SimpleType<String> | SimpleType.STRING SimpleType 实例，该实例描述其 Java 类名称为 java.lang.String 的值。
static SimpleType<Void> | SimpleType.VOID SimpleType 实例描述其 Java 类名称为 java.lang.Void 的值。

参数类型为 SimpleType 的 javax.management.openmbean 中的构造方法
ArrayType(SimpleType<?> elementType, boolean primitiveArray)
为提供的 SimpleType 构造一个一维 ArrayType 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.openmbean.TabularData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.openmbean.TabularData
的使用

使用 TabularData 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 TabularData 的使用

实现 TabularData 的 javax.management.openmbean 中的类
 class TabularDataSupport
TabularDataSupport 类是实现 TabularData 和 Map 接口的开放数据 类，并且在内部它是基于哈希映射数据结构的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.TabularDataSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.TabularDataSupport
的使用

没有 javax.management.openmbean.TabularDataSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.openmbean.TabularType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.openmbean.TabularType
的使用

使用 TabularType 的软件包
javax.management.openmbean 提供开放数据类型和 Open MBean 描述符类。

javax.management.openmbean 中 TabularType 的使用

返回 TabularType 的 javax.management.openmbean 中的方法
TabularType | TabularData.getTabularType() 返回描述此 TabularData 实例的表格类型。
TabularType | TabularDataSupport.getTabularType() 返回描述此 TabularData 实例的表格类型。

参数类型为 TabularType 的 javax.management.openmbean 中的构造方法
TabularDataSupport(TabularType tabularType)
创建一个空 TabularDataSupport 实例，其开放类型是 tabularType，并且它的基础 HashMap 具有默认初始容量 (101) 和默认加载因子 (0.75)。
TabularDataSupport(TabularType tabularType, int initialCapacity, float loadFactor)
创建一个空 TabularDataSupport 实例，其开放类型为 tabularType，它的基础 HashMap 具有指定的初始容量和加载因子。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


DescriptorSupport (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 DescriptorSupport

java.lang.Object
    继承者  javax.management.modelmbean.DescriptorSupport
所有已实现的接口：
Serializable, Cloneable, Descriptor
public class DescriptorSupport
extends Object
implements Descriptor

此类表示 ModelMBean 元素的元数据集。描述符是 ModelMBeanInfo、ModelMBeanNotificationInfo、ModelMBeanAttributeInfo、ModelMBeanConstructorInfo 和 ModelMBeanParameterInfo 的一部分。

描述符由字段集合组成。每个字段都采用 fieldname=fieldvalue 格式。字段名称是不区分大小写的，在字段值上将保留大小写。

所有字段名称和值都不是预定义的。任何程序都可以定义和添加新字段。出于实现一致性考虑，某些字段已预定义，并受 ModelMBeanInfo、ModelMBeanAttributeInfo、ModelMBeanConstructorInfo、ModelMBeanNotificationInfo、ModelMBeanOperationInfo 和 ModelMBean 类的支持。

此类的 serialVersionUID 为 -6292969195866300415L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
DescriptorSupport()
描述符默认的构造方法。
DescriptorSupport(DescriptorSupport inDescr)
采用 Descriptor 作为参数的描述符构造方法。
DescriptorSupport(int initNumFields)
描述符构造方法。
DescriptorSupport(String... fields)
带有 fieldName=fieldValue 格式的字段的构造方法。
DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。
DescriptorSupport(String[] fieldNames, Object[] fieldValues)
带有字段名称和字段值的构造方法。
方法摘要
Object | clone() 返回作为 Descriptor 副本的新 Descriptor。
boolean | equals(Object o) 将此描述符与给定对象比较。
String[] | getFieldNames() 返回描述符中的所有字段名。
String[] | getFields() 以 string 数组的形式返回此 descriptor 中所包含的所有字段。
Object | getFieldValue(String fieldName) 返回指定字段名的值，如果该名称不存在任何值，则返回 null。
Object[] | getFieldValues(String... fieldNames) 以 Object 数组的形式返回该 descriptor 中的所有字段值。
int | hashCode() 返回此描述符的哈希码值。
boolean | isValid() 如果所有给定名称的字段都有合法值，则返回 true。
void | removeField(String fieldName) 从该 descriptor 中删除字段。
void | setField(String fieldName, Object fieldValue) 设置特定字段名的值。
void | setFields(String[] fieldNames, Object[] fieldValues) 将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。
String | toString() 返回表示描述符的可读字符串。
String | toXMLString() 返回表示描述符的 XML 字符串。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DescriptorSupport

public DescriptorSupport()
描述符默认的构造方法。默认的初始描述符大小为 20。此大小会根据需要而增加。
注意，创建的空描述符不是有效的描述符（isValid 方法返回 false）。

DescriptorSupport

public DescriptorSupport(int initNumFields)
                  throws MBeanException,
                         RuntimeOperationsException
描述符构造方法。它使用存储 descriptor 字段的 Map 的初始容量作为参数。容量将根据需要而增加。
注意，创建的空描述符不是有效的描述符（isValid 方法返回 false）。

参数：
initNumFields - 存储 descriptor 字段的 Map 的初始容量。
抛出：
RuntimeOperationsException - 如果 initNumField 的值是非法值 (<= 0)
MBeanException - 如果包装了一个分布式通信异常。

DescriptorSupport

public DescriptorSupport(DescriptorSupport inDescr)
采用 Descriptor 作为参数的描述符构造方法。创建新描述符，它被初始化为传入参数中的描述符的值。

参数：
inDescr - 描述符，用于初始化所构造的描述符。如果该参数为 null 或不包含 descriptor 字段，则将创建一个空 Descriptor。

DescriptorSupport

public DescriptorSupport(String inStr)
                  throws MBeanException,
                         RuntimeOperationsException,
                         XMLParseException

Descriptor 构造方法带有一个 XML String。

XML 字符串的格式是未定义的，但实现必须确保在使用此构造方法进行实例化时，能够使用现有描述符上的 toXMLString() 返回的字符串来实例化一个等效的描述符。

在此实现中，所有字段值都将以 String 形式创建。如果字段值不是 String 形式的，则程序员必须重置或正确转换这些字段。

参数：
inStr - 用于填充此 Descriptor 的 XML 格式的字符串。格式是未定义的，但任何实现必须确保在使用此构造方法进行实例化时，能够使用现有描述符上的 toXMLString 方法返回的字符串来实例化一个等效的描述符。
抛出：
RuntimeOperationsException - 如果传递到参数中的 String inStr 为 null
XMLParseException - 如果解析输入 String 时发生 XML 解析问题
MBeanException - 如果包装了一个分布式通信异常。

DescriptorSupport

public DescriptorSupport(String[] fieldNames,
                         Object[] fieldValues)
                  throws RuntimeOperationsException
带有字段名称和字段值的构造方法。两个数组都不可以为 null。

参数：
fieldNames - 字段名称的 String 数组。此数组的所有元素都不可以为 null。
fieldValues - 对应字段值的 Object 数组。此数组的元素可以为 null。fieldValue 对于 fieldName 必须是有效的（正如 isValid 方法中所定义的那样）。

注：参数的数组大小应是匹配的。如果两个数组均为空，则创建一个空描述符。

抛出：
RuntimeOperationsException - 如果 Names 或 Values 字段的值为非法值。数组长度必须相等。如果因为某种原因导致描述符构造失败，则将抛出此异常。

DescriptorSupport

public DescriptorSupport(String... fields)
带有 fieldName=fieldValue 格式的字段的构造方法。

参数：
fields - 每个元素包含一个字段名称和字段值的 String 数组。如果此数组为 null 或空，则将执行默认的构造方法。忽略 null 字符串或空字符串。

所有字段值都应是 String。如果字段值不是 String，则程序员必须重置或正确转换这些字段。

注：每个字符串都应为 fieldName=fieldValue 形式。字段名称到第一个 = 字符结束；例如，如果 String 为 a=b=c 则字段名称为 a，其值为 b=c。

抛出：
RuntimeOperationsException - 如果 Names 或 Values 字段的值为非法值。字段必须包含 "="。"=fieldValue"、"fieldName" 和 "fieldValue" 是非法的。FieldName 不可以为 null。"fieldName=" 将使该值为 null。如果因为某种原因导致描述符构造失败，则将抛出此异常。
方法详细信息

getFieldValue

public Object getFieldValue(String fieldName)
                     throws RuntimeOperationsException
从接口 Descriptor 复制的描述
返回指定字段名的值，如果该名称不存在任何值，则返回 null。

指定者：
接口 Descriptor 中的 getFieldValue
参数：
fieldName - 字段名称。
返回：
相应的值，如果字段不存在，则返回 null。
抛出：
RuntimeOperationsException - 如果字段名称不合法。

setField

public void setField(String fieldName,
                     Object fieldValue)
              throws RuntimeOperationsException
从接口 Descriptor 复制的描述

设置特定字段名的值。这将修改现有的字段或添加一个新字段。

设置前将验证该字段值。如果该值无效，则将抛出一个异常。有效性的含义依赖于描述符实现。

指定者：
接口 Descriptor 中的 setField
参数：
fieldName - 要设置的字段的名称。不能为 null 或空。
fieldValue - 针对该字段名称所设置的字段值。如果 null 是字段的有效值，则可以为 null。
抛出：
RuntimeOperationsException - 如果字段名或字段值不合法（包装的异常为 IllegalArgumentException）；或者描述符不可变（包装的异常为 UnsupportedOperationException）。

getFields

public String[] getFields()
从接口 Descriptor 复制的描述
以 string 数组的形式返回此 descriptor 中所包含的所有字段。

指定者：
接口 Descriptor 中的 getFields
返回：
各字段的 String 数组，格式为 fieldName=fieldValue。
如果字段值不是一个 String，则对该值调用 toString() 方法并将返回值（用圆括号括起来）用作所返回数组中字段的值。如果字段的值为 null，则返回数组中的字段值将为空。如果描述符为空，则将得到一个空数组。
另请参见：
Descriptor.setFields(java.lang.String[], java.lang.Object[])

getFieldNames

public String[] getFieldNames()
从接口 Descriptor 复制的描述
返回描述符中的所有字段名。

指定者：
接口 Descriptor 中的 getFieldNames
返回：
字段名称的 String 数组。如果描述符为空，则将得到一个空数组。

getFieldValues

public Object[] getFieldValues(String... fieldNames)
从接口 Descriptor 复制的描述
以 Object 数组的形式返回该 descriptor 中的所有字段值。返回值的顺序与 fieldNames String 数组参数的顺序相同。

指定者：
接口 Descriptor 中的 getFieldValues
参数：
fieldNames - 字段名称的 String 数组，应该返回这些字段的值。如果该数组为空，则将返回一个空数组。如果数组为 null，则将返回所有值，如同参数是 Descriptor.getFieldNames() 返回的数组一样。如果数组中某个字段名不存在（包括字段名为 null 或空字符串的情况），则对于要返回的匹配数组元素，将返回 null。
返回：
字段值的 Object 数组。如果 fieldNames 列表为空，则将得到一个空数组。

setFields

public void setFields(String[] fieldNames,
                      Object[] fieldValues)
               throws RuntimeOperationsException
从接口 Descriptor 复制的描述

将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。数组大小必须是匹配的。

设置前将验证该字段值。如果该值无效，则将抛出一个异常。如果数组为空，则所有更改都将无效。

指定者：
接口 Descriptor 中的 setFields
参数：
fieldNames - 字段名称的 String 数组。数组和数组元素不能为 null。
fieldValues - 对应字段值的 Object 数组。数组不能为 null。数组的元素可以为 null。
抛出：
RuntimeOperationsException - 如果由于某种原因更改失败。如果 fieldNames 或 fieldValues 为 null，或者数组的长度不同，或者其中一个数组存在非法值，则包装的异常为 IllegalArgumentException。如果描述符不可变，且调用将更改其内容，则包装的异常为 UnsupportedOperationException。
另请参见：
Descriptor.getFields()

clone

public Object clone()
             throws RuntimeOperationsException
返回作为 Descriptor 副本的新 Descriptor。

指定者：
接口 Descriptor 中的 clone
覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
RuntimeOperationsException - 如果 Names 或 Values 字段的值为非法值。如果因为某种原因导致描述符构造失败，则将抛出此异常。
另请参见：
Cloneable

removeField

public void removeField(String fieldName)
从接口 Descriptor 复制的描述
从该 descriptor 中删除字段。

指定者：
接口 Descriptor 中的 removeField
参数：
fieldName - 要移除的字段的 String 名称。如果字段名不合法或找不到字段，则不抛出任何异常。

equals

public boolean equals(Object o)
将此描述符与给定对象比较。如果给定对象也是一个 Descriptor，并且两个 Descriptor 具有相同的字段名称（有时是不同的）和关联值，则两个对象相等。如果满足以下情况，则两个 Descriptor 字段的各个值相等：

  • 如果一个值为 null，则另一值也必须为 null。
  • 如果一个值是基本类型数组，则另一个值必须是相同类型的基本类型数组，并且具有相同的元素。
  • 如果一个值是对象数组，则另一个值也必须是对象数组，且 Arrays.deepEquals 必须返回 true。
  • 其他情况下，Object.equals(Object) 必须返回 true。

指定者：
接口 Descriptor 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与之比较的对象。
返回：
如果对象相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此描述符的哈希码值。该哈希码是描述符每个字段的哈希码的总和。名为 n 且值为 v 的字段的哈希码为 n.toLowerCase().hashCode() ^ h。这里的 h 是 v 的哈希码，计算方式如下：

  • 如果 v 为 null，则 h 为 0。
  • 如果 v 是基本类型数组，则使用恰当重载形式的 java.util.Arrays.hashCode 计算 h。
  • 如果 v 是对象数组，则使用 Arrays.deepHashCode 计算 h。
  • 其他情况下，h 为 v.hashCode()。

指定者：
接口 Descriptor 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

isValid

public boolean isValid()
                throws RuntimeOperationsException
如果所有给定名称的字段都有合法值，则返回 true。

此实现不支持与目录或查找服务进行互操作。因此，根据规范，将不对 "export" 字段进行检查。

否则，在以下情况下此实现返回 false：

  • 名称和 descriptorType fieldNames 尚未定义，或者为 null、空或不是 String
  • 类、角色、getMethod、setMethod fieldNames（如果已定义）为 null 或不是 String
  • persistPeriod、currencyTimeLimit、lastUpdatedTimeStamp、lastReturnedTimeStamp（如果已定义）为 null，或者不是 Numeric String 或 Numeric Value（其值 >= -1）
  • log fieldName（如果已定义）为 null，或者不是 Boolean，或者不是值为 "t"、"f"、"true"、"false" 的 String 。这些 String 值不能是区分大小写的。
  • visibility fieldName（如果已定义）为 null，或者不是 Numeric String 或 Numeric Value（其值 >= 1 且 <= 4）
  • severity fieldName（如果已定义）为 null，或不为 Numeric String 或 Numeric Value（其值 >= 0 且 <= 6）
  • persistPolicy fieldName（如果已定义）为 null，或不是以下字符串之一：
    "OnUpdate"、"OnTimer"、"NoMoreOftenThan"、"OnUnregister"、"Always"、"Never"。这些 String 值不能是区分大小写的。

指定者：
接口 Descriptor 中的 isValid
返回：
如果值是合法的，则返回 true。
抛出：
RuntimeOperationsException - 如果因为某种原因导致验证检查失败，则将抛出此异常。

toXMLString

public String toXMLString()

返回表示描述符的 XML 字符串。

格式是未定义的，但实现应确保在使用构造方法 DescriptorSupport(String inStr) 进行实例化时，能够使用此方法返回的字符串来构造一个等效描述符。

对于不是 String 对象的字段，可以调用 toString() 来创建值。该值将用括号括起来。不保证能够重新构造这些对象，除非它们已经过特殊设置以有意义的格式支持 toString()，并且具有接受相同格式的 String 的匹配构造方法。

如果描述符为空，则返回以下 String：<Descriptor></Descriptor>

返回：
XML 字符串。
抛出：
RuntimeOperationsException - 如果 Names 或 Values 字段的值为非法值。如果因为某种原因导致 XML 格式的字符串构造失败，则将抛出此异常。

toString

public String toString()
返回表示描述符的可读字符串。该字符串的格式将为 "fieldName=fieldValue,fieldName2=fieldValue2,..."
如果描述符中没有字段，则返回一个空 String。
如果 fieldValue 是一个对象，则对它调用 toString() 方法，其返回值用作括号中的字段值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
抛出：
RuntimeOperationsException - 如果 Names 或 Values 字段的值为非法值。如果因为某种原因导致描述符字符串出错，则将抛出此异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


InvalidTargetObjectTypeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 InvalidTargetObjectTypeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.modelmbean.InvalidTargetObjectTypeException
所有已实现的接口：
Serializable
public class InvalidTargetObjectTypeException
extends Exception

当指定了无效的目标对象类型时，抛出此异常。

此类的 serialVersionUID 为 1190536278266811217L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
InvalidTargetObjectTypeException()
默认构造方法。
InvalidTargetObjectTypeException(Exception e, String s)
带有异常和字符串的构造方法。
InvalidTargetObjectTypeException(String s)
根据字符串进行构造的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidTargetObjectTypeException

public InvalidTargetObjectTypeException()
默认构造方法。

InvalidTargetObjectTypeException

public InvalidTargetObjectTypeException(String s)
根据字符串进行构造的构造方法。

参数：
s - 将被合并到此异常的消息中的 String 值。

InvalidTargetObjectTypeException

public InvalidTargetObjectTypeException(Exception e,
                                        String s)
带有异常和字符串的构造方法。

参数：
e - 可能已捕获并以 InvalidTargetObjectTypeException 形式重新发布的异常。我们可能希望使用该消息重写 printStackTrace() 方法，以获取指回初始抛出堆栈的数据。
s - 将被合并到此异常的消息中的字符串值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
接口 ModelMBean

所有超级接口：
DynamicMBean, ModelMBeanNotificationBroadcaster, NotificationBroadcaster, PersistentMBean
所有已知实现类：
RequiredModelMBean
public interface ModelMBean
extends DynamicMBean, PersistentMBean, ModelMBeanNotificationBroadcaster

ModelMBean 必须实现此接口。此接口的实现必须与每个 JMX Agent 一起分发。

Java 资源使用 MBeanServer 的 createMBean 方法来实例化 ModelMBean，以便具有可管理性。然后该资源设置 ModelMBean 实例的 ModelMBeanInfo（带有 Descriptor）。通过 ModelMBean 的 ModelMBeanInfo 公开的属性和操作像其他 MBean 一样可以从 MBean、连接器/适配器进行访问。通过 ModelMBeanInfo Descriptor，可以定义托管应用程序中的值和方法，并可以将它们映射到 ModelMBean 的属性和操作。此映射可以在 XML 格式文件的开发过程中定义，也可以以编程方式在运行时动态定义。

在 MBeanServer 中实例化的每个 ModelMBean 都是可管理的：通过连接到该 MBeanServer 的连接器/适配器，可以远程访问其属性和操作。如果 Java 对象不是 JMX 兼容的 MBean，则它不能在 MBeanServer 中进行注册。通过实例化 ModelMBean，资源可保证 MBean 是有效的。

每个公共方法必须抛出 MBeanException 和 RuntimeOperationsException。这允许包装来自分布式通信（RMI、EJB 等）的异常。这些异常不必由实现抛出，在规范和 javadoc 中描述的情形除外。

从以下版本开始：
1.5

方法摘要
void | setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
从接口 javax.management.DynamicMBean 继承的方法
getAttribute, getAttributes, getMBeanInfo, invoke, setAttribute, setAttributes
从接口 javax.management.PersistentMBean 继承的方法
load, store
从接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 继承的方法
addAttributeChangeNotificationListener, removeAttributeChangeNotificationListener, sendAttributeChangeNotification, sendAttributeChangeNotification, sendNotification, sendNotification
从接口 javax.management.NotificationBroadcaster 继承的方法
addNotificationListener, getNotificationInfo, removeNotificationListener

方法详细信息

setModelMBeanInfo

void setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo)
                       throws MBeanException,
                              RuntimeOperationsException
使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。此方法能够在 ModelMBean 上设置自定义的 ModelMBeanInfo（只要它没有向 MBeanServer 注册）。
一旦自定义并在 ModelMBean 上设置 ModelMBean 的 ModelMBeanInfo（带有 Descriptor）之后，就可以向 MBeanServer 注册 ModelMBean。

如果当前注册 ModelMBean，则此方法抛出包装 IllegalStateException 的 RuntimeOperationsException

参数：
inModelMBeanInfo - ModelMBean 要使用的 ModelMBeanInfo 对象。
抛出：
MBeanException - 包装了一个分布式通信异常。
RuntimeOperationsException -
  • 如果传入参数的 MBeanInfo 为 null，则包装一个 IllegalArgumentException。
  • 如果当前在 MBeanServer 中注册 ModelMBean，则包装一个 IllegalStateException。

setManagedResource

void setManagedResource(Object mr,
                        String mr_type)
                        throws MBeanException,
                               RuntimeOperationsException,
                               InstanceNotFoundException,
                               InvalidTargetObjectTypeException
设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。

参数：
mr - 作为托管资源的对象
mr_type - 托管资源的引用类型。可以为：ObjectReference、Handle、IOR、EJBHandle 和 RMIReference。如果 MBeanServer 不能处理传入的 mr_type，将抛出 InvalidTargetTypeException。
抛出：
MBeanException - 如果对象的初始化程序已抛出异常。
RuntimeOperationsException - 如果包装了一个 IllegalArgumentException：传入参数的托管资源类型为 null。
InstanceNotFoundException - 如果找不到托管资源对象。
InvalidTargetObjectTypeException - 如果 ModelMBean 或 JMX Agent 不能处理托管资源类型。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBeanAttributeInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 ModelMBeanAttributeInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanAttributeInfo
            继承者  javax.management.modelmbean.ModelMBeanAttributeInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorAccess, DescriptorRead
public class ModelMBeanAttributeInfo
extends MBeanAttributeInfo
implements DescriptorAccess

ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。它是 MBeanAttributeInfo 的一个子类，添加了关联的 Descriptor 和 DescriptorAccess 接口实现。

描述符中的字段定义如下，但不限于此：

 name           : 属性名称
 descriptorType : 必须为 "attribute"
 value          : 属性的当前值
 default        : 属性的默认值
 displayName    : 将在显示中使用的属性名称
 getMethod      : get 方法的操作描述符名称
 setMethod      : set 方法的操作描述符名称
 protocolMap    : 实现 Descriptor 接口的对象：映射关系必须适用于该属性并且项可以在运行时进行更新或扩充。
 persistPolicy  : OnUpdate|OnTimer|NoMoreOftenThan|OnUnregister|Always|Never
 persistPeriod  : 秒数 － 持续周期的频率。当 persistPolicy 为 "OnTimer" 或 "NoMoreOftenThan" 时使用。
 currencyTimeLimit : 值保持有效的时间，<0 表示无效，=0 表示总是有效，>0 表示有效的秒数
 lastUpdatedTimeStamp : 当设置值时
 visibility     : 1-4，其中 1 表示总是可见；4 表示几乎不可见
 presentationString : 允许数据呈现的 xml 格式的字符串
默认的描述符包含 name、descriptorType 和 displayName 字段。

注：由于与此规范的以前版本不一致，因此对于 currencyTimeLimit，建议不使用负值或零。要指示某个缓存的值永远无效，请忽略 currencyTimeLimit 字段。要指示它总是有效，请对此字段使用一个非常大的值。

此类的 serialVersionUID 为 6181543027787327345L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
根据此 ModelMBeanAttributeInfo Object 构造新的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
方法摘要
Object | clone() 创建并返回新的 ModelMBeanAttributeInfo，它是此 ModelMBeanAttributeInfo 的副本。
Descriptor | getDescriptor() 获取 ModelMBeanAttributeInfo 的关联 Descriptor 的副本。
void | setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanAttributeDescriptor 的关联 Descriptor（完全取代）。
String | toString() 返回 ModelMBeanAttributeInfo 实例的可读版本。
从类 javax.management.MBeanAttributeInfo 继承的方法
equals, getType, hashCode, isIs, isReadable, isWritable
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String description,
                               Method getter,
                               Method setter)
                        throws IntrospectionException
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。已构造对象的 Descriptor 包括 Method 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
name - 属性名称。
description - 属性的可读描述。它是可选的。
getter - 用于读取属性值的方法。如果该属性是只写的，则此参数可以为 null。
setter - 用于写入属性值的方法。如果该属性是只读的，则此参数可以为 null。
抛出：
IntrospectionException - 如果此属性的定义中存在一致性问题。

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String description,
                               Method getter,
                               Method setter,
                               Descriptor descriptor)
                        throws IntrospectionException
构造 ModelMBeanAttributeInfo 对象。已构造对象的 Descriptor 包括 Method 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
name - 属性名称。
description - 属性的可读描述。它是可选的。
getter - 用于读取属性值的方法。如果该属性是只写的，则此参数可以为 null。
setter - 用于写入属性值的方法。如果该属性是只读的，则此参数可以为 null。
descriptor - 包含此 Attribute 实例的适当元数据的 Descriptor 的实例。如果此参数为 null，则将创建默认描述符。如果描述符不包含 "displayName" 字段，则用默认值将此字段添加到描述符中。
抛出：
IntrospectionException - 如果此属性的定义中存在一致性问题。
RuntimeOperationsException - 包装一个 IllegalArgumentException。描述符无效，或者描述符 "name" 字段不等于 name 参数，或者描述符字段 "DescriptorType" 不等于 "attribute"。

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String type,
                               String description,
                               boolean isReadable,
                               boolean isWritable,
                               boolean isIs)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

参数：
name - 属性名称
type - 属性的类型名称或类名称
description - 属性的可读描述。
isReadable - 如果属性有获取方法，则该参数为 true，否则为 false。
isWritable - 如果属性有设置方法，则该参数为 true，否则为 false。
isIs - 如果属性有一个 "is" 获取方法，则该参数为 true，否则为 false。

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(String name,
                               String type,
                               String description,
                               boolean isReadable,
                               boolean isWritable,
                               boolean isIs,
                               Descriptor descriptor)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。

参数：
name - 属性名称
type - 属性的类型名称或类名称
description - 属性的可读描述。
isReadable - 如果属性有获取方法，则该参数为 true，否则为 false。
isWritable - 如果属性有设置方法，则该参数为 true，否则为 false。
isIs - 如果属性有一个 "is" 获取方法，则为 true，否则为 false。
descriptor - 包含此 Attribute 实例的适当元数据的 Descriptor 的一个实例。如果它为 null，则将创建默认描述符。如果描述符不包含 "displayName" 字段，则用默认值将此字段添加到描述符中。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException。描述符无效，或者描述符 "name" 字段不等于 name 参数，或者描述符字段 "DescriptorType" 不等于 "attribute"。

ModelMBeanAttributeInfo

public ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
根据此 ModelMBeanAttributeInfo Object 构造新的 ModelMBeanAttributeInfo 对象。这将创建一个默认描述符。

参数：
inInfo - 将被复制的 ModelMBeanAttributeInfo
方法详细信息

getDescriptor

public Descriptor getDescriptor()
获取 ModelMBeanAttributeInfo 的关联 Descriptor 的副本。

指定者：
接口 DescriptorRead 中的 getDescriptor
覆盖：
类 MBeanFeatureInfo 中的 getDescriptor
返回：
与 ModelMBeanAttributeInfo 对象关联的 Descriptor。
另请参见：
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
设置 ModelMBeanAttributeDescriptor 的关联 Descriptor（完全取代）。如果新 Descriptor 为 null，则关联的 Descriptor 恢复为默认描述符。在分配 Descriptor 之前验证它。如果新 Descriptor 无效，则抛出一个包装 IllegalArgumentException 的 RuntimeOperationsException。

指定者：
接口 DescriptorAccess 中的 setDescriptor
参数：
inDescriptor - 替换与 ModelMBeanAttributeInfo 关联的 Descriptor
抛出：
RuntimeOperationsException - 包装无效 Descriptor 的 IllegalArgumentException
另请参见：
getDescriptor()

clone

public Object clone()
创建并返回新的 ModelMBeanAttributeInfo，它是此 ModelMBeanAttributeInfo 的副本。

覆盖：
类 MBeanAttributeInfo 中的 clone
返回：
此实例的一个副本。
抛出：
RuntimeOperationsException - 如果 Names 或 Values 字段的值为非法值。如果因为某种原因导致描述符构造失败，则将抛出此异常。
另请参见：
Cloneable

toString

public String toString()
返回 ModelMBeanAttributeInfo 实例的可读版本。

覆盖：
类 MBeanAttributeInfo 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBeanConstructorInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 ModelMBeanConstructorInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanConstructorInfo
            继承者  javax.management.modelmbean.ModelMBeanConstructorInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorAccess, DescriptorRead
public class ModelMBeanConstructorInfo
extends MBeanConstructorInfo
implements DescriptorAccess

ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。它是 MBeanConstructorInfo 的一个子类，添加了关联 Descriptor 和 DescriptorAccess 接口实现。

描述符中的字段定义如下，但不限于此：

 name           : 构造方法名称
 descriptorType : 必须为 "operation"
 role           : 必须为 "constructor"
 displayName    : 构造方法的可读名称
 visibility     : 1-4，其中 1 表示总是可见；4 表示几乎不可见
 presentationString : 描述如何呈现操作的 xml 格式的字符串

persistPolicy 和 currencyTimeLimit 字段对于构造方法没有意义，但并不认为它们无效。

默认的描述符包含 name、descriptorType、displayName 和 role 字段。

此类的 serialVersionUID 为 3862947819818064362L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
ModelMBeanConstructorInfo(String description, Constructor constructorMethod)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
方法摘要
Object | clone() 创建并返回新 ModelMBeanConstructorInfo，它是此 ModelMBeanConstructorInfo 的副本。
Descriptor | getDescriptor() 返回关联 Descriptor 的副本。
void | setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanConstructorInfo 的关联 Descriptor（完全替换）。
String | toString() 以可读形式返回包含 ModelMBeanConstructorInfo 全部内容的字符串。
从类 javax.management.MBeanConstructorInfo 继承的方法
equals, getSignature, hashCode
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String description,
                                 Constructor constructorMethod)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。已构造对象的 Descriptor 包括 Constructor 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
description - 构造方法的可读描述。
constructorMethod - 描述 MBean 构造方法的 java.lang.reflect.Constructor 对象。

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String description,
                                 Constructor constructorMethod,
                                 Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。已构造对象的 Descriptor 包括 Constructor 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
description - 构造方法的可读描述。
constructorMethod - 描述 ModelMBean 构造方法的 java.lang.reflect.Constructor 对象。
descriptor - 包含此 ModelMBeanConstructorInfo 实例的适当元数据的 Descriptor 的一个实例。如果该参数为 null，则将创建默认描述符。如果描述符不包含 "displayName" 字段，则用默认值将此字段添加到描述符中。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException。描述符无效，或者描述符 "name" 字段不等于 name 参数，或者描述符字段 "DescriptorType" 不等于 "operation"，或者描述符 "role" 字段不等于 "constructor"。

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String name,
                                 String description,
                                 MBeanParameterInfo[] signature)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。

参数：
name - 构造方法名称。
description - 构造方法的可读描述。
signature - 描述构造方法参数的 MBeanParameterInfo 对象数组。

ModelMBeanConstructorInfo

public ModelMBeanConstructorInfo(String name,
                                 String description,
                                 MBeanParameterInfo[] signature,
                                 Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。

参数：
name - 构造方法名称。
description - 构造方法的可读描述。
signature - 描述构造方法参数的 MBeanParameterInfo 对象。
descriptor - 包含此 MBeanConstructorInfo 实例的适当元数据的 Descriptor 的一个实例。如果该参数为 null，则将创建默认描述符。如果描述符不包含 "displayName" 字段，则用默认值将此字段添加到描述符中。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException。描述符无效，或者描述符 "name" 字段不等于 name 参数，或者描述符字段 "DescriptorType" 不等于 "operation"，或者描述符 "role" 字段不等于 "constructor"。
方法详细信息

clone

public Object clone()
创建并返回新 ModelMBeanConstructorInfo，它是此 ModelMBeanConstructorInfo 的副本。

覆盖：
类 MBeanConstructorInfo 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getDescriptor

public Descriptor getDescriptor()
返回关联 Descriptor 的副本。

指定者：
接口 DescriptorRead 中的 getDescriptor
覆盖：
类 MBeanFeatureInfo 中的 getDescriptor
返回：
与 ModelMBeanConstructorInfo 对象关联的 Descriptor。
另请参见：
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
设置 ModelMBeanConstructorInfo 的关联 Descriptor（完全替换）。如果新的 Descriptor 为 null，则关联 Descriptor 恢复为默认描述符。分配 Descriptor 之前验证它。如果新的 Descriptor 无效，则抛出一个包装 IllegalArgumentException 的 RuntimeOperationsException。

指定者：
接口 DescriptorAccess 中的 setDescriptor
参数：
inDescriptor - 替换与 ModelMBeanConstructor 关联的 Descriptor。如果描述符不包含 "displayName" 字段，则用默认值将此字段添加到描述符中。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException。描述符无效，或者描述符 "name" 字段不等于 name 参数，或者描述符字段 "DescriptorType" 不等于 "operation"，或者描述符 "role" 字段不等于 "constructor"。
另请参见：
getDescriptor()

toString

public String toString()
以可读形式返回包含 ModelMBeanConstructorInfo 全部内容的字符串。

覆盖：
类 MBeanConstructorInfo 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBeanInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
接口 ModelMBeanInfo

所有已知实现类：
ModelMBeanInfoSupport
public interface ModelMBeanInfo

此接口由每个 ModelMBean 的 ModelMBeanInfo 实现。此接口的实现必须与每个 JMX Agent 一起发布。

Java 资源使用 MBeanServer 的 createMBean 方法来实例化 ModelMBean，以便具有可管理性。然后该资源设置 ModelMBean 实例的 ModelMBeanInfo 和 Descriptor。通过 ModelMBean 的 ModelMBeanInfo 公开的属性、操作和通知组成了管理接口，并且像其他 MBean 一样可以从 MBean、连接器/适配器进行访问。通过 Descriptor，可以定义托管应用程序中的值和方法，并可以将它们映射到 ModelMBean 的属性和操作。此映射可以在文件的开发过程中定义，也可以以编程方式在运行时动态定义。

MBeanServer 中实例化的每个 ModelMBean 都是可管理的：通过连接到该 MBeanServer 的连接器/适配器，可以远程访问其属性、操作和通知。Java 对象不能在 MBeanServer 中进行注册，除非它是 JMX 兼容的 MBean。通过实例化 ModelMBean，资源可保证 MBean 是有效的。 每个公共方法必须抛出 MBeanException 和 RuntimeOperationsException。这允许包装来自分布式通信（RMI 和 EJB 等）的异常。

从以下版本开始：
1.5

方法摘要
Object | clone() 创建并返回此对象的一个副本。
ModelMBeanAttributeInfo | getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
MBeanAttributeInfo[] | getAttributes() 返回为管理公开的属性列表。
String | getClassName() 返回此 MBeanInfo 所描述的 MBean 的 Java 类名称。
MBeanConstructorInfo[] | getConstructors() 返回 MBean 的公共构造方法列表。
String | getDescription() 返回 MBean 的可读描述。
Descriptor | getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor[] | getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor | getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
ModelMBeanNotificationInfo | getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
MBeanNotificationInfo[] | getNotifications() 返回 MBean 所发送的通知列表。
ModelMBeanOperationInfo | getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
MBeanOperationInfo[] | getOperations() 返回 MBean 的操作列表。
void | setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | setMBeanDescriptor(Descriptor inDescriptor) 设置 ModelMBean 的描述符。

方法详细信息

getDescriptors

Descriptor[] getDescriptors(String inDescriptorType)
                            throws MBeanException,
                                   RuntimeOperationsException
返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。

参数：
inDescriptorType - 必须为要返回的描述符设置的 descriptorType 字段值。必须为 "mbean"、"attribute"、"operation"、"constructor" 或 "notification"。如果它为 null 或空，则将返回所有类型。
返回：
包含 inDescriptorType 类型的 ModelMBean 的所有描述符的 Descriptor 数组。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 当参数中的 descriptorType 不是以下值之一时，包装一个 IllegalArgumentException："mbean"、"attribute"、"operation"、"constructor"、"notification"、空、 null。
另请参见：
setDescriptors(javax.management.Descriptor[])

setDescriptors

void setDescriptors(Descriptor[] inDescriptors)
                    throws MBeanException,
                           RuntimeOperationsException
添加或替换 ModelMBeanInfo 中的描述符。

参数：
inDescriptors - ModelMBeanInfo 中要设置的描述符。忽略列表中的 null 元素。所有描述符必须具有 name 和 descriptorType 字段。
抛出：
RuntimeOperationsException - 包装 null 或无效描述符的 IllegalArgumentException。
MBeanException - 包装一个分布式通信异常。
另请参见：
getDescriptors(java.lang.String)

getDescriptor

Descriptor getDescriptor(String inDescriptorName,
                         String inDescriptorType)
                         throws MBeanException,
                                RuntimeOperationsException
返回通过 name 和 descriptorType 请求的 Descriptor。

参数：
inDescriptorName - 描述符的名称。
inDescriptorType - 要请求的描述符的类型。如果它为 null 或空，就搜索所有类型。有效的类型有 'mbean'、'attribute'、'constructor'、'operation'、'notification'。此值将等于所返回的描述符中的 'descriptorType' 字段。
返回：
包含具有相同 name 和 descriptorType 的 ModelMBean 描述符的 Descriptor。如果未找到描述符，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装描述符的名称为 null 的 IllegalArgumentException，或者 null 或无效类型的 IllegalArgumentException。类型必须为 "mbean"、"attribute"、"constructor"、"operation" 或 "notification"。
另请参见：
setDescriptor(javax.management.Descriptor, java.lang.String)

setDescriptor

void setDescriptor(Descriptor inDescriptor,
                   String inDescriptorType)
                   throws MBeanException,
                          RuntimeOperationsException
设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。将调用对应 ModelMBean*Info 的 setDescriptor 方法来设置指定的描述符。

参数：
inDescriptor - ModelMBean 中要设置的描述符。它必须不为 null。所有描述符必须有 name 和 descriptorType 字段。
inDescriptorType - 要设置的描述符类型。如果它为 null，则使用描述符中的 descriptorType 字段。如果此值是指定的，则必须在描述符的 descriptorType 字段中设置它。必须为 "mbean"、"attribute"、"constructor"、"operation" 或 "notification"。
抛出：
RuntimeOperationsException - 包装非法或 null 参数的 IllegalArgumentException，或者如果在对应的 MBeanAttributeInfo、MBeanConstructorInfo、MBeanNotificationInfo 或 MBeanOperationInfo 中找不到描述符的 name 字段。
MBeanException - 包装一个分布式通信异常。
另请参见：
getDescriptor(java.lang.String, java.lang.String)

getMBeanDescriptor

Descriptor getMBeanDescriptor()
                              throws MBeanException,
                                     RuntimeOperationsException
返回包含 MBean 级策略的 ModelMBean 的描述符。此描述符包含关于 MBean 和默认持久性及缓存策略的元数据。

描述符中的字段定义如下，但不限于此：

 name           : MBean 名称
 descriptorType : 必须为 "mbean"
 displayName    : 要在显示中使用的属性名称
 persistPolicy  : OnUpdate|OnTimer|NoMoreOftenThan|OnUnregister|Always|Never
 persistLocation : 应在其中保持 MBean 的完全限定目录名（如果适当）。
 persistFile    : 应在其中保持 MBean 的文件名称。
 persistPeriod  : 秒数 －  OnTime 和 NoMoreOftenThan PersistPolicy 的保持周期的频率
 currencyTimeLimit : 值保持有效的时间，<0 为无效，=0 为总是有效，>0 为有效的秒数
 log            : 其中 t：记录所有通知；f：不记录通知
 logfile        : 要记录事件的完全限定文件名
 visibility     : 1-4，其中 1：总是可见；4：几乎不可见
 export         : 要用于导出/公开此 MBean 的名称，以便其他 JMX Agent 可以找到它

 presentationString : 允许数据与 MBean 关联的 xml 格式的字符串。

默认描述符为：name=mbeanName、descriptorType=mbean、displayName=this.getClassName()、persistPolicy=never、log=F、export=F、visibility=1 如果描述符不包含所有这些字段，则将以这些默认值添加它们。

注：由于与此规范的以前版本不一致，因此对于 currencyTimeLimit，推荐不使用负值或零。要指示某个缓存的值永远无效，请忽略 currencyTimeLimit 字段。要指示它总是有效，请为此字段使用一个非常大的值。

返回：
MBean 描述符。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 如果获取描述符时发生 RuntimeException。
另请参见：
setMBeanDescriptor(javax.management.Descriptor)

setMBeanDescriptor

void setMBeanDescriptor(Descriptor inDescriptor)
                        throws MBeanException,
                               RuntimeOperationsException
设置 ModelMBean 的描述符。此描述符包含默认的、关于 MBean 和默认持久性及缓存策略的 MBean 级元数据。此操作执行描述符的完全替换，不执行合并。如果要设置的描述符为 null，则将创建默认描述符。默认描述符为：name=mbeanName、descriptorType=mbean、displayName=this.getClassName()、 persistPolicy=never、log=F、export=F、visibility=1 如果描述符不包含所有这些字段，则将以这些默认值添加它们。 有关有效字段名称的描述，请参阅 getMBeanDescriptor 方法的 javadoc。

参数：
inDescriptor - 要设置的描述符。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装无效描述符的 IllegalArgumentException。
另请参见：
getMBeanDescriptor()

getAttribute

ModelMBeanAttributeInfo getAttribute(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
返回通过名称请求的 ModelMBeanAttributeInfo。

参数：
inName - 要获取的 ModelMBeanAttributeInfo 名称。如果不存在此名称的 ModelMBeanAttributeInfo，则返回 null。
返回：
指定属性的属性信息，如果没有，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装 null 属性名称的 IllegalArgumentException。

getOperation

ModelMBeanOperationInfo getOperation(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
返回通过名称请求的 ModelMBeanOperationInfo。

参数：
inName - 要获取的 ModelMBeanOperationInfo 名称。如果不存在此名称的 ModelMBeanOperationInfo，则返回 null。
返回：
指定操作的操作信息，如果没有，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装 null 操作名称的 IllegalArgumentException。

getNotification

ModelMBeanNotificationInfo getNotification(String inName)
                                           throws MBeanException,
                                                  RuntimeOperationsException
返回通过名称请求的 ModelMBeanNotificationInfo。

参数：
inName - 要获取的 ModelMBeanNotificationInfo 名称。如果不存在此名称的 ModelMBeanNotificationInfo，则返回 null。
返回：
指定通知的信息，如果没有，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装 null 通知名称的 IllegalArgumentException。

clone

Object clone()
创建并返回此对象的一个副本。

getAttributes

MBeanAttributeInfo[] getAttributes()
返回为管理公开的属性列表。每个属性由一个 MBeanAttributeInfo 对象描述。

返回：
MBeanAttributeInfo 对象的数组。

getClassName

String getClassName()
返回此 MBeanInfo 所描述的 MBean 的 Java 类名称。

返回：
Java 类名称。

getConstructors

MBeanConstructorInfo[] getConstructors()
返回 MBean 的公共构造方法列表。每个属性由一个 MBeanConstructorInfo 对象描述。

返回：
MBeanConstructorInfo 对象的数组。

getDescription

String getDescription()
返回 MBean 的可读描述。

返回：
描述。

getNotifications

MBeanNotificationInfo[] getNotifications()
返回 MBean 所发送的通知列表。每个通知由一个 MBeanNotificationInfo 对象描述。

除了由应用程序指定的任何通知之外，ModelMBean 还可以始终发送两个其他通知：

  • 一个通知的描述符名称为 "GENERIC"，displayName 为 "jmx.modelmbean.generic" 。
  • 第二个通知是标准的属性更改通知，描述符的名称为 "ATTRIBUTE_CHANGE"，displayName 为 "jmx.attribute.change"。
因此，除应用程序所指定的通知之外，ModelMBeanInfo 的任何实现应该总是添加这两个通知。

返回：
MBeanNotificationInfo 对象的数组。

getOperations

MBeanOperationInfo[] getOperations()
返回 MBean 的操作列表。每个操作由一个 MBeanOperationInfo 对象描述。

返回：
MBeanOperationInfo 对象的数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBeanInfoSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 ModelMBeanInfoSupport

java.lang.Object
    继承者  javax.management.MBeanInfo
        继承者  javax.management.modelmbean.ModelMBeanInfoSupport
所有已实现的接口：
Serializable, Cloneable, DescriptorRead, ModelMBeanInfo
public class ModelMBeanInfoSupport
extends MBeanInfo
implements ModelMBeanInfo

此类表示 ModelMBean 的元数据。描述符已被添加到元数据对象上。

Java 资源使用 MBeanServer 的 createMBean 方法来实例化 ModelMBean，以便具有可管理性。然后该资源设置 ModelMBean 实例的 ModelMBeanInfo 和 Descriptor。通过 ModelMBean 的 ModelMBeanInfo 公开的属性和操作像其他 MBean 一样可以从 MBean、连接器/适配器进行访问。通过使用 Descriptor，可以定义托管应用程序中的值和方法，并且可以将它们映射到 ModelMBean 的属性和操作。此映射可以在文件的开发过程中定义，也可以以编程方式在运行时动态定义。

MBeanServer 中实例化的每个 ModelMBean 都是可管理的：通过连接到该 MBeanServer 的连接器/适配器，可以远程访问其属性和操作。如果 Java 对象不是兼容 JMX 的 MBean，那么它不能在 MBeanServer 中进行注册。通过实例化 ModelMBean，资源得到保证，因此 MBean 是有效的。每个公共方法必须抛出 MBeanException 和 RuntimeOperationsException。这允许包装来自分布式通信（RMI、EJB 等）的异常。

此类的 serialVersionUID 为 -1935722590756516193L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
ModelMBeanInfoSupport(ModelMBeanInfo mbi)
构造作为给定 ModelMBeanInfoSupport 副本的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
方法摘要
Object | clone() 返回此实例的浅表复制。
ModelMBeanAttributeInfo | getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
ModelMBeanConstructorInfo | getConstructor(String inName) 返回通过名称请求的 ModelMBeanConstructorInfo。
Descriptor | getDescriptor() 获取此 MBean 的描述符。
Descriptor | getDescriptor(String inDescriptorName) 返回通过名称请求的 Descriptor。
Descriptor | getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor[] | getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor | getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
ModelMBeanNotificationInfo | getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
ModelMBeanOperationInfo | getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
void | setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | setMBeanDescriptor(Descriptor inMBeanDescriptor) 设置 ModelMBean 的描述符。
从类 javax.management.MBeanInfo 继承的方法
equals, getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations, hashCode, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.management.modelmbean.ModelMBeanInfo 继承的方法
getAttributes, getClassName, getConstructors, getDescription, getNotifications, getOperations

构造方法详细信息

ModelMBeanInfoSupport

public ModelMBeanInfoSupport(ModelMBeanInfo mbi)
构造作为给定 ModelMBeanInfoSupport 副本的 ModelMBeanInfoSupport。返回对象是给定对象的浅表复制。Descriptor 或所包含的数组（@code ModelMBeanAttributeInfo[]} 等）都不会被复制。此方法的主要作用是通过 setDescriptor 修改返回实例的 Descriptor，而不影响原对象的 Descriptor。

参数：
mbi - ModelMBeanInfo 实例，正在创建的 ModelMBeanInfo 从该实例进行实例化。

ModelMBeanInfoSupport

public ModelMBeanInfoSupport(String className,
                             String description,
                             ModelMBeanAttributeInfo[] attributes,
                             ModelMBeanConstructorInfo[] constructors,
                             ModelMBeanOperationInfo[] operations,
                             ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。默认描述符为：name=mbeanName、descriptorType=mbean、displayName=ClassName、persistPolicy=never、log=F 和 visibility=1。

参数：
className - MBean 的类名称
description - ModelMBean 的可读描述
attributes - 带有描述符的 ModelMBeanAttributeInfo 对象数组
constructors - 带有描述符的 ModelMBeanConstructorInfo 对象数组
operations - 带有描述符的 ModelMBeanOperationInfo 对象数组
notifications - 带有描述符的 ModelMBeanNotificationInfo 对象数组

ModelMBeanInfoSupport

public ModelMBeanInfoSupport(String className,
                             String description,
                             ModelMBeanAttributeInfo[] attributes,
                             ModelMBeanConstructorInfo[] constructors,
                             ModelMBeanOperationInfo[] operations,
                             ModelMBeanNotificationInfo[] notifications,
                             Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。

参数：
className - MBean 的类名称
description - ModelMBean 的可读描述
attributes - 带有描述符的 ModelMBeanAttributeInfo 对象数组
constructors - 带有描述符的 ModelMBeanConstructorInfo 对象数组
operations - 带有描述符的 ModelMBeanOperationInfo 对象数组
notifications - 带有描述符的 ModelMBeanNotificationInfo 对象数组如果描述符为 null，则将构造默认描述符。默认描述符为：name=className、descriptorType=mbean、displayName=className、persistPolicy=never、log=F 和 visibility=1。如果描述符不包含所有这些字段，则将用默认值添加它们。
抛出：
RuntimeOperationsException - 包装了针对传入参数中的无效描述符的 IllegalArgumentException。（有关有效 MBean 描述符的定义，请参见 getMBeanDescriptor）。
方法详细信息

clone

public Object clone()
返回此实例的浅表复制。Descriptor 或所包含的数组（@code ModelMBeanAttributeInfo[]} 等）都不会被复制。此方法的主要作用是通过 setDescriptor 修改副本的 Descriptor，而不影响原对象的 Descriptor。

指定者：
接口 ModelMBeanInfo 中的 clone
覆盖：
类 MBeanInfo 中的 clone
返回：
此实例的浅表复制。
另请参见：
Cloneable

getDescriptors

public Descriptor[] getDescriptors(String inDescriptorType)
                            throws MBeanException,
                                   RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。

指定者：
接口 ModelMBeanInfo 中的 getDescriptors
参数：
inDescriptorType - 必须为要返回的描述符设置的 descriptorType 字段值。必须为 "mbean"、"attribute"、"operation"、"constructor" 或 "notification"。如果它为 null 或空，则将返回所有类型。
返回：
包含 inDescriptorType 类型的 ModelMBean 的所有描述符的 Descriptor 数组。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 当参数中的 descriptorType 不是以下值之一时，包装一个 IllegalArgumentException："mbean"、"attribute"、"operation"、"constructor"、"notification"、空、 null。
另请参见：
ModelMBeanInfo.setDescriptors(javax.management.Descriptor[])

setDescriptors

public void setDescriptors(Descriptor[] inDescriptors)
                    throws MBeanException,
                           RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
添加或替换 ModelMBeanInfo 中的描述符。

指定者：
接口 ModelMBeanInfo 中的 setDescriptors
参数：
inDescriptors - ModelMBeanInfo 中要设置的描述符。忽略列表中的 null 元素。所有描述符必须具有 name 和 descriptorType 字段。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装 null 或无效描述符的 IllegalArgumentException。
另请参见：
ModelMBeanInfo.getDescriptors(java.lang.String)

getDescriptor

public Descriptor getDescriptor(String inDescriptorName)
                         throws MBeanException,
                                RuntimeOperationsException
返回通过名称请求的 Descriptor。

参数：
inDescriptorName - 描述符名称。
返回：
包含具有相同名称的 ModelMBean 描述符的 Descriptor。如果未找到该描述符，则返回 null。
抛出：
MBeanException - 包装了一个分布式通信异常。
RuntimeOperationsException - 包装了针对 null 名称的 IllegalArgumentException。
另请参见：
setDescriptor(javax.management.Descriptor, java.lang.String)

getDescriptor

public Descriptor getDescriptor(String inDescriptorName,
                                String inDescriptorType)
                         throws MBeanException,
                                RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
返回通过 name 和 descriptorType 请求的 Descriptor。

指定者：
接口 ModelMBeanInfo 中的 getDescriptor
参数：
inDescriptorName - 描述符的名称。
inDescriptorType - 要请求的描述符的类型。如果它为 null 或空，就搜索所有类型。有效的类型有 'mbean'、'attribute'、'constructor'、'operation'、'notification'。此值将等于所返回的描述符中的 'descriptorType' 字段。
返回：
包含具有相同 name 和 descriptorType 的 ModelMBean 描述符的 Descriptor。如果未找到描述符，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装描述符的名称为 null 的 IllegalArgumentException，或者 null 或无效类型的 IllegalArgumentException。类型必须为 "mbean"、"attribute"、"constructor"、"operation" 或 "notification"。
另请参见：
ModelMBeanInfo.setDescriptor(javax.management.Descriptor, java.lang.String)

setDescriptor

public void setDescriptor(Descriptor inDescriptor,
                          String inDescriptorType)
                   throws MBeanException,
                          RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。将调用对应 ModelMBean*Info 的 setDescriptor 方法来设置指定的描述符。

指定者：
接口 ModelMBeanInfo 中的 setDescriptor
参数：
inDescriptor - ModelMBean 中要设置的描述符。它必须不为 null。所有描述符必须有 name 和 descriptorType 字段。
inDescriptorType - 要设置的描述符类型。如果它为 null，则使用描述符中的 descriptorType 字段。如果此值是指定的，则必须在描述符的 descriptorType 字段中设置它。必须为 "mbean"、"attribute"、"constructor"、"operation" 或 "notification"。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装非法或 null 参数的 IllegalArgumentException，或者如果在对应的 MBeanAttributeInfo、MBeanConstructorInfo、MBeanNotificationInfo 或 MBeanOperationInfo 中找不到描述符的 name 字段。
另请参见：
ModelMBeanInfo.getDescriptor(java.lang.String, java.lang.String)

getAttribute

public ModelMBeanAttributeInfo getAttribute(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
返回通过名称请求的 ModelMBeanAttributeInfo。

指定者：
接口 ModelMBeanInfo 中的 getAttribute
参数：
inName - 要获取的 ModelMBeanAttributeInfo 名称。如果不存在此名称的 ModelMBeanAttributeInfo，则返回 null。
返回：
指定属性的属性信息，如果没有，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装 null 属性名称的 IllegalArgumentException。

getOperation

public ModelMBeanOperationInfo getOperation(String inName)
                                     throws MBeanException,
                                            RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
返回通过名称请求的 ModelMBeanOperationInfo。

指定者：
接口 ModelMBeanInfo 中的 getOperation
参数：
inName - 要获取的 ModelMBeanOperationInfo 名称。如果不存在此名称的 ModelMBeanOperationInfo，则返回 null。
返回：
指定操作的操作信息，如果没有，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装 null 操作名称的 IllegalArgumentException。

getConstructor

public ModelMBeanConstructorInfo getConstructor(String inName)
                                         throws MBeanException,
                                                RuntimeOperationsException
返回通过名称请求的 ModelMBeanConstructorInfo。如果不存在具有此名称的 ModelMBeanConstructorInfo，则返回 null。

参数：
inName - 构造方法名称。
返回：
指定构造方法的构造方法信息，如果没有这类信息，则返回 null。
抛出：
MBeanException - 包装了一个分布式通信异常。
RuntimeOperationsException - 包装了针对 null 构造方法名称的 IllegalArgumentException。

getNotification

public ModelMBeanNotificationInfo getNotification(String inName)
                                           throws MBeanException,
                                                  RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
返回通过名称请求的 ModelMBeanNotificationInfo。

指定者：
接口 ModelMBeanInfo 中的 getNotification
参数：
inName - 要获取的 ModelMBeanNotificationInfo 名称。如果不存在此名称的 ModelMBeanNotificationInfo，则返回 null。
返回：
指定通知的信息，如果没有，则返回 null。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装 null 通知名称的 IllegalArgumentException。

getDescriptor

public Descriptor getDescriptor()
从类 MBeanInfo 复制的描述
获取此 MBean 的描述符。更改返回值对原描述符没有影响。

指定者：
接口 DescriptorRead 中的 getDescriptor
覆盖：
类 MBeanInfo 中的 getDescriptor
返回：
一个描述符，可能是不可变的，也可能是原描述符的副本。
从以下版本开始：
1.6

getMBeanDescriptor

public Descriptor getMBeanDescriptor()
                              throws MBeanException
从接口 ModelMBeanInfo 复制的描述
返回包含 MBean 级策略的 ModelMBean 的描述符。此描述符包含关于 MBean 和默认持久性及缓存策略的元数据。

描述符中的字段定义如下，但不限于此：

 name           : MBean 名称
 descriptorType : 必须为 "mbean"
 displayName    : 要在显示中使用的属性名称
 persistPolicy  : OnUpdate|OnTimer|NoMoreOftenThan|OnUnregister|Always|Never
 persistLocation : 应在其中保持 MBean 的完全限定目录名（如果适当）。
 persistFile    : 应在其中保持 MBean 的文件名称。
 persistPeriod  : 秒数 －  OnTime 和 NoMoreOftenThan PersistPolicy 的保持周期的频率
 currencyTimeLimit : 值保持有效的时间，<0 为无效，=0 为总是有效，>0 为有效的秒数
 log            : 其中 t：记录所有通知；f：不记录通知
 logfile        : 要记录事件的完全限定文件名
 visibility     : 1-4，其中 1：总是可见；4：几乎不可见
 export         : 要用于导出/公开此 MBean 的名称，以便其他 JMX Agent 可以找到它

 presentationString : 允许数据与 MBean 关联的 xml 格式的字符串。

默认描述符为：name=mbeanName、descriptorType=mbean、displayName=this.getClassName()、persistPolicy=never、log=F、export=F、visibility=1 如果描述符不包含所有这些字段，则将以这些默认值添加它们。

注：由于与此规范的以前版本不一致，因此对于 currencyTimeLimit，推荐不使用负值或零。要指示某个缓存的值永远无效，请忽略 currencyTimeLimit 字段。要指示它总是有效，请为此字段使用一个非常大的值。

指定者：
接口 ModelMBeanInfo 中的 getMBeanDescriptor
返回：
MBean 描述符。
抛出：
MBeanException - 包装一个分布式通信异常。
另请参见：
ModelMBeanInfo.setMBeanDescriptor(javax.management.Descriptor)

setMBeanDescriptor

public void setMBeanDescriptor(Descriptor inMBeanDescriptor)
                        throws MBeanException,
                               RuntimeOperationsException
从接口 ModelMBeanInfo 复制的描述
设置 ModelMBean 的描述符。此描述符包含默认的、关于 MBean 和默认持久性及缓存策略的 MBean 级元数据。此操作执行描述符的完全替换，不执行合并。如果要设置的描述符为 null，则将创建默认描述符。默认描述符为：name=mbeanName、descriptorType=mbean、displayName=this.getClassName()、 persistPolicy=never、log=F、export=F、visibility=1 如果描述符不包含所有这些字段，则将以这些默认值添加它们。 有关有效字段名称的描述，请参阅 getMBeanDescriptor 方法的 javadoc。

指定者：
接口 ModelMBeanInfo 中的 setMBeanDescriptor
参数：
inMBeanDescriptor - 要设置的描述符。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装无效描述符的 IllegalArgumentException。
另请参见：
ModelMBeanInfo.getMBeanDescriptor()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBeanNotificationBroadcaster (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
接口 ModelMBeanNotificationBroadcaster

所有超级接口：
NotificationBroadcaster
所有已知子接口：
ModelMBean
所有已知实现类：
RequiredModelMBean
public interface ModelMBeanNotificationBroadcaster
extends NotificationBroadcaster

ModelMBean 必须实现此接口。此接口的实现必须与每个 JMX Agent 一起发布。

Java 资源使用 MBeanServer 的 createMBean 方法来实例化 ModelMBean，以便具有可管理性。然后该资源设置 ModelMBean 实例的 ModelMBeanInfo（带有 Descriptor）。通过 ModelMBean 的 ModelMBeanInfo 公开的属性和操作像其他 MBean 一样，可以从 MBean、连接器/适配器进行访问。通过 ModelMBeanInfo Descriptor，可以定义托管应用程序中的值和方法，并可以将它们映射到 ModelMBean 的属性和操作。此映射可以在 XML 格式的文件的开发过程中定义，也可以以编程方式在运行时动态定义。

MBeanServer 中实例化的每个 ModelMBean 都是可管理的：通过连接到该 MBeanServer 的连接器/适配器可以远程访问其属性和操作。Java 对象不能在 MBeanServer 中进行注册，除非它是 JMX 兼容的 MBean。通过实例化 ModelMBean，资源可保证 MBean 是有效的。

每个公共方法必须抛出 MBeanException 和 RuntimeOperationsException。这允许包装来自分布式通信（RMI 和 EJB 等）的异常。除规范和 javadoc 中描述的情况外，这些异常不必由实现抛出。

从以下版本开始：
1.5

方法摘要
void | addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | sendAttributeChangeNotification(AttributeChangeNotification notification) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | sendNotification(String ntfyText) 将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
从接口 javax.management.NotificationBroadcaster 继承的方法
addNotificationListener, getNotificationInfo, removeNotificationListener

方法详细信息

sendNotification

void sendNotification(Notification ntfyObj)
                      throws MBeanException,
                             RuntimeOperationsException
以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。

参数：
ntfyObj - 要传递给侦听器对象的 'handleNotification' 方法的通知。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 Notification 对象为 null。

sendNotification

void sendNotification(String ntfyText)
                      throws MBeanException,
                             RuntimeOperationsException
将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。

参数：
ntfyText - Notification 中要传递到侦听器对象的 'handleNotification' 方法的文本。 所构造的 Notification 将为： 类型 "jmx.modelmbean.generic" 源 此 ModelMBean 实例 序列 1
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 Notification 文本字符串为 null。

sendAttributeChangeNotification

void sendAttributeChangeNotification(AttributeChangeNotification notification)
                                     throws MBeanException,
                                            RuntimeOperationsException
将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。

参数：
notification - 要传递给侦听器对象的 'handleNotification' 方法的通知。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 AttributeChangeNotification 对象为 null。

sendAttributeChangeNotification

void sendAttributeChangeNotification(Attribute oldValue,
                                     Attribute newValue)
                                     throws MBeanException,
                                            RuntimeOperationsException
将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。

参数：
oldValue - 属性的原始值
newValue - 属性的当前值

所构造的 attributeChangeNotification 将为：
类型     "jmx.attribute.change"
源      此 ModelMBean 实例
序列    1
   attributeName oldValue.getName()
   attributeType oldValue's class
   attributeOldValue oldValue.getValue()
   attributeNewValue newValue.getValue()
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 Attribute 对象为 null，或参数中两个 Attribute 对象的名称不同。

addAttributeChangeNotificationListener

void addAttributeChangeNotificationListener(NotificationListener listener,
                                            String attributeName,
                                            Object handback)
                                            throws MBeanException,
                                                   RuntimeOperationsException,
                                                   IllegalArgumentException
注册一个将 NotificationListener 接口实现为侦听器的对象。当通过或由 ModelMBean 发布任何 attributeChangeNotification 时，将调用此对象的 'handleNotification()' 方法。这不包括其他 Notification。它们必须独立注册。将为此 attributeName 生成一个 AttributeChangeNotification。

参数：
listener - 将处理由已注册的 MBean 发出的通知的侦听器对象。
attributeName - 要为其接收更改通知的 ModelMBean 属性名称。如果参数为 null，则所有更改将导致发布 attributeChangeNotification。
handback - 当发出通知时，要发送到带有通知的侦听器的上下文。
抛出：
IllegalArgumentException - 侦听器不可以为 null。
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException。传入参数中的属性名称不存在。
另请参见：
removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)

removeAttributeChangeNotificationListener

void removeAttributeChangeNotificationListener(NotificationListener listener,
                                               String attributeName)
                                               throws MBeanException,
                                                      RuntimeOperationsException,
                                                      ListenerNotFoundException
从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。

参数：
listener - 正在处理由注册的 MBean 发出的通知的侦听器名称。此方法将移除与此侦听器相关的所有信息。
attributeName - 侦听器不再为其接收 attributeChangeNotifications 的属性。如果为 null，则将移除所有 attributeChangeNotifications 的侦听器。
抛出：
ListenerNotFoundException - 侦听器未在 MBean 中注册，或为 null。
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException 如果 inAttributeName 参数没有对应一个属性名称。
另请参见：
addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBeanNotificationInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 ModelMBeanNotificationInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanNotificationInfo
            继承者  javax.management.modelmbean.ModelMBeanNotificationInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorAccess, DescriptorRead
public class ModelMBeanNotificationInfo
extends MBeanNotificationInfo
implements DescriptorAccess

ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。它是 MBeanNotificationInfo 的一个子类，添加了关联的 Descriptor 和 Descriptor 接口的实现

描述符中的字段定义如下，但不限于此：

name           :通知名称
descriptorType :必须为 "notification"
severity       :0-6，其中 0：未知；1：不可恢复的；
                2: 关键的，失败；3：主要的，严重的；
                4: 次要的，边缘的，错误；5：警告：
                6: 正常的、清楚的、丰富的
messageID      :消息文本的唯一键（允许转换，分析）
messageText    :通知文本
log            :T － 记录消息 F － 不记录消息
logfile        :字符串完全限定文件名，适用于：操作系统
visibility     :1-4，其中 1：总是可见 4：几乎不可见
presentationString :允许数据呈现的 xml 格式的字符串
默认的描述符包含 name、descriptorType、displayName 和 severity(=6) 字段。

此类的 serialVersionUID 为 -7445681389570207141L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
从此 ModelMBeanNotfication Object 构造新 ModelMBeanNotificationInfo 对象。
ModelMBeanNotificationInfo(String[] notifTypes, String name, String description)
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。
ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。
方法摘要
Object | clone() 创建并返回新 ModelMBeanNotificationInfo，它是此 ModelMBeanNotificationInfo 的副本。
Descriptor | getDescriptor() 返回 ModelMBeanNotificationInfo 的关联 Descriptor 的副本。
void | setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanNotificationInfo 的关联 Descriptor（完全替换）。
String | toString() 返回包含 ModelMBeanNotificationInfo 的可读字符串。
从类 javax.management.MBeanNotificationInfo 继承的方法
equals, getNotifTypes, hashCode
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ModelMBeanNotificationInfo

public ModelMBeanNotificationInfo(String[] notifTypes,
                                  String name,
                                  String description)
构造带有默认描述符的 ModelMBeanNotificationInfo 对象。

参数：
notifTypes - 包含可以发送的通知类型的字符串（以点表示法）数组。
name - Notification 类的名称。
description - Notification 的可读描述。可选的。

ModelMBeanNotificationInfo

public ModelMBeanNotificationInfo(String[] notifTypes,
                                  String name,
                                  String description,
                                  Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。

参数：
notifTypes - 包含可以发送的通知类型的字符串（以点表示法）数组。
name - Notification 类的名称。
description - Notification 的可读描述。可选的。
descriptor - 包含此 MBeanNotificationInfo 的实例的适当元数据的 Descriptor 实例。如果它为 null，则将创建默认描述符。如果描述符不包含 "displayName" 或 "severity" 字段，则以默认值将这些字段添加到描述符中。
抛出：
RuntimeOperationsException - 包装了一个 IllegalArgumentException。描述符无效，或者描述符 "name" 字段不等于参数名称，或者描述符 "DescriptorType" 字段不等于 "notification"。

ModelMBeanNotificationInfo

public ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
从此 ModelMBeanNotfication Object 构造新 ModelMBeanNotificationInfo 对象。

参数：
inInfo - 要被复制的 ModelMBeanNotificationInfo
方法详细信息

clone

public Object clone()
创建并返回新 ModelMBeanNotificationInfo，它是此 ModelMBeanNotificationInfo 的副本。

覆盖：
类 MBeanNotificationInfo 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getDescriptor

public Descriptor getDescriptor()
返回 ModelMBeanNotificationInfo 的关联 Descriptor 的副本。

指定者：
接口 DescriptorRead 中的 getDescriptor
覆盖：
类 MBeanFeatureInfo 中的 getDescriptor
返回：
与 ModelMBeanNotificationInfo 对象关联的 Descriptor。
另请参见：
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
设置 ModelMBeanNotificationInfo 的关联 Descriptor（完全替换）。如果新 Descriptor 为 null，则关联 Descriptor 恢复为默认描述符。分配 Descriptor 之前验证它。如果新 Descriptor 无效，则抛出一个包装 IllegalArgumentException 的 RuntimeOperationsException。

指定者：
接口 DescriptorAccess 中的 setDescriptor
参数：
inDescriptor - 替换与 ModelMBeanNotification 接口关联的 Descriptor
抛出：
RuntimeOperationsException - 包装了无效 Descriptor 的 IllegalArgumentException。
另请参见：
getDescriptor()

toString

public String toString()
返回包含 ModelMBeanNotificationInfo 的可读字符串。

覆盖：
类 MBeanNotificationInfo 中的 toString
返回：
描述此对象的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModelMBeanOperationInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 ModelMBeanOperationInfo

java.lang.Object
    继承者  javax.management.MBeanFeatureInfo
        继承者  javax.management.MBeanOperationInfo
            继承者  javax.management.modelmbean.ModelMBeanOperationInfo
所有已实现的接口：
Serializable, Cloneable, DescriptorAccess, DescriptorRead
public class ModelMBeanOperationInfo
extends MBeanOperationInfo
implements DescriptorAccess

ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。它是 MBeanOperationInfo 的一个子类，添加了关联的 Descriptor 和 DescriptorAccess 接口实现。

描述符中的字段定义如下，但不限于此：
 name           : 操作的名称
 descriptorType : 必须为 "operation"
 class          : 其中定义了方法（完全限定）的类
 role           : 必须为 "operation"、"getter" 或 "setter"
 targetObject   : 将在其上执行此方法的对象
 targetType     : targetObject 的对象引用类型可以为：ObjectReference | Handle | EJBHandle | IOR | MIReference。
 value          : 操作的缓存值
 currencyTimeLimit : 缓存值的有效时间
 lastUpdatedTimeStamp : 当设置缓存值时
 visibility            : 1-4，其中 1 表示总是可见；4 表示几乎不可见
 presentationString : 用于描述如何呈现操作的 xml 格式的字符串
默认的描述符包含 name、descriptorType、displayName 和 role 字段。

注：由于与此规范的以前版本不一致，因此对于 currencyTimeLimit，建议不要使用负值或零。要指示某个缓存的值永远无效，请忽略 currencyTimeLimit 字段。要指示它总是有效，请为此字段使用一个非常大的值。

此类的 serialVersionUID 为 6532732096650090465L。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从类 javax.management.MBeanOperationInfo 继承的字段
ACTION, ACTION_INFO, INFO, UNKNOWN
从类 javax.management.MBeanFeatureInfo 继承的字段
description, name
构造方法摘要
ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
根据此 ModelMBeanOperation Object 构造新的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。
方法摘要
Object | clone() 创建并返回新的 ModelMBeanOperationInfo，它是此 ModelMBeanOperationInfo 的副本。
Descriptor | getDescriptor() 返回 ModelMBeanOperationInfo 的关联 Descriptor 的副本。
void | setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanOperationInfo 的关联 Descriptor（完全取代）。
String | toString() 以可读形式返回包含 ModelMBeanOperationInfo 全部内容的字符串。
从类 javax.management.MBeanOperationInfo 继承的方法
equals, getImpact, getReturnType, getSignature, hashCode
从类 javax.management.MBeanFeatureInfo 继承的方法
getDescription, getName
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String description,
                               Method operationMethod)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。已构造对象的 Descriptor 包括 Method 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
operationMethod - 描述 MBean 操作的 java.lang.reflect.Method 对象。
description - 操作的可读描述。

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String description,
                               Method operationMethod,
                               Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。已构造对象的 Descriptor 包括 Method 对象（包含 DescriptorKey 元注释）生成的字段。

参数：
operationMethod - 描述 MBean 操作的 java.lang.reflect.Method 对象。
description - 操作的可读描述。
descriptor - 包含此 ModelMBeanOperationInfo 实例的适当元数据的 Descriptor 的一个实例。如果该参数为 null，则将创建默认描述符。如果描述符不包含 "displayName" 或 "role" 字段，则以默认值将这些字段添加到描述符中。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException。描述符无效；描述符 "name" 字段不等于操作名称；描述符 "DescriptorType" 字段不等于 "operation"；描述符 "role" 字段不等于 "operation"、"getter" 或 "setter"。

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String name,
                               String description,
                               MBeanParameterInfo[] signature,
                               String type,
                               int impact)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。

参数：
name - 方法名称。
description - 操作的可读描述。
signature - 描述方法的参数的 MBeanParameterInfo 对象。
type - 方法返回值的类型。
impact - 方法的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(String name,
                               String description,
                               MBeanParameterInfo[] signature,
                               String type,
                               int impact,
                               Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

参数：
name - 方法名称。
description - 操作的可读描述。
signature - 描述方法的参数的 MBeanParameterInfo 对象。
type - 方法返回值的类型。
impact - 方法的影响，为 INFO、ACTION、ACTION_INFO、UNKNOWN 之一。
descriptor - 包含此 MBeanOperationInfo 实例的适当元数据的 Descriptor 的实例。如果该参数为 null，是将创建默认描述符。如果描述符不包含 "displayName" 或 "role" 字段，则以默认值将这些字段添加到描述符中。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException。描述符无效；描述符 "name" 字段不等于操作名称；描述符 "DescriptorType" 字段不等于 "operation"；描述符 "role" 字段不等于 "operation"、"getter" 或 "setter"。

ModelMBeanOperationInfo

public ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
根据此 ModelMBeanOperation Object 构造新的 ModelMBeanOperationInfo 对象。

参数：
inInfo - 要复制的 ModelMBeanOperationInfo
方法详细信息

clone

public Object clone()
创建并返回新的 ModelMBeanOperationInfo，它是此 ModelMBeanOperationInfo 的副本。

覆盖：
类 MBeanOperationInfo 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getDescriptor

public Descriptor getDescriptor()
返回 ModelMBeanOperationInfo 的关联 Descriptor 的副本。

指定者：
接口 DescriptorRead 中的 getDescriptor
覆盖：
类 MBeanFeatureInfo 中的 getDescriptor
返回：
与 ModelMBeanOperationInfo 对象关联的 Descriptor。
另请参见：
setDescriptor(javax.management.Descriptor)

setDescriptor

public void setDescriptor(Descriptor inDescriptor)
设置 ModelMBeanOperationInfo 的关联 Descriptor（完全取代）。如果新 Descriptor 为 null，则该关联 Descriptor 恢复为默认描述符。在分配 Descriptor 之前先验证它。如果新 Descriptor 无效，则抛出包装 IllegalArgumentException 的 RuntimeOperationsException。

指定者：
接口 DescriptorAccess 中的 setDescriptor
参数：
inDescriptor - 替换与 ModelMBeanOperation 关联的 Descriptor。
抛出：
RuntimeOperationsException - 包装一个无效 Descriptor 的 IllegalArgumentException。
另请参见：
getDescriptor()

toString

public String toString()
以可读形式返回包含 ModelMBeanOperationInfo 全部内容的字符串。

覆盖：
类 MBeanOperationInfo 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequiredModelMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 RequiredModelMBean

java.lang.Object
    继承者  javax.management.modelmbean.RequiredModelMBean
所有已实现的接口：
DynamicMBean, MBeanRegistration, ModelMBean, ModelMBeanNotificationBroadcaster, NotificationBroadcaster, NotificationEmitter, PersistentMBean
public class RequiredModelMBean
extends Object
implements ModelMBean, MBeanRegistration, NotificationEmitter

此类是 ModelMBean 的实现。每个发行的 JMX Agent 必须带有 ModelMBean 的适当实现，且该类必须是指定的 RequiredModelMBean。

Java 资源使用 MBeanServer 的 createMBean 方法来实例化 RequiredModelMBean，希望以这种方式获得可管理性。然后该资源设置 RequiredModelMBean 实例的 MBeanInfo 和 Descriptor。通过 ModelMBean 的 ModelMBeanInfo 公开的属性和操作像其他 MBean 一样可以从 MBean、连接器/适配器进行访问。通过使用 Descriptor，可以定义托管应用程序中的值和方法，并可以将它们映射到 ModelMBean 的属性和操作。此映射可以在 XML 格式的文件中定义，也可以以编程方式在运行时动态定义。

MBeanServer 中实例化的每个 RequiredModelMBean 都将是可管理的：
通过连接到该 MBeanServer 的连接器/适配器，可以远程访问其属性和操作。

Java 对象不能在 MBeanServer 中进行注册，除非它是 JMX 兼容的 MBean。通过实例化 RequiredModelMBean，资源得到了保证，因此 MBean 是有效的。每个公共方法必须抛出 MBeanException 和 RuntimeOperationsException，允许使用这些异常包装来自分布式通信（RMI、EJB 等）的异常。

从以下版本开始：
1.5

构造方法摘要
RequiredModelMBean()
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。
RequiredModelMBean(ModelMBeanInfo mbi)
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。
方法摘要
void | addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
Object | getAttribute(String attrName) 返回为此 ModelMBean 定义的指定属性的值。
AttributeList | getAttributes(String[] attrNames) 返回 ModelMBean 中几个属性的值。
protected ClassLoaderRepository | getClassLoaderRepository() 返回用于执行类加载的 Class Loader Repository。
MBeanInfo | getMBeanInfo() 返回此 RequiredModelMBean 公开的属性、操作、构造方法和通知是为了便于管理。
MBeanNotificationInfo[] | getNotificationInfo() 返回总是由 RequiredModelMBean 生成的 Notification 数组。
Object | invoke(String opName, Object[] opArgs, String[] sig) 调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。
void | load() 使用在持久存储中找到的 MBean 的数据实例化此 MBean。
void | postDeregister() 允许 MBean 在已从 MBean 服务器注销之后执行任何所需要的操作。
void | postRegister(Boolean registrationDone) 允许 MBean 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。
void | preDeregister() 允许 MBean 在由 MBean 服务器注销之前执行任何所需要的操作。
ObjectName | preRegister(MBeanServer server, ObjectName name) 允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。
void | removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | removeNotificationListener(NotificationListener listener) 从 RequiredModelMBean 移除一个 Notification 的侦听器。
void | removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | sendAttributeChangeNotification(AttributeChangeNotification ntfyObj) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | sendNotification(String ntfyText) 将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。
AttributeList | setAttributes(AttributeList attributes) 设置此 ModelMBean 的属性数组的值。
void | setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
void | setModelMBeanInfo(ModelMBeanInfo mbi) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | store() 捕获此 MBean 实例的当前状态，并将它写出到持久存储中。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RequiredModelMBean

public RequiredModelMBean()
                   throws MBeanException,
                          RuntimeOperationsException
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。

可以使用 setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo) 方法来自定义 RequiredModelMBean 的 MBeanInfo 和 Descriptor。自定义 RequiredModelMBean 的 MBeanInfo 和 Descriptor 之后，可以在 MBeanServer 中注册 RequiredModelMBean。

抛出：
MBeanException - 包装了一个分布式通信异常。
RuntimeOperationsException - 在对象的构造期间包装了一个 RuntimeException。

RequiredModelMBean

public RequiredModelMBean(ModelMBeanInfo mbi)
                   throws MBeanException,
                          RuntimeOperationsException
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。只要尚未在 MBeanServer 中注册 RequiredModelMBean，就可以使用 setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo) 方法自定义 RequiredModelMBean 的 MBeanInfo 和 Descriptor。自定义 RequiredModelMBean 的 MBeanInfo 和 Descriptor 之后，可以向 MBeanServer 注册 RequiredModelMBean。

参数：
mbi - RequiredModelMBean 要使用的 ModelMBeanInfo 对象。给定的 ModelMBeanInfo 根据 setModelMBeanInfo(javax.management.modelmbean.ModelMBeanInfo) 指定的方式进行复制和修改
抛出：
MBeanException - 包装了一个分布式通信异常。
RuntimeOperationsException - 包装了一个 {link java.lang.IllegalArgumentException}：传入参数中的 MBeanInfo 为 null。
方法详细信息

setModelMBeanInfo

public void setModelMBeanInfo(ModelMBeanInfo mbi)
                       throws MBeanException,
                              RuntimeOperationsException
使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。此方法能够设置 ModelMBean 上的自定义 ModelMBeanInfo（只要它尚未在 MBeanServer 中注册）。
一旦自定义 ModelMBean 的 ModelMBeanInfo 并在 ModelMBean 上设置它（带有 Descriptor）之后，就可以在 MBeanServer 中注册 ModelMBean。

如果目前已经注册了 ModelMBean，则此方法抛出包装 IllegalStateException 的 RuntimeOperationsException

如果给定的 inModelMBeanInfo 不包含任何 GENERIC 或 ATTRIBUTE_CHANGE 通知的 ModelMBeanNotificationInfo，则 RequiredModelMBean 将为这些缺少的通知提供它自己的默认 ModelMBeanNotificationInfo。

指定者：
接口 ModelMBean 中的 setModelMBeanInfo
参数：
mbi - ModelMBean 要使用的 ModelMBeanInfo 对象。
抛出：
MBeanException - 包装了一个分布式通信异常。
RuntimeOperationsException -
  • 如果传入参数的 MBeanInfo 为 null，则包装一个 IllegalArgumentException。
  • 如果目前已经在 MBeanServer 中注册了 ModelMBean，则包装一个 IllegalStateException。

setManagedResource

public void setManagedResource(Object mr,
                               String mr_type)
                        throws MBeanException,
                               RuntimeOperationsException,
                               InstanceNotFoundException,
                               InvalidTargetObjectTypeException
设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。

指定者：
接口 ModelMBean 中的 setManagedResource
参数：
mr - 作为托管资源的对象
mr_type - 托管资源的引用类型。
该参数可以是："ObjectReference"、"Handle"、"IOR"、"EJBHandle" 或 "RMIReference"。
在此实现中仅支持 "ObjectReference"。
抛出：
MBeanException - 如果对象初始化程序已抛出异常。
InstanceNotFoundException - 如果找不到托管资源对象
InvalidTargetObjectTypeException - 托管资源对象应为 "ObjectReference"。
RuntimeOperationsException - 如果设置资源时包装一个 RuntimeException。

load

public void load()
          throws MBeanException,
                 RuntimeOperationsException,
                 InstanceNotFoundException

使用在持久存储中找到的 MBean 的数据实例化此 MBean。加载的数据可以包括属性和操作值。

此方法的调用应在此实例的构造或实例化期间，且在向 MBeanServer 注册该 MBean 之前。

如果此类的实例不支持持久存储，则抛出包装 ServiceNotFoundException 的 MBeanException。

指定者：
接口 PersistentMBean 中的 load
抛出：
MBeanException - 包装另一个异常，或者不支持持久存储
RuntimeOperationsException - 包装来自持久机制的异常
InstanceNotFoundException - 不能从持久存储找到或加载此 MBean

store

public void store()
           throws MBeanException,
                  RuntimeOperationsException,
                  InstanceNotFoundException

捕获此 MBean 实例的当前状态，并将它写出到持久存储中。存储的状态可以包括属性和操作值。

如果此类的实例不支持持久存储，则抛出包装 ServiceNotFoundException 的 MBeanException。

来自 MBean 和属性描述符的持久策略用于指导此方法的执行。如果 'persistPolicy' 是以下值，则应存储 MBean：

  != "never"
   = "always"
   = "onTimer" and now > 'lastPersistTime' + 'persistPeriod'
   = "NoMoreOftenThan" and now > 'lastPersistTime' + 'persistPeriod'
   = "onUnregister"

如果 'persistPolicy' 字段是以下值，则不存储 MBean：

    = "never"
    = "onUpdate"
    = "onTimer" && now < 'lastPersistTime' + 'persistPeriod'

指定者：
接口 PersistentMBean 中的 store
抛出：
MBeanException - 包装另一个异常，或者如果不支持持久存储
RuntimeOperationsException - 包装来自持久机制的异常
InstanceNotFoundException - 不能找到/访问持久存储

getMBeanInfo

public MBeanInfo getMBeanInfo()
返回此 RequiredModelMBean 公开的属性、操作、构造方法和通知是为了便于管理。

指定者：
接口 DynamicMBean 中的 getMBeanInfo
返回：
允许检索此 MBean 的所有属性、操作和 Notification 的 ModelMBeanInfo 的实例。

invoke

public Object invoke(String opName,
                     Object[] opArgs,
                     String[] sig)
              throws MBeanException,
                     ReflectionException
调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。

如果要调用的给定方法连同提供的签名与 RequiredModelMbean 可访问方法中的某个方法匹配，则将调用此匹配的方法。否则将在托管资源上尝试调用给定的方法。

该操作返回的最后一个值可以在该操作的描述符中进行缓存，此描述符位于 ModelMBeanOperationInfo 的描述符中。有效值将位于 'value' 字段中（如果有）。如果描述符中的 'currencyTimeLimit' 字段为：

  • <0 则不缓存该值，且该值永远无效。调用 operation 方法。清除 'value' 和 'lastUpdatedTimeStamp' 字段。
  • =0 则总是缓存该值，且该值总有效。返回 'value' 字段。如果没有 'value' 字段，则调用属性的 operation 方法。将 'lastUpdatedTimeStamp' 字段和 `value' 字段设置为该操作返回的值和当前时间戳。
  • >0 表示 'value' 字段有效的秒数。当 'lastUpdatedTimeStamp' + 'currencyTimeLimit' > Now 时，'value' 字段不再有效。
    • 当 'value' 有效时，返回 'value'。
    • 当 'value' 不再有效时，调用 operation 方法。更新 'lastUpdatedTimeStamp' 字段和 `value' 字段。

注：由于与此规范以前版本不一致，因此对于 currencyTimeLimit，建议不要使用负值或零。要指示某个缓存的值永远无效，请忽略 currencyTimeLimit 字段。要指示它总是有效，请为此字段使用一个非常大的值。

指定者：
接口 DynamicMBean 中的 invoke
参数：
opName - 要调用的方法名称。此名称可以是包括类名称的完全限定方法名，如果类名称是在操作描述符的 'class' 字段中定义的，则此名称也可以仅为方法名称。
opArgs - 包含调用操作时要设置的参数的数组
sig - 包含操作签名的数组。用于加载类对象的类加载器与用于加载 MBean（要在其上调用操作）的类加载器相同。
返回：
该方法返回的对象，它表示在指定托管资源上调用方法的结果。
抛出：
MBeanException - 包装以下 Exceptions 之一：
  • 由管理对象调用的方法抛出的 Exception。
  • ServiceNotFoundException: 为指定操作或托管资源定义的 ModelMBeanOperationInfo 或 descriptor 都不为 null。
  • InvalidTargetObjectTypeException: 'targetType' 字段值不为 'objectReference'。
ReflectionException - 包装一个试图调用该方法时抛出的 Exception。
RuntimeOperationsException - 包装一个 IllegalArgumentException。方法名称为 null。

getAttribute

public Object getAttribute(String attrName)
                    throws AttributeNotFoundException,
                           MBeanException,
                           ReflectionException
返回为此 ModelMBean 定义的指定属性的值。该属性返回的最后一个值可以在该属性的描述符中进行缓存。有效值将位于 'value' 字段中（如果有）。如果描述符中的 'currencyTimeLimit' 字段为：
  • <0 则不缓存该值，且该值永远无效。调用该属性的获取方法。清除 'value' 和 'lastUpdatedTimeStamp' 字段。
  • =0 则总是缓存该值，且该值总有效。返回 'value' 字段。如果没有 'value' 字段，则调用属性的获取方法。将 'lastUpdatedTimeStamp' 字段和 'value' 字段设置为该属性值和当前时间戳。
  • >0 表示 'value' 字段有效的秒数。当 'lastUpdatedTimeStamp' + 'currencyTimeLimit' > Now 时，'value' 字段不再有效。
    • 当 'value' 有效时，返回 'value'。
    • 当 'value' 不再有效时，调用该属性的获取方法。更新 'lastUpdatedTimeStamp' 字段和 `value' 字段。

注：由于与此规范以前版本不一致，因此对于 currencyTimeLimit，建议不要使用负值或零。要指示某个缓存的值永远无效，请忽略 currencyTimeLimit 字段。要指示它总是有效，请为此字段使用一个非常大的值。

如果 'getMethod' 字段包含有效的操作描述符名称，则执行操作描述符所描述的方法。该方法的响应将作为属性值返回。如果操作失败或返回值的类型与属性声明的类型不兼容，则将抛出异常。

如果没有定义 'getMethod' 字段，则返回属性的默认值。如果返回值的类型与属性声明的类型不兼容，则将抛出异常。

属性声明的类型是 MBeanAttributeInfo.getType() 返回的 String。如果以下条件中有一个为真，则值与此类型兼容：

  • 值为 null；
  • 声明的名称是基本类型名（比如 "int"）且该值是对应包装器类的实例（比如 java.lang.Integer）；
  • 值类的名称与声明的名称完全相同；
  • 声明的名称可以通过值的类加载器加载，并能生成一个类，且可以将值赋予该类。

在此实现中，对于需要调用 getMethod 的每种情况，因为该方法是通过标准的 "invoke" 方法调用的并因此需要 operationInfo，所以必须为该 getMethod 指定一个操作，以便调用正确工作。

指定者：
接口 DynamicMBean 中的 getAttribute
参数：
attrName - 指定要检索的属性名称的 String。它必须与 ModelMBeanAttributeInfo 名称匹配。
返回：
从描述符 'value' 字段或从描述符的 'getMethod' 字段中的操作调用检索到的属性值。
抛出：
AttributeNotFoundException - 如果指定的属性在 MBean 中不是可访问的。以下情况可能导致 AttributeNotFoundException：
  • 未找到 Model MBean 的 ModelMBeanInfo。
  • 未找到指定属性名称的 ModelMBeanAttributeInfo。
  • ModelMBeanAttributeInfo isReadable 方法返回 'false'。
MBeanException - 包装以下 Exception 之一：
  • InvalidAttributeValueException: 从属性的获取方法检索到一个错误值类型，或者描述符中未定义属性的 'getMethod' 字段且默认值不存在。
  • ServiceNotFoundException: 没有为属性的获取方法定义 ModelMBeanOperationInfo，或者没有与 ModelMBeanOperationInfo 关联的描述符，或者托管资源为 null。
  • InvalidTargetObjectTypeException 'targetType' 字段值不是 'objectReference'。
  • 由管理对象的设置方法抛出的 Exception。
ReflectionException - 包装试图调用设置方法时抛出的 Exception。
RuntimeOperationsException - 包装 IllegalArgumentException：参数中的属性名称为 null。
另请参见：
setAttribute(javax.management.Attribute)

getAttributes

public AttributeList getAttributes(String[] attrNames)
返回 ModelMBean 中几个属性的值。执行所传入的 attrNames 数组中每个属性名称的 getAttribute。

指定者：
接口 DynamicMBean 中的 getAttributes
参数：
attrNames - 要检索的属性名称的 String 数组。
返回：
检索到的属性的数组。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException：参数中的对象名称为 null，或参数中的属性为 null。
另请参见：
setAttributes(javax.management.AttributeList)

setAttribute

public void setAttribute(Attribute attribute)
                  throws AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
设置指定的 ModelMBean 的指定属性值。如果属性描述符的 'setMethod' 字段包含有效的操作描述符名称，则执行操作描述符所描述的方法。在此实现中，必须正确指定操作描述符，并将它们分配给 modelMBeanInfo，以便 'setMethod' 正确工作。该方法的响应将被设置为描述符中的属性值。

如果 currencyTimeLimit > 0，则在属性描述符的 'value' 字段中缓存属性的新值，并且 'lastUpdatedTimeStamp' 字段设置为当前时间戳。

如果属性描述符的 persist 字段不为 null，则来自属性描述符的 Persistence 策略用于指导在持久存储中存储属性。
如果 'persistPolicy' 字段是以下值，则存储 MBean：

  • != "never"
  • = "always"
  • = "onUpdate"
  • = "onTimer" and now > 'lastPersistTime' + 'persistPeriod'
  • = "NoMoreOftenThan" and now > 'lastPersistTime' + 'persistPeriod'
如果 'persistPolicy' 字段是以下值，则不存储 MBean：
  • = "never"
  • = "onTimer" && now < 'lastPersistTime' + 'persistPeriod'
  • = "onUnregister"
  • = "NoMoreOftenThan" and now < 'lastPersistTime' + 'persistPeriod'

Model MBean 的 ModelMBeanInfo 存储于文件中。

指定者：
接口 DynamicMBean 中的 setAttribute
参数：
attribute - 包含要设置的属性的名称和要设置的值的 Attribute 实例。
抛出：
AttributeNotFoundException - 如果指定的属性在 MBean 中不是可访问的。
以下情况可能导致 AttributeNotFoundException：
  • 未找到指定属性的 ModelMBeanAttributeInfo。
  • ModelMBeanAttributeInfo 的 isWritable 方法返回 'false'。
InvalidAttributeValueException - 如果没有为指定的属性定义描述符。
MBeanException - 包装以下 Exception 之一：
  • 由管理对象的设置方法抛出的 Exception。
  • 如果在属性的描述符中定义了一个 setMethod 字段且托管资源为 null，或者没有定义任何 setMethod 字段且该属性没有启用缓存，则抛出 ServiceNotFoundException。注意，如果也没有定义任何 getMethod 字段，则将自动启用缓存。
  • InvalidTargetObjectTypeException 'targetType' 字段值不是 'objectReference'。
  • 由管理对象的设置方法抛出的 Exception。
ReflectionException - 包装试图调用设置方法时抛出的 Exception。
RuntimeOperationsException - 包装一个 IllegalArgumentException：参数中的属性为 null。
另请参见：
getAttribute(java.lang.String)

setAttributes

public AttributeList setAttributes(AttributeList attributes)
设置此 ModelMBean 的属性数组的值。为列表中每个属性执行 setAttribute() 方法。

指定者：
接口 DynamicMBean 中的 setAttributes
参数：
attributes - 属性列表：要设置的属性的标识和这些属性要设置的值。
返回：
所设置的属性数组，以及 Attribute 实例中它们的新值。
抛出：
RuntimeOperationsException - 包装一个 IllegalArgumentException：参数中的对象名称为 null，或参数中的属性为 null。
另请参见：
getAttributes(java.lang.String[])

addNotificationListener

public void addNotificationListener(NotificationListener listener,
                                    NotificationFilter filter,
                                    Object handback)
                             throws IllegalArgumentException
注册一个将 NotificationListener 接口实现为侦听器的对象。当通过或由 ModelMBean 发布任何通知时，将调用此对象的 'handleNotification()' 方法。这不包括 attributeChangeNotifications。它们必须独立注册。

指定者：
接口 NotificationBroadcaster 中的 addNotificationListener
参数：
listener - 将处理由已注册的 MBean 发出的通知的侦听器对象。
filter - 过滤器对象。如果为 null，则在处理通知之前将不执行过滤。
handback - 当发出通知时，要发送到带有通知的侦听器的上下文。
抛出：
IllegalArgumentException - 侦听器不可以为 null。
另请参见：
removeNotificationListener(javax.management.NotificationListener)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener)
                                throws ListenerNotFoundException
从 RequiredModelMBean 移除一个 Notification 的侦听器。

指定者：
接口 NotificationBroadcaster 中的 removeNotificationListener
参数：
listener - 正在处理由注册的 MBean 发出的通知的侦听器名称。此方法将移除与此侦听器相关的所有信息。
抛出：
ListenerNotFoundException - 侦听器未在 MBean 中注册，或为 null。
另请参见：
addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeNotificationListener

public void removeNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)
                                throws ListenerNotFoundException
从接口 NotificationEmitter 复制的描述

从此 MBean 移除一个侦听器。该 MBean 必须有一个与给定 listener、filter 和 handback 参数完全匹配的侦听器。如果有多个此类侦听器，则只移除一个侦听器。

当且仅当在要移除的侦听器中 filter 和 handback 参数为 null 时，这两个参数才可以为 null。

指定者：
接口 NotificationEmitter 中的 removeNotificationListener
参数：
listener - 以前添加到此 MBean 中的侦听器。
filter - 添加侦听器时指定的过滤器。
handback - 添加侦听器时指定的回送。
抛出：
ListenerNotFoundException - 如果没有在该 MBean 中注册侦听器，或者没有用给定的过滤器和回送注册它。

sendNotification

public void sendNotification(Notification ntfyObj)
                      throws MBeanException,
                             RuntimeOperationsException
从接口 ModelMBeanNotificationBroadcaster 复制的描述
以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。

指定者：
接口 ModelMBeanNotificationBroadcaster 中的 sendNotification
参数：
ntfyObj - 要传递给侦听器对象的 'handleNotification' 方法的通知。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 Notification 对象为 null。

sendNotification

public void sendNotification(String ntfyText)
                      throws MBeanException,
                             RuntimeOperationsException
从接口 ModelMBeanNotificationBroadcaster 复制的描述
将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。

指定者：
接口 ModelMBeanNotificationBroadcaster 中的 sendNotification
参数：
ntfyText - Notification 中要传递到侦听器对象的 'handleNotification' 方法的文本。 所构造的 Notification 将为： 类型 "jmx.modelmbean.generic" 源 此 ModelMBean 实例 序列 1
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 Notification 文本字符串为 null。

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()
返回总是由 RequiredModelMBean 生成的 Notification 数组。

RequiredModelMBean 还可能总是发送两个其他通知：

  • 一个带有描述符 "name=GENERIC,descriptorType=notification,log=T,severity=6,displayName=jmx.modelmbean.generic"
  • 第二个是带有描述符 "name=ATTRIBUTE_CHANGE,descriptorType=notification,log=T,severity=6,displayName=jmx.attribute.change" 的标准属性更改通知
因此这两个通知总是被添加到由应用程序指定的通知中。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
返回：
MBeanNotificationInfo[]

addAttributeChangeNotificationListener

public void addAttributeChangeNotificationListener(NotificationListener inlistener,
                                                   String inAttributeName,
                                                   Object inhandback)
                                            throws MBeanException,
                                                   RuntimeOperationsException,
                                                   IllegalArgumentException
从接口 ModelMBeanNotificationBroadcaster 复制的描述
注册一个将 NotificationListener 接口实现为侦听器的对象。当通过或由 ModelMBean 发布任何 attributeChangeNotification 时，将调用此对象的 'handleNotification()' 方法。这不包括其他 Notification。它们必须独立注册。将为此 attributeName 生成一个 AttributeChangeNotification。

指定者：
接口 ModelMBeanNotificationBroadcaster 中的 addAttributeChangeNotificationListener
参数：
inlistener - 将处理由已注册的 MBean 发出的通知的侦听器对象。
inAttributeName - 要为其接收更改通知的 ModelMBean 属性名称。如果参数为 null，则所有更改将导致发布 attributeChangeNotification。
inhandback - 当发出通知时，要发送到带有通知的侦听器的上下文。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException。传入参数中的属性名称不存在。
IllegalArgumentException - 侦听器不可以为 null。
另请参见：
ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String)

removeAttributeChangeNotificationListener

public void removeAttributeChangeNotificationListener(NotificationListener inlistener,
                                                      String inAttributeName)
                                               throws MBeanException,
                                                      RuntimeOperationsException,
                                                      ListenerNotFoundException
从接口 ModelMBeanNotificationBroadcaster 复制的描述
从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。

指定者：
接口 ModelMBeanNotificationBroadcaster 中的 removeAttributeChangeNotificationListener
参数：
inlistener - 正在处理由注册的 MBean 发出的通知的侦听器名称。此方法将移除与此侦听器相关的所有信息。
inAttributeName - 侦听器不再为其接收 attributeChangeNotifications 的属性。如果为 null，则将移除所有 attributeChangeNotifications 的侦听器。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException 如果 inAttributeName 参数没有对应一个属性名称。
ListenerNotFoundException - 侦听器未在 MBean 中注册，或为 null。
另请参见：
ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(javax.management.NotificationListener, java.lang.String, java.lang.Object)

sendAttributeChangeNotification

public void sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
                                     throws MBeanException,
                                            RuntimeOperationsException
从接口 ModelMBeanNotificationBroadcaster 复制的描述
将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。

指定者：
接口 ModelMBeanNotificationBroadcaster 中的 sendAttributeChangeNotification
参数：
ntfyObj - 要传递给侦听器对象的 'handleNotification' 方法的通知。
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 AttributeChangeNotification 对象为 null。

sendAttributeChangeNotification

public void sendAttributeChangeNotification(Attribute inOldVal,
                                            Attribute inNewVal)
                                     throws MBeanException,
                                            RuntimeOperationsException
从接口 ModelMBeanNotificationBroadcaster 复制的描述
将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。

指定者：
接口 ModelMBeanNotificationBroadcaster 中的 sendAttributeChangeNotification
参数：
inOldVal - 属性的原始值
inNewVal - 属性的当前值

所构造的 attributeChangeNotification 将为：
类型     "jmx.attribute.change"
源      此 ModelMBean 实例
序列    1
   attributeName oldValue.getName()
   attributeType oldValue's class
   attributeOldValue oldValue.getValue()
   attributeNewValue newValue.getValue()
抛出：
MBeanException - 包装一个分布式通信异常。
RuntimeOperationsException - 包装一个 IllegalArgumentException：传入参数中的 Attribute 对象为 null，或参数中两个 Attribute 对象的名称不同。

getClassLoaderRepository

protected ClassLoaderRepository getClassLoaderRepository()
返回用于执行类加载的 Class Loader Repository。子类可能希望重新定义此方法，以便返回应在此对象中使用的适当 ClassLoaderRepository。

返回：
类加载器存储库。

preRegister

public ObjectName preRegister(MBeanServer server,
                              ObjectName name)
                       throws Exception
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。如果未指定 MBean 名称，则 MBean 可以提供其注册的名称。如果引发任何异常，MBean 将不会注册到 MBean 服务器中。

为确保 RequireModelMBean 的运行时语义正确，重新加载或重写此方法的任何 RequiredModelMBean 的子类都应在自己的 preRegister 实现中调用 super.preRegister(server, name)。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
server - 将在其中注册 MBean 的 MBean 服务器。
name - MBean 的对象名称。如果传递到 MBeanServer 接口中的 createMBean 或 registerMBean 方法的名称参数为 null，则此名称为 null。在这种情况下，此方法必须返回新 MBean 的非 null ObjectName。
返回：
MBean 将注册的名称。此值必须不为 null。如果 name 参数不为 null，那么它通常（但并非必要）是返回的值。
抛出：
Exception - 此异常由 MBean 服务器捕获，并以 MBeanRegistrationException 的形式重新抛出。

postRegister

public void postRegister(Boolean registrationDone)
允许 MBean 在已注册到 MBean 服务器之后或注册失败之后执行任何所需要的操作。

为确保 RequireModelMBean 的运行时语义正确，重新加载或重写此方法的任何 RequiredModelMBean 的子类都应在自己的 postRegister 实现中调用 super.postRegister(registrationDone)。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示 MBean 是否已成功注册到 MBean 服务器中。值 false 意味着注册失败。

preDeregister

public void preDeregister()
                   throws Exception
允许 MBean 在由 MBean 服务器注销之前执行任何所需要的操作。

为确保 RequireModelMBean 的运行时语义正确，重新加载或重写此方法的任何 RequiredModelMBean 的子类都应在自己的 preDeregister 实现中调用 super.preDeregister()。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
Exception - 此异常由 MBean 服务器捕获，并以 MBeanRegistrationException 的形式重新抛出。

postDeregister

public void postDeregister()
允许 MBean 在已从 MBean 服务器注销之后执行任何所需要的操作。

为确保 RequireModelMBean 的运行时语义正确，重新加载或重写此方法的任何 RequiredModelMBean 的子类都应在自己的 postDeregister 实现中调用 super.postDeregister()。

指定者：
接口 MBeanRegistration 中的 postDeregister
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XMLParseException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.modelmbean
类 XMLParseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.management.modelmbean.XMLParseException
所有已实现的接口：
Serializable
public class XMLParseException
extends Exception

当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。 它还用于来自可能被使用的 XML 解析器的包装器异常。

此类的 serialVersionUID 为 3176664577895105181L。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
XMLParseException()
默认构造方法。
XMLParseException(Exception e, String s)
带有字符串和异常的构造方法。
XMLParseException(String s)
带有字符串的构造方法。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

XMLParseException

public XMLParseException()
默认构造方法。

XMLParseException

public XMLParseException(String s)
带有字符串的构造方法。

参数：
s - 详细消息。

XMLParseException

public XMLParseException(Exception e,
                         String s)
带有字符串和异常的构造方法。

参数：
e - 嵌套的异常。
s - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.modelmbean (Java 2 Platform SE 6)

 javax.management.modelmbean
接口
ModelMBean
ModelMBeanInfo
ModelMBeanNotificationBroadcaster
类
DescriptorSupport
ModelMBeanAttributeInfo
ModelMBeanConstructorInfo
ModelMBeanInfoSupport
ModelMBeanNotificationInfo
ModelMBeanOperationInfo
RequiredModelMBean
异常
InvalidTargetObjectTypeException
XMLParseException


javax.management.modelmbean (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.modelmbean

提供了 ModelMBean 类的定义。

请参见：
描述

接口摘要
ModelMBean | ModelMBean 必须实现此接口。
ModelMBeanInfo | 此接口由每个 ModelMBean 的 ModelMBeanInfo 实现。
ModelMBeanNotificationBroadcaster | ModelMBean 必须实现此接口。

类摘要
DescriptorSupport | 此类表示 ModelMBean 元素的元数据集。
ModelMBeanAttributeInfo | ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
ModelMBeanConstructorInfo | ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
ModelMBeanInfoSupport | 此类表示 ModelMBean 的元数据。
ModelMBeanNotificationInfo | ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
ModelMBeanOperationInfo | ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。
RequiredModelMBean | 此类是 ModelMBean 的实现。

异常摘要
InvalidTargetObjectTypeException | 当指定了无效的目标对象类型时，抛出此异常。
XMLParseException | 当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

软件包 javax.management.modelmbean 的描述

提供了 ModelMBean 类的定义。Model MBean 是充当管理接口与底层托管资源之间桥梁的 MBean。管理接口和托管资源都指定为 Java 对象。不同管理接口和托管资源可以多次重用相同的 Model MBean 实现，它可以提供诸如持久存储和缓存这样常见的功能。

Model MBean 实现 ModelMBean 接口。它是一个 DynamicMBean 接口，该接口的 getMBeanInfo 方法返回实现 ModelMBeanInfo 的对象。

每个 MBean 都有一个 MBeanInfo，它包含关于 MBean 本身、其属性、操作、构造方法和通知的信息。Model MBean 用 Descriptor 来扩充此 MBeanInfo，这里 Descriptor 通过 (key,value) 对的形式对其他信息进行编码。通常，Descriptor 是 DescriptorSupport 的实例。

RequiredModelMBean 类提供了标准的 Model MBean 实现。

以下显示了一个 Model MBean 的示例，它使我们可以通过 MBean 服务器管理 HashMap 的 get 方法。其他方法不能通过 MBean 服务器进行管理。这里 HashMap 没有特殊的地方。任何公共类的公共方法都可以通过相同方式进行管理。

import java.lang.reflect.Method;
import java.util.HashMap;
import javax.management.*;
import javax.management.modelmbean.*;

// ...

MBeanServer mbs = MBeanServerFactory.createMBeanServer();
// The MBean Server

HashMap map = new HashMap();
// The resource that will be managed

// Construct the management interface for the Model MBean
Method getMethod = HashMap.class.getMethod("get", new Class[] {Object.class});
ModelMBeanOperationInfo getInfo =
    new ModelMBeanOperationInfo("Get value for key", getMethod);
ModelMBeanInfo mmbi =
    new ModelMBeanInfoSupport(HashMap.class.getName(),
                              "Map of keys and values",
                              null,  // no attributes
                              null,  // no constructors
                              new ModelMBeanOperationInfo[] {getInfo},
                              null); // no notifications

// Make the Model MBean and link it to the resource
ModelMBean mmb = new RequiredModelMBean(mmbi);
mmb.setManagedResource(map, "ObjectReference");

// Register the Model MBean in the MBean Server
ObjectName mapName = new ObjectName(":type=Map,name=whatever");
mbs.registerMBean(mmb, mapName);

// Resource can evolve independently of the MBean
map.put("key", "value");

// Can access the "get" method through the MBean Server
mbs.invoke(mapName, "get", new Object[] {"key"}, new String[] {Object.class.getName()});
// returns "value"

包规范

  • 参见有关 JMX 的 Java SE 6 Platform 文档中可用的 JMX 1.3 规范 的 PDF 文档。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.modelmbean 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.modelmbean 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.management.modelmbean.DescriptorSupport (implements javax.management.Descriptor)
    • javax.management.MBeanFeatureInfo (implements javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.MBeanAttributeInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanAttributeInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanConstructorInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanConstructorInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanNotificationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanNotificationInfo (implements javax.management.DescriptorAccess)
      • javax.management.MBeanOperationInfo (implements java.lang.Cloneable)
        • javax.management.modelmbean.ModelMBeanOperationInfo (implements javax.management.DescriptorAccess)
    • javax.management.MBeanInfo (implements java.lang.Cloneable, javax.management.DescriptorRead, java.io.Serializable)
      • javax.management.modelmbean.ModelMBeanInfoSupport (implements javax.management.modelmbean.ModelMBeanInfo)
    • javax.management.modelmbean.RequiredModelMBean (implements javax.management.MBeanRegistration, javax.management.modelmbean.ModelMBean, javax.management.NotificationEmitter)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.management.modelmbean.InvalidTargetObjectTypeException
        • javax.management.modelmbean.XMLParseException

接口分层结构

  • javax.management.DynamicMBean
    • javax.management.modelmbean.ModelMBean (并 extends javax.management.modelmbean.ModelMBeanNotificationBroadcaster, javax.management.PersistentMBean)
  • javax.management.modelmbean.ModelMBeanInfo
  • javax.management.NotificationBroadcaster
    • javax.management.modelmbean.ModelMBeanNotificationBroadcaster
      • javax.management.modelmbean.ModelMBean (并 extends javax.management.DynamicMBean, javax.management.PersistentMBean)
  • javax.management.PersistentMBean
    • javax.management.modelmbean.ModelMBean (并 extends javax.management.DynamicMBean, javax.management.modelmbean.ModelMBeanNotificationBroadcaster)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.modelmbean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.modelmbean
的使用

使用 javax.management.modelmbean 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 使用的 javax.management.modelmbean 中的类
DescriptorSupport
此类表示 ModelMBean 元素的元数据集。
InvalidTargetObjectTypeException
当指定了无效的目标对象类型时，抛出此异常。
ModelMBean
ModelMBean 必须实现此接口。
ModelMBeanAttributeInfo
ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
ModelMBeanConstructorInfo
ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
ModelMBeanInfo
此接口由每个 ModelMBean 的 ModelMBeanInfo 实现。
ModelMBeanNotificationBroadcaster
ModelMBean 必须实现此接口。
ModelMBeanNotificationInfo
ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
ModelMBeanOperationInfo
ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。
XMLParseException
当将某个 XML 格式的字符串解析为 ModelMBean 对象，或从 ModelMBean 对象创建 XML 格式的字符串时，抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.DescriptorSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.DescriptorSupport
的使用

使用 DescriptorSupport 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 DescriptorSupport 的使用

参数类型为 DescriptorSupport 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(DescriptorSupport inDescr)
采用 Descriptor 作为参数的描述符构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.InvalidTargetObjectTypeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.InvalidTargetObjectTypeException
的使用

使用 InvalidTargetObjectTypeException 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 InvalidTargetObjectTypeException 的使用

抛出 InvalidTargetObjectTypeException 的 javax.management.modelmbean 中的方法
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.modelmbean.ModelMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.modelmbean.ModelMBean
的使用

使用 ModelMBean 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBean 的使用

实现 ModelMBean 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.ModelMBeanAttributeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanAttributeInfo
的使用

使用 ModelMBeanAttributeInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanAttributeInfo 的使用

返回 ModelMBeanAttributeInfo 的 javax.management.modelmbean 中的方法
ModelMBeanAttributeInfo | ModelMBeanInfo.getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)

参数类型为 ModelMBeanAttributeInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(ModelMBeanAttributeInfo inInfo)
根据此 ModelMBeanAttributeInfo Object 构造新的 ModelMBeanAttributeInfo 对象。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.ModelMBeanConstructorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanConstructorInfo
的使用

使用 ModelMBeanConstructorInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanConstructorInfo 的使用

返回 ModelMBeanConstructorInfo 的 javax.management.modelmbean 中的方法
 ModelMBeanConstructorInfo ModelMBeanInfoSupport.getConstructor(String inName)
返回通过名称请求的 ModelMBeanConstructorInfo。

参数类型为 ModelMBeanConstructorInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.modelmbean.ModelMBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.modelmbean.ModelMBeanInfo
的使用

使用 ModelMBeanInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanInfo 的使用

实现 ModelMBeanInfo 的 javax.management.modelmbean 中的类
 class ModelMBeanInfoSupport
此类表示 ModelMBean 的元数据。

参数类型为 ModelMBeanInfo 的 javax.management.modelmbean 中的方法
void | ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。

参数类型为 ModelMBeanInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(ModelMBeanInfo mbi)
构造作为给定 ModelMBeanInfoSupport 副本的 ModelMBeanInfoSupport。
RequiredModelMBean(ModelMBeanInfo mbi)
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.ModelMBeanInfoSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanInfoSupport
的使用

没有 javax.management.modelmbean.ModelMBeanInfoSupport 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.modelmbean.ModelMBeanNotificationBroadcaster
的使用

使用 ModelMBeanNotificationBroadcaster 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanNotificationBroadcaster 的使用

javax.management.modelmbean 中 ModelMBeanNotificationBroadcaster 的子接口
 interface ModelMBean
ModelMBean 必须实现此接口。

实现 ModelMBeanNotificationBroadcaster 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.ModelMBeanNotificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanNotificationInfo
的使用

使用 ModelMBeanNotificationInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanNotificationInfo 的使用

返回 ModelMBeanNotificationInfo 的 javax.management.modelmbean 中的方法
ModelMBeanNotificationInfo | ModelMBeanInfo.getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)

参数类型为 ModelMBeanNotificationInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanNotificationInfo(ModelMBeanNotificationInfo inInfo)
从此 ModelMBeanNotfication Object 构造新 ModelMBeanNotificationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.ModelMBeanOperationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.ModelMBeanOperationInfo
的使用

使用 ModelMBeanOperationInfo 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 ModelMBeanOperationInfo 的使用

返回 ModelMBeanOperationInfo 的 javax.management.modelmbean 中的方法
ModelMBeanOperationInfo | ModelMBeanInfo.getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)

参数类型为 ModelMBeanOperationInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications)
创建带有所提供的信息、但描述符为默认描述符的 ModelMBeanInfoSupport。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanOperationInfo(ModelMBeanOperationInfo inInfo)
根据此 ModelMBeanOperation Object 构造新的 ModelMBeanOperationInfo 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.RequiredModelMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.RequiredModelMBean
的使用

没有 javax.management.modelmbean.RequiredModelMBean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.modelmbean.XMLParseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.modelmbean.XMLParseException
的使用

使用 XMLParseException 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 XMLParseException 的使用

抛出 XMLParseException 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


JMXAddressable (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
接口 JMXAddressable

所有已知实现类：
JMXConnectorServer, RMIConnector, RMIConnectorServer
public interface JMXAddressable

由可能具有 JMXServiceURL 地址的对象实现。所有 JMXConnectorServer 对象都可以实现此接口。根据连接器实现，JMXConnector 对象也可以实现此接口。RMI Connector 的 JMXConnector 对象是实现此接口的 RMIConnector 实例。

实现此接口的对象在某一特定时刻可能没有地址。这可以通过 getAddress() 中的 null 返回值指示。

从以下版本开始：
1.6

方法摘要
 JMXServiceURL getAddress()
此对象的地址。

方法详细信息

getAddress

JMXServiceURL getAddress()

此对象的地址。

返回：
此对象的地址；如果没有地址，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


JMXAuthenticator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
接口 JMXAuthenticator

public interface JMXAuthenticator

定义如何将远程凭据转换为 JAAS Subject（主题）的接口。此接口由 RMI Connector Server 使用，也可供其他连接器服务器使用。

此由用户定义的验证实例作为属性 JMXConnectorServer.AUTHENTICATOR 的值被传入环境映射中的连接器服务器。对于只使用此验证系统的连接器服务器，如果此属性不存在或者其值为 null，则将不执行任何对用户的验证并允许对由 MBeanServerConnection 对象导出的方法的完全访问。

如果验证成功，则返回一个用其关联的 principal 填充的经验证的 subject。然后将基于给定的主体集执行验证检查。

从以下版本开始：
1.5

方法摘要
 Subject authenticate(Object credentials)
用给定的客户端凭据验证 MBeanServerConnection 客户端。

方法详细信息

authenticate

Subject authenticate(Object credentials)

用给定的客户端凭据验证 MBeanServerConnection 客户端。

参数：
credentials - 用户定义的凭据，其传入此服务器以便在创建 MBeanServerConnection 之前验证用户。此参数的实际类型，以及是否允许为 null，取决于连接器。
返回：
包含其关联主体的经验证的主题。
抛出：
SecurityException - 如果服务器无法用所提供的凭据验证用户。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnectionNotification (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXConnectionNotification

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.management.Notification
            继承者  javax.management.remote.JMXConnectionNotification
所有已实现的接口：
Serializable
public class JMXConnectionNotification
extends Notification

在客户端连接打开或关闭时，或者当通知丢失时发出的通知。这些通知由连接器服务器（JMXConnectorServer 的实例）和连接器客户端（JMXConnector 的实例）进行发送。在某些连接器中，一个会话可包含一个连接序列。将为每个连接发送打开连接或关闭连接的通知。

通知的类型为以下之一：

类型 | 含义
jmx.remote.connection.opened | 打开了一个新的客户端连接。
jmx.remote.connection.closed | 关闭了一个客户端连接。
jmx.remote.connection.failed | 客户端连接意外失败。
jmx.remote.connection.notifs.lost | 客户端连接可能已丢失通知。此通知只出现在客户端。

通知的 timeStamp 为一个时间值（与 System.currentTimeMillis() 一致），它指示通知的构造时间。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static String | CLOSED 关闭连接通知的通知类型字符串。
static String | FAILED 连接失败通知的通知类型字符串。
static String | NOTIFS_LOST 可能已丢失通知的连接的通知类型字符串。
static String | OPENED 打开连接通知的通知类型字符串。
从类 javax.management.Notification 继承的字段
source
构造方法摘要
JMXConnectionNotification(String type, Object source, String connectionId, long sequenceNumber, String message, Object userData)
构造一个新的连接通知。
方法摘要
 String getConnectionId()
该通知所属连接的连接 ID。
从类 javax.management.Notification 继承的方法
getMessage, getSequenceNumber, getTimeStamp, getType, getUserData, setSequenceNumber, setSource, setTimeStamp, setUserData, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OPENED

public static final String OPENED

打开连接通知的通知类型字符串。

另请参见：
常量字段值

CLOSED

public static final String CLOSED

关闭连接通知的通知类型字符串。

另请参见：
常量字段值

FAILED

public static final String FAILED

连接失败通知的通知类型字符串。

另请参见：
常量字段值

NOTIFS_LOST

public static final String NOTIFS_LOST

可能已丢失通知的连接的通知类型字符串。

另请参见：
常量字段值
构造方法详细信息

JMXConnectionNotification

public JMXConnectionNotification(String type,
                                 Object source,
                                 String connectionId,
                                 long sequenceNumber,
                                 String message,
                                 Object userData)
构造一个新的连接通知。通知的 source 取决于它是由连接器服务器发送还是连接器客户端发送：
  • 对于连接器服务器，如果它是在 MBean 服务器上注册的，则源为在其上注册的 ObjectName。否则，它是一个到连接器服务器对象自身的引用（JMXConnectorServer 的子类的实例）。
  • 对于连接器客户端，源是一个到连接器客户端对象的引用（实现 JMXConnector 的类的实例）。

参数：
type - 通知的类型。通常为常量 OPENED、CLOSED、FAILED 和 NOTIFS_LOST 之一。如果类型为一个不同的字符串也不为错。
source - 发出此通知的连接器服务器或客户端。
connectionId - 其连接器服务器中的连接的 ID。
sequenceNumber - 一个非负整数。期望但不要求此数大于任何来自该源的通知中已出现过的 sequenceNumber。
message - 不明确的文本消息，通常包含对事件的具有可读性的描述。可以为 null。
userData - 其类型和含义由连接器服务器定义的一个对象。可以为 null。
抛出：
NullPointerException - 如果 type、source 或 connectionId 为 null。
IllegalArgumentException - 如果 sequenceNumber 为负。
方法详细信息

getConnectionId

public String getConnectionId()

该通知所属连接的连接 ID。

返回：
连接 ID。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
接口 JMXConnector

所有超级接口：
Closeable
所有已知实现类：
RMIConnector
public interface JMXConnector
extends Closeable

JMX API 连接器的客户端。使用此类型的对象可建立到连接器服务器的连接。

新创建的此类型对象尚未连接。在此对象能够使用之前，必须调用其 connect 方法。但是，由 JMXConnectorFactory.connect 创建的对象已经连接。

从以下版本开始：
1.5

字段摘要
static String CREDENTIALS
属性的名称，它指定了连接过程中发送给连接器服务器的凭据。
方法摘要
void | addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个接收连接状态改变的侦听器。
void | close() 关闭客户端到其服务器的连接。
void | connect() 建立到连接器服务器的连接。
void | connect(Map<String,?> env) 建立到连接器服务器的连接。
String | getConnectionId() 获得来自连接器服务器的连接 ID。
MBeanServerConnection | getMBeanServerConnection() 返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
MBeanServerConnection | getMBeanServerConnection(Subject delegationSubject) 返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。
void | removeConnectionNotificationListener(NotificationListener listener) 将一个用于接收状态更改通知的侦听器从列表中移除。
void | removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。

字段详细信息

CREDENTIALS

static final String CREDENTIALS

属性的名称，它指定了连接过程中发送给连接器服务器的凭据。与此属性关联的值（如果有）为服务器的 JMXAuthenticator 的具有适当类型的可序列化的对象。

另请参见：
常量字段值
方法详细信息

connect

void connect()
             throws IOException

建立到连接器服务器的连接。此方法等效于 connect(null)。

抛出：
IOException - 如果由于存在通信问题而导致无法建立连接。
SecurityException - 如果由于安全原因而无法建立连接。

connect

void connect(Map<String,?> env)
             throws IOException

建立到连接器服务器的连接。

如果已在该对象上成功调用了 connect，则再次调用将没有任何作用。但是，如果 close() 是在调用 connect 之后调用的，则新的 connect 将抛出 IOException。

否则，在此对象上未调用过任何一个 connect，或者虽然调用过但生成了一个异常。然后对 connect 的调用将试图建立到连接器服务器的连接。

参数：
env - 连接的属性。此映射中的属性重写创建 JMXConnector 时指定的映射中的属性（如果有）。此参数可以为 null，其等效于一个空映射。
抛出：
IOException - 如果由于存在通信问题而导致无法建立连接。
SecurityException - 如果由于安全原因而无法建立连接。

getMBeanServerConnection

MBeanServerConnection getMBeanServerConnection()
                                               throws IOException

返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。对于给定的 JMXConnector，对此方法两次成功的调用通常将返回相同的 MBeanServerConnection 对象，尽管不需要这样做。

对于返回的 MBeanServerConnection 中的每个方法，调用该方法将导致调用远程 MBean 服务器中的相应方法。MBean 服务器方法返回的值就是返回给客户端的值。如果 MBean 服务器方法生成了 Exception，则客户端上也会出现相同的 Exception。如果 MBean 服务器方法（或尝试对它的调用）生成了 Error，则该 Error 将包装在 JMXServerErrorException 中，从客户端能够看到该错误。

调用该方法等效于调用 getMBeanServerConnection(null)，这意味着未指定任何委托主题并且在 MBeanServerConnection 上调用的所有操作必须使用经验证的主题（如果有）。

返回：
一个通过将其方法转发到远程 MBean 服务器而实现 MBeanServerConnection 接口的对象。
抛出：
IOException - 如果无法创建有效的 MBeanServerConnection，例如，由于尚未建立到远程 MBean 服务器的连接（用 connect 方法），或者连接已关闭，或者连接已断开。

getMBeanServerConnection

MBeanServerConnection getMBeanServerConnection(Subject delegationSubject)
                                               throws IOException

返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。对于给定的 JMXConnector 和 Subject，对此方法两次成功的调用通常将返回相同的 MBeanServerConnection 对象，尽管不需要这样做。

对于返回的 MBeanServerConnection 中的每个方法，调用此方法导致调用代表给定委托主题，而不是经验证主题的远程 MBean 服务器上的对应方法。MBean 服务器方法返回的值就是返回给客户端的值。如果 MBean 服务器方法生成了 Exception，则客户端上也会出现相同的 Exception。如果 MBean 服务器方法（或尝试对它的调用）生成了 Error，则该 Error 将包装在 JMXServerErrorException 中，从客户端能够看到该错误。

参数：
delegationSubject - 代表将执行何种请求的 Subject。可以为 null，这种情况下执行请求表示经验证的 Subject（如果有）。
返回：
一个通过将其方法转发到代表给定委托主题的远程 MBean 服务器而实现 MBeanServerConnection 接口的对象。
抛出：
IOException - 如果无法创建有效的 MBeanServerConnection，例如，由于尚未建立到远程 MBean 服务器的连接（用 connect 方法），或者连接已关闭，或者连接已断开。

close

void close()
           throws IOException

关闭客户端到其服务器的连接。任何正在进行中的或新的使用由 getMBeanServerConnection() 返回的 MBeanServerConnection 的请求将获得一个 IOException。

如果已在该对象上成功调用了 close，则再次调用将没有任何作用。如果从未调用过 close，或者调用过但生成了异常，则将尝试关闭该连接。此尝试可能成功，此时 close 将正常返回，也可能生成一个异常。

关闭连接是一个潜在的慢操作。例如，假设服务器已崩溃，则关闭操作可能不得不等待网络协议超时。不希望关闭操作出现阻塞的调用者应在单独的线程中处理关闭。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果无法完全关闭连接。如果抛出此异常，连接的服务器端是否已完全关闭为未知。

addConnectionNotificationListener

void addConnectionNotificationListener(NotificationListener listener,
                                       NotificationFilter filter,
                                       Object handback)

添加一个接收连接状态改变的侦听器。该侦听器将接收 JMXConnectionNotification 类型的通知。实现也可发送任何其他类型的通知。

使用此方法可添加任意个数的侦听器。相同的侦听器可使用相同或不同的 filter 和 handback 值多次添加。不对重复的条目进行任何特殊处理。例如，假设侦听器两次注册均为不带 filter，则将为每个通知调用两次其 handleNotification 方法。

参数：
listener - 用于接收连接状态通知的侦听器。
filter - 用于选择要发送给侦听器的通知的过滤器，如果将发送所有的通知，则为 null。
handback - 将随每个通知提供给侦听器的对象。可以为 null。
抛出：
NullPointerException - 如果 listener 为 null。
另请参见：
removeConnectionNotificationListener(javax.management.NotificationListener), NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeConnectionNotificationListener

void removeConnectionNotificationListener(NotificationListener listener)
                                          throws ListenerNotFoundException

将一个用于接收状态更改通知的侦听器从列表中移除。此侦听器必须在以前已经添加。如果有多个匹配的侦听器，则移除所有匹配的侦听器。

参数：
listener - 用于接收连接状态通知的侦听器。
抛出：
NullPointerException - 如果 listener 为 null。
ListenerNotFoundException - 如果侦听器未用此 JMXConnector 注册。
另请参见：
removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object),
addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object),
NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeConnectionNotificationListener

void removeConnectionNotificationListener(NotificationListener l,
                                          NotificationFilter f,
                                          Object handback)
                                          throws ListenerNotFoundException

将一个用于接收状态更改通知的侦听器从列表中移除。该侦听器必须在以前已经用相同的三个参数添加。如果有多个匹配的侦听器，则只移除一个匹配的侦听器。

参数：
l - 用于接收连接状态通知的侦听器。
f - 用于选择发送给侦听器通知的过滤器。可以为 null。
handback - 将随每个通知提供给侦听器的对象。可以为 null。
抛出：
ListenerNotFoundException - 如果侦听器未用此 JMXConnector 注册，或者未用给定的 filter 和 handback 注册。
另请参见：
removeConnectionNotificationListener(NotificationListener), addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object), NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

getConnectionId

String getConnectionId()
                       throws IOException

获得来自连接器服务器的连接 ID。对于给定的连接器服务器，每个连接将具有一个在连接的整个生命周期中都不改变的唯一 ID。

返回：
此连接的唯一 ID。这与连接器服务器包含在其 JMXConnectionNotification 中的 ID 相同。package description 描述了连接 ID 的约定。
抛出：
IOException - 如果无法获得连接 ID，例如在连接关闭或断开的情况下。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnectorFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXConnectorFactory

java.lang.Object
    继承者  javax.management.remote.JMXConnectorFactory

public class JMXConnectorFactory
extends Object

用于创建 JMX API 连接器客户端的工厂。此类没有实例。

通常使用此类的 connect 方法建立连接。更高级的应用程序可使用 newJMXConnector 分离连接器客户端的创建，使用 JMXConnector.connect(Map) 建立自身的连接。

每个客户端都是由 JMXConnectorProvider 的实例创建的。此实例按如下方式建立。假设给定的 JMXServiceURL 类似于 "service:jmx:protocol:remainder"。则工厂将尝试查找适当的 JMXConnectorProvider 以供 protocol 使用。protocol 中出现的每个 + 或 - 字符都分别由 . 或 _ 替换。

对提供者包列表 的搜索如下所示：

  1. 如果传给 newJMXConnector 的 environment 参数包含关键字 jmx.remote.protocol.provider.pkgs，则关联的值为提供者包列表。
  2. 否则，如果存在系统属性 jmx.remote.protocol.provider.pkgs，则其值为提供者包列表。
  3. 否则，没有任何提供者包列表。

提供者包列表是一个表现为由竖直线 (|) 分隔的非空 Java 包名称列表的字符串。如果该字符串为空，则提供者包列表也为空。如果提供者包列表不是一个字符串，或者如果它包含空字符串元素，则抛出 JMXProviderException 异常。

如果存在提供者包列表并且不为空，则对于列表中的每个 pkg 元素，此工厂将尝试加载以下类

pkg.protocol.ClientProvider

如果传给 newJMXConnector 的 environment 参数包含关键字 jmx.remote.protocol.provider.class.loader，则关联的值为用于加载提供者的类加载器。如果关联的值不是一个 ClassLoader 的实例，则抛出 IllegalArgumentException。

如果 environment 参数中没有 jmx.remote.protocol.provider.class.loader 关键字，则使用调用线程的上下文类加载器。

如果尝试加载该类时生成 ClassNotFoundException，则继续对列表中的下一个元素搜索处理程序。

否则，提供者查找的问题将由 JMXProviderException 通过其 cause 指示如下所示的基础异常来通知：

  • 如果尝试加载类时生成了一个 ClassNotFoundException 之外的异常，则它就是 cause；
  • 如果该类的 Class.newInstance() 生成了异常，则这就是 cause。

如果上述步骤中未找到任何提供者，包括无提供者包列表的默认情况，则实现将使用 protocol 自身的提供者，或者如果也没有自身的提供者，则抛出 MalformedURLException。实现也可以选择通过其他途径查找提供者。例如，它可能支持服务提供者的 JAR 约定，其服务接口为 JMXConnectorProvider。

每个实现都必须支持由字符串 rmi 或 iiop 指定的 RMI 连接器协议。

一旦找到了提供者，newJMXConnector 方法的结果就是在该提供者上调用 newJMXConnector 的结果。

传给 JMXConnectorProvider 的 Map 参数为一个新的只读 Map，它包含了原先传给 JMXConnectorFactory.newJMXConnector 的 environment 参数中的所有条目（如果有）。此外，如果 environment 参数中没有 jmx.remote.protocol.provider.class.loader 关键字，则将此关键字添加到新的只读 Map 中。关联的值为调用线程的上下文类加载器。

从以下版本开始：
1.5

字段摘要
static String | DEFAULT_CLASS_LOADER 指定默认的类加载器的属性名称。
static String | PROTOCOL_PROVIDER_CLASS_LOADER 指定用于加载协议提供者的类加载器的属性名称。
static String | PROTOCOL_PROVIDER_PACKAGES 指定查找协议的处理程序时需参考的提供者包的属性名称。
方法摘要
static JMXConnector | connect(JMXServiceURL serviceURL) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_CLASS_LOADER

public static final String DEFAULT_CLASS_LOADER

指定默认的类加载器的属性名称。该类加载器用于反序列化来自远程 MBeanServerConnection 调用的返回值及异常。与此属性关联的值为 ClassLoader 的实例。

另请参见：
常量字段值

PROTOCOL_PROVIDER_PACKAGES

public static final String PROTOCOL_PROVIDER_PACKAGES

指定查找协议的处理程序时需参考的提供者包的属性名称。与此属性关联的值为由竖直线 (|) 分隔的包名称的字符串。

另请参见：
常量字段值

PROTOCOL_PROVIDER_CLASS_LOADER

public static final String PROTOCOL_PROVIDER_CLASS_LOADER

指定用于加载协议提供者的类加载器的属性名称。与此属性关联的值为 ClassLoader 的实例。

另请参见：
常量字段值
方法详细信息

connect

public static JMXConnector connect(JMXServiceURL serviceURL)
                            throws IOException

创建到位于给定地址的连接器服务器的连接。

此方法等效于 connect(serviceURL, null)。

参数：
serviceURL - 要连接到的连接器服务器的地址。
返回：
调用过其 connect 方法的 JMXConnector。
抛出：
NullPointerException - 如果 serviceURL 为 null。
IOException - 如果由于通信问题造成无法建立连接器客户端或连接。
SecurityException - 如果由于安全原因而无法建立连接。

connect

public static JMXConnector connect(JMXServiceURL serviceURL,
                                   Map<String,?> environment)
                            throws IOException

创建到位于给定地址的连接器服务器的连接。

此方法等效于：

 JMXConnector conn = JMXConnectorFactory.newJMXConnector(serviceURL,
                                                         environment);
 conn.connect(environment);

参数：
serviceURL - 要连接到的连接器服务器的地址。
environment - 用于确定如何建立连接的一组属性。此参数可以为 null。此映射中关键字必须为字符串。每个关联值的适当类型取决于属性。此调用不改变 environment 的内容。
返回：
代表新建立连接的 JMXConnector。每次对此方法的成功调用都生成不同的对象。
抛出：
NullPointerException - 如果 serviceURL 为 null。
IOException - 如果由于通信问题造成无法建立连接器客户端或连接。
SecurityException - 如果由于安全原因而无法建立连接。

newJMXConnector

public static JMXConnector newJMXConnector(JMXServiceURL serviceURL,
                                           Map<String,?> environment)
                                    throws IOException

为位于给定地址的连接器服务器创建一个连接器客户端。结果客户端直到调用其 connect 方法时才连接。

参数：
serviceURL - 要连接到的连接器服务器的地址。
environment - 用于确定如何建立连接的一组属性。此参数可以为 null。此映射中关键字必须为字符串。每个关联值的适当类型取决于属性。此调用不改变 environment 的内容。
返回：
代表新连接器客户端的 JMXConnector。每次对此方法的成功调用都生成不同的对象。
抛出：
NullPointerException - 如果 serviceURL 为 null。
IOException - 如果由于通信问题而导致无法建立连接器客户端。
MalformedURLException - 如果 serviceURL 中的协议无提供者。
JMXProviderException - 如果 serviceURL 中的协议有提供者，但提供者由于某种原因而无法使用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnectorProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
接口 JMXConnectorProvider

public interface JMXConnectorProvider

使用给定的协议创建 JMX API 连接器客户端的提供者。此接口的实例由 JMXConnectorFactory 作为其 newJMXConnector 方法的一部分创建。

从以下版本开始：
1.5

方法摘要
 JMXConnector newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment)
创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。

方法详细信息

newJMXConnector

JMXConnector newJMXConnector(JMXServiceURL serviceURL,
                             Map<String,?> environment)
                             throws IOException

创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。每次成功调用此方法都会生成不同的 JMXConnector 对象。

参数：
serviceURL - 要连接到的连接器服务器的地址。
environment - 包含用于确定如何建立连接的指定属性的只读 Map。此映射中关键字必须为字符串。每个关联值的适合类型取决于属性。

返回：
代表新连接器客户端的 JMXConnector。每次成功调用此方法都生成不同的对象。
抛出：
NullPointerException - 如果 serviceURL 或 environment 为 null。
IOException - 对于提供者实现，建议如下：如果此提供者无法识别 serviceURL 中的协议，则抛出 MalformedURLException；如果此提供者可用于 serviceURL 中的协议，但由于某些原因无法使用，则抛出 JMXProviderException；如果由于通信问题而无法连接，则抛出其他 IOException。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnectorServer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXConnectorServer

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.remote.JMXConnectorServer
所有已实现的接口：
MBeanRegistration, NotificationBroadcaster, NotificationEmitter, JMXAddressable, JMXConnectorServerMBean
直接已知子类：
RMIConnectorServer
public abstract class JMXConnectorServer
extends NotificationBroadcasterSupport
implements JMXConnectorServerMBean, MBeanRegistration, JMXAddressable

每个连接器服务器的超类。连接器服务器连接到 MBean 服务器。它侦听客户端连接请求并为每个请求创建连接。

连接器服务器或者通过在该 MBean 服务器上注册该连接器服务器，或者通过将 MBean 服务器传给其构造方法来与 MBean 服务器关联。

连接器服务器在创建时为非活动的。只有在调用了 start 方法后，它才开始侦听客户端连接。当调用了 stop 方法，或者将连接器服务器从其 MBean 服务器注销后，连接器服务器停止侦听客户端连接。

停止连接器服务器并不会将它从其 MBean 服务器注销。连接器服务器一旦停止就无法重新启动。

客户端连接每次建立或断开都将发出一个类 JMXConnectionNotification 的通知。

从以下版本开始：
1.5

字段摘要
static String AUTHENTICATOR
为连接器服务器指定经验证的属性名称。
构造方法摘要
JMXConnectorServer()
构造一个将注册为连接到 MBean 服务器的 MBean 的连接器服务器。
JMXConnectorServer(MBeanServer mbeanServer)
构造一个连接到给定 MBean 服务器的连接器服务器。
方法摘要
protected void | connectionClosed(String connectionId, String message, Object userData) 正常关闭客户端连接时由子类调用。
protected void | connectionFailed(String connectionId, String message, Object userData) 客户端连接失败时由子类调用。
protected void | connectionOpened(String connectionId, String message, Object userData) 打开新的客户端连接时由子类调用。
String[] | getConnectionIds() 当前打开的到此连接器服务器的连接 ID 列表。
MBeanServer | getMBeanServer() 返回该连接器服务器连接到的 MBean 服务器。
MBeanNotificationInfo[] | getNotificationInfo() 返回一个指示由该 MBean 发送的通知的数组。
void | postDeregister() 允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。
void | postRegister(Boolean registrationDone) 允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。
void | preDeregister() 当此连接器服务器从 MBean 服务器上注销时，由该 MBean 服务器调用此方法。
ObjectName | preRegister(MBeanServer mbs, ObjectName name) 当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。
void | setMBeanServerForwarder(MBeanServerForwarder mbsf) 添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。
JMXConnector | toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.management.remote.JMXConnectorServerMBean 继承的方法
getAddress, getAttributes, isActive, start, stop
从接口 javax.management.remote.JMXAddressable 继承的方法
getAddress

字段详细信息

AUTHENTICATOR

public static final String AUTHENTICATOR

为连接器服务器指定经验证的属性名称。此属性关联的值（如果有）必须是一个实现 JMXAuthenticator 接口的对象。

另请参见：
常量字段值
构造方法详细信息

JMXConnectorServer

public JMXConnectorServer()

构造一个将注册为连接到 MBean 服务器的 MBean 的连接器服务器。此构造方法通常由 createMBean 方法之一在创建（在 MBean 服务器内）实现远程可用的连接器服务器时调用。

JMXConnectorServer

public JMXConnectorServer(MBeanServer mbeanServer)

构造一个连接到给定 MBean 服务器的连接器服务器。使用这样的方法创建的连接器服务器可注册到一个不同的 MBean 服务器上。

参数：
mbeanServer - 该连接器服务器连接到的 MBean 服务器。如果该连接器服务器将通过注册的方式连接到 MBean 服务器，则为 Null。
方法详细信息

getMBeanServer

public MBeanServer getMBeanServer()

返回该连接器服务器连接到的 MBean 服务器。

返回：
该连接器服务器连接到的 MBean 服务器，或者如果尚未连接到 MBean 服务器，则返回 null。

setMBeanServerForwarder

public void setMBeanServerForwarder(MBeanServerForwarder mbsf)
从接口 JMXConnectorServerMBean 复制的描述

添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。此对象将作为任何由此连接器服务器创建的新连接的 MBeanServer 提供。现有连接不受影响。

如果此连接器服务器已与一个 MBeanServer 对象关联，则将该对象提供给 mbsf.setMBeanServer。如果这样做生成异常，则该方法抛出相同的异常，没有任何其他作用。

如果此连接器尚未与一个 MBeanServer 对象关联，或者如果刚才提到的 mbsf.setMBeanServer 调用成功，则 mbsf 成为该连接器服务器的 MBeanServer。

指定者：
接口 JMXConnectorServerMBean 中的 setMBeanServerForwarder
参数：
mbsf - 新的 MBeanServerForwarder。

getConnectionIds

public String[] getConnectionIds()
从接口 JMXConnectorServerMBean 复制的描述

当前打开的到此连接器服务器的连接 ID 列表。

指定者：
接口 JMXConnectorServerMBean 中的 getConnectionIds
返回：
包含 ID 列表的新字符串数组。如果当前没有打开的连接，则此数组将为空。

toJMXConnector

public JMXConnector toJMXConnector(Map<String,?> env)
                            throws IOException

返回此连接器服务器的客户端 stub。客户端 stub 为一个可序列化的对象，其 connect 方法可用于建立一个到此连接器服务器的新连接。

给定的连接器不必支持生成客户端 stub。但是，由 JMX Remote API 指定的连接器必须支持生成客户端 stub（JMXMP Connector 和 RMI Connector）。

此方法的默认实现使用 JMXConnectorServerMBean.getAddress() 和 JMXConnectorFactory 生成 stub，其代码等效于：

 JMXServiceURL addr = getAddress();
 return JMXConnectorFactory.newJMXConnector(addr, env);

此代码不适用的连接器服务器必须重写此方法，这样或者实现适当的逻辑，或者抛出 UnsupportedOperationException。

指定者：
接口 JMXConnectorServerMBean 中的 toJMXConnector
参数：
env - 客户端连接参数，与提供给 JMXConnector.connect(Map) 的参数具有相同的类型。可以为 null，它等效于一个空映射。
返回：
可用于建立到此连接器服务器的新连接的客户端 stub。
抛出：
UnsupportedOperationException - 如果此连接器服务器不支持生成客户端 stub。
IllegalStateException - 如果 JMXConnectorServer 未启动（请参阅 JMXConnectorServerMBean.isActive()）。
IOException - 如果存在通信问题而导致无法创建 stub。

getNotificationInfo

public MBeanNotificationInfo[] getNotificationInfo()

返回一个指示由该 MBean 发送的通知的数组。JMXConnectorServer 中的实现返回带一个元素的数组，这指示它可以发出在此类中定义的类型的类 JMXConnectionNotification 的通知。能够发出其他通知的子类应返回一个包含该元素和对其他通知的描述的数组。

指定者：
接口 NotificationBroadcaster 中的 getNotificationInfo
覆盖：
类 NotificationBroadcasterSupport 中的 getNotificationInfo
返回：
可能的通知的数组。

connectionOpened

protected void connectionOpened(String connectionId,
                                String message,
                                Object userData)

打开新的客户端连接时由子类调用。将由 getConnectionIds() 返回的 connectionId 添加到列表中，然后发出一个类型为 JMXConnectionNotification.OPENED 的 JMXConnectionNotification。

参数：
connectionId - 新连接的 ID。它必须与任何由此连接器服务器先前打开的连接的 ID 不一样。
message - 发出的 JMXConnectionNotification 的消息。可以为 null。请参阅 Notification.getMessage()。
userData - 发出的 JMXConnectionNotification 的 userData。可以为 null。请参阅 Notification.getUserData()。
抛出：
NullPointerException - 如果 connectionId 为 null。

connectionClosed

protected void connectionClosed(String connectionId,
                                String message,
                                Object userData)

正常关闭客户端连接时由子类调用。从列表中移除由 getConnectionIds() 返回的 connectionId，然后发出一个类型为 JMXConnectionNotification.CLOSED 的 JMXConnectionNotification。

参数：
connectionId - 已关闭连接的 ID。
message - 发出的 JMXConnectionNotification 的消息。可以为 null。请参阅 Notification.getMessage()。
userData - 发出的 JMXConnectionNotification 的 userData。可以为 null。请参阅 Notification.getUserData()。
抛出：
NullPointerException - 如果 connectionId 为 null。

connectionFailed

protected void connectionFailed(String connectionId,
                                String message,
                                Object userData)

客户端连接失败时由子类调用。从列表中移除由 getConnectionIds() 返回的 connectionId，然后发出一个类型为 JMXConnectionNotification.FAILED 的 JMXConnectionNotification。

参数：
connectionId - 失败连接的 ID。
message - 发出的 JMXConnectionNotification 的消息。可以为 null。请参阅 Notification.getMessage()。
userData - 发出的 JMXConnectionNotification 的 userData。可以为 null。请参阅 Notification.getUserData()。
抛出：
NullPointerException - 如果 connectionId 为 null。

preRegister

public ObjectName preRegister(MBeanServer mbs,
                              ObjectName name)

当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。此连接器服务器连接到此 MBean 服务器上且其 getMBeanServer() 方法将返回 mbs。

如果该连接器服务器已连接到 MBean 服务器，则该方法没有任何作用。它所连接到的 MBean 服务器不一定就是所注册的 MBean 服务器。

指定者：
接口 MBeanRegistration 中的 preRegister
参数：
mbs - 该连接器服务器注册所在的 MBean 服务器。
name - MBean 的对象名。
返回：
MBean 将注册的名称。
抛出：
NullPointerException - 如果 mbs 或 name 为 null。

postRegister

public void postRegister(Boolean registrationDone)
从接口 MBeanRegistration 复制的描述
允许 MBean 在被注册到 MBean 服务器或注销失败后执行任何所需要的操作。

指定者：
接口 MBeanRegistration 中的 postRegister
参数：
registrationDone - 指示该 MBean 是否已在 MBean 服务器中成功注册。false 值意味着注册阶段已失败。

preDeregister

public void preDeregister()
                   throws Exception

当此连接器服务器从 MBean 服务器上注销时，由该 MBean 服务器调用此方法。如果该连接器服务器以注册的方式连接到该 MBean 服务器，并且如果该连接器服务器仍为活动状态，则注销它将调用 stop 方法。如果 stop 方法抛出一个异常，则注销尝试将失败。建议在注销 MBean 之前显式调用 stop 方法。

指定者：
接口 MBeanRegistration 中的 preDeregister
抛出：
IOException - 如果异常由 stop 方法抛出。
Exception - MBean 服务器会捕捉此异常并以 MBeanRegistrationException 的形式重新抛出。

postDeregister

public void postDeregister()
从接口 MBeanRegistration 复制的描述
允许 MBean 在已从 MBean 服务器注销之后执行所需要的任何操作。

指定者：
接口 MBeanRegistration 中的 postDeregister
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnectorServerFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXConnectorServerFactory

java.lang.Object
    继承者  javax.management.remote.JMXConnectorServerFactory

public class JMXConnectorServerFactory
extends Object

用于创建 JMX API 连接器服务器的工厂。此类没有实例。

每个连接器服务器都是由 JMXConnectorServerProvider 的实例创建的。此实例如下所示。假设给定的 JMXServiceURL 类似于 "service:jmx:protocol:remainder"。则工厂将尝试查找适当的 JMXConnectorServerProvider 以供 protocol 使用。protocol 中出现的每个 + 或 - 字符都分别由 . 或 _ 替换。

对提供者包列表 的搜索如下所示：

  1. 如果传给 newJMXConnectorServer 的 environment 参数包含关键字 jmx.remote.protocol.provider.pkgs，则关联的值为提供者包列表。
  2. 否则，如果存在系统属性 jmx.remote.protocol.provider.pkgs，则其值为提供者包列表。
  3. 否则，没有任何提供者包列表。

提供者包列表是一个表现为由竖直线 (|) 分隔的非空 Java 包名称列表的字符串。如果该字符串为空，则提供者包列表也为空。如果提供者包列表不是一个字符串，或者如果它包含空字符串元素，则抛出 JMXProviderException 异常。

如果存在提供者包列表并且不为空，则对于列表中的每个 pkg 元素，此工厂将尝试加载以下类

pkg.protocol.ServerProvider

如果传给 newJMXConnectorServer 的 environment 参数包含关键字 jmx.remote.protocol.provider.class.loader，则关联的值为用于加载提供者的类加载器。如果关联的值不是一个 ClassLoader 的实例，则抛出 IllegalArgumentException。

如果 environment 参数中没有 jmx.remote.protocol.provider.class.loader 关键字，则使用调用线程的上下文类加载器。

如果尝试加载该类时生成 ClassNotFoundException，则继续对列表中的下一个元素搜索处理程序。

否则，提供者查找的问题将由 JMXProviderException 通过其 cause 指示如下所示的基础异常来通知：

  • 如果尝试加载类时生成了一个 ClassNotFoundException 之外的异常，则它就是 cause；
  • 如果该类的 Class.newInstance() 生成了异常，则这就是 cause。

如果上述步骤中未找到任何提供者，包括无提供者包列表的默认情况，则实现将使用 protocol 自身的提供者，或者如果也没有自身的提供者，则抛出 MalformedURLException。实现也可以选择通过其他途径查找提供者。例如，它可能支持 JAR conventions for service providers，其服务接口为 JMXConnectorServerProvider。

每个实现都必须支持由字符串 rmi 或 iiop 指定的 RMI 连接器协议。

一旦找到了提供者，newJMXConnectorServer 方法的结果就是在该提供者上调用 newJMXConnectorServer 的结果。

传给 JMXConnectorServerProvider 的 Map 参数为一个新的只读 Map，它包含了原先传给 JMXConnectorServerFactory.newJMXConnectorServer 的 environment 参数中的所有条目（如果有）。此外，如果 environment 参数中没有 jmx.remote.protocol.provider.class.loader 关键字，则将此关键字添加到新的只读 Map 中。关联的值为调用线程的上下文类加载器。

从以下版本开始：
1.5

字段摘要
static String | DEFAULT_CLASS_LOADER 指定默认的类加载器的属性名称。
static String | DEFAULT_CLASS_LOADER_NAME 指定默认的类加载器 MBean 名称的属性名称。
static String | PROTOCOL_PROVIDER_CLASS_LOADER 指定用于加载协议提供者的类加载器的属性名称。
static String | PROTOCOL_PROVIDER_PACKAGES 指定查找协议的处理程序时需参考的提供者包的属性名称。
方法摘要
static JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
创建位于给定地址的连接器服务器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

DEFAULT_CLASS_LOADER

public static final String DEFAULT_CLASS_LOADER

指定默认的类加载器的属性名称。此类加载器用于反序列化从客户端收到请求对象（之前可能参考了一个特定于 MBean 的类加载器）。与此属性关联的值为 ClassLoader 的实例。

另请参见：
常量字段值

DEFAULT_CLASS_LOADER_NAME

public static final String DEFAULT_CLASS_LOADER_NAME

指定默认的类加载器 MBean 名称的属性名称。此类加载器用于反序列化从客户端收到请求对象（之前可能参考了一个特定于 MBean 的类加载器）。与此属性关联的值为 ObjectName 的实例。

另请参见：
常量字段值

PROTOCOL_PROVIDER_PACKAGES

public static final String PROTOCOL_PROVIDER_PACKAGES

指定查找协议的处理程序时需参考的提供者包的属性名称。与此属性关联的值为由竖直线 (|) 分隔的包名称的字符串。

另请参见：
常量字段值

PROTOCOL_PROVIDER_CLASS_LOADER

public static final String PROTOCOL_PROVIDER_CLASS_LOADER

指定用于加载协议提供者的类加载器的属性名称。与此属性关联的值为 ClassLoader 的实例。

另请参见：
常量字段值
方法详细信息

newJMXConnectorServer

public static JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL,
                                                       Map<String,?> environment,
                                                       MBeanServer mbeanServer)
                                                throws IOException

创建位于给定地址的连接器服务器。结果服务器直到调用其 start 方法时才启动。

参数：
serviceURL - 新的连接器服务器的地址。新的连接器服务器的 getAddress 方法返回的连接器服务器的实际地址不一定完全相同。例如，它可能包含一个端口号，而原始地址中并没有该端口号。
environment - 用于控制新连接器服务器的行为的一组属性。此参数可以为 null。此映射中关键字必须为字符串。每个关联值的适当类型取决于属性。此调用不改变 environment 的内容。
mbeanServer - 该连接器服务器连接到的 MBean 服务器。如果该连接器服务器将通过注册的方式连接到 MBean 服务器，则为 Null。
返回：
代表新的连接器服务器的 JMXConnectorServer。每次对此方法的成功调用都生成不同的对象。
抛出：
NullPointerException - 如果 serviceURL 为 null。
IOException - 如果由于存在通信问题而导致无法建立连接器服务器。
MalformedURLException - 如果 serviceURL 中的协议无提供者。
JMXProviderException - 如果 serviceURL 中的协议有提供者，但提供者由于某种原因而无法使用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnectorServerMBean (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
接口 JMXConnectorServerMBean

所有已知实现类：
JMXConnectorServer, RMIConnectorServer
public interface JMXConnectorServerMBean

供连接器服务器使用的 MBean 接口。JMX API 连接器服务器连接到 MBean 服务器并为远程客户端建立到该 MBean 服务器的连接。

新创建的连接器服务器为非活动的，它还不侦听连接。只有在调用其 start 方法后，它才开始侦听连接。

从以下版本开始：
1.5

方法摘要
JMXServiceURL | getAddress() 该连接器服务器的地址。
Map<String,?> | getAttributes() 此连接器服务器的属性。
String[] | getConnectionIds() 当前打开的到此连接器服务器的连接 ID 列表。
boolean | isActive() 确定连接器服务器是否活动。
void | setMBeanServerForwarder(MBeanServerForwarder mbsf) 添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。
void | start() 激活连接器服务器，即开始侦听客户端连接。
void | stop() 取消激活连接器服务器，即停止对客户端连接的侦听。
JMXConnector | toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

方法详细信息

start

void start()
           throws IOException

激活连接器服务器，即开始侦听客户端连接。在连接器服务器已激活时，调用此方法没有任何作用。在连接器服务器已停止时，调用此方法将生成 IOException。

抛出：
IOException - 如果无法启动侦听，或者如果连接器服务器已经停止。
IllegalStateException - 如果此连接器服务器尚未连接到 MBean 服务器。

stop

void stop()
          throws IOException

取消激活连接器服务器，即停止对客户端连接的侦听。调用此方法还将关闭所有由此服务器建立的客户端连接。返回此方法后，无论正常返回还是抛出异常，连接器服务器都不再创建任何新的客户端连接。

连接器服务器一旦停止就无法再启动。

在连接器服务器已停止时，调用此方法没有任何效果。在客户端服务器尚未启动时调用此方法将永久禁用连接器服务器对象。

如果关闭客户端连接导致异常，则该异常不会从此方法抛出。而会从此 MBean 发出一个类型为 JMXConnectionNotification.FAILED 的 JMXConnectionNotification，同时显示无法关闭连接的连接 ID。

关闭连接器服务器是一个潜在的慢操作。例如，如果具有打开连接的客户端发生崩溃，则关闭操作不得不等待网络协议超时。不希望关闭操作出现阻塞的调用者应在单独的线程中处理关闭。

抛出：
IOException - 如果无法完全关闭服务器。抛出此异常时，服务器已尝试关闭所有的客户端连接。除了那些服务器尝试将它们关闭时生成异常的连接，所有的客户端连接都被关闭。

isActive

boolean isActive()

确定连接器服务器是否活动。当连接器服务器的 start 方法成功返回时，此连接器服务器即进入活动状态，并一直保持活动状态直到调用其 stop 方法或连接器服务器失败。

返回：
如果该连接器服务器为活动的，则返回 true。

setMBeanServerForwarder

void setMBeanServerForwarder(MBeanServerForwarder mbsf)

添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。此对象将作为任何由此连接器服务器创建的新连接的 MBeanServer 提供。现有连接不受影响。

如果此连接器服务器已与一个 MBeanServer 对象关联，则将该对象提供给 mbsf.setMBeanServer。如果这样做生成异常，则该方法抛出相同的异常，没有任何其他作用。

如果此连接器尚未与一个 MBeanServer 对象关联，或者如果刚才提到的 mbsf.setMBeanServer 调用成功，则 mbsf 成为该连接器服务器的 MBeanServer。

参数：
mbsf - 新的 MBeanServerForwarder。
抛出：
IllegalArgumentException - 如果调用 mbsf.setMBeanServer 失败，生成了 IllegalArgumentException。这包含了 mbsf 为 null 的情况。

getConnectionIds

String[] getConnectionIds()

当前打开的到此连接器服务器的连接 ID 列表。

返回：
包含 ID 列表的新字符串数组。如果当前没有打开的连接，则此数组将为空。

getAddress

JMXServiceURL getAddress()

该连接器服务器的地址。

返回：
该连接器服务器的地址，或者如果没有任何地址，则返回 null。

getAttributes

Map<String,?> getAttributes()

此连接器服务器的属性。

返回：
包含该连接器服务器的属性的一个只读映射。该映射中忽略了其值不可序列化的属性。如果没有可序列化的属性，则返回的映射为空。

toJMXConnector

JMXConnector toJMXConnector(Map<String,?> env)
                            throws IOException

返回此连接器服务器的客户端 stub。客户端 stub 为一个可序列化的对象，其 connect 方法可用于建立一个到此连接器服务器的新连接。

给定的连接器不必支持生成客户端 stub。但是，由 JMX Remote API 指定的连接器必须支持生成客户端 stub（JMXMP Connector 和 RMI Connector）。

参数：
env - 客户端连接参数，与提供给 JMXConnector.connect(Map) 的参数具有相同的类型。可以为 null，它等效于一个空映射。
返回：
可用于建立到此连接器服务器的新连接的客户端 stub。
抛出：
UnsupportedOperationException - 如果此连接器服务器不支持生成客户端 stub。
IllegalStateException - 如果 JMXConnectorServer 未启动（请参阅 isActive()）。
IOException - 如果存在通信问题而导致无法创建 stub。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXConnectorServerProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
接口 JMXConnectorServerProvider

public interface JMXConnectorServerProvider

使用给定的协议创建 JMX API 连接器服务器的提供者。此接口的实例由 JMXConnectorServerFactory 作为其 newJMXConnectorServer 方法的一部分创建。

从以下版本开始：
1.5

方法摘要
 JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer)
创建位于给定地址的新连接器服务器。

方法详细信息

newJMXConnectorServer

JMXConnectorServer newJMXConnectorServer(JMXServiceURL serviceURL,
                                         Map<String,?> environment,
                                         MBeanServer mbeanServer)
                                         throws IOException

创建位于给定地址的新连接器服务器。每个对此方法的成功调用生成不同的 JMXConnectorServer 对象。

参数：
serviceURL - 新的连接器服务器的地址。新的连接器服务器的 getAddress 方法返回的连接器服务器的实际地址不一定完全相同。例如，它可能包含一个端口号，而原始地址中并没有该端口号。
environment - 包含用于控制新连接器服务器行为的命名属性的只读 Map。此映射中关键字必须为字符串。每个关联值的适合类型取决于属性。
mbeanServer - 该连接器服务器连接到的 MBean 服务器。如果该连接器服务器将通过注册的方式连接到 MBean 服务器，则该参数为 Null。
返回：
代表新的连接器服务器的 JMXConnectorServer。每次成功调用此方法都生成不同的对象。
抛出：
NullPointerException - 如果 serviceURL 或 environment 为 null。
IOException - 如果连接器服务器无法创建。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXPrincipal (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXPrincipal

java.lang.Object
    继承者  javax.management.remote.JMXPrincipal
所有已实现的接口：
Serializable, Principal
public class JMXPrincipal
extends Object
implements Principal, Serializable

JMX Remote API 的远程客户端的身份。

类似 JMXPrincipal 的 principal 可能与一个特定的 Subject 关联以便为该 Subject 增加其他的身份。有关如何获得这样的身份的详细信息，请参阅 Subject 类。然后可基于与 Subject 关联的 Principal 制定验证决策。

从以下版本开始：
1.5
另请参见：
Principal, Subject, 序列化表格

构造方法摘要
JMXPrincipal(String name)
为给定的身份创建一个 JMXPrincipal。
方法摘要
boolean | equals(Object o) 比较指定的 Object 与此 JMXPrincipal 是否相等。
String | getName() 返回此 principal 的名称。
int | hashCode() 返回此 JMXPrincipal 的哈希码。
String | toString() 返回此 JMXPrincipal 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMXPrincipal

public JMXPrincipal(String name)

为给定的身份创建一个 JMXPrincipal。

参数：
name - 此身份的 JMX Remote API 名称。
抛出：
NullPointerException - 如果该 name 为 null。
方法详细信息

getName

public String getName()
返回此 principal 的名称。

指定者：
接口 Principal 中的 getName
返回：
此 JMXPrincipal 的名称。

toString

public String toString()
返回此 JMXPrincipal 的字符串表示形式。

指定者：
接口 Principal 中的 toString
覆盖：
类 Object 中的 toString
返回：
此 JMXPrincipal 的字符串表示形式。

equals

public boolean equals(Object o)
比较指定的 Object 与此 JMXPrincipal 是否相等。如果给定对象也是一个 JMXPrincipal 并且两个 JMXPrincipal 具有相同的名称，则返回 true。

指定者：
接口 Principal 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 要与此 JMXPrincipal 进行相等性比较的 Object。
返回：
如果指定的 Object 与此 JMXPrincipal 相等，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 JMXPrincipal 的哈希码。

指定者：
接口 Principal 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 JMXPrincipal 的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXProviderException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXProviderException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.management.remote.JMXProviderException
所有已实现的接口：
Serializable
public class JMXProviderException
extends IOException

当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。

从以下版本开始：
1.5
另请参见：
JMXConnectorFactory.newJMXConnector(javax.management.remote.JMXServiceURL, java.util.Map), JMXConnectorServerFactory.newJMXConnectorServer(javax.management.remote.JMXServiceURL, java.util.Map, javax.management.MBeanServer), 序列化表格

构造方法摘要
JMXProviderException()
构造一个不带指定详细消息的 JMXProviderException。
JMXProviderException(String message)
构造带指定详细消息的 JMXProviderException。
JMXProviderException(String message, Throwable cause)
构造带指定详细消息和嵌套异常的 JMXProviderException。
方法摘要
 Throwable getCause()
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMXProviderException

public JMXProviderException()

构造一个不带指定详细消息的 JMXProviderException。

JMXProviderException

public JMXProviderException(String message)

构造带指定详细消息的 JMXProviderException。

参数：
message - 详细消息

JMXProviderException

public JMXProviderException(String message,
                            Throwable cause)

构造带指定详细消息和嵌套异常的 JMXProviderException。

参数：
message - 详细消息
cause - 嵌套的异常
方法详细信息

getCause

public Throwable getCause()
从类 Throwable 复制的描述
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。（该 Cause 是导致抛出此 throwable 的throwable。）

此实现返回由一个需要 Throwable 的构造方法提供的 cause，或者在创建之后通过 Throwable.initCause(Throwable) 方法进行设置的 cause。虽然通常不需要重写此方法，但子类可以重写它，以返回一个通过某些其他方式设置的 cause。这适用于在异常链（异常嵌套）机制被加入到 Throwable 之前存在“遗留 Throwable 链机制”的情况。注意，不必 重写任何 PrintStackTrace 方法，所有方法都调用 getCause 方法来确定 throwable 的 cause。

覆盖：
类 Throwable 中的 getCause
返回：
此 throwable 的 cause，如果 cause 不存在或是未知的，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXServerErrorException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXServerErrorException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.management.remote.JMXServerErrorException
所有已实现的接口：
Serializable
public class JMXServerErrorException
extends IOException

在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。JMXServerErrorException 实例包含作为其 cause 而发生的初始 Error。

从以下版本开始：
1.5
另请参见：
ServerError, 序列化表格

构造方法摘要
JMXServerErrorException(String s, Error err)
构造带指定详细消息和嵌套错误的 JMXServerErrorException。
方法摘要
 Throwable getCause()
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMXServerErrorException

public JMXServerErrorException(String s,
                               Error err)
构造带指定详细消息和嵌套错误的 JMXServerErrorException。

参数：
s - 详细消息。
err - 嵌套错误。此参数为 null 时也可以构造该类的实例，但标准的连接器不这样做。
方法详细信息

getCause

public Throwable getCause()
从类 Throwable 复制的描述
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。（该 Cause 是导致抛出此 throwable 的throwable。）

此实现返回由一个需要 Throwable 的构造方法提供的 cause，或者在创建之后通过 Throwable.initCause(Throwable) 方法进行设置的 cause。虽然通常不需要重写此方法，但子类可以重写它，以返回一个通过某些其他方式设置的 cause。这适用于在异常链（异常嵌套）机制被加入到 Throwable 之前存在“遗留 Throwable 链机制”的情况。注意，不必 重写任何 PrintStackTrace 方法，所有方法都调用 getCause 方法来确定 throwable 的 cause。

覆盖：
类 Throwable 中的 getCause
返回：
此 throwable 的 cause，如果 cause 不存在或是未知的，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMXServiceURL (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 JMXServiceURL

java.lang.Object
    继承者  javax.management.remote.JMXServiceURL
所有已实现的接口：
Serializable
public class JMXServiceURL
extends Object
implements Serializable

JMX API 连接器服务器的地址。此类的实例是不可变的。

地址是 SLP 的抽象服务 URL，此内容在 RFC 2609 中进行了定义并在 RFC 3111 中进行了修正。它看起来应该如下所示：

service:jmx:protocol:sap

其中 protocol 为连接到连接器服务器所用的传输协议。它是一个或多个 ASCII 字符所组成的字符串，每个字符为字母、数字或字符 + 或 - 之一。第一个字符必须为字母。大写字母被转换为小写字母。

sap 是查找到连接器服务器的地址位置。此地址采用了 RFC 2609 中为基于 IP 的协议所定义的语法子集。说它是子集是因为它不支持 user@host 语法。

此类目前也不支持由 RFC 2609 定义的其他语法。

所支持的语法为：

//[host[:port]][url-path]

方括号 [] 指示地址的可选部分。并不是所有的协议都能识别所有可选部分。

host 是主机名，它是一个 IPv4 数值主机地址，或是括在方括号中的 IPv6 数值地址。

port 是一个十进制的端口号。0 表示默认或匿名端口，这取决于协议。

host 和 port 均可忽略。必须有了 host 才能提供 port。

url-path（如果有）以一个斜杠 (/) 或分号 (;) 开头直到地址结束。它可以采用 RFC 2609 中指定的分号语法包含属性。此类不对这些属性进行解析，因此无法检测到错误的属性语法。

尽管根据 RFC 2609 的规定，包含以分号开头的 url-path 是合法的，但不是所有的 SLP 实现都允许这样，所以建议避免使用这种语法。

初始 service:jmx:protocol 字符串或地址的主机部分并不区分大小写。根据所采用的协议，url-path 部分可能会区分大小写。

从以下版本开始：
1.5
另请参见：
RFC 2609, "Service Templates and Service: Schemes", RFC 3111, "Service Location Protocol Modifications for IPv6", 序列化表格

构造方法摘要
JMXServiceURL(String serviceURL)
通过解析 Service URL 字符串来构造 JMXServiceURL。
JMXServiceURL(String protocol, String host, int port)
构造具有给定协议、主机和端口的 JMXServiceURL。
JMXServiceURL(String protocol, String host, int port, String urlPath)
构造具有给定部分的 JMXServiceURL。
方法摘要
boolean | equals(Object obj) 指示是否有其他的对象等于此对象。
String | getHost() Service URL 的主机部分。
int | getPort() Service URL 的端口部分。
String | getProtocol() Service URL 的协议部分。
String | getURLPath() Service URL 的 URL Path 部分。
int | hashCode() 返回该对象的哈希码值。
String | toString() 此 Service URL 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMXServiceURL

public JMXServiceURL(String serviceURL)
              throws MalformedURLException

通过解析 Service URL 字符串来构造 JMXServiceURL。

参数：
serviceURL - 要解析的 URL 字符串。
抛出：
NullPointerException - 如果 serviceURL 为 null。
MalformedURLException - 如果 serviceURL 不符合 Abstract Service URL 的语法，或者它不是 JMX Remote API 服务的有效名称。JMXServiceURL 必须以字符串 "service:jmx:" 开头。（不区分大小写）。不允许包含任何不属于可打印 ASCII 字符的字符。

JMXServiceURL

public JMXServiceURL(String protocol,
                     String host,
                     int port)
              throws MalformedURLException

构造具有给定协议、主机和端口的 JMXServiceURL。此构造方法等效于 JMXServiceURL(protocol, host, port, null)。

参数：
protocol - URL 的协议部分。如果为 null，则默认为 jmxmp。
host - URL 的主机部分。如果为 null，则默认为本地主机名，它由 InetAddress.getLocalHost().getHostName() 确定。如果它为一个数值 IPv6 地址，可选择将其括在方括号 [] 中。
port - URL 的端口部分。
抛出：
MalformedURLException - 如果某一部分在语法上不正确，或者如果 host 为 null 并且无法找到本地主机名，或者如果 port 为负。

JMXServiceURL

public JMXServiceURL(String protocol,
                     String host,
                     int port,
                     String urlPath)
              throws MalformedURLException

构造具有给定部分的 JMXServiceURL。

参数：
protocol - URL 的协议部分。如果为 null，则默认为 jmxmp。
host - URL 的主机部分。如果为 null，则默认为本地主机名，它由 InetAddress.getLocalHost().getHostName() 确定。如果它为一个数值 IPv6 地址，可选择将其括在方括号 [] 中。
port - URL 的端口部分。
urlPath - URL 的 URL Path 部分。如果为 null，则默认为空字符串。
抛出：
MalformedURLException - 如果某一部分在语法上不正确，或者如果 host 为 null 并且无法找到本地主机名，或者如果 port 为负。
方法详细信息

getProtocol

public String getProtocol()

Service URL 的协议部分。

返回：
Service URL 的协议部分。它从不为 null。

getHost

public String getHost()

Service URL 的主机部分。如果 Service URL 是用带一个 URL 字符串参数的构造方法所构造的，则结果为该 URL 中指定主机的子字符串。如果此 Service URL 是用带一个独立主机参数的构造方法所构造的，则结果为所指定的字符串。如果该字符串为 null，则结果为 InetAddress.getLocalHost().getHostName()。

无论是哪种情况，如果主机是使用数值 IPv6 地址的 [...] 语法指定的，则此处的返回值不包括方括号。

返回：
Service URL 的主机部分。它从不为 null。

getPort

public int getPort()

Service URL 的端口部分。如果未指定任何端口，则返回值为 0。

返回：
Service URL 的端口，如果没有，则返回 0。

getURLPath

public String getURLPath()

Service URL 的 URL Path 部分。这是一个空字符串，或以斜杠 (/) 开头的字符串，或以分号 (;) 开头的字符串。

返回：
Service URL 的 URL Path 部分。它从不为 null。

toString

public String toString()

此 Service URL 的字符串表示形式。如果把此方法的返回值提供给 JMXServiceURL 构造方法，则结果对象等于此值。

返回字符串的 host 部分是由 getHost() 返回的值。如果该值指定了一个数值 IPv6 地址，则它用方括号 [] 括起。

返回字符串的 port 部分是由 getPort() 返回的值，以最短的十进制形式表示。如果该值为零，则忽略该值。

覆盖：
类 Object 中的 toString
返回：
此 Service URL 的字符串表示形式。

equals

public boolean equals(Object obj)

指示是否有其他的对象等于此对象。当且仅当 obj 为 JMXServiceURL 的一个实例，后者的 getProtocol()、getHost()、getPort() 和 getURLPath() 方法均返回与此对象相等的值时，此方法才返回 true。getProtocol() 和 getHost() 的值的大小写可能不同，但不影响二者的相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
从类 Object 复制的描述
返回该对象的哈希码值。支持此方法是为了提高哈希表（例如 java.util.Hashtable 提供的哈希表）的性能。

hashCode 的常规协定是：

  • 在 Java 应用程序执行期间，在对同一对象多次调用 hashCode 方法时，必须一致地返回相同的整数，前提是将对象进行 equals 比较时所用的信息没有被修改。从某一应用程序的一次执行到同一应用程序的另一次执行，该整数无需保持一致。
  • 如果根据 equals(Object) 方法，两个对象是相等的，那么对这两个对象中的每个对象调用 hashCode 方法都必须生成相同的整数结果。
  • 如果根据 Object.equals(java.lang.Object) 方法，两个对象不相等，那么对这两个对象中的任一对象上调用 hashCode 方法不 要求一定生成不同的整数结果。但是，程序员应该意识到，为不相等的对象生成不同整数结果可以提高哈希表的性能。

实际上，由 Object 类定义的 hashCode 方法确实会针对不同的对象返回不同的整数。（这一般是通过将该对象的内部地址转换成一个整数来实现的，但是 JavaTM 编程语言不需要这种实现技巧。）

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MBeanServerForwarder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
接口 MBeanServerForwarder

所有超级接口：
MBeanServer, MBeanServerConnection
public interface MBeanServerForwarder
extends MBeanServer

此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。通常情况下，此接口的实现在将此方法转发到包装的对象之前和/或之后执行 MBeanServer 接口的某些或所有方法中的某些操作。这样的例子包括安全检查和记录。

从以下版本开始：
1.5

方法摘要
MBeanServer | getMBeanServer() 返回请求将转发到其上的 MBeanServer 对象。
void | setMBeanServer(MBeanServer mbs) 设置 MBeanServer 对象，请求经此对象处理后将转发到其上。
从接口 javax.management.MBeanServer 继承的方法
addNotificationListener, addNotificationListener, createMBean, createMBean, createMBean, createMBean, deserialize, deserialize, deserialize, getAttribute, getAttributes, getClassLoader, getClassLoaderFor, getClassLoaderRepository, getDefaultDomain, getDomains, getMBeanCount, getMBeanInfo, getObjectInstance, instantiate, instantiate, instantiate, instantiate, invoke, isInstanceOf, isRegistered, queryMBeans, queryNames, registerMBean, removeNotificationListener, removeNotificationListener, removeNotificationListener, removeNotificationListener, setAttribute, setAttributes, unregisterMBean

方法详细信息

getMBeanServer

MBeanServer getMBeanServer()
返回请求将转发到其上的 MBeanServer 对象。

返回：
请求将转发到其上的 MBeanServer 对象，如果没有，则返回 null。
另请参见：
setMBeanServer(javax.management.MBeanServer)

setMBeanServer

void setMBeanServer(MBeanServer mbs)
设置 MBeanServer 对象，请求经此对象处理后将转发到其上。

参数：
mbs - 将请求转发到其上的 MBeanServer 对象。
抛出：
IllegalArgumentException - 如果此对象已经转发到一个 MBeanServer 对象，或者 mbs 为 null，或者 mbs 与此对象相同。
另请参见：
getMBeanServer()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotificationResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 NotificationResult

java.lang.Object
    继承者  javax.management.remote.NotificationResult
所有已实现的接口：
Serializable
public class NotificationResult
extends Object
implements Serializable

缓存的通知的查询结果。通知缓存中的通知具有正的、单调递增的序列号。通知查询的结果包含以下元素：

  • 缓存中保留的最早的通知的序列号。
  • 下一个可供查询使用的通知的序列号。这将是下一个通知查询的起始序列号。
  • 与返回的通知和相应的侦听器对应的 (Notification,listenerID) 对的数组。

nextSequenceNumber 不能小于 earliestSequenceNumber。如果小于早先的序列号，这表明介于两个号之间的通知可能已丢失。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
NotificationResult(long earliestSequenceNumber, long nextSequenceNumber, TargetedNotification[] targetedNotifications)
构造一个通知查询结果。
方法摘要
long | getEarliestSequenceNumber() 返回缓存中保留的最早通知的序列号。
long | getNextSequenceNumber() 返回下一个可供查询使用的通知的序列号。
TargetedNotification[] | getTargetedNotifications() 返回查询到的通知以及相应的侦听器。
String | toString() 返回该对象的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotificationResult

public NotificationResult(long earliestSequenceNumber,
                          long nextSequenceNumber,
                          TargetedNotification[] targetedNotifications)

构造一个通知查询结果。

参数：
earliestSequenceNumber - 缓存中仍保留的最早通知的序列号。
nextSequenceNumber - 下一个可供查询使用的通知的序列号。
targetedNotifications - 查询得到的通知以及相应的侦听器。此数组可以为空。
抛出：
IllegalArgumentException - 如果 targetedNotifications 为 null，或者 earliestSequenceNumber 或 nextSequenceNumber 为负。
方法详细信息

getEarliestSequenceNumber

public long getEarliestSequenceNumber()
返回缓存中保留的最早通知的序列号。

返回：
缓存中保留的最早通知的序列号。

getNextSequenceNumber

public long getNextSequenceNumber()
返回下一个可供查询使用的通知的序列号。

返回：
下一个可供查询使用的通知的序列号。

getTargetedNotifications

public TargetedNotification[] getTargetedNotifications()
返回查询到的通知以及相应的侦听器。

返回：
查询得到的通知以及相应的侦听器。此数组可以为空。

toString

public String toString()
返回该对象的字符串表示形式。结果应是一个简明而丰富的表示形式，它方便人们阅读。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SubjectDelegationPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 SubjectDelegationPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.management.remote.SubjectDelegationPermission
所有已实现的接口：
Serializable, Guard
public final class SubjectDelegationPermission
extends BasicPermission

授权标识表示验证标识执行操作所需的权限。

SubjectDelegationPermission 包含一个名称（也称为“目标名称”），但没有动作列表；可以使用，也可以不使用指定权限。

目标名称是验证主体类名带一个句点和验证主体名称，即 "PrincipalClassName.PrincipalName"。

星号可能单独出现，也可能紧跟在 "." 后面出现在目标名称的末尾，它表示通配符匹配。

例如，"*"、"javax.management.remote.JMXPrincipal.*" 和 "javax.management.remote.JMXPrincipal.delegate" 都是有效的目标名称。其中，第一个表示来自任意主体类的任意主体名称，第二个表示具体主体类 javax.management.remote.JMXPrincipal 的任意主体名称，第三个表示具体主体类 javax.management.remote.JMXPrincipal 的具体主题名称 delegate。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
SubjectDelegationPermission(String name)
创建具有指定名称的新 SubjectDelegationPermission。
SubjectDelegationPermission(String name, String actions)
创建带指定名称的新 SubjectDelegationPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

SubjectDelegationPermission

public SubjectDelegationPermission(String name)
创建具有指定名称的新 SubjectDelegationPermission。此名称为 SubjectDelegationPermission 的符号名。

参数：
name - SubjectDelegationPermission 的名称
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

SubjectDelegationPermission

public SubjectDelegationPermission(String name,
                                   String actions)
创建带指定名称的新 SubjectDelegationPermission 对象。此名称是 SubjectDelegationPermission 的符号名，而目前不使用操作 String，该字符串应该为 null。

参数：
name - SubjectDelegationPermission 的名称
actions - 应该为 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空或 actions 不为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TargetedNotification (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.remote
类 TargetedNotification

java.lang.Object
    继承者  javax.management.remote.TargetedNotification
所有已实现的接口：
Serializable
public class TargetedNotification
extends Object
implements Serializable

一个 (Notification, Listener ID) 对。

此类用于将一个发出的通知与通知所定向的侦听器 ID 进行关联。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
TargetedNotification(Notification notification, Integer listenerID)
构造一个 TargetedNotification 对象。
方法摘要
Integer | getListenerID() 此通知所定向的侦听器的 ID。
Notification | getNotification() 发出的通知。
String | toString() 返回此定向通知的一个文本表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TargetedNotification

public TargetedNotification(Notification notification,
                            Integer listenerID)

构造一个 TargetedNotification 对象。此对象包含一个 (Notification, Listener ID) 对。Listener ID 标识通知所定向的客户端侦听器。客户端侦听器 ID 是作为对 addNotificationListener 请求的响应原先从连接器服务器返回的一个 ID。

参数：
notification - 从 MBean 服务器发出的通知。
listenerID - 此通知所定向的侦听器的 ID。
抛出：
IllegalArgumentException - 如果 listenerID 或 notification 为 null。
方法详细信息

getNotification

public Notification getNotification()

发出的通知。

返回：
通知。

getListenerID

public Integer getListenerID()

此通知所定向的侦听器的 ID。

返回：
侦听器 ID。

toString

public String toString()
返回此定向通知的一个文本表示形式。

覆盖：
类 Object 中的 toString
返回：
此定向的通知的一个文本表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.remote (Java 2 Platform SE 6)

 javax.management.remote
接口
JMXAddressable
JMXAuthenticator
JMXConnector
JMXConnectorProvider
JMXConnectorServerMBean
JMXConnectorServerProvider
MBeanServerForwarder
类
JMXConnectionNotification
JMXConnectorFactory
JMXConnectorServer
JMXConnectorServerFactory
JMXPrincipal
JMXServiceURL
NotificationResult
SubjectDelegationPermission
TargetedNotification
异常
JMXProviderException
JMXServerErrorException


javax.management.remote (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.remote

对 JMX MBean 服务器进行远程访问使用的接口。

请参见：
描述

接口摘要
JMXAddressable | 由可能具有 JMXServiceURL 地址的对象实现。
JMXAuthenticator | 定义如何将远程凭据转换为 JAAS Subject（主题）的接口。
JMXConnector | JMX API 连接器的客户端。
JMXConnectorProvider | 使用给定的协议创建 JMX API 连接器客户端的提供者。
JMXConnectorServerMBean | 供连接器服务器使用的 MBean 接口。
JMXConnectorServerProvider | 使用给定的协议创建 JMX API 连接器服务器的提供者。
MBeanServerForwarder | 此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。

类摘要
JMXConnectionNotification | 在客户端连接打开或关闭时，或者当通知丢失时发出的通知。
JMXConnectorFactory | 用于创建 JMX API 连接器客户端的工厂。
JMXConnectorServer | 每个连接器服务器的超类。
JMXConnectorServerFactory | 用于创建 JMX API 连接器服务器的工厂。
JMXPrincipal | JMX Remote API 的远程客户端的身份。
JMXServiceURL | JMX API 连接器服务器的地址。
NotificationResult | 缓存的通知的查询结果。
SubjectDelegationPermission | 授权标识表示验证标识执行操作所需的权限。
TargetedNotification | 一个 (Notification, Listener ID) 对。

异常摘要
JMXProviderException | 当提供者存在所需的协议但由于某种原因不能使用时由 JMXConnectorFactory 和 JMXConnectorServerFactory 抛出的异常。
JMXServerErrorException | 在处理远程 MBean 服务器中的调用的过程中抛出了 Error 时，远程 MBeanServer 方法调用导致抛出的异常。

软件包 javax.management.remote 的描述

对 JMX MBean 服务器进行远程访问使用的接口。此包定义了使 JMX MBean 服务器可远程管理的重要接口。此功能性的完整规范，可参考 JMX Specification, version 1.4 PDF 文档的 Part III。

JMX 规范定义了连接器的概念。连接器连接到 JMX API MBean 服务器并使远程 Java 客户端可访问该服务器。连接器的客户端导出与 MBean 服务器基本相同的接口，尤其是 MBeanServerConnection 接口。

连接器通过给定的协议实现了 MBean 服务器的远程访问。
JMX Remote API 定义了标准的连接器 RMI Connector，它通过 RMI 提供了对 MBeanServer 的远程访问。
JMX Remote API 还定义了一个可选协议，名为 JMXMP（JMX 消息传递协议）。JMXMP 基于 TCP 连接上的序列化 Java 对象（在可选包 javax.management.remote.message 中定义）。实现此协议的连接器称为 JMXMP Connector。也可以使用 JMXConnectorFactory 提供的用户定义的连接器协议和可选的通用连接器 (javax.management.remote.generic)。

连接器地址

通常连接器都有一个地址，它由类 JMXServiceURL 表示。JMXMP 连接器的地址如下所示：

      service:jmx:jmxmp://myhost:9876

RMI 连接器的地址可以多种形式，javax.management.remote.rmi 包的文档中有相关的详细论述。

创建连接器服务器

连接器服务器通过构造 JMXConnectorServer 的子类的实例创建。多数情况下，该实例是用 JMXConnectorServerFactory.newJMXConnectorServer 方法创建的。

通常情况下，连接器服务器与一个 MBean 服务器通过两种方式关联，或者通过在该 MBean 服务器上注册的方式，或者在创建连接器服务器时通过将该 MBean 服务器作为一个参数提供。

创建连接器客户端

连接器客户端通常通过将 JMXServiceURL 提供给 JMXConnectorFactory.connect 方法创建。

对于更特殊的用户，连接器服务器可通过直接实例化一个实现 JMXConnector 接口的类创建，例如类 RMIConnector。

其他的客户端或服务器参数

创建连接器客户端或服务器时，可以提供一个类型为 Map 的定义了其他参数的对象。此 Map 中的每个条目都包含一个关键字符串和一个适合于该关键字类型的关联值。JMX Remote API 定义的标准关键字都以字符串 "jmx.remote." 开头。文档 JMX Remote API 列出了这些标准关键字。

连接标识符

每个由连接器服务器打开的连接都具有一个字符串标识符，称为连接 ID.此标识符出现在由连接器服务器发出的 JMXConnectionNotification 事件中、JMXConnectorServerMBean#getConnectionIds() 返回的列表中以及由客户端的 getConnectionId() 方法返回的值中。

按照惯例，连接 ID 如下所示：

jmxmp://clienthost:6789 clientname xxxyyyzzz

遵守此惯例的连接 ID 的正规语法如下（使用《The Java Language Specification, Second Edition》中的 grammar notation）：

ConnectionId:
    Protocol : ClientAddressopt Space ClientIdopt Space ArbitraryText

ClientAddress:
// HostAddress ClientPortopt

ClientPort
    : HostPort

Protocol 是一个可由 JMXConnectorFactory 识别的协议。

ClientAddress 是连接的客户端的地址和端口（如果可确定），否则什么也不是。HostAddress 是客户端从其连接的主机的 Internet 地址，可以为数值或 DNS 形式。数值 IPv6 地址括在方括号 [] 中。HostPort 为客户端从其连接的十进制端口号。

ClientId 为客户端实体的标识，通常为由 JMXPrincipal.getName() 返回的字符串。此字符串不能包含空格。

ArbitraryText 是连接器服务器创建客户端 ID 时添加的其他文本。它至少应能够将此连接 ID 从此连接服务器上当前打开的任何其他连接的 ID 中区分出来。

从以下版本开始：
1.5
另请参见：
Java SE 6 Platform documentation on JMX technology， 特别是 JMX Specification, version 1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.remote 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.remote 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.management.Notification
        • javax.management.remote.JMXConnectionNotification
    • javax.management.remote.JMXConnectorFactory
    • javax.management.remote.JMXConnectorServerFactory
    • javax.management.remote.JMXPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.management.remote.JMXServiceURL (implements java.io.Serializable)
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.remote.JMXConnectorServer (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnectorServerMBean, javax.management.MBeanRegistration)
    • javax.management.remote.NotificationResult (implements java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.management.remote.SubjectDelegationPermission
    • javax.management.remote.TargetedNotification (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.management.remote.JMXProviderException
          • javax.management.remote.JMXServerErrorException

接口分层结构

  • java.io.Closeable
    • javax.management.remote.JMXConnector
  • javax.management.remote.JMXAddressable
  • javax.management.remote.JMXAuthenticator
  • javax.management.remote.JMXConnectorProvider
  • javax.management.remote.JMXConnectorServerMBean
  • javax.management.remote.JMXConnectorServerProvider
  • javax.management.MBeanServerConnection
    • javax.management.MBeanServer
      • javax.management.remote.MBeanServerForwarder
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.remote 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.remote
的使用

使用 javax.management.remote 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 使用的 javax.management.remote 中的类
JMXAddressable
由可能具有 JMXServiceURL 地址的对象实现。
JMXConnector
JMX API 连接器的客户端。
JMXConnectorServer
每个连接器服务器的超类。
JMXConnectorServerMBean
供连接器服务器使用的 MBean 接口。
JMXServiceURL
JMX API 连接器服务器的地址。
MBeanServerForwarder
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。
TargetedNotification
一个 (Notification, Listener ID) 对。

javax.management.remote.rmi 使用的 javax.management.remote 中的类
JMXAddressable
由可能具有 JMXServiceURL 地址的对象实现。
JMXConnector
JMX API 连接器的客户端。
JMXConnectorServer
每个连接器服务器的超类。
JMXConnectorServerMBean
供连接器服务器使用的 MBean 接口。
JMXServiceURL
JMX API 连接器服务器的地址。
MBeanServerForwarder
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。
NotificationResult
缓存的通知的查询结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


RMIConnection (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
接口 RMIConnection

所有超级接口：
Closeable, Remote
所有已知实现类：
RMIConnectionImpl, RMIConnectionImpl_Stub
public interface RMIConnection
extends Closeable, Remote

RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。连接到 RMI 连接器的每个远程客户端都有一个实现此接口的 Remote 对象。

用户代码不经常引用此接口。它作为公用 API 的一部分指定，便于该 API 的不同实现之间实现互操作。

为确保用正确的类加载器将客户端参数在服务器端反序列化，客户端参数（例如，用于调用方法的参数）包装在 MarshalledObject 方法中。此接口的实现必须首先获得适用于操作及其目标的适当的类加载器，然后用该类加载器反序列化编组的参数。除非另外说明，MarshalledObject 或 MarshalledObject[] 类型的参数必定不为 null；如果参数为 null，则行为不明确。

有关类加载的内容在 JMX Specification, version 1.4 PDF 文档中进行了详细的描述。

此接口中的多数方法与 MBeanServerConnection 接口中的方法相似。这里未指定方法的行为方面，它与相应的 MBeanServerConnection 方法相同。

从以下版本开始：
1.5

方法摘要
 void addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 Integer[] addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void close()
关闭此连接。
 ObjectInstance createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 NotificationResult fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
检索来自连接器服务器的通知。
 Object getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 AttributeList getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 String getConnectionId()
返回连接 ID。
 String getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。
 String[] getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。
 Integer getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 MBeanInfo getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 ObjectInstance getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 Object invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 boolean isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 Set<ObjectInstance> queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectName> queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 void removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 AttributeList setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 void unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。

方法详细信息

getConnectionId

String getConnectionId()
                       throws IOException

返回连接 ID。对于每个到给定的 RMI 连接器服务器的开放连接，此字符串都不相同。

返回：
连接 ID
抛出：
IOException - 如果出现通用通信异常。
另请参见：
RMIConnector.connect

close

void close()
           throws IOException

关闭此连接。从此方法返回时，不导出实现此接口的 RMI 对象，因此对它的进一步远程调用将失败。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果无法关闭连接，或 Remote 对象无法被导出，或者在传输远程关闭请求时出现通信故障。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。

参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：className 传入的参数为 null，ObjectName 传入的参数包含模式或未为 MBean 指定任何 ObjectName。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           ObjectName loaderName,
                           Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。

参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
loaderName - 要使用的类加载器的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
InstanceNotFoundException - 指定的类加载器未在 MBean 服务器中注册。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：className 传入的参数为 null，ObjectName 传入的参数包含模式或未为 MBean 指定任何 ObjectName。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           MarshalledObject params,
                           String[] signature,
                           Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
params - 包含要调用的构造方法的参数的数组，数组封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
signature - 包含要调用的构造方法的签名的数组。可以为 null，等效于一个空数组。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：className 传入的参数为 null，ObjectName 传入的参数包含一个模式，或未为 MBean 指定任何 ObjectName。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

createMBean

ObjectInstance createMBean(String className,
                           ObjectName name,
                           ObjectName loaderName,
                           MarshalledObject params,
                           String[] signature,
                           Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
loaderName - 要使用的类加载器的对象名。
params - 包含要调用的构造方法的参数的数组，数组封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
signature - 包含要调用的构造方法的签名的数组。可以为 null，等效于一个空数组。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
InstanceNotFoundException - 指定的类加载器未在 MBean 服务器中注册。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：className 传入的参数为 null，ObjectName 传入的参数包含一个模式，或未为 MBean 指定任何 ObjectName。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

unregisterMBean

void unregisterMBean(ObjectName name,
                     Subject delegationSubject)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException,
                            IOException
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。

参数：
name - 要注册的 MBean 的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
MBeanRegistrationException - MBean 的 preDeregister （MBeanRegistration 接口）方法已抛出异常。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null 或您尝试注销的 MBean 为 MBeanServerDelegate MBean。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

getObjectInstance

ObjectInstance getObjectInstance(ObjectName name,
                                 Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        IOException
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。

参数：
name - MBean 的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
由 name 指定的与 MBean 关联的 ObjectInstance。所包含的 ObjectName 为 name，所包含的类名称为 getMBeanInfo(name).getClassName()。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

queryMBeans

Set<ObjectInstance> queryMBeans(ObjectName name,
                                MarshalledObject query,
                                Subject delegationSubject)
                                throws IOException
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。QueryExp 包装在 MarshalledObject 中。

参数：
name - 标识要检索的 MBean 的对象名模式。如果指定了 null 或未指定任何域或关键字属性，则将检索所有已注册的 MBean。
query - 用于选择 MBean 的查询表达式，它封装在 MarshalledObject 中。如果 MarshalledObject 封装了一个 null 值，则选择 MBean 时不使用任何查询表达式。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
包含选定 MBean 的 ObjectInstance 对象集。如果没有任何 MBean 满足此查询，则返回一个空列表。
抛出：
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

queryNames

Set<ObjectName> queryNames(ObjectName name,
                           MarshalledObject query,
                           Subject delegationSubject)
                           throws IOException
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。QueryExp 包装在 MarshalledObject 中。

参数：
name - 标识要检索的 MBean 名称的对象名模式。如果指定了 null 或未指定任何域或关键字属性，则将检索所有已注册的 MBean 的名称。
query - 用于选择 MBean 的查询表达式，它封装在 MarshalledObject 中。如果 MarshalledObject 封装了一个 null 值，则选择 MBean 时不使用任何查询表达式。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
包含选定的 MBean 的 ObjectName 集。如果没有任何 MBean 满足此查询，则返回一个空列表。
抛出：
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

isRegistered

boolean isRegistered(ObjectName name,
                     Subject delegationSubject)
                     throws IOException
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。

参数：
name - 要检查的 MBean 的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
True 如果 MBean 已在 MBean 服务器上注册，否则返回 false。
抛出：
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

getMBeanCount

Integer getMBeanCount(Subject delegationSubject)
                      throws IOException
处理 MBeanServerConnection.getMBeanCount() 方法。

参数：
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
已注册的 MBean 数。
抛出：
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

getAttribute

Object getAttribute(ObjectName name,
                    String attribute,
                    Subject delegationSubject)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           IOException
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。

参数：
name - 将要从其检索属性的 MBean 的对象名。
attribute - 指定要检索的属性名称的字符串。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
检索到的属性的值。
抛出：
AttributeNotFoundException - 指定的属性在 MBean 中无法访问。
MBeanException - 包装了由 MBean 的获取方法抛出的异常。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 包装了尝试调用获取方法时抛出的 java.lang.Exception。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null，或参数中的属性为 null。
RuntimeMBeanException - 包装了由 MBean 的获取方法抛出的运行时异常。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
另请参见：
setAttribute(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

getAttributes

AttributeList getAttributes(ObjectName name,
                            String[] attributes,
                            Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。

参数：
name - 从其检索属性的 MBean 的对象名。
attributes - 要检索的属性的列表。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
所检索的属性的列表。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 尝试调用 Dynamic MBean 的 getAttributes 方法时出现的异常。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null，或参数中的属性为 null。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
另请参见：
setAttributes(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

setAttribute

void setAttribute(ObjectName name,
                  MarshalledObject attribute,
                  Subject delegationSubject)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         IOException
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。Attribute 参数包装在 MarshalledObject 中。

参数：
name - 在其中设置属性的 MBean 的名称。
attribute - 要设置的属性的标识及要设置的值，封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
AttributeNotFoundException - 指定的属性在 MBean 中无法访问。
InvalidAttributeValueException - 为属性指定的值无效。
MBeanException - 包装了由 MBean 的设置方法抛出的异常。
ReflectionException - 包装了尝试调用设置方法时抛出的 java.lang.Exception。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null，或参数中的属性为 null。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
另请参见：
getAttribute(javax.management.ObjectName, java.lang.String, javax.security.auth.Subject)

setAttributes

AttributeList setAttributes(ObjectName name,
                            MarshalledObject attributes,
                            Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。AttributeList 参数包装在 MarshalledObject 中。

参数：
name - 要在其中设置属性的 MBean 的对象名。
attributes - 属性列表：要设置的属性的标识及要设置的值，封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
原先设置过的带有新值的属性列表。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 尝试调用 Dynamic MBean 的 getAttributes 方法时出现的异常。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null，或参数中的属性为 null。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
另请参见：
getAttributes(javax.management.ObjectName, java.lang.String[], javax.security.auth.Subject)

invoke

Object invoke(ObjectName name,
              String operationName,
              MarshalledObject params,
              String[] signature,
              Subject delegationSubject)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     IOException
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

参数：
name - 将在其上调用此方法的 MBean 的对象名。
operationName - 要调用的操作的名称。
params - 包含调用操作时将设置的参数的数组，它封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
signature - 包含操作的签名的数组。该类对象将使用与加载在其上调用了操作的 MBean 过程中所用的相同的类加载器加载。可以为 null，等效于一个空数组。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
操作返回的对象，它代表在指定的 MBean 上调用操作的结果。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
MBeanException - 包装了由 MBean 的调用的方法抛出的异常。
ReflectionException - 包装了尝试调用此方法时抛出的 java.lang.Exception。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
RuntimeOperationsException - 包装了 name 或 operationName 为 null 时抛出的 IllegalArgumentException。

getDefaultDomain

String getDefaultDomain(Subject delegationSubject)
                        throws IOException
处理 MBeanServerConnection.getDefaultDomain() 方法。

参数：
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
默认的域。
抛出：
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

getDomains

String[] getDomains(Subject delegationSubject)
                    throws IOException
处理 MBeanServerConnection.getDomains() 方法。

参数：
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
域列表。
抛出：
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。

getMBeanInfo

MBeanInfo getMBeanInfo(ObjectName name,
                       Subject delegationSubject)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException,
                              IOException
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。

参数：
name - 要分析的 MBean 的名称
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证委托 principal，则为 null。
返回：
允许检索该 MBean 的所有属性和操作的 MBeanInfo 的实例。
抛出：
IntrospectionException - 自行推算过程中出现的异常。
InstanceNotFoundException - 未找到指定的 MBean。
ReflectionException - 尝试调用 Dynamic MBean 的 getMBeanInfo 方法时出现的异常。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null。

isInstanceOf

boolean isInstanceOf(ObjectName name,
                     String className,
                     Subject delegationSubject)
                     throws InstanceNotFoundException,
                            IOException
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。

参数：
name - MBean 的 ObjectName。
className - 类的名称。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
按照上面的规则，如果指定的 MBean 为指定类的实例，则返回 true，否则返回 false。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
RuntimeOperationsException - 包装了 java.lang.IllegalArgumentException：参数中的对象名为 null。

addNotificationListener

void addNotificationListener(ObjectName name,
                             ObjectName listener,
                             MarshalledObject filter,
                             MarshalledObject handback,
                             Subject delegationSubject)
                             throws InstanceNotFoundException,
                                    IOException
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。NotificationFilter 参数包装在 MarshalledObject 中。Object (handback) 参数也包装在 MarshalledObject 中。

参数：
name - 应在其上添加侦听器的 MBean 的名称。
listener - 将处理由已注册的 MBean 发出通知的侦听器的对象名。
filter - 过滤器对象，封装在 MarshalledObject 中。如果封装在 MarshalledObject 中的过滤器的值为 null，则在对通知处理之前不执行任何过滤。
handback - 通知发出时发送到侦听器的上下文，封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 通知侦听器或通知广播器的 MBean 名称不与注册的任何 MBean 匹配。
RuntimeOperationsException - 包装了 IllegalArgumentException。存在由 listener 命名的 MBean，但它并不实现 NotificationListener 接口，或者 name 或 listener 为 null。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
另请参见：
removeNotificationListener(ObjectName, ObjectName, Subject), removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                ObjectName listener,
                                Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。

参数：
name - 应在其上移除侦听器的 MBean 的名称。
listener - 要移除的侦听器的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 所提供的 MBean 名称不与任何已注册 MBean 匹配。
ListenerNotFoundException - 侦听器未在 MBean 中注册。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
RuntimeOperationsException - 当 name 或 listener 为 null 时包装了 IllegalArgumentException。
另请参见：
addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

removeNotificationListener

void removeNotificationListener(ObjectName name,
                                ObjectName listener,
                                MarshalledObject filter,
                                MarshalledObject handback,
                                Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。NotificationFilter 参数包装在 MarshalledObject 中。Object 参数也包装在 MarshalledObject 中。

参数：
name - 应在其上移除侦听器的 MBean 的名称。
listener - 原先添加到此 MBean 的侦听器。
filter - 添加侦听器时指定的过滤器，它封装在 MarshalledObject 中。
handback - 添加侦听器时指定的 handback，它封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 所提供的 MBean 名称不与任何已注册 MBean 匹配。
ListenerNotFoundException - 侦听器未在 MBean 中注册，或者未用给定的过滤器和 handback 注册。
SecurityException - 如果客户端或委托的 Subject（如果有）没有执行此操作的权限。
IOException - 如果出现通用通信异常。
RuntimeOperationsException - 当 name 或 listener 为 null 时包装了 IllegalArgumentException。
另请参见：
addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

addNotificationListeners

Integer[] addNotificationListeners(ObjectName[] names,
                                   MarshalledObject[] filters,
                                   Subject[] delegationSubjects)
                                   throws InstanceNotFoundException,
                                          IOException

处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。

供来自给定 MBean 的与给定的过滤器匹配的通知使用的记录。远程客户端以后可使用 fetchNotifications 方法检索该通知。

对于每个侦听器，原始的 NotificationListener 和 handback 保留在客户端；为帮助客户端识别它们，服务器生成并返回一个唯一的 listenerID。该 listenerID 与 Notifications 一起转发到远程客户端。

如果给定 (name, filter) 对中有任何一对无法注册，则操作失败并抛出异常，不注册任何名称或过滤器。

参数：
names - 标识发出 Notification 的 MBean 的 ObjectNames。
filters - NotificationFilters 的编组表示形式的数组。此数组的元素可以为 null。
delegationSubjects - 侦听器代表其添加的 Subjects。此数组的元素可以为 null。同样，delegationSubjects 参数本身可以为 null，它表示具有 null 值的数组，数组大小与 names 和 filters 数组大小相同。
返回：
标识本地侦听器的 listenerIDs 数组。此数组具有与参数个数相同的元素数。
抛出：
IllegalArgumentException - 如果 names 或 filters 为 null，或者 names 包含 null 元素，或者三个数组的大小不相同。
ClassCastException - 如果 filters 中有一个元素解组为不是 NotificationFilter 的非 null 对象。
InstanceNotFoundException - 如果 names 中有一个不与任何已注册的 MBean 对应。
SecurityException - 如果 MBean 之一、客户端或委托的 Subject（如果有）无权添加侦听器。
IOException - 如果出现通用通信异常。

removeNotificationListeners

void removeNotificationListeners(ObjectName name,
                                 Integer[] listenerIDs,
                                 Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        ListenerNotFoundException,
                                        IOException

处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。

此方法从 MBean 服务器中的给定 MBean 中移除一个或多个 NotificationListener。

NotificationListeners 通过从 addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) 方法返回的 ID 标识。

参数：
name - 标识发出 Notification 的 MBean 的 ObjectName。
listenerIDs - 与要移除的侦听器对应的 ID。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 如果给定的 name 不对应任何已注册的 MBean。
ListenerNotFoundException - 如果有一个侦听器在服务器端无法找到。当 MBean 出于某种原因丢弃了一个侦听器，而未通过调用 MBeanServer.removeNotificationListener 丢弃时，出现该异常。
SecurityException - 如果客户端或委托的 Subject（如果有）没有移除侦听器的权限。
IOException - 如果出现通用通信异常。
IllegalArgumentException - 如果 ObjectName 或 listenerIds 为 null，或者 listenerIds 包含一个 null 元素。

fetchNotifications

NotificationResult fetchNotifications(long clientSequenceNumber,
                                      int maxNotifications,
                                      long timeout)
                                      throws IOException

检索来自连接器服务器的通知。该方法可能阻塞，直到至少有一个通知，或者直到达到指定的超时时间。该方法还可在任何时间返回零通知。

如果通知的序列号不小于 clientSequenceNumber，并且此客户端已为 MBean 生成通知至少注册了一个侦听器（带一个接收通知的过滤器），则通知可包含在该结果中。对通知感兴趣的各侦听器由从 addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) 返回的整数型 ID 标识。

参数：
clientSequenceNumber - 客户端感兴趣的第一个序列号。如果为负，它表示下一个通知将具有的序列号。
maxNotifications - 返回的不同通知的最大数。如果同一个通知出现了多次，则返回的 NotificationResult 中的 TargetedNotification 数组可能包含比此数更多的元素。如果该参数为负，则行为不明确。
timeout - 等待通知到达的最长时间，以毫秒为单位。它可以是 0，指示在无通知时该方法不应等待，而应立即返回。它可以为 Long.MAX_VALUE，指示无超时。如果该参数为负，则行为不明确。
返回：
一个 NotificationResult。
抛出：
IOException - 如果出现通用通信异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


RMIConnectionImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIConnectionImpl

java.lang.Object
    继承者  javax.management.remote.rmi.RMIConnectionImpl
所有已实现的接口：
Closeable, Remote, Unreferenced, RMIConnection
public class RMIConnectionImpl
extends Object
implements RMIConnection, Unreferenced

RMIConnection 接口的实现。用户代码不经常引用此类。

从以下版本开始：
1.5

构造方法摘要
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。
方法摘要
 void addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 Integer[] addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void close()
关闭此连接。
 ObjectInstance createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 NotificationResult fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
检索来自连接器服务器的通知。
 Object getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 AttributeList getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 String getConnectionId()
返回连接 ID。
 String getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。
 String[] getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。
 Integer getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 MBeanInfo getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 ObjectInstance getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 Object invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 boolean isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 Set<ObjectInstance> queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectName> queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 void removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 AttributeList setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 String toString()
返回此对象的字符串表示形式。
 void unreferenced()
在运行时确定引用列表（引用远程对象的客户机列表）变空之后的某个时候由 RMI 运行时调用。
 void unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RMIConnectionImpl

public RMIConnectionImpl(RMIServerImpl rmiServer,
                         String connectionId,
                         ClassLoader defaultClassLoader,
                         Subject subject,
                         Map<String,?> env)
构造新的 RMIConnection。此连接即可与 JRMP 一起使用，也可与 IIOP 传输一起使用。此对象并不导出其自身：应由调用者将其适当地导出（请参阅 RMIJRMPServerImpl.makeClient(String,Subject) 和 RMIIIOPServerImpl.makeClient(String,Subject)）。

参数：
rmiServer - 为其创建此连接的 RMIServerImpl 对象。如果该参数为 null，则行为不明确。
connectionId - 该连接的 ID。如果该参数为 null，则行为不明确。
defaultClassLoader - 将在反序列化编组对象时使用的默认 ClassLoader。可以为 null，表示引导类加载器。
subject - 将供授权使用的经验证的主题。可以为 null，表示尚未验证任何主题。
env - 包含新的 RMIServerImpl 属性的环境。可以为 null，等效于一个空映射。
方法详细信息

getConnectionId

public String getConnectionId()
                       throws IOException
从接口 RMIConnection 复制的描述

返回连接 ID。对于每个到给定的 RMI 连接器服务器的开放连接，此字符串都不相同。

指定者：
接口 RMIConnection 中的 getConnectionId
返回：
连接 ID
抛出：
IOException - 如果出现通用通信异常。
另请参见：
RMIConnector.connect

close

public void close()
           throws IOException
从接口 RMIConnection 复制的描述

关闭此连接。从此方法返回时，不导出实现此接口的 RMI 对象，因此对它的进一步远程调用将失败。

指定者：
接口 Closeable 中的 close
指定者：
接口 RMIConnection 中的 close
抛出：
IOException - 如果无法关闭连接，或 Remote 对象无法被导出，或者在传输远程关闭请求时出现通信故障。

unreferenced

public void unreferenced()
从接口 Unreferenced 复制的描述
在运行时确定引用列表（引用远程对象的客户机列表）变空之后的某个时候由 RMI 运行时调用。

指定者：
接口 Unreferenced 中的 unreferenced

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。

指定者：
接口 RMIConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
IOException - 如果出现通用通信异常。

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  ObjectName loaderName,
                                  Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。

指定者：
接口 RMIConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
loaderName - 要使用的类加载器的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
InstanceNotFoundException - 指定的类加载器未在 MBean 服务器中注册。
IOException - 如果出现通用通信异常。

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  MarshalledObject params,
                                  String[] signature,
                                  Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
params - 包含要调用的构造方法的参数的数组，数组封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
signature - 包含要调用的构造方法的签名的数组。可以为 null，等效于一个空数组。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
IOException - 如果出现通用通信异常。

createMBean

public ObjectInstance createMBean(String className,
                                  ObjectName name,
                                  ObjectName loaderName,
                                  MarshalledObject params,
                                  String[] signature,
                                  Subject delegationSubject)
                           throws ReflectionException,
                                  InstanceAlreadyExistsException,
                                  MBeanRegistrationException,
                                  MBeanException,
                                  NotCompliantMBeanException,
                                  InstanceNotFoundException,
                                  IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 createMBean
参数：
className - 要实例化的 MBean 的类名称。
name - MBean 的对象名。可以为 null。
loaderName - 要使用的类加载器的对象名。
params - 包含要调用的构造方法的参数的数组，数组封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
signature - 包含要调用的构造方法的签名的数组。可以为 null，等效于一个空数组。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
InstanceNotFoundException - 指定的类加载器未在 MBean 服务器中注册。
IOException - 如果出现通用通信异常。

unregisterMBean

public void unregisterMBean(ObjectName name,
                            Subject delegationSubject)
                     throws InstanceNotFoundException,
                            MBeanRegistrationException,
                            IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 unregisterMBean
参数：
name - 要注册的 MBean 的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
MBeanRegistrationException - MBean 的 preDeregister （MBeanRegistration 接口）方法已抛出异常。
IOException - 如果出现通用通信异常。

getObjectInstance

public ObjectInstance getObjectInstance(ObjectName name,
                                        Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 getObjectInstance
参数：
name - MBean 的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
由 name 指定的与 MBean 关联的 ObjectInstance。所包含的 ObjectName 为 name，所包含的类名称为 getMBeanInfo(name).getClassName()。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
IOException - 如果出现通用通信异常。

queryMBeans

public Set<ObjectInstance> queryMBeans(ObjectName name,
                                       MarshalledObject query,
                                       Subject delegationSubject)
                                throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。QueryExp 包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 queryMBeans
参数：
name - 标识要检索的 MBean 的对象名模式。如果指定了 null 或未指定任何域或关键字属性，则将检索所有已注册的 MBean。
query - 用于选择 MBean 的查询表达式，它封装在 MarshalledObject 中。如果 MarshalledObject 封装了一个 null 值，则选择 MBean 时不使用任何查询表达式。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
包含选定 MBean 的 ObjectInstance 对象集。如果没有任何 MBean 满足此查询，则返回一个空列表。
抛出：
IOException - 如果出现通用通信异常。

queryNames

public Set<ObjectName> queryNames(ObjectName name,
                                  MarshalledObject query,
                                  Subject delegationSubject)
                           throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。QueryExp 包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 queryNames
参数：
name - 标识要检索的 MBean 名称的对象名模式。如果指定了 null 或未指定任何域或关键字属性，则将检索所有已注册的 MBean 的名称。
query - 用于选择 MBean 的查询表达式，它封装在 MarshalledObject 中。如果 MarshalledObject 封装了一个 null 值，则选择 MBean 时不使用任何查询表达式。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
包含选定的 MBean 的 ObjectName 集。如果没有任何 MBean 满足此查询，则返回一个空列表。
抛出：
IOException - 如果出现通用通信异常。

isRegistered

public boolean isRegistered(ObjectName name,
                            Subject delegationSubject)
                     throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 isRegistered
参数：
name - 要检查的 MBean 的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
True 如果 MBean 已在 MBean 服务器上注册，否则返回 false。
抛出：
IOException - 如果出现通用通信异常。

getMBeanCount

public Integer getMBeanCount(Subject delegationSubject)
                      throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getMBeanCount() 方法。

指定者：
接口 RMIConnection 中的 getMBeanCount
参数：
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
已注册的 MBean 数。
抛出：
IOException - 如果出现通用通信异常。

getAttribute

public Object getAttribute(ObjectName name,
                           String attribute,
                           Subject delegationSubject)
                    throws MBeanException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           ReflectionException,
                           IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。

指定者：
接口 RMIConnection 中的 getAttribute
参数：
name - 将要从其检索属性的 MBean 的对象名。
attribute - 指定要检索的属性名称的字符串。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
检索到的属性的值。
抛出：
MBeanException - 包装了由 MBean 的获取方法抛出的异常。
AttributeNotFoundException - 指定的属性在 MBean 中无法访问。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 包装了尝试调用获取方法时抛出的 java.lang.Exception。
IOException - 如果出现通用通信异常。
另请参见：
RMIConnection.setAttribute(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

getAttributes

public AttributeList getAttributes(ObjectName name,
                                   String[] attributes,
                                   Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。

指定者：
接口 RMIConnection 中的 getAttributes
参数：
name - 从其检索属性的 MBean 的对象名。
attributes - 要检索的属性的列表。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
所检索的属性的列表。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 尝试调用 Dynamic MBean 的 getAttributes 方法时出现的异常。
IOException - 如果出现通用通信异常。
另请参见：
RMIConnection.setAttributes(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

setAttribute

public void setAttribute(ObjectName name,
                         MarshalledObject attribute,
                         Subject delegationSubject)
                  throws InstanceNotFoundException,
                         AttributeNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException,
                         IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。Attribute 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 setAttribute
参数：
name - 在其中设置属性的 MBean 的名称。
attribute - 要设置的属性的标识及要设置的值，封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
AttributeNotFoundException - 指定的属性在 MBean 中无法访问。
InvalidAttributeValueException - 为属性指定的值无效。
MBeanException - 包装了由 MBean 的设置方法抛出的异常。
ReflectionException - 包装了尝试调用设置方法时抛出的 java.lang.Exception。
IOException - 如果出现通用通信异常。
另请参见：
RMIConnection.getAttribute(javax.management.ObjectName, java.lang.String, javax.security.auth.Subject)

setAttributes

public AttributeList setAttributes(ObjectName name,
                                   MarshalledObject attributes,
                                   Subject delegationSubject)
                            throws InstanceNotFoundException,
                                   ReflectionException,
                                   IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。AttributeList 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 setAttributes
参数：
name - 要在其中设置属性的 MBean 的对象名。
attributes - 属性列表：要设置的属性的标识及要设置的值，封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
原先设置过的带有新值的属性列表。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 尝试调用 Dynamic MBean 的 getAttributes 方法时出现的异常。
IOException - 如果出现通用通信异常。
另请参见：
RMIConnection.getAttributes(javax.management.ObjectName, java.lang.String[], javax.security.auth.Subject)

invoke

public Object invoke(ObjectName name,
                     String operationName,
                     MarshalledObject params,
                     String[] signature,
                     Subject delegationSubject)
              throws InstanceNotFoundException,
                     MBeanException,
                     ReflectionException,
                     IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 invoke
参数：
name - 将在其上调用此方法的 MBean 的对象名。
operationName - 要调用的操作的名称。
params - 包含调用操作时将设置的参数的数组，它封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
signature - 包含操作的签名的数组。该类对象将使用与加载在其上调用了操作的 MBean 过程中所用的相同的类加载器加载。可以为 null，等效于一个空数组。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
操作返回的对象，它代表在指定的 MBean 上调用操作的结果。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
MBeanException - 包装了由 MBean 的调用的方法抛出的异常。
ReflectionException - 包装了尝试调用此方法时抛出的 java.lang.Exception。
IOException - 如果出现通用通信异常。

getDefaultDomain

public String getDefaultDomain(Subject delegationSubject)
                        throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getDefaultDomain() 方法。

指定者：
接口 RMIConnection 中的 getDefaultDomain
参数：
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
默认的域。
抛出：
IOException - 如果出现通用通信异常。

getDomains

public String[] getDomains(Subject delegationSubject)
                    throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getDomains() 方法。

指定者：
接口 RMIConnection 中的 getDomains
参数：
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
域列表。
抛出：
IOException - 如果出现通用通信异常。

getMBeanInfo

public MBeanInfo getMBeanInfo(ObjectName name,
                              Subject delegationSubject)
                       throws InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException,
                              IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 getMBeanInfo
参数：
name - 要分析的 MBean 的名称
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证委托 principal，则为 null。
返回：
允许检索该 MBean 的所有属性和操作的 MBeanInfo 的实例。
抛出：
InstanceNotFoundException - 未找到指定的 MBean。
IntrospectionException - 自行推算过程中出现的异常。
ReflectionException - 尝试调用 Dynamic MBean 的 getMBeanInfo 方法时出现的异常。
IOException - 如果出现通用通信异常。

isInstanceOf

public boolean isInstanceOf(ObjectName name,
                            String className,
                            Subject delegationSubject)
                     throws InstanceNotFoundException,
                            IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。

指定者：
接口 RMIConnection 中的 isInstanceOf
参数：
name - MBean 的 ObjectName。
className - 类的名称。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
按照上面的规则，如果指定的 MBean 为指定类的实例，则返回 true，否则返回 false。
抛出：
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
IOException - 如果出现通用通信异常。

addNotificationListeners

public Integer[] addNotificationListeners(ObjectName[] names,
                                          MarshalledObject[] filters,
                                          Subject[] delegationSubjects)
                                   throws InstanceNotFoundException,
                                          IOException
从接口 RMIConnection 复制的描述

处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。

供来自给定 MBean 的与给定的过滤器匹配的通知使用的记录。远程客户端以后可使用 fetchNotifications 方法检索该通知。

对于每个侦听器，原始的 NotificationListener 和 handback 保留在客户端；为帮助客户端识别它们，服务器生成并返回一个唯一的 listenerID。该 listenerID 与 Notifications 一起转发到远程客户端。

如果给定 (name, filter) 对中有任何一对无法注册，则操作失败并抛出异常，不注册任何名称或过滤器。

指定者：
接口 RMIConnection 中的 addNotificationListeners
参数：
names - 标识发出 Notification 的 MBean 的 ObjectNames。
filters - NotificationFilters 的编组表示形式的数组。此数组的元素可以为 null。
delegationSubjects - 侦听器代表其添加的 Subjects。此数组的元素可以为 null。同样，delegationSubjects 参数本身可以为 null，它表示具有 null 值的数组，数组大小与 names 和 filters 数组大小相同。
返回：
标识本地侦听器的 listenerIDs 数组。此数组具有与参数个数相同的元素数。
抛出：
InstanceNotFoundException - 如果 names 中有一个不与任何已注册的 MBean 对应。
IOException - 如果出现通用通信异常。

addNotificationListener

public void addNotificationListener(ObjectName name,
                                    ObjectName listener,
                                    MarshalledObject filter,
                                    MarshalledObject handback,
                                    Subject delegationSubject)
                             throws InstanceNotFoundException,
                                    IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。NotificationFilter 参数包装在 MarshalledObject 中。Object (handback) 参数也包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 addNotificationListener
参数：
name - 应在其上添加侦听器的 MBean 的名称。
listener - 将处理由已注册的 MBean 发出通知的侦听器的对象名。
filter - 过滤器对象，封装在 MarshalledObject 中。如果封装在 MarshalledObject 中的过滤器的值为 null，则在对通知处理之前不执行任何过滤。
handback - 通知发出时发送到侦听器的上下文，封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 通知侦听器或通知广播器的 MBean 名称不与注册的任何 MBean 匹配。
IOException - 如果出现通用通信异常。
另请参见：
RMIConnection.removeNotificationListener(ObjectName, ObjectName, Subject), RMIConnection.removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)

removeNotificationListeners

public void removeNotificationListeners(ObjectName name,
                                        Integer[] listenerIDs,
                                        Subject delegationSubject)
                                 throws InstanceNotFoundException,
                                        ListenerNotFoundException,
                                        IOException
从接口 RMIConnection 复制的描述

处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。

此方法从 MBean 服务器中的给定 MBean 中移除一个或多个 NotificationListener。

NotificationListeners 通过从 RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) 方法返回的 ID 标识。

指定者：
接口 RMIConnection 中的 removeNotificationListeners
参数：
name - 标识发出 Notification 的 MBean 的 ObjectName。
listenerIDs - 与要移除的侦听器对应的 ID。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 如果给定的 name 不对应任何已注册的 MBean。
ListenerNotFoundException - 如果有一个侦听器在服务器端无法找到。当 MBean 出于某种原因丢弃了一个侦听器，而未通过调用 MBeanServer.removeNotificationListener 丢弃时，出现该异常。
IOException - 如果出现通用通信异常。

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       ObjectName listener,
                                       Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。

指定者：
接口 RMIConnection 中的 removeNotificationListener
参数：
name - 应在其上移除侦听器的 MBean 的名称。
listener - 要移除的侦听器的对象名。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 所提供的 MBean 名称不与任何已注册 MBean 匹配。
ListenerNotFoundException - 侦听器未在 MBean 中注册。
IOException - 如果出现通用通信异常。
另请参见：
RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

removeNotificationListener

public void removeNotificationListener(ObjectName name,
                                       ObjectName listener,
                                       MarshalledObject filter,
                                       MarshalledObject handback,
                                       Subject delegationSubject)
                                throws InstanceNotFoundException,
                                       ListenerNotFoundException,
                                       IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。NotificationFilter 参数包装在 MarshalledObject 中。Object 参数也包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 removeNotificationListener
参数：
name - 应在其上移除侦听器的 MBean 的名称。
listener - 原先添加到此 MBean 的侦听器。
filter - 添加侦听器时指定的过滤器，它封装在 MarshalledObject 中。
handback - 添加侦听器时指定的 handback，它封装在 MarshalledObject 中。
delegationSubject - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
InstanceNotFoundException - 所提供的 MBean 名称不与任何已注册 MBean 匹配。
ListenerNotFoundException - 侦听器未在 MBean 中注册，或者未用给定的过滤器和 handback 注册。
IOException - 如果出现通用通信异常。
另请参见：
RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

fetchNotifications

public NotificationResult fetchNotifications(long clientSequenceNumber,
                                             int maxNotifications,
                                             long timeout)
                                      throws IOException
从接口 RMIConnection 复制的描述

检索来自连接器服务器的通知。该方法可能阻塞，直到至少有一个通知，或者直到达到指定的超时时间。该方法还可在任何时间返回零通知。

如果通知的序列号不小于 clientSequenceNumber，并且此客户端已为 MBean 生成通知至少注册了一个侦听器（带一个接收通知的过滤器），则通知可包含在该结果中。对通知感兴趣的各侦听器由从 RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) 返回的整数型 ID 标识。

指定者：
接口 RMIConnection 中的 fetchNotifications
参数：
clientSequenceNumber - 客户端感兴趣的第一个序列号。如果为负，它表示下一个通知将具有的序列号。
maxNotifications - 返回的不同通知的最大数。如果同一个通知出现了多次，则返回的 NotificationResult 中的 TargetedNotification 数组可能包含比此数更多的元素。如果该参数为负，则行为不明确。
timeout - 等待通知到达的最长时间，以毫秒为单位。它可以是 0，指示在无通知时该方法不应等待，而应立即返回。它可以为 Long.MAX_VALUE，指示无超时。如果该参数为负，则行为不明确。
返回：
一个 NotificationResult。
抛出：
IOException - 如果出现通用通信异常。

toString

public String toString()

返回此对象的字符串表示形式。通常情况下，toString 方法会返回一个“按文本方式表示”此对象的字符串。结果应是一个简明而丰富的表示，它方便人们阅读。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIConnectionImpl_Stub (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIConnectionImpl_Stub

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteStub
            继承者  javax.management.remote.rmi.RMIConnectionImpl_Stub
所有已实现的接口：
Closeable, Serializable, Remote, RMIConnection
public final class RMIConnectionImpl_Stub
extends RemoteStub
implements RMIConnection

另请参见：
序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
RMIConnectionImpl_Stub(RemoteRef ref)
方法摘要
 void addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 Integer[] addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void close()
关闭此连接。
 ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 NotificationResult fetchNotifications(long $param_long_1, int $param_int_2, long $param_long_3)
检索来自连接器服务器的通知。
 Object getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 AttributeList getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 String getConnectionId()
返回连接 ID。
 String getDefaultDomain(Subject $param_Subject_1)
处理 MBeanServerConnection.getDefaultDomain() 方法。
 String[] getDomains(Subject $param_Subject_1)
处理 MBeanServerConnection.getDomains() 方法。
 Integer getMBeanCount(Subject $param_Subject_1)
处理 MBeanServerConnection.getMBeanCount() 方法。
 MBeanInfo getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 ObjectInstance getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 Object invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 boolean isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 Set queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 void removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 AttributeList setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 void unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
从类 java.rmi.server.RemoteStub 继承的方法
setRef
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

RMIConnectionImpl_Stub

public RMIConnectionImpl_Stub(RemoteRef ref)
方法详细信息

addNotificationListener

public void addNotificationListener(ObjectName $param_ObjectName_1,
                                    ObjectName $param_ObjectName_2,
                                    MarshalledObject $param_MarshalledObject_3,
                                    MarshalledObject $param_MarshalledObject_4,
                                    Subject $param_Subject_5)
                             throws IOException,
                                    InstanceNotFoundException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。NotificationFilter 参数包装在 MarshalledObject 中。Object (handback) 参数也包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 addNotificationListener
参数：
$param_ObjectName_1 - 应在其上添加侦听器的 MBean 的名称。
$param_ObjectName_2 - 将处理由已注册的 MBean 发出通知的侦听器的对象名。
$param_MarshalledObject_3 - 过滤器对象，封装在 MarshalledObject 中。如果封装在 MarshalledObject 中的过滤器的值为 null，则在对通知处理之前不执行任何过滤。
$param_MarshalledObject_4 - 通知发出时发送到侦听器的上下文，封装在 MarshalledObject 中。
$param_Subject_5 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 通知侦听器或通知广播器的 MBean 名称不与注册的任何 MBean 匹配。
另请参见：
RMIConnection.removeNotificationListener(ObjectName, ObjectName, Subject), RMIConnection.removeNotificationListener(ObjectName, ObjectName, MarshalledObject, MarshalledObject, Subject)

addNotificationListeners

public Integer[] addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1,
                                          MarshalledObject[] $param_arrayOf_MarshalledObject_2,
                                          Subject[] $param_arrayOf_Subject_3)
                                   throws IOException,
                                          InstanceNotFoundException
从接口 RMIConnection 复制的描述

处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。

供来自给定 MBean 的与给定的过滤器匹配的通知使用的记录。远程客户端以后可使用 fetchNotifications 方法检索该通知。

对于每个侦听器，原始的 NotificationListener 和 handback 保留在客户端；为帮助客户端识别它们，服务器生成并返回一个唯一的 listenerID。该 listenerID 与 Notifications 一起转发到远程客户端。

如果给定 (name, filter) 对中有任何一对无法注册，则操作失败并抛出异常，不注册任何名称或过滤器。

指定者：
接口 RMIConnection 中的 addNotificationListeners
参数：
$param_arrayOf_ObjectName_1 - 标识发出 Notification 的 MBean 的 ObjectNames。
$param_arrayOf_MarshalledObject_2 - NotificationFilters 的编组表示形式的数组。此数组的元素可以为 null。
$param_arrayOf_Subject_3 - 侦听器代表其添加的 Subjects。此数组的元素可以为 null。同样，delegationSubjects 参数本身可以为 null，它表示具有 null 值的数组，数组大小与 names 和 filters 数组大小相同。
返回：
标识本地侦听器的 listenerIDs 数组。此数组具有与参数个数相同的元素数。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 如果 names 中有一个不与任何已注册的 MBean 对应。

close

public void close()
           throws IOException
从接口 RMIConnection 复制的描述

关闭此连接。从此方法返回时，不导出实现此接口的 RMI 对象，因此对它的进一步远程调用将失败。

指定者：
接口 Closeable 中的 close
指定者：
接口 RMIConnection 中的 close
抛出：
IOException - 如果无法关闭连接，或 Remote 对象无法被导出，或者在传输远程关闭请求时出现通信故障。

createMBean

public ObjectInstance createMBean(String $param_String_1,
                                  ObjectName $param_ObjectName_2,
                                  MarshalledObject $param_MarshalledObject_3,
                                  String[] $param_arrayOf_String_4,
                                  Subject $param_Subject_5)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 createMBean
参数：
$param_String_1 - 要实例化的 MBean 的类名称。
$param_ObjectName_2 - MBean 的对象名。可以为 null。
$param_MarshalledObject_3 - 包含要调用的构造方法的参数的数组，数组封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
$param_arrayOf_String_4 - 包含要调用的构造方法的签名的数组。可以为 null，等效于一个空数组。
$param_Subject_5 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
IOException - 如果出现通用通信异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。

createMBean

public ObjectInstance createMBean(String $param_String_1,
                                  ObjectName $param_ObjectName_2,
                                  ObjectName $param_ObjectName_3,
                                  MarshalledObject $param_MarshalledObject_4,
                                  String[] $param_arrayOf_String_5,
                                  Subject $param_Subject_6)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  InstanceNotFoundException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 createMBean
参数：
$param_String_1 - 要实例化的 MBean 的类名称。
$param_ObjectName_2 - MBean 的对象名。可以为 null。
$param_ObjectName_3 - 要使用的类加载器的对象名。
$param_MarshalledObject_4 - 包含要调用的构造方法的参数的数组，数组封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
$param_arrayOf_String_5 - 包含要调用的构造方法的签名的数组。可以为 null，等效于一个空数组。
$param_Subject_6 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
IOException - 如果出现通用通信异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
InstanceNotFoundException - 指定的类加载器未在 MBean 服务器中注册。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。

createMBean

public ObjectInstance createMBean(String $param_String_1,
                                  ObjectName $param_ObjectName_2,
                                  ObjectName $param_ObjectName_3,
                                  Subject $param_Subject_4)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  InstanceNotFoundException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。

指定者：
接口 RMIConnection 中的 createMBean
参数：
$param_String_1 - 要实例化的 MBean 的类名称。
$param_ObjectName_2 - MBean 的对象名。可以为 null。
$param_ObjectName_3 - 要使用的类加载器的对象名。
$param_Subject_4 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
IOException - 如果出现通用通信异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
InstanceNotFoundException - 指定的类加载器未在 MBean 服务器中注册。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。

createMBean

public ObjectInstance createMBean(String $param_String_1,
                                  ObjectName $param_ObjectName_2,
                                  Subject $param_Subject_3)
                           throws IOException,
                                  InstanceAlreadyExistsException,
                                  MBeanException,
                                  MBeanRegistrationException,
                                  NotCompliantMBeanException,
                                  ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。

指定者：
接口 RMIConnection 中的 createMBean
参数：
$param_String_1 - 要实例化的 MBean 的类名称。
$param_ObjectName_2 - MBean 的对象名。可以为 null。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
ObjectInstance，它包含新实例化的 MBean 的 ObjectName 和 Java 类名。如果所包含的 ObjectName 为 n，则所包含的 Java 类名为 getMBeanInfo(n).getClassName()。
抛出：
IOException - 如果出现通用通信异常。
InstanceAlreadyExistsException - MBean 已处于 MBean 服务器的控制之下。
MBeanRegistrationException - MBean 的 preRegister （MBeanRegistration 接口）方法已抛出异常。不对 MBean 进行注册。
MBeanException - MBean 的构造方法已抛出异常。
NotCompliantMBeanException - 该类不是一个遵守 JMX 的 MBean。
ReflectionException - 在尝试调用 MBean 的构造方法的过程中出现的、包装了 java.lang.ClassNotFoundException 或 java.lang.Exception 的异常。

fetchNotifications

public NotificationResult fetchNotifications(long $param_long_1,
                                             int $param_int_2,
                                             long $param_long_3)
                                      throws IOException
从接口 RMIConnection 复制的描述

检索来自连接器服务器的通知。该方法可能阻塞，直到至少有一个通知，或者直到达到指定的超时时间。该方法还可在任何时间返回零通知。

如果通知的序列号不小于 clientSequenceNumber，并且此客户端已为 MBean 生成通知至少注册了一个侦听器（带一个接收通知的过滤器），则通知可包含在该结果中。对通知感兴趣的各侦听器由从 RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) 返回的整数型 ID 标识。

指定者：
接口 RMIConnection 中的 fetchNotifications
参数：
$param_long_1 - 客户端感兴趣的第一个序列号。如果为负，它表示下一个通知将具有的序列号。
$param_int_2 - 返回的不同通知的最大数。如果同一个通知出现了多次，则返回的 NotificationResult 中的 TargetedNotification 数组可能包含比此数更多的元素。如果该参数为负，则行为不明确。
$param_long_3 - 等待通知到达的最长时间，以毫秒为单位。它可以是 0，指示在无通知时该方法不应等待，而应立即返回。它可以为 Long.MAX_VALUE，指示无超时。如果该参数为负，则行为不明确。
返回：
一个 NotificationResult。
抛出：
IOException - 如果出现通用通信异常。

getAttribute

public Object getAttribute(ObjectName $param_ObjectName_1,
                           String $param_String_2,
                           Subject $param_Subject_3)
                    throws IOException,
                           AttributeNotFoundException,
                           InstanceNotFoundException,
                           MBeanException,
                           ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。

指定者：
接口 RMIConnection 中的 getAttribute
参数：
$param_ObjectName_1 - 将要从其检索属性的 MBean 的对象名。
$param_String_2 - 指定要检索的属性名称的字符串。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
检索到的属性的值。
抛出：
IOException - 如果出现通用通信异常。
AttributeNotFoundException - 指定的属性在 MBean 中无法访问。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
MBeanException - 包装了由 MBean 的获取方法抛出的异常。
ReflectionException - 包装了尝试调用获取方法时抛出的 java.lang.Exception。
另请参见：
RMIConnection.setAttribute(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

getAttributes

public AttributeList getAttributes(ObjectName $param_ObjectName_1,
                                   String[] $param_arrayOf_String_2,
                                   Subject $param_Subject_3)
                            throws IOException,
                                   InstanceNotFoundException,
                                   ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。

指定者：
接口 RMIConnection 中的 getAttributes
参数：
$param_ObjectName_1 - 从其检索属性的 MBean 的对象名。
$param_arrayOf_String_2 - 要检索的属性的列表。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
所检索的属性的列表。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 尝试调用 Dynamic MBean 的 getAttributes 方法时出现的异常。
另请参见：
RMIConnection.setAttributes(javax.management.ObjectName, java.rmi.MarshalledObject, javax.security.auth.Subject)

getConnectionId

public String getConnectionId()
                       throws IOException
从接口 RMIConnection 复制的描述

返回连接 ID。对于每个到给定的 RMI 连接器服务器的开放连接，此字符串都不相同。

指定者：
接口 RMIConnection 中的 getConnectionId
返回：
连接 ID
抛出：
IOException - 如果出现通用通信异常。
另请参见：
RMIConnector.connect

getDefaultDomain

public String getDefaultDomain(Subject $param_Subject_1)
                        throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getDefaultDomain() 方法。

指定者：
接口 RMIConnection 中的 getDefaultDomain
参数：
$param_Subject_1 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
默认的域。
抛出：
IOException - 如果出现通用通信异常。

getDomains

public String[] getDomains(Subject $param_Subject_1)
                    throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getDomains() 方法。

指定者：
接口 RMIConnection 中的 getDomains
参数：
$param_Subject_1 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
域列表。
抛出：
IOException - 如果出现通用通信异常。

getMBeanCount

public Integer getMBeanCount(Subject $param_Subject_1)
                      throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getMBeanCount() 方法。

指定者：
接口 RMIConnection 中的 getMBeanCount
参数：
$param_Subject_1 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
已注册的 MBean 数。
抛出：
IOException - 如果出现通用通信异常。

getMBeanInfo

public MBeanInfo getMBeanInfo(ObjectName $param_ObjectName_1,
                              Subject $param_Subject_2)
                       throws IOException,
                              InstanceNotFoundException,
                              IntrospectionException,
                              ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 getMBeanInfo
参数：
$param_ObjectName_1 - 要分析的 MBean 的名称
$param_Subject_2 - 包含委托 principal 的 Subject，如果使用了验证委托 principal，则为 null。
返回：
允许检索该 MBean 的所有属性和操作的 MBeanInfo 的实例。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 未找到指定的 MBean。
IntrospectionException - 自行推算过程中出现的异常。
ReflectionException - 尝试调用 Dynamic MBean 的 getMBeanInfo 方法时出现的异常。

getObjectInstance

public ObjectInstance getObjectInstance(ObjectName $param_ObjectName_1,
                                        Subject $param_Subject_2)
                                 throws IOException,
                                        InstanceNotFoundException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 getObjectInstance
参数：
$param_ObjectName_1 - MBean 的对象名。
$param_Subject_2 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
由 name 指定的与 MBean 关联的 ObjectInstance。所包含的 ObjectName 为 name，所包含的类名称为 getMBeanInfo(name).getClassName()。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。

invoke

public Object invoke(ObjectName $param_ObjectName_1,
                     String $param_String_2,
                     MarshalledObject $param_MarshalledObject_3,
                     String[] $param_arrayOf_String_4,
                     Subject $param_Subject_5)
              throws IOException,
                     InstanceNotFoundException,
                     MBeanException,
                     ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。Object[] 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 invoke
参数：
$param_ObjectName_1 - 将在其上调用此方法的 MBean 的对象名。
$param_String_2 - 要调用的操作的名称。
$param_MarshalledObject_3 - 包含调用操作时将设置的参数的数组，它封装在 MarshalledObject 中。封装的数组可以为 null，其等效于一个空数组。
$param_arrayOf_String_4 - 包含操作的签名的数组。该类对象将使用与加载在其上调用了操作的 MBean 过程中所用的相同的类加载器加载。可以为 null，等效于一个空数组。
$param_Subject_5 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
操作返回的对象，它代表在指定的 MBean 上调用操作的结果。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
MBeanException - 包装了由 MBean 的调用的方法抛出的异常。
ReflectionException - 包装了尝试调用此方法时抛出的 java.lang.Exception。

isInstanceOf

public boolean isInstanceOf(ObjectName $param_ObjectName_1,
                            String $param_String_2,
                            Subject $param_Subject_3)
                     throws IOException,
                            InstanceNotFoundException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。

指定者：
接口 RMIConnection 中的 isInstanceOf
参数：
$param_ObjectName_1 - MBean 的 ObjectName。
$param_String_2 - 类的名称。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
按照上面的规则，如果指定的 MBean 为指定类的实例，则返回 true，否则返回 false。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。

isRegistered

public boolean isRegistered(ObjectName $param_ObjectName_1,
                            Subject $param_Subject_2)
                     throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 isRegistered
参数：
$param_ObjectName_1 - 要检查的 MBean 的对象名。
$param_Subject_2 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
True 如果 MBean 已在 MBean 服务器上注册，否则返回 false。
抛出：
IOException - 如果出现通用通信异常。

queryMBeans

public Set queryMBeans(ObjectName $param_ObjectName_1,
                       MarshalledObject $param_MarshalledObject_2,
                       Subject $param_Subject_3)
                throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。QueryExp 包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 queryMBeans
参数：
$param_ObjectName_1 - 标识要检索的 MBean 的对象名模式。如果指定了 null 或未指定任何域或关键字属性，则将检索所有已注册的 MBean。
$param_MarshalledObject_2 - 用于选择 MBean 的查询表达式，它封装在 MarshalledObject 中。如果 MarshalledObject 封装了一个 null 值，则选择 MBean 时不使用任何查询表达式。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
包含选定 MBean 的 ObjectInstance 对象集。如果没有任何 MBean 满足此查询，则返回一个空列表。
抛出：
IOException - 如果出现通用通信异常。

queryNames

public Set queryNames(ObjectName $param_ObjectName_1,
                      MarshalledObject $param_MarshalledObject_2,
                      Subject $param_Subject_3)
               throws IOException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。QueryExp 包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 queryNames
参数：
$param_ObjectName_1 - 标识要检索的 MBean 名称的对象名模式。如果指定了 null 或未指定任何域或关键字属性，则将检索所有已注册的 MBean 的名称。
$param_MarshalledObject_2 - 用于选择 MBean 的查询表达式，它封装在 MarshalledObject 中。如果 MarshalledObject 封装了一个 null 值，则选择 MBean 时不使用任何查询表达式。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
包含选定的 MBean 的 ObjectName 集。如果没有任何 MBean 满足此查询，则返回一个空列表。
抛出：
IOException - 如果出现通用通信异常。

removeNotificationListener

public void removeNotificationListener(ObjectName $param_ObjectName_1,
                                       ObjectName $param_ObjectName_2,
                                       MarshalledObject $param_MarshalledObject_3,
                                       MarshalledObject $param_MarshalledObject_4,
                                       Subject $param_Subject_5)
                                throws IOException,
                                       InstanceNotFoundException,
                                       ListenerNotFoundException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。NotificationFilter 参数包装在 MarshalledObject 中。Object 参数也包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 removeNotificationListener
参数：
$param_ObjectName_1 - 应在其上移除侦听器的 MBean 的名称。
$param_ObjectName_2 - 原先添加到此 MBean 的侦听器。
$param_MarshalledObject_3 - 添加侦听器时指定的过滤器，它封装在 MarshalledObject 中。
$param_MarshalledObject_4 - 添加侦听器时指定的 handback，它封装在 MarshalledObject 中。
$param_Subject_5 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 所提供的 MBean 名称不与任何已注册 MBean 匹配。
ListenerNotFoundException - 侦听器未在 MBean 中注册，或者未用给定的过滤器和 handback 注册。
另请参见：
RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

removeNotificationListener

public void removeNotificationListener(ObjectName $param_ObjectName_1,
                                       ObjectName $param_ObjectName_2,
                                       Subject $param_Subject_3)
                                throws IOException,
                                       InstanceNotFoundException,
                                       ListenerNotFoundException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。

指定者：
接口 RMIConnection 中的 removeNotificationListener
参数：
$param_ObjectName_1 - 应在其上移除侦听器的 MBean 的名称。
$param_ObjectName_2 - 要移除的侦听器的对象名。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 所提供的 MBean 名称不与任何已注册 MBean 匹配。
ListenerNotFoundException - 侦听器未在 MBean 中注册。
另请参见：
RMIConnection.addNotificationListener(javax.management.ObjectName, javax.management.ObjectName, java.rmi.MarshalledObject, java.rmi.MarshalledObject, javax.security.auth.Subject)

removeNotificationListeners

public void removeNotificationListeners(ObjectName $param_ObjectName_1,
                                        Integer[] $param_arrayOf_Integer_2,
                                        Subject $param_Subject_3)
                                 throws IOException,
                                        InstanceNotFoundException,
                                        ListenerNotFoundException
从接口 RMIConnection 复制的描述

处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。

此方法从 MBean 服务器中的给定 MBean 中移除一个或多个 NotificationListener。

NotificationListeners 通过从 RMIConnection.addNotificationListeners(ObjectName[], MarshalledObject[], Subject[]) 方法返回的 ID 标识。

指定者：
接口 RMIConnection 中的 removeNotificationListeners
参数：
$param_ObjectName_1 - 标识发出 Notification 的 MBean 的 ObjectName。
$param_arrayOf_Integer_2 - 与要移除的侦听器对应的 ID。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 如果给定的 name 不对应任何已注册的 MBean。
ListenerNotFoundException - 如果有一个侦听器在服务器端无法找到。当 MBean 出于某种原因丢弃了一个侦听器，而未通过调用 MBeanServer.removeNotificationListener 丢弃时，出现该异常。

setAttribute

public void setAttribute(ObjectName $param_ObjectName_1,
                         MarshalledObject $param_MarshalledObject_2,
                         Subject $param_Subject_3)
                  throws IOException,
                         AttributeNotFoundException,
                         InstanceNotFoundException,
                         InvalidAttributeValueException,
                         MBeanException,
                         ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。Attribute 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 setAttribute
参数：
$param_ObjectName_1 - 在其中设置属性的 MBean 的名称。
$param_MarshalledObject_2 - 要设置的属性的标识及要设置的值，封装在 MarshalledObject 中。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
IOException - 如果出现通用通信异常。
AttributeNotFoundException - 指定的属性在 MBean 中无法访问。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
InvalidAttributeValueException - 为属性指定的值无效。
MBeanException - 包装了由 MBean 的设置方法抛出的异常。
ReflectionException - 包装了尝试调用设置方法时抛出的 java.lang.Exception。
另请参见：
RMIConnection.getAttribute(javax.management.ObjectName, java.lang.String, javax.security.auth.Subject)

setAttributes

public AttributeList setAttributes(ObjectName $param_ObjectName_1,
                                   MarshalledObject $param_MarshalledObject_2,
                                   Subject $param_Subject_3)
                            throws IOException,
                                   InstanceNotFoundException,
                                   ReflectionException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。AttributeList 参数包装在 MarshalledObject 中。

指定者：
接口 RMIConnection 中的 setAttributes
参数：
$param_ObjectName_1 - 要在其中设置属性的 MBean 的对象名。
$param_MarshalledObject_2 - 属性列表：要设置的属性的标识及要设置的值，封装在 MarshalledObject 中。
$param_Subject_3 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
返回：
原先设置过的带有新值的属性列表。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
ReflectionException - 尝试调用 Dynamic MBean 的 getAttributes 方法时出现的异常。
另请参见：
RMIConnection.getAttributes(javax.management.ObjectName, java.lang.String[], javax.security.auth.Subject)

unregisterMBean

public void unregisterMBean(ObjectName $param_ObjectName_1,
                            Subject $param_Subject_2)
                     throws IOException,
                            InstanceNotFoundException,
                            MBeanRegistrationException
从接口 RMIConnection 复制的描述
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。

指定者：
接口 RMIConnection 中的 unregisterMBean
参数：
$param_ObjectName_1 - 要注册的 MBean 的对象名。
$param_Subject_2 - 包含委托 principal 的 Subject，如果使用了验证 principal，则为 null。
抛出：
IOException - 如果出现通用通信异常。
InstanceNotFoundException - 指定的 MBean 未在 MBean 服务器中注册。
MBeanRegistrationException - MBean 的 preDeregister （MBeanRegistration 接口）方法已抛出异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIConnector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIConnector

java.lang.Object
    继承者  javax.management.remote.rmi.RMIConnector
所有已实现的接口：
Closeable, Serializable, JMXAddressable, JMXConnector
public class RMIConnector
extends Object
implements JMXConnector, Serializable, JMXAddressable

一个到远程 RMI 连接器的连接。通常使用 JMXConnectorFactory 建立这样的连接。但是，专门的应用程序可直接使用此类，例如获得 RMIServer 桩模块 (stub) 则不需要通过 JNDI。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
从接口 javax.management.remote.JMXConnector 继承的字段
CREDENTIALS
构造方法摘要
RMIConnector(JMXServiceURL url, Map<String,?> environment)
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。
RMIConnector(RMIServer rmiServer, Map<String,?> environment)
用给定的 RMI stub 构造一个 RMIConnector。
方法摘要
void | addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个接收连接状态改变的侦听器。
void | close() 关闭客户端到其服务器的连接。
void | connect() 建立到连接器服务器的连接。
void | connect(Map<String,?> environment) 建立到连接器服务器的连接。
JMXServiceURL | getAddress() 此连接器的地址。
String | getConnectionId() 获得来自连接器服务器的连接 ID。
MBeanServerConnection | getMBeanServerConnection() 返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
MBeanServerConnection | getMBeanServerConnection(Subject delegationSubject) 返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。
void | removeConnectionNotificationListener(NotificationListener listener) 将一个用于接收状态更改通知的侦听器从列表中移除。
void | removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。
String | toString() 返回此对象的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RMIConnector

public RMIConnector(JMXServiceURL url,
                    Map<String,?> environment)

构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。

地址可直接引用连接器服务器，可使用如下语法之一：

 service:jmx:rmi://[host[:port]]/stub/encoded-stub
 service:jmx:iiop://[host[:port]]/ior/encoded-IOR

（这里的方括号 [] 不属于地址的组成部分，只表示主机和端口为可选项）。

地址还可表示使用 JNDI 查找 RMI stub 的位置，使用如下语法之一：

 service:jmx:rmi://[host[:port]]/jndi/jndi-name
 service:jmx:iiop://[host[:port]]/jndi/jndi-name

实现还可识别其他地址语法，如下所示：

 service:jmx:iiop://[host[:port]]/stub/encoded-stub

参数：
url - RMI 连接器服务器的地址。
environment - 指定如何进行连接的其他属性。对于基于 JNDI 的地址，这些属性可有效地包含可由 InitialContext 识别的 JNDI 属性。此参数可以为 null，它等效于一个空映射。
抛出：
IllegalArgumentException - 如果 url 为 null。

RMIConnector

public RMIConnector(RMIServer rmiServer,
                    Map<String,?> environment)

用给定的 RMI stub 构造一个 RMIConnector。

参数：
rmiServer - 代表 RMI 连接器服务器的一个 RMI 桩模块。
environment - 指定如何进行连接的其他属性。此参数可以为 null，其等效于一个空映射。
抛出：
IllegalArgumentException - 如果 rmiServer 为 null。
方法详细信息

toString

public String toString()

返回此对象的字符串表示形式。通常，toString 方法会返回一个“按文本方式表示”此对象的字符串。结果应是一个简明而丰富的表示形式，以方便人们阅读。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式。

getAddress

public JMXServiceURL getAddress()

此连接器的地址。

指定者：
接口 JMXAddressable 中的 getAddress
返回：
此连接器的地址；如果没有任何地址，则返回 null。
从以下版本开始：
1.6

connect

public void connect()
             throws IOException
从接口 JMXConnector 复制的描述

建立到连接器服务器的连接。此方法等效于 connect(null)。

指定者：
接口 JMXConnector 中的 connect
抛出：
IOException - 如果由于存在通信问题而导致无法建立连接。

connect

public void connect(Map<String,?> environment)
             throws IOException
从接口 JMXConnector 复制的描述

建立到连接器服务器的连接。

如果已在该对象上成功调用了 connect，则再次调用将没有任何作用。但是，如果 JMXConnector.close() 是在调用 connect 之后调用的，则新的 connect 将抛出 IOException。

否则，在此对象上未调用过任何一个 connect，或者虽然调用过但生成了一个异常。然后对 connect 的调用将试图建立到连接器服务器的连接。

指定者：
接口 JMXConnector 中的 connect
参数：
environment - 连接的属性。此映射中的属性重写创建 JMXConnector 时指定的映射中的属性（如果有）。此参数可以为 null，其等效于一个空映射。
抛出：
IOException - 如果由于存在通信问题而导致无法建立连接。

getConnectionId

public String getConnectionId()
                       throws IOException
从接口 JMXConnector 复制的描述

获得来自连接器服务器的连接 ID。对于给定的连接器服务器，每个连接将具有一个在连接的整个生命周期中都不改变的唯一 ID。

指定者：
接口 JMXConnector 中的 getConnectionId
返回：
此连接的唯一 ID。这与连接器服务器包含在其 JMXConnectionNotification 中的 ID 相同。package description 描述了连接 ID 的约定。
抛出：
IOException - 如果无法获得连接 ID，例如在连接关闭或断开的情况下。

getMBeanServerConnection

public MBeanServerConnection getMBeanServerConnection()
                                               throws IOException
从接口 JMXConnector 复制的描述

返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。对于给定的 JMXConnector，对此方法两次成功的调用通常将返回相同的 MBeanServerConnection 对象，尽管不需要这样做。

对于返回的 MBeanServerConnection 中的每个方法，调用该方法将导致调用远程 MBean 服务器中的相应方法。MBean 服务器方法返回的值就是返回给客户端的值。如果 MBean 服务器方法生成了 Exception，则客户端上也会出现相同的 Exception。如果 MBean 服务器方法（或尝试对它的调用）生成了 Error，则该 Error 将包装在 JMXServerErrorException 中，从客户端能够看到该错误。

调用该方法等效于调用 getMBeanServerConnection(null)，这意味着未指定任何委托主题并且在 MBeanServerConnection 上调用的所有操作必须使用经验证的主题（如果有）。

指定者：
接口 JMXConnector 中的 getMBeanServerConnection
返回：
一个通过将其方法转发到远程 MBean 服务器而实现 MBeanServerConnection 接口的对象。
抛出：
IOException - 如果无法创建有效的 MBeanServerConnection，例如，由于尚未建立到远程 MBean 服务器的连接（用 connect 方法），或者连接已关闭，或者连接已断开。

getMBeanServerConnection

public MBeanServerConnection getMBeanServerConnection(Subject delegationSubject)
                                               throws IOException
从接口 JMXConnector 复制的描述

返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。对于给定的 JMXConnector 和 Subject，对此方法两次成功的调用通常将返回相同的 MBeanServerConnection 对象，尽管不需要这样做。

对于返回的 MBeanServerConnection 中的每个方法，调用此方法导致调用代表给定委托主题，而不是经验证主题的远程 MBean 服务器上的对应方法。MBean 服务器方法返回的值就是返回给客户端的值。如果 MBean 服务器方法生成了 Exception，则客户端上也会出现相同的 Exception。如果 MBean 服务器方法（或尝试对它的调用）生成了 Error，则该 Error 将包装在 JMXServerErrorException 中，从客户端能够看到该错误。

指定者：
接口 JMXConnector 中的 getMBeanServerConnection
参数：
delegationSubject - 代表将执行何种请求的 Subject。可以为 null，这种情况下执行请求表示经验证的 Subject（如果有）。
返回：
一个通过将其方法转发到代表给定委托主题的远程 MBean 服务器而实现 MBeanServerConnection 接口的对象。
抛出：
IOException - 如果无法创建有效的 MBeanServerConnection，例如，由于尚未建立到远程 MBean 服务器的连接（用 connect 方法），或者连接已关闭，或者连接已断开。

addConnectionNotificationListener

public void addConnectionNotificationListener(NotificationListener listener,
                                              NotificationFilter filter,
                                              Object handback)
从接口 JMXConnector 复制的描述

添加一个接收连接状态改变的侦听器。该侦听器将接收 JMXConnectionNotification 类型的通知。实现也可发送任何其他类型的通知。

使用此方法可添加任意个数的侦听器。相同的侦听器可使用相同或不同的 filter 和 handback 值多次添加。不对重复的条目进行任何特殊处理。例如，假设侦听器两次注册均为不带 filter，则将为每个通知调用两次其 handleNotification 方法。

指定者：
接口 JMXConnector 中的 addConnectionNotificationListener
参数：
listener - 用于接收连接状态通知的侦听器。
filter - 用于选择要发送给侦听器的通知的过滤器，如果将发送所有的通知，则为 null。
handback - 将随每个通知提供给侦听器的对象。可以为 null。
另请参见：
JMXConnector.removeConnectionNotificationListener(javax.management.NotificationListener), NotificationBroadcaster.addNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeConnectionNotificationListener

public void removeConnectionNotificationListener(NotificationListener listener)
                                          throws ListenerNotFoundException
从接口 JMXConnector 复制的描述

将一个用于接收状态更改通知的侦听器从列表中移除。此侦听器必须在以前已经添加。如果有多个匹配的侦听器，则移除所有匹配的侦听器。

指定者：
接口 JMXConnector 中的 removeConnectionNotificationListener
参数：
listener - 用于接收连接状态通知的侦听器。
抛出：
ListenerNotFoundException - 如果侦听器未用此 JMXConnector 注册。
另请参见：
JMXConnector.removeConnectionNotificationListener(NotificationListener, NotificationFilter, Object),
JMXConnector.addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object),
NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

removeConnectionNotificationListener

public void removeConnectionNotificationListener(NotificationListener listener,
                                                 NotificationFilter filter,
                                                 Object handback)
                                          throws ListenerNotFoundException
从接口 JMXConnector 复制的描述

将一个用于接收状态更改通知的侦听器从列表中移除。该侦听器必须在以前已经用相同的三个参数添加。如果有多个匹配的侦听器，则只移除一个匹配的侦听器。

指定者：
接口 JMXConnector 中的 removeConnectionNotificationListener
参数：
listener - 用于接收连接状态通知的侦听器。
filter - 用于选择发送给侦听器通知的过滤器。可以为 null。
handback - 将随每个通知提供给侦听器的对象。可以为 null。
抛出：
ListenerNotFoundException - 如果侦听器未用此 JMXConnector 注册，或者未用给定的 filter 和 handback 注册。
另请参见：
JMXConnector.removeConnectionNotificationListener(NotificationListener),
JMXConnector.addConnectionNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object),
NotificationEmitter.removeNotificationListener(javax.management.NotificationListener, javax.management.NotificationFilter, java.lang.Object)

close

public void close()
           throws IOException
从接口 JMXConnector 复制的描述

关闭客户端到其服务器的连接。任何正在进行中的或新的使用由 JMXConnector.getMBeanServerConnection() 返回的 MBeanServerConnection 的请求将获得一个 IOException。

如果已在该对象上成功调用了 close，则再次调用将没有任何作用。如果从未调用过 close，或者调用过但生成了异常，则将尝试关闭该连接。此尝试可能成功，此时 close 将正常返回，也可能生成一个异常。

关闭连接是一个潜在的慢操作。例如，假设服务器已崩溃，则关闭操作可能不得不等待网络协议超时。不希望关闭操作出现阻塞的调用者应在单独的线程中处理关闭。

指定者：
接口 Closeable 中的 close
指定者：
接口 JMXConnector 中的 close
抛出：
IOException - 如果无法完全关闭连接。如果抛出此异常，连接的服务器端是否已完全关闭为未知。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIConnectorServer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIConnectorServer

java.lang.Object
    继承者  javax.management.NotificationBroadcasterSupport
        继承者  javax.management.remote.JMXConnectorServer
            继承者  javax.management.remote.rmi.RMIConnectorServer
所有已实现的接口：
MBeanRegistration, NotificationBroadcaster, NotificationEmitter, JMXAddressable, JMXConnectorServerMBean
public class RMIConnectorServer
extends JMXConnectorServer

JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。通常情况下，使用 JMXConnectorServerFactory 建立这样的连接器服务器。但是，专门的应用程序可直接使用此类，例如使用 RMIServerImpl 对象。

从以下版本开始：
1.5

字段摘要
static String | JNDI_REBIND_ATTRIBUTE 属性名称，它指定代表 RMI 连接器服务器的 RMIServer stub 是否应重写位于同一地址的现有 stub。
static String | RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE 属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIClientSocketFactory。
static String | RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE 属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIServerSocketFactory。
从类 javax.management.remote.JMXConnectorServer 继承的字段
AUTHENTICATOR
构造方法摘要
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
方法摘要
protected void | connectionClosed(String connectionId, String message, Object userData) 正常关闭客户端连接时由子类调用。
protected void | connectionFailed(String connectionId, String message, Object userData) 客户端连接失败时由子类调用。
protected void | connectionOpened(String connectionId, String message, Object userData) 打开新的客户端连接时由子类调用。
JMXServiceURL | getAddress() 该连接器服务器的地址。
Map<String,?> | getAttributes() 此连接器服务器的属性。
boolean | isActive() 确定连接器服务器是否活动。
void | setMBeanServerForwarder(MBeanServerForwarder mbsf) 添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。
void | start() 激活连接器服务器，即启动对客户端连接的侦听。
void | stop() 取消激活连接器服务器，即停止对客户端连接的侦听。
JMXConnector | toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
从类 javax.management.remote.JMXConnectorServer 继承的方法
getConnectionIds, getMBeanServer, getNotificationInfo, postDeregister, postRegister, preDeregister, preRegister
从类 javax.management.NotificationBroadcasterSupport 继承的方法
addNotificationListener, handleNotification, removeNotificationListener, removeNotificationListener, sendNotification
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

JNDI_REBIND_ATTRIBUTE

public static final String JNDI_REBIND_ATTRIBUTE

属性名称，它指定代表 RMI 连接器服务器的 RMIServer stub 是否应重写位于同一地址的现有 stub。与此属性关联的值（如果有）应为与 "true" 或 "false" 相等（忽略大小写）的字符串。默认值为 false。

另请参见：
常量字段值

RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE

public static final String RMI_CLIENT_SOCKET_FACTORY_ATTRIBUTE

属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIClientSocketFactory。与此属性关联的值的类型必须为 RMIClientSocketFactory，并且只能在创建连接器服务器时提供的 Map 参数中指定。

另请参见：
常量字段值

RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE

public static final String RMI_SERVER_SOCKET_FACTORY_ATTRIBUTE

属性名称，它指定了与此连接器一起创建的 RMI 对象的 RMIServerSocketFactory。与此属性关联的值的类型必须为 RMIServerSocketFactory，并且只能在创建连接器服务器时提供的 Map 参数中指定。

另请参见：
常量字段值
构造方法详细信息

RMIConnectorServer

public RMIConnectorServer(JMXServiceURL url,
                          Map<String,?> environment)
                   throws IOException

建立 RMIConnectorServer。此方法与调用 RMIConnectorServer(directoryURL,environment,null,null) 具有相同的效果。

参数：
url - 一个定义如何创建连接器服务器的 URL。不能为 null。
environment - 控制着 RMI 对象的创建和存储的属性。可以为 null，它等效于一个空映射。
抛出：
IllegalArgumentException - 如果 url 为 null。
MalformedURLException - 如果 url 不符合 RMI 连接器的语法，或者其协议不能由此实现识别。使用此构造方法时，只有 "rmi" 和 "iiop" 为有效的。
IOException - 如果出于某种原因无法创建连接器服务器，或者其 start 方法不可避免地失败。

RMIConnectorServer

public RMIConnectorServer(JMXServiceURL url,
                          Map<String,?> environment,
                          MBeanServer mbeanServer)
                   throws IOException

为给定的 MBean 服务器建立一个 RMIConnectorServer。此方法与调用 RMIConnectorServer(directoryURL,environment,null,mbeanServer) 具有相同的效果。

参数：
url - 一个定义如何创建连接器服务器的 URL。不能为 null。
environment - 控制着 RMI 对象的创建和存储的属性。可以为 null，它等效于一个空映射。
mbeanServer - 新的连接器服务器将与其连接的 MBean 服务器，或者如果它将通过注册为 MBean 服务器中的一个 MBean 进行连接，则为 null。
抛出：
IllegalArgumentException - 如果 url 为 null。
MalformedURLException - 如果 url 不符合 RMI 连接器的语法，或者其协议不能由此实现识别。使用此构造方法时，只有 "rmi" 和 "iiop" 为有效的。
IOException - 如果出于某种原因无法创建连接器服务器，或者其 start 方法不可避免地失败。

RMIConnectorServer

public RMIConnectorServer(JMXServiceURL url,
                          Map<String,?> environment,
                          RMIServerImpl rmiServerImpl,
                          MBeanServer mbeanServer)
                   throws IOException

为给定的 MBean 服务器建立一个 RMIConnectorServer。

参数：
url - 一个定义如何创建连接器服务器的 URL。不能为 null。
environment - 控制着 RMI 对象的创建和存储的属性。可以为 null，它等效于一个空映射。
rmiServerImpl - RMIServer 接口的一个实现，与 url 中指定的协议类型一致。如果此参数为非 null，则 url 指定的协议类型没有约束，假定其为有效。否则，将只识别 "rmi" 和 "iiop"。
mbeanServer - 新的连接器服务器将与其连接的 MBean 服务器，或者如果它将通过注册为 MBean 服务器中的一个 MBean 进行连接，则为 null。
抛出：
IllegalArgumentException - 如果 url 为 null。
MalformedURLException - 如果 url 不符合 RMI 连接器的语法，或者其协议不能由此实现识别。在 rmiServerImpl 为 null 时，只能识别 "rmi" 和 "iiop"。
IOException - 如果出于某种原因无法创建连接器服务器，或者其 start 方法不可避免地失败。
另请参见：
start()
方法详细信息

toJMXConnector

public JMXConnector toJMXConnector(Map<String,?> env)
                            throws IOException

返回此连接器服务器的客户端 stub。客户端 stub 为一个可序列化的对象，其 connect 方法可用于建立一个到此连接器服务器的新连接。

指定者：
接口 JMXConnectorServerMBean 中的 toJMXConnector
覆盖：
类 JMXConnectorServer 中的 toJMXConnector
参数：
env - 客户端连接参数，与提供给 JMXConnector.connect(Map) 的参数具有相同的类型。可以为 null，它等效于一个空映射。
返回：
可用于建立到此连接器服务器的新连接的客户端 stub。
抛出：
UnsupportedOperationException - 如果此连接器服务器不支持生成客户端 stub。
IllegalStateException - 如果未启动 JMXConnectorServer（请参阅 isActive()）。
IOException - 如果存在通信问题而导致无法创建 stub。

start

public void start()
           throws IOException

激活连接器服务器，即启动对客户端连接的侦听。在连接器服务器已激活时，调用此方法没有任何作用。在连接器服务器已停止时，调用此方法将生成 IOException。

此方法第一次调用时的行为取决于构造时提供的如下所示的参数。

首先，需要一个 RMIServerImpl 的子类的对象，以便将连接器服务器从 RMI 导出：

  • 如果原先为构造方法提供了一个 RMIServerImpl，则使用该值。
  • 否则，如果为构造方法提供的 JMXServiceURL 的协议部分为 iiop，则创建一个 RMIIIOPServerImpl 类型的对象。
  • 否则，如果 JMXServiceURL 为 null，或者其协议部分为 rmi，则创建一个类型为 RMIJRMPServerImpl 的对象。
  • 否则，此实现可能创建一个特定于实现的 RMIServerImpl，或者抛出 MalformedURLException。

如果给定的地址包含一个 JNDI 目录 URL（如在 javax.management.remote.rmi 的包文档中的指定），则该 RMIConnectorServer 通过将 RMIServerImpl 绑定到给定地址进行引导。

如果 JMXServiceURL 的 URL 路径部分为空或一个单独的斜线 (/)，则 RMI 对象将不会绑定到一个目录。相反，RMIConnectorServer 地址（由 getAddress() 返回）的 URL 路径中将包含一个对它的引用的编码。javax.management.remote.rmi 的包文档中有对 rmi 和 iiop 的编码的描述。

当 URL 路径既不为空又不是一个 JNDI 目录 URL，或者当协议既不是 rmi 又不是 iiop 时的行为由实现定义，并且在创建或启动连接器服务器时可能包含抛出 MalformedURLException 的行为。

抛出：
IllegalStateException - 如果此连接器服务器尚未连接到 MBean 服务器。
IOException - 如果连接器服务器无法启动。

stop

public void stop()
          throws IOException

取消激活连接器服务器，即停止对客户端连接的侦听。调用此方法还将关闭所有由此服务器建立的客户端连接。返回此方法后，无论正常返回还是抛出异常，连接器服务器都不再创建任何新的客户端连接。

连接器服务器一旦停止就无法再启动。

在连接器服务器已停止时，调用此方法没有任何效果。在连接器服务器尚未启动时调用此方法将永久禁用连接器服务器对象。

如果关闭客户端连接导致异常，则该异常不会从此方法抛出。而会从 MBean 发出一个 JMXConnectionNotification，同时显示无法关闭的连接的连接 ID。

关闭连接器服务器是一个潜在的慢操作。例如，如果具有打开连接的客户端发生崩溃，则关闭操作不得不等待网络协议超时。不希望关闭操作出现阻塞的调用者应在单独的线程中处理关闭。

此方法在连接器服务器的 RMIServerImpl 对象上调用 close 方法。

如果 RMIServerImpl 由 start 方法绑定到 JNDI 目录，则该方法可解除到目录的绑定。

抛出：
IOException - 如果无法完全关闭服务器，或者如果无法从目录解除 RMIServerImpl 的绑定。抛出此异常时，服务器已经尝试适当地关闭所有的客户端连接、调用 RMIServerImpl.close() 并解除 RMIServerImpl 到其目录的绑定。除了那些服务器尝试将它们关闭时生成异常的连接，所有的客户端连接都被关闭。

isActive

public boolean isActive()
从接口 JMXConnectorServerMBean 复制的描述

确定连接器服务器是否活动。当连接器服务器的 start 方法成功返回时，此连接器服务器即进入活动状态，并一直保持活动状态直到调用其 stop 方法或连接器服务器失败。

返回：
如果该连接器服务器为活动的，则返回 true。

getAddress

public JMXServiceURL getAddress()
从接口 JMXConnectorServerMBean 复制的描述

该连接器服务器的地址。

返回：
该连接器服务器的地址，或者如果没有任何地址，则返回 null。

getAttributes

public Map<String,?> getAttributes()
从接口 JMXConnectorServerMBean 复制的描述

此连接器服务器的属性。

返回：
包含该连接器服务器的属性的一个只读映射。该映射中忽略了其值不可序列化的属性。如果没有可序列化的属性，则返回的映射为空。

setMBeanServerForwarder

public void setMBeanServerForwarder(MBeanServerForwarder mbsf)
从接口 JMXConnectorServerMBean 复制的描述

添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。此对象将作为任何由此连接器服务器创建的新连接的 MBeanServer 提供。现有连接不受影响。

如果此连接器服务器已与一个 MBeanServer 对象关联，则将该对象提供给 mbsf.setMBeanServer。如果这样做生成异常，则该方法抛出相同的异常，没有任何其他作用。

如果此连接器尚未与一个 MBeanServer 对象关联，或者如果刚才提到的 mbsf.setMBeanServer 调用成功，则 mbsf 成为该连接器服务器的 MBeanServer。

指定者：
接口 JMXConnectorServerMBean 中的 setMBeanServerForwarder
覆盖：
类 JMXConnectorServer 中的 setMBeanServerForwarder
参数：
mbsf - 新的 MBeanServerForwarder。

connectionOpened

protected void connectionOpened(String connectionId,
                                String message,
                                Object userData)
从类 JMXConnectorServer 复制的描述

打开新的客户端连接时由子类调用。将由 JMXConnectorServer.getConnectionIds() 返回的 connectionId 添加到列表中，然后发出一个类型为 JMXConnectionNotification.OPENED 的 JMXConnectionNotification。

覆盖：
类 JMXConnectorServer 中的 connectionOpened
参数：
connectionId - 新连接的 ID。它必须与任何由此连接器服务器先前打开的连接的 ID 不一样。
message - 发出的 JMXConnectionNotification 的消息。可以为 null。请参阅 Notification.getMessage()。
userData - 发出的 JMXConnectionNotification 的 userData。可以为 null。请参阅 Notification.getUserData()。

connectionClosed

protected void connectionClosed(String connectionId,
                                String message,
                                Object userData)
从类 JMXConnectorServer 复制的描述

正常关闭客户端连接时由子类调用。从列表中移除由 JMXConnectorServer.getConnectionIds() 返回的 connectionId，然后发出一个类型为 JMXConnectionNotification.CLOSED 的 JMXConnectionNotification。

覆盖：
类 JMXConnectorServer 中的 connectionClosed
参数：
connectionId - 已关闭连接的 ID。
message - 发出的 JMXConnectionNotification 的消息。可以为 null。请参阅 Notification.getMessage()。
userData - 发出的 JMXConnectionNotification 的 userData。可以为 null。请参阅 Notification.getUserData()。

connectionFailed

protected void connectionFailed(String connectionId,
                                String message,
                                Object userData)
从类 JMXConnectorServer 复制的描述

客户端连接失败时由子类调用。从列表中移除由 JMXConnectorServer.getConnectionIds() 返回的 connectionId，然后发出一个类型为 JMXConnectionNotification.FAILED 的 JMXConnectionNotification。

覆盖：
类 JMXConnectorServer 中的 connectionFailed
参数：
connectionId - 失败连接的 ID。
message - 发出的 JMXConnectionNotification 的消息。可以为 null。请参阅 Notification.getMessage()。
userData - 发出的 JMXConnectionNotification 的 userData。可以为 null。请参阅 Notification.getUserData()。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIIIOPServerImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIIIOPServerImpl

java.lang.Object
    继承者  javax.management.remote.rmi.RMIServerImpl
        继承者  javax.management.remote.rmi.RMIIIOPServerImpl
所有已实现的接口：
Closeable, Remote, RMIServer
public class RMIIIOPServerImpl
extends RMIServerImpl

一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。用户代码不经常直接引用此类。

从以下版本开始：
1.5
另请参见：
RMIServerImpl

构造方法摘要
RMIIIOPServerImpl(Map<String,?> env)
创建新的 RMIServerImpl。
方法摘要
protected  void closeClient(RMIConnection client)
关闭由 makeClient 建立的客户端连接。
protected  void closeServer()
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
protected  void export()
导出此 RMI 对象。
protected  String getProtocol()
返回该对象的协议字符串。
protected  RMIConnection makeClient(String connectionId, Subject subject)
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
 Remote toStub()
返回一个 IIOP stub。
从类 javax.management.remote.rmi.RMIServerImpl 继承的方法
clientClosed, close, getDefaultClassLoader, getMBeanServer, getVersion, newClient, setDefaultClassLoader, setMBeanServer
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RMIIIOPServerImpl

public RMIIIOPServerImpl(Map<String,?> env)
                  throws IOException

创建新的 RMIServerImpl。

参数：
env - 包含新的 RMIServerImpl 属性的环境。可以为 null，它等效于一个空映射。
抛出：
IOException - 如果无法创建 RMI 对象。
方法详细信息

export

protected void export()
               throws IOException
从类 RMIServerImpl 复制的描述

导出此 RMI 对象。

指定者：
类 RMIServerImpl 中的 export
抛出：
IOException - 如果无法导出此 RMI 对象。

getProtocol

protected String getProtocol()
从类 RMIServerImpl 复制的描述

返回该对象的协议字符串。对于 RMI/JRMP，该字符串为 rmi；对于 RMI/IIOP，该字符串为 iiop。

指定者：
类 RMIServerImpl 中的 getProtocol
返回：
此对象的协议字符串。

toStub

public Remote toStub()
              throws IOException

返回一个 IIOP stub。

此 stub 可能还无法连接到 ORB。只有当 stub 连接到 ORB 时，它才变得可序列化。

指定者：
类 RMIServerImpl 中的 toStub
返回：
一个 IIOP stub。
抛出：
IOException - 如果无法创建 stub，例如 RMIIIOPServerImpl 尚未导出。

makeClient

protected RMIConnection makeClient(String connectionId,
                                   Subject subject)
                            throws IOException

创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。

指定者：
类 RMIServerImpl 中的 makeClient
参数：
connectionId - 新连接的 ID。由此连接器服务器打开的每个连接将具有不同的 ID。如果此参数为 null，则行为不明确。
subject - 经验证的主题。可以为 null。
返回：
新创建的 RMIConnection。
抛出：
IOException - 如果无法创建或导出新的客户端对象。

closeClient

protected void closeClient(RMIConnection client)
                    throws IOException
从类 RMIServerImpl 复制的描述

关闭由 makeClient 建立的客户端连接。

指定者：
类 RMIServerImpl 中的 closeClient
参数：
client - 由 makeClient 以前返回的一个连接，以前尚未在其上调用过 closeClient 方法。如果违反这些条件，包括 client 为 null 的情况，则行为不明确。
抛出：
IOException - 如果无法关闭客户端连接。

closeServer

protected void closeServer()
                    throws IOException

由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。从此方法返回后，连接器服务器不接受任何新的连接。

指定者：
类 RMIServerImpl 中的 closeServer
抛出：
IOException - 如果关闭连接器服务器的尝试失败。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIJRMPServerImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIJRMPServerImpl

java.lang.Object
    继承者  javax.management.remote.rmi.RMIServerImpl
        继承者  javax.management.remote.rmi.RMIJRMPServerImpl
所有已实现的接口：
Closeable, Remote, RMIServer
public class RMIJRMPServerImpl
extends RMIServerImpl

一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。用户代码不经常直接引用此类。

从以下版本开始：
1.5
另请参见：
RMIServerImpl

构造方法摘要
RMIJRMPServerImpl(int port, RMIClientSocketFactory csf, RMIServerSocketFactory ssf, Map<String,?> env)
创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。
方法摘要
protected  void closeClient(RMIConnection client)
关闭由 makeClient 建立的客户端连接。
protected  void closeServer()
由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。
protected  void export()
导出此 RMI 对象。
protected  String getProtocol()
返回该对象的协议字符串。
protected  RMIConnection makeClient(String connectionId, Subject subject)
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
 Remote toStub()
返回此 RMIServer 对象的可序列化的 stub。
从类 javax.management.remote.rmi.RMIServerImpl 继承的方法
clientClosed, close, getDefaultClassLoader, getMBeanServer, getVersion, newClient, setDefaultClassLoader, setMBeanServer
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RMIJRMPServerImpl

public RMIJRMPServerImpl(int port,
                         RMIClientSocketFactory csf,
                         RMIServerSocketFactory ssf,
                         Map<String,?> env)
                  throws IOException

创建一个新的 RMIServer 对象，它将使用给定的套接字工厂从给定端口导出。

参数：
port - 此对象及此对象创建的 RMIConnectionImpl 对象将从其导出的端口。可以为零，它指示任何可用的端口。
csf - 创建的 RMI 对象的客户端套接字工厂。可以为 null。
ssf - 创建的 RMI 对象的服务器套接字工厂。可以为 null。
env - 环境映射。可以为 null。
抛出：
IOException - 如果无法创建 RMIServer 对象。
IllegalArgumentException - 如果 port 为负。
方法详细信息

export

protected void export()
               throws IOException
从类 RMIServerImpl 复制的描述

导出此 RMI 对象。

指定者：
类 RMIServerImpl 中的 export
抛出：
IOException - 如果无法导出此 RMI 对象。

getProtocol

protected String getProtocol()
从类 RMIServerImpl 复制的描述

返回该对象的协议字符串。对于 RMI/JRMP，该字符串为 rmi；对于 RMI/IIOP，该字符串为 iiop。

指定者：
类 RMIServerImpl 中的 getProtocol
返回：
此对象的协议字符串。

toStub

public Remote toStub()
              throws IOException

返回此 RMIServer 对象的可序列化的 stub。

指定者：
类 RMIServerImpl 中的 toStub
返回：
可序列化的 stub。
抛出：
IOException - 如果无法获得 stub，例如 RMIJRMPServerImpl 尚未导出。

makeClient

protected RMIConnection makeClient(String connectionId,
                                   Subject subject)
                            throws IOException

创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。新的 RMIConnection 对象的端口和套接字工厂就是为 RMIJRMPServerImpl 构造方法提供的对应参数。

指定者：
类 RMIServerImpl 中的 makeClient
参数：
connectionId - 新连接的 ID。由此连接器服务器打开的每个连接将具有不同的 ID。如果此参数为 null，则行为不明确。
subject - 经验证的主题。可以为 null。
返回：
新创建的 RMIConnection。
抛出：
IOException - 如果无法创建或导出新的 RMIConnection 对象。

closeClient

protected void closeClient(RMIConnection client)
                    throws IOException
从类 RMIServerImpl 复制的描述

关闭由 makeClient 建立的客户端连接。

指定者：
类 RMIServerImpl 中的 closeClient
参数：
client - 由 makeClient 以前返回的一个连接，以前尚未在其上调用过 closeClient 方法。如果违反这些条件，包括 client 为 null 的情况，则行为不明确。
抛出：
IOException - 如果无法关闭客户端连接。

closeServer

protected void closeServer()
                    throws IOException

由 RMIServerImpl.close() 调用以通过取消导出此对象关闭连接器服务器。从此方法返回后，连接器服务器不接受任何新的连接。

指定者：
类 RMIServerImpl 中的 closeServer
抛出：
IOException - 如果关闭连接器服务器的尝试失败。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIServer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
接口 RMIServer

所有超级接口：
Remote
所有已知实现类：
RMIIIOPServerImpl, RMIJRMPServerImpl, RMIServerImpl, RMIServerImpl_Stub
public interface RMIServer
extends Remote

用于建立到 RMI 连接器的连接的 RMI 对象。每个 RMI 连接器都有一个实现此接口 Remote 对象。

用户代码不经常引用此接口。它作为公用 API 的一部分指定，便于该 API 的不同实现之间实现互操作。

从以下版本开始：
1.5

方法摘要
String | getVersion() 此连接器服务器能识别的 RMI 连接协议版本。
RMIConnection | newClient(Object credentials) 建立一个使用该 RMI 连接器的新连接。

方法详细信息

getVersion

String getVersion()
                  throws RemoteException

此连接器服务器能识别的 RMI 连接协议版本。这是一个具有以下格式的字符串：

 protocol-version implementation-name

protocol-version 是由句点 (.) 分隔的两个或多个非负整数组成的序列。这里，此文档描述的这一版本的实现必须使用字符串 1.0。

协议版本后面必须有一个空格，然后是实现名称。实现名称的格式未指定。建议在其中包含一个实现版本号。例如，出于安全原因，实现可使用空字符串作为其实现名称。

返回：
具有这里描述格式的字符串。
抛出：
RemoteException - 如果在远程方法调用过程中出现通信异常。

newClient

RMIConnection newClient(Object credentials)
                        throws IOException

建立一个使用该 RMI 连接器的新连接。每个远程客户端都调用此方法以获得代表其连接的新的 RMI 对象。

参数：
credentials - 此对象指定用户定义的凭据，其传入此服务器以便在创建 RMIConnection 之前验证用户。可以为 null。
返回：
新创建的连接对象。
抛出：
IOException - 如果无法创建或导出新的客户端对象，或者如果在远程方法调用过程中出现通信异常。
SecurityException - 如果给定的凭据不允许服务器成功地验证调用者。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIServerImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIServerImpl

java.lang.Object
    继承者  javax.management.remote.rmi.RMIServerImpl
所有已实现的接口：
Closeable, Remote, RMIServer
直接已知子类：
RMIIIOPServerImpl, RMIJRMPServerImpl
public abstract class RMIServerImpl
extends Object
implements Closeable, RMIServer

表示连接器服务器的 RMI 对象。远程客户端可使用 newClient(Object) 方法进行连接。此方法返回表示此连接的 RMI 对象。

用户代码不经常直接引用此类。RMI 连接服务器通常使用 RMIConnectorServer 类创建。远程客户端通常使用 JMXConnectorFactory 或通过实例化 RMIConnector 创建连接。

这是一个抽象类。由具体的子类定义客户端连接对象的细节，例如使用的是 JRMP 还是 IIOP。

从以下版本开始：
1.5

构造方法摘要
RMIServerImpl(Map<String,?> env)
构造一个新的 RMIServerImpl。
方法摘要
protected  void clientClosed(RMIConnection client)
关闭由 makeClient 创建的客户端连接时调用的方法。
 void close()
关闭此连接服务器。
protected abstract  void closeClient(RMIConnection client)
关闭由 makeClient 建立的客户端连接。
protected abstract  void closeServer()
由 close() 调用以关闭连接器服务器。
protected abstract  void export()
导出此 RMI 对象。
 ClassLoader getDefaultClassLoader()
获得此连接器服务器使用的默认 ClassLoader。
 MBeanServer getMBeanServer()
此连接器服务器所连接的 MBeanServer。
protected abstract  String getProtocol()
返回该对象的协议字符串。
 String getVersion()
此连接器服务器能识别的 RMI 连接协议版本。
protected abstract  RMIConnection makeClient(String connectionId, Subject subject)
创建一个新的客户端连接。
 RMIConnection newClient(Object credentials)
创建一个新的客户端连接。
 void setDefaultClassLoader(ClassLoader cl)
设置此连接器服务器的默认 ClassLoader。
 void setMBeanServer(MBeanServer mbs)
设置此连接器服务器所连接的 MBeanServer。
abstract  Remote toStub()
返回此服务器对象的可远程化的 stub。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RMIServerImpl

public RMIServerImpl(Map<String,?> env)

构造一个新的 RMIServerImpl。

参数：
env - 包含新的 RMIServerImpl 属性的环境。可以为 null，它等效于一个空映射。
方法详细信息

export

protected abstract void export()
                        throws IOException

导出此 RMI 对象。

抛出：
IOException - 如果无法导出此 RMI 对象。

toStub

public abstract Remote toStub()
                       throws IOException
返回此服务器对象的可远程化的 stub。

返回：
可远程化的 stub。
抛出：
IOException - 如果无法获得 stub，例如 RMIServerImpl 尚未导出。

setDefaultClassLoader

public void setDefaultClassLoader(ClassLoader cl)

设置此连接器服务器的默认 ClassLoader。新客户端连接将使用此 classloader。现有客户端连接不受影响。

参数：
cl - 此连接器服务器将使用的新 ClassLoader。
另请参见：
getDefaultClassLoader()

getDefaultClassLoader

public ClassLoader getDefaultClassLoader()

获得此连接器服务器使用的默认 ClassLoader。

返回：
此连接器服务器使用的默认 ClassLoader。

另请参见：
setDefaultClassLoader(java.lang.ClassLoader)

setMBeanServer

public void setMBeanServer(MBeanServer mbs)

设置此连接器服务器所连接的 MBeanServer。新的客户端连接将与此 MBeanServer 交互。现有客户端连接不受影响。

参数：
mbs - 新的 MBeanServer。可以为 null，但将在尽可能长的时间内重用新的客户端连接。
另请参见：
getMBeanServer()

getMBeanServer

public MBeanServer getMBeanServer()

此连接器服务器所连接的 MBeanServer。这是传递给此对象上的 setMBeanServer(javax.management.MBeanServer) 的最后一个值，或者如果从未调用过该方法，则为 null。

返回：
此连接器所连接的 MBeanServer。
另请参见：
setMBeanServer(javax.management.MBeanServer)

getVersion

public String getVersion()
从接口 RMIServer 复制的描述

此连接器服务器能识别的 RMI 连接协议版本。这是一个具有以下格式的字符串：

 protocol-version implementation-name

protocol-version 是由句点 (.) 分隔的两个或多个非负整数组成的序列。这里，此文档描述的这一版本的实现必须使用字符串 1.0。

协议版本后面必须有一个空格，然后是实现名称。实现名称的格式未指定。建议在其中包含一个实现版本号。例如，出于安全原因，实现可使用空字符串作为其实现名称。

指定者：
接口 RMIServer 中的 getVersion
返回：
具有这里描述格式的字符串。

newClient

public RMIConnection newClient(Object credentials)
                        throws IOException

创建一个新的客户端连接。此方法调用 makeClient 并将返回的客户端连接对象添加到一个内部列表中。当此 RMIServerImpl 使用其 close() 方法被关闭时，将调用列表中剩余的每个对象的 close() 方法。

即使事实上一个客户端连接对象位于内部列表中，也不影响对其进行垃圾回收。

指定者：
接口 RMIServer 中的 newClient
参数：
credentials - 此对象指定用户定义的凭据，其传入此服务器以便在创建 RMIConnection 之前验证调用者。可以为 null。
返回：
新创建的 RMIConnection。这通常是由 makeClient 创建的对象，尽管实现可能选择将该对象包装在另一个实现 RMIConnection 的对象中。
抛出：
IOException - 如果无法创建或导出新的客户端对象。
SecurityException - 如果给定的凭据不允许服务器成功地验证用户。
IllegalStateException - 如果 getMBeanServer() 为 null。

makeClient

protected abstract RMIConnection makeClient(String connectionId,
                                            Subject subject)
                                     throws IOException

创建一个新的客户端连接。此方法由公共方法 newClient(Object) 调用。

参数：
connectionId - 新连接的 ID。由此连接器服务器打开的每个连接将具有不同的 ID。如果此参数为 null，则行为不明确。
subject - 经验证的 subject。可以为 null。
返回：
新创建的 RMIConnection。
抛出：
IOException - 如果无法创建或导出新的客户端对象。

closeClient

protected abstract void closeClient(RMIConnection client)
                             throws IOException

关闭由 makeClient 建立的客户端连接。

参数：
client - 由 makeClient 以前返回的一个连接，以前尚未在其上调用过 closeClient 方法。如果违反这些条件，包括 client 为 null 的情况，则行为不明确。
抛出：
IOException - 如果无法关闭客户端连接。

getProtocol

protected abstract String getProtocol()

返回该对象的协议字符串。对于 RMI/JRMP，该字符串为 rmi；对于 RMI/IIOP，该字符串为 iiop。

返回：
此对象的协议字符串。

clientClosed

protected void clientClosed(RMIConnection client)
                     throws IOException

关闭由 makeClient 创建的客户端连接时调用的方法。调用结果对象的 close 方法时，定义 makeClient 的子类必须安排此要调用的方法。这方便从 RMIServerImpl 的连接列表中将其移除。client 不在该列表中并不表示错误。

从连接列表中移除 client 后，此方法调用 closeClient(client)。

参数：
client - 已关闭的客户端连接。
抛出：
IOException - 如果 closeClient(javax.management.remote.rmi.RMIConnection) 抛出此异常。
NullPointerException - 如果 client 为 null。

close

public void close()
           throws IOException

关闭此连接服务器。此方法首先调用 closeServer() 方法以便不接受任何新的客户端连接。然后对由 makeClient 返回的其余每个 RMIConnection 对象调用其 close 方法。

多次调用此方法时，行为不明确。

如果 closeServer() 抛出 IOException，会关闭每个单独的连接，然后从此方法抛出 IOException。

如果 closeServer() 正常返回，但有一个或多个单独连接抛出 IOException，则在关闭所有的连接后，从此方法抛出其中的一个 IOException。如果有多个连接抛出 IOException，则无法确定哪一个异常是从此方法抛出的。

指定者：
接口 Closeable 中的 close
抛出：
IOException - 如果 closeServer() 或 RMIConnection.close() 之一调用抛出了 IOException。

closeServer

protected abstract void closeServer()
                             throws IOException

由 close() 调用以关闭连接器服务器。从此方法返回后，连接器服务器不接受任何新的连接。

抛出：
IOException - 如果关闭连接器服务器的尝试失败。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RMIServerImpl_Stub (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.management.remote.rmi
类 RMIServerImpl_Stub

java.lang.Object
    继承者  java.rmi.server.RemoteObject
        继承者  java.rmi.server.RemoteStub
            继承者  javax.management.remote.rmi.RMIServerImpl_Stub
所有已实现的接口：
Serializable, Remote, RMIServer
public final class RMIServerImpl_Stub
extends RemoteStub
implements RMIServer

另请参见：
序列化表格

字段摘要
从类 java.rmi.server.RemoteObject 继承的字段
ref
构造方法摘要
RMIServerImpl_Stub(RemoteRef ref)
方法摘要
String | getVersion() 此连接器服务器能识别的 RMI 连接协议版本。
RMIConnection | newClient(Object $param_Object_1) 建立一个使用该 RMI 连接器的新连接。
从类 java.rmi.server.RemoteStub 继承的方法
setRef
从类 java.rmi.server.RemoteObject 继承的方法
equals, getRef, hashCode, toString, toStub
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

RMIServerImpl_Stub

public RMIServerImpl_Stub(RemoteRef ref)
方法详细信息

getVersion

public String getVersion()
                  throws RemoteException
从接口 RMIServer 复制的描述

此连接器服务器能识别的 RMI 连接协议版本。这是一个具有以下格式的字符串：

 protocol-version implementation-name

protocol-version 是由句点 (.) 分隔的两个或多个非负整数组成的序列。这里，此文档描述的这一版本的实现必须使用字符串 1.0。

协议版本后面必须有一个空格，然后是实现名称。实现名称的格式未指定。建议在其中包含一个实现版本号。例如，出于安全原因，实现可使用空字符串作为其实现名称。

指定者：
接口 RMIServer 中的 getVersion
返回：
具有这里描述格式的字符串。
抛出：
RemoteException - 如果在远程方法调用过程中出现通信异常。

newClient

public RMIConnection newClient(Object $param_Object_1)
                        throws IOException
从接口 RMIServer 复制的描述

建立一个使用该 RMI 连接器的新连接。每个远程客户端都调用此方法以获得代表其连接的新的 RMI 对象。

指定者：
接口 RMIServer 中的 newClient
参数：
$param_Object_1 - 此对象指定用户定义的凭据，其传入此服务器以便在创建 RMIConnection 之前验证用户。可以为 null。
返回：
新创建的连接对象。
抛出：
IOException - 如果无法创建或导出新的客户端对象，或者如果在远程方法调用过程中出现通信异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.management.remote.rmi (Java 2 Platform SE 6)

 javax.management.remote.rmi
接口
RMIConnection
RMIServer
类
RMIConnectionImpl
RMIConnectionImpl_Stub
RMIConnector
RMIConnectorServer
RMIIIOPServerImpl
RMIJRMPServerImpl
RMIServerImpl
RMIServerImpl_Stub


javax.management.remote.rmi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.management.remote.rmi

RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

请参见：
描述

接口摘要
RMIConnection | RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。
RMIServer | 用于建立到 RMI 连接器的连接的 RMI 对象。

类摘要
RMIConnectionImpl | RMIConnection 接口的实现。
RMIConnectionImpl_Stub |
RMIConnector | 一个到远程 RMI 连接器的连接。
RMIConnectorServer | JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。
RMIIIOPServerImpl | 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
RMIJRMPServerImpl | 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
RMIServerImpl | 表示连接器服务器的 RMI 对象。
RMIServerImpl_Stub |

软件包 javax.management.remote.rmi 的描述

RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。此包定义了 RMI 连接器的用户直接引用客户端和服务器方所需的类。它还定义了其他一些类，用户虽然不经常直接引用这些类，但还是必须定义它们，主要是为 RMI 连接器的不同实现之间实现互操作。

RMI 连接器支持 RMI 的 JRMP 和 IIOP 传输方式。

与 JMX Remote API 中的多数连接器类似，RMI 连接器通常有一个地址，它是一个 JMXServiceURL。对于使用默认 RMI 传输方式 (JRMP) 的连接器，此地址的协议部分为 rmi；对于使用 RMI/IIOP 的连接器，地址的协议部分为 iiop。

RMI 连接器地址有两种形式：

  • 在 JNDI 形式 中，URL 指示查找连接器的 RMI 桩模块 (stub) 的位置。此 RMI 桩模块是一个类型为 RMIServer 的 Java 对象，它提供了对连接器服务器的远程访问。使用这种地址形式，可从包含在 URL 中的外部目录条目获取 RMI 桩模块。外部目录是指可由 JNDI 识别的任何目录，通常是 RMI 注册表、LDAP 或 CORBA 命名服务 (COS Naming)。
  • 在编码形式 中，URL 直接包括了连接到连接器服务器所需的信息。使用 RMI/JRMP 时，编码形式是服务器对象的序列化 RMI 桩模块，它采用 BASE64 编码，未嵌入换行。使用 RMI/IIOP 时，编码形式是服务器对象的 CORBA IOR。

以下内容更详细地介绍了地址。

创建 RMI 连接器服务器

创建 RMI 连接器服务器的一般方法是为方法 JMXConnectorServerFactory.newJMXConnectorServer 提供一个 RMI 连接器地址。将与连接器服务器连接的 MBean 服务器可作为该方法的一个参数指定。或者，也可以将连接器服务器注册为该 MBean 服务器中的 MBean。

还可以通过构造 RMIConnectorServer 的实例（显式或使用 MBean 服务器的 createMBean 方法）来创建 RMI 连接器服务器。

选择 RMI 传输方式

在创建连接器服务器时，通过在 serviceURL 的 protocol 部分指定 rmi 或 iiop，您可以选择 RMI 传输方式（JRMP 或 IIOP）。通过实例化 RMIServerImpl 的一个适当的子类并将其提供给 RMIConnectorServer 构造方法，还可以创建特殊的连接器服务器。

服务器生成的连接器地址

如果您指定的 serviceURL 包含空 URL 路径（在可选的主机和端口后），或者未指定 serviceURL，则连接器服务器将创建一个可供客户端连接使用的新 JMXServiceURL：

  • 如果 serviceURL 如下所示：

            service:jmx:rmi://host:port

    则连接器服务器将生成一个 RMIJRMPServerImpl，且返回如下所示的 JMXServiceURL：

            service:jmx:rmi://host:port/stub/XXXX

    其中，XXXX 为所生成对象的桩模块的序列化形式，其编码采用 BASE64，不带换行。

  • 如果 serviceURL 如下所示：

            service:jmx:iiop://host:port

    则连接器服务器将生成一个 RMIIIOPServerImpl ，且返回如下所示的 JMXServiceURL：

            service:jmx:iiop://host:port/ior/IOR:XXXX

    其中，IOR:XXXX 为所生成对象的互操作对象引用 (Interoperable Object Reference) 的标准 CORBA 编码。

  • 如果没有 serviceURL，则必须有一个用户提供的 RMIServerImpl。如果在此对象上调用 toStub 方法返回 Stub 的实例，则连接器服务器将用上述的 iiop 形式生成 JMXServiceURL。否则，它将用 rmi 形式生成 JMXServiceURL。

用户提供的 serviceURL 中的 host 为可选项。如果有这一项，则将其复制到生成的 JMXServiceURL 中，但是其他方面会忽略此项。如果没有这一项，则生成的 JXMServiceURL 将包括本地主机名。

用户提供的 serviceURL 中的 port 也是一个可选项。如果有这一项，则同样将其复制到生成的 JMXServiceURL 中；否则，生成的 JMXServiceURL 不带端口。对于使用 rmi 协议的 serviceURL，如果有 port，则它指示生成的远程对象应在该端口上导出。它没有任何其他作用。

如果用户提供了 RMIServerImpl 而不是 JMXServiceURL，则生成的 JMXServiceURL 将在其 host 部分包含本地主机名并且不带 port。

基于目录条目的连接器地址

作为刚才介绍的生成地址的另外一种情况，创建连接器服务器时提供的 serviceURL 地址指定的是目录地址，其中可存储提供的或生成的 RMIServer 桩模块。然后客户端和服务器都可以使用此目录地址。

这种情况下，serviceURL 具有如下两种形式之一：

    service:jmx:rmi://host:port/jndi/jndi-name
    service:jmx:iiop://host:port/jndi/jndi-name

其中 jndi-name 是一个可提供给 javax.naming.InitialContext.bind 的字符串。

同样，host 和 :port 均可忽略。

连接器服务器将基于协议（rmi 或 iiop），对于 rmi，还包括 port（如果有）生成 RMIServerImpl。连接器服务器启动后，它将从此对象使用其 toStub 方法派生一个桩模块并使用给定的 jndi-name 保存该对象。同样也要参考由 JNDI API 定义的属性。

例如，假设 JMXServiceURL 为：

      service:jmx:rmi://ignoredhost/jndi/rmi://myhost/myname
则连接器服务器将生成 RMIJRMPServerImpl 并使用该 JNDI 名称保存其桩模块
      rmi://myhost/myname
它表示运行在主机 myhost 的默认端口上 RMI 注册表中的 myname 项。注意，RMI 注册表只允许从本地主机注册。因此在这种情况下，myhost 必须是运行连接器服务器的主机名。

在此 JMXServiceURL 中，第一个 rmi: 指定 RMI 连接器，第二个 rmi: 指定 RMI 注册表。

另举一个例子，如果 JMXServiceURL 为：

      service:jmx:iiop://ignoredhost/jndi/ldap://dirhost:9999/cn=this,ou=that
则该连接器服务器将生成 RMIIIOPServerImpl 并使用该 JNDI 名称保存其桩模块
      ldap://dirhost:9999/cn=this,ou=that
它表示 LDAP 目录中的 cn=this,ou=that 条目，该目录在运行主机 dirhost 的端口 9999 上。

如果 JMXServiceURL 为：

      service:jmx:iiop://ignoredhost/jndi/cn=this,ou=that
则该连接器服务器将生成 RMIIIOPServerImpl 并使用该 JNDI 名称保存其桩模块
      cn=this,ou=that
要在这种情况下正常工作，JNDI API 必须经过适当配置，以提供有关要使用的目录的信息。

这些示例中，主机名 ignoredhost 未被连接器服务器或其客户端使用。可将其忽略，例如：

      service:jmx:iiop:///jndi/cn=this,ou=that

但是，在连接器服务器运行的主机上使用主机名是一个不错的做法。主机名通常不同于目录主机的名称。

连接器服务器的属性

使用默认的 JRMP 传输方式时，可使用为 RMIConnectorServer 构造方法给定的 environment 中的 jmx.remote.rmi.client.socket.factory 和 jmx.remote.rmi.server.socket.factory 属性指定 RMI 套接字工厂。这些属性的值的类型必须分别为 RMIClientSocketFactory 和 RMIServerSocketFactory。这些工厂在创建与连接器关联的 RMI 对象时使用。

创建 RMI 连接器客户端

RMI 连接器客户端通常使用 JMXConnectorFactory 且具有协议 rmi 或 iiop 的 JMXServiceURL 进行构造。

如果 JMXServiceURL 由服务器生成，如上文中的“服务器生成的连接器地址”所述，则客户端将需要直接或间接地从服务器获取该值。通常，服务器将 JMXServiceURL 存储在一个文件或查找服务中以便于使用。

如果 JMXServiceURL 使用目录语法，如上文中的“基于目录条目的连接器地址”所述，则客户端可用刚刚介绍的方法获取该值，或者客户端和服务器可能都知道要使用的适当目录条目。例如，如果 Whatsit 代理的连接器服务器使用主机 myhost 上 RMI 注册表中的 whatsit-agent-connector 条目，则客户端和服务器都知道适当的 JMXServiceURL 为：

    service:jmx:rmi:///jndi/rmi://myhost/whatsit-agent-connector

如果 RMI 桩模块的类型为 RMIServer，则可以使用 RMIConnector 的适当构造方法直接构造 RMI 连接。

为 RMI/IIOP 连接器指定一个 ORB

使用 IIOP 传输方式时，客户端和服务器可使用属性 java.naming.corba.orb 指定要使用的 ORB。连接器服务器连接到 ORB 的动作发生时间为 start，连接器客户端连接到 ORB 的动作发生时间为 connect。如果 java.naming.corba.orb 属性包含在环境 Map 中，则其值（一个 ORB）将用于连接 IIOP Stub。否则，将通过调用 org.omg.CORBA.ORB.init((String[])null,(Properties)null) 创建一个新的 org.omg.CORBA.ORB。位于同一 JVM 中的后续 RMI 连接器客户端或服务器可重用此 ORB，或者可用同样的方式创建另一个 ORB。

如果指定了 java.naming.corba.orb 属性但它并不指向一个 ORB，则将抛出 IllegalArgumentException。

当 IIOP 远程对象（Stub 或 Server）在被传入到 RMIConnector 和 RMIConnectorServer 之前通过手动创建和连接到 ORB 时，这里描述的机制将不适用。

动态代码下载

如果 RMI 连接器客户端或服务器从其同级设备收到一个无法识别的类实例，并且动态代码下载此时可以进行 RMI 连接，则可以从同级设备指定的代码基下载类。文章 Dynamic code downloading using Java RMI 对此进行了详细解释。

从以下版本开始：
1.5
另请参见：
JavaTM Remote Method Invocation (RMI), Java Naming and Directory InterfaceTM (JNDI), RFC 2045, section 6.8, "Base64 Content-Transfer-Encoding"
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.management.remote.rmi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.remote.rmi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.management.NotificationBroadcasterSupport (implements javax.management.NotificationEmitter)
      • javax.management.remote.JMXConnectorServer (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnectorServerMBean, javax.management.MBeanRegistration)
        • javax.management.remote.rmi.RMIConnectorServer
    • java.rmi.server.RemoteObject (implements java.rmi.Remote, java.io.Serializable)
      • java.rmi.server.RemoteStub
        • javax.management.remote.rmi.RMIConnectionImpl_Stub (implements javax.management.remote.rmi.RMIConnection)
        • javax.management.remote.rmi.RMIServerImpl_Stub (implements javax.management.remote.rmi.RMIServer)
    • javax.management.remote.rmi.RMIConnectionImpl (implements javax.management.remote.rmi.RMIConnection, java.rmi.server.Unreferenced)
    • javax.management.remote.rmi.RMIConnector (implements javax.management.remote.JMXAddressable, javax.management.remote.JMXConnector, java.io.Serializable)
    • javax.management.remote.rmi.RMIServerImpl (implements java.io.Closeable, javax.management.remote.rmi.RMIServer)
      • javax.management.remote.rmi.RMIIIOPServerImpl
      • javax.management.remote.rmi.RMIJRMPServerImpl

接口分层结构

  • java.io.Closeable
    • javax.management.remote.rmi.RMIConnection (并 extends java.rmi.Remote)
  • java.rmi.Remote
    • javax.management.remote.rmi.RMIConnection (并 extends java.io.Closeable)
    • javax.management.remote.rmi.RMIServer
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.management.remote.rmi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.management.remote.rmi
的使用

使用 javax.management.remote.rmi 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 使用的 javax.management.remote.rmi 中的类
RMIConnection
RMI 对象，用于将 MBeanServer 请求从客户端转发到其位于服务器端的 MBeanServer 实现。
RMIServer
用于建立到 RMI 连接器的连接的 RMI 对象。
RMIServerImpl
表示连接器服务器的 RMI 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.rmi.RMIConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.rmi.RMIConnection
的使用

使用 RMIConnection 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 RMIConnection 的使用

实现 RMIConnection 的 javax.management.remote.rmi 中的类
class | RMIConnectionImpl RMIConnection 接口的实现。
class | RMIConnectionImpl_Stub

返回 RMIConnection 的 javax.management.remote.rmi 中的方法
protected RMIConnection | RMIIIOPServerImpl.makeClient(String connectionId, Subject subject) 创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
protected RMIConnection | RMIJRMPServerImpl.makeClient(String connectionId, Subject subject) 创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
protected abstract RMIConnection | RMIServerImpl.makeClient(String connectionId, Subject subject) 创建一个新的客户端连接。
RMIConnection | RMIServer.newClient(Object credentials) 建立一个使用该 RMI 连接器的新连接。
RMIConnection | RMIServerImpl.newClient(Object credentials) 创建一个新的客户端连接。
RMIConnection | RMIServerImpl_Stub.newClient(Object $param_Object_1)

参数类型为 RMIConnection 的 javax.management.remote.rmi 中的方法
protected void | RMIServerImpl.clientClosed(RMIConnection client) 关闭由 makeClient 创建的客户端连接时调用的方法。
protected void | RMIIIOPServerImpl.closeClient(RMIConnection client)
protected void | RMIJRMPServerImpl.closeClient(RMIConnection client)
protected abstract void | RMIServerImpl.closeClient(RMIConnection client) 关闭由 makeClient 建立的客户端连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIConnectionImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnectionImpl
的使用

没有 javax.management.remote.rmi.RMIConnectionImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIConnectionImpl_Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnectionImpl_Stub
的使用

没有 javax.management.remote.rmi.RMIConnectionImpl_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIConnector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnector
的使用

没有 javax.management.remote.rmi.RMIConnector 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIConnectorServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIConnectorServer
的使用

没有 javax.management.remote.rmi.RMIConnectorServer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIIIOPServerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIIIOPServerImpl
的使用

没有 javax.management.remote.rmi.RMIIIOPServerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIJRMPServerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIJRMPServerImpl
的使用

没有 javax.management.remote.rmi.RMIJRMPServerImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.rmi.RMIServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.rmi.RMIServer
的使用

使用 RMIServer 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 RMIServer 的使用

实现 RMIServer 的 javax.management.remote.rmi 中的类
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。
class | RMIServerImpl 表示连接器服务器的 RMI 对象。
class | RMIServerImpl_Stub

参数类型为 RMIServer 的 javax.management.remote.rmi 中的构造方法
RMIConnector(RMIServer rmiServer, Map<String,?> environment)
用给定的 RMI stub 构造一个 RMIConnector。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIServerImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIServerImpl
的使用

使用 RMIServerImpl 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 RMIServerImpl 的使用

javax.management.remote.rmi 中 RMIServerImpl 的子类
class | RMIIIOPServerImpl 一个 RMIServerImpl，它通过 IIOP 导出，并可创建如同由 IIOP 导出的 RMI 对象的客户端连接。
class | RMIJRMPServerImpl 一个 RMIServer 对象，它通过 JRMP 导出，并可创建如同由 JRMP 导出的 RMI 对象的客户端连接。

参数类型为 RMIServerImpl 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.rmi.RMIServerImpl_Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.rmi.RMIServerImpl_Stub
的使用

没有 javax.management.remote.rmi.RMIServerImpl_Stub 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.JMXAddressable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXAddressable
的使用

使用 JMXAddressable 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXAddressable 的使用

实现 JMXAddressable 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 JMXAddressable 的使用

实现 JMXAddressable 的 javax.management.remote.rmi 中的类
class | RMIConnector 一个到远程 RMI 连接器的连接。
class | RMIConnectorServer JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.JMXAuthenticator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXAuthenticator
的使用

没有 javax.management.remote.JMXAuthenticator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXConnectionNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectionNotification
的使用

没有 javax.management.remote.JMXConnectionNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.JMXConnector 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnector
的使用

使用 JMXConnector 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXConnector 的使用

返回 JMXConnector 的 javax.management.remote 中的方法
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
JMXConnector | JMXConnectorServer.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。
JMXConnector | JMXConnectorServerMBean.toJMXConnector(Map<String,?> env) 返回此连接器服务器的客户端 stub。

javax.management.remote.rmi 中 JMXConnector 的使用

实现 JMXConnector 的 javax.management.remote.rmi 中的类
 class RMIConnector
一个到远程 RMI 连接器的连接。

返回 JMXConnector 的 javax.management.remote.rmi 中的方法
 JMXConnector RMIConnectorServer.toJMXConnector(Map<String,?> env)
返回此连接器服务器的客户端 stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXConnectorFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectorFactory
的使用

没有 javax.management.remote.JMXConnectorFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.JMXConnectorProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnectorProvider
的使用

没有 javax.management.remote.JMXConnectorProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXConnectorServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectorServer
的使用

使用 JMXConnectorServer 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXConnectorServer 的使用

返回 JMXConnectorServer 的 javax.management.remote 中的方法
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。

javax.management.remote.rmi 中 JMXConnectorServer 的使用

javax.management.remote.rmi 中 JMXConnectorServer 的子类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXConnectorServerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXConnectorServerFactory
的使用

没有 javax.management.remote.JMXConnectorServerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.JMXConnectorServerMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnectorServerMBean
的使用

使用 JMXConnectorServerMBean 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXConnectorServerMBean 的使用

实现 JMXConnectorServerMBean 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 JMXConnectorServerMBean 的使用

实现 JMXConnectorServerMBean 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.JMXConnectorServerProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.JMXConnectorServerProvider
的使用

没有 javax.management.remote.JMXConnectorServerProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXPrincipal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXPrincipal
的使用

没有 javax.management.remote.JMXPrincipal 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXProviderException
的使用

没有 javax.management.remote.JMXProviderException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXServerErrorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXServerErrorException
的使用

没有 javax.management.remote.JMXServerErrorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.JMXServiceURL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.JMXServiceURL
的使用

使用 JMXServiceURL 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 JMXServiceURL 的使用

返回 JMXServiceURL 的 javax.management.remote 中的方法
JMXServiceURL | JMXAddressable.getAddress() 此对象的地址。
JMXServiceURL | JMXConnectorServerMBean.getAddress() 该连接器服务器的地址。

参数类型为 JMXServiceURL 的 javax.management.remote 中的方法
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.connect(JMXServiceURL serviceURL, Map<String,?> environment) 创建到位于给定地址的连接器服务器的连接。
static JMXConnector | JMXConnectorFactory.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 为位于给定地址的连接器服务器创建一个连接器客户端。
JMXConnector | JMXConnectorProvider.newJMXConnector(JMXServiceURL serviceURL, Map<String,?> environment) 创建一个新的可随时连接到位于给定地址的连接器服务器的连接器客户端。
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。

javax.management.remote.rmi 中 JMXServiceURL 的使用

返回 JMXServiceURL 的 javax.management.remote.rmi 中的方法
JMXServiceURL | RMIConnector.getAddress() 此连接器的地址。
JMXServiceURL | RMIConnectorServer.getAddress()

参数类型为 JMXServiceURL 的 javax.management.remote.rmi 中的构造方法
RMIConnector(JMXServiceURL url, Map<String,?> environment)
构造一个将 RMI 连接器服务器连接到给定地址的 RMIConnector。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment)
建立 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.remote.MBeanServerForwarder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.remote.MBeanServerForwarder
的使用

使用 MBeanServerForwarder 的软件包
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote 中 MBeanServerForwarder 的使用

参数类型为 MBeanServerForwarder 的 javax.management.remote 中的方法
void | JMXConnectorServer.setMBeanServerForwarder(MBeanServerForwarder mbsf)
void | JMXConnectorServerMBean.setMBeanServerForwarder(MBeanServerForwarder mbsf) 添加一个截取对 MBean 服务器请求的对象，该请求是通过此连接器服务器到达的。

javax.management.remote.rmi 中 MBeanServerForwarder 的使用

参数类型为 MBeanServerForwarder 的 javax.management.remote.rmi 中的方法
 void RMIConnectorServer.setMBeanServerForwarder(MBeanServerForwarder mbsf)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.NotificationResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.NotificationResult
的使用

使用 NotificationResult 的软件包
javax.management.remote.rmi RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management.remote.rmi 中 NotificationResult 的使用

返回 NotificationResult 的 javax.management.remote.rmi 中的方法
NotificationResult | RMIConnection.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout) 检索来自连接器服务器的通知。
NotificationResult | RMIConnectionImpl.fetchNotifications(long clientSequenceNumber, int maxNotifications, long timeout)
NotificationResult | RMIConnectionImpl_Stub.fetchNotifications(long $param_long_1, int $param_int_2, long $param_long_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.SubjectDelegationPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.SubjectDelegationPermission
的使用

没有 javax.management.remote.SubjectDelegationPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.remote.TargetedNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.remote.TargetedNotification
的使用

使用 TargetedNotification 的软件包
javax.management.remote 对 JMX MBean 服务器进行远程访问使用的接口。

javax.management.remote 中 TargetedNotification 的使用

返回 TargetedNotification 的 javax.management.remote 中的方法
 TargetedNotification[] NotificationResult.getTargetedNotifications()
返回查询到的通知以及相应的侦听器。

参数类型为 TargetedNotification 的 javax.management.remote 中的构造方法
NotificationResult(long earliestSequenceNumber, long nextSequenceNumber, TargetedNotification[] targetedNotifications)
构造一个通知查询结果。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.Attribute
的使用

使用 Attribute 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 Attribute 的使用

返回变量类型为 Attribute 的类型的 javax.management 中的方法
 List<Attribute> AttributeList.asList()
以 List<Attribute> 的形式返回此列表的视图。

参数类型为 Attribute 的 javax.management 中的方法
void | AttributeList.add(Attribute object) 添加指定的 Attribute 作为列表的最后一个元素。
void | AttributeList.add(int index, Attribute object) 插入指定的属性作为指定位置处的元素。
void | AttributeList.set(int index, Attribute object) 将指定位置的元素设置为指定的属性。
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。

类型变量类型为 Attribute 的 javax.management 中的构造方法参数
AttributeList(List<Attribute> list)
构造一个包含指定 List 的元素的 AttributeList，这些元素按 List 的迭代器返回的顺序排列。

javax.management.modelmbean 中 Attribute 的使用

参数类型为 Attribute 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.AttributeChangeNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeChangeNotification
的使用

使用 AttributeChangeNotification 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 AttributeChangeNotification 的使用

参数类型为 AttributeChangeNotification 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(AttributeChangeNotification notification) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.AttributeChangeNotificationFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeChangeNotificationFilter
的使用

没有 javax.management.AttributeChangeNotificationFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.AttributeList 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeList
的使用

使用 AttributeList 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 AttributeList 的使用

返回 AttributeList 的 javax.management 中的方法
AttributeList | MBeanServer.getAttributes(ObjectName name, String[] attributes)
AttributeList | MBeanServerConnection.getAttributes(ObjectName name, String[] attributes) 获得指定 MBean 的多个属性值。
AttributeList | DynamicMBean.getAttributes(String[] attributes) 获得 Dynamic MBean 多个属性的值。
AttributeList | StandardMBean.getAttributes(String[] attributes)
AttributeList | DynamicMBean.setAttributes(AttributeList attributes) 设置 Dynamic MBean 多个属性的值。
AttributeList | StandardMBean.setAttributes(AttributeList attributes)
AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。

参数类型为 AttributeList 的 javax.management 中的方法
boolean | AttributeList.addAll(AttributeList list) 将指定 AttributeList 中的所有元素追加到列表的末尾，元素的顺序是指定 AttributeList 的 Iterator 所返回的顺序。
boolean | AttributeList.addAll(int index, AttributeList list) 将指定 AttributeList 中的所有元素插入此列表，从指定的位置开始插入，元素的顺序是指定 Attribute 的 Iterator 所返回的顺序。
AttributeList | DynamicMBean.setAttributes(AttributeList attributes) 设置 Dynamic MBean 多个属性的值。
AttributeList | StandardMBean.setAttributes(AttributeList attributes)
AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。

参数类型为 AttributeList 的 javax.management 中的构造方法
AttributeList(AttributeList list)
构造一个包含指定 AttributeList 元素的 AttributeList，元素的顺序是该 AttributeList 的迭代器所返回的顺序。

javax.management.modelmbean 中 AttributeList 的使用

返回 AttributeList 的 javax.management.modelmbean 中的方法
AttributeList | RequiredModelMBean.getAttributes(String[] attrNames) 返回 ModelMBean 中几个属性的值。
AttributeList | RequiredModelMBean.setAttributes(AttributeList attributes) 设置此 ModelMBean 的属性数组的值。

参数类型为 AttributeList 的 javax.management.modelmbean 中的方法
 AttributeList RequiredModelMBean.setAttributes(AttributeList attributes)
设置此 ModelMBean 的属性数组的值。

javax.management.remote.rmi 中 AttributeList 的使用

返回 AttributeList 的 javax.management.remote.rmi 中的方法
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.AttributeNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeNotFoundException
的使用

使用 AttributeNotFoundException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 AttributeNotFoundException 的使用

抛出 AttributeNotFoundException 的 javax.management 中的方法
Object | MBeanServer.getAttribute(ObjectName name, String attribute)
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
Object | DynamicMBean.getAttribute(String attribute) 获得 Dynamic MBean 的特定属性的值。
Object | StandardMBean.getAttribute(String attribute)
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。

javax.management.modelmbean 中 AttributeNotFoundException 的使用

抛出 AttributeNotFoundException 的 javax.management.modelmbean 中的方法
Object | RequiredModelMBean.getAttribute(String attrName) 返回为此 ModelMBean 定义的指定属性的值。
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。

javax.management.remote.rmi 中 AttributeNotFoundException 的使用

抛出 AttributeNotFoundException 的 javax.management.remote.rmi 中的方法
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.AttributeValueExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.AttributeValueExp
的使用

使用 AttributeValueExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 AttributeValueExp 的使用

返回 AttributeValueExp 的 javax.management 中的方法
static AttributeValueExp | Query.attr(String name) 返回新的属性表达式。
static AttributeValueExp | Query.attr(String className, String name) 返回新的限定属性表达式。
static AttributeValueExp | Query.classattr() 返回一个新的类属性表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数类型为 AttributeValueExp 的 javax.management 中的方法
static QueryExp | Query.anySubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.finalSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.initialSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.match(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的匹配约束条件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.BadAttributeValueExpException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.BadAttributeValueExpException
的使用

使用 BadAttributeValueExpException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 BadAttributeValueExpException 的使用

抛出 BadAttributeValueExpException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.BadBinaryOpValueExpException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.BadBinaryOpValueExpException
的使用

使用 BadBinaryOpValueExpException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 BadBinaryOpValueExpException 的使用

抛出 BadBinaryOpValueExpException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.BadStringOperationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.BadStringOperationException
的使用

使用 BadStringOperationException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 BadStringOperationException 的使用

抛出 BadStringOperationException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.DefaultLoaderRepository 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.DefaultLoaderRepository
的使用

没有 javax.management.DefaultLoaderRepository 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.Descriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.Descriptor
的使用

使用 Descriptor 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 Descriptor 的使用

实现 Descriptor 的 javax.management 中的类
 class ImmutableDescriptor
不可变的描述符。

返回 Descriptor 的 javax.management 中的方法
Descriptor | ImmutableDescriptor.clone() 返回一个与此描述符相等的描述符。
Descriptor | DescriptorRead.getDescriptor() 返回 Descriptor 的副本。
Descriptor | MBeanFeatureInfo.getDescriptor() 返回该功能的描述符。
Descriptor | MBeanInfo.getDescriptor() 获取此 MBean 的描述符。

参数类型为 Descriptor 的 javax.management 中的方法
void | DescriptorAccess.setDescriptor(Descriptor inDescriptor) 设置 Descriptor（完全替换）。
static ImmutableDescriptor | ImmutableDescriptor.union(Descriptor... descriptors) 返回一个 ImmutableDescriptor，其内容是给定描述符的并集。

参数类型为 Descriptor 的 javax.management 中的构造方法
MBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 MBeanAttributeInfo 对象。
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。
MBeanFeatureInfo(String name, String description, Descriptor descriptor)
构造一个 MBeanFeatureInfo 对象。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。
MBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造一个 MBeanNotificationInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。
MBeanParameterInfo(String name, String type, String description, Descriptor descriptor)
构造一个 MBeanParameterInfo 对象。

javax.management.modelmbean 中 Descriptor 的使用

实现 Descriptor 的 javax.management.modelmbean 中的类
 class DescriptorSupport
此类表示 ModelMBean 元素的元数据集。

返回 Descriptor 的 javax.management.modelmbean 中的方法
Descriptor | ModelMBeanAttributeInfo.getDescriptor() 获取 ModelMBeanAttributeInfo 的关联 Descriptor 的副本。
Descriptor | ModelMBeanConstructorInfo.getDescriptor() 返回关联 Descriptor 的副本。
Descriptor | ModelMBeanInfoSupport.getDescriptor()
Descriptor | ModelMBeanNotificationInfo.getDescriptor() 返回 ModelMBeanNotificationInfo 的关联 Descriptor 的副本。
Descriptor | ModelMBeanOperationInfo.getDescriptor() 返回 ModelMBeanOperationInfo 的关联 Descriptor 的副本。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName) 返回通过名称请求的 Descriptor。
Descriptor | ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
Descriptor[] | ModelMBeanInfo.getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
Descriptor | ModelMBeanInfo.getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
Descriptor | ModelMBeanInfoSupport.getMBeanDescriptor()

参数类型为 Descriptor 的 javax.management.modelmbean 中的方法
void | ModelMBeanAttributeInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanAttributeDescriptor 的关联 Descriptor（完全取代）。
void | ModelMBeanConstructorInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanConstructorInfo 的关联 Descriptor（完全替换）。
void | ModelMBeanNotificationInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanNotificationInfo 的关联 Descriptor（完全替换）。
void | ModelMBeanOperationInfo.setDescriptor(Descriptor inDescriptor) 设置 ModelMBeanOperationInfo 的关联 Descriptor（完全取代）。
void | ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
void | ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
void | ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor) 设置 ModelMBean 的描述符。
void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)

参数类型为 Descriptor 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String type, String description, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanConstructorInfo(String description, Constructor constructorMethod, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanInfoSupport(String className, String description, ModelMBeanAttributeInfo[] attributes, ModelMBeanConstructorInfo[] constructors, ModelMBeanOperationInfo[] operations, ModelMBeanNotificationInfo[] notifications, Descriptor mbeandescriptor)
创建带有所提供的信息和参数中给出的描述符的 ModelMBeanInfoSupport。
ModelMBeanNotificationInfo(String[] notifTypes, String name, String description, Descriptor descriptor)
构造 ModelMBeanNotificationInfo 对象。
ModelMBeanOperationInfo(String description, Method operationMethod, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

javax.management.openmbean 中 Descriptor 的使用

参数类型为 Descriptor 的 javax.management.openmbean 中的构造方法
OpenMBeanAttributeInfoSupport(String name, String description, OpenType<?> openType, boolean isReadable, boolean isWritable, boolean isIs, Descriptor descriptor)
构造一个 OpenMBeanAttributeInfoSupport 实例，该实例使用指定的 name、openType、description、读/写访问属性和 Descriptor 来描述 open MBean 的属性。
OpenMBeanConstructorInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 OpenMBeanConstructorInfoSupport 实例，该实例使用指定的 name、description、signature 和 descriptor 来描述 open MBean 类的构造方法。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类
OpenMBeanOperationInfoSupport(String name, String description, OpenMBeanParameterInfo[] signature, OpenType<?> returnOpenType, int impact, Descriptor descriptor)
构造一个 OpenMBeanOperationInfoSupport 实例，该实例使用指定的 name、description、signature、returnOpenType、impact 和 descriptor 来描述 open MBean 类的操作。
OpenMBeanParameterInfoSupport(String name, String description, OpenType<?> openType, Descriptor descriptor)
构造一个 OpenMBeanParameterInfoSupport 实例，该实例使用指定的 name、openType、description 和 descriptor 描述用于 open MBeans 的类的一个或多个操作或构造方法的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.DescriptorAccess 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.DescriptorAccess
的使用

使用 DescriptorAccess 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 DescriptorAccess 的使用

实现 DescriptorAccess 的 javax.management.modelmbean 中的类
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.DescriptorKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.DescriptorKey
的使用

没有 javax.management.DescriptorKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.DescriptorRead 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.DescriptorRead
的使用

使用 DescriptorRead 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 DescriptorRead 的使用

javax.management 中 DescriptorRead 的子接口
 interface DescriptorAccess
此接口用于获得对 Descriptor 类的描述符的访问，这些 Descriptor 类与某个 JMX 组件相关联，比如 MBean、MBeanInfo、MBeanAttributeInfo、MBeanNotificationInfo、MBeanOperationInfo 和 MBeanParameterInfo。

实现 DescriptorRead 的 javax.management 中的类
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanFeatureInfo 提供 MBean 描述符对象的常规信息。
class | MBeanInfo 描述由 MBean 公开的管理接口；即描述为管理操作所提供的属性和操作的集合。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。

javax.management.modelmbean 中 DescriptorRead 的使用

实现 DescriptorRead 的 javax.management.modelmbean 中的类
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanInfoSupport 此类表示 ModelMBean 的元数据。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

javax.management.openmbean 中 DescriptorRead 的使用

实现 DescriptorRead 的 javax.management.openmbean 中的类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanInfoSupport OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.DynamicMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.DynamicMBean
的使用

使用 DynamicMBean 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 DynamicMBean 的使用

实现 DynamicMBean 的 javax.management 中的类
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。
class | StandardMBean 一个管理接口由 Java 接口上的反射确定的 MBean。

javax.management.modelmbean 中 DynamicMBean 的使用

javax.management.modelmbean 中 DynamicMBean 的子接口
 interface ModelMBean
ModelMBean 必须实现此接口。

实现 DynamicMBean 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.ImmutableDescriptor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ImmutableDescriptor
的使用

使用 ImmutableDescriptor 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 ImmutableDescriptor 的使用

声明为 ImmutableDescriptor 的 javax.management 中的字段
static ImmutableDescriptor ImmutableDescriptor.EMPTY_DESCRIPTOR
空描述符。

返回 ImmutableDescriptor 的 javax.management 中的方法
static ImmutableDescriptor ImmutableDescriptor.union(Descriptor... descriptors)
返回一个 ImmutableDescriptor，其内容是给定描述符的并集。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.InstanceAlreadyExistsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InstanceAlreadyExistsException
的使用

使用 InstanceAlreadyExistsException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 InstanceAlreadyExistsException 的使用

抛出 InstanceAlreadyExistsException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。

javax.management.remote.rmi 中 InstanceAlreadyExistsException 的使用

抛出 InstanceAlreadyExistsException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.InstanceNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InstanceNotFoundException
的使用

使用 InstanceNotFoundException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management 中的方法
void | MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInputStream | MBeanServer.deserialize(ObjectName name, byte[] data) 已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
ObjectInputStream | MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data) 已过时。 使用 getClassLoader 为反序列化获得类加载器。
Object | MBeanServer.getAttribute(ObjectName name, String attribute)
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
AttributeList | MBeanServer.getAttributes(ObjectName name, String[] attributes)
AttributeList | MBeanServerConnection.getAttributes(ObjectName name, String[] attributes) 获得指定 MBean 的多个属性值。
ClassLoader | MBeanServer.getClassLoader(ObjectName loaderName) 返回指定的 ClassLoader。
ClassLoader | MBeanServer.getClassLoaderFor(ObjectName mbeanName) 返回用于加载指定 MBean 的类的 ClassLoader。
MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。
ObjectInstance | MBeanServer.getObjectInstance(ObjectName name)
ObjectInstance | MBeanServerConnection.getObjectInstance(ObjectName name) 获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
Object | MBeanServer.instantiate(String className, ObjectName loaderName) 使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
Object | MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature) 实例化一个对象。
Object | MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
Object | MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature) 在 MBean 上调用某个操作。
boolean | MBeanServer.isInstanceOf(ObjectName name, String className)
boolean | MBeanServerConnection.isInstanceOf(ObjectName name, String className) 如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
void | PersistentMBean.load() 使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。
AttributeList | MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
AttributeList | MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes) 设置指定 MBean 的多个属性值。
void | PersistentMBean.store() 捕获此 MBean 实例的当前状态并将其写出到持久存储中。
void | MBeanServer.unregisterMBean(ObjectName name)
void | MBeanServerConnection.unregisterMBean(ObjectName name) 从 MBean 服务器中注销一个 MBean。

javax.management.modelmbean 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.modelmbean 中的方法
void | RequiredModelMBean.load() 使用在持久存储中找到的 MBean 的数据实例化此 MBean。
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
void | RequiredModelMBean.store() 捕获此 MBean 实例的当前状态，并将它写出到持久存储中。

javax.management.relation 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。

javax.management.remote.rmi 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

javax.management.timer 中 InstanceNotFoundException 的使用

抛出 InstanceNotFoundException 的 javax.management.timer 中的方法
void | Timer.removeNotification(Integer id) 从通知列表中移除与指定标识符对应的计时器通知。
void | TimerMBean.removeNotification(Integer id) 从通知列表中移除与指定的标识符对应的计时器通知。
void | Timer.removeNotifications(String type) 从通知列表中移除与指定类型对应的所有计时器通知。
void | TimerMBean.removeNotifications(String type) 从通知列表中移除与指定的类型对应的所有计时器通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.IntrospectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.IntrospectionException
的使用

使用 IntrospectionException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 IntrospectionException 的使用

抛出 IntrospectionException 的 javax.management 中的方法
MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。

抛出 IntrospectionException 的 javax.management 中的构造方法
MBeanAttributeInfo(String name, String description, Method getter, Method setter)
此构造方法带有简单属性的名称，以及读取和写入属性的 Method 对象。

javax.management.modelmbean 中 IntrospectionException 的使用

抛出 IntrospectionException 的 javax.management.modelmbean 中的构造方法
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter)
构造具有默认描述符的 ModelMBeanAttributeInfo 对象。
ModelMBeanAttributeInfo(String name, String description, Method getter, Method setter, Descriptor descriptor)
构造 ModelMBeanAttributeInfo 对象。

javax.management.remote.rmi 中 IntrospectionException 的使用

抛出 IntrospectionException 的 javax.management.remote.rmi 中的方法
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.InvalidApplicationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InvalidApplicationException
的使用

使用 InvalidApplicationException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 InvalidApplicationException 的使用

抛出 InvalidApplicationException 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
boolean | QueryExp.apply(ObjectName name) 在 MBean 上应用 QueryExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.InvalidAttributeValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.InvalidAttributeValueException
的使用

使用 InvalidAttributeValueException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 InvalidAttributeValueException 的使用

抛出 InvalidAttributeValueException 的 javax.management 中的方法
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。

javax.management.modelmbean 中 InvalidAttributeValueException 的使用

抛出 InvalidAttributeValueException 的 javax.management.modelmbean 中的方法
 void RequiredModelMBean.setAttribute(Attribute attribute)
设置指定的 ModelMBean 的指定属性值。

javax.management.remote.rmi 中 InvalidAttributeValueException 的使用

抛出 InvalidAttributeValueException 的 javax.management.remote.rmi 中的方法
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.JMException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.JMException
的使用

使用 JMException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。

javax.management 中 JMException 的使用

javax.management 中 JMException 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | IntrospectionException 在 MBean 的 introspection 期间出现的异常。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | MBeanException 表示由代理的 MBean 方法所抛出的“用户定义的”异常。
class | MBeanRegistrationException 包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | OperationsException 表示在 MBean 上执行操作时，在 MBean 服务器中抛出的异常。
class | ReflectionException 表示在使用 java.lang.reflect 类调用 MBean 上的方法时，MBean 服务器中抛出的异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

javax.management.openmbean 中 JMException 的使用

javax.management.openmbean 中 JMException 的子类
 class OpenDataException
因为无法满足一个或多个有效性约束，所以无法构造开放类型、开放数据 或 open MBean 元数据信息 实例时，抛出此经过检查的异常。

javax.management.relation 中 JMException 的使用

javax.management.relation 中 JMException 的子类
class | InvalidRelationIdException 为关系提供的关系 id 已使用时引发此异常。
class | InvalidRelationServiceException 提供无效 Relation Service（关系服务）时引发此异常。
class | InvalidRelationTypeException 无效的关系类型。
class | InvalidRoleInfoException 在角色信息中，其最小程度大于其最大程度时，引发此异常。
class | InvalidRoleValueException 角色值无效。
class | RelationException 此类是关系管理过程中引发的任何异常的超类。
class | RelationNotFoundException Relation Service（关系服务）中不存在给定关系 id 的关系时引发此异常。
class | RelationServiceNotRegisteredException 在对 Relation Service（关系服务）进行访问而该 Relation Service 未注册时引发此异常。
class | RelationTypeNotFoundException Relation Service（关系服务）中不存在带给定名称的关系类型时引发此异常。
class | RoleInfoNotFoundException 给定的关系类型中不存在带指定名称的角色信息时引发此异常。
class | RoleNotFoundException 关系中的某个角色不存在，或不可读，或不可设置时，引发此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.JMRuntimeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.JMRuntimeException
的使用

使用 JMRuntimeException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.monitor | 提供 monitor 类的定义。

javax.management 中 JMRuntimeException 的使用

javax.management 中 JMRuntimeException 的子类
class | RuntimeErrorException 当代理中发生 java.lang.Error 时，必须捕获它并作为 RuntimeErrorException 重新抛出。
class | RuntimeMBeanException 表示由代理中的 MBean 方法抛出的运行时异常。
class | RuntimeOperationsException 表示在 MBean 上执行操作时代理中抛出的运行时异常。

javax.management.monitor 中 JMRuntimeException 的使用

javax.management.monitor 中 JMRuntimeException 的子类
 class MonitorSettingException
当监视器设置在运行监视器期间变得无效时由该监视器抛出的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.JMX 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.JMX
的使用

没有 javax.management.JMX 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.ListenerNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ListenerNotFoundException
的使用

使用 ListenerNotFoundException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management 中的方法
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener)
void | NotificationBroadcaster.removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener)
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener)
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。

javax.management.modelmbean 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener) 从 RequiredModelMBean 移除一个 Notification 的侦听器。
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.remote 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management.remote 中的方法
void | JMXConnector.removeConnectionNotificationListener(NotificationListener listener) 将一个用于接收状态更改通知的侦听器从列表中移除。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。

javax.management.remote.rmi 中 ListenerNotFoundException 的使用

抛出 ListenerNotFoundException 的 javax.management.remote.rmi 中的方法
 void RMIConnector.removeConnectionNotificationListener(NotificationListener listener)
 void RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanAttributeInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanAttributeInfo
的使用

使用 MBeanAttributeInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanAttributeInfo 的使用

返回 MBeanAttributeInfo 的 javax.management 中的方法
 MBeanAttributeInfo[] MBeanInfo.getAttributes()
返回为了便于管理而公开的属性的列表。

参数类型为 MBeanAttributeInfo 的 javax.management 中的方法
protected  String StandardMBean.getDescription(MBeanAttributeInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanAttributeInfo 中使用的描述。

参数类型为 MBeanAttributeInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 MBeanAttributeInfo 的使用

javax.management.modelmbean 中 MBeanAttributeInfo 的子类
 class ModelMBeanAttributeInfo
ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。

返回 MBeanAttributeInfo 的 javax.management.modelmbean 中的方法
 MBeanAttributeInfo[] ModelMBeanInfo.getAttributes()
返回为管理公开的属性列表。

javax.management.openmbean 中 MBeanAttributeInfo 的使用

javax.management.openmbean 中 MBeanAttributeInfo 的子类
 class OpenMBeanAttributeInfoSupport
描述 open MBean 的一个属性。

返回 MBeanAttributeInfo 的 javax.management.openmbean 中的方法
 MBeanAttributeInfo[] OpenMBeanInfo.getAttributes()
返回 OpenMBeanAttributeInfo 实例的数组，该实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanConstructorInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanConstructorInfo
的使用

使用 MBeanConstructorInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanConstructorInfo 的使用

返回 MBeanConstructorInfo 的 javax.management 中的方法
MBeanConstructorInfo[] | MBeanInfo.getConstructors() 返回 MBean 的公共构造方法列表。
protected MBeanConstructorInfo[] | StandardMBean.getConstructors(MBeanConstructorInfo[] ctors, Object impl) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。

参数类型为 MBeanConstructorInfo 的 javax.management 中的方法
protected MBeanConstructorInfo[] | StandardMBean.getConstructors(MBeanConstructorInfo[] ctors, Object impl) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 MBeanConstructorInfo[]。
protected String | StandardMBean.getDescription(MBeanConstructorInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanConstructorInfo 中使用的描述。
protected String | StandardMBean.getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
protected String | StandardMBean.getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。

参数类型为 MBeanConstructorInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 MBeanConstructorInfo 的使用

javax.management.modelmbean 中 MBeanConstructorInfo 的子类
 class ModelMBeanConstructorInfo
ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。

返回 MBeanConstructorInfo 的 javax.management.modelmbean 中的方法
 MBeanConstructorInfo[] ModelMBeanInfo.getConstructors()
返回 MBean 的公共构造方法列表。

javax.management.openmbean 中 MBeanConstructorInfo 的使用

javax.management.openmbean 中 MBeanConstructorInfo 的子类
 class OpenMBeanConstructorInfoSupport
描述 Open MBean 的构造方法。

返回 MBeanConstructorInfo 的 javax.management.openmbean 中的方法
 MBeanConstructorInfo[] OpenMBeanInfo.getConstructors()
返回 OpenMBeanConstructorInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 中的每个构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanInfo
的使用

使用 MBeanInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 MBeanInfo 的使用

返回 MBeanInfo 的 javax.management 中的方法
protected MBeanInfo | StandardMBean.getCachedMBeanInfo() 自定义钩子：返回为此对象缓存的 MBeanInfo。
MBeanInfo | DynamicMBean.getMBeanInfo() 使用 MBeanInfo 对象提供该 Dynamic MBean 已公开的属性和操作。
MBeanInfo | StandardMBean.getMBeanInfo() 获取此 MBean 的 MBeanInfo。
MBeanInfo | MBeanServer.getMBeanInfo(ObjectName name)
MBeanInfo | MBeanServerConnection.getMBeanInfo(ObjectName name) 此方法发现了 MBean 为管理而公开的属性和操作。

参数类型为 MBeanInfo 的 javax.management 中的方法
protected void | StandardMBean.cacheMBeanInfo(MBeanInfo info) 自定义钩子：缓存为此对象构建的 MBeanInfo。
protected String | StandardMBean.getClassName(MBeanInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的 className。
protected String | StandardMBean.getDescription(MBeanInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanInfo 中使用的描述。

javax.management.modelmbean 中 MBeanInfo 的使用

javax.management.modelmbean 中 MBeanInfo 的子类
 class ModelMBeanInfoSupport
此类表示 ModelMBean 的元数据。

返回 MBeanInfo 的 javax.management.modelmbean 中的方法
 MBeanInfo RequiredModelMBean.getMBeanInfo()
返回此 RequiredModelMBean 公开的属性、操作、构造方法和通知是为了便于管理。

javax.management.openmbean 中 MBeanInfo 的使用

javax.management.openmbean 中 MBeanInfo 的子类
 class OpenMBeanInfoSupport
OpenMBeanInfoSupport 类描述 open MBean 的管理信息：它是 MBeanInfo 的子类，并且实现了 OpenMBeanInfo 接口。

javax.management.remote.rmi 中 MBeanInfo 的使用

返回 MBeanInfo 的 javax.management.remote.rmi 中的方法
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanException
的使用

使用 MBeanException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 MBeanException 的使用

javax.management 中 MBeanException 的子类
 class MBeanRegistrationException
包装由 MBeanRegistration 接口的 preRegister() 和 preDeregister() 方法所抛出的异常。

抛出 MBeanException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
Object | MBeanServer.getAttribute(ObjectName name, String attribute)
Object | MBeanServerConnection.getAttribute(ObjectName name, String attribute) 获得指定 MBean 的特定属性值。
Object | DynamicMBean.getAttribute(String attribute) 获得 Dynamic MBean 的特定属性的值。
Object | StandardMBean.getAttribute(String attribute)
Object | MBeanServer.instantiate(String className) 使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。
Object | MBeanServer.instantiate(String className, Object[] params, String[] signature) 使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。
Object | MBeanServer.instantiate(String className, ObjectName loaderName) 使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
Object | MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature) 实例化一个对象。
Object | MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
Object | MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature) 在 MBean 上调用某个操作。
Object | DynamicMBean.invoke(String actionName, Object[] params, String[] signature) 允许在 Dynamic MBean 上调用某个操作。
Object | StandardMBean.invoke(String actionName, Object[] params, String[] signature)
void | PersistentMBean.load() 使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
void | DynamicMBean.setAttribute(Attribute attribute) 设置 Dynamic MBean 的特定属性的值。
void | StandardMBean.setAttribute(Attribute attribute)
void | MBeanServer.setAttribute(ObjectName name, Attribute attribute)
void | MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute) 设置指定 MBean 的特定属性值。
void | PersistentMBean.store() 捕获此 MBean 实例的当前状态并将其写出到持久存储中。

javax.management.modelmbean 中 MBeanException 的使用

抛出 MBeanException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
ModelMBeanAttributeInfo | ModelMBeanInfo.getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)
Object | RequiredModelMBean.getAttribute(String attrName) 返回为此 ModelMBean 定义的指定属性的值。
ModelMBeanConstructorInfo | ModelMBeanInfoSupport.getConstructor(String inName) 返回通过名称请求的 ModelMBeanConstructorInfo。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName) 返回通过名称请求的 Descriptor。
Descriptor | ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
Descriptor[] | ModelMBeanInfo.getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
Descriptor | ModelMBeanInfo.getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
Descriptor | ModelMBeanInfoSupport.getMBeanDescriptor()
ModelMBeanNotificationInfo | ModelMBeanInfo.getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)
ModelMBeanOperationInfo | ModelMBeanInfo.getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)
Object | RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig) 调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。
void | RequiredModelMBean.load() 使用在持久存储中找到的 MBean 的数据实例化此 MBean。
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(AttributeChangeNotification notification) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(Notification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(String ntfyText) 将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(String ntfyText)
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。
void | ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
void | ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
void | ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor) 设置 ModelMBean 的描述符。
void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)
void | ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.store() 捕获此 MBean 实例的当前状态，并将它写出到持久存储中。

抛出 MBeanException 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(int initNumFields)
描述符构造方法。
DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。
RequiredModelMBean()
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。
RequiredModelMBean(ModelMBeanInfo mbi)
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。

javax.management.remote.rmi 中 MBeanException 的使用

抛出 MBeanException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanFeatureInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanFeatureInfo
的使用

使用 MBeanFeatureInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanFeatureInfo 的使用

javax.management 中 MBeanFeatureInfo 的子类
class | MBeanAttributeInfo 描述出于管理目的而公开的 MBean 属性。
class | MBeanConstructorInfo 描述 MBean 所公开的构造方法。
class | MBeanNotificationInfo MBeanNotificationInfo 类用于描述 MBean 向给定的 Java 通知类发出的不同通知实例的特性。
class | MBeanOperationInfo 描述由 MBean 公开的管理操作。
class | MBeanParameterInfo 描述由 MBean 公开的操作的参数。

参数类型为 MBeanFeatureInfo 的 javax.management 中的方法
protected  String StandardMBean.getDescription(MBeanFeatureInfo info)
自定义钩子：获取将在由此 MBean 返回的 MBeanFeatureInfo 中使用的描述。

javax.management.modelmbean 中 MBeanFeatureInfo 的使用

javax.management.modelmbean 中 MBeanFeatureInfo 的子类
class | ModelMBeanAttributeInfo ModelMBeanAttributeInfo 对象描述了 ModelMBean 的属性。
class | ModelMBeanConstructorInfo ModelMBeanConstructorInfo 对象描述了 ModelMBean 的一个构造方法。
class | ModelMBeanNotificationInfo ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。
class | ModelMBeanOperationInfo ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

javax.management.openmbean 中 MBeanFeatureInfo 的使用

javax.management.openmbean 中 MBeanFeatureInfo 的子类
class | OpenMBeanAttributeInfoSupport 描述 open MBean 的一个属性。
class | OpenMBeanConstructorInfoSupport 描述 Open MBean 的构造方法。
class | OpenMBeanOperationInfoSupport 描述 Open MBean 的一个操作。
class | OpenMBeanParameterInfoSupport 描述用于 open MBean 的一个或多个操作或构造方法的参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanNotificationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanNotificationInfo
的使用

使用 MBeanNotificationInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management 中的方法
MBeanNotificationInfo[] | MBeanServerDelegate.getNotificationInfo()
MBeanNotificationInfo[] | NotificationBroadcaster.getNotificationInfo() 返回一个数组，指示此 MBean 可能发送的每个通知的 Java 类名和通知类型。
MBeanNotificationInfo[] | NotificationBroadcasterSupport.getNotificationInfo()
MBeanNotificationInfo[] | StandardEmitterMBean.getNotificationInfo()
MBeanNotificationInfo[] | MBeanInfo.getNotifications() 返回 MBean 所发出的通知列表。

参数类型为 MBeanNotificationInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。
NotificationBroadcasterSupport(Executor executor, MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport，其中的每个侦听器都是使用给定 Executor 调用的。
NotificationBroadcasterSupport(MBeanNotificationInfo... info)
使用关于可能发送的通知的信息构造一个 NotificationBroadcasterSupport。

javax.management.modelmbean 中 MBeanNotificationInfo 的使用

javax.management.modelmbean 中 MBeanNotificationInfo 的子类
 class ModelMBeanNotificationInfo
ModelMBeanNotificationInfo 对象描述了由 ModelMBean 发出的通知。

返回 MBeanNotificationInfo 的 javax.management.modelmbean 中的方法
MBeanNotificationInfo[] | RequiredModelMBean.getNotificationInfo() 返回总是由 RequiredModelMBean 生成的 Notification 数组。
MBeanNotificationInfo[] | ModelMBeanInfo.getNotifications() 返回 MBean 所发送的通知列表。

javax.management.monitor 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.monitor 中的方法
MBeanNotificationInfo[] | CounterMonitor.getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由计数器监视器发送的通知类型。
MBeanNotificationInfo[] | GaugeMonitor.getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由尺度监视器发送的通知类型。
MBeanNotificationInfo[] | StringMonitor.getNotificationInfo() 返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和由字符串监视器发送的通知类型。

javax.management.openmbean 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.openmbean 中的方法
 MBeanNotificationInfo[] OpenMBeanInfo.getNotifications()
返回 MBeanNotificationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例描述的 open MBean 所发出的每个通知。

参数类型为 MBeanNotificationInfo 的 javax.management.openmbean 中的构造方法
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations 和 notifications 描述 open MBeans 的类。
OpenMBeanInfoSupport(String className, String description, OpenMBeanAttributeInfo[] openAttributes, OpenMBeanConstructorInfo[] openConstructors, OpenMBeanOperationInfo[] openOperations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 OpenMBeanInfoSupport 实例，它使用指定的 className、description、openAttributes、openConstructors、openOperations、notifications 和 descriptor 描述 open MBeans 的类

javax.management.relation 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.relation 中的方法
 MBeanNotificationInfo[] RelationService.getNotificationInfo()
返回一个 NotificationInfo 对象，它包含通知的 Java 类的名称和发送的通知类型。

javax.management.remote 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.remote 中的方法
 MBeanNotificationInfo[] JMXConnectorServer.getNotificationInfo()
返回一个指示由该 MBean 发送的通知的数组。

javax.management.timer 中 MBeanNotificationInfo 的使用

返回 MBeanNotificationInfo 的 javax.management.timer 中的方法
 MBeanNotificationInfo[] Timer.getNotificationInfo()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanOperationInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanOperationInfo
的使用

使用 MBeanOperationInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanOperationInfo 的使用

返回 MBeanOperationInfo 的 javax.management 中的方法
 MBeanOperationInfo[] MBeanInfo.getOperations()
返回 MBean 的操作列表。

参数类型为 MBeanOperationInfo 的 javax.management 中的方法
protected String | StandardMBean.getDescription(MBeanOperationInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的描述。
protected String | StandardMBean.getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
protected int | StandardMBean.getImpact(MBeanOperationInfo info) 自定义钩子：获取将在由此 MBean 返回的 MBeanOperationInfo 中使用的操作的 impact 标志。
protected String | StandardMBean.getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。

参数类型为 MBeanOperationInfo 的 javax.management 中的构造方法
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications)
构造一个 MBeanInfo。
MBeanInfo(String className, String description, MBeanAttributeInfo[] attributes, MBeanConstructorInfo[] constructors, MBeanOperationInfo[] operations, MBeanNotificationInfo[] notifications, Descriptor descriptor)
构造一个 MBeanInfo。

javax.management.modelmbean 中 MBeanOperationInfo 的使用

javax.management.modelmbean 中 MBeanOperationInfo 的子类
 class ModelMBeanOperationInfo
ModelMBeanOperationInfo 对象描述了 ModelMBean 的管理操作。

返回 MBeanOperationInfo 的 javax.management.modelmbean 中的方法
 MBeanOperationInfo[] ModelMBeanInfo.getOperations()
返回 MBean 的操作列表。

javax.management.openmbean 中 MBeanOperationInfo 的使用

javax.management.openmbean 中 MBeanOperationInfo 的子类
 class OpenMBeanOperationInfoSupport
描述 Open MBean 的一个操作。

返回 MBeanOperationInfo 的 javax.management.openmbean 中的方法
 MBeanOperationInfo[] OpenMBeanInfo.getOperations()
返回 OpenMBeanOperationInfo 实例的数组，这些实例描述此 OpenMBeanInfo 实例所描述的 open MBean 中的每个操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanParameterInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanParameterInfo
的使用

使用 MBeanParameterInfo 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。

javax.management 中 MBeanParameterInfo 的使用

返回 MBeanParameterInfo 的 javax.management 中的方法
MBeanParameterInfo[] | MBeanConstructorInfo.getSignature() 返回此构造方法的参数列表。
MBeanParameterInfo[] | MBeanOperationInfo.getSignature() 返回此操作的参数列表。

参数类型为 MBeanParameterInfo 的 javax.management 中的方法
protected String | StandardMBean.getDescription(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的描述。
protected String | StandardMBean.getDescription(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的描述。
protected String | StandardMBean.getParameterName(MBeanConstructorInfo ctor, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanConstructorInfo 的第 sequence 个 BeanParameterInfo 的名称。
protected String | StandardMBean.getParameterName(MBeanOperationInfo op, MBeanParameterInfo param, int sequence) 自定义钩子：获取将用于由此 MBean 返回的 MBeanOperationInfo 的第 sequence 个 MBeanParameterInfo 的名称。

参数类型为 MBeanParameterInfo 的 javax.management 中的构造方法
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造一个 MBeanConstructorInfo 对象。
MBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造一个 MBeanConstructorInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造一个 MBeanOperationInfo 对象。
MBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造一个 MBeanOperationInfo 对象。

javax.management.modelmbean 中 MBeanParameterInfo 的使用

参数类型为 MBeanParameterInfo 的 javax.management.modelmbean 中的构造方法
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature)
构造带有默认描述符的 ModelMBeanConstructorInfo 对象。
ModelMBeanConstructorInfo(String name, String description, MBeanParameterInfo[] signature, Descriptor descriptor)
构造 ModelMBeanConstructorInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact)
构造带有默认描述符的 ModelMBeanOperationInfo 对象。
ModelMBeanOperationInfo(String name, String description, MBeanParameterInfo[] signature, String type, int impact, Descriptor descriptor)
构造 ModelMBeanOperationInfo 对象。

javax.management.openmbean 中 MBeanParameterInfo 的使用

javax.management.openmbean 中 MBeanParameterInfo 的子类
 class OpenMBeanParameterInfoSupport
描述用于 open MBean 的一个或多个操作或构造方法的参数。

返回 MBeanParameterInfo 的 javax.management.openmbean 中的方法
MBeanParameterInfo[] | OpenMBeanConstructorInfo.getSignature() 返回 OpenMBeanParameterInfo 实例的数组，该实例描述此 OpenMBeanConstructorInfo 实例描述的构造方法签名中的每个参数。
MBeanParameterInfo[] | OpenMBeanOperationInfo.getSignature() 返回 OpenMBeanOperationInfo 实例的数组，该实例描述此 OpenMBeanParameterInfo 实例所描述操作的签名中的每个参数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanPermission
的使用

没有 javax.management.MBeanPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.MBeanRegistration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanRegistration
的使用

使用 MBeanRegistration 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management 中的类
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。
class | StandardMBean 一个管理接口由 Java 接口上的反射确定的 MBean。

javax.management.loading 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.loading 中的类
class | MLet 允许实例化和注册来自远程 URL 的 MBean 服务器中一个或几个 MBean。
class | PrivateMLet 不添加到 ClassLoaderRepository 的 MLet。

javax.management.modelmbean 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

javax.management.monitor 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.relation 中的类
class | RelationService Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。
class | RelationSupport RelationSupport 对象由 Relation Service 内部使用，表示任何关系型的具有不限数量的角色的简单关系（只有角色，没有属性或方法）。

javax.management.remote 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 MBeanRegistration 的使用

实现 MBeanRegistration 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanRegistrationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanRegistrationException
的使用

使用 MBeanRegistrationException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 MBeanRegistrationException 的使用

抛出 MBeanRegistrationException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
void | MBeanServer.unregisterMBean(ObjectName name)
void | MBeanServerConnection.unregisterMBean(ObjectName name) 从 MBean 服务器中注销一个 MBean。

javax.management.remote.rmi 中 MBeanRegistrationException 的使用

抛出 MBeanRegistrationException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.MBeanServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanServer
的使用

使用 MBeanServer 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

java.lang.management 中 MBeanServer 的使用

返回 MBeanServer 的 java.lang.management 中的方法
static MBeanServer ManagementFactory.getPlatformMBeanServer()
返回平台 MBeanServer。

javax.management 中 MBeanServer 的使用

返回 MBeanServer 的 javax.management 中的方法
static MBeanServer | MBeanServerFactory.createMBeanServer() 返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口。
static MBeanServer | MBeanServerFactory.createMBeanServer(String domain) 返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口。
static MBeanServer | QueryEval.getMBeanServer() 返回此线程最近一次提供给 setMBeanServer 方法的 MBean 服务器。
static MBeanServer | MBeanServerFactory.newMBeanServer() 返回一个新对象，该对象使用标准的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
static MBeanServer | MBeanServerFactory.newMBeanServer(String domain) 返回一个新对象，该对象使用指定的默认域名来实现 MBeanServer 接口，不保持对此新对象的内部引用。
MBeanServer | MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate) 此方法创建一个新的 MBeanServer 实现对象。

返回变量类型为 MBeanServer 的类型的 javax.management 中的方法
static ArrayList<MBeanServer> MBeanServerFactory.findMBeanServer(String agentId)
返回已注册 MBeanServer 对象的列表。

参数类型为 MBeanServer 的 javax.management 中的方法
static ClassLoaderRepository MBeanServerFactory.getClassLoaderRepository(MBeanServer server)
返回给定 MBeanServer 使用的 ClassLoaderRepository。
 MBeanServer MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
此方法创建一个新的 MBeanServer 实现对象。
 ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
 ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。
static void MBeanServerFactory.releaseMBeanServer(MBeanServer mbeanServer)
移除对已创建 MBeanServer 的内部 MBeanServerFactory 引用。
 void AttributeValueExp.setMBeanServer(MBeanServer s)
设置要在其上执行查询的 MBean 服务器。
 void ObjectName.setMBeanServer(MBeanServer mbs)
 void QueryEval.setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。
 void QueryExp.setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。
 void StringValueExp.setMBeanServer(MBeanServer s)
设置将在其上执行查询的 MBean 服务器。
 void ValueExp.setMBeanServer(MBeanServer s)
已过时。 不再需要此方法，因为 ValueExp 可以通过使用 QueryEval.getMBeanServer() 来访问它将在其中进行计算的 MBean 服务器。

javax.management.loading 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.loading 中的方法
 ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

javax.management.modelmbean 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.modelmbean 中的方法
 ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

javax.management.monitor 中 MBeanServer 的使用

声明为 MBeanServer 的 javax.management.monitor 中的字段
protected  MBeanServer Monitor.server
对 MBean 服务器的引用。

参数类型为 MBeanServer 的 javax.management.monitor 中的方法
 ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。

javax.management.relation 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.relation 中的方法
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

参数类型为 MBeanServer 的 javax.management.relation 中的构造方法
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

javax.management.remote 中 MBeanServer 的使用

javax.management.remote 中 MBeanServer 的子接口
 interface MBeanServerForwarder
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。

返回 MBeanServer 的 javax.management.remote 中的方法
MBeanServer | JMXConnectorServer.getMBeanServer() 返回该连接器服务器连接到的 MBean 服务器。
MBeanServer | MBeanServerForwarder.getMBeanServer() 返回请求将转发到其上的 MBeanServer 对象。

参数类型为 MBeanServer 的 javax.management.remote 中的方法
static JMXConnectorServer | JMXConnectorServerFactory.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的连接器服务器。
JMXConnectorServer | JMXConnectorServerProvider.newJMXConnectorServer(JMXServiceURL serviceURL, Map<String,?> environment, MBeanServer mbeanServer) 创建位于给定地址的新连接器服务器。
ObjectName | JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name) 当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。
void | MBeanServerForwarder.setMBeanServer(MBeanServer mbs) 设置 MBeanServer 对象，请求经此对象处理后将转发到其上。

参数类型为 MBeanServer 的 javax.management.remote 中的构造方法
JMXConnectorServer(MBeanServer mbeanServer)
构造一个连接到给定 MBean 服务器的连接器服务器。

javax.management.remote.rmi 中 MBeanServer 的使用

返回 MBeanServer 的 javax.management.remote.rmi 中的方法
 MBeanServer RMIServerImpl.getMBeanServer()
此连接器服务器所连接的 MBeanServer。

参数类型为 MBeanServer 的 javax.management.remote.rmi 中的方法
 void RMIServerImpl.setMBeanServer(MBeanServer mbs)
设置此连接器服务器所连接的 MBeanServer。

参数类型为 MBeanServer 的 javax.management.remote.rmi 中的构造方法
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。
RMIConnectorServer(JMXServiceURL url, Map<String,?> environment, RMIServerImpl rmiServerImpl, MBeanServer mbeanServer)
为给定的 MBean 服务器建立一个 RMIConnectorServer。

javax.management.timer 中 MBeanServer 的使用

参数类型为 MBeanServer 的 javax.management.timer 中的方法
 ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanServerBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerBuilder
的使用

没有 javax.management.MBeanServerBuilder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.MBeanServerConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanServerConnection
的使用

使用 MBeanServerConnection 的软件包
java.lang.management | 提供管理接口，用于监视和管理 Java 虚拟机以及 Java 虚拟机在其上运行的操作系统。
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

java.lang.management 中 MBeanServerConnection 的使用

参数类型为 MBeanServerConnection 的 java.lang.management 中的方法
static
<T> T
ManagementFactory.newPlatformMXBeanProxy(MBeanServerConnection connection, String mxbeanName, Class<T> mxbeanInterface)
返回用于给定 MXBean 名称的平台 MXBean 接口的代理，以便通过给定 MBeanServerConnection 转发其方法调用。

javax.management 中 MBeanServerConnection 的使用

javax.management 中 MBeanServerConnection 的子接口
 interface MBeanServer
这是在代理端进行 MBean 操作的接口。

返回 MBeanServerConnection 的 javax.management 中的方法
 MBeanServerConnection MBeanServerInvocationHandler.getMBeanServerConnection()
MBean 服务器连接，使用此处理程序的代理的方法是通过此连接转发的。

参数类型为 MBeanServerConnection 的 javax.management 中的方法
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。

参数类型为 MBeanServerConnection 的 javax.management 中的构造方法
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName, boolean isMXBean)
可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。

javax.management.remote 中 MBeanServerConnection 的使用

javax.management.remote 中 MBeanServerConnection 的子接口
 interface MBeanServerForwarder
此类的对象实现 MBeanServer 接口并包装另一个也实现此接口的对象。

返回 MBeanServerConnection 的 javax.management.remote 中的方法
MBeanServerConnection | JMXConnector.getMBeanServerConnection() 返回一个代表远程 MBean 服务器的 MBeanServerConnection 对象。
MBeanServerConnection | JMXConnector.getMBeanServerConnection(Subject delegationSubject) 返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。

javax.management.remote.rmi 中 MBeanServerConnection 的使用

返回 MBeanServerConnection 的 javax.management.remote.rmi 中的方法
MBeanServerConnection | RMIConnector.getMBeanServerConnection()
MBeanServerConnection | RMIConnector.getMBeanServerConnection(Subject delegationSubject)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanServerDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerDelegate
的使用

使用 MBeanServerDelegate 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 MBeanServerDelegate 的使用

返回 MBeanServerDelegate 的 javax.management 中的方法
 MBeanServerDelegate MBeanServerBuilder.newMBeanServerDelegate()
此方法为新的 MBeanServer 创建新的 MBeanServerDelegate。

参数类型为 MBeanServerDelegate 的 javax.management 中的方法
 MBeanServer MBeanServerBuilder.newMBeanServer(String defaultDomain, MBeanServer outer, MBeanServerDelegate delegate)
此方法创建一个新的 MBeanServer 实现对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.MBeanServerDelegateMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.MBeanServerDelegateMBean
的使用

使用 MBeanServerDelegateMBean 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 MBeanServerDelegateMBean 的使用

实现 MBeanServerDelegateMBean 的 javax.management 中的类
 class MBeanServerDelegate
从管理的角度表示 MBean 服务器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanServerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerFactory
的使用

没有 javax.management.MBeanServerFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanServerInvocationHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerInvocationHandler
的使用

没有 javax.management.MBeanServerInvocationHandler 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanServerNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerNotification
的使用

没有 javax.management.MBeanServerNotification 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanServerPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanServerPermission
的使用

没有 javax.management.MBeanServerPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MBeanTrustPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MBeanTrustPermission
的使用

没有 javax.management.MBeanTrustPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MXBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MXBean
的使用

没有 javax.management.MXBean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.MalformedObjectNameException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.MalformedObjectNameException
的使用

使用 MalformedObjectNameException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 MalformedObjectNameException 的使用

抛出 MalformedObjectNameException 的 javax.management 中的方法
static ObjectName ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。

抛出 MalformedObjectNameException 的 javax.management 中的构造方法
ObjectInstance(String objectName, String className)
允许创建具有给定字符串表示形式的对象名和完整类名（包括包名）的ｏbjectInstance。
ObjectName(String name)
根据给定的字符串构造一个对象名。
ObjectName(String domain, Hashtable<String,String> table)
构造一个对象名，它具有根据哈希表获得的多个键属性。
ObjectName(String domain, String key, String value)
构造只具有一个键属性的对象名。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.NotCompliantMBeanException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.NotCompliantMBeanException
的使用

使用 NotCompliantMBeanException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 NotCompliantMBeanException 的使用

抛出 NotCompliantMBeanException 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
void | StandardMBean.setImplementation(Object implementation) 替换包装在此对象中的实现对象。

抛出 NotCompliantMBeanException 的 javax.management 中的构造方法
StandardMBean(Class<?> mbeanInterface)
使用指定的 mbeanInterface 类从 this 中生成 DynamicMBean。
StandardMBean(T implementation, Class<T> mbeanInterface)
使用指定的 mbeanInterface 类从对象 implementation 中生成 DynamicMBean。

javax.management.relation 中 NotCompliantMBeanException 的使用

抛出 NotCompliantMBeanException 的 javax.management.relation 中的构造方法
RoleInfo(String roleName, String mbeanClassName)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write)
构造方法。
RoleInfo(String roleName, String mbeanClassName, boolean read, boolean write, int min, int max, String descr)
构造方法。

javax.management.remote.rmi 中 NotCompliantMBeanException 的使用

抛出 NotCompliantMBeanException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.Notification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.Notification
的使用

使用 Notification 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 Notification 的使用

javax.management 中 Notification 的子类
class | AttributeChangeNotification 提供 MBean 所发送的属性更改通知的定义。
class | MBeanServerNotification 表示 MBean 服务器通过 MBeanServerDelegate MBean 所发出的通知。

参数类型为 Notification 的 javax.management 中的方法
protected void | NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback) 为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。
void | NotificationListener.handleNotification(Notification notification, Object handback) 出现 JMX 通知时调用。
boolean | AttributeChangeNotificationFilter.isNotificationEnabled(Notification notification) 向侦听器发送指定的通知之前调用。
boolean | NotificationFilter.isNotificationEnabled(Notification notification) 向侦听器发送指定通知前调用。
boolean | NotificationFilterSupport.isNotificationEnabled(Notification notification) 向侦听器发送指定的通知前调用。
void | MBeanServerDelegate.sendNotification(Notification notification) 允许 MBean 服务器发送通知。
void | NotificationBroadcasterSupport.sendNotification(Notification notification) 发送一个通知。
void | StandardEmitterMBean.sendNotification(Notification n) 发送通知。

javax.management.modelmbean 中 Notification 的使用

参数类型为 Notification 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(Notification ntfyObj)

javax.management.monitor 中 Notification 的使用

javax.management.monitor 中 Notification 的子类
 class MonitorNotification
提供对监视器 MBean 发送的通知的定义。

javax.management.relation 中 Notification 的使用

javax.management.relation 中 Notification 的子类
 class RelationNotification
Relation Service（关系服务）中的更改通知。

参数类型为 Notification 的 javax.management.relation 中的方法
void | RelationService.handleNotification(Notification notif, Object handback) 出现 JMX 通知时调用。
boolean | MBeanServerNotificationFilter.isNotificationEnabled(Notification notif) 向侦听器发送指定通知之前调用。

javax.management.remote 中 Notification 的使用

javax.management.remote 中 Notification 的子类
 class JMXConnectionNotification
在客户端连接打开或关闭时，或者当通知丢失时发出的通知。

返回 Notification 的 javax.management.remote 中的方法
 Notification TargetedNotification.getNotification()
发出的通知。

参数类型为 Notification 的 javax.management.remote 中的构造方法
TargetedNotification(Notification notification, Integer listenerID)
构造一个 TargetedNotification 对象。

javax.management.timer 中 Notification 的使用

javax.management.timer 中 Notification 的子类
 class TimerNotification
此类定义了由计时器 MBean 发送的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.NotificationBroadcaster 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationBroadcaster
的使用

使用 NotificationBroadcaster 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 NotificationBroadcaster 的使用

javax.management 中 NotificationBroadcaster 的子接口
 interface NotificationEmitter
由发出 Notifications 的 MBean 实现的接口。

实现 NotificationBroadcaster 的 javax.management 中的类
class | MBeanServerDelegate 从管理的角度表示 MBean 服务器。
class | NotificationBroadcasterSupport 提供 NotificationEmitter 接口的实现。
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

javax.management.modelmbean 中 NotificationBroadcaster 的使用

javax.management.modelmbean 中 NotificationBroadcaster 的子接口
interface | ModelMBean ModelMBean 必须实现此接口。
interface | ModelMBeanNotificationBroadcaster ModelMBean 必须实现此接口。

实现 NotificationBroadcaster 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

javax.management.monitor 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 NotificationBroadcaster 的使用

实现 NotificationBroadcaster 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.NotificationBroadcasterSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.NotificationBroadcasterSupport
的使用

使用 NotificationBroadcasterSupport 的软件包
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management.monitor 中 NotificationBroadcasterSupport 的使用

javax.management.monitor 中 NotificationBroadcasterSupport 的子类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 NotificationBroadcasterSupport 的使用

javax.management.relation 中 NotificationBroadcasterSupport 的子类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationBroadcasterSupport 的使用

javax.management.remote 中 NotificationBroadcasterSupport 的子类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 NotificationBroadcasterSupport 的使用

javax.management.remote.rmi 中 NotificationBroadcasterSupport 的子类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 NotificationBroadcasterSupport 的使用

javax.management.timer 中 NotificationBroadcasterSupport 的子类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.NotificationEmitter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationEmitter
的使用

使用 NotificationEmitter 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management 中的类
class | MBeanServerDelegate 从管理的角度表示 MBean 服务器。
class | NotificationBroadcasterSupport 提供 NotificationEmitter 接口的实现。
class | StandardEmitterMBean 一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

参数类型为 NotificationEmitter 的 javax.management 中的构造方法
StandardEmitterMBean(Class<?> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(Class<?> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, boolean isMXBean, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。
StandardEmitterMBean(T implementation, Class<T> mbeanInterface, NotificationEmitter emitter)
构造一个 MBean，其管理接口由 mbeanInterface 使用给定实现指定，并且其中的通知由给定的 NotificationEmitter 处理。

javax.management.modelmbean 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

javax.management.monitor 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.monitor 中的类
class | CounterMonitor 定义专门用来观察计数器属性值的监视器 MBean。
class | GaugeMonitor 定义专门用来观察尺度属性值的监视器 MBean。
class | Monitor 定义所有监视器 MBean 的公共部分。
class | StringMonitor 定义设计用于观察字符串属性值的监视器 MBean。

javax.management.relation 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.remote 中的类
 class JMXConnectorServer
每个连接器服务器的超类。

javax.management.remote.rmi 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.remote.rmi 中的类
 class RMIConnectorServer
JMX API 连接器服务器，用于从远程客户端创建基于 RMI 的连接。

javax.management.timer 中 NotificationEmitter 的使用

实现 NotificationEmitter 的 javax.management.timer 中的类
 class Timer
提供对计时器 MBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.NotificationFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationFilter
的使用

使用 NotificationFilter 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 NotificationFilter 的使用

实现 NotificationFilter 的 javax.management 中的类
class | AttributeChangeNotificationFilter 此类实现 attribute change notification 的 NotificationFilter 接口。
class | NotificationFilterSupport 提供 NotificationFilter 接口的实现。

参数类型为 NotificationFilter 的 javax.management 中的方法
void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
void | NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个侦听器。
void | StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。

javax.management.modelmbean 中 NotificationFilter 的使用

参数类型为 NotificationFilter 的 javax.management.modelmbean 中的方法
void | RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.relation 中 NotificationFilter 的使用

实现 NotificationFilter 的 javax.management.relation 中的类
 class MBeanServerNotificationFilter
MBeanServerNotification 的过滤器。

javax.management.remote 中 NotificationFilter 的使用

参数类型为 NotificationFilter 的 javax.management.remote 中的方法
void | JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个接收连接状态改变的侦听器。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。

javax.management.remote.rmi 中 NotificationFilter 的使用

参数类型为 NotificationFilter 的 javax.management.remote.rmi 中的方法
void | RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.NotificationFilterSupport 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.NotificationFilterSupport
的使用

使用 NotificationFilterSupport 的软件包
javax.management.relation 提供 Relation Service 的定义。

javax.management.relation 中 NotificationFilterSupport 的使用

javax.management.relation 中 NotificationFilterSupport 的子类
 class MBeanServerNotificationFilter
MBeanServerNotification 的过滤器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.NotificationListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.NotificationListener
的使用

使用 NotificationListener 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management 中的方法
void | MBeanServerDelegate.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcaster.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 在此 MBean 中添加一个侦听器。
void | NotificationBroadcasterSupport.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个侦听器。
void | StandardEmitterMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 向已注册的 MBean 添加一个侦听器。
protected void | NotificationBroadcasterSupport.handleNotification(NotificationListener listener, Notification notif, Object handback) 为了向侦听器发送通知，由该侦听器的 sendNotification 调用此方法。
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener)
void | NotificationBroadcaster.removeNotificationListener(NotificationListener listener) 从此 MBean 移除一个侦听器。
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener)
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener)
void | MBeanServerDelegate.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationBroadcasterSupport.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | NotificationEmitter.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 从此 MBean 移除一个侦听器。
void | StandardEmitterMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener) 从已注册的 MBean 中移除一个侦听器。
void | MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
void | MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback) 从已注册的 MBean 中移除一个侦听器。

javax.management.modelmbean 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
void | RequiredModelMBean.addNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener) 从 RequiredModelMBean 移除一个 Notification 的侦听器。
void | RequiredModelMBean.removeNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

javax.management.relation 中 NotificationListener 的使用

实现 NotificationListener 的 javax.management.relation 中的类
 class RelationService
Relation Service 负责创建和删除关系类型和关系，负责处理一致性并负责提供查询机制。

javax.management.remote 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management.remote 中的方法
void | JMXConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback) 添加一个接收连接状态改变的侦听器。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener listener) 将一个用于接收状态更改通知的侦听器从列表中移除。
void | JMXConnector.removeConnectionNotificationListener(NotificationListener l, NotificationFilter f, Object handback) 将一个用于接收状态更改通知的侦听器从列表中移除。

javax.management.remote.rmi 中 NotificationListener 的使用

参数类型为 NotificationListener 的 javax.management.remote.rmi 中的方法
void | RMIConnector.addConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)
void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener)
void | RMIConnector.removeConnectionNotificationListener(NotificationListener listener, NotificationFilter filter, Object handback)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.ObjectInstance 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ObjectInstance
的使用

使用 ObjectInstance 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 ObjectInstance 的使用

返回 ObjectInstance 的 javax.management 中的方法
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
ObjectInstance | MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature) 在 MBean 服务器中实例化并注册一个 MBean。
ObjectInstance | MBeanServer.getObjectInstance(ObjectName name)
ObjectInstance | MBeanServerConnection.getObjectInstance(ObjectName name) 获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
ObjectInstance | MBeanServer.registerMBean(Object object, ObjectName name) 将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。

返回变量类型为 ObjectInstance 的类型的 javax.management 中的方法
Set<ObjectInstance> | MBeanServer.queryMBeans(ObjectName name, QueryExp query)
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。

javax.management.remote.rmi 中 ObjectInstance 的使用

返回 ObjectInstance 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

返回变量类型为 ObjectInstance 的类型的 javax.management.remote.rmi 中的方法
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.ObjectName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ObjectName
的使用

使用 ObjectName 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.loading | 提供实现高级动态加载的类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.monitor | 提供 monitor 类的定义。
javax.management.openmbean | 提供开放数据类型和 Open MBean 描述符类。
javax.management.relation | 提供 Relation Service 的定义。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.management.timer | 提供对 Timer MBean（计时器 MBean）的定义。

javax.management 中 ObjectName 的使用

声明为 ObjectName 的 javax.management 中的字段
static ObjectName | MBeanServerDelegate.DELEGATE_NAME 定义 MBeanServerDelegate 的默认 ObjectName。
static ObjectName | ObjectName.WILDCARD 定义通配符 "*:*" ObjectName。

返回 ObjectName 的 javax.management 中的方法
static ObjectName ObjectName.getInstance(ObjectName name)
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
static ObjectName ObjectName.getInstance(String name)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(name) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, Hashtable<String,String> table)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, table) 获得的对象可以使用的地方。
static ObjectName ObjectName.getInstance(String domain, String key, String value)
返回 ObjectName 的实例，该 ObjectName 可用于任何使用 new ObjectName(domain, key, value) 获得的对象可以使用的地方。
 ObjectName MBeanServerNotification.getMBeanName()
返回导致该通知的 MBean 的对象名。
 ObjectName MBeanServerInvocationHandler.getObjectName()
MBean 服务器中 MBean 的名称，一些方法将转发到该 MBean。
 ObjectName ObjectInstance.getObjectName()
返回对象名部分。
 ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
 ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。

返回变量类型为 ObjectName 的类型的 javax.management 中的方法
Set<ObjectName> | MBeanServer.queryNames(ObjectName name, QueryExp query)
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。

参数类型为 ObjectName 的 javax.management 中的方法
 void MBeanServer.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.addNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。
 void MBeanServer.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.addNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
向已注册的 MBean 添加一个侦听器。
 ValueExp AttributeValueExp.apply(ObjectName name)
在 MBean 上应用 AttributeValueExp。
 boolean ObjectName.apply(ObjectName name)
测试此 ObjectName（可以是一个模式）是否与另一个 ObjectName 匹配。
 boolean QueryExp.apply(ObjectName name)
在 MBean 上应用 QueryExp。
 ValueExp StringValueExp.apply(ObjectName name)
在 MBean 上应用 ValueExp。
 ValueExp ValueExp.apply(ObjectName name)
在 MBean 上应用 ValueExp。
 int ObjectName.compareTo(ObjectName name)
比较两个 ObjectName 实例。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。
protected  Object AttributeValueExp.getAttribute(ObjectName name)
返回指定的 MBean 中给定属性的值。
 Object MBeanServer.getAttribute(ObjectName name, String attribute)
 Object MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。
 AttributeList MBeanServer.getAttributes(ObjectName name, String[] attributes)
 AttributeList MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
获得指定 MBean 的多个属性值。
 ClassLoader MBeanServer.getClassLoader(ObjectName loaderName)
返回指定的 ClassLoader。
 ClassLoader MBeanServer.getClassLoaderFor(ObjectName mbeanName)
返回用于加载指定 MBean 的类的 ClassLoader。
static ObjectName ObjectName.getInstance(ObjectName name)
返回 ObjectName 的实例，该 ObjectName 可用于任何可使用给定对象的地方。
 MBeanInfo MBeanServer.getMBeanInfo(ObjectName name)
 MBeanInfo MBeanServerConnection.getMBeanInfo(ObjectName name)
此方法发现了 MBean 为管理而公开的属性和操作。
 ObjectInstance MBeanServer.getObjectInstance(ObjectName name)
 ObjectInstance MBeanServerConnection.getObjectInstance(ObjectName name)
获得向 MBean 服务器注册的给定 MBean 的 ObjectInstance。
 Object MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
 Object MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。
 Object MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
 Object MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。
 boolean MBeanServer.isInstanceOf(ObjectName name, String className)
 boolean MBeanServerConnection.isInstanceOf(ObjectName name, String className)
如果指定的 MBean 是指定类的一个实例，则返回 true；否则返回 false。
 boolean MBeanServer.isRegistered(ObjectName name)
 boolean MBeanServerConnection.isRegistered(ObjectName name)
检查某个 MBean（通过其对象名标识）是否已向 MBean 服务器注册。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 Standard MBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass)
在本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
JMX.newMXBeanProxy(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
在同样支持 NotificationEmitter 方法的本地或远程 MBean Server 中为 MXBean 构造一个代理。
static
<T> T
MBeanServerInvocationHandler.newProxyInstance(MBeanServerConnection connection, ObjectName objectName, Class<T> interfaceClass, boolean notificationBroadcaster)
返回一个代理，该代理通过将其方法从给定 MBean 服务器转发到指定 MBean 来实现给定的接口。
 ObjectName MBeanRegistration.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在被注册到 MBean 服务器之前执行它所需要的任何操作。
 ObjectName StandardMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在 MBean 服务器中注册之前执行任何它所需要的操作。
 Set<ObjectInstance> MBeanServer.queryMBeans(ObjectName name, QueryExp query)
 Set<ObjectInstance> MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query)
获得该 MBean 服务器所控制的 MBean。
 Set<ObjectName> MBeanServer.queryNames(ObjectName name, QueryExp query)
 Set<ObjectName> MBeanServerConnection.queryNames(ObjectName name, QueryExp query)
获得该 MBean 服务器所控制的 MBean 的名称。
 ObjectInstance MBeanServer.registerMBean(Object object, ObjectName name)
将某个预先存在的对象作为 MBean 注册到 MBean 服务器中。
 void MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, NotificationListener listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
 void MBeanServerConnection.removeNotificationListener(ObjectName name, ObjectName listener, NotificationFilter filter, Object handback)
从已注册的 MBean 中移除一个侦听器。
 void MBeanServer.setAttribute(ObjectName name, Attribute attribute)
 void MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute)
设置指定 MBean 的特定属性值。
 AttributeList MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
 AttributeList MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes)
设置指定 MBean 的多个属性值。
 void MBeanServer.unregisterMBean(ObjectName name)
 void MBeanServerConnection.unregisterMBean(ObjectName name)
从 MBean 服务器中注销一个 MBean。

参数类型为 ObjectName 的 javax.management 中的构造方法
MBeanPermission(String className, String member, ObjectName objectName, String actions)
创建具有指定目标名称（类名、成员、对象名）和操作的 MBeanPermission 对象。
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName)
通过 MBean 服务器将方法转发给 Standard MBean 的调用处理程序。
MBeanServerInvocationHandler(MBeanServerConnection connection, ObjectName objectName, boolean isMXBean)
可以通过 MBean 服务器将方法转发给 Standard MBean 或 MXBean 的调用处理程序。
MBeanServerNotification(String type, Object source, long sequenceNumber, ObjectName objectName)
创建一个指定了导致该通知的 MBean 对象名和指定通知类型的 MBeanServerNotification 对象。
ObjectInstance(ObjectName objectName, String className)
允许创建具有给定对象名和完整类名（包括包名）的 ObjectInstance。

javax.management.loading 中 ObjectName 的使用

返回 ObjectName 的 javax.management.loading 中的方法
 ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

参数类型为 ObjectName 的 javax.management.loading 中的方法
 ObjectName MLet.preRegister(MBeanServer server, ObjectName name)
允许在将 m-let 注册到 MBean 之前执行任何所需要的操作。

javax.management.modelmbean 中 ObjectName 的使用

返回 ObjectName 的 javax.management.modelmbean 中的方法
 ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

参数类型为 ObjectName 的 javax.management.modelmbean 中的方法
 ObjectName RequiredModelMBean.preRegister(MBeanServer server, ObjectName name)
允许 MBean 在注册到 MBean 服务器之前执行任何所需要的操作。

javax.management.monitor 中 ObjectName 的使用

返回 ObjectName 的 javax.management.monitor 中的方法
 ObjectName Monitor.getObservedObject()
已过时。 从 JMX 1.2 开始，由 Monitor.getObservedObjects() 取代
 ObjectName MonitorMBean.getObservedObject()
已过时。 从 JMX 1.2 开始，由 MonitorMBean.getObservedObjects() 取代
 ObjectName MonitorNotification.getObservedObject()
获取此监视器通知的被观察对象。
 ObjectName[] Monitor.getObservedObjects()
返回一个包含要观察的对象的数组。
 ObjectName[] MonitorMBean.getObservedObjects()
返回一个包含要观察的对象的数组。
 ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。

参数类型为 ObjectName 的 javax.management.monitor 中的方法
 void Monitor.addObservedObject(ObjectName object)
如果尚未显示此对象，则在观察到的 MBean 集中添加指定的对象。
 void MonitorMBean.addObservedObject(ObjectName object)
将指定的对象添加到所观察的 MBean 集中。
 boolean Monitor.containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。
 boolean MonitorMBean.containsObservedObject(ObjectName object)
测试指定的对象是否在所观察的 MBean 集中。
 Number CounterMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number CounterMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 Number GaugeMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象派生的尺度，否则将为 null。
 Number GaugeMonitorMBean.getDerivedGauge(ObjectName object)
获取指定的 MBean 的派生尺度。
 String StringMonitor.getDerivedGauge(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生的尺度，否则将为 null。
 String StringMonitorMBean.getDerivedGauge(ObjectName object)
获取指定 MBean 的派生尺度。
 long CounterMonitor.getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
 long CounterMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。
 long GaugeMonitor.getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在所观察的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
 long GaugeMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。
 long StringMonitor.getDerivedGaugeTimeStamp(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取此对象的派生尺度的时间戳，否则将为 0。
 long StringMonitorMBean.getDerivedGaugeTimeStamp(ObjectName object)
获取指定 MBean 的派生尺度时间戳。
 Number CounterMonitor.getThreshold(ObjectName object)
如果指定的对象包含在观察到的 MBeans 集中，则获取指定对象的当前阈值，否则将为 null。
 Number CounterMonitorMBean.getThreshold(ObjectName object)
获取指定 MBean 的阈值。
 ObjectName Monitor.preRegister(MBeanServer server, ObjectName name)
允许在 MBean 服务器中注册监视器 MBean 之前执行任何监视器 MBean 所需要的操作。
 void Monitor.removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。
 void MonitorMBean.removeObservedObject(ObjectName object)
从所观察的 MBean 集中移除指定的对象。
 void Monitor.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 Monitor.addObservedObject(javax.management.ObjectName) 取代
 void MonitorMBean.setObservedObject(ObjectName object)
已过时。 从 JMX 1.2 开始，由 MonitorMBean.addObservedObject(javax.management.ObjectName) 取代

javax.management.openmbean 中 ObjectName 的使用

类型参数类型为 ObjectName 的 javax.management.openmbean 中的字段
static SimpleType<ObjectName> SimpleType.OBJECTNAME
SimpleType 实例，该实例描述其 Java 类名称为 javax.management.ObjectName 的值。

javax.management.relation 中 ObjectName 的使用

返回 ObjectName 的 javax.management.relation 中的方法
ObjectName | RelationNotification.getObjectName() 返回创建/移除/更新的关系的 ObjectName。
ObjectName | Relation.getRelationServiceName() 返回处理关系的 Relation Service 的 ObjectName。
ObjectName | RelationSupport.getRelationServiceName() 返回处理关系的 Relation Service 的 ObjectName。
ObjectName | RelationService.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationServiceMBean.isRelationMBean(String relationId) 如果用 MBean 表示关系（由用户创建且作为 Relation Service 中的关系添加），则返回该 MBean 的 ObjectName。
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

返回变量类型为 ObjectName 的类型的 javax.management.relation 中的方法
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Vector<ObjectName> | MBeanServerNotificationFilter.getDisabledObjectNames() 获取禁用的所有 ObjectName。
Vector<ObjectName> | MBeanServerNotificationFilter.getEnabledObjectNames() 获取所有已启用的 ObjectName。
List<ObjectName> | RelationNotification.getMBeansToUnregister() 返回因为关系移除而需要注销的 MBean 的 ObjectName 列表（仅限于关系移除）。
List<ObjectName> | RelationNotification.getNewRoleValue() 返回更新的角色的新值（仅限于角色更新）。
List<ObjectName> | RelationNotification.getOldRoleValue() 返回更新的角色的旧值（仅限于角色更新）。
Map<ObjectName,List<String>> | Relation.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationSupport.getReferencedMBeans() 检索在该关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationService.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.getReferencedMBeans(String relationId) 检索关系的各种角色中引用的 MBean。
List<ObjectName> | Relation.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationSupport.getRole(String roleName) 检索给定角色名称的角色值。
List<ObjectName> | RelationService.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | RelationServiceMBean.getRole(String relationId, String roleName) 检索给定关系中给定角色名称的角色值。
List<ObjectName> | Role.getRoleValue() 检索角色值。
List<ObjectName> | RoleUnresolved.getRoleValue() 检索角色值。

参数类型为 ObjectName 的 javax.management.relation 中的方法
void | RelationService.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | RelationServiceMBean.addRelation(ObjectName relationObjectName) 作为 Relation Service 中的关系添加由用户创建（且由其在 MBean Server 中注册）的 MBean。
void | MBeanServerNotificationFilter.disableObjectName(ObjectName objectName) 禁用与给定 ObjectName 有关的 MBeanServerNotification。
void | MBeanServerNotificationFilter.enableObjectName(ObjectName objectName) 启用与给定 ObjectName 有关的 MBeanServerNotification。
Map<ObjectName,List<String>> | RelationService.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<ObjectName,List<String>> | RelationServiceMBean.findAssociatedMBeans(ObjectName mbeanName, String relationTypeName, String roleName) 检索与关系中给定关系相关的 MBean。
Map<String,List<String>> | RelationService.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在引用给定 MBean 的引用关系。
Map<String,List<String>> | RelationServiceMBean.findReferencingRelations(ObjectName mbeanName, String relationTypeName, String roleName) 检索在其中引用给定 MBean 的关系。
void | Relation.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
void | RelationSupport.handleMBeanUnregistration(ObjectName objectName, String roleName) 在注销角色中引用的 MBean 时由 Relation Service 使用的回调。
String | RelationService.isRelation(ObjectName objectName) 如果已经将 MBean 作为关系添加在 Relation Service 中，则返回与给定 ObjectName 相关的关系 id。
String | RelationServiceMBean.isRelation(ObjectName objectName) 如果 Relation Service 中作为关系添加 MBean，则返回与给定 ObjectName 相关的关系 id。
ObjectName | RelationService.preRegister(MBeanServer server, ObjectName name)
ObjectName | RelationSupport.preRegister(MBeanServer server, ObjectName name)

类型变量类型为 ObjectName 的 javax.management.relation 中的方法参数
static String | Role.roleValueToString(List<ObjectName> roleValue) 返回给定角色值的字符串。
void | RelationService.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationServiceMBean.sendRelationRemovalNotification(String relationId, List<ObjectName> unregMBeanList) 发送关系移除通知 (RelationNotification)。
void | RelationService.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | RelationServiceMBean.sendRoleUpdateNotification(String relationId, Role newRole, List<ObjectName> oldRoleValue) 发送给定关系中的角色更新通知 (RelationNotification)。
void | Role.setRoleValue(List<ObjectName> roleValue) 设置角色值。
void | RoleUnresolved.setRoleValue(List<ObjectName> value) 设置角色值。
void | RelationService.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。
void | RelationServiceMBean.updateRoleMap(String relationId, Role newRole, List<ObjectName> oldRoleValue) 针对给定关系中给定角色的更新来处理 Relation Service 角色映射的更新。

参数类型为 ObjectName 的 javax.management.relation 中的构造方法
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationSupport(String relationId, ObjectName relationServiceName, MBeanServer relationServiceMBeanServer, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。
RelationSupport(String relationId, ObjectName relationServiceName, String relationTypeName, RoleList list)
创建一个 RelationSupport 对象。

类型变量类型为 ObjectName 的 javax.management.relation 中的构造方法参数
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, List<ObjectName> unregMBeanList)
创建一个关系创建通知（在 Relation Service 中内部创建的 RelationSupport 对象，或者作为关系添加的 MBean），或创建一个从 Relation Service 进行关系移除的通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
RelationNotification(String notifType, Object sourceObj, long sequence, long timeStamp, String message, String id, String typeName, ObjectName objectName, String name, List<ObjectName> newValue, List<ObjectName> oldValue)
为关系中的角色更新创建通知。
Role(String roleName, List<ObjectName> roleValue)
创建一个新的 Role 对象。
RoleUnresolved(String name, List<ObjectName> value, int pbType)
构造方法。

javax.management.remote 中 ObjectName 的使用

返回 ObjectName 的 javax.management.remote 中的方法
 ObjectName JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name)
当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。

参数类型为 ObjectName 的 javax.management.remote 中的方法
 ObjectName JMXConnectorServer.preRegister(MBeanServer mbs, ObjectName name)
当此连接器服务器在 MBean 服务器上注册时，由该 MBean 服务器调用此方法。

javax.management.remote.rmi 中 ObjectName 的使用

返回变量类型为 ObjectName 的类型的 javax.management.remote.rmi 中的方法
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)

参数类型为 ObjectName 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 boolean RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

javax.management.timer 中 ObjectName 的使用

返回 ObjectName 的 javax.management.timer 中的方法
 ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

参数类型为 ObjectName 的 javax.management.timer 中的方法
 ObjectName Timer.preRegister(MBeanServer server, ObjectName name)
允许计时器 MBean 在 MBean 服务器中注册之前执行任何所需的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.OperationsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.OperationsException
的使用

使用 OperationsException 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 OperationsException 的使用

javax.management 中 OperationsException 的子类
class | AttributeNotFoundException 指定的属性不存在或无法检索。
class | InstanceAlreadyExistsException 已经在存储库中注册了 MBean。
class | InstanceNotFoundException 存储库中不存在指定的 MBean。
class | IntrospectionException 在 MBean 的 introspection 期间出现的异常。
class | InvalidAttributeValueException 指定的值对该属性无效。
class | ListenerNotFoundException 存储库中不存在指定的 MBean 侦听器。
class | MalformedObjectNameException 字符串的格式不对应于有效的 ObjectName。
class | NotCompliantMBeanException 尝试在 MBean 服务器中注册一个对象，而该对象不是 JMX 兼容的 MBean 时出现此异常。
class | ServiceNotFoundException 表示请求的服务不受支持时引发的异常。

抛出 OperationsException 的 javax.management 中的方法
 ObjectInputStream MBeanServer.deserialize(ObjectName name, byte[] data)
已过时。 使用 getClassLoaderFor 为反序列化获得合适的类加载器。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.PersistentMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.PersistentMBean
的使用

使用 PersistentMBean 的软件包
javax.management.modelmbean 提供了 ModelMBean 类的定义。

javax.management.modelmbean 中 PersistentMBean 的使用

javax.management.modelmbean 中 PersistentMBean 的子接口
 interface ModelMBean
ModelMBean 必须实现此接口。

实现 PersistentMBean 的 javax.management.modelmbean 中的类
 class RequiredModelMBean
此类是 ModelMBean 的实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.Query 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.Query
的使用

没有 javax.management.Query 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.QueryEval 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.QueryEval
的使用

没有 javax.management.QueryEval 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.QueryExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.QueryExp
的使用

使用 QueryExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 QueryExp 的使用

实现 QueryExp 的 javax.management 中的类
 class ObjectName
表示 MBean 的对象名，或者能够与多个 MBean 名称相匹配的模式。

返回 QueryExp 的 javax.management 中的方法
static QueryExp | Query.and(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“与”。
static QueryExp | Query.anySubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.between(ValueExp v1, ValueExp v2, ValueExp v3) 返回一个查询表达式，表示一个值在其他两个值之间的约束条件。
static QueryExp | Query.eq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的等于约束条件。
static QueryExp | Query.finalSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.geq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。
static QueryExp | Query.gt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于”约束条件。
static QueryExp | Query.in(ValueExp val, ValueExp[] valueList) 返回一个表达式，限制某个值为显式列表中的一项。
static QueryExp | Query.initialSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.isInstanceOf(StringValueExp classNameValue) 返回一个查询表达式，表示基于 MBean 类的继承约束条件。
static QueryExp | Query.leq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。
static QueryExp | Query.lt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示 基于两个值的“小于”约束条件。
static QueryExp | Query.match(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的匹配约束条件。
static QueryExp | Query.not(QueryExp queryExp) 返回一个与其参数相反的约束条件。
static QueryExp | Query.or(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“或”。

参数类型为 QueryExp 的 javax.management 中的方法
static QueryExp | Query.and(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“与”。
static QueryExp | Query.not(QueryExp queryExp) 返回一个与其参数相反的约束条件。
static QueryExp | Query.or(QueryExp q1, QueryExp q2) 返回一个查询表达式，它是其他两个查询表达式的“或”。
Set<ObjectInstance> | MBeanServer.queryMBeans(ObjectName name, QueryExp query)
Set<ObjectInstance> | MBeanServerConnection.queryMBeans(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean。
Set<ObjectName> | MBeanServer.queryNames(ObjectName name, QueryExp query)
Set<ObjectName> | MBeanServerConnection.queryNames(ObjectName name, QueryExp query) 获得该 MBean 服务器所控制的 MBean 的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.ReflectionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ReflectionException
的使用

使用 ReflectionException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。

javax.management 中 ReflectionException 的使用

抛出 ReflectionException 的 javax.management 中的方法
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInstance MBeanServer.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
 ObjectInstance MBeanServerConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Object[] params, String[] signature)
在 MBean 服务器中实例化并注册一个 MBean。
 ObjectInputStream MBeanServer.deserialize(String className, byte[] data)
已过时。 使用 MBeanServer.getClassLoaderRepository() 来获得类加载器存储库并使用它进行反序列化。
 ObjectInputStream MBeanServer.deserialize(String className, ObjectName loaderName, byte[] data)
已过时。 使用 getClassLoader 为反序列化获得类加载器。
 Object MBeanServer.getAttribute(ObjectName name, String attribute)
 Object MBeanServerConnection.getAttribute(ObjectName name, String attribute)
获得指定 MBean 的特定属性值。
 Object DynamicMBean.getAttribute(String attribute)
获得 Dynamic MBean 的特定属性的值。
 Object StandardMBean.getAttribute(String attribute)
 AttributeList MBeanServer.getAttributes(ObjectName name, String[] attributes)
 AttributeList MBeanServerConnection.getAttributes(ObjectName name, String[] attributes)
获得指定 MBean 的多个属性值。
 MBeanInfo MBeanServer.getMBeanInfo(ObjectName name)
 MBeanInfo MBeanServerConnection.getMBeanInfo(ObjectName name)
此方法发现了 MBean 为管理而公开的属性和操作。
 Object MBeanServer.instantiate(String className)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表实例化一个对象。
 Object MBeanServer.instantiate(String className, Object[] params, String[] signature)
使用 MBean 服务器的 Class Loader Repository 中所有已注册的类加载器列表来实例化一个对象。
 Object MBeanServer.instantiate(String className, ObjectName loaderName)
使用由某个对象的 ObjectName 指定的类加载器来实例化该对象。
 Object MBeanServer.instantiate(String className, ObjectName loaderName, Object[] params, String[] signature)
实例化一个对象。
 Object MBeanServer.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
 Object MBeanServerConnection.invoke(ObjectName name, String operationName, Object[] params, String[] signature)
在 MBean 上调用某个操作。
 Object DynamicMBean.invoke(String actionName, Object[] params, String[] signature)
允许在 Dynamic MBean 上调用某个操作。
 Object StandardMBean.invoke(String actionName, Object[] params, String[] signature)
 void DynamicMBean.setAttribute(Attribute attribute)
设置 Dynamic MBean 的特定属性的值。
 void StandardMBean.setAttribute(Attribute attribute)
 void MBeanServer.setAttribute(ObjectName name, Attribute attribute)
 void MBeanServerConnection.setAttribute(ObjectName name, Attribute attribute)
设置指定 MBean 的特定属性值。
 AttributeList MBeanServer.setAttributes(ObjectName name, AttributeList attributes)
 AttributeList MBeanServerConnection.setAttributes(ObjectName name, AttributeList attributes)
设置指定 MBean 的多个属性值。

javax.management.modelmbean 中 ReflectionException 的使用

抛出 ReflectionException 的 javax.management.modelmbean 中的方法
Object | RequiredModelMBean.getAttribute(String attrName) 返回为此 ModelMBean 定义的指定属性的值。
Object | RequiredModelMBean.invoke(String opName, Object[] opArgs, String[] sig) 调用 RequiredModelMBean 上的（或通过它调用）某个方法，并返回方法的执行结果。
void | RequiredModelMBean.setAttribute(Attribute attribute) 设置指定的 ModelMBean 的指定属性值。

javax.management.remote.rmi 中 ReflectionException 的使用

抛出 ReflectionException 的 javax.management.remote.rmi 中的方法
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.RuntimeErrorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.RuntimeErrorException
的使用

没有 javax.management.RuntimeErrorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.RuntimeMBeanException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.RuntimeMBeanException
的使用

没有 javax.management.RuntimeMBeanException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.RuntimeOperationsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.RuntimeOperationsException
的使用

使用 RuntimeOperationsException 的软件包
javax.management | 提供 Java Management Extensions 的核心类。
javax.management.modelmbean | 提供了 ModelMBean 类的定义。

javax.management 中 RuntimeOperationsException 的使用

抛出 RuntimeOperationsException 的 javax.management 中的方法
Object | Descriptor.clone() 返回一个与此描述符相等的描述符。
Object | Descriptor.getFieldValue(String fieldName) 返回指定字段名的值，如果该名称不存在任何值，则返回 null。
boolean | Descriptor.isValid() 如果所有字段在给定其名称的情况下都有合法值，则返回 true。
void | PersistentMBean.load() 使用持久存储中找到的 MBean 的数据实例化此 MBean 实例。
void | Descriptor.setField(String fieldName, Object fieldValue) 设置特定字段名的值。
void | ImmutableDescriptor.setField(String fieldName, Object fieldValue) 因为此类不可变，所以不支持此操作。
void | Descriptor.setFields(String[] fieldNames, Object[] fieldValues) 将字段名称数组中的所有字段设置为与字段值数组中的索引相同的新值。
void | ImmutableDescriptor.setFields(String[] fieldNames, Object[] fieldValues) 因为此类不可变，所以不支持此操作。
void | PersistentMBean.store() 捕获此 MBean 实例的当前状态并将其写出到持久存储中。

javax.management.modelmbean 中 RuntimeOperationsException 的使用

抛出 RuntimeOperationsException 的 javax.management.modelmbean 中的方法
void | ModelMBeanNotificationBroadcaster.addAttributeChangeNotificationListener(NotificationListener listener, String attributeName, Object handback) 注册一个将 NotificationListener 接口实现为侦听器的对象。
void | RequiredModelMBean.addAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName, Object inhandback)
Object | DescriptorSupport.clone() 返回作为 Descriptor 副本的新 Descriptor。
ModelMBeanAttributeInfo | ModelMBeanInfo.getAttribute(String inName) 返回通过名称请求的 ModelMBeanAttributeInfo。
ModelMBeanAttributeInfo | ModelMBeanInfoSupport.getAttribute(String inName)
ModelMBeanConstructorInfo | ModelMBeanInfoSupport.getConstructor(String inName) 返回通过名称请求的 ModelMBeanConstructorInfo。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName) 返回通过名称请求的 Descriptor。
Descriptor | ModelMBeanInfo.getDescriptor(String inDescriptorName, String inDescriptorType) 返回通过 name 和 descriptorType 请求的 Descriptor。
Descriptor | ModelMBeanInfoSupport.getDescriptor(String inDescriptorName, String inDescriptorType)
Descriptor[] | ModelMBeanInfo.getDescriptors(String inDescriptorType) 返回由 inDescriptorType 类型的 ModelMBeanInfo 的所有 Descriptor 组成的 Descriptor 数组。
Descriptor[] | ModelMBeanInfoSupport.getDescriptors(String inDescriptorType)
Object | DescriptorSupport.getFieldValue(String fieldName)
Descriptor | ModelMBeanInfo.getMBeanDescriptor() 返回包含 MBean 级策略的 ModelMBean 的描述符。
ModelMBeanNotificationInfo | ModelMBeanInfo.getNotification(String inName) 返回通过名称请求的 ModelMBeanNotificationInfo。
ModelMBeanNotificationInfo | ModelMBeanInfoSupport.getNotification(String inName)
ModelMBeanOperationInfo | ModelMBeanInfo.getOperation(String inName) 返回通过名称请求的 ModelMBeanOperationInfo。
ModelMBeanOperationInfo | ModelMBeanInfoSupport.getOperation(String inName)
boolean | DescriptorSupport.isValid() 如果所有给定名称的字段都有合法值，则返回 true。
void | RequiredModelMBean.load() 使用在持久存储中找到的 MBean 的数据实例化此 MBean。
void | ModelMBeanNotificationBroadcaster.removeAttributeChangeNotificationListener(NotificationListener listener, String attributeName) 从 RequiredModelMBean 移除一个 attributeChangeNotifications 的侦听器。
void | RequiredModelMBean.removeAttributeChangeNotificationListener(NotificationListener inlistener, String inAttributeName)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(Attribute oldValue, Attribute newValue) 将包含属性的原有值和新值的 attributeChangeNotification 发送到 ModelMBean 上已注册的 AttributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(Attribute inOldVal, Attribute inNewVal)
void | ModelMBeanNotificationBroadcaster.sendAttributeChangeNotification(AttributeChangeNotification notification) 将传入的 attributeChangeNotification 发送到 ModelMBean 上已注册的 attributeChangeNotification 侦听器。
void | RequiredModelMBean.sendAttributeChangeNotification(AttributeChangeNotification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(Notification ntfyObj) 以 jmx.modelmbean.generic 通知形式将传入的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(Notification ntfyObj)
void | ModelMBeanNotificationBroadcaster.sendNotification(String ntfyText) 将包含传入文本字符串的 Notification 发送到 ModelMBean 上已注册的 Notification 侦听器。
void | RequiredModelMBean.sendNotification(String ntfyText)
void | ModelMBeanInfo.setDescriptor(Descriptor inDescriptor, String inDescriptorType) 设置 inDescriptorType 类型的 ModelMBean 的 info 数组中的描述符。
void | ModelMBeanInfoSupport.setDescriptor(Descriptor inDescriptor, String inDescriptorType)
void | ModelMBeanInfo.setDescriptors(Descriptor[] inDescriptors) 添加或替换 ModelMBeanInfo 中的描述符。
void | ModelMBeanInfoSupport.setDescriptors(Descriptor[] inDescriptors)
void | DescriptorSupport.setField(String fieldName, Object fieldValue)
void | DescriptorSupport.setFields(String[] fieldNames, Object[] fieldValues)
void | ModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据此句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descriptor）中的所有方法。
void | RequiredModelMBean.setManagedResource(Object mr, String mr_type) 设置对象的实例句柄，我们将根据该句柄执行此 ModelMBean 管理接口（MBeanInfo 和 Descripto）中的所有方法。
void | ModelMBeanInfo.setMBeanDescriptor(Descriptor inDescriptor) 设置 ModelMBean 的描述符。
void | ModelMBeanInfoSupport.setMBeanDescriptor(Descriptor inMBeanDescriptor)
void | ModelMBean.setModelMBeanInfo(ModelMBeanInfo inModelMBeanInfo) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.setModelMBeanInfo(ModelMBeanInfo mbi) 使用传入的 ModelMBeanInfo 实例化 ModelMBean 对象。
void | RequiredModelMBean.store() 捕获此 MBean 实例的当前状态，并将它写出到持久存储中。

抛出 RuntimeOperationsException 的 javax.management.modelmbean 中的构造方法
DescriptorSupport(int initNumFields)
描述符构造方法。
DescriptorSupport(String inStr)
Descriptor 构造方法带有一个 XML String。
DescriptorSupport(String[] fieldNames, Object[] fieldValues)
带有字段名称和字段值的构造方法。
RequiredModelMBean()
构造带有空 ModelMBeanInfo 的 RequiredModelMBean。
RequiredModelMBean(ModelMBeanInfo mbi)
使用传入的 ModelMBeanInfo 构造 RequiredModelMBean 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.ServiceNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.ServiceNotFoundException
的使用

使用 ServiceNotFoundException 的软件包
javax.management.loading 提供实现高级动态加载的类。

javax.management.loading 中 ServiceNotFoundException 的使用

抛出 ServiceNotFoundException 的 javax.management.loading 中的方法
void | MLet.addURL(String url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
void | MLetMBean.addURL(String url) 将指定的 URL 追加到 URL 列表中，以便搜索类和资源。
Set<Object> | MLet.getMBeansFromURL(String url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(String url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLet.getMBeansFromURL(URL url) 加载一个包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。
Set<Object> | MLetMBean.getMBeansFromURL(URL url) 加载包含 MLET 标记的文本文件，这些标记定义了要添加到 MBean 服务器的 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.StandardEmitterMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.StandardEmitterMBean
的使用

没有 javax.management.StandardEmitterMBean 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.StandardMBean 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.StandardMBean
的使用

使用 StandardMBean 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 StandardMBean 的使用

javax.management 中 StandardMBean 的子类
 class StandardEmitterMBean
一个其管理接口由 Java 接口上的反射确定并且可以发送通知的 MBean。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.management.StringValueExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.management.StringValueExp
的使用

使用 StringValueExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 StringValueExp 的使用

返回 StringValueExp 的 javax.management 中的方法
static StringValueExp Query.value(String val)
返回一个新的字符串表达式。

参数类型为 StringValueExp 的 javax.management 中的方法
static QueryExp | Query.anySubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.finalSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.initialSubString(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的约束条件。
static QueryExp | Query.isInstanceOf(StringValueExp classNameValue) 返回一个查询表达式，表示基于 MBean 类的继承约束条件。
static QueryExp | Query.match(AttributeValueExp a, StringValueExp s) 返回一个查询表达式，表示基于字符串参数的匹配约束条件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.management.ValueExp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.management.ValueExp
的使用

使用 ValueExp 的软件包
javax.management 提供 Java Management Extensions 的核心类。

javax.management 中 ValueExp 的使用

实现 ValueExp 的 javax.management 中的类
class | AttributeValueExp 表示用作关系约束参数的属性。
class | StringValueExp 表示作为关系约束变量的字符串。

返回 ValueExp 的 javax.management 中的方法
ValueExp | AttributeValueExp.apply(ObjectName name) 在 MBean 上应用 AttributeValueExp。
ValueExp | StringValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
ValueExp | ValueExp.apply(ObjectName name) 在 MBean 上应用 ValueExp。
static ValueExp | Query.div(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的商。
ValueExp | BadBinaryOpValueExpException.getExp() 返回产生该异常的 ValueExp。
static ValueExp | Query.minus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的差。
static ValueExp | Query.plus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。
static ValueExp | Query.times(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的乘积。
static ValueExp | Query.value(boolean val) 返回一个 boolean 值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(double val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(float val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(int val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(long val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。
static ValueExp | Query.value(Number val) 返回一个数值表达式，该表达式可用于任何希望获得 ValueExp 的 Query 调用中。

参数类型为 ValueExp 的 javax.management 中的方法
static QueryExp | Query.between(ValueExp v1, ValueExp v2, ValueExp v3) 返回一个查询表达式，表示一个值在其他两个值之间的约束条件。
static ValueExp | Query.div(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的商。
static QueryExp | Query.eq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的等于约束条件。
static QueryExp | Query.geq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于或等于”约束条件。
static QueryExp | Query.gt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“大于”约束条件。
static QueryExp | Query.in(ValueExp val, ValueExp[] valueList) 返回一个表达式，限制某个值为显式列表中的一项。
static QueryExp | Query.in(ValueExp val, ValueExp[] valueList) 返回一个表达式，限制某个值为显式列表中的一项。
static QueryExp | Query.leq(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示基于两个值的“小于或等于”约束条件。
static QueryExp | Query.lt(ValueExp v1, ValueExp v2) 返回一个查询表达式，表示 基于两个值的“小于”约束条件。
static ValueExp | Query.minus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的差。
static ValueExp | Query.plus(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的和，或者两个字符串值的串接。
static ValueExp | Query.times(ValueExp value1, ValueExp value2) 返回一个二进制表达式，表示两个数值的乘积。

参数类型为 ValueExp 的 javax.management 中的构造方法
BadBinaryOpValueExpException(ValueExp exp)
构造带指定 ValueExp 的 BadBinaryOpValueExpException。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AuthenticationException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 AuthenticationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NamingSecurityException
                    继承者  javax.naming.AuthenticationException
所有已实现的接口：
Serializable
public class AuthenticationException
extends NamingSecurityException

当访问命名或目录服务发生验证错误时，抛出此异常。验证错误可能在（举例来说）用户程序提供的证书无效或者其他原因导致对需要命名/目录服务的用户进行验证失败时发生。

如果程序想要单独处理此异常，它应该在试图捕获 NamingException 之前显式捕获 AuthenticationException。在捕获 AuthenticationException 之后，通过使用适当的证书更新已解析上下文的环境属性，该程序可以重新尝试进行验证。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
AuthenticationException()
构造一个新的 AuthenticationException 实例。
AuthenticationException(String explanation)
使用所提供的解释构造一个新的 AuthenticationException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AuthenticationException

public AuthenticationException(String explanation)
使用所提供的解释构造一个新的 AuthenticationException 实例。其他所有字段默认为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

AuthenticationException

public AuthenticationException()
构造一个新的 AuthenticationException 实例。所有字段都被设置为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AuthenticationNotSupportedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 AuthenticationNotSupportedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NamingSecurityException
                    继承者  javax.naming.AuthenticationNotSupportedException
所有已实现的接口：
Serializable
public class AuthenticationNotSupportedException
extends NamingSecurityException

当所请求验证的特定 flavor 不受支持时，抛出此异常。例如，如果程序试图使用强验证，但目录/命名服务只支持简单验证，则将抛出此异常。验证特定 flavor 的标识是特定于提供者和服务器的。它可以使用特定的验证方案指定，比如那些使用 SASL 标识的方案，或者一般验证说明符（比如 "simple" 和 "strong"）。

如果程序想要单独处理此异常，它应该在试图捕获 NamingException 之前显式捕获 AuthenticationNotSupportedException。在捕获 AuthenticationNotSupportedException 之后，通过相应地更新已解析上下文的环境属性，该程序可以使用不同的验证 flavor 重新尝试进行验证。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
AuthenticationNotSupportedException()
构造一个新的 AuthenticationNotSupportedException 实例，将解释和所有名称解析字段初始化为 null。
AuthenticationNotSupportedException(String explanation)
使用解释构造一个新的 AuthenticationNotSupportedException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AuthenticationNotSupportedException

public AuthenticationNotSupportedException(String explanation)
使用解释构造一个新的 AuthenticationNotSupportedException 实例。其他所有字段默认为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

AuthenticationNotSupportedException

public AuthenticationNotSupportedException()
构造一个新的 AuthenticationNotSupportedException 实例，将解释和所有名称解析字段初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BinaryRefAddr (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 BinaryRefAddr

java.lang.Object
    继承者  javax.naming.RefAddr
        继承者  javax.naming.BinaryRefAddr
所有已实现的接口：
Serializable
public class BinaryRefAddr
extends RefAddr

此类表示通信终端地址的二进制形式。

BinaryRefAddr 由描述通信机制的类型和包含特定于该通信机制的地址描述的不透明缓冲区组成。地址类型的格式和解释以及不透明缓冲区的内容基于三方的协议，这里的三方为：使用该地址的客户端、使用该地址的可到达对象/服务器，以及创建该地址的管理员或程序。

二进制基准地址 (reference address) 的一个示例是 BER X.500 现行地址 (presentation address)。二进制基准地址的另一个示例是服务的对象句柄的序列化形式。

二进制基准地址是不可变的，因为其字段一经创建就不能被替换。不过，可以访问用来保存不透明缓冲区的字节数组。强烈建议程序不要更改此字节数组。对此字节数组的更改需要被显式同步。

从以下版本开始：
1.3
另请参见：
RefAddr, StringRefAddr, 序列化表格

字段摘要
从类 javax.naming.RefAddr 继承的字段
addrType
构造方法摘要
BinaryRefAddr(String addrType, byte[] src)
使用地址类型和用于内容的字节数组构造一个新的 BinaryRefAddr 实例。
BinaryRefAddr(String addrType, byte[] src, int offset, int count)
使用地址类型和用于内容的字节数组区域构造一个新的 BinaryRefAddr 实例。
方法摘要
boolean | equals(Object obj) 确定 obj 是否等于此地址。
Object | getContent() 以 Object 形式检索此地址的内容。
int | hashCode() 使用地址类型和内容计算此地址的哈希码。
String | toString() 生成此地址的字符串表示形式。
从类 javax.naming.RefAddr 继承的方法
getType
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

BinaryRefAddr

public BinaryRefAddr(String addrType,
                     byte[] src)
使用地址类型和用于内容的字节数组构造一个新的 BinaryRefAddr 实例。

参数：
addrType - 描述地址类型的非 null 字符串。
src - 字节数组形式的非 null 地址内容。src 的内容被复制到新 BinaryRefAddr 中。

BinaryRefAddr

public BinaryRefAddr(String addrType,
                     byte[] src,
                     int offset,
                     int count)
使用地址类型和用于内容的字节数组区域构造一个新的 BinaryRefAddr 实例。

参数：
addrType - 描述地址类型的非 null 字符串。
src - 字节数组形式的非 null 地址内容。src 的内容被复制到新 BinaryRefAddr 中。
offset - src 中的获得字节起始索引。0 <= offset <= src.length。
count - 从 src 中提取的字节数。0 <= count <= src.length-offset。
方法详细信息

getContent

public Object getContent()
以 Object 形式检索此地址的内容。结果是一个字节数组。对此数组的更改将影响此 BinaryRefAddr 的内容。建议程序不要更改此数组的内容，如果需要更改此数组，则建议锁定缓冲区。

指定者：
类 RefAddr 中的 getContent
返回：
包含此地址内容的非 null 缓冲区。

equals

public boolean equals(Object obj)
确定 obj 是否等于此地址。如果 obj 包含相同的地址类型并且两者内容逐字节相等，则其与此对象相等。

覆盖：
类 RefAddr 中的 equals
参数：
obj - 要检查的可能为 null 的对象。
返回：
如果对象是相等的，则返回 true；否则返回 false。
另请参见：
RefAddr.getContent(), RefAddr.getType()

hashCode

public int hashCode()
使用地址类型和内容计算此地址的哈希码。如果两个 BinaryRefAddr 有相同的地址类型和相同的内容，则它们的哈希码相同。不同的 BinaryRefAddr 也可能具有相同的哈希码。

覆盖：
类 RefAddr 中的 hashCode
返回：
此地址的 int 形式的哈希码。
另请参见：
Object.hashCode()

toString

public String toString()
生成此地址的字符串表示形式。该字符串由地址的类型和带标签的内容组成。显示内容的前 32 个字节（以十六进制形式）。如果内容中的字节多于 32 个字节，则用 "..." 指示超出的字节。此字符串用于调试目的，不以编程方式对其进行解释。

覆盖：
类 RefAddr 中的 toString
返回：
此地址的非 null 字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Binding (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 Binding

java.lang.Object
    继承者  javax.naming.NameClassPair
        继承者  javax.naming.Binding
所有已实现的接口：
Serializable
直接已知子类：
SearchResult
public class Binding
extends NameClassPair

此类表示上下文中一个名称到对象的绑定。

上下文由名称到对象的绑定组成。Binding 类表示的就是这种绑定。它由一个名称和一个对象组成。Context.listBindings() 方法返回一个 Binding 枚举。

对于动态生成绑定内容的命名系统，要创建子类。

Binding 实例与多个线程的并发访问不同步。需要并发地访问 Binding 的线程应该在它们之间实现同步并提供所需的锁定。

从以下版本开始：
1.3
另请参见：
序列化表格

构造方法摘要
Binding(String name, Object obj)
在给定其名称和对象的情况下构造一个 Binding 实例。
Binding(String name, Object obj, boolean isRelative)
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。
Binding(String name, String className, Object obj)
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。
Binding(String name, String className, Object obj, boolean isRelative)
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。
方法摘要
String | getClassName() 检索绑定到此绑定名称的对象的类名称。
Object | getObject() 检索绑定到此绑定名称的对象。
void | setObject(Object obj) 设置与此绑定关联的对象。
String | toString() 生成此绑定的字符串表示形式。
从类 javax.naming.NameClassPair 继承的方法
getName, getNameInNamespace, isRelative, setClassName, setName, setNameInNamespace, setRelative
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Binding

public Binding(String name,
               Object obj)
在给定其名称和对象的情况下构造一个 Binding 实例。

如果还没有使用 setClassName() 显式设置类名称，则 getClassName() 将返回 obj 的类名称（或者 null，如果 obj 为 null）。

参数：
name - 对象的非 null 名称。它是相对于目标上下文（由 listBindings() 方法的第一个参数指定）的名称
obj - 绑定到 name 的可能为 null 的对象。
另请参见：
NameClassPair.setClassName(java.lang.String)

Binding

public Binding(String name,
               Object obj,
               boolean isRelative)
在给定其名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

如果还没有使用 setClassName() 显式设置类名称，则 getClassName() 将返回 obj 的类名称（或者 null，如果 obj 为 null）。

参数：
name - 对象的非 null 字符串名称。
obj - 绑定到 name 的可能为 null 的对象。
isRelative - 如果 name 是一个相对于目标上下文（由 listBindings() 方法的第一个参数命名）的名称，则该参数为 true；如果 name 是一个 URL 字符串，则该参数为 false。
另请参见：
NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.setClassName(java.lang.String)

Binding

public Binding(String name,
               String className,
               Object obj)
在给定其名称、类名称和对象的情况下构造一个 Binding 实例。

参数：
name - 对象的非 null 名称。它是相对于目标上下文（由 listBindings() 方法的第一个参数命名）的名称
className - 绑定到 name 的对象的类名称（可能为 null）。如果为 null，则 obj 的类名称由 getClassName() 返回。如果 obj 也为 null，则 getClassName() 将返回 null。
obj - 绑定到 name 的可能为 null 的对象。
另请参见：
NameClassPair.setClassName(java.lang.String)

Binding

public Binding(String name,
               String className,
               Object obj,
               boolean isRelative)
在给定其名称、类名称、对象以及该名称是否是相对名称的情况下构造一个 Binding 实例。

参数：
name - 对象的非 null 字符串名称。
className - 绑定到 name 的对象的类名称（可能为 null）。如果为 null，则 obj 的类名称由 getClassName() 返回。如果 obj 也为 null，则 getClassName() 将返回 null。
obj - 绑定到 name 的可能为 null 的对象。
isRelative - 如果 name 是一个相对于目标上下文（由 listBindings() 方法的第一个参数命名）的名称，则该参数为 true；如果 name 是一个 URL 字符串，则该参数为 false。
另请参见：
NameClassPair.isRelative(),
NameClassPair.setRelative(boolean),
NameClassPair.setClassName(java.lang.String)
方法详细信息

getClassName

public String getClassName()
检索绑定到此绑定名称的对象的类名称。如果已经显式设置该类名称，则返回该名称。如果未显式设置该类名称，且此绑定包含非 null 对象，则使用该对象的类名称。如果未显式设置该类名称，且此绑定不包含非 null 对象，返回 null。

覆盖：
类 NameClassPair 中的 getClassName
返回：
包含所绑定对象的类名称的字符串（可能为 null）。
另请参见：
getObject(),
getClassName(),
NameClassPair.setClassName(java.lang.String)

getObject

public Object getObject()
检索绑定到此绑定名称的对象。

返回：
绑定的对象；如果此绑定没有包含任何对象，则返回 null。
另请参见：
setObject(java.lang.Object)

setObject

public void setObject(Object obj)
设置与此绑定关联的对象。

参数：
obj - 要使用的可能为 null 的对象。
另请参见：
getObject()

toString

public String toString()
生成此绑定的字符串表示形式。该字符串表示形式由名称/类对的字符串表示形式和此绑定对象的表示形式组成，两个表示形式之间用 ':' 分隔。此字符串的内容用于调试目的，不以编程方式对其进行解释。

覆盖：
类 NameClassPair 中的 toString
返回：
此绑定的非 null 字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CannotProceedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 CannotProceedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.CannotProceedException
所有已实现的接口：
Serializable
public class CannotProceedException
extends NamingException

抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。在某一复合名称上执行操作时，命名服务提供者可以到达不属于其名称空间的名称部分。在该点上，它可以构造一个 CannotProceedException，然后调用 javax.naming.spi.NamingManager 提供的方法（比如 getContinuationContext()）来查找另一个提供者，以继续该操作。如果不能完成该过程，则向该上下文操作的调用者引发此异常。

如果程序想要单独处理此异常，它应该在试图捕获 NamingException 之前显式捕获 CannotProceedException。

CannotProceedException 实例与并发多线程访问不同步。尝试访问并修改 CannotProceedException 的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
protected Name | altName 包含已解析对象的名称，该名称相对于上下文 altNameCtx。
protected Context | altNameCtx 包含上下文，altName 是相对于该上下文指定的。
protected Hashtable<?,?> | environment 包含与无法继续进行的 Context 或 DirContext 方法有关的环境。
protected Name | remainingNewName 包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
CannotProceedException()
构造一个新的 CannotProceedException 实例。
CannotProceedException(String explanation)
使用解释构造一个新的 CannotProceedException 实例。
方法摘要
 Name getAltName()
检索此异常的 altName 字段。
 Context getAltNameCtx()
检索此异常的 altNameCtx 字段。
 Hashtable<?,?> getEnvironment()
检索创建此异常时受影响的环境。
 Name getRemainingNewName()
检索此异常的 "remaining new name" 字段，当执行 rename() 操作期间抛出此异常时，将使用该字段。
 void setAltName(Name altName)
设置此异常的 altName 字段。
 void setAltNameCtx(Context altNameCtx)
设置此异常的 altNameCtx 字段。
 void setEnvironment(Hashtable<?,?> environment)
设置调用 getEnvironment() 时将返回的环境。
 void setRemainingNewName(Name newName)
设置此异常的 "remaining new name" 字段。
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

remainingNewName

protected Name remainingNewName
包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。此信息对于继续 Context.rename() 操作是必需的。

此字段被初始化为 null。不应该直接操作它：应该使用 getRemainingName() 和 setRemainingName() 访问和更新。

另请参见：
getRemainingNewName(), setRemainingNewName(javax.naming.Name)

environment

protected Hashtable<?,?> environment
包含与无法继续进行的 Context 或 DirContext 方法有关的环境。

此字段被初始化为 null。不应该直接操作它：应该使用 getEnvironment() 和 setEnvironment() 访问和更新。

另请参见：
getEnvironment(), setEnvironment(java.util.Hashtable)

altName

protected Name altName
包含已解析对象的名称，该名称相对于上下文 altNameCtx。该名称是一个复合名称。如果为 null，则不指定任何名称。有关如何使用此方法的详细信息，请参见 javax.naming.spi.ObjectFactory.getObjectInstance 方法。

此字段被初始化为 null。不应该直接操作它：应该使用 getAltName() 和 setAltName() 访问和更新。

另请参见：
getAltName(), setAltName(javax.naming.Name), altNameCtx, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

altNameCtx

protected Context altNameCtx
包含上下文，altName 是相对于该上下文指定的。如果为 null，则暗指默认初始上下文。有关如何使用此方法的详细信息，请参见 javax.naming.spi.ObjectFactory.getObjectInstance 方法。

此字段被初始化为 null。不应该直接操作它：应该使用 getAltNameCtx() 和 setAltNameCtx() 访问和更新。

另请参见：
getAltNameCtx(), setAltNameCtx(javax.naming.Context), altName, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)
构造方法详细信息

CannotProceedException

public CannotProceedException(String explanation)
使用解释构造一个新的 CannotProceedException 实例。所有未指定字段都默认为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。如果为 null，则此异常没有详细消息。
另请参见：
Throwable.getMessage()

CannotProceedException

public CannotProceedException()
构造一个新的 CannotProceedException 实例。所有字段都默认为 null。

方法详细信息

getEnvironment

public Hashtable<?,?> getEnvironment()
检索创建此异常时受影响的环境。

返回：
可能为 null 的环境属性设置。null 表示没有为此异常记录任何环境。
另请参见：
setEnvironment(java.util.Hashtable)

setEnvironment

public void setEnvironment(Hashtable<?,?> environment)
设置调用 getEnvironment() 时将返回的环境。

参数：
environment - 可能为 null 的环境属性设置。null 表示不会为此异常记录任何环境。
另请参见：
getEnvironment()

getRemainingNewName

public Name getRemainingNewName()
检索此异常的 "remaining new name" 字段，当执行 rename() 操作期间抛出此异常时，将使用该字段。

返回：
尚未解析的可能为 null 的新名称部分。该名称是一个复合名称。它可以为 null，表示剩余的新名称字段尚未设置。
另请参见：
setRemainingNewName(javax.naming.Name)

setRemainingNewName

public void setRemainingNewName(Name newName)
设置此异常的 "remaining new name" 字段。该设置值由 getRemainingNewName() 返回。

newName 是一个复合名称。如果打算使用复合名称或字符串设置此字段，则必须将该复合名称“字符串化”，并用使用该字符串的单个组件创建一个复合名称。然后可以使用得到的复合名称调用此方法。

创建并存储 newName 的副本。对 name 进行的后续更改不会影响此 NamingException 中的副本，反之亦然。

参数：
newName - 可能为 null 的名称，"remaining new name" 将被设置成该名称。如果其为 null，则将剩余的名称字段设置为 null。
另请参见：
getRemainingNewName()

getAltName

public Name getAltName()
检索此异常的 altName 字段。它是已解析对象的名称，该名称相对于上下文 altNameCtx。在后续调用 javax.naming.spi.ObjectFactory.getObjectInstance 方法期间，将使用该名称。

返回：
已解析对象的名称，该名称相对于 altNameCtx。该名称是一个复合名称。如果为 null，则不指定任何名称。
另请参见：
setAltName(javax.naming.Name),
getAltNameCtx(),
ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

setAltName

public void setAltName(Name altName)
设置此异常的 altName 字段。

参数：
altName - 已解析对象的名称，该名称相对于 altNameCtx。该名称是一个复合名称。如果为 null，则不指定任何名称。
另请参见：
getAltName(), setAltNameCtx(javax.naming.Context)

getAltNameCtx

public Context getAltNameCtx()
检索此异常的 altNameCtx 字段。它是一个上下文，altName 就是相对于该上下文指定的。在后续调用 javax.naming.spi.ObjectFactory.getObjectInstance 方法期间，将使用该名称。

返回：
上下文，altName 是相对于该上下文指定的。如果为 null，则暗指默认初始上下文。
另请参见：
setAltNameCtx(javax.naming.Context),
getAltName(),
ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

setAltNameCtx

public void setAltNameCtx(Context altNameCtx)
设置此异常的 altNameCtx 字段。

参数：
altNameCtx - 上下文，altName 是相对于该上下文指定的。如果为 null，则暗指默认初始上下文。
另请参见：
getAltNameCtx(), setAltName(javax.naming.Name)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CommunicationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 CommunicationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.CommunicationException
所有已实现的接口：
Serializable
public class CommunicationException
extends NamingException

当客户端无法与目录或命名服务通信时，抛出此异常。无法与服务通信可能由许多因素导致，比如网络划分、硬件或接口问题、客户机端或服务器端的故障。此异常用于捕获这类通信问题。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
CommunicationException()
构造一个新的 CommunicationException 实例。
CommunicationException(String explanation)
使用所提供的参数构造一个新的 CommunicationException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CommunicationException

public CommunicationException(String explanation)
使用所提供的参数构造一个新的 CommunicationException 实例。

参数：
explanation - 有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

CommunicationException

public CommunicationException()
构造一个新的 CommunicationException 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompositeName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 CompositeName

java.lang.Object
    继承者  javax.naming.CompositeName
所有已实现的接口：
Serializable, Cloneable, Comparable<Object>, Name
public class CompositeName
extends Object
implements Name

此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。每个组件都是一个取自命名系统名称空间的字符串名称。如果组件取自层次名称空间，则可以通过使用 CompoundName 类将该组件进一步解析成其原子部分。

复合名称的组件都已编号。带 N 个组件的复合名称的索引在 0 到 N（但不包括 N）的范围内变动。可将该范围写为 [0,N)。最重要的组件位于索引 0 处。空复合名称没有组件。

JNDI 复合名称语法

JNDI 定义了复合名称的标准字符串表示形式。此表示形式是复合名称组件从左到右的串联，并使用组件分隔符（正斜杠字符 (/)）来分隔每个组件。JNDI 语法定义了以下元字符：
  • 转义符（反斜杠 \），
  • 引用字符（单引号 (') 和双引号 (")），
  • 组件分隔符（正斜杠字符 (/)）。
在将某个组件组合到复合名称字符串中时，在该组件中出现的任何前引号、先于任何元字符的转义符、位于组件末尾的转义符或者结束引用组件中的组件分隔符之前都必须加上转义字符。此外，为了避免像上述那样添加转义字符，可以使用匹配的单引号或匹配的双引号将整个组件放入引号中。出现在双引号引用的组件中的单引号不被认为是元字符（并且无需被转义），反之亦然。

在比较两个复合名称时，字符的大小写很重要。

前导组件分隔符（复合名称字符串以分隔符开始）表示一个前导空组件（由空字符串组成的组件）。尾部组件分隔符（复合名称以分隔符结束）表示一个尾部空组件。相邻的组件分隔符表示一个空组件。

复合名称示例

此表展示了一些复合名称的示例。每一行表示一个复合名称的字符串形式及其相应的结构形式 (CompositeName)。

字符串名称 | CompositeName
"" | {} (the empty name == new CompositeName("") == new CompositeName())
"x" | {"x"}
"x/y" | {"x", "y"}
"x/" | {"x", ""}
"/x" | {"", "x"}
"/" | {""}
"//" | {"", ""}
"/x/" | {"", "x", ""}
"x//y" | {"x", "", "y"}

复合示例

以下是一些复合示例。右边的列展示组合字符串复合名称，左边的列展示组合相应的 CompositeName。注意，组合两个复合名称的字符串形式只需将其字符串形式串联在一起即可。

字符串名称 | CompositeNames
"x/y" + "/" = x/y/ | {"x", "y"} + {""} = {"x", "y", ""}
"" + "x" = "x" | {} + {"x"} = {"x"}
"/" + "x" = "/x" | {""} + {"x"} = {"", "x"}
"x" + "" + "" = "x" | {"x"} + {} + {} = {"x"}

多线程访问

CompositeName 实例与并发多线程访问不同步。试图访问并修改 CompositeName 的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
序列化表格

构造方法摘要
 | CompositeName() 构造一个新的空复合名称。
protected | CompositeName(Enumeration<String> comps) 使用由 'comps' 指定的组件构造一个新的复合名称实例。
 | CompositeName(String n) 通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。
方法摘要
Name | add(int posn, String comp) 在此复合名称中的指定位置添加单个组件。
Name | add(String comp) 将单个组件添加到此复合名称的末尾。
Name | addAll(int posn, Name n) 按顺序将复合名称的组件添加到此复合名称中的指定位置。
Name | addAll(Name suffix) 按顺序将复合名称的组件添加到此复合名称的末尾。
Object | clone() 生成此复合名称的副本。
int | compareTo(Object obj) 比较此 CompositeName 与指定 Object 的顺序。
boolean | endsWith(Name n) 确定某一复合名称是否是此复合名称的后缀。
boolean | equals(Object obj) 确定两个复合名称是否相等。
String | get(int posn) 检索此复合名称的组件。
Enumeration<String> | getAll() 以字符串枚举的形式检索此复合名称的组件。
Name | getPrefix(int posn) 创建一个复合名称，其组件由此复合名称中组件的前缀组成。
Name | getSuffix(int posn) 创建一个复合名称，其组件由此复合名称中组件的后缀组成。
int | hashCode() 计算此复合名称的哈希码。
boolean | isEmpty() 确定此复合名称是否为空。
Object | remove(int posn) 从此复合名称中删除一个组件。
int | size() 检索此复合名称中的组件数。
boolean | startsWith(Name n) 确定某一复合名称是否是此复合名称的前缀。
String | toString() 生成此复合名称的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CompositeName

protected CompositeName(Enumeration<String> comps)
使用由 'comps' 指定的组件构造一个新的复合名称实例。这个受保护的方法将由 CompositeName 的子类在重写一些方法（比如 clone()、getPrefix() 和 getSuffix()）时使用。

参数：
comps - 包含新复合名称组件的非 null 枚举。每个元素都属于 String 类。该枚举将被用来提取其元素。

CompositeName

public CompositeName(String n)
              throws InvalidNameException
通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。复合名称语法在类描述中有详细说明。

参数：
n - 要解析的非 null 字符串。
抛出：
InvalidNameException - 如果 n 的复合名称语法无效。

CompositeName

public CompositeName()
构造一个新的空复合名称。当在此类名称上调用 isEmpty() 时将返回 true。

方法详细信息

toString

public String toString()
生成此复合名称的字符串表示形式。该字符串表示形式通过按顺序枚举复合名称的每个组件并用正斜杠字符分隔每个组件组成。根据 JNDI 语法（该语法在类描述中进行了说明）在必要处使用引用字符和转义字符。空组件用空字符串表示。 如此生成的字符串表示形式可以传递给 CompositeName 构造方法，以创建一个新的等效复合名称。

覆盖：
类 Object 中的 toString
返回：
此复合名称的非 null 字符串表示形式。

equals

public boolean equals(Object obj)
确定两个复合名称是否相等。如果 obj 为 null 或者不是一个复合名称，则返回 false。如果一个复合名称中的每个组件都等于另一个复合名称中的相应组件，则两个复合名称相等。这暗示着两个复合名称有相同数量的组件，并且每个组件与另一个名称中相应组件的 equals() 测试都返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的可能为 null 的对象。
返回：
如果 obj 等于此复合名称，则返回 true，否则返回 false。
另请参见：
hashCode()

hashCode

public int hashCode()
计算此复合名称的哈希码。该哈希码是此复合名称各个组件哈希码的总和。

覆盖：
类 Object 中的 hashCode
返回：
表示此名称的哈希码的 int。
另请参见：
equals(java.lang.Object)

compareTo

public int compareTo(Object obj)
比较此 CompositeName 与指定 Object 的顺序。根据此 Name 小于、等于还是大于指定 Object 分别返回负整数、零或正整数。

如果 obj 为 null 或者不是一个 CompositeName 实例，则抛出 ClassCastException。

关于这对两个复合名称相等性的意义，请参见 equals()。如果两个复合名称是相等的，则返回 0。

复合名称的排序遵从字符串比较的字典规则，并将此扩展到应用于复合名称中的所有组件。效果就像将所有组件按照指定的顺序排列起来，并在两个队列上应用字典规则。如果此复合名称“按字典顺序”小于 obj，则返回一个负数。如果此复合名称“按字典顺序”大于 obj，则返回一个正数。

指定者：
接口 Comparable<Object> 中的 compareTo
指定者：
接口 Name 中的 compareTo
参数：
obj - 要与之比较的非 null 对象。
返回：
根据此 Name 小于、等于还是大于指定 Object 分别返回负整数、零或正整数。
抛出：
ClassCastException - 如果 obj 不是 CompositeName。
另请参见：
Comparable.compareTo(Object)

clone

public Object clone()
生成此复合名称的副本。对此复合名称的组件进行的更改不会影响新副本，反之亦然。

指定者：
接口 Name 中的 clone
覆盖：
类 Object 中的 clone
返回：
此复合名称的非 null 副本。
另请参见：
Cloneable

size

public int size()
检索此复合名称中的组件数。

指定者：
接口 Name 中的 size
返回：
此复合名称中的非负组件数。

isEmpty

public boolean isEmpty()
确定此复合名称是否为空。如果复合名称没有任何组件，则该名称为空。

指定者：
接口 Name 中的 isEmpty
返回：
如果此复合名称为空，则返回 true，否则返回 false。

getAll

public Enumeration<String> getAll()
以字符串枚举的形式检索此复合名称的组件。在此枚举上更新此复合名称的结果是不确定的。

指定者：
接口 Name 中的 getAll
返回：
此复合名称组件的非 null 枚举。每个枚举元素都属于 String 类。

get

public String get(int posn)
检索此复合名称的组件。

指定者：
接口 Name 中的 get
参数：
posn - 要检索的从 0 开始的组件索引。该索引必须在范围 [0,size()) 内。
返回：
位于索引 posn 处的非 null 组件。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。

getPrefix

public Name getPrefix(int posn)
创建一个复合名称，其组件由此复合名称中组件的前缀组成。对此复合名称进行的后续更改不会影响返回的名称。

指定者：
接口 Name 中的 getPrefix
参数：
posn - 从 0 开始的组件索引，在该索引处停止。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [0,posn) 之间的组件组成的复合名称。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。

getSuffix

public Name getSuffix(int posn)
创建一个复合名称，其组件由此复合名称中组件的后缀组成。对此复合名称进行的后续更改不会影响返回的名称。

指定者：
接口 Name 中的 getSuffix
参数：
posn - 从 0 开始的组件索引，在该索引处开始。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [posn,size()) 之间的组件组成的复合名称。如果 posn 等于 size()，则返回一个空复合名称。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。

startsWith

public boolean startsWith(Name n)
确定某一复合名称是否是此复合名称的前缀。如果某一复合名称 'n' 等于 getPrefix(n.size())，则该名称是一个前缀，换句话说，此复合名称从 'n' 开始。如果 'n' 为 null 或者不是一个复合名称，则返回 false。

指定者：
接口 Name 中的 startsWith
参数：
n - 要检查的可能为 null 的名称。
返回：
如果 n 是一个 CompositeName 并且是此复合名称的前缀，则返回 true，否则返回 false。

endsWith

public boolean endsWith(Name n)
确定某一复合名称是否是此复合名称的后缀。如果某一复合名称 'n' 等于 getSuffix(size()-n.size())，则该名称是一个后缀，换句话说，此复合名称以 'n' 结尾。如果 n 为 null 或者不是一个复合名称，则返回 false。

指定者：
接口 Name 中的 endsWith
参数：
n - 要检查的可能为 null 的名称。
返回：
如果 n 是一个 CompositeName 并且是此复合名称的后缀，则返回 true，否则返回 false。

addAll

public Name addAll(Name suffix)
            throws InvalidNameException
按顺序将复合名称的组件添加到此复合名称的末尾。

指定者：
接口 Name 中的 addAll
参数：
suffix - 要添加的非 null 组件。
返回：
已更新的 CompositeName，而不是一个新的 CompositeName。不能为 null。
抛出：
InvalidNameException - 如果后缀不是一个复合名称。

addAll

public Name addAll(int posn,
                   Name n)
            throws InvalidNameException
按顺序将复合名称的组件添加到此复合名称中的指定位置。此复合名称位于第一个新组件的索引处或这之后的组件被上移（远离索引 0），以容纳新组件。

指定者：
接口 Name 中的 addAll
参数：
n - 要添加的非 null 组件。
posn - 此名称中的索引，将在该索引处添加新组件。该索引必须在范围 [0,size()] 内。
返回：
已更新的 CompositeName，而不是一个新的 CompositeName。不能为 null。
抛出：
InvalidNameException - 如果 n 不是一个复合名称。
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。

add

public Name add(String comp)
         throws InvalidNameException
将单个组件添加到此复合名称的末尾。

指定者：
接口 Name 中的 add
参数：
comp - 要添加的非 null 组件。
返回：
已更新的 CompositeName，而不是一个新的 CompositeName。不能为 null。
抛出：
InvalidNameException - 如果在该名称末尾添加 comp 违反该名称的语法。

add

public Name add(int posn,
                String comp)
         throws InvalidNameException
在此复合名称中的指定位置添加单个组件。此复合名称位于新组件的索引处或这之后的组件被上移（远离索引 0）一位，以容纳新组件。

指定者：
接口 Name 中的 add
参数：
comp - 要添加的非 null 组件。
posn - posn 在其所在位置处添加新组件的索引。该索引必须在范围 [0,size()) 内。
返回：
已更新的 CompositeName，而不是一个新的 CompositeName。不能为 null。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。
InvalidNameException - 如果在指定位置添加 comp 违反该名称的语法。

remove

public Object remove(int posn)
              throws InvalidNameException
从此复合名称中删除一个组件。移除此复合名称位置 'posn' 处的组件，而位于大于 'posn' 索引处的组件都将下移（朝着索引 0）一位。

指定者：
接口 Name 中的 remove
参数：
posn - 要删除的组件的索引。该索引必须在范围 [0,size()) 内。
返回：
移除的组件（一个 String）。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围（包括复合名称为空的情况）。
InvalidNameException - 如果删除组件违反该名称的语法。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompoundName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 CompoundName

java.lang.Object
    继承者  javax.naming.CompoundName
所有已实现的接口：
Serializable, Cloneable, Comparable<Object>, Name
public class CompoundName
extends Object
implements Name

此类表示一个组合名称，即一个取自层次名称空间的名称。组合名称中的每个组件都是一个原子名称。

组合名称的组件都已编号。带 N 个组件的组合名称的索引在 0 到 N（但不包括 N）的范围内变动。可将该范围写为 [0,N)。最重要的组件位于索引 0 处。空组合名称没有组件。

组合名称语法

组合名称的语法是使用一组属性指定的：
jndi.syntax.direction
解析的方向（"right_to_left"、"left_to_right" 和 "flat"）。如果未指定，则默认为 "flat"，这意味着名称空间是平面的，没有层次结构。
jndi.syntax.separator
原子名称组件之间的分隔符。在方向不为 "flat" 时需要。
jndi.syntax.ignorecase
如果该属性存在，则 "true" 意味着在比较名称组件时忽略大小写。如果其值不为 "true"，或者该属性不存在，则在比较名称组件时要考虑大小写。
jndi.syntax.escape
如果该属性存在，则指定用于重写分隔符、转义符和引号的转义字符串。
jndi.syntax.beginquote
如果该属性存在，则指定划分所引用字符串开始界限的字符串。
jndi.syntax.endquote
划分所引用字符串的结尾界限的字符串。如果该属性存在，则指定划分所引用字符串结尾界限的字符串。如果该属性不存在，则使用 syntax.beginquote 作为结尾引号。
jndi.syntax.beginquote2
可供选择的一组开始/结束引号。
jndi.syntax.endquote2
可供选择的一组开始/结束引号。
jndi.syntax.trimblanks
如果该属性存在，则 "true" 意味着裁剪名称组件中的所有前导空白和结尾空白，以便于进行比较。如果该属性的值不为 "true"，或者该属性不存在，则空白是有意义的。
jndi.syntax.separator.ava
如果该属性存在，则在指定多个属性/值对时指定分隔属性 - 值 - 断言的字符串。（例如，age=65,gender=male 中的 ","）。
jndi.syntax.separator.typeval
如果该属性存在，则指定分隔属性与值的字符串（例如，"age=65" 中的 "="）。
这些属性都是根据以下规则进行解释的：
  1. 在没有引号或转义符的字符串中，分隔符的任何实例都可以划分两个原子名称的界限。每个原子名称被称为一个组件。
  2. 分隔符、引号或转义符在其前面（左边）直接接有转义符时被转义。
  3. 如果有两组引号，特定的开始引号 (begin-quote) 必须与其相应的结束引号 (end-quote) 匹配。
  4. 位于组件之前的非转义开始引号必须与位于该组件结尾的非转义结束引号匹配。如此引用的组件称为引用组件。如果该组件没有应用下列涉及引用组件的规则之一，则通过移除开始引号和结束引号并将插入的字符视为普通字符来解析该组件。
  5. 嵌入非引用组件中的引号被视为普通字符串，无需匹配。
  6. 被转义或出现在非转移引号之间的分隔符被视为普通字符串，不再是分隔符。
  7. 引用组件中的转义字符串仅在后跟相应结束引用字符串时才是转义符。可以利用这一点将一个转义引号嵌套在引用组件中。
  8. 一个已转义的转义字符串不再被视为转义字符串。
  9. 不位于元字符串（引号或分隔符）之前的转义字符串以及不位于组件结尾处的转义字符串被视为普通字符串。
  10. 前导分隔符（组合名称字符串以分隔符开始）表示一个前导空原子组件（由空字符串组成）。尾部分隔符（组合名称以分隔符结束）表示一个尾部空原子组件。相邻分隔符表示一个空原子组件。

组合名称的字符串形式遵从上述语法。当将组合名称的组件转换成其字符串表示形式时，将应用上述保留语法规则（例如，嵌套的分隔符被转义或引用），以便在解析相同的字符串时，将产生相同的原始组合名称组件。

多线程访问

CompoundName 实例与并发多线程访问不同步。尝试访问并修改 CompoundName 的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
protected javax.naming.NameImpl | impl 此组合名称的实现。
protected Properties | mySyntax 此组合名称的语法属性。
构造方法摘要
protected | CompoundName(Enumeration<String> comps, Properties syntax) 使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。
 | CompoundName(String n, Properties syntax) 通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。
方法摘要
Name | add(int posn, String comp) 在此组合名称中的指定位置添加单个组件。
Name | add(String comp) 将单个组件添加到此组合名称的末尾。
Name | addAll(int posn, Name n) 按顺序将组合名称的组件添加到此组合名称中的指定位置。
Name | addAll(Name suffix) 按顺序将组合名称的组件添加到此组合名称的末尾。
Object | clone() 创建此组合名称的副本。
int | compareTo(Object obj) 比较此 CompoundName 与指定 Object 的顺序。
boolean | endsWith(Name n) 确定某一组合名称是否是此组合名称的后缀。
boolean | equals(Object obj) 确定 obj 在语法上是否等同于此组合名称。
String | get(int posn) 检索此组合名称的组件。
Enumeration<String> | getAll() 以字符串枚举的形式检索此组合名称的组件。
Name | getPrefix(int posn) 创建一个组合名称，其组件由此组合名称中组件的前缀组成。
Name | getSuffix(int posn) 创建一个组合名称，其组件由该组合名称中组件的后缀组成。
int | hashCode() 计算此组合名称的哈希码。
boolean | isEmpty() 确定此组合名称是否为空。
Object | remove(int posn) 从此组合名称中删除一个组件。
int | size() 检索此组合名称中的组件数。
boolean | startsWith(Name n) 确定某一组合名称是否是此组合名称的前缀。
String | toString() 使用组合名称的语法规则生成此组合名称的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

impl

protected transient javax.naming.NameImpl impl
此组合名称的实现。此字段由构造方法初始化，不能为 null。子类应该将其视为只读变量。

mySyntax

protected transient Properties mySyntax
此组合名称的语法属性。此字段由构造方法初始化，不能为 null。子类应该将其视为只读变量。对 mySyntax 进行的所有必要更改都应该在构造方法内而不是实例化组合名称后完成。

构造方法详细信息

CompoundName

protected CompoundName(Enumeration<String> comps,
                       Properties syntax)
使用 comps 和 syntax 指定的组件构造一个新的组合名称实例。这个受保护的方法将由 CompoundName 的子类在重写一些方法（比如 clone()、getPrefix() 和 getSuffix()）时使用。

参数：
comps - 要添加的非 null 组件枚举。该枚举的每个元素都属于 String 类。该枚举将被用来提取其元素。
syntax - 指定此组合名称语法的非 null 属性。有关这些属性的内容，请参阅类描述。

CompoundName

public CompoundName(String n,
                    Properties syntax)
             throws InvalidNameException
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。

参数：
n - 要解析的非 null 字符串。
syntax - 指定此组合名称语法的非 null 属性列表。有关这些属性的内容，请参阅类描述。
抛出：
InvalidNameException - 如果 'n' 违反 syntax 指定的语法。
方法详细信息

toString

public String toString()
使用组合名称的语法规则生成此组合名称的字符串表示形式。这些语法规则已在类描述中说明。空组件用空字符串表示。 如此生成的字符串表示形式可以传递给具有相同 syntax 属性的 CompoundName 构造方法，以创建一个新的等效组合名称。

覆盖：
类 Object 中的 toString
返回：
此组合名称的非 null 字符串表示形式。

equals

public boolean equals(Object obj)
确定 obj 在语法上是否等同于此组合名称。如果 obj 为 null 或者不是一个 CompoundName，则返回 false。如果一个组合名称中的每个组件都“等于”另一个组合名称中的相应组件，则这两个组合名称相等。

相等性也是根据此组合名称的语法定义的。CompoundName 的默认实现在比较两个组件的相等性时使用语法属性 jndi.syntax.ignorecase 和 jndi.syntax.trimblanks。如果忽略大小写，则具有相同字符顺序但大小写不同的两个字符串被认为是相等的。如果将去除空白，则为进行比较将忽略前导空白和结尾空白。

两个组合名称必须有相同的组件数。

实现注意事项：当前，不比较两个组合名称语法属性的相等性。这有可能在以后实现。

覆盖：
类 Object 中的 equals
参数：
obj - 要比较的可能为 null 的对象。
返回：
如果 obj 等于此组合名称，则返回 true，否则返回 false。
另请参见：
compareTo(java.lang.Object obj)

hashCode

public int hashCode()
计算此组合名称的哈希码。该哈希码是此组合名称“规范化”形式的各个组件的哈希码总和。每个组件都在计算其哈希码之前根据组合名称的语法被“规范化”。例如，对于不区分大小写的名称，大写形式的名称与小写形式的等效名称拥有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
表示此名称的哈希码的 int。
另请参见：
Object.equals(java.lang.Object), Hashtable

clone

public Object clone()
创建此组合名称的副本。对此组合名称的组件进行的更改不会影响新副本，反之亦然。该副本和此组合名称共享相同的语法。

指定者：
接口 Name 中的 clone
覆盖：
类 Object 中的 clone
返回：
此组合名称的非 null 副本。
另请参见：
Cloneable

compareTo

public int compareTo(Object obj)
比较此 CompoundName 与指定 Object 的顺序。根据此 Name 小于、等于还是大于指定 Object 分别返回负整数、零或正整数。

如果 obj 为 null 或者不是一个 CompoundName 实例，则抛出 ClassCastException。

关于这对两个组合名称相等性的意义，请参见 equals()。如果两个组合名称是相等的，则返回 0。

组合名称的排序取决于组合名称的语法。默认情况下，它们遵从字符串比较的字典规则，并将此扩展到应用于组合名称中的所有组件，各个组件的比较受 jndi.syntax.ignorecase 和 jndi.syntax.trimblanks 属性的影响，受影响的方式与这些属性影响 equals() 的方式相同。如果此组合名称“按字典顺序”小于 obj，则返回一个负数。如果此组合名称“按字典顺序”大于 obj，则返回一个正数。

实现注意事项：当前，在检查顺序时不比较两个组合名称语法属性的相等性。这有可能在以后实现。

指定者：
接口 Comparable<Object> 中的 compareTo
指定者：
接口 Name 中的 compareTo
参数：
obj - 要与之比较的非 null 对象。
返回：
根据此 Name 小于、等于还是大于指定 Object 分别返回负整数、零或正整数。
抛出：
ClassCastException - 如果 obj 不是一个 CompoundName。
另请参见：
equals(java.lang.Object)

size

public int size()
检索此组合名称中的组件数。

指定者：
接口 Name 中的 size
返回：
此组合名称中的非负组件数。

isEmpty

public boolean isEmpty()
确定此组合名称是否为空。如何组合名称没有任何组件，则该名称为空。

指定者：
接口 Name 中的 isEmpty
返回：
如果此组合名称为空，则返回 true，否则返回 false。

getAll

public Enumeration<String> getAll()
以字符串枚举的形式检索此组合名称的组件。在此枚举上更新此组合名称的结果是不确定的。

指定者：
接口 Name 中的 getAll
返回：
此组合名称组件的非 null 枚举。每个枚举元素都属于 String 类。

get

public String get(int posn)
检索此组合名称的组件。

指定者：
接口 Name 中的 get
参数：
posn - 要检索的从 0 开始的组件索引。该索引必须在范围 [0,size()) 内。
返回：
位于索引 posn 处的组件。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。

getPrefix

public Name getPrefix(int posn)
创建一个组合名称，其组件由此组合名称中组件的前缀组成。该结果和此组合名称共享相同的语法。对此组合名称进行的后续更改不会影响返回的名称，反之亦然。

指定者：
接口 Name 中的 getPrefix
参数：
posn - 从 0 开始的组件索引，在该索引处停止。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [0,posn) 之间的组件组成的组合名称。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。

getSuffix

public Name getSuffix(int posn)
创建一个组合名称，其组件由该组合名称中组件的后缀组成。该结果和此组合名称共享相同的语法。对此组合名称进行的后续更改不会影响返回的名称。

指定者：
接口 Name 中的 getSuffix
参数：
posn - 从 0 开始的组件索引，在该索引处开始。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [posn,size()) 之间的组件组成的组合名称。如果 posn 等于 size()，则返回一个空组合名称。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。

startsWith

public boolean startsWith(Name n)
确定某一组合名称是否是此组合名称的前缀。如果某一组合名称 'n' 等于 getPrefix(n.size())，则该名称是一个前缀，换句话说，此组合名称从 'n' 开始。如果 n 为 null 或者不是一个组合名称，则返回 false。

实现注意事项：当前，在进行比较时不使用 n 的语法属性。这有可能在以后实现。

指定者：
接口 Name 中的 startsWith
参数：
n - 要检查的可能为 null 的组合名称。
返回：
如果 n 是一个 CompoundName 并且是此组合名称的前缀，则返回 true，否则返回 false。

endsWith

public boolean endsWith(Name n)
确定某一组合名称是否是此组合名称的后缀。如果某一组合名称 'n' 等于 getSuffix(size()-n.size())，则该名称是一个后缀，换句话说，此组合名称以 'n' 结尾。如果 n 为 null 或者不是一个组合名称，则返回 false。

实现注意事项：当前，在进行比较时不使用 n 的语法属性。这有可能在以后实现。

指定者：
接口 Name 中的 endsWith
参数：
n - 要检查的可能为 null 的组合名称。
返回：
如果 n 是一个 CompoundName 并且是此组合名称的后缀，则返回 true，否则返回 false。

addAll

public Name addAll(Name suffix)
            throws InvalidNameException
按顺序将组合名称的组件添加到此组合名称的末尾。

实现注意事项：当前，不使用或检查 suffix 的语法属性。这有可能在以后实现。

指定者：
接口 Name 中的 addAll
参数：
suffix - 要添加的非 null 组件。
返回：
已更新的 CompoundName，而不是一个新的 CompoundName。不能为 null。
抛出：
InvalidNameException - 如果 suffix 不是一个组合名称，或者添加组件违反此组合名称的语法（例如，组件数超出）。

addAll

public Name addAll(int posn,
                   Name n)
            throws InvalidNameException
按顺序将组合名称的组件添加到此组合名称中的指定位置。此组合名称位于第一个新组件的索引处或这之后的组件被上移（远离索引 0），以容纳新组件。

实现注意事项：当前，不使用或检查 suffix 的语法属性。这有可能在以后实现。

指定者：
接口 Name 中的 addAll
参数：
n - 要添加的非 null 组件。
posn - 此名称中的索引，将在该索引处添加新组件。该索引必须在范围 [0,size()] 内。
返回：
已更新的 CompoundName，而不是一个新的 CompoundName。不能为 null。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。
InvalidNameException - 如果 n 不是一个组合名称，或者添加组件违反此组合名称的语法（例如，组件数超出）。

add

public Name add(String comp)
         throws InvalidNameException
将单个组件添加到此组合名称的末尾。

指定者：
接口 Name 中的 add
参数：
comp - 要添加的非 null 组件。
返回：
已更新的 CompoundName，而不是一个新的 CompoundName。不能为 null。
抛出：
InvalidNameException - 如果在该名称末尾添加 comp 违反该组合名称的语法。

add

public Name add(int posn,
                String comp)
         throws InvalidNameException
在此组合名称中的指定位置添加单个组件。此组合名称位于新组件的索引处或这之后的组件被上移（远离索引 0）一位，以容纳新组件。

指定者：
接口 Name 中的 add
参数：
comp - 要添加的非 null 组件。
posn - 在其所在位置处添加新组件的索引。该索引必须在范围 [0,size()] 内。
返回：
已更新的 CompoundName，而不是一个新的 CompoundName。不能为 null。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围。
InvalidNameException - 如果在指定位置添加 comp 违反该组合名称的语法。

remove

public Object remove(int posn)
              throws InvalidNameException
从此组合名称中删除一个组件。移除此组合名称位置 'posn' 处的组件，而位于大于 'posn' 索引处的组件都将下移（朝着索引 0）一位。

指定者：
接口 Name 中的 remove
参数：
posn - 要删除的组件的索引。该索引必须在范围 [0,size()) 内。
返回：
移除的组件（一个 String）。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围（包括组合名称为空的情况）。
InvalidNameException - 如果删除组件违反该组合名称的语法。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigurationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 ConfigurationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.ConfigurationException
所有已实现的接口：
Serializable
public class ConfigurationException
extends NamingException

当存在配置问题时，抛出此异常。这可能出现在没有正确安装某一提供者，或者服务器存在配置问题，抑或访问提供者或服务所需的配置信息不正确或丢失时。例如，在没有使用 SSL 组件配置服务提供者软件时请求将 SSL 用作安全协议将导致此异常。另一个示例是，如果提供者要求将某个 URL 指定为环境属性之一，但客户端无法提供。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
ConfigurationException()
构造一个新的 ConfigurationException 实例，将解释和所有名称解析字段初始化为 null。
ConfigurationException(String explanation)
使用解释构造一个新的 ConfigurationException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConfigurationException

public ConfigurationException(String explanation)
使用解释构造一个新的 ConfigurationException 实例。其他所有字段都默认为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

ConfigurationException

public ConfigurationException()
构造一个新的 ConfigurationException 实例，将解释和所有名称解析字段初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Context (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
接口 Context

所有已知子接口：
DirContext, EventContext, EventDirContext, LdapContext
所有已知实现类：
InitialContext, InitialDirContext, InitialLdapContext
public interface Context

此接口表示一个命名上下文，它由一组名称到对象的绑定组成。它包含检查和更新这些绑定的一些方法。

名称

每个作为参数传递给 Context 方法的名称都是相对于该上下文的。空名称用于命名上下文本身。名称参数绝对不能为 null。

大多数方法具有重载形式，一种带有 Name 参数，另一种带有 String 参数。这些重载的方法是等效的：如果 Name 和 String 参数只是相同名称的不同表示形式，则相同方法的重载形式的行为也相同。在以下方法描述中，仅完整记录一种形式。第二种形式将链接到第一种：对两者应用相同的文档。

对于支持联合的系统，Context 方法的 String 名称参数是复合名称。是 CompositeName 实例的那些名称参数被视为复合名称，而不是 CompositeName 实例的 Name 参数被视为组合名称（可能是 CompoundName 实例或组合名称的其他实现）。这允许将 NameParser.parse() 的结果用作 Context 方法的参数。在 JNDI 1.2 之前，所有名称参数都被视为复合名称。

此外，对于支持联合的系统，NamingEnumeration 中所有从 list() 和 listBindings() 返回的名称都是表示为字符串的复合名称。有关名称的字符串语法，请参见 CompositeName。

对于不支持联合的系统，名称参数（Name 或 String 形式）和 NamingEnumeration 中返回的名称可能是其自己的名称空间中的名称，而不是复合名称空间中的名称，这由服务提供者决定。

异常

此接口中的所有方法都可以抛出 NamingException 或其任意子类。有关每个异常的详细信息，请参见 NamingException 及其子类。

并发访问

不保证 Context 实例与多个线程的并发访问是同步的。需要并发地访问单个 Context 实例的线程应该在它们之间实现同步并提供必需的锁定。对于每个线程都操作一个不同 Context 实例的多个线程而言，无需实现同步。注意，向 lookup 方法传递空名称将返回一个表示相同命名上下文的新 Context 实例。

为了实现并发控制，返回 NamingEnumeration 的 Context 操作在枚举仍在使用中或者仍在遵从该操作生成的所有引用时被认为尚未完成。

参数

传递给 Context 接口或其子接口之一中任何方法的 Name 参数不会被服务提供者修改。服务提供者可以在执行操作期间保留一个对它的引用，其中包括方法结果的所有枚举和生成的所有引用的处理。调用者在这段时间内不能修改该对象。任何这类方法返回的 Name 都归调用者所有。调用者随后可修改它，而服务提供者则不能。

环境属性

JNDI 应用程序需要一种方式来传达定义访问命名服务和目录服务的环境的各种首选项和属性。例如，为了访问服务，某个上下文可能需要安全证书的规约。另一个上下文可能要求提供服务器的配置信息。这些被称为某一上下文的环境。Context 接口提供一些检索和更新此环境的方法。

该环境在上下文方法从一个上下文到下一个上下文时从父上下文中继承。对某一上下文环境的更改不会直接影响其他上下文的环境。

当将环境属性用于有效性和/或验证有效性时，这些属性与实现有关。例如，一些与安全有关的属性被服务提供者用于“登录”目录。此登录过程可能发生在创建上下文时，或者发生在第一次对该上下文调用方法时。无论这在何时或是否发生，此环境属性都与实现有关。在将环境属性添加到上下文中或从上下文中移除时，验证这些更改的有效性也都与实现有关。例如，验证某些属性可能发生在进行更改时，或者发生在对上下文执行下一个操作时，抑或根本不验证。

拥有对某一上下文的引用的任何对象都可以检查该上下文的环境。敏感信息（比如明文密码）不应该存储在该环境中，除非已知实现能保护这类信息。

资源文件

要简化设置 JNDI 应用程序所需环境的任务，可以将资源文件 与应用程序组件和服务提供者一起发布。JNDI 资源文件是使用属性文件格式的文件（参见 java.util.Properties），包括一个键/值对列表。键是属性的名称（例如 "java.naming.factory.object"），而值是使用为该属性定义的格式的字符串。以下是 JNDI 资源文件的一个示例：

 java.naming.factory.object=com.sun.jndi.ldap.AttrsToCorba:com.wiz.from.Person
 java.naming.factory.state=com.sun.jndi.ldap.CorbaToAttrs:com.wiz.from.Person
 java.naming.factory.control=com.sun.jndi.ldap.ResponseControlFactory
JNDI 类库读取资源文件，并使属性值随意可用。因此应该认为 JNDI 资源文件是“所有人可读的”，敏感信息（比如明文密码）不应该存储在那里。

有两种 JNDI 资源文件：提供者 和应用程序。

提供者资源文件
每个服务提供者都有一个可选的资源，该资源列出了特定于该提供者的属性。此资源的名称是：
[prefix/]jndiprovider.properties
其中 prefix 是提供者的上下文实现的包名称，其每个句点 (".") 都被转换成一个斜杠 ("/")。 例如，假设服务提供者定义了一个带有类名称 com.sun.jndi.ldap.LdapCtx 的上下文实现。此提供者的提供者资源被命名为 com/sun/jndi/ldap/jndiprovider.properties。如果该类不在一个包中，则资源的名称就是 jndiprovider.properties。

JNDI 类库中的某些方法使用指定 JNDI 工厂列表的标准 JNDI 属性：

  • java.naming.factory.object
  • java.naming.factory.state
  • java.naming.factory.control
  • java.naming.factory.url.pkgs
在确定这些属性的值时，JNDI 库将参考提供者资源文件。这以外的属性可由服务提供者在提供者资源文件中设置。服务提供者的文档应该明确声明哪些属性是被允许的；文件中的其他属性将被忽略。
应用程序资源文件
在部署应用程序时，该应用程序通常将在其类路径中生成若干代码基目录和 JAR。类似地，在部署 applet 时，它将有一个指定 applet 类所处地址的代码基和档案文件。JNDI 查找（使用 ClassLoader.getResources()）类路径中所有名为 jndi.properties 的应用程序资源文件。此外，如果文件 java.home/lib/jndi.properties 存在并且是可读的，则 JNDI 会将其视为一个额外的应用程序资源文件。（java.home 指示由 java.home 系统属性命名的目录。）包含在这些文件中的所有属性都被放置在初始上下文环境中。然后此环境由其他上下文继承。

对于同时出现在多个应用程序资源文件中的每个属性，JNDI 使用最先找到的值，或者在少数有意义的情况下串联所有这些值（细节在下文给出）。例如，如果在三个 jndi.properties 资源文件中存在 "java.naming.factory.object" 属性，则对象工厂列表是所有三个文件中的属性值的串联。使用此方案，每个可部署组件都要负责列出它导出的工厂。JNDI 在搜索工厂类时自动收集和使用所有这些导出列表。

从 Java 2 Platform 开始可使用应用程序资源文件，java.home/lib 中的文件除外，它在较早的 Java 平台上也可以使用。

属性的搜索算法
当 JNDI 构造一个初始上下文时，该上下文的环境是使用传递给构造方法的环境参数中定义的属性、系统属性、applet 参数和应用程序资源文件进行初始化的。有关细节请参见 InitialContext。然后此初始环境由其他上下文实例继承。

如果 JNDI 类库需要确定某一属性的值，它将通过按顺序合并取自以下两个源的值来实现这一点：

  1. 将在其上执行操作的上下文的环境。
  2. 将在其上执行操作的上下文的提供者资源文件 (jndiprovider.properties)。
对于每个同时存在于这两个源中的属性，JNDI 用以下方式确定属性的值。如果该属性是指定 JNDI 工厂列表的标准 JNDI 属性之一（如上文所列），则这些值被串联成一个以冒号分隔的列表。对于其他属性，只使用最先找到的值。

当服务提供者需要确定某一属性的值时，它通常将直接从环境中获取该值。服务提供者可以定义将置于其本身提供者资源文件中的特定于提供者的属性。在这种情况下，它应该根据上文所述合并这些值。

这样，每个服务提供者开发人员便可以指定与该服务提供者一起使用的工厂列表。这可以由应用程序或 applet 的部署者指定的应用程序资源修改，而这些资源又可以由用户修改。

从以下版本开始：
1.3

字段摘要
static String | APPLET 该常量保存用来指定搜索其他属性时将使用的初始上下文构造方法的 applet 的环境属性名称。
static String | AUTHORITATIVE 该常量保存用来指定所请求服务的权威性的环境属性名称。
static String | BATCHSIZE 该常量保存用来指定通过服务协议返回数据时要使用的批处理量 (batch size) 的环境属性名称。
static String | DNS_URL 该常量保存用来指定用于 JNDI URL 上下文的 DNS 主机名和域名（例如 "dns://somehost/wiz.com"）的环境属性名称。
static String | INITIAL_CONTEXT_FACTORY 该常量保存用来指定要使用的初始上下文工厂的环境属性名称。
static String | LANGUAGE 该常量保存用来指定用于服务的首选语言的环境属性名称。
static String | OBJECT_FACTORIES 该常量保存用来指定要使用的对象工厂列表的环境属性名称。
static String | PROVIDER_URL 该常量保存用来指定要使用的服务提供者配置信息的环境属性名称。
static String | REFERRAL 该常量保存用来指定将如何处理服务提供者遇到的引用的环境属性名称。
static String | SECURITY_AUTHENTICATION 该常量保存用来指定将使用的安全级别的环境属性名称。
static String | SECURITY_CREDENTIALS 该常量保存用来指定用于验证服务调用者主体证书的环境属性名称。
static String | SECURITY_PRINCIPAL 该常量保存用来指定用于验证服务调用者主体身份的环境属性名称。
static String | SECURITY_PROTOCOL 该常量保存用来指定将使用的安全协议的环境属性名称。
static String | STATE_FACTORIES 该常量保存用来指定要使用的状态工厂列表的环境属性名称。
static String | URL_PKG_PREFIXES 该常量保存用来指定加载 URL 上下文工厂时要使用的包前缀列表的环境属性名称。
方法摘要
Object | addToEnvironment(String propName, Object propVal) 将一个新环境属性添加到此上下文的环境中。
void | bind(Name name, Object obj) 将名称绑定到对象。
void | bind(String name, Object obj) 将名称绑定到对象。
void | close() 关闭此上下文。
Name | composeName(Name name, Name prefix) 将此上下文的名称与相对于此上下文的名称组合。
String | composeName(String name, String prefix) 将此上下文的名称与相对于此上下文的名称组合。
Context | createSubcontext(Name name) 创建并绑定一个新上下文。
Context | createSubcontext(String name) 创建并绑定一个新上下文。
void | destroySubcontext(Name name) 销毁指定上下文，并将它从名称空间中移除。
void | destroySubcontext(String name) 销毁指定上下文，并将它从名称空间中移除。
Hashtable<?,?> | getEnvironment() 检索对此上下文有效的环境。
String | getNameInNamespace() 在此上下文自己的名称空间中检索其完全名称。
NameParser | getNameParser(Name name) 检索与指定上下文关联的解析器。
NameParser | getNameParser(String name) 检索与指定上下文关联的解析器。
NamingEnumeration<NameClassPair> | list(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | list(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<Binding> | listBindings(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | listBindings(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
Object | lookup(Name name) 检索指定的对象。
Object | lookup(String name) 检索指定的对象。
Object | lookupLink(Name name) 按照除名称的最终原子组件以外的链接检索指定对象。
Object | lookupLink(String name) 按照除名称的最终原子组件以外的链接检索指定对象。
void | rebind(Name name, Object obj) 将名称绑定到对象，重写任何现有绑定。
void | rebind(String name, Object obj) 将名称绑定到对象，重写所有现有绑定。
Object | removeFromEnvironment(String propName) 从此上下文的环境中移除一个环境属性。
void | rename(Name oldName, Name newName) 将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
void | rename(String oldName, String newName) 将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
void | unbind(Name name) 取消对指定对象的绑定。
void | unbind(String name) 取消对指定对象的绑定。

字段详细信息

INITIAL_CONTEXT_FACTORY

static final String INITIAL_CONTEXT_FACTORY
该常量保存用来指定要使用的初始上下文工厂的环境属性名称。该属性的值应该是将创建初始上下文的工厂类的完全限定类名称。此属性可以在传递给初始上下文构造方法的环境参数、applet 参数、系统属性或应用程序资源文件中指定。如果没有在任何这些源中指定该属性，则在需要初始上下文完成某项操作时将抛出 NoInitialContextException。

此常量的值是 "java.naming.factory.initial"。

另请参见：
InitialContext, InitialDirContext, NamingManager.getInitialContext(java.util.Hashtable), InitialContextFactory, NoInitialContextException, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, 常量字段值

OBJECT_FACTORIES

static final String OBJECT_FACTORIES
该常量保存用来指定要使用的对象工厂列表的环境属性名称。该属性的值应该是工厂类以冒号分隔的完全限定类名称列表，这些类将在给定关于对象信息的情况下创建该对象。此属性可以在环境、applet 参数、系统属性或者一个或多个资源文件中指定。

此常量的值是 "java.naming.factory.object"。

另请参见：
NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), ObjectFactory, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, 常量字段值

STATE_FACTORIES

static final String STATE_FACTORIES
该常量保存用来指定要使用的状态工厂列表的环境属性名称。该属性的值应该是状态工厂类以冒号分隔的完全限定类名称列表，这些类将被用来在给定对象本身的情况下获得该对象的状态。此属性可以在环境、applet 参数、系统属性或者一个或多个资源文件中指定。

此常量的值是 "java.naming.factory.state"。

从以下版本开始：
1.3
另请参见：
NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), StateFactory, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, 常量字段值

URL_PKG_PREFIXES

static final String URL_PKG_PREFIXES
该常量保存用来指定加载 URL 上下文工厂时要使用的包前缀列表的环境属性名称。该属性的值应该是工厂类名称以冒号分隔的包前缀列表，该工厂类将创建一个 URL 上下文工厂。此属性可以在环境、applet 参数、系统属性或者一个或多个资源文件中指定。前缀 com.sun.jndi.url 总是被追加到可能为空的包前缀列表中。

此常量的值是 "java.naming.factory.url.pkgs"。

另请参见：
NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.getURLContext(java.lang.String, java.util.Hashtable), ObjectFactory, addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, 常量字段值

PROVIDER_URL

static final String PROVIDER_URL
该常量保存用来指定要使用的服务提供者配置信息的环境属性名称。该属性的值应该包含一个 URL 字符串（例如 "ldap://somehost:389"）。此属性可以在环境、applet 参数、系统属性或资源文件中指定。如果没有在任何这些源中指定该属性，则由服务提供者确定默认配置。

此常量的值是 "java.naming.provider.url"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), APPLET, 常量字段值

DNS_URL

static final String DNS_URL
该常量保存用来指定用于 JNDI URL 上下文的 DNS 主机名和域名（例如 "dns://somehost/wiz.com"）的环境属性名称。此属性可以在环境、applet 参数、系统属性或资源文件中指定。如果没有在任何这些源中指定该属性并且程序试图使用包含 DNS 名称的 JNDI URL，则将抛出 ConfigurationException。

此常量的值是 "java.naming.dns.url"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

AUTHORITATIVE

static final String AUTHORITATIVE
该常量保存用来指定所请求服务的权威性的环境属性名称。如果该属性的值是字符串 "true"，则意味着访问的是最具权威的源（即无需任何缓冲或副本）。如果该值是其他任何值，则该源不必（但可能）是权威性的。如果该值未指定，则默认为 "false"。

此常量的值是 "java.naming.authoritative"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

BATCHSIZE

static final String BATCHSIZE
该常量保存用来指定通过服务协议返回数据时要使用的批处理量 (batch size) 的环境属性名称。这是一个提示，提示提供者按指定的批处理量返回操作的结果，以便提供者可以优化其性能和对资源的使用。该属性的值是某一整数的字符串表示形式。如果该值未指定，则由服务提供者确定批处理量。

此常量的值是 "java.naming.batchsize"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

REFERRAL

static final String REFERRAL
该常量保存用来指定将如何处理服务提供者遇到的引用的环境属性名称。该属性的值是以下字符串之一：
"follow"
自动服从引用
"ignore"
忽略引用
"throw"
在遇到引用时抛出 ReferralException。
如果未指定此属性，则由提供者确定默认值。

此常量的值是 "java.naming.referral"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

SECURITY_PROTOCOL

static final String SECURITY_PROTOCOL
该常量保存用来指定将使用的安全协议的环境属性名称。该属性的值是一个由服务提供者确定的字符串（例如 "ssl"）。如果未指定此属性，则由服务提供者确定如何运行。

此常量的值是 "java.naming.security.protocol"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

SECURITY_AUTHENTICATION

static final String SECURITY_AUTHENTICATION
该常量保存用来指定将使用的安全级别的环境属性名称。该属性的值是下列字符串之一："none"、"simple" 和 "strong"。如果未指定此属性，则由服务提供者确定如何运行。

此常量的值是 "java.naming.security.authentication"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

SECURITY_PRINCIPAL

static final String SECURITY_PRINCIPAL
该常量保存用来指定用于验证服务调用者主体身份的环境属性名称。主体格式取决于验证方案。如果未指定此属性，则由服务提供者确定如何运行。

此常量的值是 "java.naming.security.principal"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

SECURITY_CREDENTIALS

static final String SECURITY_CREDENTIALS
该常量保存用来指定用于验证服务调用者主体证书的环境属性名称。该属性值取决于验证方案。例如，它可以是一个散列式密码、明文密码、密钥、证书，等等。如果未指定此属性，则由服务提供者确定如何运行。

此常量的值是 "java.naming.security.credentials"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

LANGUAGE

static final String LANGUAGE
该常量保存用来指定用于服务的首选语言的环境属性名称。该属性的值是一个以冒号分隔的语言标记列表，RFC 1766 中定义了这些标记。如果未指定此属性，则由服务提供者确定语言优先级。

此常量的值是 "java.naming.language"。

另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), 常量字段值

APPLET

static final String APPLET
该常量保存用来指定搜索其他属性时将使用的初始上下文构造方法的 applet 的环境属性名称。此属性的值是将被执行的 java.applet.Applet 实例。可以在传递给初始上下文构造方法的环境参数中指定此属性。在设置此属性时，初始上下文构造方法在系统属性中查找的每个属性都是在 applet 的参数列表中最先查找到的属性。如果未指定此属性，则初始上下文构造方法将仅在传递给它的环境参数、系统属性和应用程序资源文件中搜索属性。

此常量的值是 "java.naming.applet"。

从以下版本开始：
1.3
另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String), InitialContext, 常量字段值
方法详细信息

lookup

Object lookup(Name name)
              throws NamingException
检索指定的对象。如果 name 为空，则返回此上下文的一个新实例（该实例表示与此上下文相同的命名上下文，但其环境可以独立地进行修改，而且可以并发访问）。

参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象
抛出：
NamingException - 如果遇到命名异常
另请参见：
lookup(String), lookupLink(Name)

lookup

Object lookup(String name)
              throws NamingException
检索指定的对象。有关详细信息请参见 lookup(Name)。

参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象
抛出：
NamingException - 如果遇到命名异常

bind

void bind(Name name,
          Object obj)
          throws NamingException
将名称绑定到对象。所有中间上下文和目标上下文（由该名称最终原子组件以外的其他所有组件指定）都必须已经存在。

参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常
另请参见：
bind(String, Object),
rebind(Name, Object),
DirContext.bind(Name, Object, javax.naming.directory.Attributes)

bind

void bind(String name,
          Object obj)
          throws NamingException
将名称绑定到对象。有关详细信息请参见 bind(Name, Object)。

参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常

rebind

void rebind(Name name,
            Object obj)
            throws NamingException
将名称绑定到对象，重写任何现有绑定。所有中间上下文和目标上下文（由该名称最终原子组件以外的其他所有组件指定）都必须已经存在。

如果该对象是一个 DirContext，则使用该对象的属性替换与该名称关联的所有现有属性。否则，与该名称关联的所有现有属性保持不变。

参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常
另请参见：
rebind(String, Object),
bind(Name, Object),
DirContext.rebind(Name, Object, javax.naming.directory.Attributes),
DirContext

rebind

void rebind(String name,
            Object obj)
            throws NamingException
将名称绑定到对象，重写所有现有绑定。有关详细信息请参见 rebind(Name, Object)。

参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常

unbind

void unbind(Name name)
            throws NamingException
取消对指定对象的绑定。从目标上下文中移除名为 name 的最终原子名称，目标上下文由 name 的最终原子部分以外的所有名称指定。

此方法是幂等的 (idempotent)。即使最终原子名称没有绑定在目标上下文中，该操作也能成功，但如果不存在任何中间上下文，则将抛出 NameNotFoundException。

所有与该名称关联的属性都被移除。不更改中间上下文。

参数：
name - 要取消绑定的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NamingException - 如果遇到命名异常
另请参见：
unbind(String)

unbind

void unbind(String name)
            throws NamingException
取消对指定对象的绑定。有关详细信息请参见 unbind(Name)。

参数：
name - 要取消绑定的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NamingException - 如果遇到命名异常

rename

void rename(Name oldName,
            Name newName)
            throws NamingException
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。两个名称都是相对于此上下文的。所有与旧名称关联的属性都改为与新名称关联。不更改旧名称的中间上下文。

参数：
oldName - 现有绑定的名称，不能为空
newName - 新绑定的名称，不能为空
抛出：
NameAlreadyBoundException - 如果已经绑定了 newName
NamingException - 如果遇到命名异常
另请参见：
rename(String, String),
bind(Name, Object),
rebind(Name, Object)

rename

void rename(String oldName,
            String newName)
            throws NamingException
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。有关详细信息请参见 rename(Name, Name)。

参数：
oldName - 现有绑定的名称，不能为空
newName - 新绑定的名称，不能为空
抛出：
NameAlreadyBoundException - 如果已经绑定了 newName
NamingException - 如果遇到命名异常

list

NamingEnumeration<NameClassPair> list(Name name)
                                      throws NamingException
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。不包括任何子上下文的内容。

如果将某一绑定添加到此上下文，或者从此上下文中移除某个绑定，则对以前返回的枚举的影响是不确定的。

参数：
name - 要列出的上下文的名称
返回：
名称和此上下文中的绑定的类名称所组成的枚举。每个枚举元素都属于 NameClassPair 类型。
抛出：
NamingException - 如果遇到命名异常
另请参见：
list(String), listBindings(Name), NameClassPair

list

NamingEnumeration<NameClassPair> list(String name)
                                      throws NamingException
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。有关详细信息请参见 list(Name)。

参数：
name - 要列出的上下文的名称
返回：
名称和此上下文中的绑定的类名称所组成的枚举。每个枚举元素都属于 NameClassPair 类型。
抛出：
NamingException - 如果遇到命名异常

listBindings

NamingEnumeration<Binding> listBindings(Name name)
                                        throws NamingException
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。不包括任何子上下文的内容。

如果将某一绑定添加到此上下文，或者从此上下文中移除某个绑定，则对以前返回的枚举的影响是不确定的。

参数：
name - 要列出的上下文的名称
返回：
此上下文中的绑定所组成的枚举。每个枚举元素都属于 Binding 类型。
抛出：
NamingException - 如果遇到命名异常
另请参见：
listBindings(String), list(Name), Binding

listBindings

NamingEnumeration<Binding> listBindings(String name)
                                        throws NamingException
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。有关详细信息请参见 listBindings(Name)。

参数：
name - 要列出的上下文的名称
返回：
此上下文中的绑定所组成的枚举。每个枚举元素都属于 Binding 类型。
抛出：
NamingException - 如果遇到命名异常

destroySubcontext

void destroySubcontext(Name name)
                       throws NamingException
销毁指定上下文，并将它从名称空间中移除。所有与该名称关联的属性也被移除。不销毁中间上下文。

此方法是幂等的。即使最终原子名称没有绑定在目标上下文中，该操作也能成功，但如果不存在任何中间上下文，则将抛出 NameNotFoundException。

在联合命名系统中，取自某一命名系统的上下文可以绑定到另一个命名系统中的名称上。随后可以使用复合名称在外部上下文 (foreign context) 中查询和执行操作。不过，试图使用此复合名称销毁上下文将失败并抛出 NotContextException，因为外部上下文不是绑定该复合名称的上下文的子上下文。改为使用 unbind() 移除外部上下文的绑定。销毁外部上下文需要对取自该外部上下文的“本机”命名系统的上下文执行 destroySubcontext()。

参数：
name - 要销毁的上下文的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NotContextException - 如果该名称被绑定，但它没有指定一个上下文，或者它没有指定适当类型的上下文
ContextNotEmptyException - 如果指定的上下文不为空
NamingException - 如果遇到命名异常
另请参见：
destroySubcontext(String)

destroySubcontext

void destroySubcontext(String name)
                       throws NamingException
销毁指定上下文，并将它从名称空间中移除。有关详细信息请参见 destroySubcontext(Name)。

参数：
name - 要销毁的上下文的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NotContextException - 如果该名称被绑定，但它没有指定一个上下文，或者它没有指定适当类型的上下文
ContextNotEmptyException - 如果指定的上下文不为空
NamingException - 如果遇到命名异常

createSubcontext

Context createSubcontext(Name name)
                         throws NamingException
创建并绑定一个新上下文。使用给定名称创建一个新上下文，并将它绑定在目标上下文中（由该名称最终原子组件以外的所有名称指定）。所有中间上下文和目标上下文都必须已经存在。

参数：
name - 要创建的上下文的名称，不能为空
返回：
新创建的上下文。
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果创建子上下文需要指定强制属性
NamingException - 如果遇到命名异常
另请参见：
createSubcontext(String), DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes)

createSubcontext

Context createSubcontext(String name)
                         throws NamingException
创建并绑定一个新上下文。有关详细信息请参见 createSubcontext(Name)。

参数：
name - 要创建的上下文的名称，不能为空
返回：
新创建的上下文。
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果创建子上下文需要指定强制属性
NamingException - 如果遇到命名异常

lookupLink

Object lookupLink(Name name)
                  throws NamingException
按照除名称的最终原子组件以外的链接检索指定对象。如果绑定到 name 的对象不是一个链接，则返回该对象本身。

参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象不遵从最终链接（如果有）。
抛出：
NamingException - 如果遇到命名异常
另请参见：
lookupLink(String)

lookupLink

Object lookupLink(String name)
                  throws NamingException
按照除名称的最终原子组件以外的链接检索指定对象。有关详细信息请参见 lookupLink(Name)。

参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象不遵从最终链接（如果有）
抛出：
NamingException - 如果遇到命名异常

getNameParser

NameParser getNameParser(Name name)
                         throws NamingException
检索与指定上下文关联的解析器。在联合名称空间中，不同的命名系统将以不同的方式解析名称。此方法允许应用程序使用特定命名系统的命名约定获得用来将名称解析成其原子组件的解析器。在任意一个命名系统中，由此方法返回的 NameParser 对象必须相等（可使用 equals() 进行测试）。

参数：
name - 从中获得解析器的上下文的名称
返回：
可以将组合名称解析成其原子组件的名称解析器
抛出：
NamingException - 如果遇到命名异常
另请参见：
getNameParser(String), CompoundName

getNameParser

NameParser getNameParser(String name)
                         throws NamingException
检索与指定上下文关联的解析器。有关详细信息请参见 getNameParser(Name)。

参数：
name - 从中获得解析器的上下文的名称
返回：
可以将组合名称解析成其原子组件的名称解析器
抛出：
NamingException - 如果遇到命名异常

composeName

Name composeName(Name name,
                 Name prefix)
                 throws NamingException
将此上下文的名称与相对于此上下文的名称组合。在给定相对于此上下文的名称(name)以及此上下文相对于其一个祖先的名称(prefix)的情况下，此方法使用适合所涉及命名系统的语法返回这两个名称的组合。也就是说，如果 name 指定一个相对于此上下文的对象，则结果是同一个对象的名称，但该名称相对于祖先上下文。所有名称都不能为 null。

例如，如果此上下文被命名为 "wiz.com"，该名称相对于初始上下文，则

        composeName("east", "wiz.com")
可能返回 "east.wiz.com"。如果将此上下文命名为 "org/research"，则
        composeName("user/jane", "org/research")
可能返回 "org/research/user/jane"，而
        composeName("user/jane", "research")
返回 "research/user/jane"。

参数：
name - 相对于此上下文的名称
prefix - 此上下文相对于其一个祖先的名称
返回：
prefix 和 name 的组合
抛出：
NamingException - 如果遇到命名异常
另请参见：
composeName(String, String)

composeName

String composeName(String name,
                   String prefix)
                   throws NamingException
将此上下文的名称与相对于此上下文的名称组合。有关详细信息请参见 composeName(Name, Name)。

参数：
name - 相对于此上下文的名称
prefix - 此上下文相对于其一个祖先的名称
返回：
prefix 和 name 的组合
抛出：
NamingException - 如果遇到命名异常

addToEnvironment

Object addToEnvironment(String propName,
                        Object propVal)
                        throws NamingException
将一个新环境属性添加到此上下文的环境中。如果该属性已经存在，则重写该属性的值。有关环境属性的更多详细信息，请参阅类描述。

参数：
propName - 要添加的环境属性的名称，不能为 null
propVal - 要添加的属性的值，不能为 null
返回：
该属性以前的值，如果该属性以前不在此环境中，则返回 null
抛出：
NamingException - 如果遇到命名异常
另请参见：
getEnvironment(), removeFromEnvironment(String)

removeFromEnvironment

Object removeFromEnvironment(String propName)
                             throws NamingException
从此上下文的环境中移除一个环境属性。有关环境属性的更多详细信息，请参阅类描述。

参数：
propName - 要移除的环境属性的名称，不能为 null
返回：
该属性以前的值，如果该属性以前不在此环境中，则返回 null
抛出：
NamingException - 如果遇到命名异常
另请参见：
getEnvironment(), addToEnvironment(String, Object)

getEnvironment

Hashtable<?,?> getEnvironment()
                              throws NamingException
检索对此上下文有效的环境。有关环境属性的更多详细信息，请参阅类描述。

调用者不应对返回的对象进行任何更改：因为这些更改对于上下文的影响是不确定的。可以使用 addToEnvironment() 和 removeFromEnvironment() 更改此上下文的环境。

返回：
此上下文的环境，决不能为 null
抛出：
NamingException - 如果遇到命名异常
另请参见：
addToEnvironment(String, Object), removeFromEnvironment(String)

close

void close()
           throws NamingException
关闭此上下文。此方法立即释放此上下文的资源，而不是等待垃圾回收器自动释放它们。

此方法是幂等的：对已经关闭的上下文调用此方法无效。对已关闭的上下文调用其他任何方法都是不允许的，这会导致不确定的行为。

抛出：
NamingException - 如果遇到命名异常

getNameInNamespace

String getNameInNamespace()
                          throws NamingException
在此上下文自己的名称空间中检索其完全名称。

许多命名服务都有一个“完全名称”的概念，用于其各自的名称空间中的对象。例如，LDAP 项有一个独特的名称，而 DNS 记录有一个完全限定名。此方法允许客户端应用程序检索此名称。此方法返回的字符串不是一个 JNDI 复合名称，不应将它直接传递给上下文方法。在没有完全名称概念的命名系统中，将抛出 OperationNotSupportedException。

返回：
此上下文在其自己的名称空间中的名称，决不能为 null
抛出：
OperationNotSupportedException - 如果命名系统没有完全名称的概念
NamingException - 如果遇到命名异常
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ContextNotEmptyException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 ContextNotEmptyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.ContextNotEmptyException
所有已实现的接口：
Serializable
public class ContextNotEmptyException
extends NamingException

当试图销毁一个不为空的上下文时，抛出此异常。

如果程序想要单独处理此异常，它应该在试图捕获 NamingException 之前显式捕获 ContextNotEmptyException。例如，在捕获 ContextNotEmptyException 之后，该程序可能试图在重新尝试销毁上下文之前移除该上下文的内容。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
Context.destroySubcontext(javax.naming.Name), 序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
ContextNotEmptyException()
构造一个新的 ContextNotEmptyException 实例，将解释和所有名称解析字段初始化为 null。
ContextNotEmptyException(String explanation)
使用解释构造一个新的 ContextNotEmptyException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ContextNotEmptyException

public ContextNotEmptyException(String explanation)
使用解释构造一个新的 ContextNotEmptyException 实例。其他所有字段都默认为 null。

参数：
explanation - 可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

ContextNotEmptyException

public ContextNotEmptyException()
构造一个新的 ContextNotEmptyException 实例，将解释和所有名称解析字段初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InitialContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 InitialContext

java.lang.Object
    继承者  javax.naming.InitialContext
所有已实现的接口：
Context
直接已知子类：
InitialDirContext
public class InitialContext
extends Object
implements Context

此类是执行命名操作的初始上下文。

所有命名操作都相对于某一上下文。该初始上下文实现 Context 接口并提供解析名称的起始点。

在构造初始上下文时，使用传递给构造方法的环境参数中以及所有应用程序资源文件中定义的属性初始化其环境。此外，可以将少数标准 JNDI 属性指定为系统属性或 applet 参数（通过使用 Context.APPLET）。这些特殊属性列于 Context 和 LdapContext 接口文档的字段详细信息部分。

JNDI 通过按顺序合并取自以下两个源的值来确定每个属性值：

  1. 构造方法的环境参数、（适当属性的）applet 参数，以及系统属性中最先出现的属性。
  2. 应用程序资源文件 (jndi.properties)。
对于同时存在于两个源或多个应用程序资源文件中的每个属性，用以下方式确定属性值。如果该属性是指定 JNDI 工厂列表的标准 JNDI 属性之一（参见 Context），则所有值都被串联成一个以冒号分隔的列表。对于其他属性，只使用最先找到的值。

初始上下文实现是在运行时确定的。默认策略使用环境属性 "java.naming.factory.initial"，该属性包含初始上下文工厂的类名称。解析 URL 字符串时生成此策略的一个异常，如下所述。

在将 URL 字符串（一个 scheme_id:rest_of_name 形式的 String）作为名称参数传递给任一方法时，将定位处理该方案的一个 URL 上下文工厂，并将它用于解析该 URL。如果没有找到这样的工厂，则使用由 "java.naming.factory.initial" 指定的初始上下文。类似地，当将第一个组件是 URL 字符串的 CompositeName 对象作为名称参数传递给任一方法时，将定位一个 URL 上下文工厂并将它用于解析第一个名称组件。有关如何定位 URL 上下文工厂的描述，请参见 NamingManager.getURLContext()。

这一定位初始上下文和 URL 上下文工厂的默认策略可以通过调用 NamingManager.setInitialContextFactoryBuilder() 重写。

当无法实例化初始上下文时，将抛出 NoInitialContextException。此异常可以在与 InitialContext 进行的任何交互期间抛出，而不仅仅是在构造 InitialContext 时。例如，初始上下文的实现可能仅当在其上调用实际方法时惰性获取上下文。当确定初始上下文存在时，应用程序不应该对它有任何依赖性。

当环境属性 "java.naming.factory.initial" 为非 null 值时，InitialContext 构造方法将试着创建在其中指定的初始上下文。此时，如果遇到问题，所涉及的初始上下文工厂可能抛出异常。不过，在验证并向初始上下文用户指示所有与环境属性或连接有关的问题时，这将与提供者的实现有关。提供者也可以以延迟方式做到这一点：延迟到在上下文上执行某一操作时；在更急切的情况下，延迟到构造上下文时。

InitialContext 实例对多个线程的并发访问不同步。对于每个线程都操作一个不同 InitialContext 实例的多个线程而言，无需实现同步。需要并发地访问单个 InitialContext 实例的线程应该在它们之间实现同步并提供必需的锁定。

从以下版本开始：
JNDI 1.1 / Java 2 Platform, Standard Edition, v 1.3
另请参见：
Context, NamingManager.setInitialContextFactoryBuilder

字段摘要
protected Context | defaultInitCtx 该字段保存调用 NamingManager.getInitialContext() 的结果。
protected boolean | gotDefault 该字段指示是否已通过调用 NamingManager.getInitialContext() 获得了初始上下文。
protected Hashtable<Object,Object> | myProps 与此 InitialContext 关联的环境。
从接口 javax.naming.Context 继承的字段
APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES
构造方法摘要
 | InitialContext() 构造一个初始上下文。
protected | InitialContext(boolean lazy) 构造一个带有不进行初始化选项的初始上下文。
 | InitialContext(Hashtable<?,?> environment) 使用所提供的环境构造一个初始上下文。
方法摘要
 Object addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。
 void bind(Name name, Object obj)
将名称绑定到对象。
 void bind(String name, Object obj)
将名称绑定到对象。
 void close()
关闭此上下文。
 Name composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 String composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Context createSubcontext(Name name)
创建并绑定一个新上下文。
 Context createSubcontext(String name)
创建并绑定一个新上下文。
 void destroySubcontext(Name name)
销毁指定上下文，并将它从名称空间中移除。
 void destroySubcontext(String name)
销毁指定上下文，并将它从名称空间中移除。
static
<T> T
doLookup(Name name)
获取指定对象的静态方法。
static
<T> T
doLookup(String name)
获取指定对象的静态方法。
protected  Context getDefaultInitCtx()
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。
 Hashtable<?,?> getEnvironment()
检索对此上下文有效的环境。
 String getNameInNamespace()
在此上下文自己的名称空间中检索其完全名称。
 NameParser getNameParser(Name name)
检索与指定上下文关联的解析器。
 NameParser getNameParser(String name)
检索与指定上下文关联的解析器。
protected  Context getURLOrDefaultInitCtx(Name name)
获取用来解析 name 的上下文。
protected  Context getURLOrDefaultInitCtx(String name)
获取用来解析字符串名称 name 的上下文。
protected  void init(Hashtable<?,?> environment)
使用所提供的环境初始化初始上下文。
 NamingEnumeration<NameClassPair> list(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<NameClassPair> list(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<Binding> listBindings(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 NamingEnumeration<Binding> listBindings(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 Object lookup(Name name)
检索指定的对象。
 Object lookup(String name)
检索指定的对象。
 Object lookupLink(Name name)
按照除名称的最终原子组件以外的链接检索指定对象。
 Object lookupLink(String name)
按照除名称的最终原子组件以外的链接检索指定对象。
 void rebind(Name name, Object obj)
将名称绑定到对象，重写任何现有绑定。
 void rebind(String name, Object obj)
将名称绑定到对象，重写所有现有绑定。
 Object removeFromEnvironment(String propName)
从此上下文的环境中移除一个环境属性。
 void rename(Name oldName, Name newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void rename(String oldName, String newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void unbind(Name name)
取消对指定对象的绑定。
 void unbind(String name)
取消对指定对象的绑定。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

myProps

protected Hashtable<Object,Object> myProps
与此 InitialContext 关联的环境。它被初始化为 null，并由接受环境作为参数的构造方法或 init() 方法更新。

另请参见：
addToEnvironment(java.lang.String, java.lang.Object),
removeFromEnvironment(java.lang.String),
getEnvironment()

defaultInitCtx

protected Context defaultInitCtx
该字段保存调用 NamingManager.getInitialContext() 的结果。它由 getDefaultInitCtx() 在第一次调用 getDefaultInitCtx() 时设置。getDefaultInitCtx() 的后续调用返回 defaultInitCtx 的值。

另请参见：
getDefaultInitCtx()

gotDefault

protected boolean gotDefault
该字段指示是否已通过调用 NamingManager.getInitialContext() 获得了初始上下文。如果为 true，则其结果保存在 defaultInitCtx 中。

构造方法详细信息

InitialContext

protected InitialContext(boolean lazy)
                  throws NamingException
构造一个带有不进行初始化选项的初始上下文。如果子类在调用 InitialContext 构造方法时仍然未知环境属性的值，则可以在其中使用此构造方法。子类的构造方法将调用此构造方法，计算环境的值，然后在返回之前调用 init()。

参数：
lazy - 为 true 表示不初始化该初始上下文；为 false 等效于调用 new InitialContext()
抛出：
NamingException - 如果遇到命名异常
从以下版本开始：
1.3
另请参见：
init(Hashtable)

InitialContext

public InitialContext()
               throws NamingException
构造一个初始上下文。不提供环境属性。与 new InitialContext(null) 等效。

抛出：
NamingException - 如果遇到命名异常
另请参见：
InitialContext(Hashtable)

InitialContext

public InitialContext(Hashtable<?,?> environment)
               throws NamingException
使用所提供的环境构造一个初始上下文。这些环境属性已在类描述中讨论。

此构造方法不会修改 environment 或保存一个对它的引用，但可能保存一个副本。

参数：
environment - 用来创建初始上下文的环境。null 指示一个空环境。
抛出：
NamingException - 如果遇到命名异常
方法详细信息

init

protected void init(Hashtable<?,?> environment)
             throws NamingException
使用所提供的环境初始化初始上下文。这些环境属性已在类描述中讨论。

此方法将修改 environment 并保存一个对它的引用。调用者可能不再修改它。

参数：
environment - 用来创建初始上下文的环境。null 指示一个空环境。
抛出：
NamingException - 如果遇到命名异常
从以下版本开始：
1.3
另请参见：
InitialContext(boolean)

doLookup

public static <T> T doLookup(Name name)
                  throws NamingException
获取指定对象的静态方法。 此方法是一个快捷方法，等效于调用：

InitialContext ic = new InitialContext(); Object obj = ic.lookup();

如果 name 为空，则返回此上下文的一个新实例（该实例表示与此上下文相同的命名上下文，但可以独立地修改其环境，并可以并发地访问）。

参数：
name - 要查找的对象名称
返回：
绑定到 name 的对象
抛出：
NamingException - 如果遇到命名异常
从以下版本开始：
1.6
另请参见：
doLookup(String), lookup(Name)

doLookup

public static <T> T doLookup(String name)
                  throws NamingException
获取指定对象的静态方法。 有关详细信息请参见 doLookup(Name)。

参数：
name - 要查找的对象名称
返回：
绑定到 name 的对象
抛出：
NamingException - 如果遇到命名异常
从以下版本开始：
1.6

getDefaultInitCtx

protected Context getDefaultInitCtx()
                             throws NamingException
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。设置 gotDefault，说明已执行过此操作。

返回：
缓存的非 null 初始上下文。
抛出：
NoInitialContextException - 如果无法找到初始上下文。
NamingException - 如果遇到命名异常。

getURLOrDefaultInitCtx

protected Context getURLOrDefaultInitCtx(String name)
                                  throws NamingException
获取用来解析字符串名称 name 的上下文。如果 name 名称是一个 URL 字符串，则试着定位一个用于该字符串的 URL 上下文。如果没有找到这样的上下文，或者 name 不是一个 URL 字符串，则返回 getDefaultInitCtx()。

有关子类应该如何使用此方法的描述，请参见 getURLOrDefaultInitCtx(Name)。

参数：
name - 非 null 名称，将为其获得上下文。
返回：
用于 name 的 URL 上下文或者缓存的初始上下文。结果不能为 null。
抛出：
NoInitialContextException - 如果无法找到初始上下文。
NamingException - 如果遇到命名异常。
另请参见：
NamingManager.getURLContext(java.lang.String, java.util.Hashtable)

getURLOrDefaultInitCtx

protected Context getURLOrDefaultInitCtx(Name name)
                                  throws NamingException
获取用来解析 name 的上下文。如果 name 名称的第一个组件是一个 URL 字符串，则试着查找一个用于该字符串的 URL 上下文。如果没有找到这样的上下文，或者 name 的第一个组件不是一个 URL 字符串，则返回 getDefaultInitCtx()。

在创建 InitialContext 的子类时，按以下方式使用此方法。定义一个使用此方法的新方法来获得所需子类的初始上下文。

 protected XXXContext getURLOrDefaultInitXXXCtx(Name name)
 throws NamingException {
  Context answer = getURLOrDefaultInitCtx(name);
  if (!(answer instanceof XXXContext)) {
    if (answer == null) {
            throw new NoInitialContextException();
    } else {
            throw new NotContextException("Not an XXXContext");
    }
        }
        return (XXXContext)answer;
 }
当为子类中的新方法提供实现时，使用这个新定义的方法获取初始上下文。

 public Object XXXMethod1(Name name, ...) {
        throws NamingException {
    return getURLOrDefaultInitXXXCtx(name).XXXMethod1(name, ...);
 }

参数：
name - 非 null 名称，将为其获取上下文。
返回：
用于 name 的 URL 上下文或者缓存的初始上下文。结果不能为 null。
抛出：
NoInitialContextException - 如果无法找到初始上下文。
NamingException - 如果遇到命名异常。
另请参见：
NamingManager.getURLContext(java.lang.String, java.util.Hashtable)

lookup

public Object lookup(String name)
              throws NamingException
从接口 Context 复制的描述
检索指定的对象。有关详细信息请参见 Context.lookup(Name)。

指定者：
接口 Context 中的 lookup
参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象
抛出：
NamingException - 如果遇到命名异常

lookup

public Object lookup(Name name)
              throws NamingException
从接口 Context 复制的描述
检索指定的对象。如果 name 为空，则返回此上下文的一个新实例（该实例表示与此上下文相同的命名上下文，但其环境可以独立地进行修改，而且可以并发访问）。

指定者：
接口 Context 中的 lookup
参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.lookup(String), Context.lookupLink(Name)

bind

public void bind(String name,
                 Object obj)
          throws NamingException
从接口 Context 复制的描述
将名称绑定到对象。有关详细信息请参见 Context.bind(Name, Object)。

指定者：
接口 Context 中的 bind
参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常

bind

public void bind(Name name,
                 Object obj)
          throws NamingException
从接口 Context 复制的描述
将名称绑定到对象。所有中间上下文和目标上下文（由该名称最终原子组件以外的其他所有组件指定）都必须已经存在。

指定者：
接口 Context 中的 bind
参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常
另请参见：
Context.bind(String, Object),
Context.rebind(Name, Object),
DirContext.bind(Name, Object, javax.naming.directory.Attributes)

rebind

public void rebind(String name,
                   Object obj)
            throws NamingException
从接口 Context 复制的描述
将名称绑定到对象，重写所有现有绑定。有关详细信息请参见 Context.rebind(Name, Object)。

指定者：
接口 Context 中的 rebind
参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常

rebind

public void rebind(Name name,
                   Object obj)
            throws NamingException
从接口 Context 复制的描述
将名称绑定到对象，重写任何现有绑定。所有中间上下文和目标上下文（由该名称最终原子组件以外的其他所有组件指定）都必须已经存在。

如果该对象是一个 DirContext，则使用该对象的属性替换与该名称关联的所有现有属性。否则，与该名称关联的所有现有属性保持不变。

指定者：
接口 Context 中的 rebind
参数：
name - 要绑定的名称，不可以为空
obj - 要绑定的对象，可能为 null
抛出：
InvalidAttributesException - 如果对象不支持所有强制属性
NamingException - 如果遇到命名异常
另请参见：
Context.rebind(String, Object),
Context.bind(Name, Object),
DirContext.rebind(Name, Object, javax.naming.directory.Attributes),
DirContext

unbind

public void unbind(String name)
            throws NamingException
从接口 Context 复制的描述
取消对指定对象的绑定。有关详细信息请参见 Context.unbind(Name)。

指定者：
接口 Context 中的 unbind
参数：
name - 要取消绑定的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NamingException - 如果遇到命名异常

unbind

public void unbind(Name name)
            throws NamingException
从接口 Context 复制的描述
取消对指定对象的绑定。从目标上下文中移除名为 name 的最终原子名称，目标上下文由 name 的最终原子部分以外的所有名称指定。

此方法是幂等的 (idempotent)。即使最终原子名称没有绑定在目标上下文中，该操作也能成功，但如果不存在任何中间上下文，则将抛出 NameNotFoundException。

所有与该名称关联的属性都被移除。不更改中间上下文。

指定者：
接口 Context 中的 unbind
参数：
name - 要取消绑定的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NamingException - 如果遇到命名异常
另请参见：
Context.unbind(String)

rename

public void rename(String oldName,
                   String newName)
            throws NamingException
从接口 Context 复制的描述
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。有关详细信息请参见 Context.rename(Name, Name)。

指定者：
接口 Context 中的 rename
参数：
oldName - 现有绑定的名称，不能为空
newName - 新绑定的名称，不能为空
抛出：
NameAlreadyBoundException - 如果已经绑定了 newName
NamingException - 如果遇到命名异常

rename

public void rename(Name oldName,
                   Name newName)
            throws NamingException
从接口 Context 复制的描述
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。两个名称都是相对于此上下文的。所有与旧名称关联的属性都改为与新名称关联。不更改旧名称的中间上下文。

指定者：
接口 Context 中的 rename
参数：
oldName - 现有绑定的名称，不能为空
newName - 新绑定的名称，不能为空
抛出：
NameAlreadyBoundException - 如果已经绑定了 newName
NamingException - 如果遇到命名异常
另请参见：
Context.rename(String, String),
Context.bind(Name, Object),
Context.rebind(Name, Object)

list

public NamingEnumeration<NameClassPair> list(String name)
                                      throws NamingException
从接口 Context 复制的描述
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。有关详细信息请参见 Context.list(Name)。

指定者：
接口 Context 中的 list
参数：
name - 要列出的上下文的名称
返回：
名称和此上下文中的绑定的类名称所组成的枚举。每个枚举元素都属于 NameClassPair 类型。
抛出：
NamingException - 如果遇到命名异常

list

public NamingEnumeration<NameClassPair> list(Name name)
                                      throws NamingException
从接口 Context 复制的描述
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。不包括任何子上下文的内容。

如果将某一绑定添加到此上下文，或者从此上下文中移除某个绑定，则对以前返回的枚举的影响是不确定的。

指定者：
接口 Context 中的 list
参数：
name - 要列出的上下文的名称
返回：
名称和此上下文中的绑定的类名称所组成的枚举。每个枚举元素都属于 NameClassPair 类型。
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.list(String), Context.listBindings(Name), NameClassPair

listBindings

public NamingEnumeration<Binding> listBindings(String name)
                                        throws NamingException
从接口 Context 复制的描述
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。有关详细信息请参见 Context.listBindings(Name)。

指定者：
接口 Context 中的 listBindings
参数：
name - 要列出的上下文的名称
返回：
此上下文中的绑定所组成的枚举。每个枚举元素都属于 Binding 类型。
抛出：
NamingException - 如果遇到命名异常

listBindings

public NamingEnumeration<Binding> listBindings(Name name)
                                        throws NamingException
从接口 Context 复制的描述
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。不包括任何子上下文的内容。

如果将某一绑定添加到此上下文，或者从此上下文中移除某个绑定，则对以前返回的枚举的影响是不确定的。

指定者：
接口 Context 中的 listBindings
参数：
name - 要列出的上下文的名称
返回：
此上下文中的绑定所组成的枚举。每个枚举元素都属于 Binding 类型。
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.listBindings(String), Context.list(Name), Binding

destroySubcontext

public void destroySubcontext(String name)
                       throws NamingException
从接口 Context 复制的描述
销毁指定上下文，并将它从名称空间中移除。有关详细信息请参见 Context.destroySubcontext(Name)。

指定者：
接口 Context 中的 destroySubcontext
参数：
name - 要销毁的上下文的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NotContextException - 如果该名称被绑定，但它没有指定一个上下文，或者它没有指定适当类型的上下文
ContextNotEmptyException - 如果指定的上下文不为空
NamingException - 如果遇到命名异常

destroySubcontext

public void destroySubcontext(Name name)
                       throws NamingException
从接口 Context 复制的描述
销毁指定上下文，并将它从名称空间中移除。所有与该名称关联的属性也被移除。不销毁中间上下文。

此方法是幂等的。即使最终原子名称没有绑定在目标上下文中，该操作也能成功，但如果不存在任何中间上下文，则将抛出 NameNotFoundException。

在联合命名系统中，取自某一命名系统的上下文可以绑定到另一个命名系统中的名称上。随后可以使用复合名称在外部上下文 (foreign context) 中查询和执行操作。不过，试图使用此复合名称销毁上下文将失败并抛出 NotContextException，因为外部上下文不是绑定该复合名称的上下文的子上下文。改为使用 unbind() 移除外部上下文的绑定。销毁外部上下文需要对取自该外部上下文的“本机”命名系统的上下文执行 destroySubcontext()。

指定者：
接口 Context 中的 destroySubcontext
参数：
name - 要销毁的上下文的名称，不能为空
抛出：
NameNotFoundException - 如果不存在中间上下文
NotContextException - 如果该名称被绑定，但它没有指定一个上下文，或者它没有指定适当类型的上下文
ContextNotEmptyException - 如果指定的上下文不为空
NamingException - 如果遇到命名异常
另请参见：
Context.destroySubcontext(String)

createSubcontext

public Context createSubcontext(String name)
                         throws NamingException
从接口 Context 复制的描述
创建并绑定一个新上下文。有关详细信息请参见 Context.createSubcontext(Name)。

指定者：
接口 Context 中的 createSubcontext
参数：
name - 要创建的上下文的名称，不能为空
返回：
新创建的上下文。
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果创建子上下文需要指定强制属性
NamingException - 如果遇到命名异常

createSubcontext

public Context createSubcontext(Name name)
                         throws NamingException
从接口 Context 复制的描述
创建并绑定一个新上下文。使用给定名称创建一个新上下文，并将它绑定在目标上下文中（由该名称最终原子组件以外的所有名称指定）。所有中间上下文和目标上下文都必须已经存在。

指定者：
接口 Context 中的 createSubcontext
参数：
name - 要创建的上下文的名称，不能为空
返回：
新创建的上下文。
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果创建子上下文需要指定强制属性
NamingException - 如果遇到命名异常
另请参见：
Context.createSubcontext(String), DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes)

lookupLink

public Object lookupLink(String name)
                  throws NamingException
从接口 Context 复制的描述
按照除名称的最终原子组件以外的链接检索指定对象。有关详细信息请参见 Context.lookupLink(Name)。

指定者：
接口 Context 中的 lookupLink
参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象不遵从最终链接（如果有）
抛出：
NamingException - 如果遇到命名异常

lookupLink

public Object lookupLink(Name name)
                  throws NamingException
从接口 Context 复制的描述
按照除名称的最终原子组件以外的链接检索指定对象。如果绑定到 name 的对象不是一个链接，则返回该对象本身。

指定者：
接口 Context 中的 lookupLink
参数：
name - 要查询的对象的名称
返回：
绑定到 name 的对象不遵从最终链接（如果有）。
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.lookupLink(String)

getNameParser

public NameParser getNameParser(String name)
                         throws NamingException
从接口 Context 复制的描述
检索与指定上下文关联的解析器。有关详细信息请参见 Context.getNameParser(Name)。

指定者：
接口 Context 中的 getNameParser
参数：
name - 从中获得解析器的上下文的名称
返回：
可以将组合名称解析成其原子组件的名称解析器
抛出：
NamingException - 如果遇到命名异常

getNameParser

public NameParser getNameParser(Name name)
                         throws NamingException
从接口 Context 复制的描述
检索与指定上下文关联的解析器。在联合名称空间中，不同的命名系统将以不同的方式解析名称。此方法允许应用程序使用特定命名系统的命名约定获得用来将名称解析成其原子组件的解析器。在任意一个命名系统中，由此方法返回的 NameParser 对象必须相等（可使用 equals() 进行测试）。

指定者：
接口 Context 中的 getNameParser
参数：
name - 从中获得解析器的上下文的名称
返回：
可以将组合名称解析成其原子组件的名称解析器
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.getNameParser(String), CompoundName

composeName

public String composeName(String name,
                          String prefix)
                   throws NamingException
将此上下文的名称与相对于此上下文的名称组合。因为绝不能相对于除本身以外的任何上下文命名初始上下文，所以 prefix 参数的值必须是一个空名称 ("")。

指定者：
接口 Context 中的 composeName
参数：
name - 相对于此上下文的名称
prefix - 此上下文相对于其一个祖先的名称
返回：
prefix 和 name 的组合
抛出：
NamingException - 如果遇到命名异常

composeName

public Name composeName(Name name,
                        Name prefix)
                 throws NamingException
将此上下文的名称与相对于此上下文的名称组合。因为绝不能相对于除本身以外的任何上下文命名初始上下文，所以 prefix 参数的值必须是一个空名称 ("")。

指定者：
接口 Context 中的 composeName
参数：
name - 相对于此上下文的名称
prefix - 此上下文相对于其一个祖先的名称
返回：
prefix 和 name 的组合
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.composeName(String, String)

addToEnvironment

public Object addToEnvironment(String propName,
                               Object propVal)
                        throws NamingException
从接口 Context 复制的描述
将一个新环境属性添加到此上下文的环境中。如果该属性已经存在，则重写该属性的值。有关环境属性的更多详细信息，请参阅类描述。

指定者：
接口 Context 中的 addToEnvironment
参数：
propName - 要添加的环境属性的名称，不能为 null
propVal - 要添加的属性的值，不能为 null
返回：
该属性以前的值，如果该属性以前不在此环境中，则返回 null
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.getEnvironment(), Context.removeFromEnvironment(String)

removeFromEnvironment

public Object removeFromEnvironment(String propName)
                             throws NamingException
从接口 Context 复制的描述
从此上下文的环境中移除一个环境属性。有关环境属性的更多详细信息，请参阅类描述。

指定者：
接口 Context 中的 removeFromEnvironment
参数：
propName - 要移除的环境属性的名称，不能为 null
返回：
该属性以前的值，如果该属性以前不在此环境中，则返回 null
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.getEnvironment(), Context.addToEnvironment(String, Object)

getEnvironment

public Hashtable<?,?> getEnvironment()
                              throws NamingException
从接口 Context 复制的描述
检索对此上下文有效的环境。有关环境属性的更多详细信息，请参阅类描述。

调用者不应对返回的对象进行任何更改：因为这些更改对于上下文的影响是不确定的。可以使用 addToEnvironment() 和 removeFromEnvironment() 更改此上下文的环境。

指定者：
接口 Context 中的 getEnvironment
返回：
此上下文的环境，决不能为 null
抛出：
NamingException - 如果遇到命名异常
另请参见：
Context.addToEnvironment(String, Object), Context.removeFromEnvironment(String)

close

public void close()
           throws NamingException
从接口 Context 复制的描述
关闭此上下文。此方法立即释放此上下文的资源，而不是等待垃圾回收器自动释放它们。

此方法是幂等的：对已经关闭的上下文调用此方法无效。对已关闭的上下文调用其他任何方法都是不允许的，这会导致不确定的行为。

指定者：
接口 Context 中的 close
抛出：
NamingException - 如果遇到命名异常

getNameInNamespace

public String getNameInNamespace()
                          throws NamingException
从接口 Context 复制的描述
在此上下文自己的名称空间中检索其完全名称。

许多命名服务都有一个“完全名称”的概念，用于其各自的名称空间中的对象。例如，LDAP 项有一个独特的名称，而 DNS 记录有一个完全限定名。此方法允许客户端应用程序检索此名称。此方法返回的字符串不是一个 JNDI 复合名称，不应将它直接传递给上下文方法。在没有完全名称概念的命名系统中，将抛出 OperationNotSupportedException。

指定者：
接口 Context 中的 getNameInNamespace
返回：
此上下文在其自己的名称空间中的名称，决不能为 null
抛出：
OperationNotSupportedException - 如果命名系统没有完全名称的概念
NamingException - 如果遇到命名异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InsufficientResourcesException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 InsufficientResourcesException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.InsufficientResourcesException
所有已实现的接口：
Serializable
public class InsufficientResourcesException
extends NamingException

当无法使用资源完成所请求的操作时，抛出此异常。这可能是因为服务器或客户端上的资源缺乏。对于资源类型没有任何限制，因为不同的服务可能使用不同的资源。这些限制可能是因为物理限制和/或管理定额。有限资源的示例有内部缓冲区、内存和网络带宽。

InsufficientResourcesException 与 LimitExceededException 的不同之处在于，后者是因为用户/系统指定了限制而导致的。有关细节请参见 LimitExceededException。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InsufficientResourcesException()
构造一个新的 InsufficientResourcesException 实例，将解释和所有名称解析字段初始化为 null。
InsufficientResourcesException(String explanation)
使用解释构造一个新的 InsufficientResourcesException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InsufficientResourcesException

public InsufficientResourcesException(String explanation)
使用解释构造一个新的 InsufficientResourcesException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的可能为 null 的附加详细信息。
另请参见：
Throwable.getMessage()

InsufficientResourcesException

public InsufficientResourcesException()
构造一个新的 InsufficientResourcesException 实例，将解释和所有名称解析字段初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InterruptedNamingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 InterruptedNamingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.InterruptedNamingException
所有已实现的接口：
Serializable
public class InterruptedNamingException
extends NamingException

当正被调用的命名操作已经被中断时，抛出此异常。例如，应用程序可以中断正在执行搜索的线程。如果该搜索支持被中断，则将抛出 InterruptedNamingException。某一操作是否是可中断的以及何时中断取决于其实现（由服务提供者提供）。不同的实现使用不同的方式来避免其资源和对象因为无法预期的中断而毁坏。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
Context, DirContext, Thread.interrupt(), InterruptedException, 序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InterruptedNamingException()
构造一个 InterruptedNamingException 实例，将解释和所有名称解析字段初始化为 null。
InterruptedNamingException(String explanation)
使用问题的解释构造一个 InterruptedNamingException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InterruptedNamingException

public InterruptedNamingException(String explanation)
使用问题的解释构造一个 InterruptedNamingException 实例。所有与解析有关的名称字段都被初始化为 null。

参数：
explanation - 解释问题的可能为 null 的消息。
另请参见：
Throwable.getMessage()

InterruptedNamingException

public InterruptedNamingException()
构造一个 InterruptedNamingException 实例，将解释和所有名称解析字段初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidNameException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 InvalidNameException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.InvalidNameException
所有已实现的接口：
Serializable
public class InvalidNameException
extends NamingException

此异常指示被指定的名称不符合命名系统的命名语法。此异常由任何进行名称解析的方法（比如 Context、DirContext、CompositeName 和 CompoundName 中的那些方法）抛出。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
Context, DirContext, CompositeName, CompoundName, NameParser, 序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InvalidNameException()
构造一个 InvalidNameException 实例，将所有字段设置为 null。
InvalidNameException(String explanation)
使用问题的解释构造一个 InvalidNameException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidNameException

public InvalidNameException(String explanation)
使用问题的解释构造一个 InvalidNameException 实例。其他所有字段都被初始化为 null。

参数：
explanation - 解释问题的可能为 null 的消息。
另请参见：
Throwable.getMessage()

InvalidNameException

public InvalidNameException()
构造一个 InvalidNameException 实例，将所有字段设置为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LimitExceededException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 LimitExceededException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.LimitExceededException
所有已实现的接口：
Serializable
直接已知子类：
SizeLimitExceededException, TimeLimitExceededException
public class LimitExceededException
extends NamingException

当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。此异常与 InsufficientResourceException 的不同之处在于，LimitExceededException 是因为用户/系统指定的限制而抛出的。例如，为完成请求而耗尽内存是资源不足异常。客户端请求 10 个答案却得到 11 个答案则是大小限制异常。

这些限制的示例包括客户端和服务器配置限制，比如大小、时间、跳数，等等。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
LimitExceededException()
构造一个新的 LimitExceededException 实例，将解释和所有名称解析字段初始化为 null。
LimitExceededException(String explanation)
使用解释构造一个新的 LimitExceededException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LimitExceededException

public LimitExceededException()
构造一个新的 LimitExceededException 实例，将解释和所有名称解析字段初始化为 null。

LimitExceededException

public LimitExceededException(String explanation)
使用解释构造一个新的 LimitExceededException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的可能为 null 的详细信息。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 LinkException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.LinkException
所有已实现的接口：
Serializable
直接已知子类：
LinkLoopException, MalformedLinkException
public class LinkException
extends NamingException

此异常用于描述解析链接时遇到的问题。向基本 NamingException 添加补充信息，用来指出该链接所具有的问题。

与 NamingException 捕获名称解析信息的方式类似，LinkException 捕获指出解析某一链接时所遇问题的“链接”名称解析信息。所有字段都可以为 null。

  • Link Resolved Name。已解析的链接名称部分。
  • Link Resolved Object。将要进行链接名称解析的对象。
  • Link Remaining Name。未解析的链接名称部分。
  • Link Explanation。解释链接解析失败原因的详细信息。

LinkException 实例与并发多线程访问不同步。试图访问和修改单个 LinkException 实例的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
Context.lookupLink(javax.naming.Name), LinkRef, 序列化表格

字段摘要
protected String | linkExplanation 包含链接解析失败原因的异常。
protected Name | linkRemainingName 包含尚未解析的剩余链接名称。
protected Name | linkResolvedName 包含已成功解析的链接部分。
protected Object | linkResolvedObj 包含一个对象，已成功解析的链接部分一直到达该对象。
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
LinkException()
构造一个新的 LinkException 实例。
LinkException(String explanation)
使用解释构造一个新的 LinkException 实例，其他所有字段都初始化为 null。
方法摘要
String | getLinkExplanation() 检索与解析某一链接时遇到的问题关联的解释。
Name | getLinkRemainingName() 检索链接名称的剩余未解析部分。
Name | getLinkResolvedName() 检索成功被解析的链接名称的开头部分。
Object | getLinkResolvedObj() 检索已成功解析成的对象。
void | setLinkExplanation(String msg) 设置与解析某一链接时所遇问题关联的解释。
void | setLinkRemainingName(Name name) 设置此异常的剩余链接名称字段。
void | setLinkResolvedName(Name name) 设置此异常的已解析链接名称字段。
void | setLinkResolvedObj(Object obj) 设置此异常的已解析链接对象字段。
String | toString() 生成此异常的字符串表示形式。
String | toString(boolean detail) 生成此异常的字符串表示形式。
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

linkResolvedName

protected Name linkResolvedName
包含已成功解析的链接部分。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
getLinkResolvedName(), setLinkResolvedName(javax.naming.Name)

linkResolvedObj

protected Object linkResolvedObj
包含一个对象，已成功解析的链接部分一直到达该对象。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
getLinkResolvedObj(), setLinkResolvedObj(java.lang.Object)

linkRemainingName

protected Name linkRemainingName
包含尚未解析的剩余链接名称。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
getLinkRemainingName(), setLinkRemainingName(javax.naming.Name)

linkExplanation

protected String linkExplanation
包含链接解析失败原因的异常。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
getLinkExplanation(), setLinkExplanation(java.lang.String)
构造方法详细信息

LinkException

public LinkException(String explanation)
使用解释构造一个新的 LinkException 实例，其他所有字段都初始化为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

LinkException

public LinkException()
构造一个新的 LinkException 实例。所有与链接无关的和与链接有关的字段都被初始化为 null。

方法详细信息

getLinkResolvedName

public Name getLinkResolvedName()
检索成功被解析的链接名称的开头部分。

返回：
成功被解析的链接名称部分。该名称是一个复合名称。它可以为 null，表示尚未设置已解析链接名称字段。
另请参见：
getLinkResolvedObj(), setLinkResolvedName(javax.naming.Name)

getLinkRemainingName

public Name getLinkRemainingName()
检索链接名称的剩余未解析部分。

返回：
未被解析的链接名称部分。该名称是一个复合名称。它可以为 null，表示尚未设置链接剩余解析名称字段。
另请参见：
setLinkRemainingName(javax.naming.Name)

getLinkResolvedObj

public Object getLinkResolvedObj()
检索已成功解析成的对象。该对象是已解析的链接名称被绑定到的对象。

返回：
到目前为止已解析的可能为 null 的对象。如果为 null，则意味着尚未设置已解析链接对象字段。
另请参见：
getLinkResolvedName(), setLinkResolvedObj(java.lang.Object)

getLinkExplanation

public String getLinkExplanation()
检索与解析某一链接时遇到的问题关联的解释。

返回：
更详细地解释有关解析某一链接时所遇问题的可能为 null 的字符串。如果为 null，则意味着没有此异常的链接细节消息。
另请参见：
setLinkExplanation(java.lang.String)

setLinkExplanation

public void setLinkExplanation(String msg)
设置与解析某一链接时所遇问题关联的解释。

参数：
msg - 更详细地解释有关解析某一链接时所遇问题的可能为 null 的字符串。如果为 null，则意味着没有记录任何细节信息。
另请参见：
getLinkExplanation()

setLinkResolvedName

public void setLinkResolvedName(Name name)
设置此异常的已解析链接名称字段。

name 是一个复合名称。如果打算使用复合名称或字符串设置此字段，则必须将该复合名称“字符串化”，并用使用该字符串的单个组件创建一个复合名称。然后可以使用得到的复合名称调用此方法。

创建并存储 name 的副本。对 name 进行的后续更改不会影响此 NamingException 中的副本，反之亦然。

参数：
name - 用来设置已解析链接名称的名称。此值可以为 null。如果为 null，则将已解析链接名称字段设置为 null。
另请参见：
getLinkResolvedName()

setLinkRemainingName

public void setLinkRemainingName(Name name)
设置此异常的剩余链接名称字段。

name 是一个复合名称。如果打算使用复合名称或字符串设置此字段，则必须将该复合名称“字符串化”，并用使用该字符串的单个组件创建一个复合名称。然后可以使用得到的复合名称调用此方法。

创建并存储 name 的副本。对 name 进行的后续更改不会影响此 NamingException 中的副本，反之亦然。

参数：
name - 用来设置剩余链接名称的名称。此值可以为 null。如果其为 null，则将剩余的名称字段设置为 null。
另请参见：
getLinkRemainingName()

setLinkResolvedObj

public void setLinkResolvedObj(Object obj)
设置此异常的已解析链接对象字段。此字段指示最后一个成功解析的链接名称对象。

参数：
obj - 用来设置已解析链接对象的对象。此值可以为 null。如果为 null，则将已解析链接对象字段设置为 null。
另请参见：
getLinkResolvedObj()

toString

public String toString()
生成此异常的字符串表示形式。此字符串由 NamingException 信息和链接的剩余名称组成。此字符串用于调试，不以编程方式进行解释。

覆盖：
类 NamingException 中的 toString
返回：
此链接异常的非 null 字符串表示形式。

toString

public String toString(boolean detail)
生成此异常的字符串表示形式。此字符串由 NamingException 信息和解析链接的附加信息组成。如果 'detail' 为 true，则该字符串还包含有关已解析链接对象的信息。如果为 false，则此方法在形式上与不接受任何参数的 toString() 方法相同。此字符串用于调试，不以编程方式进行解释。

覆盖：
类 NamingException 中的 toString
参数：
detail - 如果为 true，则添加有关已解析链接对象的信息。
返回：
此链接异常的非 null 字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkLoopException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 LinkLoopException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.LinkException
                    继承者  javax.naming.LinkLoopException
所有已实现的接口：
Serializable
public class LinkLoopException
extends LinkException

当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。

应用于 LinkException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
LinkRef, 序列化表格

字段摘要
从类 javax.naming.LinkException 继承的字段
linkExplanation, linkRemainingName, linkResolvedName, linkResolvedObj
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
LinkLoopException()
构造一个新的 LinkLoopException 实例。
LinkLoopException(String explanation)
使用解释构造一个新的 LinkLoopException 实例，其他所有字段都被初始化为 null。
方法摘要
从类 javax.naming.LinkException 继承的方法
getLinkExplanation, getLinkRemainingName, getLinkResolvedName, getLinkResolvedObj, setLinkExplanation, setLinkRemainingName, setLinkResolvedName, setLinkResolvedObj, toString, toString
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LinkLoopException

public LinkLoopException(String explanation)
使用解释构造一个新的 LinkLoopException 实例，其他所有字段都被初始化为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

LinkLoopException

public LinkLoopException()
构造一个新的 LinkLoopException 实例。所有与链接无关的和与链接有关的字段都被初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LinkRef (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 LinkRef

java.lang.Object
    继承者  javax.naming.Reference
        继承者  javax.naming.LinkRef
所有已实现的接口：
Serializable, Cloneable
public class LinkRef
extends Reference

此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。

该名称是一个 URL，或者是一个将被相对于初始上下文解析的名称，如果该名称的第一个字符是 "."，则它相对于绑定该链接的上下文。

在上下文操作中，普通的名称解析总是根据链接进行的。解析链接名称本身可能导致该解析通过其他链接。这可能导致链接循环，该循环中的解析通常无法终止。有一个避免这类无法终止的解析的简单方法，即服务提供者可以定义一个关于调用者调用的任何单独操作中可以涉及的链接数的限制。

LinkRef 包含单个 StringRefAddr，其类型为 "LinkAddress"，其内容则是一个链接名称。Reference 的类名称字段是此 (LinkRef) 类的类名称字段。

可使用标准的 Context.bind()/rebind() 和 DirContext.bind()/rebind() 将 LinkRef 绑定到一个名称。如果最终原子名称被绑定到某一链接，则使用 Context.lookupLink() 来检索该链接本身。

许多命名系统支持可在该命名系统本身中使用的本机链接概念。JNDI 不指定这类本机链接与 JNDI 链接之间是否存在任何关系。

LinkRef 实例与多个线程的并发访问不同步。需要并发地访问 LinkRef 的线程应该在它们之间实现同步并提供所需的锁定。

从以下版本开始：
1.3
另请参见：
LinkException, LinkLoopException, MalformedLinkException, Context.lookupLink(javax.naming.Name), 序列化表格

字段摘要
从类 javax.naming.Reference 继承的字段
addrs, classFactory, classFactoryLocation, className
构造方法摘要
LinkRef(Name linkName)
为某一名称构造一个 LinkRef。
LinkRef(String linkName)
为某一字符串名称构造一个 LinkRef。
方法摘要
 String getLinkName()
检索此链接的名称。
从类 javax.naming.Reference 继承的方法
add, add, clear, clone, equals, get, get, getAll, getClassName, getFactoryClassLocation, getFactoryClassName, hashCode, remove, size, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

LinkRef

public LinkRef(Name linkName)
为某一名称构造一个 LinkRef。

参数：
linkName - 将为其创建此链接的非 null 名称。

LinkRef

public LinkRef(String linkName)
为某一字符串名称构造一个 LinkRef。

参数：
linkName - 将为其创建此链接的非 null 名称。
方法详细信息

getLinkName

public String getLinkName()
                   throws NamingException
检索此链接的名称。

返回：
此链接的非 null 名称。
抛出：
MalformedLinkException - 如果无法提取链接名称
NamingException - 如果遇到命名异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MalformedLinkException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 MalformedLinkException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.LinkException
                    继承者  javax.naming.MalformedLinkException
所有已实现的接口：
Serializable
public class MalformedLinkException
extends LinkException

如果在解析或构造链接时遇到错误链接，则抛出此异常。

应用于 LinkException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
LinkRef.getLinkName(), LinkRef, 序列化表格

字段摘要
从类 javax.naming.LinkException 继承的字段
linkExplanation, linkRemainingName, linkResolvedName, linkResolvedObj
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
MalformedLinkException()
构造一个新的 Malformed LinkException 实例。
MalformedLinkException(String explanation)
使用解释构造一个新的 MalformedLinkException 实例，其他所有字段都被初始化为 null。
方法摘要
从类 javax.naming.LinkException 继承的方法
getLinkExplanation, getLinkRemainingName, getLinkResolvedName, getLinkResolvedObj, setLinkExplanation, setLinkRemainingName, setLinkResolvedName, setLinkResolvedObj, toString, toString
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MalformedLinkException

public MalformedLinkException(String explanation)
使用解释构造一个新的 MalformedLinkException 实例，其他所有字段都被初始化为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。

MalformedLinkException

public MalformedLinkException()
构造一个新的 Malformed LinkException 实例。所有字段都被初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Name (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
接口 Name

所有超级接口：
Cloneable, Comparable<Object>, Serializable
所有已知实现类：
CompositeName, CompoundName, LdapName
public interface Name
extends Cloneable, Serializable, Comparable<Object>

Name 接口表示一个一般名称，即一个有序的组件序列。该名称可以是一个复合名称（跨多个名称空间的名称），或是一个组合名称（在各个分层的命名系统中使用的名称）。

可以有不同的 Name 实现；例如，复合名称、URL 或特定于名称空间的组合名称。

名称的组件都已编号。带 N 个组件的名称的索引在 0 到 N（但不包括 N）的范围内变动。可将该范围写为 [0,N)。最重要的组件位于索引 0 处。空名称没有组件。

此接口中的所有方法都不接收 null 作为一个参数（名称和名称组件）的有效值。同样，返回名称或名称组件的方法绝不会返回 null。

Name 的实例在不是只读访问时无法与并发多线程访问同步。

从以下版本开始：
1.3

字段摘要
static long serialVersionUID
为指示与以前的类版本序列化兼容而设置的类指纹。
方法摘要
Name | add(int posn, String comp) 在此名称中的指定位置添加单个组件。
Name | add(String comp) 将单个组件添加到此名称的末尾。
Name | addAll(int posn, Name n) 按顺序将名称的组件添加到此名称中的指定位置。
Name | addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Object | clone() 生成此名称的新副本。
int | compareTo(Object obj) 比较此名称与另一个名称的顺序。
boolean | endsWith(Name n) 确定此名称是否以某一指定后缀结束。
String | get(int posn) 检索此名称的组件。
Enumeration<String> | getAll() 以字符串枚举的形式检索此名称的组件。
Name | getPrefix(int posn) 创建一个名称，其组件由此名称中组件的前缀组成。
Name | getSuffix(int posn) 创建一个名称，其组件由此名称中组件的后缀组成。
boolean | isEmpty() 确定此名称是否为空。
Object | remove(int posn) 从此名称中移除一个组件。
int | size() 返回此名称中的组件数。
boolean | startsWith(Name n) 确定此名称是否从某一指定前缀开始。

字段详细信息

serialVersionUID

static final long serialVersionUID
为指示与以前的类版本序列化兼容而设置的类指纹。

另请参见：
常量字段值
方法详细信息

clone

Object clone()
生成此名称的新副本。对此名称的组件进行的后续更改不会影响新副本，反之亦然。

返回：
此名称的副本
另请参见：
Object.clone()

compareTo

int compareTo(Object obj)
比较此名称与另一个名称的顺序。根据此名称小于、等于还是大于给定名称分别返回负整数、零或正整数。

对于 Object.equals()，名称排序的概念取决于实现此接口的类。例如，该排序可能基于名称组件的字典顺序进行。该名称的特定属性（比如对待大小写的方式）可能影响排序。通常，无法比较两个不同类的名称。

指定者：
接口 Comparable<Object> 中的 compareTo
参数：
obj - 要与之比较的非 null 对象。
返回：
根据此名称小于、等于还是大于给定名称分别返回负整数、零或正整数
抛出：
ClassCastException - 如果 obj 不是一个可以与此名称进行比较的类型的 Name
另请参见：
Comparable.compareTo(Object)

size

int size()
返回此名称中的组件数。

返回：
此名称中的组件数。

isEmpty

boolean isEmpty()
确定此名称是否为空。空名称是没有任何组件的名称。

返回：
如果此名称为空，则返回 true，否则返回 false

getAll

Enumeration<String> getAll()
以字符串枚举的形式检索此名称的组件。在该枚举上更新此名称的效果是不确定的。如果该名称没有组件，则返回空（非 null）枚举。

返回：
此名称的组件所组成的枚举，每个组件都是一个字符串

get

String get(int posn)
检索此名称的组件。

参数：
posn - 要检索的从 0 开始的组件索引。该索引必须在范围 [0,size()) 内。
返回：
索引 posn 处的组件
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围

getPrefix

Name getPrefix(int posn)
创建一个名称，其组件由此名称中组件的前缀组成。对此名称进行的后续更改不会影响返回的名称，反之亦然。

参数：
posn - 从 0 开始的组件索引，在该索引处停止。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [0,posn) 之间的组件组成的名称。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围

getSuffix

Name getSuffix(int posn)
创建一个名称，其组件由此名称中组件的后缀组成。对此名称进行的后续更改不会影响返回的名称，反之亦然。

参数：
posn - 从 0 开始的组件索引，从该索引处开始。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [posn,size()) 之间的组件组成的名称。如果 posn 等于 size()，则返回一个空名称。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围

startsWith

boolean startsWith(Name n)
确定此名称是否从某一指定前缀开始。如果该方法与 getPrefix(n.size()) 等效，则名称 n 是一个前缀。

参数：
n - 要检查的名称
返回：
如果 n 是此名称的前缀，则返回 true，否则返回 false

endsWith

boolean endsWith(Name n)
确定此名称是否以某一指定后缀结束。如果该方法与 getSuffix(size()-n.size()) 等效，则名称 n 是一个后缀。

参数：
n - 要检查的名称
返回：
如果 n 是此名称的后缀，则返回 true，否则返回 false

addAll

Name addAll(Name suffix)
            throws InvalidNameException
按顺序将名称的组件添加到此名称的末尾。

参数：
suffix - 要添加的组件
返回：
更新的名称（不是新名称）
抛出：
InvalidNameException - 如果 suffix 不是一个有效名称，或者添加组件将违反此名称的语法规则

addAll

Name addAll(int posn,
            Name n)
            throws InvalidNameException
按顺序将名称的组件添加到此名称中的指定位置。此名称位于第一个新组件索引处或这之后的组件被上移（远离索引 0），以容纳新的组件。

参数：
n - 要添加的组件
posn - 此名称中的索引，将在该索引处添加新组件。该索引必须在范围 [0,size()] 内。
返回：
更新的名称（不是新名称）
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围
InvalidNameException - 如果 n 不是一个有效名称，或者添加组件将违反此名称的语法规则

add

Name add(String comp)
         throws InvalidNameException
将单个组件添加到此名称的末尾。

参数：
comp - 要添加的组件
返回：
更新的名称（不是新名称）
抛出：
InvalidNameException - 如果添加 comp 将违反此名称的语法规则

add

Name add(int posn,
         String comp)
         throws InvalidNameException
在此名称中的指定位置添加单个组件。此名称位于新组件索引处或这之后的组件被上移（远离索引 0）一位，以容纳新组件。

参数：
comp - 要添加的组件
posn - 将在其所在位置处添加新组件的索引。该索引必须在范围 [0,size()] 内。
返回：
更新的名称（不是新名称）
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围
InvalidNameException - 如果添加 comp 将违反此名称的语法规则

remove

Object remove(int posn)
              throws InvalidNameException
从此名称中移除一个组件。移除此名称位于指定位置处的组件。索引大于此位置的组件都被下移（朝向索引 0）一位。

参数：
posn - 要移除的组件的索引。该索引必须在范围 [0,size()) 内。
返回：
移除的组件（一个 String）
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 超出指定范围
InvalidNameException - 如果删除组件将违反该名称的语法规则
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameAlreadyBoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NameAlreadyBoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NameAlreadyBoundException
所有已实现的接口：
Serializable
public class NameAlreadyBoundException
extends NamingException

一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
Context.bind(javax.naming.Name, java.lang.Object),
Context.rebind(javax.naming.Name, java.lang.Object),
Context.createSubcontext(javax.naming.Name),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
NameAlreadyBoundException()
构造一个新的 NameAlreadyBoundException 实例。
NameAlreadyBoundException(String explanation)
使用所提供的解释构造一个新的 NameAlreadyBoundException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NameAlreadyBoundException

public NameAlreadyBoundException(String explanation)
使用所提供的解释构造一个新的 NameAlreadyBoundException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的可能为 null 的附加详细信息。
另请参见：
Throwable.getMessage()

NameAlreadyBoundException

public NameAlreadyBoundException()
构造一个新的 NameAlreadyBoundException 实例。所有字段都被设置为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameClassPair (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NameClassPair

java.lang.Object
    继承者  javax.naming.NameClassPair
所有已实现的接口：
Serializable
直接已知子类：
Binding
public class NameClassPair
extends Object
implements Serializable

此类表示存在于上下文中的某一绑定的对象名称和类名称对。

上下文由名称到对象的绑定组成。NameClassPair 类表示所绑定对象的名称和类。它由一个名称和表示包限定类名称的字符串组成。

对于动态生成名称/类对内容的命名系统，要创建子类。

NameClassPair 实例与多个线程的并发访问不同步。需要并发地访问 NameClassPair 的线程应该在它们之间实现同步并提供所需的锁定。

从以下版本开始：
1.3
另请参见：
Context.list(javax.naming.Name), 序列化表格

构造方法摘要
NameClassPair(String name, String className)
在给定名称和类名称的情况下构造一个 NameClassPair 实例。
NameClassPair(String name, String className, boolean isRelative)
在给定其名称、类名称以及该名称是否相对于列表上下文的情况下构造一个 NameClassPair 实例。
方法摘要
 String getClassName()
检索绑定到此绑定名称的对象的类名称。
 String getName()
检索此绑定的名称。
 String getNameInNamespace()
检索此绑定的完全名称。
 boolean isRelative()
确定此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。
 void setClassName(String name)
设置此绑定的类名称。
 void setName(String name)
设置此绑定的名称。
 void setNameInNamespace(String fullName)
设置此绑定的完全名称。
 void setRelative(boolean r)
设置此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。
 String toString()
生成此名称/类对的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NameClassPair

public NameClassPair(String name,
                     String className)
在给定名称和类名称的情况下构造一个 NameClassPair 实例。

参数：
name - 对象的非 null 名称。它是相对于目标上下文（由 list() 方法的第一个参数指定）的名称
className - 绑定到 name 的对象的类名称（可能为 null）。如果所绑定的对象为 null，则该参数为 null。
另请参见：
getClassName(),
setClassName(java.lang.String),
getName(),
setName(java.lang.String)

NameClassPair

public NameClassPair(String name,
                     String className,
                     boolean isRelative)
在给定其名称、类名称以及该名称是否相对于列表上下文的情况下构造一个 NameClassPair 实例。

参数：
name - 对象的非 null 名称。
className - 绑定到 name 的对象的类名称（可能为 null）。如果所绑定的对象为 null，则该参数为 null。
isRelative - 如果 name 是一个相对于目标上下文（由 list() 方法的第一个参数命名）的名称，则该参数为 true；如果 name 是一个 URL 字符串，则该参数为 false。
另请参见：
getClassName(),
setClassName(java.lang.String),
getName(),
setName(java.lang.String),
isRelative(),
setRelative(boolean)
方法详细信息

getClassName

public String getClassName()
检索绑定到此绑定名称的对象的类名称。如果绑定了某一引用或其他一些间接信息，则检索将由 Binding.getObject() 返回的最终对象的类名称。

返回：
所绑定对象的可能为 null 的类名称。如果所绑定的对象为 null，则该参数为 null。
另请参见：
Binding.getObject(),
Binding.getClassName(),
setClassName(java.lang.String)

getName

public String getName()
检索此绑定的名称。如果 isRelative() 为 true，则此名称相对于目标上下文（由 list() 的第一个参数命名）。如果 isRelative() 为 false，则此名称是一个 URL 字符串。

返回：
此绑定的非 null 名称。
另请参见：
isRelative(), setName(java.lang.String)

setName

public void setName(String name)
设置此绑定的名称。

参数：
name - 将用作该名称的非 null 字符串。
另请参见：
getName(), setRelative(boolean)

setClassName

public void setClassName(String name)
设置此绑定的类名称。

参数：
name - 将用作类名称的可能为 null 的字符串。如果为 null，则 Binding.getClassName() 将返回该绑定中对象的实际类名称。如果所绑定对象为 null，则类名称也将为 null。
另请参见：
getClassName(), Binding.getClassName()

isRelative

public boolean isRelative()
确定此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。

返回：
如果此绑定的名称相对于目标上下文，则返回 true；如果此绑定的名称是一个 URL 字符串，则返回 false。
另请参见：
setRelative(boolean), getName()

setRelative

public void setRelative(boolean r)
设置此绑定的名称是否相对于目标上下文（由 list() 方法的第一个参数命名）。

参数：
r - 如果为 true，则绑定的名称相对于目标上下文；如果为 false，则绑定的名称是一个 URL 字符串。
另请参见：
isRelative(), setName(java.lang.String)

getNameInNamespace

public String getNameInNamespace()
检索此绑定的完全名称。该完全名称是此绑定在其自己的名称空间中的绝对名称。请参见 Context.getNameInNamespace()。

在没有将完全名称的概念应用于此绑定的命名系统中，将抛出 UnsupportedOperationException。使用引入该方法之前编写的服务提供者时也会抛出此异常。

此方法返回的字符串不是一个 JNDI 复合名称，不应将它直接传递给上下文方法。

返回：
此绑定的完全名称。
抛出：
UnsupportedOperationException - 如果完全名称的概念没有应用于命名系统中的此绑定。
从以下版本开始：
1.5
另请参见：
setNameInNamespace(java.lang.String), getName()

setNameInNamespace

public void setNameInNamespace(String fullName)
设置此绑定的完全名称。只要创建 NameClassPair 并且一个完全名称可应用于此绑定，就必须调用此方法设置完全名称。

将完全名称设置为 null（或者根本不设置它）将导致 getNameInNamespace() 抛出异常。

参数：
fullName - 要使用的完全名称。
从以下版本开始：
1.5
另请参见：
getNameInNamespace(), setName(java.lang.String)

toString

public String toString()
生成此名称/类对的字符串表示形式。该字符串表示形式由以冒号 (':') 分隔的名称和类名称组成。此字符串的内容用于调试目的，不以编程方式对其进行解释。

覆盖：
类 Object 中的 toString
返回：
此名称/类对的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NameNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NameNotFoundException
所有已实现的接口：
Serializable
public class NameNotFoundException
extends NamingException

当名称的组件由于没有被绑定而无法解析时，抛出此异常。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
NameNotFoundException()
构造一个新的 NameNotFoundException 实例，将解释和所有名称解析字段和初始化为 null。
NameNotFoundException(String explanation)
使用所提供的解释构造一个新的 NameNotFoundException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NameNotFoundException

public NameNotFoundException(String explanation)
使用所提供的解释构造一个新的 NameNotFoundException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的可能为 null 的附加详细信息。
另请参见：
Throwable.getMessage()

NameNotFoundException

public NameNotFoundException()
构造一个新的 NameNotFoundException 实例，将解释和所有名称解析字段和初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameParser (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
接口 NameParser

public interface NameParser

此接口用于解析取自分层的名称空间的名称。NameParser 包含解析这些名称所需的语法信息知识（比如从左到右的方向、名称分隔符，等等）。 在使用 equals() 方法比较两个 NameParser 时，当且仅当它们服务于相同的名称空间时才返回 true。

从以下版本开始：
1.3
另请参见：
CompoundName, Name

方法摘要
 Name parse(String name)
将某一名称解析成其组件。

方法详细信息

parse

Name parse(String name)
           throws NamingException
将某一名称解析成其组件。

参数：
name - 要解析的非 null 字符串名称。
返回：
名称的非 null 已解析形式，它是使用此解析器的命名约定解析的。
抛出：
InvalidNameException - 如果名称不符合为名称空间定义的语法。
NamingException - 如果遇到命名异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingEnumeration (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
接口 NamingEnumeration<T>

所有超级接口：
Enumeration<T>
public interface NamingEnumeration<T>
extends Enumeration<T>

此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。它扩展了 Enumeration，允许在枚举期间抛出异常。

当某一方法（比如 list()、listBindings() 或 search()）返回 NamingEnumeration 时，在返回所有结果之前，将保留所遇到的所有异常。在枚举结束时抛出异常（由 hasMore() 完成）。

例如，如果 list() 只返回一部分内容，则相应的异常将是 PartialResultException。list() 将先返回一个 NamingEnumeration。当已由 NamingEnumeration 的 next() 返回最后结果时，调用 hasMore() 将导致抛出 PartialResultException。

在另一个示例中，在指定大小限制为 'n' 的情况下调用 search() 方法。如果结果由 'n' 个以上的结果组成，则 search() 将首先返回一个 NamingEnumeration。当已经通过对 NamingEnumeration 调用 next() 返回了第 n 个结果时，将在调用 hasMore() 时抛出 SizeLimitExceedException。

注意，如果程序使用 hasMoreElements() 和 nextElement() 而不是在 NamingEnumeration 上迭代，那么因为这些方法无法抛出异常，所以不会抛出异常。此外，在前面的示例中，在 nextElement() 已返回第 n 个结果后，调用 hasMoreElements() 将返回 false。

还要注意的是，如果在枚举中没有剩余元素时该程序调用 next() 或 nextElement()，则将抛出 NoSuchElementException。通过使用 hasMore() 和 hasMoreElements() 检查是否已经到达枚举末尾，程序总是可以避免此异常。

如果枚举期间抛出异常，则该枚举变得无效。对该枚举后续调用任何方法都将产生不确定的结果。

从以下版本开始：
1.3
另请参见：
Context.list(javax.naming.Name),
Context.listBindings(javax.naming.Name),
DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]),
Attributes.getAll(),
Attributes.getIDs(),
Attribute.getAll()

方法摘要
void | close() 关闭此枚举。
boolean | hasMore() 确定枚举中是否还有元素。
T | next() 检索枚举中的下一个元素。
从接口 java.util.Enumeration 继承的方法
hasMoreElements, nextElement

方法详细信息

next

T next()
       throws NamingException
检索枚举中的下一个元素。此方法允许应用程序捕获并处理在检索下一个元素时遇到的命名异常。

注意，next() 还可以抛出运行时异常 NoSuchElementException，指示调用者试图超出枚举的尾部进行枚举。此异常不同于 NamingException，后者指示在获得下一个元素时存在问题，比如说，因为某一项引用或者服务器不可用等等。

返回：
枚举中的元素（可能为 null）。只有对于可以返回 null 的枚举而言，null 才是有效值（例如，Attribute.getAll() 返回一个属性值所组成的枚举，属性值可以为 null）。
抛出：
NamingException - 如果在试图检索下一个元素时遇到命名异常。有关可能的命名异常，请参见 NamingException 及其子类。
NoSuchElementException - 如果试图在没有元素可用时获得下一个元素。
另请参见：
Enumeration.nextElement()

hasMore

boolean hasMore()
                throws NamingException
确定枚举中是否还有元素。此方法允许应用程序捕获并处理在确定是否还有元素时遇到的命名异常。

返回：
如果枚举中还有元素，则返回 true；否则返回 false。
抛出：
NamingException - 如果在试图确定枚举中是否还有另一个元素时遇到命名异常。有关可能的命名异常，请参见 NamingException 及其子类。
另请参见：
Enumeration.hasMoreElements()

close

void close()
           throws NamingException
关闭此枚举。 当已对此枚举调用此方法之后，枚举变得无效，并且对其方法的任何后续调用都将产生不确定的结果。此方法主要用于终止枚举，释放资源。如果枚举进行到结尾处（也就是说，一直到 hasMoreElements() 或 hasMore() 返回 false），则资源将被自动释放，无需显式调用 close()。

此方法指示服务提供者随意释放与该枚举关联的资源，并且可以通知服务器取消任何未处理的请求。close() 方法是实现管理其资源的一个提示。当客户端忽略 close() 调用时，建议实现使用适当的算法管理其资源。

抛出：
NamingException - 如果关闭枚举时遇到命名异常。
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NamingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
所有已实现的接口：
Serializable
直接已知子类：
AttributeInUseException, AttributeModificationException, CannotProceedException, CommunicationException, ConfigurationException, ContextNotEmptyException, InsufficientResourcesException, InterruptedNamingException, InvalidAttributeIdentifierException, InvalidAttributesException, InvalidAttributeValueException, InvalidNameException, InvalidSearchControlsException, InvalidSearchFilterException, LimitExceededException, LinkException, NameAlreadyBoundException, NameNotFoundException, NamingSecurityException, NoInitialContextException, NoSuchAttributeException, NotContextException, OperationNotSupportedException, PartialResultException, ReferralException, SchemaViolationException, ServiceUnavailableException
public class NamingException
extends Exception

此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。失败的特性由子类的名称描述。此异常捕获指出操作失败处的信息，比如解析最后进行到的位置。

  • 已解析名称。已解析的名称部分。
  • 已解析对象。名称解析已进行到其所在位置的对象。
  • 剩余名称。尚未解析的名称部分。
  • 解释。解释名称解析失败原因的详细信息。
  • 根异常。导致抛出此命名异常的异常。
所有这些字段都可以为 null 值。字段值为 null 意味着没有为该字段记录此类信息。

NamingException 实例与并发多线程访问不同步。试图访问和修改单个 NamingException 实例的多个线程应该锁定对象。

此异常已作出改进，以符合通用异常链机制。根异常（或根 cause）是与 Throwable.getCause() 方法返回的 cause 相同的对象。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
protected Name | remainingName 包含尚未解析的剩余名称。
protected Name | resolvedName 包含已成功解析的名称部分。
protected Object | resolvedObj 包含一个对象，已成功解析的名称部分进行到该对象。
protected Throwable | rootException 包含导致抛出此 NamingException 的原始异常。
构造方法摘要
NamingException()
构造一个新的 NamingException。
NamingException(String explanation)
使用解释构造一个新的 NamingException。
方法摘要
void | appendRemainingComponent(String name) 将 name 作为剩余名称中最后的组件添加。
void | appendRemainingName(Name name) 将 'name' 中的组件作为剩余名称中最后的组件添加。
Throwable | getCause() 返回此异常的 cause。
String | getExplanation() 检索与此异常关联的解释。
Name | getRemainingName() 检索名称的剩余未解析部分。
Name | getResolvedName() 检索成功被解析的名称的开头部分。
Object | getResolvedObj() 检索已成功解析成的对象。
Throwable | getRootCause() 检索此 NamingException 的根 cause，如果有的话。
Throwable | initCause(Throwable cause) 将此异常的 cause 初始化为指定值。
void | setRemainingName(Name name) 设置此异常的剩余名称字段。
void | setResolvedName(Name name) 设置此异常的已解析名称字段。
void | setResolvedObj(Object obj) 设置此异常的已解析对象字段。
void | setRootCause(Throwable e) 记录此 NamingException 的根 cause。
String | toString() 生成此异常的字符串表示形式。
String | toString(boolean detail) 生成更详细的字符串表示形式。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

resolvedName

protected Name resolvedName
包含已成功解析的名称部分。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
getResolvedName(), setResolvedName(javax.naming.Name)

resolvedObj

protected Object resolvedObj
包含一个对象，已成功解析的名称部分进行到该对象。可以为 null。此字段由构造方法初始化。应该通过其 get 和 set 方法访问和操作此字段。

另请参见：
getResolvedObj(), setResolvedObj(java.lang.Object)

remainingName

protected Name remainingName
包含尚未解析的剩余名称。它可以是一个复合名称，并且可以为 null。此字段由构造方法初始化。应该通过其 get、set 和 "append" 方法访问和操作此字段。

另请参见：
getRemainingName(),
setRemainingName(javax.naming.Name),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

rootException

protected Throwable rootException
包含导致抛出此 NamingException 的原始异常。如果存在可以从原始异常中获得的附加信息，或者无法将原始异常映射到 NamingException 的子类，则设置此字段。可以为 null。

此字段早于通用异常链设施。initCause(Throwable) 和 getCause() 方法现在是访问此信息的首选方法。

另请参见：
getRootCause(), setRootCause(Throwable), initCause(Throwable), getCause()
构造方法详细信息

NamingException

public NamingException(String explanation)
使用解释构造一个新的 NamingException。将所有未指定字段都设置为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

NamingException

public NamingException()
构造一个新的 NamingException。将所有字段都设置为 null。

方法详细信息

getResolvedName

public Name getResolvedName()
检索成功被解析的名称的开头部分。

返回：
成功被解析的名称部分。该名称是一个复合名称。它可以为 null，表示尚未设置已解析名称字段。
另请参见：
getResolvedObj(), setResolvedName(javax.naming.Name)

getRemainingName

public Name getRemainingName()
检索名称的剩余未解析部分。

返回：
尚未解析的名称部分。该名称是一个复合名称。它可以为 null，表示尚未设置剩余名称字段。
另请参见：
setRemainingName(javax.naming.Name),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

getResolvedObj

public Object getResolvedObj()
检索已成功解析成的对象。该对象是已解析名称被绑定到的对象。

返回：
到目前为止已被解析的对象（可能为 null）。null 意味着尚未设置已解析对象字段。
另请参见：
getResolvedName(), setResolvedObj(java.lang.Object)

getExplanation

public String getExplanation()
检索与此异常关联的解释。

返回：
更详细地解释此异常的字符串（可能为 null）。如果为 null，则意味着没有此异常的详细消息。
另请参见：
Throwable.getMessage()

setResolvedName

public void setResolvedName(Name name)
设置此异常的已解析名称字段。

name 是一个复合名称。如果打算使用复合名称或字符串设置此字段，则必须将该复合名称“字符串化”，并用使用该字符串的单个组件创建一个复合名称。然后可以使用得到的复合名称调用此方法。

创建并存储 name 的副本。对 name 进行的后续更改不会影响此 NamingException 中的副本，反之亦然。

参数：
name - 用来设置已解析名称的名称（可能为 null）。如果其为 null，则将已解析名称字段设置为 null。
另请参见：
getResolvedName()

setRemainingName

public void setRemainingName(Name name)
设置此异常的剩余名称字段。

name 是一个复合名称。如果打算使用复合名称或字符串设置此字段，则必须将该复合名称“字符串化”，并用使用该字符串的单个组件创建一个复合名称。然后可以使用得到的复合名称调用此方法。

创建并存储 name 的副本。对 name 进行的后续更改不会影响此 NamingException 中的副本，反之亦然。

参数：
name - 用来设置剩余名称的名称（可能为 null）。如果其为 null，则将剩余的名称字段设置为 null。
另请参见：
getRemainingName(),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

setResolvedObj

public void setResolvedObj(Object obj)
设置此异常的已解析对象字段。

参数：
name - 用来设置已解析对象的对象（可能为 null）。如果为 null，则将已解析对象字段设置为 null。
另请参见：
getResolvedObj()

appendRemainingComponent

public void appendRemainingComponent(String name)
将 name 作为剩余名称中最后的组件添加。

参数：
name - 要添加的组件。如果 name 为 null，则此方法不执行任何操作。
另请参见：
setRemainingName(javax.naming.Name),
getRemainingName(),
appendRemainingName(javax.naming.Name)

appendRemainingName

public void appendRemainingName(Name name)
将 'name' 中的组件作为剩余名称中最后的组件添加。

name 是一个复合名称。如果打算追加一个组合名称，则应该“字符串化”该组合名称，然后调用接受 String 参数的该方法的重载形式。

对 name 进行的后续更改不会影响此 NamingException 中的剩余名称字段，反之亦然。

参数：
name - 要添加的包含有序组件的名称（可能为 null）。如果 name 为 null，则此方法不执行任何操作。
另请参见：
setRemainingName(javax.naming.Name),
getRemainingName(),
appendRemainingComponent(java.lang.String)

getRootCause

public Throwable getRootCause()
检索此 NamingException 的根 cause，如果有的话。如果服务提供者需要向调用者指示非命名相关异常，同时又需要使用 NamingException 结构指示命名操作进行的程度，则可以使用命名异常的根 cause。

这是通用异常链设施之前的方法。getCause() 方法现在是获取此信息的首选方法。

返回：
导致此命名异常的异常（可能为 null）。如果为 null，则意味着没有为此命名异常设置根 cause。
另请参见：
setRootCause(java.lang.Throwable), rootException, getCause()

setRootCause

public void setRootCause(Throwable e)
记录此 NamingException 的根 cause。如果 e 为 this，则此方法不执行任何操作。

这是通用异常链设施之前的方法。initCause(Throwable) 方法现在是记录此信息的首选方法。

参数：
e - 导致命名操作失败的异常（可能为 null）。如果为 null，则意味着此命名异常没有根 cause。
另请参见：
getRootCause(), rootException, initCause(java.lang.Throwable)

getCause

public Throwable getCause()
返回此异常的 cause。cause 是导致抛出此命名异常的 throwable 对象。如果 cause 不存在或是未知的，则返回 null。

覆盖：
类 Throwable 中的 getCause
返回：
此异常的 cause，如果 cause 不存在或是未知的，则返回 null。
从以下版本开始：
1.4
另请参见：
initCause(Throwable)

initCause

public Throwable initCause(Throwable cause)
将此异常的 cause 初始化为指定值。cause 是导致抛出此命名异常的 throwable 对象。

此方法至多可以调用一次。

覆盖：
类 Throwable 中的 initCause
参数：
cause - cause（保存此 cause，以便以后通过 getCause() 方法检索）。指示 cause 不存在或未知的 null 值。
返回：
对此 NamingException 实例的引用。
抛出：
IllegalArgumentException - 如果 cause 是此异常。（throwable 对象不能是它自己的 cause。）
IllegalStateException - 如果已经在此异常上调用此方法。
从以下版本开始：
1.4
另请参见：
getCause()

toString

public String toString()
生成此异常的字符串表示形式。该字符串表示形式由此异常的类名称、详细消息组成，如果该异常有根 cause，则还包括根 cause 异常的字符串表示形式，后跟剩余名称（如果不为 null）。此字符串用于调试，不以编程方式进行解释。

覆盖：
类 Throwable 中的 toString
返回：
包含此异常字符串表示形式的非 null 字符串。

toString

public String toString(boolean detail)
生成更详细的字符串表示形式。此字符串表示形式由不使用任何参数的 toString() 返回的信息以及已解析对象（如果不为 null）的字符串表示形式组成。此字符串用于调试，不以编程方式进行解释。

参数：
detail - 如果为 true，则除了包含其他信息外，还包含有关已解析对象的详细信息。
返回：
包含该字符串表示形式的非 null 字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingSecurityException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NamingSecurityException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NamingSecurityException
所有已实现的接口：
Serializable
直接已知子类：
AuthenticationException, AuthenticationNotSupportedException, NoPermissionException
public abstract class NamingSecurityException
extends NamingException

此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。失败的特性由子类的名称描述。

如果程序想要单独处理此异常，它应该在试图捕获 NamingException 之前显式捕获 NamingSecurityException。例如，想要处理与安全有关的异常（特别是其他种类的命名异常）的程序可能会这样做。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
NamingSecurityException()
构造一个新的 NamingSecurityException 实例。
NamingSecurityException(String explanation)
使用所提供的解释构造一个新的 NamingSecurityException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NamingSecurityException

public NamingSecurityException(String explanation)
使用所提供的解释构造一个新的 NamingSecurityException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的附加详细信息（可能为 null）。
另请参见：
Throwable.getMessage()

NamingSecurityException

public NamingSecurityException()
构造一个新的 NamingSecurityException 实例。所有字段都被初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoInitialContextException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NoInitialContextException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NoInitialContextException
所有已实现的接口：
Serializable
public class NoInitialContextException
extends NamingException

当不能创建任何初始上下文实现时，抛出此异常。如何选择初始上下文实现的策略已在 InitialContext 类的文档中描述。

此异常可以在与 InitialContext 进行的任何交互期间抛出，而不仅仅是在构造 InitialContext 时。例如，初始上下文的实现可能仅当在其上调用实际方法时延后 (lazily) 检索上下文。在确定初始上下文的存在时，应用程序不应该对它有任何依赖性。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
InitialContext, InitialDirContext, NamingManager.getInitialContext(java.util.Hashtable), NamingManager.setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder), 序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
NoInitialContextException()
构造一个 NoInitialContextException 实例。
NoInitialContextException(String explanation)
使用解释构造一个 NoInitialContextException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoInitialContextException

public NoInitialContextException()
构造一个 NoInitialContextException 实例。所有字段都被初始化为 null。

NoInitialContextException

public NoInitialContextException(String explanation)
使用解释构造一个 NoInitialContextException 实例。其他所有字段都被初始化为 null。

参数：
explanation - 有关此异常的附加详细信息（可能为 null）。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RefAddr (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 RefAddr

java.lang.Object
    继承者  javax.naming.RefAddr
所有已实现的接口：
Serializable
直接已知子类：
BinaryRefAddr, StringRefAddr
public abstract class RefAddr
extends Object
implements Serializable

此类表示通信端点的地址。它由描述通信机制的类型和由 RefAddr 子类确定的地址内容组成。

例如，地址类型可以是 "BSD Printer Address"，指示该地址是一个与 BSD 打印协议的一起使用地址。其内容可以是标识理解此协议的打印机服务器位置的机器名称。

RefAddr 包含在 Reference 中。

RefAddr 是一个抽象类。它的具体实现确定其同步属性。

从以下版本开始：
1.3
另请参见：
Reference, LinkRef, StringRefAddr, BinaryRefAddr, 序列化表格

字段摘要
protected  String addrType
包含此地址的类型。
构造方法摘要
protected RefAddr(String addrType)
使用地址类型构造一个新的 RefAddr 实例。
方法摘要
boolean | equals(Object obj) 确定 obj 是否等于此 RefAddr。
abstract Object | getContent() 检索此地址的内容。
String | getType() 检索此地址的地址类型。
int | hashCode() 使用地址类型和内容计算此地址的哈希码。
String | toString() 生成此地址的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

addrType

protected String addrType
包含此地址的类型。

构造方法详细信息

RefAddr

protected RefAddr(String addrType)
使用地址类型构造一个新的 RefAddr 实例。

参数：
addrType - 描述地址类型的非 null 字符串。
方法详细信息

getType

public String getType()
检索此地址的地址类型。

返回：
此地址的非 null 地址类型。

getContent

public abstract Object getContent()
检索此地址的内容。

返回：
地址内容（可能为 null）。

equals

public boolean equals(Object obj)
确定 obj 是否等于此 RefAddr。

以下所有条件为 true 时 obj 等于 RefAddr：

    非 null
  • RefAddr 的实例
  • obj 具有与此 RefAddr 相同的地址类型（使用 String.compareTo()）
  • obj 与此 RefAddr 的内容都为 null 或者它们相等（使用 equals() 进行测试）。

覆盖：
类 Object 中的 equals
参数：
obj - 要检查的 obj（可能为 null）。
返回：
如果 obj 等于此 refaddr，则返回 true，否则返回 false。
另请参见：
getContent(), getType()

hashCode

public int hashCode()
使用地址类型和内容计算此地址的哈希码。该哈希码是地址类型的哈希码和地址内容的哈希码的总和。

覆盖：
类 Object 中的 hashCode
返回：
此地址的 int 形式的哈希码。
另请参见：
Object.hashCode()

toString

public String toString()
生成此地址的字符串表示形式。该字符串由地址的类型和带标签的内容组成。此表示形式只用于显示，不会被解析。

覆盖：
类 Object 中的 toString
返回：
此地址的非 null 字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoPermissionException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NoPermissionException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NamingSecurityException
                    继承者  javax.naming.NoPermissionException
所有已实现的接口：
Serializable
public class NoPermissionException
extends NamingSecurityException

当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。访问控制/权限模型由目录/命名服务器指示。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
NoPermissionException()
构造一个新的 NoPermissionException 实例。
NoPermissionException(String explanation)
使用解释构造一个新的 NoPermissionException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoPermissionException

public NoPermissionException(String explanation)
使用解释构造一个新的 NoPermissionException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的附加详细信息（可能为 null）。

NoPermissionException

public NoPermissionException()
构造一个新的 NoPermissionException 实例。所有字段都被初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NotContextException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 NotContextException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.NotContextException
所有已实现的接口：
Serializable
public class NotContextException
extends NamingException

当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。例如，Context.destroy() 要求指定的对象是一个上下文。如果不是，则抛出 NotContextException。另一个示例是 Context 方法在解析阶段期间遇到的非上下文。

当需要特定子类型的上下文（比如 DirContext），解析的对象是一个上下文，但不属于所需的子类型时，也会抛出此异常。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
Context.destroySubcontext(javax.naming.Name), 序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
NotContextException()
构造一个新的 NotContextException 实例。
NotContextException(String explanation)
使用解释构造一个新的 NotContextException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NotContextException

public NotContextException(String explanation)
使用解释构造一个新的 NotContextException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的附加详细信息（可能为 null）。
另请参见：
Throwable.getMessage()

NotContextException

public NotContextException()
构造一个新的 NotContextException 实例。所有字段都默认为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OperationNotSupportedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 OperationNotSupportedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.OperationNotSupportedException
所有已实现的接口：
Serializable
public class OperationNotSupportedException
extends NamingException

当上下文实现不支持将调用的操作时，抛出此异常。例如，如果某个服务器不支持 Context.bind() 方法，则在该服务器上调用 bind() 方法时，它将抛出 OperationNotSupportedException。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
OperationNotSupportedException()
构造一个新的 OperationNotSupportedException 实例。
OperationNotSupportedException(String explanation)
使用解释构造一个新的 OperationNotSupportedException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

OperationNotSupportedException

public OperationNotSupportedException()
构造一个新的 OperationNotSupportedException 实例。所有字段都默认为 null。

OperationNotSupportedException

public OperationNotSupportedException(String explanation)
使用解释构造一个新的 OperationNotSupportedException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的附加详细信息（可能为 null）。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PartialResultException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 PartialResultException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.PartialResultException
所有已实现的接口：
Serializable
public class PartialResultException
extends NamingException

抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。例如，在列出某一上下文时，此异常指示返回的结果只表示上下文中的某些绑定。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
PartialResultException()
构造一个新的 PartialResultException 实例。
PartialResultException(String explanation)
使用指定的解释消息构造一个新的异常实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PartialResultException

public PartialResultException(String explanation)
使用指定的解释消息构造一个新的异常实例。其他所有字段都默认为 null。

参数：
explanation - 解释该异常的详细信息（可能为 null）。

PartialResultException

public PartialResultException()
构造一个新的 PartialResultException 实例。所有字段都默认为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Reference (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 Reference

java.lang.Object
    继承者  javax.naming.Reference
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
LinkRef
public class Reference
extends Object
implements Cloneable, Serializable

此类表示对存在于命名/目录系统以外的对象的引用。

Reference 提供一种记录关于没有直接绑定到命名/目录系统的对象的地址信息的方式。

Reference 由有序地址列表和有关将被引用的对象的类信息组成。列表中的每个地址都标识一个用于相同概念上的对象的通信端点。“通信端点”是指示如何与对象进行联系的信息。例如，它可以是一个网络地址、本地机器内存中的一个位置、同一台机器上的另一个进程等等。列表中地址的顺序对于解释引用的对象工厂而言可能很重要。

出现多个地址的原因有很多，比如重复或者对象在多于一种的通信机制上提供接口。该地址的索引从零开始。

Reference 还包含信息，该信息有助于创建此 Reference 所引用的对象的实例。它包含该对象的类名称，以及用来创建该对象的工厂的类名称和位置。类工厂位置是以空格分隔的 URL 列表，这些 URL 表示用来加载该工厂的类路径。当需要加载工厂类（或任何它所依赖的类或资源）时，将（依次）使用每个 URL 来尝试加载该类。

Reference 实例与多个线程的并发访问不同步。需要并发地访问单个 Reference 的线程应该在它们之间实现同步并提供所需的锁定。

从以下版本开始：
1.3
另请参见：
RefAddr, StringRefAddr, BinaryRefAddr, 序列化表格

字段摘要
protected Vector<RefAddr> | addrs 包含此 Reference 中所包含的地址。
protected String | classFactory 包含用来创建此 Reference 所引用的对象实例的工厂类名称。
protected String | classFactoryLocation 包含工厂类的位置。
protected String | className 包含此 Reference 所引用的对象类的完全限定名称。
构造方法摘要
Reference(String className)
使用类名称 'className' 构造对某个对象的新引用。
Reference(String className, RefAddr addr)
使用类名称 'className' 和一个地址构造对某个对象的新引用。
Reference(String className, RefAddr addr, String factory, String factoryLocation)
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。
Reference(String className, String factory, String factoryLocation)
使用类名称 'className' 以及对象工厂的类名称和位置创建对某个对象的新引用。
方法摘要
void | add(int posn, RefAddr addr) 将地址添加到地址列表中的索引 posn 处。
void | add(RefAddr addr) 将地址添加到地址列表的末尾。
void | clear() 从此引用中删除所有地址。
Object | clone() 使用地址的类名称列表、类工厂名称和类工厂位置创建此引用的副本。
boolean | equals(Object obj) 确定 obj 是否是一个与此引用具有相同地址（按相同顺序）的引用。
RefAddr | get(int posn) 检索索引 posn 处的地址。
RefAddr | get(String addrType) 检索地址类型为 'addrType' 的第一个地址。
Enumeration<RefAddr> | getAll() 返回此索引中的地址所组成的枚举。
String | getClassName() 检索此引用所引用对象的类名称。
String | getFactoryClassLocation() 检索此引用所引用对象的工厂的位置。
String | getFactoryClassName() 检索此引用所引用对象的工厂的类名称。
int | hashCode() 计算此引用的哈希码。
Object | remove(int posn) 从地址列表中删除索引 posn 处的地址。
int | size() 检索此引用中的地址数。
String | toString() 生成此引用的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

className

protected String className
包含此 Reference 所引用的对象类的完全限定名称。

另请参见：
Class.getName()

addrs

protected Vector<RefAddr> addrs
包含此 Reference 中所包含的地址。由构造方法初始化。

classFactory

protected String classFactory
包含用来创建此 Reference 所引用的对象实例的工厂类名称。被初始化为 null。

classFactoryLocation

protected String classFactoryLocation
包含工厂类的位置。被初始化为 null。

构造方法详细信息

Reference

public Reference(String className)
使用类名称 'className' 构造对某个对象的新引用。类工厂和类工厂位置都被设置为 null。新创建的引用不包含任何地址。

参数：
className - 此引用所引用对象的非 null 类名称。

Reference

public Reference(String className,
                 RefAddr addr)
使用类名称 'className' 和一个地址构造对某个对象的新引用。类工厂和类工厂位置都被设置为 null。

参数：
className - 此引用所引用对象的非 null 类名称。
addr - 对象的非 null 地址。

Reference

public Reference(String className,
                 String factory,
                 String factoryLocation)
使用类名称 'className' 以及对象工厂的类名称和位置创建对某个对象的新引用。

参数：
className - 此引用所引用对象的非 null 类名称。
factory - 对象工厂的类名称（可能为 null）。
factoryLocation - 加载工厂的、可能为 null 的位置（例如 URL）
另请参见：
ObjectFactory, NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

Reference

public Reference(String className,
                 RefAddr addr,
                 String factory,
                 String factoryLocation)
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。

参数：
className - 此引用所引用对象的非 null 类名称。
factory - 对象工厂的类名称（可能为 null）。
factoryLocation - 加载工厂的、可能为 null 的位置（例如 URL）
addr - 对象的非 null 地址。
另请参见：
ObjectFactory, NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)
方法详细信息

getClassName

public String getClassName()
检索此引用所引用对象的类名称。

返回：
该对象的非 null 完全限定类名称。（例如 "java.lang.String"）

getFactoryClassName

public String getFactoryClassName()
检索此引用所引用对象的工厂的类名称。

返回：
该工厂的完全限定类名称（可能为 null）。（例如 "java.lang.String"）

getFactoryClassLocation

public String getFactoryClassLocation()
检索此引用所引用对象的工厂的位置。如果是一个代码基，则它是一个以空格分隔的有序 URL 列表，该列表列出了应该加载工厂类定义的位置。

返回：
包含用来加载工厂类的地址的字符串（可能为 null）。

get

public RefAddr get(String addrType)
检索地址类型为 'addrType' 的第一个地址。String.compareTo() 用于测试地址类型的相等性。

参数：
addrType - 用来查找地址的非 null 地址类型。
返回：
此引用中地址类型为 'addrType 的地址；如果不存在这样的地址，则返回 null。

get

public RefAddr get(int posn)
检索索引 posn 处的地址。

参数：
posn - 要检索的地址的索引。
返回：
索引 posn（从 0 开始）处的地址。必须在范围 [0,getAddressCount()) 内。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 不在指定的范围内。

getAll

public Enumeration<RefAddr> getAll()
返回此索引中的地址所组成的枚举。当在此引用中添加、更改或移除地址时，对此枚举的影响是不确定的。

返回：
此引用中的地址 (RefAddr) 所组成的非 null 枚举。如果此索引中没有任何地址，则返回一个不带任何元素的枚举。

size

public int size()
检索此引用中的地址数。

返回：
此引用中的非负地址数。

add

public void add(RefAddr addr)
将地址添加到地址列表的末尾。

参数：
addr - 要添加的非 null 地址。

add

public void add(int posn,
                RefAddr addr)
将地址添加到地址列表中的索引 posn 处。索引 posn 或大于该索引的所有地址都将在该列表中上移（远离索引 0）一位。

参数：
posn - 列表中要插入 addr 的索引（从 0 开始）。
addr - 要插入的非 null 地址。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 并不在指定的范围内。

remove

public Object remove(int posn)
从地址列表中删除索引 posn 处的地址。索引大于 posn 的所有地址都将在该列表中下移（朝向索引 0）一位。

参数：
posn - 要删除的地址的索引（从 0 开始）。
返回：
移除的地址。
抛出：
ArrayIndexOutOfBoundsException - 如果 posn 不在指定的范围内。

clear

public void clear()
从此引用中删除所有地址。

equals

public boolean equals(Object obj)
确定 obj 是否是一个与此引用具有相同地址（按相同顺序）的引用。可以使用 RefAddr.equals() 检查该地址。除了具有相同地址之外，Reference 还应该与此引用具有相同的类名称。不检查类工厂和类工厂位置。如果 obj 为 null 或者不是一个 Reference 实例，则返回 null。

覆盖：
类 Object 中的 equals
参数：
obj - 要检查的对象（可能为 null）。
返回：
如果 obj 等于此引用，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
计算此引用的哈希码。该哈希码是其地址的哈希玛的总和。

覆盖：
类 Object 中的 hashCode
返回：
此引用 int 形式的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
生成此引用的字符串表示形式。该字符串由此引用所引用的类名称及其每个地址的字符串表示形式组成。此表示形式只用于显示，不会被解析。

覆盖：
类 Object 中的 toString
返回：
此引用的非 null 字符串表示形式。

clone

public Object clone()
使用地址的类名称列表、类工厂名称和类工厂位置创建此引用的副本。对新创建副本的更改不会影响此 Reference，反之亦然。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Referenceable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
接口 Referenceable

public interface Referenceable

此接口由可以为自身提供 Reference 的对象实现。

Reference 表示一种记录关于没有直接绑定到命名系统的对象的地址信息的方式。这种对象可以实现 Referenceable 接口作为一种方式，从而使用该对象的程序可以确定其 Reference。例如，在绑定对象时，如果对象实现了 Referenceable 接口，则可以在该对象上调用 getReference() 来获得其 Reference 以用于绑定。

从以下版本开始：
1.3
另请参见：
Context.bind(javax.naming.Name, java.lang.Object), NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), Reference

方法摘要
 Reference getReference()
检索此对象的 Reference。

方法详细信息

getReference

Reference getReference()
                       throws NamingException
检索此对象的 Reference。

返回：
此对象的非 null Reference。
抛出：
NamingException - 如果检索引用时遇到命名异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReferralException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 ReferralException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.ReferralException
所有已实现的接口：
Serializable
直接已知子类：
LdapReferralException
public abstract class ReferralException
extends NamingException

此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。

服务提供者通过提供 getReferralInfo() 和 getReferralContext() 的实现（以及适当的构造方法和/或相应的 "set" 方法）来提供 ReferralException 的子类。

以下代码示例展示了如何使用 ReferralException。

        while (true) {
            try {
                bindings = ctx.listBindings(name);
                while (bindings.hasMore()) {
                    b = bindings.next();
                    ...
                }
                break;
            } catch (ReferralException e) {
                ctx = e.getReferralContext();
            }
        }

ReferralException 是一个抽象类。具体的实现确定其同步和序列化属性。

传递给 getReferralContext() 方法的环境属性归调用者所有。服务提供者不会修改该对象或保持对它的引用，但会保持对其副本的引用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
protected | ReferralException() 构造一个新的 ReferralException 实例。
protected | ReferralException(String explanation) 使用所提供的解释构造一个新的 ReferralException 实例。
方法摘要
abstract Context | getReferralContext() 检索继续该方法的上下文。
abstract Context | getReferralContext(Hashtable<?,?> env) 使用环境属性检索继续该方法的上下文。
abstract Object | getReferralInfo() 检索与此引用有关的信息（比如 URL）。
abstract void | retryReferral() 检索当前正被处理的引用。
abstract boolean | skipReferral() 放弃将要处理的引用。
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReferralException

protected ReferralException(String explanation)
使用所提供的解释构造一个新的 ReferralException 实例。将所有其他字段都设置为 null。

参数：
explanation - 有关此异常的附加详细信息。可以为 null。
另请参见：
Throwable.getMessage()

ReferralException

protected ReferralException()
构造一个新的 ReferralException 实例。将所有字段都设置为 null。

方法详细信息

getReferralInfo

public abstract Object getReferralInfo()
检索与此引用有关的信息（比如 URL）。该程序可以检查或向用户显示此信息，以确定是否继续此引用，或确定继续此引用所需要提供的附加信息。

返回：
与此引用有关的非 null 引用信息。

getReferralContext

public abstract Context getReferralContext()
                                    throws NamingException
检索继续该方法的上下文。不管在上下文操作期间（例如在搜索枚举期间）是否直接或间接地遇到某一引用，引用异常都应该提供一个继续该操作的上下文。引用上下文是使用抛出 ReferralException 的上下文的环境属性创建的。

要继续该操作，客户端程序应该使用与初始调用相同的参数重新调用该方法。

返回：
将继续该操作的非 null 上下文。
抛出：
NamingException - 如果遇到命名异常。调用 retryReferral() 或 skipReferral() 来继续处理这些引用。

getReferralContext

public abstract Context getReferralContext(Hashtable<?,?> env)
                                    throws NamingException
使用环境属性检索继续该方法的上下文。不管在上下文操作期间（例如在搜索枚举期间）是否直接或间接地遇到某一引用，引用异常都应该提供一个继续该操作的上下文。

引用上下文是通过使用 env 作为其环境属性来创建的。当调用者需要将不同的环境属性用于引用上下文时，应该使用此方法，而不是无参数的重载形式。例如，当需要为引用服务器提供不同的验证信息来创建引用上下文时，可能需要这样做。

要继续该操作，客户端程序应该使用与初始调用相同的参数重新调用该方法。

参数：
env - 检索引用上下文时要使用的环境（可能为 null）。如果为 null，则不使用环境属性。
返回：
将继续该操作的非 null 上下文。
抛出：
NamingException - 如果遇到命名异常。调用 retryReferral() 或 skipReferral() 来继续处理这些引用。

skipReferral

public abstract boolean skipReferral()
放弃将要处理的引用。调用此方法后应该调用 getReferralContext，以允许处理其他要继续的引用。以下代码片段展示了一个典型的使用模式。

        } catch (ReferralException e) {
            if (!shallIFollow(e.getReferralInfo())) {
                if (!e.skipReferral()) {
                    return;
                }
            }
            ctx = e.getReferralContext();
        }

返回：
如果还有引用处理正被挂起，则返回 true；否则返回 false。

retryReferral

public abstract void retryReferral()
检索当前正被处理的引用。调用此方法后应该调用 getReferralContext，以允许当前引用被重试。以下代码片段展示了一个典型的使用模式。

        } catch (ReferralException e) {
            while (true) {
                try {
                    ctx = e.getReferralContext(env);
                    break;
                } catch (NamingException ne) {
                    if (! shallIRetry()) {
                        return;
                    }
                    // modify environment properties (env), if necessary
                    e.retryReferral();
                }
            }
        }

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceUnavailableException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 ServiceUnavailableException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.ServiceUnavailableException
所有已实现的接口：
Serializable
public class ServiceUnavailableException
extends NamingException

当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。该服务可能因为各种原因而不可用。例如，服务器可能太忙而无法为请求提供服务，或者服务器可能没有为向某些请求提供服务而注册等等。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
ServiceUnavailableException()
构造一个新的 ServiceUnavailableException 实例。
ServiceUnavailableException(String explanation)
使用解释构造一个新的 ServiceUnavailableException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServiceUnavailableException

public ServiceUnavailableException(String explanation)
使用解释构造一个新的 ServiceUnavailableException 实例。其他所有字段都默认为 null。

参数：
explanation - 有关此异常的附加详细信息（可能为 null）。
另请参见：
Throwable.getMessage()

ServiceUnavailableException

public ServiceUnavailableException()
构造一个新的 ServiceUnavailableException 实例。所有字段都默认为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SizeLimitExceededException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 SizeLimitExceededException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.LimitExceededException
                    继承者  javax.naming.SizeLimitExceededException
所有已实现的接口：
Serializable
public class SizeLimitExceededException
extends LimitExceededException

当某一方法生成的结果超出与大小有关的限制时，抛出此异常。例如，如果结果中包含的对象多于用户所请求的数量，或者结果的大小超出了某个特定于实现的限制时，可能出现这种情况。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
SizeLimitExceededException()
构造一个新的 SizeLimitExceededException 实例。
SizeLimitExceededException(String explanation)
使用解释构造一个新的 SizeLimitExceededException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SizeLimitExceededException

public SizeLimitExceededException()
构造一个新的 SizeLimitExceededException 实例。所有字段都默认为 null。

SizeLimitExceededException

public SizeLimitExceededException(String explanation)
使用解释构造一个新的 SizeLimitExceededException 实例。其他所有字段都默认为 null。

参数：
explanation - 关于此异常的详细信息（可能为 null）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StringRefAddr (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 StringRefAddr

java.lang.Object
    继承者  javax.naming.RefAddr
        继承者  javax.naming.StringRefAddr
所有已实现的接口：
Serializable
public class StringRefAddr
extends RefAddr

此类表示通信终端地址的字符串形式。它由描述通信机制的类型和特定于该通信机制的字符串内容组成。地址类型的格式和解释以及地址的内容都基于三方的协议，这里的三方为：使用该地址的客户端、使用该地址的可到达对象/服务器，以及创建该地址的管理员或程序。

字符串引用地址的一个示例是主机名称。字符串引用地址的另一个示例是 URL。

字符串引用地址是不可变的：一旦创建，就无法更改。对单个 StringRefAddr 进行的多线程访问无需是同步的。

从以下版本开始：
1.3
另请参见：
RefAddr, BinaryRefAddr, 序列化表格

字段摘要
从类 javax.naming.RefAddr 继承的字段
addrType
构造方法摘要
StringRefAddr(String addrType, String addr)
使用地址类型和内容构造一个新的 StringRefAddr 实例。
方法摘要
 Object getContent()
检索此地址的内容。
从类 javax.naming.RefAddr 继承的方法
equals, getType, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

StringRefAddr

public StringRefAddr(String addrType,
                     String addr)
使用地址类型和内容构造一个新的 StringRefAddr 实例。

参数：
addrType - 描述地址类型的非 null 字符串。
addr - 字符串形式的地址内容（可能为 null）。
方法详细信息

getContent

public Object getContent()
检索此地址的内容。结果是一个字符串。

指定者：
类 RefAddr 中的 getContent
返回：
地址内容（可能为 null）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TimeLimitExceededException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming
类 TimeLimitExceededException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.LimitExceededException
                    继承者  javax.naming.TimeLimitExceededException
所有已实现的接口：
Serializable
public class TimeLimitExceededException
extends LimitExceededException

当某一方法没有在指定的时间限制内终止时，抛出此异常。例如，如果用户指定某一方法应该在不超过 10 秒的时间内完成，而该方法没有在 10 秒内完成，则可能出现这种现象。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
TimeLimitExceededException()
构造一个新的 TimeLimitExceededException 实例。
TimeLimitExceededException(String explanation)
使用所提供的参数构造一个新的 TimeLimitExceededException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TimeLimitExceededException

public TimeLimitExceededException()
构造一个新的 TimeLimitExceededException 实例。所有字段都默认为 null。

TimeLimitExceededException

public TimeLimitExceededException(String explanation)
使用所提供的参数构造一个新的 TimeLimitExceededException 实例。

参数：
explanation - 关于此异常的详细信息（可能为 null）。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.naming (Java 2 Platform SE 6)

 javax.naming
接口
Context
Name
NameParser
NamingEnumeration
Referenceable
类
BinaryRefAddr
Binding
CompositeName
CompoundName
InitialContext
LinkRef
NameClassPair
RefAddr
Reference
StringRefAddr
异常
AuthenticationException
AuthenticationNotSupportedException
CannotProceedException
CommunicationException
ConfigurationException
ContextNotEmptyException
InsufficientResourcesException
InterruptedNamingException
InvalidNameException
LimitExceededException
LinkException
LinkLoopException
MalformedLinkException
NameAlreadyBoundException
NameNotFoundException
NamingException
NamingSecurityException
NoInitialContextException
NoPermissionException
NotContextException
OperationNotSupportedException
PartialResultException
ReferralException
ServiceUnavailableException
SizeLimitExceededException
TimeLimitExceededException


javax.naming (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.naming

为访问命名服务提供类和接口。

请参见：
描述

接口摘要
Context | 此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
Name | Name 接口表示一个一般名称，即一个有序的组件序列。
NameParser | 此接口用于解析取自分层的名称空间的名称。
NamingEnumeration<T> | 此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。
Referenceable | 此接口由可以为自身提供 Reference 的对象实现。

类摘要
BinaryRefAddr | 此类表示通信终端地址的二进制形式。
Binding | 此类表示上下文中一个名称到对象的绑定。
CompositeName | 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
CompoundName | 此类表示一个组合名称，即一个取自层次名称空间的名称。
InitialContext | 此类是执行命名操作的初始上下文。
LinkRef | 此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。
NameClassPair | 此类表示存在于上下文中的某一绑定的对象名称和类名称对。
RefAddr | 此类表示通信端点的地址。
Reference | 此类表示对存在于命名/目录系统以外的对象的引用。
StringRefAddr | 此类表示通信终端地址的字符串形式。

异常摘要
AuthenticationException | 当访问命名或目录服务发生验证错误时，抛出此异常。
AuthenticationNotSupportedException | 当所请求验证的特定 flavor 不受支持时，抛出此异常。
CannotProceedException | 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
CommunicationException | 当客户端无法与目录或命名服务通信时，抛出此异常。
ConfigurationException | 当存在配置问题时，抛出此异常。
ContextNotEmptyException | 当试图销毁一个不为空的上下文时，抛出此异常。
InsufficientResourcesException | 当无法使用资源完成所请求的操作时，抛出此异常。
InterruptedNamingException | 当正被调用的命名操作已经被中断时，抛出此异常。
InvalidNameException | 此异常指示被指定的名称不符合命名系统的命名语法。
LimitExceededException | 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
LinkException | 此异常用于描述解析链接时遇到的问题。
LinkLoopException | 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
MalformedLinkException | 如果在解析或构造链接时遇到错误链接，则抛出此异常。
NameAlreadyBoundException | 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
NameNotFoundException | 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
NamingException | 此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
NamingSecurityException | 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
NoInitialContextException | 当不能创建任何初始上下文实现时，抛出此异常。
NoPermissionException | 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
NotContextException | 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
OperationNotSupportedException | 当上下文实现不支持将调用的操作时，抛出此异常。
PartialResultException | 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
ReferralException | 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
ServiceUnavailableException | 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
SizeLimitExceededException | 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
TimeLimitExceededException | 当某一方法没有在指定的时间限制内终止时，抛出此异常。

软件包 javax.naming 的描述

为访问命名服务提供类和接口。

此包定义 Java Naming and Directory InterfaceTM (JNDI) 的命名操作。 JNDI 向使用 Java 编程语言编写的应用程序提供命名和目录功能。它被设计成与任何特定的命名或目录服务实现无关。因此可以使用共同的方式对多种服务（新的、新出现的及已经部署的服务）进行访问。

上下文

此包定义上下文 的概念，由 Context 结构表示。上下文由一组名称到对象的绑定 组成。Context 是用来查找、绑定、取消绑定和重新命名对象，以及创建和销毁子上下文的核心接口。

lookup() 是最常使用的操作。当向 lookup() 提供想要查询的对象的名称时，它将返回绑定到该名称的对象。例如，以下代码段要查找一台打印机并将文档发送给该打印机对象打印：

Printer printer = (Printer)ctx.lookup("treekiller");
printer.print(report);

名称

Context 接口中的每个命名方法都有两个重载形式：一个接受 Name 参数，另一个接受字符串名称。Name 是一个表示一般名称的接口，一般名称是零个或多个组件的有序序列。对于这些方法，可以使用 Name 表示复合名称 (CompositeName)，从而可以使用跨多个名称空间的名称来命名一个对象。

接受 Name 的重载方法对那些需要对名称进行以下操作的应用程序很有用：组合名称、比较组件等等。接受字符串名称的重载方法对那些简单的应用程序可能更加有用，比如那些只是读取某一名称以及查找相应对象的应用程序。

绑定

Binding 类表示一个名称到对象的绑定。它是一个包含所绑定对象的名称、对象的类的名称和对象本身的元组 (tuple)。

Binding 类实际上是 NameClassPair 的子类，由对象的名称和对象的类名称组成。在只想要关于对象的类的信息以及不想为获得对象而额外开销时，NameClassPair 很有用。

引用

对象以不同方式存储在命名和目录服务中。如果对象存储支持存储 Java 对象，则它可能支持以序列化形式存储对象。不过，一些命名和目录服务不支持存储 Java 对象。此外，对于目录中某些对象而言，Java 程序只是访问它们的一组应用程序。在这种情况下，序列化 Java 对象可能不是最合适的表示形式。JNDI 定义了一个由 Reference 类表示的引用，它包含有关如何构造对象副本的信息。JNDI 将尝试把从目录中找到的引用转换成它们表示的 Java 对象，从而给 JNDI 客户端制造一种目录中存储的是 Java 对象的假象。

初始上下文

在 JNDI 中，所有命名和目录操作都是相对于上下文执行的。没有绝对的根。所以 JNDI 定义了一个初始上下文 InitialContext，为命名和目录操作提供起始点。一旦有了初始上下文，就可以使用它来查找其他上下文和对象。

异常

JNDI 为可能在执行命名和目录操作期间抛出的异常定义了一个类层次。此类层次的根是 NamingException。需要处理特定异常的程序可以捕获相应的异常子类。否则，这些程序应该捕获 NamingException。

包规范

JNDI API 规范及相关文档可在 JNDI documentation 中找到。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.naming 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.naming.CompositeName (implements javax.naming.Name)
    • javax.naming.CompoundName (implements javax.naming.Name)
    • javax.naming.InitialContext (implements javax.naming.Context)
    • javax.naming.NameClassPair (implements java.io.Serializable)
      • javax.naming.Binding
    • javax.naming.RefAddr (implements java.io.Serializable)
      • javax.naming.BinaryRefAddr
      • javax.naming.StringRefAddr
    • javax.naming.Reference (implements java.lang.Cloneable, java.io.Serializable)
      • javax.naming.LinkRef
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.CannotProceedException
          • javax.naming.CommunicationException
          • javax.naming.ConfigurationException
          • javax.naming.ContextNotEmptyException
          • javax.naming.InsufficientResourcesException
          • javax.naming.InterruptedNamingException
          • javax.naming.InvalidNameException
          • javax.naming.LimitExceededException
            • javax.naming.SizeLimitExceededException
            • javax.naming.TimeLimitExceededException
          • javax.naming.LinkException
            • javax.naming.LinkLoopException
            • javax.naming.MalformedLinkException
          • javax.naming.NameAlreadyBoundException
          • javax.naming.NameNotFoundException
          • javax.naming.NamingSecurityException
            • javax.naming.AuthenticationException
            • javax.naming.AuthenticationNotSupportedException
            • javax.naming.NoPermissionException
          • javax.naming.NoInitialContextException
          • javax.naming.NotContextException
          • javax.naming.OperationNotSupportedException
          • javax.naming.PartialResultException
          • javax.naming.ReferralException
          • javax.naming.ServiceUnavailableException

接口分层结构

  • java.lang.Cloneable
    • javax.naming.Name (并 extends java.lang.Comparable<T>, java.io.Serializable)
  • java.lang.Comparable<T>
    • javax.naming.Name (并 extends java.lang.Cloneable, java.io.Serializable)
  • javax.naming.Context
  • java.util.Enumeration<E>
    • javax.naming.NamingEnumeration<T>
  • javax.naming.NameParser
  • javax.naming.Referenceable
  • java.io.Serializable
    • javax.naming.Name (并 extends java.lang.Cloneable, java.lang.Comparable<T>)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.naming 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming
的使用

使用 javax.naming 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.naming 使用的 javax.naming 中的类
Binding
此类表示上下文中一个名称到对象的绑定。
Context
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
InvalidNameException
此异常指示被指定的名称不符合命名系统的命名语法。
LimitExceededException
当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
LinkException
此异常用于描述解析链接时遇到的问题。
Name
Name 接口表示一个一般名称，即一个有序的组件序列。
NameClassPair
此类表示存在于上下文中的某一绑定的对象名称和类名称对。
NameParser
此接口用于解析取自分层的名称空间的名称。
NamingEnumeration
此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。
NamingException
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
NamingSecurityException
此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
RefAddr
此类表示通信端点的地址。
Reference
此类表示对存在于命名/目录系统以外的对象的引用。

javax.naming.directory 使用的 javax.naming 中的类
Binding
此类表示上下文中一个名称到对象的绑定。
Context
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
InitialContext
此类是执行命名操作的初始上下文。
Name
Name 接口表示一个一般名称，即一个有序的组件序列。
NameClassPair
此类表示存在于上下文中的某一绑定的对象名称和类名称对。
NamingEnumeration
此接口用于枚举 javax.naming 和 javax.naming.directory 包中的方法所返回的列表。
NamingException
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。

javax.naming.event 使用的 javax.naming 中的类
Binding
此类表示上下文中一个名称到对象的绑定。
Context
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
Name
Name 接口表示一个一般名称，即一个有序的组件序列。
NamingException
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。

javax.naming.ldap 使用的 javax.naming 中的类
Context
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
InitialContext
此类是执行命名操作的初始上下文。
InvalidNameException
此异常指示被指定的名称不符合命名系统的命名语法。
Name
Name 接口表示一个一般名称，即一个有序的组件序列。
NamingException
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。
ReferralException
此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。

javax.naming.spi 使用的 javax.naming 中的类
CannotProceedException
抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
Context
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。
Name
Name 接口表示一个一般名称，即一个有序的组件序列。
NamingException
此异常是 Context 和 DirContext 接口中的操作抛出的所有异常的超类。

javax.sql.rowset.spi 使用的 javax.naming 中的类
Context
此接口表示一个命名上下文，它由一组名称到对象的绑定组成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Attribute (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
接口 Attribute

所有超级接口：
Cloneable, Serializable
所有已知实现类：
BasicAttribute
public interface Attribute
extends Cloneable, Serializable

此接口表示与命名对象关联的属性。

在目录中，命名的对象可以与其属性关联。Attribute 接口表示与命名对象关联的属性。属性包含 0 个或多个（可能为 null 的）值。属性值可以是有序的也可以是无序的（参阅 isOrdered()）。如果值是无序的，则不允许重复。如果值是有序的，则允许重复。

属性的内容和表示形式及其值均由属性的模式 定义。模式包含关于属性语法和属性其他性质的信息。有关基础目录服务支持模式时如何获取关于属性的模式信息的详细信息，请参阅 getAttributeDefinition() 和 getAttributeSyntaxDefinition()。

两个属性的相等性由实现类确定。简单的实现可以使用 Object.equals() 来确定属性值的相等性，而较复杂的实现可能使用模式信息来确定相等性。类似地，一个实现可能提供仅返回传递给其构造方法的值的静态存储结构，另一个实现可能定义 get() 和 getAll() 从目录动态获取值。

注意，更新 Attribute（如添加或移除值）对目录中相应的属性表示形式没有影响。只有使用 DirContext 接口中的操作才能实现对目录的更新。

从以下版本开始：
1.3
另请参见：
BasicAttribute

字段摘要
static long serialVersionUID
使用 JNDI 1.1.1 中的 serialVersionUID 获取互操作性。
方法摘要
void | add(int ix, Object attrVal) 将属性值添加到属性值的有序列表中。
boolean | add(Object attrVal) 向属性添加新值。
void | clear() 从此属性移除所有值。
Object | clone() 对属性进行复制。
boolean | contains(Object attrVal) 确定某个值是否在属性中。
Object | get() 检索此属性的其中一个值。
Object | get(int ix) 从属性值的有序列表中检索属性值。
NamingEnumeration<?> | getAll() 检索属性值的枚举。
DirContext | getAttributeDefinition() 检索属性的模式定义。
DirContext | getAttributeSyntaxDefinition() 检索与属性关联的语法定义。
String | getID() 检索此属性的 id。
boolean | isOrdered() 确定此属性的值是否是有序的。
Object | remove(int ix) 从属性值的有序列表中移除属性值。
boolean | remove(Object attrval) 从属性中移除指定值。
Object | set(int ix, Object attrVal) 设置属性值的有序列表中的属性值。
int | size() 检索此属性中的值数。

字段详细信息

serialVersionUID

static final long serialVersionUID
使用 JNDI 1.1.1 中的 serialVersionUID 获取互操作性。

另请参见：
常量字段值
方法详细信息

getAll

NamingEnumeration<?> getAll()
                            throws NamingException
检索属性值的枚举。如果正在进行枚举时添加、更改或移除属性值，则此枚举的行为是不确定的。如果属性值是有序的，则枚举的项将是有序的。

返回：
属性值的非 null 枚举。每个枚举元素都可能是一个 null 对象。对象的类就是属性值的类。如果属性值为 null，则元素为 null。如果属性的值为零，则返回空枚举。
抛出：
NamingException - 如果检索值时遇到命名异常。
另请参见：
isOrdered()

get

Object get()
           throws NamingException
检索此属性的其中一个值。如果属性具有多个值并且是无序的，则返回其中的任意一个值。如果属性具多个值并且是有序的，则返回第一个值。

返回：
表示属性值之一的可能为 null 的对象。如果属性值为 null，则返回 null。
抛出：
NamingException - 如果检索值时遇到命名异常。
NoSuchElementException - 如果此属性没有值。

size

int size()
检索此属性中的值数。

返回：
此属性中的非负值数。

getID

String getID()
检索此属性的 id。

返回：
此属性的 id。它不能为 null。

contains

boolean contains(Object attrVal)
确定某个值是否在属性中。相等性由实现确定，其可能使用 Object.equals() 或模式信息来确定相等性。

参数：
attrVal - 要检查的可能为 null 的值。如果为 null，则检查属性是否具有其值不为 null 的属性值。
返回：
如果 attrVal 是此属性的值之一，则返回 true；否则返回 false。
另请参见：
Object.equals(java.lang.Object), BasicAttribute.equals(java.lang.Object)

add

boolean add(Object attrVal)
向属性添加新值。如果属性值是无序的，并且 attrVal 已在属性中，则此方法不执行任何操作。如果属性值是有序的，则 attrVal 将被添加到属性值列表的末尾。

相等性由实现确定，其可能使用 Object.equals() 或模式信息来确定相等性。

参数：
attrVal - 要添加的可能为 null 的新值。如果为 null，则将 null 作为属性值添加。
返回：
如果添加了值，则返回 true；否则返回 false。

remove

boolean remove(Object attrval)
从属性中移除指定值。如果 attrval 不在属性中，则此方法不执行任何操作。如果属性值是有序的，则移除第一次出现的 attrVal，大于被移除值的索引处的属性值朝列表头方向上移（并将其索引减一）。

相等性由实现确定，其可能使用 Object.equals() 或模式信息来确定相等性。

参数：
attrval - 要从此属性中移除的可能为 null 的值。如果为 null，则移除为 null 的属性值。
返回：
如果移除了值，则返回 true；否则返回 false。

clear

void clear()
从此属性移除所有值。

getAttributeSyntaxDefinition

DirContext getAttributeSyntaxDefinition()
                                        throws NamingException
检索与属性关联的语法定义。属性的语法定义指定属性值的格式。注意，这与作为 Java 对象的属性值的表示形式不同。语法定义指的是目录的语法 概念。

例如，即使值可能为 Java String 对象，其目录语法仍可能为 "Printable String" 或 "Telephone Number"。或者值可能为字节数组，而其目录语法为 "JPEG" 或 "Certificate"。例如，如果此属性的语法为 "JPEG"，则此方法将返回 "JPEG" 的语法定义。

可以从语法定义检索的信息与目录有关。

如果实现不支持模式，则其将抛出 OperationNotSupportedException。如果实现支持模式，则其应定义此方法以返回适当的信息。

返回：
属性的语法定义。如果实现支持模式但此特定属性不具有任何模式信息，则返回 null。
抛出：
OperationNotSupportedException - 如果不支持获取模式。
NamingException - 如果在获取模式时发生命名异常。

getAttributeDefinition

DirContext getAttributeDefinition()
                                  throws NamingException
检索属性的模式定义。属性的模式定义包含的信息有：属性是多值的还是单值的；比较属性值时使用哪些匹配规则，等等。 可以从属性定义检索的信息与目录有关。

如果实现不支持模式，则其将抛出 OperationNotSupportedException。如果实现支持模式，则其应定义此方法以返回适当的信息。

返回：
此属性的模式定义。如果实现支持模式但此特定属性不具有任何模式信息，则返回 null。
抛出：
OperationNotSupportedException - 如果不支持获取模式。
NamingException - 如果在获取模式时发生命名异常。

clone

Object clone()
对属性进行复制。副本包含与初始属性相同的属性值：这些属性值不是其本身的副本。对副本的更改不会影响原件，反之亦然。

返回：
属性的非 null 副本。

isOrdered

boolean isOrdered()
确定此属性的值是否是有序的。如果属性值是有序的，则允许重复的值。如果属性值是无序的，则它们以任意顺序出现，没有重复值。

返回：
如果此属性的值是有序的，则返回 true；否则返回 false。
另请参见：
get(int), remove(int), add(int, java.lang.Object), set(int, java.lang.Object)

get

Object get(int ix)
           throws NamingException
从属性值的有序列表中检索属性值。此方法返回属性值列表中 ix 索引处的值。如果属性值是无序的，则此方法返回正好位于该索引处的值。

参数：
ix - 属性值的有序列表中值的索引。0 <= ix < size()。
返回：
位于索引 ix 处的可能为 null 的属性值；如果属性值为 null，则返回 null。
抛出：
NamingException - 如果检索值时遇到命名异常。
IndexOutOfBoundsException - 如果 ix 位于指定范围之外。

remove

Object remove(int ix)
从属性值的有序列表中移除属性值。此方法移除属性值列表中 ix 索引处的值。如果属性值是无序的，则此方法移除正好位于该索引处的值。位于大于 ix 的索引处的值朝列表开头上移（并且其索引减一）。

参数：
ix - 要移除的值的索引。0 <= ix < size()。
返回：
已移除的位于索引 ix 处的可能为 null 的属性值；如果属性值为 null，则返回 null。
抛出：
IndexOutOfBoundsException - 如果 ix 位于指定范围之外。

add

void add(int ix,
         Object attrVal)
将属性值添加到属性值的有序列表中。此方法将 attrVal 添加到属性值列表的索引 ix 处。位于 ix 处的索引的值或大于该处的索引的值朝列表的末尾下移（并且其索引加一）。如果属性值是无序的并且已经具有 attrVal，则抛出 IllegalStateException。

参数：
ix - 要添加新值的属性值的有序列表中的索引。0 <= ix <= size()。
attrVal - 要添加的可能为 null 的属性值；如果为 null，则 null 即为添加的值。
抛出：
IndexOutOfBoundsException - 如果 ix 位于指定范围之外。
IllegalStateException - 如果属性值是无序的并且 attrVal 是这些值之一。

set

Object set(int ix,
           Object attrVal)
设置属性值的有序列表中的属性值。此方法将属性值列表中 ix 索引处的值设置为 attrVal。移除旧值。如果属性值是无序的，则此方法将正好位于该索引处的值设置为 attrVal，除非 attrVal 已经是这些值中的一个。若其已经是这些值中的一个，则抛出 IllegalStateException。

参数：
ix - 属性值的有序列表中值的索引。0 <= ix < size()。
attrVal - 要使用的可能为 null 的属性值。如果为 null，则 'null' 将替换旧值。
返回：
已替换的索引 ix 处的可能为 null 的属性值。如果属性值已为 null，则返回 null。
抛出：
IndexOutOfBoundsException - 如果 ix 位于指定范围之外。
IllegalStateException - 如果 attrVal 已存在并且属性值是无序的。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AttributeInUseException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 AttributeInUseException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.AttributeInUseException
所有已实现的接口：
Serializable
public class AttributeInUseException
extends NamingException

当操作试图添加已经存在的属性时抛出此异常。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), 序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
AttributeInUseException()
构造一个新的 AttributeInUseException 实例。
AttributeInUseException(String explanation)
使用解释构造一个新的 AttributeInUseException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AttributeInUseException

public AttributeInUseException(String explanation)
使用解释构造一个新的 AttributeInUseException 实例。将所有其他字段都设置为 null。

参数：
explanation - 有关此异常的可能为 null 的附加详细信息。
另请参见：
Throwable.getMessage()

AttributeInUseException

public AttributeInUseException()
构造一个新的 AttributeInUseException 实例。所有字段都被初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeModificationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 AttributeModificationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.AttributeModificationException
所有已实现的接口：
Serializable
public class AttributeModificationException
extends NamingException

当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。该异常抛出以响应 DirContext.modifyAttributes()。它包含一个尚未执行的修改组成的列表，按照将其提供给 modifyAttributes() 的顺序排列。如果列表为 null，则不会成功执行任何修改。

AttributeModificationException 实例与并发多线程访问不同步。试图访问和修改单个 AttributeModification 实例的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), 序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
AttributeModificationException()
构造一个新的 AttributeModificationException 实例。
AttributeModificationException(String explanation)
使用解释构造一个新的 AttributeModificationException 实例。
方法摘要
ModificationItem[] | getUnexecutedModifications() 检索未执行修改的列表。
void | setUnexecutedModifications(ModificationItem[] e) 将未执行的修改列表设置为 e。
String | toString() 此异常的字符串表示形式由关于发生错误的位置信息和第一个未执行的修改组成。
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AttributeModificationException

public AttributeModificationException(String explanation)
使用解释构造一个新的 AttributeModificationException 实例。将所有其他字段都设置为 null。

参数：
explanation - 有关此异常的可能为 null 的附加详细信息。如果为 null，则此异常没有详细消息。
另请参见：
Throwable.getMessage()

AttributeModificationException

public AttributeModificationException()
构造一个新的 AttributeModificationException 实例。所有字段都被设置为 null。

方法详细信息

setUnexecutedModifications

public void setUnexecutedModifications(ModificationItem[] e)
将未执行的修改列表设置为 e。列表中的项必须以其最初在 DirContext.modifyAttributes() 中提供的顺序显示。列表中的第一项是未执行的第一项。如果此列表为 null，则没有执行最初提交给 modifyAttributes() 的任何操作。

参数：
e - 未执行修改的可能为 null 的列表。
另请参见：
getUnexecutedModifications()

getUnexecutedModifications

public ModificationItem[] getUnexecutedModifications()
检索未执行修改的列表。列表中的项以其最初在 DirContext.modifyAttributes() 中提供的顺序显示。列表中的第一项是未执行的第一项。如果此列表为 null，则没有执行最初提交给 modifyAttributes() 的任何操作。

返回：
可能为 null 的未执行修改列表。
另请参见：
setUnexecutedModifications(javax.naming.directory.ModificationItem[])

toString

public String toString()
此异常的字符串表示形式由关于发生错误的位置信息和第一个未执行的修改组成。此字符串用于调试，不以编程方式进行解释。

覆盖：
类 NamingException 中的 toString
返回：
此异常的非 null 字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Attributes (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
接口 Attributes

所有超级接口：
Cloneable, Serializable
所有已知实现类：
BasicAttributes
public interface Attributes
extends Cloneable, Serializable

此接口表示属性的集合。

在目录中，命名的对象可以与其属性关联。Attributes 接口表示属性的集合。例如，可以从目录请求与对象关联的属性。这些属性在实现 Attributes 接口的对象中返回。

实现 Attributes 接口的对象中的属性是无序的。该对象可以有零个或多个属性。Attributes 或者区分大小写或者不区分大小写（忽略大小写）。此属性在创建 Attributes 对象时确定。（有关示例，请参阅 BasicAttributes 构造方法）。在不区分大小写的 Attributes 中，搜索属性或添加属性时将忽略其属性标识符的大小写。在区分大小写的 Attributes 中，大小写至关重要。

注意，更新 Attribute（如添加或移除属性）对目录中的相应表示形式没有影响。只有使用 DirContext 接口中的操作才能实现对目录的更新。

从以下版本开始：
1.3
另请参见：
DirContext.getAttributes(javax.naming.Name),
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]),
BasicAttributes

方法摘要
Object | clone() 对属性集进行复制。
Attribute | get(String attrID) 利用属性集中的给定属性 id 检索属性。
NamingEnumeration<? extends Attribute> | getAll() 检索属性集中属性的枚举。
NamingEnumeration<String> | getIDs() 检索属性集中属性的 id 的枚举。
boolean | isCaseIgnored() 确定在检索或添加属性时属性集是否忽略属性标识符的大小写。
Attribute | put(Attribute attr) 向属性集中添加新属性。
Attribute | put(String attrID, Object val) 向属性集中添加新属性。
Attribute | remove(String attrID) 从属性集中移除属性 id 为 'attrID' 的属性。
int | size() 在属性集中检索属性数。

方法详细信息

isCaseIgnored

boolean isCaseIgnored()
确定在检索或添加属性时属性集是否忽略属性标识符的大小写。

返回：
如果忽略大小写，则返回 true；否则，返回 false。

size

int size()
在属性集中检索属性数。

返回：
此属性集中的非负属性数。

get

Attribute get(String attrID)
利用属性集中的给定属性 id 检索属性。

参数：
attrID - 要检索的属性的非 null id。如果此属性集忽略其属性 id 的字符大小写，则忽略 attrID 的大小写。
返回：
由 attrID 标识的属性；如果找不到，则返回 null。
另请参见：
put(java.lang.String, java.lang.Object), remove(java.lang.String)

getAll

NamingEnumeration<? extends Attribute> getAll()
检索属性集中属性的枚举。在此枚举上更新此属性集的结果是不确定的。

返回：
此属性集中属性的非 null 枚举。每个枚举元素都属于 Attribute 类。如果属性集的属性数为零，则返回空枚举。

getIDs

NamingEnumeration<String> getIDs()
检索属性集中属性的 id 的枚举。在此枚举上更新此属性集的结果是不确定的。

返回：
此属性集中属性 id 的非 null 枚举。每个枚举元素都属于 String 类。如果属性集的属性数为零，则返回空枚举。

put

Attribute put(String attrID,
              Object val)
向属性集中添加新属性。

参数：
attrID - 要添加的属性的非 null id。如果属性集忽略其属性 id 的字符大小写，则忽略 attrID 的大小写。
val - 要添加的属性的可能为 null 的值。如果为 null，则属性不具有任何值。
返回：
以前在此属性集中的具有 attrID 的 Attribute；如果不存在这种属性，则返回 null。
另请参见：
remove(java.lang.String)

put

Attribute put(Attribute attr)
向属性集中添加新属性。

参数：
attr - 要添加的非 null 属性。如果属性集忽略其属性 id 的字符大小写，则忽略 attr 标识符的大小写。
返回：
以前在此属性集中的与 attr 具有相同 ID 的 Attribute；如果不存在这种属性，则返回 null。
另请参见：
remove(java.lang.String)

remove

Attribute remove(String attrID)
从属性集中移除属性 id 为 'attrID' 的属性。如果该属性不存在，则忽略。

参数：
attrID - 要移除的属性的非 null id。如果属性集忽略其属性 id 的字符大小写，则忽略 attrID 的大小写。
返回：
以前在属性集中的与 attrID 具有相同 ID 的 Attribute；如果不存在这种属性，则返回 null。

clone

Object clone()
对属性集进行复制。新集合包含与初始集合相同的属性：这些属性不是其本身的副本。对副本的更改不会影响原件，反之亦然。

返回：
此属性集的非 null 副本。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 BasicAttribute

java.lang.Object
    继承者  javax.naming.directory.BasicAttribute
所有已实现的接口：
Serializable, Cloneable, Attribute
public class BasicAttribute
extends Object
implements Attribute

此类提供 Attribute 接口的基本实现。

此实现不支持模式方法 getAttributeDefinition() 和 getAttributeSyntaxDefinition()。它们仅抛出 OperationNotSupportedException。如果 BasicAttribute 的子类支持它们，则其应该重写这些方法。

在测试相等性或搜索值时，BasicAttribute 类默认使用 Object.equals() 确定属性值的相等性，值为数组时除外。对于数组，需要使用 Object.equals() 检查数组的每个元素。在进行类似的相等性检查时，BasicAttribute 的子类可以通过重写那些在其中使用模式具有意义的方法来利用模式信息。类似地，默认情况下 BasicAttribute 类返回传递给其构造方法和/或使用添加/移除方法进行操作的值。BasicAttribute 的子类可以重写 get() 和 getAll()，从目录动态获取值（或者直接实现 Attribute 接口，而不为 BasicAttribute 创建子类）。

注意，更新 BasicAttribute（如添加或移除值）对目录中相应的属性表示形式没有影响。只有使用 DirContext 接口中的操作才能实现对目录的更新。

BasicAttribute 实例与并发多线程访问不同步。试图访问并修改 BasicAttribute 的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
protected String | attrID 保存属性的 id。
protected boolean | ordered 记录此属性的值是否有序的标志。
protected Vector<Object> | values 保存属性的值。
构造方法摘要
BasicAttribute(String id)
构造一个不带值无序属性的新实例。
BasicAttribute(String id, boolean ordered)
构造一个不带值的可能为有序属性的新实例。
BasicAttribute(String id, Object value)
构造一个带有单个值的无序属性的新实例。
BasicAttribute(String id, Object value, boolean ordered)
构造一个带有单个值的可能为有序属性的新实例。
方法摘要
void | add(int ix, Object attrVal) 将属性值添加到属性值的有序列表中。
boolean | add(Object attrVal) 向此属性添加新值。
void | clear() 从此属性移除所有值。
Object | clone() 创建并返回此对象的一个副本。
boolean | contains(Object attrVal) 确定值是否在此属性中。
boolean | equals(Object obj) 确定 obj 是否等于此属性。
Object | get() 检索此属性的其中一个值。
Object | get(int ix) 从属性值的有序列表中检索属性值。
NamingEnumeration<?> | getAll() 检索此属性值的枚举。
DirContext | getAttributeDefinition() 检索此属性的模式定义。
DirContext | getAttributeSyntaxDefinition() 检索与此属性关联的语法定义。
String | getID() 检索此属性的 id。
int | hashCode() 计算此属性的哈希码。
boolean | isOrdered() 确定此属性的值是否是有序的。
Object | remove(int ix) 从属性值的有序列表中移除属性值。
boolean | remove(Object attrval) 从此属性中移除指定值。
Object | set(int ix, Object attrVal) 设置属性值的有序列表中的属性值。
int | size() 检索此属性中的值数。
String | toString() 生成此属性的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

attrID

protected String attrID
保存属性的 id。其由公共构造方法初始化且不能为 null，除非已经重写 BasicAttribute 中使用 attrID 的方法。

values

protected transient Vector<Object> values
保存属性的值。由公共构造方法初始化。其不能为 null，除非已经重写 BasicAttribute 中使用这些值的方法。

ordered

protected boolean ordered
记录此属性的值是否有序的标志。

构造方法详细信息

BasicAttribute

public BasicAttribute(String id)
构造一个不带值无序属性的新实例。

参数：
id - 属性的 id。它不能为 null。

BasicAttribute

public BasicAttribute(String id,
                      Object value)
构造一个带有单个值的无序属性的新实例。

参数：
id - 属性的 id。它不能为 null。
value - 属性的值。如果为 null，则向属性中添加 null 值。

BasicAttribute

public BasicAttribute(String id,
                      boolean ordered)
构造一个不带值的可能为有序属性的新实例。

参数：
id - 属性的 id。它不能为 null。
ordered - 为 true 表示属性值将是有序的；为 false 表示其为无序。

BasicAttribute

public BasicAttribute(String id,
                      Object value,
                      boolean ordered)
构造一个带有单个值的可能为有序属性的新实例。

参数：
id - 属性的 id。它不能为 null。
value - 属性的值。如果为 null，则向属性中添加 null 值。
ordered - 为 true 表示属性值将是有序的；为 false 表示其为无序。
方法详细信息

clone

public Object clone()
从类 Object 复制的描述
创建并返回此对象的一个副本。“副本”的准确含义可能依赖于对象的类。这样做的目的是，对于任何对象 x，表达式：
x.clone() != x
为 true，表达式：
x.clone().getClass() == x.getClass()
也为 true，但这些并非必须要满足的要求。一般情况下：
x.clone().equals(x)
为 true，但这并非必须要满足的要求。

按照惯例，返回的对象应该通过调用 super.clone 获得。如果一个类及其所有的超类（Object 除外）都遵守此约定，则 x.clone().getClass() == x.getClass()。

按照惯例，此方法返回的对象应该独立于该对象（正被复制的对象）。要获得此独立性，在 super.clone 返回对象之前，有必要对该对象的一个或多个字段进行修改。这通常意味着要复制包含正在被复制对象的内部“深层结构”的所有可变对象，并使用对副本的引用替换对这些对象的引用。如果一个类只包含基本字段或对不变对象的引用，那么通常不需要修改 super.clone 返回的对象中的字段。

Object 类的 clone 方法执行特定的复制操作。首先，如果此对象的类不能实现接口 Cloneable，则会抛出 CloneNotSupportedException。注意，所有的数组都被视为实现接口 Cloneable。否则，此方法会创建此对象的类的一个新实例，并像通过分配那样，严格使用此对象相应字段的内容初始化该对象的所有字段；这些字段的内容没有被自我复制。所以，此方法执行的是该对象的“浅表复制”，而不“深层复制”操作。

Object 类本身不实现接口 Cloneable，所以在类为 Object 的对象上调用 clone 方法将会导致在运行时抛出异常。

指定者：
接口 Attribute 中的 clone
覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

equals

public boolean equals(Object obj)
确定 obj 是否等于此属性。如果两个属性的属性 id、语法和值都相等，则这两个属性相等。如果属性值是无序的，则添加值的顺序无关紧要。如果属性值是有序的，则值必须与顺序匹配。如果 obj 为 null 或者不是 Attribute，则返回 false。

默认情况下，在比较属性 id 及其值时使用 Object.equals()，值为数组时除外。对于数组，需要使用 Object.equals() 检查数组的每个元素。子类可以重写此方法以利用模式语法信息和匹配规则，其定义了对两个属性的相等有意义的内容。子类如何使用和是否使用模式信息由子类确定。如果子类重写 equals()，则其也应该重写 hashCode()，这样两个相等的属性才能具有相同的哈希码。

覆盖：
类 Object 中的 equals
参数：
obj - 要检查的可能为 null 的对象。
返回：
如果 obj 等于此属性，则返回 true，否则返回 false。
另请参见：
hashCode(), contains(java.lang.Object)

hashCode

public int hashCode()
计算此属性的哈希码。

该哈希码通过将属性 id 及其所有值的哈希码相加来计算，值为数组时除外。对于数组，要加上每个数组元素的哈希码。如果子类重写 hashCode()，则其也应该重写 equals()，这样两个相等的属性才能具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
表示此属性的哈希码的 int。
另请参见：
equals(java.lang.Object)

toString

public String toString()
生成此属性的字符串表示形式。字符串由属性的 id 及其值组成。此字符串用于调试，不以编程方式进行解释。

覆盖：
类 Object 中的 toString
返回：
此属性的非 null 字符串表示形式。

getAll

public NamingEnumeration<?> getAll()
                            throws NamingException
检索此属性值的枚举。

默认情况下，返回值就是传递给构造方法的和/或使用添加/替换/移除方法对其进行操作的那些值。子类可以重写此方法以从目录动态检索值。

指定者：
接口 Attribute 中的 getAll
返回：
属性值的非 null 枚举。每个枚举元素都可能是一个 null 对象。对象的类就是属性值的类。如果属性值为 null，则元素为 null。如果属性的值为零，则返回空枚举。
抛出：
NamingException - 如果检索值时遇到命名异常。
另请参见：
Attribute.isOrdered()

get

public Object get()
           throws NamingException
检索此属性的其中一个值。

默认情况下，返回值就是传递给构造方法的和/或使用添加/替换/移除方法对其进行操作的那些值之一。子类可以重写此方法以从目录动态检索值。

指定者：
接口 Attribute 中的 get
返回：
表示属性值之一的可能为 null 的对象。如果属性值为 null，则返回 null。
抛出：
NamingException - 如果检索值时遇到命名异常。

size

public int size()
从接口 Attribute 复制的描述
检索此属性中的值数。

指定者：
接口 Attribute 中的 size
返回：
此属性中的非负值数。

getID

public String getID()
从接口 Attribute 复制的描述
检索此属性的 id。

指定者：
接口 Attribute 中的 getID
返回：
此属性的 id。它不能为 null。

contains

public boolean contains(Object attrVal)
确定值是否在此属性中。

默认情况下，在将 attrVal 与此属性的值相比较时使用 Object.equals()，attrVal 为数组时除外。对于数组，需要使用 Object.equals() 检查数组的每个元素。子类可以使用模式信息确定相等性。

指定者：
接口 Attribute 中的 contains
参数：
attrVal - 要检查的可能为 null 的值。如果为 null，则检查属性是否具有其值不为 null 的属性值。
返回：
如果 attrVal 是此属性的值之一，则返回 true；否则返回 false。
另请参见：
Object.equals(java.lang.Object), equals(java.lang.Object)

add

public boolean add(Object attrVal)
向此属性添加新值。

默认情况下，在将 attrVal 与此属性的值相比较时使用 Object.equals()，attrVal 为数组时除外。对于数组，需要使用 Object.equals() 检查数组的每个元素。子类可以使用模式信息确定相等性。

指定者：
接口 Attribute 中的 add
参数：
attrVal - 要添加的可能为 null 的新值。如果为 null，则将 null 作为属性值添加。
返回：
如果添加了值，则返回 true；否则返回 false。

remove

public boolean remove(Object attrval)
从此属性中移除指定值。

默认情况下，在将 attrVal 与此属性的值相比较时使用 Object.equals()，attrVal 为数组时除外。对于数组，需要使用 Object.equals() 检查数组的每个元素。子类可以使用模式信息确定相等性。

指定者：
接口 Attribute 中的 remove
参数：
attrval - 要从此属性中移除的可能为 null 的值。如果为 null，则移除为 null 的属性值。
返回：
如果移除了值，则返回 true；否则返回 false。

clear

public void clear()
从接口 Attribute 复制的描述
从此属性移除所有值。

指定者：
接口 Attribute 中的 clear

isOrdered

public boolean isOrdered()
从接口 Attribute 复制的描述
确定此属性的值是否是有序的。如果属性值是有序的，则允许重复的值。如果属性值是无序的，则它们以任意顺序出现，没有重复值。

指定者：
接口 Attribute 中的 isOrdered
返回：
如果此属性的值是有序的，则返回 true；否则返回 false。
另请参见：
Attribute.get(int),
Attribute.remove(int),
Attribute.add(int, java.lang.Object),
Attribute.set(int, java.lang.Object)

get

public Object get(int ix)
           throws NamingException
从接口 Attribute 复制的描述
从属性值的有序列表中检索属性值。此方法返回属性值列表中 ix 索引处的值。如果属性值是无序的，则此方法返回正好位于该索引处的值。

指定者：
接口 Attribute 中的 get
参数：
ix - 属性值的有序列表中值的索引。0 <= ix < size()。
返回：
位于索引 ix 处的可能为 null 的属性值；如果属性值为 null，则返回 null。
抛出：
NamingException - 如果检索值时遇到命名异常。

remove

public Object remove(int ix)
从接口 Attribute 复制的描述
从属性值的有序列表中移除属性值。此方法移除属性值列表中 ix 索引处的值。如果属性值是无序的，则此方法移除正好位于该索引处的值。位于大于 ix 的索引处的值朝列表开头上移（并且其索引减一）。

指定者：
接口 Attribute 中的 remove
参数：
ix - 要移除的值的索引。0 <= ix < size()。
返回：
已移除的位于索引 ix 处的可能为 null 的属性值；如果属性值为 null，则返回 null。

add

public void add(int ix,
                Object attrVal)
从接口 Attribute 复制的描述
将属性值添加到属性值的有序列表中。此方法将 attrVal 添加到属性值列表的索引 ix 处。位于 ix 处的索引的值或大于该处的索引的值朝列表的末尾下移（并且其索引加一）。如果属性值是无序的并且已经具有 attrVal，则抛出 IllegalStateException。

指定者：
接口 Attribute 中的 add
参数：
ix - 要添加新值的属性值的有序列表中的索引。0 <= ix <= size()。
attrVal - 要添加的可能为 null 的属性值；如果为 null，则 null 即为添加的值。

set

public Object set(int ix,
                  Object attrVal)
从接口 Attribute 复制的描述
设置属性值的有序列表中的属性值。此方法将属性值列表中 ix 索引处的值设置为 attrVal。移除旧值。如果属性值是无序的，则此方法将正好位于该索引处的值设置为 attrVal，除非 attrVal 已经是这些值中的一个。若其已经是这些值中的一个，则抛出 IllegalStateException。

指定者：
接口 Attribute 中的 set
参数：
ix - 属性值的有序列表中值的索引。0 <= ix < size()。
attrVal - 要使用的可能为 null 的属性值。如果为 null，则 'null' 将替换旧值。
返回：
已替换的索引 ix 处的可能为 null 的属性值。如果属性值已为 null，则返回 null。

getAttributeSyntaxDefinition

public DirContext getAttributeSyntaxDefinition()
                                        throws NamingException
检索与此属性关联的语法定义。

默认情况下此方法抛出 OperationNotSupportedException。如果子类支持模式，则其应该重写此方法。

指定者：
接口 Attribute 中的 getAttributeSyntaxDefinition
返回：
属性的语法定义。如果实现支持模式但此特定属性不具有任何模式信息，则返回 null。
抛出：
OperationNotSupportedException - 如果不支持获取模式。
NamingException - 如果在获取模式时发生命名异常。

getAttributeDefinition

public DirContext getAttributeDefinition()
                                  throws NamingException
检索此属性的模式定义。

默认情况下此方法抛出 OperationNotSupportedException。如果子类支持模式，则其应该重写此方法。

指定者：
接口 Attribute 中的 getAttributeDefinition
返回：
此属性的模式定义。如果实现支持模式但此特定属性不具有任何模式信息，则返回 null。
抛出：
OperationNotSupportedException - 如果不支持获取模式。
NamingException - 如果在获取模式时发生命名异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BasicAttributes (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 BasicAttributes

java.lang.Object
    继承者  javax.naming.directory.BasicAttributes
所有已实现的接口：
Serializable, Cloneable, Attributes
public class BasicAttributes
extends Object
implements Attributes

此类提供 Attributes 接口的基本实现。

BasicAttributes 或者区分大小写或者不区分大小写（忽略大小写）。此属性在调用 BasicAttributes 构造方法时确定。在不区分大小写的 BasicAttributes 中，搜索属性或添加属性时将忽略其属性标识符的大小写。在区分大小写的 BasicAttributes 中，大小写有意义。

BasicAttributes 类需要创建 Attribute 时使用 BasicAttribute。对 BasicAttribute 没有其他依赖性。

注意，更新 BasicAttributes（如添加或移除属性）对目录中的相应表示形式没有影响。只有使用 DirContext 接口中的操作才能实现对目录的更新。

BasicAttributes 实例与并发多线程访问不同步。试图访问和修改单个 BasicAttributes 实例的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
DirContext.getAttributes(javax.naming.Name),
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]),
序列化表格

构造方法摘要
BasicAttributes()
构造一个新的 Attributes 实例。
BasicAttributes(boolean ignoreCase)
构造一个新的 Attributes 实例。
BasicAttributes(String attrID, Object val)
构造带有一个属性的新 Attributes 实例。
BasicAttributes(String attrID, Object val, boolean ignoreCase)
构造带有一个属性的新 Attributes 实例。
方法摘要
Object | clone() 创建并返回此对象的一个副本。
boolean | equals(Object obj) 确定此 BasicAttributes 是否等于另一个 Attributes。
Attribute | get(String attrID) 利用属性集中的给定属性 id 检索属性。
NamingEnumeration<Attribute> | getAll() 检索属性集中属性的枚举。
NamingEnumeration<String> | getIDs() 检索属性集中属性的 id 的枚举。
int | hashCode() 计算此 BasicAttributes 的哈希码。
boolean | isCaseIgnored() 确定在检索或添加属性时属性集是否忽略属性标识符的大小写。
Attribute | put(Attribute attr) 向属性集中添加新属性。
Attribute | put(String attrID, Object val) 向属性集中添加新属性。
Attribute | remove(String attrID) 从属性集中移除属性 id 为 'attrID' 的属性。
int | size() 在属性集中检索属性数。
String | toString() 生成此属性集的字符串表示形式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

BasicAttributes

public BasicAttributes()
构造一个新的 Attributes 实例。在后续检索或添加属性时属性标识符的字符大小写有意义。

BasicAttributes

public BasicAttributes(boolean ignoreCase)
构造一个新的 Attributes 实例。如果 ignoreCase 为 true，则忽略属性标识符的字符大小写；否则大小写有意义。

参数：
ignoreCase - 为 true 表示在检索或添加属性时此属性集将忽略其属性标识符的大小写；为 false 表示要考虑大小写。

BasicAttributes

public BasicAttributes(String attrID,
                       Object val)
构造带有一个属性的新 Attributes 实例。将 attrID 和 val 指定的属性添加到新创建的属性中。在后续检索或添加属性时属性标识符的字符大小写有意义。

参数：
attrID - 要添加的非 null 属性 id。
val - 要添加的属性的值。如果为 null，则将 null 值添加到属性中。

BasicAttributes

public BasicAttributes(String attrID,
                       Object val,
                       boolean ignoreCase)
构造带有一个属性的新 Attributes 实例。将 attrID 和 val 指定的属性添加到新创建的属性中。如果 ignoreCase 为 true，则忽略属性标识符的字符大小写；否则大小写有意义。

参数：
attrID - 要添加的属性的非 null id。如果此属性集忽略其属性 id 的字符大小写，则忽略 attrID 的大小写。
val - 要添加的属性的值。如果为 null，则将 null 值添加到属性中。
ignoreCase - 为 true 表示在检索或添加属性时此属性集将忽略其属性标识符的大小写；为 false 表示要考虑大小写。
方法详细信息

clone

public Object clone()
从类 Object 复制的描述
创建并返回此对象的一个副本。“副本”的准确含义可能依赖于对象的类。这样做的目的是，对于任何对象 x，表达式：
x.clone() != x
为 true，表达式：
x.clone().getClass() == x.getClass()
也为 true，但这些并非必须要满足的要求。一般情况下：
x.clone().equals(x)
为 true，但这并非必须要满足的要求。

按照惯例，返回的对象应该通过调用 super.clone 获得。如果一个类及其所有的超类（Object 除外）都遵守此约定，则 x.clone().getClass() == x.getClass()。

按照惯例，此方法返回的对象应该独立于该对象（正被复制的对象）。要获得此独立性，在 super.clone 返回对象之前，有必要对该对象的一个或多个字段进行修改。这通常意味着要复制包含正在被复制对象的内部“深层结构”的所有可变对象，并使用对副本的引用替换对这些对象的引用。如果一个类只包含基本字段或对不变对象的引用，那么通常不需要修改 super.clone 返回的对象中的字段。

Object 类的 clone 方法执行特定的复制操作。首先，如果此对象的类不能实现接口 Cloneable，则会抛出 CloneNotSupportedException。注意，所有的数组都被视为实现接口 Cloneable。否则，此方法会创建此对象的类的一个新实例，并像通过分配那样，严格使用此对象相应字段的内容初始化该对象的所有字段；这些字段的内容没有被自我复制。所以，此方法执行的是该对象的“浅表复制”，而不“深层复制”操作。

Object 类本身不实现接口 Cloneable，所以在类为 Object 的对象上调用 clone 方法将会导致在运行时抛出异常。

指定者：
接口 Attributes 中的 clone
覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

isCaseIgnored

public boolean isCaseIgnored()
从接口 Attributes 复制的描述
确定在检索或添加属性时属性集是否忽略属性标识符的大小写。

指定者：
接口 Attributes 中的 isCaseIgnored
返回：
如果忽略大小写，则返回 true；否则，返回 false。

size

public int size()
从接口 Attributes 复制的描述
在属性集中检索属性数。

指定者：
接口 Attributes 中的 size
返回：
此属性集中的非负属性数。

get

public Attribute get(String attrID)
从接口 Attributes 复制的描述
利用属性集中的给定属性 id 检索属性。

指定者：
接口 Attributes 中的 get
参数：
attrID - 要检索的属性的非 null id。如果此属性集忽略其属性 id 的字符大小写，则忽略 attrID 的大小写。
返回：
由 attrID 标识的属性；如果找不到，则返回 null。
另请参见：
Attributes.put(java.lang.String, java.lang.Object), Attributes.remove(java.lang.String)

getAll

public NamingEnumeration<Attribute> getAll()
从接口 Attributes 复制的描述
检索属性集中属性的枚举。在此枚举上更新此属性集的结果是不确定的。

指定者：
接口 Attributes 中的 getAll
返回：
此属性集中属性的非 null 枚举。每个枚举元素都属于 Attribute 类。如果属性集的属性数为零，则返回空枚举。

getIDs

public NamingEnumeration<String> getIDs()
从接口 Attributes 复制的描述
检索属性集中属性的 id 的枚举。在此枚举上更新此属性集的结果是不确定的。

指定者：
接口 Attributes 中的 getIDs
返回：
此属性集中属性 id 的非 null 枚举。每个枚举元素都属于 String 类。如果属性集的属性数为零，则返回空枚举。

put

public Attribute put(String attrID,
                     Object val)
从接口 Attributes 复制的描述
向属性集中添加新属性。

指定者：
接口 Attributes 中的 put
参数：
attrID - 要添加的属性的非 null id。如果属性集忽略其属性 id 的字符大小写，则忽略 attrID 的大小写。
val - 要添加的属性的可能为 null 的值。如果为 null，则属性不具有任何值。
返回：
以前在此属性集中的具有 attrID 的 Attribute；如果不存在这种属性，则返回 null。
另请参见：
Attributes.remove(java.lang.String)

put

public Attribute put(Attribute attr)
从接口 Attributes 复制的描述
向属性集中添加新属性。

指定者：
接口 Attributes 中的 put
参数：
attr - 要添加的非 null 属性。如果属性集忽略其属性 id 的字符大小写，则忽略 attr 标识符的大小写。
返回：
以前在此属性集中的与 attr 具有相同 ID 的 Attribute；如果不存在这种属性，则返回 null。
另请参见：
Attributes.remove(java.lang.String)

remove

public Attribute remove(String attrID)
从接口 Attributes 复制的描述
从属性集中移除属性 id 为 'attrID' 的属性。如果该属性不存在，则忽略。

指定者：
接口 Attributes 中的 remove
参数：
attrID - 要移除的属性的非 null id。如果属性集忽略其属性 id 的字符大小写，则忽略 attrID 的大小写。
返回：
以前在属性集中的与 attrID 具有相同 ID 的 Attribute；如果不存在这种属性，则返回 null。

toString

public String toString()
生成此属性集的字符串表示形式。字符串由每个属性标识符和每个属性的内容组成。此字符串的内容用于调试目的，不以编程方式对其进行解释。

覆盖：
类 Object 中的 toString
返回：
列出此属性集的内容的非 null 字符串。

equals

public boolean equals(Object obj)
确定此 BasicAttributes 是否等于另一个 Attributes。如果两个 Attributes 均为 Attributes 的实例、对待属性 ID 的大小写的方式相同并且包含相同的属性，则它们是相等的。此 BasicAttributes 中的每个 Attribute 的相等性都是使用 Object.equals() 检查的（Attribute 的实现可能已经重写了该方法）。如果子类重写 equals()，则其也应该重写 hashCode()，这样两个相等的 Attributes 实例才能具有相同的哈希码。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的可能为 null 的对象。
返回：
如果 obj 等于此 BasicAttributes，则返回 true。
另请参见：
hashCode()

hashCode

public int hashCode()
计算此 BasicAttributes 的哈希码。

该哈希码通过加总此对象的属性的哈希码来计算。如果此 BasicAttributes 忽略其属性 ID 的大小写，则将哈希码加一。如果子类重写 hashCode()，则其也应该重写 equals()，这样两个相等的 Attributes 实例才能具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
表示此 BasicAttributes 实例的哈希码的 int。
另请参见：
equals(java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DirContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
接口 DirContext

所有超级接口：
Context
所有已知子接口：
EventDirContext, LdapContext
所有已知实现类：
InitialDirContext, InitialLdapContext
public interface DirContext
extends Context

目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。

名称

作为参数传递给 DirContext 方法的每个名称都相对于该上下文。空名称用于命名上下文本身。名称参数永远不能为 null。

大多数方法具有重载形式，一种使用 Name 参数，另一种使用 String 参数。这些重载的方法是等效的，因为如果 Name 和 String 参数只是同一名称的不同表示形式，则相同方法的重载形式以相同的方式运行。在以下的方法描述中，只记录一种形式。第二种形式链接到第一种：对两者应用相同的文档。

有关 Context 方法的名称参数解释的讨论，请参阅 Context。这些相同的规则也适用于 DirContext 方法的名称参数。

属性模型

有两个属性应该与之关联的基本模型。第一，属性可以直接与 DirContext 对象关联。在此模型中，对命名对象进行的属性操作大致等效于先对名称进行查找（返回 DirContext 对象），然后对 DirContext 对象（调用者在其中提供空名称）调用该属性操作。这些属性可视为与对象存储在一起（注意，这并不意味着实现必须进行此操作）。

第二个模型是属性与 DirContext 中的名称（通常是原子名称）相关联。在此模型中，对指定对象进行的属性操作大致等效于先对命名对象父 DirContext 的名称进行查找，然后对父 DirContext 对象（调用者在其中提供最终原子名称）调用该属性操作。这些属性可视为存储在父 DirContext 中（注意，这并不意味着实现必须进行此操作）。不是 DirContext 的对象只要其父级是 DirContext 就可以有属性。

JNDI 同时支持这两种模型。由各个服务提供者决定将属性“存储”在何处。JNDI 客户端在没有对对象属性是作为对象的一部分存储，还是存储在父对象中并与对象名称关联作出假设时，是最安全的。

属性类型名称

在 getAttributes() 和 search() 方法中，可以通过提供一个属性名称（字符串）列表来提供要返回的属性。得到的属性可能与指定的属性名称不相同。这是因为有些目录支持使其返回其他属性的功能。这些功能包括属性子类化、属性名同义词和属性语言码。

在属性子类化中，属性在类层次中定义。例如，在某些目录中，"name" 属性可能是所有与名称相关的属性（包括 "commonName" 和 "surName"）的超类。请求 "name" 属性可能同时返回 "commonName" 和 "surName" 属性。

使用属性类型同义词，目录可以将多个名称分配给同一属性。例如，"cn" 和 "commonName" 可能指的是同一属性。请求 "cn" 可能返回 "commonName" 属性。

有些目录支持属性的语言码。例如，向这种目录请求 "description" 属性可能返回以下全部属性：

  • description
  • description;lang-en
  • description;lang-de
  • description;lang-fr

操作属性

有些目录具有“操作属性”的概念，操作属性指为了管理而与目录对象关联的属性。一个操作属性的示例是对象的访问控制列表。

在 getAttributes() 和 search() 方法中，可以通过提供 null 作为要返回的属性列表来指定所有与请求的对象关联的属性。返回的属性不 包括操作属性。要检索操作属性，必须显式指定它们。

命名上下文

在某些方法中，必须将名称解析为上下文（例如，在搜索单个级别的上下文时）。这些方法的文档使用术语命名上下文 来描述其名称参数。对于这些方法，如果命名对象不是 DirContext，则抛出 NotContextException。除了这些方法之外，其他方法均不要求命名对象 为 DirContext。

参数

作为参数传递给任何方法的 Attributes、SearchControls 或数组对象不能被服务提供者修改。服务提供者可以在操作期间持有对它的引用，包括方法结果的所有枚举和对生成的所有引用的处理。调用者在此期间不应修改对象。任何方法返回的 Attributes 对象都归调用者所有。调用者可以在以后修改它，而服务提供者则不能。

异常

此接口中的所有方法都可以抛出 NamingException 或其任一子类。有关每个异常的详细信息，请参阅 NamingException 及其子类。

从以下版本开始：
1.3
另请参见：
Context

字段摘要
static int | ADD_ATTRIBUTE 此常量指定使用指定值添加属性。
static int | REMOVE_ATTRIBUTE 此常量指定从属性中删除指定的属性值。
static int | REPLACE_ATTRIBUTE 此常量指定使用指定值替换属性。
从接口 javax.naming.Context 继承的字段
APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES
方法摘要
void | bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | bind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
DirContext | createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
Attributes | getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | getAttributes(String name) 检索所有与命名对象关联的属性。
Attributes | getAttributes(String name, String[] attrIds) 检索与命名对象关联的选定属性。
DirContext | getSchema(Name name) 检索与命名对象关联的模式。
DirContext | getSchema(String name) 检索与命名对象关联的模式。
DirContext | getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | getSchemaClassDefinition(String name) 检索包含命名对象类定义的模式对象的上下文。
void | modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | modifyAttributes(String name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | modifyAttributes(String name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | rebind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
NamingEnumeration<SearchResult> | search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
从接口 javax.naming.Context 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

字段详细信息

ADD_ATTRIBUTE

static final int ADD_ATTRIBUTE
此常量指定使用指定值添加属性。

如果属性不存在，则创建属性。得到的属性会将指定的值集合与以前的值集合并起来。如果属性必须至少有一个值，则添加不带值的属性将抛出 InvalidAttributeValueException。对于属性已经存在的单值属性，抛出 AttributeInUseException。如果试图将一个以上的值添加到单值属性，则抛出 InvalidAttributeValueException。

此常量的值为 1。

另请参见：
ModificationItem, modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), 常量字段值

REPLACE_ATTRIBUTE

static final int REPLACE_ATTRIBUTE
此常量指定使用指定值替换属性。

如果属性已经存在，则使用新的指定值替换所有现有值。如果该属性不存在，则创建它。如果没有指定值，则删除属性的所有值。如果要求属性必须至少有一个值，则移除最后一个值时会将属性一起移除。如果试图将一个以上的值添加到单值属性，则抛出 InvalidAttributeValueException。

此常量的值为 2。

另请参见：
ModificationItem, modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), 常量字段值

REMOVE_ATTRIBUTE

static final int REMOVE_ATTRIBUTE
此常量指定从属性中删除指定的属性值。

得到的属性值集合不同于其以前的值集合和指定的值集合。如果没有指定值，则删除整个属性。如果属性不存在，或者指定值集合的某些或全部成员不存在，则可能忽略此情况并操作成功，也可能抛出 NamingException 指示此情况。如果要求属性必须至少有一个值，则移除最后一个值时会将属性一起移除。

此常量的值为 3。

另请参见：
ModificationItem, modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes), 常量字段值
方法详细信息

getAttributes

Attributes getAttributes(Name name)
                         throws NamingException
检索与命名对象关联的所有属性。请参阅关于属性模型、属性类型名称和操作属性的类描述。

参数：
name - 对象名，通过该对象名检索属性
返回：
与 name 关联的属性集。如果名称没有属性，则返回空属性集；永远不为 null。
抛出：
NamingException - 如果遇到命名异常
另请参见：
getAttributes(String), getAttributes(Name, String[])

getAttributes

Attributes getAttributes(String name)
                         throws NamingException
检索所有与命名对象关联的属性。有关详细信息，请参阅 getAttributes(Name)。

参数：
name - 对象名，通过该对象名检索属性
返回：
与 name 关联的属性集
抛出：
NamingException - 如果遇到命名异常

getAttributes

Attributes getAttributes(Name name,
                         String[] attrIds)
                         throws NamingException
检索与命名对象关联的选定属性。请参阅关于属性模型、属性类型名称和操作属性的类描述。

如果对象没有指定的属性，则目录将忽略不存在的属性，并返回那些对象所具有的请求属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但不允许返回任意的、无关的属性。

另请参阅类描述中的操作属性。

参数：
name - 对象名，通过该对象名检索属性
attrIds - 要检索的属性的标识符。null 指示应该检索所有属性；空数组指示不应检索任何属性。
返回：
请求的属性；永远不为 null
抛出：
NamingException - 如果遇到命名异常

getAttributes

Attributes getAttributes(String name,
                         String[] attrIds)
                         throws NamingException
检索与命名对象关联的选定属性。有关详细信息，请参阅 getAttributes(Name, String[])。

参数：
name - 对象名，通过该对象名检索属性
attrIds - 要检索的属性的标识符。null 指示应该检索所有属性；空数组指示不应检索任何属性。
返回：
请求的属性；永远不为 null
抛出：
NamingException - 如果遇到命名异常

modifyAttributes

void modifyAttributes(Name name,
                      int mod_op,
                      Attributes attrs)
                      throws NamingException
修改与命名对象关联的属性。没有指定修改的顺序。在可能的情况下，将以原子方式执行修改。

参数：
name - 属性将被更新的对象的名称
mod_op - 修改操作，为以下操作之一：ADD_ATTRIBUTE、REPLACE_ATTRIBUTE 和 REMOVE_ATTRIBUTE。
attrs - 要用于修改的属性；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常
另请参见：
modifyAttributes(Name, ModificationItem[])

modifyAttributes

void modifyAttributes(String name,
                      int mod_op,
                      Attributes attrs)
                      throws NamingException
修改与命名对象关联的属性。有关详细信息，请参阅 modifyAttributes(Name, int, Attributes)。

参数：
name - 属性将被更新的对象的名称
mod_op - 修改操作，为以下操作之一：ADD_ATTRIBUTE、REPLACE_ATTRIBUTE 和 REMOVE_ATTRIBUTE。
attrs - 要用于修改的属性；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常

modifyAttributes

void modifyAttributes(Name name,
                      ModificationItem[] mods)
                      throws NamingException
使用有序的修改列表修改与命名对象关联的属性。按指定的顺序执行修改。每个修改指定一个修改操作代码和一个对其执行操作的属性。在可能的情况下，将以原子方式执行修改。

参数：
name - 属性将被更新的对象的名称
mods - 要执行的修改的有序序列；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常
另请参见：
modifyAttributes(Name, int, Attributes), ModificationItem

modifyAttributes

void modifyAttributes(String name,
                      ModificationItem[] mods)
                      throws NamingException
使用有序的修改列表修改与命名对象关联的属性。有关详细信息，请参阅 modifyAttributes(Name, ModificationItem[])。

参数：
name - 属性将被更新的对象的名称
mods - 要执行的修改的有序序列；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常

bind

void bind(Name name,
          Object obj,
          Attributes attrs)
          throws NamingException
将名称与关联的属性一起绑定到一个对象。如果 attrs 为 null，则 obj 为 DirContext 时所得绑定将具有与 obj 关联的属性，否则不具有属性。如果 attrs 为非 null，则所得绑定的属性将为 attrs；所有与 obj 关联的属性都将被忽略。

参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常
另请参见：
Context.bind(Name, Object), rebind(Name, Object, Attributes)

bind

void bind(String name,
          Object obj,
          Attributes attrs)
          throws NamingException
将名称与关联的属性一起绑定到一个对象。有关详细信息，请参阅 bind(Name, Object, Attributes)。

参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常

rebind

void rebind(Name name,
            Object obj,
            Attributes attrs)
            throws NamingException
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。如果 attrs 为 null 且 obj 为 DirContext，则使用 obj 中的属性。如果 attrs 为 null 而 obj 不为 DirContext，则与已经在目录中绑定的对象关联的所有现有属性均保持不变。如果 attrs 为非 null，则移除与已经在目录中绑定的对象关联的所有现有属性，并将 attrs 与命名对象关联起来。如果 obj 为 DirContext 且 attrs 为非 null，则忽略 obj 的属性。

参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常
另请参见：
Context.bind(Name, Object), bind(Name, Object, Attributes)

rebind

void rebind(String name,
            Object obj,
            Attributes attrs)
            throws NamingException
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。有关详细信息，请参阅 rebind(Name, Object, Attributes)。

参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常

createSubcontext

DirContext createSubcontext(Name name,
                            Attributes attrs)
                            throws NamingException
创建并绑定新的上下文及关联的属性。此方法利用给定名称创建新的子上下文，将其绑定在目标上下文（由名称最终原子组件外的所有组件命名）中，并将提供的属性与新创建的对象关联起来。所有中间和目标上下文都必须已经存在。如果 attrs 为 null，则此方法等效于 Context.createSubcontext()。

参数：
name - 要创建的上下文的名称；不能为空
attrs - 要与新创建的上下文关联的属性
返回：
新创建的上下文
抛出：
NameAlreadyBoundException - 如果已经绑定了名称
InvalidAttributesException - 如果 attrs 不包含创建所需要的所有强制属性
NamingException - 如果遇到命名异常
另请参见：
Context.createSubcontext(Name)

createSubcontext

DirContext createSubcontext(String name,
                            Attributes attrs)
                            throws NamingException
创建并绑定新的上下文及关联的属性。有关详细信息，请参阅 createSubcontext(Name, Attributes)。

参数：
name - 要创建的上下文的名称；不能为空
attrs - 要与新创建的上下文关联的属性
返回：
新创建的上下文
抛出：
NameAlreadyBoundException - 如果已经绑定了名称
InvalidAttributesException - 如果 attrs 不包含创建所需要的所有强制属性
NamingException - 如果遇到命名异常

getSchema

DirContext getSchema(Name name)
                     throws NamingException
检索与命名对象关联的模式。模式描述一些关于名称空间的结构及其中所存储属性的规则。模式指定可以被添加到目录中的对象类型、添加对象的位置，以及对象可以具有的强制和可选属性。模式的支持范围是特定于目录的。

此方法返回可用于命名对象的模式信息树的根。多个命名对象（或者甚至整个目录）可以共享同一个模式。

诸如模式树的结构和内容、修改模式树内容的权限以及对目录进行这种修改的效果等问题都与基础目录有关。

参数：
name - 模式要被检索的对象的名称
返回：
与上下文关联的模式；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

getSchema

DirContext getSchema(String name)
                     throws NamingException
检索与命名对象关联的模式。有关详细信息，请参阅 getSchema(Name)。

参数：
name - 模式要被检索的对象的名称
返回：
与上下文关联的模式；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

getSchemaClassDefinition

DirContext getSchemaClassDefinition(Name name)
                                    throws NamingException
检索包含命名对象类定义的模式对象的上下文。

目录模式中存在的一种信息是类定义。“对象类”定义指定对象的类型 和对象必须/可以具有的属性（强制和可选）。注意，这里引用的术语“对象类”是指目录中而不是 Java 中的对象类。例如，如果命名对象是 "Person" 类的目录对象，则 getSchemaClassDefinition() 将返回 DirContext，它表示 "Person" 的（目录）对象类定义。

可以从对象类定义检索的信息与目录有关。

在 JNDI 1.2 之前，此方法返回表示命名对象类定义的单个模式对象。从 JNDI 1.2 开始，此方法返回包含所有命名对象类定义的 DirContext。

参数：
name - 对象类定义要被检索的对象的名称
返回：
包含命名对象的类定义的 DirContext；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

getSchemaClassDefinition

DirContext getSchemaClassDefinition(String name)
                                    throws NamingException
检索包含命名对象类定义的模式对象的上下文。有关详细信息，请参阅 getSchemaClassDefinition(Name)。

参数：
name - 对象类定义要被检索的对象的名称
返回：
包含命名对象的类定义的 DirContext；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

search

NamingEnumeration<SearchResult> search(Name name,
                                       Attributes matchingAttributes,
                                       String[] attributesToReturn)
                                       throws NamingException
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。使用默认的 SearchControls 设置进行搜索。

对于要选择的对象，matchingAttributes 中的每个属性都必须与对象的某个属性匹配。如果 matchingAttributes 为空或 null，则返回目标上下文中的所有对象。

如果 matchingAttributes 中的属性 A1 和对象的属性 A2 具有相同的标识符并且 A1 中的每个值都与 A2 的某个值相等，则认为 A1 与 A2 匹配。这意味着值的顺序无关紧要，并且 A2 可以包含 A1 没有的“额外”值，这些值对比较没有影响。它还意味着如果 A1 没有值，则测试是否匹配等效于测试是否存在具有相同标识符的属性 A2。

在比较属性值时使用的“相等性”的精确定义由基础目录服务定义。例如，它可能使用 Object.equals 方法或某种模式来指定不同的相等性操作。对于基于操作而非相等性的匹配（如子字符串比较），需要使用带有过滤器参数的 search 方法。

当对此 DirContext 作出更改时，对以前调用此方法返回的枚举的影响是不确定的。

如果对象没有指定的属性，则目录将忽略不存在的属性，并返回那些对象所具有的请求属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但不允许返回任意的、无关的属性。

另请参阅类描述中的操作属性。

参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性。如果为空或 null，则返回目标上下文中的所有对象。
attributesToReturn - 要返回的属性。null 指示要返回所有属性；空数组指示不返回任何属性。
返回：
SearchResult 对象的非 null 枚举。每个 SearchResult 都包含 attributesToReturn 所标识的属性和相应对象的名称，该名称相对于 name 指定的上下文命名。
抛出：
NamingException - 如果遇到命名异常
另请参见：
SearchControls, SearchResult, search(Name, String, Object[], SearchControls)

search

NamingEnumeration<SearchResult> search(String name,
                                       Attributes matchingAttributes,
                                       String[] attributesToReturn)
                                       throws NamingException
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。有关详细信息，请参阅 search(Name, Attributes, String[])。

参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性
attributesToReturn - 要返回的属性
返回：
SearchResult 对象的非 null 枚举
抛出：
NamingException - 如果遇到命名异常

search

NamingEnumeration<SearchResult> search(Name name,
                                       Attributes matchingAttributes)
                                       throws NamingException
在单个上下文中搜索包含指定属性集的对象。此方法返回这些对象的所有属性。这等效于向方法 search(Name, Attributes, String[]) 提供 null 作为 atributesToReturn 参数。
有关详细信息，请参阅 search(Name, Attributes, String[])。

参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性
返回：
SearchResult 对象的枚举
抛出：
NamingException - 如果遇到命名异常
另请参见：
search(Name, Attributes, String[])

search

NamingEnumeration<SearchResult> search(String name,
                                       Attributes matchingAttributes)
                                       throws NamingException
在单个上下文中搜索包含指定属性集的对象。有关详细信息，请参阅 search(Name, Attributes)。

参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性
返回：
SearchResult 对象的枚举
抛出：
NamingException - 如果遇到命名异常

search

NamingEnumeration<SearchResult> search(Name name,
                                       String filter,
                                       SearchControls cons)
                                       throws NamingException
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。

filter 的格式和解释遵从 RFC 2254，其中对 RFC 中提及的 attr 和 value 解释如下。

attr 为属性的标识符。

value 为属性值的字符串表示形式。如何将此字符串表示形式转换为属性值是特定于目录的。

例如，对于声明 "someCount=127"，attr 为 "someCount"，value 为 "127"。提供者根据属性 ID ("someCount")（可能还有其模式）确定属性值是否为整数。然后它适当地解析字符串 "127"。

应该使用适当的 Java (Unicode) 字符表示过滤器字符串中的所有非 ASCII 字符，不能将其编码为 UTF-8 八位组。或者，也可以使用 RFC 2254 中描述的“十六进制编码的反斜杠（backslash-hexcode）”符号。

如果目录不支持部分或全部其属性的字符串表示形式，则可以使用过滤器参数的形式为 Object 的 search 方法。然后，这种目录的服务提供者会将过滤器参数转换为其特定于服务的表示形式，以供过滤器计算使用。请参阅 search(Name, String, Object[], SearchControls)。

RFC 2254 为过滤器定义了某些操作符，包括子字符串匹配、相等性、近似匹配、大于、小于。这些操作符被映射到基础目录中具有相应语义的操作符。例如，对于相等操作符，假定目录具有匹配的规则来定义过滤器中属性的“相等性”。则此规则将用于检查滤器中指定的属性与目录中的对象属性的相等性。类似地，如果目录具有用于排序的匹配规则，则此规则将用于进行“大于”和“小于”比较。

并不是 RFC 2254 中定义的所有操作符都可用于所有属性。当操作符不可用时，抛出异常 InvalidSearchFilterException。

结果返回在 SearchResult 的枚举中。每个 SearchResult 都包含对象名和关于该对象的其他信息（请参阅 SearchResult）。名称或者相对于搜索的目标上下文（由 name 参数命名），或者为 URL 字符串。如果目标上下文包括在枚举（这可能发生在 cons 指定 SearchControls.OBJECT_SCOPE 或 SearchControls.SUBSTREE_SCOPE 的搜索范围时）中，则其名称为空字符串。SearchResult 还可能包含匹配对象的属性，如果 cons 参数指定返回该属性的话。

如果对象不具有请求的属性，则忽略不存在的属性。仅返回那些对象具有的请求的属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但是不允许返回任意的、无关的属性。

另请参阅类描述中的操作属性。

参数：
name - 要搜索的上下文或对象的名称
filter - 要用于搜索的过滤器表达式；不能为 null
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举；永远不为 null
抛出：
InvalidSearchFilterException - 如果基础目录不支持或者不理解指定的搜索过滤器
InvalidSearchControlsException - 如果搜索控件包含无效的设置
NamingException - 如果遇到命名异常
另请参见：
search(Name, String, Object[], SearchControls), SearchControls, SearchResult

search

NamingEnumeration<SearchResult> search(String name,
                                       String filter,
                                       SearchControls cons)
                                       throws NamingException
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。有关详细信息，请参见 search(Name, String, SearchControls)。

参数：
name - 要搜索的上下文或对象的名称
filter - 要用于搜索的过滤器表达式；不能为 null
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举。
抛出：
InvalidSearchFilterException - 如果基础目录不支持或者不理解指定的搜索过滤器
InvalidSearchControlsException - 如果搜索控件包含无效的设置
NamingException - 如果遇到命名异常

search

NamingEnumeration<SearchResult> search(Name name,
                                       String filterExpr,
                                       Object[] filterArgs,
                                       SearchControls cons)
                                       throws NamingException
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。

filterExpr 的解释基于 RFC 2254。它可能还包含形式为 {i}（其中 i 为整数）的变量，这些变量引用 filterArgs 数组中的对象。否则，filterExpr 的解释等同于对方法 search(Name, String, SearchControls) 的 filter 参数的解释。

当变量 {i} 出现在搜索过滤器中时，它指示要在该位置使用过滤器参数 filterArgs[i]。只要生成的 attr、value 或 matchingrule 在 RFC 2254 第 4 节的过滤器语法中出现，这些变量就可以使用。当使用字符串值的过滤器参数替换变量时，过滤器被解释为好像给定了取代变量的字符串，同时根据 RFC 2254 的规则转义了过滤器中具有特殊意义的所有字符（如 '*'）。

对于部分或全部属性不使用的字符串表示形式的目录，对应于属性值的过滤器参数可能是 String 以外的类型。例如，支持非结构化二进制值属性的目录应该接受字节数组作为过滤器参数。任何其他类型的过滤器参数的解释（如果有）由该目录的服务提供者确定，该服务提供者将过滤器操作映射到基础目录中具有相应语义的操作上。

此方法返回结果的枚举。每个枚举元素都包含对象名和关于该对象的其他信息（请参阅 SearchResult）。名称或者相对于搜索的目标上下文（由 name 参数命名），或者为 URL 字符串。如果目标上下文包括在枚举（这可能发生在 cons 指定 SearchControls.OBJECT_SCOPE 或 SearchControls.SUBSTREE_SCOPE 的搜索范围时）中，则其名称为空字符串。

SearchResult 还可能包含匹配对象的属性，如果 cons 参数指定返回该属性的话。

如果对象不具有请求的属性，则忽略不存在的属性。仅返回那些对象具有的请求的属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但是不允许返回任意的、无关的属性。

如果为此方法提供带有无效变量替换项的搜索过滤器，则结果是不确定的。当对此 DirContext 作出更改时，对以前调用此方法返回的枚举的影响是不确定的。

另请参阅类描述中的操作属性。

参数：
name - 要搜索的上下文或对象的名称
filterExpr - 要用于搜索的过滤器表达式。表达式可能包含形式为 "{i}"（其中 i 为非负整数）的变量。不能为 null。
filterArgs - 要替换 filterExpr 中的变量的参数所组成的数组。filterArgs[i] 的值将取代每个出现的 "{i}"。如果为 null，则等效于空数组。
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举；永远不为 null
抛出：
ArrayIndexOutOfBoundsException - 如果 filterExpr 包含 {i} 表达式，其中 i 在数组 filterArgs 的界限之外
InvalidSearchControlsException - 如果 cons 包含无效设置
InvalidSearchFilterException - 如果带有 filterArgs 的 filterExpr 表示无效的搜索过滤器
NamingException - 如果遇到命名异常
另请参见：
search(Name, Attributes, String[]), MessageFormat

search

NamingEnumeration<SearchResult> search(String name,
                                       String filterExpr,
                                       Object[] filterArgs,
                                       SearchControls cons)
                                       throws NamingException
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。有关详细信息，请参见 search(Name, String, Object[], SearchControls)。

参数：
name - 要搜索的上下文或对象的名称。
filterExpr - 要用于搜索的过滤器表达式。表达式可能包含形式为 "{i}"（其中 i 为非负整数）的变量。不能为 null。
filterArgs - 要替换 filterExpr 中的变量的参数所组成的数组。filterArgs[i] 的值将取代每个出现的 "{i}"。如果为 null，则等效于空数组。
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举；永远不为 null
抛出：
ArrayIndexOutOfBoundsException - 如果 filterExpr 包含 {i} 表达式，其中 i 在数组 filterArgs 的界限之外
InvalidSearchControlsException - 如果 cons 包含无效设置
InvalidSearchFilterException - 如果带有 filterArgs 的 filterExpr 表示无效的搜索过滤器
NamingException - 如果遇到命名异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InitialDirContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 InitialDirContext

java.lang.Object
    继承者  javax.naming.InitialContext
        继承者  javax.naming.directory.InitialDirContext
所有已实现的接口：
Context, DirContext
直接已知子类：
InitialLdapContext
public class InitialDirContext
extends InitialContext
implements DirContext

此类是执行目录操作的初始上下文。InitialContext 的类描述中的文档（包括关于同步的那些文档）在此处同样适用。

从以下版本开始：
1.3
另请参见：
InitialContext

字段摘要
从类 javax.naming.InitialContext 继承的字段
defaultInitCtx, gotDefault, myProps
从接口 javax.naming.directory.DirContext 继承的字段
ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE
从接口 javax.naming.Context 继承的字段
APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES
构造方法摘要
 | InitialDirContext() 构造一个初始 DirContext。
protected | InitialDirContext(boolean lazy) 构造一个具有不进行初始化的选项的初始 DirContext。
 | InitialDirContext(Hashtable<?,?> environment) 使用所提供的环境构造一个初始 DirContext。
方法摘要
void | bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | bind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
DirContext | createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
Attributes | getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | getAttributes(String name) 检索所有与命名对象关联的属性。
Attributes | getAttributes(String name, String[] attrIds) 检索与命名对象关联的选定属性。
DirContext | getSchema(Name name) 检索与命名对象关联的模式。
DirContext | getSchema(String name) 检索与命名对象关联的模式。
DirContext | getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | getSchemaClassDefinition(String name) 检索包含命名对象类定义的模式对象的上下文。
void | modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | modifyAttributes(String name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | modifyAttributes(String name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | rebind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
NamingEnumeration<SearchResult> | search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
从类 javax.naming.InitialContext 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, doLookup, doLookup, getDefaultInitCtx, getEnvironment, getNameInNamespace, getNameParser, getNameParser, getURLOrDefaultInitCtx, getURLOrDefaultInitCtx, init, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.naming.Context 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

构造方法详细信息

InitialDirContext

protected InitialDirContext(boolean lazy)
                     throws NamingException
构造一个具有不进行初始化的选项的初始 DirContext。如果子类在调用 InitialDirContext 构造方法时仍然未知环境属性的值，则可以在其中使用此构造方法。子类的构造方法将调用此构造方法，计算环境的值，然后在返回之前调用 init()。

参数：
lazy - 为 true 表示不初始化该初始 DirContext；为 false 等效于调用 new InitialDirContext()
抛出：
NamingException - 如果遇到命名异常
从以下版本开始：
1.3
另请参见：
InitialContext.init(Hashtable)

InitialDirContext

public InitialDirContext()
                  throws NamingException
构造一个初始 DirContext。不提供环境属性。等效于 new InitialDirContext(null)。

抛出：
NamingException - 如果遇到命名异常
另请参见：
InitialDirContext(Hashtable)

InitialDirContext

public InitialDirContext(Hashtable<?,?> environment)
                  throws NamingException
使用所提供的环境构造一个初始 DirContext。环境属性已在 javax.naming.InitialContext 类描述中讨论。

此构造方法不会修改 environment 或保存一个对它的引用，但可能保存一个副本。

参数：
environment - 用于创建初始 DirContext 的环境。null 指示一个空环境。
抛出：
NamingException - 如果遇到命名异常
方法详细信息

getAttributes

public Attributes getAttributes(String name)
                         throws NamingException
从接口 DirContext 复制的描述
检索所有与命名对象关联的属性。有关详细信息，请参阅 DirContext.getAttributes(Name)。

指定者：
接口 DirContext 中的 getAttributes
参数：
name - 对象名，通过该对象名检索属性
返回：
与 name 关联的属性集
抛出：
NamingException - 如果遇到命名异常

getAttributes

public Attributes getAttributes(String name,
                                String[] attrIds)
                         throws NamingException
从接口 DirContext 复制的描述
检索与命名对象关联的选定属性。有关详细信息，请参阅 DirContext.getAttributes(Name, String[])。

指定者：
接口 DirContext 中的 getAttributes
参数：
name - 对象名，通过该对象名检索属性
attrIds - 要检索的属性的标识符。null 指示应该检索所有属性；空数组指示不应检索任何属性。
返回：
请求的属性；永远不为 null
抛出：
NamingException - 如果遇到命名异常

getAttributes

public Attributes getAttributes(Name name)
                         throws NamingException
从接口 DirContext 复制的描述
检索与命名对象关联的所有属性。请参阅关于属性模型、属性类型名称和操作属性的类描述。

指定者：
接口 DirContext 中的 getAttributes
参数：
name - 对象名，通过该对象名检索属性
返回：
与 name 关联的属性集。如果名称没有属性，则返回空属性集；永远不为 null。
抛出：
NamingException - 如果遇到命名异常
另请参见：
DirContext.getAttributes(String), DirContext.getAttributes(Name, String[])

getAttributes

public Attributes getAttributes(Name name,
                                String[] attrIds)
                         throws NamingException
从接口 DirContext 复制的描述
检索与命名对象关联的选定属性。请参阅关于属性模型、属性类型名称和操作属性的类描述。

如果对象没有指定的属性，则目录将忽略不存在的属性，并返回那些对象所具有的请求属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但不允许返回任意的、无关的属性。

另请参阅类描述中的操作属性。

指定者：
接口 DirContext 中的 getAttributes
参数：
name - 对象名，通过该对象名检索属性
attrIds - 要检索的属性的标识符。null 指示应该检索所有属性；空数组指示不应检索任何属性。
返回：
请求的属性；永远不为 null
抛出：
NamingException - 如果遇到命名异常

modifyAttributes

public void modifyAttributes(String name,
                             int mod_op,
                             Attributes attrs)
                      throws NamingException
从接口 DirContext 复制的描述
修改与命名对象关联的属性。有关详细信息，请参阅 DirContext.modifyAttributes(Name, int, Attributes)。

指定者：
接口 DirContext 中的 modifyAttributes
参数：
name - 属性将被更新的对象的名称
mod_op - 修改操作，为以下操作之一：ADD_ATTRIBUTE、REPLACE_ATTRIBUTE 和 REMOVE_ATTRIBUTE。
attrs - 要用于修改的属性；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常

modifyAttributes

public void modifyAttributes(Name name,
                             int mod_op,
                             Attributes attrs)
                      throws NamingException
从接口 DirContext 复制的描述
修改与命名对象关联的属性。没有指定修改的顺序。在可能的情况下，将以原子方式执行修改。

指定者：
接口 DirContext 中的 modifyAttributes
参数：
name - 属性将被更新的对象的名称
mod_op - 修改操作，为以下操作之一：ADD_ATTRIBUTE、REPLACE_ATTRIBUTE 和 REMOVE_ATTRIBUTE。
attrs - 要用于修改的属性；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常
另请参见：
DirContext.modifyAttributes(Name, ModificationItem[])

modifyAttributes

public void modifyAttributes(String name,
                             ModificationItem[] mods)
                      throws NamingException
从接口 DirContext 复制的描述
使用有序的修改列表修改与命名对象关联的属性。有关详细信息，请参阅 DirContext.modifyAttributes(Name, ModificationItem[])。

指定者：
接口 DirContext 中的 modifyAttributes
参数：
name - 属性将被更新的对象的名称
mods - 要执行的修改的有序序列；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常

modifyAttributes

public void modifyAttributes(Name name,
                             ModificationItem[] mods)
                      throws NamingException
从接口 DirContext 复制的描述
使用有序的修改列表修改与命名对象关联的属性。按指定的顺序执行修改。每个修改指定一个修改操作代码和一个对其执行操作的属性。在可能的情况下，将以原子方式执行修改。

指定者：
接口 DirContext 中的 modifyAttributes
参数：
name - 属性将被更新的对象的名称
mods - 要执行的修改的有序序列；不能为 null
抛出：
AttributeModificationException - 如果不能成功完成修改
NamingException - 如果遇到命名异常
另请参见：
DirContext.modifyAttributes(Name, int, Attributes), ModificationItem

bind

public void bind(String name,
                 Object obj,
                 Attributes attrs)
          throws NamingException
从接口 DirContext 复制的描述
将名称与关联的属性一起绑定到一个对象。有关详细信息，请参阅 DirContext.bind(Name, Object, Attributes)。

指定者：
接口 DirContext 中的 bind
参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常

bind

public void bind(Name name,
                 Object obj,
                 Attributes attrs)
          throws NamingException
从接口 DirContext 复制的描述
将名称与关联的属性一起绑定到一个对象。如果 attrs 为 null，则 obj 为 DirContext 时所得绑定将具有与 obj 关联的属性，否则不具有属性。如果 attrs 为非 null，则所得绑定的属性将为 attrs；所有与 obj 关联的属性都将被忽略。

指定者：
接口 DirContext 中的 bind
参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
NameAlreadyBoundException - 如果已经绑定了 name
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常
另请参见：
Context.bind(Name, Object), DirContext.rebind(Name, Object, Attributes)

rebind

public void rebind(String name,
                   Object obj,
                   Attributes attrs)
            throws NamingException
从接口 DirContext 复制的描述
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。有关详细信息，请参阅 DirContext.rebind(Name, Object, Attributes)。

指定者：
接口 DirContext 中的 rebind
参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常

rebind

public void rebind(Name name,
                   Object obj,
                   Attributes attrs)
            throws NamingException
从接口 DirContext 复制的描述
将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。如果 attrs 为 null 且 obj 为 DirContext，则使用 obj 中的属性。如果 attrs 为 null 而 obj 不为 DirContext，则与已经在目录中绑定的对象关联的所有现有属性均保持不变。如果 attrs 为非 null，则移除与已经在目录中绑定的对象关联的所有现有属性，并将 attrs 与命名对象关联起来。如果 obj 为 DirContext 且 attrs 为非 null，则忽略 obj 的属性。

指定者：
接口 DirContext 中的 rebind
参数：
name - 要绑定的名称；不能为空
obj - 要绑定的对象；可能为 null
attrs - 要与绑定关联的属性
抛出：
InvalidAttributesException - 如果没有提供绑定的某些“强制”属性
NamingException - 如果遇到命名异常
另请参见：
Context.bind(Name, Object), DirContext.bind(Name, Object, Attributes)

createSubcontext

public DirContext createSubcontext(String name,
                                   Attributes attrs)
                            throws NamingException
从接口 DirContext 复制的描述
创建并绑定新的上下文及关联的属性。有关详细信息，请参阅 DirContext.createSubcontext(Name, Attributes)。

指定者：
接口 DirContext 中的 createSubcontext
参数：
name - 要创建的上下文的名称；不能为空
attrs - 要与新创建的上下文关联的属性
返回：
新创建的上下文
抛出：
NameAlreadyBoundException - 如果已经绑定了名称
InvalidAttributesException - 如果 attrs 不包含创建所需要的所有强制属性
NamingException - 如果遇到命名异常

createSubcontext

public DirContext createSubcontext(Name name,
                                   Attributes attrs)
                            throws NamingException
从接口 DirContext 复制的描述
创建并绑定新的上下文及关联的属性。此方法利用给定名称创建新的子上下文，将其绑定在目标上下文（由名称最终原子组件外的所有组件命名）中，并将提供的属性与新创建的对象关联起来。所有中间和目标上下文都必须已经存在。如果 attrs 为 null，则此方法等效于 Context.createSubcontext()。

指定者：
接口 DirContext 中的 createSubcontext
参数：
name - 要创建的上下文的名称；不能为空
attrs - 要与新创建的上下文关联的属性
返回：
新创建的上下文
抛出：
NameAlreadyBoundException - 如果已经绑定了名称
InvalidAttributesException - 如果 attrs 不包含创建所需要的所有强制属性
NamingException - 如果遇到命名异常
另请参见：
Context.createSubcontext(Name)

getSchema

public DirContext getSchema(String name)
                     throws NamingException
从接口 DirContext 复制的描述
检索与命名对象关联的模式。有关详细信息，请参阅 DirContext.getSchema(Name)。

指定者：
接口 DirContext 中的 getSchema
参数：
name - 模式要被检索的对象的名称
返回：
与上下文关联的模式；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

getSchema

public DirContext getSchema(Name name)
                     throws NamingException
从接口 DirContext 复制的描述
检索与命名对象关联的模式。模式描述一些关于名称空间的结构及其中所存储属性的规则。模式指定可以被添加到目录中的对象类型、添加对象的位置，以及对象可以具有的强制和可选属性。模式的支持范围是特定于目录的。

此方法返回可用于命名对象的模式信息树的根。多个命名对象（或者甚至整个目录）可以共享同一个模式。

诸如模式树的结构和内容、修改模式树内容的权限以及对目录进行这种修改的效果等问题都与基础目录有关。

指定者：
接口 DirContext 中的 getSchema
参数：
name - 模式要被检索的对象的名称
返回：
与上下文关联的模式；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

getSchemaClassDefinition

public DirContext getSchemaClassDefinition(String name)
                                    throws NamingException
从接口 DirContext 复制的描述
检索包含命名对象类定义的模式对象的上下文。有关详细信息，请参阅 DirContext.getSchemaClassDefinition(Name)。

指定者：
接口 DirContext 中的 getSchemaClassDefinition
参数：
name - 对象类定义要被检索的对象的名称
返回：
包含命名对象的类定义的 DirContext；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

getSchemaClassDefinition

public DirContext getSchemaClassDefinition(Name name)
                                    throws NamingException
从接口 DirContext 复制的描述
检索包含命名对象类定义的模式对象的上下文。

目录模式中存在的一种信息是类定义。“对象类”定义指定对象的类型 和对象必须/可以具有的属性（强制和可选）。注意，这里引用的术语“对象类”是指目录中而不是 Java 中的对象类。例如，如果命名对象是 "Person" 类的目录对象，则 getSchemaClassDefinition() 将返回 DirContext，它表示 "Person" 的（目录）对象类定义。

可以从对象类定义检索的信息与目录有关。

在 JNDI 1.2 之前，此方法返回表示命名对象类定义的单个模式对象。从 JNDI 1.2 开始，此方法返回包含所有命名对象类定义的 DirContext。

指定者：
接口 DirContext 中的 getSchemaClassDefinition
参数：
name - 对象类定义要被检索的对象的名称
返回：
包含命名对象的类定义的 DirContext；永远不为 null
抛出：
OperationNotSupportedException - 如果不支持模式
NamingException - 如果遇到命名异常

search

public NamingEnumeration<SearchResult> search(String name,
                                              Attributes matchingAttributes)
                                       throws NamingException
从接口 DirContext 复制的描述
在单个上下文中搜索包含指定属性集的对象。有关详细信息，请参阅 DirContext.search(Name, Attributes)。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性
返回：
SearchResult 对象的枚举
抛出：
NamingException - 如果遇到命名异常

search

public NamingEnumeration<SearchResult> search(Name name,
                                              Attributes matchingAttributes)
                                       throws NamingException
从接口 DirContext 复制的描述
在单个上下文中搜索包含指定属性集的对象。此方法返回这些对象的所有属性。这等效于向方法 search(Name, Attributes, String[]) 提供 null 作为 atributesToReturn 参数。
有关详细信息，请参阅 DirContext.search(Name, Attributes, String[])。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性
返回：
SearchResult 对象的枚举
抛出：
NamingException - 如果遇到命名异常
另请参见：
DirContext.search(Name, Attributes, String[])

search

public NamingEnumeration<SearchResult> search(String name,
                                              Attributes matchingAttributes,
                                              String[] attributesToReturn)
                                       throws NamingException
从接口 DirContext 复制的描述
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。有关详细信息，请参阅 DirContext.search(Name, Attributes, String[])。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性
attributesToReturn - 要返回的属性
返回：
SearchResult 对象的非 null 枚举
抛出：
NamingException - 如果遇到命名异常

search

public NamingEnumeration<SearchResult> search(Name name,
                                              Attributes matchingAttributes,
                                              String[] attributesToReturn)
                                       throws NamingException
从接口 DirContext 复制的描述
在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。使用默认的 SearchControls 设置进行搜索。

对于要选择的对象，matchingAttributes 中的每个属性都必须与对象的某个属性匹配。如果 matchingAttributes 为空或 null，则返回目标上下文中的所有对象。

如果 matchingAttributes 中的属性 A1 和对象的属性 A2 具有相同的标识符并且 A1 中的每个值都与 A2 的某个值相等，则认为 A1 与 A2 匹配。这意味着值的顺序无关紧要，并且 A2 可以包含 A1 没有的“额外”值，这些值对比较没有影响。它还意味着如果 A1 没有值，则测试是否匹配等效于测试是否存在具有相同标识符的属性 A2。

在比较属性值时使用的“相等性”的精确定义由基础目录服务定义。例如，它可能使用 Object.equals 方法或某种模式来指定不同的相等性操作。对于基于操作而非相等性的匹配（如子字符串比较），需要使用带有过滤器参数的 search 方法。

当对此 DirContext 作出更改时，对以前调用此方法返回的枚举的影响是不确定的。

如果对象没有指定的属性，则目录将忽略不存在的属性，并返回那些对象所具有的请求属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但不允许返回任意的、无关的属性。

另请参阅类描述中的操作属性。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文的名称
matchingAttributes - 要搜索的属性。如果为空或 null，则返回目标上下文中的所有对象。
attributesToReturn - 要返回的属性。null 指示要返回所有属性；空数组指示不返回任何属性。
返回：
SearchResult 对象的非 null 枚举。每个 SearchResult 都包含 attributesToReturn 所标识的属性和相应对象的名称，该名称相对于 name 指定的上下文命名。
抛出：
NamingException - 如果遇到命名异常
另请参见：
SearchControls, SearchResult, DirContext.search(Name, String, Object[], SearchControls)

search

public NamingEnumeration<SearchResult> search(String name,
                                              String filter,
                                              SearchControls cons)
                                       throws NamingException
从接口 DirContext 复制的描述
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。有关详细信息，请参见 DirContext.search(Name, String, SearchControls)。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文或对象的名称
filter - 要用于搜索的过滤器表达式；不能为 null
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举。
抛出：
InvalidSearchFilterException - 如果基础目录不支持或者不理解指定的搜索过滤器
InvalidSearchControlsException - 如果搜索控件包含无效的设置
NamingException - 如果遇到命名异常

search

public NamingEnumeration<SearchResult> search(Name name,
                                              String filter,
                                              SearchControls cons)
                                       throws NamingException
从接口 DirContext 复制的描述
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。

filter 的格式和解释遵从 RFC 2254，其中对 RFC 中提及的 attr 和 value 解释如下。

attr 为属性的标识符。

value 为属性值的字符串表示形式。如何将此字符串表示形式转换为属性值是特定于目录的。

例如，对于声明 "someCount=127"，attr 为 "someCount"，value 为 "127"。提供者根据属性 ID ("someCount")（可能还有其模式）确定属性值是否为整数。然后它适当地解析字符串 "127"。

应该使用适当的 Java (Unicode) 字符表示过滤器字符串中的所有非 ASCII 字符，不能将其编码为 UTF-8 八位组。或者，也可以使用 RFC 2254 中描述的“十六进制编码的反斜杠（backslash-hexcode）”符号。

如果目录不支持部分或全部其属性的字符串表示形式，则可以使用过滤器参数的形式为 Object 的 search 方法。然后，这种目录的服务提供者会将过滤器参数转换为其特定于服务的表示形式，以供过滤器计算使用。请参阅 search(Name, String, Object[], SearchControls)。

RFC 2254 为过滤器定义了某些操作符，包括子字符串匹配、相等性、近似匹配、大于、小于。这些操作符被映射到基础目录中具有相应语义的操作符。例如，对于相等操作符，假定目录具有匹配的规则来定义过滤器中属性的“相等性”。则此规则将用于检查滤器中指定的属性与目录中的对象属性的相等性。类似地，如果目录具有用于排序的匹配规则，则此规则将用于进行“大于”和“小于”比较。

并不是 RFC 2254 中定义的所有操作符都可用于所有属性。当操作符不可用时，抛出异常 InvalidSearchFilterException。

结果返回在 SearchResult 的枚举中。每个 SearchResult 都包含对象名和关于该对象的其他信息（请参阅 SearchResult）。名称或者相对于搜索的目标上下文（由 name 参数命名），或者为 URL 字符串。如果目标上下文包括在枚举（这可能发生在 cons 指定 SearchControls.OBJECT_SCOPE 或 SearchControls.SUBSTREE_SCOPE 的搜索范围时）中，则其名称为空字符串。SearchResult 还可能包含匹配对象的属性，如果 cons 参数指定返回该属性的话。

如果对象不具有请求的属性，则忽略不存在的属性。仅返回那些对象具有的请求的属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但是不允许返回任意的、无关的属性。

另请参阅类描述中的操作属性。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文或对象的名称
filter - 要用于搜索的过滤器表达式；不能为 null
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举；永远不为 null
抛出：
InvalidSearchFilterException - 如果基础目录不支持或者不理解指定的搜索过滤器
InvalidSearchControlsException - 如果搜索控件包含无效的设置
NamingException - 如果遇到命名异常
另请参见：
DirContext.search(Name, String, Object[], SearchControls), SearchControls, SearchResult

search

public NamingEnumeration<SearchResult> search(String name,
                                              String filterExpr,
                                              Object[] filterArgs,
                                              SearchControls cons)
                                       throws NamingException
从接口 DirContext 复制的描述
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。有关详细信息，请参见 DirContext.search(Name, String, Object[], SearchControls)。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文或对象的名称。
filterExpr - 要用于搜索的过滤器表达式。表达式可能包含形式为 "{i}"（其中 i 为非负整数）的变量。不能为 null。
filterArgs - 要替换 filterExpr 中的变量的参数所组成的数组。filterArgs[i] 的值将取代每个出现的 "{i}"。如果为 null，则等效于空数组。
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举；永远不为 null
抛出：
InvalidSearchControlsException - 如果 cons 包含无效设置
InvalidSearchFilterException - 如果带有 filterArgs 的 filterExpr 表示无效的搜索过滤器
NamingException - 如果遇到命名异常

search

public NamingEnumeration<SearchResult> search(Name name,
                                              String filterExpr,
                                              Object[] filterArgs,
                                              SearchControls cons)
                                       throws NamingException
从接口 DirContext 复制的描述
在命名上下文或对象中搜索符合给定搜索过滤器的项。按照搜索控件的指定执行搜索。

filterExpr 的解释基于 RFC 2254。它可能还包含形式为 {i}（其中 i 为整数）的变量，这些变量引用 filterArgs 数组中的对象。否则，filterExpr 的解释等同于对方法 search(Name, String, SearchControls) 的 filter 参数的解释。

当变量 {i} 出现在搜索过滤器中时，它指示要在该位置使用过滤器参数 filterArgs[i]。只要生成的 attr、value 或 matchingrule 在 RFC 2254 第 4 节的过滤器语法中出现，这些变量就可以使用。当使用字符串值的过滤器参数替换变量时，过滤器被解释为好像给定了取代变量的字符串，同时根据 RFC 2254 的规则转义了过滤器中具有特殊意义的所有字符（如 '*'）。

对于部分或全部属性不使用的字符串表示形式的目录，对应于属性值的过滤器参数可能是 String 以外的类型。例如，支持非结构化二进制值属性的目录应该接受字节数组作为过滤器参数。任何其他类型的过滤器参数的解释（如果有）由该目录的服务提供者确定，该服务提供者将过滤器操作映射到基础目录中具有相应语义的操作上。

此方法返回结果的枚举。每个枚举元素都包含对象名和关于该对象的其他信息（请参阅 SearchResult）。名称或者相对于搜索的目标上下文（由 name 参数命名），或者为 URL 字符串。如果目标上下文包括在枚举（这可能发生在 cons 指定 SearchControls.OBJECT_SCOPE 或 SearchControls.SUBSTREE_SCOPE 的搜索范围时）中，则其名称为空字符串。

SearchResult 还可能包含匹配对象的属性，如果 cons 参数指定返回该属性的话。

如果对象不具有请求的属性，则忽略不存在的属性。仅返回那些对象具有的请求的属性。

目录返回的属性可能多于请求（请参阅类描述中的属性类型名称），但是不允许返回任意的、无关的属性。

如果为此方法提供带有无效变量替换项的搜索过滤器，则结果是不确定的。当对此 DirContext 作出更改时，对以前调用此方法返回的枚举的影响是不确定的。

另请参阅类描述中的操作属性。

指定者：
接口 DirContext 中的 search
参数：
name - 要搜索的上下文或对象的名称
filterExpr - 要用于搜索的过滤器表达式。表达式可能包含形式为 "{i}"（其中 i 为非负整数）的变量。不能为 null。
filterArgs - 要替换 filterExpr 中的变量的参数所组成的数组。filterArgs[i] 的值将取代每个出现的 "{i}"。如果为 null，则等效于空数组。
cons - 控制搜索的搜索控件。如果为 null，则使用默认的搜索控件（等效于 (new SearchControls())）。
返回：
符合过滤器的对象的 SearchResult 所组成的枚举；永远不为 null
抛出：
InvalidSearchControlsException - 如果 cons 包含无效设置
InvalidSearchFilterException - 如果带有 filterArgs 的 filterExpr 表示无效的搜索过滤器
NamingException - 如果遇到命名异常
另请参见：
DirContext.search(Name, Attributes, String[]), MessageFormat
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidAttributeIdentifierException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 InvalidAttributeIdentifierException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.InvalidAttributeIdentifierException
所有已实现的接口：
Serializable
public class InvalidAttributeIdentifierException
extends NamingException

在试图用无效的属性标识符创建属性时，抛出此异常。属性标识符的有效性与目录有关。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InvalidAttributeIdentifierException()
构造一个新的 InvalidAttributeIdentifierException 实例。
InvalidAttributeIdentifierException(String explanation)
使用所提供的解释构造一个新的 InvalidAttributeIdentifierException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidAttributeIdentifierException

public InvalidAttributeIdentifierException(String explanation)
使用所提供的解释构造一个新的 InvalidAttributeIdentifierException 实例。将其他所有字段都设置为 null。

参数：
explanation - 一个可能为 null 的字符串，包含有关此异常的附加详细信息。
另请参见：
Throwable.getMessage()

InvalidAttributeIdentifierException

public InvalidAttributeIdentifierException()
构造一个新的 InvalidAttributeIdentifierException 实例。将所有字段都设置为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidAttributesException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 InvalidAttributesException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.InvalidAttributesException
所有已实现的接口：
Serializable
public class InvalidAttributesException
extends NamingException

在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。例如，在尝试添加或修改一个绑定，或者创建新的子上下文而未指定创建对象所需的全部强制属性时，可能发生此情况。另一种抛出此异常的情况是，在同一个属性集中指定了相互不兼容的属性，或者指定的属性与对象模式指定的属性有冲突。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InvalidAttributesException()
构造一个新的 InvalidAttributesException 实例。
InvalidAttributesException(String explanation)
使用解释构造一个新的 InvalidAttributesException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidAttributesException

public InvalidAttributesException(String explanation)
使用解释构造一个新的 InvalidAttributesException 实例。将所有其他字段都设置为 null。

参数：
explanation - 有关此异常的附加详细信息。可以为 null。
另请参见：
Throwable.getMessage()

InvalidAttributesException

public InvalidAttributesException()
构造一个新的 InvalidAttributesException 实例。将所有字段都设置为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidAttributeValueException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 InvalidAttributeValueException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.InvalidAttributeValueException
所有已实现的接口：
Serializable
public class InvalidAttributeValueException
extends NamingException

在尝试添加一个与属性的模式定义有冲突的属性时，抛出此类。例如，如果要求属性至少具有一个值时尝试添加没有值的属性、尝试将一个以上的值添加到单值属性中，或者尝试添加与属性语法有冲突的值时，可能发生此情况。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InvalidAttributeValueException()
构造一个新的 InvalidAttributeValueException 实例。
InvalidAttributeValueException(String explanation)
使用解释构造一个新的 InvalidAttributeValueException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidAttributeValueException

public InvalidAttributeValueException(String explanation)
使用解释构造一个新的 InvalidAttributeValueException 实例。将所有其他字段都设置为 null。

参数：
explanation - 有关此异常的附加详细信息。可以为 null。
另请参见：
Throwable.getMessage()

InvalidAttributeValueException

public InvalidAttributeValueException()
构造一个新的 InvalidAttributeValueException 实例。将所有字段都设置为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidSearchControlsException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 InvalidSearchControlsException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.InvalidSearchControlsException
所有已实现的接口：
Serializable
public class InvalidSearchControlsException
extends NamingException

在为搜索操作指定的 SearchControls 无效时，抛出此异常。例如，如果将作用域设置为 OBJECT_SCOPE、ONELEVEL_SCOPE、SUBTREE_SCOPE 以外的值，则抛出此异常。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InvalidSearchControlsException()
构造一个新的 InvalidSearchControlsException 实例。
InvalidSearchControlsException(String msg)
使用解释构造一个新的 InvalidSearchControlsException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidSearchControlsException

public InvalidSearchControlsException()
构造一个新的 InvalidSearchControlsException 实例。所有字段都被设置为 null。

InvalidSearchControlsException

public InvalidSearchControlsException(String msg)
使用解释构造一个新的 InvalidSearchControlsException 实例。将其他所有字段都设置为 null。

参数：
msg - 关于此异常的详细信息。可以为 null。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidSearchFilterException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 InvalidSearchFilterException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.InvalidSearchFilterException
所有已实现的接口：
Serializable
public class InvalidSearchFilterException
extends NamingException

当指定的搜索过滤器无效时，抛出此异常。过滤器的表达式可能无效，或者传递给过滤器的参数之一可能存在问题。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
InvalidSearchFilterException()
构造一个新的 InvalidSearchFilterException 实例。
InvalidSearchFilterException(String msg)
使用解释构造一个新的 InvalidSearchFilterException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidSearchFilterException

public InvalidSearchFilterException()
构造一个新的 InvalidSearchFilterException 实例。所有字段都被设置为 null。

InvalidSearchFilterException

public InvalidSearchFilterException(String msg)
使用解释构造一个新的 InvalidSearchFilterException 实例。所有其他字段都被设置为 null。

参数：
msg - 关于此异常的详细信息。可以为 null。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ModificationItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 ModificationItem

java.lang.Object
    继承者  javax.naming.directory.ModificationItem
所有已实现的接口：
Serializable
public class ModificationItem
extends Object
implements Serializable

此类表示修改项。它由修改代码和要执行操作的属性组成。

ModificationItem 实例与并发多线程访问不同步。试图访问和修改单个 ModificationItem 实例的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
序列化表格

构造方法摘要
ModificationItem(int mod_op, Attribute attr)
创建一个新的 ModificationItem 实例。
方法摘要
Attribute | getAttribute() 检索与此修改项关联的属性。
int | getModificationOp() 检索此修改项的修改代码。
String | toString() 生成此修改项的字符串表示形式，该表示形式由修改操作及其相关属性组成。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ModificationItem

public ModificationItem(int mod_op,
                        Attribute attr)
创建一个新的 ModificationItem 实例。

参数：
mod_op - 要应用的修改。它必须是以下值之一：DirContext.ADD_ATTRIBUTE DirContext.REPLACE_ATTRIBUTE DirContext.REMOVE_ATTRIBUTE
attr - 用于修改的非 null 属性。
抛出：
IllegalArgumentException - 如果 attr 为 null，或者 mod_op 不是上面指定的值之一。
方法详细信息

getModificationOp

public int getModificationOp()
检索此修改项的修改代码。

返回：
修改代码。它是以下值之一：DirContext.ADD_ATTRIBUTE DirContext.REPLACE_ATTRIBUTE DirContext.REMOVE_ATTRIBUTE

getAttribute

public Attribute getAttribute()
检索与此修改项关联的属性。

返回：
用于修改的非 null 属性。

toString

public String toString()
生成此修改项的字符串表示形式，该表示形式由修改操作及其相关属性组成。该字符串表示形式用于调试，不以编程方式进行解释。

覆盖：
类 Object 中的 toString
返回：
此修改项的非 null 字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NoSuchAttributeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 NoSuchAttributeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.NoSuchAttributeException
所有已实现的接口：
Serializable
public class NoSuchAttributeException
extends NamingException

尝试访问不存在的属性时，抛出此异常。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
NoSuchAttributeException()
构造一个新的 NoSuchAttributeException 实例。
NoSuchAttributeException(String explanation)
使用解释构造一个新的 NoSuchAttributeException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NoSuchAttributeException

public NoSuchAttributeException(String explanation)
使用解释构造一个新的 NoSuchAttributeException 实例。所有其他字段都被设置为 null。

参数：
explanation - 有关此异常的附加详细信息。可以为 null。
另请参见：
Throwable.getMessage()

NoSuchAttributeException

public NoSuchAttributeException()
构造一个新的 NoSuchAttributeException 实例。所有字段都被初始化为 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SchemaViolationException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 SchemaViolationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.directory.SchemaViolationException
所有已实现的接口：
Serializable
public class SchemaViolationException
extends NamingException

当方法在某些方面违反模式时，抛出此异常。修改违反对象模式定义的对象属性就是一个违反模式的示例。另一个示例是，将对象重命名或移动到违反名称空间模式定义的名称空间部分。

应用于 NamingException 的同步和序列化问题在这里可以直接应用。

从以下版本开始：
1.3
另请参见：
Context.bind(javax.naming.Name, java.lang.Object),
DirContext.bind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
Context.rebind(javax.naming.Name, java.lang.Object),
DirContext.rebind(javax.naming.Name, java.lang.Object, javax.naming.directory.Attributes),
DirContext.createSubcontext(javax.naming.Name, javax.naming.directory.Attributes),
Context.createSubcontext(javax.naming.Name),
DirContext.modifyAttributes(javax.naming.Name, int, javax.naming.directory.Attributes),
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
SchemaViolationException()
构造一个新的 SchemaViolationException 实例。
SchemaViolationException(String explanation)
使用所提供的解释构造一个新的 SchemaViolationException 实例。
方法摘要
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SchemaViolationException

public SchemaViolationException()
构造一个新的 SchemaViolationException 实例。将所有字段都设置为 null。

SchemaViolationException

public SchemaViolationException(String explanation)
使用所提供的解释构造一个新的 SchemaViolationException 实例。将所有其他字段都设置为 null。

参数：
explanation - 关于此异常的详细信息。可以为 null。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SearchControls (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 SearchControls

java.lang.Object
    继承者  javax.naming.directory.SearchControls
所有已实现的接口：
Serializable
public class SearchControls
extends Object
implements Serializable

此类封装确定搜索范围和搜索返回结果的因子。

SearchControls 实例与并发多线程访问不同步。试图访问和修改单个 SearchControls 实例的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
static int | OBJECT_SCOPE 搜索命名的对象。
static int | ONELEVEL_SCOPE 搜索一级命名对象。
static int | SUBTREE_SCOPE 搜索以命名对象为根的整个子树。
构造方法摘要
SearchControls()
使用默认值构造搜索约束。
SearchControls(int scope, long countlim, int timelim, String[] attrs, boolean retobj, boolean deref)
使用参数构造搜索约束。
方法摘要
long | getCountLimit() 检索将作为搜索结果返回的最大项数。
boolean | getDerefLinkFlag() 确定在搜索期间是否将取消对链接的引用。
String[] | getReturningAttributes() 检索将作为搜索的一部分返回的属性。
boolean | getReturningObjFlag() 确定对象是否将作为结果的一部分返回。
int | getSearchScope() 检索这些 SearchControls 的搜索范围。
int | getTimeLimit() 检索这些 SearchControls 以毫秒为单位的时间限制。
void | setCountLimit(long limit) 设置要作为搜索结果返回的最大项数。
void | setDerefLinkFlag(boolean on) 启用/禁用在搜索期间取消对链接的引用。
void | setReturningAttributes(String[] attrs) 指定将作为搜索的一部分返回的属性。
void | setReturningObjFlag(boolean on) 启用/禁用作为结果的一部分返回所返回对象。
void | setSearchScope(int scope) 将搜索范围设置为以下值之一：OBJECT_SCOPE、ONELEVEL_SCOPE 和 SUBTREE_SCOPE。
void | setTimeLimit(int ms) 设置这些 SearchControls 以毫秒为单位的时间限制。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OBJECT_SCOPE

public static final int OBJECT_SCOPE
搜索命名的对象。

从使用 OBJECT_SCOPE 的 search() 中得到的 NamingEnumeration 将包含一个或零个元素。如果命名的对象符合 search() 中指定的搜索过滤器，则枚举包含一个元素。元素中的名称将是一个空字符串，因为 NamingEnumeration 中的元素名称是相对于目标上下文的，在此情况下，目标上下文就是命名的对象。如果命名对象不符合 search() 中指定的搜索过滤器，则其包含零个元素。

此常量的值为 0。

另请参见：
常量字段值

ONELEVEL_SCOPE

public static final int ONELEVEL_SCOPE
搜索一级命名对象。

从使用 ONELEVEL_SCOPE 的 search() 中得到的 NamingEnumeration 包含的元素是命名上下文中的对象，这些对象符合 search() 中指定的搜索过滤器。NamingEnumeration 中的元素名称是相对于命名上下文的原子名称。

此常量的值为 1。

另请参见：
常量字段值

SUBTREE_SCOPE

public static final int SUBTREE_SCOPE
搜索以命名对象为根的整个子树。

如果命名对象不是 DirContext，则仅搜索该对象。如果命名对象不是 DirContext，则搜索以命名对象为根的子树，包括命名对象本身。

搜索将不超出命名系统的界限。

从使用 SUBTREE_SCOPE 的 search() 中得到的 NamingEnumeration 包含的元素是子树（包括命名上下文）中的对象，这些对象符合 search() 中指定的搜索过滤器的。NamingEnumeration 中的元素名称或者相对于命名上下文或者为 URL 字符串。如果命名上下文符合搜索过滤器，则它包含在以空字符串作为其名称的枚举中。

此常量的值为 2。

另请参见：
常量字段值
构造方法详细信息

SearchControls

public SearchControls()
使用默认值构造搜索约束。

默认值为：

  • 搜索一级
  • 搜索结果不存在最大返回数限制
  • 搜索不存在时间限制
  • 返回所有符合搜索过滤器的与对象关联的属性
  • 不返回命名对象（仅返回名称和类）
  • 在搜索期间不取消对链接的引用

SearchControls

public SearchControls(int scope,
                      long countlim,
                      int timelim,
                      String[] attrs,
                      boolean retobj,
                      boolean deref)
使用参数构造搜索约束。

参数：
scope - 搜索范围。为以下值之一：OBJECT_SCOPE、ONELEVEL_SCOPE 和 SUBTREE_SCOPE。
timelim - 返回前要等待的毫秒数。如果为 0，则无限期地等待。
deref - 如果为 true，则在搜索期间取消对链接的引用。
countlim - 要返回的最大项数。如果为 0，则返回符合过滤器的所有项。
retobj - 如果为 true，则返回绑定到项名称的对象；如果为 false，则不返回对象。
attrs - 要与项一起返回的属性的标识符。如果为 null，则返回所有属性。如果为空，则不返回任何属性。
方法详细信息

getSearchScope

public int getSearchScope()
检索这些 SearchControls 的搜索范围。

OBJECT_SCOPE、ONELEVEL_SCOPE 或 SUBTREE_SCOPE 之一。

返回：
此 SearchControls 的搜索范围。
另请参见：
setSearchScope(int)

getTimeLimit

public int getTimeLimit()
检索这些 SearchControls 以毫秒为单位的时间限制。

如果值为 0，则其意味着无限期地等待。

返回：
这些 SearchControls 以毫秒为单位的时间限制。
另请参见：
setTimeLimit(int)

getDerefLinkFlag

public boolean getDerefLinkFlag()
确定在搜索期间是否将取消对链接的引用。

返回：
如果将取消对链接的引用，则返回 true；否则返回 false。
另请参见：
setDerefLinkFlag(boolean)

getReturningObjFlag

public boolean getReturningObjFlag()
确定对象是否将作为结果的一部分返回。

返回：
如果返回对象，则返回 true；否则返回 false。
另请参见：
setReturningObjFlag(boolean)

getCountLimit

public long getCountLimit()
检索将作为搜索结果返回的最大项数。

0 指示将返回所有项。

返回：
将返回的最大项数。
另请参见：
setCountLimit(long)

getReturningAttributes

public String[] getReturningAttributes()
检索将作为搜索的一部分返回的属性。

值 null 指示将返回所有属性。空数组指示不返回任何属性。

返回：
标识将返回的属性的属性 id 所组成的数组。可以为 null。
另请参见：
setReturningAttributes(java.lang.String[])

setSearchScope

public void setSearchScope(int scope)
将搜索范围设置为以下值之一：OBJECT_SCOPE、ONELEVEL_SCOPE 和 SUBTREE_SCOPE。

参数：
scope - 此 SearchControls 的搜索范围。
另请参见：
getSearchScope()

setTimeLimit

public void setTimeLimit(int ms)
设置这些 SearchControls 以毫秒为单位的时间限制。

如果值为 0，则其意味着无限期地等待。

参数：
ms - 这些 SearchControls 以毫秒为单位的时间限制。
另请参见：
getTimeLimit()

setDerefLinkFlag

public void setDerefLinkFlag(boolean on)
启用/禁用在搜索期间取消对链接的引用。

参数：
on - 如果为 true，则取消对链接的引用；如果为 false，则不取消。
另请参见：
getDerefLinkFlag()

setReturningObjFlag

public void setReturningObjFlag(boolean on)
启用/禁用作为结果的一部分返回所返回对象。

如果禁用，则仅返回对象的名称和类。如果启用，则返回对象。

参数：
on - 如果为 true，则返回对象；如果为 false，则不返回对象。
另请参见：
getReturningObjFlag()

setCountLimit

public void setCountLimit(long limit)
设置要作为搜索结果返回的最大项数。

0 指示没有任何限制：将返回所有项。

参数：
limit - 将返回的最大项数。
另请参见：
getCountLimit()

setReturningAttributes

public void setReturningAttributes(String[] attrs)
指定将作为搜索的一部分返回的属性。

null 指示将返回所有属性。空数组指示不返回任何属性。

参数：
attrs - 标识将返回的属性的属性 id 所组成的数组。可以为 null。
另请参见：
getReturningAttributes()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SearchResult (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.directory
类 SearchResult

java.lang.Object
    继承者  javax.naming.NameClassPair
        继承者  javax.naming.Binding
            继承者  javax.naming.directory.SearchResult
所有已实现的接口：
Serializable
public class SearchResult
extends Binding

此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

SearchResult 实例与并发多线程访问不同步。试图访问和修改单个 SearchResult 实例的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
DirContext.search(javax.naming.Name, javax.naming.directory.Attributes, java.lang.String[]), 序列化表格

构造方法摘要
SearchResult(String name, Object obj, Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
SearchResult(String name, String className, Object obj, Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
方法摘要
Attributes | getAttributes() 检索此搜索结果中的属性。
void | setAttributes(Attributes attrs) 将此搜索结果的属性设置为 attrs。
String | toString() 生成此 SearchResult 的字符串表示形式。
从类 javax.naming.Binding 继承的方法
getClassName, getObject, setObject
从类 javax.naming.NameClassPair 继承的方法
getName, getNameInNamespace, isRelative, setClassName, setName, setNameInNamespace, setRelative
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SearchResult

public SearchResult(String name,
                    Object obj,
                    Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。

如果还没有使用 setClassName() 显式设置类名称，则 getClassName() 将返回 obj 的类名称（或者 null，如果 obj 为 null）。

参数：
name - 搜索项的非 null 名称。它是相对于搜索的目标上下文（由 search() 方法的第一个参数指定）的名称
obj - 绑定到名称的对象。可以为 null。
attrs - 请求与此搜索项一起返回的属性。不能为 null。
另请参见：
NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()

SearchResult

public SearchResult(String name,
                    Object obj,
                    Attributes attrs,
                    boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

如果还没有使用 setClassName() 显式设置类名称，则 getClassName() 将返回 obj 的类名称（或者 null，如果 obj 为 null）

参数：
name - 搜索项的非 null 名称。
obj - 绑定到名称的对象。可以为 null。
attrs - 请求与此搜索项一起返回的属性。不能为 null。
isRelative - 如果 name 是一个相对于搜索的目标上下文（由 search() 方法的第一个参数命名）的名称，则该参数为 true；如果 name 是一个 URL 字符串，则该参数为 false。
另请参见：
NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()

SearchResult

public SearchResult(String name,
                    String className,
                    Object obj,
                    Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。

参数：
name - 搜索项的非 null 名称。它是相对于搜索的目标上下文（由 search() 方法的第一个参数命名）的名称
className - 绑定到 name 的对象的类名称（可能为 null）。如果为 null，则 obj 的类名称由 getClassName() 返回。如果 obj 也为 null，则 getClassName() 将返回 null。
obj - 绑定到名称的对象。可以为 null。
attrs - 请求与此搜索项一起返回的属性。不能为 null。
另请参见：
NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()

SearchResult

public SearchResult(String name,
                    String className,
                    Object obj,
                    Attributes attrs,
                    boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

参数：
name - 搜索项的非 null 名称。
className - 绑定到 name 的对象的类名称（可能为 null）。如果为 null，则 obj 的类名称由 getClassName() 返回。如果 obj 也为 null，则 getClassName() 将返回 null。
obj - 绑定到名称的对象。可以为 null。
attrs - 请求与此搜索项一起返回的属性。不能为 null。
isRelative - 如果 name 是一个相对于搜索的目标上下文（由 search() 方法的第一个参数命名）的名称，则该参数为 true；如果 name 是一个 URL 字符串，则该参数为 false。
另请参见：
NameClassPair.setClassName(java.lang.String), NameClassPair.getClassName()
方法详细信息

getAttributes

public Attributes getAttributes()
检索此搜索结果中的属性。

返回：
此搜索结果中的非 null 属性。可以为空。
另请参见：
setAttributes(javax.naming.directory.Attributes)

setAttributes

public void setAttributes(Attributes attrs)
将此搜索结果的属性设置为 attrs。

参数：
attrs - 要使用的非 null 属性。可以为空。
另请参见：
getAttributes()

toString

public String toString()
生成此 SearchResult 的字符串表示形式。该字符串表示形式由绑定的字符串表示形式和此搜索结果属性的字符串表示形式组成，两个表示形式之间用 ':' 分隔。此字符串的内容用于调试目的，不以编程方式对其进行解释。

覆盖：
类 Binding 中的 toString
返回：
此 SearchResult 的字符串表示形式。不能为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.naming.directory (Java 2 Platform SE 6)

 javax.naming.directory
接口
Attribute
Attributes
DirContext
类
BasicAttribute
BasicAttributes
InitialDirContext
ModificationItem
SearchControls
SearchResult
异常
AttributeInUseException
AttributeModificationException
InvalidAttributeIdentifierException
InvalidAttributesException
InvalidAttributeValueException
InvalidSearchControlsException
InvalidSearchFilterException
NoSuchAttributeException
SchemaViolationException


javax.naming.directory (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.naming.directory

扩展 javax.naming 包以提供访问目录服务的功能。

请参见：
描述

接口摘要
Attribute | 此接口表示与命名对象关联的属性。
Attributes | 此接口表示属性的集合。
DirContext | 目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。

类摘要
BasicAttribute | 此类提供 Attribute 接口的基本实现。
BasicAttributes | 此类提供 Attributes 接口的基本实现。
InitialDirContext | 此类是执行目录操作的初始上下文。
ModificationItem | 此类表示修改项。
SearchControls | 此类封装确定搜索范围和搜索返回结果的因子。
SearchResult | 此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

异常摘要
AttributeInUseException | 当操作试图添加已经存在的属性时抛出此异常。
AttributeModificationException | 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
InvalidAttributeIdentifierException | 在试图用无效的属性标识符创建属性时，抛出此异常。
InvalidAttributesException | 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
InvalidAttributeValueException | 在尝试添加一个与属性的模式定义有冲突的属性时，抛出此类。
InvalidSearchControlsException | 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
InvalidSearchFilterException | 当指定的搜索过滤器无效时，抛出此异常。
NoSuchAttributeException | 尝试访问不存在的属性时，抛出此异常。
SchemaViolationException | 当方法在某些方面违反模式时，抛出此异常。

软件包 javax.naming.directory 的描述

扩展 javax.naming 包以提供访问目录服务的功能。

此包定义 Java Naming and Directory InterfaceTM (JNDI) 的目录操作。 JNDI 向使用 Java 编程语言编写的应用程序提供命名和目录功能。它被设计成与任何特定的命名或目录服务实现无关。因此可以使用共同的方式对多种服务（新的、新出现的及已经部署的服务）进行访问。

此包允许应用程序检索和更新与存储在目录中的对象关联的属性，以及使用指定属性搜索对象。

目录上下文

DirContext 接口表示目录上下文。该接口定义了一些方法来检验和更新与目录对象（有时称为目录项）关联的属性。

可以使用 getAttributes() 检索与目录对象（为其提供名称）关联的属性。使用 modifyAttributes() 修改属性。使用此操作可以添加、替换或移除属性和/或属性值。

通过扩展 javax.naming 包中的 Context 接口，DirContext 还可以用作命名上下文。这意味着所有目录对象也都可以提供命名上下文。例如，某个人的目录对象可能包含该人的属性，同时提供与该人相关的命名对象（如他的打印机和住宅目录）的上下文。

搜索

DirContext 包含一些对目录执行基于内容的搜索的方法。最简单和最普通的用法是，应用程序指定一属性集（可能带有特定值）来匹配 search() 方法，并将此属性集提交给该方法。也有其他重载形式的 search()，可支持更复杂的搜索过滤器。

包规范

JNDI API 规范及相关文档可在 JNDI documentation 中找到。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.naming.directory 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.directory 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.naming.directory.BasicAttribute (implements javax.naming.directory.Attribute)
    • javax.naming.directory.BasicAttributes (implements javax.naming.directory.Attributes)
    • javax.naming.InitialContext (implements javax.naming.Context)
      • javax.naming.directory.InitialDirContext (implements javax.naming.directory.DirContext)
    • javax.naming.directory.ModificationItem (implements java.io.Serializable)
    • javax.naming.NameClassPair (implements java.io.Serializable)
      • javax.naming.Binding
        • javax.naming.directory.SearchResult
    • javax.naming.directory.SearchControls (implements java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.directory.AttributeInUseException
          • javax.naming.directory.AttributeModificationException
          • javax.naming.directory.InvalidAttributeIdentifierException
          • javax.naming.directory.InvalidAttributesException
          • javax.naming.directory.InvalidAttributeValueException
          • javax.naming.directory.InvalidSearchControlsException
          • javax.naming.directory.InvalidSearchFilterException
          • javax.naming.directory.NoSuchAttributeException
          • javax.naming.directory.SchemaViolationException

接口分层结构

  • java.lang.Cloneable
    • javax.naming.directory.Attribute (并 extends java.io.Serializable)
    • javax.naming.directory.Attributes (并 extends java.io.Serializable)
  • javax.naming.Context
    • javax.naming.directory.DirContext
  • java.io.Serializable
    • javax.naming.directory.Attribute (并 extends java.lang.Cloneable)
    • javax.naming.directory.Attributes (并 extends java.lang.Cloneable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.naming.directory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.directory
的使用

使用 javax.naming.directory 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.directory 使用的 javax.naming.directory 中的类
Attribute
此接口表示与命名对象关联的属性。
Attributes
此接口表示属性的集合。
DirContext
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。
ModificationItem
此类表示修改项。
SearchControls
此类封装确定搜索范围和搜索返回结果的因子。
SearchResult
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

javax.naming.event 使用的 javax.naming.directory 中的类
DirContext
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。
SearchControls
此类封装确定搜索范围和搜索返回结果的因子。

javax.naming.ldap 使用的 javax.naming.directory 中的类
Attributes
此接口表示属性的集合。
DirContext
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。
InitialDirContext
此类是执行目录操作的初始上下文。

javax.naming.spi 使用的 javax.naming.directory 中的类
Attributes
此接口表示属性的集合。
DirContext
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.directory.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.directory.Attribute
的使用

使用 Attribute 的软件包
javax.naming.directory 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.directory 中 Attribute 的使用

实现 Attribute 的 javax.naming.directory 中的类
 class BasicAttribute
此类提供 Attribute 接口的基本实现。

返回 Attribute 的 javax.naming.directory 中的方法
Attribute | Attributes.get(String attrID) 利用属性集中的给定属性 id 检索属性。
Attribute | BasicAttributes.get(String attrID)
Attribute | ModificationItem.getAttribute() 检索与此修改项关联的属性。
Attribute | Attributes.put(Attribute attr) 向属性集中添加新属性。
Attribute | BasicAttributes.put(Attribute attr)
Attribute | Attributes.put(String attrID, Object val) 向属性集中添加新属性。
Attribute | BasicAttributes.put(String attrID, Object val)
Attribute | Attributes.remove(String attrID) 从属性集中移除属性 id 为 'attrID' 的属性。
Attribute | BasicAttributes.remove(String attrID)

返回变量类型为 Attribute 的类型的 javax.naming.directory 中的方法
NamingEnumeration<? extends Attribute> | Attributes.getAll() 检索属性集中属性的枚举。
NamingEnumeration<Attribute> | BasicAttributes.getAll()

参数类型为 Attribute 的 javax.naming.directory 中的方法
Attribute | Attributes.put(Attribute attr) 向属性集中添加新属性。
Attribute | BasicAttributes.put(Attribute attr)

参数类型为 Attribute 的 javax.naming.directory 中的构造方法
ModificationItem(int mod_op, Attribute attr)
创建一个新的 ModificationItem 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.AttributeInUseException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.AttributeInUseException
的使用

没有 javax.naming.directory.AttributeInUseException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.AttributeModificationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.AttributeModificationException
的使用

没有 javax.naming.directory.AttributeModificationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.directory.Attributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.directory.Attributes
的使用

使用 Attributes 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.directory 中 Attributes 的使用

实现 Attributes 的 javax.naming.directory 中的类
 class BasicAttributes
此类提供 Attributes 接口的基本实现。

返回 Attributes 的 javax.naming.directory 中的方法
Attributes | SearchResult.getAttributes() 检索此搜索结果中的属性。
Attributes | DirContext.getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | InitialDirContext.getAttributes(Name name)
Attributes | DirContext.getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
Attributes | DirContext.getAttributes(String name) 检索所有与命名对象关联的属性。
Attributes | InitialDirContext.getAttributes(String name)
Attributes | DirContext.getAttributes(String name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(String name, String[] attrIds)

参数类型为 Attributes 的 javax.naming.directory 中的方法
void | DirContext.bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
void | DirContext.bind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(String name, Object obj, Attributes attrs)
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
DirContext | DirContext.createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
void | DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(String name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
void | DirContext.rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
void | DirContext.rebind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(String name, Object obj, Attributes attrs)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
void | SearchResult.setAttributes(Attributes attrs) 将此搜索结果的属性设置为 attrs。

参数类型为 Attributes 的 javax.naming.directory 中的构造方法
SearchResult(String name, Object obj, Attributes attrs)
使用结果的名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String name, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。
SearchResult(String name, String className, Object obj, Attributes attrs)
使用结果的名称、类名称、绑定对象及其属性构造一个搜索结果。
SearchResult(String name, String className, Object obj, Attributes attrs, boolean isRelative)
使用结果的名称、类名称、绑定对象、属性以及该名称是否是相对的构造一个搜索结果。

javax.naming.ldap 中 Attributes 的使用

返回 Attributes 的 javax.naming.ldap 中的方法
 Attributes Rdn.toAttributes()
检索此 Rdn 中包含的类型/值映射关系的 Attributes 视图。

参数类型为 Attributes 的 javax.naming.ldap 中的构造方法
Rdn(Attributes attrSet)
根据给定属性集构造 Rdn。

javax.naming.spi 中 Attributes 的使用

返回 Attributes 的 javax.naming.spi 中的方法
 Attributes DirStateFactory.Result.getAttributes()
检索要绑定的属性。

参数类型为 Attributes 的 javax.naming.spi 中的方法
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。

参数类型为 Attributes 的 javax.naming.spi 中的构造方法
DirStateFactory.Result(Object obj, Attributes outAttrs)
构造一个 Result 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.BasicAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.BasicAttribute
的使用

没有 javax.naming.directory.BasicAttribute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.BasicAttributes 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.BasicAttributes
的使用

没有 javax.naming.directory.BasicAttributes 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.directory.DirContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.directory.DirContext
的使用

使用 DirContext 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.directory 中 DirContext 的使用

实现 DirContext 的 javax.naming.directory 中的类
 class InitialDirContext
此类是执行目录操作的初始上下文。

返回 DirContext 的 javax.naming.directory 中的方法
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
DirContext | DirContext.createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
DirContext | Attribute.getAttributeDefinition() 检索属性的模式定义。
DirContext | BasicAttribute.getAttributeDefinition() 检索此属性的模式定义。
DirContext | Attribute.getAttributeSyntaxDefinition() 检索与属性关联的语法定义。
DirContext | BasicAttribute.getAttributeSyntaxDefinition() 检索与此属性关联的语法定义。
DirContext | DirContext.getSchema(Name name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(Name name)
DirContext | DirContext.getSchema(String name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(String name)
DirContext | DirContext.getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
DirContext | DirContext.getSchemaClassDefinition(String name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(String name)

javax.naming.event 中 DirContext 的使用

javax.naming.event 中 DirContext 的子接口
 interface EventDirContext
包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。

javax.naming.ldap 中 DirContext 的使用

javax.naming.ldap 中 DirContext 的子接口
 interface LdapContext
此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。

实现 DirContext 的 javax.naming.ldap 中的类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

javax.naming.spi 中 DirContext 的使用

返回 DirContext 的 javax.naming.spi 中的方法
static DirContext DirectoryManager.getContinuationDirContext(CannotProceedException cpe)
创建一个将继续某个 DirContext 操作的上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.InitialDirContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InitialDirContext
的使用

使用 InitialDirContext 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 InitialDirContext 的使用

javax.naming.ldap 中 InitialDirContext 的子类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.InvalidAttributeIdentifierException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidAttributeIdentifierException
的使用

没有 javax.naming.directory.InvalidAttributeIdentifierException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.InvalidAttributeValueException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidAttributeValueException
的使用

没有 javax.naming.directory.InvalidAttributeValueException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.InvalidAttributesException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidAttributesException
的使用

没有 javax.naming.directory.InvalidAttributesException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.InvalidSearchControlsException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidSearchControlsException
的使用

没有 javax.naming.directory.InvalidSearchControlsException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.InvalidSearchFilterException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.InvalidSearchFilterException
的使用

没有 javax.naming.directory.InvalidSearchFilterException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.ModificationItem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.ModificationItem
的使用

使用 ModificationItem 的软件包
javax.naming.directory 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.directory 中 ModificationItem 的使用

返回 ModificationItem 的 javax.naming.directory 中的方法
 ModificationItem[] AttributeModificationException.getUnexecutedModifications()
检索未执行修改的列表。

参数类型为 ModificationItem 的 javax.naming.directory 中的方法
void | DirContext.modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
void | DirContext.modifyAttributes(String name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)
void | AttributeModificationException.setUnexecutedModifications(ModificationItem[] e) 将未执行的修改列表设置为 e。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.NoSuchAttributeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.NoSuchAttributeException
的使用

没有 javax.naming.directory.NoSuchAttributeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.SchemaViolationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.SchemaViolationException
的使用

没有 javax.naming.directory.SchemaViolationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.SearchControls 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.SearchControls
的使用

使用 SearchControls 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.directory 中 SearchControls 的使用

参数类型为 SearchControls 的 javax.naming.directory 中的方法
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

javax.naming.event 中 SearchControls 的使用

参数类型为 SearchControls 的 javax.naming.event 中的方法
void | EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
void | EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.directory.SearchResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.directory.SearchResult
的使用

使用 SearchResult 的软件包
javax.naming.directory 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming.directory 中 SearchResult 的使用

返回变量类型为 SearchResult 的类型的 javax.naming.directory 中的方法
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


EventContext (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.event
接口 EventContext

所有超级接口：
Context
所有已知子接口：
EventDirContext
public interface EventContext
extends Context

包含注册/注销侦听器的一些方法，这些侦听器在上下文中命名的对象发生更改时获得触发事件的通知。

目标

addNamingListener() 方法中的名称参数被称为目标。目标和范围一起标识侦听器感兴趣的对象。注册不存在的感兴趣目标是可能的，但是服务提供者和底层协议/服务对这种情况的支持程度可能存在限制。

如果服务仅支持注册现有目标，则试图注册不存在的目标将导致第一时间抛出 NameNotFoundException，一般是在调用 addNamingListener() 时；如果这没有发生，则侦听器将通过 NamingExceptionEvent 收到异常。

此外，对于仅支持注册现有目标的服务提供者而言，当以后从名称空间移除注册过侦听器的目标时，该侦听器通过 NamingExceptionEvent（包含 NameNotFoundException）获得通知。

应用程序可以使用 targetMustExist() 来检查 EventContext 是否支持注册不存在的目标。

事件源

对其调用注册方法的 EventContext 实例是（可能）生成事件的事件源。源不一定 是目标指定的对象。仅当目标为空名称时，目标指定的对象才是源。换句话说，目标和范围参数一起用于标识侦听器感兴趣的对象，而事件源是侦听器注册的 EventContext 实例。

例如，假定侦听器进行以下注册：

        NamespaceChangeListener listener = ...;
        src.addNamingListener("x", SUBTREE_SCOPE, listener);
以后删除名为 "x/y" 的对象时，相应的 NamingEvent (evt) 必须包含：
        evt.getEventContext() == src
        evt.getOldBinding().getName().equals("x/y")

此外，侦听器注册/注销是使用 EventContext 实例 进行的，而不是使用名称空间中的相应对象。如果程序在某个时候要移除侦听器，则它需要保持对要调用 addNamingListener() 的 EventContext 实例的引用（这正如为了以后进行移除而需要保持对侦听器的引用）。不要期望它能进行 lookup() 而获取另一个可以执行注销的 EventContext 实例。

注册的生命周期

注册侦听器在以下情况将被注销：
  • 使用 removeNamingListener() 移除。
  • 在收集关于事件的信息时抛出异常。即当侦听器收到 NamingExceptionEvent 时。
  • 对它注册的 EventContext 实例调用 Context.close() 时。
这时，具有未完成侦听器的 EventContext 实例将继续存在，并由服务提供者继续维护。

侦听器实现

注册/注销方法接受 NamingListener 的实例。对不同事件类型的 NamingEvent 使用不同的 NamingListener 子接口。例如，ObjectChangeListener 接口用于 NamingEvent.OBJECT_CHANGED 事件类型。要注册多个感兴趣事件类型，侦听器实现应该实现多个 NamingListener 子接口并调用一次 addNamingListener()。除了减少方法的调用次数并有可能减少侦听器的代码大小之外，这还允许某些服务提供者对注册进行优化。

线程问题

像通常的 Context 实例一样，不保证 EventContext 实例是线程安全的。当多个线程并发访问同一个 EventContext 时必须谨慎。有关线程问题的更多信息，请参阅包描述。

从以下版本开始：
1.3

字段摘要
static int | OBJECT_SCOPE 该常量用来表示对涉及目标指定对象的事件感兴趣。
static int | ONELEVEL_SCOPE 该常量用来表示对涉及目标指定上下文中对象的事件感兴趣，不包括目标指定的上下文。
static int | SUBTREE_SCOPE 该常量用来表示对涉及目标指定对象的子树中对象的事件感兴趣，包括目标指定的对象。
从接口 javax.naming.Context 继承的字段
APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES
方法摘要
void | addNamingListener(Name target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
void | addNamingListener(String target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。
void | removeNamingListener(NamingListener l) 从此 EventContext 触发的接收命名事件中移除一个侦听器。
boolean | targetMustExist() 确定侦听器是否可以注册不存在的感兴趣目标。
从接口 javax.naming.Context 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

字段详细信息

OBJECT_SCOPE

static final int OBJECT_SCOPE
该常量用来表示对涉及目标指定对象的事件感兴趣。

此常量的值为 0。

另请参见：
常量字段值

ONELEVEL_SCOPE

static final int ONELEVEL_SCOPE
该常量用来表示对涉及目标指定上下文中对象的事件感兴趣，不包括目标指定的上下文。

此常量的值为 1。

另请参见：
常量字段值

SUBTREE_SCOPE

static final int SUBTREE_SCOPE
该常量用来表示对涉及目标指定对象的子树中对象的事件感兴趣，包括目标指定的对象。

此常量的值为 2。

另请参见：
常量字段值
方法详细信息

addNamingListener

void addNamingListener(Name target,
                       int scope,
                       NamingListener l)
                       throws NamingException
添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。 这些事件的事件源是此上下文。有关事件源和目标的讨论，请参阅类描述。请参阅对常量 OBJECT_SCOPE、ONELEVEL_SCOPE 和 SUBTREE_SCOPE 的描述，以了解 scope 如何影响注册。

target 仅在 scope 是 ONELEVEL_SCOPE 时需要指定上下文，如果 scope 既不是 OBJECT_SCOPE 也不是 SUBTREE_SCOPE，则 target 可能指定非上下文。例如，如果调用者预先不知道 target 是否是上下文，而只想注册以 target 为根的（可能退化的）子树，则使用非上下文的 SUBTREE_SCOPE 可能很有用。

当侦听器收到事件通知时，侦听器可以在没有执行 addNamingListener() 的某个线程中调用。当多个线程并发访问同一个 EventContext 时必须谨慎。有关线程问题的更多信息，请参阅包描述。

参数：
target - 要相对于此上下文解析的非 null 名称。
scope - OBJECT_SCOPE、ONELEVEL_SCOPE 或 SUBTREE_SCOPE 之一。
l - 非 null 侦听器。
抛出：
NamingException - 如果在添加侦听器时遇到问题。
另请参见：
removeNamingListener(javax.naming.event.NamingListener)

addNamingListener

void addNamingListener(String target,
                       int scope,
                       NamingListener l)
                       throws NamingException
添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。 有关详细信息，请参阅接受 Name 参数的重载方法。

参数：
target - 相对于此上下文解析的对象的非 null 字符串名称。
scope - OBJECT_SCOPE、ONELEVEL_SCOPE 或 SUBTREE_SCOPE 之一。
l - 非 null 侦听器。
抛出：
NamingException - 如果在添加侦听器时遇到问题。
另请参见：
removeNamingListener(javax.naming.event.NamingListener)

removeNamingListener

void removeNamingListener(NamingListener l)
                          throws NamingException
从此 EventContext 触发的接收命名事件中移除一个侦听器。该侦听器可能在此 EventContext 中注册过一次以上，并且可能使用不同的目标/范围参数进行。调用此方法后，侦听器将不再使用作为事件源的此 EventContext 实例接收事件（已经在指派过程中那些事件除外）。如果侦听器不（或不再）在此 EventContext 实例中注册，则此方法不执行任何操作。

参数：
l - 非 null 侦听器。
抛出：
NamingException - 如果在移除侦听器时遇到问题。
另请参见：
addNamingListener(javax.naming.Name, int, javax.naming.event.NamingListener)

targetMustExist

boolean targetMustExist()
                        throws NamingException
确定侦听器是否可以注册不存在的感兴趣目标。

返回：
如果目标存在，则返回 true；如果目标不必存在，则返回 false。
抛出：
NamingException - 如果无法确定上下文的这一行为。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


EventDirContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.event
接口 EventDirContext

所有超级接口：
Context, DirContext, EventContext
public interface EventDirContext
extends EventContext, DirContext

包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。

此接口中的方法支持通过 RFC 2254 搜索过滤器标识对象。

通过使用搜索过滤器，使注册在注册时不存在但后来存在并符合过滤器的感兴趣对象成为可能。不过，服务提供者和底层协议/服务对这种情况的支持程度可能存在限制。如果调用者提交不能以此方式支持的过滤器，则 addNamingListener() 抛出 InvalidSearchFilterException。

有关同时适用于此接口方法的事件源和目标的描述，以及关于侦听器注册/注销的信息，请参阅 EventContext。有关线程问题的信息，请参阅包描述。

作为参数传递给任何方法的 SearchControls 或数组对象都归调用者所有。服务提供者将不修改对象，也不保持对它的引用。

从以下版本开始：
1.3

字段摘要
从接口 javax.naming.event.EventContext 继承的字段
OBJECT_SCOPE, ONELEVEL_SCOPE, SUBTREE_SCOPE
从接口 javax.naming.directory.DirContext 继承的字段
ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE
从接口 javax.naming.Context 继承的字段
APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES
方法摘要
void | addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
void | addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | addNamingListener(String target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。
从接口 javax.naming.event.EventContext 继承的方法
addNamingListener, addNamingListener, removeNamingListener, targetMustExist
从接口 javax.naming.directory.DirContext 继承的方法
bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search
从接口 javax.naming.Context 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

方法详细信息

addNamingListener

void addNamingListener(Name target,
                       String filter,
                       SearchControls ctls,
                       NamingListener l)
                       throws NamingException
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。

搜索控件 ctls 的范围、returningObj 标志和 returningAttributes 标志用来控制对侦听器感兴趣对象的选择和确定在最终 NamingEvent 对象中返回的信息。注意，如果要返回的请求信息不可用或者不能通过服务提供者或服务获取，则这些信息可能不会出现在 NamingEvent 对象中。

参数：
target - 相对于此上下文解析的对象的非 null 名称。
filter - 非 null 字符串过滤器（请参阅 RFC2254）。
ctls - 可能为 null 的搜索控件。如果为 null，则使用默认的搜索控件。
l - 非 null 侦听器。
抛出：
NamingException - 如果在添加侦听器时遇到问题。
另请参见：
EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(javax.naming.Name, java.lang.String, javax.naming.directory.SearchControls)

addNamingListener

void addNamingListener(String target,
                       String filter,
                       SearchControls ctls,
                       NamingListener l)
                       throws NamingException
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。有关此方法的行为的详细信息，请参阅接受 Name 参数的重载方法。

参数：
target - 相对于此上下文解析的对象的非 null 字符串名称。
filter - 非 null 字符串过滤器（请参阅 RFC2254）。
ctls - 可能为 null 的搜索控件。如果为 null，则使用默认的搜索控件。
l - 非 null 侦听器。
抛出：
NamingException - 如果在添加侦听器时遇到问题。
另请参见：
EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(java.lang.String, java.lang.String, javax.naming.directory.SearchControls)

addNamingListener

void addNamingListener(Name target,
                       String filter,
                       Object[] filterArgs,
                       SearchControls ctls,
                       NamingListener l)
                       throws NamingException
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。搜索控件 ctls 的范围、returningObj 标志和 returningAttributes 标志用来控制对侦听器感兴趣对象的选择和确定在最终 NamingEvent 对象中返回的信息。注意，如果要返回的请求信息不可用或者不能通过服务提供者或服务获取，则这些信息可能不会出现在 NamingEvent 对象中。

参数：
target - 相对于此上下文解析的对象的非 null 名称。
filter - 非 null 字符串过滤器（请参阅 RFC2254）。
filterArgs - 过滤器参数所组成的数组（可能为 null）。
ctls - 可能为 null 的搜索控件。如果为 null，则使用默认的搜索控件。
l - 非 null 侦听器。
抛出：
NamingException - 如果在添加侦听器时遇到问题。
另请参见：
EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(javax.naming.Name, java.lang.String, java.lang.Object[], javax.naming.directory.SearchControls)

addNamingListener

void addNamingListener(String target,
                       String filter,
                       Object[] filterArgs,
                       SearchControls ctls,
                       NamingListener l)
                       throws NamingException
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。有关此方法的行为的详细信息，请参阅接受 Name 参数的重载方法。

参数：
target - 相对于此上下文解析的对象的非 null 字符串名称。
filter - 非 null 字符串过滤器（请参阅 RFC2254）。
filterArgs - 过滤器参数所组成的数组（可能为 null）。
ctls - 可能为 null 的搜索控件。如果为 null，则使用默认的搜索控件。
l - 非 null 侦听器。
抛出：
NamingException - 如果在添加侦听器时遇到问题。
另请参见：
EventContext.removeNamingListener(javax.naming.event.NamingListener), DirContext.search(java.lang.String, java.lang.String, java.lang.Object[], javax.naming.directory.SearchControls)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamespaceChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.event
接口 NamespaceChangeListener

所有超级接口：
EventListener, NamingListener
public interface NamespaceChangeListener
extends NamingListener

指定对名称空间更改感兴趣的侦听器必须实现的方法。明确地说，是对 OBJECT_ADDED、OBJECT_RENAMED 或 OBJECT_REMOVED 事件类型的 NamingEvent 感兴趣的侦听器。

这种侦听器必须：

  1. 实现此接口及其方法。
  2. 实现 NamingListener.namingExceptionThrown()，以便在尝试收集关于事件的信息期间抛出异常时得到通知。
  3. 使用源的 addNamingListener() 方法向该源注册。
希望获得 OBJECT_CHANGED 事件类型的通知的侦听器还应该实现 ObjectChangeListener 接口。

从以下版本开始：
1.3
另请参见：
NamingEvent, ObjectChangeListener, EventContext, EventDirContext

方法摘要
void | objectAdded(NamingEvent evt) 在已经添加了对象时调用此方法。
void | objectRemoved(NamingEvent evt) 在已经移除了对象时调用此方法。
void | objectRenamed(NamingEvent evt) 在已经重命名了对象时调用此方法。
从接口 javax.naming.event.NamingListener 继承的方法
namingExceptionThrown

方法详细信息

objectAdded

void objectAdded(NamingEvent evt)
在已经添加了对象时调用此方法。

可以使用 evt.getNewBinding() 获取新添加对象的绑定。

参数：
evt - 非 null 事件。
另请参见：
NamingEvent.OBJECT_ADDED

objectRemoved

void objectRemoved(NamingEvent evt)
在已经移除了对象时调用此方法。

可以使用 evt.getOldBinding() 获取新移除对象的绑定。

参数：
evt - 非 null 事件。
另请参见：
NamingEvent.OBJECT_REMOVED

objectRenamed

void objectRenamed(NamingEvent evt)
在已经重命名了对象时调用此方法。

可以使用 evt.getNewBinding() 获取重命名对象的绑定。可以使用 evt.getOldBinding() 获取其旧绑定（重命名前的绑定）。如果新/旧绑定在已注册侦听器关注的范围之外，则这些事件之一可能为 null。

参数：
evt - 非 null 事件。
另请参见：
NamingEvent.OBJECT_RENAMED
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.event
类 NamingEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.naming.event.NamingEvent
所有已实现的接口：
Serializable
public class NamingEvent
extends EventObject

此类表示命名/目录服务触发的事件。

NamingEvent 的状态包括

  • 事件源：触发此事件的 EventContext。
  • 事件类型。
  • 新绑定：关于更改后对象的信息。
  • 旧绑定：关于更改前对象的信息。
  • 更改信息：关于触发此事件的更改的信息；通常是特定于服务提供者或特定于服务器的信息。

注意，事件源始终是注册了侦听器的那个 EventContext 实例。此外，NamingEvent 中绑定的名称始终相对于该实例。例如，假定侦听器进行以下注册：

        NamespaceChangeListener listener = ...;
        src.addNamingListener("x", SUBTREE_SCOPE, listener);
以后删除名为 "x/y" 的对象时，相应的 NamingEvent (evt) 必须包含：
        evt.getEventContext() == src
        evt.getOldBinding().getName().equals("x/y")
当多个线程并发访问同一个 EventContext 时必须谨慎。有关线程问题的更多信息，请参阅包描述。

从以下版本开始：
1.3
另请参见：
NamingListener, EventContext, 序列化表格

字段摘要
protected Object | changeInfo 包含关于生成此事件的更改的信息。
protected Binding | newBinding 包含关于更改后对象的信息。
static int | OBJECT_ADDED 指示已经添加了新对象的命名事件类型。
static int | OBJECT_CHANGED 指示已经更改了某个对象的命名事件类型。
static int | OBJECT_REMOVED 指示已经移除了某个对象的命名事件类型。
static int | OBJECT_RENAMED 指示已经重命名了某个对象的命名事件类型。
protected Binding | oldBinding 包含关于更改前对象的信息。
protected int | type 包含此事件的类型。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
构造一个 NamingEvent 的实例。
方法摘要
void | dispatch(NamingListener listener) 对此事件调用适当的侦听器方法。
Object | getChangeInfo() 检索此事件的更改信息。
EventContext | getEventContext() 检索触发此事件的事件源。
Binding | getNewBinding() 检索更改后对象的绑定。
Binding | getOldBinding() 检索更改前对象的绑定。
int | getType() 返回此事件的类型。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OBJECT_ADDED

public static final int OBJECT_ADDED
指示已经添加了新对象的命名事件类型。此常量的值为 0。

另请参见：
常量字段值

OBJECT_REMOVED

public static final int OBJECT_REMOVED
指示已经移除了某个对象的命名事件类型。此常量的值为 1。

另请参见：
常量字段值

OBJECT_RENAMED

public static final int OBJECT_RENAMED
指示已经重命名了某个对象的命名事件类型。注意，有些服务可能为单个逻辑重命名操作触发多个事件。例如，重命名操作可能通过添加具有新名称的绑定并移除旧绑定来实现。

如果新名称或旧名称在侦听器注册的范围之外，则 NamingEvent 中的新/旧绑定为 null。

重命名名称空间树中的内部节点后，应该使用作为侦听器范围一部分的顶层节点生成重命名事件。对这一点的支持程度是特定于提供者的。例如，服务可能为所有已更改内部节点的子代都生成重命名通知，相应的提供者可能无法阻止将这些通知传播到侦听器。

此常量的值为 2。

另请参见：
常量字段值

OBJECT_CHANGED

public static final int OBJECT_CHANGED
指示已经更改了某个对象的命名事件类型。更改可能包括对象的属性，也可能包括对象本身。注意，有些服务可能为单个修改触发多个事件。例如，修改可能通过首先移除旧绑定，然后添加包含相同名称但不同对象的新绑定来实现。

此常量的值为 3。

另请参见：
常量字段值

changeInfo

protected Object changeInfo
包含关于生成此事件的更改的信息。

type

protected int type
包含此事件的类型。

另请参见：
OBJECT_ADDED, OBJECT_REMOVED, OBJECT_RENAMED, OBJECT_CHANGED

oldBinding

protected Binding oldBinding
包含关于更改前对象的信息。

newBinding

protected Binding newBinding
包含关于更改后对象的信息。

构造方法详细信息

NamingEvent

public NamingEvent(EventContext source,
                   int type,
                   Binding newBd,
                   Binding oldBd,
                   Object changeInfo)
构造一个 NamingEvent 的实例。

newBd 和 oldBd 中的名称将相对于事件源 source 进行解析。 对于 OBJECT_ADDED 事件类型，newBd 不得为 null。对于 OBJECT_REMOVED 事件类型，oldBd 不得为 null。对于 OBJECT_CHANGED 事件类型，newBd 和 oldBd 不得为 null。对于 OBJECT_RENAMED 事件类型，如果新绑定或旧绑定在已注册侦听器的范围之外，则 newBd 和 oldBd 中的一个可以为 null。

参数：
source - 触发此事件的非 null 上下文。
type - 事件的类型。
newBd - 更改前的绑定（可能为 null）。请参阅方法描述。
oldBd - 更改后的绑定（可能为 null）。请参阅方法描述。
changeInfo - 包含关于更改的信息的对象（可能为 null）。
另请参见：
OBJECT_ADDED, OBJECT_REMOVED, OBJECT_RENAMED, OBJECT_CHANGED
方法详细信息

getType

public int getType()
返回此事件的类型。

返回：
此事件的类型。
另请参见：
OBJECT_ADDED, OBJECT_REMOVED, OBJECT_RENAMED, OBJECT_CHANGED

getEventContext

public EventContext getEventContext()
检索触发此事件的事件源。此操作与 EventObject.getSource() 返回相同的对象。

如果将此方法的结果用于访问事件源，例如，查找对象或获取其属性，则需要将其锁定，因为不保证 Context 的实现是线程安全的（也不保证 EventContext 是 Context 的子接口）。有关线程问题的更多信息，请参阅包描述。

返回：
触发此事件的非 null 上下文。

getOldBinding

public Binding getOldBinding()
检索更改前对象的绑定。

如果对象存在于相对源上下文 (getEventContext()) 进行更改之前，则绑定必须为非 null。即对于 OBJECT_REMOVED 和 OBJECT_CHANGED 它必须为非 null。对于 OBJECT_RENAMED，如果重命名前对象在注册侦听器关注的范围之外，则它为 null；如果对象在重命名前在该范围之内，则它为非 null。

绑定中的名称将相对于事件源 getEventContext() 进行解析。如果这类信息不可用，则 Binding.getObject() 返回的对象为 null。

返回：
更改前对象的绑定（可能为 null）。

getNewBinding

public Binding getNewBinding()
检索更改后对象的绑定。

如果对象存在于相对源上下文 (getEventContext()) 进行更改之后，则绑定必须为非 null。即对于 OBJECT_ADDED 和 OBJECT_CHANGED 它必须为非 null。对于 OBJECT_RENAMED，如果重命名后对象在注册侦听器关注的范围之外，则它为 null；如果对象在重命名后在该范围之内，则它为非 null。

绑定中的名称将相对于事件源 getEventContext() 进行解析。如果这类信息不可用，则 Binding.getObject() 返回的对象为 null。

返回：
更改后对象的绑定（可能为 null）。

getChangeInfo

public Object getChangeInfo()
检索此事件的更改信息。更改信息的值是特定于服务的。例如，它可以是用于标识服务器上更改日志中所做更改的 ID。

返回：
此事件的更改信息（可能为 null）。

dispatch

public void dispatch(NamingListener listener)
对此事件调用适当的侦听器方法。此方法的默认实现处理以下事件类型：OBJECT_ADDED、OBJECT_REMOVED、OBJECT_RENAMED 和 OBJECT_CHANGED。

侦听器方法与此方法在同一个线程中执行。有关线程问题的更多信息，请参阅包描述。

参数：
listener - 非 null 侦听器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingExceptionEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.event
类 NamingExceptionEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.naming.event.NamingExceptionEvent
所有已实现的接口：
Serializable
public class NamingExceptionEvent
extends EventObject

此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。例如，当侦听器使用的服务器在调用 addNamingListener() 后异常中止时，可能出现该情况。

从以下版本开始：
1.3
另请参见：
NamingListener.namingExceptionThrown(javax.naming.event.NamingExceptionEvent), EventContext, 序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
NamingExceptionEvent(EventContext source, NamingException exc)
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。
方法摘要
void | dispatch(NamingListener listener) 使用此事件对侦听器调用 namingExceptionThrown() 方法。
EventContext | getEventContext() 检索触发此事件的 EventContext。
NamingException | getException() 检索抛出的异常。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

NamingExceptionEvent

public NamingExceptionEvent(EventContext source,
                            NamingException exc)
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。

参数：
source - 抛出过异常的非 null 上下文。
exc - 抛出的非 null NamingException。
方法详细信息

getException

public NamingException getException()
检索抛出的异常。

返回：
抛出的异常。

getEventContext

public EventContext getEventContext()
检索触发此事件的 EventContext。此操作与 EventObject.getSource() 返回相同的对象。

返回：
触发此事件的非 null EventContext。

dispatch

public void dispatch(NamingListener listener)
使用此事件对侦听器调用 namingExceptionThrown() 方法。

参数：
listener - 非 null 命名侦听器，要对该侦听器调用方法。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.event
接口 NamingListener

所有超级接口：
EventListener
所有已知子接口：
NamespaceChangeListener, ObjectChangeListener, UnsolicitedNotificationListener
public interface NamingListener
extends EventListener

此接口是处理 NamingEvent 的侦听器接口的根。这一点对于仅实现此接口的侦听器没有意义。侦听器通常实现 NamingListener 的子接口，如 ObjectChangeListener 或 NamespaceChangeListener。

此接口包含单个方法 namingExceptionThrown()，必须实现此方法，这样侦听器才能在搜集关于其所需事件的信息时获得（服务提供者）抛出的异常的通知。调用此方法时，侦听器已经从其注册的 EventContext 中自动注销。

例如，假定侦听器实现 ObjectChangeListener 并在 EventContext 中注册。如果到服务器的连接后来中断了，则侦听器将接收到一个 NamingExceptionEvent 并可能采取某一校正操作，如向应用程序的用户发出通知。

从以下版本开始：
1.3
另请参见：
NamingEvent, NamingExceptionEvent, EventContext, EventDirContext

方法摘要
 void namingExceptionThrown(NamingExceptionEvent evt)
在试图触发 NamingEvent 期间抛出命名异常时调用此方法。

方法详细信息

namingExceptionThrown

void namingExceptionThrown(NamingExceptionEvent evt)
在试图触发 NamingEvent 期间抛出命名异常时调用此方法。

参数：
evt - 非 null 事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.event
接口 ObjectChangeListener

所有超级接口：
EventListener, NamingListener
public interface ObjectChangeListener
extends NamingListener

指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。

更改对象（的内容）时将触发 OBJECT_CHANGED 事件类型。这可能意味着对象的属性已经被修改、添加或移除，和/或对象本身已经被替换。通过检查 NamingEvent 的旧绑定和新绑定可以确定对象的更改方式。

对 OBJECT_CHANGED 事件类型感兴趣的侦听器必须：

  1. 实现此接口及其方法 (objectChanged())。
  2. 实现 NamingListener.namingExceptionThrown()，以便在尝试收集关于事件的信息期间抛出异常时得到通知。
  3. 使用源的 addNamingListener() 方法向该源注册。
希望获得名称空间更改事件的通知的侦听器还应该实现 NamespaceChangeListener 接口。

从以下版本开始：
1.3
另请参见：
NamingEvent, NamespaceChangeListener, EventContext, EventDirContext

方法摘要
 void objectChanged(NamingEvent evt)
在已经更改了对象时调用此方法。
从接口 javax.naming.event.NamingListener 继承的方法
namingExceptionThrown

方法详细信息

objectChanged

void objectChanged(NamingEvent evt)
在已经更改了对象时调用此方法。

可以使用 evt.getNewBinding() 获取更改对象的绑定。可以使用 evt.getOldBinding() 获取其旧绑定（更改前的绑定）。

参数：
evt - 非 null 命名事件。
另请参见：
NamingEvent.OBJECT_CHANGED
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.naming.event (Java 2 Platform SE 6)

 javax.naming.event
接口
EventContext
EventDirContext
NamespaceChangeListener
NamingListener
ObjectChangeListener
类
NamingEvent
NamingExceptionEvent


javax.naming.event (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.naming.event

在访问命名和目录服务时提供对事件通知的支持。

请参见：
描述

接口摘要
EventContext | 包含注册/注销侦听器的一些方法，这些侦听器在上下文中命名的对象发生更改时获得触发事件的通知。
EventDirContext | 包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。
NamespaceChangeListener | 指定对名称空间更改感兴趣的侦听器必须实现的方法。
NamingListener | 此接口是处理 NamingEvent 的侦听器接口的根。
ObjectChangeListener | 指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。

类摘要
NamingEvent | 此类表示命名/目录服务触发的事件。
NamingExceptionEvent | 此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。

软件包 javax.naming.event 的描述

在访问命名和目录服务时提供对事件通知的支持。

此包定义 Java Naming and Directory InterfaceTM (JNDI) 的事件通知操作。 JNDI 向使用 Java 编程语言编写的应用程序提供命名和目录功能。它被设计成与任何特定的命名或目录服务实现无关。因此可以使用共同的方式对多种服务（新的、新出现的及已经部署的服务）进行访问。

命名事件

此包定义 NamingEvent 类以表示由命名/目录服务生成的事件。它还定义 Context 和 DirContext 的子接口（分别称为 EventContext 和 EventDirContext），应用程序可以通过这些子接口注册它们感兴趣的、由上下文触发的事件。

NamingEvent 表示在命名或目录服务中发生的事件。有两种命名事件：

  • 影响名称空间的事件（添加/移除/重命名对象）
  • 影响对象内容的事件。
这两种事件分别由对应的侦听器处理：NamespaceChangeListener 或 ObjectChangeListener。

例如，应用程序可以按以下方式注册对上下文中的对象进行的其感兴趣的更改：

EventContext src =
    (EventContext)(new InitialContext()).lookup("o=wiz,c=us");
src.addNamingListener("ou=users", EventContext.ONELEVEL_SCOPE,
    new ChangeHandler());
...
class ChangeHandler implements ObjectChangeListener {
    public void objectChanged(NamingEvent evt) {
        System.out.println(evt.getNewBinding());
    }
    public void namingExceptionThrown(NamingExceptionEvent evt) {
        System.out.println(evt.getException());
    }
}

线程问题

将事件指派给侦听器时，侦听器方法（如 objectChanged()）可以在没有执行调用 addNamingListener() 的某个线程中执行。由服务提供者选择要使用的线程。将一个事件指派给多个侦听器时，服务提供者可以选择（通常建议这样做）在各个线程中并发执行侦听器方法。

当侦听器实例调用 NamingEvent.getEventContext() 时，它必须考虑到其他线程可能将并发使用该上下文。同样，在通过 addNamingListener() 注册侦听器时，注册线程也必须考虑到类似的可能性，即服务提供者稍后可能在新创建的线程中调用这些侦听器。因为一般不保证 Context 实例是线程安全的，所以必须根据需要同步所有上下文操作。

异常处理

当侦听器在上下文中注册事件时，上下文可能需要进行一些内部处理以便收集生成事件所需的信息。例如，上下文可能需要向服务器请求注册在服务器上进行的感兴趣更改，这些更改最终将被转换为事件。如果发生了阻止收集关于事件的信息的异常，则侦听器将永远无法获得这些事件的通知。发生此类异常时，将触发 NamingExceptionEvent 来通知侦听器。侦听器的 namingExceptionThrown() 方法被调用（如上文示例代码所示），侦听器被自动注销。

包规范

JNDI API 规范及相关文档可在 JNDI documentation 中找到。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.naming.event 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.event 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.naming.event.NamingEvent
      • javax.naming.event.NamingExceptionEvent

接口分层结构

  • javax.naming.Context
    • javax.naming.directory.DirContext
      • javax.naming.event.EventDirContext (并 extends javax.naming.event.EventContext)
    • javax.naming.event.EventContext
      • javax.naming.event.EventDirContext (并 extends javax.naming.directory.DirContext)
  • java.util.EventListener
    • javax.naming.event.NamingListener
      • javax.naming.event.NamespaceChangeListener
      • javax.naming.event.ObjectChangeListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.naming.event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.event
的使用

使用 javax.naming.event 的软件包
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.event 使用的 javax.naming.event 中的类
EventContext
包含注册/注销侦听器的一些方法，这些侦听器在上下文中命名的对象发生更改时获得触发事件的通知。
NamingEvent
此类表示命名/目录服务触发的事件。
NamingExceptionEvent
此类表示用来收集通知 NamingEvent 侦听器的信息的过程/进程抛出 NamingException 时触发的事件。
NamingListener
此接口是处理 NamingEvent 的侦听器接口的根。

javax.naming.ldap 使用的 javax.naming.event 中的类
NamingListener
此接口是处理 NamingEvent 的侦听器接口的根。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.event.EventContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.EventContext
的使用

使用 EventContext 的软件包
javax.naming.event 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.event 中 EventContext 的使用

javax.naming.event 中 EventContext 的子接口
 interface EventDirContext
包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。

返回 EventContext 的 javax.naming.event 中的方法
EventContext | NamingEvent.getEventContext() 检索触发此事件的事件源。
EventContext | NamingExceptionEvent.getEventContext() 检索触发此事件的 EventContext。

参数类型为 EventContext 的 javax.naming.event 中的构造方法
NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
构造一个 NamingEvent 的实例。
NamingExceptionEvent(EventContext source, NamingException exc)
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.event.EventDirContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.EventDirContext
的使用

没有 javax.naming.event.EventDirContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.event.NamespaceChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.NamespaceChangeListener
的使用

没有 javax.naming.event.NamespaceChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.event.NamingEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.event.NamingEvent
的使用

使用 NamingEvent 的软件包
javax.naming.event 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.event 中 NamingEvent 的使用

参数类型为 NamingEvent 的 javax.naming.event 中的方法
void | NamespaceChangeListener.objectAdded(NamingEvent evt) 在已经添加了对象时调用此方法。
void | ObjectChangeListener.objectChanged(NamingEvent evt) 在已经更改了对象时调用此方法。
void | NamespaceChangeListener.objectRemoved(NamingEvent evt) 在已经移除了对象时调用此方法。
void | NamespaceChangeListener.objectRenamed(NamingEvent evt) 在已经重命名了对象时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.event.NamingExceptionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.event.NamingExceptionEvent
的使用

使用 NamingExceptionEvent 的软件包
javax.naming.event 在访问命名和目录服务时提供对事件通知的支持。

javax.naming.event 中 NamingExceptionEvent 的使用

参数类型为 NamingExceptionEvent 的 javax.naming.event 中的方法
 void NamingListener.namingExceptionThrown(NamingExceptionEvent evt)
在试图触发 NamingEvent 期间抛出命名异常时调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.event.NamingListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.NamingListener
的使用

使用 NamingListener 的软件包
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.event 中 NamingListener 的使用

javax.naming.event 中 NamingListener 的子接口
interface | NamespaceChangeListener 指定对名称空间更改感兴趣的侦听器必须实现的方法。
interface | ObjectChangeListener 指定事件类型为 OBJECT_CHANGED 的 NamingEvent 侦听器必须实现的方法。

参数类型为 NamingListener 的 javax.naming.event 中的方法
 void EventContext.addNamingListener(Name target, int scope, NamingListener l)
添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
 void EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
 void EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
 void EventContext.addNamingListener(String target, int scope, NamingListener l)
添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。
 void EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
 void EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l)
添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。
 void NamingEvent.dispatch(NamingListener listener)
对此事件调用适当的侦听器方法。
 void NamingExceptionEvent.dispatch(NamingListener listener)
使用此事件对侦听器调用 namingExceptionThrown() 方法。
 void EventContext.removeNamingListener(NamingListener l)
从此 EventContext 触发的接收命名事件中移除一个侦听器。

javax.naming.ldap 中 NamingListener 的使用

javax.naming.ldap 中 NamingListener 的子接口
 interface UnsolicitedNotificationListener
此接口用于处理 UnsolicitedNotificationEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.event.ObjectChangeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.event.ObjectChangeListener
的使用

没有 javax.naming.event.ObjectChangeListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BasicControl (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 BasicControl

java.lang.Object
    继承者  javax.naming.ldap.BasicControl
所有已实现的接口：
Serializable, Control
直接已知子类：
ManageReferralControl, PagedResultsControl, PagedResultsResponseControl, SortControl, SortResponseControl
public class BasicControl
extends Object
implements Control

此类提供 Control 接口的基本实现。它表示在 RFC 2251 中定义的 LDAPv3 控件。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
protected boolean | criticality 控件的关键性。
protected String | id 控件的对象标识符字符串。
protected byte[] | value 控件的 ASN.1 BER 编码值。
从接口 javax.naming.ldap.Control 继承的字段
CRITICAL, NONCRITICAL
构造方法摘要
BasicControl(String id)
构造一个非关键控件。
BasicControl(String id, boolean criticality, byte[] value)
使用提供的参数构造控件。
方法摘要
byte[] | getEncodedValue() 检索控件的 ASN.1 BER 编码值。
String | getID() 检索控件的对象标识符字符串。
boolean | isCritical() 确定控件的关键性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

id

protected String id
控件的对象标识符字符串。

criticality

protected boolean criticality
控件的关键性。

value

protected byte[] value
控件的 ASN.1 BER 编码值。

构造方法详细信息

BasicControl

public BasicControl(String id)
构造一个非关键控件。

参数：
id - 控件的对象标识符字符串。

BasicControl

public BasicControl(String id,
                    boolean criticality,
                    byte[] value)
使用提供的参数构造控件。

参数：
id - 控件的对象标识符字符串。
criticality - 此控件的关键性。
value - 控件的 ASN.1 BER 编码值。它不是副本，对值进行的任何更改都将影响控件的内容。它可能为 null。
方法详细信息

getID

public String getID()
检索控件的对象标识符字符串。

指定者：
接口 Control 中的 getID
返回：
非 null 对象标识符字符串。

isCritical

public boolean isCritical()
确定控件的关键性。

指定者：
接口 Control 中的 isCritical
返回：
如果控件是关键的，则返回 true；否则返回 false。

getEncodedValue

public byte[] getEncodedValue()
检索控件的 ASN.1 BER 编码值。结果包括 BER 标记和控件值的长度，但不包括控件的对象标识符和关键性设置。

指定者：
接口 Control 中的 getEncodedValue
返回：
表示控件的 ASN.1 BER 编码值的字节数组（可能为 null）。它不是副本，对返回值进行的任何更改都将影响控件的内容。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Control (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
接口 Control

所有超级接口：
Serializable
所有已知实现类：
BasicControl, ManageReferralControl, PagedResultsControl, PagedResultsResponseControl, SortControl, SortResponseControl
public interface Control
extends Serializable

此接口表示在 RFC 2251 中定义的 LDAPv3 控件。

LDAPv3 协议使用控件发送和接收影响预定义操作行为的附加数据。可以将控件和任何 LDAP 操作一起发送到服务器。这些控件被称为请求控件。例如，可以将“排序”控件与 LDAP 搜索操作一起发送来请求以特定顺序返回结果。也可以通过服务器的响应返回经过请求的控件和未经请求的控件。这些控件被称为响应控件。例如，LDAP 服务器可以定义一个特殊控件来返回更改通知。

此接口用于表示请求控件和响应控件。

从以下版本开始：
1.3
另请参见：
ControlFactory

字段摘要
static boolean | CRITICAL 指示关键控件。
static boolean | NONCRITICAL 指示非关键控件。
方法摘要
byte[] | getEncodedValue() 检索 LDAP 控件的 ASN.1 BER 编码值。
String | getID() 检索为 LDAP 控件分配的对象标识符。
boolean | isCritical() 确定 LDAP 控件的关键性。

字段详细信息

CRITICAL

static final boolean CRITICAL
指示关键控件。此常量的值为 true。

另请参见：
常量字段值

NONCRITICAL

static final boolean NONCRITICAL
指示非关键控件。此常量的值为 false。

另请参见：
常量字段值
方法详细信息

getID

String getID()
检索为 LDAP 控件分配的对象标识符。

返回：
非 null 对象标识符字符串。

isCritical

boolean isCritical()
确定 LDAP 控件的关键性。服务器不得忽略关键控件。换句话说，如果服务器收到一个它不支持的关键控件，则无论该控件对操作是否有意义，服务器都将不执行操作并抛出 OperationNotSupportedException。

返回：
如果此控件是关键的，则返回 true；否则返回 false。

getEncodedValue

byte[] getEncodedValue()
检索 LDAP 控件的 ASN.1 BER 编码值。结果为原始 BER 字节，包括控件值的标记和长度。它不包括控件 OID 和关键性。 如果值不存在，则返回 null。

返回：
表示 LDAP 控件的 ASN.1 BER 编码值的字节数组（可能为 null）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ControlFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 ControlFactory

java.lang.Object
    继承者  javax.naming.ldap.ControlFactory

public abstract class ControlFactory
extends Object

此抽象类表示用于创建 LDAPv3 控件的工厂。LDAPv3 控件是在 RFC 2251 中定义的。

当服务提供者收到响应控件时，它使用控件工厂返回特定/适当的控件类实现。

从以下版本开始：
1.3
另请参见：
Control

构造方法摘要
protected ControlFactory()
方法摘要
abstract Control | getControlInstance(Control ctl) 使用此控件工厂创建控件。
static Control | getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ControlFactory

protected ControlFactory()
方法详细信息

getControlInstance

public abstract Control getControlInstance(Control ctl)
                                    throws NamingException
使用此控件工厂创建控件。

服务提供者使用工厂以专用控件类的形式返回从 LDAP 协议读取的控件。不使用此机制，提供者将返回仅包含 BER 编码格式的数据的控件。

通常，ctl 是包含 BER 编码数据的“基本”控件。通常通过解码 BER 编码数据使用工厂创建专门的控件实现，该实现提供一些方法以类型安全的、友好的方式来访问该数据。

例如，工厂可能使用基本控件中的 BER 编码数据并返回 VirtualListReplyControl 的实例。

如果此工厂不能使用提供的参数创建控件，则其应该返回 null。工厂只有在可以确定它是唯一需要的工厂并且不应该再尝试其他控件工厂时才抛出异常。例如，在控件中的 BER 数据不匹配给定 OID 的控件所期望的数据时，会发生这种情况。此方法抛出 NamingException，因此应该传播的所有其他内部生成的异常都必须被包装在 NamingException 中。

参数：
ctl - 非 null 控件。
返回：
一个控件（可能为 null）。
抛出：
NamingException - 如果 ctl 包含无效数据，这些无效数据阻止它用于创建控件。工厂只有在已知生成控件（由 OID 标识）的方式但由于某些原因（例如，BER 数据无效）不能生成控件时才抛出异常。

getControlInstance

public static Control getControlInstance(Control ctl,
                                         Context ctx,
                                         Hashtable<?,?> env)
                                  throws NamingException
使用已知控件工厂创建控件。

使用以下规则创建控件：

  • 使用环境的 LdapContext.CONTROL_FACTORIES 属性和与 ctx 关联的提供者资源文件的 LdapContext.CONTROL_FACTORIES 属性中指定的控件工厂，并使用原来的顺序。此属性的值是按顺序尝试的以冒号分隔的工厂类名称列表，使用的名称是第一个成功创建控件的名称。如果无法加载任何工厂，则返回 ctl。如果在创建控件时遇到异常，则将异常传递到调用者。

注意，控件工厂必须是公共的，并且必须具有不接受任何参数的公共构造方法。

参数：
ctl - 包含 OID 和 BER 数据的非 null 控件对象。
ctx - 将创建控件的上下文（可能为 null）。如果为 null，则所有这些信息都不可用。
env - 上下文的环境（可能为 null）。此值用于查找 LdapContext.CONTROL_FACTORIES 属性的值。
返回：
使用 ctl 创建的控件对象；如果使用上述算法无法创建控件对象，则返回 ctl。
抛出：
NamingException - 如果在尝试创建控件对象时遇到了命名异常。如果访问的工厂之一抛出异常，则该异常将被传播到调用者。如果在加载和实例化工厂和对象类时遇到错误，则异常将被包装在 NamingException 中，然后重新抛出。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtendedRequest (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
接口 ExtendedRequest

所有超级接口：
Serializable
所有已知实现类：
StartTlsRequest
public interface ExtendedRequest
extends Serializable

此接口表示在 RFC 2251 中定义的 LDAPv3 扩展操作请求。

     ExtendedRequest ::= [APPLICATION 23] SEQUENCE {
              requestName      [0] LDAPOID,
              requestValue     [1] OCTET STRING OPTIONAL }
它包含对象标识符字符串和可选的 ASN.1 BER 编码值。

服务提供者使用此类中的方法构造发送到 LDAP 服务器的位。应用程序通常仅处理实现此接口的类，向它们提供特定扩展操作请求所需的任何信息。然后，它将这种类作为参数传递给 LdapContext.extendedOperation() 方法，从而执行 LDAPv3 扩展操作。

例如，假定 LDAP 服务器支持“获取时间”扩展操作。它将提供 GetTimeRequest 和 GetTimeResponse 类：

 public class GetTimeRequest implements ExtendedRequest {
     public GetTimeRequest() {... };
     public ExtendedResponse createExtendedResponse(String id,
            byte[] berValue, int offset, int length)
            throws NamingException {
         return new GetTimeResponse(id, berValue, offset, length);
     }
     ...
 }
 public class GetTimeResponse implements ExtendedResponse {
     long time;
     public GetTimeResponse(String id, byte[] berValue, int offset,
            int length) throws NamingException {
time =  ... // decode berValue to get time
     }
     public java.util.Date getDate() { return new java.util.Date(time) };
     public long getTime() { return time };
     ...
 }
然后，程序将使用以下这些类：
 GetTimeResponse resp =
        (GetTimeResponse) ectx.extendedOperation(new GetTimeRequest());
 long time = resp.getTime();

从以下版本开始：
1.3
另请参见：
ExtendedResponse, LdapContext.extendedOperation(javax.naming.ldap.ExtendedRequest)

方法摘要
ExtendedResponse | createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与此请求对应的响应对象。
byte[] | getEncodedValue() 检索 LDAP 扩展操作请求的 ASN.1 BER 编码值。
String | getID() 检索请求的对象标识符。

方法详细信息

getID

String getID()
检索请求的对象标识符。

返回：
表示 LDAP ExtendedRequest.requestName 组件的非 null 对象标识符字符串。

getEncodedValue

byte[] getEncodedValue()
检索 LDAP 扩展操作请求的 ASN.1 BER 编码值。如果值不存在，则返回 null。 结果为原始 BER 字节，包括请求值的标记和长度。它不包括请求 OID。服务提供者调用此方法获取将置于扩展操作中的位，该操作将被发送给 LDAP 服务器。

返回：
表示 LDAP ExtendedRequest.requestValue 组件的 ASN.1 BER 编码内容的字节数组（可能为 null）。
抛出：
IllegalStateException - 如果因请求包含不足或无效的数据/状态而无法检索编码值。

createExtendedResponse

ExtendedResponse createExtendedResponse(String id,
                                        byte[] berValue,
                                        int offset,
                                        int length)
                                        throws NamingException
创建与此请求对应的响应对象。

在服务提供者将扩展操作请求发送到 LDAP 服务器后，它将从服务器收到响应。如果操作失败，则提供者将抛出 NamingException。如果操作成功，则提供者将使用从响应取回的数据调用此方法。此方法的任务是返回实现适合扩展操作请求的 ExtendedResponse 接口的类。

例如，Start TLS 扩展请求类需要知道如何处理 Start TLS 扩展响应。它通过创建实现 ExtendedResponse 的类完成此操作。

参数：
id - 响应控件的对象标识符（可能为 null）。
berValue - 响应控件的 ASN.1 BER 编码值（可能为 null）。此为原始 BER 字节，包括响应值的标记和长度。它不包括响应 OID。
offset - berValue 中要使用的字节的开始位置。
length - berValue 中要使用的字节数。
返回：
非 null 对象。
抛出：
NamingException - 如果因出错而无法创建扩展响应。
另请参见：
ExtendedResponse
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ExtendedResponse (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
接口 ExtendedResponse

所有超级接口：
Serializable
所有已知子接口：
UnsolicitedNotification
所有已知实现类：
StartTlsResponse
public interface ExtendedResponse
extends Serializable

此接口表示在 RFC 2251 中定义的 LDAP 扩展操作响应。

     ExtendedResponse ::= [APPLICATION 24] SEQUENCE {
          COMPONENTS OF LDAPResult,
          responseName     [10] LDAPOID OPTIONAL,
          response         [11] OCTET STRING OPTIONAL }
它包含可选的对象标识符和可选的 ASN.1 BER 编码值。

应用程序可以使用此类中的方法获取关于扩展操作响应的低级信息。但是，应用程序通常将使用特定于实现此接口的类的方法。这种类应该已经解码了响应中的 BER 缓冲区，并应该提供一些方法允许用户以类型安全的、友好的方式访问响应中数据。

例如，假定 LDAP 服务器支持“获取时间”扩展操作。它将提供 GetTimeRequest 和 GetTimeResponse 类。GetTimeResponse 类可能如下所示：

 public class GetTimeResponse implements ExtendedResponse {
     public java.util.Date getDate() {...};
     public long getTime() {...};
     ....
 }
然后，程序将使用以下这些类：
 GetTimeResponse resp =
        (GetTimeResponse) ectx.extendedOperation(new GetTimeRequest());
 java.util.Date now = resp.getDate();

从以下版本开始：
1.3
另请参见：
ExtendedRequest

方法摘要
byte[] | getEncodedValue() 检索 LDAP 扩展操作响应的 ASN.1 BER 编码值。
String | getID() 检索响应的对象标识符。

方法详细信息

getID

String getID()
检索响应的对象标识符。LDAP 协议指定响应对象标识符是可选的。如果服务器不发送它，则响应不包含任何 ID（即 null）。

返回：
表示 LDAP ExtendedResponse.responseName 组件的对象标识符字符串（可能为 null）。

getEncodedValue

byte[] getEncodedValue()
检索 LDAP 扩展操作响应的 ASN.1 BER 编码值。如果该值不在 LDAP 服务器发送的响应中，则返回 null。结果为原始 BER 字节，包括响应值的标记和长度。它不包括响应 OID。

返回：
表示 LDAP ExtendedResponse.response 组件的 ASN.1 BER 编码内容的字节数组（可能为 null）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HasControls (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
接口 HasControls

所有已知子接口：
UnsolicitedNotification
public interface HasControls

此接口用于返回控件，并使对象返回在 NamingEnumeration 中。例如，假定服务器利用搜索操作的结果发送回控件，服务提供者将返回类型为 SearchResult 并实现 HasControls 的对象所组成的 NamingEnumeration。

   NamingEnumeration elts = ectx.search((Name)name, filter, sctls);
   while (elts.hasMore()) {
        Object entry = elts.next();

        // Get search result
        SearchResult res = (SearchResult)entry;
        // do something with it

        // Get entry controls
        if (entry instanceof HasControls) {
            Control[] entryCtls = ((HasControls)entry).getControls();
            // do something with controls
        }
   }

从以下版本开始：
1.3

方法摘要
 Control[] getControls()
从实现此接口的对象中检索 Control 数组。

方法详细信息

getControls

Control[] getControls()
                      throws NamingException
从实现此接口的对象中检索 Control 数组。如果不存在任何控件，则为 null。

返回：
Control 对象所组成的数组（可能为 null）。
抛出：
NamingException - 如果因出错而无法返回控件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InitialLdapContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 InitialLdapContext

java.lang.Object
    继承者  javax.naming.InitialContext
        继承者  javax.naming.directory.InitialDirContext
            继承者  javax.naming.ldap.InitialLdapContext
所有已实现的接口：
Context, DirContext, LdapContext
public class InitialLdapContext
extends InitialDirContext
implements LdapContext

此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

有关同步的详细信息和如何创建初始上下文的策略，请参阅 javax.naming.InitialContext 和 javax.naming.InitialDirContext。

请求控件

创建初始上下文 (InitialLdapContext) 时，可以指定请求控件列表。这些控件将用作由上下文或从上下文派生的上下文执行的所有隐式 LDAP“绑定”操作的请求控件。它们被称为连接请求控件。使用 getConnectControls() 获取上下文的连接请求控件。

提供给初始上下文构造方法的请求控件不能 用作后续上下文操作（如搜索和查找）的上下文请求控件。上下文请求控件可以通过使用 setRequestControls() 设置和更新。

请求控件可以有如下两个与上下文关联的不同集合：连接请求控件和上下文请求控件。对于那些需要发送不能同时应用于上下文操作和任何隐式 LDAP“绑定”操作的关键控件的应用程序而言，这一点是必需的。典型的用户程序将执行以下操作：

 InitialLdapContext lctx = new InitialLdapContext(env, critConnCtls);
 lctx.setRequestControls(critModCtls);
 lctx.modifyAttributes(name, mods);
 Controls[] respCtls =  lctx.getResponseControls();
它首先指定用于创建初始上下文 (critConnCtls) 的关键控件，然后设置上下文的请求控件 (critModCtls) 进行上下文操作。如果出于某种原因 lctx 需要重新连接到服务器，则它将使用 critConnCtls。有关请求控件的更多讨论，请参见 LdapContext 接口。

服务提供者的实现方应该参阅 LdapContext 类描述中的 "Service Provider" 一节，以获取实现的详细信息。

从以下版本开始：
1.3
另请参见：
LdapContext, InitialContext, InitialDirContext, NamingManager.setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder)

字段摘要
从类 javax.naming.InitialContext 继承的字段
defaultInitCtx, gotDefault, myProps
从接口 javax.naming.ldap.LdapContext 继承的字段
CONTROL_FACTORIES
从接口 javax.naming.directory.DirContext 继承的字段
ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE
从接口 javax.naming.Context 继承的字段
APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES
构造方法摘要
InitialLdapContext()
不使用任何环境属性或连接请求控件构造初始上下文。
InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
使用环境属性或连接请求控件构造初始上下文。
方法摘要
ExtendedResponse | extendedOperation(ExtendedRequest request) 执行扩展操作。
Control[] | getConnectControls() 检索对此上下文有效的连接请求控件。
Control[] | getRequestControls() 检索对此上下文有效的请求控件。
Control[] | getResponseControls() 检索对此上下文调用的最后一个方法所生成的响应控件。
LdapContext | newInstance(Control[] reqCtls) 创建此上下文的新实例，使用请求控件进行初始化。
void | reconnect(Control[] connCtls) 使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
void | setRequestControls(Control[] requestControls) 为在此上下文上后续调用的方法设置请求控件。
从类 javax.naming.directory.InitialDirContext 继承的方法
bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search
从类 javax.naming.InitialContext 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, doLookup, doLookup, getDefaultInitCtx, getEnvironment, getNameInNamespace, getNameParser, getNameParser, getURLOrDefaultInitCtx, getURLOrDefaultInitCtx, init, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.naming.directory.DirContext 继承的方法
bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search
从接口 javax.naming.Context 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

构造方法详细信息

InitialLdapContext

public InitialLdapContext()
                   throws NamingException
不使用任何环境属性或连接请求控件构造初始上下文。与 new InitialLdapContext(null) 等效。

抛出：
NamingException - 如果遇到命名异常

InitialLdapContext

public InitialLdapContext(Hashtable<?,?> environment,
                          Control[] connCtls)
                   throws NamingException
使用环境属性或连接请求控件构造初始上下文。有关环境属性的讨论，请参阅 javax.naming.InitialContext。

此构造方法将不修改其参数或保存对它们的引用，但可能保存一个副本。

connCtls 用作基础上下文实例的连接请求控件。有关详细信息请参阅类描述。

参数：
environment - 用于创建初始 DirContext 的环境。null 指示空环境。
connCtls - 初始上下文的连接请求控件。如果为 null，则不使用任何连接请求控件。
抛出：
NamingException - 如果遇到命名异常
另请参见：
reconnect(javax.naming.ldap.Control[]), LdapContext.reconnect(javax.naming.ldap.Control[])
方法详细信息

extendedOperation

public ExtendedResponse extendedOperation(ExtendedRequest request)
                                   throws NamingException
从接口 LdapContext 复制的描述
执行扩展操作。 此方法用于支持 LDAPv3 扩展操作。

指定者：
接口 LdapContext 中的 extendedOperation
参数：
request - 要执行的非 null 请求。
返回：
操作的响应（可能为 null）。null 表示操作没有生成任何响应。
抛出：
NamingException - 如果在执行扩展操作时出错。

newInstance

public LdapContext newInstance(Control[] reqCtls)
                        throws NamingException
从接口 LdapContext 复制的描述
创建此上下文的新实例，使用请求控件进行初始化。 此方法是为了进行多线程访问而创建此上下文新实例的便捷方法。例如，如果多个线程要使用不同的上下文请求控件，则每个线程可以使用此方法获取它自己的此上下文的副本，并设置/获取上下文请求控件，无需与其他线程同步。

新上下文与此上下文具有相同的环境属性和连接请求控件。有关详细信息请参阅类描述。实现可能还允许此上下文和新上下文共享同一个网络连接或其他资源，如果这样做不妨碍这两种上下文各自的独立性。

指定者：
接口 LdapContext 中的 newInstance
参数：
reqCtls - 要用于新上下文的请求控件（可能为 null）。如果为 null，则不使用任何请求控件初始化上下文。
返回：
非 null LdapContext 实例。
抛出：
NamingException - 如果在创建新实例时出错。
另请参见：
InitialLdapContext

reconnect

public void reconnect(Control[] connCtls)
               throws NamingException
从接口 LdapContext 复制的描述
使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。

此方法是一种显式启动 LDAP“绑定”操作的方式。例如，可以使用此方法为 LDAP“绑定”操作设置请求控件，或者显式连接到服务器以获取由 LDAP“绑定”操作返回的响应控件。

此方法将此上下文的 connCtls 设置为其新连接请求控件。此上下文的上下文请求控件将不受影响。调用此方法后，所有后续隐式重接将使用 connCtls 完成。connCtls 还可用作从此上下文派生的新上下文实例的连接请求控件。这些连接请求控件将不受 setRequestControls() 的影响。

服务提供者的实现方应该读取类描述中的“服务提供者”一节，以获取实现详细信息。

指定者：
接口 LdapContext 中的 reconnect
参数：
connCtls - 要使用的控件（可能为 null）。如果为 null，则不使用任何控件。
抛出：
NamingException - 如果重接时出错。
另请参见：
LdapContext.getConnectControls(), LdapContext.newInstance(javax.naming.ldap.Control[])

getConnectControls

public Control[] getConnectControls()
                             throws NamingException
从接口 LdapContext 复制的描述
检索对此上下文有效的连接请求控件。JNDI 实现所拥有的控件是不可变的。调用者既不能修改数组也不能修改控件。

指定者：
接口 LdapContext 中的 getConnectControls
返回：
控件数组（可能为 null）。null 表示没有为此上下文设置任何连接控件。
抛出：
NamingException - 如果在获取请求控件时出错。

setRequestControls

public void setRequestControls(Control[] requestControls)
                        throws NamingException
从接口 LdapContext 复制的描述
为在此上下文上后续调用的方法设置请求控件。JNDI 实现所拥有的请求控件是不可变的。调用者既不能修改数组也不能修改控件。

此操作移除所有以前的请求控件，并添加 requestControls 供在此上下文上调用的后续方法使用。此方法不影响此上下文的连接请求控件。

注意，在下一次调用 setRequestControls() 之前 requestControls 一直有效。如果不想让这些控件继续影响上下文方法，则需要使用 null 或空数组作为参数显式调用 setRequestControls() 来清除它们。要检查对此上下文有效的请求控件，请使用 getRequestControls()。

指定者：
接口 LdapContext 中的 setRequestControls
参数：
requestControls - 要使用的控件（可能为 null）。如果为 null，则不使用任何控件。
抛出：
NamingException - 如果在设置请求控件时出错。
另请参见：
LdapContext.getRequestControls()

getRequestControls

public Control[] getRequestControls()
                             throws NamingException
从接口 LdapContext 复制的描述
检索对此上下文有效的请求控件。JNDI 实现所拥有的请求控件是不可变的。调用者既不能修改数组也不能修改控件。

指定者：
接口 LdapContext 中的 getRequestControls
返回：
控件数组（可能为 null）。null 表示没有为此上下文设置任何请求控件。
抛出：
NamingException - 如果在获取请求控件时出错。
另请参见：
LdapContext.setRequestControls(javax.naming.ldap.Control[])

getResponseControls

public Control[] getResponseControls()
                              throws NamingException
从接口 LdapContext 复制的描述
检索对此上下文调用的最后一个方法所生成的响应控件。JNDI 实现所拥有的响应控件是不可变的。调用者既不能修改数组也不能修改控件。

这些响应控件可能由成功或失败的操作生成。

调用可能返回响应控件的上下文方法时，上一个方法调用生成的响应控件将被清除。getResponseControls()（按照从 LDAP 服务器收到响应控件的顺序） 返回上下文方法使用的 LDAP 操作生成的所有响应控件。调用 getResponseControls() 不清除响应控件。在调用可能返回控件的下一个上下文方法之前，可以多次调用它（并返回相同的控件）。

指定者：
接口 LdapContext 中的 getResponseControls
返回：
控件数组（可能为 null）。如果为 null，则对此上下文调用的上一个方法不会生成任何控件。
抛出：
NamingException - 如果在获取响应控件时出错。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LdapContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
接口 LdapContext

所有超级接口：
Context, DirContext
所有已知实现类：
InitialLdapContext
public interface LdapContext
extends DirContext

此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。 对于不需要这些控件或扩展操作的应用程序，则应该使用更一般的 javax.naming.directory.DirContext 来代替。

关于控件的使用细节

此接口提供对 LDAP v3 控件的支持。在较高级别，这一支持允许用户程序为用户程序调用 Context/DirContext 方法期间执行的 LDAP 操作设置请求控件，并读取从 LDAP 操作得到的响应控件。在实现级别，有些细节用户程序和服务提供者的开发人员都需要理解才能正确地使用请求控件和响应控件。

请求控件

请求控件有两种类型：

  • 影响连接的创建方式的请求控件
  • 影响上下文方法的请求控件
在需要利用 LDAP 服务器建立或重新建立连接时使用前者。在将所有其他 LDAP 操作发送到 LDAP 服务器时使用后者。两种类型的请求控件之间必须存在差别的原因是， JNDI 是一种不直接处理连接的高级 API。服务提供者负责进行所有必需的连接管理。因此，多个上下文实例可能共享单个连接，并且服务提供者可以自由地使用它自己的算法保存连接和网络使用。对上下文实例调用方法时，服务提供者除了执行相应的 LDAP 操作，可能还需要进行一些连接管理。对于连接管理，它使用连接请求控件，而对于常规 LDAP 操作，它使用上下文请求控件。

如果没有显式限定，术语“请求控件”就是指上下文请求控件。

上下文请求控件

上下文实例获取其请求控件有两种方式：
  1. ldapContext.newInstance(reqCtls)
  2. ldapContext.setRequestControls(reqCtls)
其中 ldapContext 是 LdapContext 的实例。为 reqCtls 指定 null 或空数组意味着不存在请求控件。newInstance() 使用 reqCtls 创建上下文的新实例，而 setRequestControls() 将现有上下文实例的请求控件更新为 reqCtls。

与环境属性不同，从某个上下文实例派生的上下文实例不能继承 它的请求控件。派生的上下文实例的上下文请求控件为 null。必须使用 setRequestControls() 显式设置派生的上下文实例的请求控件。

上下文实例的请求控件需要使用方法 getRequestControls() 进行检索。

连接请求控件

可以使用三种方式设置连接请求控件：
  1. new InitialLdapContext(env, connCtls)
  2. refException.getReferralContext(env, connCtls)
  3. ldapContext.reconnect(connCtls);
其中 refException 是 LdapReferralException 的实例，ldapContext 是 LdapContext 的实例。为 connCtls 指定 null 或空数组意味着不存在连接请求控件。

与环境属性一样，从上下文派生的上下文可以继承 它的连接请求控件。通常，使用 InitialLdapContext 构造方法或 LdapReferralContext.getReferralContext() 来初始化连接请求控件。这些连接请求控件可以由共享同一连接的上下文继承，即上下文是从初始或引用上下文派生的。

使用 reconnect() 更改上下文的连接请求控件。调用 ldapContext.reconnect() 仅影响 ldapContext 使用的连接和从 ldapContext 派生的所有新上下文实例。以前与 ldapContext 共享连接的上下文保持不变。即上下文的连接请求控件必须显式更改，更改另一个上下文的连接请求控件对它没有影响。

上下文实例的连接请求控件需要使用方法 getConnectControls() 进行检索。

服务提供者需求

服务提供者用以下方式支持连接和上下文请求控件。上下文请求控件必须在每个上下文实例的基础上相关联，而连接请求控件必须在每个连接实例的基础上相关联。服务提供者必须在环境属性 "java.naming.ldap.control.connect" 中查找连接请求控件，并将此环境属性传递到它创建的上下文实例中。

响应控件

方法 LdapContext.getResponseControls() 用于检索由于调用 Context/DirContext 操作而执行的 LDAP 操作生成的响应控件。结果为基础 LDAP 操作生成的所有响应控件，包括所有隐式重接。要仅获取重接响应控件，请使用 reconnect()，然后使用 getResponseControls()。

参数

作为参数传递给任何方法的 Control[] 数组都为调用者所有。服务提供者将不修改数组，也不保持对它的引用，但它可能保持对数组中个别 Control 对象的引用。任何方法返回的 Control[] 数组都是不可变的，并且不能被调用者或服务提供者进行后续修改。

从以下版本开始：
1.3
另请参见：
InitialLdapContext, LdapReferralException.getReferralContext(java.util.Hashtable,javax.naming.ldap.Control[])

字段摘要
static String CONTROL_FACTORIES
该常量保存用来指定要使用的控件工厂列表的环境属性名称。
从接口 javax.naming.directory.DirContext 继承的字段
ADD_ATTRIBUTE, REMOVE_ATTRIBUTE, REPLACE_ATTRIBUTE
从接口 javax.naming.Context 继承的字段
APPLET, AUTHORITATIVE, BATCHSIZE, DNS_URL, INITIAL_CONTEXT_FACTORY, LANGUAGE, OBJECT_FACTORIES, PROVIDER_URL, REFERRAL, SECURITY_AUTHENTICATION, SECURITY_CREDENTIALS, SECURITY_PRINCIPAL, SECURITY_PROTOCOL, STATE_FACTORIES, URL_PKG_PREFIXES
方法摘要
ExtendedResponse | extendedOperation(ExtendedRequest request) 执行扩展操作。
Control[] | getConnectControls() 检索对此上下文有效的连接请求控件。
Control[] | getRequestControls() 检索对此上下文有效的请求控件。
Control[] | getResponseControls() 检索对此上下文调用的最后一个方法所生成的响应控件。
LdapContext | newInstance(Control[] requestControls) 创建此上下文的新实例，使用请求控件进行初始化。
void | reconnect(Control[] connCtls) 使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
void | setRequestControls(Control[] requestControls) 为在此上下文上后续调用的方法设置请求控件。
从接口 javax.naming.directory.DirContext 继承的方法
bind, bind, createSubcontext, createSubcontext, getAttributes, getAttributes, getAttributes, getAttributes, getSchema, getSchema, getSchemaClassDefinition, getSchemaClassDefinition, modifyAttributes, modifyAttributes, modifyAttributes, modifyAttributes, rebind, rebind, search, search, search, search, search, search, search, search
从接口 javax.naming.Context 继承的方法
addToEnvironment, bind, bind, close, composeName, composeName, createSubcontext, createSubcontext, destroySubcontext, destroySubcontext, getEnvironment, getNameInNamespace, getNameParser, getNameParser, list, list, listBindings, listBindings, lookup, lookup, lookupLink, lookupLink, rebind, rebind, removeFromEnvironment, rename, rename, unbind, unbind

字段详细信息

CONTROL_FACTORIES

static final String CONTROL_FACTORIES
该常量保存用来指定要使用的控件工厂列表的环境属性名称。该属性的值应该是工厂类以冒号分隔的完全限定类名称列表，这些类将在给定另一控件的情况下创建一个控件。有关详细信息，请参见 ControlFactory.getControlInstance()。此属性可以在环境、applet 参数、系统属性或者一个或多个资源文件中指定。

此常量的值是 "java.naming.factory.control"。

另请参见：
ControlFactory, Context.addToEnvironment(java.lang.String, java.lang.Object), Context.removeFromEnvironment(java.lang.String), 常量字段值
方法详细信息

extendedOperation

ExtendedResponse extendedOperation(ExtendedRequest request)
                                   throws NamingException
执行扩展操作。 此方法用于支持 LDAPv3 扩展操作。

参数：
request - 要执行的非 null 请求。
返回：
操作的响应（可能为 null）。null 表示操作没有生成任何响应。
抛出：
NamingException - 如果在执行扩展操作时出错。

newInstance

LdapContext newInstance(Control[] requestControls)
                        throws NamingException
创建此上下文的新实例，使用请求控件进行初始化。 此方法是为了进行多线程访问而创建此上下文新实例的便捷方法。例如，如果多个线程要使用不同的上下文请求控件，则每个线程可以使用此方法获取它自己的此上下文的副本，并设置/获取上下文请求控件，无需与其他线程同步。

新上下文与此上下文具有相同的环境属性和连接请求控件。有关详细信息请参阅类描述。实现可能还允许此上下文和新上下文共享同一个网络连接或其他资源，如果这样做不妨碍这两种上下文各自的独立性。

参数：
requestControls - 要用于新上下文的请求控件（可能为 null）。如果为 null，则不使用任何请求控件初始化上下文。
返回：
非 null LdapContext 实例。
抛出：
NamingException - 如果在创建新实例时出错。
另请参见：
InitialLdapContext

reconnect

void reconnect(Control[] connCtls)
               throws NamingException
使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。

此方法是一种显式启动 LDAP“绑定”操作的方式。例如，可以使用此方法为 LDAP“绑定”操作设置请求控件，或者显式连接到服务器以获取由 LDAP“绑定”操作返回的响应控件。

此方法将此上下文的 connCtls 设置为其新连接请求控件。此上下文的上下文请求控件将不受影响。调用此方法后，所有后续隐式重接将使用 connCtls 完成。connCtls 还可用作从此上下文派生的新上下文实例的连接请求控件。这些连接请求控件将不受 setRequestControls() 的影响。

服务提供者的实现方应该读取类描述中的“服务提供者”一节，以获取实现详细信息。

参数：
connCtls - 要使用的控件（可能为 null）。如果为 null，则不使用任何控件。
抛出：
NamingException - 如果重接时出错。
另请参见：
getConnectControls(), newInstance(javax.naming.ldap.Control[])

getConnectControls

Control[] getConnectControls()
                             throws NamingException
检索对此上下文有效的连接请求控件。JNDI 实现所拥有的控件是不可变的。调用者既不能修改数组也不能修改控件。

返回：
控件数组（可能为 null）。null 表示没有为此上下文设置任何连接控件。
抛出：
NamingException - 如果在获取请求控件时出错。

setRequestControls

void setRequestControls(Control[] requestControls)
                        throws NamingException
为在此上下文上后续调用的方法设置请求控件。JNDI 实现所拥有的请求控件是不可变的。调用者既不能修改数组也不能修改控件。

此操作移除所有以前的请求控件，并添加 requestControls 供在此上下文上调用的后续方法使用。此方法不影响此上下文的连接请求控件。

注意，在下一次调用 setRequestControls() 之前 requestControls 一直有效。如果不想让这些控件继续影响上下文方法，则需要使用 null 或空数组作为参数显式调用 setRequestControls() 来清除它们。要检查对此上下文有效的请求控件，请使用 getRequestControls()。

参数：
requestControls - 要使用的控件（可能为 null）。如果为 null，则不使用任何控件。
抛出：
NamingException - 如果在设置请求控件时出错。
另请参见：
getRequestControls()

getRequestControls

Control[] getRequestControls()
                             throws NamingException
检索对此上下文有效的请求控件。JNDI 实现所拥有的请求控件是不可变的。调用者既不能修改数组也不能修改控件。

返回：
控件数组（可能为 null）。null 表示没有为此上下文设置任何请求控件。
抛出：
NamingException - 如果在获取请求控件时出错。
另请参见：
setRequestControls(javax.naming.ldap.Control[])

getResponseControls

Control[] getResponseControls()
                              throws NamingException
检索对此上下文调用的最后一个方法所生成的响应控件。JNDI 实现所拥有的响应控件是不可变的。调用者既不能修改数组也不能修改控件。

这些响应控件可能由成功或失败的操作生成。

调用可能返回响应控件的上下文方法时，上一个方法调用生成的响应控件将被清除。getResponseControls()（按照从 LDAP 服务器收到响应控件的顺序） 返回上下文方法使用的 LDAP 操作生成的所有响应控件。调用 getResponseControls() 不清除响应控件。在调用可能返回控件的下一个上下文方法之前，可以多次调用它（并返回相同的控件）。

返回：
控件数组（可能为 null）。如果为 null，则对此上下文调用的上一个方法不会生成任何控件。
抛出：
NamingException - 如果在获取响应控件时出错。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LdapName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 LdapName

java.lang.Object
    继承者  javax.naming.ldap.LdapName
所有已实现的接口：
Serializable, Cloneable, Comparable<Object>, Name
public class LdapName
extends Object
implements Name

此类表示 RFC 2253 指定的标识名。标识名（即 DN）由名为相对标识名（即 RDN）的一列有序组件组成。RFC 2253 中描述了 DN 的语法细节。

此类对 RFC 2253 中存在的一些歧义解释如下：

  • RFC 2253 未定义术语“空白”。在其位置使用 ASCII 空白字符 0x20 (" ")。
  • 空白在 ','、';'、'=' 和 '+' 的两边都允许使用。这种空白可以被此代码接受，但不是此代码生成的，在比较名称时将被忽略。
  • 包含 '=' 或非先导 '#' 字符（取消转义）的 AttributeValue 字符串是可以接受的。

传递给 LdapName 或由它返回的字符串名称使用完整的 Unicode 字符集。它们也可能包含一些编码为 UTF-8 的字符，用三字符的子字符串（如 "\\B4"）表示其中每个八位组。但是，它们不能包含编码为 UTF-8 并使用该字符串中的单个字符表示每个八位组的字符：因为这可能会使含义不明确。

LdapName 将恰当地解析所有有效名称，但是在解析无效名称时不会尝试检测所有可能的错误情况。在接受无效名称时，它显得很“大方”。名称的“有效性”在将名称提供给 LDAP 服务器时最终确定，服务器将基于名称的模式信息和互操作性考虑之类的因素来决定接受还是拒绝该名称。

在测试名称的相等性时，属性类型（二进制和字符串值）不区分大小写。值不同但使用等效的引用、转义或 UTF8 十六进制编码的字符串视为相等。多值 RDN 中组件的顺序（如 "ou=Sales+cn=Bob"）无关紧要。

LDAP 名称的组件（即 RDN）已经编号。带有 n 个 RDN 的 LDAP 名称的索引范围从 0 到 n-1。可将该范围写为 [0,n)。最右边的 RDN 位于索引 0 处，最左边的 RDN 位于索引 n-1 处。例如，标识名："CN=Steve Kille, O=Isode Limited, C=GB" 按以下顺序进行编号，范围为从 0 到 2：{C=GB, O=Isode Limited, CN=Steve Kille}。空 LDAP 名称由空 RDN 列表表示。

LdapName 的实例的并发多线程只读访问不必是同步的。

除非另有说明，否则将 null 参数传递给此类中的构造方法或方法的行为都会导致抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
LdapName(List<Rdn> rdns)
在给定已解析 RDN 组件的情况下构造 LDAP 名称。
LdapName(String name)
根据给定标识名构造 LDAP 名称。
方法摘要
Name | add(int posn, Rdn comp) 将单个 RDN 添加到此 LDAP 名称中的指定位置。
Name | add(int posn, String comp) 将单个组件添加到此 LDAP 名称中的指定位置。
Name | add(Rdn comp) 将单个 RDN 添加到此 LDAP 名称的末尾。
Name | add(String comp) 将单个组件添加到此 LDAP 名称的末尾。
Name | addAll(int posn, List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称中的指定位置。
Name | addAll(int posn, Name suffix) 按顺序将名称的组件添加到此名称中的指定位置。
Name | addAll(List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称的末尾。
Name | addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Object | clone() 生成此名称的新副本。
int | compareTo(Object obj) 比较此 LdapName 与指定 Object 的顺序。
boolean | endsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。
boolean | endsWith(Name n) 确定此 LDAP 名称是否以某一指定 LDAP 名称后缀结尾。
boolean | equals(Object obj) 确定两个 LDAP 名称是否相等。
String | get(int posn) 以字符串形式检索此 LDAP 名称的组件。
Enumeration<String> | getAll() 以字符串枚举的形式检索此名称的组件。
Name | getPrefix(int posn) 创建一个名称，其组件由此 LDAP 名称中组件的前缀组成。
Rdn | getRdn(int posn) 以 Rdn 形式检索此 LDAP 名称的 RDN。
List<Rdn> | getRdns() 检索相对标识名列表。
Name | getSuffix(int posn) 创建一个名称，其组件由此 LDAP 名称中组件的后缀组成。
int | hashCode() 计算此 LDAP 名称的哈希码。
boolean | isEmpty() 确定此 LDAP 名称是否为空。
Object | remove(int posn) 从此 LDAP 名称中移除一个组件。
int | size() 检索此 LDAP 名称中的组件数。
boolean | startsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。
boolean | startsWith(Name n) 确定此 LDAP 名称是否从某一指定 LDAP 名称前缀开始。
String | toString() 返回一个此 LDAP 名称的字符串表示形式，该表示形式使用 RFC 2253 定义并在类描述中描述的格式。
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

LdapName

public LdapName(String name)
         throws InvalidNameException
根据给定标识名构造 LDAP 名称。

参数：
name - 此为根据在 RFC 2253 中定义的规则格式化的非 null 标识名。
抛出：
InvalidNameException - 如果检测到违反语法的情况。
另请参见：
Rdn.escapeValue(Object value)

LdapName

public LdapName(List<Rdn> rdns)
在给定已解析 RDN 组件的情况下构造 LDAP 名称。

列表中 RDN 的索引遵从类描述中描述的 RDN 编号方式。

参数：
rdns - 形成此 LDAP 名称的非 null Rdn 列表。
方法详细信息

size

public int size()
检索此 LDAP 名称中的组件数。

指定者：
接口 Name 中的 size
返回：
此 LDAP 名称中的非负组件数。

isEmpty

public boolean isEmpty()
确定此 LDAP 名称是否为空。空名称是没有任何组件的名称。

指定者：
接口 Name 中的 isEmpty
返回：
如果此 LDAP 名称为空，则返回 true，否则返回 false。

getAll

public Enumeration<String> getAll()
以字符串枚举的形式检索此名称的组件。在此枚举上更新此名称的结果是不确定的。如果该名称没有组件，则返回空（非 null）枚举。枚举返回组件的顺序与根据类描述中的描述对组件进行编号的顺序相同。

指定者：
接口 Name 中的 getAll
返回：
此 LDAP 名称组件所组成的非 null 枚举。每个枚举元素都属于 String 类。

get

public String get(int posn)
以字符串形式检索此 LDAP 名称的组件。

指定者：
接口 Name 中的 get
参数：
posn - 要检索的从 0 开始的组件索引。该索引必须在范围 [0,size()) 内。
返回：
位于索引 posn 处的非 null 组件。
抛出：
IndexOutOfBoundsException - 如果 posn 超出指定范围。

getRdn

public Rdn getRdn(int posn)
以 Rdn 形式检索此 LDAP 名称的 RDN。

参数：
posn - 要检索的从 0 开始的 RDN 索引。该索引必须在范围 [0,size()) 内。
返回：
位于索引 posn 处的非 null RDN。
抛出：
IndexOutOfBoundsException - 如果 posn 超出指定范围。

getPrefix

public Name getPrefix(int posn)
创建一个名称，其组件由此 LDAP 名称中组件的前缀组成。对此名称进行的后续更改不会影响返回的名称，反之亦然。

指定者：
接口 Name 中的 getPrefix
参数：
posn - 从 0 开始的组件索引，在该索引处停止。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [0,posn) 之间的组件组成的 LdapName 实例。如果 posn 为零，则返回空 LDAP 名称。
抛出：
IndexOutOfBoundsException - 如果 posn 超出指定范围。

getSuffix

public Name getSuffix(int posn)
创建一个名称，其组件由此 LDAP 名称中组件的后缀组成。对此名称进行的后续更改不会影响返回的名称，反之亦然。

指定者：
接口 Name 中的 getSuffix
参数：
posn - 从 0 开始的组件索引，在该索引处开始。该索引必须在范围 [0,size()] 内。
返回：
由索引范围在 [posn,size()) 之间的组件组成的 LdapName 实例。如果 posn 等于 size()，则返回一个空 LDAP 名称。
抛出：
IndexOutOfBoundsException - 如果 posn 超出指定范围。

startsWith

public boolean startsWith(Name n)
确定此 LDAP 名称是否从某一指定 LDAP 名称前缀开始。如果名称 n 等于 getPrefix(n.size())，则该名称是前缀，换句话说，此 LDAP 名称从 'n' 开始。如果 n 为 null 或者不是按照类描述中的描述进行格式化的 RFC2253，则返回 false。

指定者：
接口 Name 中的 startsWith
参数：
n - 要检查的 LDAP 名称。
返回：
如果 n 是此 LDAP 名称的前缀，则返回 true，否则返回 false。
另请参见：
getPrefix(int posn)

startsWith

public boolean startsWith(List<Rdn> rdns)
确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。如果此 LdapName 至少等于 rdns 的长度，则返回 true，对于范围 [0, rdns.size()) 中的每个位置 p，组件 getRdn(p) 都匹配 rdns.get(p)。否则返回 false。如果 rdns 为 null，则返回 false。

参数：
rdns - 要检查的 Rdn 的序列。
返回：
如果 rdns 形成此 LDAP 名称的前缀，则返回 true，否则返回 false。

endsWith

public boolean endsWith(Name n)
确定此 LDAP 名称是否以某一指定 LDAP 名称后缀结尾。如果名称 n 等于 getSuffix(size()-n.size())，则该名称是后缀，换句话说，此 LDAP 名称以 'n' 结尾。如果 n 为 null 或者不是按照类描述中的描述进行格式化的 RFC2253，则返回 false。

指定者：
接口 Name 中的 endsWith
参数：
n - 要检查的 LDAP 名称。
返回：
如果 n 是此名称的后缀，则返回 true，否则返回 false。
另请参见：
getSuffix(int posn)

endsWith

public boolean endsWith(List<Rdn> rdns)
确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。如果此 LdapName 至少等于 rdns 的长度，则返回 true，对于范围 [size() - rdns.size(), size()) 中的每个位置 p，组件 getRdn(p) 都匹配 rdns.get(p)。否则返回 false。如果 rdns 为 null，则返回 false。

参数：
rdns - 要检查的 Rdn 的序列。
返回：
如果 rdns 形成此 LDAP 名称的后缀，则返回 true，否则返回 false。

addAll

public Name addAll(Name suffix)
            throws InvalidNameException
按顺序将名称的组件添加到此名称的末尾。

指定者：
接口 Name 中的 addAll
参数：
suffix - 要添加的非 null 组件。
返回：
已更新的名称（而不是新实例）。
抛出：
InvalidNameException - 如果 suffix 不是一个有效的 LDAP 名称，或者添加组件将违反此 LDAP 名称的语法规则。

addAll

public Name addAll(List<Rdn> suffixRdns)
按顺序将名称的 RDN 添加到此名称的末尾。

参数：
suffixRdns - 要添加的非 null 后缀 Rdn。
返回：
已更新的名称（而不是新实例）。

addAll

public Name addAll(int posn,
                   Name suffix)
            throws InvalidNameException
按顺序将名称的组件添加到此名称中的指定位置。此 LDAP 名称位于第一个新组件的索引（如果有）处或这之后的组件被上移（远离索引 0），以容纳新组件。

指定者：
接口 Name 中的 addAll
参数：
suffix - 要添加的非 null 组件。
posn - 在其所在位置处添加新组件的索引。该索引必须在范围 [0,size()] 内。
返回：
更新的名称（而不是新实例）。
抛出：
InvalidNameException - 如果 suffix 不是一个有效的 LDAP 名称，或者添加组件将违反此 LDAP 名称的语法规则。
IndexOutOfBoundsException - 如果 posn 超出指定范围。

addAll

public Name addAll(int posn,
                   List<Rdn> suffixRdns)
按顺序将名称的 RDN 添加到此名称中的指定位置。此 LDAP 名称位于第一个新 RDN 的索引（如果有）处或这之后的 RDN 被上移（远离索引 0），以容纳新 RDN。

参数：
suffixRdns - 要添加的非 null 后缀 Rdn。
posn - 在其所在位置处添加后缀 RDN 的索引。该索引必须在范围 [0,size()] 内。
返回：
更新的名称（而不是新实例）。
抛出：
IndexOutOfBoundsException.如果 - posn 超出指定范围。

add

public Name add(String comp)
         throws InvalidNameException
将单个组件添加到此 LDAP 名称的末尾。

指定者：
接口 Name 中的 add
参数：
comp - 要添加的非 null 组件。
返回：
更新的 LdapName，而不是新实例。不能为 null。
抛出：
InvalidNameException - 如果在该名称末尾添加 comp 违反该名称的语法。

add

public Name add(Rdn comp)
将单个 RDN 添加到此 LDAP 名称的末尾。

参数：
comp - 要添加的非 null RDN。
返回：
更新的 LdapName，而不是新实例。不能为 null。

add

public Name add(int posn,
                String comp)
         throws InvalidNameException
将单个组件添加到此 LDAP 名称中的指定位置。此 LDAP 名称位于新组件的索引（如果有）处或这之后的组件被上移（远离索引 0）一位，以容纳新组件。

指定者：
接口 Name 中的 add
参数：
comp - 要添加的非 null 组件。
posn - 在其所在位置处添加新组件的索引。该索引必须在范围 [0,size()] 内。
返回：
更新的 LdapName，而不是新实例。不能为 null。
抛出：
IndexOutOfBoundsException - 如果 posn 超出指定范围。
InvalidNameException - 如果在指定位置添加 comp 违反该名称的语法。

add

public Name add(int posn,
                Rdn comp)
将单个 RDN 添加到此 LDAP 名称中的指定位置。此 LDAP 名称位于新 RDN 的索引（如果有）处或这之后的 RDN 被上移（远离索引 0）一位，以容纳新 RDN。

参数：
comp - 要添加的非 null RDN。
posn - 在其所在位置处添加新 RDN 的索引。该索引必须在范围 [0,size()] 内。
返回：
更新的 LdapName，而不是新实例。不能为 null。
抛出：
IndexOutOfBoundsException - 如果 posn 超出指定范围。

remove

public Object remove(int posn)
              throws InvalidNameException
从此 LDAP 名称中移除一个组件。移除此名称位于指定位置处的组件。索引大于此位置的组件（如果有）都被下移（朝向索引 0）一位。

指定者：
接口 Name 中的 remove
参数：
posn - 要移除的组件的索引。该索引必须在范围 [0,size()) 内。
返回：
移除的组件（一个 String）。
抛出：
IndexOutOfBoundsException - 如果 posn 超出指定范围。
InvalidNameException - 如果删除组件将违反该名称的语法规则。

getRdns

public List<Rdn> getRdns()
检索相对标识名列表。列表的内容不可修改。返回列表中 RDN 的索引遵从类描述中描述的 RDN 编号方式。如果名称没有组件，则返回空列表。

返回：
作为 RDN 列表的名称，这些 RDN 是 Rdn 类的实例。

clone

public Object clone()
生成此名称的新副本。对此名称的组件进行的后续更改不会影响新副本，反之亦然。

指定者：
接口 Name 中的 clone
覆盖：
类 Object 中的 clone
返回：
此 LDAP 名称的副本。
另请参见：
Cloneable

toString

public String toString()
返回一个此 LDAP 名称的字符串表示形式，该表示形式使用 RFC 2253 定义并在类描述中描述的格式。如果名称没有组件，则返回空字符串。

覆盖：
类 Object 中的 toString
返回：
LdapName 的字符串表示形式。

equals

public boolean equals(Object obj)
确定两个 LDAP 名称是否相等。如果 obj 为 null 或者不是 LDAP 名称，则返回 false。

如果一个 LDAP 名称中的每个 RDN 都等于另一个 LDAP 名称中的相应 RDN，则两个 LDAP 名称相等。这意味着两个 LDAP 名称有相同数量的 RDN，并且每个 RDN 与另一个名称中相应 RDN 的 equals() 测试都返回 true。有关 RDN 相等性的定义，请参阅 Rdn.equals(Object obj)。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的对象（可能为 null）。
返回：
如果 obj 等于此 LDAP 名称，则返回 true，否则返回 false。
另请参见：
hashCode()

compareTo

public int compareTo(Object obj)
比较此 LdapName 与指定 Object 的顺序。根据此 Name 小于、等于还是大于指定 Object 分别返回负整数、零或正整数。

如果 obj 为 null 或者不是一个 LdapName 实例，则抛出 ClassCastException。

LDAP 名称的排序遵从字符串比较的字典规则，并将此扩展到应用于 LDAP 名称中的所有 RDN。按照 RDN 的指定顺序将它们排列起来，并按字典顺序进行比较。有关 RDN 比较规则，请参见 Rdn.compareTo(Object obj)。

如果此 LDAP 名称按字典顺序小于 obj，则返回一个负数。如果此 LDAP 名称按字典顺序大于 obj，则返回一个正数。

指定者：
接口 Comparable<Object> 中的 compareTo
指定者：
接口 Name 中的 compareTo
参数：
obj - 要与之比较的非 null LdapName 实例。
返回：
根据此 Name 小于、等于还是大于指定 obj 分别返回负整数、零或正整数。
抛出：
ClassCastException - 如果 obj 为 null 或者不是一个 LdapName。
另请参见：
Comparable.compareTo(Object)

hashCode

public int hashCode()
计算此 LDAP 名称的哈希码。该哈希码是此名称各个 RDN 哈希码的总和。

覆盖：
类 Object 中的 hashCode
返回：
表示此名称的哈希码的 int。
另请参见：
equals(java.lang.Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LdapReferralException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 LdapReferralException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.naming.NamingException
                继承者  javax.naming.ReferralException
                    继承者  javax.naming.ldap.LdapReferralException
所有已实现的接口：
Serializable
public abstract class LdapReferralException
extends ReferralException

此抽象类用于表示 LDAP 引用异常。它通过提供接受请求控件的 getReferralContext() 方法扩展基础 ReferralException。LdapReferralException 是一个抽象类。它具体的实现确定其同步和序列化属性。

作为参数传递给 getReferralContext() 方法的 Control[] 数组为调用者所有。服务提供者将不修改数组，也不保持对它的引用，但它可能保持对数组中个别 Control 对象的引用。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
从类 javax.naming.NamingException 继承的字段
remainingName, resolvedName, resolvedObj, rootException
构造方法摘要
protected | LdapReferralException() 构造一个新的 LdapReferralException 实例。
protected | LdapReferralException(String explanation) 使用所提供的解释构造一个新的 LdapReferralException 实例。
方法摘要
abstract Context | getReferralContext() 使用上下文的环境（但不使用控件）检索继续该方法的上下文。
abstract Context | getReferralContext(Hashtable<?,?> env) 使用环境属性（但不使用控件）检索继续该方法的上下文。
abstract Context | getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。
从类 javax.naming.ReferralException 继承的方法
getReferralInfo, retryReferral, skipReferral
从类 javax.naming.NamingException 继承的方法
appendRemainingComponent, appendRemainingName, getCause, getExplanation, getRemainingName, getResolvedName, getResolvedObj, getRootCause, initCause, setRemainingName, setResolvedName, setResolvedObj, setRootCause, toString, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LdapReferralException

protected LdapReferralException(String explanation)
使用所提供的解释构造一个新的 LdapReferralException 实例。将所有其他字段都设置为 null。

参数：
explanation - 有关此异常的附加详细信息。可以为 null。
另请参见：
Throwable.getMessage()

LdapReferralException

protected LdapReferralException()
构造一个新的 LdapReferralException 实例。将所有字段都设置为 null。

方法详细信息

getReferralContext

public abstract Context getReferralContext()
                                    throws NamingException
使用上下文的环境（但不使用控件）检索继续该方法的上下文。使用抛出 ReferralException 的上下文的环境属性（但不使用控件）创建引用上下文。

该方法等效于

 getReferralContext(ctx.getEnvironment(), null);
其中 ctx 是抛出 ReferralException. 的上下文

在此类中重写该方法仅出于文档编制目的。有关使用此方法的方式，请参阅 ReferralException。

指定者：
类 ReferralException 中的 getReferralContext
返回：
将继续该方法的非 null 上下文。
抛出：
NamingException - 如果遇到命名异常。调用 retryReferral() 或 skipReferral() 来继续处理这些引用。

getReferralContext

public abstract Context getReferralContext(Hashtable<?,?> env)
                                    throws NamingException
使用环境属性（但不使用控件）检索继续该方法的上下文。使用 env 作为其环境属性（但不使用控件）创建引用上下文。

该方法等效于

 getReferralContext(env, null);

在此类中重写该方法仅出于文档编制目的。有关使用此方法的方式，请参阅 ReferralException。

指定者：
类 ReferralException 中的 getReferralContext
参数：
env - 检索引用上下文时要使用的环境（可能为 null）。如果为 null，则不使用环境属性。
返回：
将继续该方法的非 null 上下文。
抛出：
NamingException - 如果遇到命名异常。调用 retryReferral() 或 skipReferral() 来继续处理这些引用。

getReferralContext

public abstract Context getReferralContext(Hashtable<?,?> env,
                                           Control[] reqCtls)
                                    throws NamingException
使用请求控件和环境属性检索继续该方法的上下文。不管在上下文操作期间（例如在搜索枚举期间）是否直接或间接地遇到某一引用，引用异常都应该提供一个继续该操作的上下文。要继续该操作，客户端程序应该使用与初始调用相同的参数重新调用该方法。

reqCtls 在创建到引用的服务器的连接时使用。这些控件将用作上下文和从上下文派生的上下文实例的连接请求控件。reqCtls 同时还是后续上下文操作的上下文请求控件。有关详细信息，请参阅 LdapContext 类描述。

当调用者需要提供请求控件来创建引用上下文时，应该使用此方法，而不是其他两个重载形式。例如，当需要提供与验证有关的特殊控件时，它可能这样做。

服务提供者的实现方应该参阅 LdapContext 类描述中的 "Service Provider" 一节，以获取实现的详细信息。

参数：
reqCtls - 要用于新上下文的请求控件（可能为 null）。如果 null 或空数组意味着不使用任何请求控件。
env - 要用于新上下文的环境属性（可能为 null）。如果为 null，则不使用任何环境属性初始化上下文。
返回：
将继续该方法的非 null 上下文。
抛出：
NamingException - 如果遇到命名异常。调用 retryReferral() 或 skipReferral() 来继续处理这些引用。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ManageReferralControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 ManageReferralControl

java.lang.Object
    继承者  javax.naming.ldap.BasicControl
        继承者  javax.naming.ldap.ManageReferralControl
所有已实现的接口：
Serializable, Control
public final class ManageReferralControl
extends BasicControl

将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。它允许请求者询问或更新这些对象。

此类实现 RFC 3296 中定义的 ManageDsaIT 的 LDAPv3 请求控件。 该控件不具有任何控件值。

从以下版本开始：
1.5
另请参见：
序列化表格

字段摘要
static String OID
ManageReferral 控件的分配对象标识符为 2.16.840.1.113730.3.4.2。
从类 javax.naming.ldap.BasicControl 继承的字段
criticality, id, value
从接口 javax.naming.ldap.Control 继承的字段
CRITICAL, NONCRITICAL
构造方法摘要
ManageReferralControl()
构造一个关键的 ManageReferral 控件。
ManageReferralControl(boolean criticality)
构造一个 ManageReferral 控件。
方法摘要
从类 javax.naming.ldap.BasicControl 继承的方法
getEncodedValue, getID, isCritical
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OID

public static final String OID
ManageReferral 控件的分配对象标识符为 2.16.840.1.113730.3.4.2。

另请参见：
常量字段值
构造方法详细信息

ManageReferralControl

public ManageReferralControl()
构造一个关键的 ManageReferral 控件。

ManageReferralControl

public ManageReferralControl(boolean criticality)
构造一个 ManageReferral 控件。

参数：
criticality - 控件的关键性设置。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PagedResultsControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 PagedResultsControl

java.lang.Object
    继承者  javax.naming.ldap.BasicControl
        继承者  javax.naming.ldap.PagedResultsControl
所有已实现的接口：
Serializable, Control
public final class PagedResultsControl
extends BasicControl

请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。请求方根据搜索操作调用率控制批量返回率。

以下代码示例展示了使用该类的方式：

     // Open an LDAP association
     LdapContext ctx = new InitialLdapContext();

     // Activate paged results
     int pageSize = 20; // 20 entries per page
     byte[] cookie = null;
     int total;
     ctx.setRequestControls(new Control[]{
         new PagedResultsControl(pageSize, Control.CRITICAL) });

     do {
         // Perform the search
         NamingEnumeration results =
             ctx.search("", "(objectclass=*)", new SearchControls());

         // Iterate over a batch of search results
         while (results != null && results.hasMore()) {
             // Display an entry
             SearchResult entry = (SearchResult)results.next();
             System.out.println(entry.getName());
             System.out.println(entry.getAttributes());

             // Handle the entry's response controls (if any)
             if (entry instanceof HasControls) {
                 // ((HasControls)entry).getControls();
             }
         }
         // Examine the paged results control response
         Control[] controls = ctx.getResponseControls();
         if (controls != null) {
             for (int i = 0; i < controls.length; i++) {
                 if (controls[i] instanceof PagedResultsResponseControl) {
                     PagedResultsResponseControl prrc =
                         (PagedResultsResponseControl)controls[i];
                     total = prrc.getResultSize();
                     cookie = prrc.getCookie();
                 } else {
                     // Handle other response controls (if any)
                 }
             }
         }

         // Re-activate paged results
         ctx.setRequestControls(new Control[]{
             new PagedResultsControl(pageSize, cookie, Control.CRITICAL) });
     } while (cookie != null);

     // Close the LDAP association
     ctx.close();
     ...

此类实现在 RFC 2696 中定义的分页结果的 LDAPv3 控件。 控件值具有以下 ASN.1 定义：

     realSearchControlValue ::= SEQUENCE {
         size      INTEGER (0..maxInt),
                           -- requested page size from client
                           -- result set size estimate from server
         cookie    OCTET STRING
     }

从以下版本开始：
1.5
另请参见：
PagedResultsResponseControl, 序列化表格

字段摘要
static String OID
分页结果控件的分配对象标识符为 1.2.840.113556.1.4.319。
从类 javax.naming.ldap.BasicControl 继承的字段
criticality, id, value
从接口 javax.naming.ldap.Control 继承的字段
CRITICAL, NONCRITICAL
构造方法摘要
PagedResultsControl(int pageSize, boolean criticality)
构造一个控件来设置要在每页结果中返回的项数。
PagedResultsControl(int pageSize, byte[] cookie, boolean criticality)
构造一个控件来设置要在每页结果中返回的项数。
方法摘要
从类 javax.naming.ldap.BasicControl 继承的方法
getEncodedValue, getID, isCritical
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OID

public static final String OID
分页结果控件的分配对象标识符为 1.2.840.113556.1.4.319。

另请参见：
常量字段值
构造方法详细信息

PagedResultsControl

public PagedResultsControl(int pageSize,
                           boolean criticality)
                    throws IOException
构造一个控件来设置要在每页结果中返回的项数。

参数：
pageSize - 要在一个页面中返回的项数。
criticality - 如果为 true，则服务器必须遵从控件，按照 pageSize 的指示返回搜索结果或拒绝执行搜索。如果为 false，则服务器不必遵从控件。
抛出：
IOException - 如果在将提供的参数编码到控件中时遇到错误。

PagedResultsControl

public PagedResultsControl(int pageSize,
                           byte[] cookie,
                           boolean criticality)
                    throws IOException
构造一个控件来设置要在每页结果中返回的项数。cookie 是由服务器提供的，可以从分页结果响应控件获取。

通过将 pageSize 设置为零并将 cookie 设置为从服务器收到的最后一个 cookie，可以放弃分页结果序列。

参数：
pageSize - 要在一个页面中返回的项数。
cookie - 服务器生成的 cookie（可能为 null）。
criticality - 如果为 true，则服务器必须遵从控件，按照 pageSize 的指示返回搜索结果或拒绝执行搜索。如果为 false，则服务器不必遵从控件。
抛出：
IOException - 如果在将提供的参数编码到控件中时遇到错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PagedResultsResponseControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 PagedResultsResponseControl

java.lang.Object
    继承者  javax.naming.ldap.BasicControl
        继承者  javax.naming.ldap.PagedResultsResponseControl
所有已实现的接口：
Serializable, Control
public final class PagedResultsResponseControl
extends BasicControl

指示一批搜索结果的末尾。包含结果集中总项数的估计值和一个不透明 cookie。必须将 cookie 提供给下一个搜索操作，这样才能获取下一批的结果。

PagedResultsControl 中的代码示例展示了使用此类的方式。

此类实现在 RFC 2696 中定义的分页结果的 LDAPv3 响应控件。 控件值具有以下 ASN.1 定义：

     realSearchControlValue ::= SEQUENCE {
         size      INTEGER (0..maxInt),
                           -- requested page size from client
                           -- result set size estimate from server
         cookie    OCTET STRING
     }

从以下版本开始：
1.5
另请参见：
PagedResultsControl, 序列化表格

字段摘要
static String OID
分页结果响应控件的分配对象标识符为 1.2.840.113556.1.4.319。
从类 javax.naming.ldap.BasicControl 继承的字段
criticality, id, value
从接口 javax.naming.ldap.Control 继承的字段
CRITICAL, NONCRITICAL
构造方法摘要
PagedResultsResponseControl(String id, boolean criticality, byte[] value)
构造分页结果响应控件。
方法摘要
byte[] | getCookie() 检索服务器生成的 cookie。
int | getResultSize() 检索搜索结果中的项数（估计值）。
从类 javax.naming.ldap.BasicControl 继承的方法
getEncodedValue, getID, isCritical
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OID

public static final String OID
分页结果响应控件的分配对象标识符为 1.2.840.113556.1.4.319。

另请参见：
常量字段值
构造方法详细信息

PagedResultsResponseControl

public PagedResultsResponseControl(String id,
                                   boolean criticality,
                                   byte[] value)
                            throws IOException
构造分页结果响应控件。

参数：
id - 控件的对象标识符字符串。
criticality - 控件的关键性。
value - 控件的 ASN.1 BER 编码值。它不是副本，对值进行的任何更改都将影响控件的内容。
抛出：
IOException - 如果在解码控件值时遇到错误。
方法详细信息

getResultSize

public int getResultSize()
检索搜索结果中的项数（估计值）。

返回：
搜索结果中的项数；如果未知，则为零。

getCookie

public byte[] getCookie()
检索服务器生成的 cookie。当不再有供服务器返回的项时，返回 null。

返回：
服务器生成 cookie（可能为 null）。它不是副本，对 cookie 进行的任何更改都将更新控件的状态，因此不建议进行更改操作。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Rdn (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 Rdn

java.lang.Object
    继承者  javax.naming.ldap.Rdn
所有已实现的接口：
Serializable, Comparable<Object>
public class Rdn
extends Object
implements Serializable, Comparable<Object>

此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。RDN 的一个示例是 "OU=Sales+CN=J.Smith"。在此示例中，RDN 由多个属性类型/值对组成。RDN 根据 LdapName 类描述中的描述进行解析。

Rdn 类将 RDN 表示为属性类型/值映射关系，可以使用 Attributes 查看。此外，它还包含一些便捷方法，允许在 Rdn 由单个类型/值对组成（这是该类的典型使用方式）时对类型和值进行方便地检索。它还包含一些帮助器方法，允许根据 RFC2253 中定义的转义语法转义非格式化的属性值和取消格式化值的转义。对于采用或返回 Object 形式的属性值的方法，该值可能为 String（非转义形式的），也可能为字节数组。

Rdn 将恰当地解析所有有效 RDN，但是在解析无效 RDN 时不会尝试检测所有可能的错误情况。在接受无效 RDN 时，它显得很“大方”。名称的“有效性”在将名称提供给 LDAP 服务器时最终确定，服务器将基于名称的模式信息和互操作性考虑之类的因素来决定接受还是拒绝该名称。

以下示例代码展示了如何使用将类型和值用作参数的构造方法构造 Rdn：

        Rdn rdn = new Rdn("cn", "Juicy, Fruit");
        System.out.println(rdn.toString());
最后一行将打印 cn=Juicy\, Fruit。unescapeValue() 方法可用于取消在初始值 "Juicy, Fruit" 中所产生的转义逗号的转义。escapeValue() 方法在逗号之前添加转义。

可以通过 RFC 2253 中定义的 RDN 的字符串表示形式实例化此类，如以下示例代码所示：

        Rdn rdn = new Rdn("cn=Juicy\\, Fruit");
        System.out.println(rdn.toString());
最后一行将打印 cn=Juicy\, Fruit。

Rdn 实例的并发多线程只读访问不必是同步的。

除非另有说明，否则将 null 参数传递给此类中的构造方法或方法的行为都会导致抛出 NullPointerException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
Rdn(Attributes attrSet)
根据给定属性集构造 Rdn。
Rdn(Rdn rdn)
根据给定 rdn 构造 Rdn。
Rdn(String rdnString)
根据给定字符串构造 Rdn。
Rdn(String type, Object value)
根据给定属性类型和值构造 Rdn。
方法摘要
int | compareTo(Object obj) 比较此 Rdn 与指定 Object 的顺序。
boolean | equals(Object obj) 比较指定 Object 与此 Rdn 的相等性。
static String | escapeValue(Object val) 在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。
String | getType() 检索一个此 Rdn 的类型。
Object | getValue() 检索一个此 Rdn 的值。
int | hashCode() 返回此 RDN 的哈希码。
int | size() 检索此 Rdn 中的属性类型/值对的数目。
Attributes | toAttributes() 检索此 Rdn 中包含的类型/值映射关系的 Attributes 视图。
String | toString() 以字符串形式返回此 Rdn，该字符串使用由 RFC 2253 定义并在 LdapName 类描述中描述的格式表示。
static Object | unescapeValue(String val) 在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Rdn

public Rdn(Attributes attrSet)
    throws InvalidNameException
根据给定属性集构造 Rdn。参见 Attributes。

字符串属性值不会被解释为 RFC 2253 格式的 RDN 字符串。即这些值是按字面意义（不解析）使用的，假定被取消了转义。

参数：
attrSet - 包含类型/值映射关系的非 null 非空属性。
抛出：
InvalidNameException - 如果无法使用 attrSet 的内容构造有效的 RDN。

Rdn

public Rdn(String rdnString)
    throws InvalidNameException
根据给定字符串构造 Rdn。此构造方法采用根据 RFC 2253 中定义和在 LdapName 类描述中描述的规则格式化的字符串。

参数：
rdnString - 非 null 和非空 RFC2253 格式化字符串。
抛出：
InvalidNameException - 如果在解析 rdnString 期间发生语法错误。

Rdn

public Rdn(Rdn rdn)
根据给定 rdn 构造 Rdn。将 rdn 的内容简单地复制到新创建的 Rdn 中。

参数：
rdn - 要复制的非 null Rdn。

Rdn

public Rdn(String type,
           Object value)
    throws InvalidNameException
根据给定属性类型和值构造 Rdn。字符串属性值不会被解释为 RFC 2253 格式的 RDN 字符串。即这些值是按字面意义（不解析）使用的，假定被取消了转义。

参数：
type - 非 null 和非空字符串属性类型。
value - 非 null 和非空属性值。
抛出：
InvalidNameException - 如果无法使用类型/值构造有效的 RDN。
另请参见：
toString()
方法详细信息

getValue

public Object getValue()
检索一个此 Rdn 的值。当 RDN 包含单个类型和值的映射关系（常见的 RDN 用法）时，此为获取值的便捷方法。

对于多值 RDN，此方法返回与 getType() 方法返回的类型相对应的值。

返回：
非 null 属性值。

getType

public String getType()
检索一个此 Rdn 的类型。当 RDN 包含单个类型和值的映射关系（常见的 RDN 用法）时，此为获取类型的便捷方法。

对于多值 RDN，类型/值对不具有对其定义的任何特定顺序。在这种情况下，此方法返回一种类型/值对的类型。getValue() 方法返回与此方法返回的类型相对应的值。

返回：
非 null 属性类型。

toString

public String toString()
以字符串形式返回此 Rdn，该字符串使用由 RFC 2253 定义并在 LdapName 类描述中描述的格式表示。

覆盖：
类 Object 中的 toString
返回：
Rdn 的字符串表示形式。

compareTo

public int compareTo(Object obj)
比较此 Rdn 与指定 Object 的顺序。根据此 Rdn 小于、等于还是大于指定 Object 分别返回负整数、零或正整数。

如果 obj 为 null 或者不是一个 Rdn 实例，则抛出 ClassCastException。

将 RDN 的属性类型和值对并肩排列起来，并按字典顺序进行比较。多值 Rdn 中组件的顺序（如 "ou=Sales+cn=Bob"）无关紧要。

指定者：
接口 Comparable<Object> 中的 compareTo
参数：
obj - 要与之比较的非 null 对象。
返回：
根据此 Rdn 小于、等于还是大于指定 Object 分别返回负整数、零或正整数。
抛出：
ClassCastException - 如果 obj 为 null 或者不是一个 Rdn。

equals

public boolean equals(Object obj)
比较指定 Object 与此 Rdn 的相等性。如果给定对象也是 Rdn 并且两个 Rdn 表示相同的属性类型和值的映射关系，则返回 true。多值 Rdn 中组件的顺序（如 "ou=Sales+cn=Bob"）无关紧要。

按照以下方式进行类型和值的相等性匹配：

  • 比较类型的相等性，忽略大小写。
  • 值不同但使用等效的引用、转义或 UTF8 十六进制编码的字符串视为相等。在比较过程中忽略值的大小写。

如果 obj 为 null 或者不是一个 Rdn 实例，则返回 false。

覆盖：
类 Object 中的 equals
参数：
obj - 要与此 Rdn 进行相等性比较的对象。
返回：
如果指定的对象与此 Rdn 相等，则返回 true。
另请参见：
hashCode()

hashCode

public int hashCode()
返回此 RDN 的哈希码。两个相等的（根据 equals 方法） RDN 将具有相同的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
表示此 Rdn 哈希码的 int。
另请参见：
equals(java.lang.Object)

toAttributes

public Attributes toAttributes()
检索此 Rdn 中包含的类型/值映射关系的 Attributes 视图。

返回：
包含此 Rdn 的类型/值映射关系的非 null 属性。

size

public int size()
检索此 Rdn 中的属性类型/值对的数目。

返回：
此 Rdn 中非负的类型/值对的数目。

escapeValue

public static String escapeValue(Object val)
在给定属性值的情况下返回根据 RFC 2253 中指定的规则转义的字符串。

例如，如果 val 为 "Sue, Grabbit and Runn"，则此方法返回的转义值为 "Sue\, Grabbit and Runn"。

将字符串值表示为 String，将二进制值表示为字节数组。

参数：
val - 要转义的非 null 对象。
返回：
转义的字符串值。
抛出：
ClassCastException - 如果 val 不是 String 或字节数组。

unescapeValue

public static Object unescapeValue(String val)
在给定根据 RFC 2253 中指定的规则进行格式化的属性值字符串的情况下，返回未格式化的值。移除转义和引用，并将十六进制编码的 UTF-8 转换为等效的 UTF-16 字符。以 String 形式返回字符串值，以字节数组形式返回二进制值。

合法值和非法值在 RFC 2253 中定义。此方法在接受值方面要求并不严格，它不会捕获所有的非法值。因此，传入非法值时，不一定触发 IllegalArgumentException。

参数：
val - 要取消转义的非 null 字符串。
返回：
转义值。
抛出：
IllegalArgumentException - 当提供非法值时。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SortControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 SortControl

java.lang.Object
    继承者  javax.naming.ldap.BasicControl
        继承者  javax.naming.ldap.SortControl
所有已实现的接口：
Serializable, Control
public final class SortControl
extends BasicControl

请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。使用一个或多个排序键所组成的有序列表与关联的排序参数一起指定排序标准。搜索结果根据排序控件中提供的参数在 LDAP 服务器排序，然后返回给请求方。如果服务器上不支持排序（而排序控件被标记为关键），则不执行搜索操作并返回错误。

以下代码示例展示了使用该类的方式：

     // Open an LDAP association
     LdapContext ctx = new InitialLdapContext();

     // Activate sorting
     String sortKey = "cn";
     ctx.setRequestControls(new Control[]{
         new SortControl(sortKey, Control.CRITICAL) });

     // Perform a search
     NamingEnumeration results =
         ctx.search("", "(objectclass=*)", new SearchControls());

     // Iterate over search results
     while (results != null && results.hasMore()) {
         // Display an entry
         SearchResult entry = (SearchResult)results.next();
         System.out.println(entry.getName());
         System.out.println(entry.getAttributes());

         // Handle the entry's response controls (if any)
         if (entry instanceof HasControls) {
             // ((HasControls)entry).getControls();
         }
     }
     // Examine the sort control response
     Control[] controls = ctx.getResponseControls();
     if (controls != null) {
         for (int i = 0; i < controls.length; i++) {
             if (controls[i] instanceof SortResponseControl) {
                 SortResponseControl src = (SortResponseControl)controls[i];
                 if (! src.isSorted()) {
                     throw src.getException();
                 }
             } else {
                 // Handle other response controls (if any)
             }
         }
     }

     // Close the LDAP association
     ctx.close();
     ...

此类实现在 RFC 2891 中定义的用于服务器端排序的 LDAPv3 请求控件。 控件值具有以下 ASN.1 定义：

     SortKeyList ::= SEQUENCE OF SEQUENCE {
         attributeType     AttributeDescription,
         orderingRule  [0] MatchingRuleId OPTIONAL,
         reverseOrder  [1] BOOLEAN DEFAULT FALSE }

从以下版本开始：
1.5
另请参见：
SortKey, SortResponseControl, 序列化表格

字段摘要
static String OID
服务器端排序控件的分配对象标识符为 1.2.840.113556.1.4.473。
从类 javax.naming.ldap.BasicControl 继承的字段
criticality, id, value
从接口 javax.naming.ldap.Control 继承的字段
CRITICAL, NONCRITICAL
构造方法摘要
SortControl(SortKey[] sortBy, boolean criticality)
构造一个控件来对排序键列表进行排序。
SortControl(String[] sortBy, boolean criticality)
构造一个控件来按升序对属性列表进行排序。
SortControl(String sortBy, boolean criticality)
构造一个控件来按升序对单个属性进行排序。
方法摘要
从类 javax.naming.ldap.BasicControl 继承的方法
getEncodedValue, getID, isCritical
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OID

public static final String OID
服务器端排序控件的分配对象标识符为 1.2.840.113556.1.4.473。

另请参见：
常量字段值
构造方法详细信息

SortControl

public SortControl(String sortBy,
                   boolean criticality)
            throws IOException
构造一个控件来按升序对单个属性进行排序。使用为指定属性定义的排序匹配规则执行排序。

参数：
sortBy - 用于排序的属性 ID。
criticality - 如果为 true，则服务器属性遵从控件，按照请求返回搜索结果或拒绝执行搜索。如果为 false，则服务器不必遵从控件。
抛出：
IOException - 如果在编码控件中提供的参数时遇到错误。

SortControl

public SortControl(String[] sortBy,
                   boolean criticality)
            throws IOException
构造一个控件来按升序对属性列表进行排序。使用为每个指定属性定义的排序匹配规则执行排序。

参数：
sortBy - 用于排序的非 null 属性 ID 列表。列表按从高到低的排序键优先级顺序排列。
criticality - 如果为 true，则服务器属性遵从控件，按照请求返回搜索结果或拒绝执行搜索。如果为 false，则服务器不必遵从控件。
抛出：
IOException - 如果在编码控件中提供的参数时遇到错误。

SortControl

public SortControl(SortKey[] sortBy,
                   boolean criticality)
            throws IOException
构造一个控件来对排序键列表进行排序。每个排序键都指定要使用的排序顺序和排序匹配规则。

参数：
sortBy - 用于排序的非 null 键列表。列表按从高到低的排序键优先级顺序排列。
criticality - 如果为 true，则服务器属性遵从控件，按照请求返回搜索结果或拒绝执行搜索。如果为 false，则服务器不必遵从控件。
抛出：
IOException - 如果在编码控件中提供的参数时遇到错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SortKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 SortKey

java.lang.Object
    继承者  javax.naming.ldap.SortKey

public class SortKey
extends Object

排序键及其关联的排序参数。此类实现在 RFC 2891 中定义的、LDAPv3 控件用来在服务器端排序搜索结果的排序键。

从以下版本开始：
1.5
另请参见：
SortControl

构造方法摘要
SortKey(String attrID)
创建属性的默认排序键。
SortKey(String attrID, boolean ascendingOrder, String matchingRuleID)
创建属性的排序键。
方法摘要
String | getAttributeID() 检索排序键的属性 ID。
String | getMatchingRuleID() 检索用于排序属性值的匹配规则 ID。
boolean | isAscending() 确定排序顺序。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SortKey

public SortKey(String attrID)
创建属性的默认排序键。条目将根据指定的属性并使用为该属性定义的排序匹配规则以升序进行排序。

参数：
attrID - 要用作排序键的非 null 属性 ID。

SortKey

public SortKey(String attrID,
               boolean ascendingOrder,
               String matchingRuleID)
创建属性的排序键。条目将根据指定属性并使用指定匹配规则（如果提供）以指定排序顺序进行排序。

参数：
attrID - 要用作排序键的非 null 属性 ID。
ascendingOrder - 如果为 true，则条目将以升序进行排序。否则将以降序进行排列。
matchingRuleID - 用来排序属性值的匹配规则的 ID（可能为 null）。如果未指定，则使用为排序键属性定义的排序匹配规则。
方法详细信息

getAttributeID

public String getAttributeID()
检索排序键的属性 ID。

返回：
排序键的非 null 属性 ID。

isAscending

public boolean isAscending()
确定排序顺序。

返回：
如果排序顺序为升序，则返回 true；如果为降序，则返回 false。

getMatchingRuleID

public String getMatchingRuleID()
检索用于排序属性值的匹配规则 ID。

返回：
匹配规则 ID（可能为 null）。如果为 null，则使用为排序键属性定义的排序匹配规则。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SortResponseControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 SortResponseControl

java.lang.Object
    继承者  javax.naming.ldap.BasicControl
        继承者  javax.naming.ldap.SortResponseControl
所有已实现的接口：
Serializable, Control
public final class SortResponseControl
extends BasicControl

指示搜索结果的请求排序是否成功。当结果代码指示成功时，结果已按照请求进行了排序。否则，排序失败，同时服务器可能提供关于错误原因的附加详细信息。

SortControl 中的代码示例展示了使用此类的方式。

此类实现在 RFC 2891 中定义的用于服务器端排序的 LDAPv3 响应控件。 控件值具有以下 ASN.1 定义：

     SortResult ::= SEQUENCE {
        sortResult  ENUMERATED {
            success                   (0), -- results are sorted
            operationsError           (1), -- server internal failure
            timeLimitExceeded         (3), -- timelimit reached before
                                           -- sorting was completed
            strongAuthRequired        (8), -- refused to return sorted
                                           -- results via insecure
                                           -- protocol
            adminLimitExceeded       (11), -- too many matching entries
                                           -- for the server to sort
            noSuchAttribute          (16), -- unrecognized attribute
                                           -- type in sort key
            inappropriateMatching    (18), -- unrecognized or inappro-
                                           -- priate matching rule in
                                           -- sort key
            insufficientAccessRights (50), -- refused to return sorted
                                           -- results to this client
            busy                     (51), -- too busy to process
            unwillingToPerform       (53), -- unable to sort
            other                    (80)
            },
      attributeType [0] AttributeType OPTIONAL }

从以下版本开始：
1.5
另请参见：
SortControl, 序列化表格

字段摘要
static String OID
服务器端排序响应控件的分配对象标识符为 1.2.840.113556.1.4.474。
从类 javax.naming.ldap.BasicControl 继承的字段
criticality, id, value
从接口 javax.naming.ldap.Control 继承的字段
CRITICAL, NONCRITICAL
构造方法摘要
SortResponseControl(String id, boolean criticality, byte[] value)
构造一个控件来指示排序请求的结果。
方法摘要
String | getAttributeID() 检索导致排序失败的属性的 ID。
NamingException | getException() 检索适合结果代码的 NamingException。
int | getResultCode() 检索排序操作的 LDAP 结果代码。
boolean | isSorted() 确定是否已成功排序搜索结果。
从类 javax.naming.ldap.BasicControl 继承的方法
getEncodedValue, getID, isCritical
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OID

public static final String OID
服务器端排序响应控件的分配对象标识符为 1.2.840.113556.1.4.474。

另请参见：
常量字段值
构造方法详细信息

SortResponseControl

public SortResponseControl(String id,
                           boolean criticality,
                           byte[] value)
                    throws IOException
构造一个控件来指示排序请求的结果。

参数：
id - 此控件的对象标识符字符串。
criticality - 控件的关键性。
value - 控件的 ASN.1 BER 编码值。它不是副本，对值进行的任何更改都将影响控件的内容。
抛出：
IOException - 如果在解码控件值时遇到错误。
方法详细信息

isSorted

public boolean isSorted()
确定是否已成功排序搜索结果。如果在排序过程中出错，则抛出 NamingException。

返回：
如果已排序搜索结果，则返回 true。

getResultCode

public int getResultCode()
检索排序操作的 LDAP 结果代码。

返回：
结果代码。值为零指示成功。

getAttributeID

public String getAttributeID()
检索导致排序失败的属性的 ID。如果服务器没有返回任何 ID，则返回 null。

返回：
错误属性的 ID（可能为 null）。

getException

public NamingException getException()
检索适合结果代码的 NamingException。

返回：
如果结果代码指示成功，则返回 NamingException 或 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StartTlsRequest (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 StartTlsRequest

java.lang.Object
    继承者  javax.naming.ldap.StartTlsRequest
所有已实现的接口：
Serializable, ExtendedRequest
public class StartTlsRequest
extends Object
implements ExtendedRequest

此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。 StartTLS 的对象标识符为 1.3.6.1.4.1.1466.20037，没有定义任何扩展请求值。

使用 StartTlsRequest/StartTlsResponse 在与 JNDI 上下文（对该上下文调用 extendedOperation()）关联的现有 LDAP 连接上建立 TLS 连接。通常，JNDI 程序使用以下这些类。

 import javax.naming.ldap.*;

 // Open an LDAP association
 LdapContext ctx = new InitialLdapContext();

 // Perform a StartTLS extended operation
 StartTlsResponse tls =
     (StartTlsResponse) ctx.extendedOperation(new StartTlsRequest());

 // Open a TLS connection (over the existing LDAP association) and get details
 // of the negotiated TLS session: cipher suite, peer certificate, etc.
 SSLSession session = tls.negotiate();

 // ... use ctx to perform protected LDAP operations

 // Close the TLS connection (revert back to the underlying LDAP association)
 tls.close();

 // ... use ctx to perform unprotected LDAP operations

 // Close the LDAP association
 ctx.close;

从以下版本开始：
1.4
另请参见：
StartTlsResponse, 序列化表格

字段摘要
static String OID
StartTLS 扩展请求的分配对象标识符为 1.3.6.1.4.1.1466.20037。
构造方法摘要
StartTlsRequest()
构造 StartTLS 扩展请求。
方法摘要
ExtendedResponse | createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。
byte[] | getEncodedValue() 检索 StartTLS 请求的 ASN.1 BER 编码值。
String | getID() 检索 StartTLS 请求的对象标识符字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OID

public static final String OID
StartTLS 扩展请求的分配对象标识符为 1.3.6.1.4.1.1466.20037。

另请参见：
常量字段值
构造方法详细信息

StartTlsRequest

public StartTlsRequest()
构造 StartTLS 扩展请求。

方法详细信息

getID

public String getID()
检索 StartTLS 请求的对象标识符字符串。

指定者：
接口 ExtendedRequest 中的 getID
返回：
对象标识符字符串 "1.3.6.1.4.1.1466.20037"。

getEncodedValue

public byte[] getEncodedValue()
检索 StartTLS 请求的 ASN.1 BER 编码值。因为该请求没有定义任何值，所以始终返回 null。

指定者：
接口 ExtendedRequest 中的 getEncodedValue
返回：
null 值。

createExtendedResponse

public ExtendedResponse createExtendedResponse(String id,
                                               byte[] berValue,
                                               int offset,
                                               int length)
                                        throws NamingException
创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。

结果必须为 StartTlsResponse 的具体子类，并且必须具有不带参数的公共构造方法。

此方法通过查找具有以下名称的配置文件来查找实现类：

META-INF/services/javax.naming.ldap.StartTlsResponse
配置文件及其相应的实现类对于调用线程的上下文类加载器而言必须是可访问的。

每个配置文件应该包含一个完全限定类名称列表，每行一个类名。忽略各名称周围的空格字符和制表符以及空行。注释字符为 '#' (0x23)；将忽略每行第一个注释字符后面的所有字符。文件必须使用 UTF-8 编码。

此方法将返回它能够从类名称列表（通过配置文件收集）成功加载和实例化的第一个实现类的实例。此方法使用调用线程的上下文类加载器查找配置文件和加载实现类。

如果使用此方式找不到任何类，则此方法将使用特定于实现的方式来查找实现。如果一个也找不到，则抛出 NamingException。

指定者：
接口 ExtendedRequest 中的 createExtendedResponse
参数：
id - 扩展响应的对象标识符。其值必须为 "1.3.6.1.4.1.1466.20037" 或 null。两个值是等价的。
berValue - 扩展响应的 ASN.1 BER 编码值（可能为 null）。此为原始 BER 字节，包括响应值的标记和长度。它不包括响应 OID。它的值将被忽略，因为不要求 Start TLS 响应包含任何响应值。
offset - berValue 中要使用的字节的开始位置。它的值将被忽略，因为不要求 Start TLS 响应包含任何响应值。
length - berValue 中要使用的字节数。它的值将被忽略，因为不要求 Start TLS 响应包含任何响应值。
返回：
StartTLS 扩展响应对象。
抛出：
NamingException - 如果在创建 StartTLS 扩展响应对象时遇到命名异常。
另请参见：
ExtendedResponse
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StartTlsResponse (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 StartTlsResponse

java.lang.Object
    继承者  javax.naming.ldap.StartTlsResponse
所有已实现的接口：
Serializable, ExtendedResponse
public abstract class StartTlsResponse
extends Object
implements ExtendedResponse

此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。 StartTLS 的对象标识符为 1.3.6.1.4.1.1466.20037，没有定义任何扩展响应值。

使用 Start TLS 扩展请求和响应在与 JNDI 上下文（对该上下文调用 extendedOperation()）关联的现有 LDAP 连接上建立 TLS 连接。通常，JNDI 程序使用以下 Start TLS 扩展请求和响应类。

 import javax.naming.ldap.*;

 // Open an LDAP association
 LdapContext ctx = new InitialLdapContext();

 // Perform a StartTLS extended operation
 StartTlsResponse tls =
     (StartTlsResponse) ctx.extendedOperation(new StartTlsRequest());

 // Open a TLS connection (over the existing LDAP association) and get details
 // of the negotiated TLS session: cipher suite, peer certificate, ...
 SSLSession session = tls.negotiate();

 // ... use ctx to perform protected LDAP operations

 // Close the TLS connection (revert back to the underlying LDAP association)
 tls.close();

 // ... use ctx to perform unprotected LDAP operations

 // Close the LDAP association
 ctx.close;

从以下版本开始：
1.4
另请参见：
StartTlsRequest, 序列化表格

字段摘要
static String OID
StartTLS 扩展响应的分配对象标识符为 1.3.6.1.4.1.1466.20037。
构造方法摘要
protected StartTlsResponse()
构造 StartTLS 扩展响应。
方法摘要
abstract void | close() 妥善地关闭 TLS 连接并转换回底层连接。
byte[] | getEncodedValue() 检索 StartTLS 响应的 ASN.1 BER 编码值。
String | getID() 检索 StartTLS 响应的对象标识符字符串。
abstract SSLSession | negotiate() 使用默认的 SSL 套接字工厂协商 TLS 会话。
abstract SSLSession | negotiate(SSLSocketFactory factory) 使用 SSL 套接字工厂协商 TLS 会话。
abstract void | setEnabledCipherSuites(String[] suites) 重写在 TLS 连接上启用的密码套件的默认列表。
abstract void | setHostnameVerifier(HostnameVerifier verifier) 设置在已完成 TLS 握手且默认主机名校验失败后供 negotiate() 使用的主机名校验器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

OID

public static final String OID
StartTLS 扩展响应的分配对象标识符为 1.3.6.1.4.1.1466.20037。

另请参见：
常量字段值
构造方法详细信息

StartTlsResponse

protected StartTlsResponse()
构造 StartTLS 扩展响应。具体子类必须具有不带参数的公共构造方法。

方法详细信息

getID

public String getID()
检索 StartTLS 响应的对象标识符字符串。

指定者：
接口 ExtendedResponse 中的 getID
返回：
对象标识符字符串 "1.3.6.1.4.1.1466.20037"。

getEncodedValue

public byte[] getEncodedValue()
检索 StartTLS 响应的 ASN.1 BER 编码值。因为响应没有定义任何值，所以始终返回 null。

指定者：
接口 ExtendedResponse 中的 getEncodedValue
返回：
null 值。

setEnabledCipherSuites

public abstract void setEnabledCipherSuites(String[] suites)
重写在 TLS 连接上启用的密码套件的默认列表。密码套件必须已经作为受支持的项由 SSLSocketFactory.getSupportedCipherSuites() 列出。即使已经启用套件，它仍然有可能不可用，因为有可能同位体不支持它，或者必需的证书（或私钥）不可用。

参数：
suites - 要启用的所有密码套件的非 null 名称列表。
另请参见：
negotiate()

setHostnameVerifier

public abstract void setHostnameVerifier(HostnameVerifier verifier)
设置在已完成 TLS 握手且默认主机名校验失败后供 negotiate() 使用的主机名校验器。setHostnameVerifier() 必须在调用 negotiate() 前调用才能生效。如果在 negotiate() 之后调用，则此方法不执行任何操作。

参数：
verifier - 非 null 主机名校验器回调。
另请参见：
negotiate()

negotiate

public abstract SSLSession negotiate()
                              throws IOException
使用默认的 SSL 套接字工厂协商 TLS 会话。

此方法等效于 negotiate(null)。

返回：
协商的 SSL 会话
抛出：
IOException - 如果在建立 TLS 会话时遇到 IO 错误。
另请参见：
setEnabledCipherSuites(java.lang.String[]), setHostnameVerifier(javax.net.ssl.HostnameVerifier)

negotiate

public abstract SSLSession negotiate(SSLSocketFactory factory)
                              throws IOException
使用 SSL 套接字工厂协商 TLS 会话。

使用提供的 SSL 套接字工厂创建 SSL 套接字，并将其附加到现有连接上。执行 TLS 握手并返回协商的会话信息。

如果密码套件是通过 setEnabledCipherSuites 设置的，则需要在 TLS 握手开始之前启用这些套件。

主机名校验在 TLS 握手完成之后执行。默认的主机名校验将服务器主机名与存在于服务器证书中的主机名信息进行匹配。如果此校验失败且没有通过 setHostnameVerifier 设置任何回调，则协商失败。如果此校验失败但通过 setHostnameVerifier 设置了回调，则使用回调确定协商是否成功。

如果发生错误，则关闭 SSL 套接字并抛出 IOException。底层连接保持原样。

参数：
factory - 要使用的 SSL 套接字工厂（可能为 null）。如果为 null，则使用默认的 SSL 套接字工厂。
返回：
协商的 SSL 会话
抛出：
IOException - 如果在建立 TLS 会话时遇到 IO 错误。
另请参见：
setEnabledCipherSuites(java.lang.String[]), setHostnameVerifier(javax.net.ssl.HostnameVerifier)

close

public abstract void close()
                    throws IOException
妥善地关闭 TLS 连接并转换回底层连接。

抛出：
IOException - 如果在关闭 TLS 连接时遇到 IO 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsolicitedNotification (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
接口 UnsolicitedNotification

所有超级接口：
ExtendedResponse, HasControls, Serializable
public interface UnsolicitedNotification
extends ExtendedResponse, HasControls

此接口表示在 RFC 2251 中定义的未经请求的通知。未经请求的通知将被 LDAP 服务器发送到 LDAP 客户端，该客户端无需进行任何请求操作。其格式是扩展响应 (ExtendedResponse) 的格式。

从以下版本开始：
1.3
另请参见：
ExtendedResponse, UnsolicitedNotificationEvent, UnsolicitedNotificationListener

方法摘要
NamingException | getException() 检索使用服务器发送的信息构造的异常。
String[] | getReferrals() 检索服务器发送的引用。
从接口 javax.naming.ldap.ExtendedResponse 继承的方法
getEncodedValue, getID
从接口 javax.naming.ldap.HasControls 继承的方法
getControls

方法详细信息

getReferrals

String[] getReferrals()
检索服务器发送的引用。

返回：
引用数组（可能为 null），每个引用由一个 URL 字符串表示。如果为 null，则服务器不发送任何引用。

getException

NamingException getException()
检索使用服务器发送的信息构造的异常。

返回：
使用服务器发送的信息构造的异常（可能为 null）。如果为 null，则“成功”状态由服务器指定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsolicitedNotificationEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
类 UnsolicitedNotificationEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.naming.ldap.UnsolicitedNotificationEvent
所有已实现的接口：
Serializable
public class UnsolicitedNotificationEvent
extends EventObject

此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

从以下版本开始：
1.3
另请参见：
UnsolicitedNotification, UnsolicitedNotificationListener, EventContext.addNamingListener(javax.naming.Name, int, javax.naming.event.NamingListener), EventDirContext.addNamingListener(javax.naming.Name, java.lang.String, javax.naming.directory.SearchControls, javax.naming.event.NamingListener), EventContext.removeNamingListener(javax.naming.event.NamingListener), 序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
UnsolicitedNotificationEvent(Object src, UnsolicitedNotification notice)
构造一个新的 UnsolicitedNotificationEvent 实例。
方法摘要
void | dispatch(UnsolicitedNotificationListener listener) 使用此事件对侦听器调用 notificationReceived() 方法。
UnsolicitedNotification | getNotification() 返回未经请求的通知。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsolicitedNotificationEvent

public UnsolicitedNotificationEvent(Object src,
                                    UnsolicitedNotification notice)
构造一个新的 UnsolicitedNotificationEvent 实例。

参数：
src - 触发事件的非 null 源。
notice - 未经请求的非 null 通知。
方法详细信息

getNotification

public UnsolicitedNotification getNotification()
返回未经请求的通知。

返回：
导致触发此事件的未经请求的非 null 通知。

dispatch

public void dispatch(UnsolicitedNotificationListener listener)
使用此事件对侦听器调用 notificationReceived() 方法。

参数：
listener - 要调用 notificationReceived 方法的非 null 侦听器。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsolicitedNotificationListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.ldap
接口 UnsolicitedNotificationListener

所有超级接口：
EventListener, NamingListener
public interface UnsolicitedNotificationListener
extends NamingListener

此接口用于处理 UnsolicitedNotificationEvent。“未经请求的通知”在 RFC 2251 中定义。它允许服务器将未经请求的通知发送到客户端。UnsolicitedNotificationListener 必须：

  1. 实现此接口及其方法
  2. 实现 NamingListener.namingExceptionThrown()，以便在尝试收集未经请求的通知事件期间抛出异常时得到通知。
  3. 使用 EventContext 或 EventDirContext 中的 addNamingListener() 方法之一向上下文注册。对于 UnsolicitedNotificationListener 而言，这些方法只能使用 NamingListener 参数；其他参数都将被忽略。（如果它实现了其他侦听器接口的话这些参数可能适用）。

从以下版本开始：
1.3
另请参见：
UnsolicitedNotificationEvent,
UnsolicitedNotification,
EventContext.addNamingListener(javax.naming.Name, int, javax.naming.event.NamingListener),
EventDirContext.addNamingListener(javax.naming.Name, java.lang.String, javax.naming.directory.SearchControls, javax.naming.event.NamingListener),
EventContext.removeNamingListener(javax.naming.event.NamingListener)

方法摘要
 void notificationReceived(UnsolicitedNotificationEvent evt)
当收到了未经请求的通知时调用。
从接口 javax.naming.event.NamingListener 继承的方法
namingExceptionThrown

方法详细信息

notificationReceived

void notificationReceived(UnsolicitedNotificationEvent evt)
当收到了未经请求的通知时调用。

参数：
evt - 非 null UnsolicitedNotificationEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.naming.ldap (Java 2 Platform SE 6)

 javax.naming.ldap
接口
Control
ExtendedRequest
ExtendedResponse
HasControls
LdapContext
UnsolicitedNotification
UnsolicitedNotificationListener
类
BasicControl
ControlFactory
InitialLdapContext
LdapName
ManageReferralControl
PagedResultsControl
PagedResultsResponseControl
Rdn
SortControl
SortKey
SortResponseControl
StartTlsRequest
StartTlsResponse
UnsolicitedNotificationEvent
异常
LdapReferralException


javax.naming.ldap (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.naming.ldap

提供对 LDAPv3 扩展操作和控件的支持。

请参见：
描述

接口摘要
Control | 此接口表示在 RFC 2251 中定义的 LDAPv3 控件。
ExtendedRequest | 此接口表示在 RFC 2251 中定义的 LDAPv3 扩展操作请求。
ExtendedResponse | 此接口表示在 RFC 2251 中定义的 LDAP 扩展操作响应。
HasControls | 此接口用于返回控件，并使对象返回在 NamingEnumeration 中。
LdapContext | 此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。
UnsolicitedNotification | 此接口表示在 RFC 2251 中定义的未经请求的通知。
UnsolicitedNotificationListener | 此接口用于处理 UnsolicitedNotificationEvent。

类摘要
BasicControl | 此类提供 Control 接口的基本实现。
ControlFactory | 此抽象类表示用于创建 LDAPv3 控件的工厂。
InitialLdapContext | 此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。
LdapName | 此类表示 RFC 2253 指定的标识名。
ManageReferralControl | 将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
PagedResultsControl | 请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
PagedResultsResponseControl | 指示一批搜索结果的末尾。
Rdn | 此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。
SortControl | 请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
SortKey | 排序键及其关联的排序参数。
SortResponseControl | 指示搜索结果的请求排序是否成功。
StartTlsRequest | 此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。
StartTlsResponse | 此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。
UnsolicitedNotificationEvent | 此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。

异常摘要
LdapReferralException 此抽象类用于表示 LDAP 引用异常。

软件包 javax.naming.ldap 的描述

提供对 LDAPv3 扩展操作和控件的支持。

此包扩展 Java Naming and Directory InterfaceTM (JNDI) 的目录操作。 JNDI 向使用 Java 编程语言编写的应用程序提供命名和目录功能。它被设计成与任何特定的命名或目录服务实现无关。因此可以使用共同的方式对多种服务（新的、新出现的及已经部署的服务）进行访问。

此包用于处理 LDAPv3 扩展操作和控件的应用程序和服务提供者，这在 RFC 2251 中定义。此包中的核心接口是 LdapContext，该接口定义了一些在上下文中执行扩展操作和处理控件的方法。

扩展操作

此包定义了接口 ExtendedRequest 来表示扩展操作的参数，定义了接口 ExtendedResponse 来表示扩展操作的结果。扩展响应始终与扩展请求成对出现，但反过来不一定成立。即扩展请求可以没有对应的扩展响应。

应用程序通常不直接处理这些接口，而是处理实现 这些接口的类。应用程序可能作为通过 IETF 进行标准化的扩展操作清单的一部分获取这些类，也可能从特定于供应商的扩展操作的目录供应商获取这些类。请求类应该具有以类型安全的、用户友好的方式接受参数的构造方法，而响应类应该具有以类型安全的、用户友好的方式获取响应数据的存取方法。请求/响应类在内部处理编码和解码的 BER 值。

例如，假定 LDAP 服务器支持“获取时间”扩展操作。它将提供诸如 GetTimeRequest 和 GetTimeResponse 之类的类，以便应用程序可以使用此功能。应用程序将按以下方式使用这些类：

GetTimeResponse resp =
    (GetTimeResponse) ectx.extendedOperation(new GetTimeRequest());
long time = resp.getTime();

GetTimeRequest 和 GetTimeResponse 类可能按照以下方式定义：

public class GetTimeRequest implements ExtendedRequest {
    // User-friendly constructor
    public GetTimeRequest() {
    };

    // Methods used by service providers
    public String getID() {
        return GETTIME_REQ_OID;
    }
    public byte[] getEncodedValue() {
        return null;  // no value needed for get time request
    }
    public ExtendedResponse createExtendedResponse(
        String id, byte[] berValue, int offset, int length) throws NamingException {
        return new GetTimeResponse(id, berValue, offset, length);
    }
}
public class GetTimeResponse() implements ExtendedResponse {
    long time;
    // called by GetTimeRequest.createExtendedResponse()
    public GetTimeResponse(String id, byte[] berValue, int offset, int length)
        throws NamingException {
        // check validity of id
        long time =  ... // decode berValue to get time
    }

    // Type-safe and User-friendly methods
    public java.util.Date getDate() { return new java.util.Date(time); }
    public long getTime() { return time; }

    // Low level methods
    public byte[] getEncodedValue() {
        return // berValue saved;
    }
    public String getID() {
        return GETTIME_RESP_OID;
    }
}

控件

此包定义了接口 Control 来表示 LDAPv3 控件。它可以是发送到 LDAP 服务器的控件（请求控件）或由 LDAP 服务器返回的控件（响应控件）。与扩展请求和响应不同，在请求控件和响应控件之间不存在任何必然的配对关系。可以发送请求控件而不要求返回响应控件，也可以收到响应控件而没有发送任何请求控件。

应用程序通常不直接处理此接口，而是处理实现 此接口的类。应用程序可能作为通过 IETF 进行标准化的控件清单的一部分获取控件类，也可能从特定于供应商的控件的目录供应商获取这些类。请求控件类应该具有以类型安全的、用户友好的方式接受参数的构造方法，而响应控件类应该具有以类型安全的、用户友好的方式获取响应数据的存取方法。请求/响应控件类在内部处理编码和解码的 BER 值。

例如，假定 LDAP 服务器支持“签名结果”请求控件，将此控件与请求一起发送时，它将请求服务器对操作的结果进行数字签名。它将提供 SignedResultsControl 类，以便应用程序可以使用此功能。应用程序将按以下方式使用此类：

Control[] reqCtls = new Control[] {new SignedResultsControl(Control.CRITICAL)};
ectx.setRequestControls(reqCtls);
NamingEnumeration enum = ectx.search(...);
SignedResultsControl 类可能按照以下方式定义：
public class SignedResultsControl implements Control {
    // User-friendly constructor
    public SignedResultsControl(boolean criticality) {
        // assemble the components of the request control
    };

    // Methods used by service providers
    public String getID() {
        return // control's object identifier
    }
    public byte[] getEncodedValue() {
        return // ASN.1 BER encoded control value
    }
    ...
}

当服务提供者接收响应控件时，它将使用 ControlFactory 类生成实现 Control 接口的特定类。

LDAP 服务器可以利用 LDAP 操作及枚举结果（如列举或搜索操作返回的那些结果）发回响应控件。LdapContext 提供方法 (getResponseControls()) 来获取利用 LDAP 操作发送的响应控件，而 HasControls 接口用于检索与枚举结果关联的响应控件。

例如，假定 LDAP 服务器发回“更改 ID”控件来响应成功修改。它将提供 ChangeIDControl 类，以便应用程序可以使用此功能。应用程序将执行更新，然后试图获取更改 ID。

// Perform update
Context ctx = ectx.createSubsubcontext("cn=newobj");

// Get response controls
Control[] respCtls = ectx.getResponseControls();
if (respCtls != null) {
    // Find the one we want
    for (int i = 0; i < respCtls; i++) {
        if(respCtls[i] instanceof ChangeIDControl) {
            ChangeIDControl cctl = (ChangeIDControl)respCtls[i];
            System.out.println(cctl.getChangeID());
        }
    }
}
供应商可能提供以下 ChangeIDControl 和 VendorXControlFactory 类。当服务提供者从 LDAP 服务器接收响应控件时，该提供者将使用 VendorXControlFactory。
public class ChangeIDControl implements Control {
    long id;

    // Constructor used by ControlFactory
    public ChangeIDControl(String OID, byte[] berVal) throws NamingException {
        // check validity of OID
        id = // extract change ID from berVal
    };

    // Type-safe and User-friendly method
    public long getChangeID() {
        return id;
    }

    // Low-level methods
    public String getID() {
        return CHANGEID_OID;
    }
    public byte[] getEncodedValue() {
        return // original berVal
    }
    ...
}
public class VendorXControlFactory extends ControlFactory {
    public VendorXControlFactory () {
    }

    public Control getControlInstance(Control orig) throws NamingException {
        if (isOneOfMyControls(orig.getID())) {
            ...

            // determine which of ours it is and call its constructor
            return (new ChangeIDControl(orig.getID(), orig.getEncodedValue()));
        }
        return null;  // not one of ours
    }
}

包规范

JNDI API 规范及相关文档可在 JNDI documentation 中找到。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.naming.ldap 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.ldap 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.naming.ldap.BasicControl (implements javax.naming.ldap.Control)
      • javax.naming.ldap.ManageReferralControl
      • javax.naming.ldap.PagedResultsControl
      • javax.naming.ldap.PagedResultsResponseControl
      • javax.naming.ldap.SortControl
      • javax.naming.ldap.SortResponseControl
    • javax.naming.ldap.ControlFactory
    • java.util.EventObject (implements java.io.Serializable)
      • javax.naming.ldap.UnsolicitedNotificationEvent
    • javax.naming.InitialContext (implements javax.naming.Context)
      • javax.naming.directory.InitialDirContext (implements javax.naming.directory.DirContext)
        • javax.naming.ldap.InitialLdapContext (implements javax.naming.ldap.LdapContext)
    • javax.naming.ldap.LdapName (implements javax.naming.Name)
    • javax.naming.ldap.Rdn (implements java.lang.Comparable<T>, java.io.Serializable)
    • javax.naming.ldap.SortKey
    • javax.naming.ldap.StartTlsRequest (implements javax.naming.ldap.ExtendedRequest)
    • javax.naming.ldap.StartTlsResponse (implements javax.naming.ldap.ExtendedResponse)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.naming.NamingException
          • javax.naming.ReferralException
            • javax.naming.ldap.LdapReferralException

接口分层结构

  • javax.naming.Context
    • javax.naming.directory.DirContext
      • javax.naming.ldap.LdapContext
  • java.util.EventListener
    • javax.naming.event.NamingListener
      • javax.naming.ldap.UnsolicitedNotificationListener
  • javax.naming.ldap.HasControls
    • javax.naming.ldap.UnsolicitedNotification (并 extends javax.naming.ldap.ExtendedResponse)
  • java.io.Serializable
    • javax.naming.ldap.Control
    • javax.naming.ldap.ExtendedRequest
    • javax.naming.ldap.ExtendedResponse
      • javax.naming.ldap.UnsolicitedNotification (并 extends javax.naming.ldap.HasControls)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.naming.ldap 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.ldap
的使用

使用 javax.naming.ldap 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 使用的 javax.naming.ldap 中的类
BasicControl
此类提供 Control 接口的基本实现。
Control
此接口表示在 RFC 2251 中定义的 LDAPv3 控件。
ExtendedRequest
此接口表示在 RFC 2251 中定义的 LDAPv3 扩展操作请求。
ExtendedResponse
此接口表示在 RFC 2251 中定义的 LDAP 扩展操作响应。
HasControls
此接口用于返回控件，并使对象返回在 NamingEnumeration 中。
LdapContext
此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。
Rdn
此类表示相对标识名，或 RDN，它是一个 RFC 2253 指定的标识名组件。
SortKey
排序键及其关联的排序参数。
UnsolicitedNotification
此接口表示在 RFC 2251 中定义的未经请求的通知。
UnsolicitedNotificationEvent
此类表示为响应 LDAP 服务器发送的未经请求的通知而触发的事件。
UnsolicitedNotificationListener
此接口用于处理 UnsolicitedNotificationEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.BasicControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.BasicControl
的使用

使用 BasicControl 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 BasicControl 的使用

javax.naming.ldap 中 BasicControl 的子类
class | ManageReferralControl 将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
class | PagedResultsControl 请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
class | PagedResultsResponseControl 指示一批搜索结果的末尾。
class | SortControl 请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
class | SortResponseControl 指示搜索结果的请求排序是否成功。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.ldap.Control 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.Control
的使用

使用 Control 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 Control 的使用

实现 Control 的 javax.naming.ldap 中的类
class | BasicControl 此类提供 Control 接口的基本实现。
class | ManageReferralControl 将引用和其他特殊 LDAP 对象作为普通 LDAP 对象处理的请求。
class | PagedResultsControl 请求由 LDAP 服务器以指定的大小批量返回搜索操作的结果。
class | PagedResultsResponseControl 指示一批搜索结果的末尾。
class | SortControl 请求 LDAP 服务器在返回搜索操作的结果前对这些结果进行排序。
class | SortResponseControl 指示搜索结果的请求排序是否成功。

返回 Control 的 javax.naming.ldap 中的方法
Control[] | InitialLdapContext.getConnectControls()
Control[] | LdapContext.getConnectControls() 检索对此上下文有效的连接请求控件。
abstract Control | ControlFactory.getControlInstance(Control ctl) 使用此控件工厂创建控件。
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
Control[] | HasControls.getControls() 从实现此接口的对象中检索 Control 数组。
Control[] | InitialLdapContext.getRequestControls()
Control[] | LdapContext.getRequestControls() 检索对此上下文有效的请求控件。
Control[] | InitialLdapContext.getResponseControls()
Control[] | LdapContext.getResponseControls() 检索对此上下文调用的最后一个方法所生成的响应控件。

参数类型为 Control 的 javax.naming.ldap 中的方法
abstract Control | ControlFactory.getControlInstance(Control ctl) 使用此控件工厂创建控件。
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。
LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
LdapContext | LdapContext.newInstance(Control[] requestControls) 创建此上下文的新实例，使用请求控件进行初始化。
void | InitialLdapContext.reconnect(Control[] connCtls)
void | LdapContext.reconnect(Control[] connCtls) 使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
void | InitialLdapContext.setRequestControls(Control[] requestControls)
void | LdapContext.setRequestControls(Control[] requestControls) 为在此上下文上后续调用的方法设置请求控件。

参数类型为 Control 的 javax.naming.ldap 中的构造方法
InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
使用环境属性或连接请求控件构造初始上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.ControlFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.ControlFactory
的使用

没有 javax.naming.ldap.ControlFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.ldap.ExtendedRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.ExtendedRequest
的使用

使用 ExtendedRequest 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 ExtendedRequest 的使用

实现 ExtendedRequest 的 javax.naming.ldap 中的类
 class StartTlsRequest
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展请求。

参数类型为 ExtendedRequest 的 javax.naming.ldap 中的方法
ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
ExtendedResponse | LdapContext.extendedOperation(ExtendedRequest request) 执行扩展操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.ldap.ExtendedResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.ExtendedResponse
的使用

使用 ExtendedResponse 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 ExtendedResponse 的使用

javax.naming.ldap 中 ExtendedResponse 的子接口
 interface UnsolicitedNotification
此接口表示在 RFC 2251 中定义的未经请求的通知。

实现 ExtendedResponse 的 javax.naming.ldap 中的类
 class StartTlsResponse
此类实现在 Lightweight Directory Access Protocol (v3): Extension for Transport Layer Security 中定义的 StartTLS 的 LDAPv3 扩展响应。

返回 ExtendedResponse 的 javax.naming.ldap 中的方法
ExtendedResponse | ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与此请求对应的响应对象。
ExtendedResponse | StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。
ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
ExtendedResponse | LdapContext.extendedOperation(ExtendedRequest request) 执行扩展操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.ldap.HasControls 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.HasControls
的使用

使用 HasControls 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 HasControls 的使用

javax.naming.ldap 中 HasControls 的子接口
 interface UnsolicitedNotification
此接口表示在 RFC 2251 中定义的未经请求的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.InitialLdapContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.InitialLdapContext
的使用

没有 javax.naming.ldap.InitialLdapContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.ldap.LdapContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.LdapContext
的使用

使用 LdapContext 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 LdapContext 的使用

实现 LdapContext 的 javax.naming.ldap 中的类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

返回 LdapContext 的 javax.naming.ldap 中的方法
LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
LdapContext | LdapContext.newInstance(Control[] requestControls) 创建此上下文的新实例，使用请求控件进行初始化。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.LdapName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.LdapName
的使用

没有 javax.naming.ldap.LdapName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.LdapReferralException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.LdapReferralException
的使用

没有 javax.naming.ldap.LdapReferralException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.ManageReferralControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.ManageReferralControl
的使用

没有 javax.naming.ldap.ManageReferralControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.PagedResultsControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.PagedResultsControl
的使用

没有 javax.naming.ldap.PagedResultsControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.PagedResultsResponseControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.PagedResultsResponseControl
的使用

没有 javax.naming.ldap.PagedResultsResponseControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.Rdn 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.Rdn
的使用

使用 Rdn 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 Rdn 的使用

返回 Rdn 的 javax.naming.ldap 中的方法
 Rdn LdapName.getRdn(int posn)
以 Rdn 形式检索此 LDAP 名称的 RDN。

返回变量类型为 Rdn 的类型的 javax.naming.ldap 中的方法
 List<Rdn> LdapName.getRdns()
检索相对标识名列表。

参数类型为 Rdn 的 javax.naming.ldap 中的方法
Name | LdapName.add(int posn, Rdn comp) 将单个 RDN 添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(Rdn comp) 将单个 RDN 添加到此 LDAP 名称的末尾。

类型变量类型为 Rdn 的 javax.naming.ldap 中的方法参数
Name | LdapName.addAll(int posn, List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称中的指定位置。
Name | LdapName.addAll(List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称的末尾。
boolean | LdapName.endsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的后缀。
boolean | LdapName.startsWith(List<Rdn> rdns) 确定指定的 RDN 序列是否形成此 LDAP 名称的前缀。

参数类型为 Rdn 的 javax.naming.ldap 中的构造方法
Rdn(Rdn rdn)
根据给定 rdn 构造 Rdn。

类型变量类型为 Rdn 的 javax.naming.ldap 中的构造方法参数
LdapName(List<Rdn> rdns)
在给定已解析 RDN 组件的情况下构造 LDAP 名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.SortControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.SortControl
的使用

没有 javax.naming.ldap.SortControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.SortKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.SortKey
的使用

使用 SortKey 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 SortKey 的使用

参数类型为 SortKey 的 javax.naming.ldap 中的构造方法
SortControl(SortKey[] sortBy, boolean criticality)
构造一个控件来对排序键列表进行排序。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.SortResponseControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.SortResponseControl
的使用

没有 javax.naming.ldap.SortResponseControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.StartTlsRequest 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.StartTlsRequest
的使用

没有 javax.naming.ldap.StartTlsRequest 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.StartTlsResponse 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.StartTlsResponse
的使用

没有 javax.naming.ldap.StartTlsResponse 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.ldap.UnsolicitedNotification 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.UnsolicitedNotification
的使用

使用 UnsolicitedNotification 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 UnsolicitedNotification 的使用

返回 UnsolicitedNotification 的 javax.naming.ldap 中的方法
 UnsolicitedNotification UnsolicitedNotificationEvent.getNotification()
返回未经请求的通知。

参数类型为 UnsolicitedNotification 的 javax.naming.ldap 中的构造方法
UnsolicitedNotificationEvent(Object src, UnsolicitedNotification notice)
构造一个新的 UnsolicitedNotificationEvent 实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ldap.UnsolicitedNotificationEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ldap.UnsolicitedNotificationEvent
的使用

使用 UnsolicitedNotificationEvent 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 UnsolicitedNotificationEvent 的使用

参数类型为 UnsolicitedNotificationEvent 的 javax.naming.ldap 中的方法
 void UnsolicitedNotificationListener.notificationReceived(UnsolicitedNotificationEvent evt)
当收到了未经请求的通知时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.ldap.UnsolicitedNotificationListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.ldap.UnsolicitedNotificationListener
的使用

使用 UnsolicitedNotificationListener 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 UnsolicitedNotificationListener 的使用

参数类型为 UnsolicitedNotificationListener 的 javax.naming.ldap 中的方法
 void UnsolicitedNotificationEvent.dispatch(UnsolicitedNotificationListener listener)
使用此事件对侦听器调用 notificationReceived() 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


DirectoryManager (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
类 DirectoryManager

java.lang.Object
    继承者  javax.naming.spi.NamingManager
        继承者  javax.naming.spi.DirectoryManager

public class DirectoryManager
extends NamingManager

此类包含支持 DirContext 实现的方法。

此类是 NamingManager 的一个扩展。它包含一些方法供服务提供者用来访问对象工厂和状态工厂，并用来获得连续上下文以支持联合。

将 DirectoryManager 用于多个线程的并发访问是安全的。

除非另有说明，否则传递给任何方法的 Name、Attributes 或环境参数都归调用者所有。该实现不会修改对象或保持对该对象的引用，尽管可能保持对其副本的引用。

从以下版本开始：
1.3
另请参见：
DirObjectFactory, DirStateFactory

字段摘要
从类 javax.naming.spi.NamingManager 继承的字段
CPE
方法摘要
static DirContext | getContinuationDirContext(CannotProceedException cpe) 创建一个将继续某个 DirContext 操作的上下文。
static Object | getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
static DirStateFactory.Result | getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。
从类 javax.naming.spi.NamingManager 继承的方法
getContinuationContext, getInitialContext, getObjectInstance, getStateToBind, getURLContext, hasInitialContextFactoryBuilder, setInitialContextFactoryBuilder, setObjectFactoryBuilder
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getContinuationDirContext

public static DirContext getContinuationDirContext(CannotProceedException cpe)
                                            throws NamingException
创建一个将继续某个 DirContext 操作的上下文。此方法的运行非常类似于 NamingManager.getContinuationContext()，唯一的不同是它返回的连续上下文是一个 DirContext。

参数：
cpe - 触发此连续的非 null 异常。
返回：
用于继续该操作的非 null DirContext 对象。
抛出：
NamingException - 如果发生命名异常。
另请参见：
NamingManager.getContinuationContext(CannotProceedException)

getObjectInstance

public static Object getObjectInstance(Object refInfo,
                                       Name name,
                                       Context nameCtx,
                                       Hashtable<?,?> environment,
                                       Attributes attrs)
                                throws Exception
为指定对象、属性和环境创建一个对象实例。

除以下不同之处外，此方法与 NamingManager.getObjectInstance 相同：

  • 它接受包含与对象关联的属性的 Attributes 参数。DirObjectFactory 可以使用这些属性来保存所拥有的对象，以便从目录中查找它们。
  • 所尝试的对象工厂必须实现 ObjectFactory 或 DirObjectFactory。如果它实现 DirObjectFactory，则使用 DirObjectFactory.getObjectInstance()，否则使用 ObjectFactory.getObjectInstance()。
实现 DirContext 接口的服务提供者应该使用此方法而不是 NamingManager.getObjectInstance()。

参数：
refInfo - 将为之创建对象的对象（可能为 null）。
name - 此对象的相对于 nameCtx 的名称。指定名称是可选操作；如果忽略名称，则 name 应该为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的。如果为 null，则 name 相对于默认初始上下文。
environment - 将在创建对象和对象工厂时使用的环境（可能为 null）。
attrs - 与 refInfo 关联的属性（可能为 null）。这些属性可能不是用于 refInfo 的完整属性集，可以从目录中读取更多的属性。
返回：
使用 refInfo 和 attrs 创建的对象；如果无法通过工厂创建对象，则返回 refInfo。
抛出：
NamingException - 如果在试图获得 URL 上下文时遇到命名异常，或者受访问的工厂之一抛出 NamingException。
Exception - 如果受访问的工厂之一抛出异常，或者加载和实例化工厂和对象类时遇到错误。工厂只有在不希望试图使用其他工厂创建对象时才抛出异常。请参见 DirObjectFactory.getObjectInstance()。
从以下版本开始：
1.3
另请参见：
NamingManager.getURLContext(java.lang.String, java.util.Hashtable), DirObjectFactory, DirObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)

getStateToBind

public static DirStateFactory.Result getStateToBind(Object obj,
                                                    Name name,
                                                    Context nameCtx,
                                                    Hashtable<?,?> environment,
                                                    Attributes attrs)
                                             throws NamingException
在给定初始对象及其属性时，检索用于绑定的对象的状态。

除以下不同之处外，此方法与 NamingManager.getStateToBind 类似：

  • 它接受包含传递给 DirContext.bind() 方法的属性的 Attributes 参数。
  • 它返回一个非 null DirStateFactory.Result 实例，该实例包含将被绑定的对象，以及伴随该绑定的属性。该对象和属性都可以为 null。
  • 每个所尝试的状态工厂都必须实现 StateFactory 或 DirStateFactory。如果它实现 DirStateFactory，则调用 DirStateFactory.getStateToBind()；否则调用 StateFactory.getStateToBind()。
实现 DirContext 接口的服务提供者应该使用此方法而不是 NamingManager.getStateToBind()。

有关如何确定要尝试的状态工厂列表的描述，请参见 NamingManager.getStateToBind()。

此方法返回的对象归调用者所有。该实现随后不会对它进行修改。它或者包含一个同样归调用者所有的新 Attributes 对象，或者包含对原始 attrs 参数的引用。

参数：
obj - 将为其获得要绑定的状态的非 null 对象。
name - 此对象相对于 nameCtx 的名称，如果没有指定名称，则该参数为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的，如果 name 相对于默认初始上下文，则该参数为 null。
environment - 将在创建状态工厂和对象状态时使用的环境（可能为 null）。
attrs - 将与对象绑定在一起的属性（可能为 null）。
返回：
一个非 null DirStateFactory.Result，它包含要绑定的对象和属性。如果没有任何状态工厂返回非 null 应答，则结果将包含该对象本身 (obj) 以及原始属性。
抛出：
NamingException - 如果使用这些工厂时遇到命名异常。工厂只有在不希望试图使用其他工厂创建对象时才抛出异常。请参见 DirStateFactory.getStateToBind()。
从以下版本开始：
1.3
另请参见：
DirStateFactory, DirStateFactory.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


DirObjectFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 DirObjectFactory

所有超级接口：
ObjectFactory
public interface DirObjectFactory
extends ObjectFactory

此接口表示一个工厂，该工厂用来在给定某一对象以及有关该对象的属性的情况下创建该对象。

JNDI 框架允许通过对象工厂 动态加载对象实现。有关详细信息，请参见 ObjectFactory。

DirObjectFactory 扩展了 ObjectFactory，它允许将 Attributes 实例提供给 getObjectInstance() 方法。DirObjectFactory 实现将由 DirContext 服务提供者使用。除了从目录中读取对象之外，该服务提供者还可能已经拥有对该对象工厂有用的属性，以检查该工厂是否应该处理对象。例如，LDAP 风格的服务提供者可能已经读取对象的“对象类 (objectclass)”。CORBA 对象工厂可能只对具有 "objectclass=corbaObject" 的 LDAP 项感兴趣。通过使用 LDAP 服务提供者所提供的属性，CORBA 对象工厂可以快速排除不需要关注的对象，而非 CORBA 对象工厂可以快速排除与 CORBA 有关的 LDAP 项。

从以下版本开始：
1.3
另请参见：
NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), ObjectFactory

方法摘要
 Object getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs)
使用位置或引用信息以及指定的属性创建一个对象。
从接口 javax.naming.spi.ObjectFactory 继承的方法
getObjectInstance

方法详细信息

getObjectInstance

Object getObjectInstance(Object obj,
                         Name name,
                         Context nameCtx,
                         Hashtable<?,?> environment,
                         Attributes attrs)
                         throws Exception
使用位置或引用信息以及指定的属性创建一个对象。

使用 environment 提供此对象的特殊需要。这种 environment 属性的一个示例是用户身份信息。

DirectoryManager.getObjectInstance() 接连在对象工厂中进行加载。如果遇到 DirObjectFactory，它将调用 DirObjectFactory.getObjectInstance()；否则它将调用 ObjectFactory.getObjectInstance()。它将持续这样做，直到某一工厂产生非 null 应答。

当对象工厂抛出异常时，该异常被传递给 DirectoryManager.getObjectInstance() 的调用者。停止搜索可能产生非 null 应答的其他工厂。对象工厂只有在可以确定它是唯一需要的工厂并且不应该再尝试其他对象工厂时才抛出异常。如果此对象工厂无法使用所提供的参数创建对象，则它应该返回 null。

因为 DirObjectFactory 扩展了 ObjectFactory，所以它实际上有两个 getObjectInstance() 方法，其中一个方法在属性参数上不同于另一个方法。给出一个实现 DirObjectFactory 的工厂，DirectoryManager.getObjectInstance() 将只使用接受属性参数的方法，而 NamingManager.getObjectInstance() 将只使用不接收属性参数的方法。

有关 URL 上下文工厂和对象工厂其他属性的描述，请参阅 ObjectFactory，它同样适用于 DirObjectFactory。

name、attrs 和 environment 参数都归调用者所有。该实现不会修改这些对象或保存对它们的引用，尽管它可能保存对这些对象的副本的引用。

参数：
obj - 包含可在创建对象时使用的位置或引用信息的对象（可能为 null）。
name - 此对象相对于 nameCtx 的名称，如果没有指定名称，则该参数为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的，如果 name 相对于默认初始上下文，则该参数为 null。
environment - 创建对象时使用的环境（可能为 null）。
attrs - 包含 obj 的某些属性的属性（可能为 null）。attrs 不一定拥有 obj 的所有属性。如果对象工厂需要更多的属性，则需要使用 obj 或者 name 和 nameCtx 获取。该工厂不得修改 attrs。
返回：
已创建的对象；如果无法创建对象，则返回 null。
抛出：
Exception - 如果此对象工厂在试图创建对象时遇到异常，并且不再尝试其他对象工厂。
另请参见：
DirectoryManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), NamingManager.getURLContext(java.lang.String, java.util.Hashtable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DirStateFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 DirStateFactory

所有超级接口：
StateFactory
public interface DirStateFactory
extends StateFactory

此接口表示一个工厂，该工厂用来获得对象的状态和用于绑定的相应属性。

JNDI 框架允许通过对象工厂动态加载对象实现。

DirStateFactory 扩展了 StateFactory，它允许将 Attributes 实例提供给 getStateToBind() 方法并由该方法返回。DirStateFactory 实现将由 DirContext 服务提供者使用。当调用者使用 DirContext.bind() 绑定对象时，还可以指定一个与该对象绑定在一起的属性集合。要绑定的对象和属性被传递给工厂的 getStateToBind() 方法。如果该工厂处理这些对象和属性，则它会返回由对象和要绑定的属性组成的相应对。如果该工厂没有处理该对象，则必须返回 null。

例如，调用者可以将一个打印机对象与一些与打印机相关的属性绑定在一起。

 ctx.rebind("inky", printer, printerAttrs);
用于 ctx 的 LDAP 服务提供者使用 DirStateFactory（直接通过 DirectoryManager.getStateToBind()）并向它提供 printer 和 printerAttrs。用于 LDAP 目录的工厂可以将 printer 转换成一个属性集，并将它们与 printerAttrs 合并在一起。然后服务提供者使用得到的属性创建一个 LDAP 项并更新目录。

因为 DirStateFactory 扩展了 StateFactory，所以它有两个 getStateToBind() 方法，其中一个方法在属性参数上不同于另一个方法。DirectoryManager.getStateToBind() 将只使用接受属性参数的形式，而 NamingManager.getStateToBind() 将只使用不接受属性参数的形式。

可以使用不同的参数多次调用 DirStateFactory 任何一种形式的 getStateToBind() 方法。该实现是线程安全的。

从以下版本开始：
1.3
另请参见：
DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), DirObjectFactory

嵌套类摘要
static class DirStateFactory.Result
用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。
方法摘要
 DirStateFactory.Result getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs)
在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
从接口 javax.naming.spi.StateFactory 继承的方法
getStateToBind

方法详细信息

getStateToBind

DirStateFactory.Result getStateToBind(Object obj,
                                      Name name,
                                      Context nameCtx,
                                      Hashtable<?,?> environment,
                                      Attributes inAttrs)
                                      throws NamingException
在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。

DirectoryManager.getStateToBind() 接连在状态工厂中加载。如果某一工厂实现 DirStateFactory，则 DirectoryManager 将调用此方法；否则，它将调用 StateFactory.getStateToBind()。它将持续这样做，直到某一工厂产生非 null 响应。

当某一工厂抛出异常时，该异常被传递给 DirectoryManager.getStateToBind() 的调用者。停止搜索可能产生非 null 应答的其他工厂。工厂只有在可以确定它是唯一需要的工厂并且不应该再尝试其他工厂时才抛出异常。如果此对象工厂无法使用所提供的参数创建对象，则它应该返回 null。

可以有选择地使用 name 和 nameCtx 参数来指定要创建的对象的名称。有关详细信息，请参阅 ObjectFactory.getObjectInstance() 中“名称和上下文参数”的描述。如果某一工厂使用 nameCtx，则它应该将其使用与并发访问同步，因为无法保证上下文实现是线程安全的。

name、inAttrs 和 environment 参数都归调用者所有。该实现不会修改这些对象或保存对它们的引用，尽管它可能保存对这些对象的副本的引用。此方法返回的对象归调用者所有。该实现随后不会对它进行修改。它或者包含一个同样归调用者所有的新 Attributes 对象，或者包含对原始 inAttrs 参数的引用。

参数：
obj - 将检索其状态的对象（可能为 null）。
name - 此对象相对于 nameCtx 的名称，如果没有指定名称，则该参数为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的，如果 name 相对于默认初始上下文，则该参数为 null。
environment - 将在创建对象的状态时使用的环境（可能为 null）。
inAttrs - 将与对象绑定在一起的属性（可能为 null）。该工厂不得修改 inAttrs。
返回：
一个 Result，它包含用于绑定的对象状态和要绑定的相应属性；如果该对象没有使用此工厂，则返回 null。
抛出：
NamingException - 如果此工厂在试图获得对象的状态时遇到异常，并且不再尝试其他工厂。
另请参见：
DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DirStateFactory.Result (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
类 DirStateFactory.Result

java.lang.Object
    继承者  javax.naming.spi.DirStateFactory.Result
正在封闭接口：
DirStateFactory
public static class DirStateFactory.Result
extends Object

用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。

构造方法摘要
DirStateFactory.Result(Object obj, Attributes outAttrs)
构造一个 Result 实例。
方法摘要
Attributes | getAttributes() 检索要绑定的属性。
Object | getObject() 检索要绑定的对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DirStateFactory.Result

public DirStateFactory.Result(Object obj,
                              Attributes outAttrs)
构造一个 Result 实例。

参数：
obj - 要绑定的对象（可能为 null）。
outAttrs - 要绑定的属性（可能为 null）。
方法详细信息

getObject

public Object getObject()
检索要绑定的对象。

返回：
要绑定的对象（可能为 null）。

getAttributes

public Attributes getAttributes()
检索要绑定的属性。

返回：
要绑定的属性（可能为 null）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InitialContextFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 InitialContextFactory

public interface InitialContextFactory

此接口表示创建初始上下文的工厂。

JNDI 框架允许在运行时指定不同的初始上下文实现。初始上下文是使用初始上下文工厂 创建的。初始上下文工厂必须实现 InitialContextFactory 接口，该接口提供了一个方法，用于创建实现 Context 接口的初始上下文的实例。此外，工厂类必须是公共的，必须有一个不接受任何参数的公共构造方法。

从以下版本开始：
1.3
另请参见：
InitialContextFactoryBuilder, NamingManager.getInitialContext(java.util.Hashtable), InitialContext, InitialDirContext

方法摘要
 Context getInitialContext(Hashtable<?,?> environment)
创建一个初始上下文，以便开始进行名称解析。

方法详细信息

getInitialContext

Context getInitialContext(Hashtable<?,?> environment)
                          throws NamingException
创建一个初始上下文，以便开始进行名称解析。使用 environment 提供此上下文的特殊需要。

环境参数由调用者所有。该实现不会修改对象或保持对该对象的引用，尽管可能保持对其副本的引用。

参数：
environment - 指定在创建初始上下文时所使用信息的环境（可能为 null）。
返回：
实现 Context 接口的非 null 初始上下文对象。
抛出：
NamingException - 如果无法创建初始上下文。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InitialContextFactoryBuilder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 InitialContextFactoryBuilder

public interface InitialContextFactoryBuilder

此接口表示创建初始上下文工厂的生成器。

JNDI 框架允许在运行时指定不同的初始上下文实现。初始上下文是使用初始上下文工厂创建的。通过调用 NamingManager.setInitialContextFactoryBuilder()，程序可以安装自己的创建初始上下文工厂的生成器，从而可以重写该框架使用的默认策略。这类生成器必须实现 InitialContextFactoryBuilder 接口。

从以下版本开始：
1.3
另请参见：
InitialContextFactory, NamingManager.getInitialContext(java.util.Hashtable), NamingManager.setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder), NamingManager.hasInitialContextFactoryBuilder(), InitialContext, InitialDirContext

方法摘要
 InitialContextFactory createInitialContextFactory(Hashtable<?,?> environment)
使用指定环境创建一个初始上下文工厂。

方法详细信息

createInitialContextFactory

InitialContextFactory createInitialContextFactory(Hashtable<?,?> environment)
                                                  throws NamingException
使用指定环境创建一个初始上下文工厂。

环境参数由调用者所有。该实现不会修改对象或保持对该对象的引用，尽管可能保持对其副本的引用。

参数：
environment - 用来创建初始上下文实现的环境。可以为 null。
返回：
非 null 初始上下文工厂。
抛出：
NamingException - 如果无法创建初始上下文工厂。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NamingManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
类 NamingManager

java.lang.Object
    继承者  javax.naming.spi.NamingManager
直接已知子类：
DirectoryManager
public class NamingManager
extends Object

此类包含一些方法来创建上下文对象以及通过命名或目录服务中的信息引用的对象。

此类无法被实例化。它只有静态方法。

用于此类文档中的 URL 是指通过 RFC 1738 及其相关的 RFC 定义的 URL 字符串。它是符合其中所述语法的任何字符串，在 java.net.URL 类或 Web 浏览器中未必总能获得相应的支持。

将 NamingManager 用于多个线程的并发访问是安全的。

除非另有说明，否则传递给任何方法的 Name 或环境参数都归调用者所有。该实现不会修改对象或保持对该对象的引用，尽管可能保持对其副本的引用。

从以下版本开始：
1.3

字段摘要
static String CPE
保存环境属性名称的常量，getContinuationContext() 将其 CannotProceedException 参数的值保存在该环境属性中。
方法摘要
static Context | getContinuationContext(CannotProceedException cpe) 创建一个将继续上下文操作的上下文。
static Context | getInitialContext(Hashtable<?,?> env) 使用指定环境属性创建一个初始上下文工厂。
static Object | getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
static Object | getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
static Context | getURLContext(String scheme, Hashtable<?,?> environment) 为给定的 URL 方案 id 创建一个上下文。
static boolean | hasInitialContextFactoryBuilder() 确定是否已经设置了初始上下文工厂生成器。
static void | setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder) 将 InitialContextFactory 生成器设置为生成器。
static void | setObjectFactoryBuilder(ObjectFactoryBuilder builder) ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

CPE

public static final String CPE
保存环境属性名称的常量，getContinuationContext() 将其 CannotProceedException 参数的值保存在该环境属性中。此属性由连续上下文继承，并且该上下文的服务提供者可以使用它来检查异常的字段。

此常量的值是 "java.naming.spi.CannotProceedException"。

从以下版本开始：
1.3
另请参见：
getContinuationContext(javax.naming.CannotProceedException), 常量字段值
方法详细信息

setObjectFactoryBuilder

public static void setObjectFactoryBuilder(ObjectFactoryBuilder builder)
                                    throws NamingException
ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。有关默认策略的描述，请参见 getObjectInstance() 和类 ObjectFactory。setObjectFactoryBuilder() 通过安装 ObjectFactoryBuilder 重写此默认策略。后续对象工厂将使用安装的生成器加载和创建。

生成器只有在允许执行线程这样做（通过安全管理器的 checkSetFactory() 方法）时才能被安装。一旦安装了生成器，就不能再替换它。

参数：
builder - 要安装的工厂生成器。如果为 null，则不安装任何生成器。
抛出：
SecurityException - 由于安全原因而无法安装生成器。
NamingException - 由于与安全无关的原因而无法安装生成器。
IllegalStateException - 如果已经安装了一个工厂。
另请参见：
getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), ObjectFactory, ObjectFactoryBuilder, SecurityManager.checkSetFactory()

getObjectInstance

public static Object getObjectInstance(Object refInfo,
                                       Name name,
                                       Context nameCtx,
                                       Hashtable<?,?> environment)
                                throws Exception
为指定对象和环境创建一个对象实例。

如果已经安装了一个对象工厂生成器，则使用它来创建用于创建对象的工厂。否则使用以下规则来创建该对象：

  1. 如果 refInfo 是一个包含工厂类名称的 Reference 或 Referenceable，则使用指定的工厂来创建该对象。如果无法创建工厂，则返回 refInfo。从 JDK 1.1 开始，如果必须从引用中指定的位置加载工厂类，则必须已经安装 SecurityManager，否则工厂创建将失败。如果在创建工厂时遇到异常，则将该异常传递到调用者。
  2. 如果 refInfo 是一个不带工厂类名称的 Reference 或 Referenceable，并且该地址或这些地址是地址类型为 "URL" 的 StringRefAddr，则尝试使用对应于每个 URL 方案 id 的 URL 上下文工厂来创建该对象（参见 getURLContext()）。如果失败，则继续下一个步骤。
  3. 使用环境的 Context.OBJECT_FACTORIES 属性和与 nameCtx 关联的提供者资源文件的 Context.OBJECT_FACTORIES 属性中指定的对象工厂，并使用原来的顺序。此属性的值是按顺序尝试的以冒号分隔的工厂类名称列表，使用的名称是第一个成功创建对象的名称。如果没有加载任何工厂，则返回 refInfo。如果在创建对象时遇到异常，则将该异常传递到调用者。

实现 DirContext 接口的服务提供者应该使用 DirectoryManager.getObjectInstance() 而不是此方法。只实现 Context 接口的服务提供者应该使用此方法。

注意，对象工厂（实现 ObjectFactory 接口的对象）必须是公共的，并且必须有一个不接受任何参数的公共构造方法。

可以有选择地使用 name 和 nameCtx 参数来指定将创建的对象的名称。name 是该对象相对于上下文 nameCtx 的名称。此信息对于对象工厂或对象实现可能很有用。如果有几个可以从中指定对象的可能上下文（通常会是这种情况），则由调用者决定选择哪一个。根据经验，应选择“最深的”可用上下文。如果 nameCtx 为 null，则 name 相对于默认初始上下文。如果没有名称将被指定，则 name 参数应该为 null。

参数：
refInfo - 将为之创建对象的对象（可能为 null）。
name - 此对象的相对于 nameCtx 的名称。指定名称是可选操作；如果忽略名称，则 name 应该为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的。如果为 null，则 name 相对于默认初始上下文。
environment - 将在创建对象和对象工厂时使用的环境（可能为 null）。
返回：
使用 refInfo 创建的对象；如果无法使用上述算法创建对象，则返回 refInfo。
抛出：
NamingException - 如果在试图获得 URL 上下文时遇到命名异常，或者受访问的工厂之一抛出 NamingException。
Exception - 如果受访问的工厂之一抛出异常，或者加载和实例化工厂和对象类时遇到错误。工厂只有在不希望试图使用其他工厂创建对象时才抛出异常。请参见 ObjectFactory.getObjectInstance()。
另请参见：
getURLContext(java.lang.String, java.util.Hashtable), ObjectFactory, ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

getURLContext

public static Context getURLContext(String scheme,
                                    Hashtable<?,?> environment)
                             throws NamingException
为给定的 URL 方案 id 创建一个上下文。

得到的上下文用于解析 scheme 方案的 URL。得到的上下文没有绑定到特定 URL。它能够使用指定方案处理任意 URL。

创建所得上下文的工厂的类名称包含命名约定方案 id URLContextFactory（例如，用于 "ftp" 方案 id 的 "ftpURLContextFactory"），所在的包指定如下。Context.URL_PKG_PREFIXES 环境属性（可能包含从 applet 参数、系统属性或应用程序资源文件中获得的值）包含以冒号分隔的包前缀列表。按指定的顺序尝试该属性中的每个包前缀来加载工厂类。默认包前缀是 "com.sun.jndi.url"（如果指定的包前缀都无效，则尝试使用此默认前缀）。完整的包名称是使用包前缀构造的，并与方案 id 连接在一起。

例如，如果方案 id 为 "ldap"，而 Context.URL_PKG_PREFIXES 属性包含 "com.widget:com.wiz.jndi"，则命名管理器将尝试加载以下类，直到成功实例化其中的一个：

  • com.widget.ldap.ldapURLContextFactory
  • com.wiz.jndi.ldap.ldapURLContextFactory
  • com.sun.jndi.url.ldap.ldapURLContextFactory
如果没有包前缀有效，则返回 null。

如果某一工厂被实例化，则使用以下参数调用该工厂来产生结果上下文。

factory.getObjectInstance(null, environment);

例如，按上述方式对 LDAP URL 上下文工厂调用 getObjectInstance() 将返回一个可以解析 LDAP url（例如 "ldap://ldap.wiz.com/o=wiz,c=us"、"ldap://ldap.umich.edu/o=umich,c=us" 等等）的上下文。

注意，对象工厂（实现 ObjectFactory 接口的对象）必须是公共的，并且必须有一个不接受任何参数的公共构造方法。

参数：
scheme - 上下文支持的 URL 的非 null 方案 id。
environment - 将在创建对象和对象工厂时使用的环境属性（可能为 null）。
返回：
使用方案 id scheme 解析 URL 的上下文；如果没有找到用于创建该上下文的工厂，则返回 null。
抛出：
NamingException - 如果在创建上下文时发生命名异常。
另请参见：
getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), ObjectFactory.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable)

getInitialContext

public static Context getInitialContext(Hashtable<?,?> env)
                                 throws NamingException
使用指定环境属性创建一个初始上下文工厂。

如果已经安装 InitialContextFactoryBuilder，则使用它来创建用于创建该初始上下文的工厂。否则使用 Context.INITIAL_CONTEXT_FACTORY 环境属性中指定的类。注意，初始上下文工厂（实现 InitialContextFactory 接口的对象）必须是公共的，并且必须有一个不接受任何参数的公共构造方法。

参数：
env - 创建上下文时要使用的环境属性（可能为 null）。
返回：
非 null 的初始上下文。
抛出：
NoInitialContextException - 如果没有找到 Context.INITIAL_CONTEXT_FACTORY 属性，或者指定了一个不存在的类或无法实例化的类，抑或因为其他一些原因而无法创建初始上下文。
NamingException - 如果遇到其他命名异常。
另请参见：
InitialContext, InitialDirContext

setInitialContextFactoryBuilder

public static void setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder)
                                            throws NamingException
将 InitialContextFactory 生成器设置为生成器。

生成器只有在安全管理器允许执行线程这样做时才能被安装。一旦安装了生成器，就不能再替换它。

参数：
builder - 要安装的初始上下文工厂生成器。如果为 null，则不设置任何生成器。
抛出：
SecurityException - 由于安全原因而无法安装生成器。
NamingException - 由于与安全无关的原因而无法安装生成器。
IllegalStateException - 如果以前已经安装了生成器。
另请参见：
hasInitialContextFactoryBuilder(), SecurityManager.checkSetFactory()

hasInitialContextFactoryBuilder

public static boolean hasInitialContextFactoryBuilder()
确定是否已经设置了初始上下文工厂生成器。

返回：
如果已经设置了初始上下文工厂生成器，则返回 true；否则返回 false。
另请参见：
setInitialContextFactoryBuilder(javax.naming.spi.InitialContextFactoryBuilder)

getContinuationContext

public static Context getContinuationContext(CannotProceedException cpe)
                                      throws NamingException
创建一个将继续上下文操作的上下文。

当对跨多个名称空间的名称执行某一操作时，取自某个命名系统的上下文可能需要将该操作传递给下一个命名系统。为做到这一点，上下文实现首先构造一个包含指出该操作已进行程度的信息的 CannotProceedException。然后通过调用 getContinuationContext 从 JNDI 中获取连续上下文。然后，该上下文实现应该通过对连续上下文调用相同的操作，使用尚未解析的剩余名称重新开始该上下文操作。

在使用 cpe 参数前，此方法通过将 CPE 属性的值设置为 cpe 来更新与该对象关联的环境。此属性将由连续上下文继承，并且该上下文的服务提供者可以使用它来检查此异常的字段。

参数：
cpe - 触发此连续的非 null 异常。
返回：
用于继续该操作的非 null Context 对象。
抛出：
NamingException - 如果发生命名异常。

getStateToBind

public static Object getStateToBind(Object obj,
                                    Name name,
                                    Context nameCtx,
                                    Hashtable<?,?> environment)
                             throws NamingException
检索用于绑定的对象的状态。

实现 DirContext 接口的服务提供者应该使用 DirectoryManager.getStateToBind() 而不是此方法。只实现 Context 接口的服务提供者应该使用此方法。

此方法使用取自环境属性的 Context.STATE_FACTORIES 属性和与 nameCtx 有关的提供者资源文件的 Context.STATE_FACTORIES 属性中的指定状态工厂，并使用原来的顺序。此属性的值是按顺序尝试的以冒号分隔的工厂类名称列表，使用的名称是第一个成功返回对象状态的名称。如果以这种方式没有检索到对象状态，则返回该对象本身。如果在检索状态时遇到异常，则将该异常传递到调用者。

注意，状态工厂（实现 StateFactory 接口的对象）必须是公共的，并且必须有一个不接受任何参数的公共构造方法。

可以有选择地使用 name 和 nameCtx 参数来指定要创建的对象的名称。有关详细信息，请参阅 ObjectFactory.getObjectInstance() 中“名称和上下文参数”的描述。

此方法可以返回一个 Referenceable 对象。获得此对象的服务提供者可以选择直接存储该对象，或者提取（使用 Referenceable.getReference()）并存储其引用。

参数：
obj - 将为其获得要绑定的状态的非 null 对象。
name - 此对象相对于 nameCtx 的名称，如果没有指定名称，则该参数为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的，如果 name 相对于默认初始上下文，则该参数为 null。
environment - 将在创建状态工厂和对象状态时使用的环境（可能为 null）。
返回：
表示用于绑定的 obj 状态的非 null 对象。它可以是该对象 (obj) 本身。
抛出：
NamingException - 如果受访问的工厂之一抛出异常，或者加载和实例化工厂和对象类时遇到错误。工厂只有在不希望试图使用其他工厂创建对象时才抛出异常。请参见 StateFactory.getStateToBind()。
从以下版本开始：
1.3
另请参见：
StateFactory, StateFactory.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 ObjectFactory

所有已知子接口：
DirObjectFactory
public interface ObjectFactory

此类表示用于创建对象的工厂。

JNDI 框架允许通过对象工厂 动态加载对象实现。例如，当查找绑定在名称空间中的打印机时，如果打印服务将打印机的名称绑定到 Reference，则可以使用该打印机 Reference 创建一个打印机对象，从而查找的调用者可以在查找后直接在该打印机对象上操作。

ObjectFactory 负责创建特定类型的对象。在上述示例中，可以有一个用来创建 Printer 对象的 PrinterObjectFactory。

对象工厂必须实现 ObjectFactory 接口。此外，工厂类必须是公共的，必须有一个不接受任何参数的公共构造方法。

可以使用不同的参数多次调用对象工厂的 getObjectInstance() 方法。该实现是线程安全的。

用于此类文档中的 URL 是指通过 RFC 1738 及其相关的 RFC 定义的 URL 字符串。它是符合其中所述语法的任何字符串，在 java.net.URL 类或 Web 浏览器中未必总能获得相应的支持。

从以下版本开始：
1.3
另请参见：
NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.getURLContext(java.lang.String, java.util.Hashtable), ObjectFactoryBuilder, StateFactory

方法摘要
 Object getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
使用指定的位置或引用信息创建一个对象。

方法详细信息

getObjectInstance

Object getObjectInstance(Object obj,
                         Name name,
                         Context nameCtx,
                         Hashtable<?,?> environment)
                         throws Exception
使用指定的位置或引用信息创建一个对象。

使用 environment 提供此对象的特殊需要。这种 environment 属性的一个示例是用户身份信息。

NamingManager.getObjectInstance() 接连在对象工厂中加载，并在这些工厂上调用此方法，直到某一工厂产生非 null 应答。当对象工厂抛出异常时，该异常被传递给 NamingManager.getObjectInstance() 的调用者（并且不再搜索可能产生非 null 应答的其他工厂）。对象工厂只有在可以确定它是唯一需要的工厂并且不应该再尝试其他对象工厂时才抛出异常。如果此对象工厂无法使用所提供的参数创建对象，则它应该返回 null。

URL 上下文工厂 是一个特殊的 ObjectFactory，它创建用于解析 URL 或位置由 URL 指定的对象的上下文。URL 上下文工厂的 getObjectInstance() 方法将遵守以下规则。

  1. 如果 obj 为 null，则创建一个上下文，该上下文用于解析与此工厂关联的方案的 URL。得到的上下文没有绑定到特定 URL：它能够使用此工厂的方案 id 处理任意 URL。例如，在 LDAP URL 上下文工厂上调用将 obj 设置为 null 的 getObjectInstance() 将返回一个可以解析 LDAP URL（比如 "ldap://ldap.wiz.com/o=wiz,c=us" 和 "ldap://ldap.umich.edu/o=umich,c=us"）的上下文。
  2. 如果 obj 是一个 URL 字符串，则创建由该 URL 标识的对象（通常是一个上下文）。例如，假设这是一个 LDAP URL 上下文工厂。如果 obj 是 "ldap://ldap.wiz.com/o=wiz,c=us"，则 getObjectInstance() 将返回由 LDAP 服务器 ldap.wiz.com 上的标识名 "o=wiz, c=us" 指定的上下文。然后可以使用此上下文解析相对于该上下文的 LDAP 名称（比如 "cn=George"）。
  3. 如果 obj 是一个 URL 字符串数组，则根据它们所引用的上下文假定这些 URL 相等。验证这些 URL 是否相等或是否需要相等取决于上下文工厂。数组中 URL 的顺序无关紧要。由 getObjectInstance() 返回的对象类似于单个 URL 的情况下返回的对象。该对象是由 URL 指定的对象。
  4. 如果 obj 属于其他任何类型，则 getObjectInstance() 的行为由上下文工厂实现确定。

name 和 environment 参数都归调用者所有。该实现不会修改这些对象或保存对它们的引用，尽管它可能保存对这些对象的副本的引用。

名称和上下文参数。 可以有选择地使用 name 和 nameCtx 参数来指定将创建的对象的名称。name 是该对象相对于上下文 nameCtx 的名称。如果有几个可以从中指定对象的可能上下文（通常会是这种情况），则由调用者决定选择哪一个。根据经验，应选择“最深的”可用上下文。如果 nameCtx 为 null，则 name 相对于默认初始上下文。如果没有名称将被指定，则 name 参数应该为 null。如果某一工厂使用 nameCtx，则它应该将其使用与并发访问同步，因为无法保证上下文实现是线程安全的。

参数：
obj - 包含可在创建对象时使用的位置或引用信息的对象（可能为 null）。
name - 此对象相对于 nameCtx 的名称，如果没有指定名称，则该参数为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的，如果 name 相对于默认初始上下文，则该参数为 null。
environment - 创建对象时使用的环境（可能为 null）。
返回：
已创建的对象；如果无法创建对象，则返回 null。
抛出：
Exception - 如果此对象工厂在试图创建对象时遇到异常，并且不再尝试其他对象工厂。
另请参见：
NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.getURLContext(java.lang.String, java.util.Hashtable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ObjectFactoryBuilder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 ObjectFactoryBuilder

public interface ObjectFactoryBuilder

此接口表示创建对象工厂的生成器。

JNDI 框架允许通过对象工厂 动态加载对象实现。例如，当查找绑定在名称空间中的打印机时，如果打印服务将打印机的名称绑定到 Reference，则可以使用该打印机 Reference 创建一个打印机对象，从而查找的调用者可以在查找后直接在该打印机对象上操作。ObjectFactory 负责创建特定类型的对象。JNDI 使用默认策略来使用和加载对象工厂。可以通过调用使用 ObjectFactoryBuilder 参数的 NamingManager.setObjectFactoryBuilder() 重写此默认策略，ObjectFactoryBuilder 参数中包含创建/加载对象工厂的程序定义的方式。任何 ObjectFactoryBuilder 实现都必须实现此接口来创建对象工厂。

从以下版本开始：
1.3
另请参见：
ObjectFactory, NamingManager.getObjectInstance(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), NamingManager.setObjectFactoryBuilder(javax.naming.spi.ObjectFactoryBuilder)

方法摘要
 ObjectFactory createObjectFactory(Object obj, Hashtable<?,?> environment)
使用所提供的环境创建一个新对象工厂。

方法详细信息

createObjectFactory

ObjectFactory createObjectFactory(Object obj,
                                  Hashtable<?,?> environment)
                                  throws NamingException
使用所提供的环境创建一个新对象工厂。

环境参数由调用者所有。该实现不会修改对象或保持对该对象的引用，尽管可能保持对其副本的引用。

参数：
obj - 将为之创建工厂的对象（可能为 null）。
environment - 创建工厂时要使用的环境。可以为 null。
返回：
非 null 的 ObjectFactory 新实例。
抛出：
NamingException - 如果无法创建对象工厂。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Resolver (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 Resolver

public interface Resolver

此接口表示用于名称解析的“中间上下文”。

Resolver 接口包含一些方法，不支持 Context 的子类但可以作为解析操作的中间上下文的上下文要实现这些方法。

传递给任何方法的 Name 参数都归调用者所有。服务提供者将不修改对象，也不保持对它的引用。任何方法返回的 ResolveResult 对象都归调用者所有。调用者随后可修改它，而服务提供者则不能。

从以下版本开始：
1.3

方法摘要
ResolveResult | resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。

方法详细信息

resolveToClass

ResolveResult resolveToClass(Name name,
                             Class<? extends Context> contextType)
                             throws NamingException
部分解析某一名称。在给定 Context 子类型实例的第一个上下文处停止。

参数：
name - 要解析的名称
contextType - 要解析的对象的类型。该类型应该是 Context 的子类型。
返回：
找到的对象，以及 name 的未解析的后缀。不能为 null。
抛出：
NotContextException - 如果没有找到适当类型的上下文
NamingException - 如果遇到命名异常
另请参见：
resolveToClass(String, Class)

resolveToClass

ResolveResult resolveToClass(String name,
                             Class<? extends Context> contextType)
                             throws NamingException
部分解析某一名称。有关详细信息，请参见 resolveToClass(Name, Class)。

参数：
name - 要解析的名称
contextType - 要解析的对象的类型。该类型应该是 Context 的子类型。
返回：
找到的对象，以及 name 的未解析的后缀。不能为 null。
抛出：
NotContextException - 如果没有找到适当类型的上下文
NamingException - 如果遇到命名异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResolveResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
类 ResolveResult

java.lang.Object
    继承者  javax.naming.spi.ResolveResult
所有已实现的接口：
Serializable
public class ResolveResult
extends Object
implements Serializable

此类表示解析某一名称的结果。它包含作为名称解析结果的对象和尚未解析的名称部分。

ResolveResult 实例与并发多线程访问不同步。试图访问和修改单个 ResolveResult 实例的多个线程应该锁定对象。

从以下版本开始：
1.3
另请参见：
序列化表格

字段摘要
protected Name | remainingName 该字段包含要解析的剩余名称。
protected Object | resolvedObj 该字段包含已成功解析成的 Object。
构造方法摘要
protected | ResolveResult() 构造一个 ResolveResult 实例，使已解析对象和剩余名称都被初始化为 null。
 | ResolveResult(Object robj, Name rname) 构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。
 | ResolveResult(Object robj, String rcomp) 构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。
方法摘要
void | appendRemainingComponent(String name) 将单个组件添加到剩余名称末尾。
void | appendRemainingName(Name name) 将组件添加到剩余名称的末尾。
Name | getRemainingName() 检索名称的剩余未解析部分。
Object | getResolvedObj() 检索已成功解析成的 Object。
void | setRemainingName(Name name) 将此结果的剩余名称字段设置为 name。
void | setResolvedObj(Object obj) 将此结果的已解析 Object 字段设置为 obj。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

resolvedObj

protected Object resolvedObj
该字段包含已成功解析成的 Object。它只在使用子类构造时可以为 null。构造方法应该总是初始化此字段。

remainingName

protected Name remainingName
该字段包含要解析的剩余名称。它只在使用子类构造时可以为 null。构造方法应该总是初始化此字段。

构造方法详细信息

ResolveResult

protected ResolveResult()
构造一个 ResolveResult 实例，使已解析对象和剩余名称都被初始化为 null。

ResolveResult

public ResolveResult(Object robj,
                     String rcomp)
构造一个新的 ResolveResult 实例，该实例由已解析对象和剩余未解析组件组成。

参数：
robj - 作为解析结果的非 null 对象。
rcomp - 尚未解析的单个剩余名称组件。不能为 null（但可以为空）。

ResolveResult

public ResolveResult(Object robj,
                     Name rname)
构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。

参数：
robj - 作为解析结果的非 null Object。
rname - 尚未解析的剩余名称。
方法详细信息

getRemainingName

public Name getRemainingName()
检索名称的剩余未解析部分。

返回：
名称的剩余未解析部分。不能为 null 但可以为空。
另请参见：
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String),
setRemainingName(javax.naming.Name)

getResolvedObj

public Object getResolvedObj()
检索已成功解析成的 Object。

返回：
已成功解析成的 Object。不能为 null。
另请参见：
setResolvedObj(java.lang.Object)

setRemainingName

public void setRemainingName(Name name)
将此结果的剩余名称字段设置为 name。生成 name 的副本，从而在此 ResolveResult 中修改该副本不会影响 name，反之亦然。

参数：
name - 用来设置剩余名称的名称。不能为 null。
另请参见：
getRemainingName(),
appendRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

appendRemainingName

public void appendRemainingName(Name name)
将组件添加到剩余名称的末尾。

参数：
name - 要添加的组件。可以为 null。
另请参见：
getRemainingName(),
setRemainingName(javax.naming.Name),
appendRemainingComponent(java.lang.String)

appendRemainingComponent

public void appendRemainingComponent(String name)
将单个组件添加到剩余名称末尾。

参数：
name - 要添加的组件。可以为 null。
另请参见：
getRemainingName(), appendRemainingName(javax.naming.Name)

setResolvedObj

public void setResolvedObj(Object obj)
将此结果的已解析 Object 字段设置为 obj。

参数：
obj - 用来设置已解析 obj 字段的对象。不能为 null。
另请参见：
getResolvedObj()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StateFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.naming.spi
接口 StateFactory

所有已知子接口：
DirStateFactory
public interface StateFactory

此接口表示一个工厂，该工厂用来获得用于绑定的对象状态。

JNDI 框架允许通过对象工厂 动态加载对象实现。例如，当查找绑定在名称空间中的打印机时，如果打印服务将打印机的名称绑定到 Reference，则可以使用该打印机 Reference 创建一个打印机对象，从而查找的调用者可以在查找后直接在该打印机对象上操作。

ObjectFactory 负责创建特定类型的对象。在上述示例中，可以有一个用来创建 Printer 对象的 PrinterObjectFactory。

对于相反过程，当将对象绑定到名称空间中时，JNDI 将提供状态工厂。继续打印机的示例，假设打印机对象被更新和重新绑定：

 ctx.rebind("inky", printer);
用于 ctx 的服务提供者使用一个状态工厂来获得绑定到其名称空间的 printer 的状态。用于 Printer 类型对象的状态工厂可能返回一个用来存储在命名系统中的更紧凑的对象。

状态工厂必须实现 StateFactory 接口。此外，工厂类必须是公共的，必须有一个不接受任何参数的公共构造方法。

可以使用不同的参数多次调用状态工厂的 getStateToBind() 方法。该实现是线程安全的。

StateFactory 与只实现 Context 接口的服务提供者一起使用。DirStateFactory 与实现 DirContext 接口的服务提供者一起使用。

从以下版本开始：
1.3
另请参见：
NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes), ObjectFactory, DirStateFactory

方法摘要
 Object getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment)
检索用于绑定的对象状态。

方法详细信息

getStateToBind

Object getStateToBind(Object obj,
                      Name name,
                      Context nameCtx,
                      Hashtable<?,?> environment)
                      throws NamingException
检索用于绑定的对象状态。

NamingManager.getStateToBind() 接连在状态工厂中加载，并在这些工厂上调用此方法，直到某一工厂产生非 null 应答。DirectoryManager.getStateToBind() 接连在状态工厂中加载。如果某一工厂实现 DirStateFactory，则 DirectoryManager 调用 DirStateFactory.getStateToBind()；否则它调用 StateFactory.getStateToBind()。

当某一工厂抛出异常时，该异常被传递给 NamingManager.getStateToBind() 和 DirectoryManager.getStateToBind() 的调用者。停止搜索可能产生非 null 应答的其他工厂。工厂只有在可以确定它是唯一需要的工厂并且不应该再尝试其他工厂时才抛出异常。如果此对象工厂无法使用所提供的参数创建对象，则它应该返回 null。

可以有选择地使用 name 和 nameCtx 参数来指定要创建的对象的名称。有关详细信息，请参阅 ObjectFactory.getObjectInstance() 中“名称和上下文参数”的描述。如果某一工厂使用 nameCtx，则它应该将其使用与并发访问同步，因为无法保证上下文实现是线程安全的。

name 和 environment 参数都归调用者所有。该实现不会修改这些对象或保存对它们的引用，尽管它可能保存对这些对象的副本的引用。

参数：
obj - 将检索其状态的非 null 对象。
name - 此对象相对于 nameCtx 的名称，如果没有指定名称，则该参数为 null。
nameCtx - 一个上下文，name 参数是相对于该上下文指定的，如果 name 相对于默认初始上下文，则该参数为 null。
environment - 将在创建对象的状态时使用的环境（可能为 null）。
返回：
用于绑定的对象状态；如果该工厂没有返回任何更改，则返回 null。
抛出：
NamingException - 如果此工厂在试图获得对象的状态时遇到异常，并且不再尝试其他工厂。
另请参见：
NamingManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable), DirectoryManager.getStateToBind(java.lang.Object, javax.naming.Name, javax.naming.Context, java.util.Hashtable, javax.naming.directory.Attributes)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.naming.spi (Java 2 Platform SE 6)

 javax.naming.spi
接口
DirObjectFactory
DirStateFactory
InitialContextFactory
InitialContextFactoryBuilder
ObjectFactory
ObjectFactoryBuilder
Resolver
StateFactory
类
DirectoryManager
DirStateFactory.Result
NamingManager
ResolveResult


javax.naming.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.naming.spi

提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

请参见：
描述

接口摘要
DirObjectFactory | 此接口表示一个工厂，该工厂用来在给定某一对象以及有关该对象的属性的情况下创建该对象。
DirStateFactory | 此接口表示一个工厂，该工厂用来获得对象的状态和用于绑定的相应属性。
InitialContextFactory | 此接口表示创建初始上下文的工厂。
InitialContextFactoryBuilder | 此接口表示创建初始上下文工厂的生成器。
ObjectFactory | 此类表示用于创建对象的工厂。
ObjectFactoryBuilder | 此接口表示创建对象工厂的生成器。
Resolver | 此接口表示用于名称解析的“中间上下文”。
StateFactory | 此接口表示一个工厂，该工厂用来获得用于绑定的对象状态。

类摘要
DirectoryManager | 此类包含支持 DirContext 实现的方法。
DirStateFactory.Result | 用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。
NamingManager | 此类包含一些方法来创建上下文对象以及通过命名或目录服务中的信息引用的对象。
ResolveResult | 此类表示解析某一名称的结果。

软件包 javax.naming.spi 的描述

提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

此包定义 Java Naming and Directory InterfaceTM (JNDI) 的服务提供者接口 (SPI)。 JNDI 向使用 Java 编程语言编写的应用程序提供命名和目录功能。它被设计成与任何特定的命名或目录服务实现无关。因此可以使用共同的方式对多种服务（新的、新出现的及已经部署的服务）进行访问。

JNDI SPI 提供一些方法来创建 JNDI 服务提供者，JNDI 应用程序可通过这些提供者访问不同的命名和目录服务。

插件架构

服务提供者包允许动态插入不同实现。这些不同的实现包括用于初始上下文 的那些实现，以及用于可从初始上下文到达的那些上下文的实现。

Java 对象支持

服务提供者包支持 javax.naming.Context.lookup() 以及相关方法的实现方返回非常适合 Java 程序员的 Java 对象。例如，当从目录中查找打印机名称时，用户很自然地会期望返回一个能在上面进行操作的打印机对象。

多个命名系统（联合）

JNDI 操作允许应用程序提供跨多个命名系统的名称。因此在完成某一操作的过程中，服务提供者可能需要与另一个服务提供者进行交互，以便（举例来说）传递该操作，使它在下一个命名系统中得以继续。服务提供者包支持不同的提供者协作完成 JNDI 操作。

包规范

JNDI API 规范及相关文档可在 JNDI documentation 中找到。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.naming.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.naming.spi.DirStateFactory.Result
    • javax.naming.spi.NamingManager
      • javax.naming.spi.DirectoryManager
    • javax.naming.spi.ResolveResult (implements java.io.Serializable)

接口分层结构

  • javax.naming.spi.InitialContextFactory
  • javax.naming.spi.InitialContextFactoryBuilder
  • javax.naming.spi.ObjectFactory
    • javax.naming.spi.DirObjectFactory
  • javax.naming.spi.ObjectFactoryBuilder
  • javax.naming.spi.Resolver
  • javax.naming.spi.StateFactory
    • javax.naming.spi.DirStateFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.naming.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.naming.spi
的使用

使用 javax.naming.spi 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 使用的 javax.naming.spi 中的类
DirStateFactory.Result
用于返回 DirStateFactory.getStateToBind() 的结果的对象/属性对。
InitialContextFactory
此接口表示创建初始上下文的工厂。
InitialContextFactoryBuilder
此接口表示创建初始上下文工厂的生成器。
NamingManager
此类包含一些方法来创建上下文对象以及通过命名或目录服务中的信息引用的对象。
ObjectFactory
此类表示用于创建对象的工厂。
ObjectFactoryBuilder
此接口表示创建对象工厂的生成器。
ResolveResult
此类表示解析某一名称的结果。
StateFactory
此接口表示一个工厂，该工厂用来获得用于绑定的对象状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.DirObjectFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.DirObjectFactory
的使用

没有 javax.naming.spi.DirObjectFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.DirStateFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.DirStateFactory
的使用

没有 javax.naming.spi.DirStateFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.spi.DirStateFactory.Result 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.DirStateFactory.Result
的使用

使用 DirStateFactory.Result 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 DirStateFactory.Result 的使用

返回 DirStateFactory.Result 的 javax.naming.spi 中的方法
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.spi.DirectoryManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.DirectoryManager
的使用

没有 javax.naming.spi.DirectoryManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.InitialContextFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.InitialContextFactory
的使用

使用 InitialContextFactory 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 InitialContextFactory 的使用

返回 InitialContextFactory 的 javax.naming.spi 中的方法
 InitialContextFactory InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment)
使用指定环境创建一个初始上下文工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.InitialContextFactoryBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.InitialContextFactoryBuilder
的使用

使用 InitialContextFactoryBuilder 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 InitialContextFactoryBuilder 的使用

参数类型为 InitialContextFactoryBuilder 的 javax.naming.spi 中的方法
static void NamingManager.setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder)
将 InitialContextFactory 生成器设置为生成器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.spi.NamingManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.NamingManager
的使用

使用 NamingManager 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 NamingManager 的使用

javax.naming.spi 中 NamingManager 的子类
 class DirectoryManager
此类包含支持 DirContext 实现的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.ObjectFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.ObjectFactory
的使用

使用 ObjectFactory 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 ObjectFactory 的使用

javax.naming.spi 中 ObjectFactory 的子接口
 interface DirObjectFactory
此接口表示一个工厂，该工厂用来在给定某一对象以及有关该对象的属性的情况下创建该对象。

返回 ObjectFactory 的 javax.naming.spi 中的方法
 ObjectFactory ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment)
使用所提供的环境创建一个新对象工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.ObjectFactoryBuilder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.ObjectFactoryBuilder
的使用

使用 ObjectFactoryBuilder 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 ObjectFactoryBuilder 的使用

参数类型为 ObjectFactoryBuilder 的 javax.naming.spi 中的方法
static void NamingManager.setObjectFactoryBuilder(ObjectFactoryBuilder builder)
ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.spi.ResolveResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.spi.ResolveResult
的使用

使用 ResolveResult 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 ResolveResult 的使用

返回 ResolveResult 的 javax.naming.spi 中的方法
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.Resolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.Resolver
的使用

没有 javax.naming.spi.Resolver 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.spi.StateFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.spi.StateFactory
的使用

使用 StateFactory 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 StateFactory 的使用

javax.naming.spi 中 StateFactory 的子接口
 interface DirStateFactory
此接口表示一个工厂，该工厂用来获得对象的状态和用于绑定的相应属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.AuthenticationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.AuthenticationException
的使用

没有 javax.naming.AuthenticationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.AuthenticationNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.AuthenticationNotSupportedException
的使用

没有 javax.naming.AuthenticationNotSupportedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.BinaryRefAddr 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.BinaryRefAddr
的使用

没有 javax.naming.BinaryRefAddr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.Binding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.Binding
的使用

使用 Binding 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。

javax.naming 中 Binding 的使用

返回变量类型为 Binding 的类型的 javax.naming 中的方法
NamingEnumeration<Binding> | Context.listBindings(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
NamingEnumeration<Binding> | Context.listBindings(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(String name)

javax.naming.directory 中 Binding 的使用

javax.naming.directory 中 Binding 的子类
 class SearchResult
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

javax.naming.event 中 Binding 的使用

声明为 Binding 的 javax.naming.event 中的字段
protected Binding | NamingEvent.newBinding 包含关于更改后对象的信息。
protected Binding | NamingEvent.oldBinding 包含关于更改前对象的信息。

返回 Binding 的 javax.naming.event 中的方法
Binding | NamingEvent.getNewBinding() 检索更改后对象的绑定。
Binding | NamingEvent.getOldBinding() 检索更改前对象的绑定。

参数类型为 Binding 的 javax.naming.event 中的构造方法
NamingEvent(EventContext source, int type, Binding newBd, Binding oldBd, Object changeInfo)
构造一个 NamingEvent 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.CannotProceedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CannotProceedException
的使用

使用 CannotProceedException 的软件包
javax.naming.spi 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming.spi 中 CannotProceedException 的使用

参数类型为 CannotProceedException 的 javax.naming.spi 中的方法
static Context | NamingManager.getContinuationContext(CannotProceedException cpe) 创建一个将继续上下文操作的上下文。
static DirContext | DirectoryManager.getContinuationDirContext(CannotProceedException cpe) 创建一个将继续某个 DirContext 操作的上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.CommunicationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CommunicationException
的使用

没有 javax.naming.CommunicationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.CompositeName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CompositeName
的使用

没有 javax.naming.CompositeName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.CompoundName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.CompoundName
的使用

没有 javax.naming.CompoundName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ConfigurationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ConfigurationException
的使用

没有 javax.naming.ConfigurationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.Context 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.Context
的使用

使用 Context 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.naming 中 Context 的使用

实现 Context 的 javax.naming 中的类
 class InitialContext
此类是执行命名操作的初始上下文。

声明为 Context 的 javax.naming 中的字段
protected Context | CannotProceedException.altNameCtx 包含上下文，altName 是相对于该上下文指定的。
protected Context | InitialContext.defaultInitCtx 该字段保存调用 NamingManager.getInitialContext() 的结果。

返回 Context 的 javax.naming 中的方法
 Context Context.createSubcontext(Name name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(Name name)
 Context Context.createSubcontext(String name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(String name)
 Context CannotProceedException.getAltNameCtx()
检索此异常的 altNameCtx 字段。
protected  Context InitialContext.getDefaultInitCtx()
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。
abstract  Context ReferralException.getReferralContext()
检索继续该方法的上下文。
abstract  Context ReferralException.getReferralContext(Hashtable<?,?> env)
使用环境属性检索继续该方法的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(Name name)
获取用来解析 name 的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(String name)
获取用来解析字符串名称 name 的上下文。

参数类型为 Context 的 javax.naming 中的方法
 void CannotProceedException.setAltNameCtx(Context altNameCtx)
设置此异常的 altNameCtx 字段。

javax.naming.directory 中 Context 的使用

javax.naming.directory 中 Context 的子接口
 interface DirContext
目录服务接口，包含一些用于检查和更新与对象关联的属性以及搜索目录的方法。

实现 Context 的 javax.naming.directory 中的类
 class InitialDirContext
此类是执行目录操作的初始上下文。

javax.naming.event 中 Context 的使用

javax.naming.event 中 Context 的子接口
interface | EventContext 包含注册/注销侦听器的一些方法，这些侦听器在上下文中命名的对象发生更改时获得触发事件的通知。
interface | EventDirContext 包含注册侦听器的一些方法，这些侦听器在目录上下文中命名的对象发生更改时将获得触发事件的通知。

javax.naming.ldap 中 Context 的使用

javax.naming.ldap 中 Context 的子接口
 interface LdapContext
此接口表示一个上下文，在该上下文中可以利用 LDAPv3 样式的控件执行操作，并且可以执行 LDAPv3 样式的扩展操作。

实现 Context 的 javax.naming.ldap 中的类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

返回 Context 的 javax.naming.ldap 中的方法
abstract Context | LdapReferralException.getReferralContext() 使用上下文的环境（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env) 使用环境属性（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。

参数类型为 Context 的 javax.naming.ldap 中的方法
static Control ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env)
使用已知控件工厂创建控件。

javax.naming.spi 中 Context 的使用

返回 Context 的 javax.naming.spi 中的方法
static Context | NamingManager.getContinuationContext(CannotProceedException cpe) 创建一个将继续上下文操作的上下文。
Context | InitialContextFactory.getInitialContext(Hashtable<?,?> environment) 创建一个初始上下文，以便开始进行名称解析。
static Context | NamingManager.getInitialContext(Hashtable<?,?> env) 使用指定环境属性创建一个初始上下文工厂。
static Context | NamingManager.getURLContext(String scheme, Hashtable<?,?> environment) 为给定的 URL 方案 id 创建一个上下文。

参数类型为 Context 的 javax.naming.spi 中的方法
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。

类型变量类型为 Context 的 javax.naming.spi 中的方法参数
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。

javax.sql.rowset.spi 中 Context 的使用

参数类型为 Context 的 javax.sql.rowset.spi 中的方法
static void SyncFactory.setJNDIContext(Context ctx)
设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ContextNotEmptyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ContextNotEmptyException
的使用

没有 javax.naming.ContextNotEmptyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.InitialContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InitialContext
的使用

使用 InitialContext 的软件包
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.directory 中 InitialContext 的使用

javax.naming.directory 中 InitialContext 的子类
 class InitialDirContext
此类是执行目录操作的初始上下文。

javax.naming.ldap 中 InitialContext 的使用

javax.naming.ldap 中 InitialContext 的子类
 class InitialLdapContext
此类是执行 LDAPv3 样式的扩展操作和控件的初始上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.InsufficientResourcesException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InsufficientResourcesException
的使用

没有 javax.naming.InsufficientResourcesException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.InterruptedNamingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InterruptedNamingException
的使用

没有 javax.naming.InterruptedNamingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.InvalidNameException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.InvalidNameException
的使用

使用 InvalidNameException 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming 中 InvalidNameException 的使用

抛出 InvalidNameException 的 javax.naming 中的方法
Name | CompositeName.add(int posn, String comp) 在此复合名称中的指定位置添加单个组件。
Name | CompoundName.add(int posn, String comp) 在此组合名称中的指定位置添加单个组件。
Name | Name.add(int posn, String comp) 在此名称中的指定位置添加单个组件。
Name | CompositeName.add(String comp) 将单个组件添加到此复合名称的末尾。
Name | CompoundName.add(String comp) 将单个组件添加到此组合名称的末尾。
Name | Name.add(String comp) 将单个组件添加到此名称的末尾。
Name | CompositeName.addAll(int posn, Name n) 按顺序将复合名称的组件添加到此复合名称中的指定位置。
Name | CompoundName.addAll(int posn, Name n) 按顺序将组合名称的组件添加到此组合名称中的指定位置。
Name | Name.addAll(int posn, Name n) 按顺序将名称的组件添加到此名称中的指定位置。
Name | CompositeName.addAll(Name suffix) 按顺序将复合名称的组件添加到此复合名称的末尾。
Name | CompoundName.addAll(Name suffix) 按顺序将组合名称的组件添加到此组合名称的末尾。
Name | Name.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Object | CompositeName.remove(int posn) 从此复合名称中删除一个组件。
Object | CompoundName.remove(int posn) 从此组合名称中删除一个组件。
Object | Name.remove(int posn) 从此名称中移除一个组件。

抛出 InvalidNameException 的 javax.naming 中的构造方法
CompositeName(String n)
通过使用复合名称语法（从左到右，用斜杠分隔）解析字符串 n 来构造一个新的复合名称实例。
CompoundName(String n, Properties syntax)
通过解析使用提供的 syntax 属性所指定的语法的字符串 n 来构造一个新的组合名称实例。

javax.naming.ldap 中 InvalidNameException 的使用

抛出 InvalidNameException 的 javax.naming.ldap 中的方法
Name | LdapName.add(int posn, String comp) 将单个组件添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(String comp) 将单个组件添加到此 LDAP 名称的末尾。
Name | LdapName.addAll(int posn, Name suffix) 按顺序将名称的组件添加到此名称中的指定位置。
Name | LdapName.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Object | LdapName.remove(int posn) 从此 LDAP 名称中移除一个组件。

抛出 InvalidNameException 的 javax.naming.ldap 中的构造方法
LdapName(String name)
根据给定标识名构造 LDAP 名称。
Rdn(Attributes attrSet)
根据给定属性集构造 Rdn。
Rdn(String rdnString)
根据给定字符串构造 Rdn。
Rdn(String type, Object value)
根据给定属性类型和值构造 Rdn。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.LimitExceededException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LimitExceededException
的使用

使用 LimitExceededException 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 LimitExceededException 的使用

javax.naming 中 LimitExceededException 的子类
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.LinkException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LinkException
的使用

使用 LinkException 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 LinkException 的使用

javax.naming 中 LinkException 的子类
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.LinkLoopException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LinkLoopException
的使用

没有 javax.naming.LinkLoopException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.LinkRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.LinkRef
的使用

没有 javax.naming.LinkRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.MalformedLinkException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.MalformedLinkException
的使用

没有 javax.naming.MalformedLinkException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.Name 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.Name
的使用

使用 Name 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming 中 Name 的使用

实现 Name 的 javax.naming 中的类
class | CompositeName 此类表示一个复合名称，即一个跨多个名称空间组件名称的序列。
class | CompoundName 此类表示一个组合名称，即一个取自层次名称空间的名称。

声明为 Name 的 javax.naming 中的字段
protected Name | CannotProceedException.altName 包含已解析对象的名称，该名称相对于上下文 altNameCtx。
protected Name | LinkException.linkRemainingName 包含尚未解析的剩余链接名称。
protected Name | LinkException.linkResolvedName 包含已成功解析的链接部分。
protected Name | NamingException.remainingName 包含尚未解析的剩余名称。
protected Name | CannotProceedException.remainingNewName 包含 Context.rename() 第二个 "name" 参数的剩余未解析部分。
protected Name | NamingException.resolvedName 包含已成功解析的名称部分。

返回 Name 的 javax.naming 中的方法
 Name CompositeName.add(int posn, String comp)
在此复合名称中的指定位置添加单个组件。
 Name CompoundName.add(int posn, String comp)
在此组合名称中的指定位置添加单个组件。
 Name Name.add(int posn, String comp)
在此名称中的指定位置添加单个组件。
 Name CompositeName.add(String comp)
将单个组件添加到此复合名称的末尾。
 Name CompoundName.add(String comp)
将单个组件添加到此组合名称的末尾。
 Name Name.add(String comp)
将单个组件添加到此名称的末尾。
 Name CompositeName.addAll(int posn, Name n)
按顺序将复合名称的组件添加到此复合名称中的指定位置。
 Name CompoundName.addAll(int posn, Name n)
按顺序将组合名称的组件添加到此组合名称中的指定位置。
 Name Name.addAll(int posn, Name n)
按顺序将名称的组件添加到此名称中的指定位置。
 Name CompositeName.addAll(Name suffix)
按顺序将复合名称的组件添加到此复合名称的末尾。
 Name CompoundName.addAll(Name suffix)
按顺序将组合名称的组件添加到此组合名称的末尾。
 Name Name.addAll(Name suffix)
按顺序将名称的组件添加到此名称的末尾。
 Name Context.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name InitialContext.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name CannotProceedException.getAltName()
检索此异常的 altName 字段。
 Name LinkException.getLinkRemainingName()
检索链接名称的剩余未解析部分。
 Name LinkException.getLinkResolvedName()
检索成功被解析的链接名称的开头部分。
 Name CompositeName.getPrefix(int posn)
创建一个复合名称，其组件由此复合名称中组件的前缀组成。
 Name CompoundName.getPrefix(int posn)
创建一个组合名称，其组件由此组合名称中组件的前缀组成。
 Name Name.getPrefix(int posn)
创建一个名称，其组件由此名称中组件的前缀组成。
 Name NamingException.getRemainingName()
检索名称的剩余未解析部分。
 Name CannotProceedException.getRemainingNewName()
检索此异常的 "remaining new name" 字段，当执行 rename() 操作期间抛出此异常时，将使用该字段。
 Name NamingException.getResolvedName()
检索成功被解析的名称的开头部分。
 Name CompositeName.getSuffix(int posn)
创建一个复合名称，其组件由此复合名称中组件的后缀组成。
 Name CompoundName.getSuffix(int posn)
创建一个组合名称，其组件由该组合名称中组件的后缀组成。
 Name Name.getSuffix(int posn)
创建一个名称，其组件由此名称中组件的后缀组成。
 Name NameParser.parse(String name)
将某一名称解析成其组件。

参数类型为 Name 的 javax.naming 中的方法
 Name CompositeName.addAll(int posn, Name n)
按顺序将复合名称的组件添加到此复合名称中的指定位置。
 Name CompoundName.addAll(int posn, Name n)
按顺序将组合名称的组件添加到此组合名称中的指定位置。
 Name Name.addAll(int posn, Name n)
按顺序将名称的组件添加到此名称中的指定位置。
 Name CompositeName.addAll(Name suffix)
按顺序将复合名称的组件添加到此复合名称的末尾。
 Name CompoundName.addAll(Name suffix)
按顺序将组合名称的组件添加到此组合名称的末尾。
 Name Name.addAll(Name suffix)
按顺序将名称的组件添加到此名称的末尾。
 void NamingException.appendRemainingName(Name name)
将 'name' 中的组件作为剩余名称中最后的组件添加。
 void Context.bind(Name name, Object obj)
将名称绑定到对象。
 void InitialContext.bind(Name name, Object obj)
 Name Context.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name InitialContext.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Context Context.createSubcontext(Name name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(Name name)
 void Context.destroySubcontext(Name name)
销毁指定上下文，并将它从名称空间中移除。
 void InitialContext.destroySubcontext(Name name)
static
<T> T
InitialContext.doLookup(Name name)
获取指定对象的静态方法。
 boolean CompositeName.endsWith(Name n)
确定某一复合名称是否是此复合名称的后缀。
 boolean CompoundName.endsWith(Name n)
确定某一组合名称是否是此组合名称的后缀。
 boolean Name.endsWith(Name n)
确定此名称是否以某一指定后缀结束。
 NameParser Context.getNameParser(Name name)
检索与指定上下文关联的解析器。
 NameParser InitialContext.getNameParser(Name name)
protected  Context InitialContext.getURLOrDefaultInitCtx(Name name)
获取用来解析 name 的上下文。
 NamingEnumeration<NameClassPair> Context.list(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<NameClassPair> InitialContext.list(Name name)
 NamingEnumeration<Binding> Context.listBindings(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 NamingEnumeration<Binding> InitialContext.listBindings(Name name)
 Object Context.lookup(Name name)
检索指定的对象。
 Object InitialContext.lookup(Name name)
 Object Context.lookupLink(Name name)
按照除名称的最终原子组件以外的链接检索指定对象。
 Object InitialContext.lookupLink(Name name)
 void Context.rebind(Name name, Object obj)
将名称绑定到对象，重写任何现有绑定。
 void InitialContext.rebind(Name name, Object obj)
 void Context.rename(Name oldName, Name newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void InitialContext.rename(Name oldName, Name newName)
 void CannotProceedException.setAltName(Name altName)
设置此异常的 altName 字段。
 void LinkException.setLinkRemainingName(Name name)
设置此异常的剩余链接名称字段。
 void LinkException.setLinkResolvedName(Name name)
设置此异常的已解析链接名称字段。
 void NamingException.setRemainingName(Name name)
设置此异常的剩余名称字段。
 void CannotProceedException.setRemainingNewName(Name newName)
设置此异常的 "remaining new name" 字段。
 void NamingException.setResolvedName(Name name)
设置此异常的已解析名称字段。
 boolean CompositeName.startsWith(Name n)
确定某一复合名称是否是此复合名称的前缀。
 boolean CompoundName.startsWith(Name n)
确定某一组合名称是否是此组合名称的前缀。
 boolean Name.startsWith(Name n)
确定此名称是否从某一指定前缀开始。
 void Context.unbind(Name name)
取消对指定对象的绑定。
 void InitialContext.unbind(Name name)

参数类型为 Name 的 javax.naming 中的构造方法
LinkRef(Name linkName)
为某一名称构造一个 LinkRef。

javax.naming.directory 中 Name 的使用

参数类型为 Name 的 javax.naming.directory 中的方法
void | DirContext.bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
Attributes | DirContext.getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | InitialDirContext.getAttributes(Name name)
Attributes | DirContext.getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
DirContext | DirContext.getSchema(Name name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(Name name)
DirContext | DirContext.getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
void | DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
void | DirContext.rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)

javax.naming.event 中 Name 的使用

参数类型为 Name 的 javax.naming.event 中的方法
void | EventContext.addNamingListener(Name target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
void | EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。

javax.naming.ldap 中 Name 的使用

实现 Name 的 javax.naming.ldap 中的类
 class LdapName
此类表示 RFC 2253 指定的标识名。

返回 Name 的 javax.naming.ldap 中的方法
Name | LdapName.add(int posn, Rdn comp) 将单个 RDN 添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(int posn, String comp) 将单个组件添加到此 LDAP 名称中的指定位置。
Name | LdapName.add(Rdn comp) 将单个 RDN 添加到此 LDAP 名称的末尾。
Name | LdapName.add(String comp) 将单个组件添加到此 LDAP 名称的末尾。
Name | LdapName.addAll(int posn, List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称中的指定位置。
Name | LdapName.addAll(int posn, Name suffix) 按顺序将名称的组件添加到此名称中的指定位置。
Name | LdapName.addAll(List<Rdn> suffixRdns) 按顺序将名称的 RDN 添加到此名称的末尾。
Name | LdapName.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
Name | LdapName.getPrefix(int posn) 创建一个名称，其组件由此 LDAP 名称中组件的前缀组成。
Name | LdapName.getSuffix(int posn) 创建一个名称，其组件由此 LDAP 名称中组件的后缀组成。

参数类型为 Name 的 javax.naming.ldap 中的方法
Name | LdapName.addAll(int posn, Name suffix) 按顺序将名称的组件添加到此名称中的指定位置。
Name | LdapName.addAll(Name suffix) 按顺序将名称的组件添加到此名称的末尾。
boolean | LdapName.endsWith(Name n) 确定此 LDAP 名称是否以某一指定 LDAP 名称后缀结尾。
boolean | LdapName.startsWith(Name n) 确定此 LDAP 名称是否从某一指定 LDAP 名称前缀开始。

javax.naming.spi 中 Name 的使用

声明为 Name 的 javax.naming.spi 中的字段
protected  Name ResolveResult.remainingName
该字段包含要解析的剩余名称。

返回 Name 的 javax.naming.spi 中的方法
 Name ResolveResult.getRemainingName()
检索名称的剩余未解析部分。

参数类型为 Name 的 javax.naming.spi 中的方法
void | ResolveResult.appendRemainingName(Name name) 将组件添加到剩余名称的末尾。
static Object | NamingManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment) 为指定对象和环境创建一个对象实例。
Object | ObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 使用指定的位置或引用信息创建一个对象。
Object | DirObjectFactory.getObjectInstance(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 使用位置或引用信息以及指定的属性创建一个对象。
static Object | DirectoryManager.getObjectInstance(Object refInfo, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 为指定对象、属性和环境创建一个对象实例。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
void | ResolveResult.setRemainingName(Name name) 将此结果的剩余名称字段设置为 name。

参数类型为 Name 的 javax.naming.spi 中的构造方法
ResolveResult(Object robj, Name rname)
构造一个新的 ResolveResult 实例，该实例由已解析 Object 和剩余名称组成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NameAlreadyBoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NameAlreadyBoundException
的使用

没有 javax.naming.NameAlreadyBoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NameClassPair 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NameClassPair
的使用

使用 NameClassPair 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming 中 NameClassPair 的使用

javax.naming 中 NameClassPair 的子类
 class Binding
此类表示上下文中一个名称到对象的绑定。

返回变量类型为 NameClassPair 的类型的 javax.naming 中的方法
NamingEnumeration<NameClassPair> | Context.list(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
NamingEnumeration<NameClassPair> | Context.list(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(String name)

javax.naming.directory 中 NameClassPair 的使用

javax.naming.directory 中 NameClassPair 的子类
 class SearchResult
此类表示作为 DirContext.search() 方法的结果返回的 NamingEnumeration 中的一项。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NameNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NameNotFoundException
的使用

没有 javax.naming.NameNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.NameParser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.NameParser
的使用

使用 NameParser 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 NameParser 的使用

返回 NameParser 的 javax.naming 中的方法
NameParser | Context.getNameParser(Name name) 检索与指定上下文关联的解析器。
NameParser | InitialContext.getNameParser(Name name)
NameParser | Context.getNameParser(String name) 检索与指定上下文关联的解析器。
NameParser | InitialContext.getNameParser(String name)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.NamingEnumeration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.NamingEnumeration
的使用

使用 NamingEnumeration 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。

javax.naming 中 NamingEnumeration 的使用

返回 NamingEnumeration 的 javax.naming 中的方法
NamingEnumeration<NameClassPair> | Context.list(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(Name name)
NamingEnumeration<NameClassPair> | Context.list(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
NamingEnumeration<NameClassPair> | InitialContext.list(String name)
NamingEnumeration<Binding> | Context.listBindings(Name name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(Name name)
NamingEnumeration<Binding> | Context.listBindings(String name) 枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
NamingEnumeration<Binding> | InitialContext.listBindings(String name)

javax.naming.directory 中 NamingEnumeration 的使用

返回 NamingEnumeration 的 javax.naming.directory 中的方法
NamingEnumeration<?> | Attribute.getAll() 检索属性值的枚举。
NamingEnumeration<? extends Attribute> | Attributes.getAll() 检索属性集中属性的枚举。
NamingEnumeration<?> | BasicAttribute.getAll() 检索此属性值的枚举。
NamingEnumeration<Attribute> | BasicAttributes.getAll()
NamingEnumeration<String> | Attributes.getIDs() 检索属性集中属性的 id 的枚举。
NamingEnumeration<String> | BasicAttributes.getIDs()
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NamingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NamingException
的使用

使用 NamingException 的软件包
javax.naming | 为访问命名服务提供类和接口。
javax.naming.directory | 扩展 javax.naming 包以提供访问目录服务的功能。
javax.naming.event | 在访问命名和目录服务时提供对事件通知的支持。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.naming.spi | 提供一些方法来动态地插入对通过 javax.naming 和相关包访问命名和目录服务的支持。

javax.naming 中 NamingException 的使用

javax.naming 中 NamingException 的子类
class | AuthenticationException 当访问命名或目录服务发生验证错误时，抛出此异常。
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | CannotProceedException 抛出此异常指示操作到达了名称中的某一点，在该点上操作无法继续进行。
class | CommunicationException 当客户端无法与目录或命名服务通信时，抛出此异常。
class | ConfigurationException 当存在配置问题时，抛出此异常。
class | ContextNotEmptyException 当试图销毁一个不为空的上下文时，抛出此异常。
class | InsufficientResourcesException 当无法使用资源完成所请求的操作时，抛出此异常。
class | InterruptedNamingException 当正被调用的命名操作已经被中断时，抛出此异常。
class | InvalidNameException 此异常指示被指定的名称不符合命名系统的命名语法。
class | LimitExceededException 当某一方法因为用户或系统指定的限制而异常终止时，抛出此异常。
class | LinkException 此异常用于描述解析链接时遇到的问题。
class | LinkLoopException 当检测到的某个循环试图解析某一链接，或者已达到某一特定于实现的链接计数限制时，抛出此异常。
class | MalformedLinkException 如果在解析或构造链接时遇到错误链接，则抛出此异常。
class | NameAlreadyBoundException 一些方法抛出此异常来指示因为名称已经绑定到另一个对象而无法添加某一绑定。
class | NameNotFoundException 当名称的组件由于没有被绑定而无法解析时，抛出此异常。
class | NamingSecurityException 此异常是 Context 和 DirContext 接口中的操作所抛出的与安全有关的异常的超类。
class | NoInitialContextException 当不能创建任何初始上下文实现时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。
class | NotContextException 当命名操作进行到需要上下文来继续该操作的某处，而解析的对象不是一个上下文时，抛出此异常。
class | OperationNotSupportedException 当上下文实现不支持将调用的操作时，抛出此异常。
class | PartialResultException 抛出此异常指示结果正在返回或者到目前为止只返回了部分结果，并且操作无法完成。
class | ReferralException 此抽象类用于表示一个引用异常，该异常是在响应某一引用（比如 LDAP v3 服务器返回的引用）时生成的。
class | ServiceUnavailableException 当试图与目录或命名服务通信，而该服务不可用时，抛出此异常。
class | SizeLimitExceededException 当某一方法生成的结果超出与大小有关的限制时，抛出此异常。
class | TimeLimitExceededException 当某一方法没有在指定的时间限制内终止时，抛出此异常。

抛出 NamingException 的 javax.naming 中的方法
 Object Context.addToEnvironment(String propName, Object propVal)
将一个新环境属性添加到此上下文的环境中。
 Object InitialContext.addToEnvironment(String propName, Object propVal)
 void Context.bind(Name name, Object obj)
将名称绑定到对象。
 void InitialContext.bind(Name name, Object obj)
 void Context.bind(String name, Object obj)
将名称绑定到对象。
 void InitialContext.bind(String name, Object obj)
 void Context.close()
关闭此上下文。
 void InitialContext.close()
 void NamingEnumeration.close()
关闭此枚举。
 Name Context.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Name InitialContext.composeName(Name name, Name prefix)
将此上下文的名称与相对于此上下文的名称组合。
 String Context.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。
 String InitialContext.composeName(String name, String prefix)
将此上下文的名称与相对于此上下文的名称组合。
 Context Context.createSubcontext(Name name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(Name name)
 Context Context.createSubcontext(String name)
创建并绑定一个新上下文。
 Context InitialContext.createSubcontext(String name)
 void Context.destroySubcontext(Name name)
销毁指定上下文，并将它从名称空间中移除。
 void InitialContext.destroySubcontext(Name name)
 void Context.destroySubcontext(String name)
销毁指定上下文，并将它从名称空间中移除。
 void InitialContext.destroySubcontext(String name)
static
<T> T
InitialContext.doLookup(Name name)
获取指定对象的静态方法。
static
<T> T
InitialContext.doLookup(String name)
获取指定对象的静态方法。
protected  Context InitialContext.getDefaultInitCtx()
通过调用 NamingManager.getInitialContext() 获取初始上下文，并将它缓存在 defaultInitCtx 中。
 Hashtable<?,?> Context.getEnvironment()
检索对此上下文有效的环境。
 Hashtable<?,?> InitialContext.getEnvironment()
 String LinkRef.getLinkName()
检索此链接的名称。
 String Context.getNameInNamespace()
在此上下文自己的名称空间中检索其完全名称。
 String InitialContext.getNameInNamespace()
 NameParser Context.getNameParser(Name name)
检索与指定上下文关联的解析器。
 NameParser InitialContext.getNameParser(Name name)
 NameParser Context.getNameParser(String name)
检索与指定上下文关联的解析器。
 NameParser InitialContext.getNameParser(String name)
 Reference Referenceable.getReference()
检索此对象的 Reference。
abstract  Context ReferralException.getReferralContext()
检索继续该方法的上下文。
abstract  Context ReferralException.getReferralContext(Hashtable<?,?> env)
使用环境属性检索继续该方法的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(Name name)
获取用来解析 name 的上下文。
protected  Context InitialContext.getURLOrDefaultInitCtx(String name)
获取用来解析字符串名称 name 的上下文。
 boolean NamingEnumeration.hasMore()
确定枚举中是否还有元素。
protected  void InitialContext.init(Hashtable<?,?> environment)
使用所提供的环境初始化初始上下文。
 NamingEnumeration<NameClassPair> Context.list(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<NameClassPair> InitialContext.list(Name name)
 NamingEnumeration<NameClassPair> Context.list(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象的类名称。
 NamingEnumeration<NameClassPair> InitialContext.list(String name)
 NamingEnumeration<Binding> Context.listBindings(Name name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 NamingEnumeration<Binding> InitialContext.listBindings(Name name)
 NamingEnumeration<Binding> Context.listBindings(String name)
枚举绑定在指定上下文中的名称，以及绑定到这些名称的对象。
 NamingEnumeration<Binding> InitialContext.listBindings(String name)
 Object Context.lookup(Name name)
检索指定的对象。
 Object InitialContext.lookup(Name name)
 Object Context.lookup(String name)
检索指定的对象。
 Object InitialContext.lookup(String name)
 Object Context.lookupLink(Name name)
按照除名称的最终原子组件以外的链接检索指定对象。
 Object InitialContext.lookupLink(Name name)
 Object Context.lookupLink(String name)
按照除名称的最终原子组件以外的链接检索指定对象。
 Object InitialContext.lookupLink(String name)
 T NamingEnumeration.next()
检索枚举中的下一个元素。
 Name NameParser.parse(String name)
将某一名称解析成其组件。
 void Context.rebind(Name name, Object obj)
将名称绑定到对象，重写任何现有绑定。
 void InitialContext.rebind(Name name, Object obj)
 void Context.rebind(String name, Object obj)
将名称绑定到对象，重写所有现有绑定。
 void InitialContext.rebind(String name, Object obj)
 Object Context.removeFromEnvironment(String propName)
从此上下文的环境中移除一个环境属性。
 Object InitialContext.removeFromEnvironment(String propName)
 void Context.rename(Name oldName, Name newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void InitialContext.rename(Name oldName, Name newName)
 void Context.rename(String oldName, String newName)
将一个新名称绑定到已经被绑定到某一旧名称的对象上，并取消对旧名称的绑定。
 void InitialContext.rename(String oldName, String newName)
 void Context.unbind(Name name)
取消对指定对象的绑定。
 void InitialContext.unbind(Name name)
 void Context.unbind(String name)
取消对指定对象的绑定。
 void InitialContext.unbind(String name)

抛出 NamingException 的 javax.naming 中的构造方法
InitialContext()
构造一个初始上下文。
InitialContext(boolean lazy)
构造一个带有不进行初始化选项的初始上下文。
InitialContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始上下文。

javax.naming.directory 中 NamingException 的使用

javax.naming.directory 中 NamingException 的子类
class | AttributeInUseException 当操作试图添加已经存在的属性时抛出此异常。
class | AttributeModificationException 当试图添加、移除或修改与属性的（模式）定义或属性的状态有冲突的属性、属性标识符或属性值时抛出此异常。
class | InvalidAttributeIdentifierException 在试图用无效的属性标识符创建属性时，抛出此异常。
class | InvalidAttributesException 在尝试添加或修改不完全或不正确地指定的属性集时，抛出此异常。
class | InvalidAttributeValueException 在尝试添加一个与属性的模式定义有冲突的属性时，抛出此类。
class | InvalidSearchControlsException 在为搜索操作指定的 SearchControls 无效时，抛出此异常。
class | InvalidSearchFilterException 当指定的搜索过滤器无效时，抛出此异常。
class | NoSuchAttributeException 尝试访问不存在的属性时，抛出此异常。
class | SchemaViolationException 当方法在某些方面违反模式时，抛出此异常。

抛出 NamingException 的 javax.naming.directory 中的方法
void | DirContext.bind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(Name name, Object obj, Attributes attrs)
void | DirContext.bind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象。
void | InitialDirContext.bind(String name, Object obj, Attributes attrs)
DirContext | DirContext.createSubcontext(Name name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(Name name, Attributes attrs)
DirContext | DirContext.createSubcontext(String name, Attributes attrs) 创建并绑定新的上下文及关联的属性。
DirContext | InitialDirContext.createSubcontext(String name, Attributes attrs)
Object | Attribute.get() 检索此属性的其中一个值。
Object | BasicAttribute.get() 检索此属性的其中一个值。
Object | Attribute.get(int ix) 从属性值的有序列表中检索属性值。
Object | BasicAttribute.get(int ix)
NamingEnumeration<?> | Attribute.getAll() 检索属性值的枚举。
NamingEnumeration<?> | BasicAttribute.getAll() 检索此属性值的枚举。
DirContext | Attribute.getAttributeDefinition() 检索属性的模式定义。
DirContext | BasicAttribute.getAttributeDefinition() 检索此属性的模式定义。
Attributes | DirContext.getAttributes(Name name) 检索与命名对象关联的所有属性。
Attributes | InitialDirContext.getAttributes(Name name)
Attributes | DirContext.getAttributes(Name name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(Name name, String[] attrIds)
Attributes | DirContext.getAttributes(String name) 检索所有与命名对象关联的属性。
Attributes | InitialDirContext.getAttributes(String name)
Attributes | DirContext.getAttributes(String name, String[] attrIds) 检索与命名对象关联的选定属性。
Attributes | InitialDirContext.getAttributes(String name, String[] attrIds)
DirContext | Attribute.getAttributeSyntaxDefinition() 检索与属性关联的语法定义。
DirContext | BasicAttribute.getAttributeSyntaxDefinition() 检索与此属性关联的语法定义。
DirContext | DirContext.getSchema(Name name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(Name name)
DirContext | DirContext.getSchema(String name) 检索与命名对象关联的模式。
DirContext | InitialDirContext.getSchema(String name)
DirContext | DirContext.getSchemaClassDefinition(Name name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(Name name)
DirContext | DirContext.getSchemaClassDefinition(String name) 检索包含命名对象类定义的模式对象的上下文。
DirContext | InitialDirContext.getSchemaClassDefinition(String name)
void | DirContext.modifyAttributes(Name name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(Name name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(Name name, ModificationItem[] mods)
void | DirContext.modifyAttributes(String name, int mod_op, Attributes attrs) 修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, int mod_op, Attributes attrs)
void | DirContext.modifyAttributes(String name, ModificationItem[] mods) 使用有序的修改列表修改与命名对象关联的属性。
void | InitialDirContext.modifyAttributes(String name, ModificationItem[] mods)
void | DirContext.rebind(Name name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(Name name, Object obj, Attributes attrs)
void | DirContext.rebind(String name, Object obj, Attributes attrs) 将名称与关联的属性一起绑定到一个对象，并重写任何现有绑定。
void | InitialDirContext.rebind(String name, Object obj, Attributes attrs)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(Name name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(Name name, String filter, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes) 在单个上下文中搜索包含指定属性集的对象。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes)
NamingEnumeration<SearchResult> | DirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn) 在单个上下文中搜索包含指定属性集的对象，并检索选定的属性。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, Attributes matchingAttributes, String[] attributesToReturn)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filterExpr, Object[] filterArgs, SearchControls cons)
NamingEnumeration<SearchResult> | DirContext.search(String name, String filter, SearchControls cons) 在命名上下文或对象中搜索符合给定搜索过滤器的项。
NamingEnumeration<SearchResult> | InitialDirContext.search(String name, String filter, SearchControls cons)

抛出 NamingException 的 javax.naming.directory 中的构造方法
InitialDirContext()
构造一个初始 DirContext。
InitialDirContext(boolean lazy)
构造一个具有不进行初始化的选项的初始 DirContext。
InitialDirContext(Hashtable<?,?> environment)
使用所提供的环境构造一个初始 DirContext。

javax.naming.event 中 NamingException 的使用

返回 NamingException 的 javax.naming.event 中的方法
 NamingException NamingExceptionEvent.getException()
检索抛出的异常。

抛出 NamingException 的 javax.naming.event 中的方法
void | EventContext.addNamingListener(Name target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标和范围所标识的对象发生更改时触发。
void | EventDirContext.addNamingListener(Name target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(Name target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由 target 指定的对象上的搜索过滤器 filter 标识的对象时触发。
void | EventContext.addNamingListener(String target, int scope, NamingListener l) 添加接收命名事件的侦听器，这些事件在目标名称和范围指定的对象发生更改时触发。
void | EventDirContext.addNamingListener(String target, String filter, Object[] filterArgs, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 和过滤器参数标识的对象时触发。
void | EventDirContext.addNamingListener(String target, String filter, SearchControls ctls, NamingListener l) 添加接收命名事件的侦听器，这些事件在修改由字符串目标名称指定的对象上的搜索过滤器 filter 标识的对象时触发。
void | EventContext.removeNamingListener(NamingListener l) 从此 EventContext 触发的接收命名事件中移除一个侦听器。
boolean | EventContext.targetMustExist() 确定侦听器是否可以注册不存在的感兴趣目标。

参数类型为 NamingException 的 javax.naming.event 中的构造方法
NamingExceptionEvent(EventContext source, NamingException exc)
使用在抛出过 NamingException 的上下文和抛出的异常构造一个 NamingExceptionEvent 的实例。

javax.naming.ldap 中 NamingException 的使用

javax.naming.ldap 中 NamingException 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

返回 NamingException 的 javax.naming.ldap 中的方法
NamingException | SortResponseControl.getException() 检索适合结果代码的 NamingException。
NamingException | UnsolicitedNotification.getException() 检索使用服务器发送的信息构造的异常。

抛出 NamingException 的 javax.naming.ldap 中的方法
ExtendedResponse | ExtendedRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与此请求对应的响应对象。
ExtendedResponse | StartTlsRequest.createExtendedResponse(String id, byte[] berValue, int offset, int length) 创建与 LDAP StartTLS 扩展请求相对应的扩展响应对象。
ExtendedResponse | InitialLdapContext.extendedOperation(ExtendedRequest request)
ExtendedResponse | LdapContext.extendedOperation(ExtendedRequest request) 执行扩展操作。
Control[] | InitialLdapContext.getConnectControls()
Control[] | LdapContext.getConnectControls() 检索对此上下文有效的连接请求控件。
abstract Control | ControlFactory.getControlInstance(Control ctl) 使用此控件工厂创建控件。
static Control | ControlFactory.getControlInstance(Control ctl, Context ctx, Hashtable<?,?> env) 使用已知控件工厂创建控件。
Control[] | HasControls.getControls() 从实现此接口的对象中检索 Control 数组。
abstract Context | LdapReferralException.getReferralContext() 使用上下文的环境（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env) 使用环境属性（但不使用控件）检索继续该方法的上下文。
abstract Context | LdapReferralException.getReferralContext(Hashtable<?,?> env, Control[] reqCtls) 使用请求控件和环境属性检索继续该方法的上下文。
Control[] | InitialLdapContext.getRequestControls()
Control[] | LdapContext.getRequestControls() 检索对此上下文有效的请求控件。
Control[] | InitialLdapContext.getResponseControls()
Control[] | LdapContext.getResponseControls() 检索对此上下文调用的最后一个方法所生成的响应控件。
LdapContext | InitialLdapContext.newInstance(Control[] reqCtls)
LdapContext | LdapContext.newInstance(Control[] requestControls) 创建此上下文的新实例，使用请求控件进行初始化。
void | InitialLdapContext.reconnect(Control[] connCtls)
void | LdapContext.reconnect(Control[] connCtls) 使用提供的控件和此上下文的环境重新连接到 LDAP 服务器。
void | InitialLdapContext.setRequestControls(Control[] requestControls)
void | LdapContext.setRequestControls(Control[] requestControls) 为在此上下文上后续调用的方法设置请求控件。

抛出 NamingException 的 javax.naming.ldap 中的构造方法
InitialLdapContext()
不使用任何环境属性或连接请求控件构造初始上下文。
InitialLdapContext(Hashtable<?,?> environment, Control[] connCtls)
使用环境属性或连接请求控件构造初始上下文。

javax.naming.spi 中 NamingException 的使用

抛出 NamingException 的 javax.naming.spi 中的方法
InitialContextFactory | InitialContextFactoryBuilder.createInitialContextFactory(Hashtable<?,?> environment) 使用指定环境创建一个初始上下文工厂。
ObjectFactory | ObjectFactoryBuilder.createObjectFactory(Object obj, Hashtable<?,?> environment) 使用所提供的环境创建一个新对象工厂。
static Context | NamingManager.getContinuationContext(CannotProceedException cpe) 创建一个将继续上下文操作的上下文。
static DirContext | DirectoryManager.getContinuationDirContext(CannotProceedException cpe) 创建一个将继续某个 DirContext 操作的上下文。
Context | InitialContextFactory.getInitialContext(Hashtable<?,?> environment) 创建一个初始上下文，以便开始进行名称解析。
static Context | NamingManager.getInitialContext(Hashtable<?,?> env) 使用指定环境属性创建一个初始上下文工厂。
static Object | NamingManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象的状态。
Object | StateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment) 检索用于绑定的对象状态。
DirStateFactory.Result | DirStateFactory.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes inAttrs) 在给定要传输的对象和属性的情况下检索用于绑定的对象的状态。
static DirStateFactory.Result | DirectoryManager.getStateToBind(Object obj, Name name, Context nameCtx, Hashtable<?,?> environment, Attributes attrs) 在给定初始对象及其属性时，检索用于绑定的对象的状态。
static Context | NamingManager.getURLContext(String scheme, Hashtable<?,?> environment) 为给定的 URL 方案 id 创建一个上下文。
ResolveResult | Resolver.resolveToClass(Name name, Class<? extends Context> contextType) 部分解析某一名称。
ResolveResult | Resolver.resolveToClass(String name, Class<? extends Context> contextType) 部分解析某一名称。
static void | NamingManager.setInitialContextFactoryBuilder(InitialContextFactoryBuilder builder) 将 InitialContextFactory 生成器设置为生成器。
static void | NamingManager.setObjectFactoryBuilder(ObjectFactoryBuilder builder) ObjectFactoryBuilder 确定尝试加载对象工厂时使用的策略。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NamingSecurityException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NamingSecurityException
的使用

使用 NamingSecurityException 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 NamingSecurityException 的使用

javax.naming 中 NamingSecurityException 的子类
class | AuthenticationException 当访问命名或目录服务发生验证错误时，抛出此异常。
class | AuthenticationNotSupportedException 当所请求验证的特定 flavor 不受支持时，抛出此异常。
class | NoPermissionException 当试图执行某一操作，而客户端没有执行该操作的权限时，抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NoInitialContextException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NoInitialContextException
的使用

没有 javax.naming.NoInitialContextException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.RefAddr 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.RefAddr
的使用

使用 RefAddr 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 RefAddr 的使用

javax.naming 中 RefAddr 的子类
class | BinaryRefAddr 此类表示通信终端地址的二进制形式。
class | StringRefAddr 此类表示通信终端地址的字符串形式。

类型参数类型为 RefAddr 的 javax.naming 中的字段
protected  Vector<RefAddr> Reference.addrs
包含此 Reference 中所包含的地址。

返回 RefAddr 的 javax.naming 中的方法
RefAddr | Reference.get(int posn) 检索索引 posn 处的地址。
RefAddr | Reference.get(String addrType) 检索地址类型为 'addrType' 的第一个地址。

返回变量类型为 RefAddr 的类型的 javax.naming 中的方法
 Enumeration<RefAddr> Reference.getAll()
返回此索引中的地址所组成的枚举。

参数类型为 RefAddr 的 javax.naming 中的方法
void | Reference.add(int posn, RefAddr addr) 将地址添加到地址列表中的索引 posn 处。
void | Reference.add(RefAddr addr) 将地址添加到地址列表的末尾。

参数类型为 RefAddr 的 javax.naming 中的构造方法
Reference(String className, RefAddr addr)
使用类名称 'className' 和一个地址构造对某个对象的新引用。
Reference(String className, RefAddr addr, String factory, String factoryLocation)
使用类名称 'className'、对象工厂的类名称和位置以及对象的地址创建该对某个对象的新引用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NoPermissionException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NoPermissionException
的使用

没有 javax.naming.NoPermissionException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.NotContextException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.NotContextException
的使用

没有 javax.naming.NotContextException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.OperationNotSupportedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.OperationNotSupportedException
的使用

没有 javax.naming.OperationNotSupportedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.PartialResultException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.PartialResultException
的使用

没有 javax.naming.PartialResultException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.Reference 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.Reference
的使用

使用 Reference 的软件包
javax.naming 为访问命名服务提供类和接口。

javax.naming 中 Reference 的使用

javax.naming 中 Reference 的子类
 class LinkRef
此类表示一个 Reference，其内容是绑定到上下文中的原子名称的一个名称，称为链接名称 (link name)。

返回 Reference 的 javax.naming 中的方法
 Reference Referenceable.getReference()
检索此对象的 Reference。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.naming.Referenceable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.naming.Referenceable
的使用

没有 javax.naming.Referenceable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ReferralException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ReferralException
的使用

使用 ReferralException 的软件包
javax.naming.ldap 提供对 LDAPv3 扩展操作和控件的支持。

javax.naming.ldap 中 ReferralException 的使用

javax.naming.ldap 中 ReferralException 的子类
 class LdapReferralException
此抽象类用于表示 LDAP 引用异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.ServiceUnavailableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.ServiceUnavailableException
的使用

没有 javax.naming.ServiceUnavailableException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.SizeLimitExceededException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.SizeLimitExceededException
的使用

没有 javax.naming.SizeLimitExceededException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.StringRefAddr 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.StringRefAddr
的使用

没有 javax.naming.StringRefAddr 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.naming.TimeLimitExceededException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.naming.TimeLimitExceededException
的使用

没有 javax.naming.TimeLimitExceededException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ServerSocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.net
类 ServerSocketFactory

java.lang.Object
    继承者  javax.net.ServerSocketFactory
直接已知子类：
SSLServerSocketFactory
public abstract class ServerSocketFactory
extends Object

此类创建服务器套接字。它可以被其他的工厂子类化，这些工厂创建特定类型的服务器套接字。这为其他的公共套接字级功能提供了通用框架。它是套接字工厂的服务器端对应物，同样也提供了一种方式，用来捕获与正在创建的套接字相关的各种策略。

像套接字工厂一样，服务器 Socket 工厂的实例也有用来创建套接字的方法。还存在一个特定于环境的默认服务器套接字工厂；框架则通常使用它们自己的自定义工厂。

从以下版本开始：
1.4
另请参见：
SocketFactory

构造方法摘要
protected ServerSocketFactory()
创建服务器套接字工厂。
方法摘要
ServerSocket | createServerSocket() 返回未绑定的服务器套接字。
abstract ServerSocket | createServerSocket(int port) 返回绑定到指定端口的服务器套接字。
abstract ServerSocket | createServerSocket(int port, int backlog) 返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。
abstract ServerSocket | createServerSocket(int port, int backlog, InetAddress ifAddress) 返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。
static ServerSocketFactory | getDefault() 返回该环境默认套接字工厂的一个副本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServerSocketFactory

protected ServerSocketFactory()
创建服务器套接字工厂。

方法详细信息

getDefault

public static ServerSocketFactory getDefault()
返回该环境默认套接字工厂的一个副本。

返回：
ServerSocketFactory

createServerSocket

public ServerSocket createServerSocket()
                                throws IOException
返回未绑定的服务器套接字。用给与此工厂的套接字选项（例如，接受超时）配置该套接字。

返回：
未绑定的套接字
抛出：
IOException - 如果不能创建套接字
另请参见：
ServerSocket.bind(java.net.SocketAddress),
ServerSocket.bind(java.net.SocketAddress, int),
ServerSocket.ServerSocket()

createServerSocket

public abstract ServerSocket createServerSocket(int port)
                                         throws IOException
返回绑定到指定端口的服务器套接字。用给与此工厂的套接字选项（例如，接受超时）配置该套接字。

参数：
port - 要侦听的端口
返回：
ServerSocket
抛出：
IOException - 如果出现网络错误
另请参见：
ServerSocket.ServerSocket(int)

createServerSocket

public abstract ServerSocket createServerSocket(int port,
                                                int backlog)
                                         throws IOException
返回绑定到指定端口的服务器套接字，并且使用指定的连接 backlog。用给与此工厂的套接字选项（例如，接受超时）配置该套接字。

参数：
port - 要侦听的端口
backlog - 已排队的连接数
返回：
ServerSocket
抛出：
IOException - 如果出现网络错误
另请参见：
ServerSocket.ServerSocket(int, int)

createServerSocket

public abstract ServerSocket createServerSocket(int port,
                                                int backlog,
                                                InetAddress ifAddress)
                                         throws IOException
返回绑定到指定端口的服务器套接字，该套接字带有指定的侦听 backlog 和本地 IP。ifAddress 参数可以在 ServerSocket 的多宿主主机上使用，ServerSocket 仅接受对其地址之一的连接请求。如果 ifAddress 为 null，则它将接受所有本地地址上的连接。用给与此工厂的套接字选项（例如，接受超时）配置该套接字。

参数：
port - 要侦听的端口
backlog - 已排队的连接数
ifAddress - 要使用的网络接口地址
返回：
ServerSocket
抛出：
IOException - 如果出现网络错误
另请参见：
ServerSocket.ServerSocket(int, int, java.net.InetAddress)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.net
类 SocketFactory

java.lang.Object
    继承者  javax.net.SocketFactory
直接已知子类：
SSLSocketFactory
public abstract class SocketFactory
extends Object

此类创建套接字。它可以被其他工厂子类化，这些工厂创建特定的套接字子类，从而为其他的公共套接字级功能提供了通用框架。

套接字工厂是一种捕获与正被创建的套接字相关的各种策略的简单方式，以不需要对请求套接字的代码进行特殊配置的方式生成这种套接字。

  • 由于工厂和套接字的多态性，只要通过向应用程序代码传递不同种类的工厂，那么相同的应用程序代码就可使用不同种类的套接字。
  • 可以使用构造套接字时所用的参数来自定义工厂本身。因此举例来说，可以自定义工厂返回带有不同网络超时或已经配置好的安全参数的套接字。
  • 返回给应用程序的套接字可以是 java.net.Socket 的子类，这样它们可以直接为诸如压缩、安全性、记录标记、统计信息收集或防火墙隧道等特性公开新的 API。

工厂类由特定于环境的配置机制来指定。例如，getDefault 方法可以返回适合于特定用户或 applet 的工厂，框架可以使用为其自身目的所自定义的工厂。

从以下版本开始：
1.4
另请参见：
ServerSocketFactory

构造方法摘要
protected SocketFactory()
创建一个 SocketFactory。
方法摘要
Socket | createSocket() 创建一个未连接的套接字。
abstract Socket | createSocket(InetAddress host, int port) 创建一个套接字并把它连接到指定地址上的指定端口号。
abstract Socket | createSocket(InetAddress address, int port, InetAddress localAddress, int localPort) 创建一个套接字并把它连接到指定远程端口上的指定远程地址。
abstract Socket | createSocket(String host, int port) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
abstract Socket | createSocket(String host, int port, InetAddress localHost, int localPort) 创建一个套接字并把它连接到指定远程主机上的指定远程端口。
static SocketFactory | getDefault() 返回该环境默认套接字工厂的一个副本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SocketFactory

protected SocketFactory()
创建一个 SocketFactory。

方法详细信息

getDefault

public static SocketFactory getDefault()
返回该环境默认套接字工厂的一个副本。

返回：
默认的 SocketFactory

createSocket

public Socket createSocket()
                    throws IOException
创建一个未连接的套接字。

返回：
未连接的套接字
抛出：
IOException - 如果不能创建套接字
另请参见：
Socket.connect(java.net.SocketAddress),
Socket.connect(java.net.SocketAddress, int),
Socket.Socket()

createSocket

public abstract Socket createSocket(String host,
                                    int port)
                             throws IOException,
                                    UnknownHostException
创建一个套接字并把它连接到指定远程主机上的指定远程端口。使用为此工厂建立的套接字选项来配置此套接字。

参数：
host - 服务器主机
port - 服务器端口
返回：
Socket
抛出：
IOException - 如果创建套接字时出现 I/O 错误
UnknownHostException - 如果主机是未知的
另请参见：
Socket.Socket(String, int)

createSocket

public abstract Socket createSocket(String host,
                                    int port,
                                    InetAddress localHost,
                                    int localPort)
                             throws IOException,
                                    UnknownHostException
创建一个套接字并把它连接到指定远程主机上的指定远程端口。套接字还会绑定到提供的本地地址和端口。使用为此工厂建立的套接字选项来配置此套接字。

参数：
host - 服务器主机
port - 服务器端口
localHost - 套接字绑定到的本地地址
localPort - 套接字绑定到的本地端口
返回：
Socket
抛出：
IOException - 如果创建套接字时出现 I/O 错误
UnknownHostException - 如果主机是未知的
另请参见：
Socket.Socket(String, int, java.net.InetAddress, int)

createSocket

public abstract Socket createSocket(InetAddress host,
                                    int port)
                             throws IOException
创建一个套接字并把它连接到指定地址上的指定端口号。使用为此工厂建立的套接字选项来配置此套接字。

参数：
host - 服务器主机
port - 服务器端口
返回：
Socket
抛出：
IOException - 如果创建套接字时出现 I/O 错误
另请参见：
Socket.Socket(java.net.InetAddress, int)

createSocket

public abstract Socket createSocket(InetAddress address,
                                    int port,
                                    InetAddress localAddress,
                                    int localPort)
                             throws IOException
创建一个套接字并把它连接到指定远程端口上的指定远程地址。套接字还会绑定到提供的本地地址和端口。使用为此工厂建立的套接字选项来配置此套接字。

参数：
address - 服务器网络地址
port - 服务器端口
localAddress - 客户端网络地址
localPort - 客户端端口
返回：
Socket
抛出：
IOException - 如果创建套接字时出现 I/O 错误
另请参见：
Socket.Socket(java.net.InetAddress, int, java.net.InetAddress, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.net (Java 2 Platform SE 6)

 javax.net
类
ServerSocketFactory
SocketFactory


javax.net (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.net

提供用于网络应用程序的类。

请参见：
描述

类摘要
ServerSocketFactory | 此类创建服务器套接字。
SocketFactory | 此类创建套接字。

软件包 javax.net 的描述

提供用于网络应用程序的类。这些类包括用于创建套接字的工厂。使用套接字工厂可以封装套接字的创建和配置行为。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.net 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.net 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.net.ServerSocketFactory
    • javax.net.SocketFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.net 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.net
的使用

使用 javax.net 的软件包
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。

javax.net 使用的 javax.net 中的类
ServerSocketFactory
此类创建服务器套接字。
SocketFactory
此类创建套接字。

javax.net.ssl 使用的 javax.net 中的类
ServerSocketFactory
此类创建服务器套接字。
SocketFactory
此类创建套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


CertPathTrustManagerParameters (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 CertPathTrustManagerParameters

java.lang.Object
    继承者  javax.net.ssl.CertPathTrustManagerParameters
所有已实现的接口：
ManagerFactoryParameters
public class CertPathTrustManagerParameters
extends Object
implements ManagerFactoryParameters

CertPathParameters 的包装器。使用 TrustManagerFactory.init() 方法，此类被用来向基于 TrustManager 的 CertPath 传递验证设置。

此类的实例是不可变的。

从以下版本开始：
1.5
另请参见：
X509TrustManager, TrustManagerFactory, CertPathParameters

构造方法摘要
CertPathTrustManagerParameters(CertPathParameters parameters)
根据指定的 parameters 构造新的 CertPathTrustManagerParameters。
方法摘要
 CertPathParameters getParameters()
返回此类封装的 CertPathParameters 的副本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CertPathTrustManagerParameters

public CertPathTrustManagerParameters(CertPathParameters parameters)
根据指定的 parameters 构造新的 CertPathTrustManagerParameters。复制该 parameters，以防止后续修改。

参数：
parameters - 要使用的 CertPathParameters
抛出：
NullPointerException - 如果 parameters 为 null
方法详细信息

getParameters

public CertPathParameters getParameters()
返回此类封装的 CertPathParameters 的副本。

返回：
此类封装的 CertPathParameters 的副本。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


HandshakeCompletedEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 HandshakeCompletedEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.net.ssl.HandshakeCompletedEvent
所有已实现的接口：
Serializable
public class HandshakeCompletedEvent
extends EventObject

此事件指示在给定的 SSL 连接上 SSL 握手结束。所有关于该握手结果的核心信息都通过 "SSLSession" 对象捕获。出于方便的考虑，此事件类提供对一些重要会话属性的直接访问。

此事件的源是在其上刚刚结束握手的 SSLSocket。

从以下版本开始：
1.4
另请参见：
SSLSocket, HandshakeCompletedListener, SSLSession, 序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
构造一个新的 HandshakeCompletedEvent。
方法摘要
String | getCipherSuite() 返回由握手产生的会话所使用的密码套件。
Certificate[] | getLocalCertificates() 返回握手期间发送到同位体的证书。
Principal | getLocalPrincipal() 返回握手期间发送到同位体的主体。
X509Certificate[] | getPeerCertificateChain() 返回同位体的标识，同位体是作为定义会话的一部分而标识的。
Certificate[] | getPeerCertificates() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Principal | getPeerPrincipal() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
SSLSession | getSession() 返回触发此事件的会话。
SSLSocket | getSocket() 返回作为此事件源的套接字。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HandshakeCompletedEvent

public HandshakeCompletedEvent(SSLSocket sock,
                               SSLSession s)
构造一个新的 HandshakeCompletedEvent。

参数：
sock - 作为事件源的 SSLSocket
s - 与此事件相关联的 SSLSession
方法详细信息

getSession

public SSLSession getSession()
返回触发此事件的会话。

返回：
此握手的 SSLSession

getCipherSuite

public String getCipherSuite()
返回由握手产生的会话所使用的密码套件。（这是从 SSLsession 获取密码套件的便捷方法。）

返回：
在此会话期间协商的密码套件名称。

getLocalCertificates

public Certificate[] getLocalCertificates()
返回握手期间发送到同位体的证书。注：仅当使用基于证书的密码套件时此方法才有用。 当在一次握手中有多个证书可供使用时，实现选择它认为是“最好的”可用证书链，并把它传输到另一方。此方法允许调用者知道实际所使用的证书链。

返回：
证书的有序数组，本地证书在前，后跟所有证书颁发机构。如果没有发送任何证书，则返回 null。
另请参见：
getLocalPrincipal()

getPeerCertificates

public Certificate[] getPeerCertificates()
                                  throws SSLPeerUnverifiedException
返回同位体的标识，同位体是作为定义会话的一部分而建立的。注：仅当使用基于证书的密码套件时才可以使用此方法；将它与非基于证书的密码套件（如 Kerberos）一起使用将抛出 SSLPeerUnverifiedException。

返回：
同位体证书的有序数组，同位体自己的证书在前，后跟所有证书颁发机构。
抛出：
SSLPeerUnverifiedException - 如果没有验证同位体。
另请参见：
getPeerPrincipal()

getPeerCertificateChain

public X509Certificate[] getPeerCertificateChain()
                                          throws SSLPeerUnverifiedException
返回同位体的标识，同位体是作为定义会话的一部分而标识的。注：仅当使用基于证书的密码套件时才可以使用此方法；将它与非基于证书的密码套件（如 Kerberos）一起使用将抛出 SSLPeerUnverifiedException。

注：此方法存在是为了和以前的版本兼容。新的应用程序应该使用 getPeerCertificates()。

返回：
同位体 X.509 证书的有序数组，同位体自己的证书在前，后跟所有证书颁发机构。（证书的格式是初始的 JSSE X509Certificate 格式。）
抛出：
SSLPeerUnverifiedException - 如果同位体未经验证。
另请参见：
getPeerPrincipal()

getPeerPrincipal

public Principal getPeerPrincipal()
                           throws SSLPeerUnverifiedException
返回同位体的标识，同位体是作为定义会话的一部分而建立的。

返回：
同位体的主体。返回基于 X509 的密码套件的最终实体证书的 X500Principal，以及 Kerberos 的密码套件的 KerberosPrincipal。
抛出：
SSLPeerUnverifiedException - 如果尚未验证同位体的标识
从以下版本开始：
1.5
另请参见：
getPeerCertificates(), getLocalPrincipal()

getLocalPrincipal

public Principal getLocalPrincipal()
返回握手期间发送到同位体的主体。

返回：
发送到同位体的主体。返回基于 X509 的密码套件的最终实体证书的 X500Principal，以及 Kerberos 的密码套件的 KerberosPrincipal。如果没有发送任何主体，则返回 null。
从以下版本开始：
1.5
另请参见：
getLocalCertificates(), getPeerPrincipal()

getSocket

public SSLSocket getSocket()
返回作为此事件源的套接字。（这是一个方便的功能，使应用程序无需进行强制类型转换即可写入代码。）

返回：
返回在其上进行连接的套接字。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HandshakeCompletedListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 HandshakeCompletedListener

所有超级接口：
EventListener
public interface HandshakeCompletedListener
extends EventListener

任何希望接收有关给定 SSL 连接上 SSL 协议握手结束通知的类实现此接口。

当 SSL 握手结束时，新安全参数将会建立。这些参数始终包括用来保护报文的安全密钥。它们也可能包括和新会话 相关联的参数，例如经过验证的同位体标识和新的 SSL 密码套件。

从以下版本开始：
1.4

方法摘要
 void handshakeCompleted(HandshakeCompletedEvent event)
当 SSL 握手结束时，在已注册的对象上调用此方法。

方法详细信息

handshakeCompleted

void handshakeCompleted(HandshakeCompletedEvent event)
当 SSL 握手结束时，在已注册的对象上调用此方法。

参数：
event - 标识在给定 SSL 连接上的 SSL 握手何时结束的事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HostnameVerifier (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 HostnameVerifier

public interface HostnameVerifier

此类是用于主机名验证的基接口。

在握手期间，如果 URL 的主机名和服务器的标识主机名不匹配，则验证机制可以回调此接口的实现程序来确定是否应该允许此连接。

策略可以是基于证书的或依赖于其他验证方案。

当验证 URL 主机名使用的默认规则失败时使用这些回调。

从以下版本开始：
1.4

方法摘要
 boolean verify(String hostname, SSLSession session)
验证主机名和服务器验证方案的匹配是可接受的。

方法详细信息

verify

boolean verify(String hostname,
               SSLSession session)
验证主机名和服务器验证方案的匹配是可接受的。

参数：
hostname - 主机名
session - 到主机的连接上使用的 SSLSession
返回：
如果主机名是可接受的，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HttpsURLConnection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 HttpsURLConnection

java.lang.Object
    继承者  java.net.URLConnection
        继承者  java.net.HttpURLConnection
            继承者  javax.net.ssl.HttpsURLConnection

public abstract class HttpsURLConnection
extends HttpURLConnection

HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。

有关 https 规范的更多详细信息，请参见 http://www.w3.org/pub/WWW/Protocols/ 和 RFC 2818。

此类使用 HostnameVerifier 和 SSLSocketFactory。为这两个类都定义了默认实现。但是，可以根据每个类（静态的）或每个实例来替换该实现。所有新 HttpsURLConnection 实例在创建时将被分配“默认的”静态值，通过在连接前调用每个实例适当的 set 方法可以重写这些值。

从以下版本开始：
1.4

字段摘要
protected  HostnameVerifier hostnameVerifier
此对象的 hostnameVerifier。
从类 java.net.HttpURLConnection 继承的字段
chunkLength, fixedContentLength, HTTP_ACCEPTED, HTTP_BAD_GATEWAY, HTTP_BAD_METHOD, HTTP_BAD_REQUEST, HTTP_CLIENT_TIMEOUT, HTTP_CONFLICT, HTTP_CREATED, HTTP_ENTITY_TOO_LARGE, HTTP_FORBIDDEN, HTTP_GATEWAY_TIMEOUT, HTTP_GONE, HTTP_INTERNAL_ERROR, HTTP_LENGTH_REQUIRED, HTTP_MOVED_PERM, HTTP_MOVED_TEMP, HTTP_MULT_CHOICE, HTTP_NO_CONTENT, HTTP_NOT_ACCEPTABLE, HTTP_NOT_AUTHORITATIVE, HTTP_NOT_FOUND, HTTP_NOT_IMPLEMENTED, HTTP_NOT_MODIFIED, HTTP_OK, HTTP_PARTIAL, HTTP_PAYMENT_REQUIRED, HTTP_PRECON_FAILED, HTTP_PROXY_AUTH, HTTP_REQ_TOO_LONG, HTTP_RESET, HTTP_SEE_OTHER, HTTP_SERVER_ERROR, HTTP_UNAUTHORIZED, HTTP_UNAVAILABLE, HTTP_UNSUPPORTED_TYPE, HTTP_USE_PROXY, HTTP_VERSION, instanceFollowRedirects, method, responseCode, responseMessage
从类 java.net.URLConnection 继承的字段
allowUserInteraction, connected, doInput, doOutput, ifModifiedSince, url, useCaches
构造方法摘要
protected HttpsURLConnection(URL url)
使用指定的 URL 创建 HttpsURLConnection。
方法摘要
abstract String | getCipherSuite() 返回在此连接上使用的密码套件。
static HostnameVerifier | getDefaultHostnameVerifier() 获取此类的新实例所继承的默认 HostnameVerifier。
static SSLSocketFactory | getDefaultSSLSocketFactory() 获取此类的新实例所继承的默认静态 SSLSocketFactory。
HostnameVerifier | getHostnameVerifier() 获取此实例适当的 HostnameVerifier。
abstract Certificate[] | getLocalCertificates() 返回握手期间发送给服务器的证书。
Principal | getLocalPrincipal() 返回握手期间发送到服务器的主体。
Principal | getPeerPrincipal() 返回服务器的主体，它是作为定义会话的一部分而建立的。
abstract Certificate[] | getServerCertificates() 返回服务器的证书链，它是作为定义会话的一部分而建立的。
SSLSocketFactory | getSSLSocketFactory() 获取为安全 https URL 连接创建套接字时使用的 SSL 套接字工厂。
static void | setDefaultHostnameVerifier(HostnameVerifier v) 设置此类的新实例所继承的默认 HostnameVerifier。
static void | setDefaultSSLSocketFactory(SSLSocketFactory sf) 设置此类的新实例所继承的默认 SSLSocketFactory。
void | setHostnameVerifier(HostnameVerifier v) 设置此实例的 HostnameVerifier。
void | setSSLSocketFactory(SSLSocketFactory sf) 设置当此实例为安全 https URL 连接创建套接字时使用的 SSLSocketFactory。
从类 java.net.HttpURLConnection 继承的方法
disconnect, getErrorStream, getFollowRedirects, getHeaderField, getHeaderFieldDate, getHeaderFieldKey, getInstanceFollowRedirects, getPermission, getRequestMethod, getResponseCode, getResponseMessage, setChunkedStreamingMode, setFixedLengthStreamingMode, setFollowRedirects, setInstanceFollowRedirects, setRequestMethod, usingProxy
从类 java.net.URLConnection 继承的方法
addRequestProperty, connect, getAllowUserInteraction, getConnectTimeout, getContent, getContent, getContentEncoding, getContentLength, getContentType, getDate, getDefaultAllowUserInteraction, getDefaultRequestProperty, getDefaultUseCaches, getDoInput, getDoOutput, getExpiration, getFileNameMap, getHeaderField, getHeaderFieldInt, getHeaderFields, getIfModifiedSince, getInputStream, getLastModified, getOutputStream, getReadTimeout, getRequestProperties, getRequestProperty, getURL, getUseCaches, guessContentTypeFromName, guessContentTypeFromStream, setAllowUserInteraction, setConnectTimeout, setContentHandlerFactory, setDefaultAllowUserInteraction, setDefaultRequestProperty, setDefaultUseCaches, setDoInput, setDoOutput, setFileNameMap, setIfModifiedSince, setReadTimeout, setRequestProperty, setUseCaches, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

hostnameVerifier

protected HostnameVerifier hostnameVerifier
此对象的 hostnameVerifier。

构造方法详细信息

HttpsURLConnection

protected HttpsURLConnection(URL url)
使用指定的 URL 创建 HttpsURLConnection。

参数：
url - URL
方法详细信息

getCipherSuite

public abstract String getCipherSuite()
返回在此连接上使用的密码套件。

返回：
密码套件
抛出：
IllegalStateException - 如果在连接建立前调用此方法。

getLocalCertificates

public abstract Certificate[] getLocalCertificates()
返回握手期间发送给服务器的证书。

注：仅当使用基于证书的密码套件时此方法才有用。

当在一次握手中有多个证书可供使用时，实现选择它认为是“最好的”可用证书链，并把它传输到另一方。此方法允许调用者知道实际发送的证书链。

返回：
证书的有序数组，客户端的证书在前，后跟所有证书颁发机构。如果没有发送任何证书，则返回 null。
抛出：
IllegalStateException - 如果在连接建立前调用此方法。
另请参见：
getLocalPrincipal()

getServerCertificates

public abstract Certificate[] getServerCertificates()
                                             throws SSLPeerUnverifiedException
返回服务器的证书链，它是作为定义会话的一部分而建立的。

注：仅当使用基于证书的密码套件时才可以使用此方法；将它与非基于证书的密码套件（如 Kerberos）一起使用将抛出 SSLPeerUnverifiedException。

返回：
服务器证书的有序数组，同位体的证书在前，后跟所有证书颁发机构。
抛出：
SSLPeerUnverifiedException - 如果没有验证同位体。
IllegalStateException - 如果在连接建立前调用此方法。
另请参见：
getPeerPrincipal()

getPeerPrincipal

public Principal getPeerPrincipal()
                           throws SSLPeerUnverifiedException
返回服务器的主体，它是作为定义会话的一部分而建立的。

注：子类应重写此方法。如果没有重写此方法，则对于基于证书的密码套件，它将默认返回服务器终端实体证书的 X500Principal，对于非基于证书的密码套件（如 Kerberos），则抛出 SSLPeerUnverifiedException。

返回：
服务器的主体。返回基于 X509 的密码套件的终端实体证书的 X500Principal，以及 Kerberos 的密码套件的 KerberosPrincipal。
抛出：
SSLPeerUnverifiedException - 如果没有验证同位体
IllegalStateException - 如果在连接建立前调用此方法。
从以下版本开始：
1.5
另请参见：
getServerCertificates(), getLocalPrincipal()

getLocalPrincipal

public Principal getLocalPrincipal()
返回握手期间发送到服务器的主体。

注：子类应重写此方法。如果没有重写此方法，则对于基于证书的密码套件，它将默认返回发送到服务器的终端实体证书的 X500Principal，对于非基于证书的密码套件（如 Kerberos），则返回 null。

返回：
发送到服务器的主体。返回基于 X509 的密码套件的终端实体证书的 X500Principal，以及 Kerberos 的密码套件的 KerberosPrincipal。如果没有发送任何主体，则返回 null。
抛出：
IllegalStateException - 如果在连接建立前调用此方法。
从以下版本开始：
1.5
另请参见：
getLocalCertificates(), getPeerPrincipal()

setDefaultHostnameVerifier

public static void setDefaultHostnameVerifier(HostnameVerifier v)
设置此类的新实例所继承的默认 HostnameVerifier。

如果不调用此方法，则默认的 HostnameVerifier 假定连接不应该被允许。

参数：
v - 默认的主机名校验器
抛出：
IllegalArgumentException - 如果 HostnameVerifier 参数为 null。
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许 SSLPermission("setHostnameVerifier")
另请参见：
getDefaultHostnameVerifier()

getDefaultHostnameVerifier

public static HostnameVerifier getDefaultHostnameVerifier()
获取此类的新实例所继承的默认 HostnameVerifier。

返回：
默认的主机名校验器
另请参见：
setDefaultHostnameVerifier(HostnameVerifier)

setHostnameVerifier

public void setHostnameVerifier(HostnameVerifier v)
设置此实例的 HostnameVerifier。

此类的新实例继承由 setDefaultHostnameVerifier 设置的默认静态主机名校验器。调用此方法会替换此对象的 HostnameVerifier。

参数：
v - 主机名校验器
抛出：
IllegalArgumentException - 如果 HostnameVerifier 参数为 null。
另请参见：
getHostnameVerifier(), setDefaultHostnameVerifier(HostnameVerifier)

getHostnameVerifier

public HostnameVerifier getHostnameVerifier()
获取此实例适当的 HostnameVerifier。

返回：
主机名校验器
另请参见：
setHostnameVerifier(HostnameVerifier), setDefaultHostnameVerifier(HostnameVerifier)

setDefaultSSLSocketFactory

public static void setDefaultSSLSocketFactory(SSLSocketFactory sf)
设置此类的新实例所继承的默认 SSLSocketFactory。

当为安全 https URL 连接创建套接字时使用套接字工厂。

参数：
sf - 默认的 SSL 套接字工厂
抛出：
IllegalArgumentException - 如果 SSLSocketFactory 参数为 null。
SecurityException - 如果安全管理器存在并且其 checkSetFactory 方法不允许指定套接字工厂。
另请参见：
getDefaultSSLSocketFactory()

getDefaultSSLSocketFactory

public static SSLSocketFactory getDefaultSSLSocketFactory()
获取此类的新实例所继承的默认静态 SSLSocketFactory。

当为安全 https URL 连接创建套接字时使用套接字工厂。

返回：
默认的 SSLSocketFactory
另请参见：
setDefaultSSLSocketFactory(SSLSocketFactory)

setSSLSocketFactory

public void setSSLSocketFactory(SSLSocketFactory sf)
设置当此实例为安全 https URL 连接创建套接字时使用的 SSLSocketFactory。

此类的新实例继承由 setDefaultSSLSocketFactory 设置的默认静态 SSLSocketFactory。调用此方法会替换此对象的 SSLSocketFactory。

参数：
sf - SSL 套接字工厂
抛出：
IllegalArgumentException - 如果 SSLSocketFactory 参数为 null。
另请参见：
getSSLSocketFactory()

getSSLSocketFactory

public SSLSocketFactory getSSLSocketFactory()
获取为安全 https URL 连接创建套接字时使用的 SSL 套接字工厂。

返回：
SSLSocketFactory
另请参见：
setSSLSocketFactory(SSLSocketFactory)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 KeyManager

所有已知子接口：
X509KeyManager
所有已知实现类：
X509ExtendedKeyManager
public interface KeyManager

这是用于 JSSE 密钥管理器的基接口。

KeyManager 负责管理用于验证到同位体的本地 SSLSocket 的密钥内容。如果没有密钥内容可以使用，则套接字将不能提供验证证书。

通过使用 KeyManagerFactory，或实现 KeyManager 子类之一来创建 KeyManager。

从以下版本开始：
1.4
另请参见：
KeyManagerFactory

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyManagerFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 KeyManagerFactory

java.lang.Object
    继承者  javax.net.ssl.KeyManagerFactory

public class KeyManagerFactory
extends Object

此类充当基于密钥内容源的密钥管理器的工厂。每个密钥管理器管理特定类型的、由安全套接字所使用的密钥内容。密钥内容是基于 KeyStore 和/或提供者特定的源。

从以下版本开始：
1.4
另请参见：
KeyManager

构造方法摘要
protected KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 KeyManagerFactory 对象。
方法摘要
String | getAlgorithm() 返回此 KeyManagerFactory 对象的算法名称。
static String | getDefaultAlgorithm() 获取默认的 KeyManagerFactory 算法名称。
static KeyManagerFactory | getInstance(String algorithm) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static KeyManagerFactory | getInstance(String algorithm, Provider provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static KeyManagerFactory | getInstance(String algorithm, String provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
KeyManager[] | getKeyManagers() 为每类密钥内容返回一个密钥管理器。
Provider | getProvider() 返回此 KeyManagerFactory 对象的提供者。
void | init(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
void | init(ManagerFactoryParameters spec) 使用特定于提供者的密钥内容源初始化此工厂。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyManagerFactory

protected KeyManagerFactory(KeyManagerFactorySpi factorySpi,
                            Provider provider,
                            String algorithm)
创建 KeyManagerFactory 对象。

参数：
factorySpi - 委托
provider - 提供者
algorithm - 算法
方法详细信息

getDefaultAlgorithm

public static final String getDefaultAlgorithm()
获取默认的 KeyManagerFactory 算法名称。

默认的算法可以在运行时改变，方法是通过把 "ssl.KeyManagerFactory.algorithm" 安全属性（在 Java 安全属性文件或通过调用 Security.setProperty(java.lang.String, java.lang.String) 来设置）的值设置为所需的算法名称。

返回：
在 Java 安全属性中指定的默认算法名称；如果不存在这种属性，则返回一个特定于实现的默认值。
另请参见：
Security.setProperty(java.lang.String, java.lang.String)

getAlgorithm

public final String getAlgorithm()
返回此 KeyManagerFactory 对象的算法名称。

这与创建此 KeyManagerFactory 对象的某个 getInstance 调用中所指定的名称相同。

返回：
此 KeyManagerFactory 对象的算法名称。

getInstance

public static final KeyManagerFactory getInstance(String algorithm)
                                           throws NoSuchAlgorithmException
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 KeyManagerFactorySpi 实现的新 KeyManagerFactory 对象，该实现取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求算法的标准名称。有关标准算法名称的信息，请参阅 Java Secure Socket Extension Reference Guide 。
返回：
新的 KeyManagerFactory 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 KeyManagerFactorySpi 实现。
另请参见：
Provider

getInstance

public static final KeyManagerFactory getInstance(String algorithm,
                                                  String provider)
                                           throws NoSuchAlgorithmException,
                                                  NoSuchProviderException
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

返回一个封装 KeyManagerFactorySpi 实现的新 KeyManagerFactory 对象，该实现取自指定的提供者。指定的提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 所请求算法的标准名称。有关标准算法名称的信息，请参阅 Java Secure Socket Extension Reference Guide 。
provider - 提供者的名称。
返回：
新的 KeyManagerFactory 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 KeyManagerFactorySpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static final KeyManagerFactory getInstance(String algorithm,
                                                  Provider provider)
                                           throws NoSuchAlgorithmException
返回充当密钥管理器工厂的 KeyManagerFactory 对象。

返回一个封装 KeyManagerFactorySpi 实现的新 KeyManagerFactory 对象，该实现取自指定的 Provider 对象。注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 所请求算法的标准名称。有关标准算法名称的信息，请参阅 Java Secure Socket Extension Reference Guide 。
provider - 提供者的实例。
返回：
新的 KeyManagerFactory 对象。
抛出：
NoSuchAlgorithmException - 不能从指定 Provider 对象获得指定算法的 KeyManagerFactorySpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 KeyManagerFactory 对象的提供者。

返回：
此 KeyManagerFactory 对象的提供者

init

public final void init(KeyStore ks,
                       char[] password)
                throws KeyStoreException,
                       NoSuchAlgorithmException,
                       UnrecoverableKeyException
使用密钥内容源初始化此工厂。

提供者通常使用 KeyStore 来获取在安全套接字协商期间所使用的密钥内容。KeyStore 通常是受密码保护的。

有关更多灵活初始化的信息，请参见 init(ManagerFactoryParameters)。

参数：
ks - KeyStore 或 null
password - 用来恢复 KeyStore 中密钥的密码
抛出：
KeyStoreException - 如果此操作失败
NoSuchAlgorithmException - 如果指定的提供者中的指定算法不可用。
UnrecoverableKeyException - 如果不能恢复密钥（例如给定的 password 是错误的）。

init

public final void init(ManagerFactoryParameters spec)
                throws InvalidAlgorithmParameterException
使用特定于提供者的密钥内容源初始化此工厂。

在某些情况下，提供者可能需要除 keystore 和密码以外的其他初始化参数。期望由该特定提供者的用户传递由提供者定义的适当 ManagerFactoryParameters 实现。然后提供者可以调用 ManagerFactoryParameters 实现中指定的方法来获取所需的信息。

参数：
spec - 特定于提供者的参数规范实现
抛出：
InvalidAlgorithmParameterException - 如果遇到了错误

getKeyManagers

public final KeyManager[] getKeyManagers()
为每类密钥内容返回一个密钥管理器。

返回：
密钥管理器
抛出：
IllegalStateException - 如果 KeyManagerFactory 未初始化
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyManagerFactorySpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 KeyManagerFactorySpi

java.lang.Object
    继承者  javax.net.ssl.KeyManagerFactorySpi

public abstract class KeyManagerFactorySpi
extends Object

此类为 KeyManagerFactory 类定义了服务提供者接口 (SPI)。

此类中的所有抽象方法都必须由希望提供特定密钥管理器工厂实现的每个加密服务提供者来实现。

从以下版本开始：
1.4
另请参见：
KeyManagerFactory, KeyManager

构造方法摘要
KeyManagerFactorySpi()
方法摘要
protected abstract KeyManager[] | engineGetKeyManagers() 为每类密钥内容返回一个密钥管理器。
protected abstract void | engineInit(KeyStore ks, char[] password) 使用密钥内容源初始化此工厂。
protected abstract void | engineInit(ManagerFactoryParameters spec) 使用密钥内容源初始化此工厂。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyManagerFactorySpi

public KeyManagerFactorySpi()
方法详细信息

engineInit

protected abstract void engineInit(KeyStore ks,
                                   char[] password)
                            throws KeyStoreException,
                                   NoSuchAlgorithmException,
                                   UnrecoverableKeyException
使用密钥内容源初始化此工厂。

参数：
ks - KeyStore 或 null
password - 用来恢复密钥的密码
抛出：
KeyStoreException - 如果此操作失败
NoSuchAlgorithmException - 如果指定的提供者中的指定算法不可用。
UnrecoverableKeyException - 如果不能恢复密钥
另请参见：
KeyManagerFactory.init(KeyStore, char[])

engineInit

protected abstract void engineInit(ManagerFactoryParameters spec)
                            throws InvalidAlgorithmParameterException
使用密钥内容源初始化此工厂。

在某些情况下，提供者可能需要除 keystore 和密码以外的其他初始化参数。期望由该特定提供者的用户传递由提供者定义的适当 ManagerFactoryParameters 实现。然后提供者可以调用 ManagerFactoryParameters 实现中指定的方法来获取所需的信息。

参数：
spec - 一个特定于提供者的参数规范实现
抛出：
InvalidAlgorithmParameterException - 如果参数有问题
另请参见：
KeyManagerFactory.init(ManagerFactoryParameters spec)

engineGetKeyManagers

protected abstract KeyManager[] engineGetKeyManagers()
为每类密钥内容返回一个密钥管理器。

返回：
密钥管理器
抛出：
IllegalStateException - 如果 KeyManagerFactorySpi 没有被初始化
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStoreBuilderParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 KeyStoreBuilderParameters

java.lang.Object
    继承者  javax.net.ssl.KeyStoreBuilderParameters
所有已实现的接口：
ManagerFactoryParameters
public class KeyStoreBuilderParameters
extends Object
implements ManagerFactoryParameters

封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。

从以下版本开始：
1.5
另请参见：
KeyStore.Builder, X509KeyManager

构造方法摘要
KeyStoreBuilderParameters(KeyStore.Builder builder)
根据指定的 KeyStore.Builder 构造新的 KeyStoreBuilderParameters。
KeyStoreBuilderParameters(List parameters)
根据 KeyStore.Builder 的列表构造新的 KeyStoreBuilderParameters。
方法摘要
 List getParameters()
返回此对象封装的不可修改的 KeyStore.Builder 列表。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

KeyStoreBuilderParameters

public KeyStoreBuilderParameters(KeyStore.Builder builder)
根据指定的 KeyStore.Builder 构造新的 KeyStoreBuilderParameters。

参数：
builder - Builder 对象
抛出：
NullPointerException - 如果 builder 为 null

KeyStoreBuilderParameters

public KeyStoreBuilderParameters(List parameters)
根据 KeyStore.Builder 的列表构造新的 KeyStoreBuilderParameters。注意，复制该列表以防止后续修改。

参数：
parameters - Builder 对象的列表
抛出：
NullPointerException - 如果 parameters 为 null
IllegalArgumentException - 如果 parameters 是空列表
方法详细信息

getParameters

public List getParameters()
返回此对象封装的不可修改的 KeyStore.Builder 列表。

返回：
此对象封装的不可修改的 KeyStore.Builder 列表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ManagerFactoryParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 ManagerFactoryParameters

所有已知实现类：
CertPathTrustManagerParameters, KeyStoreBuilderParameters
public interface ManagerFactoryParameters

此类是用来向 KeyManagerFactory 或 TrustManagerFactory 提供特定于算法的信息的基接口。

在某些情况下，提供者可能需要除 keystore 以外的其他初始化参数。期望由该特定提供者的用户传递由提供者定义的、适当的此类子接口实现。然后提供者可以调用 ManagerFactoryParameters 实现中指定的方法来获取所需的信息。

从以下版本开始：
1.4

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLContext

java.lang.Object
    继承者  javax.net.ssl.SSLContext

public class SSLContext
extends Object

此类的实例表示安全套接字协议的实现，它充当用于安全套接字工厂或 SSLEngine 的工厂。用可选的一组密钥和信任管理器及安全随机字节源初始化此类。

从以下版本开始：
1.4

构造方法摘要
protected SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
创建 SSLContext 对象。
方法摘要
SSLEngine | createSSLEngine() 使用此上下文创建新的 SSLEngine。
SSLEngine | createSSLEngine(String peerHost, int peerPort) 使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。
SSLSessionContext | getClientSessionContext() 返回客户端会话上下文，它表示可供客户端 SSL 套接字握手阶段所使用的 SSL 会话集。
static SSLContext | getDefault() 返回默认的 SSL 上下文。
SSLParameters | getDefaultSSLParameters() 返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
static SSLContext | getInstance(String protocol) 返回实现指定安全套接字协议的 SSLContext 对象。
static SSLContext | getInstance(String protocol, Provider provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static SSLContext | getInstance(String protocol, String provider) 返回实现指定安全套接字协议的 SSLContext 对象。
String | getProtocol() 返回此 SSLContext 对象的协议名称。
Provider | getProvider() 返回此 SSLContext 对象的提供者。
SSLSessionContext | getServerSessionContext() 返回服务器会话上下文，它表示可供服务器端 SSL 套接字握手阶段所使用的 SSL 会话集。
SSLServerSocketFactory | getServerSocketFactory() 返回此上下文的 ServerSocketFactory 对象。
SSLSocketFactory | getSocketFactory() 返回此上下文的 SocketFactory 对象。
SSLParameters | getSupportedSSLParameters() 返回表示此 SSL 上下文受支持设置的 SSLParameters 的副本。
void | init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。
static void | setDefault(SSLContext context) 设置默认的 SSL 上下文。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SSLContext

protected SSLContext(SSLContextSpi contextSpi,
                     Provider provider,
                     String protocol)
创建 SSLContext 对象。

参数：
contextSpi - 代理
provider - 提供者
protocol - 协议
方法详细信息

getDefault

public static SSLContext getDefault()
                             throws NoSuchAlgorithmException
返回默认的 SSL 上下文。

如果默认上下文是使用 SSLContext.setDefault() 方法设置的，则返回该上下文。否则，第一次调用此方法将触发调用 SSLContext.getInstance("Default")。如果成功，则该对象成为默认的 SSL 上下文并返回。

默认上下文立即可用并且无需初始化。

返回：
默认的 SSL 上下文
抛出：
NoSuchAlgorithmException - 如果 SSLContext.getInstance() 调用失败
从以下版本开始：
1.6

setDefault

public static void setDefault(SSLContext context)
设置默认的 SSL 上下文。它由对 getDefault() 的后续调用返回。默认上下文必须立即可用并且无需初始化。

参数：
context - SSLContext
抛出：
NullPointerException - 如果 context 为 null
SecurityException - 如果安全管理器存在并且其 checkPermission 方法不允许 SSLPermission("setDefaultSSLContext")
从以下版本开始：
1.6

getInstance

public static SSLContext getInstance(String protocol)
                              throws NoSuchAlgorithmException
返回实现指定安全套接字协议的 SSLContext 对象。

此方法从首选提供者开始遍历已注册安全提供者列表。返回一个封装 SSLContextSpi 实现的新 SSLContext 对象，该实现取自支持指定协议的第一个提供者。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
protocol - 所请求协议的标准名称。有关标准协议名称的信息，请参见 Java Secure Socket Extension Reference Guide 的附录 A。
返回：
新的 SSLContext 对象。
抛出：
NoSuchAlgorithmException - 如果没有提供者支持指定协议的 TrustManagerFactorySpi 实现。
另请参见：
Provider

getInstance

public static SSLContext getInstance(String protocol,
                                     String provider)
                              throws NoSuchAlgorithmException,
                                     NoSuchProviderException
返回实现指定安全套接字协议的 SSLContext 对象。

返回一个封装 SSLContextSpi 实现的新 SSLContext 对象，该实现取自指定的提供者。指定的提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
protocol - 所请求协议的标准名称。有关标准协议名称的信息，请参见 Java Secure Socket Extension Reference Guide 的附录 A。
provider - 提供者的名称。
返回：
新的 SSLContext 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定提供者获得指定协议的 SSLContextSpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static SSLContext getInstance(String protocol,
                                     Provider provider)
                              throws NoSuchAlgorithmException
返回实现指定安全套接字协议的 SSLContext 对象。

返回一个封装 SSLContextSpi 实现的新 SSLContext 对象，该实现取自指定的 Provider 对象。 注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
protocol - 所请求协议的标准名称。有关标准协议名称的信息，请参见 Java Secure Socket Extension Reference Guide 的附录 A。
provider - 提供者的实例。
返回：
新的 SSLContext 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定 Provider 对象获得指定协议的 KeyManagerFactorySpi 实现。
IllegalArgumentException - 如果提供者的名称为 null。
另请参见：
Provider

getProtocol

public final String getProtocol()
返回此 SSLContext 对象的协议名称。

这与创建此 SSLContext 对象的某个 getInstance 调用中所指定的名称相同。

返回：
此 SSLContext 对象的协议名称。

getProvider

public final Provider getProvider()
返回此 SSLContext 对象的提供者。

返回：
此 SSLContext 对象的提供者

init

public final void init(KeyManager[] km,
                       TrustManager[] tm,
                       SecureRandom random)
                throws KeyManagementException
初始化此上下文。前两个参数都可以为 null，在这种情况下将搜索装入的安全提供者来寻找适当工厂的最高优先级实现。同样，安全的 random 参数也可以为 null，在这种情况下将使用默认的实现。

只有数组中的第一个特定密钥和/或信任管理器实现类型的实例被使用。（例如，只有数组中的第一个 javax.net.ssl.X509KeyManager 被使用。）

参数：
km - 验证密钥源或 null
tm - 同位体验证信任决策源或 null
random - 此生成器的随机源或 null
抛出：
KeyManagementException - 如果此操作失败

getSocketFactory

public final SSLSocketFactory getSocketFactory()
返回此上下文的 SocketFactory 对象。

返回：
SocketFactory 对象
抛出：
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 init()

getServerSocketFactory

public final SSLServerSocketFactory getServerSocketFactory()
返回此上下文的 ServerSocketFactory 对象。

返回：
ServerSocketFactory 对象
抛出：
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 init()

createSSLEngine

public final SSLEngine createSSLEngine()
使用此上下文创建新的 SSLEngine。

使用此工厂方法的应用程序不为内部会话重用策略提供提示。如果需要提示，则应该使用 createSSLEngine(String, int)。

某些密码套件（例如 Kerberos）需要远程主机名信息，在这种情况下不应该使用此工厂方法。

返回：
SSLEngine 对象
抛出：
UnsupportedOperationException - 如果底层提供者不实现该操作。
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 init()
从以下版本开始：
1.5

createSSLEngine

public final SSLEngine createSSLEngine(String peerHost,
                                       int peerPort)
使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。

使用此工厂方法的应用程序为内部会话重用策略提供提示。

某些密码套件（例如 Kerberos）需要远程主机名信息，在这种情况下需要指定 peerHost。

参数：
peerHost - 主机的非授权名
peerPort - 非授权端口
返回：
新的 SSLEngine 对象
抛出：
UnsupportedOperationException - 如果底层提供者不实现该操作。
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 init()
从以下版本开始：
1.5

getServerSessionContext

public final SSLSessionContext getServerSessionContext()
返回服务器会话上下文，它表示可供服务器端 SSL 套接字握手阶段所使用的 SSL 会话集。

此上下文在一些环境下可能不可用，在这种情况下此方法返回 null。例如，当底层 SSL 提供者不提供 SSLSessionContext 接口实现时，此方法返回 null。否则返回非 null 会话上下文。

返回：
绑定到此 SSL 上下文的服务器会话上下文

getClientSessionContext

public final SSLSessionContext getClientSessionContext()
返回客户端会话上下文，它表示可供客户端 SSL 套接字握手阶段所使用的 SSL 会话集。

此上下文在一些环境下可能不可用，在这种情况下此方法返回 null。例如，当底层 SSL 提供者不提供 SSLSessionContext 接口实现时，此方法返回 null。否则返回非 null 会话上下文。

返回：
绑定到此 SSL 上下文的客户端会话上下文

getDefaultSSLParameters

public final SSLParameters getDefaultSSLParameters()
返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。

该参数将始终具有密码套件和设置为非 null 值的协议数组。

返回：
具有默认设置的 SSLParameters 对象的副本
抛出：
UnsupportedOperationException - 如果不能获得默认的 SSL 参数。
从以下版本开始：
1.6

getSupportedSSLParameters

public final SSLParameters getSupportedSSLParameters()
返回表示此 SSL 上下文受支持设置的 SSLParameters 的副本。

该参数将始终具有密码套件和设置为非 null 值的协议数组。

返回：
具有受支持设置的 SSLParameters 对象的副本
抛出：
UnsupportedOperationException - 如果不能获得受支持的 SSL 参数。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLContextSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLContextSpi

java.lang.Object
    继承者  javax.net.ssl.SSLContextSpi

public abstract class SSLContextSpi
extends Object

此类为 SSLContext 类定义了服务提供者接口 (SPI)。

此类中的所有抽象方法都必须由每个想要提供实现特定 SSL 上下文的加密服务提供者实现。

从以下版本开始：
1.4
另请参见：
SSLContext

构造方法摘要
SSLContextSpi()
方法摘要
protected abstract SSLEngine | engineCreateSSLEngine() 使用此上下文创建新的 SSLEngine。
protected abstract SSLEngine | engineCreateSSLEngine(String host, int port) 使用此上下文创建 SSLEngine。
protected abstract SSLSessionContext | engineGetClientSessionContext() 返回此上下文的客户端 SSLSessionContext 对象。
protected SSLParameters | engineGetDefaultSSLParameters() 返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
protected abstract SSLSessionContext | engineGetServerSessionContext() 返回此上下文的服务器 SSLSessionContext 对象。
protected abstract SSLServerSocketFactory | engineGetServerSocketFactory() 返回此上下文的 ServerSocketFactory 对象。
protected abstract SSLSocketFactory | engineGetSocketFactory() 返回此上下文的 SocketFactory 对象。
protected SSLParameters | engineGetSupportedSSLParameters() 返回表示此 SSL 上下文最大受支持设置的 SSLParameters 的副本。
protected abstract void | engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SSLContextSpi

public SSLContextSpi()
方法详细信息

engineInit

protected abstract void engineInit(KeyManager[] km,
                                   TrustManager[] tm,
                                   SecureRandom sr)
                            throws KeyManagementException
初始化此上下文。

参数：
km - 验证密钥源
tm - 同位体验证信任决策源或
sr - 随机源
抛出：
KeyManagementException - 如果此操作失败
另请参见：
SSLContext.init(KeyManager [], TrustManager [], SecureRandom)

engineGetSocketFactory

protected abstract SSLSocketFactory engineGetSocketFactory()
返回此上下文的 SocketFactory 对象。

返回：
SocketFactory 对象
抛出：
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 engineInit()
另请参见：
SSLContext.getSocketFactory()

engineGetServerSocketFactory

protected abstract SSLServerSocketFactory engineGetServerSocketFactory()
返回此上下文的 ServerSocketFactory 对象。

返回：
ServerSocketFactory 对象
抛出：
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 engineInit()
另请参见：
SSLContext.getServerSocketFactory()

engineCreateSSLEngine

protected abstract SSLEngine engineCreateSSLEngine()
使用此上下文创建新的 SSLEngine。

使用此工厂方法的应用程序不为内部会话重用策略提供提示。如果需要提示，则应该使用 engineCreateSSLEngine(String, int)。

某些密码套件（例如 Kerberos）需要远程主机名信息，在这种情况下不应该使用此工厂方法。

返回：
SSLEngine 对象
抛出：
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 engineInit()
从以下版本开始：
1.5
另请参见：
SSLContext.createSSLEngine()

engineCreateSSLEngine

protected abstract SSLEngine engineCreateSSLEngine(String host,
                                                   int port)
使用此上下文创建 SSLEngine。

使用此工厂方法的应用程序为内部会话重用策略提供提示。

某些密码套件（例如 Kerberos）需要远程主机名信息，在这种情况下需要指定 peerHost。

参数：
host - 主机的非授权名
port - 非授权端口号
返回：
SSLEngine 对象
抛出：
IllegalStateException - 如果 SSLContextImpl 需要初始化并且尚未调用 engineInit()
从以下版本开始：
1.5
另请参见：
SSLContext.createSSLEngine(String, int)

engineGetServerSessionContext

protected abstract SSLSessionContext engineGetServerSessionContext()
返回此上下文的服务器 SSLSessionContext 对象。

返回：
SSLSessionContext 对象
另请参见：
SSLContext.getServerSessionContext()

engineGetClientSessionContext

protected abstract SSLSessionContext engineGetClientSessionContext()
返回此上下文的客户端 SSLSessionContext 对象。

返回：
SSLSessionContext 对象
另请参见：
SSLContext.getClientSessionContext()

engineGetDefaultSSLParameters

protected SSLParameters engineGetDefaultSSLParameters()
返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。

该参数将始终具有密码套件和设置为非 null 值的协议数组。

默认实现从通过调用此上下文 SocketFactory 的 SocketFactory.createSocket() 方法所创建的 SSLSocket 获得该参数。

返回：
具有默认设置的 SSLParameters 对象的副本
抛出：
UnsupportedOperationException - 如果不能获得默认的 SSL 参数。
从以下版本开始：
1.6

engineGetSupportedSSLParameters

protected SSLParameters engineGetSupportedSSLParameters()
返回表示此 SSL 上下文最大受支持设置的 SSLParameters 的副本。

该参数将始终具有密码套件和设置为非 null 值的协议数组。

默认实现从通过调用此上下文 SocketFactory 的 SocketFactory.createSocket() 方法所创建的 SSLSocket 获得该参数。

返回：
具有最大受支持设置的 SSLParameters 对象的副本
抛出：
UnsupportedOperationException - 如果不能获得受支持的 SSL 参数。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLEngine (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLEngine

java.lang.Object
    继承者  javax.net.ssl.SSLEngine

public abstract class SSLEngine
extends Object

此类允许使用安全套接字层 (SSL) 或 IETF RFC 2246 "Transport Layer Security" (TLS) 协议进行安全通信，但它与传输无关。

安全的通信模式包括：

  • 完整性保护。SSL/TLS 保护报文不被主动的窃听者修改。
  • 验证。在多数模式下，SSL/TLS 提供对等验证。服务器通常要进行验证，客户端也可在服务器的请求下进行验证。
  • 机密性（私有性保护）。在多数模式下，SSL/TLS 加密在客户端和服务器之间发送的数据。这保护了数据的机密性，所以被动的窃听者不能看到各种类型的敏感数据，如财务信息或个人信息。
这些类型的保护由一个“密码套件”指定，“密码套件”是由给定的 SSL 连接使用的加密算法组合。在协商过程中，两个端点必须对在双方的环境中都可用的密码套件达成一致。如果不存在这种公共的套件，就不能建立 SSL 连接，也不能交换数据。

通过称为“握手”的协商过程来建立所用的密码套件。此过程的目的是创建或重新加入一个“会话”，“会话”可以保护很多会话过程中的连接。握手结束后，可以使用 getSession() 方法访问会话的属性。

SSLSocket 类提供很多相同的安全功能，但是所有的入站和出站数据都是使用底层 Socket 自动地传输，底层 Socket 设计为使用阻塞模型。虽然这适合于很多应用程序，但是此模型却不提供大型服务器所需的可伸缩性。

SSLEngine 的主要特征是它在入站和出站的字节流上操作，与传输机制无关。安排到同位体可靠的 I/O 传输是 SSLEngine 用户的职责。通过从 I/O 传输机制中分离出 SSL/TLS 抽象，SSLEngine 可以被用于各种 I/O 类型，例如 non-blocking I/O (polling)、selectable non-blocking I/O、 Socket 和传统的 Input/OutputStreams、本地的 ByteBuffers 或字节数组、未来的异步 I/O 模型等等。

从较高的层次上看，SSLEngine 表示为如下：

                   app data

                |           ^
                |     |     |
                v     |     |
           +----+-----|-----+----+
           |          |          |
           |       SSL|Engine    |
   wrap()  |          |          |  unwrap()
           | OUTBOUND | INBOUND  |
           |          |          |
           +----+-----|-----+----+
                |     |     ^
                |     |     |
                v           |

                   net data
应用程序数据（也称为纯文本或明文）是应用程序生成或使用的数据。它的对应物是网络数据，它由握手和/或密文（加密的）数据组成，并且注定要通过 I/O 机制传输。入站数据指的是从同位体接收的数据，出站数据是去往同位体的数据。

（在 SSLEngine 上下文中，术语“握手数据”的意思是所有用来建立和控制安全连接的已交换数据。握手数据包括 SSL/TLS 消息 "alert"、"change_cipher_spec" 和 "handshake。"）

SSLEngine 有五种不同的阶段。

  1. 创建 - 已经创建和初始化 SSLEngine，但尚未被使用。在此阶段，应用程序可以设置任何特定于 SSLEngine 的设置（启用密码套件、SSLEngine 应该以客户端还是服务器模式握手等等）。一旦握手开始，任何新的设置（除了客户端/服务器模式，见下文）将在下一次握手时才被使用。
  2. 初始握手 - 初始握手是两个同位体交换通信参数，直到建立 SSLSession 为止的过程。在此阶段不能发送应用程序数据。
  3. 应用程序数据 - 一旦通信参数建立起来且握手完成，就可以通过 SSLEngine 传输应用程序数据。出站的应用程序报文被加密并进行完整性保护，入站的报文进行相反的过程。
  4. 重新握手 - 在应用程序数据阶段的任何时间，每一方都可以请求重新协商会话。新的握手数据可以混入到应用程序数据中。在开始重新握手阶段之前，应用程序可以重置 SSL/TLS 通信参数，例如已启用的密码套件列表和是否使用客户端验证，但是不能更改客户端/服务器模式。如前所述，一旦握手开始，任何新的 SSLEngine 配置设置都将在下一次握手时才被使用。
  5. 关闭 - 当不再需要连接时，应用程序应该关闭 SSLEngine，并且也应该在关闭底层传输机制之前发送/接收所有剩余的报文到同位体。一旦引擎关闭，它就是不可重用的：必须创建一个新的 SSLEngine。
根据已初始化的 SSLContext 来调用 SSLContext.createSSLEngine() 即可创建 SSLEngine。在第一次调用 wrap()、unwrap() 或 beginHandshake() 之前应该设置所有的配置参数。这些方法都能触发初始握手。

分别对出站或入站数据调用 wrap() 或 unwrap() 可使数据通过引擎。根据 SSLEngine 的状态，对 wrap() 的调用可能使用源缓冲区的应用程序数据，并且可能在目标缓冲区内生成网络数据。出站数据可以包含应用程序和/或握手数据。对 unwrap() 的调用将检查源缓冲区，如果数据是握手信息，则可能提前握手；如果数据是应用程序数据，则将其放入目标缓冲区中。底层 SSL/TLS 算法的状态将决定何时使用和生成数据。

调用 wrap() 和 unwrap() 返回 SSLEngineResult，它指示操作的状态以及（可选的）如何与引擎交互以取得进展。

SSLEngine 只是生成/使用完整的 SSL/TLS 包，它不在 wrap()/unwrap() 的调用之间内部存储应用程序数据。因此输入和输出 ByteBuffer 必须设为合适的大小以便容纳可能生成的最多记录。要确定合适的缓冲区大小，应该调用 SSLSession.getPacketBufferSize() 和 SSLSession.getApplicationBufferSize()。通常无需考虑出站应用程序数据缓冲区的大小。如果缓冲区的状况不允许正确地使用/生成数据，则应用程序必须加以确定（通过 SSLEngineResult）并纠正问题，然后再尝试调用一次。

例如，如果引擎确定没有足够的目标缓冲区空间可用，则 unwrap() 将返回 SSLEngineResult.Status.BUFFER_OVERFLOW 结果。应用程序应该调用 SSLSession.getApplicationBufferSize() 并将该值与目标缓冲区中的可用空间进行比较，如有必要，可以扩大该缓冲区。类似地，如果 unwrap() 返回 SSLEngineResult.Status.BUFFER_UNDERFLOW，则应用程序应调用 SSLSession.getPacketBufferSize() 以确保源缓冲区有足够的空间来容纳记录（如有必要，可以扩大该缓冲区），然后获得更多的入站数据。

   SSLEngineResult r = engine.unwrap(src, dst);
   switch (r.getStatus()) {
   BUFFER_OVERFLOW:
       // Could attempt to drain the dst buffer of any already obtained
       // data, but we'll just increase it to the size needed.
       int appSize = engine.getSession().getApplicationBufferSize();
       ByteBuffer b = ByteBuffer.allocate(appSize + dst.position());
       dst.flip();
       b.put(dst);
       dst = b;
       // retry the operation.
       break;
   BUFFER_UNDERFLOW:
       int netSize = engine.getSession().getPacketBufferSize();
       // Resize buffer if needed.
       if (netSize > dst.capacity()) {
           ByteBuffer b = ByteBuffer.allocate(netSize);
           src.flip();
           b.put(src);
           src = b;
       }
       // Obtain more inbound network data for src,
       // then retry the operation.
       break;
   // other cases: CLOSED, OK.
   }

与 SSLSocket 不同，SSLEngine 的所有方法都是非阻塞的。SSLEngine 实现所需的任务结果可能需要经过很长的时间才能获得，甚至可能被阻塞。例如，TrustManager 可能需要连接到远程的证书验证服务，或者 KeyManager 可能需要提示用户来确定将哪个证书用作客户端验证部分。另外，创建加密的签名和验证它们可能很慢，就好像阻塞一样。

对于任何可能阻塞的操作，SSLEngine 将创建 Runnable 委托任务。当 SSLEngineResult 指示需要一个委托任务结果时，应用程序必须调用 getDelegatedTask() 来获取一个未执行的委托任务并调用其 run() 方法（根据计算策略的不同，可能要使用不同的线程）。应用程序应该继续获取委托任务，直到没有为止，然后再尝试执行最初的操作。

在通信会话的结尾，应用程序应该正确地关闭 SSL/TLS 链接。SSL/TLS 协议有关闭握手报文，这些报文应该在释放 SSLEngine 并关闭底层传输机制之前传送到同位体。通过以下某个方法可发起关闭：SSLException、入站的关闭握手报文或某种 close 方法。在所有情况下，关闭握手报文由引擎生成，在 SSLEngineResult 的状态返回 "CLOSED"，或者 isOutboundDone() 返回 true 之前应该重复调用 wrap()。从 wrap() 方法获得的所有数据都应该发送到同位体。

使用 closeOutbound() 通知引擎该应用程序将不再发送任何其他数据了。

同位体通过发送它自己的关闭握手报文来通知它的关闭意图。在此报文被本地 SSLEngine 的 unwrap() 调用接收和处理后，应用程序可检测关闭，方法是调用 unwrap() 并寻找带有状态 "CLOSED" 的 SSLEngineResult，或者是 isInboundDone() 返回 true。如果由于某些原因使同位体关闭通信链接但没有发送正确的 SSL/TLS 关闭报文，则应用程序可以检测流的末尾并且能够通过 closeInbound() 来通知引擎没有更多的入站报文需要处理。某些应用程序可能选择要求同位体传送有序的关闭报文，在这种情况下，它们能够检查出关闭是由握手报文生成的，而不是由流的末尾这种情况引起的。

有两组密码套件是您在管理密码套件时需要知道的：

  • 支持的密码套件：SSL 实现支持的所有套件。使用 getSupportedCipherSuites() 来报告此列表。
  • 启用的密码套件，它可少于完整的支持套件集。使用 setEnabledCipherSuites(String []) 方法设置此组套件，使用 getEnabledCipherSuites() 方法查询它们。最初，在一个新引擎上启用默认的密码套件集，表示最低的建议配置。
实现默认要求，默认只启用那些可对服务器进行验证并提供机密性的密码套件。只有双方明确同意可进行无需验证和/或非私有的（未加密的）通信时才选择这种密码套件。

每个 SSL/TLS 连接都必须有一个客户端和一个服务器，因此每一端必须决定担任哪种角色。这种选择决定了谁来开始握手过程以及每一方应该发送哪种类型的报文。方法 setUseClientMode(boolean) 可配置模式。一旦初始握手开始，SSLEngine 就不能在客户端和服务器模式间转换，甚至在执行重新协商时也不能。

应用程序可能选择在不同的线程中处理委托任务。当创建一个 SSLEngine 时，当前的 AccessControlContext 被保存。所有以后的委托任务都将使用此上下文来处理：也就是说，所有的访问控制决定都使用创建引擎时所捕获的上下文来做出。

并发性要点：下面是需要知道的两种并发性问题：
  1. wrap() 和 unwrap() 方法可以互相并发执行。
  2. SSL/TLS 协议使用有序的包。应用程序必须小心保证生成的包按顺序传递。如果包无序到达，则可能出现不可预料的或灾难性的结果。

    例如：

                    synchronized (outboundLock) {
                    sslEngine.wrap(src, dst);
                    outboundQueue.put(dst);
                }
    做为必然的结果，两个线程必须不能试图并发地调用相同的方法（wrap() 或 unwrap()），因为没有方法保证最后包的排序。

从以下版本开始：
1.5
另请参见：
SSLContext, SSLSocket, SSLServerSocket, SSLSession, Socket

构造方法摘要
protected | SSLEngine() SSLEngine 的构造方法，该构造方法不为内部会话重用策略提供提示。
protected | SSLEngine(String peerHost, int peerPort) SSLEngine 的构造方法。
方法摘要
abstract  void beginHandshake()
在此 SSLEngine 上发起握手（初始的或重新协商）。
abstract  void closeInbound()
通知没有更多的入站网络数据将发送到此 SSLEngine。
abstract  void closeOutbound()
通知没有更多的出站应用程序数据将在此 SSLEngine 上发送。
abstract  Runnable getDelegatedTask()
返回此 SSLEngine 的一个委托 Runnable 任务。
abstract  String[] getEnabledCipherSuites()
返回为了在此引擎上使用而当前已启用的 SSL 密码套件名称。
abstract  String[] getEnabledProtocols()
返回当前已启用的，以便让 SSLEngine 使用的协议版本的名称。
abstract  boolean getEnableSessionCreation()
如果可以由此引擎建立新的 SSL 会话，则返回 true。
abstract  SSLEngineResult.HandshakeStatus getHandshakeStatus()
返回此 SSLEngine 的当前握手状态。
abstract  boolean getNeedClientAuth()
如果引擎要求 客户端验证，则返回 true。
 String getPeerHost()
返回同位体的主机名。
 int getPeerPort()
返回同位体的端口号。
abstract  SSLSession getSession()
返回此 SSLEngine 中使用的 SSLSession。
 SSLParameters getSSLParameters()
返回对此 SSLEngine 有效的 SSLParameters。
abstract  String[] getSupportedCipherSuites()
返回为了在此引擎上使用而可以启用的密码套件名称。
abstract  String[] getSupportedProtocols()
返回能够被启用，以便让 SSLEngine 可使用的协议的名称。
abstract  boolean getUseClientMode()
如果引擎设置为在握手时使用客户端模式，则返回 true。
abstract  boolean getWantClientAuth()
如果引擎请求 客户端验证，则返回 true。
abstract  boolean isInboundDone()
返回 unwrap(ByteBuffer, ByteBuffer) 是否再接受更多的入站数据报文。
abstract  boolean isOutboundDone()
返回 wrap(ByteBuffer, ByteBuffer) 是否再生成更多的出站数据报文。
abstract  void setEnabledCipherSuites(String[] suites)
设置密码套件为启用，以便在此引擎上使用。
abstract  void setEnabledProtocols(String[] protocols)
设置为了在此引擎上使用而启用的协议版本。
abstract  void setEnableSessionCreation(boolean flag)
控制是否可以由此引擎建立新的 SSL 会话。
abstract  void setNeedClientAuth(boolean need)
配置引擎要求 客户端进行验证。
 void setSSLParameters(SSLParameters params)
对此引擎应用 SSLParameters。
abstract  void setUseClientMode(boolean mode)
配置引擎在握手时使用客户端（或服务器）模式。
abstract  void setWantClientAuth(boolean want)
配置引擎请求 客户端验证。
 SSLEngineResult unwrap(ByteBuffer src, ByteBuffer dst)
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
 SSLEngineResult unwrap(ByteBuffer src, ByteBuffer[] dsts)
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
abstract  SSLEngineResult unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length)
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
 SSLEngineResult wrap(ByteBuffer[] srcs, ByteBuffer dst)
尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract  SSLEngineResult wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst)
尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
 SSLEngineResult wrap(ByteBuffer src, ByteBuffer dst)
试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SSLEngine

protected SSLEngine()
SSLEngine 的构造方法，该构造方法不为内部会话重用策略提供提示。

另请参见：
SSLContext.createSSLEngine(), SSLSessionContext

SSLEngine

protected SSLEngine(String peerHost,
                    int peerPort)
SSLEngine 的构造方法。

SSLEngine 实现可以使用 peerHost 和 peerPort 参数作为其内部会话重用策略的提示。

某些密码套件（例如 Kerberos）需要远程主机名信息。为了使用 Kerberos，此类的实现应该使用这种构造方法。

该参数不由 SSLEngine 进行验证。

参数：
peerHost - 同位体主机的名称
peerPort - 同位体的端口号
另请参见：
SSLContext.createSSLEngine(String, int), SSLSessionContext
方法详细信息

getPeerHost

public String getPeerHost()
返回同位体的主机名。

注意，该值未经验证，不应该依赖它。

返回：
同位体的主机名；如果没有可供使用的主机名，则返回 null。

getPeerPort

public int getPeerPort()
返回同位体的端口号。

注意，该值未经验证，不应该依赖它。

返回：
同位体的端口号；如果没有可供使用的端口号，则返回 -1。

wrap

public SSLEngineResult wrap(ByteBuffer src,
                            ByteBuffer dst)
                     throws SSLException
试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。

调用此方法与调用下面的方法产生的行为完全相同：

 engine.wrap(new ByteBuffer [] { src }, 0, 1, dst);

参数：
src - 包含出站应用程序数据的 ByteBuffer
dst - 保存出站网络数据的 ByteBuffer
返回：
描述此次操作结果的 SSLEngineResult。
抛出：
SSLException - 如果处理数据时遇到的问题导致 SSLEngine 中止。关于引擎关闭的更多信息，请参见该类的描述。
ReadOnlyBufferException - 如果 dst 缓冲区是只读的。
IllegalArgumentException - 如果 src 或 dst 为 null。
IllegalStateException - 如果没有设置客户端/服务器模式。
另请参见：
wrap(ByteBuffer [], int, int, ByteBuffer)

wrap

public SSLEngineResult wrap(ByteBuffer[] srcs,
                            ByteBuffer dst)
                     throws SSLException
尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。

调用此方法与调用下面的方法产生的行为完全相同：

 engine.wrap(srcs, 0, srcs.length, dst);

参数：
srcs - 包含出站应用程序数据的 ByteBuffers 数组
dst - 保存出站网络数据的 ByteBuffer
返回：
描述此次操作结果的 SSLEngineResult。
抛出：
SSLException - 如果处理数据时遇到的问题导致 SSLEngine 中止。关于引擎关闭的更多信息，请参见该类的描述。
ReadOnlyBufferException - 如果 dst 缓冲区是只读的。
IllegalArgumentException - 如果 srcs 或 dst 为 null，或者 srcs 中的任何元素为 null。
IllegalStateException - 如果没有设置客户端/服务器模式。
另请参见：
wrap(ByteBuffer [], int, int, ByteBuffer)

wrap

public abstract SSLEngineResult wrap(ByteBuffer[] srcs,
                                     int offset,
                                     int length,
                                     ByteBuffer dst)
                              throws SSLException
尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。此“集中” 操作可在单个调用中对来自一个或多个给定缓冲区序列的字节序列进行编码。集中包装通常在实现网络协议或文件格式时很有用，例如将数据分组放入段中（这些段由一个或多个长度固定的头，后跟长度可变的正文组成）。关于集中的更多信息，请参见 GatheringByteChannel，有关子序列行为的更多信息，请参见 GatheringByteChannel.write(ByteBuffer[], int, int)。

根据 SSLEngine 的状态，此方法可能生成网络数据而不使用任何应用程序数据（例如，它可能生成握手数据）。

应用程序负责把网络数据可靠地传输到同位体，同时也保证将多次调用 wrap() 所创建的数据以和它生成时相同的顺序传输。应用程序必须正确地同步对此方法的多次调用。

如果此 SSLEngine 还没有开始它的初始握手，则此方法将自动开始进行握手。

此方法将尝试生成一个 SSL/TLS 包，并使用尽可能多的源数据，但是使用的数据将从不会超过每个缓冲区中剩余字节的总和。会更新每个 ByteBuffer 的位置，以反映使用或生成的数据量。界限保持不变。

由 srcs 和 dst ByteBuffer 使用的底层内存必须不能相同。

关于引擎关闭的更多信息，请参见该类的描述。

参数：
srcs - 包含出站应用程序数据的 ByteBuffers 数组
offset - 第一个缓冲区（要获取该缓冲区中的字节）在缓冲区数组中的偏移量；必须为非负数并且不能大于 srcs.length
length - 要访问的最大缓冲区编号；它必须为非负和不能大于 srcs.length - offset
dst - 保存出站网络数据的 ByteBuffer
返回：
描述此次操作结果的 SSLEngineResult。
抛出：
SSLException - 如果处理数据时遇到的问题导致 SSLEngine 中止。关于引擎关闭的更多信息，请参见该类的描述。
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立。
ReadOnlyBufferException - 如果 dst 缓冲区是只读的。
IllegalArgumentException - 如果 srcs 或 dst 为 null， 或者指定的 srcs 子序列中的任何元素为 null。
IllegalStateException - 如果没有设置客户端/服务器模式。
另请参见：
GatheringByteChannel, GatheringByteChannel.write( ByteBuffer[], int, int)

unwrap

public SSLEngineResult unwrap(ByteBuffer src,
                              ByteBuffer dst)
                       throws SSLException
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。

调用此方法与调用下面的方法产生的行为完全相同：

 engine.unwrap(src, new ByteBuffer [] { dst }, 0, 1);

参数：
src - 包含入站网络数据的 ByteBuffer。
dst - 保存入站应用程序数据的 ByteBuffer。
返回：
描述此次操作结果的 SSLEngineResult。
抛出：
SSLException - 如果处理数据时遇到的问题导致 SSLEngine 中止。关于引擎关闭的更多信息，请参见该类的描述。
ReadOnlyBufferException - 如果 dst 缓冲区是只读的。
IllegalArgumentException - 如果 src 或 dst 为 null。
IllegalStateException - 如果没有设置客户端/服务器模式。
另请参见：
unwrap(ByteBuffer, ByteBuffer [], int, int)

unwrap

public SSLEngineResult unwrap(ByteBuffer src,
                              ByteBuffer[] dsts)
                       throws SSLException
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。

调用此方法与调用下面的方法产生的行为完全相同：

 engine.unwrap(src, dsts, 0, dsts.length);

参数：
src - 包含入站网络数据的 ByteBuffer。
dsts - 保存入站应用程序数据的 ByteBuffer 数组。
返回：
描述此次操作结果的 SSLEngineResult。
抛出：
SSLException - 如果处理数据时遇到的问题导致 SSLEngine 中止。关于引擎关闭的更多信息，请参见该类的描述。
ReadOnlyBufferException - 如果任何一个 dst 缓冲区是只读的。
IllegalArgumentException - 如果 src 或 dsts 为 null，或者 dsts 中的任何元素为 null。
IllegalStateException - 如果没有设置客户端/服务器模式。
另请参见：
unwrap(ByteBuffer, ByteBuffer [], int, int)

unwrap

public abstract SSLEngineResult unwrap(ByteBuffer src,
                                       ByteBuffer[] dsts,
                                       int offset,
                                       int length)
                                throws SSLException
尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。此“分散” 操作可在单个调用中把字节序列解码到一个或多个给定缓冲区序列中。分散解包通常在实现网络协议或文件格式时很有用，例如将数据分组放入段中（这些段由一个或多个长度固定的头，后跟长度可变的正文组成）。关于分散的更多信息，请参见 ScatteringByteChannel，有关子序列行为的更多信息，请参见 { ScatteringByteChannel.read(ByteBuffer[], int, int)。

根据 SSLEngine 的状态，此方法可能使用网络数据而不生成任何应用程序数据（例如，它可能使用握手数据）。

应用程序负责从同位体可靠地获取网络数据，并且负责以数据接收时的顺序对数据调用 unwrap()。应用程序必须正确地同步对此方法的多次调用。

如果此 SSLEngine 还没有开始它的初始握手，则此方法将自动开始进行握手。

此方法将尝试使用一个完整的 SSL/TLS 网络包，但使用的数据从不超过缓冲区中剩余字节的总和。会更新每个 ByteBuffer 的位置，以反映使用或生成的数据量。界限保持不变。

由 src 和 dsts ByteBuffer 使用的底层内存必须不能相同。

由于入站网络缓冲区可能由于调用而被修改：因此，如果由于某些次要目的而需要网络数据包，则在调用此方法前应该复制该数据。注：网络数据对第二个 SSLEngine 将不再有用，因为每个 SSLEngine 包含唯一的随机状态，该状态影响 SSL/TLS 报文。

关于引擎关闭的更多信息，请参见该类的描述。

参数：
src - 包含入站网络数据的 ByteBuffer。
dsts - 保存入站应用程序数据的 ByteBuffer 数组。
offset - 第一个缓冲区（要传递该缓冲区中的字节）在缓冲区数组中的偏移量；必须为非负数并且不能大于 dsts.length。
length - 要访问的最大缓冲区数；必须为非负数并且不能大于 dsts.length - offset。
返回：
描述此次操作结果的 SSLEngineResult。
抛出：
SSLException - 如果处理数据时遇到的问题导致 SSLEngine 中止。关于引擎关闭的更多信息，请参见该类的描述。
IndexOutOfBoundsException - 如果关于 offset 和 length 参数的前提不成立。
ReadOnlyBufferException - 如果任何一个 dst 缓冲区是只读的。
IllegalArgumentException - 如果 src 或 dsts 为 null，或者指定的 dsts 子序列中的任何元素为 null。
IllegalStateException - 如果没有设置客户端/服务器模式。
另请参见：
ScatteringByteChannel, ScatteringByteChannel.read( ByteBuffer[], int, int)

getDelegatedTask

public abstract Runnable getDelegatedTask()
返回此 SSLEngine 的一个委托 Runnable 任务。

SSLEngine 操作可能需要阻塞操作的结果，或者可能花费很长的时间才能完成。此方法用来获取一个未完成的 Runnable 操作（任务）。必须分配给每个任务一个线程（可能是当前的）来执行 run 操作。一旦 run 方法返回，则不再需要 Runnable 对象，它可能被丢弃。

当创建此对象时，委托任务在 AccessControlContext 中的适当位置运行。

对此方法的一次调用恰好返回每个未完成的任务一次。

多个委托任务可以并行运行。

返回：
一个委托 Runnable 任务；如果没有则返回 null。

closeInbound

public abstract void closeInbound()
                           throws SSLException
通知没有更多的入站网络数据将发送到此 SSLEngine。

如果应用程序通过调用 closeOutbound() 发起关闭进程，则在某些情况下不要求发起方等待同位体的相应关闭报文。（有关等待关闭报警的更改信息，请参见 TLS 规范的 7.2.1 节 (RFC 2246)。）在这种情况下，不需要调用此方法。

但是如果应用程序没有发起关闭进程，如果上面的情况不适用，则每当到达 SSL/TLS 数据流的末尾时就应该调用此方法。这保证了入站端的关闭，也检查该同位体是否正确地遵循 SSL/TLS 关闭过程，从而检测可能的截断攻击。

此方法是幂等的：如果入站端已经关闭，则此方法不执行任何操作。

应该调用 wrap() 来刷新任何剩余的握手数据。

抛出：
SSLException - 如果此引擎没有从同位体接收到正确的 SSL/TLS 关闭通知报文。
另请参见：
isInboundDone(), isOutboundDone()

isInboundDone

public abstract boolean isInboundDone()
返回 unwrap(ByteBuffer, ByteBuffer) 是否再接受更多的入站数据报文。

返回：
如果 SSLEngine 不再使用任何网络数据（同时也暗含不再生成任何应用程序数据），则返回 true。
另请参见：
closeInbound()

closeOutbound

public abstract void closeOutbound()
通知没有更多的出站应用程序数据将在此 SSLEngine 上发送。

此方法是幂等的：如果出站端已经关闭，则此方法不执行任何操作。

应该调用 wrap(ByteBuffer, ByteBuffer) 来刷新任何剩余的握手数据。

另请参见：
isOutboundDone()

isOutboundDone

public abstract boolean isOutboundDone()
返回 wrap(ByteBuffer, ByteBuffer) 是否再生成更多的出站数据报文。

注意，在关闭阶段，SSLEngine 可能生成必须发送到同位体的握手关闭数据。必须调用 wrap() 来生成此数据。当此方法返回 true 时，将不再创建出站数据。

返回：
如果 SSLEngine 不再生成任何网络数据，则返回 true
另请参见：
closeOutbound(), closeInbound()

getSupportedCipherSuites

public abstract String[] getSupportedCipherSuites()
返回为了在此引擎上使用而可以启用的密码套件名称。通常，因为此列表可能包括无法满足默认服务质量要求的密码套件，所以默认情况下实际启动的是这些密码套件的子集。这种密码套件在特殊的应用程序中可能很有用。

返回：
密码套件名称的数组
另请参见：
getEnabledCipherSuites(), setEnabledCipherSuites(String [])

getEnabledCipherSuites

public abstract String[] getEnabledCipherSuites()
返回为了在此引擎上使用而当前已启用的 SSL 密码套件名称。当首次创建 SSLEngine 时，所有启用的密码套件都支持最低的服务质量。因此，在某些环境中此值可能为空。

即使密码套件已经被启用，它也可能从不被使用。（例如，同位体不支持它、密码套件必须的证书/私钥不可用，或者启用了匿名的密码套件但需要进行验证。）

返回：
密码套件名称的数组
另请参见：
getSupportedCipherSuites(), setEnabledCipherSuites(String [])

setEnabledCipherSuites

public abstract void setEnabledCipherSuites(String[] suites)
设置密码套件为启用，以便在此引擎上使用。

suites 参数中的每个密码套件都必须由 getSupportedCipherSuites() 列出，否则该方法会失败。在成功调用此方法之后，仅启用了在 suites 参数中列出的套件以便使用。

有关为什么一个密码套件在引擎上从来不被使用的更多信息，请参见 getEnabledCipherSuites()。

参数：
suites - 要启用的所有密码套件的名称
抛出：
IllegalArgumentException - 当一个或多个由参数命名的密码套件不被支持时，或参数为 null 时。
另请参见：
getSupportedCipherSuites(), getEnabledCipherSuites()

getSupportedProtocols

public abstract String[] getSupportedProtocols()
返回能够被启用，以便让 SSLEngine 可使用的协议的名称。

返回：
所支持的协议的数组

getEnabledProtocols

public abstract String[] getEnabledProtocols()
返回当前已启用的，以便让 SSLEngine 使用的协议版本的名称。

返回：
协议的数组
另请参见：
setEnabledProtocols(String [])

setEnabledProtocols

public abstract void setEnabledProtocols(String[] protocols)
设置为了在此引擎上使用而启用的协议版本。

该协议必须已经由 getSupportedProtocols() 将其作为受支持的协议列出。在成功调用此方法之后，仅启用了在 protocols 参数中列出的协议以便使用。

参数：
protocols - 要启用的所有协议的名称。
抛出：
IllegalArgumentException - 当一个或多个由参数命名的协议不被支持时，或 protocols 参数为 null 时。
另请参见：
getEnabledProtocols()

getSession

public abstract SSLSession getSession()
返回此 SSLEngine 中使用的 SSLSession。

这些 SSLSession 可以是持久的，并且通常对应于某个用户的整个登录会话过程。该会话指定了会话中所有连接主动使用的特定密码套件，以及该会话的客户端和服务器标识。

与 SSLSocket.getSession() 不同，此方法在握手完成之后才阻塞。

在初始握手结束之前，此方法返回一个会话对象，它报告 "SSL_NULL_WITH_NULL_NULL" 形式的无效密码套件。

返回：
此 SSLEngine 的 SSLSession
另请参见：
SSLSession

beginHandshake

public abstract void beginHandshake()
                             throws SSLException
在此 SSLEngine 上发起握手（初始的或重新协商）。

初始握手不需要此方法，因为如果握手尚未开始，wrap() 和 unwrap() 方法将隐式地调用此方法。

注意，会话的同位体也可以通过发送适当的会话重新协商握手报文来请求与此 SSLEngine 进行会话重新协商。

与 SSLSocket#startHandshake() 方法不同，此方法在握手完成之后才阻塞。

为了强迫一个完整的 SSL/TLS 会话重新协商，调用此方法之前应该使当前的会话无效。

某些协议可能不支持在一个现有引擎上的多次握手，可能抛出 SSLException。

抛出：
SSLException - 如果通知 SSLEngine 开始新的握手时遇到了问题。关于引擎关闭的更多信息，请参见该类的描述。
IllegalStateException - 如果没有设置客户端/服务器模式。
另请参见：
SSLSession.invalidate()

getHandshakeStatus

public abstract SSLEngineResult.HandshakeStatus getHandshakeStatus()
返回此 SSLEngine 的当前握手状态。

返回：
当前的 SSLEngineResult.HandshakeStatus。

setUseClientMode

public abstract void setUseClientMode(boolean mode)
配置引擎在握手时使用客户端（或服务器）模式。

必须在任何握手出现之前调用此方法。一旦握手开始，在此引擎的生命周期内就无法重置该模式。

服务器通常对其自己进行验证，不要求客户端也这么做。

参数：
mode - 如果引擎应该以“客户端”模式开始它的握手，则为 true
抛出：
IllegalArgumentException - 如果在初始握手开始后试图更改模式。
另请参见：
getUseClientMode()

getUseClientMode

public abstract boolean getUseClientMode()
如果引擎设置为在握手时使用客户端模式，则返回 true。

返回：
如果引擎应该以“客户端”模式进行握手，则返回 true
另请参见：
setUseClientMode(boolean)

setNeedClientAuth

public abstract void setNeedClientAuth(boolean need)
配置引擎要求 客户端进行验证。此选项只对服务器模式的引擎有用。

引擎的客户端验证设置是以下三种之一:

  • 必须的客户端验证
  • 请求的客户端验证
  • 不需要客户端验证

与 setWantClientAuth(boolean) 不同，如果设置了此选项并且客户端选择不提供其自身的验证信息，则协商将会停止且引擎将开始它的关闭过程。

调用此方法会重写由此方法或 setWantClientAuth(boolean) 以前所做的任何设置。

参数：
need - 如果要求进行客户端验证，则设置为 true；如果不需要客户端验证，则设置为 false。
另请参见：
getNeedClientAuth(), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

getNeedClientAuth

public abstract boolean getNeedClientAuth()
如果引擎要求 客户端验证，则返回 true。此选项只对服务器模式的引擎有用。

返回：
如果要求进行客户端验证，返回 true；如果不需要客户端验证，则返回 false。
另请参见：
setNeedClientAuth(boolean), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

setWantClientAuth

public abstract void setWantClientAuth(boolean want)
配置引擎请求 客户端验证。此选项只对服务器模式的引擎有用。

引擎的客户端验证设置是以下三种之一:

  • 必须的客户端验证
  • 请求的客户端验证
  • 不需要客户端验证

与 setNeedClientAuth(boolean) 不同，如果设置了此选项并且客户端选择不提供其自身的验证信息，则协商将会继续。

调用此方法会重写由此方法或 setNeedClientAuth(boolean) 以前所做的任何设置。

参数：
want - 如果请求进行客户端验证，则设置为 true；如果不需要客户端验证，则设置为 false。
另请参见：
getWantClientAuth(), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

getWantClientAuth

public abstract boolean getWantClientAuth()
如果引擎请求 客户端验证，则返回 true。此选项只对服务器模式的引擎有用。

返回：
如果请求进行客户端验证，则返回 true；如果不需要客户端验证，则返回 false。
另请参见：
setNeedClientAuth(boolean), getNeedClientAuth(), setWantClientAuth(boolean), setUseClientMode(boolean)

setEnableSessionCreation

public abstract void setEnableSessionCreation(boolean flag)
控制是否可以由此引擎建立新的 SSL 会话。如果不允许创建会话，也没有可以恢复的现有会话，则不会有成功的握手。

参数：
flag - 为 true 时指示可以创建会话；这是默认的。为 false 时指示必须恢复现有会话
另请参见：
getEnableSessionCreation()

getEnableSessionCreation

public abstract boolean getEnableSessionCreation()
如果可以由此引擎建立新的 SSL 会话，则返回 true。

返回：
返回值为 true 时指示可以创建会话；这是默认的。为 false 时指示必须恢复现有会话
另请参见：
setEnableSessionCreation(boolean)

getSSLParameters

public SSLParameters getSSLParameters()
返回对此 SSLEngine 有效的 SSLParameters。返回的 SSLParameters 的密码套件和协议始终为非 null。

返回：
对此 SSLEngine 有效的 SSLParameters。
从以下版本开始：
1.6

setSSLParameters

public void setSSLParameters(SSLParameters params)
对此引擎应用 SSLParameters。

这意味着：

  • 如果 params.getCipherSuites() 不为 null，则使用该值调用 setEnabledCipherSuites()
  • 如果 params.getProtocols() 不为 null，则使用该值调用 setEnabledProtocols()
  • 如果 params.getNeedClientAuth() 或 params.getWantClientAuth() 返回 true，则分别调用 setNeedClientAuth(true) 和 setWantClientAuth(true)；否则调用 setWantClientAuth(false)。

参数：
params - 参数
抛出：
IllegalArgumentException - 如果 setEnabledCipherSuites() 或 setEnabledProtocols() 调用失败
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLEngineResult (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLEngineResult

java.lang.Object
    继承者  javax.net.ssl.SSLEngineResult

public class SSLEngineResult
extends Object

SSLEngine I/O 调用所生成的结果状态的封装。

SSLEngine 提供了在两个同位体之间建立安全通信会话的方式。SSLEngine 操作通常使用输入缓冲区中的字节，并在输出缓冲区生成字节。此类提供了描述 SSLEngine 状态的操作结果值，其中包括为了结束正在进行的握手而需要何种操作的指示。最后，它报告此操作使用和生成的字节数。

从以下版本开始：
1.5
另请参见：
SSLEngine, SSLEngine.wrap(ByteBuffer, ByteBuffer), SSLEngine.unwrap(ByteBuffer, ByteBuffer)

嵌套类摘要
static class | SSLEngineResult.HandshakeStatus 描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
static class | SSLEngineResult.Status 描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。
构造方法摘要
SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
初始化此类的一个新实例。
方法摘要
int | bytesConsumed() 返回使用的输入缓冲区中的字节数。
int | bytesProduced() 返回写入到输出缓冲区中的字节数。
SSLEngineResult.HandshakeStatus | getHandshakeStatus() 获得此 SSLEngine 操作的握手状态。
SSLEngineResult.Status | getStatus() 获得此 SSLEngine 操作的返回值。
String | toString() 返回此对象的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLEngineResult

public SSLEngineResult(SSLEngineResult.Status status,
                       SSLEngineResult.HandshakeStatus handshakeStatus,
                       int bytesConsumed,
                       int bytesProduced)
初始化此类的一个新实例。

参数：
status - 该操作的返回值。
handshakeStatus - 当前的握手状态。
bytesConsumed - 使用的源 ByteBuffer 中的字节数。
bytesProduced - 放入目标 ByteBuffer 中的字节数
抛出：
IllegalArgumentException - 如果 status 或 handshakeStatus 参数为 null，如果 <<code>bytesConsumed 或 bytesProduced 为负。
方法详细信息

getStatus

public final SSLEngineResult.Status getStatus()
获得此 SSLEngine 操作的返回值。

返回：
返回值

getHandshakeStatus

public final SSLEngineResult.HandshakeStatus getHandshakeStatus()
获得此 SSLEngine 操作的握手状态。

返回：
握手状态

bytesConsumed

public final int bytesConsumed()
返回使用的输入缓冲区中的字节数。

返回：
使用的字节数。

bytesProduced

public final int bytesProduced()
返回写入到输出缓冲区中的字节数。

返回：
生成的字节数。

toString

public String toString()
返回此对象的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLEngineResult.HandshakeStatus (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.net.ssl
枚举 SSLEngineResult.HandshakeStatus

java.lang.Object
    继承者  java.lang.Enum<SSLEngineResult.HandshakeStatus>
        继承者  javax.net.ssl.SSLEngineResult.HandshakeStatus
所有已实现的接口：
Serializable, Comparable<SSLEngineResult.HandshakeStatus>
正在封闭类：
SSLEngineResult
public static enum SSLEngineResult.HandshakeStatus
extends Enum<SSLEngineResult.HandshakeStatus>

描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。

从以下版本开始：
1.5

枚举常量摘要
FINISHED
SSLEngine 已经完成握手。
NEED_TASK
SSLEngine 在继续进行握手前需要一个（或多个）代理任务的结果。
NEED_UNWRAP
在继续进行握手前，SSLEngine 需要从远端接收数据。
NEED_WRAP
在继续进行握手前，SSLEngine 必须向远端发送数据，所以应该调用 SSLEngine.wrap()。
NOT_HANDSHAKING
SSLEngine 当前没有进行握手。
方法摘要
static SSLEngineResult.HandshakeStatus | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SSLEngineResult.HandshakeStatus[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

NOT_HANDSHAKING

public static final SSLEngineResult.HandshakeStatus NOT_HANDSHAKING
SSLEngine 当前没有进行握手。

FINISHED

public static final SSLEngineResult.HandshakeStatus FINISHED
SSLEngine 已经完成握手。

此值只能通过调用 SSLEngine.wrap()/unwrap() 且该调用结束了一次握手过程时生成。它从来不由 SSLEngine.getHandshakeStatus() 生成。

另请参见：
SSLEngine.wrap(ByteBuffer, ByteBuffer),
SSLEngine.unwrap(ByteBuffer, ByteBuffer),
SSLEngine.getHandshakeStatus()

NEED_TASK

public static final SSLEngineResult.HandshakeStatus NEED_TASK
SSLEngine 在继续进行握手前需要一个（或多个）代理任务的结果。

另请参见：
SSLEngine.getDelegatedTask()

NEED_WRAP

public static final SSLEngineResult.HandshakeStatus NEED_WRAP
在继续进行握手前，SSLEngine 必须向远端发送数据，所以应该调用 SSLEngine.wrap()。

另请参见：
SSLEngine.wrap(ByteBuffer, ByteBuffer)

NEED_UNWRAP

public static final SSLEngineResult.HandshakeStatus NEED_UNWRAP
在继续进行握手前，SSLEngine 需要从远端接收数据。

方法详细信息

values

public static final SSLEngineResult.HandshakeStatus[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SSLEngineResult.HandshakeStatus c : SSLEngineResult.HandshakeStatus.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SSLEngineResult.HandshakeStatus valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SSLEngineResult.Status (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.net.ssl
枚举 SSLEngineResult.Status

java.lang.Object
    继承者  java.lang.Enum<SSLEngineResult.Status>
        继承者  javax.net.ssl.SSLEngineResult.Status
所有已实现的接口：
Serializable, Comparable<SSLEngineResult.Status>
正在封闭类：
SSLEngineResult
public static enum SSLEngineResult.Status
extends Enum<SSLEngineResult.Status>

描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。 Status 值不能反映当前正在进行的 SSLEngine 握手的状态。有关该握手状态的信息应参考 SSLEngineResult 的 HandshakeStatus。

从以下版本开始：
1.5

枚举常量摘要
BUFFER_OVERFLOW
SSLEngine 不能进行该操作，因为在目标缓冲区没有足够的字节空间可以容纳结果。
BUFFER_UNDERFLOW
SSLEngine 不能对传入的数据解包，因为没有足够的源字节可以用来生成一个完整的包。
CLOSED
该操作只关闭了 SSLEngine 的这一端，或者由于它已经关闭而无法完成该操作。
OK
SSLEngine 完成了操作，并且可处理类似的调用。
方法摘要
static SSLEngineResult.Status | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SSLEngineResult.Status[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

BUFFER_UNDERFLOW

public static final SSLEngineResult.Status BUFFER_UNDERFLOW
SSLEngine 不能对传入的数据解包，因为没有足够的源字节可以用来生成一个完整的包。

再重新调用一次即可有更多的字节可供使用。

BUFFER_OVERFLOW

public static final SSLEngineResult.Status BUFFER_OVERFLOW
SSLEngine 不能进行该操作，因为在目标缓冲区没有足够的字节空间可以容纳结果。

再重新调用一次即可有更多的字节可供使用。

另请参见：
SSLSession.getPacketBufferSize(), SSLSession.getApplicationBufferSize()

OK

public static final SSLEngineResult.Status OK
SSLEngine 完成了操作，并且可处理类似的调用。

CLOSED

public static final SSLEngineResult.Status CLOSED
该操作只关闭了 SSLEngine 的这一端，或者由于它已经关闭而无法完成该操作。

方法详细信息

values

public static final SSLEngineResult.Status[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SSLEngineResult.Status c : SSLEngineResult.Status.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SSLEngineResult.Status valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SSLException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.net.ssl.SSLException
所有已实现的接口：
Serializable
直接已知子类：
SSLHandshakeException, SSLKeyException, SSLPeerUnverifiedException, SSLProtocolException
public class SSLException
extends IOException

指示由 SSL 子系统检测到的某类错误。此类为异常的通用类，它是由失败 SSL 相关操作生成的。

从以下版本开始：
1.4 。
另请参见：
序列化表格

构造方法摘要
SSLException(String reason)
构造一个异常，该异常报告由 SSL 子系统发现的错误。
SSLException(String message, Throwable cause)
创建带指定详细消息和原因的 SSLException。
SSLException(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造异常 SSLException（它通常包含 cause 的类和详细消息）。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLException

public SSLException(String reason)
构造一个异常，该异常报告由 SSL 子系统发现的错误。

参数：
reason - 描述该问题。

SSLException

public SSLException(String message,
                    Throwable cause)
创建带指定详细消息和原因的 SSLException。

参数：
message - 详细消息（保存此消息，以便以后通过 Throwable.getMessage() 方法获取它）。
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5

SSLException

public SSLException(Throwable cause)
根据指定的原因和 (cause==null ? null : cause.toString()) 的详细消息构造异常 SSLException（它通常包含 cause 的类和详细消息）。

参数：
cause - cause（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出原因是不存在的或是未知的。）
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLHandshakeException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLHandshakeException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.net.ssl.SSLException
                    继承者  javax.net.ssl.SSLHandshakeException
所有已实现的接口：
Serializable
public class SSLHandshakeException
extends SSLException

指示客户端和服务器不能就所需安全级别进行协商。连接不再可用。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
SSLHandshakeException(String reason)
构造一个报告由 SSL 子系统在握手期间发现的错误的异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLHandshakeException

public SSLHandshakeException(String reason)
构造一个报告由 SSL 子系统在握手期间发现的错误的异常。

参数：
reason - 描述问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLKeyException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLKeyException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.net.ssl.SSLException
                    继承者  javax.net.ssl.SSLKeyException
所有已实现的接口：
Serializable
public class SSLKeyException
extends SSLException

报告错误的 SSL 密钥。通常，这指示对服务器或客户端的 SSL 证书和私钥的错误配置。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
SSLKeyException(String reason)
构造一个报告由 SSL 子系统发现的密钥管理错误的异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLKeyException

public SSLKeyException(String reason)
构造一个报告由 SSL 子系统发现的密钥管理错误的异常。

参数：
reason - 描述问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLParameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLParameters

java.lang.Object
    继承者  javax.net.ssl.SSLParameters

public class SSLParameters
extends Object

封装 SSL/TLS 连接的参数。参数是 SSL/TLS 握手中接受的密码套件列表、允许的协议列表，以及 SSL/TLS 服务器是否应该请求或要求客户机验证。

通过此类的构造方法可以创建 SSLParameters。使用 SSLSocket 和 SSLEngine 中的 getSSLParameters() 方法或者 SSLContext 中的 getDefaultSSLParameters() 和 getSupportedSSLParameters() 方法，还可以获取对象。

通过 SSLSocket.setSSLParameters() 和 SSLEngine.getSSLParameters() 方法可以将 SSLParameters 应用到连接。

从以下版本开始：
1.6
另请参见：
SSLSocket, SSLEngine, SSLContext

构造方法摘要
SSLParameters()
构造 SSLParameters。
SSLParameters(String[] cipherSuites)
根据指定的密码套件数组构造 SSLParameters。
SSLParameters(String[] cipherSuites, String[] protocols)
根据指定的密码套件数组和协议数组构造 SSLParameters。
方法摘要
String[] | getCipherSuites() 返回密码套件数组的副本；如果未设置，则返回 null。
boolean | getNeedClientAuth() 返回是否应该要求客户机验证。
String[] | getProtocols() 返回协议数组的副本；如果未设置，则返回 null。
boolean | getWantClientAuth() 返回是否应该请求客户机验证。
void | setCipherSuites(String[] cipherSuites) 设置密码套件数组。
void | setNeedClientAuth(boolean needClientAuth) 设置是否应该要求客户机验证。
void | setProtocols(String[] protocols) 设置协议数组。
void | setWantClientAuth(boolean wantClientAuth) 设置是否应该请求客户机验证。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SSLParameters

public SSLParameters()
构造 SSLParameters。

cipherSuites 和协议值被设置为 null，wantClientAuth 和 needClientAuth 被设置为 false。

SSLParameters

public SSLParameters(String[] cipherSuites)
根据指定的密码套件数组构造 SSLParameters。调用此构造方法等效于先调用无参数构造方法，再调用 setCipherSuites(cipherSuites)。

参数：
cipherSuites - 密码套件数组（或 null）

SSLParameters

public SSLParameters(String[] cipherSuites,
                     String[] protocols)
根据指定的密码套件数组和协议数组构造 SSLParameters。调用此构造方法等效于先调用无参数构造方法，再调用 setCipherSuites(cipherSuites) 和 setProtocols(protocols)。

参数：
cipherSuites - 密码套件数组（或 null）
protocols - 协议数组（或 null）
方法详细信息

getCipherSuites

public String[] getCipherSuites()
返回密码套件数组的副本；如果未设置，则返回 null。

返回：
密码套件数组的副本；如果未设置，则返回 null。

setCipherSuites

public void setCipherSuites(String[] cipherSuites)
设置密码套件数组。

参数：
cipherSuites - 密码套件数组（或 null）

getProtocols

public String[] getProtocols()
返回协议数组的副本；如果未设置，则返回 null。

返回：
协议数组的副本；如果未设置，则返回 null。

setProtocols

public void setProtocols(String[] protocols)
设置协议数组。

参数：
protocols - 协议数组（或 null）

getWantClientAuth

public boolean getWantClientAuth()
返回是否应该请求客户机验证。

返回：
是否应该请求客户机验证。

setWantClientAuth

public void setWantClientAuth(boolean wantClientAuth)
设置是否应该请求客户机验证。调用此方法将清除 needClientAuth 标志。

参数：
wantClientAuth - 是否应该请求客户机验证

getNeedClientAuth

public boolean getNeedClientAuth()
返回是否应该要求客户机验证。

返回：
是否应该要求客户机验证。

setNeedClientAuth

public void setNeedClientAuth(boolean needClientAuth)
设置是否应该要求客户机验证。调用此方法将清除 wantClientAuth 标志。

参数：
needClientAuth - 是否应该要求客户机验证
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLPeerUnverifiedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLPeerUnverifiedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.net.ssl.SSLException
                    继承者  javax.net.ssl.SSLPeerUnverifiedException
所有已实现的接口：
Serializable
public class SSLPeerUnverifiedException
extends SSLException

指示还没有验证同位体的身份。

如果同位体未能识别它自己（例如，没有证书、正使用的特定密码套件不支持验证或在 SSL 联络期间没有建立同位体的验证），此异常被抛出。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
SSLPeerUnverifiedException(String reason)
构造一个报告还没有验证 SSL 同位体的身份的异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLPeerUnverifiedException

public SSLPeerUnverifiedException(String reason)
构造一个报告还没有验证 SSL 同位体的身份的异常。

参数：
reason - 描述问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.net.ssl.SSLPermission
所有已实现的接口：
Serializable, Guard
public final class SSLPermission
extends BasicPermission

此类用于各种网络权限。SSLPermission 包含一个名称（也称为“目标名称”），但没有动作列表；您并非一定拥有所指定的权限。

目标名称是网络权限的名称（见下文）。命名约定遵守层次结构属性命名约定。另外，名称的末尾可能有一个星号，星号前有一个“.”，或者只有星号，用来表示通配符。例如："foo.*" 或 "*" 是有效的，而 "*foo" 或 "a*b" 则是无效的。

下表列出了所有可能的 SSLPermission 目标名称，并描述了每个名称允许何种权限，还讨论了将权限授予代码的风险。

权限目标名称 | 权限所允许的操作 | 允许此权限所带来的风险
setHostnameVerifier | 设置回调的能力，回调能决定是否允许通过 HttpsURLConnection 连接的主机不匹配服务器证书中的公共名称字段。 | 恶意代码可以设置校验器，从而监视由 HttpsURLConnection 请求访问的主机名或允许服务器证书使用无效的公共名称。
getSSLSessionContext | 获取 SSLSession 的 SLSessionContext 的能力。 | 恶意代码可以监视在 SSL 同级之间的会话，或者使会话无效从而降低性能。
setDefaultSSLContext | 设置默认的 SSL 上下文的能力 | 恶意代码可以设置监视打开连接的上下文，或者传送的纯文本数据。

从以下版本开始：
1.4
另请参见：
BasicPermission, Permission, Permissions, PermissionCollection, SecurityManager, 序列化表格

构造方法摘要
SSLPermission(String name)
用指定的名称创建一个新的 SSLPermission。
SSLPermission(String name, String actions)
用指定的名称创建一个新的 SSLPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLPermission

public SSLPermission(String name)
用指定的名称创建一个新的 SSLPermission。此名称是 SSLPermission 的符号名，比如“setDefaultAuthenticator”等等。名称的末尾可能有一个星号，它的前面有一个“.”，或者只有星号，用来表示通配符。

参数：
name - SSLPermission 的名称。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

SSLPermission

public SSLPermission(String name,
                     String actions)
用指定的名称创建一个新的 SSLPermission 对象。此名称是 SSLPermission 的符号名，当前不使用动作 String，其应该为 null。

参数：
name - SSLPermission 的名称。
actions - 忽略。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLProtocolException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLProtocolException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.net.ssl.SSLException
                    继承者  javax.net.ssl.SSLProtocolException
所有已实现的接口：
Serializable
public class SSLProtocolException
extends SSLException

报告在 SSL 协议的操作中的错误。通常这指示协议实现中的缺陷。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
SSLProtocolException(String reason)
构造一个报告由 SSL 子系统检测到的 SSL 协议错误的异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLProtocolException

public SSLProtocolException(String reason)
构造一个报告由 SSL 子系统检测到的 SSL 协议错误的异常。

参数：
reason - 描述问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLServerSocket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLServerSocket

java.lang.Object
    继承者  java.net.ServerSocket
        继承者  javax.net.ssl.SSLServerSocket

public abstract class SSLServerSocket
extends ServerSocket

此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。

此类的实例通常使用 SSLServerSocketFactory 来创建。SSLServerSocket 的主要功能是通过接受连接来创建 SSLSocket。

SSLServerSocket 包含了一些状态数据，这些数据在创建套接字时由 SSLSocket 继承。它们包括启用的密码套件和协议、客户端验证是否必需，以及创建的套接字应该以客户端模式还是服务器模式开始握手。可以通过调用适当的方法重写由创建的 SSLSocket 所继承的状态。

从以下版本开始：
1.4
另请参见：
ServerSocket, SSLSocket

构造方法摘要
protected | SSLServerSocket() 仅供子类使用。
protected | SSLServerSocket(int port) 仅供子类使用。
protected | SSLServerSocket(int port, int backlog) 仅供子类使用。
protected | SSLServerSocket(int port, int backlog, InetAddress address) 仅供子类使用。
方法摘要
abstract String[] | getEnabledCipherSuites() 返回当前被启用以供新接受的连接使用的密码套件列表。
abstract String[] | getEnabledProtocols() 返回当前新接受的连接启用的协议的名称。
abstract boolean | getEnableSessionCreation() 如果新 SSL 会话可以通过此服务器套接字创建的套接字建立，则返回 true。
abstract boolean | getNeedClientAuth() 如果新 accept 的服务器模式的 SSLSocket 要求 客户端验证，则返回 true。
abstract String[] | getSupportedCipherSuites() 返回可以启用以供 SSL 连接使用的密码套件的名称。
abstract String[] | getSupportedProtocols() 返回可以启用的协议的名称。
abstract boolean | getUseClientMode() 如果接受的连接处于 SSL 客户端模式，则返回 true。
abstract boolean | getWantClientAuth() 如果新接受的服务器模式的连接请求 客户端验证，则返回 true。
abstract void | setEnabledCipherSuites(String[] suites) 把密码套件设置为启用的以供接受的连接使用。
abstract void | setEnabledProtocols(String[] protocols) 控制启用哪些特定的协议以供接受的连接使用。
abstract void | setEnableSessionCreation(boolean flag) 控制新 SSL 会话是否可以通过此服务器套接字创建的套接字建立。
abstract void | setNeedClientAuth(boolean need) 控制接受的服务器模式 SSLSocket 是否将在开始时配置为要求 客户端验证。
abstract void | setUseClientMode(boolean mode) 控制接受的连接是以（默认的）SSL 服务器模式还是在 SSL 客户端模式工作。
abstract void | setWantClientAuth(boolean want) 控制 accept 服务器模式的 SSLSockets 是否将在开始时配置为请求 客户端验证。
从类 java.net.ServerSocket 继承的方法
accept, bind, bind, close, getChannel, getInetAddress, getLocalPort, getLocalSocketAddress, getReceiveBufferSize, getReuseAddress, getSoTimeout, implAccept, isBound, isClosed, setPerformancePreferences, setReceiveBufferSize, setReuseAddress, setSocketFactory, setSoTimeout, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLServerSocket

protected SSLServerSocket()
                   throws IOException
仅供子类使用。

使用默认的验证上下文创建未绑定的 TCP 服务器套接字。

抛出：
IOException - 如果创建套接字时发生 I/O 错误

SSLServerSocket

protected SSLServerSocket(int port)
                   throws IOException
仅供子类使用。

使用默认的验证上下文在端口上创建 TCP 服务器套接字。连接 backlog 默认为最多可有五十个连接排队，超过此数，系统将拒绝新的连接请求。

参数：
port - 侦听的端口
抛出：
IOException - 当创建套接字时出现 I/O 错误

SSLServerSocket

protected SSLServerSocket(int port,
                          int backlog)
                   throws IOException
仅供子类使用。

使用默认的验证上下文和指定的连接 backlog 在端口上创建 TCP 服务器套接字。

参数：
port - 侦听的端口号
backlog - 在系统应该开始拒绝新的请求前可以挂起的连接数
抛出：
IOException - 如果创建套接字时出现 I/O 错误

SSLServerSocket

protected SSLServerSocket(int port,
                          int backlog,
                          InetAddress address)
                   throws IOException
仅供子类使用。

使用默认的验证上下文、指定的连接 backlog 和指定的网络接口在端口上创建 TCP 服务器套接字。此构造方法用在多宿主机（像那些用作防火墙或路由器的主机）上以控制通过哪一个接口提供网络服务。

参数：
port - 侦听的端口号
backlog - 在系统应该开始拒绝新的请求前可以挂起的连接数
address - 网络接口的地址，通过此地址接受连接
抛出：
IOException - 如果创建套接字时出现 I/O 错误
方法详细信息

getEnabledCipherSuites

public abstract String[] getEnabledCipherSuites()
返回当前被启用以供新接受的连接使用的密码套件列表。

如果没有显式修改此列表，则系统提供的默认值在所有启用的密码套件中保证最低的服务质量。

实际上不使用启用的密码套件有多个原因。例如： 服务器套接字可能没有适当的私钥供它使用或者密码套件可能是匿名的，阻止使用客户端验证，而服务器套接字已经被告知需要那种验证。

返回：
启用的密码套件的数组
另请参见：
getSupportedCipherSuites(), setEnabledCipherSuites(String [])

setEnabledCipherSuites

public abstract void setEnabledCipherSuites(String[] suites)
把密码套件设置为启用的以供接受的连接使用。

这些密码套件必须已经由 getSupportedCipherSuites() 作为支持套件列出。在成功调用此方法之后，只有在 suites 参数中列出的套件才会被启用以供连接使用。

对于需要验证信息但这些信息在此 ServerSocket 的验证上下文中不存在的套件，即使已经启用，任何情况下也不会使用它。

从 accept() 返回的 SSLSocket 继承此设置。

参数：
suites - 要启用的所有密码套件名称
抛出：
IllegalArgumentException - 当一个或多个由参数命名的密码套件不被支持时，或参数为 null 时。
另请参见：
getSupportedCipherSuites(), getEnabledCipherSuites()

getSupportedCipherSuites

public abstract String[] getSupportedCipherSuites()
返回可以启用以供 SSL 连接使用的密码套件的名称。

通常，因为此列表可能包括无法满足默认服务质量要求的密码套件，所以默认情况下实际启动的是这些密码套件的子集。这种密码套件在专门的应用程序中才能有用。

返回：
密码套件名称的数组
另请参见：
getEnabledCipherSuites(), setEnabledCipherSuites(String [])

getSupportedProtocols

public abstract String[] getSupportedProtocols()
返回可以启用的协议的名称。

返回：
支持的协议名称的数组
另请参见：
getEnabledProtocols(), setEnabledProtocols(String [])

getEnabledProtocols

public abstract String[] getEnabledProtocols()
返回当前新接受的连接启用的协议的名称。

返回：
协议名称的数组
另请参见：
getSupportedProtocols(), setEnabledProtocols(String [])

setEnabledProtocols

public abstract void setEnabledProtocols(String[] protocols)
控制启用哪些特定的协议以供接受的连接使用。

该协议必须已经由 getSupportedProtocols() 将其作为受支持的协议列出。在成功调用此方法之后，仅启用了在 protocols 参数中列出的协议以便使用。

从 accept() 返回的 SSLSocket 继承此设置。

参数：
protocols - 要启用的所有协议的名称。
抛出：
IllegalArgumentException - 当一个或多个由参数命名的协议不受支持时，或 protocols 参数为 null时。
另请参见：
getEnabledProtocols(), getSupportedProtocols()

setNeedClientAuth

public abstract void setNeedClientAuth(boolean need)
控制接受的服务器模式 SSLSocket 是否将在开始时配置为要求 客户端验证。

套接字的客户端验证设置是下面的其中之一:

  • 必需的客户端验证
  • 请求的客户端验证
  • 不需要客户端验证

与 setWantClientAuth(boolean) 不同，如果设置了接受的套接字的选项并且客户端选择不提供关于自己的验证信息，协商将会停止且连接将被终止。

调用此方法会重写由此方法或 setWantClientAuth(boolean) 以前所做的任何设置。

最初继承的设置可以通过调用 SSLSocket.setNeedClientAuth(boolean) 或 SSLSocket.setWantClientAuth(boolean) 来重写。

参数：
need - 如果要求进行客户端验证，则设置为 true；如果不需要客户端验证，则设置为 false。
另请参见：
getNeedClientAuth(), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

getNeedClientAuth

public abstract boolean getNeedClientAuth()
如果新 accept 的服务器模式的 SSLSocket 要求 客户端验证，则返回 true。

最初继承的设置可以通过调用 SSLSocket.setNeedClientAuth(boolean) 或 SSLSocket.setWantClientAuth(boolean) 来重写。

返回：
如果要求进行客户端验证，返回 true；如果不需要客户端验证，则返回 false。
另请参见：
setNeedClientAuth(boolean), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

setWantClientAuth

public abstract void setWantClientAuth(boolean want)
控制 accept 服务器模式的 SSLSockets 是否将在开始时配置为请求 客户端验证。

套接字的客户端验证设置是下面的其中之一:

  • 必需的客户端验证
  • 请求的客户端验证
  • 不需要客户端验证

与 setNeedClientAuth(boolean) 不同，如果设置了接受的套接字的选项并且客户端选择不提供关于自己的验证信息，则协商将会继续。

调用此方法会重写由此方法或 setNeedClientAuth(boolean) 以前所做的任何设置。

最初继承的设置可以通过调用 SSLSocket.setNeedClientAuth(boolean) 或 SSLSocket.setWantClientAuth(boolean) 来重写。

参数：
want - 如果请求进行客户端验证，则设置为 true；如果不需要客户端验证，则设置为 false。
另请参见：
getWantClientAuth(), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

getWantClientAuth

public abstract boolean getWantClientAuth()
如果新接受的服务器模式的连接请求 客户端验证，则返回 true。

最初继承的设置可以通过调用 SSLSocket.setNeedClientAuth(boolean) 或 SSLSocket.setWantClientAuth(boolean) 来重写。

返回：
如果请求进行客户端验证，则返回 true；如果不需要客户端验证，则返回 false。
另请参见：
setWantClientAuth(boolean), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

setUseClientMode

public abstract void setUseClientMode(boolean mode)
控制接受的连接是以（默认的）SSL 服务器模式还是在 SSL 客户端模式工作。

服务器通常对其自己进行验证，不要求客户端也这么做。

有时，TCP 服务器需要以SSL 客户端模式处理新接受的连接，但这种情况比较少见。例如，FTP 客户端在获得服务器套接字的同时侦听是否有来自服务器的反向连接。FTP 客户端将使用 "client" 模式的 SSLServerSocket 来接受反向的连接，而 FTP 服务器使用禁止 "client" 模式的 SSLSocket 来启动连接。在联络期间，可以重用已存在的 SSL 会话。

从 accept() 返回的 SSLSocket 继承此设置。

参数：
mode - 如果新接受的连接应该使用 SSL 客户端模式，则此参数为 true。
另请参见：
getUseClientMode()

getUseClientMode

public abstract boolean getUseClientMode()
如果接受的连接处于 SSL 客户端模式，则返回 true。

返回：
如果连接应该使用 SSL 客户端模式，则返回 true。
另请参见：
setUseClientMode(boolean)

setEnableSessionCreation

public abstract void setEnableSessionCreation(boolean flag)
控制新 SSL 会话是否可以通过此服务器套接字创建的套接字建立。

从 accept() 返回的 SSLSocket 继承此设置。

参数：
flag - 为 true 时指示可以创建会话，这是默认的；为 false 时指示必须恢复现有的会话。
另请参见：
getEnableSessionCreation()

getEnableSessionCreation

public abstract boolean getEnableSessionCreation()
如果新 SSL 会话可以通过此服务器套接字创建的套接字建立，则返回 true。

返回：
为 true 时指示可以创建会话，这是默认的；为 false 时指示必须恢复现有的会话。
另请参见：
setEnableSessionCreation(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLServerSocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLServerSocketFactory

java.lang.Object
    继承者  javax.net.ServerSocketFactory
        继承者  javax.net.ssl.SSLServerSocketFactory

public abstract class SSLServerSocketFactory
extends ServerSocketFactory

SSLServerSocketFactory 创建 SSLServerSocket。

从以下版本开始：
1.4
另请参见：
SSLSocket, SSLServerSocket

构造方法摘要
protected SSLServerSocketFactory()
构造方法仅供子类使用。
方法摘要
static ServerSocketFactory | getDefault() 返回默认的 SSL 服务器套接字工厂。
abstract String[] | getDefaultCipherSuites() 返回默认情况下启用的密码套件的列表。
abstract String[] | getSupportedCipherSuites() 返回可以在由此工厂创建的 SSL 连接上启用的密码套件的名称。
从类 javax.net.ServerSocketFactory 继承的方法
createServerSocket, createServerSocket, createServerSocket, createServerSocket
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SSLServerSocketFactory

protected SSLServerSocketFactory()
构造方法仅供子类使用。

方法详细信息

getDefault

public static ServerSocketFactory getDefault()
返回默认的 SSL 服务器套接字工厂。

第一次调用此方法时，将检查安全属性 "ssl.ServerSocketFactory.provider"。如果它不为 null，则加载并实例化使用该名称的类。如果成功并且该对象是 SSLServerSocketFactory 的实例，则它成为默认的 SSL 服务器套接字工厂。

否则，此方法返回 SSLContext.getDefault().getServerSocketFactory()。如果该调用失败，则返回无效的工厂。

返回：
默认的 ServerSocketFactory
另请参见：
SSLContext.getDefault()

getDefaultCipherSuites

public abstract String[] getDefaultCipherSuites()
返回默认情况下启用的密码套件的列表。除非启用了不同的列表，否则 SSL 连接上的联络将使用这些密码套件中的一个。这些默认值的最低服务质量是要求保护机密性和服务器验证（也就是说没有匿名的密码套件）。

返回：
默认情况下启用的密码套件的数组。
另请参见：
getSupportedCipherSuites()

getSupportedCipherSuites

public abstract String[] getSupportedCipherSuites()
返回可以在由此工厂创建的 SSL 连接上启用的密码套件的名称。通常，因为此列表可能包含不能满足这些默认值的服务质量要求的密码套件，所以默认情况下只能实际启用它们的子集。这种密码套件在专门的应用程序中才能有用。

返回：
密码套件名称的数组
另请参见：
getDefaultCipherSuites()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLSession (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 SSLSession

public interface SSLSession

在 SSL 中，会话用来描述两个实体间正在发生的关系。每个 SSL 连接在某一时刻都会涉及一个会话，但是该会话可以同时地或相继地用在这些实体的多个连接上。还可以用不同的会话代替某一连接上使用的会话。会话是作为 SSL 握手协议的一部分创建或重新加入的。影响安全或资源使用的策略或由应用程序显式调用 invalidate 可能使会话无效。会话管理策略通常用来调优性能。

除了标准会话属性之外，SSL 会话还会公开以下这些只读属性：

  • 同级身份。 会话是在特定客户端和特定服务器之间进行的。同级身份可能已作为会话设置的一部分建立。同位体通常是用 X.509 证书链标识。
  • 密码套件的名称。密码套件描述在特定会话中的连接使用的加密保护的种类。
  • 同级主机。一次会话的所有连接都是在相同的两个主机之间进行的。连接的另一端的主机的地址是可用的。

可以显式地使会话无效。当遇到某种错误时，也可以隐式地使会话无效。

从以下版本开始：
1.4

方法摘要
int | getApplicationBufferSize() 获取使用此会话时期望的最大应用程序数据的当前大小。
String | getCipherSuite() 返回会话中的所有连接所使用的 SSL 密码套件的名称。
long | getCreationTime() 返回创建此会话表示的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。
byte[] | getId() 返回分配给此会话的标识符。
long | getLastAccessedTime() 返回此会话表示上一次被会话层应用访问的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。
Certificate[] | getLocalCertificates() 返回握手期间发送给同位体的证书。
Principal | getLocalPrincipal() 返回握手期间发送给同位体的主体。
int | getPacketBufferSize() 获取使用此会话时期望的最大 SSL/TLS 包的当前大小。
X509Certificate[] | getPeerCertificateChain() 返回同级身份，该同级身份被标识作为定义会话的一部分。
Certificate[] | getPeerCertificates() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
String | getPeerHost() 返回此会话中同位体的主机名称。
int | getPeerPort() 返回此会话中同位体的端口号。
Principal | getPeerPrincipal() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
String | getProtocol() 返回会话中的所有连接使用的协议的标准名称。
SSLSessionContext | getSessionContext() 返回此会话所在的上下文。
Object | getValue(String name) 返回会话的应用层数据中的绑定到给定名称的对象。
String[] | getValueNames() 返回绑定到会话中的所有应用层数据对象的名称组成的数组。
void | invalidate() 使会话失效。
boolean | isValid() 返回此会话对于恢复和加入是否是有效的和可用的。
void | putValue(String name, Object value) 使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。
void | removeValue(String name) 移除会话的应用层数据中绑定到给定名称的对象。

方法详细信息

getId

byte[] getId()
返回分配给此会话的标识符。

返回：
会话的标识符

getSessionContext

SSLSessionContext getSessionContext()
返回此会话所在的上下文。

此上下文在一些环境中可能不可用，在这种情况下，此方法返回 null。

如果存在上下文并且已安装了一个安全管理器，则调用者可能需要相应的权限才能访问上下文，否则可能抛出安全异常。在 Java 环境中，使用 SSLPermission("getSSLSessionContext") 权限调用安全管理器的 checkPermission 方法。

返回：
用于此会话的会话上下文；如果上下文不可用，则返回 null。
抛出：
SecurityException - 如果调用线程没有获取 SSL 会话上下文的权限。

getCreationTime

long getCreationTime()
返回创建此会话表示的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。

返回：
创建此会话的时间

getLastAccessedTime

long getLastAccessedTime()
返回此会话表示上一次被会话层应用访问的时间，该时间是自协调世界时 1970 年 1 月 1 日午夜起经过的毫秒数。

访问将指示使用会话数据建立一个新的连接。访问期间并不反映应用级操作，例如获取或设置与会话相关的值。

此信息在会话管理策略中特别有用。例如，会话管理器线程可以将所有会话放在一个很长时间未被使用的给定上下文中；或者可能根据生存时间对会话进行排序，以优化一些任务。

返回：
上一次访问此会话的时间

invalidate

void invalidate()
使会话失效。

将来的连接无法恢复或加入此会话。但是，任何使用此会话的现有连接可以继续使用此会话，直到该连接关闭。

另请参见：
isValid()

isValid

boolean isValid()
返回此会话对于恢复和加入是否是有效的和可用的。

返回：
如果可以重新加入此会话，则返回 true。
从以下版本开始：
1.5
另请参见：
invalidate()

putValue

void putValue(String name,
              Object value)
使用给定的 name 将指定的 value 对象绑定到会话的应用层数据中。

替换任何使用相同 name 的现有绑定。如果新的（或现有）value 实现了 SSLSessionBindingListener 接口，则会相应地通知 value 表示的对象。

出于安全原因，具有相同名称的值在不同的访问控制上下文之间是不可见的。

参数：
name - 数据对象将要绑定到的名称。此参数不可以为 null。
value - 将要绑定的数据对象。此参数不可以为 null。
抛出：
IllegalArgumentException - 如果任何一个参数为 null。

getValue

Object getValue(String name)
返回会话的应用层数据中的绑定到给定名称的对象。如果不存在这种绑定，则返回 null。

出于安全原因，具有相同名称的值在不同的访问控制上下文之间是不可见的。

参数：
name - 要查找的绑定的名称。
返回：
绑定到该名称的值；如果不存在绑定，则返回 null。
抛出：
IllegalArgumentException - 如果参数为 null。

removeValue

void removeValue(String name)
移除会话的应用层数据中绑定到给定名称的对象。如果没有对象绑定到给定名称，则什么都不做。如果绑定的现有对象实现了 SessionBindingListener 接口，则以适当的方式通知它。

出于安全原因，具有相同名称的值在不同的访问控制上下文之间是不可见的。

参数：
name - 将移除的在不同访问控制上下文之间可见的对象名称
抛出：
IllegalArgumentException - 如果参数为 null。

getValueNames

String[] getValueNames()
返回绑定到会话中的所有应用层数据对象的名称组成的数组。

出于安全原因，具有相同名称的值在不同的访问控制上下文之间是不可见的。

返回：
绑定到此会话的对象的名称组成的非 null（可能为空）数组。

getPeerCertificates

Certificate[] getPeerCertificates()
                                  throws SSLPeerUnverifiedException
返回同级身份，该同级身份是作为定义会话的一部分而建立的。

注：仅当使用基于证书的密码套件时才可以使用此方法；将它与非基于证书的密码套件（如 Kerberos）一起使用将抛出 SSLPeerUnverifiedException。

返回：
同级证书的有序数组，同位体自己的证书紧跟在任何证书授权之后。
抛出：
SSLPeerUnverifiedException - 如果同级身份未被验证
另请参见：
getPeerPrincipal()

getLocalCertificates

Certificate[] getLocalCertificates()
返回握手期间发送给同位体的证书。

注：仅当使用基于证书的密码套件时此方法才有用。

当在一次握手中有多个证书可供使用时，具体实现可以选择使用它认为“最好的”证书链，并将该证书链传输给另一端。此方法允许调用者知道实际使用了哪些证书链。

返回：
证书的有序数组，本地证书紧跟在任何证书授权之后。如果没有发送任何证书，则返回 null。
另请参见：
getLocalPrincipal()

getPeerCertificateChain

X509Certificate[] getPeerCertificateChain()
                                          throws SSLPeerUnverifiedException
返回同级身份，该同级身份被标识作为定义会话的一部分。

注：仅当使用基于证书的密码套件时才可以使用此方法；将它与非基于证书的密码套件（如 Kerberos）一起使用将抛出 SSLPeerUnverifiedException。

注：此方法存在是为了与以前的版本兼容。新的应用程序应该使用 getPeerCertificates()。

返回：
同级 X.509 证书的有序数组，同位体自己的证书紧跟在任何证书授权之后。（证书格式采用原来的 JSSE 证书 X509Certificate 格式。）
抛出：
SSLPeerUnverifiedException - 如果同级身份未被验证
另请参见：
getPeerPrincipal()

getPeerPrincipal

Principal getPeerPrincipal()
                           throws SSLPeerUnverifiedException
返回同级身份，该同级身份是作为定义会话的一部分而建立的。

返回：
同位体的主体。对于基于 X509 的密码套件，返回最终实体证书的 X500Principal；对于 Kerberos 密码套件，返回 KerberosPrincipal。
抛出：
SSLPeerUnverifiedException - 如果同级身份未被验证
从以下版本开始：
1.5
另请参见：
getPeerCertificates(), getLocalPrincipal()

getLocalPrincipal

Principal getLocalPrincipal()
返回握手期间发送给同位体的主体。

返回：
发送给同位体的主体。返回基于 X509 的密码套件的最终实体证书的 X500Principal，以及 Kerberos 的密码套件的 KerberosPrincipal。如果没有发送任何主体，则返回 null。
从以下版本开始：
1.5
另请参见：
getLocalCertificates(), getPeerPrincipal()

getCipherSuite

String getCipherSuite()
返回会话中的所有连接所使用的 SSL 密码套件的名称。

此密码套件定义了针对连接上发送的数据所提供的保护级别，包括所使用的加密类型和如何进行验证的大多数方面。

返回：
会话的密码套件的名称。

getProtocol

String getProtocol()
返回会话中的所有连接使用的协议的标准名称。

此方法定义了连接中使用的协议。

返回：
会话中的所有连接使用的协议的标准名称。

getPeerHost

String getPeerHost()
返回此会话中同位体的主机名称。

对于服务器来说，该主机是客户端的主机；对于客户端来说，它是服务器的主机。此名称可以不是一个完全限定的主机名或根本不是主机名，因为它可以表示同级网络地址的字符串编码。如果需要这样的名称，可以根据此方法返回的值通过名称服务来解析该名称。

此值并没有经过验证，因此不应依赖它。它主要被用作 SSLSession 缓存策略的提示。

返回：
同级主机的主机名称；如果没有信息可用，则返回 null。

getPeerPort

int getPeerPort()
返回此会话中同位体的端口号。

对于服务器来说，该端口号是客户端的端口号；对于客户端来说，它是服务器的端口号。

此值并没有经过验证，因此不应依赖它。它主要被用作 SSLSession 缓存策略的提示。

返回：
同位体的端口号；如果没有信息可用，则返回 -1。
从以下版本开始：
1.5

getPacketBufferSize

int getPacketBufferSize()
获取使用此会话时期望的最大 SSL/TLS 包的当前大小。

使用此会话的 SSLEngine 可以生成任意大小并包括此方法返回的值的 SSL/TLS 包。所有 SSLEngine 网络缓冲区的大小最少应该是这么大，以防止执行 wrap 和 unwrap 时出现空间不足问题。

返回：
期望网络包大小的当前最大值
从以下版本开始：
1.5
另请参见：
SSLEngine.wrap(ByteBuffer, ByteBuffer), SSLEngine.unwrap(ByteBuffer, ByteBuffer)

getApplicationBufferSize

int getApplicationBufferSize()
获取使用此会话时期望的最大应用程序数据的当前大小。

SSLEngine 应用数据缓冲区必须足够大以容纳所接收的取自任何入站网络应用数据包的应用数据。通常，出站应用数据缓冲区可以为任意大小。

返回：
期望应用程序包大小的当前最大值
从以下版本开始：
1.5
另请参见：
SSLEngine.wrap(ByteBuffer, ByteBuffer), SSLEngine.unwrap(ByteBuffer, ByteBuffer)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLSessionBindingEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLSessionBindingEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.net.ssl.SSLSessionBindingEvent
所有已实现的接口：
Serializable
public class SSLSessionBindingEvent
extends EventObject

此事件向 SSLSessionBindingListener 传播。当通过 SSLSession.putValue(String, Object) 或 SSLSession.removeValue(String) 将侦听器对象绑定到 SSLSession 或从 SSLSession 解除绑定时，实现 SSLSessionBindingListener 的对象将接收此类型的事件。事件的 name 字段是一种键，侦听器在其中绑定和解除绑定。

从以下版本开始：
1.4
另请参见：
SSLSession, SSLSessionBindingListener, 序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
SSLSessionBindingEvent(SSLSession session, String name)
构造一个新的 SSLSessionBindingEvent。
方法摘要
String | getName() 返回将对象绑定到或从其解除绑定的名称。
SSLSession | getSession() 返回 SSLSession，将侦听器绑定其中或从其解除绑定。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLSessionBindingEvent

public SSLSessionBindingEvent(SSLSession session,
                              String name)
构造一个新的 SSLSessionBindingEvent。

参数：
session - 充当事件源的 SSLSession
name - 将对象绑定到的或从其解除绑定的名称
抛出：
IllegalArgumentException - 如果 session 为 null。
方法详细信息

getName

public String getName()
返回将对象绑定到或从其解除绑定的名称。

返回：
将对象绑定到的或从其解除绑定的名称

getSession

public SSLSession getSession()
返回 SSLSession，将侦听器绑定其中或从其解除绑定。

返回：
SSLSession
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLSessionBindingListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 SSLSessionBindingListener

所有超级接口：
EventListener
public interface SSLSessionBindingListener
extends EventListener

想知道何时将它们绑定到 SSLSession 或从 SSLSession 解除绑定的对象实现此接口。不管事件通过 SSLSession.putValue(String, Object) 还是 SSLSession.removeValue(String) 出现，事件都通过标识此会话的 SSLSessionBindingEvent 进行通信。

从以下版本开始：
1.4
另请参见：
SSLSession, SSLSessionBindingEvent

方法摘要
void | valueBound(SSLSessionBindingEvent event) 调用此方法通知侦听器要将其绑定到 SSLSession 中。
void | valueUnbound(SSLSessionBindingEvent event) 调用此方法通知侦听器要从 SSLSession 中解除其绑定。

方法详细信息

valueBound

void valueBound(SSLSessionBindingEvent event)
调用此方法通知侦听器要将其绑定到 SSLSession 中。

参数：
event - 将侦听器绑定其中的标识 SSLSession 的事件。

valueUnbound

void valueUnbound(SSLSessionBindingEvent event)
调用此方法通知侦听器要从 SSLSession 中解除其绑定。

参数：
event - 要从此 SSLSession 中被解其绑定的标识 SSLSession 的事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLSessionContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 SSLSessionContext

public interface SSLSessionContext

SSLSessionContext 表示与单个实体关联的 SSLSession。例如，它可以与同时参与多个会话的服务器或客户端相关联。

不是所有的环境都包含会话上下文。

下面是影响会话的存储方式的 SSLSessionContext 参数：

  • 可以将会话设置为经过指定的时间限制后终止。
  • 可以限制可以存储在上下文中的会话数。
可以根据会话的 id 获取会话，SSLSessionContext 中的所有会话 id 可以被列入表中。

从以下版本开始：
1.4
另请参见：
SSLSession

方法摘要
Enumeration | getIds() 返回在此 SSLSessionContext 下分组的所有会话 id 的 Enumeration。
SSLSession | getSession(byte[] sessionId) 返回绑定到指定会话 id 的 SSLSession。
int | getSessionCacheSize() 返回用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
int | getSessionTimeout() 返回在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。
void | setSessionCacheSize(int size) 设置用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。
void | setSessionTimeout(int seconds) 设置在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。

方法详细信息

getSession

SSLSession getSession(byte[] sessionId)
返回绑定到指定会话 id 的 SSLSession。

参数：
sessionId - Session 标识符
返回：
SSLSession；如果指定的会话 id 没有指向有效的 SLSession，则返回 null。
抛出：
NullPointerException - 如果 sessionId 为 null。

getIds

Enumeration getIds()
返回在此 SSLSessionContext 下分组的所有会话 id 的 Enumeration。

返回：
所有 Session id 枚举。

setSessionTimeout

void setSessionTimeout(int seconds)
                       throws IllegalArgumentException
设置在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。

如果把超时值限制设置为't' 秒，则在会话创建 't' 秒后超过超时值限制。当已经超过会话的超时值限制时，SSLSession 对象将变成无效的并且后来的连接不能恢复和重新加入此会话。当此 SSLSessionContext 的超时值改变时，将立即检查会话是否超过超时值。

参数：
seconds - 以秒为单位的新的会话超时值；零表示没有限制。
抛出：
IllegalArgumentException - 如果指定的超时值 < 0。
另请参见：
getSessionTimeout()

getSessionTimeout

int getSessionTimeout()
返回在此 SSLSessionContext 下分组的 SSLSession 对象的超时值限制。

如果把超时值限制设置为't' 秒，则在会话创建 't' 秒后超过超时值限制。当已经超过会话的超时值限制时，SSLSession 对象将变成无效的并且后来的连接不能恢复和重新加入此会话。当此 SSLSessionContext 的超时值改变时，将立即检查会话是否超过超时值。

返回：
以秒为单位的会话超时值；零表示没有限制。
另请参见：
setSessionTimeout(int)

setSessionCacheSize

void setSessionCacheSize(int size)
                         throws IllegalArgumentException
设置用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。

参数：
size - 新的会话缓存大小限制；零表示没有限制。
抛出：
IllegalArgumentException - 如果指定的大小 < 0。
另请参见：
getSessionCacheSize()

getSessionCacheSize

int getSessionCacheSize()
返回用来存储在此 SSLSessionContext 下分组的 SSLSession 对象的缓存大小。

返回：
会话缓存大小；零表示没有大小限制。
另请参见：
setSessionCacheSize(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLSocket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLSocket

java.lang.Object
    继承者  java.net.Socket
        继承者  javax.net.ssl.SSLSocket

public abstract class SSLSocket
extends Socket

此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。

这种套接字是普通的流套接字，只不过它们在底层网络传输协议（如 TCP）上添加了安全保护层。这些保护包括：

  • 完整性保护。SSL 可以防止消息被主动的窃听者修改。
  • 验证。在多数模式下，SSL 提供对等验证。服务器通常要进行验证，客户机可以根据服务器的请求进行验证。
  • 机密性（私有性保护）。在多数模式下，SSL 加密在客户机和服务器之间发送的数据。这保护了数据的机密性，所以被动的窃听者不能看到各种类型的敏感数据，如财务信息或个人信息。

这些保护由一个“密码套件”指定，“密码套件”是给定的 SSL 连接所使用的加密算法组合。在协商过程中，两个端点必须对可用于双方环境的密码套件达成一致。如果不存在这种公共的套件，就不能建立 SSL 连接，也不能交换数据。

通过称为“握手”的协商过程可建立所用的密码套件。此过程的目的是创建或重新加入一个“会话”，“会话”可以防止多个连接超时。握手完成后，可以使用 getSession 方法访问会话的属性。此连接上最初的握手可以用以下三种方式开始：

  • 调用 startHandshake 显式地开始握手，或者
  • 任何在此套接字上读取或写入应用数据的尝试将引起隐式握手，或者
  • 调用 getSession 尝试建立会话（如果当前不存在有效的会话）将进行隐式握手。

如果握手由于某些原因失败，则 SSLSocket 将关闭，不进行更多通信。

管理密码套件时需要知道以下两组密码套件：

  • 支持的 密码套件：SSL 实现支持的所有套件。使用 getSupportedCipherSuites 报告此列表。
  • 启用的 密码套件，它可少于完整的支持套件集。此组使用 setEnabledCipherSuites 方法设置，使用 getEnabledCipherSuites 方法查询。最初，在表示最低建议配置的新套接字上启用默认的密码套件集。

默认情况下，实现要求只默认启用那些可对服务器进行验证并提供机密性的密码套件。只有双方明确同意非验证和/或非私有的（未加密的）的通信时才选择这种密码套件。

第一次创建 SSLSocket 时不进行握手，从而应用程序可以首先设置它们的通信首选项：使用哪个密码套件、套接字应该为客户机还是服务器模式等。但是，应用数据在连接上发送时始终提供安全性。

可以进行注册以便接收握手结束的事件通知。这涉及到另外两个类的使用。HandshakeCompletedEvent 对象会被传递到由此 API 的用户所注册 HandshakeCompletedListener 实例。 SSLSocket 通过 SSLSocketFactory 创建，或通过从 SSLServerSocket 接受 一个连接来创建。

SSL 套接字必须选择以客户机还是服务器模式操作。这将决定谁来开始握手过程，以及每一方应该发送哪种报文。每个连接都必须有一个客户机和一个服务器，否则握手将无法正确进行。初始握手开始后，套接字就不能在客户机和服务器模式间转换，即使在执行重新协商时也不能。

从以下版本开始：
1.4
另请参见：
Socket, SSLServerSocket, SSLSocketFactory

构造方法摘要
protected | SSLSocket() 仅供子类使用。
protected | SSLSocket(InetAddress address, int port) 仅供子类使用。
protected | SSLSocket(InetAddress address, int port, InetAddress clientAddress, int clientPort) 仅供子类使用。
protected | SSLSocket(String host, int port) 仅供子类使用。
protected | SSLSocket(String host, int port, InetAddress clientAddress, int clientPort) 仅供子类使用。
方法摘要
abstract void | addHandshakeCompletedListener(HandshakeCompletedListener listener) 注册一个事件侦听器来接收此连接上的 SSL 握手已经完成的通知。
abstract String[] | getEnabledCipherSuites() 返回当前启用以供此连接使用的 SSL 密码套件的名称。
abstract String[] | getEnabledProtocols() 返回当前启用以供此连接使用的协议版本的名称。
abstract boolean | getEnableSessionCreation() 如果可以使用此套接字建立新的 SSL 会话，则返回 true。
abstract boolean | getNeedClientAuth() 如果套接字要求 客户机验证，则返回 true。
abstract SSLSession | getSession() 返回此连接使用的 SSL 会话。
SSLParameters | getSSLParameters() 返回对此 SSLSocket 有效的 SSLParameters。
abstract String[] | getSupportedCipherSuites() 返回可以启用以供此连接使用的密码套件的名称。
abstract String[] | getSupportedProtocols() 返回能够被启用以供 SSL 连接使用的协议的名称。
abstract boolean | getUseClientMode() 如果套接字设置为握手时使用客户机模式，则返回 true。
abstract boolean | getWantClientAuth() 如果套接字请求 客户机验证，则返回 true。
abstract void | removeHandshakeCompletedListener(HandshakeCompletedListener listener) 移除一个以前注册的握手完成侦听器。
abstract void | setEnabledCipherSuites(String[] suites) 将密码套件设置为启用以供此连接使用。
abstract void | setEnabledProtocols(String[] protocols) 设置启用以供此连接使用的协议版本。
abstract void | setEnableSessionCreation(boolean flag) 控制是否可以使用此套接字建立新的 SSL 会话。
abstract void | setNeedClientAuth(boolean need) 配置套接字要求 客户机验证。
void | setSSLParameters(SSLParameters params) 对此套接字应用 SSLParameters。
abstract void | setUseClientMode(boolean mode) 配置套接字在握手时使用客户机（或服务器）模式。
abstract void | setWantClientAuth(boolean want) 配置套接字请求 客户机验证。
abstract void | startHandshake() 在此连接上开始 SSL 握手。
从类 java.net.Socket 继承的方法
bind, close, connect, connect, getChannel, getInetAddress, getInputStream, getKeepAlive, getLocalAddress, getLocalPort, getLocalSocketAddress, getOOBInline, getOutputStream, getPort, getReceiveBufferSize, getRemoteSocketAddress, getReuseAddress, getSendBufferSize, getSoLinger, getSoTimeout, getTcpNoDelay, getTrafficClass, isBound, isClosed, isConnected, isInputShutdown, isOutputShutdown, sendUrgentData, setKeepAlive, setOOBInline, setPerformancePreferences, setReceiveBufferSize, setReuseAddress, setSendBufferSize, setSocketImplFactory, setSoLinger, setSoTimeout, setTcpNoDelay, setTrafficClass, shutdownInput, shutdownOutput, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SSLSocket

protected SSLSocket()
仅供子类使用。构造未初始化且未连接的 TCP 套接字。

SSLSocket

protected SSLSocket(String host,
                    int port)
             throws IOException,
                    UnknownHostException
仅供子类使用。构造一个到指定端口指定主机的 TCP 连接。它充当 SSL 客户机。

参数：
host - 要连接的主机的名称
port - 服务器的端口号
抛出：
IOException - 如果创建套接字时发生 I/O 错误
UnknownHostException - 如果主机是未知的

SSLSocket

protected SSLSocket(InetAddress address,
                    int port)
             throws IOException
仅供子类使用。构造一个到指定地址和端口的服务器的 TCP 连接。它充当 SSL 客户机。

参数：
address - 服务器的主机
port - 服务器主机的端口
抛出：
IOException - 如果创建套接字时发生 I/O 错误。

SSLSocket

protected SSLSocket(String host,
                    int port,
                    InetAddress clientAddress,
                    int clientPort)
             throws IOException,
                    UnknownHostException
仅供子类使用。构造一个到指定端口指定主机的 SSL 连接，将给定的地址和端口绑定到连接的客户机那端。它充当 SSL 客户机。

参数：
host - 要连接的主机的名称
port - 服务器的端口号
clientAddress - 客户机的主机
clientPort - 客户机的端口号
抛出：
IOException - 如果创建套接字时发生 I/O 错误
UnknownHostException - 如果主机是未知的

SSLSocket

protected SSLSocket(InetAddress address,
                    int port,
                    InetAddress clientAddress,
                    int clientPort)
             throws IOException
仅供子类使用。构造一个到指定地址和 TCP 端口的服务器的 SSL 连接，将给定地址和端口绑定到连接的客户机那端。它充当 SSL 客户机。

参数：
address - 服务器主机
port - 服务器主机的端口
clientAddress - 客户机的主机
clientPort - 客户机端口号
抛出：
IOException - 如果创建套接字时发生 I/O 错误
方法详细信息

getSupportedCipherSuites

public abstract String[] getSupportedCipherSuites()
返回可以启用以供此连接使用的密码套件的名称。通常，此列表可能包含一些默认值不满足服务质量要求的密码套件，所以默认情况下实际只启用了部分密码套件。这种密码套件在特定的应用程序中很有用。

返回：
密码套件名称的数组
另请参见：
getEnabledCipherSuites(), setEnabledCipherSuites(String [])

getEnabledCipherSuites

public abstract String[] getEnabledCipherSuites()
返回当前启用以供此连接使用的 SSL 密码套件的名称。当第一次创建 SSLSocket 时，所有启用的密码套件都支持最低的服务质量。因此，在某些环境中此值可能为空。

即使密码套件已经被启用，也可能不会使用它。例如，同位体不支持它、密码套件必需的证书（私钥）不可用、启用了匿名的密码套件但需要进行验证等。

返回：
密码套件名称数组
另请参见：
getSupportedCipherSuites(), setEnabledCipherSuites(String [])

setEnabledCipherSuites

public abstract void setEnabledCipherSuites(String[] suites)
将密码套件设置为启用以供此连接使用。

suites 参数中的每个密码套件都必须已经由 getSupportedCipherSuites() 列出，否则此方法失败。成功调用此方法之后，只有在 suites 参数中列出的套件才能被启用以供连接使用。

有的密码套件从不被连接使用，有关其原因的更多信息，请参见 getEnabledCipherSuites()。

参数：
suites - 将被启用的所有密码套件的名称
抛出：
IllegalArgumentException - 如果由参数指定的一个或多个协议不受支持，或 protocols 参数为 null。
另请参见：
getSupportedCipherSuites(), getEnabledCipherSuites()

getSupportedProtocols

public abstract String[] getSupportedProtocols()
返回能够被启用以供 SSL 连接使用的协议的名称。

返回：
所支持的协议数组

getEnabledProtocols

public abstract String[] getEnabledProtocols()
返回当前启用以供此连接使用的协议版本的名称。

返回：
协议数组
另请参见：
setEnabledProtocols(String [])

setEnabledProtocols

public abstract void setEnabledProtocols(String[] protocols)
设置启用以供此连接使用的协议版本。

协议必须已经由所支持的 getSupportedProtocols() 列出。成功调用此方法之后，只有在 protocols 参数中列出的协议才能被启用以供使用。

参数：
protocols - 将被启用的所有协议的名称。
抛出：
IllegalArgumentException - 如果由参数指定的一个或多个协议不受支持，或 protocols 参数为 null。
另请参见：
getEnabledProtocols()

getSession

public abstract SSLSession getSession()
返回此连接使用的 SSL 会话。它可以是持久会话，并且通常对应于某个用户的整个登录会话过程。该会话指定一个会话中所有连接主动使用的特定密码套件，以及会话客户机和服务器的标识。

此方法将发起初始握手（如有必要），然后阻塞，直到握手已经建立。

如果在初始握手期间出现错误，则此方法返回一个无效的会话对象，该对象会报告一个无效的密码套件 "SSL_NULL_WITH_NULL_NULL"。

返回：
SSLSession

addHandshakeCompletedListener

public abstract void addHandshakeCompletedListener(HandshakeCompletedListener listener)
注册一个事件侦听器来接收此连接上的 SSL 握手已经完成的通知。

参数：
listener - “握手已完成” (HandShake Completed) 事件侦听器
抛出：
IllegalArgumentException - 如果参数为 null。
另请参见：
startHandshake(), removeHandshakeCompletedListener(HandshakeCompletedListener)

removeHandshakeCompletedListener

public abstract void removeHandshakeCompletedListener(HandshakeCompletedListener listener)
移除一个以前注册的握手完成侦听器。

参数：
listener - “握手已完成”事件侦听器
抛出：
IllegalArgumentException - 如果没有注册此侦听器，或参数为 null。
另请参见：
addHandshakeCompletedListener(HandshakeCompletedListener)

startHandshake

public abstract void startHandshake()
                             throws IOException
在此连接上开始 SSL 握手。这样做通常是因为需要使用新的加密密钥、需要更改密码套件或开始新的会话。若要强制完成重新验证，可以在开始此握手之前使当前会话无效。

如果数据已经在连接上发送，则在此握手期间数据继续流动。当握手完成时，将使用事件来通知。 此方法对于连接上的初始握手是同步的，它在协商的握手完成时返回。一些协议可能不支持在一个已经存在的套接字上的多次握手，并可能抛出 SSLException。

抛出：
IOException - 如果发生网络级别的错误
另请参见：
addHandshakeCompletedListener(HandshakeCompletedListener)

setUseClientMode

public abstract void setUseClientMode(boolean mode)
配置套接字在握手时使用客户机（或服务器）模式。

此方法必须在发生任何握手之前调用。一旦握手开始，在此套接字的生存期内将不能再重置模式。

服务器通常会验证本身，客户机则不要求这么做。

参数：
mode - 如果套接字应该以“客户机”模式开始它的握手，此参数为 true
抛出：
IllegalArgumentException - 如果初始握手开始后试图更改模式。
另请参见：
getUseClientMode()

getUseClientMode

public abstract boolean getUseClientMode()
如果套接字设置为握手时使用客户机模式，则返回 true。

返回：
如果套接字应该以“客户机”模式进行握手，则返回 true
另请参见：
setUseClientMode(boolean)

setNeedClientAuth

public abstract void setNeedClientAuth(boolean need)
配置套接字要求 客户机验证。此选项只对服务器模式的套接字有用。

套接字的客户机验证设置是以下之一:

  • 要求的客户机验证
  • 请求的客户机验证
  • 不需要客户机验证

与 setWantClientAuth(boolean) 不同，如果设置了此选项并且客户机选择不提供关于本身的验证信息，协商将会停止且连接将被终止。

调用此方法会重写由此方法或 setWantClientAuth(boolean) 以前所做的任何设置。

参数：
need - 如果要求客户机验证设置，则为 true；如果不需要客户机验证设置，则为 false。
另请参见：
getNeedClientAuth(), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

getNeedClientAuth

public abstract boolean getNeedClientAuth()
如果套接字要求 客户机验证，则返回 true。此选项只对服务器模式的套接字有用。

返回：
如果要求客户机验证，返回 true；如果不需要客户机验证，则返回 false。
另请参见：
setNeedClientAuth(boolean), setWantClientAuth(boolean), getWantClientAuth(), setUseClientMode(boolean)

setWantClientAuth

public abstract void setWantClientAuth(boolean want)
配置套接字请求 客户机验证。此选项只对服务器模式的套接字有用。

套接字的客户机验证设置是以下之一:

  • 要求的客户机验证
  • 请求的客户机验证
  • 不需要客户机验证

与 setNeedClientAuth(boolean) 不同，如果设置了此选项并且客户机选择不提供关于本身的验证信息，则协商将会继续。

调用此方法会重写由此方法或 setNeedClientAuth(boolean) 以前所做的任何设置。

参数：
want - 如果请求进行客户机验证，则设置为 true；如果不需要客户机验证，则设置为 false。
另请参见：
getWantClientAuth(), setNeedClientAuth(boolean), getNeedClientAuth(), setUseClientMode(boolean)

getWantClientAuth

public abstract boolean getWantClientAuth()
如果套接字请求 客户机验证，则返回 true。此选项只对服务器模式的套接字有用。

返回：
如果请求进行客户机验证，则返回 true；如果不需要客户机验证，则返回 false。
另请参见：
setNeedClientAuth(boolean), getNeedClientAuth(), setWantClientAuth(boolean), setUseClientMode(boolean)

setEnableSessionCreation

public abstract void setEnableSessionCreation(boolean flag)
控制是否可以使用此套接字建立新的 SSL 会话。如果不允许创建会话，也没有可以恢复的现有会话，则握手不会成功。

参数：
flag - 如果为 true，则指示可以创建会话，这是默认设置；如果为 false，则指示必须恢复一个现有的会话
另请参见：
getEnableSessionCreation()

getEnableSessionCreation

public abstract boolean getEnableSessionCreation()
如果可以使用此套接字建立新的 SSL 会话，则返回 true。

返回：
如果为 true，则指示可以创建会话，这是默认设置；如果为 false，则指示必须恢复一个现有的会话
另请参见：
setEnableSessionCreation(boolean)

getSSLParameters

public SSLParameters getSSLParameters()
返回对此 SSLSocket 有效的 SSLParameters。返回的 SSLParameters 的密码套件和协议始终不为 null。

返回：
对此 SSLSocket 有效的 SSLParameters。
从以下版本开始：
1.6

setSSLParameters

public void setSSLParameters(SSLParameters params)
对此套接字应用 SSLParameters。

这意味着：

  • 如果 params.getCipherSuites() 不为 null，则使用该值调用 setEnabledCipherSuites()
  • 如果 params.getProtocols() 不为 null，则使用该值调用 setEnabledProtocols()
  • 如果 params.getNeedClientAuth() 或 params.getWantClientAuth() 返回 true，则分别调用 setNeedClientAuth(true) 和 setWantClientAuth(true)；否则调用 setWantClientAuth(false)。

参数：
params - 参数
抛出：
IllegalArgumentException - 如果 setEnabledCipherSuites() 或 setEnabledProtocols() 调用失败
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SSLSocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 SSLSocketFactory

java.lang.Object
    继承者  javax.net.SocketFactory
        继承者  javax.net.ssl.SSLSocketFactory

public abstract class SSLSocketFactory
extends SocketFactory

SSLSocketFactory 创建 SSLSocket。

从以下版本开始：
1.4
另请参见：
SSLSocket

构造方法摘要
SSLSocketFactory()
构造方法仅供子类使用。
方法摘要
abstract Socket | createSocket(Socket s, String host, int port, boolean autoClose) 返回在连接到指定主机的给定端口的现有套接字上分层的套接字。
static SocketFactory | getDefault() 返回默认的 SSL 套接字工厂。
abstract String[] | getDefaultCipherSuites() 返回默认情况下启用的密码套件的列表。
abstract String[] | getSupportedCipherSuites() 返回可以在 SSL 连接上启用的密码套件的名称。
从类 javax.net.SocketFactory 继承的方法
createSocket, createSocket, createSocket, createSocket, createSocket
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SSLSocketFactory

public SSLSocketFactory()
构造方法仅供子类使用。

方法详细信息

getDefault

public static SocketFactory getDefault()
返回默认的 SSL 套接字工厂。

第一次调用此方法时，将检查安全属性 "ssl.SocketFactory.provider"。如果它不为 null，则加载并实例化使用该名称的类。如果成功并且该对象是 SSLSocketFactory 的实例，则它成为默认的 SSL 套接字工厂。

否则，此方法返回 SSLContext.getDefault().getSocketFactory()。 如果该调用失败，则返回无效的工厂。

返回：
默认的 SocketFactory
另请参见：
SSLContext.getDefault()

getDefaultCipherSuites

public abstract String[] getDefaultCipherSuites()
返回默认情况下启用的密码套件的列表。除非启用了不同的列表，否则 SSL 连接上的联络将使用这些密码套件中的一个。这些默认值的最低服务质量是要求保护机密性和服务器验证（也就是说没有匿名的密码套件）。

返回：
默认情况下启用的密码套件的数组。
另请参见：
getSupportedCipherSuites()

getSupportedCipherSuites

public abstract String[] getSupportedCipherSuites()
返回可以在 SSL 连接上启用的密码套件的名称。通常，因为此列表可能包含不能满足这些默认值的服务质量要求的密码套件，所以默认情况下只能实际启用它们的子集。这种密码套件在专门的应用程序中才能有用。

返回：
密码套件名称的数组
另请参见：
getDefaultCipherSuites()

createSocket

public abstract Socket createSocket(Socket s,
                                    String host,
                                    int port,
                                    boolean autoClose)
                             throws IOException
返回在连接到指定主机的给定端口的现有套接字上分层的套接字。通过代理使用 SSL 或者协商在已有的套接字上使用 SSL 时可以使用此构造方法。主机和端口号指的是逻辑同位体目标。使用为此工厂建立的套接字选项来配置此套接字。

参数：
s - 已有的套接字
host - 服务器主机
port - 服务器端口
autoClose - 关闭此套接字时关闭底层套接字
返回：
连接到指定主机和端口的套接字
抛出：
IOException - 如果创建套接字时出现 I/O 错误
UnknownHostException - 如果不能识别主机
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrustManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 TrustManager

所有已知子接口：
X509TrustManager
public interface TrustManager

这是用于 JSSE 信任管理器的基接口。

TrustManager 负责管理做出信任决定时使用的的信任材料，也负责决定是否接受同位体提供的证书。

通过使用 TrustManagerFactory，或实现 TrustManager 子类之一创建 TrustManager。

从以下版本开始：
1.4
另请参见：
TrustManagerFactory

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrustManagerFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 TrustManagerFactory

java.lang.Object
    继承者  javax.net.ssl.TrustManagerFactory

public class TrustManagerFactory
extends Object

此类充当基于信任材料源的信任管理器的工厂。每个信任管理器管理特定类型的由安全套接字使用的信任材料。信任材料是基于 KeyStore 和/或提供者特定的源。

从以下版本开始：
1.4
另请参见：
TrustManager

构造方法摘要
protected TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 TrustManagerFactory 对象。
方法摘要
String | getAlgorithm() 返回此 TrustManagerFactory 对象的算法名称。
static String | getDefaultAlgorithm() 获取默认的 TrustManagerFactory 算法名称。
static TrustManagerFactory | getInstance(String algorithm) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static TrustManagerFactory | getInstance(String algorithm, Provider provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static TrustManagerFactory | getInstance(String algorithm, String provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
Provider | getProvider() 返回此 TrustManagerFactory 对象的提供者。
TrustManager[] | getTrustManagers() 为每种信任材料返回一个信任管理器。
void | init(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
void | init(ManagerFactoryParameters spec) 使用特定于提供者的信任材料源初始化此工厂。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TrustManagerFactory

protected TrustManagerFactory(TrustManagerFactorySpi factorySpi,
                              Provider provider,
                              String algorithm)
创建 TrustManagerFactory 对象。

参数：
factorySpi - 委托
provider - 提供者
algorithm - 算法
方法详细信息

getDefaultAlgorithm

public static final String getDefaultAlgorithm()
获取默认的 TrustManagerFactory 算法名称。

默认的 TrustManager 可以在运行时改变，方法是通过把 "ssl.TrustManagerFactory.algorithm" 安全属性（在 Java 安全属性文件或 通过调用 Security.setProperty(String, String) 设置）的值设置为期望的名称。

返回：
在 Java 安全属性中指定的默认算法名称；如果没有这种属性存在，则返回一个特定于实现的默认值。

getAlgorithm

public final String getAlgorithm()
返回此 TrustManagerFactory 对象的算法名称。

这与创建此 TrustManagerFactory 对象的 getInstance 调用之一指定的名称相同。

返回：
此 TrustManagerFactory 对象的算法名称。

getInstance

public static final TrustManagerFactory getInstance(String algorithm)
                                             throws NoSuchAlgorithmException
返回充当信任管理器工厂的 TrustManagerFactory 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 TrustManagerFactorySpi 实现的新 TrustManagerFactory 对象，该对象取自支持指定算法的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 请求的信任管理算法的标准名称。有关标准算法名称的信息，请参见 Java Secure Socket Extension Reference Guide 。
返回：
新的 TrustManagerFactory 对象。
抛出：
NoSuchAlgorithmException - 如果没有 Provider 支持指定算法的 TrustManagerFactorySpi 实现。
另请参见：
Provider

getInstance

public static final TrustManagerFactory getInstance(String algorithm,
                                                    String provider)
                                             throws NoSuchAlgorithmException,
                                                    NoSuchProviderException
返回充当信任管理器工厂的 TrustManagerFactory 对象。

返回一个封装 KeyManagerFactorySpi 实现的新 KeyManagerFactory 对象，该实现取自指定的提供者。指定的提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
algorithm - 请求的信任管理算法的标准名称。有关标准算法名称的信息，请参见 Java Secure Socket Extension Reference Guide 。
provider - 提供者的名称。
返回：
新的 TrustManagerFactory 对象
抛出：
NoSuchAlgorithmException - 如果不能从指定提供者获得指定算法的 TrustManagerFactorySpi 实现。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
IllegalArgumentException - 如果提供者的名称为 null 或空。
另请参见：
Provider

getInstance

public static final TrustManagerFactory getInstance(String algorithm,
                                                    Provider provider)
                                             throws NoSuchAlgorithmException
返回充当信任管理器工厂的 TrustManagerFactory 对象。

返回一个封装 TrustManagerFactorySpi 实现的新 TrustManagerFactory 对象，该实现取自指定的 Provider 对象。注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
algorithm - 请求的信任管理算法的标准名称。有关标准算法名称的信息，请参见 Java Secure Socket Extension Reference Guide 。
provider - 提供者的实例。
返回：
新的 TrustManagerFactory 对象。
抛出：
NoSuchAlgorithmException - 如果不能从指定 Provider 对象获得指定算法的 TrustManagerFactorySpi 实现。
IllegalArgumentException - 如果 provider 为 null。
另请参见：
Provider

getProvider

public final Provider getProvider()
返回此 TrustManagerFactory 对象的提供者。

返回：
此 TrustManagerFactory 对象的提供者。

init

public final void init(KeyStore ks)
                throws KeyStoreException
用证书授权源和相关的信任材料初始化此工厂。

提供者通常使用 KeyStore 作为基础做出信任决定。

有关更多灵活初始化的信息，请参见 init(ManagerFactoryParameters)。

参数：
ks - 密钥仓库或 null
抛出：
KeyStoreException - 如果此操作失败

init

public final void init(ManagerFactoryParameters spec)
                throws InvalidAlgorithmParameterException
使用特定于提供者的信任材料源初始化此工厂。

在某些情况下，提供者可能需要初始化参数而不是密钥仓库。期望由该特定提供者的用户传递由提供者定义的适当 ManagerFactoryParameters 实现。然后提供者可以调用 ManagerFactoryParameters 实现中指定的方法来获取所需的信息。

参数：
spec - 特定于提供者的参数规范的实现
抛出：
InvalidAlgorithmParameterException - 如果遇到了错误

getTrustManagers

public final TrustManager[] getTrustManagers()
为每种信任材料返回一个信任管理器。

返回：
密钥管理器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TrustManagerFactorySpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 TrustManagerFactorySpi

java.lang.Object
    继承者  javax.net.ssl.TrustManagerFactorySpi

public abstract class TrustManagerFactorySpi
extends Object

此类为 TrustManagerFactory 类定义了服务提供者接口 (SPI)。

此类中的所有抽象方法都必须由希望提供特定信任管理器工厂实现的每个加密服务提供者来实现。

从以下版本开始：
1.4
另请参见：
TrustManagerFactory, TrustManager

构造方法摘要
TrustManagerFactorySpi()
方法摘要
protected abstract TrustManager[] | engineGetTrustManagers() 为每种信任材料返回一个信任管理器。
protected abstract void | engineInit(KeyStore ks) 用证书授权源和相关的信任材料初始化此工厂。
protected abstract void | engineInit(ManagerFactoryParameters spec) 使用特定于提供者的密钥材料源初始化此工厂。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TrustManagerFactorySpi

public TrustManagerFactorySpi()
方法详细信息

engineInit

protected abstract void engineInit(KeyStore ks)
                            throws KeyStoreException
用证书授权源和相关的信任材料初始化此工厂。

参数：
ks - 密钥仓库或 null
抛出：
KeyStoreException - 如果此操作失败
另请参见：
TrustManagerFactory.init(KeyStore)

engineInit

protected abstract void engineInit(ManagerFactoryParameters spec)
                            throws InvalidAlgorithmParameterException
使用特定于提供者的密钥材料源初始化此工厂。

在某些情况下，提供者可能需要初始化参数而不是密钥仓库。期望由该特定提供者的用户传递由提供者定义的适当 ManagerFactoryParameters 实现。然后提供者可以调用 ManagerFactoryParameters 实现中指定的方法来获取所需的信息。

参数：
spec - 一个特定于提供者的参数规范的实现
抛出：
InvalidAlgorithmParameterException - 如果参数有问题
另请参见：
TrustManagerFactory.init(ManagerFactoryParameters spec)

engineGetTrustManagers

protected abstract TrustManager[] engineGetTrustManagers()
为每种信任材料返回一个信任管理器。

返回：
信任管理器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509ExtendedKeyManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
类 X509ExtendedKeyManager

java.lang.Object
    继承者  javax.net.ssl.X509ExtendedKeyManager
所有已实现的接口：
KeyManager, X509KeyManager
public abstract class X509ExtendedKeyManager
extends Object
implements X509KeyManager

提供 X509KeyManager 接口的扩展的抽象类。

应该重写此类中的方法以提供实际的实现。

从以下版本开始：
1.5

构造方法摘要
protected X509ExtendedKeyManager()
仅供子类使用的构造方法。
方法摘要
String | chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。
String | chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.net.ssl.X509KeyManager 继承的方法
chooseClientAlias, chooseServerAlias, getCertificateChain, getClientAliases, getPrivateKey, getServerAliases

构造方法详细信息

X509ExtendedKeyManager

protected X509ExtendedKeyManager()
仅供子类使用的构造方法。

方法详细信息

chooseEngineClientAlias

public String chooseEngineClientAlias(String[] keyType,
                                      Principal[] issuers,
                                      SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。

默认实现返回 null。

参数：
keyType - 密钥算法类型名称，以首选的密钥类型在前的顺序。
issuers - 可接受的 CA 发行者主题名称列表，如果使用哪个发行者并不重要，则此参数为 null。
engine - 将用于此连接的 SSLEngine。此参数可以为 null，这表示此接口的实现可以自由选择适用于任何引擎的别名。
返回：
所需密钥的别名；如果没有匹配项，则返回 null。

chooseEngineServerAlias

public String chooseEngineServerAlias(String keyType,
                                      Principal[] issuers,
                                      SSLEngine engine)
选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。

默认实现返回 null。

参数：
keyType - 密钥算法类型名称。
issuers - 可接受的 CA 发行者主题名称列表，如果使用哪个发行者并不重要，则此参数为 null。
engine - 将用于此连接的 SSLEngine。此参数可以为 null，这表示此接口的实现可以自由选择适用于任何引擎的别名。
返回：
所需密钥的别名；如果没有匹配项，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509KeyManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 X509KeyManager

所有超级接口：
KeyManager
所有已知实现类：
X509ExtendedKeyManager
public interface X509KeyManager
extends KeyManager

此接口的实例管理使用哪一个基于 X509 证书的密钥对来验证本地的安全套接字。

在安全套接字协商期间，实现调用此接口中的方法来完成下面的工作：

  • 确定基于现有标准进行协商可以使用的别名集合，
  • 选择基于现有标准的最好的别名，和
  • 为指定别名获取相应的密钥材料。

注：应该使用 X509ExtendedKeyManager 支持此类。

从以下版本开始：
1.4

方法摘要
String | chooseClientAlias(String[] keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。
String | chooseServerAlias(String keyType, Principal[] issuers, Socket socket) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。
X509Certificate[] | getCertificateChain(String alias) 返回与给定别名关联的证书链。
String[] | getClientAliases(String keyType, Principal[] issuers) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。
PrivateKey | getPrivateKey(String alias) 返回与给定别名关联的密钥。
String[] | getServerAliases(String keyType, Principal[] issuers) 根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

方法详细信息

getClientAliases

String[] getClientAliases(String keyType,
                          Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字客户端的匹配别名。

参数：
keyType - 密钥算法类型名称
issuers - 可接受的 CA 发行者主体名称列表，如果使用哪个发行者并不重要，则此参数为 null。
返回：
匹配的别名数组；如果没有匹配的，则返回 null。

chooseClientAlias

String chooseClientAlias(String[] keyType,
                         Principal[] issuers,
                         Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字客户端的别名。

参数：
keyType - 密钥算法类型名称，以首选的密钥类型在前的顺序。
issuers - 可接受的 CA 发行者主体名称列表，如果使用哪个发行者并不重要，则此参数为 null。
socket - 将用于此连接的套接字。此参数可以为 null，这表示实现可以自由选择适用于任何套接字的别名。
返回：
所需密钥的别名；如果没有匹配项，则返回 null。

getServerAliases

String[] getServerAliases(String keyType,
                          Principal[] issuers)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），获取用于验证安全套接字服务器端的别名。

参数：
keyType - 密钥算法类型名称
issuers - 可接受的 CA 发行者主体名称列表，如果使用哪个发行者并不重要，则此参数为 null。
返回：
匹配的别名数组；如果没有匹配的，则返回 null。

chooseServerAlias

String chooseServerAlias(String keyType,
                         Principal[] issuers,
                         Socket socket)
根据给定公钥类型和同位体识别的证书发行者授权机构列表（如果有），选择用于验证安全套接字服务器端的别名。

参数：
keyType - 密钥算法类型名称。
issuers - 可接受的 CA 发行者主体名称列表，如果使用哪个发行者并不重要，则此参数为 null。
socket - 将用于此连接的套接字。此参数可以为 null，这表示实现可以自由选择适用于任何套接字的别名。
返回：
所需密钥的别名；如果没有匹配项，则返回 null。

getCertificateChain

X509Certificate[] getCertificateChain(String alias)
返回与给定别名关联的证书链。

参数：
alias - 别名
返回：
证书链（以用户证书在前根证书授权在后的顺序）；如果没有找到别名，则返回 null。

getPrivateKey

PrivateKey getPrivateKey(String alias)
返回与给定别名关联的密钥。

参数：
alias - 别名
返回：
请求的密钥；如果不能找到别名，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509TrustManager (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.net.ssl
接口 X509TrustManager

所有超级接口：
TrustManager
public interface X509TrustManager
extends TrustManager

此接口的实例管理使用哪一个 X509 证书来验证远端的安全套接字。决定是根据信任的证书授权、证书撤消列表、在线状态检查或其他方式做出的。

从以下版本开始：
1.4

方法摘要
void | checkClientTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。
void | checkServerTrusted(X509Certificate[] chain, String authType) 给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。
X509Certificate[] | getAcceptedIssuers() 返回受验证同位体信任的认证中心的数组。

方法详细信息

checkClientTrusted

void checkClientTrusted(X509Certificate[] chain,
                        String authType)
                        throws CertificateException
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的客户端 SSL 验证。 验证类型由实际使用的证书确定。例如，如果使用 RSAPublicKey，则 authType 应为 "RSA"。检查是否大小写敏感的。

参数：
chain - 同位体的证书链
authType - 基于客户端证书的验证类型
抛出：
IllegalArgumentException - 如果将 null 或长度为零的 chain 传递给 chain 参数，或者将 null 或长度为零的字符串传递给 authType 参数
CertificateException - 如果证书链不受此 TrustManager 信任。

checkServerTrusted

void checkServerTrusted(X509Certificate[] chain,
                        String authType)
                        throws CertificateException
给出同位体提供的部分或完整的证书链，构建到可信任的根的证书路径，并且返回是否可以确认和信任将其用于基于验证类型的服务器 SSL 验证。 验证类型是表示为一个 String 的密码套件的密钥交换算法部分，例如 "RSA"、"DHE_DSS"。注：对于一些可输出的密码套件，密钥交换算法是在运行时的联络期间确定的。例如，对于 TLS_RSA_EXPORT_WITH_RC4_40_MD5，当临时的 RSA 密钥 用于密钥交换时 authType 应为 RSA_EXPORT，当使用来自服务器证书的密钥时 authType 应为 RSA。检查是否大小写敏感的。

参数：
chain - 同位体的证书链
authType - 使用的密钥交换算法
抛出：
IllegalArgumentException - 如果 null 或长度为零的 chain 传递给 chain 参数，或者 null 或长度为零的字符串传递给 authType 参数
CertificateException - 如果证书链不受此 TrustManager 信任。

getAcceptedIssuers

X509Certificate[] getAcceptedIssuers()
返回受验证同位体信任的认证中心的数组。

返回：
可接受的 CA 发行者证书的非 null（可能为空）的数组。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.net.ssl (Java 2 Platform SE 6)

 javax.net.ssl
接口
HandshakeCompletedListener
HostnameVerifier
KeyManager
ManagerFactoryParameters
SSLSession
SSLSessionBindingListener
SSLSessionContext
TrustManager
X509KeyManager
X509TrustManager
类
CertPathTrustManagerParameters
HandshakeCompletedEvent
HttpsURLConnection
KeyManagerFactory
KeyManagerFactorySpi
KeyStoreBuilderParameters
SSLContext
SSLContextSpi
SSLEngine
SSLEngineResult
SSLParameters
SSLPermission
SSLServerSocket
SSLServerSocketFactory
SSLSessionBindingEvent
SSLSocket
SSLSocketFactory
TrustManagerFactory
TrustManagerFactorySpi
X509ExtendedKeyManager
枚举
SSLEngineResult.HandshakeStatus
SSLEngineResult.Status
异常
SSLException
SSLHandshakeException
SSLKeyException
SSLPeerUnverifiedException
SSLProtocolException


javax.net.ssl (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.net.ssl

提供用于安全套接字包的类。

请参见：
描述

接口摘要
HandshakeCompletedListener | 任何希望接收有关给定 SSL 连接上 SSL 协议握手结束通知的类实现此接口。
HostnameVerifier | 此类是用于主机名验证的基接口。
KeyManager | 这是用于 JSSE 密钥管理器的基接口。
ManagerFactoryParameters | 此类是用来向 KeyManagerFactory 或 TrustManagerFactory 提供特定于算法的信息的基接口。
SSLSession | 在 SSL 中，会话用来描述两个实体间正在发生的关系。
SSLSessionBindingListener | 想知道何时将它们绑定到 SSLSession 或从 SSLSession 解除绑定的对象实现此接口。
SSLSessionContext | SSLSessionContext 表示与单个实体关联的 SSLSession。
TrustManager | 这是用于 JSSE 信任管理器的基接口。
X509KeyManager | 此接口的实例管理使用哪一个基于 X509 证书的密钥对来验证本地的安全套接字。
X509TrustManager | 此接口的实例管理使用哪一个 X509 证书来验证远端的安全套接字。

类摘要
CertPathTrustManagerParameters | CertPathParameters 的包装器。
HandshakeCompletedEvent | 此事件指示在给定的 SSL 连接上 SSL 握手结束。
HttpsURLConnection | HttpsURLConnection 扩展 HttpURLConnection，支持各种特定于 https 功能。
KeyManagerFactory | 此类充当基于密钥内容源的密钥管理器的工厂。
KeyManagerFactorySpi | 此类为 KeyManagerFactory 类定义了服务提供者接口 (SPI)。
KeyStoreBuilderParameters | 封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。
SSLContext | 此类的实例表示安全套接字协议的实现，它充当用于安全套接字工厂或 SSLEngine 的工厂。
SSLContextSpi | 此类为 SSLContext 类定义了服务提供者接口 (SPI)。
SSLEngine | 此类允许使用安全套接字层 (SSL) 或 IETF RFC 2246 "Transport Layer Security" (TLS) 协议进行安全通信，但它与传输无关。
SSLEngineResult | SSLEngine I/O 调用所生成的结果状态的封装。
SSLParameters | 封装 SSL/TLS 连接的参数。
SSLPermission | 此类用于各种网络权限。
SSLServerSocket | 此类扩展了 ServerSocket 并且提供使用像 Secure Sockets Layer (SSL) 或 Transport Layer Security (TLS) 协议的安全服务器套接字。
SSLServerSocketFactory | SSLServerSocketFactory 创建 SSLServerSocket。
SSLSessionBindingEvent | 此事件向 SSLSessionBindingListener 传播。
SSLSocket | 此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。
SSLSocketFactory | SSLSocketFactory 创建 SSLSocket。
TrustManagerFactory | 此类充当基于信任材料源的信任管理器的工厂。
TrustManagerFactorySpi | 此类为 TrustManagerFactory 类定义了服务提供者接口 (SPI)。
X509ExtendedKeyManager | 提供 X509KeyManager 接口的扩展的抽象类。

枚举摘要
SSLEngineResult.HandshakeStatus | 描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
SSLEngineResult.Status | 描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。

异常摘要
SSLException | 指示由 SSL 子系统检测到的某类错误。
SSLHandshakeException | 指示客户端和服务器不能就所需安全级别进行协商。
SSLKeyException | 报告错误的 SSL 密钥。
SSLPeerUnverifiedException | 指示还没有验证同位体的身份。
SSLProtocolException | 报告在 SSL 协议的操作中的错误。

软件包 javax.net.ssl 的描述

提供用于安全套接字包的类。借助于安全套接字类，可以使用 SSL 或相关的安全协议进行通信，以便可靠地检测网络字节流中的任何错误，并且可以选择对数据进行加密和/或对通信同位体进行验证。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.net.ssl 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.net.ssl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.net.ssl.CertPathTrustManagerParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.util.EventObject (implements java.io.Serializable)
      • javax.net.ssl.HandshakeCompletedEvent
      • javax.net.ssl.SSLSessionBindingEvent
    • javax.net.ssl.KeyManagerFactory
    • javax.net.ssl.KeyManagerFactorySpi
    • javax.net.ssl.KeyStoreBuilderParameters (implements javax.net.ssl.ManagerFactoryParameters)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.net.ssl.SSLPermission
    • java.net.ServerSocket
      • javax.net.ssl.SSLServerSocket
    • javax.net.ServerSocketFactory
      • javax.net.ssl.SSLServerSocketFactory
    • java.net.Socket
      • javax.net.ssl.SSLSocket
    • javax.net.SocketFactory
      • javax.net.ssl.SSLSocketFactory
    • javax.net.ssl.SSLContext
    • javax.net.ssl.SSLContextSpi
    • javax.net.ssl.SSLEngine
    • javax.net.ssl.SSLEngineResult
    • javax.net.ssl.SSLParameters
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.net.ssl.SSLException
            • javax.net.ssl.SSLHandshakeException
            • javax.net.ssl.SSLKeyException
            • javax.net.ssl.SSLPeerUnverifiedException
            • javax.net.ssl.SSLProtocolException
    • javax.net.ssl.TrustManagerFactory
    • javax.net.ssl.TrustManagerFactorySpi
    • java.net.URLConnection
      • java.net.HttpURLConnection
        • javax.net.ssl.HttpsURLConnection
    • javax.net.ssl.X509ExtendedKeyManager (implements javax.net.ssl.X509KeyManager)

接口分层结构

  • java.util.EventListener
    • javax.net.ssl.HandshakeCompletedListener
    • javax.net.ssl.SSLSessionBindingListener
  • javax.net.ssl.HostnameVerifier
  • javax.net.ssl.KeyManager
    • javax.net.ssl.X509KeyManager
  • javax.net.ssl.ManagerFactoryParameters
  • javax.net.ssl.SSLSession
  • javax.net.ssl.SSLSessionContext
  • javax.net.ssl.TrustManager
    • javax.net.ssl.X509TrustManager

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.net.ssl.SSLEngineResult.Status
      • javax.net.ssl.SSLEngineResult.HandshakeStatus
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.net.ssl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.net.ssl
的使用

使用 javax.net.ssl 的软件包
java.net | 为实现网络应用程序提供类。
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 使用的 javax.net.ssl 中的类
SSLPeerUnverifiedException
指示还没有验证同位体的身份。

javax.naming.ldap 使用的 javax.net.ssl 中的类
HostnameVerifier
此类是用于主机名验证的基接口。
SSLSession
在 SSL 中，会话用来描述两个实体间正在发生的关系。
SSLSocketFactory
SSLSocketFactory 创建 SSLSocket。

javax.net.ssl 使用的 javax.net.ssl 中的类
HandshakeCompletedEvent
此事件指示在给定的 SSL 连接上 SSL 握手结束。
HandshakeCompletedListener
任何希望接收有关给定 SSL 连接上 SSL 协议握手结束通知的类实现此接口。
HostnameVerifier
此类是用于主机名验证的基接口。
KeyManager
这是用于 JSSE 密钥管理器的基接口。
KeyManagerFactory
此类充当基于密钥内容源的密钥管理器的工厂。
KeyManagerFactorySpi
此类为 KeyManagerFactory 类定义了服务提供者接口 (SPI)。
ManagerFactoryParameters
此类是用来向 KeyManagerFactory 或 TrustManagerFactory 提供特定于算法的信息的基接口。
SSLContext
此类的实例表示安全套接字协议的实现，它充当用于安全套接字工厂或 SSLEngine 的工厂。
SSLContextSpi
此类为 SSLContext 类定义了服务提供者接口 (SPI)。
SSLEngine
此类允许使用安全套接字层 (SSL) 或 IETF RFC 2246 "Transport Layer Security" (TLS) 协议进行安全通信，但它与传输无关。
SSLEngineResult
SSLEngine I/O 调用所生成的结果状态的封装。
SSLEngineResult.HandshakeStatus
描述此 SSLEngine 的当前握手状态的 SSLEngineResult 枚举。
SSLEngineResult.Status
描述 SSLEngine 操作总体结果的 SSLEngineResult 枚举。
SSLException
指示由 SSL 子系统检测到的某类错误。
SSLParameters
封装 SSL/TLS 连接的参数。
SSLPeerUnverifiedException
指示还没有验证同位体的身份。
SSLServerSocketFactory
SSLServerSocketFactory 创建 SSLServerSocket。
SSLSession
在 SSL 中，会话用来描述两个实体间正在发生的关系。
SSLSessionBindingEvent
此事件向 SSLSessionBindingListener 传播。
SSLSessionContext
SSLSessionContext 表示与单个实体关联的 SSLSession。
SSLSocket
此类扩展 Socket 并提供使用诸如安全套接字层 (Secure Sockets Layer, SSL) 或 IETF 传输层安全性 (Transport Layer Security, TLS) 等协议的安全套接字。
SSLSocketFactory
SSLSocketFactory 创建 SSLSocket。
TrustManager
这是用于 JSSE 信任管理器的基接口。
TrustManagerFactory
此类充当基于信任材料源的信任管理器的工厂。
TrustManagerFactorySpi
此类为 TrustManagerFactory 类定义了服务提供者接口 (SPI)。
X509KeyManager
此接口的实例管理使用哪一个基于 X509 证书的密钥对来验证本地的安全套接字。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.CertPathTrustManagerParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.CertPathTrustManagerParameters
的使用

没有 javax.net.ssl.CertPathTrustManagerParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.ManagerFactoryParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.ManagerFactoryParameters
的使用

使用 ManagerFactoryParameters 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 ManagerFactoryParameters 的使用

实现 ManagerFactoryParameters 的 javax.net.ssl 中的类
class | CertPathTrustManagerParameters CertPathParameters 的包装器。
class | KeyStoreBuilderParameters 封装了 KeyStore.Builders 列表的 X509KeyManagers 参数对象。

参数类型为 ManagerFactoryParameters 的 javax.net.ssl 中的方法
protected abstract void | KeyManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用密钥内容源初始化此工厂。
protected abstract void | TrustManagerFactorySpi.engineInit(ManagerFactoryParameters spec) 使用特定于提供者的密钥材料源初始化此工厂。
void | KeyManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的密钥内容源初始化此工厂。
void | TrustManagerFactory.init(ManagerFactoryParameters spec) 使用特定于提供者的信任材料源初始化此工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.HandshakeCompletedEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.HandshakeCompletedEvent
的使用

使用 HandshakeCompletedEvent 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 HandshakeCompletedEvent 的使用

参数类型为 HandshakeCompletedEvent 的 javax.net.ssl 中的方法
 void HandshakeCompletedListener.handshakeCompleted(HandshakeCompletedEvent event)
当 SSL 握手结束时，在已注册的对象上调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.SSLSession 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.SSLSession
的使用

使用 SSLSession 的软件包
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。

javax.naming.ldap 中 SSLSession 的使用

返回 SSLSession 的 javax.naming.ldap 中的方法
abstract SSLSession | StartTlsResponse.negotiate() 使用默认的 SSL 套接字工厂协商 TLS 会话。
abstract SSLSession | StartTlsResponse.negotiate(SSLSocketFactory factory) 使用 SSL 套接字工厂协商 TLS 会话。

javax.net.ssl 中 SSLSession 的使用

返回 SSLSession 的 javax.net.ssl 中的方法
SSLSession | HandshakeCompletedEvent.getSession() 返回触发此事件的会话。
abstract SSLSession | SSLSocket.getSession() 返回此连接使用的 SSL 会话。
abstract SSLSession | SSLEngine.getSession() 返回此 SSLEngine 中使用的 SSLSession。
SSLSession | SSLSessionBindingEvent.getSession() 返回 SSLSession，将侦听器绑定其中或从其解除绑定。
SSLSession | SSLSessionContext.getSession(byte[] sessionId) 返回绑定到指定会话 id 的 SSLSession。

参数类型为 SSLSession 的 javax.net.ssl 中的方法
 boolean HostnameVerifier.verify(String hostname, SSLSession session)
验证主机名和服务器验证方案的匹配是可接受的。

参数类型为 SSLSession 的 javax.net.ssl 中的构造方法
HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
构造一个新的 HandshakeCompletedEvent。
SSLSessionBindingEvent(SSLSession session, String name)
构造一个新的 SSLSessionBindingEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLSocket
的使用

使用 SSLSocket 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLSocket 的使用

返回 SSLSocket 的 javax.net.ssl 中的方法
 SSLSocket HandshakeCompletedEvent.getSocket()
返回作为此事件源的套接字。

参数类型为 SSLSocket 的 javax.net.ssl 中的构造方法
HandshakeCompletedEvent(SSLSocket sock, SSLSession s)
构造一个新的 HandshakeCompletedEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLPeerUnverifiedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLPeerUnverifiedException
的使用

使用 SSLPeerUnverifiedException 的软件包
java.net | 为实现网络应用程序提供类。
javax.net.ssl | 提供用于安全套接字包的类。

java.net 中 SSLPeerUnverifiedException 的使用

抛出 SSLPeerUnverifiedException 的 java.net 中的方法
abstract Principal | SecureCacheResponse.getPeerPrincipal() 返回服务器的主体，该主体是作为在获得了网络资源的初始连接期间定义会话的一部分建立的。
abstract List<Certificate> | SecureCacheResponse.getServerCertificateChain() 从缓存返回服务器的证书链，该证书链是作为在获得了网络资源的初始连接中定义会话的一部分建立的。

javax.net.ssl 中 SSLPeerUnverifiedException 的使用

抛出 SSLPeerUnverifiedException 的 javax.net.ssl 中的方法
X509Certificate[] | HandshakeCompletedEvent.getPeerCertificateChain() 返回同位体的标识，同位体是作为定义会话的一部分而标识的。
X509Certificate[] | SSLSession.getPeerCertificateChain() 返回同级身份，该同级身份被标识作为定义会话的一部分。
Certificate[] | HandshakeCompletedEvent.getPeerCertificates() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Certificate[] | SSLSession.getPeerCertificates() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
Principal | HandshakeCompletedEvent.getPeerPrincipal() 返回同位体的标识，同位体是作为定义会话的一部分而建立的。
Principal | SSLSession.getPeerPrincipal() 返回同级身份，该同级身份是作为定义会话的一部分而建立的。
Principal | HttpsURLConnection.getPeerPrincipal() 返回服务器的主体，它是作为定义会话的一部分而建立的。
abstract Certificate[] | HttpsURLConnection.getServerCertificates() 返回服务器的证书链，它是作为定义会话的一部分而建立的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLException
的使用

使用 SSLException 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLException 的使用

javax.net.ssl 中 SSLException 的子类
class | SSLHandshakeException 指示客户端和服务器不能就所需安全级别进行协商。
class | SSLKeyException 报告错误的 SSL 密钥。
class | SSLPeerUnverifiedException 指示还没有验证同位体的身份。
class | SSLProtocolException 报告在 SSL 协议的操作中的错误。

抛出 SSLException 的 javax.net.ssl 中的方法
abstract void | SSLEngine.beginHandshake() 在此 SSLEngine 上发起握手（初始的或重新协商）。
abstract void | SSLEngine.closeInbound() 通知没有更多的入站网络数据将发送到此 SSLEngine。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer src, ByteBuffer dst) 试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.SSLSessionContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.SSLSessionContext
的使用

使用 SSLSessionContext 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLSessionContext 的使用

返回 SSLSessionContext 的 javax.net.ssl 中的方法
protected abstract SSLSessionContext | SSLContextSpi.engineGetClientSessionContext() 返回此上下文的客户端 SSLSessionContext 对象。
protected abstract SSLSessionContext | SSLContextSpi.engineGetServerSessionContext() 返回此上下文的服务器 SSLSessionContext 对象。
SSLSessionContext | SSLContext.getClientSessionContext() 返回客户端会话上下文，它表示可供客户端 SSL 套接字握手阶段所使用的 SSL 会话集。
SSLSessionContext | SSLContext.getServerSessionContext() 返回服务器会话上下文，它表示可供服务器端 SSL 套接字握手阶段所使用的 SSL 会话集。
SSLSessionContext | SSLSession.getSessionContext() 返回此会话所在的上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.HandshakeCompletedListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.HandshakeCompletedListener
的使用

使用 HandshakeCompletedListener 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 HandshakeCompletedListener 的使用

参数类型为 HandshakeCompletedListener 的 javax.net.ssl 中的方法
abstract void | SSLSocket.addHandshakeCompletedListener(HandshakeCompletedListener listener) 注册一个事件侦听器来接收此连接上的 SSL 握手已经完成的通知。
abstract void | SSLSocket.removeHandshakeCompletedListener(HandshakeCompletedListener listener) 移除一个以前注册的握手完成侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLParameters
的使用

使用 SSLParameters 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLParameters 的使用

返回 SSLParameters 的 javax.net.ssl 中的方法
protected SSLParameters | SSLContextSpi.engineGetDefaultSSLParameters() 返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
protected SSLParameters | SSLContextSpi.engineGetSupportedSSLParameters() 返回表示此 SSL 上下文最大受支持设置的 SSLParameters 的副本。
SSLParameters | SSLContext.getDefaultSSLParameters() 返回表示此 SSL 上下文默认设置的 SSLParameters 的副本。
SSLParameters | SSLSocket.getSSLParameters() 返回对此 SSLSocket 有效的 SSLParameters。
SSLParameters | SSLEngine.getSSLParameters() 返回对此 SSLEngine 有效的 SSLParameters。
SSLParameters | SSLContext.getSupportedSSLParameters() 返回表示此 SSL 上下文受支持设置的 SSLParameters 的副本。

参数类型为 SSLParameters 的 javax.net.ssl 中的方法
void | SSLSocket.setSSLParameters(SSLParameters params) 对此套接字应用 SSLParameters。
void | SSLEngine.setSSLParameters(SSLParameters params) 对此引擎应用 SSLParameters。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.HostnameVerifier 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.HostnameVerifier
的使用

使用 HostnameVerifier 的软件包
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。

javax.naming.ldap 中 HostnameVerifier 的使用

参数类型为 HostnameVerifier 的 javax.naming.ldap 中的方法
abstract  void StartTlsResponse.setHostnameVerifier(HostnameVerifier verifier)
设置在已完成 TLS 握手且默认主机名校验失败后供 negotiate() 使用的主机名校验器。

javax.net.ssl 中 HostnameVerifier 的使用

声明为 HostnameVerifier 的 javax.net.ssl 中的字段
protected  HostnameVerifier HttpsURLConnection.hostnameVerifier
此对象的 hostnameVerifier。

返回 HostnameVerifier 的 javax.net.ssl 中的方法
static HostnameVerifier | HttpsURLConnection.getDefaultHostnameVerifier() 获取此类的新实例所继承的默认 HostnameVerifier。
HostnameVerifier | HttpsURLConnection.getHostnameVerifier() 获取此实例适当的 HostnameVerifier。

参数类型为 HostnameVerifier 的 javax.net.ssl 中的方法
static void | HttpsURLConnection.setDefaultHostnameVerifier(HostnameVerifier v) 设置此类的新实例所继承的默认 HostnameVerifier。
void | HttpsURLConnection.setHostnameVerifier(HostnameVerifier v) 设置此实例的 HostnameVerifier。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.HttpsURLConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.HttpsURLConnection
的使用

没有 javax.net.ssl.HttpsURLConnection 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLSocketFactory
的使用

使用 SSLSocketFactory 的软件包
javax.naming.ldap | 提供对 LDAPv3 扩展操作和控件的支持。
javax.net.ssl | 提供用于安全套接字包的类。

javax.naming.ldap 中 SSLSocketFactory 的使用

参数类型为 SSLSocketFactory 的 javax.naming.ldap 中的方法
abstract  SSLSession StartTlsResponse.negotiate(SSLSocketFactory factory)
使用 SSL 套接字工厂协商 TLS 会话。

javax.net.ssl 中 SSLSocketFactory 的使用

返回 SSLSocketFactory 的 javax.net.ssl 中的方法
protected abstract SSLSocketFactory | SSLContextSpi.engineGetSocketFactory() 返回此上下文的 SocketFactory 对象。
static SSLSocketFactory | HttpsURLConnection.getDefaultSSLSocketFactory() 获取此类的新实例所继承的默认静态 SSLSocketFactory。
SSLSocketFactory | SSLContext.getSocketFactory() 返回此上下文的 SocketFactory 对象。
SSLSocketFactory | HttpsURLConnection.getSSLSocketFactory() 获取为安全 https URL 连接创建套接字时使用的 SSL 套接字工厂。

参数类型为 SSLSocketFactory 的 javax.net.ssl 中的方法
static void | HttpsURLConnection.setDefaultSSLSocketFactory(SSLSocketFactory sf) 设置此类的新实例所继承的默认 SSLSocketFactory。
void | HttpsURLConnection.setSSLSocketFactory(SSLSocketFactory sf) 设置当此实例为安全 https URL 连接创建套接字时使用的 SSLSocketFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.KeyManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.KeyManager
的使用

使用 KeyManager 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 KeyManager 的使用

javax.net.ssl 中 KeyManager 的子接口
 interface X509KeyManager
此接口的实例管理使用哪一个基于 X509 证书的密钥对来验证本地的安全套接字。

实现 KeyManager 的 javax.net.ssl 中的类
 class X509ExtendedKeyManager
提供 X509KeyManager 接口的扩展的抽象类。

返回 KeyManager 的 javax.net.ssl 中的方法
protected abstract KeyManager[] | KeyManagerFactorySpi.engineGetKeyManagers() 为每类密钥内容返回一个密钥管理器。
KeyManager[] | KeyManagerFactory.getKeyManagers() 为每类密钥内容返回一个密钥管理器。

参数类型为 KeyManager 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLContext
的使用

使用 SSLContext 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLContext 的使用

返回 SSLContext 的 javax.net.ssl 中的方法
static SSLContext | SSLContext.getDefault() 返回默认的 SSL 上下文。
static SSLContext | SSLContext.getInstance(String protocol) 返回实现指定安全套接字协议的 SSLContext 对象。
static SSLContext | SSLContext.getInstance(String protocol, Provider provider) 返回实现指定安全套接字协议的 SSLContext 对象。
static SSLContext | SSLContext.getInstance(String protocol, String provider) 返回实现指定安全套接字协议的 SSLContext 对象。

参数类型为 SSLContext 的 javax.net.ssl 中的方法
static void SSLContext.setDefault(SSLContext context)
设置默认的 SSL 上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.KeyManagerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.KeyManagerFactory
的使用

使用 KeyManagerFactory 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 KeyManagerFactory 的使用

返回 KeyManagerFactory 的 javax.net.ssl 中的方法
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, Provider provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。
static KeyManagerFactory | KeyManagerFactory.getInstance(String algorithm, String provider) 返回充当密钥管理器工厂的 KeyManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.KeyManagerFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.KeyManagerFactorySpi
的使用

使用 KeyManagerFactorySpi 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 KeyManagerFactorySpi 的使用

参数类型为 KeyManagerFactorySpi 的 javax.net.ssl 中的构造方法
KeyManagerFactory(KeyManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 KeyManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.KeyStoreBuilderParameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.KeyStoreBuilderParameters
的使用

没有 javax.net.ssl.KeyStoreBuilderParameters 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLContextSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLContextSpi
的使用

使用 SSLContextSpi 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLContextSpi 的使用

参数类型为 SSLContextSpi 的 javax.net.ssl 中的构造方法
SSLContext(SSLContextSpi contextSpi, Provider provider, String protocol)
创建 SSLContext 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.TrustManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.TrustManager
的使用

使用 TrustManager 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 TrustManager 的使用

javax.net.ssl 中 TrustManager 的子接口
 interface X509TrustManager
此接口的实例管理使用哪一个 X509 证书来验证远端的安全套接字。

返回 TrustManager 的 javax.net.ssl 中的方法
protected abstract TrustManager[] | TrustManagerFactorySpi.engineGetTrustManagers() 为每种信任材料返回一个信任管理器。
TrustManager[] | TrustManagerFactory.getTrustManagers() 为每种信任材料返回一个信任管理器。

参数类型为 TrustManager 的 javax.net.ssl 中的方法
protected abstract void | SSLContextSpi.engineInit(KeyManager[] km, TrustManager[] tm, SecureRandom sr) 初始化此上下文。
void | SSLContext.init(KeyManager[] km, TrustManager[] tm, SecureRandom random) 初始化此上下文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLServerSocketFactory
的使用

使用 SSLServerSocketFactory 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLServerSocketFactory 的使用

返回 SSLServerSocketFactory 的 javax.net.ssl 中的方法
protected abstract SSLServerSocketFactory | SSLContextSpi.engineGetServerSocketFactory() 返回此上下文的 ServerSocketFactory 对象。
SSLServerSocketFactory | SSLContext.getServerSocketFactory() 返回此上下文的 ServerSocketFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLEngine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngine
的使用

使用 SSLEngine 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngine 的使用

返回 SSLEngine 的 javax.net.ssl 中的方法
SSLEngine | SSLContext.createSSLEngine() 使用此上下文创建新的 SSLEngine。
SSLEngine | SSLContext.createSSLEngine(String peerHost, int peerPort) 使用此上下文创建新的 SSLEngine，该上下文使用劝告同位体信息。
protected abstract SSLEngine | SSLContextSpi.engineCreateSSLEngine() 使用此上下文创建新的 SSLEngine。
protected abstract SSLEngine | SSLContextSpi.engineCreateSSLEngine(String host, int port) 使用此上下文创建 SSLEngine。

参数类型为 SSLEngine 的 javax.net.ssl 中的方法
String | X509ExtendedKeyManager.chooseEngineClientAlias(String[] keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的客户端和由同位体（如果有)识别的证书发行者授权列表进行验证。
String | X509ExtendedKeyManager.chooseEngineServerAlias(String keyType, Principal[] issuers, SSLEngine engine) 选择别名，对给出公钥类型的 SSLEngine 连接的服务器和由同位体（如果有)识别的证书发行者授权列表进行验证。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLEngineResult 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngineResult
的使用

使用 SSLEngineResult 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngineResult 的使用

返回 SSLEngineResult 的 javax.net.ssl 中的方法
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer dst) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区中。
SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区序列中。
abstract SSLEngineResult | SSLEngine.unwrap(ByteBuffer src, ByteBuffer[] dsts, int offset, int length) 尝试把 SSL/TLS 网络数据解码到纯文本应用程序数据缓冲区子序列中。
SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, ByteBuffer dst) 尝试把数据缓冲区序列中的纯文本字节编码成 SSL/TLS 网络数据。
abstract SSLEngineResult | SSLEngine.wrap(ByteBuffer[] srcs, int offset, int length, ByteBuffer dst) 尝试把数据缓冲区字序列中的纯文本字节编码成 SSL/TLS 网络数据。
SSLEngineResult | SSLEngine.wrap(ByteBuffer src, ByteBuffer dst) 试图把缓冲区的纯文本应用程序数据编码成 SSL/TLS 网络数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLEngineResult.Status 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngineResult.Status
的使用

使用 SSLEngineResult.Status 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngineResult.Status 的使用

返回 SSLEngineResult.Status 的 javax.net.ssl 中的方法
SSLEngineResult.Status | SSLEngineResult.getStatus() 获得此 SSLEngine 操作的返回值。
static SSLEngineResult.Status | SSLEngineResult.Status.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SSLEngineResult.Status[] | SSLEngineResult.Status.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 SSLEngineResult.Status 的 javax.net.ssl 中的构造方法
SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLEngineResult.HandshakeStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLEngineResult.HandshakeStatus
的使用

使用 SSLEngineResult.HandshakeStatus 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLEngineResult.HandshakeStatus 的使用

返回 SSLEngineResult.HandshakeStatus 的 javax.net.ssl 中的方法
abstract SSLEngineResult.HandshakeStatus | SSLEngine.getHandshakeStatus() 返回此 SSLEngine 的当前握手状态。
SSLEngineResult.HandshakeStatus | SSLEngineResult.getHandshakeStatus() 获得此 SSLEngine 操作的握手状态。
static SSLEngineResult.HandshakeStatus | SSLEngineResult.HandshakeStatus.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SSLEngineResult.HandshakeStatus[] | SSLEngineResult.HandshakeStatus.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 SSLEngineResult.HandshakeStatus 的 javax.net.ssl 中的构造方法
SSLEngineResult(SSLEngineResult.Status status, SSLEngineResult.HandshakeStatus handshakeStatus, int bytesConsumed, int bytesProduced)
初始化此类的一个新实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLHandshakeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLHandshakeException
的使用

没有 javax.net.ssl.SSLHandshakeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLKeyException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLKeyException
的使用

没有 javax.net.ssl.SSLKeyException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLPermission
的使用

没有 javax.net.ssl.SSLPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLProtocolException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLProtocolException
的使用

没有 javax.net.ssl.SSLProtocolException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLServerSocket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLServerSocket
的使用

没有 javax.net.ssl.SSLServerSocket 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.SSLSessionBindingEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.SSLSessionBindingEvent
的使用

使用 SSLSessionBindingEvent 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 SSLSessionBindingEvent 的使用

参数类型为 SSLSessionBindingEvent 的 javax.net.ssl 中的方法
void | SSLSessionBindingListener.valueBound(SSLSessionBindingEvent event) 调用此方法通知侦听器要将其绑定到 SSLSession 中。
void | SSLSessionBindingListener.valueUnbound(SSLSessionBindingEvent event) 调用此方法通知侦听器要从 SSLSession 中解除其绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.SSLSessionBindingListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.SSLSessionBindingListener
的使用

没有 javax.net.ssl.SSLSessionBindingListener 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.TrustManagerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.TrustManagerFactory
的使用

使用 TrustManagerFactory 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 TrustManagerFactory 的使用

返回 TrustManagerFactory 的 javax.net.ssl 中的方法
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, Provider provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。
static TrustManagerFactory | TrustManagerFactory.getInstance(String algorithm, String provider) 返回充当信任管理器工厂的 TrustManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.TrustManagerFactorySpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.TrustManagerFactorySpi
的使用

使用 TrustManagerFactorySpi 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 TrustManagerFactorySpi 的使用

参数类型为 TrustManagerFactorySpi 的 javax.net.ssl 中的构造方法
TrustManagerFactory(TrustManagerFactorySpi factorySpi, Provider provider, String algorithm)
创建 TrustManagerFactory 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.X509KeyManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.X509KeyManager
的使用

使用 X509KeyManager 的软件包
javax.net.ssl 提供用于安全套接字包的类。

javax.net.ssl 中 X509KeyManager 的使用

实现 X509KeyManager 的 javax.net.ssl 中的类
 class X509ExtendedKeyManager
提供 X509KeyManager 接口的扩展的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.net.ssl.X509TrustManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.net.ssl.X509TrustManager
的使用

没有 javax.net.ssl.X509TrustManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ssl.X509ExtendedKeyManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ssl.X509ExtendedKeyManager
的使用

没有 javax.net.ssl.X509ExtendedKeyManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.ServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.ServerSocketFactory
的使用

使用 ServerSocketFactory 的软件包
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。

javax.net 中 ServerSocketFactory 的使用

返回 ServerSocketFactory 的 javax.net 中的方法
static ServerSocketFactory ServerSocketFactory.getDefault()
返回该环境默认套接字工厂的一个副本。

javax.net.ssl 中 ServerSocketFactory 的使用

javax.net.ssl 中 ServerSocketFactory 的子类
 class SSLServerSocketFactory
SSLServerSocketFactory 创建 SSLServerSocket。

返回 ServerSocketFactory 的 javax.net.ssl 中的方法
static ServerSocketFactory SSLServerSocketFactory.getDefault()
返回默认的 SSL 服务器套接字工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.net.SocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.net.SocketFactory
的使用

使用 SocketFactory 的软件包
javax.net | 提供用于网络应用程序的类。
javax.net.ssl | 提供用于安全套接字包的类。

javax.net 中 SocketFactory 的使用

返回 SocketFactory 的 javax.net 中的方法
static SocketFactory SocketFactory.getDefault()
返回该环境默认套接字工厂的一个副本。

javax.net.ssl 中 SocketFactory 的使用

javax.net.ssl 中 SocketFactory 的子类
 class SSLSocketFactory
SSLSocketFactory 创建 SSLSocket。

返回 SocketFactory 的 javax.net.ssl 中的方法
static SocketFactory SSLSocketFactory.getDefault()
返回默认的 SSL 套接字工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AttributeException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 AttributeException

public interface AttributeException

接口 AttributeException 是一个混合接口，PrintException 的子类可实现该接口以报告涉及一个或多个打印属性的错误条件，特定的 Print Service 实例不支持该条件。要么该属性根本不受支持，要么虽然该属性受支持，但是特定的指定值不受支持。Print Service API 未定义任何实现 AttributeException 接口的打印异常类，这由打印服务的实现程序来决定。

方法摘要
Class[] | getUnsupportedAttributes() 返回其 PrintService 实例根本不支持该属性的打印属性类数组，如果没有这种属性，则返回 null。
Attribute[] | getUnsupportedValues() 返回其 PrintService 实例支持该属性，但是不支持该属性特定值的打印属性数组，如果没有这种属性值，则返回 null。

方法详细信息

getUnsupportedAttributes

Class[] getUnsupportedAttributes()
返回其 PrintService 实例根本不支持该属性的打印属性类数组，如果没有这种属性，则返回 null。返回数组中的对象是扩展了基接口 Attribute 的类。

返回：
不受支持的属性类

getUnsupportedValues

Attribute[] getUnsupportedValues()
返回其 PrintService 实例支持该属性，但是不支持该属性特定值的打印属性数组，如果没有这种属性值，则返回 null。

返回：
不受支持的属性值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CancelablePrintJob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 CancelablePrintJob

所有超级接口：
DocPrintJob
public interface CancelablePrintJob
extends DocPrintJob

打印应用程序使用此接口来取消打印作业。此接口扩展了 DocPrintJob。如果打印作业是可取消的，则从 PrintService 所返回的 DocPrintJob 实现来实现此接口。尝试取消某个打印作业之前，客户端需要测试 PrintService 所返回的 DocPrintJob 对象是否实际上实现了此接口。客户端永远不应假定 DocPrintJob 实现了此接口。PrintService 可能仅支持取消某类打印数据和表示形式类名。这意味着只有 PrintService 返回的某些 DocPrintJob 对象才实现此接口。

如果使用此接口的实现成功地取消了某个作业，则鼓励服务实现程序实现此可选接口，并且向所有侦听器传递 javax.print.event.PrintJobEvent.JOB_CANCELLED 事件。服务还应注意，此方法的实现可能是通过单独的客户端线程完成的，而不是发出打印请求的线程完成的。因此，此接口的实现必须是线程安全的。

方法摘要
 void cancel()
停止对打印作业的进一步处理。
从接口 javax.print.DocPrintJob 继承的方法
addPrintJobAttributeListener, addPrintJobListener, getAttributes, getPrintService, print, removePrintJobAttributeListener, removePrintJobListener

方法详细信息

cancel

void cancel()
            throws PrintException
停止对打印作业的进一步处理。

即使某个服务支持此方法，也不能断定作业取消总是能够成功。一旦作业到达或经过其处理过程中的某个点，就无法再取消该作业了。成功的取消仅意味着未打印整个作业，但是在取消返回时可能已经打印完成部分作业。

如果取消不成功，则该服务抛出 PrintException。尚未提交进行打印的作业应该抛出此异常。对已经成功取消的打印作业再执行取消不视为错误，并且总是可以成功。

在某些服务中，取消可能是一个很长的过程，这涉及对服务器的请求和对其打印队列的处理。客户端可能希望在不影响应用程序执行的线程中执行取消。

抛出：
PrintException - 如果无法成功取消该作业。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Doc (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 Doc

所有已知实现类：
SimpleDoc
public interface Doc

接口 Doc 指定某个对象的接口，该接口为 PrintJob 提供部分打印数据。"Doc" 是一个简短、易于发音的术语，指“部分打印数据”。客户端向 PrintJob 传递一个实现接口 Doc 的对象，PrintJob 则在该对象上调用方法来获得打印数据。Doc 接口允许 PrintJob：

  • 确定所提供的打印数据的格式，或 "doc flavor"（类 DocFlavor）。doc flavor 指定了打印数据格式（MIME 类型）和提供打印数据的对象的表示形式类。

  • 获得打印数据表示形式对象，它是 doc flavor 表示形式类的实例。然后 PrintJob 可从该表示形式对象获得实际的打印数据。

  • 获得各种打印属性，这些属性指定该 doc 的其他特征，或者指定用于该 doc 的处理指令。打印属性在 javax.print.attribute 包中定义。doc 返回其存储在 javax.print.attribute.DocAttributeSet 中的打印属性。

每次调用接口 Doc 实现中的方法时，都允许该方法返回相同的对象。对于　PrintJob　或 doc 对象的其他调用者也是这样，其中，当调用者获得打印数据时，其打印数据表示形式对象“使用”该打印数据，例如作为流的打印数据表示形式对象。一旦 PrintJob 已经调用了 getPrintData() 并且获得了该流，则对 getPrintData() 的所有其他调用都返回相同的流对象（对它的读取可能已经进行），而不是 从头开始重新读取打印数据的新流对象。指定 doc 对象具有此行为可简化 doc 对象的实现，根据 doc 只向一个 PrintJob 传送打印数据，而不是向多个 PrintJob 传送打印数据可以证明。（要向多个不同的 PrintJob 传送相同的打印数据，必须在同一打印数据源上创建多个不同的 doc 对象。）

接口 Doc 提供了极佳的实现灵活性。构造 doc 对象时，打印数据可能已经存在。在这种情况下，可将 doc 的方法所返回的对象提供给该 doc 的构造方法、提前存储在该 doc 中，以及只是在调用时返回该对象。另外，构造 doc 对象时，打印数据可能不存在。在这种情况下，doc 对象可能延迟提供一个实现，该实现仅在 PrintJob 为它调用方法（当 PrintJob 调用 getPrintData() 方法）时才生成打印数据表示形式对象（和/或打印数据）。

对于并发访问同一个 doc 的客户端线程数目没有限制。因此，接口 Doc 的所有实现必须设计为多线程安全的。

但是对于从 Doc 所获得的打印数据而言，只能有一个使用者。

如果从客户端获得作为流的打印数据（通过调用 Doc 的 getReaderForText() 或 getStreamForBytes() 方法），或者因为打印数据源已经是一个 InputStream 或 Reader，则 PrintService 在所有作业完成的情况下，始终应该关闭客户端的这些流。注意以下警告。如果打印数据本身是一个流，则 PrintService 总是关闭它。如果打印数据是可以以流形式请求的其他内容，则 PrintService 仅在其终止前已获得流的情况下才关闭该流。也就是说，仅仅因为 PrintService 可能请求流形式的数据并不意味着（也不暗含着），这些依赖 PrintService 来关闭它们的 Doc 实现程序应该只为响应服务的请求才创建这种流。

方法摘要
DocAttributeSet | getAttributes() 获取此 doc 对象的打印属性集。
DocFlavor | getDocFlavor() 确定此 doc 对象提供其部分打印数据所用的 DocFlavor。
Object | getPrintData() 获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。
Reader | getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
InputStream | getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。

方法详细信息

getDocFlavor

DocFlavor getDocFlavor()
确定此 doc 对象提供其部分打印数据所用的 DocFlavor。

返回：
Doc flavor。

getPrintData

Object getPrintData()
                    throws IOException
获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。getPrintData() 方法返回一个表示形式类的实例，其名称由 getDocFlavor()、getRepresentationClassName() 给定，可将返回值从类 Object 强制转换为该表示形式类。

返回：
打印数据表示形式对象。
抛出：
IOException - 如果表示形式类是一个流且在构造该流时存在 I/O 错误。

getAttributes

DocAttributeSet getAttributes()
获取此 doc 对象的打印属性集。如果返回的属性集包括特定属性 X 的实例，则打印机必须为此 doc 使用该属性值，该值覆盖作业属性集中属性 X 的所有值。如果返回的属性集不包括特定属性 X 的实例，或者返回 null，则打印机必须参考该作业的属性集来获得属性 X 的值，如果在该集合中未找到该属性值，则打印机必须使用一个与实现相关的默认值。返回的属性集是不可修改的。

返回：
此 doc 不可修改的打印属性集，或者为 null，以从该作业的属性集中获得所有属性值。

getReaderForText

Reader getReaderForText()
                        throws IOException
获得一个从此 doc 中提取字符打印数据的 reader。如果 DocFlavor 具有以下打印数据表示形式类之一，则需要 Doc 实现支持此方法，否则返回 null：
  • char[]
  • java.lang.String
  • java.io.Reader
为了从打印数据表示形式对象中以字符流的形式读取打印数据，使用 doc 的打印数据表示形式对象来构造并返回一个 Reader。但是，如果打印数据表示形式对象本身就是一个 Reader，则只是返回该打印数据表示形式对象。

返回：
从此 doc 中读取打印数据字符的 Reader。如果因为此 doc 不符合上述标准而无法提供 reader，则返回 null。
抛出：
IOException - 如果创建 reader 时存在 I/O 错误。

getStreamForBytes

InputStream getStreamForBytes()
                              throws IOException
获得一个从此 doc 中提取 byte 打印数据的输入流。如果 DocFlavor 具有以下打印数据表示形式类之一，则需要 Doc 实现支持此方法，否则返回 null：
  • byte[]
  • java.io.InputStream
获得此 doc 的打印数据表示形式对象，然后为了从打印数据表示形式对象中以 byte 流的形式读取打印数据，需要创建并返回一个输入流。但是，如果打印数据表示形式对象本身就是一个输入流，则只是返回该打印数据表示形式对象。

返回：
从此 doc 中读取打印数据 byte 的输入流。如果因为此 doc 不符合上述标准而无法提供输入流，则返回 null。
抛出：
IOException - 如果创建输入流时存在 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor

java.lang.Object
    继承者  javax.print.DocFlavor
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
public class DocFlavor
extends Object
implements Serializable, Cloneable

类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。"Doc" 是一个简短、易于发音的术语，指“部分打印数据”。打印数据格式，即 "doc flavor" 由两方面的内容组成：

  • MIME 类型。 这是一个多用途的 Internet 邮件扩展 (MIME) 媒体类型（在 RFC 2045 和 RFC 2046 中定义），指定了如何解释打印数据。文本数据的字符集应该是 IANA MIME 优先名称，如果未指定优先名称，则使用其规范名称。另外也可识别较早 Java 平台版本所支持的一些历史名称。有关 Java 平台所支持的字符编码的更多信息，请参阅字符编码。

  • 表示形式类名。 这指定了提供实际打印数据的对象的完全限定类名，由 Class.getName() 方法返回。（因此 byte[] 的类名是 "[B"，char[] 的类名是 "[C"。）

DocPrintJob 通过接口 Doc 获得其打印数据。Doc 对象允许 DocPrintJob 来确定客户端可以提供的 doc flavor。Doc 对象还允许 DocPrintJob 获得一个 doc flavor 的表示形式类的实例，然后 DocPrintJob 可从中获得实际的打印数据。

客户端格式化打印数据

有两大类的打印数据：客户端格式的打印数据和服务格式的打印数据。

对于客户端格式的打印数据，客户端确定或知道该打印数据格式。例如，客户端可能有 JPEG 编码的图像、HTML 代码的 URL 或以某种编码形式包含纯文本的磁盘文件（可能从外部源获得），并且需要某种方式向打印服务描述数据格式。

doc flavor 的表示形式类是 JPS DocPrintJob 的一个管道，可从客户端获得字符或 byte 序列。doc flavor 的 MIME 类型是标准的媒体类型之一，通知如何解释字符或 byte 序列。有关标准媒体类型的列表，请参阅 Internet 编号分配机构 (IANA) 的媒介类型目录。接口 Doc 提供两个实用操作：getReaderForText 和 getStreamForBytes()，用来帮助 Doc 对象的客户端提取客户端格式的打印数据。

对于客户端格式化打印数据，打印数据表示形式类通常是以下之一（虽然也允许使用其他表示形式类）：

  • 字符数组 (char[]) -- 打印数据由数组中的 Unicde 字符所组成。

  • String -- 打印数据由 string 中的 Unicde 字符组成。

  • 字符流 (java.io.Reader) -- 打印数据由从流中读取（一直读取到流的末尾）的 Unicode 字符组成。

  • Byte 数组 (byte[]) -- 打印数据由数组中的 byte 所组成。这些 byte 在 doc flavor 的 MIME 类型所指定的字符集中编码。如果 MIME 类型未指定某个字符集，则默认的字符集是 US-ASCII。

  • Byte 流 (java.io.InputStream) -- 打印数据由从流中读取（一直读取到流的末尾）的 byte 所组成。这些 byte 在 doc flavor 的 MIME 类型所指定的字符集中编码。如果 MIME 类型未指定某个字符集，则默认的字符集是 US-ASCII。
  • 统一资源定位符 (URL) -- 打印数据由从 URL 位置读取的 byte 所组成。这些 byte 在 doc flavor 的 MIME 类型所指定的字符集中编码。如果 MIME 类型未指定某个字符集，则默认的字符集是 US-ASCII。

    当表示形式类是一个 URL 时，打印服务本身直接访问其 URL 地址并下载文档，与客户端无关。该服务可以是在不同环境中执行的某种网络打印服务形式。这意味着不应使用 URL 打印数据 flavor 来打印位于受限制 URL 处的文档，在这种 URL 处，客户端可以看到该文档但打印机无法看到。这还意味着不应使用 URL 打印数据 flavor 来打印存储在本地文件中的文档，在客户端可独立访问的 URL 处无法提供这种文档。例如，一个并非由 HTTP 服务器或 FTP 服务器所提供的文件。要打印这种文档，应该让客户端在该 URL 或文件上打开一个输入流并使用输入流数据 flavor。

默认编码和平台编码

对于其 doc flavor 的 MIME 类型未包括 charset 参数的 byte 打印数据而言，Java 打印服务实例假定默认的字符集是 US-ASCII。这与 RFC 2046 保持一致，它声明默认的字符集是 US-ASCII。注意，US-ASCII 是一个 UTF-8 子集，所以如果未来 RFC 以兼容的方式将 UTF-8 作为默认值，则可能会扩大该字符集。

还要注意，当以文本数据的形式解释 byte 流时，这与 Java 运行时的行为有所不同。这假定了用于用户语言环境的默认编码。因此，当以本地编码形式使用 Java 打印服务后台打印某个文件时，正确指定编码很重要。在英语语言环境中工作的开发人员应该特别注意这一点，因为其平台编码对应于默认的 mime 字符集。在这种纯属巧合的特定情况下，不指定平台数据的编码也可工作。

每个 Java 虚拟机实例都具有在虚拟机启动期间所确定的默认字符编码，并且该默认编码通常取决于底层操作系统使用的语言环境和字符集。在分布式环境中，不保证两个 VM 共享同一默认编码。因此，希望以流的形式将平台编码文本数据从主机平台发送到 Java 打印服务实例的客户端，必须显式地声明字符集，而不能依赖于默认值。

首选的形式是正式的 IANA 编码主名称。以流形式发送文本数据的应用程序应该始终在 mime 类型中指定字符集，这就需要为数据（如文件，以该平台的编码形式存储）获得主机平台的编码形式。可从 DocFlavor.hostEncoding 获得与此对应且适合以 DocFlavor 的 mime 类型所使用的 CharSet。这可能不会总是主 IANA 名称，但是可保证是此 VM 所理解的 CharSet。对于公共的 flavor，可以使用预定义的 *HOST DocFlavor。

有关 Java 平台所支持的字符编码的更多信息，请参阅字符编码。

推荐的 DocFlavor

Java Print Service API 未定义任何强制支持的 DocFlavor。但是，对于客户端格式化打印数据，以下是 Java Print Service 实例可以支持的 MIME 类型的示例。类 DocFlavor 内的嵌套类为这些示例 doc flavor 声明了预定义的静态常量 DocFlavor 对象；可使用类 DocFlavor 的构造方法来创建任意的 doc flavor。

  • 预格式化的文本

    MIME 类型 | 描述
    "text/plain" | 默认字符集 (US-ASCII) 中的纯文本
    "text/plain; charset=xxx" | 字符集 xxx 中的纯文本
    "text/html" | 默认字符集形式 (US-ASCII) 的超文本标记语言
    "text/html; charset=xxx" | 字符集 xxx 形式的超文本标记语言

    一般情况下，预先格式化的文本打印数据要么由表示形式类以字符方式提供（字符数组、String、Reader），要么由表示形式类以 byte 方式提供（byte 数组、InputStream、URL）。

  • 预格式化的页面描述语言 (PDL) 文档

    MIME 类型 | 描述
    "application/pdf" | 便携文档格式文档
    "application/postscript" | PostScript 文档
    "application/vnd.hp-PCL" | 打印机控制语言文档

    一般情况下，预格式化的 PDL 打印数据在面向 byte 的表示形式类（byte 数组、InputStream、URL）中提供。

  • 预格式化的图像

    MIME 类型 | 描述
    "image/gif" | 图形交换格式图像
    "image/jpeg" | 联合图像专家组图像
    "image/png" | 便携网络图形图像

    一般情况下，预格式化的图像打印数据在面向 byte 的表示形式类（byte 数组、InputStream、URL）中提供。

  • 预格式化的自动检测打印数据

    MIME 类型 | 描述
    "application/octet-stream" | 打印数据格式是未指定的（就是一个八位组流）

    打印机决定如何解释该打印数据；这种“自动检测”的工作方式与实现相关。一般情况下，预格式化的自动检测打印数据在面向 byte 的表示形式类（byte 数组、InputStream、URL）中提供。

    服务格式化打印数据

    对于服务格式化打印数据，Java Print Service 实例确定打印数据格式。doc flavor 的表示形式类表示一个接口（例如 RenderableImage 接口或 Java printable 接口），DocPrintJob 调用该接口的方法来确定要打印的内容。doc flavor 的 MIME 类型是特殊值 "application/x-java-jvm-local-objectref" 时，指示客户端将提供对 Java 对象的引用，该对象实现了以表示形式类命名的接口。此 MIME 类型只是一个占位符；重要的是打印数据表示形式类。

    对于服务格式化打印数据，打印数据表示形式类通常是以下之一（虽然也允许使用其他表示形式类）：类 DocFlavor 内的嵌套类为这些示例 doc flavor 声明了预定义的静态常量 DocFlavor 对象；可使用类 DocFlavor 的构造方法来创建任意的 doc flavor。

    • RenderableImage 对象 -- 客户端提供一个实现了接口 RenderableImage 的对象。打印机调用该接口内的方法来获得要打印的图像。

    • Printable 对象 -- 客户端提供一个实现了接口 Printable 的对象。打印机调用该接口内的方法来依次获得要打印的页面。对于每个页面，打印机都提供一个图形上下文，而客户端在该图形上下文中绘制的所有内容都会被打印。

    • Pageable 对象 -- 客户端提供一个实现了接口 Pageable 的对象。打印机调用该接口内的方法来依次获得要打印的页面。对于每个页面，打印机都提供一个图形上下文，而客户端在该图形上下文中绘制的所有内容都会被打印。

    预定义的 Doc Flavor

    无需 Java 打印服务支持以下打印数据格式和打印数据表示形式类。实际上，使用此类的开发人员不应该假定特定的打印服务支持与这些预定义的 doc flavor 相对应的文档类型。应该始终查询打印服务来确定该服务支持的 doc flavor。但是鼓励那些具有支持这些 doc flavor 的打印服务的开发人员引用此处预定义的一个实例。
    • 通过 byte 流提供纯文本打印数据。需要特别说明的是，建议支持以下 doc flavor：
      · ("text/plain", "java.io.InputStream")
      · ("text/plain; charset=us-ascii", "java.io.InputStream")
      · ("text/plain; charset=utf-8", "java.io.InputStream")

    • RenderableImage 对象。需要特别说明的是，建议支持以下 doc flavor：
      · ("application/x-java-jvm-local-objectref", "java.awt.image.renderable.RenderableImage")

    根据实现的选择，除了上述强制要求的以外，还允许 Java Print Service 实例支持任意其他 doc flavor（或一个都不支持）。

    支持上述 doc flavor 是很值得的，这样进行打印的客户端可以依赖于是否能够在任意 JPS 打印机上进行打印，而不管该打印机支持哪些 doc flavor。如果打印机不支持客户端的首选 doc flavor，则客户端至少可以打印纯文本，或者客户端可以将其数据转换为 Renderable 图像并打印该图像。

    另外，为了处理纯文本打印数据，每个 Java Print Service 实例必须满足这些要求：

    • 字符对回车-换行 (CR-LF) 意味着“转到下一行的第 1 列”。
    • 单个回车 (CR) 字符本身意味着“转到下一行的第 1 列”。
    • 单个换行 (LF) 字符本身意味着“转到下一行的列第 1 列”。

    客户端本身必须执行不满足上述要求的所有纯文本打印数据的格式化工作。

    设计基本原理

    javax.print.data 包中的类 DocFlavor 与类 DataFlavor 相似。在 Java 打印服务 (JPS) API 中不使用类 DataFlavor 的原因有三个，这些原因的根源都在于允许其他打印服务 API 共享 JPS API，而这些打印服务 API 可能需要在 Java 配置文件上运行，但不包括 Java 平台、Standard Edition 的配置文件。

    1. JPS API 设计用于不支持 AWT 的 Java 配置文件中。

    2. 类 java.awt.datatransfer.DataFlavor 的实现不保证等效的 DataFlavor 具有相同的序列化表示形式。DocFlavor 确实并且可以用于需要此内容的服务中。

    3. 类 java.awt.datatransfer.DataFlavor 的实现包括可读的名称，该名称作为序列化表示形式的一部分。该名称作为服务匹配约束的一部分是不合适的。

    类 DocFlavor 的序列化表示形式使用以下 MIME 类型字符串的规范形式。因此，MIME 类型不同但等效（具有相同的规范形式）的两个 doc flavor 可认为是相等的。

    • 保留媒体类型、媒体子类型和参数，但是丢弃所有注释和空白字符。
    • 媒体类型、媒体子类型和参数名都转换为小写。
    • 参数值保留其原始状况，但将文本媒体类型的 charset 参数值转换为小写。
    • 移除参数值两侧的引号字符。
    • 移除参数值内的引用反斜线字符。
    • 按参数名的升序顺序排列各个参数。

    类 DocFlavor 的序列化表示形式还包含表示形式类的完全限定类名，而不是表示形式类本身（一个 Class 对象）。这就允许客户端在不必加载表示形式类的情况下，就可以检查 Java Print Service 实例支持的 doc flavor，否则这对于资源有限的客户端来说是个问题。

    另请参见：
    序列化表格

    嵌套类摘要
    static class DocFlavor.BYTE_ARRAY
    类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
    static class DocFlavor.CHAR_ARRAY
    类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
    static class DocFlavor.INPUT_STREAM
    类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
    static class DocFlavor.READER
    类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
    static class DocFlavor.SERVICE_FORMATTED
    类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
    static class DocFlavor.STRING
    类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
    static class DocFlavor.URL
    类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。
    字段摘要
    static String hostEncoding
    表示主机操作系统编码的 String。
    构造方法摘要
    DocFlavor(String mimeType, String className)
    根据给定的 MIME 类型和表示形式类名构造新的 DocFlavor 对象。
    方法摘要
     boolean equals(Object obj)
    确定此 DocFlavor 对象是否等于给定的对象。
     String getMediaSubtype()
    返回此 DocFlavor 对象的媒体子类型（根据 MIME 类型）。
     String getMediaType()
    返回此 DocFlavor 对象的媒体类型（根据 MIME 类型）。
     String getMimeType()
    根据 MIME 类型的规范形式返回此 DocFlavor 对象的 MIME 类型字符串。
     String getParameter(String paramName)
    返回表示 MIME 参数的 String。
     String getRepresentationClassName()
    返回此 DocFlavor 对象的表示形式类名。
     int hashCode()
    返回此 DocFlavor 对象的哈希码。
     String toString()
    将此 DocFlavor 转换为字符串。
    从类 java.lang.Object 继承的方法
    clone, finalize, getClass, notify, notifyAll, wait, wait, wait

    字段详细信息

    hostEncoding

    public static final String hostEncoding
    表示主机操作系统编码的 String。该 String 遵循 RFC 2278: IANA Charset Registration Procedures 中所记录的约定，但为了与以前的 Java 平台版本保持兼容，要返回历史名称的情况除外。此方法返回的值仅对返回它的 VM 有效，仅用于 DocFlavor 中。这是正在执行的 VM 中所有 "HOST" 预定义 DocFlavor 的 charset。

    构造方法详细信息

    DocFlavor

    public DocFlavor(String mimeType,
                 String className)
    根据给定的 MIME 类型和表示形式类名构造新的 DocFlavor 对象。给定的 MIME 类型被转换为规范形式并进行内部存储。

    参数：
    mimeType - MIME 媒体类型字符串。
    className - 完全限定表示形式类名。
    抛出：
    NullPointerException - （未经检查的异常）如果 mimeType 为 null 或 className 为 null。
    IllegalArgumentException - （未经检查的异常）如果 mimeType 未遵守 MIME 媒体类型字符串的语法约定。
    方法详细信息

    getMimeType

    public String getMimeType()
    根据 MIME 类型的规范形式返回此 DocFlavor 对象的 MIME 类型字符串。每个参数值都在单引号内。

    返回：
    MIME 类型

    getMediaType

    public String getMediaType()
    返回此 DocFlavor 对象的媒体类型（根据 MIME 类型）。

    返回：
    媒体类型

    getMediaSubtype

    public String getMediaSubtype()
    返回此 DocFlavor 对象的媒体子类型（根据 MIME 类型）。

    返回：
    媒体子类型

    getParameter

    public String getParameter(String paramName)
    返回表示 MIME 参数的 String。Mime 类型可能包括通常是可选的参数。文本类型的 charset 通常是一个有用的示例。如果在 MIME 类型中为此 flavor 指定了某个参数，则此便捷方法返回该指定参数的值。

    参数：
    paramName - 参数名。执行匹配操作前，此名称被内部转换为规范的小写格式。
    返回：
    MIME 参数的 String 表示形式，如果该 MIME 类型字符串中没有该参数，则返回 null。
    抛出：
    NullPointerException - 如果 paramName 为 null。

    getRepresentationClassName

    public String getRepresentationClassName()
    返回此 DocFlavor 对象的表示形式类名。

    返回：
    表示形式类名。

    toString

    public String toString()
    将此 DocFlavor 转换为字符串。

    覆盖：
    类 Object 中的 toString
    返回：
    规范形式的 MIME 类型字符串。每个参数值都在单引号内。将 "class=" 参数添加到 MIME 类型字符串中，以指示表示形式类名。

    hashCode

    public int hashCode()
    返回此 DocFlavor 对象的哈希码。

    覆盖：
    类 Object 中的 hashCode
    返回：
    此对象的一个哈希码值。
    另请参见：
    Object.equals(java.lang.Object), Hashtable

    equals

    public boolean equals(Object obj)
    确定此 DocFlavor 对象是否等于给定的对象。如果给定的对象不为 null、是一个 DocFlavor 实例、具有和此 DocFlavor 对象的 MIME 类型等效的 MIME 类型（也就是说，两个 MIME 类型具有相同的媒体类型、媒体子类型和参数），并且具有和此 DocFlavor 对象相同的表示形式类名，则两个对象是相等的。因此，如果两个 DocFlavor 对象的 MIME 类型除注释外都相同，则认为这两个对象是相等的。但是，分别具有 "text/plain" 和 "text/plain; charset=US-ASCII" MIME 类型的两个 DocFlavor 对象被认为是不相等的，即使它们表示相同的媒体类型也是如此（因为纯文本的默认字符集是 US-ASCII）。

    覆盖：
    类 Object 中的 equals
    参数：
    obj - 要测试的 Object。
    返回：
    如果此 DocFlavor 对象等于 obj，则返回 true；否则返回 false。
    另请参见：
    Object.hashCode(), Hashtable
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor.BYTE_ARRAY (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor.BYTE_ARRAY

java.lang.Object
    继承者  javax.print.DocFlavor
        继承者  javax.print.DocFlavor.BYTE_ARRAY
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
DocFlavor
public static class DocFlavor.BYTE_ARRAY
extends DocFlavor

类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。

另请参见：
序列化表格

嵌套类摘要
从类 javax.print.DocFlavor 继承的嵌套类/接口
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
字段摘要
static DocFlavor.BYTE_ARRAY | AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
从类 javax.print.DocFlavor 继承的字段
hostEncoding
构造方法摘要
DocFlavor.BYTE_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[B"（byte 数组）的新 DocFlavor。
方法摘要
从类 javax.print.DocFlavor 继承的方法
equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TEXT_PLAIN_HOST

public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_HOST
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。请参阅 hostEncoding。打印数据表示形式类名 = "[B"（byte 数组）。

TEXT_PLAIN_UTF_8

public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_8
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_PLAIN_UTF_16

public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_PLAIN_UTF_16BE

public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16BE
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_PLAIN_UTF_16LE

public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_UTF_16LE
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_PLAIN_US_ASCII

public static final DocFlavor.BYTE_ARRAY TEXT_PLAIN_US_ASCII
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_HTML_HOST

public static final DocFlavor.BYTE_ARRAY TEXT_HTML_HOST
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。请参阅 hostEncoding。打印数据表示形式类名 = "[B"（byte 数组）。

TEXT_HTML_UTF_8

public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_8
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_HTML_UTF_16

public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_HTML_UTF_16BE

public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16BE
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_HTML_UTF_16LE

public static final DocFlavor.BYTE_ARRAY TEXT_HTML_UTF_16LE
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

TEXT_HTML_US_ASCII

public static final DocFlavor.BYTE_ARRAY TEXT_HTML_US_ASCII
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

PDF

public static final DocFlavor.BYTE_ARRAY PDF
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

POSTSCRIPT

public static final DocFlavor.BYTE_ARRAY POSTSCRIPT
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

PCL

public static final DocFlavor.BYTE_ARRAY PCL
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

GIF

public static final DocFlavor.BYTE_ARRAY GIF
MIME 类型 = "image/gif"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

JPEG

public static final DocFlavor.BYTE_ARRAY JPEG
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

PNG

public static final DocFlavor.BYTE_ARRAY PNG
MIME 类型 = "image/png"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

AUTOSENSE

public static final DocFlavor.BYTE_ARRAY AUTOSENSE
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。客户端必须确定使用此 DocFlavor 所描述的数据对于打印机是否有效。

构造方法详细信息

DocFlavor.BYTE_ARRAY

public DocFlavor.BYTE_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[B"（byte 数组）的新 DocFlavor。

参数：
mimeType - MIME 媒体类型字符串。
抛出：
NullPointerException - （未经检查的异常）如果 mimeType 为 null，则抛出该异常。
IllegalArgumentException - （未经检查的异常）如果 mimeType 未遵守 MIME 媒体类型字符串的语法约定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor.CHAR_ARRAY (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor.CHAR_ARRAY

java.lang.Object
    继承者  javax.print.DocFlavor
        继承者  javax.print.DocFlavor.CHAR_ARRAY
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
DocFlavor
public static class DocFlavor.CHAR_ARRAY
extends DocFlavor

类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。同样，字符集是 Unicode。

另请参见：
序列化表格

嵌套类摘要
从类 javax.print.DocFlavor 继承的嵌套类/接口
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
字段摘要
static DocFlavor.CHAR_ARRAY | TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
static DocFlavor.CHAR_ARRAY | TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
从类 javax.print.DocFlavor 继承的字段
hostEncoding
构造方法摘要
DocFlavor.CHAR_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[C"（字符数组）的新 DocFlavor。
方法摘要
从类 javax.print.DocFlavor 继承的方法
equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TEXT_PLAIN

public static final DocFlavor.CHAR_ARRAY TEXT_PLAIN
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。

TEXT_HTML

public static final DocFlavor.CHAR_ARRAY TEXT_HTML
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。

构造方法详细信息

DocFlavor.CHAR_ARRAY

public DocFlavor.CHAR_ARRAY(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "[C"（字符数组）的新 DocFlavor。

参数：
mimeType - MIME 媒体类型字符串。如果它是文本媒体类型，则假定它包含 "charset=utf-16" 参数。
抛出：
NullPointerException - （未经检查的异常）如果 mimeType 为 null。
IllegalArgumentException - （未经检查的异常）如果 mimeType 未遵守 MIME 媒体类型字符串的语法约定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor.INPUT_STREAM (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor.INPUT_STREAM

java.lang.Object
    继承者  javax.print.DocFlavor
        继承者  javax.print.DocFlavor.INPUT_STREAM
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
DocFlavor
public static class DocFlavor.INPUT_STREAM
extends DocFlavor

类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。

另请参见：
序列化表格

嵌套类摘要
从类 javax.print.DocFlavor 继承的嵌套类/接口
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
字段摘要
static DocFlavor.INPUT_STREAM | AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
从类 javax.print.DocFlavor 继承的字段
hostEncoding
构造方法摘要
DocFlavor.INPUT_STREAM(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.InputStream"（byte 流）的新 DocFlavor。
方法摘要
从类 javax.print.DocFlavor 继承的方法
equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TEXT_PLAIN_HOST

public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_HOST
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。请参阅 hostEncoding。打印数据表示形式类名 = "java.io.InputStream"（byte 流）。

TEXT_PLAIN_UTF_8

public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_8
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_PLAIN_UTF_16

public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_PLAIN_UTF_16BE

public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16BE
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_PLAIN_UTF_16LE

public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_UTF_16LE
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_PLAIN_US_ASCII

public static final DocFlavor.INPUT_STREAM TEXT_PLAIN_US_ASCII
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_HTML_HOST

public static final DocFlavor.INPUT_STREAM TEXT_HTML_HOST
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。请参阅 hostEncoding。打印数据表示形式类名 = "java.io.InputStream"（byte 流）。

TEXT_HTML_UTF_8

public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_8
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_HTML_UTF_16

public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_HTML_UTF_16BE

public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16BE
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_HTML_UTF_16LE

public static final DocFlavor.INPUT_STREAM TEXT_HTML_UTF_16LE
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

TEXT_HTML_US_ASCII

public static final DocFlavor.INPUT_STREAM TEXT_HTML_US_ASCII
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

PDF

public static final DocFlavor.INPUT_STREAM PDF
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

POSTSCRIPT

public static final DocFlavor.INPUT_STREAM POSTSCRIPT
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

PCL

public static final DocFlavor.INPUT_STREAM PCL
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

GIF

public static final DocFlavor.INPUT_STREAM GIF
MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

JPEG

public static final DocFlavor.INPUT_STREAM JPEG
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

PNG

public static final DocFlavor.INPUT_STREAM PNG
MIME 类型 = "image/png"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

AUTOSENSE

public static final DocFlavor.INPUT_STREAM AUTOSENSE
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。客户端必须确定使用此 DocFlavor 所描述的数据对于打印机是否有效。

构造方法详细信息

DocFlavor.INPUT_STREAM

public DocFlavor.INPUT_STREAM(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.InputStream"（byte 流）的新 DocFlavor。

参数：
mimeType - MIME 媒体类型字符串。
抛出：
NullPointerException - （未经检查的异常）如果 mimeType 为 null。
IllegalArgumentException - （未经检查的异常）如果 mimeType 未遵守 MIME 媒体类型字符串的语法约定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor.READER (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor.READER

java.lang.Object
    继承者  javax.print.DocFlavor
        继承者  javax.print.DocFlavor.READER
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
DocFlavor
public static class DocFlavor.READER
extends DocFlavor

类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。同样，字符集是 Unicode。

另请参见：
序列化表格

嵌套类摘要
从类 javax.print.DocFlavor 继承的嵌套类/接口
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
字段摘要
static DocFlavor.READER | TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
static DocFlavor.READER | TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
从类 javax.print.DocFlavor 继承的字段
hostEncoding
构造方法摘要
DocFlavor.READER(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.Reader"（字符流）的新 DocFlavor。
方法摘要
从类 javax.print.DocFlavor 继承的方法
equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TEXT_PLAIN

public static final DocFlavor.READER TEXT_PLAIN
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。

TEXT_HTML

public static final DocFlavor.READER TEXT_HTML
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。

构造方法详细信息

DocFlavor.READER

public DocFlavor.READER(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.io.Reader"（字符流）的新 DocFlavor。

参数：
mimeType - MIME 媒体类型字符串。如果它是文本媒体类型，则假定它包含 "charset=utf-16" 参数。
抛出：
NullPointerException - （未经检查的异常）如果 mimeType 为 null。
IllegalArgumentException - （未经检查的异常）如果 mimeType 未遵守 MIME 媒体类型字符串的语法约定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor.SERVICE_FORMATTED (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor.SERVICE_FORMATTED

java.lang.Object
    继承者  javax.print.DocFlavor
        继承者  javax.print.DocFlavor.SERVICE_FORMATTED
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
DocFlavor
public static class DocFlavor.SERVICE_FORMATTED
extends DocFlavor

类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。

另请参见：
序列化表格

嵌套类摘要
从类 javax.print.DocFlavor 继承的嵌套类/接口
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
字段摘要
static DocFlavor.SERVICE_FORMATTED | PAGEABLE 打印数据表示形式类名 = "java.awt.print.Pageable"（pageable 对象）的服务格式化打印数据 DocFlavor。
static DocFlavor.SERVICE_FORMATTED | PRINTABLE 打印数据表示形式类名 = "java.awt.print.Printable"（printable 对象）的服务格式化打印数据 DocFlavor。
static DocFlavor.SERVICE_FORMATTED | RENDERABLE_IMAGE 打印数据表示形式类名 = "java.awt.image.renderable.RenderableImage"（RenderableImage 对象）的服务格式化打印数据 DocFlavor。
从类 javax.print.DocFlavor 继承的字段
hostEncoding
构造方法摘要
DocFlavor.SERVICE_FORMATTED(String className)
构造具有 "application/x-java-jvm-local-objectref" MIME 类型（指示服务格式化打印数据）和给定打印数据表示形式类名的新 DocFlavor。
方法摘要
从类 javax.print.DocFlavor 继承的方法
equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

RENDERABLE_IMAGE

public static final DocFlavor.SERVICE_FORMATTED RENDERABLE_IMAGE
打印数据表示形式类名 = "java.awt.image.renderable.RenderableImage"（RenderableImage 对象）的服务格式化打印数据 DocFlavor。

PRINTABLE

public static final DocFlavor.SERVICE_FORMATTED PRINTABLE
打印数据表示形式类名 = "java.awt.print.Printable"（printable 对象）的服务格式化打印数据 DocFlavor。

PAGEABLE

public static final DocFlavor.SERVICE_FORMATTED PAGEABLE
打印数据表示形式类名 = "java.awt.print.Pageable"（pageable 对象）的服务格式化打印数据 DocFlavor。

构造方法详细信息

DocFlavor.SERVICE_FORMATTED

public DocFlavor.SERVICE_FORMATTED(String className)
构造具有 "application/x-java-jvm-local-objectref" MIME 类型（指示服务格式化打印数据）和给定打印数据表示形式类名的新 DocFlavor。

参数：
className - 完全限定表示形式类名。
抛出：
NullPointerException - （未经检查的异常）如果 className 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor.STRING (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor.STRING

java.lang.Object
    继承者  javax.print.DocFlavor
        继承者  javax.print.DocFlavor.STRING
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
DocFlavor
public static class DocFlavor.STRING
extends DocFlavor

类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。同样，字符集是 Unicode。

另请参见：
序列化表格

嵌套类摘要
从类 javax.print.DocFlavor 继承的嵌套类/接口
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
字段摘要
static DocFlavor.STRING | TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
static DocFlavor.STRING | TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
从类 javax.print.DocFlavor 继承的字段
hostEncoding
构造方法摘要
DocFlavor.STRING(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.lang.String" 的新 DocFlavor。
方法摘要
从类 javax.print.DocFlavor 继承的方法
equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TEXT_PLAIN

public static final DocFlavor.STRING TEXT_PLAIN
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。

TEXT_HTML

public static final DocFlavor.STRING TEXT_HTML
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。

构造方法详细信息

DocFlavor.STRING

public DocFlavor.STRING(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.lang.String" 的新 DocFlavor。

参数：
mimeType - MIME 媒体类型字符串。如果它是文本媒体类型，则假定它包含 "charset=utf-16" 参数。
抛出：
NullPointerException - （未经检查的异常）如果 mimeType 为 null。
IllegalArgumentException - （未经检查的异常）如果 mimeType 未遵守 MIME 媒体类型字符串的语法约定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocFlavor.URL (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 DocFlavor.URL

java.lang.Object
    继承者  javax.print.DocFlavor
        继承者  javax.print.DocFlavor.URL
所有已实现的接口：
Serializable, Cloneable
正在封闭类：
DocFlavor
public static class DocFlavor.URL
extends DocFlavor

类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。例如使用统一资源定位符 (java.net.URL) 作为打印数据表示形式类的 DocFlavor。

另请参见：
序列化表格

嵌套类摘要
从类 javax.print.DocFlavor 继承的嵌套类/接口
DocFlavor.BYTE_ARRAY, DocFlavor.CHAR_ARRAY, DocFlavor.INPUT_STREAM, DocFlavor.READER, DocFlavor.SERVICE_FORMATTED, DocFlavor.STRING, DocFlavor.URL
字段摘要
static DocFlavor.URL | AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.URL | TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.URL | TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = java.net.URL""（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
从类 javax.print.DocFlavor 继承的字段
hostEncoding
构造方法摘要
DocFlavor.URL(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.net.URL" 的新 DocFlavor。
方法摘要
从类 javax.print.DocFlavor 继承的方法
equals, getMediaSubtype, getMediaType, getMimeType, getParameter, getRepresentationClassName, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TEXT_PLAIN_HOST

public static final DocFlavor.URL TEXT_PLAIN_HOST
MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。请参阅 hostEncoding。打印数据表示形式类名 = "java.net.URL"（byte 流）。

TEXT_PLAIN_UTF_8

public static final DocFlavor.URL TEXT_PLAIN_UTF_8
MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_PLAIN_UTF_16

public static final DocFlavor.URL TEXT_PLAIN_UTF_16
MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = java.net.URL""（byte 流）的 DocFlavor。

TEXT_PLAIN_UTF_16BE

public static final DocFlavor.URL TEXT_PLAIN_UTF_16BE
MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_PLAIN_UTF_16LE

public static final DocFlavor.URL TEXT_PLAIN_UTF_16LE
MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_PLAIN_US_ASCII

public static final DocFlavor.URL TEXT_PLAIN_US_ASCII
MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_HTML_HOST

public static final DocFlavor.URL TEXT_HTML_HOST
MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。请参阅 hostEncoding。打印数据表示形式类名 = "java.net.URL"（byte 流）。

TEXT_HTML_UTF_8

public static final DocFlavor.URL TEXT_HTML_UTF_8
MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_HTML_UTF_16

public static final DocFlavor.URL TEXT_HTML_UTF_16
MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_HTML_UTF_16BE

public static final DocFlavor.URL TEXT_HTML_UTF_16BE
MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_HTML_UTF_16LE

public static final DocFlavor.URL TEXT_HTML_UTF_16LE
MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

TEXT_HTML_US_ASCII

public static final DocFlavor.URL TEXT_HTML_US_ASCII
MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

PDF

public static final DocFlavor.URL PDF
MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。

POSTSCRIPT

public static final DocFlavor.URL POSTSCRIPT
MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。

PCL

public static final DocFlavor.URL PCL
MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。

GIF

public static final DocFlavor.URL GIF
MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。

JPEG

public static final DocFlavor.URL JPEG
MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。

PNG

public static final DocFlavor.URL PNG
MIME 类型 = "image/png"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。

AUTOSENSE

public static final DocFlavor.URL AUTOSENSE
MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。客户端必须确定使用此 DocFlavor 所描述的数据对于打印机是否有效。

构造方法详细信息

DocFlavor.URL

public DocFlavor.URL(String mimeType)
构造具有给定 MIME 类型和打印数据表示形式类名 "java.net.URL" 的新 DocFlavor。

参数：
mimeType - MIME 媒体类型字符串。
抛出：
NullPointerException - （未经检查的异常）如果 mimeType 为 null。
IllegalArgumentException - （未经检查的异常）如果 mimeType 未遵守 MIME 媒体类型字符串的语法约定。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocPrintJob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 DocPrintJob

所有已知子接口：
CancelablePrintJob, MultiDocPrintJob
public interface DocPrintJob

此接口表示了一个可使用作业属性集打印指定文档的打印作业。可从 PrintService 获得一个实现了此接口的对象。

方法摘要
void | addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes) 为指定属性中的更改注册一个侦听器。
void | addPrintJobListener(PrintJobListener listener) 为此 PrintJob 执行期间所出现的事件注册一个侦听器。
PrintJobAttributeSet | getAttributes() 获取此 PrintJob 的打印属性集。
PrintService | getPrintService() 确定此 PrintJob 对象所绑定到的 PrintService 对象。
void | print(Doc doc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印文档。
void | removePrintJobAttributeListener(PrintJobAttributeListener listener) 移除此 PrintJob 的属性侦听器。
void | removePrintJobListener(PrintJobListener listener) 移除此 PrintJob 的侦听器。

方法详细信息

getPrintService

PrintService getPrintService()
确定此 PrintJob 对象所绑定到的 PrintService 对象。

返回：
PrintService 对象。

getAttributes

PrintJobAttributeSet getAttributes()
获取此 PrintJob 的打印属性集。返回的属性集对象是不可修改的。返回的属性集对象是调用 getAttributes() 方法时此 PrintJob 的属性集的一个“快照”；也就是说，如果以后此 PrintJob 属性集的内容更改了，则不更新返回的属性集对象的内容。要检测属性值的更改，可再次调用 getAttributes() 并将新的属性集与以前的属性集进行比较；或者可为 PrintJob 事件注册一个侦听器。返回值可以是一个空集合，但不应为 null。

返回：
PrintJob 属性

addPrintJobListener

void addPrintJobListener(PrintJobListener listener)
为此 PrintJob 执行期间所出现的事件注册一个侦听器。如果 listener 为 null，则不会抛出异常，并且不执行任何操作。如果已注册了侦听器，则会再次注册它。

参数：
listener - 实现侦听器接口的对象
另请参见：
removePrintJobListener(javax.print.event.PrintJobListener)

removePrintJobListener

void removePrintJobListener(PrintJobListener listener)
移除此 PrintJob 的侦听器。如果参数所指定的侦听器尚未添加到此组件，则此方法不起作用，也不抛出异常。如果 listener 为 null，则不会抛出异常，并且不执行任何操作。如果多次注册了某个侦听器，则只移除其中一个注册记录。

参数：
listener - 实现侦听器接口的对象
另请参见：
addPrintJobListener(javax.print.event.PrintJobListener)

addPrintJobAttributeListener

void addPrintJobAttributeListener(PrintJobAttributeListener listener,
                                  PrintJobAttributeSet attributes)
为指定属性中的更改注册一个侦听器。如果 listener 为 null，则不会抛出异常，并且不执行任何操作。要确定此作业可能报告的属性更新，客户端可以调用 getAttributes() 并标识所关注的和可能报告给侦听器的子集。预期更新有关指定作业属性更改的客户端应该验证该属性是否在该属性集中，但是只有确实更改了属性并且作业检测到该更改时才会进行更新。另外更新还可能受到作业批处理的影响。为了最大限度地降低 PrintJob 处理中的开销，建议仅对可能更改的属性子集进行侦听。如果指定的属性集是空集合，则不向侦听器报告任何属性更新。如果属性集为 null，这就意味着要侦听该作业支持的所有动态属性。如果某个作业无法报告任意属性更新，那么这就可能导致没有更新通知。 如果已注册了侦听器，则会再次注册它。

参数：
listener - 实现侦听器接口的对象
attributes - 要侦听的属性，如果为 null 则表示由作业确定的所有可能更改的属性。
另请参见：
removePrintJobAttributeListener(javax.print.event.PrintJobAttributeListener)

removePrintJobAttributeListener

void removePrintJobAttributeListener(PrintJobAttributeListener listener)
移除此 PrintJob 的属性侦听器。如果参数所指定的侦听器尚未添加到此组件，则此方法不起作用，也不抛出异常。如果 listener 为 null，则不会抛出异常，并且不执行任何操作。如果多次注册了某个侦听器，即使是为不同的属性集注册，也不保证会移除哪个侦听器。

参数：
listener - 实现侦听器接口的对象
另请参见：
addPrintJobAttributeListener(javax.print.event.PrintJobAttributeListener, javax.print.attribute.PrintJobAttributeSet)

print

void print(Doc doc,
           PrintRequestAttributeSet attributes)
           throws PrintException
使用指定的作业属性打印文档。对于给定的 PrintJob，只应该调用此方法一次。再次调用该方法不会导致将新的作业后台打印到打印机。服务实现将定义用于服务中断和恢复的策略。当 print 方法返回时，打印工作可能尚未完成，因为可在不同的线程中异步进行打印工作。希望监视打印成功与否的应用程序客户端应该注册 PrintJobListener。

PrintService 实现应该关闭它们从客户端 doc 所获取的所有打印数据流（即 Reader 或 InputStream 实现）。可靠的客户端可能还希望对此进行验证。如果无法打印 DocFlavor，则始终会生成异常。

参数：
doc - 要打印的文档。如果必须是一个 flavor，则此 PrintJob 必须支持它。
attributes - 应用到此 PrintJob 的作业属性。如果此参数为 null，则使用默认属性。
抛出：
PrintException - 该异常可能会额外实现一个接口，该接口更精确地描述了下列异常的原因
  • FlavorException。如果该文档具有此 PrintJob 不支持的 flavor。
  • AttributeException。如果应用到此 PrintJob 的一个或多个属性无效。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FlavorException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 FlavorException

public interface FlavorException

接口 FlavorException 是一个混合接口，PrintException 的子类可实现它来报告有关某个 DocFlavor 或多个 DocFlavor（类 DocFlavor）的错误状况。Print Service API 未定义任何实现了接口 FlavorException 的打印异常类，这由打印服务的实现程序来决定。

方法摘要
 DocFlavor[] getUnsupportedFlavors()
返回不受支持的 flavor。

方法详细信息

getUnsupportedFlavors

DocFlavor[] getUnsupportedFlavors()
返回不受支持的 flavor。

返回：
不受支持的 DocFlavor。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiDoc (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 MultiDoc

public interface MultiDoc

接口 MultiDoc 指定某个对象的接口，该对象为 PrintJob 提供多部分打印数据。"Doc" 是一个简短、易于发音的术语，指“部分打印数据”，而 "multidoc" 指一组多个 doc。客户端向 PrintJob 传递一个实现了接口 MultiDoc 的对象，PrintJob 则在该对象上调用方法来获得打印数据。

接口 MultiDoc 提供了类似于多个 doc“链接列表”的抽象概念。一个 multidoc 对象就像该链接列表中的一个节点，包含列表中的当前 doc 和一个指向列表中下一个节点 (multidoc) 的指针。PrintJob 可以调用 multidoc 的 getDoc() 方法来获得当前的 doc。当转至下一个 doc 时，PrintJob 可以调用 multidoc 的 next() 方法来获得下一个 multidoc，它包含下一个 doc。所以访问 multidoc 的 PrintJob 代码可能如下所示：

      void processMultiDoc(MultiDoc theMultiDoc) {

          MultiDoc current = theMultiDoc;

          while (current != null) {
              processDoc (current.getDoc());
              current = current.next();
          }
      }

当然，可以满足协定的任意方式来实现接口 MultiDoc；不必在实现中使用链接列表。

要获得 multidoc PrintJob 的所有打印数据，PrintService 代理可以使用以下两种模式：

  1. interleaved 模式：从当前 multidoc 中获得 doc。从当前 doc 中获得打印数据表示形式对象。从打印数据表示形式对象中获得所有打印数据。根据当前的 multidoc 获得下一个 multidoc，重复执行该过程，直到不再有 multidoc 为止。（上述代码示例使用了交错模式。）

  2. all-at-once 模式：从当前 multidoc 中获得 doc，并将 doc 保存在列表中。根据当前的 multidoc 获得下一个 multidoc，并重复执行该过程，直到没有 multidoc 为止。然后在已保存的 doc 列表上进行迭代。从当前 doc 中获得打印数据表示形式对象。从打印数据表示形式对象中获得所有打印数据。转到列表中的下一个 doc，并重复执行该过程，直到不再有 doc 为止。
现在，考虑一个随时生成打印数据，并且不具有一次存储多份打印数据的资源的打印客户端。如果 PrintService 代理使用 all-at-once 模式来获得打印数据，则会为这种客户端造成难题；在 PrintService 代理回来处理并请求打印数据之前，该客户端必须保存所有 doc 的打印数据，而该客户端是无法这样做的。要让这种客户端正常打印，PrintService 代理必须使用 interleaved 模式。

为了解决此问题并简化客户端向 PrintJob 提供多个 doc 的设计，必需让所有支持 multidoc PrintJob 的 PrintService 代理使用 interleaved 模式来访问 MultiDoc 对象。也就是说，如果给定了 MultiDoc 对象，则 PrintService 代理将调用 getDoc() 一次或多次，直到它成功获得当前 Doc 对象为止。然后 PrintService 代理将获得当前 doc 的打印数据，在获得所有打印数据或出现不可恢复的错误之前，不会执行其他操作。如果能够继续执行其他操作，那么在 PrintService 代理成功获得下一个 MultiDoc 对象或说明没有 MultiDoc 的指示之前，PrintService 代理将接着调用 next() 一次或多次。接口 MultiDoc 的实现可以假定 PrintService 代理将使用此 interleaved 模式；对于任意其他模式的使用，未指定 MultiDoc 实现的行为。

对于同时访问同一 multidoc 的客户端线程的数目没有限制。因此，必须将接口 MultiDoc 的所有实现设计为多线程安全的。实际上，在 PrintJob 线程从 doc 列表（概念上的列表）的开始获取 doc 的同时，客户端线程可以向该列表的末尾添加 doc；只要 multidoc 对象可正确地对这些线程实现同步，这两个线程将互不干扰。

方法摘要
Doc | getDoc() 获取当前的 doc 对象。
MultiDoc | next() 转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。

方法详细信息

getDoc

Doc getDoc()
           throws IOException
获取当前的 doc 对象。

返回：
当前的 doc 对象。
抛出：
IOException - 如果读取文档时出现错误。

next

MultiDoc next()
              throws IOException
转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。

返回：
包含下一个 doc 对象的 Multidoc 对象，如果没有任何其他 doc 对象，则返回 null。
抛出：
IOException - 如果查找下一个文档时出现错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiDocPrintJob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 MultiDocPrintJob

所有超级接口：
DocPrintJob
public interface MultiDocPrintJob
extends DocPrintJob

从 MultiDocPrintService 中获得，MultiDocPrintJob 可使用作业属性集以单个 PrintJob 的形式打印指定的文档集合。

方法摘要
 void print(MultiDoc multiDoc, PrintRequestAttributeSet attributes)
使用指定的作业属性打印 MultiDoc。
从接口 javax.print.DocPrintJob 继承的方法
addPrintJobAttributeListener, addPrintJobListener, getAttributes, getPrintService, print, removePrintJobAttributeListener, removePrintJobListener

方法详细信息

print

void print(MultiDoc multiDoc,
           PrintRequestAttributeSet attributes)
           throws PrintException
使用指定的作业属性打印 MultiDoc。对于给定的 PrintJob，只应该调用此方法一次。再次调用该方法不会导致将新的作业后台打印到打印机。服务实现将定义用于服务中断和恢复的策略。希望监视打印成功与否的应用程序客户端应该注册 PrintJobListener。

参数：
multiDoc - 要打印的文档。必须都是该 PrintJob 和 PrintService 所支持的 flavor。
attributes - 应用到此 PrintJob 的作业属性。如果此参数为 null，则使用默认属性。
抛出：
PrintException - 该异常可能会额外实现一个接口，该接口更精确地描述了下列异常的原因
  • FlavorException。如果该文档具有此 PrintJob 不支持的 flavor。
  • AttributeException。如果此 PrintJob 的一个或多个属性无效。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultiDocPrintService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 MultiDocPrintService

所有超级接口：
PrintService
public interface MultiDocPrintService
extends PrintService

接口 MultiPrintService 是 MultiDocPrintJob 的工厂。MultiPrintService 描述了打印机的功能，并可查询它来了解打印机支持的属性。

方法摘要
 MultiDocPrintJob createMultiDocPrintJob()
创建一个可打印 multiDoc 的作业。
从接口 javax.print.PrintService 继承的方法
addPrintServiceAttributeListener, createPrintJob, equals, getAttribute, getAttributes, getDefaultAttributeValue, getName, getServiceUIFactory, getSupportedAttributeCategories, getSupportedAttributeValues, getSupportedDocFlavors, getUnsupportedAttributes, hashCode, isAttributeCategorySupported, isAttributeValueSupported, isDocFlavorSupported, removePrintServiceAttributeListener

方法详细信息

createMultiDocPrintJob

MultiDocPrintJob createMultiDocPrintJob()
创建一个可打印 multiDoc 的作业。

返回：
一个 MultiDocPrintJob
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 PrintException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.print.PrintException
所有已实现的接口：
Serializable
public class PrintException
extends Exception

类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。此基类仅提供对该错误的字符串描述。如果适用，子类可提供更详细的信息。

另请参见：
序列化表格

构造方法摘要
PrintException()
构造不带详细消息的 print 异常。
PrintException(Exception e)
构造链接了所提供异常的 print 异常。
PrintException(String s)
构造带给定详细消息的 print 异常。
PrintException(String s, Exception e)
构造带给定详细消息和链异常的 print 异常。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrintException

public PrintException()
构造不带详细消息的 print 异常。

PrintException

public PrintException(String s)
构造带给定详细消息的 print 异常。

参数：
s - 详细消息，如果没有详细消息，则为 null。

PrintException

public PrintException(Exception e)
构造链接了所提供异常的 print 异常。

参数：
e - 链异常。

PrintException

public PrintException(String s,
                      Exception e)
构造带给定详细消息和链异常的 print 异常。

参数：
s - 详细消息，如果没有详细消息，则为 null。
e - 链异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 PrintService

所有已知子接口：
MultiDocPrintService
所有已知实现类：
StreamPrintService
public interface PrintService

接口 PrintService 是 DocPrintJob 的工厂。PrintService 描述了打印机的功能，并可查询它来了解打印机支持的属性。

示例：

   DocFlavor flavor = DocFlavor.INPUT_STREAM.POSTSCRIPT;
   PrintRequestAttributeSet aset = new HashPrintRequestAttributeSet();
   aset.add(MediaSizeName.ISO_A4);
   PrintService[] pservices =
                 PrintServiceLookup.lookupPrintServices(flavor, aset);
   if (pservices.length > 0) {
       DocPrintJob pj = pservices[0].createPrintJob();
       try {
           FileInputStream fis = new FileInputStream("test.ps");
           Doc doc = new SimpleDoc(fis, flavor, null);
           pj.print(doc, aset);
        } catch (FileNotFoundException fe) {
        } catch (PrintException e) {
        }
   }

方法摘要
 void addPrintServiceAttributeListener(PrintServiceAttributeListener listener)
为此 PrintService 上的事件注册一个侦听器。
 DocPrintJob createPrintJob()
创建并返回一个 PrintJob，它应能够处理取自任意受支持的 docflavor 的数据。
 boolean equals(Object obj)
确定两个服务是否引用相同的底层服务。
<T extends PrintServiceAttribute>
T
getAttribute(Class<T> category)
获取单个指定服务属性的值。
 PrintServiceAttributeSet getAttributes()
获得此 PrintService 的打印机描述属性集，这些属性给出了此 PrintService 的状态。
 Object getDefaultAttributeValue(Class<? extends Attribute> category)
确定给定类别中此 PrintService 的默认打印属性值。
 String getName()
返回此 PrintService 的 String 名称，应用程序可以使用该名称来请求特定的 PrintService。
 ServiceUIFactory getServiceUIFactory()
返回 UI 组件的工厂方法，该组件允许用户通过各种角色与服务交互。
 Class<?>[] getSupportedAttributeCategories()
确定客户端在设置此 PrintService 的作业时，可以指定的打印属性类别。
 Object getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
 DocFlavor[] getSupportedDocFlavors()
确定在设置此 PrintService 的作业时，客户端可以指定的打印数据格式。
 AttributeSet getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes)
标识在特定 DocFlavor 的上下文中打印请求不支持的属性。
 int hashCode()
此方法的实现方式应该与 equals(Object) 具有一致性。
 boolean isAttributeCategorySupported(Class<? extends Attribute> category)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。
 boolean isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。
 boolean isDocFlavorSupported(DocFlavor flavor)
确定此 PrintService 是否支持具体 DocFlavor。
 void removePrintServiceAttributeListener(PrintServiceAttributeListener listener)
移除此 PrintService 的 PrintService 侦听器。

方法详细信息

getName

String getName()
返回此 PrintService 的 String 名称，应用程序可以使用该名称来请求特定的 PrintService。在适合的上下文（如名称服务）中，此名称必须是唯一的。在某些环境中，此唯一的名称可能与在 PrinterName 属性中定义的、用户友好的打印机名相同。

返回：
服务名。

createPrintJob

DocPrintJob createPrintJob()
创建并返回一个 PrintJob，它应能够处理取自任意受支持的 docflavor 的数据。

返回：
DocPrintJob 对象

addPrintServiceAttributeListener

void addPrintServiceAttributeListener(PrintServiceAttributeListener listener)
为此 PrintService 上的事件注册一个侦听器。

参数：
listener - PrintServiceAttributeListener，它监视 PrintService 的状态
另请参见：
removePrintServiceAttributeListener(javax.print.event.PrintServiceAttributeListener)

removePrintServiceAttributeListener

void removePrintServiceAttributeListener(PrintServiceAttributeListener listener)
移除此 PrintService 的 PrintService 侦听器。这意味着该侦听器不再侦听 PrintService 事件。

参数：
listener - PrintServiceAttributeListener 对象
另请参见：
addPrintServiceAttributeListener(javax.print.event.PrintServiceAttributeListener)

getAttributes

PrintServiceAttributeSet getAttributes()
获得此 PrintService 的打印机描述属性集，这些属性给出了此 PrintService 的状态。返回的属性集对象是不可修改的。返回的属性集对象是调用 getAttributes() 方法时此 PrintService 的属性集的一个“快照”：也就是说，如果以后此 PrintService 属性集的内容更改了，则不 更新返回的属性集的内容。要检测属性值的更改，可再次调用 getAttributes() 并将新的属性集与以前的属性集进行比较；或者可为 PrintService 事件注册一个侦听器。

返回：
此 PrintService 属性集不可修改的快照。可以为空，但不能为 null。

getAttribute

<T extends PrintServiceAttribute> T getAttribute(Class<T> category)
获取单个指定服务属性的值。这对于只需要一个属性值并且希望最大限度降低开销的客户端而言是很有用的。

参数：
category - 此服务所支持的 PrintServiceAttribute 类别 - 不可以为 null。
返回：
所支持的属性的值，如果此服务不支持该属性，则返回 null。
抛出：
NullPointerException - 如果 category 为 null。
IllegalArgumentException - （未经检查的异常）如果 category 并非实现了接口 PrintServiceAttribute 的 Class。

getSupportedDocFlavors

DocFlavor[] getSupportedDocFlavors()
确定在设置此 PrintService 的作业时，客户端可以指定的打印数据格式。打印数据格式由 "doc flavor"（类 DocFlavor）所指定，该 "doc flavor" 则由 MIME 类型和打印数据表示形式类所组成。

注意，在组合使用所有属性时，可能不支持某些 doc flavor。使用 getUnsupportedAttributes(..) 来验证具体属性组合是否支持 doc flavor。

返回：
受支持的 doc flavor 的数组，至少应该有一个元素。

isDocFlavorSupported

boolean isDocFlavorSupported(DocFlavor flavor)
确定此 PrintService 是否支持具体 DocFlavor。这是确定该 DocFlavor 是否为所得 getSupportedDocFlavors() 成员的便捷方法。

注意，在组合使用所有属性时，可能不支持某些 doc flavor。使用 getUnsupportedAttributes(..) 来验证指定的属性组合是否支持 doc flavor。

参数：
flavor - 查询是否支持 DocFlavor。
返回：
如果此 PrintService 支持指定的 DocFlavor，则返回 true；否则返回 false
抛出：
NullPointerException - （未经检查的异常）如果 flavor 为 null，则抛出该异常。

getSupportedAttributeCategories

Class<?>[] getSupportedAttributeCategories()
确定客户端在设置此 PrintService 的作业时，可以指定的打印属性类别。打印属性类别由实现了接口 Attribute 的 Class 所指定。此方法只返回受支持的属性类别；并不返回受支持的特定属性值。

此方法为任何可能的作业返回此 PrintService 支持的所有打印属性类别。在特定的上下文（即特定的 DocFlavor）中可能不支持某些类别。提交请求前使用包括了 DocFlavor 的某个方法来验证该请求，如 getSupportedAttributeValues(..)。

返回：
打印属性类别的数组，客户端可在打印请求中以 doc 级或作业级属性来指定这些类别。该数组中的每个元素都是一个实现了接口 Attribute 的 Class。如果没有支持的类别，则该数组为空。

isAttributeCategorySupported

boolean isAttributeCategorySupported(Class<? extends Attribute> category)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。打印属性类别由实现了接口 Attribute 的 Class 所指定。此方法通知是否支持该属性类别；它不通知是否支持特定的属性值。

在特定的上下文（即特定的 DocFlavor）中可能不支持某些类别。提交请求前使用包括了 DocFlavor 的某个方法来验证该请求，如 getSupportedAttributeValues(..)。

这是确定该类别是否为所得 getSupportedAttributeCategories() 成员的便捷方法。

参数：
category - 要测试的打印属性类别。它必须是实现了接口 Attribute 的 Class。
返回：
如果此 PrintService 支持在打印请求的 category 中指定 doc 级或作业级的属性，则返回 true；否则返回 false。
抛出：
NullPointerException - （未经检查的异常）如果 category 为 null，则抛出该异常。
IllegalArgumentException - （未经检查的异常）如果 category 并非实现了接口 Attribute 的 Class。

getDefaultAttributeValue

Object getDefaultAttributeValue(Class<? extends Attribute> category)
确定给定类别中此 PrintService 的默认打印属性值。打印属性值是实现了接口 Attribute 的类的实例。如果客户端设置了打印作业但未指定给定类别中的任何属性值，则此 PrintService 将使用默认属性值。

在特定的上下文（即特定的 DocFlavor）中可能不支持某些属性。提交请求前使用包括了 DocFlavor 的某个方法来验证该请求，如 getSupportedAttributeValues(..)。

并非所有的属性都具有默认值。例如，服务没有 RequestingUser 的默认值，即对于不受支持的类别返回 null 意味着没有该类别的服务默认值。使用 isAttributeCategorySupported(Class) 方法来区分这些情况。

参数：
category - 打印属性类别，其默认属性值被请求。它必须是实现了接口 Attribute 的 Class。
返回：
category 的默认属性值，如果此 PrintService 不支持在打印请求的 category 中指定 doc 级或作业级的属性，或者服务没有此属性的默认值，则返回 null。
抛出：
NullPointerException - （未经检查的异常）如果 category 为 null，则抛出该异常。
IllegalArgumentException - （未经检查的异常）如果 category 并非实现了接口 Attribute 的 Class。

getSupportedAttributeValues

Object getSupportedAttributeValues(Class<? extends Attribute> category,
                                   DocFlavor flavor,
                                   AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。打印属性值是实现了接口 Attribute 的类的实例。

如果 flavor 为 null 并且 attributes 为 null 或是一个空集合，则此方法为任何可能的作业返回此 PrintService 支持的所有打印属性值。如果 flavor 不为 null 或 attributes 不是空集合，则此方法只返回与给定 doc flavor 和/或属性集兼容的打印属性值。也就是说，null 返回值可能指示指定此属性与指定的 DocFlavor 不兼容。另外，如果 DocFlavor 不为 null，则它必须是此 PrintService 支持的 flavor，否则将抛出 IllegalArgumentException。

如果 attributes 参数包含其类别与 category 参数相同的 Attribute，则该服务必须忽略 AttributeSet 中的此属性。

为了准确表示上下文，在此集合中必须包括要在 Doc 上指定的 DocAttribute。

此方法返回一个 Object，因为不同的打印属性类别以不同的方式指示受支持的属性值。包 javax.print.attribute.standard 中每个打印属性的文档都描述了每个属性如何指示其受支持的值。指示这种支持的可能方式包括：

  • 返回属性类别的单个实例来指示所使用的任何值都是合法的，例如由其值是任意文本字符串的属性所使用的值。（与返回的属性对象的值无关。）
  • 返回一个或多个属性类别实例的数组，其中包含所使用的合法值，例如由具有枚举值列表的属性所使用的值。数组的类型是一个指定属性类别类型的数组，由其 getCategory(Class) 方法返回。
  • 返回（某个类而不是属性类别）的单个对象，指示有关所用合法值的绑定，例如由其值必须位于一定范围内的整数值属性所使用的值。

参数：
category - 要测试的打印属性类别。它必须是实现了接口 Attribute 的 Class。
flavor - 用于假定作业的 Doc flavor，或者为 null。
attributes - 用于假定作业的打印属性集（包括作业级属性和 doc 级属性），或者为 null。
返回：
指示 category 受支持的值的 Object，如果此 PrintService 不支持在打印请求的 category 中指定 doc 级或作业级的属性，则返回 null。
抛出：
NullPointerException - （未经检查的异常）如果 category 为 null。
IllegalArgumentException - （未经检查的异常）如果 category 并非实现了接口 Attribute 的 Class，或者此服务不支持 DocFlavor。

isAttributeValueSupported

boolean isAttributeValueSupported(Attribute attrval,
                                  DocFlavor flavor,
                                  AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。打印属性值是实现了接口 Attribute 的类的实例。

如果 flavor 为 null 并且 attributes 为 null 或是一个空集合，则此方法将通知此 PrintService 是否支持针对某种可能的 doc flavor 和属性集组合所给定的打印属性值。如果 flavor 不为 null 或 attributes 不是空集合，则此方法通知此 PrintService 是否支持结合了给定的 doc flavor 和/或属性集的给定的打印属性值。

另外，如果 DocFlavor 不为 null，则它必须是此 PrintService 支持的 flavor，否则将抛出 IllegalArgumentException。

为了准确表示上下文，在此集合中必须包括要在 Doc 上指定的 DocAttribute。

这是确定该值是否为所得 getSupportedAttributeValues(...) 成员的便捷方法。

参数：
attrval - 要测试的打印属性值。
flavor - 用于假定作业的 Doc flavor，或者为 null。
attributes - 用于假定作业的打印属性集（包括作业级属性和 doc 级属性），或者为 null。
返回：
如果此 PrintService 支持将 attrval 指定为打印请求中 doc 级或作业级的属性，则返回 true；否则返回 false。
抛出：
NullPointerException - （未经检查的异常）如果 attrval 为 null，则抛出该异常。
IllegalArgumentException - 如果此 PrintService 不支持 flavor。

getUnsupportedAttributes

AttributeSet getUnsupportedAttributes(DocFlavor flavor,
                                      AttributeSet attributes)
标识在特定 DocFlavor 的上下文中打印请求不支持的属性。对于验证可能的打印作业和标识无法支持的具体的属性而言，此方法很有用。仅提供受支持的 DocFlavor 很重要，否则将抛出 IllegalArgumentException。如果此方法的返回值为 null，则支持所有属性。

为了准确表示上下文，在此集合中必须包括要在 Doc 上指定的 DocAttribute。

如果返回值不为 null，则返回集合中的所有属性都是此 DocFlavor 所不支持的。返回的集合不区分不受支持的属性类别和不受支持的属性值。

然后可通过从原始的属性集中移除所有不受支持的属性（不支持 DocFlavor 的情况除外），就可以创建一个受支持的打印请求。

如果不支持某些属性的原因是与其他属性有冲突，则由服务决定选择将哪些属性标识为冲突的原因。

调用此方法前使用 isDocFlavorSupported() 来验证是否支持某个 DocFlavor。

参数：
flavor - 要测试的 Doc flavor，或者为 null
attributes - 用于假定作业的打印属性集（包括作业级属性和 doc 级属性），或者为 null。
返回：
如果此 PrintService 支持打印请求规范，则返回 null；否则返回不受支持的属性。
抛出：
IllegalArgumentException - 如果此 PrintService 不支持 flavor。

getServiceUIFactory

ServiceUIFactory getServiceUIFactory()
返回 UI 组件的工厂方法，该组件允许用户通过各种角色与服务交互。不提供任何 UI 的服务应该返回 null。确实提供 UI 但是又想在没有 UI 支持的环境中得到支持的 PrintService 应该确保该工厂是不可初始化的，除非应用程序调用此方法来获得该工厂。有关更多信息，请参阅 ServiceUIFactory。

返回：
null 或用于 UI 组件的工厂。

equals

boolean equals(Object obj)
确定两个服务是否引用相同的底层服务。封装了 PrintService 的对象即使在引用相同的底层服务时也不会表现出引用相等性。

客户端应该调用此方法来确定两个服务是否引用了相同的底层服务。

各个服务必须实现此方法，并且仅在客户端可以交换地使用被比较的服务对象时才返回 true。如果返回 true，则各个服务可返回对底层服务的相同对象引用，但是客户端不能依赖于引用相等性。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此服务与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
此方法的实现方式应该与 equals(Object) 具有一致性。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintServiceLookup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 PrintServiceLookup

java.lang.Object
    继承者  javax.print.PrintServiceLookup

public abstract class PrintServiceLookup
extends Object

此类的实现为特定类型的 PrintService（通常等效于打印机）提供查找服务。

可同时安装多个实现。所有实现必须能够以 PrintService 实例的方式描述找到的打印机。通常在 JAR 文件中自动查找此服务类的实现（请参阅 SPI JAR 文件规范）。这些类必须是可以使用默认的构造方法进行实例化的。另外，应用程序可以在运行时显式地注册实例。

应用程序只使用此抽象类的静态方法。由子类中的服务提供者实现这些实例方法，当应用程序调用此类的静态方法时，由这些方法报告所有已安装查找类的统一结果。

建议 PrintServiceLookup 实现程序检查 SecurityManager.checkPrintJobAccess()，以拒绝对不受信任代码的访问。遵从此建议的策略意味着不受信任代码可能无法找到任何 PrintService。已下载的 applet 是不受信任代码最常见的示例。

对每个查找服务执行此项检查，从而允许策略中存在灵活性，以反映不同查找服务的需求。

如果安装了安全管理器并且其 checkPrintJobAccess() 方法拒绝访问，则查找结果中不会包括那些通过 registerService(PrintService) 注册的服务。

构造方法摘要
PrintServiceLookup()
方法摘要
abstract PrintService | getDefaultPrintService() 应用程序不直接调用它。
abstract MultiDocPrintService[] | getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 应用程序不直接调用它。
abstract PrintService[] | getPrintServices() 应用程序不直接调用它。
abstract PrintService[] | getPrintServices(DocFlavor flavor, AttributeSet attributes) 查找肯定可支持指定属性和 DocFlavor 组合的服务。
static PrintService | lookupDefaultPrintService() 查找此环境的默认 PrintService。
static MultiDocPrintService[] | lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。
static PrintService[] | lookupPrintServices(DocFlavor flavor, AttributeSet attributes) 查找能够打印指定 DocFlavor 的 PrintService。
static boolean | registerService(PrintService service) 允许应用程序直接注册一个实现了 PrintService 的类的实例。
static boolean | registerServiceProvider(PrintServiceLookup sp) 允许应用程序显式地注册一个实现了查找服务的类。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PrintServiceLookup

public PrintServiceLookup()
方法详细信息

lookupPrintServices

public static final PrintService[] lookupPrintServices(DocFlavor flavor,
                                                       AttributeSet attributes)
查找能够打印指定 DocFlavor 的 PrintService。

参数：
flavor - 要打印的 flavor。如果为 null，则不使用此项约束。
attributes - 该 PrintService 必须支持的属性。如果为 null，则不使用此项约束。
返回：
相符的 PrintService 对象的数组，这些对象表示那些支持指定 flavor 属性的打印服务。如果没有相符的服务，则数组的长度为零。

lookupMultiDocPrintServices

public static final MultiDocPrintService[] lookupMultiDocPrintServices(DocFlavor[] flavors,
                                                                       AttributeSet attributes)
查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。

在查找可以打印 MultiDoc（其中的元素可能具有不同 flavor） 的服务方面，此方法很有用。应用程序本身可以依次对每个 DocFlavor 执行多次查找，然后对结果进行整理来完成此功能，但是查找服务可以更高效地完成此项工作。

参数：
flavors - 要打印的 flavor。如果为 null 或为空，则不使用此项约束。否则只返回可打印所有指定 doc flavor 的 multidoc PrintService。
attributes - 该 PrintService 必须支持的属性。如果为 null，则不使用此项约束。
返回：
相符的 MultiDocPrintService 对象的数组。如果没有相符的服务，则数组的长度为零。

lookupDefaultPrintService

public static final PrintService lookupDefaultPrintService()
查找此环境的默认 PrintService。此方法可以返回 null。如果多个查找服务每个都指定了默认值，则没有精确定义选择哪个服务，则通常将本机平台服务（而不是已安装的服务）作为默认值返回。如果没有明确标识的本机平台默认 PrintService，则默认值是以实现相关的方式所要找的第一个服务。

这可能包括使用任意首选的 API，它可作为 Java 或本机平台的一部分而提供。设置属性 javax.print.defaultPrinter 的用户可以重写此算法。指定的服务必须证明是有效的，并且目前可作为默认值返回。

返回：
默认的 PrintService。

registerServiceProvider

public static boolean registerServiceProvider(PrintServiceLookup sp)
允许应用程序显式地注册一个实现了查找服务的类。在不同的 VM 调用后不会保留该注册关系。如果应用程序需要提供一个不是安装的一部分的新服务，则这一点是很有用的。如果已注册该查找服务或无法注册它，则该方法返回 false。

参数：
sp - 查找服务的实现。
返回：
如果新注册了该新的查找服务，则返回 true；否则返回 false。

registerService

public static boolean registerService(PrintService service)
允许应用程序直接注册一个实现了 PrintService 的类的实例。由 PrintServiceLookup 类使用此服务所报告的属性值和类来执行对该服务的查找操作。这可能比专为该服务调整过的查找服务效率要低。因此建议注册一个 PrintServiceLookup 实例。如果此服务以前未注册并且现在成功注册了，则该方法返回 true。不应使用 StreamPrintService 实例调用此方法。这样始终会注册失败并且该方法将返回 false。

参数：
service - PrintService 的实现。
返回：
如果新注册了该服务，则返回 true；否则返回 false。

getPrintServices

public abstract PrintService[] getPrintServices(DocFlavor flavor,
                                                AttributeSet attributes)
查找肯定可支持指定属性和 DocFlavor 组合的服务。应用程序不直接调用此方法。

此方法由服务提供者实现，由此类的静态方法使用。

结果应该与下列过程相同：获得所有 PrintService，逐个查询每个 PrintService 是否支持指定的属性和 flavor；但是处理时为 PrintService 充分利用查找服务的功能要更为高效。

参数：
flavor - 必需的文档。如果为 null，则忽略它。
attributes - 必需支持的属性。如果为 null，则不使用此项约束。
返回：
相符的 PrintService 的数组。如果没有相符的服务，则数组的长度为零。

getPrintServices

public abstract PrintService[] getPrintServices()
应用程序不直接调用它。此方法由服务提供者实现，由此类的静态方法使用。

返回：
此查找服务类已知的所有 PrintService 的数组。如果未找到服务，则数组的长度为零。

getMultiDocPrintServices

public abstract MultiDocPrintService[] getMultiDocPrintServices(DocFlavor[] flavors,
                                                                AttributeSet attributes)
应用程序不直接调用它。

此方法由服务提供者实现，由此类的静态方法使用。

查找肯定可支持指定属性和 DocFlavor 组合的 MultiDoc PrintService。

参数：
flavors - 必需的文档。如果为 null 或为空，则忽略它。
attributes - 必需支持的属性。如果为 null，则不使用此项约束。
返回：
相符的 PrintService 的数组。如果没有相符的服务，则数组的长度为零。

getDefaultPrintService

public abstract PrintService getDefaultPrintService()
应用程序不直接调用它。此方法由服务提供者实现，由打印查找服务调用

返回：
此查找服务的默认 PrintService。如果没有默认 PrintService，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceUI (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 ServiceUI

java.lang.Object
    继承者  javax.print.ServiceUI

public class ServiceUI
extends Object

此类是各种 UI 便捷方法的集合，这些方法为浏览那些通过 Java Print Service API 所查找的 PrintService 提供了图形用户对话框。

该对话框遵从标准的模式，为用户提供继续/取消的选项，以及允许用户选择要使用并指定各种选择（如纸张大小和份数）的 PrintService。

该对话框设计成通过可插入 PrintService 的公共 API 来与这些服务一同使用。

如果 PrintService 提供了任意的供应商扩展，则用户可通过供应商提供的选项卡窗格 Component 来访问这些扩展。鼓励这种供应商扩展使用 Swing! 并支持其可访问性 API。供应商扩展应该返回作为 AttributeSet 一部分的设置。希望保持用户设置的应用程序应该使用这些设置来指定打印作业。注意，Java 打印服务的所有其他部分都不引用此类，并且不包括在与 AWT 包的存在无关的配置文件中。

构造方法摘要
ServiceUI()
方法摘要
static PrintService printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes)
为用户提供一个选择 PrintService（打印机）的对话框。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ServiceUI

public ServiceUI()
方法详细信息

printDialog

public static PrintService printDialog(GraphicsConfiguration gc,
                                       int x,
                                       int y,
                                       PrintService[] services,
                                       PrintService defaultService,
                                       DocFlavor flavor,
                                       PrintRequestAttributeSet attributes)
                                throws HeadlessException
为用户提供一个选择 PrintService（打印机）的对话框。在应用程序指定的位置显示它，并且它是有模式的。如果指定的位置无效或者要使该对话框不可见，则在由实现所确定的位置显示它。该对话框阻塞其调用的线程，并且是有模式的应用程序。

该对话框可以包括一个选项卡窗格，该窗格具有在浏览 PrintService 时，可以延迟方式从 PrintService 的 ServiceUIFactory 所获得的自定义 UI。对话框会首先试图查找一个作为 JComponent 的 MAIN_UIROLE，然后查找作为 Panel 的 MAIN_UIROLE。如果没有 ServiceUIFactory 或没有相符的角色，则自定义选项卡将为空或不可见。

如果用户“确定”了该对话框，则对话框返回用户选择的 PrintService，如果用户“取消”了该对话框，则返回 null。

应用程序必须传递要浏览的 PrintService 的数组。该数组必须是非 null 和非空的。通常应用程序只传递能够打印特定 doc flavor 的 PrintService。

应用程序可以传递最初显示的 PrintService。可浏览服务的数组中必须包括非 null 参数。如果此参数为 null，则由实现选择某个服务。

可选地，应用程序可以传递要打印的 flavor。如果这是呈现给用户的非 mull 选择，则可针对该服务所支持的 flavor 更好地验证该选择。应用程序必须为返回的用户选择传递 PrintRequestAttributeSet。所调用的 PrintRequestAttributeSet 可以为空，或者可包含特定于应用程序的值。

这些内容用于为最初显示的 PrintService 设置初始设置。忽略那些 PrintService 不支持的值。在用户浏览 PrintService 时，将属性和值复制到新的显示内容。如果用户浏览的 PrintService 不支持特定的属性-值，则将该服务的默认值用作要复制的新值。

如果用户取消了对话框，则返回的属性将不会反映用户进行的任何更改。 此方法的典型基本用法是：

 PrintService[] services = PrintServiceLookup.lookupPrintServices(
                            DocFlavor.INPUT_STREAM.JPEG, null);
 PrintRequestAttributeSet attributes = new HashPrintRequestAttributeSet();
 if (services.length > 0) {
    PrintService service =  ServiceUI.printDialog(null, 50, 50,
                                               services, services[0],
                                               null,
                                               attributes);
    if (service != null) {
     ... print ...
    }
 }

参数：
gc - 用于选择屏幕。null 意味着主屏幕或默认屏幕。
x - 对话框在屏幕坐标中的位置，包括边框
y - 对话框在屏幕坐标中的位置，包括边框
services - 可浏览的服务，必须不为 null。
defaultService - 要显示的初始 PrintService。
flavor - 要打印的 flavor，或者为 null。
attributes - 输入时为应用程序最初提供的首选项。这不能为 null，但可以为空。输出时为反映用户所作的更改的属性。
返回：
用户选择的 PrintService，如果用户取消了对话框，则返回 null。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
IllegalArgumentException - 如果 services 为 null 或为空，或者 attributes 为 null，或者初始的 PrintService 未在可浏览服务的列表中。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServiceUIFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 ServiceUIFactory

java.lang.Object
    继承者  javax.print.ServiceUIFactory

public abstract class ServiceUIFactory
extends Object

服务可以可选地提供 UI，这些 UI 允许以不同的角色进行不同风格的交互。一种角色可以是浏览并设置打印选项的终端用户。另一种角色可以是管理 PrintService。

虽然 PrintService API 目前不提供对管理 PrintService 的标准化支持，但是可以监视 PrintService 并且可以为专用的更新机制提供 UI。

基本的设计目的是允许应用程序仅在需要时以延迟方式查找并初始化服务，而不依赖任何 API（但使用 API 的环境除外）。

首选使用 Swing UI，因为它提供了更为一致的 L&F 并且可支持可访问性 API。

用例：

  ServiceUIFactory factory = printService.getServiceUIFactory();
  if (factory != null) {
      JComponent swingui = (JComponent)factory.getUI(
                                         ServiceUIFactory.MAIN_UIROLE,
                                         ServiceUIFactory.JCOMPONENT_UI);
      if (swingui != null) {
          tabbedpane.add("Custom UI", swingui);
      }
  }

字段摘要
static int | ABOUT_UIROLE 表示一个充当提供 "About" 信息角色的 UI。
static int | ADMIN_UIROLE 表示一个充当管理角色的 UI。
static String | DIALOG_UI 表示一个作为 AWT 对话框实现的 UI。
static String | JCOMPONENT_UI 表示一个作为 Swing 组件实现的 UI。
static String | JDIALOG_UI 表示一个作为 Swing 对话框实现的 UI。
static int | MAIN_UIROLE 表示一个充当普通终端用户角色的 UI。
static String | PANEL_UI 表示一个作为 AWT 面板实现的 UI。
static int | RESERVED_UIROLE 不是有效的角色，但是可将大于此的角色 ID 用于服务支持的专用角色。
构造方法摘要
ServiceUIFactory()
方法摘要
abstract Object | getUI(int role, String ui) 获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。
abstract String[] | getUIClassNamesForRole(int role) 给定从此工厂获取的 UI 角色，获取实现此角色的此工厂可提供的 UI 类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

JCOMPONENT_UI

public static final String JCOMPONENT_UI
表示一个作为 Swing 组件实现的 UI。String 的值是完全限定类名："javax.swing.JComponent"。

另请参见：
常量字段值

PANEL_UI

public static final String PANEL_UI
表示一个作为 AWT 面板实现的 UI。String 的值是完全限定类名："java.awt.Panel"。

另请参见：
常量字段值

DIALOG_UI

public static final String DIALOG_UI
表示一个作为 AWT 对话框实现的 UI。String 的值是完全限定类名："java.awt.Dialog"。

另请参见：
常量字段值

JDIALOG_UI

public static final String JDIALOG_UI
表示一个作为 Swing 对话框实现的 UI。String 的值是完全限定类名："javax.swing.JDialog"。

另请参见：
常量字段值

ABOUT_UIROLE

public static final int ABOUT_UIROLE
表示一个充当提供 "About" 信息角色的 UI。

另请参见：
常量字段值

ADMIN_UIROLE

public static final int ADMIN_UIROLE
表示一个充当管理角色的 UI。

另请参见：
常量字段值

MAIN_UIROLE

public static final int MAIN_UIROLE
表示一个充当普通终端用户角色的 UI。

另请参见：
常量字段值

RESERVED_UIROLE

public static final int RESERVED_UIROLE
不是有效的角色，但是可将大于此的角色 ID 用于服务支持的专用角色。要正确使用它，需要知道此角色所执行的功能。

另请参见：
常量字段值
构造方法详细信息

ServiceUIFactory

public ServiceUIFactory()
方法详细信息

getUI

public abstract Object getUI(int role,
                             String ui)
获得一个 UI 对象，它可能被应用程序强制转换为所请求的 UI 类型并在该应用程序的用户界面中使用。

参数：
role - 所请求的角色。必须是此工厂支持的标准角色或某个专用角色。
ui - 所请求的角色的类型。
返回：
UI 角色，如果此工厂不提供所请求的 UI 角色，则返回 null
抛出：
IllegalArgumentException - 如果 role 或 ui 既不是标准的角色或 UI，也不是该工厂支持的专用角色或 UI。

getUIClassNamesForRole

public abstract String[] getUIClassNamesForRole(int role)
给定从此工厂获取的 UI 角色，获取实现此角色的此工厂可提供的 UI 类型。返回的 String 应该引用此类中定义的静态变量，这样应用程序可以使用引用相等性 ("==")。

参数：
role - 要被查找的角色。
返回：
此类为指定角色所支持的 UI 类型，如果没有用于此角色的 UI，则返回 null。
抛出：
IllegalArgumentException - 如果该 role 是非标准的角色，或者此工厂不支持该 role。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleDoc (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 SimpleDoc

java.lang.Object
    继承者  javax.print.SimpleDoc
所有已实现的接口：
Doc
public final class SimpleDoc
extends Object
implements Doc

此类是接口 Doc 的实现，可用于很多常见的打印请求中。它可处理目前作为 DocFlavor 类中静态变量所定义的所有“预定义” doc flavor。

特别是此类实现了某些 Doc 规范所必需的语义：

  • 如果请求了并且是合适的，则为服务构造流。
  • 确保对某个方法的每次调用都返回相同的对象。
  • 确保多个线程可以访问 Doc。
  • 对数据是否与 doc flavor 相符执行某种验证。
希望在其他作业中重用该 doc 对象或需要 MultiDoc 的客户端不希望使用此类。

如果打印数据是一个流，或者打印作业以流的形式请求数据，那么当数据传输完成或作业终止后服务正确地关闭该流时，SimpleDoc 不再进行监视。客户端可能优先使用其自己添加了侦听器的 doc 实现，以监视作业的完成并验证是否有诸如流等的可用资源（即是否已关闭）。

构造方法摘要
SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。
方法摘要
DocAttributeSet | getAttributes() 获得此 doc 对象的打印属性集。
DocFlavor | getDocFlavor() 确定其 doc 对象将提供其部分打印数据的 doc flavor。
Object | getPrintData() 获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。
Reader | getReaderForText() 获得一个从此 doc 中提取字符打印数据的 reader。
InputStream | getStreamForBytes() 获得一个从此 doc 中提取 byte 打印数据的输入流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SimpleDoc

public SimpleDoc(Object printData,
                 DocFlavor flavor,
                 DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。

参数：
printData - 打印数据对象
flavor - DocFlavor 对象
attributes - DocAttributeSet，可以为 null
抛出：
IllegalArgumentException - 如果 flavor 或 printData 为 null，或者 printData 不对应于指定的 doc flavor--例如，数据不是 DocFlavor 中的表示形式所指定的类型。
方法详细信息

getDocFlavor

public DocFlavor getDocFlavor()
确定其 doc 对象将提供其部分打印数据的 doc flavor。

指定者：
接口 Doc 中的 getDocFlavor
返回：
DocFlavor。

getAttributes

public DocAttributeSet getAttributes()
获得此 doc 对象的打印属性集。如果返回的属性集包括特定属性 X 的实例，则打印机必须为此 doc 使用该属性值，该值覆盖作业属性集中属性 X 的所有值。如果返回的属性集不包括特定属性 X 的实例，或者返回 null，则打印机必须参考该作业的属性集来获得属性 X 的值，如果在该集合中未找到该属性值，则打印机必须使用一个与实现相关的默认值。返回的属性集是不可修改的。

指定者：
接口 Doc 中的 getAttributes
返回：
此 doc 不可修改的打印属性集，或者为 null，以从该作业的属性集中获得所有属性值。

getPrintData

public Object getPrintData()
                    throws IOException
从接口 Doc 复制的描述
获得打印数据表示形式对象，该对象包含此 doc 对象的部分打印数据，其格式对应于受支持的 DocFlavor。getPrintData() 方法返回一个表示形式类的实例，其名称由 getDocFlavor()、getRepresentationClassName() 给定，可将返回值从类 Object 强制转换为该表示形式类。

指定者：
接口 Doc 中的 getPrintData
返回：
打印数据表示形式对象。
抛出：
IOException - 如果表示形式类是一个流且在构造该流时存在 I/O 错误。

getReaderForText

public Reader getReaderForText()
                        throws IOException
获得一个从此 doc 中提取字符打印数据的 reader。如果 DocFlavor 具有以下打印数据表示形式类之一，则需要 Doc 实现支持此方法，否则返回 null：
  • char[]
  • java.lang.String
  • java.io.Reader
为了从打印数据表示形式对象中以字符流的形式读取打印数据，使用 doc 的打印数据表示形式对象来构造并返回一个 Reader。但是，如果打印数据表示形式对象本身就是一个 Reader，则只返回该打印数据表示形式对象。

指定者：
接口 Doc 中的 getReaderForText
返回：
从此 doc 中读取打印数据字符的 Reader。如果因为此 doc 不符合上述标准而无法提供 reader，则返回 null。
抛出：
IOException - 如果创建 reader 时存在 I/O 错误。

getStreamForBytes

public InputStream getStreamForBytes()
                              throws IOException
获得一个从此 doc 中提取 byte 打印数据的输入流。如果 DocFlavor 具有以下打印数据表示形式类之一，则需要 Doc 实现支持此方法，否则此方法返回 null：
  • byte[]
  • java.io.InputStream
获得该 doc 的打印数据表示形式对象。然后，为了从打印数据表示形式对象中以 byte 流形式读取打印数据，创建并返回一个输入流。但是，如果打印数据表示形式对象本身就是一个输入流，则只返回该打印数据表示形式对象。

指定者：
接口 Doc 中的 getStreamForBytes
返回：
从此 doc 中读取打印数据 byte 的 InputStream。如果因为此 doc 不符合上述标准而无法提供输入流，则返回 null。
抛出：
IOException - 如果创建输入流时存在 I/O 错误。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StreamPrintService (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 StreamPrintService

java.lang.Object
    继承者  javax.print.StreamPrintService
所有已实现的接口：
PrintService
public abstract class StreamPrintService
extends Object
implements PrintService

此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。这主要用于输出格式是一种适合于查看或存档的文档类型的服务。必须以 mime 类型的形式声明该输出格式。这等效于其中表示形式类始终是 "java.io.OutputStream" 的某种输出 doc flavor。可从 StreamPrintServiceFactory 实例中获得 StreamPrintService 类的实例。

注意，StreamPrintService 与 PrintService 不同，PrintService 支持 Destination 属性。StreamPrintService 始终请求一个输出流，而 PrintService 可选地接受一个 Destination。StreamPrintService 没有针对其格式化输出的默认目标。另外，StreamPrintService 应该以在其他上下文中有用的格式生成输出。不应期望 StreamPrintService 支持 Destination 属性。

构造方法摘要
protected StreamPrintService(OutputStream out)
构造一个 StreamPrintService 对象。
方法摘要
void | dispose() 处置此 StreamPrintService。
abstract String | getOutputFormat() 返回此 PrintService 所发出的文档格式。
OutputStream | getOutputStream() 获得输出流。
boolean | isDisposed() 返回一个 boolean 值，指示是否已处置此 StreamPrintService。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.print.PrintService 继承的方法
addPrintServiceAttributeListener, createPrintJob, equals, getAttribute, getAttributes, getDefaultAttributeValue, getName, getServiceUIFactory, getSupportedAttributeCategories, getSupportedAttributeValues, getSupportedDocFlavors, getUnsupportedAttributes, hashCode, isAttributeCategorySupported, isAttributeValueSupported, isDocFlavorSupported, removePrintServiceAttributeListener

构造方法详细信息

StreamPrintService

protected StreamPrintService(OutputStream out)
构造一个 StreamPrintService 对象。

参数：
out - 流，格式化打印数据送入该流。
方法详细信息

getOutputStream

public OutputStream getOutputStream()
获得输出流。

返回：
此服务将格式化打印数据所发送到的流。

getOutputFormat

public abstract String getOutputFormat()
返回此 PrintService 所发出的文档格式。必须是 mime 类型格式，与 DocFlavor 的 mime 类型部分兼容

返回：
标识输出格式的 mime 类型。
另请参见：
DocFlavor

dispose

public void dispose()
处置此 StreamPrintService。如果无法重用某个流服务，则必须处置它以指示此情况。通常客户端将调用此方法。某些服务（可写入无法有意义地追加的数据）也可以处置该流。这不会关闭该流。它只是将其标记为此服务无法再使用它而已。

isDisposed

public boolean isDisposed()
返回一个 boolean 值，指示是否已处置此 StreamPrintService。如果已处置此对象，则返回 true。服务和客户端应用程序使用此方法来识别那些没有应该再写入的数据的流。

返回：
如果已处置此 StreamPrintService，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StreamPrintServiceFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print
类 StreamPrintServiceFactory

java.lang.Object
    继承者  javax.print.StreamPrintServiceFactory

public abstract class StreamPrintServiceFactory
extends Object

StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。典型的输出文档格式为 Postscript(TM)。

此类由服务实现，并通过服从 SPI JAR File specification 的实现查找。

应用程序可调用 lookupStreamPrintServiceFactories(DocFlavor, String) 方法来查找此类的实例。

应用程序可使用从工厂获得的 StreamPrintService 来代替表示物理打印机设备的 PrintService。

构造方法摘要
StreamPrintServiceFactory()
方法摘要
abstract String | getOutputFormat() 查询该工厂，了解从此工厂获得的打印机所发出的文档的格式。
abstract StreamPrintService | getPrintService(OutputStream out) 返回可打印到指定输出流的 StreamPrintService。
abstract DocFlavor[] | getSupportedDocFlavors() 查询该工厂，了解从此工厂所获得打印机可接受的 doc flavor。
static StreamPrintServiceFactory[] | lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType) 查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

StreamPrintServiceFactory

public StreamPrintServiceFactory()
方法详细信息

lookupStreamPrintServiceFactories

public static StreamPrintServiceFactory[] lookupStreamPrintServiceFactories(DocFlavor flavor,
                                                                            String outputMimeType)
查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。例如，doc flavor 是用户希望创建的文档类型，不是打印前的文档 flavor。

虽然在 StreamPrintService 的查找中使用 null 是可接受的值，但是通常要搜索所需的特定格式，如 Postscript(TM)。

参数：
flavor - 输入文档的类型 - null 意味着匹配所有类型。
outputMimeType - 表示所需的输出格式，用于标识适合的流打印机工厂。null 值意味着匹配所有格式。
返回：
用于 StreamPrintService 实例的匹配工厂，如果无法找到适合的工厂，则返回一个空工厂。

getOutputFormat

public abstract String getOutputFormat()
查询该工厂，了解从此工厂获得的打印机所发出的文档的格式。

返回：
以 mime 类型描述的输出格式。

getSupportedDocFlavors

public abstract DocFlavor[] getSupportedDocFlavors()
查询该工厂，了解从此工厂所获得打印机可接受的 doc flavor。

返回：
受支持的 doc flavor 的数组。

getPrintService

public abstract StreamPrintService getPrintService(OutputStream out)
返回可打印到指定输出流的 StreamPrintService。由应用程序创建并管理该输出流。应用程序负责关闭该流，并确保不再使用此打印机。从打印机创建的所有 PrintJob 完成前，应用程序不应关闭此流。提前关闭此流可能生成 PrinterException 和一个指示作业失败的事件。

尽管可以重用连接到物理打印机的 PrintService，但不能重用连接到流的 StreamPrintService。从 DocPrintJob 的 print 方法返回前，打印系统可使用 dispose 方法处置底层的 StreamPrintService，这样该打印系统就知道此打印机不再是可使用的。这等效于从此转至脱机状态的物理打印机。应用程序可以提供一个 null 打印流来创建可查询的服务。为这种流创建一个 PrintJob 是无效的。在构造时分配资源的实现应该检查该流，并且仅在该流不为 null 时才分配资源。

参数：
out - 已生成输出的目标流。
返回：
一个 PrintService，它将生成由此工厂所支持的 DocFlavor 所指定的格式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URIException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print
接口 URIException

public interface URIException

接口 URIException 是一个混合接口，PrintException 的子类可实现它来报告有关 URI 地址的错误状况。打印服务 API 未定义任何实现了接口 URIException 的打印异常类，这由打印服务的实现程序来决定。

字段摘要
static int | URIInaccessible 指示打印机无法访问该 URI 地址。
static int | URIOtherProblem 指示出于所有其他原因未明确标识的问题类别。
static int | URISchemeNotSupported 指示打印机不支持该 URI 地址中的 URI 方案（"http"、"ftp" 等等）。
方法摘要
int | getReason() 返回事件的原因。
URI | getUnsupportedURI() 返回 URI。

字段详细信息

URIInaccessible

static final int URIInaccessible
指示打印机无法访问该 URI 地址。例如，如果打印机将要获得打印数据时甚至无法建立到该 URI 地址的连接，则打印机可报告此错误。

另请参见：
常量字段值

URISchemeNotSupported

static final int URISchemeNotSupported
指示打印机不支持该 URI 地址中的 URI 方案（"http"、"ftp" 等等）。

另请参见：
常量字段值

URIOtherProblem

static final int URIOtherProblem
指示出于所有其他原因未明确标识的问题类别。

另请参见：
常量字段值
方法详细信息

getUnsupportedURI

URI getUnsupportedURI()
返回 URI。

返回：
导致此异常的 URI。

getReason

int getReason()
返回事件的原因。

返回：
此接口中所枚举的某个预定义原因。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.print (Java 2 Platform SE 6)

 javax.print
接口
AttributeException
CancelablePrintJob
Doc
DocPrintJob
FlavorException
MultiDoc
MultiDocPrintJob
MultiDocPrintService
PrintService
URIException
类
DocFlavor
DocFlavor.BYTE_ARRAY
DocFlavor.CHAR_ARRAY
DocFlavor.INPUT_STREAM
DocFlavor.READER
DocFlavor.SERVICE_FORMATTED
DocFlavor.STRING
DocFlavor.URL
PrintServiceLookup
ServiceUI
ServiceUIFactory
SimpleDoc
StreamPrintService
StreamPrintServiceFactory
异常
PrintException


javax.print (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.print

为 JavaTM Print Service API 提供了主要类和接口。

请参见：
描述

接口摘要
AttributeException | 接口 AttributeException 是一个混合接口，PrintException 的子类可实现该接口以报告涉及一个或多个打印属性的错误条件，特定的 Print Service 实例不支持该条件。
CancelablePrintJob | 打印应用程序使用此接口来取消打印作业。
Doc | 接口 Doc 指定某个对象的接口，该接口为 PrintJob 提供部分打印数据。
DocPrintJob | 此接口表示了一个可使用作业属性集打印指定文档的打印作业。
FlavorException | 接口 FlavorException 是一个混合接口，PrintException 的子类可实现它来报告有关某个 DocFlavor 或多个 DocFlavor（类 DocFlavor）的错误状况。
MultiDoc | 接口 MultiDoc 指定某个对象的接口，该对象为 PrintJob 提供多部分打印数据。
MultiDocPrintJob | 从 MultiDocPrintService 中获得，MultiDocPrintJob 可使用作业属性集以单个 PrintJob 的形式打印指定的文档集合。
MultiDocPrintService | 接口 MultiPrintService 是 MultiDocPrintJob 的工厂。
PrintService | 接口 PrintService 是 DocPrintJob 的工厂。
URIException | 接口 URIException 是一个混合接口，PrintException 的子类可实现它来报告有关 URI 地址的错误状况。

类摘要
DocFlavor | 类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
DocFlavor.BYTE_ARRAY | 类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.CHAR_ARRAY | 类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.INPUT_STREAM | 类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.READER | 类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.SERVICE_FORMATTED | 类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
DocFlavor.STRING | 类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.URL | 类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。
PrintServiceLookup | 此类的实现为特定类型的 PrintService（通常等效于打印机）提供查找服务。
ServiceUI | 此类是各种 UI 便捷方法的集合，这些方法为浏览那些通过 Java Print Service API 所查找的 PrintService 提供了图形用户对话框。
ServiceUIFactory | 服务可以可选地提供 UI，这些 UI 允许以不同的角色进行不同风格的交互。
SimpleDoc | 此类是接口 Doc 的实现，可用于很多常见的打印请求中。
StreamPrintService | 此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。
StreamPrintServiceFactory | StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。

异常摘要
PrintException 类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。

软件包 javax.print 的描述

为 JavaTM Print Service API 提供了主要类和接口。Java Print Service API 允许客户端和服务器应用程序具备如下功能：

  • 根据其性能发现并选择 PrintService。
  • 指定打印数据的格式。
  • 向支持所打印文档类型的服务提交 PrintJob。

PrintService 发现

应用程序可调用抽象类 PrintServiceLookup 的静态方法来查找 PrintService，这些 PrintService 具有满足应用程序打印要求的功能。例如，要打印双面文档，应用程序首先需要找到具有双面打印功能的打印机。

JDK 包括的 PrintServiceLookup 实现可查找标准的平台打印机。要查找其他类型的打印机（如 IPP 打印机或 JINI 打印机），PrintService 提供者可写入 PrintServiceLookup 实现。PrintService 提供者可使用 SPI JAR 文件规范 动态地安装这些 PrintServiceLookup 实现。

属性定义

javax.print.attribute 和 javax.print.attribute.standard 包定义了打印属性，这些属性描述了 PrintService 的功能、指定 PrintJob 的要求并跟踪 PrintJob 的进度。

javax.print.attribute 包描述了属性类型和属性分类方法。javax.print.attribute.standard 包枚举了 API 所支持的所有标准属性，其中大多数是在 IETF 规范 RFC 2911 Internet Printing Protocol, 1.1:Model and Semantics（2000 年 9 月）中所指定的属性实现。javax.print.attribute.standard 中指定的属性包括常见的功能，如：分辨率、份数、介质大小、作业优先级和页面范围。

文档类型规范

DocFlavor 类表示了打印数据的格式，如 JPEG 或 PostScript。DocFlavor 对象由 MIME 类型（描述了格式）和文档表示形式类名（指示如何将文档发送到打印机或输出流）所组成。应用程序使用 DocFlavor 和属性集来查找某些打印机，这些打印机可打印由 DocFlavor 所指定的文档类型且具有属性集所指定的功能。

使用 API

典型的应用程序使用 Java Print Service API 执行以下步骤来处理打印请求：
  1. 选择一个 DocFlavor。
  2. 创建一个属性集。
  3. 找到一个可处理由 DocFlavor 和属性集所指定的打印请求的 PrintService。
  4. 创建一个 Doc 对象，该对象封装 DocFlavor 和实际的打印数据，这些打印数据可采用很多形式，包括：Postscript 文件、JPEG 图像、URL 或纯文本。
  5. 从 PrintService 获得一个由 DocPrintJob 表示的 PrintJob。
  6. 调用 PrintJob 的 print 方法。
以下代码示例说明了 Java Print Service API 的典型用法：找到可在 A4 大小的纸张上打印 5 份 Postscript 文档双面副本的打印机、根据某个返回的 PrintService 创建 PrintJob 并调用 print 方法。

FileInputStream psStream;
try {
   psStream = new FileInputStream("file.ps");
} catch (FileNotFoundException ffne) {
}
if (psStream == null) {
    return;
}

DocFlavor psInFormat = DocFlavor.INPUT_STREAM.POSTSCRIPT;
Doc myDoc = new SimpleDoc(psStream, psInFormat, null);
PrintRequestAttributeSet aset =
        new HashPrintRequestAttributeSet();
aset.add(new Copies(5));
aset.add(MediaSize.A4);
aset.add(Sides.DUPLEX);
PrintService[] services =
  PrintServiceLookup.lookupPrintServices(psInFormat, aset);
if (services.length > 0) {
   DocPrintJob job = services[0].createPrintJob();
   try {
        job.print(myDoc, aset);
   } catch (PrintException pe) {}
}

请注意：在 javax.print API 中，只有在方法中显式记录传递给方法的 null 引用参数具有有意义的解释时，该参数才是正确的。否则就是错误的编码方式，并且可能立即或在稍后某时导致运行时异常。IllegalArgumentException 和 NullPointerException 是典型的异常示例，并且是这种情况可接受的运行时异常。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.print 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.print.DocFlavor (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.DocFlavor.BYTE_ARRAY
      • javax.print.DocFlavor.CHAR_ARRAY
      • javax.print.DocFlavor.INPUT_STREAM
      • javax.print.DocFlavor.READER
      • javax.print.DocFlavor.SERVICE_FORMATTED
      • javax.print.DocFlavor.STRING
      • javax.print.DocFlavor.URL
    • javax.print.PrintServiceLookup
    • javax.print.ServiceUI
    • javax.print.ServiceUIFactory
    • javax.print.SimpleDoc (implements javax.print.Doc)
    • javax.print.StreamPrintService (implements javax.print.PrintService)
    • javax.print.StreamPrintServiceFactory
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.print.PrintException

接口分层结构

  • javax.print.AttributeException
  • javax.print.Doc
  • javax.print.DocPrintJob
    • javax.print.CancelablePrintJob
    • javax.print.MultiDocPrintJob
  • javax.print.FlavorException
  • javax.print.MultiDoc
  • javax.print.PrintService
    • javax.print.MultiDocPrintService
  • javax.print.URIException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.print 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print
的使用

使用 javax.print 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 使用的 javax.print 中的类
PrintService
接口 PrintService 是 DocPrintJob 的工厂。
StreamPrintServiceFactory
StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。

javax.print 使用的 javax.print 中的类
Doc
接口 Doc 指定某个对象的接口，该接口为 PrintJob 提供部分打印数据。
DocFlavor
类 DocFlavor 封装了一个对象，该对象指定提供给 DocPrintJob 的打印数据的格式。
DocFlavor.BYTE_ARRAY
类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.CHAR_ARRAY
类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.INPUT_STREAM
类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.READER
类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.SERVICE_FORMATTED
类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
DocFlavor.STRING
类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
DocFlavor.URL
类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。
DocPrintJob
此接口表示了一个可使用作业属性集打印指定文档的打印作业。
MultiDoc
接口 MultiDoc 指定某个对象的接口，该对象为 PrintJob 提供多部分打印数据。
MultiDocPrintJob
从 MultiDocPrintService 中获得，MultiDocPrintJob 可使用作业属性集以单个 PrintJob 的形式打印指定的文档集合。
MultiDocPrintService
接口 MultiPrintService 是 MultiDocPrintJob 的工厂。
PrintException
类 PrintException 封装了与打印有关的错误状况，此状况在使用 PrintService 实例时会发生。
PrintService
接口 PrintService 是 DocPrintJob 的工厂。
PrintServiceLookup
此类的实现为特定类型的 PrintService（通常等效于打印机）提供查找服务。
ServiceUIFactory
服务可以可选地提供 UI，这些 UI 允许以不同的角色进行不同风格的交互。
StreamPrintService
此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。
StreamPrintServiceFactory
StreamPrintServiceFactory 是 StreamPrintService 实例的工厂，StreamPrintService 可以 mime 类型所描述的特定文档格式向输出流中打印数据。

javax.print.event 使用的 javax.print 中的类
DocPrintJob
此接口表示了一个可使用作业属性集打印指定文档的打印作业。
PrintService
接口 PrintService 是 DocPrintJob 的工厂。

javax.swing 使用的 javax.print 中的类
PrintService
接口 PrintService 是 DocPrintJob 的工厂。

javax.swing.text 使用的 javax.print 中的类
PrintService
接口 PrintService 是 DocPrintJob 的工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Attribute (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 Attribute

所有超级接口：
Serializable
所有已知子接口：
DocAttribute, PrintJobAttribute, PrintRequestAttribute, PrintServiceAttribute, SupportedValuesAttribute
所有已知实现类：
Chromaticity, ColorSupported, Compression, Copies, CopiesSupported, DateTimeAtCompleted, DateTimeAtCreation, DateTimeAtProcessing, Destination, DocumentName, Fidelity, Finishings, JobHoldUntil, JobImpressions, JobImpressionsCompleted, JobImpressionsSupported, JobKOctets, JobKOctetsProcessed, JobKOctetsSupported, JobMediaSheets, JobMediaSheetsCompleted, JobMediaSheetsSupported, JobMessageFromOperator, JobName, JobOriginatingUserName, JobPriority, JobPrioritySupported, JobSheets, JobState, JobStateReason, JobStateReasons, Media, MediaName, MediaPrintableArea, MediaSize, MediaSizeName, MediaTray, MultipleDocumentHandling, NumberOfDocuments, NumberOfInterveningJobs, NumberUp, NumberUpSupported, OrientationRequested, OutputDeviceAssigned, PageRanges, PagesPerMinute, PagesPerMinuteColor, PDLOverrideSupported, PresentationDirection, PrinterInfo, PrinterIsAcceptingJobs, PrinterLocation, PrinterMakeAndModel, PrinterMessageFromOperator, PrinterMoreInfo, PrinterMoreInfoManufacturer, PrinterName, PrinterResolution, PrinterState, PrinterStateReason, PrinterStateReasons, PrinterURI, PrintQuality, QueuedJobCount, ReferenceUriSchemesSupported, RequestingUserName, Severity, SheetCollate, Sides
public interface Attribute
extends Serializable

接口 Attribute 是由任何一个打印属性类实现的基本接口，用于指示该类表示某一打印属性。所有打印属性都是可序列化的。

方法摘要
Class<? extends Attribute> | getCategory() 将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。
String | getName() 获取类别的名称,此属性值是该类别的一个实例。

方法详细信息

getCategory

Class<? extends Attribute> getCategory()
将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。

返回：
打印属性类（类别），是类 java.lang.Class 的一个实例。

getName

String getName()
获取类别的名称,此属性值是该类别的一个实例。

注： 此方法用于为属性的类别提供默认的非本地化字符串。如果两个属性对象从 getCategory() 方法返回相同的类别，则它们应从 getName() 方法返回相同的名称。

返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 AttributeSet

所有已知子接口：
DocAttributeSet, PrintJobAttributeSet, PrintRequestAttributeSet, PrintServiceAttributeSet
所有已知实现类：
HashAttributeSet, HashDocAttributeSet, HashPrintJobAttributeSet, HashPrintRequestAttributeSet, HashPrintServiceAttributeSet
public interface AttributeSet

接口 AttributeSet 为打印属性集指定接口。打印属性是一个对象，其类实现接口 Attribute。

属性集包含一组属性值，在该集合中，不允许出现重复值。此外，属性集中的每个值是某一类别 的成员，在该集合的任何特定类别中最多允许有一个值。对于某个属性集，值都是 Attribute 对象，类别都是 Class 对象。属性的类别是该类属性的类层次结构的根处的类（或接口）。注意，属性对象的类别可以是属性对象的类的超类，而不是属性对象的类本身。通过调用接口 Attribute 中定义的 getCategory() 方法确定属性对象的类别。

AttributeSet 的接口与 Java Collections API 的 java.util.Map 的接口类似，但是对于它将要接受的类型有更强的限制性，并且将键和值组合到了属性中。

在 Print Service API 中，多处使用了属性集。在每个上下文中，只有某些属性（DocAttribute、PrintRequestAttribute、PrintJobAttribute 和 PrintServiceAttribute）允许出现在属性集中，这由属性类实现的标记接口确定。一个属性集有四种规范，它们限于只能分别包含以下四种属性之一：DocAttributeSet、PrintRequestAttributeSet、PrintJobAttributeSet 和 PrintServiceAttributeSet。注意，许多属性类会实现多个标记接口，因此可以出现在多个上下文中。

  • 包含 DocAttribute 的 DocAttributeSet 指定单个文档的特征和应用到单个文档的打印作业的设置。

  • 包含 PrintRequestAttribute 的 PrintRequestAttributeSet 指定应用到整个打印作业和打印作业中的所有文档的设置。

  • 包含 PrintJobAttribute 的 PrintJobAttributeSet 报告打印作业的状态。

  • 包含 PrintServiceAttribute 的 PrintServiceAttributeSet 报告 Print Service 实例的状态。

在某些上下文中，仅允许客户机检查属性集的内容，但不允许更改它们（该集合是只读的）。在其他地方，允许客户机检查和更改属性集的内容（该集合是可读写的）。对于只读属性集，调用更改操作会抛出一个 UnmodifiableSetException。

Print Service API 提供接口 AttributeSet 的一个实现，即类 HashAttributeSet。客户机可以使用类 HashAttributeSet，或提供其自已的接口 AttributeSet 的实现。Print Service API 还提供接口 AttributeSet 的子接口的实现，即类 HashDocAttributeSet、HashPrintRequestAttributeSet、HashPrintJobAttributeSet 和 HashPrintServiceAttributeSet。

方法摘要
boolean | add(Attribute attribute) 如果指定的属性尚不存在，则将它添加到此属性集中，首先要移除与指定属性值相同的属性类别中的任何现有值。
boolean | addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
void | clear() 从此属性集中移除所有属性。
boolean | containsKey(Class<?> category) 如果此属性集包含指定类别的一个属性，则返回 true。
boolean | containsValue(Attribute attribute) 如果此属性集包含给定的属性值，则返回 true。
boolean | equals(Object object) 比较指定的对象与此属性集的相等性。
Attribute | get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
int | hashCode() 返回此属性集的哈希码值。
boolean | isEmpty() 如果此属性集不包含任何属性，则返回 true。
boolean | remove(Attribute attribute) 从此属性集移除指定的属性（如果存在）。
boolean | remove(Class<?> category) 从此属性集移除此类别的任何属性（如果存在）。
int | size() 返回此属性集中属性的数量。
Attribute[] | toArray() 返回此集合中包含的属性的数组。

方法详细信息

get

Attribute get(Class<?> category)
返回此属性集在给定的属性类别中包含的属性值。如果此属性集在给定的属性类别中不包含任何属性值，则返回 null。

参数：
category - 将返回其关联的属性值的属性类别。它必须是实现接口 Attribute 的 Class。
返回：
此属性集中包含的给定属性类别中的属性值，如果此属性集在给定的属性类别中不包含任何属性值，则返回 null。
抛出：
NullPointerException - （未经检查的异常）如果 category 为 null，则抛出该异常。
ClassCastException - （未经检查的异常）如果 category 不是实现接口 Attribute 的 Class，则抛出该异常。

add

boolean add(Attribute attribute)
如果指定的属性尚不存在，则将它添加到此属性集中，首先要移除与指定属性值相同的属性类别中的任何现有值。

参数：
attribute - 要添加到此属性集的属性值。
返回：
如果此属性集由于调用而发生改变（即给定的属性值还不是此属性集的成员），则返回 true。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 add() 操作，则抛出该异常。

remove

boolean remove(Class<?> category)
从此属性集移除此类别的任何属性（如果存在）。如果 category 为 null，则 remove() 不执行任何操作，并返回 false。

参数：
category - 要从此属性集移除的属性类别。
返回：
如果此属性集由于调用而发生改变（即给定的属性值已经成为此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 remove() 操作，则抛出该异常。

remove

boolean remove(Attribute attribute)
从此属性集移除指定的属性（如果存在）。如果 attribute 为 null，则 remove() 不执行任何操作，并返回 false。

参数：
attribute - 从此属性集移除的属性值。
返回：
如果此属性集由于调用而发生改变（即给定的属性值已经成为此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 remove() 操作，则抛出该异常。

containsKey

boolean containsKey(Class<?> category)
如果此属性集包含指定类别的一个属性，则返回 true。

参数：
category - 将测试其是否存在于此属性集中的类别。
返回：
如果此属性集包含指定类别的一个属性值，则返回 true。

containsValue

boolean containsValue(Attribute attribute)
如果此属性集包含给定的属性值，则返回 true。

参数：
attribute - 将测试其是否存在于此属性集中的属性值。
返回：
如果此属性集包含给定的属性值，则返回 true。

addAll

boolean addAll(AttributeSet attributes)
将指定集合中的所有元素添加到此属性中。该结果与使用指定集合中的每个元素将 = add(Attribute) 操作成功地应用到此属性集中相同。如果正在进行此操作的同时修改了指定的集合，则 addAll(AttributeSet) 操作的行为是不确定的。

如果 addAll(AttributeSet) 操作抛出一个异常，则对此属性集状态的影响取决于实现方法；在异常点之前，不一定将指定集合中的元素添加到了此属性集。

参数：
attributes - 要将其元素添加到此属性集中的属性。
返回：
如果此属性集由于调用而发生改变，则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 addAll(AttributeSet) 方法，则抛出该异常。
NullPointerException - （未经检查的异常）如果指定集合中的某一元素为 null，则抛出该异常。
另请参见：
add(Attribute)

size

int size()
返回此属性集中属性的数量。如果此属性集包含的元素多于 Integer.MAX_VALUE ，则返回 Integer.MAX_VALUE。

返回：
此属性集中属性的数量。

toArray

Attribute[] toArray()
返回此集合中包含的属性的数组。

返回：
作为数组包含在此集合中的属性，如果 AttributeSet 为空，则返回零长度。

clear

void clear()
从此属性集中移除所有属性。

抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 clear() 操作，则抛出该异常。

isEmpty

boolean isEmpty()
如果此属性集不包含任何属性，则返回 true。

返回：
如果此属性集不包含任何属性，则返回 true。

equals

boolean equals(Object object)
比较指定的对象与此属性集的相等性。如果给定的对象也是一个属性集，并且两个属性集包含相同的属性类别到属性值的映射关系，则返回 true。这确保了 equals() 方法能跨越 AttributeSet 接口的不同实现正常运行。

覆盖：
类 Object 中的 equals
参数：
object - 要与此属性集进行相等性比较的对象。
返回：
如果指定对象等于此属性集，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

int hashCode()
返回此属性集的哈希码值。属性集的哈希码被定义为 AttributeSet 中每个条目的哈希码的总和。这确保了 t1.equals(t2) 意味对于任何两个属性集 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是 Object.hashCode() 的通用协定所要求的。

覆盖：
类 Object 中的 hashCode
返回：
此属性集的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AttributeSetUtilities (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 AttributeSetUtilities

java.lang.Object
    继承者  javax.print.attribute.AttributeSetUtilities

public final class AttributeSetUtilities
extends Object

类 AttributeSetUtilities 为操作 AttributeSets 提供静态方法。

  • 用于创建属性集的不可修改的同步视图的方法。
  • 用于构建接口 AttributeSet 的实现的操作。

AttributeSet S 的不可修改的视图 U 为客户机提供对 S 的“只读”访问。U 上的查询操作“遍历”S；因此，S 中的更改会反映在 U 中。但是，任何修改 U 的尝试都会导致 UnmodifiableSetException。如果属性集对象 S 是可序列化的，则不可修改的视图对象 U 将是可序列化的。

属性集 S 的 同步视图 V 为客户机提供对 S 的同步（多线程安全）访问。V 的每个操作使用 V 本身作为锁定对象进行同步，然后只调用 S 的相应操作。为了相互保证独占访问，通过 V 完成对 S 的所有访问非常重要。如果属性集对象 S 是可序列化的，则同步视图对象 V 将是可序列化的。

如 javax.print 的包描述中提及的那样，方法的 null 引用参数是不正确的，除非在该方法中将该参数明确记录为具有有意义的解释。与之相反的用法是不正确的编码，可能立即或在稍后某一时间导致运行时异常。IllegalArgumentException 和 NullPointerException 是针对这种情况的典型的、可接受的运行时异常的示例。

方法摘要
static AttributeSet | synchronizedView(AttributeSet attributeSet) 创建给定属性集的同步视图。
static DocAttributeSet | synchronizedView(DocAttributeSet attributeSet) 创建一个给定文档属性集的同步视图。
static PrintJobAttributeSet | synchronizedView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的同步视图。
static PrintRequestAttributeSet | synchronizedView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的同步视图。
static PrintServiceAttributeSet | synchronizedView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的同步视图。
static AttributeSet | unmodifiableView(AttributeSet attributeSet) 创建给定属性集的不可修改的视图。
static DocAttributeSet | unmodifiableView(DocAttributeSet attributeSet) 创建一个给定文档属性集的不可修改的视图。
static PrintJobAttributeSet | unmodifiableView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的不可修改的视图。
static PrintRequestAttributeSet | unmodifiableView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的不可修改的视图。
static PrintServiceAttributeSet | unmodifiableView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的不可修改的视图。
static Class<?> | verifyAttributeCategory(Object object, Class<?> interfaceName) 验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。
static Attribute | verifyAttributeValue(Object object, Class<?> interfaceName) 验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。
static void | verifyCategoryForValue(Class<?> category, Attribute attribute) 验证给定的属性类别对象是否等于给定属性值对象的类别。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

unmodifiableView

public static AttributeSet unmodifiableView(AttributeSet attributeSet)
创建给定属性集的不可修改的视图。

参数：
attributeSet - 底层属性集。
返回：
attributeSet 的不可修改的视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

unmodifiableView

public static DocAttributeSet unmodifiableView(DocAttributeSet attributeSet)
创建一个给定文档属性集的不可修改的视图。

参数：
attributeSet - 底层文档属性集。
返回：
attributeSet 的不可修改的视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

unmodifiableView

public static PrintRequestAttributeSet unmodifiableView(PrintRequestAttributeSet attributeSet)
创建一个给定打印请求属性集的不可修改的视图。

参数：
attributeSet - 底层打印请求属性集。
返回：
attributeSet 的不可修改的视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

unmodifiableView

public static PrintJobAttributeSet unmodifiableView(PrintJobAttributeSet attributeSet)
创建一个给定打印作业属性集的不可修改的视图。

参数：
attributeSet - 底层打印作业属性集。
返回：
attributeSet 的不可修改的视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

unmodifiableView

public static PrintServiceAttributeSet unmodifiableView(PrintServiceAttributeSet attributeSet)
创建一个给定打印服务属性集的不可修改的视图。

参数：
attributeSet - 底层打印服务属性集。
返回：
attributeSet 的不可修改的视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

synchronizedView

public static AttributeSet synchronizedView(AttributeSet attributeSet)
创建给定属性集的同步视图。

参数：
attributeSet - 底层属性集。
返回：
attributeSet 的同步视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

synchronizedView

public static DocAttributeSet synchronizedView(DocAttributeSet attributeSet)
创建一个给定文档属性集的同步视图。

参数：
attributeSet - 底层文档属性集。
返回：
attributeSet 的同步视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

synchronizedView

public static PrintRequestAttributeSet synchronizedView(PrintRequestAttributeSet attributeSet)
创建一个给定打印请求属性集的同步视图。

参数：
attributeSet - 底层打印请求属性集。
返回：
attributeSet 的同步视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

synchronizedView

public static PrintJobAttributeSet synchronizedView(PrintJobAttributeSet attributeSet)
创建一个给定打印作业属性集的同步视图。

参数：
attributeSet - 底层打印作业属性集。
返回：
attributeSet 的同步视图。
抛出：
NullPointerException - 如果 attributeSet 为 null，则抛出该异常。

synchronizedView

public static PrintServiceAttributeSet synchronizedView(PrintServiceAttributeSet attributeSet)
创建一个给定打印服务属性集的同步视图。

参数：
attributeSet - 底层打印服务属性集。
返回：
attributeSet 的同步视图。

verifyAttributeCategory

public static Class<?> verifyAttributeCategory(Object object,
                                               Class<?> interfaceName)
验证给定的对象是否为实现给定接口（假定为接口 Attribute 或其子接口）的 Class。

参数：
object - 要测试的对象。
interfaceName - 该对象必须实现的接口。
返回：
如果 object 是实现 interfaceName 的 Class，则返回的 object 向下转型到类型 Class；否则抛出一个异常。
抛出：
NullPointerException - （未经检查的异常）如果 object 为 null，则抛出该异常。
ClassCastException - （未经检查的异常）如果 object 不是实现 interfaceName 的 Class，则抛出该异常。

verifyAttributeValue

public static Attribute verifyAttributeValue(Object object,
                                             Class<?> interfaceName)
验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。

参数：
object - 要测试的对象。
interfaceName - 其对象必须是实例的接口的名称。
返回：
如果 object 是 interfaceName 的一个实例，则返回的 object 向下转型到类型 Attribute；否则抛出一个异常。
抛出：
NullPointerException - （未经检查的异常）如果 object 为 null，则抛出该异常。
ClassCastException - （未经检查的异常）如果 object 不是 interfaceName 的一个实例，则抛出该异常。

verifyCategoryForValue

public static void verifyCategoryForValue(Class<?> category,
                                          Attribute attribute)
验证给定的属性类别对象是否等于给定属性值对象的类别。如果等于，则此方法只返回而不执行任何操作。如果不等于，则此方法抛出一个异常。

参数：
category - 要测试的属性类别。
attribute - 要测试的属性值。
抛出：
NullPointerException - （未经检查的异常）如果 category 为 null，或者如果 attribute 为 null，则抛出该异常。
IllegalArgumentException - （未经检查的异常）如果 category 不等于 attribute 的类别，则抛出该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateTimeSyntax (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 DateTimeSyntax

java.lang.Object
    继承者  javax.print.attribute.DateTimeSyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
DateTimeAtCompleted, DateTimeAtCreation, DateTimeAtProcessing, JobHoldUntil
public abstract class DateTimeSyntax
extends Object
implements Serializable, Cloneable

类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。

实际上，日期-时间属性存储为类 java.util.Date 的值。通过调用 getValue() 可以获取日期-时间属性的日期值。日期-时间属性的日期值在构造时建立（请参见 DateTimeSyntax(Date)）。构造之后，日期-时间属性的值是不可变的。

要构造年、月、日、时、分等独立值的日期-时间属性，请使用 java.util.Calendar 对象构造 java.util.Date 对象，然后使用 java.util.Date 对象构造日期-时间属性。要将日期-时间属性转换为年、月、日、时、分等独立值，请创建 java.util.Calendar 对象，并将其设置为日期-时间属性的 java.util.Date。类 DateTimeSyntax 存储其值，形式为 java.util.Date，而不是 java.util.Calendar，因为 java.util.Date 与 java.util.Calendar 相比，前者在存储时通常占用较少的内存，并花费较少的时间。

另请参见：
序列化表格

构造方法摘要
protected DateTimeSyntax(Date value)
构造具有给定 java.util.Date 值的新的日期-时间属性。
方法摘要
boolean | equals(Object object) 返回此日期-时间属性是否等效于传入的对象。
Date | getValue() 返回此日期-时间属性的 java.util.Date 值。
int | hashCode() 返回此日期-时间属性的哈希码值。
String | toString() 返回对应于此日期-时间属性的字符串值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DateTimeSyntax

protected DateTimeSyntax(Date value)
构造具有给定 java.util.Date 值的新的日期-时间属性。

参数：
value - java.util.Date 值。
抛出：
NullPointerException - （未经检查的异常）如果 theValue 为 null，则抛出该异常。
方法详细信息

getValue

public Date getValue()
返回此日期-时间属性的 java.util.Date 值。

返回：
日期。

equals

public boolean equals(Object object)
返回此日期-时间属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 DateTimeSyntax 的一个实例。
  3. 此日期-时间属性的 java.util.Date 值和 object 的 java.util.Date 值相等。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此日期-时间属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此日期-时间属性的哈希码值。哈希码是此属性的 java.util.Date 值的代码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回对应于此日期-时间属性的字符串值。字符串值就是此属性的转换为字符串的 java.util.Date 值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 DocAttribute

所有超级接口：
Attribute, Serializable
所有已知实现类：
Chromaticity, Compression, DocumentName, Finishings, Media, MediaName, MediaPrintableArea, MediaSizeName, MediaTray, NumberUp, OrientationRequested, PageRanges, PrinterResolution, PrintQuality, SheetCollate, Sides
public interface DocAttribute
extends Attribute

接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。）客户机可以在 Doc 的属性集中包括 DocAttribute，以指定该文档的特征。如果属性实现 PrintRequestAttribute 以及 DocAttribute，则客户机可以在指定打印作业的属性集中包括该属性，以指定该作业中所有文档的特征。

另请参见：
DocAttributeSet, PrintRequestAttributeSet

方法摘要
从接口 javax.print.attribute.Attribute 继承的方法
getCategory, getName

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 DocAttributeSet

所有超级接口：
AttributeSet
所有已知实现类：
HashDocAttributeSet
public interface DocAttributeSet
extends AttributeSet

接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。在 Print Service API 中，客户机使用 DocAttributeSet 指定每个文档的特征和打印作业设置，以便将其应用到个别文档中。

DocAttributeSet 就是其构造方法和更改操作保证附加不变量的 AttributeSet，即 DocAttributeSet 中的所有属性值必须是接口 DocAttribute 的实例。下面重新指定了 add(Attribute) 和 addAll(AttributeSet) 操作，以保证此附加不变量。

方法摘要
boolean | add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

方法详细信息

add

boolean add(Attribute attribute)
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。

指定者：
接口 AttributeSet 中的 add
参数：
attribute - 要添加到此属性集的属性值。
返回：
如果此属性集由于调用而发生改变（即：给定的属性值还不是此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 add() 操作，则抛出该异常。
ClassCastException - （未经检查的异常）如果 attribute 不是接口 DocAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

addAll

boolean addAll(AttributeSet attributes)
将指定集合中的所有元素添加到此属性中。该结果与使用指定集合中的每个元素将 add(Attribute) 操作成功地应用到此属性集中相同。如果指定集合中的任何类别都与此属性集中的类别不相同，则 addAll() 操作会有效地修改此属性集，使其值成为两个集合的并集。

如果正在进行此操作的同时修改了指定的集合，则 addAll() 操作的行为是不确定的。

如果 addAll() 操作抛出一个异常，则对此属性集状态的影响取决于实现方法；在异常点之前，不一定将指定集合中的元素添加到了此属性集。

指定者：
接口 AttributeSet 中的 addAll
参数：
attributes - 要将其元素添加到此属性集中的属性。
返回：
如果此属性集由于调用而发生改变，则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 addAll() 方法，则抛出该异常。
ClassCastException - （未经检查的异常）如果指定集中的某个元素不是接口 DocAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果指定的集合为 null，则抛出该异常。
另请参见：
add(Attribute)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EnumSyntax (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 EnumSyntax

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
Chromaticity, ColorSupported, Compression, Fidelity, Finishings, JobSheets, JobState, JobStateReason, Media, MultipleDocumentHandling, OrientationRequested, PDLOverrideSupported, PresentationDirection, PrinterIsAcceptingJobs, PrinterState, PrinterStateReason, PrintQuality, ReferenceUriSchemesSupported, Severity, SheetCollate, Sides
public abstract class EnumSyntax
extends Object
implements Serializable, Cloneable

类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。扩展类 EnumSyntax 的枚举类提供一组枚举值（对象），它是该枚举类的单一实例；例如：

     public class Bach extends EnumSyntax {
         public static final Bach JOHANN_SEBASTIAN     = new Bach(0);
         public static final Bach WILHELM_FRIEDEMANN   = new Bach(1);
         public static final Bach CARL_PHILIP_EMMANUEL = new Bach(2);
         public static final Bach JOHANN_CHRISTIAN     = new Bach(3);
         public static final Bach P_D_Q                = new Bach(4);

         private static final String[] stringTable = {
             "Johann Sebastian Bach",
              "Wilhelm Friedemann Bach",
              "Carl Philip Emmanuel Bach",
              "Johann Christian Bach",
              "P.D.Q. Bach"
         };

         protected String[] getStringTable() {
             return stringTable;
         }

         private static final Bach[] enumValueTable = {
             JOHANN_SEBASTIAN,
              WILHELM_FRIEDEMANN,
              CARL_PHILIP_EMMANUEL,
              JOHANN_CHRISTIAN,
              P_D_Q
         };

         protected EnumSyntax[] getEnumValueTable() {
             return enumValueTable;
         }
     }
然后，可以写入使用 == 和 != 运算符的代码，以测试枚举值；例如：
     Bach theComposer;
     . . .
     if (theComposer == Bach.JOHANN_SEBASTIAN) {
         System.out.println ("The greatest composer of all time!");
     }
枚举类的 equals() 方法仅为相同的对象 (==) 执行测试。

通过调用 toString() 可以将枚举值转换为字符串。从枚举类提供的表获取字符串。

实际上，枚举值就是一个整数，枚举类中每个枚举值都有一个不同的整数。通过调用 getValue() 可以获取枚举值的整数值。枚举值的整数值是在构造时建立的（请参阅 EnumSyntax(int)）。由于构造方法是受保护的，唯一可能的枚举值是枚举类中声明的单一对象；在运行时无法创建其他枚举值。

可以定义枚举类的子类，该枚举类会使用其他枚举值对它进行扩展。子类的枚举值的整数值不必与超类的枚举值的整数值不同；==、!=、equals() 和 toString() 方法仍将正常运行，即使子类使用一些与超类相同的整数值。但是，使用枚举类和子类的应用程序在超类和子类中可能需要具有不同的整数值。

另请参见：
序列化表格

构造方法摘要
protected EnumSyntax(int value)
使用给定的整数值构造一个新枚举值。
方法摘要
Object | clone() 返回此枚举值的一个副本，该副本保留了枚举值的语义，它是与此枚举值相同的对象。
protected EnumSyntax[] | getEnumValueTable() 返回此枚举值的枚举类的枚举值表。
protected int | getOffset() 返回此枚举值的枚举类使用的最小整数值。
protected String[] | getStringTable() 返回此枚举值的枚举类的字符串表。
int | getValue() 返回此枚举值的整数值。
int | hashCode() 返回此枚举值的哈希码值。
protected Object | readResolve() 在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。
String | toString() 返回对应于此枚举值的字符串值。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

EnumSyntax

protected EnumSyntax(int value)
使用给定的整数值构造一个新枚举值。

参数：
value - 整数值。
方法详细信息

getValue

public int getValue()
返回此枚举值的整数值。

返回：
值

clone

public Object clone()
返回此枚举值的一个副本，该副本保留了枚举值的语义，它是与此枚举值相同的对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

hashCode

public int hashCode()
返回此枚举值的哈希码值。哈希码正好是此枚举值的整数值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回对应于此枚举值的字符串值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

readResolve

protected Object readResolve()
                      throws ObjectStreamException
在对象输入过程中，将此反序列化的枚举实例转换为枚举属性类中定义的适当枚举值。

返回：
单个枚举值，它存储在 getEnumValueTable() 返回的枚举值表中的索引 i-L 处，其中 i 是此枚举值的整数值，L 是 getOffset() 返回的值。
抛出：
ObjectStreamException - 如果无法对流反序列化
InvalidObjectException - 如果枚举值表为 null，此枚举值的整数值与枚举值表中的元素不对应，或枚举值表中的对应元素为 null，则抛出该异常。（注：InvalidObjectException 是 ObjectStreamException 的一个子类，ObjectStreamException 由 readResolve() 声明抛出。

getStringTable

protected String[] getStringTable()
返回此枚举值的枚举类的字符串表。假设枚举类的整数值的范围是 L..L+N-1，其中 L 是 getOffset() 返回的值，N 是字符串表的长度。字符串表中索引 i-L 处的元素是 toString() 针对其整数值是 i 的枚举值所返回的值。如果任何枚举值都不使用上面范围中的整数，则对应的表元素保持为 null。

默认实现返回 null。如果枚举类（类 EnumSyntax 的子类）不重写此方法，以返回非 null 字符串表，并且子类不重写 toString() 方法，则基类 toString() 方法将仅返回此枚举值的整数值的字符串表示形式。

返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回此枚举值的枚举类的枚举值表。假设枚举类的整数值的范围是 L..L+N-1，其中 L 是 getOffset() 返回的值，N 是枚举值表的长度。枚举值表中索引 i-L 处的元素是其整数值是 i 的枚举值对象；在枚举实例的反序列化过程中，readResolve() 方法需要此元素来保持单一语义。如果任何枚举值都不使用上面范围中的整数，则对应的表元素保持为 null。

默认实现返回 null。如果枚举类（类 EnumSyntax 的子类）不重写此方法，以返回非 null 枚举值表，并且子类不重写 readResolve() 方法，则每当从对象输入流反序列化枚举实例时，基类 readResolve() 方法将抛出一个异常。

返回：
值表

getOffset

protected int getOffset()
返回此枚举值的枚举类使用的最小整数值。

默认实现返回 0。如果枚举类（类 EnumSyntax 的子类）使用以非 0 开始的整数值，则重写子类中的此方法。

返回：
最小枚举值的偏移量。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HashAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 HashAttributeSet

java.lang.Object
    继承者  javax.print.attribute.HashAttributeSet
所有已实现的接口：
Serializable, AttributeSet
直接已知子类：
HashDocAttributeSet, HashPrintJobAttributeSet, HashPrintRequestAttributeSet, HashPrintServiceAttributeSet
public class HashAttributeSet
extends Object
implements AttributeSet, Serializable

类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。

另请参见：
序列化表格

构造方法摘要
 | HashAttributeSet() 构造一个新的、空属性集。
 | HashAttributeSet(Attribute attribute) 构造一个最初使用给定属性填充的新属性集。
 | HashAttributeSet(Attribute[] attributes) 构造一个最初使用给定数组中的值填充的新属性集。
protected | HashAttributeSet(Attribute[] attributes, Class<?> interfaceName) 构造一个新的属性集，其中该属性集的成员限于给定的接口。
protected | HashAttributeSet(Attribute attribute, Class<?> interfaceName) 构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。
 | HashAttributeSet(AttributeSet attributes) 构造一个最初使用给定集合中的值填充的新属性集。
protected | HashAttributeSet(AttributeSet attributes, Class<?> interfaceName) 构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。
protected | HashAttributeSet(Class<?> interfaceName) 构造一个新的空属性集，其中该属性集的成员限于给定的接口。
方法摘要
boolean | add(Attribute attribute) 如果指定的属性不存在，则将它添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有属性。
boolean | addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
void | clear() 从此属性集中移除所有属性。
boolean | containsKey(Class<?> category) 如果此属性集包含指定类别的属性，则返回 true。
boolean | containsValue(Attribute attribute) 如果此属性集包含给定的属性，则返回 true。
boolean | equals(Object object) 比较指定的对象与此属性集的相等性。
Attribute | get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
int | hashCode() 返回此属性集的哈希码值。
boolean | isEmpty() 如果此属性集不包含任何属性，则返回 true。
boolean | remove(Attribute attribute) 从此属性集移除指定的属性（如果存在）。
boolean | remove(Class<?> category) 从此属性集移除此类别的任何属性（如果存在）。
int | size() 返回此属性集中属性的数量。
Attribute[] | toArray() 返回此集合中包含的属性的数组。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

HashAttributeSet

public HashAttributeSet()
构造一个新的、空属性集。

HashAttributeSet

public HashAttributeSet(Attribute attribute)
构造一个最初使用给定属性填充的新属性集。

参数：
attribute - 要添加到此集合的属性值。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

HashAttributeSet

public HashAttributeSet(Attribute[] attributes)
构造一个最初使用给定数组中的值填充的新属性集。通过将 attributes 数组中的元素从索引 0 开始按顺序添加到该集合来填充新的属性集。因此，如果该数组包含重复的属性值或属性类别，则后面的数组元素可以替换前面的数组元素。

参数：
attributes - 要添加到该集合的属性值的数组。如果为 null，则构造一个空属性集。
抛出：
NullPointerException - （未经检查的异常）如果 attributes 的任何元素为 null，则抛出该异常。

HashAttributeSet

public HashAttributeSet(AttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集。

参数：
attributes - 从中初始化此集合的属性集。如果为 null，则构造一个空属性集。

HashAttributeSet

protected HashAttributeSet(Class<?> interfaceName)
构造一个新的空属性集，其中该属性集的成员限于给定的接口。

参数：
interfaceName - 此属性集的所有成员必须是其实例的接口。假设是接口 Attribute 或其子接口。
抛出：
NullPointerException - 如果 interfaceName 为 null。

HashAttributeSet

protected HashAttributeSet(Attribute attribute,
                           Class<?> interfaceName)
构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。

参数：
attribute - 要添加到此集合的属性值。
interfaceName - 此属性集的所有成员必须是其实例的接口。假设是接口 Attribute 或其子接口。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。
NullPointerException - 如果 interfaceName 为 null。
ClassCastException - （未经检查的异常）如果 attribute 不是 interfaceName 的一个实例，则抛出该异常。

HashAttributeSet

protected HashAttributeSet(Attribute[] attributes,
                           Class<?> interfaceName)
构造一个新的属性集，其中该属性集的成员限于给定的接口。通过将 attributes 数组中的元素从索引 0 开始按顺序添加到该集合来填充新的属性集。因此，如果该数组包含重复的属性值或属性类别，则后面的数组元素可以替换前面的数组元素。

参数：
attributes - 要添加到该集合的属性值的数组。如果为 null，则构造一个空属性集。
interfaceName - 此属性集的所有成员必须是其实例的接口。假设是接口 Attribute 或其子接口。
抛出：
NullPointerException - （未经检查的异常）如果 attributes 的任何元素为 null，则抛出该异常。
NullPointerException - 如果 interfaceName 为 null。
ClassCastException - （未经检查的异常）如果 attributes 的元素不是 interfaceName 的一个实例，则抛出该异常。

HashAttributeSet

protected HashAttributeSet(AttributeSet attributes,
                           Class<?> interfaceName)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。

参数：
attributes - 要初始化该集合的属性值的集合。如果为 null，则构造一个空属性集。
interfaceName - 此属性集的所有成员必须是其实例的接口。假设是接口 Attribute 或其子接口。
抛出：
ClassCastException - （未经检查的异常）如果 attributes 的元素不是 interfaceName 的一个实例，则抛出该异常。
方法详细信息

get

public Attribute get(Class<?> category)
返回此属性集在给定的属性类别中包含的属性值。如果此属性集在给定的属性类别中不包含任何属性值，则返回 null。

指定者：
接口 AttributeSet 中的 get
参数：
category - 将返回其关联的属性值的属性类别。它必须是实现接口 Attribute 的 Class。
返回：
此属性集中包含的给定属性类别中的属性值，如果此属性集在给定的属性类别中不包含任何属性值，则返回 null。
抛出：
NullPointerException - （未经检查的异常）如果 category 为 null，则抛出该异常。
ClassCastException - （未经检查的异常）如果 category 不是实现接口 Attribute 的 Class，则抛出该异常。

add

public boolean add(Attribute attribute)
如果指定的属性不存在，则将它添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有属性。

指定者：
接口 AttributeSet 中的 add
参数：
attribute - 要添加到此属性集的属性值。
返回：
如果此属性集由于调用而发生改变（即：给定的属性值还不是此属性集的成员），则返回 true。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 add() 操作，则抛出该异常。

remove

public boolean remove(Class<?> category)
从此属性集移除此类别的任何属性（如果存在）。如果 category 为 null，则 remove() 不执行任何操作，并返回 false。

指定者：
接口 AttributeSet 中的 remove
参数：
category - 要从此属性集移除的属性类别。
返回：
如果此属性集由于调用而发生改变（即给定的属性类别已经成为此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 remove() 操作，则抛出该异常。

remove

public boolean remove(Attribute attribute)
从此属性集移除指定的属性（如果存在）。如果 attribute 为 null，则 remove() 不执行任何操作，并返回 false。

指定者：
接口 AttributeSet 中的 remove
参数：
attribute - 从此属性集移除的属性值。
返回：
如果此属性集由于调用而发生改变（即：给定的属性值已经成为此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 remove() 操作，则抛出该异常。

containsKey

public boolean containsKey(Class<?> category)
如果此属性集包含指定类别的属性，则返回 true。

指定者：
接口 AttributeSet 中的 containsKey
参数：
category - 将测试其是否存在于此属性集中的类别。
返回：
如果此属性集包含指定类别的一个属性值，则返回 true。

containsValue

public boolean containsValue(Attribute attribute)
如果此属性集包含给定的属性，则返回 true。

指定者：
接口 AttributeSet 中的 containsValue
参数：
attribute - 将测试其是否存在于此属性集中的值。
返回：
如果此属性集包含给定的属性值，则返回 true。

addAll

public boolean addAll(AttributeSet attributes)
将指定集合中的所有元素添加到此属性中。该结果与使用指定集合中的每个元素将 add(Attribute) 操作成功地应用到此属性集中相同。如果正在进行此操作的同时修改了指定的集合，则 addAll(AttributeSet) 操作的行为是不确定的。

如果 addAll(AttributeSet) 操作抛出一个异常，则对此属性集状态的影响取决于实现方法；在异常点之前，不一定将指定集合中的元素添加到了此属性集。

指定者：
接口 AttributeSet 中的 addAll
参数：
attributes - 要将其元素添加到此属性集中的属性。
返回：
如果此属性集由于调用而发生改变，则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 addAll(AttributeSet) 方法，则抛出该异常。
NullPointerException - （未经检查的异常）如果指定集合中的某一元素为 null，或该集合为 null，则抛出该异常。
另请参见：
add(Attribute)

size

public int size()
返回此属性集中属性的数量。如果此属性集包含的元素多于 Integer.MAX_VALUE ，则返回 Integer.MAX_VALUE。

指定者：
接口 AttributeSet 中的 size
返回：
此属性集中属性的数量。

toArray

public Attribute[] toArray()
从接口 AttributeSet 复制的描述
返回此集合中包含的属性的数组。

指定者：
接口 AttributeSet 中的 toArray
返回：
作为数组包含在此集合中的属性，如果 AttributeSet 为空，则返回零长度。

clear

public void clear()
从此属性集中移除所有属性。

指定者：
接口 AttributeSet 中的 clear
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 clear() 操作，则抛出该异常。

isEmpty

public boolean isEmpty()
如果此属性集不包含任何属性，则返回 true。

指定者：
接口 AttributeSet 中的 isEmpty
返回：
如果此属性集不包含任何属性，则返回 true。

equals

public boolean equals(Object object)
比较指定的对象与此属性集的相等性。如果给定的对象也是一个属性集，并且两个属性集包含相同的属性类别到属性值的映射关系，则返回 true。这确保了 equals() 方法能跨越 AttributeSet 接口的不同实现正常运行。

指定者：
接口 AttributeSet 中的 equals
覆盖：
类 Object 中的 equals
参数：
object - 要与此属性集进行相等性比较的对象。
返回：
如果指定对象等于此属性集，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此属性集的哈希码值。属性集的哈希码被定义为 AttributeSet 中每个条目的哈希码的总和。这确保了 t1.equals(t2) 意味对于任何两个属性集 t1 和 t2 而言，都存在 t1.hashCode()==t2.hashCode()，这是 Object.hashCode() 的通用协定所要求的。

指定者：
接口 AttributeSet 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此属性集的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HashDocAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 HashDocAttributeSet

java.lang.Object
    继承者  javax.print.attribute.HashAttributeSet
        继承者  javax.print.attribute.HashDocAttributeSet
所有已实现的接口：
Serializable, AttributeSet, DocAttributeSet
public class HashDocAttributeSet
extends HashAttributeSet
implements DocAttributeSet, Serializable

类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。

另请参见：
序列化表格

构造方法摘要
HashDocAttributeSet()
构造一个新的空哈希文档属性集。
HashDocAttributeSet(DocAttribute attribute)
构造一个最初使用给定值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 DocAttribute 接口。
方法摘要
从类 javax.print.attribute.HashAttributeSet 继承的方法
add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait
从接口 javax.print.attribute.DocAttributeSet 继承的方法
add, addAll
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

构造方法详细信息

HashDocAttributeSet

public HashDocAttributeSet()
构造一个新的空哈希文档属性集。

HashDocAttributeSet

public HashDocAttributeSet(DocAttribute attribute)
构造一个最初使用给定值填充的新哈希文档属性集。

参数：
attribute - 要添加到此集合的属性值。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

HashDocAttributeSet

public HashDocAttributeSet(DocAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希文档属性集。通过将 attributes 数组中的元素从索引 0 开始按顺序添加到该集合来填充新的属性集。因此，如果该数组包含重复的属性值或属性类别，则后面的数组元素可以替换前面的数组元素。

参数：
attributes - 要添加到该集合的属性值的数组。如果为 null，则构造一个空属性集。
抛出：
NullPointerException - （未经检查的异常）如果 attributes 的任何元素为 null，则抛出该异常。

HashDocAttributeSet

public HashDocAttributeSet(DocAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 DocAttribute 接口。

参数：
attributes - 要初始化该集合的属性值的集合。如果为 null，则构造一个空属性集。
抛出：
ClassCastException - （未经检查的异常）如果 attributes 的元素不是 DocAttribute 的一个实例，则抛出该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HashPrintJobAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 HashPrintJobAttributeSet

java.lang.Object
    继承者  javax.print.attribute.HashAttributeSet
        继承者  javax.print.attribute.HashPrintJobAttributeSet
所有已实现的接口：
Serializable, AttributeSet, PrintJobAttributeSet
public class HashPrintJobAttributeSet
extends HashAttributeSet
implements PrintJobAttributeSet, Serializable

类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。

另请参见：
序列化表格

构造方法摘要
HashPrintJobAttributeSet()
构造一个新的空哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute attribute)
构造一个最初使用给定值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintJobAttribute 接口。
方法摘要
从类 javax.print.attribute.HashAttributeSet 继承的方法
add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait
从接口 javax.print.attribute.PrintJobAttributeSet 继承的方法
add, addAll
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

构造方法详细信息

HashPrintJobAttributeSet

public HashPrintJobAttributeSet()
构造一个新的空哈希打印作业属性集。

HashPrintJobAttributeSet

public HashPrintJobAttributeSet(PrintJobAttribute attribute)
构造一个最初使用给定值填充的新哈希打印作业属性集。

参数：
attribute - 要添加到此集合的属性值。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

HashPrintJobAttributeSet

public HashPrintJobAttributeSet(PrintJobAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希打印作业属性集。通过将 attributes 数组中的元素从索引 0 开始按顺序添加到该集合来填充新的属性集。因此，如果该数组包含重复的属性值或属性类别，则后面的数组元素可以替换前面的数组元素。

参数：
attributes - 要添加到该集合的属性值的数组。如果为 null，则构造一个空属性集。
抛出：
NullPointerException - （未经检查的异常）如果 attributes 的任何元素为 null，则抛出该异常。

HashPrintJobAttributeSet

public HashPrintJobAttributeSet(PrintJobAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintJobAttribute 接口。

参数：
attributes - 要初始化该集合的属性值的集合。如果为 null，则构造一个空属性集。
抛出：
ClassCastException - （未经检查的异常）如果 attributes 的元素不是 PrintJobAttribute 的一个实例，则抛出该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HashPrintRequestAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 HashPrintRequestAttributeSet

java.lang.Object
    继承者  javax.print.attribute.HashAttributeSet
        继承者  javax.print.attribute.HashPrintRequestAttributeSet
所有已实现的接口：
Serializable, AttributeSet, PrintRequestAttributeSet
public class HashPrintRequestAttributeSet
extends HashAttributeSet
implements PrintRequestAttributeSet, Serializable

类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。

另请参见：
序列化表格

构造方法摘要
HashPrintRequestAttributeSet()
构造一个新的空打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute attribute)
构造一个最初使用给定值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 (PrintRequestAttributeSe 接口。
方法摘要
从类 javax.print.attribute.HashAttributeSet 继承的方法
add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait
从接口 javax.print.attribute.PrintRequestAttributeSet 继承的方法
add, addAll
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

构造方法详细信息

HashPrintRequestAttributeSet

public HashPrintRequestAttributeSet()
构造一个新的空打印请求属性集。

HashPrintRequestAttributeSet

public HashPrintRequestAttributeSet(PrintRequestAttribute attribute)
构造一个最初使用给定值填充的新打印请求属性集。

参数：
attribute - 要添加到此集合的属性值。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

HashPrintRequestAttributeSet

public HashPrintRequestAttributeSet(PrintRequestAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印请求属性集。通过将 attributes 数组中的元素从索引 0 开始按顺序添加到该集合来填充新的属性集。因此，如果该数组包含重复的属性值或属性类别，则后面的数组元素可以替换前面的数组元素。

参数：
attributes - 要添加到该集合的属性值的数组。如果为 null，则构造一个空属性集。
抛出：
NullPointerException - （未经检查的异常）如果 attributes 的任何元素为 null，则抛出该异常。

HashPrintRequestAttributeSet

public HashPrintRequestAttributeSet(PrintRequestAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 (PrintRequestAttributeSe 接口。

参数：
attributes - 要初始化该集合的属性值的集合。如果为 null，则构造一个空属性集。
抛出：
ClassCastException - （未经检查的异常）如果 attributes 的元素不是 (PrintRequestAttributeSe 的一个实例，则抛出该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HashPrintServiceAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 HashPrintServiceAttributeSet

java.lang.Object
    继承者  javax.print.attribute.HashAttributeSet
        继承者  javax.print.attribute.HashPrintServiceAttributeSet
所有已实现的接口：
Serializable, AttributeSet, PrintServiceAttributeSet
public class HashPrintServiceAttributeSet
extends HashAttributeSet
implements PrintServiceAttributeSet, Serializable

类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

另请参见：
序列化表格

构造方法摘要
HashPrintServiceAttributeSet()
构造一个新的空哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute attribute)
构造一个最初使用给定值填充的新哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintServiceAttribute 接口。
方法摘要
从类 javax.print.attribute.HashAttributeSet 继承的方法
add, addAll, clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait
从接口 javax.print.attribute.PrintServiceAttributeSet 继承的方法
add, addAll
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

构造方法详细信息

HashPrintServiceAttributeSet

public HashPrintServiceAttributeSet()
构造一个新的空哈希打印服务属性集。

HashPrintServiceAttributeSet

public HashPrintServiceAttributeSet(PrintServiceAttribute attribute)
构造一个最初使用给定值填充的新哈希打印服务属性集。

参数：
attribute - 要添加到此集合的属性值。
抛出：
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

HashPrintServiceAttributeSet

public HashPrintServiceAttributeSet(PrintServiceAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印服务属性集。通过将 attributes 数组中的元素从索引 0 开始按顺序添加到该集合来填充新的属性集。因此，如果该数组包含重复的属性值或属性类别，则后面的数组元素可以替换前面的数组元素。

参数：
attributes - 要添加到该集合的属性值的数组。如果为 null，则构造一个空属性集。
抛出：
NullPointerException - （未经检查的异常）如果 attributes 的任何元素为 null，则抛出该异常。

HashPrintServiceAttributeSet

public HashPrintServiceAttributeSet(PrintServiceAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintServiceAttribute 接口。

参数：
attributes - 要初始化该集合的属性值的集合。如果为 null，则构造一个空属性集。
抛出：
ClassCastException - （未经检查的异常）如果 attributes 的任何元素不是 PrintServiceAttribute 的一个实例，则抛出该异常。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


IntegerSyntax (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 IntegerSyntax

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
Copies, JobImpressions, JobImpressionsCompleted, JobKOctets, JobKOctetsProcessed, JobMediaSheets, JobMediaSheetsCompleted, JobPriority, JobPrioritySupported, NumberOfDocuments, NumberOfInterveningJobs, NumberUp, PagesPerMinute, PagesPerMinuteColor, QueuedJobCount
public abstract class IntegerSyntax
extends Object
implements Serializable, Cloneable

类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。

实际上，整数属性正好是一个整数。通过调用 getValue() 可以获取整数属性的整数值。整数属性的整数值是在构造时建立的（请参阅 IntegerSyntax(int)）。构造之后，整数属性的值是不可变的。

另请参见：
序列化表格

构造方法摘要
protected | IntegerSyntax(int value) 使用给定的整数值构造一个新的整数属性。
protected | IntegerSyntax(int value, int lowerBound, int upperBound) 使用给定的整数值构造一个新的整数属性，它必须位于给定的范围内。
方法摘要
boolean | equals(Object object) 返回此整数属性是否等效于传入的对象。
int | getValue() 返回此整数属性的整数值。
int | hashCode() 返回此整数属性的哈希码值。
String | toString() 返回对应于此整数属性的字符串值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

IntegerSyntax

protected IntegerSyntax(int value)
使用给定的整数值构造一个新的整数属性。

参数：
value - 整数值。

IntegerSyntax

protected IntegerSyntax(int value,
                        int lowerBound,
                        int upperBound)
使用给定的整数值构造一个新的整数属性，它必须位于给定的范围内。

参数：
value - 整数值。
lowerBound - 下边界。
upperBound - 上边界。
抛出：
IllegalArgumentException - （未经检查的异常）如果 value 小于 lowerBound 或大于 upperBound，则抛出该异常。
方法详细信息

getValue

public int getValue()
返回此整数属性的整数值。

返回：
整数值

equals

public boolean equals(Object object)
返回此整数属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 IntegerSyntax 的一个实例。
  3. 此整数属性的值和 object 的值相等。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此整数属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此整数属性的哈希码值。哈希码正好是此整数属性的整数值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回对应于此整数属性的字符串值。字符串值就是此整数属性的转换为字符串的整数值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintJobAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 PrintJobAttribute

所有超级接口：
Attribute, Serializable
所有已知实现类：
Chromaticity, Copies, DateTimeAtCompleted, DateTimeAtCreation, DateTimeAtProcessing, Destination, Fidelity, Finishings, JobHoldUntil, JobImpressions, JobImpressionsCompleted, JobKOctets, JobKOctetsProcessed, JobMediaSheets, JobMediaSheetsCompleted, JobMessageFromOperator, JobName, JobOriginatingUserName, JobPriority, JobSheets, JobState, JobStateReasons, Media, MediaName, MediaPrintableArea, MediaSizeName, MediaTray, MultipleDocumentHandling, NumberOfDocuments, NumberOfInterveningJobs, NumberUp, OrientationRequested, OutputDeviceAssigned, PageRanges, PresentationDirection, PrinterResolution, PrintQuality, SheetCollate, Sides
public interface PrintJobAttribute
extends Attribute

PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。Print Service 实例将许多 PrintJobAttributes 添加到“打印作业”的属性集中，以报告“打印作业”的状态。如果属性实现 PrintRequestAttribute 以及 PrintJobAttribute，则客户机可以包括属性集中的属性，以便为“打印作业”指定属性的值。

另请参见：
PrintRequestAttributeSet, PrintJobAttributeSet

方法摘要
从接口 javax.print.attribute.Attribute 继承的方法
getCategory, getName

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ResolutionSyntax (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 ResolutionSyntax

java.lang.Object
    继承者  javax.print.attribute.ResolutionSyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
PrinterResolution
public abstract class ResolutionSyntax
extends Object
implements Serializable, Cloneable

类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。

分辨率属性的值由两项组成，即反向进纸分辨率和进纸分辨率。通过提供两个值和指示测量该值的单位可以构造分辨率属性。提供一些方法以返回分辨率属性的值，并指示将要返回的值的单位。两个最常见分辨率单位是每英寸点数 (dpi) 和每厘米点数 (dpcm)，为指示这些单位，提供了导出的常量 DPI 和 DPCM。

一旦构造之后，分辨率属性的值就是不可变的。

设计

分辨率属性的反向进纸分辨率和进纸分辨率值是使用每 100 英寸的点数为单位 (dphi) 进行内部存储的。使用 dphi（比方说，而不是公制单位）存储该值允许在 dpi 和 dphi 之间以及 dpcm 和 dphi 之间进行精确的整数算法转换：1 dpi = 100 dphi，1 dpcm = 254 dphi。因此，可以使用任一单位将该值存储到分辨率属性，并从其获取，精度上没有任何损失。如果使用浮点表示形式，则不能保证这一点。但是，如果使用一个单位创建分辨率属性的值，使用其他单位进行获取，则通常会发生舍入误差；例如，600 dpi 将被舍入为 236 dpcm，而实际值（五位数）为 236.22 dpcm。

使用通用单位 dphi 内部存储该值可以比较这两种分辨率属性，无需考虑创建值的单位；例如，300 dpcm 将相当于 762 dpi，因为它们都存储为 76200 dphi。尤其是，查询服务可以基于它们序列化表示形式的相等性来匹配分辨率属性，而不管它们用哪种单位创建。另外，对内部存储使用整数可以允许执行精确的相等性比较，如果使用浮点表示形式，则不保证这一点。

导出的常量 DPI 实际上是转换因子，将一个以 dpi 为单位的值乘以转换因子可以获得以 dphi 为单位的值。同样，导出的常量 DPCM 实际上是转换因子，将一个以 dpcm 为单位的值乘以转换因子可以获得以 dphi 为单位的值。客户机可以通过提供其自已的转换因子指定使用某些单位（ dpi 或 dpcm 除外）的分辨率值。但是，由于只注意支持外部单位 dpi 和 dpcm 而选择了内部单位 dphi，所以不能保证对客户机单位的转换因子将是一个准确的整数。如果转换因子不是一个准确的整数，则使用客户机单位的分辨率值不能精确地存储。

另请参见：
序列化表格

字段摘要
static int | DPCM 指示每厘米点数为单位 (dpcm) 的值。
static int | DPI 指示每英寸点数为单位 (dpi) 的值。
构造方法摘要
ResolutionSyntax(int crossFeedResolution, int feedResolution, int units)
根据给定项构造一个新的分辨率属性。
方法摘要
boolean | equals(Object object) 返回此分辨率属性是否等效于传入的对象。
int | getCrossFeedResolution(int units) 返回给定单位的此分辨率属性的反向进纸分辨率。
protected int | getCrossFeedResolutionDphi() 返回以 dphi 为单位的此分辨率属性的反向进纸分辨率。
int | getFeedResolution(int units) 返回给定单位的此分辨率属性的进纸分辨率。
protected int | getFeedResolutionDphi() 返回以 dphi 为单位的此分辨率属性的进纸分辨率。
int[] | getResolution(int units) 获取给定单位的此分辨率属性的分辨率值。
int | hashCode() 返回此分辨率属性的哈希码值。
boolean | lessThanOrEquals(ResolutionSyntax other) 确定此分辨率属性的值是否小于或等于给定分辨率属性的值。
String | toString() 返回此分辨率属性的字符串版本。
String | toString(int units, String unitsName) 返回给定单位的此分辨率属性的字符串版本。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

DPI

public static final int DPI
指示每英寸点数为单位 (dpi) 的值。它实际上是转换因子，dpi 乘以该转换因子得到 dphi (100)。

另请参见：
常量字段值

DPCM

public static final int DPCM
指示每厘米点数为单位 (dpcm) 的值。它实际上是转换因子，dpcm 乘以该转换因子得到 dphi (254)。

另请参见：
常量字段值
构造方法详细信息

ResolutionSyntax

public ResolutionSyntax(int crossFeedResolution,
                        int feedResolution,
                        int units)
根据给定项构造一个新的分辨率属性。

参数：
crossFeedResolution - 反向进纸分辨率。
feedResolution - 进纸分辨率。
units - 单位转换因子，即 DPI 或 DPCM。
抛出：
IllegalArgumentException - （未经检查的异常）如果 crossFeedResolution < 1 或 feedResolution < 1 或 units < 1，则抛出该异常。
方法详细信息

getResolution

public int[] getResolution(int units)
获取给定单位的此分辨率属性的分辨率值。将该值舍入为最接近的整数。

参数：
units - 单位转换因子，即 DPI 或 DPCM。
返回：
包含索引 0 处的反向进纸分辨率和索引 1 处的进纸分辨率的两元素数组。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getCrossFeedResolution

public int getCrossFeedResolution(int units)
返回给定单位的此分辨率属性的反向进纸分辨率。将该值舍入为最接近的整数。

参数：
units - 单位转换因子，即 DPI 或 DPCM。
返回：
反向进纸分辨率。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getFeedResolution

public int getFeedResolution(int units)
返回给定单位的此分辨率属性的进纸分辨率。将该值舍入为最接近的整数。

参数：
units - 单位转换因子，即 DPI 或 DPCM。
返回：
进纸分辨率。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

toString

public String toString(int units,
                       String unitsName)
返回给定单位的此分辨率属性的字符串版本。该字符串采用的形式是 "CxF U"，其中 C 为反向进纸分辨率，F 为进纸分辨率，U 为单位名称。将该值舍入为最接近的整数。

参数：
units - 单位转换因子，即 DPI 或 DPCM。
unitsName - 单位名称字符串，即 "dpi" 或 "dpcm"。如果为 null，则没有任何单位名称附加到该结果。
返回：
此分辨率属性的字符串版本。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

lessThanOrEquals

public boolean lessThanOrEquals(ResolutionSyntax other)
确定此分辨率属性的值是否小于或等于给定分辨率属性的值。如果以下条件都为 true，则为 true：
  • 此属性的反向进纸分辨率小于或等于 other 属性的反向进纸分辨率。
  • 此属性的进纸分辨率小于或等于 other 属性的进纸分辨率。

参数：
other - 与之比较的分辨率属性。
返回：
如果此分辨率属性小于或等于 other 分辨率属性，则返回 True，否则返回 false。
抛出：
NullPointerException - （未经检查的异常）如果 other 为 null，则抛出该异常。

equals

public boolean equals(Object object)
返回此分辨率属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 ResolutionSyntax 的一个实例。
  3. 此属性的反向进纸分辨率等于 object 的反向进纸分辨率。
  4. 此属性的进纸分辨率等于 object 的进纸分辨率。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此分辨率属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此分辨率属性的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此分辨率属性的字符串版本。此字符串采用的形式是 "CxF dphi"，其中 C 为反向进纸分辨率，F 为进纸分辨率。使用内部单位 dphi 报告该值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getCrossFeedResolutionDphi

protected int getCrossFeedResolutionDphi()
返回以 dphi 为单位的此分辨率属性的反向进纸分辨率。（在子类中使用。）

返回：
反向进纸分辨率。

getFeedResolutionDphi

protected int getFeedResolutionDphi()
返回以 dphi 为单位的此分辨率属性的进纸分辨率。（在子类中使用。）

返回：
进纸分辨率。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintJobAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 PrintJobAttributeSet

所有超级接口：
AttributeSet
所有已知实现类：
HashPrintJobAttributeSet
public interface PrintJobAttributeSet
extends AttributeSet

接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。在 Print Service API 中，服务使用 PrintJobAttributeSet 来报告打印作业的状态。

PrintJobAttributeSet 就是 AttributeSet，其构造方法和更改操作保证一个附加的不变量，即 PrintJobAttributeSet 中的所有属性值必须是接口 PrintJobAttribute 的实例。下面重新指定了 add(Attribute) 和 addAll(AttributeSet) 操作，以保证此附加不变量。

方法摘要
boolean | add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

方法详细信息

add

boolean add(Attribute attribute)
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。

指定者：
接口 AttributeSet 中的 add
参数：
attribute - 要添加到此属性集的属性值。
返回：
如果此属性集由于调用而发生改变（即：给定的属性值还不是此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 add() 操作，则抛出该异常。
ClassCastException - （未经检查的异常）如果 attribute 不是接口 PrintJobAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

addAll

boolean addAll(AttributeSet attributes)
将指定集合中的所有元素添加到此属性中。该结果与使用指定集合中的每个元素将 add(Attribute) 操作成功地应用到此属性集中相同。如果指定集合中的任何类别都与此属性集中的类别不相同，则 addAll() 操作会有效地修改此属性集，使其值成为两个集合的并集。

如果正在进行此操作的同时修改了指定的集合，则 addAll() 操作的行为是不确定的。

如果 addAll() 操作抛出一个异常，则对此属性集状态的影响取决于实现方法；在异常点之前，不一定将指定集合中的元素添加到了此属性集。

指定者：
接口 AttributeSet 中的 addAll
参数：
attributes - 要将其元素添加到此属性集中的属性。
返回：
如果此属性集由于调用而发生改变，则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 addAll() 方法，则抛出该异常。
ClassCastException - （未经检查的异常）如果指定集中的某个元素不是接口 PrintJobAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果指定的集合为 null，则抛出该异常。
另请参见：
add(Attribute)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintRequestAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 PrintRequestAttribute

所有超级接口：
Attribute, Serializable
所有已知实现类：
Chromaticity, Copies, Destination, Fidelity, Finishings, JobHoldUntil, JobImpressions, JobKOctets, JobMediaSheets, JobName, JobPriority, JobSheets, Media, MediaName, MediaPrintableArea, MediaSizeName, MediaTray, MultipleDocumentHandling, NumberUp, OrientationRequested, PageRanges, PresentationDirection, PrinterResolution, PrintQuality, RequestingUserName, SheetCollate, Sides
public interface PrintRequestAttribute
extends Attribute

接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。

使用 PrintRequestAttribute 标记并且可以被标记为 PrintJobAttribute 的属性，它表示作业属性的子集，该子集可以是作业请求规范的一部分。

如果属性实现 DocAttribute 以及 PrintRequestAttribute，则客户机可以包括 Doc 的属性集中的属性，以指定仅与该文档有关的作业设置。

另请参见：
DocAttributeSet, PrintRequestAttributeSet

方法摘要
从接口 javax.print.attribute.Attribute 继承的方法
getCategory, getName

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintRequestAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 PrintRequestAttributeSet

所有超级接口：
AttributeSet
所有已知实现类：
HashPrintRequestAttributeSet
public interface PrintRequestAttributeSet
extends AttributeSet

接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。客户机使用 PrintRequestAttributeSet 指定应用到整个打印作业和打印作业中的所有文档的设置。

PrintRequestAttributeSet 就是 AttributeSet，其构造方法和更改操作保证一个附加不变量，即 PrintRequestAttributeSet 中的所有属性值必须是接口 PrintRequestAttribute 的实例。下面重新指定了 add(Attribute) 和 addAll(AttributeSet) 操作，以保证此附加不变量。

方法摘要
boolean | add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

方法详细信息

add

boolean add(Attribute attribute)
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。

指定者：
接口 AttributeSet 中的 add
参数：
attribute - 要添加到此属性集的属性值。
返回：
如果此属性集由于调用而发生改变（即：给定的属性值还不是此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 add() 操作，则抛出该异常。
ClassCastException - （未经检查的异常）如果 attribute 不是接口 PrintRequestAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

addAll

boolean addAll(AttributeSet attributes)
将指定集合中的所有元素添加到此属性中。该结果与使用指定集合中的每个元素将 add(Attribute) 操作成功地应用到此属性集中相同。如果指定集合中的任何类别都与此属性集中的类别不相同，则 addAll() 操作会有效地修改此属性集，使其值成为两个集合的并集。

如果正在进行此操作的同时修改了指定的集合，则 addAll() 操作的行为是不确定的。

如果 addAll() 操作抛出一个异常，则对此属性集状态的影响取决于实现方法；在异常点之前，不一定将指定集合中的元素添加到了此属性集。

指定者：
接口 AttributeSet 中的 addAll
参数：
attributes - 要将其元素添加到此属性集中的属性。
返回：
如果此属性集由于调用而发生改变，则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 addAll() 方法，则抛出该异常。
ClassCastException - （未经检查的异常）如果指定集中的某个元素不是接口 PrintRequestAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果指定的集合为 null，则抛出该异常。
另请参见：
add(Attribute)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintServiceAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 PrintServiceAttribute

所有超级接口：
Attribute, Serializable
所有已知实现类：
ColorSupported, PagesPerMinute, PagesPerMinuteColor, PDLOverrideSupported, PrinterInfo, PrinterIsAcceptingJobs, PrinterLocation, PrinterMakeAndModel, PrinterMessageFromOperator, PrinterMoreInfo, PrinterMoreInfoManufacturer, PrinterName, PrinterState, PrinterStateReasons, PrinterURI, QueuedJobCount
public interface PrintServiceAttribute
extends Attribute

接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。“打印服务”实例将许多 PrintServiceAttributes 添加到“打印服务”的属性集中，以报告“打印服务”的状态。

另请参见：
PrintServiceAttributeSet

方法摘要
从接口 javax.print.attribute.Attribute 继承的方法
getCategory, getName

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintServiceAttributeSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 PrintServiceAttributeSet

所有超级接口：
AttributeSet
所有已知实现类：
HashPrintServiceAttributeSet
public interface PrintServiceAttributeSet
extends AttributeSet

接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。在“打印服务”API 中，“打印服务”实例使用 PrintServiceAttributeSet 报告打印服务的状态。

PrintServiceAttributeSet 就是 AttributeSet，其构造方法和更改操作保证一个附加的不变量，即 PrintServiceAttributeSet 中的所有属性值必须是接口 PrintServiceAttribute 的实例。下面重新指定了 add(Attribute) 和 addAll(AttributeSet) 操作，以保证此附加不变量。

方法摘要
boolean | add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
从接口 javax.print.attribute.AttributeSet 继承的方法
clear, containsKey, containsValue, equals, get, hashCode, isEmpty, remove, remove, size, toArray

方法详细信息

add

boolean add(Attribute attribute)
如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。

指定者：
接口 AttributeSet 中的 add
参数：
attribute - 要添加到此属性集的属性值。
返回：
如果此属性集由于调用而发生改变（即：给定的属性值还不是此属性集的成员），则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 add() 操作，则抛出该异常。
ClassCastException - （未经检查的异常）如果 attribute 不是接口 PrintServiceAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果 attribute 为 null，则抛出该异常。

addAll

boolean addAll(AttributeSet attributes)
将指定集合中的所有元素添加到此属性中。该结果与使用指定集合中的每个元素将 add(Attribute) 操作成功地应用到此属性集中相同。如果指定集合中的任何类别都与此属性集中的类别不相同，则 addAll() 操作会有效地修改此属性集，使其值成为两个集合的并集。

如果正在进行此操作的同时修改了指定的集合，则 addAll() 操作的行为是不确定的。

如果 addAll() 操作抛出一个异常，则对此属性集状态的影响取决于实现方法；在异常点之前，不一定将指定集合中的元素添加到了此属性集。

指定者：
接口 AttributeSet 中的 addAll
参数：
attributes - 要将其元素添加到此属性集中的属性。
返回：
如果此属性集由于调用而发生改变，则返回 true。
抛出：
UnmodifiableSetException - （未经检查的异常）如果此属性集不支持 addAll() 方法，则抛出该异常。
ClassCastException - （未经检查的异常）如果指定集中的某个元素不是接口 PrintServiceAttribute 的一个实例，则抛出该异常。
NullPointerException - （未经检查的异常）如果指定的集合为 null，则抛出该异常。
另请参见：
add(Attribute)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SetOfIntegerSyntax (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 SetOfIntegerSyntax

java.lang.Object
    继承者  javax.print.attribute.SetOfIntegerSyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
CopiesSupported, JobImpressionsSupported, JobKOctetsSupported, JobMediaSheetsSupported, NumberUpSupported, PageRanges
public abstract class SetOfIntegerSyntax
extends Object
implements Serializable, Cloneable

类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。这包括其值是一个整数范围的属性和其值是一组整数范围的属性。

可以用“字符串形式”构造一个 SetOfIntegerSyntax 的实例。字符串由零或多个用逗号分隔的整数组组成。每个整数组由一个整数、连字符 (-) 分隔的两个整数，或冒号 (:) 分隔的两个整数组成。每个整数由一个或多个十进制数字（0 至 9）组成。空格字符不能在整数中显示，否则被忽略。例如： "", "1", "5-10", "1:2, 4".

也可以使用“数组形式”构造一个 SetOfIntegerSyntax 的实例。数组形式由零个或多个整数组的数组组成，其中每个整数组是长度为 1 或长度为 2 的 int 数组；例如，int[0][]、int[][]{{1}}、int[][]{{5,10}}、int[][]{{1,2},{4}}。

在字符串形式和数组形式中，每个连续的整数组都提供一系列在集合中包括的整数。每组中的第一个整数提供该范围的下边界；第二个整数提供该范围的上边界；如果在组中仅有一个整数，则上边界与下边界相同。如果上边界小于下边界，则它表示一个 null 范围（无值）。如果上边界等于下边界，则它表示由单个值组成的范围。如果上边界大于下边界，则它表示由多个值组成的范围。该范围可以按任意顺序显示，并允许重叠。所有范围的并集给出该集合的内容。一旦构造 SetOfIntegerSyntax 实例之后，其值就是不可变的。

SetOfIntegerSyntax 对象的值实际上以“规范 数组形式”存储。除没有任何 null 范围外，这与数组形式相同；用尽可能少的范围（即：合并重叠范围）表示集合的成员；范围按升序显示；并且将每个范围按形式 {下边界, 上边界} 表示为长度为 2 的 int 数组。将空集表示为零长度数组。

类 SetOfIntegerSyntax 可以进行以下操作：以规范数组形式返回集合的成员、测试给定的整数是否为集合的成员，迭代集合的成员。

另请参见：
序列化表格

构造方法摘要
protected | SetOfIntegerSyntax(int member) 构造一个包含单个整数的新整数集属性。
protected | SetOfIntegerSyntax(int[][] members) 使用以字符串形式给定的成员构造一个新的整数集属性。
protected | SetOfIntegerSyntax(int lowerBound, int upperBound) 构造一个包含单一整数范围的新整数集属性。
protected | SetOfIntegerSyntax(String members) 使用以字符串形式给定的成员构造一个新的整数集属性。
方法摘要
boolean | contains(int x) 确定此整数集属性是否包含给定的值。
boolean | contains(IntegerSyntax attribute) 确定此整数集属性是否包含给定的整数属性的值。
boolean | equals(Object object) 返回此整数集属性是否等效于传入的对象。
int[][] | getMembers() 获取规范数组形式的此整数集属性的成员。
int | hashCode() 返回此整数集属性的哈希码值。
int | next(int x) 确定此整数集属性中的最小整数是否大于给定值。
String | toString() 返回对应于此整数集属性的字符串值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

SetOfIntegerSyntax

protected SetOfIntegerSyntax(String members)
使用以字符串形式给定的成员构造一个新的整数集属性。

参数：
members - 字符串形式的集合成员。如果为 null，则构造一个空集。
抛出：
IllegalArgumentException - （未经检查的异常）如果 members 不遵循正确的语法，则抛出该异常。

SetOfIntegerSyntax

protected SetOfIntegerSyntax(int[][] members)
使用以字符串形式给定的成员构造一个新的整数集属性。

参数：
members - 数组形式的集合成员。如果为 null，则构造一个空集。
抛出：
NullPointerException - （未经检查的异常）如果 members 的任何元素为 null，则抛出该异常。
IllegalArgumentException - （未经检查的异常）如果 members 的任何元素不是长度为 1 或长度为 2 的数组，或者如果 members 中任何非 null 范围的下边界小于零，则抛出该异常。

SetOfIntegerSyntax

protected SetOfIntegerSyntax(int member)
构造一个包含单个整数的新整数集属性。

参数：
member - 集合成员。
抛出：
IllegalArgumentException - （未经检查的异常）如果 member 小于零，则抛出该异常。

SetOfIntegerSyntax

protected SetOfIntegerSyntax(int lowerBound,
                             int upperBound)
构造一个包含单一整数范围的新整数集属性。如果下边界大于上边界（null 范围），则构造一个空集。

参数：
lowerBound - 范围的下边界。
upperBound - 范围的上边界。
抛出：
IllegalArgumentException - （未经检查的异常）如果范围为非 null，并且 lowerBound 小于零，则抛出该异常。
方法详细信息

getMembers

public int[][] getMembers()
获取规范数组形式的此整数集属性的成员。返回的数组是“安全的”；客户机可以在不影响此整数集属性的情况下对它进行更改。

返回：
规范数组形式的此整数集属性的成员。

contains

public boolean contains(int x)
确定此整数集属性是否包含给定的值。

参数：
x - 整数值。
返回：
如果此整数集属性包含值 x，则返回 True，否则返回 false。

contains

public boolean contains(IntegerSyntax attribute)
确定此整数集属性是否包含给定的整数属性的值。

参数：
attribute - 整数属性。
返回：
如果此整数集属性包含 theAttribute 的值，则返回 True，否则返回 false。

next

public int next(int x)
确定此整数集属性中的最小整数是否大于给定值。如果此整数集属性中没有任何整数大于给定值，则返回 -1。（由于整数集属性只包含非负值，所以该集合中始终不显示 -1。）可以使用 next() 方法按升序迭代整数集属性中的整数值，如下所示：
     SetOfIntegerSyntax attribute = . . .;
     int i = -1;
     while ((i = attribute.next (i)) != -1)
         {
         foo (i);
         }

参数：
x - 整数值。
返回：
此整数集属性中大于 x 的最小整数，如果此整数集属性中没有任何整数大于 x，则返回 -1。

equals

public boolean equals(Object object)
返回此整数集属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 SetOfIntegerSyntax 的一个实例。
  3. 此整数集属性的成员和 object 的成员相同。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此整数集属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此整数集属性的哈希码值。哈希码是规范数组形式的范围的上边界和下边界的总数，0 表示空集。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回对应于此整数集属性的字符串值。如果此集合为空，则字符串值为零长度字符串。否则，字符串值是规范数组形式的范围的逗号分隔的列表，其中，如果下边界等于上边界，则可以将每个范围表示为 "i"，否则表示为 "i-j"。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Size2DSyntax (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 Size2DSyntax

java.lang.Object
    继承者  javax.print.attribute.Size2DSyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
MediaSize
public abstract class Size2DSyntax
extends Object
implements Serializable, Cloneable

类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。

二维大小属性的值由两项组成：X 维度和 Y 维度。通过提供两个值和指示测量该值的单位可以构造一个二维大小的属性。提供一些方法以返回二维大小属性的值，并指示将返回值的单位。两个最常见的大小单位是英寸 (in) 和毫米 (mm)，为指示这些单位，提供了导出的常量 INCH 和 MM。

一旦构造之后，二维大小属性的值就是不可变的。

设计

将二维大小属性的 X 和 Y 维度值在内部存储为整数，单位是微米 (µm)，其中 1 微米 = 10-6 米 = 1/1000 毫米 = 1/25400 英寸。这使要表示的维度精确到 1/1000 毫米 (= 1 µm) 或 1/100 英寸 (= 254 µm)。如果用 2 的负次幂表示小数英寸，这使表示的维度精确到 1/8 英寸 (= 3175 µm)，而不是 1/16 英寸（因为 1/16 英寸不等于一个整数微米）。

以通用单位微米的形式内部存储该维度可以比较这两种大小的属性，无需考虑创建它们的单位；例如，8.5 英寸将相当于 215.9 毫米，因为他们都存储为 215900 微米。例如，查询服务可以基于其序列化表示形式的相等性来匹配分辨率属性，无论它们用哪种单位创建。对内部存储使用整数可以允许执行精确的相等性比较，如果使用内部浮点表示形式，则不保证这一点。注意，如果查找公制单位的美国信函大小介质，您必须搜索大小为 215.9 x 279.4 毫米的介质；舍入为整数 216 x 279 毫米将不匹配。

导出的常量 INCH 实际上是转换因子，将一个以英寸 为单位的值乘以该转换因子可以获得以微米为单位的值。同样，导出的常量 MM 实际上也是转换因子，将一个以毫米为单位的值乘以该转换因子可以获得以微米为单位的值。客户机可以通过提供其自已的转换因子来指定使用某些单位（英寸或毫米除外）的分辨率值。但是，由于选择内部单位微米时只考虑支持外部单位英寸和毫米，所以不能保证针对客户机单位的转换因子是一个准确的整数。如果转换因子不是一个准确的整数，则使用客户机单位的分辨率值不能精确地存储。

另请参见：
序列化表格

字段摘要
static int | INCH 指示单位为英寸 (in) 的值。
static int | MM 指示单位为毫米 (mm) 的值。
构造方法摘要
protected | Size2DSyntax(float x, float y, int units) 根据给定的浮点值构造一个新的二维大小属性。
protected | Size2DSyntax(int x, int y, int units) 根据给定的整数值构造一个新的二维大小属性。
方法摘要
boolean | equals(Object object) 返回此二维大小属性是否等效于传入的对象。
float[] | getSize(int units) 获取给定单位的此二维大小属性的维度作为浮点值。
float | getX(int units) 返回给定单位的此二维大小属性的 X 维度作为浮点值。
protected int | getXMicrometers() 返回此二维大小属性的 X 维度（以微米为单位）。
float | getY(int units) 返回给定单位的此二维大小属性的 Y 维度作为浮点值。
protected int | getYMicrometers() 返回此二维大小属性的 Y 维度（以微米为单位）。
int | hashCode() 返回此二维大小属性的哈希码值。
String | toString() 返回此二维大小属性的字符串版本。
String | toString(int units, String unitsName) 返回给定单位的此二维大小属性的字符串版本。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

INCH

public static final int INCH
指示单位为英寸 (in) 的值。它实际上是转换因子，英寸乘以该转换因子得到微米 (25400)。

另请参见：
常量字段值

MM

public static final int MM
指示单位为毫米 (mm) 的值。它实际上是转换因子，毫米乘以该转换因子得到微米 (1000)。

另请参见：
常量字段值
构造方法详细信息

Size2DSyntax

protected Size2DSyntax(float x,
                       float y,
                       int units)
根据给定的浮点值构造一个新的二维大小属性。

参数：
x - X 维度。
y - Y 维度。
units - 单位转换因子，即 INCH 或 MM。
抛出：
IllegalArgumentException - （未经检查的异常）如果 x < 0 或 y < 0 或 units < 1。

Size2DSyntax

protected Size2DSyntax(int x,
                       int y,
                       int units)
根据给定的整数值构造一个新的二维大小属性。

参数：
x - X 维度。
y - Y 维度。
units - 单位转换因子，即 INCH 或 MM。
抛出：
IllegalArgumentException - （未经检查的异常）如果 x < 0 或 y < 0 或 units < 1。
方法详细信息

getSize

public float[] getSize(int units)
获取给定单位的此二维大小属性的维度作为浮点值。

参数：
units - 单位转换因子，即 INCH 或 MM。
返回：
包含索引 0 处的 X 维度和索引 1 处的 Y 维度的两元素数组。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getX

public float getX(int units)
返回给定单位的此二维大小属性的 X 维度作为浮点值。

参数：
units - 单位转换因子，即 INCH 或 MM。
返回：
X 维度。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getY

public float getY(int units)
返回给定单位的此二维大小属性的 Y 维度作为浮点值。

参数：
units - 单位转换因子，即 INCH 或 MM。
返回：
Y 维度。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

toString

public String toString(int units,
                       String unitsName)
返回给定单位的此二维大小属性的字符串版本。该字符串采用的形式是 "XxY U"，其中 X 为 X 维度，Y 为 Y 维度，U 为单位名称。以浮点形式显示该值。

参数：
units - 单位转换因子，即 INCH 或 MM。
unitsName - 单位名称字符串，即 "in" 或 "mm"。如果为 null，则没有任何单位名称附加到该结果。
返回：
此二维大小属性的字符串版本。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

equals

public boolean equals(Object object)
返回此二维大小属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 Size2DSyntax 的一个实例。
  3. 此属性的 X 维度等于 object 的 X 维度。
  4. 此属性的 Y 维度等于 object 的 Y 维度。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此二维大小属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此二维大小属性的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
返回此二维大小属性的字符串版本。该字符串采用的形式是 "XxY um"，其中 X 为 X 维度，Y 为 Y 维度。使用内部单位微米报告该值。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getXMicrometers

protected int getXMicrometers()
返回此二维大小属性的 X 维度（以微米为单位）。（在子类中使用。）

返回：
X 维度（单位微米）。

getYMicrometers

protected int getYMicrometers()
返回此二维大小属性的 Y 维度（以微米为单位）。（在子类中使用。）

返回：
Y 维度（微米）。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SupportedValuesAttribute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
接口 SupportedValuesAttribute

所有超级接口：
Attribute, Serializable
所有已知实现类：
CopiesSupported, JobImpressionsSupported, JobKOctetsSupported, JobMediaSheetsSupported, JobPrioritySupported, NumberUpSupported
public interface SupportedValuesAttribute
extends Attribute

接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。例如，如果“打印服务”实例支持 Copies 属性，则该“打印服务”实例将具有 CopiesSupported 属性，它是一个 SupportedValuesAttribute，该属性提供客户机为 Copies 属性指定的合法值。

方法摘要
从接口 javax.print.attribute.Attribute 继承的方法
getCategory, getName

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextSyntax (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 TextSyntax

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
DocumentName, JobMessageFromOperator, JobName, JobOriginatingUserName, OutputDeviceAssigned, PrinterInfo, PrinterLocation, PrinterMakeAndModel, PrinterMessageFromOperator, PrinterName, RequestingUserName
public abstract class TextSyntax
extends Object
implements Serializable, Cloneable

类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。文本属性包括指示自然语言的语言环境。因此，文本属性总是表示本地化字符串。一旦构造之后，文本属性的值就是不可变的。

另请参见：
序列化表格

构造方法摘要
protected TextSyntax(String value, Locale locale)
使用指定的字符串和语言环境构造 TextAttribute。
方法摘要
boolean | equals(Object object) 返回此文本属性是否等效于传入的对象。
Locale | getLocale() 返回此文本属性的文本字符串的自然语言（语言环境）。
String | getValue() 返回此文本属性的文本字符串。
int | hashCode() 返回此文本属性的哈希码。
String | toString() 返回标识此文本属性的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

TextSyntax

protected TextSyntax(String value,
                     Locale locale)
使用指定的字符串和语言环境构造 TextAttribute。

参数：
value - 文本字符串。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未经检查的异常）如果 value 为 null，则抛出该异常。
方法详细信息

getValue

public String getValue()
返回此文本属性的文本字符串。

返回：
文本字符串。

getLocale

public Locale getLocale()
返回此文本属性的文本字符串的自然语言（语言环境）。

返回：
语言环境

hashCode

public int hashCode()
返回此文本属性的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object object)
返回此文本属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 TextSyntax 的一个实例。
  3. 此文本属性的底层字符串和 object 的底层字符串相等。
  4. 此文本属性的语言环境和 object 的语言环境相等。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此文本属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回标识此文本属性的字符串。该字符串是该属性的底层文本字符串。

覆盖：
类 Object 中的 toString
返回：
标识此对象的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnmodifiableSetException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 UnmodifiableSetException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.lang.RuntimeException
                继承者  javax.print.attribute.UnmodifiableSetException
所有已实现的接口：
Serializable
public class UnmodifiableSetException
extends RuntimeException

当由于设置不可修改而无法执行请求的操作时，抛出该异常。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
UnmodifiableSetException()
构造不带详细消息的 UnsupportedOperationException。
UnmodifiableSetException(String message)
构造带指定详细消息的 UnmodifiableSetException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnmodifiableSetException

public UnmodifiableSetException()
构造不带详细消息的 UnsupportedOperationException。

UnmodifiableSetException

public UnmodifiableSetException(String message)
构造带指定详细消息的 UnmodifiableSetException。

参数：
message - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


URISyntax (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute
类 URISyntax

java.lang.Object
    继承者  javax.print.attribute.URISyntax
所有已实现的接口：
Serializable, Cloneable
直接已知子类：
Destination, PrinterMoreInfo, PrinterMoreInfoManufacturer, PrinterURI
public abstract class URISyntax
extends Object
implements Serializable, Cloneable

类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。一旦构造之后，URI 属性的值就是不可变的。

另请参见：
序列化表格

构造方法摘要
protected URISyntax(URI uri)
构造带有指定 URI 的 URI 属性。
方法摘要
boolean | equals(Object object) 返回此 URI 属性是否等效于传入的对象。
URI | getURI() 返回此 URI 属性的 URI 值。
int | hashCode() 返回此 URI 属性的哈希码。
String | toString() 返回标识此 URI 属性的字符串。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

URISyntax

protected URISyntax(URI uri)
构造带有指定 URI 的 URI 属性。

参数：
uri - URI。
抛出：
NullPointerException - （未经检查的异常） 如果 uri 为 null，则抛出该异常。
方法详细信息

getURI

public URI getURI()
返回此 URI 属性的 URI 值。

返回：
URI。

hashCode

public int hashCode()
返回此 URI 属性的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object object)
返回此 URI 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 URISyntax 的一个实例。
  3. 此 URI 属性的底层 URI 和 object 的底层 URI 相等。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 URI 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回标识此 URI 属性的字符串。该字符串是该属性的底层 URI 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
标识此对象的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.print.attribute (Java 2 Platform SE 6)

 javax.print.attribute
接口
Attribute
AttributeSet
DocAttribute
DocAttributeSet
PrintJobAttribute
PrintJobAttributeSet
PrintRequestAttribute
PrintRequestAttributeSet
PrintServiceAttribute
PrintServiceAttributeSet
SupportedValuesAttribute
类
AttributeSetUtilities
DateTimeSyntax
EnumSyntax
HashAttributeSet
HashDocAttributeSet
HashPrintJobAttributeSet
HashPrintRequestAttributeSet
HashPrintServiceAttributeSet
IntegerSyntax
ResolutionSyntax
SetOfIntegerSyntax
Size2DSyntax
TextSyntax
URISyntax
异常
UnmodifiableSetException


javax.print.attribute (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.print.attribute

提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

请参见：
描述

接口摘要
Attribute | 接口 Attribute 是由任何一个打印属性类实现的基本接口，用于指示该类表示某一打印属性。
AttributeSet | 接口 AttributeSet 为打印属性集指定接口。
DocAttribute | 接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
DocAttributeSet | 接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。
PrintJobAttribute | PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
PrintJobAttributeSet | 接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
PrintRequestAttribute | 接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
PrintRequestAttributeSet | 接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。
PrintServiceAttribute | 接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
PrintServiceAttributeSet | 接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。
SupportedValuesAttribute | 接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。

类摘要
AttributeSetUtilities | 类 AttributeSetUtilities 为操作 AttributeSets 提供静态方法。
DateTimeSyntax | 类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
EnumSyntax | 类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
HashAttributeSet | 类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
HashDocAttributeSet | 类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
HashPrintJobAttributeSet | 类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
HashPrintRequestAttributeSet | 类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
HashPrintServiceAttributeSet | 类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。
IntegerSyntax | 类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
ResolutionSyntax | 类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
SetOfIntegerSyntax | 类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
Size2DSyntax | 类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
TextSyntax | 类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
URISyntax | 类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

异常摘要
UnmodifiableSetException 当由于设置不可修改而无法执行请求的操作时，抛出该异常。

软件包 javax.print.attribute 的描述

提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

什么是属性？

设置打印作业时，客户端会指定两件事情：打印数据和处理指令。打印数据是要打印的实际内容。处理指令告知打印机如何打印该打印数据，如：使用什么介质，打印多少副本，在纸上是单面打印还是双面打印。客户端使用 Java Print Service API 的属性定义来指定这些处理指令。

打印数据和处理指令都是独立的实体。这意味着：您可以在不同时间使用不同的处理指令打印同一打印数据。

  • 例如，您可以在美国信函大小的白纸上双面、装订打印 20 张幻灯片演示文稿副本作为演讲的讲义；还可以在美国信函大小的透明介质上单面打印一份相同的幻灯片演示文稿作为演讲的实际幻灯片。
  • 您可以在不同时间使用相同的处理指令打印不同的数据。例如，您可以将默认处理指令设置为：美国信函大小的纸张、双面、装订。每当打印一项作业时，会使用这些设置进行打印，除非显式重写它们。

处理指令不指定打印作业处理该请求的方式；每条处理指令仅是对打印作业结果的描述。打印作业确定实现处理指令所指定结果的方式。将处理指令表示为描述项可为实现打印作业提供更大的灵活性。

属性类别和值

每个打印机都有一组功能，如在不同大小的纸张上打印或打印多个副本。每个功能都有一个范围值。例如，打印机的方向功能可能有以下范围值：[landscape, portrait]。对于每个打印请求，可以将该功能设置为这些值之一。Java Print Service API 使用术语属性类别指打印机功能，使用术语属性值指该功能的值。

在 Java Print Service API 中，通过实现 Attribute 接口的 Java 类来表示属性类别。属性值是这样的类或其某个子类的实例。例如，要指定副本数，应用程序会构造一个具有所需副本数的 Copies 类的实例，并将 Copies 实例用作打印请求的一部分。在这种情况下，Copies 类表示属性类别，Copies 实例表示属性值。

属性职责

将打印作业提交给打印机时，客户端将提供描述打印数据特征的属性（如，文档名称），以及应如何打印打印数据（如，双面、五份）。如果打印作业由多部分打印数据组成，则不同部分可能具有不同的处理指令，如将 8 × 11 英寸的介质用于第一个文档，11 × 17 英寸的介质用于另一个文档。

打印机开始处理打印作业之后，关于该作业的其他信息将可供使用，可能包括：作业状态（如完成 或排队）和到目前为止已打印的页数。这些信息片段也是属性。属性还可描述打印机本身，如：打印机名称、打印机位置和已排队的作业数。

Java Print Service API 使用 Attribute 的五个子接口定义这些不同类型的属性：

  • DocAttribute 指定每个文档的特征和应用到每个文档的打印作业设置。
  • PrintRequestAttribute 指定应用到整个打印作业和打印作业中所有文档的设置。
  • PrintJobAttribute 报告打印作业的状态。
  • PrintServiceAttribute 报告打印服务的状态。
  • SupportedValuesAttribute 为另一个属性提供支持的值。
每个属性类实现一个或多个这些标记子接口，以指示在 API 中可以使用该属性的位置。如果属性类实现多个标记子接口，则可以在多个上下文中使用该属性。例如，介质属性可以作为 DocAttribute 应用到打印作业中的一个文档，或作为 PrintRequestAttribute 应用到整个打印作业。某些低级别属性从不用于其自身，但是，总是可以将它们汇集到高级别属性中。这此低级别属性类仅实现接口 Attribute，不能实现任何标记子接口。

Java Print Service API 定义了一组标准属性类，它可以按照 Internet Printing Protocol (IPP) 版本 1.1 对属性进行建模。标准属性类位于子包 javax.print.attribute.standard 中，目的是保持实际属性类在概念上与包 javax.print.attribute 中定义的一般设备分开。

属性集

在提交打印作业时，客户端通常需要提供多个处理指令。例如，客户端可能需要指定大小为 A4 的介质和横向方向。要发送多个处理指令，客户端将属性收集到 Java Print Service API 通过 AttributeSet 接口所表示的属性集中。

AttributeSet 接口类似于 Map 接口：它提供键到值的映射，其中每个键都是唯一的，并且只能包含一个值。但是，AttributeSet 接口设计用于专门支持 Java Print Service API 的需求。AttributeSet 要求：

  1. AttributeSet 中的每个键对应于一个类别，键的值只能是属性值之一，它属于该键表示的类别。因此，与 Map 不同，AttributeSet 限制了键的可能值：不能将属性类别设置为不属于该类别的属性值。
  2. 在同一集合中，不能存在同一类别的两个属性。例如，属性集合决不能同时包含“单面”属性和“双面”属性，因为这两个属性会导致打印机指令冲突。
  3. 只可以将实现 Attribute 接口的属性添加到该集合。

javax.print.attribute 包中包括了作为属性集接口具体实现的 HashAttributeSet。HashAttributeSet 提供基于哈希映射的属性集。您可以使用此实现，或提供自已的接口 AttributeSet 实现。

Java Print Service API 提供属性集的四个规范，它们限于仅包含四种属性之一，如属性职责一节所讨论的：

  • DocAttributeSet
  • PrintRequestAttributeSet
  • PrintJobAttributeSet
  • PrintServiceAttributeSet
注意，这里仅列出了四种属性集，但是有五种属性。接口 SupportedValuesAttribute 表示为另一个属性提供支持值的属性。永远不可能将支持值属性汇集到属性集中，因此不存在为它们定义的属性集子接口。

在某些上下文中，属性集是只读的，这意味着只允许客户端检查属性集的内容，但不能更改它们。在其他上下文中，属性集是可读写的，这意味着允许客户端检查和更改属性集的内容。对于只读属性集，调用更改操作会抛出 UnmodifiableSetException。

包 javax.print.attribute 包括每个属性集子接口的一个具体实现：

  • HashDocAttributeSet
  • HashPrintRequestAttributeSet,
  • HashPrintJobAttributeSet,
  • HashPrintServiceAttributeSet.
所有这些类都扩展 HashAttributeSet，并强制要求只允许属性集包含相应类型属性的限制。

属性类设计

属性值是一个小的原子数据项，如整数或枚举值。Java Print Service API 不使用基本数据类型（如 int）来表示属性值，原因如下：
  • 基本数据类型不是类型安全的。例如，编译器不应允许将“copies”属性值用于“sides”属性。
  • 一些属性必须表示为几个值的记录。打印机分辨率就是一个例子，它需要两个数（如，表示 600 × 300 dpi 的 600 和 300）。
对于类型安全性和要统一表示所有属性，Java Print Service API 将每个属性类别定义为类，如类 Copies、类 Sides 和 类 PrinterResolution。每个属性类可以包装一个或多个包含属性值的基本数据项。属性集操作在添加属性、在同一类别中查找现有属性和查找给定其类别的属性时经常执行属性类别对象之间的比较。因为属性类别由类表示，所以使用 Class.equals 方法可以执行快速的属性值比较。

尽管 Java Print Service API 包括大量不同的属性类别，但是仅存在很少的不同类型的属性值。大多数属性可由少量数据类型表示，如：整数值、整数范围、文本或整数值的枚举。类别接受的属性值类型称为属性的抽象语法。为了提供一致性并减少代码重复，Java Print Service API 定义了抽象语法类，以表示每个抽象语法，并且只要可能，可以将这些类用作标准属性的父级。抽象语法类是：

  • EnumSyntax 提供类型安全的枚举，其中枚举值表示为单个对象。每个枚举都是包装隐藏 int 值的枚举类实例。
  • IntegerSyntax 是用于整数值属性的抽象语法。
  • TextSyntax 是用于文本值属性的抽象语法，并且包括立提供文本字符串的自然语言的语言环境。
  • SetOfIntegerSyntax 是表示整数范围或整数集的属性的抽象语法。
  • ResolutionSyntax 是表示分辨率值（如 600×300 dpi）的属性的抽象语法。
  • Size2DSyntax 是表示二维大小（如，纸张大小为 8.5 × 11 英寸）的属性的抽象语法。
  • DateTimeSyntax 是其值为日期和时间的属性的抽象语法。
  • URISyntax 是其值为统一资源定位符的属性的抽象语法。
抽象语法类独立于使用它们的属性。事实上，与打印无关的应用程序可以使用抽象语法类。虽然多数标准属性类会扩展某个抽象语法类，但不需要任何属性类扩展上述类之一。抽象语法类仅提供许多属性类可以共享的便捷实现。

每个属性类可以直接或间接实现 Attribute 接口，以便将其标记为打印属性。在某些上下文的限制属性集中出现的属性类也实现 Attribute 的一个或多个子接口。多数属性类也扩展适当的抽象语法类，以获取该实现。考虑 Sides 属性类：

public class Sides
  extends EnumSyntax
  implements DocAttribute, PrintRequestAttribute, PrintJobAttribute
  {
  public final Object getCategory()
    {
    return Sides.class;
    }
  ...
  }

由于每个属性类会实现 Attribute，所以每个属性类必须提供返回属性类别的 getCategory 方法的实现。对于属性 Sides，getCategory 方法返回 Sides.class。getCategory 方法最终确保了标准属性类的所有供应商定义的子类都显示在同一类别中。每个属性对象在构造之后都是不可变的，这样可以随意地传递属性对象引用。要获取不同的属性值，请构造不同的属性对象。

属性供应商

Java Print Service API 被设计成可让供应商：
  • 为 javax.print.attribute.standard 中定义的所有标准属性定义新的特定于供应商的值。
  • 定义表示供应商打印机专用功能（标准属性已不支持）的新属性类别。
要为属性定义一个新值，客户端可以使用任意值在运行时构造此属性的实例。但是，使用 EnumSyntax 的抽象语法类的枚举属性在编译时将所有的可能属性值指定为属性类的单个实例。这意味着在运行时无法构造新的枚举值。要为标准枚举属性定义新的特定于供应商的值，供应商必须定义一个指定单个新实例的新属性类。要确保新的属性值与标准属性值在相同的类别中，新的属性类必须是标准属性类的子类。

要定义新的属性类别，供应商需要定义新的属性类。此属性类（与标准属性类类似）实现 Attribute 或其子接口之一，并扩展抽象语法类。供应商可以使用现有的抽象语法类，或者定义新的抽象语法类。无论在哪里（如在 AttributeSet 中）使用 Attribute，都可以使用供应商定义的新属性。

使用属性

典型的打印应用程序使用 PrintRequestAttributeSet，因为打印请求属性是客户端通常指定的属性类型。下面的示例介绍如何创建打印请求属性的属性集，并查找可以按照指定的属性打印文档的打印机：

FileInputStream psStream;
try {
   psstream = new FileInputStream("file.ps");
} catch (FileNotFoundException ffne) {
}
if (psstream == null) {
return;
}
//Set the document type.  See the DocFlavor documentation for
//more information.
DocFlavor psInFormat = DocFlavor.INPUT_STREAM.POSTSCRIPT;
Doc myDoc = new SimpleDoc(pstream, psInFormat, null);
PrintRequestAttributeSet aset = new HashPrintRequestAttributeSet();
aset.add(new Copies(5));
aset.add(MediaSize.A4);
aset.add(Sides.DUPLEX);

PrintService[] services =
                PrintServiceLookup.lookupPrintServices(psInFormat, aset);
if (services.length > 0) {
   DocPrintJob job = services[0].createPrintJob();
   try {
        job.print(myDoc, aset);
   } catch (PrintException pe) {}
}

请注意：在 javax.print API 中，只有方法中显式地记录 null 引用具有有意义的解释时，方法的 null 引用参数才是正确的。与之相反的用法是不正确的编码，可能立即或在稍后某一时间导致运行时异常。IllegalArgumentException 和 NullPointerException 是针对这种情况的典型的、可接受的运行时异常的示例。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.print.attribute 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print.attribute 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.print.attribute.AttributeSetUtilities
    • javax.print.attribute.DateTimeSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.EnumSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.HashAttributeSet (implements javax.print.attribute.AttributeSet, java.io.Serializable)
      • javax.print.attribute.HashDocAttributeSet (implements javax.print.attribute.DocAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintJobAttributeSet (implements javax.print.attribute.PrintJobAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintRequestAttributeSet (implements javax.print.attribute.PrintRequestAttributeSet, java.io.Serializable)
      • javax.print.attribute.HashPrintServiceAttributeSet (implements javax.print.attribute.PrintServiceAttributeSet, java.io.Serializable)
    • javax.print.attribute.IntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.ResolutionSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.SetOfIntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.Size2DSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • javax.print.attribute.TextSyntax (implements java.lang.Cloneable, java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.lang.RuntimeException
          • javax.print.attribute.UnmodifiableSetException
    • javax.print.attribute.URISyntax (implements java.lang.Cloneable, java.io.Serializable)

接口分层结构

  • javax.print.attribute.AttributeSet
    • javax.print.attribute.DocAttributeSet
    • javax.print.attribute.PrintJobAttributeSet
    • javax.print.attribute.PrintRequestAttributeSet
    • javax.print.attribute.PrintServiceAttributeSet
  • java.io.Serializable
    • javax.print.attribute.Attribute
      • javax.print.attribute.DocAttribute
      • javax.print.attribute.PrintJobAttribute
      • javax.print.attribute.PrintRequestAttribute
      • javax.print.attribute.PrintServiceAttribute
      • javax.print.attribute.SupportedValuesAttribute
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.print.attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print.attribute
的使用

使用 javax.print.attribute 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 使用的 javax.print.attribute 中的类
PrintRequestAttributeSet
接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。

javax.print 使用的 javax.print.attribute 中的类
Attribute
接口 Attribute 是由任何一个打印属性类实现的基本接口，用于指示该类表示某一打印属性。
AttributeSet
接口 AttributeSet 为打印属性集指定接口。
DocAttributeSet
接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。
PrintJobAttributeSet
接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
PrintRequestAttributeSet
接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。
PrintServiceAttribute
接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
PrintServiceAttributeSet
接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。

javax.print.attribute 使用的 javax.print.attribute 中的类
Attribute
接口 Attribute 是由任何一个打印属性类实现的基本接口，用于指示该类表示某一打印属性。
AttributeSet
接口 AttributeSet 为打印属性集指定接口。
DocAttribute
接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
DocAttributeSet
接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。
EnumSyntax
类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
HashAttributeSet
类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
IntegerSyntax
类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
PrintJobAttribute
PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
PrintJobAttributeSet
接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
PrintRequestAttribute
接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
PrintRequestAttributeSet
接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。
PrintServiceAttribute
接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
PrintServiceAttributeSet
接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。
ResolutionSyntax
类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。

javax.print.attribute.standard 使用的 javax.print.attribute 中的类
Attribute
接口 Attribute 是由任何一个打印属性类实现的基本接口，用于指示该类表示某一打印属性。
DateTimeSyntax
类 DateTimeSyntax 是一个抽象的基类，它提供其值是日期和时间的所有属性的公共实现。
DocAttribute
接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
EnumSyntax
类 EnumSyntax 是一个抽象的基类，它提供所有“类型安全枚举”对象的公共实现。
IntegerSyntax
类 IntegerSyntax 是一个抽象的基类，它提供具有整数值的所有属性的公共实现。
PrintJobAttribute
PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
PrintRequestAttribute
接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
PrintServiceAttribute
接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
ResolutionSyntax
类 ResolutionSyntax 是一种抽象的基类，它提供表示打印机分辨率的所有属性的公共实现。
SetOfIntegerSyntax
类 SetOfIntegerSyntax 是一种抽象的基类，它提供其值是非负整数集合的所有属性的公共实现。
Size2DSyntax
类 Size2DSyntax 是一种抽象的基类，它提供表示二维大小的所有属性的公共实现。
SupportedValuesAttribute
接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。
TextSyntax
类 TextSyntax 是一种抽象的基类，它提供其值是字符串的所有属性的公共实现。
URISyntax
类 URISyntax 是一种抽象的基类，它提供其值是统一资源标识符 (URI) 的所有属性的公共实现。

javax.print.event 使用的 javax.print.attribute 中的类
PrintJobAttributeSet
接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
PrintServiceAttributeSet
接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。

javax.swing 使用的 javax.print.attribute 中的类
PrintRequestAttributeSet
接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。

javax.swing.text 使用的 javax.print.attribute 中的类
PrintRequestAttributeSet
接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Chromaticity (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Chromaticity

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Chromaticity
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class Chromaticity
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。打印客户机使用此类来指定应如何生成或处理打印数据。它不能描述设备的颜色性能。查询设备的 ColorSupported 属性可以确定该设备是否支持彩色打印。

下表显示了指定单色或彩色文档的 MONOCHROME 或 COLOR 的 Chromaticity 属性的效果。

Chromaticity 属性 | Monochrome Document 上的效果 | Color Document 上的效果
MONOCHROME | 照原样打印，单色 | 单色打印，将彩色转换为灰色阴影
COLOR | 照原样打印，单色 | 照原样打印，彩色

IPP Compatibility: Chromaticity 目前不是 IPP 属性。

另请参见：
序列化表格

字段摘要
static Chromaticity | COLOR 彩色打印。
static Chromaticity | MONOCHROME 单色打印。
构造方法摘要
protected Chromaticity(int value)
构造具有给定整数值的新色度枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 Chromaticity 类的枚举值表。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
protected String[] | getStringTable() 返回 Chromaticity 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MONOCHROME

public static final Chromaticity MONOCHROME
单色打印。

COLOR

public static final Chromaticity COLOR
彩色打印。

构造方法详细信息

Chromaticity

protected Chromaticity(int value)
构造具有给定整数值的新色度枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 Chromaticity 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 Chromaticity 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 Chromaticity 类，类别是 Chromaticity 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 Chromaticity 类，类别名称为 "chromaticity"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ColorSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 ColorSupported

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.ColorSupported
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class ColorSupported
extends EnumSyntax
implements PrintServiceAttribute

ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。处理颜色的所有文档指令均嵌入打印数据中（均不是附加到打印数据外作业的属性）。

注：终端用户可以通过查询 PrinterMoreInfoManufacturer 属性确定颜色支持的特性和细节。

不要混淆 ColorSupported 属性与 Chromaticity 属性。Chromaticity 是客户机可以为作业指定的属性，用于通知打印机以单色还是彩色打印某文档，这可能会导致打印机以单色打印彩色文档。ColorSupported 是打印机描述属性，它通知打印机是否能够以彩色打印，而不管客户机如何指定打印任何特殊文档。

IPP Compatibility: 对于 SUPPORTED，IPP 布尔值为 "true"，对于 NOT_SUPPORTED，IPP 布尔值为 "false"。getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static ColorSupported | NOT_SUPPORTED 该打印机不能进行任何类型的彩色打印。
static ColorSupported | SUPPORTED 该打印机能够进行某些类型的彩色打印，例如高亮颜色或全处理颜色。
构造方法摘要
protected ColorSupported(int value)
构造具有给定整数值的支持新颜色的枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 ColorSupported 类的枚举值表。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
protected String[] | getStringTable() 返回 ColorSupported 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

NOT_SUPPORTED

public static final ColorSupported NOT_SUPPORTED
该打印机不能进行任何类型的彩色打印。

SUPPORTED

public static final ColorSupported SUPPORTED
该打印机能够进行某些类型的彩色打印，例如高亮颜色或全处理颜色。

构造方法详细信息

ColorSupported

protected ColorSupported(int value)
构造具有给定整数值的支持新颜色的枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 ColorSupported 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 ColorSupported 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 ColorSupported 类，类别为 ColorSupported 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 ColorSupported 类，类别名称为 "color-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Compression (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Compression

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Compression
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute
public class Compression
extends EnumSyntax
implements DocAttribute

Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。Compression 是打印数据（文档）的属性，而不是 Print Job 的属性。如果没有指定文档的 Compression 属性，则打印机假定该文档的打印数据是未压缩的（即默认的 Compression 值总是 NONE）。

IPP Compatibility: getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static Compression | COMPRESS UNIX 压缩技术。
static Compression | DEFLATE ZIP 公共域 inflate/deflate 压缩技术。
static Compression | GZIP RFC 1952 中所描述的 GNU zip 压缩技术。
static Compression | NONE 不使用压缩。
构造方法摘要
protected Compression(int value)
构造具有给定整数值的新压缩枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 Compression 类的枚举值表。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
protected String[] | getStringTable() 返回 Compression 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

NONE

public static final Compression NONE
不使用压缩。

DEFLATE

public static final Compression DEFLATE
ZIP 公共域 inflate/deflate 压缩技术。

GZIP

public static final Compression GZIP
RFC 1952 中所描述的 GNU zip 压缩技术。

COMPRESS

public static final Compression COMPRESS
UNIX 压缩技术。

构造方法详细信息

Compression

protected Compression(int value)
构造具有给定整数值的新压缩枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 Compression 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 Compression 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 Compression 类和任何供应商定义的子类，类别是 Compression 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 Compression 类和任何供应商定义的子类，类别名称为 "compression"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Copies (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Copies

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.Copies
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class Copies
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute

Copies 类是整数值形式的打印属性类，它指定了要打印的份数。

在许多设备上，支持的逐份打印数将受到设备上物理输出纸盒的限制，并且可能与支持的非逐份打印数不同。

在多文档打印作业（具有多个文档的作业）上带有值 n 的 Copies 属性的效果取决于（可能是默认的）MultipleDocumentHandling 属性值：

  • SINGLE_DOCUMENT －－ 结果将为组成所有输入文档的单个输出文档的 n 份副本。

  • SINGLE_DOCUMENT_NEW_SHEET －－ 结果将为组成所有输入文档的单个输出文档的 n 份副本，且每个输入文档的首个印张将总是在新介质纸张上开始。

  • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES －－ 结果将为首个输入文档的 n 份副本，后跟第二个输入文档的 n 份副本，……后跟最后一个输入文档的 n 份副本。

  • SEPARATE_DOCUMENTS_COLLATED_COPIES －－ 结果将为首个输入文档，第二个输入文档，……最后一个输入文档，文档组被重复 n 次。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
Copies(int value)
构造具有给定整数值的新副本属性。
方法摘要
boolean | equals(Object object) 返回此副本属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Copies

public Copies(int value)
构造具有给定整数值的新副本属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 1，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此副本属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 Copies 类的实例。
  3. 此副本属性的值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此副本属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 Copies 类，类别为 Copies 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 Copies 类，类别名称为 "copies"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CopiesSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 CopiesSupported

java.lang.Object
    继承者  javax.print.attribute.SetOfIntegerSyntax
        继承者  javax.print.attribute.standard.CopiesSupported
所有已实现的接口：
Serializable, Cloneable, Attribute, SupportedValuesAttribute
public final class CopiesSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute

CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。它限制为单个连续的整数范围，不允许存在多个非重叠范围。

IPP Compatibility: CopiesSupported 属性的规范数组形式给出了要包含于 IPP "copies-supported" 属性中的副本范围的下边界和上边界。有关规范数组形式的解释，请参见 SetOfIntegerSyntax。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
CopiesSupported(int member)
构造一个新的支持副本的属性，它包含单个整数。
CopiesSupported(int lowerBound, int upperBound)
构造一个新的支持副本的属性，它包含一个整数范围。
方法摘要
boolean | equals(Object object) 返回支持副本的此属性是否等于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
从类 javax.print.attribute.SetOfIntegerSyntax 继承的方法
contains, contains, getMembers, hashCode, next, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CopiesSupported

public CopiesSupported(int member)
构造一个新的支持副本的属性，它包含单个整数。即仅支持 Copies 的某个值。

参数：
member - 集合成员。
抛出：
IllegalArgumentException - （未检查的异常）如果 member 小于 1，则抛出此异常。

CopiesSupported

public CopiesSupported(int lowerBound,
                       int upperBound)
构造一个新的支持副本的属性，它包含一个整数范围。即仅支持某个范围内的 Copies 值。

参数：
lowerBound - 范围的下边界。
upperBound - 范围的上边界。
抛出：
IllegalArgumentException - （未检查的异常）如果指定了 null 范围，或指定了 lowerBound 小于 1 的非 null 范围，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回支持副本的此属性是否等于传入的对象。若要相等，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 CopiesSupported 类的实例。
  3. 支持副本的此属性的成员与 object 的成员不相同。

覆盖：
类 SetOfIntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等于此支持副本的属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 CopiesSupported 类，类别为 CopiesSupported 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 CopiesSupported 类，类别名称为 "copies-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateTimeAtCompleted (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 DateTimeAtCompleted

java.lang.Object
    继承者  javax.print.attribute.DateTimeSyntax
        继承者  javax.print.attribute.standard.DateTimeAtCompleted
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class DateTimeAtCompleted
extends DateTimeSyntax
implements PrintJobAttribute

DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。

要从独立的 year、month、day、hour、minute 等值构造 DateTimeAtCompleted 属性，请使用 Calendar 对象来构造一个 Date 对象，然后使用该 Date 对象来构造 DateTimeAtCompleted 属性。要将 DateTimeAtCompleted 属性转换为独立的 year、month、day、hour、minute 等值，请创建一个 Calendar 对象，并根据 DateTimeAtCompleted 属性将它设置为 Date。

IPP Compatibility: 构造 IPP "date-time-at-completed" 属性所需的信息可以按以上描述获取。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
DateTimeAtCompleted(Date dateTime)
构造具有给定 Date 值的新 date-time at completed 属性。
方法摘要
boolean | equals(Object object) 返回此 DateTimeAtCompleted 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
从类 javax.print.attribute.DateTimeSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DateTimeAtCompleted

public DateTimeAtCompleted(Date dateTime)
构造具有给定 Date 值的新 date-time at completed 属性。

参数：
dateTime - Date 值。
抛出：
NullPointerException - （未检查的异常）如果 dateTime 为 null，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 DateTimeAtCompleted 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 DateTimeAtCompleted 类的实例。
  3. 此 DateTimeAtCompleted 属性的 Date 值与 object 的 Date 值相等。

覆盖：
类 DateTimeSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 DateTimeAtCompleted 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 DateTimeAtCompleted 类，类别为 DateTimeAtCompleted 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 DateTimeAtCompleted 类，类别名称为 "date-time-at-completed"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateTimeAtCreation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 DateTimeAtCreation

java.lang.Object
    继承者  javax.print.attribute.DateTimeSyntax
        继承者  javax.print.attribute.standard.DateTimeAtCreation
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class DateTimeAtCreation
extends DateTimeSyntax
implements PrintJobAttribute

DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。

要从独立的 year、month、day、hour、minute 等值构造 DateTimeAtCreation 属性，请使用 Calendar 对象来构造一个 Date 对象，然后使用该 Date 对象来构造 DateTimeAtCreation 属性。要将 DateTimeAtCreation 属性转换为独立的 year、month、day、hour、minute 等值，请创建一个 Calendar 对象，并根据 DateTimeAtCreation 属性将它设置为 Date。

IPP Compatibility: 构造 IPP "date-time-at-creation" 属性所需的信息可以按以上描述获取。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
DateTimeAtCreation(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtCreation 属性。
方法摘要
boolean | equals(Object object) 返回此 DateTimeAtCreation 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
从类 javax.print.attribute.DateTimeSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DateTimeAtCreation

public DateTimeAtCreation(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtCreation 属性。

参数：
dateTime - Date 值。
抛出：
NullPointerException - （未检查的异常）如果 dateTime 为 null，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 DateTimeAtCreation 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 DateTimeAtCreation 类的实例。
  3. 此 DateTimeAtCreation 属性的 Date 值与 object 的 Date 值相等。

覆盖：
类 DateTimeSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 DateTimeAtCreation 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 DateTimeAtCreation 类，类别为 DateTimeAtCreation 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 DateTimeAtCreation 类，类别名称为 "date-time-at-creation"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DateTimeAtProcessing (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 DateTimeAtProcessing

java.lang.Object
    继承者  javax.print.attribute.DateTimeSyntax
        继承者  javax.print.attribute.standard.DateTimeAtProcessing
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class DateTimeAtProcessing
extends DateTimeSyntax
implements PrintJobAttribute

DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。

要从独立的 year、month、day、hour、minute 等值构造 DateTimeAtProcessing 属性，请使用 Calendar 对象来构造一个 Date 对象，然后使用该 Date 对象来构造 DateTimeAtProcessing 属性。要将 DateTimeAtProcessing 属性转换为独立的 year、month、day、hour、minute 等值，请创建一个 Calendar 对象，并根据 DateTimeAtProcessing 属性将它设置为 Date。

IPP Compatibility: 构造 IPP "date-time-at-processing" 属性所需的信息可以按以上描述获取。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
DateTimeAtProcessing(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtProcessing 属性。
方法摘要
boolean | equals(Object object) 返回此 DateTimeAtProcessing 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
从类 javax.print.attribute.DateTimeSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DateTimeAtProcessing

public DateTimeAtProcessing(Date dateTime)
构造具有给定 Date 值的新的 DateTimeAtProcessing 属性。

参数：
dateTime - Date 值。
抛出：
NullPointerException - （未检查的异常）如果 dateTime 为 null，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 DateTimeAtProcessing 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 DateTimeAtProcessing 类的实例。
  3. 此 DateTimeAtProcessing 属性的 Date 值与 object 的 Date 值相等。

覆盖：
类 DateTimeSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 DateTimeAtProcessing 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 DateTimeAtProcessing 类，类别为 DateTimeAtProcessing 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 DateTimeAtProcessing 类，类别名称为 "date-time-at-processing"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Destination (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Destination

java.lang.Object
    继承者  javax.print.attribute.URISyntax
        继承者  javax.print.attribute.standard.Destination
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class Destination
extends URISyntax
implements PrintJobAttribute, PrintRequestAttribute

Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。许多 PrintServices 不支持除打印机设备之外的目标概念，因此将不支持此属性。

此属性的常见用法是希望将输出重定向到某个本地磁盘文件的应用程序：例如 "file:out.prn"。注意 "file:" 的正确构造应使用 File 类的 toURI() 方法来执行 URI 机制的实例。有关更多信息，请参阅该类的文档。

如果目标 URI 是在 PrintRequest 中指定的，并且输出不能通过 PrintService 访问它，则将抛出 PrintException。PrintException 可以实现 URIException 以提供更具体的原因。

IPP Compatibility: Destination 不是 IPP 属性。

另请参见：
序列化表格

构造方法摘要
Destination(URI uri)
构造具有给定 URI 的新目标属性。
方法摘要
boolean | equals(Object object) 返回此目标属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
从类 javax.print.attribute.URISyntax 继承的方法
getURI, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Destination

public Destination(URI uri)
构造具有给定 URI 的新目标属性。

参数：
uri - URI。
抛出：
NullPointerException - （未经检查的异常） 如果 uri 为 null，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此目标属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 Destination 类的实例。
  3. 此目标属性的 URI 与 object 的 URI 相同。

覆盖：
类 URISyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此目标属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 Destination 类，类别为 Destination 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 Destination 类，类别名称为 "spool-data-destination"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 DocumentName

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.DocumentName
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute
public final class DocumentName
extends TextSyntax
implements DocAttribute

DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。DocumentName 是打印数据（文档）的属性，而不是 Print Job 的属性。文档名称是客户机所定义的任意字符串。但是，如果未指定 JobName，则应使用 DocumentName 替代，这意味着 DocumentName 支持规范要求 JobName 的报告，反之亦然。有关更多信息，请参阅 JobName。

IPP Compatibility: 字符串值给出了 IPP 名称值。语言环境给出了 IPP 自然语言。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
DocumentName(String documentName, Locale locale)
构造具有给定文档名称和语言环境的新文档名称属性。
方法摘要
boolean | equals(Object object) 返回此文档名称属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DocumentName

public DocumentName(String documentName,
                    Locale locale)
构造具有给定文档名称和语言环境的新文档名称属性。

参数：
documentName - 文档名称。
locale - 文本字符串的自然语言。null 被解释为意味着 Locale.getDefault() 所返回的默认语言环境
抛出：
NullPointerException - （未经检查的异常）如果 documentName 为 null，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此文档名称属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 DocumentName 类的实例。
  3. 此文档名称属性的底层字符串与 object 的底层字符串相同。
  4. 此文档名称属性的语言环境与 object 的语言环境相同。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此文档名称属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 DocumentName 类，类别为 DocumentName 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 DocumentName 类，类别名称为 "document-name"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Fidelity (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Fidelity

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Fidelity
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class Fidelity
extends EnumSyntax
implements PrintJobAttribute, PrintRequestAttribute

Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。如果指定了 FIDELITY_TRUE，且某个服务不能按照指定精确打印作业，则它必须拒绝该作业。如果指定了 FIDELITY_FALSE，则对打印作业进行合理尝试是可接受的。如果未提供，则默认为 FIDELITY_FALSE。

IPP Compatibility: 对于 FIDELITY_TRUE，IPP 布尔值为 "true"，对于 FIDELITY_FALSE，该布尔值为 "false"。getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。有关 IPP 保真度属性的更完整描述，请参见 RFC 2911 Section 15.1。

另请参见：
序列化表格

字段摘要
static Fidelity | FIDELITY_FALSE 打印机应对打印作业进行合理尝试，即使它不能完全按照指定的要求打印该作业。
static Fidelity | FIDELITY_TRUE 必须完全按照指定的要求打印作业，或者拒绝该作业。
构造方法摘要
protected Fidelity(int value)
构造具有给定整数值的新保真度枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 Fidelity 类的枚举值表。
String | getName() 获取类别名称，这里此属性值是该类别的实例。
protected String[] | getStringTable() 返回 Fidelity 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

FIDELITY_TRUE

public static final Fidelity FIDELITY_TRUE
必须完全按照指定的要求打印作业，或者拒绝该作业。

FIDELITY_FALSE

public static final Fidelity FIDELITY_FALSE
打印机应对打印作业进行合理尝试，即使它不能完全按照指定的要求打印该作业。

构造方法详细信息

Fidelity

protected Fidelity(int value)
构造具有给定整数值的新保真度枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 Fidelity 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 Fidelity 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 Fidelity 类，类别为 Fidelity 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，这里此属性值是该类别的实例。

对于 Fidelity 类，类别名称为 "ipp-attribute-fidelity"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Finishings (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Finishings

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Finishings
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public class Finishings
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。对于多文档打印作业（具有多个文档的作业），MultipleDocumentHandling 属性确定了什么构成了以结束为目的的“副本”。

标准 Finishing 值有：

NONE | STAPLE | EDGE_STITCH
BIND | SADDLE_STITCH | COVER

以下 Finishing 值是更具体的值；它们指示角或边，就好像该文档是一个纵向文档一样：

STAPLE_TOP_LEFT | EDGE_STITCH_LEFT | STAPLE_DUAL_LEFT
STAPLE_BOTTOM_LEFT | EDGE_STITCH_TOP | STAPLE_DUAL_TOP
STAPLE_TOP_RIGHT | EDGE_STITCH_RIGHT | STAPLE_DUAL_RIGHT
STAPLE_BOTTOM_RIGHT | EDGE_STITCH_BOTTOM | STAPLE_DUAL_BOTTOM

STAPLE_XXX 值是相对于文档指定的，就好像该文档是纵向文档一样。如果文档实际上是横向文档，或者反向横向文档，则客户机提供适当的转换值。例如，当保持读取时要定位横向文档的左上角中的某个装订点，客户机提供了 STAPLE_BOTTOM_LEFT 值（因为横向定义为从纵向旋转 +90 度，即逆时针旋转）。另一方面，为了在保持读取时定位反向横向文档的左上角中的某个装订点，客户机提供了 STAPLE_TOP_RIGHT 值（因为反向横向定义为从纵向旋转 -90 度，即顺时针旋转）。

每个装订点相对于文档的角（垂直、水平、呈角度的）取决于实现，这又进而取决于属性值。

Finishings 属性在多文档打印作业（具有多个文档的作业）上的 效果取决于所有文档是否已指定相同绑定，或者是否不同文档指定了不同绑定，并取决于（可能是默认的） MultipleDocumentHandling 属性的值。

  • 如果所有文档均已指定了相同绑定，则 MultipleDocumentHandling 的任何值均有意义，且打印机的处理取决于 MultipleDocumentHandling 值：
    • SINGLE_DOCUMENT －－ 所有输入文档将作为一个输出文档与指定绑定进行绑定。

    • SINGLE_DOCUMENT_NEW_SHEET －－ 所有输入文档将作为一个输出文档与指定绑定进行绑定，且每个输入文档的首份打印将总是从新介质纸张开始。

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES －－ 每个输入文档将与指定绑定进行单独绑定。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES －－ 每个输入文档将与指定绑定进行单独绑定。

  • 如果不同文档已指定不同绑定，则只有两个 MultipleDocumentHandling 值有意义，当提交作业时如果指定了任何其他值，则打印机报告错误：
    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES －－ 每个输入文档将与其自己的指定绑定进行单独绑定。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES －－ 每个输入文档将与其自己的指定绑定进行单独绑定。

IPP Compatibility: Finishings 类封装了可能包含在 IPP "finishings" 属性中的某些 IPP 枚举值，它是一个枚举集合。getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。在 IPP 中， Finishings 是一个多值属性，此 API 目前仅允许指定一个绑定。

另请参见：
序列化表格

字段摘要
static Finishings | BIND 此值指示要将某个绑定应用于文档；绑定的类型和布局是由位置定义的。
static Finishings | COVER 当需要为文档选择非打印（或预打印）封面时指定此值。
static Finishings | EDGE_STITCH 将文档（或多个文档）与沿某个边的一个或多个装订点（金属针脚）绑定。
static Finishings | EDGE_STITCH_BOTTOM 将文档（或多个文档）与沿底边的一个或多个装订点（金属针脚）绑定。
static Finishings | EDGE_STITCH_LEFT 将文档（或多个文档）与沿左边的一个或多个装订点（金属针脚）绑定。
static Finishings | EDGE_STITCH_RIGHT 将文档（或多个文档）与沿右边的一个或多个装订点（金属针脚）绑定。
static Finishings | EDGE_STITCH_TOP 将文档（或多个文档）与沿顶边的一个或多个装订点（金属针脚）绑定。
static Finishings | NONE 不执行绑定。
static Finishings | SADDLE_STITCH 将文档（或多个文档）与沿中折线的一个或多个装订点（金属针脚）绑定。
static Finishings | STAPLE 将文档（或多个文档）与一个或多个装订点进行绑定。
static Finishings | STAPLE_BOTTOM_LEFT 将文档（或多个文档）与左下角中的一个或多个装订点绑定。
static Finishings | STAPLE_BOTTOM_RIGHT 将文档或多个文档与右下角中的一个或多个装订点绑定。
static Finishings | STAPLE_DUAL_BOTTOM 将文档（或多个文档）与沿底边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | STAPLE_DUAL_LEFT 将文档（或多个文档）与沿左边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | STAPLE_DUAL_RIGHT 将文档（或多个文档）与沿右边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | STAPLE_DUAL_TOP 将文档（或多个文档）与沿顶边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | STAPLE_TOP_LEFT 将文档（或多个文档）与左上角中的一个或多个装订点绑定。
static Finishings | STAPLE_TOP_RIGHT 将文档或多个文档与右上角中的一个或多个装订点绑定。
构造方法摘要
protected Finishings(int value)
构造具有给定整数值的新 finishings 绑定枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 Finishings 类的枚举值表。
String | getName() 获取类别名称，此属性值为该类别的实例。
protected int | getOffset() 返回 Finishings 类所使用的最小整数值。
protected String[] | getStringTable() 返回 Finishings 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

NONE

public static final Finishings NONE
不执行绑定。

STAPLE

public static final Finishings STAPLE
将文档（或多个文档）与一个或多个装订点进行绑定。装订点的精确数目和布局由位置定义。

COVER

public static final Finishings COVER
当需要为文档选择非打印（或预打印）封面时指定此值。这并不是由文档本身来取代打印封面（在封面材料介质上）的规范。

BIND

public static final Finishings BIND
此值指示要将某个绑定应用于文档；绑定的类型和布局是由位置定义的。

SADDLE_STITCH

public static final Finishings SADDLE_STITCH
将文档（或多个文档）与沿中折线的一个或多个装订点（金属针脚）绑定。装订点的精确数目和布局以及中折线是由实现和/或位置定义的。

EDGE_STITCH

public static final Finishings EDGE_STITCH
将文档（或多个文档）与沿某个边的一个或多个装订点（金属针脚）绑定。装订点的精确数目和布局由实现和/或位置定义。

STAPLE_TOP_LEFT

public static final Finishings STAPLE_TOP_LEFT
将文档（或多个文档）与左上角中的一个或多个装订点绑定。

STAPLE_BOTTOM_LEFT

public static final Finishings STAPLE_BOTTOM_LEFT
将文档（或多个文档）与左下角中的一个或多个装订点绑定。

STAPLE_TOP_RIGHT

public static final Finishings STAPLE_TOP_RIGHT
将文档或多个文档与右上角中的一个或多个装订点绑定。

STAPLE_BOTTOM_RIGHT

public static final Finishings STAPLE_BOTTOM_RIGHT
将文档或多个文档与右下角中的一个或多个装订点绑定。

EDGE_STITCH_LEFT

public static final Finishings EDGE_STITCH_LEFT
将文档（或多个文档）与沿左边的一个或多个装订点（金属针脚）绑定。装订点的精确数目和布局由实现和/或位置定义。

EDGE_STITCH_TOP

public static final Finishings EDGE_STITCH_TOP
将文档（或多个文档）与沿顶边的一个或多个装订点（金属针脚）绑定。装订点的精确数目和布局由实现和/或位置定义。

EDGE_STITCH_RIGHT

public static final Finishings EDGE_STITCH_RIGHT
将文档（或多个文档）与沿右边的一个或多个装订点（金属针脚）绑定。装订点的精确数目和布局由实现和/或位置定义。

EDGE_STITCH_BOTTOM

public static final Finishings EDGE_STITCH_BOTTOM
将文档（或多个文档）与沿底边的一个或多个装订点（金属针脚）绑定。装订点的精确数目和布局由实现和/或位置定义。

STAPLE_DUAL_LEFT

public static final Finishings STAPLE_DUAL_LEFT
将文档（或多个文档）与沿左边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。

STAPLE_DUAL_TOP

public static final Finishings STAPLE_DUAL_TOP
将文档（或多个文档）与沿顶边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。

STAPLE_DUAL_RIGHT

public static final Finishings STAPLE_DUAL_RIGHT
将文档（或多个文档）与沿右边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。

STAPLE_DUAL_BOTTOM

public static final Finishings STAPLE_DUAL_BOTTOM
将文档（或多个文档）与沿底边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。

构造方法详细信息

Finishings

protected Finishings(int value)
构造具有给定整数值的新 finishings 绑定枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 Finishings 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 Finishings 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getOffset

protected int getOffset()
返回 Finishings 类所使用的最小整数值。

覆盖：
类 EnumSyntax 中的 getOffset
返回：
最小枚举值的偏移量。

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 Finishings 类和任何供应商定义的子类，类别是 Finishings 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 Finishings 类和任何供应商定义的子类，类别名称为 "finishings"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobHoldUntil (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobHoldUntil

java.lang.Object
    继承者  javax.print.attribute.DateTimeSyntax
        继承者  javax.print.attribute.standard.JobHoldUntil
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class JobHoldUntil
extends DateTimeSyntax
implements PrintRequestAttribute, PrintJobAttribute

JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。

如果此属性的值指定了将来的某个日期-时间，则打印机应将 JOB_HOLD_UNTIL_SPECIFIED 的 JobStateReason 值添加到作业的 JobStateReasons 属性，必须将作业移动到 PENDING_HELD 状态，并且在指定的日期-时间到来之前不能安排该打印作业。

当指定的日期-时间到来时，打印机必须从作业的 JobStateReasons 属性中移除 JOB_HOLD_UNTIL_SPECIFIED 的 JobStateReason 值（如果存在）。如果没有其他使打印作业保持为 PENDING_HELD 状态的作业状态原因，则打印机必须将该作业移动到 PENDING 状态，以将其作为处理的候选作业。

如果已经超过指定的日期-时间，则该作业必须立即成为处理的候选作业。因此，使打印作业立即成为候选作业的一种方法是指定构造如下的 JobHoldUntil 属性（表示的日期-时间为 GMT 时间 1970 年 1 月 1 日，00:00:00）：

     JobHoldUntil immediately = new JobHoldUntil (new Date (0L));

如果客户机没有在 Print Request 中提供此属性，且打印机支持此属性，则打印机必须使用其（与实现有关的）默认的作业提交时的 JobHoldUntil 值（与作业处理时必要时所使用的大多数作业模板属性不同）。

要从独立的 year、month、day、hour、minute 等值构造 JobHoldUntil 属性，请使用 Calendar 对象来构造一个 Date 对象，然后使用该 Date 对象来构造 JobHoldUntil 属性。要将 JobHoldUntil 属性转换为独立的 year、month、day、hour、minute 等值，请创建一个 Calendar 对象，并根据 JobHoldUntil 属性将它设置为 Date。

IPP Compatibility: 虽然 IPP 支持指定为关键字的 "job-hold-until" 属性，但此处 IPP 不支持指定为日期和时间的 "job-hold-until" 属性。但是，可以在丢失一定精度的情况下，将日期和时间转换为标准 IPP 关键字之一；例如，日期为今天、时间为本地时间 9:00pm 的 JobHoldUntil 值可以转换为标准的 IPP 关键字 "night"。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobHoldUntil(Date dateTime)
构造具有给定 Date 值新 JobHoldUntil 属性。
方法摘要
boolean | equals(Object object) 返回此 JobHoldUntil 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.DateTimeSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobHoldUntil

public JobHoldUntil(Date dateTime)
构造具有给定 Date 值新 JobHoldUntil 属性。

参数：
dateTime - Date 值。
抛出：
NullPointerException - （未检查的异常）如果 dateTime 为 null，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobHoldUntil 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobHoldUntil 类的实例。
  3. 此 JobHoldUntil 属性的 Date 值与 object 的 Date 值相等。

覆盖：
类 DateTimeSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobHoldUntil 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobHoldUntil 类，类别为 JobHoldUntil 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobHoldUntil 类，类别名称为 "job-hold-until"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobImpressions (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobImpressions

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobImpressions
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class JobImpressions
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute

JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。“印张" 是打印在单一介质页上的图像（在不同配置中可能有许多输出流页）。

JobImpressions 属性描述了作业的大小。此属性不应是计数器，它应是有用的路径和计划信息（如果已知）。如果在 Print Request 中未提供 JobImpressions 属性值，则打印机可能尝试计算该值。即使客户机在 Print Request 中提供了 JobImpressions 属性值，但如果打印机能够计算出比客户机所提供的值更精确的值，则打印机可以选择更改该值。在刚好提交作业时，或提交后的任意时刻，打印机可以确定 JobImpressions 属性的正确值。

与 JobKOctets 一样，JobImpressions 值不能包括由 Copies 属性指定的副本数所产生的乘数，这与设备能否在无需多次传递作业或文档的情况下处理多个副本无关，并且与输出是否逐份打印无关。因此，该值与实现无关，它反映了文档（或多个文档）的大小，度量单位是与副本数无关的印张。

与 JobKOctets 一样，JobImpressions 值不能包括由嵌入文档数据的副本指令产生的乘数。如果文档数据实际上包括文档数据的复制，则此值将包括这样的复制。换句话说，此值总是源文档数据中的印张，而不是由作业产生的印张的度量。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
JobImpressionsSupported, JobImpressionsCompleted, JobKOctets, JobMediaSheets, 序列化表格

构造方法摘要
JobImpressions(int value)
构造具有给定整数值的新作业印张属性。
方法摘要
boolean | equals(Object object) 返回此作业印张属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobImpressions

public JobImpressions(int value)
构造具有给定整数值的新作业印张属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此作业印张属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是 JobImpressions 类的实例。
  3. 此作业印张属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此作业印张属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobImpressions 类，类别为 JobImpressions 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobImpressions 类，类别名称为 "job-impressions"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobImpressionsCompleted (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobImpressionsCompleted

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobImpressionsCompleted
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class JobImpressionsCompleted
extends IntegerSyntax
implements PrintJobAttribute

JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。对于打印设备，已完成的印数包括解释、标记和堆栈输出。

JobImpressionsCompleted 属性描述了作业进度。此属性应为计数器。即尚未开始处理的作业的 JobImpressionsCompleted 值必须为 0。当作业的 JobState 为 PROCESSING 或 PROCESSING_STOPPED 时，随着作业被处理，JobImpressionsCompleted 值应增大；它指示在查询 Print Job 的属性设置时，或在报告打印作业事件时的已完成处理的作业量。当作业进入 COMPLETED、CANCELED 或 ABORTED 状态时，JobImpressionsCompleted 值为作业的最终值。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
JobImpressions, JobImpressionsSupported, JobKOctetsProcessed, JobMediaSheetsCompleted, 序列化表格

构造方法摘要
JobImpressionsCompleted(int value)
构造具有给定整数值的新的 JobImpressionsCompleted 属性。
方法摘要
boolean | equals(Object object) 返回此 JobImpressionsCompleted 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobImpressionsCompleted

public JobImpressionsCompleted(int value)
构造具有给定整数值的新的 JobImpressionsCompleted 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobImpressionsCompleted 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是 JobImpressionsCompleted 类的实例。
  3. 此 JobImpressionsCompleted 属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobImpressionsCompleted 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取被用作此打印属性值的“类别”的打印属性类。

对于 JobImpressionsCompleted 类，类别为 JobImpressionsCompleted 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobImpressionsCompleted 类，类别名称为 "job-impressions-completed"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobImpressionsSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobImpressionsSupported

java.lang.Object
    继承者  javax.print.attribute.SetOfIntegerSyntax
        继承者  javax.print.attribute.standard.JobImpressionsSupported
所有已实现的接口：
Serializable, Cloneable, Attribute, SupportedValuesAttribute
public final class JobImpressionsSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute

JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。它限制为整数的单个连续范围，不允许多个非重叠范围。这以打印机将接受的印数形式给出了打印作业总大小的下边界和上边界。

IPP Compatibility: JobImpressionsSupported 属性的规范数组形式给出了要包含于 IPP "job-impressions-supported" 属性中的值的范围的下边界和上边界。有关规范数组形式的解释，请参见 SetOfIntegerSyntax。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobImpressionsSupported(int lowerBound, int upperBound)
构造包含单个整数范围的新的 JobImpressionsSupported 属性。
方法摘要
boolean | equals(Object object) 返回此 JobImpressionsSupported 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.SetOfIntegerSyntax 继承的方法
contains, contains, getMembers, hashCode, next, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobImpressionsSupported

public JobImpressionsSupported(int lowerBound,
                               int upperBound)
构造包含单个整数范围的新的 JobImpressionsSupported 属性。即仅支持某个范围中的 JobImpression 值。

参数：
lowerBound - 范围的下边界。
upperBound - 范围的上边界。
抛出：
IllegalArgumentException - （未检查的异常）如果指定了 null 范围，或者指定了 lowerBound 小于 0 的非 null 范围，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobImpressionsSupported 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是 JobImpressionsSupported 类的实例。
  3. 此 JobImpressionsSupported 属性的成员与 object 的成员相同。

覆盖：
类 SetOfIntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobImpressionsSupported 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobImpressionsSupported 类，类别为 JobImpressionsSupported 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobImpressionsSupported 类，类别名称为 "job-impressions-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobKOctets (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobKOctets

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobKOctets
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class JobKOctets
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute

JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。必须对该值进行舍入操作，这样 1 字节和 1024 字节之间的作业必须指示为 1K 字节，1025 到 2048 必须指示为 2K 字节， 依此类推。对于多文档打印作业（具有多个文档的作业），JobKOctets 值的计算是通过累加单个文档的字节大小，然后舍入到最近的 K 字节值来实现的。

JobKOctets 属性描述了作业的大小。此属性不是计数器，它应是有用的路径和计划信息（如果已知）。如果在 Print Request 中未提供 JobKOctets 属性值，则打印机可能尝试计算该值。即使客户机在 Print Request 中提供了 JobKOctets 属性值，如果打印机能够计算出比客户机所提供的值更精确的值，则打印机可以选择更改该值。在刚好提交作业的时刻，或提交后的任意时刻，打印机可以确定 JobKOctets 属性的正确值。

JobKOctets 值不能包括由 Copies 属性指定的副本数所产生的乘数，这与设备能否在无需多次传递作业或文档数据的情况下处理多个副本无关，并且与输出是否逐份打印无关。因此，该值与实现无关，它指示文档（或多个文档）大小，度量单位是与副本数无关的 K 字节。

JobKOctets 值不能包括由嵌入文档数据的副本指令产生的乘数。如果文档数据实际上包括文档数据的复制，则此值将包括这样的复制。换句话说，此值总是源文档数据的大小，而不是要生成的硬拷贝输出的度量。

文档大小是根据文档的 DocFlavor 指定的打印数据表示形式类计算的，如下表所示。

表示形式类 | 文档大小
byte[] | 字节数组的长度
java.io.InputStream | 从流读取的字节数
char[] | 字符数组的长度 x 2
java.lang.String | 字符串的长度 x 2
java.io.Reader | 从流读取的字符数 x 2
java.net.URL | 从给定的 URL 地址处的文件读取的字节数
java.awt.image.renderable.RenderableImage | 与实现有关*
java.awt.print.Printable | 与实现有关*
java.awt.print.Pageable | 与实现有关*

* 在这些情况下，Print Service 本身生成要发送到打印机的打印数据。如果 Print Service 支持 JobKOctets 属性，则对于这些情况，Print Service 本身必须计算打印数据的大小，替换客户机所指定的任何 JobKOctets 值。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
JobKOctetsSupported, JobKOctetsProcessed, JobImpressions, JobMediaSheets, 序列化表格

构造方法摘要
JobKOctets(int value)
构造具有给定整数值的新 JobKOctets 属性。
方法摘要
boolean | equals(Object object) 返回此 JobKOctets 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobKOctets

public JobKOctets(int value)
构造具有给定整数值的新 JobKOctets 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobKOctets 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobKOctets 类的实例。
  3. 此 JobKOctets 属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobKOctets 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobKOctets 类，类别为 JobKOctets 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobKOctets 类，类别名称为 "job-k-octets"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobKOctetsProcessed (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobKOctetsProcessed

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobKOctetsProcessed
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class JobKOctetsProcessed
extends IntegerSyntax
implements PrintJobAttribute

JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。必须对该值进行舍入操作，这样 1 字节和 1024 字节之间的作业必须指示为 1K 字节，1025 到 2048 必须指示为 2K 字节，依此类推。对于多文档打印作业（具有多个文档的作业），JobKOctetsProcessed 值的计算是通过累加到目前为止单个文档的字节数，然后舍入到最接近的 K 字节值来实现的。

JobKOctetsProcessed 属性描述了作业进度。此属性应为计数器。即尚未开始处理的作业的 JobKOctetsProcessed 值必须为 0。当作业的 JobState 为 PROCESSING 或 PROCESSING_STOPPED 时，随着作业被处理，JobKOctetsProcessed 值应增大；它指示在查询 Print Job 的属性设置时刻，或在报告打印作业事件时刻的已完成处理的作业量。当作业进入 COMPLETED、CANCELED 或 ABORTED 状态时，JobKOctetsProcessed 值为作业的最终值。

对于仅具有单个传入数据的解释器生成多个副本的实现，JobKOctetsProcessed 属性的最终值必须等于 JobKOctets 属性的值。对于解释器通过处理每个副本的数据来生成多个副本的实现，最终值必须为多个 JobKOctets 属性值。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
JobKOctets, JobKOctetsSupported, JobImpressionsCompleted, JobMediaSheetsCompleted, 序列化表格

构造方法摘要
JobKOctetsProcessed(int value)
构造具有给定整数值的新的 JobKOctetsProcessed 属性。
方法摘要
boolean | equals(Object object) 返回此 JobKOctetsProcessed 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobKOctetsProcessed

public JobKOctetsProcessed(int value)
构造具有给定整数值的新的 JobKOctetsProcessed 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobKOctetsProcessed 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobKOctetsProcessed 类的实例。
  3. 此 JobKOctetsProcessed 属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobKOctetsProcessed 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobKOctetsProcessed 类，类别为 JobKOctetsProcessed 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobKOctetsProcessed 类，类别名称为 "job-k-octets-processed"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobKOctetsSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobKOctetsSupported

java.lang.Object
    继承者  javax.print.attribute.SetOfIntegerSyntax
        继承者  javax.print.attribute.standard.JobKOctetsSupported
所有已实现的接口：
Serializable, Cloneable, Attribute, SupportedValuesAttribute
public final class JobKOctetsSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute

JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。它限制为整数的单个连续范围，不允许多个非重叠范围。这以打印机将接受的 K 字节（1024 字节）单位给出了打印作业总大小的下边界和上边界。

IPP Compatibility: The JobKOctetsSupported 属性的规范数组形式给出了要包含于 IPP "job-k-octets-supported" 属性中的值的范围的下边界和上边界。有关规范数组形式的解释，请参见 SetOfIntegerSyntax。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobKOctetsSupported(int lowerBound, int upperBound)
构造包含单个整数范围的新的 JobKOctetsSupported 属性。
方法摘要
boolean | equals(Object object) 返回此 JobKOctetsSupported 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.SetOfIntegerSyntax 继承的方法
contains, contains, getMembers, hashCode, next, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobKOctetsSupported

public JobKOctetsSupported(int lowerBound,
                           int upperBound)
构造包含单个整数范围的新的 JobKOctetsSupported 属性。即仅支持某个范围中的 JobKOctets 值。

参数：
lowerBound - 范围的下边界。
upperBound - 范围的上边界。
抛出：
IllegalArgumentException - （未检查的异常）如果指定了 null 范围，或者指定了 lowerBound 小于 0 的非 null 范围，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobKOctetsSupported 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobKOctetsSupported 类的实例。
  3. 此 JobKOctetsSupported 属性的成员与 object 的成员相同。

覆盖：
类 SetOfIntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobKOctetsSupported 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobKOctetsSupported 类，类别为 JobKOctetsSupported 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobKOctetsSupported 类，类别名称为 "job-k-octets-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobMediaSheets (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobMediaSheets

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobMediaSheets
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public class JobMediaSheets
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute

JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。

JobMediaSheets 属性描述了作业大小。此属性不是计数器，它应是有用的路径和计划信息（如果已知）。如果在 Print Request 中未提供 JobMediaSheets 属性值，则打印机可能尝试计算该值。即使客户机在 Print Request 中提供了 JobMediaSheets 属性值，如果打印机能够计算出比客户机所提供的值更精确的值，则打印机可以选择更改该值。在刚好提交作业时，或提交后的任意时刻，打印机可以确定 JobMediaSheets 属性的正确值。

与 JobKOctets 和 JobImpressions 属性不同，JobMediaSheets 值必须包括由 Copies 属性所指定的副本数提供的乘数，以及嵌入在文档数据中的 "number of copies" 指令（如果有）。这种差异允许系统管理员控制以下两者的下边界和上边界：(1) 使用 JobKOctetsSupported 和 JobImpressionsSupported 控制文档（或多个文档）的大小 (2) 使用 JobMediaSheetsSupported 控制作业的大小。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
JobMediaSheetsSupported, JobMediaSheetsCompleted, JobKOctets, JobImpressions, 序列化表格

构造方法摘要
JobMediaSheets(int value)
构造具有给定整数值的新 JobMediaSheets 属性。
方法摘要
boolean | equals(Object object) 返回此 JobMediaSheets 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobMediaSheets

public JobMediaSheets(int value)
构造具有给定整数值的新 JobMediaSheets 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobMediaSheets 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobMediaSheets 类的实例。
  3. 此作业介质纸张属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobMediaSheets 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobMediaSheets 类和任何供应商定义的子类，类别为 JobMediaSheets 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobMediaSheets 类和任何供应商提供的子类，类别名称为 "job-media-sheets"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobMediaSheetsCompleted (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobMediaSheetsCompleted

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobMediaSheetsCompleted
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class JobMediaSheetsCompleted
extends IntegerSyntax
implements PrintJobAttribute

JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。

JobMediaSheetsCompleted 属性描述了作业进度。此属性应为计数器。即尚未开始处理的作业的 JobMediaSheetsCompleted 值必须为 0。当作业的 JobState 为 PROCESSING 或 PROCESSING_STOPPED 时，随着作业被处理，JobMediaSheetsCompleted 值应增大；它指示在查询 Print Job 的属性设置时，或在执行打印作业事件时的已完成处理的作业量。当作业进入 COMPLETED、CANCELED 或 ABORTED 状态时，JobMediaSheetsCompleted 值为作业的最终值。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
JobMediaSheets, JobMediaSheetsSupported, JobKOctetsProcessed, JobImpressionsCompleted, 序列化表格

构造方法摘要
JobMediaSheetsCompleted(int value)
构造具有整数值的 JobMediaSheetsCompleted 属性。
方法摘要
boolean | equals(Object object) 返回此 JobMediaSheetsCompleted 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值是该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobMediaSheetsCompleted

public JobMediaSheetsCompleted(int value)
构造具有整数值的 JobMediaSheetsCompleted 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobMediaSheetsCompleted 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobMediaSheetsCompleted 类的实例。
  3. 此 JobMediaSheetsCompleted 属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobMediaSheetsCompleted 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobMediaSheetsCompleted 类，类别为 JobMediaSheetsCompleted 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值是该类别的实例。

对于 JobMediaSheetsCompleted 类，类别名称为 "job-media-sheets-completed"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobMediaSheetsSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobMediaSheetsSupported

java.lang.Object
    继承者  javax.print.attribute.SetOfIntegerSyntax
        继承者  javax.print.attribute.standard.JobMediaSheetsSupported
所有已实现的接口：
Serializable, Cloneable, Attribute, SupportedValuesAttribute
public final class JobMediaSheetsSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute

Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。它限制为整数的单个连续范围，不允许多个非重叠范围。这以打印机将接受的介质纸张数形式给出了打印作业总大小的下边界和上边界。

IPP Compatibility: The JobMediaSheetsSupported 属性的规范数组形式给出了要包含于 IPP "job-media-sheets-supported" 属性中的值的范围的下边界和上边界。有关规范数组形式的解释，请参见 SetOfIntegerSyntax。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobMediaSheetsSupported(int lowerBound, int upperBound)
构造包含单个整数范围的新的 JobMediaSheetsSupported 属性。
方法摘要
boolean | equals(Object object) 返回支持的此 JobMediaSheetsSupported 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.SetOfIntegerSyntax 继承的方法
contains, contains, getMembers, hashCode, next, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobMediaSheetsSupported

public JobMediaSheetsSupported(int lowerBound,
                               int upperBound)
构造包含单个整数范围的新的 JobMediaSheetsSupported 属性。即仅支持某个范围中的 JobMediaSheets 值。

参数：
lowerBound - 范围的下边界。
upperBound - 范围的上边界。
抛出：
IllegalArgumentException - （未检查的异常）如果指定了 null 范围，或者指定了 lowerBound 小于 0 的非 null 范围，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回支持的此 JobMediaSheetsSupported 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobMediaSheetsSupported 类的实例。
  3. 支持的此 JobMediaSheetsSupported 属性的成员与 object 的成员相同。

覆盖：
类 SetOfIntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobMediaSheetsSupported 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobMediaSheetsSupported 类，类别为 JobMediaSheetsSupported 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobMediaSheetsSupported 类，类别名称为 "job-media-sheets-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobMessageFromOperator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobMessageFromOperator

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.JobMessageFromOperator
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class JobMessageFromOperator
extends TextSyntax
implements PrintJobAttribute

JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。

Print Job 的属性集包括 JobMessageFromOperator 属性的零个或一个实例，不超过一个实例。新的 JobMessageFromOperator 属性替换现有的 JobMessageFromOperator 属性（如果有）。换句话说，JobMessageFromOperator 不应是历史记录。如果需要，客户机可以检测 Print Job 的 JobMessageFromOperator 属性的更改，并维护客户机自己的 JobMessageFromOperator 属性值的历史记录。

IPP Compatibility: 字符串值给出了 IPP 名称值。语言环境给出了 IPP 自然语言。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobMessageFromOperator(String message, Locale locale)
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。
方法摘要
boolean | equals(Object object) 返回 Operator 属性传来的此作业消息是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobMessageFromOperator

public JobMessageFromOperator(String message,
                              Locale locale)
使用给定消息和语言环境构造新的 JobMessageFromOperator 属性。

参数：
message - 消息。
locale - 文本字符串的自然语言。null 被解释为意味着 Locale.getDefault() 所返回的默认语言环境
抛出：
NullPointerException - （未检查的异常）如果 message 为 null，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回 Operator 属性传来的此作业消息是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobMessageFromOperator 类的实例。
  3. Operator 属性传来的此作业消息的底层字符串与 object 的底层字符串相同。
  4. Operator 属性传来的此作业消息的语言环境与 object 的语言环境相同。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于 Operator 属性传来的此作业消息，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobMessageFromOperator 类，类别为 JobMessageFromOperator 属性本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobMessageFromOperator 类，类别名称为 "job-message-from-operator"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobName

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.JobName
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class JobName
extends TextSyntax
implements PrintRequestAttribute, PrintJobAttribute

JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。作业名称是客户机所定义的任意字符串。不同作业之间不必使用唯一名称。Print Job 的 JobName 属性设置为客户机在 Print Request 的属性集中提供的值。但是，如果客户机没有在 Print Request 中提供 JobName 属性，则当打印机创建 Print Job 时，必须生成 JobName。打印机应从以下产生某个值的源中的第一个源生成 Print Job 的 JobName 属性值：(1) 作业中首个文档（或唯一文档）的 DocumentName 属性，(2) 如果文档的打印数据表示形式对象为 URL，则为作业中首个文档（或唯一文档）的 URL，或者 (3) 任何其他特定的 Print Job 片段和/或文档内容信息。

IPP Compatibility: 字符串值给出了 IPP 名称值。语言环境给出了 IPP 自然语言。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobName(String jobName, Locale locale)
构造具有给定作业名称和语言环境的新JobName属性。
方法摘要
boolean | equals(Object object) 返回此作业名称属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobName

public JobName(String jobName,
               Locale locale)
构造具有给定作业名称和语言环境的新JobName属性。

参数：
jobName - 作业名称。
locale - 文本字符串的自然语言。null 被解释为意味着 Locale.getDefault() 所返回的默认语言环境
抛出：
NullPointerException - （未检查的异常）如果 jobName 为 null，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此作业名称属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobName 类的实例。
  3. 此作业名称属性的底层字符串和 object 的底层字符串相同。
  4. 此作业名称属性的语言环境与 object 的语言环境相同。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此作业名称属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobName 类，类别为 JobName 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobName 类，类别名称为 "job-name"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobOriginatingUserName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobOriginatingUserName

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.JobOriginatingUserName
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class JobOriginatingUserName
extends TextSyntax
implements PrintJobAttribute

JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。如有可能，打印机将此属性设置为它能够从验证服务获取的最符合验证的可打印用户名称，这里验证服务验证所提交的 Print Request。如果此功能不可用，则打印机使用客户机在 Print Request 的属性集中提供的 RequestingUserName 属性值。如果验证服务不可用，且客户机未提供 RequestingUserName 属性，则打印机将 JobOriginatingUserName 属性设置为空（零长度的）字符串。

IPP Compatibility: 字符串值给出了 IPP 名称值。语言环境给出了 IPP 自然语言。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobOriginatingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。
方法摘要
boolean | equals(Object object) 返回此 JobOriginatingUserName 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobOriginatingUserName

public JobOriginatingUserName(String userName,
                              Locale locale)
构造具有给定用户名称和语言环境的新的 JobOriginatingUserName 属性。

参数：
userName - 用户名称。
locale - 文本字符串的自然语言。null 被解释为意味着 Locale.getDefault() 所返回的默认语言环境
抛出：
NullPointerException - （未检查的异常）如果 userName 为 null，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 JobOriginatingUserName 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobOriginatingUserName 类的实例。
  3. 此 JobOriginatingUserName 属性的底层字符串和 object 的底层字符串相同。
  4. 此 JobOriginatingUserName 属性的语言环境与 object 的语言环境相同。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 JobOriginatingUserName 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobOriginatingUserName 类，类别为 JobOriginatingUserName 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobOriginatingUserName 类，类别名称为 "job-originating-user-name"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobPriority (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobPriority

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobPriority
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class JobPriority
extends IntegerSyntax
implements PrintRequestAttribute, PrintJobAttribute

JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。

如果为 Print Job 指定了 JobPriority 属性，则它指定了安排作业的优先级。较高的值指定较高的优先级。值 1 指示最低的可能优先级。值 100 指示最高的可能优先级。在准备打印的作业中，打印机必须在打印优先级值为 n-1 的所有作业之前，打印所有优先级值为 n 的作业。

如果客户机未指定 Print Job 的 JobPriority 属性，且打印机不支持 JobPriority 属性，则打印机必须使用由实现所定义的默认值。

客户机可以总是为某作业指定任何 1 到 100 的作业优先级值。但是，Print Service 实例可能支持小于 100 的不同作业优先级级别。如果是这种情况，则 Print Service 实例自动将由客户机指定的作业优先级值映射为某个支持的作业优先级级别，将 100 个优先级值平均分为可用的作业优先级级别。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobPriority(int value)
构造具有给定整数值的新 JobPriority 属性。
方法摘要
boolean | equals(Object object) 返回此作业优先级属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobPriority

public JobPriority(int value)
构造具有给定整数值的新 JobPriority 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 1 或大于 100，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此作业优先级属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobPriority 类的实例。
  3. 此作业优先级属性的值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此作业优先级属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobPriority 类，类别为 JobPriority 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobPriority 类，类别名称为 "job-priority"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobPrioritySupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobPrioritySupported

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.JobPrioritySupported
所有已实现的接口：
Serializable, Cloneable, Attribute, SupportedValuesAttribute
public final class JobPrioritySupported
extends IntegerSyntax
implements SupportedValuesAttribute

JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。

客户机可以总是为作业指定任何 1 到 100 的 JobPriority 值。但是，Print Service 实例可能支持少于 100 个 不同的作业优先级级别。如果是这种情况，则 Print Service 实例自动将由客户机指定的作业优先级值映射为某个支持的作业优先级级别，将 100 个优先级值平均分为可用的作业优先级级别。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobPrioritySupported(int value)
构造具有给定整数值的新的 JobPrioritySupported 属性。
方法摘要
boolean | equals(Object object) 返回支持的此作业优先级属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

JobPrioritySupported

public JobPrioritySupported(int value)
构造具有给定整数值的新的 JobPrioritySupported 属性。

参数：
value - 支持的不同作业优先级级别的数目。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 1 或大于 100，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回支持的此作业优先级属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 JobPrioritySupported 类的实例。
  3. 支持的此作业优先级属性的值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于支持的此作业优先级属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobPrioritySupported 类，类别为 JobPrioritySupported 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobPrioritySupported 类，类别名称为 "job-priority-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobSheets (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobSheets

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.JobSheets
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public class JobSheets
extends EnumSyntax
implements PrintRequestAttribute, PrintJobAttribute

JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。JobSheets 类声明了标准作业页值的关键字。由实现或位置定义的作业页属性的名称也可以通过定义 JobSheets 类的子类来创建。

多文档打印作业（具有多个文档的作业）上的 JobSheets 属性的效果可能受到 MultipleDocumentHandling 作业属性的影响，这取决于特殊 JobSheets 值的意义。

IPP Compatibility: getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。对于子类，必须本地化属性值以给出 IPP 名称和自然语言值。

另请参见：
序列化表格

字段摘要
static JobSheets | NONE 不打印作业页。
static JobSheets | STANDARD 打印一个或多个指定位置的标准作业页，例如，打印单张开始页，或者打印开始页和结束页。
构造方法摘要
protected JobSheets(int value)
构造具有给定整数值的新 JobSheets 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 class JobSheets 类的枚举值表。
String | getName() 获取类别名称，此属性值为该类别的实例。
protected String[] | getStringTable() 返回 JobSheets 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

NONE

public static final JobSheets NONE
不打印作业页。

STANDARD

public static final JobSheets STANDARD
打印一个或多个指定位置的标准作业页，例如，打印单张开始页，或者打印开始页和结束页。

构造方法详细信息

JobSheets

protected JobSheets(int value)
构造具有给定整数值的新 JobSheets 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 JobSheets 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 class JobSheets 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobSheets 类和任何供应商定义的子类，类别为 JobSheets 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobSheets 类和任何供应商定义的子类，类别名称为 "job-sheets"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobState (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobState

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.JobState
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public class JobState
extends EnumSyntax
implements PrintJobAttribute

JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。JobState 类定义了标准的作业状态值。Print Service 实现只需报告适合于特殊实现的作业状态；它不必报告每个定义的作业状态。JobStateReasons 属性扩充了 JobState 属性，以给出有关处于给定作业状态的作业的更详细信息。

IPP Compatibility: getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static JobState | ABORTED 作业已被系统中止（通常当作业处于 PROCESSING 或 PROCESSING_STOPPED 状态时），打印机已完成正在中止的作业，且所有作业状态属性已达到作业的最终值。
static JobState | CANCELED 作业已被人为操作取消，打印机已完成了正取消的作业，且所有作业状态属性已达到作业的最终值。
static JobState | COMPLETED 作业已成功完成，或以警告或错误结束，所有作业介质纸张已成功堆栈到适当的输出纸盒（或多个纸盒）中，且所有作业状态已达到作业的最终值。
static JobState | PENDING 作业为要开始处理的候选作业，但尚未开始处理。
static JobState | PENDING_HELD 由于某些原因，作业不是要处理的候选作业，但当这些原因不再存在时，作业将返回 PENDING 状态。
static JobState | PROCESSING 正在处理作业。
static JobState | PROCESSING_STOPPED 由于某些原因，正在处理时作业已停止，且当这些原因不再存在时，作业返回到 PROCESSING 状态。
static JobState | UNKNOWN 作业状态是未知的。
构造方法摘要
protected JobState(int value)
构造具有给定整数值的新 JobState 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 JobState 类的枚举值表。
String | getName() 获取类别名称，此属性值为该类别的实例。
protected String[] | getStringTable() 返回 JobState 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

UNKNOWN

public static final JobState UNKNOWN
作业状态是未知的。

PENDING

public static final JobState PENDING
作业为要开始处理的候选作业，但尚未开始处理。

PENDING_HELD

public static final JobState PENDING_HELD
由于某些原因，作业不是要处理的候选作业，但当这些原因不再存在时，作业将返回 PENDING 状态。作业的 JobStateReasons 属性必须指示该作业为什么不再是要处理的候选作业。

PROCESSING

public static final JobState PROCESSING
正在处理作业。以下一个或多个活动正在发生：
  1. 作业正在使用（或正在尝试使用）一个或多个纯软件进程，这些进程正在分析、创建或解释某个 PDL，等等。

  2. 作业正在使用（或正在尝试使用）一个或多个硬件设备，这些设备正在解释某个 PDL，正在介质上作标记，和/或正在执行结束操作，例如正在装订，等等。

  3. 如果打印机已经就绪，但输出设备尚未打印它，则要么是因为该作业尚未到达输出设备，要么是因为该作业正在输出设备或某些其他打印缓冲（spooler）中排队, 等待输入设备打印它。

当作业处于 PROCESSING 状态时，全部作业状态包括打印机的 PrinterState 和 PrinterStateReasons 属性中所表示的详细状态。

实现可能（但不一定）包括作业的 JobStateReasons 属性中的额外值，以指示打印进度，例如添加 JOB_PRINTING 值以指示输出设备何时实际在纸张上进行标记，和/或添加 PROCESSING_TO_STOP_POINT 值以指示打印机处于取消或中止作业的进程中。

PROCESSING_STOPPED

public static final JobState PROCESSING_STOPPED
由于某些原因，正在处理时作业已停止，且当这些原因不再存在时，作业返回到 PROCESSING 状态。

作业的 JobStateReasons 属性可能指示为什么作业已停止处理。例如，如果输出设备停止，则作业的 JobStateReasons 属性中可能包含 PRINTER_STOPPED 值。

注：当输出设备停止时，该设备通常以设备上本地可读形式指示其条件。客户机可以通过查询打印机的 PrinterState 和 PrinterStateReasons 属性，远程获取更完整的设备状态。

CANCELED

public static final JobState CANCELED
作业已被人为操作取消，打印机已完成了正取消的作业，且所有作业状态属性已达到作业的最终值。当打印机正取消作业时，该作业保持其当前状态，但作业的 JobStateReasons 属性应包含 PROCESSING_TO_STOP_POINT 值，以及 CANCELED_BY_USER、CANCELED_BY_OPERATOR 或 CANCELED_AT_DEVICE 值之一。当作业变为 CANCELED 状态时，必须移除 PROCESSING_TO_STOP_POINT 值（如果存在），但必须保持 CANCELED_BY_xxx 值（如果存在）。

ABORTED

public static final JobState ABORTED
作业已被系统中止（通常当作业处于 PROCESSING 或 PROCESSING_STOPPED 状态时），打印机已完成正在中止的作业，且所有作业状态属性已达到作业的最终值。当打印机正取消作业时，该作业保持其当前状态，但作业的 JobStateReasons 属性应包含 PROCESSING_TO_STOP_POINT 和 ABORTED_BY_SYSTEM 值。当作业变为 ABORTED 状态时，必须移除 PROCESSING_TO_STOP_POINT 值（如果存在），但必须保持 ABORTED_BY_SYSTEM 值（如果存在）。

COMPLETED

public static final JobState COMPLETED
作业已成功完成，或以警告或错误结束，所有作业介质纸张已成功堆栈到适当的输出纸盒（或多个纸盒）中，且所有作业状态已达到作业的最终值。作业的 JobStateReasons 属性应包含以下值之一：COMPLETED_SUCCESSFULLY、COMPLETED_WITH_WARNINGS 或 COMPLETED_WITH_ERRORS。

构造方法详细信息

JobState

protected JobState(int value)
构造具有给定整数值的新 JobState 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 JobState 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 JobState 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobState 类和任何供应商定义的子类，类别为 JobState 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobState 类和任何供应商定义的子类，类别名称为 "job-state"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobStateReason (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobStateReason

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.JobStateReason
所有已实现的接口：
Serializable, Cloneable, Attribute
public class JobStateReason
extends EnumSyntax
implements Attribute

JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。JobStateReason 类定义了标准的作业状态原因值。Print Service 实现只需报告适合于特定实现的作业状态原因；它不必报告每个定义的作业状态原因。

JobStateReason 的实例不直接出现在 Print Job 的属性集中。但是，JobStateReasons 属性出现在 Print Job 的属性集中。JobStateReasons 属性包含零个、一个或多个 JobStateReason 对象，它们属于 Print Job 的状态。当 Print Job 的对应条件变为 true 时，打印机将 JobStateReason 对象添加到 Print Job 的 JobStateReasons 属性，且当对应条件变为 false 时，再移除 JobStateReason 对象，而不管 Print Job 的总体 JobState 是否也更改。

IPP Compatibility: getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static JobStateReason | ABORTED_BY_SYSTEM 系统中止了作业。
static JobStateReason | COMPRESSION_ERROR 系统中止了作业，因为打印机在解压缩文档数据中遇到错误。
static JobStateReason | DOCUMENT_ACCESS_ERROR 打印机不能访问由引用传递的一个或多个文档（即打印数据表示形式对象为 URL）。
static JobStateReason | DOCUMENT_FORMAT_ERROR 系统中止了作业，因为打印机在处理文档数据时遇到错误。
static JobStateReason | JOB_CANCELED_AT_DEVICE 非标识本地用户取消了作业，即在设备控制台的用户取消了作业。
static JobStateReason | JOB_CANCELED_BY_OPERATOR 操作员取消了作业，操作员即用户，其已被授权为具有操作员权限（无论是本地还是远程）。
static JobStateReason | JOB_CANCELED_BY_USER 作业所有者取消了作业，作业所有者即用户，通过验证的该用户身份与创建 Print Job 的初始用户的值相同，或某位其他授权终端用户，例如作业所有者安全组成员。
static JobStateReason | JOB_COMPLETED_SUCCESSFULLY 作业成功完成。
static JobStateReason | JOB_COMPLETED_WITH_ERRORS 作业以错误结束（也可能是警告）。
static JobStateReason | JOB_COMPLETED_WITH_WARNINGS 作业以警告结束。
static JobStateReason | JOB_DATA_INSUFFICIENT 打印机已创建 Print Job，但打印机在可以将作业转为 PROCESSING 状态之前还需要额外的打印数据。
static JobStateReason | JOB_HOLD_UNTIL_SPECIFIED 为作业的 JobHoldUntil 属性值指定一个将来的日期-时间。
static JobStateReason | JOB_INCOMING 打印机已创建 Print Job，但打印机尚未完成访问或接收所有打印数据。
static JobStateReason | JOB_INTERPRETING 作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据。
static JobStateReason | JOB_OUTGOING 打印机正将作业传输到输出设备。
static JobStateReason | JOB_PRINTING 输出设备为标记介质。
static JobStateReason | JOB_QUEUED 打印机处于 PROCESSING 状态，更明确地讲，打印机已对文档数据排队。
static JobStateReason | JOB_QUEUED_FOR_MARKER 打印机处于 PENDING_HELD、PENDING 或 PROCESSING 状态，更明确地讲，打印机已完成足够的文档处理，能够开始标记且作业正在等待标记。
static JobStateReason | JOB_RESTARTABLE 此作业被保留，且当前可以重新开始。
static JobStateReason | JOB_TRANSFORMING 作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据并生成另一个电子表示形式。
static JobStateReason | PRINTER_STOPPED 打印机的 PrinterState 属性值为 STOPPED。
static JobStateReason | PRINTER_STOPPED_PARTLY 打印机的 PrinterStateReasons 属性值包含 STOPPED_PARTLY 的 PrinterStateReason 值。
static JobStateReason | PROCESSING_TO_STOP_POINT 请求者已取消作业，或打印机已中止作业，但打印机仍在执行该作业的某些操作，直到遇到指定的停止点，或已完成作业终止/清除操作。
static JobStateReason | QUEUED_IN_DEVICE 作业已被转发到某个不能发送回状态的设备或打印系统。
static JobStateReason | RESOURCES_ARE_NOT_READY 在候选作业的任何物理打印机上，至少有一个该作业所需的资源（例如介质、字体、资源对象等）未就绪。
static JobStateReason | SERVICE_OFF_LINE 打印机离线，不接受作业。
static JobStateReason | SUBMISSION_INTERRUPTED 由于某些不可预见的原因，作业未完成提交。
static JobStateReason | UNSUPPORTED_COMPRESSION 系统取消了作业，这是因为打印机尝试解压缩文档数据时确定该压缩实际上不在打印机所支持的文档数据中。
static JobStateReason | UNSUPPORTED_DOCUMENT_FORMAT 系统中止了作业，因为文档数据的文档格式（doc flavor）不在打印机所支持的格式中。
构造方法摘要
protected JobStateReason(int value)
构造具有给定整数值的新 JobStateReason 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 JobStateReason 类的枚举值表。
String | getName() 获取类别名称，此属性值为该类别的实例。
protected String[] | getStringTable() 返回 JobStateReason 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

JOB_INCOMING

public static final JobStateReason JOB_INCOMING
打印机已创建 Print Job，但打印机尚未完成访问或接收所有打印数据。

JOB_DATA_INSUFFICIENT

public static final JobStateReason JOB_DATA_INSUFFICIENT
打印机已创建 Print Job，但打印机在可以将作业转为 PROCESSING 状态之前还需要额外的打印数据。如果打印机尚未接收所有数据就开始处理，则打印机移除 JOB_DATA_INSUFFICIENT 原因，但保持 JOB_INCOMING 原因。如果打印机在已接收所有数据之后才开始处理，则打印机同时移除 JOB_DATA_INSUFFICIENT 和 JOB_INCOMING 原因。

DOCUMENT_ACCESS_ERROR

public static final JobStateReason DOCUMENT_ACCESS_ERROR
打印机不能访问由引用传递的一个或多个文档（即打印数据表示形式对象为 URL）。此原因应覆盖任何文件访问问题，包括文件不存在和由于访问控制问题产生的拒绝访问。打印机是否中止作业并将作业转为 ABORTED 作业状态，或者打印所有可访问的文档并将作业转为 COMPLETED 作业状态，并将 COMPLETED_WITH_ERRORS 原因添加到作业的 JobStateReasons 属性，取决于实现和/或位置策略。如果打印机支持带有 URL 打印数据表示形式对象的文档 格式，则此值应受支持。

SUBMISSION_INTERRUPTED

public static final JobStateReason SUBMISSION_INTERRUPTED
由于某些不可预见的原因，作业未完成提交。可能的原因包括 (1) 客户机完全提交作业之前打印机已崩溃，(2) 文档数据完全传输到打印机之前，打印机或文档传输方法已以某种不可逆形式崩溃，(3) 完全提交作业之前客户机已崩溃。

JOB_OUTGOING

public static final JobStateReason JOB_OUTGOING
打印机正将作业传输到输出设备。

JOB_HOLD_UNTIL_SPECIFIED

public static final JobStateReason JOB_HOLD_UNTIL_SPECIFIED
为作业的 JobHoldUntil 属性值指定一个将来的日期-时间。移除此原因且没有保持作业的其他原因之前，作业不能成为处理的侯选作业。如果 JobHoldUntil 作业模板属性受支持，则此值应受支持。

RESOURCES_ARE_NOT_READY

public static final JobStateReason RESOURCES_ARE_NOT_READY
在候选作业的任何物理打印机上，至少有一个该作业所需的资源（例如介质、字体、资源对象等）未就绪。此条件可以在接收作业时检测，或者当作业正挂起或处理时检测，这取决于实现。作业可以保持其当前状态，或者转为 PENDING_HELD 状态，这取决于实现和/或作业安排策略。

PRINTER_STOPPED_PARTLY

public static final JobStateReason PRINTER_STOPPED_PARTLY
打印机的 PrinterStateReasons 属性值包含 STOPPED_PARTLY 的 PrinterStateReason 值。

PRINTER_STOPPED

public static final JobStateReason PRINTER_STOPPED
打印机的 PrinterState 属性值为 STOPPED。

JOB_INTERPRETING

public static final JobStateReason JOB_INTERPRETING
作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据。

JOB_QUEUED

public static final JobStateReason JOB_QUEUED
打印机处于 PROCESSING 状态，更明确地讲，打印机已对文档数据排队。

JOB_TRANSFORMING

public static final JobStateReason JOB_TRANSFORMING
作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据并生成另一个电子表示形式。

JOB_QUEUED_FOR_MARKER

public static final JobStateReason JOB_QUEUED_FOR_MARKER
打印机处于 PENDING_HELD、PENDING 或 PROCESSING 状态，更明确地讲，打印机已完成足够的文档处理，能够开始标记且作业正在等待标记。需要人为干涉以释放作业的系统将作业置于 PENDING_HELD 作业状态。自动选择作业以使用标记的系统将作业置于 PENDING 作业状态，或当等待标记的同时保持作业处于 PROCESSING 作业状态，这取决于实现。当开始标记时，所有实现将作业置于（或回退到）PROCESSING 状态。

JOB_PRINTING

public static final JobStateReason JOB_PRINTING
输出设备为标记介质。此值适用于花费大量时间处理以下情况的打印机：(1) 当未发生标记并希望显示标记现在正在发生时，或者 (2)当作业正处于被取消或中止的进程中，同时作业保持在 PROCESSING 状态，但标记尚未停止，因此作业的印张或纸张计数仍在增加。

JOB_CANCELED_BY_USER

public static final JobStateReason JOB_CANCELED_BY_USER
作业所有者取消了作业，作业所有者即用户，通过验证的该用户身份与创建 Print Job 的初始用户的值相同，或某位其他授权终端用户，例如作业所有者安全组成员。此值应受支持。

JOB_CANCELED_BY_OPERATOR

public static final JobStateReason JOB_CANCELED_BY_OPERATOR
操作员取消了作业，操作员即用户，其已被授权为具有操作员权限（无论是本地还是远程）。如果安全策略允许任何人取消任何人的作业，则当非作业所有者取消该作业时可以使用此值。对于这样的安全策略，就取消作业而言，在效果上每位人员都是操作员。如果实现允许由非作业所有者取消作业，则此值应受支持。

JOB_CANCELED_AT_DEVICE

public static final JobStateReason JOB_CANCELED_AT_DEVICE
非标识本地用户取消了作业，即在设备控制台的用户取消了作业。如果实现支持在控制台取消作业，则此值应受支持。

ABORTED_BY_SYSTEM

public static final JobStateReason ABORTED_BY_SYSTEM
系统中止了作业。作业分以下情况 (1) 在正被取消的进程中，(2) 已被系统取消并置于 ABORTED 状态，或者 (3) 已被系统取消并置于 PENDING_HELD 状态，因此用户或操作员可以手动尝试该作业。此值应受支持。

UNSUPPORTED_COMPRESSION

public static final JobStateReason UNSUPPORTED_COMPRESSION
系统取消了作业，这是因为打印机尝试解压缩文档数据时确定该压缩实际上不在打印机所支持的文档数据中。此值必须受支持，因为 Compression 是必需的文档描述属性。

COMPRESSION_ERROR

public static final JobStateReason COMPRESSION_ERROR
系统中止了作业，因为打印机在解压缩文档数据中遇到错误。如果打印机发送此原因，则文档数据已通过任何已导致 UNSUPPORTED_COMPRESSION 作业状态原因的测试。

UNSUPPORTED_DOCUMENT_FORMAT

public static final JobStateReason UNSUPPORTED_DOCUMENT_FORMAT
系统中止了作业，因为文档数据的文档格式（doc flavor）不在打印机所支持的格式中。如果客户机指定了具有 "application/octet-stream" 的 MIME 类型的 doc flavor，则如果打印机不能通过自动感知确定文档数据的实际格式，则打印机可能中止该作业（即使打印机支持显式指定的文档格式）。此值必须受支持，因为每个文档都需要指定 doc flavor。

DOCUMENT_FORMAT_ERROR

public static final JobStateReason DOCUMENT_FORMAT_ERROR
系统中止了作业，因为打印机在处理文档数据时遇到错误。如果打印机发送此原因，则文档数据已通过任何已导致 UNSUPPORTED_DOCUMENT_FORMAT 作业状态原因的测试。

PROCESSING_TO_STOP_POINT

public static final JobStateReason PROCESSING_TO_STOP_POINT
请求者已取消作业，或打印机已中止作业，但打印机仍在执行该作业的某些操作，直到遇到指定的停止点，或已完成作业终止/清除操作。

如果实现需要一段可度量的时间来取消处于 PROCESSING 或 PROCESSING_STOPPED 作业状态中的作业，则打印机必须使用此原因来指示打印机仍在执行作业的某些操作，同时该作业保持 PROCESSING 或 PROCESSING_STOPPED 状态。当所有作业的作业描述属性已停止增加时，打印机将作业从 PROCESSING 状态更改为 CANCELED 或 ABORTED 作业状态。

SERVICE_OFF_LINE

public static final JobStateReason SERVICE_OFF_LINE
打印机离线，不接受作业。所有 PENDING 状态的作业进入 PENDING_HELD 状态。如果服务或文档 转换的输入被破坏或崩溃，则可能发生此情况。

JOB_COMPLETED_SUCCESSFULLY

public static final JobStateReason JOB_COMPLETED_SUCCESSFULLY
作业成功完成。此值应受支持。

JOB_COMPLETED_WITH_WARNINGS

public static final JobStateReason JOB_COMPLETED_WITH_WARNINGS
作业以警告结束。如果实现检测到警告，则此值应受支持。

JOB_COMPLETED_WITH_ERRORS

public static final JobStateReason JOB_COMPLETED_WITH_ERRORS
作业以错误结束（也可能是警告）。如果实现检测到错误，则此值应受支持。

JOB_RESTARTABLE

public static final JobStateReason JOB_RESTARTABLE
此作业被保留，且当前可以重新开始。如果作业的 JobStateReasons 属性中包含 JOB_RESTARTABLE，则打印机必须接受请求以重新开始该作业。如果支持重新开始作业，则此值应受支持。[目前 Java Print Service API 中没有重新开始作业的功能。]

QUEUED_IN_DEVICE

public static final JobStateReason QUEUED_IN_DEVICE
作业已被转发到某个不能发送回状态的设备或打印系统。打印机将作业的 JobState 属性设置为 COMPLETED，并将 QUEUED_IN_DEVICE 原因添加到作业的 JobStateReasons 属性，以指示打印机没有有关作业的额外信息，并且将永远没有任何更多信息。

构造方法详细信息

JobStateReason

protected JobStateReason(int value)
构造具有给定整数值的新 JobStateReason 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 JobStateReason 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 JobStateReason 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobStateReason 类和任何供应商定义的子类，类别为 JobStateReason 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobStateReason 类和任何供应商定义的子类，类别名称为 "job-state-reason"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JobStateReasons (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 JobStateReasons

java.lang.Object
    继承者  java.util.AbstractCollection<E>
        继承者  java.util.AbstractSet<E>
            继承者  java.util.HashSet<JobStateReason>
                继承者  javax.print.attribute.standard.JobStateReasons
所有已实现的接口：
Serializable, Cloneable, Iterable<JobStateReason>, Collection<JobStateReason>, Set<JobStateReason>, Attribute, PrintJobAttribute
public final class JobStateReasons
extends HashSet<JobStateReason>
implements PrintJobAttribute

JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。

JobStateReason 的实例不直接出现在 Print Job 的属性集中。但是，JobStateReasons 属性出现在 Print Job 的属性集中。JobStateReasons 属性包含零个、一个或多个 JobStateReason 对象，它们属于 Print Job 的状态。当 Print Job 的对应条件变为 true 时，打印机将 JobStateReason 对象添加到 Print Job 的 JobStateReasons 属性，且当对应条件变为 false 时，再移除 JobStateReason 对象，而不管 Print Job 的总体 JobState 是否也更改。

JobStateReasons 类从 java.util.HashSet 类继承其实现。与大多数构造后不可变的打印属性不同，我们把 JobStateReasons 类设计为可变的，您可以将 JobStateReason 对象添加到现有 JobStateReasons 对象中，也可以再移除它们。但是，与 java.util.HashSet 类一样, JobStateReasons 类不是多线程安全的。如果 JobStateReasons 对象将供多个线程使用，则要保证使其操作同步（例如，使用从 java.util.Collections 类获取的同步 set 视图）。

IPP 兼容性：每个单个 JobStateReason 对象的 toString() 方法所返回的字符串值给出了 IPP 关键字值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
JobStateReasons()
构造新的空作业状态原因属性；底层哈希集合具有默认的初始容量和加载因子。
JobStateReasons(Collection<JobStateReason> collection)
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。
JobStateReasons(int initialCapacity)
构造新的空作业状态原因属性；底层哈希集合具有给定的初始容量和默认的加载因子。
JobStateReasons(int initialCapacity, float loadFactor)
构造新的空作业状态原因属性；底层哈希集合具有给定的容量和加载因子。
方法摘要
boolean | add(JobStateReason o) 将指定的元素添加到此作业状态原因属性（如果它尚未存在）。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 java.util.HashSet 继承的方法
clear, clone, contains, isEmpty, iterator, remove, size
从类 java.util.AbstractSet 继承的方法
equals, hashCode, removeAll
从类 java.util.AbstractCollection 继承的方法
addAll, containsAll, retainAll, toArray, toArray, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Set 继承的方法
addAll, containsAll, equals, hashCode, removeAll, retainAll, toArray, toArray

构造方法详细信息

JobStateReasons

public JobStateReasons()
构造新的空作业状态原因属性；底层哈希集合具有默认的初始容量和加载因子。

JobStateReasons

public JobStateReasons(int initialCapacity)
构造新的空作业状态原因属性；底层哈希集合具有给定的初始容量和默认的加载因子。

参数：
initialCapacity - 初始容量。
抛出：
IllegalArgumentException - 如果初始容量小于零。

JobStateReasons

public JobStateReasons(int initialCapacity,
                       float loadFactor)
构造新的空作业状态原因属性；底层哈希集合具有给定的容量和加载因子。

参数：
initialCapacity - 初始容量。
loadFactor - 加载因子。
抛出：
IllegalArgumentException - 如果初始容量小于零。

JobStateReasons

public JobStateReasons(Collection<JobStateReason> collection)
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。底层哈希集合的初始容量和加载因子如超类构造方法 HashSet(Collection) 中所指定的那样。

参数：
collection - 要复制的集合。
抛出：
NullPointerException - （未检查的异常）如果 collection 为 null，或 collection 中任何元素为 null，则抛出此异常。
ClassCastException - （未检查的异常）如果 collection 中任何元素不是 JobStateReason 类的实例，则抛出此异常。
方法详细信息

add

public boolean add(JobStateReason o)
将指定的元素添加到此作业状态原因属性（如果它尚未存在）。要添加的元素必须为 JobStateReason 类的实例。如果此作业状态原因属性已经包含指定的元素，则该调用不改变此作业状态原因属性并返回 false。

指定者：
接口 Collection<JobStateReason> 中的 add
指定者：
接口 Set<JobStateReason> 中的 add
覆盖：
类 HashSet<JobStateReason> 中的 add
参数：
o - 将要添加到此作业状态原因属性中的元素。
返回：
如果此作业状态原因属性不包含指定的元素，则返回 true。
抛出：
NullPointerException - （未检查的异常）如果指定的元素为 null，则抛出此异常。
ClassCastException - （未检查的异常）如果指定的元素不是 JobStateReason 类的实例，则抛出此异常。
从以下版本开始：
1.5

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 JobStateReasons 类，类别为 JobStateReasons 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 JobStateReasons 类，类别名称为 "job-state-reasons"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Media (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Media

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Media
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
直接已知子类：
MediaName, MediaSizeName, MediaTray
public abstract class Media
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

Media 类是打印属性类，它指定了要在其上打印的介质。

可以以不同方式指定 Media。

  • 可以通过纸张源（例如纸张托盘）来指定它
  • 可以通过标准大小（例如 "A4"）来指定它
  • 可以通过名称（例如 "letterhead"）来指定它
其中每个对应于 IPP "media" 属性。当前 API 不支持通过特征（例如颜色，不透明度）来描述介质。规范的以后版本可能支持这一点。

Media 对象是通过表示某种方式（可以以该方式指定 Media 属性）的值构造的。

IPP Compatibility: getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

构造方法摘要
protected Media(int value)
构造通过名称指定的新 Media 属性。
方法摘要
boolean | equals(Object object) 返回此介质属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getEnumValueTable, getOffset, getStringTable, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Media

protected Media(int value)
构造通过名称指定的新 Media 属性。

参数：
value - 值。
方法详细信息

equals

public boolean equals(Object object)
返回此介质属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是与此对象相同的 Media 的子类。
  3. 值相等。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此介质属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 Media 类和任何供应商定义的子类，类别为 Media 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 Media 类和任何供应商定义的子类，类别名称为 "media"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Sides (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Sides

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Sides
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class Sides
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

多文档打印（一个作业带有多个文档）作业的 Sides 属性的效果取决于是为所有的文档指定了相同的 sides 值，还是不同的文档指定了不同的 sides 值，以及 MultipleDocumentHandling 属性的值（可能是默认值）。

  • 如果所有的文档指定了相同的 sides 值 n，则 MultipleDocumentHandling 的任何值都有意义，因此打印机的处理取决于 MultipleDocumentHandling 的值：
    • SINGLE_DOCUMENT -- 所有输入文档都将合并到一个输出文档中。每个介质纸张都包括来自输出文档的 n 个印张。

    • SINGLE_DOCUMENT_NEW_SHEET -- 所有输入文档都将合并到一个输出文档中。每个介质纸张都包括来自输出文档的 n 个印张。但是，始终在新的介质纸张上开始每个输入文档的第一个印张；这意味着输入文档的最后一张介质纸张上可能只有一个印张。

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- 输入文档将保持为单独的文档。每个介质纸张都包括来自输入文档的 n 个印张。由于输入文档是单独的，所以始终在新的介质纸张上开始每个输入文档的第一个印张；这意味着输入文档的最后一张介质纸张上可能只有一个印张。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES -- 输入文档将保持为单独的文档。每个介质纸张都包括来自输入文档的 n 个印张。由于输入文档是单独的，所以始终在新的介质纸张上开始每个输入文档的第一个印张；这意味着输入文档的最后一张介质纸张上可能只有一个印张。

    • SINGLE_DOCUMENT -- 所有输入文档都将合并到一个输出文档中。每个介质纸张都将包括来自输出文档的 ni 个印张，其中 i 是与输出文档中的数量对应的输入文档数量。当下一个输入文档具有不同于前一个输入文档的 sides 值时，下一个输入文档的第一个打印流页将从下一个介质纸张处开始，因此很可能会在前一个介质纸张上只留下一个印张。

    • SINGLE_DOCUMENT_NEW_SHEET -- 所有输入文档都将合并到一个输出文档中。每个介质纸张都包括来自输出文档的 n 个印张。但是，始终在新的介质纸张上开始每个输入文档的第一个印张；这意味着输入文档的最后一张介质纸张上可能只有一个印张。

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- 输入文档将保持为单独的文档。对于输入文档 i，每个介质纸张都包括来自该输入文档的 ni 个印张。由于输入文档是单独，所以始终在新的介质纸张上开始每个输入文档的第一个印张；这意味着输入文档的最后一张介质纸张上可能只有一个印张。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES -- 输入文档将保持为单独的文档。对于输入文档 i，每个介质纸张都包括来自该输入文档的 ni 个印张。由于输入文档是单独，所以始终在新的介质纸张上开始每个输入文档的第一个印张；这意味着输入文档的最后一张介质纸张上可能只有一个印张。

IPP 兼容性：由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static Sides | DUPLEX “双面长边”的别名（请参阅 TWO_SIDED_LONG_EDGE）。
static Sides | ONE_SIDED 将每个连续的打印流页应用于连续介质纸张的相同面。
static Sides | TUMBLE “双面短边”的别名（请参阅 TWO_SIDED_SHORT_EDGE）。
static Sides | TWO_SIDED_LONG_EDGE 将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在长边上一样。
static Sides | TWO_SIDED_SHORT_EDGE 将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在短边上一样。
构造方法摘要
protected Sides(int value)
构造具有给定整数值的新 sides 枚举值，
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 Sides 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 Sides 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ONE_SIDED

public static final Sides ONE_SIDED
将每个连续的打印流页应用于连续介质纸张的相同面。

TWO_SIDED_LONG_EDGE

public static final Sides TWO_SIDED_LONG_EDGE
将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在长边上一样。此整版形式称为 "duplex"（请参阅 DUPLEX）。

TWO_SIDED_SHORT_EDGE

public static final Sides TWO_SIDED_SHORT_EDGE
将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在短边上一样。此整版形式称为 "tumble"（请参阅 TUMBLE）。

DUPLEX

public static final Sides DUPLEX
“双面长边”的别名（请参阅 TWO_SIDED_LONG_EDGE）。

TUMBLE

public static final Sides TUMBLE
“双面短边”的别名（请参阅 TWO_SIDED_SHORT_EDGE）。

构造方法详细信息

Sides

protected Sides(int value)
构造具有给定整数值的新 sides 枚举值，

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 Sides 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 Sides 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 Sides，该类别就是类 Sides 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 Sides，类别名称是 "sides"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MediaName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaName

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Media
            继承者  javax.print.attribute.standard.MediaName
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public class MediaName
extends Media
implements Attribute

MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。

可以使用此属性来替代指定 MediaSize 或 MediaTray。

MediaName 类当前声明了几种标准介质名称。由实现或位置定义的介质名称属性的名称也可以通过定义 MediaName 类的子类来创建。

IPP Compatibility: MediaName 是命名介质的 IPP "media" 属性值的表示类。

另请参见：
序列化表格

字段摘要
static MediaName | ISO_A4_TRANSPARENT A4 纸透明度。
static MediaName | ISO_A4_WHITE 空白 A4 纸。
static MediaName | NA_LETTER_TRANSPARENT 信纸透明度。
static MediaName | NA_LETTER_WHITE 空白信纸。
构造方法摘要
protected MediaName(int value)
构造具有给定整数值的新 MediaName 枚举值。
方法摘要
protected EnumSyntax[] | getEnumValueTable() 返回 MediaTray 类的枚举值表。
protected String[] | getStringTable() 返回 MediaTray 类的字符串表。
从类 javax.print.attribute.standard.Media 继承的方法
equals, getCategory, getName
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.print.attribute.Attribute 继承的方法
getCategory, getName

字段详细信息

NA_LETTER_WHITE

public static final MediaName NA_LETTER_WHITE
空白信纸。

NA_LETTER_TRANSPARENT

public static final MediaName NA_LETTER_TRANSPARENT
信纸透明度。

ISO_A4_WHITE

public static final MediaName ISO_A4_WHITE
空白 A4 纸。

ISO_A4_TRANSPARENT

public static final MediaName ISO_A4_TRANSPARENT
A4 纸透明度。

构造方法详细信息

MediaName

protected MediaName(int value)
构造具有给定整数值的新 MediaName 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 MediaTray 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
String 表。

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 MediaTray 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
枚举值表。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaPrintableArea (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaPrintableArea

java.lang.Object
    继承者  javax.print.attribute.standard.MediaPrintableArea
所有已实现的接口：
Serializable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class MediaPrintableArea
extends Object
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。

可打印区域被指定为介质总维度之内的矩形。

大多数打印机不能在介质的整个表面上打印，这是由于打印机的硬件限制。此类可用于查询所假定的打印作业的可接受值，以及请求要在打印作业中使用的可打印区域的限制之内的某个区域。

要查询可打印区域，客户机必须提供适合的上下文。如果不至少指定要使用的介质尺寸，则不能获取有意义的可打印区域值。

此属性不是根据与纸边的距离描述的，部分是强调此属性不是与特定介质无关的，但必须在其他属性的选择上下文中进行描述。此外，客户机使用可打印区域更为方便。

硬件的最小页边距不仅是打印机的属性，而且是介质尺寸、方向、介质类型和任何指定的 finishing 的函数。PrintService 提供了在适合的上下文中查询支持的属性值的方法：参见 PrintService.getSupportedAttributeValues()

矩形可打印区域定义如下：在纵向模式中，(x,y) 原点位于纸张左上角，与在请求上下文中所指定的方向无关。例如，纵向或横向方向中 A4 纸的可打印区域中， height > width。

可打印区域属性的值以整数值形式进行内部存储，以 micrometers (µm) 为单位，其中 1 micrometer = 10-6 meter = 1/1000 millimeter = 1/25400 inch。这使要表示的维度精确到 1/1000 毫米 (= 1 µm) 或 1/100 英寸 (= 254 µm)。如果小数 inch 以 2 的负数次幂表示，则这允许将维度精确表示为 1/8 inch (= 3175 µm) 而不是 1/16 inch 的精度（因为 1/16 inch 不等于整数的 µm）。

IPP Compatibility: MediaPrintableArea 不是 IPP 属性。

另请参见：
序列化表格

字段摘要
static int | INCH 指示以 inch (in) 为单位的值。
static int | MM 指示以 millimeters (mm) 为单位的值。
构造方法摘要
MediaPrintableArea(float x, float y, float w, float h, int units)
从浮点值构造 MediaPrintableArea 对象。
MediaPrintableArea(int x, int y, int w, int h, int units)
从整数值构造 MediaPrintableArea 对象。
方法摘要
boolean | equals(Object object) 返回此介质页边距属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
float | getHeight(int units) 以指定单位获取可打印区域的 height。
String | getName() 获取类别名称，此属性值为该类别的实例。
float[] | getPrintableArea(int units) 以顺序为 x, y, w, h 的 4 个值的数组形式获取可打印区域。
float | getWidth(int units) 以指定单位获取可打印区域的 width。
float | getX(int units) 以指定的单位获取可打印区域的原点的 x 位置。
float | getY(int units) 以指定单位获取可打印区域的原点的 y 位置。
int | hashCode() 返回此属性的哈希码值。
String | toString() 以 mm 为单位返回此矩形大小属性的字符串版本。
String | toString(int units, String unitsName) 以给定单位返回此矩形大小属性的字符串版本。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

INCH

public static final int INCH
指示以 inch (in) 为单位的值。它实际上是转换因子，英寸乘以该转换因子得到微米 (25400)。

另请参见：
常量字段值

MM

public static final int MM
指示以 millimeters (mm) 为单位的值。它实际上是转换因子，毫米乘以该转换因子得到微米 (1000)。

另请参见：
常量字段值
构造方法详细信息

MediaPrintableArea

public MediaPrintableArea(float x,
                          float y,
                          float w,
                          float h,
                          int units)
从浮点值构造 MediaPrintableArea 对象。

参数：
x - 可打印的 x
y - 可打印的 y
w - 可打印的 width
h - 可打印的 height
units - 用于表示值的单位。
抛出：
IllegalArgumentException - 如果 x < 0 或 y < 0 或 w <= 0 或 h <= 0 或 units < 1，则抛出此异常。

MediaPrintableArea

public MediaPrintableArea(int x,
                          int y,
                          int w,
                          int h,
                          int units)
从整数值构造 MediaPrintableArea 对象。

参数：
x - 可打印的 x
y - 可打印的 y
w - 可打印的 width
h - 可打印的 height
units - 用于表示值的单位。
抛出：
IllegalArgumentException - 如果 x < 0 或 y < 0 或 w <= 0 或 h <= 0 或 units < 1，则抛出此异常。
方法详细信息

getPrintableArea

public float[] getPrintableArea(int units)
以顺序为 x, y, w, h 的 4 个值的数组形式获取可打印区域。返回的值以给定单位为单位。

参数：
units - 单位转换因子，例如，INCH 或 MM。
返回：
以指定的单位返回 x, y, w, h 数组形式的可打印区域。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getX

public float getX(int units)
以指定的单位获取可打印区域的原点的 x 位置。

参数：
units - 单位转换因子，例如，INCH 或 MM。
返回：
以指定单位返回可打印区域的原点的 x 位置。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getY

public float getY(int units)
以指定单位获取可打印区域的原点的 y 位置。

参数：
units - 单位转换因子，例如，INCH 或 MM。
返回：
以指定单位返回可打印区域的原点的 y 位置。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getWidth

public float getWidth(int units)
以指定单位获取可打印区域的 width。

参数：
units - 单位转换因子，例如，INCH 或 MM。
返回：
以指定单位返回可打印区域的 width。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

getHeight

public float getHeight(int units)
以指定单位获取可打印区域的 height。

参数：
units - 单位转换因子，例如 INCH 或 MM。
返回：
以指定单位返回可打印区域的 height。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

equals

public boolean equals(Object object)
返回此介质页边距属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 MediaPrintableArea 类的实例。
  3. 原点和维度是相同的。

覆盖：
类 Object 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此介质页边距属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 MediaPrintableArea 类，类别为 MediaPrintableArea 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 MediaPrintableArea 类，类别名称为 "media-printable-area"。

这不是 IPP V1.1 属性。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。

toString

public String toString(int units,
                       String unitsName)
以给定单位返回此矩形大小属性的字符串版本。

参数：
units - 单位转换因子，例如 INCH 或 MM。
unitsName - 单位名称字符串，例如 "in" 或 "mm"。如果为 null，则没有任何单位名称附加到该结果。
返回：
此二维大小属性的字符串版本。
抛出：
IllegalArgumentException - （未经检查的异常）如果 units < 1，则抛出该异常。

toString

public String toString()
以 mm 为单位返回此矩形大小属性的字符串版本。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

hashCode

public int hashCode()
返回此属性的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaSize (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaSize

java.lang.Object
    继承者  javax.print.attribute.Size2DSyntax
        继承者  javax.print.attribute.standard.MediaSize
所有已实现的接口：
Serializable, Cloneable, Attribute
public class MediaSize
extends Size2DSyntax
implements Attribute

MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。因此，Y 维度必须大小或等于 X 维度。MediaSize 类声明了许多标准介质尺寸值，这些值被组织到 ISO、JIS、North American、engineering 和其他介质的嵌套类中。

MediaSize 尚未用于指定介质。其当前职责是作为指定的介质的映射（参见 MediaSizeName）。客户机可以使用映射方法 MediaSize.getMediaSizeForName(MediaSizeName) 来查找此 API 中枚举的 MediaSizeName 实例的物理维度。此方法适用于需要此信息来格式化打印和标记打印页数的客户机。

另请参见：
序列化表格

嵌套类摘要
static class | MediaSize.Engineering MediaSize.Engineering 类包括 engineering 介质的 MediaSize 值。
static class | MediaSize.ISO MediaSize.ISO 类包括 ISO 介质的 MediaSize 值。
static class | MediaSize.JIS MediaSize.JIS 类包括 JIS (Japanese) 介质的 MediaSize 值。
static class | MediaSize.NA MediaSize.NA 类包括 North American 介质的 MediaSize 值。
static class | MediaSize.Other MediaSize.Other 类包括其他介质的 MediaSize 值。
字段摘要
从类 javax.print.attribute.Size2DSyntax 继承的字段
INCH, MM
构造方法摘要
MediaSize(float x, float y, int units)
从给定浮点值构造新 MediaSize 属性。
MediaSize(float x, float y, int units, MediaSizeName media)
从给定浮点值构造新 MediaSize 属性。
MediaSize(int x, int y, int units)
从给定整数值构造新 MediaSize 属性。
MediaSize(int x, int y, int units, MediaSizeName media)
从给定整数值构造新 MediaSize 属性。
方法摘要
boolean | equals(Object object) 返回此介质尺寸属性是否等效于传入的对象。
static MediaSizeName | findMedia(float x, float y, int units) 指定的维度用于从所有标准 MediaSize 实例中定位一个匹配的 MediaSize 实例。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
static MediaSize | getMediaSizeForName(MediaSizeName media) 获取指定的命名介质的 MediaSize。
MediaSizeName | getMediaSizeName() 获取此尺寸的介质名称（如果有）。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.Size2DSyntax 继承的方法
getSize, getX, getXMicrometers, getY, getYMicrometers, hashCode, toString, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MediaSize

public MediaSize(float x,
                 float y,
                 int units)
从给定浮点值构造新 MediaSize 属性。

参数：
x - X 维度。
y - Y 维度。
units - 单位转换因子，例如 Size2DSyntax.INCH 或 Size2DSyntax.MM。
抛出：
IllegalArgumentException - （未检查的异常）如果 x < 0 或 y < 0 或 units < 1 或 x > y，则抛出此异常。

MediaSize

public MediaSize(int x,
                 int y,
                 int units)
从给定整数值构造新 MediaSize 属性。

参数：
x - X 维度。
y - Y 维度。
units - 单位转换因子，例如 Size2DSyntax.INCH 或 Size2DSyntax.MM。
抛出：
IllegalArgumentException - （未检查的异常）如果 x < 0 或 y < 0 或 units < 1 或 x > y，则抛出此异常。

MediaSize

public MediaSize(float x,
                 float y,
                 int units,
                 MediaSizeName media)
从给定浮点值构造新 MediaSize 属性。

参数：
x - X 维度。
y - Y 维度。
units - 单位转换因子，例如 Size2DSyntax.INCH 或 Size2DSyntax.MM。
media - 与此 MediaSize 关联的介质名称
抛出：
IllegalArgumentException - （未检查的异常）如果 x < 0 或 y < 0 或 units < 1 或 x > y，则抛出此异常。

MediaSize

public MediaSize(int x,
                 int y,
                 int units,
                 MediaSizeName media)
从给定整数值构造新 MediaSize 属性。

参数：
x - X 维度。
y - Y 维度。
units - 单位转换因子，例如 Size2DSyntax.INCH 或 Size2DSyntax.MM。
media - 与此 MediaSize 关联的介质名称
抛出：
IllegalArgumentException - （未检查的异常）如果 x < 0 或 y < 0 或 units < 1 或 x > y，则抛出此异常。
方法详细信息

getMediaSizeName

public MediaSizeName getMediaSizeName()
获取此尺寸的介质名称（如果有）。

返回：
此介质尺寸的名称，如果没有与此尺寸关联的名称（匿名尺寸），则返回 null。

getMediaSizeForName

public static MediaSize getMediaSizeForName(MediaSizeName media)
获取指定的命名介质的 MediaSize。

参数：
media - - 要查找其尺寸的介质名称
返回：
介质尺寸，如果此介质与任何尺寸均不关联，则返回 null。

findMedia

public static MediaSizeName findMedia(float x,
                                      float y,
                                      int units)
指定的维度用于从所有标准 MediaSize 实例中定位一个匹配的 MediaSize 实例。如果没有精确匹配，则使用最接近的匹配。

然后依次使用 MediaSize 查找 MediaSizeName 对象。如果最接近的匹配 MediaSize 没有对应的 Media 实例，则此方法可能返回 null。

此方法适用于只具有维度并且希望查找对应于该维度的 Media 的客户机。

参数：
x - - X 维度
y - - Y 维度。
units - 单位转换因子，例如 Size2DSyntax.INCH 或 Size2DSyntax.MM
返回：
与这些维度匹配的 MediaSizeName 或 null。
抛出：
IllegalArgumentException - 如果 x <= 0、y <= 0 或 units < 1，则抛出此异常

equals

public boolean equals(Object object)
返回此介质尺寸属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 MediaSize 类的实例。
  3. 此介质大小属性的 X 维度与 object 的 X 维度相等。
  4. 此介质大小属性的 Y 维度与 object 的 Y 维度相等。

覆盖：
类 Size2DSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此介质尺寸属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 MediaSize 类和任何供应商定义的子类，类别为 MediaSize 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 MediaSize 类和任何供应商定义的子类，类别名称为 "media-size"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaSize.Engineering (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaSize.Engineering

java.lang.Object
    继承者  javax.print.attribute.standard.MediaSize.Engineering
正在封闭类：
MediaSize
public static final class MediaSize.Engineering
extends Object

MediaSize.Engineering 类包括 engineering 介质的 MediaSize 值。

字段摘要
static MediaSize | A 指定 engineering A 尺寸，8.5 inch × 11 inch。
static MediaSize | B 指定 engineering B 尺寸，11 inch × 17 inch。
static MediaSize | C 指定 engineering C 尺寸，17 inch × 22 inch。
static MediaSize | D 指定 engineering D 尺寸，22 inch × 34 inch。
static MediaSize | E 指定 engineering E 尺寸，34 inch × 44 inch。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

A

public static final MediaSize A
指定 engineering A 尺寸，8.5 inch × 11 inch。

B

public static final MediaSize B
指定 engineering B 尺寸，11 inch × 17 inch。

C

public static final MediaSize C
指定 engineering C 尺寸，17 inch × 22 inch。

D

public static final MediaSize D
指定 engineering D 尺寸，22 inch × 34 inch。

E

public static final MediaSize E
指定 engineering E 尺寸，34 inch × 44 inch。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaSize.ISO (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaSize.ISO

java.lang.Object
    继承者  javax.print.attribute.standard.MediaSize.ISO
正在封闭类：
MediaSize
public static final class MediaSize.ISO
extends Object

MediaSize.ISO 类包括 ISO 介质的 MediaSize 值。

字段摘要
static MediaSize | A0 指定 ISO A0 尺寸，841 mm × 1189 mm。
static MediaSize | A1 指定 ISO A1 尺寸，594 mm × 841 mm。
static MediaSize | A10 指定 ISO A10 尺寸，26 mm × 37 mm。
static MediaSize | A2 指定 ISO A2 尺寸，420 mm × 594 mm。
static MediaSize | A3 指定 ISO A3 尺寸，297 mm × 420 mm。
static MediaSize | A4 指定 ISO A4 尺寸，210 × by 297 mm。
static MediaSize | A5 指定 ISO A5 尺寸，148 mm × 210 mm。
static MediaSize | A6 指定 ISO A6 尺寸，105 mm × 148 mm。
static MediaSize | A7 指定 ISO A7 尺寸，74 mm × 105 mm。
static MediaSize | A8 指定 ISO A8 尺寸，52 mm × 74 mm。
static MediaSize | A9 指定 ISO A9 尺寸，37 mm × 52 mm。
static MediaSize | B0 指定 ISO B0 尺寸，1000 mm × 1414 mm。
static MediaSize | B1 指定 ISO B1 尺寸，707 mm × 1000 mm。
static MediaSize | B10 指定 ISO B10 尺寸，31 mm × 44 mm。
static MediaSize | B2 指定 ISO B2 尺寸，500 mm × 707 mm。
static MediaSize | B3 指定 ISO B3 尺寸，353 mm × 500 mm。
static MediaSize | B4 指定 ISO B4 尺寸，250 mm × 353 mm。
static MediaSize | B5 指定 ISO B5 尺寸，176 mm × 250 mm。
static MediaSize | B6 指定 ISO B6 尺寸，125 mm × 176 mm。
static MediaSize | B7 指定 ISO B7 尺寸，88 mm × 125 mm。
static MediaSize | B8 指定 ISO B8 尺寸，62 mm × 88 mm。
static MediaSize | B9 指定 ISO B9 尺寸，44 mm × 62 mm。
static MediaSize | C3 指定 ISO C3 尺寸，324 mm × 458 mm。
static MediaSize | C4 指定 ISO C4 尺寸，229 mm × 324 mm。
static MediaSize | C5 指定 ISO C5 尺寸，162 mm × 229 mm。
static MediaSize | C6 指定 ISO C6 尺寸，114 mm × 162 mm。
static MediaSize | DESIGNATED_LONG 指定 ISO Designated Long 尺寸，110 mm × 220 mm。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

A0

public static final MediaSize A0
指定 ISO A0 尺寸，841 mm × 1189 mm。

A1

public static final MediaSize A1
指定 ISO A1 尺寸，594 mm × 841 mm。

A2

public static final MediaSize A2
指定 ISO A2 尺寸，420 mm × 594 mm。

A3

public static final MediaSize A3
指定 ISO A3 尺寸，297 mm × 420 mm。

A4

public static final MediaSize A4
指定 ISO A4 尺寸，210 × by 297 mm。

A5

public static final MediaSize A5
指定 ISO A5 尺寸，148 mm × 210 mm。

A6

public static final MediaSize A6
指定 ISO A6 尺寸，105 mm × 148 mm。

A7

public static final MediaSize A7
指定 ISO A7 尺寸，74 mm × 105 mm。

A8

public static final MediaSize A8
指定 ISO A8 尺寸，52 mm × 74 mm。

A9

public static final MediaSize A9
指定 ISO A9 尺寸，37 mm × 52 mm。

A10

public static final MediaSize A10
指定 ISO A10 尺寸，26 mm × 37 mm。

B0

public static final MediaSize B0
指定 ISO B0 尺寸，1000 mm × 1414 mm。

B1

public static final MediaSize B1
指定 ISO B1 尺寸，707 mm × 1000 mm。

B2

public static final MediaSize B2
指定 ISO B2 尺寸，500 mm × 707 mm。

B3

public static final MediaSize B3
指定 ISO B3 尺寸，353 mm × 500 mm。

B4

public static final MediaSize B4
指定 ISO B4 尺寸，250 mm × 353 mm。

B5

public static final MediaSize B5
指定 ISO B5 尺寸，176 mm × 250 mm。

B6

public static final MediaSize B6
指定 ISO B6 尺寸，125 mm × 176 mm。

B7

public static final MediaSize B7
指定 ISO B7 尺寸，88 mm × 125 mm。

B8

public static final MediaSize B8
指定 ISO B8 尺寸，62 mm × 88 mm。

B9

public static final MediaSize B9
指定 ISO B9 尺寸，44 mm × 62 mm。

B10

public static final MediaSize B10
指定 ISO B10 尺寸，31 mm × 44 mm。

C3

public static final MediaSize C3
指定 ISO C3 尺寸，324 mm × 458 mm。

C4

public static final MediaSize C4
指定 ISO C4 尺寸，229 mm × 324 mm。

C5

public static final MediaSize C5
指定 ISO C5 尺寸，162 mm × 229 mm。

C6

public static final MediaSize C6
指定 ISO C6 尺寸，114 mm × 162 mm。

DESIGNATED_LONG

public static final MediaSize DESIGNATED_LONG
指定 ISO Designated Long 尺寸，110 mm × 220 mm。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaSize.JIS (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaSize.JIS

java.lang.Object
    继承者  javax.print.attribute.standard.MediaSize.JIS
正在封闭类：
MediaSize
public static final class MediaSize.JIS
extends Object

MediaSize.JIS 类包括 JIS (Japanese) 介质的 MediaSize 值。

字段摘要
static MediaSize | B0 指定 JIS B0 尺寸，1030 mm × 1456 mm。
static MediaSize | B1 指定 JIS B1 尺寸，728 mm × 1030 mm。
static MediaSize | B10 指定 JIS B10 尺寸，32 mm × 45 mm。
static MediaSize | B2 指定 JIS B2 尺寸，515 mm × 728 mm。
static MediaSize | B3 指定 JIS B3 尺寸，364 mm × 515 mm。
static MediaSize | B4 指定 JIS B4 尺寸，257 mm × 364 mm。
static MediaSize | B5 指定 JIS B5 尺寸，182 mm × 257 mm。
static MediaSize | B6 指定 JIS B6 尺寸，128 mm × 182 mm。
static MediaSize | B7 指定 JIS B7 尺寸，91 mm × 128 mm。
static MediaSize | B8 指定 JIS B8 尺寸，64 mm × 91 mm。
static MediaSize | B9 指定 JIS B9 尺寸，45 mm × 64 mm。
static MediaSize | CHOU_1 指定 JIS Chou ("long") #1 信封尺寸，142 mm × 332 mm。
static MediaSize | CHOU_2 指定 JIS Chou ("long") #2 信封尺寸，119 mm × 277 mm。
static MediaSize | CHOU_3 指定 JIS Chou ("long") #3 信封尺寸，120 mm by 235 mm。
static MediaSize | CHOU_30 指定 JIS Chou ("long") #30 信封尺寸，92 mm by 235 mm。
static MediaSize | CHOU_4 指定 JIS Chou ("long") #4 信封尺寸，90 mm × 205 mm。
static MediaSize | CHOU_40 指定 JIS Chou ("long") #40 信封尺寸，90 mm × 225 mm。
static MediaSize | KAKU_0 指定 JIS Kaku ("square") #0 信封尺寸，287 mm × 382 mm。
static MediaSize | KAKU_1 指定 JIS Kaku ("square") #1 信封尺寸，270 mm × 382 mm。
static MediaSize | KAKU_2 指定 JIS Kaku ("square") #2 信封尺寸，240 mm × 332 mm。
static MediaSize | KAKU_20 指定 JIS Kaku ("square") #20 信封尺寸，229 mm × 324 mm。
static MediaSize | KAKU_3 指定 JIS Kaku ("square") #3 信封尺寸，216 mm × 277 mm。
static MediaSize | KAKU_4 指定 JIS Kaku ("square") #4 信封尺寸，197 mm × 267 mm。
static MediaSize | KAKU_5 指定 JIS Kaku ("square") #5 信封尺寸，190 mm by 240 mm。
static MediaSize | KAKU_6 指定 JIS Kaku ("square") #6 信封尺寸，162 mm × 229 mm。
static MediaSize | KAKU_7 指定 JIS Kaku ("square") #7 信封尺寸，142 mm × 205 mm。
static MediaSize | KAKU_8 指定 JIS Kaku ("square") #8 信封尺寸，119 mm × 197 mm。
static MediaSize | KAKU_A4 指定 JIS Kaku ("square") A4 信封尺寸，228 mm × 312 mm。
static MediaSize | YOU_1 指定 JIS You ("Western") #1 信封尺寸，120 mm × 176 mm。
static MediaSize | YOU_2 指定 JIS You ("Western") #2 信封尺寸，114 mm × 162 mm。
static MediaSize | YOU_3 指定 JIS You ("Western") #3 信封尺寸，98 mm × 148 mm。
static MediaSize | YOU_4 指定 JIS You ("Western") #4 信封尺寸，105 mm × 235 mm。
static MediaSize | YOU_5 指定 JIS You ("Western") #5 信封尺寸，95 mm × 217 mm。
static MediaSize | YOU_6 指定 JIS You ("Western") #6 信封尺寸，98 mm × 190 mm。
static MediaSize | YOU_7 指定 JIS You ("Western") #7 信封尺寸，92 mm × 165 mm。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

B0

public static final MediaSize B0
指定 JIS B0 尺寸，1030 mm × 1456 mm。

B1

public static final MediaSize B1
指定 JIS B1 尺寸，728 mm × 1030 mm。

B2

public static final MediaSize B2
指定 JIS B2 尺寸，515 mm × 728 mm。

B3

public static final MediaSize B3
指定 JIS B3 尺寸，364 mm × 515 mm。

B4

public static final MediaSize B4
指定 JIS B4 尺寸，257 mm × 364 mm。

B5

public static final MediaSize B5
指定 JIS B5 尺寸，182 mm × 257 mm。

B6

public static final MediaSize B6
指定 JIS B6 尺寸，128 mm × 182 mm。

B7

public static final MediaSize B7
指定 JIS B7 尺寸，91 mm × 128 mm。

B8

public static final MediaSize B8
指定 JIS B8 尺寸，64 mm × 91 mm。

B9

public static final MediaSize B9
指定 JIS B9 尺寸，45 mm × 64 mm。

B10

public static final MediaSize B10
指定 JIS B10 尺寸，32 mm × 45 mm。

CHOU_1

public static final MediaSize CHOU_1
指定 JIS Chou ("long") #1 信封尺寸，142 mm × 332 mm。

CHOU_2

public static final MediaSize CHOU_2
指定 JIS Chou ("long") #2 信封尺寸，119 mm × 277 mm。

CHOU_3

public static final MediaSize CHOU_3
指定 JIS Chou ("long") #3 信封尺寸，120 mm by 235 mm。

CHOU_4

public static final MediaSize CHOU_4
指定 JIS Chou ("long") #4 信封尺寸，90 mm × 205 mm。

CHOU_30

public static final MediaSize CHOU_30
指定 JIS Chou ("long") #30 信封尺寸，92 mm by 235 mm。

CHOU_40

public static final MediaSize CHOU_40
指定 JIS Chou ("long") #40 信封尺寸，90 mm × 225 mm。

KAKU_0

public static final MediaSize KAKU_0
指定 JIS Kaku ("square") #0 信封尺寸，287 mm × 382 mm。

KAKU_1

public static final MediaSize KAKU_1
指定 JIS Kaku ("square") #1 信封尺寸，270 mm × 382 mm。

KAKU_2

public static final MediaSize KAKU_2
指定 JIS Kaku ("square") #2 信封尺寸，240 mm × 332 mm。

KAKU_3

public static final MediaSize KAKU_3
指定 JIS Kaku ("square") #3 信封尺寸，216 mm × 277 mm。

KAKU_4

public static final MediaSize KAKU_4
指定 JIS Kaku ("square") #4 信封尺寸，197 mm × 267 mm。

KAKU_5

public static final MediaSize KAKU_5
指定 JIS Kaku ("square") #5 信封尺寸，190 mm by 240 mm。

KAKU_6

public static final MediaSize KAKU_6
指定 JIS Kaku ("square") #6 信封尺寸，162 mm × 229 mm。

KAKU_7

public static final MediaSize KAKU_7
指定 JIS Kaku ("square") #7 信封尺寸，142 mm × 205 mm。

KAKU_8

public static final MediaSize KAKU_8
指定 JIS Kaku ("square") #8 信封尺寸，119 mm × 197 mm。

KAKU_20

public static final MediaSize KAKU_20
指定 JIS Kaku ("square") #20 信封尺寸，229 mm × 324 mm。

KAKU_A4

public static final MediaSize KAKU_A4
指定 JIS Kaku ("square") A4 信封尺寸，228 mm × 312 mm。

YOU_1

public static final MediaSize YOU_1
指定 JIS You ("Western") #1 信封尺寸，120 mm × 176 mm。

YOU_2

public static final MediaSize YOU_2
指定 JIS You ("Western") #2 信封尺寸，114 mm × 162 mm。

YOU_3

public static final MediaSize YOU_3
指定 JIS You ("Western") #3 信封尺寸，98 mm × 148 mm。

YOU_4

public static final MediaSize YOU_4
指定 JIS You ("Western") #4 信封尺寸，105 mm × 235 mm。

YOU_5

public static final MediaSize YOU_5
指定 JIS You ("Western") #5 信封尺寸，95 mm × 217 mm。

YOU_6

public static final MediaSize YOU_6
指定 JIS You ("Western") #6 信封尺寸，98 mm × 190 mm。

YOU_7

public static final MediaSize YOU_7
指定 JIS You ("Western") #7 信封尺寸，92 mm × 165 mm。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaSize.NA (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaSize.NA

java.lang.Object
    继承者  javax.print.attribute.standard.MediaSize.NA
正在封闭类：
MediaSize
public static final class MediaSize.NA
extends Object

MediaSize.NA 类包括 North American 介质的 MediaSize 值。

字段摘要
static MediaSize | LEGAL 指定 North American 合法尺寸，8.5 inch × 14 inch。
static MediaSize | LETTER 指定 North American 信纸尺寸，8.5 inch × 11 inch。
static MediaSize | NA_10x13_ENVELOPE 指定 North American 10 inch × 13 inch 信封尺寸。
static MediaSize | NA_10x14_ENVELOPE 指定 North American 10 inch × 14 inch 信封尺寸。
static MediaSize | NA_10X15_ENVELOPE 指定 North American 10 inch × 15 inch 信封尺寸。
static MediaSize | NA_5X7 指定 North American 5 inch × 7 inch 纸。
static MediaSize | NA_6X9_ENVELOPE 指定 North American 6 inch × 9 inch 信封尺寸。
static MediaSize | NA_7X9_ENVELOPE 指定 North American 7 inch × 9 inch 信封尺寸。
static MediaSize | NA_8X10 指定 North American 8 inch × 10 inch 纸。
static MediaSize | NA_9x11_ENVELOPE 指定 North American 9 inch × 11 inch 信封尺寸。
static MediaSize | NA_9x12_ENVELOPE 指定 North American 9 inch × 12 inch 信封尺寸。
static MediaSize | NA_NUMBER_10_ENVELOPE 指定 North American Number 10 商用信封尺寸，4.125 inch × 9.5 inch。
static MediaSize | NA_NUMBER_11_ENVELOPE 指定 North American Number 11 商用信封尺寸，4.5 inch × 10.375 inch。
static MediaSize | NA_NUMBER_12_ENVELOPE 指定 North American Number 12 商用信封尺寸，4.75 inch × 11 inch。
static MediaSize | NA_NUMBER_14_ENVELOPE 指定 North American Number 14 商用信封尺寸，5 inch × 11.5 inch。
static MediaSize | NA_NUMBER_9_ENVELOPE 指定 North American Number 9 商用信封尺寸，3.875 inch × 8.875 inch。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

LETTER

public static final MediaSize LETTER
指定 North American 信纸尺寸，8.5 inch × 11 inch。

LEGAL

public static final MediaSize LEGAL
指定 North American 合法尺寸，8.5 inch × 14 inch。

NA_5X7

public static final MediaSize NA_5X7
指定 North American 5 inch × 7 inch 纸。

NA_8X10

public static final MediaSize NA_8X10
指定 North American 8 inch × 10 inch 纸。

NA_NUMBER_9_ENVELOPE

public static final MediaSize NA_NUMBER_9_ENVELOPE
指定 North American Number 9 商用信封尺寸，3.875 inch × 8.875 inch。

NA_NUMBER_10_ENVELOPE

public static final MediaSize NA_NUMBER_10_ENVELOPE
指定 North American Number 10 商用信封尺寸，4.125 inch × 9.5 inch。

NA_NUMBER_11_ENVELOPE

public static final MediaSize NA_NUMBER_11_ENVELOPE
指定 North American Number 11 商用信封尺寸，4.5 inch × 10.375 inch。

NA_NUMBER_12_ENVELOPE

public static final MediaSize NA_NUMBER_12_ENVELOPE
指定 North American Number 12 商用信封尺寸，4.75 inch × 11 inch。

NA_NUMBER_14_ENVELOPE

public static final MediaSize NA_NUMBER_14_ENVELOPE
指定 North American Number 14 商用信封尺寸，5 inch × 11.5 inch。

NA_6X9_ENVELOPE

public static final MediaSize NA_6X9_ENVELOPE
指定 North American 6 inch × 9 inch 信封尺寸。

NA_7X9_ENVELOPE

public static final MediaSize NA_7X9_ENVELOPE
指定 North American 7 inch × 9 inch 信封尺寸。

NA_9x11_ENVELOPE

public static final MediaSize NA_9x11_ENVELOPE
指定 North American 9 inch × 11 inch 信封尺寸。

NA_9x12_ENVELOPE

public static final MediaSize NA_9x12_ENVELOPE
指定 North American 9 inch × 12 inch 信封尺寸。

NA_10x13_ENVELOPE

public static final MediaSize NA_10x13_ENVELOPE
指定 North American 10 inch × 13 inch 信封尺寸。

NA_10x14_ENVELOPE

public static final MediaSize NA_10x14_ENVELOPE
指定 North American 10 inch × 14 inch 信封尺寸。

NA_10X15_ENVELOPE

public static final MediaSize NA_10X15_ENVELOPE
指定 North American 10 inch × 15 inch 信封尺寸。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaSize.Other (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaSize.Other

java.lang.Object
    继承者  javax.print.attribute.standard.MediaSize.Other
正在封闭类：
MediaSize
public static final class MediaSize.Other
extends Object

MediaSize.Other 类包括其他介质的 MediaSize 值。

字段摘要
static MediaSize | EXECUTIVE 指定 executive 尺寸，7.25 inch × 10.5 inch。
static MediaSize | FOLIO 指定 folio 尺寸，8.5 inch × 13 inch。
static MediaSize | INVOICE 指定 invoice 尺寸，5.5 inch × 8.5 inch。
static MediaSize | ITALY_ENVELOPE 指定 Italy 信封尺寸，110 mm × 230 mm。
static MediaSize | JAPANESE_DOUBLE_POSTCARD 指定 Japanese Double 明信片尺寸，148 mm × 200 mm。
static MediaSize | JAPANESE_POSTCARD 指定 Japanese 明信片尺寸，100 mm × 148 mm。
static MediaSize | LEDGER 指定 ledger 尺寸，11 inch × 17 inch。
static MediaSize | MONARCH_ENVELOPE 指定 Monarch 信封尺寸，3.87 inch × 7.5 inch。
static MediaSize | PERSONAL_ENVELOPE 指定 Personal 信封尺寸，3.625 inch × 6.5 inch。
static MediaSize | QUARTO 指定 quarto 尺寸，8.5 inch × 10.83 inch。
static MediaSize | TABLOID 指定 tabloid 尺寸，11 inch × 17 inch。
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

EXECUTIVE

public static final MediaSize EXECUTIVE
指定 executive 尺寸，7.25 inch × 10.5 inch。

LEDGER

public static final MediaSize LEDGER
指定 ledger 尺寸，11 inch × 17 inch。

TABLOID

public static final MediaSize TABLOID
指定 tabloid 尺寸，11 inch × 17 inch。

从以下版本开始：
1.5

INVOICE

public static final MediaSize INVOICE
指定 invoice 尺寸，5.5 inch × 8.5 inch。

FOLIO

public static final MediaSize FOLIO
指定 folio 尺寸，8.5 inch × 13 inch。

QUARTO

public static final MediaSize QUARTO
指定 quarto 尺寸，8.5 inch × 10.83 inch。

ITALY_ENVELOPE

public static final MediaSize ITALY_ENVELOPE
指定 Italy 信封尺寸，110 mm × 230 mm。

MONARCH_ENVELOPE

public static final MediaSize MONARCH_ENVELOPE
指定 Monarch 信封尺寸，3.87 inch × 7.5 inch。

PERSONAL_ENVELOPE

public static final MediaSize PERSONAL_ENVELOPE
指定 Personal 信封尺寸，3.625 inch × 6.5 inch。

JAPANESE_POSTCARD

public static final MediaSize JAPANESE_POSTCARD
指定 Japanese 明信片尺寸，100 mm × 148 mm。

JAPANESE_DOUBLE_POSTCARD

public static final MediaSize JAPANESE_DOUBLE_POSTCARD
指定 Japanese Double 明信片尺寸，148 mm × 200 mm。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaSizeName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaSizeName

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Media
            继承者  javax.print.attribute.standard.MediaSizeName
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public class MediaSizeName
extends Media

MediaSizeName 类是 Media 的子类。

可以使用此属性来替代指定 MediaName 或 MediaTray。

MediaSizeName 类当前声明了几种标准介质名称值。

IPP Compatibility: MediaSizeName 是命名介质大小的 IPP "media" 属性值的表示形式类。介质尺寸名称对应于 IPP 1.1 RFC RFC 2911 中的名称。

另请参见：
序列化表格

字段摘要
static MediaSizeName | A A 尺寸。
static MediaSizeName | B B 尺寸。
static MediaSizeName | C C 尺寸。
static MediaSizeName | D D 尺寸。
static MediaSizeName | E E 尺寸。
static MediaSizeName | EXECUTIVE executive 尺寸。
static MediaSizeName | FOLIO folio 尺寸。
static MediaSizeName | INVOICE invoice 尺寸。
static MediaSizeName | ISO_A0 A0 尺寸。
static MediaSizeName | ISO_A1 A1 尺寸。
static MediaSizeName | ISO_A10 A10 尺寸。
static MediaSizeName | ISO_A2 A2 尺寸。
static MediaSizeName | ISO_A3 A3 尺寸。
static MediaSizeName | ISO_A4 A4 尺寸。
static MediaSizeName | ISO_A5 A5 尺寸。
static MediaSizeName | ISO_A6 A6 尺寸。
static MediaSizeName | ISO_A7 A7 尺寸。
static MediaSizeName | ISO_A8 A8 尺寸。
static MediaSizeName | ISO_A9 A9 尺寸。
static MediaSizeName | ISO_B0 ISO B0 尺寸。
static MediaSizeName | ISO_B1 ISO B1 尺寸。
static MediaSizeName | ISO_B10 ISO B10 尺寸。
static MediaSizeName | ISO_B2 ISO B2 尺寸。
static MediaSizeName | ISO_B3 ISO B3 尺寸。
static MediaSizeName | ISO_B4 ISO B4 尺寸。
static MediaSizeName | ISO_B5 ISO B5 尺寸。
static MediaSizeName | ISO_B6 ISO B6 尺寸。
static MediaSizeName | ISO_B7 ISO B7 尺寸。
static MediaSizeName | ISO_B8 ISO B8 尺寸。
static MediaSizeName | ISO_B9 ISO B9 尺寸。
static MediaSizeName | ISO_C0 ISO C0 尺寸。
static MediaSizeName | ISO_C1 ISO C1 尺寸。
static MediaSizeName | ISO_C2 ISO C2 尺寸。
static MediaSizeName | ISO_C3 ISO C3 尺寸。
static MediaSizeName | ISO_C4 ISO C4 尺寸。
static MediaSizeName | ISO_C5 ISO C5 尺寸。
static MediaSizeName | ISO_C6 信纸尺寸。
static MediaSizeName | ISO_DESIGNATED_LONG ISO designated long 尺寸。
static MediaSizeName | ITALY_ENVELOPE Italy 信封尺寸。
static MediaSizeName | JAPANESE_DOUBLE_POSTCARD Japanese Double Postcard 尺寸。
static MediaSizeName | JAPANESE_POSTCARD Japanese Postcard 尺寸。
static MediaSizeName | JIS_B0 JIS B0 尺寸。
static MediaSizeName | JIS_B1 JIS B1 尺寸。
static MediaSizeName | JIS_B10 JIS B10 尺寸。
static MediaSizeName | JIS_B2 JIS B2 尺寸。
static MediaSizeName | JIS_B3 JIS B3 尺寸。
static MediaSizeName | JIS_B4 JIS B4 尺寸。
static MediaSizeName | JIS_B5 JIS B5 尺寸。
static MediaSizeName | JIS_B6 JIS B6 尺寸。
static MediaSizeName | JIS_B7 JIS B7 尺寸。
static MediaSizeName | JIS_B8 JIS B8 尺寸。
static MediaSizeName | JIS_B9 JIS B9 尺寸。
static MediaSizeName | LEDGER ledger 尺寸。
static MediaSizeName | MONARCH_ENVELOPE monarch 信封尺寸。
static MediaSizeName | NA_10X13_ENVELOPE 10x13 North American 信封尺寸。
static MediaSizeName | NA_10X14_ENVELOPE 10x14North American 信封尺寸。
static MediaSizeName | NA_10X15_ENVELOPE 10x15 North American 信封尺寸。
static MediaSizeName | NA_5X7 5x7 North American 纸。
static MediaSizeName | NA_6X9_ENVELOPE 6x9 North American 信封尺寸。
static MediaSizeName | NA_7X9_ENVELOPE 7x9 North American 信封尺寸。
static MediaSizeName | NA_8X10 8x10 North American 纸。
static MediaSizeName | NA_9X11_ENVELOPE 9x11 North American 信封尺寸。
static MediaSizeName | NA_9X12_ENVELOPE 9x12 North American 信封尺寸。
static MediaSizeName | NA_LEGAL legal 尺寸。
static MediaSizeName | NA_LETTER 信纸尺寸。
static MediaSizeName | NA_NUMBER_10_ENVELOPE 10 号信封尺寸。
static MediaSizeName | NA_NUMBER_11_ENVELOPE 11 号信封尺寸。
static MediaSizeName | NA_NUMBER_12_ENVELOPE 12 号信封尺寸。
static MediaSizeName | NA_NUMBER_14_ENVELOPE 14 号信封尺寸。
static MediaSizeName | NA_NUMBER_9_ENVELOPE 9 号信封尺寸。
static MediaSizeName | PERSONAL_ENVELOPE 私人信封尺寸。
static MediaSizeName | QUARTO quarto 尺寸。
static MediaSizeName | TABLOID tabloid 尺寸。
构造方法摘要
protected MediaSizeName(int value)
构造具有给定整数值的新 MediaSizeName 枚举值。
方法摘要
protected EnumSyntax[] | getEnumValueTable() 返回 MediaSizeName 类的枚举值表。
protected String[] | getStringTable() 返回 MediaSizeName 类的字符串表。
从类 javax.print.attribute.standard.Media 继承的方法
equals, getCategory, getName
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

ISO_A0

public static final MediaSizeName ISO_A0
A0 尺寸。

ISO_A1

public static final MediaSizeName ISO_A1
A1 尺寸。

ISO_A2

public static final MediaSizeName ISO_A2
A2 尺寸。

ISO_A3

public static final MediaSizeName ISO_A3
A3 尺寸。

ISO_A4

public static final MediaSizeName ISO_A4
A4 尺寸。

ISO_A5

public static final MediaSizeName ISO_A5
A5 尺寸。

ISO_A6

public static final MediaSizeName ISO_A6
A6 尺寸。

ISO_A7

public static final MediaSizeName ISO_A7
A7 尺寸。

ISO_A8

public static final MediaSizeName ISO_A8
A8 尺寸。

ISO_A9

public static final MediaSizeName ISO_A9
A9 尺寸。

ISO_A10

public static final MediaSizeName ISO_A10
A10 尺寸。

ISO_B0

public static final MediaSizeName ISO_B0
ISO B0 尺寸。

ISO_B1

public static final MediaSizeName ISO_B1
ISO B1 尺寸。

ISO_B2

public static final MediaSizeName ISO_B2
ISO B2 尺寸。

ISO_B3

public static final MediaSizeName ISO_B3
ISO B3 尺寸。

ISO_B4

public static final MediaSizeName ISO_B4
ISO B4 尺寸。

ISO_B5

public static final MediaSizeName ISO_B5
ISO B5 尺寸。

ISO_B6

public static final MediaSizeName ISO_B6
ISO B6 尺寸。

ISO_B7

public static final MediaSizeName ISO_B7
ISO B7 尺寸。

ISO_B8

public static final MediaSizeName ISO_B8
ISO B8 尺寸。

ISO_B9

public static final MediaSizeName ISO_B9
ISO B9 尺寸。

ISO_B10

public static final MediaSizeName ISO_B10
ISO B10 尺寸。

JIS_B0

public static final MediaSizeName JIS_B0
JIS B0 尺寸。

JIS_B1

public static final MediaSizeName JIS_B1
JIS B1 尺寸。

JIS_B2

public static final MediaSizeName JIS_B2
JIS B2 尺寸。

JIS_B3

public static final MediaSizeName JIS_B3
JIS B3 尺寸。

JIS_B4

public static final MediaSizeName JIS_B4
JIS B4 尺寸。

JIS_B5

public static final MediaSizeName JIS_B5
JIS B5 尺寸。

JIS_B6

public static final MediaSizeName JIS_B6
JIS B6 尺寸。

JIS_B7

public static final MediaSizeName JIS_B7
JIS B7 尺寸。

JIS_B8

public static final MediaSizeName JIS_B8
JIS B8 尺寸。

JIS_B9

public static final MediaSizeName JIS_B9
JIS B9 尺寸。

JIS_B10

public static final MediaSizeName JIS_B10
JIS B10 尺寸。

ISO_C0

public static final MediaSizeName ISO_C0
ISO C0 尺寸。

ISO_C1

public static final MediaSizeName ISO_C1
ISO C1 尺寸。

ISO_C2

public static final MediaSizeName ISO_C2
ISO C2 尺寸。

ISO_C3

public static final MediaSizeName ISO_C3
ISO C3 尺寸。

ISO_C4

public static final MediaSizeName ISO_C4
ISO C4 尺寸。

ISO_C5

public static final MediaSizeName ISO_C5
ISO C5 尺寸。

ISO_C6

public static final MediaSizeName ISO_C6
信纸尺寸。

NA_LETTER

public static final MediaSizeName NA_LETTER
信纸尺寸。

NA_LEGAL

public static final MediaSizeName NA_LEGAL
legal 尺寸。

EXECUTIVE

public static final MediaSizeName EXECUTIVE
executive 尺寸。

LEDGER

public static final MediaSizeName LEDGER
ledger 尺寸。

TABLOID

public static final MediaSizeName TABLOID
tabloid 尺寸。

INVOICE

public static final MediaSizeName INVOICE
invoice 尺寸。

FOLIO

public static final MediaSizeName FOLIO
folio 尺寸。

QUARTO

public static final MediaSizeName QUARTO
quarto 尺寸。

JAPANESE_POSTCARD

public static final MediaSizeName JAPANESE_POSTCARD
Japanese Postcard 尺寸。

JAPANESE_DOUBLE_POSTCARD

public static final MediaSizeName JAPANESE_DOUBLE_POSTCARD
Japanese Double Postcard 尺寸。

A

public static final MediaSizeName A
A 尺寸。

B

public static final MediaSizeName B
B 尺寸。

C

public static final MediaSizeName C
C 尺寸。

D

public static final MediaSizeName D
D 尺寸。

E

public static final MediaSizeName E
E 尺寸。

ISO_DESIGNATED_LONG

public static final MediaSizeName ISO_DESIGNATED_LONG
ISO designated long 尺寸。

ITALY_ENVELOPE

public static final MediaSizeName ITALY_ENVELOPE
Italy 信封尺寸。

MONARCH_ENVELOPE

public static final MediaSizeName MONARCH_ENVELOPE
monarch 信封尺寸。

PERSONAL_ENVELOPE

public static final MediaSizeName PERSONAL_ENVELOPE
私人信封尺寸。

NA_NUMBER_9_ENVELOPE

public static final MediaSizeName NA_NUMBER_9_ENVELOPE
9 号信封尺寸。

NA_NUMBER_10_ENVELOPE

public static final MediaSizeName NA_NUMBER_10_ENVELOPE
10 号信封尺寸。

NA_NUMBER_11_ENVELOPE

public static final MediaSizeName NA_NUMBER_11_ENVELOPE
11 号信封尺寸。

NA_NUMBER_12_ENVELOPE

public static final MediaSizeName NA_NUMBER_12_ENVELOPE
12 号信封尺寸。

NA_NUMBER_14_ENVELOPE

public static final MediaSizeName NA_NUMBER_14_ENVELOPE
14 号信封尺寸。

NA_6X9_ENVELOPE

public static final MediaSizeName NA_6X9_ENVELOPE
6x9 North American 信封尺寸。

NA_7X9_ENVELOPE

public static final MediaSizeName NA_7X9_ENVELOPE
7x9 North American 信封尺寸。

NA_9X11_ENVELOPE

public static final MediaSizeName NA_9X11_ENVELOPE
9x11 North American 信封尺寸。

NA_9X12_ENVELOPE

public static final MediaSizeName NA_9X12_ENVELOPE
9x12 North American 信封尺寸。

NA_10X13_ENVELOPE

public static final MediaSizeName NA_10X13_ENVELOPE
10x13 North American 信封尺寸。

NA_10X14_ENVELOPE

public static final MediaSizeName NA_10X14_ENVELOPE
10x14North American 信封尺寸。

NA_10X15_ENVELOPE

public static final MediaSizeName NA_10X15_ENVELOPE
10x15 North American 信封尺寸。

NA_5X7

public static final MediaSizeName NA_5X7
5x7 North American 纸。

NA_8X10

public static final MediaSizeName NA_8X10
8x10 North American 纸。

构造方法详细信息

MediaSizeName

protected MediaSizeName(int value)
构造具有给定整数值的新 MediaSizeName 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 MediaSizeName 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 MediaSizeName 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MediaTray (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MediaTray

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Media
            继承者  javax.print.attribute.standard.MediaTray
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public class MediaTray
extends Media
implements Attribute

MediaTray 类是 Media 的子类。MediaTray 类是打印属性类，它是一个枚举值，指定了作业的纸张托盘或纸盒。可以使用此属性来替代指定 MediaSize 或 MediaName。

MediaTray 类声明了标准介质种类值的关键字。介质种类属性的由实现或由位置定义的名称也可以通过定义 MediaTray 类的子类来创建。

IPP Compatibility: MediaTray 是命名纸张托盘的 IPP "media" 属性值的表示类。

另请参见：
序列化表格

字段摘要
static MediaTray | BOTTOM 打印机中的底层进纸托盘。
static MediaTray | ENVELOPE 打印机中的信封进纸托盘。
static MediaTray | LARGE_CAPACITY 打印机中的大容量进纸托盘。
static MediaTray | MAIN 打印机中的主要进纸托盘。
static MediaTray | MANUAL 打印机中的手动进纸托盘。
static MediaTray | MIDDLE 打印机中的中层进纸托盘。
static MediaTray | SIDE 侧面进纸托盘。
static MediaTray | TOP 打印机中的顶层进纸托盘。
构造方法摘要
protected MediaTray(int value)
构造具有给定整数值的新 MediaTray 枚举值。
方法摘要
protected EnumSyntax[] | getEnumValueTable() 返回 MediaTray 类的枚举值表。
protected String[] | getStringTable() 返回 MediaTray 类字符串表。
从类 javax.print.attribute.standard.Media 继承的方法
equals, getCategory, getName
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 javax.print.attribute.Attribute 继承的方法
getCategory, getName

字段详细信息

TOP

public static final MediaTray TOP
打印机中的顶层进纸托盘。

MIDDLE

public static final MediaTray MIDDLE
打印机中的中层进纸托盘。

BOTTOM

public static final MediaTray BOTTOM
打印机中的底层进纸托盘。

ENVELOPE

public static final MediaTray ENVELOPE
打印机中的信封进纸托盘。

MANUAL

public static final MediaTray MANUAL
打印机中的手动进纸托盘。

LARGE_CAPACITY

public static final MediaTray LARGE_CAPACITY
打印机中的大容量进纸托盘。

MAIN

public static final MediaTray MAIN
打印机中的主要进纸托盘。

SIDE

public static final MediaTray SIDE
侧面进纸托盘。

构造方法详细信息

MediaTray

protected MediaTray(int value)
构造具有给定整数值的新 MediaTray 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 MediaTray 类字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 MediaTray 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MultipleDocumentHandling (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 MultipleDocumentHandling

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.MultipleDocumentHandling
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public class MultipleDocumentHandling
extends EnumSyntax
implements PrintRequestAttribute, PrintJobAttribute

MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。当 Copies 属性值超过 1 时，MultipleDocumentHandling 还控制从处理文档所得到的副本的生成顺序。此属性仅与由两个或多个文档组成的多文档打印作业相关。

简单地说，MultipleDocumentHandling 确定了被输入到多文档打印作业中的多个输入(电子)文档之间与多文档打印作业所生成的输出(物理)文档(或多个文档)之间的关系。有两种可能：

  • 多个输入文档被合并到单个输出文档中。在此单个输出文档上执行结束操作(Finishings)。Copies 属性通知要生成的此单个输出文档的副本数。MultipleDocumentHandling 值 SINGLE_DOCUMENT 和 SINGLE_DOCUMENT_NEW_SHEET 指定了此可能性的两个变量。

  • 多个输入文档保持独立的输出文档。在每个输出文档上独立执行结束操作(Finishings)。Copies 属性通知要生成的每个独立输出文档的副本数。MultipleDocumentHandling 值 SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 和 SEPARATE_DOCUMENTS_COLLATED_COPIES 指定此可能性的两个变量。

在以下的详细解释中，如果 "a" 表示文档数据的实例，则处理 "a" 中的数据的结果为由 "a(*)" 表示的介质纸张序列。

标准的 MultipleDocumentHandling 值有：

  • SINGLE_DOCUMENT。如果打印作业有多个文档（比方说，文档数据称为 a 和 b），则所有文档数据（a 然后 b）的处理结果必须被视为结束操作的单个介质纸张序列；即应以 a(*),b(*) 序列的串联顺序执行结束操作。打印机不能强制将每个文档实例中的数据格式化到新的打印流页，也不能在新的介质纸张上开始新的印张。如果生成多个副本，则处理文档数据得到的介质纸张集的顺序必须为 a(*),b(*),a(*),b(*),...，并且打印机对象必须强制在新介质纸张上开始每个副本（a(*),b(*)）。

  • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES.如果打印作业有多个文档（比方说，文档数据称为 a 和 b），则每个文档实例的数据处理结果必须被视为结束操作的单个介质纸张序列；即应独立地结束每个集合 a(*) 和 b(*)。打印机必须强制单个文档中数据处理结果的每个副本在新介质纸张上开始。如果生成多个副本，则处理文档数据得到的介质纸张集合顺序必须为 a(*),a(*),...,b(*),b(*)...。

  • SEPARATE_DOCUMENTS_COLLATED_COPIES.如果打印作业有多个文档（比方说，文档数据称为 a 和 b），则每个文档实例中的数据处理结果必须被视为结束操作的单个介质纸张序列；即应独立地结束每个集合 a(*) 和 b(*)。打印机必须强制单个文档中数据处理结果的每个副本在新介质纸张上开始。如果生成多个副本，则处理文档数据得到的介质纸张集合顺序必须为 a(*),b(*),a(*),b(*),...。

  • SINGLE_DOCUMENT。与 SINGLE_DOCUMENT 相同，除打印机必须确保作业中每个文档实例的首个印张被置于新介质纸张上。此值允许用单个装订点将多个文档装订到一起，其中每个文档均在新介质纸张上开始。

SINGLE_DOCUMENT 在打印流页顺序方面与 SEPARATE_DOCUMENTS_COLLATED_COPIES 相同，但在介质纸张生成方面不同，因为 SINGLE_DOCUMENT 将下一个文档的首页置于纸张的后端（如果作业到目前为止已生成奇数页），而 SEPARATE_DOCUMENTS_COLLATED_COPIES 总是强制将下一个文档或文档副本置于新纸张上。

此外，如果指定了 STAPLE 的 Finishings 属性，则：

  • 对于 SINGLE_DOCUMENT，文档 a 和 b 作为单个文档被装订到一起（不在新纸张上开始）。

  • 对于 SINGLE_DOCUMENT_NEW_SHEET，文档 a 和 b 作为单个文档被装订到一起，但文档 b 在新纸张上开始。

  • 对于 SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 和 SEPARATE_DOCUMENTS_COLLATED_COPIES，文档 a 和 b 独立装订。

注： 这些值均不提供在文档中生成非逐份打印纸张的方式，即其中纸张 n 的多个副本在相同文档的纸张 n+1 之前生成。要指定该功能，请参见 SheetCollate 属性。

IPP Compatibility: getName() 所返回的类别名称为 IPP 属性名称。枚举的整数值为 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
Copies, Finishings, NumberUp, PageRanges, SheetCollate, Sides, 序列化表格

字段摘要
static MultipleDocumentHandling | SEPARATE_DOCUMENTS_COLLATED_COPIES 独立文档逐份打印副本 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 独立文档非逐份打印副本 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | SINGLE_DOCUMENT 单个文档 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | SINGLE_DOCUMENT_NEW_SHEET 单个文档新纸张 －－ 有关更多信息，请参见上文。
构造方法摘要
protected MultipleDocumentHandling(int value)
构造具有给定整数值的新 MultipleDocumentHandling 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回 MultipleDocumentHandling 类的枚举值表。
String | getName() 获取类别名称，此属性值为该类别的实例。
protected String[] | getStringTable() 返回 MultipleDocumentHandling 类的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

SINGLE_DOCUMENT

public static final MultipleDocumentHandling SINGLE_DOCUMENT
单个文档 －－ 有关更多信息，请参见上文。

SEPARATE_DOCUMENTS_UNCOLLATED_COPIES

public static final MultipleDocumentHandling SEPARATE_DOCUMENTS_UNCOLLATED_COPIES
独立文档非逐份打印副本 －－ 有关更多信息，请参见上文。

SEPARATE_DOCUMENTS_COLLATED_COPIES

public static final MultipleDocumentHandling SEPARATE_DOCUMENTS_COLLATED_COPIES
独立文档逐份打印副本 －－ 有关更多信息，请参见上文。

SINGLE_DOCUMENT_NEW_SHEET

public static final MultipleDocumentHandling SINGLE_DOCUMENT_NEW_SHEET
单个文档新纸张 －－ 有关更多信息，请参见上文。

构造方法详细信息

MultipleDocumentHandling

protected MultipleDocumentHandling(int value)
构造具有给定整数值的新 MultipleDocumentHandling 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回 MultipleDocumentHandling 类的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回 MultipleDocumentHandling 类的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 MultipleDocumentHandling 类和任何供应商定义的子类，类别为 MultipleDocumentHandling 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 MultipleDocumentHandling 类和任何供应商定义的子类，类别名称为 "multiple-document-handling"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberOfDocuments (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 NumberOfDocuments

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.NumberOfDocuments
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class NumberOfDocuments
extends IntegerSyntax
implements PrintJobAttribute

NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
NumberOfDocuments(int value)
构造具有给定整数值的新 NumberOfDocuments 属性。
方法摘要
boolean | equals(Object object) 返回此文档数属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

NumberOfDocuments

public NumberOfDocuments(int value)
构造具有给定整数值的新 NumberOfDocuments 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此文档数属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 NumberOfDocuments 类的实例。
  3. 此文档数属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此文档数属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 NumberOfDocuments 类，类别为 NumberOfDocuments 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 NumberOfDocuments 类，类别名称为 "number-of-documents"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberOfInterveningJobs (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 NumberOfInterveningJobs

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.NumberOfInterveningJobs
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class NumberOfInterveningJobs
extends IntegerSyntax
implements PrintJobAttribute

NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。

IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
NumberOfInterveningJobs(int value)
构造具有给定整数值的新的 NumberOfInterveningJobs 属性。
方法摘要
boolean | equals(Object object) 返回此 NumberOfInterveningJobs 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

NumberOfInterveningJobs

public NumberOfInterveningJobs(int value)
构造具有给定整数值的新的 NumberOfInterveningJobs 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 0，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 NumberOfInterveningJobs 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 NumberOfInterveningJobs 类的实例。
  3. 此 NumberOfInterveningJobs 属性值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 NumberOfInterveningJobs 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 NumberOfInterveningJobs 类，类别为 NumberOfInterveningJobs 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 NumberOfInterveningJobs 类，类别名称为 "number-of-intervening-jobs"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberUp (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 NumberUp

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.NumberUp
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class NumberUp
extends IntegerSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。也就是说，如果 NumberUp 值为 n，则打印机必须将 n 个打印流页放置于选中介质的实例单面上。要完成此功能，打印机可以添加某种转换、缩放或旋转。此属性主要控制打印流页的转换、缩放和旋转。

多文档打印作业（具有多个文档的作业）上的 NumberUp 属性的效果取决于是否所有文档均已指定相同的计数值，或者是否不同文档已指定不同计数值，并取决于（可能是默认的）MultipleDocumentHandling 属性的值。

  • 如果所有文档均已指定了相同计数值 n，则 MultipleDocumentHandling 的任何值均有意义，且打印机的处理取决于 MultipleDocumentHandling 值：
    • SINGLE_DOCUMENT －－ 所有输入文档将被合并为一个输出文档。每个介质印张将由 nm 个取自输出文档的打印流页组成。

    • SINGLE_DOCUMENT_NEW_SHEET －－ 所有输入文档将被合并为一个输出文档。每个介质印张将由 n 个取自输出文档的打印流页组成。但是，每个输入文档的首个印张将总是在新介质纸张上开始；这意味着输入文档的最后一个印张上可能有少于 n 个打印流页。

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES －－ 输入文档将保持独立。每个介质印张将由 n 个取自输入文档的打印流页组成。因为输入文档是独立的，所以每个输入文档的首个印张将总是在新介质纸张上开始；这意味着输入文档的最后一个印张上可能有少于 n 个打印流页。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES －－ 输入文档将保持独立。每个介质印张将由 n 个取自输入文档的打印流页组成。因为输入文档是独立的，所以每个输入文档的首个印张将总是在新介质纸张上开始；这意味着输入文档的最后一个印张上可能有少于 n 个打印流页。
    • SINGLE_DOCUMENT －－ 所有输入文档将被合并为一个输出文档。每个介质纸张将由 ni 个取自输出文档的打印流页组成，其中 i 为对应于输出文档中该点的输入文档数。当下一个文档具有不同于前一个输入文档的计数值时，下一个输入文档的首个打印流页在下一个介质印张的开始处开始，可能保留少于前一个介质印张上的全部打印流页数。

    • SINGLE_DOCUMENT_NEW_SHEET －－ 所有输入文档将被合并为一个输出文档。每个介质印张将由 n 个取自输出文档的打印流页组成。但是，每个输入文档的首个印张将总是在新介质纸张上开始；这意味着输入文档的最后一个印张上可能有少于 n 个打印流页。

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES －－ 输入文档将保持独立。对于输入文档 i， 每个介质印张将由 ni 个取自输入文档的打印流页组成。因为输入文档是独立的，所以每个输入文档的首个印张将总是在新介质纸张上开始；这意味着输入文档的最后一个印张上可能有少于 ni 个打印流页。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES －－ 输入文档将保持独立。对于输入文档 i， 每个介质印张将由 ni 个取自输入文档的打印流页组成。因为输入文档是独立的，所以每个输入文档的首个印张将总是在新介质纸张上开始；这意味着输入文档的最后一个印张上可能有少于 ni 个打印流页。
IPP Compatibility: 整数值给出了 IPP 整数值。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
NumberUp(int value)
构造具有给定整数值的新 NumberUp 属性。
方法摘要
boolean | equals(Object object) 返回此计数属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

NumberUp

public NumberUp(int value)
构造具有给定整数值的新 NumberUp 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未检查的异常）如果 value 小于 1，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此计数属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 NumberUp 类的实例。
  3. 此计数属性的值与 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此计数属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 NumberUp 类，类别为 NumberUp 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 NumberUp 类，类别名称为 "number-up"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NumberUpSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 NumberUpSupported

java.lang.Object
    继承者  javax.print.attribute.SetOfIntegerSyntax
        继承者  javax.print.attribute.standard.NumberUpSupported
所有已实现的接口：
Serializable, Cloneable, Attribute, SupportedValuesAttribute
public final class NumberUpSupported
extends SetOfIntegerSyntax
implements SupportedValuesAttribute

NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。

IPP Compatibility: NumberUpSupported 属性的规范数组形式给出了要包含于 IPP "number-up-supported" 属性中的 number-up 的范围的下边界和上边界。有关规范数组形式的解释，请参见 SetOfIntegerSyntax。getName() 所返回的类别名称给出了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
NumberUpSupported(int member)
构造一个包含单个整数的新的 NumberUpSupported 属性。
NumberUpSupported(int[][] members)
构造具有给定成员的新的 NumberUpSupported 属性。
NumberUpSupported(int lowerBound, int upperBound)
构造一个包含单个整数范围的新的 NumberUpSupported 属性。
方法摘要
boolean | equals(Object object) 返回此 NumberUpSupported 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别名称，此属性值为该类别的实例。
从类 javax.print.attribute.SetOfIntegerSyntax 继承的方法
contains, contains, getMembers, hashCode, next, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

NumberUpSupported

public NumberUpSupported(int[][] members)
构造具有给定成员的新的 NumberUpSupported 属性。支持的 NumberUp 值用"数组形式"指定；有关数据形式的解释，请参见 SetOfIntegerSyntax 类。

参数：
members - 数组形式的集合成员。
抛出：
NullPointerException - （未检查的异常）如果 members 为 null 或 members 的任何元素为 null，则抛出此异常。
IllegalArgumentException - （未检查的异常）如果 members 的任何元素不是长度为 1 或 2 的数组，则抛出此异常。如果 members 为零长度的数组或集合的任何成员小于 1，也抛出此异常。

NumberUpSupported

public NumberUpSupported(int member)
构造一个包含单个整数的新的 NumberUpSupported 属性。即仅支持 NumberUp 的某个值。

参数：
member - 集合成员。
抛出：
IllegalArgumentException - （未检查的异常）如果 member 小于 1，则抛出此异常。

NumberUpSupported

public NumberUpSupported(int lowerBound,
                         int upperBound)
构造一个包含单个整数范围的新的 NumberUpSupported 属性。即仅支持某个范围中的 NumberUp 值。

参数：
lowerBound - 范围的下边界。
upperBound - 范围的上边界。
抛出：
IllegalArgumentException - （未检查的异常）如果指定了 null 范围，或者指定了 lowerBound 小于 1 的非 null 范围，则抛出此异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 NumberUpSupported 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 为 NumberUpSupported 类的实例。
  3. 此 NumberUpSupported 属性的成员与 object 的成员相同。

覆盖：
类 SetOfIntegerSyntax 中的 equals
参数：
object - 要比较的 Object。
返回：
如果 object 等效于此 NumberUpSupported 属性，则返回 true，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将被用作此打印属性值的“类别”的打印属性类。

对于 NumberUpSupported 类，类别为 NumberUpSupported 类本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），它是 java.lang.Class 类的实例。

getName

public final String getName()
获取类别名称，此属性值为该类别的实例。

对于 NumberUpSupported 类，类别名称为 "number-up-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OrientationRequested (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 OrientationRequested

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.OrientationRequested
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class OrientationRequested
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。

对于某些文档格式（如 "application/postscript"），所需的打印流页方向可在该文档数据内指定。此信息由设备驱动程序在提交打印作业前生成。其他文档格式（如 "text/plain"）在文档数据内不包括所需要的方向这一概念。在后一种情况下，打印者可以在提交文档数据后将所需的方向与该文档数据绑定。有时想让打印机仅支持某些文档格式的 OrientationRequested 属性（例如 "text/plain" 或 "text/html"），但不支持其他文档格式（例如 "application/postscript"）的这一属性。这与其他作业模板属性没有任何不同，因为打印作业始终能够在不同作业模板属性的值之间施加限制。但是，由于很多情况下打印机只为受支持文档格式的子集支持 OrientationRequested 属性，所以在此要加以特别说明。

IPP 兼容性：由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static OrientationRequested | LANDSCAPE 沿介质的长边描绘内容。
static OrientationRequested | PORTRAIT 沿介质的短边描绘内容。
static OrientationRequested | REVERSE_LANDSCAPE 沿介质的长边描绘内容，但方式正好与横向相反。
static OrientationRequested | REVERSE_PORTRAIT 沿介质的短边描绘内容，但方式正好与纵向相反。
构造方法摘要
protected OrientationRequested(int value)
构造具有给定整数值的新 OrientationRequested 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 OrientationRequested 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected int | getOffset() 返回类 OrientationRequested 所使用的最小整数值。
protected String[] | getStringTable() 返回类 OrientationRequested 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

PORTRAIT

public static final OrientationRequested PORTRAIT
沿介质的短边描绘内容。

LANDSCAPE

public static final OrientationRequested LANDSCAPE
沿介质的长边描绘内容。横向被定义为针对纵向的介质而言，将要描绘的打印流页旋转 +90 度（即逆时针方向）。注：之所以选择 +90 方向，是因为在长边上的简单完成要么是在纵向边上完成，要么是在横向边上完成。

REVERSE_LANDSCAPE

public static final OrientationRequested REVERSE_LANDSCAPE
沿介质的长边描绘内容，但方式正好与横向相反。反向横向被定义为针对纵向的介质而言，将要描绘的打印流页旋转 -90 度（即顺时针方向）。注：之所以添加 REVERSE_LANDSCAPE 值，是因为有些应用程序会从纵向横向旋转 -90 度，而不是 +90 度。

REVERSE_PORTRAIT

public static final OrientationRequested REVERSE_PORTRAIT
沿介质的短边描绘内容，但方式正好与纵向相反。反向纵向被定义为针对纵向的介质而言，将要描绘的打印流页旋转 180 度。注： 添加 REVERSE_PORTRAIT 值是为了使用 Finishings 属性，以防在简单完成设备（这些设备只有一个完成位置）上完成纵向文档时需要相反的边。因此，简单完成设备可以“靠右”装订一个 "text/plain" 纵向文档，这在某些中东语言（如希伯来语）中很常见。

构造方法详细信息

OrientationRequested

protected OrientationRequested(int value)
构造具有给定整数值的新 OrientationRequested 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 OrientationRequested 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 OrientationRequested 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getOffset

protected int getOffset()
返回类 OrientationRequested 所使用的最小整数值。

覆盖：
类 EnumSyntax 中的 getOffset
返回：
最小枚举值的偏移量。

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 OrientationRequested，该类别就是类 OrientationRequested 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 OrientationRequested，类别名称是 "orientation-requested"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PageRanges (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PageRanges

java.lang.Object
    继承者  javax.print.attribute.SetOfIntegerSyntax
        继承者  javax.print.attribute.standard.PageRanges
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class PageRanges
extends SetOfIntegerSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。对于那些标识为文档中不存在的页，将不会打印任何内容。该属性与打印流 页相关，而与应用程序编号的页无关（例如，某些字处理应用程序的标题或脚注中的页数）。

在大多数情况下，要打印的准确页数由设备驱动程序生成，因此不需要此属性。但是当打印已经格式化过的存档文档时，最终用户可以选择只打印该文档中所包含的页子集。在这种情况下，如果将页范围指定为 "n-m"，则要打印的第一页将为页 n。将打印文档中后面所有的页，包括页 m。

如果没有为打印作业指定 PageRanges 属性，则将打印文档的中所有页。换句话说，PageRanges 属性的默认值始终是 {{1, Integer.MAX_VALUE}}。

多文档打印作业（一个作业带有多个文档）的 PageRanges 属性的效果取决于是为所有的文档指定了相同的页范围，还是为不同的文档指定了不同的页范围，以及 MultipleDocumentHandling 属性的值（可能是默认值）。

  • 如果为所有的文档指定了相同的页范围，则 MultipleDocumentHandling 的任何值都有意义，因此打印机的处理取决于 MultipleDocumentHandling 的值：
    • SINGLE_DOCUMENT -- 所有输入文档都将合并到一个输出文档中。将打印该输出文档指定的页范围。

    • SINGLE_DOCUMENT_NEW_SHEET -- 所有的输入文档都将合并到一个输出文档中，并且始终在新的介质纸张上开始每个输入文档的第一个印张。将打印该输出文档指定的页范围。

    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- 对于每个单独的输入文档，都将打印指定的页范围。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES -- 对于每个单独的输入文档，都将打印指定的页范围。
    • SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- 对于每个单独的输入文档，将打印出其自己指定的页范围。

    • SEPARATE_DOCUMENTS_COLLATED_COPIES -- 对于每个单独的输入文档，将打印出其自己指定的页范围。

IPP 兼容性： PageRanges 属性的规范数组形式提供了要包括在内的所有页范围的下边界和上边界，以及 IPP "page-ranges" 属性。有关规范数组形式的解释，请参阅类 SetOfIntegerSyntax。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PageRanges(int member)
构造一个包括单个整数的新 PageRanges 属性。
PageRanges(int[][] members)
构造具有给定成员的新 PageRanges 属性。
PageRanges(int lowerBound, int upperBound)
构造一个包括单一整数范围的新 PageRanges 属性。
PageRanges(String members)
构造具有给定成员（字符串形式）的新 PageRanges 属性。
方法摘要
boolean | equals(Object object) 返回此 PageRanges 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.SetOfIntegerSyntax 继承的方法
contains, contains, getMembers, hashCode, next, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PageRanges

public PageRanges(int[][] members)
构造具有给定成员的新 PageRanges 属性。以“数组形式”指定这些成员，有关数组形式的解释，请参阅类 SetOfIntegerSyntax。

参数：
members - 以数组形式设置的成员。
抛出：
NullPointerException - （未经检查的异常）如果 members 为 null，或者 members 的任何元素为 null。
IllegalArgumentException - （未经检查的异常）如果没有任何 members 元素是长度为一或长度为二的数组。如果 members 是长度为零的数组，或者集合中的任何成员都小于 1，则也会抛出此异常。

PageRanges

public PageRanges(String members)
构造具有给定成员（字符串形式）的新 PageRanges 属性。有关语法的解释，请参阅类 SetOfIntegerSyntax。

参数：
members - 以字符串形式设置的成员。
抛出：
NullPointerException - （未经检查的异常）如果 members 为 null，或者 members 的任何元素为 null。
IllegalArgumentException - （未经检查的异常）如果 members 没有遵守正确的语法。如果构造的整数集为零长度的数组，或者集合中的任何成员小于 1，则也会抛出此异常。

PageRanges

public PageRanges(int member)
构造一个包括单个整数的新 PageRanges 属性。也就是说只打印一页。

参数：
member - 设置的成员。
抛出：
IllegalArgumentException - （未经检查的异常）如果 member 小于 1。

PageRanges

public PageRanges(int lowerBound,
                  int upperBound)
构造一个包括单一整数范围的新 PageRanges 属性。也就是说只打印那些在一个范围中的页。

参数：
lowerBound - 范围的下边界。
upperBound - 范围的上边界。
抛出：
IllegalArgumentException - （未经检查的异常）如果指定了 null 范围，或者指定了非 null 的范围，但 lowerBound 小于 1。
方法详细信息

equals

public boolean equals(Object object)
返回此 PageRanges 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PageRanges 的一个实例。
  3. 此 PageRanges 属性的成员和 object 的成员相同。

覆盖：
类 SetOfIntegerSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PageRanges 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PageRanges，该类别就是类 PageRanges 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PageRanges，该类别名称是 "page-ranges"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OutputDeviceAssigned (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 OutputDeviceAssigned

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.OutputDeviceAssigned
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute
public final class OutputDeviceAssigned
extends TextSyntax
implements PrintJobAttribute

OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。如果输出设备实现了嵌入式的 PrintService 实例，则打印机无需设置此属性。如果打印服务器实现了 PrintService 实例，则该值可能会为空（零长度字符串），或者在服务为作业分配输出设备前不会返回值。此属性在单个服务支持多个设备（即所谓的“扇出”）时尤其有用。

IPP 兼容性：字符串值提供了 IPP 名称值。语言环境提供了 IPP 自然语言。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
OutputDeviceAssigned(String deviceName, Locale locale)
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。
方法摘要
boolean | equals(Object object) 返回此 OutputDeviceAssigned 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

OutputDeviceAssigned

public OutputDeviceAssigned(String deviceName,
                            Locale locale)
构造具有给定设备名称和语言环境的新 OutputDeviceAssigned 属性。

参数：
deviceName - 设备名称。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未经检查的异常）如果 deviceName 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 OutputDeviceAssigned 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 OutputDeviceAssigned 的一个实例。
  3. 此 OutputDeviceAssigned 属性的底层字符串和 object 的底层字符串相等。
  4. 此 OutputDeviceAssigned 的语言环境和 object 的语言环境相等。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 OutputDeviceAssigned 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 OutputDeviceAssigned，该类别就是类 OutputDeviceAssigned 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 OutputDeviceAssigned，类别名称是 "output-device-assigned"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PagesPerMinute (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PagesPerMinute

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.PagesPerMinute
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PagesPerMinute
extends IntegerSyntax
implements PrintServiceAttribute

PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。此属性仅提供信息，不是一种服务保证。一般情况下，它是一种在市场营销文字中用来描述设备的值。0 值指示设备处理一页需要两分多钟时间。

IPP 兼容性：该整数值提供了 IPP 整数值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PagesPerMinute(int value)
构造具有给定整数值的新 PagesPerMinute 属性。
方法摘要
boolean | equals(Object object) 返回此 PagesPerMinute 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PagesPerMinute

public PagesPerMinute(int value)
构造具有给定整数值的新 PagesPerMinute 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未经检查的异常）如果 value 小于 0。
方法详细信息

equals

public boolean equals(Object object)
返回此 PagesPerMinute 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PagesPerMinute 的一个实例。
  3. 此 PagesPerMinute 属性的值和 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PagesPerMinute 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PagesPerMinute，该类别就是类 PagesPerMinute 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PagesPerMinute，该类别名称是 "pages-per-minute"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PagesPerMinuteColor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PagesPerMinuteColor

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.PagesPerMinuteColor
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PagesPerMinuteColor
extends IntegerSyntax
implements PrintServiceAttribute

PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。对于此属性的目的，"color" 意味着与 ColorSupported 属性相同，即设备完全可以接受任何类型的彩色打印，其中包括高亮彩色和全处理彩色。此属性仅提供信息，不是一种服务保证。一般情况下，它是一种在市场营销文字中用来描述设备彩色功能的值。0 值指示设备处理一页需要两分多钟时间。如果彩色设备有多种彩色模式，则它可以使用此属性的 PagesPerMinute 值，该值与产生最大页数的模式对应。

黑白打印机必须不在其属性集或服务注册中包括 PagesPerMinuteColor 属性。如果有此属性，则必须还有 ColorSupported 打印机描述属性并且具有 SUPPORTED 值。

IPP 兼容性：该整数值提供了 IPP 整数值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PagesPerMinuteColor(int value)
构造具有给定整数值的新 PagesPerMinuteColor 属性。
方法摘要
boolean | equals(Object object) 返回此 PagesPerMinuteColor 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PagesPerMinuteColor

public PagesPerMinuteColor(int value)
构造具有给定整数值的新 PagesPerMinuteColor 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未经检查的异常）如果 value 小于 0。
方法详细信息

equals

public boolean equals(Object object)
返回此 PagesPerMinuteColor 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PagesPerMinuteColor 的一个实例。
  3. 此 PagesPerMinute 属性的值和 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PagesPerMinuteColor 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PagesPerMinuteColor，该类别就是类 PagesPerMinuteColor 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PagesPerMinuteColor，该类别名称是 "pages-per-minute-color"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PDLOverrideSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PDLOverrideSupported

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.PDLOverrideSupported
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public class PDLOverrideSupported
extends EnumSyntax
implements PrintServiceAttribute

PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。

IPP 兼容性：由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static PDLOverrideSupported | ATTEMPTED 打印机会尝试让外部作业属性值优先于嵌入到文档打印数据中的指令，但是不保证确实会如此。
static PDLOverrideSupported | NOT_ATTEMPTED 打印机不会尝试让外部的作业属性值优先于嵌入到文档打印数据中的指令。
构造方法摘要
protected PDLOverrideSupported(int value)
构造具有给定整数值的新 PDLOverrideSupported 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 PDLOverrideSupported 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 PDLOverrideSupported 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

NOT_ATTEMPTED

public static final PDLOverrideSupported NOT_ATTEMPTED
打印机不会尝试让外部的作业属性值优先于嵌入到文档打印数据中的指令。

ATTEMPTED

public static final PDLOverrideSupported ATTEMPTED
打印机会尝试让外部作业属性值优先于嵌入到文档打印数据中的指令，但是不保证确实会如此。

构造方法详细信息

PDLOverrideSupported

protected PDLOverrideSupported(int value)
构造具有给定整数值的新 PDLOverrideSupported 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 PDLOverrideSupported 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 PDLOverrideSupported 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PDLOverrideSupported 和任何供应商定义的子类，该类别都是类 PDLOverrideSupported 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PDLOverrideSupported 和任何供应商定义的子类，类别名称都是 "pdl-override-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PresentationDirection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PresentationDirection

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.PresentationDirection
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintJobAttribute, PrintRequestAttribute
public final class PresentationDirection
extends EnumSyntax
implements PrintJobAttribute, PrintRequestAttribute

PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。这在镜像不同脚本的文本布局约定方面非常有用。例如，英语是 "toright-tobottom"，希伯来语是 "toleft-tobottom"，日语通常是 "tobottom-toleft"。

IPP 兼容性：此属性并非 IPP 1.1 属性；它是 IPP 1.1 的 Production Printing Extension (PDF) 中的一种属性。由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static PresentationDirection | TOBOTTOM_TOLEFT 从右上开始，按列布置各页，然后向左下部展开。
static PresentationDirection | TOBOTTOM_TORIGHT 从左上开始，按列布置各页，然后向右下部展开。
static PresentationDirection | TOLEFT_TOBOTTOM 从右上部开始，按行布置各页，然后向左下部展开。
static PresentationDirection | TOLEFT_TOTOP 从右下部开始，按行布置各页，然后向左上部展开。
static PresentationDirection | TORIGHT_TOBOTTOM 从左上部开始，按行布置各页，然后向右下部展开。
static PresentationDirection | TORIGHT_TOTOP 从左下部开始，按行布置各页，然后向右上部展开。
static PresentationDirection | TOTOP_TOLEFT 从右下部开始，按列布置各页，然后向左上部展开。
static PresentationDirection | TOTOP_TORIGHT 从左下部开始，按列布置各页，然后向右上部展开。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 PresentationDirection 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 PresentationDirection 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

TOBOTTOM_TORIGHT

public static final PresentationDirection TOBOTTOM_TORIGHT
从左上开始，按列布置各页，然后向右下部展开。

TOBOTTOM_TOLEFT

public static final PresentationDirection TOBOTTOM_TOLEFT
从右上开始，按列布置各页，然后向左下部展开。

TOTOP_TORIGHT

public static final PresentationDirection TOTOP_TORIGHT
从左下部开始，按列布置各页，然后向右上部展开。

TOTOP_TOLEFT

public static final PresentationDirection TOTOP_TOLEFT
从右下部开始，按列布置各页，然后向左上部展开。

TORIGHT_TOBOTTOM

public static final PresentationDirection TORIGHT_TOBOTTOM
从左上部开始，按行布置各页，然后向右下部展开。

TORIGHT_TOTOP

public static final PresentationDirection TORIGHT_TOTOP
从左下部开始，按行布置各页，然后向右上部展开。

TOLEFT_TOBOTTOM

public static final PresentationDirection TOLEFT_TOBOTTOM
从右上部开始，按行布置各页，然后向左下部展开。

TOLEFT_TOTOP

public static final PresentationDirection TOLEFT_TOTOP
从右下部开始，按行布置各页，然后向左上部展开。

方法详细信息

getStringTable

protected String[] getStringTable()
返回类 PresentationDirection 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 PresentationDirection 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PresentationDirection，该类别就是类 PresentationDirection 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PresentationDirection，类别名称是 "presentation-direction"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterInfo

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.PrinterInfo
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterInfo
extends TextSyntax
implements PrintServiceAttribute

PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。这包括类似于下面的信息："This printer can be used for printing color transparencies for HR presentations" 或 "Out of courtesy for others, please print only small (1-5 page) jobs at this printer"，乃至 \ "This printer is going away on July 1, 1997, please find a new printer"。

IPP 兼容性：字符串值提供了 IPP 名称值。语言环境提供了 IPP 自然语言。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterInfo(String info, Locale locale)
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterInfo 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterInfo

public PrinterInfo(String info,
                   Locale locale)
构造具有给定信息字符串和语言环境的新 PrinterInfo 属性。

参数：
info - 打印机信息字符串。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未经检查的异常）如果 info 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterInfo 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterInfo 的一个实例。
  3. 此 PrinterInfo 属性的底层字符串和 object 的底层字符串相等。
  4. 此 PrinterInfo 属性的语言环境和 object 的语言环境相等。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterInfo 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterInfo，该类别就是类 PrinterInfo 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterInfo，类别名称是 "printer-info"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterIsAcceptingJobs (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterIsAcceptingJobs

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.PrinterIsAcceptingJobs
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterIsAcceptingJobs
extends EnumSyntax
implements PrintServiceAttribute

PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。此值与 PrinterState 和 PrinterStateReasons 属性无关，这是因为其值不会影响当前作业；而只会影响以后的作业。如果该值为 NOT_ACCEPTING_JOBS，那么即便是 PrinterState 为 IDLE 时打印机也会拒绝作业。如果值是 ACCEPTING_JOBS，那么即便是 PrinterState 为 STOPPED 时打印机也会接受作业。

IPP 兼容性：对于 ACCEPTING_JOBS，IPP boolean 值为 "true"，而对于 NOT_ACCEPTING_JOBS，其值为 "false"。由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static PrinterIsAcceptingJobs | ACCEPTING_JOBS 打印机当前接受作业。
static PrinterIsAcceptingJobs | NOT_ACCEPTING_JOBS 打印机当前拒绝发送给它的任何作业。
构造方法摘要
protected PrinterIsAcceptingJobs(int value)
构造具有给定整数值的新 PrinterIsAcceptingJobs 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 PrinterIsAcceptingJobs 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 PrinterIsAcceptingJobs 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

NOT_ACCEPTING_JOBS

public static final PrinterIsAcceptingJobs NOT_ACCEPTING_JOBS
打印机当前拒绝发送给它的任何作业。

ACCEPTING_JOBS

public static final PrinterIsAcceptingJobs ACCEPTING_JOBS
打印机当前接受作业。

构造方法详细信息

PrinterIsAcceptingJobs

protected PrinterIsAcceptingJobs(int value)
构造具有给定整数值的新 PrinterIsAcceptingJobs 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 PrinterIsAcceptingJobs 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 PrinterIsAcceptingJobs 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterIsAcceptingJobs，该类别就是类 PrinterIsAcceptingJobs 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterIsAcceptingJobs，类别名称是 "printer-is-accepting-jobs"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterLocation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterLocation

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.PrinterLocation
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterLocation
extends TextSyntax
implements PrintServiceAttribute

PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。这包括类似于下面的信息："in Room 123A, second floor of building XYZ"。

IPP 兼容性：字符串值提供了 IPP 名称值。语言环境提供了 IPP 自然语言。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterLocation(String location, Locale locale)
构造具有给定位置和语言环境的新 PrinterLocation 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterLocation 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterLocation

public PrinterLocation(String location,
                       Locale locale)
构造具有给定位置和语言环境的新 PrinterLocation 属性。

参数：
location - 打印机位置。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未检查的异常）如果 location 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterLocation 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterLocation 的一个实例。
  3. 此 PrinterLocation 属性的底层字符串和 object 的底层字符串相等。
  4. 此 PrinterLocation 属性的语言环境和 object 的语言环境相等。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterLocation 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterLocation，该类别就是类 PrinterLocation 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterLocation，类别名称是 "printer-location"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterMakeAndModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterMakeAndModel

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.PrinterMakeAndModel
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterMakeAndModel
extends TextSyntax
implements PrintServiceAttribute

PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。

IPP 兼容性：字符串值提供了 IPP 名称值。语言环境提供了 IPP 自然语言。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterMakeAndModel(String makeAndModel, Locale locale)
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterMakeAndModel 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterMakeAndModel

public PrinterMakeAndModel(String makeAndModel,
                           Locale locale)
构造具有给定制造和型号字符串以及语言环境的新 PrinterMakeAndModel 属性。

参数：
makeAndModel - 打印机的制造和型号字符串。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未经检查的异常）如果 makeAndModel 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterMakeAndModel 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterMakeAndModel 的一个实例。
  3. 此 PrinterMakeAndModel 属性的底层字符串和 object 的底层字符串相等。
  4. 此 PrinterMakeAndModel 属性的语言环境和 object 的语言环境相等。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterMakeAndModel 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterMakeAndModel，该类别就是类 PrinterMakeAndModel 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterMakeAndModel，类别名称是 "printer-make-and-model"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterMessageFromOperator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterMessageFromOperator

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.PrinterMessageFromOperator
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterMessageFromOperator
extends TextSyntax
implements PrintServiceAttribute

PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。

Print Service 的属性集包括零实例或一个 PrinterMessageFromOperator 属性的实例（不超过一个实例）。新的 PrinterMessageFromOperator 属性将取代现有的 PrinterMessageFromOperator 属性（如果有）。换句话说，PrinterMessageFromOperator 不会成为历史记录。如果想让它成为历史记录，则客户端就可以检测对 Print Service 的 PrinterMessageFromOperator 属性所做的更改，并且维护 PrinterMessageFromOperator 属性值的客户端自己的历史记录。

IPP 兼容性：字符串值提供了 IPP 名称值。语言环境提供了 IPP 自然语言。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterMessageFromOperator(String message, Locale locale)
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterMessageFromOperator 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterMessageFromOperator

public PrinterMessageFromOperator(String message,
                                  Locale locale)
构造具有给定消息和语言环境的新 PrinterMessageFromOperator 属性。

参数：
message - 消息。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未经检查的异常）如果 message 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterMessageFromOperator 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterMessageFromOperator 的一个实例。
  3. 此 PrinterMessageFromOperator 属性的底层字符串和 object 的底层字符串相等。
  4. 此 PrinterMessageFromOperator 属性的语言环境和 object 的语言环境相等。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterMessageFromOperator 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterMessageFromOperator，该类别就是类 PrinterMessageFromOperator 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterMessageFromOperator，类别名称是 "printer-message-from-operator"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterMoreInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterMoreInfo

java.lang.Object
    继承者  javax.print.attribute.URISyntax
        继承者  javax.print.attribute.standard.PrinterMoreInfo
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterMoreInfo
extends URISyntax
implements PrintServiceAttribute

PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。例如，这可以是一个引用 web 浏览器可访问的 HTML 页的 HTTP 类型 URI。可从此 URI 中获得的信息专门供最终用户使用。可以从此 URI 中访问超出 Print Service API 之外的功能。该信息特定于此打印机实例和特定于站点的服务（例如，作业定价、服务提供、最终用户协助）。

相反，PrinterMoreInfoManufacturer 属性用来查找有关此常规种类打印机的更多信息，而不是此特定的打印机。

IPP 兼容性：由 toString() 返回的字符串形式提供了 IPP uri 值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterMoreInfo(URI uri)
构造具有指定 URI 的新 PrinterMoreInfo 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterMoreInfo 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.URISyntax 继承的方法
getURI, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterMoreInfo

public PrinterMoreInfo(URI uri)
构造具有指定 URI 的新 PrinterMoreInfo 属性。

参数：
uri - URI。
抛出：
NullPointerException - （未经检查的异常）如果 uri 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterMoreInfo 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterMoreInfo 的一个实例。
  3. 此 PrinterMoreInfo 属性的 URI 和 object 的 URI 相等。

覆盖：
类 URISyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterMoreInfo 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterMoreInfo，该类别就是类 PrinterMoreInfo 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterMoreInfo，类别名称是 "printer-more-info"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterMoreInfoManufacturer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterMoreInfoManufacturer

java.lang.Object
    继承者  javax.print.attribute.URISyntax
        继承者  javax.print.attribute.standard.PrinterMoreInfoManufacturer
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterMoreInfoManufacturer
extends URISyntax
implements PrintServiceAttribute

PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。从此 URI 中获得的信息专门供最终用户使用。可从此 URI 中访问超出 Print Service API 范围的功能（例如，最新固件、升级、服务代理、可用的可选功能、有关彩色支持的详细信息）。该信息与此打印机的种类有关，而与特定于站点的修改或服务无关。

与此相反，PrinterMoreInfo 属性用于查找关于此特定打印机而不是此通用类型打印机的更多信息。

IPP 兼容性：由 toString() 返回的字符串形式提供了 IPP uri 值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterMoreInfoManufacturer(URI uri)
构造具有指定 URI 的新 PrinterMoreInfoManufacturer 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterMoreInfoManufacturer 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.URISyntax 继承的方法
getURI, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterMoreInfoManufacturer

public PrinterMoreInfoManufacturer(URI uri)
构造具有指定 URI 的新 PrinterMoreInfoManufacturer 属性。

参数：
uri - URI。
抛出：
NullPointerException - （未经检查的异常）如果 uri 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterMoreInfoManufacturer 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterMoreInfoManufacturer 的一个实例。
  3. 此 PrinterMoreInfoManufacturer 属性的 URI 和 object 的 URI 相等。

覆盖：
类 URISyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterMoreInfoManufacturer 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterMoreInfoManufacturer，该类别就是类 PrinterMoreInfoManufacturer 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterMoreInfoManufacturer，类别名称是 "printer-more-info-manufacturer"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterName

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.PrinterName
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterName
extends TextSyntax
implements PrintServiceAttribute

PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。与其说它是一个 URI，倒不如说它是一个最终用户友好的名称。管理员可以确定打印机的名称并将此属性设置为该名称。此名称可以是打印机 URI 的最后部分，也可以与其无关。在非美式英语语言环境中，名称可以包含那些在 URI 中不允许的字符。

IPP 兼容性：字符串值提供了 IPP 名称值。语言环境提供了 IPP 自然语言。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterName(String printerName, Locale locale)
构造具有给定名称和语言环境的新 PrinterName 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterName 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterName

public PrinterName(String printerName,
                   Locale locale)
构造具有给定名称和语言环境的新 PrinterName 属性。

参数：
printerName - 打印机名称。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未经检查的异常）如果 printerName 为 null，则抛出该异常。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterName 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterName 的一个实例。
  3. 此 PrinterName 属性的底层字符串和 object 的底层字符串相等。
  4. 此 PrinterName 属性的语言环境和 object 的语言环境相等。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterName 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterName，该类别就是类 PrinterName 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterName，类别名称是 "printer-name"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterResolution (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterResolution

java.lang.Object
    继承者  javax.print.attribute.ResolutionSyntax
        继承者  javax.print.attribute.standard.PrinterResolution
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class PrinterResolution
extends ResolutionSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。此属性假定打印机有少部分（而不是全部）设备分辨率设置，打印机可以此设备分辨率运行。

可以多种方式使用 PrinterResolution：

  1. 当客户端进行搜索，查找支持客户端所需准确（不多不少）分辨率的打印机时，客户端可以指定类 PrinterResolution 的一个实例，指示客户端所需的准确分辨率。只有支持该分辨率的打印机才与搜索相匹配。

  2. 当客户端需要使用客户端所需准确（不多不少）的分辨率来打印一项作业时，客户端可将类 PrinterResolution 的一个实例指定为 Print Job 的一个属性。如果 Print Job 不支持该分辨率，并且 Fidelity 被设置为 true，则操作将失败。
如果客户端想查找一个支持高于最低所需分辨率的打印机，则有必要将此属性排除在查找请求之外，直接查询受支持的分辨率集，并指定能最好地满足客户要求的某个分辨率。在某些情况下，这通过指定经常控制分辨率的 PrintQuality 属性即可轻松地实现。

IPP 兼容性：构造 IPP "printer-resolution" 属性所需的信息可以通过调用 PrinterResolution 对象的方法来获取。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

字段摘要
从类 javax.print.attribute.ResolutionSyntax 继承的字段
DPCM, DPI
构造方法摘要
PrinterResolution(int crossFeedResolution, int feedResolution, int units)
根据给定的项构造新的 PrinterResolution 属性。
方法摘要
boolean | equals(Object object) 返回此 PrinterResolution 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.ResolutionSyntax 继承的方法
getCrossFeedResolution, getCrossFeedResolutionDphi, getFeedResolution, getFeedResolutionDphi, getResolution, hashCode, lessThanOrEquals, toString, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterResolution

public PrinterResolution(int crossFeedResolution,
                         int feedResolution,
                         int units)
根据给定的项构造新的 PrinterResolution 属性。

参数：
crossFeedResolution - Cross 进纸分辨率。
feedResolution - 进纸分辨率。
units - 单位转换因子，例如 ResolutionSyntax.DPI 或 ResolutionSyntax.>DPCM。
抛出：
IllegalArgumentException - （未经检查的异常）如果 crossFeedResolution < 1 或 feedResolution < 1，或者 units < 1。
方法详细信息

equals

public boolean equals(Object object)
返回此 PrinterResolution 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterResolution 的一个实例。
  3. 此属性的 cross 进纸分辨率与 object 的 cross 进纸分辨率相等。
  4. 此属性的进纸分辨率与 object 的进纸分辨率相等。

覆盖：
类 ResolutionSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterResolution 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterResolution，该类别就是类 PrinterResolution 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterResolution，类别名称是 "printer-resolution"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterState (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterState

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.PrinterState
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterState
extends EnumSyntax
implements PrintServiceAttribute

PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。类 PrinterState 定义了标准的打印机状态值。Print Service 实现只需要报告这些打印机的状态，说明哪些状态合乎特定的实现；而不必报告每种已定义的打印机状态。PrinterStateReasons 属性扩充了 PrinterState 属性，以提供有关给定的打印机状态下打印机的更多详细信息。

IPP 兼容性：由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static PrinterState | IDLE 指示可以开始处理新作业，无需等待。
static PrinterState | PROCESSING 指示正在处理作业；处理完成前新作业需等待。
static PrinterState | STOPPED 指示没有作业可以处理，需要干预。
static PrinterState | UNKNOWN 打印机状态未知。
构造方法摘要
protected PrinterState(int value)
构造具有给定整数值的新 PrinterState 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 PrinterState 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 PrinterState 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

UNKNOWN

public static final PrinterState UNKNOWN
打印机状态未知。

IDLE

public static final PrinterState IDLE
指示可以开始处理新作业，无需等待。

PROCESSING

public static final PrinterState PROCESSING
指示正在处理作业；处理完成前新作业需等待。

STOPPED

public static final PrinterState STOPPED
指示没有作业可以处理，需要干预。

构造方法详细信息

PrinterState

protected PrinterState(int value)
构造具有给定整数值的新 PrinterState 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 PrinterState 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 PrinterState 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterState，该类别就是类 PrinterState 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterState，类别名称是 "printer-state"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterStateReason (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterStateReason

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.PrinterStateReason
所有已实现的接口：
Serializable, Cloneable, Attribute
public class PrinterStateReason
extends EnumSyntax
implements Attribute

PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。类 PrinterStateReason 定义了标准的打印机状态原因值。Print Service 实现只需要报告这些打印机状态的原因，说明哪些原因合乎特定的实现；而不必报告每种已定义的打印机状态原因。

PrinterStateReason 的实例不会直接出现在 Print Service 的属性集中。而 PrinterStateReasons 属性则会出现在 Print Service 的属性集中。PrinterStateReasons 属性包括零、一个或多个与 Print Service 的状态相关的 PrinterStateReason 对象，并且每个 PrinterStateReason 对象都与 REPORT（不太严重）、WARNING 或 ERROR（最严重）的 Severity 级别相关联。当相应的条件变成了打印机的真实条件时，打印机将把 PrinterStateReason 对象添加到 Print Service 的 PrinterStateReasons 属性中，而当相应的条件变成虚假条件时，无论 Print Service 的总体 PrinterState 是否也已更改，打印机都将再次移除 PrinterStateReason 对象。

IPP 兼容性：字符串值由每个 PrinterStateReason 和相关的 Severity 对象的 toString() 方法返回，它们之间用连字号（"-"）连接，该值提供了 PrinterStateReasons 的 IPP 关键字值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

字段摘要
static PrinterStateReason | CONNECTING_TO_DEVICE 打印机已经在输出设备中安排了作业，并且正在与共享的网络输出设备进行连接（并且可能在相当长的时间内无法实际开始打印作业，因为这取决于网络上其他服务器对该输出设备的使用情况）。
static PrinterStateReason | COVER_OPEN 设备上的一个或多个机盖处于打开状态。
static PrinterStateReason | DEVELOPER_EMPTY 设备显影剂已用完。
static PrinterStateReason | DEVELOPER_LOW 设备显影剂不足。
static PrinterStateReason | DOOR_OPEN 设备上的一个或多个门处于打开状态。
static PrinterStateReason | FUSER_OVER_TEMP 热熔器温度高于正常值。
static PrinterStateReason | FUSER_UNDER_TEMP 热熔器温度低于正常值。
static PrinterStateReason | INPUT_TRAY_MISSING 设备中没有一个或多个输入纸盒。
static PrinterStateReason | INTERLOCK_OPEN 打印机上的一个或多个连锁设备未锁定。
static PrinterStateReason | INTERPRETER_RESOURCE_UNAVAILABLE 解释器资源（例如字体、格式）不可用。
static PrinterStateReason | MARKER_SUPPLY_EMPTY 设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）已用完。
static PrinterStateReason | MARKER_SUPPLY_LOW 设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）不足。
static PrinterStateReason | MARKER_WASTE_ALMOST_FULL 设备指示器耗材废物容器几乎已填满。
static PrinterStateReason | MARKER_WASTE_FULL 设备指示器耗材废物容器已填满。
static PrinterStateReason | MEDIA_EMPTY 至少一个输入纸盒是空的。
static PrinterStateReason | MEDIA_JAM 设备中卡住了介质。
static PrinterStateReason | MEDIA_LOW 至少一个输入纸盒的介质不足。
static PrinterStateReason | MEDIA_NEEDED 纸盒中没有介质。
static PrinterStateReason | MOVING_TO_PAUSED 已经暂停了打印机，但设备要停下来还需要一些时间。
static PrinterStateReason | OPC_LIFE_OVER 光敏导电体已不再运行。
static PrinterStateReason | OPC_NEAR_EOL 光敏导电体寿命将到期。
static PrinterStateReason | OTHER 打印机已经检测到了一个以下未列出的错误。
static PrinterStateReason | OUTPUT_AREA_ALMOST_FULL 一个或多个输出区域几乎已经填满（例如纸盒、装订器、整理器）。
static PrinterStateReason | OUTPUT_AREA_FULL 一个或多个输出区域已经填满（例如纸盒、装订器、整理器）。
static PrinterStateReason | OUTPUT_TRAY_MISSING 设备中没有一个或多个输出纸盒。
static PrinterStateReason | PAUSED 已经暂停了打印机并且打印机的 PrinterState 为 STOPPED。
static PrinterStateReason | SHUTDOWN 已经从服务中移除了打印机，并且可以给该打印机断电或者物理移除它。
static PrinterStateReason | SPOOL_AREA_FULL 已达到为后台打印分配的持久存储限制。
static PrinterStateReason | STOPPED_PARTLY 当打印机控制多个输出设备时，此原因指示一个或多个设备被停止。
static PrinterStateReason | STOPPING 打印机正在停止设备，并且打印机也将很快停下来。
static PrinterStateReason | TIMED_OUT 服务器能够连接到输出设备（或始终处于连接状态），但却无法获得输出设备的响应。
static PrinterStateReason | TONER_EMPTY 设备的碳粉用完。
static PrinterStateReason | TONER_LOW 设备的碳粉不足。
构造方法摘要
protected PrinterStateReason(int value)
构造具有给定整数值的新 PrinterStateReason 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 PrinterStateReason 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 PrinterStateReason 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

OTHER

public static final PrinterStateReason OTHER
打印机已经检测到了一个以下未列出的错误。

MEDIA_NEEDED

public static final PrinterStateReason MEDIA_NEEDED
纸盒中没有介质。

MEDIA_JAM

public static final PrinterStateReason MEDIA_JAM
设备中卡住了介质。

MOVING_TO_PAUSED

public static final PrinterStateReason MOVING_TO_PAUSED
已经暂停了打印机，但设备要停下来还需要一些时间。然后，当所有的输出都停止后，PrinterState 将变为 STOPPED，PAUSED 值会取代 PrinterStateReasons 属性中的 MOVING_TO_PAUSED 值。如果可以暂停打印机并且在某些特定情形下实现需要占用相当长时间来暂停设备，则必须支持此值。

PAUSED

public static final PrinterStateReason PAUSED
已经暂停了打印机并且打印机的 PrinterState 为 STOPPED。在此情况下，打印机必须不产生打印输出，但它必须执行客户端请求的其他操作。如果正在打印作业时暂停了打印机，则打印机必须在其打开后恢复打印该作业，并且在此暂停后的打印输出中不留下任何痕迹。如果可以暂停打印机，则必须支持此值。

SHUTDOWN

public static final PrinterStateReason SHUTDOWN
已经从服务中移除了打印机，并且可以给该打印机断电或者物理移除它。在此情况下，打印机必须不产生打印输出，并且如果仍处于活动状态的打印服务器无法识别该打印机，则该打印机必须不执行客户端请求的其他操作。如果打印机正在打印作业时被关闭，则在打开打印机后该打印机不必恢复打印该作业。如果打印机恢复打印此类作业，可能会在此类关机情况的打印输出中留下痕迹，例如，关机前打印的那一部分可能会在关机后再打印一次。

CONNECTING_TO_DEVICE

public static final PrinterStateReason CONNECTING_TO_DEVICE
打印机已经在输出设备中安排了作业，并且正在与共享的网络输出设备进行连接（并且可能在相当长的时间内无法实际开始打印作业，因为这取决于网络上其他服务器对该输出设备的使用情况）。

TIMED_OUT

public static final PrinterStateReason TIMED_OUT
服务器能够连接到输出设备（或始终处于连接状态），但却无法获得输出设备的响应。

STOPPING

public static final PrinterStateReason STOPPING
打印机正在停止设备，并且打印机也将很快停下来。停止设备后，打印机将把 PrinterState 更改为 STOPPED。即使打印机只有一个输出设备，STOPPING 原因也永远不会是一个错误。当输出设备停止接受作业时，在输出设备完成打印时打印机的 PrinterStateReasons 将具有此原因。

STOPPED_PARTLY

public static final PrinterStateReason STOPPED_PARTLY
当打印机控制多个输出设备时，此原因指示一个或多个设备被停止。如果该原因的严重性是 report，则表示有不超过一半的输出设备被停止。如果该原因的严重性是 warning，则表示有一半或更多（但不是全部）的输出设备被停止。

TONER_LOW

public static final PrinterStateReason TONER_LOW
设备的碳粉不足。

TONER_EMPTY

public static final PrinterStateReason TONER_EMPTY
设备的碳粉用完。

SPOOL_AREA_FULL

public static final PrinterStateReason SPOOL_AREA_FULL
已达到为后台打印分配的持久存储限制。打印机暂时无法接受更多的作业。当打印机能够接受更多作业时将去除此原因。此值应该由一次只接受一项或少量作业的非后台打印打印机或者已经填满了后台打印空间的后台打印打印机使用。

COVER_OPEN

public static final PrinterStateReason COVER_OPEN
设备上的一个或多个机盖处于打开状态。

INTERLOCK_OPEN

public static final PrinterStateReason INTERLOCK_OPEN
打印机上的一个或多个连锁设备未锁定。

DOOR_OPEN

public static final PrinterStateReason DOOR_OPEN
设备上的一个或多个门处于打开状态。

INPUT_TRAY_MISSING

public static final PrinterStateReason INPUT_TRAY_MISSING
设备中没有一个或多个输入纸盒。

MEDIA_LOW

public static final PrinterStateReason MEDIA_LOW
至少一个输入纸盒的介质不足。

MEDIA_EMPTY

public static final PrinterStateReason MEDIA_EMPTY
至少一个输入纸盒是空的。

OUTPUT_TRAY_MISSING

public static final PrinterStateReason OUTPUT_TRAY_MISSING
设备中没有一个或多个输出纸盒。

OUTPUT_AREA_ALMOST_FULL

public static final PrinterStateReason OUTPUT_AREA_ALMOST_FULL
一个或多个输出区域几乎已经填满（例如纸盒、装订器、整理器）。

OUTPUT_AREA_FULL

public static final PrinterStateReason OUTPUT_AREA_FULL
一个或多个输出区域已经填满（例如纸盒、装订器、整理器）。

MARKER_SUPPLY_LOW

public static final PrinterStateReason MARKER_SUPPLY_LOW
设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）不足。

MARKER_SUPPLY_EMPTY

public static final PrinterStateReason MARKER_SUPPLY_EMPTY
设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）已用完。

MARKER_WASTE_ALMOST_FULL

public static final PrinterStateReason MARKER_WASTE_ALMOST_FULL
设备指示器耗材废物容器几乎已填满。

MARKER_WASTE_FULL

public static final PrinterStateReason MARKER_WASTE_FULL
设备指示器耗材废物容器已填满。

FUSER_OVER_TEMP

public static final PrinterStateReason FUSER_OVER_TEMP
热熔器温度高于正常值。

FUSER_UNDER_TEMP

public static final PrinterStateReason FUSER_UNDER_TEMP
热熔器温度低于正常值。

OPC_NEAR_EOL

public static final PrinterStateReason OPC_NEAR_EOL
光敏导电体寿命将到期。

OPC_LIFE_OVER

public static final PrinterStateReason OPC_LIFE_OVER
光敏导电体已不再运行。

DEVELOPER_LOW

public static final PrinterStateReason DEVELOPER_LOW
设备显影剂不足。

DEVELOPER_EMPTY

public static final PrinterStateReason DEVELOPER_EMPTY
设备显影剂已用完。

INTERPRETER_RESOURCE_UNAVAILABLE

public static final PrinterStateReason INTERPRETER_RESOURCE_UNAVAILABLE
解释器资源（例如字体、格式）不可用。

构造方法详细信息

PrinterStateReason

protected PrinterStateReason(int value)
构造具有给定整数值的新 PrinterStateReason 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 PrinterStateReason 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 PrinterStateReason 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterStateReason 和任何供应商定义的子类，该类别都是类 PrinterStateReason 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterStateReason 和任何供应商定义的子类，类别名称均是 "printer-state-reason"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterStateReasons (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterStateReasons

java.lang.Object
    继承者  java.util.AbstractMap<K,V>
        继承者  java.util.HashMap<PrinterStateReason,Severity>
            继承者  javax.print.attribute.standard.PrinterStateReasons
所有已实现的接口：
Serializable, Cloneable, Map<PrinterStateReason,Severity>, Attribute, PrintServiceAttribute
public final class PrinterStateReasons
extends HashMap<PrinterStateReason,Severity>
implements PrintServiceAttribute

PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。

PrinterStateReason 的实例不会直接出现在 Print Service 的属性集中。而 PrinterStateReasons 属性则会出现在 Print Service 的属性集中。PrinterStateReasons 属性包括零、一个或多个与 Print Service 的状态相关的 PrinterStateReason 对象，并且每个 PrinterStateReason 对象都与 REPORT（不太严重）、WARNING 或 ERROR（最严重）的 Severity 级别相关联。当相应的条件变成了打印机的真实条件时，打印机将把 PrinterStateReason 对象添加到 Print Service 的 PrinterStateReasons 属性中，而当相应的条件变成虚假条件时，无论 Print Service 的总体 PrinterState 是否也已更改，打印机都将再次移除 PrinterStateReason 对象。

类 PrinterStateReasons 从类 java.util.HashMap 中继承了其实现。映射中的每一项都包括映射到 Severity 对象（值）的 PrinterStateReason 对象（键）：

与大部分一旦构造就不可改变的打印属性不同，类 PrinterStateReasons 设计为可变的；您可以将 PrinterStateReason 对象添加到现有的 PrinterStateReasons 对象中，并可将它们移除。不过，与类 java.util.HashMap 一样，类 PrinterStateReasons 具有 bot 多线程安全性。如果 PrinterStateReasons 对象将由多线程使用，则一定要同步其操作（例如，使用从类 java.util.Collections 中获取的已同步映射视图）。

IPP 兼容性：字符串值由每个 PrinterStateReason 对象和相关的 Severity 对象的 toString() 方法返回，它们之间用连字号 ("-") 连接，该值提供了 IPP 关键字值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

嵌套类摘要
从类 java.util.AbstractMap 继承的嵌套类/接口
AbstractMap.SimpleEntry<K,V>, AbstractMap.SimpleImmutableEntry<K,V>
构造方法摘要
PrinterStateReasons()
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有默认的初始容量和加载因子。
PrinterStateReasons(int initialCapacity)
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和默认的加载因子。
PrinterStateReasons(int initialCapacity, float loadFactor)
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和加载因子。
PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
Set<PrinterStateReason> | printerStateReasonSet(Severity severity) 在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。
Severity | put(PrinterStateReason reason, Severity severity) 根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。
从类 java.util.HashMap 继承的方法
clear, clone, containsKey, containsValue, entrySet, get, isEmpty, keySet, putAll, remove, size, values
从类 java.util.AbstractMap 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait
从接口 java.util.Map 继承的方法
equals, hashCode

构造方法详细信息

PrinterStateReasons

public PrinterStateReasons()
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有默认的初始容量和加载因子。

PrinterStateReasons

public PrinterStateReasons(int initialCapacity)
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和默认的加载因子。

参数：
initialCapacity - 初始容量。
抛出：
IllegalArgumentException - 如果初始容量小于零。

PrinterStateReasons

public PrinterStateReasons(int initialCapacity,
                           float loadFactor)
构造一个新的空 PrinterStateReasons 属性；底层哈希映射具有给定的初始容量和加载因子。

参数：
initialCapacity - 初始容量。
loadFactor - 加载因子。
抛出：
IllegalArgumentException - 如果初始容量小于零。

PrinterStateReasons

public PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。底层哈希映射的初始容量和加载因子与在超类构造方法 HashMap(Map) 中指定的相同。

参数：
map - 要复制的映射。
抛出：
NullPointerException - （未经检查的异常）如果 map 为 null，或者 map 中的任何键或值为 null。
ClassCastException - （未经检查的异常）如果 map 中的任何键不是类 PrinterStateReason 的一个实例，或者 map 中的任何值不是类 Severity 一个实例。
方法详细信息

put

public Severity put(PrinterStateReason reason,
                    Severity severity)
根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。如果此 PrinterStateReasons 属性以前包含了给定打印机状态原因的映射关系，则取代原来的值。

指定者：
接口 Map<PrinterStateReason,Severity> 中的 put
覆盖：
类 HashMap<PrinterStateReason,Severity> 中的 put
参数：
reason - 打印机状态原因。这必须是类 PrinterStateReason 的一个实例。
severity - 打印机状态原因的严重性。这必须是类 Severity 的一个实例。
返回：
以前与给定打印机状态原因相关联的严重性，如果给定的打印机状态原因不存在，则返回 null。
抛出：
NullPointerException - （未经检查的异常）如果 reason 为 null，或者 severity 为 null。
ClassCastException - （未经检查的异常）如果 reason 不是类 PrinterStateReason 的一个实例，或者 severity 不是类 Severity 的一个实例。
从以下版本开始：
1.5

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterStateReasons，该类别就是类 PrinterStateReasons 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterStateReasons，类别名称是 "printer-state-reasons"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。

printerStateReasonSet

public Set<PrinterStateReason> printerStateReasonSet(Severity severity)
在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。该视图集中的每个元素都是一个 PrinterStateReason 对象。视图集中仅有的元素是映射到给定严重性值的 PrinterStateReason 对象。该视图集受此 PrinterStateReasons 属性支持，因此，对此 PrinterStateReasons 属性的更改会在视图集中反映出来。该视图集不支持元素插入或移除。视图集的迭代器不支持元素移除。

参数：
severity - 严重性级别。
返回：
在给定 Severity 级别每个 PrinterStateReason 属性的视图集。
抛出：
NullPointerException - （未经检查的异常）如果 severity 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrinterURI (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrinterURI

java.lang.Object
    继承者  javax.print.attribute.URISyntax
        继承者  javax.print.attribute.standard.PrinterURI
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class PrinterURI
extends URISyntax
implements PrintServiceAttribute

PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。如果打印机有这样的名称，则管理员可以确定打印机的 URI 并将此属性设置为该名称。

IPP 兼容性：这实现了 IPP PrinterURI 属性。由 toString() 返回的字符串形式提供了 IPP PrinterURI 值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
PrinterURI(URI uri)
构建具有指定 URI 的新 PrinterURI 属性。
方法摘要
boolean | equals(Object object) 返回此打印机名称属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.URISyntax 继承的方法
getURI, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrinterURI

public PrinterURI(URI uri)
构建具有指定 URI 的新 PrinterURI 属性。

参数：
uri - 打印机的 URI
抛出：
NullPointerException - （未经检查的异常）如果 uri 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此打印机名称属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 PrinterURI 的一个实例。
  3. 此 PrinterURI 属性的底层 URI 和 object 的底层 URI 相等。

覆盖：
类 URISyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 PrinterURI 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrinterURI 和任何供应商定义的子类，该类别都是类 PrinterURI 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrinterURI 和任何供应商定义的子类，类别名称均是 "printer-uri"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintQuality (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 PrintQuality

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.PrintQuality
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public class PrintQuality
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。

IPP 兼容性：由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static PrintQuality | DRAFT 打印机可提供的最低打印质量。
static PrintQuality | HIGH 打印机可提供的最高打印质量。
static PrintQuality | NORMAL 打印机上的正常或中等质量。
构造方法摘要
protected PrintQuality(int value)
构造具有给定整数值的新 PrintQuality 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 PrintQuality 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected int | getOffset() 返回类 PrintQuality 所使用的最小整数值。
protected String[] | getStringTable() 返回类 PrintQuality 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

DRAFT

public static final PrintQuality DRAFT
打印机可提供的最低打印质量。

NORMAL

public static final PrintQuality NORMAL
打印机上的正常或中等质量。

HIGH

public static final PrintQuality HIGH
打印机可提供的最高打印质量。

构造方法详细信息

PrintQuality

protected PrintQuality(int value)
构造具有给定整数值的新 PrintQuality 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 PrintQuality 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 PrintQuality 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getOffset

protected int getOffset()
返回类 PrintQuality 所使用的最小整数值。

覆盖：
类 EnumSyntax 中的 getOffset
返回：
最小枚举值的偏移量。

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 PrintQuality 和任何供应商定义的子类，该类别都是类 PrintQuality 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 PrintQuality 和任何供应商定义的子类，类别名称均为 "print-quality"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


QueuedJobCount (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 QueuedJobCount

java.lang.Object
    继承者  javax.print.attribute.IntegerSyntax
        继承者  javax.print.attribute.standard.QueuedJobCount
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintServiceAttribute
public final class QueuedJobCount
extends IntegerSyntax
implements PrintServiceAttribute

QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。

IPP 兼容性：该整数值提供了 IPP 整数值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
QueuedJobCount(int value)
构造具有给定整数值的新 QueuedJobCount 属性。
方法摘要
boolean | equals(Object object) 返回此 QueuedJobCount 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.IntegerSyntax 继承的方法
getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

QueuedJobCount

public QueuedJobCount(int value)
构造具有给定整数值的新 QueuedJobCount 属性。

参数：
value - 整数值。
抛出：
IllegalArgumentException - （未经检查的异常）如果 value 小于 0。
方法详细信息

equals

public boolean equals(Object object)
返回此 QueuedJobCount 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 QueuedJobCount 的一个实例。
  3. 此 QueuedJobCount 属性的值和 object 的值相等。

覆盖：
类 IntegerSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 QueuedJobCount 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 QueuedJobCount，该类别就是类 QueuedJobCount 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 QueuedJobCount，类别名称是 "queued-job-count"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReferenceUriSchemesSupported (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 ReferenceUriSchemesSupported

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.ReferenceUriSchemesSupported
所有已实现的接口：
Serializable, Cloneable, Attribute
public class ReferenceUriSchemesSupported
extends EnumSyntax
implements Attribute

ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。如果打印机支持具有 "java.net.URL" 打印数据表示形式类的 doc flavor，则该打印机可以使用类 ReferenceUriSchemesSupported 的实例来公布它可接受的 URI 方案。可接受的 URI 方案作为服务属性包含在查找服务中；这使客户端可搜索能够使用特定 URI 方案即可获得打印数据的打印机。还可使用接口 PrintService 中的 capability 方法查询可接受的 URI 方案。但是，ReferenceUriSchemesSupported 属性一般单独用来确定可接受的 URI 方案，doc、打印请求、打印作业或打印服务的属性集中从不包括这些方案。

因特网地址分配委员会维护着URI 模式官方列表。

类 ReferenceUriSchemesSupported 为广泛使用的 URI 方案定义了枚举值。支持其他 URI 方案的打印机可以在类 ReferenceUriSchemesSupported 的子类中定义它们。

IPP 兼容性：由 getName() 返回的类别名称是 IPP 属性名称。枚举的整数值是 IPP 枚举值。toString() 方法返回属性值的 IPP 字符串表示形式。

另请参见：
序列化表格

字段摘要
static ReferenceUriSchemesSupported | FILE 特定于主机的文件名称。
static ReferenceUriSchemesSupported | FTP 文件传输协议 (FTP)。
static ReferenceUriSchemesSupported | GOPHER Gopher 协议。
static ReferenceUriSchemesSupported | HTTP 超文本传输协议 (HTTP)。
static ReferenceUriSchemesSupported | HTTPS 安全超文本传输协议 (HTTPS)。
static ReferenceUriSchemesSupported | NEWS USENET 新闻。
static ReferenceUriSchemesSupported | NNTP 使用网络新闻传输协议 (NNTP) 的 USENET 新闻。
static ReferenceUriSchemesSupported | WAIS 广域信息服务器 (WAIS) 协议。
构造方法摘要
protected ReferenceUriSchemesSupported(int value)
构造具有给定整数值的新 ReferenceUriSchemesSupported 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 ReferenceUriSchemesSupported 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 ReferenceUriSchemesSupported 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

FTP

public static final ReferenceUriSchemesSupported FTP
文件传输协议 (FTP)。

HTTP

public static final ReferenceUriSchemesSupported HTTP
超文本传输协议 (HTTP)。

HTTPS

public static final ReferenceUriSchemesSupported HTTPS
安全超文本传输协议 (HTTPS)。

GOPHER

public static final ReferenceUriSchemesSupported GOPHER
Gopher 协议。

NEWS

public static final ReferenceUriSchemesSupported NEWS
USENET 新闻。

NNTP

public static final ReferenceUriSchemesSupported NNTP
使用网络新闻传输协议 (NNTP) 的 USENET 新闻。

WAIS

public static final ReferenceUriSchemesSupported WAIS
广域信息服务器 (WAIS) 协议。

FILE

public static final ReferenceUriSchemesSupported FILE
特定于主机的文件名称。

构造方法详细信息

ReferenceUriSchemesSupported

protected ReferenceUriSchemesSupported(int value)
构造具有给定整数值的新 ReferenceUriSchemesSupported 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 ReferenceUriSchemesSupported 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 ReferenceUriSchemesSupported 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 ReferenceUriSchemesSupported 和任何供应商定义的子类，该类别都是类 ReferenceUriSchemesSupported 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 ReferenceUriSchemesSupported 和任何供应商定义的子类，类别名称均是 "reference-uri-schemes-supported"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RequestingUserName (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 RequestingUserName

java.lang.Object
    继承者  javax.print.attribute.TextSyntax
        继承者  javax.print.attribute.standard.RequestingUserName
所有已实现的接口：
Serializable, Cloneable, Attribute, PrintRequestAttribute
public final class RequestingUserName
extends TextSyntax
implements PrintRequestAttribute

RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。RequestingUserName 是一种由客户端定义的任意字符串。打印机不会将客户端指定的 RequestingUserName 属性放到 Print Job 的属性集中；而是放入 JobOriginatingUserName 属性。这意味着支持使用此属性指定用户名称的服务还应该在作业的属性集中报告 JobOriginatingUserName。注意，许多打印服务都可以有一种独立验证用户名称的方式，对 RequestingUserName 的状态支持也是这样，但实际上打印服务会接着报告由该服务验证的用户名称，而不是通过此属性指定的用户名称。

IPP 兼容性：字符串值提供了 IPP 名称值。语言环境提供了 IPP 自然语言。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

构造方法摘要
RequestingUserName(String userName, Locale locale)
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。
方法摘要
boolean | equals(Object object) 返回此 RequestingUserName 属性是否等效于传入的对象。
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
从类 javax.print.attribute.TextSyntax 继承的方法
getLocale, getValue, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

RequestingUserName

public RequestingUserName(String userName,
                          Locale locale)
构造具有给定用户名称和语言环境的新 RequestingUserName 属性。

参数：
userName - 用户名称。
locale - 文本字符串的自然语言。将 null 解释为默认的语言环境，这是 Locale.getDefault() 返回的语言环语。
抛出：
NullPointerException - （未经检查的异常）如果 userName 为 null。
方法详细信息

equals

public boolean equals(Object object)
返回此 RequestingUserName 属性是否等效于传入的对象。若要等效，以下所有条件都必须为 true：
  1. object 不为 null。
  2. object 是类 RequestingUserName 的一个实例。
  3. 此 RequestingUserName 属性的底层字符串和 object 的底层字符串相等。
  4. 此 RequestingUserName 属性的语言环境和 object 的语言环境相等。

覆盖：
类 TextSyntax 中的 equals
参数：
object - 要比较的对象。
返回：
如果 object 等效于此 RequestingUserName 属性，则返回 True，否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 RequestingUserName，该类别就是类 RequestingUserName 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 RequestingUserName，类别名称是 "requesting-user-name"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Severity (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 Severity

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.Severity
所有已实现的接口：
Serializable, Cloneable, Attribute
public final class Severity
extends EnumSyntax
implements Attribute

Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。

Severity 的实例不会直接出现在 Print Service 的属性集中。而 PrinterStateReasons 属性则会出现在 Print Service 的属性集中。PrinterStateReasons 属性包括零、一个或多个与 Print Service 的状态相关的 PrinterStateReason 对象，并且每个 PrinterStateReason 对象都与 REPORT（不太严重）、WARNING 或 ERROR（最严重）的 Severity 级别相关。当相应的条件变成了打印机的真实条件时，打印机将把 PrinterStateReason 对象添加到 Print Service 的 PrinterStateReasons 属性中，而当相应的条件变成虚假条件时，无论 Print Service 的总体 PrinterState 是否也已更改，打印机将再次移除 PrinterStateReason 对象。

IPP 兼容性：Severity.toString() 返回 "error"、"warning" 或 "report"。字符串值由每个 PrinterStateReason 和相关的 Severity 对象的 toString() 方法返回，它们之间用连字号（"-"）连接，该值提供了 PrinterStateReasons 的 IPP 关键字值。由 getName() 返回的类别名称提供了 IPP 属性名称。

另请参见：
序列化表格

字段摘要
static Severity | ERROR 指示 PrinterStateReason 是 "error"（最严重）。
static Severity | REPORT 指示 PrinterStateReason 是 "report"（不太严重）。
static Severity | WARNING 指示 PrinterStateReason 是 "warning"。
构造方法摘要
protected Severity(int value)
构造具有给定整数值的新 Severity 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 Severity 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 Severity 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

REPORT

public static final Severity REPORT
指示 PrinterStateReason 是 "report"（不太严重）。实现可以选择忽略部分或全部 "report"。有些 "report" 指定了更为详细的打印机状态；其他一些可作为 "warning" 的先兆。"report" 不能包含任何会影响打印输出的内容。

WARNING

public static final Severity WARNING
指示 PrinterStateReason 是 "warning"。实现可以选择忽略部分或全部 "warning"。"warning" 可作为 "error" 的先兆。"error" 不能包括任何会阻止作业完成的内容，但在某些情况下输出的质量可能仍然较差。

ERROR

public static final Severity ERROR
指示 PrinterStateReason 是 "error"（最严重）。实现必须包括全部的 "error"。如果此属性包括一个或多个 "error"，则打印机的 PrinterState 必须为 STOPPED。

构造方法详细信息

Severity

protected Severity(int value)
构造具有给定整数值的新 Severity 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 Severity 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 Severity 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 Severity，该类别就是类 Severity 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 Severit，类别名称是 "severity"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SheetCollate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.attribute.standard
类 SheetCollate

java.lang.Object
    继承者  javax.print.attribute.EnumSyntax
        继承者  javax.print.attribute.standard.SheetCollate
所有已实现的接口：
Serializable, Cloneable, Attribute, DocAttribute, PrintJobAttribute, PrintRequestAttribute
public final class SheetCollate
extends EnumSyntax
implements DocAttribute, PrintRequestAttribute, PrintJobAttribute

SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。当 SheetCollate 为 COLLATED 时，将使用排列有序的打印流纸张打印每个文档的每个副本。当 SheetCollate 为 UNCOLLATED 时，每个打印流纸张将被连续多次打印，其次数等于 Copies 属性的值。例如，假设一个文档需要打印出两种输出介质纸张，Copies 为 6，SheetCollate 为 UNCOLLATED；则在此情况下，将首先打印出六份第一种介质纸张，然后再打印出六份第二种介质纸张。

无论纸张整理的效果是通过将文档的副本放在多个输出箱中达到的，还是放在同一个输出箱中使用已定义的实现达到的，文档区分都与实现相关。另外，无论是通过多种方式传递作业，还是使用一种输出来存档，分类器都与实现相关。

如果打印机不支持 SheetCollate 属性（是指客户端无法指定任何特定的纸张整理），则打印机的行为都必须表现为似乎 SheetCollate 始终被设置为 COLLATED。

SheetCollate 属性可与 MultipleDocumentHandling 属性交互。MultipleDocumentHandling 属性描述了对整个文档的整理，而 SheetCollate 属性描述了整理文档中具体页的语义。

多文档打印（一个作业带有多个文档）作业的 SheetCollate 属性的效果取决于是为所有的文档指定了相同的纸张整理，还是为不同的文档指定了不同的纸张整理，以及 MultipleDocumentHandling 属性的值（可能是默认值）。

  • 如果为所有的文档指定了相同的纸张整理，则允许进行 SheetCollate 和 MultipleDocumentHandling 的以下组合，并且在指定了其他任何组合的情况下提交作业时，打印机都将报告一个错误：
    • SheetCollate = COLLATED，MultipleDocumentHandling = SINGLE_DOCUMENT -- 所有的输入文档都将合并到一个输出文档中。生成输出文档的多个副本，按整理后的顺序打印各页，即页 1，2，3，……，1，2，3 等。

    • SheetCollate = COLLATED，MultipleDocumentHandling = SINGLE_DOCUMENT_NEW_SHEET -- 所有的输入文档都将合并到一个输出文档中，并且始终在新的介质纸张上开始每个输入文档的第一个印张。生成输出文档的多个副本，按整理后的顺序打印各页，即页 1，2，3，……，1，2，3 等。

    • SheetCollate = COLLATED，MultipleDocumentHandling = SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- 每个输入文档都保持为一个单独的输出文档。生成输出文档的多个副本（称它们为 A，B……），按整理后的顺序打印每个文档的各页，但这些文档本身却是按非整理顺序，即页 A1，A2，A3，……，A1，A2，A3，……，B1，B2，B3，……，B1，B2，B3 等。

    • SheetCollate = COLLATED, MultipleDocumentHandling = SEPARATE_DOCUMENTS_COLLATED_COPIES -- 每个输入文档都保持为一个单独的输出文档。生成输出文档的多个副本（称它们为 A，B……），按整理后的顺序打印每个文档的各页，这些文档本身也按整理顺序打印，即页 A1，A2，A3，……，B1，B2，B3，……，A1，A2，A3，……，B1，B2，B3 等。

    • SheetCollate = UNCOLLATED, MultipleDocumentHandling = SINGLE_DOCUMENT -- 所有的输入文档都将合并到一个输出文档中。生成输出文档的多个副本，按非整理顺序打印各页，即页 1，1，……，2，2，……，3，3 等。

    • SheetCollate = UNCOLLATED, MultipleDocumentHandling = SINGLE_DOCUMENT_NEW_SHEET -- 所有的输入文档都将合并到一个输出文档中，并且始终在新的介质纸张上开始每个输入文档的第一个印张。生成输出文档的多个副本，按非整理顺序打印各页，即页 1，1，……，2，2，……，3，3 等。

    • SheetCollate = UNCOLLATED, MultipleDocumentHandling = SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- 每个输入文档都保持为一个单独的输出文档。生成输出文档的多个副本（称它们为 A、B……），按非整理顺序打印每个文档的各页，这些文档本身也按非整理顺序打印，即页 A1，A1，……，A2，A2，……，A3，A3，……，B1，B1，……，B2，B2，……，B3，B3 等。

  • 如果为不同的文档指定了不同的纸张整理，则只允许使用 MultipleDocumentHandling 的一个值，并且在指定了其他任何值的情况下提交作业时，打印机都将报告一个错误：
    • MultipleDocumentHandling = SEPARATE_DOCUMENTS_UNCOLLATED_COPIES -- 每个输入文档都保持为一个单独的输出文档。生成输出文档的多个副本（称它们为 A，B……），按照相应输入文档的 SheetCollate 属性指定值以整理后或非整理顺序打印每个文档的各页，同时这些文档本身也按非整理顺序打印。如果文档 A 是 SheetCollate = UNCOLLATED，文档 B 是 SheetCollate = COLLATED，则将打印出以下页：A1，A1，……，A2，A2，……，A3，A3，……，B1，B2，B3，……，B1，B2，B3 等。

IPP 兼容性：SheetCollate 目前不是 IPP 属性。

另请参见：
MultipleDocumentHandling, 序列化表格

字段摘要
static SheetCollate | COLLATED 当打印多个副本时，文档中的纸张以整理后的顺序出现。
static SheetCollate | UNCOLLATED 当打印多个副本时，文档中的纸张以非整理顺序出现。
构造方法摘要
protected SheetCollate(int value)
构造具有给定整数值的新 SheetCollate 枚举值。
方法摘要
Class<? extends Attribute> | getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
protected EnumSyntax[] | getEnumValueTable() 返回类 SheetCollate 的枚举值表。
String | getName() 获取类别的名称，此属性值是该类别的一个实例。
protected String[] | getStringTable() 返回类 SheetCollate 的字符串表。
从类 javax.print.attribute.EnumSyntax 继承的方法
clone, getOffset, getValue, hashCode, readResolve, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

UNCOLLATED

public static final SheetCollate UNCOLLATED
当打印多个副本时，文档中的纸张以非整理顺序出现。

COLLATED

public static final SheetCollate COLLATED
当打印多个副本时，文档中的纸张以整理后的顺序出现。

构造方法详细信息

SheetCollate

protected SheetCollate(int value)
构造具有给定整数值的新 SheetCollate 枚举值。

参数：
value - 整数值。
方法详细信息

getStringTable

protected String[] getStringTable()
返回类 SheetCollate 的字符串表。

覆盖：
类 EnumSyntax 中的 getStringTable
返回：
字符串表

getEnumValueTable

protected EnumSyntax[] getEnumValueTable()
返回类 SheetCollate 的枚举值表。

覆盖：
类 EnumSyntax 中的 getEnumValueTable
返回：
值表

getCategory

public final Class<? extends Attribute> getCategory()
获取将用作此打印属性值的“类别”的打印属性类。

对于类 SheetCollate，该类别就是类 SheetCollate 本身。

指定者：
接口 Attribute 中的 getCategory
返回：
打印属性类（类别），这是类 java.lang.Class 的一个实例。

getName

public final String getName()
获取类别的名称，此属性值是该类别的一个实例。

对于类 SheetCollate，类别名称是 "sheet-collate"。

指定者：
接口 Attribute 中的 getName
返回：
属性类别名称。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


javax.print.attribute.standard (Java 2 Platform SE 6)

 javax.print.attribute.standard
类
Chromaticity
ColorSupported
Compression
Copies
CopiesSupported
DateTimeAtCompleted
DateTimeAtCreation
DateTimeAtProcessing
Destination
DocumentName
Fidelity
Finishings
JobHoldUntil
JobImpressions
JobImpressionsCompleted
JobImpressionsSupported
JobKOctets
JobKOctetsProcessed
JobKOctetsSupported
JobMediaSheets
JobMediaSheetsCompleted
JobMediaSheetsSupported
JobMessageFromOperator
JobName
JobOriginatingUserName
JobPriority
JobPrioritySupported
JobSheets
JobState
JobStateReason
JobStateReasons
Media
MediaName
MediaPrintableArea
MediaSize
MediaSize.Engineering
MediaSize.ISO
MediaSize.JIS
MediaSize.NA
MediaSize.Other
MediaSizeName
MediaTray
MultipleDocumentHandling
NumberOfDocuments
NumberOfInterveningJobs
NumberUp
NumberUpSupported
OrientationRequested
OutputDeviceAssigned
PageRanges
PagesPerMinute
PagesPerMinuteColor
PDLOverrideSupported
PresentationDirection
PrinterInfo
PrinterIsAcceptingJobs
PrinterLocation
PrinterMakeAndModel
PrinterMessageFromOperator
PrinterMoreInfo
PrinterMoreInfoManufacturer
PrinterName
PrinterResolution
PrinterState
PrinterStateReason
PrinterStateReasons
PrinterURI
PrintQuality
QueuedJobCount
ReferenceUriSchemesSupported
RequestingUserName
Severity
SheetCollate
Sides


javax.print.attribute.standard (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.print.attribute.standard

包 javax.print.attribute.standard 包括特定打印属性的类。

请参见：
描述

类摘要
Chromaticity | Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
ColorSupported | ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
Compression | Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
Copies | Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
CopiesSupported | CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
DateTimeAtCompleted | DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
DateTimeAtCreation | DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
DateTimeAtProcessing | DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
Destination | Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
DocumentName | DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
Fidelity | Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
Finishings | Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
JobHoldUntil | JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
JobImpressions | JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
JobImpressionsCompleted | JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
JobImpressionsSupported | JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
JobKOctets | JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
JobKOctetsProcessed | JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
JobKOctetsSupported | JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
JobMediaSheets | JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
JobMediaSheetsCompleted | JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
JobMediaSheetsSupported | Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
JobMessageFromOperator | JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
JobName | JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
JobOriginatingUserName | JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
JobPriority | JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
JobPrioritySupported | JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
JobSheets | JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
JobState | JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
JobStateReason | JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
JobStateReasons | JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
Media | Media 类是打印属性类，它指定了要在其上打印的介质。
MediaName | MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
MediaPrintableArea | MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
MediaSize | MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
MediaSize.Engineering | MediaSize.Engineering 类包括 engineering 介质的 MediaSize 值。
MediaSize.ISO | MediaSize.ISO 类包括 ISO 介质的 MediaSize 值。
MediaSize.JIS | MediaSize.JIS 类包括 JIS (Japanese) 介质的 MediaSize 值。
MediaSize.NA | MediaSize.NA 类包括 North American 介质的 MediaSize 值。
MediaSize.Other | MediaSize.Other 类包括其他介质的 MediaSize 值。
MediaSizeName | MediaSizeName 类是 Media 的子类。
MediaTray | MediaTray 类是 Media 的子类。
MultipleDocumentHandling | MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
NumberOfDocuments | NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
NumberOfInterveningJobs | NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
NumberUp | NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
NumberUpSupported | NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
OrientationRequested | OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
OutputDeviceAssigned | OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
PageRanges | PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
PagesPerMinute | PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
PagesPerMinuteColor | PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
PDLOverrideSupported | PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
PresentationDirection | PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
PrinterInfo | PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
PrinterIsAcceptingJobs | PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
PrinterLocation | PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
PrinterMakeAndModel | PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
PrinterMessageFromOperator | PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
PrinterMoreInfo | PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
PrinterMoreInfoManufacturer | PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
PrinterName | PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
PrinterResolution | PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
PrinterState | PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
PrinterStateReason | PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
PrinterStateReasons | PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
PrinterURI | PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
PrintQuality | PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
QueuedJobCount | QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。
ReferenceUriSchemesSupported | ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
RequestingUserName | RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
Severity | Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
SheetCollate | SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
Sides | Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

软件包 javax.print.attribute.standard 的描述

包 javax.print.attribute.standard 包括特定打印属性的类。父包 javax.print.attribute 提供了描述 Java Print Service 属性的类型以及如何分类这些属性的类和接口。

属性表示打印服务可以提供的打印功能。对于每种属性，打印服务要么支持该属性，要么不支持该属性。对于受支持属性的每个可能值，打印服务要么支持该值，要么不支持该值。

API 需要每种打印服务都支持某些属性；其他属性是可选的，并且服务可以选择是否支持它们。每种属性都有一组它可接受的值。API 需要每种打印服务都支持某些属性的某些值；其他属性值是可选的，并且服务可以选择是否支持它们。这些支持要求记录在每个属性类的文档中。

包 javax.print.attribute.standard 包含广泛应用于打印域的标准打印属性和标准打印属性值。除了标准打印属性，打印服务供应商还可以提供特定于供应商的新打印属性。供应商还可以提供标准打印属性的特定于供应商的扩展（子类） -- 例如，为现有的标准属性提供其他特定于供应商的值。当然，如果某个供应商希望客户端能够使用任何添加或扩展的属性，则该供应商必须公布新的属性类。

许多标准属性类都扩展了 javax.print.attribute 包的某个抽象语法类。这些抽象语法类分别表示不同的类型。例如，EnumSyntax 类表示类型安全的枚举。抽象语法类为属性值提供了包装器。

如果某个属性类扩展 EnumSyntax，并且该属性的值是 IPP 可兼容的值，则该属性的 toString 方法将返回属性值的 IPP 字符串表示形式，例如，JobState 属性的字符串表示形式 "processing-stopped"。不过，由于 EnumSyntax 类是可扩展的，所以供应商可以定义其自己的属性值。如果属性使用 EnumSyntax 类并且被设置为某个供应商定义的值，则 toString 方法将不会返回该值的 IPP 字符串表示形式。

打印客户端应用程序一般不需要使用包 javax.print.attribute.standard 中的全部打印属性类，只需要与该应用程序相关的那些打印属性类。

包 javax.print.attribute.standard 中的属性类基于发表于 2000 年 9 月的 RFC 文档 RFC 2911 Internet Printing Protocol/1.1:Model and Semantics 中定义的 Internet Printing Protocol (IPP) 属性。有关更多信息，请参阅 RFC 2911。各种属性类的描述性文本大部分摘自于上述文档。感谢上述作者对 API 所做的贡献。

属性组织

有以下五种打印属性：doc 属性、print request 属性、print job 属性、print service 属性和 supported-values 属性。

Doc 属性

Doc 属性指定了每个 doc 的特征和应用于每个 doc 的打印作业设置。doc 属性类实现了接口 DocAttribute。doc 属性可以出现在 DocAttributeSet 中。

Print Request 属性

Print request 属性指定了将应用于整个打印作业和打印作业中所有 doc 的设置。print request 属性类实现了接口 PrintRequestAttribute。print request 属性可以出现在 PrintRequestAttributeSet 中。

有些属性是 doc 属性，但却不是 print request 属性，并且只能在 doc 级指定。有些属性是 print request 属性，但却不是 doc 属性，并且只能在 Print Request 级指定。有些属性既是 doc 属性又是 print request 属性，并且可以在 doc 级或 Print Request 级指定。

当在 doc 级指定时，属性仅应用于该级中的一个 doc。当在 Print Request 级指定时，属性则应用于整个作业，其中包括该作业中的所有 doc。但是，在 doc 级指定的属性会覆盖在 Print Request 级指定的同一类别中的属性。

Print Job 属性

Print job 属性报告“打印作业”的状态。print job 属性类实现了接口 PrintJobAttribute。print job 属性可以出现在 PrintJobAttributeSet 中。

有些属性既是 print request 属性又是 print job 属性；客户端可以将这些属性包括在 Print Request 中以指定确定出现的 PrintJob 的特征，并且这些属性还可以出现在该 PrintJob 的属性集中。有些属性是 print job 属性，但却不是 print request 属性；打印服务本身可以将这些属性添加到 PrintJob 的属性集中。

Print Service 属性

Print service 属性报告打印服务的状态。print service 属性类实现了接口 PrintServiceAttribute。print service 属性可以出现在 PrintServiceAttributeSet 中。

Supported-Values 属性

supported-value 属性指示打印服务支持的另一个属性的合法值。supported-values 属性类实现了接口 SupportedValuesAttribute。但是 supported-values 属性从不会出现在属性集中，所以它们没有受限制的 AttributeSet 子接口。

属性表

下表列出了所有打印属性。该表显示了除接口 Attribute 之外每个属性类实现的标记接口，因此指示每种属性在 API 中的使用方式。对于每个 doc 属性和 print request 属性，标记为 "SupportedValuesAttribute" 的这一列列出了 supported-values 属性类（如果有），使用它打印服务可以指示该属性类别所支持的值。

属性类 | Doc 属性 | Print Request 属性 | Print Job 属性 | Print Service 属性 | SupportedValuesAttribute
Compression | X |  |  |  |
DocumentName | X |  |  |  |
Chromaticity | X | X | X |  |
Copies |  | X | X |  | CopiesSupported
Finishings | X | X | X |  |
JobHoldUntil |  | X | X |  |
JobImpressions |  | X | X |  | JobImpressionsSupported
JobKOctets |  | X | X |  | JobKOctetsSupported
JobMediaSheets |  | X | X |  | JobMediaSheetsSupported
JobName |  | X | X |  |
JobPriority |  | X | X |  | JobPrioritySupported
JobSheets |  | X | X |  |
Media | X | X | X |  |
MediaSize |  |  |  |  |
MultipleDocumentHandling |  | X | X |  |
NumberUp | X | X | X |  | NumberUpSupported
OrientationRequested | X | X | X |  |
PageRanges | X | X | X |  |
PresentationDirection | X | X | X |  |
PrinterResolution | X | X | X |  |
PrintQuality | X | X | X |  |
RequestingUserName |  | X | X |  |
SheetCollate | X | X | X |  |
Sides | X | X | X |  |
DateTimeAtCompleted |  |  | X |  |
DateTimeAtCreation |  |  | X |  |
DateTimeAtProcessing |  |  | X |  |
JobImpressionsCompleted |  |  | X |  |
JobKOctetsProcessed |  |  | X |  |
JobMediaSheetsCompleted |  |  | X |  |
JobMessageFromOperator |  |  | X |  |
JobOriginatingUserName |  |  | X |  |
JobState |  |  | X |  |
JobStateReasons 包含零个或更多 -- |  |  | X |  |
-- JobStateReason |  |  |  |  |
NumberOfDocuments |  |  | X |  |
NumberOfInterveningJobs |  |  | X |  |
OutputDeviceAssigned |  |  | X |  |
ColorSupported |  |  |  | X |
PagesPerMinute |  |  |  | X |
PagesPerMinuteColor |  |  |  | X |
PDLOverrideSupported |  |  |  | X |
PrinterIsAcceptingJobs |  |  |  | X |
PrinterInfo |  |  |  | X |
PrinterLocation |  |  |  | X |
PrinterMessageFromOperator |  |  |  | X |
PrinterMakeAndModel |  |  |  | X |
PrinterMoreInfo |  |  |  | X |
PrinterMoreInfoManufacturer |  |  |  | X |
PrinterName |  |  |  | X |
PrinterState |  |  |  | X |
PrinterStateReasons 包含零个或更多 -- |  |  |  | X |
-- PrinterStateReason |  |  |  |  |
-- Severity |  |  |  |  |
QueuedJobCount |  |  |  | X |
ReferenceUriSchemesSupported |  |  |  |  |

请注意：在 javax.print API 中，只有方法中显式地记录 null 引用具有有意义的解释时，方法的 null 引用参数才是正确的。否则使用 null 引用参数是错误的编码，并且可能会导致立即或稍后出现运行时异常。IllegalArgumentException 和 NullPointerException 是此类情形下典型和可接受的运行时异常示例。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.print.attribute.standard 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print.attribute.standard 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.AbstractCollection<E> (implements java.util.Collection<E>)
      • java.util.AbstractSet<E> (implements java.util.Set<E>)
        • java.util.HashSet<E> (implements java.lang.Cloneable, java.io.Serializable, java.util.Set<E>)
          • javax.print.attribute.standard.JobStateReasons (implements javax.print.attribute.PrintJobAttribute)
    • java.util.AbstractMap<K,V> (implements java.util.Map<K,V>)
      • java.util.HashMap<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • javax.print.attribute.standard.PrinterStateReasons (implements javax.print.attribute.PrintServiceAttribute)
    • javax.print.attribute.DateTimeSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DateTimeAtCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtCreation (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.DateTimeAtProcessing (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobHoldUntil (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.EnumSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Chromaticity (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ColorSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.Compression (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.Fidelity (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Finishings (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobState (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Media (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
        • javax.print.attribute.standard.MediaName (implements javax.print.attribute.Attribute)
        • javax.print.attribute.standard.MediaSizeName
        • javax.print.attribute.standard.MediaTray (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.MultipleDocumentHandling (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.OrientationRequested (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PDLOverrideSupported (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PresentationDirection (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterIsAcceptingJobs (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterState (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterStateReason (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.PrintQuality (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.ReferenceUriSchemesSupported (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.Severity (implements javax.print.attribute.Attribute)
      • javax.print.attribute.standard.SheetCollate (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.Sides (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.IntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Copies (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressions (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobImpressionsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobKOctets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobKOctetsProcessed (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobMediaSheets (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobMediaSheetsCompleted (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobPriority (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobPrioritySupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberOfDocuments (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberOfInterveningJobs (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.NumberUp (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PagesPerMinute (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PagesPerMinuteColor (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.QueuedJobCount (implements javax.print.attribute.PrintServiceAttribute)
    • javax.print.attribute.standard.MediaPrintableArea (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.standard.MediaSize.Engineering
    • javax.print.attribute.standard.MediaSize.ISO
    • javax.print.attribute.standard.MediaSize.JIS
    • javax.print.attribute.standard.MediaSize.NA
    • javax.print.attribute.standard.MediaSize.Other
    • javax.print.attribute.ResolutionSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.PrinterResolution (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.SetOfIntegerSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.CopiesSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobImpressionsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobKOctetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.JobMediaSheetsSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.NumberUpSupported (implements javax.print.attribute.SupportedValuesAttribute)
      • javax.print.attribute.standard.PageRanges (implements javax.print.attribute.DocAttribute, javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.Size2DSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.MediaSize (implements javax.print.attribute.Attribute)
    • javax.print.attribute.TextSyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.DocumentName (implements javax.print.attribute.DocAttribute)
      • javax.print.attribute.standard.JobMessageFromOperator (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.JobName (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.JobOriginatingUserName (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.OutputDeviceAssigned (implements javax.print.attribute.PrintJobAttribute)
      • javax.print.attribute.standard.PrinterInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterLocation (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMakeAndModel (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMessageFromOperator (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterName (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.RequestingUserName (implements javax.print.attribute.PrintRequestAttribute)
    • javax.print.attribute.URISyntax (implements java.lang.Cloneable, java.io.Serializable)
      • javax.print.attribute.standard.Destination (implements javax.print.attribute.PrintJobAttribute, javax.print.attribute.PrintRequestAttribute)
      • javax.print.attribute.standard.PrinterMoreInfo (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterMoreInfoManufacturer (implements javax.print.attribute.PrintServiceAttribute)
      • javax.print.attribute.standard.PrinterURI (implements javax.print.attribute.PrintServiceAttribute)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.print.attribute.standard 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print.attribute.standard
的使用

使用 javax.print.attribute.standard 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 使用的 javax.print.attribute.standard 中的类
Chromaticity
Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
ColorSupported
ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
Compression
Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
Fidelity
Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
Finishings
Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
JobSheets
JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
JobState
JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
JobStateReason
JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
Media
Media 类是打印属性类，它指定了要在其上打印的介质。
MediaName
MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
MediaSize
MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。
MediaSizeName
MediaSizeName 类是 Media 的子类。
MediaTray
MediaTray 类是 Media 的子类。
MultipleDocumentHandling
MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
OrientationRequested
OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
PDLOverrideSupported
PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
PresentationDirection
PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
PrinterIsAcceptingJobs
PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
PrinterState
PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
PrinterStateReason
PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
PrintQuality
PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
ReferenceUriSchemesSupported
ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
Severity
Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
SheetCollate
SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
Sides
Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Chromaticity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Chromaticity
的使用

使用 Chromaticity 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Chromaticity 的使用

声明为 Chromaticity 的 javax.print.attribute.standard 中的字段
static Chromaticity | Chromaticity.COLOR 彩色打印。
static Chromaticity | Chromaticity.MONOCHROME 单色打印。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.ColorSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.ColorSupported
的使用

使用 ColorSupported 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 ColorSupported 的使用

声明为 ColorSupported 的 javax.print.attribute.standard 中的字段
static ColorSupported | ColorSupported.NOT_SUPPORTED 该打印机不能进行任何类型的彩色打印。
static ColorSupported | ColorSupported.SUPPORTED 该打印机能够进行某些类型的彩色打印，例如高亮颜色或全处理颜色。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Compression 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Compression
的使用

使用 Compression 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Compression 的使用

声明为 Compression 的 javax.print.attribute.standard 中的字段
static Compression | Compression.COMPRESS UNIX 压缩技术。
static Compression | Compression.DEFLATE ZIP 公共域 inflate/deflate 压缩技术。
static Compression | Compression.GZIP RFC 1952 中所描述的 GNU zip 压缩技术。
static Compression | Compression.NONE 不使用压缩。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Copies 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Copies
的使用

没有 javax.print.attribute.standard.Copies 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.CopiesSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.CopiesSupported
的使用

没有 javax.print.attribute.standard.CopiesSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.DateTimeAtCompleted 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DateTimeAtCompleted
的使用

没有 javax.print.attribute.standard.DateTimeAtCompleted 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.DateTimeAtCreation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DateTimeAtCreation
的使用

没有 javax.print.attribute.standard.DateTimeAtCreation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.DateTimeAtProcessing 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DateTimeAtProcessing
的使用

没有 javax.print.attribute.standard.DateTimeAtProcessing 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Destination 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Destination
的使用

没有 javax.print.attribute.standard.Destination 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.DocumentName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.DocumentName
的使用

没有 javax.print.attribute.standard.DocumentName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Fidelity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Fidelity
的使用

使用 Fidelity 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Fidelity 的使用

声明为 Fidelity 的 javax.print.attribute.standard 中的字段
static Fidelity | Fidelity.FIDELITY_FALSE 打印机应对打印作业进行合理尝试，即使它不能完全按照指定的要求打印该作业。
static Fidelity | Fidelity.FIDELITY_TRUE 必须完全按照指定的要求打印作业，或者拒绝该作业。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Finishings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Finishings
的使用

使用 Finishings 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Finishings 的使用

声明为 Finishings 的 javax.print.attribute.standard 中的字段
static Finishings | Finishings.BIND 此值指示要将某个绑定应用于文档；绑定的类型和布局是由位置定义的。
static Finishings | Finishings.COVER 当需要为文档选择非打印（或预打印）封面时指定此值。
static Finishings | Finishings.EDGE_STITCH 将文档（或多个文档）与沿某个边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_BOTTOM 将文档（或多个文档）与沿底边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_LEFT 将文档（或多个文档）与沿左边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_RIGHT 将文档（或多个文档）与沿右边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.EDGE_STITCH_TOP 将文档（或多个文档）与沿顶边的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.NONE 不执行绑定。
static Finishings | Finishings.SADDLE_STITCH 将文档（或多个文档）与沿中折线的一个或多个装订点（金属针脚）绑定。
static Finishings | Finishings.STAPLE 将文档（或多个文档）与一个或多个装订点进行绑定。
static Finishings | Finishings.STAPLE_BOTTOM_LEFT 将文档（或多个文档）与左下角中的一个或多个装订点绑定。
static Finishings | Finishings.STAPLE_BOTTOM_RIGHT 将文档或多个文档与右下角中的一个或多个装订点绑定。
static Finishings | Finishings.STAPLE_DUAL_BOTTOM 将文档（或多个文档）与沿底边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_DUAL_LEFT 将文档（或多个文档）与沿左边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_DUAL_RIGHT 将文档（或多个文档）与沿右边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_DUAL_TOP 将文档（或多个文档）与沿顶边的两个装订点（金属针脚）绑定，假定该文档为纵向文档（参见上文）。
static Finishings | Finishings.STAPLE_TOP_LEFT 将文档（或多个文档）与左上角中的一个或多个装订点绑定。
static Finishings | Finishings.STAPLE_TOP_RIGHT 将文档或多个文档与右上角中的一个或多个装订点绑定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobHoldUntil 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobHoldUntil
的使用

没有 javax.print.attribute.standard.JobHoldUntil 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobImpressions 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobImpressions
的使用

没有 javax.print.attribute.standard.JobImpressions 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobImpressionsCompleted 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobImpressionsCompleted
的使用

没有 javax.print.attribute.standard.JobImpressionsCompleted 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobImpressionsSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobImpressionsSupported
的使用

没有 javax.print.attribute.standard.JobImpressionsSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobKOctets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobKOctets
的使用

没有 javax.print.attribute.standard.JobKOctets 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobKOctetsProcessed 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobKOctetsProcessed
的使用

没有 javax.print.attribute.standard.JobKOctetsProcessed 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobKOctetsSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobKOctetsSupported
的使用

没有 javax.print.attribute.standard.JobKOctetsSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobMediaSheets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMediaSheets
的使用

没有 javax.print.attribute.standard.JobMediaSheets 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobMediaSheetsCompleted 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMediaSheetsCompleted
的使用

没有 javax.print.attribute.standard.JobMediaSheetsCompleted 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobMediaSheetsSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMediaSheetsSupported
的使用

没有 javax.print.attribute.standard.JobMediaSheetsSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobMessageFromOperator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobMessageFromOperator
的使用

没有 javax.print.attribute.standard.JobMessageFromOperator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobName
的使用

没有 javax.print.attribute.standard.JobName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobOriginatingUserName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobOriginatingUserName
的使用

没有 javax.print.attribute.standard.JobOriginatingUserName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobPriority 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobPriority
的使用

没有 javax.print.attribute.standard.JobPriority 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobPrioritySupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobPrioritySupported
的使用

没有 javax.print.attribute.standard.JobPrioritySupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobSheets 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobSheets
的使用

使用 JobSheets 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 JobSheets 的使用

声明为 JobSheets 的 javax.print.attribute.standard 中的字段
static JobSheets | JobSheets.NONE 不打印作业页。
static JobSheets | JobSheets.STANDARD 打印一个或多个指定位置的标准作业页，例如，打印单张开始页，或者打印开始页和结束页。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobState 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobState
的使用

使用 JobState 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 JobState 的使用

声明为 JobState 的 javax.print.attribute.standard 中的字段
static JobState | JobState.ABORTED 作业已被系统中止（通常当作业处于 PROCESSING 或 PROCESSING_STOPPED 状态时），打印机已完成正在中止的作业，且所有作业状态属性已达到作业的最终值。
static JobState | JobState.CANCELED 作业已被人为操作取消，打印机已完成了正取消的作业，且所有作业状态属性已达到作业的最终值。
static JobState | JobState.COMPLETED 作业已成功完成，或以警告或错误结束，所有作业介质纸张已成功堆栈到适当的输出纸盒（或多个纸盒）中，且所有作业状态已达到作业的最终值。
static JobState | JobState.PENDING 作业为要开始处理的候选作业，但尚未开始处理。
static JobState | JobState.PENDING_HELD 由于某些原因，作业不是要处理的候选作业，但当这些原因不再存在时，作业将返回 PENDING 状态。
static JobState | JobState.PROCESSING 正在处理作业。
static JobState | JobState.PROCESSING_STOPPED 由于某些原因，正在处理时作业已停止，且当这些原因不再存在时，作业返回到 PROCESSING 状态。
static JobState | JobState.UNKNOWN 作业状态是未知的。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobStateReason 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobStateReason
的使用

使用 JobStateReason 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 JobStateReason 的使用

声明为 JobStateReason 的 javax.print.attribute.standard 中的字段
static JobStateReason | JobStateReason.ABORTED_BY_SYSTEM 系统中止了作业。
static JobStateReason | JobStateReason.COMPRESSION_ERROR 系统中止了作业，因为打印机在解压缩文档数据中遇到错误。
static JobStateReason | JobStateReason.DOCUMENT_ACCESS_ERROR 打印机不能访问由引用传递的一个或多个文档（即打印数据表示形式对象为 URL）。
static JobStateReason | JobStateReason.DOCUMENT_FORMAT_ERROR 系统中止了作业，因为打印机在处理文档数据时遇到错误。
static JobStateReason | JobStateReason.JOB_CANCELED_AT_DEVICE 非标识本地用户取消了作业，即在设备控制台的用户取消了作业。
static JobStateReason | JobStateReason.JOB_CANCELED_BY_OPERATOR 操作员取消了作业，操作员即用户，其已被授权为具有操作员权限（无论是本地还是远程）。
static JobStateReason | JobStateReason.JOB_CANCELED_BY_USER 作业所有者取消了作业，作业所有者即用户，通过验证的该用户身份与创建 Print Job 的初始用户的值相同，或某位其他授权终端用户，例如作业所有者安全组成员。
static JobStateReason | JobStateReason.JOB_COMPLETED_SUCCESSFULLY 作业成功完成。
static JobStateReason | JobStateReason.JOB_COMPLETED_WITH_ERRORS 作业以错误结束（也可能是警告）。
static JobStateReason | JobStateReason.JOB_COMPLETED_WITH_WARNINGS 作业以警告结束。
static JobStateReason | JobStateReason.JOB_DATA_INSUFFICIENT 打印机已创建 Print Job，但打印机在可以将作业转为 PROCESSING 状态之前还需要额外的打印数据。
static JobStateReason | JobStateReason.JOB_HOLD_UNTIL_SPECIFIED 为作业的 JobHoldUntil 属性值指定一个将来的日期-时间。
static JobStateReason | JobStateReason.JOB_INCOMING 打印机已创建 Print Job，但打印机尚未完成访问或接收所有打印数据。
static JobStateReason | JobStateReason.JOB_INTERPRETING 作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据。
static JobStateReason | JobStateReason.JOB_OUTGOING 打印机正将作业传输到输出设备。
static JobStateReason | JobStateReason.JOB_PRINTING 输出设备为标记介质。
static JobStateReason | JobStateReason.JOB_QUEUED 打印机处于 PROCESSING 状态，更明确地讲，打印机已对文档数据排队。
static JobStateReason | JobStateReason.JOB_QUEUED_FOR_MARKER 打印机处于 PENDING_HELD、PENDING 或 PROCESSING 状态，更明确地讲，打印机已完成足够的文档处理，能够开始标记且作业正在等待标记。
static JobStateReason | JobStateReason.JOB_RESTARTABLE 此作业被保留，且当前可以重新开始。
static JobStateReason | JobStateReason.JOB_TRANSFORMING 作业处于 PROCESSING 状态，更明确地讲，打印机正解释文档数据并生成另一个电子表示形式。
static JobStateReason | JobStateReason.PRINTER_STOPPED 打印机的 PrinterState 属性值为 STOPPED。
static JobStateReason | JobStateReason.PRINTER_STOPPED_PARTLY 打印机的 PrinterStateReasons 属性值包含 STOPPED_PARTLY 的 PrinterStateReason 值。
static JobStateReason | JobStateReason.PROCESSING_TO_STOP_POINT 请求者已取消作业，或打印机已中止作业，但打印机仍在执行该作业的某些操作，直到遇到指定的停止点，或已完成作业终止/清除操作。
static JobStateReason | JobStateReason.QUEUED_IN_DEVICE 作业已被转发到某个不能发送回状态的设备或打印系统。
static JobStateReason | JobStateReason.RESOURCES_ARE_NOT_READY 在候选作业的任何物理打印机上，至少有一个该作业所需的资源（例如介质、字体、资源对象等）未就绪。
static JobStateReason | JobStateReason.SERVICE_OFF_LINE 打印机离线，不接受作业。
static JobStateReason | JobStateReason.SUBMISSION_INTERRUPTED 由于某些不可预见的原因，作业未完成提交。
static JobStateReason | JobStateReason.UNSUPPORTED_COMPRESSION 系统取消了作业，这是因为打印机尝试解压缩文档数据时确定该压缩实际上不在打印机所支持的文档数据中。
static JobStateReason | JobStateReason.UNSUPPORTED_DOCUMENT_FORMAT 系统中止了作业，因为文档数据的文档格式（doc flavor）不在打印机所支持的格式中。

参数类型为 JobStateReason 的 javax.print.attribute.standard 中的方法
 boolean JobStateReasons.add(JobStateReason o)
将指定的元素添加到此作业状态原因属性（如果它尚未存在）。

类型变量类型为 JobStateReason 的 javax.print.attribute.standard 中的构造方法参数
JobStateReasons(Collection<JobStateReason> collection)
构造新的作业状态原因属性，它包含与给定集合相同的 JobStateReason 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.JobStateReasons 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.JobStateReasons
的使用

没有 javax.print.attribute.standard.JobStateReasons 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Media 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Media
的使用

使用 Media 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Media 的使用

javax.print.attribute.standard 中 Media 的子类
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Sides 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Sides
的使用

使用 Sides 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Sides 的使用

声明为 Sides 的 javax.print.attribute.standard 中的字段
static Sides | Sides.DUPLEX “双面长边”的别名（请参阅 TWO_SIDED_LONG_EDGE）。
static Sides | Sides.ONE_SIDED 将每个连续的打印流页应用于连续介质纸张的相同面。
static Sides | Sides.TUMBLE “双面短边”的别名（请参阅 TWO_SIDED_SHORT_EDGE）。
static Sides | Sides.TWO_SIDED_LONG_EDGE 将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在长边上一样。
static Sides | Sides.TWO_SIDED_SHORT_EDGE 将每个连续的打印流页对应用于连续介质纸张的前后两面，以便介质上的每个打印流页对方向正对着读者，就好像绑定在短边上一样。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaName
的使用

使用 MediaName 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaName 的使用

声明为 MediaName 的 javax.print.attribute.standard 中的字段
static MediaName | MediaName.ISO_A4_TRANSPARENT A4 纸透明度。
static MediaName | MediaName.ISO_A4_WHITE 空白 A4 纸。
static MediaName | MediaName.NA_LETTER_TRANSPARENT 信纸透明度。
static MediaName | MediaName.NA_LETTER_WHITE 空白信纸。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaPrintableArea 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaPrintableArea
的使用

没有 javax.print.attribute.standard.MediaPrintableArea 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaSize 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize
的使用

使用 MediaSize 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaSize 的使用

声明为 MediaSize 的 javax.print.attribute.standard 中的字段
static MediaSize | MediaSize.Engineering.A 指定 engineering A 尺寸，8.5 inch × 11 inch。
static MediaSize | MediaSize.ISO.A0 指定 ISO A0 尺寸，841 mm × 1189 mm。
static MediaSize | MediaSize.ISO.A1 指定 ISO A1 尺寸，594 mm × 841 mm。
static MediaSize | MediaSize.ISO.A10 指定 ISO A10 尺寸，26 mm × 37 mm。
static MediaSize | MediaSize.ISO.A2 指定 ISO A2 尺寸，420 mm × 594 mm。
static MediaSize | MediaSize.ISO.A3 指定 ISO A3 尺寸，297 mm × 420 mm。
static MediaSize | MediaSize.ISO.A4 指定 ISO A4 尺寸，210 × by 297 mm。
static MediaSize | MediaSize.ISO.A5 指定 ISO A5 尺寸，148 mm × 210 mm。
static MediaSize | MediaSize.ISO.A6 指定 ISO A6 尺寸，105 mm × 148 mm。
static MediaSize | MediaSize.ISO.A7 指定 ISO A7 尺寸，74 mm × 105 mm。
static MediaSize | MediaSize.ISO.A8 指定 ISO A8 尺寸，52 mm × 74 mm。
static MediaSize | MediaSize.ISO.A9 指定 ISO A9 尺寸，37 mm × 52 mm。
static MediaSize | MediaSize.Engineering.B 指定 engineering B 尺寸，11 inch × 17 inch。
static MediaSize | MediaSize.ISO.B0 指定 ISO B0 尺寸，1000 mm × 1414 mm。
static MediaSize | MediaSize.JIS.B0 指定 JIS B0 尺寸，1030 mm × 1456 mm。
static MediaSize | MediaSize.ISO.B1 指定 ISO B1 尺寸，707 mm × 1000 mm。
static MediaSize | MediaSize.JIS.B1 指定 JIS B1 尺寸，728 mm × 1030 mm。
static MediaSize | MediaSize.ISO.B10 指定 ISO B10 尺寸，31 mm × 44 mm。
static MediaSize | MediaSize.JIS.B10 指定 JIS B10 尺寸，32 mm × 45 mm。
static MediaSize | MediaSize.ISO.B2 指定 ISO B2 尺寸，500 mm × 707 mm。
static MediaSize | MediaSize.JIS.B2 指定 JIS B2 尺寸，515 mm × 728 mm。
static MediaSize | MediaSize.ISO.B3 指定 ISO B3 尺寸，353 mm × 500 mm。
static MediaSize | MediaSize.JIS.B3 指定 JIS B3 尺寸，364 mm × 515 mm。
static MediaSize | MediaSize.ISO.B4 指定 ISO B4 尺寸，250 mm × 353 mm。
static MediaSize | MediaSize.JIS.B4 指定 JIS B4 尺寸，257 mm × 364 mm。
static MediaSize | MediaSize.ISO.B5 指定 ISO B5 尺寸，176 mm × 250 mm。
static MediaSize | MediaSize.JIS.B5 指定 JIS B5 尺寸，182 mm × 257 mm。
static MediaSize | MediaSize.ISO.B6 指定 ISO B6 尺寸，125 mm × 176 mm。
static MediaSize | MediaSize.JIS.B6 指定 JIS B6 尺寸，128 mm × 182 mm。
static MediaSize | MediaSize.ISO.B7 指定 ISO B7 尺寸，88 mm × 125 mm。
static MediaSize | MediaSize.JIS.B7 指定 JIS B7 尺寸，91 mm × 128 mm。
static MediaSize | MediaSize.ISO.B8 指定 ISO B8 尺寸，62 mm × 88 mm。
static MediaSize | MediaSize.JIS.B8 指定 JIS B8 尺寸，64 mm × 91 mm。
static MediaSize | MediaSize.ISO.B9 指定 ISO B9 尺寸，44 mm × 62 mm。
static MediaSize | MediaSize.JIS.B9 指定 JIS B9 尺寸，45 mm × 64 mm。
static MediaSize | MediaSize.Engineering.C 指定 engineering C 尺寸，17 inch × 22 inch。
static MediaSize | MediaSize.ISO.C3 指定 ISO C3 尺寸，324 mm × 458 mm。
static MediaSize | MediaSize.ISO.C4 指定 ISO C4 尺寸，229 mm × 324 mm。
static MediaSize | MediaSize.ISO.C5 指定 ISO C5 尺寸，162 mm × 229 mm。
static MediaSize | MediaSize.ISO.C6 指定 ISO C6 尺寸，114 mm × 162 mm。
static MediaSize | MediaSize.JIS.CHOU_1 指定 JIS Chou ("long") #1 信封尺寸，142 mm × 332 mm。
static MediaSize | MediaSize.JIS.CHOU_2 指定 JIS Chou ("long") #2 信封尺寸，119 mm × 277 mm。
static MediaSize | MediaSize.JIS.CHOU_3 指定 JIS Chou ("long") #3 信封尺寸，120 mm by 235 mm。
static MediaSize | MediaSize.JIS.CHOU_30 指定 JIS Chou ("long") #30 信封尺寸，92 mm by 235 mm。
static MediaSize | MediaSize.JIS.CHOU_4 指定 JIS Chou ("long") #4 信封尺寸，90 mm × 205 mm。
static MediaSize | MediaSize.JIS.CHOU_40 指定 JIS Chou ("long") #40 信封尺寸，90 mm × 225 mm。
static MediaSize | MediaSize.Engineering.D 指定 engineering D 尺寸，22 inch × 34 inch。
static MediaSize | MediaSize.ISO.DESIGNATED_LONG 指定 ISO Designated Long 尺寸，110 mm × 220 mm。
static MediaSize | MediaSize.Engineering.E 指定 engineering E 尺寸，34 inch × 44 inch。
static MediaSize | MediaSize.Other.EXECUTIVE 指定 executive 尺寸，7.25 inch × 10.5 inch。
static MediaSize | MediaSize.Other.FOLIO 指定 folio 尺寸，8.5 inch × 13 inch。
static MediaSize | MediaSize.Other.INVOICE 指定 invoice 尺寸，5.5 inch × 8.5 inch。
static MediaSize | MediaSize.Other.ITALY_ENVELOPE 指定 Italy 信封尺寸，110 mm × 230 mm。
static MediaSize | MediaSize.Other.JAPANESE_DOUBLE_POSTCARD 指定 Japanese Double 明信片尺寸，148 mm × 200 mm。
static MediaSize | MediaSize.Other.JAPANESE_POSTCARD 指定 Japanese 明信片尺寸，100 mm × 148 mm。
static MediaSize | MediaSize.JIS.KAKU_0 指定 JIS Kaku ("square") #0 信封尺寸，287 mm × 382 mm。
static MediaSize | MediaSize.JIS.KAKU_1 指定 JIS Kaku ("square") #1 信封尺寸，270 mm × 382 mm。
static MediaSize | MediaSize.JIS.KAKU_2 指定 JIS Kaku ("square") #2 信封尺寸，240 mm × 332 mm。
static MediaSize | MediaSize.JIS.KAKU_20 指定 JIS Kaku ("square") #20 信封尺寸，229 mm × 324 mm。
static MediaSize | MediaSize.JIS.KAKU_3 指定 JIS Kaku ("square") #3 信封尺寸，216 mm × 277 mm。
static MediaSize | MediaSize.JIS.KAKU_4 指定 JIS Kaku ("square") #4 信封尺寸，197 mm × 267 mm。
static MediaSize | MediaSize.JIS.KAKU_5 指定 JIS Kaku ("square") #5 信封尺寸，190 mm by 240 mm。
static MediaSize | MediaSize.JIS.KAKU_6 指定 JIS Kaku ("square") #6 信封尺寸，162 mm × 229 mm。
static MediaSize | MediaSize.JIS.KAKU_7 指定 JIS Kaku ("square") #7 信封尺寸，142 mm × 205 mm。
static MediaSize | MediaSize.JIS.KAKU_8 指定 JIS Kaku ("square") #8 信封尺寸，119 mm × 197 mm。
static MediaSize | MediaSize.JIS.KAKU_A4 指定 JIS Kaku ("square") A4 信封尺寸，228 mm × 312 mm。
static MediaSize | MediaSize.Other.LEDGER 指定 ledger 尺寸，11 inch × 17 inch。
static MediaSize | MediaSize.NA.LEGAL 指定 North American 合法尺寸，8.5 inch × 14 inch。
static MediaSize | MediaSize.NA.LETTER 指定 North American 信纸尺寸，8.5 inch × 11 inch。
static MediaSize | MediaSize.Other.MONARCH_ENVELOPE 指定 Monarch 信封尺寸，3.87 inch × 7.5 inch。
static MediaSize | MediaSize.NA.NA_10x13_ENVELOPE 指定 North American 10 inch × 13 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_10x14_ENVELOPE 指定 North American 10 inch × 14 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_10X15_ENVELOPE 指定 North American 10 inch × 15 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_5X7 指定 North American 5 inch × 7 inch 纸。
static MediaSize | MediaSize.NA.NA_6X9_ENVELOPE 指定 North American 6 inch × 9 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_7X9_ENVELOPE 指定 North American 7 inch × 9 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_8X10 指定 North American 8 inch × 10 inch 纸。
static MediaSize | MediaSize.NA.NA_9x11_ENVELOPE 指定 North American 9 inch × 11 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_9x12_ENVELOPE 指定 North American 9 inch × 12 inch 信封尺寸。
static MediaSize | MediaSize.NA.NA_NUMBER_10_ENVELOPE 指定 North American Number 10 商用信封尺寸，4.125 inch × 9.5 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_11_ENVELOPE 指定 North American Number 11 商用信封尺寸，4.5 inch × 10.375 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_12_ENVELOPE 指定 North American Number 12 商用信封尺寸，4.75 inch × 11 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_14_ENVELOPE 指定 North American Number 14 商用信封尺寸，5 inch × 11.5 inch。
static MediaSize | MediaSize.NA.NA_NUMBER_9_ENVELOPE 指定 North American Number 9 商用信封尺寸，3.875 inch × 8.875 inch。
static MediaSize | MediaSize.Other.PERSONAL_ENVELOPE 指定 Personal 信封尺寸，3.625 inch × 6.5 inch。
static MediaSize | MediaSize.Other.QUARTO 指定 quarto 尺寸，8.5 inch × 10.83 inch。
static MediaSize | MediaSize.Other.TABLOID 指定 tabloid 尺寸，11 inch × 17 inch。
static MediaSize | MediaSize.JIS.YOU_1 指定 JIS You ("Western") #1 信封尺寸，120 mm × 176 mm。
static MediaSize | MediaSize.JIS.YOU_2 指定 JIS You ("Western") #2 信封尺寸，114 mm × 162 mm。
static MediaSize | MediaSize.JIS.YOU_3 指定 JIS You ("Western") #3 信封尺寸，98 mm × 148 mm。
static MediaSize | MediaSize.JIS.YOU_4 指定 JIS You ("Western") #4 信封尺寸，105 mm × 235 mm。
static MediaSize | MediaSize.JIS.YOU_5 指定 JIS You ("Western") #5 信封尺寸，95 mm × 217 mm。
static MediaSize | MediaSize.JIS.YOU_6 指定 JIS You ("Western") #6 信封尺寸，98 mm × 190 mm。
static MediaSize | MediaSize.JIS.YOU_7 指定 JIS You ("Western") #7 信封尺寸，92 mm × 165 mm。

返回 MediaSize 的 javax.print.attribute.standard 中的方法
static MediaSize MediaSize.getMediaSizeForName(MediaSizeName media)
获取指定的命名介质的 MediaSize。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaSize.ISO 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.ISO
的使用

没有 javax.print.attribute.standard.MediaSize.ISO 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaSize.JIS 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.JIS
的使用

没有 javax.print.attribute.standard.MediaSize.JIS 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaSize.NA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.NA
的使用

没有 javax.print.attribute.standard.MediaSize.NA 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaSize.Engineering 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.Engineering
的使用

没有 javax.print.attribute.standard.MediaSize.Engineering 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaSize.Other 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSize.Other
的使用

没有 javax.print.attribute.standard.MediaSize.Other 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaSizeName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaSizeName
的使用

使用 MediaSizeName 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaSizeName 的使用

声明为 MediaSizeName 的 javax.print.attribute.standard 中的字段
static MediaSizeName | MediaSizeName.A A 尺寸。
static MediaSizeName | MediaSizeName.B B 尺寸。
static MediaSizeName | MediaSizeName.C C 尺寸。
static MediaSizeName | MediaSizeName.D D 尺寸。
static MediaSizeName | MediaSizeName.E E 尺寸。
static MediaSizeName | MediaSizeName.EXECUTIVE executive 尺寸。
static MediaSizeName | MediaSizeName.FOLIO folio 尺寸。
static MediaSizeName | MediaSizeName.INVOICE invoice 尺寸。
static MediaSizeName | MediaSizeName.ISO_A0 A0 尺寸。
static MediaSizeName | MediaSizeName.ISO_A1 A1 尺寸。
static MediaSizeName | MediaSizeName.ISO_A10 A10 尺寸。
static MediaSizeName | MediaSizeName.ISO_A2 A2 尺寸。
static MediaSizeName | MediaSizeName.ISO_A3 A3 尺寸。
static MediaSizeName | MediaSizeName.ISO_A4 A4 尺寸。
static MediaSizeName | MediaSizeName.ISO_A5 A5 尺寸。
static MediaSizeName | MediaSizeName.ISO_A6 A6 尺寸。
static MediaSizeName | MediaSizeName.ISO_A7 A7 尺寸。
static MediaSizeName | MediaSizeName.ISO_A8 A8 尺寸。
static MediaSizeName | MediaSizeName.ISO_A9 A9 尺寸。
static MediaSizeName | MediaSizeName.ISO_B0 ISO B0 尺寸。
static MediaSizeName | MediaSizeName.ISO_B1 ISO B1 尺寸。
static MediaSizeName | MediaSizeName.ISO_B10 ISO B10 尺寸。
static MediaSizeName | MediaSizeName.ISO_B2 ISO B2 尺寸。
static MediaSizeName | MediaSizeName.ISO_B3 ISO B3 尺寸。
static MediaSizeName | MediaSizeName.ISO_B4 ISO B4 尺寸。
static MediaSizeName | MediaSizeName.ISO_B5 ISO B5 尺寸。
static MediaSizeName | MediaSizeName.ISO_B6 ISO B6 尺寸。
static MediaSizeName | MediaSizeName.ISO_B7 ISO B7 尺寸。
static MediaSizeName | MediaSizeName.ISO_B8 ISO B8 尺寸。
static MediaSizeName | MediaSizeName.ISO_B9 ISO B9 尺寸。
static MediaSizeName | MediaSizeName.ISO_C0 ISO C0 尺寸。
static MediaSizeName | MediaSizeName.ISO_C1 ISO C1 尺寸。
static MediaSizeName | MediaSizeName.ISO_C2 ISO C2 尺寸。
static MediaSizeName | MediaSizeName.ISO_C3 ISO C3 尺寸。
static MediaSizeName | MediaSizeName.ISO_C4 ISO C4 尺寸。
static MediaSizeName | MediaSizeName.ISO_C5 ISO C5 尺寸。
static MediaSizeName | MediaSizeName.ISO_C6 信纸尺寸。
static MediaSizeName | MediaSizeName.ISO_DESIGNATED_LONG ISO designated long 尺寸。
static MediaSizeName | MediaSizeName.ITALY_ENVELOPE Italy 信封尺寸。
static MediaSizeName | MediaSizeName.JAPANESE_DOUBLE_POSTCARD Japanese Double Postcard 尺寸。
static MediaSizeName | MediaSizeName.JAPANESE_POSTCARD Japanese Postcard 尺寸。
static MediaSizeName | MediaSizeName.JIS_B0 JIS B0 尺寸。
static MediaSizeName | MediaSizeName.JIS_B1 JIS B1 尺寸。
static MediaSizeName | MediaSizeName.JIS_B10 JIS B10 尺寸。
static MediaSizeName | MediaSizeName.JIS_B2 JIS B2 尺寸。
static MediaSizeName | MediaSizeName.JIS_B3 JIS B3 尺寸。
static MediaSizeName | MediaSizeName.JIS_B4 JIS B4 尺寸。
static MediaSizeName | MediaSizeName.JIS_B5 JIS B5 尺寸。
static MediaSizeName | MediaSizeName.JIS_B6 JIS B6 尺寸。
static MediaSizeName | MediaSizeName.JIS_B7 JIS B7 尺寸。
static MediaSizeName | MediaSizeName.JIS_B8 JIS B8 尺寸。
static MediaSizeName | MediaSizeName.JIS_B9 JIS B9 尺寸。
static MediaSizeName | MediaSizeName.LEDGER ledger 尺寸。
static MediaSizeName | MediaSizeName.MONARCH_ENVELOPE monarch 信封尺寸。
static MediaSizeName | MediaSizeName.NA_10X13_ENVELOPE 10x13 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_10X14_ENVELOPE 10x14North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_10X15_ENVELOPE 10x15 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_5X7 5x7 North American 纸。
static MediaSizeName | MediaSizeName.NA_6X9_ENVELOPE 6x9 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_7X9_ENVELOPE 7x9 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_8X10 8x10 North American 纸。
static MediaSizeName | MediaSizeName.NA_9X11_ENVELOPE 9x11 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_9X12_ENVELOPE 9x12 North American 信封尺寸。
static MediaSizeName | MediaSizeName.NA_LEGAL legal 尺寸。
static MediaSizeName | MediaSizeName.NA_LETTER 信纸尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_10_ENVELOPE 10 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_11_ENVELOPE 11 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_12_ENVELOPE 12 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_14_ENVELOPE 14 号信封尺寸。
static MediaSizeName | MediaSizeName.NA_NUMBER_9_ENVELOPE 9 号信封尺寸。
static MediaSizeName | MediaSizeName.PERSONAL_ENVELOPE 私人信封尺寸。
static MediaSizeName | MediaSizeName.QUARTO quarto 尺寸。
static MediaSizeName | MediaSizeName.TABLOID tabloid 尺寸。

返回 MediaSizeName 的 javax.print.attribute.standard 中的方法
static MediaSizeName | MediaSize.findMedia(float x, float y, int units) 指定的维度用于从所有标准 MediaSize 实例中定位一个匹配的 MediaSize 实例。
MediaSizeName | MediaSize.getMediaSizeName() 获取此尺寸的介质名称（如果有）。

参数类型为 MediaSizeName 的 javax.print.attribute.standard 中的方法
static MediaSize MediaSize.getMediaSizeForName(MediaSizeName media)
获取指定的命名介质的 MediaSize。

参数类型为 MediaSizeName 的 javax.print.attribute.standard 中的构造方法
MediaSize(float x, float y, int units, MediaSizeName media)
从给定浮点值构造新 MediaSize 属性。
MediaSize(int x, int y, int units, MediaSizeName media)
从给定整数值构造新 MediaSize 属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MediaTray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MediaTray
的使用

使用 MediaTray 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MediaTray 的使用

声明为 MediaTray 的 javax.print.attribute.standard 中的字段
static MediaTray | MediaTray.BOTTOM 打印机中的底层进纸托盘。
static MediaTray | MediaTray.ENVELOPE 打印机中的信封进纸托盘。
static MediaTray | MediaTray.LARGE_CAPACITY 打印机中的大容量进纸托盘。
static MediaTray | MediaTray.MAIN 打印机中的主要进纸托盘。
static MediaTray | MediaTray.MANUAL 打印机中的手动进纸托盘。
static MediaTray | MediaTray.MIDDLE 打印机中的中层进纸托盘。
static MediaTray | MediaTray.SIDE 侧面进纸托盘。
static MediaTray | MediaTray.TOP 打印机中的顶层进纸托盘。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.MultipleDocumentHandling 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.MultipleDocumentHandling
的使用

使用 MultipleDocumentHandling 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 MultipleDocumentHandling 的使用

声明为 MultipleDocumentHandling 的 javax.print.attribute.standard 中的字段
static MultipleDocumentHandling | MultipleDocumentHandling.SEPARATE_DOCUMENTS_COLLATED_COPIES 独立文档逐份打印副本 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | MultipleDocumentHandling.SEPARATE_DOCUMENTS_UNCOLLATED_COPIES 独立文档非逐份打印副本 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | MultipleDocumentHandling.SINGLE_DOCUMENT 单个文档 －－ 有关更多信息，请参见上文。
static MultipleDocumentHandling | MultipleDocumentHandling.SINGLE_DOCUMENT_NEW_SHEET 单个文档新纸张 －－ 有关更多信息，请参见上文。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.NumberOfDocuments 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberOfDocuments
的使用

没有 javax.print.attribute.standard.NumberOfDocuments 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.NumberOfInterveningJobs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberOfInterveningJobs
的使用

没有 javax.print.attribute.standard.NumberOfInterveningJobs 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.NumberUp 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberUp
的使用

没有 javax.print.attribute.standard.NumberUp 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.NumberUpSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.NumberUpSupported
的使用

没有 javax.print.attribute.standard.NumberUpSupported 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.OrientationRequested 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.OrientationRequested
的使用

使用 OrientationRequested 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 OrientationRequested 的使用

声明为 OrientationRequested 的 javax.print.attribute.standard 中的字段
static OrientationRequested | OrientationRequested.LANDSCAPE 沿介质的长边描绘内容。
static OrientationRequested | OrientationRequested.PORTRAIT 沿介质的短边描绘内容。
static OrientationRequested | OrientationRequested.REVERSE_LANDSCAPE 沿介质的长边描绘内容，但方式正好与横向相反。
static OrientationRequested | OrientationRequested.REVERSE_PORTRAIT 沿介质的短边描绘内容，但方式正好与纵向相反。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PageRanges 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PageRanges
的使用

没有 javax.print.attribute.standard.PageRanges 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.OutputDeviceAssigned 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.OutputDeviceAssigned
的使用

没有 javax.print.attribute.standard.OutputDeviceAssigned 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PDLOverrideSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PDLOverrideSupported
的使用

使用 PDLOverrideSupported 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PDLOverrideSupported 的使用

声明为 PDLOverrideSupported 的 javax.print.attribute.standard 中的字段
static PDLOverrideSupported | PDLOverrideSupported.ATTEMPTED 打印机会尝试让外部作业属性值优先于嵌入到文档打印数据中的指令，但是不保证确实会如此。
static PDLOverrideSupported | PDLOverrideSupported.NOT_ATTEMPTED 打印机不会尝试让外部的作业属性值优先于嵌入到文档打印数据中的指令。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PagesPerMinute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PagesPerMinute
的使用

没有 javax.print.attribute.standard.PagesPerMinute 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PagesPerMinuteColor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PagesPerMinuteColor
的使用

没有 javax.print.attribute.standard.PagesPerMinuteColor 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PresentationDirection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PresentationDirection
的使用

使用 PresentationDirection 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PresentationDirection 的使用

声明为 PresentationDirection 的 javax.print.attribute.standard 中的字段
static PresentationDirection | PresentationDirection.TOBOTTOM_TOLEFT 从右上开始，按列布置各页，然后向左下部展开。
static PresentationDirection | PresentationDirection.TOBOTTOM_TORIGHT 从左上开始，按列布置各页，然后向右下部展开。
static PresentationDirection | PresentationDirection.TOLEFT_TOBOTTOM 从右上部开始，按行布置各页，然后向左下部展开。
static PresentationDirection | PresentationDirection.TOLEFT_TOTOP 从右下部开始，按行布置各页，然后向左上部展开。
static PresentationDirection | PresentationDirection.TORIGHT_TOBOTTOM 从左上部开始，按行布置各页，然后向右下部展开。
static PresentationDirection | PresentationDirection.TORIGHT_TOTOP 从左下部开始，按行布置各页，然后向右上部展开。
static PresentationDirection | PresentationDirection.TOTOP_TOLEFT 从右下部开始，按列布置各页，然后向左上部展开。
static PresentationDirection | PresentationDirection.TOTOP_TORIGHT 从左下部开始，按列布置各页，然后向右上部展开。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrintQuality 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrintQuality
的使用

使用 PrintQuality 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrintQuality 的使用

声明为 PrintQuality 的 javax.print.attribute.standard 中的字段
static PrintQuality | PrintQuality.DRAFT 打印机可提供的最低打印质量。
static PrintQuality | PrintQuality.HIGH 打印机可提供的最高打印质量。
static PrintQuality | PrintQuality.NORMAL 打印机上的正常或中等质量。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterInfo
的使用

没有 javax.print.attribute.standard.PrinterInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterIsAcceptingJobs 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterIsAcceptingJobs
的使用

使用 PrinterIsAcceptingJobs 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrinterIsAcceptingJobs 的使用

声明为 PrinterIsAcceptingJobs 的 javax.print.attribute.standard 中的字段
static PrinterIsAcceptingJobs | PrinterIsAcceptingJobs.ACCEPTING_JOBS 打印机当前接受作业。
static PrinterIsAcceptingJobs | PrinterIsAcceptingJobs.NOT_ACCEPTING_JOBS 打印机当前拒绝发送给它的任何作业。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterLocation 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterLocation
的使用

没有 javax.print.attribute.standard.PrinterLocation 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterMakeAndModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMakeAndModel
的使用

没有 javax.print.attribute.standard.PrinterMakeAndModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterMessageFromOperator 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMessageFromOperator
的使用

没有 javax.print.attribute.standard.PrinterMessageFromOperator 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterMoreInfo 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMoreInfo
的使用

没有 javax.print.attribute.standard.PrinterMoreInfo 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterMoreInfoManufacturer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterMoreInfoManufacturer
的使用

没有 javax.print.attribute.standard.PrinterMoreInfoManufacturer 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterName
的使用

没有 javax.print.attribute.standard.PrinterName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterResolution 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterResolution
的使用

没有 javax.print.attribute.standard.PrinterResolution 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterState 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterState
的使用

使用 PrinterState 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrinterState 的使用

声明为 PrinterState 的 javax.print.attribute.standard 中的字段
static PrinterState | PrinterState.IDLE 指示可以开始处理新作业，无需等待。
static PrinterState | PrinterState.PROCESSING 指示正在处理作业；处理完成前新作业需等待。
static PrinterState | PrinterState.STOPPED 指示没有作业可以处理，需要干预。
static PrinterState | PrinterState.UNKNOWN 打印机状态未知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterStateReason 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterStateReason
的使用

使用 PrinterStateReason 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 PrinterStateReason 的使用

声明为 PrinterStateReason 的 javax.print.attribute.standard 中的字段
static PrinterStateReason | PrinterStateReason.CONNECTING_TO_DEVICE 打印机已经在输出设备中安排了作业，并且正在与共享的网络输出设备进行连接（并且可能在相当长的时间内无法实际开始打印作业，因为这取决于网络上其他服务器对该输出设备的使用情况）。
static PrinterStateReason | PrinterStateReason.COVER_OPEN 设备上的一个或多个机盖处于打开状态。
static PrinterStateReason | PrinterStateReason.DEVELOPER_EMPTY 设备显影剂已用完。
static PrinterStateReason | PrinterStateReason.DEVELOPER_LOW 设备显影剂不足。
static PrinterStateReason | PrinterStateReason.DOOR_OPEN 设备上的一个或多个门处于打开状态。
static PrinterStateReason | PrinterStateReason.FUSER_OVER_TEMP 热熔器温度高于正常值。
static PrinterStateReason | PrinterStateReason.FUSER_UNDER_TEMP 热熔器温度低于正常值。
static PrinterStateReason | PrinterStateReason.INPUT_TRAY_MISSING 设备中没有一个或多个输入纸盒。
static PrinterStateReason | PrinterStateReason.INTERLOCK_OPEN 打印机上的一个或多个连锁设备未锁定。
static PrinterStateReason | PrinterStateReason.INTERPRETER_RESOURCE_UNAVAILABLE 解释器资源（例如字体、格式）不可用。
static PrinterStateReason | PrinterStateReason.MARKER_SUPPLY_EMPTY 设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）已用完。
static PrinterStateReason | PrinterStateReason.MARKER_SUPPLY_LOW 设备上至少有一个指示器表示耗材（例如碳粉、墨水、色带）不足。
static PrinterStateReason | PrinterStateReason.MARKER_WASTE_ALMOST_FULL 设备指示器耗材废物容器几乎已填满。
static PrinterStateReason | PrinterStateReason.MARKER_WASTE_FULL 设备指示器耗材废物容器已填满。
static PrinterStateReason | PrinterStateReason.MEDIA_EMPTY 至少一个输入纸盒是空的。
static PrinterStateReason | PrinterStateReason.MEDIA_JAM 设备中卡住了介质。
static PrinterStateReason | PrinterStateReason.MEDIA_LOW 至少一个输入纸盒的介质不足。
static PrinterStateReason | PrinterStateReason.MEDIA_NEEDED 纸盒中没有介质。
static PrinterStateReason | PrinterStateReason.MOVING_TO_PAUSED 已经暂停了打印机，但设备要停下来还需要一些时间。
static PrinterStateReason | PrinterStateReason.OPC_LIFE_OVER 光敏导电体已不再运行。
static PrinterStateReason | PrinterStateReason.OPC_NEAR_EOL 光敏导电体寿命将到期。
static PrinterStateReason | PrinterStateReason.OTHER 打印机已经检测到了一个以下未列出的错误。
static PrinterStateReason | PrinterStateReason.OUTPUT_AREA_ALMOST_FULL 一个或多个输出区域几乎已经填满（例如纸盒、装订器、整理器）。
static PrinterStateReason | PrinterStateReason.OUTPUT_AREA_FULL 一个或多个输出区域已经填满（例如纸盒、装订器、整理器）。
static PrinterStateReason | PrinterStateReason.OUTPUT_TRAY_MISSING 设备中没有一个或多个输出纸盒。
static PrinterStateReason | PrinterStateReason.PAUSED 已经暂停了打印机并且打印机的 PrinterState 为 STOPPED。
static PrinterStateReason | PrinterStateReason.SHUTDOWN 已经从服务中移除了打印机，并且可以给该打印机断电或者物理移除它。
static PrinterStateReason | PrinterStateReason.SPOOL_AREA_FULL 已达到为后台打印分配的持久存储限制。
static PrinterStateReason | PrinterStateReason.STOPPED_PARTLY 当打印机控制多个输出设备时，此原因指示一个或多个设备被停止。
static PrinterStateReason | PrinterStateReason.STOPPING 打印机正在停止设备，并且打印机也将很快停下来。
static PrinterStateReason | PrinterStateReason.TIMED_OUT 服务器能够连接到输出设备（或始终处于连接状态），但却无法获得输出设备的响应。
static PrinterStateReason | PrinterStateReason.TONER_EMPTY 设备的碳粉用完。
static PrinterStateReason | PrinterStateReason.TONER_LOW 设备的碳粉不足。

返回变量类型为 PrinterStateReason 的类型的 javax.print.attribute.standard 中的方法
 Set<PrinterStateReason> PrinterStateReasons.printerStateReasonSet(Severity severity)
在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。

参数类型为 PrinterStateReason 的 javax.print.attribute.standard 中的方法
 Severity PrinterStateReasons.put(PrinterStateReason reason, Severity severity)
根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。

类型变量类型为 PrinterStateReason 的 javax.print.attribute.standard 中的构造方法参数
PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterStateReasons 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterStateReasons
的使用

没有 javax.print.attribute.standard.PrinterStateReasons 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.PrinterURI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.PrinterURI
的使用

没有 javax.print.attribute.standard.PrinterURI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.QueuedJobCount 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.QueuedJobCount
的使用

没有 javax.print.attribute.standard.QueuedJobCount 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.ReferenceUriSchemesSupported 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.ReferenceUriSchemesSupported
的使用

使用 ReferenceUriSchemesSupported 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 ReferenceUriSchemesSupported 的使用

声明为 ReferenceUriSchemesSupported 的 javax.print.attribute.standard 中的字段
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.FILE 特定于主机的文件名称。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.FTP 文件传输协议 (FTP)。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.GOPHER Gopher 协议。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.HTTP 超文本传输协议 (HTTP)。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.HTTPS 安全超文本传输协议 (HTTPS)。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.NEWS USENET 新闻。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.NNTP 使用网络新闻传输协议 (NNTP) 的 USENET 新闻。
static ReferenceUriSchemesSupported | ReferenceUriSchemesSupported.WAIS 广域信息服务器 (WAIS) 协议。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.RequestingUserName 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.RequestingUserName
的使用

没有 javax.print.attribute.standard.RequestingUserName 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.Severity 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.Severity
的使用

使用 Severity 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Severity 的使用

声明为 Severity 的 javax.print.attribute.standard 中的字段
static Severity | Severity.ERROR 指示 PrinterStateReason 是 "error"（最严重）。
static Severity | Severity.REPORT 指示 PrinterStateReason 是 "report"（不太严重）。
static Severity | Severity.WARNING 指示 PrinterStateReason 是 "warning"。

返回 Severity 的 javax.print.attribute.standard 中的方法
 Severity PrinterStateReasons.put(PrinterStateReason reason, Severity severity)
根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。

参数类型为 Severity 的 javax.print.attribute.standard 中的方法
Set<PrinterStateReason> | PrinterStateReasons.printerStateReasonSet(Severity severity) 在此 PrinterStateReasons 中，获得在给定的严重性级别每个 PrinterStateReasons 属性的不可修改的视图集。
Severity | PrinterStateReasons.put(PrinterStateReason reason, Severity severity) 根据给定的严重性级别，将给定的打印机状态原因添加到此 PrinterStateReasons 属性中。

类型变量类型为 Severity 的 javax.print.attribute.standard 中的构造方法参数
PrinterStateReasons(Map<PrinterStateReason,Severity> map)
构造一个新的 PrinterStateReasons 属性，它包括与给定映射相同的 PrinterStateReason 到 Severity 映射关系。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.standard.SheetCollate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.standard.SheetCollate
的使用

使用 SheetCollate 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 SheetCollate 的使用

声明为 SheetCollate 的 javax.print.attribute.standard 中的字段
static SheetCollate | SheetCollate.COLLATED 当打印多个副本时，文档中的纸张以整理后的顺序出现。
static SheetCollate | SheetCollate.UNCOLLATED 当打印多个副本时，文档中的纸张以非整理顺序出现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.Attribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.Attribute
的使用

使用 Attribute 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print 中 Attribute 的使用

返回 Attribute 的 javax.print 中的方法
 Attribute[] AttributeException.getUnsupportedValues()
返回其 PrintService 实例支持该属性，但是不支持该属性特定值的打印属性数组，如果没有这种属性值，则返回 null。

参数类型为 Attribute 的 javax.print 中的方法
 boolean PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes)
确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。

类型变量类型为 Attribute 的 javax.print 中的方法参数
Object | PrintService.getDefaultAttributeValue(Class<? extends Attribute> category) 确定给定类别中此 PrintService 的默认打印属性值。
Object | PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
boolean | PrintService.isAttributeCategorySupported(Class<? extends Attribute> category) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定打印属性类别。

javax.print.attribute 中 Attribute 的使用

javax.print.attribute 中 Attribute 的子接口
interface | DocAttribute 接口 DocAttribute 是打印属性类实现的一个标记接口，用于指示属性表示文档 (doc) 的设置（“Doc”是一个简短的、容易发音的术语，指“打印数据的片段”。
interface | PrintJobAttribute PrintJobAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印作业”的状态或“打印作业”的一些其他特征。
interface | PrintRequestAttribute 接口 PrintRequestAttribute 是打印属性类实现的标记接口，以指示属性表示用于打印作业的请求设置。
interface | PrintServiceAttribute 接口 PrintServiceAttribute 是打印属性类实现的标记接口，以指示该属性描述“打印服务”的状态或“打印服务”的一些其他特征。
interface | SupportedValuesAttribute 接口 SupportedValuesAttribute 是打印属性类实现的标记接口，以指示该属性描述用于其他属性的支持值。

返回 Attribute 的 javax.print.attribute 中的方法
Attribute | AttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
Attribute | HashAttributeSet.get(Class<?> category) 返回此属性集在给定的属性类别中包含的属性值。
Attribute[] | AttributeSet.toArray() 返回此集合中包含的属性的数组。
Attribute[] | HashAttributeSet.toArray()
static Attribute | AttributeSetUtilities.verifyAttributeValue(Object object, Class<?> interfaceName) 验证给定的对象是否为给定接口（假定为接口 Attribute 或其子接口）的一个实例。

返回变量类型为 Attribute 的类型的 javax.print.attribute 中的方法
 Class<? extends Attribute> Attribute.getCategory()
将此打印属性值添加到属性集时，为它获取用作“类别”的打印属性类。

参数类型为 Attribute 的 javax.print.attribute 中的方法
boolean | AttributeSet.add(Attribute attribute) 如果指定的属性尚不存在，则将它添加到此属性集中，首先要移除与指定属性值相同的属性类别中的任何现有值。
boolean | DocAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | HashAttributeSet.add(Attribute attribute) 如果指定的属性不存在，则将它添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有属性。
boolean | PrintJobAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | PrintRequestAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | PrintServiceAttributeSet.add(Attribute attribute) 如果指定的属性值不存在，则将其添加到此属性集中，方法是首先移除与指定属性值相同的属性类别中的任何现有值（可选操作）。
boolean | AttributeSet.containsValue(Attribute attribute) 如果此属性集包含给定的属性值，则返回 true。
boolean | HashAttributeSet.containsValue(Attribute attribute) 如果此属性集包含给定的属性，则返回 true。
boolean | AttributeSet.remove(Attribute attribute) 从此属性集移除指定的属性（如果存在）。
boolean | HashAttributeSet.remove(Attribute attribute) 从此属性集移除指定的属性（如果存在）。
static void | AttributeSetUtilities.verifyCategoryForValue(Class<?> category, Attribute attribute) 验证给定的属性类别对象是否等于给定属性值对象的类别。

参数类型为 Attribute 的 javax.print.attribute 中的构造方法
HashAttributeSet(Attribute attribute)
构造一个最初使用给定属性填充的新属性集。
HashAttributeSet(Attribute[] attributes)
构造一个最初使用给定数组中的值填充的新属性集。
HashAttributeSet(Attribute[] attributes, Class<?> interfaceName)
构造一个新的属性集，其中该属性集的成员限于给定的接口。
HashAttributeSet(Attribute attribute, Class<?> interfaceName)
构造一个最初使用给定属性填充的新属性集，其中该属性集的成员限于给定的接口。

javax.print.attribute.standard 中 Attribute 的使用

返回变量类型为 Attribute 的类型的 javax.print.attribute.standard 中的方法
Class<? extends Attribute> | Chromaticity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ColorSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Compression.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Copies.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | CopiesSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtCreation.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DateTimeAtProcessing.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Destination.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | DocumentName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Fidelity.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Finishings.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobHoldUntil.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressions.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsCompleted.getCategory() 获取被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobImpressionsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsProcessed.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobKOctetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsCompleted.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMediaSheetsSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobMessageFromOperator.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobOriginatingUserName.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPriority.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobPrioritySupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobSheets.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobState.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReason.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | JobStateReasons.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Media.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaPrintableArea.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MediaSize.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | MultipleDocumentHandling.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfDocuments.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberOfInterveningJobs.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUp.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | NumberUpSupported.getCategory() 获取将被用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OrientationRequested.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | OutputDeviceAssigned.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PDLOverrideSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PageRanges.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinute.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PagesPerMinuteColor.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PresentationDirection.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrintQuality.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterIsAcceptingJobs.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterLocation.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMakeAndModel.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMessageFromOperator.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfo.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterMoreInfoManufacturer.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterResolution.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterState.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReason.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterStateReasons.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | PrinterURI.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | QueuedJobCount.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | ReferenceUriSchemesSupported.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | RequestingUserName.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Severity.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | SheetCollate.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。
Class<? extends Attribute> | Sides.getCategory() 获取将用作此打印属性值的“类别”的打印属性类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.AttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.AttributeSet
的使用

使用 AttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print 中 AttributeSet 的使用

返回 AttributeSet 的 javax.print 中的方法
 AttributeSet PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes)
标识在特定 DocFlavor 的上下文中打印请求不支持的属性。

参数类型为 AttributeSet 的 javax.print 中的方法
abstract MultiDocPrintService[] | PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 应用程序不直接调用它。
abstract PrintService[] | PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes) 查找肯定可支持指定属性和 DocFlavor 组合的服务。
Object | PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
AttributeSet | PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes) 标识在特定 DocFlavor 的上下文中打印请求不支持的属性。
boolean | PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。
static MultiDocPrintService[] | PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。
static PrintService[] | PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes) 查找能够打印指定 DocFlavor 的 PrintService。

javax.print.attribute 中 AttributeSet 的使用

javax.print.attribute 中 AttributeSet 的子接口
interface | DocAttributeSet 接口 DocAttributeSet 指定文档属性（即：实现接口 DocAttribute 的打印属性）集的接口。
interface | PrintJobAttributeSet 接口 PrintJobAttributeSet 为打印作业属性（即：实现接口 PrintJobAttribute 的打印属性）集指定接口。
interface | PrintRequestAttributeSet 接口 PrintRequestAttributeSet 为打印请求属性（即：实现接口 PrintRequestAttribute 的打印属性）的集合指定接口。
interface | PrintServiceAttributeSet 接口 PrintServiceAttributeSet 为打印作业属性（即：实现接口 PrintServiceAttribute 的打印属性）集指定接口。

实现 AttributeSet 的 javax.print.attribute 中的类
class | HashAttributeSet 类 HashAttributeSet 提供具有哈希映射特征的 AttributeSet 实现。
class | HashDocAttributeSet 类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
class | HashPrintJobAttributeSet 类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
class | HashPrintRequestAttributeSet 类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
class | HashPrintServiceAttributeSet 类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

返回 AttributeSet 的 javax.print.attribute 中的方法
static AttributeSet | AttributeSetUtilities.synchronizedView(AttributeSet attributeSet) 创建给定属性集的同步视图。
static AttributeSet | AttributeSetUtilities.unmodifiableView(AttributeSet attributeSet) 创建给定属性集的不可修改的视图。

参数类型为 AttributeSet 的 javax.print.attribute 中的方法
boolean | AttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | DocAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | HashAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | PrintJobAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | PrintRequestAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
boolean | PrintServiceAttributeSet.addAll(AttributeSet attributes) 将指定集合中的所有元素添加到此属性中。
static AttributeSet | AttributeSetUtilities.synchronizedView(AttributeSet attributeSet) 创建给定属性集的同步视图。
static AttributeSet | AttributeSetUtilities.unmodifiableView(AttributeSet attributeSet) 创建给定属性集的不可修改的视图。

参数类型为 AttributeSet 的 javax.print.attribute 中的构造方法
HashAttributeSet(AttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集。
HashAttributeSet(AttributeSet attributes, Class<?> interfaceName)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于给定的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.AttributeSetUtilities 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.AttributeSetUtilities
的使用

没有 javax.print.attribute.AttributeSetUtilities 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.DateTimeSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.DateTimeSyntax
的使用

使用 DateTimeSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 DateTimeSyntax 的使用

javax.print.attribute.standard 中 DateTimeSyntax 的子类
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.DocAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.DocAttribute
的使用

使用 DocAttribute 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 DocAttribute 的使用

参数类型为 DocAttribute 的 javax.print.attribute 中的构造方法
HashDocAttributeSet(DocAttribute attribute)
构造一个最初使用给定值填充的新哈希文档属性集。
HashDocAttributeSet(DocAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希文档属性集。

javax.print.attribute.standard 中 DocAttribute 的使用

实现 DocAttribute 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.DocAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.DocAttributeSet
的使用

使用 DocAttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print 中 DocAttributeSet 的使用

返回 DocAttributeSet 的 javax.print 中的方法
DocAttributeSet | Doc.getAttributes() 获取此 doc 对象的打印属性集。
DocAttributeSet | SimpleDoc.getAttributes() 获得此 doc 对象的打印属性集。

参数类型为 DocAttributeSet 的 javax.print 中的构造方法
SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。

javax.print.attribute 中 DocAttributeSet 的使用

实现 DocAttributeSet 的 javax.print.attribute 中的类
 class HashDocAttributeSet
类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。

返回 DocAttributeSet 的 javax.print.attribute 中的方法
static DocAttributeSet | AttributeSetUtilities.synchronizedView(DocAttributeSet attributeSet) 创建一个给定文档属性集的同步视图。
static DocAttributeSet | AttributeSetUtilities.unmodifiableView(DocAttributeSet attributeSet) 创建一个给定文档属性集的不可修改的视图。

参数类型为 DocAttributeSet 的 javax.print.attribute 中的方法
static DocAttributeSet | AttributeSetUtilities.synchronizedView(DocAttributeSet attributeSet) 创建一个给定文档属性集的同步视图。
static DocAttributeSet | AttributeSetUtilities.unmodifiableView(DocAttributeSet attributeSet) 创建一个给定文档属性集的不可修改的视图。

参数类型为 DocAttributeSet 的 javax.print.attribute 中的构造方法
HashDocAttributeSet(DocAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 DocAttribute 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.EnumSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.EnumSyntax
的使用

使用 EnumSyntax 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 EnumSyntax 的使用

返回 EnumSyntax 的 javax.print.attribute 中的方法
protected  EnumSyntax[] EnumSyntax.getEnumValueTable()
返回此枚举值的枚举类的枚举值表。

javax.print.attribute.standard 中 EnumSyntax 的使用

javax.print.attribute.standard 中 EnumSyntax 的子类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | Compression Compression 类是打印属性类，它是一个枚举值，指定如何压缩打印数据。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReason JobStateReason 类是打印属性类，它是一个枚举值，提供了有关作业当前状态的额外信息，例如，扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReason PrinterStateReason 类是打印属性类，它是一个枚举值，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | ReferenceUriSchemesSupported ReferenceUriSchemesSupported 类是打印属性类，它是一种枚举，指示了“URI 方案”（如 "http:"或 "ftp:"），打印机可使用它来获取存储在 URI 位置的打印数据。
class | Severity Severity 类是打印属性类，它是一种枚举，表示 PrinterStateReason 属性的严重性。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

返回 EnumSyntax 的 javax.print.attribute.standard 中的方法
protected EnumSyntax[] | Chromaticity.getEnumValueTable() 返回 Chromaticity 类的枚举值表。
protected EnumSyntax[] | ColorSupported.getEnumValueTable() 返回 ColorSupported 类的枚举值表。
protected EnumSyntax[] | Compression.getEnumValueTable() 返回 Compression 类的枚举值表。
protected EnumSyntax[] | Fidelity.getEnumValueTable() 返回 Fidelity 类的枚举值表。
protected EnumSyntax[] | Finishings.getEnumValueTable() 返回 Finishings 类的枚举值表。
protected EnumSyntax[] | JobSheets.getEnumValueTable() 返回 class JobSheets 类的枚举值表。
protected EnumSyntax[] | JobState.getEnumValueTable() 返回 JobState 类的枚举值表。
protected EnumSyntax[] | JobStateReason.getEnumValueTable() 返回 JobStateReason 类的枚举值表。
protected EnumSyntax[] | MediaName.getEnumValueTable() 返回 MediaTray 类的枚举值表。
protected EnumSyntax[] | MediaSizeName.getEnumValueTable() 返回 MediaSizeName 类的枚举值表。
protected EnumSyntax[] | MediaTray.getEnumValueTable() 返回 MediaTray 类的枚举值表。
protected EnumSyntax[] | MultipleDocumentHandling.getEnumValueTable() 返回 MultipleDocumentHandling 类的枚举值表。
protected EnumSyntax[] | OrientationRequested.getEnumValueTable() 返回类 OrientationRequested 的枚举值表。
protected EnumSyntax[] | PDLOverrideSupported.getEnumValueTable() 返回类 PDLOverrideSupported 的枚举值表。
protected EnumSyntax[] | PresentationDirection.getEnumValueTable() 返回类 PresentationDirection 的枚举值表。
protected EnumSyntax[] | PrintQuality.getEnumValueTable() 返回类 PrintQuality 的枚举值表。
protected EnumSyntax[] | PrinterIsAcceptingJobs.getEnumValueTable() 返回类 PrinterIsAcceptingJobs 的枚举值表。
protected EnumSyntax[] | PrinterState.getEnumValueTable() 返回类 PrinterState 的枚举值表。
protected EnumSyntax[] | PrinterStateReason.getEnumValueTable() 返回类 PrinterStateReason 的枚举值表。
protected EnumSyntax[] | ReferenceUriSchemesSupported.getEnumValueTable() 返回类 ReferenceUriSchemesSupported 的枚举值表。
protected EnumSyntax[] | Severity.getEnumValueTable() 返回类 Severity 的枚举值表。
protected EnumSyntax[] | SheetCollate.getEnumValueTable() 返回类 SheetCollate 的枚举值表。
protected EnumSyntax[] | Sides.getEnumValueTable() 返回类 Sides 的枚举值表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.HashAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashAttributeSet
的使用

使用 HashAttributeSet 的软件包
javax.print.attribute 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。

javax.print.attribute 中 HashAttributeSet 的使用

javax.print.attribute 中 HashAttributeSet 的子类
class | HashDocAttributeSet 类 HashDocAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 DocAttributeSet 的语义限制。
class | HashPrintJobAttributeSet 类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。
class | HashPrintRequestAttributeSet 类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。
class | HashPrintServiceAttributeSet 类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.HashDocAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashDocAttributeSet
的使用

没有 javax.print.attribute.HashDocAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.HashPrintJobAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashPrintJobAttributeSet
的使用

没有 javax.print.attribute.HashPrintJobAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.HashPrintRequestAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashPrintRequestAttributeSet
的使用

没有 javax.print.attribute.HashPrintRequestAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.HashPrintServiceAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.HashPrintServiceAttributeSet
的使用

没有 javax.print.attribute.HashPrintServiceAttributeSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.IntegerSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.IntegerSyntax
的使用

使用 IntegerSyntax 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 IntegerSyntax 的使用

参数类型为 IntegerSyntax 的 javax.print.attribute 中的方法
 boolean SetOfIntegerSyntax.contains(IntegerSyntax attribute)
确定此整数集属性是否包含给定的整数属性的值。

javax.print.attribute.standard 中 IntegerSyntax 的使用

javax.print.attribute.standard 中 IntegerSyntax 的子类
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.PrintJobAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintJobAttribute
的使用

使用 PrintJobAttribute 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 PrintJobAttribute 的使用

参数类型为 PrintJobAttribute 的 javax.print.attribute 中的构造方法
HashPrintJobAttributeSet(PrintJobAttribute attribute)
构造一个最初使用给定值填充的新哈希打印作业属性集。
HashPrintJobAttributeSet(PrintJobAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新哈希打印作业属性集。

javax.print.attribute.standard 中 PrintJobAttribute 的使用

实现 PrintJobAttribute 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | DateTimeAtCompleted DateTimeAtCompleted 类是打印属性类，它是一个日期-时间属性，指示 Print Job 完成（或取消或中止）的日期和时间。
class | DateTimeAtCreation DateTimeAtCreation 类是打印属性类，它是一个日期-时间属性，指示创建 Print Job 时的日期和时间。
class | DateTimeAtProcessing DateTimeAtProcessing 类是打印属性类，它是一个日期-时间属性，指示首次开始处理 Print Job 的日期和时间。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobImpressionsCompleted JobImpressionsCompleted 类是整数值形式的打印属性类，它指定了到目前为止已完成作业的印数。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobKOctetsProcessed JobKOctetsProcessed 类是整数值形式的打印属性类，它指定了到目前为止已处理的打印数据字节总数，以 K 字节为单位，即以 1024 字节为单位。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobMediaSheetsCompleted JobMediaSheetsCompleted 类是整数值形式的打印属性类，它指定了到目前为止全部作业的已完成标记和堆栈的介质纸张数，不管这些纸张完成的是单面处理还是双面处理。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | JobState JobState 是打印属性类，它是一个枚举值，标识了打印作业的当前状态。
class | JobStateReasons JobStateReasons 类是打印属性类，它是一个枚举值集合，提供了有关作业当前状态的额外信息，即扩充作业的 JobState 属性值的信息。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberOfDocuments NumberOfDocuments 类是整数值形式的打印属性类，它指示打印机已接受此作业的单份文档数，而不管文档的打印数据是否已到达打印机。
class | NumberOfInterveningJobs NumberOfInterveningJobs 类是整数值形式的打印属性类，它指示在此作业之前的作业数，这些作业按期望完成的相对时间顺序排序（即当前安排的顺序）。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.ResolutionSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.ResolutionSyntax
的使用

使用 ResolutionSyntax 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 ResolutionSyntax 的使用

参数类型为 ResolutionSyntax 的 javax.print.attribute 中的方法
 boolean ResolutionSyntax.lessThanOrEquals(ResolutionSyntax other)
确定此分辨率属性的值是否小于或等于给定分辨率属性的值。

javax.print.attribute.standard 中 ResolutionSyntax 的使用

javax.print.attribute.standard 中 ResolutionSyntax 的子类
 class PrinterResolution
PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.PrintJobAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintJobAttributeSet
的使用

使用 PrintJobAttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 PrintJobAttributeSet 的使用

返回 PrintJobAttributeSet 的 javax.print 中的方法
 PrintJobAttributeSet DocPrintJob.getAttributes()
获取此 PrintJob 的打印属性集。

参数类型为 PrintJobAttributeSet 的 javax.print 中的方法
 void DocPrintJob.addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes)
为指定属性中的更改注册一个侦听器。

javax.print.attribute 中 PrintJobAttributeSet 的使用

实现 PrintJobAttributeSet 的 javax.print.attribute 中的类
 class HashPrintJobAttributeSet
类 HashPrintJobAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintJobAttributeSet 的语义限制。

返回 PrintJobAttributeSet 的 javax.print.attribute 中的方法
static PrintJobAttributeSet | AttributeSetUtilities.synchronizedView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的同步视图。
static PrintJobAttributeSet | AttributeSetUtilities.unmodifiableView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的不可修改的视图。

参数类型为 PrintJobAttributeSet 的 javax.print.attribute 中的方法
static PrintJobAttributeSet | AttributeSetUtilities.synchronizedView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的同步视图。
static PrintJobAttributeSet | AttributeSetUtilities.unmodifiableView(PrintJobAttributeSet attributeSet) 创建一个给定打印作业属性集的不可修改的视图。

参数类型为 PrintJobAttributeSet 的 javax.print.attribute 中的构造方法
HashPrintJobAttributeSet(PrintJobAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintJobAttribute 接口。

javax.print.event 中 PrintJobAttributeSet 的使用

返回 PrintJobAttributeSet 的 javax.print.event 中的方法
 PrintJobAttributeSet PrintJobAttributeEvent.getAttributes()
确定已经更改的打印属性及其新值。

参数类型为 PrintJobAttributeSet 的 javax.print.event 中的构造方法
PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
构造一个 PrintJobAttributeEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.PrintRequestAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintRequestAttribute
的使用

使用 PrintRequestAttribute 的软件包
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute 中 PrintRequestAttribute 的使用

参数类型为 PrintRequestAttribute 的 javax.print.attribute 中的构造方法
HashPrintRequestAttributeSet(PrintRequestAttribute attribute)
构造一个最初使用给定值填充的新打印请求属性集。
HashPrintRequestAttributeSet(PrintRequestAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印请求属性集。

javax.print.attribute.standard 中 PrintRequestAttribute 的使用

实现 PrintRequestAttribute 的 javax.print.attribute.standard 中的类
class | Chromaticity Chromaticity 类是打印属性类，它是一个枚举值，指定单色打印或彩色打印。
class | Copies Copies 类是整数值形式的打印属性类，它指定了要打印的份数。
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | Fidelity Fidelity 类是打印属性类，它是一个枚举值，指示客户机提供的请求属性是否要求具有总体保真度。
class | Finishings Finishings 类是打印属性类，它是一个枚举值，标识了打印机是否将某个正在完成的某类绑定操作应用到作业中每个打印文档的每个副本中。
class | JobHoldUntil JobHoldUntil 类是打印属性类，它是一个日期-时间属性，指定了作业必须成为候选打印作业的准确日期和时间。
class | JobImpressions JobImpressions 类是整数值形式的打印属性类，它指定了正提交的文档（或多个文档）的印张的总大小。
class | JobKOctets JobKOctets 类是整数值形式的打印属性类，它指定了以 K 字节为单位的文档总大小，即以要在作业中处理的所请求的 1024 字节为单位。
class | JobMediaSheets JobMediaSheets 类是整数值形式的打印属性类，它指定了要为此作业生成的介质纸张总数。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobPriority JobPriority 类是整数值形式的打印属性类，它指定了打印作业的优先级。
class | JobSheets JobSheets 类是打印属性类，它是一个枚举值，确定必须打印作业的开始页和结束页（如果有）。
class | Media Media 类是打印属性类，它指定了要在其上打印的介质。
class | MediaName MediaName 类是 Media 的子类，它是打印属性类（一个枚举），以名称形式指定了打印作业的介质。
class | MediaPrintableArea MediaPrintableArea 类是打印属性类，用于区分介质的可打印区域和不可打印区域。
class | MediaSizeName MediaSizeName 类是 Media 的子类。
class | MediaTray MediaTray 类是 Media 的子类。
class | MultipleDocumentHandling MultipleDocumentHandling 类是打印属性类，它是一个枚举值，控制结束操作和一个或多个打印流在印张中和在介质纸张上的布局。
class | NumberUp NumberUp 类是整数值形式的打印属性类，它指定了要放置于选中介质的实例单面上的打印流页数。
class | OrientationRequested OrientationRequested 类是打印属性类，它是一种枚举，指示所打印的打印流页的所需方向；但它不描述客户端提供的打印流页的方向。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。
class | PresentationDirection PresentationDirection 类是打印属性类，它是一种枚举，它与 NumberUp 属性结合使用，以指示应用于所选单面介质实例上多个打印流页的布局。
class | PrinterResolution PrinterResolution 类是打印属性类，指定了打印机支持的或将用于打印作业的精确分辨率。
class | PrintQuality PrintQuality 类是打印属性类，它是一种枚举，指定了打印机为该作业使用的打印质量。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。
class | SheetCollate SheetCollate 类是打印属性类，它是一种枚举，当由 Copies 属性指定了文档的多个副本时，它可以指定作业中每个打印文档的每个副本的介质纸张是否排列有序。
class | Sides Sides 类是打印属性类，它是一种枚举，指定了如何将打印流页应用于选定介质实例的各面（即一个印张）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.PrintRequestAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintRequestAttributeSet
的使用

使用 PrintRequestAttributeSet 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 java.awt.print 中的方法
 PageFormat PrinterJob.getPageFormat(PrintRequestAttributeSet attributes)
使用与受此作业 PrintService 支持的那些值一致的值（即由 getPrintService() 返回的值），以及 attributes 中包含的介质、可打印区域和方向计算 PageFormat。
 PageFormat PrinterJob.pageDialog(PrintRequestAttributeSet attributes)
显示跨平台页面设置对话框的便捷方法。
 void PrinterJob.print(PrintRequestAttributeSet attributes)
使用属性集中的设置打印一组页面。
 boolean PrinterJob.printDialog(PrintRequestAttributeSet attributes)
为所有服务显示跨平台打印对话框的便捷方法，这些服务能够使用 Pageable 接口打印 2D 图形。

javax.print 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 javax.print 中的方法
void | DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印文档。
void | MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印 MultiDoc。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。

javax.print.attribute 中 PrintRequestAttributeSet 的使用

实现 PrintRequestAttributeSet 的 javax.print.attribute 中的类
 class HashPrintRequestAttributeSet
类 HashPrintRequestAttributeSet 从类 HashAttributeSet 继承其实现，并强制执行接口 PrintRequestAttributeSet 的语义限制。

返回 PrintRequestAttributeSet 的 javax.print.attribute 中的方法
static PrintRequestAttributeSet | AttributeSetUtilities.synchronizedView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的同步视图。
static PrintRequestAttributeSet | AttributeSetUtilities.unmodifiableView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的不可修改的视图。

参数类型为 PrintRequestAttributeSet 的 javax.print.attribute 中的方法
static PrintRequestAttributeSet | AttributeSetUtilities.synchronizedView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的同步视图。
static PrintRequestAttributeSet | AttributeSetUtilities.unmodifiableView(PrintRequestAttributeSet attributeSet) 创建一个给定打印请求属性集的不可修改的视图。

参数类型为 PrintRequestAttributeSet 的 javax.print.attribute 中的构造方法
HashPrintRequestAttributeSet(PrintRequestAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 (PrintRequestAttributeSe 接口。

javax.swing 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 javax.swing 中的方法
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。

javax.swing.text 中 PrintRequestAttributeSet 的使用

参数类型为 PrintRequestAttributeSet 的 javax.swing.text 中的方法
 boolean JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.PrintServiceAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintServiceAttribute
的使用

使用 PrintServiceAttribute 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.attribute.standard | 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print 中 PrintServiceAttribute 的使用

类型参数类型为 PrintServiceAttribute 的 javax.print 中的方法
<T extends PrintServiceAttribute>
T
PrintService.getAttribute(Class<T> category)
获取单个指定服务属性的值。

javax.print.attribute 中 PrintServiceAttribute 的使用

参数类型为 PrintServiceAttribute 的 javax.print.attribute 中的构造方法
HashPrintServiceAttributeSet(PrintServiceAttribute attribute)
构造一个最初使用给定值填充的新哈希打印服务属性集。
HashPrintServiceAttributeSet(PrintServiceAttribute[] attributes)
构造一个最初使用给定数组中的值填充的新打印服务属性集。

javax.print.attribute.standard 中 PrintServiceAttribute 的使用

实现 PrintServiceAttribute 的 javax.print.attribute.standard 中的类
class | ColorSupported ColorSupported 类是打印属性类，它是一个枚举值，标识了设备是否能够支持任何类型的彩色打印，包括高亮颜色和全处理颜色 (full process color)。
class | PagesPerMinute PagesPerMinute 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、黑白设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PagesPerMinuteColor PagesPerMinuteColor 类是一个整数值的打印属性，它指示与此打印机可生成（例如在单工、彩色设置下）的总页数最接近的每分钟可以生成的额定页数。
class | PDLOverrideSupported PDLOverrideSupported 类是打印属性类，它是一种枚举，表示可使用以打印数据外部的属性方式所指定的处理指令，来重写嵌入到文档打印数据中的处理指令。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterIsAcceptingJobs PrinterIsAcceptingJobs 类是打印属性类，它是一种枚举，指示打印机当前是否能够接受作业。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | PrinterState PrinterState 类是打印机属性类，它是一种枚举，标识了打印机的当前状态。
class | PrinterStateReasons PrinterStateReasons 类是打印属性类，它是一组枚举值集合，提供了有关打印机当前状态的附加信息，即扩充了打印机 PrinterState 属性值的信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。
class | QueuedJobCount QueuedJobCount 类是整数值打印属性，它指示了其 JobState 是 PENDING、PENDING_HELD、PROCESSING 或 PROCESSING_STOPPED 的打印机中的作业数。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.PrintServiceAttributeSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.PrintServiceAttributeSet
的使用

使用 PrintServiceAttributeSet 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.attribute | 提供了描述 JavaTM Print Service 属性的类型以及如何分类这些属性的类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 PrintServiceAttributeSet 的使用

返回 PrintServiceAttributeSet 的 javax.print 中的方法
 PrintServiceAttributeSet PrintService.getAttributes()
获得此 PrintService 的打印机描述属性集，这些属性给出了此 PrintService 的状态。

javax.print.attribute 中 PrintServiceAttributeSet 的使用

实现 PrintServiceAttributeSet 的 javax.print.attribute 中的类
 class HashPrintServiceAttributeSet
类 HashPrintServiceAttributeSet 提供从类 HashAttributeSet 继承其实现的属性集，并强制执行接口 PrintServiceAttributeSet 的语义限制。

返回 PrintServiceAttributeSet 的 javax.print.attribute 中的方法
static PrintServiceAttributeSet | AttributeSetUtilities.synchronizedView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的同步视图。
static PrintServiceAttributeSet | AttributeSetUtilities.unmodifiableView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的不可修改的视图。

参数类型为 PrintServiceAttributeSet 的 javax.print.attribute 中的方法
static PrintServiceAttributeSet | AttributeSetUtilities.synchronizedView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的同步视图。
static PrintServiceAttributeSet | AttributeSetUtilities.unmodifiableView(PrintServiceAttributeSet attributeSet) 创建一个给定打印服务属性集的不可修改的视图。

参数类型为 PrintServiceAttributeSet 的 javax.print.attribute 中的构造方法
HashPrintServiceAttributeSet(PrintServiceAttributeSet attributes)
构造一个最初使用给定集合中的值填充的新属性集，其中该属性集的成员限于 PrintServiceAttribute 接口。

javax.print.event 中 PrintServiceAttributeSet 的使用

返回 PrintServiceAttributeSet 的 javax.print.event 中的方法
 PrintServiceAttributeSet PrintServiceAttributeEvent.getAttributes()
确定已经更改的打印服务属性及其新值。

参数类型为 PrintServiceAttributeSet 的 javax.print.event 中的构造方法
PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
构造一个 PrintServiceAttributeEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.SetOfIntegerSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.SetOfIntegerSyntax
的使用

使用 SetOfIntegerSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 SetOfIntegerSyntax 的使用

javax.print.attribute.standard 中 SetOfIntegerSyntax 的子类
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。
class | PageRanges PageRanges 类是打印属性类，它是一个整数集，标识 Printer 对象为所要打印的每个文档的每份副本所使用的打印流页范围。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.Size2DSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.Size2DSyntax
的使用

使用 Size2DSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 Size2DSyntax 的使用

javax.print.attribute.standard 中 Size2DSyntax 的子类
 class MediaSize
MediaSize 是二维大小值形式的打印属性类，它指示纵向方向中的介质维度，其中 X 维度沿底边计算，Y 维度沿左边计算。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.attribute.SupportedValuesAttribute 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.attribute.SupportedValuesAttribute
的使用

使用 SupportedValuesAttribute 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 SupportedValuesAttribute 的使用

实现 SupportedValuesAttribute 的 javax.print.attribute.standard 中的类
class | CopiesSupported CopiesSupported 类是打印属性类，它是一个整数集，给出了支持的 Copies 属性的值。
class | JobImpressionsSupported JobImpressionsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobImpressions 属性值。
class | JobKOctetsSupported JobKOctetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobKOctets 属性的值。
class | JobMediaSheetsSupported Class JobMediaSheetsSupported 类是打印属性类，它是一个整数集，给出了支持的 JobMediaSheets 属性。
class | JobPrioritySupported JobPrioritySupported 类是整数值形式的打印属性类，它指定了 Print Service 实例是否支持 JobPriority 属性，以及支持的不同作业优先级数目。
class | NumberUpSupported NumberUpSupported 类是打印属性类，它是一个整数集，给出了支持的 NumberUp 属性值。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.TextSyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.TextSyntax
的使用

使用 TextSyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 TextSyntax 的使用

javax.print.attribute.standard 中 TextSyntax 的子类
class | DocumentName DocumentName 类是打印属性类，它是一个文本属性，指定了文档名称。
class | JobMessageFromOperator JobMessageFromOperator 类是打印属性类，它是一个文本属性，提供操作员、系统管理员或“智能”进程传来的消息，向终端用户指示某个作业上的修改或其他管理操作的原因。
class | JobName JobName 类是打印属性类，它是一个文本属性，指定了打印作业的名称。
class | JobOriginatingUserName JobOriginatingUserName 类是打印属性类，它是一个文本属性，包含提交打印作业的终端用户的名称。
class | OutputDeviceAssigned OutputDeviceAssigned 类是打印属性类，它是一种文本属性，标识了服务将此作业所分配到的输出设备。
class | PrinterInfo PrinterInfo 类是打印属性类，它是一种文本属性，提供了有关打印机的描述性信息。
class | PrinterLocation PrinterLocation 类是打印属性类，它是一种文本属性，标识了设备的位置。
class | PrinterMakeAndModel PrinterMakeAndModel 类是打印属性类，它是一种文本属性，说明打印机的制造和型号。
class | PrinterMessageFromOperator PrinterMessageFromOperator 类是打印属性类，它是一种文本属性，提供操作员、系统管理员或“智能”进程传来的处理中的消息，可向最终用户指示有关打印机状态（如为什么不可用或者希望何时可用）的信息。
class | PrinterName PrinterName 类是打印属性类，它是一种文本属性，指定了打印机的名称。
class | RequestingUserName RequestingUserName 类是打印属性类，它是一种文本属性，指定了提交打印作业的最终用户的名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.URISyntax 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.URISyntax
的使用

使用 URISyntax 的软件包
javax.print.attribute.standard 包 javax.print.attribute.standard 包括特定打印属性的类。

javax.print.attribute.standard 中 URISyntax 的使用

javax.print.attribute.standard 中 URISyntax 的子类
class | Destination Destination 类是打印属性类，它是一个 URI，用于指示进入缓冲池的打印机格式的数据的可选目标。
class | PrinterMoreInfo PrinterMoreInfo 类是打印属性类，它是一种 URI，用来获取有关此特定打印机的更多信息。
class | PrinterMoreInfoManufacturer PrinterMoreInfoManufacturer 类是打印属性类，它是一种 URI，用于获取有关此类型设备的更多信息。
class | PrinterURI PrinterURI 类是打印属性类，它是一个 URI，指定了全局唯一的打印机名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.attribute.UnmodifiableSetException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.attribute.UnmodifiableSetException
的使用

没有 javax.print.attribute.UnmodifiableSetException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


PrintEvent (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print.event
类 PrintEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.print.event.PrintEvent
所有已实现的接口：
Serializable
直接已知子类：
PrintJobAttributeEvent, PrintJobEvent, PrintServiceAttributeEvent
public class PrintEvent
extends EventObject

类 PrintEvent 是所有 Print Service API 事件的超类。

另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PrintEvent(Object source)
构造一个 PrintEvent 对象。
方法摘要
 String toString()
返回此 EventObject 的 String 表示形式。
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrintEvent

public PrintEvent(Object source)
构造一个 PrintEvent 对象。

参数：
source - 事件源
抛出：
IllegalArgumentException - 如果 source 为 null。
方法详细信息

toString

public String toString()
从类 EventObject 复制的描述
返回此 EventObject 的 String 表示形式。

覆盖：
类 EventObject 中的 toString
返回：
描述事件的消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PrintJobAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.event
类 PrintJobAdapter

java.lang.Object
    继承者  javax.print.event.PrintJobAdapter
所有已实现的接口：
PrintJobListener
public abstract class PrintJobAdapter
extends Object
implements PrintJobListener

接收打印作业事件的抽象适配器类。此类中的方法为空。此类存在的目的只是为了便于创建侦听器对象。扩展此类可创建 PrintJobEvent 侦听器并重写所需事件的方法。与 ComponentListener 接口不同，此抽象接口提供了 null 方法，因此您只需要定义所需的方法，而不需要定义所有的方法。

构造方法摘要
PrintJobAdapter()
方法摘要
void | printDataTransferCompleted(PrintJobEvent pje) 调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
void | printJobCanceled(PrintJobEvent pje) 调用此方法来通知客户端，作业已被用户或程序取消。
void | printJobCompleted(PrintJobEvent pje) 调用此方法来通知客户端，作业已成功完成。
void | printJobFailed(PrintJobEvent pje) 调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
void | printJobNoMoreEvents(PrintJobEvent pje) 调用此方法来通知客户端，不需要再提供事件。
void | printJobRequiresAttention(PrintJobEvent pje) 调用此方法来通知客户端，可能会发生一些用户可纠正的问题（例如打印机缺纸）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PrintJobAdapter

public PrintJobAdapter()
方法详细信息

printDataTransferCompleted

public void printDataTransferCompleted(PrintJobEvent pje)
调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。接收到此事件之后，客户端不应假定已完全打印了该数据。

指定者：
接口 PrintJobListener 中的 printDataTransferCompleted
参数：
pje - 要通知的事件

printJobCompleted

public void printJobCompleted(PrintJobEvent pje)
调用此方法来通知客户端，作业已成功完成。

指定者：
接口 PrintJobListener 中的 printJobCompleted
参数：
pje - 要通知的事件

printJobFailed

public void printJobFailed(PrintJobEvent pje)
调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。

指定者：
接口 PrintJobListener 中的 printJobFailed
参数：
pje - 要通知的事件

printJobCanceled

public void printJobCanceled(PrintJobEvent pje)
调用此方法来通知客户端，作业已被用户或程序取消。

指定者：
接口 PrintJobListener 中的 printJobCanceled
参数：
pje - 要通知的事件

printJobNoMoreEvents

public void printJobNoMoreEvents(PrintJobEvent pje)
调用此方法来通知客户端，不需要再提供事件。生成此事件的原因之一是：作业已成功完成，但打印系统功能有限，无法验证此事件。如果未提供其他的终端事件（完成/失败/取消），则必须提供此事件。

指定者：
接口 PrintJobListener 中的 printJobNoMoreEvents
参数：
pje - 要通知的事件

printJobRequiresAttention

public void printJobRequiresAttention(PrintJobEvent pje)
调用此方法来通知客户端，可能会发生一些用户可纠正的问题（例如打印机缺纸）。

指定者：
接口 PrintJobListener 中的 printJobRequiresAttention
参数：
pje - 要通知的事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintJobAttributeEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.event
类 PrintJobAttributeEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.print.event.PrintEvent
            继承者  javax.print.event.PrintJobAttributeEvent
所有已实现的接口：
Serializable
public class PrintJobAttributeEvent
extends PrintEvent

类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。

另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
构造一个 PrintJobAttributeEvent 对象。
方法摘要
PrintJobAttributeSet | getAttributes() 确定已经更改的打印属性及其新值。
DocPrintJob | getPrintJob() 确定此打印作业事件适合的 Print Job。
从类 javax.print.event.PrintEvent 继承的方法
toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrintJobAttributeEvent

public PrintJobAttributeEvent(DocPrintJob source,
                              PrintJobAttributeSet attributes)
构造一个 PrintJobAttributeEvent 对象。

参数：
source - 生成此事件的打印作业
attributes - 要报告的属性更改
抛出：
IllegalArgumentException - 如果 source 为 null。
方法详细信息

getPrintJob

public DocPrintJob getPrintJob()
确定此打印作业事件适合的 Print Job。

返回：
Print Job 对象。

getAttributes

public PrintJobAttributeSet getAttributes()
确定已经更改的打印属性及其新值。

返回：
属性，包含已经更改的打印作业属性的新值。返回的集合是不可修改的。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintJobAttributeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.event
接口 PrintJobAttributeListener

public interface PrintJobAttributeListener

此接口的实现连接到 DocPrintJob，以监视与此打印作业关联的属性状态的更改。

方法摘要
 void attributeUpdate(PrintJobAttributeEvent pjae)
通知侦听器某些打印作业属性已更改。

方法详细信息

attributeUpdate

void attributeUpdate(PrintJobAttributeEvent pjae)
通知侦听器某些打印作业属性已更改。触发此事件的一个示例是：JobState 属性从 PROCESSING 更改为 PROCESSING_STOPPED。

参数：
pjae - 事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintJobEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.event
类 PrintJobEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.print.event.PrintEvent
            继承者  javax.print.event.PrintJobEvent
所有已实现的接口：
Serializable
public class PrintJobEvent
extends PrintEvent

类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。

另请参见：
序列化表格

字段摘要
static int | DATA_TRANSFER_COMPLETE 不必打印该作业，但数据已经成功地从客户端传输到了打印服务。
static int | JOB_CANCELED 作业已被 PrintService 取消。
static int | JOB_COMPLETE 文档已被完全打印。
static int | JOB_FAILED 打印服务报告无法完成作业。
static int | NO_MORE_EVENTS 并非所有的打印服务都能够提供所需的事件，甚至无法通知作业何时完成。
static int | REQUIRES_ATTENTION 打印服务指示可能发生需要外部干预的瞬态问题，然后打印服务才可以继续进行。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PrintJobEvent(DocPrintJob source, int reason)
构造一个 PrintJobEvent 对象。
方法摘要
int | getPrintEventType() 获得此事件的原因。
DocPrintJob | getPrintJob() 确定此打印作业事件适合的 DocPrintJob。
从类 javax.print.event.PrintEvent 继承的方法
toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

JOB_CANCELED

public static final int JOB_CANCELED
作业已被 PrintService 取消。

另请参见：
常量字段值

JOB_COMPLETE

public static final int JOB_COMPLETE
文档已被完全打印。

另请参见：
常量字段值

JOB_FAILED

public static final int JOB_FAILED
打印服务报告无法完成作业。应用程序必须重新提交该作业。

另请参见：
常量字段值

REQUIRES_ATTENTION

public static final int REQUIRES_ATTENTION
打印服务指示可能发生需要外部干预的瞬态问题，然后打印服务才可以继续进行。可以生成此消息的一个示例是打印机用完了纸张。

另请参见：
常量字段值

NO_MORE_EVENTS

public static final int NO_MORE_EVENTS
并非所有的打印服务都能够提供所需的事件，甚至无法通知作业何时完成。此消息指示打印作业没有更多的信息或与打印服务之间没有通信。如果未提供终端事件（完成/失败/取消），则必须始终提供此消息。例如，如果在接收此消息之前尚未接收到诸如 JOB_COMPLETE 之类的消息，则可以得出的唯一结论就是打印服务不支持提供此类事件。

另请参见：
常量字段值

DATA_TRANSFER_COMPLETE

public static final int DATA_TRANSFER_COMPLETE
不必打印该作业，但数据已经成功地从客户端传输到了打印服务。客户端可以释放这些数据资源。

另请参见：
常量字段值
构造方法详细信息

PrintJobEvent

public PrintJobEvent(DocPrintJob source,
                     int reason)
构造一个 PrintJobEvent 对象。

参数：
source - 一个 DocPrintJob 对象
reason - 一个指定原因的 int。
抛出：
IllegalArgumentException - 如果 source 为 null。
方法详细信息

getPrintEventType

public int getPrintEventType()
获得此事件的原因。

返回：
原因 int。

getPrintJob

public DocPrintJob getPrintJob()
确定此打印作业事件适合的 DocPrintJob。

返回：
DocPrintJob 对象，该对象表示报告了由此 PrintJobEvent 所封装事件的打印作业。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintJobListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.event
接口 PrintJobListener

所有已知实现类：
PrintJobAdapter
public interface PrintJobListener

此侦听器接口的实现应该连接到 DocPrintJob，以监视打印机作业的状态。在处理打印作业的线程上或服务创建的通知线程上可以调用这些回调方法。无论是哪一种情况，在这些回调中客户端都不必执行较长时间的处理。

方法摘要
void | printDataTransferCompleted(PrintJobEvent pje) 调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
void | printJobCanceled(PrintJobEvent pje) 调用此方法来通知客户端，作业已被用户或程序取消。
void | printJobCompleted(PrintJobEvent pje) 调用此方法来通知客户端，作业已成功完成。
void | printJobFailed(PrintJobEvent pje) 调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
void | printJobNoMoreEvents(PrintJobEvent pje) 调用此方法来通知客户端，不需要再提供事件。
void | printJobRequiresAttention(PrintJobEvent pje) 调用此方法来通知客户端，发生了一个用户也许能够修复的错误，可以生成此事件的一个错误示例是打印机用完了纸张。

方法详细信息

printDataTransferCompleted

void printDataTransferCompleted(PrintJobEvent pje)
调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。接收到此事件之后，客户端不应假定已完全打印了该数据。如果未接收到此事件，则客户端必须等待终端事件（完成/取消/失败），然后再释放资源。

参数：
pje - 生成此事件的作业

printJobCompleted

void printJobCompleted(PrintJobEvent pje)
调用此方法来通知客户端，作业已成功完成。

参数：
pje - 生成此事件的作业

printJobFailed

void printJobFailed(PrintJobEvent pje)
调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。

参数：
pje - 生成此事件的作业

printJobCanceled

void printJobCanceled(PrintJobEvent pje)
调用此方法来通知客户端，作业已被用户或程序取消。

参数：
pje - 生成此事件的作业

printJobNoMoreEvents

void printJobNoMoreEvents(PrintJobEvent pje)
调用此方法来通知客户端，不需要再提供事件。生成此事件的原因之一是：作业已成功完成，但打印系统功能有限，无法验证此事件。如果未提供其他的终端事件（完成/失败/取消），则必须提供此事件。

参数：
pje - 生成此事件的作业

printJobRequiresAttention

void printJobRequiresAttention(PrintJobEvent pje)
调用此方法来通知客户端，发生了一个用户也许能够修复的错误，可以生成此事件的一个错误示例是打印机用完了纸张。

参数：
pje - 生成此事件的作业
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintServiceAttributeEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.print.event
类 PrintServiceAttributeEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.print.event.PrintEvent
            继承者  javax.print.event.PrintServiceAttributeEvent
所有已实现的接口：
Serializable
public class PrintServiceAttributeEvent
extends PrintEvent

类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
构造一个 PrintServiceAttributeEvent 对象。
方法摘要
PrintServiceAttributeSet | getAttributes() 确定已经更改的打印服务属性及其新值。
PrintService | getPrintService() 返回打印服务。
从类 javax.print.event.PrintEvent 继承的方法
toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrintServiceAttributeEvent

public PrintServiceAttributeEvent(PrintService source,
                                  PrintServiceAttributeSet attributes)
构造一个 PrintServiceAttributeEvent 对象。

参数：
source - 生成此事件的打印作业
attributes - 要报告的属性更改
抛出：
IllegalArgumentException - 如果 source 为 null。
方法详细信息

getPrintService

public PrintService getPrintService()
返回打印服务。

返回：
Print Service 对象。

getAttributes

public PrintServiceAttributeSet getAttributes()
确定已经更改的打印服务属性及其新值。

返回：
属性，包含已经更改的服务属性的新值。返回的集合是不可修改的。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrintServiceAttributeListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.print.event
接口 PrintServiceAttributeListener

public interface PrintServiceAttributeListener

此侦听器接口的实现连接到 PrintService，以便监视打印服务的状态。

要监视特定的作业，请参阅 PrintJobListener 和 PrintJobAttributeListener。

方法摘要
 void attributeUpdate(PrintServiceAttributeEvent psae)
调用此方法来通知侦听器关于打印服务中的事件。

方法详细信息

attributeUpdate

void attributeUpdate(PrintServiceAttributeEvent psae)
调用此方法来通知侦听器关于打印服务中的事件。该服务将在事件通知线程上调用此方法。在此回调中客户端不应执行太长时间的处理，否则会阻塞后续的事件通知。

参数：
psae - 要通知的事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.print.event (Java 2 Platform SE 6)

 javax.print.event
接口
PrintJobAttributeListener
PrintJobListener
PrintServiceAttributeListener
类
PrintEvent
PrintJobAdapter
PrintJobAttributeEvent
PrintJobEvent
PrintServiceAttributeEvent


javax.print.event (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.print.event

包 javax.print.event 包含事件类和侦听器接口。

请参见：
描述

接口摘要
PrintJobAttributeListener | 此接口的实现连接到 DocPrintJob，以监视与此打印作业关联的属性状态的更改。
PrintJobListener | 此侦听器接口的实现应该连接到 DocPrintJob，以监视打印机作业的状态。
PrintServiceAttributeListener | 此侦听器接口的实现连接到 PrintService，以便监视打印服务的状态。

类摘要
PrintEvent | 类 PrintEvent 是所有 Print Service API 事件的超类。
PrintJobAdapter | 接收打印作业事件的抽象适配器类。
PrintJobAttributeEvent | 类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
PrintJobEvent | 类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
PrintServiceAttributeEvent | 类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

软件包 javax.print.event 的描述

包 javax.print.event 包含事件类和侦听器接口。

它们可以用来监视打印服务（如打印机联机和脱机）和具体打印作业的进度。

请注意：在 javax.print API 中，只有方法中显式地记录 null 引用具有有意义的解释时，方法的 null 引用参数才是正确的。与之相反的用法是不正确的编码，可能立即或在稍后某一时间导致运行时异常。IllegalArgumentException 和 NullPointerException 是针对这种情况的典型的、可接受的运行时异常的示例。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.print.event 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print.event 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.print.event.PrintEvent
        • javax.print.event.PrintJobAttributeEvent
        • javax.print.event.PrintJobEvent
        • javax.print.event.PrintServiceAttributeEvent
    • javax.print.event.PrintJobAdapter (implements javax.print.event.PrintJobListener)

接口分层结构

  • javax.print.event.PrintJobAttributeListener
  • javax.print.event.PrintJobListener
  • javax.print.event.PrintServiceAttributeListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.print.event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.print.event
的使用

使用 javax.print.event 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 使用的 javax.print.event 中的类
PrintJobAttributeListener
此接口的实现连接到 DocPrintJob，以监视与此打印作业关联的属性状态的更改。
PrintJobListener
此侦听器接口的实现应该连接到 DocPrintJob，以监视打印机作业的状态。
PrintServiceAttributeListener
此侦听器接口的实现连接到 PrintService，以便监视打印服务的状态。

javax.print.event 使用的 javax.print.event 中的类
PrintEvent
类 PrintEvent 是所有 Print Service API 事件的超类。
PrintJobAttributeEvent
类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
PrintJobEvent
类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
PrintJobListener
此侦听器接口的实现应该连接到 DocPrintJob，以监视打印机作业的状态。
PrintServiceAttributeEvent
类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.event.PrintEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintEvent
的使用

使用 PrintEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintEvent 的使用

javax.print.event 中 PrintEvent 的子类
class | PrintJobAttributeEvent 类 PrintJobAttributeEvent 封装 PrintService 报告的事件，以便让客户端知道 PrintJob 的一个或多个打印属性已更改。
class | PrintJobEvent 类 PrintJobEvent 封装打印作业报告的常见事件，以便让侦听器知道 DocPrintJob 处理的进度。
class | PrintServiceAttributeEvent 类 PrintServiceAttributeEvent 封装 Print Service 实例报告的事件，以便让客户端知道打印服务状态的更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.event.PrintJobAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintJobAdapter
的使用

没有 javax.print.event.PrintJobAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.event.PrintJobAttributeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintJobAttributeEvent
的使用

使用 PrintJobAttributeEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintJobAttributeEvent 的使用

参数类型为 PrintJobAttributeEvent 的 javax.print.event 中的方法
 void PrintJobAttributeListener.attributeUpdate(PrintJobAttributeEvent pjae)
通知侦听器某些打印作业属性已更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.event.PrintJobAttributeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.event.PrintJobAttributeListener
的使用

使用 PrintJobAttributeListener 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintJobAttributeListener 的使用

参数类型为 PrintJobAttributeListener 的 javax.print 中的方法
void | DocPrintJob.addPrintJobAttributeListener(PrintJobAttributeListener listener, PrintJobAttributeSet attributes) 为指定属性中的更改注册一个侦听器。
void | DocPrintJob.removePrintJobAttributeListener(PrintJobAttributeListener listener) 移除此 PrintJob 的属性侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.event.PrintJobEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintJobEvent
的使用

使用 PrintJobEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintJobEvent 的使用

参数类型为 PrintJobEvent 的 javax.print.event 中的方法
void | PrintJobAdapter.printDataTransferCompleted(PrintJobEvent pje) 调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
void | PrintJobListener.printDataTransferCompleted(PrintJobEvent pje) 调用此方法来通知客户端，已成功地将数据传输到打印服务，客户端可以释放分配给该数据的本地资源。
void | PrintJobAdapter.printJobCanceled(PrintJobEvent pje) 调用此方法来通知客户端，作业已被用户或程序取消。
void | PrintJobListener.printJobCanceled(PrintJobEvent pje) 调用此方法来通知客户端，作业已被用户或程序取消。
void | PrintJobAdapter.printJobCompleted(PrintJobEvent pje) 调用此方法来通知客户端，作业已成功完成。
void | PrintJobListener.printJobCompleted(PrintJobEvent pje) 调用此方法来通知客户端，作业已成功完成。
void | PrintJobAdapter.printJobFailed(PrintJobEvent pje) 调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
void | PrintJobListener.printJobFailed(PrintJobEvent pje) 调用此方法来通知客户端，无法成功完成作业，必须重新提交该作业。
void | PrintJobAdapter.printJobNoMoreEvents(PrintJobEvent pje) 调用此方法来通知客户端，不需要再提供事件。
void | PrintJobListener.printJobNoMoreEvents(PrintJobEvent pje) 调用此方法来通知客户端，不需要再提供事件。
void | PrintJobAdapter.printJobRequiresAttention(PrintJobEvent pje) 调用此方法来通知客户端，可能会发生一些用户可纠正的问题（例如打印机缺纸）。
void | PrintJobListener.printJobRequiresAttention(PrintJobEvent pje) 调用此方法来通知客户端，发生了一个用户也许能够修复的错误，可以生成此事件的一个错误示例是打印机用完了纸张。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.event.PrintJobListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.event.PrintJobListener
的使用

使用 PrintJobListener 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 PrintJobListener 的使用

参数类型为 PrintJobListener 的 javax.print 中的方法
void | DocPrintJob.addPrintJobListener(PrintJobListener listener) 为此 PrintJob 执行期间所出现的事件注册一个侦听器。
void | DocPrintJob.removePrintJobListener(PrintJobListener listener) 移除此 PrintJob 的侦听器。

javax.print.event 中 PrintJobListener 的使用

实现 PrintJobListener 的 javax.print.event 中的类
 class PrintJobAdapter
接收打印作业事件的抽象适配器类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.event.PrintServiceAttributeEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.event.PrintServiceAttributeEvent
的使用

使用 PrintServiceAttributeEvent 的软件包
javax.print.event 包 javax.print.event 包含事件类和侦听器接口。

javax.print.event 中 PrintServiceAttributeEvent 的使用

参数类型为 PrintServiceAttributeEvent 的 javax.print.event 中的方法
 void PrintServiceAttributeListener.attributeUpdate(PrintServiceAttributeEvent psae)
调用此方法来通知侦听器关于打印服务中的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.event.PrintServiceAttributeListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.event.PrintServiceAttributeListener
的使用

使用 PrintServiceAttributeListener 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintServiceAttributeListener 的使用

参数类型为 PrintServiceAttributeListener 的 javax.print 中的方法
void | PrintService.addPrintServiceAttributeListener(PrintServiceAttributeListener listener) 为此 PrintService 上的事件注册一个侦听器。
void | PrintService.removePrintServiceAttributeListener(PrintServiceAttributeListener listener) 移除此 PrintService 的 PrintService 侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.AttributeException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.AttributeException
的使用

没有 javax.print.AttributeException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.CancelablePrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.CancelablePrintJob
的使用

没有 javax.print.CancelablePrintJob 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.Doc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.Doc
的使用

使用 Doc 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 Doc 的使用

实现 Doc 的 javax.print 中的类
 class SimpleDoc
此类是接口 Doc 的实现，可用于很多常见的打印请求中。

返回 Doc 的 javax.print 中的方法
 Doc MultiDoc.getDoc()
获取当前的 doc 对象。

参数类型为 Doc 的 javax.print 中的方法
 void DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes)
使用指定的作业属性打印文档。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor
的使用

使用 DocFlavor 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor 的使用

javax.print 中 DocFlavor 的子类
static class | DocFlavor.BYTE_ARRAY 类 DocFlavor.BYTE_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 数组 (byte[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.CHAR_ARRAY 类 DocFlavor.CHAR_ARRAY 提供了预定义的静态常量 DocFlavor 对象，例如使用字符数组 (char[]) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.INPUT_STREAM 类 DocFlavor.INPUT_STREAM 提供了预定义的静态常量 DocFlavor 对象，例如使用 byte 流 (java.io.InputStream) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.READER 类 DocFlavor.READER 提供了预定义的静态常量 DocFlavor 对象，例如使用字符流 (java.io.Reader) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.SERVICE_FORMATTED 类 DocFlavor.SERVICE_FORMATTED 提供了预定义的静态常量 DocFlavor 对象，例如用于服务格式化打印数据的 DocFlavor。
static class | DocFlavor.STRING 类 DocFlavor.STRING 提供了预定义的静态常量 DocFlavor 对象，例如使用字符串 (java.lang.String) 作为打印数据表示形式类的 DocFlavor。
static class | DocFlavor.URL 类 DocFlavor.URL 提供了预定义的静态常量 DocFlavor 对象。

返回 DocFlavor 的 javax.print 中的方法
DocFlavor | Doc.getDocFlavor() 确定此 doc 对象提供其部分打印数据所用的 DocFlavor。
DocFlavor | SimpleDoc.getDocFlavor() 确定其 doc 对象将提供其部分打印数据的 doc flavor。
DocFlavor[] | PrintService.getSupportedDocFlavors() 确定在设置此 PrintService 的作业时，客户端可以指定的打印数据格式。
abstract DocFlavor[] | StreamPrintServiceFactory.getSupportedDocFlavors() 查询该工厂，了解从此工厂所获得打印机可接受的 doc flavor。
DocFlavor[] | FlavorException.getUnsupportedFlavors() 返回不受支持的 flavor。

参数类型为 DocFlavor 的 javax.print 中的方法
abstract MultiDocPrintService[] | PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 应用程序不直接调用它。
abstract PrintService[] | PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes) 查找肯定可支持指定属性和 DocFlavor 组合的服务。
Object | PrintService.getSupportedAttributeValues(Class<? extends Attribute> category, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定类别中的打印属性值。
AttributeSet | PrintService.getUnsupportedAttributes(DocFlavor flavor, AttributeSet attributes) 标识在特定 DocFlavor 的上下文中打印请求不支持的属性。
boolean | PrintService.isAttributeValueSupported(Attribute attrval, DocFlavor flavor, AttributeSet attributes) 确定客户端在设置此 PrintService 的作业时，是否可以指定给定的打印属性值。
boolean | PrintService.isDocFlavorSupported(DocFlavor flavor) 确定此 PrintService 是否支持具体 DocFlavor。
static MultiDocPrintService[] | PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。
static PrintService[] | PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes) 查找能够打印指定 DocFlavor 的 PrintService。
static StreamPrintServiceFactory[] | StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType) 查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。

参数类型为 DocFlavor 的 javax.print 中的构造方法
SimpleDoc(Object printData, DocFlavor flavor, DocAttributeSet attributes)
构造具有指定打印数据、doc flavor 和 doc 属性集的 SimpleDoc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor.BYTE_ARRAY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.BYTE_ARRAY
的使用

使用 DocFlavor.BYTE_ARRAY 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.BYTE_ARRAY 的使用

声明为 DocFlavor.BYTE_ARRAY 的 javax.print 中的字段
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。
static DocFlavor.BYTE_ARRAY | DocFlavor.BYTE_ARRAY.TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "[B"（byte 数组）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor.INPUT_STREAM 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.INPUT_STREAM
的使用

使用 DocFlavor.INPUT_STREAM 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.INPUT_STREAM 的使用

声明为 DocFlavor.INPUT_STREAM 的 javax.print 中的字段
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。
static DocFlavor.INPUT_STREAM | DocFlavor.INPUT_STREAM.TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.io.InputStream"（byte 流）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor.URL 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.URL
的使用

使用 DocFlavor.URL 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.URL 的使用

声明为 DocFlavor.URL 的 javax.print 中的字段
static DocFlavor.URL | DocFlavor.URL.AUTOSENSE MIME 类型 = "application/octet-stream"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.GIF MIME 类型 = "image/gif"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.JPEG MIME 类型 = "image/jpeg"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.PCL MIME 类型 = "application/vnd.hp-PCL"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.PDF MIME 类型 = "application/pdf"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.PNG MIME 类型 = "image/png"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.POSTSCRIPT MIME 类型 = "application/postscript"，打印数据表示形式类名 = "java.net.URL" 的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_HOST MIME 类型 = "text/html"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_US_ASCII MIME 类型 = "text/html; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_16 MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_16BE MIME 类型 = "text/html; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_16LE MIME 类型 = "text/html; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_HTML_UTF_8 MIME 类型 = "text/html; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_HOST MIME 类型 = "text/plain"（以主机平台编码形式编码）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_US_ASCII MIME 类型 = "text/plain; charset=us-ascii"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_16 MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = java.net.URL""（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_16BE MIME 类型 = "text/plain; charset=utf-16be"（big-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_16LE MIME 类型 = "text/plain; charset=utf-16le"（little-endian 字节顺序），打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。
static DocFlavor.URL | DocFlavor.URL.TEXT_PLAIN_UTF_8 MIME 类型 = "text/plain; charset=utf-8"，打印数据表示形式类名 = "java.net.URL"（byte 流）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor.CHAR_ARRAY 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.CHAR_ARRAY
的使用

使用 DocFlavor.CHAR_ARRAY 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.CHAR_ARRAY 的使用

声明为 DocFlavor.CHAR_ARRAY 的 javax.print 中的字段
static DocFlavor.CHAR_ARRAY | DocFlavor.CHAR_ARRAY.TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。
static DocFlavor.CHAR_ARRAY | DocFlavor.CHAR_ARRAY.TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "[C"（字符数组）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor.STRING 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.STRING
的使用

使用 DocFlavor.STRING 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.STRING 的使用

声明为 DocFlavor.STRING 的 javax.print 中的字段
static DocFlavor.STRING | DocFlavor.STRING.TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。
static DocFlavor.STRING | DocFlavor.STRING.TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.lang.String" 的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor.READER 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.READER
的使用

使用 DocFlavor.READER 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.READER 的使用

声明为 DocFlavor.READER 的 javax.print 中的字段
static DocFlavor.READER | DocFlavor.READER.TEXT_HTML MIME 类型 = "text/html; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。
static DocFlavor.READER | DocFlavor.READER.TEXT_PLAIN MIME 类型 = "text/plain; charset=utf-16"，打印数据表示形式类名 = "java.io.Reader"（字符流）的 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.DocFlavor.SERVICE_FORMATTED 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.DocFlavor.SERVICE_FORMATTED
的使用

使用 DocFlavor.SERVICE_FORMATTED 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 DocFlavor.SERVICE_FORMATTED 的使用

声明为 DocFlavor.SERVICE_FORMATTED 的 javax.print 中的字段
static DocFlavor.SERVICE_FORMATTED | DocFlavor.SERVICE_FORMATTED.PAGEABLE 打印数据表示形式类名 = "java.awt.print.Pageable"（pageable 对象）的服务格式化打印数据 DocFlavor。
static DocFlavor.SERVICE_FORMATTED | DocFlavor.SERVICE_FORMATTED.PRINTABLE 打印数据表示形式类名 = "java.awt.print.Printable"（printable 对象）的服务格式化打印数据 DocFlavor。
static DocFlavor.SERVICE_FORMATTED | DocFlavor.SERVICE_FORMATTED.RENDERABLE_IMAGE 打印数据表示形式类名 = "java.awt.image.renderable.RenderableImage"（RenderableImage 对象）的服务格式化打印数据 DocFlavor。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.DocPrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.DocPrintJob
的使用

使用 DocPrintJob 的软件包
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。

javax.print 中 DocPrintJob 的使用

javax.print 中 DocPrintJob 的子接口
interface | CancelablePrintJob 打印应用程序使用此接口来取消打印作业。
interface | MultiDocPrintJob 从 MultiDocPrintService 中获得，MultiDocPrintJob 可使用作业属性集以单个 PrintJob 的形式打印指定的文档集合。

返回 DocPrintJob 的 javax.print 中的方法
 DocPrintJob PrintService.createPrintJob()
创建并返回一个 PrintJob，它应能够处理取自任意受支持的 docflavor 的数据。

javax.print.event 中 DocPrintJob 的使用

返回 DocPrintJob 的 javax.print.event 中的方法
DocPrintJob | PrintJobAttributeEvent.getPrintJob() 确定此打印作业事件适合的 Print Job。
DocPrintJob | PrintJobEvent.getPrintJob() 确定此打印作业事件适合的 DocPrintJob。

参数类型为 DocPrintJob 的 javax.print.event 中的构造方法
PrintJobAttributeEvent(DocPrintJob source, PrintJobAttributeSet attributes)
构造一个 PrintJobAttributeEvent 对象。
PrintJobEvent(DocPrintJob source, int reason)
构造一个 PrintJobEvent 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.FlavorException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.FlavorException
的使用

没有 javax.print.FlavorException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.MultiDoc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.MultiDoc
的使用

使用 MultiDoc 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 MultiDoc 的使用

返回 MultiDoc 的 javax.print 中的方法
 MultiDoc MultiDoc.next()
转到包含 doc 对象序列中下一个 doc 对象的 multidoc 对象。

参数类型为 MultiDoc 的 javax.print 中的方法
 void MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes)
使用指定的作业属性打印 MultiDoc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.MultiDocPrintJob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.MultiDocPrintJob
的使用

使用 MultiDocPrintJob 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 MultiDocPrintJob 的使用

返回 MultiDocPrintJob 的 javax.print 中的方法
 MultiDocPrintJob MultiDocPrintService.createMultiDocPrintJob()
创建一个可打印 multiDoc 的作业。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.MultiDocPrintService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.MultiDocPrintService
的使用

使用 MultiDocPrintService 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 MultiDocPrintService 的使用

返回 MultiDocPrintService 的 javax.print 中的方法
abstract MultiDocPrintService[] | PrintServiceLookup.getMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 应用程序不直接调用它。
static MultiDocPrintService[] | PrintServiceLookup.lookupMultiDocPrintServices(DocFlavor[] flavors, AttributeSet attributes) 查找能够打印 MultiDoc（包含所有指定的 doc flavor）的 MultiDoc PrintService。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.PrintException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.PrintException
的使用

使用 PrintException 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintException 的使用

抛出 PrintException 的 javax.print 中的方法
void | CancelablePrintJob.cancel() 停止对打印作业的进一步处理。
void | DocPrintJob.print(Doc doc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印文档。
void | MultiDocPrintJob.print(MultiDoc multiDoc, PrintRequestAttributeSet attributes) 使用指定的作业属性打印 MultiDoc。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.PrintService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.PrintService
的使用

使用 PrintService 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。
javax.print.event | 包 javax.print.event 包含事件类和侦听器接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

java.awt.print 中 PrintService 的使用

返回 PrintService 的 java.awt.print 中的方法
PrintService | PrinterJob.getPrintService() 返回此打印机作业的服务（打印机）。
static PrintService[] | PrinterJob.lookupPrintServices() 查找 2D 打印服务的便捷方法。

参数类型为 PrintService 的 java.awt.print 中的方法
 void PrinterJob.setPrintService(PrintService service)
将此 PrinterJob 与新的 PrintService 关联。

javax.print 中 PrintService 的使用

javax.print 中 PrintService 的子接口
 interface MultiDocPrintService
接口 MultiPrintService 是 MultiDocPrintJob 的工厂。

实现 PrintService 的 javax.print 中的类
 class StreamPrintService
此类扩展了 PrintService 并表示这样一种 PrintService，即以不同的格式向客户端提供的输出流打印数据。

返回 PrintService 的 javax.print 中的方法
abstract PrintService | PrintServiceLookup.getDefaultPrintService() 应用程序不直接调用它。
PrintService | DocPrintJob.getPrintService() 确定此 PrintJob 对象所绑定到的 PrintService 对象。
abstract PrintService[] | PrintServiceLookup.getPrintServices() 应用程序不直接调用它。
abstract PrintService[] | PrintServiceLookup.getPrintServices(DocFlavor flavor, AttributeSet attributes) 查找肯定可支持指定属性和 DocFlavor 组合的服务。
static PrintService | PrintServiceLookup.lookupDefaultPrintService() 查找此环境的默认 PrintService。
static PrintService[] | PrintServiceLookup.lookupPrintServices(DocFlavor flavor, AttributeSet attributes) 查找能够打印指定 DocFlavor 的 PrintService。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。

参数类型为 PrintService 的 javax.print 中的方法
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。
static PrintService | ServiceUI.printDialog(GraphicsConfiguration gc, int x, int y, PrintService[] services, PrintService defaultService, DocFlavor flavor, PrintRequestAttributeSet attributes) 为用户提供一个选择 PrintService（打印机）的对话框。
static boolean | PrintServiceLookup.registerService(PrintService service) 允许应用程序直接注册一个实现了 PrintService 的类的实例。

javax.print.event 中 PrintService 的使用

返回 PrintService 的 javax.print.event 中的方法
 PrintService PrintServiceAttributeEvent.getPrintService()
返回打印服务。

参数类型为 PrintService 的 javax.print.event 中的构造方法
PrintServiceAttributeEvent(PrintService source, PrintServiceAttributeSet attributes)
构造一个 PrintServiceAttributeEvent 对象。

javax.swing 中 PrintService 的使用

参数类型为 PrintService 的 javax.swing 中的方法
 boolean JTable.print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service)
打印此 JTable。

javax.swing.text 中 PrintService 的使用

参数类型为 PrintService 的 javax.swing.text 中的方法
 boolean JTextComponent.print(MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintService service, PrintRequestAttributeSet attributes, boolean interactive)
打印此 JTextComponent 的内容。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.PrintServiceLookup 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.PrintServiceLookup
的使用

使用 PrintServiceLookup 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 PrintServiceLookup 的使用

参数类型为 PrintServiceLookup 的 javax.print 中的方法
static boolean PrintServiceLookup.registerServiceProvider(PrintServiceLookup sp)
允许应用程序显式地注册一个实现了查找服务的类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.ServiceUI 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.ServiceUI
的使用

没有 javax.print.ServiceUI 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.ServiceUIFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.ServiceUIFactory
的使用

使用 ServiceUIFactory 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 ServiceUIFactory 的使用

返回 ServiceUIFactory 的 javax.print 中的方法
 ServiceUIFactory PrintService.getServiceUIFactory()
返回 UI 组件的工厂方法，该组件允许用户通过各种角色与服务交互。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.SimpleDoc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.SimpleDoc
的使用

没有 javax.print.SimpleDoc 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.StreamPrintService 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.StreamPrintService
的使用

使用 StreamPrintService 的软件包
javax.print 为 JavaTM Print Service API 提供了主要类和接口。

javax.print 中 StreamPrintService 的使用

返回 StreamPrintService 的 javax.print 中的方法
abstract  StreamPrintService StreamPrintServiceFactory.getPrintService(OutputStream out)
返回可打印到指定输出流的 StreamPrintService。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.print.StreamPrintServiceFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.print.StreamPrintServiceFactory
的使用

使用 StreamPrintServiceFactory 的软件包
java.awt.print | 为通用的打印 API 提供类和接口。
javax.print | 为 JavaTM Print Service API 提供了主要类和接口。

java.awt.print 中 StreamPrintServiceFactory 的使用

返回 StreamPrintServiceFactory 的 java.awt.print 中的方法
static StreamPrintServiceFactory[] PrinterJob.lookupStreamPrintServices(String mimeType)
定位可以成像 2D 图形的流打印服务工厂的便捷方法。

javax.print 中 StreamPrintServiceFactory 的使用

返回 StreamPrintServiceFactory 的 javax.print 中的方法
static StreamPrintServiceFactory[] StreamPrintServiceFactory.lookupStreamPrintServiceFactories(DocFlavor flavor, String outputMimeType)
查找 PrintService 的工厂，PrintJob 可使用它来输出数据流，数据格式由 flavor 指定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.print.URIException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.print.URIException
的使用

没有 javax.print.URIException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


PortableRemoteObject (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.rmi
类 PortableRemoteObject

java.lang.Object
    继承者  javax.rmi.PortableRemoteObject

public class PortableRemoteObject
extends Object

服务器实现对象可以从 javax.rmi.PortableRemoteObject 继承，也可以实现一个远程接口，然后使用 exportObject 方法将其本身注册为服务器对象。toStub 方法采用服务器实现，并返回一个可用于访问该服务器对象的 stub。连接方法使 Remote 对象准备好进行远程通信。unexportObject 方法用于注销服务器对象，使之可用于垃圾回收。narrow 方法采用一个对象引用或抽象接口类型，并尝试使其变窄以适合给定的接口。如果该操作成功，结果将是一个指定类型的对象，否则将抛出一个异常。

构造方法摘要
protected PortableRemoteObject()
通过调用 exportObject(this) 初始化该对象。
方法摘要
static void | connect(Remote target, Remote source) 使 Remote 对象准备好进行远程通信。
static void | exportObject(Remote obj) 准备服务器对象，以接收远程调用。
static Object | narrow(Object narrowFrom, Class narrowTo) 检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。
static Remote | toStub(Remote obj) 返回给定服务器对象的 stub。
static void | unexportObject(Remote obj) 从运行时注销服务器对象，允许对象用于垃圾回收。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PortableRemoteObject

protected PortableRemoteObject()
                        throws RemoteException
通过调用 exportObject(this) 初始化该对象。

抛出：
RemoteException - 如果导出失败。
方法详细信息

exportObject

public static void exportObject(Remote obj)
                         throws RemoteException
准备服务器对象，以接收远程调用。注意，PortableRemoteObject 的子类不需要调用此方法，因为它由构造器调用。

参数：
obj - 要导出的服务器对象。
抛出：
RemoteException - 如果导出失败。

toStub

public static Remote toStub(Remote obj)
                     throws NoSuchObjectException
返回给定服务器对象的 stub。

参数：
obj - 需要 stub 的服务器对象。必须为 PortableRemoteObject 的一个子类，或者以前已经是调用 exportObject(java.rmi.Remote) 的目标。
返回：
该对象的最常派生的 stub。
抛出：
NoSuchObjectException - 如果找不到给定服务器对象的 stub。

unexportObject

public static void unexportObject(Remote obj)
                           throws NoSuchObjectException
从运行时注销服务器对象，允许对象用于垃圾回收。

参数：
obj - 要撤消导出的对象。
抛出：
NoSuchObjectException - 如果当前未导出远程对象。

narrow

public static Object narrow(Object narrowFrom,
                            Class narrowTo)
                     throws ClassCastException
检查以确保远程或抽象接口类型的对象可以强制转换为所需的类型。

参数：
narrowFrom - 要检查的对象。
narrowTo - 所需的类型。
返回：
可以强制转换为所需类型的对象。
抛出：
ClassCastException - 如果 narrowFrom 不能强制转换为 narrowTo。

connect

public static void connect(Remote target,
                           Remote source)
                    throws RemoteException
使 Remote 对象准备好进行远程通信。在远程方法调用上，当对象作为一个参数发送或接收时，这通常是隐式发生的，但是在某些情况下，通过进行显式调用执行此操作较为有用。有关更多信息，请参阅 Stub#connect 方法。

参数：
target - 要连接的对象。
source - 以前连接的对象。
抛出：
RemoteException - 如果 source 未连接，或者如果 target 已经连接到与 source 不同的 ORB。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.rmi (Java 2 Platform SE 6)

 javax.rmi
类
PortableRemoteObject


javax.rmi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.rmi

包含 RMI-IIOP 的用户 API。

请参见：
描述

类摘要
PortableRemoteObject 服务器实现对象可以从 javax.rmi.PortableRemoteObject 继承，也可以实现一个远程接口，然后使用 exportObject 方法将其本身注册为服务器对象。

软件包 javax.rmi 的描述

包含 RMI-IIOP 的用户 API。这些 API 供 RMI-IIOP 应用程序使用，并在 IIOP 或 JRMP 上运行时提等效的语法。另请参阅 javax.rmi.CORBA 包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.rmi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.rmi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.rmi.PortableRemoteObject
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.rmi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.rmi
的使用

没有 javax.rmi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ClassDesc (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
类 ClassDesc

java.lang.Object
    继承者  javax.rmi.CORBA.ClassDesc
所有已实现的接口：
Serializable
public class ClassDesc
extends Object
implements Serializable

此类用于对 IIOP 上的 java.lang.Class 对象进行编组。

另请参见：
序列化表格

构造方法摘要
ClassDesc()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ClassDesc

public ClassDesc()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


PortableRemoteObjectDelegate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
接口 PortableRemoteObjectDelegate

public interface PortableRemoteObjectDelegate

支持 PortableRemoteObject 中方法实现的委托。委托是类的单一实例，它实现此接口并提供 javax.rmi.PortableRemoteObject 的所有方法的替代实现。 通过提供委托的类名称作为 javax.rmi.CORBA.PortableRemoteObjectClass 系统属性的值启用委托。

另请参见：
PortableRemoteObject

方法摘要
 void connect(Remote target, Remote source)
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。
 void exportObject(Remote obj)
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。
 Object narrow(Object narrowFrom, Class narrowTo)
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。
 Remote toStub(Remote obj)
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。
 void unexportObject(Remote obj)
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。

方法详细信息

exportObject

void exportObject(Remote obj)
                  throws RemoteException
PortableRemoteObject.exportObject(java.rmi.Remote) 的委托调用。

抛出：
RemoteException

toStub

Remote toStub(Remote obj)
              throws NoSuchObjectException
PortableRemoteObject.toStub(java.rmi.Remote) 的委托调用。

抛出：
NoSuchObjectException

unexportObject

void unexportObject(Remote obj)
                    throws NoSuchObjectException
PortableRemoteObject.unexportObject(java.rmi.Remote) 的委托调用。

抛出：
NoSuchObjectException

narrow

Object narrow(Object narrowFrom,
              Class narrowTo)
              throws ClassCastException
PortableRemoteObject.narrow(java.lang.Object, java.lang.Class) 的委托调用。

抛出：
ClassCastException

connect

void connect(Remote target,
             Remote source)
             throws RemoteException
PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote) 的委托调用。

抛出：
RemoteException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Stub (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
类 Stub

java.lang.Object
    继承者  org.omg.CORBA.portable.ObjectImpl
        继承者  org.omg.CORBA_2_3.portable.ObjectImpl
            继承者  javax.rmi.CORBA.Stub
所有已实现的接口：
Serializable, Object
直接已知子类：
_Remote_Stub
public abstract class Stub
extends ObjectImpl
implements Serializable

必须从其继承所有 RMI-IIOP stub 的基类。

另请参见：
序列化表格

构造方法摘要
Stub()
方法摘要
void | connect(ORB orb) 将此 stub 连接到 ORB。
boolean | equals(Object obj) 比较两个 stub 的相等性。
int | hashCode() 返回对象的哈希码值，对于表示同一远程对象的所有 stub，其哈希码值是相等的。
String | toString() 返回此 stub 的字符串表示形式。
从类 org.omg.CORBA_2_3.portable.ObjectImpl 继承的方法
_get_codebase
从类 org.omg.CORBA.portable.ObjectImpl 继承的方法
_create_request, _create_request, _duplicate, _get_delegate, _get_domain_managers, _get_interface_def, _get_policy, _hash, _ids, _invoke, _is_a, _is_equivalent, _is_local, _non_existent, _orb, _release, _releaseReply, _request, _request, _servant_postinvoke, _servant_preinvoke, _set_delegate, _set_policy_override
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Stub

public Stub()
方法详细信息

hashCode

public int hashCode()
返回对象的哈希码值，对于表示同一远程对象的所有 stub，其哈希码值是相等的。

覆盖：
类 ObjectImpl 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object obj)
比较两个 stub 的相等性。在用于比较表示同一远程对象的 stub 时返回 true，否则返回 false。

覆盖：
类 ObjectImpl 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 变量相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回此 stub 的字符串表示形式。对于表示同一远程对象的所有 stub，返回相同的字符串。

覆盖：
类 ObjectImpl 中的 toString
返回：
此 stub 的字符串表示形式。

connect

public void connect(ORB orb)
             throws RemoteException
将此 stub 连接到 ORB。在反序列化 stub 后要求此操作，但在 ORB 流对其取消屏蔽后不要求此操作。如果未连接的 stub 被传递到 ORB 流进行编组，则将其隐式连接到该 ORB。应用程序代码不应直接调用此方法，但应调用可移植包装器方法 PortableRemoteObject.connect(java.rmi.Remote, java.rmi.Remote)。

参数：
orb - 要连接到的 ORB。
抛出：
RemoteException - 如果 stub 已经连接到另一个 ORB，或者如果 stub 不表示一个导出的远程对象或本地对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StubDelegate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
接口 StubDelegate

public interface StubDelegate

支持 Stub 中方法实现的委托。委托是类的实例，此类实现此接口并提供 javax.rmi.CORBA.Stub 的所有方法的替代实现。如果启用了委托，则每个 stub 都有一个关联的委托。 通过提供委托的类名称作为 javax.rmi.CORBA.StubClass 系统属性的值来启用委托。

另请参见：
Stub

方法摘要
 void connect(Stub self, ORB orb)
Stub.connect(org.omg.CORBA.ORB) 的委托调用。
 boolean equals(Stub self, Object obj)
Stub.equals(java.lang.Object) 的委托调用。
 int hashCode(Stub self)
Stub.hashCode() 的委托调用。
 void readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。
 String toString(Stub self)
Stub.toString() 的委托调用。
 void writeObject(Stub self, ObjectOutputStream s)
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

方法详细信息

hashCode

int hashCode(Stub self)
Stub.hashCode() 的委托调用。

equals

boolean equals(Stub self,
               Object obj)
Stub.equals(java.lang.Object) 的委托调用。

toString

String toString(Stub self)
Stub.toString() 的委托调用。

connect

void connect(Stub self,
             ORB orb)
             throws RemoteException
Stub.connect(org.omg.CORBA.ORB) 的委托调用。

抛出：
RemoteException

readObject

void readObject(Stub self,
                ObjectInputStream s)
                throws IOException,
                       ClassNotFoundException
Stub.readObject(java.io.ObjectInputStream) 的委托调用。

抛出：
IOException
ClassNotFoundException

writeObject

void writeObject(Stub self,
                 ObjectOutputStream s)
                 throws IOException
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

抛出：
IOException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Tie (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
接口 Tie

所有超级接口：
InvokeHandler
public interface Tie
extends InvokeHandler

定义所有 RMI-IIOP 服务器端 tie 必须实现的方法。

方法摘要
void | deactivate() 取消激活此 tie 表示的目标对象。
Remote | getTarget() 返回此 tie 的目标。
ORB | orb() 返回此 tie 的 ORB。
void | orb(ORB orb) 设置此 tie 的 ORB。
void | setTarget(Remote target) 由 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 调用以设置此 tie 的目标。
Object | thisObject() 返回此 tie 表示的目标对象的对象引用。
从接口 org.omg.CORBA.portable.InvokeHandler 继承的方法
_invoke

方法详细信息

thisObject

Object thisObject()
返回此 tie 表示的目标对象的对象引用。

返回：
此目标对象的对象引用。

deactivate

void deactivate()
                throws NoSuchObjectException
取消激活此 tie 表示的目标对象。

抛出：
NoSuchObjectException

orb

ORB orb()
返回此 tie 的 ORB。

返回：
ORB。

orb

void orb(ORB orb)
设置此 tie 的 ORB。

参数：
orb - 该 ORB。

setTarget

void setTarget(Remote target)
由 Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 调用以设置此 tie 的目标。

参数：
target - 用作此 tie 的目标的对象。

getTarget

Remote getTarget()
返回此 tie 的目标。

返回：
该目标。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Util (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
类 Util

java.lang.Object
    继承者  javax.rmi.CORBA.Util

public class Util
extends Object

提供可以由 stub 和 tie 用于执行公共操作的实用方法。

方法摘要
static Object | copyObject(Object obj, ORB orb) 复制或连接一个对象。
static Object[] | copyObjects(Object[] obj, ORB orb) 复制或连接一个对象数组。
static ValueHandler | createValueHandler() 返回实现 ValueHandler 接口的类的单一实例。
static String | getCodebase(Class clz) 返回给定类的代码基（如果存在）。
static Tie | getTie(Remote target) 返回给定目标对象的 tie（如果存在）。
static boolean | isLocal(Stub stub) isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。
static Class | loadClass(String className, String remoteCodebase, ClassLoader loader) 为指定的类返回一个类实例。
static RemoteException | mapSystemException(SystemException ex) 将 SystemException 映射到 RemoteException。
static Object | readAny(InputStream in) 将 java.lang.Object 作为 CORBA any 读取。
static void | registerTarget(Tie tie, Remote target) 为 tie 注册一个目标。
static void | unexportObject(Remote target) 从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。
static RemoteException | wrapException(Throwable orig) 包装由实现方法抛出的异常。
static void | writeAbstractObject(OutputStream out, Object obj) 将 java.lang.Object 作为一个值或 CORBA Object 写入。
static void | writeAny(OutputStream out, Object obj) 将 any java.lang.Object 作为 CORBA any 写入。
static void | writeRemoteObject(OutputStream out, Object obj) 将 java.lang.Object 作为 CORBA Object 写入。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

mapSystemException

public static RemoteException mapSystemException(SystemException ex)
将 SystemException 映射到 RemoteException。

参数：
ex - 要映射的 SystemException。
返回：
映射的异常。

writeAny

public static void writeAny(OutputStream out,
                            Object obj)
将 any java.lang.Object 作为 CORBA any 写入。

参数：
out - 要写入 any 的流。
obj - 要写入为 any 的对象。

readAny

public static Object readAny(InputStream in)
将 java.lang.Object 作为 CORBA any 读取。

参数：
in - 从中读取 any 的流。
返回：
从流读取的 Object。

writeRemoteObject

public static void writeRemoteObject(OutputStream out,
                                     Object obj)
将 java.lang.Object 作为 CORBA Object 写入。如果 obj 是导出的 RMI-IIOP 服务器对象，则查找 tie 并传递到 obj，然后写入 out.write_Object(org.omg.CORBA.Object)。如果 obj 是 CORBA Object，则将其写入到 out.write_Object(org.omg.CORBA.Object)。

参数：
out - 要将 Object 写入的流。
obj - 要写入的对象。

writeAbstractObject

public static void writeAbstractObject(OutputStream out,
                                       Object obj)
将 java.lang.Object 作为一个值或 CORBA Object 写入。如果 obj 是一个值对象或者是一个 stub 对象，则将其写入到 out.write_abstract_interface(java.lang.Object)。如果 obj 是导出的 RMI-IIOP 服务器对象，则查找 tie 并传递到 obj，然后写入到 out.write_abstract_interface(java.lang.Object)。

参数：
out - 要写入 Object 的流。
obj - 要写入的对象。

registerTarget

public static void registerTarget(Tie tie,
                                  Remote target)
为 tie 注册一个目标。将 tie 添加到内部表并对 tie 对象调用 Tie.setTarget(java.rmi.Remote)。

参数：
tie - 要注册的 tie。
target - tie 的目标。

unexportObject

public static void unexportObject(Remote target)
                           throws NoSuchObjectException
从内部表中移除关联的 tie，并调用 Tie.deactivate() 以取消激活该对象。

参数：
target - 要撤消导出的对象。
抛出：
NoSuchObjectException

getTie

public static Tie getTie(Remote target)
返回给定目标对象的 tie（如果存在）。

返回：
tie，如果没有为给定目标注册 tie，则返回 null。

createValueHandler

public static ValueHandler createValueHandler()
返回实现 ValueHandler 接口的类的单一实例。

返回：
实现 ValueHandler 接口的类。

getCodebase

public static String getCodebase(Class clz)
返回给定类的代码基（如果存在）。

参数：
clz - 为其获取代码基的类。
返回：
URL 的空格分隔的列表，或者为 null。

loadClass

public static Class loadClass(String className,
                              String remoteCodebase,
                              ClassLoader loader)
                       throws ClassNotFoundException
为指定的类返回一个类实例。

此方法的规范是“Java 到 IDL 语言的映射关系”ptc/00-01-06。

在 Java SE 平台上，此方法的工作方式如下：

  • 在调用堆栈上查找第一个非 null 的 ClassLoader，并使用此 ClassLoader 尝试加载类。
  • 如果第一步失败，并且如果 remoteCodebase 为非 null，且 useCodebaseOnly 为 false，则调用 java.rmi.server.RMIClassLoader.loadClass(remoteCodebase, className)。
  • 如果 remoteCodebase 为 null 或 useCodebaseOnly 为 true，则调用 java.rmi.server.RMIClassLoader.loadClass(className)。
  • 如果通过步骤 1、2 或 3 没有成功加载类，并且 loader 为非 null，则调用 loader.loadClass(className)。
  • 如果通过步骤 1、2、3 或 4 成功加载类，则返回加载的类，否则抛出 ClassNotFoundException。

    参数：
    className - 类名。
    remoteCodebase - 可能从中发现类的空格分隔的 URL 列表。可以为 null。
    loader - 在所有其他方法失败时可以用来加载类的 ClassLoader。
    返回：
    表示加载的类的 Class 对象。
    抛出：
    ClassNotFoundException - 如果不能加载类。

isLocal

public static boolean isLocal(Stub stub)
                       throws RemoteException
isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。 如果通过本地伺服器实现特定对象，并因此使用本地调用 API，则提供 _is_local() 方法以便能够确定 stub。

参数：
stub - 要测试的 stub。
返回：
如果具体化对象的伺服器与 stub 位于同一个进程，并且它们共享同一个 ORB 实例，则 _is_local() 方法返回 true。否则，_is_local() 方法返回 false。_is_local() 的默认行为是返回 false。
抛出：
RemoteException - 如果 Java 到 IDL 的规范 没有指定导致抛出 RemoteException 的条件。

wrapException

public static RemoteException wrapException(Throwable orig)
包装由实现方法抛出的异常。它返回相应的客户端异常。

参数：
orig - 要包装的异常。
返回：
包装的异常。

copyObjects

public static Object[] copyObjects(Object[] obj,
                                   ORB orb)
                            throws RemoteException
复制或连接一个对象数组。由本地 stub 使用以复制任意数量的实际参数，根据需要保留共享的交叉参数以支持 RMI 语义。

参数：
obj - 要复制或连接的对象。
orb - 该 ORB。
返回：
复制或连接的对象。
抛出：
RemoteException - 如果不能复制或连接任何对象。

copyObject

public static Object copyObject(Object obj,
                                ORB orb)
                         throws RemoteException
复制或连接一个对象。由本地 stub 使用，以复制实际参数、结果对象或异常。

参数：
obj - 要复制的对象。
orb - 该 ORB。
返回：
复制或连接的对象。
抛出：
RemoteException - 如果不能复制或连接该对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UtilDelegate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
接口 UtilDelegate

public interface UtilDelegate

支持 Util 中方法实现的委托。委托是类的单一实例，它实现此接口，并提供 javax.rmi.CORBA.Util 的所有方法的替代实现。 通过提供委托的类名称作为 javax.rmi.CORBA.UtilClass 系统属性的值来启用委托。

另请参见：
Util

方法摘要
 Object copyObject(Object obj, ORB orb)
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。
 Object[] copyObjects(Object[] obj, ORB orb)
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。
 ValueHandler createValueHandler()
Util.createValueHandler() 的委托调用。
 String getCodebase(Class clz)
Util.getCodebase(java.lang.Class) 的委托调用。
 Tie getTie(Remote target)
Util.getTie(java.rmi.Remote) 的委托调用。
 boolean isLocal(Stub stub)
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。
 Class loadClass(String className, String remoteCodebase, ClassLoader loader)
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。
 RemoteException mapSystemException(SystemException ex)
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。
 Object readAny(InputStream in)
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。
 void registerTarget(Tie tie, Remote target)
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。
 void unexportObject(Remote target)
Util.unexportObject(java.rmi.Remote) 的委托调用。
 RemoteException wrapException(Throwable obj)
Util.wrapException(java.lang.Throwable) 的委托调用。
 void writeAbstractObject(OutputStream out, Object obj)
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
 void writeAny(OutputStream out, Object obj)
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。
 void writeRemoteObject(OutputStream out, Object obj)
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

方法详细信息

mapSystemException

RemoteException mapSystemException(SystemException ex)
Util.mapSystemException(org.omg.CORBA.SystemException) 的委托调用。

writeAny

void writeAny(OutputStream out,
              Object obj)
Util.writeAny(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

readAny

Object readAny(InputStream in)
Util.readAny(org.omg.CORBA.portable.InputStream) 的委托调用。

writeRemoteObject

void writeRemoteObject(OutputStream out,
                       Object obj)
Util.writeRemoteObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

writeAbstractObject

void writeAbstractObject(OutputStream out,
                         Object obj)
Util.writeAbstractObject(org.omg.CORBA.portable.OutputStream, java.lang.Object) 的委托调用。

registerTarget

void registerTarget(Tie tie,
                    Remote target)
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。

unexportObject

void unexportObject(Remote target)
                    throws NoSuchObjectException
Util.unexportObject(java.rmi.Remote) 的委托调用。

抛出：
NoSuchObjectException

getTie

Tie getTie(Remote target)
Util.getTie(java.rmi.Remote) 的委托调用。

createValueHandler

ValueHandler createValueHandler()
Util.createValueHandler() 的委托调用。

getCodebase

String getCodebase(Class clz)
Util.getCodebase(java.lang.Class) 的委托调用。

loadClass

Class loadClass(String className,
                String remoteCodebase,
                ClassLoader loader)
                throws ClassNotFoundException
Util.loadClass(java.lang.String, java.lang.String, java.lang.ClassLoader) 的委托调用。

抛出：
ClassNotFoundException

isLocal

boolean isLocal(Stub stub)
                throws RemoteException
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。

抛出：
RemoteException

wrapException

RemoteException wrapException(Throwable obj)
Util.wrapException(java.lang.Throwable) 的委托调用。

copyObject

Object copyObject(Object obj,
                  ORB orb)
                  throws RemoteException
Util.copyObject(java.lang.Object, org.omg.CORBA.ORB) 的委托调用。

抛出：
RemoteException

copyObjects

Object[] copyObjects(Object[] obj,
                     ORB orb)
                     throws RemoteException
Util.copyObjects(java.lang.Object[], org.omg.CORBA.ORB) 的委托调用。

抛出：
RemoteException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
接口 ValueHandler

所有已知子接口：
ValueHandlerMultiFormat
public interface ValueHandler

定义允许序列化 Java 对象到 GIOP 流或从其序列化 Java 对象的方法。

方法摘要
String | getRMIRepositoryID(Class clz) 返回给定 Java 类的 CORBA RepositoryId。
RunTime | getRunTimeCodeBase() 返回此 ValueHandler 的 CodeBase。
boolean | isCustomMarshaled(Class clz) 指示给定的类是执行自定义编组还是默认编组。
Serializable | readValue(InputStream in, int offset, Class clz, String repositoryID, RunTime sender) 使用 Java 语义从流中读取一个值。
Serializable | writeReplace(Serializable value) 如果该值包含 writeReplace 方法，则返回该结果。
void | writeValue(OutputStream out, Serializable value) 使用 Java 语义将一个值写入流。

方法详细信息

writeValue

void writeValue(OutputStream out,
                Serializable value)
使用 Java 语义将一个值写入流。

参数：
out - 要向其中写入值的流。
value - 要写入流中的值。

readValue

Serializable readValue(InputStream in,
                       int offset,
                       Class clz,
                       String repositoryID,
                       RunTime sender)
使用 Java 语义从流中读取一个值。

参数：
in - 要从中读取值的流。
offset - 输入流中的当前位置。
clz - 要读入的值的类型。
repositoryID - 要读入的值的 RepositoryId。
sender - 发送上下文运行时代码基。
返回：
从流读取的值。

getRMIRepositoryID

String getRMIRepositoryID(Class clz)
返回给定 Java 类的 CORBA RepositoryId。

参数：
clz - Java 类。
返回：
类的 CORBA RepositoryId。

isCustomMarshaled

boolean isCustomMarshaled(Class clz)
指示给定的类是执行自定义编组还是默认编组。

参数：
clz - 测试是否执行自定义编组的类。
返回：
如果该类执行自定义编组，则返回 true，否则返回 false。

getRunTimeCodeBase

RunTime getRunTimeCodeBase()
返回此 ValueHandler 的 CodeBase。这由 ORB 运行时使用。在第一个 GIOP 响应上，该服务器发送包含此 CodeBase 的 IOR 的服务上下文。客户机在第一个 GIOP 请求上执行相同的操作。

返回：
此 ValueHandler 的 SendingContext.CodeBase。

writeReplace

Serializable writeReplace(Serializable value)
如果该值包含 writeReplace 方法，则返回该结果。否则，返回该值本身。

参数：
value - 要编组的值。
返回：
要在 wire 上编组的真实值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ValueHandlerMultiFormat (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.rmi.CORBA
接口 ValueHandlerMultiFormat

所有超级接口：
ValueHandler
public interface ValueHandlerMultiFormat
extends ValueHandler

Java 到 IDL ptc 02-01-12 1.5.1.5。

从以下版本开始：
1.5

方法摘要
byte | getMaximumStreamFormatVersion() 返回由此 ValueHandler 对象支持的 RMI/IDL 自定义值类型的最大流格式版本。
void | writeValue(OutputStream out, Serializable value, byte streamFormatVersion) 允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。
从接口 javax.rmi.CORBA.ValueHandler 继承的方法
getRMIRepositoryID, getRunTimeCodeBase, isCustomMarshaled, readValue, writeReplace, writeValue

方法详细信息

getMaximumStreamFormatVersion

byte getMaximumStreamFormatVersion()
返回由此 ValueHandler 对象支持的 RMI/IDL 自定义值类型的最大流格式版本。ValueHandler 对象必须支持返回的流格式版本和所有较低版本。 ORB 可使用此值以包括在标准的 IOR 标记组件或服务上下文中，以向其他 ORB 指示它支持的最大 RMI-IIOP 流格式。如果未包括，则 GIOP 1.2 默认为流格式版本 1，对于 GIOP 1.3 和更高版本，则默认为流格式版本 2。

writeValue

void writeValue(OutputStream out,
                Serializable value,
                byte streamFormatVersion)
允许 ORB 为 RMI/IDL 自定义值类型传递流格式版本。如果 ORB 调用此方法，则它必须在 1 和 getMaximumStreamFormatVersion 方法返回的值（包括）之间传递流格式版本，否则，将抛出带有标准小代码的 BAD_PARAM 异常。 如果 ORB 调用较旧的 ValueHandler.writeValue(OutputStream, Serializable) 方法，则隐含流格式版本 1。 传递到 ValueHandlerMultiFormat.writeValue 方法的 ORB 输出流必须实现 ValueOutputStream 接口，而且传递到 ValueHandler.readValue 方法的 ORB 输入流必须实现 ValueInputStream 接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.rmi.CORBA (Java 2 Platform SE 6)

 javax.rmi.CORBA
接口
PortableRemoteObjectDelegate
StubDelegate
Tie
UtilDelegate
ValueHandler
ValueHandlerMultiFormat
类
ClassDesc
Stub
Util


javax.rmi.CORBA (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.rmi.CORBA

包含用于 RMI-IIOP 的可移植性 API。

请参见：
描述

接口摘要
PortableRemoteObjectDelegate | 支持 PortableRemoteObject 中方法实现的委托。
StubDelegate | 支持 Stub 中方法实现的委托。
Tie | 定义所有 RMI-IIOP 服务器端 tie 必须实现的方法。
UtilDelegate | 支持 Util 中方法实现的委托。
ValueHandler | 定义允许序列化 Java 对象到 GIOP 流或从其序列化 Java 对象的方法。
ValueHandlerMultiFormat | Java 到 IDL ptc 02-01-12 1.5.1.5。

类摘要
ClassDesc | 此类用于对 IIOP 上的 java.lang.Class 对象进行编组。
Stub | 必须从其继承所有 RMI-IIOP stub 的基类。
Util | 提供可以由 stub 和 tie 用于执行公共操作的实用方法。

软件包 javax.rmi.CORBA 的描述

包含用于 RMI-IIOP 的可移植性 API。这些 API 提供一个生成的 stub 和 tie 与 RMI-IIOP 运行时之间的标准接口。对于 IIOP 上的 RMI，它们还允许使用第三方 ORB 作为 Sun 提供的 ORB 的替代方法。它们不是从 RMI-IIOP 应用程序直接调用的。另请参阅 javax.rmi 包。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.rmi.CORBA 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.rmi.CORBA 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.rmi.CORBA.ClassDesc (implements java.io.Serializable)
    • org.omg.CORBA.portable.ObjectImpl (implements org.omg.CORBA.Object)
      • org.omg.CORBA_2_3.portable.ObjectImpl
        • javax.rmi.CORBA.Stub (implements java.io.Serializable)
    • javax.rmi.CORBA.Util

接口分层结构

  • org.omg.CORBA.portable.InvokeHandler
    • javax.rmi.CORBA.Tie
  • javax.rmi.CORBA.PortableRemoteObjectDelegate
  • javax.rmi.CORBA.StubDelegate
  • javax.rmi.CORBA.UtilDelegate
  • javax.rmi.CORBA.ValueHandler
    • javax.rmi.CORBA.ValueHandlerMultiFormat
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.rmi.CORBA 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.rmi.CORBA
的使用

使用 javax.rmi.CORBA 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 使用的 javax.rmi.CORBA 中的类
Stub
必须从其继承所有 RMI-IIOP stub 的基类。
Tie
定义所有 RMI-IIOP 服务器端 tie 必须实现的方法。
ValueHandler
定义允许序列化 Java 对象到 GIOP 流或从其序列化 Java 对象的方法。

org.omg.stub.java.rmi 使用的 javax.rmi.CORBA 中的类
Stub
必须从其继承所有 RMI-IIOP stub 的基类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.rmi.CORBA.ClassDesc 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.CORBA.ClassDesc
的使用

没有 javax.rmi.CORBA.ClassDesc 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.rmi.CORBA.PortableRemoteObjectDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.PortableRemoteObjectDelegate
的使用

没有 javax.rmi.CORBA.PortableRemoteObjectDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.rmi.CORBA.Stub 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.CORBA.Stub
的使用

使用 Stub 的软件包
javax.rmi.CORBA | 包含用于 RMI-IIOP 的可移植性 API。
org.omg.stub.java.rmi | 包含用于 java.rmi 包中出现的 Remote 类型的 RMI-IIOP Stub。

javax.rmi.CORBA 中 Stub 的使用

参数类型为 Stub 的 javax.rmi.CORBA 中的方法
 void StubDelegate.connect(Stub self, ORB orb)
connect(org.omg.CORBA.ORB) 的委托调用。
 boolean StubDelegate.equals(Stub self, Object obj)
equals(java.lang.Object) 的委托调用。
 int StubDelegate.hashCode(Stub self)
hashCode() 的委托调用。
static boolean Util.isLocal(Stub stub)
isLocal 方法与 ObjectImpl._is_local 方法具有相同的语义，否则可能抛出 RemoteException。
 boolean UtilDelegate.isLocal(Stub stub)
Util.isLocal(javax.rmi.CORBA.Stub) 的委托调用。
 void StubDelegate.readObject(Stub self, ObjectInputStream s)
Stub.readObject(java.io.ObjectInputStream) 的委托调用。
 String StubDelegate.toString(Stub self)
toString() 的委托调用。
 void StubDelegate.writeObject(Stub self, ObjectOutputStream s)
Stub.writeObject(java.io.ObjectOutputStream) 的委托调用。

org.omg.stub.java.rmi 中 Stub 的使用

org.omg.stub.java.rmi 中 Stub 的子类
 class _Remote_Stub
此类为 Remote 类型提供 Stub。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.rmi.CORBA.StubDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.StubDelegate
的使用

没有 javax.rmi.CORBA.StubDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.rmi.CORBA.Tie 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.Tie
的使用

使用 Tie 的软件包
javax.rmi.CORBA 包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.CORBA 中 Tie 的使用

返回 Tie 的 javax.rmi.CORBA 中的方法
static Tie Util.getTie(Remote target)
返回给定目标对象的 tie（如果存在）。
 Tie UtilDelegate.getTie(Remote target)
Util.getTie(java.rmi.Remote) 的委托调用。

参数类型为 Tie 的 javax.rmi.CORBA 中的方法
static void Util.registerTarget(Tie tie, Remote target)
为 tie 注册一个目标。
 void UtilDelegate.registerTarget(Tie tie, Remote target)
Util.registerTarget(javax.rmi.CORBA.Tie, java.rmi.Remote) 的委托调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.rmi.CORBA.Util 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.CORBA.Util
的使用

没有 javax.rmi.CORBA.Util 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.rmi.CORBA.UtilDelegate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.UtilDelegate
的使用

没有 javax.rmi.CORBA.UtilDelegate 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.rmi.CORBA.ValueHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.ValueHandler
的使用

使用 ValueHandler 的软件包
javax.rmi.CORBA 包含用于 RMI-IIOP 的可移植性 API。

javax.rmi.CORBA 中 ValueHandler 的使用

javax.rmi.CORBA 中 ValueHandler 的子接口
 interface ValueHandlerMultiFormat
Java 到 IDL ptc 02-01-12 1.5.1.5。

返回 ValueHandler 的 javax.rmi.CORBA 中的方法
static ValueHandler Util.createValueHandler()
返回实现 ValueHandler 接口的类的单一实例。
 ValueHandler UtilDelegate.createValueHandler()
Util.createValueHandler() 的委托调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.rmi.CORBA.ValueHandlerMultiFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.rmi.CORBA.ValueHandlerMultiFormat
的使用

没有 javax.rmi.CORBA.ValueHandlerMultiFormat 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


SslRMIClientSocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.rmi.ssl
类 SslRMIClientSocketFactory

java.lang.Object
    继承者  javax.rmi.ssl.SslRMIClientSocketFactory
所有已实现的接口：
Serializable, RMIClientSocketFactory
public class SslRMIClientSocketFactory
extends Object
implements RMIClientSocketFactory, Serializable

SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。

此类通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议实现 RMIClientSocketFactory。

此类使用默认的 SSLSocketFactory（请参阅 SSLSocketFactory.getDefault()）创建 SSL 套接字。此类的所有实例在功能上是等效的。尤其是，在服务器要求客户机进行验证时，它们都共享相同的信任存储区和相同的密钥存储区。在子类中通过重写 createSocket(String,int) 方法可以修改此行为；在此情况下，equals 和 hashCode 可能也需要重写。

如果指定了系统属性 javax.rmi.ssl.client.enabledCipherSuites，则 createSocket(String,int) 方法将在返回套接字之前调用 SSLSocket.setEnabledCipherSuites(String[])。此系统属性的值是一个字符串，该字符串是要启用的 SSL/TLS 密码套件的逗号分隔的列表。

如果指定了系统属性 javax.rmi.ssl.client.enabledProtocols，createSocket(String,int) 方法将在返回套接字之前调用 SSLSocket.setEnabledProtocols(String[])。此系统属性的值是一个字符串，该字符串是要启用的 SSL/TLS 协议版本的逗号分隔的列表。

从以下版本开始：
1.5
另请参见：
SSLSocketFactory, SslRMIServerSocketFactory, 序列化表格

构造方法摘要
SslRMIClientSocketFactory()
创建一个新的 SslRMIClientSocketFactory。
方法摘要
Socket | createSocket(String host, int port) 创建一个 SSL 套接字。
boolean | equals(Object obj) 指示某个其他对象是否“等于”此对象。
int | hashCode() 返回此 SslRMIClientSocketFactory 的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SslRMIClientSocketFactory

public SslRMIClientSocketFactory()

创建一个新的 SslRMIClientSocketFactory。

方法详细信息

createSocket

public Socket createSocket(String host,
                           int port)
                    throws IOException

创建一个 SSL 套接字。

如果指定了系统属性 javax.rmi.ssl.client.enabledCipherSuites，则此方法将在返回套接字之前调用 SSLSocket.setEnabledCipherSuites(String[])。此系统属性的值是一个字符串，该字符串是要启用的 SSL/TLS 密码套件的逗号分隔的列表。

如果指定了系统属性 javax.rmi.ssl.client.enabledProtocols，则此方法将在返回套接字之前调用 SSLSocket.setEnabledProtocols(String[])。此系统属性的值是一个字符串，该字符串是要启用的 SSL/TLS 协议版本的逗号分隔的列表。

指定者：
接口 RMIClientSocketFactory 中的 createSocket
参数：
host - 主机名
port - 端口号
返回：
连接到指定主机和端口的套接字。
抛出：
IOException - 如果在套接字创建过程中发生 I/O 错误

equals

public boolean equals(Object obj)

指示某个其他对象是否“等于”此对象。

因为此类的所有实例在功能上都等效（它们都使用默认的 SSLSocketFactory），所以此方法仅返回 this.getClass().equals(obj.getClass())。

如果子类的实例在功能上不都等效，则该子类应该重写此方法以及 hashCode()。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此 SslRMIClientSocketFactory 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此 SslRMIClientSocketFactory 的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SslRMIServerSocketFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.rmi.ssl
类 SslRMIServerSocketFactory

java.lang.Object
    继承者  javax.rmi.ssl.SslRMIServerSocketFactory
所有已实现的接口：
RMIServerSocketFactory
public class SslRMIServerSocketFactory
extends Object
implements RMIServerSocketFactory

SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。

此类通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议实现 RMIServerSocketFactory。

此类使用默认的 SSLSocketFactory（请参阅 SSLSocketFactory.getDefault()）或默认的 SSLServerSocketFactory（请参阅 SSLServerSocketFactory.getDefault()）创建 SSL 套接字。因此，在服务器要求客户机进行验证时，此类的所有实例共享相同的密钥存储区和相同的信任存储区。在子类中通过重写 createServerSocket(int) 方法可以修改此行为；在此情况下，equals 和 hashCode 可能也需要重写。

从以下版本开始：
1.5
另请参见：
SSLSocketFactory, SSLServerSocketFactory, SslRMIClientSocketFactory

构造方法摘要
SslRMIServerSocketFactory()
使用默认的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。
SslRMIServerSocketFactory(String[] enabledCipherSuites, String[] enabledProtocols, boolean needClientAuth)
使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。
方法摘要
ServerSocket | createServerSocket(int port) 创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。
boolean | equals(Object obj) 指示某个其他对象是否“等于”此对象。
String[] | getEnabledCipherSuites() 返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则返回 null。
String[] | getEnabledProtocols() 返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则返回 null。
boolean | getNeedClientAuth() 如果由此工厂创建的服务器套接字所接受的 SSL 连接上要求客户机进行验证，则返回 true。
int | hashCode() 返回此 SslRMIServerSocketFactory 的哈希码值。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SslRMIServerSocketFactory

public SslRMIServerSocketFactory()

使用默认的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

由此工厂创建的服务器套接字接受的 SSL 连接启用了默认的密码套件和协议版本，不要求客户机进行验证。

SslRMIServerSocketFactory

public SslRMIServerSocketFactory(String[] enabledCipherSuites,
                                 String[] enabledProtocols,
                                 boolean needClientAuth)
                          throws IllegalArgumentException

使用指定的 SSL 套接字配置创建一个新的 SslRMIServerSocketFactory。

参数：
enabledCipherSuites - 由此工厂创建的服务器套接字所接受的 SSL 连接上启用的所有密码套件的名称，如果为 null 将使用默认启用的密码套件
enabledProtocols - 由此工厂创建的服务器套接字接受的 SSL 连接上启用的所有协议版本的名称，如果为 null 将使用默认启用的协议版本
needClientAuth - 如果为 true，将要求在由此工厂创建的服务器套接字接受的 SSL 连接上进行客户机验证；如果为 false，则不要求客户机进行验证
抛出：
IllegalArgumentException - 当不支持由 enabledCipherSuites 参数命名的一个或多个密码套件时，当不支持由 enabledProtocols 参数命名的一个或多个协议时，或者在尝试检查提供的要启用的密码套件和协议是否受支持时遇到问题，就会抛出此异常。
另请参见：
SSLSocket.setEnabledCipherSuites(java.lang.String[]),
SSLSocket.setEnabledProtocols(java.lang.String[]),
SSLSocket.setNeedClientAuth(boolean)
方法详细信息

getEnabledCipherSuites

public final String[] getEnabledCipherSuites()

返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的密码套件的名称，如果此工厂使用默认启用的密码套件，则返回 null。

返回：
启用的密码套件的数组，或者为 null
另请参见：
SSLSocket.setEnabledCipherSuites(java.lang.String[])

getEnabledProtocols

public final String[] getEnabledProtocols()

返回由此工厂创建的服务器套接字所接受的 SSL 连接上启用的协议版本的名称，如果此工厂使用默认启用的协议版本，则返回 null。

返回：
启用的协议版本的数组，或者为 null
另请参见：
SSLSocket.setEnabledProtocols(java.lang.String[])

getNeedClientAuth

public final boolean getNeedClientAuth()

如果由此工厂创建的服务器套接字所接受的 SSL 连接上要求客户机进行验证，则返回 true。

返回：
如果要求客户机进行验证，则返回 true
另请参见：
SSLSocket.setNeedClientAuth(boolean)

createServerSocket

public ServerSocket createServerSocket(int port)
                                throws IOException

创建一个服务器套接字，该套接字接受根据此工厂的 SSL 套接字配置参数配置的 SSL 连接。

指定者：
接口 RMIServerSocketFactory 中的 createServerSocket
参数：
port - 端口号
返回：
指定端口上的服务器套接字
抛出：
IOException - 如果在服务器套接字创建过程中发生 I/O 错误

equals

public boolean equals(Object obj)

指示某个其他对象是否“等于”此对象。

如果两个 SslRMIServerSocketFactory 对象使用了相同的 SSL 套接字配置参数构造，则这两个对象相等。

如果子类添加了影响相等性的实例状态，则该子类应重写此方法以及 hashCode()。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()

返回此 SslRMIServerSocketFactory 的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
此 SslRMIServerSocketFactory 的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.rmi.ssl (Java 2 Platform SE 6)

 javax.rmi.ssl
类
SslRMIClientSocketFactory
SslRMIServerSocketFactory


javax.rmi.ssl (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.rmi.ssl

通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

请参见：
描述

类摘要
SslRMIClientSocketFactory | SslRMIClientSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的客户端套接字。
SslRMIServerSocketFactory | SslRMIServerSocketFactory 实例由 RMI 运行时使用，以便通过 SSL 获取 RMI 调用的服务端套接字。

软件包 javax.rmi.ssl 的描述

通过安全套接字层 (SSL) 或传输层安全 (TLS) 协议提供 RMIClientSocketFactory 和 RMIServerSocketFactory 的实现。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.rmi.ssl 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.rmi.ssl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.rmi.ssl.SslRMIClientSocketFactory (implements java.rmi.server.RMIClientSocketFactory, java.io.Serializable)
    • javax.rmi.ssl.SslRMIServerSocketFactory (implements java.rmi.server.RMIServerSocketFactory)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.rmi.ssl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.rmi.ssl
的使用

没有 javax.rmi.ssl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.rmi.ssl.SslRMIClientSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.ssl.SslRMIClientSocketFactory
的使用

没有 javax.rmi.ssl.SslRMIClientSocketFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.rmi.ssl.SslRMIServerSocketFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.ssl.SslRMIServerSocketFactory
的使用

没有 javax.rmi.ssl.SslRMIServerSocketFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.rmi.PortableRemoteObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.rmi.PortableRemoteObject
的使用

没有 javax.rmi.PortableRemoteObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractScriptEngine (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.script
类 AbstractScriptEngine

java.lang.Object
    继承者  javax.script.AbstractScriptEngine
所有已实现的接口：
ScriptEngine
public abstract class AbstractScriptEngine
extends Object
implements ScriptEngine

为几个 eval 方法的变体提供标准实现。

eval(Reader)

eval(String)

eval(String, Bindings)

eval(Reader, Bindings)

是使用带有 SimpleScriptContext 的抽象方法

eval(Reader,ScriptContext) 或 eval(String, ScriptContext)

实现的。

SimpleScriptContext 被用作 AbstractScriptEngine 的默认 ScriptContext。

从以下版本开始：
1.6

字段摘要
protected  ScriptContext context
此 AbstractScriptEngine 的默认 ScriptContext。
从接口 javax.script.ScriptEngine 继承的字段
ARGV, ENGINE, ENGINE_VERSION, FILENAME, LANGUAGE, LANGUAGE_VERSION, NAME
构造方法摘要
AbstractScriptEngine()
创建一个新的 AbstractScriptEngine 实例，使用 SimpleScriptContext 作为其默认 ScriptContext。
AbstractScriptEngine(Bindings n)
创建一个新实例，使用指定 Bindings 作为受保护 context 字段中的 ENGINE_SCOPE Bindings。
方法摘要
 Object eval(Reader reader)
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。
 Object eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
 Object eval(String script)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。
 Object eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。
 Object get(String key)
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。
 Bindings getBindings(int scope)
返回受保护 context 字段中具有指定范围值的 Bindings。
 ScriptContext getContext()
返回受保护 context 字段的值。
protected  ScriptContext getScriptContext(Bindings nn)
返回一个 SimpleScriptContext。
 void put(String key, Object value)
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。
 void setBindings(Bindings bindings, int scope)
使用 context 字段中的相应范围值设置 Bindings。
 void setContext(ScriptContext ctxt)
将受保护 context 字段的值设置为指定的 ScriptContext。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.script.ScriptEngine 继承的方法
createBindings, eval, eval, getFactory

字段详细信息

context

protected ScriptContext context
此 AbstractScriptEngine 的默认 ScriptContext。

构造方法详细信息

AbstractScriptEngine

public AbstractScriptEngine()
创建一个新的 AbstractScriptEngine 实例，使用 SimpleScriptContext 作为其默认 ScriptContext。

AbstractScriptEngine

public AbstractScriptEngine(Bindings n)
创建一个新实例，使用指定 Bindings 作为受保护 context 字段中的 ENGINE_SCOPE Bindings。

参数：
n - 指定的 Bindings。
抛出：
NullPointerException - 如果 n 为 null。
方法详细信息

setContext

public void setContext(ScriptContext ctxt)
将受保护 context 字段的值设置为指定的 ScriptContext。

指定者：
接口 ScriptEngine 中的 setContext
参数：
ctxt - 指定的 ScriptContext。
抛出：
NullPointerException - 如果 ctxt 为 null。

getContext

public ScriptContext getContext()
返回受保护 context 字段的值。

指定者：
接口 ScriptEngine 中的 getContext
返回：
受保护 context 字段的值。

getBindings

public Bindings getBindings(int scope)
返回受保护 context 字段中具有指定范围值的 Bindings。

指定者：
接口 ScriptEngine 中的 getBindings
参数：
scope - 指定的范围
返回：
相应的 Bindings。
抛出：
IllegalArgumentException - 如果范围值对于受保护 context 字段的类型无效。

setBindings

public void setBindings(Bindings bindings,
                        int scope)
使用 context 字段中的相应范围值设置 Bindings。

指定者：
接口 ScriptEngine 中的 setBindings
参数：
bindings - 指定的 Bindings。
scope - 指定的范围。
抛出：
IllegalArgumentException - 如果范围值对于 context 字段的类型无效。
NullPointerException - 如果 bindings 为 null 且 scope 为 ScriptContext.ENGINE_SCOPE

put

public void put(String key,
                Object value)
使用受保护 context 字段的 ENGINE_SCOPE Bindings 中的指定键设置指定的值。

指定者：
接口 ScriptEngine 中的 put
参数：
key - 指定的键。
value - 指定的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空。

get

public Object get(String key)
获取受保护 context 字段的 ENGINE_SCOPE 中指定键的值。

指定者：
接口 ScriptEngine 中的 get
参数：
key - 将返回其值的键
返回：
指定键的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空。

eval

public Object eval(Reader reader,
                   Bindings bindings)
            throws ScriptException
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。使用指定的 Bindings，而不是 context 字段的 ENGINE_SCOPE Bindings。

指定者：
接口 ScriptEngine 中的 eval
参数：
reader - 包含脚本的源的 Reader。
bindings - 执行脚本时用于 ENGINE_SCOPE 的 Bindings。
返回：
eval(Reader, ScriptContext) 的返回值
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果任何参数为 null。

eval

public Object eval(String script,
                   Bindings bindings)
            throws ScriptException
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。

指定者：
接口 ScriptEngine 中的 eval
参数：
script - 包含脚本的源的 String。
bindings - 执行脚本时用作 ENGINE_SCOPE 的 Bindings。
返回：
eval(String, ScriptContext) 的返回值
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果任何参数为 null。

eval

public Object eval(Reader reader)
            throws ScriptException
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。

指定者：
接口 ScriptEngine 中的 eval
参数：
reader - 包含脚本的源的 Reader。
返回：
eval(Reader, ScriptContext) 的返回值
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果任何参数为 null。

eval

public Object eval(String script)
            throws ScriptException
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。

指定者：
接口 ScriptEngine 中的 eval
参数：
script - 包含脚本的源的 String。
返回：
eval(String, ScriptContext) 的返回值
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果任何参数为 null。

getScriptContext

protected ScriptContext getScriptContext(Bindings nn)
返回一个 SimpleScriptContext。该 SimpleScriptContext：

  • 将指定的 Bindings 用于其 ENGINE_SCOPE
  • 将抽象 getGlobalScope 方法返回的 Bindings 用作其 GLOBAL_SCOPE
  • 使用此 ScriptEngine 的默认 ScriptContext 中的 Reader 和 Writer

此方法返回的 SimpleScriptContext 被用来实现使用抽象 eval(Reader,Bindings) 和 eval(String,Bindings) 的 eval 方法。

参数：
nn - 用于 ENGINE_SCOPE 的 Bindings
返回：
SimpleScriptContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Bindings (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
接口 Bindings

所有超级接口：
Map<String,Object>
所有已知实现类：
SimpleBindings
public interface Bindings
extends Map<String,Object>

所有键均为 String 的键/值对映射关系。

从以下版本开始：
1.6

嵌套类摘要
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
方法摘要
boolean | containsKey(Object key) 如果此映射包含指定键的映射关系，则返回 true。
Object | get(Object key) 返回此映射将指定键所映射的值。
Object | put(String name, Object value) 设置指定的值。
void | putAll(Map<? extends String,? extends Object> toMerge) 将给定 Map 中的所有映射关系添加到此 Bindings 中。
Object | remove(Object key) 如果存在此键的映射关系，则将其从此映射中移除（可选操作）。
从接口 java.util.Map 继承的方法
clear, containsValue, entrySet, equals, hashCode, isEmpty, keySet, size, values

方法详细信息

put

Object put(String name,
           Object value)
设置指定的值。

指定者：
接口 Map<String,Object> 中的 put
参数：
name - 与值关联的名称。
value - 与名称关联的值。
返回：
以前与给定名称关联的值。如果以前没有与该名称关联的值，则返回 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空 String。

putAll

void putAll(Map<? extends String,? extends Object> toMerge)
将给定 Map 中的所有映射关系添加到此 Bindings 中。

指定者：
接口 Map<String,Object> 中的 putAll
参数：
toMerge - 与此 Map 合并的 Map。
抛出：
NullPointerException - 如果 toMerge 映射为 null，或者该映射中的某些键为 null。
IllegalArgumentException - 如果该映射中的某些键为空 String。

containsKey

boolean containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。更正式地说，当且仅当此映射包含针对满足 (key==null ? k==null :key.equals(k)) 的键 k 的映射关系时，返回 true。（最多只能有一个这样的映射关系。）

指定者：
接口 Map<String,Object> 中的 containsKey
参数：
key - 要测试是否存在于此映射中的键。
返回：
如果此映射包含指定键的映射关系，则返回 true。
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不是 String
IllegalArgumentException - 如果 key 为空 String

get

Object get(Object key)
返回此映射将指定键所映射的值。如果此映射中不包含此键的映射关系，则返回 null。返回 null 值不一定 表示此映射不包含该键的映射关系；也可能此映射将该键显式地映射为 null。可使用 containsKey 操作来区分这两种情况。

更正式地说，如果此映射包含满足 (key==null ? k==null :key.equals(k)) 的键 k 到值 v 的映射关系，那么此方法返回 v；否则返回 null。（最多只能有一个这样的映射关系。）

指定者：
接口 Map<String,Object> 中的 get
参数：
key - 要返回关联值的键。
返回：
此映射中指定键所映射的值；如果映射不包含此键的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不是 String
IllegalArgumentException - 如果 key 为空 String

remove

Object remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。更正式地说，如果此映射包含满足 (key==null ? k==null :key.equals(k)) 的键 k 到值 v 的映射关系，则移除该映射关系。（该映射最多只能包含一个这样的映射关系。）

返回映射中以前关联该键的值；如果映射不包含此键的映射关系，则返回 null。（如果该实现支持 null 值，则返回 null 也可能表示映射以前将 null 与指定的键关联。）调用返回后，映射将不包含指定键的映射关系。

指定者：
接口 Map<String,Object> 中的 remove
参数：
key - 其映射关系要从映射中移除的键。
返回：
以前与指定键关联的值；如果没有该键的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不是 String
IllegalArgumentException - 如果 key 为空 String
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Compilable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
接口 Compilable

public interface Compilable

由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法将脚本编译成无需重新编译就能反复执行的某种形式。

从以下版本开始：
1.6

方法摘要
CompiledScript | compile(Reader script) 编译脚本（从 Reader 读取的源），以便以后执行。
CompiledScript | compile(String script) 编译脚本（以 String 形式表示的源），以便以后执行。

方法详细信息

compile

CompiledScript compile(String script)
                       throws ScriptException
编译脚本（以 String 形式表示的源），以便以后执行。

参数：
script - 脚本的源，以 String 形式表示。
返回：
一个 CompiledScript 的子类，以后将使用 CompiledScript 的某一个 eval 方法执行。
抛出：
ScriptException - 如果编译失败。
NullPointerException - 如果参数为 null。

compile

CompiledScript compile(Reader script)
                       throws ScriptException
编译脚本（从 Reader 读取的源），以便以后执行。除了传递源的方式不同之外，在功能上等同于 compile(String)。

参数：
script - 从中获得脚本源的 reader。
返回：
一个 CompiledScript 的实现，以后将使用 CompiledScript 的某一个 eval 方法执行。
抛出：
ScriptException - 如果编译失败。
NullPointerException - 如果参数为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompiledScript (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
类 CompiledScript

java.lang.Object
    继承者  javax.script.CompiledScript

public abstract class CompiledScript
extends Object

存储编译结果的类扩展自此类。状态能够以 Java 类、Java 类文件或脚本语言操作码的形式存储。脚本可以反复执行而无需重新解析。

每个 CompiledScript 都与一个 ScriptEngine 关联，调用 CompiledScript 的 eval 方法将导致 ScriptEngine 执行脚本。执行 CompiledScript 引起的 ScriptEngine 状态的更改在随后引擎执行脚本期间可见。

从以下版本开始：
1.6

构造方法摘要
CompiledScript()
方法摘要
Object | eval() 执行存储在 CompiledScript 对象中的程序。
Object | eval(Bindings bindings) 执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。
abstract Object | eval(ScriptContext context) 执行存储在此 CompiledScript 对象中的程序。
abstract ScriptEngine | getEngine() 返回用 compile 方法创建了此 CompiledScript 的 ScriptEngine。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CompiledScript

public CompiledScript()
方法详细信息

eval

public abstract Object eval(ScriptContext context)
                     throws ScriptException
执行存储在此 CompiledScript 对象中的程序。

参数：
context - 一个 ScriptContext，它的使用方式与传递给 ScriptEngine eval 方法的 ScriptContext 相同。
返回：
执行脚本所返回的值（如果有）。如果执行脚本没有返回任何值，则应返回 null。
抛出：
ScriptException - 如果发生错误。
NullPointerException - 如果 context 为 null。

eval

public Object eval(Bindings bindings)
            throws ScriptException
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。如果 bindings 为 null，则调用此方法的效果等同于调用 eval(getEngine().getContext())。

. 使用与关联 ScriptEngine 的默认 ScriptContext 关联的 GLOBAL_SCOPE Bindings、Reader 和 Writer。

参数：
bindings - 用于 ENGINE_SCOPE 的属性的 bindings。
返回：
执行脚本所返回的值
抛出：
ScriptException - 如果发生错误。

eval

public Object eval()
            throws ScriptException
执行存储在 CompiledScript 对象中的程序。使用关联 ScriptEngine 的默认 ScriptContext。调用此方法的效果等同于调用 eval(getEngine().getContext())。

返回：
执行脚本所返回的值
抛出：
ScriptException - 如果发生错误。

getEngine

public abstract ScriptEngine getEngine()
返回用 compile 方法创建了此 CompiledScript 的 ScriptEngine。CompiledScript 将在此引擎中执行。

返回：
创建了此 CompiledScript 的 ScriptEngine
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Invocable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
接口 Invocable

public interface Invocable

由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法允许在以前执行过的脚本中调用程序。

从以下版本开始：
1.6

方法摘要
<T> T
getInterface(Class<T> clasz)
返回一个接口的实现，该接口使用解释器中编译的函数。
<T> T
getInterface(Object thiz, Class<T> clasz)
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。
 Object invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。
 Object invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

方法详细信息

invokeMethod

Object invokeMethod(Object thiz,
                    String name,
                    Object... args)
                    throws ScriptException,
                           NoSuchMethodException
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

参数：
name - 将被调用的程序的名称。
thiz - 如果该程序是脚本中已定义类的成员，并且 thiz 是以前的执行或调用所返回的类的实例，则通过该实例调用指定的方法。
args - 传递给程序的参数。将参数转换为脚本变量的规则是特定于实现的。
返回：
程序所返回的值。将脚本方法返回的脚本变量转换为 Java Object 的规则是特定于实现的。
抛出：
ScriptException - 如果在调用方法期间发生错误。
NoSuchMethodException - 如果不存在具有给定名称或匹配参数类型的方法。
NullPointerException - 如果方法名称为 null。
IllegalArgumentException - 如果指定的 thiz 为 null，或者指定的 Object 不表示一个脚本对象。

invokeFunction

Object invokeFunction(String name,
                      Object... args)
                      throws ScriptException,
                             NoSuchMethodException
用于调用脚本中定义的顶层程序和函数。

参数：
args - 传递给程序或函数的参数
返回：
程序或函数所返回的值
抛出：
ScriptException - 如果在调用方法期间发生错误。
NoSuchMethodException - 如果不存在具有给定名称或匹配参数类型的方法。
NullPointerException - 如果方法名称为 null。

getInterface

<T> T getInterface(Class<T> clasz)
返回一个接口的实现，该接口使用解释器中编译的函数。该接口的方法是使用 invokeFunction 方法实现的。

参数：
clasz - 要返回的接口的 Class 对象。
返回：
所请求接口的实例；如果所请求接口不可用，即 ScriptEngine 中不存在与所请求接口中的函数相匹配的已编译函数，则返回 null。
抛出：
IllegalArgumentException - 如果指定的 Class 对象为 null，或者该对象不是一个接口。

getInterface

<T> T getInterface(Object thiz,
                   Class<T> clasz)
返回一个接口的实现，该接口使用解释器中已编译脚本对象的成员函数。该接口的方法是使用 invokeMethod 方法实现的。

参数：
thiz - 其成员函数被用来实现接口方法的脚本对象。
clasz - 要返回的接口的 Class 对象。
返回：
所请求接口的实例；如果所请求接口不可用，即 ScriptEngine 中不存在与所请求接口中的方法相匹配的已编译方法，则返回 null。
抛出：
IllegalArgumentException - 如果指定的 Class 对象为 null 或不是一个接口，或者指定的 Object 为 null 或不表示一个脚本对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScriptContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
接口 ScriptContext

所有已知实现类：
SimpleScriptContext
public interface ScriptContext

该接口的实现类被用来连接 Script Engines 和宿主应用程序中的对象（如有范围的 Bindings）。每个范围都是一个指定属性集，这些属性的值可以使用 ScriptContext 方法设置和获取。ScriptContext 还公开可由 ScriptEngine 用于输入和输出的 Reader 和 Writer。

从以下版本开始：
1.6

字段摘要
static int | ENGINE_SCOPE EngineScope 属性在单个 ScriptEngine 的生存期是可见的，并为每个引擎维护一个属性集。
static int | GLOBAL_SCOPE GlobalScope 属性对于同一 ScriptEngineFactory 创建的所有引擎都是可见的。
方法摘要
Object | getAttribute(String name) 获取范围中按搜索顺序最早出现的具有给定名称的属性的值。
Object | getAttribute(String name, int scope) 获取给定范围中某一属性的值。
int | getAttributesScope(String name) 获取定义了某个属性的最小范围。
Bindings | getBindings(int scope) 获取与此 ScriptContext 中的给定范围关联的 Bindings。
Writer | getErrorWriter() 返回用来显示错误输出的 Writer。
Reader | getReader() 返回脚本用来读取输入的 Reader。
List<Integer> | getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。
Writer | getWriter() 返回脚本的 Writer，以便在显示输出时使用。
Object | removeAttribute(String name, int scope) 移除给定范围中的某一属性。
void | setAttribute(String name, Object value, int scope) 设置给定范围中某一属性的值。
void | setBindings(Bindings bindings, int scope) 将 Bindings 实例与此 ScriptContext 中的特定范围关联。
void | setErrorWriter(Writer writer) 设置用来显示错误输出的 Writer。
void | setReader(Reader reader) 设置脚本的 Reader，以读取输入。
void | setWriter(Writer writer) 设置脚本的 Writer，以便在显示输出时使用。

字段详细信息

ENGINE_SCOPE

static final int ENGINE_SCOPE
EngineScope 属性在单个 ScriptEngine 的生存期是可见的，并为每个引擎维护一个属性集。

另请参见：
常量字段值

GLOBAL_SCOPE

static final int GLOBAL_SCOPE
GlobalScope 属性对于同一 ScriptEngineFactory 创建的所有引擎都是可见的。

另请参见：
常量字段值
方法详细信息

setBindings

void setBindings(Bindings bindings,
                 int scope)
将 Bindings 实例与此 ScriptContext 中的特定范围关联。getAttribute 和 setAttribute 方法的调用必须映射到指定范围的 Bindings 的 get 和 put 方法。

参数：
bindings - 与给定范围关联的 Bindings
scope - 范围
抛出：
IllegalArgumentException - 如果没有为此类型 ScriptContext 中的指定范围值定义 Bindings。
NullPointerException - 如果 scope 的值为 ENGINE_SCOPE 并且指定的 Bindings 为 null。

getBindings

Bindings getBindings(int scope)
获取与此 ScriptContext 中的给定范围关联的 Bindings。

返回：
关联的 Bindings。如果尚未设置，则返回 null。
抛出：
IllegalArgumentException - 如果没有为此类型的 ScriptContext 中的指定范围值定义 Bindings。

setAttribute

void setAttribute(String name,
                  Object value,
                  int scope)
设置给定范围中某一属性的值。

参数：
name - 要设置的属性的名称
value - 属性值
scope - 属性的设置范围
抛出：
IllegalArgumentException - 如果 name 为空，或者 scope 无效。
NullPointerException - 如果 name 为 null。

getAttribute

Object getAttribute(String name,
                    int scope)
获取给定范围中某一属性的值。

参数：
name - 要获取的属性名称。
scope - 将在其中获取属性的范围。
返回：
属性值。返回 null 表示 name 不存在于给定范围中。
抛出：
IllegalArgumentException - 如果 name 为空，或者 scope 的值无效。
NullPointerException - 如果 name 为 null。

removeAttribute

Object removeAttribute(String name,
                       int scope)
移除给定范围中的某一属性。

参数：
name - 要移除的属性的名称
scope - 移除属性的范围
返回：
移除的值。
抛出：
IllegalArgumentException - 如果 name 为空，或者 scope 无效。
NullPointerException - 如果 name 为 null。

getAttribute

Object getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。搜索顺序由范围参数的数值确定（从最小的范围值开始）。

参数：
name - 要获取的属性的名称。
返回：
具有给定名称的属性的值，该属性位于定义它的最小范围中。如果任何范围中都不存在具有该名称的属性，则返回 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

getAttributesScope

int getAttributesScope(String name)
获取定义了某个属性的最小范围。

参数：
name - 属性的名称。
返回：
最小范围。如果在任何范围内都没有定义具有给定名称的属性，则返回 -1。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

getWriter

Writer getWriter()
返回脚本的 Writer，以便在显示输出时使用。

返回：
Writer。

getErrorWriter

Writer getErrorWriter()
返回用来显示错误输出的 Writer。

返回：
Writer

setWriter

void setWriter(Writer writer)
设置脚本的 Writer，以便在显示输出时使用。

参数：
writer - 新的 Writer。

setErrorWriter

void setErrorWriter(Writer writer)
设置用来显示错误输出的 Writer。

参数：
writer - Writer。

getReader

Reader getReader()
返回脚本用来读取输入的 Reader。

返回：
Reader。

setReader

void setReader(Reader reader)
设置脚本的 Reader，以读取输入。

参数：
reader - 新的 Reader。

getScopes

List<Integer> getScopes()
返回 ScriptContext 中所有有效范围值的不可变 List。

返回：
范围值列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScriptEngine (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
接口 ScriptEngine

所有已知实现类：
AbstractScriptEngine
public interface ScriptEngine

ScriptEngine 是基础接口，该接口的方法在此规范的每个实现中都必须具有完整的功能。

这些方法提供基本的脚本功能。为这个简单接口编写的应用程序应该对每个实现稍做修改就能够运行。这包括执行脚本的方法，以及设置和获取值的方法。

这些值是两种类型的键/值对。组成第一种类型的键/值对中的键是此规范或个别实现中保留和定义的键。包含保留键的键/值对中的值具有指定的含义。

另一种类型由那些创建 Java 语言 Bindings 的键/值对组成，值通常通过相应键或其装饰的形式用脚本表示。

从以下版本开始：
1.6

字段摘要
static String | ARGV 指定值的保留键，它将一个位置参数数组传递给某一脚本。
static String | ENGINE 指定值的保留键，它是 ScriptEngine 实现的名称。
static String | ENGINE_VERSION 指定值的保留键，它标识 ScriptEngine 实现的版本。
static String | FILENAME 指定值的保留键，它是将被执行的文件的名称。
static String | LANGUAGE 指定值的保留键，它是受实现支持的 Scripting Language 的完全名称。
static String | LANGUAGE_VERSION 指定值的保留键，它标识受实现支持的脚本语言的版本。
static String | NAME 指定值的保留键，它标识脚本语言的短名称。
方法摘要
 Bindings createBindings()
返回一个未初始化的 Bindings。
 Object eval(Reader reader)
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。
 Object eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
 Object eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
 Object eval(String script)
执行指定的脚本。
 Object eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。
 Object eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。
 Object get(String key)
获取在此引擎的状态中设置的值。
 Bindings getBindings(int scope)
返回指定值的范围。
 ScriptContext getContext()
返回 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。
 ScriptEngineFactory getFactory()
返回此 ScriptEngine 所属的类的 ScriptEngineFactory。
 void put(String key, Object value)
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。
 void setBindings(Bindings bindings, int scope)
设置将由脚本使用的指定值的范围。
 void setContext(ScriptContext context)
设置 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。

字段详细信息

ARGV

static final String ARGV
指定值的保留键，它将一个位置参数数组传递给某一脚本。

另请参见：
常量字段值

FILENAME

static final String FILENAME
指定值的保留键，它是将被执行的文件的名称。

另请参见：
常量字段值

ENGINE

static final String ENGINE
指定值的保留键，它是 ScriptEngine 实现的名称。

另请参见：
常量字段值

ENGINE_VERSION

static final String ENGINE_VERSION
指定值的保留键，它标识 ScriptEngine 实现的版本。

另请参见：
常量字段值

NAME

static final String NAME
指定值的保留键，它标识脚本语言的短名称。ScriptEngineManager 使用该名称查找具有 getEngineByName 方法中的给定名称的 ScriptEngine。

另请参见：
常量字段值

LANGUAGE

static final String LANGUAGE
指定值的保留键，它是受实现支持的 Scripting Language 的完全名称。

另请参见：
常量字段值

LANGUAGE_VERSION

static final String LANGUAGE_VERSION
指定值的保留键，它标识受实现支持的脚本语言的版本。

另请参见：
常量字段值
方法详细信息

eval

Object eval(String script,
            ScriptContext context)
            throws ScriptException
立即执行脚本，该脚本的源是作为第一个参数传递的 String。脚本在执行之前，可以重新解析或重新编译。以前的执行在引擎中遗留的状态（包括变量值和已编译的程序）在这次执行中是可见的。

参数：
script - 将由脚本引擎执行的脚本。
context - 公开不同范围中的属性集的 ScriptContext。规范中定义了范围 ScriptContext.GLOBAL_SCOPE 和 ScriptContext.ENGINE_SCOPE 的含义。

ScriptContext 的 ENGINE_SCOPE Bindings 包含将在此脚本执行期间使用的应用程序对象脚本变量的 bindings。
返回：
执行脚本所返回的值。
抛出：
ScriptException - 如果脚本发生错误。对于底层脚本实现抛出的经过检查的 Exception，ScriptEngine 应该创建并抛出 ScriptException 包装器。
NullPointerException - 如果任一参数为 null。

eval

Object eval(Reader reader,
            ScriptContext context)
            throws ScriptException
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。

参数：
reader - 将由脚本引擎执行的脚本的源。
context - 传递给脚本引擎的 ScriptContext。
返回：
执行脚本所返回的值。
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果任一参数为 null。

eval

Object eval(String script)
            throws ScriptException
执行指定的脚本。使用 ScriptEngine 的默认 ScriptContext。

参数：
script - 要执行的脚本语言源。
返回：
执行脚本所返回的值。
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果参数为 null。

eval

Object eval(Reader reader)
            throws ScriptException
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。

参数：
reader - 脚本的源。
返回：
脚本返回的值。
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果参数为 null。

eval

Object eval(String script,
            Bindings n)
            throws ScriptException
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。使用默认 ScriptContext 的 Reader、Writer 和非 ENGINE_SCOPE Bindings。ScriptEngine 的 ENGINE_SCOPE Bindings 不变，其映射关系不随脚本执行发生改变。

参数：
script - 脚本的源。
n - 将用于脚本执行的属性的 Bindings。
返回：
脚本返回的值。
抛出：
ScriptException - 如果脚本发生错误。
NullPointerException - 如果任一参数为 null。

eval

Object eval(Reader reader,
            Bindings n)
            throws ScriptException
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。

参数：
reader - 脚本的源。
n - 属性的 Bindings。
返回：
脚本返回的值。
抛出：
ScriptException - 如果发生错误。
NullPointerException - 如果任一参数为 null。

put

void put(String key,
         Object value)
设置 ScriptEngine 的状态中的键/值对，它创建一个将在脚本执行中使用或者以其他方式使用的 Java Language Binding，具体取决于该键是否被保留。必须与 getBindings(ScriptContext.ENGINE_SCOPE).put 具有相同的效果。

参数：
key - 要添加的指定值的名称
value - 要添加的指定值的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空。

get

Object get(String key)
获取在此引擎的状态中设置的值。该值可能是使用 setValue 设置的值，也可能是 ScriptEngine 状态中的某个其他值，具体取决于实现。必须与 getBindings(ScriptContext.ENGINE_SCOPE).get 具有相同的效果。

参数：
key - 将返回其值的键
返回：
给定键的值
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空。

getBindings

Bindings getBindings(int scope)
返回指定值的范围。可能的范围有：

  • ScriptContext.GLOBAL_SCOPE - 表示全局范围的指定值的集合。如果此 ScriptEngine 是通过 ScriptEngineManager 创建的，则该管理器将设置全局范围 bindings。如果没有与此 ScriptEngine 关联的全局范围，则此范围可能为 null
  • ScriptContext.ENGINE_SCOPE - 表示此 ScriptEngine 的状态的指定值的集合。在使用关联键作为变量名称的脚本中，这些值通常是可见的。
  • ScriptEngine 的默认 ScriptContext 中定义的其他范围值。

返回的 Bindings 实例必须与对 ScriptEngine 的默认 ScriptContext 调用 ScriptContext 的 getBindings 方法（使用相应参数）所返回的实例一样。

参数：
scope - ScriptContext.ENGINE_SCOPE 或 ScriptContext.GLOBAL_SCOPE，指定要返回的 Bindings。ScriptContext 的实现可以定义其他范围。如果 ScriptEngine 的默认 ScriptContext 定义了其他范围，则这些范围都可以传递给该参数，以获取相应的 Bindings。
返回：
指定范围的 Bindings。
抛出：
IllegalArgumentException - 如果指定范围无效

setBindings

void setBindings(Bindings bindings,
                 int scope)
设置将由脚本使用的指定值的范围。可能的范围有：

  • ScriptContext.ENGINE_SCOPE - 指定的 Bindings 将替代 ScriptEngine 的引擎范围。
  • ScriptContext.GLOBAL_SCOPE - 指定的 Bindings 必须作为 GLOBAL_SCOPE 可见。
  • ScriptEngine 的默认 ScriptContext 中定义的其他范围值。

该方法必须与对 ScriptEngine 的默认 ScriptContext 调用 ScriptContext 的 setBindings 方法（使用 scope 的相应值）的效果相同。

参数：
bindings - 指定范围的 Bindings。
scope - 指定的范围。ScriptContext.ENGINE_SCOPE、ScriptContext.GLOBAL_SCOPE 或者其他有效范围值。
抛出：
IllegalArgumentException - 如果 scope 有效
NullPointerException - 如果 bindings 为 null 并且 scope 为 ScriptContext.ENGINE_SCOPE

createBindings

Bindings createBindings()
返回一个未初始化的 Bindings。

返回：
用来替代此 ScriptEngine 状态的 Bindings。

getContext

ScriptContext getContext()
返回 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。

返回：
ScriptEngine 的默认 ScriptContext。

setContext

void setContext(ScriptContext context)
设置 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。

参数：
context - 将替代 ScriptEngine 中默认 ScriptContext 的 ScriptContext。
抛出：
NullPointerException - 如果 context 为 null。

getFactory

ScriptEngineFactory getFactory()
返回此 ScriptEngine 所属的类的 ScriptEngineFactory。

返回：
ScriptEngineFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScriptEngineFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
接口 ScriptEngineFactory

public interface ScriptEngineFactory

ScriptEngineFactory 用来描述和实例化 ScriptEngine。

实现 ScriptEngine 的每个类都有一个相应的工厂，该工厂公开描述引擎类的元数据。

ScriptEngineManager 使用 Jar 文件规范 中描述的服务提供者机制来获取所有当前 ClassLoader 中可用的 ScriptEngineFactory 实例。

从以下版本开始：
1.6

方法摘要
String | getEngineName() 返回 ScriptEngine 的完全名称。
String | getEngineVersion() 返回 ScriptEngine 的版本。
List<String> | getExtensions() 返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。
String | getLanguageName() 返回此 ScriptEngine 支持的脚本语言的名称。
String | getLanguageVersion() 返回此 ScriptEngine 支持的脚本语言的版本。
String | getMethodCallSyntax(String obj, String m, String... args) 返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。
List<String> | getMimeTypes() 返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。
List<String> | getNames() 返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。
String | getOutputStatement(String toDisplay) 返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。
Object | getParameter(String key) 返回属性值，该属性的含义可能是特定于实现的。
String | getProgram(String... statements) 返回一个包含给定语句的有效脚本语言的可执行程序。
ScriptEngine | getScriptEngine() 返回与此 ScriptEngineFactory 关联的 ScriptEngine 的实例。

方法详细信息

getEngineName

String getEngineName()
返回 ScriptEngine 的完全名称。例如，基于 Mozilla Rhino Javascript 引擎的实现可以返回 Rhino Mozilla Javascript Engine。

返回：
引擎实现的名称。

getEngineVersion

String getEngineVersion()
返回 ScriptEngine 的版本。

返回：
ScriptEngine 实现版本。

getExtensions

List<String> getExtensions()
返回文件扩展名的不可变列表，这些扩展名通常标识使用此 ScriptEngine 支持的语言所编写的脚本。该数组由 ScriptEngineManager 使用，用于实现其 getEngineByExtension 方法。

返回：
扩展名列表。

getMimeTypes

List<String> getMimeTypes()
返回 mimetypes 的不可变列表，这些 mimetypes 与可由引擎执行的脚本关联。该列表由 ScriptEngineManager 类使用，用于实现其 getEngineByMimetype 方法。

返回：
mime 类型的列表。

getNames

List<String> getNames()
返回 ScriptEngine 短名称的不可变列表，这些名称由 ScriptEngineManager 用来标识 ScriptEngine。例如，基于 Mozilla Rhino Javascript 引擎的实现可以返回包含 {"javascript", "rhino"} 的列表。

getLanguageName

String getLanguageName()
返回此 ScriptEngine 支持的脚本语言的名称。

返回：
受支持语言的名称。

getLanguageVersion

String getLanguageVersion()
返回此 ScriptEngine 支持的脚本语言的版本。

返回：
受支持语言的版本。

getParameter

Object getParameter(String key)
返回属性值，该属性的含义可能是特定于实现的。其值在所有实现中定义的键有：
  • ScriptEngine.ENGINE
  • ScriptEngine.ENGINE_VERSION
  • ScriptEngine.NAME
  • ScriptEngine.LANGUAGE
  • ScriptEngine.LANGUAGE_VERSION

用于这些键的值分别是 getEngineName、getEngineVersion、getName、getLanguageName 和 getLanguageVersion 返回的 String。

还定义了保留键 THREADING，它的值描述了与脚本并发执行和状态维护有关的引擎行为。用于 THREADING 键的值有：

    null - 引擎实现不是线程安全的，并且无法用来在多个线程上并发执行脚本。

    "MULTITHREADED" - 引擎实现是内部线程安全的，并且脚本可以并发执行，尽管在某个线程上执行脚本的效果对于另一个线程上的脚本是可见的。

    "THREAD-ISOLATED" - 该实现满足 "MULTITHREADED" 的要求，并且引擎为不同线程上执行的脚本中的符号维护独立的值。

    "STATELESS" - 该实现满足 "THREAD-ISOLATED" 的要求。此外，脚本执行不改变 Bindings 中的映射关系，该 Bindings 是 ScriptEngine 的引擎范围。具体来说，Bindings 及其关联值中的键在执行脚本之前和之后是相同的。

实现可以定义特定于实现的键。

参数：
key - 参数名
返回：
给定参数的值。如果没有为键分配值，则返回 null。

getMethodCallSyntax

String getMethodCallSyntax(String obj,
                           String m,
                           String... args)
返回一个 String，该 String 可用来调用使用受支持脚本语言语法的 Java 对象的方法。例如，Javascript 引擎的实现可能是：

public String getMethodCallSyntax(String obj,
String m, String... args) {
String ret = obj;
ret += "."+ m + "(";
for (int i = 0; i < args.length; i++) {
ret += args[i];
if (i == args.length - 1) {
ret += ")";
} else {
ret += ",";
          }
      }
return ret;
 }

参数：
obj - 表示其方法将被调用的对象的名称。该名称是用来使用 ScriptEngine 的 put 方法、ENGINE_SCOPE Bindings 的 put 方法或者 ScriptContext 的 setAttribute 方法创建 bindings 的名称。脚本中使用的标识符可以是指定标识符的装饰形式。
m - 要调用的方法的名称。
args - 方法调用中的参数名称。
返回：
用来调用使用脚本语言语法的方法的 String。

getOutputStatement

String getOutputStatement(String toDisplay)
返回一个 String，该 String 可用作一个语句来显示使用受支持脚本语言语法的指定 String。例如，Perl 引擎的实现可能是：

public String getOutputStatement(String toDisplay) {
return "print(" + toDisplay + ")";
 }

参数：
toDisplay - 将由返回的语句显示的 String。
返回：
用来显示使用脚本语言语法的 String 的字符串。

getProgram

String getProgram(String... statements)
返回一个包含给定语句的有效脚本语言的可执行程序。例如，PHP 引擎的实现可能是：

public String getProgram(String... statements) {
$retval = "<?\n";
int len = statements.length;
for (int i = 0; i < len; i++) {
$retval += statements[i] + ";\n";
      }
$retval += "?>";

 }

参数：
statements - 要执行的语句。可能是调用 getMethodCallSyntax 和 getOutputStatement 方法的返回值。
返回：
程序

getScriptEngine

ScriptEngine getScriptEngine()
返回与此 ScriptEngineFactory 关联的 ScriptEngine 的实例。通常返回一个新的 ScriptEngine，但这些实现可以池化、共享或重用引擎。

返回：
新的 ScriptEngine 实例。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScriptEngineManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
类 ScriptEngineManager

java.lang.Object
    继承者  javax.script.ScriptEngineManager

public class ScriptEngineManager
extends Object

ScriptEngineManager 为 ScriptEngine 类实现一个发现和实例化机制，还维护一个键/值对集合来存储所有 Manager 创建的引擎所共享的状态。此类使用服务提供者机制枚举所有的 ScriptEngineFactory 实现。

ScriptEngineManager 提供了一个方法，可以返回一个所有工厂实现和基于语言名称、文件扩展名和 mime 类型查找工厂的实用方法所组成的数组。

键/值对的 Bindings（即由管理器维护的 "Global Scope"）对于 ScriptEngineManager 创建的所有 ScriptEngine 实例都是可用的。Bindings 中的值通常公开于所有脚本中。

从以下版本开始：
1.6

构造方法摘要
ScriptEngineManager()
如果调用者可访问线程上下文 ClassLoader，则调用此构造方法的效果与调用 ScriptEngineManager(Thread.currentThread().getContextClassLoader()) 相同。
ScriptEngineManager(ClassLoader loader)
此构造方法使用服务调用者机制加载对于给定 ClassLoader 可见的 ScriptEngineFactory 实现。
方法摘要
Object | get(String key) 获取 Global Scope 中指定键的值。
Bindings | getBindings() getBindings 返回 globalScope 字段的值。
ScriptEngine | getEngineByExtension(String extension) 查找并创建一个给定扩展的 ScriptEngine。
ScriptEngine | getEngineByMimeType(String mimeType) 查找并创建一个给定 mime 类型的 ScriptEngine。
ScriptEngine | getEngineByName(String shortName) 查找并创建一个给定名称的 ScriptEngine。
List<ScriptEngineFactory> | getEngineFactories() 返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。
void | put(String key, Object value) 设置 Global Scope 中指定的键/值对。
void | registerEngineExtension(String extension, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理扩展。
void | registerEngineMimeType(String type, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理 mime 类型。
void | registerEngineName(String name, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理语言名称。
void | setBindings(Bindings bindings) setBindings 存储 globalScope 字段中的指定 Bindings。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScriptEngineManager

public ScriptEngineManager()
如果调用者可访问线程上下文 ClassLoader，则调用此构造方法的效果与调用 ScriptEngineManager(Thread.currentThread().getContextClassLoader()) 相同。否则，效果与调用 ScriptEngineManager(null) 相同。

另请参见：
Thread.getContextClassLoader()

ScriptEngineManager

public ScriptEngineManager(ClassLoader loader)
此构造方法使用服务调用者机制加载对于给定 ClassLoader 可见的 ScriptEngineFactory 实现。

如果 loader 为 null，则加载与平台打包在一起的脚本引擎工厂，以及常用扩展目录（已安装的扩展）中的脚本引擎工厂。

参数：
loader - 用来发现脚本引擎工厂的 ClassLoader。
方法详细信息

setBindings

public void setBindings(Bindings bindings)
setBindings 存储 globalScope 字段中的指定 Bindings。ScriptEngineManager 将此 Bindings 设置为由它创建的 ScriptEngine 对象的全局 bindings。

参数：
bindings - 指定的 Bindings
抛出：
IllegalArgumentException - 如果 bindings 为 null。

getBindings

public Bindings getBindings()
getBindings 返回 globalScope 字段的值。ScriptEngineManager 将此 Bindings 设置为由它创建的 ScriptEngine 对象的全局 bindings。

返回：
globalScope 字段。

put

public void put(String key,
                Object value)
设置 Global Scope 中指定的键/值对。

参数：
key - 要设置的键
value - 要设置的值。
抛出：
NullPointerException - 如果 key 为 null。
IllegalArgumentException - 如果 key 为空字符串。

get

public Object get(String key)
获取 Global Scope 中指定键的值。

参数：
key - 将返回其值的键。
返回：
指定键的值。

getEngineByName

public ScriptEngine getEngineByName(String shortName)
查找并创建一个给定名称的 ScriptEngine。该算法首先查找一个 ScriptEngineFactory，该 ScriptEngineFactory 已经针对给定名称使用 registerEngineName 方法注册为处理程序。

如果没有找到这样的 ScriptEngineFactory，则搜索构造方法存储的 ScriptEngineFactory 实例数组，以获得具有指定名称的 ScriptEngineFactory。如果通过这两种方法之一找到了一个 ScriptEngineFactory，则用它来创建 ScriptEngine 实例。

参数：
shortName - ScriptEngine 实现的短名称，由其 ScriptEngineFactory 的 getNames 方法返回。
返回：
搜索到的工厂所创建的 ScriptEngine。如果没有找到这样的工厂，则返回 null。ScriptEngineManager 将它自己的 globalScope Bindings 设置为新建 ScriptEngine 的 GLOBAL_SCOPE Bindings。
抛出：
NullPointerException - 如果 shortName 为 null。

getEngineByExtension

public ScriptEngine getEngineByExtension(String extension)
查找并创建一个给定扩展的 ScriptEngine。使用 getEngineByName 所使用的算法，不同之处在于搜索从查找已使用 registerEngineExtension 注册以处理给定扩展的 ScriptEngineFactory 开始。

参数：
extension - 给定扩展
返回：
用来处理具有此扩展的引擎。如果没有找到这样的引擎，则返回 null。
抛出：
NullPointerException - 如果 extension 为 null。

getEngineByMimeType

public ScriptEngine getEngineByMimeType(String mimeType)
查找并创建一个给定 mime 类型的 ScriptEngine。使用 getEngineByName 所使用的算法，不同之处在于搜索从查找已使用 registerEngineMimeType 注册以处理给定 mime 类型的 ScriptEngineFactory 开始。

参数：
mimeType - 给定 mime 类型
返回：
用来处理具有此 mime 类型的脚本的引擎。如果没有找到这样的引擎，则返回 null。
抛出：
NullPointerException - 如果 mimeType 为 null。

getEngineFactories

public List<ScriptEngineFactory> getEngineFactories()
返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。

返回：
所有已发现 ScriptEngineFactory 所组成的列表。

registerEngineName

public void registerEngineName(String name,
                               ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理语言名称。重写所有使用发现机制找到的这类关联。

参数：
name - 要与 ScriptEngineFactory 关联的名称。
factory - 要与给定名称关联的类。
抛出：
NullPointerException - 如果任何参数为 null。

registerEngineMimeType

public void registerEngineMimeType(String type,
                                   ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理 mime 类型。重写所有使用发现机制找到的这类关联。

参数：
type - 要与 ScriptEngineFactory 关联的 mime 类型。
factory - 要与给定 mime 类型关联的类。
抛出：
NullPointerException - 如果任何参数为 null。

registerEngineExtension

public void registerEngineExtension(String extension,
                                    ScriptEngineFactory factory)
注册一个 ScriptEngineFactory 来处理扩展。重写所有使用发现机制找到的这类关联。

参数：
extension - 要与 ScriptEngineFactory 关联的扩展类型。
factory - 要与给定扩展关联的类。
抛出：
NullPointerException - 如果任何参数为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScriptException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
类 ScriptException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.script.ScriptException
所有已实现的接口：
Serializable
public class ScriptException
extends Exception

脚本 API 的一般 Exception 类。由底层脚本实现抛出的经过检查的异常类型必须包装在 ScriptException 的实例中。该类具有存储行号和列号的成员，如果文件名信息可用，还具有存储文件名的成员。

从以下版本开始：
1.6
另请参见：
序列化表格

构造方法摘要
ScriptException(Exception e)
创建一个包装底层解释器抛出的 Exception 的 ScriptException。
ScriptException(String s)
使用将在其消息中使用的 String 创建一个 ScriptException。
ScriptException(String message, String fileName, int lineNumber)
使用将在错误消息中使用的消息、文件名和行号创建一个 ScriptException。
ScriptException(String message, String fileName, int lineNumber, int columnNumber)
指定消息、文件名、行号和列号的 ScriptException 构造方法。
方法摘要
int | getColumnNumber() 获取发生错误的列号。
String | getFileName() 获取导致错误的脚本的源。
int | getLineNumber() 获取发生错误的行号。
String | getMessage() 返回一条消息，该消息包含传递给构造方法的 String，以及行号、列号和文件名（如果它们已知）。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ScriptException

public ScriptException(String s)
使用将在其消息中使用的 String 创建一个 ScriptException。文件名、行号和列号没有指定。

参数：
s - 将在消息中使用的 String。

ScriptException

public ScriptException(Exception e)
创建一个包装底层解释器抛出的 Exception 的 ScriptException。行号、列号和文件名没有指定。

参数：
e - 包装的 Exception。

ScriptException

public ScriptException(String message,
                       String fileName,
                       int lineNumber)
使用将在错误消息中使用的消息、文件名和行号创建一个 ScriptException。

参数：
message - 将在消息中使用的字符串
fileName - 描述导致抛出 ScriptException 的脚本错误位置的文件或资源名。
lineNumber - 描述导致抛出 ScriptException 的脚本错误位置的行号。

ScriptException

public ScriptException(String message,
                       String fileName,
                       int lineNumber,
                       int columnNumber)
指定消息、文件名、行号和列号的 ScriptException 构造方法。

参数：
message - 消息。
fileName - 文件名
lineNumber - 行号。
columnNumber - 列号。
方法详细信息

getMessage

public String getMessage()
返回一条消息，该消息包含传递给构造方法的 String，以及行号、列号和文件名（如果它们已知）。

覆盖：
类 Throwable 中的 getMessage
返回：
错误消息。

getLineNumber

public int getLineNumber()
获取发生错误的行号。

返回：
行号。如果行号不可用，则返回 -1。

getColumnNumber

public int getColumnNumber()
获取发生错误的列号。

返回：
列号。如果列号不可用，则返回 -1。

getFileName

public String getFileName()
获取导致错误的脚本的源。

返回：
脚本的文件名，或者描述脚本源的其他字符串。如果源的描述不可用，则返回某些实现定义的字符串，如 <unknown>。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleBindings (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.script
类 SimpleBindings

java.lang.Object
    继承者  javax.script.SimpleBindings
所有已实现的接口：
Map<String,Object>, Bindings
public class SimpleBindings
extends Object
implements Bindings

一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。

从以下版本开始：
1.6

嵌套类摘要
从接口 java.util.Map 继承的嵌套类/接口
Map.Entry<K,V>
构造方法摘要
SimpleBindings()
默认构造方法使用 HashMap。
SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。
方法摘要
void | clear() 从此映射中移除所有映射关系（可选操作）。
boolean | containsKey(Object key) 如果此映射包含指定键的映射关系，则返回 true。
boolean | containsValue(Object value) 如果此映射将一个或多个键映射到指定值，则返回 true。
Set<Map.Entry<String,Object>> | entrySet() 返回此映射中包含的映射关系的 Set 视图。
Object | get(Object key) 返回此映射将指定键所映射到的值。
boolean | isEmpty() 如果此映射未包含键-值映射关系，则返回 true。
Set<String> | keySet() 返回此映射中包含的键的 Set 视图。
Object | put(String name, Object value) 设置底层 map 字段中的指定键/值。
void | putAll(Map<? extends String,? extends Object> toMerge) putAll 是使用 Map.putAll 实现的。
Object | remove(Object key) 如果存在此键的映射关系，则将其从此映射中移除（可选操作）。
int | size() 返回此映射中的键-值映射关系数。
Collection<Object> | values() 返回此映射中包含的值的 Collection 视图。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.util.Map 继承的方法
equals, hashCode

构造方法详细信息

SimpleBindings

public SimpleBindings(Map<String,Object> m)
构造方法使用现有 Map 来存储值。

参数：
m - 支持此 SimpleBindings 的 Map。
抛出：
NullPointerException - 如果 m 为 null

SimpleBindings

public SimpleBindings()
默认构造方法使用 HashMap。

方法详细信息

put

public Object put(String name,
                  Object value)
设置底层 map 字段中的指定键/值。

指定者：
接口 Map<String,Object> 中的 put
指定者：
接口 Bindings 中的 put
参数：
name - 值的名称
value - 要设置的值。
返回：
指定键以前的值。如果以前没有设置键，则返回 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

putAll

public void putAll(Map<? extends String,? extends Object> toMerge)
putAll 是使用 Map.putAll 实现的。

指定者：
接口 Map<String,Object> 中的 putAll
指定者：
接口 Bindings 中的 putAll
参数：
toMerge - 要添加的值的 Map。
抛出：
NullPointerException - 如果 toMerge 映射为 null，或者该映射中的某些键为 null。
IllegalArgumentException - 如果该映射中的某些键为空 String。

clear

public void clear()
从此映射中移除所有映射关系（可选操作）。此调用返回后，该映射将为空。

指定者：
接口 Map<String,Object> 中的 clear

containsKey

public boolean containsKey(Object key)
如果此映射包含指定键的映射关系，则返回 true。更正式地说，当且仅当此映射包含针对满足 (key==null ? k==null :key.equals(k)) 的键 k 的映射关系时，返回 true。（最多只能有一个这样的映射关系。）

指定者：
接口 Map<String,Object> 中的 containsKey
指定者：
接口 Bindings 中的 containsKey
参数：
key - 要测试是否存在于此映射中的键。
返回：
如果此映射包含指定键的映射关系，则返回 true。
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不是 String
IllegalArgumentException - 如果 key 为空 String

containsValue

public boolean containsValue(Object value)
如果此映射将一个或多个键映射到指定值，则返回 true。更确切地讲，当且仅当此映射至少包含一个对满足 (value==null ? v==null : value.equals(v)) 的值 v 的映射关系时，返回 true。对于大多数 Map 接口的实现而言，此操作需要的时间可能与映射大小呈线性关系。

指定者：
接口 Map<String,Object> 中的 containsValue
参数：
value - 测试是否存在于此映射中的值
返回：
如果此映射将一个或多个键映射到指定值，则返回 true

entrySet

public Set<Map.Entry<String,Object>> entrySet()
返回此映射中包含的映射关系的 Set 视图。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作，或者通过对迭代器返回的映射项执行 setValue 操作除外），则迭代结果是不确定的。set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<String,Object> 中的 entrySet
返回：
此映射中包含的映射关系的 set 视图

get

public Object get(Object key)
返回此映射将指定键所映射到的值。如果此映射中没有此键的映射关系，则返回 null。返回 null 值不一定 表示此映射不包含该键的映射关系；也可能此映射将该键显式地映射为 null。可使用 containsKey 操作来区分这两种情况。

更正式地说，如果此映射包含满足 (key==null ? k==null :key.equals(k)) 的键 k 到值 v 的映射关系，那么此方法返回 v；否则返回 null。（最多只能有一个这样的映射关系。）

指定者：
接口 Map<String,Object> 中的 get
指定者：
接口 Bindings 中的 get
参数：
key - 要返回关联值的键。
返回：
此映射中指定键所映射的值；如果映射不包含此键的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不是 String
IllegalArgumentException - 如果 key 为空 String

isEmpty

public boolean isEmpty()
如果此映射未包含键-值映射关系，则返回 true。

指定者：
接口 Map<String,Object> 中的 isEmpty
返回：
如果此映射未包含键-值映射关系，则返回 true

keySet

public Set<String> keySet()
返回此映射中包含的键的 Set 视图。该 set 受映射支持，所以对映射的更改可在此 set 中反映出来，反之亦然。如果对该 set 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。set 支持元素移除，通过 Iterator.remove、Set.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<String,Object> 中的 keySet
返回：
此映射中包含的键的 set 视图

remove

public Object remove(Object key)
如果存在此键的映射关系，则将其从此映射中移除（可选操作）。更正式地说，如果此映射包含满足 (key==null ? k==null :key.equals(k)) 的键 k 到值 v 的映射关系，则移除该映射关系。（该映射最多只能包含一个这样的映射关系。）

返回映射中以前关联该键的值；如果映射不包含此键的映射关系，则返回 null。（如果该实现支持 null 值，则返回 null 也可能表示映射以前将 null 与指定的键关联。）调用返回后，映射将不包含指定键的映射关系。

指定者：
接口 Map<String,Object> 中的 remove
指定者：
接口 Bindings 中的 remove
参数：
key - 其映射关系要从映射中移除的键。
返回：
以前与指定键关联的值；如果没有该键的映射关系，则返回 null。
抛出：
NullPointerException - 如果 key 为 null
ClassCastException - 如果 key 不是 String
IllegalArgumentException - 如果 key 为空 String

size

public int size()
返回此映射中的键-值映射关系数。如果该映射包含的元素大于 Integer.MAX_VALUE，则返回 Integer.MAX_VALUE。

指定者：
接口 Map<String,Object> 中的 size
返回：
此映射中的键-值映射关系数

values

public Collection<Object> values()
返回此映射中包含的值的 Collection 视图。该 collection 受映射支持，所以对映射的更改可在此 collection 中反映出来，反之亦然。如果对该 collection 进行迭代的同时修改了映射（通过迭代器自己的 remove 操作除外），则迭代结果是不确定的。collection 支持元素移除，通过 Iterator.remove、Collection.remove、removeAll、retainAll 和 clear 操作可从映射中移除相应的映射关系。它不支持 add 或 addAll 操作。

指定者：
接口 Map<String,Object> 中的 values
返回：
此映射中包含的值的 collection 视图
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SimpleScriptContext (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.script
类 SimpleScriptContext

java.lang.Object
    继承者  javax.script.SimpleScriptContext
所有已实现的接口：
ScriptContext
public class SimpleScriptContext
extends Object
implements ScriptContext

ScriptContext 的简单实现。

从以下版本开始：
1.6

字段摘要
protected Bindings | engineScope 此字段是引擎范围 bindings。
protected Writer | errorWriter 此字段是用于脚本输出错误的 writer。
protected Bindings | globalScope 此字段是全局范围 bindings。
protected Reader | reader 此字段是用于脚本输入的 reader。
protected Writer | writer 此字段是用于脚本输出的 writer。
从接口 javax.script.ScriptContext 继承的字段
ENGINE_SCOPE, GLOBAL_SCOPE
构造方法摘要
SimpleScriptContext()
方法摘要
Object | getAttribute(String name) 获取范围中按搜索顺序最早出现的具有给定名称的属性的值。
Object | getAttribute(String name, int scope) 获取给定范围中某一属性的值。
int | getAttributesScope(String name) 获取用来定义属性的最小范围。
Bindings | getBindings(int scope) 如果指定范围为 ENGINE_SCOPE，则返回 engineScope 字段的值。
Writer | getErrorWriter() 返回用来显示错误输出的 Writer。
Reader | getReader() 返回脚本用来读取输入的 Reader。
List<Integer> | getScopes() 返回 ScriptContext 中所有有效范围值的不可变 List。
Writer | getWriter() 返回脚本的 Writer，以便在显示输出时使用。
Object | removeAttribute(String name, int scope) 移除给定范围中的某一属性。
void | setAttribute(String name, Object value, int scope) 设置给定范围中某一属性的值。
void | setBindings(Bindings bindings, int scope) 针对给定范围设置属性的 Bindings。
void | setErrorWriter(Writer writer) 设置用来显示错误输出的 Writer。
void | setReader(Reader reader) 设置脚本的 Reader，以读取输入。
void | setWriter(Writer writer) 设置脚本的 Writer，以便在显示输出时使用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

writer

protected Writer writer
此字段是用于脚本输出的 writer。默认情况下，使用基于 System.out 的 PrintWriter。可使用存取方法 getWriter 和 setWriter 来管理此字段。

另请参见：
System.out, PrintWriter

errorWriter

protected Writer errorWriter
此字段是用于脚本输出错误的 writer。默认情况下，使用基于 System.err 的 PrintWriter。可使用存取方法 getErrorWriter 和 setErrorWriter 来管理此字段。

另请参见：
System.err, PrintWriter

reader

protected Reader reader
此字段是用于脚本输入的 reader。默认情况下，此 reader 使用基于 System.in 的 InputStreamReader 和默认字符集。可使用存取方法 getReader 和 setReader 来管理此字段。

另请参见：
System.in, InputStreamReader

engineScope

protected Bindings engineScope
此字段是引擎范围 bindings。默认情况下，使用 SimpleBindings。可使用存取方法 setBindings 和 getBindings 来管理此字段。

另请参见：
SimpleBindings

globalScope

protected Bindings globalScope
此字段是全局范围 bindings。默认情况下，使用 null 值（表示没有全局范围）。可使用存取方法 setBindings 和 getBindings 来管理此字段。

构造方法详细信息

SimpleScriptContext

public SimpleScriptContext()
方法详细信息

setBindings

public void setBindings(Bindings bindings,
                        int scope)
针对给定范围设置属性的 Bindings。如果范围值为 ENGINE_SCOPE，则使用给定 Bindings 替代 engineScope 字段。如果范围值为 GLOBAL_SCOPE，则使用给定 Bindings 替换 globalScope 字段。

指定者：
接口 ScriptContext 中的 setBindings
参数：
bindings - 要设置的属性的 Bindings。
scope - 范围值，将在该范围中设置属性。
抛出：
IllegalArgumentException - 如果 scope 无效。
NullPointerException - 如果 scope 的值为 ENGINE_SCOPE 并且指定的 Bindings 为 null。

getAttribute

public Object getAttribute(String name)
获取范围中按搜索顺序最早出现的具有给定名称的属性的值。搜索顺序由范围参数的数值确定（从最小的范围值开始）。

指定者：
接口 ScriptContext 中的 getAttribute
参数：
name - 要获取的属性的名称。
返回：
具有给定名称的属性的值，该属性位于定义它的最小范围中。如果任何范围中都不存在具有该名称的属性，则返回 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

getAttribute

public Object getAttribute(String name,
                           int scope)
获取给定范围中某一属性的值。

指定者：
接口 ScriptContext 中的 getAttribute
参数：
name - 要获取的属性名称。
scope - 将在其中获取属性的范围。
返回：
属性值。返回 null 表示 name 不存在于给定范围中。
抛出：
IllegalArgumentException - 如果 name 为空，或者 scope 的值无效。
NullPointerException - 如果 name 为 null。

removeAttribute

public Object removeAttribute(String name,
                              int scope)
移除给定范围中的某一属性。

指定者：
接口 ScriptContext 中的 removeAttribute
参数：
name - 要移除的属性的名称
scope - 移除属性的范围
返回：
移除的值。
抛出：
IllegalArgumentException - 如果 name 为空，或者 scope 无效。
NullPointerException - 如果 name 为 null。

setAttribute

public void setAttribute(String name,
                         Object value,
                         int scope)
设置给定范围中某一属性的值。

指定者：
接口 ScriptContext 中的 setAttribute
参数：
name - 要设置的属性的名称
value - 属性值
scope - 属性的设置范围
抛出：
IllegalArgumentException - 如果 name 为空，或者 scope 无效。
NullPointerException - 如果 name 为 null。

getWriter

public Writer getWriter()
返回脚本的 Writer，以便在显示输出时使用。

指定者：
接口 ScriptContext 中的 getWriter
返回：
Writer。

getReader

public Reader getReader()
返回脚本用来读取输入的 Reader。

指定者：
接口 ScriptContext 中的 getReader
返回：
Reader。

setReader

public void setReader(Reader reader)
设置脚本的 Reader，以读取输入。

指定者：
接口 ScriptContext 中的 setReader
参数：
reader - 新的 Reader。

setWriter

public void setWriter(Writer writer)
设置脚本的 Writer，以便在显示输出时使用。

指定者：
接口 ScriptContext 中的 setWriter
参数：
writer - 新的 Writer。

getErrorWriter

public Writer getErrorWriter()
返回用来显示错误输出的 Writer。

指定者：
接口 ScriptContext 中的 getErrorWriter
返回：
Writer

setErrorWriter

public void setErrorWriter(Writer writer)
设置用来显示错误输出的 Writer。

指定者：
接口 ScriptContext 中的 setErrorWriter
参数：
writer - Writer。

getAttributesScope

public int getAttributesScope(String name)
获取用来定义属性的最小范围。

指定者：
接口 ScriptContext 中的 getAttributesScope
参数：
name - 属性的名称。
返回：
最小范围。如果在任何范围内都没有定义具有给定名称的属性，则返回 -1。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

getBindings

public Bindings getBindings(int scope)
如果指定范围为 ENGINE_SCOPE，则返回 engineScope 字段的值。如果指定范围为 GLOBAL_SCOPE，则返回 globalScope 字段的值。

指定者：
接口 ScriptContext 中的 getBindings
参数：
scope - 指定范围
返回：
engineScope 或 globalScope 字段的值。
抛出：
IllegalArgumentException - 如果 scope 的值无效。

getScopes

public List<Integer> getScopes()
返回 ScriptContext 中所有有效范围值的不可变 List。

指定者：
接口 ScriptContext 中的 getScopes
返回：
范围值列表
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.script (Java 2 Platform SE 6)

 javax.script
接口
Bindings
Compilable
Invocable
ScriptContext
ScriptEngine
ScriptEngineFactory
类
AbstractScriptEngine
CompiledScript
ScriptEngineManager
SimpleBindings
SimpleScriptContext
异常
ScriptException


javax.script (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.script

脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

请参见：
描述

接口摘要
Bindings | 所有键均为 String 的键/值对映射关系。
Compilable | 由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法将脚本编译成无需重新编译就能反复执行的某种形式。
Invocable | 由 ScriptEngines 实现的可选接口，该 ScriptEngines 的方法允许在以前执行过的脚本中调用程序。
ScriptContext | 该接口的实现类被用来连接 Script Engines 和宿主应用程序中的对象（如有范围的 Bindings）。
ScriptEngine | ScriptEngine 是基础接口，该接口的方法在此规范的每个实现中都必须具有完整的功能。
ScriptEngineFactory | ScriptEngineFactory 用来描述和实例化 ScriptEngine。

类摘要
AbstractScriptEngine | 为几个 eval 方法的变体提供标准实现。
CompiledScript | 存储编译结果的类扩展自此类。
ScriptEngineManager | ScriptEngineManager 为 ScriptEngine 类实现一个发现和实例化机制，还维护一个键/值对集合来存储所有 Manager 创建的引擎所共享的状态。
SimpleBindings | 一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。
SimpleScriptContext | ScriptContext 的简单实现。

异常摘要
ScriptException 脚本 API 的一般 Exception 类。

软件包 javax.script 的描述

脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。此 API 供那些希望在其 Java 应用程序中执行用脚本语言编写的程序的应用程序编程人员使用。脚本语言程序通常由应用程序的终端用户提供。

javax.script 包的主要功能有：

  1. 脚本执行：脚本是用作脚本引擎所执行程序的源的字符流。脚本执行使用 ScriptEngine 的 eval 方法和 Invocable 接口的方法。

  2. 绑定：此功能允许将 Java 对象作为指定变量公开给脚本程序。Bindings 和 ScriptContext 类用于此目的。

  3. 编译：此功能允许反复存储和执行脚本引擎前端所生成的中间代码。这有利于多次执行相同脚本的应用程序。引擎的前端只需要对每个脚本执行一次，而不是每次脚本执行都执行一次，因此这些应用程序可以获得高效率。注意，此功能是可选的，脚本引擎可以选择不实现它。调用者需要使用 instanceof 来检查 Compilable 接口的可用性。

  4. 调用：此功能允许重用脚本引擎前端所生成的中间代码。编译功能允许重执行中间代码所表示的整个脚本，而调用功能允许重执行脚本中的个别程序/方法。因为对于编译而言，并非所有的脚本引擎都需要提供此功能。调用者必须检查 Invocable 的可用性。

  5. 脚本引擎发现和元数据：为脚本 API 编写的应用程序可能对脚本引擎有特定的要求。一些可能需要特定的脚本语言和/或版本，而另一些可能需要特定的实现引擎和/或版本。脚本引擎是以指定方式打包的，从而可以在运行时被发现，并可以查询属性。Engine 发现机制基于 Jar 文件规范中描述的 Service 发现机制。脚本引擎实现类打包在 jar 文件中，这些文件包含一个名为 META-INF/services/javax.script.ScriptEngineFactory 的文本资源。此资源必须为打包在 jar 文件中的每个 ScriptEngineFactory 包含一个行。ScriptEngineManager 包括 getEngineFactories 方法，该方法用于获取所有使用此机制发现的 ScriptEngineFactory 实例。ScriptEngineFactory 拥有用于查询关于脚本引擎的属性的方法。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.script 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.script 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.script.AbstractScriptEngine (implements javax.script.ScriptEngine)
    • javax.script.CompiledScript
    • javax.script.ScriptEngineManager
    • javax.script.SimpleBindings (implements javax.script.Bindings)
    • javax.script.SimpleScriptContext (implements javax.script.ScriptContext)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.script.ScriptException

接口分层结构

  • javax.script.Compilable
  • javax.script.Invocable
  • java.util.Map<K,V>
    • javax.script.Bindings
  • javax.script.ScriptContext
  • javax.script.ScriptEngine
  • javax.script.ScriptEngineFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.script 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.script
的使用

使用 javax.script 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 使用的 javax.script 中的类
Bindings
所有键均为 String 的键/值对映射关系。
CompiledScript
存储编译结果的类扩展自此类。
ScriptContext
该接口的实现类被用来连接 Script Engines 和宿主应用程序中的对象（如有范围的 Bindings）。
ScriptEngine
ScriptEngine 是基础接口，该接口的方法在此规范的每个实现中都必须具有完整的功能。
ScriptEngineFactory
ScriptEngineFactory 用来描述和实例化 ScriptEngine。
ScriptException
脚本 API 的一般 Exception 类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.script.AbstractScriptEngine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.AbstractScriptEngine
的使用

没有 javax.script.AbstractScriptEngine 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.script.Bindings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.Bindings
的使用

使用 Bindings 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 Bindings 的使用

实现 Bindings 的 javax.script 中的类
 class SimpleBindings
一个受 HashMap 或其他某些指定 Map 支持的 Bindings 的简单实现。

声明为 Bindings 的 javax.script 中的字段
protected Bindings | SimpleScriptContext.engineScope 此字段是引擎范围 bindings。
protected Bindings | SimpleScriptContext.globalScope 此字段是全局范围 bindings。

返回 Bindings 的 javax.script 中的方法
Bindings | ScriptEngine.createBindings() 返回一个未初始化的 Bindings。
Bindings | ScriptEngineManager.getBindings() getBindings 返回 globalScope 字段的值。
Bindings | AbstractScriptEngine.getBindings(int scope) 返回受保护 context 字段中具有指定范围值的 Bindings。
Bindings | ScriptContext.getBindings(int scope) 获取与此 ScriptContext 中的给定范围关联的 Bindings。
Bindings | ScriptEngine.getBindings(int scope) 返回指定值的范围。
Bindings | SimpleScriptContext.getBindings(int scope) 如果指定范围为 ENGINE_SCOPE，则返回 engineScope 字段的值。

参数类型为 Bindings 的 javax.script 中的方法
 Object CompiledScript.eval(Bindings bindings)
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。
 Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
 Object ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
 Object AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。
 Object ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。
protected  ScriptContext AbstractScriptEngine.getScriptContext(Bindings nn)
返回一个 SimpleScriptContext。
 void ScriptEngineManager.setBindings(Bindings bindings)
setBindings 存储 globalScope 字段中的指定 Bindings。
 void AbstractScriptEngine.setBindings(Bindings bindings, int scope)
使用 context 字段中的相应范围值设置 Bindings。
 void ScriptContext.setBindings(Bindings bindings, int scope)
将 Bindings 实例与此 ScriptContext 中的特定范围关联。
 void ScriptEngine.setBindings(Bindings bindings, int scope)
设置将由脚本使用的指定值的范围。
 void SimpleScriptContext.setBindings(Bindings bindings, int scope)
针对给定范围设置属性的 Bindings。

参数类型为 Bindings 的 javax.script 中的构造方法
AbstractScriptEngine(Bindings n)
创建一个新实例，使用指定 Bindings 作为受保护 context 字段中的 ENGINE_SCOPE Bindings。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.script.Compilable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.Compilable
的使用

没有 javax.script.Compilable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.script.CompiledScript 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.CompiledScript
的使用

使用 CompiledScript 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 CompiledScript 的使用

返回 CompiledScript 的 javax.script 中的方法
CompiledScript | Compilable.compile(Reader script) 编译脚本（从 Reader 读取的源），以便以后执行。
CompiledScript | Compilable.compile(String script) 编译脚本（以 String 形式表示的源），以便以后执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.script.Invocable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.Invocable
的使用

没有 javax.script.Invocable 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.script.ScriptContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.ScriptContext
的使用

使用 ScriptContext 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptContext 的使用

实现 ScriptContext 的 javax.script 中的类
 class SimpleScriptContext
ScriptContext 的简单实现。

声明为 ScriptContext 的 javax.script 中的字段
protected  ScriptContext AbstractScriptEngine.context
此 AbstractScriptEngine 的默认 ScriptContext。

返回 ScriptContext 的 javax.script 中的方法
ScriptContext | AbstractScriptEngine.getContext() 返回受保护 context 字段的值。
ScriptContext | ScriptEngine.getContext() 返回 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。
protected ScriptContext | AbstractScriptEngine.getScriptContext(Bindings nn) 返回一个 SimpleScriptContext。

参数类型为 ScriptContext 的 javax.script 中的方法
 Object ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
abstract  Object CompiledScript.eval(ScriptContext context)
执行存储在此 CompiledScript 对象中的程序。
 Object ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。
 void AbstractScriptEngine.setContext(ScriptContext ctxt)
将受保护 context 字段的值设置为指定的 ScriptContext。
 void ScriptEngine.setContext(ScriptContext context)
设置 ScriptEngine 的默认 ScriptContext，在没有指定 ScriptContext 时，该 ScriptEngine 的 Bindings、Reader 和 Writer 被用于脚本执行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.script.ScriptEngine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.ScriptEngine
的使用

使用 ScriptEngine 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptEngine 的使用

实现 ScriptEngine 的 javax.script 中的类
 class AbstractScriptEngine
为几个 eval 方法的变体提供标准实现。

返回 ScriptEngine 的 javax.script 中的方法
abstract ScriptEngine | CompiledScript.getEngine() 返回用 compile 方法创建了此 CompiledScript 的 ScriptEngine。
ScriptEngine | ScriptEngineManager.getEngineByExtension(String extension) 查找并创建一个给定扩展的 ScriptEngine。
ScriptEngine | ScriptEngineManager.getEngineByMimeType(String mimeType) 查找并创建一个给定 mime 类型的 ScriptEngine。
ScriptEngine | ScriptEngineManager.getEngineByName(String shortName) 查找并创建一个给定名称的 ScriptEngine。
ScriptEngine | ScriptEngineFactory.getScriptEngine() 返回与此 ScriptEngineFactory 关联的 ScriptEngine 的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.script.ScriptEngineFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.script.ScriptEngineFactory
的使用

使用 ScriptEngineFactory 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptEngineFactory 的使用

返回 ScriptEngineFactory 的 javax.script 中的方法
 ScriptEngineFactory ScriptEngine.getFactory()
返回此 ScriptEngine 所属的类的 ScriptEngineFactory。

返回变量类型为 ScriptEngineFactory 的类型的 javax.script 中的方法
 List<ScriptEngineFactory> ScriptEngineManager.getEngineFactories()
返回一个数组，该数组的元素是发现机制找到的所有 ScriptEngineFactory 类的实例。

参数类型为 ScriptEngineFactory 的 javax.script 中的方法
void | ScriptEngineManager.registerEngineExtension(String extension, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理扩展。
void | ScriptEngineManager.registerEngineMimeType(String type, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理 mime 类型。
void | ScriptEngineManager.registerEngineName(String name, ScriptEngineFactory factory) 注册一个 ScriptEngineFactory 来处理语言名称。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.script.ScriptEngineManager 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.ScriptEngineManager
的使用

没有 javax.script.ScriptEngineManager 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.script.ScriptException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.ScriptException
的使用

使用 ScriptException 的软件包
javax.script 脚本 API 由定义 Java TM Scripting Engines 的接口和类组成，并为它们在 Java 应用程序中的使用提供框架。

javax.script 中 ScriptException 的使用

抛出 ScriptException 的 javax.script 中的方法
 CompiledScript Compilable.compile(Reader script)
编译脚本（从 Reader 读取的源），以便以后执行。
 CompiledScript Compilable.compile(String script)
编译脚本（以 String 形式表示的源），以便以后执行。
 Object CompiledScript.eval()
执行存储在 CompiledScript 对象中的程序。
 Object CompiledScript.eval(Bindings bindings)
执行存储在 CompiledScript 对象中的程序，脚本执行期间使用所提供的属性的 Bindings 作为关联 ScriptEngine 的 ENGINE_SCOPE。
 Object AbstractScriptEngine.eval(Reader reader)
eval(Reader) 调用抽象 eval(Reader, ScriptContext)，并传递 context 字段的值给它。
 Object ScriptEngine.eval(Reader reader)
除了脚本的源是以 Reader 形式提供的外，与 eval(String) 相同。
 Object AbstractScriptEngine.eval(Reader reader, Bindings bindings)
eval(Reader, Bindings) 调用抽象 eval(Reader, ScriptContext) 方法，并传递一个 ScriptContext 给它，对于 ENGINE_SCOPE 以外的范围，该 ScriptContext 的 Reader、Writer 和 Bindings 等同于受保护 context 字段的 Reader、Writer 和 Bindings。
 Object ScriptEngine.eval(Reader reader, Bindings n)
除了脚本的源是以 Reader 形式提供的外，与 eval(String, Bindings) 相同。
 Object ScriptEngine.eval(Reader reader, ScriptContext context)
与 eval(String, ScriptContext) 相同，其中脚本的源是从 Reader 读取的。
abstract  Object CompiledScript.eval(ScriptContext context)
执行存储在此 CompiledScript 对象中的程序。
 Object AbstractScriptEngine.eval(String script)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader) 相同。
 Object ScriptEngine.eval(String script)
执行指定的脚本。
 Object AbstractScriptEngine.eval(String script, Bindings bindings)
除使用抽象 eval(String, ScriptContext) 之外，与 eval(Reader, Bindings) 相同。
 Object ScriptEngine.eval(String script, Bindings n)
执行脚本，脚本执行期间使用 Bindings 参数作为 ScriptEngine 的 ENGINE_SCOPE Bindings。
 Object ScriptEngine.eval(String script, ScriptContext context)
立即执行脚本，该脚本的源是作为第一个参数传递的 String。
 Object Invocable.invokeFunction(String name, Object... args)
用于调用脚本中定义的顶层程序和函数。
 Object Invocable.invokeMethod(Object thiz, String name, Object... args)
对以前的脚本执行中已经编译的脚本对象（以 ScriptEngine 的状态保持）调用某一方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.script.SimpleBindings 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.SimpleBindings
的使用

没有 javax.script.SimpleBindings 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.script.SimpleScriptContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.script.SimpleScriptContext
的使用

没有 javax.script.SimpleScriptContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AuthPermission (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
类 AuthPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.security.auth.AuthPermission
所有已实现的接口：
Serializable, Guard
public final class AuthPermission
extends BasicPermission

此类用于验证权限。AuthPermission 包含一个名称（也称为“目标名称”），但没有动作列表；您并非一定拥有所指定的权限。

目标名称就是安全配置参数的名称（见下文）。目前 AuthPermission 对象可用来保护对 Policy、Subject、LoginContext 和 Configuration 对象的访问。

AuthPermission 的可能目标名称有：

        doAs -                  允许调用者调用
                                Subject.doAs 方法。

        doAsPrivileged -        允许调用者调用
                                Subject.doAsPrivileged 方法。

       getSubject - 允许获取与当前的 Thread 关联的一个或多个 Subject（主题）。

        getSubjectFromDomainCombiner - 允许获取与 SubjectDomainCombiner 关联的 Subject。

        setReadOnly - 允许调用者将 Subject 设置为只读。

        modifyPrincipals - 允许调用者修改与 Subject 关联的 Principals Set。

        modifyPublicCredentials - 允许调用者修改与 Subject 关联的公共证书 Set。

        modifyPrivateCredentials - 允许调用者修改与 Subject 关联的私有证书 Set。

       refreshCredential - 允许代码在一个实现了 Refreshable 接口的证书对象上调用 refresh 方法。

        destroyCredential - 允许代码在一个实现了 Destroyable 接口的证书对象上调用 destroy 方法。

        createLoginContext.{name} - 允许代码用指定的 name 实例化一个 LoginContext。name 可用作为安装的登录 Configuration（通过 Configuration.getConfiguration() 返回）中的索引。name 可以使用通配符（设置为 '*'），从而允许使用任何名称。

       getLoginConfiguration - 允许获取系统级登录 Configuration。

        createLoginConfiguration.{type} - 允许代码通过 Configuration.getInstance 获取 Configuration 对象。

       setLoginConfiguration - 允许设置系统级登录 Configuration。

        refreshLoginConfiguration - 允许刷新系统级登录 Configuration。

以下目标名称已过时，推荐使用 createLoginContext.{name}。

        createLoginContext - 允许代码实例化一个 LoginContext。

javax.security.auth.Policy 已过时，推荐使用 java.security.Policy。因此，以下目标名称也已经过时：

        getPolicy - 允许调用者获取系统级基于 Subject 的访问控制策略。

        setPolicy - 允许调用者设置系统级基于 Subject 的访问控制策略。

        refreshPolicy - 允许调用者刷新系统级基于 Subject 的访问控制策略。

另请参见：
序列化表格

构造方法摘要
AuthPermission(String name)
创建具有指定名称的新 AuthPermission。
AuthPermission(String name, String actions)
创建具有指定名称的新 AuthPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AuthPermission

public AuthPermission(String name)
创建具有指定名称的新 AuthPermission。name 是 AuthPermission 的符号名。

参数：
name - AuthPermission 的名称
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

AuthPermission

public AuthPermission(String name,
                      String actions)
创建具有指定名称的新 AuthPermission 对象。name 是 AuthPermission 的符号名，并且 actions 字符串目前未使用，应该为 null。

参数：
name - AuthPermission 的名称

actions - 应该为 null。
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Destroyable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
接口 Destroyable

所有已知实现类：
KerberosKey, KerberosTicket, KeyStore.PasswordProtection, X500PrivateCredential
public interface Destroyable

诸如 credentials 之类的对象可以选择实现此接口以便提供销毁它的内容的功能。

另请参见：
Subject

方法摘要
void | destroy() 销毁此 Object。
boolean | isDestroyed() 确定此 Object 是否已经销毁。

方法详细信息

destroy

void destroy()
             throws DestroyFailedException
销毁此 Object。

销毁或清除与此 Object 相关的敏感信息。对此 Object 上某个方法的后续调用将导致抛出 IllegalStateException。

抛出：
DestroyFailedException - 如果销毁操作失败。

SecurityException - 如果调用者没有销毁此 Object 的权限。

isDestroyed

boolean isDestroyed()
确定此 Object 是否已经销毁。

返回：
如果此 Object 已经销毁，则返回 true；否则，返回 false。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DestroyFailedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
类 DestroyFailedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.auth.DestroyFailedException
所有已实现的接口：
Serializable
public class DestroyFailedException
extends Exception

当 destroy 操作失败时，抛出此异常。

此异常由实现 Destroyable 接口的证书在 destroy 方法失败时抛出。

另请参见：
序列化表格

构造方法摘要
DestroyFailedException()
构造不带详细消息的 DestroyFailedException。
DestroyFailedException(String msg)
构造带指定详细消息的 DestroyFailedException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DestroyFailedException

public DestroyFailedException()
构造不带详细消息的 DestroyFailedException。详细消息是描述此特定异常的字符串。

DestroyFailedException

public DestroyFailedException(String msg)
构造带指定详细消息的 DestroyFailedException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Policy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
类 Policy

java.lang.Object
    继承者  javax.security.auth.Policy
已过时。 从 JDK 1.4 版本开始，由 java.security.Policy 取代。java.security.Policy 有一个方法：
        public PermissionCollection getPermissions
            (java.security.ProtectionDomain pd)
ProtectionDomain 有一个构造方法：
        public ProtectionDomain
            (CodeSource cs,
             PermissionCollection permissions,
             ClassLoader loader,
             Principal[] principals)
这两个 API 为调用者提供向 Policy 查询基于 Principal 的 Permission 条目的方法。

@Deprecated
public abstract class Policy
extends Object

这是用于表示基于 Subject 授权的系统策略的抽象类。此类的子类实现提供一种方式来指定一个基于 Subject 的访问控制 Policy。

可以通过以下方式查询 Policy 对象，查找授予作为 Principal 运行的代码的 Permission 集合：

        policy = Policy.getPolicy();
        PermissionCollection perms = policy.getPermissions(subject,
                                                        codeSource);
Policy 对象查询本地策略，且返回适当的 Permissions 对象，该对象所具有的权限被授予与所提供的 subject 相关联的 Principals，同时也授予由提供的 codeSource 指定的代码。

Policy 包含下面的信息。注意，此例子只表示默认的 Policy 实现的语法。此类的子类实现可以实现替代语法，也可以根据任何如文件、数据库或服务器之类的源获取 Policy。

Policy 中的每一项表示为一个 grant 条目。每个 grant 条目指定代码基、代码签名者和 Principals 三元组，以及授予该三元组的 Permissions。

        grant CodeBase ["URL"], Signedby ["signers"],
              Principal [Principal_Class] "Principal_Name" {
            Permission Permission_Class ["Target_Name"]
                                        [, "Permission_Actions"]
                                        [, signedBy "SignerName"];
        };
三元组名称/值对的组成部分 CodeBase 和 Signedby 是可选的。如果它们不存在，任何代码基和任何签名者（包括未签名代码）都将相符。例如，
        grant CodeBase "foo.com", Signedby "foo",
              Principal com.sun.security.auth.SolarisPrincipal "duke" {
            permission java.io.FilePermission "/home/duke", "read, write";
        };
此 grant 条目指定 "foo.com" 中的代码，由 "foo" 签名,作为 SolarisPrincipal 运行且名称为 duke，权限为 Permission。此 Permission 允许执行代码在目录 "/home/duke" 下读取和写入文件。

为了作为一个特定的 Principal“运行”，代码调用 Subject.doAs(subject, ...) 方法。调用该方法后，代码作为与指定的 Subject 相关联的所有 Principals 运行。注意，只在调用 Subject.doAs 之后，此 Policy（以及在此 Policy 中授予的 Permission）才有效。

多个 Principals 可以列在一个 grant 条目中。在 grant 条目中的所有 Principals 必须与提供给 Subject.doAs 的 Subject 相关联，以便授予该 Subject 指定的 Permissions。

        grant Principal com.sun.security.auth.SolarisPrincipal "duke",
              Principal com.sun.security.auth.SolarisNumericUserPrincipal "0" {
            permission java.io.FilePermission "/home/duke", "read, write";
            permission java.net.SocketPermission "duke.com", "connect";
        };
此条目授予任何以 "duke" 和 "0" 运行的代码在 duke 的主目录下读取和写入文件的权限，以及创建到 "duke.com" 的套接字连接的权限。

注意，在此 Policy 中不允许非基于 Principal 的 grant 条目。因此，像下面这样的 grant 条目：

        grant CodeBase "foo.com", Signedby "foo" {
            permission java.io.FilePermission "/tmp/scratch", "read, write";
        };
是被拒绝的。这种权限必须列在 java.security.Policy 中。

可以通过把 "auth.policy.provider" 安全属性（在 Java 安全属性文件中）的值设置为所需的 Policy 实现类的完全限定名，从而改变默认的 Policy 实现。Java 安全属性文件位于名称为 <JAVA_HOME>/lib/security/java.security 的文件中。<JAVA_HOME> 是指 java.home 系统属性的值并指定安装 JRE 的目录。

构造方法摘要
protected Policy()
已过时。 唯一的构造方法。
方法摘要
abstract PermissionCollection | getPermissions(Subject subject, CodeSource cs) 已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。
static Policy | getPolicy() 已过时。 返回安装的 Policy 对象。
abstract void | refresh() 已过时。 刷新/重新加载 Policy。
static void | setPolicy(Policy policy) 已过时。 设置系统级 Policy 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Policy

protected Policy()
已过时。
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getPolicy

public static Policy getPolicy()
已过时。
返回安装的 Policy 对象。此方法首先通过 AuthPermission("getPolicy") 权限调用 SecurityManager.checkPermission ，以确保调用者具有获取 Policy 对象的权限。

返回：
安装的 Policy。返回值不能为 null。
抛出：
SecurityException - 如果当前线程不具有获取此 Policy 对象的权限。
另请参见：
setPolicy(javax.security.auth.Policy)

setPolicy

public static void setPolicy(Policy policy)
已过时。
设置系统级 Policy 对象。此方法首先通过 AuthPermission("setPolicy") 权限调用 SecurityManager.checkPermission ，以确保调用者具有设置 Policy 对象的权限。

参数：
policy - 新的系统 Policy 对象。
抛出：
SecurityException - 如果当前线程不具有设置此 Policy 的权限。
另请参见：
getPolicy()

getPermissions

public abstract PermissionCollection getPermissions(Subject subject,
                                                    CodeSource cs)
已过时。
获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。

参数：
subject - 与此 Subject（主题）所关联的 Principal（主体）与提供的 CodeSource 共同确定此方法返回的 Permission。此参数可以为 null。

cs - 它的 CodeSource 所指定的代码，与提供的 CodeSource 一起使用，确定此方法返回的 Permissions。此参数可以为 null。
返回：
授予所有的 Subject 以及提供的 subject 和 cs 参数中指定的代码的 Permissions Collection。

refresh

public abstract void refresh()
已过时。
刷新/重新加载 Policy。

此方法使该对象刷新/重新加载其当前 Policy。这是依赖于实现的。例如，如果 Policy 对象存储在文件中，调用 refresh 将会引起重新读取该文件。

抛出：
SecurityException - 如果调用者没有刷新此 Policy 的权限。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PrivateCredentialPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
类 PrivateCredentialPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  javax.security.auth.PrivateCredentialPermission
所有已实现的接口：
Serializable, Guard
public final class PrivateCredentialPermission
extends Permission

此类用来保护对属于特定 Subject 的私有 Credential 的访问。Subject 通过 Principals Set 表示。

此 Permission 的目标名称指定了一个 Credential 类名和一个 Principals Set。此 Permission 的操作的唯一有效值是 "read"。目标名称必须遵守下面的语法：

        CredentialClass {PrincipalClass "PrincipalName"}*
例如，下面的权限授予对 Subjects 拥有的 com.sun.PrivateCredential 的访问，该 Subjects 有一个 com.sun.Principal,名称为 "duke"。注意，尽管此例子（以及下面的所有例子）在 grant 语句中不包含 Codebase、SignedBy 或 Principal 信息（为了使例子简单），但是实际的策略配置在适当的时候应该指定该信息。

    grant {
        permission javax.security.auth.PrivateCredentialPermission
                "com.sun.PrivateCredential com.sun.Principal \"duke\"",
                "read";
    };
如果 CredentialClass 为 "*"，那么授予属于指定的 Subject 的所有 Credential 访问权限。如果 "PrincipalName" 为 "*"，那么授予指定的由任何 Subject 拥有的 Credential 访问权限，此 Subject 具有指定的 Principal （实际的 PrincipalName 无关紧要）。例如，下面的语句授予对任何有 a.b.Principal 的 Subject 所拥有的 a.b.Credential 访问权限。
    grant {
        permission javax.security.auth.PrivateCredentialPermission
                "a.b.Credential a.b.Principal "*"",
                "read";
    };
如果 PrincipalClass 和 "PrincipalName" 都为 "*"，那么授予由任何 Subject 拥有的指定的 Credential 访问权限。

另外，PrincipalClass/PrincipalName 对可以重复：

    grant {
        permission javax.security.auth.PrivateCredentialPermission
                "a.b.Credential a.b.Principal "duke" c.d.Principal "dukette"",
                "read";
    };
上面的语句授予对私有 Credential（"a.b.Credential"）的访问权限，"a.b.Credential" 属于带有至少两个 Principals 的 Subject：名称为 "duke" 的 "a.b.Principal"，和名称为 "dukette" 的 "c.d.Principal"。

另请参见：
序列化表格

构造方法摘要
PrivateCredentialPermission(String name, String actions)
创建具有指定 name 的新 PrivateCredentialPermission。
方法摘要
boolean | equals(Object obj) 检查两个 PrivateCredentialPermission 对象是否相等。
String | getActions() 返回操作的“规范的字符串表示形式”。
String | getCredentialClass() 返回与此 PrivateCredentialPermission 相关联的 Credential 的 Class 名称。
String[][] | getPrincipals() 返回与此 PrivateCredentialPermission 相关联的 Principal 类和名称。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此 PrivateCredentialPermission 是否暗含指定的Permission。
PermissionCollection | newPermissionCollection() 返回 PermissionCollection 中同类的 PrivateCredentialPermissions 集合。
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

PrivateCredentialPermission

public PrivateCredentialPermission(String name,
                                   String actions)
创建具有指定 name 的新 PrivateCredentialPermission。name 指定了一个 Credential 类和一个 Principal 集合。

参数：
name - 指定 Credential 类和 Principal 集合的名称。

actions - 指定 Credential 能够被读取的操作。
抛出：
IllegalArgumentException - 如果 name 没有遵循正确的语法或者如果 actions 不是 "read"。
方法详细信息

getCredentialClass

public String getCredentialClass()
返回与此 PrivateCredentialPermission 相关联的 Credential 的 Class 名称。

返回：
与此 PrivateCredentialPermission 相关联的 Credential 的 Class 名称。

getPrincipals

public String[][] getPrincipals()
返回与此 PrivateCredentialPermission 相关联的 Principal 类和名称。信息以二维数组 (array[x][y]) 的形式返回。'x' 值对应于 Principal 的类和名称对的数目。当 (y==0) 时，它对应于 Principal 类值，当 (y==1) 时,它对应于 Principal 名称值。例如，array[0][0] 对应于数组中的第一个 Principal 的类名。array[0][1] 对应于数组中的第一个 Principal 的 Principal 名。

返回：
与此 PrivateCredentialPermission 相关联的 Principal 类和名称。

implies

public boolean implies(Permission p)
检查此 PrivateCredentialPermission 是否暗含指定的Permission。

如果满足下面的条件，则此方法返回 true：

  • p 是 PrivateCredentialPermission 的一个实例，且

  • 此对象的目标名称隐含了 p 的目标名称。例如：
            [* P1 "duke"] implies [a.b.Credential P1 "duke"].
        [C1 P1 "duke"] implies [C1 P1 "duke" P2 "dukette"].
        [C1 P2 "dukette"] implies [C1 P1 "duke" P2 "dukette"].

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的 Permission。
返回：
如果此 PrivateCredentialPermission 隐含了指定的 Permission，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 PrivateCredentialPermission 对象是否相等。检查 obj 是否为 PrivateCredentialPermission，是否与此对象具有相同的证书类以及相同的 Principals。在各自的 Permission 的目标名称中的 Principals 的顺序是无关的。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 为 PrivateCredentialPermission，与此对象具有相同的证书类以及相同的 Principals，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回操作的“规范的字符串表示形式”。此方法总是返回 String "read"。

指定者：
类 Permission 中的 getActions
返回：
操作（总是返回 "read"）。

newPermissionCollection

public PermissionCollection newPermissionCollection()
返回 PermissionCollection 中同类的 PrivateCredentialPermissions 集合。没有定义这种 PermissionCollection，所以此方法总是返回 null。

覆盖：
类 Permission 中的 newPermissionCollection
返回：
所有情况下都返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Refreshable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
接口 Refreshable

所有已知实现类：
KerberosTicket
public interface Refreshable

诸如证书之类的对象可以选择实现此接口，以提供对自己进行刷新的功能。例如，有特定限时生存期的证书可以实现此接口，以允许调用者刷新使它有效的时间周期。

另请参见：
Subject

方法摘要
boolean | isCurrent() 确定此 Object 是否是当前的。
void | refresh() 更新或延长此 Object 的有效期。

方法详细信息

isCurrent

boolean isCurrent()
确定此 Object 是否是当前的。

返回：
如果此 Object 是当前的，则返回 true；否则，返回 false。

refresh

void refresh()
             throws RefreshFailedException
更新或延长此 Object 的有效期。

抛出：
SecurityException - 如果调用者没有更新或延长此 Object 的有效期的权限。

RefreshFailedException - 如果刷新企图失败。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RefreshFailedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
类 RefreshFailedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.auth.RefreshFailedException
所有已实现的接口：
Serializable
public class RefreshFailedException
extends Exception

当 refresh 操作失败时，抛出此异常。

此异常由实现 Refreshable 接口的证书在 refresh 方法失败时抛出。

另请参见：
序列化表格

构造方法摘要
RefreshFailedException()
构造不带详细消息的 RefreshFailedException。
RefreshFailedException(String msg)
构造带指定详细消息的 RefreshFailedException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RefreshFailedException

public RefreshFailedException()
构造不带详细消息的 RefreshFailedException。详细消息是描述此特定异常的 String。

RefreshFailedException

public RefreshFailedException(String msg)
构造带指定详细消息的 RefreshFailedException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Subject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
类 Subject

java.lang.Object
    继承者  javax.security.auth.Subject
所有已实现的接口：
Serializable
public final class Subject
extends Object
implements Serializable

Subject 表示某一项（如一个人）的一组相关信息。此类信息包括 Subject 的身份，以及与安全相关的属性（例如，密码和加密密钥）。

Subject 可以潜在地具有多重身份。每个身份被表示为 Subject 中的一个 Principal。Principal 只是把名称绑定到 Subject。例如，Subject 正好是一个人（Alice）时,它可以有两个主体：一个把她驾驶证上的名称 "Alice Bar" 绑定到 Subject，另一个把学生身份证上的号码 "999-99-9999" 绑定到 Subject。即使每个主体具有不同的名称，它们也都指的是同一个 Subject。

Subject 也可以拥有与安全相关的属性，它们被称为证书。敏感的证书需要特殊的保护，例如私有加密密钥存储在私有的证书 Set 中。将证书设计为共享的，例如公钥证书或 Kerberos 服务票据存储在一个公开证书 Set 中。访问和修改不同的证书 Set 需要不同的权限。

要获取与 Subject 关联的所有 Principal，请调用 getPrincipals 方法。要获取属于一个 Subject 的所有公开的或私有的证书，请分别调用 getPublicCredentials 方法或 getPrivateCredentials 方法。要修改返回的 Principal 和证书的 Set，请使用定义在 Set 类中的方法。例如：

        Subject subject;
        Principal principal;
        Object credential;

        // add a Principal and credential to the Subject
        subject.getPrincipals().add(principal);
        subject.getPublicCredentials().add(credential);

此 Subject 类实现 Serializable。但与 Subject 关联的 Principal 是已序列化的，与 Subject 关联的证书不是已序列化的。注意，java.security.Principal 类不会实现 Serializable。因此，与 Subject 关联的所有具体的 Principal 实现必须实现 Serializable。

另请参见：
Principal, DomainCombiner, 序列化表格

构造方法摘要
Subject()
创建一个带有空的 Principal Set 和空的公开或私有证书 Set 的 Subject 的一个实例。
Subject(boolean readOnly, Set<? extends Principal> principals, Set<?> pubCredentials, Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。
方法摘要
static
<T> T
doAs(Subject subject, PrivilegedAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
doAs(Subject subject, PrivilegedExceptionAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
static
<T> T
doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
 boolean equals(Object o)
比较指定对象与此 Subject 的相等性。
 Set<Principal> getPrincipals()
返回与此 Subject 关联的 Principal Set。
<T extends Principal>
Set<T>
getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。
 Set<Object> getPrivateCredentials()
返回此 Subject 中包含的私有证书 Set。
<T> Set<T>
getPrivateCredentials(Class<T> c)
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。
 Set<Object> getPublicCredentials()
返回此 Subject 中包含的公开证书 Set。
<T> Set<T>
getPublicCredentials(Class<T> c)
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。
static Subject getSubject(AccessControlContext acc)
获取与提供的 AccessControlContext 关联的 Subject。
 int hashCode()
返回此 Subject 的哈希码。
 boolean isReadOnly()
查询此 Subject 是否为只读的。
 void setReadOnly()
将此 Subject 设置为只读的。
 String toString()
返回此 Subject 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Subject

public Subject()
创建一个带有空的 Principal Set 和空的公开或私有证书 Set 的 Subject 的一个实例。

在新构建的 Set 允许进行后续修改前检查此 Subject 是否已设置为只读的。新创建的 Set 还通过确保调用者具有足够权限的方式来防止非法修改。

要修改 Principal Set，调用者必须具有 AuthPermission("modifyPrincipals") 权限。要修改公开证书 Set，调用者必须具有 AuthPermission("modifyPublicCredentials") 权限。要修改私有证书 Set，调用者必须具有 AuthPermission("modifyPrivateCredentials") 权限。

Subject

public Subject(boolean readOnly,
               Set<? extends Principal> principals,
               Set<?> pubCredentials,
               Set<?> privCredentials)
创建带有 Principal 和证书的 Subject 的实例。

指定将 Set 中的 Principal 和证书复制到新构建的 Set 中。在新创建的 Set 允许进行后续修改前检查此 Subject 是否已设置为只读的。新创建的 Set 还通过确保调用者具有足够权限的方式来防止非法修改。

要修改 Principal Set，调用者必须具有 AuthPermission("modifyPrincipals") 权限。要修改公开证书 Set，调用者必须具有 AuthPermission("modifyPublicCredentials") 权限。要修改私有证书 Set，调用者必须具有 AuthPermission("modifyPrivateCredentials") 权限。

参数：
readOnly - 如果 Subject 是只读的，则参数为 true，否则为 false。

principals - 要与此 Subject 关联的 Principal Set。

pubCredentials - 要与此 Subject 关联的公开证书 Set。

privCredentials - 要与此 Subject 关联的私有证书 Set。
抛出：
NullPointerException - 如果指定的 principals、pubCredentials 或 privCredentials 为 null。
方法详细信息

setReadOnly

public void setReadOnly()
将此 Subject 设置为只读的。

对此 Subject 的 Principal Set 和证书 Set 的修改（添加和移除）将是不允许的。仍然允许在此 Subject 的证书上进行 destroy 操作。

如果后续企图修改 Subject 的 Principal 和证书 Set，将导致抛出 IllegalStateException。另外，一旦 Subject 是只读的，就不可能再将它重新设置为可写的。

抛出：
SecurityException - 如果调用者不具有将此 Subject 设置为只读的权限。

isReadOnly

public boolean isReadOnly()
查询此 Subject 是否为只读的。

返回：
如果此 Subject 为只读的，则返回 true；否则，返回 false。

getSubject

public static Subject getSubject(AccessControlContext acc)
获取与提供的 AccessControlContext 关联的 Subject。

AccessControlContext 可以包含很多 Subject（从嵌套的 doAs 调用得到）。在这种情况下，返回与 AccessControlContext 关联的最近的 Subject。

参数：
acc - AccessControlContext，从它获取 Subject。
返回：
与所提供的 AccessControlContext 关联的 Subject，如果没有 Subject 与提供的 AccessControlContext 相关联，则返回 null。
抛出：
SecurityException - 如果调用者不具有获取此 Subject 的权限。

NullPointerException - 如果提供的 AccessControlContext 为 null。

doAs

public static <T> T doAs(Subject subject,
                         PrivilegedAction<T> action)
作为特定的 Subject 的功能。

此方法首先通过 AccessController.getContext 获取当前 Thread 的 AccessControlContext，接着使用获得的上下文与新的 SubjectDomainCombiner （使用提供的 Subject 构建）实例化一个 AccessControlContext。最后，此方法调用 AccessController.doPrivileged，将提供的 PrivilegedAction 以及新构建的 AccessControlContext 传递到 AccessController.doPrivileged。

参数：
subject - 指定的 action 将作为该 Subject 运行。此参数可以为 null。

action - 将作为指定的 Subject 运行的代码。

返回：
PrivilegedAction 的 run 方法所返回的值。
抛出：
NullPointerException - 如果 PrivilegedAction 为 null。

SecurityException - 如果调用者不具有调用此方法的权限。

doAs

public static <T> T doAs(Subject subject,
                         PrivilegedExceptionAction<T> action)
              throws PrivilegedActionException
作为特定的 Subject 的功能。

此方法首先通过 AccessController.getContext 获取当前 Thread 的 AccessControlContext，接着使用获得的上下文与新的 SubjectDomainCombiner（使用提供的 Subject 构建）实例化一个 AccessControlContext。最后，此方法调用 AccessController.doPrivileged，将提供的 PrivilegedExceptionAction 以及新构建的 AccessControlContext 传递到 AccessController.doPrivileged。

参数：
subject - 指定的 action 将作为该 Subject 运行。此参数可以为 null。

action - 将作为指定的 Subject 运行的代码。

返回：
PrivilegedExceptionAction 的 run 方法所返回的值。
抛出：
PrivilegedActionException - 如果 PrivilegedExceptionAction.run 方法抛出经过检查的异常。

NullPointerException - 如果指定的 PrivilegedExceptionAction 为 null。

SecurityException - 如果调用者不具有调用此方法的权限。

doAsPrivileged

public static <T> T doAsPrivileged(Subject subject,
                                   PrivilegedAction<T> action,
                                   AccessControlContext acc)
作为特定的 Subject 的特权功能。

除了使用提供的 AccessControlContext，而不是获取当前 Thread 的 AccessControlContext 外，此方法的行为与 Subject.doAs 完全一样。如果提供的 AccessControlContext 为 null，则此方法实例化一个新的带有空 ProtectionDomains 集合的 AccessControlContext。

参数：
subject - 指定的 action 将作为该 Subject 运行。此参数可以为 null。

action - 将作为指定的 Subject 运行的代码。

acc - 限制为指定 subject 和 action 的 AccessControlContext。

返回：
PrivilegedAction 的 run 方法所返回的值。
抛出：
NullPointerException - 如果 PrivilegedAction 为 null。

SecurityException - 如果调用者不具有调用此方法的权限。

doAsPrivileged

public static <T> T doAsPrivileged(Subject subject,
                                   PrivilegedExceptionAction<T> action,
                                   AccessControlContext acc)
                        throws PrivilegedActionException
作为特定的 Subject 的特权功能。

除了使用提供的 AccessControlContext，而不是获取当前 Thread 的 AccessControlContext 外，此方法的行为与 Subject.doAs 完全一样。如果提供的 AccessControlContext 为 null，则此方法实例化一个新的带有空 ProtectionDomains 集合的 AccessControlContext。

参数：
subject - 指定的 action 将作为该 Subject 运行。此参数可以为 null。

action - 将作为指定的 Subject 运行的代码。

acc - 限制为指定 subject 和 action 的 AccessControlContext。

返回：
PrivilegedExceptionAction 的 run 方法所返回的值。
抛出：
PrivilegedActionException - 如果 PrivilegedExceptionAction.run 方法抛出经过检查的异常。

NullPointerException - 如果指定的 PrivilegedExceptionAction 为 null。

SecurityException - 如果调用者不具有调用此方法的权限。

getPrincipals

public Set<Principal> getPrincipals()
返回与此 Subject 关联的 Principal Set。每个 Principal 表示此 Subject 的一个身份。

此 Subject 的内部 Principal Set 支持返回的 Set。对返回的 Set 的任何修改也影响内部的 Principal Set。

返回：
与此 Subject 关联的 Principal Set。

getPrincipals

public <T extends Principal> Set<T> getPrincipals(Class<T> c)
返回与此 Subject 关联的 Principal Set，它是指定的 Class 的实例或子类。

此 Subject 的内部 Principal Set 不支持返回的 Set。每次方法调用都创建和返回一个新的 Set。对返回的 Set 的修改不影响内部的 Principal Set。

参数：
c - 返回的 Principal Set 将都是此类的实例。
返回：
是指定的 Class 的实例的 Principal Set。
抛出：
NullPointerException - 如果指定的 Class 为 null。

getPublicCredentials

public Set<Object> getPublicCredentials()
返回此 Subject 中包含的公开证书 Set。

此 Subject 的内部公开证书 Set 支持返回的 Set。对返回的 Set 的任何修改也影响内部公开证书 Set。

返回：
此 Subject 中包含的公开证书 Set。

getPrivateCredentials

public Set<Object> getPrivateCredentials()
返回此 Subject 中包含的私有证书 Set。

此 Subject 的内部私有证书 Set 支持返回的 Set。对返回的 Set 的任何修改也影响内部私有证书 Set。

调用者需要权限来访问返回的 Set 中的证书，或修改 Set 本身。如果调用者不具有正确的权限,则会抛出 SecurityException。

当迭代 Set 时，如果调用者不具有访问特定证书的权限，则抛出 SecurityException。Iterator 仍然是前移到 Set 中的下一个元素。

返回：
此 Subject 中包含的私有证书 Set。

getPublicCredentials

public <T> Set<T> getPublicCredentials(Class<T> c)
返回与此 Subject 关联的公开证书 Set，它是指定的 Class 的实例或子类。

此 Subject 的内部公开证书 Set 不支持返回的 Set。每次方法调用都创建和返回一个新的 Set。对返回的 Set 的修改不影响内部公开证书 Set。

参数：
c - 返回的公开证书 Set 将都是此类的实例。
返回：
是指定的 Class 的实例的公开证书 Set。
抛出：
NullPointerException - 如果指定的 Class 为 null。

getPrivateCredentials

public <T> Set<T> getPrivateCredentials(Class<T> c)
返回与此 Subject关联的私有证书 Set，它是指定的 Class 的实例或子类。

调用者必须具有访问所有请求证书的权限，否则将抛出 SecurityException。

此 Subject 的内部私有证书 Set 不支持返回的 Set。每次方法调用都创建和返回一个新的 Set。对返回的 Set 的修改不影响内部私有证书 Set。

参数：
c - 返回的私有证书 Set 将都是此类的实例。
返回：
是指定的 Class 的实例的私有证书 Set。
抛出：
NullPointerException - 如果指定的 Class 为 null。

equals

public boolean equals(Object o)
比较指定对象与此 Subject 的相等性。如果给定对象也是一个 Subject 并且两个 Subject 是等效的，则返回 true。更正式地说，如果两个 Subject 的 Principal 和 Credential Set 是相等的，则它们的实例就是相等的。

覆盖：
类 Object 中的 equals
参数：
o - 要与此 Subject 进行相等性比较的对象。
返回：
如果指定的对象与此 Subject 相等，则返回 true。
抛出：
SecurityException - 如果调用者不具有访问此 Subject 的私有证书的权限，或者如果调用者不具有访问所提供的 Subject 的私有证书的权限。
另请参见：
Object.hashCode(), Hashtable

toString

public String toString()
返回此 Subject 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此 Subject 的字符串表示形式。

hashCode

public int hashCode()
返回此 Subject 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
此 Subject 的哈希码。
抛出：
SecurityException - 如果调用者不具有访问此 Subject 的私有证书的权限。
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SubjectDomainCombiner (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth
类 SubjectDomainCombiner

java.lang.Object
    继承者  javax.security.auth.SubjectDomainCombiner
所有已实现的接口：
DomainCombiner
public class SubjectDomainCombiner
extends Object
implements DomainCombiner

SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。

构造方法摘要
SubjectDomainCombiner(Subject subject)
将提供的 Subject 与此 SubjectDomainCombiner 关联。
方法摘要
ProtectionDomain[] | combine(ProtectionDomain[] currentDomains, ProtectionDomain[] assignedDomains) 使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。
Subject | getSubject() 获取与此 SubjectDomainCombiner 关联的 Subject。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SubjectDomainCombiner

public SubjectDomainCombiner(Subject subject)
将提供的 Subject 与此 SubjectDomainCombiner 关联。

参数：
subject - 要与此 SubjectDomainCombiner 关联的 Subject。
方法详细信息

getSubject

public Subject getSubject()
获取与此 SubjectDomainCombiner 关联的 Subject。

返回：
与此 SubjectDomainCombiner 关联的 Subject，如果没有与此 SubjectDomainCombiner 关联的 Subject，则返回 null。
抛出：
SecurityException - 如果调用者没有获取与此 SubjectDomainCombiner 关联的 Subject 的权限。

combine

public ProtectionDomain[] combine(ProtectionDomain[] currentDomains,
                                  ProtectionDomain[] assignedDomains)
使用与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新相关的 ProtectionDomains。

为 currentDomains 数组中的每个 ProtectionDomain 创建一个新的 ProtectionDomain 实例。每个新 ProtectionDomain 实例使用相应的 currentDomains 中的 ProtectionDomain 的 CodeSource、Permission 和 ClassLoader，以及与此 SubjectDomainCombiner 关联的 Subject 的 Principals 来创建。

将所有新实例化的 ProtectionDomains 组合到一个新数组中。把 assignedDomains 数组中的 ProtectionDomains 追加到此新数组中，同时返回结果。

注意，可能发生移除重复的 ProtectionDomains 这样的优化。另外，也允许缓存 ProtectionDomains。

指定者：
接口 DomainCombiner 中的 combine
参数：
currentDomains - 与当前执行线程关联的 ProtectionDomain，直到最近的特权 ProtectionDomain。ProtectionDomain 按执行的顺序列出，最近执行的 ProtectionDomain 位于数组的开头。如果当前的执行线程没有相关的 ProtectionDomains，则此参数可以为 null。

assignedDomains - 从父线程继承的 ProtectionDomains，如果发生对 AccessController.doPrivileged(..., context) 的调用，则此参数为特权 context 中的 ProtectionDomains。如果不存在从父线程继承的 ProtectionDomains 或不存在取自 context 的 ProtectionDomains，则此参数可以为 null。
返回：
由更新的 ProtectionDomains 组成的新数组，或 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.auth (Java 2 Platform SE 6)

 javax.security.auth
接口
Destroyable
Refreshable
类
AuthPermission
Policy
PrivateCredentialPermission
Subject
SubjectDomainCombiner
异常
DestroyFailedException
RefreshFailedException


javax.security.auth (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.auth

此包提供用于进行验证和授权的框架。

请参见：
描述

接口摘要
Destroyable | 诸如 credentials 之类的对象可以选择实现此接口以便提供销毁它的内容的功能。
Refreshable | 诸如证书之类的对象可以选择实现此接口，以提供对自己进行刷新的功能。

类摘要
AuthPermission | 此类用于验证权限。
Policy | 已过时。 从 JDK 1.4 版本开始，由 java.security.Policy 取代。
PrivateCredentialPermission | 此类用来保护对属于特定 Subject 的私有 Credential 的访问。
Subject | Subject 表示某一项（如一个人）的一组相关信息。
SubjectDomainCombiner | SubjectDomainCombiner 通过与此 SubjectDomainCombiner 关联的 Subject 中的 Principals 更新 ProtectionDomains。

异常摘要
DestroyFailedException | 当 destroy 操作失败时，抛出此异常。
RefreshFailedException | 当 refresh 操作失败时，抛出此异常。

软件包 javax.security.auth 的描述

此包提供用于进行验证和授权的框架。此框架允许以可插入的方式执行验证。不同的验证模块可以插入到应用程序中而不要求修改应用程序本身。授权组件允许基于代码基、代码签名者和代码执行者 (Subjects) 的访问控制规范。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.auth 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.security.auth.AuthPermission
      • javax.security.auth.PrivateCredentialPermission
    • javax.security.auth.Policy
    • javax.security.auth.Subject (implements java.io.Serializable)
    • javax.security.auth.SubjectDomainCombiner (implements java.security.DomainCombiner)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.auth.DestroyFailedException
        • javax.security.auth.RefreshFailedException

接口分层结构

  • javax.security.auth.Destroyable
  • javax.security.auth.Refreshable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.auth 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth
的使用

使用 javax.security.auth 的软件包
java.security | 为安全框架提供类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.security 使用的 javax.security.auth 中的类
Destroyable
诸如 credentials 之类的对象可以选择实现此接口以便提供销毁它的内容的功能。
DestroyFailedException
当 destroy 操作失败时，抛出此异常。
Subject
Subject 表示某一项（如一个人）的一组相关信息。

javax.management.remote 使用的 javax.security.auth 中的类
Subject
Subject 表示某一项（如一个人）的一组相关信息。

javax.management.remote.rmi 使用的 javax.security.auth 中的类
Subject
Subject 表示某一项（如一个人）的一组相关信息。

javax.security.auth 使用的 javax.security.auth 中的类
DestroyFailedException
当 destroy 操作失败时，抛出此异常。
Policy
已过时。 从 JDK 1.4 版本开始，由 java.security.Policy 取代。java.security.Policy 有一个方法：
        public PermissionCollection getPermissions
            (java.security.ProtectionDomain pd)
ProtectionDomain 有一个构造方法：
        public ProtectionDomain
            (CodeSource cs,
             PermissionCollection permissions,
             ClassLoader loader,
             Principal[] principals)
这两个 API 为调用者提供向 Policy 查询基于 Principal 的 Permission 条目的方法。
RefreshFailedException
当 refresh 操作失败时，抛出此异常。
Subject
Subject 表示某一项（如一个人）的一组相关信息。

javax.security.auth.kerberos 使用的 javax.security.auth 中的类
Destroyable
诸如 credentials 之类的对象可以选择实现此接口以便提供销毁它的内容的功能。
DestroyFailedException
当 destroy 操作失败时，抛出此异常。
Refreshable
诸如证书之类的对象可以选择实现此接口，以提供对自己进行刷新的功能。
RefreshFailedException
当 refresh 操作失败时，抛出此异常。

javax.security.auth.login 使用的 javax.security.auth 中的类
Subject
Subject 表示某一项（如一个人）的一组相关信息。

javax.security.auth.spi 使用的 javax.security.auth 中的类
Subject
Subject 表示某一项（如一个人）的一组相关信息。

javax.security.auth.x500 使用的 javax.security.auth 中的类
Destroyable
诸如 credentials 之类的对象可以选择实现此接口以便提供销毁它的内容的功能。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Callback (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
接口 Callback

所有已知实现类：
AuthorizeCallback, ChoiceCallback, ConfirmationCallback, LanguageCallback, NameCallback, PasswordCallback, RealmCallback, RealmChoiceCallback, TextInputCallback, TextOutputCallback
public interface Callback

将此接口的实现传递给 CallbackHandler，允许底层安全服务与调用的应用程序交互，从而获取特定的验证数据（如用户名和密码），或者显示特定的信息（如错误和警告消息）。

Callback 实现不获取或显示底层安全服务请求的信息。Callback 实现仅提供将此类请求传递给应用程序的方法,然后如果合适，应用程序将请求的信息返回给底层安全服务。

另请参见：
CallbackHandler, ChoiceCallback, ConfirmationCallback, LanguageCallback, NameCallback, PasswordCallback, TextInputCallback, TextOutputCallback

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CallbackHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
接口 CallbackHandler

public interface CallbackHandler

应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。

CallbackHandler 是以与应用程序相关的方式实现的。例如，通过实现带有图形用户界面（GUI）的应用程序，可以弹出窗口，以提示请求的信息或显示错误消息。实现也可以选择从替换源获取请求信息，而不询问终端用户。

底层安全服务通过向 CallbackHandler 传递单独的 Callback，以请求不同类型的信息。CallbackHandler 实现根据传递给它的 Callback 决定如何获取和显示信息。例如，如果底层服务需要用户名和密码对用户进行验证，则它使用 NameCallback 和 PasswordCallback。接着 CallbackHandler 就连续提示要求输入用户名和密码，或者在一个窗口中提示要求输入用户名和密码。

可以在 auth.login.defaultCallbackHandler 安全属性中指定默认的 CallbackHandler 类实现。可以在 Java 安全属性文件中设置安全属性，Java 安全属性文件位于名称为 <JAVA_HOME>/lib/security/java.security 的文件中。<JAVA_HOME> 是指 java.home 系统属性的值并且指定安装 JRE 的目录。

如果安全属性设置为 CallbackHandler 实现类的完全限定名，那么 LoginContext 将加载指定的 CallbackHandler 并把它传递给底层 LoginModules。如果没有提供处理程序，则 LoginContext 只加载默认的处理程序。

所有默认的处理程序实现必须提供一个公有的无参构造方法。

方法摘要
 void handle(Callback[] callbacks)
获取或显示在提供的 Callback 中请求的信息。

方法详细信息

handle

void handle(Callback[] callbacks)
            throws IOException,
                   UnsupportedCallbackException

获取或显示在提供的 Callback 中请求的信息。

为了获取或显示请求的信息，handle 方法实现检查传入的 Callback 对象的实例.下面提供的例子是对 handle 方法实现的示范。此例子代码只用来作为指导。为了简单起见，省去了很多细节（包括适当的错误处理）。

 public void handle(Callback[] callbacks)
 throws IOException, UnsupportedCallbackException {

         for (int i = 0; i < callbacks.length; i++) {
            if (callbacks[i] instanceof TextOutputCallback) {

                // display the message according to the specified type
                TextOutputCallback toc = (TextOutputCallback)callbacks[i];
                switch (toc.getMessageType()) {
                case TextOutputCallback.INFORMATION:
                    System.out.println(toc.getMessage());
                    break;
                case TextOutputCallback.ERROR:
                    System.out.println("ERROR: " + toc.getMessage());
                    break;
                case TextOutputCallback.WARNING:
                    System.out.println("WARNING: " + toc.getMessage());
                    break;
                default:
                    throw new IOException("Unsupported message type: " +
                                        toc.getMessageType());
                }

            } else if (callbacks[i] instanceof NameCallback) {

                // prompt the user for a username
                NameCallback nc = (NameCallback)callbacks[i];

                // ignore the provided defaultName
                System.err.print(nc.getPrompt());
                System.err.flush();
                nc.setName((new BufferedReader
                        (new InputStreamReader(System.in))).readLine());

            } else if (callbacks[i] instanceof PasswordCallback) {

                // prompt the user for sensitive information
                PasswordCallback pc = (PasswordCallback)callbacks[i];
                System.err.print(pc.getPrompt());
                System.err.flush();
                pc.setPassword(readPassword(System.in));

            } else {
                throw new UnsupportedCallbackException
                        (callbacks[i], "Unrecognized Callback");
            }
         }
 }

 // Reads user password from given input stream.
 private char[] readPassword(InputStream in) throws IOException {
    // insert code to read a user password from the input stream
 }

参数：
callbacks - 由底层安全服务提供的 Callback 对象的数组，包括要获取或显示的请求信息。
抛出：
IOException - 如果发生输入或输出错误。

UnsupportedCallbackException - 如果此方法的实现不支持在 callbacks 参数中指定的一个或多个 Callback。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChoiceCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 ChoiceCallback

java.lang.Object
    继承者  javax.security.auth.callback.ChoiceCallback
所有已实现的接口：
Serializable, Callback
直接已知子类：
RealmChoiceCallback
public class ChoiceCallback
extends Object
implements Callback, Serializable

底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。

另请参见：
CallbackHandler, 序列化表格

构造方法摘要
ChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multipleSelectionsAllowed)
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。
方法摘要
boolean | allowMultipleSelections() 获取布尔值，该布尔值确定是否允许从该 choices 列表进行多重选择。
String[] | getChoices() 获取选项列表。
int | getDefaultChoice() 获取 defaultChoice。
String | getPrompt() 获取提示。
int[] | getSelectedIndexes() 获取选中的选项。
void | setSelectedIndex(int selection) 设置选中的选项。
void | setSelectedIndexes(int[] selections) 设置选中的选项。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ChoiceCallback

public ChoiceCallback(String prompt,
                      String[] choices,
                      int defaultChoice,
                      boolean multipleSelectionsAllowed)
构造一个 ChoiceCallback，带有提示、选项列表、默认选项和指定选项列表是否允许进行多重选择的布尔值。

参数：
prompt - 用于描述选项列表的提示。

choices - 选项列表。

defaultChoice - 该选项用作显示选项列表时的默认选项。此值表示为 choices 数组中的索引。

multipleSelectionsAllowed - 指定是否可以从选项列表进行多重选择的布尔值。
抛出：
IllegalArgumentException - 如果 prompt 为 null，如果 prompt 的长度为 0，如果 choices 为 null，如果 choices 的长度为 0，如果 choices 中的任何元素为 null，如果 choices 中的任何元素的长度为 0，或者 defaultChoice 不在 choices 的数组边界内。
方法详细信息

getPrompt

public String getPrompt()
获取提示。

返回：
提示。

getChoices

public String[] getChoices()
获取选项列表。

返回：
选项列表。

getDefaultChoice

public int getDefaultChoice()
获取 defaultChoice。

返回：
defaultChoice，表示为 choices 列表中的索引。

allowMultipleSelections

public boolean allowMultipleSelections()
获取布尔值，该布尔值确定是否允许从该 choices 列表进行多重选择。

返回：
是否允许进行多重选择。

setSelectedIndex

public void setSelectedIndex(int selection)
设置选中的选项。

参数：
selection - 表示为 choices 列表中的索引的选择。
另请参见：
getSelectedIndexes()

setSelectedIndexes

public void setSelectedIndexes(int[] selections)
设置选中的选项。

参数：
selections - 表示为 choices 列表中的索引的选择。
抛出：
UnsupportedOperationException - 如果不允许进行多重选择（由 allowMultipleSelections 确定），则抛出该异常。
另请参见：
getSelectedIndexes()

getSelectedIndexes

public int[] getSelectedIndexes()
获取选中的选项。

返回：
选中的选项，表示为 choices 列表中的索引。
另请参见：
setSelectedIndexes(int[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfirmationCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 ConfirmationCallback

java.lang.Object
    继承者  javax.security.auth.callback.ConfirmationCallback
所有已实现的接口：
Serializable, Callback
public class ConfirmationCallback
extends Object
implements Callback, Serializable

底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。

另请参见：
CallbackHandler, 序列化表格

字段摘要
static int | CANCEL CANCEL 选项。
static int | ERROR ERROR 消息类型。
static int | INFORMATION INFORMATION 消息类型。
static int | NO NO 选项。
static int | OK OK 选项。
static int | OK_CANCEL_OPTION OK/CANCEL 确认选项。
static int | UNSPECIFIED_OPTION 未指定的选项类型。
static int | WARNING WARNING 消息类型。
static int | YES YES 选项。
static int | YES_NO_CANCEL_OPTION YES/NO/CANCEL 确认选项。
static int | YES_NO_OPTION YES/NO 确认选项。
构造方法摘要
ConfirmationCallback(int messageType, int optionType, int defaultOption)
构造一个带有消息类型、选项类型和默认选项的 ConfirmationCallback。
ConfirmationCallback(int messageType, String[] options, int defaultOption)
构造一个带有消息类型、选项列表和默认选项的 ConfirmationCallback。
ConfirmationCallback(String prompt, int messageType, int optionType, int defaultOption)
构造一个带有提示、消息类型、选项类型和默认选项的 ConfirmationCallback。
ConfirmationCallback(String prompt, int messageType, String[] options, int defaultOption)
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。
方法摘要
int | getDefaultOption() 获取默认选项。
int | getMessageType() 获取消息类型。
String[] | getOptions() 获取确认选项。
int | getOptionType() 获取选项类型。
String | getPrompt() 获取提示。
int | getSelectedIndex() 获取选中的确认选项。
void | setSelectedIndex(int selection) 设置选中的确认选项。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UNSPECIFIED_OPTION

public static final int UNSPECIFIED_OPTION
未指定的选项类型。

如果此 ConfirmationCallback 是使用 options 而不是 optionType 实例化的，则 getOptionType 方法返回此值。

另请参见：
常量字段值

YES_NO_OPTION

public static final int YES_NO_OPTION
YES/NO 确认选项。

如果 ConfirmationCallback 构造方法需要一个以 YES 或 NO 作答的确认信息，则底层安全服务将此值指定为 ConfirmationCallback 构造方法的 optionType。

另请参见：
常量字段值

YES_NO_CANCEL_OPTION

public static final int YES_NO_CANCEL_OPTION
YES/NO/CANCEL 确认选项。

如果 ConfirmationCallback 构造方法需要一个以 YES、NO 或 CANCEL 作答的确认信息，则底层安全服务将此值指定为 ConfirmationCallback 构造方法的 optionType。

另请参见：
常量字段值

OK_CANCEL_OPTION

public static final int OK_CANCEL_OPTION
OK/CANCEL 确认选项。

如果 ConfirmationCallback 构造方法需要一个以 OK 或 CANCEL 作答的确认信息，则底层安全服务将此值指定为 ConfirmationCallback 构造方法的 optionType。

另请参见：
常量字段值

YES

public static final int YES
YES 选项。

如果指定了此 ConfirmationCallback 的 optionType，则可以将此选项指定为 defaultOption 或作为选择的索引返回。

另请参见：
常量字段值

NO

public static final int NO
NO 选项。

如果指定了此 ConfirmationCallback 的 optionType，则可以将此选项指定为 defaultOption 或作为选择的索引返回。

另请参见：
常量字段值

CANCEL

public static final int CANCEL
CANCEL 选项。

如果指定了此 ConfirmationCallback 的 optionType，则可以将此选项指定为 defaultOption 或作为选择的索引返回。

另请参见：
常量字段值

OK

public static final int OK
OK 选项。

如果指定了此 ConfirmationCallback 的 optionType，则可以将此选项指定为 defaultOption 或作为选择的索引返回。

另请参见：
常量字段值

INFORMATION

public static final int INFORMATION
INFORMATION 消息类型。

另请参见：
常量字段值

WARNING

public static final int WARNING
WARNING 消息类型。

另请参见：
常量字段值

ERROR

public static final int ERROR
ERROR 消息类型。

另请参见：
常量字段值
构造方法详细信息

ConfirmationCallback

public ConfirmationCallback(int messageType,
                            int optionType,
                            int defaultOption)
构造一个带有消息类型、选项类型和默认选项的 ConfirmationCallback。

如果底层安全服务需要 YES/NO、 YES/NO/CANCEL 或 OK/CANCEL 确认信息，则它们使用此构造方法。

参数：
messageType - 消息类型（INFORMATION、WARNING 或 ERROR）。

optionType - 选项类型（YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION）。

defaultOption - 从提供的 optionType（YES、NO、CANCEL 或 OK）得出的默认选项。
抛出：
IllegalArgumentException - 如果 messageType 不是 INFORMATION、WARNING 或 ERROR，如果 optionType 不是 YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION，或者 defaultOption 不与 optionType 中的某个选项对应。

ConfirmationCallback

public ConfirmationCallback(int messageType,
                            String[] options,
                            int defaultOption)
构造一个带有消息类型、选项列表和默认选项的 ConfirmationCallback。

如果底层安全服务需要的确认信息不同于可供使用的、已提供的预置确认信息（例如，CONTINUE/ABORT 或 STOP/GO），则它们使用此构造方法。确认选项在 options 数组中列出，由 CallbackHandler 实现通过与预置选项一致的方式显示。

参数：
messageType - 消息类型（INFORMATION、WARNING 或 ERROR）。

options - 确认选项列表。

defaultOption - 默认选项，表示为 options 数组中的索引。
抛出：
IllegalArgumentException - 如果 messageType 不是 INFORMATION、WARNING 或 ERROR，如果 options 为 null，如果 options 的长度为 0，如果 options 中的任何一个元素为 null，如果 options 中的任何一个元素的长度为 0，或者 defaultOption 不在 options 的数组边界内。

ConfirmationCallback

public ConfirmationCallback(String prompt,
                            int messageType,
                            int optionType,
                            int defaultOption)
构造一个带有提示、消息类型、选项类型和默认选项的 ConfirmationCallback。

如果底层安全服务需要 YES/NO、 YES/NO/CANCEL 或 OK/CANCEL 确认信息，则它们使用此构造方法。

参数：
prompt - 用于描述选项列表的提示。

messageType - 消息类型（INFORMATION、WARNING 或 ERROR）。

optionType - 选项类型（YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION）。

defaultOption - 从提供的 optionType（YES、NO、CANCEL 或 OK）得出的默认选项。
抛出：
IllegalArgumentException - 如果 prompt 为 null，如果 prompt 的长度为 0，如果 messageType 不是 INFORMATION、WARNING 或 ERROR，如果 optionType 不是 YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION，或者 defaultOption 不对应于 optionType 中的某个选项。

ConfirmationCallback

public ConfirmationCallback(String prompt,
                            int messageType,
                            String[] options,
                            int defaultOption)
构造一个带有提示、消息类型、选项列表和默认选项的 ConfirmationCallback。

如果底层安全服务需要的确认信息不同于可供使用的、已提供的预置确认信息（例如，CONTINUE/ABORT 或 STOP/GO），则它们使用此构造方法。确认选项在 options 数组中列出，由 CallbackHandler 实现通过与预置选项一致的方式显示。

参数：
prompt - 用于描述选项列表的提示。

messageType - 消息类型（INFORMATION、WARNING 或 ERROR）。

options - 确认选项列表。

defaultOption - 默认选项，表示为 options 数组中的索引。
抛出：
IllegalArgumentException - 如果 prompt 为 null，如果 prompt 的长度为 0，如果 messageType 不是 INFORMATION、WARNING 或 ERROR，如果 options 为 null，如果 options 的长度为 0，如果 options 中的任何一个元素为 null，如果 options 中的任何一个元素长度为 0，或者 defaultOption 不是位于 options 的数组边界内。
方法详细信息

getPrompt

public String getPrompt()
获取提示。

返回：
提示，如果此 ConfirmationCallback 实例化为不带 prompt，则返回 null。

getMessageType

public int getMessageType()
获取消息类型。

返回：
消息类型（INFORMATION、WARNING 或 ERROR）。

getOptionType

public int getOptionType()
获取选项类型。

如果此方法返回 UNSPECIFIED_OPTION，那么此 ConfirmationCallback 是使用 options 而不是 optionType 实例化的。在这种情况下，调用 getOptions 方法，以确定显示何种确认选项。

返回：
选项类型（YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION），如果此 ConfirmationCallback 是使用 options 而不是 optionType 实例化的，则返回 UNSPECIFIED_OPTION。

getOptions

public String[] getOptions()
获取确认选项。

返回：
确认选项列表，如果此 ConfirmationCallback 是使用 optionType 而不是 options 实例化的，则返回 null。

getDefaultOption

public int getDefaultOption()
获取默认选项。

返回：
默认选项，如果为此 ConfirmationCallback 的构造方法指定了 optionType，则表示为 YES、NO、OK 或 CANCEL。否则，此方法返回默认选项，作为为此 ConfirmationCallback 的构造方法指定的 options 数组中的索引。

setSelectedIndex

public void setSelectedIndex(int selection)
设置选中的确认选项。

参数：
selection - 如果为此 ConfirmationCallback 的构造方法指定了一个 optionType，则该 selection 表示为 YES、NO、OK 或 CANCEL。否则，该 selection 表示为为此 ConfirmationCallback 的构造方法指定的 options 数组中的索引。
另请参见：
getSelectedIndex()

getSelectedIndex

public int getSelectedIndex()
获取选中的确认选项。

返回：
如果为此 ConfirmationCallback 的构造方法指定了一个 optionType ，则返回选中的确认选项，表示为 YES、NO、OK 或 CANCEL。否则，此方法返回选中的确认选项，作为为此 ConfirmationCallback 的构造方法指定的 options 数组中的索引。
另请参见：
setSelectedIndex(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LanguageCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 LanguageCallback

java.lang.Object
    继承者  javax.security.auth.callback.LanguageCallback
所有已实现的接口：
Serializable, Callback
public class LanguageCallback
extends Object
implements Callback, Serializable

底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。

另请参见：
CallbackHandler, 序列化表格

构造方法摘要
LanguageCallback()
构造一个 LanguageCallback。
方法摘要
Locale | getLocale() 获取检索到的 Locale。
void | setLocale(Locale locale) 设置获取到的 Locale。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LanguageCallback

public LanguageCallback()
构造一个 LanguageCallback。

方法详细信息

setLocale

public void setLocale(Locale locale)
设置获取到的 Locale。

参数：
locale - 获取到的 Locale。
另请参见：
getLocale()

getLocale

public Locale getLocale()
获取检索到的 Locale。

返回：
获取到的 Locale，如果不能获取 Locale ，则返回 null。
另请参见：
setLocale(java.util.Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


NameCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 NameCallback

java.lang.Object
    继承者  javax.security.auth.callback.NameCallback
所有已实现的接口：
Serializable, Callback
public class NameCallback
extends Object
implements Callback, Serializable

底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。

另请参见：
CallbackHandler, 序列化表格

构造方法摘要
NameCallback(String prompt)
构造一个带提示的 NameCallback。
NameCallback(String prompt, String defaultName)
构造一个带提示和默认名称的 NameCallback。
方法摘要
String | getDefaultName() 获取默认名称。
String | getName() 获取检索到的名称。
String | getPrompt() 获取提示。
void | setName(String name) 设置检索到的名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

NameCallback

public NameCallback(String prompt)
构造一个带提示的 NameCallback。

参数：
prompt - 用来请求名称的提示。
抛出：
IllegalArgumentException - 如果 prompt 为 null 或者 prompt 的长度为 0。

NameCallback

public NameCallback(String prompt,
                    String defaultName)
构造一个带提示和默认名称的 NameCallback。

参数：
prompt - 用来请求信息的提示。

defaultName - 用作与提示一起显示的默认名称。
抛出：
IllegalArgumentException - 如果 prompt 为 null，如果 prompt 的长度为 0，如果 defaultName 为 null 或者 defaultName 的长度为 0。
方法详细信息

getPrompt

public String getPrompt()
获取提示。

返回：
提示。

getDefaultName

public String getDefaultName()
获取默认名称。

返回：
默认的名称，如果此 NameCallback 没有使用 defaultName 实例化，则返回 null。

setName

public void setName(String name)
设置检索到的名称。

参数：
name - 检索到的名称（它可以为 null）。
另请参见：
getName()

getName

public String getName()
获取检索到的名称。

返回：
获取到的名称（它可以为 null）
另请参见：
setName(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PasswordCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 PasswordCallback

java.lang.Object
    继承者  javax.security.auth.callback.PasswordCallback
所有已实现的接口：
Serializable, Callback
public class PasswordCallback
extends Object
implements Callback, Serializable

底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。

另请参见：
CallbackHandler, 序列化表格

构造方法摘要
PasswordCallback(String prompt, boolean echoOn)
构造带提示和布尔值的 PasswordCallback，该布尔值指定键入密码时是否应该显示该密码。
方法摘要
void | clearPassword() 清除获取到的密码。
char[] | getPassword() 获取检索到的密码。
String | getPrompt() 获取提示。
boolean | isEchoOn() 返回密码是否应该在键入时显示。
void | setPassword(char[] password) 设置获取到的密码。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PasswordCallback

public PasswordCallback(String prompt,
                        boolean echoOn)
构造带提示和布尔值的 PasswordCallback，该布尔值指定键入密码时是否应该显示该密码。

参数：
prompt - 用来请求密码的提示。

echoOn - 如果密码应该在键入时显示，则该参数为 true。
抛出：
IllegalArgumentException - 如果 prompt 为 null 或者 prompt 的长度为 0。
方法详细信息

getPrompt

public String getPrompt()
获取提示。

返回：
提示。

isEchoOn

public boolean isEchoOn()
返回密码是否应该在键入时显示。

返回：
密码是否应该在键入时显示。

setPassword

public void setPassword(char[] password)
设置获取到的密码。

此方法在存储 password 前对其进行了复制。

参数：
password - 获取到的密码，它可以为 null。
另请参见：
getPassword()

getPassword

public char[] getPassword()
获取检索到的密码。

此方法返回获取到的密码的一份副本。

返回：
获取到的密码，它可以为 null。
另请参见：
setPassword(char[])

clearPassword

public void clearPassword()
清除获取到的密码。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextInputCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 TextInputCallback

java.lang.Object
    继承者  javax.security.auth.callback.TextInputCallback
所有已实现的接口：
Serializable, Callback
直接已知子类：
RealmCallback
public class TextInputCallback
extends Object
implements Callback, Serializable

底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。

另请参见：
CallbackHandler, 序列化表格

构造方法摘要
TextInputCallback(String prompt)
构造一个带提示的 TextInputCallback。
TextInputCallback(String prompt, String defaultText)
构造一个带提示和默认输入值的 TextInputCallback。
方法摘要
String | getDefaultText() 获取默认文本。
String | getPrompt() 获取提示。
String | getText() 获取检索到的文本。
void | setText(String text) 设置获取到的文本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TextInputCallback

public TextInputCallback(String prompt)
构造一个带提示的 TextInputCallback。

参数：
prompt - 用来请求信息的提示。
抛出：
IllegalArgumentException - 如果 prompt 为 null 或者 prompt 的长度为 0。

TextInputCallback

public TextInputCallback(String prompt,
                         String defaultText)
构造一个带提示和默认输入值的 TextInputCallback。

参数：
prompt - 用来请求信息的提示。

defaultText - 用作与提示一起显示的默认文本。
抛出：
IllegalArgumentException - 如果 prompt 为 null，如果 prompt 的长度为 0，如果 defaultText 为 null 或者 defaultText 的长度为 0。
方法详细信息

getPrompt

public String getPrompt()
获取提示。

返回：
提示。

getDefaultText

public String getDefaultText()
获取默认文本。

返回：
默认的文本，如果此 TextInputCallback 没有使用 defaultText 实例化，则返回 null。

setText

public void setText(String text)
设置获取到的文本。

参数：
text - 获取到的文本，它可以为 null。
另请参见：
getText()

getText

public String getText()
获取检索到的文本。

返回：
获取到的文本，它可以为 null。
另请参见：
setText(java.lang.String)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TextOutputCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 TextOutputCallback

java.lang.Object
    继承者  javax.security.auth.callback.TextOutputCallback
所有已实现的接口：
Serializable, Callback
public class TextOutputCallback
extends Object
implements Callback, Serializable

底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。

另请参见：
CallbackHandler, 序列化表格

字段摘要
static int | ERROR 错误消息。
static int | INFORMATION 信息消息。
static int | WARNING 警告消息。
构造方法摘要
TextOutputCallback(int messageType, String message)
构造一个带消息类型和将要显示的消息的 TextOutputCallback。
方法摘要
String | getMessage() 获取将要显示的消息。
int | getMessageType() 获取消息类型。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

INFORMATION

public static final int INFORMATION
信息消息。

另请参见：
常量字段值

WARNING

public static final int WARNING
警告消息。

另请参见：
常量字段值

ERROR

public static final int ERROR
错误消息。

另请参见：
常量字段值
构造方法详细信息

TextOutputCallback

public TextOutputCallback(int messageType,
                          String message)
构造一个带消息类型和将要显示的消息的 TextOutputCallback。

参数：
messageType - 消息类型（INFORMATION、WARNING 或 ERROR）。

message - 将要显示的消息。

抛出：
IllegalArgumentException - 如果 messageType 不是 INFORMATION、WARNING 或 ERROR，如果 message 为 null，或者 message 的长度为 0。
方法详细信息

getMessageType

public int getMessageType()
获取消息类型。

返回：
消息类型（INFORMATION、WARNING 或 ERROR）。

getMessage

public String getMessage()
获取将要显示的消息。

返回：
将要显示的消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedCallbackException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.callback
类 UnsupportedCallbackException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.auth.callback.UnsupportedCallbackException
所有已实现的接口：
Serializable
public class UnsupportedCallbackException
extends Exception

在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

另请参见：
序列化表格

构造方法摘要
UnsupportedCallbackException(Callback callback)
构造不带详细消息的 UnsupportedCallbackException。
UnsupportedCallbackException(Callback callback, String msg)
构造带指定详细消息的 UnsupportedCallbackException。
方法摘要
 Callback getCallback()
获取未识别的 Callback。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedCallbackException

public UnsupportedCallbackException(Callback callback)
构造不带详细消息的 UnsupportedCallbackException。

参数：
callback - 未识别的 Callback。

UnsupportedCallbackException

public UnsupportedCallbackException(Callback callback,
                                    String msg)
构造带指定详细消息的 UnsupportedCallbackException。详细消息是描述此特定异常的 String。

参数：
callback - 未识别的 Callback。

msg - 详细消息。
方法详细信息

getCallback

public Callback getCallback()
获取未识别的 Callback。

返回：
未识别的 Callback。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.auth.callback (Java 2 Platform SE 6)

 javax.security.auth.callback
接口
Callback
CallbackHandler
类
ChoiceCallback
ConfirmationCallback
LanguageCallback
NameCallback
PasswordCallback
TextInputCallback
TextOutputCallback
异常
UnsupportedCallbackException


javax.security.auth.callback (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.auth.callback

此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

请参见：
描述

接口摘要
Callback | 将此接口的实现传递给 CallbackHandler，允许底层安全服务与调用的应用程序交互，从而获取特定的验证数据（如用户名和密码），或者显示特定的信息（如错误和警告消息）。
CallbackHandler | 应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。

类摘要
ChoiceCallback | 底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
ConfirmationCallback | 底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。
LanguageCallback | 底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。
NameCallback | 底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。
PasswordCallback | 底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。
TextInputCallback | 底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。
TextOutputCallback | 底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。

异常摘要
UnsupportedCallbackException 在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

软件包 javax.security.auth.callback 的描述

此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.auth.callback 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.callback 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.security.auth.callback.ChoiceCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.ConfirmationCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.LanguageCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.NameCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.PasswordCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.TextInputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.TextOutputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.auth.callback.UnsupportedCallbackException

接口分层结构

  • javax.security.auth.callback.Callback
  • javax.security.auth.callback.CallbackHandler
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.auth.callback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.callback
的使用

使用 javax.security.auth.callback 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.sasl | 包含用于支持 SASL 的类和接口。

java.security 使用的 javax.security.auth.callback 中的类
CallbackHandler
应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。

javax.security.auth.callback 使用的 javax.security.auth.callback 中的类
Callback
将此接口的实现传递给 CallbackHandler，允许底层安全服务与调用的应用程序交互，从而获取特定的验证数据（如用户名和密码），或者显示特定的信息（如错误和警告消息）。
UnsupportedCallbackException
在 CallbackHandler 不能识别特定的 Callback 时发出的信号。

javax.security.auth.login 使用的 javax.security.auth.callback 中的类
CallbackHandler
应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。

javax.security.auth.spi 使用的 javax.security.auth.callback 中的类
CallbackHandler
应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。

javax.security.sasl 使用的 javax.security.auth.callback 中的类
Callback
将此接口的实现传递给 CallbackHandler，允许底层安全服务与调用的应用程序交互，从而获取特定的验证数据（如用户名和密码），或者显示特定的信息（如错误和警告消息）。
CallbackHandler
应用程序实现 CallbackHandler，并将其传递到底层安全服务，以便它们能与应用程序交互，从而获得特定的验证数据（如用户名和密码），或显示特定的信息（如错误和警告消息）。
ChoiceCallback
底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
TextInputCallback
底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.auth.callback.Callback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.callback.Callback
的使用

使用 Callback 的软件包
javax.security.auth.callback | 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。
javax.security.sasl | 包含用于支持 SASL 的类和接口。

javax.security.auth.callback 中 Callback 的使用

实现 Callback 的 javax.security.auth.callback 中的类
class | ChoiceCallback 底层安全服务实例化一个 ChoiceCallback ，并将它传递给 CallbackHandler 的 handle 方法，以显示选项列表并获取选中的选项。
class | ConfirmationCallback 底层安全服务实例化 ConfirmationCallback，并将其传递到 CallbackHandler 的 handle 方法，以请求 YES/NO、OK/CANCEL、YES/NO/CANCEL 或其他类似的确认信息。
class | LanguageCallback 底层安全服务实例化一个 LanguageCallback, 并将其传递给 CallbackHandler 的 handle 方法，以获取用于本地化文本的 Locale。
class | NameCallback 底层安全服务实例化一个 NameCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取名称信息。
class | PasswordCallback 底层安全服务实例化一个 PasswordCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取密码信息。
class | TextInputCallback 底层安全服务实例化一个 TextInputCallback 并将其传递给 CallbackHandler 的 handle 方法，以获取普通的文本信息。
class | TextOutputCallback 底层安全服务实例化一个 TextOutputCallback 并将其传递给 CallbackHandler 的 handle 方法，以显示信息消息、警告消息和错误消息。

返回 Callback 的 javax.security.auth.callback 中的方法
 Callback UnsupportedCallbackException.getCallback()
获取未识别的 Callback。

参数类型为 Callback 的 javax.security.auth.callback 中的方法
 void CallbackHandler.handle(Callback[] callbacks)
获取或显示在提供的 Callback 中请求的信息。

参数类型为 Callback 的 javax.security.auth.callback 中的构造方法
UnsupportedCallbackException(Callback callback)
构造不带详细消息的 UnsupportedCallbackException。
UnsupportedCallbackException(Callback callback, String msg)
构造带指定详细消息的 UnsupportedCallbackException。

javax.security.sasl 中 Callback 的使用

实现 Callback 的 javax.security.sasl 中的类
class | AuthorizeCallback 此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。
class | RealmCallback SaslClient 和 SaslServer 使用此回调来获取领域信息。
class | RealmChoiceCallback SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.auth.callback.CallbackHandler 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.callback.CallbackHandler
的使用

使用 CallbackHandler 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。
javax.security.sasl | 包含用于支持 SASL 的类和接口。

java.security 中 CallbackHandler 的使用

返回 CallbackHandler 的 java.security 中的方法
 CallbackHandler KeyStore.CallbackHandlerProtection.getCallbackHandler()
返回 CallbackHandler。

参数类型为 CallbackHandler 的 java.security 中的方法
abstract void | AuthProvider.login(Subject subject, CallbackHandler handler) 登录到此 provider 中。
abstract void | AuthProvider.setCallbackHandler(CallbackHandler handler) 设置 CallbackHandler。

参数类型为 CallbackHandler 的 java.security 中的构造方法
KeyStore.CallbackHandlerProtection(CallbackHandler handler)
根据 CallbackHandler 构造新的 CallbackHandlerProtection。

javax.security.auth.login 中 CallbackHandler 的使用

参数类型为 CallbackHandler 的 javax.security.auth.login 中的构造方法
LoginContext(String name, CallbackHandler callbackHandler)
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

javax.security.auth.spi 中 CallbackHandler 的使用

参数类型为 CallbackHandler 的 javax.security.auth.spi 中的方法
 void LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

javax.security.sasl 中 CallbackHandler 的使用

参数类型为 CallbackHandler 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.ChoiceCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.ChoiceCallback
的使用

使用 ChoiceCallback 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 ChoiceCallback 的使用

javax.security.sasl 中 ChoiceCallback 的子类
 class RealmChoiceCallback
SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.ConfirmationCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.ConfirmationCallback
的使用

没有 javax.security.auth.callback.ConfirmationCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.LanguageCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.LanguageCallback
的使用

没有 javax.security.auth.callback.LanguageCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.NameCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.NameCallback
的使用

没有 javax.security.auth.callback.NameCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.PasswordCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.PasswordCallback
的使用

没有 javax.security.auth.callback.PasswordCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.TextInputCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.TextInputCallback
的使用

使用 TextInputCallback 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 TextInputCallback 的使用

javax.security.sasl 中 TextInputCallback 的子类
 class RealmCallback
SaslClient 和 SaslServer 使用此回调来获取领域信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.TextOutputCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.TextOutputCallback
的使用

没有 javax.security.auth.callback.TextOutputCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.callback.UnsupportedCallbackException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.callback.UnsupportedCallbackException
的使用

使用 UnsupportedCallbackException 的软件包
javax.security.auth.callback 此包提供与应用程序进行交互所必需的类，以便检索信息（例如，包括用户名和密码的验证数据）或显示信息（例如，错误和警告消息）。

javax.security.auth.callback 中 UnsupportedCallbackException 的使用

抛出 UnsupportedCallbackException 的 javax.security.auth.callback 中的方法
 void CallbackHandler.handle(Callback[] callbacks)
获取或显示在提供的 Callback 中请求的信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


DelegationPermission (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.kerberos
类 DelegationPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.security.auth.kerberos.DelegationPermission
所有已实现的接口：
Serializable, Guard
public final class DelegationPermission
extends BasicPermission
implements Serializable

此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。

此 Permission 的目标名称指定一对 kerberos 服务主体。第一个服务主体是受信任而使用 TGT 的从属服务主体。第二个服务主体指定目标服务，从属服务主体代表启动的 KerberosPrincipal 与其进行交互。指定后一种服务主体是为了限制可代理票据的使用。

例如，要指定可转发 TGT 的“主机”服务使用，则目标权限的指定如下：

  DelegationPermission("\"host/foo.example.com@EXAMPLE.COM\" \"krbtgt/EXAMPLE.COM@EXAMPLE.COM\"");

要为“后备”服务提供可代理的 nfs 服务票据，则目标权限可以指定为：

  DelegationPermission("\"backup/bar.example.com@EXAMPLE.COM\" \"nfs/home.EXAMPLE.COM@EXAMPLE.COM\"");

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
DelegationPermission(String principals)
创建带有指定从属主体和目标主体的新 DelegationPermission。
DelegationPermission(String principals, String actions)
创建带有指定从属主体和目标主体的新 DelegationPermission。
方法摘要
boolean | equals(Object obj) 检查两个 DelegationPermission 对象是否相等。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此 Kerberos 代理权限对象是否“隐含”指定的权限。
PermissionCollection | newPermissionCollection() 返回用于存储 DelegationPermission 对象的 PermissionCollection 对象。
从类 java.security.BasicPermission 继承的方法
getActions
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

DelegationPermission

public DelegationPermission(String principals)
创建带有指定从属主体和目标主体的新 DelegationPermission。

参数：
principals - 从属主体和目标主体的名称
抛出：
NullPointerException - 如果 principals 为 null。
IllegalArgumentException - 如果 principals 为空。

DelegationPermission

public DelegationPermission(String principals,
                            String actions)
创建带有指定从属主体和目标主体的新 DelegationPermission。

参数：
principals - 从属主体和目标主体的名称

actions - 应该为 null。
抛出：
NullPointerException - 如果 principals 为 null。
IllegalArgumentException - 如果 principals 为空。
方法详细信息

implies

public boolean implies(Permission p)
检查此 Kerberos 代理权限对象是否“隐含”指定的权限。

如果上述条件都不为 true，则 implies 返回 false。

覆盖：
类 BasicPermission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果此对象隐含指定的权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 DelegationPermission 对象是否相等。

覆盖：
类 BasicPermission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 是一个 DelegationPermission，并且与此 DelegationPermission 对象具有相同的从属和服务主体，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。

覆盖：
类 BasicPermission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

newPermissionCollection

public PermissionCollection newPermissionCollection()
返回用于存储 DelegationPermission 对象的 PermissionCollection 对象。
DelegationPermission 对象必须以允许将它们按任意顺序插入集合的方式来存储，但同时也允许以有效（并一致）的方式实现 PermissionCollection 的 implies 方法。

覆盖：
类 BasicPermission 中的 newPermissionCollection
返回：
适合用来存储 DelegationPermissions 的新 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


KerberosKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.kerberos
类 KerberosKey

java.lang.Object
    继承者  javax.security.auth.kerberos.KerberosKey
所有已实现的接口：
Serializable, Key, SecretKey, Destroyable
public class KerberosKey
extends Object
implements SecretKey, Destroyable

此类为 Kerberos 主体封装一个长期秘密密钥。

获取主体的密码和从主体生成秘密密钥的所有 Kerberos JAAS 登录模块都应该使用此类。在任何可以使用的地方，登录模块甚至可以直接从 Kerberos "keytab" 读取此秘密密钥。有时，例如在没有用户到用户 (user-to-user) 验证的情况下对服务器进行验证时，在验证过程的提交阶段，登录模块将在 Subject 的私有证书集中存储此类的实例。

如果应用程序需要从 Subject 访问 KerberosKey 实例，可能必须授予应用程序 PrivateCredentialPermission 权限。当应用程序依靠默认的 JGSS Kerberos 机制去访问 KerberosKey 时，不需要此权限。但在这种情况下，应用程序将需要适当的 ServicePermission 权限。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
KerberosKey(KerberosPrincipal principal, byte[] keyBytes, int keyType, int versionNum)
当已知密钥类型和密钥版本号时，根据给出的字节构造 KerberosKey。
KerberosKey(KerberosPrincipal principal, char[] password, String algorithm)
根据主体的密码构造 KerberosKey。
方法摘要
void | destroy() 销毁此密钥。
boolean | equals(Object other) 比较指定 Object 与此 KerberosKey 的相等性。
String | getAlgorithm() 返回此密钥的标准算法名称。
byte[] | getEncoded() 返回秘密密钥的密钥材料。
String | getFormat() 返回此秘密密钥的编码格式的名称。
int | getKeyType() 返回此长期密钥的密钥类型。
KerberosPrincipal | getPrincipal() 返回此密钥所属的主体。
int | getVersionNumber() 返回密钥版本号。
int | hashCode() 返回此 KerberosKey 的哈希码。
boolean | isDestroyed() 确定此密钥是否已经销毁。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

KerberosKey

public KerberosKey(KerberosPrincipal principal,
                   byte[] keyBytes,
                   int keyType,
                   int versionNum)
当已知密钥类型和密钥版本号时，根据给出的字节构造 KerberosKey。当从 Kerberos "keytab" 读取秘密密钥信息时，可以使用此 KerberosKey。

参数：
principal - 此秘密密钥所属的主体
keyBytes - 秘密密钥的原始字节
keyType - 秘密密钥的密钥类型，由 Kerberos 协议规范定义。
versionNum - 此秘密密钥的版本号。

KerberosKey

public KerberosKey(KerberosPrincipal principal,
                   char[] password,
                   String algorithm)
根据主体的密码构造 KerberosKey。

参数：
principal - 此密码所属的主体
password - 应该用于计算密钥的密码
algorithm - 此密钥将使用的算法的名称。在假定默认算法为 "DES" 的情况下此参数可以为 null。
抛出：
IllegalArgumentException - 如果不支持传递的算法名称。
方法详细信息

getPrincipal

public final KerberosPrincipal getPrincipal()
返回此密钥所属的主体。

返回：
此密钥所属的主体。

getVersionNumber

public final int getVersionNumber()
返回密钥版本号。

返回：
密钥版本号。

getKeyType

public final int getKeyType()
返回此长期密钥的密钥类型。

返回：
密钥类型。

getAlgorithm

public final String getAlgorithm()
返回此密钥的标准算法名称。例如，"DES" 指示此密钥是一个 DES 密钥。有关标准算法名称的信息，请参阅 Java Cryptography Architecture API Specification & Reference 中的附录 A。 与此密钥有关联的算法的名称。

指定者：
接口 Key 中的 getAlgorithm
返回：
与此密钥关联的算法名称。

getFormat

public final String getFormat()
返回此秘密密钥的编码格式的名称。

指定者：
接口 Key 中的 getFormat
返回：
字符串 "RAW"。

getEncoded

public final byte[] getEncoded()
返回秘密密钥的密钥材料。

指定者：
接口 Key 中的 getEncoded
返回：
密钥材料。

destroy

public void destroy()
             throws DestroyFailedException
销毁此密钥。销毁密钥后对此密钥其他任何方法的调用将导致抛出 IllegalStateException。

指定者：
接口 Destroyable 中的 destroy
抛出：
DestroyFailedException - 如果销毁密钥时出现一些错误。

isDestroyed

public boolean isDestroyed()
确定此密钥是否已经销毁。

指定者：
接口 Destroyable 中的 isDestroyed
返回：
如果此 Object 已经销毁，则返回 true；否则，返回 false。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

hashCode

public int hashCode()
返回此 KerberosKey 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
KerberosKey 的 hashCode()
从以下版本开始：
1.6
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object other)
比较指定 Object 与此 KerberosKey 的相等性。如果给定对象也是 KerberosKey 并且两个 KerberosKey 实例相等，则返回 true。

覆盖：
类 Object 中的 equals
参数：
other - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KerberosPrincipal (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.kerberos
类 KerberosPrincipal

java.lang.Object
    继承者  javax.security.auth.kerberos.KerberosPrincipal
所有已实现的接口：
Serializable, Principal
public final class KerberosPrincipal
extends Object
implements Principal, Serializable

此类封装 Kerberos 主体。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
static int | KRB_NT_PRINCIPAL 用户主体名称类型。
static int | KRB_NT_SRV_HST 主机名作为实例 (telnet, rcommands) 的服务的名称类型。
static int | KRB_NT_SRV_INST 服务和其他唯一实例 (krbtgt) 名称类型。
static int | KRB_NT_SRV_XHST 将主机名作为剩余组件的服务的名称类型。
static int | KRB_NT_UID 唯一 ID 名称类型。
static int | KRB_NT_UNKNOWN 未知的名称类型。
构造方法摘要
KerberosPrincipal(String name)
根据提供的字符串输入构造 KerberosPrincipal。
KerberosPrincipal(String name, int nameType)
根据提供的字符串和名称类型输入构造 KerberosPrincipal。
方法摘要
boolean | equals(Object other) 比较指定的对象与此 Principal 是否相等。
String | getName() 返回的字符串对应于 Kerberos Principal 名称的 single-string 表示形式，RFC 1964 的 2.1 小节中指定了这种表示形式。
int | getNameType() 返回 KerberosPrincipal 的名称类型。
String | getRealm() 返回此 Kerberos 主体的域组件。
int | hashCode() 返回此主体的哈希码。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

KRB_NT_UNKNOWN

public static final int KRB_NT_UNKNOWN
未知的名称类型。

另请参见：
常量字段值

KRB_NT_PRINCIPAL

public static final int KRB_NT_PRINCIPAL
用户主体名称类型。

另请参见：
常量字段值

KRB_NT_SRV_INST

public static final int KRB_NT_SRV_INST
服务和其他唯一实例 (krbtgt) 名称类型。

另请参见：
常量字段值

KRB_NT_SRV_HST

public static final int KRB_NT_SRV_HST
主机名作为实例 (telnet, rcommands) 的服务的名称类型。

另请参见：
常量字段值

KRB_NT_SRV_XHST

public static final int KRB_NT_SRV_XHST
将主机名作为剩余组件的服务的名称类型。

另请参见：
常量字段值

KRB_NT_UID

public static final int KRB_NT_UID
唯一 ID 名称类型。

另请参见：
常量字段值
构造方法详细信息

KerberosPrincipal

public KerberosPrincipal(String name)
根据提供的字符串输入构造 KerberosPrincipal。此主体的名称类型默认为 KRB_NT_PRINCIPAL 假定此字符串包含一个名称，该名称的格式在 RFC 1964 的 2.1.1. 小节 (Kerberos Principal Name Form) 中指定（例如 duke@FOO.COM，其中的 duke 表示主体，FOO.COM 表示域）。

如果输入的名称中不包含域，则使用默认的域。默认域可以在 Kerberos 配置文件中指定或通过 java.security.krb5.realm 系统属性指定。有关的更多信息请参见 Kerberos Requirements

参数：
name - 主体名称
抛出：
IllegalArgumentException - 如果名称不是正确格式的，或者如果名称为 null，抑或如果名称不包含将使用的域，并且没有在 Kerberos 配置文件或 java.security.krb5.realm 系统属性中指定默认域。

KerberosPrincipal

public KerberosPrincipal(String name,
                         int nameType)
根据提供的字符串和名称类型输入构造 KerberosPrincipal。假定此字符串包含一个名称，RFC 1964 的 2.1 小节 (Mandatory Name Forms) 中指定了该字符串的格式。RFC 1510 的 7.2 小节 (Principal Names) 中指定了有效的名称类型。输入的名称必须与提供的名称类型一致。（例如，duke@FOO.COM 是 KRB_NT_PRINCIPAL 名称类型的有效输入字符串，其中 duke 表示主体，FOO.COM 表示域）。

如果输入的名称中不包含域，则使用默认的域。可以在 Kerberos 配置文件中指定默认域或通过 java.security.krb5.realm 系统属性指定默认域。有关的更多信息请参见 Kerberos Requirements 。

参数：
name - 主体名称
nameType - 主体的名称类型
抛出：
IllegalArgumentException - 如果名称不是正确格式的，或者名称为 null，抑或如果 nameType 不受支持，或者如果名称不包含将使用的域并且没有在 Kerberos 配置文件中指定默认域或通过 java.security.krb5.realm 系统属性指定默认域。
方法详细信息

getRealm

public String getRealm()
返回此 Kerberos 主体的域组件。

返回：
此 Kerberos 主体的域组件。

hashCode

public int hashCode()
返回此主体的哈希码。哈希码被定义为以下计算的结果：

  hashCode = getName().hashCode();

指定者：
接口 Principal 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
KerberosPrincipal 的 hashCode()
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object other)
比较指定的对象与此 Principal 是否相等。如果给定对象也是一个 KerberosPrincipal 并且两个 KerberosPrincipal 实例是等效的，则返回 true。更正式地说，如果 getName() 返回的值是相等的并且 getNameType() 返回的值也是相等的，则两个 KerberosPrincipal 实例是相等的。

指定者：
接口 Principal 中的 equals
覆盖：
类 Object 中的 equals
参数：
other - 要与之进行比较的 Object
返回：
如果传入的 Object 和此对象表示相同的主体，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

getName

public String getName()
返回的字符串对应于 Kerberos Principal 名称的 single-string 表示形式，RFC 1964 的 2.1 小节中指定了这种表示形式。

指定者：
接口 Principal 中的 getName
返回：
主体名称。

getNameType

public int getNameType()
返回 KerberosPrincipal 的名称类型。 RFC1510 的 7.2 小节中指定了有效的名称类型。

返回：
名称类型。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

指定者：
接口 Principal 中的 toString
覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KerberosTicket (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.kerberos
类 KerberosTicket

java.lang.Object
    继承者  javax.security.auth.kerberos.KerberosTicket
所有已实现的接口：
Serializable, Destroyable, Refreshable
public class KerberosTicket
extends Object
implements Destroyable, Refreshable, Serializable

此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。它捕获 Key Distribution Center (KDC) 发送给客端的所有信息，这些信息定义在 Kerberos 协议规范(RFC 1510) 中的应答消息 KDC-REP 中。

向 KDC 验证用户的所有 Kerberos JAAS 登录模块都应该使用此类。在可以使用的地方，登录模块甚至可以从操作系统的票据缓存中读取此信息，而不是直接与 KDC 通信。在 JAAS 验证过程的提交阶段，JAAS 登录模块应该实例化此类并将该实例存储在 Subject 的私有证书集中。

如果应用程序需要从 Subject 访问 KerberosTicket 实例，可能必须授予应用程序 PrivateCredentialPermission 权限。当应用程序依靠默认的 JGSS Kerberos 机制去访问 KerberosTicket 时，不需要此权限。但在这种情况下，应用程序将需要适当的 ServicePermission 权限。

注意此类适用于票据授权票据和其他的规则服务票据。票据授权票据就是更一般化的服务票据的特殊情况。

从以下版本开始：
1.4
另请参见：
Subject, PrivateCredentialPermission, LoginContext, GSSCredential, GSSManager, 序列化表格

构造方法摘要
KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。
方法摘要
void | destroy() 销毁票据和存储在其中的敏感信息。
boolean | equals(Object other) 比较给定 Object 与此 KerberosTicket 的相等性。
Date | getAuthTime() 返回客户端进行验证的时间。
KerberosPrincipal | getClient() 返回与此票据有关联的客户端主体。
InetAddress[] | getClientAddresses() 返回可从其所指位置使用票据的地址列表。
byte[] | getEncoded() 返回整个票据的 ASN.1 编码。
Date | getEndTime() 返回此票据有效期的期满时间。
boolean[] | getFlags() 返回与此票据有关联的标志。
Date | getRenewTill() 返回此票据最新的期满时间，包括所有的更新。
KerberosPrincipal | getServer() 返回与此票据有关联的服务主体。
SecretKey | getSessionKey() 返回与此票据有关联的会话密钥。
int | getSessionKeyType() 返回与此票据有关联的会话密钥的密钥类型（由 Kerberos Protocol Specification 定义）。
Date | getStartTime() 返回此票据有效期的开始时间。
int | hashCode() 返回此 KerberosTicket 的哈希码。
boolean | isCurrent() 确定此票据是否仍旧是当前的。
boolean | isDestroyed() 确定是否已经销毁此票据。
boolean | isForwardable() 确定此票据是否是可转发的。
boolean | isForwarded() 根据验证（包括转发的票据授权票据）确定此票据是否已经转发或发出。
boolean | isInitial() 确定此票据是否是使用 Kerberos AS-Exchange 协议发出的，而不是根据某些票据授权票据发出的。
boolean | isPostdated() 确定此票据是否是延后的。
boolean | isProxiable() 确定此票据是否是可代理的。
boolean | isProxy() 确定此票据是否是代理票据。
boolean | isRenewable() 确定此票据是否是可更新的。
void | refresh() 延长此票据的有效期。
String | toString() 返回该对象的字符串表示。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

KerberosTicket

public KerberosTicket(byte[] asn1Encoding,
                      KerberosPrincipal client,
                      KerberosPrincipal server,
                      byte[] sessionKey,
                      int keyType,
                      boolean[] flags,
                      Date authTime,
                      Date startTime,
                      Date endTime,
                      Date renewTill,
                      InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。

参数：
asn1Encoding - Kerberos 协议规范定义的票据的 ASN.1 编码
client - 拥有此服务票据的客户端
server - 适用此票据的服务
sessionKey - 必须用来加密将要发送给服务器的授权者的会话密钥的原始字节
keyType - Kerberos 协议规范定义的会话密钥的密钥类型。
flags - 票据标志。此数组中的每个元素指示表示票据标志的 ASN.1 BitString 中的相应位值。如果此数组中的元素的数量小于 Kerberos 协议使用的标志的数量，则将丢失的标记填充为 false。
authTime - 客户端的初始验证时间
startTime - 经过这段时间后票据将生效。将 authTime 的值视为 startTime 时，此值可以为 null。
endTime - 经过这段时间后票据将不再有效
renewTill - 票据的绝对过期时间，包括所有可能的更新。对于不可更新的票据，此字段可以为 null。
clientAddresses - 客户端可以在其所指的位置使用票据的地址。如果票据在任何地址都是可用的，则此字段可以为 null。
方法详细信息

getClient

public final KerberosPrincipal getClient()
返回与此票据有关联的客户端主体。

返回：
客户端主体。

getServer

public final KerberosPrincipal getServer()
返回与此票据有关联的服务主体。

返回：
服务主体。

getSessionKey

public final SecretKey getSessionKey()
返回与此票据有关联的会话密钥。

返回：
会话密钥。

getSessionKeyType

public final int getSessionKeyType()
返回与此票据有关联的会话密钥的密钥类型（由 Kerberos Protocol Specification 定义）。

返回：
与此票据关联的会话密钥的密钥类型。
另请参见：
getSessionKey()

isForwardable

public final boolean isForwardable()
确定此票据是否是可转发的。

返回：
如果此票据是可转发的，则返回 true；否则返回 false。

isForwarded

public final boolean isForwarded()
根据验证（包括转发的票据授权票据）确定此票据是否已经转发或发出。

返回：
如果根据涉及转发的票据授权票据的验证确定此票据已经转发或发出，则返回 true；否则返回 false。

isProxiable

public final boolean isProxiable()
确定此票据是否是可代理的。

返回：
如果此票据是可代理的，则返回 true；否则返回 false。

isProxy

public final boolean isProxy()
确定此票据是否是代理票据。

返回：
如果此票据是代理票据，则返回 true；否则返回 false。

isPostdated

public final boolean isPostdated()
确定此票据是否是延后的。

返回：
如果此票据是延后的，则返回 true；否则返回 false。

isRenewable

public final boolean isRenewable()
确定此票据是否是可更新的。如果是可更新的，则调用 refresh 方法，假定更新的有效期还没有结束。

返回：
如果此票据是可更新的，则返回 true；否则返回 false。

isInitial

public final boolean isInitial()
确定此票据是否是使用 Kerberos AS-Exchange 协议发出的，而不是根据某些票据授权票据发出的。

返回：
如果此票据是使用 Kerberos AS-Exchange 协议发出的，则返回 true；否则返回 false。

getFlags

public final boolean[] getFlags()
返回与此票据有关联的标志。返回数组中的每个元素指示表示票据标志的 ASN.1 BitString 中的相应位值。

返回：
与此票据有关联的标志。

getAuthTime

public final Date getAuthTime()
返回客户端进行验证的时间。

返回：
对客户端进行验证的时间；如果未设置，则返回 null。

getStartTime

public final Date getStartTime()
返回此票据有效期的开始时间。

返回：
此票据有效期的开始时间；如果未设置，则返回 null。

getEndTime

public final Date getEndTime()
返回此票据有效期的期满时间。

返回：
此票据有效期的期满时间。

getRenewTill

public final Date getRenewTill()
返回此票据最新的期满时间，包括所有的更新。对于不可更新的票据将返回 null 值。

返回：
此票据最新的期满时间。

getClientAddresses

public final InetAddress[] getClientAddresses()
返回可从其所指位置使用票据的地址列表。

返回：
地址列表，如果没有提供此字段，则返回 null。

getEncoded

public final byte[] getEncoded()
返回整个票据的 ASN.1 编码。

返回：
整个票据的 ASN.1 编码。

isCurrent

public boolean isCurrent()
确定此票据是否仍旧是当前的。

指定者：
接口 Refreshable 中的 isCurrent
返回：
如果此 Object 是当前的，则返回 true；否则，返回 false。

refresh

public void refresh()
             throws RefreshFailedException
延长此票据的有效期。如果刷新操作成功，则票据将包含一个新的会话密钥。如果票据是不可更新的或已经超出最新允许更新时间，则刷新操作将失败。任何由 KDC 返回的其他错误都将导致此方法失败。 注：此方法与此对象的 accessor 方法不是同步的。因此调用者需要意识到有多个线程可能访问此方法并试图在同一时间更新它。

指定者：
接口 Refreshable 中的 refresh
抛出：
RefreshFailedException - 如果票据是不可更新的，或已经超过了最新允许更新时间，抑或 KDC 返回了某些错误。
另请参见：
isRenewable(), getRenewTill()

destroy

public void destroy()
             throws DestroyFailedException
销毁票据和存储在其中的敏感信息。

指定者：
接口 Destroyable 中的 destroy
抛出：
DestroyFailedException - 如果销毁操作失败。

isDestroyed

public boolean isDestroyed()
确定是否已经销毁此票据。

指定者：
接口 Destroyable 中的 isDestroyed
返回：
如果此 Object 已经销毁，则返回 true；否则，返回 false。

toString

public String toString()
从类 Object 复制的描述
返回该对象的字符串表示。通常，toString 方法会返回一个“以文本方式表示”此对象的字符串。结果应是一个简明但易于读懂的信息表达式。建议所有子类都重写此方法。

Object 类的 toString 方法返回一个字符串，该字符串由类名（对象是该类的一个实例）、at 标记符“@”和此对象哈希码的无符号十六进制表示组成。换句话说，该方法返回一个字符串，它的值等于：

getClass().getName() + '@' + Integer.toHexString(hashCode())

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

hashCode

public int hashCode()
返回此 KerberosTicket 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
KerberosTicket 的 hashCode()
从以下版本开始：
1.6
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object other)
比较给定 Object 与此 KerberosTicket 的相等性。如果给定对象也是 KerberosTicket 并且两个 KerberosTicket 相等，则返回 true。

覆盖：
类 Object 中的 equals
参数：
other - 要比较的 Object
返回：
如果指定对象等于此 KerberosTicket，则返回 true；否则返回 false。注：如果其中一个 KerberosTicket 已经销毁，则返回 false。
从以下版本开始：
1.6
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ServicePermission (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.kerberos
类 ServicePermission

java.lang.Object
    继承者  java.security.Permission
        继承者  javax.security.auth.kerberos.ServicePermission
所有已实现的接口：
Serializable, Guard
public final class ServicePermission
extends Permission
implements Serializable

此类用于保护 Kerberos 服务和访问这些服务所必需的证书。服务主体与访问该服务所必需的证书之间存在一对一的映射关系。因此授予访问服务主体的权限隐含了授予访问使用该服务主体建立安全上下文所必需的证书的权限。不管证书是在缓存中还是通过与 KDC 交换获得的，这一规则都适用。证书可以是票据授权票据、服务票据或密钥表中的密钥。

ServicePermission 包含服务主体名称和指定可在其中使用证书的上下文的动作列表。

服务主体名称是提供服务的 KereberosPrincipal 的规范名称，也就是说 KerberosPrincipal 表示 Kerberos 服务主体。此名称是以区分大小写的方式处理的。星号可以单独出现，表示任何服务主体。

授予此权限暗示着调用者可以使用该动作指定的上下文中缓存的证书（TGT、服务票据或秘密密钥）。在证书为 TGT 的情况下，授予此权限还暗示着 TGT 可以通过 Authentication Service 交换获得。

可能的动作为：

initiate -  允许调用者使用证书来启动带有服务主体的安全上下文。

accept -  允许调用者使用证书来接受作为特定主体的安全上下文。
例如，指定访问 TGT 的权限来启动安全上下文，权限的构造如下：

     ServicePermission("krbtgt/EXAMPLE.COM@EXAMPLE.COM", "initiate");

为获取服务票据来启动带有 "host" 服务的上下文，权限的构造如下：

     ServicePermission("host/foo.example.com@EXAMPLE.COM", "initiate");

对于 Kerberized 服务器，该动作为 "accept"。例如，访问和使用 Kerberized“主机”服务（telnet 以及类似服务）的秘密密钥的权限将被构造如下：

     ServicePermission("host/foo.example.com@EXAMPLE.COM", "accept");

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
ServicePermission(String servicePrincipal, String action)
创建带指定的 servicePrincipal 和 action 的新 ServicePermission。
方法摘要
boolean | equals(Object obj) 检查两个 ServicePermission 对象是否相等。
String | getActions() 返回动作的规范化字符串表示形式。
int | hashCode() 返回此对象的哈希码值。
boolean | implies(Permission p) 检查此 Kerberos 服务权限对象是否“隐含”指定的权限。
PermissionCollection | newPermissionCollection() 返回用于存储 ServicePermission 对象的 PermissionCollection 对象。
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ServicePermission

public ServicePermission(String servicePrincipal,
                         String action)
创建带指定的 servicePrincipal 和 action 的新 ServicePermission。

参数：
servicePrincipal - 服务主体的名称。星号可以单独出现，表示任何服务主体。

actions - 动作字符串。
方法详细信息

implies

public boolean implies(Permission p)
检查此 Kerberos 服务权限对象是否“隐含”指定的权限。

如果上述条件都不为 true，则 implies 返回 false。

指定者：
类 Permission 中的 implies
参数：
p - 所要检查的权限。
返回：
如果此对象隐含指定的权限，则返回 true；否则返回 false。

equals

public boolean equals(Object obj)
检查两个 ServicePermission 对象是否相等。

指定者：
类 Permission 中的 equals
参数：
obj - 要与此对象进行相等性测试的对象。
返回：
如果 obj 是一个 ServicePermission，并且与此 ServicePermission 对象具有相同的服务主体和动作，则返回 true。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此对象的哈希码值。

指定者：
类 Permission 中的 hashCode
返回：
此对象的哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getActions

public String getActions()
返回动作的规范化字符串表示形式。始终按以下顺序返回存在的动作：initiate 和 accept。

指定者：
类 Permission 中的 getActions
返回：
此 Permission 的操作。

newPermissionCollection

public PermissionCollection newPermissionCollection()
返回用于存储 ServicePermission 对象的 PermissionCollection 对象。
ServicePermission 对象必须以允许将它们按任意顺序插入集合的方式来存储，但同时也允许以有效（并一致）的方式实现 PermissionCollection 的 implies 方法。

覆盖：
类 Permission 中的 newPermissionCollection
返回：
适合用来存储 ServicePermissions 的新的 PermissionCollection 对象。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.auth.kerberos (Java 2 Platform SE 6)

 javax.security.auth.kerberos
类
DelegationPermission
KerberosKey
KerberosPrincipal
KerberosTicket
ServicePermission


javax.security.auth.kerberos (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.auth.kerberos

此包包含与 Kerberos 网络验证协议相关的实用工具类。

请参见：
描述

类摘要
DelegationPermission | 此类用于限制 Kerberos 代理模型（即可转发和可代理票据）的使用。
KerberosKey | 此类为 Kerberos 主体封装一个长期秘密密钥。
KerberosPrincipal | 此类封装 Kerberos 主体。
KerberosTicket | 此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。
ServicePermission | 此类用于保护 Kerberos 服务和访问这些服务所必需的证书。

软件包 javax.security.auth.kerberos 的描述

此包包含与 Kerberos 网络验证协议相关的实用工具类。它们本身不对 Kerberos 提供太多的支持。

Kerberos 网络验证协议定义在 RFC 1510 中。Java 2 平台通过 org.ietf.jgss 包来包含对 Kerberos 客户端的支持。可能还包含一个实现 LoginModule 的登录模块来对 Kerberos 主体进行验证。

使用系统属性 java.security.krb5.realm 和 java.security.krb5.kdc，用户可以提供自己默认的域名称和用于该域的 Key Distribution Center (KDC) 主机。此外，可以提供 <java-home>/lib/security 目录中的称为 krb5.conf 的 MIT 样式配置文件。如果把此文件放置在别的地方，可以通过系统属性 java.security.krb5.conf 指示该位置。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.auth.kerberos 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.kerberos 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.security.auth.kerberos.KerberosKey (implements javax.security.auth.Destroyable, javax.crypto.SecretKey)
    • javax.security.auth.kerberos.KerberosPrincipal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.kerberos.KerberosTicket (implements javax.security.auth.Destroyable, javax.security.auth.Refreshable, java.io.Serializable)
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.security.auth.kerberos.DelegationPermission (implements java.io.Serializable)
      • javax.security.auth.kerberos.ServicePermission (implements java.io.Serializable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.auth.kerberos 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.kerberos
的使用

使用 javax.security.auth.kerberos 的软件包
javax.security.auth.kerberos 此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.kerberos 使用的 javax.security.auth.kerberos 中的类
KerberosPrincipal
此类封装 Kerberos 主体。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.kerberos.DelegationPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.DelegationPermission
的使用

没有 javax.security.auth.kerberos.DelegationPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.kerberos.KerberosKey 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.KerberosKey
的使用

没有 javax.security.auth.kerberos.KerberosKey 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.kerberos.KerberosPrincipal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.KerberosPrincipal
的使用

使用 KerberosPrincipal 的软件包
javax.security.auth.kerberos 此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.kerberos 中 KerberosPrincipal 的使用

返回 KerberosPrincipal 的 javax.security.auth.kerberos 中的方法
KerberosPrincipal | KerberosTicket.getClient() 返回与此票据有关联的客户端主体。
KerberosPrincipal | KerberosKey.getPrincipal() 返回此密钥所属的主体。
KerberosPrincipal | KerberosTicket.getServer() 返回与此票据有关联的服务主体。

参数类型为 KerberosPrincipal 的 javax.security.auth.kerberos 中的构造方法
KerberosKey(KerberosPrincipal principal, byte[] keyBytes, int keyType, int versionNum)
当已知密钥类型和密钥版本号时，根据给出的字节构造 KerberosKey。
KerberosKey(KerberosPrincipal principal, char[] password, String algorithm)
根据主体的密码构造 KerberosKey。
KerberosTicket(byte[] asn1Encoding, KerberosPrincipal client, KerberosPrincipal server, byte[] sessionKey, int keyType, boolean[] flags, Date authTime, Date startTime, Date endTime, Date renewTill, InetAddress[] clientAddresses)
使用客户端从 KDC 接收的或从缓存中读取的证书信息构造 KerberosTicket。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.kerberos.KerberosTicket 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.KerberosTicket
的使用

没有 javax.security.auth.kerberos.KerberosTicket 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.kerberos.ServicePermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.kerberos.ServicePermission
的使用

没有 javax.security.auth.kerberos.ServicePermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AccountException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 AccountException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.AccountException
所有已实现的接口：
Serializable
直接已知子类：
AccountExpiredException, AccountLockedException, AccountNotFoundException
public class AccountException
extends LoginException

一般的帐户异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AccountException()
构造不带详细消息的 AccountException。
AccountException(String msg)
构造带指定详细消息的 AccountException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AccountException

public AccountException()
构造不带详细消息的 AccountException。详细消息是描述此特定异常的 String。

AccountException

public AccountException(String msg)
构造带指定详细消息的 AccountException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AccountExpiredException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 AccountExpiredException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.AccountException
                        继承者  javax.security.auth.login.AccountExpiredException
所有已实现的接口：
Serializable
public class AccountExpiredException
extends AccountException

当用户帐户到期时抛出此异常。

当 LoginModule 确定一个帐户已到期时抛出此异常。例如，在成功验证用户身份后， LoginModule 可以确定该用户的帐号已到期。 在这种情况下，LoginModule 抛出此异常来通知应用程序。然后应用程序采取适当的步骤来通知用户。

另请参见：
序列化表格

构造方法摘要
AccountExpiredException()
构造不带详细消息的 AccountExpiredException。
AccountExpiredException(String msg)
构造带指定详细消息的 AccountExpiredException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AccountExpiredException

public AccountExpiredException()
构造不带详细消息的 AccountExpiredException。详细消息是描述此特定异常的 String。

AccountExpiredException

public AccountExpiredException(String msg)
构造带指定详细消息的 AccountExpiredException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccountLockedException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 AccountLockedException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.AccountException
                        继承者  javax.security.auth.login.AccountLockedException
所有已实现的接口：
Serializable
public class AccountLockedException
extends AccountException

帐户被锁定时抛出此异常。

当 LoginModule 确定正在试图对一个锁定帐户进行验证时，可以抛出此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AccountLockedException()
构造不带详细消息的 AccountLockedException。
AccountLockedException(String msg)
构造带指定详细消息的 AccountLockedException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AccountLockedException

public AccountLockedException()
构造不带详细消息的 AccountLockedException。详细消息是描述此特定异常的 String。

AccountLockedException

public AccountLockedException(String msg)
构造带指定详细消息的 AccountLockedException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AccountNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 AccountNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.AccountException
                        继承者  javax.security.auth.login.AccountNotFoundException
所有已实现的接口：
Serializable
public class AccountNotFoundException
extends AccountException

未找到帐户时抛出此异常。

如果 LoginModule 无法找到执行验证所需的帐户时，可以抛出此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AccountNotFoundException()
构造不带详细消息的 AccountNotFoundException。
AccountNotFoundException(String msg)
构造带指定详细消息的 AccountNotFoundException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AccountNotFoundException

public AccountNotFoundException()
构造不带详细消息的 AccountNotFoundException。详细消息是描述此特定异常的 String。

AccountNotFoundException

public AccountNotFoundException(String msg)
构造带指定详细消息的 AccountNotFoundException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AppConfigurationEntry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 AppConfigurationEntry

java.lang.Object
    继承者  javax.security.auth.login.AppConfigurationEntry

public class AppConfigurationEntry
extends Object

此类表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。每个 AppConfigurationEntry 都包含 LoginModule 名称、控制标记（指定此 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL）和特定于 LoginModule 的选项。有关不同的控制标记及其语义的更多信息，请参考 Configuration 类。

另请参见：
Configuration

嵌套类摘要
static class AppConfigurationEntry.LoginModuleControlFlag
此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。
构造方法摘要
AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。
方法摘要
AppConfigurationEntry.LoginModuleControlFlag | getControlFlag() 返回此 LoginModule 的 controlFlag（REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL 中的任何一个）。
String | getLoginModuleName() 获取所配置的 LoginModule 的类名称。
Map<String,?> | getOptions() 获取为此 LoginModule 配置的选项。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AppConfigurationEntry

public AppConfigurationEntry(String loginModuleName,
                             AppConfigurationEntry.LoginModuleControlFlag controlFlag,
                             Map<String,?> options)
此类的默认构造方法。

此条目表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。

参数：
loginModuleName - 表示为指定的应用程序配置的 LoginModule 的类名称的 String。

controlFlag - REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。

options - 为此 LoginModule 配置的选项。
抛出：
IllegalArgumentException - 如果 loginModuleName 为 null；如果 LoginModuleName 的长度为 0；如果 controlFlag 不是 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL；如果 options 为 null。
方法详细信息

getLoginModuleName

public String getLoginModuleName()
获取所配置的 LoginModule 的类名称。

返回：
所配置的 LoginModule 的 String 形式的类名称。

getControlFlag

public AppConfigurationEntry.LoginModuleControlFlag getControlFlag()
返回此 LoginModule 的 controlFlag（REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL 中的任何一个）。

返回：
此 LoginModule 的 controlFlag（REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL 中的任何一个）。

getOptions

public Map<String,?> getOptions()
获取为此 LoginModule 配置的选项。

返回：
为此 LoginModule 配置的不可修改的 Map 形式的选项。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AppConfigurationEntry.LoginModuleControlFlag (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 AppConfigurationEntry.LoginModuleControlFlag

java.lang.Object
    继承者  javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
正在封闭类：
AppConfigurationEntry
public static class AppConfigurationEntry.LoginModuleControlFlag
extends Object

此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。

字段摘要
static AppConfigurationEntry.LoginModuleControlFlag | OPTIONAL 可供选择的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | REQUIRED 所需的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | REQUISITE 必需的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | SUFFICIENT 足够的 LoginModule。
方法摘要
 String toString()
返回此 controlFlag 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

REQUIRED

public static final AppConfigurationEntry.LoginModuleControlFlag REQUIRED
所需的 LoginModule。

REQUISITE

public static final AppConfigurationEntry.LoginModuleControlFlag REQUISITE
必需的 LoginModule。

SUFFICIENT

public static final AppConfigurationEntry.LoginModuleControlFlag SUFFICIENT
足够的 LoginModule。

OPTIONAL

public static final AppConfigurationEntry.LoginModuleControlFlag OPTIONAL
可供选择的 LoginModule。

方法详细信息

toString

public String toString()
返回此 controlFlag 的字符串表示形式。

该字符串的格式为 "LoginModuleControlFlag: flag"，其中 flag 是 required、requisite、sufficient、optional 之一。

覆盖：
类 Object 中的 toString
返回：
此 controlFlag 的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Configuration (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 Configuration

java.lang.Object
    继承者  javax.security.auth.login.Configuration

public abstract class Configuration
extends Object

Configuration 对象负责指定应该将哪一个 LoginModule 用于某一特定应用程序，以及应该以什么样的顺序调用 LoginModule。

登录配置包含以下信息。注意，此示例仅表示 Configuration 的默认语法。此类的子类实现可以实现替代语法，也可以从任何源（比如文件、数据库或服务器）中检索 Configuration。

      Name {
              ModuleClass  Flag    ModuleOptions;
              ModuleClass  Flag    ModuleOptions;
              ModuleClass  Flag    ModuleOptions;
      };
      Name {
              ModuleClass  Flag    ModuleOptions;
              ModuleClass  Flag    ModuleOptions;
      };
other {
              ModuleClass  Flag    ModuleOptions;
              ModuleClass  Flag    ModuleOptions;
      };

Configuration 中的每个条目都是通过应用程序名（Name）进行索引的，并且每个条目都包含为该应用程序配置的 LoginModules 的列表。每个 LoginModule 都是通过其完全限定类名来指定的。验证是按指定的具体顺序沿着模块列表向下进行。如果应用程序没有特定条目，则验证的条目默认为用于“其他方面”的特定条目。

当顺着堆栈往下进行验证时，Flag 值控制整个行为。下面是 Flag 的有效值的描述和它们各自的语义：

1) Required - 要求 LoginModule 成功。
              不管它成功或失败，验证都将沿着 LoginModule 列表继续向下进行。
2) Requisite - 要求 LoginModule 成功。
               如果它成功，则验证沿着 LoginModule 列表继续向下进行。
               如果它失败，则该控制立即返回给应用程序（验证不再沿着 LoginModule 列表继续向下进行)。
3) Sufficient - 不要求 LoginModule 成功。
               如果成功，则控制立即返回到应用程序（验证不再沿着 LoginModule 列表继续向下进行）。
               如果失败，则验证沿着 LoginModule 列表继续向下进行。
4) Optional - 不要求 LoginModule 成功。
              不管它成功或失败，验证都将沿着 LoginModule 列表继续向下进行。

仅在所有 Required 和 Requisite LoginModules 成功时，整个验证才成功。如果配置了 Sufficient LoginModule 并且获得成功，则只要 Sufficient LoginModule 之前的 Required 和 Requisite LoginModules 是成功的，整个验证就会成功。如果没有为应用程序配置 Required 或 Requisite LoginModules，那么至少有一个 Sufficient 或 Optional LoginModule 必须成功。

ModuleOptions 是特定于 LoginModule 的值的空格隔开列表，这些值被直接传递给底层 LoginModules。这些选项由 LoginModule 自身定义，并在其自身中控制它的行为。例如，LoginModule 可以定义一些选项，以便支持调试/测试功能。在 Configuration 中指定选项的正确方法是使用如下的键-值对：debug="true"。键和值应该用等号分隔，值应该用双引号括起来。如果在值中出现 ${system.property} 形式的 String，则将它扩展为系统属性值。注意，对 LoginModule 可以定义的选项个数的没有限制。

下面展示基于以上语法的示例 Configuration 条目：

 Login {
   com.sun.security.auth.module.UnixLoginModule required;
   com.sun.security.auth.module.Krb5LoginModule optional
                   useTicketCache="true"
                   ticketCache="${user.home}${/}tickets";
 };

此 Configuration 指定一个名称为 "Login" 的应用程序，要求用户首先对 com.sun.security.auth.module.UnixLoginModule 进行验证，该验证必须成功。即使 UnixLoginModule 验证失败，com.sun.security.auth.module.Krb5LoginModule 仍将被调用。这有助于隐藏失败源。由于 Krb5LoginModule 是 Optional，所以仅在 UnixLoginModule (Required) 成功时，整个验证才获得成功。

还要注意的是，特定于 LoginModule 的选项 useTicketCache="true" 和 ticketCache=${user.home}${/}tickets" 被传递到 Krb5LoginModule。这些选项指示 Krb5LoginModule 使用指定位置处缓存的票据。系统属性 user.home 和 / (file.separator) 扩展成它们各自的值。

在任意给定时间，运行时中只安装了一个 Configuration 对象。可通过调用 setConfiguration 方法安装 Configuration 对象。已安装的 Configuration 对象可通过调用 getConfiguration 方法获取。

如果运行时中没有安装 Configuration 对象，则对 getConfiguration 的调用将安装一个默认 Configuration 实现的实例（此抽象类的默认子类实现）。通过将 "login.configuration.provider" 的安全属性（在 Java 安全属性文件中）的值设置为所需的 Configuration 子类实现的完全限定名，可以更改默认的 Configuration 实现。Java 安全属性文件位于名称为 <JAVA_HOME>/lib/security/java.security 的文件中。<JAVA_HOME> 是指 java.home 系统属型的值，也指定安装 JRE 的目录。

应用程序代码可直接子类化 Configuration 以提供自定义实现。此外，可通过调用带标准类型的某一个 getInstance 工厂方法构造 Configuration 对象的实例。默认策略类型为 "JavaLoginConfig"。有关标准 Configuration 类型的列表，请参见 Java Cryptography Architecture API Specification & Reference 的附录 A。

另请参见：
LoginContext

嵌套类摘要
static interface Configuration.Parameters
此类表示 Configuration 参数的标记接口。
构造方法摘要
protected Configuration()
唯一的构造方法。
方法摘要
abstract AppConfigurationEntry[] | getAppConfigurationEntry(String name) 获取此 Configuration 中指定 name 的 AppConfigurationEntry。
static Configuration | getConfiguration() 获取已安装的登录 Configuration。
static Configuration | getInstance(String type, Configuration.Parameters params) 返回指定类型的 Configuration 对象。
static Configuration | getInstance(String type, Configuration.Parameters params, Provider provider) 返回指定类型的 Configuration 对象。
static Configuration | getInstance(String type, Configuration.Parameters params, String provider) 返回指定类型的 Configuration 对象。
Configuration.Parameters | getParameters() 返回 Configuration 参数。
Provider | getProvider() 返回此 Configuration 的 Provider。
String | getType() 返回此 Configuration 的类型。
void | refresh() 刷新和重新加载 Configuration。
static void | setConfiguration(Configuration configuration) 设置登录 Configuration。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Configuration

protected Configuration()
唯一的构造方法。（由子类构造方法调用，通常是隐式的）。

方法详细信息

getConfiguration

public static Configuration getConfiguration()
获取已安装的登录 Configuration。

返回：
登录 Configuration。如果 Configuration 对象是由 Configuration.setConfiguration 方法设置的，则返回该对象。否则返回默认的 Configuration 对象。
抛出：
SecurityException - 如果调用者没有检索此 Configuration 的权限。
另请参见：
setConfiguration(javax.security.auth.login.Configuration)

setConfiguration

public static void setConfiguration(Configuration configuration)
设置登录 Configuration。

参数：
configuration - 新的 Configuration
抛出：
SecurityException - 如果当前线程没有设置 Configuration 的 Permission。
另请参见：
getConfiguration()

getInstance

public static Configuration getInstance(String type,
                                        Configuration.Parameters params)
                                 throws NoSuchAlgorithmException
返回指定类型的 Configuration 对象。

此方法从首选 Provider 开始遍历已注册安全提供者列表。返回一个封装 ConfigurationSpi 实现的新 Configuration 对象，该实现取自支持指定类型的第一个 Provider。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
type - 指定的 Configuration 类型。有关标准 Configuration 类型的列表，请参见 Java Cryptography Architecture API Specification & Reference 的附录 A。
params - Configuration 的参数，可以为 null。
返回：
新的 Configuration 对象。
抛出：
SecurityException - 如果调用者没有获取指定类型的 Configuration 实例的权限。
NullPointerException - 如果指定类型为 null。
IllegalArgumentException - 如果取自选定 Provider 的 ConfigurationSpi 实现不理解指定参数。
NoSuchAlgorithmException - 如果没有 Provider 支持指定类型的 ConfigurationSpi 实现。
从以下版本开始：
1.6
另请参见：
Provider

getInstance

public static Configuration getInstance(String type,
                                        Configuration.Parameters params,
                                        String provider)
                                 throws NoSuchProviderException,
                                        NoSuchAlgorithmException
返回指定类型的 Configuration 对象。

返回一个封装 ConfigurationSpi 实现的新 Configuration 对象，该实现取自指定的提供者。指定的提供者必须在安全提供者列表中注册。

注意，可以通过 Security.getProviders() 方法获取已注册提供者列表。

参数：
type - 指定的 Configuration 类型。有关标准 Configuration 类型的列表，请参见 Java Cryptography Architecture API Specification & Reference 的附录 A。
params - Configuration 的参数，可以为 null。
provider - 提供者。
返回：
新的 Configuration 对象。
抛出：
SecurityException - 如果调用者没有获取指定类型的 Configuration 实例的权限。
NullPointerException - 如果指定类型为 null。
IllegalArgumentException - 如果指定提供者为 null 或空，或者取自指定提供者的 ConfigurationSpi 实现不理解指定参数。
NoSuchProviderException - 如果指定提供者未在安全提供者列表中注册。
NoSuchAlgorithmException - 如果指定提供者不支持指定类型的 ConfigurationSpi 实现。
从以下版本开始：
1.6
另请参见：
Provider

getInstance

public static Configuration getInstance(String type,
                                        Configuration.Parameters params,
                                        Provider provider)
                                 throws NoSuchAlgorithmException
返回指定类型的 Configuration 对象。

返回一个封装 ConfigurationSpi 实现的新 Configuration 对象，该实现取自指定的 Provider 对象。 注意，指定的 Provider 对象无需在提供者列表中注册。

参数：
type - 指定的 Configuration 类型。有关标准 Configuration 类型的列表，请参见 Java Cryptography Architecture API Specification & Reference 的附录 A。
params - Configuration 的参数，可以为 null。
provider - Provider。
返回：
新的 Configuration 对象。
抛出：
SecurityException - 如果调用者没有获取指定类型的 Configuration 实例的权限。
NullPointerException - 如果指定类型为 null。
IllegalArgumentException - 如果指定的 Provider 为 null，或者取自指定 Provider 的 ConfigurationSpi 实现不理解指定参数。
NoSuchAlgorithmException - 如果指定 Provider 不支持指定类型的 ConfigurationSpi 实现。
从以下版本开始：
1.6
另请参见：
Provider

getProvider

public Provider getProvider()
返回此 Configuration 的 Provider。

只有在此 Configuration 实例是通过调用 Configuration.getInstance 获得的时，它才有 Provider。否则，此方法返回 null。

返回：
此 Configuration 的 Provider，或者返回 null。
从以下版本开始：
1.6

getType

public String getType()
返回此 Configuration 的类型。

只有在此 Configuration 实例是通过调用 Configuration.getInstance 获得的时，它才有类型。否则，此方法返回 null。

返回：
此 Configuration 的类型，或者返回 null。
从以下版本开始：
1.6

getParameters

public Configuration.Parameters getParameters()
返回 Configuration 参数。

只有在此 Configuration 实例是通过调用 Configuration.getInstance 获得的时，它才有参数。否则，此方法返回 null。

返回：
Configuration 参数，或者返回 null。
从以下版本开始：
1.6

getAppConfigurationEntry

public abstract AppConfigurationEntry[] getAppConfigurationEntry(String name)
获取此 Configuration 中指定 name 的 AppConfigurationEntry。

参数：
name - 用于索引 Configuration 的名称。
返回：
对应于此 Configuration 中指定 name 的 AppConfigurationEntries 数组，如果不存在指定的 name 条目，则返回 null。

refresh

public void refresh()
刷新和重新加载 Configuration。

此方法导致此 Configuration 对象以与实现有关的方式刷新/重新加载其内容。例如，如果此 Configuration 对象将其条目存储在文件中，则调用 refresh 可能导致重新读取该文件。

此方法的默认实现不执行任何操作。如果该实现支持刷新操作，则应该重写此方法。

抛出：
SecurityException - 如果调用者没有刷新此 Configuration 的权限。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Configuration.Parameters (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
接口 Configuration.Parameters

所有已知实现类：
URIParameter
正在封闭类：
Configuration
public static interface Configuration.Parameters

此类表示 Configuration 参数的标记接口。

从以下版本开始：
1.6

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConfigurationSpi (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 ConfigurationSpi

java.lang.Object
    继承者  javax.security.auth.login.ConfigurationSpi

public abstract class ConfigurationSpi
extends Object

此类为 Configuration 类定义服务提供者接口（SPI）。每个想要提供 Configuration 实现的服务提供者都必须实现此类中的所有抽象方法。

此抽象类的子类实现必须提供可将 Configuration.Parameters 对象作为输入参数的公共构造方法。如果此构造方法不理解 Configuration.Parameters 输入，那么它也必须抛出 IllegalArgumentException。

从以下版本开始：
1.6

构造方法摘要
ConfigurationSpi()
方法摘要
protected abstract AppConfigurationEntry[] | engineGetAppConfigurationEntry(String name) 获取指定 name 的 AppConfigurationEntry。
protected void | engineRefresh() 刷新并重新加载 Configuration。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ConfigurationSpi

public ConfigurationSpi()
方法详细信息

engineGetAppConfigurationEntry

protected abstract AppConfigurationEntry[] engineGetAppConfigurationEntry(String name)
获取指定 name 的 AppConfigurationEntry。

参数：
name - 用于索引 Configuration 的名称。
返回：
指定 name 的 AppConfigurationEntry 数组；如果不存在指定 name 的条目，则返回 null。

engineRefresh

protected void engineRefresh()
刷新并重新加载 Configuration。

此方法导致此 Configuration 对象以与实现有关的方式刷新/重新加载其内容。例如，如果此 Configuration 对象将其条目存储在文件中，则调用 refresh 可能导致重新读取该文件。

此方法的默认实现不执行任何操作。如果实现支持刷新操作，则应该重写此方法。

抛出：
SecurityException - 如果调用者没有刷新其 Configuration 的权限。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CredentialException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 CredentialException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.CredentialException
所有已实现的接口：
Serializable
直接已知子类：
CredentialExpiredException, CredentialNotFoundException
public class CredentialException
extends LoginException

一般证书异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
CredentialException()
构造不带详细消息的 CredentialException。
CredentialException(String msg)
构造带指定详细消息的 CredentialException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CredentialException

public CredentialException()
构造不带详细消息的 CredentialException。详细消息是描述此特定异常的 String。

CredentialException

public CredentialException(String msg)
构造带指定详细消息的 CredentialException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CredentialExpiredException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 CredentialExpiredException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.CredentialException
                        继承者  javax.security.auth.login.CredentialExpiredException
所有已实现的接口：
Serializable
public class CredentialExpiredException
extends CredentialException

当 Credential 到期时抛出此异常。

当 LoginModule 确定 Credential 已到期时抛出此异常。例如，用其 login 方法验证用户的 LoginModule 可以确定用户的密码（虽然输入地正确）已经过期。在这种情况下，LoginModule 抛出此异常来通知应用程序。然后应用程序采取适当的步骤帮助用户更新密码。

另请参见：
序列化表格

构造方法摘要
CredentialExpiredException()
构造不带详细消息的 CredentialExpiredException。
CredentialExpiredException(String msg)
构造带指定详细消息的 CredentialExpiredException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CredentialExpiredException

public CredentialExpiredException()
构造不带详细消息的 CredentialExpiredException。详细消息是描述此特定异常的 String。

CredentialExpiredException

public CredentialExpiredException(String msg)
构造带指定详细消息的 CredentialExpiredException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CredentialNotFoundException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 CredentialNotFoundException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.CredentialException
                        继承者  javax.security.auth.login.CredentialNotFoundException
所有已实现的接口：
Serializable
public class CredentialNotFoundException
extends CredentialException

找不到证书时抛出此异常。

如果 LoginModule 不能找到执行验证所需的证书时，可能抛出此异常。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
CredentialNotFoundException()
构造不带详细消息的 CredentialNotFoundException。
CredentialNotFoundException(String msg)
构造带指定详细消息的 CredentialNotFoundException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CredentialNotFoundException

public CredentialNotFoundException()
构造不带详细消息的 CredentialNotFoundException。详细消息是描述此特定异常的 String。

CredentialNotFoundException

public CredentialNotFoundException(String msg)
构造带指定详细消息的 CredentialNotFoundException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FailedLoginException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 FailedLoginException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
                    继承者  javax.security.auth.login.FailedLoginException
所有已实现的接口：
Serializable
public class FailedLoginException
extends LoginException

当用户验证失败时抛出此异常。

如果验证失败，则 LoginModules 抛出此异常。例如，如果用户输入不正确的密码时，LoginModule 抛出此异常。

另请参见：
序列化表格

构造方法摘要
FailedLoginException()
构造不带详细消息的 FailedLoginException。
FailedLoginException(String msg)
构造带指定详细消息的 FailedLoginException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FailedLoginException

public FailedLoginException()
构造不带详细消息的 FailedLoginException。详细消息是描述此特定异常的 String。

FailedLoginException

public FailedLoginException(String msg)
构造带指定详细消息的 FailedLoginException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoginContext (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 LoginContext

java.lang.Object
    继承者  javax.security.auth.login.LoginContext

public class LoginContext
extends Object

LoginContext 类描述用于验证 Subjects 的基本方法和提供开发与底层验证技术无关的应用程序的方法。Configuration 指定将与特定应用程序一起使用的验证技术或 LoginModule。可以将不同的 LoginModules 插入到应用程序中而无需修改应用程序本身。

除了支持可插入 验证之外，此类还支持堆栈式 验证的概念。可将应用程序配置为使用多于一个的 LoginModule。例如，可以在应用程序上配置 Kerberos LoginModule 和智能卡 LoginModule。

典型的调用者使用名称 和 CallbackHandler 来实例化 LoginContext。LoginContext 使用名称 作为 Configuration 中的索引，以确定应该使用哪些 LoginModules，并确定为了使整个验证成功，哪些验证是必须成功的。把 CallbackHandler 被传递给底层 LoginModules，因此它们可以与用户通信和交互（例如，通过图形用户界面提示用户名和密码）。

一旦调用者已经实例化一个 LoginContext，则它会调用 login 方法对 Subject 进行验证。login 方法调用配置的模块来执行它们各自类型的验证（用户名/密码、智能卡 pin 码验证，等等）。注意，如果验证失败，则 LoginModules 不会尝试重新进行验证，也不会导致延迟。这类任务属于 LoginContext 调用者。

如果 login 方法返回而不是抛出一个异常，则整个验证就获得成功了。接着调用者可以通过调用 getSubject 方法来检索新验证的 Subject。与 Subject 关联的 Principals 和 Credentials 可以通过分别调用 Subject 的 getPrincipals、getPublicCredentials 和 getPrivateCredentials 方法来进行检索。

调用者可通过调用 logout 方法注销 Subject。与对待 login 方法类似，此 logout 方法对已配置的模块调用 logout 方法。

LoginContext 不应该用于对一个以上的 Subject 进行验证。单个 LoginContext 应该用于对每个不同的 Subject 进行验证。

以下文档适用于所有的 LoginContext 构造方法：

  1. Subject
    • 如果构造方法有一个 Subject 输入参数，则 LoginContext 使用调用者指定的 Subject 对象。

    • 如果调用者指定一个 null Subject，并且 null 值是允许的，则 LoginContext 将实例化一个新 Subject。

    • 如果构造方法没有 Subject 输入参数，则 LoginContext 将实例化一个新 Subject。

  2. Configuration
    • 如果构造方法有一个 Configuration 输入参数，并且调用者指定一个非 null Configuration，则 LoginContext 使用调用者指定的 Configuration。

      如果构造方法没有 Configuration 输入参数，或者调用者指定一个 null Configuration 对象，则构造方法使用以下调用来获得已安装的 Configuration：

            config = Configuration.getConfiguration();
      对于这两种情况，提供给构造方法的 name 参数被传递给 Configuration.getAppConfigurationEntry 方法。如果 Configuration 没有用于指定 name 的条目，那么 LoginContext 将使用名称 "other"（默认条目名称）调用 getAppConfigurationEntry。如果没有用于 "other" 的条目，则抛出 LoginException。

    • 当 LoginContext 使用已安装的 Configuration 时，调用者需要 createLoginContext.name 和 createLoginContext.other AuthPermissions（可能需要）。此外，LoginContext 将从 AccessController.doPrivileged 调用中调用已配置的模块，因此执行与安全有关的任务（例如连接到远端主机和更新 Subject）的模块将需要各自的权限，但是 LoginContext 的调用者不需要这些权限。

    • 当 LoginContext 使用调用者指定的 Configuration 时，调用者不需要任何 createLoginContext AuthPermission。LoginContext 为调用者保存 AccessControlContext，并且从该上下文限制的 AccessController.doPrivileged 调用中调用已配置的模块。这意味着调用者上下文（在创建 LoginContext 时存储的上下文）必须具有足够的权限去执行该模块可以执行的任何与安全有关的任务。

  3. CallbackHandler
    • 如果构造方法有一个 CallbackHandler 输入参数，则 LoginContext 将使用调用者指定的 CallbackHandler 对象。

    • 如果构造方法没有 CallbackHandler 输入参数，或者调用者指定了一个 null CallbackHandler 对象（并且允许使用 null 值），则 LoginContext 将查询 auth.login.defaultCallbackHandler 安全属性来查找默认处理程序实现的完全限定类名称。如果没有设置安全属性，则底层模块不会有一个用来与用户通信的 CallbackHandler。调用者因此假定已配置的模块具有对用户进行验证的替代方法。

    • 当 LoginContext 使用安装的 Configuration（而不是调用者指定的 Configuration，请参阅上文）时，此 LoginContext 必须在一个新 CallbackHandler 实现中包装任何调用者指定的或默认的 CallbackHandler 实现，CallbackHandler 实现的 handle 方法的实现在由调用者的当前 AccessControlContext 限制的 java.security.AccessController.doPrivileged 调用中调用指定 CallbackHandler 的 handle 方法。

注意，Security Properties（比如 auth.login.defaultCallbackHandler）可以通过 java.security.Security 类以编程的方式来进行设置，或者是在名为 <JAVA_HOME>/lib/security/java.security的 Java 安全属性文件中静态设置的。<JAVA_HOME> 是指java.home 系统属性的值并且指定安装 JRE 的目录）

另请参见：
Security, AuthPermission, Subject, CallbackHandler, Configuration, LoginModule

构造方法摘要
LoginContext(String name)
使用 name 实例化一个新 LoginContext 对象。
LoginContext(String name, CallbackHandler callbackHandler)
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject)
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。
方法摘要
Subject | getSubject() 返回已进行验证的 Subject。
void | login() 执行验证。
void | logout() 注销 Subject。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LoginContext

public LoginContext(String name)
             throws LoginException
使用 name 实例化一个新 LoginContext 对象。

参数：
name - 用作为 Configuration 中的索引的名称。
抛出：
LoginException - 如果调用者指定的 name 在 Configuration 中没有出现，并且不存在用于 "other" 的 Configuration 条目，或者设置了 auth.login.defaultCallbackHandler 安全属性，但是无法加载实现类。

SecurityException - 如果设置了 SecurityManager，但调用者没有 AuthPermission("createLoginContext.name") 权限，或者 name 的配置条目不存在，并且调用者没有 AuthPermission("createLoginContext.other") 权限。

LoginContext

public LoginContext(String name,
                    Subject subject)
             throws LoginException
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。

参数：
name - 用作为 Configuration 中的索引的名称。

subject - 要进行验证的 Subject。
抛出：
LoginException - 如果调用者指定的 name 在 Configuration 中没有出现，并且不存在用于 "other" 的 Configuration 条目，如果调用者指定的 subject 为 null，或者设置了 auth.login.defaultCallbackHandler 安全属性，但是不能加载实现类。

SecurityException - 如果设置了 SecurityManager 但调用者没有 AuthPermission("createLoginContext.name") 权限，或者 name 的配置条目不存在，并且调用者又没有 AuthPermission("createLoginContext.other") 权限。

LoginContext

public LoginContext(String name,
                    CallbackHandler callbackHandler)
             throws LoginException
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。

用作为 Configuration 中的索引的名称。

参数：
callbackHandler - LoginModules 用来与用户通信的 CallbackHandler 对象。
抛出：
LoginException - 如果调用者指定的 name 在 Configuration 中没有出现，并且不存在用于 "other" 的 Configuration 条目，或者调用者指定的 callbackHandler 为 null。

SecurityException - 如果设置了 SecurityManager 但调用者没有 AuthPermission("createLoginContext.name") 权限，或者 name 的配置条目不存在并且调用者又没有 AuthPermission("createLoginContext.other") 权限。

LoginContext

public LoginContext(String name,
                    Subject subject,
                    CallbackHandler callbackHandler)
             throws LoginException
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。

参数：
name - 用作为 Configuration 中的索引的名称。

subject - 要进行验证的 Subject。

callbackHandler - LoginModules 用来与用户通信的 CallbackHandler 对象。
抛出：
LoginException - 如果调用者指定的 name 在 Configuration 中没有出现，并且不存在用于 "other" 的 Configuration 条目，或调用者指定的 subject 为 null，或调用者指定的 callbackHandler 为 null。

SecurityException - 如果设置了 SecurityManager 但调用者没有 AuthPermission("createLoginContext.name") 权限，或者 name 的配置条目不存在并且调用者又没有 AuthPermission("createLoginContext.other") 权限。

LoginContext

public LoginContext(String name,
                    Subject subject,
                    CallbackHandler callbackHandler,
                    Configuration config)
             throws LoginException
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

参数：
name - 用作为调用者指定的 Configuration 中的索引的名称。

subject - 要进行验证的 Subject 或 null。

callbackHandler - LoginModules 用来与用户通信的 CallbackHandler 对象，或者为 null。

config - 列出将被调用来执行验证的登录模块的 Configuration，或者为 null。
抛出：
LoginException - 如果调用者指定的 name 在 Configuration 中没有出现，并且不存在用于 "other" 的 Configuration 条目。

SecurityException - 如果设置了 SecurityManager，config 为 null，且任一个调用者都没有 AuthPermission("createLoginContext.name") 权限，或者 name 的配置条目不存在，并且调用者又没有 AuthPermission("createLoginContext.other") 权限。
从以下版本开始：
1.5
方法详细信息

login

public void login()
           throws LoginException
执行验证。

此方法对为指定给 LoginContext 构造方法的 name 配置的每个 LoginModule 调用 login 方法，由登录 Configuration 确定。每个 LoginModule 执行各自类型的验证（用户名/密码、智能卡 pin 码验证，等等）。

此方法完成由两个阶段组成的验证过程，如果整个验证成功（相关的 REQUIRED、REQUISITE、SUFFICIENT 和 OPTIONAL LoginModules 获得成功），通过调用每个已配置的 LoginModule 的 commit 方法来完成验证过程；如果整个验证失败，通过调用每个配置的 LoginModule 的 abort 方法来完成验证过程。如果验证成功，每个成功的 LoginModule 的 commit 方法会将相关的 Principals 和 Credentials 与 Subject 联系起来。如果验证失败，则每个 LoginModule 的 abort 方法都移除/销毁任何以前存储的状态。

如果验证过程的 commit 阶段失败，则整个验证失败，且此方法对每个已配置的 LoginModule 调用 abort 方法。

如果因为某种原因导致 abort 阶段失败，此方法将传播在 login 阶段或 commit 阶段抛出的原始异常。在上述任何一种情况下，整个验证都将失败。

在多个 LoginModules 失败的情况下，此方法传播由第一个失败的 LoginModule 引起的异常。

注意，如果此方法进入 abort 阶段（login 或 commit 阶段失败），不管它们各自的 Configuration flag 参数如何，此方法都将调用为应用程序配置的所有 LoginModules。这实质上意味着在 abort 阶段忽略 Requisite 和 Sufficient 语义。这保证能发生正确的清除和状态恢复。

抛出：
LoginException - 如果验证失败。

logout

public void logout()
            throws LoginException
注销 Subject。

此方法对为此 LoginContext 配置的每个 LoginModule 调用 logout 方法。每个 LoginModule 执行各自的注销过程，包括移除/销毁 Subject 的 Principal 和 Credential 信息以及状态清除。

注意，不管 LoginModules 的 Configuration flag 参数如何，此方法都将调用为应用程序配置的所有 LoginModules。这实质上意味着忽略此方法的 Requisite 和 Sufficient 语义。这保证能发生正确的清除和状态恢复。

抛出：
LoginException - 如果注销失败。

getSubject

public Subject getSubject()
返回已进行验证的 Subject。

返回：
已进行验证的 Subject。如果调用者为此 LoginContext 的构造方法指定一个 Subject，则此方法将返回调用者指定的 Subject。如果没有指定 Subject 并且验证成功，则此方法将返回由此 LoginContext 实例化且用于验证的 Subject。如果没有指定 Subject，并且验证失败或没有试图进行验证，则此方法返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LoginException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.login
类 LoginException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.security.GeneralSecurityException
                继承者  javax.security.auth.login.LoginException
所有已实现的接口：
Serializable
直接已知子类：
AccountException, CredentialException, FailedLoginException
public class LoginException
extends GeneralSecurityException

此异常是基本的登录异常。

另请参见：
LoginContext, 序列化表格

构造方法摘要
LoginException()
构造不带详细消息的 LoginException。
LoginException(String msg)
构造带指定详细消息的 LoginException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LoginException

public LoginException()
构造不带详细消息的 LoginException。详细消息是描述此特定异常的 String。

LoginException

public LoginException(String msg)
构造带指定详细消息的 LoginException。详细消息是描述此特定异常的 String。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.auth.login (Java 2 Platform SE 6)

 javax.security.auth.login
接口
Configuration.Parameters
类
AppConfigurationEntry
AppConfigurationEntry.LoginModuleControlFlag
Configuration
ConfigurationSpi
LoginContext
异常
AccountException
AccountExpiredException
AccountLockedException
AccountNotFoundException
CredentialException
CredentialExpiredException
CredentialNotFoundException
FailedLoginException
LoginException


javax.security.auth.login (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.auth.login

此包提供可插入的验证框架。

请参见：
描述

接口摘要
Configuration.Parameters 此类表示 Configuration 参数的标记接口。

类摘要
AppConfigurationEntry | 此类表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。
AppConfigurationEntry.LoginModuleControlFlag | 此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。
Configuration | Configuration 对象负责指定应该将哪一个 LoginModule 用于某一特定应用程序，以及应该以什么样的顺序调用 LoginModule。
ConfigurationSpi | 此类为 Configuration 类定义服务提供者接口（SPI）。
LoginContext | LoginContext 类描述用于验证 Subjects 的基本方法和提供开发与底层验证技术无关的应用程序的方法。

异常摘要
AccountException | 一般的帐户异常。
AccountExpiredException | 当用户帐户到期时抛出此异常。
AccountLockedException | 帐户被锁定时抛出此异常。
AccountNotFoundException | 未找到帐户时抛出此异常。
CredentialException | 一般证书异常。
CredentialExpiredException | 当 Credential 到期时抛出此异常。
CredentialNotFoundException | 找不到证书时抛出此异常。
FailedLoginException | 当用户验证失败时抛出此异常。
LoginException | 此异常是基本的登录异常。

软件包 javax.security.auth.login 的描述

此包提供可插入的验证框架。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.auth.login 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.login 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.security.auth.login.AppConfigurationEntry
    • javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
    • javax.security.auth.login.Configuration
    • javax.security.auth.login.ConfigurationSpi
    • javax.security.auth.login.LoginContext
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.security.GeneralSecurityException
          • javax.security.auth.login.LoginException
            • javax.security.auth.login.AccountException
              • javax.security.auth.login.AccountExpiredException
              • javax.security.auth.login.AccountLockedException
              • javax.security.auth.login.AccountNotFoundException
            • javax.security.auth.login.CredentialException
              • javax.security.auth.login.CredentialExpiredException
              • javax.security.auth.login.CredentialNotFoundException
            • javax.security.auth.login.FailedLoginException

接口分层结构

  • javax.security.auth.login.Configuration.Parameters
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.auth.login 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.login
的使用

使用 javax.security.auth.login 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。

java.security 使用的 javax.security.auth.login 中的类
Configuration.Parameters
此类表示 Configuration 参数的标记接口。
LoginException
此异常是基本的登录异常。

javax.security.auth.login 使用的 javax.security.auth.login 中的类
AccountException
一般的帐户异常。
AppConfigurationEntry
此类表示为在 Configuration 类中的 getAppConfigurationEntry(String appName) 方法中指定的应用程序配置的单个 LoginModule 条目。
AppConfigurationEntry.LoginModuleControlFlag
此类表示 LoginModule 是否为 REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL。
Configuration
Configuration 对象负责指定应该将哪一个 LoginModule 用于某一特定应用程序，以及应该以什么样的顺序调用 LoginModule。
Configuration.Parameters
此类表示 Configuration 参数的标记接口。
CredentialException
一般证书异常。
LoginException
此异常是基本的登录异常。

javax.security.auth.spi 使用的 javax.security.auth.login 中的类
LoginException
此异常是基本的登录异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.AccountException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountException
的使用

使用 AccountException 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 AccountException 的使用

javax.security.auth.login 中 AccountException 的子类
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.AccountExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountExpiredException
的使用

没有 javax.security.auth.login.AccountExpiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.AccountLockedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountLockedException
的使用

没有 javax.security.auth.login.AccountLockedException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.AccountNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AccountNotFoundException
的使用

没有 javax.security.auth.login.AccountNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.AppConfigurationEntry 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AppConfigurationEntry
的使用

使用 AppConfigurationEntry 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 AppConfigurationEntry 的使用

返回 AppConfigurationEntry 的 javax.security.auth.login 中的方法
protected abstract AppConfigurationEntry[] | ConfigurationSpi.engineGetAppConfigurationEntry(String name) 获取指定 name 的 AppConfigurationEntry。
abstract AppConfigurationEntry[] | Configuration.getAppConfigurationEntry(String name) 获取此 Configuration 中指定 name 的 AppConfigurationEntry。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.AppConfigurationEntry.LoginModuleControlFlag
的使用

使用 AppConfigurationEntry.LoginModuleControlFlag 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 AppConfigurationEntry.LoginModuleControlFlag 的使用

声明为 AppConfigurationEntry.LoginModuleControlFlag 的 javax.security.auth.login 中的字段
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.OPTIONAL 可供选择的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.REQUIRED 所需的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.REQUISITE 必需的 LoginModule。
static AppConfigurationEntry.LoginModuleControlFlag | AppConfigurationEntry.LoginModuleControlFlag.SUFFICIENT 足够的 LoginModule。

返回 AppConfigurationEntry.LoginModuleControlFlag 的 javax.security.auth.login 中的方法
 AppConfigurationEntry.LoginModuleControlFlag AppConfigurationEntry.getControlFlag()
返回此 LoginModule 的 controlFlag（REQUIRED、REQUISITE、SUFFICIENT 或 OPTIONAL 中的任何一个）。

参数类型为 AppConfigurationEntry.LoginModuleControlFlag 的 javax.security.auth.login 中的构造方法
AppConfigurationEntry(String loginModuleName, AppConfigurationEntry.LoginModuleControlFlag controlFlag, Map<String,?> options)
此类的默认构造方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.Configuration 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.Configuration
的使用

使用 Configuration 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 Configuration 的使用

返回 Configuration 的 javax.security.auth.login 中的方法
static Configuration | Configuration.getConfiguration() 获取已安装的登录 Configuration。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, Provider provider) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, String provider) 返回指定类型的 Configuration 对象。

参数类型为 Configuration 的 javax.security.auth.login 中的方法
static void Configuration.setConfiguration(Configuration configuration)
设置登录 Configuration。

参数类型为 Configuration 的 javax.security.auth.login 中的构造方法
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.auth.login.Configuration.Parameters 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.login.Configuration.Parameters
的使用

使用 Configuration.Parameters 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。

java.security 中 Configuration.Parameters 的使用

实现 Configuration.Parameters 的 java.security 中的类
 class URIParameter
包含一个 URI 的参数，该 URI 指向用于 PolicySpi 或 ConfigurationSpi 实现的数据。

javax.security.auth.login 中 Configuration.Parameters 的使用

返回 Configuration.Parameters 的 javax.security.auth.login 中的方法
 Configuration.Parameters Configuration.getParameters()
返回 Configuration 参数。

参数类型为 Configuration.Parameters 的 javax.security.auth.login 中的方法
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, Provider provider) 返回指定类型的 Configuration 对象。
static Configuration | Configuration.getInstance(String type, Configuration.Parameters params, String provider) 返回指定类型的 Configuration 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.ConfigurationSpi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.ConfigurationSpi
的使用

没有 javax.security.auth.login.ConfigurationSpi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.CredentialException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.CredentialException
的使用

使用 CredentialException 的软件包
javax.security.auth.login 此包提供可插入的验证框架。

javax.security.auth.login 中 CredentialException 的使用

javax.security.auth.login 中 CredentialException 的子类
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.CredentialExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.CredentialExpiredException
的使用

没有 javax.security.auth.login.CredentialExpiredException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.CredentialNotFoundException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.CredentialNotFoundException
的使用

没有 javax.security.auth.login.CredentialNotFoundException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.LoginContext 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.LoginContext
的使用

没有 javax.security.auth.login.LoginContext 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.FailedLoginException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.FailedLoginException
的使用

没有 javax.security.auth.login.FailedLoginException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.login.LoginException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.login.LoginException
的使用

使用 LoginException 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。

java.security 中 LoginException 的使用

抛出 LoginException 的 java.security 中的方法
abstract void | AuthProvider.login(Subject subject, CallbackHandler handler) 登录到此 provider 中。
abstract void | AuthProvider.logout() 在此 provider 中注销。

javax.security.auth.login 中 LoginException 的使用

javax.security.auth.login 中 LoginException 的子类
class | AccountException 一般的帐户异常。
class | AccountExpiredException 当用户帐户到期时抛出此异常。
class | AccountLockedException 帐户被锁定时抛出此异常。
class | AccountNotFoundException 未找到帐户时抛出此异常。
class | CredentialException 一般证书异常。
class | CredentialExpiredException 当 Credential 到期时抛出此异常。
class | CredentialNotFoundException 找不到证书时抛出此异常。
class | FailedLoginException 当用户验证失败时抛出此异常。

抛出 LoginException 的 javax.security.auth.login 中的方法
void | LoginContext.login() 执行验证。
void | LoginContext.logout() 注销 Subject。

抛出 LoginException 的 javax.security.auth.login 中的构造方法
LoginContext(String name)
使用 name 实例化一个新 LoginContext 对象。
LoginContext(String name, CallbackHandler callbackHandler)
使用 name 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject)
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

javax.security.auth.spi 中 LoginException 的使用

抛出 LoginException 的 javax.security.auth.spi 中的方法
boolean | LoginModule.abort() 中止验证过程的方法（阶段 2）。
boolean | LoginModule.commit() 提交验证过程的方法（阶段 2）。
boolean | LoginModule.login() 对 Subject 进行验证的方法（阶段 1）。
boolean | LoginModule.logout() 注销 Subject 的方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


LoginModule (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.spi
接口 LoginModule

public interface LoginModule

LoginModule 描述由验证技术提供者实现的接口。LoginModule 插入到应用程序中以提供特定类型的验证。

当应用程序写入 LoginContext API 时，验证技术提供者将实现 LoginModule 接口。Configuration 指定将与特定登录应用程序一起使用的 LoginModule(s)。因此可以将不同的 LoginModule 插入到应用程序中，而无需修改应用程序本身。

LoginContext 负责读取 Configuration 和实例化适当的 LoginModule。每个 LoginModule 都是使用 Subject、CallbackHandler、共享的 LoginModule 状态和特定于 LoginModule 的选项来实例化的。 Subject 表示当前正进行验证的 Subject，如果验证成功，则使用相关的 Credential 更新它。LoginModule 使用 CallbackHandler 与用户进行通信。例如，CallbackHandler 可以用于提示要求用户名和密码。注意，CallbackHandler 可以为 null。确实需要一个 CallbackHandler 来对 Subject 进行验证的 LoginModule 可以抛出 LoginException。LoginModule 可以有选择地使用共享状态来共享它们之间的信息或数据。

特定于 LoginModule 的选项表示由管理员或用户在 Configuration 中为此 LoginModule 配置的选项。这些选项由 LoginModule 自身定义，并在其中控制其行为。例如，LoginModule 可以定义支持调试/测试功能的选项。这些选项是使用键-值语法定义的，例如 debug=true。LoginModule 以 Map 形式存储这些选项，因此可以使用键来获取这些值。注意，对 LoginModule 选择定义的选项个数是没有限制的。

调用应用程序将验证过程视为单个操作。但是，LoginModule 中的验证过程分两个不同的阶段进行。在第一个阶段，LoginModule 的 login 方法由 LoginContext 的 login 方法调用。LoginModule 的 login 方法执行实际的验证（例如，提示并验证密码），并将验证状态作为私有状态信息保存。一旦完成上述操作，LoginModule 的 login 将返回 true（如果成功）或 false（如果应该忽略它），或抛出 LoginException 来指示失败。在失败的情况下，LoginModule 不必再尝试进行验证或者引入延迟。由应用程序完成这类任务。如果应用程序试图重新尝试验证，将会再次调用 LoginModule 的 login 方法。

在第二个阶段，如果 LoginContext 的整个验证成功（相关的 REQUIRED、REQUISITE、SUFFICIENT 和 OPTIONAL LoginModule 成功），则调用 LoginModule 的 commit 方法。LoginModule 的 commit 方法检查其私有保存状态，以查看自己的验证是否成功。如果整个 LoginContext 验证成功，并且 LoginModule 自己的验证也获得成功，则 commit 方法会将相关的 Principal（已进行验证的身份）和 Credential（验证数据，如加密密钥）与位于 LoginModule 中的 Subject 联系在一起。

如果 LoginContext 的整个验证失败（相关的 REQUIRED、REQUISITE、SUFFICIENT 和 OPTIONAL LoginModule 没有成功），则调用每个 LoginModule 的 abort 方法。在这种情况下，LoginModule 移除/销毁原先保存的任何验证状态。

注销 Subject 只涉及一个阶段。LoginContext 调用 LoginModule 的 logout 方法。然后 LoginModule 的 logout 方法执行注销过程，例如从 Subject 中移除 Principal 或 Credential，或者记录会话信息。

LoginModule 实现必须有一个无参数的构造方法。这允许加载 LoginModule 的类对其进行实例化。

另请参见：
LoginContext, Configuration

方法摘要
boolean | abort() 中止验证过程的方法（阶段 2）。
boolean | commit() 提交验证过程的方法（阶段 2）。
void | initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options) 初始化此 LoginModule。
boolean | login() 对 Subject 进行验证的方法（阶段 1）。
boolean | logout() 注销 Subject 的方法。

方法详细信息

initialize

void initialize(Subject subject,
                CallbackHandler callbackHandler,
                Map<String,?> sharedState,
                Map<String,?> options)
初始化此 LoginModule。

在此 LoginModule 已经实例化后，由 LoginContext 调用此方法。此方法的目的是使用相关的信息初始化此 LoginModule。如果此 LoginModule 不理解存储在 sharedState 或 options 参数中的任何数据，则可以忽略它们。

参数：
subject - 要进行验证的 Subject。

callbackHandler - 用来与最终用户通信的 CallbackHandler（例如，提示要求用户名和密码）。

sharedState - 与其他已配置的 LoginModule 共享的状态。

options - 在登录 Configuration 中为此特定的 LoginModule 指定的选项。

login

boolean login()
              throws LoginException
对 Subject 进行验证的方法（阶段 1）。

此方法的实现对 Subject 进行验证。例如，它可以向 Subject 提示一些信息（比如用户名和密码），然后试图验证该密码。此方法将验证尝试的结果作为私有状态保存在 LoginModule 中。

返回：
如果验证成功，则返回 true；如果应该忽略此 LoginModule，则返回 false。
抛出：
LoginException - 如果验证失败

commit

boolean commit()
               throws LoginException
提交验证过程的方法（阶段 2）。

如果 LoginContext 的整个验证成功（相关的 REQUIRED、REQUISITE、SUFFICIENT 和 OPTIONAL LoginModule 成功），则调用此方法。

如果此 LoginModule 自己的验证尝试成功（通过获取 login 方法保存的私有状态检查），则此方法会将相关的 Principal 和 Credential 与位于 LoginModule 中的 Subject 联系在一起。如果此 LoginModule 自己的验证尝试失败，则此方法将移除/销毁原先保存的任何状态。

返回：
如果此方法成功，则返回 true；如果应该忽略此 LoginModule，则返回 false。
抛出：
LoginException - 如果提交失败。

abort

boolean abort()
              throws LoginException
中止验证过程的方法（阶段 2）。

如果 LoginContext 的整个验证失败（相关的 REQUIRED、REQUISITE、SUFFICIENT 和 OPTIONAL LoginModule 没有成功），则调用此方法。

如果此 LoginModule 自己的验证尝试成功（通过获取 login 方法保存的私有状态检查），则此方法将清除任何原先保存的状态。

返回：
如果此方法成功，则返回 true；如果应该忽略此 LoginModule，则返回 false。
抛出：
LoginException - 如果中止失败

logout

boolean logout()
               throws LoginException
注销 Subject 的方法。

此方法的实现可以移除/销毁 Subject 的 Principal 和 Credential。

返回：
如果此方法成功，则返回 true；如果应该忽略此 LoginModule，则返回 false。
抛出：
LoginException - 如果注销失败
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.auth.spi (Java 2 Platform SE 6)

 javax.security.auth.spi
接口
LoginModule


javax.security.auth.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.auth.spi

此包提供用于实现可插入验证模块的接口。

请参见：
描述

接口摘要
LoginModule LoginModule 描述由验证技术提供者实现的接口。

软件包 javax.security.auth.spi 的描述

此包提供用于实现可插入验证模块的接口。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.auth.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.spi 的分层结构

软件包分层结构：
所有软件包

接口分层结构

  • javax.security.auth.spi.LoginModule
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.auth.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.spi
的使用

没有 javax.security.auth.spi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.auth.spi.LoginModule 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.spi.LoginModule
的使用

没有 javax.security.auth.spi.LoginModule 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


X500Principal (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.x500
类 X500Principal

java.lang.Object
    继承者  javax.security.auth.x500.X500Principal
所有已实现的接口：
Serializable, Principal
public final class X500Principal
extends Object
implements Principal, Serializable

此类表示一个 X.500 Principal。X500Principal 由标识名（例如，"CN=Duke, OU=JavaSoft, O=Sun Microsystems, C=US"）表示。

可以通过使用标识名的字符串表示形式或通过使用标识名的 ASN.1 DER 编码的字节表示形式对此类进行实例化。RFC 2253 中定义了标识名的字符串表示形式的当前规范。但是此类接受 RFC 2253 和 RFC 1779 的字符串格式，也识别属性类别关键字，该关键字的 OID（对象标识符）是在 RFC 2459 中定义的。

此 X500Principal 的字符串表示形式可以通过调用 getName 方法获得。

注意，X509Certificate 的 getSubjectX500Principal 和 getIssuerX500Principal 方法返回表示证书的发行者和主体字段的 X500Principals。

从以下版本开始：
1.4
另请参见：
X509Certificate, 序列化表格

字段摘要
static String | CANONICAL 标识名的规范化字符串格式。
static String | RFC1779 标识名的 RFC 1779 字符串格式。
static String | RFC2253 标识名的 RFC 2253 字符串格式。
构造方法摘要
X500Principal(byte[] name)
根据 ASN.1 DER 编码格式的标识名创建 X500Principal。
X500Principal(InputStream is)
根据包含 ASN.1 DER 编码格式的标识名的 InputStream 创建 X500Principal。
X500Principal(String name)
根据 X.500 标识名（例："CN=Duke、 OU=JavaSoft、 O=Sun Microsystems、 C=US"）的字符串表示形式创建 X500Principal。
X500Principal(String name, Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。
方法摘要
boolean | equals(Object o) 比较指定的 Object 与此 X500Principal 的相等性。
byte[] | getEncoded() 返回 ASN.1 DER 编码形式的标识名。
String | getName() 返回使用 RFC 2253 中所定义格式的 X.500 标识名的字符串表示形式。
String | getName(String format) 返回使用指定格式的 X.500 标识名的字符串表示形式。
String | getName(String format, Map<String,String> oidMap) 返回使用指定格式的 X.500 标识名的字符串表示形式。
int | hashCode() 返回此 X500Principal 的哈希码。
String | toString() 返回此 X500Principal 的用户友好的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

RFC1779

public static final String RFC1779
标识名的 RFC 1779 字符串格式。

另请参见：
常量字段值

RFC2253

public static final String RFC2253
标识名的 RFC 2253 字符串格式。

另请参见：
常量字段值

CANONICAL

public static final String CANONICAL
标识名的规范化字符串格式。

另请参见：
常量字段值
构造方法详细信息

X500Principal

public X500Principal(String name)
根据 X.500 标识名（例："CN=Duke、 OU=JavaSoft、 O=Sun Microsystems、 C=US"）的字符串表示形式创建 X500Principal。 标识名必须使用 RFC 1779 或 RFC 2253（任何一种格式都是可接受的）中定义的语法指定。

此构造方法识别在 RFC 1779 和 RFC 2253（列出在 getName(String format) 中）中定义的属性类别关键字，以及 T、DNQ 或 DNQUALIFIER、SURNAME、GIVENNAME、INITIALS、GENERATION、EMAILADDRESS 和 SERIALNUMBER 关键字（它们的 OID 定义在 RFC 2459 及其后续文档中）。其他任何属性类型都必须指定为 OID。

参数：
name - RFC 1779 或 RFC 2253 格式的 X.500 标识名
抛出：
NullPointerException - 如果 name 为 null
IllegalArgumentException - 如果错误地指定了 name

X500Principal

public X500Principal(String name,
                     Map<String,String> keywordMap)
根据 X.500 标识名（例：“CN=Duke、OU=JavaSoft、O=Sun Microsystems、C=US”）的字符串表示形式创建 X500Principal。 标识名必须使用 RFC 1779 或 RFC 2253（任何一种格式都是可接受的）中定义的语法指定。

此构造方法识别 X500Principal(String) 中指定的属性类型关键字，也识别在 keywordMap 参数列出的其他关键字。keywordMap 中的关键字项优先于 X500Principal(String) 所识别的默认关键字。关键字必须全部用大写指定，否则它们将被忽略。忽略错误地指定的关键字；但是，如果该名称中的关键字映射到错误地指定的 OID，则抛出 IllegalArgumentException。允许两个不同的关键字映射到同一个 OID。

参数：
name - RFC 1779 或 RFC 2253 格式的 X.500 标识名
keywordMap - 属性类型关键字映射，其中每个关键字是一个映射到 String 形式的相应对象标识符的关键字 String（由句点分隔的非负整数序列）。映射可以为空但不能为 null。
抛出：
NullPointerException - 如果 name 或 keywordMap 为 null
IllegalArgumentException - 如果错误地指定了 name 或者 name 中的关键字映射到没有以正确形式存在的 OID
从以下版本开始：
1.6

X500Principal

public X500Principal(byte[] name)
根据 ASN.1 DER 编码格式的标识名创建 X500Principal。此结构的 ASN.1 表示如下所示。

 Name ::= CHOICE {
   RDNSequence }

 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName

 RelativeDistinguishedName ::=
   SET SIZE (1 .. MAX) OF AttributeTypeAndValue

 AttributeTypeAndValue ::= SEQUENCE {
   type     AttributeType,
   value    AttributeValue }

 AttributeType ::= OBJECT IDENTIFIER

 AttributeValue ::= ANY DEFINED BY AttributeType
 ....
 DirectoryString ::= CHOICE {
       teletexString           TeletexString (SIZE (1..MAX)),
       printableString         PrintableString (SIZE (1..MAX)),
       universalString         UniversalString (SIZE (1..MAX)),
       utf8String              UTF8String (SIZE (1.. MAX)),
       bmpString               BMPString (SIZE (1..MAX)) }

参数：
name - 包含 ASN.1 DER 编码格式的标识名的字节数组
抛出：
IllegalArgumentException - 如果出现编码错误（不正确的 DN 格式）

X500Principal

public X500Principal(InputStream is)
根据包含 ASN.1 DER 编码格式的标识名的 InputStream 创建 X500Principal。X500Principal(byte[] name) 的文档中提供了此结构的 ASN.1 表示法。

输入流的读取位置位于已编码标识名后的下一个可用字节处。

参数：
is - 包含 ASN.1 DER 编码格式的标识名的 InputStream
抛出：
NullPointerException - 如果 InputStream 为 null
IllegalArgumentException - 如果出现编码错误（不正确的 DN 格式）
方法详细信息

getName

public String getName()
返回使用 RFC 2253 中所定义格式的 X.500 标识名的字符串表示形式。

此方法等效于调用 getName(X500Principal.RFC2253)。

指定者：
接口 Principal 中的 getName
返回：
此 X500Principal 的标识名

getName

public String getName(String format)
返回使用指定格式的 X.500 标识名的字符串表示形式。该格式的有效值是 "RFC1779"、"RFC2253" 和 "CANONICAL"（不区分大小写）。

如果将格式指定为 "RFC1779"，则此方法指定 RFC 1779（CN、L、ST、O、OU、C 和 STREET）中定义的属性类型关键字。其他任何属性类型都被指定为 OID。

如果将格式指定为 "RFC2253"，则此方法指定 RFC 2253（CN、L、ST、O、OU、C、STREET、DC 和 UID）中定义的属性类型关键字。其他任何属性类型都被指定为 OID。在进行严格的读取时，RFC 2253 只指定 UTF-8 字符串表示形式。此方法返回的 String 是通过解码此 UTF-8 表示形式得到的 Unicode 字符串。

如果将格式指定为 "CANONICAL"，则此方法返回遵循 RFC 2253 的字符串表示形式，该表示形式具有如下的附加规范要求：

  1. 从编码为点号分隔的十进制 OID 的属性类型中移除前导零。
  2. 类型 PrintableString 和 UTF8String 的 DirectoryString 属性值不是以十六进制形式输出的
  3. 除了类型 PrintableString 和 UTF8String 以外的其他类型的 DirectoryString 属性值是以十六进制形式输出的
  4. 从非十六进制属性值（除非该值完全由空白字符组成）中移除前导和尾部空白字符
  5. 一个或多个空白字符的内部子字符串被转换成非十六进制属性值中的单个空格。
  6. 包括一个以上的 Attribute Value Assertion (AVA) 的相对标识名是按如下顺序输出的：包含标准关键字的 AVA 的字母排序，后跟包含 OID 关键字的 AVA 的数字排序
  7. 属性值中的唯一被转义字符是 RFC 2253 的 2.4 小节中声明必须被转义的那些字符（使用正斜杠字符将它们转义）。
  8. 可以使用 String.toUpperCase(Locale.US) 将整个名称转换为大写的。
  9. 可以使用 String.toLowerCase(Locale.US) 将整个名称转换为小写的。
  10. 最后使用标准化形式 KD 将名称标准化，Unicode Standard 和 UAX #15 中描述了该形式

其他标准格式可能在以后引入。

参数：
format - 要使用的格式
返回：
使用特定格式的此 X500Principal 的字符串表示形式
抛出：
IllegalArgumentException - 如果指定格式无效或者为 null

getName

public String getName(String format,
                      Map<String,String> oidMap)
返回使用指定格式的 X.500 标识名的字符串表示形式。该格式的有效值有 "RFC1779" 和 "RFC2253"（不区分大小写）。不允许 "CANONICAL" 并会抛出 IllegalArgumentException。

此方法返回使用 getName(String) 中指定格式的 String，并发出 oidMap 中列出的 OID 的其他属性类型关键字。oidMap 中的 OID 项优先于 getName(String) 所识别的默认 OID。忽略错误地指定的 OID；但是，如果该名称中的 OID 映射到错误地指定的关键字，则抛出 IllegalArgumentException。

其他标准格式可能在以后引入。

警告：其他实现可能无法识别其他属性类型关键字；因此，如果不确定其他实现是否识别这些关键字，请不要使用此方法。

参数：
format - 要使用的格式
oidMap - OID 映射，其中每个关键字是一个 String 形式的对象标识符（由句点分隔的非负整数序列），它映射到相应的属性类型关键字 String。映射可以为空但不能为 null。
返回：
使用指定格式的此 X500Principal 的字符串表示形式
抛出：
IllegalArgumentException - 如果指定格式无效、为 null 或者名称的 OID 映射到错误地指定的关键字
NullPointerException - 如果 oidMap 为 null
从以下版本开始：
1.6

getEncoded

public byte[] getEncoded()
返回 ASN.1 DER 编码形式的标识名。X500Principal(byte[] name) 的文档中提供了此结构的 ASN.1 表示法。

注意，返回的字节数组被复制，以防止后续修改。

返回：
包含 ASN.1 DER 编码格式的标识名的字节数组

toString

public String toString()
返回此 X500Principal 的用户友好的字符串表示形式。

指定者：
接口 Principal 中的 toString
覆盖：
类 Object 中的 toString
返回：
此 X500Principal 的字符串表示形式

equals

public boolean equals(Object o)
比较指定的 Object 与此 X500Principal 的相等性。

需要特别说明的是，如果 Object o 是一个 X500Principal，并且此对象和 o 二者的规范字符串表示形式（通过 getName(X500Principal.CANONICAL) 方法获得）是相等的，此方法返回 true。

此实现与 RFC 2459 的要求是兼容的。

指定者：
接口 Principal 中的 equals
覆盖：
类 Object 中的 equals
参数：
o - 将与此 X500Principal 进行相等性比较的对象。
返回：
如果指定的 Object 等于此 X500Principal，则返回 true;否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回此 X500Principal 的哈希码。

哈希码是通过以下方式计算的：getName(X500Principal.CANONICAL).hashCode()

指定者：
接口 Principal 中的 hashCode
覆盖：
类 Object 中的 hashCode
返回：
此 X500Principal 的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


X500PrivateCredential (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.auth.x500
类 X500PrivateCredential

java.lang.Object
    继承者  javax.security.auth.x500.X500PrivateCredential
所有已实现的接口：
Destroyable
public final class X500PrivateCredential
extends Object
implements Destroyable

此类表示一个 X500PrivateCredential。它将 X.509 证书、相应的私钥和用于引用 KeyStore 中的确切密钥对的 KeyStore 别名联系在一起。这允许在主体中查找 X.500 主体的私有证书。

构造方法摘要
X500PrivateCredential(X509Certificate cert, PrivateKey key)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
X500PrivateCredential(X509Certificate cert, PrivateKey key, String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。
方法摘要
void | destroy() 清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。
String | getAlias() 返回 KeyStore 别名。
X509Certificate | getCertificate() 返回 X.509 证书。
PrivateKey | getPrivateKey() 返回 PrivateKey。
boolean | isDestroyed() 确定是否已清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

X500PrivateCredential

public X500PrivateCredential(X509Certificate cert,
                             PrivateKey key)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

参数：
cert - X509Certificate
key - 证书的 PrivateKey
抛出：
IllegalArgumentException - 如果 cert 或 key 为 null

X500PrivateCredential

public X500PrivateCredential(X509Certificate cert,
                             PrivateKey key,
                             String alias)
创建将 X.509 证书、私钥和 KeyStore 别名联系在一起的 X500PrivateCredential。

参数：
cert - X509Certificate
key - 证书的 PrivateKey
alias - KeyStore 别名
抛出：
IllegalArgumentException - 如果 cert、key 或 alias 为 null
方法详细信息

getCertificate

public X509Certificate getCertificate()
返回 X.509 证书。

返回：
X509Certificate

getPrivateKey

public PrivateKey getPrivateKey()
返回 PrivateKey。

返回：
PrivateKey

getAlias

public String getAlias()
返回 KeyStore 别名。

返回：
KeyStore 别名

destroy

public void destroy()
清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。

指定者：
接口 Destroyable 中的 destroy

isDestroyed

public boolean isDestroyed()
确定是否已清除对此对象中的 X.509 证书、私钥和 KeyStore 别名的引用。

指定者：
接口 Destroyable 中的 isDestroyed
返回：
如果 X509Certificate 和 PrivateKey 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.auth.x500 (Java 2 Platform SE 6)

 javax.security.auth.x500
类
X500Principal
X500PrivateCredential


javax.security.auth.x500 (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.auth.x500

此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

请参见：
描述

类摘要
X500Principal | 此类表示一个 X.500 Principal。
X500PrivateCredential | 此类表示一个 X500PrivateCredential。

软件包 javax.security.auth.x500 的描述

此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

从以下版本开始：
JDK1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.auth.x500 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.x500 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.security.auth.x500.X500Principal (implements java.security.Principal, java.io.Serializable)
    • javax.security.auth.x500.X500PrivateCredential (implements javax.security.auth.Destroyable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.auth.x500 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.auth.x500
的使用

使用 javax.security.auth.x500 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 使用的 javax.security.auth.x500 中的类
X500Principal
此类表示一个 X.500 Principal。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.x500.X500PrivateCredential 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.x500.X500PrivateCredential
的使用

没有 javax.security.auth.x500.X500PrivateCredential 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.x500.X500Principal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.x500.X500Principal
的使用

使用 X500Principal 的软件包
java.security.cert 提供用于解析和管理证书、证书撤消列表 (CRL) 和证书路径的类和接口。

java.security.cert 中 X500Principal 的使用

返回 X500Principal 的 java.security.cert 中的方法
X500Principal | TrustAnchor.getCA() 以 X500Principal 的形式返回最受信任的 CA 的名称。
X500Principal | X509CRLEntry.getCertificateIssuer() 获取此项所描述的 X509Certificate 的发布方。
X500Principal | X509CertSelector.getIssuer() 以 X500Principal 的形式返回 issuer 标准。
X500Principal | X509CRL.getIssuerX500Principal() 以 X500Principal 的形式返回 CRL 的发布方（发布方标识名）值。
X500Principal | X509Certificate.getIssuerX500Principal() 以 X500Principal 的形式返回证书的发布方（发布方标识名）值。
X500Principal | X509CertSelector.getSubject() 以 X500Principal 的形式返回 subject 标准。
X500Principal | X509Certificate.getSubjectX500Principal() 以 X500Principal 的形式返回证书的主体（主体标识名）值。

返回变量类型为 X500Principal 的类型的 java.security.cert 中的方法
 Collection<X500Principal> X509CRLSelector.getIssuers()
返回 issuerNames 标准。

参数类型为 X500Principal 的 java.security.cert 中的方法
void | X509CRLSelector.addIssuer(X500Principal issuer) 向 issuerNames 标准中添加名称。
void | X509CertSelector.setIssuer(X500Principal issuer) 设置 issuer 标准。
void | X509CertSelector.setSubject(X500Principal subject) 设置 subject 标准。

类型变量类型为 X500Principal 的 java.security.cert 中的方法参数
 void X509CRLSelector.setIssuers(Collection<X500Principal> issuers)
设置 issuerNames 标准。

参数类型为 X500Principal 的 java.security.cert 中的构造方法
TrustAnchor(X500Principal caPrincipal, PublicKey pubKey, byte[] nameConstraints)
创建一个 TrustAnchor 实例，其中以 X500Principal 和公钥的形式指定最受信任的 CA。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.DestroyFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.DestroyFailedException
的使用

使用 DestroyFailedException 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

java.security 中 DestroyFailedException 的使用

抛出 DestroyFailedException 的 java.security 中的方法
 void KeyStore.PasswordProtection.destroy()
清除密码。

javax.security.auth 中 DestroyFailedException 的使用

抛出 DestroyFailedException 的 javax.security.auth 中的方法
 void Destroyable.destroy()
销毁此 Object。

javax.security.auth.kerberos 中 DestroyFailedException 的使用

抛出 DestroyFailedException 的 javax.security.auth.kerberos 中的方法
void | KerberosKey.destroy() 销毁此密钥。
void | KerberosTicket.destroy() 销毁票据和存储在其中的敏感信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.auth.Destroyable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.Destroyable
的使用

使用 Destroyable 的软件包
java.security | 为安全框架提供类和接口。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。
javax.security.auth.x500 | 此包包含应该用来在 Subject 中存储 X500 Principal 和 X500 Private Crendentials 的类。

java.security 中 Destroyable 的使用

实现 Destroyable 的 java.security 中的类
static class KeyStore.PasswordProtection
ProtectionParameter 的一个基于密码的实现。

javax.security.auth.kerberos 中 Destroyable 的使用

实现 Destroyable 的 javax.security.auth.kerberos 中的类
class | KerberosKey 此类为 Kerberos 主体封装一个长期秘密密钥。
class | KerberosTicket 此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。

javax.security.auth.x500 中 Destroyable 的使用

实现 Destroyable 的 javax.security.auth.x500 中的类
 class X500PrivateCredential
此类表示一个 X500PrivateCredential。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.Policy 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.Policy
的使用

使用 Policy 的软件包
javax.security.auth 此包提供用于进行验证和授权的框架。

javax.security.auth 中 Policy 的使用

返回 Policy 的 javax.security.auth 中的方法
static Policy Policy.getPolicy()
已过时。 返回安装的 Policy 对象。

参数类型为 Policy 的 javax.security.auth 中的方法
static void Policy.setPolicy(Policy policy)
已过时。 设置系统级 Policy 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.PrivateCredentialPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.PrivateCredentialPermission
的使用

没有 javax.security.auth.PrivateCredentialPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.RefreshFailedException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.RefreshFailedException
的使用

使用 RefreshFailedException 的软件包
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.kerberos | 此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth 中 RefreshFailedException 的使用

抛出 RefreshFailedException 的 javax.security.auth 中的方法
 void Refreshable.refresh()
更新或延长此 Object 的有效期。

javax.security.auth.kerberos 中 RefreshFailedException 的使用

抛出 RefreshFailedException 的 javax.security.auth.kerberos 中的方法
 void KerberosTicket.refresh()
延长此票据的有效期。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.auth.Refreshable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.auth.Refreshable
的使用

使用 Refreshable 的软件包
javax.security.auth.kerberos 此包包含与 Kerberos 网络验证协议相关的实用工具类。

javax.security.auth.kerberos 中 Refreshable 的使用

实现 Refreshable 的 javax.security.auth.kerberos 中的类
 class KerberosTicket
此类封装了 Kerberos 票据和从客户端的视点所观察到的有关信息。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.Subject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.Subject
的使用

使用 Subject 的软件包
java.security | 为安全框架提供类和接口。
javax.management.remote | 对 JMX MBean 服务器进行远程访问使用的接口。
javax.management.remote.rmi | RMI 连接器是供 JMX Remote API 使用的一种连接器，后者使用 RMI 将客户端请求传输到远程 MBean 服务器。
javax.security.auth | 此包提供用于进行验证和授权的框架。
javax.security.auth.login | 此包提供可插入的验证框架。
javax.security.auth.spi | 此包提供用于实现可插入验证模块的接口。

java.security 中 Subject 的使用

参数类型为 Subject 的 java.security 中的方法
abstract  void AuthProvider.login(Subject subject, CallbackHandler handler)
登录到此 provider 中。

javax.management.remote 中 Subject 的使用

返回 Subject 的 javax.management.remote 中的方法
 Subject JMXAuthenticator.authenticate(Object credentials)
用给定的客户端凭据验证 MBeanServerConnection 客户端。

参数类型为 Subject 的 javax.management.remote 中的方法
 MBeanServerConnection JMXConnector.getMBeanServerConnection(Subject delegationSubject)
返回 MBeanServerConnection 对象，它表示在其上执行代表提供的委托主题操作的远程 MBean 服务器。

javax.management.remote.rmi 中 Subject 的使用

参数类型为 Subject 的 javax.management.remote.rmi 中的方法
 void RMIConnection.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.addNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.addNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.addNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 Integer[] RMIConnection.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
处理 MBeanServerConnection.addNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 Integer[] RMIConnectionImpl.addNotificationListeners(ObjectName[] names, MarshalledObject[] filters, Subject[] delegationSubjects)
 Integer[] RMIConnectionImpl_Stub.addNotificationListeners(ObjectName[] $param_arrayOf_ObjectName_1, MarshalledObject[] $param_arrayOf_MarshalledObject_2, Subject[] $param_arrayOf_Subject_3)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName, Object[], String[]) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, MarshalledObject params, String[] signature, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, MarshalledObject $param_MarshalledObject_4, String[] $param_arrayOf_String_5, Subject $param_Subject_6)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, ObjectName loaderName, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, ObjectName $param_ObjectName_3, Subject $param_Subject_4)
 ObjectInstance RMIConnection.createMBean(String className, ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.createMBean(String, ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.createMBean(String className, ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.createMBean(String $param_String_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 Object RMIConnection.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
处理 MBeanServerConnection.getAttribute(ObjectName, String) 方法。
 Object RMIConnectionImpl.getAttribute(ObjectName name, String attribute, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.getAttribute(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 AttributeList RMIConnection.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
处理 MBeanServerConnection.getAttributes(ObjectName, String[]) 方法。
 AttributeList RMIConnectionImpl.getAttributes(ObjectName name, String[] attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.getAttributes(ObjectName $param_ObjectName_1, String[] $param_arrayOf_String_2, Subject $param_Subject_3)
 String RMIConnection.getDefaultDomain(Subject delegationSubject)
处理 MBeanServerConnection.getDefaultDomain() 方法。
 String RMIConnectionImpl.getDefaultDomain(Subject delegationSubject)
 String RMIConnectionImpl_Stub.getDefaultDomain(Subject $param_Subject_1)
 String[] RMIConnection.getDomains(Subject delegationSubject)
处理 MBeanServerConnection.getDomains() 方法。
 String[] RMIConnectionImpl.getDomains(Subject delegationSubject)
 String[] RMIConnectionImpl_Stub.getDomains(Subject $param_Subject_1)
 Integer RMIConnection.getMBeanCount(Subject delegationSubject)
处理 MBeanServerConnection.getMBeanCount() 方法。
 Integer RMIConnectionImpl.getMBeanCount(Subject delegationSubject)
 Integer RMIConnectionImpl_Stub.getMBeanCount(Subject $param_Subject_1)
 MBeanInfo RMIConnection.getMBeanInfo(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getMBeanInfo(ObjectName) 方法。
 MBeanInfo RMIConnectionImpl.getMBeanInfo(ObjectName name, Subject delegationSubject)
 MBeanInfo RMIConnectionImpl_Stub.getMBeanInfo(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 MBeanServerConnection RMIConnector.getMBeanServerConnection(Subject delegationSubject)
 ObjectInstance RMIConnection.getObjectInstance(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.getObjectInstance(ObjectName) 方法。
 ObjectInstance RMIConnectionImpl.getObjectInstance(ObjectName name, Subject delegationSubject)
 ObjectInstance RMIConnectionImpl_Stub.getObjectInstance(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
 Object RMIConnection.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
处理 MBeanServerConnection.invoke(ObjectName, String, Object[], String[]) 方法。
 Object RMIConnectionImpl.invoke(ObjectName name, String operationName, MarshalledObject params, String[] signature, Subject delegationSubject)
 Object RMIConnectionImpl_Stub.invoke(ObjectName $param_ObjectName_1, String $param_String_2, MarshalledObject $param_MarshalledObject_3, String[] $param_arrayOf_String_4, Subject $param_Subject_5)
 boolean RMIConnection.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
处理 MBeanServerConnection.isInstanceOf(ObjectName, String) 方法。
 boolean RMIConnectionImpl.isInstanceOf(ObjectName name, String className, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isInstanceOf(ObjectName $param_ObjectName_1, String $param_String_2, Subject $param_Subject_3)
 boolean RMIConnection.isRegistered(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.isRegistered(ObjectName) 方法。
 boolean RMIConnectionImpl.isRegistered(ObjectName name, Subject delegationSubject)
 boolean RMIConnectionImpl_Stub.isRegistered(ObjectName $param_ObjectName_1, Subject $param_Subject_2)
protected  RMIConnection RMIIIOPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 IIOP 导出的 RMI 对象的新客户端连接。
protected  RMIConnection RMIJRMPServerImpl.makeClient(String connectionId, Subject subject)
创建一个如同从 JRMP 导出的 RMI 对象的新的客户端连接。
protected abstract  RMIConnection RMIServerImpl.makeClient(String connectionId, Subject subject)
创建一个新的客户端连接。
 Set<ObjectInstance> RMIConnection.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryMBeans(ObjectName, QueryExp) 方法。
 Set<ObjectInstance> RMIConnectionImpl.queryMBeans(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryMBeans(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 Set<ObjectName> RMIConnection.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
处理 MBeanServerConnection.queryNames(ObjectName, QueryExp) 方法。
 Set<ObjectName> RMIConnectionImpl.queryNames(ObjectName name, MarshalledObject query, Subject delegationSubject)
 Set RMIConnectionImpl_Stub.queryNames(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, MarshalledObject filter, MarshalledObject handback, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, MarshalledObject $param_MarshalledObject_3, MarshalledObject $param_MarshalledObject_4, Subject $param_Subject_5)
 void RMIConnection.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
处理 MBeanServerConnection.removeNotificationListener(ObjectName, ObjectName) 方法。
 void RMIConnectionImpl.removeNotificationListener(ObjectName name, ObjectName listener, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListener(ObjectName $param_ObjectName_1, ObjectName $param_ObjectName_2, Subject $param_Subject_3)
 void RMIConnection.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
处理 removeNotificationListener(ObjectName, NotificationListener) 和 removeNotificationListener(ObjectName, NotificationListener, NotificationFilter, Object) 方法。
 void RMIConnectionImpl.removeNotificationListeners(ObjectName name, Integer[] listenerIDs, Subject delegationSubject)
 void RMIConnectionImpl_Stub.removeNotificationListeners(ObjectName $param_ObjectName_1, Integer[] $param_arrayOf_Integer_2, Subject $param_Subject_3)
 void RMIConnection.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
处理 MBeanServerConnection.setAttribute(ObjectName, Attribute) 方法。
 void RMIConnectionImpl.setAttribute(ObjectName name, MarshalledObject attribute, Subject delegationSubject)
 void RMIConnectionImpl_Stub.setAttribute(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 AttributeList RMIConnection.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
处理 MBeanServerConnection.setAttributes(ObjectName, AttributeList) 方法。
 AttributeList RMIConnectionImpl.setAttributes(ObjectName name, MarshalledObject attributes, Subject delegationSubject)
 AttributeList RMIConnectionImpl_Stub.setAttributes(ObjectName $param_ObjectName_1, MarshalledObject $param_MarshalledObject_2, Subject $param_Subject_3)
 void RMIConnection.unregisterMBean(ObjectName name, Subject delegationSubject)
处理 MBeanServerConnection.unregisterMBean(ObjectName) 方法。
 void RMIConnectionImpl.unregisterMBean(ObjectName name, Subject delegationSubject)
 void RMIConnectionImpl_Stub.unregisterMBean(ObjectName $param_ObjectName_1, Subject $param_Subject_2)

参数类型为 Subject 的 javax.management.remote.rmi 中的构造方法
RMIConnectionImpl(RMIServerImpl rmiServer, String connectionId, ClassLoader defaultClassLoader, Subject subject, Map<String,?> env)
构造新的 RMIConnection。

javax.security.auth 中 Subject 的使用

返回 Subject 的 javax.security.auth 中的方法
Subject | SubjectDomainCombiner.getSubject() 获取与此 SubjectDomainCombiner 关联的 Subject。
static Subject | Subject.getSubject(AccessControlContext acc) 获取与提供的 AccessControlContext 关联的 Subject。

参数类型为 Subject 的 javax.security.auth 中的方法
static
<T> T
Subject.doAs(Subject subject, PrivilegedAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAs(Subject subject, PrivilegedExceptionAction<T> action)
作为特定的 Subject 的功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
static
<T> T
Subject.doAsPrivileged(Subject subject, PrivilegedExceptionAction<T> action, AccessControlContext acc)
作为特定的 Subject 的特权功能。
abstract  PermissionCollection Policy.getPermissions(Subject subject, CodeSource cs)
已过时。 获取授予与指定的 CodeSource 关联的 Principals 的 Permissions。

参数类型为 Subject 的 javax.security.auth 中的构造方法
SubjectDomainCombiner(Subject subject)
将提供的 Subject 与此 SubjectDomainCombiner 关联。

javax.security.auth.login 中 Subject 的使用

返回 Subject 的 javax.security.auth.login 中的方法
 Subject LoginContext.getSubject()
返回已进行验证的 Subject。

参数类型为 Subject 的 javax.security.auth.login 中的构造方法
LoginContext(String name, Subject subject)
使用 name 和 Subject 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler)
使用 name、要进行验证的 Subject 和 CallbackHandler 对象实例化一个新 LoginContext 对象。
LoginContext(String name, Subject subject, CallbackHandler callbackHandler, Configuration config)
使用 name、要进行验证的 Subject、CallbackHandler 对象和登录 Configuration 来实例化一个新 LoginContext 对象。

javax.security.auth.spi 中 Subject 的使用

参数类型为 Subject 的 javax.security.auth.spi 中的方法
 void LoginModule.initialize(Subject subject, CallbackHandler callbackHandler, Map<String,?> sharedState, Map<String,?> options)
初始化此 LoginModule。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.SubjectDomainCombiner 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.SubjectDomainCombiner
的使用

没有 javax.security.auth.SubjectDomainCombiner 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.auth.AuthPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.auth.AuthPermission
的使用

没有 javax.security.auth.AuthPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


Certificate (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.cert
类 Certificate

java.lang.Object
    继承者  javax.security.cert.Certificate
直接已知子类：
X509Certificate
public abstract class Certificate
extends Object

管理各种身份证书的抽象类。身份证书是某个主体的保证，保证某个公钥是另一个主体的公钥。（主体表示一个实体，如个人用户、团体或公司。）

此类是具有不同格式但是很常用的证书的抽象。例如，不同的证书类型（如 X.509 和 PGP）共享通用的证书功能（如编码和验证）和某些信息类型（如公钥）。

虽然 X.509、PGP 和 SDSI 证书包含不同的信息集，并且它们以不同的方式存储和获取信息，但都可以通过扩展 Certificate 类来实现它们。

注：包 javax.security.cert 中的类用于与早期版本的 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）保持兼容。新的应用程序应该使用 java.security.cert 中的标准 Java SE 证书类。

从以下版本开始：
1.4
另请参见：
X509Certificate

构造方法摘要
Certificate()
方法摘要
boolean | equals(Object other) 比较此证书是否与指定对象相等。
abstract byte[] | getEncoded() 返回此证书的编码形式。
abstract PublicKey | getPublicKey() 从此证书中获取公钥。
int | hashCode() 返回根据此证书的编码形式得出的证书的哈希码值。
abstract String | toString() 返回此证书的字符串表示形式。
abstract void | verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Certificate

public Certificate()
方法详细信息

equals

public boolean equals(Object other)
比较此证书是否与指定对象相等。如果 other 对象是一个 Certificate 的实例，则获取其编码形式并且与此证书的编码形式进行比较。

覆盖：
类 Object 中的 equals
参数：
other - 要与此证书进行相等性测试的对象。
返回：
如果两个证书的编码形式匹配，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public int hashCode()
返回根据此证书的编码形式得出的证书的哈希码值。

覆盖：
类 Object 中的 hashCode
返回：
哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getEncoded

public abstract byte[] getEncoded()
                           throws CertificateEncodingException
返回此证书的编码形式。假定每种证书类型只有一种编码形式；例如 X.509 证书将以 ASN.1 DER 的形式进行编码。

返回：
此证书的编码形式
抛出：
CertificateEncodingException - 如果内部证书编码失败

verify

public abstract void verify(PublicKey key)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
验证是否已使用与指定公钥相对应的私钥签署了此证书。

参数：
key - 用于进行验证的 PublicKey。
抛出：
NoSuchAlgorithmException - 如果签名算法不受支持。
InvalidKeyException - 如果密钥不正确。
NoSuchProviderException - 如果没有默认的提供者。
SignatureException - 如果发生签名错误。
CertificateException - 如果出现编码错误。

verify

public abstract void verify(PublicKey key,
                            String sigProvider)
                     throws CertificateException,
                            NoSuchAlgorithmException,
                            InvalidKeyException,
                            NoSuchProviderException,
                            SignatureException
验证是否已使用与指定公钥相对应的私钥签署了此证书。此方法使用指定提供者所提供的签名验证引擎。

参数：
key - 用于进行验证的 PublicKey。
sigProvider - 签名提供者的名称。
抛出：
NoSuchAlgorithmException - 如果签名算法不受支持。
InvalidKeyException - 如果密钥不正确。
NoSuchProviderException - 如果提供者不正确。
SignatureException - 如果发生签名错误。
CertificateException - 如果出现编码错误。

toString

public abstract String toString()
返回此证书的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
此证书的字符串表示形式。

getPublicKey

public abstract PublicKey getPublicKey()
从此证书中获取公钥。

返回：
公钥。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CertificateEncodingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.cert
类 CertificateEncodingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.cert.CertificateException
                继承者  javax.security.cert.CertificateEncodingException
所有已实现的接口：
Serializable
public class CertificateEncodingException
extends CertificateException

证书编码异常。当试图对证书进行编码而出现错误时，就抛出此异常。

注：包 javax.security.cert 中的类用于与早期版本的 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）保持兼容。新的应用程序应该使用 java.security.cert 中的标准 Java SE 证书类。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
CertificateEncodingException()
构造不带详细消息的 CertificateEncodingException。
CertificateEncodingException(String message)
构造带指定详细信息的 CertificateEncodingException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateEncodingException

public CertificateEncodingException()
构造不带详细消息的 CertificateEncodingException。详细消息是描述此特定异常的字符串。

CertificateEncodingException

public CertificateEncodingException(String message)
构造带指定详细信息的 CertificateEncodingException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.cert
类 CertificateException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.cert.CertificateException
所有已实现的接口：
Serializable
直接已知子类：
CertificateEncodingException, CertificateExpiredException, CertificateNotYetValidException, CertificateParsingException
public class CertificateException
extends Exception

此异常指示各种证书问题之一。

注：包 javax.security.cert 中的类用于与早期版本的 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）保持兼容。新的应用程序应该使用 java.security.cert 中的标准 Java SE 证书类。

从以下版本开始：
1.4
另请参见：
Certificate, 序列化表格

构造方法摘要
CertificateException()
构造不带详细消息的 CertificateException。
CertificateException(String msg)
构造带给定详细消息的 CertificateException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateException

public CertificateException()
构造不带详细消息的 CertificateException。详细消息是描述此特定异常的字符串。

CertificateException

public CertificateException(String msg)
构造带给定详细消息的 CertificateException。详细消息是描述此特定异常的字符串。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateExpiredException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.cert
类 CertificateExpiredException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.cert.CertificateException
                继承者  javax.security.cert.CertificateExpiredException
所有已实现的接口：
Serializable
public class CertificateExpiredException
extends CertificateException

证书过期异常。只要当前的 Date 或指定的 Date 超过证书有效期中所指定的 notAfter 日期/时间，就抛出此异常。

注：包 javax.security.cert 中的类用于与早期版本的 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）保持兼容。新的应用程序应该使用 java.security.cert 中的标准 Java SE 证书类。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
CertificateExpiredException()
构造不带详细消息的 CertificateExpiredException。
CertificateExpiredException(String message)
构造带指定详细信息的 CertificateExpiredException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateExpiredException

public CertificateExpiredException()
构造不带详细消息的 CertificateExpiredException。详细消息是描述此特定异常的字符串。

CertificateExpiredException

public CertificateExpiredException(String message)
构造带指定详细信息的 CertificateExpiredException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateNotYetValidException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.cert
类 CertificateNotYetValidException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.cert.CertificateException
                继承者  javax.security.cert.CertificateNotYetValidException
所有已实现的接口：
Serializable
public class CertificateNotYetValidException
extends CertificateException

证书不再有效异常。只要当前的 Date 或指定的 Date 在证书有效期中的 notBefore 日期/时间之前，就抛出此异常。

注：包 javax.security.cert 中的类用于与早期版本的 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）保持兼容。新的应用程序应该使用 java.security.cert 中的标准 Java SE 证书类。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
CertificateNotYetValidException()
构造不带详细消息的 CertificateNotYetValidException。
CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateNotYetValidException

public CertificateNotYetValidException()
构造不带详细消息的 CertificateNotYetValidException。详细消息是描述此特定异常的字符串。

CertificateNotYetValidException

public CertificateNotYetValidException(String message)
构造带指定详细消息的 CertificateNotYetValidException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CertificateParsingException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.cert
类 CertificateParsingException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.security.cert.CertificateException
                继承者  javax.security.cert.CertificateParsingException
所有已实现的接口：
Serializable
public class CertificateParsingException
extends CertificateException

证书解析异常。解析无效的 DER 编码证书或者在该 Certificate 中发现不受支持的 DER 功能时，就抛出此异常。

注：包 javax.security.cert 中的类用于与早期版本的 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）保持兼容。新的应用程序应该使用 java.security.cert 中的标准 Java SE 证书类。

从以下版本开始：
1.4
另请参见：
序列化表格

构造方法摘要
CertificateParsingException()
构造不带详细消息的 CertificateParsingException。
CertificateParsingException(String message)
构造带指定详细信息的 CertificateParsingException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CertificateParsingException

public CertificateParsingException()
构造不带详细消息的 CertificateParsingException。详细消息是描述此特定异常的字符串。

CertificateParsingException

public CertificateParsingException(String message)
构造带指定详细信息的 CertificateParsingException。详细消息是描述此特定异常的字符串。

参数：
message - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


X509Certificate (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.cert
类 X509Certificate

java.lang.Object
    继承者  javax.security.cert.Certificate
        继承者  javax.security.cert.X509Certificate

public abstract class X509Certificate
extends Certificate

X.509 v1 证书的抽象类。此类提供了一种访问 X.509 v1 证书所有属性的标准方式。无法通过此接口提供专用于 X.509 v2 或 v3 的属性。以后的 API 发展会提供对全部 X.509 v3 属性的完全访问。

基本的 X.509 格式由 ISO/IEC 和 ANSI X9 所定义，用 ASN.1 描述如下：

 Certificate  ::=  SEQUENCE  {
     tbsCertificate       TBSCertificate,
     signatureAlgorithm   AlgorithmIdentifier,
     signature            BIT STRING  }

这些证书被广泛使用以支持 Internet 安全系统中的验证和其他功能。常见的应用包括增强保密邮件 (PEM)、传输层安全 (SSL)、用于受信任软件发布的代码签名和安全电子交易 (SET)。

由证书颁发机构 (CA) 来管理和担保这些证书。CA 的工作是创建证书，方法是将数据置于 X.509 标准格式，然后以数字方式签署该数据。CA 充当受信任的第三方，在不能直接通信的主体之间传递信息。CA 证书可由其自身签名，也可由其他 CA 签名，如“根”CA。

tbsCertificate 的 ASN.1 定义是：

 TBSCertificate  ::=  SEQUENCE  {
     version         [0]  EXPLICIT Version DEFAULT v1,
     serialNumber         CertificateSerialNumber,
     signature            AlgorithmIdentifier,
     issuer               Name,
     validity             Validity,
     subject              Name,
     subjectPublicKeyInfo SubjectPublicKeyInfo,
     }

下面是实例化 X.509 证书的示例代码：

 InputStream inStream = new FileInputStream("fileName-of-cert");
 X509Certificate cert = X509Certificate.getInstance(inStream);
 inStream.close();
或者
 byte[] certData = <certificate read from a file, say>
 X509Certificate cert = X509Certificate.getInstance(certData);

无论是哪种情况，实例化 X.509 证书的代码都要查找 Java 安全属性文件来找到实际的实现，或者实例化一个默认的实现。

Java 安全属性文件位于指定的 <JAVA_HOME>/lib/security/java.security 文件中。<JAVA_HOME> 是指 java.home 系统属性的值并且指定安装 JRE 的目录。在安全属性文件中，X.509 v1 的默认实现可能如下：

 cert.provider.x509v1=com.sun.security.cert.internal.x509.X509V1CertImpl

要想实例化另一个实现，必须更改此 cert.provider.x509v1 属性的值。如果未设置此安全属性，则使用默认实现。目前，由于对安全属性的访问可能有安全限制，所以在类初始化时查找并缓存此值，如果无法访问安全属性，则退而使用默认实现。

注：包 javax.security.cert 中的类用于与早期版本的 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）保持兼容。新的应用程序应该使用 java.security.cert 中的标准 Java SE 证书类。

从以下版本开始：
1.4
另请参见：
Certificate, X509Extension

构造方法摘要
X509Certificate()
方法摘要
abstract void | checkValidity() 检查证书目前是否有效。
abstract void | checkValidity(Date date) 检查指定的日期是否处于证书的有效期内。
static X509Certificate | getInstance(byte[] certData) 实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。
static X509Certificate | getInstance(InputStream inStream) 实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。
abstract Principal | getIssuerDN() 获取证书的 issuer（发布方的标识名）值。
abstract Date | getNotAfter() 获取证书有效期的 notAfter 日期。
abstract Date | getNotBefore() 获取证书有效期的 notBefore 日期。
abstract BigInteger | getSerialNumber() 获取证书的 serialNumber 值。
abstract String | getSigAlgName() 获取用于该证书签名算法的名称。
abstract String | getSigAlgOID() 获取证书的签名算法 OID 字符串。
abstract byte[] | getSigAlgParams() 从此证书的签名算法中获取 DER 编码形式的签名算法参数。
abstract Principal | getSubjectDN() 获取证书的 subject（主体的标识名）值。
abstract int | getVersion() 获取证书的 version（版本号）值。
从类 javax.security.cert.Certificate 继承的方法
equals, getEncoded, getPublicKey, hashCode, toString, verify, verify
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

X509Certificate

public X509Certificate()
方法详细信息

getInstance

public static final X509Certificate getInstance(InputStream inStream)
                                         throws CertificateException
实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。在安全属性文件中，属性 cert.provider.x509v1 的值指定了一个类，而这个类提供了该实现（X509Certificate 是一个抽象类）。

注：期望输入流中只有一个 DER 编码的证书。另外，所有 X509Certificate 子类必须提供以下形式的构造方法：

 public <subClass>(InputStream inStream) ...

参数：
inStream - 输入流，为了初始化该证书而要从中读取数据。
返回：
使用从输入流中读取的数据初始化了的X509Certificate 对象。
抛出：
CertificateException - 如果发生类初始化或证书解析错误。

getInstance

public static final X509Certificate getInstance(byte[] certData)
                                         throws CertificateException
实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。由指定为安全属性文件中 cert.provider.x509v1 属性值的类来提供该实现（X509Certificate 是一个抽象类）。

注：所有 X509Certificate 子类必须提供以下形式的构造方法：

 public <subClass>(InputStream inStream) ...

参数：
certData - 包含 DER 编码证书的 byte 数组。
返回：
X509Certificate 对象，已使用 certData 中的数据初始化该对象。
抛出：
CertificateException - 如果发生类初始化或证书解析错误。

checkValidity

public abstract void checkValidity()
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
检查证书目前是否有效。即当前的日期和时间是否仍在证书中所给定的有效期内。

有效期由两个日期/时间值组成：证书有效的起始日期（和时间）和终止日期（和时间）。用 ASN.1 中定义如下：

 validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }

抛出：
CertificateExpiredException - 如果证书已过期。
CertificateNotYetValidException - 如果证书不再有效。

checkValidity

public abstract void checkValidity(Date date)
                            throws CertificateExpiredException,
                                   CertificateNotYetValidException
检查指定的日期是否处于证书的有效期内。换句话说，这确定该证书在指定的日期/时间是否有效。

参数：
date - 要检查的 Date，以确定此证书在该日期/时间是否有效。
抛出：
CertificateExpiredException - 如果对于所提供的 date 而言该证书已过期。
CertificateNotYetValidException - 如果对于所提供的 date 而言该证书不再有效。
另请参见：
checkValidity()

getVersion

public abstract int getVersion()
获取证书的 version（版本号）值。此内容的 ASN.1 定义如下：
 version         [0]  EXPLICIT Version DEFAULT v1

 Version  ::=  INTEGER  {  v1(0), v2(1), v3(2)  }

返回：
ASN.1 编码形式的版本号，即 0、1 或 2。

getSerialNumber

public abstract BigInteger getSerialNumber()
获取证书的 serialNumber 值。序列号是证书颁发机构为每个证书所分配的一个整数。给定的 CA 所发布的每个证书的序列号必须是唯一的（即发布方名称和序列号标识一个唯一的证书）。此内容的 ASN.1 定义如下：
 serialNumber     CertificateSerialNumber

 CertificateSerialNumber  ::=  INTEGER

返回：
序列号。

getIssuerDN

public abstract Principal getIssuerDN()
获取证书的 issuer（发布方的标识名）值。发布方名称标识了签署（并发布）该证书的实体。

发布方名称字段包含一个 X.500 标识名 (DN)。此内容的 ASN.1 定义如下：

 issuer    Name

 Name ::= CHOICE { RDNSequence }
 RDNSequence ::= SEQUENCE OF RelativeDistinguishedName
 RelativeDistinguishedName ::=
     SET OF AttributeValueAssertion

 AttributeValueAssertion ::= SEQUENCE {
                               AttributeType,
                               AttributeValue }
 AttributeType ::= OBJECT IDENTIFIER
 AttributeValue ::= ANY
Name 描述了一个层次结构名，由属性（如国家/地区名）和相应值（如 US）组成。AttributeValue 组件的类型由 AttributeType 来确定；一般是 directoryString。directoryString 通常是 PrintableString、TeletexString 或 UniversalString 之一。

返回：
一个 Principal，其名称是发布方的标识名。

getSubjectDN

public abstract Principal getSubjectDN()
获取证书的 subject（主体的标识名）值。此内容的 ASN.1 定义如下：
 subject    Name

有关 Name 和其他相关定义，请参阅 getIssuerDN。

返回：
一个 Principal，其名称是主体名。
另请参见：
getIssuerDN()

getNotBefore

public abstract Date getNotBefore()
获取证书有效期的 notBefore 日期。相关的 ASN.1 定义如下：
 validity             Validity

 Validity ::= SEQUENCE {
     notBefore      CertificateValidityDate,
     notAfter       CertificateValidityDate }

 CertificateValidityDate ::= CHOICE {
     utcTime        UTCTime,
     generalTime    GeneralizedTime }

返回：
有效期的起始日期。
另请参见：
checkValidity()

getNotAfter

public abstract Date getNotAfter()
获取证书有效期的 notAfter 日期。相关的 ASN.1 定义，请参阅 getNotBefore。

返回：
有效期的终止日期。
另请参见：
checkValidity()

getSigAlgName

public abstract String getSigAlgName()
获取用于该证书签名算法的名称。例如字符串 "SHA-1/DSA"。此内容的 ASN.1 定义如下：
 signatureAlgorithm   AlgorithmIdentifier

 AlgorithmIdentifier  ::=  SEQUENCE  {
     algorithm               OBJECT IDENTIFIER,
     parameters              ANY DEFINED BY algorithm OPTIONAL  }
                             -- contains a value of the type
                             -- registered for use with the
                             -- algorithm object identifier value

根据 algorithm OID 字符串确定该算法名。

返回：
签名算法名。

getSigAlgOID

public abstract String getSigAlgOID()
获取证书的签名算法 OID 字符串。OID 由一组句点分隔的正数来表示。例如，按照 PKIX 部分 I 中的规定，字符串 "1.2.840.10040.4.3" 标识使用 DSA 签名算法的 SHA-1。

相关的 ASN.1 定义，请参阅 getSigAlgName。

返回：
签名算法 OID 字符串。

getSigAlgParams

public abstract byte[] getSigAlgParams()
从此证书的签名算法中获取 DER 编码形式的签名算法参数。在大多数情况下，该签名算法参数为 null；参数通常是与证书的公钥一起提供的。

相关的 ASN.1 定义，请参阅 getSigAlgName。

返回：
DER 编码形式的签名算法参数，如果没有该参数，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.cert (Java 2 Platform SE 6)

 javax.security.cert
类
Certificate
X509Certificate
异常
CertificateEncodingException
CertificateException
CertificateExpiredException
CertificateNotYetValidException
CertificateParsingException


javax.security.cert (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.cert

为公钥证书提供类。

请参见：
描述

类摘要
Certificate | 管理各种身份证书的抽象类。
X509Certificate | X.509 v1 证书的抽象类。

异常摘要
CertificateEncodingException | 证书编码异常。
CertificateException | 此异常指示各种证书问题之一。
CertificateExpiredException | 证书过期异常。
CertificateNotYetValidException | 证书不再有效异常。
CertificateParsingException | 证书解析异常。

软件包 javax.security.cert 的描述

为公钥证书提供类。

这些类包括 java.security.cert 包的简化版本。这些类作为 Java 安全套接字扩展（Java Secure Socket Extension，JSSE）的一部分而开发。将 JSSE 添加到 J2SE version 1.4 时，仅出于向后兼容性的原因才添加此包。

新的应用程序不应使用此包，而应使用 java.security.cert。

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.cert 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.cert 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.security.cert.Certificate
      • javax.security.cert.X509Certificate
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.security.cert.CertificateException
          • javax.security.cert.CertificateEncodingException
          • javax.security.cert.CertificateExpiredException
          • javax.security.cert.CertificateNotYetValidException
          • javax.security.cert.CertificateParsingException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.cert 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.cert
的使用

使用 javax.security.cert 的软件包
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.cert | 为公钥证书提供类。

javax.net.ssl 使用的 javax.security.cert 中的类
X509Certificate
X.509 v1 证书的抽象类。

javax.security.cert 使用的 javax.security.cert 中的类
Certificate
管理各种身份证书的抽象类。
CertificateEncodingException
证书编码异常。
CertificateException
此异常指示各种证书问题之一。
CertificateExpiredException
证书过期异常。
CertificateNotYetValidException
证书不再有效异常。
X509Certificate
X.509 v1 证书的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.cert.X509Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.X509Certificate
的使用

使用 X509Certificate 的软件包
javax.net.ssl | 提供用于安全套接字包的类。
javax.security.cert | 为公钥证书提供类。

javax.net.ssl 中 X509Certificate 的使用

返回 X509Certificate 的 javax.net.ssl 中的方法
X509Certificate[] | HandshakeCompletedEvent.getPeerCertificateChain() 返回同位体的标识，同位体是作为定义会话的一部分而标识的。
X509Certificate[] | SSLSession.getPeerCertificateChain() 返回同级身份，该同级身份被标识作为定义会话的一部分。

javax.security.cert 中 X509Certificate 的使用

返回 X509Certificate 的 javax.security.cert 中的方法
static X509Certificate | X509Certificate.getInstance(byte[] certData) 实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。
static X509Certificate | X509Certificate.getInstance(InputStream inStream) 实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.cert.Certificate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.Certificate
的使用

使用 Certificate 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 Certificate 的使用

javax.security.cert 中 Certificate 的子类
 class X509Certificate
X.509 v1 证书的抽象类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.cert.CertificateException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateException
的使用

使用 CertificateException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateException 的使用

javax.security.cert 中 CertificateException 的子类
class | CertificateEncodingException 证书编码异常。
class | CertificateExpiredException 证书过期异常。
class | CertificateNotYetValidException 证书不再有效异常。
class | CertificateParsingException 证书解析异常。

抛出 CertificateException 的 javax.security.cert 中的方法
static X509Certificate | X509Certificate.getInstance(byte[] certData) 实例化一个 X509Certificate 对象，并使用指定的 byte 数组初始化它。
static X509Certificate | X509Certificate.getInstance(InputStream inStream) 实例化一个 X509Certificate 对象，并使用从输入流 inStream 读取的数据初始化它。
abstract void | Certificate.verify(PublicKey key) 验证是否已使用与指定公钥相对应的私钥签署了此证书。
abstract void | Certificate.verify(PublicKey key, String sigProvider) 验证是否已使用与指定公钥相对应的私钥签署了此证书。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.cert.CertificateExpiredException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateExpiredException
的使用

使用 CertificateExpiredException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateExpiredException 的使用

抛出 CertificateExpiredException 的 javax.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查指定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.cert.CertificateNotYetValidException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateNotYetValidException
的使用

使用 CertificateNotYetValidException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateNotYetValidException 的使用

抛出 CertificateNotYetValidException 的 javax.security.cert 中的方法
abstract void | X509Certificate.checkValidity() 检查证书目前是否有效。
abstract void | X509Certificate.checkValidity(Date date) 检查指定的日期是否处于证书的有效期内。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.cert.CertificateEncodingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateEncodingException
的使用

使用 CertificateEncodingException 的软件包
javax.security.cert 为公钥证书提供类。

javax.security.cert 中 CertificateEncodingException 的使用

抛出 CertificateEncodingException 的 javax.security.cert 中的方法
abstract  byte[] Certificate.getEncoded()
返回此证书的编码形式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.cert.CertificateParsingException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.cert.CertificateParsingException
的使用

没有 javax.security.cert.CertificateParsingException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AuthenticationException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
类 AuthenticationException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.security.sasl.SaslException
                    继承者  javax.security.sasl.AuthenticationException
所有已实现的接口：
Serializable
public class AuthenticationException
extends SaslException

此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。

注意，不出现 AuthenticationException 并不意味着失败不是由验证错误所导致的。如果 SASL 机制实现无法确定失败的类型，或者不想泄漏失败的类型（例如由于安全的原因），那么它可以抛出更通用的 SaslException 代替 AuthenticationException。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AuthenticationException()
构造一个新的 AuthenticationException 实例。
AuthenticationException(String detail)
构造带详细消息的新 AuthenticationException 实例。
AuthenticationException(String detail, Throwable ex)
构造带详细消息和根异常的新 AuthenticationException 实例。
方法摘要
从类 javax.security.sasl.SaslException 继承的方法
getCause, initCause, toString
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AuthenticationException

public AuthenticationException()
构造一个新的 AuthenticationException 实例。根异常和详细消息为 null。

AuthenticationException

public AuthenticationException(String detail)
构造带详细消息的新 AuthenticationException 实例。根异常为 null。

参数：
detail - 包含异常细节的字符串，可能为 null。
另请参见：
Throwable.getMessage()

AuthenticationException

public AuthenticationException(String detail,
                               Throwable ex)
构造带详细消息和根异常的新 AuthenticationException 实例。

参数：
detail - 包含异常细节的字符串，可能为 null。
ex - 导致此异常的根异常，可能为 null。
另请参见：
Throwable.getMessage(), SaslException.getCause()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AuthorizeCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
类 AuthorizeCallback

java.lang.Object
    继承者  javax.security.sasl.AuthorizeCallback
所有已实现的接口：
Serializable, Callback
public class AuthorizeCallback
extends Object
implements Callback, Serializable

此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
AuthorizeCallback(String authnID, String authzID)
构造 AuthorizeCallback 的实例。
方法摘要
String | getAuthenticationID() 返回要检查的验证 id。
String | getAuthorizationID() 返回要检查的授权 id。
String | getAuthorizedID() 返回已授权用户的 id。
boolean | isAuthorized() 确定是否允许用验证 id 代表授权 id。
void | setAuthorized(boolean ok) 设置是否允许授权。
void | setAuthorizedID(String id) 设置已授权实体的 id。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AuthorizeCallback

public AuthorizeCallback(String authnID,
                         String authzID)
构造 AuthorizeCallback 的实例。

参数：
authnID - （已验证的）验证 id。
authzID - 授权 id。
方法详细信息

getAuthenticationID

public String getAuthenticationID()
返回要检查的验证 id。

返回：
要检查的验证 id。

getAuthorizationID

public String getAuthorizationID()
返回要检查的授权 id。

返回：
要检查的授权 id。

isAuthorized

public boolean isAuthorized()
确定是否允许用验证 id 代表授权 id。

返回：
如果允许授权，则返回 true；否则返回 false
另请参见：
setAuthorized(boolean), getAuthorizedID()

setAuthorized

public void setAuthorized(boolean ok)
设置是否允许授权。

参数：
ok - 如果允许授权，则为 true；否则为 false
另请参见：
isAuthorized(), setAuthorizedID(java.lang.String)

getAuthorizedID

public String getAuthorizedID()
返回已授权用户的 id。

返回：
已授权用户的 id。null 意味着授权失败。
另请参见：
setAuthorized(boolean), setAuthorizedID(java.lang.String)

setAuthorizedID

public void setAuthorizedID(String id)
设置已授权实体的 id。仅在该 id 与 getAuthorizationID() 的返回值不同时才由处理程序调用。例如，可能需要针对该 id 所要使用的环境对其进行规范化处理。

参数：
id - 已授权用户的 id。
另请参见：
setAuthorized(boolean), getAuthorizedID()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RealmCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
类 RealmCallback

java.lang.Object
    继承者  javax.security.auth.callback.TextInputCallback
        继承者  javax.security.sasl.RealmCallback
所有已实现的接口：
Serializable, Callback
public class RealmCallback
extends TextInputCallback

SaslClient 和 SaslServer 使用此回调来获取领域信息。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RealmCallback(String prompt)
构造带提示的 RealmCallback。
RealmCallback(String prompt, String defaultRealmInfo)
构造带提示和默认领域信息的 RealmCallback。
方法摘要
从类 javax.security.auth.callback.TextInputCallback 继承的方法
getDefaultText, getPrompt, getText, setText
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RealmCallback

public RealmCallback(String prompt)
构造带提示的 RealmCallback。

参数：
prompt - 用于请求领域信息的非 null 提示。
抛出：
IllegalArgumentException - 如果 prompt 为 null 或空字符串。

RealmCallback

public RealmCallback(String prompt,
                     String defaultRealmInfo)
构造带提示和默认领域信息的 RealmCallback。

参数：
prompt - 用于请求领域信息的非 null 提示。
defaultRealmInfo - 要使用的非 null 默认领域信息。
抛出：
IllegalArgumentException - 如果 prompt 为 null 或空字符串、如果 defaultRealm 为空或 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RealmChoiceCallback (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
类 RealmChoiceCallback

java.lang.Object
    继承者  javax.security.auth.callback.ChoiceCallback
        继承者  javax.security.sasl.RealmChoiceCallback
所有已实现的接口：
Serializable, Callback
public class RealmChoiceCallback
extends ChoiceCallback

SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
RealmChoiceCallback(String prompt, String[] choices, int defaultChoice, boolean multiple)
构造带提示、选项列表和默认选项的 RealmChoiceCallback。
方法摘要
从类 javax.security.auth.callback.ChoiceCallback 继承的方法
allowMultipleSelections, getChoices, getDefaultChoice, getPrompt, getSelectedIndexes, setSelectedIndex, setSelectedIndexes
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RealmChoiceCallback

public RealmChoiceCallback(String prompt,
                           String[] choices,
                           int defaultChoice,
                           boolean multiple)
构造带提示、选项列表和默认选项的 RealmChoiceCallback。

参数：
prompt - 用来请求领域的非 null 提示。
choices - 要从中选择的非 null 的领域列表。
defaultChoice - 显示选项列表时用作默认选项的选项。这是 choices 数组中的索引。
multiple - 如果允许多个选项，则为 true；否则为 false
抛出：
IllegalArgumentException - 如果 prompt 为 null 或者是空字符串、如果 choices 的长度为 0、如果 choices 的任一元素为 null 或为空、如果 defaultChoice 不在 choices 的数组边界内
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Sasl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
类 Sasl

java.lang.Object
    继承者  javax.security.sasl.Sasl

public class Sasl
extends Object

用于创建 SASL 客户端和服务器的静态类。

此类定义了如何查找、加载和实例化 SASL 客户端和服务器的策略。

例如，通过执行以下操作，应用程序或库可获得 SASL 客户端：

 SaslClient sc = Sasl.createSaslClient(mechanisms,
     authorizationId, protocol, serverName, props, callbackHandler);
然后该程序可继续使用该实例来创建验证连接。

类似地，服务器可使用下列代码来获得 SASL 服务器：

 SaslServer ss = Sasl.createSaslServer(mechanism,
     protocol, serverName, props, callbackHandler);

从以下版本开始：
1.5

字段摘要
static String | CREDENTIALS 属性的名称，它指定要使用的证书。
static String | MAX_BUFFER 属性名，指定 SaslClient/SaslServer 接收缓冲区的最大大小（以字节为单位）。
static String | POLICY_FORWARD_SECRECY 属性名，指定是否需要在会话间实现了转发安全性的机制。
static String | POLICY_NOACTIVE 属性名，指定是否允许易受主动式攻击（非字典）的机制。
static String | POLICY_NOANONYMOUS 属性名，指定是否允许接受匿名登录的机制。
static String | POLICY_NODICTIONARY 属性名，指定是否允许易受被动式字典攻击的机制。
static String | POLICY_NOPLAINTEXT 属性名，指定是否允许易受简单被动式攻击（例如 "PLAIN"）的机制。
static String | POLICY_PASS_CREDENTIALS 属性名，指定是否需要传递客户端证书的机制。
static String | QOP 属性名，指定要使用的保护级别。
static String | RAW_SEND_SIZE 属性名，指定 SaslClient/SaslServer 初始发送缓冲区的最大大小（以字节为单位）。
static String | REUSE 属性名，指定是否重用以前已验证过的会话信息。
static String | SERVER_AUTH 属性名，指定服务器是否必须验证客户端。
static String | STRENGTH 属性名，指定要使用的密码强度。
方法摘要
static SaslClient | createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
static SaslServer | createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
static Enumeration<SaslClientFactory> | getSaslClientFactories() 获得用于生成 SaslClient 的已知工厂的枚举。
static Enumeration<SaslServerFactory> | getSaslServerFactories() 获得用于生成 SaslServer 的已知工厂的枚举。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

QOP

public static final String QOP
属性名，指定要使用的保护级别。该属性包含一个逗号分隔的、客户端或服务器希望支持的保护级别值的有序列表。保护级别值 (qop) 是下列之一：
  • "auth" - 仅验证
  • "auth-int" - 验证和完整性保护
  • "auth-conf" - 验证、完整性和机密性保护
该列表的顺序指定了客户端或服务器的首选顺序。如果此属性不存在，则默认的保护级别是 "auth"。此常量的值是 "javax.security.sasl.qop"。

另请参见：
常量字段值

STRENGTH

public static final String STRENGTH
属性名，指定要使用的密码强度。该属性包含一个逗号分隔的、客户端或服务器希望支持的密码强度值的有序列表。强度值是下列之一：
  • "low"
  • "medium"
  • "high"
该列表的顺序指定了客户端或服务器的首选顺序。实现应该允许配置这些值的含义。应用程序可以使用 Java Cryptography Extension（Java 加密扩展，JCE），借助可使用 JCE 的机制来控制对与该强度值相符的密码套件的选择。
如果此属性不存在，则默认的强度是 "high,medium,low"。此常量的值是 "javax.security.sasl.strength"。

另请参见：
常量字段值

SERVER_AUTH

public static final String SERVER_AUTH
属性名，指定服务器是否必须验证客户端。如果服务器必须验证客户端，则该属性包含 "true"；否则包含 "false"。默认值为 "false"。
此常量的值是 "javax.security.sasl.server.authentication"。

另请参见：
常量字段值

MAX_BUFFER

public static final String MAX_BUFFER
属性名，指定 SaslClient/SaslServer 接收缓冲区的最大大小（以字节为单位）。该属性包含一个整数的字符串表示形式。
如果此属性不存在，则由机制定义默认的大小。
此常量的值是 "javax.security.sasl.maxbuffer"。

另请参见：
常量字段值

RAW_SEND_SIZE

public static final String RAW_SEND_SIZE
属性名，指定 SaslClient/SaslServer 初始发送缓冲区的最大大小（以字节为单位）。该属性包含一个整数的字符串表示形式。验证交换期间在客户端和服务器之间协商此属性的值。
此常量的值是 "javax.security.sasl.rawsendsize"。

另请参见：
常量字段值

REUSE

public static final String REUSE
属性名，指定是否重用以前已验证过的会话信息。如果机制实现可以尝试重用以前已验证的会话信息，则该属性包含 "true"；如果实现必须不重用以前已验证的会话信息，则该属性包含 "false"。"true" 设置仅用作一个提示：这不一定会实际重用该信息，很多原因都可能导致无法重用，这些原因包括（但不限于）机制不支持重用、可重用的信息已过期和同位体拒绝支持重用。 该属性的默认值是 "false"。此常量的值是 "javax.security.sasl.reuse"。 注意，不管是否提供了此属性，必须提供创建 SASL 客户端/服务器实例所需的所有其他参数和属性。也就是说，如果期望重用该信息，也不能提供较少的其他信息。 支持重用的机制实现可以允许为某些方面自定义其实现，如缓存大小、超时和可重用性标准。这些自定义内容与实现有关。

另请参见：
常量字段值

POLICY_NOPLAINTEXT

public static final String POLICY_NOPLAINTEXT
属性名，指定是否允许易受简单被动式攻击（例如 "PLAIN"）的机制。如果不允许这种机制，则该属性包含 "true"；如果允许这种机制，则包含 "false"。默认值为 "false"。
此常量的值是 "javax.security.sasl.policy.noplaintext"。

另请参见：
常量字段值

POLICY_NOACTIVE

public static final String POLICY_NOACTIVE
属性名，指定是否允许易受主动式攻击（非字典）的机制。如果不允许这种易受主动式攻击的机制，则该属性包含 "true"；如果允许这种机制，则包含 "false"。默认值为 "false"。
此常量的值是 "javax.security.sasl.policy.noactive"。

另请参见：
常量字段值

POLICY_NODICTIONARY

public static final String POLICY_NODICTIONARY
属性名，指定是否允许易受被动式字典攻击的机制。如果不允许这种易受字典攻击的机制，则该属性包含 "true"；如果允许这种机制，则包含 "false"。默认值为 "false"。
此常量的值是 "javax.security.sasl.policy.nodictionary"。

另请参见：
常量字段值

POLICY_NOANONYMOUS

public static final String POLICY_NOANONYMOUS
属性名，指定是否允许接受匿名登录的机制。如果不允许这种接受匿名登录的机制，则该属性包含 "true"；如果允许这种机制，则包含 "false"。默认值为 "false"。
此常量的值是 "javax.security.sasl.policy.noanonymous"。

另请参见：
常量字段值

POLICY_FORWARD_SECRECY

public static final String POLICY_FORWARD_SECRECY
属性名，指定是否需要在会话间实现了转发安全性的机制。转发安全性意味着中断一个会话不会自动为中断后续的会话提供信息。如果需要在会话间实现转发安全性的机制，则该属性包含 "true"；如果不需要这样的机制，则包含 "false"。默认值为 "false"。
此常量的值是 "javax.security.sasl.policy.forward"。

另请参见：
常量字段值

POLICY_PASS_CREDENTIALS

public static final String POLICY_PASS_CREDENTIALS
属性名，指定是否需要传递客户端证书的机制。如果需要传递客户端证书的机制，则该属性包含 "true"；如果不需要这样的机制，则包含 "false"。默认值为 "false"。
此常量的值是 "javax.security.sasl.policy.credentials"。

另请参见：
常量字段值

CREDENTIALS

public static final String CREDENTIALS
属性的名称，它指定要使用的证书。该属性包含特定于机制的 Java 证书对象。机制实现可以检查此属性的值，以确定它是否是它们支持的类。该属性可以向支持委托的验证的机制提供证书。
此常量的值为 "javax.security.sasl.credentials"。

另请参见：
常量字段值
方法详细信息

createSaslClient

public static SaslClient createSaslClient(String[] mechanisms,
                                          String authorizationId,
                                          String protocol,
                                          String serverName,
                                          Map<String,?> props,
                                          CallbackHandler cbh)
                                   throws SaslException
使用提供的参数创建 SaslClient。 此方法使用 JCA Security Provider Framework（在 "Java Cryptography Architecture API Specification & Reference" 中描述）来查找和选择 SaslClient 实现。 首先，它从 "SaslClientFactory" 服务的已注册安全提供者和指定的 SASL 机制中获得 SaslClientFactory 实例的有序列表。然后它在列表中的每个工厂实例上调用 createSaslClient()，直到某个调用生成一个非 null 的 SaslClient 实例为止。此方法返回非 null 的 SaslClient 实例，如果搜索无法生成非 null 的 SaslClient 实例，则返回 null。

SaslClientFactory 的安全提供者向 JCA Security Provider Framework 注册以下形式的键：
SaslClientFactory.机制名
和值（即 javax.security.sasl.SaslClientFactory 实现的类名）。 例如，一个包含工厂类 com.wiz.sasl.digest.ClientFactory（支持 "DIGEST-MD5" 机制）的提供者将向 JCA 注册以下项：SaslClientFactory.DIGEST-MD5 com.wiz.sasl.digest.ClientFactory

有关如何安装和配置安全服务提供者的信息，请参阅 "Java Cryptography Architecture API Specification & Reference"。

参数：
mechanisms - 要试用的机制名的非 null 列表。每个名称都是 SASL 机制的 IANA 注册名。（例如 "GSSAPI"、"CRAM-MD5"）。
authorizationId - 与协议有关可能为 null 的用于授权的标识。如果为 null 或空，则服务器根据客户端的验证证书派生出一个授权 ID。SASL 验证成功完成后，就允许指定的实体访问。
protocol - 非 null 的协议（例如 "ldap"）字符串名，将用它执行验证。
serverName - 服务器的非 null 完全限定主机名，要向该服务器进行验证。
props - 可能为 null 的属性集，用于选择 SASL 机制并配置所选机制的验证交换。例如，如果 props 包含 Sasl.POLICY_NOPLAINTEXT 属性，且属性值为 "true"，则所选的 SASL 机制必须不易受到简单被动式攻击的影响。除了在此类中所声明的标准属性外，也可以包括其他的可能特定于机制的属性。忽略与所选机制无关的属性，包括带有非字符串关键字的所有映射项。
cbh - SASL 机制使用的回调处理程序（可能为 null），以便为完成验证而从应用程序/库获得更多的信息。例如，SASL 机制可能需要从调用者获得验证 ID、密码和域。使用 NameCallback 来请求验证 ID。使用 PasswordCallback 来请求密码。如果要从域列表中选择，则使用 RealmChoiceCallback 来请求域，如果必须输入域，则使用 RealmCallback 来请求域。
返回：
使用所提供参数创建的 SaslClient，可能为 null。如果为 null，则无法找到可生成 SaslClient 的 SaslClientFactory。
抛出：
SaslException - 如果因为错误而无法创建 SaslClient。

createSaslServer

public static SaslServer createSaslServer(String mechanism,
                                          String protocol,
                                          String serverName,
                                          Map<String,?> props,
                                          CallbackHandler cbh)
                                   throws SaslException
为指定机制创建一个 SaslServer。 此方法使用 JCA Security Provider Framework（在 "Java Cryptography Architecture API Specification & Reference" 中所有描述）来查找和选择 SaslServer 实现。 首先，它从 "SaslServerFactory" 服务的已注册安全提供者和指定的 SASL 机制中获得 SaslServerFactory 实例的有序列表。然后它在列表中的每个工厂实例上调用 createSaslServer()，直到某个调用生成一个非 null 的 SaslServer 实例为止。此方法返回非 null 的 SaslServer 实例，如果搜索无法生成非 null 的 SaslServer 实例，则返回 null。

SaslServerFactory 的安全提供者向 JCA Security Provider Framework 注册以下形式的键：
SaslServerFactory.机制名
和值（即 javax.security.sasl.SaslServerFactory 实现的类名）。 例如，一个包含工厂类 com.wiz.sasl.digest.ServerFactory（支持 "DIGEST-MD5" 机制）的提供者将向 JCA 注册以下项： SaslServerFactory.DIGEST-MD5 com.wiz.sasl.digest.ServerFactory

有关如何安装和配置安全服务提供者的信息，请参阅 "Java Cryptography Architecture API Specification & Reference"。

参数：
mechanism - 非 null 的机制名。它必须是 SASL 机制的 IANA 注册名。（例如 "GSSAPI"、"CRAM-MD5"）。
protocol - 非 null 的协议（例如 "ldap"）字符串名，将为它执行验证。
serverName - 服务器的非 null 完全限定主机名。
props - 可能为 null 的属性集，用于选择 SASL 机制并配置所选机制的验证交换。例如，如果 props 包含 Sasl.POLICY_NOPLAINTEXT 属性，且属性值为 "true"，则所选的 SASL 机制必须不易受到简单被动式攻击的危害。除了在此类中所声明的标准属性外，也可以包括其他的可能特定于机制的属性。忽略与所选机制无关的属性，包括带有非字符串关键字的所有映射项。
cbh - SASL 机制使用的回调处理程序（可能为 null），以便为完成验证而从应用程序/库获得更多的信息。例如，SASL 机制可能需要从调用者获得验证 ID、密码和域。使用 NameCallback 来请求验证 ID。使用 PasswordCallback 来请求密码。如果要从域列表中选择，则使用 RealmChoiceCallback 来请求域，如果必须输入域，则使用 RealmCallback 来请求域。
返回：
使用所提供参数创建的 SaslServer，可能为 null。如果为 null，则无法找到可生成 SaslServer 的 SaslServerFactory。
抛出：
SaslException - 如果因为错误而无法创建 SaslServer。

getSaslClientFactories

public static Enumeration<SaslClientFactory> getSaslClientFactories()
获得用于生成 SaslClient 的已知工厂的枚举。此方法使用与 createSaslClient() 相同的查找工厂算法。

返回：
用于生成 SaslClient 的已知工厂非 null 枚举。
另请参见：
createSaslClient(java.lang.String[], java.lang.String, java.lang.String, java.lang.String, java.util.Map, javax.security.auth.callback.CallbackHandler)

getSaslServerFactories

public static Enumeration<SaslServerFactory> getSaslServerFactories()
获得用于生成 SaslServer 的已知工厂的枚举。此方法使用与 createSaslServer() 相同的查找工厂算法。

返回：
用于生成 SaslServer 的已知工厂的非 null 枚举，
另请参见：
createSaslServer(java.lang.String, java.lang.String, java.lang.String, java.util.Map, javax.security.auth.callback.CallbackHandler)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SaslClient (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
接口 SaslClient

public interface SaslClient

以客户端的身份执行 SASL 验证。

为了执行具体 SASL 机制所定义的验证，协议库（例如用于 LDAP 的库）要获得此类的一个实例。调用 SaslClient 实例的方法可处理 challenge，并创建与 SaslClient 所实现的 SASL 机制相对应的响应。随着验证的进行，该实例会封装 SASL 客户端的验证交换状态。

以下是 LDAP 库如何使用 SaslClient 的一个示例。它首先获得 SaslClient 的一个实例：

 SaslClient sc = Sasl.createSaslClient(mechanisms,
     authorizationId, protocol, serverName, props, callbackHandler);
然后它可继续使用该客户端进行验证。例如，LDAP 库可能按如下方式使用该客户端：
 // Get initial response and send to server
 byte[] response = (sc.hasInitialResponse() ? sc.evaluateChallenge(new byte[0]) :
     null);
 LdapResult res = ldap.sendBindRequest(dn, sc.getName(), response);
 while (!sc.isComplete() &&
     (res.status == SASL_BIND_IN_PROGRESS || res.status == SUCCESS)) {
     response = sc.evaluateChallenge(res.getBytes());
     if (res.status == SUCCESS) {
         // we're done; don't expect to send another BIND
         if (response != null) {
               throw new SaslException(
                   "Protocol error: attempting to send response after completion");
           }
         break;
     }
     res = ldap.sendBindRequest(dn, sc.getName(), response);
 }
 if (sc.isComplete() && res.status == SUCCESS) {
    String qop = (String) sc.getNegotiatedProperty(Sasl.QOP);
    if (qop != null
        && (qop.equalsIgnoreCase("auth-int")
            || qop.equalsIgnoreCase("auth-conf"))) {

      // Use SaslClient.wrap() and SaslClient.unwrap() for future
      // communication with server
        ldap.in = new SecureInputStream(sc, ldap.in);
        ldap.out = new SecureOutputStream(sc, ldap.out);
    }
 }
如果该机制有初始响应，则库可调用带有空 challenge 的 evaluateChallenge() 来获得该初始响应。诸如 IMAP4 等此类协议在其送往服务器的第一个验证命令中不包括初始响应，所以可无需首先调用 hasInitialResponse() 或 evaluateChallenge() 即可发起验证。当服务器响应该命令时，它会发送初始 challenge。对于客户端首先发送数据的 SASL 机制而言，服务器应该发出一个没有数据的 challenge。然后，这会导致带有空 challenge 的 evaluateChallenge() 调用（在客户端上）。

从以下版本开始：
1.5
另请参见：
Sasl, SaslClientFactory

方法摘要
void | dispose() 处置 SaslClient 可能使用的所有系统资源或安全敏感信息。
byte[] | evaluateChallenge(byte[] challenge) 评估 challenge 数据并生成一个响应。
String | getMechanismName() 返回此 SASL 客户端的 IANA 注册机制名。
Object | getNegotiatedProperty(String propName) 获取已协商的属性。
boolean | hasInitialResponse() 确定此机制是否具有可选的初始响应。
boolean | isComplete() 确定验证交换是否已完成。
byte[] | unwrap(byte[] incoming, int offset, int len) 解包接收自服务器的 byte 数组。
byte[] | wrap(byte[] outgoing, int offset, int len) 包装要发送到服务器的 byte 数组。

方法详细信息

getMechanismName

String getMechanismName()
返回此 SASL 客户端的 IANA 注册机制名。（例如 "CRAM-MD5"、"GSSAPI"）。

返回：
表示 IANA 注册机制名的非 null 字符串。

hasInitialResponse

boolean hasInitialResponse()
确定此机制是否具有可选的初始响应。如果为 true，则调用者应该调用带有空数组的 evaluateChallenge() 以获得初始响应。

返回：
如果此机制具有初始响应，则返回 true。

evaluateChallenge

byte[] evaluateChallenge(byte[] challenge)
                         throws SaslException
评估 challenge 数据并生成一个响应。如果在验证处理期间接收到服务器的 challenge，则调用此方法来准备要提交给服务器的下一个合适响应。

参数：
challenge - 服务器发送的非 null challenge。该 challenge 数组的长度可以为零。
返回：
要发送给服务器的响应，可能为 null。如果 challenge 随附一个 "SUCCESS" 状态并且它只包含客户端更新其状态的数据，而没有需要送到服务器的响应，则返回 null。如果客户端要发送没有数据的响应，则该响应是一个零长度的 byte 数组。
抛出：
SaslException - 如果处理 challenge 或生成响应时发生错误。

isComplete

boolean isComplete()
确定验证交换是否已完成。可在任何时间调用此方法，但是通常在调用者接收到服务器关于交换已完成的指示（以特定于协议的方式通知）前不会调用此方法。

返回：
如果验证交换已完成，则返回 true；否则返回 false。

unwrap

byte[] unwrap(byte[] incoming,
              int offset,
              int len)
              throws SaslException
解包接收自服务器的 byte 数组。仅在验证交换已完成（即 isComplete() 返回 true）后，并且仅在验证交换已经协商将完整性和/或机密性作为保护级别时才调用此方法；否则会抛出 IllegalStateException。

incoming 是 SASL 缓冲区的内容（在 RFC 2222 中定义），没有表示长度的前导 4 个八位组字段。offset 和 len 指定了要使用的 incoming 部分。

参数：
incoming - 非 null 的 byte 数组，包含取自服务器的已编码字节。
offset - 所用字节在 incoming 中的开始位置。
len - 要使用的 incoming 中的字节数。
返回：
包含已解码字节的非 null byte 数组。
抛出：
SaslException - 如果无法成功解包 incoming。
IllegalStateException - 如果验证交换未完成，如果协商的保护级别既没有完整性，也没有机密性。

wrap

byte[] wrap(byte[] outgoing,
            int offset,
            int len)
            throws SaslException
包装要发送到服务器的 byte 数组。仅在验证交换已完成（即 isComplete() 返回 true）后，并且仅在验证交换已经协商将完整性和/或机密性作为保护级别时才调用此方法；否则会抛出 IllegalStateException。

此方法的结果会组成 SASL 缓冲区的内容（在 RFC 2222 中定义），没有表示长度的前导 4 个八位组字段。offset 和 len 指定了要使用的 outgoing 部分。

参数：
outgoing - 非 null 的 byte 数组，包含要编码的字节。
offset - 所用字节在 outgoing 中的开始位置。
len - 要使用的 outgoing 中的字节数。
返回：
包含已编码字节的非 null byte 数组。
抛出：
SaslException - 如果无法成功包装 outgoing。
IllegalStateException - 如果验证交换未完成，如果协商的保护级别既没有完整性，也没有机密性。

getNegotiatedProperty

Object getNegotiatedProperty(String propName)
获取已协商的属性。仅在验证交换已完成后（即 isComplete() 返回 true 时）才调用此方法；否则会抛出 IllegalStateException。

参数：
propName - 非 null 的属性名。
返回：
已协商的属性的值。如果为 null，则未协商该属性，或者该属性不适用于此机制。
抛出：
IllegalStateException - 如果未完成此验证交换。

dispose

void dispose()
             throws SaslException
处置 SaslClient 可能使用的所有系统资源或安全敏感信息。调用此方法会使 SaslClient 实例失效。此方法是幂等的。

抛出：
SaslException - 如果释放资源时遇到问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SaslClientFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
接口 SaslClientFactory

public interface SaslClientFactory

用于创建 SaslClient 实例的接口。实现此接口的类必须是线程安全的，并且可同时处理多个请求。它还必须具有不接受参数的公共构造方法。

客户端通常不直接访问此接口，而是使用 Sasl 静态方法访问此接口。但是，特定的环境可以提供和安装一个新的或不同的 SaslClientFactory。

从以下版本开始：
1.5
另请参见：
SaslClient, Sasl

方法摘要
SaslClient | createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
String[] | getMechanismNames(Map<String,?> props) 返回与指定的机制选择策略相符的机制的名称数组。

方法详细信息

createSaslClient

SaslClient createSaslClient(String[] mechanisms,
                            String authorizationId,
                            String protocol,
                            String serverName,
                            Map<String,?> props,
                            CallbackHandler cbh)
                            throws SaslException
使用提供的参数创建 SaslClient。

参数：
mechanisms - 要试用的机制名称的非 null 列表。每个名称都是 SASL 机制的 IANA 注册名。（例如 "GSSAPI"、"CRAM-MD5"）。
authorizationId - 用于授权的标识，可能为 null，与协议有关。如果为 null 或空，则服务器根据客户端的验证证书派生出一个授权 ID。SASL 验证成功完成后，就允许指定的实体进行访问。
protocol - 非 null 的协议（例如 "ldap"）字符串名，将为它执行验证。
serverName - 服务器的非 null 完全限定主机名，要对该服务器进行验证。
props - 可能为 null 的属性集，用于选择 SASL 机制并配置所选机制的验证交换。有关标准属性的列表，请参阅 Sasl 类。也可包括其他可能特定于机制的属性。忽略与所选机制无关的属性，包括带有非字符串键的所有映射条目。
cbh - SASL 机制使用的回调处理程序（可能为 null），以便为完成验证而从应用程序/库获得更多的信息。例如，SASL 机制可能需要从调用者获得验证 ID、密码和领域。使用 NameCallback 来请求验证 ID。使用 PasswordCallback 来请求密码。如果要从领域列表中选择，则使用 RealmChoiceCallback 来请求领域，如果必须输入领域，则使用 RealmCallback 来请求领域。
返回：
使用所提供参数创建的 SaslClient，可能为 null。如果为 null，则此工厂无法使用所提供的参数生成 SaslClient。
抛出：
SaslException - 如果因为错误而无法创建 SaslClient。

getMechanismNames

String[] getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

参数：
props - 可能为 null 的属性集，用于指定 SASL 机制的安全策略。例如，如果 props 包含值为 "true" 的属性 Sasl.POLICY_NOPLAINTEXT，则该工厂必须不返回任何易于受到简单被动式攻击危害的 SASL 机制。有关策略属性的完整列表，请参阅 Sasl 类。如果 props 中有与策略无关的属性则忽略该属性，包括带有非字符串键的所有映射条目。
返回：
非 null 的数组，包含 IANA 注册的 SASL 机制名。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SaslException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
类 SaslException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.io.IOException
                继承者  javax.security.sasl.SaslException
所有已实现的接口：
Serializable
直接已知子类：
AuthenticationException
public class SaslException
extends IOException

此类表示在使用 SASL 时所发生的错误。

从以下版本开始：
1.5
另请参见：
序列化表格

构造方法摘要
SaslException()
构造一个新的 SaslException 实例。
SaslException(String detail)
构造带详细消息的新 SaslException 实例。
SaslException(String detail, Throwable ex)
构造带详细消息和根异常的新 SaslException 实例。
方法摘要
Throwable | getCause() 返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。
Throwable | initCause(Throwable cause) 将此 throwable 的 cause 初始化为指定值。
String | toString() 返回此异常的字符串表示形式。
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getLocalizedMessage, getMessage, getStackTrace, printStackTrace, printStackTrace, printStackTrace, setStackTrace
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SaslException

public SaslException()
构造一个新的 SaslException 实例。根异常和详细消息为 null。

SaslException

public SaslException(String detail)
构造带详细消息的新 SaslException 实例。根异常为 null。

参数：
detail - 包含异常细节的字符串，可以为 null。
另请参见：
Throwable.getMessage()

SaslException

public SaslException(String detail,
                     Throwable ex)
构造带详细消息和根异常的新 SaslException 实例。例如，可能由于回调处理程序的问题而导致的 SaslException，如果该处理程序不支持请求的回调，则抛出 NoSuchCallbackException，如果该处理程序获取回调数据时有问题，则抛出 IOException。因此，SaslException 的根异常就是该回调处理程序所抛出的异常。

参数：
detail - 包含异常细节的字符串，可能为 null。
ex - 导致此异常的根异常，可能为 null。
另请参见：
Throwable.getMessage(), getCause()
方法详细信息

getCause

public Throwable getCause()
从类 Throwable 复制的描述
返回此 throwable 的 cause；如果 cause 不存在或未知，则返回 null。（该 Cause 是导致抛出此 throwable 的throwable。）

此实现返回由一个需要 Throwable 的构造方法提供的 cause，或者在创建之后通过 Throwable.initCause(Throwable) 方法进行设置的 cause。虽然通常不需要重写此方法，但子类可以重写它，以返回一个通过某些其他方式设置的 cause。这适用于在异常链（异常嵌套）机制被加入到 Throwable 之前存在“遗留 Throwable 链机制”的情况。注意，不必 重写任何 PrintStackTrace 方法，所有方法都调用 getCause 方法来确定 throwable 的 cause。

覆盖：
类 Throwable 中的 getCause
返回：
此 throwable 的 cause，如果 cause 不存在或是未知的，则返回 null。

initCause

public Throwable initCause(Throwable cause)
从类 Throwable 复制的描述
将此 throwable 的 cause 初始化为指定值。（该 Cause 是导致抛出此 throwable 的throwable。）

此方法至多可以调用一次。此方法通常从构造方法中调用，或者在创建 throwable 后立即调用。如果此 throwable 通过 Throwable.Throwable(Throwable) 或 Throwable.Throwable(String,Throwable) 创建，此方法甚至一次也不能调用。

覆盖：
类 Throwable 中的 initCause
参数：
cause - 原因（保存此 cause，以便以后通过 Throwable.getCause() 方法获取它）。（允许 null 值，指出 cause 是不存在的或是未知的。）
返回：
对此 Throwable 实例的引用。

toString

public String toString()
返回此异常的字符串表示形式。该字符串表示形式包含此异常的类名、其详细消息，并且如果有根异常，还包含该根异常的字符串表示形式。此字符串表示形式用于调试，意味着不以编程方式解释它。

覆盖：
类 Throwable 中的 toString
返回：
此异常的非 null 字符串表示形式。
另请参见：
Throwable.getMessage()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SaslServer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
接口 SaslServer

public interface SaslServer

以服务器的身份执行 SASL 验证。

为了执行具体 SASL 机制所定义的验证，服务器（例如 LDAP 服务器）要获得此类的一个实例。调用 SaslServer 实例上的方法可生成与 SaslServer 所实现的 SASL 机制相对应的 challenge。随着验证的进行，该实例会封装 SASL 服务器的验证交换状态。

以下是 LDAP 服务器如何使用 SaslServer 的一个示例。它首先为客户端请求的 SASL 机制获得一个 SaslServer 实例：

 SaslServer ss = Sasl.createSaslServer(mechanism,
     "ldap", myFQDN, props, callbackHandler);
然后可继续为验证使用该服务器。例如，假设 LDAP 服务器接收到一个 LDAP BIND 请求，其中包含 SASL 机制的名称和（可选的）初始响应。然后它可按如下方式使用服务器：
 while (!ss.isComplete()) {
     try {
         byte[] challenge = ss.evaluateResponse(response);
         if (ss.isComplete()) {
             status = ldap.sendBindResponse(mechanism, challenge, SUCCESS);
         } else {
             status = ldap.sendBindResponse(mechanism, challenge,
                   SASL_BIND_IN_PROGRESS);
             response = ldap.readBindRequest();
         }
     } catch (SaslException e) {
            status = ldap.sendErrorResponse(e);
            break;
     }
 }
 if (ss.isComplete() && status == SUCCESS) {
    String qop = (String) sc.getNegotiatedProperty(Sasl.QOP);
    if (qop != null
        && (qop.equalsIgnoreCase("auth-int")
            || qop.equalsIgnoreCase("auth-conf"))) {

      // Use SaslServer.wrap() and SaslServer.unwrap() for future
      // communication with client
        ldap.in = new SecureInputStream(ss, ldap.in);
        ldap.out = new SecureOutputStream(ss, ldap.out);
    }
 }

从以下版本开始：
1.5
另请参见：
Sasl, SaslServerFactory

方法摘要
void | dispose() 处置 SaslServer 可能使用的所有系统资源或安全敏感信息。
byte[] | evaluateResponse(byte[] response) 评估响应数据并生成一个 challenge。
String | getAuthorizationID() 报告此会话客户端的有效授权 ID。
String | getMechanismName() 返回此 SASL 服务器的 IANA 注册机制名。
Object | getNegotiatedProperty(String propName) 获取已协商的属性。
boolean | isComplete() 确定验证交换是否已完成。
byte[] | unwrap(byte[] incoming, int offset, int len) 解包接收自客户端的 byte 数组。
byte[] | wrap(byte[] outgoing, int offset, int len) 包装要发送到客户端的 byte 数组。

方法详细信息

getMechanismName

String getMechanismName()
返回此 SASL 服务器的 IANA 注册机制名。（例如 "CRAM-MD5"、"GSSAPI"）。

返回：
表示 IANA 注册机制名的非 null 字符串。

evaluateResponse

byte[] evaluateResponse(byte[] response)
                        throws SaslException
评估响应数据并生成一个 challenge。 如果在验证处理期间接收到客户端的响应，则调用此方法来准备要提交给客户端的下一个合适 challenge。如果验证已成功并且没有其他 challenge 数据要发送给客户端，则 challenge 为 null。如果必须通过向客户端发送 challenge 来继续进行验证，或者如果验证已成功但客户端需要处理 challenge 数据，则 challenge 是非 null 的。每次调用 evaluateResponse() 后都应该调用 isComplete() 来确定是否还需要客户端的进一步响应。

参数：
response - 客户端发送的非 null（但可能为空）响应。
返回：
要发送给客户端的 challenge，可能为 null。如果验证已成功并且没有其他 challenge 数据要发送给客户端，则 challenge 为 null。
抛出：
SaslException - 如果处理响应或生成 challenge 时发生错误。

isComplete

boolean isComplete()
确定验证交换是否已完成。通常在每次调用 evaluateResponse() 后调用此方法来确定验证是否已成功完成，还是应该继续进行。

返回：
如果验证交换已完成，则返回 true；否则返回 false。

getAuthorizationID

String getAuthorizationID()
报告此会话客户端的有效授权 ID。仅在 isComplete() 返回 true 时才可调用此方法。

返回：
客户端的授权 ID。
抛出：
IllegalStateException - 如果未完成此次验证会话

unwrap

byte[] unwrap(byte[] incoming,
              int offset,
              int len)
              throws SaslException
解包接收自客户端的 byte 数组。仅在验证交换已完成（即 isComplete() 返回 true）后，并且仅在验证交换已经协商将完整性和/或机密性作为保护级别时才调用此方法；否则会抛出 IllegalStateException。

incoming 是 SASL 缓冲区的内容（在 RFC 2222 中定义），没有表示长度的前导 4 个八位组字段。offset 和 len 指定了要使用的 incoming 部分。

参数：
incoming - 非 null 的 byte 数组，包含取自客户端的已编码字节。
offset - 所用字节在 incoming 中的开始位置。
len - 使用 incoming 中的字节数。
返回：
包含已解码字节的非 null byte 数组。
抛出：
SaslException - 如果无法成功解包 incoming。
IllegalStateException - 如果验证交换未完成，如果协商的保护级别既没有完整性，也没有机密性

wrap

byte[] wrap(byte[] outgoing,
            int offset,
            int len)
            throws SaslException
包装要发送到客户端的 byte 数组。仅在验证交换已完成（即 isComplete() 返回 true）后，并且仅在验证交换已经协商将完整性和/或机密性作为保护级别时才调用此方法；否则会抛出 SaslException。

此方法的结果会组成 SASL 缓冲区的内容（在 RFC 2222 中定义），没有表示长度的前导 4 个八位组字段。offset 和 len 指定了要使用的 outgoing 部分。

参数：
outgoing - 非 null 的 byte 数组，包含要编码的字节。
offset - 所用字节在 outgoing 中的开始位置。
len - 使用 outgoing 中的字节数。
返回：
包含已编码字节的非 null byte 数组。
抛出：
SaslException - 如果无法成功包装 outgoing。
IllegalStateException - 如果验证交换未完成，如果协商的保护级别既没有完整性，也没有机密性。

getNegotiatedProperty

Object getNegotiatedProperty(String propName)
获取已协商的属性。仅在验证交换已完成后（即当 isComplete() 返回 true）才调用此方法；否则会抛出 IllegalStateException。

参数：
propName - 属性
返回：
已协商属性的值。如果为 null，则未协商该属性，或者该属性不适用于此机制。
抛出：
IllegalStateException - 如果未完成此验证交换

dispose

void dispose()
             throws SaslException
处置 SaslServer 可能使用的所有系统资源或安全敏感信息。调用此方法会使 SaslServer 实例失效。此方法是幂等的。

抛出：
SaslException - 如果释放资源时遇到问题。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SaslServerFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.security.sasl
接口 SaslServerFactory

public interface SaslServerFactory

用于创建 SaslServer 实例的接口。实现此接口的类必须是线程安全的，并且可同时处理多个请求。它还必须具有不接受参数的公共构造方法。

服务器通常不直接访问此接口，而是使用 Sasl 静态方法访问此接口。但是，特定的环境可以提供和安装一个新的或不同的 SaslServerFactory。

从以下版本开始：
1.5
另请参见：
SaslServer, Sasl

方法摘要
SaslServer | createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。
String[] | getMechanismNames(Map<String,?> props) 返回与指定的机制选择策略相符的机制的名称数组。

方法详细信息

createSaslServer

SaslServer createSaslServer(String mechanism,
                            String protocol,
                            String serverName,
                            Map<String,?> props,
                            CallbackHandler cbh)
                            throws SaslException
使用提供的参数创建 SaslServer。如果无法使用提供的参数创建 SaslServer，则返回 null。如果因为错误而无法创建 SaslServer，则抛出 SaslException。

参数：
mechanism - SASL 机制的非 null IANA 注册名。（例如 "GSSAPI"、"CRAM-MD5"）。
protocol - 非 null 的协议（例如 "ldap"）字符串名，将为它执行验证。
serverName - 服务器的非 null 完全限定主机名，要对该服务器进行验证。
props - 可能为 null 的属性集，用于选择 SASL 机制并配置所选机制的验证交换。有关标准属性的列表，请参阅 Sasl 类。也可包括其他可能特定于机制的属性。忽略与所选机制无关的属性，包括带有非字符串键的所有映射条目。
cbh - SASL 机制使用的回调处理程序（可能为 null），以便为完成验证而从应用程序/库获得更多的信息。例如，SASL 机制可能需要从调用者获得验证 ID、密码和领域。使用 NameCallback 来请求验证 ID。使用 PasswordCallback 来请求密码。如果要从领域列表中选择，则使用 RealmChoiceCallback 来请求领域，如果必须输入领域，则使用 RealmCallback 来请求领域。
返回：
使用所提供参数创建的 SaslServer，可能为 null。如果为 null，则此工厂无法使用所提供的参数生成 SaslServer。
抛出：
SaslException - 如果因为错误而无法创建 SaslServer。

getMechanismNames

String[] getMechanismNames(Map<String,?> props)
返回与指定的机制选择策略相符的机制的名称数组。

参数：
props - 可能为 null 的属性集，用于指定 SASL 机制的安全策略。例如，如果 props 包含值为 "true" 的属性 Sasl.POLICY_NOPLAINTEXT，则该工厂必须不返回任何易于受到简单被动式攻击危害的 SASL 机制。有关策略属性的完整列表，请参阅 Sasl 类。如果 props 中有与策略无关的属性则忽略该属性，包括带有非字符串键的所有映射条目。
返回：
非 null 的数组，包含 IANA 注册的 SASL 机制名。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.security.sasl (Java 2 Platform SE 6)

 javax.security.sasl
接口
SaslClient
SaslClientFactory
SaslServer
SaslServerFactory
类
AuthorizeCallback
RealmCallback
RealmChoiceCallback
Sasl
异常
AuthenticationException
SaslException


javax.security.sasl (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.security.sasl

包含用于支持 SASL 的类和接口。

请参见：
描述

接口摘要
SaslClient | 以客户端的身份执行 SASL 验证。
SaslClientFactory | 用于创建 SaslClient 实例的接口。
SaslServer | 以服务器的身份执行 SASL 验证。
SaslServerFactory | 用于创建 SaslServer 实例的接口。

类摘要
AuthorizeCallback | 此回调由 SaslServer 使用，以确定某个实体（由已验证的验证 id 所标识）能否代表另一个实体（由授权 id 所标识）。
RealmCallback | SaslClient 和 SaslServer 使用此回调来获取领域信息。
RealmChoiceCallback | SaslClient 和 SaslServer 使用此回调获得给定领域选项列表的领域。
Sasl | 用于创建 SASL 客户端和服务器的静态类。

异常摘要
AuthenticationException | 此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。
SaslException | 此类表示在使用 SASL 时所发生的错误。

软件包 javax.security.sasl 的描述

包含用于支持 SASL 的类和接口。 此包为 SASL 机制定义了各种类和接口。开发人员使用它来添加对使用 SASL 的、基于连接的协议的验证支持。

SASL 概述

简单验证和安全层 (SASL) 指定了一种挑战-响应协议，使用该协议在客户端和服务器之间交换数据，从而实现验证和（可选）建立一个可承载后续通信的安全层。它与基于连接的协议，如 LDAPv3 或 IMAPv4 一起使用。RFC 2222 中描述了 SASL。

为 SASL 定义了各种机制。每种机制都为成功进行验证而定义了客户端和服务器之间必须交换的数据。特定机制所需的这种数据交换被称作其协议配置文件。下面是 Internet 标准团体已经定义的一些机制的示例。

  • DIGEST-MD5 (RFC 2831)。此机制定义了如何将 HTTP 摘要验证用作 SASL 机制。
  • Anonymous (RFC 2245)。此机制是匿名验证，其中无需使用证书。
  • External (RFC 2222)。此机制从外部源（如 TLS 或 IPsec）获得验证信息。
  • S/Key (RFC 2222)。此机制使用 MD4 摘要算法并基于共享密钥来交换数据。
  • GSSAPI (RFC 2222)。此机制使用 GSSAPI 来获得验证信息。

某些机制同时提供验证和建立安全层，而其他机制则只提供验证。Anonymous 和 S/Key 不提供给任何安全层。GSSAPI 和 DIGEST-MD5 允许进行安全层的协商。对于 External，由外部协议来确定安全层。

使用

此 API 的用户通常是为基于连接的协议（如 LDAPv3 和 IMAPv4）生成客户端库实现的开发人员，以及编写服务器（如 LDAP 服务器和 IMAP 服务器）的开发人员。编写客户端库的开发人员可使用 SaslClient 和 SaslClientFactory 接口。编写服务器的开发人员可使用 SaslServer 和 SaslServerFactory 接口。

这两组用户的每一组都可以进一步再分成两组：那些生成 SASL 机制和那些使用 SASL 机制的用户。SASL 机制的生产者需要提供这些接口的实现，而 SASL 机制的用户使用此包中的 API 来访问这些实现。

相关文档

有关如何使用此 API 的信息，请参阅 Java SASL Programming Guide。

从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.security.sasl 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.sasl 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.security.sasl.AuthorizeCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
    • javax.security.auth.callback.ChoiceCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmChoiceCallback
    • javax.security.sasl.Sasl
    • javax.security.auth.callback.TextInputCallback (implements javax.security.auth.callback.Callback, java.io.Serializable)
      • javax.security.sasl.RealmCallback
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.io.IOException
          • javax.security.sasl.SaslException
            • javax.security.sasl.AuthenticationException

接口分层结构

  • javax.security.sasl.SaslClient
  • javax.security.sasl.SaslClientFactory
  • javax.security.sasl.SaslServer
  • javax.security.sasl.SaslServerFactory
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.security.sasl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.security.sasl
的使用

使用 javax.security.sasl 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 使用的 javax.security.sasl 中的类
SaslClient
以客户端的身份执行 SASL 验证。
SaslClientFactory
用于创建 SaslClient 实例的接口。
SaslException
此类表示在使用 SASL 时所发生的错误。
SaslServer
以服务器的身份执行 SASL 验证。
SaslServerFactory
用于创建 SaslServer 实例的接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.sasl.AuthenticationException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.AuthenticationException
的使用

没有 javax.security.sasl.AuthenticationException 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.sasl.AuthorizeCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.AuthorizeCallback
的使用

没有 javax.security.sasl.AuthorizeCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.sasl.RealmCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.RealmCallback
的使用

没有 javax.security.sasl.RealmCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.sasl.RealmChoiceCallback 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.RealmChoiceCallback
的使用

没有 javax.security.sasl.RealmChoiceCallback 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.sasl.Sasl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.Sasl
的使用

没有 javax.security.sasl.Sasl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.sasl.SaslClient 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslClient
的使用

使用 SaslClient 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslClient 的使用

返回 SaslClient 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.sasl.SaslClientFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslClientFactory
的使用

使用 SaslClientFactory 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslClientFactory 的使用

返回变量类型为 SaslClientFactory 的类型的 javax.security.sasl 中的方法
static Enumeration<SaslClientFactory> Sasl.getSaslClientFactories()
获得用于生成 SaslClient 的已知工厂的枚举。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.security.sasl.SaslException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.security.sasl.SaslException
的使用

使用 SaslException 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslException 的使用

javax.security.sasl 中 SaslException 的子类
 class AuthenticationException
此异常由 SASL 机制实现抛出，指示由于和验证有关的原因（如无效的标识、口令 或密钥），SASL 交换已失败。

抛出 SaslException 的 javax.security.sasl 中的方法
static SaslClient | Sasl.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
SaslClient | SaslClientFactory.createSaslClient(String[] mechanisms, String authorizationId, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslClient。
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。
void | SaslClient.dispose() 处置 SaslClient 可能使用的所有系统资源或安全敏感信息。
void | SaslServer.dispose() 处置 SaslServer 可能使用的所有系统资源或安全敏感信息。
byte[] | SaslClient.evaluateChallenge(byte[] challenge) 评估 challenge 数据并生成一个响应。
byte[] | SaslServer.evaluateResponse(byte[] response) 评估响应数据并生成一个 challenge。
byte[] | SaslClient.unwrap(byte[] incoming, int offset, int len) 解包接收自服务器的 byte 数组。
byte[] | SaslServer.unwrap(byte[] incoming, int offset, int len) 解包接收自客户端的 byte 数组。
byte[] | SaslClient.wrap(byte[] outgoing, int offset, int len) 包装要发送到服务器的 byte 数组。
byte[] | SaslServer.wrap(byte[] outgoing, int offset, int len) 包装要发送到客户端的 byte 数组。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.sasl.SaslServer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslServer
的使用

使用 SaslServer 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslServer 的使用

返回 SaslServer 的 javax.security.sasl 中的方法
static SaslServer | Sasl.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 为指定机制创建一个 SaslServer。
SaslServer | SaslServerFactory.createSaslServer(String mechanism, String protocol, String serverName, Map<String,?> props, CallbackHandler cbh) 使用提供的参数创建 SaslServer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.security.sasl.SaslServerFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.security.sasl.SaslServerFactory
的使用

使用 SaslServerFactory 的软件包
javax.security.sasl 包含用于支持 SASL 的类和接口。

javax.security.sasl 中 SaslServerFactory 的使用

返回变量类型为 SaslServerFactory 的类型的 javax.security.sasl 中的方法
static Enumeration<SaslServerFactory> Sasl.getSaslServerFactories()
获得用于生成 SaslServer 的已知工厂的枚举。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AudioFileFormat (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 AudioFileFormat

java.lang.Object
    继承者  javax.sound.sampled.AudioFileFormat

public class AudioFileFormat
extends Object

AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。

AudioSystem 类包括确定音频文件格式的方法、从音频文件获得音频输入流的方法，以及从音频输入流写入音频文件的方法。

AudioFileFormat 对象可以包括属性的集合。属性是一对键和值：键的类型是 String，其关联属性值是任意对象。属性指定其他信息元数据（如作者、版权和文件期限）。属性是可选信息，不需要文件 reader 和文件 writer 实现来提供或识别属性。

下表列出了一些应该在实现中使用的常见属性：

属性键 | 值类型 | 描述
“期限” | Long | 以微秒为单位的文件回放期限
“作者” | String | 此文件的作者姓名
“标题” | String | 此文件的标题
“版权” | String | 版权消息
“日期” | Date | 录制或发行日期
“注释” | String | 任意文本

从以下版本开始：
1.3
另请参见：
AudioInputStream

嵌套类摘要
static class AudioFileFormat.Type
Type 类的实例表示音频文件的标准类型之一。
构造方法摘要
 | AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength) 构造音频文件格式对象。
 | AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties) 构造具有定义的属性集合的音频文件格式对象。
protected | AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength) 构造音频文件格式对象。
方法摘要
int | getByteLength() 获得以字节为单位的整个文件（不只是其音频数据）的大小。
AudioFormat | getFormat() 获得音频文件中包含的音频数据的格式。
int | getFrameLength() 获得文件中包含的音频数据的长度，以示例帧为单位表示。
Object | getProperty(String key) 获得键指定的属性值。
AudioFileFormat.Type | getType() 获得音频文件类型，如 WAVE 或 AU。
Map<String,Object> | properties() 获得不可修改的属性映射。
String | toString() 提供文件格式的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AudioFileFormat

protected AudioFileFormat(AudioFileFormat.Type type,
                          int byteLength,
                          AudioFormat format,
                          int frameLength)
构造音频文件格式对象。此受保护的构造方法旨在返回音频文件或受支持音频文件格式的信息时供文件读取服务的提供者使用。

参数：
type - 音频文件的类型
byteLength - 以字节为单位的文件长度，或 AudioSystem.NOT_SPECIFIED
format - 文件中包含的音频文件的格式
frameLength - 以示例帧为单位的音频数据的长度，或 AudioSystem.NOT_SPECIFIED
另请参见：
getType()

AudioFileFormat

public AudioFileFormat(AudioFileFormat.Type type,
                       AudioFormat format,
                       int frameLength)
构造音频文件格式对象。应用程序可以使用此公共构造方法描述请求的音频文件的属性。

参数：
type - 音频文件的类型
format - 文件中包含的音频数据的格式
frameLength - 以示例帧为单位的音频数据的长度，或 AudioSystem.NOT_SPECIFIED

AudioFileFormat

public AudioFileFormat(AudioFileFormat.Type type,
                       AudioFormat format,
                       int frameLength,
                       Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。应用程序可以使用此公共构造方法描述请求的音频文件的属性。复制属性映射以防对其进行更改。

参数：
type - 音频文件的类型
format - 文件中包含的音频数据的格式
frameLength - 以示例帧为单位的音频数据的长度，或 AudioSystem.NOT_SPECIFIED
properties - 带属性的 Map<String,Object> 对象
从以下版本开始：
1.5
方法详细信息

getType

public AudioFileFormat.Type getType()
获得音频文件类型，如 WAVE 或 AU。

返回：
音频文件类型
另请参见：
AudioFileFormat.Type.WAVE, AudioFileFormat.Type.AU, AudioFileFormat.Type.AIFF, AudioFileFormat.Type.AIFC, AudioFileFormat.Type.SND

getByteLength

public int getByteLength()
获得以字节为单位的整个文件（不只是其音频数据）的大小。

返回：
以字节为单位的音频文件的长度
另请参见：
AudioSystem.NOT_SPECIFIED

getFormat

public AudioFormat getFormat()
获得音频文件中包含的音频数据的格式。

返回：
音频数据的格式

getFrameLength

public int getFrameLength()
获得文件中包含的音频数据的长度，以示例帧为单位表示。

返回：
文件中音频数据的示例帧数
另请参见：
AudioSystem.NOT_SPECIFIED

properties

public Map<String,Object> properties()
获得不可修改的属性映射。属性的概念在类描述进一步解释。

返回：
包含所有属性的 Map<String,Object> 对象。如果不能识别任何属性，则返回空映射。
从以下版本开始：
1.5
另请参见：
getProperty(String)

getProperty

public Object getProperty(String key)
获得键指定的属性值。属性的概念在类描述进一步解释。

如果指定属性不是为特定文件格式定义的，则此方法返回 null。

参数：
key - 所需属性的键
返回：
具有指定键的属性值；如果属性不存在，则返回 null。
从以下版本开始：
1.5
另请参见：
properties

toString

public String toString()
提供文件格式的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
以字符串表示的文件格式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AudioFileFormat.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 AudioFileFormat.Type

java.lang.Object
    继承者  javax.sound.sampled.AudioFileFormat.Type
正在封闭类：
AudioFileFormat
public static class AudioFileFormat.Type
extends Object

Type 类的实例表示音频文件的标准类型之一。静态实例是为常见类型提供的。

字段摘要
static AudioFileFormat.Type | AIFC 指定 AIFF-C 文件。
static AudioFileFormat.Type | AIFF 指定 AIFF 文件。
static AudioFileFormat.Type | AU 指定 AU 文件。
static AudioFileFormat.Type | SND 指定 SND 文件。
static AudioFileFormat.Type | WAVE 指定 WAVE 文件。
构造方法摘要
AudioFileFormat.Type(String name, String extension)
构造文件类型。
方法摘要
boolean | equals(Object obj) 终止 equals 方法
String | getExtension() 获得此文件类型的常见文件扩展名。
int | hashCode() 终止 hashCode 方法
String | toString() 按文件类型的 String 表示形式提供文件类型的名称。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

WAVE

public static final AudioFileFormat.Type WAVE
指定 WAVE 文件。

AU

public static final AudioFileFormat.Type AU
指定 AU 文件。

AIFF

public static final AudioFileFormat.Type AIFF
指定 AIFF 文件。

AIFC

public static final AudioFileFormat.Type AIFC
指定 AIFF-C 文件。

SND

public static final AudioFileFormat.Type SND
指定 SND 文件。

构造方法详细信息

AudioFileFormat.Type

public AudioFileFormat.Type(String name,
                            String extension)
构造文件类型。

参数：
name - 命名文件类型的字符串
extension - 通常不用前导点标记文件类型的字符串。
方法详细信息

equals

public final boolean equals(Object obj)
终止 equals 方法

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终止 hashCode 方法

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public final String toString()
按文件类型的 String 表示形式提供文件类型的名称。

覆盖：
类 Object 中的 toString
返回：
文件类型的名称

getExtension

public String getExtension()
获得此文件类型的常见文件扩展名。

返回：
文件类型扩展名
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AudioFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 AudioFormat

java.lang.Object
    继承者  javax.sound.sampled.AudioFormat

public class AudioFormat
extends Object

AudioFormat 是在声音流中指定特定数据安排的类。通过检查以音频格式存储的信息，可以发现在二进制声音数据中解释位的方式。

每个数据行都有与其数据流相关的音频格式。源（回放）数据行的音频格式指示数据行期望接收输出的数据类型。对于目标（捕获）数据行，音频格式指定可以从该行读取的数据种类。当然，声音文件也有音频格式。AudioFileFormat 类封装 AudioFormat 以及其他特定于文件的信息。类似地，AudioInputStream 具有 AudioFormat。

AudioFormat 类适应多种常见声音文件编码技术，包括脉冲编码调制 (PCM)、mu-law 编码和 a-law 编码。这些编码技术是预先定义的，但服务提供者可以创建新的编码类型。特定格式使用的编码通过其 encoding 字段命名。

除编码外，音频格式还包括进一步指定具体数据安排的其他属性。这些属性包括信道数、采样速率、样本大小、字节顺序、帧速率和帧大小。声音可以有不同数量的音频信道：单声道有一个信道，立体声有两个信道。样本速率测量每信道、每秒钟采用的声压“快照”（样本）数。（如果声音是立体声，而不是单声道，则在每个瞬间实际测量两个样本：一个是左声道，另一个是右声道；不过，样本速率仍测量每个声道的数量，所以不管声道数是多少，速率都一样。这是该术语的标准用途。）样本大小指示用于存储每个快照的位数；典型值是 8 和 16。对于 16 位样本（或大于一个字节大小的任何其他样本），字节顺序很重要；每个样本中的字节要么以 "little-endian" 样式排列，要么以 "big-endian" 样式排列。对于类似 PCM 的编码，帧由在给定时间点上所有声道的样本集合组成，因此帧的大小（以字节为单位）总是等于样本大小（以字节为单位）乘以声道数。不过，使用其他种类的编码，帧可以包含整个系列样本的压缩数据包，以及其他非样本数据。对于这些编码，样本速率和样本大小在将数据解码到 PCM 之后引用该数据，所以它们与帧速率和帧大小完全不同。

AudioFormat 对象可以包括属性的集合。属性是一个键值对：键属于 String 类型，相关属性值可为任意对象。属性指定其他格式规范，如压缩格式的比特率。属性主要用作传送往返于服务提供者的其他音频格式信息的方法。因此，属性在 matches(AudioFormat) 方法中被忽略。不过，依靠已安装的服务提供者的方法（如 (AudioFormat, AudioFormat) isConversionSupported）可以考虑使用属性，具体取决于各自的服务提供者实现。

下表列出了服务提供者应该使用的一些常见属性（如果适用）：

属性键 | 值类型 | 描述
“比特率” | Integer | 以位每秒为单位的平均比特率
“可变比特率” | Boolean | 如果文件采用可变比特率 (VBR) 进行编码，则为 true
“音质” | Integer | 编码/转换质量，1 到 100

鼓励服务提供者（插件）的供应商寻找关于其他已经在第三方插件中建立的属性的信息，并遵循相同的约定。

从以下版本开始：
1.3
另请参见：
DataLine.getFormat(), AudioInputStream.getFormat(), AudioFileFormat, FormatConversionProvider

嵌套类摘要
static class AudioFormat.Encoding
Encoding 类命名用于音频流的数据表示形式的特定类型。
字段摘要
protected boolean | bigEndian 指示是以 big-endian 顺序还是 little-endian 顺序存储音频数据。
protected int | channels 使用此格式的音频信道数（单声道为 1，立体声为 2）。
protected AudioFormat.Encoding | encoding 此格式使用的音频编码技术。
protected float | frameRate 具有此格式的声音每秒播放和录制的帧数。
protected int | frameSize 每个具有此格式的声音帧包含的字节数。
protected float | sampleRate 具有此格式的声音每秒播放或录制的样本数。
protected int | sampleSizeInBits 每个具有此格式的声音样本中的位数。
构造方法摘要
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian)
构造具有给定参数的 AudioFormat。
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。
AudioFormat(float sampleRate, int sampleSizeInBits, int channels, boolean signed, boolean bigEndian)
构造具有线性 PCM 编码和给定参数的 AudioFormat。
方法摘要
int | getChannels() 获取信道数。
AudioFormat.Encoding | getEncoding() 获取此格式声音的编码类型。
float | getFrameRate() 获取以帧每秒为单位的帧速率。
int | getFrameSize() 获取以字节为单位的帧大小。
Object | getProperty(String key) 获取键指定的属性值。
float | getSampleRate() 获取样本速率。
int | getSampleSizeInBits() 获取样本的大小。
boolean | isBigEndian() 指示是以 big-endian 顺序还是以 little-endian 顺序存储音频数据。
boolean | matches(AudioFormat format) 指示此格式是否与指定格式匹配。
Map<String,Object> | properties() 获取不可修改的属性映射。
String | toString() 返回描述格式的字符串，如："PCM SIGNED 22050 Hz 16 bit mono big-endian"。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

encoding

protected AudioFormat.Encoding encoding
此格式使用的音频编码技术。

sampleRate

protected float sampleRate
具有此格式的声音每秒播放或录制的样本数。

sampleSizeInBits

protected int sampleSizeInBits
每个具有此格式的声音样本中的位数。

channels

protected int channels
使用此格式的音频信道数（单声道为 1，立体声为 2）。

frameSize

protected int frameSize
每个具有此格式的声音帧包含的字节数。

frameRate

protected float frameRate
具有此格式的声音每秒播放和录制的帧数。

bigEndian

protected boolean bigEndian
指示是以 big-endian 顺序还是 little-endian 顺序存储音频数据。

构造方法详细信息

AudioFormat

public AudioFormat(AudioFormat.Encoding encoding,
                   float sampleRate,
                   int sampleSizeInBits,
                   int channels,
                   int frameSize,
                   float frameRate,
                   boolean bigEndian)
构造具有给定参数的 AudioFormat。该编码指定用于表示数据的约定。其他参数在类描述中进一步解释。

参数：
encoding - 音频编码技术
sampleRate - 每秒的样本数
sampleSizeInBits - 每个样本中的位数
channels - 声道数（单声道 1 个，立体声 2 个，等等）
frameSize - 每帧中的字节数
frameRate - 每秒的帧数
bigEndian - 指示是否以 big-endian 字节顺序存储单个样本中的数据（false 意味着 little-endian）。

AudioFormat

public AudioFormat(AudioFormat.Encoding encoding,
                   float sampleRate,
                   int sampleSizeInBits,
                   int channels,
                   int frameSize,
                   float frameRate,
                   boolean bigEndian,
                   Map<String,Object> properties)
构造具有给定参数的 AudioFormat。该编码指定用于表示数据的约定。其他参数在类描述中进一步解释。

参数：
encoding - 音频编码技术
sampleRate - 每秒样本数
sampleSizeInBits - 每个样本中的位数
channels - 声道数（单声道为 1，立体声为 2，等等）
frameSize - 每帧包含的字节数
frameRate - 每秒帧数
bigEndian - 指示是否以 big-endian 字节顺序存储数据（false 意味着 little-endian）
properties - 包含格式属性的 Map<String,Object> 对象
从以下版本开始：
1.5

AudioFormat

public AudioFormat(float sampleRate,
                   int sampleSizeInBits,
                   int channels,
                   boolean signed,
                   boolean bigEndian)
构造具有线性 PCM 编码和给定参数的 AudioFormat。将帧大小设置为包含每个声道一个样本所需的字节数，将帧速率设置为样本速率。

参数：
sampleRate - 每秒的样本数
sampleSizeInBits - 每个样本中的位数
channels - 声道数（单声道 1 个，立体声 2 个）
signed - 指示数据是有符号的，还是无符号的
bigEndian - 指示是否以 big-endian 字节顺序存储单个样本中的数据（false 意味着 little-endian）。
方法详细信息

getEncoding

public AudioFormat.Encoding getEncoding()
获取此格式声音的编码类型。

返回：
编码类型
另请参见：
AudioFormat.Encoding.PCM_SIGNED, AudioFormat.Encoding.PCM_UNSIGNED, AudioFormat.Encoding.ULAW, AudioFormat.Encoding.ALAW

getSampleRate

public float getSampleRate()
获取样本速率。对于压缩格式，返回值是未压缩音频数据的样本速率。当此 AudioFormat 用于查询（如 AudioSystem.isConversionSupported）或功能（如 DataLine.Info.getFormats）时，AudioSystem.NOT_SPECIFIED 的样本速率意味着可以接受任何样本速率。当没有为此音频格式定义样本速率时，还会返回 AudioSystem.NOT_SPECIFIED。

返回：
每秒样本数，或 AudioSystem.NOT_SPECIFIED
另请参见：
getFrameRate(), AudioSystem.NOT_SPECIFIED

getSampleSizeInBits

public int getSampleSizeInBits()
获取样本的大小。对于压缩格式，返回值是未压缩音频数据的样本大小。当此 AudioFormat 用于查询（如 AudioSystem.isConversionSupported）或功能（如 DataLine.Info.getFormats）时，AudioSystem.NOT_SPECIFIED 的样本大小意味着可以接受任何样本大小。当没有为此音频格式定义样本大小时，还会返回 AudioSystem.NOT_SPECIFIED。

返回：
每个样本中的位数，或 AudioSystem.NOT_SPECIFIED
另请参见：
getFrameSize(), AudioSystem.NOT_SPECIFIED

getChannels

public int getChannels()
获取信道数。当此 AudioFormat 用于查询（如 AudioSystem.isConversionSupported）或功能（如 DataLine.Info.getFormats）时，AudioSystem.NOT_SPECIFIED 的返回值意味着可以接受任何（正）数量的信道。

返回：
信道数（单声道为 1，立体声为 2，等等），或 AudioSystem.NOT_SPECIFIED
另请参见：
AudioSystem.NOT_SPECIFIED

getFrameSize

public int getFrameSize()
获取以字节为单位的帧大小。当此 AudioFormat 用于查询（如 AudioSystem.isConversionSupported）或功能（如 DataLine.Info.getFormats）时，AudioSystem.NOT_SPECIFIED 的帧大小意味着可以接受任何帧大小。当没有为此音频格式定义帧大小时，还会返回 AudioSystem.NOT_SPECIFIED。

返回：
每帧字节数，或 AudioSystem.NOT_SPECIFIED
另请参见：
getSampleSizeInBits(), AudioSystem.NOT_SPECIFIED

getFrameRate

public float getFrameRate()
获取以帧每秒为单位的帧速率。当此 AudioFormat 用于查询（如 AudioSystem.isConversionSupported）或功能（如 DataLine.Info.getFormats）时，AudioSystem.NOT_SPECIFIED 的帧速率意味着可以接受任何帧速率。当没有为此音频格式定义帧速率时，还会返回 AudioSystem.NOT_SPECIFIED。

返回：
每秒帧数，或 AudioSystem.NOT_SPECIFIED
另请参见：
getSampleRate(), AudioSystem.NOT_SPECIFIED

isBigEndian

public boolean isBigEndian()
指示是以 big-endian 顺序还是以 little-endian 顺序存储音频数据。如果样本大小不超过一个字节，则返回值没有实际意义。

返回：
如果按 big-endian 字节顺序存储数据，则返回 true；如果按 little-endian 顺序，则返回 false

properties

public Map<String,Object> properties()
获取不可修改的属性映射。属性的概念在类描述进一步解释。

返回：
包含所有属性的 Map<String,Object> 对象。如果无法识别任何属性，则返回空映射。
从以下版本开始：
1.5
另请参见：
getProperty(String)

getProperty

public Object getProperty(String key)
获取键指定的属性值。属性的概念在类描述进一步解释。

如果指定属性不是为特定文件格式定义的，则此方法返回 null。

参数：
key - 所需属性的键
返回：
具有指定键的属性值；如果属性不存在，则返回 null。
从以下版本开始：
1.5
另请参见：
properties

matches

public boolean matches(AudioFormat format)
指示此格式是否与指定格式匹配。所谓匹配是指两种格式的编码、信道数、每个样本的位数以及每帧包含的字节数均必须相同。如果指定格式的采样速率值不为 AudioSystem.NOT_SPECIFIED（表示任何采样速率均匹配），则这两种格式还必须具有相同的采样速率。如果指定格式的帧速率不为 AudioSystem.NOT_SPECIFIED，则二者的帧速率必须大致相等。如果样本大小大于一个字节，则字节存储顺序（big-endian 或 little-endian）必须匹配。

参数：
format - 要测试是否匹配的格式
返回：
如果此格式与指定格式匹配，则返回 true；否则，返回 false。

toString

public String toString()
返回描述格式的字符串，如："PCM SIGNED 22050 Hz 16 bit mono big-endian"。字符串的内容可能会因 Java Sound 实现的不同而不同。

覆盖：
类 Object 中的 toString
返回：
描述格式参数的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AudioFormat.Encoding (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 AudioFormat.Encoding

java.lang.Object
    继承者  javax.sound.sampled.AudioFormat.Encoding
正在封闭类：
AudioFormat
public static class AudioFormat.Encoding
extends Object

Encoding 类命名用于音频流的数据表示形式的特定类型。编码除了信道数、样本频率、样本大小、帧速率、帧大小和字节顺序之外，还包括音频格式。

音频编码的常见类型是脉冲编码调制 (PCM)，它只是声音波形的线性（比例）表示形式。有了 PCM，每个样本中存储的数字都与该时间点上的声压瞬时振幅成比例。这些数字通常是有符号的或无符号的整数。除了 PCM 外，其他编码还有 mu-law 和 a-law，它们是常用于记录语音的声音振幅的非线性映射。

通过引用由此类创建的静态对象（如 PCM_SIGNED 或 PCM_UNSIGNED）之一，可以使用预定义的编码。服务提供者可以创建新的编码（如压缩音频格式或浮点 PCM 样本），并可通过 AudioSystem 类使用这些编码。

Encoding 类是静态类，所以具有相同编码的所有 AudioFormat 对象都将引用同一个对象（而不是同一类的不同实例）。这允许通过检查两种格式的编码是否相等进行匹配操作。

从以下版本开始：
1.3
另请参见：
AudioFormat, FormatConversionProvider

字段摘要
static AudioFormat.Encoding | ALAW 指定 a-law 编码数据。
static AudioFormat.Encoding | PCM_SIGNED 指定有符号的线性 PCM 数据。
static AudioFormat.Encoding | PCM_UNSIGNED 指定无符号的线性 PCM 数据。
static AudioFormat.Encoding | ULAW 指定 u-law 编码数据。
构造方法摘要
AudioFormat.Encoding(String name)
构造一个新编码。
方法摘要
boolean | equals(Object obj) 终止 equals 方法
int | hashCode() 终止 hashCode 方法
String | toString() 提供编码的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

PCM_SIGNED

public static final AudioFormat.Encoding PCM_SIGNED
指定有符号的线性 PCM 数据。

PCM_UNSIGNED

public static final AudioFormat.Encoding PCM_UNSIGNED
指定无符号的线性 PCM 数据。

ULAW

public static final AudioFormat.Encoding ULAW
指定 u-law 编码数据。

ALAW

public static final AudioFormat.Encoding ALAW
指定 a-law 编码数据。

构造方法详细信息

AudioFormat.Encoding

public AudioFormat.Encoding(String name)
构造一个新编码。

参数：
name - 新编码类型的名称
方法详细信息

equals

public final boolean equals(Object obj)
终止 equals 方法

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终止 hashCode 方法

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public final String toString()
提供编码的 String 表示形式。此 String 与传入构造方法的名称相同。对于预定义的编码，该名称类似于编码的变量（字段）名称。例如，PCM_SIGNED.toString() 返回名称 "pcm_signed"。

覆盖：
类 Object 中的 toString
返回：
编码名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AudioInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 AudioInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  javax.sound.sampled.AudioInputStream
所有已实现的接口：
Closeable
public class AudioInputStream
extends InputStream

音频输入流是具有指定音频格式和长度的输入流。长度用示例帧表示，不用字节表示。提供几种方法，用于从流读取一定数量的字节，或未指定数量的字节。音频输入流跟踪所读取的最后一个字节。可以跳过任意数量的字节以到达稍后的读取位置。音频输入流可支持标记。设置标记时，会记住当前位置，以便可以稍后返回到该位置。

AudioSystem 类包括许多操作 AudioInputStream 对象的方法。例如，这些方法可以让您：

  • 从外部音频文件、流或 URL 获得音频输入流
  • 从音频输入流写入外部文件
  • 将音频输入流转换为不同的音频格式

从以下版本开始：
1.3
另请参见：
AudioSystem, Clip.open(AudioInputStream)

字段摘要
protected AudioFormat | format 流中包含的音频数据的格式。
protected long | frameLength 此流的长度，以示例帧为单位。
protected long | framePos 此流中的当前位置，以示例帧为单位（从零开始）。
protected int | frameSize 每帧的大小，以字节为单位。
构造方法摘要
AudioInputStream(InputStream stream, AudioFormat format, long length)
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。
AudioInputStream(TargetDataLine line)
构造从指示的目标数据行读取数据的音频输入流。
方法摘要
int | available() 返回可不受阻塞地从此音频输入流中读取（或跳过）的最大字节数。
void | close() 关闭此音频输入流并释放与该流关联的所有系统资源。
AudioFormat | getFormat() 获得此音频输入流中声音数据的音频格式。
long | getFrameLength() 获得流的长度，以示例帧表示，而不是以字节表示。
void | mark(int readlimit) 标记此音频输入流中的当前位置。
boolean | markSupported() 测试此音频输入流是否支持 mark 和 reset 方法。
int | read() 从音频输入流读取数据下一个字节。
int | read(byte[] b) 从音频输入流读取一定数量的字节，并将其存储在缓冲区数组 b 中。
int | read(byte[] b, int off, int len) 从音频流读取指定的最大数量的数据字节，并将其放入给定的字节数组中。
void | reset() 将此音频输入流重新定位到上一次调用其 mark 方法时的位置。
long | skip(long n) 跳过并丢弃此音频输入流中指定数量的字节。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

format

protected AudioFormat format
流中包含的音频数据的格式。

frameLength

protected long frameLength
此流的长度，以示例帧为单位。

frameSize

protected int frameSize
每帧的大小，以字节为单位。

framePos

protected long framePos
此流中的当前位置，以示例帧为单位（从零开始）。

构造方法详细信息

AudioInputStream

public AudioInputStream(InputStream stream,
                        AudioFormat format,
                        long length)
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。

参数：
stream - 流，AudioInputStream 对象以该为基础
format - 此流的音频数据格式
length - 在此流中的数据长度（以示例帧为单位）

AudioInputStream

public AudioInputStream(TargetDataLine line)
构造从指示的目标数据行读取数据的音频输入流。该流的格式与目标数据行的格式相同，长度为 AudioSystem#NOT_SPECIFIED。

参数：
line - 此流从中获得数据的目标数据行。
另请参见：
AudioSystem.NOT_SPECIFIED
方法详细信息

getFormat

public AudioFormat getFormat()
获得此音频输入流中声音数据的音频格式。

返回：
描述此流的格式的音频格式对象

getFrameLength

public long getFrameLength()
获得流的长度，以示例帧表示，而不是以字节表示。

返回：
以示例帧为单位的长度

read

public int read()
         throws IOException
从音频输入流读取数据下一个字节。音频输入流的帧大小必须是一个字节，否则将抛出 IOException。

指定者：
类 InputStream 中的 read
返回：
数据的下一个字节；如果已到达流的末尾，则返回 -1
抛出：
IOException - 如果发生输入或输出错误
另请参见：
read(byte[], int, int), read(byte[]),

read

public int read(byte[] b)
         throws IOException
从音频输入流读取一定数量的字节，并将其存储在缓冲区数组 b 中。以整数形式返回实际读取的字节数。在输入数据可用、检测到流末尾或抛出异常之前，此方法将一直阻塞。

此方法将总是读取整数帧。如果数组的长度不是整数帧，则读取最大数量的 b.length - (b.length % frameSize) 字节。

覆盖：
类 InputStream 中的 read
参数：
b - 将数据读入的缓冲区
返回：
读入缓冲区的总字节数；如果因已到达流末尾而不再有更多数据，则返回 -1
抛出：
IOException - 如果发生输入或输出错误
另请参见：
read(byte[], int, int),
read(),
available()

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
从音频流读取指定的最大数量的数据字节，并将其放入给定的字节数组中。

此方法将总是读取整数帧。如果 len 未指定整数帧，则读取最大数量的 len - (len % frameSize) 字节。

覆盖：
类 InputStream 中的 read
参数：
b - 将数据读入的缓冲区
off - 从数组 b 的开头开始的偏移量，将从此处写入数据
len - 要读取的最大数量的字节
返回：
读入缓冲区的总字节数；如果因已到达流末尾而不再有更多数据，则返回 -1
抛出：
IOException - 如果发生输入或输出错误
另请参见：
read(byte[]), read(), skip(long), available()

skip

public long skip(long n)
          throws IOException
跳过并丢弃此音频输入流中指定数量的字节。

覆盖：
类 InputStream 中的 skip
参数：
n - 要跳过的请求数量的字节
返回：
跳过的实际字节数
抛出：
IOException - 如果发生输入或输出错误
另请参见：
read(), available()

available

public int available()
              throws IOException
返回可不受阻塞地从此音频输入流中读取（或跳过）的最大字节数。此限制只应用于对此音频输入流的 read 或 skip 方法的下一个调用；每次调用这些方法时该限制都可以有所不同。如果关闭此流，则可能抛出 IOException，这一点取决于基础流。

覆盖：
类 InputStream 中的 available
返回：
可以不受阻塞地从此音频输入流中读取的字节数
抛出：
IOException - 如果发生输入或输出错误
另请参见：
read(byte[], int, int), read(byte[]), read(), skip(long)

close

public void close()
           throws IOException
关闭此音频输入流并释放与该流关联的所有系统资源。

指定者：
接口 Closeable 中的 close
覆盖：
类 InputStream 中的 close
抛出：
IOException - 如果发生输入或输出错误

mark

public void mark(int readlimit)
标记此音频输入流中的当前位置。

覆盖：
类 InputStream 中的 mark
参数：
readlimit - 在标记位置变得无效之前可以读取的最大字节数。
另请参见：
reset(), markSupported()

reset

public void reset()
           throws IOException
将此音频输入流重新定位到上一次调用其 mark 方法时的位置。

覆盖：
类 InputStream 中的 reset
抛出：
IOException - 如果发生输入或输出错误。
另请参见：
mark(int), markSupported()

markSupported

public boolean markSupported()
测试此音频输入流是否支持 mark 和 reset 方法。

覆盖：
类 InputStream 中的 markSupported
返回：
如果此流支持 mark 和 reset 方法，则返回 true；否则返回 false
另请参见：
mark(int), reset()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AudioPermission (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 AudioPermission

java.lang.Object
    继承者  java.security.Permission
        继承者  java.security.BasicPermission
            继承者  javax.sound.sampled.AudioPermission
所有已实现的接口：
Serializable, Guard
public class AudioPermission
extends BasicPermission

AudioPermission 类表示对音频系统资源的访问权限。AudioPermission 包含一个目标名称，但是没有动作列表；您可以有指定的权限，也可以没有。

目标名称是音频权限的名称（参见下表）。这些名称遵守层次结构的属性命名约定。另外，可以用星号来表示所有的音频权限。

下表列出了可能的 AudioPermission 目标名称。该表准确描述了每个名称所允许的权限，也讨论了将该权限授予代码的风险。

权限目标名称 | 允许的权限 | 允许此权限所带来的风险
播放 | 通过系统上的一个或多个音频设备进行音频回放。允许应用程序获得并操作行和混频器，以供音频回放（呈现）使用。 | 在某些情况下，使用此权限可能影响其他应用程序，因为一行的音频可能与在系统上播放的其他音频混合，而且操作一个混频器将影响使用该混频器的所有行。
录制 | 通过系统上的一个或多个音频设备进行音频录制。允许应用程序获得并操作行和混频器，以供音频录制（捕获）使用。 | 在某些情况下，使用此权限可能影响其他应用程序，因为操作混频器会影响使用该混频器的所有行的音频。此权限可以启用窃听用户的 applet 或应用程序。

从以下版本开始：
1.3
另请参见：
序列化表格

构造方法摘要
AudioPermission(String name)
创建具有指定符号名（如 "play" 或 "record"）的 AudioPermission 对象。
AudioPermission(String name, String actions)
创建具有指定符号名（"play" 或 "record"）的 AudioPermission 对象。
方法摘要
从类 java.security.BasicPermission 继承的方法
equals, getActions, hashCode, implies, newPermissionCollection
从类 java.security.Permission 继承的方法
checkGuard, getName, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

AudioPermission

public AudioPermission(String name)
创建具有指定符号名（如 "play" 或 "record"）的 AudioPermission 对象。星号可用于指示所有音频权限。

参数：
name - 新 AudioPermission 的名称
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。

AudioPermission

public AudioPermission(String name,
                       String actions)
创建具有指定符号名（"play" 或 "record"）的 AudioPermission 对象。当前未使用 actions 参数，它应该为 null。

参数：
name - 新 AudioPermission 名称
actions - （未使用，应该为 null）
抛出：
NullPointerException - 如果 name 为 null。
IllegalArgumentException - 如果 name 为空。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AudioSystem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 AudioSystem

java.lang.Object
    继承者  javax.sound.sampled.AudioSystem

public class AudioSystem
extends Object

AudioSystem 类充当取样音频系统资源的入口点。此类允许查询和访问安装在系统上的混频器。AudioSystem 包括许多在不同格式间转换音频数据的方法，以及在音频文件和流之间进行转换的方法。它还提供不用显式处理混频器即可直接从 AudioSystem 获得 Line 的方法。

属性可用于指定特定行类型的默认混频器。系统属性和属性文件都要考虑。在 Sun 引用实现中，属性文件是 JRE 目录中的 "lib/sound.properties"。如果存在作为系统属性的属性并且存在于属性文件中，则优先使用系统属性。如果未指定任何属性，则在可用的设备中选择适当的默认值。属性文件的语法在 Properties.load 中指定。下表列出了可用的属性键和获得它们的方法：

属性键 | 接口 | 起作用的方法
javax.sound.sampled.Clip | Clip | getLine(javax.sound.sampled.Line.Info), getClip()
javax.sound.sampled.Port | Port | getLine(javax.sound.sampled.Line.Info)
javax.sound.sampled.SourceDataLine | SourceDataLine | getLine(javax.sound.sampled.Line.Info), getSourceDataLine(javax.sound.sampled.AudioFormat)
javax.sound.sampled.TargetDataLine | TargetDataLine | getLine(javax.sound.sampled.Line.Info), getTargetDataLine(javax.sound.sampled.AudioFormat)
属性值由提供者类名称和混频器名称组成，通过哈希标记 ("#") 进行分隔。提供者类名称是具体 mixer provider 类的完全限定名。混频器名称是与由 Mixer.Info 的 getName 方法返回的 String 匹配。可以省略类名称或混频器名称。如果只指定类名称，则尾部哈希标记是可选的。

如果指定了提供者类，并且可以从已安装的提供者成功地检索到它，则可从该提供者检索 Mixer.Info 对象的列表。否则，当这些混频器不提供后续匹配时，从包含所有可用 Mixer.Info 对象的 getMixerInfo() 中检索列表。

如果指定了混频器名称，则搜索所产生的 Mixer.Info 对象的列表：返回第一个具有匹配名称且其 Mixer 提供相应行接口的对象。如果未找到匹配的 Mixer.Info 对象，或未指定混频器名称，则返回得到的列表中提供相应行接口的第一个混频器。 例如，在调用 getLine 请求 Clip 实例时，值为 "com.sun.media.sound.MixerProvider#SunClip" 的属性 javax.sound.sampled.Clip 将具有以下结果：如果在已安装的混频器提供者列表中存在类 com.sun.media.sound.MixerProvider，则返回第一个具有名称 "SunClip" 的混频器中的第一个 Clip。如果无法找到，则返回指定提供者的第一个混频器中的第一个 Clip，不管名称如何。如果不存在，则返回所有混频器（由 getMixerInfo 返回）列表中具有名称 "SunClip" 的第一个 Mixer 中的第一个 Clip；或者，如果这个也找不到，则返回可以从所有混频器列表中找到的第一个 Mixer 的第一个 Clip。如果还是失败，则抛出 IllegalArgumentException。

从以下版本开始：
1.3
另请参见：
AudioFormat, AudioInputStream, Mixer, Line, Line.Info

字段摘要
static int NOT_SPECIFIED
代表未知数字值的整数。
方法摘要
static AudioFileFormat | getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioFileFormat | getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioFileFormat | getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。
static AudioFileFormat.Type[] | getAudioFileTypes() 获得由系统为其提供文件写入支持的文件类型。
static AudioFileFormat.Type[] | getAudioFileTypes(AudioInputStream stream) 获得系统可从指定音频输入流写入的文件类型。
static AudioInputStream | getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示编码的音频输入流。
static AudioInputStream | getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示格式的音频输入流。
static AudioInputStream | getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static AudioInputStream | getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。
static AudioInputStream | getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。
static Clip | getClip() 获得可用于回放音频文件或音频流的剪辑。
static Clip | getClip(Mixer.Info mixerInfo) 从指定混频器获得可用于回放音频文件或音频流的剪辑。
static Line | getLine(Line.Info info) 获得与指定 Line.Info 对象中的描述匹配的行。
static Mixer | getMixer(Mixer.Info info) 获得请求的音频混频器。
static Mixer.Info[] | getMixerInfo() 获得混频器信息对象的数组，该数组表示当前安装在系统上的音频混频器的集合。
static SourceDataLine | getSourceDataLine(AudioFormat format) 获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
static SourceDataLine | getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
static Line.Info[] | getSourceLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部源行的信息。
static TargetDataLine | getTargetDataLine(AudioFormat format) 获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
static TargetDataLine | getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。
static AudioFormat.Encoding[] | getTargetEncodings(AudioFormat.Encoding sourceEncoding) 使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。
static AudioFormat.Encoding[] | getTargetEncodings(AudioFormat sourceFormat) 使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。
static AudioFormat[] | getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。
static Line.Info[] | getTargetLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部目标行的信息。
static boolean | isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。
static boolean | isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat) 指示是否可从另一指定格式的音频输入流获得指定格式的音频输入流。
static boolean | isFileTypeSupported(AudioFileFormat.Type fileType) 指示系统是否提供指定文件类型的文件写入支持。
static boolean | isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定文件类型的音频文件。
static boolean | isLineSupported(Line.Info info) 指示系统是否支持与指定 Line.Info 对象匹配的行。
static int | write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
static int | write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示指定文件类型的音频文件的字节流写入所提供的输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NOT_SPECIFIED

public static final int NOT_SPECIFIED
代表未知数字值的整数。此值只适用于通常不采用负值的有符号的量。示例包括文件大小、帧大小、缓冲区大小和样本速率。许多 Java Sound 构造方法接受这些参数的 NOT_SPECIFIED 值。据文档记录，其他方法可能也接受或返回此值。

另请参见：
常量字段值
方法详细信息

getMixerInfo

public static Mixer.Info[] getMixerInfo()
获得混频器信息对象的数组，该数组表示当前安装在系统上的音频混频器的集合。

返回：
当前安装的混频器的信息对象的数组。如果系统上没有混频器可用，则返回长度为 0 的数组。
另请参见：
getMixer(javax.sound.sampled.Mixer.Info)

getMixer

public static Mixer getMixer(Mixer.Info info)
获得请求的音频混频器。

参数：
info - 表示所需混频器的 Mixer.Info 对象，或者为 null，表示系统默认混频器
返回：
请求的混频器
抛出：
SecurityException - 如果因为安全限制请求的混频器不可用
IllegalArgumentException - 如果信息对象不表示安装在系统上的混频器
另请参见：
getMixerInfo()

getSourceLineInfo

public static Line.Info[] getSourceLineInfo(Line.Info info)
获得关于已安装混频器所支持特定类型的全部源行的信息。

参数：
info - 指定请求其信息的行种类的 Line.Info 对象
返回：
Line.Info 对象的数组，这些对象描述与请求的类型匹配的源行。如果所有的匹配源行都不受支持，则返回长度为 0 的数组。
另请参见：
Mixer.getSourceLineInfo(Line.Info)

getTargetLineInfo

public static Line.Info[] getTargetLineInfo(Line.Info info)
获得关于已安装混频器所支持特定类型的全部目标行的信息。

参数：
info - 指定请求其信息的行种类的 Line.Info 对象
返回：
Line.Info 对象的数组，这些对象描述与请求的类型匹配的目标行。如果所有的匹配目标行都不受支持，则返回长度为 0 的数组。
另请参见：
Mixer.getTargetLineInfo(Line.Info)

isLineSupported

public static boolean isLineSupported(Line.Info info)
指示系统是否支持与指定 Line.Info 对象匹配的行。如果所有已安装的混频器都支持行，则说明行受支持。

参数：
info - 描述查询其支持的行的 Line.Info 对象
返回：
如果至少支持一个匹配行，则返回 true；否则返回 false
另请参见：
Mixer.isLineSupported(Line.Info)

getLine

public static Line getLine(Line.Info info)
                    throws LineUnavailableException
获得与指定 Line.Info 对象中的描述匹配的行。

如果请求 DataLine，且 info 是 DataLine.Info 的实例（至少指定一种完全限定的音频格式），则上一个数据行将用作返回的 DataLine 的默认格式。

如果定义了系统属性 javax.sound.sampled.Clip、javax.sound.sampled.Port、javax.sound.sampled.SourceDataLine 和 javax.sound.sampled.TargetDataLine，或在文件 "sound.properties" 中定义它们，则使用它们检索默认行。有关详细信息，请参阅类描述。 如果未设置相应属性，或尚未安装属性中请求的混频器，或不提供请求的行，则在所有安装的混频器中查询请求的行类型。从提供请求的行类型的第一个混频器中返回行。

参数：
info - 描述所需种类的行的 Line.Info 对象
返回：
请求的种类的行
抛出：
LineUnavailableException - 如果由于资源限制匹配行不可用
SecurityException - 如果由于安全限制匹配行不可用
IllegalArgumentException - 如果系统不是通过所有安装的混频器至少支持一个匹配 Line.Info 对象的行

getClip

public static Clip getClip()
                    throws LineUnavailableException
获得可用于回放音频文件或音频流的剪辑。返回的剪辑将通过默认系统混频器提供；如果不可能，则通过安装在系统中的支持 Clip 对象的任何其他混频器提供。

返回的剪辑必须用 open(AudioFormat) 或 open(AudioInputStream) 方法打开。

这是在内部使用 getMixer 和 getLine 的高级方法。

如果定义了系统属性 javax.sound.sampled.Clip，或在文件 "sound.properties" 中定义了它，则使用它检索默认剪辑。有关详细信息，请参阅类描述。

返回：
所需的剪辑对象
抛出：
LineUnavailableException - 如果由于资源限制剪辑对象不可用
SecurityException - 如果由于安全限制剪辑对象不可用
IllegalArgumentException - 如果不是通过所有安装的混频器至少支持一个剪辑实例
从以下版本开始：
1.5
另请参见：
getClip(Mixer.Info)

getClip

public static Clip getClip(Mixer.Info mixerInfo)
                    throws LineUnavailableException
从指定混频器获得可用于回放音频文件或音频流的剪辑。

返回的剪辑必须用 open(AudioFormat) 或 open(AudioInputStream) 方法打开。

这是在内部使用 getMixer 和 getLine 的高级方法。

参数：
mixerInfo - 表示所需混频器的 Mixer.Info 对象，或者为 null，表示系统默认混频器
返回：
指定混频器中的剪辑对象
抛出：
LineUnavailableException - 如果由于资源限制此混频器不提供剪辑
SecurityException - 如果由于安全限制此混频器不提供剪辑
IllegalArgumentException - 如果系统不是通过所有安装的混频器至少支持一个剪辑
从以下版本开始：
1.5
另请参见：
getClip()

getSourceDataLine

public static SourceDataLine getSourceDataLine(AudioFormat format)
                                        throws LineUnavailableException
获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。返回的行将通过默认系统混频器提供，如果有可能，则通过安装在系统中的支持匹配 SourceDataLine 对象的任何其他混频器提供。

返回的行应该用 open(AudioFormat) 或 open(AudioFormat, int) 方法打开。

这是在内部使用 getMixer 和 getLine 的高级方法。

返回的 SourceDataLine 的默认音频格式将使用 format 进行初始化。

如果定义了系统属性 javax.sound.sampled.SourceDataLine，或在文件 "sound.properties" 中定义了它，则使用它检索默认的源数据行。有关详细信息，请参阅类描述。

参数：
format - 指定返回行的受支持格式的 AudioFormat 对象，或者为 null，表示任何音频格式
返回：
所需的 SourceDataLine 对象
抛出：
LineUnavailableException - 如果由于资源限制匹配的源数据行不可用
SecurityException - 如果由于安全限制匹配的源数据行不可用
IllegalArgumentException - 如果系统不是通过所有安装的混频器至少支持一个支持指定音频格式的源数据行
从以下版本开始：
1.5
另请参见：
getSourceDataLine(AudioFormat, Mixer.Info)

getSourceDataLine

public static SourceDataLine getSourceDataLine(AudioFormat format,
                                               Mixer.Info mixerinfo)
                                        throws LineUnavailableException
获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。

返回的行应该用 open(AudioFormat) 或 open(AudioFormat, int) 方法打开。

这是在内部使用 getMixer 和 getLine 的高级方法。

返回的 SourceDataLine 的默认音频格式将使用 format 进行初始化。

参数：
format - 指定返回行的受支持音频格式的 AudioFormat 对象，或者为 null，表示任何音频格式
mixerinfo - 表示所需混频器的 Mixer.Info 对象，或者为null，表示系统默认混频器
返回：
所需的 SourceDataLine 对象
抛出：
LineUnavailableException - 如果由于资源限制指定混频器中的匹配源数据行不可用
SecurityException - 如果由于安全限制指定混频器中的匹配源数据行不可用
IllegalArgumentException - 如果指定的混频器不至少支持一个支持指定音频格式的源数据行
从以下版本开始：
1.5
另请参见：
getSourceDataLine(AudioFormat)

getTargetDataLine

public static TargetDataLine getTargetDataLine(AudioFormat format)
                                        throws LineUnavailableException
获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。返回的行将通过默认系统混频器提供，如果有可能，则通过安装在系统中的支持匹配 TargetDataLine 对象的任何其他混频器提供。

返回的行应该用 open(AudioFormat) 或 open(AudioFormat, int) 方法打开。

这是在内部使用 getMixer 和 getLine 的高级方法。

返回的 TargetDataLine 的默认音频格式将使用 format 进行初始化。

参数：
format - 指定返回行的受支持格式的 AudioFormat 对象，或者为 null，表示任何音频格式
返回：
所需的 TargetDataLine 对象
抛出：
LineUnavailableException - 如果由于资源限制匹配的目标数据行不可用
SecurityException - 如果由于安全限制匹配的目标数据行不可用
IllegalArgumentException - 如果系统不是通过所有安装的混频器至少支持一个支持指定音频格式的目标数据行
从以下版本开始：
1.5
另请参见：
getTargetDataLine(AudioFormat, Mixer.Info), AudioPermission

getTargetDataLine

public static TargetDataLine getTargetDataLine(AudioFormat format,
                                               Mixer.Info mixerinfo)
                                        throws LineUnavailableException
获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。

返回的行应该用 open(AudioFormat) 或 open(AudioFormat, int) 方法打开。

这是在内部使用 getMixer 和 getLine 的高级方法。

返回的 TargetDataLine 的默认音频格式将使用 format 进行初始化。

如果定义了系统属性 javax.sound.sampled.TargetDataLine，或在文件 "sound.properties" 中定义了它，则使用它检索默认的源数据行。有关详细信息，请参阅类描述。

参数：
format - 指定返回行的受支持音频格式的 AudioFormat 对象，或者为 null，表示任何音频格式
mixerinfo - 表示所需混频器的 Mixer.Info 对象，或者为null，表示系统默认混频器
返回：
所需的 TargetDataLine 对象
抛出：
LineUnavailableException - 如果由于资源限制指定混频器中的匹配目标数据行不可用
SecurityException - 如果由于安全限制指定混频器中的匹配目标数据行不可用
IllegalArgumentException - 如果指定的混频器不至少支持一个支持指定音频格式的目标数据行
从以下版本开始：
1.5
另请参见：
getTargetDataLine(AudioFormat), AudioPermission

getTargetEncodings

public static AudioFormat.Encoding[] getTargetEncodings(AudioFormat.Encoding sourceEncoding)
使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。

参数：
sourceEncoding - 查询其转换支持的编码
返回：
编码的数组。如果不支持 sourceEncoding，则返回长度为 0 的数组。否则，数组长度将至少为 1，表示 sourceEncoding（不转换）。

getTargetEncodings

public static AudioFormat.Encoding[] getTargetEncodings(AudioFormat sourceFormat)
使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。

参数：
sourceFormat - 查询其转换的音频格式
返回：
编码的数组。如果不支持 sourceFormat，则返回长度为 0 的数组。否则，数组长度将至少为 1，表示 sourceFormat 的编码（不转换）。

isConversionSupported

public static boolean isConversionSupported(AudioFormat.Encoding targetEncoding,
                                            AudioFormat sourceFormat)
指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。

参数：
targetEncoding - 转换后所需的编码
sourceFormat - 转换前的音频格式
返回：
如果支持转换，则返回 true；否则返回 false

getAudioInputStream

public static AudioInputStream getAudioInputStream(AudioFormat.Encoding targetEncoding,
                                                   AudioInputStream sourceStream)
通过转换提供的音频输入流，获得所指示编码的音频输入流。

参数：
targetEncoding - 转换后所需的编码
sourceStream - 要转换的流
返回：
所指示编码的音频输入流
抛出：
IllegalArgumentException - 如果不支持转换
另请参见：
getTargetEncodings(AudioFormat.Encoding), getTargetEncodings(AudioFormat), isConversionSupported(AudioFormat.Encoding, AudioFormat), getAudioInputStream(AudioFormat, AudioInputStream)

getTargetFormats

public static AudioFormat[] getTargetFormats(AudioFormat.Encoding targetEncoding,
                                             AudioFormat sourceFormat)
使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。

参数：
targetEncoding - 转换后所需的编码
sourceFormat - 转换前的音频格式
返回：
格式的数组。如果不支持任何指定编码的格式，则返回长度为 0 的数组。

isConversionSupported

public static boolean isConversionSupported(AudioFormat targetFormat,
                                            AudioFormat sourceFormat)
指示是否可从另一指定格式的音频输入流获得指定格式的音频输入流。

参数：
targetFormat - 转换后所需的音频格式
sourceFormat - 转换前的音频格式
返回：
如果支持转换，则返回 true；否则返回 false

getAudioInputStream

public static AudioInputStream getAudioInputStream(AudioFormat targetFormat,
                                                   AudioInputStream sourceStream)
通过转换提供的音频输入流，获得所指示格式的音频输入流。

参数：
targetFormat - 转换后所需的音频格式
sourceStream - 要转换的流
返回：
所指示格式的音频输入流
抛出：
IllegalArgumentException - 如果不支持转换
另请参见：
getTargetFormats(AudioFormat.Encoding, AudioFormat),
isConversionSupported(AudioFormat, AudioFormat),
getAudioInputStream(AudioFormat.Encoding, AudioInputStream)

getAudioFileFormat

public static AudioFileFormat getAudioFileFormat(InputStream stream)
                                          throws UnsupportedAudioFileException,
                                                 IOException
获得提供的音频输入流的音频文件格式。该流必须指向有效的音频文件数据。此方法的实现可能需要多个解析器来检查流，以确定这些解析器是否支持它。这些解析器必须能够标记流，读取足够多的数据来确定它们是否支持流，并且如果不支持，则将流的阅读指针重新设置到其初始位置。如果输入流不支持这些操作，则此方法可能会失败，并抛出 IOException。

参数：
stream - 应该从中提取文件格式信息的输入流
返回：
描述流的音频文件格式的 AudioFileFormat 对象
抛出：
UnsupportedAudioFileException - 如果流不指向系统识别的有效音频文件数据
IOException - 如果发生输入/输出异常
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getAudioFileFormat

public static AudioFileFormat getAudioFileFormat(URL url)
                                          throws UnsupportedAudioFileException,
                                                 IOException
获得指定 URL 的音频文件格式。该 URL 必须指向有效的音频文件数据。

参数：
url - 应该从中提取文件格式信息的 URL
返回：
描述音频文件格式的 AudioFileFormat 对象
抛出：
UnsupportedAudioFileException - 如果该 URL 不指向系统识别的有效音频文件数据
IOException - 如果发生输入/输出异常

getAudioFileFormat

public static AudioFileFormat getAudioFileFormat(File file)
                                          throws UnsupportedAudioFileException,
                                                 IOException
获得指定 File 的音频文件格式。该 File 必须指向有效的音频文件数据。

参数：
file - 应该从中提取文件格式信息的 File
返回：
描述音频文件格式的 AudioFileFormat 对象
抛出：
UnsupportedAudioFileException - 如果 File 不指向系统识别的有效文件数据
IOException - 如果发生 I/O 异常

getAudioInputStream

public static AudioInputStream getAudioInputStream(InputStream stream)
                                            throws UnsupportedAudioFileException,
                                                   IOException
从提供的输入流获得音频输入流。该流必须指向有效的音频文件数据。此方法的实现可能需要多个解析器来检查流，以确定这些解析器是否支持它。这些解析器必须能够标记流，读取足够多的数据来确定它们是否支持流，并且如果不支持，则将流的阅读指针重新设置到其初始位置。如果输入流不支持这些操作，则此方法可能会失败，并抛出 IOException。

参数：
stream - 应该从中构造 AudioInputStream 的输入流
返回：
基于输入流中包含的音频文件数据的 AudioInputStream 对象。
抛出：
UnsupportedAudioFileException - 如果流不指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getAudioInputStream

public static AudioInputStream getAudioInputStream(URL url)
                                            throws UnsupportedAudioFileException,
                                                   IOException
从提供的 URL 获得音频输入流。该 URL 必须指向有效的音频文件数据。

参数：
url - 应该为其构造 AudioInputStream 的 URL
返回：
基于由 URL 指向的音频文件数据的 AudioInputStream 对象
抛出：
UnsupportedAudioFileException - 如果 URL 不指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常

getAudioInputStream

public static AudioInputStream getAudioInputStream(File file)
                                            throws UnsupportedAudioFileException,
                                                   IOException
从提供的 File 获得音频输入流。该 File 必须指向有效的音频文件数据。

参数：
file - 应该为其构造 AudioInputStream 的 File
返回：
基于由 File 指向的音频文件数据的 AudioInputStream 对象
抛出：
UnsupportedAudioFileException - 如果 File 不指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常

getAudioFileTypes

public static AudioFileFormat.Type[] getAudioFileTypes()
获得由系统为其提供文件写入支持的文件类型。

返回：
唯一文件类型的数组。如果不支持任何文件类型，则返回长度为 0 的数组。

isFileTypeSupported

public static boolean isFileTypeSupported(AudioFileFormat.Type fileType)
指示系统是否提供指定文件类型的文件写入支持。

参数：
fileType - 查询其写入功能的文件类型
返回：
如果支持文件类型，则返回 true；否则返回 false

getAudioFileTypes

public static AudioFileFormat.Type[] getAudioFileTypes(AudioInputStream stream)
获得系统可从指定音频输入流写入的文件类型。

参数：
stream - 查询其音频文件类型支持的音频输入流
返回：
文件类型的数组。如果不支持任何文件类型，则返回长度为 0 的数组。

isFileTypeSupported

public static boolean isFileTypeSupported(AudioFileFormat.Type fileType,
                                          AudioInputStream stream)
指示是否可以从指示的音频输入流写入指定文件类型的音频文件。

参数：
fileType - 查询其写入功能的文件类型
stream - 查询其文件写入支持的流
返回：
如果此音频输入流支持文件类型，则返回 true；否则返回 false

write

public static int write(AudioInputStream stream,
                        AudioFileFormat.Type fileType,
                        OutputStream out)
                 throws IOException
将表示指定文件类型的音频文件的字节流写入所提供的输出流。有些文件类型需要将长度写入文件标题；此类文件不能从前往后写入，除非预先知道长度。如果音频文件类型中的长度为 AudioSystem.NOT_SPECIFIED，则尝试写入此类型的文件将失败，并抛出 IOException。

参数：
stream - 包含要写入文件的音频数据的音频输入流
fileType - 要写入的音频文件的种类
out - 应将文件数据写入其中的流
返回：
写入输出流的字节数
抛出：
IOException - 如果发生输入/输出异常
IllegalArgumentException - 如果系统不支持文件类型
另请参见：
isFileTypeSupported(javax.sound.sampled.AudioFileFormat.Type), getAudioFileTypes()

write

public static int write(AudioInputStream stream,
                        AudioFileFormat.Type fileType,
                        File out)
                 throws IOException
将表示指定文件类型的音频文件的字节流写入所提供的外部文件。

参数：
stream - 包含要写入文件的音频数据的音频输入流
fileType - 要写入的音频文件的种类
out - 应将文件数据写入其中的外部文件
返回：
写入文件的字节数
抛出：
IOException - 如果发生 I/O 错误
IllegalArgumentException - 如果系统不支持文件类型
另请参见：
isFileTypeSupported(javax.sound.sampled.AudioFileFormat.Type), getAudioFileTypes()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BooleanControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 BooleanControl

java.lang.Object
    继承者  javax.sound.sampled.Control
        继承者  javax.sound.sampled.BooleanControl

public abstract class BooleanControl
extends Control

BooleanControl 能够在影响行音频的两个可能的设置之间切换。这些设置都是 boolean 值（true 和 false）。图形用户界面可以表示由两个状态按钮、一个 on/off 开关、两个互斥按钮或一个复选框（在其他几种可能性之间）组成的控件。例如，按下一个按钮可能激活 MUTE 控件，以抑制行音频。

与其他 Control 子类一样，将提供一个为适合在用户界面中显示的值返回字符串标签的方法。

从以下版本开始：
1.3

嵌套类摘要
static class BooleanControl.Type
BooleanControl.Type 类的实例标识一种 boolean 控件。
构造方法摘要
protected | BooleanControl(BooleanControl.Type type, boolean initialValue) 构造一个具有给定参数的新 boolean 控件对象。
protected | BooleanControl(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel) 构造一个具有给定参数的新 boolean 控件对象。
方法摘要
String | getStateLabel(boolean state) 获得指定状态的标签。
boolean | getValue() 获得此控件的当前值。
void | setValue(boolean value) 设置控件的当前值。
String | toString() 提供控件的字符串表示形式
从类 javax.sound.sampled.Control 继承的方法
getType
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

BooleanControl

protected BooleanControl(BooleanControl.Type type,
                         boolean initialValue,
                         String trueStateLabel,
                         String falseStateLabel)
构造一个具有给定参数的新 boolean 控件对象。

参数：
type - 此 float 控件对象表示的控件类型
initialValue - 初始控件值
trueStateLabel - 由 true 表示的状态标签，如 "true" 或 "on"。
falseStateLabel - 由 false 表示的状态标签，如 "false" 或 "off"。

BooleanControl

protected BooleanControl(BooleanControl.Type type,
                         boolean initialValue)
构造一个具有给定参数的新 boolean 控件对象。true 和 false 状态的标签默认为 "true" 和 "false"。

参数：
type - 由此 float 控件对象表示的控件类型
initialValue - 初始控件值
方法详细信息

setValue

public void setValue(boolean value)
设置控件的当前值。默认实现只设置所指示的值。有些控件需要在受设置值的影响之前打开行。

参数：
value - 所需的新值。

getValue

public boolean getValue()
获得此控件的当前值。

返回：
当前值。

getStateLabel

public String getStateLabel(boolean state)
获得指定状态的标签。

返回：
指定状态的标签，如 true 的标签 "true" 或 "on"，或指示 false 的标签 "false" 或 "off"。

toString

public String toString()
提供控件的字符串表示形式

覆盖：
类 Control 中的 toString
返回：
字符串描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BooleanControl.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 BooleanControl.Type

java.lang.Object
    继承者  javax.sound.sampled.Control.Type
        继承者  javax.sound.sampled.BooleanControl.Type
正在封闭类：
BooleanControl
public static class BooleanControl.Type
extends Control.Type

BooleanControl.Type 类的实例标识一种 boolean 控件。静态实例是为常见类型提供的。

从以下版本开始：
1.3

字段摘要
static BooleanControl.Type | APPLY_REVERB 表示是否将回响应用于行的控件。
static BooleanControl.Type | MUTE 表示行的静音状态的控件。
构造方法摘要
protected BooleanControl.Type(String name)
构造新的 boolean 控件类型。
方法摘要
从类 javax.sound.sampled.Control.Type 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MUTE

public static final BooleanControl.Type MUTE
表示行的静音状态的控件。注意，静音状态不影响音量。

APPLY_REVERB

public static final BooleanControl.Type APPLY_REVERB
表示是否将回响应用于行的控件。注意，此控件的状态不影响行的回响设置，但确实会影响是否使用这些设置。

构造方法详细信息

BooleanControl.Type

protected BooleanControl.Type(String name)
构造新的 boolean 控件类型。

参数：
name - 新 boolean 控件类型的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Clip (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 Clip

所有超级接口：
DataLine, Line
public interface Clip
extends DataLine

Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。

因为数据是提前加载的且具有已知长度，所以可以设置一个剪辑，以便在其音频数据中的任何位置开始播放。也可以创建一个循环，以便在播放剪辑时该循环重复播放。使用起始和结尾示例帧以及应该播放循环的次数指定循环。

剪辑可以从支持此类型的行的 Mixer 中获得。打开剪辑时，将数据加载到剪辑中。

音频剪辑的回放可以使用 start 和 stop 方法开始和终止。这些方法不重新设置介质的位置；start 导致从回放最后停止的位置继续回放。要从剪辑的音频数据的开头重新启动回放，只需通过 setFramePosition(0) 调用 stop 即可，该方法可将介质重绕到剪辑的开头。

从以下版本开始：
1.3

嵌套类摘要
从接口 javax.sound.sampled.DataLine 继承的嵌套类/接口
DataLine.Info
字段摘要
static int LOOP_CONTINUOUSLY
指示循环应该无限期继续而不是在指定数量的循环后完成的值。
方法摘要
int | getFrameLength() 获得介质长度（以示例帧为单位）。
long | getMicrosecondLength() 获得介质持续时间（以微秒为单位）
void | loop(int count) 从当前位置开始循环回放。
void | open(AudioFormat format, byte[] data, int offset, int bufferSize) 打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。
void | open(AudioInputStream stream) 使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。
void | setFramePosition(int frames) 设置介质位置（以示例帧为单位）。
void | setLoopPoints(int start, int end) 设置将在循环中播放的第一个和最后一个示例帧。
void | setMicrosecondPosition(long microseconds) 设置介质位置（以微秒为单位）。
从接口 javax.sound.sampled.DataLine 继承的方法
available, drain, flush, getBufferSize, getFormat, getFramePosition, getLevel, getLongFramePosition, getMicrosecondPosition, isActive, isRunning, start, stop
从接口 javax.sound.sampled.Line 继承的方法
addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

字段详细信息

LOOP_CONTINUOUSLY

static final int LOOP_CONTINUOUSLY
指示循环应该无限期继续而不是在指定数量的循环后完成的值。

另请参见：
loop(int), 常量字段值
方法详细信息

open

void open(AudioFormat format,
          byte[] data,
          int offset,
          int bufferSize)
          throws LineUnavailableException
打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。使用所指示的格式和音频数据打开剪辑。如果此操作成功，则将行标记为 open 且向行的侦听器指派一个 OPEN 事件。

在已经打开的行上调用此方法是非法的，可能导致 IllegalStateException。

注意，有些行一旦关闭，无法重新打开。试图重新打开这样的行将始终导致 LineUnavailableException。

参数：
format - 所提供的音频数据的格式
data - 包含要加载到剪辑中的音频数据的字节数组
offset - 开始复制的点，用数组开头处的字节 表示
bufferSize - 从数组加载到剪辑的数据的字节 数
抛出：
LineUnavailableException - 如果因资源限制而无法打开行
IllegalArgumentException - 如果缓冲区大小不表示整数示例帧，或者如果未完全指定 format 或其无效
IllegalStateException - 如果已经打开行
SecurityException - 如果因安全限制而无法打开行
另请参见：
Line.close(), Line.isOpen(), LineListener

open

void open(AudioInputStream stream)
          throws LineUnavailableException,
                 IOException
使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。打开剪辑意味着它应该获得所有所需的系统资源并变得可操作。如果此操作输入流。如果此操作成功，则将行标记为 open 并向行的侦听器指派一个 OPEN 事件。

在已经打开的行上调用此方法是非法的，可能导致 IllegalStateException。

注意，有些行一旦关闭，无法重新打开。试图重新打开这样的行将始终导致 LineUnavailableException。

参数：
stream - 从中将音频数据读入剪辑的音频输入流
抛出：
LineUnavailableException - 如果因资源限制而无法打开行
IOException - 如果在读取流的过程中发生 I/O 异常
IllegalArgumentException - 如果未完全指定流的音频格式或其无效
IllegalStateException - 如果已经打开行
SecurityException - if 如果因安全限制而无法打开行
另请参见：
Line.close(), Line.isOpen(), LineListener

getFrameLength

int getFrameLength()
获得介质长度（以示例帧为单位）。

返回：
介质长度（以示例帧为单位）；如果未打开行，则返回 AudioSystem.NOT_SPECIFIED。
另请参见：
AudioSystem.NOT_SPECIFIED

getMicrosecondLength

long getMicrosecondLength()
获得介质持续时间（以微秒为单位）

返回：
以微秒表示的介质持续时间；如果未打开行，则返回 AudioSystem.NOT_SPECIFIED。
另请参见：
AudioSystem.NOT_SPECIFIED

setFramePosition

void setFramePosition(int frames)
设置介质位置（以示例帧为单位）。该位置从零开始；第一帧的帧数为零。剪辑下一次开始播放时，它将通过播放此位置的帧开始。

要获得以示例帧为单位的当前位置，使用 DataLine 的 getFramePosition 方法即可。

参数：
frames - 所需新介质的位置（以示例帧表示）

setMicrosecondPosition

void setMicrosecondPosition(long microseconds)
设置介质位置（以微秒为单位）。剪辑下一次开始播放时，它将在此位置开始。不保证精度级别。例如，实现可能根据当前帧的位置和音频示例帧速率计算微秒位置。应将以微秒为单位的精度限制为每示例帧的微秒数。

要获得以微秒为单位的当前位置，使用 DataLine 的 getMicrosecondPosition 方法即可。

参数：
microseconds - 所需新介质的位置（以微秒表示）

setLoopPoints

void setLoopPoints(int start,
                   int end)
设置将在循环中播放的第一个和最后一个示例帧。结束点必须大于或等于起点，并且两者都必须介于加载的介质大小以内。起点为 0 值意味着加载介质的开头。类似地，结束点为 -1 指示介质的最后一帧。

参数：
start - 以示例帧（从零开始）为单位的循环起始位置
end - 以示例帧（从零开始）为单位的循环结束位置，或为 -1 表示最后一帧
抛出：
IllegalArgumentException - 如果无法设置请求的循环点，这通常是因为一个或两个请求的点超出介质持续时间，或因为结束点在起点之前

loop

void loop(int count)
从当前位置开始循环回放。回放将持续到循环的结束点，然后返回到循环起始点 count 次，最后继续回放到剪辑的末尾。

如果在调用此方法时当前位置大于循环结束点，则回放只持续到剪辑的结尾，不用循环。

count 值为 0 指示任何当前循环都应该停止，并且回放应该持续到剪辑的末尾。在循环操作期间使用任何其他值调用此方法的行为都是不确定的。

如果在循环期间回放停止，则清除当前循环状态；后续循环和起始请求的行为将不受中断的循环操作的影响。

参数：
count - 回放应该从循环的结束位置返回到循环的起始位置的次数，或者为 LOOP_CONTINUOUSLY 指示循环在中断前应该一起持续
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompoundControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 CompoundControl

java.lang.Object
    继承者  javax.sound.sampled.Control
        继承者  javax.sound.sampled.CompoundControl

public abstract class CompoundControl
extends Control

CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。

从以下版本开始：
1.3

嵌套类摘要
static class CompoundControl.Type
CompoundControl.Type 内部类的实例标识一种组合控件。
构造方法摘要
protected CompoundControl(CompoundControl.Type type, Control[] memberControls)
构造一个具有给定参数的新组合控件对象。
方法摘要
Control[] | getMemberControls() 返回组成组合控件的成员控件集合。
String | toString() 提供控件的字符串表示形式
从类 javax.sound.sampled.Control 继承的方法
getType
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CompoundControl

protected CompoundControl(CompoundControl.Type type,
                          Control[] memberControls)
构造一个具有给定参数的新组合控件对象。

参数：
type - 由此组件控件对象表示的控件类型
memberControls - 成员控件的集合
方法详细信息

getMemberControls

public Control[] getMemberControls()
返回组成组合控件的成员控件集合。

返回：
成员控件的集合。

toString

public String toString()
提供控件的字符串表示形式

覆盖：
类 Control 中的 toString
返回：
字符串描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompoundControl.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 CompoundControl.Type

java.lang.Object
    继承者  javax.sound.sampled.Control.Type
        继承者  javax.sound.sampled.CompoundControl.Type
正在封闭类：
CompoundControl
public static class CompoundControl.Type
extends Control.Type

CompoundControl.Type 内部类的实例标识一种组合控件。静态实例是为常见类型提供的。

从以下版本开始：
1.3

构造方法摘要
protected CompoundControl.Type(String name)
构造一个新的组合控件类型。
方法摘要
从类 javax.sound.sampled.Control.Type 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

CompoundControl.Type

protected CompoundControl.Type(String name)
构造一个新的组合控件类型。

参数：
name - 新组合控件类型的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Control (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 Control

java.lang.Object
    继承者  javax.sound.sampled.Control
直接已知子类：
BooleanControl, CompoundControl, EnumControl, FloatControl
public abstract class Control
extends Object

Line 常常具有一个控件（如 gain 和 pan）集合，这些控件都会影响通过行传递的音频信号。Java Sound 的 Line 对象让您通过将其类作为参数传入 getControl 方法来获得特定的控件对象。

因为各种类型的控件有着不同的目的和特性，所以可以从定义每种控件的子类访问它们的所有功能。

从以下版本开始：
1.3
另请参见：
Line.getControls(), Line.isControlSupported(javax.sound.sampled.Control.Type)

嵌套类摘要
static class Control.Type
Type 类的实例表示控件的类型。
构造方法摘要
protected Control(Control.Type type)
构造具有指定类型的控件。
方法摘要
Control.Type | getType() 获得控件的类型。
String | toString() 获得描述控件类型及其当前状态的 String。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Control

protected Control(Control.Type type)
构造具有指定类型的控件。

参数：
type - 所需控件的种类
方法详细信息

getType

public Control.Type getType()
获得控件的类型。

返回：
控件类型。

toString

public String toString()
获得描述控件类型及其当前状态的 String。

覆盖：
类 Object 中的 toString
返回：
控件的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Control.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 Control.Type

java.lang.Object
    继承者  javax.sound.sampled.Control.Type
直接已知子类：
BooleanControl.Type, CompoundControl.Type, EnumControl.Type, FloatControl.Type
正在封闭类：
Control
public static class Control.Type
extends Object

Type 类的实例表示控件的类型。静态实例是为常见类型提供的。

构造方法摘要
protected Control.Type(String name)
构造具有指定名称的新控件类型。
方法摘要
boolean | equals(Object obj) 终止 equals 方法
int | hashCode() 终止 hashCode 方法
String | toString() 提供控件类型的 String 表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Control.Type

protected Control.Type(String name)
构造具有指定名称的新控件类型。该名称应该是一个描述性字符串，它适合在应用程序中添加控件标签（如 "Gain" 或 "Balance"）时使用。

参数：
name - 新控件类型的名称。
方法详细信息

equals

public final boolean equals(Object obj)
终止 equals 方法

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终止 hashCode 方法

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public final String toString()
提供控件类型的 String 表示形式。此 String 与传入构造方法的名称相同。

覆盖：
类 Object 中的 toString
返回：
该控件类型的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataLine (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 DataLine

所有超级接口：
Line
所有已知子接口：
Clip, SourceDataLine, TargetDataLine
public interface DataLine
extends Line

DataLine 将与介质相关的功能添加到其超接口 Line。此功能包括一些传输控制方法，这些方法可以启动、停止、消耗和刷新通过数据行传入的音频数据。数据行还可以报告介质的当前位置、音量和音频格式。数据行通过使用子接口 SourceDataLine 或 Clip 用于音频输出，这些子接口允许应用程序写入数据。类似地，音频输入由子接口 TargetDataLine 处理，该接口允许读取数据。

数据行有一个内部缓冲区，传入或传出数据在该缓冲区被加入队列。此内部缓冲区变空之前（通常因为已处理所有列队的数据），drain() 方法发生阻塞。flush() 方法将放弃内部缓冲区中的所有可用的已列队数据。

只要数据行开始还是停止数据的活动现象或数据的捕获，就会产生 START 和 STOP 事件。这些事件可能在响应特定请求时生成，也可能是不太直接的状态更改的结果。例如，如果对非活动数据行调用 start()，且数据可用于捕获或回放，则将在实际开始数据回放或捕获时生成 START 事件。或者，如果因为活动数据行的数据流受到限制而在数据呈现中发生间隙，则生成 STOP 事件。

混频器常常支持多条数据行的同步控制。可以通过混频器接口的 synchronize 方法来建立同步。关于更完整的描述，请参见 Mixer 接口的描述。

从以下版本开始：
1.3
另请参见：
LineEvent

嵌套类摘要
static class DataLine.Info
除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。
方法摘要
int | available() 获得当前可用于数据行内部缓冲区中处理的应用程序的数据字节数。
void | drain() 通过在清空数据行的内部缓冲区之前继续数据 I/O，排空数据行中的列队数据。
void | flush() 刷新数据行中已列队的数据。
int | getBufferSize() 获得将适合数据行的内部缓冲区的最大数据字节数。
AudioFormat | getFormat() 获得数据行的音频数据的当前格式（编码、样本频率、信道数，等等）。
int | getFramePosition() 获得音频数据中的当前位置（以样本帧为单位）。
float | getLevel() 获得行的当前音量级别。
long | getLongFramePosition() 获得音频数据中的当前位置（以样本帧为单位）。
long | getMicrosecondPosition() 获得音频数据中的当前位置（以微秒为单位）。
boolean | isActive() 指示该行是否正在进行活动 I/O（如回放或捕获）。
boolean | isRunning() 指示该行是否正在运行。
void | start() 允许某一数据行执行数据 I/O。
void | stop() 停止行。
从接口 javax.sound.sampled.Line 继承的方法
addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

方法详细信息

drain

void drain()
通过在清空数据行的内部缓冲区之前继续数据 I/O，排空数据行中的列队数据。在完成排空操作之前，此方法发生阻塞。因为这是一个阻塞方法，所以应小心使用它。如果在队列中有数据的终止行上调用 drain()，则在该行正在运行和数据队列变空之前，此方法将发生阻塞。如果通过一个线程调用 drain()，另一个线程继续填充数据队列，则该操作没有完成。此方法总是在关闭数据行时返回。

另请参见：
flush()

flush

void flush()
刷新数据行中已列队的数据。已刷新的数据将被丢弃。在某些情况下，不是所有已列队的数据都被丢弃。例如，混频器可以刷新特定输入行的缓冲区中的数据，但是输出缓冲区中尚未播放的数据（混合的结果）仍将被播放。如果想要在重新启动回放或捕获时跳过“陈旧的”数据，则可以在暂停某一数据行（正常情况）之后调用此方法。（刷新尚未停止的数据行是合法的，但在活动行上这样做很可能导致数据的间断，导致一个显而易见的单击。）

另请参见：
stop(), drain()

start

void start()
允许某一数据行执行数据 I/O。如果在已经运行的数据行上调用此方法，则此方法不执行任何操作。除非已刷新缓冲区中的数据，否则该行将从停止该数据行时未经处理的第一帧开始恢复 I/O。当开始音频捕获或回放时，生成 START 事件。

另请参见：
stop(), isRunning(), LineEvent

stop

void stop()
停止行。停止的行应该停止 I/O 活动。但是，如果行已被打开并且正在运行，它应该保留恢复活动所需的资源。停止的行应该保留其缓冲区中的任何音频数据而不是丢弃它，以便在恢复时，I/O 可以从原来停止的位置继续（如有可能）。（当然，此操作不保证在当前缓冲区之外永远不会有间断；如果停止的情况持续时间太长，则可能删除输入或输出示例。）如果需要，可以通过调用 flush 方法丢弃保留的数据。当音频捕获或回放停止时，生成 STOP 事件。

另请参见：
start(),
isRunning(),
flush(),
LineEvent

isRunning

boolean isRunning()
指示该行是否正在运行。默认值为 false。打开的行将在响应调用 start 方法而呈现第一个数据时开始运行，并可持续到响应调用 stop 或因为回放结束而表现为停止状态时为止。

返回：
如果该行正在运行，则返回 true；否则返回 false
另请参见：
start(), stop()

isActive

boolean isActive()
指示该行是否正在进行活动 I/O（如回放或捕获）。当非活动行变得活动时，它会向其侦听器发送一个 START 事件。类似地，当活动行变得不活动时，它将发送 STOP 事件。

返回：
如果行将在活动情况下捕获或呈现声音，则返回 true；否则返回 false
另请参见：
Line.isOpen(),
Line.addLineListener(javax.sound.sampled.LineListener),
Line.removeLineListener(javax.sound.sampled.LineListener),
LineEvent,
LineListener

getFormat

AudioFormat getFormat()
获得数据行的音频数据的当前格式（编码、样本频率、信道数，等等）。

如果行未打开且从来没有打开过，则返回默认格式。默认格式是一个特定音频格式实现，如果 DataLine.Info 对象（用于检索此 DataLine）至少指定一个完全限定的音频格式，则将最后一个格式用作默认格式。打开具有特定音频格式（如 SourceDataLine.open(AudioFormat)）的行将重写默认格式。

返回：
当前的音频数据格式
另请参见：
AudioFormat

getBufferSize

int getBufferSize()
获得将适合数据行的内部缓冲区的最大数据字节数。对于源数据行，这是将写入数据的缓冲区的大小。对于目标数据行，它是可以读取数据的缓冲区的大小。注意，这里使用的单位是字节，但它将始终对应于音频数据的样本帧数（整数）。

返回：
缓冲区的大小（以字节为单位）

available

int available()
获得当前可用于数据行内部缓冲区中处理的应用程序的数据字节数。对于源数据行，该数据字节数是可以不受阻塞地写入缓冲区的数据量。对于目标数据行，该数据字节数是可用于由应用程序读取的数据量。对于剪贴区，因为在打开剪贴区时将音频数据加载到缓冲区，并保留到关闭剪贴区时才收到通知，所以此值始终为 0。

注意，这里使用的单位是字节，但将始终对应于音频数据的样本帧数（整数）。

保证应用程序对从 available() 返回的字节数进行的读取或写入操作不受阻塞；不过，不保证试图读取或写入更多数据将发生阻塞。

返回：
可用的数据量（以字节为单位）

getFramePosition

int getFramePosition()
获得音频数据中的当前位置（以样本帧为单位）。帧位置测量从打开行以来由行捕获的样本帧数或在行中呈现的样本帧数。此返回值将包装大约 2^31 以后的帧。建议改用 getLongFramePosition。

返回：
打开行以来已经处理的帧数
另请参见：
getLongFramePosition()

getLongFramePosition

long getLongFramePosition()
获得音频数据中的当前位置（以样本帧为单位）。帧位置测量从打开行以来由行捕获的样本帧数或在行中呈现的样本帧数。

返回：
打开行以来已经处理的帧数
从以下版本开始：
1.5

getMicrosecondPosition

long getMicrosecondPosition()
获得音频数据中的当前位置（以微秒为单位）。微秒位置测量对应于从打开行以来由行捕获的样本帧数或在行中呈现的样本帧数的时间。不保证精度的级别。例如，某一实现可能根据当前帧的位置和音频样本帧比率来计算微秒位置 (microsecond position)。以微秒为单位的精度应限制为每样本帧的微秒数。

返回：
打开行以来所处理数据的微秒数

getLevel

float getLevel()
获得行的当前音量级别。此级别是对信号的当前振幅的测量，且不应该与音量控制的当前设置混淆。范围从 0.0（静）到 1.0（声音波形的最大可能振幅）。该单位测量线性振幅，不测量分贝数。

返回：
此行中信号的当前振幅，或 AudioSystem.NOT_SPECIFIED
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataLine.Info (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 DataLine.Info

java.lang.Object
    继承者  javax.sound.sampled.Line.Info
        继承者  javax.sound.sampled.DataLine.Info
正在封闭接口：
DataLine
public static class DataLine.Info
extends Line.Info

除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。这些信息包括：

  • 受数据行支持的音频格式
  • 其内部缓冲区的最小和最大大小
因为 Line.Info 了解它所描述的行的类，所以 DataLine.Info 对象可以描述 DataLine 子接口（比如 SourceDataLine、TargetDataLine 和 Clip）。通过将 DataLine.Info 的适当实例作为参数传递到某一方法（如 Mixer.getLine(Line.Info)），可以查询任何类型的行混频器。

从以下版本开始：
1.3
另请参见：
Line.Info

构造方法摘要
DataLine.Info(Class<?> lineClass, AudioFormat format)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。
DataLine.Info(Class<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。
DataLine.Info(Class<?> lineClass, AudioFormat format, int bufferSize)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。
方法摘要
AudioFormat[] | getFormats() 获得数据行支持的音频格式的集合。
int | getMaxBufferSize() 获得数据行支持的最大缓冲区大小。
int | getMinBufferSize() 获得数据行支持的最小缓冲区大小。
boolean | isFormatSupported(AudioFormat format) 指示此数据行是否支持特定的音频格式。
boolean | matches(Line.Info info) 确定指定的信息对象是否与此对象匹配。
String | toString() 获得数据行信息的文本描述。
从类 javax.sound.sampled.Line.Info 继承的方法
getLineClass
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DataLine.Info

public DataLine.Info(Class<?> lineClass,
                     AudioFormat[] formats,
                     int minBufferSize,
                     int maxBufferSize)
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。此构造方法通常在返回受支持行的信息时由混频器实现使用。

参数：
lineClass - 该信息对象描述的数据行的类
formats - 受支持格式的集合
minBufferSize - 数据行支持的最小缓冲区大小（以字节为单位）
maxBufferSize - 数据行支持的最大缓冲区大小（以字节为单位）

DataLine.Info

public DataLine.Info(Class<?> lineClass,
                     AudioFormat format,
                     int bufferSize)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。此构造方法通常由应用程序用于描述所需的行。

参数：
lineClass - 该信息对象描述的数据行的类
format - 所需的格式
bufferSize - 所需的缓冲区大小（以字节为单位）

DataLine.Info

public DataLine.Info(Class<?> lineClass,
                     AudioFormat format)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。此构造方法通常由应用程序用于描述所需的行。

参数：
lineClass - 该信息对象所描述的数据行的类
format - 所需的格式
方法详细信息

getFormats

public AudioFormat[] getFormats()
获得数据行支持的音频格式的集合。注意，isFormatSupported(AudioFormat) 可能为某种其他格式返回 true，这些格式是从 getFormats() 返回的集合中丢失的。反之则不然：保证 isFormatSupported(AudioFormat) 为所有由 getFormats() 返回的格式返回 true。 如果 AudioFormat 实例中的某些字段不适用该格式，或者如果该格式不支持对字段使用大量的值，则可以将这些字段设置为 NOT_SPECIFIED。例如，最多支持 64 个信道的多信道设备可以将此方法返回的 AudioFormat 实例中的信道字段设置为 NOT_SPECIFIED。

返回：
受支持的音频格式的集合。
另请参见：
isFormatSupported(AudioFormat)

isFormatSupported

public boolean isFormatSupported(AudioFormat format)
指示此数据行是否支持特定的音频格式。如果指定格式与任何受支持的格式匹配，则此方法的默认实现只返回 true。

参数：
format - 查询其是否受支持的音频格式。
返回：
如果该格式受支持，则返回 true；否则返回 false
另请参见：
getFormats(), AudioFormat.matches(javax.sound.sampled.AudioFormat)

getMinBufferSize

public int getMinBufferSize()
获得数据行支持的最小缓冲区大小。

返回：
以字节为单位的最小缓冲区大小，或 AudioSystem.NOT_SPECIFIED

getMaxBufferSize

public int getMaxBufferSize()
获得数据行支持的最大缓冲区大小。

返回：
以字节为单位的最大缓冲区大小，或 AudioSystem.NOT_SPECIFIED

matches

public boolean matches(Line.Info info)
确定指定的信息对象是否与此对象匹配。若要匹配，则必须满足超类匹配要求。此外，该对象的最小缓冲区大小必须至少与指定对象的缓冲区大小相同，其最大缓冲区大小必须至多与指定对象的缓冲区大小相同，并且它的所有格式都必须与指定对象支持的格式匹配。

覆盖：
类 Line.Info 中的 matches
参数：
info - 要与此对象比较的 info 对象
返回：
如果此对象与指定的对象匹配，则返回 true；否则返回 false。

toString

public String toString()
获得数据行信息的文本描述。

覆盖：
类 Line.Info 中的 toString
返回：
字符串描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EnumControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 EnumControl

java.lang.Object
    继承者  javax.sound.sampled.Control
        继承者  javax.sound.sampled.EnumControl

public abstract class EnumControl
extends Control

EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。在图形用户界面中，这样的控件可由一组按钮表示，每个按钮都选择一个值或设置。例如，回响控件可能提供几个预置的回响设置，而不是连续提供应由 FloatControl 对象表示的可调整的排序参数。

只在两个设置之间提供选择的控件常被实现为一个 BooleanControl，而在某些可计量维度之间提供一组值的控件可能被实现为具有粗分辨率的 FloatControl。不过，EnumControl 的关键特性是，返回的值是任意对象，而不是数字值或 boolean 值。这意味着每个返回的对象都可以提供更多信息。例如，REVERB 控件的设置是可以查询用于每个设置的参数值的 ReverbType 实例。

从以下版本开始：
1.3

嵌套类摘要
static class EnumControl.Type
EnumControl.Type 内部类的实例标识了某种枚举控件。
构造方法摘要
protected EnumControl(EnumControl.Type type, Object[] values, Object value)
构造一个具有给定参数的新枚举控件对象。
方法摘要
Object | getValue() 获得此控件的当前值。
Object[] | getValues() 返回此控件的可能值的集合。
void | setValue(Object value) 设置控件的当前值。
String | toString() 提供该控件的字符串表示形式。
从类 javax.sound.sampled.Control 继承的方法
getType
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

EnumControl

protected EnumControl(EnumControl.Type type,
                      Object[] values,
                      Object value)
构造一个具有给定参数的新枚举控件对象。

参数：
type - 此枚举控件对象表示的控件类型
values - 该控件的可能值的集合
value - 初始控件值
方法详细信息

setValue

public void setValue(Object value)
设置控件的当前值。默认实现只根据指示设置值。如果指示的值不受支持，则抛出 IllegalArgumentException。有些控件要求提前打开行，以防受设置值受影响。

参数：
value - 所需的新值
抛出：
IllegalArgumentException - 如果指示的值不在允许的范围内

getValue

public Object getValue()
获得此控件的当前值。

返回：
当前值

getValues

public Object[] getValues()
返回此控件的可能值的集合。

返回：
可能值的集合

toString

public String toString()
提供该控件的字符串表示形式。

覆盖：
类 Control 中的 toString
返回：
字符串描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EnumControl.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 EnumControl.Type

java.lang.Object
    继承者  javax.sound.sampled.Control.Type
        继承者  javax.sound.sampled.EnumControl.Type
正在封闭类：
EnumControl
public static class EnumControl.Type
extends Control.Type

EnumControl.Type 内部类的实例标识了某种枚举控件。静态实例是为常见类型提供的。

从以下版本开始：
1.3
另请参见：
EnumControl

字段摘要
static EnumControl.Type REVERB
表示对一组可能的回响设置的控件。
构造方法摘要
protected EnumControl.Type(String name)
构造一个新的枚举控件类型。
方法摘要
从类 javax.sound.sampled.Control.Type 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

REVERB

public static final EnumControl.Type REVERB
表示对一组可能的回响设置的控件。每个回响设置都是通过 ReverbType 类的一个实例描述的。（要访问这些设置，可对类型 REVERB 的枚举控件调用 EnumControl.getValues()。）

构造方法详细信息

EnumControl.Type

protected EnumControl.Type(String name)
构造一个新的枚举控件类型。

参数：
name - 新枚举控件类型的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FloatControl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 FloatControl

java.lang.Object
    继承者  javax.sound.sampled.Control
        继承者  javax.sound.sampled.FloatControl

public abstract class FloatControl
extends Control

FloatControl 对象提供对浮点值范围的控制。Float 控件常常通过滑块或旋钮之类的可连续调节对象在图形用户界面中表示。FloatControl 的具体子类实现诸如 gain 和 pan 之类的控件，这些控件会以应用程序可以操作的方式影响行的音频信号。FloatControl.Type 内部类提供用于标识一些常见 float 控件的那些类型的静态实例。

FloatControl 抽象类提供设置和获取控件的当前浮点值的方法。其他方法获得可能的值范围和控件的分辨率（所返回值之间的最小增量）。一些 float 控件允许将新值延伸至指定时间段。FloatControl 还包括一些方法，这些方法返回用于该控件的最大、最小和中点位置的字符串标签。

从以下版本开始：
1.3
另请参见：
Line.getControls(), Line.isControlSupported(javax.sound.sampled.Control.Type)

嵌套类摘要
static class FloatControl.Type
FloatControl.Type 内部类的实例标识了某种 float 控件。
构造方法摘要
protected | FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units) 构造具有给定参数的新 float 控件对象。
protected | FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel) 构造具有给定参数的新 float 控件对象
方法摘要
float | getMaximum() 获得所允许的最大值。
String | getMaxLabel() 获得最大值的标签，如 "Right" 或 "Full"。
String | getMidLabel() 获得中点值的标签，如 "Center" 或 "Default"。
float | getMinimum() 获得所允许的最小值。
String | getMinLabel() 获得最小值的标签，如 "Left" 或 "Off"。
float | getPrecision() 获得该控件的分辨率或粒度，以该控件测量的单位为准。
String | getUnits() 获得表示控件值的单位标签，如 "dB" 或 "frames per second"。
int | getUpdatePeriod() 获得最小时间间隔（以微秒为单位），在此段时间内，控件值可以在移动期间更改。
float | getValue() 获得此控件的当前值。
void | setValue(float newValue) 设置控件的当前值。
void | shift(float from, float to, int microseconds) 在整个指定的时间内线性地将控件值从初始值更改为最终值，以微秒为单位进行指定。
String | toString() 提供控件的字符串表示形式
从类 javax.sound.sampled.Control 继承的方法
getType
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FloatControl

protected FloatControl(FloatControl.Type type,
                       float minimum,
                       float maximum,
                       float precision,
                       int updatePeriod,
                       float initialValue,
                       String units,
                       String minLabel,
                       String midLabel,
                       String maxLabel)
构造具有给定参数的新 float 控件对象

参数：
type - 由此 float 控件对象表示的控件种类
minimum - 该控件允许的最小值
maximum - 该控件允许的最大值
precision - 该控件的分辨率或粒度。这是离散有效值之间的增量大小。
updatePeriod - 最小时间间隔（以微秒为单位），在此段时间内，控件可以在 shift 期间从一个离散值更改为下一个离散值
initialValue - 构造控件时该控件的起始值
units - 用来表示控件值的单位的标签，如 "dB" 或 "frames per second"
minLabel - 最小值的标签，如 "Left" 或 "Off"
midLabel - 中点值的标签，如 "Center" 或 "Default"
maxLabel - 最大值的标签，如 "Right" 或 "Full"

FloatControl

protected FloatControl(FloatControl.Type type,
                       float minimum,
                       float maximum,
                       float precision,
                       int updatePeriod,
                       float initialValue,
                       String units)
构造具有给定参数的新 float 控件对象。将最小、最大和中点值的标签设置为零长度字符串。

参数：
type - 由此 float 控件对象表示的控件种类
minimum - 该控件允许的最小值
maximum - 该控件允许的最大值
precision - 该控件的分辨率或粒度。这是离散有效值之间的增量大小。
updatePeriod - 最小时间间隔（以微秒为单位），在此段时间内，控件可以在 shift 期间从一个离散值更改为下一个离散值
initialValue - 构造控件时该控件的起始值
units - 表示控件值的音位标签，如 "dB" 或 "frames per second"
方法详细信息

setValue

public void setValue(float newValue)
设置控件的当前值。默认实现只根据指示设置该值。如果指示的值大于最大值，或小于最小值，则抛出 IllegalArgumentException。有些控件要求提前打开它们的行，以防受设置值受影响。

参数：
newValue - 所需的新值
抛出：
IllegalArgumentException - 如果指示的值不在允许的范围内

getValue

public float getValue()
获得此控件的当前值。

返回：
当前值

getMaximum

public float getMaximum()
获得所允许的最大值。

返回：
所允许的最大值

getMinimum

public float getMinimum()
获得所允许的最小值。

返回：
所允许的最小值

getUnits

public String getUnits()
获得表示控件值的单位标签，如 "dB" 或 "frames per second"。

返回：
单位标签；如果没有标签，则返回零长度字符串

getMinLabel

public String getMinLabel()
获得最小值的标签，如 "Left" 或 "Off"。

返回：
最小值标签；如果没有设置标签，则返回零长度字符串

getMidLabel

public String getMidLabel()
获得中点值的标签，如 "Center" 或 "Default"。

返回：
中点值标签；如果没有设置标签，则返回零长度字符串

getMaxLabel

public String getMaxLabel()
获得最大值的标签，如 "Right" 或 "Full"。

返回：
最大值标签；如果没有设置标签，则返回零长度字符串

getPrecision

public float getPrecision()
获得该控件的分辨率或粒度，以该控件测量的单位为准。精度是受支持浮点值的集合中此控件的离散有效值之间的增量大小。

返回：
控件的精度

getUpdatePeriod

public int getUpdatePeriod()
获得最小时间间隔（以微秒为单位），在此段时间内，控件值可以在移动期间更改。更新周期是控件用来在移动期间更新值的频率的倒数。如果实现不支持随时间移动的值，则它应立即将控件的值设置为最终值，并从此方法返回 -1。

返回：
以微秒为单位的更新周期；如果随着时间的流逝，移动变得不受支持，则返回 -1
另请参见：
shift(float, float, int)

shift

public void shift(float from,
                  float to,
                  int microseconds)
在整个指定的时间内线性地将控件值从初始值更改为最终值，以微秒为单位进行指定。此方法可以不受阻塞地返回；它不会等到移动完成。实现应该在指定时间内完成操作。默认实现只能立即将该值更改最终值。

参数：
from - 移动开始时的初始值
to - 移动之后的最终值
microseconds - 移动持续的最长时间（以微秒为单位）
另请参见：
getUpdatePeriod()

toString

public String toString()
提供控件的字符串表示形式

覆盖：
类 Control 中的 toString
返回：
字符串描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FloatControl.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 FloatControl.Type

java.lang.Object
    继承者  javax.sound.sampled.Control.Type
        继承者  javax.sound.sampled.FloatControl.Type
正在封闭类：
FloatControl
public static class FloatControl.Type
extends Control.Type

FloatControl.Type 内部类的实例标识了某种 float 控件。静态实例是为常见类型提供的。

从以下版本开始：
1.3

字段摘要
static FloatControl.Type | AUX_RETURN 表示某一行上辅助返回音量的控件。
static FloatControl.Type | AUX_SEND 表示某一行上辅助发送音量的控件。
static FloatControl.Type | BALANCE 表示两个立体声扬声器之间立体声信号相对平衡的控件。
static FloatControl.Type | MASTER_GAIN 表示某一行上总音量的控件。
static FloatControl.Type | PAN 表示信号的相对 pan（左右定位）的控件。
static FloatControl.Type | REVERB_RETURN 表示某一行上后回响 (post-reverb) 音量的控件。
static FloatControl.Type | REVERB_SEND 表示某一行上预回响 (pre-reverb) 音量的控件。
static FloatControl.Type | SAMPLE_RATE 表示更改音频回放的样本频率的控件。
static FloatControl.Type | VOLUME 表示某一行上的音量的控件。
构造方法摘要
protected FloatControl.Type(String name)
构造新的 float 控件类型。
方法摘要
从类 javax.sound.sampled.Control.Type 继承的方法
equals, hashCode, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MASTER_GAIN

public static final FloatControl.Type MASTER_GAIN
表示某一行上总音量的控件。

音量是以分贝 (dB) 为单位的量，该量可添加到固有的分贝级音频信号，即由音量控件更改之前的信号级别。正音量增强（增加）信号的音量，负音量削弱（削减）信号的音量。音量设置的默认值为 0.0 dB，意味着信号的响度不受影响。注意，音量测量的是 dB，不测量振幅。以分贝为单位的音量和相应线性振幅乘数之间的关系是：

linearScalar = pow(10.0, gainDB/20.0)

FloatControl 类具有为音量施加最大和最小允许值的方法。不过，因为音频信号可能已经是高振幅，所以最大设置不保证将音量应用于该振幅时信号不失真（除非最大值为零或负数）。为了避免从非常大的音量设置中溢出数值，音量控件可以实现裁剪，这意味着信号的振幅将限制在其音频格式可表示的最大值，而不是换行。

这些注释应用于常规音量控件，不仅仅是主音量控件。一个行可以有多个音量控件。例如，混频器（本身就是一个行）可以有一个主音量控件、一个辅助返回控件、一个回响返回控件，并且在每个源行上有一个单独的辅助发送和回响发送。

另请参见：
AUX_SEND, AUX_RETURN, REVERB_SEND, REVERB_RETURN, VOLUME

AUX_SEND

public static final FloatControl.Type AUX_SEND
表示某一行上辅助发送音量的控件。

另请参见：
MASTER_GAIN, AUX_RETURN

AUX_RETURN

public static final FloatControl.Type AUX_RETURN
表示某一行上辅助返回音量的控件。

另请参见：
MASTER_GAIN, AUX_SEND

REVERB_SEND

public static final FloatControl.Type REVERB_SEND
表示某一行上预回响 (pre-reverb) 音量的控件。此控件可以用于影响导向混频器内部回响单位的行信号的数量。

另请参见：
MASTER_GAIN, REVERB_RETURN, EnumControl.Type.REVERB

REVERB_RETURN

public static final FloatControl.Type REVERB_RETURN
表示某一行上后回响 (post-reverb) 音量的控件。此控件可以用于控件从内部回响单元所返回信号的相对振幅。

另请参见：
MASTER_GAIN, REVERB_SEND

VOLUME

public static final FloatControl.Type VOLUME
表示某一行上的音量的控件。

PAN

public static final FloatControl.Type PAN
表示信号的相对 pan（左右定位）的控件。该信号可以是音色；该 pan 设置影响它在立体声混音中由混频器分配的方式。值的有效范围是 -1.0（仅对左声道）到 1.0（仅对右声道）。默认值为 0.0（居中）。

另请参见：
BALANCE

BALANCE

public static final FloatControl.Type BALANCE
表示两个立体声扬声器之间立体声信号相对平衡的控件。值的有效范围是 -1.0（仅对左声道）到 1.0（仅对右声道）。默认值为 0.0（居中）。

另请参见：
PAN

SAMPLE_RATE

public static final FloatControl.Type SAMPLE_RATE
表示更改音频回放的样本频率的控件。更改样本频率的实际效果取决于介质的自然频率与通过此控件设置的频率之间的关系。自然频率是在数据行的 AudioFormat 对象中指定的样本频率。例如，如果介质的自然频率是每秒 11025 个样本，且将样本频率设置为每秒 22050 个样本，则介质将以正常速度的两倍回放。

使用此控件更改样本频率不影响数据行的音频格式。还要注意的是，每次更改声音的样本频率，都会导致音调的变化。例如，样本频率增加一倍将使声音频谱中的频率增加一倍，这样音调就提高八度。

构造方法详细信息

FloatControl.Type

protected FloatControl.Type(String name)
构造新的 float 控件类型。

参数：
name - 新 float 控件类型的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Line (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 Line

所有已知子接口：
Clip, DataLine, Mixer, Port, SourceDataLine, TargetDataLine
public interface Line

Line 接口表示单声道或多声道音频供给。line 是数字音频“管线”（如混频器、输入或输出端口，或往返于混频器的数据路径）的元素。

line 可以有各种控件，如 gain、pan 和 reverb。这些控件本身是扩展基本 Control 类的那些类的实例。Line 接口提供两个获得 line 控件的存取方法：getControls 返回整个集合，getControl 返回指定类型的单个控件。

行在不同的时间以各种状态存在。当行打开时，它保留本身的系统资源；关闭时，这些资源就会为其他对象或应用程序释放。isOpen() 方法让您发现行是打开的还是关闭的。但是打开的行不需要处理数据。此类处理通常由 SourceDataLine.write 和 TargetDataLine.read 之类的子接口方法初始化。

可以注册一个对象，以便每当行状态更改时接收通知。该对象必须实现 LineListener 接口，此接口由单个方法 update 组成。此方法将在行打开和关闭时调用（如果该行在开始和停止时是一个 DataLine）。

可以注册一个对象来侦听多个行。用其 update 方法接收的事件将指定创建该事件的行、事件的类型（OPEN、CLOSE、START 或 STOP），以及发生事件时该行处理的样本帧的数量。

如果行是共享的音频资源时由未授权的代码调用，则某些行操作（如 open 和 close）可以生成安全性异常。

从以下版本开始：
1.3
另请参见：
LineEvent

嵌套类摘要
static class Line.Info
Line.Info 对象包含关于行的信息。
方法摘要
void | addLineListener(LineListener listener) 将侦听器添加到此行。
void | close() 关闭行，指示可以释放的该行使用的所有系统资源。
Control | getControl(Control.Type control) 获得指定类型的控件，如果有的话。
Control[] | getControls() 获得与此行相关的控件集合。
Line.Info | getLineInfo() 获得描述此行的 Line.Info 对象。
boolean | isControlSupported(Control.Type control) 指示该行是否支持特定类型的控件。
boolean | isOpen() 指示行是否已打开，行已打开则意味着它已保留系统资源并是可操作的，尽管它当前可能没有播放或捕获声音。
void | open() 打开行，指示它应该获得所有所需系统资源并变得可操作。
void | removeLineListener(LineListener listener) 从此行的侦听器列表中移除指定侦听器。

方法详细信息

getLineInfo

Line.Info getLineInfo()
获得描述此行的 Line.Info 对象。

返回：
该行的描述。

open

void open()
          throws LineUnavailableException
打开行，指示它应该获得所有所需系统资源并变得可操作。如果此操作获得成功，则将行标记为 open，且向行的侦听器指派一个 OPEN 事件。

注意，有些行一旦关闭就无法重新打开。试图重新打开这样的行总是导致 LineUnavailableException。

某些类型的行具有可能影响资源分配的可配置属性。例如，必须使用特定格式和缓冲区大小打开 DataLine。此类行应该提供配置这些属性的机制，如允许应用程序指定所需设置的其他一个或多个 open 方法。

此方法不使用任何参数，并使用当前设置打开行。对于 SourceDataLine 和 TargetDataLine 对象，这意味着使用默认设置打开该行。但对于 Clip，缓冲区大小是在加载数据时确定的。由于此方法不允许应用程序指定任何要加载的数据，因此会抛出 IllegalArgumentException。所以用户应该改用 Clip 接口中提供的某一 open 方法将数据加载到 Clip 中。

对于 DataLine，如果用于检索行的 DataLine.Info 对象至少指定一个完全限定的音频格式，则将使用最后一个格式作为默认格式。

抛出：
IllegalArgumentException - 如果在 Clip 接口上调用此方法。
LineUnavailableException - 如果由于资源限制无法打开该行。
SecurityException - 如果由于安全限制无法打开该行。
另请参见：
close(), isOpen(), LineEvent, DataLine, Clip.open(AudioFormat, byte[], int, int), Clip.open(AudioInputStream)

close

void close()
关闭行，指示可以释放的该行使用的所有系统资源。如果此操作成功，则将行标记为 closed，并给行的侦听器指派一个 CLOSE 事件。

抛出：
SecurityException - 如果由于安全限制无法关闭该行。
另请参见：
open(), isOpen(), LineEvent

isOpen

boolean isOpen()
指示行是否已打开，行已打开则意味着它已保留系统资源并是可操作的，尽管它当前可能没有播放或捕获声音。

返回：
如果行已打开，则返回 true；否则返回 false。
另请参见：
open(), close()

getControls

Control[] getControls()
获得与此行相关的控件集合。有些控件可能只在行打开时可用。如果没有控件，则此方法则返回一个长度为 0 的数组

返回：
控件数组
另请参见：
getControl(javax.sound.sampled.Control.Type)

isControlSupported

boolean isControlSupported(Control.Type control)
指示该行是否支持特定类型的控件。有些控件可能只在行打开时可用。

参数：
control - 查询其是否受支持的控件类型
返回：
如果至少有一个指定类型的控件受支持，则返回 true；否则返回 false。

getControl

Control getControl(Control.Type control)
获得指定类型的控件，如果有的话。有些控件可能只在行打开时可用。

参数：
control - 所请求的控件类型
返回：
指定类型的控件
抛出：
IllegalArgumentException - 如果指定类型的控件不受支持
另请参见：
getControls(), isControlSupported(Control.Type control)

addLineListener

void addLineListener(LineListener listener)
将侦听器添加到此行。每当行的状态发生更改，就要使用描述更改的 LineEvent 对象调用侦听器的 update() 方法。

参数：
listener - 将作为侦听器添加到此行的对象
另请参见：
removeLineListener(javax.sound.sampled.LineListener), LineListener.update(javax.sound.sampled.LineEvent), LineEvent

removeLineListener

void removeLineListener(LineListener listener)
从此行的侦听器列表中移除指定侦听器。

参数：
listener - 要移除的侦听器
另请参见：
addLineListener(javax.sound.sampled.LineListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Line.Info (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 Line.Info

java.lang.Object
    继承者  javax.sound.sampled.Line.Info
直接已知子类：
DataLine.Info, Port.Info
正在封闭接口：
Line
public static class Line.Info
extends Object

Line.Info 对象包含关于行的信息。只有 Line.Info 本身提供的信息是该行的 Java 类。Line.Info 子类添加关于该行的其他种类的信息。这些附加信息取决于通过 Line.Info 子类所描述的行种类实现的 Line 子接口。

Line.Info 可以使用 Line、Mixer 和 AudioSystem 接口的各种方法进行检索。其他这样的方法允许将 Line.Info 作为参数传递，以了解与指定配置匹配的行是否可用并获得它们。

从以下版本开始：
1.3
另请参见：
Line.getLineInfo(),
Mixer.getSourceLineInfo(),
Mixer.getTargetLineInfo(),
Mixer.getLine(Line.Info),
Mixer.getSourceLineInfo(Line.Info),
Mixer.getTargetLineInfo(Line.Info),
Mixer.isLineSupported(Line.Info),
AudioSystem.getLine(Line.Info),
AudioSystem.getSourceLineInfo(Line.Info),
AudioSystem.getTargetLineInfo(Line.Info),
AudioSystem.isLineSupported(Line.Info)

构造方法摘要
Line.Info(Class<?> lineClass)
构造描述指定类的行的 info 对象。
方法摘要
Class<?> | getLineClass() 获得此 Line.Info 对象所描述的行的类。
boolean | matches(Line.Info info) 指示指定的信息对象是否与此对象匹配。
String | toString() 获得行信息的文本描述。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Line.Info

public Line.Info(Class<?> lineClass)
构造描述指定类的行的 info 对象。此构造方法通常由应用程序用于描述所需的行。

参数：
lineClass - 新的 Line.Info 对象描述的行的类
方法详细信息

getLineClass

public Class<?> getLineClass()
获得此 Line.Info 对象所描述的行的类。

返回：
所描述的行的类

matches

public boolean matches(Line.Info info)
指示指定的信息对象是否与此对象匹配。若要匹配，则指定的对象必须与此对象相同，或是此对象的一种特殊情况。指定的 info 对象必须是与此对象相同的类的实例，或者是此对象子类型的实例。此外，指定对象的属性必须与此对象的功能兼容。确切地说，指定 info 对象的路由配置必须与此对象的路由配置兼容。子类可能添加其他标准来确定两个对象是否匹配。

参数：
info - 要与此对象比较的 info 对象
返回：
如果指定对象与此对象匹配，则返回 true；否则返回 false

toString

public String toString()
获得行信息的文本描述。

覆盖：
类 Object 中的 toString
返回：
字符串描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 LineEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.sound.sampled.LineEvent
所有已实现的接口：
Serializable
public class LineEvent
extends EventObject

LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。这四种状态更改中的每一种更改都由相应的事件类型表示。侦听器将事件作为一个参数接收到其 update 方法中。通过查询事件，侦听器可以了解事件的类型、负责该事件的行，以及发生事件时行所处理的数据量。

尽管此类实现了 Serializable，但试图序列化 LineEvent 对象仍将失败。

从以下版本开始：
1.3
另请参见：
Line, LineListener.update(javax.sound.sampled.LineEvent)

嵌套类摘要
static class LineEvent.Type
该 LineEvent.Type 内部类标识行上所发生事件的种类。
字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
LineEvent(Line line, LineEvent.Type type, long position)
构造源自指定行的指定类型的新事件。
方法摘要
long | getFramePosition() 获得事件发生时行的音频数据的位置，用样本帧表示。
Line | getLine() 获得作为此事件的源的音频行。
LineEvent.Type | getType() 获得事件的类型。
String | toString() 获得事件的字符串表示形式。
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LineEvent

public LineEvent(Line line,
                 LineEvent.Type type,
                 long position)
构造源自指定行的指定类型的新事件。

参数：
line - 此事件的源
type - 事件类型（OPEN、CLOSE、START 或 STOP）
position - 事件发生时行已经处理的样本帧数，或 AudioSystem.NOT_SPECIFIED
抛出：
IllegalArgumentException - 如果 line 为 null。
方法详细信息

getLine

public final Line getLine()
获得作为此事件的源的音频行。

返回：
负责此事件的行

getType

public final LineEvent.Type getType()
获得事件的类型。

返回：
此事件的类型（LineEvent.Type.OPEN、LineEvent.Type.CLOSE、LineEvent.Type.START 或 LineEvent.Type.STOP）

getFramePosition

public final long getFramePosition()
获得事件发生时行的音频数据的位置，用样本帧表示。例如，如果暂停时源行已经回放了 14 个样本帧，则暂停事件应将行的位置报告为 14。使用从 0 开始的计数时，要处理的下一帧应是帧号 14，使用从 1 开始计数时则应是 15。

注意，此字段只与数据行生成的某些事件相关，如 START 和 STOP。对于不依赖样本帧的那些行生成的事件，以及未知此值的任何其他事件而言，位置值应该是 AudioSystem.NOT_SPECIFIED。

返回：
以样本帧数表示的行的位置

toString

public String toString()
获得事件的字符串表示形式。字符串的内容在 Java Sound 的实现之间可能是各不相同的。

覆盖：
类 EventObject 中的 toString
返回：
描述该事件的字符串。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineEvent.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 LineEvent.Type

java.lang.Object
    继承者  javax.sound.sampled.LineEvent.Type
正在封闭类：
LineEvent
public static class LineEvent.Type
extends Object

该 LineEvent.Type 内部类标识行上所发生事件的种类。静态实例是为常见类型（OPEN、CLOSE、START 和 STOP）提供的。

另请参见：
LineEvent.getType()

字段摘要
static LineEvent.Type | CLOSE 行关闭（释放该行在打开时获得的系统资源）时发送的事件类型。
static LineEvent.Type | OPEN 行打开（为行本身保留系统资源）时发送的事件类型。
static LineEvent.Type | START 在行响应 start 请求而进行音频数据的活动输入或输出时发送的事件类型。
static LineEvent.Type | STOP 当行响应 stop 请求或者因为已到达介质的结尾处而终止音频数据的活动输入或输出时发送的事件类型。
构造方法摘要
protected LineEvent.Type(String name)
构造新的事件类型。
方法摘要
boolean | equals(Object obj) 指示指定对象是否等于此事件类型，如果对象是相同的，则返回 true。
int | hashCode() 终止 hashcode 方法。
String | toString() 以字符串形式返回类型名称。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

OPEN

public static final LineEvent.Type OPEN
行打开（为行本身保留系统资源）时发送的事件类型。

另请参见：
CLOSE, Line.open()

CLOSE

public static final LineEvent.Type CLOSE
行关闭（释放该行在打开时获得的系统资源）时发送的事件类型。

另请参见：
OPEN, Line.close()

START

public static final LineEvent.Type START
在行响应 start 请求而进行音频数据的活动输入或输出时发送的事件类型。

另请参见：
STOP, DataLine.start()

STOP

public static final LineEvent.Type STOP
当行响应 stop 请求或者因为已到达介质的结尾处而终止音频数据的活动输入或输出时发送的事件类型。

另请参见：
START, DataLine.stop()
构造方法详细信息

LineEvent.Type

protected LineEvent.Type(String name)
构造新的事件类型。

参数：
name - 类型的名称
方法详细信息

equals

public final boolean equals(Object obj)
指示指定对象是否等于此事件类型，如果对象是相同的，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象
返回：
如果此事件类型与 obj 相同，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终止 hashcode 方法。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public String toString()
以字符串形式返回类型名称。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 LineListener

所有超级接口：
EventListener
public interface LineListener
extends EventListener

可以注册实现 LineListener 接口的类的实例来接收行状态更改时发生的事件。

从以下版本开始：
1.3
另请参见：
Line, Line.addLineListener(javax.sound.sampled.LineListener), Line.removeLineListener(javax.sound.sampled.LineListener), LineEvent

方法摘要
 void update(LineEvent event)
通知侦听器行的状态已发生更改。

方法详细信息

update

void update(LineEvent event)
通知侦听器行的状态已发生更改。然后侦听器可以调用 LineEvent 方法来获得有关该事件的信息。

参数：
event - 描述更改的行事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineUnavailableException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 LineUnavailableException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.sound.sampled.LineUnavailableException
所有已实现的接口：
Serializable
public class LineUnavailableException
extends Exception

LineUnavailableException 是指示某一行因为不可用而无法打开的异常。此情况通常在请求的行已由另一个应用程序使用时发生。

从以下版本开始：
1.3
另请参见：
序列化表格

构造方法摘要
LineUnavailableException()
构造将 null 作为错误详细消息的 LineUnavailableException。
LineUnavailableException(String message)
构造具有指定详细消息的 LineUnavailableException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LineUnavailableException

public LineUnavailableException()
构造将 null 作为错误详细消息的 LineUnavailableException。

LineUnavailableException

public LineUnavailableException(String message)
构造具有指定详细消息的 LineUnavailableException。

参数：
message - 包含错误详细信息的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Mixer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 Mixer

所有超级接口：
Line
public interface Mixer
extends Line

混频器是一个具有一行或多行的音频设备。不需要将它设计用于混合音频信号。实际混合音频的混频器具有多个输入（源）行和至少一个输出（目标）行。前者常常是实现 SourceDataLine 的类的实例，后者是实现 TargetDataLine 的类的实例。Port 对象不是源行就是目标行。通过将其某些源行作为实现 Clip 接口的对象的实例，混频器可以接受事先录制的环绕声音作为输入。

通过 Line 接口（该接口由 Mixer 扩展）的方法，混频器可以提供对该混频器而言全局可用的控件集。例如，该混频器可以有一个主音量控件。这些全局控件与属于该混频器的每个单行的控件明显不同。

有些混频器（特别是那些具有内部数字混音功能的混频器）可能通过实现 DataLine 接口提供其他功能。

混频器可以支持其行的同步。当启动或停止同步组中的一行时，该组中的其他行自动与明显受影响的行同时启动或停止。

从以下版本开始：
1.3

嵌套类摘要
static class Mixer.Info
Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。
方法摘要
Line | getLine(Line.Info info) 获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
int | getMaxLines(Line.Info info) 获得可以在此混频器上同时打开的所请求类型的行的最大近似数。
Mixer.Info | getMixerInfo() 获得关于此混频器的信息，包括产品名称、版本、供应商，等等。
Line.Info[] | getSourceLineInfo() 获得关于此混频器支持的源行集合的信息。
Line.Info[] | getSourceLineInfo(Line.Info info) 获得关于此混频器支持的特定类型源行的信息。
Line[] | getSourceLines() 获得当前对此混频器打开的所有源行的集合。
Line.Info[] | getTargetLineInfo() 获得关于此混频器支持的目标行集合的信息。
Line.Info[] | getTargetLineInfo(Line.Info info) 获得关于此混频器支持的特定类型目标行的信息。
Line[] | getTargetLines() 获得当前从此混频器打开的所有目标行的集合。
boolean | isLineSupported(Line.Info info) 指示混频器是否支持与指定 Line.Info 对象匹配的一行（或多行）。
boolean | isSynchronizationSupported(Line[] lines, boolean maintainSync) 报告此混频器是否支持指定行集合的同步。
void | synchronize(Line[] lines, boolean maintainSync) 同步两个或多个行。
void | unsynchronize(Line[] lines) 释放指定行的同步。
从接口 javax.sound.sampled.Line 继承的方法
addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

方法详细信息

getMixerInfo

Mixer.Info getMixerInfo()
获得关于此混频器的信息，包括产品名称、版本、供应商，等等。

返回：
描述此混频器的混频器信息对象
另请参见：
Mixer.Info

getSourceLineInfo

Line.Info[] getSourceLineInfo()
获得关于此混频器支持的源行集合的信息。有些源行可能只在此混频器打开时可用。

返回：
表示此混频器的源行的 Line.Info 对象数组。如果不支持任何源行，则返回一个长度为 0 的数组。

getTargetLineInfo

Line.Info[] getTargetLineInfo()
获得关于此混频器支持的目标行集合的信息。有些目标行可能只在此混频器打开时可用。

返回：
表示此混频器的目标行的 Line.Info 对象数组。如果不支持任何目标行，则返回一个长度为 0 的数组。

getSourceLineInfo

Line.Info[] getSourceLineInfo(Line.Info info)
获得关于此混频器支持的特定类型源行的信息。有些源行可能只在此混频器打开时可用。

参数：
info - 描述其信息被查询的那些行的 Line.Info 对象
返回：
描述与所请求类型匹配的源行的 Line.Info 对象数组。如果不支持任何匹配源行，则返回一个长度为 0 的数组。

getTargetLineInfo

Line.Info[] getTargetLineInfo(Line.Info info)
获得关于此混频器支持的特定类型目标行的信息。有些目标行可能只在此混频器打开时可用。

参数：
info - 描述查询其信息的行的 Line.Info 对象
返回：
描述与所请求类型匹配的目标行的 Line.Info 对象数组。如果不支持任何匹配的目标行，则返一个回长度为 0 的数组。

isLineSupported

boolean isLineSupported(Line.Info info)
指示混频器是否支持与指定 Line.Info 对象匹配的一行（或多行）。有些行可能只在此混频器打开时受支持。

参数：
info - 描述查询其是否受支持的行
返回：
如果至少支持一个匹配行，则返回 true；否则返回 false

getLine

Line getLine(Line.Info info)
             throws LineUnavailableException
获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。

如果请求某一 DataLine，且 info 是 DataLine.Info 的实例（至少指定一个完全限定的音频格式），则将使用最后一种格式作为所返回 DataLine 的默认格式。

参数：
info - 描述所需的行
抛出：
LineUnavailableException - 如果由于资源限制而使匹配行不可用
IllegalArgumentException - 如果此 mixer 不支持与描述匹配的所有行
SecurityException - 如果由于安全限制而使匹配行不可用

getMaxLines

int getMaxLines(Line.Info info)
获得可以在此混频器上同时打开的所请求类型的行的最大近似数。 某些类型的混频器没有绝对限制，可能允许打开多个行。由于某些行是共享资源，因此，如果另一个进程已打开此混频器的一些行，则混频器可能无法打开最大数量的行。 所请求类型是与 Line.Info 对象中提供的描述匹配的任何一行。例如，如果 info 对象表示一个扬声器端口，且该混频器只支持一个扬声器端口，则此方法应该返回 1。 如果 info 对象表示一个源数据行，且该混频器支持同时使用 32 个源数据行，则返回值应该是 32。 如果没有限制，则此方法返回 AudioSystem.NOT_SPECIFIED。

参数：
info - 描述将查询其受支持实例数的那些行的 Line.Info
返回：
受支持的匹配行的最大数量，或 AudioSystem.NOT_SPECIFIED

getSourceLines

Line[] getSourceLines()
获得当前对此混频器打开的所有源行的集合。

返回：
当前对此混频器打开的源行。如果当前没有对此混频器打开的源行，则返回一个长度为 0 的数组。
抛出：
SecurityException - 如果由于安全限制而使匹配行不可用

getTargetLines

Line[] getTargetLines()
获得当前从此混频器打开的所有目标行的集合。

返回：
当前从此混频器打开的目标行。如果当前没有从此混频器打开的目标行，则返回一个长度为 0 的数组。
抛出：
SecurityException - 如果由于安全限制而使匹配行不可用

synchronize

void synchronize(Line[] lines,
                 boolean maintainSync)
同步两个或多个行。启动或停止某个这些行的音频回放或捕获的任何后续命令都将对该组中的其他行产生相同的效果，所以它们同时启动或停止播放或捕获数据。

参数：
lines - 应该同步的行
maintainSync - 如果在执行行操作的过程中必须始终精确地维护同步（即同步必须是样本精确的），则该参数为 true；如果只在启动和停止操作的过程中需要精确同步，则该参数为 false
抛出：
IllegalArgumentException - 如果行无法同步。这可能在行属于不同类型或具有此混频器不支持其同步的不同格式，或在所有指定行不属于此混频器的情况下发生。

unsynchronize

void unsynchronize(Line[] lines)
释放指定行的同步。该数组必须与已为其建立同步的数组相同；否则可能抛出异常。但可以指定 null，在此情况下，属于此混频器的所有当前同步行都将被解除同步。

参数：
lines - 应该为其释放同步的同步行；对于此混频器的所有同步行，该参数都为 null。
抛出：
IllegalArgumentException - 如果这些行无法解除同步。这可能在指定参数并不完全与已经为其建立同步的行集合匹配的情况下发生。

isSynchronizationSupported

boolean isSynchronizationSupported(Line[] lines,
                                   boolean maintainSync)
报告此混频器是否支持指定行集合的同步。

参数：
lines - 查询其是否支持同步的那些行的集合
maintainSync - 如果在指定行操作的过程中始终精确地维护同步（即同步必须是样本精确的），则该参数为 true；如果只在启动和停止操作的过程中需要精确同步，则该参数为 false
返回：
如果行可以同步，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Mixer.Info (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 Mixer.Info

java.lang.Object
    继承者  javax.sound.sampled.Mixer.Info
正在封闭接口：
Mixer
public static class Mixer.Info
extends Object

Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。此信息可以通过 Mixer 接口的 getMixerInfo 方法进行检索。

从以下版本开始：
1.3

构造方法摘要
protected Mixer.Info(String name, String vendor, String description, String version)
构造混频器的 info 对象，并向它传递给定的文本信息。
方法摘要
boolean | equals(Object obj) 指示两个 info 对象是否相等；如果相等，则返回 true。
String | getDescription() 获得混频器的描述。
String | getName() 获得混频器的名称。
String | getVendor() 获得混频器的供应商。
String | getVersion() 获得混频器的版本。
int | hashCode() 终止该 hashcode 方法。
String | toString() 提供混频器信息的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

Mixer.Info

protected Mixer.Info(String name,
                     String vendor,
                     String description,
                     String version)
构造混频器的 info 对象，并向它传递给定的文本信息。

参数：
name - 混频器的名称
vendor - 构造或创建硬件或软件混频器的公司
description - 关于混频器的描述文本
version - 混频器的版本信息
方法详细信息

equals

public final boolean equals(Object obj)
指示两个 info 对象是否相等；如果相等，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要将此 info 对象与之比较的引用对象
返回：
如果此信息对象与 obj 参数相同，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终止该 hashcode 方法。

覆盖：
类 Object 中的 hashCode
返回：
此对象的哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

getName

public final String getName()
获得混频器的名称。

返回：
命名混频器的字符串

getVendor

public final String getVendor()
获得混频器的供应商。

返回：
命名混频器供应商的字符串

getDescription

public final String getDescription()
获得混频器的描述。

返回：
混频器的文本描述

getVersion

public final String getVersion()
获得混频器的版本。

返回：
混频器的文本版本信息

toString

public final String toString()
提供混频器信息的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
描述信息对象的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Port (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 Port

所有超级接口：
Line
public interface Port
extends Line

端口是往返于音频输入或输出线与音频设备之间的简单线路。常见的充当源线路（混频器输入）的端口示例包括麦克风、线路输入和 CD-ROM 驱动器。充当目标线路（混频器输出）的端口包括扬声器、耳机和线路输出。可以使用 Port.Info 对象访问端口。

从以下版本开始：
1.3

嵌套类摘要
static class Port.Info
该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。
方法摘要
从接口 javax.sound.sampled.Line 继承的方法
addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Port.Info (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 Port.Info

java.lang.Object
    继承者  javax.sound.sampled.Line.Info
        继承者  javax.sound.sampled.Port.Info
正在封闭接口：
Port
public static class Port.Info
extends Line.Info

该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。按照定义，端口充当其混频器的源或目标，但不会同时是两者。（音频输入端口是源；音频输出端口是目标。）

要了解可用的端口，可以通过 Mixer 的 getSourceLineInfo 和 getTargetLineInfo 方法检索 port 的 info 对象。还可以构造 Port.Info 类的实例，并用它来获得与 Port.Info 对象中指定的参数匹配的行。

从以下版本开始：
1.3

字段摘要
static Port.Info | COMPACT_DISC 从 CD-ROM 驱动器获得音频端口类型。
static Port.Info | HEADPHONE 向耳机插孔发送音频端口类型。
static Port.Info | LINE_IN 从线路级音频输入插孔获得音频端口类型。
static Port.Info | LINE_OUT 向线路级音频输出插孔发送音频端口类型。
static Port.Info | MICROPHONE 从内置麦克风或麦克风插孔中获得音频端口类型。
static Port.Info | SPEAKER 向内置扬声器或扬声器插孔发送音频端口类型。
构造方法摘要
Port.Info(Class<?> lineClass, String name, boolean isSource)
根据给定的信息构造端口的 info 对象。
方法摘要
boolean | equals(Object obj) 终止 equals 方法
String | getName() 获得端口的名称。
int | hashCode() 终止 hashCode 方法
boolean | isSource() 指示端口是其混频器的源还是目标。
boolean | matches(Line.Info info) 指示此指定 info 对象是否与此对象匹配。
String | toString() 提供该端口的 String 表示形式。
从类 javax.sound.sampled.Line.Info 继承的方法
getLineClass
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

MICROPHONE

public static final Port.Info MICROPHONE
从内置麦克风或麦克风插孔中获得音频端口类型。

LINE_IN

public static final Port.Info LINE_IN
从线路级音频输入插孔获得音频端口类型。

COMPACT_DISC

public static final Port.Info COMPACT_DISC
从 CD-ROM 驱动器获得音频端口类型。

SPEAKER

public static final Port.Info SPEAKER
向内置扬声器或扬声器插孔发送音频端口类型。

HEADPHONE

public static final Port.Info HEADPHONE
向耳机插孔发送音频端口类型。

LINE_OUT

public static final Port.Info LINE_OUT
向线路级音频输出插孔发送音频端口类型。

构造方法详细信息

Port.Info

public Port.Info(Class<?> lineClass,
                 String name,
                 boolean isSource)
根据给定的信息构造端口的 info 对象。此构造方法通常由 Java Sound 的实现用于描述受支持的行。

参数：
lineClass - info 对象描述的端口的类。
name - 命名端口的字符串
isSource - 如果端口是源端口（如麦克风），则该参数为 true；如果端口是目标端口（如扬声器），则该参数为 false。
方法详细信息

getName

public String getName()
获得端口的名称。

返回：
命名该端口的字符串

isSource

public boolean isSource()
指示端口是其混频器的源还是目标。

返回：
如果该端口是源端口（如麦克风），则返回 true；如果该端口是目标端口（如扬声器），则返回 false。

matches

public boolean matches(Line.Info info)
指示此指定 info 对象是否与此对象匹配。若要匹配，则必须满足超类的匹配要求，并且各类型必须相等。

覆盖：
类 Line.Info 中的 matches
参数：
info - 为其查询匹配的 info 对象
返回：
如果指定对象与此对象匹配，则返回 true；否则返回 false

equals

public final boolean equals(Object obj)
终止 equals 方法

覆盖：
类 Object 中的 equals
参数：
obj - 要与之比较的引用对象。
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false。
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终止 hashCode 方法

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public final String toString()
提供该端口的 String 表示形式。

覆盖：
类 Line.Info 中的 toString
返回：
描述该端口的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ReverbType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 ReverbType

java.lang.Object
    继承者  javax.sound.sampled.ReverbType

public class ReverbType
extends Object

ReverbType 类提供用于访问应用于音频信号的各种回响设置的方法。

回响模拟从一个房间的墙壁、天花板和地板发出的声音反射。根据房间的大小和房间表面材料吸收和反射度，声音可能回响很长时间才消失。

ReverbType 提供的回响参数由早期反射的延迟时间和强度、晚期反射的延迟时间和强度以及总衰减时间组成。早期反射是房间表面发出的直接信号的单独初始低级反射。晚期反射是以房间回响为特征的密集型高级返射。启动这两种反射类型的延迟时间使侦听器认识到房间形状和容量的总体大小和复杂性。房间越大，反射延迟时间越长。早期和晚期的反射强度定义了反射信号与直接信号相比的音量（以分贝为单位）。这些强度使侦听器记住房间表面和其中物体的吸收特性。衰减时间定义回响在不再被察觉之前（“有效 0”）呈指数级衰减所用的时间。表面的吸收力越大或越小，衰减时间都会变得越长。

这里定义的参数集合可能不包括回响的所有方面，正如有些系统指定的一样。例如，Midi 制造商联盟 (MMA) 有一个交互式专业组 (IASIG)，该组有一个已定义 Level 2 Spec 的 3-D 工作组 (I3DL2)。I3DL2 支持回响过滤和对回响密度的控制。JavaSound 1.0 回响控件的定义中不包括这些属性。在此情况下，实现系统应该要么扩展定义的回响控件以包括附加的参数，要么以适合这里所描述模型的方式解释系统的其他功能。

如果在 I3DL2 兼容的设备上实现 JavaSound，则：

  • 禁用过滤（将高频衰减设置为 0.0 dB）
  • 将密度参数设置为最小密度和最大密度之间的中间值

下表显示了实现可用于有代表性的一组回响设置的参数值。

回响类型和参数

类型 | 衰减时间 (ms) | 晚期密度 (dB) | 晚期延迟 (ms) | 早期密度 (dB) | 早期延迟 (ms)
山洞 | 2250 | -2.0 | 41.3 | -1.4 | 10.3
地下室 | 1600 | -1.0 | 10.3 | -0.7 | 2.6
车库 | 900 | -6.0 | 14.7 | -4.0 | 3.9
声音实验室 | 280 | -3.0 | 8.0 | -2.0 | 2.0
壁橱 | 150 | -10.0 | 2.5 | -7.0 | 0.6

从以下版本开始：
1.3

构造方法摘要
protected ReverbType(String name, int earlyReflectionDelay, float earlyReflectionIntensity, int lateReflectionDelay, float lateReflectionIntensity, int decayTime)
构造具有指定回响参数值的新回响类型。
方法摘要
boolean | equals(Object obj) 指示指定对象是否等于此回响类型，如果对象相同，则返回 true。
int | getDecayTime() 获得衰减时间，该时间是晚期反射削弱到有效 0 的总时间差。
int | getEarlyReflectionDelay() 返回早期反射延迟时间，以微秒为单位。
float | getEarlyReflectionIntensity() 返回早期反射密度，以分贝为单位。
int | getLateReflectionDelay() 返回晚期反射延迟时间，以微秒为单位。
float | getLateReflectionIntensity() 返回晚期反射密度，以分贝为单位。
String | getName() 获得此回响类型的名称。
int | hashCode() 终止 hashcode 方法。
String | toString() 提供回响类型的 String 表示形式，包括其名称和其参数设置。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

ReverbType

protected ReverbType(String name,
                     int earlyReflectionDelay,
                     float earlyReflectionIntensity,
                     int lateReflectionDelay,
                     float lateReflectionIntensity,
                     int decayTime)
构造具有指定回响参数值的新回响类型。

参数：
name - 新回响类型的名称，或长度为 0 的 String
earlyReflectionDelay - 新类型的早期反射延迟时间，以微秒为单位
earlyReflectionIntensity - 新类型的早期反射密度，以 dB 为单位
lateReflectionDelay - 新类型的晚期反射延迟时间，以微秒为单位
lateReflectionIntensity - 新类型的晚期反射密度，以 dB 为单位
decayTime - 新类型的衰减时间，以微秒为单位
方法详细信息

getName

public String getName()
获得此回响类型的名称。

返回：
此回响类型的名称
从以下版本开始：
1.5

getEarlyReflectionDelay

public final int getEarlyReflectionDelay()
返回早期反射延迟时间，以微秒为单位。该时间是听到直接信号时和听到前几个早期反射时之间的时间差。

返回：
此回响类型的早期反射延迟时间，以微秒为单位

getEarlyReflectionIntensity

public final float getEarlyReflectionIntensity()
返回早期反射密度，以分贝为单位。这是相对于直接信号的头几个早期反射的振幅衰减。

返回：
此回响类型的早期反射密度，以 dB 为单位

getLateReflectionDelay

public final int getLateReflectionDelay()
返回晚期反射延迟时间，以微秒为单位。这是听到头几个早期反射时和听到头几个早期反射时之间的时间量。

返回：
此回响类型的晚期反射延迟时间，以微秒为单位

getLateReflectionIntensity

public final float getLateReflectionIntensity()
返回晚期反射密度，以分贝为单位。这是相对于直接信号的头几个晚期反射的振幅衰减。

返回：
此回响类型的晚期反射密度，以 dB 为单位

getDecayTime

public final int getDecayTime()
获得衰减时间，该时间是晚期反射削弱到有效 0 的总时间差。该有效 0 值与实现有关。

返回：
晚期反射的衰减时间，以微秒为单位

equals

public final boolean equals(Object obj)
指示指定对象是否等于此回响类型，如果对象相同，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 要与之进行比较的引用对象
返回：
如果此回响类型与 obj 相同，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终止 hashcode 方法。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public final String toString()
提供回响类型的 String 表示形式，包括其名称和其参数设置。字符串的具体内容可以在 Java Sound 的实现之间变化。

覆盖：
类 Object 中的 toString
返回：
回响类型名称和描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SourceDataLine (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 SourceDataLine

所有超级接口：
DataLine, Line
public interface SourceDataLine
extends DataLine

源数据行是可以写入数据的数据行。它充当其混频器的源。应用程序将音频字节写入源数据行，这样可处理字节缓冲并将它们传递给混频器。混频器可以将这些样本与取自其他源的样本混合起来，然后将该混合物传递到输出端口之类的目标（它可表示声卡上的音频输出设备）。

注意，此接口的命名约定反映了数据行及其混频器之间的关系。从应用程序的角度来看，源数据行可能充当音频数据的目标。

可以通过使用适当 DataLine.Info 对象调用 Mixer 的 getLine 方法从混频器获得源数据行。

SourceDataLine 接口提供将音频数据写入数据行的缓冲区中的方法。播放或混合音频的应用程序应该以足够快的速度将数据写入源数据行，以防缓冲区下溢（排空），下溢可能导致单击时音频数据中出现可感知的间断。应用程序可以使用在 DataLine 接口中定义的 available 方法来确定当前在数据行缓冲区中列队的数据量。可以不受阻塞地写入缓冲区的数据量是缓冲区大小和已列队数据量之间的差值。如果由于下溢而导致音频输出的传递停止，则生成 STOP 事件。恢复音频输出时生成 START 事件。

从以下版本开始：
1.3
另请参见：
Mixer, DataLine, TargetDataLine

嵌套类摘要
从接口 javax.sound.sampled.DataLine 继承的嵌套类/接口
DataLine.Info
方法摘要
void | open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | open(AudioFormat format, int bufferSize) 打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。
int | write(byte[] b, int off, int len) 通过此源数据行将音频数据写入混频器。
从接口 javax.sound.sampled.DataLine 继承的方法
available, drain, flush, getBufferSize, getFormat, getFramePosition, getLevel, getLongFramePosition, getMicrosecondPosition, isActive, isRunning, start, stop
从接口 javax.sound.sampled.Line 继承的方法
addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

方法详细信息

open

void open(AudioFormat format,
          int bufferSize)
          throws LineUnavailableException
打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。

以字节为单位指定缓冲区大小，但该大小必须表示整数形式的样本帧数。使用不满足此要求的所请求缓冲区大小调用此方法可能导致 IllegalArgumentException。已打开的行的实际缓冲区大小可能与所请求缓冲区大小不同。实际设置的值可以通过后续调用 DataLine.getBufferSize() 来查询。

如果此操作成功，则将该行标记为 open，并向行的侦听器指派一个 OPEN 事件。

在已经打开的行上调用此方法是非法的，并且可能导致 IllegalStateException。

注意，有些行一旦关闭就无法重新打开。试图重新打开这样的行总是导致 LineUnavailableException。

参数：
format - 所需的音频格式
bufferSize - 所需的缓冲区大小
抛出：
LineUnavailableException - 如果由于资源限制而无法打开行
IllegalArgumentException - 如果缓冲区大小不表示整数形式的样本帧数，或者 format 未完全指定或是无效的
IllegalStateException - 如果行已经打开
SecurityException - 如果由于安全限制而无法打开行
另请参见：
open(AudioFormat),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

open

void open(AudioFormat format)
          throws LineUnavailableException
打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。

该实现选择缓冲区大小，此大小是以字节为单位来测量的，但它不包括整数形式的样本帧数。系统选择的缓冲区大小可以通过后续调用 DataLine.getBufferSize() 来查询。

如果此操作成功，则将该行标记为 open，并向行的侦听器指派一个 OPEN 事件。

在已经打开的行上调用此方法是非法的，并且可能导致 IllegalStateException。

注意，有些行一旦关闭就无法重新打开。试图重新打开这样的行总是导致 LineUnavailableException。

参数：
format - 所需音频格式
抛出：
LineUnavailableException - 如果由于资源限制而无法打开行
IllegalArgumentException - 如果 format 未完全指定的或是无效的
IllegalStateException - 如果行已经打开
SecurityException - 如果由于安全限制而无法打开行
另请参见：
open(AudioFormat, int),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

write

int write(byte[] b,
          int off,
          int len)
通过此源数据行将音频数据写入混频器。所请求的数据字节数是从指定的数组中读取的（从数组中给定的偏移量开始），并且将被写入数据行的缓冲区。如果调用者试图写入多于当前可写入数据量的数据（参见 available），则此方法在写入所请求数据量之前一直阻塞。即使要写入的请求数据量大于数据行的缓冲区大小，此方法也适用。不过，如果在写入请求的数据量之前数据行已关闭、停止或刷新，则该方法不再阻塞，但它会返回至今为止写入的字节数。

可以使用 DataLine 接口的 available 方法确认可不受阻塞地写入的字节数。（在保证可以不受阻塞地写入此字节数时，不保证试图写入其他数据不会发生阻塞。）

要写入的字节数必须表示整数形式的样本帧数，比如：

[ bytes written ] % [frame size in bytes ] == 0

返回值将始终满足此要求。写入表示非整数形式的样本帧数的字节数的请求无法完成，并且可能导致 IllegalArgumentException。

参数：
b - 包含要写入数据行的数据的字节数组
len - 数组中的有效数据的长度，以字节为单位（即要写入的请求数据量，以字节为单位）
off - 数组开始处的偏移量，以字节为单位
返回：
实际写入的字节数
抛出：
IllegalArgumentException - 如果所请求字节数不表示整数形式的样本帧数，或者 len 为负
ArrayIndexOutOfBoundsException - 如果 off 为负，或者 off+len 大于数组 b 的长度。
另请参见：
TargetDataLine.read(byte[], int, int), DataLine.available()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TargetDataLine (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
接口 TargetDataLine

所有超级接口：
DataLine, Line
public interface TargetDataLine
extends DataLine

目标数据行是可以从中读取音频数据的某种类型的 DataLine。最常见的示例是从音频捕获设备获取其数据的数据行。（该设备被实现为写入目标数据行的混频器。）

注意，此接口的命名约定反映了行及其混频器之间的关系。从应用程序的角度来看，目标数据行可以充当音频数据的源。

可以通过使用适当 DataLine.Info 对象调用 Mixer 的 getLine 方法从混频器获得目标数据行。

该 TargetDataLine 接口提供从目标数据行的缓冲区读取所捕获数据的方法。录制音频的应用程序应该以足够快的速度从该目标数据行读取数据，以防缓冲区溢出，溢出可能导致单击时所捕获数据中出现可感知的间断。应用程序可以使用 DataLine 接口中定义的 available 方法来确定数据行缓冲区中已列队的当前数据量。如果缓冲区发生溢出，则时间最长的列队数据被丢弃并由新的数据替换。

从以下版本开始：
1.3
另请参见：
Mixer, DataLine, SourceDataLine

嵌套类摘要
从接口 javax.sound.sampled.DataLine 继承的嵌套类/接口
DataLine.Info
方法摘要
void | open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | open(AudioFormat format, int bufferSize) 打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。
int | read(byte[] b, int off, int len) 从数据行的输入缓冲区读取音频数据。
从接口 javax.sound.sampled.DataLine 继承的方法
available, drain, flush, getBufferSize, getFormat, getFramePosition, getLevel, getLongFramePosition, getMicrosecondPosition, isActive, isRunning, start, stop
从接口 javax.sound.sampled.Line 继承的方法
addLineListener, close, getControl, getControls, getLineInfo, isControlSupported, isOpen, open, removeLineListener

方法详细信息

open

void open(AudioFormat format,
          int bufferSize)
          throws LineUnavailableException
打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。

以字节为单位指定缓冲区大小，但该大小必须表示整数形式的样本帧数。使用不满足此要求的所请求缓冲区大小调用此方法可能导致 IllegalArgumentException。已打开的行实际缓冲区大小可能与请求的缓冲区大小不同。实际设置的值可以通过后续调用 DataLine.getBufferSize() 来查询

如果此操作成功，则将该行标记为 open，并向行的侦听器指派一个 OPEN 事件。

在已经打开的行上调用此方法是非法的，并且可能导致 IllegalStateException。

有些行一旦关闭就不能重新打开。试图重新打开这样的行总是导致 LineUnavailableException。

参数：
format - 所需的音频格式
bufferSize - 所需的缓冲区大小，以字节为单位。
抛出：
LineUnavailableException - 如果由于资源限制而无法打开行
IllegalArgumentException - 如果缓冲区大小不表示整数形式的样本帧数，或者 format 未完全指定或是无效的
IllegalStateException - 如果行已经打开
SecurityException - 如果由于安全限制而无法打开行
另请参见：
open(AudioFormat),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

open

void open(AudioFormat format)
          throws LineUnavailableException
打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。

该实现选择缓冲区大小，此大小是以字节为单位来测量的，但它不包括整数形式的样本帧数。系统选择的缓冲区大小可以通过后续调用 DataLine.getBufferSize() 来查询

如果此操作成功，则将该行标记为 open，并向行的侦听器指派一个 OPEN 事件。

在已经打开的行上调用此方法是非法的，并且可能导致 IllegalStateException。

有些行一旦关闭就无法重新打开。试图重新打开这样的行总是导致 LineUnavailableException。

参数：
format - 所需音频格式
抛出：
LineUnavailableException - 如果由于资源限制而无法打开行
IllegalArgumentException - 如果 format 未完全指定或是无效的
IllegalStateException - 如果行已经打开
SecurityException - 如果由于安全限制而无法打开行
另请参见：
open(AudioFormat, int),
Line.open(),
Line.close(),
Line.isOpen(),
LineEvent

read

int read(byte[] b,
         int off,
         int len)
从数据行的输入缓冲区读取音频数据。将所请求的字节数读入指定数组，起点是该数组中的指定偏移量，以字节为单位。读取所完请求的数据量之前，此方法发生阻塞。不过，如果在读取完所请求的数据之前数据行已关闭、停止、排空或刷新，则该方法不再阻塞，但它会返回至今为止读取的字节数。

可以使用 DataLine 接口的 available 方法确认可不受阻塞地读取的字节数。（在保证可以不受阻塞地读取此字节数时，不保证试图读取其他数据不会发生阻塞。）

要读取的字节数必须表示整数形式的样本帧数，比如：

[ bytes read ] % [frame size in bytes ] == 0

返回值将始终满足此要求。读取表示非整数形式的样本帧数的字节数的请求无法完成，并且可能导致 IllegalArgumentException。

参数：
b - 将在此方法返回时包含所请求输入数据的字节数组
off - 数组开始处的偏移量，以字节为单位
len - 请求的读取字节数
返回：
实际读取的字节数
抛出：
IllegalArgumentException - 如果所请求的字节数不表示整数形式的样本帧数，或者 len 为负。
ArrayIndexOutOfBoundsException - 如果 off 为负，或者 off+len 大于数组 b 的长度。
另请参见：
SourceDataLine.write(byte[], int, int), DataLine.available()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedAudioFileException (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled
类 UnsupportedAudioFileException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.sound.sampled.UnsupportedAudioFileException
所有已实现的接口：
Serializable
public class UnsupportedAudioFileException
extends Exception

UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

从以下版本开始：
1.3
另请参见：
序列化表格

构造方法摘要
UnsupportedAudioFileException()
构造将 null 作为其错误详细消息的 UnsupportedAudioFileException。
UnsupportedAudioFileException(String message)
构造具有指定详细消息的 UnsupportedAudioFileException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedAudioFileException

public UnsupportedAudioFileException()
构造将 null 作为其错误详细消息的 UnsupportedAudioFileException。

UnsupportedAudioFileException

public UnsupportedAudioFileException(String message)
构造具有指定详细消息的 UnsupportedAudioFileException。

参数：
message - 包含错误详细信息的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sound.sampled (Java 2 Platform SE 6)

 javax.sound.sampled
接口
Clip
DataLine
Line
LineListener
Mixer
Port
SourceDataLine
TargetDataLine
类
AudioFileFormat
AudioFileFormat.Type
AudioFormat
AudioFormat.Encoding
AudioInputStream
AudioPermission
AudioSystem
BooleanControl
BooleanControl.Type
CompoundControl
CompoundControl.Type
Control
Control.Type
DataLine.Info
EnumControl
EnumControl.Type
FloatControl
FloatControl.Type
Line.Info
LineEvent
LineEvent.Type
Mixer.Info
Port.Info
ReverbType
异常
LineUnavailableException
UnsupportedAudioFileException


javax.sound.sampled (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sound.sampled

提供用于捕获、处理和回放取样的音频数据的接口和类。

请参见：
描述

接口摘要
Clip | Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
DataLine | DataLine 将与介质相关的功能添加到其超接口 Line。
Line | Line 接口表示单声道或多声道音频供给。
LineListener | 可以注册实现 LineListener 接口的类的实例来接收行状态更改时发生的事件。
Mixer | 混频器是一个具有一行或多行的音频设备。
Port | 端口是往返于音频输入或输出线与音频设备之间的简单线路。
SourceDataLine | 源数据行是可以写入数据的数据行。
TargetDataLine | 目标数据行是可以从中读取音频数据的某种类型的 DataLine。

类摘要
AudioFileFormat | AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。
AudioFileFormat.Type | Type 类的实例表示音频文件的标准类型之一。
AudioFormat | AudioFormat 是在声音流中指定特定数据安排的类。
AudioFormat.Encoding | Encoding 类命名用于音频流的数据表示形式的特定类型。
AudioInputStream | 音频输入流是具有指定音频格式和长度的输入流。
AudioPermission | AudioPermission 类表示对音频系统资源的访问权限。
AudioSystem | AudioSystem 类充当取样音频系统资源的入口点。
BooleanControl | BooleanControl 能够在影响行音频的两个可能的设置之间切换。
BooleanControl.Type | BooleanControl.Type 类的实例标识一种 boolean 控件。
CompoundControl | CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。
CompoundControl.Type | CompoundControl.Type 内部类的实例标识一种组合控件。
Control | Line 常常具有一个控件（如 gain 和 pan）集合，这些控件都会影响通过行传递的音频信号。
Control.Type | Type 类的实例表示控件的类型。
DataLine.Info | 除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。
EnumControl | EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。
EnumControl.Type | EnumControl.Type 内部类的实例标识了某种枚举控件。
FloatControl | FloatControl 对象提供对浮点值范围的控制。
FloatControl.Type | FloatControl.Type 内部类的实例标识了某种 float 控件。
Line.Info | Line.Info 对象包含关于行的信息。
LineEvent | LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。
LineEvent.Type | 该 LineEvent.Type 内部类标识行上所发生事件的种类。
Mixer.Info | Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。
Port.Info | 该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。
ReverbType | ReverbType 类提供用于访问应用于音频信号的各种回响设置的方法。

异常摘要
LineUnavailableException | LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
UnsupportedAudioFileException | UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

软件包 javax.sound.sampled 的描述

提供用于捕获、处理和回放取样的音频数据的接口和类。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • 声音

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.sound.sampled 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.sampled 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.sound.sampled.AudioFileFormat
    • javax.sound.sampled.AudioFileFormat.Type
    • javax.sound.sampled.AudioFormat
    • javax.sound.sampled.AudioFormat.Encoding
    • javax.sound.sampled.AudioSystem
    • javax.sound.sampled.Control
      • javax.sound.sampled.BooleanControl
      • javax.sound.sampled.CompoundControl
      • javax.sound.sampled.EnumControl
      • javax.sound.sampled.FloatControl
    • javax.sound.sampled.Control.Type
      • javax.sound.sampled.BooleanControl.Type
      • javax.sound.sampled.CompoundControl.Type
      • javax.sound.sampled.EnumControl.Type
      • javax.sound.sampled.FloatControl.Type
    • java.util.EventObject (implements java.io.Serializable)
      • javax.sound.sampled.LineEvent
    • java.io.InputStream (implements java.io.Closeable)
      • javax.sound.sampled.AudioInputStream
    • javax.sound.sampled.Line.Info
      • javax.sound.sampled.DataLine.Info
      • javax.sound.sampled.Port.Info
    • javax.sound.sampled.LineEvent.Type
    • javax.sound.sampled.Mixer.Info
    • java.security.Permission (implements java.security.Guard, java.io.Serializable)
      • java.security.BasicPermission (implements java.io.Serializable)
        • javax.sound.sampled.AudioPermission
    • javax.sound.sampled.ReverbType
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.sound.sampled.LineUnavailableException
        • javax.sound.sampled.UnsupportedAudioFileException

接口分层结构

  • java.util.EventListener
    • javax.sound.sampled.LineListener
  • javax.sound.sampled.Line
    • javax.sound.sampled.DataLine
      • javax.sound.sampled.Clip
      • javax.sound.sampled.SourceDataLine
      • javax.sound.sampled.TargetDataLine
    • javax.sound.sampled.Mixer
    • javax.sound.sampled.Port
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sound.sampled 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.sampled
的使用

使用 javax.sound.sampled 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 使用的 javax.sound.sampled 中的类
AudioFileFormat
AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。
AudioFileFormat.Type
Type 类的实例表示音频文件的标准类型之一。
AudioFormat
AudioFormat 是在声音流中指定特定数据安排的类。
AudioFormat.Encoding
Encoding 类命名用于音频流的数据表示形式的特定类型。
AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。
BooleanControl.Type
BooleanControl.Type 类的实例标识一种 boolean 控件。
Clip
Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
CompoundControl.Type
CompoundControl.Type 内部类的实例标识一种组合控件。
Control
Line 常常具有一个控件（如 gain 和 pan）集合，这些控件都会影响通过行传递的音频信号。
Control.Type
Type 类的实例表示控件的类型。
DataLine
DataLine 将与介质相关的功能添加到其超接口 Line。
EnumControl.Type
EnumControl.Type 内部类的实例标识了某种枚举控件。
FloatControl.Type
FloatControl.Type 内部类的实例标识了某种 float 控件。
Line
Line 接口表示单声道或多声道音频供给。
Line.Info
Line.Info 对象包含关于行的信息。
LineEvent
LineEvent 类封装某一行每次打开、关闭、启动或停止时向其侦听器发送的信息。
LineEvent.Type
该 LineEvent.Type 内部类标识行上所发生事件的种类。
LineListener
可以注册实现 LineListener 接口的类的实例来接收行状态更改时发生的事件。
LineUnavailableException
LineUnavailableException 是指示某一行因为不可用而无法打开的异常。
Mixer
混频器是一个具有一行或多行的音频设备。
Mixer.Info
Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。
Port.Info
该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。
SourceDataLine
源数据行是可以写入数据的数据行。
TargetDataLine
目标数据行是可以从中读取音频数据的某种类型的 DataLine。
UnsupportedAudioFileException
UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

javax.sound.sampled.spi 使用的 javax.sound.sampled 中的类
AudioFileFormat
AudioFileFormat 类的实例描述音频文件，包括文件类型、文件长度（以字节为单位）、文件中包含的音频数据的长度（以示例帧为单位），以及音频数据的格式。
AudioFileFormat.Type
Type 类的实例表示音频文件的标准类型之一。
AudioFormat
AudioFormat 是在声音流中指定特定数据安排的类。
AudioFormat.Encoding
Encoding 类命名用于音频流的数据表示形式的特定类型。
AudioInputStream
音频输入流是具有指定音频格式和长度的输入流。
Mixer
混频器是一个具有一行或多行的音频设备。
Mixer.Info
Mixer.Info 类表示关于音频混频器的信息，包括产品的名称、版本和供应商，以及文本描述。
UnsupportedAudioFileException
UnsupportedAudioFileException 是指示因为文件没有包含可识别文件类型和格式的有效数据而致使操作失败的异常。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AudioFileReader (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled.spi
类 AudioFileReader

java.lang.Object
    继承者  javax.sound.sampled.spi.AudioFileReader

public abstract class AudioFileReader
extends Object

音频文件读取服务的提供者。提供具体实现的类可以根据一种或多种类型的音频文件来分析格式信息，并且可以根据这些类型的文件生成音频输入流。

从以下版本开始：
1.3

构造方法摘要
AudioFileReader()
方法摘要
abstract AudioFileFormat | getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioFileFormat | getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioFileFormat | getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。
abstract AudioInputStream | getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract AudioInputStream | getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。
abstract AudioInputStream | getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AudioFileReader

public AudioFileReader()
方法详细信息

getAudioFileFormat

public abstract AudioFileFormat getAudioFileFormat(InputStream stream)
                                            throws UnsupportedAudioFileException,
                                                   IOException
获得所提供输入流的音频文件格式。该流必须指向有效的音频文件数据。通常，音频文件 reader 可能需要在确定它们是否支持该流之前从中读取一些数据。这些解析器必须能够标记该流，读取足够量的数据来确定它们是否支持该流，如果不支持，则将该流的阅读指针重新设置到其初始位置。如果输入流不支持此操作，则此方法可能会失败，并抛出 IOException。

参数：
stream - 应该从中提取文件格式信息的输入流
返回：
描述音频文件格式的 AudioFileFormat 对象
抛出：
UnsupportedAudioFileException - 如果该流没有指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getAudioFileFormat

public abstract AudioFileFormat getAudioFileFormat(URL url)
                                            throws UnsupportedAudioFileException,
                                                   IOException
获得所提供 URL 的音频文件格式。该 URL 必须指向有效的音频文件数据。

参数：
url - 应该从中提取文件格式信息的 URL
返回：
描述音频文件格式的 AudioFileFormat 对象
抛出：
UnsupportedAudioFileException - 如果该 URL 没有指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常

getAudioFileFormat

public abstract AudioFileFormat getAudioFileFormat(File file)
                                            throws UnsupportedAudioFileException,
                                                   IOException
获得所提供 File 的音频文件格式。该 File 必须指向有效的音频文件数据。

参数：
file - 应该从中提取文件格式信息的 File
返回：
描述音频文件格式的 AudioFileFormat 对象
抛出：
UnsupportedAudioFileException - 如果 File 没有指向系统识别的有效文件数据
IOException - 如果发生 I/O 异常

getAudioInputStream

public abstract AudioInputStream getAudioInputStream(InputStream stream)
                                              throws UnsupportedAudioFileException,
                                                     IOException
从所提供的输入流中获得音频输入流。该流必须指向有效的音频文件数据。通常，音频文件 reader 可能需要在确定它们是否支持该流之前从中读取一些数据。这些解析器必须能够标记该流，读取足够量的数据来确定它们是否支持该流，如果不支持，则将该流的阅读指针重新设置到其初始位置。如果输入流不支持此操作，则此方法可能会失败，并抛出 IOException。

参数：
stream - 应该从中构造 AudioInputStream 的输入流
返回：
基于包含在输入流中的音频文件数据的 AudioInputStream 对象。
抛出：
UnsupportedAudioFileException - 如果该流没有指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getAudioInputStream

public abstract AudioInputStream getAudioInputStream(URL url)
                                              throws UnsupportedAudioFileException,
                                                     IOException
从所提供的 URL 获得音频输入流。该 URL 必须指向有效的音频文件数据。

参数：
url - 应该为其构造 AudioInputStream 的 URL
返回：
基于由 URL 指向的音频文件数据的 AudioInputStream 对象
抛出：
UnsupportedAudioFileException - 如果 URL 没有指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常

getAudioInputStream

public abstract AudioInputStream getAudioInputStream(File file)
                                              throws UnsupportedAudioFileException,
                                                     IOException
从所提供的 File 获得音频输入流。该 File 必须指向有效的音频文件数据。

参数：
file - 应该为其构造 AudioInputStream 的 File
返回：
基于由 File 指向的音频文件数据的 AudioInputStream 对象
抛出：
UnsupportedAudioFileException - 如果 File 没有指向系统识别的有效音频文件数据
IOException - 如果发生 I/O 异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AudioFileWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled.spi
类 AudioFileWriter

java.lang.Object
    继承者  javax.sound.sampled.spi.AudioFileWriter

public abstract class AudioFileWriter
extends Object

音频文件写入服务的提供者。提供具体实现的类可以从音频流写入一种或多种类型的音频文件。

从以下版本开始：
1.3

构造方法摘要
AudioFileWriter()
方法摘要
abstract AudioFileFormat.Type[] | getAudioFileTypes() 获得此音频文件 writer 为其提供文件写入支持的文件类型。
abstract AudioFileFormat.Type[] | getAudioFileTypes(AudioInputStream stream) 获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。
boolean | isFileTypeSupported(AudioFileFormat.Type fileType) 指示此音频文件 writer 是否提供指定文件类型的文件写入支持。
boolean | isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定类型的音频文件。
abstract int | write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
abstract int | write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示所指示文件类型的音频文件的字节流写入所提供的输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AudioFileWriter

public AudioFileWriter()
方法详细信息

getAudioFileTypes

public abstract AudioFileFormat.Type[] getAudioFileTypes()
获得此音频文件 writer 为其提供文件写入支持的文件类型。

返回：
文件类型的数组。如果不支持任何文件类型，则返回一个长度为 0 的数组。

isFileTypeSupported

public boolean isFileTypeSupported(AudioFileFormat.Type fileType)
指示此音频文件 writer 是否提供指定文件类型的文件写入支持。

参数：
fileType - 为其查询写入功能的文件类型
返回：
如果支持该文件类型，则返回 true；否则返回 false

getAudioFileTypes

public abstract AudioFileFormat.Type[] getAudioFileTypes(AudioInputStream stream)
获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。

参数：
stream - 为其查询音频文件类型支持情况的音频输入流
返回：
文件类型的数组。如果不支持任何文件类型，则返回一个长度为 0 的数组。

isFileTypeSupported

public boolean isFileTypeSupported(AudioFileFormat.Type fileType,
                                   AudioInputStream stream)
指示是否可以从指示的音频输入流写入指定类型的音频文件。

参数：
fileType - 为其查询写入功能的文件类型
stream - 为其查询文件写入支持情况的流
返回：
如果支持此音频输入流的文件类型，则返回 true；否则返回 false

write

public abstract int write(AudioInputStream stream,
                          AudioFileFormat.Type fileType,
                          OutputStream out)
                   throws IOException
将表示所指示文件类型的音频文件的字节流写入所提供的输出流。一些文件类型需要将长度写入文件标题，并且不能从前往后写入，除非预先知道该长度。如果音频文件格式中的长度是 AudioSystem.NOT_SPECIFIED，则试图写入这样一个文件类型将失败，并抛出 IOException。

参数：
stream - 包含将写入输出流的音频数据的音频输入流
fileType - 将写入输出流的文件类型
out - 应该在其中写入文件数据的流
返回：
写入输出流的字节数
抛出：
IOException - 如果发生 I/O 异常
IllegalArgumentException - 如果系统不支持该文件类型
另请参见：
isFileTypeSupported(AudioFileFormat.Type, AudioInputStream), getAudioFileTypes()

write

public abstract int write(AudioInputStream stream,
                          AudioFileFormat.Type fileType,
                          File out)
                   throws IOException
将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。

参数：
stream - 包含将写入文件中的音频数据的音频输入流
fileType - 将写入文件的文件类型
out - 应该将文件数据写入其中的外部文件
返回：
写入文件的字节数
抛出：
IOException - 如果发生 I/O 异常
IllegalArgumentException - 如果系统不支持该文件格式
另请参见：
isFileTypeSupported(javax.sound.sampled.AudioFileFormat.Type), getAudioFileTypes()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FormatConversionProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled.spi
类 FormatConversionProvider

java.lang.Object
    继承者  javax.sound.sampled.spi.FormatConversionProvider

public abstract class FormatConversionProvider
extends Object

格式转换提供者提供从一种或多种输入格式到一种或多种输出格式的格式转换服务。转换器包括编码器（编码或解码音频数据）和代码转换器等。格式转换器提供确定所支持的转换方法和从可以读取的转换数据获得音频流的方法。

源格式表示要转换的转入音频数据的格式。

目标格式表示已处理的、已转换的音频数据的格式。这是可以从由某个 getAudioInputStream 方法返回的流中读取的数据的格式。

从以下版本开始：
1.3

构造方法摘要
FormatConversionProvider()
方法摘要
abstract AudioInputStream | getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定编码的音频输入流。
abstract AudioInputStream | getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定格式的音频输入流。
abstract AudioFormat.Encoding[] | getSourceEncodings() 获得源格式编码的集合，此提供者从该集合中提供格式转换服务。
abstract AudioFormat.Encoding[] | getTargetEncodings() 获得目标格式编码的集合，此提供者向该集合提供格式转换服务。
abstract AudioFormat.Encoding[] | getTargetEncodings(AudioFormat sourceFormat) 获得受给定了特定源格式的格式转换器支持的目标格式编码集合。
abstract AudioFormat[] | getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 获得具有受格式转换器支持的指定编码的目标格式集合。
boolean | isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示格式转换器是否支持从特定格式向特定编码的转换。
boolean | isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat) 指示格式转换器是否支持到从一种特定格式到另一种格式的转换。
boolean | isSourceEncodingSupported(AudioFormat.Encoding sourceEncoding) 指示格式转换器是否支持从指定源格式编码的转换。
boolean | isTargetEncodingSupported(AudioFormat.Encoding targetEncoding) 指示格式转换器是否支持到指定目标格式编码的转换。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FormatConversionProvider

public FormatConversionProvider()
方法详细信息

getSourceEncodings

public abstract AudioFormat.Encoding[] getSourceEncodings()
获得源格式编码的集合，此提供者从该集合中提供格式转换服务。

返回：
源格式编码的数组。数组将始终具有至少为 1 的长度。

getTargetEncodings

public abstract AudioFormat.Encoding[] getTargetEncodings()
获得目标格式编码的集合，此提供者向该集合提供格式转换服务。

返回：
目标格式编码的数组。数组将始终具有至少为 1 的长度。

isSourceEncodingSupported

public boolean isSourceEncodingSupported(AudioFormat.Encoding sourceEncoding)
指示格式转换器是否支持从指定源格式编码的转换。

参数：
sourceEncoding - 为其提供查询支持的源格式编码
返回：
如果编码受支持，则返回 true；否则返回 false

isTargetEncodingSupported

public boolean isTargetEncodingSupported(AudioFormat.Encoding targetEncoding)
指示格式转换器是否支持到指定目标格式编码的转换。

参数：
targetEncoding - 为其提供查询支持的目标格式编码
返回：
如果编码受支持，则返回 true；否则返回 false

getTargetEncodings

public abstract AudioFormat.Encoding[] getTargetEncodings(AudioFormat sourceFormat)
获得受给定了特定源格式的格式转换器支持的目标格式编码集合。如果没有为此源格式受支持的目标格式编码，则返回一个长度为 0 的数组。

返回：
受支持的目标格式编码的数组。

isConversionSupported

public boolean isConversionSupported(AudioFormat.Encoding targetEncoding,
                                     AudioFormat sourceFormat)
指示格式转换器是否支持从特定格式向特定编码的转换。

参数：
argetEncoding - 传出数据所需的编码
sourceFormat - 传入数据的格式
返回：
如果转换受支持，则返回 true；否则返回 false

getTargetFormats

public abstract AudioFormat[] getTargetFormats(AudioFormat.Encoding targetEncoding,
                                               AudioFormat sourceFormat)
获得具有受格式转换器支持的指定编码的目标格式集合。如果没有为此源格式受支持的具有指定编码的目标格式，则返回一个长度为 0 的数组。

返回：
受支持的目标格式的数组。

isConversionSupported

public boolean isConversionSupported(AudioFormat targetFormat,
                                     AudioFormat sourceFormat)
指示格式转换器是否支持到从一种特定格式到另一种格式的转换。

参数：
targetFormat - 传出数据所需的格式
sourceFormat - 传入数据的格式
返回：
如果转换受支持，则返回 true；否则，返回 false

getAudioInputStream

public abstract AudioInputStream getAudioInputStream(AudioFormat.Encoding targetEncoding,
                                                     AudioInputStream sourceStream)
从给定的音频输入流获得具有指定编码的音频输入流。

参数：
targetEncoding - 处理后的流所需的编码
sourceStream - 应该从中读取要处理数据的数据流
返回：
可以读取已处理的具有指定目标编码的数据流
抛出：
IllegalArgumentException - 如果提供的格式组合不受支持。

getAudioInputStream

public abstract AudioInputStream getAudioInputStream(AudioFormat targetFormat,
                                                     AudioInputStream sourceStream)
从给定的音频输入流获得具有指定格式的音频输入流。

参数：
targetFormat - 处理后的流所需的数据格式
sourceStream - 应该从中读取要处理数据的数据流
返回：
可以从中读取已处理的具有指定格式的数据流
抛出：
IllegalArgumentException - 如果提供的格式组合不受支持。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MixerProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.sampled.spi
类 MixerProvider

java.lang.Object
    继承者  javax.sound.sampled.spi.MixerProvider

public abstract class MixerProvider
extends Object

特定的混频器类型的提供者和工厂。此机制允许支持确定在混频器的创建/管理中管理资源的方式的实现。

从以下版本开始：
1.3

构造方法摘要
MixerProvider()
方法摘要
abstract Mixer | getMixer(Mixer.Info info) 获得由 info 对象表示的混频器的实例。
abstract Mixer.Info[] | getMixerInfo() 获得表示由该 MixerProvider 提供的混频器的 info 对象集合。
boolean | isMixerSupported(Mixer.Info info) 指示混频器提供者是否支持由指定混频器 info 对象表示的混频器。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MixerProvider

public MixerProvider()
方法详细信息

isMixerSupported

public boolean isMixerSupported(Mixer.Info info)
指示混频器提供者是否支持由指定混频器 info 对象表示的混频器。

参数：
info - 描述查询其支持的混频器的 info 对象
返回：
如果指定混频器受支持，则返回 true；否则返回 false

getMixerInfo

public abstract Mixer.Info[] getMixerInfo()
获得表示由该 MixerProvider 提供的混频器的 info 对象集合。

返回：
混频器 info 对象的集合

getMixer

public abstract Mixer getMixer(Mixer.Info info)
获得由 info 对象表示的混频器的实例。

参数：
info - 描述所需混频器的 info 对象
返回：
混频器实例
抛出：
IllegalArgumentException - 如果指定的 info 对象与由此 MixerProvider 支持的混频器的 info 对象不匹配。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sound.sampled.spi (Java 2 Platform SE 6)

 javax.sound.sampled.spi
类
AudioFileReader
AudioFileWriter
FormatConversionProvider
MixerProvider


javax.sound.sampled.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sound.sampled.spi

在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

请参见：
描述

类摘要
AudioFileReader | 音频文件读取服务的提供者。
AudioFileWriter | 音频文件写入服务的提供者。
FormatConversionProvider | 格式转换提供者提供从一种或多种输入格式到一种或多种输出格式的格式转换服务。
MixerProvider | 特定的混频器类型的提供者和工厂。

软件包 javax.sound.sampled.spi 的描述

在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • 声音

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.sound.sampled.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.sampled.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.sound.sampled.spi.AudioFileReader
    • javax.sound.sampled.spi.AudioFileWriter
    • javax.sound.sampled.spi.FormatConversionProvider
    • javax.sound.sampled.spi.MixerProvider
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sound.sampled.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.sampled.spi
的使用

没有 javax.sound.sampled.spi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.spi.AudioFileReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.AudioFileReader
的使用

没有 javax.sound.sampled.spi.AudioFileReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.spi.AudioFileWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.AudioFileWriter
的使用

没有 javax.sound.sampled.spi.AudioFileWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.spi.FormatConversionProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.FormatConversionProvider
的使用

没有 javax.sound.sampled.spi.FormatConversionProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.spi.MixerProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.spi.MixerProvider
的使用

没有 javax.sound.sampled.spi.MixerProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.AudioFileFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFileFormat
的使用

使用 AudioFileFormat 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFileFormat 的使用

返回 AudioFileFormat 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。

javax.sound.sampled.spi 中 AudioFileFormat 的使用

返回 AudioFileFormat 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.AudioFileFormat.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFileFormat.Type
的使用

使用 AudioFileFormat.Type 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFileFormat.Type 的使用

声明为 AudioFileFormat.Type 的 javax.sound.sampled 中的字段
static AudioFileFormat.Type | AudioFileFormat.Type.AIFC 指定 AIFF-C 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.AIFF 指定 AIFF 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.AU 指定 AU 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.SND 指定 SND 文件。
static AudioFileFormat.Type | AudioFileFormat.Type.WAVE 指定 WAVE 文件。

返回 AudioFileFormat.Type 的 javax.sound.sampled 中的方法
static AudioFileFormat.Type[] | AudioSystem.getAudioFileTypes() 获得由系统为其提供文件写入支持的文件类型。
static AudioFileFormat.Type[] | AudioSystem.getAudioFileTypes(AudioInputStream stream) 获得系统可从指定音频输入流写入的文件类型。
AudioFileFormat.Type | AudioFileFormat.getType() 获得音频文件类型，如 WAVE 或 AU。

参数类型为 AudioFileFormat.Type 的 javax.sound.sampled 中的方法
static boolean | AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType) 指示系统是否提供指定文件类型的文件写入支持。
static boolean | AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定文件类型的音频文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示指定文件类型的音频文件的字节流写入所提供的输出流。

参数类型为 AudioFileFormat.Type 的 javax.sound.sampled 中的构造方法
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength)
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength)
构造音频文件格式对象。

javax.sound.sampled.spi 中 AudioFileFormat.Type 的使用

返回 AudioFileFormat.Type 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat.Type[] | AudioFileWriter.getAudioFileTypes() 获得此音频文件 writer 为其提供文件写入支持的文件类型。
abstract AudioFileFormat.Type[] | AudioFileWriter.getAudioFileTypes(AudioInputStream stream) 获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。

参数类型为 AudioFileFormat.Type 的 javax.sound.sampled.spi 中的方法
boolean | AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType) 指示此音频文件 writer 是否提供指定文件类型的文件写入支持。
boolean | AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定类型的音频文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.AudioFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFormat
的使用

使用 AudioFormat 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFormat 的使用

声明为 AudioFormat 的 javax.sound.sampled 中的字段
protected  AudioFormat AudioInputStream.format
流中包含的音频数据的格式。

返回 AudioFormat 的 javax.sound.sampled 中的方法
AudioFormat | AudioFileFormat.getFormat() 获得音频文件中包含的音频数据的格式。
AudioFormat | AudioInputStream.getFormat() 获得此音频输入流中声音数据的音频格式。
AudioFormat | DataLine.getFormat() 获得数据行的音频数据的当前格式（编码、样本频率、信道数，等等）。
AudioFormat[] | DataLine.Info.getFormats() 获得数据行支持的音频格式的集合。
static AudioFormat[] | AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。

参数类型为 AudioFormat 的 javax.sound.sampled 中的方法
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示格式的音频输入流。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format) 获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format) 获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat sourceFormat) 使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。
static AudioFormat[] | AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。
static boolean | AudioSystem.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。
static boolean | AudioSystem.isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat) 指示是否可从另一指定格式的音频输入流获得指定格式的音频输入流。
boolean | DataLine.Info.isFormatSupported(AudioFormat format) 指示此数据行是否支持特定的音频格式。
boolean | AudioFormat.matches(AudioFormat format) 指示此格式是否与指定格式匹配。
void | SourceDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | Clip.open(AudioFormat format, byte[] data, int offset, int bufferSize) 打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。
void | SourceDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。

参数类型为 AudioFormat 的 javax.sound.sampled 中的构造方法
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength)
构造音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, AudioFormat format, int frameLength, Map<String,Object> properties)
构造具有定义的属性集合的音频文件格式对象。
AudioFileFormat(AudioFileFormat.Type type, int byteLength, AudioFormat format, int frameLength)
构造音频文件格式对象。
AudioInputStream(InputStream stream, AudioFormat format, long length)
使用指定输入流中的音频数据构造具有请求的格式和长度（以示例帧为单位）的音频输入流。
DataLine.Info(Class<?> lineClass, AudioFormat format)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式。
DataLine.Info(Class<?> lineClass, AudioFormat[] formats, int minBufferSize, int maxBufferSize)
根据指定信息构造数据行的信息对象，这些包括受支持音频格式的集合和缓冲区大小的范围。
DataLine.Info(Class<?> lineClass, AudioFormat format, int bufferSize)
根据指定信息构造数据行的信息对象，这些信息包括单个音频格式和所需的缓冲区大小。

javax.sound.sampled.spi 中 AudioFormat 的使用

返回 AudioFormat 的 javax.sound.sampled.spi 中的方法
abstract  AudioFormat[] FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat)
获得具有受格式转换器支持的指定编码的目标格式集合。

参数类型为 AudioFormat 的 javax.sound.sampled.spi 中的方法
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定格式的音频输入流。
abstract AudioFormat.Encoding[] | FormatConversionProvider.getTargetEncodings(AudioFormat sourceFormat) 获得受给定了特定源格式的格式转换器支持的目标格式编码集合。
abstract AudioFormat[] | FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 获得具有受格式转换器支持的指定编码的目标格式集合。
boolean | FormatConversionProvider.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示格式转换器是否支持从特定格式向特定编码的转换。
boolean | FormatConversionProvider.isConversionSupported(AudioFormat targetFormat, AudioFormat sourceFormat) 指示格式转换器是否支持到从一种特定格式到另一种格式的转换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.AudioFormat.Encoding 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioFormat.Encoding
的使用

使用 AudioFormat.Encoding 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioFormat.Encoding 的使用

声明为 AudioFormat.Encoding 的 javax.sound.sampled 中的字段
static AudioFormat.Encoding | AudioFormat.Encoding.ALAW 指定 a-law 编码数据。
protected AudioFormat.Encoding | AudioFormat.encoding 此格式使用的音频编码技术。
static AudioFormat.Encoding | AudioFormat.Encoding.PCM_SIGNED 指定有符号的线性 PCM 数据。
static AudioFormat.Encoding | AudioFormat.Encoding.PCM_UNSIGNED 指定无符号的线性 PCM 数据。
static AudioFormat.Encoding | AudioFormat.Encoding.ULAW 指定 u-law 编码数据。

返回 AudioFormat.Encoding 的 javax.sound.sampled 中的方法
AudioFormat.Encoding | AudioFormat.getEncoding() 获取此格式声音的编码类型。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat.Encoding sourceEncoding) 使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat sourceFormat) 使用已安装的格式转换器集合，获得系统可以从具有指定格式的音频输入流中获得的编码。

参数类型为 AudioFormat.Encoding 的 javax.sound.sampled 中的方法
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示编码的音频输入流。
static AudioFormat.Encoding[] | AudioSystem.getTargetEncodings(AudioFormat.Encoding sourceEncoding) 使用已安装的格式转换器集合获得系统可以从具有指定编码的音频输入流中获得的编码。
static AudioFormat[] | AudioSystem.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 使用已安装的格式转换器，获得具有特定编码的格式，以及系统可以从指定格式的流中获得的格式。
static boolean | AudioSystem.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示是否可以从具有指定格式的音频输入流获得指定编码的音频输入流。

参数类型为 AudioFormat.Encoding 的 javax.sound.sampled 中的构造方法
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian)
构造具有给定参数的 AudioFormat。
AudioFormat(AudioFormat.Encoding encoding, float sampleRate, int sampleSizeInBits, int channels, int frameSize, float frameRate, boolean bigEndian, Map<String,Object> properties)
构造具有给定参数的 AudioFormat。

javax.sound.sampled.spi 中 AudioFormat.Encoding 的使用

返回 AudioFormat.Encoding 的 javax.sound.sampled.spi 中的方法
abstract AudioFormat.Encoding[] | FormatConversionProvider.getSourceEncodings() 获得源格式编码的集合，此提供者从该集合中提供格式转换服务。
abstract AudioFormat.Encoding[] | FormatConversionProvider.getTargetEncodings() 获得目标格式编码的集合，此提供者向该集合提供格式转换服务。
abstract AudioFormat.Encoding[] | FormatConversionProvider.getTargetEncodings(AudioFormat sourceFormat) 获得受给定了特定源格式的格式转换器支持的目标格式编码集合。

参数类型为 AudioFormat.Encoding 的 javax.sound.sampled.spi 中的方法
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定编码的音频输入流。
abstract AudioFormat[] | FormatConversionProvider.getTargetFormats(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 获得具有受格式转换器支持的指定编码的目标格式集合。
boolean | FormatConversionProvider.isConversionSupported(AudioFormat.Encoding targetEncoding, AudioFormat sourceFormat) 指示格式转换器是否支持从特定格式向特定编码的转换。
boolean | FormatConversionProvider.isSourceEncodingSupported(AudioFormat.Encoding sourceEncoding) 指示格式转换器是否支持从指定源格式编码的转换。
boolean | FormatConversionProvider.isTargetEncodingSupported(AudioFormat.Encoding targetEncoding) 指示格式转换器是否支持到指定目标格式编码的转换。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.AudioInputStream 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioInputStream
的使用

使用 AudioInputStream 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 AudioInputStream 的使用

返回 AudioInputStream 的 javax.sound.sampled 中的方法
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示编码的音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示格式的音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。

参数类型为 AudioInputStream 的 javax.sound.sampled 中的方法
static AudioFileFormat.Type[] | AudioSystem.getAudioFileTypes(AudioInputStream stream) 获得系统可从指定音频输入流写入的文件类型。
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示编码的音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 通过转换提供的音频输入流，获得所指示格式的音频输入流。
static boolean | AudioSystem.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定文件类型的音频文件。
void | Clip.open(AudioInputStream stream) 使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示指定文件类型的音频文件的字节流写入所提供的外部文件。
static int | AudioSystem.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示指定文件类型的音频文件的字节流写入所提供的输出流。

javax.sound.sampled.spi 中 AudioInputStream 的使用

返回 AudioInputStream 的 javax.sound.sampled.spi 中的方法
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定编码的音频输入流。
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定格式的音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。

参数类型为 AudioInputStream 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat.Type[] | AudioFileWriter.getAudioFileTypes(AudioInputStream stream) 获得此音频文件 writer 可以从指定的音频输入流写入的文件类型。
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat.Encoding targetEncoding, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定编码的音频输入流。
abstract AudioInputStream | FormatConversionProvider.getAudioInputStream(AudioFormat targetFormat, AudioInputStream sourceStream) 从给定的音频输入流获得具有指定格式的音频输入流。
boolean | AudioFileWriter.isFileTypeSupported(AudioFileFormat.Type fileType, AudioInputStream stream) 指示是否可以从指示的音频输入流写入指定类型的音频文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, File out) 将表示所指示文件格式的音频文件的字节流写入所提供的外部文件。
abstract int | AudioFileWriter.write(AudioInputStream stream, AudioFileFormat.Type fileType, OutputStream out) 将表示所指示文件类型的音频文件的字节流写入所提供的输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.AudioPermission 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioPermission
的使用

没有 javax.sound.sampled.AudioPermission 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.AudioSystem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.AudioSystem
的使用

没有 javax.sound.sampled.AudioSystem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.BooleanControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.BooleanControl
的使用

没有 javax.sound.sampled.BooleanControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.BooleanControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.BooleanControl.Type
的使用

使用 BooleanControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 BooleanControl.Type 的使用

声明为 BooleanControl.Type 的 javax.sound.sampled 中的字段
static BooleanControl.Type | BooleanControl.Type.APPLY_REVERB 表示是否将回响应用于行的控件。
static BooleanControl.Type | BooleanControl.Type.MUTE 表示行的静音状态的控件。

参数类型为 BooleanControl.Type 的 javax.sound.sampled 中的构造方法
BooleanControl(BooleanControl.Type type, boolean initialValue)
构造一个具有给定参数的新 boolean 控件对象。
BooleanControl(BooleanControl.Type type, boolean initialValue, String trueStateLabel, String falseStateLabel)
构造一个具有给定参数的新 boolean 控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.Clip 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Clip
的使用

使用 Clip 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Clip 的使用

返回 Clip 的 javax.sound.sampled 中的方法
static Clip | AudioSystem.getClip() 获得可用于回放音频文件或音频流的剪辑。
static Clip | AudioSystem.getClip(Mixer.Info mixerInfo) 从指定混频器获得可用于回放音频文件或音频流的剪辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.CompoundControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.CompoundControl
的使用

没有 javax.sound.sampled.CompoundControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.CompoundControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.CompoundControl.Type
的使用

使用 CompoundControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 CompoundControl.Type 的使用

参数类型为 CompoundControl.Type 的 javax.sound.sampled 中的构造方法
CompoundControl(CompoundControl.Type type, Control[] memberControls)
构造一个具有给定参数的新组合控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.Control 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Control
的使用

使用 Control 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Control 的使用

javax.sound.sampled 中 Control 的子类
class | BooleanControl BooleanControl 能够在影响行音频的两个可能的设置之间切换。
class | CompoundControl CompoundControl（如图形均衡器）控制两个或多个相关属性，每个属性本身都表示为 Control。
class | EnumControl EnumControl 提供对一组截然不同的可能值的控制，每个值都由一个对象表示。
class | FloatControl FloatControl 对象提供对浮点值范围的控制。

返回 Control 的 javax.sound.sampled 中的方法
Control | Line.getControl(Control.Type control) 获得指定类型的控件，如果有的话。
Control[] | Line.getControls() 获得与此行相关的控件集合。
Control[] | CompoundControl.getMemberControls() 返回组成组合控件的成员控件集合。

参数类型为 Control 的 javax.sound.sampled 中的构造方法
CompoundControl(CompoundControl.Type type, Control[] memberControls)
构造一个具有给定参数的新组合控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.Control.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Control.Type
的使用

使用 Control.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Control.Type 的使用

javax.sound.sampled 中 Control.Type 的子类
static class | BooleanControl.Type BooleanControl.Type 类的实例标识一种 boolean 控件。
static class | CompoundControl.Type CompoundControl.Type 内部类的实例标识一种组合控件。
static class | EnumControl.Type EnumControl.Type 内部类的实例标识了某种枚举控件。
static class | FloatControl.Type FloatControl.Type 内部类的实例标识了某种 float 控件。

返回 Control.Type 的 javax.sound.sampled 中的方法
 Control.Type Control.getType()
获得控件的类型。

参数类型为 Control.Type 的 javax.sound.sampled 中的方法
Control | Line.getControl(Control.Type control) 获得指定类型的控件，如果有的话。
boolean | Line.isControlSupported(Control.Type control) 指示该行是否支持特定类型的控件。

参数类型为 Control.Type 的 javax.sound.sampled 中的构造方法
Control(Control.Type type)
构造具有指定类型的控件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.EnumControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.EnumControl
的使用

没有 javax.sound.sampled.EnumControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.EnumControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.EnumControl.Type
的使用

使用 EnumControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 EnumControl.Type 的使用

声明为 EnumControl.Type 的 javax.sound.sampled 中的字段
static EnumControl.Type EnumControl.Type.REVERB
表示对一组可能的回响设置的控件。

参数类型为 EnumControl.Type 的 javax.sound.sampled 中的构造方法
EnumControl(EnumControl.Type type, Object[] values, Object value)
构造一个具有给定参数的新枚举控件对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.FloatControl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.FloatControl
的使用

没有 javax.sound.sampled.FloatControl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.FloatControl.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.FloatControl.Type
的使用

使用 FloatControl.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 FloatControl.Type 的使用

声明为 FloatControl.Type 的 javax.sound.sampled 中的字段
static FloatControl.Type | FloatControl.Type.AUX_RETURN 表示某一行上辅助返回音量的控件。
static FloatControl.Type | FloatControl.Type.AUX_SEND 表示某一行上辅助发送音量的控件。
static FloatControl.Type | FloatControl.Type.BALANCE 表示两个立体声扬声器之间立体声信号相对平衡的控件。
static FloatControl.Type | FloatControl.Type.MASTER_GAIN 表示某一行上总音量的控件。
static FloatControl.Type | FloatControl.Type.PAN 表示信号的相对 pan（左右定位）的控件。
static FloatControl.Type | FloatControl.Type.REVERB_RETURN 表示某一行上后回响 (post-reverb) 音量的控件。
static FloatControl.Type | FloatControl.Type.REVERB_SEND 表示某一行上预回响 (pre-reverb) 音量的控件。
static FloatControl.Type | FloatControl.Type.SAMPLE_RATE 表示更改音频回放的样本频率的控件。
static FloatControl.Type | FloatControl.Type.VOLUME 表示某一行上的音量的控件。

参数类型为 FloatControl.Type 的 javax.sound.sampled 中的构造方法
FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units)
构造具有给定参数的新 float 控件对象。
FloatControl(FloatControl.Type type, float minimum, float maximum, float precision, int updatePeriod, float initialValue, String units, String minLabel, String midLabel, String maxLabel)
构造具有给定参数的新 float 控件对象

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.LineEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.LineEvent
的使用

使用 LineEvent 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineEvent 的使用

参数类型为 LineEvent 的 javax.sound.sampled 中的方法
 void LineListener.update(LineEvent event)
通知侦听器行的状态已发生更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.LineEvent.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.LineEvent.Type
的使用

使用 LineEvent.Type 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineEvent.Type 的使用

声明为 LineEvent.Type 的 javax.sound.sampled 中的字段
static LineEvent.Type | LineEvent.Type.CLOSE 行关闭（释放该行在打开时获得的系统资源）时发送的事件类型。
static LineEvent.Type | LineEvent.Type.OPEN 行打开（为行本身保留系统资源）时发送的事件类型。
static LineEvent.Type | LineEvent.Type.START 在行响应 start 请求而进行音频数据的活动输入或输出时发送的事件类型。
static LineEvent.Type | LineEvent.Type.STOP 当行响应 stop 请求或者因为已到达介质的结尾处而终止音频数据的活动输入或输出时发送的事件类型。

返回 LineEvent.Type 的 javax.sound.sampled 中的方法
 LineEvent.Type LineEvent.getType()
获得事件的类型。

参数类型为 LineEvent.Type 的 javax.sound.sampled 中的构造方法
LineEvent(Line line, LineEvent.Type type, long position)
构造源自指定行的指定类型的新事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.LineListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.LineListener
的使用

使用 LineListener 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineListener 的使用

参数类型为 LineListener 的 javax.sound.sampled 中的方法
void | Line.addLineListener(LineListener listener) 将侦听器添加到此行。
void | Line.removeLineListener(LineListener listener) 从此行的侦听器列表中移除指定侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.Mixer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Mixer
的使用

使用 Mixer 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 Mixer 的使用

返回 Mixer 的 javax.sound.sampled 中的方法
static Mixer AudioSystem.getMixer(Mixer.Info info)
获得请求的音频混频器。

javax.sound.sampled.spi 中 Mixer 的使用

返回 Mixer 的 javax.sound.sampled.spi 中的方法
abstract  Mixer MixerProvider.getMixer(Mixer.Info info)
获得由 info 对象表示的混频器的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.Mixer.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Mixer.Info
的使用

使用 Mixer.Info 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 Mixer.Info 的使用

返回 Mixer.Info 的 javax.sound.sampled 中的方法
static Mixer.Info[] | AudioSystem.getMixerInfo() 获得混频器信息对象的数组，该数组表示当前安装在系统上的音频混频器的集合。
Mixer.Info | Mixer.getMixerInfo() 获得关于此混频器的信息，包括产品名称、版本、供应商，等等。

参数类型为 Mixer.Info 的 javax.sound.sampled 中的方法
static Clip | AudioSystem.getClip(Mixer.Info mixerInfo) 从指定混频器获得可用于回放音频文件或音频流的剪辑。
static Mixer | AudioSystem.getMixer(Mixer.Info info) 获得请求的音频混频器。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。

javax.sound.sampled.spi 中 Mixer.Info 的使用

返回 Mixer.Info 的 javax.sound.sampled.spi 中的方法
abstract  Mixer.Info[] MixerProvider.getMixerInfo()
获得表示由该 MixerProvider 提供的混频器的 info 对象集合。

参数类型为 Mixer.Info 的 javax.sound.sampled.spi 中的方法
abstract Mixer | MixerProvider.getMixer(Mixer.Info info) 获得由 info 对象表示的混频器的实例。
boolean | MixerProvider.isMixerSupported(Mixer.Info info) 指示混频器提供者是否支持由指定混频器 info 对象表示的混频器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.Port 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Port
的使用

没有 javax.sound.sampled.Port 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.Port.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Port.Info
的使用

使用 Port.Info 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Port.Info 的使用

声明为 Port.Info 的 javax.sound.sampled 中的字段
static Port.Info | Port.Info.COMPACT_DISC 从 CD-ROM 驱动器获得音频端口类型。
static Port.Info | Port.Info.HEADPHONE 向耳机插孔发送音频端口类型。
static Port.Info | Port.Info.LINE_IN 从线路级音频输入插孔获得音频端口类型。
static Port.Info | Port.Info.LINE_OUT 向线路级音频输出插孔发送音频端口类型。
static Port.Info | Port.Info.MICROPHONE 从内置麦克风或麦克风插孔中获得音频端口类型。
static Port.Info | Port.Info.SPEAKER 向内置扬声器或扬声器插孔发送音频端口类型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.ReverbType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.ReverbType
的使用

没有 javax.sound.sampled.ReverbType 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.SourceDataLine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.SourceDataLine
的使用

使用 SourceDataLine 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 SourceDataLine 的使用

返回 SourceDataLine 的 javax.sound.sampled 中的方法
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format) 获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.TargetDataLine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.TargetDataLine
的使用

使用 TargetDataLine 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 TargetDataLine 的使用

返回 TargetDataLine 的 javax.sound.sampled 中的方法
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format) 获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。

参数类型为 TargetDataLine 的 javax.sound.sampled 中的构造方法
AudioInputStream(TargetDataLine line)
构造从指示的目标数据行读取数据的音频输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.UnsupportedAudioFileException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.UnsupportedAudioFileException
的使用

使用 UnsupportedAudioFileException 的软件包
javax.sound.sampled | 提供用于捕获、处理和回放取样的音频数据的接口和类。
javax.sound.sampled.spi | 在提供新音频设备、声音文件 reader 和 writer，或音频格式转换器时，提供将为其创建子类的服务提供者的抽象类。

javax.sound.sampled 中 UnsupportedAudioFileException 的使用

抛出 UnsupportedAudioFileException 的 javax.sound.sampled 中的方法
static AudioFileFormat | AudioSystem.getAudioFileFormat(File file) 获得指定 File 的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(InputStream stream) 获得提供的音频输入流的音频文件格式。
static AudioFileFormat | AudioSystem.getAudioFileFormat(URL url) 获得指定 URL 的音频文件格式。
static AudioInputStream | AudioSystem.getAudioInputStream(File file) 从提供的 File 获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(InputStream stream) 从提供的输入流获得音频输入流。
static AudioInputStream | AudioSystem.getAudioInputStream(URL url) 从提供的 URL 获得音频输入流。

javax.sound.sampled.spi 中 UnsupportedAudioFileException 的使用

抛出 UnsupportedAudioFileException 的 javax.sound.sampled.spi 中的方法
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(File file) 获得所提供 File 的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(InputStream stream) 获得所提供输入流的音频文件格式。
abstract AudioFileFormat | AudioFileReader.getAudioFileFormat(URL url) 获得所提供 URL 的音频文件格式。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(File file) 从所提供的 File 获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(InputStream stream) 从所提供的输入流中获得音频输入流。
abstract AudioInputStream | AudioFileReader.getAudioInputStream(URL url) 从所提供的 URL 获得音频输入流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.LineUnavailableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.LineUnavailableException
的使用

使用 LineUnavailableException 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 LineUnavailableException 的使用

抛出 LineUnavailableException 的 javax.sound.sampled 中的方法
static Clip | AudioSystem.getClip() 获得可用于回放音频文件或音频流的剪辑。
static Clip | AudioSystem.getClip(Mixer.Info mixerInfo) 从指定混频器获得可用于回放音频文件或音频流的剪辑。
static Line | AudioSystem.getLine(Line.Info info) 获得与指定 Line.Info 对象中的描述匹配的行。
Line | Mixer.getLine(Line.Info info) 获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format) 获得一个源数据行，该行可用于以 AudioFormat 对象指定的格式回放音频数据。
static SourceDataLine | AudioSystem.getSourceDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个源数据行，该行可用于以 AudioFormat 对象（通过由 Mixer.Info 对象指定的混频器提供）指定的格式回放音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format) 获得一个目标数据行，该行可用于以 AudioFormat 对象指定的格式记录音频数据。
static TargetDataLine | AudioSystem.getTargetDataLine(AudioFormat format, Mixer.Info mixerinfo) 获得一个目标数据行，该可用于以 AudioFormat 对象（该对象通过由 Mixer.Info 对象指定的混频器提供）指定的格式记录音频数据。
void | Line.open() 打开行，指示它应该获得所有所需系统资源并变得可操作。
void | SourceDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format) 打开具有指定格式的行，这样可使行获得所有所需的系统资源并变得可操作。
void | Clip.open(AudioFormat format, byte[] data, int offset, int bufferSize) 打开剪辑，意味着它应该获得所有所需的系统资源并变得可操作。
void | SourceDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和建议缓冲区大小的行，这样可使该行获得所有所需系统资源并变得可操作。
void | TargetDataLine.open(AudioFormat format, int bufferSize) 打开具有指定格式和请求缓冲区大小的行，这样可使行获得所有所需的系统资源并变得可操作。
void | Clip.open(AudioInputStream stream) 使用出现在所提供的音频输入流中的格式和音频数据打开剪辑。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.DataLine 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.DataLine
的使用

使用 DataLine 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 DataLine 的使用

javax.sound.sampled 中 DataLine 的子接口
interface | Clip Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
interface | SourceDataLine 源数据行是可以写入数据的数据行。
interface | TargetDataLine 目标数据行是可以从中读取音频数据的某种类型的 DataLine。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.DataLine.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.DataLine.Info
的使用

没有 javax.sound.sampled.DataLine.Info 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.sampled.Line 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.sampled.Line
的使用

使用 Line 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Line 的使用

javax.sound.sampled 中 Line 的子接口
interface | Clip Clip 接口表示特殊种类的数据行，该数据行的音频数据可以在回放前加载，而不是实时流出。
interface | DataLine DataLine 将与介质相关的功能添加到其超接口 Line。
interface | Mixer 混频器是一个具有一行或多行的音频设备。
interface | Port 端口是往返于音频输入或输出线与音频设备之间的简单线路。
interface | SourceDataLine 源数据行是可以写入数据的数据行。
interface | TargetDataLine 目标数据行是可以从中读取音频数据的某种类型的 DataLine。

返回 Line 的 javax.sound.sampled 中的方法
Line | LineEvent.getLine() 获得作为此事件的源的音频行。
static Line | AudioSystem.getLine(Line.Info info) 获得与指定 Line.Info 对象中的描述匹配的行。
Line | Mixer.getLine(Line.Info info) 获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
Line[] | Mixer.getSourceLines() 获得当前对此混频器打开的所有源行的集合。
Line[] | Mixer.getTargetLines() 获得当前从此混频器打开的所有目标行的集合。

参数类型为 Line 的 javax.sound.sampled 中的方法
boolean | Mixer.isSynchronizationSupported(Line[] lines, boolean maintainSync) 报告此混频器是否支持指定行集合的同步。
void | Mixer.synchronize(Line[] lines, boolean maintainSync) 同步两个或多个行。
void | Mixer.unsynchronize(Line[] lines) 释放指定行的同步。

参数类型为 Line 的 javax.sound.sampled 中的构造方法
LineEvent(Line line, LineEvent.Type type, long position)
构造源自指定行的指定类型的新事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.sampled.Line.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.sampled.Line.Info
的使用

使用 Line.Info 的软件包
javax.sound.sampled 提供用于捕获、处理和回放取样的音频数据的接口和类。

javax.sound.sampled 中 Line.Info 的使用

javax.sound.sampled 中 Line.Info 的子类
static class | DataLine.Info 除了继承自其超类的类信息之外，DataLine.Info 还提供特定于数据行的其他信息。
static class | Port.Info 该 Port.Info 类扩展了具有其他特定于端口的信息的 Line.Info，这些信息包括端口的名称以及该端口是否是其混频器的源或目标。

返回 Line.Info 的 javax.sound.sampled 中的方法
Line.Info | Line.getLineInfo() 获得描述此行的 Line.Info 对象。
Line.Info[] | Mixer.getSourceLineInfo() 获得关于此混频器支持的源行集合的信息。
static Line.Info[] | AudioSystem.getSourceLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部源行的信息。
Line.Info[] | Mixer.getSourceLineInfo(Line.Info info) 获得关于此混频器支持的特定类型源行的信息。
Line.Info[] | Mixer.getTargetLineInfo() 获得关于此混频器支持的目标行集合的信息。
static Line.Info[] | AudioSystem.getTargetLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部目标行的信息。
Line.Info[] | Mixer.getTargetLineInfo(Line.Info info) 获得关于此混频器支持的特定类型目标行的信息。

参数类型为 Line.Info 的 javax.sound.sampled 中的方法
static Line | AudioSystem.getLine(Line.Info info) 获得与指定 Line.Info 对象中的描述匹配的行。
Line | Mixer.getLine(Line.Info info) 获得可供使用并且与指定 Line.Info 对象中的描述匹配的行。
int | Mixer.getMaxLines(Line.Info info) 获得可以在此混频器上同时打开的所请求类型的行的最大近似数。
static Line.Info[] | AudioSystem.getSourceLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部源行的信息。
Line.Info[] | Mixer.getSourceLineInfo(Line.Info info) 获得关于此混频器支持的特定类型源行的信息。
static Line.Info[] | AudioSystem.getTargetLineInfo(Line.Info info) 获得关于已安装混频器所支持特定类型的全部目标行的信息。
Line.Info[] | Mixer.getTargetLineInfo(Line.Info info) 获得关于此混频器支持的特定类型目标行的信息。
static boolean | AudioSystem.isLineSupported(Line.Info info) 指示系统是否支持与指定 Line.Info 对象匹配的行。
boolean | Mixer.isLineSupported(Line.Info info) 指示混频器是否支持与指定 Line.Info 对象匹配的一行（或多行）。
boolean | Port.Info.matches(Line.Info info) 指示此指定 info 对象是否与此对象匹配。
boolean | DataLine.Info.matches(Line.Info info) 确定指定的信息对象是否与此对象匹配。
boolean | Line.Info.matches(Line.Info info) 指示指定的信息对象是否与此对象匹配。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


ControllerEventListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 ControllerEventListener

所有超级接口：
EventListener
public interface ControllerEventListener
extends EventListener

ControllerEventListener 接口应由一个其实例需要在 Sequencer 处理了请求的 MIDI 控制更改事件类型时接收通知的类实现。要注册 ControllerEventListener 对象以接收这样的通知，可调用 Sequencer 的 addControllerEventListener 方法，指定希望获得其控制更改通知的 MIDI 控件类型。

另请参见：
MidiChannel.controlChange(int, int)

方法摘要
 void controlChange(ShortMessage event)
当 Sequencer 遇到并处理了一个此侦听器需要的控制更改事件时调用。

方法详细信息

controlChange

void controlChange(ShortMessage event)
当 Sequencer 遇到并处理了一个此侦听器需要的控制更改事件时调用。传入的事件是一个 ShortMessage，其第一个数据字节指示控件号，第二个数据字节是为控件设置的值。

参数：
event - sequencer 在其处理的序列中遇到的控制更改事件
另请参见：
Sequencer.addControllerEventListener(ControllerEventListener, int[]),
MidiChannel.controlChange(int, int),
ShortMessage.getData1(),
ShortMessage.getData2()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


Instrument (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 Instrument

java.lang.Object
    继承者  javax.sound.midi.SoundbankResource
        继承者  javax.sound.midi.Instrument

public abstract class Instrument
extends SoundbankResource

乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。乐器通常存储在称为 soundbank（音库）的集合中。要让乐器演奏乐曲，必须先将其加载到合成器中，然后还需要在一个或多个通道中通过程序更改命令选用该乐器。这些通道上后续接收的 MIDI 乐曲将使用选定乐器的声音演奏。

另请参见：
Soundbank, Soundbank.getInstruments(), Patch, Synthesizer.loadInstrument(Instrument), MidiChannel.programChange(int, int)

构造方法摘要
protected Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。
方法摘要
 Patch getPatch()
获得 Patch 对象，该对象指示此乐器在合成器中存储位置处的库和程序号。
从类 javax.sound.midi.SoundbankResource 继承的方法
getData, getDataClass, getName, getSoundbank
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Instrument

protected Instrument(Soundbank soundbank,
                     Patch patch,
                     String name,
                     Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。在有加载此乐器的后续请求时，音库将搜索其内容中是否有此乐器的 Patch，然后将此乐器加载到由 Patch 对象指示的库和程序位置的合成器中。

参数：
soundbank - 包含此乐器的音库
patch - 此乐器的包
name - 此乐器的名称
dataClass - 用于表示样本数据的类。
另请参见：
Synthesizer.loadInstrument(Instrument)
方法详细信息

getPatch

public Patch getPatch()
获得 Patch 对象，该对象指示此乐器在合成器中存储位置处的库和程序号。

返回：
此乐器的包
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InvalidMidiDataException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 InvalidMidiDataException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.sound.midi.InvalidMidiDataException
所有已实现的接口：
Serializable
public class InvalidMidiDataException
extends Exception

一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。这通常意味着，从 MIDI 规范角度来看，此数据输入本身或数据内部无效。一个示例是未定义的状态字节。然而，此异常可能只意味着此数据在使用它的环境中无效，或者接收此数据的对象无法解析或使用它。例如，尽管在 MIDI 规范中定义了 Type 2 MIDI 文件格式，但文件读取器可能无法解析 Type 2 MIDI 文件。

另请参见：
序列化表格

构造方法摘要
InvalidMidiDataException()
构造一个 InvalidMidiDataException，使用 null 作为其错误详细消息。
InvalidMidiDataException(String message)
构造带指定详细消息的 InvalidMidiDataException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

InvalidMidiDataException

public InvalidMidiDataException()
构造一个 InvalidMidiDataException，使用 null 作为其错误详细消息。

InvalidMidiDataException

public InvalidMidiDataException(String message)
构造带指定详细消息的 InvalidMidiDataException。

参数：
message - 将作为错误详细消息显示的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaEventListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 MetaEventListener

所有超级接口：
EventListener
public interface MetaEventListener
extends EventListener

MetaEventListener 接口应由其实例需要在 Sequencer 处理了 MetaMessage 时接收通知的类实现。要将 MetaEventListener 对象注册为接收这样的通知，将它作为参数传给 Sequencer 的 addMetaEventListener 方法。

方法摘要
 void meta(MetaMessage meta)
在 Sequencer 遇到并处理了一个它正在处理的 Sequence 中的 MetaMessage 时调用。

方法详细信息

meta

void meta(MetaMessage meta)
在 Sequencer 遇到并处理了一个它正在处理的 Sequence 中的 MetaMessage 时调用。

参数：
meta - sequencer 遇到的元消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MetaMessage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 MetaMessage

java.lang.Object
    继承者  javax.sound.midi.MidiMessage
        继承者  javax.sound.midi.MetaMessage
所有已实现的接口：
Cloneable
public class MetaMessage
extends MidiMessage

MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。（请参阅 MidiMessage 类描述中的论述。）Standard MIDI Files 规范定义了各种元事件类型，例如序列号、歌词、提示点和设置的速度。还有针对类似歌词、版权、速度指示、时间和主要签名、制造者等信息的元事件。有关更多的信息，请参见 Standard MIDI Files 1.0 规范，它是由 MIDI 制造商协会 (http://www.midi.org) 发布的 Complete MIDI 1.0 Detailed Specification 的一部分。

使用 MIDI wire 协议传输数据时，ShortMessage 带状态值 0xFF 表示系统重置消息。在 MIDI 文件中，此相同的状态值表示 MetaMessage。各个元消息类型通过状态字节 0xFF 后面的第一个字节进行区分。后续的字节是数据字节。与系统独占消息相同，其中还有任意个数据字节，具体取决于 MetaMessage 的类型。

另请参见：
MetaEventListener

字段摘要
static int META
MetaMessage 的状态字节（0xFF 或 255），供在 MIDI 文件中使用。
从类 javax.sound.midi.MidiMessage 继承的字段
data, length
构造方法摘要
 | MetaMessage() 构造一个新的 MetaMessage。
protected | MetaMessage(byte[] data) 构造一个新的 MetaMessage。
方法摘要
Object | clone() 创建一个与此对象具有相同类和相同内容的新对象。
byte[] | getData() 获得元消息数据的副本。
int | getType() 获得 MetaMessage 的类型。
void | setMessage(int type, byte[] data, int length) 为 MetaMessage 设置消息参数。
从类 javax.sound.midi.MidiMessage 继承的方法
getLength, getMessage, getStatus, setMessage
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

META

public static final int META
MetaMessage 的状态字节（0xFF 或 255），供在 MIDI 文件中使用。它与 SYSTEM_RESET 具有相同的值，用于实时 "MIDI wire" 协议中。

另请参见：
MidiMessage.getStatus(), 常量字段值
构造方法详细信息

MetaMessage

public MetaMessage()
构造一个新的 MetaMessage。在此不设置消息的内容；可随后使用 setMessage 对其进行设置。

MetaMessage

protected MetaMessage(byte[] data)
构造一个新的 MetaMessage。

参数：
data - 包含完整消息的 byte 数组。使用 setMessage 方法可更改消息数据。
另请参见：
setMessage(int, byte[], int)
方法详细信息

setMessage

public void setMessage(int type,
                       byte[] data,
                       int length)
                throws InvalidMidiDataException
为 MetaMessage 设置消息参数。由于元消息只允许有一个状态字节值 0xFF，因此在这里不需要对其进行指定。对于所有的元消息，调用 getStatus 都返回 0xFF。

type 参数应该是一个 MetaMessage 中的状态字节后的 byte 有效值。data 参数应包含 MetaMessage 的所有后续字节。换句话说，不将指定 MetaMessage 类型的字节认为是数据字节。

参数：
type - 元消息类型（不超过 128）
data - MIDI 消息中的数据字节
length - data byte 数组中的字节数
抛出：
InvalidMidiDataException - 如果参数值未指定有效的 MIDI 元消息
InvalidMidiDataException

getType

public int getType()
获得 MetaMessage 的类型。

返回：
一个表示 MetaMessage 类型的整数

getData

public byte[] getData()
获得元消息数据的副本。返回的 byte 数组不包括状态字节或消息长度数据。元消息的数据长度就是数组的长度。注意，整个消息的长度包括了状态字节和元消息类型字节，因此可能比返回的数组更长。

返回：
包含元消息数据的数组。
另请参见：
MidiMessage.getLength()

clone

public Object clone()
创建一个与此对象具有相同类和相同内容的新对象。

指定者：
类 MidiMessage 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiChannel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 MidiChannel

public interface MidiChannel

表示一个单独 MIDI 通道的 MidiChannel 对象。通常，每个 MidiChannel 方法处理由 MIDI 规范定义的名称类似 MIDI “通道声音”或“通道模式”的消息。除此之外，MidiChannel 还添加了某些 "get" 方法，可检索由某个标准 MIDI 通道消息最近设置的值。类似地，也添加了用于检索每个通道的单声和静音值的方法。

Synthesizer 对象有一个 MidiChannel 集合，通常一个 MidiChannels 对应于 MIDI 1.0 规范规定的 16 个通道中的一个。Synthesizer 在其 MidiChannel 接收到 noteOn 消息时生成声音。

有关已规定的 MIDI 通道消息行为的更多信息，请参见 MIDI 1.0 规范，在此不加赘述。此规范名称为 MIDI Reference:The Complete MIDI 1.0 Detailed Specification，它由 MIDI 制造商协会 (http://www.midi.org) 发布。

MIDI 最初是一个用于报告键盘乐师动作的协议。在 MidiChannel API 中可以看出该起源的痕迹, 它保留了类似键号、键速度和键力度等 MIDI 概念。我们应该理解，MIDI 数据并不一定都起源于键盘演奏者（该源可以是另一类乐师或软件）。有些设备可以生成速度和力度的常数值，而不管如何演奏音符。同时，MIDI 规范通常让合成器根据实现程序的需要来决定数据的使用方式。例如，不一定需要始终将速度数据映射到音量和/或声音的亮度。

另请参见：
Synthesizer.getChannels()

方法摘要
void | allNotesOff() 关闭此通道上当前发声的所有音符。
void | allSoundOff() 立即关闭通道上所有发声的音符，同时忽略当前 Instrument 的 Hold Pedal 状态和内部衰减率。
void | controlChange(int controller, int value) 对指定控件的值的更改作出反应。
int | getChannelPressure() 获得通道的键盘力度。
int | getController(int controller) 获得指定控件的当前值。
boolean | getMono() 获得当前的 mono/poly 模式。
boolean | getMute() 获得此通道的当前静音状态。
boolean | getOmni() 获得当前的 omni 模式。
int | getPitchBend() 获得此通道的向上或向下的音高偏移量。
int | getPolyPressure(int noteNumber) 获得指定键被按下的力度。
int | getProgram() 获得此通道的当前程序号。
boolean | getSolo() 获得此通道的当前 solo 状态。
boolean | localControl(boolean on) 打开或关闭本地控制。
void | noteOff(int noteNumber) 关闭指定的音符。
void | noteOff(int noteNumber, int velocity) 关闭指定的音符。
void | noteOn(int noteNumber, int velocity) 启动指定的音符发出声音。
void | programChange(int program) 更改一个程序（包）。
void | programChange(int bank, int program) 使用库和程序（包）号更改程序。
void | resetAllControllers() 将所有实现的控件重置为其默认值。
void | setChannelPressure(int pressure) 对键盘力度的更改作出反应。
void | setMono(boolean on) 打开或关闭 mono 模式。
void | setMute(boolean mute) 设置此通道的静音状态。
void | setOmni(boolean on) 打开或关闭 omni 模式。
void | setPitchBend(int bend) 更改此通道上所有音符的音高偏移量。
void | setPolyPressure(int noteNumber, int pressure) 对指定音符键力度的更改作出反应。
void | setSolo(boolean soloState) 设置此通道的 solo 状态。

方法详细信息

noteOn

void noteOn(int noteNumber,
            int velocity)
启动指定的音符发出声音。键被按下的速度通常控制着音符的音量和/或亮度。如果 velocity 为零，则此方法类似于执行 noteOff(int)，终止此音符。

参数：
noteNumber - MIDI 音符号，从 0 到 127（60 = 中央 C）
velocity - 键被按下的速度
另请参见：
noteOff(int, int)

noteOff

void noteOff(int noteNumber,
             int velocity)
关闭指定的音符。键的弹起速度，如果不忽略此值，则它可用于影响音符衰减的速度。任何情况下，音符都不太可能立即消失；它的衰减率取决于 Instrument 的内部情况。如果按下 Hold Pedal（一种控件；请参见 controlChange），则此方法的效果要推迟到踏板释放时才能体现。

参数：
noteNumber - MIDI 音符号，从 0 到 127（60 = 中央 C）
velocity - 键释放的速度
另请参见：
noteOff(int),
noteOn(int, int),
allNotesOff(),
allSoundOff()

noteOff

void noteOff(int noteNumber)
关闭指定的音符。

参数：
noteNumber - MIDI 音符号，从 0 到 127（60 = 中央 C）
另请参见：
noteOff(int, int)

setPolyPressure

void setPolyPressure(int noteNumber,
                     int pressure)
对指定音符键力度的更改作出反应。复调键力度允许键盘演奏者同时按下多个键，每个键可以有不同的力度值。此力度在不忽略的情况下，通常用于改变音符的不同特性，如音量、亮度或颤音。 基础合成器可能不支持此 MIDI 消息。为了验证 setPolyPressure 设置是否成功，可使用 getPolyPressure。

参数：
noteNumber - MIDI 音符号，从 0 到 127（60 = 中央 C）
pressure - 指定键的值，从 0 到 127（127 = 最大力度）
另请参见：
getPolyPressure(int)

getPolyPressure

int getPolyPressure(int noteNumber)
获得指定键被按下的力度。

参数：
noteNumber - MIDI 音符号，从 0 到 127（60 = 中央 C）。 如果设备不支持设置 PolyPressure，则此方法始终返回 0。这种情况下，调用 setPolyPressure 没有任何作用。
返回：
该音符的力度值，从 0 到 127（127 = 最大力度）
另请参见：
setPolyPressure(int, int)

setChannelPressure

void setChannelPressure(int pressure)
对键盘力度的更改作出反应。通道力度指示键盘演奏者按下整个键盘的力度。此值可以是每个键的力度传感器值的最大值或平均值，它由 setPolyPressure 设置。多数情况下，它是对设备上不实现复调键力度的单一传感器的的度量。力度可用于控制声音的各个方面，如在 setPolyPressure 中的描述。 基础合成器可能不支持此 MIDI 消息。为了验证 setChannelPressure 设置是否成功，可使用 getChannelPressure。

参数：
pressure - 键盘被按下的力度，从 0 到 127（127 = 最大力度）
另请参见：
setPolyPressure(int, int), getChannelPressure()

getChannelPressure

int getChannelPressure()
获得通道的键盘力度。如果设备不支持设置 ChannelPressure，则此方法始终返回 0。这种情况下，调用 setChannelPressure 没有任何作用。

返回：
该音符的力度值，从 0 到 127（127 = 最大力度）
另请参见：
setChannelPressure(int)

controlChange

void controlChange(int controller,
                   int value)
对指定控件的值的更改作出反应。控件是指不同于键盘键的其他控制手段，例如开关、滑杆、踏板、滚轮或呼吸力度传感器。MIDI 1.0 Specification 提供了 MIDI 设备上的典型控件的标准号，并对某些控件的效果进行了描述。Instrument 对控件更改的反应方式特定于 Instrument。

MIDI 1.0 Specification 同时定义了 7 位控件和 14 位控件。连续的控件，例如滚轮和滑杆通常为 14 位（两个 MIDI 字节），而离散的控件，例如开关，通常为 7 位（一个 MIDI 字节）。请参考规范，了解每种控制类型的具体精度。

控件 64 到 95 (0x40 - 0x5F) 允许 7 位精度。7 位控件的值完全通过 value 参数进行设置。其他的控件集通过使用两个控件号（一个用于最高有效 7 位，另一个用于最低有效 7 位）提供 14 位精度。控件号 0 到 31 (0x00 - 0x1F) 控制着 14 位控件的最高有效 7 位；控件号 32 到 63 (0x20 - 0x3F) 控制着这些控件的最低有效 7 位。例如，控件号 7 (0x07) 控制着通道音量控件的高 7 位，而控件号 39 (0x27) 则控制着低 7 位。14 位控件的值由这两个部分一起确定。当设置了控件的最高有效 7 位（使用控件号 0 到 31）时，低 7 位自动设置为 0。相应的用于低 7 位的控件号可用于进一步调整此控件值。 基础合成器可能不支持特定的控件消息。为了验证是否对 controlChange 进行了成功的调用，可使用 getController。

参数：
controller - 控件号（0 到 127；请参见 MIDI 1.0 Specification 中的解释）
value - 将指定的控件更改成的值（0 到 127）
另请参见：
getController(int)

getController

int getController(int controller)
获得指定控件的当前值。返回值以 7 位形式表示。对于 14 位控件，需要分别获得 MSB 和 LSB 控件值。例如，要计算音量控件的 14 位值，可将控件 7 的值（0x07, 通道音量 MSB）乘以 128 然后加上控件 39 的值（0x27，通道音量 LSB）即可得到该值。 如果设备不支持设置特定的控件，则对该控件此方法将返回 0。这种情况下调用 controlChange 没有任何作用。

参数：
controller - 需要其值的控件号。允许的范围为 0-127；请参见 MIDI 1.0 Specification 中的解释。
返回：
指定控件的当前值（0 到 127）
另请参见：
controlChange(int, int)

programChange

void programChange(int program)
更改一个程序（包）。此方法从当前选定的乐器库中选取一种特定的乐器。

MIDI 规范并未指示已经能够发声的音符应切换到新的乐器（音色），还是继续使用它们原先的音色，直到由音符关闭来终止。

程序号从零开始（表示为 0 到 127）。注意，MIDI 硬件显示和有关 MIDI 的文字描述通常使用 1 到 128 的范围。 基础合成器可能不支持特定的程序。为了验证是否对 programChange 进行了成功的调用，请使用 getProgram。

参数：
program - 要切换到的程序号（0 到 127）
另请参见：
programChange(int, int), getProgram()

programChange

void programChange(int bank,
                   int program)
使用库和程序（包）号更改程序。 基础合成器可能不支持特定的库或程序。为了验证是否对 programChange 进行了成功的调用，可使用 getProgram 和 getController。由于要通过控制更改的方式来更改库，所以可使用下面的语句验证当前的库：
   int bank = (getController(0) * 128)
              + getController(32);

参数：
bank - 要切换到的库号（0 到 16383）
program - 在指定的库（0 到 127）中使用的程序（包）
另请参见：
programChange(int), getProgram()

getProgram

int getProgram()
获得此通道的当前程序号。

返回：
当前选定包的程序号
另请参见：
Patch.getProgram(),
Synthesizer.loadInstrument(javax.sound.midi.Instrument),
programChange(int)

setPitchBend

void setPitchBend(int bend)
更改此通道上所有音符的音高偏移量。这影响到所有当前发声的音符和后续的发声音符。（要停止使用弯音 (pitch bend)，需要将此值重置为中心位置）。

MIDI 规范规定弯音为一个 14 位值，其中，零为最大的向下弯音，16383 为最大的向上弯音，8192 位于中心位置（无弯音）。实际的音高更改量未指定；可由弯音微调设置对其进行更改。但是 General MIDI 规范指明，默认的范围应为距中心向上或向下的两个半音程。 基础合成器可能不支持此 MIDI 消息。为了验证 setPitchBend 设置是否成功，可使用 getPitchBend。

参数：
bend - 音高的更改量，它是一个非负的 14 位值（8192 = 无 bend）
另请参见：
getPitchBend()

getPitchBend

int getPitchBend()
获得此通道的向上或向下的音高偏移量。如果设备不支持设置弯音，则此方法始终返回 8192。这种情况下，调用 setPitchBend 没有任何作用。

返回：
弯音量，它是一个非负的 14 位值（8192 = 无 bend）
另请参见：
setPitchBend(int)

resetAllControllers

void resetAllControllers()
将所有实现的控件重置为其默认值。

另请参见：
controlChange(int, int)

allNotesOff

void allNotesOff()
关闭此通道上当前发声的所有音符。音符不太可能立即消失；它们的衰减率取决于 Instrument 的内部情况。如果按下 Hold Pedal 控件（请参见 controlChange），则此方法的效果要推迟到踏板释放时才能体现。

另请参见：
allSoundOff(), noteOff(int)

allSoundOff

void allSoundOff()
立即关闭通道上所有发声的音符，同时忽略当前 Instrument 的 Hold Pedal 状态和内部衰减率。

另请参见：
allNotesOff()

localControl

boolean localControl(boolean on)
打开或关闭本地控制。本地控制在默认情况下是开启的。 "on" 设置表示如果设备能够合成声音并传输 MIDI 消息，则它将合成声音作为对它本身所传输的音符打开和音符关闭消息的响应。它还将响应从其他传输设备接收到的消息。"off" 设置表示合成器将忽略其自身传输的 MIDI 消息，但不忽略从其他设备接收到的消息。 基础合成器可能不支持本地控制。为了验证是否对 localControl 行了成功的调用，请检查返回值。

参数：
on - true 可打开本地控制，false 则关闭本地控制
返回：
新的本地控制值，如果不支持本地控制，则返回 false

setMono

void setMono(boolean on)
打开或关闭 mono 模式。在 mono 模式下，通道一次只合成一个音符。在 poly 模式（等效于 mono 模式关闭）下，通道可同步合成多个音符。默认情况下 mono 为关闭（poly 模式为打开）。

"Mono" 是 "monophonic"（单声道）的简写，在此上下文中与 "polyphonic"（复调）相反，指的是每个 MIDI 通道有单个合成器声音。它与音频通道数没有任何关系（即“单声道”和“立体声”录音的情况）。 基础合成器可能不支持 mono 模式。为了验证是否对 setMono 进行了成功的调用，可使用 getMono。

参数：
on - true 为打开 mono 模式，false 为关闭 mono 模式（表示打开 poly 模式）。
另请参见：
getMono(), VoiceStatus

getMono

boolean getMono()
获得当前的 mono/poly 模式。无论如何调用 setMono，不允许更改 mono/poly 模式的合成器将始终返回相同的值。

返回：
如果 mono 模式为打开，则返回 true，否则返回 false（表示 poly 模式为打开）。
另请参见：
setMono(boolean)

setOmni

void setOmni(boolean on)
打开或关闭 omni 模式。在 omni 模式下，通道会响应发送到所有通道上的消息。omni 为关闭时，通道只响应发送到其通道号上的消息。默认情况下 omni 为关闭。 基础合成器可能不支持 omni 模式。为了验证 setOmni 设置是否成功，可使用 getOmni。

参数：
on - true 表示开启 omni 模式，false 表示关闭 omni 模式。
另请参见：
getOmni(), VoiceStatus

getOmni

boolean getOmni()
获得当前的 omni 模式。无论如何调用 setOmni，不允许更改 omni 模式的合成器将始终返回相同的值。

返回：
如果 omni 模式为打开，则返回 true，否则返回 false（表示 omni 模式为关闭）。
另请参见：
setOmni(boolean)

setMute

void setMute(boolean mute)
设置此通道的静音状态。值为 true 表示该通道将设置为静音，值为 false 表示该通道可发声（如果其他通道为非 solo）。

与 allSoundOff() 不同，此方法只适用于特定的通道，而不是所有的通道。更进一步地说，它不只将当前发声的音符设置为静音，而且将后续接收的音符都设置为静音。 基础合成器可能不支持静音通道。为了验证是否对 setMute 进行了成功的调用，可使用 getMute。

参数：
mute - 新的静音状态
另请参见：
getMute(), setSolo(boolean)

getMute

boolean getMute()
获得此通道的当前静音状态。如果基础合成器不支持对此通道的静音设置，则此方法始终返回 false。

返回：
通道为静音设置，则返回 true，否则返回 false
另请参见：
setMute(boolean)

setSolo

void setSolo(boolean soloState)
设置此通道的 solo 状态。如果 solo 为 true，则只有此通道及其他 solo 通道可发声。如果 solo 为 false，则只有其他 solo 通道可发声；除非在没有 solo 通道的情况下，所有非静音通道都发声。 基础合成器可能不支持 solo 通道。为了验证是否对 setSolo 进行了成功的调用，可使用 getSolo。

参数：
soloState - 该通道的新 solo 状态
另请参见：
getSolo()

getSolo

boolean getSolo()
获得此通道的当前 solo 状态。如果基础合成器不支持此通道上的 solo，则此方法始终返回 false。

返回：
如果通道为 solo，则返回 true，否则返回 false
另请参见：
setSolo(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiDevice (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 MidiDevice

所有已知子接口：
Sequencer, Synthesizer
public interface MidiDevice

MidiDevice 是用于所有 MIDI 设备的基接口。常见的设备包括合成器、sequencer、MIDI 输入端口和 MIDI 输出端口。

MidiDevice 可以是 MIDI 事件的传输器或接收器，或同时为二者。因此，它可以提供 Transmitter 或 Receiver 实例（或二者都提供）。通常情况下，MIDI IN 端口提供传输器，MIDI OUT 端口和合成器提供接收器。Sequencer 通常提供用于回放的传输器和用于录音的接收器。

MidiDevice 可显式打开和关闭，也可隐式打开和关闭。显式打开通过在 MidiDevice 实例上调用 open() 来实现，显式关闭通过在 MidiDevice 实例上调用 close() 来实现。如果应用程序显式打开了 MidiDevice，则也必须显式地将其关闭，以释放系统资源和允许应用程序完全退出。隐式打开通过调用 MidiSystem.getReceiver 和 MidiSystem.getTransmitter 实现。由 MidiSystem.getReceiver 和 MidiSystem.getTransmitter 使用的 MidiDevice 与实现相关，除非使用了属性 javax.sound.midi.Receiver 和 javax.sound.midi.Transmitter（请参见 MidiSystem 中对用于选择默认提供者的属性的描述）。对隐式打开的 MidiDevice 可隐式关闭它，方法是关闭打开它所得到的 Receiver 或 Transmitter。如果应用程序获得了多个隐式打开的 Receiver 或 Transmitter，则在关闭最后一个 Receiver 或 Transmitter 后才关闭设备。另一方面，直接在设备实例上调用 getReceiver 或 getTransmitter 并不会隐式打开此设备。关闭这些 Transmitter 和 Receiver 并不隐式关闭设备。要使用其 Receiver 或 Transmitter 以这样的方式获得的设备，必须显式打开和关闭此设备。

如果在同一 MidiDevice 实例上混用隐式和显式的打开和关闭，则应用以下规则：

  • 显式打开（在隐式打开之前或之后）后，设备将无法使用隐式关闭方式关闭。关闭显式打开设备的唯一方式是显式关闭。
  • 显式关闭总会关闭设备，即使设备曾经隐式打开也是如此。后续的隐式关闭没有任何效果。
要检测一个 MidiDevice 是否代表一个硬件 MIDI 端口，可使用以下编程技巧：
 MidiDevice device = ...;
 if ( ! (device instanceof Sequencer) && ! (device instanceof Synthesizer)) {
   // we're now sure that device represents a MIDI port
   // ...
 }

MidiDevice 包括一个提供制造商信息和其他信息的 MidiDevice.Info 对象。

另请参见：
Synthesizer, Sequencer, Receiver, Transmitter

嵌套类摘要
static class MidiDevice.Info
一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。
方法摘要
void | close() 关闭设备，指示设备现在应释放任何正在使用的系统资源。
MidiDevice.Info | getDeviceInfo() 获得有关设备的信息，其中包括包含了其名称、供应商和描述的 Java 类和 Strings。
int | getMaxReceivers() 获得该 MIDI 设备上用于接收 MIDI 数据的最大可用 MIDI IN 连接数。
int | getMaxTransmitters() 获得该 MIDI 设备用于传输 MIDI 数据的最大可用 MIDI OUT 连接数。
long | getMicrosecondPosition() 获得设备的当前时间戳，以微秒为单位。
Receiver | getReceiver() 获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。
List<Receiver> | getReceivers() 返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。
Transmitter | getTransmitter() 获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。
List<Transmitter> | getTransmitters() 返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。
boolean | isOpen() 报告设备是否为打开状态。
void | open() 打开设备，指示它现在应获取任何所需的系统资源然后开始运行。

方法详细信息

getDeviceInfo

MidiDevice.Info getDeviceInfo()
获得有关设备的信息，其中包括包含了其名称、供应商和描述的 Java 类和 Strings。

返回：
设备信息

open

void open()
          throws MidiUnavailableException
打开设备，指示它现在应获取任何所需的系统资源然后开始运行。

使用此调用显式打开设备的应用程序必须通过调用 close() 开关闭该设备。这样做对于释放系统资源和让应用程序完全退出很有必要。

注意，有些设备一旦关闭就无法重新打开。尝试重新打开这样的设备将始终返回一个 MidiUnavailableException。

抛出：
MidiUnavailableException - 如果由于资源限制而无法打开该设备。
SecurityException - 如果由于安全限制而无法打开该设备。
另请参见：
close(), isOpen()

close

void close()
关闭设备，指示设备现在应释放任何正在使用的系统资源。

从此设备打开的所有 Receiver 和 Transmitter 实例都将关闭。这包括通过 MidiSystem 获取的实例。

另请参见：
open(), isOpen()

isOpen

boolean isOpen()
报告设备是否为打开状态。

返回：
如果设备为打开状态，则返回 true，否则返回 false
另请参见：
open(), close()

getMicrosecondPosition

long getMicrosecondPosition()
获得设备的当前时间戳，以微秒为单位。如果设备支持时间戳，它应从设备一打开就从 0 开始计数，并以微秒为单位继续递增该时间戳，直到设备关闭为止。如果设备不支持时间戳，它应始终返回 -1。

返回：
设备的当前时间戳，以微秒为单位，如果设备不支持时间戳，则返回 -1。

getMaxReceivers

int getMaxReceivers()
获得该 MIDI 设备上用于接收 MIDI 数据的最大可用 MIDI IN 连接数。

返回：
最大 MIDI IN 连接数，如果有无限个连接可用，则返回 -1。

getMaxTransmitters

int getMaxTransmitters()
获得该 MIDI 设备用于传输 MIDI 数据的最大可用 MIDI OUT 连接数。

返回：
最大 MIDI OUT 连接数，如果有无限个连接可用，则返回 -1。

getReceiver

Receiver getReceiver()
                     throws MidiUnavailableException
获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。返回的接收器必须在应用程序结束使用后关闭。

使用此方法获得 Receiver 并不打开设备。要想能够使用该设备，必须通过调用 open() 将其显式打开。同理，关闭 Receiver 并不关闭设备。必须通过调用 close() 将其显式关闭。

返回：
供设备使用的接收器。
抛出：
MidiUnavailableException - 如果由于资源限制使接收器不可用
另请参见：
Receiver.close()

getReceivers

List<Receiver> getReceivers()
返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。通过关闭接收器可将它从设备中移除。

返回：
已打开接收器的不可修改列表
从以下版本开始：
1.5

getTransmitter

Transmitter getTransmitter()
                           throws MidiUnavailableException
获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。返回的传输器必须在应用程序结束使用后关闭。

使用此方法获得 Transmitter 并不打开设备。要想能够使用该设备，必须通过调用 open() 将其显式打开。同理，关闭 Transmitter 并不关闭设备。必须通过调用 close() 将其显式关闭。

返回：
供设备使用的一个 MIDI OUT 传输器。
抛出：
MidiUnavailableException - 如果由于资源限制使传输器不可用
另请参见：
Transmitter.close()

getTransmitters

List<Transmitter> getTransmitters()
返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。通过关闭传输器可将它从设备中移除。

返回：
已打开传输器的不可修改列表
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiDevice.Info (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 MidiDevice.Info

java.lang.Object
    继承者  javax.sound.midi.MidiDevice.Info
正在封闭接口：
MidiDevice
public static class MidiDevice.Info
extends Object

一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。

另请参见：
MidiDevice.getDeviceInfo()

构造方法摘要
protected MidiDevice.Info(String name, String vendor, String description, String version)
构造一个设备 info 对象。
方法摘要
boolean | equals(Object obj) 报告两个对象是否相等。
String | getDescription() 获得关于设备的描述。
String | getName() 获得设备的名称。
String | getVendor() 获得提供设备的公司名称。
String | getVersion() 获得设备的版本。
int | hashCode() 终结 hashcode 方法。
String | toString() 提供设备信息的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

MidiDevice.Info

protected MidiDevice.Info(String name,
                          String vendor,
                          String description,
                          String version)
构造一个设备 info 对象。

参数：
name - 设备的名称
vendor - 提供设备的公司名称
description - 对设备的描述
version - 设备的版本信息
方法详细信息

equals

public final boolean equals(Object obj)
报告两个对象是否相等。如果两个对象相等，则返回 true。

覆盖：
类 Object 中的 equals
参数：
obj - 与该对象比较的参考对象
返回：
如果此对象与 obj 参数相同，则返回 true；否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终结 hashcode 方法。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

getName

public final String getName()
获得设备的名称。

返回：
包含设备名称的字符串

getVendor

public final String getVendor()
获得提供设备的公司名称。

返回：
device 供应商的名称

getDescription

public final String getDescription()
获得关于设备的描述。

返回：
对设备的描述

getVersion

public final String getVersion()
获得设备的版本。

返回：
设备的文本性版本信息。

toString

public final String toString()
提供设备信息的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
对 info 对象的描述
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 MidiEvent

java.lang.Object
    继承者  javax.sound.midi.MidiEvent

public class MidiEvent
extends Object

MIDI 事件包含一个 MIDI 消息和一个相应的用刻度表示的时间戳，可代表存储在 MIDI 文件或 Sequence 对象中的 MIDI 事件信息。刻度的持续时间由包含在 MIDI 文件或 Sequence 对象中的时间信息指定。

在 Java Sound 中，MidiEvent 对象通常包含在 Track 中，而 Tracks 类似地包含在 Sequence 中。

构造方法摘要
MidiEvent(MidiMessage message, long tick)
构造一个新的 MidiEvent。
方法摘要
MidiMessage | getMessage() 获得事件中包含的 MIDI 消息。
long | getTick() 获得事件的用 MIDI 刻度表示的时间戳
void | setTick(long tick) 设置事件的用 MIDI 刻度表示的时间戳
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MidiEvent

public MidiEvent(MidiMessage message,
                 long tick)
构造一个新的 MidiEvent。

参数：
message - 包含在事件中的 MIDI 消息
tick - 用 MIDI 刻度表示的事件的时间戳
方法详细信息

getMessage

public MidiMessage getMessage()
获得事件中包含的 MIDI 消息。

返回：
MIDI 消息

setTick

public void setTick(long tick)
设置事件的用 MIDI 刻度表示的时间戳

参数：
tick - 新的时间戳，用 MIDI 刻度表示

getTick

public long getTick()
获得事件的用 MIDI 刻度表示的时间戳

返回：
事件的用 MIDI 刻度表示的时间戳
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiFileFormat (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 MidiFileFormat

java.lang.Object
    继承者  javax.sound.midi.MidiFileFormat

public class MidiFileFormat
extends Object

MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。

MidiFileFormat 对象可包含一组属性。属性是一对键和值：键的类型是 String，关联属性值是任意对象。属性指定其他的信息元数据（如作者或版权）。属性是可选信息，不要求文件 reader 和文件 writer 实现提供或识别属性。

下表列出了一些应在实现中使用的常见属性：

属性键 | 值类型 | 描述
"author" | String | 此文件的作者名
"title" | String | 此文件的标题
"copyright" | String | 版权消息
"date" | Date | 录制或发行日期
"comment" | String | 任意文本

另请参见：
MidiSystem.getMidiFileFormat(java.io.File), Sequencer.setSequence(java.io.InputStream stream)

字段摘要
protected int | byteLength MIDI 文件的长度，以字节为单位。
protected float | divisionType MIDI 文件的 division 类型。
protected long | microsecondLength MIDI 文件的持续时间，以微秒为单位。
protected int | resolution MIDI 文件的定时精度。
protected int | type MIDI 文件的类型。
static int | UNKNOWN_LENGTH 表示未知长度。
构造方法摘要
MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds)
构造一个 MidiFileFormat。
MidiFileFormat(int type, float divisionType, int resolution, int bytes, long microseconds, Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。
方法摘要
int | getByteLength() 获得 MIDI 文件的长度，用 8 位字节表示。
float | getDivisionType() 获得 MIDI 文件的定时 division 类型。
long | getMicrosecondLength() 获得 MIDI 文件的长度，用微秒表示。
Object | getProperty(String key) 获得由键指定的属性值。
int | getResolution() 获得 MIDI 文件的定时精度。
int | getType() 获得 MIDI 文件类型。
Map<String,Object> | properties() 获得属性的一个不可修改的映射。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UNKNOWN_LENGTH

public static final int UNKNOWN_LENGTH
表示未知长度。

另请参见：
getByteLength(), getMicrosecondLength(), 常量字段值

type

protected int type
MIDI 文件的类型。

divisionType

protected float divisionType
MIDI 文件的 division 类型。

另请参见：
Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30

resolution

protected int resolution
MIDI 文件的定时精度。

byteLength

protected int byteLength
MIDI 文件的长度，以字节为单位。

microsecondLength

protected long microsecondLength
MIDI 文件的持续时间，以微秒为单位。

构造方法详细信息

MidiFileFormat

public MidiFileFormat(int type,
                      float divisionType,
                      int resolution,
                      int bytes,
                      long microseconds)
构造一个 MidiFileFormat。

参数：
type - MIDI 文件类型（0、1 或 2）
divisionType - 定时 division 类型（PPQ 或某一 SMPTE 类型）
resolution - 定时精度
bytes - MIDI 文件的长度，以字节为单位，如果长度未知，则为 UNKNOWN_LENGTH
microseconds - 文件的持续时间，以微秒为单位，如果文件持续时间未知，则为 UNKNOWN_LENGTH
另请参见：
UNKNOWN_LENGTH, Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30

MidiFileFormat

public MidiFileFormat(int type,
                      float divisionType,
                      int resolution,
                      int bytes,
                      long microseconds,
                      Map<String,Object> properties)
构造带一组属性的 MidiFileFormat。

参数：
type - MIDI 文件类型（0、1 或 2）
divisionType - 定时 division 类型（PPQ 或某一 SMPTE 类型）
resolution - 定时精度
bytes - MIDI 文件的长度，以字节为单位，如果长度未知，则为 UNKNOWN_LENGTH
microseconds - 文件的持续时间，以微秒为单位，如果文件持续时间未知，则为 UNKNOWN_LENGTH
properties - 一个带属性的 Map<String,Object> 对象
从以下版本开始：
1.5
另请参见：
UNKNOWN_LENGTH, Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30
方法详细信息

getType

public int getType()
获得 MIDI 文件类型。

返回：
文件的类型（0、1 或 2）

getDivisionType

public float getDivisionType()
获得 MIDI 文件的定时 division 类型。

返回：
division 类型（PPQ 或某一 SMPTE 类型）
另请参见：
Sequence.Sequence(float, int), Sequence.PPQ, Sequence.SMPTE_24, Sequence.SMPTE_25, Sequence.SMPTE_30DROP, Sequence.SMPTE_30, Sequence.getDivisionType()

getResolution

public int getResolution()
获得 MIDI 文件的定时精度。如果 division 类型为 PPQ，则精度按每拍的节拍数指定。对于 SMTPE 定时，精度按每帧的节拍数指定。

返回：
每拍 (PPQ) 或每帧 (SMPTE) 的节拍数
另请参见：
getDivisionType(), Sequence.getResolution()

getByteLength

public int getByteLength()
获得 MIDI 文件的长度，用 8 位字节表示。

返回：
文件中的字节数，如果未知，则为 UNKNOWN_LENGTH
另请参见：
UNKNOWN_LENGTH

getMicrosecondLength

public long getMicrosecondLength()
获得 MIDI 文件的长度，用微秒表示。

返回：
文件的持续时间，以微秒为单位，如果未知，则返回 UNKNOWN_LENGTH
另请参见：
Sequence.getMicrosecondLength(), getByteLength(), UNKNOWN_LENGTH

properties

public Map<String,Object> properties()
获得属性的一个不可修改的映射。在类描述中对属性的概念进行了进一步的介绍。

返回：
一个包含所有属性的 Map<String,Object> 对象。如果没有任何可识别的属性，则返回一个空映射。
从以下版本开始：
1.5
另请参见：
getProperty(String)

getProperty

public Object getProperty(String key)
获得由键指定的属性值。在类描述中对属性的概念进行了进一步的介绍。

如果对于一个特定的文件格式，指定的属性未定义，则此方法返回 null。

参数：
key - 所需属性的键
返回：
具有指定键的属性的值，如果此属性不存在，则返回 null。
从以下版本开始：
1.5
另请参见：
properties
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiMessage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 MidiMessage

java.lang.Object
    继承者  javax.sound.midi.MidiMessage
所有已实现的接口：
Cloneable
直接已知子类：
MetaMessage, ShortMessage, SysexMessage
public abstract class MidiMessage
extends Object
implements Cloneable

MidiMessage 是 MIDI 消息的基类。这些基类中不仅包含了合成器可响应的标准 MIDI 消息，还包含可供 sequencer 程序使用的“元事件”。还有针对类似歌词、版权、速度指示、时间和主要签名、制造者等信息的元事件。有关更多的信息，请参见 Standard MIDI Files 1.0 规范，它是由 MIDI 制造商协会 (http://www.midi.org) 发布的 Complete MIDI 1.0 Detailed Specification 的一部分。

MidiMessage 基类提供了对有关 MIDI 消息的三类信息的访问：

  • 消息的状态字节
  • 消息的总长度，以字节为单位（状态字节加数据字节）
  • 包含完整消息的 byte 数组
MidiMessage 包含了用于获取这些值的方法，但不包括用于设置这些值的方法。设置这些值是子类的任务。

MIDI 标准用字节表示 MIDI 数据。但是，由于 JavaTM 使用带符号字节，所以 Java Sound API 表示 MIDI 数据时使用整数而不是字节。例如，MidiMessage 的 getStatus() 方法返回用整数表示的 MIDI 状态字节。如果处理来源于 Java Sound 之外的 MIDI 数据，而现在又编码为带符号字节，可使用以下转换将字节转换为整数：

int i = (int)(byte & 0xFF)

如果只需要将一个已知 MIDI 字节值作为方法参数传递，则可使用（例如）十进制或十六进制符号直接将其表示为整数。例如，要传递“实际有意义的”状态字节作为 ShortMessage 的 setMessage(int) 方法的第一个参数，您可以将其表示为 254 或 0xFE。

另请参见：
Track, Sequence, Receiver

字段摘要
protected byte[] | data MIDI 消息数据。
protected int | length MIDI 消息中的字节数，包括状态字节和数据字节。
构造方法摘要
protected MidiMessage(byte[] data)
构造一个新的 MidiMessage。
方法摘要
abstract Object | clone() 创建一个与此对象具有相同类和相同内容的新对象。
int | getLength() 获得 MIDI 消息的总长度，以字节为单位。
byte[] | getMessage() 获得 MIDI 消息数据。
int | getStatus() 获得 MIDI 消息的状态字节。
protected void | setMessage(byte[] data, int length) 为 MIDI 消息设置数据。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

data

protected byte[] data
MIDI 消息数据。第一个字节是消息的状态字节；后面一直到消息长度字节为止的是此消息的数据字节。

另请参见：
getLength()

length

protected int length
MIDI 消息中的字节数，包括状态字节和数据字节。

另请参见：
getLength()
构造方法详细信息

MidiMessage

protected MidiMessage(byte[] data)
构造一个新的 MidiMessage。此受保护的构造方法由具体子类调用，具体子类应确保数据数组指定一个完整有效的 MIDI 消息。

参数：
data - 包含完整消息的 byte 数组。使用 setMessage 方法可更改消息数据。
另请参见：
setMessage(byte[], int)
方法详细信息

setMessage

protected void setMessage(byte[] data,
                          int length)
                   throws InvalidMidiDataException
为 MIDI 消息设置数据。此受保护的方法由具体子类调用，具体子类应确保数据数组指定一个完整有效的 MIDI 消息。

抛出：
InvalidMidiDataException

getMessage

public byte[] getMessage()
获得 MIDI 消息数据。返回的 byte 数组中的第一个字节是消息的状态字节。后面一直到消息长度字节为止的是数据字节。byte 数组的长度可能会大于实际消息的长度；消息总长度（以字节为单位）由 getLength() 方法报告。

返回：
包含完整的 MidiMessage 数据的 byte 数组

getStatus

public int getStatus()
获得 MIDI 消息的状态字节。以整数方式表示状态“字节”；请参见 MidiMessage 类描述中的讨论。

返回：
此事件的状态字节的整数表示形式

getLength

public int getLength()
获得 MIDI 消息的总长度，以字节为单位。一个 MIDI 消息包含一个状态字节和零个或多个数据字节。返回值的范围：系统实时消息为 1，通道消息为 2 或 3，元和系统独占消息为任意值。

返回：
消息的长度，以字节为单位

clone

public abstract Object clone()
创建一个与此对象具有相同类和相同内容的新对象。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiSystem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 MidiSystem

java.lang.Object
    继承者  javax.sound.midi.MidiSystem

public class MidiSystem
extends Object

MidiSystem 类提供了对已安装的 MIDI 系统资源的访问，包括诸如 synthesizer、sequencer 和 MIDI 输入和输出端口等设备。典型的简单 MIDI 应用程序可通过调用一个或多个 MidiSystem 方法开始，这样可了解已安装的设备并获得该应用程序中所需要的设备。

该类还有用于读取那些包含了标准 MIDI 文件数据或音库的文件、流和 URL 的方法。可以查询 MidiSystem 了解指定 MIDI 文件的格式。

无法实例化 MidiSystem；所有的方法都是静态的。

属性可用于指定默认的 MIDI 设备。系统属性和属性文件都可用于指定默认 MIDI 设备。属性文件是位于 JRE 目录中的 "lib/sound.properties"。如果一个属性既是系统属性，又包含在属性文件中，则系统属性优先。如果两者都未指定，则会在可用的设备中选择一个合适的默认值。属性文件的语法在 Properties.load 中指定。下表列出了可用的属性键和获取该属性的方法：

属性键 | 接口 | 起作用的方法
javax.sound.midi.Receiver | Receiver | getReceiver()
javax.sound.midi.Sequencer | Sequencer | getSequencer()
javax.sound.midi.Synthesizer | Synthesizer | getSynthesizer()
javax.sound.midi.Transmitter | Transmitter | getTransmitter()
属性值包含提供者类名和设备名，二者通过哈希标记 ("#") 分隔。提供者类名是具体 MIDI device provider 类的完全限定名称。设备名与由 MidiDevice.Info 的 getName 方法返回的 String 匹配。 类名或设备名都可以被忽略。如果只指定了类名，则尾部的哈希标记是可选的。

如果指定了提供者类，并且可从所安装的提供者中成功地检索到此类，则从该提供者检索 MidiDevice.Info 对象列表。否则，当这些设备未提供后续匹配时，则从 getMidiDeviceInfo() 检索该列表以包含所有可用的 MidiDevice.Info 对象。

如果指定了设备名，则搜索得到的 MidiDevice.Info 对象列表：将返回第一个具有匹配的名称，并且其 MidiDevice 实现了相应接口的结果。如果未找到任何匹配的 MidiDevice.Info 对象，或者未指定设备名称，则从结果列表返回第一个适合的设备。对于 Sequencer 和 Synthesizer，如果设备实现了相应的接口，则该设备为适合的设备；对于 Receiver 和 Transmitter，如果设备既未实现 Sequencer 也未实现 Synthesizer，并且至少分别提供了一个 Receiver 或 Transmitter，则该设备为适合的设备。 例如，对于具有 "com.sun.media.sound.MidiProvider#SunMIDI1" 值的属性 javax.sound.midi.Receiver，在调用 getReceiver 时，它将具有下面的结果：如果类 com.sun.media.sound.MidiProvider 出现在已安装的 MIDI 设备提供者列表中，则将返回第一个名称为 "SunMIDI1" 的 Receiver 设备。如果未找到此种设备，则将返回该提供者的第一个 Receiver，不考虑其名称。如果没有，则将返回所有设备列表中的第一个名称为 "SunMIDI1" 的 Receiver（如同从 getMidiDeviceInfo 返回的结果），如果未找到，则返回在所有设备列表中能找到的第一个 Receiver。如果仍未找到，则抛出 MidiUnavailableException。

方法摘要
static MidiDevice | getMidiDevice(MidiDevice.Info info) 获得请求的 MIDI 设备。
static MidiDevice.Info[] | getMidiDeviceInfo() 获得信息对象数组，表示系统中可用的所有 MIDI 设备集。
static MidiFileFormat | getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static MidiFileFormat | getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static MidiFileFormat | getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。
static int[] | getMidiFileTypes() 获得系统为其提供文件写入支持的 MIDI 文件类型的集合。
static int[] | getMidiFileTypes(Sequence sequence) 获得系统可从指定 sequence 写入的 MIDI 文件类型集合。
static Receiver | getReceiver() 从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。
static Sequence | getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Sequence | getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Sequence | getSequence(URL url) 从指定的 URL 获得 MIDI 序列。
static Sequencer | getSequencer() 获得连接到默认设备上的默认的 Sequencer。
static Sequencer | getSequencer(boolean connected) 获得默认的 Sequencer，它可选地连接到默认设备上。
static Soundbank | getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static Soundbank | getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
static Soundbank | getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。
static Synthesizer | getSynthesizer() 获得默认的合成器。
static Transmitter | getTransmitter() 从外部 MIDI 端口或其他默认源获得 MIDI 传输器。
static boolean | isFileTypeSupported(int fileType) 指示系统是否提供了指定 MIDI 文件类型的文件写入支持。
static boolean | isFileTypeSupported(int fileType, Sequence sequence) 指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
static int | write(Sequence in, int type, File out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。
static int | write(Sequence in, int fileType, OutputStream out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getMidiDeviceInfo

public static MidiDevice.Info[] getMidiDeviceInfo()
获得信息对象数组，表示系统中可用的所有 MIDI 设备集。然后，通过调用 getMidiDevice，可使用返回的信息对象获得相应的设备对象。

返回：
一个 MidiDevice.Info 对象的数组，每个已安装的 MIDI 设备对应一个对象。如果未安装这样的设备，则返回长度为 0 的数组。

getMidiDevice

public static MidiDevice getMidiDevice(MidiDevice.Info info)
                                throws MidiUnavailableException
获得请求的 MIDI 设备。

参数：
info - 表示所需设备的设备信息对象。
返回：
所请求的设备
抛出：
MidiUnavailableException - 如果由于资源限制使所请求的设备不可用
IllegalArgumentException - 如果 info 对象并不表示系统上已安装的 MIDI 设备
另请参见：
getMidiDeviceInfo()

getReceiver

public static Receiver getReceiver()
                            throws MidiUnavailableException
从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。

如果定义了系统属性 javax.sound.midi.Receiver，或者在文件 "sound.properties" 中定义了该属性，则它可用于标识提供了默认接收器的设备。有关详细信息，请参阅类描述。 如果没有适合的 MIDI 端口可用，则从已安装的合成器中检索 Receiver。

如果此方法成功返回，则隐式打开 Receiver 所属于的 MidiDevice（如果它尚未打开）。通过在返回的 Receiver 上调用 close 可以关闭一个隐式打开的设备。所有打开的 Receiver 实例都必须关闭，以释放由 MidiDevice 所占用的系统资源。有关打开/关闭行为的详细描述，请参见 MidiDevice 的类描述。

返回：
默认的 MIDI 接收器
抛出：
MidiUnavailableException - 如果由于资源限制使默认的接收器不可用，或者系统上未安装任何提供接收器的设备

getTransmitter

public static Transmitter getTransmitter()
                                  throws MidiUnavailableException
从外部 MIDI 端口或其他默认源获得 MIDI 传输器。

如果定义了系统属性 javax.sound.midi.Transmitter，或者在文件 "sound.properties" 中定义了该属性，则它可用于标识提供了默认传输器的设备。有关详细信息，请参阅类描述。 如果此方法成功返回，则隐式打开 Transmitter 所属于的 MidiDevice（如果它尚未打开）。通过在返回的 Transmitter 上调用 close 可以关闭一个隐式打开的设备。所有打开的 Transmitter 实例都必须关闭，以释放由 MidiDevice 所占用的系统资源。有关打开/关闭行为的详细描述，请参见 MidiDevice 的类描述。

返回：
默认的 MIDI 传输器
抛出：
MidiUnavailableException - 如果由于资源限制使默认的传输器不可用，或者系统上未安装任何提供传输器的设备

getSynthesizer

public static Synthesizer getSynthesizer()
                                  throws MidiUnavailableException
获得默认的合成器。

如果定义了系统属性 javax.sound.midi.Synthesizer，或者在文件 "sound.properties" 中定义了该属性，则它可用于标识默认的合成器。有关详细信息，请参阅类描述。

返回：
默认的合成器
抛出：
MidiUnavailableException - 如果由于资源限制使合成器不可用，或者系统上未安装任何合成器

getSequencer

public static Sequencer getSequencer()
                              throws MidiUnavailableException
获得连接到默认设备上的默认的 Sequencer。返回的 Sequencer 实例连接到默认的 Synthesizer，如同由 getSynthesizer() 返回的结果。如果没有可用的 Synthesizer，或者默认的 Synthesizer 无法打开，则 sequencer 会连接到默认的 Receiver，如同由 getReceiver() 返回的结果。该连接是通过从 Sequencer 检索 Transmitter 实例并设置其 Receiver 来建立的。关闭和重新打开 sequencer 将恢复到默认设备的连接。

此方法等效于调用 getSequencer(true)。

如果定义了系统属性 javax.sound.midi.Sequencer，或者在文件 "sound.properties" 中定义了该属性，则它可用于标识默认的 sequencer。有关详细信息，请参阅类描述。

返回：
连接到默认 Receiver 上的默认 sequencer
抛出：
MidiUnavailableException - 如果由于资源限制使 sequencer 不可用，或者任何已安装的 MidiDevice 上都没有可用的 Receiver，或者系统中未安装 sequencer。
另请参见：
getSequencer(boolean), getSynthesizer(), getReceiver()

getSequencer

public static Sequencer getSequencer(boolean connected)
                              throws MidiUnavailableException
获得默认的 Sequencer，它可选地连接到默认设备上。

如果 connected 为 true，则返回的 Sequencer 实例连接到默认的 Synthesizer，如同由 getSynthesizer() 返回的结果。如果没有可用的 Synthesizer，或者默认的 Synthesizer 无法打开，则 sequencer 会连接到默认的 Receiver，如同由 getReceiver() 返回的结果。该连接是通过从 Sequencer 检索 Transmitter 实例并设置其 Receiver 来建立的。关闭和重新打开 sequencer 将恢复到默认设备的连接。

如果 connected 为 false，则返回的 Sequencer 实例为未连接，它没有打开的 Transmitter。为了在 MIDI 设备或 Synthesizer 上运行 sequencer，有必要获得 Transmitter 并设置其 Receiver。

如果定义了系统属性 javax.sound.midi.Sequencer，或者在文件 "sound.properties" 中定义了该属性，则它可用于标识默认的 sequencer。有关详细信息，请参阅类描述。

返回：
默认的 sequencer
抛出：
MidiUnavailableException - 如果由于资源限制使 sequencer 不可用，或者系统中未安装 sequencer，或者如果 connected 为 true 并且任何已安装的 MidiDevice 都没有可用的 Receiver
从以下版本开始：
1.5
另请参见：
getSynthesizer(), getReceiver()

getSoundbank

public static Soundbank getSoundbank(InputStream stream)
                              throws InvalidMidiDataException,
                                     IOException
通过从指定的流读取来构造一个 MIDI 音库。该流必须指向有效的 MIDI 音库文件。通常，MIDI 文件提供者可能需要在确定它们是否支持流之前从中读取一些数据。这些解析器必须能够标记流，读取足够多的数据来确定它们是否支持流，并且如果不支持，则将流的阅读指针重新设置到其初始位置。如果输入流不支持此操作，则此方法可能会失败，并抛出 IOException。

参数：
stream - 音库数据的源。
返回：
音库
抛出：
InvalidMidiDataException - 如果该流没有指向系统识别的有效 MIDI 音库数据
IOException - 如果加载音库时发生 I/O 错误
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getSoundbank

public static Soundbank getSoundbank(URL url)
                              throws InvalidMidiDataException,
                                     IOException
通过从指定的 URL 处读取来构造一个 Soundbank。该 URL 必须指向有效的 MIDI 音库文件。

参数：
url - 音库数据的源
返回：
音库
抛出：
InvalidMidiDataException - 如果 URL 未指向系统识别的有效 MIDI 音库数据
IOException - 如果加载音库时发生 I/O 错误

getSoundbank

public static Soundbank getSoundbank(File file)
                              throws InvalidMidiDataException,
                                     IOException
通过从指定的 File 读取来构造一个 Soundbank。该 File 必须指向有效的 MIDI 音库文件。

参数：
file - 音库数据的源
返回：
音库
抛出：
InvalidMidiDataException - 如果 File 未指向系统识别的有效 MIDI 音库数据
IOException - 如果加载音库时发生 I/O 错误

getMidiFileFormat

public static MidiFileFormat getMidiFileFormat(InputStream stream)
                                        throws InvalidMidiDataException,
                                               IOException
获得指定的输入流中数据的 MIDI 文件格式。该流必须指向系统可识别的文件类型的有效 MIDI 文件数据。

此方法和/或它调用的代码可能需要从流读取一些数据，以确定是否支持流的数据格式。因此实现可能需要标记流、读取足够的数据来确定流是否为支持的格式，并将流的阅读指针重新设置到其初始位置。如果输入流不允许此组操作，则此方法可能会失败，并抛出 IOException。

只有针对那些能由已安装的文件 reader 所解析的类型的文件，该操作才能成功。即使是有效的文件，如果未安装兼容的文件 reader，则也会失败并抛出 InvalidMidiDataException。如果安装了兼容的文件 reader，但在确定文件格式时遇到错误，则也会失败并抛出 InvalidMidiDataException。

参数：
stream - 应从中提取文件格式信息的输入流
返回：
描述 MIDI 文件格式的 MidiFileFormat 对象
抛出：
InvalidMidiDataException - 如果流没有指向系统识别的有效 MIDI 文件数据
IOException - 如果访问流时发生 I/O 异常
另请参见：
getMidiFileFormat(URL), getMidiFileFormat(File), InputStream.markSupported(), InputStream.mark(int)

getMidiFileFormat

public static MidiFileFormat getMidiFileFormat(URL url)
                                        throws InvalidMidiDataException,
                                               IOException
获得指定 URL 中数据的 MIDI 文件格式。该 URL 必须指向系统可识别的文件类型的有效 MIDI 文件数据。

只有针对那些能由已安装的文件 reader 所解析的类型的文件，该操作才能成功。即使是有效的文件，如果未安装兼容的文件 reader，则也会失败并抛出 InvalidMidiDataException。如果安装了兼容的文件 reader，但在确定文件格式时遇到错误，则也会失败并抛出 InvalidMidiDataException。

参数：
url - 应该从中提取文件格式信息的 URL
返回：
描述 MIDI 文件格式的 MidiFileFormat 对象
抛出：
InvalidMidiDataException - 如果 URL 没有指向系统识别的有效 MIDI 文件数据
IOException - 如果访问 URL 时发生 I/O 异常
另请参见：
getMidiFileFormat(InputStream), getMidiFileFormat(File)

getMidiFileFormat

public static MidiFileFormat getMidiFileFormat(File file)
                                        throws InvalidMidiDataException,
                                               IOException
获得指定 File 的 MIDI 文件格式。该 File 必须指向系统可识别的文件类型的有效 MIDI 文件数据。

只有针对那些能由已安装的文件 reader 所解析的类型的文件，该操作才能成功。即使是有效的文件，如果未安装兼容的文件 reader，则也会失败并抛出 InvalidMidiDataException。如果安装了兼容的文件 reader，但在确定文件格式时遇到错误，则也会失败并抛出 InvalidMidiDataException。

参数：
file - 应该从中提取文件格式信息的 File
返回：
描述 MIDI 文件格式的 MidiFileFormat 对象
抛出：
InvalidMidiDataException - 如果 File 没有指向系统可识别的有效 MIDI 文件数据
IOException - 如果访问文件时发生 I/O 异常
另请参见：
getMidiFileFormat(InputStream), getMidiFileFormat(URL)

getSequence

public static Sequence getSequence(InputStream stream)
                            throws InvalidMidiDataException,
                                   IOException
从指定的输入流获得 MIDI 序列。该流必须指向系统可识别的文件类型的有效 MIDI 文件数据。

此方法和/或它调用的代码可能需要从流读取一些数据，以确定是否支持流的数据格式。因此实现可能需要标记流、读取足够的数据来确定流是否为支持的格式，并将流的阅读指针重新设置到其初始位置。如果输入流不允许此组操作，则此方法可能会失败，并抛出 IOException。

只有针对那些能由已安装的文件 reader 所解析的类型的文件，该操作才能成功。即使是有效的文件，如果未安装兼容的文件 reader，则也会失败并抛出 InvalidMidiDataException。如果安装了兼容的文件 reader，但在从文件数据构造 Sequence 对象时遇到错误，则也会失败并抛出 InvalidMidiDataException。

参数：
stream - 应该从中构造 Sequence 的输入流
返回：
基于输入流中包含的 MIDI 文件数据的 Sequence 对象
抛出：
InvalidMidiDataException - 如果流没有指向系统识别的有效 MIDI 文件数据
IOException - 如果访问流时发生 I/O 异常
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getSequence

public static Sequence getSequence(URL url)
                            throws InvalidMidiDataException,
                                   IOException
从指定的 URL 获得 MIDI 序列。该 URL 必须指向系统可识别的文件类型的有效 MIDI 文件数据。

只有针对那些能由已安装的文件 reader 所解析的类型的文件，该操作才能成功。即使是有效的文件，如果未安装兼容的文件 reader，则也会失败并抛出 InvalidMidiDataException。如果安装了兼容的文件 reader，但在从文件数据构造 Sequence 对象时遇到错误，则也会失败并抛出 InvalidMidiDataException。

参数：
url - 应该从中构造 Sequence 的 URL
返回：
基于由 URL 指向的 MIDI 文件数据的 Sequence 对象
抛出：
InvalidMidiDataException - 如果 URL 没有指向系统识别的有效 MIDI 文件数据
IOException - 如果访问 URL 时发生 I/O 异常

getSequence

public static Sequence getSequence(File file)
                            throws InvalidMidiDataException,
                                   IOException
从指定的 File 获得 MIDI 序列。该 File 必须指向系统可识别的文件类型的有效 MIDI 文件数据。

只有针对那些能由已安装的文件 reader 所解析的类型的文件，该操作才能成功。即使是有效的文件，如果未安装兼容的文件 reader，则也会失败并抛出 InvalidMidiDataException。如果安装了兼容的文件 reader，但在从文件数据构造 Sequence 对象时遇到错误，则也会失败并抛出 InvalidMidiDataException。

参数：
file - 应该从中构造 Sequence 的 File
返回：
基于由 File 指向的 MIDI 文件数据的 Sequence 对象
抛出：
InvalidMidiDataException - 如果 File 没有指向系统识别的有效 MIDI 文件数据
IOException - 如果发生 I/O 异常

getMidiFileTypes

public static int[] getMidiFileTypes()
获得系统为其提供文件写入支持的 MIDI 文件类型的集合。

返回：
唯一文件类型的数组。如果不支持任何文件类型，则返回长度为 0 的数组。

isFileTypeSupported

public static boolean isFileTypeSupported(int fileType)
指示系统是否提供了指定 MIDI 文件类型的文件写入支持。

参数：
fileType - 查询其写入功能的文件类型
返回：
如果支持文件类型，则返回 true；否则返回 false

getMidiFileTypes

public static int[] getMidiFileTypes(Sequence sequence)
获得系统可从指定 sequence 写入的 MIDI 文件类型集合。

参数：
sequence - 为其查询 MIDI 文件类型支持的序列
返回：
唯一的受支持文件类型的集合。如果不支持任何文件类型，则返回长度为 0 的数组。

isFileTypeSupported

public static boolean isFileTypeSupported(int fileType,
                                          Sequence sequence)
指示是否可从指示的序列写入指定文件类型的 MIDI 文件。

参数：
fileType - 查询其写入功能的文件类型
sequence - 查询其文件写入支持的序列
返回：
如果支持此序列的文件类型，则返回 true；否则返回 false

write

public static int write(Sequence in,
                        int fileType,
                        OutputStream out)
                 throws IOException
将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。

参数：
in - 包含要写入文件的 MIDI 数据的序列
fileType - 要写入输出流的文件的文件类型
out - 应将文件数据写入的流
返回：
写入到输出流的字节数
抛出：
IOException - 如果发生 I/O 异常
IllegalArgumentException - 如果系统不支持该文件格式
另请参见：
isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)

write

public static int write(Sequence in,
                        int type,
                        File out)
                 throws IOException
将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。

参数：
in - 包含要写入文件的 MIDI 数据的序列
type - 要写入输出流的文件的文件类型
out - 应将文件数据写入的外部文件
返回：
写入到文件的字节数
抛出：
IOException - 如果发生 I/O 异常
IllegalArgumentException - 如果系统不支持该文件类型
另请参见：
isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiUnavailableException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 MidiUnavailableException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.sound.midi.MidiUnavailableException
所有已实现的接口：
Serializable
public class MidiUnavailableException
extends Exception

当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。当设备由另一个应用程序使用时经常出现这种情况。更一般的情况是，有限数量的某种资源可用于某种用途，而所有这些资源都正在使用（可能都由此应用程序使用）时，会出现这种情况。后一种情况的示例，请参见 Transmitter 的 setReceiver 方法。

另请参见：
序列化表格

构造方法摘要
MidiUnavailableException()
构造一个 MidiUnavailableException，使用 null 作为其错误详细消息。
MidiUnavailableException(String message)
构造带指定详细消息的 MidiUnavailableException。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MidiUnavailableException

public MidiUnavailableException()
构造一个 MidiUnavailableException，使用 null 作为其错误详细消息。

MidiUnavailableException

public MidiUnavailableException(String message)
构造带指定详细消息的 MidiUnavailableException。

参数：
message - 将作为错误详细消息显示的字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Patch (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 Patch

java.lang.Object
    继承者  javax.sound.midi.Patch

public class Patch
extends Object

一个 Patch 对象，用于表示 MIDI 合成器上的某个位置，其中存储（加载）了单个乐器。每个 Instrument 对象都有其自己的 Patch 对象，它指定了乐器应加载到的内存位置。该位置由一个库索引和一个程序号抽象指定（而不是通过任何直接引用 RAM 的具体地址或偏移量的机制指定）。这是一种层次化索引机制：MIDI 提供多达 16384 个库，每个库包含多达 128 个程序位置。例如，最小类型的合成器可能只有一个乐器库，该库中只有 32 种乐器（程序）。

要选择演奏特定 MIDI 通道上的音符所使用的乐器，可使用两种指定包位置 MIDI 消息：一个是库选择命令，一个是程序更改通道命令。等效的 Java Sound 为 MidiChannel 的 programChange(int, int) 方法。

另请参见：
Instrument,
Instrument.getPatch(),
MidiChannel.programChange(int, int),
Synthesizer.loadInstruments(Soundbank, Patch[]),
Soundbank,
Sequence.getPatchList()

构造方法摘要
Patch(int bank, int program)
从指定的库和程序号构造一个新的 patch 对象。
方法摘要
int | getBank() 返回包含该 Patch 指定其位置乐器的库的号码。
int | getProgram() 返回该 Patch 指定其位置的乐器在库中的索引号。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Patch

public Patch(int bank,
             int program)
从指定的库和程序号构造一个新的 patch 对象。

参数：
bank - 库索引（范围从 0 到 16383）
program - 程序索引（范围从 0 到 127）
方法详细信息

getBank

public int getBank()
返回包含该 Patch 指定其位置乐器的库的号码。

返回：
库号，范围从 0 到 16383
另请参见：
MidiChannel.programChange(int, int)

getProgram

public int getProgram()
返回该 Patch 指定其位置的乐器在库中的索引号。

返回：
乐器的程序号，范围从 0 到 127
另请参见：
MidiChannel.getProgram(),
MidiChannel.programChange(int),
MidiChannel.programChange(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Receiver (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 Receiver

public interface Receiver

一个 Receiver，用于接收 MidiEvent 对象，并且通常执行一些响应性的操作，例如，解释该对象以生成声音或原始 MIDI 输出。常见的 MIDI 接收器包括合成器和 MIDI Out 端口。

另请参见：
MidiDevice, Synthesizer, Transmitter

方法摘要
void | close() 指示应用程序已结束使用接收器，以及其请求的受限制资源可能已被释放或已可用。
void | send(MidiMessage message, long timeStamp) 向接收器发送一个 MIDI 消息和时间戳。

方法详细信息

send

void send(MidiMessage message,
          long timeStamp)
向接收器发送一个 MIDI 消息和时间戳。如果该接收器不支持时间戳，则该时间戳值应为 -1。

参数：
message - 要发送的 MIDI 消息
timeStamp - 消息的时间戳，以微秒为单位。
抛出：
IllegalStateException - 如果接收器关闭

close

void close()
指示应用程序已结束使用接收器，以及其请求的受限制资源可能已被释放或已可用。

如果创建此 Receiver 导致隐式打开底层设备，则该方法隐式关闭该设备。只有当设备由其他隐式打开该设备的 Receiver 或 Transmitter 实例保持打开，以及此设备已显式打开时才会出现这种情况。如果从其检索该 Receiver 的设备通过调用 MidiDevice.close 显式关闭，则 Receiver 也被关闭。有关打开/关闭行为的详细描述，请参见 MidiDevice 的类描述。

另请参见：
MidiSystem.getReceiver()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Sequence (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 Sequence

java.lang.Object
    继承者  javax.sound.midi.Sequence

public class Sequence
extends Object

Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。特别地，Sequence 包含定时信息和一个或多个轨道。每个 track 包含一系列的 MIDI 事件（例如音符打开、音符关闭、程序更改和元事件）。sequence 的定时信息指定了用于为 sequence 中的事件加时间戳的单位类型。

Sequence 可从一个 MIDI 文件创建，方法是将该文件读入到输入流并调用 MidiSystem 的某个 getSequence 方法。还可以从头构建 sequence，方法是将新的 Track 添加到空 Sequence 中，然后将 MidiEvent 对象添加到这些 Track 中。

另请参见：
Sequencer.setSequence(java.io.InputStream stream),
Sequencer.setSequence(Sequence sequence),
Track.add(MidiEvent),
MidiFileFormat

字段摘要
protected float | divisionType sequence 的定时 division 类型。
static float | PPQ 基于速度的定时类型，其精度用每四分音符的拍子数（节拍）表示。
protected int | resolution sequence 的定时精度。
static float | SMPTE_24 基于 SMPTE 的定时类型，每秒 24 帧（精度用每帧的节拍数表示）。
static float | SMPTE_25 基于 SMPTE 的定时类型，每秒 25 帧（精度用每帧的节拍数表示）。
static float | SMPTE_30 基于 SMPTE 的定时类型，每秒 30 帧（精度用每帧的节拍数表示）。
static float | SMPTE_30DROP 基于 SMPTE 的定时类型，每秒 29.97 帧（精度用每帧的节拍数表示）。
protected Vector<Track> | tracks 此 sequence 中的 MIDI 轨道。
构造方法摘要
Sequence(float divisionType, int resolution)
构造具有指定的定时 division 类型和定时精度的新 MIDI Sequence。
Sequence(float divisionType, int resolution, int numTracks)
构造具有指定的定时 division 类型、定时精度和轨道数的新 MIDI Sequence。
方法摘要
Track | createTrack() 创建一个新的、初始为空的轨道作为此 Sequence 的一部分。
boolean | deleteTrack(Track track) 从 Sequence 中移除指定的轨道。
float | getDivisionType() 获得此 Sequence 的定时 division 类型。
long | getMicrosecondLength() 获得此 Sequence 的持续时间，用微秒表示。
Patch[] | getPatchList() 获得此 Sequence 中引用的包列表。
int | getResolution() 获得此 Sequence 的定时精度。
long | getTickLength() 获得此 Sequence 的持续时间，用 MIDI 节拍数表示。
Track[] | getTracks() 获得包含此 Sequence 中所有轨道的数组。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

PPQ

public static final float PPQ
基于速度的定时类型，其精度用每四分音符的拍子数（节拍）表示。

另请参见：
Sequence(float, int), 常量字段值

SMPTE_24

public static final float SMPTE_24
基于 SMPTE 的定时类型，每秒 24 帧（精度用每帧的节拍数表示）。

另请参见：
Sequence(float, int), 常量字段值

SMPTE_25

public static final float SMPTE_25
基于 SMPTE 的定时类型，每秒 25 帧（精度用每帧的节拍数表示）。

另请参见：
Sequence(float, int), 常量字段值

SMPTE_30DROP

public static final float SMPTE_30DROP
基于 SMPTE 的定时类型，每秒 29.97 帧（精度用每帧的节拍数表示）。

另请参见：
Sequence(float, int), 常量字段值

SMPTE_30

public static final float SMPTE_30
基于 SMPTE 的定时类型，每秒 30 帧（精度用每帧的节拍数表示）。

另请参见：
Sequence(float, int), 常量字段值

divisionType

protected float divisionType
sequence 的定时 division 类型。

另请参见：
PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, getDivisionType()

resolution

protected int resolution
sequence 的定时精度。

另请参见：
getResolution()

tracks

protected Vector<Track> tracks
此 sequence 中的 MIDI 轨道。

另请参见：
getTracks()
构造方法详细信息

Sequence

public Sequence(float divisionType,
                int resolution)
         throws InvalidMidiDataException
构造具有指定的定时 division 类型和定时精度的新 MIDI Sequence。division 类型必须是可识别的 MIDI 定时类型之一。对于基于速度的定时，divisionType 是 PPQ（每四分音符的节拍数），精度通过每拍的节拍数指定。对于 SMTPE 定时，divisionType 指定每秒的帧数，精度通过每帧的节拍数指定。该 Sequence 不包含任何初始轨道。可从 Sequence 中添加或移除轨道，方法是使用 createTrack() 和 deleteTrack(javax.sound.midi.Track)。

参数：
divisionType - 定时 division 类型（PPQ 和某个 SMPTE 类型）
resolution - 定时精度
抛出：
InvalidMidiDataException - 如果 divisionType 无效
另请参见：
PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, getDivisionType(), getResolution(), getTracks()

Sequence

public Sequence(float divisionType,
                int resolution,
                int numTracks)
         throws InvalidMidiDataException
构造具有指定的定时 division 类型、定时精度和轨道数的新 MIDI Sequence。division 类型必须是可识别的 MIDI 定时类型之一。对于基于速度的定时，divisionType 是 PPQ（每四分音符的节拍数），精度通过每拍的节拍数指定。对于 SMTPE 定时，divisionType 指定每秒的帧数，精度通过每帧的节拍数指定。将使用由 numTracks 指定的轨道数来初始化该 Sequence。这些轨道初始为空（即它们只包含元事件 End of Track）。使用 getTracks() 方法可检索轨道以供编辑。还可以使用 createTrack() 和 deleteTrack(javax.sound.midi.Track) 添加其他的轨道或移除现有的轨道。

参数：
divisionType - 定时 division 类型（PPQ 或某个 SMPTE 类型）
resolution - 定时精度
numTracks - Sequence 中的初始轨道数。
抛出：
InvalidMidiDataException - 如果 divisionType 无效
另请参见：
PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, getDivisionType(), getResolution()
方法详细信息

getDivisionType

public float getDivisionType()
获得此 Sequence 的定时 division 类型。

返回：
division 类型（PPQ 或某个 SMPTE 类型）
另请参见：
PPQ, SMPTE_24, SMPTE_25, SMPTE_30DROP, SMPTE_30, Sequence(float, int), MidiFileFormat.getDivisionType()

getResolution

public int getResolution()
获得此 Sequence 的定时精度。如果 Sequence 的 division 类型为 PPQ，则精度按每拍的节拍数指定。对于 SMTPE 定时，精度按每帧的节拍数指定。

返回：
每拍 (PPQ) 或每帧 (SMPTE) 的节拍数
另请参见：
getDivisionType(),
Sequence(float, int),
MidiFileFormat.getResolution()

createTrack

public Track createTrack()
创建一个新的、初始为空的轨道作为此 Sequence 的一部分。轨道初始包含元事件 End of Track。返回新创建的轨道。可使用 getTracks() 检索 Sequence 中的所有轨道。可使用 deleteTrack(javax.sound.midi.Track) 从 Sequence 中移除轨道。

返回：
新创建的轨道

deleteTrack

public boolean deleteTrack(Track track)
从 Sequence 中移除指定的轨道。

参数：
track - 要移除的轨道
返回：
如果轨道原先存在但后来被移除，则返回 true；否则返回 false。
另请参见：
createTrack(), getTracks()

getTracks

public Track[] getTracks()
获得包含此 Sequence 中所有轨道的数组。如果 Sequence 中不包含任何轨道，则返回长度为 0 的数组。

返回：
轨道数组
另请参见：
createTrack(), deleteTrack(javax.sound.midi.Track)

getMicrosecondLength

public long getMicrosecondLength()
获得此 Sequence 的持续时间，用微秒表示。

返回：
此 Sequence 的持续时间，以微秒为单位。

getTickLength

public long getTickLength()
获得此 Sequence 的持续时间，用 MIDI 节拍数表示。

返回：
此 Sequence 的长度，以节拍数为单位
另请参见：
getMicrosecondLength()

getPatchList

public Patch[] getPatchList()
获得此 Sequence 中引用的包列表。使用该包列表可将所需的 Instrument 对象加载到 Synthesizer 中。

返回：
此 Sequence 中使用的 Patch 对象数组
另请参见：
Synthesizer.loadInstruments(Soundbank, Patch[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Sequencer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 Sequencer

所有超级接口：
MidiDevice
public interface Sequencer
extends MidiDevice

回放 MIDI sequence 的硬件或软件设备就是所谓的 sequencer。MIDI sequence 包含加了时间戳的 MIDI 数据列表，例如可从标准 MIDI 文件读取的数据。多数 sequencer 还提供创建和编辑 sequence 的功能。

Sequencer 接口包括用于以下基本 MIDI sequencer 操作的方法：

  • 从 MIDI 文件数据获取一个 sequence
  • 开始和停止回放
  • 移动到 sequence 中的任意位置
  • 更改回放速度
  • 将回放与内部时钟或接收到的 MIDI 消息同步
  • 控制另一个设备的定时
另外还以直接或间接的方式，通过 Sequencer 可访问的对象支持以下操作：
  • 通过添加或删除单独 MIDI 事件或整个轨道来编辑数据
  • 对 sequence 中的单独轨道静音或执行独奏
  • 通知 listener 对象有关回放 sequence 时遇到的任何元事件或控制更改事件。

另请参见：
Sequencer.SyncMode, addMetaEventListener(javax.sound.midi.MetaEventListener), ControllerEventListener, Receiver, Transmitter, MidiDevice

嵌套类摘要
static class Sequencer.SyncMode
SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。
从接口 javax.sound.midi.MidiDevice 继承的嵌套类/接口
MidiDevice.Info
字段摘要
static int LOOP_CONTINUOUSLY
一个值，指示循环应无限继续而不是在执行完特定次数的循环后停止。
方法摘要
int[] | addControllerEventListener(ControllerEventListener listener, int[] controllers) 注册一个控件事件侦听器，以便在 sequencer 处理所请求的一种或多种类型的控制更改事件时接收通知。
boolean | addMetaEventListener(MetaEventListener listener) 注册一个元事件侦听器，以便在 sequence 中遇到元事件并由此 sequencer 处理时接收通知。
int | getLoopCount() 获得回放的重复次数。
long | getLoopEndPoint() 获得循环的结束位置，以 MIDI 节拍为单位。
long | getLoopStartPoint() 获得循环的起始位置，以 MIDI 节拍为单位。
Sequencer.SyncMode | getMasterSyncMode() 获得此 sequencer 的当前主同步模式。
Sequencer.SyncMode[] | getMasterSyncModes() 获得此 sequencer 支持的主同步模式集。
long | getMicrosecondLength() 获得当前 sequence 的长度，用微秒表示，如果未设置 sequence，则为 0。
long | getMicrosecondPosition() 获得 sequence 中的当前位置，用微秒表示。
Sequence | getSequence() 获得 Sequencer 当前所操作的 sequence。
Sequencer.SyncMode | getSlaveSyncMode() 获得此 sequencer 的当前从同步模式。
Sequencer.SyncMode[] | getSlaveSyncModes() 获得此 sequencer 支持的从同步模式集。
float | getTempoFactor() 返回 sequencer 的当前速度因子。
float | getTempoInBPM() 获得当前的速度，用每分钟的拍数表示。
float | getTempoInMPQ() 获得当前的速度，用每四分音符的微秒数表示。
long | getTickLength() 获得当前 sequence 的长度，用 MIDI 节拍数表示，如果未设置 sequence，则为 0。
long | getTickPosition() 获得 sequence 的当前位置，用 MIDI 节拍数表示。
boolean | getTrackMute(int track) 获得轨道的当前静音状态。
boolean | getTrackSolo(int track) 获得轨道的当前 solo 状态。
boolean | isRecording() 指示 Sequencer 当前是否正在录制。
boolean | isRunning() 指示 Sequencer 当前是否正在运行。
void | recordDisable(Track track) 禁止向指定轨道的录制。
void | recordEnable(Track track, int channel) 为录制特定通道上接收的事件准备指定的轨道。
int[] | removeControllerEventListener(ControllerEventListener listener, int[] controllers) 移除侦听一类或多类控件事件的控件事件侦听器。
void | removeMetaEventListener(MetaEventListener listener) 从此 sequencer 的已注册侦听器列表中移除指定的元事件侦听器（如果实际上此侦听器已注册）。
void | setLoopCount(int count) 设置循环回放的重复次数。
void | setLoopEndPoint(long tick) 设置在循环中播放的最后一个 MIDI 节拍。
void | setLoopStartPoint(long tick) 设置在循环中播放的第一个 MIDI 节拍。
void | setMasterSyncMode(Sequencer.SyncMode sync) 设置此 sequencer 使用的定时信息源。
void | setMicrosecondPosition(long microseconds) 设置 sequence 中的当前位置，用微秒表示
void | setSequence(InputStream stream) 设置 sequencer 所操作的当前 sequence。
void | setSequence(Sequence sequence) 设置 sequencer 所操作的当前 sequence。
void | setSlaveSyncMode(Sequencer.SyncMode sync) 设置此 sequencer 的从同步模式。
void | setTempoFactor(float factor) 根据所提供的 factor 按比例提高 sequencer 的实际回放速度。
void | setTempoInBPM(float bpm) 设置速度，以每分钟的拍数为单位。
void | setTempoInMPQ(float mpq) 设置速度，以每四分音符的微秒数为单位。
void | setTickPosition(long tick) 设置当前 sequencer 位置，以 MIDI 节拍数为单位。
void | setTrackMute(int track, boolean mute) 设置轨道的静音状态。
void | setTrackSolo(int track, boolean solo) 设置轨道的 solo 状态。
void | start() 开始回放当前已加载 sequence 中的 MIDI 数据。
void | startRecording() 开始录制和回放 MIDI 数据。
void | stop() 停止录音（如果处于活动状态）及当前已加载 sequence（如果有）的回放。
void | stopRecording() 停止录制（如果处于活动状态）。
从接口 javax.sound.midi.MidiDevice 继承的方法
close, getDeviceInfo, getMaxReceivers, getMaxTransmitters, getReceiver, getReceivers, getTransmitter, getTransmitters, isOpen, open

字段详细信息

LOOP_CONTINUOUSLY

static final int LOOP_CONTINUOUSLY
一个值，指示循环应无限继续而不是在执行完特定次数的循环后停止。

从以下版本开始：
1.5
另请参见：
setLoopCount(int), 常量字段值
方法详细信息

setSequence

void setSequence(Sequence sequence)
                 throws InvalidMidiDataException
设置 sequencer 所操作的当前 sequence。

此方法即使在 Sequencer 关闭时也可调用。

参数：
sequence - 要加载的 sequence。
抛出：
InvalidMidiDataException - 如果该 sequence 包含无效的 MIDI 数据或不受支持的数据。

setSequence

void setSequence(InputStream stream)
                 throws IOException,
                        InvalidMidiDataException
设置 sequencer 所操作的当前 sequence。该流必须指向 MIDI 文件数据。

此方法即使在 Sequencer 关闭时也可调用。

参数：
stream - 包含 MIDI 文件数据的流。
抛出：
IOException - 如果读取流时发生 I/O 异常。
InvalidMidiDataException - 如果在流中遇到无效数据，或者流不受支持。

getSequence

Sequence getSequence()
获得 Sequencer 当前所操作的 sequence。

此方法即使在 Sequencer 关闭时也可调用。

返回：
当前的 sequence，如果当前未设置任何 sequence，则返回 null。

start

void start()
开始回放当前已加载 sequence 中的 MIDI 数据。回放将从当前位置开始。如果回放位置到达循环终点，并且循环计数大于 0，则回放将从循环开始点继续运行 setLoopCount 中设置的重复次数。此后，如果循环计数为 0，则回放将继续播放直到 sequence 末尾。

该实现确保合成器在跳转到循环开始点时通过发送合适的控件、弯音和程序更改事件来保持一致的状态。

抛出：
IllegalStateException - 如果 Sequencer 已关闭。
另请参见：
setLoopStartPoint(long), setLoopEndPoint(long), setLoopCount(int), stop()

stop

void stop()
停止录音（如果处于活动状态）及当前已加载 sequence（如果有）的回放。

抛出：
IllegalStateException - 如果 Sequencer 已关闭。
另请参见：
start(), isRunning()

isRunning

boolean isRunning()
指示 Sequencer 当前是否正在运行。默认值为 false。Sequencer 在调用 start() 或 startRecording() 之一时开始运行。然后 isRunning 返回 true，直到 sequence 的回放完成或调用了 stop()。

返回：
如果 Sequencer 正在运行中，则返回 true；否则返回 false

startRecording

void startRecording()
开始录制和回放 MIDI 数据。数据录制到为其启用的通道上的所有已启用音轨上。录制从 sequencer 的当前位置开始。录制会话过程中重写音轨上的全部已有事件。取自当前已加载 sequence 的事件（如果有）随录制过程中接收的消息传递给 sequencer 的传输器。

注意，默认不允许轨道进行录制。为了录制 MIDI 数据，必须至少指定一个轨道允许录制。

抛出：
IllegalStateException - 如果 Sequencer 已关闭。
另请参见：
startRecording(),
recordEnable(javax.sound.midi.Track, int),
recordDisable(javax.sound.midi.Track)

stopRecording

void stopRecording()
停止录制（如果处于活动状态）。继续当前 sequence 的回放。

抛出：
IllegalStateException - 如果 Sequencer 已关闭。
另请参见：
startRecording(), isRecording()

isRecording

boolean isRecording()
指示 Sequencer 当前是否正在录制。默认值为 false。Sequencer 在 startRecording() 调用时开始录制，然后在调用 stop() 或 stopRecording() 前，此方法返回 true。

返回：
如果 Sequencer 正在录制中，则返回 true；否则返回 false

recordEnable

void recordEnable(Track track,
                  int channel)
为录制特定通道上接收的事件准备指定的轨道。一旦启用，轨道将在录制处于活动状态时接收事件。

参数：
track - 要录制事件的轨道
channel - 接收其上事件的通道。如果通道值指定为 -1，则轨道将从所有通道接收数据。
抛出：
IllegalArgumentException - 如果 track 不是当前 sequence 的一部分。

recordDisable

void recordDisable(Track track)
禁止向指定轨道的录制。事件将不再录制到此轨道中。

参数：
track - 要禁止录制的轨道，或为 null 以禁止录制到所有轨道。

getTempoInBPM

float getTempoInBPM()
获得当前的速度，用每分钟的拍数表示。实际的回放速度是返回值和速度因子的乘积。

返回：
当前的速度，用每分钟的拍数表示
另请参见：
getTempoFactor(), setTempoInBPM(float), getTempoInMPQ()

setTempoInBPM

void setTempoInBPM(float bpm)
设置速度，以每分钟的拍数为单位。实际的回放速度是指定值和速度因子的乘积。

参数：
bpm - 所需的新速度，以每分钟的拍数为单位
另请参见：
getTempoFactor(), setTempoInMPQ(float), getTempoInBPM()

getTempoInMPQ

float getTempoInMPQ()
获得当前的速度，用每四分音符的微秒数表示。实际的回放速度是返回值和速度因子的乘积。

返回：
当前的速度，以每四分音符的微秒数为单位
另请参见：
getTempoFactor(), setTempoInMPQ(float), getTempoInBPM()

setTempoInMPQ

void setTempoInMPQ(float mpq)
设置速度，以每四分音符的微秒数为单位。实际的回放速度是指定值和速度因子的乘积。

参数：
mpq - 所需的新速度，以每四分音符的微秒数为单位。
另请参见：
getTempoFactor(), setTempoInBPM(float), getTempoInMPQ()

setTempoFactor

void setTempoFactor(float factor)
根据所提供的 factor 按比例提高 sequencer 的实际回放速度。默认值是 1.0。值为 1.0 表示固有的速率（sequence 中指定的速度），2.0 表示速度为两倍大小，依此类推。速度因子并不影响 getTempoInMPQ() 和 getTempoInBPM() 返回的值。这些值指示提高速度前的速度。

注意，在使用外部同步时无法调整速度因子。这种情况下，setTempoFactor 始终将速度因子设置为 1.0。

参数：
factor - 所请求的速度标量
另请参见：
getTempoFactor()

getTempoFactor

float getTempoFactor()
返回 sequencer 的当前速度因子。默认值是 1.0。

返回：
速度因子。
另请参见：
setTempoFactor(float)

getTickLength

long getTickLength()
获得当前 sequence 的长度，用 MIDI 节拍数表示，如果未设置 sequence，则为 0。

返回：
sequence 的长度，以节拍数为单位

getTickPosition

long getTickPosition()
获得 sequence 的当前位置，用 MIDI 节拍数表示。（节拍持续的秒数由速度和存储在 Sequence 中的定时精度确定。）

返回：
当前节拍
另请参见：
setTickPosition(long)

setTickPosition

void setTickPosition(long tick)
设置当前 sequencer 位置，以 MIDI 节拍数为单位。

参数：
tick - 所需的节拍位置
另请参见：
getTickPosition()

getMicrosecondLength

long getMicrosecondLength()
获得当前 sequence 的长度，用微秒表示，如果未设置 sequence，则为 0。

返回：
sequence 的长度，用微秒表示。

getMicrosecondPosition

long getMicrosecondPosition()
获得 sequence 中的当前位置，用微秒表示。

指定者：
接口 MidiDevice 中的 getMicrosecondPosition
返回：
当前位置，用微秒表示
另请参见：
setMicrosecondPosition(long)

setMicrosecondPosition

void setMicrosecondPosition(long microseconds)
设置 sequence 中的当前位置，用微秒表示

参数：
microseconds - 所需的位置，以微秒为单位
另请参见：
getMicrosecondPosition()

setMasterSyncMode

void setMasterSyncMode(Sequencer.SyncMode sync)
设置此 sequencer 使用的定时信息源。Sequencer 与主同步模式同步，主同步模式为内部时钟、MIDI 时钟和 MIDI 时间代码，具体取决于 sync 的值。sync 参数必须是所支持的模式之一，如 getMasterSyncModes() 返回的结果。

参数：
sync - 所需的主同步模式
另请参见：
Sequencer.SyncMode.INTERNAL_CLOCK, Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, getMasterSyncMode()

getMasterSyncMode

Sequencer.SyncMode getMasterSyncMode()
获得此 sequencer 的当前主同步模式。

返回：
当前的主同步模式
另请参见：
setMasterSyncMode(Sequencer.SyncMode), getMasterSyncModes()

getMasterSyncModes

Sequencer.SyncMode[] getMasterSyncModes()
获得此 sequencer 支持的主同步模式集。

返回：
可用的主同步模式
另请参见：
Sequencer.SyncMode.INTERNAL_CLOCK, Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, getMasterSyncMode(), setMasterSyncMode(Sequencer.SyncMode)

setSlaveSyncMode

void setSlaveSyncMode(Sequencer.SyncMode sync)
设置此 sequencer 的从同步模式。这指示由 sequencer 发送到接收器的定时信息类型。sync 参数必须是所支持的模式之一，如 getSlaveSyncModes() 返回的结果。

参数：
sync - 所需的从同步模式
另请参见：
Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, Sequencer.SyncMode.NO_SYNC, getSlaveSyncModes()

getSlaveSyncMode

Sequencer.SyncMode getSlaveSyncMode()
获得此 sequencer 的当前从同步模式。

返回：
当前的从同步模式
另请参见：
setSlaveSyncMode(Sequencer.SyncMode), getSlaveSyncModes()

getSlaveSyncModes

Sequencer.SyncMode[] getSlaveSyncModes()
获得此 sequencer 支持的从同步模式集。

返回：
可用的从同步模式
另请参见：
Sequencer.SyncMode.MIDI_SYNC, Sequencer.SyncMode.MIDI_TIME_CODE, Sequencer.SyncMode.NO_SYNC

setTrackMute

void setTrackMute(int track,
                  boolean mute)
设置轨道的静音状态。此方法可能由于某些原因而失败。例如，所指定的轨道号可能对于当前 sequence 无效，或者 sequencer 可能不支持此功能。需要验证此操作是否成功的应用程序应在此调用后调用 getTrackMute(int)。

参数：
track - 轨道号。当前 sequence 中的轨道从 0 到 sequence 中的轨道数减 1 来编号。
mute - 轨道的新静音状态。true 表示轨道应静音，false 表示轨道应为非静音。
另请参见：
getSequence()

getTrackMute

boolean getTrackMute(int track)
获得轨道的当前静音状态。未静音前所有轨道的默认静音状态都是 false。在任何指定轨道未静音的情况下，此方法应返回 false。这适用于当 sequencer 不支持轨道静音并且指定的轨道索引无效的情况。

参数：
track - 轨道号。当前 sequence 中的轨道从 0 到 sequence 中的轨道数减 1 来编号。
返回：
如果已静音，则返回 true；如果未静音，则返回 false。

setTrackSolo

void setTrackSolo(int track,
                  boolean solo)
设置轨道的 solo 状态。如果 solo 为 true，则只有此轨道及其他 solo 轨道可发声。如果 solo 为 false，则只有其他 solo 轨道可发声，如果没有任何 solo 轨道，则所有非静音轨道都发声。

此方法可能由于某些原因而失败。例如，所指定的轨道号可能对于当前 sequence 无效，或者 sequencer 可能不支持此功能。需要验证此操作是否成功的应用程序应在此调用后调用 getTrackSolo(int)。

参数：
track - 轨道号。当前 sequence 中的轨道从 0 到 sequence 中的轨道数减 1 来编号。
solo - 轨道的新 solo 状态。true 表示轨道应为 solo，false 表示轨道应为非 solo。
另请参见：
getSequence()

getTrackSolo

boolean getTrackSolo(int track)
获得轨道的当前 solo 状态。未 solo 前所有轨道的默认静音状态都是 false。在任何指定轨道未 solo 的情况下，此方法应返回 false。这适用于当 sequencer 不支持轨道 solo 并且指定的轨道索引无效的情况。

参数：
track - 轨道号。当前 sequence 中的轨道从 0 到 sequence 中的轨道数减 1 来编号。
返回：
如果已为 solo，则返回 true；如果不是，则返回 false。

addMetaEventListener

boolean addMetaEventListener(MetaEventListener listener)
注册一个元事件侦听器，以便在 sequence 中遇到元事件并由此 sequencer 处理时接收通知。此方法在此 sequencer 类不支持元事件通知时会失败。

参数：
listener - 要添加的侦听器
返回：
如果成功添加了该侦听器，则返回 true；否则返回 false
另请参见：
removeMetaEventListener(javax.sound.midi.MetaEventListener), MetaEventListener, MetaMessage

removeMetaEventListener

void removeMetaEventListener(MetaEventListener listener)
从此 sequencer 的已注册侦听器列表中移除指定的元事件侦听器（如果实际上此侦听器已注册）。

参数：
listener - 要移除的元事件侦听器
另请参见：
addMetaEventListener(javax.sound.midi.MetaEventListener)

addControllerEventListener

int[] addControllerEventListener(ControllerEventListener listener,
                                 int[] controllers)
注册一个控件事件侦听器，以便在 sequencer 处理所请求的一种或多种类型的控制更改事件时接收通知。类型由 controllers 参数指定，该参数应包含一个 MIDI 控件号的数组。（每个编号应该是 0 到 127（包括）之间的一个数。请参见 MIDI 1.0 规范中与各种类型控件对应的编号。）

返回的数组包含 MIDI 控件号，侦听器将从现在开始接收其事件。有些 sequencer 可能不支持控件事件通知，这种情况下数组长度为 0。其他 sequencer 可能支持某些控件的通知，但不是全部。此方法可重复调用。每次调用时，返回的数组都指示侦听器将接收其通知的所有控件，而不仅仅是在该特定调用中请求的控件。

参数：
listener - 要添加到已注册侦听器列表中的控件事件侦听器
controllers - 为其请求更改通知的 MIDI 控件号
返回：
其更改将报告给指定侦听器的所有 MIDI 控件号
另请参见：
removeControllerEventListener(javax.sound.midi.ControllerEventListener, int[]), ControllerEventListener

removeControllerEventListener

int[] removeControllerEventListener(ControllerEventListener listener,
                                    int[] controllers)
移除侦听一类或多类控件事件的控件事件侦听器。controllers 参数使用一个 MIDI 号的数组，与侦听器将不再接收其更改通知的控件对应。要将此侦听器从已注册侦听器列表中彻底移除，可为 controllers 传递 null。返回的数组包含 MIDI 控件号，侦听器将从现在开始接收其事件。如果侦听器将不接收任何控件的更改通知，则数组长度为 0。

参数：
listener - 旧的侦听器
controllers - 应为其取消更改通知的 MIDI 控件号，或者为 null 以取消所有的控件
返回：
其更改现在将报告给指定侦听器的所有 MIDI 控件号
另请参见：
addControllerEventListener(javax.sound.midi.ControllerEventListener, int[])

setLoopStartPoint

void setLoopStartPoint(long tick)
设置在循环中播放的第一个 MIDI 节拍。如果循环数大于 0，则回放到达循环终点时将跳转到此点。

起始点的值为 0 表示已加载 sequence 的开始。起始点必须小于或等于结束点，并且必须位于已加载 sequence 的大小内。

Sequencer 的循环起始点默认为 sequence 的开始。

参数：
tick - 循环的起始位置，以 MIDI 节拍为单位（从零开始）
抛出：
IllegalArgumentException - 如果所请求的循环起始点无法设置，通常是因为位于 sequence 的持续时间之外或起始点在结束点之后
从以下版本开始：
1.5
另请参见：
setLoopEndPoint(long), setLoopCount(int), getLoopStartPoint(), start()

getLoopStartPoint

long getLoopStartPoint()
获得循环的起始位置，以 MIDI 节拍为单位。

返回：
循环的起始位置，以 MIDI 节拍为单位（从零开始）
从以下版本开始：
1.5
另请参见：
setLoopStartPoint(long)

setLoopEndPoint

void setLoopEndPoint(long tick)
设置在循环中播放的最后一个 MIDI 节拍。如果循环数为 0，则循环结束点将无效，回放在到达循环结束点时会继续播放。

结束点值为 -1 指示 sequence 的最后节拍。否则，结束点必须大于或等于起始点，并且必须位于已加载 sequence 的大小内。

Sequencer 的循环结束点默认为 -1，表示 sequence 的结束点。

参数：
tick - 循环的结束位置，以 MIDI 节拍为单位（从零开始），-1 指示结束点节拍
抛出：
IllegalArgumentException - 如果所请求的循环点无法设置，通常是因为位于 sequence 的持续时间之外或结束点在起始点之前
从以下版本开始：
1.5
另请参见：
setLoopStartPoint(long), setLoopCount(int), getLoopEndPoint(), start()

getLoopEndPoint

long getLoopEndPoint()
获得循环的结束位置，以 MIDI 节拍为单位。

返回：
循环的结束位置，以 MIDI 节拍为单位（从零开始），-1 指示 sequence 的结束点
从以下版本开始：
1.5
另请参见：
setLoopEndPoint(long)

setLoopCount

void setLoopCount(int count)
设置循环回放的重复次数。当回放位置到达循环结束点时，它将返回到循环起始点 count 次，此后回放将继续播放，直到 sequence 的结束点为止。

如果此方法调用时，当前位置大于循环结束点，则回放会继续进行至 sequence 的结束点而不循环，除非随后更改了循环结束点。

count 值为 0 可禁用循环：回放将在循环结束点继续，不会返回到循环起始点。这是 sequencer 的默认方式。

如果回放在循环时停止，则当前循环状态被清除；后续开始请求不受已中断循环操作的影响。

参数：
count - 回放应从循环结束点返回循环起始点的次数，或 LOOP_CONTINUOUSLY 指示循环应一直继续直到被中断
抛出：
IllegalArgumentException - 如果 count 为负且不等于 LOOP_CONTINUOUSLY
从以下版本开始：
1.5
另请参见：
setLoopStartPoint(long), setLoopEndPoint(long), getLoopCount(), start()

getLoopCount

int getLoopCount()
获得回放的重复次数。

返回：
回放在其播放至 sequence 结束点后的循环数
从以下版本开始：
1.5
另请参见：
setLoopCount(int), start()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Sequencer.SyncMode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 Sequencer.SyncMode

java.lang.Object
    继承者  javax.sound.midi.Sequencer.SyncMode
正在封闭接口：
Sequencer
public static class Sequencer.SyncMode
extends Object

SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。如果 sequencer 与主设备同步，sequencer 将修改其当前时间以响应主设备的消息。如果 sequencer 带有从设备，此 sequencer 通常会发送消息以控制从设备的计时。

有三种预定义模式可为 sequencer 指定一个可能的主设备：INTERNAL_CLOCK、MIDI_SYNC 和 MIDI_TIME_CODE。后两种在 sequencer 从其他设备接收 MIDI 消息时工作。在这两种模式中，sequencer 的时间基于系统实时计时时钟消息和各自的 MIDI 时间代码 (MTC) 消息进行重置。这两种模式还可用于辅模式，此时，sequencer 将相应类型的 MIDI 消息发送至其接收者（无论此 sequencer 是否还从主设备接收它们）。第四种模式 NO_SYNC 用于指示 sequencer 不应控制其接收者的计时。

另请参见：
Sequencer.setMasterSyncMode(Sequencer.SyncMode), Sequencer.setSlaveSyncMode(Sequencer.SyncMode)

字段摘要
static Sequencer.SyncMode | INTERNAL_CLOCK 主同步模式，它使 sequencer 从其内部时钟获取计时信息。
static Sequencer.SyncMode | MIDI_SYNC 指定使用 MIDI 时钟消息的主或辅同步模式。
static Sequencer.SyncMode | MIDI_TIME_CODE 指定使用 MIDI 时间代码的主或辅同步模式如果此模式用作主同步模式，sequencer 从 MIDI 时间代码消息获取其计时信息。
static Sequencer.SyncMode | NO_SYNC 辅同步模式，指示不应向接收者发送任何计时信息。
构造方法摘要
protected Sequencer.SyncMode(String name)
构造一个同步模式。
方法摘要
boolean | equals(Object obj) 确定两个对象是否等价。
int | hashCode() 终结 hashcode 方法。
String | toString() 以模式的字符串表示形式提供此同步模式的名称。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

字段详细信息

INTERNAL_CLOCK

public static final Sequencer.SyncMode INTERNAL_CLOCK
主同步模式，它使 sequencer 从其内部时钟获取计时信息。这不是一个合法的辅同步模式。

MIDI_SYNC

public static final Sequencer.SyncMode MIDI_SYNC
指定使用 MIDI 时钟消息的主或辅同步模式。如果此模式用作主同步模式，sequencer 从系统实时 MIDI 时钟消息获取其计时信息。此模式只适用于 sequencer 的主同步模式，sequencer 也是 MIDI 接收者。如果这里为辅同步模式，此 sequencer 发送系统实时 MIDI 时钟消息至其接收者。MIDI 时钟消息发送速度为每四分音符 24 个。

MIDI_TIME_CODE

public static final Sequencer.SyncMode MIDI_TIME_CODE
指定使用 MIDI 时间代码的主或辅同步模式如果此模式用作主同步模式，sequencer 从 MIDI 时间代码消息获取其计时信息。此模式只适用于 sequencer 的主同步模式，sequencer 也是 MIDI 接收者。如果此模式用作辅同步模式，sequencer 发送 MIDI 时间代码消息至其接收者。（请参见 MIDI 1.0 Detailed Specification 获取对 MIDI 时间代码的描述。）

NO_SYNC

public static final Sequencer.SyncMode NO_SYNC
辅同步模式，指示不应向接收者发送任何计时信息。这不是一个合法的主同步模式。

构造方法详细信息

Sequencer.SyncMode

protected Sequencer.SyncMode(String name)
构造一个同步模式。

参数：
name - 同步模式的名称
方法详细信息

equals

public final boolean equals(Object obj)
确定两个对象是否等价。如果两个对象相同，则返回 true

覆盖：
类 Object 中的 equals
参数：
obj - 参与比较的参考对象
返回：
如果此对象与 obj 参数相等，则返回 true，否则返回 false
另请参见：
Object.hashCode(), Hashtable

hashCode

public final int hashCode()
终结 hashcode 方法。

覆盖：
类 Object 中的 hashCode
返回：
此对象的一个哈希码值。
另请参见：
Object.equals(java.lang.Object), Hashtable

toString

public final String toString()
以模式的字符串表示形式提供此同步模式的名称。

覆盖：
类 Object 中的 toString
返回：
此同步模式的名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ShortMessage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 ShortMessage

java.lang.Object
    继承者  javax.sound.midi.MidiMessage
        继承者  javax.sound.midi.ShortMessage
所有已实现的接口：
Cloneable
public class ShortMessage
extends MidiMessage

ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。满足此标准的 MIDI 消息类型是通道声音、通道模式、系统常见和系统实时消息，换句话说，除系统独占和元事件之外的所有情况。ShortMessage 类提供了用于获取和设置 MIDI 消息内容的方法。

多个 ShortMessage 方法带有整数参数，您可通过它来指定 MIDI 状态或数据字节。如果知道此数字值，则可以直接使用数字表示。对于系统常见和系统实时消息，通常可使用相应的 ShortMessage 字段，例如 SYSTEM_RESET。对于通道消息，状态字节的高四位由一个命令值指定，低四位由一个 MIDI 通道号指定。要转换传入的 MIDI 数据字节（Java 带符号字节格式），可以使用 MidiMessage 类描述中给出的变换码。

另请参见：
SysexMessage, MetaMessage

字段摘要
static int | ACTIVE_SENSING ACTIVE_SENSING 消息的状态字节（0xFE 或 254）。
static int | CHANNEL_PRESSURE CHANNEL_PRESSURE (Aftertouch) 消息的命令值（0xD0 或 208）
static int | CONTINUE CONTINUE 消息的状态字节（0xFB 或 251）。
static int | CONTROL_CHANGE CONTROL_CHANGE 消息的命令值（0xB0 或 176）
static int | END_OF_EXCLUSIVE End of System Exclusive 消息的状态字节（0xF7 或 247）。
static int | MIDI_TIME_CODE MIDI Time Code Quarter Frame 消息的状态字节（0xF1 或 241）。
static int | NOTE_OFF NOTE_OFF 消息的命令值（0x80 或 128）
static int | NOTE_ON NOTE_ON 消息的命令值（0x90 或 144）
static int | PITCH_BEND PITCH_BEND 消息的命令值（0xE0 或 224）
static int | POLY_PRESSURE Polyphonic Key Pressure (Aftertouch) 消息的命令值（0xA0 或 128）
static int | PROGRAM_CHANGE PROGRAM_CHANGE 消息的命令值（0xC0 或 192）
static int | SONG_POSITION_POINTER SONG_POSITION_POINTER 消息的状态字节（0xF2 或 242）。
static int | SONG_SELECT MIDI SONG_SELECT 消息的状态字节（0xF3 或 243）。
static int | START START 消息的状态字节（0xFA 或 250）。
static int | STOP STOP 消息的状态字节（0xFC 或 252）。
static int | SYSTEM_RESET SYSTEM_RESET 消息的状态字节（0xFF 或 255）。
static int | TIMING_CLOCK TIMING_CLOCK 消息的状态字节（0xF8 或 248）。
static int | TUNE_REQUEST TUNE_REQUEST 消息的状态字节（0xF6 或 246）。
从类 javax.sound.midi.MidiMessage 继承的字段
data, length
构造方法摘要
 | ShortMessage() 构造一个新的 ShortMessage。
protected | ShortMessage(byte[] data) 构造一个新的 ShortMessage。
方法摘要
Object | clone() 创建一个与此对象具有相同类和相同内容的新对象。
int | getChannel() 获取与此事件关联的 MIDI 通道。
int | getCommand() 获取与此事件关联的 MIDI 命令。
int | getData1() 获取消息中的第一个数据字节。
int | getData2() 获取消息中的第二个数据字节。
protected int | getDataLength(int status) 检索与特定状态字节值关联的数据字节数。
void | setMessage(int status) 为不带任何数据字节的 MIDI 消息设置参数。
void | setMessage(int status, int data1, int data2) 为带一个或两个数据字节的 MIDI 消息设置参数。
void | setMessage(int command, int channel, int data1, int data2) 为带两个数据字节的通道消息设置短消息参数。
从类 javax.sound.midi.MidiMessage 继承的方法
getLength, getMessage, getStatus, setMessage
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

MIDI_TIME_CODE

public static final int MIDI_TIME_CODE
MIDI Time Code Quarter Frame 消息的状态字节（0xF1 或 241）。

另请参见：
MidiMessage.getStatus(), 常量字段值

SONG_POSITION_POINTER

public static final int SONG_POSITION_POINTER
SONG_POSITION_POINTER 消息的状态字节（0xF2 或 242）。

另请参见：
MidiMessage.getStatus(), 常量字段值

SONG_SELECT

public static final int SONG_SELECT
MIDI SONG_SELECT 消息的状态字节（0xF3 或 243）。

另请参见：
MidiMessage.getStatus(), 常量字段值

TUNE_REQUEST

public static final int TUNE_REQUEST
TUNE_REQUEST 消息的状态字节（0xF6 或 246）。

另请参见：
MidiMessage.getStatus(), 常量字段值

END_OF_EXCLUSIVE

public static final int END_OF_EXCLUSIVE
End of System Exclusive 消息的状态字节（0xF7 或 247）。

另请参见：
MidiMessage.getStatus(), 常量字段值

TIMING_CLOCK

public static final int TIMING_CLOCK
TIMING_CLOCK 消息的状态字节（0xF8 或 248）。

另请参见：
MidiMessage.getStatus(), 常量字段值

START

public static final int START
START 消息的状态字节（0xFA 或 250）。

另请参见：
MidiMessage.getStatus(), 常量字段值

CONTINUE

public static final int CONTINUE
CONTINUE 消息的状态字节（0xFB 或 251）。

另请参见：
MidiMessage.getStatus(), 常量字段值

STOP

public static final int STOP
STOP 消息的状态字节（0xFC 或 252）。

另请参见：
MidiMessage.getStatus(), 常量字段值

ACTIVE_SENSING

public static final int ACTIVE_SENSING
ACTIVE_SENSING 消息的状态字节（0xFE 或 254）。

另请参见：
MidiMessage.getStatus(), 常量字段值

SYSTEM_RESET

public static final int SYSTEM_RESET
SYSTEM_RESET 消息的状态字节（0xFF 或 255）。

另请参见：
MidiMessage.getStatus(), 常量字段值

NOTE_OFF

public static final int NOTE_OFF
NOTE_OFF 消息的命令值（0x80 或 128）

另请参见：
常量字段值

NOTE_ON

public static final int NOTE_ON
NOTE_ON 消息的命令值（0x90 或 144）

另请参见：
常量字段值

POLY_PRESSURE

public static final int POLY_PRESSURE
Polyphonic Key Pressure (Aftertouch) 消息的命令值（0xA0 或 128）

另请参见：
常量字段值

CONTROL_CHANGE

public static final int CONTROL_CHANGE
CONTROL_CHANGE 消息的命令值（0xB0 或 176）

另请参见：
常量字段值

PROGRAM_CHANGE

public static final int PROGRAM_CHANGE
PROGRAM_CHANGE 消息的命令值（0xC0 或 192）

另请参见：
常量字段值

CHANNEL_PRESSURE

public static final int CHANNEL_PRESSURE
CHANNEL_PRESSURE (Aftertouch) 消息的命令值（0xD0 或 208）

另请参见：
常量字段值

PITCH_BEND

public static final int PITCH_BEND
PITCH_BEND 消息的命令值（0xE0 或 224）

另请参见：
常量字段值
构造方法详细信息

ShortMessage

public ShortMessage()
构造一个新的 ShortMessage。可保证新消息的内容指定一个有效的 MIDI 消息。之后，可以使用 setMessage 方法之一来设置消息的内容。

另请参见：
setMessage(int)

ShortMessage

protected ShortMessage(byte[] data)
构造一个新的 ShortMessage。

参数：
data - 包含完整消息的 byte 数组。使用 setMessage 方法可更改消息数据。
另请参见：
setMessage(int)
方法详细信息

setMessage

public void setMessage(int status)
                throws InvalidMidiDataException
为不带任何数据字节的 MIDI 消息设置参数。

参数：
status - MIDI 状态字节
抛出：
InvalidMidiDataException - 如果 status 没有为不要求任何数据字节的消息指定有效的 MIDI 状态字节。
InvalidMidiDataException
另请参见：
setMessage(int, int, int), setMessage(int, int, int, int)

setMessage

public void setMessage(int status,
                       int data1,
                       int data2)
                throws InvalidMidiDataException
为带一个或两个数据字节的 MIDI 消息设置参数。如果消息只带一个数据字节，则忽略第二个数据字节；如果消息不带任何数据字节，则忽略两个数据字节。

参数：
status - MIDI 状态字节
data1 - 第一个数据字节
data2 - 第二个数据字节
抛出：
InvalidMidiDataException - 如果该状态字节或属于此消息的所有数据字节都未指定有效的 MIDI 消息。
InvalidMidiDataException
另请参见：
setMessage(int, int, int, int), setMessage(int)

setMessage

public void setMessage(int command,
                       int channel,
                       int data1,
                       int data2)
                throws InvalidMidiDataException
为带两个数据字节的通道消息设置短消息参数。如果消息只带一个数据字节，则忽略第二个数据字节；如果消息不带任何数据字节，则忽略两个数据字节。

参数：
command - 此消息所表示的 MIDI 命令
channel - 与此消息关联的通道
data1 - 第一个数据字节
data2 - 第二个数据字节
抛出：
InvalidMidiDataException - 如果该状态字节或属于此消息的所有数据字节都未指定有效的 MIDI 消息
InvalidMidiDataException
另请参见：
setMessage(int, int, int),
setMessage(int),
getCommand(),
getChannel(),
getData1(),
getData2()

getChannel

public int getChannel()
获取与此事件关联的 MIDI 通道。此方法假定事件是一个 MIDI 通道消息；否则返回值没有意义。

返回：
与此消息关联的 MIDI 通道。
另请参见：
setMessage(int, int, int, int)

getCommand

public int getCommand()
获取与此事件关联的 MIDI 命令。此方法假定事件是一个 MIDI 通道消息；否则返回值没有意义。

另请参见：
setMessage(int, int, int, int)

getData1

public int getData1()
获取消息中的第一个数据字节。

返回：
data1 字段的值
另请参见：
setMessage(int, int, int)

getData2

public int getData2()
获取消息中的第二个数据字节。

返回：
data2 字段的值
另请参见：
setMessage(int, int, int)

clone

public Object clone()
创建一个与此对象具有相同类和相同内容的新对象。

指定者：
类 MidiMessage 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable

getDataLength

protected final int getDataLength(int status)
                           throws InvalidMidiDataException
检索与特定状态字节值关联的数据字节数。

参数：
status - 状态字节值，必须表示一个短 MIDI 消息
返回：
数据长度，以字节为单位（0、1 或 2）
抛出：
InvalidMidiDataException - 如果 status 参数不表示任何短消息的状态字节
InvalidMidiDataException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Soundbank (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 Soundbank

public interface Soundbank

Soundbank 包含可加载到 Synthesizer 中的一组 Instruments。注意，Java Sound Soundbank 不同于 MIDI 库。MIDI 允许有 16383 个库，每个库包含 128 种乐器（有时又称程序、包或音色）。但是，一个 Soundbank 可包含 16383 乘以 128 种乐器，因为 Soundbank 中的乐器按 MIDI 程序号和 MIDI 库号索引的（通过 Patch 对象）。因此，一个 Soundbank 可当作一组 MIDI 库。

Soundbank 包括了返回 String 对象的方法（该对象中包含音库名称、制造商、版本号和描述）。这些字符串的准确内容和格式留给实现程序掌握。

不同的合成器使用各种合成技巧。常见的一种合成技巧是波表合成，回放其中一个录制的声音段，通常使用循环和音高更改。Downloadable Sound (DLS) 格式使用录制的声音段，如同 Headspace Engine 一样。基于波表合成（或其他使用所存储的录制声音）的 Soundbanks 和 Instruments 通常应实现 getResources() 方法，以提供对这些录制段的访问。但是，这是可选的；如果合成技巧未使用采样声音（FM 合成和物理建模是这类技巧的示例），或者使用了采样声音但实现程序选择了使采样不可访问，则此方法可返回一个长度为零的数组。

另请参见：
Synthesizer.getDefaultSoundbank(), Synthesizer.isSoundbankSupported(javax.sound.midi.Soundbank), Synthesizer.loadInstruments(Soundbank, Patch[]), Patch, Instrument, SoundbankResource

方法摘要
String | getDescription() 获得音库适于显示的文本描述。
Instrument | getInstrument(Patch patch) 获得取自给定 Patch 的 Instrument。
Instrument[] | getInstruments() 获得包含在此音库中的乐器列表。
String | getName() 获得音库的名称。
SoundbankResource[] | getResources() 提取音库中包含的非乐器资源列表。
String | getVendor() 获得命名提供此音库的公司的 string
String | getVersion() 获得音库的版本字符串。

方法详细信息

getName

String getName()
获得音库的名称。

返回：
命名音库的 String

getVersion

String getVersion()
获得音库的版本字符串。

返回：
指示音库版本的 String

getVendor

String getVendor()
获得命名提供此音库的公司的 string

返回：
供应商字符串

getDescription

String getDescription()
获得音库适于显示的文本描述。

返回：
描述音库的 String

getResources

SoundbankResource[] getResources()
提取音库中包含的非乐器资源列表。

返回：
一个资源数组，不包含乐器。如果音库不包含任何资源（乐器除外），则返回长度为 0 的数组。

getInstruments

Instrument[] getInstruments()
获得包含在此音库中的乐器列表。

返回：
此 SoundBank 中的 Instruments 的数组，如果音库中未包含任何乐器，则返回长度为 0 的数组。
另请参见：
Synthesizer.getLoadedInstruments(), getInstrument(Patch)

getInstrument

Instrument getInstrument(Patch patch)
获得取自给定 Patch 的 Instrument。

参数：
patch - 一个指定库索引和程序更改号的 Patch 对象
返回：
所请求的乐器，如果音库中未包含任何乐器，则返回 null
另请参见：
getInstruments(), Synthesizer.loadInstruments(Soundbank, Patch[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SoundbankResource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 SoundbankResource

java.lang.Object
    继承者  javax.sound.midi.SoundbankResource
直接已知子类：
Instrument
public abstract class SoundbankResource
extends Object

SoundbankResource 表示存储在 Soundbank 中的任何音频资源。常见的音库资源包括：

  • 乐器。可通过多种方式指定乐器。但是，所有的音库都有定义乐器的某些机制。定义过程中，它们可能引用音库中存储的其他资源。每个乐器都有一个 Patch，它指定在 MIDI 消息中可通过其引用的 MIDI 程序和库。乐器信息可存储在 Instrument 对象中。
  • 音频采样。采样通常是一个采样音频波表，包含持续几分之一秒或最多几秒的短声音录音。这些音频采样可由 Synthesizer 使用来合成声音，以便作为对 MIDI 命令的响应，或者提取出来供应用程序使用。（此术语反映了乐师使用“采样”一词统指一系列连续的音频采样或帧，而不是单一的瞬间采样）。音频采样的数据类将是一个对象，它封装了音频采样数据本身和有关如何解释该数据的信息（音频数据的格式），例如 AudioInputStream。
  • 嵌入式 sequence。音库可包含内置存储在一个数据对象（如 Sequence）中的乐曲数据。

使用波表合成或相关技巧合成的合成器在合成音符时回放采样中的音频，通常是在模仿原先录制的实际乐器时。但是，在 Instruments 和 Soundbank 中的采样之间不必有一一对应关系。单个 Instrument 可使用多个 SoundbankResource（通常用于具有不相似的音高或亮度的音符）。同样，多个 Instrument 可使用同一个采样。

构造方法摘要
protected SoundbankResource(Soundbank soundBank, String name, Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。
方法摘要
abstract Object | getData() 获得存储在此 SoundbankResource 中的采样音频。
Class<?> | getDataClass() 获得此采样所使用的表示其数据的类。
String | getName() 获得资源的名称。
Soundbank | getSoundbank() 获得包含此 SoundbankResource 的音库。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SoundbankResource

protected SoundbankResource(Soundbank soundBank,
                            String name,
                            Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。（设置 SoundbankResource 的名称、采样音频数据和乐器是子类的任务）。

参数：
soundBank - 包含此 SoundbankResource 的音库
name - 采样的名称
dataClass - 用于表示采样数据的类
另请参见：
getSoundbank(),
getName(),
getDataClass(),
getData()
方法详细信息

getSoundbank

public Soundbank getSoundbank()
获得包含此 SoundbankResource 的音库。

返回：
存储此 SoundbankResource 的音库

getName

public String getName()
获得资源的名称。这通常应该是资源的描述性字符串。

返回：
乐器的名称

getDataClass

public Class<?> getDataClass()
获得此采样所使用的表示其数据的类。由 getData 返回的对象将是此类。如果此 SoundbankResource 对象不支持对其数据的直接访问，则返回 null。

返回：
用于表示采样数据的类，如果数据不可访问，则返回 null

getData

public abstract Object getData()
获得存储在此 SoundbankResource 中的采样音频。返回的对象类型取决于具体类的实现，可使用 getDataClass 查询对象类型。

返回：
包含采样音频数据的对象
另请参见：
getDataClass()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Synthesizer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 Synthesizer

所有超级接口：
MidiDevice
public interface Synthesizer
extends MidiDevice

Synthesizer 生成声音。这通常发生在某个 Synthesizer 的 MidiChannel 对象直接或通过 Synthesizer 对象接收到 noteOn 消息时。很多 Synthesizer 都支持 Receiver，通过后者可将 MIDI 事件发送至 Synthesizer。这种情况下，Synthesizer 通常的响应是发送一个相应的消息至合适的 MidiChannel，如果事件不是 MIDI 通道消息之一，则自己处理该事件。

Synthesizer 接口包括可从音库加载和卸载乐器 (instrument) 的方法。一个乐器就是用于合成某种声音类型的规范，无论这种声音模仿的是传统乐器还是某种音效或其他想象出来的声音。音库是通过库和程序号组织的一组乐器（通过乐器的 Patch 对象）。不同的 Synthesizer 类可实现不同的声音合成技巧，这意味着某些乐器可以与给定的合成器兼容，而另一些则不行。同样，合成器可以为乐器保留有限的内存量，这意味着不是每种合成器都可使用每种音库和乐器，即使合成技术兼容时也是如此。要查看取自某种音库的乐器是否可由给定的合成器演奏，可调用 Synthesizer 的 isSoundbankSupported 方法。

“加载”乐器意味着该乐器可用于合成音符。乐器加载至由其 Patch 对象指定的库和程序位置。加载并不一定意味着后续演奏的音符将立即具有此新加载乐器的声音。要使乐器演奏音符，某个合成器的 MidiChannel 对象必须接收（或已经接收）可使该特定乐器的库和程序号被选中的程序更改消息。

另请参见：
MidiSystem.getSynthesizer(), Soundbank, Instrument, MidiChannel.programChange(int, int), Receiver, Transmitter, MidiDevice

嵌套类摘要
从接口 javax.sound.midi.MidiDevice 继承的嵌套类/接口
MidiDevice.Info
方法摘要
Instrument[] | getAvailableInstruments() 获得该合成器随附的乐器列表。
MidiChannel[] | getChannels() 获得此合成器控制的一组 MIDI 通道。
Soundbank | getDefaultSoundbank() 获得合成器的默认音库（如果合成器存在）。
long | getLatency() 获得此合成器导致的处理延迟，用微秒表示。
Instrument[] | getLoadedInstruments() 获得当前加载到此 Synthesizer 中的乐器列表。
int | getMaxPolyphony() 获得此合成器可同时发声的最大音符数。
VoiceStatus[] | getVoiceStatus() 获得由此合成器生成的声音的当前状态。
boolean | isSoundbankSupported(Soundbank soundbank) 通知调用者此合成器是否能够从指定的音库加载乐器。
boolean | loadAllInstruments(Soundbank soundbank) 将指定 Soundbank 中包含的所有乐器加载到 Synthesizer 中。
boolean | loadInstrument(Instrument instrument) 让特定的乐器可用于合成。
boolean | loadInstruments(Soundbank soundbank, Patch[] patchList) 从指定 Soundbank 加载指定修补程序所引用的乐器。
boolean | remapInstrument(Instrument from, Instrument to) 重新映射一个乐器。
void | unloadAllInstruments(Soundbank soundbank) 卸载指定 Soundbank 中包含的所有乐器。
void | unloadInstrument(Instrument instrument) 卸载特定的乐器。
void | unloadInstruments(Soundbank soundbank, Patch[] patchList) 从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。
从接口 javax.sound.midi.MidiDevice 继承的方法
close, getDeviceInfo, getMaxReceivers, getMaxTransmitters, getMicrosecondPosition, getReceiver, getReceivers, getTransmitter, getTransmitters, isOpen, open

方法详细信息

getMaxPolyphony

int getMaxPolyphony()
获得此合成器可同时发声的最大音符数。

返回：
同时发声的最大音符数
另请参见：
getVoiceStatus()

getLatency

long getLatency()
获得此合成器导致的处理延迟，用微秒表示。此延迟可衡量从 MIDI 消息发送至合成器的时刻到该合成器实际生成相应结果的时刻之间最坏的延迟情况。

尽管延迟用微秒表示，但合成器实际延迟测量值的变化范围可能远大于此精度所建议的时间（微秒）。例如，合成器最坏的情况下可能延迟几个毫秒或更多。

返回：
最坏的延迟情况，以微秒为单位

getChannels

MidiChannel[] getChannels()
获得此合成器控制的一组 MIDI 通道。返回数组中的每个非 null 元素都是一个 MidiChannel，可接收该通道号上发送的 MIDI 消息。

MIDI 1.0 规范提供 16 个通道，所以此方法返回一个至少有 16 个元素的数组。但是，如果此合成器不使用所有的 16 个通道，则数组中的某些元素可能为 null，所以应在使用前检查每个元素。

返回：
一个由此 Synthesizer 管理的 MidiChannel 对象数组。有些数组元素可能为 null。

getVoiceStatus

VoiceStatus[] getVoiceStatus()
获得由此合成器生成的声音的当前状态。如果此 Synthesizer 类未提供声音信息，则返回的数组长度将始终为 0。否则其长度始终等于声音总数，与 getMaxPolyphony() 的返回结果一样。（有关合成器声音的说明，请参阅 VoiceStatus 类描述。）

返回：
一个 VoiceStatus 对象数组，该对象提供关于相应合成器声音的信息
另请参见：
getMaxPolyphony(), VoiceStatus

isSoundbankSupported

boolean isSoundbankSupported(Soundbank soundbank)
通知调用者此合成器是否能够从指定的音库加载乐器。如果不支持该音库，则任何试图从中加载乐器的尝试将抛出 IllegalArgumentException。

参数：
soundbank - 查询其是否受支持的音库
返回：
如果支持该音库，则返回 true，否则返回 false
另请参见：
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
loadAllInstruments(javax.sound.midi.Soundbank),
unloadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
unloadAllInstruments(javax.sound.midi.Soundbank),
getDefaultSoundbank()

loadInstrument

boolean loadInstrument(Instrument instrument)
让特定的乐器可用于合成。此乐器加载至由其 Patch 对象指定的修补程序位置，所以如果接收到（或已经收到）导致该修补程序被选中的程序更改消息，则使用 instrument 的声音演奏随后的音符。如果已加载指定的乐器，则此方法不执行任何操作并返回 true。

该乐器必须是此 Synthesizer 支持的音库的一部分。（可以使用 Instrument 的 getSoundbank 方法和 Synthesizer 的 isSoundbankSupported 方法验证。）

参数：
instrument - 要加载的乐器
返回：
如果乐器成功加载（或已经加载），则返回 true，如果乐器无法加载（例如，合成器内存不足无法加载），则返回 false
抛出：
IllegalArgumentException - 如果此 Synthesizer 不支持指定乐器的音库
另请参见：
unloadInstrument(javax.sound.midi.Instrument),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
loadAllInstruments(javax.sound.midi.Soundbank),
remapInstrument(javax.sound.midi.Instrument, javax.sound.midi.Instrument),
SoundbankResource.getSoundbank(),
MidiChannel.programChange(int, int)

unloadInstrument

void unloadInstrument(Instrument instrument)
卸载特定的乐器。

参数：
instrument - 要卸载的乐器
抛出：
IllegalArgumentException - 如果此 Synthesizer 不支持指定乐器的音库
另请参见：
loadInstrument(javax.sound.midi.Instrument),
unloadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
unloadAllInstruments(javax.sound.midi.Soundbank),
getLoadedInstruments(),
remapInstrument(javax.sound.midi.Instrument, javax.sound.midi.Instrument)

remapInstrument

boolean remapInstrument(Instrument from,
                        Instrument to)
重新映射一个乐器。 乐器 to 将替换乐器 from。
例如，如果 from 位于库号 2，即程序号 11 的位置，则重新映射导致该库和程序位置被 to 所占用。
如果该函数获得成功，则乐器 from 被卸载。

通过调用 loadInstrument(javax.sound.midi.Instrument)、loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]) 或 loadAllInstruments(javax.sound.midi.Soundbank) 之一，可以取消对重载乐器 from 的重新映射。

参数：
from - 要替换的 Instrument 对象
to - 用来替换旧乐器的 Instrument 对象，应该将它加载到合成器中
返回：
如果成功地重新映射乐器，则返回 true，如果合成器没有实现此功能，则返回 false
抛出：
IllegalArgumentException - 如果乐器 from 或乐器 to 不受合成器的支持，或者没有加载乐器 to
NullPointerException - 如果 from 或 to 参数使用 null 值
另请参见：
loadInstrument(javax.sound.midi.Instrument),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[]),
loadAllInstruments(javax.sound.midi.Soundbank)

getDefaultSoundbank

Soundbank getDefaultSoundbank()
获得合成器的默认音库（如果合成器存在）。（有些合成器提供默认或内置的音库。）如果合成器没有默认音库，则必须从外部音库显式加载乐器。

返回：
默认音库，如果不存在，则返回 null。
另请参见：
isSoundbankSupported(javax.sound.midi.Soundbank)

getAvailableInstruments

Instrument[] getAvailableInstruments()
获得该合成器随附的乐器列表。这些乐器可能内置在合成器中，也可能是合成器提供的默认音库的一部分等等。

注意，不能使用此方法查找当前加载到合成器中的乐器；如果要查找，可使用 getLoadedInstruments()。此方法也不指示可加载到合成器中的所有乐器；它仅指示合成器随附的乐器子集。要了解是否可加载另一个乐器，可以调用 isSoundbankSupported()，如果支持该乐器的 Soundbank，则可尝试加载该乐器。

返回：
可用乐器列表。
另请参见：
getLoadedInstruments(), isSoundbankSupported(Soundbank), loadInstrument(javax.sound.midi.Instrument)

getLoadedInstruments

Instrument[] getLoadedInstruments()
获得当前加载到此 Synthesizer 中的乐器列表。

返回：
当前已加载乐器的列表
另请参见：
loadInstrument(javax.sound.midi.Instrument),
getAvailableInstruments(),
Soundbank.getInstruments()

loadAllInstruments

boolean loadAllInstruments(Soundbank soundbank)
将指定 Soundbank 中包含的所有乐器加载到 Synthesizer 中。

参数：
soundbank - 将被加载乐器的 Soundbank
返回：
如果所有乐器均成功加载（或已经加载），则返回 true；如果有乐器无法加载（例如，Synthesizer 没有足够的内存），则返回 false
抛出：
IllegalArgumentException - 如果所请求的音库与此合成器不兼容。
另请参见：
isSoundbankSupported(javax.sound.midi.Soundbank),
loadInstrument(javax.sound.midi.Instrument),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[])

unloadAllInstruments

void unloadAllInstruments(Soundbank soundbank)
卸载指定 Soundbank 中包含的所有乐器。

参数：
soundbank - 包含要卸载的乐器的音库
抛出：
IllegalArgumentException - 如果不支持该音库。
另请参见：
isSoundbankSupported(javax.sound.midi.Soundbank),
unloadInstrument(javax.sound.midi.Instrument),
unloadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[])

loadInstruments

boolean loadInstruments(Soundbank soundbank,
                        Patch[] patchList)
从指定 Soundbank 加载指定修补程序所引用的乐器。每个 Patch 对象都指示一个库和程序号；具有匹配的 Patch 的 Instrument 将被加载至该库和程序位置。

参数：
soundbank - 包含要加载的乐器的 Soundbank
patchList - 应为其加载乐器的修补程序列表
返回：
如果所有乐器均成功加载（或已经加载），则返回 true，如果有乐器无法加载（例如，Synthesizer 没有足够的内存），则返回 false
抛出：
IllegalArgumentException - 如果不支持该音库。
另请参见：
isSoundbankSupported(javax.sound.midi.Soundbank),
Instrument.getPatch(),
loadAllInstruments(javax.sound.midi.Soundbank),
loadInstrument(javax.sound.midi.Instrument),
Soundbank.getInstrument(Patch),
Sequence.getPatchList()

unloadInstruments

void unloadInstruments(Soundbank soundbank,
                       Patch[] patchList)
从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。

参数：
soundbank - 包含要卸载的乐器的音库
patchList - 应为其卸载乐器的修补程序列表
抛出：
IllegalArgumentException - 如果不支持该音库。
另请参见：
unloadInstrument(javax.sound.midi.Instrument),
unloadAllInstruments(javax.sound.midi.Soundbank),
isSoundbankSupported(javax.sound.midi.Soundbank),
Instrument.getPatch(),
loadInstruments(javax.sound.midi.Soundbank, javax.sound.midi.Patch[])
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SysexMessage (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 SysexMessage

java.lang.Object
    继承者  javax.sound.midi.MidiMessage
        继承者  javax.sound.midi.SysexMessage
所有已实现的接口：
Cloneable
public class SysexMessage
extends MidiMessage

表示 MIDI 系统独占消息 SysexMessage 对象。

当从 MIDI 文件中读取系统独占消息时，它通常具有已定义的长度。取自 MIDI 文件的系统独占消息的数据应存储在 SysexMessage 的数据数组中，如下所示：系统独占消息状态字节（0xF0 或 0xF7），所有消息数据字节和最后的独占结束标志 (0xF7)。因此，SysexMessage 对象报告的长度为系统独占数据的长度加上两个字节：一个字节为状态字节，另一个为独占结束标志。

按照 Standard MIDI Files 规范的规定，有两个状态字节值对于从 MIDI 文件读取的 SysexMessage 是合法的：

  • 0xF0:系统独占消息（与 MIDI 导线协议相同）
  • 0xF7:特殊系统独占消息

当使用 Java Sound 处理通过 MIDI 导线协议接收的系统独占数据时，它应将数据置于一个或多个 SysexMessage 中。在这种情况下，预先不知道系统独占数据的长度；系统独占数据的结束由 MIDI 导线字节流中的一个独占结束标志 (0xF7) 所标记。

  • 0xF0:系统独占消息（与 MIDI 导线协议相同）
  • 0xF7:独占结束 (EOX)
第一个包含用于特定系统独占消息数据的 SysexMessage 对象应有状态值 0xF0。如果此消息包含该消息的所有系统独占数据，则它应以状态字节 0xF7 (EOX) 结束。否则，应在一个或多个 SysexMessage 中发送其他的系统独占数据，状态值为 0xF7。包含系统独占消息最后数据的 SysexMessage 应以 0xF7 (EOX) 值结束，以标记系统独占消息的结束。

如果使用 MIDI 导线协议传输取自 SysexMessage 对象的系统独占数据，则只有初始 0xF0 状态字节、系统独占数据本身和最终的 0xF7 (EOX) 字节应该被传播；任何用于指示 SysexMessage 包含连续系统独占数据的 0xF7 状态字节都不应该通过 MIDI 导线协议被传播。

字段摘要
static int | SPECIAL_SYSTEM_EXCLUSIVE 用于 SPECIAL_SYSTEM_EXCLUSIVE 消息的状态字节（0xF7 或 247），供在 MIDI 文件中使用。
static int | SYSTEM_EXCLUSIVE 用于 SYSTEM_EXCLUSIVE 消息的状态字节（0xF0 或 240）。
从类 javax.sound.midi.MidiMessage 继承的字段
data, length
构造方法摘要
 | SysexMessage() 构造一个新的 SysexMessage。
protected | SysexMessage(byte[] data) 构造一个新的 SysexMessage。
方法摘要
Object | clone() 创建一个与此对象具有相同类和相同内容的新对象。
byte[] | getData() 获得系统独占消息数据的副本。
void | setMessage(byte[] data, int length) 为系统独占消息设置数据。
void | setMessage(int status, byte[] data, int length) 为系统独占消息设置数据。
从类 javax.sound.midi.MidiMessage 继承的方法
getLength, getMessage, getStatus
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

SYSTEM_EXCLUSIVE

public static final int SYSTEM_EXCLUSIVE
用于 SYSTEM_EXCLUSIVE 消息的状态字节（0xF0 或 240）。

另请参见：
MidiMessage.getStatus(), 常量字段值

SPECIAL_SYSTEM_EXCLUSIVE

public static final int SPECIAL_SYSTEM_EXCLUSIVE
用于 SPECIAL_SYSTEM_EXCLUSIVE 消息的状态字节（0xF7 或 247），供在 MIDI 文件中使用。它与 END_OF_EXCLUSIVE 具有相同的值，用于实时 "MIDI wire" 协议中。

另请参见：
MidiMessage.getStatus(), 常量字段值
构造方法详细信息

SysexMessage

public SysexMessage()
构造一个新的 SysexMessage。可保证新消息的内容指定一个有效的 MIDI 消息。之后，可以使用 setMessage 方法之一来设置消息的内容。

另请参见：
setMessage(byte[], int)

SysexMessage

protected SysexMessage(byte[] data)
构造一个新的 SysexMessage。

参数：
data - 包含完整消息的 byte 数组。使用 setMessage 方法可更改消息数据。
另请参见：
setMessage(byte[], int)
方法详细信息

setMessage

public void setMessage(byte[] data,
                       int length)
                throws InvalidMidiDataException
为系统独占消息设置数据。数据数组的第一个字节必须是一个有效的系统独占状态字节（0xF0 或 0xF7）。

覆盖：
类 MidiMessage 中的 setMessage
参数：
data - 系统独占消息数据
length - 数组中有效消息数据的长度，包含状态字节。
抛出：
InvalidMidiDataException

setMessage

public void setMessage(int status,
                       byte[] data,
                       int length)
                throws InvalidMidiDataException
为系统独占消息设置数据。

参数：
status - 消息的状态字节（0xF0 或 0xF7）
data - 系统独占消息数据
length - 数组中有效消息数据的长度
抛出：
InvalidMidiDataException

getData

public byte[] getData()
获得系统独占消息数据的副本。返回的 byte 数组不包括状态字节。

返回：
包含系统独占消息数据的数组。

clone

public Object clone()
创建一个与此对象具有相同类和相同内容的新对象。

指定者：
类 MidiMessage 中的 clone
返回：
此实例的一个副本。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Track (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 Track

java.lang.Object
    继承者  javax.sound.midi.Track

public class Track
extends Object

MIDI 音轨是一个可随其他音轨存储在标准 MIDI 文件中的独立的 MIDI 事件流（带时间戳的 MIDI 数据）。MIDI 规范只允许 16 通道的 MIDI 数据，音轨是一个绕过此限制的方法。一个 MIDI 文件可包含任何数量的音轨，每个音轨包含其自身的多达 16 个通道的 MIDI 数据流。

Track 占用 Sequencer 演奏的数据层次中的一个中间层。sequencer 演奏 sequence，它包含音轨，而音轨包含 MIDI 事件。Sequencer 可能提供 mute 或 solo 具体音轨的控制。

音轨的计时信息和精度由包含该音轨的 sequence 控制并存储在其中。给定的 Track 被当作属于维持其计时的特定的 Sequence。因此，新（空）音轨通过调用 Sequence.createTrack() 方法创建，而不是直接调用 Track 构造方法。

Track 类通过从其添加或移除 MidiEvent 对象提供了用于编辑音轨的方法。这些操作使事件列表保持正确的时间顺序。还包括用于获得有关其包含的事件数或刻度持续时间的音轨大小的方法。

另请参见：
Sequencer.setTrackMute(int, boolean), Sequencer.setTrackSolo(int, boolean)

方法摘要
boolean | add(MidiEvent event) 将新事件添加至音轨。
MidiEvent | get(int index) 获得位于指定索引处的事件。
boolean | remove(MidiEvent event) 从音轨中移除指定的事件。
int | size() 获得此音轨中的事件数。
long | ticks() 获得音轨的长度，用 MIDI 刻度表示。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

add

public boolean add(MidiEvent event)
将新事件添加至音轨。如果事件已包含在音轨中，则不再添加。事件列表按时间顺序排列，这意味着此事件将插入到列表中的适当位置，而不一定是最后。

参数：
event - 要添加的事件
返回：
如果该事件在音轨中原先不存在并进行了添加，则返回 true，否则返回 false

remove

public boolean remove(MidiEvent event)
从音轨中移除指定的事件。

参数：
event - 要移除的事件
返回：
如果事件原先在音轨中存在但后来被移除，则返回 true，否则返回 false

get

public MidiEvent get(int index)
              throws ArrayIndexOutOfBoundsException
获得位于指定索引处的事件。

参数：
index - 事件向量中所需事件的位置
抛出：
ArrayIndexOutOfBoundsException - 如果指定的索引为负或小于此音轨的当前大小。
ArrayIndexOutOfBoundsException
另请参见：
size()

size

public int size()
获得此音轨中的事件数。

返回：
音轨的事件向量的大小

ticks

public long ticks()
获得音轨的长度，用 MIDI 刻度表示。（刻度持续的秒数由包含此音轨的 Sequence 的计时精度确定，同时也取决于由 sequencer 设置的音乐的节拍。）

返回：
持续时间，以刻度为单位
另请参见：
Sequence.Sequence(float, int),
Sequencer.setTempoInBPM(float),
Sequencer.getTickPosition()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Transmitter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
接口 Transmitter

public interface Transmitter

一个 Transmitter，其将 MidiEvent 对象发送至一个或多个 Receivers。常见的 MIDI 传输器包括 sequencer 和 MIDI 输入端口。

另请参见：
Receiver

方法摘要
void | close() 指示应用程序已结束使用传输器，以及其请求的受限制资源可能已被释放或已可用。
Receiver | getReceiver() 获得此传输器将向其传送 MIDI 消息的当前接收器。
void | setReceiver(Receiver receiver) 设置此传输器将向其传送 MIDI 消息的接收器。

方法详细信息

setReceiver

void setReceiver(Receiver receiver)
设置此传输器将向其传送 MIDI 消息的接收器。如果当前已设置一个接收器，则用此接收器代替那个接收器。

参数：
receiver - 所需的接收器。

getReceiver

Receiver getReceiver()
获得此传输器将向其传送 MIDI 消息的当前接收器。

返回：
当前接收器。如果当前未设置任何接收器，则返回 null

close

void close()
指示应用程序已结束使用传输器，以及其请求的受限制资源可能已被释放或已可用。

如果创建此 Transmitter 导致隐式打开基础设备，则该方法隐式关闭该设备。只有当设备由其他隐式打开该设备的 Receiver 或 Transmitter 实例保持打开，以及该设备已显式打开时才会出现这种情况。如果从其检索该 Transmitter 的设备通过调用 MidiDevice.close 显式关闭，则 Transmitter 也被关闭。有关打开/关闭行为的详细描述，请参见 MidiDevice 的类描述。

另请参见：
MidiSystem.getTransmitter()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


VoiceStatus (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi
类 VoiceStatus

java.lang.Object
    继承者  javax.sound.midi.VoiceStatus

public class VoiceStatus
extends Object

VoiceStatus 对象包含有关由 Synthesizer 生成的某个声音当前状态的信息。

MIDI 合成器通常能够生成最多的同步发声音符数，也称为声音。声音是连续的单音符流，将到来的 MIDI 音符分配给特定声音的过程即所谓的声音分配。但是，声音分配算法和每个声音的内容通常只存在于 MIDI 合成器内部，对外隐藏。当然，我们可以从 MIDI 消息了解合成器正在演奏的音符，并可能推断出一些声音中的音符分配信息。但是 MIDI 本身并未提供一种报告合成器将哪个音符分配给哪种声音的方式，甚至都未报告合成器能够合成的声音数。

但在 Java Sound 中，Synthesizer 类可通过其 getVoiceStatus() 方法公开其声音的内容。建议使用此行为，但这是可选的；不公开其声音分配的合成器仅返回一个长度为零的数组。确实报告其声音状态的 Synthesizer 应对其所有声音一直维护此信息，无论该声音当前是否发出。换句话说，给定类型的 Synthesizer 始终具有固定数量的声音，等于它能够发声的最大同步音符数。

如果该声音当前不处理 MIDI 音符，则视其为非活动的。在未给定任何 note-on 命令时，或在接收到的每个 note-on 命令已通过相应的 note-off（或通过一个“关闭所有音符”消息）中止时，该声音为非活动的。例如，发生这种情形的条件是：让一个能够演奏 16 个同步发声音符的合成器演奏一个四音符和弦；这种情况下，只有四种声音为活动的（假定没有演奏以前的音符）。通常，一个状态报告为活动的声音生成可听到的声音，但是并非总是如此；这还取决于乐器的细节（即合成算法）和音符已持续的时间。例如，一个声音可合成单击掌声。由于此声消失速度太快，所以它可能在收到 note-off 消息前变得无法听到。此时，该声音仍视为活动的，即使当前不生成任何声音。

除了活动或非活动状态，VoiceStatus 类还提供了显示声音当前 MIDI 通道、库和程序号、MIDI 音符号和 MIDI 音量的字段。所有这些内容都可在声音过程中更改。声音为非活动时，这些字段中每个字段都有一个未指定的值，所以应首先检查活动的字段。

另请参见：
Synthesizer.getMaxPolyphony(), Synthesizer.getVoiceStatus()

字段摘要
boolean | active 指示声音当前是否正在处理 MIDI 音符。
int | bank 此声音当前正在使用的乐器的库号。
int | channel 在其上演奏此声音的 MIDI 通道。
int | note 此声音正在演奏的 MIDI 音符。
int | program 此声音当前正在使用的乐器的程序号。
int | volume 声音的当前 MIDI 音量级。
构造方法摘要
VoiceStatus()
方法摘要
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

active

public boolean active
指示声音当前是否正在处理 MIDI 音符。请参见活动和非活动声音的解释。

channel

public int channel
在其上演奏此声音的 MIDI 通道。如果声音为活动的，则值为从零开始的通道号，如果声音为非活动的，则未指定该值。

另请参见：
MidiChannel, active

bank

public int bank
此声音当前正在使用的乐器的库号。这是一个由 MIDI 库选择消息指定的号；它并不指一个 SoundBank 对象。如果声音为活动的，则值的范围为 0 到 16383，如果声音为非活动的，则未指定该值。

另请参见：
Patch, Soundbank, active, MidiChannel.programChange(int, int)

program

public int program
此声音当前正在使用的乐器的程序号。如果声音为活动的，则值的范围为 0 到 127，如果声音为非活动的，则未指定该值。

另请参见：
MidiChannel.getProgram(), Patch, active

note

public int note
此声音正在演奏的 MIDI 音符。活动声音的范围从 0 到 127，以半音为单位，60 指中央 C(Middle C)。如果声音为非活动的，则未指定该值。

另请参见：
MidiChannel.noteOn(int, int), active

volume

public int volume
声音的当前 MIDI 音量级。如果声音为活动的，则值的范围为 0 到 127，如果声音为非活动的，则未指定该值。

注意，此值不一定反映此声音所发声的瞬间级；该级是诸多因素产生的结果，包括当前乐器及其生成的振幅包络线的形状。

另请参见：
active
构造方法详细信息

VoiceStatus

public VoiceStatus()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sound.midi (Java 2 Platform SE 6)

 javax.sound.midi
接口
ControllerEventListener
MetaEventListener
MidiChannel
MidiDevice
Receiver
Sequencer
Soundbank
Synthesizer
Transmitter
类
Instrument
MetaMessage
MidiDevice.Info
MidiEvent
MidiFileFormat
MidiMessage
MidiSystem
Patch
Sequence
Sequencer.SyncMode
ShortMessage
SoundbankResource
SysexMessage
Track
VoiceStatus
异常
InvalidMidiDataException
MidiUnavailableException


javax.sound.midi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sound.midi

提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

请参见：
描述

接口摘要
ControllerEventListener | ControllerEventListener 接口应由一个其实例需要在 Sequencer 处理了请求的 MIDI 控制更改事件类型时接收通知的类实现。
MetaEventListener | MetaEventListener 接口应由其实例需要在 Sequencer 处理了 MetaMessage 时接收通知的类实现。
MidiChannel | 表示一个单独 MIDI 通道的 MidiChannel 对象。
MidiDevice | MidiDevice 是用于所有 MIDI 设备的基接口。
Receiver | 一个 Receiver，用于接收 MidiEvent 对象，并且通常执行一些响应性的操作，例如，解释该对象以生成声音或原始 MIDI 输出。
Sequencer | 回放 MIDI sequence 的硬件或软件设备就是所谓的 sequencer。
Soundbank | Soundbank 包含可加载到 Synthesizer 中的一组 Instruments。
Synthesizer | Synthesizer 生成声音。
Transmitter | 一个 Transmitter，其将 MidiEvent 对象发送至一个或多个 Receivers。

类摘要
Instrument | 乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。
MetaMessage | MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
MidiDevice.Info | 一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。
MidiEvent | MIDI 事件包含一个 MIDI 消息和一个相应的用刻度表示的时间戳，可代表存储在 MIDI 文件或 Sequence 对象中的 MIDI 事件信息。
MidiFileFormat | MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。
MidiMessage | MidiMessage 是 MIDI 消息的基类。
MidiSystem | MidiSystem 类提供了对已安装的 MIDI 系统资源的访问，包括诸如 synthesizer、sequencer 和 MIDI 输入和输出端口等设备。
Patch | 一个 Patch 对象，用于表示 MIDI 合成器上的某个位置，其中存储（加载）了单个乐器。
Sequence | Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。
Sequencer.SyncMode | SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。
ShortMessage | ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
SoundbankResource | SoundbankResource 表示存储在 Soundbank 中的任何音频资源。
SysexMessage | 表示 MIDI 系统独占消息 SysexMessage 对象。
Track | MIDI 音轨是一个可随其他音轨存储在标准 MIDI 文件中的独立的 MIDI 事件流（带时间戳的 MIDI 数据）。
VoiceStatus | VoiceStatus 对象包含有关由 Synthesizer 生成的某个声音当前状态的信息。

异常摘要
InvalidMidiDataException | 一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
MidiUnavailableException | 当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。

软件包 javax.sound.midi 的描述

提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

相关文档

有关概述、教程、示例和指南，请参阅：
  • Sound

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.sound.midi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.midi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.sound.midi.MidiDevice.Info
    • javax.sound.midi.MidiEvent
    • javax.sound.midi.MidiFileFormat
    • javax.sound.midi.MidiMessage (implements java.lang.Cloneable)
      • javax.sound.midi.MetaMessage
      • javax.sound.midi.ShortMessage
      • javax.sound.midi.SysexMessage
    • javax.sound.midi.MidiSystem
    • javax.sound.midi.Patch
    • javax.sound.midi.Sequence
    • javax.sound.midi.Sequencer.SyncMode
    • javax.sound.midi.SoundbankResource
      • javax.sound.midi.Instrument
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.sound.midi.InvalidMidiDataException
        • javax.sound.midi.MidiUnavailableException
    • javax.sound.midi.Track
    • javax.sound.midi.VoiceStatus

接口分层结构

  • java.util.EventListener
    • javax.sound.midi.ControllerEventListener
    • javax.sound.midi.MetaEventListener
  • javax.sound.midi.MidiChannel
  • javax.sound.midi.MidiDevice
    • javax.sound.midi.Sequencer
    • javax.sound.midi.Synthesizer
  • javax.sound.midi.Receiver
  • javax.sound.midi.Soundbank
  • javax.sound.midi.Transmitter
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sound.midi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.midi
的使用

使用 javax.sound.midi 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 使用的 javax.sound.midi 中的类
ControllerEventListener
ControllerEventListener 接口应由一个其实例需要在 Sequencer 处理了请求的 MIDI 控制更改事件类型时接收通知的类实现。
Instrument
乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。
InvalidMidiDataException
一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
MetaEventListener
MetaEventListener 接口应由其实例需要在 Sequencer 处理了 MetaMessage 时接收通知的类实现。
MetaMessage
MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
MidiChannel
表示一个单独 MIDI 通道的 MidiChannel 对象。
MidiDevice
MidiDevice 是用于所有 MIDI 设备的基接口。
MidiDevice.Info
一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。
MidiEvent
MIDI 事件包含一个 MIDI 消息和一个相应的用刻度表示的时间戳，可代表存储在 MIDI 文件或 Sequence 对象中的 MIDI 事件信息。
MidiFileFormat
MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。
MidiMessage
MidiMessage 是 MIDI 消息的基类。
MidiUnavailableException
当请求的 MIDI 组件由于不可用而无法打开或创建时，抛出 MidiUnavailableException 异常。
Patch
一个 Patch 对象，用于表示 MIDI 合成器上的某个位置，其中存储（加载）了单个乐器。
Receiver
一个 Receiver，用于接收 MidiEvent 对象，并且通常执行一些响应性的操作，例如，解释该对象以生成声音或原始 MIDI 输出。
Sequence
Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。
Sequencer
回放 MIDI sequence 的硬件或软件设备就是所谓的 sequencer。
Sequencer.SyncMode
SyncMode 对象表示 MIDI sequencer 的时间标记可与主或从设备同步的方式之一。
ShortMessage
ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
Soundbank
Soundbank 包含可加载到 Synthesizer 中的一组 Instruments。
SoundbankResource
SoundbankResource 表示存储在 Soundbank 中的任何音频资源。
Synthesizer
Synthesizer 生成声音。
Track
MIDI 音轨是一个可随其他音轨存储在标准 MIDI 文件中的独立的 MIDI 事件流（带时间戳的 MIDI 数据）。
Transmitter
一个 Transmitter，其将 MidiEvent 对象发送至一个或多个 Receivers。
VoiceStatus
VoiceStatus 对象包含有关由 Synthesizer 生成的某个声音当前状态的信息。

javax.sound.midi.spi 使用的 javax.sound.midi 中的类
InvalidMidiDataException
一个 InvalidMidiDataException，指示遇到了不恰当的 MIDI 数据。
MidiDevice
MidiDevice 是用于所有 MIDI 设备的基接口。
MidiDevice.Info
一个 MidiDevice.Info 对象，它包含了有关 MidiDevice 的各种数据，包括其名称、创建它的公司及描述性文本。
MidiFileFormat
MidiFileFormat 对象，它封装了 MIDI 文件的类型、长度和定时信息。
Sequence
Sequence 是一种数据结构，包含可由 Sequencer 对象回放的音乐信息（通常是整首歌曲或音乐作品）。
Soundbank
Soundbank 包含可加载到 Synthesizer 中的一组 Instruments。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


MidiDeviceProvider (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi.spi
类 MidiDeviceProvider

java.lang.Object
    继承者  javax.sound.midi.spi.MidiDeviceProvider

public abstract class MidiDeviceProvider
extends Object

MidiDeviceProvider 是特定类型的 MIDI 设备的工厂或提供者。此机制允许实现确定在创建和管理设备时管理资源的方式。

构造方法摘要
MidiDeviceProvider()
方法摘要
abstract MidiDevice | getDevice(MidiDevice.Info info) 获得由信息对象表示的设备的实例。
abstract MidiDevice.Info[] | getDeviceInfo() 获得表示设备或由此 MidiDeviceProvider 提供的设备的信息对象集合。
boolean | isDeviceSupported(MidiDevice.Info info) 指示该设备提供者是否支持由指定的设备信息对象表示的设备。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MidiDeviceProvider

public MidiDeviceProvider()
方法详细信息

isDeviceSupported

public boolean isDeviceSupported(MidiDevice.Info info)
指示该设备提供者是否支持由指定的设备信息对象表示的设备。

参数：
info - 描述查找其支持的设备的信息对象
返回：
如果指定设备受支持，则返回 true；否则返回 false

getDeviceInfo

public abstract MidiDevice.Info[] getDeviceInfo()
获得表示设备或由此 MidiDeviceProvider 提供的设备的信息对象集合。

返回：
设备信息对象集合

getDevice

public abstract MidiDevice getDevice(MidiDevice.Info info)
获得由信息对象表示的设备的实例。

参数：
info - 描述所需设备的信息对象
返回：
设备实例
抛出：
IllegalArgumentException - 如果指定的信息对象与此 MidiDeviceProvider 所支持设备的信息对象不匹配。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


MidiFileReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi.spi
类 MidiFileReader

java.lang.Object
    继承者  javax.sound.midi.spi.MidiFileReader

public abstract class MidiFileReader
extends Object

MidiFileReader 提供 MIDI 文件读取服务。实现此接口的类可从一种或多种类型的 MIDI 文件解析格式信息，并可从这些类型的文件生成 Sequence 对象。

从以下版本开始：
1.3

构造方法摘要
MidiFileReader()
方法摘要
abstract MidiFileFormat | getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract MidiFileFormat | getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract MidiFileFormat | getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。
abstract Sequence | getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Sequence | getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Sequence | getSequence(URL url) 从提供的 URL 获得 MIDI 序列。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MidiFileReader

public MidiFileReader()
方法详细信息

getMidiFileFormat

public abstract MidiFileFormat getMidiFileFormat(InputStream stream)
                                          throws InvalidMidiDataException,
                                                 IOException
获得所提供的输入流的 MIDI 文件格式。流必须指向有效的 MIDI 文件数据。通常，MIDI 文件 reader 可能需要在确定它们是否支持流之前从中读取一些数据。这些解析器必须能够标记流，读取足够多的数据来确定它们是否支持流，并且如果不支持，则将流的阅读指针重新设置到其初始位置。如果输入流不支持此操作，则此方法可能会失败，并抛出 IOException。

参数：
stream - 应该从中提取文件格式信息的输入流
返回：
描述 MIDI 文件格式的 MidiFileFormat 对象
抛出：
InvalidMidiDataException - 如果流没有指向系统识别的有效 MIDI 文件数据
IOException - 如果发生 I/O 异常
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getMidiFileFormat

public abstract MidiFileFormat getMidiFileFormat(URL url)
                                          throws InvalidMidiDataException,
                                                 IOException
获得提供的 URL 的 MIDI 文件格式。URL 必须指向有效的 MIDI 文件数据。

参数：
url - 应该从中提取文件格式信息的 URL
返回：
描述 MIDI 文件格式的 MidiFileFormat 对象
抛出：
InvalidMidiDataException - 如果 URL 没有指向系统识别的有效 MIDI 文件数据
IOException - 如果发生 I/O 异常

getMidiFileFormat

public abstract MidiFileFormat getMidiFileFormat(File file)
                                          throws InvalidMidiDataException,
                                                 IOException
获得提供的 File 的 MIDI 文件格式。File 必须指向有效的 MIDI 文件数据。

参数：
file - 应该从中提取文件格式信息的 File
返回：
描述 MIDI 文件格式的 MidiFileFormat 对象
抛出：
InvalidMidiDataException - 如果 File 没有指向系统识别的有效 MIDI 文件数据
IOException - 如果发生 I/O 异常

getSequence

public abstract Sequence getSequence(InputStream stream)
                              throws InvalidMidiDataException,
                                     IOException
从提供的输入流获得 MIDI 序列。流必须指向有效的 MIDI 文件数据。通常，MIDI 文件 reader 可能需要在确定它们是否支持流之前从中读取一些数据。这些解析器必须能够标记流，读取足够多的数据来确定它们是否支持流，并且如果不支持，则将流的阅读指针重新设置到其初始位置。如果输入流不支持此操作，则此方法可能会失败，并抛出 IOException。

参数：
stream - 应该从中构造 Sequence 的输入流
返回：
基于包含在输入流中的 MIDI 文件数据的 Sequence 对象。
抛出：
InvalidMidiDataException - 如果该流没有指向系统识别的有效 MIDI 文件数据
IOException - 如果发生 I/O 异常
另请参见：
InputStream.markSupported(), InputStream.mark(int)

getSequence

public abstract Sequence getSequence(URL url)
                              throws InvalidMidiDataException,
                                     IOException
从提供的 URL 获得 MIDI 序列。URL 必须指向有效的 MIDI 文件数据。

参数：
url - 应该为其构造 Sequence 的 URL
返回：
基于由 URL 指向的 MIDI 文件数据的 Sequence 对象
抛出：
InvalidMidiDataException - 如果 URL 没有指向系统识别的有效 MIDI 文件数据
IOException - 如果发生 I/O 异常

getSequence

public abstract Sequence getSequence(File file)
                              throws InvalidMidiDataException,
                                     IOException
从提供的 File 获得 MIDI 序列。File 必须指向有效的 MIDI 文件数据。

参数：
file - 应该从中构造 Sequence 的 File
返回：
基于由 File 指向的 MIDI 文件数据的 Sequence 对象
抛出：
InvalidMidiDataException - 如果 File 没有指向系统识别的有效 MIDI 文件数据
IOException - 如果发生 I/O 异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MidiFileWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi.spi
类 MidiFileWriter

java.lang.Object
    继承者  javax.sound.midi.spi.MidiFileWriter

public abstract class MidiFileWriter
extends Object

MidiFileWriter 提供 MIDI 文件写入服务。实现此接口的类可以从 Sequence 对象写入一种或多种类型的 MIDI 文件。

从以下版本开始：
1.3

构造方法摘要
MidiFileWriter()
方法摘要
abstract int[] | getMidiFileTypes() 获得此文件 writer 为其提供文件写入支持的 MIDI 文件类型的集合。
abstract int[] | getMidiFileTypes(Sequence sequence) 获得此文件 writer 可从指定的序列写入的文件类型。
boolean | isFileTypeSupported(int fileType) 指示此文件 writer 是否提供指定 MIDI 文件类型的文件写入支持。
boolean | isFileTypeSupported(int fileType, Sequence sequence) 指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
abstract int | write(Sequence in, int fileType, File out) 写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。
abstract int | write(Sequence in, int fileType, OutputStream out) 写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

MidiFileWriter

public MidiFileWriter()
方法详细信息

getMidiFileTypes

public abstract int[] getMidiFileTypes()
获得此文件 writer 为其提供文件写入支持的 MIDI 文件类型的集合。

返回：
文件类型的数组。如果不支持任何文件类型，则返回长度为 0 的数组。

getMidiFileTypes

public abstract int[] getMidiFileTypes(Sequence sequence)
获得此文件 writer 可从指定的序列写入的文件类型。

参数：
sequence - 为其查询 MIDI 文件类型支持的序列
返回：
文件类型的数组。如果不支持任何文件类型，则返回长度为 0 的数组。

isFileTypeSupported

public boolean isFileTypeSupported(int fileType)
指示此文件 writer 是否提供指定 MIDI 文件类型的文件写入支持。

参数：
fileType - 查询其写入功能的文件类型
返回：
如果支持文件类型，则返回 true；否则返回 false

isFileTypeSupported

public boolean isFileTypeSupported(int fileType,
                                   Sequence sequence)
指示是否可从指示的序列写入指定文件类型的 MIDI 文件。

参数：
fileType - 查询其写入功能的文件类型
sequence - 查询其文件写入支持的序列
返回：
如果支持此序列的文件类型，则返回 true；否则返回 false

write

public abstract int write(Sequence in,
                          int fileType,
                          OutputStream out)
                   throws IOException
写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。

参数：
in - 包含要写入文件的 MIDI 数据的序列
fileType - 要写入输出流的文件类型
out - 应将文件数据写入的流
返回：
写入输出流的字节数
抛出：
IOException - 如果发生 I/O 异常
IllegalArgumentException - 如果文件 writer 不支持文件类型
另请参见：
isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)

write

public abstract int write(Sequence in,
                          int fileType,
                          File out)
                   throws IOException
写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。

参数：
in - 包含要写入外部文件的 MIDI 数据的序列
fileType - 要写入外部文件的文件类型
out - 应将文件数据写入的外部文件
返回：
写入文件的字节数
抛出：
IOException - 如果发生 I/O 异常
IllegalArgumentException - 如果此文件 writer 不支持文件类型
另请参见：
isFileTypeSupported(int, Sequence), getMidiFileTypes(Sequence)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SoundbankReader (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sound.midi.spi
类 SoundbankReader

java.lang.Object
    继承者  javax.sound.midi.spi.SoundbankReader

public abstract class SoundbankReader
extends Object

SoundbankReader 提供音库文件读取服务。SoundbankReader 的具体子类分析给定的音库文件，生成可加载到 Synthesizer 中的 Soundbank 对象。

从以下版本开始：
1.3

构造方法摘要
SoundbankReader()
方法摘要
abstract Soundbank | getSoundbank(File file) 从提供的 File 获得音库对象。
abstract Soundbank | getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。
abstract Soundbank | getSoundbank(URL url) 从提供的 URL 获得音库对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SoundbankReader

public SoundbankReader()
方法详细信息

getSoundbank

public abstract Soundbank getSoundbank(URL url)
                                throws InvalidMidiDataException,
                                       IOException
从提供的 URL 获得音库对象。

参数：
url - 表示音库的 URL。
返回：
音库对象
抛出：
InvalidMidiDataException - 如果 URL 不指向此音库 reader 识别的有效 MIDI 音库数据
IOException - 如果发生 I/O 错误

getSoundbank

public abstract Soundbank getSoundbank(InputStream stream)
                                throws InvalidMidiDataException,
                                       IOException
从提供的 InputStream 获得音库对象。

参数：
stream - 表示音库的 InputStream
返回：
音库对象
抛出：
InvalidMidiDataException - 如果流不指向此音库 reader 识别的有效 MIDI 音库数据
IOException - 如果发生 I/O 错误

getSoundbank

public abstract Soundbank getSoundbank(File file)
                                throws InvalidMidiDataException,
                                       IOException
从提供的 File 获得音库对象。

参数：
file - 表示音库的 File
返回：
音库对象
抛出：
InvalidMidiDataException - 如果文件不指向此音库 reader 识别的有效 MIDI 音库文件
IOException - 如果发生 I/O 错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sound.midi.spi (Java 2 Platform SE 6)

 javax.sound.midi.spi
类
MidiDeviceProvider
MidiFileReader
MidiFileWriter
SoundbankReader


javax.sound.midi.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sound.midi.spi

在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

请参见：
描述

类摘要
MidiDeviceProvider | MidiDeviceProvider 是特定类型的 MIDI 设备的工厂或提供者。
MidiFileReader | MidiFileReader 提供 MIDI 文件读取服务。
MidiFileWriter | MidiFileWriter 提供 MIDI 文件写入服务。
SoundbankReader | SoundbankReader 提供音库文件读取服务。

软件包 javax.sound.midi.spi 的描述

在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

相关文档

有关概述、教程、示例和指南的信息，请参阅：
  • 声音

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.sound.midi.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.midi.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.sound.midi.spi.MidiDeviceProvider
    • javax.sound.midi.spi.MidiFileReader
    • javax.sound.midi.spi.MidiFileWriter
    • javax.sound.midi.spi.SoundbankReader
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sound.midi.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sound.midi.spi
的使用

没有 javax.sound.midi.spi 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.spi.MidiDeviceProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.MidiDeviceProvider
的使用

没有 javax.sound.midi.spi.MidiDeviceProvider 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.spi.MidiFileReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.MidiFileReader
的使用

没有 javax.sound.midi.spi.MidiFileReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.spi.MidiFileWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.MidiFileWriter
的使用

没有 javax.sound.midi.spi.MidiFileWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.spi.SoundbankReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.spi.SoundbankReader
的使用

没有 javax.sound.midi.spi.SoundbankReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.ControllerEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.ControllerEventListener
的使用

使用 ControllerEventListener 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 ControllerEventListener 的使用

参数类型为 ControllerEventListener 的 javax.sound.midi 中的方法
int[] | Sequencer.addControllerEventListener(ControllerEventListener listener, int[] controllers) 注册一个控件事件侦听器，以便在 sequencer 处理所请求的一种或多种类型的控制更改事件时接收通知。
int[] | Sequencer.removeControllerEventListener(ControllerEventListener listener, int[] controllers) 移除侦听一类或多类控件事件的控件事件侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.Instrument 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Instrument
的使用

使用 Instrument 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Instrument 的使用

返回 Instrument 的 javax.sound.midi 中的方法
Instrument[] | Synthesizer.getAvailableInstruments() 获得该合成器随附的乐器列表。
Instrument | Soundbank.getInstrument(Patch patch) 获得取自给定 Patch 的 Instrument。
Instrument[] | Soundbank.getInstruments() 获得包含在此音库中的乐器列表。
Instrument[] | Synthesizer.getLoadedInstruments() 获得当前加载到此 Synthesizer 中的乐器列表。

参数类型为 Instrument 的 javax.sound.midi 中的方法
boolean | Synthesizer.loadInstrument(Instrument instrument) 让特定的乐器可用于合成。
boolean | Synthesizer.remapInstrument(Instrument from, Instrument to) 重新映射一个乐器。
void | Synthesizer.unloadInstrument(Instrument instrument) 卸载特定的乐器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.InvalidMidiDataException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.InvalidMidiDataException
的使用

使用 InvalidMidiDataException 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 InvalidMidiDataException 的使用

抛出 InvalidMidiDataException 的 javax.sound.midi 中的方法
protected int | ShortMessage.getDataLength(int status) 检索与特定状态字节值关联的数据字节数。
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。
protected void | MidiMessage.setMessage(byte[] data, int length) 为 MIDI 消息设置数据。
void | SysexMessage.setMessage(byte[] data, int length) 为系统独占消息设置数据。
void | ShortMessage.setMessage(int status) 为不带任何数据字节的 MIDI 消息设置参数。
void | MetaMessage.setMessage(int type, byte[] data, int length) 为 MetaMessage 设置消息参数。
void | SysexMessage.setMessage(int status, byte[] data, int length) 为系统独占消息设置数据。
void | ShortMessage.setMessage(int status, int data1, int data2) 为带一个或两个数据字节的 MIDI 消息设置参数。
void | ShortMessage.setMessage(int command, int channel, int data1, int data2) 为带两个数据字节的通道消息设置短消息参数。
void | Sequencer.setSequence(InputStream stream) 设置 sequencer 所操作的当前 sequence。
void | Sequencer.setSequence(Sequence sequence) 设置 sequencer 所操作的当前 sequence。

抛出 InvalidMidiDataException 的 javax.sound.midi 中的构造方法
Sequence(float divisionType, int resolution)
构造具有指定的定时 division 类型和定时精度的新 MIDI Sequence。
Sequence(float divisionType, int resolution, int numTracks)
构造具有指定的定时 division 类型、定时精度和轨道数的新 MIDI Sequence。

javax.sound.midi.spi 中 InvalidMidiDataException 的使用

抛出 InvalidMidiDataException 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.MetaEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.MetaEventListener
的使用

使用 MetaEventListener 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MetaEventListener 的使用

参数类型为 MetaEventListener 的 javax.sound.midi 中的方法
boolean | Sequencer.addMetaEventListener(MetaEventListener listener) 注册一个元事件侦听器，以便在 sequence 中遇到元事件并由此 sequencer 处理时接收通知。
void | Sequencer.removeMetaEventListener(MetaEventListener listener) 从此 sequencer 的已注册侦听器列表中移除指定的元事件侦听器（如果实际上此侦听器已注册）。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.MetaMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MetaMessage
的使用

使用 MetaMessage 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MetaMessage 的使用

参数类型为 MetaMessage 的 javax.sound.midi 中的方法
 void MetaEventListener.meta(MetaMessage meta)
在 Sequencer 遇到并处理了一个它正在处理的 Sequence 中的 MetaMessage 时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.MidiChannel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.MidiChannel
的使用

使用 MidiChannel 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiChannel 的使用

返回 MidiChannel 的 javax.sound.midi 中的方法
 MidiChannel[] Synthesizer.getChannels()
获得此合成器控制的一组 MIDI 通道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.MidiDevice 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.MidiDevice
的使用

使用 MidiDevice 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 MidiDevice 的使用

javax.sound.midi 中 MidiDevice 的子接口
interface | Sequencer 回放 MIDI sequence 的硬件或软件设备就是所谓的 sequencer。
interface | Synthesizer Synthesizer 生成声音。

返回 MidiDevice 的 javax.sound.midi 中的方法
static MidiDevice MidiSystem.getMidiDevice(MidiDevice.Info info)
获得请求的 MIDI 设备。

javax.sound.midi.spi 中 MidiDevice 的使用

返回 MidiDevice 的 javax.sound.midi.spi 中的方法
abstract  MidiDevice MidiDeviceProvider.getDevice(MidiDevice.Info info)
获得由信息对象表示的设备的实例。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.MidiDevice.Info 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiDevice.Info
的使用

使用 MidiDevice.Info 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 MidiDevice.Info 的使用

返回 MidiDevice.Info 的 javax.sound.midi 中的方法
MidiDevice.Info | MidiDevice.getDeviceInfo() 获得有关设备的信息，其中包括包含了其名称、供应商和描述的 Java 类和 Strings。
static MidiDevice.Info[] | MidiSystem.getMidiDeviceInfo() 获得信息对象数组，表示系统中可用的所有 MIDI 设备集。

参数类型为 MidiDevice.Info 的 javax.sound.midi 中的方法
static MidiDevice MidiSystem.getMidiDevice(MidiDevice.Info info)
获得请求的 MIDI 设备。

javax.sound.midi.spi 中 MidiDevice.Info 的使用

返回 MidiDevice.Info 的 javax.sound.midi.spi 中的方法
abstract  MidiDevice.Info[] MidiDeviceProvider.getDeviceInfo()
获得表示设备或由此 MidiDeviceProvider 提供的设备的信息对象集合。

参数类型为 MidiDevice.Info 的 javax.sound.midi.spi 中的方法
abstract MidiDevice | MidiDeviceProvider.getDevice(MidiDevice.Info info) 获得由信息对象表示的设备的实例。
boolean | MidiDeviceProvider.isDeviceSupported(MidiDevice.Info info) 指示该设备提供者是否支持由指定的设备信息对象表示的设备。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.MidiEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiEvent
的使用

使用 MidiEvent 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiEvent 的使用

返回 MidiEvent 的 javax.sound.midi 中的方法
 MidiEvent Track.get(int index)
获得位于指定索引处的事件。

参数类型为 MidiEvent 的 javax.sound.midi 中的方法
boolean | Track.add(MidiEvent event) 将新事件添加至音轨。
boolean | Track.remove(MidiEvent event) 从音轨中移除指定的事件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.MidiFileFormat 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiFileFormat
的使用

使用 MidiFileFormat 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 MidiFileFormat 的使用

返回 MidiFileFormat 的 javax.sound.midi 中的方法
static MidiFileFormat | MidiSystem.getMidiFileFormat(File file) 获得指定 File 的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(InputStream stream) 获得指定的输入流中数据的 MIDI 文件格式。
static MidiFileFormat | MidiSystem.getMidiFileFormat(URL url) 获得指定 URL 中数据的 MIDI 文件格式。

javax.sound.midi.spi 中 MidiFileFormat 的使用

返回 MidiFileFormat 的 javax.sound.midi.spi 中的方法
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(File file) 获得提供的 File 的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(InputStream stream) 获得所提供的输入流的 MIDI 文件格式。
abstract MidiFileFormat | MidiFileReader.getMidiFileFormat(URL url) 获得提供的 URL 的 MIDI 文件格式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.MidiMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiMessage
的使用

使用 MidiMessage 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiMessage 的使用

javax.sound.midi 中 MidiMessage 的子类
class | MetaMessage MetaMessage 是一个 MidiMessage，它对于合成器没有任何意义，但可存储在一个 MIDI 文件中然后由 sequencer 程序解释。
class | ShortMessage ShortMessage 包含了一个 MIDI 消息，该消息在状态字节后最多有两个数据字节。
class | SysexMessage 表示 MIDI 系统独占消息 SysexMessage 对象。

返回 MidiMessage 的 javax.sound.midi 中的方法
 MidiMessage MidiEvent.getMessage()
获得事件中包含的 MIDI 消息。

参数类型为 MidiMessage 的 javax.sound.midi 中的方法
 void Receiver.send(MidiMessage message, long timeStamp)
向接收器发送一个 MIDI 消息和时间戳。

参数类型为 MidiMessage 的 javax.sound.midi 中的构造方法
MidiEvent(MidiMessage message, long tick)
构造一个新的 MidiEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.MidiSystem 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiSystem
的使用

没有 javax.sound.midi.MidiSystem 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.MidiUnavailableException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.MidiUnavailableException
的使用

使用 MidiUnavailableException 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 MidiUnavailableException 的使用

抛出 MidiUnavailableException 的 javax.sound.midi 中的方法
static MidiDevice | MidiSystem.getMidiDevice(MidiDevice.Info info) 获得请求的 MIDI 设备。
Receiver | MidiDevice.getReceiver() 获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。
static Receiver | MidiSystem.getReceiver() 从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。
static Sequencer | MidiSystem.getSequencer() 获得连接到默认设备上的默认的 Sequencer。
static Sequencer | MidiSystem.getSequencer(boolean connected) 获得默认的 Sequencer，它可选地连接到默认设备上。
static Synthesizer | MidiSystem.getSynthesizer() 获得默认的合成器。
Transmitter | MidiDevice.getTransmitter() 获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。
static Transmitter | MidiSystem.getTransmitter() 从外部 MIDI 端口或其他默认源获得 MIDI 传输器。
void | MidiDevice.open() 打开设备，指示它现在应获取任何所需的系统资源然后开始运行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.Patch 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Patch
的使用

使用 Patch 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Patch 的使用

返回 Patch 的 javax.sound.midi 中的方法
Patch | Instrument.getPatch() 获得 Patch 对象，该对象指示此乐器在合成器中存储位置处的库和程序号。
Patch[] | Sequence.getPatchList() 获得此 Sequence 中引用的包列表。

参数类型为 Patch 的 javax.sound.midi 中的方法
Instrument | Soundbank.getInstrument(Patch patch) 获得取自给定 Patch 的 Instrument。
boolean | Synthesizer.loadInstruments(Soundbank soundbank, Patch[] patchList) 从指定 Soundbank 加载指定修补程序所引用的乐器。
void | Synthesizer.unloadInstruments(Soundbank soundbank, Patch[] patchList) 从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。

参数类型为 Patch 的 javax.sound.midi 中的构造方法
Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.Receiver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Receiver
的使用

使用 Receiver 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Receiver 的使用

返回 Receiver 的 javax.sound.midi 中的方法
Receiver | MidiDevice.getReceiver() 获得 MIDI 设备可通过其接收 MIDI 数据的 MIDI IN 接收器。
static Receiver | MidiSystem.getReceiver() 从外部 MIDI 端口或其他默认设备获得 MIDI 接收器。
Receiver | Transmitter.getReceiver() 获得此传输器将向其传送 MIDI 消息的当前接收器。

返回变量类型为 Receiver 的类型的 javax.sound.midi 中的方法
 List<Receiver> MidiDevice.getReceivers()
返回与该 MidiDevice 连接的所有当前活动的、非关闭的接收器。

参数类型为 Receiver 的 javax.sound.midi 中的方法
 void Transmitter.setReceiver(Receiver receiver)
设置此传输器将向其传送 MIDI 消息的接收器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.Sequence 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Sequence
的使用

使用 Sequence 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 Sequence 的使用

返回 Sequence 的 javax.sound.midi 中的方法
Sequence | Sequencer.getSequence() 获得 Sequencer 当前所操作的 sequence。
static Sequence | MidiSystem.getSequence(File file) 从指定的 File 获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(InputStream stream) 从指定的输入流获得 MIDI 序列。
static Sequence | MidiSystem.getSequence(URL url) 从指定的 URL 获得 MIDI 序列。

参数类型为 Sequence 的 javax.sound.midi 中的方法
static int[] | MidiSystem.getMidiFileTypes(Sequence sequence) 获得系统可从指定 sequence 写入的 MIDI 文件类型集合。
static boolean | MidiSystem.isFileTypeSupported(int fileType, Sequence sequence) 指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
void | Sequencer.setSequence(Sequence sequence) 设置 sequencer 所操作的当前 sequence。
static int | MidiSystem.write(Sequence in, int type, File out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的外部文件。
static int | MidiSystem.write(Sequence in, int fileType, OutputStream out) 将表示所指示 MIDI 文件类型的文件的字节流写入提供的输出流。

javax.sound.midi.spi 中 Sequence 的使用

返回 Sequence 的 javax.sound.midi.spi 中的方法
abstract Sequence | MidiFileReader.getSequence(File file) 从提供的 File 获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(InputStream stream) 从提供的输入流获得 MIDI 序列。
abstract Sequence | MidiFileReader.getSequence(URL url) 从提供的 URL 获得 MIDI 序列。

参数类型为 Sequence 的 javax.sound.midi.spi 中的方法
abstract int[] | MidiFileWriter.getMidiFileTypes(Sequence sequence) 获得此文件 writer 可从指定的序列写入的文件类型。
boolean | MidiFileWriter.isFileTypeSupported(int fileType, Sequence sequence) 指示是否可从指示的序列写入指定文件类型的 MIDI 文件。
abstract int | MidiFileWriter.write(Sequence in, int fileType, File out) 写入表示指示为所提供外部文件的文件类型的 MIDI 文件的字节流。
abstract int | MidiFileWriter.write(Sequence in, int fileType, OutputStream out) 写入表示指示为所提供输出流的文件类型的 MIDI 文件的字节流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.Sequencer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Sequencer
的使用

使用 Sequencer 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Sequencer 的使用

返回 Sequencer 的 javax.sound.midi 中的方法
static Sequencer | MidiSystem.getSequencer() 获得连接到默认设备上的默认的 Sequencer。
static Sequencer | MidiSystem.getSequencer(boolean connected) 获得默认的 Sequencer，它可选地连接到默认设备上。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.Sequencer.SyncMode 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Sequencer.SyncMode
的使用

使用 Sequencer.SyncMode 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Sequencer.SyncMode 的使用

声明为 Sequencer.SyncMode 的 javax.sound.midi 中的字段
static Sequencer.SyncMode | Sequencer.SyncMode.INTERNAL_CLOCK 主同步模式，它使 sequencer 从其内部时钟获取计时信息。
static Sequencer.SyncMode | Sequencer.SyncMode.MIDI_SYNC 指定使用 MIDI 时钟消息的主或辅同步模式。
static Sequencer.SyncMode | Sequencer.SyncMode.MIDI_TIME_CODE 指定使用 MIDI 时间代码的主或辅同步模式如果此模式用作主同步模式，sequencer 从 MIDI 时间代码消息获取其计时信息。
static Sequencer.SyncMode | Sequencer.SyncMode.NO_SYNC 辅同步模式，指示不应向接收者发送任何计时信息。

返回 Sequencer.SyncMode 的 javax.sound.midi 中的方法
Sequencer.SyncMode | Sequencer.getMasterSyncMode() 获得此 sequencer 的当前主同步模式。
Sequencer.SyncMode[] | Sequencer.getMasterSyncModes() 获得此 sequencer 支持的主同步模式集。
Sequencer.SyncMode | Sequencer.getSlaveSyncMode() 获得此 sequencer 的当前从同步模式。
Sequencer.SyncMode[] | Sequencer.getSlaveSyncModes() 获得此 sequencer 支持的从同步模式集。

参数类型为 Sequencer.SyncMode 的 javax.sound.midi 中的方法
void | Sequencer.setMasterSyncMode(Sequencer.SyncMode sync) 设置此 sequencer 使用的定时信息源。
void | Sequencer.setSlaveSyncMode(Sequencer.SyncMode sync) 设置此 sequencer 的从同步模式。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.ShortMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.ShortMessage
的使用

使用 ShortMessage 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 ShortMessage 的使用

参数类型为 ShortMessage 的 javax.sound.midi 中的方法
 void ControllerEventListener.controlChange(ShortMessage event)
当 Sequencer 遇到并处理了一个此侦听器需要的控制更改事件时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.Soundbank 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Soundbank
的使用

使用 Soundbank 的软件包
javax.sound.midi | 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。
javax.sound.midi.spi | 在提供新的 MIDI 设备、MIDI 文件 reader 和 writer、或音库 reader 时提供服务提供者要实现的接口。

javax.sound.midi 中 Soundbank 的使用

返回 Soundbank 的 javax.sound.midi 中的方法
Soundbank | Synthesizer.getDefaultSoundbank() 获得合成器的默认音库（如果合成器存在）。
Soundbank | SoundbankResource.getSoundbank() 获得包含此 SoundbankResource 的音库。
static Soundbank | MidiSystem.getSoundbank(File file) 通过从指定的 File 读取来构造一个 Soundbank。
static Soundbank | MidiSystem.getSoundbank(InputStream stream) 通过从指定的流读取来构造一个 MIDI 音库。
static Soundbank | MidiSystem.getSoundbank(URL url) 通过从指定的 URL 处读取来构造一个 Soundbank。

参数类型为 Soundbank 的 javax.sound.midi 中的方法
boolean | Synthesizer.isSoundbankSupported(Soundbank soundbank) 通知调用者此合成器是否能够从指定的音库加载乐器。
boolean | Synthesizer.loadAllInstruments(Soundbank soundbank) 将指定 Soundbank 中包含的所有乐器加载到 Synthesizer 中。
boolean | Synthesizer.loadInstruments(Soundbank soundbank, Patch[] patchList) 从指定 Soundbank 加载指定修补程序所引用的乐器。
void | Synthesizer.unloadAllInstruments(Soundbank soundbank) 卸载指定 Soundbank 中包含的所有乐器。
void | Synthesizer.unloadInstruments(Soundbank soundbank, Patch[] patchList) 从指定的 MIDI 音库中卸载指定修补程序所引用的乐器。

参数类型为 Soundbank 的 javax.sound.midi 中的构造方法
Instrument(Soundbank soundbank, Patch patch, String name, Class<?> dataClass)
从指定的 Patch 构造一个新的 MIDI 乐器。
SoundbankResource(Soundbank soundBank, String name, Class<?> dataClass)
根据给定的音库和波表索引构造一个新的 SoundbankResource。

javax.sound.midi.spi 中 Soundbank 的使用

返回 Soundbank 的 javax.sound.midi.spi 中的方法
abstract Soundbank | SoundbankReader.getSoundbank(File file) 从提供的 File 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(InputStream stream) 从提供的 InputStream 获得音库对象。
abstract Soundbank | SoundbankReader.getSoundbank(URL url) 从提供的 URL 获得音库对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.SoundbankResource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.SoundbankResource
的使用

使用 SoundbankResource 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 SoundbankResource 的使用

javax.sound.midi 中 SoundbankResource 的子类
 class Instrument
乐器是带特定参数设置的声音合成算法，通常是为模仿现实世界的特定乐器或为获得特定音效而设计的。

返回 SoundbankResource 的 javax.sound.midi 中的方法
 SoundbankResource[] Soundbank.getResources()
提取音库中包含的非乐器资源列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.Synthesizer 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Synthesizer
的使用

使用 Synthesizer 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Synthesizer 的使用

返回 Synthesizer 的 javax.sound.midi 中的方法
static Synthesizer MidiSystem.getSynthesizer()
获得默认的合成器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.SysexMessage 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.SysexMessage
的使用

没有 javax.sound.midi.SysexMessage 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.Track 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.Track
的使用

使用 Track 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Track 的使用

类型参数类型为 Track 的 javax.sound.midi 中的字段
protected  Vector<Track> Sequence.tracks
此 sequence 中的 MIDI 轨道。

返回 Track 的 javax.sound.midi 中的方法
Track | Sequence.createTrack() 创建一个新的、初始为空的轨道作为此 Sequence 的一部分。
Track[] | Sequence.getTracks() 获得包含此 Sequence 中所有轨道的数组。

参数类型为 Track 的 javax.sound.midi 中的方法
boolean | Sequence.deleteTrack(Track track) 从 Sequence 中移除指定的轨道。
void | Sequencer.recordDisable(Track track) 禁止向指定轨道的录制。
void | Sequencer.recordEnable(Track track, int channel) 为录制特定通道上接收的事件准备指定的轨道。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sound.midi.Transmitter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sound.midi.Transmitter
的使用

使用 Transmitter 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 Transmitter 的使用

返回 Transmitter 的 javax.sound.midi 中的方法
Transmitter | MidiDevice.getTransmitter() 获得 MIDI 设备将从其传输 MIDI 数据的 MIDI OUT 连接。
static Transmitter | MidiSystem.getTransmitter() 从外部 MIDI 端口或其他默认源获得 MIDI 传输器。

返回变量类型为 Transmitter 的类型的 javax.sound.midi 中的方法
 List<Transmitter> MidiDevice.getTransmitters()
返回与该 MidiDevice 连接的所有当前活动的、非关闭的传输器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sound.midi.VoiceStatus 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sound.midi.VoiceStatus
的使用

使用 VoiceStatus 的软件包
javax.sound.midi 提供用于 MIDI（音乐乐器数字接口）数据的 I/O、序列化和合成的接口和类。

javax.sound.midi 中 VoiceStatus 的使用

返回 VoiceStatus 的 javax.sound.midi 中的方法
 VoiceStatus[] Synthesizer.getVoiceStatus()
获得由此合成器生成的声音的当前状态。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


CommonDataSource (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 CommonDataSource

所有已知子接口：
ConnectionPoolDataSource, DataSource, XADataSource
public interface CommonDataSource

此接口定义在 DataSource、XADataSource 和 ConnectionPoolDataSource 之间公用的方法。

方法摘要
int | getLoginTimeout() 获取此数据源试图连接到某一数据库时可以等待的最长时间，以秒为单位。
PrintWriter | getLogWriter() 获取此 DataSource 对象的日志 writer。
void | setLoginTimeout(int seconds) 设置此数据源试图连接到某一数据库时将等待的最长时间，以秒为单位。
void | setLogWriter(PrintWriter out) 将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。

方法详细信息

getLogWriter

PrintWriter getLogWriter()
                         throws SQLException

获取此 DataSource 对象的日志 writer。

日志 writer 是一个字符输出流，此数据源的所有日志记录和跟踪消息都将被打印到该输出流。这包括由此对象的方法打印的消息、由此对象构造的其他对象的方法打印的消息等等。打印到特定于数据源的日志 writer 的消息不会被打印到与 java.sql.DriverManager 类关联的日志 writer。创建 DataSource 对象时，日志 writer 最初为 null；换句话说，默认为禁用日志记录。

返回：
此数据源的日志 writer；如果禁用日志记录，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
另请参见：
setLogWriter(java.io.PrintWriter)

setLogWriter

void setLogWriter(PrintWriter out)
                  throws SQLException

将此 DataSource 对象的日志 writer 设置为给定的 java.io.PrintWriter 对象。

日志 writer 是一个字符输出流，此数据源的所有日志记录和跟踪消息都将被打印到该输出流。这包括由此对象的方法打印的消息、由此对象构造的其他对象的方法打印的消息等等。打印到特定于数据源的日志 writer 的消息不会被打印到与 java.sql.DriverManager 类关联的日志 writer。创建 DataSource 对象时，日志 writer 最初为 null；换句话说，默认为禁用日志记录。

参数：
out - 新的日志 writer；如果要禁用日志记录，则设置为 null
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
另请参见：
getLogWriter()

setLoginTimeout

void setLoginTimeout(int seconds)
                     throws SQLException

设置此数据源试图连接到某一数据库时将等待的最长时间，以秒为单位。值为 0 表示超时值为默认的系统超时值（如果有）；否则它表示不存在超时值。创建 DataSource 对象时，登录超时值最初为 0。

参数：
seconds - 数据源登录超时值
抛出：
SQLException - 如果发生数据库访问错误。
从以下版本开始：
1.4
另请参见：
getLoginTimeout()

getLoginTimeout

int getLoginTimeout()
                    throws SQLException
获取此数据源试图连接到某一数据库时可以等待的最长时间，以秒为单位。值为 0 表示超时值为默认的系统超时值（如果有）；否则它表示不存在超时值。创建 DataSource 对象时，登录超时值最初为 0。

返回：
数据源登录超时值
抛出：
SQLException - 如果发生数据库访问错误。
从以下版本开始：
1.4
另请参见：
setLoginTimeout(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ConnectionEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
类 ConnectionEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.sql.ConnectionEvent
所有已实现的接口：
Serializable
public class ConnectionEvent
extends EventObject

提供关于连接相关事件的源信息的 Event 对象。当应用程序关闭已入池连接并发生错误时生成 ConnectionEvent 对象。ConnectionEvent 对象包含两种信息：

  • 应用程序关闭的入池连接
  • 在发生错误事件时要向应用程序抛出的 SQLException

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ConnectionEvent(PooledConnection con)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象进行初始化。
ConnectionEvent(PooledConnection con, SQLException ex)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。
方法摘要
 SQLException getSQLException()
获取此 ConnectionEvent 对象的 SQLException。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ConnectionEvent

public ConnectionEvent(PooledConnection con)

构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象进行初始化。SQLException 的默认值为 null。

参数：
con - 作为事件源的入池连接
抛出：
IllegalArgumentException - 如果 con 为 null。

ConnectionEvent

public ConnectionEvent(PooledConnection con,
                       SQLException ex)

构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。

参数：
con - 作为事件源的入池连接
ex - 要向应用程序抛出的 SQLException
抛出：
IllegalArgumentException - 如果 con 为 null。
方法详细信息

getSQLException

public SQLException getSQLException()

获取此 ConnectionEvent 对象的 SQLException。可能为 null。

返回：
要抛出的 SQLException，或者 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConnectionEventListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 ConnectionEventListener

所有超级接口：
EventListener
public interface ConnectionEventListener
extends EventListener

注册该对象便可获得由 PooledConnection 对象生成的事件的通知。

ConnectionEventListener 接口由连接池组件实现。连接池组件通常由 JDBC 驱动程序供应商或另一个系统软件供应商提供。当使用注册了侦听器的入池连接完成应用程序时，JDBC 驱动程序将向 ConnectionEventListener 对象发出通知。该通知发生在应用程序对其 PooledConnection 对象表示形式调用 close 方法之后。当连接因 PooledConnection 不适合将来使用而发生连接错误时（例如，服务器崩溃），ConnectionEventListener 也将得到通知。JDBC 驱动程序仅在驱动程序使用 PooledConnection 对象向应用程序抛出 SQLException 之前向侦听器发出通知。

从以下版本开始：
1.4

方法摘要
void | connectionClosed(ConnectionEvent event) 通知此 ConnectionEventListener 应用程序已对其入池连接的表示形式调用 close 方法。
void | connectionErrorOccurred(ConnectionEvent event) 通知此 ConnectionEventListener 发生了严重错误，入池连接不再可用。

方法详细信息

connectionClosed

void connectionClosed(ConnectionEvent event)
通知此 ConnectionEventListener 应用程序已对其入池连接的表示形式调用 close 方法。

参数：
event - 描述事件源的事件对象

connectionErrorOccurred

void connectionErrorOccurred(ConnectionEvent event)
通知此 ConnectionEventListener 发生了严重错误，入池连接不再可用。驱动程序仅在向应用程序抛出包含在给定 ConnectionEvent 对象中的 SQLException 时发出此通知。

参数：
event - 一个事件对象，它描述事件源和包含驱动程序将抛出的 SQLException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ConnectionPoolDataSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 ConnectionPoolDataSource

所有超级接口：
CommonDataSource
public interface ConnectionPoolDataSource
extends CommonDataSource

PooledConnection 对象的工厂。实现此接口的对象通常在基于 JavaTM Naming and Directory Interface (JNDI) 的命名服务中注册。

从以下版本开始：
1.4

方法摘要
PooledConnection | getPooledConnection() 尝试建立可用作入池连接的物理数据库连接。
PooledConnection | getPooledConnection(String user, String password) 尝试建立可用作入池连接的物理数据库连接。
从接口 javax.sql.CommonDataSource 继承的方法
getLoginTimeout, getLogWriter, setLoginTimeout, setLogWriter

方法详细信息

getPooledConnection

PooledConnection getPooledConnection()
                                     throws SQLException
尝试建立可用作入池连接的物理数据库连接。

返回：
PooledConnection 对象，该对象是到此 ConnectionPoolDataSource 对象表示的数据库的物理连接
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getPooledConnection

PooledConnection getPooledConnection(String user,
                                     String password)
                                     throws SQLException
尝试建立可用作入池连接的物理数据库连接。

参数：
user - 为其建立连接的数据库用户
password - 用户的密码
返回：
PooledConnection 对象，该对象是到此 ConnectionPoolDataSource 对象表示的数据库的物理连接
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DataSource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 DataSource

所有超级接口：
CommonDataSource, Wrapper
public interface DataSource
extends CommonDataSource, Wrapper

该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。作为 DriverManager 工具的替代项，DataSource 对象是获取连接的首选方法。实现 DataSource 接口的对象通常在基于 JavaTM Naming and Directory Interface (JNDI) API 的命名服务中注册。

DataSource 接口由驱动程序供应商实现。共有三种类型的实现：

  1. 基本实现 - 生成标准的 Connection 对象
  2. 连接池实现 - 生成自动参与连接池的 Connection 对象。此实现与中间层连接池管理器一起使用。
  3. 分布式事务实现 - 生成一个 Connection 对象，该对象可用于分布式事务，大多数情况下总是参与连接池。此实现与中间层事务管理器一起使用，大多数情况下总是与连接池管理器一起使用。

DataSource 对象的属性在必要时可以修改。例如，如果将数据源移动到另一个服务器，则可更改与服务器相关的属性。其优点在于，由于可以更改数据源的属性，所以任何访问该数据源的代码都无需更改。

通过 DataSource 对象访问的驱动程序本身不会向 DriverManager 注册。通过查找操作获取 DataSource 对象，然后使用该对象创建 Connection 对象。使用基本的实现，通过 DataSource 对象获取的连接与通过 DriverManager 设施获取的连接相同。

从以下版本开始：
1.4

方法摘要
Connection | getConnection() 尝试建立与此 DataSource 对象所表示的数据源的连接。
Connection | getConnection(String username, String password) 尝试建立与此 DataSource 对象所表示的数据源的连接。
从接口 javax.sql.CommonDataSource 继承的方法
getLoginTimeout, getLogWriter, setLoginTimeout, setLogWriter
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

方法详细信息

getConnection

Connection getConnection()
                         throws SQLException

尝试建立与此 DataSource 对象所表示的数据源的连接。

返回：
到数据源的连接
抛出：
SQLException - 如果发生数据库访问错误

getConnection

Connection getConnection(String username,
                         String password)
                         throws SQLException

尝试建立与此 DataSource 对象所表示的数据源的连接。

参数：
username - 为其建立连接的数据库用户
password - 用户的密码
返回：
到数据源的连接
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PooledConnection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 PooledConnection

所有已知子接口：
XAConnection
public interface PooledConnection

为连接池管理提供钩子 (hook) 的对象。PooledConnection 对象表示到数据源的物理连接。该连接在应用程序使用完后可以回收而不用关闭，从而减少了需要建立连接的次数。

应用程序员不直接使用 PooledConnection 接口，而是通过一个管理连接池的中间层基础设施使用。

当应用程序调用 DataSource.getConnection 方法时，它取回 Connection 对象。如果连接池已完成，则该 Connection 对象实际上是到 PooledConnection 对象的句柄，这是一个物理连接。

连接池管理器（通常为应用程序服务器）维护 PooledConnection 对象的池。如果在池中存在可用的 PooledConnection 对象，则连接池管理器返回作为到该物理连接的句柄的 Connection 对象。如果不存在可用的 PooledConnection 对象，则连接池管理器调用 ConnectionPoolDataSource 方法 getPoolConnection 创建新的物理连接。实现 ConnectionPoolDataSource 的 JDBC 驱动程序创建新的 PooledConnection 对象并返回一个到它的句柄。

当应用程序关闭连接时，它调用 Connection 方法 close。完成连接池时，连接池管理器将得到通知；因为它曾使用 ConnectionPool 方法 addConnectionEventListener 作为 ConnectionEventListener 对象注册它自身。连接池管理器释放到 PooledConnection 对象的句柄，并将 PooledConnection 对象返回到连接池，以便再次使用。因此，当应用程序关闭其连接时，基础物理连接会被回收而不是被关闭。

在连接池管理器调用 PooledConnection 方法 close 之前，物理连接不会被关闭。调用此方法通常是为了按顺序关闭服务器，也可能在发生了严重错误，导致连接变得不可用时调用。

连接池管理器通常也是一个语句池管理器，用于维护 PreparedStatement 对象的池。当应用程序关闭一个准备好的语句时，它调用 PreparedStatement 方法 close。 当完成 Statement 池操作时，该池管理器获得通知，因为它本身已使用 ConnectionPool 方法 addStatementEventListener 作为 StatementEventListener 对象注册。 因此，当应用程序关闭其 PreparedStatement 时，底层准备好的语句会被回收而不是被关闭。

从以下版本开始：
1.4

方法摘要
void | addConnectionEventListener(ConnectionEventListener listener) 注册给定的事件侦听器，以便在此 PooledConnection 对象上发生事件时它将得到通知。
void | addStatementEventListener(StatementEventListener listener) 向此 PooledConnection 对象注册一个 StatementEventListener。
void | close() 关闭此 PooledConnection 对象表示的物理连接。
Connection | getConnection() 创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。
void | removeConnectionEventListener(ConnectionEventListener listener) 从在此 PooledConnection 对象上发生事件时得到通知的组件所组成的列表中移除给定的事件侦听器。
void | removeStatementEventListener(StatementEventListener listener) 从一个组件列表中移除指定的 StatementEventListener，该列表由驱动程序检测到 PreparedStatement 已关闭或无效时将获得通知的组件组成。

方法详细信息

getConnection

Connection getConnection()
                         throws SQLException
创建并返回一个 Connection 对象，它是此 PooledConnection 对象表示的物理连接的句柄。当应用程序已经调用 DataSource.getConnection 方法但不存在可用的 PooledConnection 对象时，连接池管理器将调用此方法。有关更多信息，请参阅接口描述。

返回：
一个 Connection 对象，它是到此 PooledConnection 对象的句柄
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

close

void close()
           throws SQLException
关闭此 PooledConnection 对象表示的物理连接。应用程序永远不会直接调用此方法；它由连接池模块或管理器调用。

有关更多信息，请参阅接口描述。

抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

addConnectionEventListener

void addConnectionEventListener(ConnectionEventListener listener)
注册给定的事件侦听器，以便在此 PooledConnection 对象上发生事件时它将得到通知。

参数：
listener - 一个组件（通常为连接池管理器），它实现了 ConnectionEventListener 接口，并在关闭连接或发生错误时应得到通知
另请参见：
removeConnectionEventListener(javax.sql.ConnectionEventListener)

removeConnectionEventListener

void removeConnectionEventListener(ConnectionEventListener listener)
从在此 PooledConnection 对象上发生事件时得到通知的组件所组成的列表中移除给定的事件侦听器。

参数：
listener - 一个组件（通常为连接池管理器），它实现了 ConnectionEventListener 接口，并已作为侦听器向此 PooledConnection 对象注册
另请参见：
addConnectionEventListener(javax.sql.ConnectionEventListener)

addStatementEventListener

void addStatementEventListener(StatementEventListener listener)
向此 PooledConnection 对象注册一个 StatementEventListener。该连接创建的 PreparedStatement 关闭或检测为无效时希望获得通知的组件可以使用此方法向此 PooledConnection 对象注册一个 StatementEventListener。

参数：
listener - 实现将向此 PooledConnection 对象注册的 StatementEventListener 接口的组件

从以下版本开始：
1.6

removeStatementEventListener

void removeStatementEventListener(StatementEventListener listener)
从一个组件列表中移除指定的 StatementEventListener，该列表由驱动程序检测到 PreparedStatement 已关闭或无效时将获得通知的组件组成。

参数：
listener - 实现以前向此 PooledConnection 对象注册的 StatementEventListener 接口的组件

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 RowSet

所有超级接口：
ResultSet, Wrapper
所有已知子接口：
CachedRowSet, FilteredRowSet, JdbcRowSet, JoinRowSet, SyncResolver, WebRowSet
public interface RowSet
extends ResultSet

该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。rowset 可用作可视化 Bean 开发环境中的 JavaBeans 组件，它可以在设计时创建和配置并在运行时执行。

RowSet 接口提供一组 JavaBeans 属性，这些属性允许配置一个 RowSet 实例来连接 JDBC 数据源并从中读取某些数据。一组设置方法（setInt、setBytes、setString 等等）提供将输入参数传递到 rowset 命令属性的方式。在一般情况下，此命令是 rowset 从关系数据库获取其数据时所使用的 SQL 查询。

RowSet 接口支持 JavaBeans 事件，允许应用程序中的其他组件在 rowset 发生事件时（如值的更改）得到通知。

RowSet 接口是唯一的，因为需要使用其他 JDBC API 来实现它。换句话说，RowSet 实现是在 JDBC 驱动程序“顶部”执行的软件层。任何人都可以提供 RowSet 接口的实现，包括希望将 RowSet 实现作为其 JDBC 产品的一部分提供的 JDBC 驱动程序供应商。

RowSet 对象可以建立一个与数据源的连接并在其整个生命周期中维持该连接，在此情况下，该对象被称为连接的 rowset。rowset 还可以建立一个与数据源的连接，从其获取数据，然后关闭它。这种 rowset 被称为非连接 rowset。非连接 rowset 可以在断开时更改其数据，然后将这些更改发送回原始数据源，不过它必须重新建立连接才能完成此操作。

非连接 rowset 可以具有与之关联的 reader（RowSetReader 对象）和 writer（RowSetWriter 对象）。可以多种方式实现 reader 来使用数据填充 rowset，包括从非关系型数据源获取数据。也可以多种方式实现 writer 来将对 rowset 的数据所做的更改传回底层数据源。

Rowset 易于使用。RowSet 接口扩展了标准 java.sql.ResultSet 接口。RowSetMetaData 接口扩展了 java.sql.ResultSetMetaData 接口。因此，熟悉 JDBC API 的开发人员必须学习少数几个新 API 才能使用 rowset。此外，与 JDBC ResultSet 对象配套使用的第三方软件工具也可以方便地用于 rowset。

从以下版本开始：
1.4

字段摘要
从接口 java.sql.ResultSet 继承的字段
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
方法摘要
void | addRowSetListener(RowSetListener listener) 注册给定侦听器，以便此 RowSet 对象上发生事件时将得到通知。
void | clearParameters() 清除为此 RowSet 对象命令设置的参数。
void | execute() 使用数据填充此 RowSet 对象。
String | getCommand() 获取此 RowSet 对象的命令属性。
String | getDataSourceName() 获取标识此 RowSet 对象的数据源的逻辑名称。
boolean | getEscapeProcessing() 获取是否为此 RowSet 对象启用转义处理。
int | getMaxFieldSize() 获取可以对某些列值返回的最大字节数。
int | getMaxRows() 获取此 RowSet 对象可以包含的最大行数。
String | getPassword() 获取用于创建数据库连接的密码。
int | getQueryTimeout() 获取驱动程序等待语句执行的最大秒数。
int | getTransactionIsolation() 获取为此 RowSet 对象设置的事务隔离级别。
Map<String,Class<?>> | getTypeMap() 获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。
String | getUrl() 如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。
String | getUsername() 获取用于创建此 RowSet 对象的数据库连接的用户名。
boolean | isReadOnly() 获取此 RowSet 对象是否是只读的。
void | removeRowSetListener(RowSetListener listener) 从在此 RowSet 对象上发生事件时得到通知的组件所组成的列表中移除指定的侦听器。
void | setArray(int i, Array x) 使用给定 Array 值设置此 RowSet 对象命令中的指定参数。
void | setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | setAsciiStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | setBigDecimal(int parameterIndex, BigDecimal x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。
void | setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。
void | setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | setBinaryStream(int parameterIndex, InputStream x, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。
void | setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有给定字节数。
void | setBlob(int i, Blob x) 使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。
void | setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。
void | setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | setBoolean(int parameterIndex, boolean x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java boolean 值。
void | setBoolean(String parameterName, boolean x) 将指定参数设置为给定的 Java boolean 值。
void | setByte(int parameterIndex, byte x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值。
void | setByte(String parameterName, byte x) 将指定参数设置为给定的 Java byte 值。
void | setBytes(int parameterIndex, byte[] x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值数组。
void | setBytes(String parameterName, byte[] x) 将指定参数设置为给定的 Java byte 数组。
void | setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。
void | setCharacterStream(int parameterIndex, Reader reader, int length) 将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。
void | setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。
void | setClob(int i, Clob x) 使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。
void | setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。
void | setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setCommand(String cmd) 将此 RowSet 对象的命令属性设置为给定的 SQL 查询。
void | setConcurrency(int concurrency) 将此 RowSet 对象的并发性设置为给定的并发级别。
void | setDataSourceName(String name) 将此 RowSet 对象的数据源名称属性设置为给定的 String。
void | setDate(int parameterIndex, Date x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。
void | setDate(int parameterIndex, Date x, Calendar cal) 使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。
void | setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | setDouble(int parameterIndex, double x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java double 值。
void | setDouble(String parameterName, double x) 将指定参数设置为给定的 Java double 值。
void | setEscapeProcessing(boolean enable) 将此 RowSet 对象的转义处理设置为开或关。
void | setFloat(int parameterIndex, float x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java float 值。
void | setFloat(String parameterName, float x) 将指定参数设置为给定的 Java float 值。
void | setInt(int parameterIndex, int x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java int 值。
void | setInt(String parameterName, int x) 将指定参数设置为给定的 Java int 值。
void | setLong(int parameterIndex, long x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java long 值。
void | setLong(String parameterName, long x) 将指定参数设置为给定的 Java long 值。
void | setMaxFieldSize(int max) 将可以对列值返回的最大字节数设置为给定的字节数。
void | setMaxRows(int max) 将此 RowSet 对象可以包含的最大行数设置为指定数。
void | setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setNString(int parameterIndex, String value) 将指定参数设置为给定的 String 对象。
void | setNString(String parameterName, String value) 将指定参数设置为给定的 String 对象。
void | setNull(int parameterIndex, int sqlType) 将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
void | setNull(int paramIndex, int sqlType, String typeName) 将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。
void | setNull(String parameterName, int sqlType) 将指定参数设置为 SQL NULL。
void | setNull(String parameterName, int sqlType, String typeName) 将指定参数设置为 SQL NULL。
void | setObject(int parameterIndex, Object x) 使用 Java Object 设置此 RowSet 对象命令中的指定参数。
void | setObject(int parameterIndex, Object x, int targetSqlType) 使用 Java Object 设置此 RowSet 对象命令中的指定参数。
void | setObject(int parameterIndex, Object x, int targetSqlType, int scaleOrLength) 使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。
void | setObject(String parameterName, Object x) 使用给定对象设置指定参数的值。
void | setObject(String parameterName, Object x, int targetSqlType) 使用给定对象设置指定参数的值。
void | setObject(String parameterName, Object x, int targetSqlType, int scale) 使用给定对象设置指定参数的值。
void | setPassword(String password) 将此 RowSet 对象的数据库密码设置为给定的 String。
void | setQueryTimeout(int seconds) 将驱动程序等待语句执行的最大秒数设置为给定的秒数。
void | setReadOnly(boolean value) 将此 RowSet 对象的只读性设置为给定的 boolean 值。
void | setRef(int i, Ref x) 使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。
void | setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | setShort(int parameterIndex, short x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java short 值。
void | setShort(String parameterName, short x) 将指定参数设置为给定的 Java short 值。
void | setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。
void | setString(int parameterIndex, String x) 将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。
void | setString(String parameterName, String x) 将指定参数设置为给定的 Java String 值。
void | setTime(int parameterIndex, Time x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。
void | setTime(int parameterIndex, Time x, Calendar cal) 使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。
void | setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | setTimestamp(int parameterIndex, Timestamp x) 将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。
void | setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。
void | setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
void | setTransactionIsolation(int level) 设置此 RowSet 对象的事务隔离级别。
void | setType(int type) 将此 RowSet 对象的类型设置为给定的类型。
void | setTypeMap(Map<String,Class<?>> map) 将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。
void | setURL(int parameterIndex, URL x) 将指定参数设置为给定的 java.net.URL 值。
void | setUrl(String url) 设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。
void | setUsername(String name) 将此 RowSet 对象的用户名属性设置为给定的 String。
从接口 java.sql.ResultSet 继承的方法
absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

方法详细信息

getUrl

String getUrl()
              throws SQLException
如果此 RowSet 对象使用 DriverManager 而非 DataSource 对象建立连接，则获取创建连接时将使用的 url 属性。默认值为 null。

返回：
字符串 url
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
setUrl(java.lang.String)

setUrl

void setUrl(String url)
            throws SQLException
设置此 RowSet 对象在使用 DriverManager 创建连接时将使用的 URL。 设置此属性是可选的。如果使用 URL，则在使用 rowset 连接到数据库之前，必须加载接受 URL 的 JDBC 驱动程序。在读取或写入数据时，rowset 将在内部使用 URL 创建数据库连接。创建连接时可能使用 URL，也可能使用数据源名称，具体取决于最近一次设置为非 null 值的是哪一个。

参数：
url - 字符串值；可以为 null
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getUrl()

getDataSourceName

String getDataSourceName()
获取标识此 RowSet 对象的数据源的逻辑名称。

返回：
数据源名称
另请参见：
setDataSourceName(java.lang.String), setUrl(java.lang.String)

setDataSourceName

void setDataSourceName(String name)
                       throws SQLException
将此 RowSet 对象的数据源名称属性设置为给定的 String。

可以使用数据源名称属性的值来查找已经在命名服务中注册的 DataSource 对象。完成检索后，可以使用 DataSource 对象创建到它所表示的数据源的连接。

参数：
name - 此 RowSet 对象数据源的逻辑名称；可以为 null
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getDataSourceName()

getUsername

String getUsername()
获取用于创建此 RowSet 对象的数据库连接的用户名。用户名属性是在调用 execute 方法前在运行时设置的。它通常不是 RowSet 对象的序列化状态的一部分。

返回：
用户名属性
另请参见：
setUsername(java.lang.String)

setUsername

void setUsername(String name)
                 throws SQLException
将此 RowSet 对象的用户名属性设置为给定的 String。

参数：
name - 用户名
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getUsername()

getPassword

String getPassword()
获取用于创建数据库连接的密码。密码属性是在调用 execute 方法前在运行时设置的。它通常不是 RowSet 对象的序列化状态的一部分。

返回：
用于创建数据库连接的密码
另请参见：
setPassword(java.lang.String)

setPassword

void setPassword(String password)
                 throws SQLException
将此 RowSet 对象的数据库密码设置为给定的 String。

参数：
password - 密码字符串
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getPassword()

getTransactionIsolation

int getTransactionIsolation()
获取为此 RowSet 对象设置的事务隔离级别。

返回：
事务隔离级别；Connection.TRANSACTION_READ_UNCOMMITTED、Connection.TRANSACTION_READ_COMMITTED、Connection.TRANSACTION_REPEATABLE_READ 或 Connection.TRANSACTION_SERIALIZABLE 之一
另请参见：
setTransactionIsolation(int)

setTransactionIsolation

void setTransactionIsolation(int level)
                             throws SQLException
设置此 RowSet 对象的事务隔离级别。

参数：
level - 事务隔离级别；Connection.TRANSACTION_READ_UNCOMMITTED、Connection.TRANSACTION_READ_COMMITTED、Connection.TRANSACTION_REPEATABLE_READ 或 Connection.TRANSACTION_SERIALIZABLE 之一
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getTransactionIsolation()

getTypeMap

Map<String,Class<?>> getTypeMap()
                                throws SQLException
获取与此 RowSet 对象关联的 Map 对象，该对象指定 SQL 用户定义类型的自定义映射关系（如果有）。默认类型映射为空。

返回：
一个 java.util.Map 对象，该对象包含 SQL 用户定义类型的名称及其映射到的 Java 类
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
setTypeMap(java.util.Map>)

setTypeMap

void setTypeMap(Map<String,Class<?>> map)
                throws SQLException
将给定 java.util.Map 对象安装为此 RowSet 对象的默认类型映射表。在通过方法参数提供另一个类型映射表之前，将一直使用此类型映射表。

参数：
map - 一个 java.util.Map 对象，该对象包含 SQL 用户定义类型的名称及其映射到的 Java 类
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getTypeMap()

getCommand

String getCommand()
获取此 RowSet 对象的命令属性。 命令属性包含命令字符串，该字符串必须为 SQL 查询，执行该查询可以使用数据填充 rowset。默认值为 null。

返回：
命令字符串；可以为 null
另请参见：
setCommand(java.lang.String)

setCommand

void setCommand(String cmd)
                throws SQLException
将此 RowSet 对象的命令属性设置为给定的 SQL 查询。 当 rowset 从不支持命令的数据源（如电子表格）获取数据时，此属性是可选的。

参数：
cmd - 将用于为此 RowSet 对象获取数据的 SQL 查询；可以为 null
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getCommand()

isReadOnly

boolean isReadOnly()
获取此 RowSet 对象是否是只读的。如果能够进行更新，则默认 rowset 为可更新。

试图更新只读 rowset 将导致抛出 SQLException。

返回：
如果此 RowSet 对象是只读的，则返回 true；如果它是可更新的，则返回 false
另请参见：
setReadOnly(boolean)

setReadOnly

void setReadOnly(boolean value)
                 throws SQLException
将此 RowSet 对象的只读性设置为给定的 boolean 值。

参数：
value - 如果只读，则该值为 true；如果可更新，则为 false
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
isReadOnly()

getMaxFieldSize

int getMaxFieldSize()
                    throws SQLException
获取可以对某些列值返回的最大字节数。此限制仅应用于 BINARY、VARBINARY、LONGVARBINARYBINARY、CHAR、VARCHAR、LONGVARCHAR、NCHAR 和 NVARCHAR 列。如果超过了该限制，则默认丢弃多出的数据。

返回：
当前最大列大小限制；零表示不存在任何限制
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
setMaxFieldSize(int)

setMaxFieldSize

void setMaxFieldSize(int max)
                     throws SQLException
将可以对列值返回的最大字节数设置为给定的字节数。此限制仅应用于 BINARY、VARBINARY、LONGVARBINARYBINARY、CHAR、VARCHAR、LONGVARCHAR、NCHAR 和 NVARCHAR 列。如果超过了该限制，则默认丢弃多出的数据。为了获得最大的可移植性，应该使用大于 256 的值。

参数：
max - 以字节为单位的新最大列大小限制；零表示没有任何限制
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getMaxFieldSize()

getMaxRows

int getMaxRows()
               throws SQLException
获取此 RowSet 对象可以包含的最大行数。如果超过了该限制，则正常撤消多出的行。

返回：
此 RowSet 对象可以包含的当前最大行数；零表示不存在任何限制
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
setMaxRows(int)

setMaxRows

void setMaxRows(int max)
                throws SQLException
将此 RowSet 对象可以包含的最大行数设置为指定数。如果超过了该限制，则正常撤消多出的行。

参数：
max - 新最大行数；零表示没有任何限制
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getMaxRows()

getEscapeProcessing

boolean getEscapeProcessing()
                            throws SQLException
获取是否为此 RowSet 对象启用转义处理。如果启用转义扫描（默认值），则驱动程序在将 SQL 语句发送到数据库之前将执行转义替换。

返回：
如果启用转义处理，则返回 true；如果禁用，则返回 false
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
setEscapeProcessing(boolean)

setEscapeProcessing

void setEscapeProcessing(boolean enable)
                         throws SQLException
将此 RowSet 对象的转义处理设置为开或关。如果转义扫描为开启（默认值），则驱动程序在将 SQL 语句发送到数据库之前将执行转义替换。

参数：
enable - 为 true 表示启用转义处理；为 false 表示禁用转义处理
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getEscapeProcessing()

getQueryTimeout

int getQueryTimeout()
                    throws SQLException
获取驱动程序等待语句执行的最大秒数。如果超过此限制，则抛出 SQLException。

返回：
以秒为单位的当前查询超时限制；零表示不存在任何限制
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
setQueryTimeout(int)

setQueryTimeout

void setQueryTimeout(int seconds)
                     throws SQLException
将驱动程序等待语句执行的最大秒数设置为给定的秒数。如果超过此限制，则抛出 SQLException。

参数：
seconds - 以秒为单位的新查询超时限制；零表示不存在任何限制
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
getQueryTimeout()

setType

void setType(int type)
             throws SQLException
将此 RowSet 对象的类型设置为给定的类型。此方法用于更改 rowset 的类型，默认情况下该类型为只读且不可滚动。

参数：
type - 以下指定类型的 ResultSet 常量之一：ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
ResultSet.getType()

setConcurrency

void setConcurrency(int concurrency)
                    throws SQLException
将此 RowSet 对象的并发性设置为给定的并发级别。此方法用于更改 rowset 的并发级别，默认情况下为 ResultSet.CONCUR_READ_ONLY。

参数：
concurrency - 以下指定并发级别的 ResultSet 常量之一：ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
ResultSet.getConcurrency()

setNull

void setNull(int parameterIndex,
             int sqlType)
             throws SQLException
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。

注： 必须指定参数的 SQL 类型。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
sqlType - 由 java.sql.Types 定义的 SQL 类型代码
抛出：
SQLException - 如果发生数据库访问错误

setNull

void setNull(String parameterName,
             int sqlType)
             throws SQLException
将指定参数设置为 SQL NULL。

注： 必须指定该参数的 SQL 类型。

参数：
parameterName - 参数的名称
sqlType - java.sql.Types 中定义的 SQL 类型代码
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setNull

void setNull(int paramIndex,
             int sqlType,
             String typeName)
             throws SQLException
将此 RowSet 对象的 SQL 命令中的指定参数设置为 SQL NULL。这种 setNull 方法应该用于 SQL 用户定义的类型 (UDT) 和 REF 类型参数。UDT 的例子包括：STRUCT、DISTINCT、JAVA_OBJECT 和指定数组类型。

注： 为了便于移植，在指定 NULL UDT 或 REF 参数时，应用程序必须提供 SQL 类型代码和全限定 SQL 类型名称。对于 UDT 参数，名称是参数本身的类型名称。对于 REF 参数，名称是所引用类型的类型名称。如果 JDBC 驱动程序不需要类型代码或类型名称信息，那么它可以忽略此信息。 尽管此方法适合 UDT 和 REF 参数使用，但可以使用此方法来设置任意 JDBC 类型的 null 参数。如果该参数没有用户定义的类型或 REF 类型，则忽略 typeName 参数。

参数：
paramIndex - 第一个参数是 1，第二个参数是 2 ……
sqlType - 取自 java.sql.Types 的值
typeName - SQL UDT 的完全限定名或 REF 类型引用的 SQL 结构化类型的名称；如果不是 UDT 或 REF 类型，则忽略该参数
抛出：
SQLException - 如果发生数据库访问错误

setNull

void setNull(String parameterName,
             int sqlType,
             String typeName)
             throws SQLException
将指定参数设置为 SQL NULL。这种 setNull 方法应该用于用户定义类型和 REF 类型参数。用户定义类型的示例有：STRUCT、DISTINCT、JAVA_OBJECT 和指定数组类型。

注： 为了便于移植，在指定 NULL 用户定义参数或 REF 参数时，应用程序必须提供 SQL 类型代码和完全限定的 SQL 类型名称。 在用户定义类型的情况下，名称是参数本身的类型名称。对于 REF 参数，名称是所引用类型的类型名称。如果 JDBC 驱动程序不需要类型代码或类型名称信息，那么它可以忽略这些信息。 尽管此方法供用户定义参数和 Ref 参数使用，但也可以使用它设置任何 JDBC 类型的 null 参数。如果该参数不具有用户定义类型或 REF 类型，则忽略给定 typeName。

参数：
parameterName - 参数的名称
sqlType - 取自 java.sql.Types 的值
typeName - SQL 用户定义类型的完全限定名称；如果该参数不是用户定义类型或 SQL REF 值，则忽略它
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setBoolean

void setBoolean(int parameterIndex,
                boolean x)
                throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java boolean 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL BIT 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setBoolean

void setBoolean(String parameterName,
                boolean x)
                throws SQLException
将指定参数设置为给定的 Java boolean 值。在将此值发送到数据库时，驱动程序将其转换为 SQL BIT 或 BOOLEAN 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getBoolean(int)

setByte

void setByte(int parameterIndex,
             byte x)
             throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL TINYINT 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setByte

void setByte(String parameterName,
             byte x)
             throws SQLException
将指定参数设置为给定的 Java byte 值。在将此值发送到数据库时，驱动程序将其转换为 SQL TINYINT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getByte(int)

setShort

void setShort(int parameterIndex,
              short x)
              throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java short 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL SMALLINT 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setShort

void setShort(String parameterName,
              short x)
              throws SQLException
将指定参数设置为给定的 Java short 值。在将此值发送到数据库时，驱动程序将其转换为 SQL SMALLINT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getShort(int)

setInt

void setInt(int parameterIndex,
            int x)
            throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java int 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL INTEGER 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setInt

void setInt(String parameterName,
            int x)
            throws SQLException
将指定参数设置为给定的 Java int 值。在将此值发送到数据库时，驱动程序将其转换为 SQL INTEGER 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getInt(int)

setLong

void setLong(int parameterIndex,
             long x)
             throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java long 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL BIGINT 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setLong

void setLong(String parameterName,
             long x)
             throws SQLException
将指定参数设置为给定的 Java long 值。在将此值发送到数据库时，驱动程序将其转换为 SQL BIGINT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getLong(int)

setFloat

void setFloat(int parameterIndex,
              float x)
              throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java float 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL REAL 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setFloat

void setFloat(String parameterName,
              float x)
              throws SQLException
将指定参数设置为给定的 Java float 值。在将此值发送到数据库时，驱动程序将其转换为 SQL FLOAT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getFloat(int)

setDouble

void setDouble(int parameterIndex,
               double x)
               throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java double 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL DOUBLE 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setDouble

void setDouble(String parameterName,
               double x)
               throws SQLException
将指定参数设置为给定的 Java double 值。在将此值发送到数据库时，驱动程序将其转换为 SQL DOUBLE 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getDouble(int)

setBigDecimal

void setBigDecimal(int parameterIndex,
                   BigDecimal x)
                   throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 java.math.BigDeciaml 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL NUMERIC 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setBigDecimal

void setBigDecimal(String parameterName,
                   BigDecimal x)
                   throws SQLException
将指定参数设置为给定的 java.math.BigDecimal 值。在将此值发送到数据库时，驱动程序将其转换为 SQL NUMERIC 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getBigDecimal(int, int)

setString

void setString(int parameterIndex,
               String x)
               throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java String 值。在将此值发送给数据库之前，驱动程序将其转换为 SQL VARCHAR 或 LONGVARCHAR 值，具体取决于该参数相对于驱动程序在 VARCHAR 值上的限制的大小。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setString

void setString(String parameterName,
               String x)
               throws SQLException
将指定参数设置为给定的 Java String 值。在将此值发送到数据库时，驱动程序将其转换为 SQL VARCHAR 或 LONGVARCHAR 值（具体取决于该参数相对于驱动程序在 VARCHAR 值上的限制的大小）。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getString(int)

setBytes

void setBytes(int parameterIndex,
              byte[] x)
              throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Java byte 值数组。在将此值发送给数据库之前，驱动程序将其转换为 SQL VARBINARY 或 LONGVARBINARY 值，具体取决于该参数相对于驱动程序在 VARBINARY 值上的限制的大小。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setBytes

void setBytes(String parameterName,
              byte[] x)
              throws SQLException
将指定参数设置为给定的 Java byte 数组。在将此值发送到数据库时，驱动程序将其转换为 SQL VARBINARY 或 LONGVARBINARY 值（具体取决于该参数相对于驱动程序在 VARBINARY 值上的限制的大小）。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getBytes(int)

setDate

void setDate(int parameterIndex,
             Date x)
             throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Date 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL DATE 值，使用默认的 java.util.Calendar 来计算日期。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setTime

void setTime(int parameterIndex,
             Time x)
             throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Time 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL TIME 值，使用默认的 java.util.Calendar 来计算该值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setTimestamp

void setTimestamp(int parameterIndex,
                  Timestamp x)
                  throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 java.sql.Timestamp 值。在将此值发送到数据库之前，驱动程序将其转换为 SQL TIMESTAMP 值，使用默认的 java.util.Calendar 来计算该值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误

setTimestamp

void setTimestamp(String parameterName,
                  Timestamp x)
                  throws SQLException
将指定参数设置为给定的 java.sql.Timestamp 值。在将此值发送到数据库时，驱动程序将其转换为 SQL TIMESTAMP 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getTimestamp(int)

setAsciiStream

void setAsciiStream(int parameterIndex,
                    InputStream x,
                    int length)
                    throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。更实际的做法是，通过 java.io.InputStream 而不是 LONGVARCHAR 参数来发送很大的 ASCII 值。在到达文件末尾之前，驱动程序将根据需要从该流读取数据。

注：此流对象既可以是一个标准 Java 流对象，也可以是用户定义的实现标准接口的子类。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果发生数据库访问错误

setAsciiStream

void setAsciiStream(String parameterName,
                    InputStream x,
                    int length)
                    throws SQLException
将指定参数设置为给定输入流，该输入流将拥有指定字节数。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。 JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数的名称
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setBinaryStream

void setBinaryStream(int parameterIndex,
                     InputStream x,
                     int length)
                     throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.InputStream 值。更实际的做法是，通过 java.io.InputStream 而不是 LONGVARBINARY 参数来发送很大的二进制值。在到达文件末尾之前，驱动程序将根据需要从该流读取数据。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含二进制参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果发生数据库访问错误

setBinaryStream

void setBinaryStream(String parameterName,
                     InputStream x,
                     int length)
                     throws SQLException
将指定参数设置为给定输入流，该输入流将拥有给定字节数。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数的名称
x - 包含二进制参数值的 java 输入流
length - 流中的字节数
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setCharacterStream

void setCharacterStream(int parameterIndex,
                        Reader reader,
                        int length)
                        throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 java.io.Reader 值。更实际的做法是，通过 java.io.Reader 而不是 LONGVARCHAR 参数来发送很大的 UNICODE 值。在到达文件末尾之前，驱动程序将根据需要从该流读取数据。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含要设置的 UNICODE 数据的 Reader 对象
length - 流中的字符数
抛出：
SQLException - 如果发生数据库访问错误

setCharacterStream

void setCharacterStream(String parameterName,
                        Reader reader,
                        int length)
                        throws SQLException
将指定参数设置为给定 Reader 对象，该对象是给定的字符长度数目。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。 JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数的名称
reader - 包含用作指定参数的 UNICODE 数据的 java.io.Reader 对象
length - 流中的字符数
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setAsciiStream

void setAsciiStream(int parameterIndex,
                    InputStream x)
                    throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定输入流。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。 JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带长度参数的 setAsciiStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含 ASCII 参数值的 Java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setAsciiStream

void setAsciiStream(String parameterName,
                    InputStream x)
                    throws SQLException
将指定参数设置为给定输入流。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setAsciiStream 是否更有效。

参数：
parameterName - 参数的名称
x - 包含 ASCII 参数值的 Java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

void setBinaryStream(int parameterIndex,
                     InputStream x)
                     throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定输入流。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBinaryStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含二进制参数值的 Java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

void setBinaryStream(String parameterName,
                     InputStream x)
                     throws SQLException
将指定参数设置为给定输入流。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBinaryStream 是否更有效。

参数：
parameterName - 参数的名称
x - 包含二进制参数值的 Java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setCharacterStream

void setCharacterStream(int parameterIndex,
                        Reader reader)
                        throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定 Reader 对象。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。 JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setCharacterStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含 Unicode 数据的 java.io.Reader 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setCharacterStream

void setCharacterStream(String parameterName,
                        Reader reader)
                        throws SQLException
将指定参数设置为给定 Reader 对象。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setCharacterStream 是否更有效。

参数：
parameterName - 参数的名称
reader - 包含 Unicode 数据的 java.io.Reader 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(int parameterIndex,
                         Reader value)
                         throws SQLException
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集 (national character set) 的必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNCharacterStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误；如果在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setObject

void setObject(int parameterIndex,
               Object x,
               int targetSqlType,
               int scaleOrLength)
               throws SQLException
使用给定 Java Object 设置此 RowSet 对象命令中的指定参数。对于整数值，应该使用 java.lang 等效对象（例如，对于 int，应使用 Integer 类的实例）。 如果第二个参数是 InputStream，则该流必须包含 scaleOrLength 所指定的字节数。如果第二个参数是 Reader，则该 reader 必须包含 scaleOrLength 所指定的字符数。如果这些条件都不为 true，则驱动程序在执行准备好的语句时将会生成 SQLException。

在发送到数据库之前，给定 Java 对象将被转换为 targetSqlType。

如果对象是实现 SQLData 的类，则 rowset 应该调用 SQLData.writeSQL 方法将对象写入 SQLOutput 数据流中。另一方面，如果对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将其作为相应 SQL 类型的值传递给数据库。

注意，此方法可用于传递特定于数据库的抽象数据类型。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（定义于 java.sql.Types 中）。scale 参数可以进一步限定此类型。
scaleOrLength - 对于 java.sql.Types.DECIMAL 或 java.sql.Types.NUMERIC 类型，该值是小数点后的位数。对于 Java Object 类型 InputStream 和 Reader，该值是流或 reader 中数据的长度。对于所有其他类型，将忽略此值。
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Types

setObject

void setObject(String parameterName,
               Object x,
               int targetSqlType,
               int scale)
               throws SQLException
使用给定对象设置指定参数的值。第二个参数必须是一个对象类型；对于整数值，应该使用 java.lang 的等效对象。

在发送到数据库之前，给定 Java 对象将被转换为给定的 targetSqlType。 如果对象具有自定义映射关系（属于实现 SQLData 接口的类），则 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流中。另一方面，如果对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将其作为相应 SQL 类型的值传递给数据库。

注意，此方法可用于传递特定于数据库的抽象数据类型。

参数：
parameterName - 参数的名称
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（在 java.sql.Types 中定义）。scale 参数可以进一步限定此类型。
scale - 对于 java.sql.Types.DECIMAL 或 java.sql.Types.NUMERIC 类型，该值是小数点后的位数。对于所有其他类型，将忽略此值。
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.4
另请参见：
Types, ResultSet.getObject(int)

setObject

void setObject(int parameterIndex,
               Object x,
               int targetSqlType)
               throws SQLException
使用 Java Object 设置此 RowSet 对象命令中的指定参数。对于整数值，应该使用 java.lang 等效对象。此方法与上述 setObject 类似，但使用的 scale 是第二个参数的 scale。标量值的 scale 为零。字面值的 scale 存在于字面中。

尽管支持浮点型输入值，但不建立使用该类型值调用此方法。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（定义于 java.sql.Types 中）
抛出：
SQLException - 如果发生数据库访问错误

setObject

void setObject(String parameterName,
               Object x,
               int targetSqlType)
               throws SQLException
使用给定对象设置指定参数的值。此方法类似于上面的 setObject 方法，不同之处在于它假定 scale 为 0。

参数：
parameterName - 参数的名称
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（在 java.sql.Types 中定义）
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.4
另请参见：
ResultSet.getObject(int)

setObject

void setObject(String parameterName,
               Object x)
               throws SQLException
使用给定对象设置指定参数的值。第二个参数必须是 Object 类型；所以，应该对内置类型使用 java.lang 的等效对象。

JDBC 规范指定一个从 Java Object 类型到 SQL 类型的标准映射关系。在发送到数据库之前，给定参数将被转换为相应的 SQL 类型。

注意，通过使用特定于驱动程序的 Java 类型，此方法可用于传递特定于数据库的抽象数据类型。 如果对象是实现 SQLData 接口的类，则 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流中。另一方面，如果对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将其作为相应 SQL 类型的值传递给数据库。

如果出现混淆，例如该对象是实现多个上述指定接口的类，则此方法抛出异常。

参数：
parameterName - 参数的名称
x - 包含输入参数值的对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 CallableStatement 上调用此方法或者给定 Object 参数不明确
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getObject(int)

setObject

void setObject(int parameterIndex,
               Object x)
               throws SQLException
使用 Java Object 设置此 RowSet 对象命令中的指定参数。对于整数值，应该使用 java.lang 等效对象。

JDBC 规范提供了一个从 Java Object 类型到 SQL 类型的标准映射关系。在将给定 Java 对象发送到数据库之前，驱动程序将其转换为其标准的 SQL 映射关系。

注意，通过使用特定于驱动程序的 Java 类型，此方法可用于传递特定于数据库的抽象数据类型。 如果对象是实现 SQLData 的类，则 rowset 应该调用 SQLData.writeSQL 方法将对象写入 SQLOutput 数据流中。另一方面，如果对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将其作为相应 SQL 类型的值传递给数据库。

如果出现混淆，例如如果该对象是实现多个这些接口的类，则抛出异常。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含输入参数值的对象
抛出：
SQLException - 如果发生数据库访问错误

setRef

void setRef(int i,
            Ref x)
            throws SQLException
使用给定 Ref 值设置此 RowSet 对象命令中的指定参数。驱动程序将此值转换为适当的 REF(<结构化类型>) 值。

参数：
i - 第一个参数是 1，第二个参数是 2 ……
x - 一个对象，它表示 SQL REF 类型的数据
抛出：
SQLException - 如果发生数据库访问错误

setBlob

void setBlob(int i,
             Blob x)
             throws SQLException
使用给定 Blob 值设置此 RowSet 对象命令中的指定参数。在将此值发送到数据库之前，驱动程序会将其转换为 Blob 对象表示的 BLOB 值。

参数：
i - 第一个参数是 1，第二个参数是 2 ……
x - 表示 BLOB 的对象
抛出：
SQLException - 如果发生数据库访问错误

setBlob

void setBlob(int parameterIndex,
             InputStream inputStream,
             long length)
             throws SQLException
将指定参数设置为 InputStream 对象。 inputstream 必须包含 length 所指定的字符数，否则，在执行 PreparedStatement 时将会生成 SQLException。此方法不同于 setBinaryStream (int, InputStream, int) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
inputStream - 包含用来设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果发生数据库访问错误；如果在关闭的 PreparedStatement 上调用此方法；如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0 或者 inputstream 中的字节数不匹配指定长度。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(int parameterIndex,
             InputStream inputStream)
             throws SQLException
将指定参数设置为 InputStream 对象。此方法不同于 setBinaryStream (int, InputStream) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBlob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
inputStream - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 PreparedStatement 上调用此方法或者 parameterIndex 不对应 SQL 语句中的参数标记
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(String parameterName,
             InputStream inputStream,
             long length)
             throws SQLException
将指定参数设置为 InputStream 对象。inputstream 必须包含 length 所指定的字符数，否则，在执行 CallableStatement 时将会生成 SQLException。此方法不同于 setBinaryStream (int, InputStream, int) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器。

参数：
parameterName - 要设置的参数名称
inputStream - 包含用来设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记，或者指定长度小于 0；如果 inputstream 中的字节数不匹配指定长度；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(String parameterName,
             Blob x)
             throws SQLException
将指定参数设置为给定的 java.sql.Blob 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL BLOB 值。

参数：
parameterName - 参数的名称
x - 映射 SQL BLOB 值的 Blob 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

void setBlob(String parameterName,
             InputStream inputStream)
             throws SQLException
将指定参数设置为 InputStream 对象。此方法不同于 setBinaryStream (int, InputStream) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBlob 是否更有效。

参数：
parameterName - 参数的名称
inputStream - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(int i,
             Clob x)
             throws SQLException
使用给定 Clob 值设置此 RowSet 对象命令中的指定参数。在将此值发送到数据库之前，驱动程序会将其转换为 Clob 对象表示的 CLOB 值。

参数：
i - 第一个参数是 1，第二个参数是 2 ……
x - 表示 CLOB 的对象
抛出：
SQLException - 如果发生数据库访问错误

setClob

void setClob(int parameterIndex,
             Reader reader,
             long length)
             throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 PreparedStatement 时将会生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法；如果 parameterIndex 不对应 SQL 语句中的参数标记，或者指定长度小于 0。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(int parameterIndex,
             Reader reader)
             throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序该参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setClob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 PreparedStatement 上调用此方法或者 parameterIndex 不对应 SQL 语句中的参数标记
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(String parameterName,
             Reader reader,
             long length)
             throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 CallableStatement 时将会生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序该参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

参数：
parameterName - 要设置的参数的名称
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(String parameterName,
             Clob x)
             throws SQLException
将指定参数设置为给定的 java.sql.Clob 对象。将此值发送到数据库时，驱动程序将其转换为 SQL CLOB 值。

参数：
parameterName - 参数的名称
x - 映射 SQL CLOB 值的 Clob 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

void setClob(String parameterName,
             Reader reader)
             throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序该参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setClob 是否更有效。

参数：
parameterName - 参数的名称
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setArray

void setArray(int i,
              Array x)
              throws SQLException
使用给定 Array 值设置此 RowSet 对象命令中的指定参数。在将此值发送到数据库之前，驱动程序会将其转换为 Array 对象表示的 ARRAY 值。

参数：
i - 第一个参数是 1，第二个参数是 2 ……
x - 表示 SQL 数组的对象
抛出：
SQLException - 如果发生数据库访问错误

setDate

void setDate(int parameterIndex,
             Date x,
             Calendar cal)
             throws SQLException
使用给定 java.sql.Date 值设置此 RowSet 对象命令中的指定参数。驱动程序将此值转换为 SQL DATE 值，使用给定 java.util.Calendar 对象来计算日期。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
cal - 用于计算日期的 java.util.Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误

setDate

void setDate(String parameterName,
             Date x)
             throws SQLException
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。在将此值发送到数据库时，驱动程序将其转换为 SQL DATE 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getDate(int)

setDate

void setDate(String parameterName,
             Date x,
             Calendar cal)
             throws SQLException
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。驱动程序使用 Calendar 对象构造一个 SQL DATE 值，该值随后被驱动程序发送到数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算日期。如果没有指定任何 Calendar 对象，则驱动程序使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数的名称
x - 参数值
cal - 驱动程序将用来构造日期的 Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getDate(int)

setTime

void setTime(int parameterIndex,
             Time x,
             Calendar cal)
             throws SQLException
使用给定 java.sql.Time 值设置此 RowSet 对象命令中的指定参数。在将此值发送到数据库之前，驱动程序将其转换为 SQL TIME 值，使用给定 java.util.Calendar 对象来计算该值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
cal - 用于计算时间的 java.util.Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误

setTime

void setTime(String parameterName,
             Time x)
             throws SQLException
将指定参数设置为给定的 java.sql.Time 值。在将此值发送到数据库时，驱动程序将其转换为 SQL TIME 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getTime(int)

setTime

void setTime(String parameterName,
             Time x,
             Calendar cal)
             throws SQLException
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。驱动程序使用 Calendar 对象构造一个 SQL TIME 值，该值随后被驱动程序发送到数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间。如果没有指定任何 Calendar 对象，则驱动程序使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数的名称
x - 参数值
cal - 驱动程序将用来构造时间的 Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getTime(int)

setTimestamp

void setTimestamp(int parameterIndex,
                  Timestamp x,
                  Calendar cal)
                  throws SQLException
使用给定 java.sql.Timestamp 值设置此 RowSet 对象命令中的指定参数。在将此值发送到数据库之前，驱动程序将其转换为 SQL TIMESTAMP 值，使用给定 java.util.Calendar 对象来计算该值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
cal - 用于计算时间戳的 java.util.Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误

setTimestamp

void setTimestamp(String parameterName,
                  Timestamp x,
                  Calendar cal)
                  throws SQLException
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。驱动程序使用 Calendar 对象构造一个 SQL TIMESTAMP 值，该值随后被驱动程序发送到数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间戳。如果没有指定任何 Calendar 对象，则驱动程序使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数的名称
x - 参数值
cal - 驱动程序将用来构造时间戳的 Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
ResultSet.getTimestamp(int)

clearParameters

void clearParameters()
                     throws SQLException
清除为此 RowSet 对象命令设置的参数。

通常参数值对 RowSet 对象的重复使用仍然有效。设置一个参数值会自动清除其以前的值。不过，在某些情况下，直接释放当前参数值使用的资源也是很有用的；这可以通过调用 clearParameters 方法来实现。

抛出：
SQLException - 如果发生数据库访问错误

execute

void execute()
             throws SQLException
使用数据填充此 RowSet 对象。

execute 方法可以使用以下属性来创建用于读取数据的连接：url、数据源名称、用户名、密码、事务隔离和类型映射表。 execute 方法可以使用以下属性来创建执行命令的语句：命令、只读、最大字段大小、最大行数、转义处理和查询超时值。

如果没有设置必需的参数，则抛出异常。如果此方法执行成功，则丢弃 rowset 的当前内容，同时设置（或重置）rowset 的元数据。如果存在未执行的更新，则忽略它们。

如果此 RowSet 对象不维持与其数据源的连续连接，则它可以使用 reader（RowSetReader 对象）来填充数据。在此情况下，reader 应该已经在此 RowSet 对象中注册，并且 execute 方法将作为其实现的一部分调用 reader 的 readData 方法。

抛出：
SQLException - 如果发生数据库访问错误，或者没有设置建立连接和创建语句所需的任何属性

addRowSetListener

void addRowSetListener(RowSetListener listener)
注册给定侦听器，以便此 RowSet 对象上发生事件时将得到通知。

参数：
listener - 一个组件，它实现了 RowSetListener 接口并希望在此 RowSet 对象上发生事件时得到通知
另请参见：
removeRowSetListener(javax.sql.RowSetListener)

removeRowSetListener

void removeRowSetListener(RowSetListener listener)
从在此 RowSet 对象上发生事件时得到通知的组件所组成的列表中移除指定的侦听器。

参数：
listener - 一个组件，它已注册为此 RowSet 对象的侦听器
另请参见：
addRowSetListener(javax.sql.RowSetListener)

setSQLXML

void setSQLXML(int parameterIndex,
               SQLXML xmlObject)
               throws SQLException
将指定参数设置为给定 java.sql.SQLXML 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL XML 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
xmlObject - 映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的结果集上调用此方法，没有为 SQLXML 对象关闭 java.xml.transform.Result、Writer 或 OutputStream，或者在处理 XML 值时发生错误。异常的 getCause 方法可以提供更详细的异常，例如，如果该流不包含有效的 XML。
从以下版本开始：
1.6

setSQLXML

void setSQLXML(String parameterName,
               SQLXML xmlObject)
               throws SQLException
将指定参数设置为给定的 java.sql.SQLXML 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL XML 值。

参数：
parameterName - 参数的名称
xmlObject - 映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的结果集上调用此方法，没有为 SQLXML 对象关闭 java.xml.transform.Result、Writer 或 OutputStream，或者在处理 XML 值时发生错误。异常的 getCause 方法可以提供更详细的异常，例如，如果该流不包含有效的 XML。
从以下版本开始：
1.6

setRowId

void setRowId(int parameterIndex,
              RowId x)
              throws SQLException
将指定参数设置为给定的 java.sql.RowId 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL ROWID 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

setRowId

void setRowId(String parameterName,
              RowId x)
              throws SQLException
将指定参数设置为给定的 java.sql.RowId 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL ROWID。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

setNString

void setNString(int parameterIndex,
                String value)
                throws SQLException
将指定参数设置为给定的 String 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR 值（具体取决于该参数相对于驱动程序在 NVARCHAR 值上的限制的大小）。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNString

void setNString(String parameterName,
                String value)
                throws SQLException
将指定参数设置为给定的 String 对象。驱动程序将此值转换为 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR

参数：
parameterName - 要设置的列的名称
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(int parameterIndex,
                         Reader value,
                         long length)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集的必要转换。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
length - 参数数据中的字符数。
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(String parameterName,
                         Reader value,
                         long length)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集的必要转换。

参数：
parameterName - 要设置的列的名称
value - 参数值
length - 参数数据中的字符数。
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNCharacterStream

void setNCharacterStream(String parameterName,
                         Reader value)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集的必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNCharacterStream 是否更有效。

参数：
parameterName - 参数的名称
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误；或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(String parameterName,
              NClob value)
              throws SQLException
将指定参数设置为 java.sql.NClob 对象。该对象实现 java.sql.NClob 接口。此 NClob 对象映射到 SQL NCLOB。

参数：
parameterName - 要设置的列的名称
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNClob

void setNClob(String parameterName,
              Reader reader,
              long length)
              throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 CallableStatement 时将会生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序该参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器。

参数：
parameterName - 要设置的参数的名称
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(String parameterName,
              Reader reader)
              throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序该参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNClob 是否更有效。

参数：
parameterName - 参数的名称
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(int parameterIndex,
              Reader reader,
              long length)
              throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 PreparedStatement 时将会生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序该参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

void setNClob(int parameterIndex,
              NClob value)
              throws SQLException
将指定参数设置为 java.sql.NClob 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL NCLOB 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误
从以下版本开始：
1.6

setNClob

void setNClob(int parameterIndex,
              Reader reader)
              throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序该参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNClob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setURL

void setURL(int parameterIndex,
            URL x)
            throws SQLException
将指定参数设置为给定的 java.net.URL 值。在将此值发送到数据库时，驱动程序将其转换为 SQL DATALINK 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 要设置的 java.net.URL 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
类 RowSetEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.sql.RowSetEvent
所有已实现的接口：
Serializable
public class RowSetEvent
extends EventObject

RowSet 对象发生事件时生成的 Event 对象。当 rowset 的单个行被更改、整个 rowset 被更改或者 rowset 指针移动时将生成 RowSetEvent 对象。

当 RowSet 对象上发生某个事件时，RowSetListener 中的一个方法将被发送到所有已注册侦听器，以通知它们发生了该事件。将 Event 对象提供给 RowSetListener 方法，以便侦听器使用它来找出作为事件源的 RowSet 对象。

从以下版本开始：
1.4
另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
RowSetEvent(RowSet source)
构造一个 RowSetEvent 对象，并使用给定的 RowSet 对象进行初始化。
方法摘要
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RowSetEvent

public RowSetEvent(RowSet source)
构造一个 RowSetEvent 对象，并使用给定的 RowSet 对象进行初始化。

参数：
source - 数据已更改或指针已移动的 RowSet 对象
抛出：
IllegalArgumentException - 如果 source 为 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetInternal (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 RowSetInternal

public interface RowSetInternal

为了将自身呈现给 RowSetReader 或 RowSetWriter 对象的 RowSet 对象实现应实现该接口。RowSetInternal 接口包含一些允许 reader 或 writer 访问并修改 rowset 内部状态的方法。

从以下版本开始：
1.4

方法摘要
Connection | getConnection() 获取传递给此 RowSet 对象的 Connection 对象。
ResultSet | getOriginal() 获取包含此 RowSet 对象原始值的 ResultSet 对象。
ResultSet | getOriginalRow() 获取仅包含当前行原始值的 ResultSet 对象。
Object[] | getParams() 获取已为此 RowSet 对象的命令设置的参数。
void | setMetaData(RowSetMetaData md) 将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。

方法详细信息

getParams

Object[] getParams()
                   throws SQLException
获取已为此 RowSet 对象的命令设置的参数。

返回：
此 RowSet 对象的命令的当前参数值所组成的数组
抛出：
SQLException - 如果发生数据库访问错误

getConnection

Connection getConnection()
                         throws SQLException
获取传递给此 RowSet 对象的 Connection 对象。

返回：
传递给 rowset 的 Connection 对象；如果没有传递任何对象，则返回 null
抛出：
SQLException - 如果发生数据库访问错误

setMetaData

void setMetaData(RowSetMetaData md)
                 throws SQLException
将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。与 rowset 关联的 RowSetReader 对象将使用 RowSetMetaData 方法来设置那些提供关于 rowset 列信息的值。

参数：
md - 将设置的 RowSetMetaData 对象，它具有关于 rowset 列的信息。
抛出：
SQLException - 如果发生数据库访问错误

getOriginal

ResultSet getOriginal()
                      throws SQLException
获取包含此 RowSet 对象原始值的 ResultSet 对象。

将指针置于结果集的第一行之前。只有 getOriginal 方法返回的结果集所包含的行才会被认为具有原始值。

返回：
rowset 的原始值
抛出：
SQLException - 如果发生数据库访问错误

getOriginalRow

ResultSet getOriginalRow()
                         throws SQLException
获取仅包含当前行原始值的 ResultSet 对象。如果当前行不具有任何原始值，则返回空结果集。如果不存在当前行，则抛出异常。

返回：
ResultSet 对象形式的当前行的原始值
抛出：
SQLException - 如果发生数据库访问错误，或者当指针位于插入行上、第一行之前或最后一行之后时调用了此方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 RowSetListener

所有超级接口：
EventListener
public interface RowSetListener
extends EventListener

要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。通过使用 RowSet.addRowSetListener 方法在 RowSet 对象中注册，组件将变成侦听器。已注册组件实现此接口的方式决定它得到事件通知时将执行的操作。

从以下版本开始：
1.4

方法摘要
void | cursorMoved(RowSetEvent event) 通知已注册侦听器 RowSet 对象的指针已移动。
void | rowChanged(RowSetEvent event) 通知已注册侦听器 RowSet 对象的其中一行发生了更改。
void | rowSetChanged(RowSetEvent event) 通知已注册侦听器给定 RowSetEvent 对象中的 RowSet 对象已更改其全部内部。

方法详细信息

rowSetChanged

void rowSetChanged(RowSetEvent event)
通知已注册侦听器给定 RowSetEvent 对象中的 RowSet 对象已更改其全部内部。

可以使用 event.getSource 方法获取事件源。

参数：
event - 一个 RowSetEvent 对象，它包含作为事件源的 RowSet 对象

rowChanged

void rowChanged(RowSetEvent event)
通知已注册侦听器 RowSet 对象的其中一行发生了更改。

可以使用 event.getSource 方法获取事件源。

参数：
event - 一个 RowSetEvent 对象，它包含作为事件源的 RowSet 对象

cursorMoved

void cursorMoved(RowSetEvent event)
通知已注册侦听器 RowSet 对象的指针已移动。

可以使用 event.getSource 方法获取事件源。

参数：
event - 一个 RowSetEvent 对象，它包含作为事件源的 RowSet 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetMetaData (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 RowSetMetaData

所有超级接口：
ResultSetMetaData, Wrapper
所有已知实现类：
RowSetMetaDataImpl
public interface RowSetMetaData
extends ResultSetMetaData

该对象包含关于 RowSet 对象的列的信息。此接口扩展了 ResultSetMetaData 接口，它增加了一些在 RowSetMetaData 对象中设置值的方法。当 RowSetReader 对象将数据读入 RowSet 对象时，它将创建一个 RowSetMetaData 对象并使用 RowSetMetaData 接口中的方法对其进行初始化。然后，reader 将 RowSetMetaData 对象传递给 rowset。

当应用程序调用 RowSet.execute 方法时，将在内部调用此接口中的方法；应用程序员不直接使用它们。

从以下版本开始：
1.4

字段摘要
从接口 java.sql.ResultSetMetaData 继承的字段
columnNoNulls, columnNullable, columnNullableUnknown
方法摘要
void | setAutoIncrement(int columnIndex, boolean property) 设置是否为指定列自动编号。
void | setCaseSensitive(int columnIndex, boolean property) 设置指定列是否区分大小写。
void | setCatalogName(int columnIndex, String catalogName) 将指定列的表的类别名称（如果有）设置为给定的 String。
void | setColumnCount(int columnCount) 将 RowSet 对象中的列数设置为给定数。
void | setColumnDisplaySize(int columnIndex, int size) 将指定列的正常最大宽度（以 char 表示）设置为给定的 int。
void | setColumnLabel(int columnIndex, String label) 将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。
void | setColumnName(int columnIndex, String columnName) 将指定列的名称设置为给定的 String。
void | setColumnType(int columnIndex, int SQLType) 将指定列的 SQL 类型设置为给定的类型。
void | setColumnTypeName(int columnIndex, String typeName) 将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。
void | setCurrency(int columnIndex, boolean property) 设置指定的列是否是现金值。
void | setNullable(int columnIndex, int property) 设置是否可以将指定列的值设置为 NULL。
void | setPrecision(int columnIndex, int precision) 将指定列的小数位数设置为给定的 int。
void | setScale(int columnIndex, int scale) 将指定列的小数点右边的位数设置为给定的 int。
void | setSchemaName(int columnIndex, String schemaName) 将指定列的表模式的名称（如果有）设置为给定的 String。
void | setSearchable(int columnIndex, boolean property) 设置是否可以在 where 子句中使用指定的列。
void | setSigned(int columnIndex, boolean property) 设置指定列是否是有符号数字。
void | setTableName(int columnIndex, String tableName) 将指定列的表名称（如果有）设置为给定的 String。
从接口 java.sql.ResultSetMetaData 继承的方法
getCatalogName, getColumnClassName, getColumnCount, getColumnDisplaySize, getColumnLabel, getColumnName, getColumnType, getColumnTypeName, getPrecision, getScale, getSchemaName, getTableName, isAutoIncrement, isCaseSensitive, isCurrency, isDefinitelyWritable, isNullable, isReadOnly, isSearchable, isSigned, isWritable
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap

方法详细信息

setColumnCount

void setColumnCount(int columnCount)
                    throws SQLException
将 RowSet 对象中的列数设置为给定数。

参数：
columnCount - RowSet 对象中的列数
抛出：
SQLException - 如果发生数据库访问错误

setAutoIncrement

void setAutoIncrement(int columnIndex,
                      boolean property)
                      throws SQLException
设置是否为指定列自动编号。默认值是不对 RowSet 对象的列进行自动编号。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
property - 如果为列自动编号，则为 true；否则为 false
抛出：
SQLException - 如果发生数据库访问错误

setCaseSensitive

void setCaseSensitive(int columnIndex,
                      boolean property)
                      throws SQLException
设置指定列是否区分大小写。默认值为 false。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
property - 如果该列是区分大小写的，则为 true；否则为 false
抛出：
SQLException - 如果发生数据库访问错误

setSearchable

void setSearchable(int columnIndex,
                   boolean property)
                   throws SQLException
设置是否可以在 where 子句中使用指定的列。默认值为 false。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
property - 如果可以在 WHERE 子句中使用该列，则为 true；否则为 false
抛出：
SQLException - 如果发生数据库访问错误

setCurrency

void setCurrency(int columnIndex,
                 boolean property)
                 throws SQLException
设置指定的列是否是现金值。默认值为 false。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
property - 如果该列是现金值，则为 true；否则为 false
抛出：
SQLException - 如果发生数据库访问错误

setNullable

void setNullable(int columnIndex,
                 int property)
                 throws SQLException
设置是否可以将指定列的值设置为 NULL。默认值为 ResultSetMetaData.columnNullableUnknown

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
property - 以下常量之一：ResultSetMetaData.columnNoNulls、ResultSetMetaData.columnNullable 或 ResultSetMetaData.columnNullableUnknown
抛出：
SQLException - 如果发生数据库访问错误

setSigned

void setSigned(int columnIndex,
               boolean property)
               throws SQLException
设置指定列是否是有符号数字。默认值为 false。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
property - 如果该列是有符号数字，则为 true；否则为 false
抛出：
SQLException - 如果发生数据库访问错误

setColumnDisplaySize

void setColumnDisplaySize(int columnIndex,
                          int size)
                          throws SQLException
将指定列的正常最大宽度（以 char 表示）设置为给定的 int。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
size - 指定列的正常最大字符数
抛出：
SQLException - 如果发生数据库访问错误

setColumnLabel

void setColumnLabel(int columnIndex,
                    String label)
                    throws SQLException
将建议用于打印输出和显示的列标题（如果有）设置为给定的 String。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
label - 列标题
抛出：
SQLException - 如果发生数据库访问错误

setColumnName

void setColumnName(int columnIndex,
                   String columnName)
                   throws SQLException
将指定列的名称设置为给定的 String。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
columnName - 指定列的名称
抛出：
SQLException - 如果发生数据库访问错误

setSchemaName

void setSchemaName(int columnIndex,
                   String schemaName)
                   throws SQLException
将指定列的表模式的名称（如果有）设置为给定的 String。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
schemaName - 模式名
抛出：
SQLException - 如果发生数据库访问错误

setPrecision

void setPrecision(int columnIndex,
                  int precision)
                  throws SQLException
将指定列的小数位数设置为给定的 int。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
precision - 小数位的总数
抛出：
SQLException - 如果发生数据库访问错误

setScale

void setScale(int columnIndex,
              int scale)
              throws SQLException
将指定列的小数点右边的位数设置为给定的 int。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
scale - 小数点右边的位数
抛出：
SQLException - 如果发生数据库访问错误

setTableName

void setTableName(int columnIndex,
                  String tableName)
                  throws SQLException
将指定列的表名称（如果有）设置为给定的 String。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
tableName - 列的表名称
抛出：
SQLException - 如果发生数据库访问错误

setCatalogName

void setCatalogName(int columnIndex,
                    String catalogName)
                    throws SQLException
将指定列的表的类别名称（如果有）设置为给定的 String。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
catalogName - 列的类别名称
抛出：
SQLException - 如果发生数据库访问错误

setColumnType

void setColumnType(int columnIndex,
                   int SQLType)
                   throws SQLException
将指定列的 SQL 类型设置为给定的类型。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
SQLType - 列的 SQL 类型
抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Types

setColumnTypeName

void setColumnTypeName(int columnIndex,
                       String typeName)
                       throws SQLException
将指定列的特定于数据源的类型名称（如果有）设置为给定的 String。

参数：
columnIndex - 第一个列是 1，第二个列是 2，……
typeName - 特定于数据源的类型名称。
抛出：
SQLException - 如果发生数据库访问错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 RowSetReader

所有已知子接口：
XmlReader
public interface RowSetReader

该设施供非连接 RowSet 对象调用以填充数据行。reader（实现 RowSetReader 接口的对象）可以在支持 reader/writer 范例的 RowSet 对象中注册。调用 RowSet 对象的 execute 方法时，它将依次调用 reader 的 readData 方法。

从以下版本开始：
1.4

方法摘要
 void readData(RowSetInternal caller)
读取调用 RowSet 对象的新内容。

方法详细信息

readData

void readData(RowSetInternal caller)
              throws SQLException
读取调用 RowSet 对象的新内容。要调用此方法，RowSet 对象必须已经实现了 RowSetInternal 接口并作为其 reader 注册了此 RowSetReader 对象。readData 方法由支持 reader/writer 范例的 rowset 的 RowSet.execute 方法在内部调用。

readData 方法为调用者添加行。此操作可以使用许多种方式实现，甚至可以使用没有关系的数据源中的行来填充调用者。一般情况下，reader 可以调用 rowset 的任何方法，但有一种例外。调用 execute 方法将导致抛出 SQLException，因为 execute 不能以递归方式调用。此外，当 reader 调用 RowSet 方法时，任何侦听器都不会得到通知；即不会生成任何 RowSetEvent 对象，也不会调用任何 RowSetListener 方法。出现此情况的原因是，侦听器已经从 execute 方法得到了通知。

参数：
caller - RowSet 对象，该对象 (1) 已经实现了 RowSetInternal 接口， (2) 此 reader 在其中注册， 和(3) 其 execute 方法调用了此 reader
抛出：
SQLException - 如果发生数据库访问错误或者此方法调用 RowSet.execute 方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 RowSetWriter

所有已知子接口：
TransactionalWriter, XmlWriter
public interface RowSetWriter

实现 RowSetWriter 接口的对象，称为 writer。writer 可以在支持 reader/writer 范例的 RowSet 对象中注册。

如果非连接 RowSet 对象修改它的某些数据，并且它具有与之关联的 writer，则可以实现它，使其在内部调用 writer 的 writeData 方法，以将更新写回数据源。要做到这一点，writer 必须首先建立一个与 rowset 的数据源的连接。

如果在数据源中已经更改了要更新的数据，则会发生冲突；在此情况下，writer 不会将更改写入数据源。writer 用于防止或限制冲突而使用的算法完全依赖于其实现。

从以下版本开始：
1.4

方法摘要
 boolean writeData(RowSetInternal caller)
将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。

方法详细信息

writeData

boolean writeData(RowSetInternal caller)
                  throws SQLException
将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。

参数：
caller - RowSet 对象，该对象 (1) 已经实现 RowSetInternal 接口, (2) 此 writer 在其中注册, 和(3) 内部调用此方法
返回：
如果写入了修改的数据，则返回 true；否则返回 false，在此情况下，存在冲突
抛出：
SQLException - 如果发生数据库访问错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatementEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
类 StatementEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.sql.StatementEvent
所有已实现的接口：
Serializable
public class StatementEvent
extends EventObject

StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。当驱动程序确定与 PooledConnection 关联的 PreparedStatement 已经关闭或驱动程序确定它无效时，发生此事件。

从以下版本开始：
1.6
另请参见：
序列化表格

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
StatementEvent(PooledConnection con, PreparedStatement statement)
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。
StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。
方法摘要
SQLException | getSQLException() 返回驱动程序将要抛出的 SQLException。
PreparedStatement | getStatement() 返回正在关闭或无效的 PreparedStatement。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

StatementEvent

public StatementEvent(PooledConnection con,
                      PreparedStatement statement)
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。包含在事件中的 SQLException 默认为 null。

参数：
con - 与已关闭或无效的 PreparedStatement 关联的 PooledConnection。
statement - 正在关闭的或无效的 PreparedStatement

抛出：
IllegalArgumentException - 如果 con 为 null。
从以下版本开始：
1.6

StatementEvent

public StatementEvent(PooledConnection con,
                      PreparedStatement statement,
                      SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。

参数：
con - 与已关闭或无效的 PreparedStatement 关联的 PooledConnection。
statement - 正在关闭的或无效的 PreparedStatement
exception - 驱动程序将要抛出给应用程序的 SQLException
抛出：
IllegalArgumentException - 如果 con 为 null。

从以下版本开始：
1.6
方法详细信息

getStatement

public PreparedStatement getStatement()
返回正在关闭或无效的 PreparedStatement。

返回：
正在关闭的或无效的 PreparedStatement

从以下版本开始：
1.6

getSQLException

public SQLException getSQLException()
返回驱动程序将要抛出的 SQLException。

返回：
驱动程序将要抛出的 SQLException

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


StatementEventListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 StatementEventListener

所有超级接口：
EventListener
public interface StatementEventListener
extends EventListener

注册为能获得 Statement 池中 PreparedStatement 上所发生事件的通知的对象。

JDBC 3.0 规范添加了 maxStatement ConnectionPooledDataSource 属性，以为启用 PreparedStatement 的池操作提供标准机制并指定语句池的大小。然而，当 PreparedStatement 变为无效时，驱动程序无法通知外部语句池。对于某些数据库，如果执行影响表的 DDL 操作，则语句将变为无效。例如，应用程序可以创建一个临时表，在表上进行某些操作然后销毁它。再次需要时，应用程序还可重新创建相同的表。销毁该表后，某些数据库将使所有引用该临时表的准备语句无效。

与 ConnectionEventListener 接口中定义的方法类似，驱动程序检测到语句无效时将在抛出异常之前调用 StatementEventListener.statementErrorOccurred 方法。PreparedStatement 关闭时，驱动程序也将调用 StatementEventListener.statementClosed 方法。

允许组件使用 PooledConnection 注册 StatementEventListener 的方法已经被添加到 PooledConnection 接口。

从以下版本开始：
1.6

方法摘要
void | statementClosed(StatementEvent event) 检测到 PreparedStatement 关闭时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。
void | statementErrorOccurred(StatementEvent event) 检测到 PreparedStatement 无效时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。

方法详细信息

statementClosed

void statementClosed(StatementEvent event)
检测到 PreparedStatement 关闭时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。

参数：
event - 一个事件对象，它描述事件源以及 PreparedStatement 已经关闭。
从以下版本开始：
1.6

statementErrorOccurred

void statementErrorOccurred(StatementEvent event)
检测到 PreparedStatement 无效时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。驱动程序在向应用程序抛出包含于给定事件的 SQLException 之前调用此方法。

参数：
event - 一个事件对象，它描述事件源、无效的语句和驱动程序将要抛出的异常。事件源是与无效 PreparedStatement 关联的 PooledConnection。

从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XAConnection (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 XAConnection

所有超级接口：
PooledConnection
public interface XAConnection
extends PooledConnection

为分布式事务提供支持的对象。可以通过 XAResource 对象在分布式事务中利用 XAConnection 对象。事务管理器（通常为中间层服务器的一部分）通过 XAResource 对象管理 XAConnection 对象。

应用程序员不直接使用此接口，而是通过运行于中间层服务器的事务管理器使用。

从以下版本开始：
1.4

方法摘要
 XAResource getXAResource()
获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。
从接口 javax.sql.PooledConnection 继承的方法
addConnectionEventListener, addStatementEventListener, close, getConnection, removeConnectionEventListener, removeStatementEventListener

方法详细信息

getXAResource

XAResource getXAResource()
                         throws SQLException
获取 XAResource 对象，事务管理器将使用该对象管理此 XAConnection 对象如何参与到分布式事务中。

返回：
XAResource 对象
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XADataSource (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql
接口 XADataSource

所有超级接口：
CommonDataSource
public interface XADataSource
extends CommonDataSource

在内部使用的 XAConnection 对象的工厂。实现 XADataSource 接口的对象通常在使用 Java Naming and Directory InterfaceTM (JNDI) 的命令服务中注册。

从以下版本开始：
1.4

方法摘要
XAConnection | getXAConnection() 尝试建立可在分布式事务中使用的物理数据库连接。
XAConnection | getXAConnection(String user, String password) 使用给定的用户名和密码，尝试建立一个物理数据库连接。
从接口 javax.sql.CommonDataSource 继承的方法
getLoginTimeout, getLogWriter, setLoginTimeout, setLogWriter

方法详细信息

getXAConnection

XAConnection getXAConnection()
                             throws SQLException
尝试建立可在分布式事务中使用的物理数据库连接。

返回：
可在分布式事务中使用的 XAConnection 对象，该对象表示到数据源的物理连接
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

getXAConnection

XAConnection getXAConnection(String user,
                             String password)
                             throws SQLException
使用给定的用户名和密码，尝试建立一个物理数据库连接。返回的连接可在分布式事务中使用。

参数：
user - 为其建立连接的数据库用户
password - 用户的密码
返回：
可在分布式事务中使用的 XAConnection 对象，该对象表示到数据源的物理连接
抛出：
SQLException - 如果发生数据库访问错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sql (Java 2 Platform SE 6)

 javax.sql
接口
CommonDataSource
ConnectionEventListener
ConnectionPoolDataSource
DataSource
PooledConnection
RowSet
RowSetInternal
RowSetListener
RowSetMetaData
RowSetReader
RowSetWriter
StatementEventListener
XAConnection
XADataSource
类
ConnectionEvent
RowSetEvent
StatementEvent


javax.sql (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sql

为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

请参见：
描述

接口摘要
CommonDataSource | 此接口定义在 DataSource、XADataSource 和 ConnectionPoolDataSource 之间公用的方法。
ConnectionEventListener | 注册该对象便可获得由 PooledConnection 对象生成的事件的通知。
ConnectionPoolDataSource | PooledConnection 对象的工厂。
DataSource | 该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。
PooledConnection | 为连接池管理提供钩子 (hook) 的对象。
RowSet | 该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
RowSetInternal | 为了将自身呈现给 RowSetReader 或 RowSetWriter 对象的 RowSet 对象实现应实现该接口。
RowSetListener | 要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。
RowSetMetaData | 该对象包含关于 RowSet 对象的列的信息。
RowSetReader | 该设施供非连接 RowSet 对象调用以填充数据行。
RowSetWriter | 实现 RowSetWriter 接口的对象，称为 writer。
StatementEventListener | 注册为能获得 Statement 池中 PreparedStatement 上所发生事件的通知的对象。
XAConnection | 为分布式事务提供支持的对象。
XADataSource | 在内部使用的 XAConnection 对象的工厂。

类摘要
ConnectionEvent | 提供关于连接相关事件的源信息的 Event 对象。
RowSetEvent | RowSet 对象发生事件时生成的 Event 对象。
StatementEvent | StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。

软件包 javax.sql 的描述

为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。此包补充了 java.sql 包，它从 1.4 版本开始包含在 Java 平台、标准版 (Java SETM) 中。它保留了 Java 平台、企业版 (Java EETM) 中的精华部分。

java.sql 包中提供以下内容：

  1. DataSource 接口，用于建立到数据源的连接，是 DriverManager 的替代项。
  2. 连接池和语句池
  3. 分布式事务
  4. Rowset

应用程序直接使用 DataSource 和 RowSet API，但连接池和分布式事务 API 只能由中间层基础设施在内部使用。

使用 DataSource 对象建立连接

javax.sql 包提供建立到数据源的连接的首选方式。DriverManager 类（原始机制）仍然有效，使用它的代码将继续运行。然而，与 DriverManager 机制相比，较新的 DataSource 机制更为可取，因为有更多的优点。

下面是使用 DataSource 对象建立连接的主要优点：

  • 可以对数据源的属性进行更改，这意味着当数据源或驱动程序发生更改时，不必更改应用程序代码。
  • 通过已实现为与中间层基础设施一起使用的 DataSource 对象，可获得连接池、语句池和分布式事务。通过 DriverManager 建立的连接不具有连接池和语句池或分布式事务功能。

驱动程序提供 DataSource 实现。特定的 DataSource 对象表示特定的物理数据源，DataSource 对象创建的每个连接都是到该物理数据源的连接。

数据源的逻辑名称需要向使用 Java Naming and Directory InterfaceTM (JNDI) API 的命名服务注册，通常由系统管理员或某个执行系统管理员职责的人执行。应用程序可以通过查找注册的逻辑名称获取它需要的 DataSource 对象。然后，应用程序可以使用 DataSource 对象创建到它所表示物理数据源的连接。

DataSource 对象可以实现为与中间层设施一起使用，这样可将它生成的连接入池以供重用。使用这种 DataSource 实现的应用程序将自动获取参与连接池的连接。DataSource 对象也可以实现为与中间层设施一起使用，这样无需要任何特殊编码即可将它所生成连接用于分布式事务。

连接池和语句池

通过实现为与中间层连接池管理器一起使用的 DataSource 对象建立的连接将参与连接池。这能显著地提高性能，因为创建新连接开销很大。连接池允许使用和重用连接，因此可以极大地减少需要创建的新连接数。

连接池是完全透明的。此操作是在中间层 Java EE 配置中自动完成的，因此就应用程序而言，无需对代码进行任何更改。应用程序可以简单地使用 DataSource.getConnection 方法获取入池连接，并按使用任何 Connection 对象相同的方式使用该连接。

用于连接池的类和接口是：

  • ConnectionPoolDataSource
  • PooledConnection
  • ConnectionEvent
  • ConnectionEventListener
  • StatementEvent
  • StatementEventListener
连接池管理器（三层体系结构的中间层中的设施）在后台使用这些类和接口。当调用 ConnectionPoolDataSource 对象创建 PooledConnection 对象时，连接池管理器将作为 ConnectionEventListener 对象在新 PooledConnection 对象中注册。当关闭连接或发生错误时，连接池管理器（作为侦听器）获取包括 ConnectionEvent 对象在内的通知。

如果连接池管理器支持 Statement 池，则对于可以通过调用 DatabaseMetaData.supportsStatementPooling 方法确定的 PreparedStatements，连接池管理器将向新 PooledConnection 对象注册为 StatementEventListener 对象。当 PreparedStatement 关闭或者发生错误时，连接池管理器（作为一个侦听器）获取一个通知，该通知包括 StatementEvent 对象。

分布式事务

与入池连接一样，通过实现为与中间层基础设施一起使用的 DataSource 对象建立的连接可参与分布式事务。这为应用程序提供了在单个事务中占用多个服务器上的数据源的能力。

用于分布式事务的类和接口是：

  • XADataSource
  • XAConnection
这些接口由事务管理器使用；应用程序不直接使用它们。

XAConnection 接口是从 PooledConnection 接口派生的，因此适用于入池连接的内容也适用于作为分布式事务一部分的连接。中间层中的事务管理器透明地处理所有动作。应用程序代码中的唯一变化是，应用程序不能执行任何与事务管理器对事务的处理有冲突的操作。更明确地说，应用程序不能调用方法 Connection.commit 或 Connection.rollback，并且它不能将连接设置为自动提交模式（即它不能调用 Connection.setAutoCommit(true)）。

应用程序不必为参与分布式事务而执行任何特殊操作。它只需要通过 DataSource.getConnection 方法创建到所需的数据源的连接，就跟它通常的做法一样。事务管理器在后台管理事务。XADataSource 接口创建 XAConnection 对象，每个 XAConnection 对象创建事务管理器用于管理连接的 XAResource 对象。

Rowset

RowSet 接口在后台与各种其他类和接口一起使用。RowSet 可分为三个类别。
  1. 事件通知
    • RowSetListener
      RowSet 对象是 JavaBeansTM 组件，因为它具有属性并参与 JavaBeans 事件通知机制。RowSetListener 接口由希望在特定 RowSet 对象发生事件时获得通知的组件实现。这种组件通过 RowSet.addRowSetListener 方法在 rowset 中作为侦听器注册。

      当 RowSet 对象更改它的其中一行、所有行或者移动其指针时，它将同时通知向它注册的所有侦听器。侦听器通过执行对它调用的通知方法的实现作出反应。

    • RowSetEvent
      作为内部通知进程的一部分，RowSet 对象创建一个 RowSetEvent 的实例并将其传递到侦听器。侦听器可以使用此 RowSetEvent 对象来找出具有该事件的 rowset。

  2. 元数据
    • RowSetMetaData
      此接口从 ResultSetMetaData 接口派生而来，提供关于 RowSet 对象中的列的信息。应用程序可以使用 RowSetMetaData 方法来找出 rowset 包含的列数和每列可以包含的数据种类。

      RowSetMetaData 接口提供用于设置关于列的信息的方法，但是应用程序通常不使用这些方法。当应用程序调用 RowSet 方法 execute 时，RowSet 对象将包含新的行设置，并且其 RowSetMetaData 对象将在内部被更新，以包含关于新行的信息。

  3. Reader/Writer 设施
    实现 RowSetInternal 接口的 RowSet 对象可以调用与之关联的 RowSetReader 对象来填充数据。它还可以调用与之关联的 RowSetWriter 对象将对其行所做的任何更改写回数据源，它的行最初便是从该数据源获取的。保持连接到其数据源的 rowset 不需要使用 reader 和 writer，因为它可以直接对数据源进行操作。
    • RowSetInternal
      通过实现 RowSetInternal 接口，RowSet 对象获取对其内部状态的访问权限，并且能够调用其 reader 和 writer。rowset 关注其当前行的值和当前行之前那个行的值（称为原始 值）。rowset 还关注：（1）已经设置的用于命令的参数（2）传递给它的连接（如果有）。rowset 在后台使用 RowSetInternal 方法获取对此信息的访问权限。应用程序通常不直接调用这些方法。

    • RowSetReader
      已经实现 RowSetInternal 接口的非连接 RowSet 对象可以调用其 reader（与之关联的 RowSetReader 对象）来填充数据。当应用程序调用 RowSet.execute 方法时，该方法调用 rowset 的 reader 来执行大多数操作。实现与实现可能大不相同，但一般过程是：reader 建立到数据源的连接，从数据源读取数据并使用该数据填充 rowset，然后关闭连接。reader 还可能更新其 rowset 的 RowSetMetaData 对象。rowset 的内部状态也将被更新，或者由 reader 进行或者由 RowSet.execute 方法直接进行。
    • RowSetWriter
      已经实现 RowSetInternal 接口的非连接 RowSet 对象可以调用其 writer（与之关联的 RowSetWriter 对象）将更改写回底层数据源。实现与实现可能大不相同，但一般情况下，writer 将执行以下操作：

      • 建立到数据源的连接
      • 检查是否存在冲突，即了解曾经在 rowset 中更改的值是否在数据源中也进行了更改
      • 如果不存在冲突，则将新值写入数据源
      • 关闭连接

RowSet 接口可以使用多种方式实现，任何人都可以编写实现。鼓励开发人员充分发挥想象力，探索使用 rowset 的新方式。

重要注意事项：对于使用标记有 "Since 1.6" 的 API，必须使用实现 JDBC 4.0 API 的 JDBC 技术驱动程序才能运行。必须检查驱动程序文档，以确保它实现了所需使用的特定功能。

包规范

  • JDBC 4.0 API 的规范

相关文档

由 Addison-Wesley Longman 出版的 Java 系列书提供关于 javax.sql 包中的类和实现的详细信息：
  • JDBCTM API Tutorial and Reference, Third Edition:

从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.sql 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • java.util.EventObject (implements java.io.Serializable)
      • javax.sql.ConnectionEvent
      • javax.sql.RowSetEvent
      • javax.sql.StatementEvent

接口分层结构

  • javax.sql.CommonDataSource
    • javax.sql.ConnectionPoolDataSource
    • javax.sql.DataSource (并 extends java.sql.Wrapper)
    • javax.sql.XADataSource
  • java.util.EventListener
    • javax.sql.ConnectionEventListener
    • javax.sql.RowSetListener
    • javax.sql.StatementEventListener
  • javax.sql.PooledConnection
    • javax.sql.XAConnection
  • javax.sql.RowSetInternal
  • javax.sql.RowSetReader
  • javax.sql.RowSetWriter
  • java.sql.Wrapper
    • javax.sql.DataSource (并 extends javax.sql.CommonDataSource)
    • java.sql.ResultSet
      • javax.sql.RowSet
    • java.sql.ResultSetMetaData
      • javax.sql.RowSetMetaData
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sql 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql
的使用

使用 javax.sql 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql 使用的 javax.sql 中的类
CommonDataSource
此接口定义在 DataSource、XADataSource 和 ConnectionPoolDataSource 之间公用的方法。
ConnectionEvent
提供关于连接相关事件的源信息的 Event 对象。
ConnectionEventListener
注册该对象便可获得由 PooledConnection 对象生成的事件的通知。
PooledConnection
为连接池管理提供钩子 (hook) 的对象。
RowSet
该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
RowSetEvent
RowSet 对象发生事件时生成的 Event 对象。
RowSetInternal
为了将自身呈现给 RowSetReader 或 RowSetWriter 对象的 RowSet 对象实现应实现该接口。
RowSetListener
要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。
RowSetMetaData
该对象包含关于 RowSet 对象的列的信息。
StatementEvent
StatementEvent 被传送给所有用 PooledConnection 注册的 StatementEventListener。
StatementEventListener
注册为能获得 Statement 池中 PreparedStatement 上所发生事件的通知的对象。
XAConnection
为分布式事务提供支持的对象。

javax.sql.rowset 使用的 javax.sql 中的类
RowSet
该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
RowSetEvent
RowSet 对象发生事件时生成的 Event 对象。
RowSetListener
要在 RowSet 对象的生命周期内发生重要事件时得到通知的组件必须实现该接口。
RowSetMetaData
该对象包含关于 RowSet 对象的列的信息。

javax.sql.rowset.spi 使用的 javax.sql 中的类
RowSet
该接口添加了对 JavaBeansTM 组件模型的 JDBC API 支持。
RowSetReader
该设施供非连接 RowSet 对象调用以填充数据行。
RowSetWriter
实现 RowSetWriter 接口的对象，称为 writer。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


BaseRowSet (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
类 BaseRowSet

java.lang.Object
    继承者  javax.sql.rowset.BaseRowSet
所有已实现的接口：
Serializable, Cloneable
public abstract class BaseRowSet
extends Object
implements Serializable, Cloneable

提供一个具有基本功能的 RowSet 对象的抽象类。基本功能包括设置属性和发送事件通知，这是所有 JavaBeansTM 组件都必须实现的。

1.0 概述

BaseRowSet 类为所有 RowSet 实现提供核心功能，所有标准实现可以结合使用此类和一个或多个 RowSet 接口来提供标准特定于供应商的实现。更详细地说，即所有实现必须至少实现一个 RowSet 接口（JdbcRowSet、CachedRowSet、JoinRowSet、FilteredRowSet 或 WebRowSet）。这意味着所有扩展 BaseRowSet 类的实现也必须实现一个 RowSet 接口。

BaseRowSet 类提供以下内容：

  • 属性
    • 用于存储当前属性的字段
    • 用于获取和设置属性的方法

  • 事件通知

  • 完整的设置方法集 用于设置 RowSet 对象命令中的各个参数

  • 流
    • 用于存储流实例的字段
    • 指示流类型的常量

2.0 设置属性

所有 rowset 都维护一个属性集，通常使用某种工具来设置这些属性。rowset 具有的属性的数量和种类各不相同，这取决于 RowSet 实现的用途及其获得数据的方式。例如，从 ResultSet 对象获得其数据的 rowset 需要设置那些建立数据库连接所需的属性。如果某个 RowSet 对象使用 DriverManager 设施建立连接，则它需要设置一个标识合适驱动程序的 JDBC URL 属性，还需要设置那些提供用户名和密码的属性。另一方面，如果 rowset 使用 DataSource 对象建立连接（这是首选的方法），则它无需设置 JDBC URL 属性。但是它需要设置用于数据源逻辑名的属性，以及用户名和密码的属性。

注：要使用 DataSource 对象建立连接，该 DataSource 对象必须已经向使用 Java Naming and Directory InterfaceTM (JNDI) API 的命名服务注册。通常由具有系统管理员资格的人员完成此注册。

3.0 设置命令及其参数

rowset 从关系型数据库获取其数据时，它执行一条可生成 ResultSet 对象的命令（查询）。此查询就是为 RowSet 对象的 command 属性所设置的命令。rowset 使用数据填充自身的方式是将数据从 ResultSet 对象读取到其自身。如果查询为要设置的值包含占位符，则使用 BaseRowSet 的设置方法设置这些值。如有必要，所有设置方法都允许将这些值设置为 null。

以下代码片断展示了如何设置 CachedRowSetTM 对象 crs 的 command 属性。注意，如果使用某种工具设置属性，则这就是该工具应使用的代码。

    crs.setCommand("SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS" +
                   "WHERE CREDIT_LIMIT > ? AND REGION = ?");

在此示例中，CREDIT_LIMIT 和 REGION 的值是占位符参数，用一个问号 (?) 指示。第一个问号是占位符参数编号 1，第二个问号是占位符参数编号 2，依此类推。执行查询前必须为占位符参数设置值。要设置这些占位符参数，BaseRowSet 类提供了一组与 PreparedStatement 接口类似的设置方法，用于设置每种数据类型的值。RowSet 对象内部存储该参数值，该对象的 execute 方法在将要执行的命令发送到 DBMS 前，使用这些值内部设置占位符参数的值。

以下代码片断演示了如何设置前一个示例查询中的两个参数。

    crs.setInt(1, 5000);
    crs.setString(2, "West");
如果此时调用 execute 方法，则发送到 DBMS 的查询是：
    "SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS" +
                   "WHERE CREDIT_LIMIT > 5000 AND REGION = 'West'"
注：将 Array、Clob、Blob 和 Ref 对象设置为命令参数，将这些值分别存储为 SerialArray、SerialClob、SerialBlob 和 SerialRef 对象。

4.0 在后台处理参数

注：BaseRowSet 类提供两类设置方法：一类设置属性，一类设置占位符参数。此部分中讨论的设置方法是设置占位符参数的那一类。

使用 BaseRowSet 的设置方法设置的占位符参数以对象的形式存储在内部 Hashtable 对象中。基本类型则以其 Object 类型存储。例如，byte 以 Byte 对象的形式存储，int 则以 Integer 对象的形式存储。调用方法 execute 时，Hashtable 对象中的值替换命令中的适当占位符参数。 调用方法 getParams 能够以 Object 实例数组的形式返回存储在 Hashtable 对象中的值。此数组中的元素可以是一个简单的 Object 实例，也可以是一个数组（Object 类型）。使用特定的设置方法可确定此数组中某个元素是 Object 还是数组。

大多数设置占位符参数的方法采用两个参数，第一个参数指示要设置的占位符参数，第二个参数给出要设置的值。getInt、getString、getBoolean 和 getLong 之类的方法属于此类。调用这些方法后，调用方法 getParams 将返回一个数组，其中带有已经设置的值。每个数组元素都是一个 Object 实例，表示已经设置的值。根据传递到设置方法的 int（第一个参数）来确定这些值在数组中的顺序。该数组中的值就是传递给设置方法的值（第二个参数）。换句话说，数组中的第一个元素是为 RowSet 对象的命令中第一个占位符参数所设置的值。第二个元素是为第二个占位符参数所设置的值，依此类推。

一些设置方法除了要设置的值外，还发送驱动程序和 DBMS 信息。如果在使用了此类设置方法后再调用方法 getParams，则数组中的元素本身就是数组，以容纳附加信息。在此类别中，方法 setNull 是一个特例，因为它有一种形式只带有两个参数 (setNull(int parameterIndex, int SqlType))。尽管如此，它仍然需要一个数组来包含要传递给驱动程序和 DBMS 的信息。此数组中的第一个元素是要设置的值，该值为 null；第二个元素是为 sqlType 提供的 int，指示要设置为 null 的 SQL 值的类型。某些 DBMS 需要此信息，因此为了确保应用程序的可移植性，此信息是必需的。当要设置为 null 的值是用户定义的类型时，可使用该方法的另一种形式。这种形式带有三个参数 (setNull(int parameterIndex, int sqlType, String typeName))，同样需要一个数组来包含要传递给驱动程序和 DBMS 的信息。此数组中的前两个参数与第一种 setNull 相同。第三个参数 typeName 给出了用户定义类型的 SQL 名称。与其他设置方法一样，通过 getParams 返回的数组中元素的位置来指示要设置的占位符参数的编号。所以，举例来说，如果提供给 setNull 的参数是 2，则 getParams 返回的数组中的第二个元素将是一个两元素或三元素数组。

某些方法（如 setObject 和 setDate）还有带有多于两个参数的形式，这些额外的参数为驱动程序或 DBMS 提供信息。例如，方法 setDate、setTime 和 setTimestamp 可将 Calendar 对象作为其第三个参数。如果 DBMS 没有存储时区信息，则驱动程序使用 Calendar 对象来构造正在设置的 Date、Time 或 Timestamp 对象。与提供附加信息的其他方法一样，getParams 返回的数组中的元素是一个数组，而不是简单的 Object 实例。

方法 setAsciiStream、setBinaryStream、setCharacterStream 和 setUnicodeStream（该方法已废弃，所以应用程序应该使用 getCharacterStream）带有三个参数，所以对于这些方法，getParams 返回的数组中的元素也是一个数组。这些设置方法的不同之处在于除了由参数提供的信息外，该数组还包含一个 BaseRowSet 常量，指示正在设置的流类型。

注：由扩展此类的 RowSet 实现内部调用方法 getParams；应用程序的程序员通常不直接调用此方法。

5.0 事件通知

BaseRowSet 类为 rowset 提供了事件通知机制。它包含字段 listeners、添加和移除侦听器的方法，以及将更改通知给侦听器的方法。

侦听器是一个实现了 RowSetListener 接口的对象。如果已经将侦听器添加到 RowSet 对象的侦听器列表，则 RowSet 对象上发生事件时它将获得通知。每个侦听器的 RowSetListener 方法实现定义了获得发生事件的通知时，该对象将执行的操作。

RowSet 对象有三种可能的事件：

  1. 光标移动
  2. 更改了个别行（更新、删除或插入）
  3. 更改了整个 RowSet 对象的内容

用于通知的 BaseRowSet 方法指示已经发生事件的类型。例如，方法 notifyRowChanged 指示某行已经被更新、删除或插入。每种通知方法都创建 RowSetEvent 对象，将该对象提供给侦听器，从而标识发生事件的 RowSet 对象。侦听器如何使用此信息（可能不执行任何操作）取决于它的实现方式。

6.0 默认行为

默认的 BaseRowSet 对象是用很多起始值初始化的。 扩展 BaseRowSet 类的默认 RowSet 实例具有以下特点：
  • 具有可滚动的指针并且不显示其他对象所做的更改。
  • 是可更新的。
  • 不显示已删除的行。
  • 对于驱动程序要多长时间才执行 RowSet 对象的命令没有限制。
  • 对于可以包含的行数没有限制。
  • 对于一列可以包含的字节数没有限制。注：此限制仅适用于包含以下类型值的列：BINARY、VARBINARY、LONGVARBINARY、CHAR、VARCHAR 和 LONGVARCHAR。
  • 无法看到未提交的数据（进行“脏”读）。
  • 已开启转义处理。
  • 已将其连接的类型映射设置为 null。
  • 具有空的 Vector 对象，用于存储为 RowSet 对象命令中的占位符参数设置的值。

如果需要其他值，则应用程序必须显式设置该属性值。例如，以下代码行将 CachedRowSet 对象 crs 的最大行数设置为 500。

    crs.setMaxRows(500);
对于任何违反已定义断言的情况，扩展此 BaseRowSet 类的方法实现必须抛出 SQLException 对象。此外，如果扩展的类重写和重新实现了任何 BaseRowSet 方法，并且遇到了连接性或底层数据源问题，则方法可以为此另外抛出 SQLException 对象。

另请参见：
序列化表格

字段摘要
static int | ASCII_STREAM_PARAM 该常量向 RowSetReaderImpl 对象指示给定的参数是一个 ASCII 流。
protected InputStream | asciiStream 将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
static int | BINARY_STREAM_PARAM 该常量向 RowSetReaderImpl 对象指示给定的参数是一个二进制流。
protected InputStream | binaryStream 将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
protected Reader | charStream 将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。
static int | UNICODE_STREAM_PARAM 该常量向 RowSetReaderImpl 对象指示给定的参数是一个 Unicode 流。
protected InputStream | unicodeStream 将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。
构造方法摘要
BaseRowSet()
构造一个新的 BaseRowSet 对象，使用默认的 Vector 对象初始化其 listeners 字段。
方法摘要
void | addRowSetListener(RowSetListener listener) 只要在此 RowSet 对象上发生事件，就将通知该侦听器。
void | clearParameters() 清除所有此 RowSet 对象的内部参数表示形式的当前参数值，这些参数值将在执行此 RowSet 对象的命令时在其中设置这些参数。
String | getCommand() 获取作为此 RowSet 对象的命令的 SQL 查询。
int | getConcurrency() 返回此 RowSet 对象的并发性。
String | getDataSourceName() 返回向使用 Java Naming and Directory Interface (JNDI) API 的命名服务所提供的逻辑名，这将获得 javax.sql.DataSource 对象。
boolean | getEscapeProcessing() 确定是否为此 RowSet 对象启用了转义处理。
int | getFetchDirection() 获取此 RowSet 对象的当前有关获取方向的设置。
int | getFetchSize() 返回此 RowSet 对象的获取大小。
int | getMaxFieldSize() 获取可用于此 RowSet 对象列值的最大字节数。
int | getMaxRows() 获取此 RowSet 对象可以包含的最大行数。
Object[] | getParams() 获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。
String | getPassword() 返回用于创建此 RowSet 对象的数据库连接的密码。
int | getQueryTimeout() 获取驱动程序等待查询执行的最大秒数。
boolean | getShowDeleted() 获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
int | getTransactionIsolation() 返回此 RowSet 对象连接的事务隔离属性。
int | getType() 返回此 RowSet 对象的类型。
Map<String,Class<?>> | getTypeMap() 获取与此 RowSet 对象的 Connection 对象关联的类型映射表。
String | getUrl() 获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。
String | getUsername() 返回用于创建数据库连接的用户名。
protected void | initParams() 执行必需的内部配置和初始化，从而允许所有 JDBC RowSet 实现开始使用 BaseRowSet 实例提供的标准设施。
boolean | isReadOnly() 返回一个指示此 RowSet 对象是否为只读的 boolean 值。
protected void | notifyCursorMoved() 通知向此 RowSet 对象注册的所有侦听器其光标已移动。
protected void | notifyRowChanged() 通知向此 RowSet 对象注册的所有侦听器其行已更改。
protected void | notifyRowSetChanged() 通知向此 RowSet 对象注册的所有侦听器其整个内容已更改。
void | removeRowSetListener(RowSetListener listener) 从此 RowSet 对象的侦听器列表中移除指定的对象。
void | setArray(int parameterIndex, Array array) 将指定参数设置为 Java 编程语言中的 Array 对象。
void | setAsciiStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | setAsciiStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。
void | setAsciiStream(String parameterName, InputStream x) 将指定参数设置为给定的输入流。
void | setAsciiStream(String parameterName, InputStream x, int length) 将指定参数设置为给定输入流，该输入流将拥有指定字节数。
void | setBigDecimal(int parameterIndex, BigDecimal x) 将指定参数设置为给定的 java.lang.BigDecimal 值。
void | setBigDecimal(String parameterName, BigDecimal x) 将指定参数设置为给定的 java.math.BigDecimal 值。
void | setBinaryStream(int parameterIndex, InputStream x) 将此 RowSet 对象命令中的指定参数设置为给定输入流。
void | setBinaryStream(int parameterIndex, InputStream x, int length) 将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。
void | setBinaryStream(String parameterName, InputStream x) 将指定参数设置为给定输入流。
void | setBinaryStream(String parameterName, InputStream x, int length) 将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。
void | setBlob(int parameterIndex, Blob x) 将指定参数设置为 Java 编程语言中的给定 Blob 对象。
void | setBlob(int parameterIndex, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | setBlob(int parameterIndex, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | setBlob(String parameterName, Blob x) 将指定参数设置为给定的 java.sql.Blob 对象。
void | setBlob(String parameterName, InputStream inputStream) 将指定参数设置为 InputStream 对象。
void | setBlob(String parameterName, InputStream inputStream, long length) 将指定参数设置为 InputStream 对象。
void | setBoolean(int parameterIndex, boolean x) 将指定参数设置为 Java 编程语言中的给定 boolean 值。
void | setBoolean(String parameterName, boolean x) 将指定参数设置为给定的 Java boolean 值。
void | setByte(int parameterIndex, byte x) 将指定参数设置为 Java 编程语言中的给定 byte 值。
void | setByte(String parameterName, byte x) 将指定参数设置为给定的 Java byte 值。
void | setBytes(int parameterIndex, byte[] x) 将指定参数设置为给定的 byte 数组。
void | setBytes(String parameterName, byte[] x) 将指定参数设置为给定的 Java byte 数组。
void | setCharacterStream(int parameterIndex, Reader reader) 将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。
void | setCharacterStream(int parameterIndex, Reader reader, int length) 将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。
void | setCharacterStream(String parameterName, Reader reader) 将指定参数设置为给定 Reader 对象。
void | setCharacterStream(String parameterName, Reader reader, int length) 将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。
void | setClob(int parameterIndex, Clob x) 将指定参数设置为 Java 编程语言中的给定 Clob 对象。
void | setClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | setClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setClob(String parameterName, Clob x) 将指定参数设置为给定的 java.sql.Clob 对象。
void | setClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | setClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setCommand(String cmd) 将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。
void | setConcurrency(int concurrency) 将此 RowSet 对象的并发性设置为指定的并发性。
void | setDataSourceName(String name) 将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。
void | setDate(int parameterIndex, Date x) 将指定参数设置为给定的 java.sql.Date 值。
void | setDate(int parameterIndex, Date x, Calendar cal) 将指定参数设置为给定的 java.sql.Date 对象。
void | setDate(String parameterName, Date x) 使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。
void | setDate(String parameterName, Date x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。
void | setDouble(int parameterIndex, double x) 将指定参数设置为 Java 编程语言中的给定 double 值。
void | setDouble(String parameterName, double x) 将指定参数设置为给定的 Java double 值。
void | setEscapeProcessing(boolean enable) 设置为给定的 boolean 值，指示将 SQL 语句发送到数据库之前，驱动程序是否扫描转义语法并进行转义替换。
void | setFetchDirection(int direction) 为驱动程序提供一个性能提示，该提示指示处理此 RowSet 对象中各行时使用的方向。
void | setFetchSize(int rows) 将此 RowSet 对象的获取大小设置为给定的行数。
void | setFloat(int parameterIndex, float x) 将指定参数设置为 Java 编程语言中的给定 float 值。
void | setFloat(String parameterName, float x) 将指定参数设置为给定的 Java float 值。
void | setInt(int parameterIndex, int x) 将指定参数设置为 Java 编程语言中的 int 值。
void | setInt(String parameterName, int x) 将指定参数设置为给定的 Java int 值。
void | setLong(int parameterIndex, long x) 将指定参数设置为 Java 编程语言中的给定 long 值。
void | setLong(String parameterName, long x) 将指定参数设置为给定的 Java long 值。
void | setMaxFieldSize(int max) 将可用于此 RowSet 对象列值的最大字节数设置为给定数。
void | setMaxRows(int max) 将此 RowSet 对象可以包含的最大行数设置为给定数。
void | setNCharacterStream(int parameterIndex, Reader value) 将此 RowSet 对象命令中的指定参数设置为 Reader 对象。
void | setNCharacterStream(int parameterIndex, Reader value, long length) 将指定参数设置为 Reader 对象。
void | setNCharacterStream(String parameterName, Reader value) 将指定参数设置为 Reader 对象。
void | setNCharacterStream(String parameterName, Reader value, long length) 将指定参数设置为 Reader 对象。
void | setNClob(int parameterIndex, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | setNClob(int parameterIndex, Reader reader) 将指定参数设置为 Reader 对象。
void | setNClob(int parameterIndex, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setNClob(String parameterName, NClob value) 将指定参数设置为 java.sql.NClob 对象。
void | setNClob(String parameterName, Reader reader) 将指定参数设置为 Reader 对象。
void | setNClob(String parameterName, Reader reader, long length) 将指定参数设置为 Reader 对象。
void | setNString(int parameterIndex, String value) 将指定参数设置为给定的 String 对象。
void | setNString(String parameterName, String value) 将指定参数设置为给定的 String 对象。
void | setNull(int parameterIndex, int sqlType) 将指定参数设置为 SQL NULL。
void | setNull(int parameterIndex, int sqlType, String typeName) 将指定参数设置为 SQL NULL。
void | setNull(String parameterName, int sqlType) 将指定参数设置为 SQL NULL。
void | setNull(String parameterName, int sqlType, String typeName) 将指定参数设置为 SQL NULL。
void | setObject(int parameterIndex, Object x) 将指定参数设置为 Java 编程语言中的 Object。
void | setObject(int parameterIndex, Object x, int targetSqlType) 使用给定 Object 值设置指定参数的值。
void | setObject(int parameterIndex, Object x, int targetSqlType, int scale) 将指定参数设置为 Java 编程语言中的 Object。
void | setObject(String parameterName, Object x) 使用给定对象设置指定参数的值。
void | setObject(String parameterName, Object x, int targetSqlType) 使用给定对象设置指定参数的值。
void | setObject(String parameterName, Object x, int targetSqlType, int scale) 使用给定对象设置指定参数的值。
void | setPassword(String pass) 将用于创建此 RowSet 对象的数据库连接的密码设置为给定的 String 对象。
void | setQueryTimeout(int seconds) 将驱动程序等待查询执行的最大秒数设置为给定的数。
void | setReadOnly(boolean value) 将此 RowSet 对象的 readOnly 属性设置为给定的 boolean 值。
void | setRef(int parameterIndex, Ref ref) 将指定参数设置为 Java 编程语言中的给定 Ref 对象。
void | setRowId(int parameterIndex, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | setRowId(String parameterName, RowId x) 将指定参数设置为给定的 java.sql.RowId 对象。
void | setShort(int parameterIndex, short x) 将指定参数设置为 Java 编程语言中的给定 short 值。
void | setShort(String parameterName, short x) 将指定参数设置为给定的 Java short 值。
void | setShowDeleted(boolean value) 将属性 showDeleted 设置为给定的 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
void | setSQLXML(int parameterIndex, SQLXML xmlObject) 将指定参数设置为给定 java.sql.SQLXML 对象。
void | setSQLXML(String parameterName, SQLXML xmlObject) 将指定参数设置为给定的 java.sql.SQLXML 对象。
void | setString(int parameterIndex, String x) 将指定参数设置为给定的 String 值。
void | setString(String parameterName, String x) 将指定参数设置为给定的 Java String 值。
void | setTime(int parameterIndex, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | setTime(int parameterIndex, Time x, Calendar cal) 将指定参数设置为给定的 java.sql.Time 对象。
void | setTime(String parameterName, Time x) 将指定参数设置为给定的 java.sql.Time 值。
void | setTime(String parameterName, Time x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。
void | setTimestamp(int parameterIndex, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | setTimestamp(int parameterIndex, Timestamp x, Calendar cal) 将指定参数设置为给定的 java.sql.Timestamp 对象。
void | setTimestamp(String parameterName, Timestamp x) 将指定参数设置为给定的 java.sql.Timestamp 值。
void | setTimestamp(String parameterName, Timestamp x, Calendar cal) 使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。
void | setTransactionIsolation(int level) 将此 JDBC RowSet 对象的事务隔离属性设置为给定的常量。
void | setType(int type) 将此 RowSet 对象的类型设置为指定类型。
void | setTypeMap(Map<String,Class<?>> map) 将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。
void | setUnicodeStream(int parameterIndex, InputStream x, int length) 已过时。 应该使用 getCharacterStream 替代它
void | setURL(int parameterIndex, URL x) 将指定参数设置为给定的 java.net.URL 值。
void | setUrl(String url) 将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。
void | setUsername(String name) 将此 RowSet 对象的 username 属性设置为给定的用户名。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UNICODE_STREAM_PARAM

public static final int UNICODE_STREAM_PARAM
该常量向 RowSetReaderImpl 对象指示给定的参数是一个 Unicode 流。此 RowSetReaderImpl 对象作为 SyncProvider 抽象类的扩展来提供，该抽象类在 SyncFactory 静态工厂 SPI 机制中定义。

另请参见：
常量字段值

BINARY_STREAM_PARAM

public static final int BINARY_STREAM_PARAM
该常量向 RowSetReaderImpl 对象指示给定的参数是一个二进制流。此 RowSetReaderImpl 对象作为 SyncProvider 抽象类的扩展来提供，该抽象类在 SyncFactory 静态工厂 SPI 机制中定义。

另请参见：
常量字段值

ASCII_STREAM_PARAM

public static final int ASCII_STREAM_PARAM
该常量向 RowSetReaderImpl 对象指示给定的参数是一个 ASCII 流。此 RowSetReaderImpl 对象作为 SyncProvider 抽象类的扩展来提供，该抽象类在 SyncFactory 静态工厂 SPI 机制中定义。

另请参见：
常量字段值

binaryStream

protected InputStream binaryStream
将由方法 getBinaryStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

unicodeStream

protected InputStream unicodeStream
将由方法 getUnicodeStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

asciiStream

protected InputStream asciiStream
将由方法 getAsciiStream 返回的 InputStream 对象，该方法在 ResultSet 接口中指定。

charStream

protected Reader charStream
将由方法 getCharacterStream 返回的 Reader 对象，该方法在 ResultSet 接口中指定。

构造方法详细信息

BaseRowSet

public BaseRowSet()
构造一个新的 BaseRowSet 对象，使用默认的 Vector 对象初始化其 listeners 字段。初始化时使用的其他默认值列在此类类注释的 6.0 部分。

方法详细信息

initParams

protected void initParams()
执行必需的内部配置和初始化，从而允许所有 JDBC RowSet 实现开始使用 BaseRowSet 实例提供的标准设施。应该在实例化 RowSet 对象后再调用此方法，以正确地初始化所有参数。此方法永远不应该由应用程序调用，而应从具有扩展此类的 RowSet 实现的对象中调用。

addRowSetListener

public void addRowSetListener(RowSetListener listener)
只要在此 RowSet 对象上发生事件，就将通知该侦听器。

为了准确地反映 RowSet 对象的当前状态，侦听器可能是一个需要更新的表或图形。

注：如果 RowSetListener 对象为 null，则此方法正常丢弃该 null 值，不向侦听器集添加 null 引用。

注：如果已经设置了侦听器，则新的 RowSetListerner 实例将添加到已注册接收此 RowSet 事件通知的侦听器集合。

参数：
listener - 一个对象，它已经实现了 javax.sql.RowSetListener 接口并且希望在此 RowSet 对象上发生任何事件时得到通知；可以为 null。
另请参见：
removeRowSetListener(javax.sql.RowSetListener)

removeRowSetListener

public void removeRowSetListener(RowSetListener listener)
从此 RowSet 对象的侦听器列表中移除指定的对象。如果给定的参数不是已注册侦听器，则此方法不执行任何操作。 注：如果 RowSetListener 对象为 null，则此方法正常丢弃该 null 值。

参数：
listener - 位于此 RowSet 对象的侦听器列表中的 RowSetListener 对象
另请参见：
addRowSetListener(javax.sql.RowSetListener)

notifyCursorMoved

protected void notifyCursorMoved()
                          throws SQLException
通知向此 RowSet 对象注册的所有侦听器其光标已移动。

当应用程序调用某个方法移动光标时，该方法移动光标，然后内部调用此方法。应用程序永远不应该直接调用此方法。

抛出：
SQLException - 如果扩展 BaseRowSet 抽象类的类未实现 RowSet 接口或其某个子接口。

notifyRowChanged

protected void notifyRowChanged()
                         throws SQLException
通知向此 RowSet 对象注册的所有侦听器其行已更改。

当应用程序调用更改某行的方法时，如 CachedRowSet 方法 insertRow、updateRow 或 deleteRow，该方法内部调用 notifyRowChanged。应用程序永远不应该直接调用此方法。

抛出：
SQLException - 如果扩展 BaseRowSet 抽象类的类未实现 RowSet 接口或其某个子接口。

notifyRowSetChanged

protected void notifyRowSetChanged()
                            throws SQLException
通知向此 RowSet 对象注册的所有侦听器其整个内容已更改。

当应用程序调用更改 RowSet 对象整个内容的方法时，如 CachedRowSet 方法 execute、populate、restoreOriginal 或 release，该方法内部调用（直接或间接）notifyRowSetChanged。应用程序永远不应该直接调用此方法。

抛出：
SQLException - 如果扩展 BaseRowSet 抽象类的类未实现 RowSet 接口或其某个子接口。

getCommand

public String getCommand()
获取作为此 RowSet 对象的命令的 SQL 查询。command 属性包含为填充此 RowSet 对象所执行的查询。

此方法返回的 SQL 查询由 RowSet 方法使用，如 execute 和 populate，扩展了 BaseRowSet 抽象类和实现了一个或多个标准 JSR-114 RowSet 接口的任何类都可实现这些方法。

RowSet 对象的 reader 使用该命令获得 ResultSet 对象。然后 reader 从 ResultSet 对象读取数据并使用该数据填充此 RowSet 对象。

command 属性的默认值为 null。

返回：
String，它是此 RowSet 对象的 command 属性的值；可以为 null
另请参见：
setCommand(java.lang.String)

setCommand

public void setCommand(String cmd)
                throws SQLException
将此 RowSet 对象的 command 属性设置为给定的 String 对象，并清除为前一个命令设置的参数（如果有）。

如果 RowSet 对象从一个不支持 command 属性的数据源获得数据（如电子表格或其他表格文件），则不需要 command 属性。因此，此属性是可选的，可以为 null。

参数：
cmd - 包含 SQL 查询的 String 对象，该查询将被设置为此 RowSet 对象的 command 属性；可以为 null 但不能是空字符串
抛出：
SQLException - 如果提供空字符串作为 command 值
另请参见：
getCommand()

getUrl

public String getUrl()
              throws SQLException
获取此 RowSet 对象的 javax.sql.Reader 对象用来建立与关系数据库连接（使用启用 JDBC 技术的驱动程序）的 JDBC URL。

如果底层数据源是非 SQL 数据源（如电子表格或 XML 数据源），则该 Url 属性为 null。

返回：
包含 JDBC URL 的 String 对象，该 URL 用来为此 RowSet 对象建立连接；如果未设置，则为 null（默认值）
抛出：
SQLException - 如果获取 URL 值时发生错误
另请参见：
setUrl(java.lang.String)

setUrl

public void setUrl(String url)
            throws SQLException
将此 RowSet 对象的 Url 属性设置为给定的 String 对象，并将 dataSource 名称属性设置为 null。Url 属性是使用启用 JDBC 技术的驱动程序（“JDBC 驱动程序”）和 DriverManager 建立连接时所使用的 JDBC URL。在驱动程序文档中可以找到特定驱动程序要使用的恰当 JDBC URL。虽然对如何形成 JDBC URL 有很多指导方针，但驱动程序供应商可以指定除长度为 0（空字符串）以外的任何 String 对象。

如果使用 DataSource 对象而不是 DriverManager 建立连接，则设置 Url 属性是可选的。驱动程序将使用最近一次指定的 URL 属性或 dataSourceName 属性来创建连接。如果应用程序使用 JDBC URL，则必须在使用 RowSet 对象连接到数据库之前加载可接受 JDBC URL 的 JDBC 驱动程序。为了读取或写入数据，RowSet 对象将内部使用该 URL 创建数据库连接。

参数：
url - 一个 String 对象，包含为此 RowSet 对象建立到数据库的连接时所使用的 JDBC URL；可以为 null 但不得为空字符串
抛出：
SQLException - 如果设置 Url 属性时发生错误，或者提供的参数是长度为 0 的字符串（空字符串）
另请参见：
getUrl()

getDataSourceName

public String getDataSourceName()
返回向使用 Java Naming and Directory Interface (JNDI) API 的命名服务所提供的逻辑名，这将获得 javax.sql.DataSource 对象。可使用此 DataSource 对象建立到它所表示的数据源的连接。

用户应该设置 url 或数据源名称属性。驱动程序将使用最近一次设置的属性来建立连接。

返回：
一个 String 对象，标识建立连接所使用的 DataSource 对象；如果尚未设置逻辑名，则返回 null。
另请参见：
setDataSourceName(java.lang.String)

setDataSourceName

public void setDataSourceName(String name)
                       throws SQLException
将此 RowSet 对象的 DataSource 名称属性设置为给定的逻辑名，并将此 RowSet 对象的 Url 属性设置为 null。该名称必须已绑定到 JNDI 命名服务中的 DataSource 对象，这样应用程序才可以使用该名称执行查找，以获取绑定到该名称的 DataSource 对象。然后可使用此 DataSource 对象建立到它所表示的数据源的连接。

用户应该设置 Url 属性或 dataSourceName 属性。如果同时设置了两个属性，则驱动程序将使用最近一次设置的属性。

参数：
name - 一个 String 对象，它所带的名称可提供给基于 JNDI 技术的命名服务，以获取可用于建立连接的 DataSource 对象；可以为 null 但不得为空字符串
抛出：
SQLException - 如果提供空字符串作为 DataSource 名称
另请参见：
zhang

getUsername

public String getUsername()
返回用于创建数据库连接的用户名。因为 username 属性不是序列化的，所以在调用方法 execute 之前在运行时设置该属性。

返回：
String 对象，包含为创建连接而提供给数据源的用户名；如果未设置，则为 null（默认值）
另请参见：
setUsername(java.lang.String)

setUsername

public void setUsername(String name)
将此 RowSet 对象的 username 属性设置为给定的用户名。因为 username 属性不是序列化的，所以在调用方法 execute 之前在运行时设置该属性。

参数：
name - String 对象，包含为创建连接而提供给数据源的用户名。可以为 null。
另请参见：
getUsername()

getPassword

public String getPassword()
返回用于创建此 RowSet 对象的数据库连接的密码。因为 password 属性不是序列化的，所以在调用方法 execute 之前在运行时设置该属性。默认值为 null。

返回：
String 对象，表示为创建连接而必须提供给数据库的密码
另请参见：
setPassword(java.lang.String)

setPassword

public void setPassword(String pass)
将用于创建此 RowSet 对象的数据库连接的密码设置为给定的 String 对象。因为 password 属性不是序列化的，所以在调用方法 execute 之前在运行时设置该属性。

参数：
pass - String 对象，表示为创建连接而提供给数据库的密码。可以为 null。
另请参见：
getPassword()

setType

public void setType(int type)
             throws SQLException
将此 RowSet 对象的类型设置为指定类型。默认类型是 ResultSet.TYPE_SCROLL_INSENSITIVE。

参数：
type - 以下常量之一：ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
抛出：
SQLException - 如果提供的参数不是以下常量之一：ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
另请参见：
getConcurrency(), getType()

getType

public int getType()
            throws SQLException
返回此 RowSet 对象的类型。类型是由创建 RowSet 对象的语句最初确定的。RowSet 对象可在任何时间调用方法 setType 来更改其类型。默认值是 TYPE_SCROLL_INSENSITIVE。

返回：
此 JDBC RowSet 对象的类型，必须是以下值之一：ResultSet.TYPE_FORWARD_ONLY、ResultSet.TYPE_SCROLL_INSENSITIVE 或 ResultSet.TYPE_SCROLL_SENSITIVE
抛出：
SQLException - 如果获得此 RowSet 对象的类型时发生错误
另请参见：
setType(int)

setConcurrency

public void setConcurrency(int concurrency)
                    throws SQLException
将此 RowSet 对象的并发性设置为指定的并发性。所有 RowSet 对象（连接或非连接的）的默认并发性是 ResultSet.CONCUR_UPDATABLE，但是可在任何时间调用此方法来更改该并发性。

参数：
concurrency - 以下常量之一：ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
抛出：
SQLException - 如果提供的参数不是以下常量之一：ResultSet.CONCUR_UPDATABLE 或 ResultSet.CONCUR_READ_ONLY
另请参见：
getConcurrency(), isReadOnly()

isReadOnly

public boolean isReadOnly()
返回一个指示此 RowSet 对象是否为只读的 boolean 值。任何试图更新只读 RowSet 对象将导致抛出 SQLException。默认情况下，如果可以进行更新，则 rowset 是可更新的。

返回：
如果不能更新此 RowSet 对象，则返回 true；否则返回 false
另请参见：
setConcurrency(int), setReadOnly(boolean)

setReadOnly

public void setReadOnly(boolean value)
将此 RowSet 对象的 readOnly 属性设置为给定的 boolean 值。

参数：
value - 为 true 指示此 RowSet 对象是只读的；为 false 指示该对象是可更新的

getTransactionIsolation

public int getTransactionIsolation()
返回此 RowSet 对象连接的事务隔离属性。此属性表示在事务中请求使用的事务隔离级别。

对于某些 RowSet 实现，如在非连接环境中操作的 CachedRowSet，SyncProvider 对象提供了互补的锁定和数据完整性选项。以下描述的选项仅与连接的 RowSet 对象（JdbcRowSet 对象）有关。

返回：
以下常量之一：Connection.TRANSACTION_NONE、Connection.TRANSACTION_READ_UNCOMMITTED、Connection.TRANSACTION_READ_COMMITTED、Connection.TRANSACTION_REPEATABLE_READ 或 Connection.TRANSACTION_SERIALIZABLE
另请参见：
SyncFactory, SyncProvider, setTransactionIsolation(int)

setTransactionIsolation

public void setTransactionIsolation(int level)
                             throws SQLException
将此 JDBC RowSet 对象的事务隔离属性设置为给定的常量。如果可以，DBMS 将为事务使用此事务隔离级别。

对于某些 RowSet 实现，如在非连接环境中操作的 CachedRowSet，所用的 SyncProvider 对象提供了互补的锁定和数据完整性选项。以下描述的选项仅与连接的 RowSet 对象（JdbcRowSet 对象）有关。

参数：
level - 以下常量之一，按升序列出：Connection.TRANSACTION_NONE、Connection.TRANSACTION_READ_UNCOMMITTED、Connection.TRANSACTION_READ_COMMITTED、Connection.TRANSACTION_REPEATABLE_READ 或 Connection.TRANSACTION_SERIALIZABLE
抛出：
SQLException - 如果给定的参数不是 Connection 常量之一
另请参见：
SyncFactory, SyncProvider, getTransactionIsolation()

getTypeMap

public Map<String,Class<?>> getTypeMap()
获取与此 RowSet 对象的 Connection 对象关联的类型映射表。

支持 JDBC 3.0 API 的驱动程序将创建具有关联类型映射表的 Connection 对象。此类型映射表（初始为空）可以包含一个或多个完全限定的 SQL 名，以及指示命名 SQL 值所要映射的类的 Class 对象。当没有其他类型映射取代自定义类型映射时，在连接的类型映射表中指定的类型映射将用做自定义类型映射。

如果向可以执行自定义映射的方法显式提供类型映射表，则该类型映射表将取代连接的类型映射表。

返回：
java.util.Map 对象，它是此 RowSet 对象连接的类型映射表

setTypeMap

public void setTypeMap(Map<String,Class<?>> map)
将给定的 java.util.Map 对象安装为与此 RowSet 对象的 Connection 对象关联的类型映射表。如果为方法显式提供了不同的类型映射表，则使用提供的类型映射表，否则将使用此类型映射表中所指示的自定义映射。

参数：
map - 一个 java.util.Map 对象，包含用户定义类型 (UDT) 的 SQL 类型名称到 Java 编程语言中类的映射。Map 对象中每一项都由 UDT 的完全限定 SQL 名称和用于该 UDT 的 SQLData 实现的 Class 对象组成。可以为 null。

getMaxFieldSize

public int getMaxFieldSize()
                    throws SQLException
获取可用于此 RowSet 对象列值的最大字节数。此限制仅适用于包含以下类型值的列：BINARY、VARBINARY、LONGVARBINARY、CHAR、VARCHAR 和 LONGVARCHAR。如果超过了该限制，则正常丢弃多出的数据。

返回：
指示当前最大列大小限制的 int 值；0 表示没有限制
抛出：
SQLException - 如果确定列大小的最大限制时内部发生错误

setMaxFieldSize

public void setMaxFieldSize(int max)
                     throws SQLException
将可用于此 RowSet 对象列值的最大字节数设置为给定数。此限制仅适用于包含以下类型值的列：BINARY、VARBINARY、LONGVARBINARY、CHAR、VARCHAR 和 LONGVARCHAR。如果超过了该限制，则正常丢弃多出的数据。为了获得最大的可移植性，建议使用大于 256 的值。

参数：
max - 指示新的最大列大小限制的 int 值；0 表示没有限制
抛出：
SQLException - 如果 (1) 设置最大列大小限制时内部发生错误 (2) 设置的大小小于 0

getMaxRows

public int getMaxRows()
               throws SQLException
获取此 RowSet 对象可以包含的最大行数。如果超过了此限制，则正常撤消多出的行。

返回：
指示当前最大行数的 int 值；0 表示没有限制
抛出：
SQLException - 如果确定 Rowset 对象可以包含的最大行数限制时内部发生错误

setMaxRows

public void setMaxRows(int max)
                throws SQLException
将此 RowSet 对象可以包含的最大行数设置为给定数。如果超过了此限制，则正常撤消多出的行。

参数：
max - 指示当前最大行数的 int 值；0 表示没有限制
抛出：
SQLException - 如果设置 JDBC RowSet 对象可以包含的最大行数限制时内部发生错误；如果 max 小于 0；如果 max 小于 RowSet 的 fetchSize

setEscapeProcessing

public void setEscapeProcessing(boolean enable)
                         throws SQLException
设置为给定的 boolean 值，指示将 SQL 语句发送到数据库之前，驱动程序是否扫描转义语法并进行转义替换。默认值是驱动程序执行转义处理。

注：因为 PreparedStatement 对象通常在调用此方法之前解析，所以对准备的语句禁用转义处理无效。

参数：
enable - 为 true 表示启用转义处理；为 false 表示禁用该处理
抛出：
SQLException - 如果设置底层启用 JDBC 技术的驱动程序处理转义语法时发生错误

getQueryTimeout

public int getQueryTimeout()
                    throws SQLException
获取驱动程序等待查询执行的最大秒数。如果超过该限制，则抛出 SQLException。

返回：
当前的查询超时限制，以秒为单位；0 表示没有限制
抛出：
SQLException - 如果确定查询超时值时发生错误

setQueryTimeout

public void setQueryTimeout(int seconds)
                     throws SQLException
将驱动程序等待查询执行的最大秒数设置为给定的数。如果超过该限制，则抛出 SQLException。

参数：
seconds - 新的查询超时限制，以秒为单位；0 表示没有限制；不得小于 0
抛出：
SQLException - 如果设置查询超时值时发生错误，如果查询超时值小于 0

getShowDeleted

public boolean getShowDeleted()
                       throws SQLException
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。默认值为 false。

注：允许保持已删除行可见会使某些方法的行为变得复杂。但是，多数 RowSet 对象的用户可以简单地忽略此额外细节，因为只有极其特殊的应用程序才会利用此功能。

返回：
如果已删除行是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果确定已删除行是否可见时发生错误
另请参见：
setShowDeleted(boolean)

setShowDeleted

public void setShowDeleted(boolean value)
                    throws SQLException
将属性 showDeleted 设置为给定的 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。

参数：
value - 如果已删除行是可见的，则为 true；否则为 false
抛出：
SQLException - 如果设置已删除行是否可见时发生错误
另请参见：
getShowDeleted()

getEscapeProcessing

public boolean getEscapeProcessing()
                            throws SQLException
确定是否为此 RowSet 对象启用了转义处理。

返回：
如果开启了转义处理，则返回 true；否则返回 false
抛出：
SQLException - 如果在确定是否启用转义处理时发生错误，或者尚未启用内部转义处理触发器

setFetchDirection

public void setFetchDirection(int direction)
                       throws SQLException
为驱动程序提供一个性能提示，该提示指示处理此 RowSet 对象中各行时使用的方向。驱动程序可以忽略此提示。

RowSet 对象继承它从中获取数据的 ResultSet 对象的默认属性。该 ResultSet 对象的默认获取方向由创建它的 Statement 对象设置。

仅在 RowSet 对象已使用 JDBC 驱动程序连接到数据库时，此方法才适用。

RowSet 对象可在任何时间使用此方法来更改其有关获取方向的设置。

参数：
direction - ResultSet.FETCH_FORWARD、ResultSet.FETCH_REVERSE 或 ResultSet.FETCH_UNKNOWN 之一
抛出：
SQLException - 如果 (1) RowSet 类型是 TYPE_FORWARD_ONLY 并且给定的获取方向不是 FETCH_FORWARD (2) 给定的获取方向不是以下值之一：ResultSet.FETCH_FORWARD、ResultSet.FETCH_REVERSE 或 ResultSet.FETCH_UNKNOWN
另请参见：
getFetchDirection()

getFetchDirection

public int getFetchDirection()
                      throws SQLException
获取此 RowSet 对象的当前有关获取方向的设置。默认类型是 ResultSet.FETCH_FORWARD。

返回：
ResultSet.FETCH_FORWARD、ResultSet.FETCH_REVERSE 或 ResultSet.FETCH_UNKNOWN 之一
抛出：
SQLException - 如果确定获取行的当前获取方向时发生错误
另请参见：
setFetchDirection(int)

setFetchSize

public void setFetchSize(int rows)
                  throws SQLException
将此 RowSet 对象的获取大小设置为给定的行数。获取大小为启用 JDBC 技术的驱动程序（“JDBC 驱动程序”）提供了一个提示，该提示指示此 RowSet 对象还需要行时应该从数据库获取的行数。如果指定的获取大小为 0，则驱动程序忽略该值，随意对获取大小作出它自己的最佳猜测。

RowSet 对象继承它从中获取数据的 ResultSet 对象的默认属性。该 ResultSet 对象的默认获取大小由创建它的 Statement 对象设置。

仅在 RowSet 对象已使用 JDBC 驱动程序连接到数据库时，此方法才适用。对于连接的 RowSet 实现（如 JdbcRowSet），此方法对底层 JDBC 驱动程序直接并立即产生影响。

RowSet 对象可在任何时间使用此方法来更改其有关获取大小的设置。

对于某些 RowSet 实现，如在非连接环境中操作的 CachedRowSet，正在使用的 SyncProvider 对象可以利用获取大小来轮询数据源、获取不超过该获取大小的多个行，以及获取可以形成原始查询所返回的实际行子集的多个行。这种实现的变化由非连接 RowSet 对象所使用的具体 SyncProvider 对象确定。

参数：
rows - 要获取的行数；0 让驱动程序决定最佳的获取大小；不得小于 0 或大于此 RowSet 对象允许的最大行数（调用方法 getMaxRows() 返回的数目）
抛出：
SQLException - 如果指定的获取大小小于 0 或大于最大行数限制
另请参见：
getFetchSize()

getFetchSize

public int getFetchSize()
                 throws SQLException
返回此 RowSet 对象的获取大小。默认值为 0。

返回：
当此 RowSet 对象还需要从数据库获取行时，建议作为获取大小的行数
抛出：
SQLException - 如果确定当前获取大小中的行数时发生错误
另请参见：
setFetchSize(int)

getConcurrency

public int getConcurrency()
                   throws SQLException
返回此 RowSet 对象的并发性。对于连接和非连接 RowSet 对象而言，默认值都是 CONCUR_UPDATABLE。

应用程序可以在任何时间调用方法 setConcurrency 来更改 RowSet 对象的并发性。

返回：
此 RowSet 对象的并发性类型，必须是以下值之一：ResultSet.CONCUR_READ_ONLY 或 ResultSet.CONCUR_UPDATABLE
抛出：
SQLException - 如果获得此 RowSet 对象的并发性时发生错误
另请参见：
setConcurrency(int), isReadOnly()

setNull

public void setNull(int parameterIndex,
                    int sqlType)
             throws SQLException
将指定参数设置为 SQL NULL。注意，必须使用 java.sql.Types 中定义的某个类型代码指定参数的 SQL 类型。在第二个参数中指定此 SQL 类型。

注意，第二个参数告知 DBMS 值的数据类型被设置为 NULL。某些 DBMS 需要此信息，所以为了使代码更容易移植，此信息是必需的。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setNull 后再调用方法 getParams 将返回一个 Object 数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素为 null。第二个元素是为 sqlType 设置的值。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果将第二个占位符参数设置为 null，则包含该值的数组是 getParams 返回的数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
sqlType - 一个 int 值，是类 Types 中定义的 SQL 类型代码之一。如果提供了非标准的 sqlType，则此方法不会抛出 SQLException。这隐含着对非标准 SQL 类型的支持。
抛出：
SQLException - 如果发生数据库访问错误或者给定的参数索引超出范围
另请参见：
getParams()

setNull

public void setNull(int parameterIndex,
                    int sqlType,
                    String typeName)
             throws SQLException
将指定参数设置为 SQL NULL。 虽然这种形式的 setNull 方法用于用户定义的参数和 REF 参数，但是也可使用此方法设置任意 JDBC 类型的 null 参数。以下是用户定义的类型：STRUCT、DISTINCT、JAVA_OBJECT 和指定数组类型。

注：为了便于移植，在指定 NULL 用户定义参数或 REF 参数时，应用程序必须提供 SQL 类型代码和完全限定的 SQL 类型名称。在用户定义类型的情况下，名称是参数本身的类型名称。对于 REF 参数，名称是所引用类型的类型名称。如果启用 JDBC 技术的驱动程序不需要类型代码和类型名称信息，那么它可以忽略这些信息。

如果该参数没有用户定义的类型或 REF 类型，则忽略给定的 typeName 参数。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setNull 后再调用方法 getParams 将返回一个 Object 数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素为 null。第二个元素是为 sqlType 设置的值，第三个元素是为 typeName 设置的值。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果将第二个占位符参数设置为 null，则包含该值的数组是 getParams 返回的数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
sqlType - java.sql.Types 中的值
typeName - SQL 用户定义类型的完全限定名，如果该参数不是用户定义类型或 REF 值，则忽略该参数
抛出：
SQLException - 如果发生错误或者给定的参数索引超出范围
另请参见：
getParams()

setBoolean

public void setBoolean(int parameterIndex,
                       boolean x)
                throws SQLException
将指定参数设置为 Java 编程语言中的给定 boolean 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL BIT 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setByte

public void setByte(int parameterIndex,
                    byte x)
             throws SQLException
将指定参数设置为 Java 编程语言中的给定 byte 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL TINYINT 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setShort

public void setShort(int parameterIndex,
                     short x)
              throws SQLException
将指定参数设置为 Java 编程语言中的给定 short 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL SMALLINT 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setInt

public void setInt(int parameterIndex,
                   int x)
            throws SQLException
将指定参数设置为 Java 编程语言中的 int 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL INTEGER 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setLong

public void setLong(int parameterIndex,
                    long x)
             throws SQLException
将指定参数设置为 Java 编程语言中的给定 long 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL BIGINT 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setFloat

public void setFloat(int parameterIndex,
                     float x)
              throws SQLException
将指定参数设置为 Java 编程语言中的给定 float 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL FLOAT 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setDouble

public void setDouble(int parameterIndex,
                      double x)
               throws SQLException
将指定参数设置为 Java 编程语言中的给定 double 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL DOUBLE 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setBigDecimal

public void setBigDecimal(int parameterIndex,
                          BigDecimal x)
                   throws SQLException
将指定参数设置为给定的 java.lang.BigDecimal 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL NUMERIC 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setString

public void setString(int parameterIndex,
                      String x)
               throws SQLException
将指定参数设置为给定的 String 值。在将此值发送给数据库时，驱动程序将它转换成一个 SQL VARCHAR 或 LONGVARCHAR 值（取决于该参数相对于驱动程序在 VARCHAR 值上的限制的相对大小）。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setBytes

public void setBytes(int parameterIndex,
                     byte[] x)
              throws SQLException
将指定参数设置为给定的 byte 数组。在将此值发送给数据库时，驱动程序将它转换成一个 SQL VARBINARY 或 LONGVARBINARY 值（取决于该参数相对于驱动程序在 VARBINARY 值上的限制的相对大小）。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setDate

public void setDate(int parameterIndex,
                    Date x)
             throws SQLException
将指定参数设置为给定的 java.sql.Date 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL DATE 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setDate 后再调用方法 getParams 将返回一个数组，其中要为占位符参数编号 parameterIndex 设置的值是作为第二个参数提供的 Date 对象。注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 参数值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setTime

public void setTime(int parameterIndex,
                    Time x)
             throws SQLException
将指定参数设置为给定的 java.sql.Time 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL TIME 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setTime 方法后再调用方法 getParams 将返回一个已经设置的参数所组成的数组。要为参数占位符编号 parameterIndex 进行设置的参数是设置为此方法第二个参数的 Time 对象。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 一个 java.sql.Time 对象，将设置为占位符参数 parameterIndex 的值
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setTimestamp

public void setTimestamp(int parameterIndex,
                         Timestamp x)
                  throws SQLException
将指定参数设置为给定的 java.sql.Timestamp 值。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL TIMESTAMP 值。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setTimestamp 后再调用方法 getParams 将返回一个数组，其中占位符参数编号 parameterIndex 的值是作为此方法第二个参数提供的 Timestamp 对象。注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 一个 java.sql.Timestamp 对象
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setAsciiStream

public void setAsciiStream(int parameterIndex,
                           InputStream x,
                           int length)
                    throws SQLException
将指定参数设置为给定的 java.io.InputStream 对象，该对象将具有指定的字节数。将读取该流的内容并发送到数据库。如果读取并发送到数据库的字节数不等于 length，则此方法抛出 SQLException 对象。

在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 对象将它发送给参数可能更实际一些。在到达文件末尾之前，启用 JDBC 技术的驱动程序将根据需要从该流读取数据。驱动程序将执行从 ASCII 到数据库 CHAR 格式的任何必要转换。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用 setAsciiStream 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 java.io.InputStream 对象。第二个元素是为 length 设置的值。第三个元素是内部 BaseRowSet 常量，指示传递到此方法的流是一个 ASCII 流。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的输入流是第二个占位符参数的值，则包含该值的数组将是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数。这是驱动程序要发送到 DBMS 的字节数；长度为 0 或小于 0 是未定义的，但会导致在底层 JDBC 驱动程序中抛出无效长度异常。
抛出：
SQLException - 如果发生错误、参数索引超出范围，或者当连接到数据源时，驱动程序读取和发送到数据库的字节数不等于 length 中指定的字节数
另请参见：
getParams()

setAsciiStream

public void setAsciiStream(int parameterIndex,
                           InputStream x)
                    throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定输入流。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setAsciiStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含 ASCII 参数值的 Java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

public void setBinaryStream(int parameterIndex,
                            InputStream x,
                            int length)
                     throws SQLException
将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。将读取该流的内容并发送到数据库。如果读取并发送到数据库的字节数不等于 length，则此方法抛出 SQLException 对象。

在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。在到达文件末尾之前，启用 JDBC 技术的驱动程序将根据需要从该流读取数据。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用 setBinaryStream 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 java.io.InputStream 对象。第二个元素是为 length 设置的值。第三个元素是内部 BaseRowSet 常量，指示传递到此方法的流是一个二进制流。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的输入流是第二个占位符参数的值，则包含该值的数组将是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 包含要设置的二进制值的输入流
length - 流中的字节数；长度为 0 或小于 0 是未定义的，但会导致在底层 JDBC 驱动程序中抛出无效长度异常。
抛出：
SQLException - 如果发生错误、参数索引超出范围，或者当连接到数据源时，驱动程序读取和发送到数据库的字节数不等于 length 中指定的字节数
另请参见：
getParams()

setBinaryStream

public void setBinaryStream(int parameterIndex,
                            InputStream x)
                     throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定输入流。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBinaryStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 包含二进制参数值的 java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setUnicodeStream

public void setUnicodeStream(int parameterIndex,
                             InputStream x,
                             int length)
                      throws SQLException
已过时。 应该使用 getCharacterStream 替代它

将指定参数设置为给定的 java.io.InputStream 对象，该对象具有指定的字节数。将读取该流的内容并发送到数据库。如果读取和发送到数据库的字节数不等于 length，则此方法抛出 SQLException。

在将一个非常大的 Unicode 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 对象发送它可能更为实际。在到达文件末尾之前，启用 JDBC 技术的驱动程序将根据需要从该流读取数据。驱动程序将执行从 Unicode 到数据库 CHAR 格式的任何必要转换。Unicode 流的字节格式必须是 Java UTF-8，这在 Java 虚拟机规范中定义。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

此方法已废弃，应该使用 getCharacterStream 替代它。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。调用 setUnicodeStream 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 java.io.InputStream 对象。第二个元素是为 length 设置的值。第三个元素是内部 BaseRowSet 常量，指示传递到此方法的流是一个 Unicode 流。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的输入流是第二个占位符参数的值，则包含该值的数组将是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 包含 UNICODE 参数值的 java.io.InputStream 对象
length - 输入流中的字节数
抛出：
SQLException - 如果发生错误、参数索引超出范围，或者驱动程序读取和发送到数据库的字节数不等于 length 中指定的字节数
另请参见：
getParams()

setCharacterStream

public void setCharacterStream(int parameterIndex,
                               Reader reader,
                               int length)
                        throws SQLException
将指定参数设置为给定的 java.io.Reader 对象，该对象具有指定的字符数。将读取该 reader 的内容并发送到数据库。如果读取和发送到数据库的字节数不等于 length，则此方法抛出 SQLException。

在将一个非常大的 Unicode 值输入到 LONGVARCHAR 参数时，通过 Reader 对象发送它可能更为实际。在到达文件末尾之前，启用 JDBC 技术的驱动程序将根据需要从该流读取数据。驱动程序将执行从 Unicode 到数据库 CHAR 格式的任何必要转换。Unicode 流的字节格式必须是 Java UTF-8，这在 Java 虚拟机规范中定义。

注：此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用 setCharacterStream 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 java.io.Reader 对象。第二个元素是为 length 设置的值。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的 reader 是第二个占位符参数的值，则包含该值的数组将是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
reader - 包含 Unicode 数据的 Reader 对象
length - 流中的字符数；长度为 0 或小于 0 是未定义的，但会导致在底层 JDBC 驱动程序中抛出无效长度异常。
抛出：
SQLException - 如果发生错误、参数索引超出范围，或者当连接到数据源时，驱动程序读取和发送到数据库的字节数不等于 length 中指定的字节数
另请参见：
getParams()

setCharacterStream

public void setCharacterStream(int parameterIndex,
                               Reader reader)
                        throws SQLException
将此 RowSet 对象命令中的指定参数设置为给定的 Reader 对象。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setCharacterStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含 Unicode 数据的 java.io.Reader 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setObject

public void setObject(int parameterIndex,
                      Object x,
                      int targetSqlType,
                      int scale)
               throws SQLException
将指定参数设置为 Java 编程语言中的 Object。第二个参数必须是 Object 类型。对于整数值，应该使用 java.lang 等效对象。例如，为 int 使用类 Integer。

将此对象发送到数据库前，驱动程序将它转换成指定的目标 SQL 类型。如果对象具有自定义映射（属于实现 SQLData 的类），则驱动程序应该调用 SQLData.writeSQL 方法将该对象写入 SQL 数据流中。另一方面，如果该对象是实现 Ref、Blob、Clob、Struct 或 Array 的类，则驱动程序应该将它作为相应 SQL 类型的值传递给数据库。

注意，此方法可用于传递特定于数据库的抽象数据类型。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。调用这种形式的 setObject 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 Object 实例。第二个元素是为 targetSqlType 设置的值。第三个元素是为 scale 设置的值，如果要设置的对象类型不是 java.sql.Types.NUMERIC 或 java.sql.Types.DECIMAL，则驱动程序忽略该值。参数编号由方法 getParams 返回的数组中的元素位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的对象是第二个占位符参数的值，则包含该值的数组是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 包含输入参数值的 Object；必须是 Object 类型
targetSqlType - 要发送到数据库的 SQL 类型（在 java.sql.Types 中定义）。scale 参数可以进一步限定此类型。如果提供了非标准的 targetSqlType，则此方法不会抛出 SQLException。这隐含着对非标准 SQL 类型的支持。
scale - 对于类型 java.sql.Types.DECIMAL 和 java.sql.Types.NUMERIC，该值是小数点后的位数。对于所有其他类型，将忽略此值。
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setObject

public void setObject(int parameterIndex,
                      Object x,
                      int targetSqlType)
               throws SQLException
使用给定 Object 值设置指定参数的值。此方法类似于 setObject(int parameterIndex, Object x, int targetSqlType, int scale)，不同之处在于它假定 scale 为 0。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setObject 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 Object 实例。第二个元素是为 targetSqlType 设置的值。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的对象是第二个占位符参数的值，则包含该值的数组是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 包含输入参数值的 Object；必须是 Object 类型
targetSqlType - 要发送到数据库的 SQL 类型（在 java.sql.Types 中定义）。如果提供了非标准的 targetSqlType，则此方法不会抛出 SQLException。这隐含着对非标准 SQL 类型的支持。
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setObject

public void setObject(int parameterIndex,
                      Object x)
               throws SQLException
将指定参数设置为 Java 编程语言中的 Object。第二个参数必须是 Object 类型。对于整数值，应该使用 java.lang 等效对象。例如，为 int 使用类 Integer。

JDBC 规范定义了一个从 Java Object 类型到 SQL 类型的标准映射。在将给定的对象发送到数据库之前，驱动程序使用此标准映射将其转换为对应的 SQL 类型。如果对象具有自定义映射（属于实现 SQLData 的类），则驱动程序应该调用 SQLData.writeSQL 方法将该对象写入 SQL 数据流中。

另一方面，如果该对象是实现 Ref、Blob、Clob、Struct 或 Array 的类，则驱动程序应该将它作为相应 SQL 类型的值传递给数据库。

如果出现混淆，例如如果该对象是实现多个接口的类，则此方法抛出异常。

注意，此方法可用于传递特定于数据库的抽象数据类型。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用此方法后再调用方法 getParams 将返回一个当前命令参数的 object 数组，其中包括已为占位符参数编号 parameterIndex 设置的 Object。注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 包含输入参数值的对象
抛出：
SQLException - 如果发生错误、参数索引超出范围，或者在要设置的对象实现方面存在混淆
另请参见：
getParams()

setRef

public void setRef(int parameterIndex,
                   Ref ref)
            throws SQLException
将指定参数设置为 Java 编程语言中的给定 Ref 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL REF 值。在内部，该 Ref 被表示成 SerialRef，以确保可序列化性。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用此方法后再调用方法 getParams 将返回一个当前命令参数的 object 数组，其中包括已为占位符参数编号 parameterIndex 设置的 Ref 对象。注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
ref - 表示 SQL REF 值的 Ref 对象；不能为 null
抛出：
SQLException - 如果发生错误、参数索引超出范围，或者 Ref 对象为 null；或者 Ref 对象返回 null 基本类型名称。
另请参见：
getParams(), SerialRef

setBlob

public void setBlob(int parameterIndex,
                    Blob x)
             throws SQLException
将指定参数设置为 Java 编程语言中的给定 Blob 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL BLOB 值。在内部，该 Blob 被表示成 SerialBlob，以确保可序列化性。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用此方法后再调用方法 getParams 将返回一个当前命令参数的 object 数组，其中包括已为占位符参数编号 parameterIndex 设置的 Blob 对象。注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 表示 SQL BLOB 值的 Blob 对象
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams(), SerialBlob

setClob

public void setClob(int parameterIndex,
                    Clob x)
             throws SQLException
将指定参数设置为 Java 编程语言中的给定 Clob 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL CLOB 值。在内部，该 Clob 被表示成 SerialClob，以确保可序列化性。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用此方法后再调用方法 getParams 将返回一个当前命令参数的 object 数组，其中包括已为占位符参数编号 parameterIndex 设置的 Clob 对象。注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 表示 SQL CLOB 值的 Clob 对象；不能为 null
抛出：
SQLException - 如果发生错误、参数索引超出范围，或者 Clob 为 null
另请参见：
getParams(), SerialBlob

setArray

public void setArray(int parameterIndex,
                     Array array)
              throws SQLException
将指定参数设置为 Java 编程语言中的 Array 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL ARRAY 值。在内部，该 Array 被表示成 SerialArray，以确保可序列化性。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用此方法后再调用方法 getParams 将返回一个当前命令参数的 object 数组，其中包括已为占位符参数编号 parameterIndex 设置的 Array 对象。注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是元素编号 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
array - 表示 SQL ARRAY 值的 Array 对象，不能为 null。传递到此方法的 Array 对象必须对所有调用的 getArray() 方法返回非 null 的 Object。null 值将导致抛出 SQLException。
抛出：
SQLException - 如果发生错误、参数索引超出范围或者 ARRAY 为 null
另请参见：
getParams(), SerialArray

setDate

public void setDate(int parameterIndex,
                    Date x,
                    Calendar cal)
             throws SQLException
将指定参数设置为给定的 java.sql.Date 对象。当 DBMS 不存储时区信息时，驱动程序将使用给定的 Calendar 对象构造要发送到数据库的 SQL DATE 值。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算日期。如果没有指定任何 Calendar 对象，则驱动程序使用运行应用程序的虚拟机所在的时区。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setDate 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 java.sql.Date 对象。第二个元素是为 cal 设置的值。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的 date 是第二个占位符参数的值，则包含该值的数组是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 表示 SQL DATE 值的 java.sql.Date 对象
cal - 构造日期时所使用的 java.util.Calendar 对象
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setTime

public void setTime(int parameterIndex,
                    Time x,
                    Calendar cal)
             throws SQLException
将指定参数设置为给定的 java.sql.Time 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL TIME 值。

当 DBMS 不存储时区信息时，驱动程序将使用给定的 Calendar 对象构造要发送到数据库的 SQL TIME 值。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算日期。如果没有指定任何 Calendar 对象，则驱动程序使用运行应用程序的虚拟机所在的时区。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setTime 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 java.sql.Time 对象。第二个元素是为 cal 设置的值。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的 time 是第二个占位符参数的值，则包含该值的数组是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 一个 java.sql.Time 对象
cal - 驱动程序可用来构造时间的 java.util.Calendar 对象
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

setTimestamp

public void setTimestamp(int parameterIndex,
                         Timestamp x,
                         Calendar cal)
                  throws SQLException
将指定参数设置为给定的 java.sql.Timestamp 对象。在将该对象发送到数据库时，驱动程序将它转换成一个 SQL TIMESTAMP 值。

当 DBMS 不存储时区信息时，驱动程序将使用给定的 Calendar 对象构造要发送到数据库的 SQL TIMESTAMP 值。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算 timestamp。如果没有指定任何 Calendar 对象，则驱动程序使用运行应用程序的虚拟机所在的时区。

此方法设置的参数值是内部存储的，当调用方法 execute 时，将该值作为此 RowSet 对象命令中的适当参数提供。必须在扩展此类和实现了一个或多个标准 JSR-114 RowSet 接口的所有类中提供 execute 和 populate 之类的方法。

注：JdbcRowSet 不需要 populate 方法，因为它没有在此类中定义。

调用这种形式的 setTimestamp 后再调用方法 getParams 将返回一个数组，其中包含已经设置的参数值。在该数组中，表示使用此方法所设置的值的元素本身也是一个数组。该数组的第一个元素是给定的 java.sql.Timestamp 对象。第二个元素是为 cal 设置的值。参数编号由方法 getParams 返回的数组中元素的位置指示，第一个元素是第一个占位符参数的值，第二个元素是第二个占位符参数的值，依此类推。换句话说，如果正在设置的 timestamp 是第二个占位符参数的值，则包含该值的数组是 getParams 返回数组中的第二个元素。

注意，因为数组中的元素编号从 0 开始，所以对应于占位符参数编号 parameterIndex 的数组元素是 parameterIndex -1。

参数：
parameterIndex - 此 RowSet 对象命令中要设置的占位符参数的序号。第一个参数是 1，第二个参数是 2，依此类推；必须大于等于 1
x - 一个 java.sql.Timestamp 对象
cal - 驱动程序构造 timestamp 所使用的 java.util.Calendar 对象
抛出：
SQLException - 如果发生错误或者参数索引超出范围
另请参见：
getParams()

clearParameters

public void clearParameters()
                     throws SQLException
清除所有此 RowSet 对象的内部参数表示形式的当前参数值，这些参数值将在执行此 RowSet 对象的命令时在其中设置这些参数。

通常参数值对此 RowSet 对象的重复使用仍然有效。使用设置方法设置参数值可自动清除指定参数的值，并用新的指定值替换该值。

此方法由 setCommand 方法内部调用，以清除前一条命令设置的所有参数。

另外，此方法与 initParams 方法的不同之处在于它保持 RowSet 对象的模式。

抛出：
SQLException - 如果清除参数时发生错误

getParams

public Object[] getParams()
                   throws SQLException
获取一个数组，其中包含为此 RowSet 对象命令设置的参数值（包括 Object 和基本类型），如果尚未设置任何参数，则抛出 SQLException 对象。将命令发送到 DBMS 执行前，这些参数将替换 PreparedStatement 对象中的占位符参数，该对象是用于扩展了 BaseRowSet 类的 RowSet 实现的命令。

返回数组的每个元素都是一个 Object 实例，包含提供给设置方法的参数值。元素的顺序由提供给 parameterIndex 的值确定。如果设置方法仅带有参数索引和要设置的值（可能为 null），则数组元素将包含要设置的值（以 Object 的形式表示）。如果还有附加参数，则数组元素本身就是一个数组，包含要设置的值和所有提供给设置方法的附加参数值。如果该方法设置一个流，则数组元素包括将提供给该方法的流类型。这些附加参数供驱动程序或 DBMS 使用，可以使用这些参数，也可以不使用。

注：类型 Array、Blob、Clob 和 Ref 的已存储参数值分别以 SerialArray、SerialBlob、SerialClob 和 SerialRef 的形式返回。

返回：
Object 实例所组成的数组，包括在此 RowSet 对象的命令中所设置的参数值；如果尚未设置任何参数，则返回空数组
抛出：
SQLException - 如果获取此 RowSet 对象参数的对象数组时发生错误，或者并非所有的参数都已经设置

setNull

public void setNull(String parameterName,
                    int sqlType)
             throws SQLException
将指定参数设置为 SQL NULL。

注： 必须指定参数的 SQL 类型。

参数：
parameterName - 参数的名称
sqlType - java.sql.Types 中定义的 SQL 类型代码
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setNull

public void setNull(String parameterName,
                    int sqlType,
                    String typeName)
             throws SQLException
将指定参数设置为 SQL NULL。这种 setNull 方法应该用于用户定义类型和 REF 类型参数。用户定义类型的示例有：STRUCT、DISTINCT、JAVA_OBJECT 和指定数组类型。

注： 为了便于移植，在指定 NULL 用户定义参数或 REF 参数时，应用程序必须提供 SQL 类型代码和完全限定的 SQL 类型名称。对于用户定义类型，名称是参数本身的类型名称。对于 REF 参数，名称是所引用类型的类型名称。 如果 JDBC 驱动程序不需要类型代码或类型名称信息，那么它可以忽略这些信息。 尽管此方法供用户定义参数和 Ref 参数使用，但也可以使用它来设置任何 JDBC 类型的 null 参数。如果该参数不具有用户定义类型或 REF 类型，则忽略给定 typeName。

参数：
parameterName - 参数的名称
sqlType - 取自 java.sql.Types 的值
typeName - SQL 用户定义类型的完全限定名称；如果该参数不是用户定义类型或 SQL REF 值，则忽略它
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setBoolean

public void setBoolean(String parameterName,
                       boolean x)
                throws SQLException
将指定参数设置为给定的 Java boolean 值。在将此值发送到数据库时，驱动程序将其转换为 SQL BIT 或 BOOLEAN 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getBoolean

setByte

public void setByte(String parameterName,
                    byte x)
             throws SQLException
将指定参数设置为给定的 Java byte 值。在将此值发送到数据库时，驱动程序将其转换为 SQL TINYINT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getByte

setShort

public void setShort(String parameterName,
                     short x)
              throws SQLException
将指定参数设置为给定的 Java short 值。在将此值发送到数据库时，驱动程序将其转换为 SQL SMALLINT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getShort

setInt

public void setInt(String parameterName,
                   int x)
            throws SQLException
将指定参数设置为给定的 Java int 值。在将此值发送到数据库时，驱动程序将其转换为 SQL INTEGER 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getInt

setLong

public void setLong(String parameterName,
                    long x)
             throws SQLException
将指定参数设置为给定的 Java long 值。在将此值发送到数据库时，驱动程序将其转换为 SQL BIGINT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getLong

setFloat

public void setFloat(String parameterName,
                     float x)
              throws SQLException
将指定参数设置为给定的 Java float 值。在将此值发送到数据库时，驱动程序将其转换为 SQL FLOAT 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getFloat

setDouble

public void setDouble(String parameterName,
                      double x)
               throws SQLException
将指定参数设置为给定的 Java double 值。在将此值发送到数据库时，驱动程序将其转换为 SQL DOUBLE 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getDouble

setBigDecimal

public void setBigDecimal(String parameterName,
                          BigDecimal x)
                   throws SQLException
将指定参数设置为给定的 java.math.BigDecimal 值。在将此值发送到数据库时，驱动程序将其转换为 SQL NUMERIC 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getBigDecimal

setString

public void setString(String parameterName,
                      String x)
               throws SQLException
将指定参数设置为给定的 Java String 值。在将此值发送到数据库时，驱动程序将其转换为 SQL VARCHAR 或 LONGVARCHAR 值（具体取决于该参数相对于驱动程序在 VARCHAR 值上的限制的大小）。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getString

setBytes

public void setBytes(String parameterName,
                     byte[] x)
              throws SQLException
将指定参数设置为给定的 Java byte 数组。在将此值发送到数据库时，驱动程序将其转换为 SQL VARBINARY 或 LONGVARBINARY 值（具体取决于该参数相对于驱动程序在 VARBINARY 值上的限制的大小）。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getBytes

setTimestamp

public void setTimestamp(String parameterName,
                         Timestamp x)
                  throws SQLException
将指定参数设置为给定的 java.sql.Timestamp 值。在将此值发送到数据库时，驱动程序将其转换为 SQL TIMESTAMP 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getTimestamp

setAsciiStream

public void setAsciiStream(String parameterName,
                           InputStream x,
                           int length)
                    throws SQLException
将指定参数设置为给定输入流，该输入流将拥有指定字节数。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数的名称
x - 包含 ASCII 参数值的 Java 输入流
length - 流中的字节数
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setBinaryStream

public void setBinaryStream(String parameterName,
                            InputStream x,
                            int length)
                     throws SQLException
将指定参数设置为给定的输入流，该输入流将拥有指定的字节数。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数的名称
x - 包含二进制参数值的 java 输入流
length - 流中的字节数
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setCharacterStream

public void setCharacterStream(String parameterName,
                               Reader reader,
                               int length)
                        throws SQLException
将指定参数设置为给定的 Reader 对象，该对象是给定的字符长度数目。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

参数：
parameterName - 参数的名称
reader - 包含用作指定参数的 UNICODE 数据的 java.io.Reader 对象
length - 流中的字符数
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4

setAsciiStream

public void setAsciiStream(String parameterName,
                           InputStream x)
                    throws SQLException
将指定参数设置为给定的输入流。在将一个非常大的 ASCII 值输入到 LONGVARCHAR 参数时，通过 java.io.InputStream 发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 ASCII 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setAsciiStream 是否更有效。

参数：
parameterName - 参数的名称
x - 包含 ASCII 参数值的 Java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBinaryStream

public void setBinaryStream(String parameterName,
                            InputStream x)
                     throws SQLException
将指定参数设置为给定输入流。在将一个非常大的二进制值输入到 LONGVARBINARY 参数时，通过 java.io.InputStream 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBinaryStream 是否更有效。

参数：
parameterName - 参数的名称
x - 包含二进制参数值的 Java 输入流
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setCharacterStream

public void setCharacterStream(String parameterName,
                               Reader reader)
                        throws SQLException
将指定参数设置为给定 Reader 对象。在将一个非常大的 UNICODE 值输入到 LONGVARCHAR 参数时，通过 java.io.Reader 对象发送它可能更为实际。将根据需要从流中读取数据，一直读取到文件末尾。JDBC 驱动程序将执行从 UNICODE 到数据库 char 格式的任何必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setCharacterStream 是否更有效。

参数：
parameterName - 参数的名称
reader - 包含 Unicode 数据的 java.io.Reader 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNCharacterStream

public void setNCharacterStream(int parameterIndex,
                                Reader value)
                         throws SQLException
将此 RowSet 对象命令中的指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集 (national character set) 的必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNCharacterStream 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误；如果在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setObject

public void setObject(String parameterName,
                      Object x,
                      int targetSqlType,
                      int scale)
               throws SQLException
使用给定对象设置指定参数的值。第二个参数必须是一个对象类型；对于整数值，应该使用 java.lang 的等效对象。

在发送到数据库之前，给定 Java 对象将被转换为给定的 targetSqlType。 如果对象具有自定义映射关系（属于实现 SQLData 接口的类），则 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流中。另一方面，如果对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将其作为相应 SQL 类型的值传递给数据库。

注意，此方法可用于传递特定于数据库的抽象数据类型。

参数：
parameterName - 参数的名称
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（在 java.sql.Types 中定义）。scale 参数可以进一步限定此类型。
scale - 对于 java.sql.Types.DECIMAL 或 java.sql.Types.NUMERIC 类型，该值是小数点后的位数。对于所有其他类型，将忽略此值。
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.4
另请参见：
Types, #getObject

setObject

public void setObject(String parameterName,
                      Object x,
                      int targetSqlType)
               throws SQLException
使用给定对象设置指定参数的值。此方法类似于上面的 setObject 方法，不同之处在于它假定 scale 为 0。

参数：
parameterName - 参数的名称
x - 包含输入参数值的对象
targetSqlType - 将发送给数据库的 SQL 类型（在 java.sql.Types 中定义）
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 targetSqlType 是 ARRAY、BLOB、CLOB、DATALINK、JAVA_OBJECT、NCHAR、NCLOB、NVARCHAR、LONGNVARCHAR、REF、ROWID、SQLXML 或 STRUCT 数据类型并且 JDBC 驱动程序不支持此数据类型
从以下版本开始：
1.4
另请参见：
#getObject

setObject

public void setObject(String parameterName,
                      Object x)
               throws SQLException
使用给定对象设置指定参数的值。第二个参数必须是 Object 类型；所以，应该对内置类型使用 java.lang 的等效对象。

JDBC 规范指定一个从 Java Object 类型到 SQL 类型的标准映射关系。在发送到数据库之前，给定参数将被转换为相应的 SQL 类型。

注意，通过使用特定于驱动程序的 Java 类型，此方法可用于传递特定于数据库的抽象数据类型。 如果对象是实现 SQLData 接口的类，则 JDBC 驱动程序应该调用 SQLData.writeSQL 方法将它写入 SQL 数据流中。另一方面，如果对象是实现 Ref、Blob、Clob、NClob、Struct、java.net.URL 或 Array 的类，则驱动程序应该将其作为相应 SQL 类型的值传递给数据库。

如果出现混淆，例如，此对象是实现多个上述指定接口的类，则此方法抛出异常。

参数：
parameterName - 参数的名称
x - 包含输入参数值的对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 CallableStatement 上调用此方法或者给定 Object 参数不明确
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getObject

setBlob

public void setBlob(int parameterIndex,
                    InputStream inputStream,
                    long length)
             throws SQLException
将指定参数设置为 InputStream 对象。inputstream 必须包含 length 所指定的字符数，否则，在执行 PreparedStatement 时将生成 SQLException。此方法不同于 setBinaryStream (int, InputStream, int) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
inputStream - 包含用来设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果发生数据库访问错误；如果在关闭的 PreparedStatement 上调用此方法；如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0 或者 inputstream 中的字节数不匹配指定长度。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

public void setBlob(int parameterIndex,
                    InputStream inputStream)
             throws SQLException
将指定参数设置为 InputStream 对象。此方法不同于 setBinaryStream (int, InputStream) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBlob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
inputStream - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 PreparedStatement 上调用此方法或者 parameterIndex 不对应 SQL 语句中的参数标记
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

public void setBlob(String parameterName,
                    InputStream inputStream,
                    long length)
             throws SQLException
将指定参数设置为 InputStream 对象。 inputstream 必须包含 length 所指定的字符数，否则，在执行 CallableStatement 时将生成 SQLException。此方法不同于 setBinaryStream (int, InputStream, int) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器。

参数：
parameterName - 要设置的参数名称
inputStream - 包含用来设置参数值的数据的对象。
length - 参数数据中的字节数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记，或者指定长度小于 0；如果 inputstream 中的字节数不匹配指定长度；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

public void setBlob(String parameterName,
                    Blob x)
             throws SQLException
将指定参数设置为给定的 java.sql.Blob 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL BLOB 值。

参数：
parameterName - 参数的名称
x - 映射 SQL BLOB 值的 Blob 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setBlob

public void setBlob(String parameterName,
                    InputStream inputStream)
             throws SQLException
将指定参数设置为 InputStream 对象。此方法不同于 setBinaryStream (int, InputStream) 方法，因为它通知驱动程序参数值应该以 BLOB 的形式发送到服务器。使用 setBinaryStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARBINARY 还是 BLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setBlob 是否更有效。

参数：
parameterName - 参数的名称
inputStream - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

public void setClob(int parameterIndex,
                    Reader reader,
                    long length)
             throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 PreparedStatement 时将生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果发生数据库访问错误，或者在关闭的 PreparedStatement 上调用此方法；如果 parameterIndex 不对应 SQL 语句中的参数标记，或者指定长度小于 0。
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

public void setClob(int parameterIndex,
                    Reader reader)
             throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setClob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误，在关闭的 PreparedStatement 上调用此方法或者 parameterIndex 不对应 SQL 语句中的参数标记
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

public void setClob(String parameterName,
                    Reader reader,
                    long length)
             throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 CallableStatement 时将生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

参数：
parameterName - 要设置的参数的名称
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

public void setClob(String parameterName,
                    Clob x)
             throws SQLException
将指定参数设置为给定的 java.sql.Clob 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL CLOB 值。

参数：
parameterName - 参数的名称
x - 映射 SQL CLOB 值的 Clob 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setClob

public void setClob(String parameterName,
                    Reader reader)
             throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序参数值应该以 CLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGVARCHAR 还是 CLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setClob 是否更有效。

参数：
parameterName - 参数的名称
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setDate

public void setDate(String parameterName,
                    Date x)
             throws SQLException
使用运行应用程序的虚拟机所在的默认时区将指定参数设置为给定的 java.sql.Date 值。在将此值发送到数据库时，驱动程序将其转换为 SQL DATE 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getDate

setDate

public void setDate(String parameterName,
                    Date x,
                    Calendar cal)
             throws SQLException
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Date 值。驱动程序使用 Calendar 对象构造一个 SQL DATE 值，该值随后被驱动程序发送到数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算日期。如果没有指定任何 Calendar 对象，则驱动程序使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数的名称
x - 参数值
cal - 驱动程序将用来构造日期的 Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getDate

setTime

public void setTime(String parameterName,
                    Time x)
             throws SQLException
将指定参数设置为给定的 java.sql.Time 值。在将此值发送到数据库时，驱动程序将其转换为 SQL TIME 值。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getTime

setTime

public void setTime(String parameterName,
                    Time x,
                    Calendar cal)
             throws SQLException
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Time 值。驱动程序使用 Calendar 对象构造一个 SQL TIME 值，该值随后被驱动程序发送到数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间。如果没有指定任何 Calendar 对象，则驱动程序使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数的名称
x - 参数值
cal - 驱动程序将用来构造时间的 Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getTime

setTimestamp

public void setTimestamp(String parameterName,
                         Timestamp x,
                         Calendar cal)
                  throws SQLException
使用给定 Calendar 对象将指定参数设置为给定的 java.sql.Timestamp 值。驱动程序使用 Calendar 对象构造一个 SQL TIMESTAMP 值，该值随后被驱动程序发送到数据库。利用 Calendar 对象，驱动程序可以在考虑自定义时区的情况下计算时间戳。如果没有指定任何 Calendar 对象，则驱动程序使用默认时区，该时区是运行应用程序的虚拟机所在的时区。

参数：
parameterName - 参数的名称
x - 参数值
cal - 驱动程序将用来构造时间戳的 Calendar 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
另请参见：
#getTimestamp

setSQLXML

public void setSQLXML(int parameterIndex,
                      SQLXML xmlObject)
               throws SQLException
将指定参数设置为给定 java.sql.SQLXML 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL XML 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
xmlObject - 映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的结果集上调用此方法，没有为 SQLXML 对象关闭 java.xml.transform.Result、Writer 或 OutputStream，或者在处理 XML 值时发生错误。异常的 getCause 方法可以提供更详细的异常，例如，如果该流不包含有效的 XML。
从以下版本开始：
1.6

setSQLXML

public void setSQLXML(String parameterName,
                      SQLXML xmlObject)
               throws SQLException
将指定参数设置为给定的 java.sql.SQLXML 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL XML 值。

参数：
parameterName - 参数的名称
xmlObject - 映射 SQL XML 值的 SQLXML 对象
抛出：
SQLException - 如果发生数据库访问错误，在关闭的结果集上调用此方法，没有为 SQLXML 对象关闭 java.xml.transform.Result、Writer 或 OutputStream，或者在处理 XML 值时发生错误。异常的 getCause 方法可以提供更详细的异常，例如，如果该流不包含有效的 XML。
从以下版本开始：
1.6

setRowId

public void setRowId(int parameterIndex,
                     RowId x)
              throws SQLException
将指定参数设置为给定的 java.sql.RowId 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL ROWID 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

setRowId

public void setRowId(String parameterName,
                     RowId x)
              throws SQLException
将指定参数设置为给定的 java.sql.RowId 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL ROWID。

参数：
parameterName - 参数的名称
x - 参数值
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

setNString

public void setNString(int parameterIndex,
                       String value)
                throws SQLException
将指定参数设置为给定的 String 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR 值（具体取决于该参数相对于驱动程序在 NVARCHAR 值上的限制的大小）。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNString

public void setNString(String parameterName,
                       String value)
                throws SQLException
将指定参数设置为给定的 String 对象。驱动程序将此值转换为 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR

参数：
parameterName - 要设置的列的名称
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNCharacterStream

public void setNCharacterStream(int parameterIndex,
                                Reader value,
                                long length)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集的必要转换。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
length - 参数数据中的字符数。
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNCharacterStream

public void setNCharacterStream(String parameterName,
                                Reader value,
                                long length)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集的必要转换。

参数：
parameterName - 要设置的列的名称
value - 参数值
length - 参数数据中的字符数。
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNCharacterStream

public void setNCharacterStream(String parameterName,
                                Reader value)
                         throws SQLException
将指定参数设置为 Reader 对象。Reader 读取数据，一直读取到文件末尾。驱动程序将执行从 Java 字符格式到数据库中国家字符集的必要转换。

注： 此流对象既可以是一个标准 Java 流对象，也可以是实现标准接口的用户自己的子类。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNCharacterStream 是否更有效。

参数：
parameterName - 参数的名称
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误；或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

public void setNClob(String parameterName,
                     NClob value)
              throws SQLException
将指定参数设置为 java.sql.NClob 对象。该对象实现 java.sql.NClob 接口。此 NClob 对象映射到 SQL NCLOB。

参数：
parameterName - 要设置的列的名称
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNClob

public void setNClob(String parameterName,
                     Reader reader,
                     long length)
              throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 CallableStatement 时将生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器。

参数：
parameterName - 要设置的参数的名称
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

public void setNClob(String parameterName,
                     Reader reader)
              throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器。

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNClob 是否更有效。

参数：
parameterName - 参数的名称
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 CallableStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

public void setNClob(int parameterIndex,
                     Reader reader,
                     long length)
              throws SQLException
将指定参数设置为 Reader 对象。reader 必须包含 length 所指定的字符数，否则，在执行 PreparedStatement 时将会生成 SQLException。此方法不同于 setCharacterStream (int, Reader, int) 方法，因为它通知驱动程序参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
length - 参数数据中的字符数。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果指定长度小于 0；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setNClob

public void setNClob(int parameterIndex,
                     NClob value)
              throws SQLException
将指定参数设置为 java.sql.NClob 对象。在将此值发送到数据库时，驱动程序将其转换为 SQL NCLOB 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
value - 参数值
抛出：
SQLException - 如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；或者发生数据库访问错误
从以下版本开始：
1.6

setNClob

public void setNClob(int parameterIndex,
                     Reader reader)
              throws SQLException
将指定参数设置为 Reader 对象。此方法不同于 setCharacterStream (int, Reader) 方法，因为它通知驱动程序参数值应该以 NCLOB 的形式发送到服务器。使用 setCharacterStream 方法时，驱动程序必须做额外的工作来确定参数数据是以 LONGNVARCHAR 还是 NCLOB 的形式发送到服务器

注： 请参考 JDBC 驱动程序文档确定使用带有长度参数的 setNClob 是否更有效。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
reader - 包含用来设置参数值的数据的对象。
抛出：
SQLException - 如果 parameterIndex 不对应 SQL 语句中的参数标记；如果驱动程序不支持国家字符集；如果驱动程序检测到可能发生数据转换错误；如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

setURL

public void setURL(int parameterIndex,
                   URL x)
            throws SQLException
将指定参数设置为给定的 java.net.URL 值。在将此值发送到数据库时，驱动程序将其转换为 SQL DATALINK 值。

参数：
parameterIndex - 第一个参数的索引是 1，第二个参数的索引是 2 ……
x - 要设置的 java.net.URL 对象
抛出：
SQLException - 如果发生数据库访问错误或者在关闭的 PreparedStatement 上调用此方法
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


CachedRowSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
接口 CachedRowSet

所有超级接口：
Joinable, ResultSet, RowSet, Wrapper
所有已知子接口：
FilteredRowSet, JoinRowSet, WebRowSet
public interface CachedRowSet
extends RowSet, Joinable

所有标准 CachedRowSet 实现都必须实现的接口。

Sun Microsystems 提供的 CachedRowSet 接口的参考实现是一个标准实现。开发人员可以按原样使用此实现、可以扩展它，也可以选择自己编写此接口的实现。

CachedRowSet 对象是一个数据行的容器，可在内存中缓存其各行，这使得进行操作时无需总是连接到数据源。此外，它还是一个 JavaBeansTM 组件，是可滚动、可更新、可序列化的。CachedRowSet 对象通常包含结果集中的行，但它也可以包含任何具有表格式的文件（如电子表格）中的行。参考实现只支持从 ResultSet 对象中获取数据，但是开发人员可以扩展 SyncProvider 实现，以提供对其他表格数据源的访问。

应用程序可以修改 CachedRowSet 对象中的数据，这些修改随后可以被传播回数据源。

CachedRowSet 对象是一个非连接 rowset，这意味着它只会短暂地连接其数据源。连接数据源发生在读取数据以用各行填充自身，以及将更改传播回其底层数据源时。其余时间 CachedRowSet 对象是非连接的，包括修改它的数据时。非连接使 RowSet 对象更为简洁，因此更容易传递给另一个组件。例如，非连接 RowSet 对象可以被序列化并通过导线传递到瘦客户端 (thin client)，如个人数字助理（personal digital assistant，PDA）。

1.0 创建 CachedRowSet 对象

以下代码行使用参考实现 (RI) 中提供的默认 CachedRowSet 构造方法来创建默认的 CachedRowSet 对象。
     CachedRowSetImpl crs = new CachedRowSetImpl();
这一新 CachedRowSet 对象的属性设置为 BaseRowSet 对象的默认属性，此外，它将 RIOptimisticProvider 对象作为其同步提供者。RIOptimisticProvider（RI 中包含的两个 SyncProvider 实现之一）是在没有指定同步提供者时，SyncFactory 单件 (singleton) 将提供的默认提供者。

SyncProvider 对象提供了带有 reader 的（RowSetReader 对象）的 CachedRowSet 对象，用于从数据源读取数据以便用该数据填充自身。可以实现 reader 从 ResultSet 对象或者表格式的文件中读取数据。SyncProvider 对象还提供了 writer（RowSetWriter 对象），用于同步在与底层数据源中的数据断开连接时对 CachedRowSet 对象数据所做的任何更改。

可以实现 writer 以在检查和避免冲突方面实施不同程度的关注。（如果使用某个值填充 rowset 后更改了数据源中的该值，则会发生冲突。）RIOptimisticProvider 实现假定冲突很少或没有冲突，因此不设置锁定。仅在没有冲突时，它才使用取自 CachedRowSet 对象的值更新数据源。也可以实现其他 writer，使其始终可将修改后的数据写入数据源，这可以通过不检查冲突来实现，或者从另一个方面着手，即通过设置足够的锁定来防止对数据源中的数据进行更改。这两种 writer 之间还可以有其他 writer 实现。

CachedRowSet 对象可以使用任何已向 SyncFactory 单件注册的 SyncProvider 实现。通过调用以下代码行，应用程序可以找到已注册的 SyncProvider 实现。

      java.util.Enumeration providers = SyncFactory.getRegisteredProviders();

CachedRowSet 对象可使用两种方式来指定它将使用的 SyncProvider 对象。 向构造方法提供实现名
以下代码行创建 CachedRowSet 对象 crs2，使用默认值初始化该对象，但其 SyncProvider 对象是指定的。

          CachedRowSetImpl crs2 = new CachedRowSetImpl(
                                 "com.fred.providers.HighAvailabilityProvider");
  • 使用 CachedRowSet 方法 setSyncProvider 设置 SyncProvider
    以下代码行为 crs 重置 SyncProvider 对象，该 CachedRowSet 对象是使用默认构造方法创建的。
               crs.setSyncProvider("com.fred.providers.HighAvailabilityProvider");
    SyncFactory 和 SyncProvider 的注释。

    2.0 从 CachedRowSet 对象获取数据

    从 CachedRowSet 对象获取数据可使用继承自 ResultSet 接口的获取方法。以下示例（其中 crs 是一个 CachedRowSet 对象）演示了如何在各行中进行迭代，获取每行中的列值。第一个示例使用以列号为参数的获取方法；第二个示例使用以列名为参数的获取方法。当 RowSet 对象的命令是 SELECT * FROM TABLENAME 形式时通常使用列号；当命令通过名称指定列时则通常使用列名。
        while (crs.next()) {
        String name = crs.getString(1);
        int id = crs.getInt(2);
        Clob comment = crs.getClob(3);
        short dept = crs.getShort(4);
        System.out.println(name + "  " + id + "  " + comment + "  " + dept);
    }

        while (crs.next()) {
        String name = crs.getString("NAME");
        int id = crs.getInt("ID");
        Clob comment = crs.getClob("COM");
        short dept = crs.getShort("DEPT");
        System.out.println(name + "  " + id + "  " + comment + "  " + dept);
    }

    2.1 获取 RowSetMetaData

    通过在 RowSetMetaData 对象上调用 ResultSetMetaData 和 RowSetMetaData 的方法，应用程序可以获得有关 CachedRowSet 对象中各列的信息。以下代码片断（其中 crs 是一个 CachedRowSet 对象）展示了该过程。第一行使用关于 crs 中各列的信息创建一个 RowSetMetaData 对象。继承自 ResultSet 接口的方法 getMetaData 返回一个 ResultSetMetaData 对象，将该对象分配给变量 rsmd 前会将其强制转换为 RowSetMetaData 对象。第二行查明 jrs 的列数，第三行获得存储在 jrs 第二列中 JDBC 类型的值。
         RowSetMetaData rsmd = (RowSetMetaData)crs.getMetaData();
     int count = rsmd.getColumnCount();
     int type = rsmd.getColumnType(2);
    RowSetMetaData 接口与 ResultSetMetaData 接口有两方面不同。
    • 它包括设置方法：当使用取自不同 ResultSet 对象的数据填充 RowSet 对象时，该 RowSet 对象在内部使用这些方法。

    • 它包含较少的获取方法：某些 ResultSetMetaData 方法无法应用到 RowSet 对象。例如，不会应用那些获取某个列值是可写入的还是只读的方法，因为 RowSet 对象的所有列要么是可写入的，要么是只读的，这取决于该 rowset 是否可更新。
    注：要返回 RowSetMetaData 对象，实现必须重写 java.sql.ResultSet 中定义的 getMetaData() 方法返回 RowSetMetaData 对象。

    3.0 更新 CachedRowSet 对象

    更新 CachedRowSet 对象与更新 ResultSet 对象类似，但是因为更新 rowset 时它并未连接到其数据源，所以必须执行额外的步骤才能使更改在底层数据源中生效。调用方法 updateRow 或 insertRow 后，CachedRowSet 对象还必须调用方法 acceptChanges 使更新写入数据源。以下示例（其中指针在 CachedRowSet 对象 crs 中的行上）显示了更新当前行中两个列值并同样更新 RowSet 对象的底层数据源所需的代码。
         crs.updateShort(3, 58);
     crs.updateInt(4, 150000);
     crs.updateRow();
     crs.acceptChanges();

    下一个示例演示了移至插入行、在插入行上构建新行、将新行插入 rowset，然后调用方法 acceptChanges 将新行添加到底层数据源。注意，与获取方法一样，更新方法可以采用列索引或列名来指定所操作的列。

         crs.moveToInsertRow();
     crs.updateString("Name", "Shakespeare");
     crs.updateInt("ID", 10098347);
     crs.updateShort("Age", 58);
     crs.updateInt("Sal", 150000);
     crs.insertRow();
     crs.moveToCurrentRow();
     crs.acceptChanges();

    注：insertRow() 方法在何处插入 CachedRowSet 对象的插入行内容是由实现定义的。CachedRowSet 接口的参考实现紧随当前行插入新行，但也可以实现为在任何其他位置插入新行。

    有关这些示例的另一个注意点是它们使用方法 acceptChanges 的方式。通过内部调用 RowSet 对象的 writer 将这些更改写入数据源，从而将 CachedRowSet 对象中的更改传播回底层数据源的正是此方法。为此，writer 不得不承受建立到数据源的连接所带来的开销。上述两个代码片断在调用 updateRow 或 insertRow 后立即调用方法 acceptChanges。但是，如果更改了多个行，则更高效的做法是在调用所有 updateRow 和 insertRow 后再调用 acceptChanges。如果只调用 acceptChanges 一次，则只需要建立一个连接。

    4.0 更新底层数据源

    执行 acceptChanges 方法时，在后台调用 CachedRowSet 对象的 writer（一个 RowSetWriterImpl 对象），以便将对 rowset 所作的更改写入底层数据源。实现该 writer 以建立到数据源的连接并写入更新。

    可通过 SyncProvider 接口的实现提供 writer，这已第 1 部分“创建 CachedRowSet 对象”中讨论。默认的参考实现提供者 RIOptimisticProvider 会实现其 writer 使用乐观并发控制 (optimistic concurrency control) 机制。也就是说，在 rowset 与数据库断开时它不对底层数据库维持任何锁定，在将数据写入数据源之前它只是检查是否有冲突。如果存在冲突，则不向数据源写入任何内容。

    SyncProvider 类提供的 reader/writer 设施是可插入的，允许自定义数据的获取和更新。如果需要其他的并发控制机制，可使用方法 setSyncProvider 插入其他 SyncProvider 实现。

    要使用乐观并发控制例程，RIOptismisticProvider 要同时维护其当前值及其原始值（刚好位于当前值之前的值）。注意，如果没有对 RowSet 对象中的数据进行任何更改，则其当前值和原始值相同，都是最初填充 RowSet 对象时使用的值。但是，一旦更改了 RowSet 对象中的任何值，当前值和原始值就不同了，尽管此时原始值仍是最初的值。随着后续对 RowSet 对象中的数据进行更改，其原始值和当前值仍保持不同，但是其原始值将是前一个当前值。

    关注原始值允许 writer 对 RowSet 对象的原始值和数据库中的值进行比较。如果数据库中的值与 RowSet 对象的原始值不同，则意味着数据库中的值已经更改，出现了冲突。writer 是否检查冲突、检查的程度如何，以及它如何处理冲突都取决于它的实现方式。

    5.0 注册和通知侦听器

    作为 JavaBeans 组件，参与 JavaBeans 事件模型的所有 rowset 都继承了用来注册侦听器和用来通知这些侦听器 BaseRowSet 类中发生更改的各种方法。CachedRowSet 对象的侦听器是一个组件，只要 rowset 中发生更改，它就应得到通知。例如，如果 CachedRowSet 对象包含查询的结果，并且这些结果将以表格和条形图之类的形式显示，则可以向 rowset 将该表格和条形图注册为侦听器，这样它们可以更新以反映各种更改。要成为侦听器，表格和条形图类必须实现 RowSetListener 接口。然后可将它们添加到 CachedRowSet 对象的侦听器列表，如以下代码行所示。

    crs.addRowSetListener(table);
    crs.addRowSetListener(barGraph);
    每个移动指针或更改数据的 CachedRowSet 方法也将更改通知已注册的侦听器，所以当 crs 中发生更改时 table 和 barGraph 将得到通知。

    6.0 向瘦客户端传递数据

    使用 CachedRowSet 对象的主要原因之一是要在应用程序的不同组件之间传递数据。因为 CachedRowSet 对象是可序列化的，所以可使用它（举例来说）将运行于服务器环境的企业 JavaBeans 组件执行查询的结果通过网络发送到运行于 web 浏览器的客户端。

    由于 CachedRowSet 对象是非连接的，所以和具有相同数据的 ResultSet 对象相比更为简洁。因此，它特别适于向瘦客户端（如 PDA）发送数据，这种瘦客户端由于资源限制或安全考虑而不适于使用 JDBC 驱动程序。所以 CachedRowSet 对象可提供一种“获取各行”的方式而无需实现全部 JDBC API。

    7.0 滚动和更新

    CachedRowSet 对象的第二个主要用途是为那些本身不提供滚动和更新的 ResultSet 对象提供这些功能。换句话说，当 DBMS 不提供对滚动和更新的完全支持时，可使用 CachedRowSet 对象扩充启用 JDBC 技术的驱动程序（以下称为“JDBC 驱动程序”）的功能。要使不可滚动和只读的 ResultSet 对象变得可滚动和可更新，程序员只需创建一个使用该 ResultSet 对象的数据所填充的 CachedRowSet 对象即可。以下代码片断演示了这一过程，其中 stmt 是一个 Statement 对象。
        ResultSet rs = stmt.executeQuery("SELECT * FROM EMPLOYEES");
    CachedRowSetImpl crs = new CachedRowSetImpl();
    crs.populate(rs);

    现在对象 crs 与对象 rs 一样，也包含了取自表 EMPLOYEES 的数据。不同的是 crs 的指针可以向前、向后移动，或者移动到特定行，即使 rs 的指针只能向前移动也是如此。此外，即使 rs 是不可更新的，crs 也将是可更新的，因为在默认情况下，CachedRowSet 对象是可滚动和可更新的。

    总之，可将 CachedRowSet 对象简单地看成是一个非连接的行集合，这些行将缓存在数据源外部。由于它比较小并且是可序列化的，所以它可以轻松地通过导线发送，并且非常适合于向瘦客户端发送数据。但是 CachedRowSet 对象也有局限性：它的大小限制在它一次可在内存中存储的数据量范围内。

    8.0 获得通用数据访问

    CachedRowSet 类的另一个优势在于它能够从关系数据库以外各种数据源获取并存储数据。可以实现 rowset 的 reader 读取任何表格数据源（包括电子表格或平面文件）的数据，并用该数据填充其 rowset。因为 CachedRowSet 对象及其元数据都可以从头创建，所以充当 rowset 工厂的组件可以使用此功能来创建一个包含非 SQL 数据源数据的 rowset。但是，大部分情况下，希望 CachedRowSet 对象包含使用 JDBC API 从 SQL 数据库中获取的数据。

    9.0 设置属性

    所有 rowset 都维护一个属性集，通常使用某种工具来设置这些属性。rowset 具有的属性的数量和种类各不相同，这取决于 rowset 的用途及其获得数据的方式。例如，从 ResultSet 对象获得其数据的 rowset 需要设置那些建立数据库连接所需的属性。如果某个 rowset 使用 DriverManager 设施建立连接，则它需要设置一个标识合适驱动程序的 JDBC URL 属性，还需要设置那些提供用户名和密码的属性。另一方面，如果 rowset 使用 DataSource 对象建立连接（这是首选的方法），则它无需设置 JDBC URL 属性。但是它需要设置用于数据源逻辑名、用户名和密码的属性。

    注：要使用 DataSource 对象建立连接，该 DataSource 对象必须已经向使用 Java Naming and Directory InterfaceTM (JNDI) API 的命名服务注册。通常由具有系统管理员资格的人员完成此注册。

    为了能够使用数据库的数据填充，rowset 需要设置 command 属性。此属性是一种 PreparedStatement 对象的查询，该对象允许查询具有在运行时（而不是设计时）设置的参数占位符。要用各种值设置这些占位符参数，rowset 要为设置每种数据类型的值提供设置方法，类似于 PreparedStatement 接口提供的设置方法。

    以下代码片断展示了如何设置 CachedRowSet 对象 crs 的 command 属性。注意，如果使用某种工具设置属性，则这就是该工具应使用的代码。

        crs.setCommand("SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS " +
                   "WHERE CREDIT_LIMIT > ? AND REGION = ?");

    用于设置该命令占位符参数的值被包含在 RowSet 对象的 params 字段中，该字段是一个 Vector 对象。CachedRowSet 类为设置其 params 字段中的元素提供了一组设置方法。以下代码片断演示了如何设置前一个示例查询中的两个参数。

        crs.setInt(1, 5000);
    crs.setString(2, "West");

    params 字段现在包含两个元素，每个元素都是一个两元素长的数组。第一个元素是参数号；第二个元素是要设置的值。在这种情况下，params 的第一个元素是 1，5000，第二个元素是 2，"West"。当应用程序调用方法 execute 时，它会依次调用此 RowSet 对象的 reader，该 reader 会依次调用其 readData 方法。作为实现的一部分，readData 将获得 params 中的值并使用这些值设置命令的占位符参数。以下代码片断说明了在获得 Connection 对象 con 后 reader 如何执行此操作。

        PreparedStatement pstmt = con.prepareStatement(crs.getCommand());
    reader.decodeParams();
    // decodeParams figures out which setter methods to use and does something
    // like the following:
    //    for (i = 0; i < params.length; i++) {
    //        pstmt.setObject(i + 1, params[i]);
    //    }

    这里用于 crs 的命令是查询 "SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS WHERE CREDIT_LIMIT > 5000 AND REGION = "West"。readData 方法使用以下代码行执行此命令后，它会获得 rs 的数据，该数据用于填充 crs。

         ResultSet rs = pstmt.executeQuery();

    上述代码片断说明了在后台进行的操作；这些操作不会出现在应用程序中，因为应用程序不会调用 readData 和 decodeParams 之类的方法。相反，以下代码片断展示了应用程序可能执行的操作。它设置 rowset 的命令、设置 command 属性并执行该命令。只需调用 execute 方法，就可使用从表 CUSTOMERS 请求的数据生成 crs。

        crs.setCommand("SELECT FIRST_NAME, LAST_NAME, ADDRESS FROM CUSTOMERS" +
                   "WHERE CREDIT_LIMIT > ? AND REGION = ?");
    crs.setInt(1, 5000);
    crs.setString(2, "West");
    crs.execute();

    10.0 分页数据

    因为 CachedRowSet 对象在内存中存储数据，所以它在任一时间可以包含的数据量是由可用的内存量决定的。要避开此限制，CachedRowSet 对象可以数据块（称为页）的形式从 ResultSet 对象中获取数据。要利用此机制，应用程序应使用方法 setPageSize 设置一页中要包括的行数。换句话说，如果页大小设置为 5，则一次从数据源中获取一个 5 行的数据块。应用程序也可选择设置一次可获取的最大行数。如果最大行数设置为 0，或者未设置最大行数，则对一次获取的行数没有限制。

    设置各个属性后，必须使用方法 populate 或方法 execute 用数据填充 CachedRowSet 对象。以下代码行演示了如何使用方法 populate。注意，该方法的这种形式采用两个参数，ResultSet 句柄和 ResultSet 对象中的行，从该行开始获取各行。

         CachedRowSet crs = new CachedRowSetImpl();
     crs.setMaxRows(20);
     crs.setPageSize(4);
     crs.populate(rsHandle, 10);
    运行此代码时，将使用 rsHandle 中从第 10 行开始的 4 行数据填充 crs。

    下一个代码片断展示了如何使用方法 execute 填充 CachedRowSet 对象，该方法可以采用 Connection 对象作为一个参数，也可以不采用。此代码向 execute 传递 Connection 对象 conHandle。

    注意，以下代码片断和上述代码片断有两处差别。首先，没有调用方法 setMaxRows，所以没有对 crs 可以包含的行数设置限制。（记住，对于 crs 在内存中可以存储的数据量，总是有一个最高限制。）第二个差别是不能向方法 execute 传递 ResultSet 对象中起始获取行的行号。此方法始终从第一行开始获取。

         CachedRowSet crs = new CachedRowSetImpl();
     crs.setPageSize(5);
     crs.execute(conHandle);
    运行此代码后，crs 将包含由 crs 的命令所生成的 ResultSet 对象中的 5 行数据。crs 的 writer 将使用 conHandle 连接数据源并执行 crs 的命令。然后应用程序就能够在 crs 中的数据上进行操作，方式与在任何其他 CachedRowSet 对象的数据上进行操作的方式相同。

    要访问下一页（数据块），应用程序可调用方法 nextPage。此方法创建新的 CachedRowSet 对象并用下一页的数据填充。例如，假定 CachedRowSet 对象的命令返回一个具有 1000 行数据的 ResultSet 对象 rs。如果页大小设置为 100，则首次调用方法 nextPage 将创建一个包含 rs 前 100 行的 CachedRowSet 对象。在使用这前 100 行的数据执行完所需的操作后，应用程序可以再次调用方法 nextPage 创建另一个带有 rs 第二个 100 行数据的 CachedRowSet 对象。第一个 CachedRowSet 对象中的数据不再存在于内存中，因为它已被第二个 CachedRowSet 对象的数据替换了。调用方法 nextPage 10 次后，第十个 CachedRowSet 对象将包含 rs 最后 100 行存储在内存中的数据。在任意给定时间，内存中仅存储一个 CachedRowSet 对象的数据。

    只要当前页不是各行的最后一页，方法 nextPage 就返回 true，没有其他页时，则返回 false。因此，可在 while 循环中使用它来获取所有页，正如在以下代码行中所演示的。

         CachedRowSet crs = CachedRowSetImpl();
     crs.setPageSize(100);
     crs.execute(conHandle);

     while(crs.nextPage()) {
         while(crs.next()) {
             . . . // operate on chunks (of 100 rows each) in crs,
                   // row by row
         }
     }
    运行此代码片断后，应用程序会遍历所有 1000 行，但是每次内存中的数据只有 100 行。

    CachedRowSet 接口还定义了方法 previousPage。正如方法 nextPage 类似于 ResultSet 方法 next，方法 previousPage 也类似于 ResultSet 方法 previous。与方法 nextPage 类似，previousPage 创建一个 CachedRowSet 对象，包含作为页大小设置的行数。因此，（举例来说）方法 previousPage 可用在上述代码片断末尾的 while 循环中，以从最后一页开始逆向遍历到第一页。方法 previousPage 也与 nextPage 类似，因为它也可以用在 while 循环中，不同之处在于它是在前面还有页时返回 true，前面没有页时返回 false。

    通过将指针定位于每页最后一行的后面（如以下代码片断所执行的），方法 previous 就可以在每页中从最后一行遍历到第一行。代码也可将指针置于每页第一行的前面，然后在 while 循环中使用 next 方法，以在每页中从最第一行遍历到最后一行。

    以下代码片断假定是前一个代码片断的继续，这意味着第十个 CachedRowSet 对象的指针位于最后一行。代码将指针移到最后一行的后面，这样第一次调用方法 previous 会将指针放回到最后一行上。遍历最后一页（CachedRowSet 对象 crs）的所有行后，代码接着会进入 while 循环以获得第九页、向后遍历各行、转至第八页、向后遍历各行，依此类推，直到第一页的第一行为止。

         crs.afterLast();
     while(crs.previous())  {
         . . . // navigate through the rows, last to first
     {
     while(crs.previousPage())  {
         crs.afterLast();
         while(crs.previous())  {
             . . . // go from the last row to the first row of each page
         }
     }

    字段摘要
    static boolean COMMIT_ON_ACCEPT_CHANGES
    导致在调用 acceptChanges() 时，CachedRowSet 对象的 SyncProvider 提交更改。
    从接口 java.sql.ResultSet 继承的字段
    CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
    方法摘要
     void acceptChanges()
    将对此 CachedRowSet 对象所做的行更新、插入以及删除更改传播到底层数据源。
     void acceptChanges(Connection con)
    将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。
     boolean columnUpdated(int idx)
    指示此 CachedRowSet 对象当前行中的指定列是否已更新。
     boolean columnUpdated(String columnName)
    指示此 CachedRowSet 对象当前行中的指定列是否已更新。
     void commit()
    每个 CachedRowSet 对象的 SyncProvider 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
     CachedRowSet createCopy()
    创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。
     CachedRowSet createCopyNoConstraints()
    创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。
     CachedRowSet createCopySchema()
    创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。
     RowSet createShared()
    返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。
     void execute(Connection conn)
    用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。
     int[] getKeyColumns()
    返回一个包含一个或多个列号的数组，这些列号指示了形成某个键的列，该键唯一地标识了此 CachedRowSet 对象中的某个行。
     ResultSet getOriginal()
    返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。
     ResultSet getOriginalRow()
    返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。
     int getPageSize()
    返回 CachedRowSet 对象的页大小。
     RowSetWarning getRowSetWarnings()
    获取此 RowSet 对象上的调用报告的第一个警告。
     boolean getShowDeleted()
    获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
     SyncProvider getSyncProvider()
    获取此 CachedRowSet 对象的 SyncProvider 实现。
     String getTableName()
    返回创建此 CachedRowSet 对象时所用对象（表）的标识符。
     boolean nextPage()
    逐个增加 CachedRowSet 的当前页。
     void populate(ResultSet data)
    使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
     void populate(ResultSet rs, int startRow)
    使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。
     boolean previousPage()
    逐个减少 CachedRowSet 的当前页。
     void release()
    释放此 CachedRowSet 对象的当前内容并将 rowSetChanged 事件发送到所有已注册侦听器。
     void restoreOriginal()
    将此 CachedRowSet 对象还原成其原始值，即执行上一组更改前的值。
     void rollback()
    每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
     void rollback(Savepoint s)
    每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
     void rowSetPopulated(RowSetEvent event, int numRows)
    通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。
     void setKeyColumns(int[] keys)
    使用给定的列号数组设置此 CachedRowSet 对象的 keyCols 字段，它形成了唯一标识此 CachedRowSet 对象中某个行的键。
     void setMetaData(RowSetMetaData md)
    使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。
     void setOriginalRow()
    将此 CachedRowSet 对象中的当前行设置为原始行。
     void setPageSize(int size)
    设置 CachedRowSet 对象的页大小。
     void setShowDeleted(boolean b)
    将属性 showDeleted 设置为给定的 boolean 值，它确定标记为删除的行是否会出现在当前行集合中。
     void setSyncProvider(String provider)
    将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。
     void setTableName(String tabName)
    将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。
     int size()
    返回此 CachedRowSet 对象中的行数。
     Collection<?> toCollection()
    将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。
     Collection<?> toCollection(int column)
    将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
     Collection<?> toCollection(String column)
    将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。
     void undoDelete()
    取消删除当前行并通知侦听器已更改了某个行。
     void undoInsert()
    如果已经插入了当前行，则立即将它从此 CachedRowSet 对象移除，同样要通知侦听器已更改了某个行。
     void undoUpdate()
    如果已经修改了行，则立即逆转上一次更新操作。
    从接口 javax.sql.RowSet 继承的方法
    addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername
    从接口 java.sql.ResultSet 继承的方法
    absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull
    从接口 java.sql.Wrapper 继承的方法
    isWrapperFor, unwrap
    从接口 javax.sql.rowset.Joinable 继承的方法
    getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

    字段详细信息

    COMMIT_ON_ACCEPT_CHANGES

    static final boolean COMMIT_ON_ACCEPT_CHANGES
    导致在调用 acceptChanges() 时，CachedRowSet 对象的 SyncProvider 提交更改。如果设置为 false，则在调用 CachedRowSet 接口的某个事务方法之前，不提交更改。

    另请参见：
    commit(), rollback(), 常量字段值
    方法详细信息

    populate

    void populate(ResultSet data)
              throws SQLException
    使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。

    当应用程序具有到开放 ResultSet 对象的连接时，此方法可作为 execute 方法的替代方法。使用方法 populate 比使用无参数的 execute 方法要更为高效，因为它不用打开新的连接和重新执行此 CachedRowSet 对象的命令。与采用 ResultSet 对象的 execute 相比，使用 populate 方法要更为便捷。

    参数：
    data - 一个 ResultSet 对象，它包含要读入到此 CachedRowSet 对象中的数据
    抛出：
    SQLException - 如果提供的 ResultSet 对象为 null 或者此 CachedRowSet 对象无法获取关联的 ResultSetMetaData 对象
    另请参见：
    execute(java.sql.Connection), ResultSet, ResultSetMetaData

    execute

    void execute(Connection conn)
             throws SQLException
    用数据填充此 CachedRowSet 对象，使用给定的连接来生成从中读取数据的结果集。此方法应该关闭它所创建的所有数据库连接，以确保此 CachedRowSet 对象是断开连接的，它从其数据源读取数据或向其数据源写入数据时除外。

    此 CachedRowSet 对象的 reader 将使用 conn 来建立到数据源的连接，以便能够执行 rowset 的命令，并将数据从得到的 ResultSet 对象读入此 CachedRowSet 对象中。此方法在填充此 CachedRowSet 对象后同样会关闭 conn。

    如果调用此方法时已经填充了实现，则设置（重置）内容和元数据。同样，如果在调用方法 acceptChanges 来提交显式的更新之前调用此方法，则这些更新会丢失。

    参数：
    conn - 带有有效属性的标准 JDBC Connection 对象
    抛出：
    SQLException - 如果提供了无效的 Connection 对象或在建立到数据源的连接过程中发生错误
    另请参见：
    populate(java.sql.ResultSet), Connection

    acceptChanges

    void acceptChanges()
                   throws SyncProviderException
    将对此 CachedRowSet 对象所做的行更新、插入以及删除更改传播到底层数据源。

    此方法调用此 CachedRowSet 对象的 writer 在后台完成工作。标准的 CachedRowSet 实现应该使用 SyncFactory 单件来获得 SyncProvider 实例，以提供一个 RowSetWriter 对象 (writer)。该 writer 会尝试将在此 CachedRowSet 对象中所做的更改传播回数据源。

    方法 acceptChanges 成功执行后，除了将更改写入数据源外，它还使当前行中的值成为原始行中的值。

    根据所用 SyncProvider 实现的同步级别，writer 将原始值与数据源中的值进行比较，以检查是否有冲突。如果有冲突，则 RIOptimisticProvider 实现可能会抛出 SyncProviderException 并且不向数据源中写入任何内容。

    应用程序可以选择捕获 SyncProviderException 对象并获取它所包含的 SyncResolver 对象。SyncResolver 对象逐行列出冲突，并在数据源上设置锁定，以避免在解决当前冲突的同时出现更多冲突。此外，对于每个冲突，它还提供了各种方法来检查该冲突和设置在数据源中应该保持不变的值。解决所有冲突后，应用程序必须再次调用 acceptChanges 方法，将已解决冲突的值写入数据源。如果数据源中的所有值都已经是保持不变的值，则方法 acceptChanges 不执行任何操作。

    某些提供者实现可以使用锁定来确保没有冲突。在这种情况下，可以保证在调用方法 acceptChanges 时，writer 能成功地将更改写入数据源。调用方法 updateRow、insertRow 或 deleteRow 后可立即调用此方法，但是在完成所有更改后只调用此方法一次要更为高效，这样只需要建立一个连接。

    注：acceptChanges() 方法将确定 COMMIT_ON_ACCEPT_CHANGES 是否设置为 true。如果设置为 true，则将同步中的所有更新都提交给数据源。否则应用程序必须显式地调用恰当的 commit() 或 rollback() 方法。

    抛出：
    SQLException - 如果指针位于插入行上
    SyncProviderException - 如果底层同步提供者的 writer 无法将更新写回数据源
    另请参见：
    acceptChanges(java.sql.Connection), RowSetWriter, SyncFactory, SyncProvider, SyncProviderException, SyncResolver

    acceptChanges

    void acceptChanges(Connection con)
                   throws SyncProviderException
    将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。

    另一种形式的 acceptChanges 方法不传递连接，因为它使用已经定义在 RowSet 对象内的 Connection 对象，该对象是最初用来填充 RowSet 的连接。

    acceptChanges 方法的这一形式与无参数形式类似；但与其他形式不同的是，此形式只能在底层数据源是一个 JDBC 数据源时使用。SyncProvider 必须使用已更新的 Connection 属性来重置 RowSetWriter 配置，以确保 CachedRowSet 对象的内容是正确同步的。

    方法 acceptChanges 成功执行后，除了将更改写入数据源外，它还使当前行中的值与原始行中的值相同。

    根据所用 SyncProvider 实现的同步级别，writer 将原始值与数据源中的值进行比较，以检查是否有冲突。如果有冲突，则 RIOptimisticProvider 实现可能会抛出 SyncProviderException 并且不向数据源中写入任何内容。

    应用程序可以选择捕获 SyncProviderException 对象并获取它所包含的 SyncResolver 对象。SyncResolver 对象逐行列出冲突，并在数据源上设置锁定，以避免在解决当前冲突的同时出现更多冲突。此外，对于每个冲突，它还提供了各种方法来检查该冲突和设置在数据源中应该保持不变的值。解决所有冲突后，应用程序必须再次调用 acceptChanges 方法，将已解决冲突的值写入数据源。如果数据源中的所有值都已经是保持不变的值，则方法 acceptChanges 不执行任何操作。

    某些提供者实现可以使用锁定来确保没有冲突。在这种情况下，可以保证在调用方法 acceptChanges 时，writer 能成功地将更改写入数据源。调用方法 updateRow、insertRow 或 deleteRow 后可立即调用此方法，但是在完成所有更改后只调用此方法一次要更为高效，这样只需要建立一个连接。

    注：acceptChanges() 方法将确定 COMMIT_ON_ACCEPT_CHANGES 是否设置为 true。如果设置为 true，则将同步中的所有更新都提交给数据源。否则应用程序必须显式地调用相应的 commit 或 rollback 方法。

    参数：
    con - 标准的 JDBC Connection 对象
    抛出：
    SQLException - 如果指针位于插入行上
    SyncProviderException - 如果底层同步提供者的 writer 无法将更新写回数据源
    另请参见：
    acceptChanges(), RowSetWriter, SyncFactory, SyncProvider, SyncProviderException, SyncResolver

    restoreOriginal

    void restoreOriginal()
                     throws SQLException
    将此 CachedRowSet 对象还原成其原始值，即执行上一组更改前的值。如果未对 rowset 进行任何更改或者只有一组更改，则原始值是填充此 CachedRowSet 对象时使用的值；否则原始值是正好在其当前值之前的值。

    调用此方法时，CachedRowSet 实现必须确保对当前 rowset 实例所做的所有更新、插入和删除都已由之前的值取代。此外，应该将指针重置到第一行，并且应该触发一个 rowSetChanged 事件，以通知所有已注册侦听器。

    抛出：
    SQLException - 如果将此 CachedRowSet 对象的当前值回滚到其之前的值时发生错误
    另请参见：
    RowSetListener.rowSetChanged(javax.sql.RowSetEvent)

    release

    void release()
             throws SQLException
    释放此 CachedRowSet 对象的当前内容并将 rowSetChanged 事件发送到所有已注册侦听器。丢弃所有显式更新，调用此方法后 rowset 不包含任何行。不与底层数据源进行任何交互，并且所有 rowset 内容、元数据和内容更新都应该是不可恢复的。

    完全清除此 CachedRowSet 对象的内容和关联的更新之前，此对象应该保持锁定，从而防止其他持有对此 RowSet 对象引用的组件进行“脏”读。此外，在所有读取此 CachedRowSet 对象的组件完成其读取之前，不能释放对象的内容。触发 rowSetChanged 事件后，此 CachedRowSet 对象应该返回到正常行为。

    保留元数据（包括 JDBC 属性和 Synchronization SPI 属性）以备后用。各种属性（如 command 属性）与原始数据源（此 CachedRowSet 对象最初根据该数据源创建）相关是很重要的。

    此方法清空 rowset，这与 close 方法不同，后者将整个 rowset 标记为可恢复以允许垃圾回收器回收 rowset 的 Java VM 资源。

    抛出：
    SQLException - 如果清空此 CachedRowSet 对象的内容时发生错误
    另请参见：
    RowSetListener.rowSetChanged(javax.sql.RowSetEvent), ResultSet.close()

    undoDelete

    void undoDelete()
                throws SQLException
    取消删除当前行并通知侦听器已更改了某个行。调用此方法后，不再将当前行标记为删除。在 rowset 生命周期中的任何时候都可调用此方法。

    此外，可以通过调整指针的位置取消多个行删除，调整指针位置可使用任何指针位置控制方法，比如：

    • CachedRowSet.absolute
    • CachedRowSet.first
    • CachedRowSet.last

    抛出：
    SQLException - 如果 (1) 尚未删除当前行或 (2) 指针在插入行上、在第一行的前面或在最后一行的后面
    另请参见：
    undoInsert(), ResultSet.cancelRowUpdates()

    undoInsert

    void undoInsert()
                throws SQLException
    如果已经插入了当前行，则立即将它从此 CachedRowSet 对象移除，同样要通知侦听器已更改了某个行。在 rowset 生命周期中的任何时候都可调用此方法，如果当前行在异常限制范围内（见下文），则它将取消当前行的行插入。

    此外，可以通过调整指针的位置取消多个行插入，调整指针位置可使用任何指针位置控制方法，比如：

    • CachedRowSet.absolute
    • CachedRowSet.first
    • CachedRowSet.last

    抛出：
    SQLException - 如果 (1) 尚未插入当前行或者 (2) 指针在第一行的前面、最后一行的后面或在插入行上
    另请参见：
    undoDelete(), ResultSet.cancelRowUpdates()

    undoUpdate

    void undoUpdate()
                throws SQLException
    如果已经修改了行，则立即逆转上一次更新操作。可调用此方法逆转所有列上的更新，直到行中的所有更新都已回滚到其上一次同步 (acceptChanges) 或填充之前的状态。执行对插入行的更新时也可以调用此方法。

    undoUpdate 可以在 rowset 生命周期中的任何时间调用；但是，在发生同步之后，此方法在发生对 rowset 数据的更多修改之前将无效。

    抛出：
    SQLException - 如果此 CachedRowSet 对象中指针在第一行的前面或最后一行的后面。
    另请参见：
    undoDelete(),
undoInsert(),
ResultSet.cancelRowUpdates()

    columnUpdated

    boolean columnUpdated(int idx)
                      throws SQLException
    指示此 CachedRowSet 对象当前行中的指定列是否已更新。

    参数：
    idx - 一个 int 值，标识要检查更新的列
    返回：
    如果已对指定列进行可见更新，则返回 true；否则返回 false
    抛出：
    SQLException - 如果指针在插入行上、在第一行的前面或者在最后一行的后面
    另请参见：
    DatabaseMetaData.updatesAreDetected(int)

    columnUpdated

    boolean columnUpdated(String columnName)
                      throws SQLException
    指示此 CachedRowSet 对象当前行中的指定列是否已更新。

    参数：
    columnName - 一个 String 对象，提供要检查更新的列名
    返回：
    如果已对该列进行可见更新，则返回 true；否则返回 false
    抛出：
    SQLException - 如果指针在插入行上、在第一行的前面或者在最后一行的后面
    另请参见：
    DatabaseMetaData.updatesAreDetected(int)

    toCollection

    Collection<?> toCollection()
                           throws SQLException
    将此 CachedRowSet 对象转换成一个 Collection 对象，它包含此 CachedRowSet 对象的所有数据。实现在如何表示此 Collection 对象上有一定的自由度，这是由于 Collection 框架的抽象本质所造成的。必须用通用 Collection 实现或专用的 Collection 实现（如 TreeMap 对象或 Vector 对象）来完全表示每一行。SQL NULL 列值必须表示为 Java 编程语言中的 null。

    CachedRowSet 接口的标准参考实现对 rowset 使用 TreeMap 对象，每行中的值都包含在 Vector 对象中。预期多数实现都是如此。

    TreeMap 类型的 collection 可保证按照键升序，并根据键类的自然顺序存储映射。每个键引用一个与 RowSet 对象的一行相对应的 Vector 对象。因此，每个 Vector 对象的大小必须与 RowSet 对象中的列数完全相等。TreeMap collection 使用的键由实现决定，实现可以选择利用内部 RowSet 表结构内可用的已设置键，这些键已经设置在 RowSet 对象本身或底层 SQL 数据上。

    返回：
    一个 Collection 对象，它包含此 CachedRowSet 对象中每一行的值
    抛出：
    SQLException - 如果生成该 collection 时发生错误
    另请参见：
    toCollection(int), toCollection(String)

    toCollection

    Collection<?> toCollection(int column)
                           throws SQLException
    将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。实现在如何表示此 Collection 对象上有一定的自由度，这是由于 Collection 框架的抽象本质所造成的。应该用通用 Collection 实现或专用的 Collection 实现（如 Vector 对象）来完全表示每个列值。SQL NULL 列值必须表示为 Java 编程语言中的 null。

    标准的参考实现使用 Vector 对象包含列值，预期多数实现都是如此。如果使用 Vector 对象，则其大小必须与此 CachedRowSet 对象中的行数完全相等。

    参数：
    column - 一个 int 值，指示值要用 Collection 对象来表示的列
    返回：
    一个 Collection 对象，它包含存储在此 CachedRowSet 对象指定列中的值
    抛出：
    SQLException - 如果生成 collection 时发生错误，或者提供了无效的列 id
    另请参见：
    toCollection(), toCollection(String)

    toCollection

    Collection<?> toCollection(String column)
                           throws SQLException
    将此 CachedRowSet 对象中的指定列转换成一个 Collection 对象。实现在如何表示此 Collection 对象上有一定的自由度，这是由于 Collection 框架的抽象本质所造成的。应该用通用 Collection 实现或专用的 Collection 实现（如 Vector 对象）来完全表示每个列值。SQL NULL 列值必须表示为 Java 编程语言中的 null。

    标准的参考实现使用 Vector 对象包含列值，预期多数实现都是如此。如果使用 Vector 对象，则其大小必须与此 CachedRowSet 对象中的行数完全相等。

    参数：
    column - 一个 String 对象，提供值要用 Collection 来表示的列的名称
    返回：
    一个 Collection 对象，它包含存储在此 CachedRowSet 对象指定列中的值
    抛出：
    SQLException - 如果生成该 collection 时发生错误，或者提供了无效的列 id
    另请参见：
    toCollection(), toCollection(int)

    getSyncProvider

    SyncProvider getSyncProvider()
                             throws SQLException
    获取此 CachedRowSet 对象的 SyncProvider 实现。在内部，rowset 使用此方法来触发 rowset 和数据源之间的读取或写入动作。例如，rowset 可能需要从 SyncProvider 获得 rowset reader（RowSetReader 对象）上的句柄，以允许填充 rowset。
         RowSetReader rowsetReader = null;
     SyncProvider provider =
         SyncFactory.getInstance("javax.sql.rowset.provider.RIOptimisticProvider");
         if (provider instanceof RIOptimisticProvider) {
             rowsetReader = provider.getRowSetReader();
         }
    假定 rowsetReader 是 rowset 实现内的一个私有的、可访问的字段，当应用程序调用 execute 方法时，它会依次调用 reader 的 readData 方法来填充该 RowSet 对象。

     rowsetReader.readData((RowSetInternal)this);

    此外，应用程序可以使用此方法返回的 SyncProvider 对象来调用可返回有关 SyncProvider 对象信息的方法，这些信息包括有关供应商、版本、提供者标识、同步级别和当前已设置的锁定等。

    返回：
    实例化 rowset 时所设置的 SyncProvider 对象，如果没有设置，则返回默认的提供者
    抛出：
    SQLException - 如果在返回 SyncProvider 对象时发生错误
    另请参见：
    setSyncProvider(java.lang.String)

    setSyncProvider

    void setSyncProvider(String provider)
                     throws SQLException
    将此 CachedRowSet 对象的 SyncProvider 对象设置为指定的提供者。此方法允许重置 SyncProvider 对象。

    应该始终使用可用的 SyncProvider 机制来实例化 CachedRowSet 实现，但在某些情况下重置 SyncProvider 对象更合乎需要或者是必需的。例如，应用程序可能希望暂时使用默认的 SyncProvider 对象，然后选择使用最近可用并能更好地满足其需求的提供者。

    重置 SyncProvider 对象会导致 RowSet 对象从 SyncFactory 请求新的 SyncProvider 实现。这能够重置所有以前与原始数据源的连接和关系，并可能彻底更改非连接 rowset 的同步行为。

    参数：
    provider - 一个 String 对象，提供了 SyncProvider 实现的完全限定类名
    抛出：
    SQLException - 如果试图重置 SyncProvider 实现时发生错误
    另请参见：
    getSyncProvider()

    size

    int size()
    返回此 CachedRowSet 对象中的行数。

    返回：
    rowset 中的行数

    setMetaData

    void setMetaData(RowSetMetaData md)
                 throws SQLException
    使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。当 RowSetReader 对象读取 rowset 内容时，它创建一个 RowSetMetaData 对象并使用 RowSetMetaData 实现中的方法进行初始化。参考实现则使用 RowSetMetaDataImpl 类。当 reader 完成 rowset 内容的读取后，在内部调用此方法，以便将 RowSetMetaData 对象传递到 rowset。

    参数：
    md - 一个 RowSetMetaData 对象，包含关于此 CachedRowSet 对象中各列的元数据
    抛出：
    SQLException - 如果向 rowset 提供了无效的元数据

    getOriginal

    ResultSet getOriginal()
                      throws SQLException
    返回一个包含此 CachedRowSet 对象原始值的 ResultSet 对象。

    ResultSet 对象的指针应该位于第一行的前面。此外，返回的 ResultSet 对象应该具有以下属性：

    • ResultSet.TYPE_SCROLL_INSENSITIVE
    • ResultSet.CONCUR_UPDATABLE

    RowSet 对象的原始值是上一次与底层数据源同步之前所具有的值。如果没有进行同步，则原始值就是填充该 RowSet 对象时所使用的值。当应用程序调用方法 acceptChanges 并且已实现了 SyncProvider 对象来检查冲突时，在内部调用此方法。如果正是这种情况，则 writer 比较原始值与数据源中当前的值，检查是否存在冲突。

    返回：
    包含此 CachedRowSet 对象原始值的 ResultSet 对象
    抛出：
    SQLException - 如果生成该 ResultSet 对象时发生错误

    getOriginalRow

    ResultSet getOriginalRow()
                         throws SQLException
    返回一个只包含此 CachedRowSet 对象当前行原始值的 ResultSet 对象。

    ResultSet 对象的指针应该位于第一行的前面。此外，返回的 ResultSet 对象应该具有以下属性：

    • ResultSet.TYPE_SCROLL_INSENSITIVE
    • ResultSet.CONCUR_UPDATABLE

    返回：
    原始行结果集
    抛出：
    SQLException - 如果没有当前行
    另请参见：
    setOriginalRow()

    setOriginalRow

    void setOriginalRow()
                    throws SQLException
    将此 CachedRowSet 对象中的当前行设置为原始行。

    将当前行中所有已修改的值与数据源同步后，在内部调用此方法。当前行必须被标记为无法再插入、删除或更新。

    调用 setOriginalRow 是不可逆的。

    抛出：
    SQLException - 如果没有当前行或重置原始行的内容时遇到错误
    另请参见：
    getOriginalRow()

    getTableName

    String getTableName()
                    throws SQLException
    返回创建此 CachedRowSet 对象时所用对象（表）的标识符。可在多种场合下设置此名称，并且规范并未对设置次数或标准实现是否应该跟踪以前的表名强加任何限制。

    返回：
    一个 String 对象，提供了作为此 CachedRowSet 对象的数据源的表名，如果没有为表设置名称，则返回 null
    抛出：
    SQLException - 如果返回表名时遇到错误
    另请参见：
    ResultSetMetaData.getTableName(int)

    setTableName

    void setTableName(String tabName)
                  throws SQLException
    将派生此 CachedRowSet 对象的表的标识符设置为给定的表名。尝试进行同步期间，在比较数据源中的值与 CachedRowSet 对象的值时，writer 使用此名称来确定要使用的表。表标识符还指示应该将取自此 CachedRowSet 对象的修改值写入何处。

    此 CachedRowSet 对象的实现可以从 RowSetMetaDataImpl 对象内部获得该名称。

    参数：
    tabName - 一个 String 对象，标识派生此 CachedRowSet 对象的表，不能为 null，但是可以为空字符串
    抛出：
    SQLException - 如果命名该表时遇到错误，或者 tabName 为 null
    另请参见：
    RowSetMetaData.setTableName(int, java.lang.String), RowSetWriter, SyncProvider

    getKeyColumns

    int[] getKeyColumns()
                    throws SQLException
    返回一个包含一个或多个列号的数组，这些列号指示了形成某个键的列，该键唯一地标识了此 CachedRowSet 对象中的某个行。

    返回：
    包含列号的数组，该列号指示哪些列组成此 CachedRowSet 对象中行的主键。如果没有列表示主键，则此数组应该为空。
    抛出：
    SQLException - 如果此 CachedRowSet 对象为空
    另请参见：
    setKeyColumns(int[]), Joinable.getMatchColumnIndexes(), Joinable.getMatchColumnNames()

    setKeyColumns

    void setKeyColumns(int[] keys)
                   throws SQLException
    使用给定的列号数组设置此 CachedRowSet 对象的 keyCols 字段，它形成了唯一标识此 CachedRowSet 对象中某个行的键。

    如果 CachedRowSet 对象成为 JoinRowSet 对象的一部分，那么在指定为键列的列也成为匹配列的情况下，会保留此方法所定义的键和得到的约束条件。

    参数：
    keys - 一个 int 数组，指示形成此 CachedRowSet 对象的主键的列；数组中的每个元素都必须大于 0 并小于等于此 rowset 中的列数
    抛出：
    SQLException - 如果给定数组中的任意元素对此 rowset 无效
    另请参见：
    getKeyColumns(),
Joinable.setMatchColumn(String),
Joinable.setMatchColumn(int)

    createShared

    RowSet createShared()
                    throws SQLException
    返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。实际上，两个 CachedRowSet 对象在相同的数据上具有指针。因此，某个副本所做的任何更改对原始对象和所有其他副本而言都是可见的，就像原始对象所做的更改对其所有副本而言都是可见的一样。如果某个副本调用方法更改底层数据，则它所调用的方法会通知所有已注册侦听器，就像原始 CachedRowSet 对象调用该方法时一样。

    此外，此方法创建的所有 RowSet 对象具有与此 CachedRowSet 对象相同的属性。例如，如果此 CachedRowSet 对象是只读的，则其所有副本也是只读的。如果将 CachedRowSet 对象更改为可更新的，则所有副本也成为可更新的。

    注：如果多个线程访问通过 createShared() 方法创建的 RowSet 对象，则指定以下行为来保持共享数据的完整性：应该在每个对象和单个底层表结构之间连续进行所有共享 RowSet 对象的读取和写入。

    返回：
    新的共享 RowSet 对象，具有与此 CachedRowSet 对象相同的属性并且在相同的数据上具有指针
    抛出：
    SQLException - 如果发生错误或者底层平台中不支持复制
    另请参见：
    RowSetEvent, RowSetListener

    createCopy

    CachedRowSet createCopy()
                        throws SQLException
    创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。与通过调用 createShared 所创建的 RowSet 对象相反，对原始 RowSet 对象副本所做的更新对于原始 RowSet 对象而言不得是可见的。同样，向原始 RowSet 注册的所有事件侦听器不得侦听新 RowSet 副本的事件。此外，必须维持已建立的所有约束限制。

    返回：
    新的 RowSet 对象，它是此 CachedRowSet 对象的深层副本并且完全独立于此 CachedRowSet 对象
    抛出：
    SQLException - 如果生成此 CachedRowSet 对象的副本时发生错误
    另请参见：
    createShared(),
createCopySchema(),
createCopyNoConstraints(),
RowSetEvent,
RowSetListener

    createCopySchema

    CachedRowSet createCopySchema()
                              throws SQLException
    创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。该副本不得包含任何内容，而只能表示原始 CachedRowSet 对象的表结构。此外，在原始 CachedRowSet 对象中设置的主键和外键约束必须在新的空 CachedRowSet 对象中等效执行。与通过调用 createShared 方法所生成的 RowSet 对象相反，对使用 createCopySchema 方法创建的此 CachedRowSet 对象副本所做的更新对于此 CachedRowSet 对象而言不得是可见的。

    应用程序可以根据此方法返回的 CachedRowSet 对象来形成 WebRowSet，从而可将 RowSet 模式定义导出为 XML 以备后用。

    抛出：
    SQLException - 如果复制此 CachedRowSet 对象的结构时发送错误
    另请参见：
    createShared(),
createCopySchema(),
createCopyNoConstraints(),
RowSetEvent,
RowSetListener

    createCopyNoConstraints

    CachedRowSet createCopyNoConstraints()
                                     throws SQLException
    创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。与通过调用 createShared 方法所生成的 RowSet 对象相反，对此 CachedRowSet 对象副本所做的更新对于此 CachedRowSet 对象而言不得是可见的。同样，向此 CachedRowSet 对象注册的所有事件侦听器不得侦听新 RowSet 对象的事件。此外，不得在副本中维持为此 CachedRowSet 对象所建立的任何约束限制。

    返回：
    新的 CachedRowSet 对象，它是此 CachedRowSet 对象的深层副本并且完全独立于此 CachedRowSet 对象
    抛出：
    SQLException - 如果生成此 CachedRowSet 对象的副本时发生错误
    另请参见：
    createCopy(),
createShared(),
createCopySchema(),
RowSetEvent,
RowSetListener

    getRowSetWarnings

    RowSetWarning getRowSetWarnings()
                                throws SQLException
    获取此 RowSet 对象上的调用报告的第一个警告。此 RowSet 对象上的后续警告会被链接到此方法返回的 RowSetWarning 对象。 每次读取新行时，都会自动清除警告链。不可以在已经关闭的 RowSet 对象上调用此方法；这样做将导致抛出 SQLException。

    返回：
    报告的第一个 RowSetWarning 对象，如果没有，则返回 null
    抛出：
    SQLException - 如果在已关闭的 RowSet 上调用此方法
    另请参见：
    RowSetWarning

    getShowDeleted

    boolean getShowDeleted()
                       throws SQLException
    获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。如果返回 true，则已删除行与当前行一起可见。如果返回 false，则已删除行与当前行集合一起不可见。默认值为 false。

    出于安全考虑或为了更好地适合某些部署情况，标准的 rowset 实现可以选择限制此行为。这是由实现定义的，并不表示标准行为。

    注：允许保持已删除行可见会使某些标准 JDBC RowSet 实现方法的行为变得复杂。但是，多数 rowset 用户可以简单地忽略此额外细节，因为只有极其特殊的应用程序才会利用此功能。

    返回：
    如果已删除行是可见的，则返回 true；否则返回 false
    抛出：
    SQLException - 如果 rowset 实现无法确定标记为删除的行是否可见
    另请参见：
    setShowDeleted(boolean)

    setShowDeleted

    void setShowDeleted(boolean b)
                    throws SQLException
    将属性 showDeleted 设置为给定的 boolean 值，它确定标记为删除的行是否会出现在当前行集合中。如果将值设置为 true，则已删除行与当前行集合一起立即可见。如果将值设置为 false，则已删除行与当前行集合一起被设置为不可见。

    出于安全考虑或为了更好地适合某些部署情况，标准的 rowset 实现可以选择限制此行为。这是由实现定义的，并不表示标准行为。

    参数：
    b - 如果应该显示已删除行，则为 true；否则为 false
    抛出：
    SQLException - 如果 rowset 实现无法重置已删除行是否应该可见
    另请参见：
    getShowDeleted()

    commit

    void commit()
            throws SQLException
    每个 CachedRowSet 对象的 SyncProvider 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。此方法包装 Connection 提交方法，以允许灵活的自动提交或非自动提交事务控制支持。

    使自从上一次提交/回滚以来 acceptChanges() 方法进行的所有更改成为持久更改。此方法应该只在已禁用自动提交模式时使用。

    抛出：
    SQLException - 如果发生数据库访问错误或者此 CachedRowSet 内的 Connection 对象处于自动提交模式下
    另请参见：
    Connection.setAutoCommit(boolean)

    rollback

    void rollback()
              throws SQLException
    每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。

    撤消当前事务中所做的所有更改。此方法应该只在已禁用自动提交模式时使用。

    抛出：
    SQLException - 如果发生数据库访问错误或者此 CachedRowSet 内的 Connection 对象处于自动提交模式下。

    rollback

    void rollback(Savepoint s)
              throws SQLException
    每个 CachedRowSet 对象的 SyncProvider 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。

    撤消当前事务中所做的所有更改，回到上一次 Savepoint 事务标记。此方法应该只在已禁用自动提交模式时使用。

    参数：
    s - Savepoint 事务标记
    抛出：
    SQLException - 如果发生数据库访问错误或者此 CachedRowSet 内的 Connection 对象处于自动提交模式下。

    rowSetPopulated

    void rowSetPopulated(RowSetEvent event,
                     int numRows)
                     throws SQLException
    通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。numRows 参数确保只在每隔 numRow 行时才触发此事件。

    可使用方法 event.getSource 获取事件源。

    参数：
    event - 一个 RowSetEvent 对象，包含作为事件源的 RowSet 对象
    numRows - 填入此值时，指示生成的 CachedRowSet 应该触发事件的行间隔数；默认值是 0；不能小于 fetchSize 或 0
    抛出：
    SQLException

    populate

    void populate(ResultSet rs,
              int startRow)
              throws SQLException
    使用取自给定 ResultSet 对象的数据填充此 CachedRowSet 对象。虽然与 populate(ResultSet) 方法十分类似，但此方法提供了一个额外的参数，允许指定 ResultSet 内开始使用数据填充 CachedRowSet 实例的位置。

    当应用程序具有到开放 ResultSet 对象的连接时，此方法可作为 execute 方法的替代方法。使用方法 populate 比使用无参数的 execute 方法要更为高效，因为它不用打开新的连接和重新执行此 CachedRowSet 对象的命令。与采用 ResultSet 对象的 execute 相比，使用 populate 方法要更为便捷。

    参数：
    startRow - ResultSet 中的位置，从其处开始填充此 CachedRowSet 的记录
    rs - 一个 ResultSet 对象，包含要读入到此 CachedRowSet 对象的数据
    抛出：
    SQLException - 如果提供的 ResultSet 对象为 null 或者此 CachedRowSet 对象无法获取关联的 ResultSetMetaData 对象
    另请参见：
    execute(java.sql.Connection), populate(ResultSet), ResultSet, ResultSetMetaData

    setPageSize

    void setPageSize(int size)
                 throws SQLException
    设置 CachedRowSet 对象的页大小。可以配置 CachedRowSet 以页大小的行数来填充 CachedRowSet。调用 populate() 或 execute() 时，CachedRowSet 都根据用于填充 RowSet 的原始 SQL 查询来获取附加页。

    参数：
    size - CachedRowSet 的页大小
    抛出：
    SQLException - 如果设置 CachedRowSet 页大小时发生错误或者页大小小于 0。

    getPageSize

    int getPageSize()
    返回 CachedRowSet 对象的页大小。

    返回：
    int 值的页大小

    nextPage

    boolean nextPage()
                 throws SQLException
    逐个增加 CachedRowSet 的当前页。如果剩余行仍在用于填充 RowSet 的原始 SQL 查询范围内，则此方法导致 CachedRowSet 实现获取下一个页面大小的行并填充 RowSet。

    返回：
    如果还有其他页，则返回 true；如果这是最后一页，则返回 false
    抛出：
    SQLException - 如果获取下一页时发生错误，或者在调用 populate 或 execute 之前过早地调用了此方法。

    previousPage

    boolean previousPage()
                     throws SQLException
    逐个减少 CachedRowSet 的当前页。这导致 CachedRowSet 实现获取前一个页面大小的行并填充 RowSet。前一页中返回的行数必须始终在用于填充 RowSet 的原始 SQL 查询范围内。

    返回：
    如果成功地获取了前一页，则返回 true；如果这是第一页，则返回 false。
    抛出：
    SQLException - 如果获取前一页时发生错误，或者在调用 populate 或 execute 之前过早地调用了此方法。
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FilteredRowSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
接口 FilteredRowSet

所有超级接口：
CachedRowSet, Joinable, ResultSet, RowSet, WebRowSet, Wrapper
public interface FilteredRowSet
extends WebRowSet

所有标准 FilteredRowSet 实现都必须实现的标准接口。FilteredRowSetImpl 类提供了可在需要时扩展的参考实现。另外，供应商可通过实现此接口来随意实现其自己的版本。

1.0 背景

有时 RowSet 对象需要对其内容进行某种程度的过滤。一种可能的解决方案是为所有标准的 RowSet 实现提供一种查询语言；但是这对诸如非连接 RowSet 对象之类的轻量级组件而言是一种不切实际的方法。FilteredRowSet 接口寻求在不提供重量级查询语言和这种查询语言所需处理的情况下解决这一需求问题。

JDBC FilteredRowSet 标准实现可实现 RowSet 接口并扩展 CachedRowSetTM 类。CachedRowSet 类提供了一组受保护的光标操纵方法，FilteredRowSet 实现可重写这些方法将来提供过滤支持。

2.0 Predicate 共享

如果使用父接口中继承的 createShared 方法共享了 FilteredRowSet 实现，则应所有 FilteredRowSet 实例副本应共享 Predicate 并不做任何修改。

3.0 使用

通过实现 Predicate（请参阅 Predicate 类 JavaDoc 中的示例），便可以按下述方式使用 FilteredRowSet。

     FilteredRowSet frs = new FilteredRowSetImpl();
     frs.populate(rs);

     Range name = new Range("Alpha", "Bravo", "columnName");
     frs.setFilter(name);

     frs.next() // only names from "Alpha" to "Bravo" will be returned
在上面的示例中，我们初始化了一个 Range 对象，它实现了 Predicate 接口。此对象表示以下约束条件：从此 FilteredRowSet 对象输出或修改的所有行必须在列 'columnName' 中，在值 'Alpha' 和 'Bravo' 之间（包括这两个值）。如果对不包含过滤器范围内的数据的 FilteredRowSet 对象应用过滤器，则不返回任何行。

此框架允许多个类实现 predicate，从而能以组合方式使用其来达到所需的过滤结果，无需进行查询语言处理。

4.0 更新 FilteredRowSet 对象

在 FilteredRowSet 对象上设置的 predicate 对 RowSet 对象中的所有行应用了一个标准，用来管理 RowSet 对象中的一个行子集。此标准控制可见的行子集，定义可以被修改、删除或插入的列。

因此，必须将 FilteredRowSet 对象上设置的 predicate 视为双向的，将设置的标准视为 FilteredRowSet 对象的所有视图和更新的控制机制。试图更新违反该标准的 FilteredRowSet 将导致抛出 SQLException 对象。

可在任何时间向 FilteredRowSet 实例应用新的 Predicate 对象来修改 FilteredRowSet 范围标准。如果没有检测到对 FilteredRowSet 对象的任何附加引用，则修改范围标准是可能的。新的过滤器对 FilteredRowSet 对象内所执行的标准会立即产生影响，所有后续视图和更新都将受到类似执行的影响。

5.0 过滤器外部各行的行为

在移除过滤器或应用新的过滤器之前，不能修改那些位于 FilteredRowSet 对象上设置的过滤器范围外的各行。

此外，只有位于过滤器范围内的各行才与数据源同步。

字段摘要
从接口 javax.sql.rowset.WebRowSet 继承的字段
PUBLIC_XML_SCHEMA, SCHEMA_SYSTEM_ID
从接口 javax.sql.rowset.CachedRowSet 继承的字段
COMMIT_ON_ACCEPT_CHANGES
从接口 java.sql.ResultSet 继承的字段
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
方法摘要
Predicate | getFilter() 获取此 FilteredRowSet 对象的活动过滤器。
void | setFilter(Predicate p) 将给定的 Predicate 对象应用到此 FilteredRowSet 对象。
从接口 javax.sql.rowset.WebRowSet 继承的方法
readXml, readXml, writeXml, writeXml, writeXml, writeXml
从接口 javax.sql.rowset.CachedRowSet 继承的方法
acceptChanges, acceptChanges, columnUpdated, columnUpdated, commit, createCopy, createCopyNoConstraints, createCopySchema, createShared, execute, getKeyColumns, getOriginal, getOriginalRow, getPageSize, getRowSetWarnings, getShowDeleted, getSyncProvider, getTableName, nextPage, populate, populate, previousPage, release, restoreOriginal, rollback, rollback, rowSetPopulated, setKeyColumns, setMetaData, setOriginalRow, setPageSize, setShowDeleted, setSyncProvider, setTableName, size, toCollection, toCollection, toCollection, undoDelete, undoInsert, undoUpdate
从接口 javax.sql.RowSet 继承的方法
addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername
从接口 java.sql.ResultSet 继承的方法
absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap
从接口 javax.sql.rowset.Joinable 继承的方法
getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

方法详细信息

setFilter

void setFilter(Predicate p)
               throws SQLException
将给定的 Predicate 对象应用到此 FilteredRowSet 对象。过滤器同时控制入境 (inbound) 视图和出境 (outbound) 视图，限制哪些行是可见的，哪些行是可以操作的。

可以在任何时间设置新的 Predicate 对象。这样可以更改 RowSet 对象数据上的约束条件。另外，在运行时修改过滤器会出现问题，所以多个组件可以在一个 FilteredRowSet 对象上进行操作。当 FilteredRowSet 对象的底层 Predicate 对象更改时，应用程序开发人员必须负责管理对 FilteredRowSet 对象的多重处理。

参数：
p - Predicate 对象，它定义了此 FilteredRowSet 对象的过滤器。设置 null 值将清除 predicate，允许所有行成为可见行。
抛出：
SQLException - 如果在设置 Predicate 对象时发生错误

getFilter

Predicate getFilter()
获取此 FilteredRowSet 对象的活动过滤器。

返回：
此 FilteredRowSet 对象的 Predicate；如果没有设置过滤器，则返回 null。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JdbcRowSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
接口 JdbcRowSet

所有超级接口：
Joinable, ResultSet, RowSet, Wrapper
public interface JdbcRowSet
extends RowSet, Joinable

所有标准 JdbcRowSet 实现都必须实现的标准接口。

1.0 概述

ResultSet 对象的包装器使得将该结果集用作 JavaBeansTM 组件成为可能。因此，JdbcRowSet 对象可以是某个 Beans，是可用于组成应用程序的工具。因为 JdbcRowSet 是一个连接的 rowset，也就是说，它使用启用 JDBC 技术的驱动程序来维持它与数据库的连接，所以它也能有效地使驱动程序成为 JavaBeans 组件。

因为它始终连接到其数据库，所以 JdbcRowSet 的实例可以简单地采用在其上进行调用的方法，并依次对其 ResultSet 对象调用这些方法。因此，结果集可以是（举例来说）Swing 应用程序中的一个组件。

JdbcRowSet 对象的另一个优点是可使用它让 ResultSet 对象可滚动和可更新。默认情况下，所有 RowSet 对象都是可滚动的和可更新的。如果使用的驱动程序和数据库不支持结果集的滚动和/或更新，则应用程序可以组装一个带 ResultSet 对象数据的 JdbcRowSet 对象，然后在该 JdbcRowSet 对象上操作，就好像它是 ResultSet 对象一样。

2.0 创建 JdbcRowSet 对象

JdbcRowSet 接口的参考实现 JdbcRowSetImpl 提供了默认构造方法的实现。使用默认值初始化新的实例，可根据需要使用新值设置这些默认值。在调用新实例的 execute 方法之前，它实际上无法真正发挥作用。通常，此方法执行以下操作：
  • 建立与数据库的连接
  • 创建一个 PreparedStatement 对象并设置其所有占位符参数
  • 执行语句来创建 ResultSet 对象
如果 execute 方法执行成功，则使用以下内容设置适当的私有 JdbcRowSet 字段：
  • Connection 对象 -- rowset 和数据库之间的连接
  • PreparedStatement 对象 -- 生成结果集的查询
  • ResultSet 对象 -- rowset 的命令所生成的和正在生成的结果集，实际上是一个 JavaBeans 组件
如果尚未设置这些字段，则意味着尚未成功执行 execute 方法，此时除 execute 和 close 以外，不能在该 rowset 上调用任何方法。调用所有其他公共方法都会抛出异常。

但是在调用 execute 方法之前，必须设置那些建立连接所需的命令和属性。以下代码片断创建了一个 JdbcRowSetImpl 对象、设置命令连接属性、设置占位符参数，然后调用方法 execute。

     JdbcRowSetImpl jrs = new JdbcRowSetImpl();
     jrs.setCommand("SELECT * FROM TITLES WHERE TYPE = ?");
     jrs.setURL("jdbc:myDriver:myAttribute");
     jrs.setUsername("cervantes");
     jrs.setPassword("sancho");
     jrs.setString(1, "BIOGRAPHY");
     jrs.execute();
变量 jrs 现在表示一个 JdbcRowSetImpl 实例，它是 ResultSet 对象的一个瘦包装器，而该对象包含了表 TITLES 中书籍类型为传记的所有行。此时，在 jrs 上调用的操作将影响结果集中的各行，该结果集实际上是一个 JavaBeans 组件。

JdbcRowSet 参考实现中的 RowSet 方法 execute 的实现与 CachedRowSetTM 参考实现中的不同，从而导致对已连接和非连接 RowSet 对象的不同要求。

字段摘要
从接口 java.sql.ResultSet 继承的字段
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
方法摘要
void | commit() 每个 JdbcRowSet 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。
boolean | getAutoCommit() 每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
RowSetWarning | getRowSetWarnings() 获取此 JdbcRowSet 对象上的调用报告的第一个警告。
boolean | getShowDeleted() 获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。
void | rollback() 每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
void | rollback(Savepoint s) 每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
void | setAutoCommit(boolean autoCommit) 每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。
void | setShowDeleted(boolean b) 将属性 showDeleted 设置为给定的 boolean 值。
从接口 javax.sql.RowSet 继承的方法
addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername
从接口 java.sql.ResultSet 继承的方法
absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap
从接口 javax.sql.rowset.Joinable 继承的方法
getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

方法详细信息

getShowDeleted

boolean getShowDeleted()
                       throws SQLException
获取一个 boolean 值，该值指示标记为删除的行是否会出现在当前行集合中。如果返回 true，则已删除行与当前行一起可见。如果返回 false，则已删除行与当前行集合一起不可见。默认值为 false。

出于安全考虑或为了某些部署情况，标准的 rowset 实现可以选择限制此行为。已删除行的可见性是实现定义的，并不表示标准行为。

注：允许保持已删除行可见会使某些标准 JDBC RowSet 实现方法的行为变得复杂。但是，多数 rowset 用户可以简单地忽略此额外细节，因为只有极其特殊的应用程序才会利用此功能。

返回：
如果已删除行是可见的，则返回 true；否则返回 false
抛出：
SQLException - 如果 rowset 实现无法确定是否使标记为删除的行保持可见
另请参见：
setShowDeleted(boolean)

setShowDeleted

void setShowDeleted(boolean b)
                    throws SQLException
将属性 showDeleted 设置为给定的 boolean 值。此属性确定标记为删除的行是否继续出现在当前行集合中。如果将值设置为 true，则已删除行与当前行集合一起立即可见。如果将值设置为 false，则已删除行与当前行集合一起被设置为不可见。

出于安全考虑或为了某些部署情况，标准的 rowset 实现可以选择限制此行为。这是由实现定义的，并不表示标准行为。

参数：
b - 如果应该显示已删除行，则为 true；否则为 false
抛出：
SQLException - 如果 rowset 实现无法重置已删除行是否应该可见
另请参见：
getShowDeleted()

getRowSetWarnings

RowSetWarning getRowSetWarnings()
                                throws SQLException
获取此 JdbcRowSet 对象上的调用报告的第一个警告。如果此 JdbcRowSet 对象上报告了第二个警告，则将它链接到第一个警告，并可通过在第一个警告上调用方法 RowSetWarning.getNextWarning 来获取该警告。此 JdbcRowSet 对象上的后续警告会被链接到方法 RowSetWarning.getNextWarning 返回的 RowSetWarning 对象。 每次读取新行时，都会自动清除警告链。不可以在已经关闭的 RowSet 对象上调用此方法；这样做将导致抛出 SQLException。

因为 JdbcRowSet 对象始终连接到其数据源，所以该对象可以依靠现有的活动 Statement、Connection 和 ResultSet 实例。这意味着应用程序可以通过调用 getNextWarning 方法来获得所提供的附加 SQLWarning 通知。非连接 Rowset 对象（如 CachedRowSet 对象）不必访问这些 getNextWarning 方法。

返回：
此 JdbcRowSet 对象上报告第一个 RowSetWarning 对象，如果没有则为 null
抛出：
SQLException - 如果在已关闭的 JdbcRowSet 对象上调用此方法
另请参见：
RowSetWarning

commit

void commit()
            throws SQLException
每个 JdbcRowSet 都包含一个取自 ResultSet 的 Connection 对象或传递到其构造方法的 JDBC 属性。此方法包装 Connection 提交方法，以允许灵活的自动提交或非自动提交事务控制支持。

使自从上一次提交/回滚以来进行的所有更改成为持久更改，并释放此 Connection 对象当前保存的所有数据库锁定。此方法应该只在已禁用自动提交模式时使用。

抛出：
SQLException - 如果发生数据库访问错误或者此 JdbcRowSet 内的 Connection 对象处于自动提交模式下
另请参见：
Connection.setAutoCommit(boolean)

getAutoCommit

boolean getAutoCommit()
                      throws SQLException
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。此方法包装 Connection 的 getAutoCommit 方法，以允许应用程序确定 JdbcRowSet 的事务行为。

将此 connection 的自动提交模式设置为给定的状态。如果 connection 处于自动提交模式下，则将执行其所有 SQL 语句，并将这些语句作为单独的事务提交。否则，其 SQL 语句将成组地进入通过调用 commit 方法或 rollback 方法终止的事务中。默认情况下，新的 connection 处于自动提交模式下。

抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Connection.getAutoCommit()

setAutoCommit

void setAutoCommit(boolean autoCommit)
                   throws SQLException
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。此方法包装 Connection 的 getAutoCommit 方法，以允许应用程序设置 JdbcRowSet 的事务行为。

设置此 Connection 对象的当前自动提交模式。

抛出：
SQLException - 如果发生数据库访问错误
另请参见：
Connection.setAutoCommit(boolean)

rollback

void rollback()
              throws SQLException
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。取消在当前事务中进行的所有更改，并释放此 Connection 对象当前保存的所有数据库锁定。此方法应该只在已禁用自动提交模式时使用。

抛出：
SQLException - 如果发生数据库访问错误或者此 JdbcRowSet 内的 Connection 对象处于自动提交模式下。
另请参见：
rollback(Savepoint)

rollback

void rollback(Savepoint s)
              throws SQLException
每个 JdbcRowSet 都包含一个取自原始 ResultSet 的 Connection 对象或传递给它的 JDBC 属性。取消在当前事务中进行的所有更改，一直到最后设置的保存点，并释放此 Connection 对象当前保存的所有数据库锁定。此方法应该只在已禁用自动提交模式时使用。

抛出：
SQLException - 如果发生数据库访问错误或者此 JdbcRowSet 内的 Connection 对象处于自动提交模式下。
另请参见：
rollback()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Joinable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
接口 Joinable

所有已知子接口：
CachedRowSet, FilteredRowSet, JdbcRowSet, JoinRowSet, WebRowSet
public interface Joinable

1.0 背景

Joinable 接口提供了用于获取和设置匹配列的各种方法，匹配列是形成通过将 RowSet 对象添加到 JoinRowSet 对象所形成的 SQL JOIN 的基础。

任何标准 RowSet 实现都可以实现 Joinable 接口，以便能够被添加到 JoinRowSet 对象中。实现此接口使 RowSet 对象能够使用各种 Joinable 方法，这些方法可设置、检索和获取有关匹配列的信息。应用程序可以将尚未实现 Joinable 接口的 RowSet 对象添加到 JoinRowSet 对象中，但是这样做必须使用一个同时带有 RowSet 对象和匹配列（或者 RowSet 对象数组和匹配列数组）的 JoinRowSet.addRowSet 方法。

要获取访问 Joinable 接口中的方法，RowSet 对象至少要实现 5 个标准 RowSet 接口中的一个并且要实现 Joinable 接口。另外，多数 RowSet 对象扩展了 BaseRowSet 类。例如：

     class MyRowSetImpl extends BaseRowSet implements CachedRowSet, Joinable {
         :
         :
     }

2.0 使用指南

Joinable 接口中的方法允许 RowSet 对象设置匹配列、获取匹配列或取消设置匹配列，匹配列是 SQL JOIN 的基础。可将实现这些方法的类的实例添加到 JoinRowSet 对象，以便允许建立 SQL JOIN 关系。

     CachedRowSet crs = new MyRowSetImpl();
     crs.populate((ResultSet)rs);
     (Joinable)crs.setMatchColumnIndex(1);

     JoinRowSet jrs = new JoinRowSetImpl();
     jrs.addRowSet(crs);
在上例中，crs 是一个已经实现了 Joinable 接口的 CachedRowSet 对象。在下例中，crs2 没有实现 Joinable 接口，所以它必须将匹配列作为参数提供给 addRowSet 方法。此示例假定列 1 是匹配列。
     CachedRowSet crs2 = new MyRowSetImpl();
     crs2.populate((ResultSet)rs);

     JoinRowSet jrs2 = new JoinRowSetImpl();
     jrs2.addRowSet(crs2, 1);

JoinRowSet 接口使它能够从已合并为一个表的一个或多个 RowSet 对象获取数据，从而避免了创建数据库连接的开销。因此理论上它非常适合于非连接 RowSet 对象使用。尽管如此，任何 RowSet 对象都可以实现此接口，无论它是连接的还是非连接的。注意，始终连接到其数据源的 JdbcRowSet 对象可以直接成为 SQL JOIN 的一部分，而不必先成为 JoinRowSet 对象的一部分。

3.0 管理多个匹配列

传递到 setMatchColumn 方法中的索引数组除了指示将用于匹配的列外，还指示要设置的匹配列数（数组的长度）。例如：
     int[] i = {1, 2, 4, 7}; // indicates four match columns, with column
                             // indexes 1, 2, 4, 7 participating in the JOIN.
     Joinable.setMatchColumn(i);
可按以下方式将后续匹配列添加到不同 Joinable 对象（已经实现 Joinable 接口的 RowSet 对象）。
     int[] w = {3, 2, 5, 3};
     Joinable2.setMatchColumn(w);
当应用程序向 JoinRowSet 对象添加两个或更多 RowSet 对象时，数组中索引的顺序特别重要。每个数组索引都直接映射到以前添加的 RowSet 对象的相应索引。如果出现重叠或间隙，则匹配列数据将被保留在添加了附加 Joinable RowSet 并需要关联匹配列数据的事件中。因此，应用程序可以以任意顺序设置多个匹配列，但是此顺序对 SQL JOIN 的结果有直接的影响。

此断言在使用列名而不是列索引来指示匹配列时也同样适用。

另请参见：
JoinRowSet

方法摘要
int[] | getMatchColumnIndexes() 获取使用方法 setMatchColumn(int[] columnIdxes) 为此 RowSet 对象设置的匹配列的索引。
String[] | getMatchColumnNames() 获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。
void | setMatchColumn(int columnIdx) 将指定的列设置为此 RowSet 对象的匹配列。
void | setMatchColumn(int[] columnIdxes) 将指定的列设置为此 RowSet 对象的匹配列。
void | setMatchColumn(String columnName) 将指定的列设置为此 RowSet 对象的匹配列。
void | setMatchColumn(String[] columnNames) 将指定的列设置为此 RowSet 对象的匹配列。
void | unsetMatchColumn(int columnIdx) 取消将指定的列设置为此 RowSet 对象的匹配列。
void | unsetMatchColumn(int[] columnIdxes) 取消将指定的列设置为此 RowSet 对象的匹配列。
void | unsetMatchColumn(String columnName) 取消将指定的列设置为此 RowSet 对象的匹配列。
void | unsetMatchColumn(String[] columnName) 取消将指定的列设置为此 RowSet 对象的匹配列。

方法详细信息

setMatchColumn

void setMatchColumn(int columnIdx)
                    throws SQLException
将指定的列设置为此 RowSet 对象的匹配列。现在 JoinRowSet 对象可以根据匹配列添加此 RowSet 对象。

子接口（如 CachedRowSetTM 接口）定义了方法 CachedRowSet.setKeyColumns，该方法允许在具体列上强制执行主键语义。当 CachedRowSet 对象将主键列设置为匹配列时，setMatchColumn(int columnIdx) 方法的实现应该确保坚持关于键列的约束条件。

参数：
columnIdx - 一个 int 值，标识要设置为匹配列的列索引
抛出：
SQLException - 如果设置了无效的列索引
另请参见：
setMatchColumn(int[]), unsetMatchColumn(int)

setMatchColumn

void setMatchColumn(int[] columnIdxes)
                    throws SQLException
将指定的列设置为此 RowSet 对象的匹配列。现在 JoinRowSet 对象可以根据匹配列添加此 RowSet 对象。

参数：
columnIdxes - 一个 int 数组，标识要设置为匹配列的列索引
抛出：
SQLException - 如果设置了无效的列索引
另请参见：
setMatchColumn(int[]), unsetMatchColumn(int[])

setMatchColumn

void setMatchColumn(String columnName)
                    throws SQLException
将指定的列设置为此 RowSet 对象的匹配列。现在 JoinRowSet 对象可以根据匹配列添加此 RowSet 对象。

子接口（如 CachedRowSet 接口）定义方法 CachedRowSet.setKeyColumns，该方法允许在具体列上强制执行主键语义。当 CachedRowSet 对象将主键列设置为匹配列时，setMatchColumn(String columnIdx) 方法的实现应该确保坚持关于键列的约束条件。

参数：
columnName - String 对象，提供了要设置为匹配列的列名
抛出：
SQLException - 如果设置了无效的列名、列名为 null 或列名是空字符串
另请参见：
unsetMatchColumn(int), setMatchColumn(int[])

setMatchColumn

void setMatchColumn(String[] columnNames)
                    throws SQLException
将指定的列设置为此 RowSet 对象的匹配列。现在 JoinRowSet 对象可以根据匹配列添加此 RowSet 对象。

参数：
columnNames - String 对象数组，提供了要设置为匹配列的列名
抛出：
SQLException - 如果设置了无效的列名、列名为 null 或列名是空字符串
另请参见：
unsetMatchColumn(int), setMatchColumn(int[])

getMatchColumnIndexes

int[] getMatchColumnIndexes()
                            throws SQLException
获取使用方法 setMatchColumn(int[] columnIdxes) 为此 RowSet 对象设置的匹配列的索引。

返回：
int 数组，标识已设置为此 RowSet 对象匹配列的列索引
抛出：
SQLException - 如果未设置任何匹配列
另请参见：
setMatchColumn(int), unsetMatchColumn(int)

getMatchColumnNames

String[] getMatchColumnNames()
                             throws SQLException
获取使用方法 setMatchColumn(String [] columnNames) 为此 RowSet 对象设置的匹配列的名称。

返回：
String 对象数组，提供了已设置为此 RowSet 对象匹配列的列名称
抛出：
SQLException - 如果未设置任何匹配列
另请参见：
setMatchColumn(int), unsetMatchColumn(int)

unsetMatchColumn

void unsetMatchColumn(int columnIdx)
                      throws SQLException
取消将指定的列设置为此 RowSet 对象的匹配列。

在指定的列上调用方法 CachedRowSet.unsetKeyColumns 之前，实现了 Joinable 接口的 RowSet 对象必须确保可继续强制执行与键有关的约束条件。

参数：
columnIdx - 一个 int 值，标识被取消设置为匹配列的列索引
抛出：
SQLException - 如果指定了无效的列索引或者指定的列以前未被设置为匹配列
另请参见：
setMatchColumn(int)

unsetMatchColumn

void unsetMatchColumn(int[] columnIdxes)
                      throws SQLException
取消将指定的列设置为此 RowSet 对象的匹配列。

参数：
columnIdxes - int 数组，标识被取消设置为匹配列的列索引
抛出：
SQLException - 如果指定了无效的列索引或者指定的列以前未被设置为匹配列
另请参见：
setMatchColumn(int)

unsetMatchColumn

void unsetMatchColumn(String columnName)
                      throws SQLException
取消将指定的列设置为此 RowSet 对象的匹配列。

在指定的列上调用方法 CachedRowSet.unsetKeyColumns 之前，实现了 Joinable 接口的 RowSet 对象必须确保可继续强制执行与键有关的约束条件。

参数：
columnName - String 对象，提供了被取消设置为匹配列的列名
抛出：
SQLException - 如果指定了无效的列名或者指定的列以前未被设置为匹配列
另请参见：
setMatchColumn(int)

unsetMatchColumn

void unsetMatchColumn(String[] columnName)
                      throws SQLException
取消将指定的列设置为此 RowSet 对象的匹配列。

参数：
columnName - String 对象数组，提供了被取消设置为匹配列的列名
抛出：
SQLException - 如果指定了无效的列名或者指定的列以前未被设置为匹配列
另请参见：
setMatchColumn(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JoinRowSet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
接口 JoinRowSet

所有超级接口：
CachedRowSet, Joinable, ResultSet, RowSet, WebRowSet, Wrapper
public interface JoinRowSet
extends WebRowSet

JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。换句话说，JoinRowSet 对象可作为一个数据容器，这些数据取自那些形成 SQL JOIN 关系的 RowSet 对象。

Joinable 接口提供了一些用于设置、获取和取消设置匹配列的方法，匹配列建立 SQL JOIN 关系的基础。通过将匹配列提供给恰当形式的 JointRowSet 方法 addRowSet 也可设置匹配列。

1.0 概述

无连接的 RowSet 对象（CachedRowSet 对象和扩展 CachedRowSet 接口的实现）没有一种能在 RowSet 之间建立 SQL JOIN且无需重新连接数据源（该操作开销很大）的标准方式。JoinRowSet 接口是专门为解决这一需求而设计的。

任何 RowSet 对象都可添加到 JoinRowSet 对象，以成为 SQL JOIN 关系的一部分。这意味着已连接和无连接的 RowSet 对象都可成为 JOIN 的一部分。鼓励在连接环境中运行的 RowSet 对象（JdbcRowSet 对象）使用它们已连接的数据库直接在表之间建立 SQL JOIN 关系。但必要时也可以将 JdbcRowSet 对象添加到 JoinRowSet 对象中。

可将任意数目的 RowSet 对象添加到 JoinRowSet 的实例中，前提是只要这些对象可以在 SQL JOIN 中关联起来。根据定义，SQL JOIN 语句用于将两个或多个基于某个公共属性的关系数据库表中所包含的数据组合在一起。Joinable 接口提供了用于建立公共属性的方法，可通过设置匹配列 来建立。匹配列通常与主键相符，但是不要求匹配列与主键相同。通过建立然后强制执行匹配列，JoinRowSet 对象可在 RowSet 对象之间建立 JOIN 关系，无需可用关系型数据库的协助。

可通过使用方法 setJoinType 设置某个 JoinRowSet 常量来确定要建立的 JOIN 的类型。可设置以下 SQL JOIN 类型：

  • CROSS_JOIN
  • FULL_JOIN
  • INNER_JOIN - 未设置 JOIN 类型时使用的默认值
  • LEFT_OUTER_JOIN
  • RIGHT_OUTER_JOIN
注意，如果未设置类型，则 JOIN 将自动为 INNER_JOIN。JoinRowSet 接口中各字段的注释说明了这些 JOIN 类型，它们都是标准的 SQL JOIN 类型。

2.0 使用 JoinRowSet 对象创建 JOIN

当创建了一个 JoinRowSet 对象时，它是空的。要添加的第一个 RowSet 对象将成为 JOIN 关系的基础。应用程序必须确定在要添加到 JoinRowSet 对象的每个 RowSet 对象中，哪个列应该是匹配列。所有的 RowSet 对象必须包含匹配列，并且每个匹配列中的值必须可以与其他匹配列中的值相比较。这些列不必有相同的名称（虽然通常它们的名称相同），只要数据类型是可比较的，它们也不必存储完全相同的数据类型。

可用两种方式来设置匹配列：

  • 通过调用 Joinable 的方法 setMatchColumn
    将 RowSet 对象添加到 JoinRowSet 对象之前，这是可以设置匹配列的唯一方法。为了使用方法 setMatchColumn，RowSet 对象必须已经实现了 Joinable 接口。一旦设置了匹配列值，则可在任意时间使用此方法来重置匹配列。
  • 通过调用某种形式的 JoinRowSet 方法 addRowSet（使用列名或列号，或者列名数组或列号数组）
    5 个 addRowSet 方法中有 4 个采用匹配列作为参数。这 4 个方法可在将 RowSet 对象添加到 JoinRowSet 对象时设置或重置匹配列。

3.0 示例用法

以下代码片断将两个 CachedRowSet 对象添加到 JoinRowSet 对象中。注意，在此示例中未设置 SQL JOIN 类型，所以建立了默认的 JOIN 类型，即 INNER_JOIN。

在以下代码片断中，表 EMPLOYEES 被添加到 JoinRowSet 对象 jrs 中，该表的匹配列被设置为第一列 (EMP_ID)。然后添加表 ESSP_BONUS_PLAN，其匹配列同样是 EMP_ID 列。将第二个表添加到 jrs 时，只添加 EMP_ID 值匹配 EMPLOYEES 表 EMP_ID 值的 ESSP_BONUS_PLAN 中的行。在这种情况下，红利分配中的所有人都是雇员，所以表 ESSP_BONUS_PLAN 中的所有行都被添加 JoinRowSet 对象中。在此示例中，两个被添加的 CachedRowSet 对象都已实现了 Joinable 接口，因此都可调用 Joinable 方法 setMatchColumn。

     JoinRowSet jrs = new JoinRowSetImpl();

     ResultSet rs1 = stmt.executeQuery("SELECT * FROM EMPLOYEES");
     CachedRowSet empl = new CachedRowSetImpl();
     empl.populate(rs1);
     empl.setMatchColumn(1);
     jrs.addRowSet(empl);

     ResultSet rs2 = stmt.executeQuery("SELECT * FROM ESSP_BONUS_PLAN");
     CachedRowSet bonus = new CachedRowSetImpl();
     bonus.populate(rs2);
     bonus.setMatchColumn(1); // EMP_ID is the first column
     jrs.addRowSet(bonus);

此时，jrs 是两个 RowSet 对象基于其 EMP_ID 列的内部 JOIN。应用程序现在可以浏览已组合的数据，就好像在浏览单个 RowSet 对象一样。因为 jrs 本身是一个 RowSet 对象，所以应用程序可以使用 RowSet 方法浏览或修改它。

     jrs.first();
     int employeeID = jrs.getInt(1);
     String employeeName = jrs.getString(2);

注意，因为在应用程序添加第二个或后续 RowSet 对象时必须强制执行 SQL JOIN，所以在执行 JOIN 时最初会出现性能下降。

以下代码片断添加了一个附加 CachedRowSet 对象。在这种情况下，将 CachedRowSet 对象添加到 JoinRowSet 对象时设置匹配列 (EMP_ID)。

     ResultSet rs3 = stmt.executeQuery("SELECT * FROM 401K_CONTRIB");
     CachedRowSet fourO1k = new CachedRowSetImpl();
     four01k.populate(rs3);
     jrs.addRowSet(four01k, 1);

JoinRowSet 对象 jrs 现在包含取自所有三个表的值。EMP_ID 列值匹配 jrs 中 EMP_ID 列值的 four01k 中的每行数据都被添加到 jrs。

4.0 JoinRowSet 方法

JoinRowSet 接口提供了多种方法用于添加 RowSet 对象和获得有关 JoinRowSet 对象的信息。
  • 添加一个或多个 RowSet 对象的方法
    这些方法允许应用程序一次添加一个 RowSet 对象，或者一次添加多个 RowSet 对象。无论是哪种情况，该方法可以为要添加的每个 RowSet 对象指定匹配列。
  • 获得信息的方法
    一个方法获取 JoinRowSet 对象中的 RowSet 对象，另一个方法获取 RowSet 名称。第三个方法获取后台使用以形成 SQL JOIN 的 WHERE子句，或者有关 WHERE 子句作用的文本描述。
  • 与 JOIN 类型有关的方法
    一个方法设置 JOIN 类型，5 个方法用于查找 JoinRowSet 对象是否支持给定的类型。
  • 制作 JoinRowSet 对象单独副本的方法
    此方法创建一个副本，可与数据源保持一致。

字段摘要
static int | CROSS_JOIN ANSI 风格的 JOIN，提供两个表的交叉乘积。
static int | FULL_JOIN ANSI 风格的 JOIN，提供一个完全 JOIN。
static int | INNER_JOIN ANSI 风格的 JOIN，提供两个表之间的内联合 (inner join)。
static int | LEFT_OUTER_JOIN ANSI 风格的 JOIN，提供两个表之间的左外联合 (left outer join)。
static int | RIGHT_OUTER_JOIN ANSI 风格的 JOIN，提供两个表之间的右外联合 (right outer join)。
从接口 javax.sql.rowset.WebRowSet 继承的字段
PUBLIC_XML_SCHEMA, SCHEMA_SYSTEM_ID
从接口 javax.sql.rowset.CachedRowSet 继承的字段
COMMIT_ON_ACCEPT_CHANGES
从接口 java.sql.ResultSet 继承的字段
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
方法摘要
void | addRowSet(Joinable rowset) 将给定的 RowSet 对象添加到此 JoinRowSet 对象。
void | addRowSet(RowSet[] rowset, int[] columnIdx) 将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。
void | addRowSet(RowSet[] rowset, String[] columnName) 将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。
void | addRowSet(RowSet rowset, int columnIdx) 将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。
void | addRowSet(RowSet rowset, String columnName) 将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。
int | getJoinType() 返回一个 int 值，它描述控制此 JoinRowSet 实例的已设置 SQL JOIN 类型。
String[] | getRowSetNames() 返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。
Collection<?> | getRowSets() 返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。
String | getWhereClause() 返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。
void | setJoinType(int joinType) 允许应用程序调整在 JoinRowSet 对象实例包含的表上强制应用的 JOIN 类型。
boolean | supportsCrossJoin() 指示 JoinRowSet 实现是否支持 CROSS_JOIN。
boolean | supportsFullJoin() 指示 JoinRowSet 实现是否支持 FULL_JOIN。
boolean | supportsInnerJoin() 指示 JoinRowSet 实现是否支持 INNER_JOIN。
boolean | supportsLeftOuterJoin() 指示 JoinRowSet 实现是否支持 LEFT_OUTER_JOIN。
boolean | supportsRightOuterJoin() 指示 JoinRowSet 实现是否支持 RIGHT_OUTER_JOIN。
CachedRowSet | toCachedRowSet() 创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。
从接口 javax.sql.rowset.WebRowSet 继承的方法
readXml, readXml, writeXml, writeXml, writeXml, writeXml
从接口 javax.sql.rowset.CachedRowSet 继承的方法
acceptChanges, acceptChanges, columnUpdated, columnUpdated, commit, createCopy, createCopyNoConstraints, createCopySchema, createShared, execute, getKeyColumns, getOriginal, getOriginalRow, getPageSize, getRowSetWarnings, getShowDeleted, getSyncProvider, getTableName, nextPage, populate, populate, previousPage, release, restoreOriginal, rollback, rollback, rowSetPopulated, setKeyColumns, setMetaData, setOriginalRow, setPageSize, setShowDeleted, setSyncProvider, setTableName, size, toCollection, toCollection, toCollection, undoDelete, undoInsert, undoUpdate
从接口 javax.sql.RowSet 继承的方法
addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername
从接口 java.sql.ResultSet 继承的方法
absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap
从接口 javax.sql.rowset.Joinable 继承的方法
getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

字段详细信息

CROSS_JOIN

static final int CROSS_JOIN
ANSI 风格的 JOIN，提供两个表的交叉乘积。

另请参见：
常量字段值

INNER_JOIN

static final int INNER_JOIN
ANSI 风格的 JOIN，提供两个表之间的内联合 (inner join)。任一联合表中的所有不匹配列都应被丢弃。

另请参见：
常量字段值

LEFT_OUTER_JOIN

static final int LEFT_OUTER_JOIN
ANSI 风格的 JOIN，提供两个表之间的左外联合 (left outer join)。在 SQL 中，这可描述为应该从 JOIN 语句左侧表中返回所有记录的情况。

另请参见：
常量字段值

RIGHT_OUTER_JOIN

static final int RIGHT_OUTER_JOIN
ANSI 风格的 JOIN，提供两个表之间的右外联合 (right outer join)。在 SQL 中，这可描述为即使左侧的表没有匹配记录的情况下也应该从 JOIN 语句右侧表中返回所有记录的情况。

另请参见：
常量字段值

FULL_JOIN

static final int FULL_JOIN
ANSI 风格的 JOIN，提供一个完全 JOIN。指定不管在另一个表上是否有匹配的记录，都会返回任一表中的所有行。

另请参见：
常量字段值
方法详细信息

addRowSet

void addRowSet(Joinable rowset)
               throws SQLException
将给定的 RowSet 对象添加到此 JoinRowSet 对象。如果该 RowSet 对象是第一个添加到此 JoinRowSet 对象中的对象，则它形成要建立的 JOIN 关系的基础。

仅在给定的 RowSet 对象已经具有使用 Joinable 方法 setMatchColumn 所设置的匹配列时才应该使用此方法。

注：Joinable 是所有已经实现了 Joinable 接口的 RowSet 对象。

参数：
rowset - 要添加到此 JoinRowSet 对象的 RowSet 对象；它必须实现 Joinable 接口并且具有已设置的匹配列
抛出：
SQLException - 如果 (1) 将空的 rowset 添加到此 JoinRowSet 对象，(2) 尚未设置 rowset 的匹配列，或 (3) rowset 违反了活动状态的 JOIN
另请参见：
Joinable.setMatchColumn(int)

addRowSet

void addRowSet(RowSet rowset,
               int columnIdx)
               throws SQLException
将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。如果该 RowSet 对象是第一个添加到此 JoinRowSet 对象中的对象，则它形成要建立的 JOIN 关系的基础。

当尚未设置 RowSet 的匹配列时才应使用此方法。

参数：
rowset - 要添加到此 JoinRowSet 对象的 RowSet 对象；它可以实现 Joinable 接口
columnIdx - 一个 int 值，它标识要成为匹配列的列
抛出：
SQLException - 如果 (1) rowset 是一个空 rowset 或 (2) rowset 违反了活动状态的 JOIN
另请参见：
Joinable.unsetMatchColumn(int)

addRowSet

void addRowSet(RowSet rowset,
               String columnName)
               throws SQLException
将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。如果 rowset 是第一个添加到此 JoinRowSet 对象中的对象，则它形成要建立的 JOIN 关系的基础。

当给定的 RowSet 对象还没有匹配列时应该使用此方法。

参数：
rowset - 要添加到此 JoinRowSet 对象的 RowSet 对象；它可以实现 Joinable 接口
columnName - String 对象，它提供要设置为匹配列的列名
抛出：
SQLException - 如果 (1) rowset 是一个空 rowset 或 (2) rowset 的匹配列不满足 JOIN 的条件

addRowSet

void addRowSet(RowSet[] rowset,
               int[] columnIdx)
               throws SQLException
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。将 columnIdx 中的第一个元素设置为 rowset 中第一个 RowSet 对象的匹配列，将 columnIdx 中的第二个元素设置为 rowset 中第二个元素的匹配列，依此类推。

添加到此 JoinRowSet 对象的第一个 RowSet 对象形成 JOIN 关系的基础。

当给定的 RowSet 对象还没有匹配列时应该使用此方法。

参数：
rowset - 要添加到 JOIN 的一个或多个 RowSet 对象所组成的数组；它可以实现 Joinable 接口
columnIdx - 一个 int 值数组，指示要设置为 rowset 中 RowSet 对象的匹配列的列索引
抛出：
SQLException - 如果 (1) 将空的 rowset 添加到此 JoinRowSet 对象，(2) 没有设置 rowset 中 RowSet 对象的匹配列，或 (3) 要添加的 RowSet 对象违反了活动状态的 JOIN

addRowSet

void addRowSet(RowSet[] rowset,
               String[] columnName)
               throws SQLException
将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。将 columnName 中的第一个元素设置为 rowset 中第一个 RowSet 对象的匹配列，将 columnName 中的第二个元素设置为 rowset 中第二个元素的匹配列，依此类推。

添加到此 JoinRowSet 对象的第一个 RowSet 对象形成 JOIN 关系的基础。

当给定的 RowSet 对象还没有匹配列时应该使用此方法。

参数：
rowset - 要添加到 JOIN 的一个或多个 RowSet 对象所组成的数组；它可以实现 Joinable 接口
columnName - 一个 String 值数组，指示要设置为 rowset 中 RowSet 对象的匹配列的列名
抛出：
SQLException - 如果 (1) 将空的 rowset 添加到此 JoinRowSet 对象，(2) 没有设置 rowset 中 RowSet 对象的匹配列，或 (3) 要添加的 RowSet 对象违反了活动状态的 JOIN

getRowSets

Collection<?> getRowSets()
                         throws SQLException
返回一个 Collection 对象，包含已经添加到此 JoinRowSet 对象的 RowSet 对象。此方法应该返回 JOIN 内包含的 'n' 个 RowSet 并维持此并集中出现的所有更新。

返回：
一个 Collection 对象，由添加到此 JoinRowSet 对象的 RowSet 对象组成
抛出：
SQLException - 如果生成要返回的 Collection 对象时发生错误

getRowSetNames

String[] getRowSetNames()
                        throws SQLException
返回一个 String 数组，包含添加到此 JoinRowSet 对象的 RowSet 对象的名称。

返回：
此 JoinRowSet 对象中的 RowSet 对象名所组成的 String 数组
抛出：
SQLException - 如果获取 RowSet 对象的名称时发生错误
另请参见：
CachedRowSet.setTableName(java.lang.String)

toCachedRowSet

CachedRowSet toCachedRowSet()
                            throws SQLException
创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。

如果对 JoinRowSet 进行了任何更新或修改，则该方法返回的 CachedRowSet 无法使其更改与数据源中的原始行和表保持一致。返回的 CachedRowSet 实例不应包含修改数据，并且应该清除其原始 SQL 语句的所有属性。应用程序应该使用 RowSet.setCommand 方法重置 SQL 语句。

要允许更改与数据源中的原始表保持一致，应该使用 acceptChanges 方法并对 JoinRowSet 对象实例调用该方法。实现可以利用在其中跟踪的内部数据和更新来与 SyncProvider 进行交互，以保持所有更改不变。

返回：
包含 JoinRowSet 内容的 CachedRowSet
抛出：
SQLException - 如果组合 CachedRowSet 对象时发生错误
另请参见：
RowSet, CachedRowSet, SyncProvider

supportsCrossJoin

boolean supportsCrossJoin()
指示 JoinRowSet 实现是否支持 CROSS_JOIN。

返回：
如果支持 CROSS_JOIN，则返回 true；否则返回 false

supportsInnerJoin

boolean supportsInnerJoin()
指示 JoinRowSet 实现是否支持 INNER_JOIN。

返回：
如果支持 INNER_JOIN，则返回 true；否则返回 false

supportsLeftOuterJoin

boolean supportsLeftOuterJoin()
指示 JoinRowSet 实现是否支持 LEFT_OUTER_JOIN。

返回：
如果支持 LEFT_OUTER_JOIN，则返回 true；否则返回 false

supportsRightOuterJoin

boolean supportsRightOuterJoin()
指示 JoinRowSet 实现是否支持 RIGHT_OUTER_JOIN。

返回：
如果支持 RIGHT_OUTER_JOIN，则返回 true；否则返回 false

supportsFullJoin

boolean supportsFullJoin()
指示 JoinRowSet 实现是否支持 FULL_JOIN。

返回：
如果支持 FULL_JOIN，则返回 true；否则返回 false

setJoinType

void setJoinType(int joinType)
                 throws SQLException
允许应用程序调整在 JoinRowSet 对象实例包含的表上强制应用的 JOIN 类型。如果实现不支持给定的 JOIN 类型，则应抛出 SQLException。

参数：
joinType - SQL JOIN 的标准 JoinRowSet.XXX 静态字段定义，用来在运行过程中重新配置 JoinRowSet 实例。
抛出：
SQLException - 如果设置了不支持的 JOIN 类型
另请参见：
getJoinType()

getWhereClause

String getWhereClause()
                      throws SQLException
返回在 JoinRowSet 对象中使用的 WHERE 子句的类似 SQL 的描述。通过提供 JOIN 的 SQL 字符串描述或一个文本描述，一个实现可以描述 SQL JOIN 的 WHERE 子句，以协助应用程序使用 JoinRowSet。

返回：
whereClause，JoinRowSet 实例中使用的逻辑 WHERE 子句的文本或 SQL 描述
抛出：
SQLException - 如果生成 WHERE 子句的表示形式时发生错误。

getJoinType

int getJoinType()
                throws SQLException
返回一个 int 值，它描述控制此 JoinRowSet 实例的已设置 SQL JOIN 类型。返回的类型是标准的 JoinRowSet 类型之一：CROSS_JOIN、INNER_JOIN、LEFT_OUTER_JOIN、RIGHT_OUTER_JOIN 或 FULL_JOIN。

返回：
joinType，SQL JOIN 的某个标准 JoinRowSet 静态字段定义。在没有显式设置类型时，将 JoinRowSet.INNER_JOIN 作为默认的 JOIN 类型返回。
抛出：
SQLException - 如果在确定该 JoinRowSet 实例支持的 SQL JOIN 类型时发生错误。
另请参见：
setJoinType(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Predicate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
接口 Predicate

public interface Predicate

为所有 FilteredRowSet 对象提供框架以描述其过滤器的标准接口。

1.0 背景

Predicate 接口是一个标准接口，应用程序可以实现它来定义希望应用于 FilteredRowSet 对象的过滤器。FilteredRowSet 对象使用此接口的实现并实施在 evaluate 方法的实现中定义的各种约束。FilteredRowSet 对象以双向方式实施过滤器约束：它只输出过滤器的约束中存在的行；反之，也只插入、修改或更新过滤器的约束中存在的行。

2.0 实现指南

要为 FilteredRowSet 提供 predicate，则必须实现此接口。此时，JDBC RowSet Implementations (JSR-114) 不指定任何标准过滤器定义。通过为要使用 FilteredRowSet 接口的参考实现和供应商实现来定义和部署的过滤器范围指定一个标准的方法与机制，此接口允许形成一个应用程序驱动的 Predicate 的灵活实现。

示例实现如下所示：

    public class Range implements Predicate {

       private Object lo[];
       private Object hi[];
       private int idx[];

       public Range(Object[] lo, Object[] hi, int[] idx) {
          this.lo = lo;
          this.hi = hi;
          this.idx = idx;
       }

      public boolean evaluate(RowSet rs) {
          CachedRowSet crs = (CachedRowSet)rs;
          boolean bool1,bool2;

          // Check the present row determine if it lies
          // within the filtering criteria.

          for (int i = 0; i < idx.length; i++) {

                if ((rs.getObject(idx[i]) >= lo[i]) &&
                  (rs.getObject(idx[i]) >= hi[i]) {
                    bool1 = true; // within filter constraints
          } else {
            bool2 = true; // outside of filter constraints
          }
      }

      if (bool2) {
return false;
      } else {
return true;
      }
  }

上述示例实现一个简单的范围 predicate。注意，实现应该（但不是必须）提供基于 String 和整数索引的构造方法，供同时使用两种列标识约定的 JDBC RowSet Implementation 应用程序使用。

方法摘要
 boolean evaluate(Object value, int column)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。
 boolean evaluate(Object value, String columnName)
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。
 boolean evaluate(RowSet rs)
此方法通常称为 FilteredRowSet 对象内部方法（非公共），它控制 RowSet 对象的指针从一行移动到下一行。

方法详细信息

evaluate

boolean evaluate(RowSet rs)
此方法通常称为 FilteredRowSet 对象内部方法（非公共），它控制 RowSet 对象的指针从一行移动到下一行。此外，如果此内部方法将指针移动到一个已删除的行上，则其将继续移动指针，直到找到一个有效行为止。

返回：
如果在过滤器中存在更多行，则返回 true；否则返回 false

evaluate

boolean evaluate(Object value,
                 int column)
                 throws SQLException
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter() 方法设置的过滤标准（或标准，如果存在多个约束）中。

向 FilteredRowSet 实例插入新行时，FilteredRowSet 对象将在内部使用此方法。

参数：
value - 一个 Object 值，需要检查其是否可以为 FilterRowSet 对象的一部分。
column - 一个 int 对象，必须与此 RowSet 对象中列的 SQL 索引相匹配。初始化 Predicate 时，此值必须已作为要过滤的列之一传递给 Predicate
返回：
如果行值位于过滤器中，则返回 true；否则返回 false
抛出：
SQLException - 如果列不是过滤标准的一部分

evaluate

boolean evaluate(Object value,
                 String columnName)
                 throws SQLException
FilteredRowSet 对象调用此方法来检查值是否位于使用 setFilter 方法设置的过滤标准中。

向 FilteredRowSet 实例插入新行时，FilteredRowSet 对象将在内部使用此方法。

参数：
value - 一个 Object 值，需要检查其是否可以为 FilterRowSet 对象的一部分。
columnName - 一个 String 对象，必须与此 RowSet 中列的 SQL 名称相匹配（忽略大小写）。初始化 Predicate 时，此值必须作为要过滤的列之一传递给 Predicate。
返回：
如果值位于过滤器中，则返回 true；否则，返回 false。
抛出：
SQLException - 如果列不是过滤标准的一部分
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetMetaDataImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
类 RowSetMetaDataImpl

java.lang.Object
    继承者  javax.sql.rowset.RowSetMetaDataImpl
所有已实现的接口：
Serializable, ResultSetMetaData, Wrapper, RowSetMetaData
public class RowSetMetaDataImpl
extends Object
implements RowSetMetaData, Serializable

为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。RowSetMetaDataImpl 对象跟踪 rowset 中的列并为每个列维持一个列属性的内部数组。

RowSet 对象在内部创建 RowSetMetaDataImpl 对象以设置和获取关于其列的信息。

注：在填充 RowSetMetaDataImpl 对象所描述的 RowSet 对象之前，该对象中的所有元数据都应视为不可用。因此，在 RowSet 对象包含数据之前调用任何获取信息的 RowSetMetaDataImpl 方法所导致的行为都被定义为是不确定的。

另请参见：
序列化表格

字段摘要
从接口 java.sql.ResultSetMetaData 继承的字段
columnNoNulls, columnNullable, columnNullableUnknown
构造方法摘要
RowSetMetaDataImpl()
方法摘要
 String getCatalogName(int columnIndex)
获取派生指定列中值的表的类别名称。
 String getColumnClassName(int columnIndex)
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。
 int getColumnCount()
获取为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。
 int getColumnDisplaySize(int columnIndex)
获取以 char 为单位的指定列的正常最大宽度。
 String getColumnLabel(int columnIndex)
获取用于打印输出和显示的指定列的建议列标题。
 String getColumnName(int columnIndex)
获取指定列的名称。
 int getColumnType(int columnIndex)
获取存储在指定行中值的 SQL 类型的类型代码（java.sql.Types 常量之一）。
 String getColumnTypeName(int columnIndex)
获取存储在指定列中值的特定于 DBMS 的类型名称。
 int getPrecision(int columnIndex)
获取存储在指定列中的值的数字总数。
 int getScale(int columnIndex)
获取存储在指定列中的值的小数点右边的数字数。
 String getSchemaName(int columnIndex)
获取派生指定列中值的表的模式名称。
 String getTableName(int columnIndex)
获取派生指定列中值的表名称。
 boolean isAutoIncrement(int columnIndex)
获取存储在指定列中的值是否自动编号，因而是只读的。
 boolean isCaseSensitive(int columnIndex)
指示指定列的名称是否区分大小写。
 boolean isCurrency(int columnIndex)
指示存储在指定列中的值是否为缓存值。
 boolean isDefinitelyWritable(int columnIndex)
指示在指定的列上进行写操作是否一定可以获得成功。
 int isNullable(int columnIndex)
获取指示是否可以在指定列中存储 NULL 值的常量。
 boolean isReadOnly(int columnIndex)
指示指定的列是否一定不可写入，即只读。
 boolean isSearchable(int columnIndex)
指示是否可以在 WHERE 子句中使用存储在指定列中的值。
 boolean isSigned(int columnIndex)
指示存储在指定列中的值是否为有符号数。
 boolean isWrapperFor(Class<?> interfaces)
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。
 boolean isWritable(int columnIndex)
指示在指定的列上进行写操作是否可以获得成功。
 void setAutoIncrement(int columnIndex, boolean property)
将指定列设置为给定 boolean 值，以指示是否为该列自动编号，从而变为只读。
 void setCaseSensitive(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示该列的名称是否区分大小写。
 void setCatalogName(int columnIndex, String catalogName)
将派生指定列的表名称设置为 catalogName。
 void setColumnCount(int columnCount)
在为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中，将列数设置为给定数。
 void setColumnDisplaySize(int columnIndex, int size)
将指定列中的正常最大 char 数设置为给定数。
 void setColumnLabel(int columnIndex, String label)
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。
 void setColumnName(int columnIndex, String columnName)
将指定列的列名称设置为给定的名称。
 void setColumnType(int columnIndex, int SQLType)
将存储在指定列中的值的 SQL 类型代码设置为 java.sql.Types 类中的给定类型代码。
 void setColumnTypeName(int columnIndex, String typeName)
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。
 void setCurrency(int columnIndex, boolean property)
将指定列设置为给定的 boolean，以指示存储在该列中的值是否为缓存值。
 void setNullable(int columnIndex, int property)
将指定列设置为 ResultSetMetaData 接口中的给定常量，以指示是否可以将存储在该列中的值设置为 NULL。
 void setPrecision(int columnIndex, int precision)
将存储在指定列中的值的小数位数的总数设置为给定数。
 void setScale(int columnIndex, int scale)
将存储在指定列中的值的小数点右边的位数设置为给定数。
 void setSchemaName(int columnIndex, String schemaName)
将指定列的表的模式名称（如果有）设置为 schemaName。
 void setSearchable(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否可以在 WHERE 子句中使用。
 void setSigned(int columnIndex, boolean property)
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否为有符号数。
 void setTableName(int columnIndex, String tableName)
将派生指定列的表名称设置为给定的表名称。
<T> T
unwrap(Class<T> iface)
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RowSetMetaDataImpl

public RowSetMetaDataImpl()
方法详细信息

setColumnCount

public void setColumnCount(int columnCount)
                    throws SQLException
在为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中，将列数设置为给定数。

指定者：
接口 RowSetMetaData 中的 setColumnCount
参数：
columnCount - 给出 RowSet 对象中列数的 int
抛出：
SQLException - 如果给定数小于或等于零

setAutoIncrement

public void setAutoIncrement(int columnIndex,
                             boolean property)
                      throws SQLException
将指定列设置为给定 boolean 值，以指示是否为该列自动编号，从而变为只读。

指定者：
接口 RowSetMetaData 中的 setAutoIncrement
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
property - 如果给定列自动加 1，则为 true；否则为 false
抛出：
SQLException - 如果发生数据库访问错误或者给定索引超出限制
SQLException - 如果发生数据库访问错误

setCaseSensitive

public void setCaseSensitive(int columnIndex,
                             boolean property)
                      throws SQLException
将指定列设置为给定的 boolean 值，以指示该列的名称是否区分大小写。

指定者：
接口 RowSetMetaData 中的 setCaseSensitive
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
property - 为 true 指示列名称区分大小写；否则为 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

setSearchable

public void setSearchable(int columnIndex,
                          boolean property)
                   throws SQLException
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否可以在 WHERE 子句中使用。

指定者：
接口 RowSetMetaData 中的 setSearchable
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
property - 为 true 指示列值可以在 WHERE 子句中使用；否则为 false
抛出：
SQLException - 如果发生数据库访问错误或者给定的列数超出限制
SQLException - 如果发生数据库访问错误

setCurrency

public void setCurrency(int columnIndex,
                        boolean property)
                 throws SQLException
将指定列设置为给定的 boolean，以指示存储在该列中的值是否为缓存值。

指定者：
接口 RowSetMetaData 中的 setCurrency
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
property - 如果该值为缓存值，则为 true；否则为 false。
抛出：
SQLException - 如果发生数据库访问错误或者给定的列数超出限制
SQLException - 如果发生数据库访问错误

setNullable

public void setNullable(int columnIndex,
                        int property)
                 throws SQLException
将指定列设置为 ResultSetMetaData 接口中的给定常量，以指示是否可以将存储在该列中的值设置为 NULL。

指定者：
接口 RowSetMetaData 中的 setNullable
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
property - 以下 ResultSetMetaData 常量之一：columnNoNulls、columnNullable 或 columnNullableUnknown
抛出：
SQLException - 如果发生数据库访问错误、给定列数超出限制，或者提供给 property 参数的值不是以下常量之一：ResultSetMetaData.columnNoNulls、ResultSetMetaData.columnNullable 或 ResultSetMetaData.columnNullableUnknown
SQLException - 如果发生数据库访问错误

setSigned

public void setSigned(int columnIndex,
                      boolean property)
               throws SQLException
将指定列设置为给定的 boolean 值，以指示存储在该列中的值是否为有符号数。

指定者：
接口 RowSetMetaData 中的 setSigned
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
property - 为 true 指示列值为有符号数；为 false 指示其不是有符号数
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

setColumnDisplaySize

public void setColumnDisplaySize(int columnIndex,
                                 int size)
                          throws SQLException
将指定列中的正常最大 char 数设置为给定数。

指定者：
接口 RowSetMetaData 中的 setColumnDisplaySize
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
size - 以 char 表示的列的最大大小；必须大于等于 0
抛出：
SQLException - 如果发生数据库访问错误、给定列数超出限制，或者 size 小于 0

setColumnLabel

public void setColumnLabel(int columnIndex,
                           String label)
                    throws SQLException
将建议用于打印输出和显示的列标签（如果有）设置为给定的 label。如果 label 为 null，则将列标签设置为空字符串 ("")。

指定者：
接口 RowSetMetaData 中的 setColumnLabel
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
label - 用于打印输出和显示的列标签；如果列标签为 null，则设置空 String
抛出：
SQLException - 如果发生数据库访问错误或者给定列索引超出限制

setColumnName

public void setColumnName(int columnIndex,
                          String columnName)
                   throws SQLException
将指定列的列名称设置为给定的名称。

指定者：
接口 RowSetMetaData 中的 setColumnName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
columnName - 指示列名称的 String 对象；如果给定名称为 null，则设置空 String
抛出：
SQLException - 如果发生数据库访问错误或者给定索引超出限制

setSchemaName

public void setSchemaName(int columnIndex,
                          String schemaName)
                   throws SQLException
将指定列的表的模式名称（如果有）设置为 schemaName。如果 schemaName 为 null，则将模式名称设置为空字符串 ("")。

指定者：
接口 RowSetMetaData 中的 setSchemaName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
schemaName - 表的模式名称，指定列中的值从其派生；可能为空 String 或 null
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

setPrecision

public void setPrecision(int columnIndex,
                         int precision)
                  throws SQLException
将存储在指定列中的值的小数位数的总数设置为给定数。

指定者：
接口 RowSetMetaData 中的 setPrecision
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
precision - 小数位数的总数；必须大于等于 0
抛出：
SQLException - 如果发生数据库访问错误、columnIndex 超出限制，或者 precision 小于 0

setScale

public void setScale(int columnIndex,
                     int scale)
              throws SQLException
将存储在指定列中的值的小数点右边的位数设置为给定数。

指定者：
接口 RowSetMetaData 中的 setScale
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
scale - 小数点右边的小数位数；必须大于等于 0
抛出：
SQLException - 如果发生数据库访问错误、columnIndex 超出限制，或者 scale 小于 0

setTableName

public void setTableName(int columnIndex,
                         String tableName)
                  throws SQLException
将派生指定列的表名称设置为给定的表名称。

指定者：
接口 RowSetMetaData 中的 setTableName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
tableName - 列的表名称；可以为 null 或空字符串
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

setCatalogName

public void setCatalogName(int columnIndex,
                           String catalogName)
                    throws SQLException
将派生指定列的表名称设置为 catalogName。如果 catalogName 为 null，则将类别名称设置为空字符串。

指定者：
接口 RowSetMetaData 中的 setCatalogName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
catalogName - 列的表的类别名称；如果 catalogName 为 null，则设置为 String
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

setColumnType

public void setColumnType(int columnIndex,
                          int SQLType)
                   throws SQLException
将存储在指定列中的值的 SQL 类型代码设置为 java.sql.Types 类中的给定类型代码。

指定者：
接口 RowSetMetaData 中的 setColumnType
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
SQLType - 指定列的 SQL 类型，它必须为 java.sql.Types 类中的常量之一
抛出：
SQLException - 如果发生数据库访问错误、给定列数超出限制，或者指定的列类型不是 java.sql.Types 中的常量之一
另请参见：
Types

setColumnTypeName

public void setColumnTypeName(int columnIndex,
                              String typeName)
                       throws SQLException
将供存储在指定列中的值的数据源使用的类型名称设置为给定类型名称。

指定者：
接口 RowSetMetaData 中的 setColumnTypeName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和 rowset 中的列数之间（包含两端的值）
typeName - 特定于数据源的类型名称；如果 typeName 为 null，则设置空 String
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getColumnCount

public int getColumnCount()
                   throws SQLException
获取为其创建此 RowSetMetaDataImpl 对象的 RowSet 对象中的列数。

指定者：
接口 ResultSetMetaData 中的 getColumnCount
返回：
列数
抛出：
SQLException - 如果在确定列数时发生错误

isAutoIncrement

public boolean isAutoIncrement(int columnIndex)
                        throws SQLException
获取存储在指定列中的值是否自动编号，因而是只读的。

指定者：
接口 ResultSetMetaData 中的 isAutoIncrement
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果列是自动编号的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isCaseSensitive

public boolean isCaseSensitive(int columnIndex)
                        throws SQLException
指示指定列的名称是否区分大小写。

指定者：
接口 ResultSetMetaData 中的 isCaseSensitive
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果列是区分大小写的，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isSearchable

public boolean isSearchable(int columnIndex)
                     throws SQLException
指示是否可以在 WHERE 子句中使用存储在指定列中的值。

指定者：
接口 ResultSetMetaData 中的 isSearchable
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果可以在 WHERE 子句中使用指定列中的值，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isCurrency

public boolean isCurrency(int columnIndex)
                   throws SQLException
指示存储在指定列中的值是否为缓存值。

指定者：
接口 ResultSetMetaData 中的 isCurrency
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果指定列中的值为缓存值，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isNullable

public int isNullable(int columnIndex)
               throws SQLException
获取指示是否可以在指定列中存储 NULL 值的常量。

指定者：
接口 ResultSetMetaData 中的 isNullable
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
ResultSetMetaData 接口中的常量；columnNoNulls、columnNullable 或 columnNullableUnknown
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isSigned

public boolean isSigned(int columnIndex)
                 throws SQLException
指示存储在指定列中的值是否为有符号数。

指定者：
接口 ResultSetMetaData 中的 isSigned
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果指定列中的值为有符号数，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getColumnDisplaySize

public int getColumnDisplaySize(int columnIndex)
                         throws SQLException
获取以 char 为单位的指定列的正常最大宽度。

指定者：
接口 ResultSetMetaData 中的 getColumnDisplaySize
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
可以在指定列中显示的最大 char 数
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getColumnLabel

public String getColumnLabel(int columnIndex)
                      throws SQLException
获取用于打印输出和显示的指定列的建议列标题。

指定者：
接口 ResultSetMetaData 中的 getColumnLabel
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
用于打印输出和显示的建议列标题
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getColumnName

public String getColumnName(int columnIndex)
                     throws SQLException
获取指定列的名称。

指定者：
接口 ResultSetMetaData 中的 getColumnName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
指定列的列名称
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getSchemaName

public String getSchemaName(int columnIndex)
                     throws SQLException
获取派生指定列中值的表的模式名称。

指定者：
接口 ResultSetMetaData 中的 getSchemaName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
模式名称；如果不存在可用的模式名称，则返回一个空 String
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getPrecision

public int getPrecision(int columnIndex)
                 throws SQLException
获取存储在指定列中的值的数字总数。

指定者：
接口 ResultSetMetaData 中的 getPrecision
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
存储在指定列中值的精度
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getScale

public int getScale(int columnIndex)
             throws SQLException
获取存储在指定列中的值的小数点右边的数字数。

指定者：
接口 ResultSetMetaData 中的 getScale
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
存储在指定列中的 scale 值
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getTableName

public String getTableName(int columnIndex)
                    throws SQLException
获取派生指定列中值的表名称。

指定者：
接口 ResultSetMetaData 中的 getTableName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
表名称；如果不存在可用的表名称，则返回空 String
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getCatalogName

public String getCatalogName(int columnIndex)
                      throws SQLException
获取派生指定列中值的表的类别名称。

指定者：
接口 ResultSetMetaData 中的 getCatalogName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
列的表的类别名称；如果不存在可用的类别名称，则返回空 String
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getColumnType

public int getColumnType(int columnIndex)
                  throws SQLException
获取存储在指定行中值的 SQL 类型的类型代码（java.sql.Types 常量之一）。

指定者：
接口 ResultSetMetaData 中的 getColumnType
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
表示存储在指定列中值的 SQL 类型的 int
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制
另请参见：
Types

getColumnTypeName

public String getColumnTypeName(int columnIndex)
                         throws SQLException
获取存储在指定列中值的特定于 DBMS 的类型名称。

指定者：
接口 ResultSetMetaData 中的 getColumnTypeName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
供数据源使用的类型名称
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isReadOnly

public boolean isReadOnly(int columnIndex)
                   throws SQLException
指示指定的列是否一定不可写入，即只读。

指定者：
接口 ResultSetMetaData 中的 isReadOnly
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果此 RowSet 对象是只读的并因而不可更新，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isWritable

public boolean isWritable(int columnIndex)
                   throws SQLException
指示在指定的列上进行写操作是否可以获得成功。返回值为 true 意味着写操作可能成功，也可能不成功。

指定者：
接口 ResultSetMetaData 中的 isWritable
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果在指定列上进行的写操作可能成功，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

isDefinitelyWritable

public boolean isDefinitelyWritable(int columnIndex)
                             throws SQLException
指示在指定的列上进行写操作是否一定可以获得成功。

指定者：
接口 ResultSetMetaData 中的 isDefinitelyWritable
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两端的值）
返回：
如果在指定列上进行的写操作一定会成功，则返回 true；否则返回 false
抛出：
SQLException - 如果发生数据库访问错误或者给定列数超出限制

getColumnClassName

public String getColumnClassName(int columnIndex)
                          throws SQLException
获取 Java 编程语言中一个类的完全限定名，该类是指定列中的值将映射到的那个类。例如，如果值为 int，则此方法返回的类名称将为 java.lang.Integer。

如果指定列中的值进行自定义映射，则此方法返回实现 SQLData 的类的名称。当调用 ResultSet.getObject 方法从指定列获取值时，该方法将创建此类或其某个子类的实例。

指定者：
接口 ResultSetMetaData 中的 getColumnClassName
参数：
columnIndex - 第一列为 1，第二列为 2，依此类推；必须介于 1 和列数之间（包含两个端点）
返回：
Java 编程语言中类的完全限定名，供 RowSet.getObject 方法用来获取指定列中的值。如果存在自定义映射，则返回值是用于自定义映射的类名称。
抛出：
SQLException - 如果发生数据库访问错误或者给定的列数超出限制

unwrap

public <T> T unwrap(Class<T> iface)
         throws SQLException
返回实现给定接口以允许访问非标准方法，或者代理未公开标准方法的的对象。结果可能是实现接口的对象或是该对象的一个代理。如果接收者实现接口，则它就是要返回的对象。如果接收者是一个包装器，并且包装的对象实现接口，则该对象就是要返回的对象。否则，返回的对象是在包装的对象上递归地调用 unwrap 的结果。如果接收者不是包装器并且不实现接口，则抛出 SQLException。

指定者：
接口 Wrapper 中的 unwrap
参数：
iface - 定义结果必须实现的接口的 Class。
返回：
实现接口的对象。可以是实际实现对象的代理。
抛出：
SQLException - 如果未找到实现接口的对象
从以下版本开始：
1.6

isWrapperFor

public boolean isWrapperFor(Class<?> interfaces)
                     throws SQLException
如果调用者实现接口参数或者是实现接口参数的对象的直接或间接包装器，则返回 true。否则，返回 false。如果调用者实现接口，则返回 true；如果调用者是包装器，则返回在包装的对象上递归地调用 isWrapperFor 的结果。如果调用者不实现接口并且不是包装器，则返回 false。与 unwrap 相比，此方法作为一个低成本的操作实现，从而调用者可以使用此方法来避免昂贵的 unwrap 调用（它们可能会失败）。如果此方法返回 true，则使用相同参数调用 unwrap 应该成功。

指定者：
接口 Wrapper 中的 isWrapperFor
参数：
interfaces - 定义接口的 Class。
返回：
如果调用者实现接口或者是实现接口的对象的直接或间接包装器。
抛出：
SQLException - 如果在确定调用者是否是带有给定接口的对象的包装器时发生错误。
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSetWarning (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
类 RowSetWarning

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  javax.sql.rowset.RowSetWarning
所有已实现的接口：
Serializable, Iterable<Throwable>
public class RowSetWarning
extends SQLException

SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。这些警告正常链接到其方法调用会导致报告警告的那些对象。此类对 SQLWarning 类进行补充。

Rowset 警告可以从 JdbcRowSet、CachedRowSetTM、WebRowSet、FilteredRowSet 或 JoinRowSet 实现中获取到。要获取在任何 RowSet 实现上报告的第一个警告，需要使用在 JdbcRowSet 接口或 CachedRowSet 接口中定义的 getRowSetWarnings 方法。要获取链接到第一个警告的警告，需要使用 RowSetWarning 方法 getNextWarning。要获取后续警告，需要对每个返回的 RowSetWarning 对象调用 getNextWarning。

继承方法 getMessage、getSQLState 和 getErrorCode 用于获取 RowSetWarning 对象中包含的信息。

另请参见：
序列化表格

构造方法摘要
RowSetWarning()
构造一个默认的 RowSetWarning 对象。
RowSetWarning(String reason)
用给定的 reason 值构造 RowSetWarning 对象；SQLState 默认为 null，vendorCode 默认为 0。
RowSetWarning(String reason, String SQLState)
构造一个 RowSetWarning 对象，并使用给定的 reason 和 SQLState 值进行初始化。
RowSetWarning(String reason, String SQLState, int vendorCode)
构造一个完全指定的 RowSetWarning 对象，并使用给定的 reason、SQLState 和 vendorCode 值进行初始化。
方法摘要
RowSetWarning | getNextWarning() 获取链接到此 SQLWarning 对象的警告。
void | setNextWarning(RowSetWarning warning) 将 warning 设置为下一个警告，即连接到此 RowSetWarning 对象的警告。
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RowSetWarning

public RowSetWarning(String reason)
用给定的 reason 值构造 RowSetWarning 对象；SQLState 默认为 null，vendorCode 默认为 0。

参数：
reason - 给出警告描述的 String 对象；如果 String 为 null，则此构造方法的行为类似于默认的（零参数）RowSetWarning 构造方法

RowSetWarning

public RowSetWarning()
构造一个默认的 RowSetWarning 对象。原因默认为 null，SQLState 默认为 null，vendorCode 默认为 0。

RowSetWarning

public RowSetWarning(String reason,
                     String SQLState)
构造一个 RowSetWarning 对象，并使用给定的 reason 和 SQLState 值进行初始化。供应商代码默认为 0。 如果 reason 或 SQLState 参数为 null，则此构造方法的行为类似于默认的（零参数）RowSetWarning 构造方法。

参数：
reason - 给出警告描述的 String；
SQLState - 标识警告的 XOPEN 代码；如果未提供标准的 XOPEN SQLState，则不抛出任何异常。

RowSetWarning

public RowSetWarning(String reason,
                     String SQLState,
                     int vendorCode)
构造一个完全指定的 RowSetWarning 对象，并使用给定的 reason、SQLState 和 vendorCode 值进行初始化。 如果 reason 或 SQLState 参数为 null，则此构造方法的行为类似于默认的（零参数）RowSetWarning 构造方法。

参数：
reason - 给出警告描述的 String；
SQLState - 标识警告的 XOPEN 代码；如果未提供标准的 XPOEN SQLState，则不抛出任何异常。
vendorCode - 特定于数据库供应商的警告代码
方法详细信息

getNextWarning

public RowSetWarning getNextWarning()
获取链接到此 SQLWarning 对象的警告。

返回：
链接到此警告的 RowSetWarning 对象；如果不存在链接到此警告的 RowSetWarning 对象，则返回 null（默认值）
另请参见：
setNextWarning(javax.sql.rowset.RowSetWarning)

setNextWarning

public void setNextWarning(RowSetWarning warning)
将 warning 设置为下一个警告，即连接到此 RowSetWarning 对象的警告。

参数：
warning - 要设置为下一个警告的 RowSetWarning 对象；如果 RowSetWarning 为 null，则此值表示警告链接中的结束点
另请参见：
getNextWarning()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WebRowSet (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset
接口 WebRowSet

所有超级接口：
CachedRowSet, Joinable, ResultSet, RowSet, Wrapper
所有已知子接口：
FilteredRowSet, JoinRowSet
public interface WebRowSet
extends CachedRowSet

所有 WebRowSet 的实现都必须实现的标准接口。

1.0 概述

WebRowSetImpl 提供可在需要时扩展的标准参考实现。

标准的 WebRowSet XML 模式定义位于以下 URI 中：

     http://java.sun.com/xml/ns/jdbc/webrowset.xsd
它描述使用 XML 描述 RowSet 对象时所需的标准 XML 文档格式，所有 WebRowSet 接口的标准实现必须使用该文档格式以确保互操作性。此外，WebRowSet 模式使用特定的 SQL/XML 模式注释，从而确保较高的跨平台互操作性。目前 ISO 组织正在为此而努力。SQL/XML 定义可从以下 URI 中得到：
     http://standards.iso.org/iso/9075/2002/12/sqlxml
模式定义从以下三个不同方面描述 RowSet 对象的内部数据：
  • 属性
    • 除了较为通用的 RowSet 属性之外，这些属性还描述标准同步提供者属性。

  • 元数据
    • 此项描述与 WebRowSet 对象管理的表格结构关联的元数据。描述的元数据与在底层 java.sql.ResultSet 接口中可访问的元数据是紧密联系在一起的。

  • 数据
    • 此项描述原始数据（自从 WebRowSet 对象的上一次填充或上一次同步以来的数据状态）和当前数据。通过跟踪原始数据和当前数据之间的 delta，WebRowSet 维持其数据中的更改与原始数据源同步的能力。

2.0 WebRowSet 状态

以下几部分演示 WebRowSet 实现应该如何使用 XML 模式来描述更新、插入和删除操作，以及描述 XML 中 WebRowSet 对象的状态。

2.1 状态 1 - 将 WebRowSet 对象输出为 XML

在此示例中，创建一个 WebRowSet 对象，并使用取自数据源的一个简单的 2 列、5 行表进行填充。具有 WebRowSet 对象中的 5 个行使以 XML 描述它们成为可能。描述在 RowSet 接口中定义的各种标准 JavaBeans 属性和在 CachedRowSetTM 接口中定义的标准属性的元数据，提供描述 WebRowSet 属性的主要细节。使用标准 writeXml 方法将 WebRowSet 对象输出为 XML 将内部属性描述如下：
<properties>
       <command>select co1, col2 from test_table</command>
        <concurrency>1</concurrency>
        <datasource/>
        <escape-processing>true</escape-processing>
        <fetch-direction>0</fetch-direction>
        <fetch-size>0</fetch-size>
        <isolation-level>1</isolation-level>
        <key-columns/>
        <map/>
        <max-field-size>0</max-field-size>
        <max-rows>0</max-rows>
        <query-timeout>0</query-timeout>
        <read-only>false</read-only>
        <rowset-type>TRANSACTION_READ_UNCOMMITED</rowset-type>
        <show-deleted>false</show-deleted>
        <table-name/>
        <url>jdbc:thin:oracle</url>
        <sync-provider>
                <sync-provider-name>.com.rowset.provider.RIOptimisticProvider</sync-provider-name>
                <sync-provider-vendor>Sun Microsystems</sync-provider-vendor>
                <sync-provider-version>1.0</sync-provider-name>
                <sync-provider-grade>LOW</sync-provider-grade>
              <data-source-lock>NONE</data-source-lock>
        </sync-provider>
</properties>
描述 WebRowSet 的组成的元数据使用 XML 描述的细节如下所示。注意，两个列都在 column-definition 标识之间描述。
<metadata>
        <column-count>2</column-count>
        <column-definition>
                <column-index>1</column-index>
                <auto-increment>false</auto-increment>
                <case-sensitive>true</case-sensitive>
                <currency>false</currency>
                <nullable>1</nullable>
                <signed>false</signed>
                <searchable>true</searchable>
                <column-display-size>10</column-display-size>
                <column-label>COL1</column-label>
                <column-name>COL1</column-name>
                <schema-name/>
                <column-precision>10</column-precision>
                <column-scale>0</column-scale>
                <table-name/>
                <catalog-name/>
                <column-type>1</column-type>
                <column-type-name>CHAR</column-type-name>
        </column-definition>
        <column-definition>
                <column-index>2</column-index>
                <auto-increment>false</auto-increment>
                <case-sensitive>false</case-sensitive>
                <currency>false</currency>
                <nullable>1</nullable>
                <signed>true</signed>
                <searchable>true</searchable>
                <column-display-size>39</column-display-size>
                <column-label>COL2</column-label>
                <column-name>COL2</column-name>
                <schema-name/>
                <column-precision>38</column-precision>
                <column-scale>0</column-scale>
                <table-name/>
                <catalog-name/>
                <column-type>3</column-type>
                <column-type-name>NUMBER</column-type-name>
        </column-definition>
</metadata>
详细说明如何描述属性和元数据之后，以下详细说明如何使用 XML 描述 WebRowSet 对象的内容。注意，它描述的是自从实例化以来没有经过任何修改的 WebRowSet 对象。currentRow 标记将被映射到 WebRowSet 对象所提供的表结构的每一个行。columnValue 标记可能包含 stringData 或 binaryData 标记，这取决于将 XML 值映射回的 SQL 类型。binaryData 标记包含 Base64 编码的数据，通常用于 BLOB 和 CLOB 类型数据。
 <data>
        <currentRow>
                <columnValue>
                        firstrow
                </columnValue>
                <columnValue>
                        1
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        secondrow
                </columnValue>
                <columnValue>
                        2
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        thirdrow
                </columnValue>
                <columnValue>
                        3
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        fourthrow
                </columnValue>
                <columnValue>
                        4
                </columnValue>
        </currentRow>
 </data>

2.2 状态 2 - 删除行

在 WebRowSet 对象中删除行首先简单地移动到要删除的行，然后调用 deleteRow 方法，如任何其他 RowSet 对象一样。以下两个代码行（其中 wrs 为 WebRowSet 对象）将删除第三行。
     wrs.absolute(3);
     wrs.deleteRow();
XML 描述显示第三行被标记为 deleteRow，这将在 WebRowSet 对象中删去第三行。
 <data>
        <currentRow>
                <columnValue>
                        firstrow
                </columnValue>
                <columnValue>
                        1
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        secondrow
                </columnValue>
                <columnValue>
                        2
                </columnValue>
        </currentRow>
        <deleteRow>
                <columnValue>
                        thirdrow
                </columnValue>
                <columnValue>
                        3
                </columnValue>
        </deleteRow>
        <currentRow>
                <columnValue>
                        fourthrow
                </columnValue>
                <columnValue>
                        4
                </columnValue>
        </currentRow>
 </data>

2.3 状态 3 - 插入行

WebRowSet 对象插入新行的方式是，移动到插入行，为该行中的每一列调用适当的更新方法，然后调用 insertRow 方法。
 wrs.moveToInsertRow();
 wrs.updateString(1, "fifththrow");
 wrs.updateString(2, "5");
 wrs.insertRow();
以下代码片段更改刚插入的行中第二列的值。注意，此代码在将新行直接插入到当前行的后面时应用，这就是 next 方法将指针移动到正确行的原因。调用方法 acceptChanges 将更改写入数据源。
 wrs.moveToCurrentRow();
 wrs.next();
 wrs.updateString(2, "V");
 wrs.acceptChanges();
 :
使用 XML 描述此操作演示了在新行中插入 Java 代码的位置，然后在个别字段上的新插入行上执行更新。

 <data>
        <currentRow>
                <columnValue>
                        firstrow
                </columnValue>
                <columnValue>
                        1
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        secondrow
                </columnValue>
                <columnValue>
                        2
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        newthirdrow
                </columnValue>
                <columnValue>
                        III
                </columnValue>
        </currentRow>
        <insertRow>
                <columnValue>
                        fifthrow
                </columnValue>
                <columnValue>
                        5
                </columnValue>
                <updateValue>
                        V
                </updateValue>
        </insertRow>
        <currentRow>
                <columnValue>
                        fourthrow
                </columnValue>
                <columnValue>
                        4
                </columnValue>
        </currentRow>
</date>

2.4 状态 4 - 修改行

修改行生成特定的 XML，该 XML 记录新值和被替换的值。被替换的值变成原始值，而新值变成当前值。以下代码将指针移动到特定行，执行一些修改，并在完成时更新行。
 wrs.absolute(5);
 wrs.updateString(1, "new4thRow");
 wrs.updateString(2, "IV");
 wrs.updateRow();
在 XML 中，此操作用 modifyRow 标记描述。出于原始行跟踪目的，原始值和新值都包含在该标记中。
 <data>
        <currentRow>
                <columnValue>
                        firstrow
                </columnValue>
                <columnValue>
                        1
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        secondrow
                </columnValue>
                <columnValue>
                        2
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        newthirdrow
                </columnValue>
                <columnValue>
                        III
                </columnValue>
        </currentRow>
        <currentRow>
                <columnValue>
                        fifthrow
                </columnValue>
                <columnValue>
                        5
                </columnValue>
        </currentRow>
        <modifyRow>
                <columnValue>
                        fourthrow
                </columnValue>
                <updateValue>
                        new4thRow
                </updateValue>
                <columnValue>
                        4
                </columnValue>
                <updateValue>
                        IV
                </updateValue>
        </modifyRow>
 </data>

另请参见：
JdbcRowSet, CachedRowSet, FilteredRowSet, JoinRowSet

字段摘要
static String | PUBLIC_XML_SCHEMA 为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的公共标识符。
static String | SCHEMA_SYSTEM_ID 为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的 URL。
从接口 javax.sql.rowset.CachedRowSet 继承的字段
COMMIT_ON_ACCEPT_CHANGES
从接口 java.sql.ResultSet 继承的字段
CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
方法摘要
void | readXml(InputStream iStream) 读取基于流的 XML 输入，以填充此 WebRowSet 对象。
void | readXml(Reader reader) 从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。
void | writeXml(OutputStream oStream) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。
void | writeXml(ResultSet rs, OutputStream oStream) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。
void | writeXml(ResultSet rs, Writer writer) 使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。
void | writeXml(Writer writer) 以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。
从接口 javax.sql.rowset.CachedRowSet 继承的方法
acceptChanges, acceptChanges, columnUpdated, columnUpdated, commit, createCopy, createCopyNoConstraints, createCopySchema, createShared, execute, getKeyColumns, getOriginal, getOriginalRow, getPageSize, getRowSetWarnings, getShowDeleted, getSyncProvider, getTableName, nextPage, populate, populate, previousPage, release, restoreOriginal, rollback, rollback, rowSetPopulated, setKeyColumns, setMetaData, setOriginalRow, setPageSize, setShowDeleted, setSyncProvider, setTableName, size, toCollection, toCollection, toCollection, undoDelete, undoInsert, undoUpdate
从接口 javax.sql.RowSet 继承的方法
addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername
从接口 java.sql.ResultSet 继承的方法
absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull
从接口 java.sql.Wrapper 继承的方法
isWrapperFor, unwrap
从接口 javax.sql.rowset.Joinable 继承的方法
getMatchColumnIndexes, getMatchColumnNames, setMatchColumn, setMatchColumn, setMatchColumn, setMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn, unsetMatchColumn

字段详细信息

PUBLIC_XML_SCHEMA

static final String PUBLIC_XML_SCHEMA
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的公共标识符。

另请参见：
常量字段值

SCHEMA_SYSTEM_ID

static final String SCHEMA_SYSTEM_ID
为 WebRowSet 实现定义 XML 标记及其有效值的 XML 模式定义的 URL。

另请参见：
常量字段值
方法详细信息

readXml

void readXml(Reader reader)
             throws SQLException
从给定的 Reader 对象以其 XML 格式读取 WebRowSet 对象。

参数：
reader - 用于填充此 WebRowSet 对象的 java.io.Reader 流。
抛出：
SQLException - 如果发生数据库访问错误

readXml

void readXml(InputStream iStream)
             throws SQLException,
                    IOException
读取基于流的 XML 输入，以填充此 WebRowSet 对象。

参数：
iStream - 用来填充此 WebRowSet 对象的 java.io.InputStream
抛出：
SQLException - 如果发生数据源访问错误
IOException - 如果发生 IO 异常

writeXml

void writeXml(ResultSet rs,
              Writer writer)
              throws SQLException
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 Writer 对象。

注：可以移动 WebRowSet 指针将内容写出到 XML 数据源中。如果以这种方式实现，则在调用 writeXml() 之前指针必须先返回其位置。

参数：
rs - 用于填充此 WebRowSet 对象的 ResultSet 对象
writer - 要写入的 java.io.Writer 对象。
抛出：
SQLException - 如果在以 XML 格式写出 rowset 内容时发生错误

writeXml

void writeXml(ResultSet rs,
              OutputStream oStream)
              throws SQLException,
                     IOException
使用给定 ResultSet 对象的内容填充此 WebRowSet 对象，并以 XML 格式将其数据、属性和元数据写入给定的 OutputStream 对象。

注：可以移动 WebRowSet 指针将内容写出到 XML 数据源中。如果以这种方式实现，则在调用 writeXml() 之前必须先将指针返回其位置。

参数：
rs - 用于填充此 WebRowSet 对象的 ResultSet 对象
oStream - 要写入的 java.io.OutputStream
抛出：
SQLException - 如果发生数据源访问错误
IOException - 如果发生 IO 异常

writeXml

void writeXml(Writer writer)
              throws SQLException
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 Writer 对象。

参数：
writer - 要写入的 java.io.Writer 流
抛出：
SQLException - 如果在将 rowset 内容写出到 XML 时出错

writeXml

void writeXml(OutputStream oStream)
              throws SQLException,
                     IOException
以 XML 格式将此 WebRowSet 对象的数据、属性和元数据写入给定的 OutputStream 对象。

参数：
oStream - 要写入的 java.io.OutputStream 流
抛出：
SQLException - 如果发生数据源访问错误
IOException - 如果发生 IO 异常
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sql.rowset (Java 2 Platform SE 6)

 javax.sql.rowset
接口
CachedRowSet
FilteredRowSet
JdbcRowSet
Joinable
JoinRowSet
Predicate
WebRowSet
类
BaseRowSet
RowSetMetaDataImpl
异常
RowSetWarning


javax.sql.rowset (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sql.rowset

JDBC RowSet 实现的标准接口和基类。

请参见：
描述

接口摘要
CachedRowSet | 所有标准 CachedRowSet 实现都必须实现的接口。
FilteredRowSet | 所有标准 FilteredRowSet 实现都必须实现的标准接口。
JdbcRowSet | 所有标准 JdbcRowSet 实现都必须实现的标准接口。
Joinable | 1.0 背景 Joinable 接口提供了用于获取和设置匹配列的各种方法，匹配列是形成通过将 RowSet 对象添加到 JoinRowSet 对象所形成的 SQL JOIN 的基础。
JoinRowSet | JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
Predicate | 为所有 FilteredRowSet 对象提供框架以描述其过滤器的标准接口。
WebRowSet | 所有 WebRowSet 的实现都必须实现的标准接口。

类摘要
BaseRowSet | 提供一个具有基本功能的 RowSet 对象的抽象类。
RowSetMetaDataImpl | 为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

异常摘要
RowSetWarning SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。

软件包 javax.sql.rowset 的描述

JDBC RowSet 实现的标准接口和基类。此包包含了标准 RowSet 实现可实现或扩展的各种接口和类。

目录

  • 1.0 包规范
  • 2.0 标准 RowSet 定义
  • 3.0 实现者指南
  • 4.0 相关规范
  • 5.0 相关文档

1.0 包规范

此包指定了 5 个标准的 JDBC RowSet 接口。所有这 5 个接口都扩展了 JDBC 3.0 规范中描述的 RowSet 接口。可以预计随着此项技术的成熟，会出现其他更专用 JDBC RowSet 类型的定义。以后的定义应该 通过继承指定为子接口，与此规范中所用的方式类似。

注：此包中提供的接口定义构成了所有兼容 JDBC RowSet 实现的基础。供应商和打算提供其自己的兼容 RowSet 实现的高级开发人员应该特别注意在接口规范中详述的声明。

2.0 标准 RowSet 定义

  • JdbcRowSet - ResultSet 对象的包装器，使得该结果集用作 JavaBeansTM 组件成为可能。因此，JdbcRowSet 对象可以是一个 Bean，任何工具都可将其作为基于架构的组件部分来组装应用程序。JdbcRowSet 对象是连接的 RowSet 对象，也就是说，它必须使用启用 JDBC 技术的驱动程序（“JDBC 驱动程序”）来持续维持它与数据源的连接。此外，JdbcRowSet 对象提供完全可更新和可滚动的表格数据结构，这在 JDBC 3.0 规范中定义。

  • CachedRowSetTM> - CachedRowSet 对象是一个 JavaBeansTM 组件，是可滚动的、可更新的、可序列化的，并且通常是与其数据源断开连接的。CachedRowSet 对象通常包含取自结果集的多个行，但是也可包含任何取自表格式文件（如电子表格）的行。CachedRowSet 实现必须使用 SyncFactory 管理和获得可插入的 SyncProvider 对象，以便在非连接 RowSet 对象和原始数据源之间提供同步。通常 SyncProvider 实现依靠 JDBC 驱动程序来连接特定数据源。javax.sql.rowset.spi 包规范中讨论了关于此机制的更多详细信息。

  • WebRowSet - WebRowSet 对象是 CachedRowSet 的扩展，可以用合适的 XML 格式读取和写入 RowSet 对象。此类调用 XmlReader 对象（RowSetReader 接口的扩展）来读取 XML 格式的 rowset。调用 XmlWriter 对象（RowSetWriter 接口的扩展）来写入 XML 格式的 rowset。SyncFactory 以 SyncProvider 实现的形式提供 WebRowSet 对象所需的 reader 和 writer。为了确保使用合适的 XML，在 http://java.sun.com/xml/ns/jdbc/webrowset.xsd 中定义并发布了标准的通用 XML 模式。

  • FilteredRowSet - FilteredRowSet 对象以编程和可扩展的方式提供过滤功能。有很多实例在 RowSet object 需要在其内容中提供过滤时无需放弃非连接环境，从而节省了必须创建到数据源的连接所带来的开销。从提供重量级的全部 SQL 查询能力，到可移植的组件，再到更轻量级的方法，这一需求的解决方案各有不同。FilteredRowSet 对象使用 Predicate 接口的实现，该接口可以在运行时定义一个过滤器。接着，FilteredRowSet 对象的任务是强行为入站 (inbound) 和出站 (outbound) 读写操作设置过滤器。也就是说，可以将所有过滤器认为是双向的。未定义任何标准过滤器；但是指定了足够的机制以允许实现任何所需的过滤器。

  • JoinRowSet - JoinRowSet 接口描述了一种机制，根据这种机制可在两个或多个标准 RowSet 实现之间建立关系。可将任意数目的 RowSet 对象添加到 JoinRowSet 对象中，只要能够以 SQL JOIN 类似的方式将这些 RowSet 对象关联起来。根据定义，SQL JOIN 语句用于根据公共的属性将两个（或多个）关系数据库表中包含的数据组合起来。通过建立然后实施列匹配，JoinRowSet 对象可在 RowSet 实例之间建立关系，而无需触动原始数据源。

3.0 实现者指南

JDBC RowSet 实现的兼容实现必须遵循此规范中描述的声明。为了与 Java Community Process 的条款保持一致，可以获得一个兼容性测试工具包（Test Compatibility Kit，TCK）的许可，以确保与规范保持兼容性。以下各段概述了一些实现标准 JDBC RowSet 定义的入门知识。实现者还应参考 javax.sql.rowset.spi 包中的实现者指南，以获得有关 SyncProvider 实现的指南。

  • 3.1 BaseRowSet 类的职责

    兼容的 JDBC RowSet 实现必须实现此包中指定的一个或多个标准接口，并且可以扩展 BaseRowSet 抽象类。例如，CachedRowSet 实现必须实现 CachedRowSet 接口并扩展 BaseRowSet 抽象类。BaseRowSet 类提供用于构建所有 RowSet 实现的标准架构，无论是存在于连接环境还是非连接环境中的 RowSet 对象。BaseRowSet 抽象类为所有 RowSet 实现提供其基本功能，包括与 JavaBeans 组件要求完全兼容的属性操纵和事件通知。例如，参考实现中提供的所有实现（包含在 com.sun.rowset 包中）都使用 BaseRowSet 作为其实现的基础。

    下表展示了 BaseRowSet 抽象类提供的功能。

    功能
             详细信息
    属性
             提供标准的 JavaBeans 属性操纵机制，允许应用程序获得和设置 RowSet 的命令和属性值。有关标准 RowSet 属性的更多信息，请参阅 javax.sql.RowSet 接口的文档（JDBC 3.0 规范中提供）。
    事件通知
             向已注册事件侦听器提供标准的 JavaBeans 事件通知。有关如何注册和处理由兼容实现所生成的标准 RowSet 事件的更多信息，请参阅 javax.sql.RowSetEvent 接口的文档（JDBC 3.0 规范中提供）。
    用于 RowSet 对象命令的 Setter
             为设置 RowSet 命令参数提供完整的设置方法集。
    流
             除了为流类型标记提供常量集外，还为流实例的存储提供了各种字段。

  • 3.2 连接 RowSet 需求

    JdbcRowSet 描述一种必须始终连接到原始数据源的 RowSet 对象。JdbcRowSet 的实现应该确保此连接是由 JDBC 驱动程序唯一提供的。此外，作为 JdbcRowSet 接口的实现并因此在连接环境中运行的 RowSet 对象不使用 SyncFactory 来获取 RowSetReader 对象或 RowSetWriter 对象。由于存在可更新和可滚动的底层 ResultSet 实现，所以它们可以安全地依靠 JDBC 驱动程序来满足其需求。

  • 3.3 非连接 RowSet 需求

    非连接 RowSet 对象（如 CachedRowSet 对象）应该将连接管理委托给 SyncFactory 所提供的 SyncProvider 对象。要确保完全的非连接语义，所有非连接 RowSet 对象必须确保已关闭填充 RowSet 对象时所建立的与数据源的原始连接，以便垃圾回收器能够恢复和释放资源。SyncProvider 对象确保可维护关键的 JDBC 属性，从而在需要进行同步时可重新建立到数据源的连接。因此，非连接 RowSet 对象应该确保在 Connection 对象上没有保留任何其他引用。

  • 3.4 RowSetMetaDataImpl 的职责

    RowsetMetaDataImpl 类是一个提供 RowSetMetaData 接口实现的实用工具类，它同时为连接和非连接 RowSet 对象的元数据提供标准的设置方法实现。所有实现都可随意使用此标准实现，但是并不要求必须如此。

  • 3.5 RowSetWarning 类

    RowSetWarning 类提供了可在 RowSet 实现上设置的警告。与 SQLWarning 对象类似，RowSetWarning 对象正常链接到其方法会导致抛出警告的那些对象。所有 RowSet 实现应该确保如果生成了警告，则会发生此链接操作，还要确保通过 JdbcRowSet 接口或 CachedRowSet 接口中定义的 getRowSetWarnings 方法可以获得这些警告。使用某个 getRowSetWarnings 方法获取警告后，可在 RowSetWarning 上调用其方法 getNextWarning 来获取所有可能链接到它的警告。如果返回了某个警告，则可以在其上调用 getNextWarning 并一直调用下去，直到再没有其他警告为止。

  • 3.6 Joinable 接口

    Joinable 接口同时为连接和非连接 RowSet 对象提供要在 SQL JOIN 操作中添加到 JoinRowSet 对象的功能。已经实现了 Joinable 接口的 RowSet 对象可以设置匹配列、获取匹配列或取消设置匹配列。然后 JoinRowSet 对象可以使用 RowSet 对象的匹配列作为添加 RowSet 对象的基础。

4.0 相关规范

  • JDBC 3.0 规范
  • XML Schema
  • SyncML

5.0 相关文档

  • JDBC RowSet 教程

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.sql.rowset 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql.rowset 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.sql.rowset.BaseRowSet (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.RowSetMetaDataImpl (implements javax.sql.RowSetMetaData, java.io.Serializable)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • javax.sql.rowset.RowSetWarning

接口分层结构

  • javax.sql.rowset.Joinable
    • javax.sql.rowset.CachedRowSet (并 extends javax.sql.RowSet)
      • javax.sql.rowset.WebRowSet
        • javax.sql.rowset.FilteredRowSet
        • javax.sql.rowset.JoinRowSet
    • javax.sql.rowset.JdbcRowSet (并 extends javax.sql.RowSet)
  • javax.sql.rowset.Predicate
  • java.sql.Wrapper
    • java.sql.ResultSet
      • javax.sql.RowSet
        • javax.sql.rowset.CachedRowSet (并 extends javax.sql.rowset.Joinable)
          • javax.sql.rowset.WebRowSet
            • javax.sql.rowset.FilteredRowSet
            • javax.sql.rowset.JoinRowSet
        • javax.sql.rowset.JdbcRowSet (并 extends javax.sql.rowset.Joinable)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sql.rowset 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql.rowset
的使用

使用 javax.sql.rowset 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 使用的 javax.sql.rowset 中的类
CachedRowSet
所有标准 CachedRowSet 实现都必须实现的接口。
Joinable
1.0 背景 Joinable 接口提供了用于获取和设置匹配列的各种方法，匹配列是形成通过将 RowSet 对象添加到 JoinRowSet 对象所形成的 SQL JOIN 的基础。
Predicate
为所有 FilteredRowSet 对象提供框架以描述其过滤器的标准接口。
RowSetWarning
SQLException 的一个扩展，提供关于在 RowSet 对象上设置的数据库警告的信息。
WebRowSet
所有 WebRowSet 的实现都必须实现的标准接口。

javax.sql.rowset.spi 使用的 javax.sql.rowset 中的类
WebRowSet
所有 WebRowSet 的实现都必须实现的标准接口。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


SerialArray (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialArray

java.lang.Object
    继承者  javax.sql.rowset.serial.SerialArray
所有已实现的接口：
Serializable, Cloneable, Array
public class SerialArray
extends Object
implements Array, Serializable, Cloneable

序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。

SerialArray 类提供一个根据 Array 对象创建 SerialArray 实例的构造方法，提供获取基本类型及其 SQL 名称的各种方法，以及复制全部或部分 SerialArray 对象的各种方法。

注：要让此类正常运行，到数据源的连接必须可用，这样在需要时才能实现 SQL Array 对象（将其所有元素置于客户端服务器）。在这种情况下，指向数据源中数据的逻辑指针（如定位符）当前不受支持。

另请参见：
序列化表格

构造方法摘要
SerialArray(Array array)
根据给定 Array 对象构造新的 SerialArray 对象。
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
方法摘要
void | free() 此方法释放 Array 对象及其占有的资源。
Object | getArray() 返回一个新数组，它是此 SerialArray 对象的副本。
Object | getArray(long index, int count) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | getArray(long index, int count, Map<String,Class<?>> map) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | getArray(Map<String,Class<?>> map) 返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
int | getBaseType() 获取此 SerialArray 对象中 SQL 类型的元素。
String | getBaseTypeName() 获取此 SerialArray 对象元素特定于 DBMS 的类型名称。
ResultSet | getResultSet() 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。
ResultSet | getResultSet(long index, int count) 获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SerialArray

public SerialArray(Array array,
                   Map<String,Class<?>> map)
            throws SerialException,
                   SQLException
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。

如果数组元素为 UDT 并且给定类型映射表具有针对该 UDT 的条目，则此方法执行自定义映射。自定义映射是递归的，这意味着，如果 SQL 结构类型的元素是 SQL 结构类型，而它本身又具有 SQL 结构类型的元素，则根据给定类型映射表映射每个具有自定义映射关系的结构类型。

新 SerialArray 对象包含的元素与用来构建它的 Array 对象相同，基本类型为 SQL 类型 STRUCT、ARRAY、BLOB、CLOB、DATALINK 或 JAVA_OBJECT 时除外。在这种情况下，新 SerialArray 对象中的每个元素都是适当的序列化形式，即 SerialStruct、SerialArray、SerialBlob、SerialClob、SerialDatalink 或 SerialJavaObject 对象。

注：(1) 用来创建 SerialArray 对象的 Array 对象在被传递给构造方法之前，必须已经在客户端实现了 SQL ARRAY 值的数据。否则，新 SerialArray 对象将不包含任何数据。

注：(2) 如果 Array 包含 java.sql.Types.JAVA_OBJECT 类型，则调用 SerialJavaObject 构造方法，其中会执行检查以确保此对象可序列化。

注：(3) 提供给此构造方法的 Array 对象对于任何 Array.getArray() 方法都不能返回 null。SerialArray 无法序列化 null 数组值。

参数：
array - 要序列化的 Array 对象
map - java.util.Map 对象，其中每个条目都包含：1) 给出 UDT（SQL 结构类型或 distinct 类型）完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象。map 参数对 Blob、Clob、DATALINK 或 JAVA_OBJECT 类型没有任何影响。
抛出：
SerialException - 如果在序列化 Array 对象时出错
SQLException - 如果发生数据库访问错误或者 array 或 map 值为 null

SerialArray

public SerialArray(Array array)
            throws SerialException,
                   SQLException
根据给定 Array 对象构造新的 SerialArray 对象。

此构造方法不执行自定义映射。如果数组的基本类型为 SQL 结构类型并且需要自定义映射，则应该使用 SerialArray(Array array, Map map) 构造方法。

新 SerialArray 对象包含的元素与其据以构建的 Array 对象相同，基本类型为 SQL 类型 BLOB、CLOB、DATALINK 或 JAVA_OBJECT 时除外。在这种情况下，新 SerialArray 对象中的每个元素都是适当的序列化形式，即 SerialBlob、SerialClob、SerialDatalink 或 SerialJavaObject 对象。

注：(1) 用来创建 SerialArray 对象的 Array 对象在被传递给构造方法之前，必须已经在客户端实现了 SQL ARRAY 值的数据。否则，新 SerialArray 对象将不包含任何数据。

注：(2) 提供给此构造方法的 Array 对象对于任何 Array.getArray() 方法都不能返回 null。SerialArray 无法序列化 null 数组值。

参数：
array - 要序列化的 Array 对象
抛出：
SerialException - 如果在序列化 Array 对象时出错
SQLException - 如果发生数据库访问错误或者 array 参数为 null。
方法详细信息

free

public void free()
          throws SQLException
此方法释放 Array 对象及其占有的资源。调用 free 方法后，该对象将无效。

如果多次调用了 free，则对 free 的后续调用都被视为无操作 (no-op)。

指定者：
接口 Array 中的 free
抛出：
SQLException - 如果释放 Array 的资源时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
从以下版本开始：
1.6

getArray

public Object getArray()
                throws SerialException
返回一个新数组，它是此 SerialArray 对象的副本。

指定者：
接口 Array 中的 getArray
返回：
Java 编程语言中此 SerialArray 对象 Object 形式的副本
抛出：
SerialException - 如果在获取此 SerialArray 对象的副本时出错

getArray

public Object getArray(Map<String,Class<?>> map)
                throws SerialException
返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。

如果数组元素为 UDT 并且给定类型映射表具有针对该 UDT 的条目，则此方法执行自定义映射。自定义映射是递归的，这意味着，如果 SQL 结构类型的元素是 SQL 结构类型，而它本身又具有 SQL 结构类型的元素，则根据给定类型映射表映射每个具有自定义映射关系的结构类型。

指定者：
接口 Array 中的 getArray
参数：
map - java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
返回：
Java 编程语言中此 SerialArray 对象 Object 形式的副本
抛出：
SerialException - 如果发生错误

getArray

public Object getArray(long index,
                       int count)
                throws SerialException
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

指定者：
接口 Array 中的 getArray
参数：
index - 此 SerialArray 对象中要复制的第一个元素的索引；第一个元素的索引为 0
count - 要复制的连续元素数，从给定索引处开始
返回：
Java 编程语言中此 SerialArray 对象指定元素的 Object 形式的副本
抛出：
SerialException - 如果发生错误

getArray

public Object getArray(long index,
                       int count,
                       Map<String,Class<?>> map)
                throws SerialException
返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。

如果数组元素为 UDT 并且给定类型映射表具有针对该 UDT 的条目，则此方法执行自定义映射。自定义映射是递归的，这意味着，如果 SQL 结构类型的元素是 SQL 结构类型，而它本身又具有 SQL 结构类型的元素，则根据给定类型映射表映射每个具有自定义映射关系的结构类型。

指定者：
接口 Array 中的 getArray
参数：
index - 此 SerialArray 对象中要复制的第一个元素的索引；数组中第一个元素的索引为 0
count - 要复制的连续元素数，从给定的索引处开始
map - java.util.Map 对象，该对象中的每个条目包含：1) 给出 UDT 完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
返回：
Java 编程语言中此 SerialArray 对象指定元素 Object 形式的副本
抛出：
SerialException - 如果发生错误

getBaseType

public int getBaseType()
                throws SerialException
获取此 SerialArray 对象中 SQL 类型的元素。返回的 int 是 java.sql.Types 类中的一个常量。

指定者：
接口 Array 中的 getBaseType
返回：
java.sql.Types 中的一个常量，指示此 SerialArray 对象中 SQL 类型的元素
抛出：
SerialException - 如果发生错误

getBaseTypeName

public String getBaseTypeName()
                       throws SerialException
获取此 SerialArray 对象元素特定于 DBMS 的类型名称。

指定者：
接口 Array 中的 getBaseTypeName
返回：
DBMS 用于此 SerialArray 对象基本类型的 SQL 类型名称
抛出：
SerialException - 如果发生错误

getResultSet

public ResultSet getResultSet(long index,
                              int count)
                       throws SerialException
获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。此方法使用连接的类型映射表来映射数组的元素，如果该映射表包含一个对应于基本类型的项。否则使用标准映射关系。

指定者：
接口 Array 中的 getResultSet
参数：
index - 此 SerialArray 对象中要复制的第一个元素的索引；数组中第一个元素的索引为 0
count - 要复制的连续元素数，从给定索引处开始
返回：
包含此 SerialArray 对象中指定元素的 ResultSet 对象，每个元素一个单独行
抛出：
SerialException - （该异常依次抛出 UnsupportedOperationException）如果调用此方法

getResultSet

public ResultSet getResultSet(Map<String,Class<?>> map)
                       throws SerialException
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。此方法使用指定的 map 进行类型映射自定义，除非数组的基本类型与 map 中用户定义类型 (UDT) 不匹配，这种情况下使用标准映射关系。这一 getResultSet 方法使用给定类型映射表或标准映射关系；它绝不会使用与连接关联的类型映射表。

指定者：
接口 Array 中的 getResultSet
参数：
map - java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
返回：
包含此 SerialArray 对象中所有元素的 ResultSet 对象，第个元素一个单独行
抛出：
SerialException - （该异常依次抛出 UnsupportedOperationException）如果调用此方法

getResultSet

public ResultSet getResultSet()
                       throws SerialException
获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。如果合适，则使用该连接的类型映射表来映射数组的元素；否则使用标准映射关系。

指定者：
接口 Array 中的 getResultSet
返回：
包含此 SerialArray 对象中所有元素的 ResultSet 对象，每个元素一个单独行
抛出：
SerialException - （该异常依次抛出 UnsupportedOperationException）如果调用此方法

getResultSet

public ResultSet getResultSet(long index,
                              int count,
                              Map<String,Class<?>> map)
                       throws SerialException
获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。此方法使用指定的 map 进行类型映射自定义，除非数组的基本类型与 map 中用户定义类型 (UDT) 不匹配，这种情况下使用标准映射关系。这一 getResultSet 方法使用给定类型映射表或标准映射关系；它绝不会使用与连接关联的类型映射表。

指定者：
接口 Array 中的 getResultSet
参数：
index - 此 SerialArray 对象中要复制的第一个元素的索引；数组中第一个元素的索引为 0
count - 要复制的连续元素数，从给定的索引处开始
map - java.util.Map 对象，该对象中的每个条目包含：1) 给出 UDT 完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
返回：
包含此 SerialArray 对象中指定元素的 ResultSet 对象，每个元素一个单独行
抛出：
SerialException - （该异常依次抛出 UnsupportedOperationException）如果调用此方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SerialBlob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialBlob

java.lang.Object
    继承者  javax.sql.rowset.serial.SerialBlob
所有已实现的接口：
Serializable, Cloneable, Blob
public class SerialBlob
extends Object
implements Blob, Serializable, Cloneable

SQL BLOB 值在 Java 编程语言中的序列化映射关系。

SerialBlob 类提供一个根据 Blob 对象创建实例的构造方法。注意，在根据 Blob 对象构造 SerialBlob 对象之前，Blob 对象应该已经将 SQL Blob 值的数据置于客户端上。SQL Blob 值的数据可以在客户端上以字节数组（使用 Blob.getBytes 方法）或未解释字节流的形式（使用 Blob.getBinaryStream 方法）实现。

SerialBlob 方法能够以字节数组或流的形式复制 SerialBlob 对象。这些方法还可以在 SerialBlob 对象中查找给定模式的字节或 Blob 对象，并可以更新或截断 Blob 对象。

另请参见：
序列化表格

构造方法摘要
SerialBlob(Blob blob)
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。
SerialBlob(byte[] b)
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。
方法摘要
void | free() 此方法释放 Blob 对象及其占有的资源。
InputStream | getBinaryStream() 以输入流的形式返回此 SerialBlob 对象。
InputStream | getBinaryStream(long pos, long length) 返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。
byte[] | getBytes(long pos, int length) 将指定的字节数（从给定位置开始）从此 SerialBlob 对象复制到另一个字节数组。
long | length() 获取此 SerialBlob 对象字节数组中的字节数。
long | position(Blob pattern, long start) 返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
long | position(byte[] pattern, long start) 返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。
OutputStream | setBinaryStream(long pos) 获取用于写入此 Blob 对象所表示的 BLOB 值的流。
int | setBytes(long pos, byte[] bytes) 将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。
int | setBytes(long pos, byte[] bytes, int offset, int length) 将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
void | truncate(long length) 截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SerialBlob

public SerialBlob(byte[] b)
           throws SerialException,
                  SQLException
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。

新的 SerialBlob 对象使用 byte 数组中的数据进行初始化，因此允许未连接 RowSet 对象无需接触数据源即可建立序列化的 Blob 对象。

参数：
b - 一个 byte 数组，包含要序列化的 Blob 对象的数据
抛出：
SerialException - 如果在序列化期间发生错误
SQLException - 如果发生 SQL 错误

SerialBlob

public SerialBlob(Blob blob)
           throws SerialException,
                  SQLException
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。

新的 SerialBlob 对象使用 Blob 对象中的数据进行初始化；因此，Blob 对象应该预先从数据库将 SQL BLOB 值的数据置于客户端上。否则，新 SerialBlob 对象将不包含任何数据。

参数：
blob - 一个 Blob 对象，根据该对象构造此 SerialBlob 对象 ；此值不能为 null。
抛出：
SerialException - 如果在序列化期间发生错误
SQLException - 如果传递给此构造方法的 Blob 为 null。
另请参见：
Blob
方法详细信息

getBytes

public byte[] getBytes(long pos,
                       int length)
                throws SerialException
将指定的字节数（从给定位置开始）从此 SerialBlob 对象复制到另一个字节数组。

注意，如果要复制的给定字节数大于此 SerialBlob 对象的字节数组的长度，则将其缩短为该数组的长度。

指定者：
接口 Blob 中的 getBytes
参数：
pos - 此 SerialBlob 对象中要复制的第一个字节的顺序位置；编号从 1 开始；不得小于 1 并且必须小于或等于此 SerialBlob 对象的长度
length - 要复制的字节数
返回：
一个字节数组，它是此 SerialBlob 对象一个区域的副本，从给定位置开始并且包含给定的连续字节数
抛出：
SerialException - 如果给定开始位置超出限制
另请参见：
Blob.setBytes(long, byte[])

length

public long length()
            throws SerialException
获取此 SerialBlob 对象字节数组中的字节数。

指定者：
接口 Blob 中的 length
返回：
一个 long 值，指示此 SerialBlob 对象的字节数组的长度（以字节为单位）
抛出：
SerialException - 如果发生错误

getBinaryStream

public InputStream getBinaryStream()
                            throws SerialException
以输入流的形式返回此 SerialBlob 对象。与相关方法 setBinaryStream 不同的是，无论 SerialBlob 是使用 Blob 对象还是使用 byte 数组创建的，都将生成流。

指定者：
接口 Blob 中的 getBinaryStream
返回：
包含此 SerialBlob 对象字节数组的 java.io.InputStream 对象
抛出：
SerialException - 如果发生错误
另请参见：
setBinaryStream(long)

position

public long position(byte[] pattern,
                     long start)
              throws SerialException,
                     SQLException
返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。

指定者：
接口 Blob 中的 position
参数：
pattern - 要搜索的字节模式
start - 此 SerialBlob 对象中字节的位置，搜索从该位置开始；第一个位置是 1；不得小于 1 且不得大于此 SerialBlob 对象的长度
返回：
此 SerialBlob 对象中给定模式开始的位置，从指定位置开始；如果找不到模式或者给定开始位置超出限制，则返回 -1；返回值的位置编号从 1 开始
抛出：
SerialException - 如果在序列化 blob 时发生错误
SQLException - 如果在从数据库访问 BLOB 值时发生错误

position

public long position(Blob pattern,
                     long start)
              throws SerialException,
                     SQLException
返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。

指定者：
接口 Blob 中的 position
参数：
pattern - 进行搜索的 Blob 对象；
start - 在此 SerialBlob 对象中开始搜索的字节的位置；第一个位置是 1；不得小于 1 且不得大于此 SerialBlob 对象的长度
返回：
在此 SerialBlob 对象中给定 Blob 对象开始的位置，从指定位置开始；如果找不到模式或者给定开始位置超出限制，则返回 -1；返回值的位置编号从 1 开始
抛出：
SerialException - 如果在序列化 blob 时发生错误
SQLException - 如果在从数据库访问 BLOB 值时发生错误

setBytes

public int setBytes(long pos,
                    byte[] bytes)
             throws SerialException,
                    SQLException
将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。

指定者：
接口 Blob 中的 setBytes
参数：
pos - SQL BLOB 值中开始写入的位置。第一个位置是 1；不得小于 1 且不得大于此 SerialBlob 对象的长度。
bytes - 要写入此 Blob 对象所表示的 BLOB 值的字节数组
返回：
写入的字节数
抛出：
SerialException - 如果在访问 BLOB 值时发生错误；如果设置了无效的位置；如果设置了无效的偏移量值
SQLException - 如果从数据库访问 BLOB 值时发生错误
另请参见：
getBytes(long, int)

setBytes

public int setBytes(long pos,
                    byte[] bytes,
                    int offset,
                    int length)
             throws SerialException,
                    SQLException
将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。写入操作从 BLOB 值中的位置 pos 处开始；写入给定字节数组中的 len 个字节。

指定者：
接口 Blob 中的 setBytes
参数：
pos - SQL BLOB 对象中开始写入的位置。第一个位置是 1；不得小于 1 且不得大于此 SerialBlob 对象的长度。
bytes - 要写入 BLOB 值的字节数组
offset - byte 数组中的偏移量，从该偏移量开始读取字节。第一个偏移量位置是 0；不得小于 0 且不得大于 byte 数组的长度
length - 要从 bytes 字节数组写入 BLOB 值的字节数。
返回：
写入的字节数
抛出：
SerialException - 如果在访问 BLOB 值时发生错误；如果设置了无效的位置；如果设置了无效的偏移量值；如果要写入的字节数大于 SerialBlob 长度；如果长度和偏移量的组合值大于 Blob 缓冲区
SQLException - 如果在从数据库访问 BLOB 值时发生错误。
另请参见：
getBytes(long, int)

setBinaryStream

public OutputStream setBinaryStream(long pos)
                             throws SerialException,
                                    SQLException
获取用于写入此 Blob 对象所表示的 BLOB 值的流。该流从位置 pos 处开始。如果此 SerialBlob 对象是使用 Blob 进行实例化的，则此方法将 setBinaryStream() 调用转发到底层 Blob。如果此 SerialBlob 是使用 byte 数组进行实例化的，则抛出 SerialException。

指定者：
接口 Blob 中的 setBinaryStream
参数：
pos - BLOB 值中开始进行写入操作的位置
返回：
可以写入数据的 java.io.OutputStream 对象
抛出：
SQLException - 如果访问 BLOB 值时发生错误
SerialException - 如果 SerialBlob 不是使用支持 setBinaryStream() 的 Blob 对象进行实例化的
从以下版本开始：
1.4
另请参见：
getBinaryStream()

truncate

public void truncate(long length)
              throws SerialException
截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。

指定者：
接口 Blob 中的 truncate
参数：
length - 此 Blob 对象表示的 BLOB 值截取后的长度（以字节为单位）
抛出：
SerialException - 如果在访问 Blob 值时发生错误，或者要截取的长度大于 SerialBlob 长度

getBinaryStream

public InputStream getBinaryStream(long pos,
                                   long length)
                            throws SQLException
返回一个包含部分 Blob 值的 InputStream 对象，它从 pos 指定的字节开始，具有 length 个字节长度。

指定者：
接口 Blob 中的 getBinaryStream
参数：
pos - 要获取的部分值的第一个字节的偏移量。Blob 的第一个字节位于位置 1。
length - 要获取的部分值的字节长度
返回：
通过其可以读取部分 Blob 值的 InputStream
抛出：
SQLException - 如果 pos 小于 1，pos 大于 Blob 的字节数，或者 pos + length 大于 Blob 的字节数
从以下版本开始：
1.6

free

public void free()
          throws SQLException
此方法释放 Blob 对象及其占有的资源。调用 free 方法后，该对象将无效。如果多次调用了 free 方法，则对 free 的后续调用将被视为无操作 (no-op)。

指定者：
接口 Blob 中的 free
抛出：
SQLException - 如果释放 Blob 的资源时发生错误
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SerialClob (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialClob

java.lang.Object
    继承者  javax.sql.rowset.serial.SerialClob
所有已实现的接口：
Serializable, Cloneable, Clob
public class SerialClob
extends Object
implements Clob, Serializable, Cloneable

SQL CLOB 值在 Java 编程语言中的序列化映射关系。

SerialClob 类提供一个根据 Clob 对象创建实例的构造方法。注意，在根据 Clob 对象构造 SerialBlob 对象之前，Clob 对象应该已经将 SQL Clob 值的数据置于客户端上。SQL CLOB 值的数据可以在客户端上以 Unicode 字符流的形式实现。

SerialClob 方法可以从 SerialClob 对象获取子字符串或者查找某种模式的字符的开头。

另请参见：
序列化表格

构造方法摘要
SerialClob(char[] ch)
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。
SerialClob(Clob clob)
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。
方法摘要
void | free() 此方法释放 Clob 对象以及它所占用的资源。
InputStream | getAsciiStream() 以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
Reader | getCharacterStream() 以 Unicode 字符流的形式返回此 SerialClob 对象的数据。
Reader | getCharacterStream(long pos, long length) 返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。
String | getSubString(long pos, int length) 返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。
long | length() 获取此 SerialClob 对象字节数组中的字节数。
long | position(Clob searchStr, long start) 返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
long | position(String searchStr, long start) 返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。
OutputStream | setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
Writer | setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。
int | setString(long pos, String str) 在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。
int | setString(long pos, String str, int offset, int length) 将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。
void | truncate(long length) 截取此 SerialClob 对象所表示的 CLOB 值，使其长度为 len 个字符。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SerialClob

public SerialClob(char[] ch)
           throws SerialException,
                  SQLException
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。

新的 SerialClob 对象使用 char 数组中的数据进行初始化，因此允许未连接 RowSet 对象无需接触数据源即可建立序列化的 Clob 对象。

参数：
ch - 表示要序列化的 Clob 对象的 char 数组
抛出：
SerialException - 如果在序列化期间发生错误
SQLException - 如果发生 SQL 错误

SerialClob

public SerialClob(Clob clob)
           throws SerialException,
                  SQLException
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。

新的 SerialClob 对象使用 Clob 对象中的数据进行初始化；因此，Clob 对象应该预先从数据库将 SQL CLOB 值的数据置于客户端上。否则，新 SerialClob 对象将不包含任何数据。

注：提供给此构造方法的 Clob 对象不能对 Clob.getCharacterStream() 和 Clob.getAsciiStream 方法返回 null。此 SerialClob 构造方法不能在此实例中序列化 Clob 对象，将抛出 SQLException 对象。

参数：
clob - 要用来构造此 SerialClob 对象的 Clob 对象；不能为 null
抛出：
SerialException - 如果在序列化期间发生错误
SQLException - 如果在捕获 CLOB 期间发生 SQL 错误；如果 Clob 对象为 null；如果对 Clob 调用 Clob.getCharacterStream() 和 Clob.getAsciiStream() 方法时都返回 null
另请参见：
Clob
方法详细信息

length

public long length()
            throws SerialException
获取此 SerialClob 对象字节数组中的字节数。

指定者：
接口 Clob 中的 length
返回：
一个 long 值，指示此 SerialClob 对象的字节数组的长度（以字节为单位）
抛出：
SerialException - 如果发生错误

getCharacterStream

public Reader getCharacterStream()
                          throws SerialException
以 Unicode 字符流的形式返回此 SerialClob 对象的数据。与相关方法 getAsciiStream 不同的是，无论 SerialClob 对象是使用 Clob 对象还是使用 char 数组创建，都将生成流。

指定者：
接口 Clob 中的 getCharacterStream
返回：
包含此 SerialClob 对象数据的 java.io.Reader 对象
抛出：
SerialException - 如果发生错误
另请参见：
Clob.setCharacterStream(long)

getAsciiStream

public InputStream getAsciiStream()
                           throws SerialException,
                                  SQLException
以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。如果此 SerialClob 对象是使用 Clob 对象实例化的，则此方法将 getAsciiStream 调用转发到底层 Clob。如果此 SerialClob 是使用 char 数组实例化的，则抛出 SerialException。

指定者：
接口 Clob 中的 getAsciiStream
返回：
包含此 SerialClob 对象数据的 java.io.InputStream 对象
抛出：
SerialException - 如果此 SerialClob 对象不是使用 Clob 对象实例化的
SQLException - 如果在访问用于创建此 SerialClob 对象的 Clob 对象表示的 CLOB 值时发生错误
另请参见：
Clob.setAsciiStream(long)

getSubString

public String getSubString(long pos,
                           int length)
                    throws SerialException
返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。

指定者：
接口 Clob 中的 getSubString
参数：
pos - 子字符串中要复制的第一个字符的位置；SerialClob 对象的第一个字符位于位置 1；不得小于 1，并且开始位置与子字符串的长度之和必须小于此 SerialClob 对象的长度
length - 子字符串中要返回的字符数；不得大于此 SerialClob 对象的长度，并且开始位置与子字符串的长度之和必须小于此 SerialClob 对象的长度
返回：
包含此 SerialClob 对象的子字符串的 String 对象，从给定位置开始，包含指定的连续字符数
抛出：
SerialException - 如果两个参数中的任意一个超出限制

position

public long position(String searchStr,
                     long start)
              throws SerialException,
                     SQLException
返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。如果未找到该模式，则此方法返回 -1。

指定者：
接口 Clob 中的 position
参数：
searchStr - 要搜索的 String 对象
start - 此 SerialClob 对象中搜索开始的位置；第一个位置是 1；不得小于 1 且不得大于此 SerialClob 对象的长度
返回：
给定 String 对象开始的位置，从指定位置开始搜索；如果未找到给定的 String 对象或者开始位置超出限制，则返回 -1；返回值的位置编号从 1 开始
抛出：
SerialException - 如果在查找 String 签名时发生错误
SQLException - 如果从数据库访问 Blob 值时发生错误

position

public long position(Clob searchStr,
                     long start)
              throws SerialException,
                     SQLException
返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。如果未找到该模式，则此方法返回 -1。

指定者：
接口 Clob 中的 position
参数：
searchStr - 要搜索的 Clob 对象
start - 此 SerialClob 对象中开始搜索的位置；第一个位置是 1；不得小于 1 且不得大于此 SerialClob 对象的长度
返回：
此 SerialClob 对象中的位置，给定的 Clob 对象从该位置开始，位于指定开始位置或该位置之后
抛出：
SerialException - 如果在查找 Clob 签名时发生错误
SQLException - 如果在从数据库访问 Blob 值时发生错误

setString

public int setString(long pos,
                     String str)
              throws SerialException
在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。

指定者：
接口 Clob 中的 setString
参数：
pos - 开始写入此 SerialClob 对象所表示的 CLOB 值的位置；第一个位置是 1；不得小于 1 且不得大于此 SerialClob 对象的长度
str - 要写入此 SerialClob 对象所表示的 CLOB 值的字符串
返回：
写入的字符数
抛出：
SerialException - 如果在访问 CLOB 值时发生错误；如果设置了无效的位置；如果设置了无效的偏移量值；如果要写入的字节数大于 SerialClob 长度；如果长度与偏移量的组合值大于 Clob 缓冲区

setString

public int setString(long pos,
                     String str,
                     int offset,
                     int length)
              throws SerialException
将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。

指定者：
接口 Clob 中的 setString
参数：
pos - 开始写入此 SerialClob 对象所表示 CLOB 值的位置；第一个位置是 1；不得小于 1 且不得大于此 SerialClob 对象的长度
str - 要写入此 Clob 对象所表示 CLOB 值的字符串
offset - str 中开始读取要写入的字符的偏移量
length - 要写入的字符数
返回：
写入的字符数
抛出：
SerialException - 如果在访问 CLOB 值时发生错误；如果设置了无效的位置；如果设置了无效的偏移量值；如果要写入的字节数大于 SerialClob 长度；如果长度与偏移量的组合值大于 Clob 缓冲区

setAsciiStream

public OutputStream setAsciiStream(long pos)
                            throws SerialException,
                                   SQLException
获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。如果此 SerialClob 对象是使用 Clob 对象实例化的，则此方法将 getAsciiStream 调用转发到底层 Clob。如果此 SerialClob 是使用 char 数组实例化的，则抛出 SerialException。

指定者：
接口 Clob 中的 setAsciiStream
参数：
pos - 开始写入此 CLOB 对象的位置
返回：
可写入 ASCII 编码字符的流
抛出：
SerialException - 如果 SerialClob 不是使用支持 setAsciiStream 的 Clob 对象实例化的
SQLException - 如果在访问 CLOB 值时发生错误
另请参见：
getAsciiStream()

setCharacterStream

public Writer setCharacterStream(long pos)
                          throws SerialException,
                                 SQLException
获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。如果此 SerialClob 对象是使用 Clob 对象实例化的，则此方法将 setCharacterStream() 调用转发到底层 Clob。如果此 SerialClob 是使用 char 数组实例化的，则抛出 SerialException。

指定者：
接口 Clob 中的 setCharacterStream
参数：
pos - 开始写入 CLOB 值中的位置
返回：
可写入 Unicode 编码字符的流
抛出：
SerialException - 如果 SerialClob 不是使用支持 setCharacterStream 的 Clob 对象实例化的
SQLException - 如果在访问 CLOB 值时发生错误
另请参见：
getCharacterStream()

truncate

public void truncate(long length)
              throws SerialException
截取此 SerialClob 对象所表示的 CLOB 值，使其长度为 len 个字符。

将 SerialClob 对象截取至长度 0 相当于清除其内容。

指定者：
接口 Clob 中的 truncate
参数：
length - CLOB 值应被截取的字节长度
抛出：
SQLException - 如果访问 CLOB 值时发生错误
SerialException

getCharacterStream

public Reader getCharacterStream(long pos,
                                 long length)
                          throws SQLException
从接口 Clob 复制的描述
返回包含部分 Clob 值的 Reader 对象，该值从 pos 指定的字符开始，长度为 length 个字符。

指定者：
接口 Clob 中的 getCharacterStream
参数：
pos - 将获取的部分值第一个字符的偏移量。Clob 中的第一个字符在位置 1 处。
length - 要获取的部分值的字符长度。
返回：
Reader，可以通过它来读取部分 Clob 值。
抛出：
SQLException - 如果 pos 小于 1，或者 pos 大于 Clob 中的字符数，或者 pos + length 大于 Clob 中的字符数
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法

free

public void free()
          throws SQLException
从接口 Clob 复制的描述
此方法释放 Clob 对象以及它所占用的资源。调用 free 方法后，该对象无效。

在调用 free 方法之后，试图调用 free 之外的方法将导致抛出 SQLException。如果多次调用 free，则对 free 的后续调用被视为无操作 (no-op)。

指定者：
接口 Clob 中的 free
抛出：
SQLException - 如果释放 Clob 的资源时发生错误
SQLFeatureNotSupportedException - 如果 JDBC 驱动程序不支持此方法
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SerialDatalink (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialDatalink

java.lang.Object
    继承者  javax.sql.rowset.serial.SerialDatalink
所有已实现的接口：
Serializable, Cloneable
public class SerialDatalink
extends Object
implements Serializable, Cloneable

SQL DATALINK 值在 Java 编程语言中的序列化映射关系。DATALINK 值引用数据源管理的底层数据源之外的文件。

RowSet 实现可以使用 RowSet.getURL 方法来获取 java.net.URL 对象，该对象可用于操作外部数据。

      java.net.URL url = rowset.getURL(1);

另请参见：
序列化表格

构造方法摘要
SerialDatalink(URL url)
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。
方法摘要
 URL getDatalink()
返回一个新 URL，它是此 SerialDatalink 对象的副本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SerialDatalink

public SerialDatalink(URL url)
               throws SerialException
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。

抛出：
SerialException - 如果 url 参数为 null
方法详细信息

getDatalink

public URL getDatalink()
                throws SerialException
返回一个新 URL，它是此 SerialDatalink 对象的副本。

返回：
Java 编程语言中此 SerialDatalink 对象 URL 对象形式的副本。
抛出：
SerialException - 如果 URL 对象不可反序列化
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SerialException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  javax.sql.rowset.serial.SerialException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SerialException
extends SQLException

指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

另请参见：
序列化表格

构造方法摘要
SerialException()
创建不带消息的新 SerialException。
SerialException(String msg)
创建带有指定消息的新 SerialException。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SerialException

public SerialException()
创建不带消息的新 SerialException。

SerialException

public SerialException(String msg)
创建带有指定消息的新 SerialException。

参数：
msg - 详细消息
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SerialJavaObject (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialJavaObject

java.lang.Object
    继承者  javax.sql.rowset.serial.SerialJavaObject
所有已实现的接口：
Serializable, Cloneable
public class SerialJavaObject
extends Object
implements Serializable, Cloneable

SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。假定 Java 对象实现 Serializable 接口，则此类仅包装序列化进程。

但是，如果因为 Java 对象不是立即可序列化的而无法进行序列化，则此类将尝试序列化所有非静态成员，以允许序列化对象状态。静态或瞬态字段不可序列化，试图序列化它们将导致抛出 SerialException 对象。

另请参见：
序列化表格

构造方法摘要
SerialJavaObject(Object obj)
SerialJavaObject 帮助器类的构造方法。
方法摘要
Field[] | getFields() 返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。
Object | getObject() 返回一个 Object，它是此 SerialJavaObject 对象的副本。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SerialJavaObject

public SerialJavaObject(Object obj)
                 throws SerialException
SerialJavaObject 帮助器类的构造方法。

参数：
obj - 要序列化的 Java Object
抛出：
SerialException - 如果发现对象不可序列化
方法详细信息

getObject

public Object getObject()
                 throws SerialException
返回一个 Object，它是此 SerialJavaObject 对象的副本。

返回：
Java 编程语言中此 SerialJavaObject 对象 Object 形式的副本
抛出：
SerialException - 如果实例已损坏

getFields

public Field[] getFields()
                  throws SerialException
返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。

返回：
Field 对象数组
抛出：
SerialException - 如果在访问序列化对象时遇到错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SerialRef (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialRef

java.lang.Object
    继承者  javax.sql.rowset.serial.SerialRef
所有已实现的接口：
Serializable, Cloneable, Ref
public class SerialRef
extends Object
implements Ref, Serializable, Cloneable

Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。

SerialRef 类提供一个根据 Ref 对象创建 SerialRef 实例的构造方法，并提供用于获取和设置 Ref 对象的各种方法。

另请参见：
序列化表格

构造方法摘要
SerialRef(Ref ref)
根据给定 Ref 对象构造 SerialRef 对象。
方法摘要
String | getBaseTypeName() 返回描述 Ref 的基本类型名称的字符串。
Object | getObject() 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
Object | getObject(Map<String,Class<?>> map) 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
void | setObject(Object obj) 将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SerialRef

public SerialRef(Ref ref)
          throws SerialException,
                 SQLException
根据给定 Ref 对象构造 SerialRef 对象。

参数：
ref - Ref 对象；不能为 null
抛出：
SQLException - 如果发生数据库访问错误；如果 ref 为 null；如果 Ref 对象返回的基本类型名称的值为 null。
SerialException - 如果在序列化 Ref 对象时发生错误
方法详细信息

getBaseTypeName

public String getBaseTypeName()
                       throws SerialException
返回描述 Ref 的基本类型名称的字符串。

指定者：
接口 Ref 中的 getBaseTypeName
返回：
Ref 基本类型名称的字符串
抛出：
SerialException - 如果尚未设置任何 Ref 对象

getObject

public Object getObject(Map<String,Class<?>> map)
                 throws SerialException
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。根据给定类型映射表映射结构类型的属性。

指定者：
接口 Ref 中的 getObject
参数：
map - 包含零个或多个条目的 java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
返回：
解析自 Ref 引用并根据提供的类型映射表映射的对象实例
抛出：
SerialException - 如果在解析引用时遇到错误
另请参见：
Ref.setObject(java.lang.Object)

getObject

public Object getObject()
                 throws SerialException
返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。

指定者：
接口 Ref 中的 getObject
返回：
解析自 Ref 引用的对象实例
抛出：
SerialException - 如果在解析引用时遇到错误
另请参见：
Ref.setObject(java.lang.Object)

setObject

public void setObject(Object obj)
               throws SerialException
将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。

指定者：
接口 Ref 中的 setObject
参数：
obj - 表示要引用的 SQL 结构类型的 Object
抛出：
SerialException - 如果在生成由此 SerialRef 对象引用的结构类型时遇到错误
另请参见：
Ref.getObject(),
Ref.getObject(Map),
PreparedStatement.setObject(int, Object),
CallableStatement.setObject(String, Object)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SerialStruct (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SerialStruct

java.lang.Object
    继承者  javax.sql.rowset.serial.SerialStruct
所有已实现的接口：
Serializable, Cloneable, Struct
public class SerialStruct
extends Object
implements Struct, Serializable, Cloneable

SQL 结构类型在 Java 编程语言中的序列化映射关系。每个尚未序列化的属性将被映射为序列化形式；如果属性本身是结构类型，则其每个尚未序列化的属性将被映射为序列化形式。

此外，结构类型将被映射为 Java 编程语言中的类，如果存在这样的映射关系；如果存在适用于其属性的映射关系，则其属性也会被映射。

SerialStruct 类提供一个根据 Struct 对象创建实例的构造方法，一个用于在数据库中获取 SQL 结构类型的 SQL 类型名称的方法，以及用于获取其属性值的各种方法。

另请参见：
序列化表格

构造方法摘要
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。
方法摘要
Object[] | getAttributes() 获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。
Object[] | getAttributes(Map<String,Class<?>> map) 获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
String | getSQLTypeName() 获取此 SerialStruct 对象的 SQL 类型名称。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SerialStruct

public SerialStruct(Struct in,
                    Map<String,Class<?>> map)
             throws SerialException
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。

参数：
map - java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
抛出：
SerialException - 如果发生错误
另请参见：
Struct

SerialStruct

public SerialStruct(SQLData in,
                    Map<String,Class<?>> map)
             throws SerialException
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。类型映射表给出映射到的 SQL 类型和类。SQLData 对象定义将 SQL 类型映射到的类。

参数：
in - SQLData 类的实例，该类将 SQL 结构类型的映射关系定义为 Java 编程语言中的一个或多个对象
map - java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
抛出：
SerialException - 如果发生错误
方法详细信息

getSQLTypeName

public String getSQLTypeName()
                      throws SerialException
获取此 SerialStruct 对象的 SQL 类型名称。此为在结构类型的 SQL 定义中使用的名称。

指定者：
接口 Struct 中的 getSQLTypeName
返回：
String 对象，该对象表示此 SerialStruct 对象所表示的 SQL 结构类型的 SQL 类型名称
抛出：
SerialException - 如果发生错误

getAttributes

public Object[] getAttributes()
                       throws SerialException
获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。

指定者：
接口 Struct 中的 getAttributes
返回：
Object 值的数组，其中每个元素为此 SerialStruct 对象所表示的 SQL 结构类型的属性。
抛出：
SerialException - 如果发生错误

getAttributes

public Object[] getAttributes(Map<String,Class<?>> map)
                       throws SerialException
获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。

指定者：
接口 Struct 中的 getAttributes
参数：
map - java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 对象 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
返回：
Object 值数组，其中每个元素都是此 SerialStruct 对象所表示的 SQL 结构类型的属性
抛出：
SerialException - 如果发生错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLInputImpl (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SQLInputImpl

java.lang.Object
    继承者  javax.sql.rowset.serial.SQLInputImpl
所有已实现的接口：
SQLInput
public class SQLInputImpl
extends Object
implements SQLInput

用于自定义映射用户定义类型 (UDT) 的输入流。SQLInputImpl 对象是一个包含值流的输入流，这些值是 UDT 的属性。

在对具有自定义映射关系的 SQL 结构类型或不同类型调用 getObject 方法时，驱动程序在后台使用此类；程序员决不直接调用 SQLInputImpl 方法。这里提供这些方法是为了便于编写 RowSet 实现。

SQLInputImpl 类提供一组类似于 ResultSet 获取方法的读取方法。这些方法可以在 SQLInputImpl 对象中读取值。

方法 wasNull 用于确定读取的最后一个值是否是 SQL NULL。

当用实现接口 SQLData 的类的对象调用方法 getObject 时，JDBC 驱动程序调用方法 SQLData.getSQLType 来确定要自定义映射的 UDT 的 SQL 类型。驱动程序创建一个 SQLInputImpl 实例，并用 UDT 的属性填充它。然后，驱动程序将输入流传递给 SQLData.readSQL 方法，该方法依次调用 SQLInputImpl 读取方法从输入流读取属性。

另请参见：
SQLData

构造方法摘要
SQLInputImpl(Object[] attributes, Map<String,Class<?>> map)
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。
方法摘要
Array | readArray() 从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。
InputStream | readAsciiStream() 以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。
BigDecimal | readBigDecimal() 以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。
InputStream | readBinaryStream() 以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。
Blob | readBlob() 以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。
boolean | readBoolean() 以 Java 编程语言中 boolean 的形式获取此 SQLInputImpl 对象中的下一个属性。
byte | readByte() 以 Java 编程语言中 byte 的形式获取此 SQLInputImpl 对象中的下一个属性。
byte[] | readBytes() 以字节数组的形式获取此 SQLInputImpl 对象中的下一个属性。
Reader | readCharacterStream() 以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。
Clob | readClob() 以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。
Date | readDate() 以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。
double | readDouble() 以 Java 编程语言中 double 的形式获取此 SQLInputImpl 对象中的下一个属性。
float | readFloat() 以 Java 编程语言中 float 的形式获取此 SQLInputImpl 对象中的下一个属性。
int | readInt() 以 Java 编程语言中 int 的形式获取此 SQLInputImpl 对象中的下一个属性。
long | readLong() 以 Java 编程语言中 long 的形式获取此 SQLInputImpl 对象中的下一个属性。
NClob | readNClob() 从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。
String | readNString() 读取流中下一个属性并以 Java 编程语言中 String 的形式返回。
Object | readObject() 以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。
Ref | readRef() 以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。
RowId | readRowId() 从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。
short | readShort() 以 Java 编程语言中 short 的形式获取此 SQLInputImpl 对象中的下一个属性。
SQLXML | readSQLXML() 从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。
String | readString() 以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。
Time | readTime() 以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
Timestamp | readTimestamp() 以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。
URL | readURL() 从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。
boolean | wasNull() 确认从此 SQLInputImpl 对象读取的上一个值是否为 null。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SQLInputImpl

public SQLInputImpl(Object[] attributes,
                    Map<String,Class<?>> map)
             throws SQLException
创建一个 SQLInputImpl 对象，并使用给定的属性数组和类型映射表进行初始化。如果这些属性中有某个 UDT 属性的名称存在于类型映射表条目中，则根据相应的 SQLData 实现映射该属性。

参数：
attributes - Object 实例数组，其中每个元素都是 UDT 属性。数组中属性的顺序与它们在 UDT 定义中所定义的顺序相同。
map - 包含零个或多个条目的 java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
抛出：
SQLException - 如果 attributes 或 map 的值为 null
方法详细信息

readString

public String readString()
                  throws SQLException
以 Java 编程语言中 String 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readString
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readBoolean

public boolean readBoolean()
                    throws SQLException
以 Java 编程语言中 boolean 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readBoolean
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readByte

public byte readByte()
              throws SQLException
以 Java 编程语言中 byte 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readByte
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readShort

public short readShort()
                throws SQLException
以 Java 编程语言中 short 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readShort
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readInt

public int readInt()
            throws SQLException
以 Java 编程语言中 int 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readInt
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readLong

public long readLong()
              throws SQLException
以 Java 编程语言中 long 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readLong
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readFloat

public float readFloat()
                throws SQLException
以 Java 编程语言中 float 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readFloat
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readDouble

public double readDouble()
                  throws SQLException
以 Java 编程语言中 double 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readDouble
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readBigDecimal

public BigDecimal readBigDecimal()
                          throws SQLException
以 java.math.BigDecimal 的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readBigDecimal
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readBytes

public byte[] readBytes()
                 throws SQLException
以字节数组的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readBytes
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readDate

public Date readDate()
              throws SQLException
以 java.sql.Date 对象的形式获取此 SQLInputImpl 中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现定义的 UDT 映射。

指定者：
接口 SQLInput 中的 readDate
返回：
此 SQLInputImpl 对象中的下一个属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readTime

public Time readTime()
              throws SQLException
以 java.sql.Time 对象的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readTime
返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readTimestamp

public Timestamp readTimestamp()
                        throws SQLException
以 java.sql.Timestamp 对象的形式获取此 SQLInputImpl 对象中的下一个属性。

指定者：
接口 SQLInput 中的 readTimestamp
返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readCharacterStream

public Reader readCharacterStream()
                           throws SQLException
以 Unicode 字符流的形式获取此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readCharacterStream
返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readAsciiStream

public InputStream readAsciiStream()
                            throws SQLException
以 ASCII 字符流的形式返回此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readAsciiStream
返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readBinaryStream

public InputStream readBinaryStream()
                             throws SQLException
以未解释字节流的形式返回此 SQLInputImpl 对象中的下一个属性。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readBinaryStream
返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readObject

public Object readObject()
                  throws SQLException
以 Java 编程语言中 Object 的形式获取此 SQLInputImpl 对象的头部值。如果不存在自定义映射关系，则返回对象的实际类型由 SQL 类型到 Java 编程语言中类型的默认映射关系确定；如果存在自定义映射关系，则返回对象的类型由此流的类型映射确定。

在将流传递给应用程序之前，启用 JDBC 技术的驱动程序在流中注册类型映射表。

当流头部中的数据为 SQL NULL 时，此方法返回 null。如果数据是具有自定义映射关系的 SQL 结构类型或 distinct 类型，则此方法确定位于流头部的数据的 SQL 类型，构造适当类的对象，并对该对象调用 SQLData.readSQL 方法。然后，readSQL 方法调用适当的 SQLInputImpl.readXXX 方法从流获取属性值。

指定者：
接口 SQLInput 中的 readObject
返回：
以 Java 编程语言中 Object 的形式返回流头部的值；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值

readRef

public Ref readRef()
            throws SQLException
以 Java 编程语言中 Ref 对象的形式获取此 SQLInputImpl 对象的头部值。

指定者：
接口 SQLInput 中的 readRef
返回：
表示位于流头部的 SQL REF 值的 Ref 对象；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readBlob

public Blob readBlob()
              throws SQLException
以 Java 编程语言中 Blob 对象的形式获取此 SQLInputImpl 对象头部的 BLOB 值。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readBlob
返回：
表示位于此流头部的 SQL BLOB 值的 Blob 对象；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readClob

public Clob readClob()
              throws SQLException
以 Java 编程语言中 Clob 对象的形式获取此 SQLInputImpl 对象头部的 CLOB 值。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readClob
返回：
表示位于流头部的 SQL CLOB 值的 Clob 对象；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readArray

public Array readArray()
                throws SQLException
从流中读取 SQL ARRAY 值并以 Java 编程语言中 Array 对象的形式返回。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readArray
返回：
表示位于流头部的 SQL ARRAY 值的 Array 对象；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

wasNull

public boolean wasNull()
                throws SQLException
确认从此 SQLInputImpl 对象读取的上一个值是否为 null。

指定者：
接口 SQLInput 中的 wasNull
返回：
如果最近一次读取的 SQL 值为 null，则返回 true；否则返回 false；默认情况下它将返回 false
抛出：
SQLException - 如果在确定上一次读取的值是否为 null 值时发生错误。

readURL

public URL readURL()
            throws SQLException
从流中读取 SQL DATALINK 值并以 Java 编程语言中 URL 对象的形式返回。

此方法不执行类型安全检查来确定返回类型是否为期望类型；该职责已委托给 SQLData 实现的 UDT 映射。

指定者：
接口 SQLInput 中的 readURL
返回：
表示位于流头部的 SQL DATALINK 值的 URL 对象；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果读取位置被定位在无效位置，或者流中不存在更多值。

readNClob

public NClob readNClob()
                throws SQLException
从流中读取 SQL NCLOB 值并以 Java 编程语言中 Clob 对象的形式返回。

指定者：
接口 SQLInput 中的 readNClob
返回：
NClob 对象，表示位于流头部的 SQL NCLOB 值的数据；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误

readNString

public String readNString()
                   throws SQLException
读取流中下一个属性并以 Java 编程语言中 String 的形式返回。访问 NCHAR、NVARCHAR 和 LONGNVARCHAR 列时使用该方法。

指定者：
接口 SQLInput 中的 readNString
返回：
属性；如果值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误

readSQLXML

public SQLXML readSQLXML()
                  throws SQLException
从流中读取 SQL XML 值并以 Java 编程语言中 SQLXML 对象的形式返回。

指定者：
接口 SQLInput 中的 readSQLXML
返回：
SQLXML 对象，表示位于流头部的 SQL XML 值的数据；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误

readRowId

public RowId readRowId()
                throws SQLException
从流中读取 SQL ROWID 值并以 Java 编程语言中 RowId 对象的形式返回。

指定者：
接口 SQLInput 中的 readRowId
返回：
RowId 对象，表示位于流头部的 SQL ROWID 值的数据；如果读取的值为 SQL NULL，则返回 null
抛出：
SQLException - 如果发生数据库访问错误
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SQLOutputImpl (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.serial
类 SQLOutputImpl

java.lang.Object
    继承者  javax.sql.rowset.serial.SQLOutputImpl
所有已实现的接口：
SQLOutput
public class SQLOutputImpl
extends Object
implements SQLOutput

用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。驱动程序在内部使用此接口，应用程序员决不能直接调用其方法。

当应用程序调用 PreparedStatement.setObject 方法时，驱动程序将检查要写入的值是否具有自定义映射关系的 UDT。如果是，则在类型映射表中将存在一个条目，该条目包含 Class 对象，用于为此 UDT 实现 SQLData 的类。如果要写入的值是 SQLData 的实例，则驱动程序将创建 SQLOutputImpl 的实例并将其传递给 SQLData.writeSQL 方法。writeSQL 方法依次调用适当的 SQLOutputImpl.writeXXX 方法，从 SQLData 对象以 SQL 用户定义类型的表示形式将数据写入 SQLOutputImpl 输出流。

构造方法摘要
SQLOutputImpl(Vector<?> attributes, Map<String,?> map)
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。
方法摘要
void | writeArray(Array x) 将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。
void | writeAsciiStream(InputStream x) 将 ASCII 字符流写入此 SQLOutputImpl 对象。
void | writeBigDecimal(BigDecimal x) 将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。
void | writeBinaryStream(InputStream x) 将未解释字节流写入此 SQLOutputImpl 对象。
void | writeBlob(Blob x) 将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。
void | writeBoolean(boolean x) 将 Java 编程语言中的 boolean 写入此 SQLOutputImpl 对象。
void | writeByte(byte x) 将 Java 编程语言中的 byte 写入此 SQLOutputImpl 对象。
void | writeBytes(byte[] x) 将 Java 编程语言中的 byte 数组写入此 SQLOutputImpl 对象。
void | writeCharacterStream(Reader x) 将 Unicode 字符流写入此 SQLOutputImpl 对象。
void | writeClob(Clob x) 将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。
void | writeDate(Date x) 将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。
void | writeDouble(double x) 将 Java 编程语言中的 double 写入此 SQLOutputImpl 对象。
void | writeFloat(float x) 将 Java 编程语言中的 float 写入此 SQLOutputImpl 对象。
void | writeInt(int x) 将 Java 编程语言中的 int 写入此 SQLOutputImpl 对象。
void | writeLong(long x) 将 Java 编程语言中的 long 写入此 SQLOutputImpl 对象。
void | writeNClob(NClob x) 将 SQL NCLOB 值写入流中。
void | writeNString(String x) 将下一个属性以 Java 编程语言中 String 的形式写入流中。
void | writeObject(SQLData x) 将包含在给定 SQLData 对象中的数据写入流中。
void | writeRef(Ref x) 将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。
void | writeRowId(RowId x) 将 SQL ROWID 值写入流中。
void | writeShort(short x) 将 Java 编程语言中的 short 写入此 SQLOutputImpl 对象。
void | writeSQLXML(SQLXML x) 将 SQL XML 值写入流中。
void | writeString(String x) 将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。
void | writeStruct(Struct x) 将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。
void | writeTime(Time x) 将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。
void | writeTimestamp(Timestamp x) 将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。
void | writeURL(URL url) 将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SQLOutputImpl

public SQLOutputImpl(Vector<?> attributes,
                     Map<String,?> map)
              throws SQLException
创建一个新的 SQLOutputImpl 对象，并使用给定的属性向量和类型映射表进行初始化。驱动程序将使用类型映射表来确定要调用的 SQLData.writeSQL 方法。然后，此方法将调用适当的 SQLOutputImpl 写入方法，以便能够将属性写入新输出流。

参数：
attributes - Vector 对象，该对象包含要映射为 Java 编程语言中一个或多个对象的 UDT 属性
map - 包含零个或多个条目的 java.util.Map 对象，其中每个条目包含：1) 给出 UDT 完全限定名的 String 2) 用于定义 UDT 映射方式的 SQLData 实现的 Class 对象
抛出：
SQLException - 如果 attributes 或 map 的值为 null
方法详细信息

writeString

public void writeString(String x)
                 throws SQLException
将 Java 编程语言中的 String 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL CHAR、VARCHAR 或 LONGVARCHAR。

指定者：
接口 SQLOutput 中的 writeString
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeBoolean

public void writeBoolean(boolean x)
                  throws SQLException
将 Java 编程语言中的 boolean 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL BIT。

指定者：
接口 SQLOutput 中的 writeBoolean
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeByte

public void writeByte(byte x)
               throws SQLException
将 Java 编程语言中的 byte 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL BIT。

指定者：
接口 SQLOutput 中的 writeByte
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeShort

public void writeShort(short x)
                throws SQLException
将 Java 编程语言中的 short 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL SMALLINT。

指定者：
接口 SQLOutput 中的 writeShort
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeInt

public void writeInt(int x)
              throws SQLException
将 Java 编程语言中的 int 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL INTEGER。

指定者：
接口 SQLOutput 中的 writeInt
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeLong

public void writeLong(long x)
               throws SQLException
将 Java 编程语言中的 long 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL BIGINT。

指定者：
接口 SQLOutput 中的 writeLong
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeFloat

public void writeFloat(float x)
                throws SQLException
将 Java 编程语言中的 float 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL REAL。

指定者：
接口 SQLOutput 中的 writeFloat
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeDouble

public void writeDouble(double x)
                 throws SQLException
将 Java 编程语言中的 double 写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL DOUBLE。

指定者：
接口 SQLOutput 中的 writeDouble
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeBigDecimal

public void writeBigDecimal(BigDecimal x)
                     throws SQLException
将 Java 编程语言中的 java.math.BigDecimal 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL NUMERIC。

指定者：
接口 SQLOutput 中的 writeBigDecimal
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeBytes

public void writeBytes(byte[] x)
                throws SQLException
将 Java 编程语言中的 byte 数组写入此 SQLOutputImpl 对象。在此值返回数据库之前，驱动程序首先将它转换为 SQL VARBINARY 或 LONGVARBINARY。

指定者：
接口 SQLOutput 中的 writeBytes
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeDate

public void writeDate(Date x)
               throws SQLException
将 Java 编程语言中的 java.sql.Date 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL DATE。

指定者：
接口 SQLOutput 中的 writeDate
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeTime

public void writeTime(Time x)
               throws SQLException
将 Java 编程语言中的 java.sql.Time 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL TIME。

指定者：
接口 SQLOutput 中的 writeTime
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeTimestamp

public void writeTimestamp(Timestamp x)
                    throws SQLException
将 Java 编程语言中的 java.sql.Timestamp 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为 SQL TIMESTAMP。

指定者：
接口 SQLOutput 中的 writeTimestamp
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeCharacterStream

public void writeCharacterStream(Reader x)
                          throws SQLException
将 Unicode 字符流写入此 SQLOutputImpl 对象。驱动程序将执行从 Unicode 到数据库 CHAR 格式的任何必要转换。

指定者：
接口 SQLOutput 中的 writeCharacterStream
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeAsciiStream

public void writeAsciiStream(InputStream x)
                      throws SQLException
将 ASCII 字符流写入此 SQLOutputImpl 对象。驱动程序将执行从 ASCII 到数据库 CHAR 格式的任何必要转换。

指定者：
接口 SQLOutput 中的 writeAsciiStream
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeBinaryStream

public void writeBinaryStream(InputStream x)
                       throws SQLException
将未解释字节流写入此 SQLOutputImpl 对象。

指定者：
接口 SQLOutput 中的 writeBinaryStream
参数：
x - 要传递到数据库的值
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeObject

public void writeObject(SQLData x)
                 throws SQLException
将包含在给定 SQLData 对象中的数据写入流中。当 SQLData 对象为 null 时，此方法将 SQL NULL 写入流中。否则，它将调用给定对象的 SQLData.writeSQL 方法，该方法将对象的属性写入流中。

SQLData.writeSQ 方法的实现调用适当的 SQLOutputImpl.writeXXX 方法，依次写入对象的每个属性。从 SQLInput 输入流读取属性和将属性写入 SQLOutputImpl 输出流都必须按照在用户定义类型的 SQL 定义中将它们列出的顺序进行。

指定者：
接口 SQLOutput 中的 writeObject
参数：
x - 表示 SQL 结构或 distinct 类型的数据的对象
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeRef

public void writeRef(Ref x)
              throws SQLException
将 Java 编程语言中的 Ref 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为可序列化的 SerialRef SQL REF 值。

指定者：
接口 SQLOutput 中的 writeRef
参数：
x - 表示 SQL REF 值的对象
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeBlob

public void writeBlob(Blob x)
               throws SQLException
将 Java 编程语言中的 Blob 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为可序列化的 SerialBlob SQL BLOB 值。

指定者：
接口 SQLOutput 中的 writeBlob
参数：
x - 表示 SQL BLOB 值的对象
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeClob

public void writeClob(Clob x)
               throws SQLException
将 Java 编程语言中的 Clob 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为可序列化的 SerialClob SQL CLOB 值。

指定者：
接口 SQLOutput 中的 writeClob
参数：
x - 表示 SQL CLOB 值的对象
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeStruct

public void writeStruct(Struct x)
                 throws SQLException
将 Java 编程语言中的 Struct 对象写入此 SQLOutputImpl 对象。在此值返回到数据库前，驱动程序将它转换成 SQL 结构类型值。

在将 SQL 结构类型被映射为 Java 编程语言中的 Struct 对象（标准映射）时，应该使用此方法。如果将 SQL 结构类型自定义映射为 Java 编程语言中的类，则应该使用 writeObject 方法。

指定者：
接口 SQLOutput 中的 writeStruct
参数：
x - 表示 SQL 结构类型的属性的对象
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeArray

public void writeArray(Array x)
                throws SQLException
将 Java 编程语言中的 Array 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为可序列化的 SerialArray SQL ARRAY 值。

指定者：
接口 SQLOutput 中的 writeArray
参数：
x - 表示 SQL ARRAY 值的对象
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeURL

public void writeURL(URL url)
              throws SQLException
将 Java 编程语言中的 java.sql.Type.DATALINK 对象写入此 SQLOutputImpl 对象。在此值返回到数据库之前，驱动程序首先将它转换为可序列化的 SerialDatalink SQL DATALINK 值。

指定者：
接口 SQLOutput 中的 writeURL
参数：
url - 表示 SQL DATALINK 值的对象
抛出：
SQLException - 如果尝试将 UDT 的属性值写入数据库的 SQLData 对象正在使用 SQLOutputImpl 对象。

writeNString

public void writeNString(String x)
                  throws SQLException
将下一个属性以 Java 编程语言中 String 的形式写入流中。在将此属性发送到流中时，驱动程序将其转换为 SQL NCHAR、NVARCHAR 或 LONGNVARCHAR 值（具体取决于该参数相对于驱动程序在 NVARCHAR 值上的限制的大小）。

指定者：
接口 SQLOutput 中的 writeNString
参数：
x - 传递给数据库的值
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

writeNClob

public void writeNClob(NClob x)
                throws SQLException
将 SQL NCLOB 值写入流中。

指定者：
接口 SQLOutput 中的 writeNClob
参数：
x - 表示 SQL NCLOB 值的数据的 NClob 对象
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

writeRowId

public void writeRowId(RowId x)
                throws SQLException
将 SQL ROWID 值写入流中。

指定者：
接口 SQLOutput 中的 writeRowId
参数：
x - 表示 SQL ROWID 值的数据的 RowId 对象
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6

writeSQLXML

public void writeSQLXML(SQLXML x)
                 throws SQLException
将 SQL XML 值写入流中。

指定者：
接口 SQLOutput 中的 writeSQLXML
参数：
x - 表示 SQL XML 值的数据的 SQLXML 对象
抛出：
SQLException - 如果发生数据库访问错误
从以下版本开始：
1.6
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sql.rowset.serial (Java 2 Platform SE 6)

 javax.sql.rowset.serial
类
SerialArray
SerialBlob
SerialClob
SerialDatalink
SerialJavaObject
SerialRef
SerialStruct
SQLInputImpl
SQLOutputImpl
异常
SerialException


javax.sql.rowset.serial (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sql.rowset.serial

提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

请参见：
描述

类摘要
SerialArray | 序列化的 Array 对象，它是 SQL ARRAY 值在 Java 编程语言中的映射关系。
SerialBlob | SQL BLOB 值在 Java 编程语言中的序列化映射关系。
SerialClob | SQL CLOB 值在 Java 编程语言中的序列化映射关系。
SerialDatalink | SQL DATALINK 值在 Java 编程语言中的序列化映射关系。
SerialJavaObject | SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。
SerialRef | Ref 对象的序列化映射关系，它是 SQL REF 值在 Java 编码语言中的映射关系。
SerialStruct | SQL 结构类型在 Java 编程语言中的序列化映射关系。
SQLInputImpl | 用于自定义映射用户定义类型 (UDT) 的输入流。
SQLOutputImpl | 用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。

异常摘要
SerialException 指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

软件包 javax.sql.rowset.serial 的描述

提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

标准的 JDBC RowSet 实现可以使用这些实用工具类协助序列化非连接 RowSet 对象。这一点有助于将非连接 RowSet 对象通过导线传输到另一个 VM 或者在应用程序中跨层传输。

1.0 SerialArray

SQL ARRAY 值在 Java 编程语言中的可序列化映射关系。

SerialArray 类提供一个根据 Array 对象创建 SerialArray 实例的构造方法，提供获取基本类型及其 SQL 名称的各种方法，以及复制全部或部分 SerialArray 对象的各种方法。

2.0 SerialBlob

SQL BLOB 值在 Java 编程语言中的可序列化映射关系。

SerialBlob 类提供一个根据 Blob 对象创建实例的构造方法。注意，在根据 Blob 对象构造 SerialBlob 对象之前，Blob 对象应该已经将 SQL BLOB 值的数据置于客户端上。SQL BLOB 值的数据可以在客户端上以字节数组（使用 Blob.getBytes 方法）或未解释字节流的形式（使用 Blob.getBinaryStream 方法）实现。

SerialBlob 方法能够以字节数组或流的形式复制 SerialBlob 对象。这些方法还可以在 SerialBlob 对象中查找给定模式的字节或 Blob 对象。

3.0 SerialClob

SQL CLOB 值在 Java 编程语言中的可序列化映射关系。

SerialClob 类提供一个根据 Clob 对象创建实例的构造方法。注意，在根据 Clob 对象构造 SerialClob 对象之前，Clob 对象应该已经将 SQL CLOB 值的数据置于客户端上。SQL CLOB 值的数据可以在客户端上以 Unicode 字符流的形式实现。

SerialClob 方法可以从 SerialClob 对象获取子字符串或者查找某种模式的字符的开头。

5.0 SerialDatalink

SQL DATALINK 值在 Java 编程语言中的可序列化映射关系。DATALINK 值引用原始数据源管理的底层数据源之外的文件。

RowSet 实现可以使用 RowSet.getURL() 方法来获取 java.net.URL 对象，该对象可用于操作外部数据。

    java.net.URL url = rowset.getURL(1);

6.0 SerialJavaObject

SQL JAVA_OBJECT 值在 Java 编程语言中的可序列化映射关系。假定 Java 对象实例实现 Serializable 接口，则此类仅包装序列化进程。

但是如果序列化不能进行（即 Java 对象不是立即可序列化的），则此类将尝试序列化所有非静态成员，以允许序列化对象实例状态。静态或瞬态字段不可序列化，尝试执行此操作将导致抛出 SerialException。

7.0 SerialRef

SQL REF 类型与 Java 编程语言之间的可序列化映射关系。

SerialRef 类提供一个根据 Ref 类型创建 SerialRef 实例的构造方法，并且提供用于获取和设置 Ref 对象类型的各种方法。

8.0 SerialStruct

SQL 结构类型在 Java 编程语言中的可序列化映射关系。每个不可序列化的属性将被映射为可序列化形式；如果属性本身是结构类型，则其每个不可序列化的属性将被映射为可序列化形式。

此外，如果将 Map 对象传递给其中一个构造方法或 getAttributes 方法，则根据在 Map 对象中指定的映射关系对结构类型进行自定义映射。
SerialStruct 类提供一个根据 Struct 对象创建实例的构造方法，提供一个用于在数据库中获取 SQL 结构类型的 SQL 类型名称的方法，以及用于获取其属性值的各种方法。

9.0 SQLInputImpl

用于自定义映射用户定义类型 (UDT) 的输入流。SQLInputImpl 对象是一个包含值流的输入流，这些值是 UDT 的属性。在对具有自定义映射关系的 SQL 结构类型或 distinct 类型调用 getObject 方法时，驱动程序在后台使用此类；程序员决不能直接调用 SQLInputImpl 方法。

SQLInputImpl 类提供一组类似于 ResultSet 获取方法的读取方法。这些方法可以在 SQLInputImpl 对象中读取值。方法 wasNull 用于确定读取的最后一个值是否是 SQL NULL。

在调用带有 Map 对象的构造方法或获取方法时，JDBC 驱动程序调用 SQLData.getSQLType 方法来确定将自定义映射的 UDT SQL 类型。驱动程序创建一个 SQLInputImpl 实例，并用 UDT 的属性填充它。然后，驱动程序将输入流传递给 SQLData.readSQL 方法，该方法依次调用 SQLInputImpl 方法从输入流读取属性。

10.0 SQLOutputImpl

用于将自定义映射的用户定义类型 (UDT) 的属性写回数据库的输出流。驱动程序在内部使用此接口，应用程序员决不能直接调用其方法。

当应用程序调用 PreparedStatement.setObject 方法时，驱动程序将检查要写入的值是否是具有自定义映射关系的 UDT。如果是，则在类型映射中将存在一个条目，该条目包含 Class 对象，用于为此 UDT 实现 SQLData 的类。如果要写入的值是 SQLData 的实例，则驱动程序将创建 SQLOutputImpl 的实例并将其传递给 SQLData.writeSQL 方法。writeSQL 方法依次调用适当的 SQLOutputImpl 写入方法，从 SQLData 对象以 SQL 用户定义类型的表示形式将数据写入 SQLOutputImpl 输出流。

自定义映射关系

JDBC API 提供用于将 SQL 结构类型或 DISTINCT 类型映射为 Java 编程语言的机制。通常，结构类型被映射为类，其属性被映射为类中的字段。（DISTINCT 类型可视为具有一个属性。）但是，也存在其他可能性和多种不同的映射关系。

程序员通过实现 SQLData 接口定义映射关系。例如，如果名为 AUTHORS 的 SQL 结构类型具有属性 NAME、TITLE 和 PUBLISHER，则其可以被映射为名为 Authors 的 Java 类。Authors 类可以具有字段 name、title 和 publisher，AUTHORS 的属性将被映射到这些字段。在这种情况下，SQLData 的实现可能如下所示：

   public class Authors implements SQLData {
       public String name;
       public String title;
       public String publisher;

       private String sql_type;
       public String getSQLTypeName() {
           return sql_type;
       }

       public void readSQL(SQLInput stream, String type)
                                  throws SQLException  {
           sql_type = type;
           name = stream.readString();
title = stream.readString();
           publisher = stream.readString();
       }

       public void writeSQL(SQLOutput stream) throws SQLException {
           stream.writeString(name);
           stream.writeString(title);
           stream.writeString(publisher);
       }
   }
java.util.Map 对象用于将 SQL 结构类型与其到 Authors 类的映射关系相关联。以下代码片段展示了一种创建 Map 对象并为其提供一个关联 AUTHORS 和 Authors 的条目的方式。
    java.util.Map map = new java.util.HashMap();
    map.put("SCHEMA_NAME.AUTHORS", Class.forName("Authors");
Map 对象 map 现在包含一个具有 SQL 结构类型的完全限定名的条目和 Authors 类的 Class 对象。可以将其传递给某个方法，以告知驱动程序将 AUTHORS 映射到 Authors 的方式。

对于未连接 RowSet 对象，仅在将 Map 对象传递给将执行自定义映射的方法或构造方法时，才可以完成自定义映射。对于连接 RowSet 对象，情况则不同，因为它们维持着与数据源的连接。执行自定义映射并由未连接 RowSet 对象调用的方法可能使用与正在使用的 Connection 对象关联的 Map 对象。因此，换句话说，如果没有指定任何映射，则默认情况下可以使用连接的类型映射。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.sql.rowset.serial 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql.rowset.serial 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.sql.rowset.serial.SerialArray (implements java.sql.Array, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialBlob (implements java.sql.Blob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialClob (implements java.sql.Clob, java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialDatalink (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialJavaObject (implements java.lang.Cloneable, java.io.Serializable)
    • javax.sql.rowset.serial.SerialRef (implements java.lang.Cloneable, java.sql.Ref, java.io.Serializable)
    • javax.sql.rowset.serial.SerialStruct (implements java.lang.Cloneable, java.io.Serializable, java.sql.Struct)
    • javax.sql.rowset.serial.SQLInputImpl (implements java.sql.SQLInput)
    • javax.sql.rowset.serial.SQLOutputImpl (implements java.sql.SQLOutput)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • javax.sql.rowset.serial.SerialException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sql.rowset.serial 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql.rowset.serial
的使用

使用 javax.sql.rowset.serial 的软件包
javax.sql.rowset.serial 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

javax.sql.rowset.serial 使用的 javax.sql.rowset.serial 中的类
SerialException
指示对 SQL 类型 BLOB、CLOB、STRUCT 或 ARRAY 以及 SQL 类型 DATALINK 和 JAVAOBJECT 进行序列化或反序列化时发生的错误。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SQLInputImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SQLInputImpl
的使用

没有 javax.sql.rowset.serial.SQLInputImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SQLOutputImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SQLOutputImpl
的使用

没有 javax.sql.rowset.serial.SQLOutputImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialArray 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialArray
的使用

没有 javax.sql.rowset.serial.SerialArray 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialBlob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialBlob
的使用

没有 javax.sql.rowset.serial.SerialBlob 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialClob 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialClob
的使用

没有 javax.sql.rowset.serial.SerialClob 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialDatalink 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialDatalink
的使用

没有 javax.sql.rowset.serial.SerialDatalink 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialException
的使用

使用 SerialException 的软件包
javax.sql.rowset.serial 提供实用工具类，允许 SQL 类型与 Java 编程语言数据类型之间的可序列化映射关系。

javax.sql.rowset.serial 中 SerialException 的使用

抛出 SerialException 的 javax.sql.rowset.serial 中的方法
Object | SerialArray.getArray() 返回一个新数组，它是此 SerialArray 对象的副本。
Object | SerialArray.getArray(long index, int count) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(long index, int count, Map<String,Class<?>> map) 返回一个新数组，它是部分此 SerialArray 对象的副本，从给定索引处的元素开始，包含给定的连续元素数。
Object | SerialArray.getArray(Map<String,Class<?>> map) 返回一个新数组，它是此 SerialArray 对象的副本，当元素为 SQL UDT 时对每个自定义映射关系的元素使用给定类型映射表。
InputStream | SerialClob.getAsciiStream() 以 ascii 流的形式获取此 SerialClob 对象指定的 CLOB 值。
Object[] | SerialStruct.getAttributes() 获取 Object 值的数组，该数组包含此 SerialStruct 对象所表示的 SQL 结构类型的属性。
Object[] | SerialStruct.getAttributes(Map<String,Class<?>> map) 获取此 SerialStruct 表示为 Object 值数组的 SQL 结构类型的属性；如果适用，则使用给定的类型映射表进行自定义映射。
int | SerialArray.getBaseType() 获取此 SerialArray 对象中 SQL 类型的元素。
String | SerialArray.getBaseTypeName() 获取此 SerialArray 对象元素特定于 DBMS 的类型名称。
String | SerialRef.getBaseTypeName() 返回描述 Ref 的基本类型名称的字符串。
InputStream | SerialBlob.getBinaryStream() 以输入流的形式返回此 SerialBlob 对象。
byte[] | SerialBlob.getBytes(long pos, int length) 将指定的字节数（从给定位置开始）从此 SerialBlob 对象复制到另一个字节数组。
Reader | SerialClob.getCharacterStream() 以 Unicode 字符流的形式返回此 SerialClob 对象的数据。
URL | SerialDatalink.getDatalink() 返回一个新 URL，它是此 SerialDatalink 对象的副本。
Field[] | SerialJavaObject.getFields() 返回 Field 对象数组，该对象包含此帮助器类将序列化的对象的每个字段。
Object | SerialJavaObject.getObject() 返回一个 Object，它是此 SerialJavaObject 对象的副本。
Object | SerialRef.getObject() 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
Object | SerialRef.getObject(Map<String,Class<?>> map) 返回表示此 SerialRef 对象引用的 SQL 结构类型的 Object。
ResultSet | SerialArray.getResultSet() 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 ARRAY 值中的元素。
ResultSet | SerialArray.getResultSet(long index, int count) 获取保存子数组元素的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(long index, int count, Map<String,Class<?>> map) 获取包含此 SerialArray 对象中元素的子数组的 ResultSet 对象，该子数组从 index 索引处开始，包含 count 个连续元素。
ResultSet | SerialArray.getResultSet(Map<String,Class<?>> map) 获取 ResultSet 对象，该对象包含由此 SerialArray 对象所表示的所有 SQL ARRAY 值的元素。
String | SerialStruct.getSQLTypeName() 获取此 SerialStruct 对象的 SQL 类型名称。
String | SerialClob.getSubString(long pos, int length) 返回包含在此 SerialClob 对象中的子字符串的副本，从给定位置开始，后跟指定字符数。
long | SerialBlob.length() 获取此 SerialBlob 对象字节数组中的字节数。
long | SerialClob.length() 获取此 SerialClob 对象字节数组中的字节数。
long | SerialBlob.position(Blob pattern, long start) 返回此 SerialBlob 对象中给定 Blob 对象开始的位置，搜索从指定位置开始。
long | SerialBlob.position(byte[] pattern, long start) 返回在此 SerialBlob 对象中给定模式的字节开始的位置，搜索从指定的位置开始。
long | SerialClob.position(Clob searchStr, long start) 返回此 SerialClob 对象中给定 Clob 签名开始的位置，搜索从指定位置开始。
long | SerialClob.position(String searchStr, long start) 返回此 SerialClob 对象中给定 String 对象开始的位置，搜索从指定位置开始。
OutputStream | SerialClob.setAsciiStream(long pos) 获取用于将 Ascii 字符写入此 SerialClob 对象所表示的 Clob 值的流，从位置 pos 处开始。
OutputStream | SerialBlob.setBinaryStream(long pos) 获取用于写入此 Blob 对象所表示的 BLOB 值的流。
int | SerialBlob.setBytes(long pos, byte[] bytes) 将给定字节数组写入此 Blob 对象表示的 BLOB 值（从位置 pos 处开始），并返回写入的字节数。
int | SerialBlob.setBytes(long pos, byte[] bytes, int offset, int length) 将所有或部分给定的 byte 数组写入此 Blob 对象表示的 BLOB 值中，并返回写入的字节数。
Writer | SerialClob.setCharacterStream(long pos) 获取用于将 Unicode 字符流写入此 SerialClob 对象所表示的 CLOB 值（位置 pos 处）的流。
void | SerialRef.setObject(Object obj) 将此 SerialRef 对象引用的 SQL 结构类型设置为给定的 Object 对象。
int | SerialClob.setString(long pos, String str) 在位置 pos 处将给定 Java String 写入此 SerialClob 对象表示的 CLOB 值中。
int | SerialClob.setString(long pos, String str, int offset, int length) 将 str 的 len 个字符写入此 Clob 表示的 CLOB 值中，从字符 offset 开始。
void | SerialBlob.truncate(long length) 截取此 Blob 对象表示的 BLOB 值，使其长度为 len 个字节。
void | SerialClob.truncate(long length) 截取此 SerialClob 对象所表示的 CLOB 值，使其长度为 len 个字符。

抛出 SerialException 的 javax.sql.rowset.serial 中的构造方法
SerialArray(Array array)
根据给定 Array 对象构造新的 SerialArray 对象。
SerialArray(Array array, Map<String,Class<?>> map)
根据给定 Array 对象构造新的 SerialArray 对象，当数组元素是 SQL UDT 时对每个元素的自定义映射关系使用给定的类型映射表。
SerialBlob(Blob blob)
根据给定 Blob 对象的序列化形式构造一个 SerialBlob 对象。
SerialBlob(byte[] b)
按照给定 byte 数组的序列化形式构造一个 SerialBlob 对象。
SerialClob(char[] ch)
按照给定 char 数组的序列化形式构造一个 SerialClob 对象。
SerialClob(Clob clob)
按照给定 Clob 对象的序列化形式构造一个 SerialClob 对象。
SerialDatalink(URL url)
根据给定的 java.net.URL 对象构造新的 SerialDatalink 对象。
SerialJavaObject(Object obj)
SerialJavaObject 帮助器类的构造方法。
SerialRef(Ref ref)
根据给定 Ref 对象构造 SerialRef 对象。
SerialStruct(SQLData in, Map<String,Class<?>> map)
根据给定 SQLData 对象构造 SerialStruct 对象，使用给定类型映射表将其自定义映射为 Java 编程语言中的类。
SerialStruct(Struct in, Map<String,Class<?>> map)
根据给定 Struct 对象构造 SerialStruct 对象，使用给定 java.util.Map 对象来自定义映射 SQL 结构类型或其任何为 SQL 结构类型的属性。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialJavaObject 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialJavaObject
的使用

没有 javax.sql.rowset.serial.SerialJavaObject 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialRef 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialRef
的使用

没有 javax.sql.rowset.serial.SerialRef 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.serial.SerialStruct 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.serial.SerialStruct
的使用

没有 javax.sql.rowset.serial.SerialStruct 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


SyncFactory (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
类 SyncFactory

java.lang.Object
    继承者  javax.sql.rowset.spi.SyncFactory

public class SyncFactory
extends Object

该服务提供者接口 (SPI) 机制可以生成由非连接 RowSet 对象使用的 SyncProvider 实例。SyncProvider 实例依次提供 javax.sql.RowSetReader 对象和 javax.sql.RowSetWriter 对象，RowSet 对象需要前者来使用数据填充本身，需要后者来将对其数据的更改传播回底层数据源。

因为 SyncFactory 类中的方法都是静态的，所以每个 Java VM 在任意一个时刻内仅有一个 SyncFactory 对象。这能确保存在一个 RowSet 实现可以从中获取其 SyncProvider 实现的单一源。

1.0 概述

SyncFactory 类提供可用同步提供者实现（SyncProvider 对象）的内部注册表。可以查询此注册表以确定可用的同步提供者。以下的代码行可以获取当前注册的提供者所组成的枚举。
     java.util.Enumeration e = SyncFactory.getRegisteredProviders();
所有的标准 RowSet 实现必须至少提供两个提供者：
  • 乐观提供者，它与 CachedRowSet 实现或从该实现派生的实现一起使用。
  • XML 提供者，它用于读取和写入 XML（比如与 WebRowSet 对象一起使用时）。
注意，JDBC RowSet 实现包括满足此要求的 SyncProvider 实现 RIOptimisticProvider 和 RIXmlProvider。

SyncFactory 类提供了一些访问器方法，用来帮助应用程序确定当前向 SyncFactory 注册的同步提供者。

其他方法让 RowSet 持久提供者向工厂机制注册或注销。这允许其他同步提供者实现在运行时可用于 RowSet 对象。

应用程序可以应用一定程度的过滤，以确定 SyncProvider 实现提供的同步级别。以下标准确定提供者是否可用于 RowSet 对象：

  1. 如果 RowSet 对象指定了特定的提供者，并且 SyncFactory 不包含对此提供者的引用，则抛出 SyncFactoryException，声明不能找到同步提供者。

  2. 如果使用指定的提供者实例化 RowSet 实现，并且适当地注册了指定的提供者，则提供请求的提供者。否则，将抛出 SyncFactoryException。

  3. 如果 RowSet 对象未指定 SyncProvider 实现，并且没有其他可用的 SyncProvider 实现，则提供参考实现提供者。

2.0 注册 SyncProvider 实现

供应商和开发人员都可以使用以下机制之一注册 SyncProvider 实现。

  • 使用命令行
    在命令行中提供提供者的名称，这会将提供者添加到系统属性中。例如：

    -Drowset.provider.classname=com.fred.providers.HighAvailabilityProvider
  • 使用标准属性文件
    参考实现的目标是随 J2SE 1.5 一起发行，这将包含一个可以手工编辑的附加资源文件。下面是参考实现中包含的属性文件示例：
       #Default JDBC RowSet sync providers listing
   #

   # Optimistic synchronization provider
   rowset.provider.classname.0=com.sun.rowset.providers.RIOptimisticProvider
   rowset.provider.vendor.0=Sun Microsystems Inc
   rowset.provider.version.0=1.0

   # XML Provider using standard XML schema
   rowset.provider.classname.1=com.sun.rowset.providers.RIXMLProvider
   rowset.provider.vendor.1=Sun Microsystems Inc.
   rowset.provider.version.1=1.0
    SyncFactory 检查此文件，并注册它包含的 SyncProvider 实现。开发人员或供应商可以将其他实现添加到此文件。例如，可能添加以下内容：
         rowset.provider.classname.2=com.fred.providers.HighAvailabilityProvider
     rowset.provider.vendor.2=Fred, Inc.
     rowset.provider.version.2=1.0

  • 使用 JNDI 上下文
    在 JNDI 上下文中可以注册可用的提供者，SyncFactory 将尝试从该 JNDI 上下文加载 SyncProvider 实现。例如，以下代码片段将在 JNDI 上下文中注册提供者实现。这是部署者通常都要执行的命令。在此示例中，MyProvider 在 CosNaming 名称空间（它是 J2EE 资源使用的名称空间）上注册。
        import javax.naming.*;

    Hashtable svrEnv = new  Hashtable();
    srvEnv.put(Context.INITIAL_CONTEXT_FACTORY, "CosNaming");

    Context ctx = new InitialContext(svrEnv);
    com.fred.providers.MyProvider = new MyProvider();
    ctx.rebind("providers/MyProvider", syncProvider);
接下来，应用程序将向 SyncFactory 实例注册 JNDI 上下文。这允许 SyncFactory 在 JNDI 上下文中进行浏览，以查找 SyncProvider 实现。
    Hashtable appEnv = new Hashtable();
    appEnv.put(Context.INITIAL_CONTEXT_FACTORY, "CosNaming");
    appEnv.put(Context.PROVIDER_URL, "iiop://hostname/providers");
    Context ctx = new InitialContext(appEnv);

    SyncFactory.registerJNDIContext(ctx);
如果 RowSet 对象试图获得 MyProvider 对象，则 SyncFactory 将尝试查找它。首先，在系统属性中进行搜索，然后在资源文件中查找，最后检查已设置的 JNDI 上下文。SyncFactory 实例验证请求的提供者是否为 SyncProvider 抽象类的有效扩展，然后将它提供给 RowSet 对象。在以下代码片段中，使用 env 创建并初始化一个新的 CachedRowSet 对象，该对象包含对 MyProvider 的绑定。
    Hashtable env = new Hashtable();
    env.put(SyncFactory.ROWSET_SYNC_PROVIDER, "com.fred.providers.MyProvider");
    CachedRowSet crs = new com.sun.rowset.CachedRowSetImpl(env);
javax.sql.rowset.spi 包规范中提供了关于这些机制的更多详细信息。

另请参见：
SyncProvider, SyncFactoryException

字段摘要
static String | ROWSET_SYNC_PROVIDER 用于同步提供者实现名称的标准属性 id。
static String | ROWSET_SYNC_PROVIDER_VERSION 用于同步提供者实现版本标记的标准属性 id。
static String | ROWSET_SYNC_VENDOR 用于同步提供者实现供应商名称的标准属性 id。
方法摘要
static SyncProvider | getInstance(String providerID) 返回 providerID 标识的 SyncProvider 实例。
static Logger | getLogger() 返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。
static Enumeration<SyncProvider> | getRegisteredProviders() 返回当前已注册的同步提供者所组成的枚举。
static SyncFactory | getSyncFactory() 返回一个 SyncFactory。
static void | registerProvider(String providerID) 将给定的同步提供者添加到工厂注册器。
static void | setJNDIContext(Context ctx) 设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现
static void | setLogger(Logger logger) 设置 SyncFactory 提供的 SyncProvider 实现所使用的日志对象。
static void | setLogger(Logger logger, Level level) 设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。
static void | unregisterProvider(String providerID) 从工厂 SPI 注册器移除指派的当前已注册同步提供者。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

ROWSET_SYNC_PROVIDER

public static String ROWSET_SYNC_PROVIDER
用于同步提供者实现名称的标准属性 id。

ROWSET_SYNC_VENDOR

public static String ROWSET_SYNC_VENDOR
用于同步提供者实现供应商名称的标准属性 id。

ROWSET_SYNC_PROVIDER_VERSION

public static String ROWSET_SYNC_PROVIDER_VERSION
用于同步提供者实现版本标记的标准属性 id。

方法详细信息

registerProvider

public static void registerProvider(String providerID)
                             throws SyncFactoryException
将给定的同步提供者添加到工厂注册器。在 SyncProvider 规范中为 SyncProvider 实现所需的命名约定提供了指导方针。

通过将 SyncProvider 实例绑定到 JNDI 名称空间可以注册绑定到 JNDI 上下文的同步提供者。

     SyncProvider p = new MySyncProvider();
 InitialContext ic = new InitialContext();
 ic.bind ("jdbc/rowset/MySyncProvider", p);
另外，应通过 SyncFactory 使用 setJNDIContext 方法设置初始 JNDI 上下文。SyncFactory 利用此上下文搜索绑定到 JNDI 上下文及其子节点的可用 SyncProvider 对象。

参数：
providerID - 一个 String 对象，具有注册的同步提供者的唯一 ID
抛出：
SyncFactoryException - 如果进行尝试提供空的或 null 提供者名称
另请参见：
setJNDIContext(javax.naming.Context)

getSyncFactory

public static SyncFactory getSyncFactory()
返回一个 SyncFactory。

返回：
SyncFactory 实例

unregisterProvider

public static void unregisterProvider(String providerID)
                               throws SyncFactoryException
从工厂 SPI 注册器移除指派的当前已注册同步提供者。

参数：
providerID - 同步提供者的唯一 id
抛出：
SyncFactoryException - 如果尝试注销未注册的 SyncProvider 实现。

getInstance

public static SyncProvider getInstance(String providerID)
                                throws SyncFactoryException
返回 providerID 标识的 SyncProvider 实例。

参数：
providerID - 提供者的唯一标识符
返回：
SyncProvider 实现
抛出：
SyncFactoryException - 如果无法找到 SyncProvider，或者尝试调用此提供者时遇到某种错误。

getRegisteredProviders

public static Enumeration<SyncProvider> getRegisteredProviders()
                                                        throws SyncFactoryException
返回当前已注册的同步提供者所组成的枚举。RowSet 实现可以将枚举中的任何提供者用作其 SyncProvider 对象。

至少应该可以使用允许用 JDBC 驱动程序存储 RowSet 内容数据的那个同步提供者。

返回：
Enumeration 向此工厂注册的可用同步提供者所组成的枚举
抛出：
SyncFactoryException

setLogger

public static void setLogger(Logger logger)
设置 SyncFactory 提供的 SyncProvider 实现所使用的日志对象。所有 SyncProvider 实现可以将其事件记录到此对象，应用程序可以使用 getLogger 方法获取此对象的句柄。

参数：
logger - Logger 对象实例

setLogger

public static void setLogger(Logger logger,
                             Level level)
设置 SyncFactory SPI 提供的 SyncProvider 实现所使用的日志对象。所有 SyncProvider 实现可以将其事件记录到此对象，应用程序可以使用 getLogger 方法获取此对象的句柄。

参数：
logger - Logger 对象实例
level - 指示所需日志等级的 Level 对象实例

getLogger

public static Logger getLogger()
                        throws SyncFactoryException
返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。

抛出：
SyncFactoryException - 如果未设置任何日志对象。

setJNDIContext

public static void setJNDIContext(Context ctx)
                           throws SyncFactoryException
设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现

参数：
ctx - 有效的 JNDI 上下文
抛出：
SyncFactoryException - 如果提供的 NDI 上下文为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


SyncFactoryException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
类 SyncFactoryException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  javax.sql.rowset.spi.SyncFactoryException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SyncFactoryException
extends SQLException

指示 SyncFactory 机制发生的错误。在没有成功实例化 SyncProvider 的情况下，无法使用非连接 RowSet 实现。

另请参见：
SyncFactory, SyncFactoryException, 序列化表格

构造方法摘要
SyncFactoryException()
创建不带详细消息的新 SyncFactoryException。
SyncFactoryException(String msg)
构造带指定详细消息的 SyncFactoryException。
方法摘要
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SyncFactoryException

public SyncFactoryException()
创建不带详细消息的新 SyncFactoryException。

SyncFactoryException

public SyncFactoryException(String msg)
构造带指定详细消息的 SyncFactoryException。

参数：
msg - 详细消息。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SyncProvider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
类 SyncProvider

java.lang.Object
    继承者  javax.sql.rowset.spi.SyncProvider

public abstract class SyncProvider
extends Object

为非连接 RowSet 对象提供 reader/writer 功能的同步机制。SyncProvider 实现是一个扩展了 SyncProvider 抽象类的类。

SyncProvider 实现由一个唯一 ID 标识，该 ID 即其完全限定类名称。此名称必须向 SyncFactory SPI 注册，这样才能使该实现可用于所有的 RowSet 实现。参考实现中的工厂机制使用此名称来实例化该实现，然后该实现可以通过其 reader（javax.sql.RowSetReader 对象）和 writer（javax.sql.RowSetWriter 对象）提供一个 RowSet 对象。

Jdbc RowSet 实现规范提供 SyncProvider 抽象类的两个参考实现：RIOptimisticProvider 和 RIXMLProvider。RIOptimisticProvider 可以使用 RowSetReader 对象和 RowSetWriter 对象设置任何 RowSet 实现。但是，只有 RIXMLProvider 实现可以设置 XmlReader 对象和 XmlWriter 对象。WebRowSet 对象使用 XmlReader 对象以 XML 格式读取数据，然后使用该数据填充本身。它使用 XmlWriter 对象以 XML 格式将本身写入到流或 java.io.Writer 对象。

1.0 实现的命名约定

作为命名 SyncProvider 实现的指南，应注意以下事项：
  • SyncProvider 实现的名称是其完全限定类名称。
  • 建议供应商在名为 providers 的包中提供 SyncProvider 实现。

例如，如果名为 Fred, Inc. 的供应商提供了 SyncProvider 实现，则可能拥有以下内容：

     Vendor name:  Fred, Inc.
     Domain name of vendor:  com.fred
     Package name:  com.fred.providers
     SyncProvider implementation class name:  HighAvailabilityProvider

     Fully qualified class name of SyncProvider implementation:
                        com.fred.providers.HighAvailabilityProvider

以下代码行使用完全限定名称向 SyncFactory 静态实例注册此实现。

     SyncFactory.registerProvider(
                          "com.fred.providers.HighAvailabilityProvider");

通过参考实现提供的默认 SyncProvider 对象使用以下名称：

     com.sun.rowset.providers.RIOptimisticProvider

供应商可以通过发送电子邮件到 jdbc@sun.com 向 Sun Microsystems 公司注册 SyncProvider 实现类名称。Sun 将维护列出可用 SyncProvider 实现的数据库，以便与兼容 RowSet 实现一起使用。此数据库将类似于已维护列出可用 JDBC 驱动程序的数据库。

有关如何实现一个新的 SyncProvider 实现的附加指南，供应商应参考参考实现同步提供者。

2.0 RowSet 对象如何获取其提供者

非连接 Rowset 对象可以使用以下两种方法之一获取对 SyncProvider 对象的访问：
  • 使用构造方法
           CachedRowSet crs = new CachedRowSet(
                  "com.fred.providers.HighAvailabilitySyncProvider");
  • 使用 setSyncProvider 方法
           CachedRowSet crs = new CachedRowSet();
       crs.setSyncProvider("com.fred.providers.HighAvailabilitySyncProvider");

默认情况下，RowSet 同步提供者的参考实现总是可用于 Java 平台。如果没有正确地注册任何其他可插入的同步提供者，则 SyncFactory 将自动生成一个默认 SyncProvider 参考实现的实例。这样，在前述的代码片段中，如果没有任何名为 com.fred.providers.HighAvailabilitySyncProvider 的实现已向 SyncFactory 实例注册，则 crs 将被分配一个参考实现中的默认提供者，它是 com.sun.rowset.providers.RIOptimisticProvider。

3.0 冲突和同步问题

如果非连接 RowSet 对象和数据源之间的更新与初始查询或底层数据源约束发生冲突，则这将导致所有非连接 RowSet 实现及其指派的 SyncProvider 实现的行为不明确。不定义此类冲突发生时的行为给 SyncProvider 实现提供更大的灵活性，使它能自己决定如何反应。

SyncProvider 实现可以选择实现特定的处理程序来处理查询冲突的子集。但是，如果 SyncProvider 实现没有处理原始查询冲突或更一般的数据源约束冲突，则所有的 SyncProvider 对象必须抛出 SyncProviderException。

4.0 可更新的 SQL VIEW

能够从 SQL 查询（最初从 SQL VIEW 形成）填充任何非连接或连接的 RowSet 对象。虽然在许多情况下能够对底层视图执行更新，但是此类更新需要附加的元数据，并且该数据可能不同。SyncProvider 类提供两个常量来指示实现是否支持更新 SQL VIEW。
  • NONUPDATABLE_VIEW_SYNC - 指示将 SQL VIEW 作为 RowSet 对象的数据底层源的情况下，SyncProvider 实现不支持与它的同步。
  • UPDATABLE_VIEW_SYNC - 指示将 SQL VIEW 作为数据底层源的情况下，SyncProvider 实现支持与它的同步。

如果使用取自 SQL VIEW 的数据填充 RowSet 对象，则默认情况是它不可更新。

5.0 SyncProvider 常量

SyncProvider 类提供三个常量集，用作返回值或 SyncProvider 方法的参数。可以实现 SyncProvider 对象来使用不同的关心程度执行 RowSet 对象与其底层数据源之间的同步。第一组常量指示如何处理同步。例如，GRADE_NONE 指示 SyncProvider 对象将不会注意查看哪些数据有用，只是将 RowSet 数据写入数据源。GRADE_MODIFIED_AT_COMMIT 指示提供者只检查修改数据的有效性。其他等级检查所有数据的有效性，或者在修改或加载数据时设置锁定。
  1. 指示 SyncProvider 对象的同步等级的常量
    • SyncProvider.GRADE_NONE
    • SyncProvider.GRADE_MODIFIED_AT_COMMIT
    • SyncProvider.GRADE_CHECK_ALL_AT_COMMIT
    • SyncProvider.GRADE_LOCK_WHEN_MODIFIED
    • SyncProvider.GRADE_LOCK_WHEN_LOADED
  2. 指示在数据源上设置何种锁定的常量
    • SyncProvider.DATASOURCE_NO_LOCK
    • SyncProvider.DATASOURCE_ROW_LOCK
    • SyncProvider.DATASOURCE_TABLE_LOCK
    • SyncProvider.DATASOURCE_DB_LOCK
  3. 指示 SyncProvider 对象是否可以对 SQL VIEW 执行更新的常量
    在前述的章节 (4.0) 中已对这些常量进行了解释。
    • SyncProvider.UPDATABLE_VIEW_SYNC
    • SyncProvider.NONUPDATABLE_VIEW_SYNC

另请参见：
SyncFactory, SyncFactoryException

字段摘要
static int | DATASOURCE_DB_LOCK 指示锁定整个数据源，该数据源是正在使用此 SyncProvider 对象的 RowSet 对象的数据源。
static int | DATASOURCE_NO_LOCK 指示在原始数据源上不保持任何锁定。
static int | DATASOURCE_ROW_LOCK 指示锁定原始 SQL 语句涉及的行，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。
static int | DATASOURCE_TABLE_LOCK 指示锁定原始 SQL 语句涉及的所有表，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。
static int | GRADE_CHECK_ALL_AT_COMMIT 指示关于原始数据源的高级别乐观同步等级。
static int | GRADE_CHECK_MODIFIED_AT_COMMIT 指示关于原始数据源的低级别乐观同步等级。
static int | GRADE_LOCK_WHEN_LOADED 指示关于原始数据源的最悲观同步等级。
static int | GRADE_LOCK_WHEN_MODIFIED 指示关于原始数据源的悲观同步等级。
static int | GRADE_NONE 指示没有提供与原始数据源的同步。
static int | NONUPDATABLE_VIEW_SYNC 指示 SyncProvider 实现不支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。
static int | UPDATABLE_VIEW_SYNC 指示 SyncProvider 实现支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。
构造方法摘要
SyncProvider()
创建默认的 SyncProvider 对象。
方法摘要
abstract int | getDataSourceLock() 返回在此 SyncProvider 实现中活动的当前数据源锁定严重性级别。
abstract int | getProviderGrade() 返回一个常量，它指示 RowSet 对象希望从此 SyncProvider 对象获得的同步等级。
abstract String | getProviderID() 返回此 SyncProvider 对象的唯一标识符。
abstract RowSetReader | getRowSetReader() 返回 javax.sql.RowSetReader 对象，它可以用于填充带有数据的 RowSet 对象。
abstract RowSetWriter | getRowSetWriter() 返回 javax.sql.RowSetWriter 对象，它可以用于将 RowSet 对象的数据写回底层数据源。
abstract String | getVendor() 返回此 SyncProvider 实例的供应商名称
abstract String | getVersion() 返回此 SyncProvider 实例的发行版本。
abstract void | setDataSourceLock(int datasource_lock) 按照 datasource_lock 指示的级别在底层数据源上设置锁定。
abstract int | supportsUpdatableView() 返回此 SyncProvider 实现是否可以执行 RowSet 对象和数据源（RowSet 从中获取其数据）中的 SQL VIEW 之间的同步。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

GRADE_NONE

public static int GRADE_NONE
指示没有提供与原始数据源的同步。返回此等级的 SyncProvider 实现仅尝试将 RowSet 对象中的更新写入底层数据源，而不检查任何数据的有效性。

GRADE_CHECK_MODIFIED_AT_COMMIT

public static int GRADE_CHECK_MODIFIED_AT_COMMIT
指示关于原始数据源的低级别乐观同步等级。 返回此等级的 SyncProvider 实现只检查已经更改的行。

GRADE_CHECK_ALL_AT_COMMIT

public static int GRADE_CHECK_ALL_AT_COMMIT
指示关于原始数据源的高级别乐观同步等级。 返回此等级的 SyncProvider 实现将检查所有的行，包括没有更改的行。

GRADE_LOCK_WHEN_MODIFIED

public static int GRADE_LOCK_WHEN_MODIFIED
指示关于原始数据源的悲观同步等级。 返回此等级的 SyncProvider 实现将锁定原始数据源中的行。

GRADE_LOCK_WHEN_LOADED

public static int GRADE_LOCK_WHEN_LOADED
指示关于原始数据源的最悲观同步等级。返回此等级的 SyncProvider 实现将锁定用于填充 RowSet 对象的原始语句所影响的整个视图和/或表。

DATASOURCE_NO_LOCK

public static int DATASOURCE_NO_LOCK
指示在原始数据源上不保持任何锁定。如果 RowSet 对象没有其他指示，则这是所有 SyncProvider 实现的默认锁定设置。

DATASOURCE_ROW_LOCK

public static int DATASOURCE_ROW_LOCK
指示锁定原始 SQL 语句涉及的行，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。

DATASOURCE_TABLE_LOCK

public static int DATASOURCE_TABLE_LOCK
指示锁定原始 SQL 语句涉及的所有表，该语句用于填充正在使用此 SyncProvider 对象的 RowSet 对象。

DATASOURCE_DB_LOCK

public static int DATASOURCE_DB_LOCK
指示锁定整个数据源，该数据源是正在使用此 SyncProvider 对象的 RowSet 对象的数据源。

UPDATABLE_VIEW_SYNC

public static int UPDATABLE_VIEW_SYNC
指示 SyncProvider 实现支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。

NONUPDATABLE_VIEW_SYNC

public static int NONUPDATABLE_VIEW_SYNC
指示 SyncProvider 实现不支持 RowSet 对象和用于填充它的 SQL VIEW 之间的同步。

构造方法详细信息

SyncProvider

public SyncProvider()
创建默认的 SyncProvider 对象。

方法详细信息

getProviderID

public abstract String getProviderID()
返回此 SyncProvider 对象的唯一标识符。

返回：
具有此 SyncProvider 对象的完全限定类名的 String 对象

getRowSetReader

public abstract RowSetReader getRowSetReader()
返回 javax.sql.RowSetReader 对象，它可以用于填充带有数据的 RowSet 对象。

返回：
javax.sql.RowSetReader 对象

getRowSetWriter

public abstract RowSetWriter getRowSetWriter()
返回 javax.sql.RowSetWriter 对象，它可以用于将 RowSet 对象的数据写回底层数据源。

返回：
javax.sql.RowSetWriter 对象

getProviderGrade

public abstract int getProviderGrade()
返回一个常量，它指示 RowSet 对象希望从此 SyncProvider 对象获得的同步等级。

返回：
一个 int，它是以下常量之一：SyncProvider.GRADE_NONE、SyncProvider.GRADE_CHECK_MODIFIED_AT_COMMIT、SyncProvider.GRADE_CHECK_ALL_AT_COMMIT、SyncProvider.GRADE_LOCK_WHEN_MODIFIED、SyncProvider.GRADE_LOCK_WHEN_LOADED

setDataSourceLock

public abstract void setDataSourceLock(int datasource_lock)
                                throws SyncProviderException
按照 datasource_lock 指示的级别在底层数据源上设置锁定。这应导致 SyncProvider 为能成功同步而调整其行为，即增加或减少其提供的乐观级别。

参数：
datasource_lock - 以下常量之一，它指示所需数据源锁定的严重性级别：
           SyncProvider.DATASOURCE_NO_LOCK,
           SyncProvider.DATASOURCE_ROW_LOCK,
           SyncProvider.DATASOURCE_TABLE_LOCK,
           SyncProvider.DATASOURCE_DB_LOCK,
抛出：
SyncProviderException - 如果设置不支持的数据源锁定级别。
另请参见：
getDataSourceLock()

getDataSourceLock

public abstract int getDataSourceLock()
                               throws SyncProviderException
返回在此 SyncProvider 实现中活动的当前数据源锁定严重性级别。

返回：
一个常量，它指示在此 SyncProvider 对象中活动的数据源锁定的当前级别；是以下常量之一：
           SyncProvider.DATASOURCE_NO_LOCK,
           SyncProvider.DATASOURCE_ROW_LOCK,
           SyncProvider.DATASOURCE_TABLE_LOCK,
           SyncProvider.DATASOURCE_DB_LOCK
抛出：
SyncProviderExceptiom - 如果在确定数据源锁定级别时发生错误。
SyncProviderException
另请参见：
setDataSourceLock(int)

supportsUpdatableView

public abstract int supportsUpdatableView()
返回此 SyncProvider 实现是否可以执行 RowSet 对象和数据源（RowSet 从中获取其数据）中的 SQL VIEW 之间的同步。

返回：
一个 int，表示此 SyncProvider 对象是否支持更新 SQL VIEW；它是以下常量之一：SyncProvider.UPDATABLE_VIEW_SYNC、SyncProvider.NONUPDATABLE_VIEW_SYNC

getVersion

public abstract String getVersion()
返回此 SyncProvider 实例的发行版本。

返回：
一个 String，它详述了 SyncProvider 实现的发行版本

getVendor

public abstract String getVendor()
返回此 SyncProvider 实例的供应商名称

返回：
一个 String，它详述了此 SyncProvider 实现的供应商名称
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SyncProviderException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
类 SyncProviderException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  java.sql.SQLException
                继承者  javax.sql.rowset.spi.SyncProviderException
所有已实现的接口：
Serializable, Iterable<Throwable>
public class SyncProviderException
extends SQLException

指示 SyncProvider 机制发生的错误。如果在从原始数源读取或向原始数据源写入时遇到冲突，则 SyncProvider 抽象类扩展将创建此异常。

SyncProvider 对象也可以创建 SyncResolver 对象，可能在构建时使用它初始化 SyncProviderException 对象，或者以后使用 SyncProvider 对象对它进行设置，如果它被实现做这些的话。

在 writer 完成冲突检查并找到一个或多个冲突之后，方法 acceptChanges 将抛出此异常。应用程序可以捕获 SyncProviderException 对象，并调用其 getSyncResolver 方法，以获取其 SyncResolver 对象。关于示例，请参阅 SyncResolver 接口注释中的代码片段。此 SyncResolver 对象将反映生成该异常的 RowSet 对象，区别在于它仅包含数据源中处于冲突状态的值。SyncResolver 对象中的所有其他值将为 null。

SyncResolver 对象可用于检查并解析一个行中的每个冲突，然后转到下一个有冲突的行，重复该过程。

SyncProviderException 对象可能包含（也可能不包含）对导致该异常条件的描述。可以调用继承的方法 getMessage，以获取该描述（如果存在）。

另请参见：
SyncFactory, SyncResolver, SyncFactoryException, 序列化表格

构造方法摘要
SyncProviderException()
创建不带任何详细消息的新 SyncProviderException 对象。
SyncProviderException(String msg)
构造带指定详细消息的 SyncProviderException 对象。
SyncProviderException(SyncResolver syncResolver)
构造带指定 SyncResolver 实例的 SyncProviderException 对象。
方法摘要
SyncResolver | getSyncResolver() 获取为此 SyncProviderException 对象设置的 SyncResolver 对象，如果没有设置，则获取包含在参考实现中的默认 SyncResolver 实现的实例。
void | setSyncResolver(SyncResolver syncResolver) 将此 SyncProviderException 对象的 SyncResolver 对象设置为提供的对象。
从类 java.sql.SQLException 继承的方法
getErrorCode, getNextException, getSQLState, iterator, setNextException
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

SyncProviderException

public SyncProviderException()
创建不带任何详细消息的新 SyncProviderException 对象。

SyncProviderException

public SyncProviderException(String msg)
构造带指定详细消息的 SyncProviderException 对象。

参数：
msg - 详细消息

SyncProviderException

public SyncProviderException(SyncResolver syncResolver)
构造带指定 SyncResolver 实例的 SyncProviderException 对象。

参数：
syncResolver - 用于处理同步冲突的 SyncResolver 实例
抛出：
IllegalArgumentException - 如果 SyncResolver 对象为 null。
方法详细信息

getSyncResolver

public SyncResolver getSyncResolver()
获取为此 SyncProviderException 对象设置的 SyncResolver 对象，如果没有设置，则获取包含在参考实现中的默认 SyncResolver 实现的实例。

如果抛出 SyncProviderException 对象，则应用程序可以使用此方法生成 SyncResolver 对象，使用该对象可以解决导致抛出异常的冲突。

返回：
为此 SyncProviderException 对象设置的 SyncResolver 对象，如果没有设置，则返回默认 SyncResolver 实现的实例。另外，如果 SyncResolver() 或 SyncResolver(String) 构造方法用于实例化 SyncResolver 实例，则也返回默认 SyncResolver 实现。

setSyncResolver

public void setSyncResolver(SyncResolver syncResolver)
将此 SyncProviderException 对象的 SyncResolver 对象设置为提供的对象。如果提供的参数为 null，则调用方法 getSyncResolver 将返回 SyncResolver 接口的默认参考实现。

参数：
syncResolver - 要设置的 SyncResolver 对象；不能为 null
抛出：
IllegalArgumentException - 如果 SyncResolver 对象为 null。
另请参见：
getSyncResolver()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SyncResolver (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
接口 SyncResolver

所有超级接口：
ResultSet, RowSet, Wrapper
public interface SyncResolver
extends RowSet

定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。虽然应用程序手工解决同步冲突并不是委托过程，但此框架还是提供了一些发生冲突时委托应用程序的方法。

注意，冲突是指 RowSet 对象的原始行值与数据源中的值不匹配的情况，它指示自最后一次同步以来数据源行已被修改。还要注意，RowSet 对象的原始值就是最后一次同步之前的值，不必是其初始值。

SyncResolver 对象的描述

SyncResolver 对象是实现 SyncResolver 接口的专用 RowSet 对象。它可以以连接的 RowSet 对象（JdbcRowSet 接口的实现）或非连接 RowSet 对象（CachedRowSet 接口或其一个子接口的实现）的形式进行操作。有关子接口的信息，请参阅 javax.sql.rowset 包描述。SyncResolver 的参考实现实现了 CachedRowSet 接口，但是其他实现可以选择实现 JdbcRowSet 接口，以满足特定的需要。

应用程序尝试使 RowSet 对象与数据源同步（通过调用 CachedRowSet 方法 acceptChanges），并且找到一个或多个冲突之后，rowset 的 SyncProvider 对象会创建一个 SyncResolver 实例。这一新的 SyncResolver 对象具有与正在尝试同步的 RowSet 对象相同的行数和列数。SyncResolver 对象包含数据源中导致冲突的值，其他值都为 null。另外，它包含关于每个冲突的信息。

获取并使用 SyncResolver 对象

当方法 acceptChanges 遇到冲突时，SyncProvider 对象会创建 SyncProviderException 对象，并使用新的 SyncResolver 对象设置它。方法 acceptChanges 将抛出此异常，然后应用程序可以捕获它并用以获取它包含的 SyncResolver 对象。以下代码片段使用 SyncProviderException 方法 getSyncResolver 来获取 SyncResolver 对象 resolver。
     } catch (SyncProviderException spe) {
         SyncResolver resolver = spe.getSyncResolver();
     ...
     }

通过所拥有的 resolver，应用程序可以使用它获取关于冲突的信息。SyncResolver 对象（如 resolver）跟踪存在冲突的每个行中的冲突。它还可以锁定受 rowset 命令影响的表，以便在解决当前冲突时不再发生其他冲突。

可以从 SyncResolver 对象获取以下几种信息：

  • 发生冲突时正试图进行的操作
    SyncProvider 接口定义了四个常量来描述可能发生的状态。其中三个常量描述发现冲突时 RowSet 对象正试图执行的操作类型（更新、删除或插入），第四个常量指示不存在冲突。当 SyncResolver 对象调用方法 getStatus 时，这些常量都是可能的返回值。
         int operation = resolver.getStatus();

  • 数据源中导致冲突的值
    当 RowSet 对象更改并尝试写入到数据源的值自上一次同步以来也在数据源中被更改时，会发生冲突。应用程序可以调用 SyncResolver 的方法 getConflictValue来获取数据源中导致冲突的值，因为 SyncResolver 对象中的值是取自数据源的冲突值。
         java.lang.Object conflictValue = resolver.getConflictValue(2);
    注意，resolver 中的列可以使用列号指定（如以上代码行中所示），也可以用列名称指定。

    使用从方法 getStatus 和 getConflictValue 获取到的信息，应用程序可以做出应在数据源中保留哪一个值的决定。然后，应用程序调用 SyncResolver 的方法 setResolvedValue，它可以设置 RowSet 对象中和数据源中要保留的值。

         resolver.setResolvedValue("DEPT", 8390426);
    在以上代码行中，列名称指定 RowSet 对象中要使用给定值设置的列。也可以用列号来指定列。

    解决当前冲突行中的所有冲突之后，应用程序会调用方法 setResolvedValue，并对 SyncResolver 对象中每个冲突行重复此过程。

    导航 SyncResolver 对象

    因为 SyncResolver 对象是 RowSet 对象，所以应用程序可以使用所有的 RowSet 方法移动指针来导航 SyncResolver 对象。例如，应用程序可以使用 RowSet 的方法 next 到达每个行，然后调用 SyncResolver 的方法 getStatus 查看行是否包含冲突。在具有一个或多个冲突的行中，应用程序可以迭代列来查找任何非 null 值，它将是数据源中处于冲突状态的值。

    要使导航 SyncResolver 对象更容易，尤其是存在大量没有冲突的行时，SyncResolver 接口定义了方法 nextConflict 和 previousConflict，它们只移动到至少包含一个冲突值的行。然后，应用程序通过提供列号作为参数调用 SyncResolver 的方法 getConflictValue，以获取冲突值本身。下一节中的代码片段给出了一个示例。

    代码示例

    以下代码片段演示非连接 RowSet 对象 crs 如何尝试使自已与底层数据源同步，然后解决冲突。在 try 块中，crs 调用方法 acceptChanges，将 Connection 对象 con 传递给它。如果不存在冲突，则将 crs 中的更改写入到数据源即可。但是，如果存在冲突，则方法 acceptChanges 将抛出 SyncProviderException 对象，catch 块生效。在此示例中，阐述了多种 SyncResolver 对象使用方式中的一种，在 while 循环中，使用 SyncResolver 的方法 nextConflict。nextConflict 返回 false 时循环将终止，这发生在 SyncResolver 对象 resolver 中不再有冲突行时。在此特定的代码片段中，resolver 查找有更新冲突的行（状态为 SyncResolver.UPDATE_ROW_CONFLICT 的行），此代码片段其余部分仅执行由于 crs 尝试更新而发生冲突的行。

    resolver 的指针移动到有更新冲突的下一个冲突行之后，方法 getRow 指示当前行的数字，并且将 CachedRowSet 对象 crs 的指针移到 crs 中的对等行。通过迭代 resolver 和 crs 中行的列，可以获取和比较冲突值，以确定应保留哪一个值。在此代码片段中，crs 中的值是设置为解决值的值，这意味着它将用于重写数据源中的冲突值。

         try {

         crs.acceptChanges(con);

     } catch (SyncProviderException spe) {

         SyncResolver resolver = spe.getSyncResolver();

         Object crsValue;  // value in the RowSet object
         Object resolverValue:  // value in the SyncResolver object
         Object resolvedValue:  // value to be persisted

         while(resolver.nextConflict())  {
             if(resolver.getStatus() == SyncResolver.UPDATE_ROW_CONFLICT)  {
                 int row = resolver.getRow();
                 crs.absolute(row);

                 int colCount = crs.getMetaData().getColumnCount();
                 for(int j = 1; j <= colCount; j++) {
                     if (resolver.getConflictValue(j) != null)  {
                         crsValue = crs.getObject(j);
                         resolverValue = resolver.getConflictValue(j);
                         . . .
                         // compare crsValue and resolverValue to determine
                         // which should be the resolved value (the value to persist)
                         resolvedValue = crsValue;

                         resolver.setResolvedValue(j, resolvedValue);
                      }
                  }
              }
          }
      }

    字段摘要
    static int DELETE_ROW_CONFLICT
    指示在 RowSet 对象试图删除数据源中的行时发生冲突。
    static int INSERT_ROW_CONFLICT
    指示在 RowSet 对象试图将行插入数据源中时发生冲突。
    static int NO_ROW_CONFLICT
    指示在 RowSet 对象试图更新、删除或插入数据源中的行时不发生任何冲突。
    static int UPDATE_ROW_CONFLICT
    指示在 RowSet 对象试图更新数据源中的行时发生冲突。
    从接口 java.sql.ResultSet 继承的字段
    CLOSE_CURSORS_AT_COMMIT, CONCUR_READ_ONLY, CONCUR_UPDATABLE, FETCH_FORWARD, FETCH_REVERSE, FETCH_UNKNOWN, HOLD_CURSORS_OVER_COMMIT, TYPE_FORWARD_ONLY, TYPE_SCROLL_INSENSITIVE, TYPE_SCROLL_SENSITIVE
    方法摘要
     Object getConflictValue(int index)
    获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
     Object getConflictValue(String columnName)
    获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。
     int getStatus()
    获取此 SyncResolver 的当前行的冲突状态，它指示在发生冲突时 RowSet 对象正尝试的操作。
     boolean nextConflict()
    将指针从其当前位置移动到下一个包含冲突值的行。
     boolean previousConflict()
    将指针从其当前位置移动到此 SyncResolver 对象中上一个冲突行。
     void setResolvedValue(int index, Object obj)
    将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。
     void setResolvedValue(String columnName, Object obj)
    将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。
    从接口 javax.sql.RowSet 继承的方法
    addRowSetListener, clearParameters, execute, getCommand, getDataSourceName, getEscapeProcessing, getMaxFieldSize, getMaxRows, getPassword, getQueryTimeout, getTransactionIsolation, getTypeMap, getUrl, getUsername, isReadOnly, removeRowSetListener, setArray, setAsciiStream, setAsciiStream, setAsciiStream, setAsciiStream, setBigDecimal, setBigDecimal, setBinaryStream, setBinaryStream, setBinaryStream, setBinaryStream, setBlob, setBlob, setBlob, setBlob, setBlob, setBlob, setBoolean, setBoolean, setByte, setByte, setBytes, setBytes, setCharacterStream, setCharacterStream, setCharacterStream, setCharacterStream, setClob, setClob, setClob, setClob, setClob, setClob, setCommand, setConcurrency, setDataSourceName, setDate, setDate, setDate, setDate, setDouble, setDouble, setEscapeProcessing, setFloat, setFloat, setInt, setInt, setLong, setLong, setMaxFieldSize, setMaxRows, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNCharacterStream, setNClob, setNClob, setNClob, setNClob, setNClob, setNClob, setNString, setNString, setNull, setNull, setNull, setNull, setObject, setObject, setObject, setObject, setObject, setObject, setPassword, setQueryTimeout, setReadOnly, setRef, setRowId, setRowId, setShort, setShort, setSQLXML, setSQLXML, setString, setString, setTime, setTime, setTime, setTime, setTimestamp, setTimestamp, setTimestamp, setTimestamp, setTransactionIsolation, setType, setTypeMap, setURL, setUrl, setUsername
    从接口 java.sql.ResultSet 继承的方法
    absolute, afterLast, beforeFirst, cancelRowUpdates, clearWarnings, close, deleteRow, findColumn, first, getArray, getArray, getAsciiStream, getAsciiStream, getBigDecimal, getBigDecimal, getBigDecimal, getBigDecimal, getBinaryStream, getBinaryStream, getBlob, getBlob, getBoolean, getBoolean, getByte, getByte, getBytes, getBytes, getCharacterStream, getCharacterStream, getClob, getClob, getConcurrency, getCursorName, getDate, getDate, getDate, getDate, getDouble, getDouble, getFetchDirection, getFetchSize, getFloat, getFloat, getHoldability, getInt, getInt, getLong, getLong, getMetaData, getNCharacterStream, getNCharacterStream, getNClob, getNClob, getNString, getNString, getObject, getObject, getObject, getObject, getRef, getRef, getRow, getRowId, getRowId, getShort, getShort, getSQLXML, getSQLXML, getStatement, getString, getString, getTime, getTime, getTime, getTime, getTimestamp, getTimestamp, getTimestamp, getTimestamp, getType, getUnicodeStream, getUnicodeStream, getURL, getURL, getWarnings, insertRow, isAfterLast, isBeforeFirst, isClosed, isFirst, isLast, last, moveToCurrentRow, moveToInsertRow, next, previous, refreshRow, relative, rowDeleted, rowInserted, rowUpdated, setFetchDirection, setFetchSize, updateArray, updateArray, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateAsciiStream, updateBigDecimal, updateBigDecimal, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBinaryStream, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBlob, updateBoolean, updateBoolean, updateByte, updateByte, updateBytes, updateBytes, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateCharacterStream, updateClob, updateClob, updateClob, updateClob, updateClob, updateClob, updateDate, updateDate, updateDouble, updateDouble, updateFloat, updateFloat, updateInt, updateInt, updateLong, updateLong, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNCharacterStream, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNClob, updateNString, updateNString, updateNull, updateNull, updateObject, updateObject, updateObject, updateObject, updateRef, updateRef, updateRow, updateRowId, updateRowId, updateShort, updateShort, updateSQLXML, updateSQLXML, updateString, updateString, updateTime, updateTime, updateTimestamp, updateTimestamp, wasNull
    从接口 java.sql.Wrapper 继承的方法
    isWrapperFor, unwrap

    字段详细信息

    UPDATE_ROW_CONFLICT

    static final int UPDATE_ROW_CONFLICT
    指示在 RowSet 对象试图更新数据源中的行时发生冲突。数据源行中要更新的值不同于该行的 RowSet 对象的原始值，这意味着自上一次同步以来已更新或删除了数据源中的行。

    另请参见：
    常量字段值

    DELETE_ROW_CONFLICT

    static final int DELETE_ROW_CONFLICT
    指示在 RowSet 对象试图删除数据源中的行时发生冲突。数据源行中要更新的值不同于该行的 RowSet 对象的原始值，这意味着自上一次同步以来已更新或删除了数据源中的行。

    另请参见：
    常量字段值

    INSERT_ROW_CONFLICT

    static final int INSERT_ROW_CONFLICT
    指示在 RowSet 对象试图将行插入数据源中时发生冲突。这意味着自上一次同步以来已经在数据源中插入了一个与要插入的行具有相同主键的行。

    另请参见：
    常量字段值

    NO_ROW_CONFLICT

    static final int NO_ROW_CONFLICT
    指示在 RowSet 对象试图更新、删除或插入数据源中的行时不发生任何冲突。SyncResolver 中的值将包含 null 值，该值仅指示此行中没有关于冲突解决的信息。

    另请参见：
    常量字段值
    方法详细信息

    getStatus

    int getStatus()
    获取此 SyncResolver 的当前行的冲突状态，它指示在发生冲突时 RowSet 对象正尝试的操作。

    返回：
    以下常量之一：SyncResolver.UPDATE_ROW_CONFLICT、SyncResolver.DELETE_ROW_CONFLICT、SyncResolver.INSERT_ROW_CONFLICT 或 SyncResolver.NO_ROW_CONFLICT

    getConflictValue

    Object getConflictValue(int index)
                        throws SQLException
    获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

    参数：
    index - 一个 int，它指定此 SyncResolver 对象的此行中的列，从该列可以获取导致冲突的值
    返回：
    此 SyncResolver 对象的当前行中指定列的值
    抛出：
    SQLException - 如果发生数据库访问错误

    getConflictValue

    Object getConflictValue(String columnName)
                        throws SQLException
    获取此 SyncResolver 对象的当前行中指定列的值，它是数据源中导致冲突的值。

    参数：
    columnName - String 对象，它指定此 SyncResolver 对象的此行中的列，从该列可以获取导致冲突的值
    返回：
    此 SyncResolver 对象的当前行中指定列的值
    抛出：
    SQLException - 如果发生数据库访问错误

    setResolvedValue

    void setResolvedValue(int index,
                      Object obj)
                      throws SQLException
    将 obj 设置为将同步的 RowSet 对象当前行中第 index 列的值。将 obj 内部地设置为数据源中的值。

    参数：
    index - 一个 int，它提供要设置保留值的列号
    obj - 一个 Object，它是在 RowSet 对象中设置的值，将它保留在数据源中
    抛出：
    SQLException - 如果发生数据库访问错误

    setResolvedValue

    void setResolvedValue(String columnName,
                      Object obj)
                      throws SQLException
    将 obj 设置为将同步的 RowSet 对象当前行中列 columnName 的值。将 obj 内部地设置为数据源中的值。

    参数：
    columnName - String 对象，它提供要设置保留值的列名称
    obj - 一个 Object，它是在 RowSet 对象中设置的值，将它保留在数据源中
    抛出：
    SQLException - 如果发生数据库访问错误

    nextConflict

    boolean nextConflict()
                     throws SQLException
    将指针从其当前位置移动到下一个包含冲突值的行。SyncResolver 对象的指针最初位于第一个冲突行之前；第一次调用 nextConflict 方法使第一个冲突行成为当前行；第二次调用使第二个冲突行成为当前行，依此类推。

    调用方法 nextConflict 将隐式关闭输入流（如果有打开的输入流），并且将清除 SyncResolver 对象的警告链。

    返回：
    如果新的当前行有效，则返回 true；如果不存在下一行，则返回 false
    抛出：
    SQLException - 如果发生数据库访问错误，或者结果集类型为 TYPE_FORWARD_ONLY

    previousConflict

    boolean previousConflict()
                         throws SQLException
    将指针从其当前位置移动到此 SyncResolver 对象中上一个冲突行。

    调用方法 previousConflict 将隐式关闭输入流（如果有打开的输入流），并且将清除 SyncResolver 对象的警告链。

    返回：
    如果指针位于有效行上，则返回 true；如果它不在结果集中，则返回 false
    抛出：
    SQLException - 如果发生数据库访问错误，或者结果集类型为 TYPE_FORWARD_ONLY
    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个类 下一个类 框架 无框架
    摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransactionalWriter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
接口 TransactionalWriter

所有超级接口：
RowSetWriter
public interface TransactionalWriter
extends RowSetWriter

一个专用接口，用来方便地扩展标准 SyncProvider 抽象类以便拥有细粒度的事务控制。

如果一个或多个非连接 RowSet 对象加入全局事务中，则它们可能希望调整自已的同步提交，以保持数据的完整性并减少发生同步异常的次数。如果是这种情况，则应用程序应将 CachedRowSet 常量 COMMIT_ON_ACCEPT_CHANGES 设置为 false，并使用此接口中定义的 commit 和 rollback 方法来管理事务边界。

方法摘要
void | commit() 使最后一次调用 commit 或 rollback 方法以来 acceptChanges 执行的所有更改永久化。
void | rollback() 撤消在当前事务中进行的所有更改。
void | rollback(Savepoint s) 撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。
从接口 javax.sql.RowSetWriter 继承的方法
writeData

方法详细信息

commit

void commit()
            throws SQLException
使最后一次调用 commit 或 rollback 方法以来 acceptChanges 执行的所有更改永久化。此方法应该只在已禁用自动提交模式时使用。

抛出：
SQLException - 如果发生数据库访问错误，或此 CachedRowSet 对象中的 Connection 对象处于自动提交模式。

rollback

void rollback()
              throws SQLException
撤消在当前事务中进行的所有更改。此方法应该只在已禁用自动提交模式时使用。

抛出：
SQLException - 如果发生数据库访问错误，或此 CachedRowSet 对象中的 Connection 对象处于自动提交模式。

rollback

void rollback(Savepoint s)
              throws SQLException
撤消在给定 Savepoint 对象之前所进行的当前事务中的所有更改。此方法应该只在已禁用自动提交模式时使用。

参数：
s - 在当前事务中标记保存点的 Savepoint 对象。设置 s 之前进行的所有更改都将被撤消。使设置 s 之后进行的所有更改永久化。
抛出：
SQLException - 如果发生数据库访问错误，或此 CachedRowSet 对象中的 Connection 对象处于自动提交模式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlReader (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
接口 XmlReader

所有超级接口：
RowSetReader
public interface XmlReader
extends RowSetReader

一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。

提供 XML 数据 reader 功能（如输出 XML 流功能）的 SyncProvider 实现可以实现此接口，以向 WebRowSet 实现提供标准 XmlReader 对象。

通过将 XmlReader 对象分配给 rowset 的 xmlReader 字段，将它注册为 WebRowSet 的 XML reader。当调用 WebRowSet 对象的 readXml 方法时，它将依次调用其 XML reader 的 readXML 方法。

方法摘要
 void readXML(WebRowSet caller, Reader reader)
从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。
从接口 javax.sql.RowSetReader 继承的方法
readData

方法详细信息

readXML

void readXML(WebRowSet caller,
             Reader reader)
             throws SQLException
从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。给定 WebRowSet 对象的 xmlReader 字段必须包含此 XmlReader 对象。

如果发生解析错误，则抛出的异常将包括关于原始 XML 文档中错误位置的信息。

参数：
caller - 要解析的 WebRowSet 对象，该对象的 xmlReader 字段必须包含对此 XmlReader 对象的引用
reader - 一个 java.io.Reader 对象，将从中读取 caller
抛出：
SQLException - 如果发生数据库访问错误或此 XmlReader 对象不是给定 rowset 的 reader
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


XmlWriter (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.sql.rowset.spi
接口 XmlWriter

所有超级接口：
RowSetWriter
public interface XmlWriter
extends RowSetWriter

一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。

提供 XML 数据 writer 功能（如输出 XML 流功能）的 SyncProvider 实现可以实现此接口，以向 WebRowSet 实现提供标准 XmlWriter 对象。

编写 WebRowSet 对象包括打印 rowset 的数据、元数据和属性，都使用适当的 XML 标记。

方法摘要
 void writeXML(WebRowSet caller, Writer writer)
将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。
从接口 javax.sql.RowSetWriter 继承的方法
writeData

方法详细信息

writeXML

void writeXML(WebRowSet caller,
              Writer writer)
              throws SQLException
将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。此文档包括 rowset 的数据、元数据、属性，再加上适当的 XML 标记。

caller 参数必须是 WebRowSet 对象，该对象的 XmlWriter 字段包含对此 XmlWriter 对象的引用。

参数：
caller - 要编写的 WebRowSet 实例，此 XmlWriter 对象是它的 writer
writer - java.io.Writer 对象，它充当输出流，用于以 XML 文档形式编写 caller
抛出：
SQLException - 如果发生数据库访问错误或此 XmlWriter 对象不是给定 WebRowSet 对象的 writer
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.sql.rowset.spi (Java 2 Platform SE 6)

 javax.sql.rowset.spi
接口
SyncResolver
TransactionalWriter
XmlReader
XmlWriter
类
SyncFactory
SyncProvider
异常
SyncFactoryException
SyncProviderException


javax.sql.rowset.spi (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.sql.rowset.spi

第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

请参见：
描述

接口摘要
SyncResolver | 定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。
TransactionalWriter | 一个专用接口，用来方便地扩展标准 SyncProvider 抽象类以便拥有细粒度的事务控制。
XmlReader | 一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。
XmlWriter | 一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。

类摘要
SyncFactory | 该服务提供者接口 (SPI) 机制可以生成由非连接 RowSet 对象使用的 SyncProvider 实例。
SyncProvider | 为非连接 RowSet 对象提供 reader/writer 功能的同步机制。

异常摘要
SyncFactoryException | 指示 SyncFactory 机制发生的错误。
SyncProviderException | 指示 SyncProvider 机制发生的错误。

软件包 javax.sql.rowset.spi 的描述

第三方供应商在其同步提供者的实现中必须使用的标准类和接口。这些类和接口被称为服务提供者接口 (SPI)。供应商通过向 jdbc@sun.com 发送电子邮件，可以使其实现被 JDBC 网页所包含，该网页列出了可用的 SyncProvider 实现。这样做有助于开发人员了解该实现。为了使 RowSet 对象能够使用实现，供应商必须向 SyncFactory 单件注册。（有关注册过程和所使用命名约定的完整解释，请参阅 SyncProvider 的类注释。）

目录

  • 1.0 包规范
  • 2.0 服务提供者架构
  • 3.0 实现者指南
  • 4.0 解决同步冲突
  • 5.0 相关的规范
  • 6.0 相关的文档

1.0 包规范

以下类和接口组成了 javax.sql.rowset.spi 包：

  • SyncFactory
  • SyncProvider
  • SyncFactoryException
  • SyncProviderException
  • SyncResolver
  • XmlReader
  • XmlWriter
  • TransactionalWriter
javax.sql 包中的以下接口也是 SPI 的一部分：
  • RowSetReader
  • RowSetWriter

SyncProvider 实现通过以下机制提供非连接 RowSet 对象：将数据读入该对象和将在该对象中修改的数据写回底层数据源。当调用 CachedRowSet 方法 execute 或 populate 时，reader、RowSetReader 或 XMLReader 对象可以将数据读入 RowSet 对象。当调用 CachedRowSet 方法 acceptChanges 时，writer、RowSetWriter 或 XMLWriter 对象可以将更改写回底层数据源。

将 RowSet 对象中的更改写入其数据源的过程称为同步。RowSet 正在使用的 SyncProvider 实现可以确定 RowSet 对象的 writer 所使用的同步级别。同步的各种级别被称为等级。

同步的较低等级称为乐观 并发级别，因为它们乐观地假设不存在任何冲突或仅有极少的冲突。当在 RowSet 对象中修改的同一数据也在数据源中修改时，会发生冲突。使用乐观并发模型意味着如果存在冲突，则会丢失对数据源或 RowSet 对象的修改。

同步的较高等级被称为悲观，因为它们假设数据源会被访问并修改。这些等级可以设置各种级别的锁定以增加不发生冲突的几率。

最低级别的同步只将对 RowSet 对象进行的任何更改写入到其底层数据源。writer 不执行任何检查冲突的操作。如果存在冲突，并且数据源值被重写，则其他方对数据源进行的更改会丢失。

RIXMLProvider 实现使用最低级别的同步，并仅将 RowSet 更改写入数据源。确实是这样，因为 XML 数据源通常不会启用事务处理技术来维护数据完整性。但是，特定的标准化组织已经在考虑提供基于 XML 的同步。有关详细信息，请参阅

     http://www.syncml.org

对于下一个级别，writer 会查看是否存在冲突，如果存在，则它不将任何内容写入到数据源。此并发级别的问题是如果另一方在 RowSet 对象获得其数据后修改了数据源中相应数据，则对 RowSet 对象进行的修改会丢失。RIOptimisticProvider 实现使用此级别的同步。

对于称为悲观并发的较高级别的同步，writer 会采取一些步骤（如设置锁定）来避免冲突。设置锁定可以是在一个行上设置，也可以是在一个表或整个数据源上设置。因此，同步级别是一个以下两者间的权衡：用户并发访问数据源的能力和 writer 保持 RowSet 对象及其同步数据源中数据的能力。

它要求所有非连接 RowSet 对象（CachedRowSet、FilteredRowSet、JoinRowSet 和 WebRowSet 对象）从 SyncFactory 机制获取它们的 SyncProvider 对象。

参考实现 (RI) 提供两个同步提供者。

  • RIOptimisticProvider
    默认的提供者，当未指定任何提供者实现时，SyncFactory 实例将它提供给非连接 RowSet 对象。
    此同步提供者使用乐观并发模型，假设访问数据库中同一数据的用户之间几乎没有冲突。它避免了使用锁定；相反，它会查看在尝试使 RowSet 对象和数据源同步之前是否存在冲突。如果存在冲突，它不执行任何操作，这意味着对 RowSet 对象的更改不会保留到数据源。
  • RIXMLProvider
    可以与 WebRowSet 对象一起使用的同步提供者，它是一个以 XML 格式写入或以 XML 格式进行读取的 rowset。RIXMLProvider 实现根本不检查任何冲突，仅将 WebRowSet 对象中的任何更新数据写入底层数据源。WebRowSet 对象处理 XML 数据时使用此提供者。
这些 SyncProvider 实现与参考实现捆绑在一起，使它们总是可用于 RowSet 实现。SyncProvider 实现通过向单一 SyncFactory 注册使它们本身可用。当 RowSet 对象通过在构造方法中指定某个提供者，或者指定它作为 CachedRowSet 方法 setSyncProvider 的参数来请求该提供者时，该单一 SyncFactory 会查看请求的提供者是否已向它注册。如果已注册，则 SyncFactory 创建一个它的实例，并将它传递到发出请求的 RowSet 对象。如果指定的 SyncProvider 实现没有注册，则单一 SyncFactory 导致抛出 SyncFactoryException 对象。如果不指定任何提供者，则单一 SyncFactory 将创建一个默认的提供者实现 RIOptimisticProvider 的实例，并将它传递到发出请求的 RowSet 对象。

如果 WebRowSet 对象在其构造方法中未指定提供者，则 SyncFactory 将为它提供一个 RIOptimisticProvider 实例。但是，可以实现 WebRowSet 的构造方法来将提供者设置为 RIXMLProvider，它以 XML 格式读取和写入 RowSet 对象。

有关更多详细信息，请参阅 SyncProvider 类规范。

供应商可以使用任何一个可能级别的同步开发 SyncProvider 实现，从而给 RowSet 对象一个选择同步机制的机会。供应商通过向 jdbc@sun.com 的 Sun Microsystems 注册完全限定类名称使其实现可用。下面将更加详细地讨论此过程。

2.0 服务提供者接口架构

    2.1 概述

    服务提供者接口提供了一个可插入的机制，通过该机制可以注册 SyncProvider 实现，然后在需要时可生成该实现。SyncFactory 使用的延时引用机制 (lazy reference mechanism) 在非连接 RowSet 对象需要实例之前不会创建实例，从而限制了不必要的资源消耗。SyncFactory 类也提供了标准 API 来配置日志选项和特定的 SyncProvider 实现可以提供的流。

    2.2 向 SyncFactory 注册

    第三方 SyncProvider 实现必须向 SyncFactory 注册，以便非连接 RowSet 对象获取它，从而使用其 javax.sql.RowSetReader 和 javax.sql.RowSetWriter 实现。以下注册机制可用于所有 SyncProvider 实现：

    • 系统属性 - 在命令行属性的设置。每次调用 Java 应用程序时，在运行时设置这些属性并在系统级应用。有关更多相关信息，请参阅“相关文档”一节。

    • 属性文件 - 标准属性文件中指定的属性。这可以使用系统属性指定，或者通过修改平台运行时所处的标准属性文件指定。此技术的参考实现包括标准的属性文件，可以对该属性文件进行编辑以添加到附加 SyncProvider 对象中。

    • JNDI 上下文 - 可以在 JNDI 上下文中注册可用提供者。SyncFactory 将尝试加载绑定到上下文的 SyncProvider 对象，并向工厂注册这些对象。必须向 SyncFactory 提供此上下文，以便机制能正确运行。

    关于如何指定系统属性或属性文件中的属性以及如何配置 JNDI 上下文的细节，已在 SyncFactory 类描述中进行了详细说明。

    2.3 SyncFactory 提供者实例生成策略

    如果正确地注册了提供者，则 SyncFactory 会生成所请求的 SyncProvider 对象。当使用指定的 SyncProvider 实现实例化非连接 RowSet 对象，或者使用替代 SyncProvider 对象在运行时对它进行配置时，请遵循以下策略。

    • 如果指定了 SyncProvider 对象，并且 SyncFactory 不 包含对提供者的任何引用，则抛出一个 SyncFactoryException。

    • 如果指定了 SyncProvider 对象，并且 SyncFactory 包含对提供者的引用，则提供所请求的提供者。

    • 如果未指定任何 SyncProvider 对象，则提供参考实现提供者 RIOptimisticProvider。

    在 SyncFactory 类中更详细地阐述了这些策略。

  • 3.0 SyncProvider 实现者指南

      3.1 要求

      完全可插入到 SyncFactory 的兼容 SyncProvider 实现必须扩展和实现 SyncProvider 类中所有的抽象方法。另外，实现必须确定 SyncProvider 类定义中定义的等级、锁定和可更新视图的功能。必须支持一个或多个 SyncProvider 描述标准。供应商实现需要提供一系列的等级、锁定和可更新视图的功能。

      此外，SyncProvider 命名约定必须符合 SyncProvider 类描述中的详细信息。

      3.2 等级

      JSR 114 定义了一组等级，用来描述 SyncProvider 对象可以提供非连接 RowSet 对象的同步质量。按服务质量从低到高的顺序列出了这些等级。

      • GRADE_NONE - 不提供与原始数据源的任何同步。返回此等级的 SyncProvider 实现仅尝试将在 RowSet 对象中更改的任何数据写入底层数据源，重写存在的任何内容。不尝试比较原始值与当前值来查看是否存在冲突。使用此等级实现 RIXMLProvider。

      • GRADE_CHECK_MODIFIED_AT_COMMIT - 一个低等级的乐观同步。返回此等级的 SyncProvider 实现将检查在上一次同步和当前正进行的同步之间进行更改的行中的冲突。任何原始数据源中已被修改的更改不会反映在非连接 RowSet 对象中。如果不存在任何冲突，则将 RowSet 对象中的更改写入数据源。如果存在冲突，则不写入任何更改。RIOptimisticProvider 实现使用此等级。

      • GRADE_CHECK_ALL_AT_COMMIT - 一个高等级的乐观同步。返回此级别的 SyncProvider 实现将检查所有的行，包括在非连接 RowSet 对象中没有更改的行。因此，当同步成功完成时，对底层数据源中的行进行的任何更改将反映在非连接 RowSet 对象中。

      • GRADE_LOCK_WHEN_MODIFIED - 一个悲观等级的同步。返回此等级的 SyncProvider 实现将锁定原始数据源中的行（该行与 RowSet 对象中更改的行对应），以减少其他进程修改数据源中同一数据的可能性。

      • GRADE_LOCK_WHEN_LOADED - 一个较高的悲观同步等级。返回此等级的 SyncProvider 实现将锁定用于填充 RowSet 对象的原始查询所影响的整个视图和/或表。

      3.3 锁定

      JSR 114 定义一个常量集，它指定是否对 RowSet 对象的底层数据源进行了某些锁定，如果是，它还指定进行锁定的构造。当 RowSet 对象从数据源断开时，这些锁定将保留在数据源上。

      这些常量应被视为对等级常量的补充。当 RowSet 对象从其数据源断开时，多数等级设置的默认设置要求不保留任何数据源锁定。等级 GRADE_LOCK_WHEN_MODIFIED 和 GRADE_LOCK_WHEN_LOADED 允许非连接 RowSet 对象对锁定程度进行细粒度控制。

      • DATASOURCE_NO_LOCK - 在原始的数据源上不保留任何锁定。如果 RowSet 对象没有其他指示，则这是所有 SyncProvider 实现的默认锁定设置。

      • DATASOURCE_ROW_LOCK - 对行进行锁定，用于填充 RowSet 对象的原始 SQL 查询会涉及这些行。

      • DATASOURCE_TABLE_LOCK - 对所有表进行锁定，用于填充 RowSet 对象的查询会涉及这些表。

      • DATASOURCE_DB_LOCK 对 RowSet 对象使用的整个数据源进行锁定。

      3.4 可更新的视图

      使用 SQL VIEW 中的数据可以填充 RowSet 对象。以下常量指示 SyncProvider 对象是否可以更新从中衍生出 VIEW 的表中的数据。

      • UPDATABLE_VIEW_SYNC 指示 SyncProvider 实现支持对从中衍生出用于填充 RowSet 对象的 SQL VIEW 的表的同步。

      • NONUPDATABLE_VIEW_SYNC 指示 SyncProvider 实现不支持对从中衍生出用于填充 RowSet 对象的 SQL VIEW 的表的同步。

      3.5 SyncProvider 等级和锁定的用法

      在下面的示例中，引用 CachedRowSetImpl 实现通过调用 setSyncProvider 方法重新配置其当前 SyncProvider 对象。

          CachedRowSetImpl crs = new CachedRowSetImpl();
    crs.setSyncProvider("com.foo.bar.HASyncProvider");
      应用程序通过非连接 RowSet 对象可以检索当前正在使用的 SyncProvider 对象。它也可以检索实现提供者的同步等级和当前正在使用的锁定程度。另外，应用程序可以灵活地设置要使用的锁定程度，从而增加成功同步的可能性。以下代码片段展示了这些操作。
          SyncProvider sync = crs.getSyncProvider();

    switch (sync.getProviderGrade()) {
    case: SyncProvider.GRADE_CHECK_ALL_AT_COMMIT
         //A high grade of optimistic synchronization
    break;
    case: SyncProvider.GRADE_CHECK_MODIFIED_AT_COMMIT
         //A low grade of optimistic synchronization
    break;
    case: SyncProvider.GRADE_LOCK_WHEN_LOADED
         // A pessimistic synchronization grade
    break;
    case: SyncProvider.GRADE_LOCK_WHEN_MODIFIED
         // A pessimistic synchronization grade
    break;
    case: SyncProvider.GRADE_NONE
      // No synchronization with the originating data source provided
    break;
    }

    switch (sync.getDataSourcLock() {
      case: SyncProvider.DATASOURCE_DB_LOCK
       // A lock is placed on the entire datasource that is used by the
       // RowSet object
       break;

      case: SyncProvider.DATASOURCE_NO_LOCK
       // No locks remain on the  originating data source.
      break;

      case: SyncProvider.DATASOURCE_ROW_LOCK
       // A lock is placed on the rows that are  touched by the original
       // SQL statement used to populate
       // the RowSet object that is using the SyncProvider
       break;

      case: DATASOURCE_TABLE_LOCK
       // A lock is placed on  all tables that are touched by the original
       // SQL statement used to populated
       // the RowSet object that is using the SyncProvider
       break;
      使用 SyncFactory 类中的静态实用工具方法也能够确定当前向 SyncFactory 注册的 SyncProvider 实现所组成的列表。
              Enumeration e = SyncFactory.getRegisteredProviders();

    4.0 解决同步冲突

    接口 SyncResolver 提供了一种应用程序手动确定发生冲突时应执行的操作的方式。当 CachedRowSet 方法 acceptChanges 完成并检测到一个或多个冲突时，它将抛出一个 SyncProviderException 对象。应用程序可以捕获该异常，并通过调用方法 SyncProviderException.getSyncResolver() 使它检索 SyncResolver 对象。

    SyncResolver 对象是实现了 SyncResolver 接口的一种特殊 CachedRowSet 对象或 JdbcRowSet 对象，它逐行检查冲突。它与同步的 RowSet 对象完全相同，区别在于它仅包含数据源中导致冲突的数据。将所有其他列值都设置为 null。为了从一个冲突值导航到另一个冲突值，SyncResolver 对象提供了方法 nextConflict 和 previousConflict。

    SyncResolver 接口也提供了一些方法，用于执行以下操作：

    • 查明冲突是否涉及到更新、删除或插入
    • 获取数据源中导致冲突的值
    • 设置应在数据源中的值（如果它需要更改）或设置应在 RowSet 对象中的值（如果它需要更改）

    在调用 CachedRowSet 方法 acceptChanges 时，它会委托给 RowSet 对象的 SyncProvider 对象。实现的 SyncProvider 对象提供 writer 的方式决定对冲突执行检查的级别（等级）。完成所有的冲突检查并且找到一个或多个冲突之后，方法 acceptChanges 会抛出一个 SyncProviderException 对象。应用程序可以捕获该异常，并使用该异常获取 SyncResolver 对象。

    然后，应用程序可以使用 SyncResolver 方法获取关于每个冲突的信息，并决定要执行的操作。如果应用程序逻辑或用户决定 RowSet 对象中的值应该保留，那么应用程序或用户可以使用它重写数据源值。

    SyncResolver 接口的注释有更多详细信息。

    5.0 相关的规范

    • JNDI 1.3
    • Java Logging API

    6.0 相关的文档

    • 系统属性
    • 资源文件
    • JDBC 连接的数据源

    概述 软件包 类 使用 树 已过时 索引 帮助
            JavaTM 2 Platform
    Standard Ed. 6
    上一个软件包 下一个软件包 框架 无框架


javax.sql.rowset.spi 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql.rowset.spi 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.sql.rowset.spi.SyncFactory
    • javax.sql.rowset.spi.SyncProvider
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • java.sql.SQLException (implements java.lang.Iterable<T>)
          • javax.sql.rowset.spi.SyncFactoryException
          • javax.sql.rowset.spi.SyncProviderException

接口分层结构

  • javax.sql.RowSetReader
    • javax.sql.rowset.spi.XmlReader
  • javax.sql.RowSetWriter
    • javax.sql.rowset.spi.TransactionalWriter
    • javax.sql.rowset.spi.XmlWriter
  • java.sql.Wrapper
    • java.sql.ResultSet
      • javax.sql.RowSet
        • javax.sql.rowset.spi.SyncResolver
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.sql.rowset.spi 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.sql.rowset.spi
的使用

使用 javax.sql.rowset.spi 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 使用的 javax.sql.rowset.spi 中的类
SyncProvider
为非连接 RowSet 对象提供 reader/writer 功能的同步机制。
SyncProviderException
指示 SyncProvider 机制发生的错误。

javax.sql.rowset.spi 使用的 javax.sql.rowset.spi 中的类
SyncFactory
该服务提供者接口 (SPI) 机制可以生成由非连接 RowSet 对象使用的 SyncProvider 实例。
SyncFactoryException
指示 SyncFactory 机制发生的错误。
SyncProvider
为非连接 RowSet 对象提供 reader/writer 功能的同步机制。
SyncProviderException
指示 SyncProvider 机制发生的错误。
SyncResolver
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.spi.SyncFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncFactory
的使用

使用 SyncFactory 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 SyncFactory 的使用

返回 SyncFactory 的 javax.sql.rowset.spi 中的方法
static SyncFactory SyncFactory.getSyncFactory()
返回一个 SyncFactory。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.spi.SyncFactoryException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncFactoryException
的使用

使用 SyncFactoryException 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 SyncFactoryException 的使用

抛出 SyncFactoryException 的 javax.sql.rowset.spi 中的方法
static SyncProvider | SyncFactory.getInstance(String providerID) 返回 providerID 标识的 SyncProvider 实例。
static Logger | SyncFactory.getLogger() 返回应用程序的日志对象，以获取 SyncProvider 实现发送的同步事件。
static Enumeration<SyncProvider> | SyncFactory.getRegisteredProviders() 返回当前已注册的同步提供者所组成的枚举。
static void | SyncFactory.registerProvider(String providerID) 将给定的同步提供者添加到工厂注册器。
static void | SyncFactory.setJNDIContext(Context ctx) 设置初始 JNDI 上下文，通过该上下文可以从 JNDI 名称空间获取 SyncProvider 实现
static void | SyncFactory.unregisterProvider(String providerID) 从工厂 SPI 注册器移除指派的当前已注册同步提供者。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.spi.SyncProvider 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncProvider
的使用

使用 SyncProvider 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 中 SyncProvider 的使用

返回 SyncProvider 的 javax.sql.rowset 中的方法
 SyncProvider CachedRowSet.getSyncProvider()
获取此 CachedRowSet 对象的 SyncProvider 实现。

javax.sql.rowset.spi 中 SyncProvider 的使用

返回 SyncProvider 的 javax.sql.rowset.spi 中的方法
static SyncProvider SyncFactory.getInstance(String providerID)
返回 providerID 标识的 SyncProvider 实例。

返回变量类型为 SyncProvider 的类型的 javax.sql.rowset.spi 中的方法
static Enumeration<SyncProvider> SyncFactory.getRegisteredProviders()
返回当前已注册的同步提供者所组成的枚举。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.spi.SyncProviderException 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.spi.SyncProviderException
的使用

使用 SyncProviderException 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 中 SyncProviderException 的使用

抛出 SyncProviderException 的 javax.sql.rowset 中的方法
void | CachedRowSet.acceptChanges() 将对此 CachedRowSet 对象所做的行更新、插入以及删除更改传播到底层数据源。
void | CachedRowSet.acceptChanges(Connection con) 将所有行更新、插入以及删除更改传播到支持此 CachedRowSet 对象的数据源，使用指定的 Connection 对象建立到数据源的连接。

javax.sql.rowset.spi 中 SyncProviderException 的使用

抛出 SyncProviderException 的 javax.sql.rowset.spi 中的方法
abstract int | SyncProvider.getDataSourceLock() 返回在此 SyncProvider 实现中活动的当前数据源锁定严重性级别。
abstract void | SyncProvider.setDataSourceLock(int datasource_lock) 按照 datasource_lock 指示的级别在底层数据源上设置锁定。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.spi.SyncResolver 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.SyncResolver
的使用

使用 SyncResolver 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 SyncResolver 的使用

返回 SyncResolver 的 javax.sql.rowset.spi 中的方法
 SyncResolver SyncProviderException.getSyncResolver()
获取为此 SyncProviderException 对象设置的 SyncResolver 对象，如果没有设置，则获取包含在参考实现中的默认 SyncResolver 实现的实例。

参数类型为 SyncResolver 的 javax.sql.rowset.spi 中的方法
 void SyncProviderException.setSyncResolver(SyncResolver syncResolver)
将此 SyncProviderException 对象的 SyncResolver 对象设置为提供的对象。

参数类型为 SyncResolver 的 javax.sql.rowset.spi 中的构造方法
SyncProviderException(SyncResolver syncResolver)
构造带指定 SyncResolver 实例的 SyncProviderException 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.spi.TransactionalWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.TransactionalWriter
的使用

没有 javax.sql.rowset.spi.TransactionalWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.spi.XmlReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.XmlReader
的使用

没有 javax.sql.rowset.spi.XmlReader 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.spi.XmlWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.spi.XmlWriter
的使用

没有 javax.sql.rowset.spi.XmlWriter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.BaseRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.BaseRowSet
的使用

没有 javax.sql.rowset.BaseRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.CachedRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.CachedRowSet
的使用

使用 CachedRowSet 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 CachedRowSet 的使用

javax.sql.rowset 中 CachedRowSet 的子接口
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

返回 CachedRowSet 的 javax.sql.rowset 中的方法
CachedRowSet | CachedRowSet.createCopy() 创建一个 RowSet 对象，它是此 CachedRowSet 对象中数据的深层副本。
CachedRowSet | CachedRowSet.createCopyNoConstraints() 创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象数据的深层副本，但是独立于此 CachedRowSet 对象。
CachedRowSet | CachedRowSet.createCopySchema() 创建一个 CachedRowSet 对象，它是此 CachedRowSet 对象的空副本。
CachedRowSet | JoinRowSet.toCachedRowSet() 创建一个包含此 JoinRowSet 对象中数据的新 CachedRowSet 对象，可以使用 CachedRowSet 对象的 SyncProvider 对象将此 JoinRowSet 对象保存到数据源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.FilteredRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.FilteredRowSet
的使用

没有 javax.sql.rowset.FilteredRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.JdbcRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.JdbcRowSet
的使用

没有 javax.sql.rowset.JdbcRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.JoinRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.JoinRowSet
的使用

没有 javax.sql.rowset.JoinRowSet 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.Joinable 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.Joinable
的使用

使用 Joinable 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 Joinable 的使用

javax.sql.rowset 中 Joinable 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

参数类型为 Joinable 的 javax.sql.rowset 中的方法
 void JoinRowSet.addRowSet(Joinable rowset)
将给定的 RowSet 对象添加到此 JoinRowSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.Predicate 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.Predicate
的使用

使用 Predicate 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 Predicate 的使用

返回 Predicate 的 javax.sql.rowset 中的方法
 Predicate FilteredRowSet.getFilter()
获取此 FilteredRowSet 对象的活动过滤器。

参数类型为 Predicate 的 javax.sql.rowset 中的方法
 void FilteredRowSet.setFilter(Predicate p)
将给定的 Predicate 对象应用到此 FilteredRowSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.RowSetMetaDataImpl 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.RowSetMetaDataImpl
的使用

没有 javax.sql.rowset.RowSetMetaDataImpl 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.rowset.RowSetWarning 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.rowset.RowSetWarning
的使用

使用 RowSetWarning 的软件包
javax.sql.rowset JDBC RowSet 实现的标准接口和基类。

javax.sql.rowset 中 RowSetWarning 的使用

返回 RowSetWarning 的 javax.sql.rowset 中的方法
RowSetWarning | RowSetWarning.getNextWarning() 获取链接到此 SQLWarning 对象的警告。
RowSetWarning | CachedRowSet.getRowSetWarnings() 获取此 RowSet 对象上的调用报告的第一个警告。
RowSetWarning | JdbcRowSet.getRowSetWarnings() 获取此 JdbcRowSet 对象上的调用报告的第一个警告。

参数类型为 RowSetWarning 的 javax.sql.rowset 中的方法
 void RowSetWarning.setNextWarning(RowSetWarning warning)
将 warning 设置为下一个警告，即连接到此 RowSetWarning 对象的警告。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.rowset.WebRowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.rowset.WebRowSet
的使用

使用 WebRowSet 的软件包
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset 中 WebRowSet 的使用

javax.sql.rowset 中 WebRowSet 的子接口
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。

javax.sql.rowset.spi 中 WebRowSet 的使用

参数类型为 WebRowSet 的 javax.sql.rowset.spi 中的方法
void | XmlReader.readXML(WebRowSet caller, Reader reader) 从给定的 XML 格式的输入流读取并解析给定的 WebRowSet 对象。
void | XmlWriter.writeXML(WebRowSet caller, Writer writer) 将给定的 WebRowSet 对象以 XML 文档的形式编写到指定的 java.io.Writer 输出流。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.CommonDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.CommonDataSource
的使用

使用 CommonDataSource 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 CommonDataSource 的使用

javax.sql 中 CommonDataSource 的子接口
interface | ConnectionPoolDataSource PooledConnection 对象的工厂。
interface | DataSource 该工厂用于提供到此 DataSource 对象所表示的物理数据源的连接。
interface | XADataSource 在内部使用的 XAConnection 对象的工厂。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.ConnectionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.ConnectionEvent
的使用

使用 ConnectionEvent 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 ConnectionEvent 的使用

参数类型为 ConnectionEvent 的 javax.sql 中的方法
void | ConnectionEventListener.connectionClosed(ConnectionEvent event) 通知此 ConnectionEventListener 应用程序已对其入池连接的表示形式调用 close 方法。
void | ConnectionEventListener.connectionErrorOccurred(ConnectionEvent event) 通知此 ConnectionEventListener 发生了严重错误，入池连接不再可用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.ConnectionEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.ConnectionEventListener
的使用

使用 ConnectionEventListener 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 ConnectionEventListener 的使用

参数类型为 ConnectionEventListener 的 javax.sql 中的方法
void | PooledConnection.addConnectionEventListener(ConnectionEventListener listener) 注册给定的事件侦听器，以便在此 PooledConnection 对象上发生事件时它将得到通知。
void | PooledConnection.removeConnectionEventListener(ConnectionEventListener listener) 从在此 PooledConnection 对象上发生事件时得到通知的组件所组成的列表中移除给定的事件侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.ConnectionPoolDataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.ConnectionPoolDataSource
的使用

没有 javax.sql.ConnectionPoolDataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.DataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.DataSource
的使用

没有 javax.sql.DataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.PooledConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.PooledConnection
的使用

使用 PooledConnection 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 PooledConnection 的使用

javax.sql 中 PooledConnection 的子接口
 interface XAConnection
为分布式事务提供支持的对象。

返回 PooledConnection 的 javax.sql 中的方法
PooledConnection | ConnectionPoolDataSource.getPooledConnection() 尝试建立可用作入池连接的物理数据库连接。
PooledConnection | ConnectionPoolDataSource.getPooledConnection(String user, String password) 尝试建立可用作入池连接的物理数据库连接。

参数类型为 PooledConnection 的 javax.sql 中的构造方法
ConnectionEvent(PooledConnection con)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象进行初始化。
ConnectionEvent(PooledConnection con, SQLException ex)
构造一个 ConnectionEvent 对象，使用给定的 PooledConnection 对象和 SQLException 对象进行初始化。
StatementEvent(PooledConnection con, PreparedStatement statement)
用指定的 PooledConnection 和 PreparedStatement 构造 StatementEvent。
StatementEvent(PooledConnection con, PreparedStatement statement, SQLException exception)
用指定的 PooledConnection、PreparedStatement 和 SQLException 构造 StatementEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.RowSet 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSet
的使用

使用 RowSet 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。
javax.sql.rowset.spi | 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql 中 RowSet 的使用

参数类型为 RowSet 的 javax.sql 中的构造方法
RowSetEvent(RowSet source)
构造一个 RowSetEvent 对象，并使用给定的 RowSet 对象进行初始化。

javax.sql.rowset 中 RowSet 的使用

javax.sql.rowset 中 RowSet 的子接口
interface | CachedRowSet 所有标准 CachedRowSet 实现都必须实现的接口。
interface | FilteredRowSet 所有标准 FilteredRowSet 实现都必须实现的标准接口。
interface | JdbcRowSet 所有标准 JdbcRowSet 实现都必须实现的标准接口。
interface | JoinRowSet JoinRowSet 接口提供了一种机制，用于将取自不同 RowSet 对象的相关数据组合到一个 JoinRowSet 对象中，该对象表示一个 SQL JOIN。
interface | WebRowSet 所有 WebRowSet 的实现都必须实现的标准接口。

返回 RowSet 的 javax.sql.rowset 中的方法
 RowSet CachedRowSet.createShared()
返回一个新的 RowSet 对象，支持该对象的数据与此 CachedRowSet 对象的相同。

参数类型为 RowSet 的 javax.sql.rowset 中的方法
void | JoinRowSet.addRowSet(RowSet[] rowset, int[] columnIdx) 将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列索引数组中的匹配列。
void | JoinRowSet.addRowSet(RowSet[] rowset, String[] columnName) 将给定 RowSet 对象数组中包含的一个或多个 RowSet 对象添加到此 JoinRowSet 对象，并且将每个 RowSet 对象的匹配列设置为给定列名数组中的匹配列。
void | JoinRowSet.addRowSet(RowSet rowset, int columnIdx) 将给定的 RowSet 对象添加到此 JoinRowSet 对象，并将指定的列设置为 RowSet 对象的匹配列。
void | JoinRowSet.addRowSet(RowSet rowset, String columnName) 将 rowset 添加到此 JoinRowSet 对象，并将指定的列设置为匹配列。
boolean | Predicate.evaluate(RowSet rs) 此方法通常称为 FilteredRowSet 对象内部方法（非公共），它控制 RowSet 对象的指针从一行移动到下一行。

javax.sql.rowset.spi 中 RowSet 的使用

javax.sql.rowset.spi 中 RowSet 的子接口
 interface SyncResolver
定义一个框架，当发生同步冲突时，它允许应用程序使用手工决策树来确定应该执行的操作。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.RowSetEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.RowSetEvent
的使用

使用 RowSetEvent 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

javax.sql 中 RowSetEvent 的使用

参数类型为 RowSetEvent 的 javax.sql 中的方法
void | RowSetListener.cursorMoved(RowSetEvent event) 通知已注册侦听器 RowSet 对象的指针已移动。
void | RowSetListener.rowChanged(RowSetEvent event) 通知已注册侦听器 RowSet 对象的其中一行发生了更改。
void | RowSetListener.rowSetChanged(RowSetEvent event) 通知已注册侦听器给定 RowSetEvent 对象中的 RowSet 对象已更改其全部内部。

javax.sql.rowset 中 RowSetEvent 的使用

参数类型为 RowSetEvent 的 javax.sql.rowset 中的方法
 void CachedRowSet.rowSetPopulated(RowSetEvent event, int numRows)
通知已注册侦听器给定 RowSetEvent 对象中的某个 RowSet 对象已经填充了多个附加行。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.RowSetInternal 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetInternal
的使用

使用 RowSetInternal 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 RowSetInternal 的使用

参数类型为 RowSetInternal 的 javax.sql 中的方法
void | RowSetReader.readData(RowSetInternal caller) 读取调用 RowSet 对象的新内容。
boolean | RowSetWriter.writeData(RowSetInternal caller) 将此 RowSetWriter 对象的 rowset 中的更改写回它从中获取数据的数据源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.RowSetListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetListener
的使用

使用 RowSetListener 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

javax.sql 中 RowSetListener 的使用

参数类型为 RowSetListener 的 javax.sql 中的方法
void | RowSet.addRowSetListener(RowSetListener listener) 注册给定侦听器，以便此 RowSet 对象上发生事件时将得到通知。
void | RowSet.removeRowSetListener(RowSetListener listener) 从在此 RowSet 对象上发生事件时得到通知的组件所组成的列表中移除指定的侦听器。

javax.sql.rowset 中 RowSetListener 的使用

参数类型为 RowSetListener 的 javax.sql.rowset 中的方法
void | BaseRowSet.addRowSetListener(RowSetListener listener) 只要在此 RowSet 对象上发生事件，就将通知该侦听器。
void | BaseRowSet.removeRowSetListener(RowSetListener listener) 从此 RowSet 对象的侦听器列表中移除指定的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.RowSetMetaData 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetMetaData
的使用

使用 RowSetMetaData 的软件包
javax.sql | 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。
javax.sql.rowset | JDBC RowSet 实现的标准接口和基类。

javax.sql 中 RowSetMetaData 的使用

参数类型为 RowSetMetaData 的 javax.sql 中的方法
 void RowSetInternal.setMetaData(RowSetMetaData md)
将给定的 RowSetMetaData 对象设置为此 RowSet 对象的 RowSetMetaData 对象。

javax.sql.rowset 中 RowSetMetaData 的使用

实现 RowSetMetaData 的 javax.sql.rowset 中的类
 class RowSetMetaDataImpl
为设置和获取关于 RowSet 对象列的元数据信息的方法提供实现。

参数类型为 RowSetMetaData 的 javax.sql.rowset 中的方法
 void CachedRowSet.setMetaData(RowSetMetaData md)
使用给定的 RowSetMetaData 对象设置此 CachedRowSet 对象的元数据。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.RowSetReader 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetReader
的使用

使用 RowSetReader 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 RowSetReader 的使用

javax.sql.rowset.spi 中 RowSetReader 的子接口
 interface XmlReader
一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。

返回 RowSetReader 的 javax.sql.rowset.spi 中的方法
abstract  RowSetReader SyncProvider.getRowSetReader()
返回 javax.sql.RowSetReader 对象，它可以用于填充带有数据的 RowSet 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.RowSetWriter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.RowSetWriter
的使用

使用 RowSetWriter 的软件包
javax.sql.rowset.spi 第三方供应商在其同步提供者的实现中必须使用的标准类和接口。

javax.sql.rowset.spi 中 RowSetWriter 的使用

javax.sql.rowset.spi 中 RowSetWriter 的子接口
interface | TransactionalWriter 一个专用接口，用来方便地扩展标准 SyncProvider 抽象类以便拥有细粒度的事务控制。
interface | XmlWriter 一个专用接口，用来方便地扩展 SyncProvider 抽象类以用于面向 XML 的同步提供者。

返回 RowSetWriter 的 javax.sql.rowset.spi 中的方法
abstract  RowSetWriter SyncProvider.getRowSetWriter()
返回 javax.sql.RowSetWriter 对象，它可以用于将 RowSet 对象的数据写回底层数据源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.sql.StatementEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.sql.StatementEvent
的使用

使用 StatementEvent 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 StatementEvent 的使用

参数类型为 StatementEvent 的 javax.sql 中的方法
void | StatementEventListener.statementClosed(StatementEvent event) 检测到 PreparedStatement 关闭时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。
void | StatementEventListener.statementErrorOccurred(StatementEvent event) 检测到 PreparedStatement 无效时，驱动程序对所有在连接上注册的 StatementEventListener 调用此方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.StatementEventListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.StatementEventListener
的使用

使用 StatementEventListener 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 StatementEventListener 的使用

参数类型为 StatementEventListener 的 javax.sql 中的方法
void | PooledConnection.addStatementEventListener(StatementEventListener listener) 向此 PooledConnection 对象注册一个 StatementEventListener。
void | PooledConnection.removeStatementEventListener(StatementEventListener listener) 从一个组件列表中移除指定的 StatementEventListener，该列表由驱动程序检测到 PreparedStatement 已关闭或无效时将获得通知的组件组成。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.XAConnection 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.XAConnection
的使用

使用 XAConnection 的软件包
javax.sql 为通过 JavaTM 编程语言进行服务器端数据源访问和处理提供 API。

javax.sql 中 XAConnection 的使用

返回 XAConnection 的 javax.sql 中的方法
XAConnection | XADataSource.getXAConnection() 尝试建立可在分布式事务中使用的物理数据库连接。
XAConnection | XADataSource.getXAConnection(String user, String password) 使用给定的用户名和密码，尝试建立一个物理数据库连接。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.sql.XADataSource 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.sql.XADataSource
的使用

没有 javax.sql.XADataSource 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractAction (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 AbstractAction

java.lang.Object
    继承者  javax.swing.AbstractAction
所有已实现的接口：
ActionListener, Serializable, Cloneable, EventListener, Action
直接已知子类：
BasicDesktopPaneUI.CloseAction, BasicDesktopPaneUI.MaximizeAction, BasicDesktopPaneUI.MinimizeAction, BasicDesktopPaneUI.NavigateAction, BasicDesktopPaneUI.OpenAction, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.UpdateAction, BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicSliderUI.ActionScroller, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreePageAction, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction, MetalFileChooserUI.DirectoryComboBoxAction, TextAction
public abstract class AbstractAction
extends Object
implements Action, Cloneable, Serializable

此类提供 JFC Action 接口的默认实现。它定义了一些标准行为，比如 Action 对象属性（icon、text 和 enabled）的 get 和 set 方法。开发人员只需为此抽象类创建子类并定义 actionPerformed 方法即可。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Action

字段摘要
protected SwingPropertyChangeSupport | changeSupport 如果已经注册了任意 PropertyChangeListener，则 changeSupport 字段负责描述它们。
protected boolean | enabled 指定是否启用操作；默认值为 true。
从接口 javax.swing.Action 继承的字段
ACCELERATOR_KEY, ACTION_COMMAND_KEY, DEFAULT, DISPLAYED_MNEMONIC_INDEX_KEY, LARGE_ICON_KEY, LONG_DESCRIPTION, MNEMONIC_KEY, NAME, SELECTED_KEY, SHORT_DESCRIPTION, SMALL_ICON
构造方法摘要
AbstractAction()
用默认描述字符串和默认图标定义一个 Action 对象。
AbstractAction(String name)
用指定描述字符串和默认图标定义一个 Action 对象。
AbstractAction(String name, Icon icon)
用指定描述字符串和指定图标定义一个 Action 对象。
方法摘要
 void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。
protected  Object clone()
复制抽象操作。
protected  void firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定 (bound) 属性的改变。
 Object[] getKeys()
返回 Object 的数组，这些对象是一些已经为其设置此 AbstractAction 值的键，如果没有已经设置该值的键，则返回 null。
 PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 AbstractAction 中的所有 PropertyChangeListener 组成的数组。
 Object getValue(String key)
获得与指定键关联的 Object。
 boolean isEnabled()
如果启用该操作，则返回 true。
 void putValue(String key, Object newValue)
设置与指定键关联的 Value。
 void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表中移除一个 PropertyChangeListener。
 void setEnabled(boolean newValue)
启用或禁用该操作。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.event.ActionListener 继承的方法
actionPerformed

字段详细信息

enabled

protected boolean enabled
指定是否启用操作；默认值为 true。

changeSupport

protected SwingPropertyChangeSupport changeSupport
如果已经注册了任意 PropertyChangeListener，则 changeSupport 字段负责描述它们。

构造方法详细信息

AbstractAction

public AbstractAction()
用默认描述字符串和默认图标定义一个 Action 对象。

AbstractAction

public AbstractAction(String name)
用指定描述字符串和默认图标定义一个 Action 对象。

AbstractAction

public AbstractAction(String name,
                      Icon icon)
用指定描述字符串和指定图标定义一个 Action 对象。

方法详细信息

getValue

public Object getValue(String key)
获得与指定键关联的 Object。

指定者：
接口 Action 中的 getValue
参数：
key - 包含指定 key 的字符串
返回：
用此键存储的绑定 Object；如果没有键，则将返回 null
另请参见：
Action.getValue(java.lang.String)

putValue

public void putValue(String key,
                     Object newValue)
设置与指定键关联的 Value。

指定者：
接口 Action 中的 putValue
参数：
key - 标识所存储对象的 String
newValue - 将使用此键存储的 Object
另请参见：
Action.putValue(java.lang.String, java.lang.Object)

isEnabled

public boolean isEnabled()
如果启用该操作，则返回 true。

指定者：
接口 Action 中的 isEnabled
返回：
如果启用该操作，则返回 true；否则返回 false
另请参见：
Action.isEnabled()

setEnabled

public void setEnabled(boolean newValue)
启用或禁用该操作。

指定者：
接口 Action 中的 setEnabled
参数：
newValue - 为 true 表示启用该操作，为 false 表示禁用该操作
另请参见：
Action.setEnabled(boolean)

getKeys

public Object[] getKeys()
返回 Object 的数组，这些对象是一些已经为其设置此 AbstractAction 值的键，如果没有已经设置该值的键，则返回 null。

返回：
一个键对象数组，如果没有已经设置好值的键，则返回 null
从以下版本开始：
1.3

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
支持报告绑定 (bound) 属性的改变。当改变了绑定属性时可调用此方法，它将向所有已注册的 PropertyChangeListener 发送相应的 PropertyChangeEvent。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。该侦听器是为所有属性注册的。

在响应对绑定属性（例如 setFont、setBackground 或 setForeground）的设置时，将触发一个 PropertyChangeEvent。注意，如果当前组件将继承其容器的前景、背景或字体，则在响应所继承属性中的更改时不会触发任何事件。

指定者：
接口 Action 中的 addPropertyChangeListener
参数：
listener - 要添加的 PropertyChangeListener
另请参见：
Action.addPropertyChangeListener(java.beans.PropertyChangeListener)

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表中移除一个 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

指定者：
接口 Action 中的 removePropertyChangeListener
参数：
listener - 要移除的 PropertyChangeListener
另请参见：
Action.removePropertyChangeListener(java.beans.PropertyChangeListener)

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 AbstractAction 中的所有 PropertyChangeListener 组成的数组。

返回：
添加的所有 PropertyChangeListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

clone

protected Object clone()
                throws CloneNotSupportedException
复制抽象操作。此方法给出了它自己的键/值列表的副本，该副本不能通过 Object.clone() 为您处理。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AbstractButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 AbstractButton

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, SwingConstants
直接已知子类：
JButton, JMenuItem, JToggleButton
public abstract class AbstractButton
extends JComponent
implements ItemSelectable, SwingConstants

定义按钮和菜单项的一般行为。

按钮可以进行配置，以及通过 Action 进行某种程度的控制。使用带有按钮的 Action 具有除直接配置按钮之外的许多优点。有关更多信息，请参阅支持 Action 的 Swing 组件，在 The Java Tutorial 中的 How to Use Actions 一节中可以找到更多信息。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Buttons, Check Boxes, and Radio Buttons 一节。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected class | AbstractButton.AccessibleAbstractButton 此类实现对 AbstractButton 类的可访问性支持。
protected class | AbstractButton.ButtonChangeListener 将 ChangeListener 扩展为可序列化的。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected ActionListener | actionListener 按钮模型的 ActionListener。
static String | BORDER_PAINTED_CHANGED_PROPERTY 标识是否绘制边框的更改。
protected ChangeEvent | changeEvent 每个按钮实例都只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
protected ChangeListener | changeListener 按钮模型的 changeListener。
static String | CONTENT_AREA_FILLED_CHANGED_PROPERTY 标识对按钮绘制的内容区域的更改。
static String | DISABLED_ICON_CHANGED_PROPERTY 标识禁用按钮时使用的图标的更改。
static String | DISABLED_SELECTED_ICON_CHANGED_PROPERTY 标识禁用并选定按钮时使用的图标的更改。
static String | FOCUS_PAINTED_CHANGED_PROPERTY 标识是否在边框拥有焦点时高亮显示。
static String | HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY 标识按钮的水平对齐方式的更改。
static String | HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY 标识按钮的水平文本位置的更改。
static String | ICON_CHANGED_PROPERTY 标识对表示该按钮的图标的更改。
protected ItemListener | itemListener 按钮模型的 ItemListener。
static String | MARGIN_CHANGED_PROPERTY 标识按钮的边界空白的更改。
static String | MNEMONIC_CHANGED_PROPERTY 标识按钮的助记符中的更改。
protected ButtonModel | model 确定按钮状态的数据模型。
static String | MODEL_CHANGED_PROPERTY 标识按钮模型中的更改。
static String | PRESSED_ICON_CHANGED_PROPERTY 标识对按下按钮时使用的图标的更改。
static String | ROLLOVER_ENABLED_CHANGED_PROPERTY 标识从启用翻转到禁用翻转或者从禁用翻转到启用翻转的更改。
static String | ROLLOVER_ICON_CHANGED_PROPERTY 标识对光标移动到按钮上时使用的图标的更改。
static String | ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY 标识对光标移动到按钮上并选定该按钮时使用的图标的更改。
static String | SELECTED_ICON_CHANGED_PROPERTY 标识对选定按钮时使用的图标的更改。
static String | TEXT_CHANGED_PROPERTY 标识按钮的文本中的更改。
static String | VERTICAL_ALIGNMENT_CHANGED_PROPERTY 标识按钮的垂直对齐方式的更改。
static String | VERTICAL_TEXT_POSITION_CHANGED_PROPERTY 标识按钮的垂直文本位置的更改。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
AbstractButton()
方法摘要
protected  void actionPropertyChanged(Action action, String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。
 void addActionListener(ActionListener l)
将一个 ActionListener 添加到按钮中。
 void addChangeListener(ChangeListener l)
向按钮添加一个 ChangeListener。
protected  void addImpl(Component comp, Object constraints, int index)
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。
 void addItemListener(ItemListener l)
将一个 ItemListener 添加到 checkbox 中。
protected  int checkHorizontalKey(int key, String exception)
验证 key 参数是否为 horizontalAlignment 和 horizontalTextPosition 属性的合法值。
protected  int checkVerticalKey(int key, String exception)
验证 key 参数是否为垂直属性的合法值。
protected  void configurePropertiesFromAction(Action a)
在此按钮上设置属性以匹配指定 Action 中的属性。
protected  ActionListener createActionListener()
protected  PropertyChangeListener createActionPropertyChangeListener(Action a)
创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。
protected  ChangeListener createChangeListener()
想以不同的方式处理 ChangeEvent 的子类可以重写此方法，以返回另一个 ChangeListener 实现。
protected  ItemListener createItemListener()
 void doClick()
以编程方式执行“单击”。
 void doClick(int pressTime)
以编程方式执行“单击”。
protected  void fireActionPerformed(ActionEvent event)
通知所有需要此事件类型的通知的已注册侦听器。
protected  void fireItemStateChanged(ItemEvent event)
通知所有需要此事件类型的通知的已注册侦听器。
protected  void fireStateChanged()
通知所有需要此事件类型的通知的已注册侦听器。
 Action getAction()
返回当前为此 ActionEvent 源设置的 Action，如果没有设置任何 Action，则返回 null。
 String getActionCommand()
返回此按钮的动作命令。
 ActionListener[] getActionListeners()
返回使用 addActionListener() 添加到此 AbstractButton 的所有 ActionListener 组成的数组。
 ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractButton 中的所有 ChangeListener 组成的数组。
 Icon getDisabledIcon()
返回禁用按钮时按钮使用的图标。
 Icon getDisabledSelectedIcon()
返回禁用并选择按钮时按钮使用的图标。
 int getDisplayedMnemonicIndex()
以索引形式返回字符，它表示助记符字符，外观应该对其提供装饰。
 boolean getHideActionText()
返回 hideActionText 属性的值，该属性确定按钮是否显示 Action 的文本。
 int getHorizontalAlignment()
返回图标和文本的水平对齐方式。
 int getHorizontalTextPosition()
返回文本相对于图标的水平位置。
 Icon getIcon()
返回默认图标。
 int getIconTextGap()
返回此按钮中显示的文本与图标之间的间隔量。
 ItemListener[] getItemListeners()
返回使用 addItemListener() 添加到此 AbstractButton 中的所有 ItemListener 组成的数组。
 String getLabel()
已过时。 - 由 getText 取代
 Insets getMargin()
返回按钮边框和标签之间的空白。
 int getMnemonic()
返回当前模型中的键盘助记符。
 ButtonModel getModel()
返回此按钮表示的模型。
 long getMultiClickThreshhold()
获取对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。
 Icon getPressedIcon()
返回按钮的按下图标。
 Icon getRolloverIcon()
返回按钮的翻转图标。
 Icon getRolloverSelectedIcon()
返回按钮的翻转选定图标。
 Icon getSelectedIcon()
返回按钮的选择图标。
 Object[] getSelectedObjects()
返回包含标签的数组（长度为 1），如果没有选择按钮，则返回 null。
 String getText()
返回按钮的文本。
 ButtonUI getUI()
返回呈现此组件的 L&F 对象。
 int getVerticalAlignment()
返回文本和图标的垂直对齐方式。
 int getVerticalTextPosition()
返回文本相对于图标的垂直位置。
 boolean imageUpdate(Image img, int infoflags, int x, int y, int w, int h)
重写的此方法在当前 Icon 的 Image 不等于传入的 Image img 时返回 false。
protected  void init(String text, Icon icon)
 boolean isBorderPainted()
获取 borderPainted 属性。
 boolean isContentAreaFilled()
获取 contentAreaFilled 属性。
 boolean isFocusPainted()
获取 paintFocus 属性。
 boolean isRolloverEnabled()
获取 rolloverEnabled 属性。
 boolean isSelected()
返回按钮的状态。
protected  void paintBorder(Graphics g)
如果 BorderPainted 属性为 true 并且按钮有边框，则绘制该按钮边框。
protected  String paramString()
返回此 AbstractButton 的字符串表示形式。
 void removeActionListener(ActionListener l)
从按钮中移除一个 ActionListener。
 void removeChangeListener(ChangeListener l)
从按钮中移除一个 ChangeListener。
 void removeItemListener(ItemListener l)
从按钮中移除一个 ItemListener。
 void removeNotify()
通知此组件它不再有父组件。
 void setAction(Action a)
设置 Action。
 void setActionCommand(String actionCommand)
设置此按钮的动作命令。
 void setBorderPainted(boolean b)
设置 borderPainted 属性。
 void setContentAreaFilled(boolean b)
设置 contentAreaFilled 属性。
 void setDisabledIcon(Icon disabledIcon)
设置按钮的禁用图标。
 void setDisabledSelectedIcon(Icon disabledSelectedIcon)
设置按钮的禁用选择图标。
 void setDisplayedMnemonicIndex(int index)
提供关于应该装饰文本中哪一个字符来表示助记符的外观提示。
 void setEnabled(boolean b)
启用（或禁用）按钮。
 void setFocusPainted(boolean b)
设置 paintFocus 属性，对于要绘制的焦点状态，该属性必须为 true。
 void setHideActionText(boolean hideActionText)
设置 hideActionText 属性，该属性确定按钮是否显示 Action 的文本。
 void setHorizontalAlignment(int alignment)
设置图标和文本的水平对齐方式。
 void setHorizontalTextPosition(int textPosition)
设置文本相对于图标的水平位置。
 void setIcon(Icon defaultIcon)
设置按钮的默认图标。
 void setIconTextGap(int iconTextGap)
如果图标和文本的属性都已设置，则此属性定义图标和文本之间的间隔。
 void setLabel(String label)
已过时。 - 由 setText(text) 取代
 void setLayout(LayoutManager mgr)
为此容器设置布局管理器，有关此方法的完整描述，请参阅 Container.setLayout(LayoutManager)。
 void setMargin(Insets m)
设置按钮边框和标签之间的空白。
 void setMnemonic(char mnemonic)
此方法现在已废弃，请使用 setMnemonic(int) 来设置按钮的助记符。
 void setMnemonic(int mnemonic)
设置当前模型上的键盘助记符。
 void setModel(ButtonModel newModel)
设置此按钮表示的模型。
 void setMultiClickThreshhold(long threshhold)
设置对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。
 void setPressedIcon(Icon pressedIcon)
设置按钮的按下图标。
 void setRolloverEnabled(boolean b)
设置 rolloverEnabled 属性，若需要翻转效果，该属性必须为 true。
 void setRolloverIcon(Icon rolloverIcon)
设置按钮的翻转图标。
 void setRolloverSelectedIcon(Icon rolloverSelectedIcon)
设置按钮的翻转选择图标。
 void setSelected(boolean b)
设置按钮的状态。
 void setSelectedIcon(Icon selectedIcon)
设置按钮的选择图标。
 void setText(String text)
设置按钮的文本。
 void setUI(ButtonUI ui)
设置呈现此组件的 L&F 对象。
 void setVerticalAlignment(int alignment)
设置图标和文本的垂直对齐方式。
 void setVerticalTextPosition(int textPosition)
设置文本相对于图标的垂直位置。
 void updateUI()
将 UI 属性重置为当前外观中的一个值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getAccessibleContext, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

MODEL_CHANGED_PROPERTY

public static final String MODEL_CHANGED_PROPERTY
标识按钮模型中的更改。

另请参见：
常量字段值

TEXT_CHANGED_PROPERTY

public static final String TEXT_CHANGED_PROPERTY
标识按钮的文本中的更改。

另请参见：
常量字段值

MNEMONIC_CHANGED_PROPERTY

public static final String MNEMONIC_CHANGED_PROPERTY
标识按钮的助记符中的更改。

另请参见：
常量字段值

MARGIN_CHANGED_PROPERTY

public static final String MARGIN_CHANGED_PROPERTY
标识按钮的边界空白的更改。

另请参见：
常量字段值

VERTICAL_ALIGNMENT_CHANGED_PROPERTY

public static final String VERTICAL_ALIGNMENT_CHANGED_PROPERTY
标识按钮的垂直对齐方式的更改。

另请参见：
常量字段值

HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY

public static final String HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY
标识按钮的水平对齐方式的更改。

另请参见：
常量字段值

VERTICAL_TEXT_POSITION_CHANGED_PROPERTY

public static final String VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
标识按钮的垂直文本位置的更改。

另请参见：
常量字段值

HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY

public static final String HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY
标识按钮的水平文本位置的更改。

另请参见：
常量字段值

BORDER_PAINTED_CHANGED_PROPERTY

public static final String BORDER_PAINTED_CHANGED_PROPERTY
标识是否绘制边框的更改。

另请参见：
常量字段值

FOCUS_PAINTED_CHANGED_PROPERTY

public static final String FOCUS_PAINTED_CHANGED_PROPERTY
标识是否在边框拥有焦点时高亮显示。

另请参见：
常量字段值

ROLLOVER_ENABLED_CHANGED_PROPERTY

public static final String ROLLOVER_ENABLED_CHANGED_PROPERTY
标识从启用翻转到禁用翻转或者从禁用翻转到启用翻转的更改。

另请参见：
常量字段值

CONTENT_AREA_FILLED_CHANGED_PROPERTY

public static final String CONTENT_AREA_FILLED_CHANGED_PROPERTY
标识对按钮绘制的内容区域的更改。

另请参见：
常量字段值

ICON_CHANGED_PROPERTY

public static final String ICON_CHANGED_PROPERTY
标识对表示该按钮的图标的更改。

另请参见：
常量字段值

PRESSED_ICON_CHANGED_PROPERTY

public static final String PRESSED_ICON_CHANGED_PROPERTY
标识对按下按钮时使用的图标的更改。

另请参见：
常量字段值

SELECTED_ICON_CHANGED_PROPERTY

public static final String SELECTED_ICON_CHANGED_PROPERTY
标识对选定按钮时使用的图标的更改。

另请参见：
常量字段值

ROLLOVER_ICON_CHANGED_PROPERTY

public static final String ROLLOVER_ICON_CHANGED_PROPERTY
标识对光标移动到按钮上时使用的图标的更改。

另请参见：
常量字段值

ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY

public static final String ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY
标识对光标移动到按钮上并选定该按钮时使用的图标的更改。

另请参见：
常量字段值

DISABLED_ICON_CHANGED_PROPERTY

public static final String DISABLED_ICON_CHANGED_PROPERTY
标识禁用按钮时使用的图标的更改。

另请参见：
常量字段值

DISABLED_SELECTED_ICON_CHANGED_PROPERTY

public static final String DISABLED_SELECTED_ICON_CHANGED_PROPERTY
标识禁用并选定按钮时使用的图标的更改。

另请参见：
常量字段值

model

protected ButtonModel model
确定按钮状态的数据模型。

changeListener

protected ChangeListener changeListener
按钮模型的 changeListener。

actionListener

protected ActionListener actionListener
按钮模型的 ActionListener。

itemListener

protected ItemListener itemListener
按钮模型的 ItemListener。

changeEvent

protected transient ChangeEvent changeEvent
每个按钮实例都只需要一个 ChangeEvent，因为事件的唯一状态是源属性。所生成的事件源总是 "this"。

构造方法详细信息

AbstractButton

public AbstractButton()
方法详细信息

setHideActionText

public void setHideActionText(boolean hideActionText)
设置 hideActionText 属性，该属性确定按钮是否显示 Action 的文本。只有在按钮上已安装了 Action 时，此方法才有用。

参数：
hideActionText - 如果按钮的 text 属性不应该反映 Action 的文本，则该参数为 true；默认情况下为 false
从以下版本开始：
1.6
另请参见：
支持 Action 的 Swing 组件

getHideActionText

public boolean getHideActionText()
返回 hideActionText 属性的值，该属性确定按钮是否显示 Action 的文本。只有在按钮上已安装了 Action 时，此方法才有用。

返回：
如果按钮的 text 属性不应该反映 Action 的文本，则返回 true；默认情况下返回 false
从以下版本开始：
1.6

getText

public String getText()
返回按钮的文本。

返回：
按钮的文本
另请参见：
setText(java.lang.String)

setText

public void setText(String text)
设置按钮的文本。

参数：
text - 用于设置文本的字符串
另请参见：
getText()

isSelected

public boolean isSelected()
返回按钮的状态。如果选定了切换按钮，则返回 true，否则返回 false。

返回：
如果选定了切换按钮，则返回 true，否则返回 false

setSelected

public void setSelected(boolean b)
设置按钮的状态。注意，此方法不会触发 actionEvent。调用 doClick 以执行程序上的动作更改。

参数：
b - 如果选择了按钮，则该参数为 true，否则为 false

doClick

public void doClick()
以编程方式执行“单击”。此方法的效果等同于用户按下并随后释放按钮。

doClick

public void doClick(int pressTime)
以编程方式执行“单击”。此方法的效果等同于用户按下并随后释放按钮。按钮在虚拟“按下”状态下停留 pressTime 毫秒的时间。

参数：
pressTime - “按下”按钮的时间，以毫秒为单位

setMargin

public void setMargin(Insets m)
设置按钮边框和标签之间的空白。将该空白设置为 null 会造成按钮使用默认空白。按钮的默认 Border 对象将使用该值来创建适当的空白。不过，如果在按钮上设置非默认边框，则由 Border 对象负责创建适当的空白（否则此属性将被忽略）。

参数：
m - 边框和标签之间的间隔

getMargin

public Insets getMargin()
返回按钮边框和标签之间的空白。

返回：
一个指定按钮边框和标签之间的空白的 Insets 对象
另请参见：
setMargin(java.awt.Insets)

getIcon

public Icon getIcon()
返回默认图标。

返回：
默认 Icon
另请参见：
setIcon(javax.swing.Icon)

setIcon

public void setIcon(Icon defaultIcon)
设置按钮的默认图标。如果没有显式地设置按下的图标，则此图标还被用作“按下”和“禁用”图标。

参数：
defaultIcon - 用作默认图像的图标
另请参见：
getIcon(), setPressedIcon(javax.swing.Icon)

getPressedIcon

public Icon getPressedIcon()
返回按钮的按下图标。

返回：
pressedIcon 属性
另请参见：
setPressedIcon(javax.swing.Icon)

setPressedIcon

public void setPressedIcon(Icon pressedIcon)
设置按钮的按下图标。

参数：
pressedIcon - 用作“按下”图像的图标
另请参见：
getPressedIcon()

getSelectedIcon

public Icon getSelectedIcon()
返回按钮的选择图标。

返回：
selectedIcon 属性
另请参见：
setSelectedIcon(javax.swing.Icon)

setSelectedIcon

public void setSelectedIcon(Icon selectedIcon)
设置按钮的选择图标。

参数：
selectedIcon - 用作“选择”图像的图标
另请参见：
getSelectedIcon()

getRolloverIcon

public Icon getRolloverIcon()
返回按钮的翻转图标。

返回：
rolloverIcon 属性
另请参见：
setRolloverIcon(javax.swing.Icon)

setRolloverIcon

public void setRolloverIcon(Icon rolloverIcon)
设置按钮的翻转图标。

参数：
rolloverIcon - 用作“翻转”图像的图标
另请参见：
getRolloverIcon()

getRolloverSelectedIcon

public Icon getRolloverSelectedIcon()
返回按钮的翻转选定图标。

返回：
rolloverSelectedIcon 属性
另请参见：
setRolloverSelectedIcon(javax.swing.Icon)

setRolloverSelectedIcon

public void setRolloverSelectedIcon(Icon rolloverSelectedIcon)
设置按钮的翻转选择图标。

参数：
rolloverSelectedIcon - 用作“选择翻转”图像的图标
另请参见：
getRolloverSelectedIcon()

getDisabledIcon

public Icon getDisabledIcon()
返回禁用按钮时按钮使用的图标。如果没有设置禁用图标，则此方法将调用转发给外观，以构造适当的禁用 Icon。

一些外观上可能没有呈现禁用图标，在这种情况下，它们将忽略此图标。

返回：
disabledIcon 属性
另请参见：
getPressedIcon(),
setDisabledIcon(javax.swing.Icon),
LookAndFeel.getDisabledIcon(javax.swing.JComponent, javax.swing.Icon)

setDisabledIcon

public void setDisabledIcon(Icon disabledIcon)
设置按钮的禁用图标。

参数：
disabledIcon - 用作禁用图像的图标
另请参见：
getDisabledIcon()

getDisabledSelectedIcon

public Icon getDisabledSelectedIcon()
返回禁用并选择按钮时按钮使用的图标。如果没有设置禁用选择图标，则将调用转发给 LookAndFeel，以从选择图标中（如果已设置）构造适当的禁用图标；否则将调用转发给 getDisabledIcon()。

一些外观上可能没有呈现禁用选择 Icon，在这种情况下，它们将忽略此图标。

返回：
disabledSelectedIcon 属性
另请参见：
getDisabledIcon(),
setDisabledSelectedIcon(javax.swing.Icon),
LookAndFeel.getDisabledSelectedIcon(javax.swing.JComponent, javax.swing.Icon)

setDisabledSelectedIcon

public void setDisabledSelectedIcon(Icon disabledSelectedIcon)
设置按钮的禁用选择图标。

参数：
disabledSelectedIcon - 用作禁用选择图像的图标
另请参见：
getDisabledSelectedIcon()

getVerticalAlignment

public int getVerticalAlignment()
返回文本和图标的垂直对齐方式。

返回：
verticalAlignment 属性，它是以下值之一：
  • SwingConstants.CENTER（默认值）
  • SwingConstants.TOP
  • SwingConstants.BOTTOM

setVerticalAlignment

public void setVerticalAlignment(int alignment)
设置图标和文本的垂直对齐方式。

参数：
alignment - 它是以下值之一：
  • SwingConstants.CENTER（默认值）
  • SwingConstants.TOP
  • SwingConstants.BOTTOM
抛出：
IllegalArgumentException - 如果对齐方式不是上面列出的合法值之一

getHorizontalAlignment

public int getHorizontalAlignment()
返回图标和文本的水平对齐方式。AbstractButton 的默认对齐方式为 SwingConstants.CENTER，但子类（如 JCheckBox）可以使用不同的默认对齐方式。

返回：
horizontalAlignment 属性，它是以下值之一：
  • SwingConstants.RIGHT
  • SwingConstants.LEFT
  • SwingConstants.CENTER
  • SwingConstants.LEADING
  • SwingConstants.TRAILING

setHorizontalAlignment

public void setHorizontalAlignment(int alignment)
设置图标和文本的水平对齐方式。AbstractButton 的默认对齐方式为 SwingConstants.CENTER，但子类（如 JCheckBox）可以使用不同的默认对齐方式。

参数：
alignment - 对齐方式的值，它是以下值之一：
  • SwingConstants.RIGHT
  • SwingConstants.LEFT
  • SwingConstants.CENTER
  • SwingConstants.LEADING
  • SwingConstants.TRAILING
抛出：
IllegalArgumentException - 如果对齐方式不是有效值之一

getVerticalTextPosition

public int getVerticalTextPosition()
返回文本相对于图标的垂直位置。

返回：
verticalTextPosition 属性，它是以下值之一：
  • SwingConstants.CENTER（默认值）
  • SwingConstants.TOP
  • SwingConstants.BOTTOM

setVerticalTextPosition

public void setVerticalTextPosition(int textPosition)
设置文本相对于图标的垂直位置。

参数：
textPosition - 它是以下值之一：
  • SwingConstants.CENTER（默认值）
  • SwingConstants.TOP
  • SwingConstants.BOTTOM

getHorizontalTextPosition

public int getHorizontalTextPosition()
返回文本相对于图标的水平位置。

返回：
horizontalTextPosition 属性，它是以下值之一：
  • SwingConstants.RIGHT
  • SwingConstants.LEFT
  • SwingConstants.CENTER
  • SwingConstants.LEADING
  • SwingConstants.TRAILING（默认值）

setHorizontalTextPosition

public void setHorizontalTextPosition(int textPosition)
设置文本相对于图标的水平位置。

参数：
textPosition - 它是以下值之一：
  • SwingConstants.RIGHT
  • SwingConstants.LEFT
  • SwingConstants.CENTER
  • SwingConstants.LEADING
  • SwingConstants.TRAILING（默认值）
抛出：
IllegalArgumentException - 如果 textPosition 不是上面列出的合法值之一

getIconTextGap

public int getIconTextGap()
返回此按钮中显示的文本与图标之间的间隔量。

返回：
等于文本与图标之间的像素数的 int 值。
从以下版本开始：
1.4
另请参见：
setIconTextGap(int)

setIconTextGap

public void setIconTextGap(int iconTextGap)
如果图标和文本的属性都已设置，则此属性定义图标和文本之间的间隔。

此属性的默认值为 4 个像素。

这是一个 JavaBeans 绑定属性。

从以下版本开始：
1.4
另请参见：
getIconTextGap()

checkHorizontalKey

protected int checkHorizontalKey(int key,
                                 String exception)
验证 key 参数是否为 horizontalAlignment 和 horizontalTextPosition 属性的合法值。有效值有：
  • SwingConstants.RIGHT
  • SwingConstants.LEFT
  • SwingConstants.CENTER
  • SwingConstants.LEADING
  • SwingConstants.TRAILING

参数：
key - 要检查的属性值
exception - IllegalArgumentException 中要使用的消息，无效值时抛出
抛出：
IllegalArgumentException - 如果 key 不是上面列出的合法值之一
另请参见：
setHorizontalTextPosition(int), setHorizontalAlignment(int)

checkVerticalKey

protected int checkVerticalKey(int key,
                               String exception)
验证 key 参数是否为垂直属性的合法值。有效值有：
  • SwingConstants.CENTER
  • SwingConstants.TOP
  • SwingConstants.BOTTOM

参数：
key - 要检查的属性值
exception - IllegalArgumentException 中要使用的消息，无效值时抛出
抛出：
IllegalArgumentException - 如果 key 不是上面列出的合法值之一

removeNotify

public void removeNotify()
通知此组件它不再有父组件。调用此方法时，移除父组件链中所有已设置的 KeyboardAction。

覆盖：
类 JComponent 中的 removeNotify
从以下版本开始：
1.6
另请参见：
JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

setActionCommand

public void setActionCommand(String actionCommand)
设置此按钮的动作命令。

参数：
actionCommand - 此按钮的动作命令

getActionCommand

public String getActionCommand()
返回此按钮的动作命令。

返回：
此按钮的动作命令

setAction

public void setAction(Action a)
设置 Action。新 Action 将替换所有以前设置的 Action，但不影响单独使用 addActionListener 添加的 ActionListener。如果 Action 已经是按钮的已注册 ActionListener，则它不需要重新注册。

设置 Action 导致支持 Action 的 Swing 组件中描述的所有属性立即更改。随后，按钮的属性根据 Action 的属性的更改进行自动更新。

此方法可以使用三个其他方法设置并帮助跟踪 Action 的属性值。它使用 configurePropertiesFromAction 方法可立即更改按钮的属性。要跟踪 Action 的属性值中的更改，此方法应注册 createActionPropertyChangeListener 返回的 PropertyChangeListener。Action 中的属性更改时，默认 PropertyChangeListener 调用 actionPropertyChanged 方法。

参数：
a - AbstractButton 的 Action，或为 null
从以下版本开始：
1.3
另请参见：
Action,
getAction(),
configurePropertiesFromAction(javax.swing.Action),
createActionPropertyChangeListener(javax.swing.Action),
actionPropertyChanged(javax.swing.Action, java.lang.String)

getAction

public Action getAction()
返回当前为此 ActionEvent 源设置的 Action，如果没有设置任何 Action，则返回 null。

返回：
此 ActionEvent 源的 Action，或 null
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

configurePropertiesFromAction

protected void configurePropertiesFromAction(Action a)
在此按钮上设置属性以匹配指定 Action 中的属性。有关关于设置了哪些属性的更多信息，请参阅支持 Action 的 Swing 组件。

参数：
a - 从中获取属性的 Action，或为 null
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

actionPropertyChanged

protected void actionPropertyChanged(Action action,
                                     String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。从 createActionPropertyChangeListener 返回的 PropertyChangeListener 中调用此方法。子类通常不需要调用此方法。支持其他 Action 属性的子类应该重写此方法以及 configurePropertiesFromAction。

有关此方法设置的属性的列表，请参阅支持 Action 的 Swing 组件处的表。

参数：
action - 与此按钮关联的 Action
propertyName - 已更改属性的名称
从以下版本开始：
1.6
另请参见：
Action, configurePropertiesFromAction(javax.swing.Action)

createActionPropertyChangeListener

protected PropertyChangeListener createActionPropertyChangeListener(Action a)
创建并返回 PropertyChangeListener，它负责侦听指定 Action 的更改以及更新适当的属性。

警告：如果为此类创建子类，则不要创建匿名内部类。否则，按钮的生命周期将依赖于 Action 的生命周期。

参数：
a - 按钮的操作
从以下版本开始：
1.3
另请参见：
Actions, Action, setAction(javax.swing.Action)

isBorderPainted

public boolean isBorderPainted()
获取 borderPainted 属性。

返回：
borderPainted 属性的值
另请参见：
setBorderPainted(boolean)

setBorderPainted

public void setBorderPainted(boolean b)
设置 borderPainted 属性。如果该属性为 true 并且按钮有边框，则绘制该边框。borderPainted 属性的默认值为 true。

参数：
b - 如果为 true 并且边框属性不为 null，则绘制该边框
另请参见：
isBorderPainted()

paintBorder

protected void paintBorder(Graphics g)
如果 BorderPainted 属性为 true 并且按钮有边框，则绘制该按钮边框。

覆盖：
类 JComponent 中的 paintBorder
参数：
g - 在其中进行绘制的 Graphics 环境
另请参见：
JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

isFocusPainted

public boolean isFocusPainted()
获取 paintFocus 属性。

返回：
paintFocus 属性
另请参见：
setFocusPainted(boolean)

setFocusPainted

public void setFocusPainted(boolean b)
设置 paintFocus 属性，对于要绘制的焦点状态，该属性必须为 true。paintFocus 属性的默认值为 true。一些外观没有绘制焦点状态；它们将忽略此属性。

参数：
b - 如果为 true，则应绘制焦点状态
另请参见：
isFocusPainted()

isContentAreaFilled

public boolean isContentAreaFilled()
获取 contentAreaFilled 属性。

返回：
contentAreaFilled 属性
另请参见：
setContentAreaFilled(boolean)

setContentAreaFilled

public void setContentAreaFilled(boolean b)
设置 contentAreaFilled 属性。如果该属性为 true，则按钮将绘制内容区域。如果希望有一个透明的按钮，比如只是一个图标的按钮，那么应该将此属性设置为 false。不要调用 setOpaque(false)。contentAreaFilled 属性的默认值为 true。

此方法可能造成组件的不透明属性发生更改。

调用此方法的具体行为在各个组件和各个 L&F 之间是各不相同的。

参数：
b - 如果为 true，则应该填充内容；如果为 false，则不填充内容区域
另请参见：
isContentAreaFilled(), JComponent.setOpaque(boolean)

isRolloverEnabled

public boolean isRolloverEnabled()
获取 rolloverEnabled 属性。

返回：
rolloverEnabled 属性的值
另请参见：
setRolloverEnabled(boolean)

setRolloverEnabled

public void setRolloverEnabled(boolean b)
设置 rolloverEnabled 属性，若需要翻转效果，该属性必须为 true。rolloverEnabled 属性的默认值为 false。一些外观也许不实现翻转效果；它们将忽略此属性。

参数：
b - 如果为 true，则应绘制翻转效果
另请参见：
isRolloverEnabled()

getMnemonic

public int getMnemonic()
返回当前模型中的键盘助记符。

返回：
模型中的键盘助记符

setMnemonic

public void setMnemonic(int mnemonic)
设置当前模型上的键盘助记符。助记符是某种键，它与外观的无鼠标修饰符（通常是 Alt）组合时（如果焦点包含在此按钮祖先窗口中的某个地方）将激活此按钮。

一个助记符必须对应键盘上的一个键，并且应该使用 java.awt.event.KeyEvent 中定义的 VK_XXX 键代码之一指定。助记符是不区分大小写的，所以具有相应键代码的键事件将造成按钮被激活，不管是否按下 Shift 修饰符。

如果在按钮的标签字符串中发现由助记符定义的字符，则第一个出现的助记符将是带下划线的，以向用户指示该助记符。

参数：
mnemonic - 表示助记符的键代码
另请参见：
KeyEvent, setDisplayedMnemonicIndex(int)

setMnemonic

public void setMnemonic(char mnemonic)
此方法现在已废弃，请使用 setMnemonic(int) 来设置按钮的助记符。此方法仅设计用于处理 'a' 到 'z' 或 'A' 到 'Z'之间的字符值。

参数：
mnemonic - 指定助记符值的字符
另请参见：
setMnemonic(int)

setDisplayedMnemonicIndex

public void setDisplayedMnemonicIndex(int index)
                               throws IllegalArgumentException
提供关于应该装饰文本中哪一个字符来表示助记符的外观提示。并不是所有的外观都能支持此方法。值 -1 指示没有助记符（助记符字符没有包含在字符串中），或者开发人员不希望显示助记符。

与助记符相关的属性发生更改时（比如助记符本身、文本……），此索引值也被更改。如果不希望默认字符带下划线，那么只能不断地调用此方法。例如，如果文本 'Save As' 带有一个助记符 'a'，您想装饰 'A'（比如装饰成 'Save As'），那么您必须在调用 setMnemonic(KeyEvent.VK_A) 之后调用 setDisplayedMnemonicIndex(5)。

参数：
index - String 中的索引，指示要加下划线的字符
抛出：
IllegalArgumentException - 如果 index >= 文本的长度，或者 < -1，则抛出该异常
从以下版本开始：
1.4
另请参见：
getDisplayedMnemonicIndex()

getDisplayedMnemonicIndex

public int getDisplayedMnemonicIndex()
以索引形式返回字符，它表示助记符字符，外观应该对其提供装饰。

返回：
表示助记符字符的索引
从以下版本开始：
1.4
另请参见：
setDisplayedMnemonicIndex(int)

setMultiClickThreshhold

public void setMultiClickThreshhold(long threshhold)
设置对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。在最初按下鼠标（并生成动作事件）之后，发生在小于 threshhold 的时间间隔中的所有后续鼠标按下事件都将被忽略，并且不生成相应的动作事件。默认情况下，threshhold 为 0，这意味着对于每个鼠标按下操作，都将触发动作事件，无论单击鼠标的速度有多快。在不需要此行为的按钮中（比如对话框中的 "OK" 按钮），应该将此 threshhold 设置为一个适当的正值。

参数：
threshhold - 按下鼠标到生成相应动作事件所需的时间量
抛出：
IllegalArgumentException - 如果 threshhold < 0
从以下版本开始：
1.4
另请参见：
getMultiClickThreshhold()

getMultiClickThreshhold

public long getMultiClickThreshhold()
获取对按钮按下鼠标到生成相应动作事件所需的时间量（以毫秒为单位）。

返回：
按下鼠标到生成相应动作事件所需的时间量
从以下版本开始：
1.4
另请参见：
setMultiClickThreshhold(long)

getModel

public ButtonModel getModel()
返回此按钮表示的模型。

返回：
model 属性
另请参见：
setModel(javax.swing.ButtonModel)

setModel

public void setModel(ButtonModel newModel)
设置此按钮表示的模型。

参数：
newModel - 新的 ButtonModel
另请参见：
getModel()

getUI

public ButtonUI getUI()
返回呈现此组件的 L&F 对象。

返回：
ButtonUI 对象
另请参见：
setUI(javax.swing.plaf.ButtonUI)

setUI

public void setUI(ButtonUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - ButtonUI L&F 对象
另请参见：
getUI()

updateUI

public void updateUI()
将 UI 属性重置为当前外观中的一个值。AbstractButton 的子类型应该重写此方法来更新 UI。例如，JButton 可以执行以下操作：
      setUI((ButtonUI)UIManager.getUI(
          "ButtonUI", "javax.swing.plaf.basic.BasicButtonUI", this));

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
将指定组件添加到此容器的指定索引所在的位置上，有关此方法的完整描述，请参阅 Container.addImpl(Component, Object, int)。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要添加的组件
constraints - 表示此组件的布局约束的对象
index - 容器列表中插入组件的位置，-1 表示添加到列表的末尾
抛出：
IllegalArgumentException - 如果 index 无效
IllegalArgumentException - 如果将容器的父容器添加到该容器自身中
IllegalArgumentException - 如果将一个窗口添加到容器中
从以下版本开始：
1.5
另请参见：
Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
LayoutManager,
LayoutManager2

setLayout

public void setLayout(LayoutManager mgr)
为此容器设置布局管理器，有关此方法的完整描述，请参阅 Container.setLayout(LayoutManager)。

覆盖：
类 Container 中的 setLayout
参数：
mgr - 指定的布局管理器
从以下版本开始：
1.5
另请参见：
Container.doLayout(), Container.getLayout()

addChangeListener

public void addChangeListener(ChangeListener l)
向按钮添加一个 ChangeListener。

参数：
l - 要添加的侦听器

removeChangeListener

public void removeChangeListener(ChangeListener l)
从按钮中移除一个 ChangeListener。

参数：
l - 要移除的侦听器

getChangeListeners

public ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractButton 中的所有 ChangeListener 组成的数组。

返回：
添加的所有 ChangeListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
通知所有需要此事件类型的通知的已注册侦听器。以延迟方式创建事件实例。

另请参见：
EventListenerList

addActionListener

public void addActionListener(ActionListener l)
将一个 ActionListener 添加到按钮中。

参数：
l - 要添加的 ActionListener

removeActionListener

public void removeActionListener(ActionListener l)
从按钮中移除一个 ActionListener。如果侦听器是按钮当前设置的 Action，则将 Action 设置为 null。

参数：
l - 要移除的侦听器

getActionListeners

public ActionListener[] getActionListeners()
返回使用 addActionListener() 添加到此 AbstractButton 的所有 ActionListener 组成的数组。

返回：
添加的所有 ActionListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

createChangeListener

protected ChangeListener createChangeListener()
想以不同的方式处理 ChangeEvent 的子类可以重写此方法，以返回另一个 ChangeListener 实现。

返回：
新的 ChangeListener

fireActionPerformed

protected void fireActionPerformed(ActionEvent event)
通知所有需要此事件类型的通知的已注册侦听器。使用 event 参数以延迟方式创建事件实例。

参数：
event - ActionEvent 对象
另请参见：
EventListenerList

fireItemStateChanged

protected void fireItemStateChanged(ItemEvent event)
通知所有需要此事件类型的通知的已注册侦听器。使用 event 参数以延迟方式创建事件实例。

参数：
event - ItemEvent 对象
另请参见：
EventListenerList

createActionListener

protected ActionListener createActionListener()

createItemListener

protected ItemListener createItemListener()

setEnabled

public void setEnabled(boolean b)
启用（或禁用）按钮。

覆盖：
类 JComponent 中的 setEnabled
参数：
b - true 表示启用按钮，否则为 false
另请参见：
Component.isEnabled(), Component.isLightweight()

getLabel

@Deprecated
public String getLabel()
已过时。 - 由 getText 取代

返回标签文本。

返回：
包含标签的 String

setLabel

@Deprecated
public void setLabel(String label)
已过时。 - 由 setText(text) 取代

设置标签文本。

参数：
label - 包含文本的 String

addItemListener

public void addItemListener(ItemListener l)
将一个 ItemListener 添加到 checkbox 中。

指定者：
接口 ItemSelectable 中的 addItemListener
参数：
l - 要添加的 ItemListener
另请参见：
ItemEvent

removeItemListener

public void removeItemListener(ItemListener l)
从按钮中移除一个 ItemListener。

指定者：
接口 ItemSelectable 中的 removeItemListener
参数：
l - 要移除的 ItemListener
另请参见：
ItemEvent

getItemListeners

public ItemListener[] getItemListeners()
返回使用 addItemListener() 添加到此 AbstractButton 中的所有 ItemListener 组成的数组。

返回：
添加的所有 ItemListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

getSelectedObjects

public Object[] getSelectedObjects()
返回包含标签的数组（长度为 1），如果没有选择按钮，则返回 null。

指定者：
接口 ItemSelectable 中的 getSelectedObjects
返回：
包含 1 个 Object 的数组：按钮的文本，如果选择该项；否则返回 null

init

protected void init(String text,
                    Icon icon)

imageUpdate

public boolean imageUpdate(Image img,
                           int infoflags,
                           int x,
                           int y,
                           int w,
                           int h)
重写的此方法在当前 Icon 的 Image 不等于传入的 Image img 时返回 false。

指定者：
接口 ImageObserver 中的 imageUpdate
覆盖：
类 Component 中的 imageUpdate
参数：
img - 要比较的 Image
infoflags - 更新图像时用于重绘按钮的标志，它确定将绘制多大的区域
x - x 坐标
y - y 坐标
w - 宽度
h - 高度
返回：
如果 infoflags 表明已完全加载了图像，则返回 false；否则返回 true。
另请参见：
ImageObserver, Component.imageUpdate(java.awt.Image, int, int, int, int, int)

paramString

protected String paramString()
返回此 AbstractButton 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

重写 paramString 来提供有关 JFC 组件的一些特定新方面的信息。

覆盖：
类 JComponent 中的 paramString
返回：
此 AbstractButton 的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractButton.AccessibleAbstractButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 AbstractButton.AccessibleAbstractButton

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
直接已知子类：
JButton.AccessibleJButton, JMenuItem.AccessibleJMenuItem, JToggleButton.AccessibleJToggleButton
正在封闭类：
AbstractButton
protected abstract class AbstractButton.AccessibleAbstractButton
extends JComponent.AccessibleJComponent
implements AccessibleAction, AccessibleValue, AccessibleText, AccessibleExtendedComponent

此类实现对 AbstractButton 类的可访问性支持。它提供适合按钮和菜单项用户界面元素的 Java Accessibility API 实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected AbstractButton.AccessibleAbstractButton()
方法摘要
boolean | doAccessibleAction(int i) 对该对象执行指定的 Action
AccessibleAction | getAccessibleAction() 获取与此对象关联的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用 Action 的数量。
String | getAccessibleActionDescription(int i) 返回对该对象的指定操作的描述。
AccessibleIcon[] | getAccessibleIcon() 获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
AccessibleKeyBinding | getAccessibleKeyBinding() 返回与此对象有关的键绑定。
String | getAccessibleName() 返回此对象的可访问名称。
AccessibleRelationSet | getAccessibleRelationSet() 获得与此对象关联的 AccessibleRelationSet（如果存在）。
AccessibleStateSet | getAccessibleStateSet() 获得此对象的状态设置。
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
String | getAfterIndex(int part, int index) 返回给定索引之后的 String。
String | getAtIndex(int part, int index) 返回给定索引处的 String。
String | getBeforeIndex(int part, int index) 返回给定索引前面的 String。
int | getCaretPosition() 返回插入符号的从零开始的偏移量。
AttributeSet | getCharacterAttribute(int i) 返回位于给定索引处的给定字符的 AttributeSet。
Rectangle | getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
int | getCharCount() 返回字符（有效索引）的数量
Number | getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
int | getIndexAtPoint(Point p) 在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。
Number | getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
String | getSelectedText() 返回选定文本的一部分。
int | getSelectionEnd() 返回选定文本中的结束偏移量。
int | getSelectionStart() 返回选定文本中的起始偏移量。
String | getTitledBorderText() 返回加标题的边界文本
String | getToolTipText() 返回工具提示文本
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleRole, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

AbstractButton.AccessibleAbstractButton

protected AbstractButton.AccessibleAbstractButton()
方法详细信息

getAccessibleName

public String getAccessibleName()
返回此对象的可访问名称。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleName
返回：
返回该对象的本地化名称，如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleIcon

public AccessibleIcon[] getAccessibleIcon()
获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleIcon
返回：
如果受对象支持，则返回一个 AccessibleIcon 数组；否则返回 null
从以下版本开始：
1.3
另请参见：
AccessibleIcon

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获得此对象的状态设置。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleRelationSet

public AccessibleRelationSet getAccessibleRelationSet()
获得与此对象关联的 AccessibleRelationSet（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleRelationSet
返回：
如果受对象支持，则返回 AccessibleRelationSet；否则返回 null
从以下版本开始：
1.3
另请参见：
AccessibleRelation

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的 AccessibleAction。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用 Action 的数量。按钮的默认行为是执行一个操作，即切换按钮。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
1，此对象中的 Action 数

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回对该对象的指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 该操作的从零开始的索引
返回：
动作的 String 描述
另请参见：
AccessibleAction.getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
对该对象执行指定的 Action

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 从零开始的操作索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
以 Number 形式获取此对象的值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
如果不选择此对象，则返回整数 0，如果选择此对象，则返回整数 1。
另请参见：
AbstractButton.isSelected()

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 True。
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
以 Number 形式获取此对象的最小值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
整数 0。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
以 Number 形式获取此对象的最大值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
整数 1。
另请参见：
AccessibleValue.getMinimumAccessibleValue()

getAccessibleText

public AccessibleText getAccessibleText()
从类 AccessibleContext 复制的描述
获取与在显示器上显示文本的此对象关联的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getIndexAtPoint

public int getIndexAtPoint(Point p)
在本地坐标中给出一个点，返回该 Point 之下的、从零开始的字符索引。如果该点无效，则此方法返回 -1。 注：AbstractButton 必须具有一个有效大小（例如，它已被添加到其祖先容器是有效顶级窗口的父容器中），以便此方法能够返回一个有意义的值。

指定者：
接口 AccessibleText 中的 getIndexAtPoint
参数：
p - 本地坐标中的 Point
返回：
Point p 之下的、从零开始的字符索引；如果 Point 无效，则返回 -1。
从以下版本开始：
1.3

getCharacterBounds

public Rectangle getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。边界在本地坐标中返回。如果索引无效，则返回一个空矩形。 注：AbstractButton 必须具有一个有效大小（例如，它已被添加到其祖先容器是有效顶级窗口的父容器中），以便此方法能够返回一个有意义的值。

指定者：
接口 AccessibleText 中的 getCharacterBounds
参数：
i - String 中的索引
返回：
返回字符边界框的屏幕坐标，如果索引无效，则返回一个空矩形。
从以下版本开始：
1.3

getCharCount

public int getCharCount()
返回字符（有效索引）的数量

指定者：
接口 AccessibleText 中的 getCharCount
返回：
字符数。
从以下版本开始：
1.3

getCaretPosition

public int getCaretPosition()
返回插入符号的从零开始的偏移量。 注：插入符号右边的那个字符将拥有与偏移量相同的索引值（插入符号在两个字符之间）。

指定者：
接口 AccessibleText 中的 getCaretPosition
返回：
插入符号的从零开始的偏移量。
从以下版本开始：
1.3

getAtIndex

public String getAtIndex(int part,
                         int index)
返回给定索引处的 String。

指定者：
接口 AccessibleText 中的 getAtIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该索引 >= 0
返回：
字母、单词或句子，对于无效索引或无效 part，则返回 null
从以下版本开始：
1.3

getAfterIndex

public String getAfterIndex(int part,
                            int index)
返回给定索引之后的 String。

指定者：
接口 AccessibleText 中的 getAfterIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该索引 >= 0
返回：
字母、单词或句子，对于无效索引或无效 part，则返回 null
从以下版本开始：
1.3

getBeforeIndex

public String getBeforeIndex(int part,
                             int index)
返回给定索引前面的 String。

指定者：
接口 AccessibleText 中的 getBeforeIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该索引 >= 0
返回：
字母、单词或句子，对于无效索引或无效 part，则返回 null
从以下版本开始：
1.3

getCharacterAttribute

public AttributeSet getCharacterAttribute(int i)
返回位于给定索引处的给定字符的 AttributeSet。

指定者：
接口 AccessibleText 中的 getCharacterAttribute
参数：
i - 文本中从零开始的索引
返回：
字符的 AttributeSet
从以下版本开始：
1.3

getSelectionStart

public int getSelectionStart()
返回选定文本中的起始偏移量。如果没有选择文本，但有一个插入符号，则起始偏移量和结束偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionStart
返回：
选择文本中起始处的索引
从以下版本开始：
1.3

getSelectionEnd

public int getSelectionEnd()
返回选定文本中的结束偏移量。如果没有选择文本，但有一个插入符号，则起始偏移量和结束偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionEnd
返回：
选择文本中结束处的索引
从以下版本开始：
1.3

getSelectedText

public String getSelectedText()
返回选定文本的一部分。

指定者：
接口 AccessibleText 中的 getSelectedText
返回：
返回选定文本的 String 部分
从以下版本开始：
1.3

getToolTipText

public String getToolTipText()
返回工具提示文本

指定者：
接口 AccessibleExtendedComponent 中的 getToolTipText
覆盖：
类 JComponent.AccessibleJComponent 中的 getToolTipText
返回：
对象的工具提示文本（如果受支持）；否则返回 null
从以下版本开始：
1.4

getTitledBorderText

public String getTitledBorderText()
返回加标题的边界文本

指定者：
接口 AccessibleExtendedComponent 中的 getTitledBorderText
覆盖：
类 JComponent.AccessibleJComponent 中的 getTitledBorderText
返回：
对象的加标题的边界文本（如果受支持）；否则返回 null
从以下版本开始：
1.4

getAccessibleKeyBinding

public AccessibleKeyBinding getAccessibleKeyBinding()
返回与此对象有关的键绑定。

指定者：
接口 AccessibleExtendedComponent 中的 getAccessibleKeyBinding
覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleKeyBinding
返回：
对象的键绑定（如果受支持）；否则返回 null
从以下版本开始：
1.4
另请参见：
AccessibleKeyBinding
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractButton.ButtonChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 AbstractButton.ButtonChangeListener

java.lang.Object
    继承者  javax.swing.AbstractButton.ButtonChangeListener
所有已实现的接口：
Serializable, EventListener, ChangeListener
正在封闭类：
AbstractButton
protected class AbstractButton.ButtonChangeListener
extends Object
implements ChangeListener, Serializable

将 ChangeListener 扩展为可序列化的。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractCellEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 AbstractCellEditor

java.lang.Object
    继承者  javax.swing.AbstractCellEditor
所有已实现的接口：
Serializable, CellEditor
直接已知子类：
DefaultCellEditor
public abstract class AbstractCellEditor
extends Object
implements CellEditor, Serializable

从以下版本开始：
1.3

字段摘要
protected ChangeEvent | changeEvent
protected EventListenerList | listenerList
构造方法摘要
AbstractCellEditor()
方法摘要
 void addCellEditorListener(CellEditorListener l)
将一个 CellEditorListener 添加到侦听器列表中。
 void cancelCellEditing()
调用 fireEditingCanceled。
protected  void fireEditingCanceled()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireEditingStopped()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
 CellEditorListener[] getCellEditorListeners()
返回使用 addCellEditorListener() 添加到此 AbstractCellEditor 中的所有 CellEditorListener 组成的数组。
 boolean isCellEditable(EventObject e)
返回 true。
 void removeCellEditorListener(CellEditorListener l)
从侦听器列表中移除一个 CellEditorListener。
 boolean shouldSelectCell(EventObject anEvent)
返回 true。
 boolean stopCellEditing()
调用 fireEditingStopped 并返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.CellEditor 继承的方法
getCellEditorValue

字段详细信息

listenerList

protected EventListenerList listenerList

changeEvent

protected transient ChangeEvent changeEvent
构造方法详细信息

AbstractCellEditor

public AbstractCellEditor()
方法详细信息

isCellEditable

public boolean isCellEditable(EventObject e)
返回 true。

指定者：
接口 CellEditor 中的 isCellEditable
参数：
e - 一个事件对象
返回：
true
另请参见：
CellEditor.shouldSelectCell(java.util.EventObject)

shouldSelectCell

public boolean shouldSelectCell(EventObject anEvent)
返回 true。

指定者：
接口 CellEditor 中的 shouldSelectCell
参数：
anEvent - 一个事件对象
返回：
true
另请参见：
CellEditor.isCellEditable(java.util.EventObject)

stopCellEditing

public boolean stopCellEditing()
调用 fireEditingStopped 并返回 true。

指定者：
接口 CellEditor 中的 stopCellEditing
返回：
true

cancelCellEditing

public void cancelCellEditing()
调用 fireEditingCanceled。

指定者：
接口 CellEditor 中的 cancelCellEditing

addCellEditorListener

public void addCellEditorListener(CellEditorListener l)
将一个 CellEditorListener 添加到侦听器列表中。

指定者：
接口 CellEditor 中的 addCellEditorListener
参数：
l - 要添加的新侦听器

removeCellEditorListener

public void removeCellEditorListener(CellEditorListener l)
从侦听器列表中移除一个 CellEditorListener。

指定者：
接口 CellEditor 中的 removeCellEditorListener
参数：
l - 要移除的侦听器

getCellEditorListeners

public CellEditorListener[] getCellEditorListeners()
返回使用 addCellEditorListener() 添加到此 AbstractCellEditor 中的所有 CellEditorListener 组成的数组。

返回：
添加的所有 CellEditorListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

fireEditingStopped

protected void fireEditingStopped()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

另请参见：
EventListenerList

fireEditingCanceled

protected void fireEditingCanceled()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

另请参见：
EventListenerList
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractListModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 AbstractListModel

java.lang.Object
    继承者  javax.swing.AbstractListModel
所有已实现的接口：
Serializable, ListModel
直接已知子类：
BasicDirectoryModel, DefaultComboBoxModel, DefaultListModel, MetalFileChooserUI.DirectoryComboBoxModel, MetalFileChooserUI.FilterComboBoxModel
public abstract class AbstractListModel
extends Object
implements ListModel, Serializable

该数据模型的抽象定义提供一个带内容的 List。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected  EventListenerList listenerList
构造方法摘要
AbstractListModel()
方法摘要
 void addListDataListener(ListDataListener l)
将某个侦听器添加到每次更改数据模型都要通知的列表。
protected  void fireContentsChanged(Object source, int index0, int index1)
AbstractListModel 子类必须在列表的一个或多个元素发生更改之后调用此方法。
protected  void fireIntervalAdded(Object source, int index0, int index1)
AbstractListModel 子类必须在将一个或多个元素添加到模型中之后调用此方法。
protected  void fireIntervalRemoved(Object source, int index0, int index1)
AbstractListModel 子类必须在从模型中移除一个或多个元素之后调用此方法。
 ListDataListener[] getListDataListeners()
返回已在此 AbstractListModel 上注册的所有列表数据侦听器组成的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
 void removeListDataListener(ListDataListener l)
将某个侦听器从每次更改数据模型都要通知的列表中移除。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.ListModel 继承的方法
getElementAt, getSize

字段详细信息

listenerList

protected EventListenerList listenerList
构造方法详细信息

AbstractListModel

public AbstractListModel()
方法详细信息

addListDataListener

public void addListDataListener(ListDataListener l)
将某个侦听器添加到每次更改数据模型都要通知的列表。

指定者：
接口 ListModel 中的 addListDataListener
参数：
l - 要添加的 ListDataListener

removeListDataListener

public void removeListDataListener(ListDataListener l)
将某个侦听器从每次更改数据模型都要通知的列表中移除。

指定者：
接口 ListModel 中的 removeListDataListener
参数：
l - 要移除的 ListDataListener

getListDataListeners

public ListDataListener[] getListDataListeners()
返回已在此 AbstractListModel 上注册的所有列表数据侦听器组成的数组。

返回：
此模型的所有 ListDataListener，如果当前没有已注册的列表数据侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addListDataListener(javax.swing.event.ListDataListener), removeListDataListener(javax.swing.event.ListDataListener)

fireContentsChanged

protected void fireContentsChanged(Object source,
                                   int index0,
                                   int index1)
AbstractListModel 子类必须在列表的一个或多个元素发生更改之后调用此方法。更改的元素由 index0 和 index1 封闭的区间（包括端点）指定。注意，index0 不必小于或等于 index1。

参数：
source - 更改的 ListModel，通常为 "this"
index0 - 新区间的一端
index1 - 新区间的另一端
另请参见：
EventListenerList, DefaultListModel

fireIntervalAdded

protected void fireIntervalAdded(Object source,
                                 int index0,
                                 int index1)
AbstractListModel 子类必须在将一个或多个元素添加到模型中之后调用此方法。新元素由 index0 和 index1 封闭的区间（包括端点）指定。注意，index0 不必小于或等于 index1。

参数：
source - 更改的 ListModel，通常为 "this"
index0 - 新区间的一端
index1 - 新区间的另一端
另请参见：
EventListenerList, DefaultListModel

fireIntervalRemoved

protected void fireIntervalRemoved(Object source,
                                   int index0,
                                   int index1)
AbstractListModel 子类必须在从模型中移除一个或多个元素之后调用此方法。index0 和 index1 是已移除区间的端点。注意，index0 不必小于或等于 index1。

参数：
source - 更改的 ListModel，通常为 "this"
index0 - 移除区间的一端，包括 index0
index1 - 移除区间的另一端，包括 index1
另请参见：
EventListenerList, DefaultListModel

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用以下代码查询列表模型 m，以获得其列表数据侦听器：

ListDataListener[] ldls = (ListDataListener[])(m.getListeners(ListDataListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 请求的侦听器类型；此参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
在此模型上注册为 FooListener 的所有对象组成的数组
抛出：
ClassCastException - 如果 listenerType 未指定实现 java.util.EventListener 的类或接口。
从以下版本开始：
1.3
另请参见：
getListDataListeners()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


AbstractSpinnerModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 AbstractSpinnerModel

java.lang.Object
    继承者  javax.swing.AbstractSpinnerModel
所有已实现的接口：
SpinnerModel
直接已知子类：
SpinnerDateModel, SpinnerListModel, SpinnerNumberModel
public abstract class AbstractSpinnerModel
extends Object
implements SpinnerModel

此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。子类必须提供 setValue、getValue、getNextValue 和 getPreviousValue 方法的实现。

从以下版本开始：
1.4
另请参见：
JSpinner, SpinnerModel, SpinnerListModel, SpinnerNumberModel, SpinnerDateModel

字段摘要
protected  EventListenerList listenerList
此模型的 ChangeListener 列表。
构造方法摘要
AbstractSpinnerModel()
方法摘要
 void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到模型的侦听器列表中。
protected  void fireStateChanged()
运行每个 ChangeListeners stateChanged() 方法。
 ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractSpinnerModel 中的所有 ChangeListener 组成的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。
 void removeChangeListener(ChangeListener l)
从模型的侦听器列表中移除一个 ChangeListener。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.SpinnerModel 继承的方法
getNextValue, getPreviousValue, getValue, setValue

字段详细信息

listenerList

protected EventListenerList listenerList
此模型的 ChangeListener 列表。子类可以在这里存储自己的侦听器。

构造方法详细信息

AbstractSpinnerModel

public AbstractSpinnerModel()
方法详细信息

addChangeListener

public void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到模型的侦听器列表中。当模型的值更改时，必须通知 ChangeListener。

指定者：
接口 SpinnerModel 中的 addChangeListener
参数：
l - 要添加的 ChangeListener
另请参见：
removeChangeListener(javax.swing.event.ChangeListener), SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

removeChangeListener

public void removeChangeListener(ChangeListener l)
从模型的侦听器列表中移除一个 ChangeListener。

指定者：
接口 SpinnerModel 中的 removeChangeListener
参数：
l - 要移除的 ChangeListener
另请参见：
addChangeListener(javax.swing.event.ChangeListener), SpinnerModel.removeChangeListener(javax.swing.event.ChangeListener)

getChangeListeners

public ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 AbstractSpinnerModel 中的所有 ChangeListener 组成的数组。

返回：
添加的所有 ChangeListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
运行每个 ChangeListeners stateChanged() 方法。

另请参见：
SpinnerModel.setValue(java.lang.Object), EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回具有添加到此模型中的给定类型的所有侦听器组成的数组。例如，查找添加到此模型中的所有 ChangeListener：
 myAbstractSpinnerModel.getListeners(ChangeListener.class);

参数：
listenerType - 要返回的侦听器类型，例如 ChangeListener.class
返回：
接收来自此模型的 listenerType 通知的所有对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Action (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 Action

所有超级接口：
ActionListener, EventListener
所有已知实现类：
AbstractAction, BasicDesktopPaneUI.CloseAction, BasicDesktopPaneUI.MaximizeAction, BasicDesktopPaneUI.MinimizeAction, BasicDesktopPaneUI.NavigateAction, BasicDesktopPaneUI.OpenAction, BasicFileChooserUI.ApproveSelectionAction, BasicFileChooserUI.CancelSelectionAction, BasicFileChooserUI.ChangeToParentDirectoryAction, BasicFileChooserUI.GoHomeAction, BasicFileChooserUI.NewFolderAction, BasicFileChooserUI.UpdateAction, BasicInternalFrameTitlePane.CloseAction, BasicInternalFrameTitlePane.IconifyAction, BasicInternalFrameTitlePane.MaximizeAction, BasicInternalFrameTitlePane.MoveAction, BasicInternalFrameTitlePane.RestoreAction, BasicInternalFrameTitlePane.SizeAction, BasicSliderUI.ActionScroller, BasicTreeUI.TreeCancelEditingAction, BasicTreeUI.TreeHomeAction, BasicTreeUI.TreeIncrementAction, BasicTreeUI.TreePageAction, BasicTreeUI.TreeToggleAction, BasicTreeUI.TreeTraverseAction, DefaultEditorKit.BeepAction, DefaultEditorKit.CopyAction, DefaultEditorKit.CutAction, DefaultEditorKit.DefaultKeyTypedAction, DefaultEditorKit.InsertBreakAction, DefaultEditorKit.InsertContentAction, DefaultEditorKit.InsertTabAction, DefaultEditorKit.PasteAction, HTMLEditorKit.HTMLTextAction, HTMLEditorKit.InsertHTMLTextAction, MetalFileChooserUI.DirectoryComboBoxAction, StyledEditorKit.AlignmentAction, StyledEditorKit.BoldAction, StyledEditorKit.FontFamilyAction, StyledEditorKit.FontSizeAction, StyledEditorKit.ForegroundAction, StyledEditorKit.ItalicAction, StyledEditorKit.StyledTextAction, StyledEditorKit.UnderlineAction, TextAction
public interface Action
extends ActionListener

Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。

除了 ActionListener 接口定义的 actionPerformed 方法之外，此接口还允许应用程序在一个位置定义：

  • 描述函数的一个或多个文本字符串。这些字符串可用于显示按钮的立体文本、在菜单项中设置文本等等。
  • 描述函数的一个或多个图标。这些图标可用于菜单控件中的图像，或者用于更复杂用户界面中的合成项。
  • 功能的启用/禁用状态。应用程序可以禁用实现此接口的函数，而不必分别禁用菜单项和工具栏按钮。所有为侦听状态更改而注册为侦听器的组件都将禁止为该项生成事件，并相应地修改显示。

可以将此接口添加到现有类中，或者用它创建一个适配器（通常通过子类化 AbstractAction 来实现）。然后可以将 Action 对象添加到多个可感知 Action 的容器中，并连接到可容纳 Action 的组件。然后可以通过调用 Action 对象的 setEnabled 方法立刻激活或取消激活 GUI 控件。

注意，Action 实现在存储方面的开销比典型的 ActionListener 要高，但后者不具有集中控制功能和广播属性更改的优点。因此，应该注意只在需要这些优点的地方使用 Action，在别处使用 ActionListener 即可。

支持 Action 的 Swing 组件

许多 Swing 的组件都具有 Action 属性。在组件上设置 Action 时，会发生以下几种情况：

  • Action 被作为 ActionListener 添加到组件。
  • 组件配置自身的某些属性以匹配 Action。
  • 组件在 Action 上安装 PropertyChangeListener，这样组件可更改其属性以反映 Action 属性中的更改。

下表描述了支持 Action 的 Swing 组件所使用的属性。在该表中，按钮 指的是任何 AbstractButton 子类，它不仅包括 JButton，而且包括一些类（如 JMenuItem）。除非另行声明，否则 Action 中的 null 属性值（或者为 null 的 Action）将导致按钮的对应属性被设置为 null。

组件属性 | 组件 | 动作键 | 注意事项
enabled | 所有 | isEnabled 方法 |
toolTipText | 所有 | SHORT_DESCRIPTION |
actionCommand | 所有 | ACTION_COMMAND_KEY |
mnemonic | 所有按钮 | MNEMONIC_KEY | null 值或 Action 将导致按钮的 mnemonic 属性被设置为 '\0'。
text | 所有按钮 | NAME | 如果不想按钮的文本反映 Action 的文本，可以将 hideActionText 属性设置为 true。如果 hideActionText 为 true，那么设置 Action 会将按钮的文本更改为 null，忽略对 NAME 的任何更改。hideActionText 对于通常仅显示 Icon 的工具栏按钮很有用。如果对于 LARGE_ICON_KEY 或 SMALL_ICON，Action 具有非 null 值，那么 JToolBar.add(Action) 会将属性设置为 true。
displayedMnemonicIndex | 所有按钮 | DISPLAYED_MNEMONIC_INDEX_KEY | 如果 DISPLAYED_MNEMONIC_INDEX_KEY 的值超出文本边界，则忽略它。当调用 setAction 时，如果取自 Action 的值为 null，则不更新显示的助记符索引。在对 DISPLAYED_MNEMONIC_INDEX_KEY 的任意后续更改中，null 被视为 -1。
icon | 除 JCheckBox、JToggleButton 和 JRadioButton 之外的所有按钮。 | LARGE_ICON_KEY 或 SMALL_ICON | JMenuItem 子类只使用 SMALL_ICON。所有其他按钮将使用 LARGE_ICON_KEY；如果该值为 null，则它们使用 SMALL_ICON。
accelerator | 除 JMenu 之外的所有 JMenuItem 子类。 | ACCELERATOR_KEY |
selected | JToggleButton、JCheckBox、JRadioButton、JCheckBoxMenuItem 和 JRadioButtonMenuItem | SELECTED_KEY | 如果遵守此属性的组件为非 null，那么它只使用该值。例如，如果设置了一个 Action，它在 JToggleButton 上的 SELECTED_KEY 为 null 值，那么该 JToggleButton 将不会以任何方式更新其选定状态。类似地，如果对于 SELECTED_KEY，Action 具有非 null 值，那么每次 JToggleButton 的选定状态发生更改时，它都会将值设置回 Action。 遵守此属性的组件保持其选定状态与此属性同步。当将同一个 Action 用于多个组件时，所有组件都保持其选定状态与此属性同步。互斥的按钮（如 ButtonGroup 中的 JToggleButton）将强制选择其中的一个按钮。因此，在用于多个互斥按钮时，不要使用相同的 Action 定义 SELECTED_KEY 属性的值。

JPopupMenu、JToolBar 和 JMenu 都提供便捷方法来创建组件和在相应的组件上设置 Action。有关更多信息，请参阅这些类。

Action 使用 PropertyChangeListener 来通知侦听器 Action 发生了更改。bean 规范指示 null 属性名称可用于指示多个值发生了更改。默认情况下，带有 Action 的 Swing 组件不处理这样的更改。要指示 Swing 应该根据 bean 规范处理 null 情况，请将系统属性 swing.actions.reconfigureOnNull 设置为 String 值 true。

另请参见：
AbstractAction

字段摘要
static String | ACCELERATOR_KEY 用来存储将用作动作加速器的 KeyStroke 的键。
static String | ACTION_COMMAND_KEY 用来确定 ActionEvent 的命令 String 的键，ActionEvent 是在 Action 因驻留在与 JComponent 关联的 Keymap 中而被通知时所创建的。
static String | DEFAULT 当前未使用。
static String | DISPLAYED_MNEMONIC_INDEX_KEY 用来存储对应于文本（由 NAME 属性标识）索引的 Integer 值的键，助记符的装饰应在该文本中呈现。
static String | LARGE_ICON_KEY 用来存储 Icon 的键。
static String | LONG_DESCRIPTION 用来存储动作的较长 String 描述的键，用于上下文相关的帮助文件。
static String | MNEMONIC_KEY 用来存储对应于一个 KeyEvent 键代码的 Integer 值的键。
static String | NAME 用来存储动作的 String 名称的键，用于菜单或按钮。
static String | SELECTED_KEY 用来存储对应于选定状态的 Boolean 值的键。
static String | SHORT_DESCRIPTION 用来存储动作的简短 String 描述的键，用于工具提示文本。
static String | SMALL_ICON 用来存储小型 Icon（比如 ImageIcon）的键。
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 添加一个 PropertyChange 侦听器。
Object | getValue(String key) 使用关联的键获取此对象的一个属性。
boolean | isEnabled() 返回 Action 的启用状态。
void | putValue(String key, Object value) 使用关联的键设置此对象的一个属性。
void | removePropertyChangeListener(PropertyChangeListener listener) 移除一个 PropertyChange 侦听器。
void | setEnabled(boolean b) 设置 Action 的启用状态。
从接口 java.awt.event.ActionListener 继承的方法
actionPerformed

字段详细信息

DEFAULT

static final String DEFAULT
当前未使用。

另请参见：
常量字段值

NAME

static final String NAME
用来存储动作的 String 名称的键，用于菜单或按钮。

另请参见：
常量字段值

SHORT_DESCRIPTION

static final String SHORT_DESCRIPTION
用来存储动作的简短 String 描述的键，用于工具提示文本。

另请参见：
常量字段值

LONG_DESCRIPTION

static final String LONG_DESCRIPTION
用来存储动作的较长 String 描述的键，用于上下文相关的帮助文件。

另请参见：
常量字段值

SMALL_ICON

static final String SMALL_ICON
用来存储小型 Icon（比如 ImageIcon）的键。该键通常用于菜单，比如 JMenuItem。

如果将同一个 Action 用于菜单和按钮，通常应同时指定 SMALL_ICON 和 LARGE_ICON_KEY。菜单将使用 SMALL_ICON，按钮将使用 LARGE_ICON_KEY。

另请参见：
常量字段值

ACTION_COMMAND_KEY

static final String ACTION_COMMAND_KEY
用来确定 ActionEvent 的命令 String 的键，ActionEvent 是在 Action 因驻留在与 JComponent 关联的 Keymap 中而被通知时所创建的。

另请参见：
常量字段值

ACCELERATOR_KEY

static final String ACCELERATOR_KEY
用来存储将用作动作加速器的 KeyStroke 的键。

从以下版本开始：
1.3
另请参见：
常量字段值

MNEMONIC_KEY

static final String MNEMONIC_KEY
用来存储对应于一个 KeyEvent 键代码的 Integer 值的键。该值通常用于指定助记符。例如：myAction.putValue(Action.MNEMONIC_KEY, KeyEvent.VK_A) 将 myAction 的助记符设置为 'a'。

从以下版本开始：
1.3
另请参见：
常量字段值

SELECTED_KEY

static final String SELECTED_KEY
用来存储对应于选定状态的 Boolean 值的键。该键通常只用于具有有意义的选择状态的组件。例如：JRadioButton 和 JCheckBox 使用此键，但是 JMenu 的实例不使用。

该属性不同于其他属性，因为它由组件读取也由组件设置。例如，如果 Action 连接到 JCheckBox，那么 JCheckBox 的选定状态将根据 Action 的选定状态设置。如果用户在 JCheckBox 上单击，JCheckBox 的选定状态和 Action 都将被更新。

注：此字段的值以 'Swing' 为前缀，以避免与现有 Action 的可能冲突。

从以下版本开始：
1.6
另请参见：
常量字段值

DISPLAYED_MNEMONIC_INDEX_KEY

static final String DISPLAYED_MNEMONIC_INDEX_KEY
用来存储对应于文本（由 NAME 属性标识）索引的 Integer 值的键，助记符的装饰应在该文本中呈现。如果此属性的值大于等于该文本的长度，则它将被视为 -1。

注：此字段的值以 'Swing' 为前缀，以避免与现有 Action 的可能冲突。

从以下版本开始：
1.6
另请参见：
AbstractButton.setDisplayedMnemonicIndex(int), 常量字段值

LARGE_ICON_KEY

static final String LARGE_ICON_KEY
用来存储 Icon 的键。该键通常由按钮（如 JButton 和 JToggleButton）使用。

如果将同一个 Action 用于菜单和按钮，通常应同时指定 SMALL_ICON 和 LARGE_ICON_KEY。菜单将使用 SMALL_ICON，按钮将使用 LARGE_ICON_KEY。

注：此字段的值以 'Swing' 为前缀，以避免与现有 Action 的可能冲突。

从以下版本开始：
1.6
另请参见：
常量字段值
方法详细信息

getValue

Object getValue(String key)
使用关联的键获取此对象的一个属性。

另请参见：
putValue(java.lang.String, java.lang.Object)

putValue

void putValue(String key,
              Object value)
使用关联的键设置此对象的一个属性。如果值发生了更改，则将一个 PropertyChangeEvent 发送到侦听器。

参数：
key - 一个包含键的 String
value - 一个 Object 值

setEnabled

void setEnabled(boolean b)
设置 Action 的启用状态。在启用时，任何与此对象关联的组件都被激活，并且都能触发此对象的 actionPerformed 方法。如果值发生了更改，则将一个 PropertyChangeEvent 发送到侦听器。

参数：
b - 为 true 表示启用此 Action；为 false 表示禁用它

isEnabled

boolean isEnabled()
返回 Action 的启用状态。在启用时，任何与此对象关联的组件都被激活，并且都能触发此对象的 actionPerformed 方法。

返回：
如果启用了此 Action，则返回 true

addPropertyChangeListener

void addPropertyChangeListener(PropertyChangeListener listener)
添加一个 PropertyChange 侦听器。容器和附属组件使用这些方法注册，以侦听此 Action 对象。当启用状态或其他属性发生更改时，已注册的侦听器会收到更改通知。

参数：
listener - 一个 PropertyChangeListener 对象

removePropertyChangeListener

void removePropertyChangeListener(PropertyChangeListener listener)
移除一个 PropertyChange 侦听器。

参数：
listener - 一个 PropertyChangeListener 对象
另请参见：
addPropertyChangeListener(java.beans.PropertyChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ActionMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ActionMap

java.lang.Object
    继承者  javax.swing.ActionMap
所有已实现的接口：
Serializable
直接已知子类：
ActionMapUIResource
public class ActionMap
extends Object
implements Serializable

ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。当按下某一个键时，ActionMap 通常与 InputMap 一起使用来定位特定操作。与 InputMap 一同使用时，ActionMap 可以有一个父级，用来搜索没有在该 ActionMap 中定义的键。

与 InputMap 一同使用时，如果创建一个循环，例如：

   ActionMap am = new ActionMap();
   ActionMap bm = new ActionMap():
   am.setParent(bm);
   bm.setParent(am);
则某些方法将导致抛出 StackOverflowError。

从以下版本开始：
1.3
另请参见：
InputMap

构造方法摘要
ActionMap()
创建一个没有父级和映射关系的 ActionMap。
方法摘要
Object[] | allKeys() 返回在此 ActionMap 及其父级中定义的键所组成的数组。
void | clear() 从此 ActionMap 中移除所有映射关系。
Action | get(Object key) 返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。
ActionMap | getParent() 返回此 ActionMap 的父级。
Object[] | keys() 返回此 ActionMap 中绑定的 Action 名称。
void | put(Object key, Action action) 添加一个 key 到 action 的绑定。
void | remove(Object key) 从此 ActionMap 中移除 key 的绑定。
void | setParent(ActionMap map) 设置此 ActionMap 的父级。
int | size() 返回 KeyStroke 绑定的数量。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ActionMap

public ActionMap()
创建一个没有父级和映射关系的 ActionMap。

方法详细信息

setParent

public void setParent(ActionMap map)
设置此 ActionMap 的父级。

参数：
map - 作为此 ActionMap 父级的 ActionMap

getParent

public ActionMap getParent()
返回此 ActionMap 的父级。

返回：
作为此 ActionMap 父级的 ActionMap，如果此 ActionMap 没有父级，则返回 null

put

public void put(Object key,
                Action action)
添加一个 key 到 action 的绑定。如果 action 为 null，则移除 key 的当前绑定。

在大多数情况下，key 将是 action.getValue(NAME)。

get

public Action get(Object key)
返回 key 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 ActionMap。

remove

public void remove(Object key)
从此 ActionMap 中移除 key 的绑定。

clear

public void clear()
从此 ActionMap 中移除所有映射关系。

keys

public Object[] keys()
返回此 ActionMap 中绑定的 Action 名称。

size

public int size()
返回 KeyStroke 绑定的数量。

allKeys

public Object[] allKeys()
返回在此 ActionMap 及其父级中定义的键所组成的数组。此方法与 keys() 的不同之处在于：此方法包括父级中定义的键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BorderFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 BorderFactory

java.lang.Object
    继承者  javax.swing.BorderFactory

public class BorderFactory
extends Object

提供标准 Border 对象的工厂类。在任何可能的地方，此工厂类都将提供对已共享 Border 实例的引用。有关更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Borders 一节。

方法摘要
static Border | createBevelBorder(int type) 创建一个指定类型的斜面边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
static Border | createBevelBorder(int type, Color highlight, Color shadow) 使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。
static Border | createBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner) 创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。
static CompoundBorder | createCompoundBorder() 创建一个具有 null 内部边缘和 null 外部边缘的合成边框。
static CompoundBorder | createCompoundBorder(Border outsideBorder, Border insideBorder) 创建一个合成边框，指定了用于外部和内部边缘的 border 对象。
static Border | createEmptyBorder() 创建一个不占用空间的空边框。
static Border | createEmptyBorder(int top, int left, int bottom, int right) 创建一个占用空间但没有绘制的空边框，指定了顶线、底线、左边框线和右边框线的宽度。
static Border | createEtchedBorder() 创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
static Border | createEtchedBorder(Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | createEtchedBorder(int type) 创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
static Border | createEtchedBorder(int type, Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | createLineBorder(Color color) 创建一个具有指定颜色的线边框。
static Border | createLineBorder(Color color, int thickness) 创建一个具有指定颜色和宽度的线边框。
static Border | createLoweredBevelBorder() 创建一个具有凹入斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
static MatteBorder | createMatteBorder(int top, int left, int bottom, int right, Color color) 使用纯色创建一个类似衬边的边框。
static MatteBorder | createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon) 创建一个由多层指定图标组成的、类似衬边的边框。
static Border | createRaisedBevelBorder() 创建一个具有凸出斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
static TitledBorder | createTitledBorder(Border border) 创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | createTitledBorder(Border border, String title) 向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | createTitledBorder(Border border, String title, int titleJustification, int titlePosition) 向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。
static TitledBorder | createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont) 向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
static TitledBorder | createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
static TitledBorder | createTitledBorder(String title) 创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

createLineBorder

public static Border createLineBorder(Color color)
创建一个具有指定颜色的线边框。

参数：
color - 用于线条的 Color
返回：
Border 对象

createLineBorder

public static Border createLineBorder(Color color,
                                      int thickness)
创建一个具有指定颜色和宽度的线边框。该宽度将应用于边框的四条边。要分别指定顶线、底线、左边框线和右边框线的宽度，请使用 createMatteBorder(int,int,int,int,Color)。

参数：
color - 用于线条的颜色 Color
thickness - 指定宽度的整数，以像素为单位
返回：
Border 对象

createRaisedBevelBorder

public static Border createRaisedBevelBorder()
创建一个具有凸出斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。（在凸出边框中，高亮显示位于顶部，阴影位于其下。）

返回：
Border 对象

createLoweredBevelBorder

public static Border createLoweredBevelBorder()
创建一个具有凹入斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。（在凹入边框中，阴影位于顶部，高亮显示位于其下。）

返回：
Border 对象

createBevelBorder

public static Border createBevelBorder(int type)
创建一个指定类型的斜面边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。（在凹入边框中，阴影位于顶部，高亮显示位于其下。）

参数：
type - 指定 BevelBorder.LOWERED 或 BevelBorder.RAISED 的整数
返回：
Border 对象

createBevelBorder

public static Border createBevelBorder(int type,
                                       Color highlight,
                                       Color shadow)
使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。高亮显示区域的外边缘使用高亮显示颜色的较明亮的色度。突出阴影区域的内边缘使用阴影颜色的较明亮的色度。

参数：
type - 指定 BevelBorder.LOWERED 或 BevelBorder.RAISED 的整数
highlight - 用于高亮显示的 Color 对象
shadow - 用于阴影的 Color 对象
返回：
Border 对象

createBevelBorder

public static Border createBevelBorder(int type,
                                       Color highlightOuter,
                                       Color highlightInner,
                                       Color shadowOuter,
                                       Color shadowInner)
创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。

注：对于凹入斜面边框，交换阴影内部和外部颜色。

参数：
type - 指定 BevelBorder.LOWERED 或 BevelBorder.RAISED 的整数
highlightOuter - 用于高亮显示区域的外边缘的 Color 对象
highlightInner - 用于高亮显示区域的内边缘的 Color 对象
shadowOuter - 用于阴影区域的外边缘的 Color 对象
shadowInner - 用于阴影区域的内边缘的 Color 对象
返回：
Border 对象

createEtchedBorder

public static Border createEtchedBorder()
创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。

返回：
Border 对象

createEtchedBorder

public static Border createEtchedBorder(Color highlight,
                                        Color shadow)
使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。

参数：
highlight - 用于边框高亮显示的 Color 对象
shadow - 用于边框阴影的 Color 对象
返回：
Border 对象

createEtchedBorder

public static Border createEtchedBorder(int type)
创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。

参数：
type - EtchedBorder.RAISED 或 EtchedBorder.LOWERED 之一
返回：
Border 对象
抛出：
IllegalArgumentException - 如果类型既不是 EtchedBorder.RAISED 也不是 EtchedBorder.LOWERED
从以下版本开始：
1.3

createEtchedBorder

public static Border createEtchedBorder(int type,
                                        Color highlight,
                                        Color shadow)
使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。

参数：
type - EtchedBorder.RAISED 或 EtchedBorder.LOWERED 之一
highlight - 用于边框高亮显示的 Color 对象
shadow - 用于边框阴影的 Color 对象
返回：
Border 对象
从以下版本开始：
1.3

createTitledBorder

public static TitledBorder createTitledBorder(String title)
创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

参数：
title - 包含标题文本的 String
返回：
TitledBorder 对象

createTitledBorder

public static TitledBorder createTitledBorder(Border border)
创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

参数：
border - 向其添加标题的 Border 对象；如果该参数为 null，则 Border 由当前外观确定。
返回：
TitledBorder 对象

createTitledBorder

public static TitledBorder createTitledBorder(Border border,
                                              String title)
向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

参数：
border - 向其添加标题的 Border 对象
title - 包含标题文本的 String
返回：
TitledBorder 对象

createTitledBorder

public static TitledBorder createTitledBorder(Border border,
                                              String title,
                                              int titleJustification,
                                              int titlePosition)
向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。

参数：
border - 向其添加标题的 Border 对象
title - 包含标题文本的 String
titleJustification - 指定标题调整的整数，该值为以下值之一：
  • TitledBorder.LEFT
  • TitledBorder.CENTER
  • TitledBorder.RIGHT
  • TitledBorder.LEADING
  • TitledBorder.TRAILING
  • TitledBorder.DEFAULT_JUSTIFICATION (leading)
titlePosition - 指示文本相对于边框的纵向位置的整数，它为以下值之一：
  • TitledBorder.ABOVE_TOP
  • TitledBorder.TOP（位于顶线上）
  • TitledBorder.BELOW_TOP
  • TitledBorder.ABOVE_BOTTOM
  • TitledBorder.BOTTOM（位于底线上）
  • TitledBorder.BELOW_BOTTOM
  • TitledBorder.DEFAULT_POSITION（顶部）
返回：
TitledBorder 对象

createTitledBorder

public static TitledBorder createTitledBorder(Border border,
                                              String title,
                                              int titleJustification,
                                              int titlePosition,
                                              Font titleFont)
向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。

参数：
border - 向其添加标题的 Border 对象
title - 包含标题文本的 String
titleJustification - 指定标题调整的整数，该值为以下值之一：
  • TitledBorder.LEFT
  • TitledBorder.CENTER
  • TitledBorder.RIGHT
  • TitledBorder.LEADING
  • TitledBorder.TRAILING
  • TitledBorder.DEFAULT_JUSTIFICATION (leading)
titlePosition - 指示文本相对于边框的纵向位置的整数，它为以下值之一：
  • TitledBorder.ABOVE_TOP
  • TitledBorder.TOP（位于顶线上）
  • TitledBorder.BELOW_TOP
  • TitledBorder.ABOVE_BOTTOM
  • TitledBorder.BOTTOM（位于底线上）
  • TitledBorder.BELOW_BOTTOM
  • TitledBorder.DEFAULT_POSITION（顶部）
titleFont - 指定标题字体的 Font 对象
返回：
TitledBorder 对象

createTitledBorder

public static TitledBorder createTitledBorder(Border border,
                                              String title,
                                              int titleJustification,
                                              int titlePosition,
                                              Font titleFont,
                                              Color titleColor)
向现有边框添加一个标题，使其具有指定的位置、字体和颜色。

参数：
border - 向其添加标题的 Border 对象
title - 包含标题文本的 String
titleJustification - 指定标题调整的整数，该值为以下值之一：
  • TitledBorder.LEFT
  • TitledBorder.CENTER
  • TitledBorder.RIGHT
  • TitledBorder.LEADING
  • TitledBorder.TRAILING
  • TitledBorder.DEFAULT_JUSTIFICATION (leading)
titlePosition - 指示文本相对于边框的纵向位置的整数，它为以下值之一：
  • TitledBorder.ABOVE_TOP
  • TitledBorder.TOP（位于顶线上）
  • TitledBorder.BELOW_TOP
  • TitledBorder.ABOVE_BOTTOM
  • TitledBorder.BOTTOM（位于底线上）
  • TitledBorder.BELOW_BOTTOM
  • TitledBorder.DEFAULT_POSITION（顶部）
titleFont - 指定标题字体的 Font 对象
titleColor - 指定标题颜色的 Color 对象
返回：
TitledBorder 对象

createEmptyBorder

public static Border createEmptyBorder()
创建一个不占用空间的空边框。（顶线、底线、左边框线和右边框线的宽度都为零。）

返回：
Border 对象

createEmptyBorder

public static Border createEmptyBorder(int top,
                                       int left,
                                       int bottom,
                                       int right)
创建一个占用空间但没有绘制的空边框，指定了顶线、底线、左边框线和右边框线的宽度。

参数：
top - 指定顶线宽度的整数，以像素为单位
left - 指定左边框线宽度的整数，以像素为单位
bottom - 指定底线宽度的整数，以像素为单位
right - 指定右边框线宽度的整数，以像素为单位
返回：
Border 对象

createCompoundBorder

public static CompoundBorder createCompoundBorder()
创建一个具有 null 内部边缘和 null 外部边缘的合成边框。

返回：
CompoundBorder 对象

createCompoundBorder

public static CompoundBorder createCompoundBorder(Border outsideBorder,
                                                  Border insideBorder)
创建一个合成边框，指定了用于外部和内部边缘的 border 对象。

参数：
outsideBorder - 用于合成边框的外部边缘的 Border 对象
insideBorder - 用于合成边框的内部边缘的 Border 对象
返回：
CompoundBorder 对象

createMatteBorder

public static MatteBorder createMatteBorder(int top,
                                            int left,
                                            int bottom,
                                            int right,
                                            Color color)
使用纯色创建一个类似衬边的边框。（此边框与线边框的不同之处在于您可以指定单独的边框尺寸。）

参数：
top - 指定顶线宽度的整数，以像素为单位
left - 指定左边框线宽度的整数，以像素为单位
right - 指定右边框线宽度的整数，以像素为单位
bottom - 指定底线宽度的整数，以像素为单位
color - 用于边框的 Color
返回：
MatteBorder 对象

createMatteBorder

public static MatteBorder createMatteBorder(int top,
                                            int left,
                                            int bottom,
                                            int right,
                                            Icon tileIcon)
创建一个由多层指定图标组成的、类似衬边的边框。该图标的多个副本被并行放置在一起来填充边框区域。

注：
如果无法加载该图标，则边框区域被绘制为灰色。

参数：
top - 指定顶线宽度的整数，以像素为单位
left - 指定左边框线宽度的整数，以像素为单位
right - 指定右边框线宽度的整数，以像素为单位
bottom - 指定底线宽度的整数，以像素为单位
tileIcon - 用于边框平铺显示的 Icon 对象
返回：
MatteBorder 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BoundedRangeModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 BoundedRangeModel

所有已知实现类：
DefaultBoundedRangeModel
public interface BoundedRangeModel

定义由 Slider 和 ProgressBar 这类组件使用的数据模型。定义四个相关的整数属性：minimum、maximum、extent 和 value。这四个整数定义了两个嵌套的区域，如下所示：

 minimum <= value <= value+extent <= maximum
外部区域是 minimum,maximum，内部区域是 value,value+extent。内部区域必须位于外部区域内，即 value 必须小于或等于 maximum，而 value+extent 必须大于或等于 minimum，并且 maximum 必须大于或等于 minimum。此模型有一些让人微感吃惊的功能。这些奇特功能的存在是为了方便 Swing BoundedRangeModel 客户端，比如 Slider 和 ScrollBar。
  • minimum 和 maximum 设置方法“纠正”其他三个属性，以适应其新 value 参数。例如，设置该模型的 minimum 属性可能更改其 maximum、value 和 extent 属性（以此顺序），以维持上述约束。
  • value 和 extent 设置方法“纠正”其参数，以符合其他三个属性定义的限制。例如，如果 value == maximum，则 setExtent(10) 会将 extent 更改为（更改回）零。
  • 这四个 BoundedRangeModel 值被定义为 Java Beans 属性，不过，Swing ChangeEvent 被用来通知客户端发生的更改，而不是 PropertyChangeEvent。这样做是为了保持监视 BoundedRangeModel 有一个低开销。更改常常根据 MouseDragged 比率进行报告。

有关指定滑块使用的自定义有限范围模型的示例，请参阅 The Java Tutorial 中的 The Anatomy of a Swing-Based Program 一节。

另请参见：
DefaultBoundedRangeModel

方法摘要
void | addChangeListener(ChangeListener x) 将一个 ChangeListener 添加到模型的侦听器列表中。
int | getExtent() 返回模型的 extent，即从模型的 value 开始的内部范围的长度。
int | getMaximum() 返回模型的 maximum。
int | getMinimum() 返回最小的可接受值。
int | getValue() 返回模型的当前值。
boolean | getValueIsAdjusting() 如果 value 属性的当前更改是一系列更改的一部分，则返回 true。
void | removeChangeListener(ChangeListener x) 从模型的侦听器列表中移除一个 ChangeListener。
void | setExtent(int newExtent) 设置模型的 extent。
void | setMaximum(int newMaximum) 将模型的 maximum 设置为 newMaximum。
void | setMinimum(int newMinimum) 将模型的 minimum 设置为 newMinimum。
void | setRangeProperties(int value, int extent, int min, int max, boolean adjusting) 此方法使用一个方法调用设置模型的所有数据。
void | setValue(int newValue) 如果 newValue 满足模型的约束限制，则将模型的当前值设置为 newValue。
void | setValueIsAdjusting(boolean b) 此属性指示，即将对模型值所做的任何更改都应被认为是一个单独的事件。

方法详细信息

getMinimum

int getMinimum()
返回最小的可接受值。

返回：
minimum 属性的值
另请参见：
setMinimum(int)

setMinimum

void setMinimum(int newMinimum)
将模型的 minimum 设置为 newMinimum。其他三个属性可能也要更改，以确保：
 minimum <= value <= value+extent <= maximum

如果模型发生更改，则通知所有侦听器。

参数：
newMinimum - 模型的新 minimum
另请参见：
getMinimum(), addChangeListener(javax.swing.event.ChangeListener)

getMaximum

int getMaximum()
返回模型的 maximum。注意，模型值的上限是 (maximum - extent)。

返回：
maximum 属性的值。
另请参见：
setMaximum(int), setExtent(int)

setMaximum

void setMaximum(int newMaximum)
将模型的 maximum 设置为 newMaximum。其他三个属性可能也要更改，以确保
 minimum <= value <= value+extent <= maximum

如果模型发生更改，则通知所有侦听器。

参数：
newMaximum - 模型的新 maximum
另请参见：
getMaximum(), addChangeListener(javax.swing.event.ChangeListener)

getValue

int getValue()
返回模型的当前值。注意，模型值的上限是 maximum - extent，下限是 minimum。

返回：
模型的值
另请参见：
setValue(int)

setValue

void setValue(int newValue)
如果 newValue 满足模型的约束限制，则将模型的当前值设置为 newValue。这些约束限制是：
 minimum <= value <= value+extent <= maximum
否则，如果 newValue 小于 minimum，则将它设置为 minimum；如果它大于 maximum，则将它设置为 maximum；如果它大于 value+extent，则将它设置为 value+extent。

在对滚动条使用 BoundedRange 模型时，value 指定滚动条调节器（也称为 "thumb" 或 "elevator"）的起始点。value 通常表示正被滚动对象的可见部分的起始点。

如果模型发生更改，则通知所有侦听器。

参数：
newValue - 模型的新值
另请参见：
getValue()

setValueIsAdjusting

void setValueIsAdjusting(boolean b)
此属性指示，即将对模型值所做的任何更改都应被认为是一个单独的事件。在开始对该值进行一系列的更改时，此属性将被设置为 true，在该值已经结束更改时，该值将被设置为 false。通常，此方法允许侦听器只在提交了最终值时采取行动，而不是必须对所有中间值进行更新。

滑块和滚动条在进行拖动时使用此属性。

参数：
b - 如果即将进行的 value 属性更改是一系列更改的一部分，则该参数为 true

getValueIsAdjusting

boolean getValueIsAdjusting()
如果 value 属性的当前更改是一系列更改的一部分，则返回 true。

返回：
valueIsAdjustingProperty。
另请参见：
setValueIsAdjusting(boolean)

getExtent

int getExtent()
返回模型的 extent，即从模型的 value 开始的内部范围的长度。

返回：
模型的 extent 属性的值
另请参见：
setExtent(int), setValue(int)

setExtent

void setExtent(int newExtent)
设置模型的 extent。newExtent 被迫大于或等于零，且小于等于 maximum - value。

在对滚动条使用 BoundedRange 模型时，extent 定义滚动条调节器（也称为 "thumb" 或 "elevator"）的长度。extent 通常表示正被滚动的对象的可见量。在使用滑块时，extent 确定 value 可以“跳跃”多少，例如当用户按下 PgUp 或 PgDn 时跳跃的量。

如果模型发生更改，则通知所有侦听器。

参数：
newExtent - 模型的新 extent
另请参见：
getExtent(), setValue(int)

setRangeProperties

void setRangeProperties(int value,
                        int extent,
                        int min,
                        int max,
                        boolean adjusting)
此方法使用一个方法调用设置模型的所有数据。该方法引起生成一个更改事件。在需要同时调整所有模型数据并且不想产生一些个别更改事件时，此方法很方便。

参数：
value - 给出当前值的一个 int 值
extent - 给出 value 可以“跳跃”的量的 int 值
min - 给出 minimum 值的 int 值
max - 给出 maximum 值的 int 值
adjusting - 一个 boolean 值，如果正在进行一系列的更改，则该参数为 true
另请参见：
setValue(int), setExtent(int), setMinimum(int), setMaximum(int), setValueIsAdjusting(boolean)

addChangeListener

void addChangeListener(ChangeListener x)
将一个 ChangeListener 添加到模型的侦听器列表中。

参数：
x - 要添加的 ChangeListener
另请参见：
removeChangeListener(javax.swing.event.ChangeListener)

removeChangeListener

void removeChangeListener(ChangeListener x)
从模型的侦听器列表中移除一个 ChangeListener。

参数：
x - 要移除的 ChangeListener
另请参见：
addChangeListener(javax.swing.event.ChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Box (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Box

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.Box
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class Box
extends JComponent
implements Accessible

使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。Box 提供几个对使用 BoxLayout 的容器（甚至非 Box 容器）有用的类方法。

Box 类可以创建几种影响布局的不可见组件：glue、struts 和 rigid 区域。如果 Box 包含的所有组件都有一个固定大小，可以使用 glue 组件（由 createGlue 返回）来控制组件的位置。如果想让两个组件之间有一个固定的空间量，可以尝试使用 strut（createHorizontalStrut 或 createVerticalStrut）。如果需要一个总是占用相同空间量的不可见组件，可以通过调用 createRigidArea 获得。

如果要实现一个 BoxLayout，可以在 The Java Tutorial 的 How to Use BoxLayout 一节中获得更多信息和示例。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
BoxLayout

嵌套类摘要
protected class | Box.AccessibleBox 此类实现 Box 类的可访问性支持。
static class | Box.Filler 参与布局但没有视图的轻量级组件的实现。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Box(int axis)
创建一个沿指定坐标轴显示其组件的 Box。
方法摘要
static Component | createGlue() 创建一个不可见的 "glue" 组件，其可见组件有一个最大宽度（对于横向 box）或高度（对于纵向 box）的 Box，该组件可能很有用。
static Box | createHorizontalBox() 创建一个从左到右显示其组件的 Box。
static Component | createHorizontalGlue() 创建一个横向 glue 组件。
static Component | createHorizontalStrut(int width) 创建一个不可见的、固定宽度的组件。
static Component | createRigidArea(Dimension d) 创建一个总是具有指定大小的不可见组件。
static Box | createVerticalBox() 创建一个从上到下显示其组件的 Box。
static Component | createVerticalGlue() 创建一个纵向 glue 组件。
static Component | createVerticalStrut(int height) 创建一个不可见的、固定高度的组件。
AccessibleContext | getAccessibleContext() 获取与此 Box 相关联的 AccessibleContext。
protected void | paintComponent(Graphics g) 绘制此 Box。
void | setLayout(LayoutManager l) 抛出一个 AWTError，因为 Box 只能使用 BoxLayout。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Box

public Box(int axis)
创建一个沿指定坐标轴显示其组件的 Box。

参数：
axis - 可以是 BoxLayout.X_AXIS、BoxLayout.Y_AXIS、BoxLayout.LINE_AXIS 或 BoxLayout.PAGE_AXIS。
抛出：
AWTError - 如果 axis 无效
另请参见：
createHorizontalBox(), createVerticalBox()
方法详细信息

createHorizontalBox

public static Box createHorizontalBox()
创建一个从左到右显示其组件的 Box。如果想创建一个遵守该组件方向的 Box，则应使用构造方法并传入 BoxLayout.LINE_AXIS 来创建 Box，例如：
   Box lineBox = new Box(BoxLayout.LINE_AXIS);

返回：
box

createVerticalBox

public static Box createVerticalBox()
创建一个从上到下显示其组件的 Box。如果想创建一个遵守该组件方向的 Box，则应使用构造方法并传入 BoxLayout.PAGE_AXIS 来创建 Box，例如：
   Box lineBox = new Box(BoxLayout.PAGE_AXIS);

返回：
box

createRigidArea

public static Component createRigidArea(Dimension d)
创建一个总是具有指定大小的不可见组件。

参数：
d - 不可见组件的尺寸
返回：
该组件
另请参见：
createGlue(), createHorizontalStrut(int), createVerticalStrut(int)

createHorizontalStrut

public static Component createHorizontalStrut(int width)
创建一个不可见的、固定宽度的组件。在一个横向 box 中，通常使用此方法强行使两个组件之间具有某一空间量。在一个纵向 box 中，可以使用此方法强行使 box 至少具有指定宽度。只有存在可用的剩余空间时，不可见组件才有高度，在这种情况下，就像其他任何没有最大高度的组件一样，它将采用其可用的共享空间。

参数：
width - 不可见组件的宽度，以像素为单位，该宽度 >= 0
返回：
该组件
另请参见：
createVerticalStrut(int), createGlue(), createRigidArea(java.awt.Dimension)

createVerticalStrut

public static Component createVerticalStrut(int height)
创建一个不可见的、固定高度的组件。在一个纵向 box 中，通常使用此方法强行使两个组件之间具有某一空间量。在一个横向 box 中，可以使用此方法强行使 box 至少具有指定高度。只有具有可用的剩余空间时，不可见组件才有宽度，在这种情况下，就像其他任何没有最大宽度的组件一样，它将采用其可用的共享空间。

参数：
height - 不可见组件的高度，以像素为单位，该高度 >= 0
返回：
该组件
另请参见：
createHorizontalStrut(int), createGlue(), createRigidArea(java.awt.Dimension)

createGlue

public static Component createGlue()
创建一个不可见的 "glue" 组件，其可见组件有一个最大宽度（对于横向 box）或高度（对于纵向 box）的 Box，该组件可能很有用。可将该 glue 组件视为一种粘性物质，它尽其所需地进行扩展，以填充与其相邻组件间的空间。

例如，假定有一个包含两个固定大小组件的横向 box。如果 box 获得额外的空间，而这两个固定大小的组件不会变得更大，那么额外的空间放到哪去呢？在没有 glue 的情况下，额外的空间将放到第二个组件的右边。如果将 glue 放在两个固定大小组件之间，则额外的空间将放到那里。如果将 glue 放在第一个固定大小组件的前面，则额外的空间将放到那里，两个固定大小的组件将被挤到 box 的右边缘。如果将 glue 放在第一个固定大小组件之前，第二个固定大小组件之后，则这两个固定大小组件将被挤到 box 的中心。

要使用 glue，请调用 Box.createGlue，并将返回的组件添加到容器中。glue 组件没有最小大小或首选大小，因此只有剩余的空间可用时，它才占用空间。如果剩余的空间可用，那么就像其他任何没有最大宽度或高度的组件一样，glue 组件将占用其可用的共享横向或纵向空间。

返回：
组件

createHorizontalGlue

public static Component createHorizontalGlue()
创建一个横向 glue 组件。

返回：
组件

createVerticalGlue

public static Component createVerticalGlue()
创建一个纵向 glue 组件。

返回：
组件

setLayout

public void setLayout(LayoutManager l)
抛出一个 AWTError，因为 Box 只能使用 BoxLayout。

覆盖：
类 Container 中的 setLayout
参数：
l - 要使用的布局管理器
另请参见：
Container.doLayout(), Container.getLayout()

paintComponent

protected void paintComponent(Graphics g)
绘制此 Box。如果此 Box 具有一个 UI，则此方法调用 super 的实现，否则，如果此 Box 是不透明的，则使用背景填充 Graphics。

覆盖：
类 JComponent 中的 paintComponent
参数：
g - 要绘制的 Graphics
抛出：
NullPointerException - 如果 g 为 null
从以下版本开始：
1.6
另请参见：
JComponent.paint(java.awt.Graphics), ComponentUI

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Box 相关联的 AccessibleContext。对于 box 来说，AccessibleContext 采用 AccessibleAWTDialog 的形式。如有必要，可创建一个新的 AccessibleAWTBox 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleBox，它充当此 Box 的 AccessibleContext。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Box.AccessibleBox (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Box.AccessibleBox

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.Box.AccessibleBox
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
Box
protected class Box.AccessibleBox
extends Container.AccessibleAWTContainer

此类实现 Box 类的可访问性支持。

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Box.AccessibleBox()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Box.AccessibleBox

protected Box.AccessibleBox()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象 (AccessibleRole.FILLER) 的职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Box.Filler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Box.Filler

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.Box.Filler
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
正在封闭类：
Box
public static class Box.Filler
extends JComponent
implements Accessible

参与布局但没有视图的轻量级组件的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class Box.Filler.AccessibleBoxFiller
此类实现 Box.Filler 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
Box.Filler(Dimension min, Dimension pref, Dimension max)
使用给定的大小范围创建形状的构造方法。
方法摘要
void | changeShape(Dimension min, Dimension pref, Dimension max) 更改此形状的大小请求。
AccessibleContext | getAccessibleContext() 获取与此 Box.Filler 相关联的 AccessibleContext。
protected void | paintComponent(Graphics g) 绘制此 Filler。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

Box.Filler

public Box.Filler(Dimension min,
                  Dimension pref,
                  Dimension max)
使用给定的大小范围创建形状的构造方法。

参数：
min - 最小大小
pref - 首选大小
max - 最大大小
方法详细信息

changeShape

public void changeShape(Dimension min,
                        Dimension pref,
                        Dimension max)
更改此形状的大小请求。此方法使 invalidate() 向上传播，以至最终将使用新的大小进行布局。

参数：
min - 将由 getMinimumSize 返回的值
pref - 将由 getPreferredSize 返回的值
max - 将由 getMaximumSize 返回的值

paintComponent

protected void paintComponent(Graphics g)
绘制此 Filler。如果此 Filler 具有一个 UI，则此方法调用 super 的实现，否则，如果此 Filler 是不透明的，则使用背景填充 Graphics。

覆盖：
类 JComponent 中的 paintComponent
参数：
g - 要绘制的 Graphics
抛出：
NullPointerException - 如果 g 为 null
从以下版本开始：
1.6
另请参见：
JComponent.paint(java.awt.Graphics), ComponentUI

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 Box.Filler 相关联的 AccessibleContext。对于 box filler，AccessibleContext 采用 AccessibleBoxFiller 的形式。如有必要，可创建一个新的 AccessibleAWTBoxFiller 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleBoxFiller，它充当此 Box.Filler 的 AccessibleContext。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Box.Filler.AccessibleBoxFiller (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Box.Filler.AccessibleBoxFiller

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  javax.swing.Box.Filler.AccessibleBoxFiller
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
Box.Filler
protected class Box.Filler.AccessibleBoxFiller
extends Component.AccessibleAWTComponent

此类实现 Box.Filler 类的可访问性支持。

嵌套类摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected Box.Filler.AccessibleBoxFiller()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, addPropertyChangeListener, contains, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Box.Filler.AccessibleBoxFiller

protected Box.Filler.AccessibleBoxFiller()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述对象 (AccessibleRole.FILLER) 的职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


BoxLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 BoxLayout

java.lang.Object
    继承者  javax.swing.BoxLayout
所有已实现的接口：
LayoutManager, LayoutManager2, Serializable
直接已知子类：
DefaultMenuLayout
public class BoxLayout
extends Object
implements LayoutManager2, Serializable

允许垂直或水平布置多个组件的布局管理器。这些组件将不包装，因此举例来说，垂直排列的组件在重新调整框架的大小时仍然被垂直排列。

以下文本是对此图像的描述。

用水平组件和垂直组件的不同组合嵌套多面板的作用类似于 GridBagLayout，但没那么复杂。该图显示了两个水平排列的面板，每个面板都包含 3 个垂直排列的组件。

BoxLayout 管理器是用 axis 参数构造的，该参数指定了将进行的布局类型。有四个选择：

X_AXIS：从左到右水平布置组件。
Y_AXIS：从上到下垂直布置组件。
LINE_AXIS：根据容器的 ComponentOrientation 属性，按照文字在一行中的排列方式布置组件。如果容器的 ComponentOrientation 表示水平，则将组件水平放置，否则将它们垂直放置。对于水平方向，如果容器的 ComponentOrientation 表示从左到右，则组件从左到右放置，否则将它们从右到左放置。对于垂直方向，组件总是从上到下放置的。
PAGE_AXIS：根据容器的 ComponentOrientation 属性，按照文本行在一页中的排列方式布置组件。如果容器的 ComponentOrientation 表示水平，则将组件垂直放置，否则将它们水平放置。对于水平方向，如果容器的 ComponentOrientation 表示从左到右，则组件从左到右放置，否则将它们从右到左放置。对于垂直方向，组件总是从上向下放置的。

对于所有方向，组件按照将它们添加到容器中的顺序排列。

BoxLayout 试图按照组件的首选宽度（对于水平布局）或首选高度（对于垂直布局）来排列它们。对于水平布局，如果并不是所有的组件都具有相同的高度，则 BoxLayout 会试图让所有组件都具有最高组件的高度。如果对于某一特定组件而言这是不可能的，则 BoxLayout 会根据该组件的 Y 调整值对它进行垂直调整。默认情况下，组件的 Y 调整值为 0.5，这意味着组件的垂直中心应该与其他 Y 调整值为 0.5 的组件的垂直中心具有相同 Y 坐标。

同样地，对于垂直布局，BoxLayout 试图让列中的所有组件具有最宽组件的宽度。如果这样做失败，则 BoxLayout 会根据这些组件的 X 调整值对它进行水平调整。对于 PAGE_AXIS 布局，基于组件的开始边水平调整。换句话说，如果容器的 ComponentOrientation 表示从左到右，则 X 调整值为 0.0 意味着组件的左边缘，否则它意味着组件的右边缘。

许多程序使用 Box 类，而不是直接使用 BoxLayout。Box 类是使用 BoxLayout 的轻量级容器。它还提供了一些帮助您很好地使用 BoxLayout 的便利方法。要获取您想要的排列，将组件添加到多个嵌套的 box 中是一种功能强大的方法。

有关更多信息和示例，请参阅 The Java Tutorial 中的 How to Use BoxLayout 一节。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Box, ComponentOrientation, JComponent.getAlignmentX(), JComponent.getAlignmentY()

字段摘要
static int | LINE_AXIS 指定应该根据目标容器的 ComponentOrientation 属性确定的文本行方向放置组件。
static int | PAGE_AXIS 指定应该根据目标容器的 ComponentOrientation 属性确定的文本行在页面中的流向来放置组件。
static int | X_AXIS 指定组件应该从左到右放置。
static int | Y_AXIS 指定组件应该从上到下放置。
构造方法摘要
BoxLayout(Container target, int axis)
创建一个将沿给定轴放置组件的布局管理器。
方法摘要
void | addLayoutComponent(Component comp, Object constraints) 此类不使用。
void | addLayoutComponent(String name, Component comp) 此类不使用。
int | getAxis() 返回用于布局组件的轴。
float | getLayoutAlignmentX(Container target) 返回容器沿 X 轴的对齐方式。
float | getLayoutAlignmentY(Container target) 返回容器沿 Y 轴的对齐方式。
Container | getTarget() 返回使用此布局管理器的容器。
void | invalidateLayout(Container target) 指示一个子容器已经更改其布局相关信息，因此应该刷新所有已缓存的计算结果。
void | layoutContainer(Container target) 在需要布置指定容器时，由 AWT 调用 。
Dimension | maximumLayoutSize(Container target) 返回目标容器布置其所包含的组件时可使用的最大尺寸。
Dimension | minimumLayoutSize(Container target) 返回布置包含在指定目标容器中的组件所需的最小尺寸。
Dimension | preferredLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。
void | removeLayoutComponent(Component comp) 此类不使用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

X_AXIS

public static final int X_AXIS
指定组件应该从左到右放置。

另请参见：
常量字段值

Y_AXIS

public static final int Y_AXIS
指定组件应该从上到下放置。

另请参见：
常量字段值

LINE_AXIS

public static final int LINE_AXIS
指定应该根据目标容器的 ComponentOrientation 属性确定的文本行方向放置组件。

另请参见：
常量字段值

PAGE_AXIS

public static final int PAGE_AXIS
指定应该根据目标容器的 ComponentOrientation 属性确定的文本行在页面中的流向来放置组件。

另请参见：
常量字段值
构造方法详细信息

BoxLayout

public BoxLayout(Container target,
                 int axis)
创建一个将沿给定轴放置组件的布局管理器。

参数：
target - 需要布置的容器
axis - 布置组件时使用的轴。它可以是以下值之一：BoxLayout.X_AXIS、BoxLayout.Y_AXIS、BoxLayout.LINE_AXIS 或 BoxLayout.PAGE_AXIS
抛出：
AWTError - 如果 axis 的值无效
方法详细信息

getTarget

public final Container getTarget()
返回使用此布局管理器的容器。

返回：
使用此布局管理器的容器
从以下版本开始：
1.6

getAxis

public final int getAxis()
返回用于布局组件的轴。返回下列轴之一：BoxLayout.X_AXIS、BoxLayout.Y_AXIS、BoxLayout.LINE_AXIS 或 BoxLayout.PAGE_AXIS

返回：
用于布局组件的轴
从以下版本开始：
1.6

invalidateLayout

public void invalidateLayout(Container target)
指示一个子容器已经更改其布局相关信息，因此应该刷新所有已缓存的计算结果。

在 Container 上调用 invalidate 方法时，由 AWT 调用此方法。因为可以对事件线程异步调用 invalidate 方法，所以可以异步调用此方法。

指定者：
接口 LayoutManager2 中的 invalidateLayout
参数：
target - 受影响的容器
抛出：
AWTError - 如果目标容器不是指定给 BoxLayout 构造方法的容器

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
此类不使用。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 组件的名称
comp - 组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
此类不使用。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 组件

addLayoutComponent

public void addLayoutComponent(Component comp,
                               Object constraints)
此类不使用。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
comp - 组件
constraints - 约束

preferredLayoutSize

public Dimension preferredLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的首选尺寸。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
target - 需要布置的容器
返回：
>= 0 && <= Integer.MAX_VALUE 的尺寸
抛出：
AWTError - 如果目标容器不是指定给 BoxLayout 构造方法的容器
另请参见：
Container, minimumLayoutSize(java.awt.Container), maximumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container target)
返回布置包含在指定目标容器中的组件所需的最小尺寸。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
target - 需要布置的容器
返回：
>= 0 && <= Integer.MAX_VALUE 的尺寸
抛出：
AWTError - 如果目标容器不是指定给 BoxLayout 构造方法的容器
另请参见：
preferredLayoutSize(java.awt.Container), maximumLayoutSize(java.awt.Container)

maximumLayoutSize

public Dimension maximumLayoutSize(Container target)
返回目标容器布置其所包含的组件时可使用的最大尺寸。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
参数：
target - 需要布置的容器
返回：
>= 0 && <= Integer.MAX_VALUE 的尺寸
抛出：
AWTError - 如果目标容器不是指定给 BoxLayout 构造方法的容器
另请参见：
preferredLayoutSize(java.awt.Container), minimumLayoutSize(java.awt.Container)

getLayoutAlignmentX

public float getLayoutAlignmentX(Container target)
返回容器沿 X 轴的对齐方式。如果 box 是水平的，则返回默认对齐方式。否则，将返回沿 X 轴放置子组件所需的对齐方式。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX
参数：
target - 容器
返回：
>= 0.0f && <= 1.0f 的调整值
抛出：
AWTError - 如果目标容器不是指定给 BoxLayout 构造方法的容器

getLayoutAlignmentY

public float getLayoutAlignmentY(Container target)
返回容器沿 Y 轴的对齐方式。如果 box 是垂直的，则返回默认对齐方式。否则，将返回沿 Y 轴放置子组件所需的对齐方式。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY
参数：
target - 容器
返回：
>= 0.0f && <= 1.0f 的调整值
抛出：
AWTError - 如果目标容器不是指定给 BoxLayout 构造方法的容器

layoutContainer

public void layoutContainer(Container target)
在需要布置指定容器时，由 AWT 调用 。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
target - 要布置的容器
抛出：
AWTError - 如果目标容器不是指定给 BoxLayout 构造方法的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ButtonGroup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ButtonGroup

java.lang.Object
    继承者  javax.swing.ButtonGroup
所有已实现的接口：
Serializable
public class ButtonGroup
extends Object
implements Serializable

此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。使用相同的 ButtonGroup 对象创建一组按钮意味着“开启”其中一个按钮时，将关闭组中的其他所有按钮。

可将 ButtonGroup 用于任何从 AbstractButton 继承的对象组。通常，按钮组包含 JRadioButton、JRadioButtonMenuItem 或 JToggleButton 的实例。但将 JButton 或 JMenuItem 的实例放入按钮组中并没有什么意义，因为 JButton 和 JMenuItem 不实现选择状态。

最初，组中的所有按钮都未被选择。

有关使用按钮组的示例和更多信息，请参阅 The Java Tutorial 中的 How to Radio Buttons 一节。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected  Vector<AbstractButton> buttons
构造方法摘要
ButtonGroup()
创建一个新的 ButtonGroup。
方法摘要
void | add(AbstractButton b) 将按钮添加到组中。
void | clearSelection() 清除选中内容，从而没有选择 ButtonGroup 中的任何按钮。
int | getButtonCount() 返回此组中的按钮数。
Enumeration<AbstractButton> | getElements() 返回此组中的所有按钮。
ButtonModel | getSelection() 返回选择按钮的模型。
boolean | isSelected(ButtonModel m) 返回对是否已选择一个 ButtonModel 的判断。
void | remove(AbstractButton b) 从组中移除按钮。
void | setSelected(ButtonModel m, boolean b) 为 ButtonModel 设置选择值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

buttons

protected Vector<AbstractButton> buttons
构造方法详细信息

ButtonGroup

public ButtonGroup()
创建一个新的 ButtonGroup。

方法详细信息

add

public void add(AbstractButton b)
将按钮添加到组中。

参数：
b - 要添加的按钮

remove

public void remove(AbstractButton b)
从组中移除按钮。

参数：
b - 要移除的按钮

clearSelection

public void clearSelection()
清除选中内容，从而没有选择 ButtonGroup 中的任何按钮。

从以下版本开始：
1.6

getElements

public Enumeration<AbstractButton> getElements()
返回此组中的所有按钮。

返回：
此组中的按钮的 Enumeration

getSelection

public ButtonModel getSelection()
返回选择按钮的模型。

返回：
选择的按钮模型

setSelected

public void setSelected(ButtonModel m,
                        boolean b)
为 ButtonModel 设置选择值。一次只能选择组中的一个按钮。

参数：
m - ButtonModel
b - 如果此按钮被选择，则该参数为 true，否则为 false

isSelected

public boolean isSelected(ButtonModel m)
返回对是否已选择一个 ButtonModel 的判断。

返回：
如果选择了按钮，则返回 true；否则返回 false

getButtonCount

public int getButtonCount()
返回此组中的按钮数。

返回：
按钮计数
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ButtonModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 ButtonModel

所有超级接口：
ItemSelectable
所有已知实现类：
DefaultButtonModel, JToggleButton.ToggleButtonModel
public interface ButtonModel
extends ItemSelectable

按钮的状态模型。

此模型用于常规按钮，也可以用于复选框和单选钮，它们是特殊种类的按钮。实际上，按钮的 UI 负责调用其模型上的方法来管理状态，细节如下：

简单地说，在一个常规按钮上按下并释放鼠标将触发按钮并导致触发 ActionEvent。可通过按钮（通常是空格键）的外观所定义的键盘键生成相同的行为。当按钮具有焦点时，按下并释放此键将得到相同的结果。对于复选框和单选钮，刚刚所描述的鼠标或键盘的等效序列导致选中该按钮。

详细地说，当与鼠标一起使用时，按钮的状态模型的工作方式如下：
在按钮的上方按下鼠标使得模型既被选中又被按下。只要鼠标保持按下，模型就保持按下，即使鼠标移到按钮之外也是如此。相反，只有当鼠标在按钮边界内保持按下时，模型才是被选中的（它可移进或移出按钮的边界，但是只有在按钮中的那部分时间模型才是被选中的）。当在模型被选中的同时释放鼠标时，也就是说当鼠标以前在按钮上按下（并且尚未释放），之后在该按钮上方释放时，将触发按钮和 ActionEvent。鼠标释放后，模型就处于未被选中和未被按下状态。

详细地说，当与键盘一起使用时，按钮状态模型的工作方式如下：
当按钮具有焦点时，按下键盘键所定义的外观使得模型既被选中又被按下。只要此键保持按下，模型就保持此状态。释放该键会将模型设置为未被选中和未被按下、触发按钮并导致触发 ActionEvent。

方法摘要
void | addActionListener(ActionListener l) 向模型添加一个 ActionListener。
void | addChangeListener(ChangeListener l) 向模型添加一个 ChangeListener。
void | addItemListener(ItemListener l) 向模型添加一个 ItemListener。
String | getActionCommand() 返回该按钮的动作命令字符串。
int | getMnemonic() 获取该按钮的键盘助记符。
boolean | isArmed() 指示触发按钮操作的部分委托事项。
boolean | isEnabled() 指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。
boolean | isPressed() 指示按钮是否已被按下。
boolean | isRollover() 指示鼠标是否在按钮上。
boolean | isSelected() 指示按钮是否已经被选择。
void | removeActionListener(ActionListener l) 从模型中移除一个 ActionListener。
void | removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。
void | removeItemListener(ItemListener l) 从模型中移除一个 ItemListener。
void | setActionCommand(String s) 设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。
void | setArmed(boolean b) 将此按钮标记为选中或未选中。
void | setEnabled(boolean b) 启用或禁用该按钮。
void | setGroup(ButtonGroup group) 标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
void | setMnemonic(int key) 设置该按钮的键盘助记符（快捷键或加速键）。
void | setPressed(boolean b) 将按钮设置为按下或未被按下。
void | setRollover(boolean b) 设置或清除该按钮的翻转状态
void | setSelected(boolean b) 选择或取消选择该按钮。
从接口 java.awt.ItemSelectable 继承的方法
getSelectedObjects

方法详细信息

isArmed

boolean isArmed()
指示触发按钮操作的部分委托事项。

返回：
如果按钮被选中，并准备触发它，则返回 true
另请参见：
setArmed(boolean)

isSelected

boolean isSelected()
指示按钮是否已经被选择。只有某些类型的按钮需要此指示，比如单选钮和复选框。

返回：
如果按钮已选择，则返回 true

isEnabled

boolean isEnabled()
指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。

返回：
如果启用按钮，则返回 true

isPressed

boolean isPressed()
指示按钮是否已被按下。

返回：
如果按钮已被按下，则返回 true

isRollover

boolean isRollover()
指示鼠标是否在按钮上。

返回：
如果鼠标在按钮上，则返回 true

setArmed

void setArmed(boolean b)
将此按钮标记为选中或未选中。

参数：
b - 是否应该选中该按钮

setSelected

void setSelected(boolean b)
选择或取消选择该按钮。

参数：
b - 为 true 表示选择该按钮，为 false 表示取消对该按钮的选择。

setEnabled

void setEnabled(boolean b)
启用或禁用该按钮。

参数：
b - 是否应该启用该按钮
另请参见：
isEnabled()

setPressed

void setPressed(boolean b)
将按钮设置为按下或未被按下。

参数：
b - 是否应该按下该按钮
另请参见：
isPressed()

setRollover

void setRollover(boolean b)
设置或清除该按钮的翻转状态

参数：
b - 该按钮是否处于翻转状态
另请参见：
isRollover()

setMnemonic

void setMnemonic(int key)
设置该按钮的键盘助记符（快捷键或加速键）。

参数：
key - 指示加速键的 int 值

getMnemonic

int getMnemonic()
获取该按钮的键盘助记符。

返回：
指示加速键的 int 值
另请参见：
setMnemonic(int)

setActionCommand

void setActionCommand(String s)
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。

参数：
s - 标识生成的事件的 String
另请参见：
getActionCommand(), ActionEvent.getActionCommand()

getActionCommand

String getActionCommand()
返回该按钮的动作命令字符串。

返回：
标识生成的事件的 String
另请参见：
setActionCommand(java.lang.String)

setGroup

void setGroup(ButtonGroup group)
标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。

参数：
group - 该按钮所属的 ButtonGroup

addActionListener

void addActionListener(ActionListener l)
向模型添加一个 ActionListener。

参数：
l - 要添加的侦听器

removeActionListener

void removeActionListener(ActionListener l)
从模型中移除一个 ActionListener。

参数：
l - 要移除的侦听器

addItemListener

void addItemListener(ItemListener l)
向模型添加一个 ItemListener。

指定者：
接口 ItemSelectable 中的 addItemListener
参数：
l - 要添加的侦听器
另请参见：
ItemEvent

removeItemListener

void removeItemListener(ItemListener l)
从模型中移除一个 ItemListener。

指定者：
接口 ItemSelectable 中的 removeItemListener
参数：
l - 要移除的侦听器
另请参见：
ItemEvent

addChangeListener

void addChangeListener(ChangeListener l)
向模型添加一个 ChangeListener。

参数：
l - 要添加的侦听器

removeChangeListener

void removeChangeListener(ChangeListener l)
从模型中移除一个 ChangeListener。

参数：
l - 要移除的侦听器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CellEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 CellEditor

所有已知子接口：
TableCellEditor, TreeCellEditor
所有已知实现类：
AbstractCellEditor, DefaultCellEditor, DefaultTreeCellEditor
public interface CellEditor

此接口定义任何通用编辑器应该能够实现的方法。

让此接口启用复杂组件（编辑器的客户端），比如 JTree 和 JTable，从而允许任何一般编辑器编辑表单元格值、树单元格值等等。如果没有此一般编辑器接口，则 JTable 不得不了解特定编辑器，比如 JTextField、JCheckBox、JComboBox 等等。此外，如果没有此接口，则编辑器（如 JTable）的客户端无法使用用户或第三方 ISV 将来开发的其他任何编辑器。

要使用此接口，创建新编辑器的开发人员可以用新的组件实现该接口。或者开发人员可以选择一个基于包装器的方法，提供一个实现 CellEditor 接口的辅助对象（请参见 JCellEditor 获取示例）。如果用户想将第三方 ISV 编辑器用于 JTable，但该 ISV 没有实现 CellEditor 接口，则包装器方法特别有用。用户可以只创建一个包含第三方编辑器对象实例的对象，并将 CellEditor API“转换”成第三方编辑器的 API。

另请参见：
CellEditorListener

方法摘要
void | addCellEditorListener(CellEditorListener l) 当编辑器停止运作或取消编辑时，向被通知的列表添加一个侦听器。
void | cancelCellEditing() 告知编辑器取消编辑并且不接受任何已部分编辑的值。
Object | getCellEditorValue() 返回编辑器中包含的值。
boolean | isCellEditable(EventObject anEvent) 询问编辑器它是否可以使用 anEvent 开始进行编辑。
void | removeCellEditorListener(CellEditorListener l) 从被通知的列表中移除一个侦听器
boolean | shouldSelectCell(EventObject anEvent) 如果应该选择正编辑的单元格，则返回 true，否则返回 false。
boolean | stopCellEditing() 告知编辑器停止编辑并接受任何已部分编辑的值作为编辑器的值。

方法详细信息

getCellEditorValue

Object getCellEditorValue()
返回编辑器中包含的值。

返回：
编辑器中包含的值

isCellEditable

boolean isCellEditable(EventObject anEvent)
询问编辑器它是否可以使用 anEvent 开始进行编辑。anEvent 在将要调用的组件的坐标系统中。编辑器不能假定由 getCellEditorComponent 返回的 Component 已被安装。此方法供客户端使用，以避免不可能进行编辑时设置和安装编辑器组件所带来的花费。如果可以开始进行编辑，则此方法返回 true。

参数：
anEvent - 编辑器考虑是否开始进行编辑时应该使用的事件
返回：
如果可开始进行编辑，则返回 true
另请参见：
shouldSelectCell(java.util.EventObject)

shouldSelectCell

boolean shouldSelectCell(EventObject anEvent)
如果应该选择正编辑的单元格，则返回 true，否则返回 false。通常，返回的值为 true，因为大多数情况下都应该选择正编辑的单元格。不过，通过返回 false 可以使选择不受某些类型的编辑更改的影响。例如，对于包含一列复选框的表，用户也许想在不改变选择的情况下能够更改这些复选框。（请参见 Netscape Communicator 来获得这样的示例）当然，这取决于编辑器的客户端是否使用返回的值，但是，如果它不想使用返回值的话，则不必使用。

参数：
anEvent - 编辑器开始进行编辑时应该使用的事件
返回：
如果编辑器愿意选择正编辑的单元格，则返回 true；否则返回 false
另请参见：
isCellEditable(java.util.EventObject)

stopCellEditing

boolean stopCellEditing()
告知编辑器停止编辑并接受任何已部分编辑的值作为编辑器的值。如果编辑没有停止，则编辑器返回 false；这对已生效并且无法接受无效条目的编辑器很有用。

返回：
如果编辑已停止，则返回 true；否则返回 false

cancelCellEditing

void cancelCellEditing()
告知编辑器取消编辑并且不接受任何已部分编辑的值。

addCellEditorListener

void addCellEditorListener(CellEditorListener l)
当编辑器停止运作或取消编辑时，向被通知的列表添加一个侦听器。

参数：
l - CellEditorListener

removeCellEditorListener

void removeCellEditorListener(CellEditorListener l)
从被通知的列表中移除一个侦听器

参数：
l - CellEditorListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CellRendererPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 CellRendererPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.CellRendererPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class CellRendererPane
extends Container
implements Accessible

此类被插入在单元格渲染器与使用它们的组件之间。它只是为了阻碍 repaint() 和 invalidate() 方法而存在，在配置渲染器时，这些方法将顺着树向上传播。此类用于 JTable、JTree 和 JList 的实现中。例如，以下是绘制 JList 中每个行的代码中使用 CellRendererPane 的方式：

   cellRendererPane = new CellRendererPane();
   ...
   Component rendererComponent = renderer.getListCellRendererComponent();
   renderer.configureListCellRenderer(dataModel.getElementAt(row), row);
   cellRendererPane.paintComponent(g, rendererComponent, this, x, y, w, h);

渲染器组件必须重写 isShowing() 并无条件地返回 true，以便正常运行，因为 Swing paint 在 isShowing 返回 false 时不对组件做任何操作。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class CellRendererPane.AccessibleCellRendererPane
此类实现 Panel 类的可访问性支持。
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected  AccessibleContext accessibleContext
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
CellRendererPane()
构造一个 CellRendererPane 对象。
方法摘要
protected  void addImpl(Component x, Object constraints, int index)
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。
 AccessibleContext getAccessibleContext()
获取与此 CellRendererPane 相关的 AccessibleContext。
 void invalidate()
重写此方法是为了避免配置单元格渲染器的子级时顺着树向上传播 invalidate。
 void paint(Graphics g)
不应调用。
 void paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。
 void paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h, boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。
 void paintComponent(Graphics g, Component c, Container p, Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。
 void update(Graphics g)
不应调用。
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addNotify, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, paramString, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphics, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, resize, resize, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

accessibleContext

protected AccessibleContext accessibleContext
构造方法详细信息

CellRendererPane

public CellRendererPane()
构造一个 CellRendererPane 对象。

方法详细信息

invalidate

public void invalidate()
重写此方法是为了避免配置单元格渲染器的子级时顺着树向上传播 invalidate。

覆盖：
类 Container 中的 invalidate
另请参见：
Container.validate(), Container.layout(), LayoutManager, LayoutManager2.invalidateLayout(Container)

paint

public void paint(Graphics g)
不应调用。

覆盖：
类 Container 中的 paint
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

update

public void update(Graphics g)
不应调用。

覆盖：
类 Container 中的 update
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

addImpl

protected void addImpl(Component x,
                       Object constraints,
                       int index)
如果指定组件已经是此组件的子组件，则不必再操心去做任何事，堆栈顺序对于单元格渲染器组件而言无关紧要（CellRendererPane 不管怎样都不进行绘制）。

覆盖：
类 Container 中的 addImpl
参数：
x - 要添加的组件
constraints - 表示此组件的布局约束的对象
另请参见：
Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
LayoutManager,
LayoutManager2

paintComponent

public void paintComponent(Graphics g,
                           Component c,
                           Container p,
                           int x,
                           int y,
                           int w,
                           int h,
                           boolean shouldValidate)
在图形对象 g 上绘制一个单元格渲染器组件 c。在绘制该组件之前，要对此方法进行 reparent 操作（如有必要），将其边界设置为 w,h 并且将图形对象（有效地）转换成 x,y。如果该对象是一个 JComponent，则暂时关闭双重缓冲。在绘制组件之后，将边界重新设置为 -w, -h, 0, 0。因此，如果该组件是最后一个被绘制的渲染器组件，那么它不会开始使用输入。Container p 是我们实际要绘制的组件，通常它等于 this.getParent()。如果 shouldValidate 为 true，则组件 c 将在绘制之前被验证。

paintComponent

public void paintComponent(Graphics g,
                           Component c,
                           Container p,
                           int x,
                           int y,
                           int w,
                           int h)
调用 this.paintComponent(g, c, p, x, y, w, h, false)。

paintComponent

public void paintComponent(Graphics g,
                           Component c,
                           Container p,
                           Rectangle r)
使用矩形的 x、y、width 和 height 字段的调用 this.paintComponent()。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 CellRendererPane 相关的 AccessibleContext。对于 CellRendererPanes，AccessibleContext 采用 AccessibleCellRendererPane 的形式。如有必要，可创建一个新的 AccessibleCellRendererPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Component 中的 getAccessibleContext
返回：
一个 AccessibleCellRendererPane，它可用作此 CellRendererPane 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CellRendererPane.AccessibleCellRendererPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 CellRendererPane.AccessibleCellRendererPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.CellRendererPane.AccessibleCellRendererPane
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
CellRendererPane
protected class CellRendererPane.AccessibleCellRendererPane
extends Container.AccessibleAWTContainer

此类实现 Panel 类的可访问性支持。

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected CellRendererPane.AccessibleCellRendererPane()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getAccessibleStateSet, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

CellRendererPane.AccessibleCellRendererPane

protected CellRendererPane.AccessibleCellRendererPane()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComboBoxEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 ComboBoxEditor

所有已知实现类：
BasicComboBoxEditor, BasicComboBoxEditor.UIResource, MetalComboBoxEditor, MetalComboBoxEditor.UIResource
public interface ComboBoxEditor

用于 JComboBox 组件的编辑器组件。

方法摘要
void | addActionListener(ActionListener l) 添加一个 ActionListener。
Component | getEditorComponent() 返回应该添加到此编辑器的树层次结构中的组件。
Object | getItem() 返回已编辑项。
void | removeActionListener(ActionListener l) 移除一个 ActionListener
void | selectAll() 请求编辑器开始编辑并选定所有对象
void | setItem(Object anObject) 设置应该编辑的项。

方法详细信息

getEditorComponent

Component getEditorComponent()
返回应该添加到此编辑器的树层次结构中的组件。

setItem

void setItem(Object anObject)
设置应该编辑的项。如有必要，可取消任何编辑。

getItem

Object getItem()
返回已编辑项。

selectAll

void selectAll()
请求编辑器开始编辑并选定所有对象

addActionListener

void addActionListener(ActionListener l)
添加一个 ActionListener。当已编辑的项发生更改时，生成一个操作事件

removeActionListener

void removeActionListener(ActionListener l)
移除一个 ActionListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComboBoxModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 ComboBoxModel

所有超级接口：
ListModel
所有已知子接口：
MutableComboBoxModel
所有已知实现类：
DefaultComboBoxModel, MetalFileChooserUI.DirectoryComboBoxModel, MetalFileChooserUI.FilterComboBoxModel
public interface ComboBoxModel
extends ListModel

用于组合框的数据模型。此接口扩展了 ListDataModel 并添加了选择项 的概念。选择项通常是组合框显示区域内可见的项。

选择项可能不必通过底层 ListModel 进行管理。这种分离行为是为模型中选择项的临时存储和检索所做的考虑。

方法摘要
Object | getSelectedItem() 返回选择的项
void | setSelectedItem(Object anItem) 设置选择项。
从接口 javax.swing.ListModel 继承的方法
addListDataListener, getElementAt, getSize, removeListDataListener

方法详细信息

setSelectedItem

void setSelectedItem(Object anItem)
设置选择项。此方法的实现应该通知所有已注册 ListDataListener 内容已更改。

参数：
anItem - 要选择的列表对象，为 null 表示清除选择

getSelectedItem

Object getSelectedItem()
返回选择的项

返回：
选择的项，如果没有选择的项，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ComponentInputMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ComponentInputMap

java.lang.Object
    继承者  javax.swing.InputMap
        继承者  javax.swing.ComponentInputMap
所有已实现的接口：
Serializable
直接已知子类：
ComponentInputMapUIResource
public class ComponentInputMap
extends InputMap

ComponentInputMap 是与特定 JComponent 相关联的 InputMap。只要 ComponentInputMap 发生更改，该组件都将自动获得通知。ComponentInputMap 用于 WHEN_IN_FOCUSED_WINDOW 绑定。

从以下版本开始：
1.3

构造方法摘要
ComponentInputMap(JComponent component)
创建一个与给定组件相关联的 ComponentInputMap。
方法摘要
void | clear() 从此对象中移除所有映射关系。
JComponent | getComponent() 返回为其创建 InputMap 的组件。
void | put(KeyStroke keyStroke, Object actionMapKey) 将一个 keyStroke 的绑定添加到 actionMapKey。
void | remove(KeyStroke key) 从此对象中移除 key 的绑定。
void | setParent(InputMap map) 设置父组件，该组件必须是一个和与此 ComponentInputMap 相同的组件相关联的 ComponentInputMap。
从类 javax.swing.InputMap 继承的方法
allKeys, get, getParent, keys, size
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ComponentInputMap

public ComponentInputMap(JComponent component)
创建一个与给定组件相关联的 ComponentInputMap。

参数：
component - 一个非 null JComponent
抛出：
IllegalArgumentException - 如果 component 为 null
方法详细信息

setParent

public void setParent(InputMap map)
设置父组件，该组件必须是一个和与此 ComponentInputMap 相同的组件相关联的 ComponentInputMap。

覆盖：
类 InputMap 中的 setParent
参数：
map - 一个 ComponentInputMap
抛出：
IllegalArgumentException - 如果 map 不是一个 ComponentInputMap 或者与相同的组件无关

getComponent

public JComponent getComponent()
返回为其创建 InputMap 的组件。

put

public void put(KeyStroke keyStroke,
                Object actionMapKey)
将一个 keyStroke 的绑定添加到 actionMapKey。如果 actionMapKey 为 null，则移除 keyStroke 的当前绑定。

覆盖：
类 InputMap 中的 put

remove

public void remove(KeyStroke key)
从此对象中移除 key 的绑定。

覆盖：
类 InputMap 中的 remove

clear

public void clear()
从此对象中移除所有映射关系。

覆盖：
类 InputMap 中的 clear
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DebugGraphics (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DebugGraphics

java.lang.Object
    继承者  java.awt.Graphics
        继承者  javax.swing.DebugGraphics

public class DebugGraphics
extends Graphics

支持图形调试的图形子类。重写 Graphics 中的大多数方法。DebugGraphics 对象很少通过手工创建。它们通常在 JComponent 的 debugGraphicsOptions 因使用 setDebugGraphicsOptions() 方法而发生更改时自动创建。

注：必须关闭双缓冲来使用 DebugGraphics：RepaintManager repaintManager = RepaintManager.currentManager(component); repaintManager.setDoubleBufferingEnabled(false);

另请参见：
JComponent.setDebugGraphicsOptions(int),
RepaintManager.currentManager(java.awt.Component),
RepaintManager.setDoubleBufferingEnabled(boolean)

字段摘要
static int | BUFFERED_OPTION 在一个单独的 Frame 中显示已缓冲的操作。
static int | FLASH_OPTION Flash 图形操作。
static int | LOG_OPTION 记录图形操作。
static int | NONE_OPTION 不要调试图形操作。
构造方法摘要
DebugGraphics()
构造一个支持减速绘制的新调试图形上下文。
DebugGraphics(Graphics graphics)
根据现有图形上下文构造一个调试图形上下文，该上下文支持减慢绘制。
DebugGraphics(Graphics graphics, JComponent component)
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。
方法摘要
void | clearRect(int x, int y, int width, int height) 重写 Graphics.clearRect。
void | clipRect(int x, int y, int width, int height) 重写 Graphics.clipRect。
void | copyArea(int x, int y, int width, int height, int destX, int destY) 重写 Graphics.copyArea。
Graphics | create() 重写 Graphics.create 来返回一个 DebugGraphics 对象。
Graphics | create(int x, int y, int width, int height) 重写 Graphics.create 来返回一个 DebugGraphics 对象。
void | dispose() 重写 Graphics.dispose。
void | draw3DRect(int x, int y, int width, int height, boolean raised) 重写 Graphics.draw3DRect。
void | drawArc(int x, int y, int width, int height, int startAngle, int arcAngle) 重写 Graphics.drawArc。
void | drawBytes(byte[] data, int offset, int length, int x, int y) 重写 Graphics.drawBytes。
void | drawChars(char[] data, int offset, int length, int x, int y) 重写 Graphics.drawChars。
boolean | drawImage(Image img, int x, int y, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | drawImage(Image img, int x, int y, ImageObserver observer) 重写 Graphics.drawImage。
boolean | drawImage(Image img, int x, int y, int width, int height, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | drawImage(Image img, int x, int y, int width, int height, ImageObserver observer) 重写 Graphics.drawImage。
boolean | drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, Color bgcolor, ImageObserver observer) 重写 Graphics.drawImage。
boolean | drawImage(Image img, int dx1, int dy1, int dx2, int dy2, int sx1, int sy1, int sx2, int sy2, ImageObserver observer) 重写 Graphics.drawImage。
void | drawLine(int x1, int y1, int x2, int y2) 重写 Graphics.drawLine。
void | drawOval(int x, int y, int width, int height) 重写 Graphics.drawOval。
void | drawPolygon(int[] xPoints, int[] yPoints, int nPoints) 重写 Graphics.drawPolygon。
void | drawPolyline(int[] xPoints, int[] yPoints, int nPoints) 重写 Graphics.drawPolyline。
void | drawRect(int x, int y, int width, int height) 重写 Graphics.drawRect。
void | drawRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight) 重写 Graphics.drawRoundRect。
void | drawString(AttributedCharacterIterator iterator, int x, int y) 重写 Graphics.drawString。
void | drawString(String aString, int x, int y) 重写 Graphics.drawString。
void | fill3DRect(int x, int y, int width, int height, boolean raised) 重写 Graphics.fill3DRect。
void | fillArc(int x, int y, int width, int height, int startAngle, int arcAngle) 重写 Graphics.fillArc。
void | fillOval(int x, int y, int width, int height) 重写 Graphics.fillOval。
void | fillPolygon(int[] xPoints, int[] yPoints, int nPoints) 重写 Graphics.fillPolygon。
void | fillRect(int x, int y, int width, int height) 重写 Graphics.fillRect。
void | fillRoundRect(int x, int y, int width, int height, int arcWidth, int arcHeight) 重写 Graphics.fillRoundRect。
static Color | flashColor() 返回用于 flash 绘制操作的 Color。
static int | flashCount() 绘制操作将要 flash 的次数。
static int | flashTime() 返回绘制操作 flash 的时间延迟。
Shape | getClip() 重写 Graphics.getClip。
Rectangle | getClipBounds() 重写 Graphics.getClipBounds。
Color | getColor() 返回用于文本绘制操作的 Color。
int | getDebugOptions() 返回此 DebugGraphics 的当前调试选项。
Font | getFont() 返回用于文本绘制操作的 Font。
FontMetrics | getFontMetrics() 重写 Graphics.getFontMetrics。
FontMetrics | getFontMetrics(Font f) 重写 Graphics.getFontMetrics。
boolean | isDrawingBuffer() 返回 drawingBuffer 值。
static PrintStream | logStream() 返回 DebugGraphics 在其中记录绘制操作的流。
void | setClip(int x, int y, int width, int height) 重写 Graphics.setClip。
void | setClip(Shape clip) 重写 Graphics.setClip。
void | setColor(Color aColor) 设置用于绘制和填充线条和图形的颜色。
void | setDebugOptions(int options) 启用/禁用有关每个图形操作的诊断信息。
static void | setFlashColor(Color flashColor) 设置用于 flash 绘制操作的 Color。
static void | setFlashCount(int flashCount) 设置绘制操作将要 flash 的次数。
static void | setFlashTime(int flashTime) 设置绘制操作 flash 的时间延迟。
void | setFont(Font aFont) 设置用于文本绘制操作的 Font。
static void | setLogStream(PrintStream stream) 设置 DebugGraphics 在其中记录绘制操作的流。
void | setPaintMode() 重写 Graphics.setPaintMode。
void | setXORMode(Color aColor) 重写 Graphics.setXORMode。
void | translate(int x, int y) 重写 Graphics.translate。
从类 java.awt.Graphics 继承的方法
drawPolygon, fillPolygon, finalize, getClipBounds, getClipRect, hitClip, toString
从类 java.lang.Object 继承的方法
clone, equals, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

LOG_OPTION

public static final int LOG_OPTION
记录图形操作。

另请参见：
常量字段值

FLASH_OPTION

public static final int FLASH_OPTION
Flash 图形操作。

另请参见：
常量字段值

BUFFERED_OPTION

public static final int BUFFERED_OPTION
在一个单独的 Frame 中显示已缓冲的操作。

另请参见：
常量字段值

NONE_OPTION

public static final int NONE_OPTION
不要调试图形操作。

另请参见：
常量字段值
构造方法详细信息

DebugGraphics

public DebugGraphics()
构造一个支持减速绘制的新调试图形上下文。

DebugGraphics

public DebugGraphics(Graphics graphics,
                     JComponent component)
根据现有图形上下文构造一个调试图形上下文，该上下文可以减慢指定组件的绘制。

参数：
graphics - 要减慢的 Graphics 上下文
component - 要缓慢绘制的 JComponent

DebugGraphics

public DebugGraphics(Graphics graphics)
根据现有图形上下文构造一个调试图形上下文，该上下文支持减慢绘制。

参数：
graphics - 要减慢的 Graphics 上下文
方法详细信息

create

public Graphics create()
重写 Graphics.create 来返回一个 DebugGraphics 对象。

指定者：
类 Graphics 中的 create
返回：
新的图形上下文，它是此图形上下文的副本。

create

public Graphics create(int x,
                       int y,
                       int width,
                       int height)
重写 Graphics.create 来返回一个 DebugGraphics 对象。

覆盖：
类 Graphics 中的 create
参数：
x - x 坐标。
y - y 坐标。
width - 剪贴矩形的宽度。
height - 剪贴矩形的高度。
返回：
新的图形上下文。
另请参见：
Graphics.translate(int, int), Graphics.clipRect(int, int, int, int)

setFlashColor

public static void setFlashColor(Color flashColor)
设置用于 flash 绘制操作的 Color。

flashColor

public static Color flashColor()
返回用于 flash 绘制操作的 Color。

另请参见：
setFlashColor(java.awt.Color)

setFlashTime

public static void setFlashTime(int flashTime)
设置绘制操作 flash 的时间延迟。

flashTime

public static int flashTime()
返回绘制操作 flash 的时间延迟。

另请参见：
setFlashTime(int)

setFlashCount

public static void setFlashCount(int flashCount)
设置绘制操作将要 flash 的次数。

flashCount

public static int flashCount()
绘制操作将要 flash 的次数。

另请参见：
setFlashCount(int)

setLogStream

public static void setLogStream(PrintStream stream)
设置 DebugGraphics 在其中记录绘制操作的流。

logStream

public static PrintStream logStream()
返回 DebugGraphics 在其中记录绘制操作的流。

另请参见：
setLogStream(java.io.PrintStream)

setFont

public void setFont(Font aFont)
设置用于文本绘制操作的 Font。

指定者：
类 Graphics 中的 setFont
参数：
aFont - 字体。
另请参见：
Graphics.getFont(),
Graphics.drawString(java.lang.String, int, int),
Graphics.drawBytes(byte[], int, int, int, int),
Graphics.drawChars(char[], int, int, int, int)

getFont

public Font getFont()
返回用于文本绘制操作的 Font。

指定者：
类 Graphics 中的 getFont
返回：
此图形上下文的当前字体。
另请参见：
setFont(java.awt.Font)

setColor

public void setColor(Color aColor)
设置用于绘制和填充线条和图形的颜色。

指定者：
类 Graphics 中的 setColor
参数：
aColor - 新的呈现颜色。
另请参见：
Color, Graphics.getColor()

getColor

public Color getColor()
返回用于文本绘制操作的 Color。

指定者：
类 Graphics 中的 getColor
返回：
此图形上下文的当前颜色。
另请参见：
setColor(java.awt.Color)

getFontMetrics

public FontMetrics getFontMetrics()
重写 Graphics.getFontMetrics。

覆盖：
类 Graphics 中的 getFontMetrics
返回：
此图形上下文当前字体的字体规格。
另请参见：
Graphics.getFont(), FontMetrics, Graphics.getFontMetrics(Font)

getFontMetrics

public FontMetrics getFontMetrics(Font f)
重写 Graphics.getFontMetrics。

指定者：
类 Graphics 中的 getFontMetrics
参数：
f - 指定的字体
返回：
指定字体的字体规格。
另请参见：
Graphics.getFont(), FontMetrics, Graphics.getFontMetrics()

translate

public void translate(int x,
                      int y)
重写 Graphics.translate。

指定者：
类 Graphics 中的 translate
参数：
x - x 坐标。
y - y 坐标。

setPaintMode

public void setPaintMode()
重写 Graphics.setPaintMode。

指定者：
类 Graphics 中的 setPaintMode

setXORMode

public void setXORMode(Color aColor)
重写 Graphics.setXORMode。

指定者：
类 Graphics 中的 setXORMode
参数：
aColor - XOR 交替颜色

getClipBounds

public Rectangle getClipBounds()
重写 Graphics.getClipBounds。

指定者：
类 Graphics 中的 getClipBounds
返回：
当前剪贴区域的边界矩形；如果未设置剪贴区，则返回 null。
另请参见：
Graphics.getClip(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int),
Graphics.setClip(Shape)

clipRect

public void clipRect(int x,
                     int y,
                     int width,
                     int height)
重写 Graphics.clipRect。

指定者：
类 Graphics 中的 clipRect
参数：
x - 要与剪贴区相交的矩形的 x 坐标
y - 要与剪贴区相交的矩形的 y 坐标
width - 要与剪贴区相交的矩形的宽度
height - 要与剪贴区相交的矩形的高度
另请参见：
Graphics.setClip(int, int, int, int), Graphics.setClip(Shape)

setClip

public void setClip(int x,
                    int y,
                    int width,
                    int height)
重写 Graphics.setClip。

指定者：
类 Graphics 中的 setClip
参数：
x - 新剪贴区矩形的 x 坐标。
y - 新剪贴区矩形的 y 坐标。
width - 新剪贴区矩形的宽度。
height - 新剪贴区矩形的高度。
另请参见：
Graphics.clipRect(int, int, int, int),
Graphics.setClip(Shape),
Graphics.getClip()

getClip

public Shape getClip()
重写 Graphics.getClip。

指定者：
类 Graphics 中的 getClip
返回：
表示当前剪贴区域的 Shape 对象；如果未设置剪贴区，则返回 null。
另请参见：
Graphics.getClipBounds(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int),
Graphics.setClip(Shape)

setClip

public void setClip(Shape clip)
重写 Graphics.setClip。

指定者：
类 Graphics 中的 setClip
参数：
clip - 用来设置剪贴形状的 Shape
另请参见：
Graphics.getClip(),
Graphics.clipRect(int, int, int, int),
Graphics.setClip(int, int, int, int)

drawRect

public void drawRect(int x,
                     int y,
                     int width,
                     int height)
重写 Graphics.drawRect。

覆盖：
类 Graphics 中的 drawRect
参数：
x - 要绘制矩形的 x 坐标。
y - 要绘制矩形的 y 坐标。
width - 要绘制矩形的宽度。
height - 要绘制矩形的高度。
另请参见：
Graphics.fillRect(int, int, int, int), Graphics.clearRect(int, int, int, int)

fillRect

public void fillRect(int x,
                     int y,
                     int width,
                     int height)
重写 Graphics.fillRect。

指定者：
类 Graphics 中的 fillRect
参数：
x - 要填充矩形的 x 坐标。
y - 要填充矩形的 y 坐标。
width - 要填充矩形的宽度。
height - 要填充矩形的高度。
另请参见：
Graphics.clearRect(int, int, int, int), Graphics.drawRect(int, int, int, int)

clearRect

public void clearRect(int x,
                      int y,
                      int width,
                      int height)
重写 Graphics.clearRect。

指定者：
类 Graphics 中的 clearRect
参数：
x - 要清除矩形的 x 坐标。
y - 要清除矩形的 y 坐标。
width - 要清除矩形的宽度。
height - 要清除矩形的高度。
另请参见：
Graphics.fillRect(int, int, int, int),
Graphics.drawRect(int, int, int, int),
Graphics.setColor(java.awt.Color),
Graphics.setPaintMode(),
Graphics.setXORMode(java.awt.Color)

drawRoundRect

public void drawRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
重写 Graphics.drawRoundRect。

指定者：
类 Graphics 中的 drawRoundRect
参数：
x - 要绘制矩形的 x 坐标。
y - 要绘制矩形的 y 坐标。
width - 要绘制矩形的宽度。
height - 要绘制矩形的高度。
arcWidth - 4 个角弧度的水平直径。
arcHeight - 4 个角弧度的垂直直径。
另请参见：
Graphics.fillRoundRect(int, int, int, int, int, int)

fillRoundRect

public void fillRoundRect(int x,
                          int y,
                          int width,
                          int height,
                          int arcWidth,
                          int arcHeight)
重写 Graphics.fillRoundRect。

指定者：
类 Graphics 中的 fillRoundRect
参数：
x - 要填充矩形的 x 坐标。
y - 要填充矩形的 y 坐标。
width - 要填充矩形的宽度。
height - 要填充矩形的高度。
arcWidth - 4 个角弧度的水平直径。
arcHeight - 4 个角弧度的垂直直径。
另请参见：
Graphics.drawRoundRect(int, int, int, int, int, int)

drawLine

public void drawLine(int x1,
                     int y1,
                     int x2,
                     int y2)
重写 Graphics.drawLine。

指定者：
类 Graphics 中的 drawLine
参数：
x1 - 第一个点的 x 坐标。
y1 - 第一个点的 y 坐标。
x2 - 第二个点的 x 坐标。
y2 - 第二个点的 y 坐标。

draw3DRect

public void draw3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
重写 Graphics.draw3DRect。

覆盖：
类 Graphics 中的 draw3DRect
参数：
x - 要绘制矩形的 x 坐标。
y - 要绘制矩形的 y 坐标。
width - 要绘制矩形的宽度。
height - 要绘制矩形的高度。
raised - 一个用于确定矩形是凸出平面显示还是凹入平面显示的 boolean 值。
另请参见：
Graphics.fill3DRect(int, int, int, int, boolean)

fill3DRect

public void fill3DRect(int x,
                       int y,
                       int width,
                       int height,
                       boolean raised)
重写 Graphics.fill3DRect。

覆盖：
类 Graphics 中的 fill3DRect
参数：
x - 要填充矩形的 x 坐标。
y - 要填充矩形的 y 坐标。
width - 要填充矩形的宽度。
height - 要填充矩形的高度。
raised - 一个用于确定矩形是凸出平面显示还是凹入平面显示的 boolean 值。
另请参见：
Graphics.draw3DRect(int, int, int, int, boolean)

drawOval

public void drawOval(int x,
                     int y,
                     int width,
                     int height)
重写 Graphics.drawOval。

指定者：
类 Graphics 中的 drawOval
参数：
x - 要绘制椭圆的左上角的 x 坐标。
y - 要绘制椭圆的左上角的 y 坐标。
width - 要绘制椭圆的宽度。
height - 要绘制椭圆的高度。
另请参见：
Graphics.fillOval(int, int, int, int)

fillOval

public void fillOval(int x,
                     int y,
                     int width,
                     int height)
重写 Graphics.fillOval。

指定者：
类 Graphics 中的 fillOval
参数：
x - 要填充椭圆的左上角的 x 坐标。
y - 要填充椭圆的左上角的 y 坐标。
width - 要填充椭圆的宽度。
height - 要填充椭圆的高度。
另请参见：
Graphics.drawOval(int, int, int, int)

drawArc

public void drawArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
重写 Graphics.drawArc。

指定者：
类 Graphics 中的 drawArc
参数：
x - 要绘制弧的左上角的 x 坐标。
y - 要绘制弧的左上角的 y 坐标。
width - 要绘制弧的宽度。
height - 要绘制弧的高度。
startAngle - 开始角度。
arcAngle - 相对于开始角度而言，弧跨越的角度。
另请参见：
Graphics.fillArc(int, int, int, int, int, int)

fillArc

public void fillArc(int x,
                    int y,
                    int width,
                    int height,
                    int startAngle,
                    int arcAngle)
重写 Graphics.fillArc。

指定者：
类 Graphics 中的 fillArc
参数：
x - 要填充弧的左上角的 x 坐标。
y - 要填充弧的左上角的 y 坐标。
width - 要填充弧的宽度。
height - 要填充弧的高度。
startAngle - 开始角度。
arcAngle - 相对于开始角度而言，弧跨越的角度。
另请参见：
Graphics.drawArc(int, int, int, int, int, int)

drawPolyline

public void drawPolyline(int[] xPoints,
                         int[] yPoints,
                         int nPoints)
重写 Graphics.drawPolyline。

指定者：
类 Graphics 中的 drawPolyline
参数：
xPoints - x 点数组
yPoints - y 点数组
nPoints - 点的总数
另请参见：
Graphics.drawPolygon(int[], int[], int)

drawPolygon

public void drawPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
重写 Graphics.drawPolygon。

指定者：
类 Graphics 中的 drawPolygon
参数：
xPoints - x 坐标数组。
yPoints - y 坐标数组。
nPoints - 点的总数。
另请参见：
Graphics.fillPolygon(int[], int[], int), Graphics.drawPolyline(int[], int[], int)

fillPolygon

public void fillPolygon(int[] xPoints,
                        int[] yPoints,
                        int nPoints)
重写 Graphics.fillPolygon。

指定者：
类 Graphics 中的 fillPolygon
参数：
xPoints - x 坐标数组。
yPoints - y 坐标数组。
nPoints - 点的总数。
另请参见：
Graphics.drawPolygon(int[], int[], int)

drawString

public void drawString(String aString,
                       int x,
                       int y)
重写 Graphics.drawString。

指定者：
类 Graphics 中的 drawString
参数：
aString - 要绘制的 string。
x - x 坐标。
y - y 坐标。
另请参见：
Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawChars(char[], int, int, int, int)

drawString

public void drawString(AttributedCharacterIterator iterator,
                       int x,
                       int y)
重写 Graphics.drawString。

指定者：
类 Graphics 中的 drawString
参数：
iterator - 要绘制其文本的迭代器
x - x 坐标。
y - y 坐标。
另请参见：
Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawChars(char[], int, int, int, int)

drawBytes

public void drawBytes(byte[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
重写 Graphics.drawBytes。

覆盖：
类 Graphics 中的 drawBytes
参数：
data - 要绘制的数据
offset - 数据的起始偏移量
length - 要绘制的字节数
x - 文本基线的 x 坐标
y - 文本基线的 y 坐标
另请参见：
Graphics.drawChars(char[], int, int, int, int), Graphics.drawString(java.lang.String, int, int)

drawChars

public void drawChars(char[] data,
                      int offset,
                      int length,
                      int x,
                      int y)
重写 Graphics.drawChars。

覆盖：
类 Graphics 中的 drawChars
参数：
data - 要绘制的字符数组
offset - 数据的初始偏移量
length - 要绘制的字符数
x - 文本基线的 x 坐标
y - 文本基线的 y 坐标
另请参见：
Graphics.drawBytes(byte[], int, int, int, int), Graphics.drawString(java.lang.String, int, int)

drawImage

public boolean drawImage(Image img,
                         int x,
                         int y,
                         ImageObserver observer)
重写 Graphics.drawImage。

指定者：
类 Graphics 中的 drawImage
参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
observer - 转换了更多图像时要通知的对象。
返回：
如果图像像素仍在更改，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(Image img,
                         int x,
                         int y,
                         int width,
                         int height,
                         ImageObserver observer)
重写 Graphics.drawImage。

指定者：
类 Graphics 中的 drawImage
参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
width - 矩形的宽度。
height - 矩形的高度。
observer - 转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(Image img,
                         int x,
                         int y,
                         Color bgcolor,
                         ImageObserver observer)
重写 Graphics.drawImage。

指定者：
类 Graphics 中的 drawImage
参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
bgcolor - 在图像非透明部分下绘制的背景色。
observer - 当转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(Image img,
                         int x,
                         int y,
                         int width,
                         int height,
                         Color bgcolor,
                         ImageObserver observer)
重写 Graphics.drawImage。

指定者：
类 Graphics 中的 drawImage
参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
x - x 坐标。
y - y 坐标。
width - 矩形的宽度。
height - 矩形的高度。
bgcolor - 在图像非透明部分下绘制的背景色。
observer - 当转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         ImageObserver observer)
重写 Graphics.drawImage。

指定者：
类 Graphics 中的 drawImage
参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
dx1 - 目标矩形第一个角的 x 坐标。
dy1 - 目标矩形第一个角的 y 坐标。
dx2 - 目标矩形第二个角的 x 坐标。
dy2 - 目标矩形第二个角的 y 坐标。
sx1 - 源矩形第一个角的 x 坐标。
sy1 - 源矩形第一个角的 y 坐标。
sx2 - 源矩形第二个角的 x 坐标。
sy2 - 源矩形第二个角的 y 坐标。
observer - 当缩放并转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

drawImage

public boolean drawImage(Image img,
                         int dx1,
                         int dy1,
                         int dx2,
                         int dy2,
                         int sx1,
                         int sy1,
                         int sx2,
                         int sy2,
                         Color bgcolor,
                         ImageObserver observer)
重写 Graphics.drawImage。

指定者：
类 Graphics 中的 drawImage
参数：
img - 要绘制的指定图像。如果 img 为 null，则此方法不执行任何操作。
dx1 - 目标矩形第一个角的 x 坐标。
dy1 - 目标矩形第一个角的 y 坐标。
dx2 - 目标矩形第二个角的 x 坐标。
dy2 - 目标矩形第二个角的 y 坐标。
sx1 - 源矩形第一个角的 x 坐标。
sy1 - 源矩形第一个角的 y 坐标。
sx2 - 源矩形第二个角的 x 坐标。
sy2 - 源矩形第二个角的 y 坐标。
bgcolor - 在图像非透明部分下绘制的背景色。
observer - 当缩放并转换了更多图像时要通知的对象。
返回：
如果图像像素仍在改变，则返回 false；否则返回 true。
另请参见：
Image, ImageObserver, ImageObserver.imageUpdate(java.awt.Image, int, int, int, int, int)

copyArea

public void copyArea(int x,
                     int y,
                     int width,
                     int height,
                     int destX,
                     int destY)
重写 Graphics.copyArea。

指定者：
类 Graphics 中的 copyArea
参数：
x - 源矩形的 x 坐标。
y - 源矩形的 y 坐标。
width - 源矩形的宽度。
height - 源矩形的高度。
destX - 复制像素的水平距离。
destY - 复制像素的垂直距离。

dispose

public void dispose()
重写 Graphics.dispose。

指定者：
类 Graphics 中的 dispose
另请参见：
Graphics.finalize(),
Component.paint(java.awt.Graphics),
Component.update(java.awt.Graphics),
Component.getGraphics(),
Graphics.create()

isDrawingBuffer

public boolean isDrawingBuffer()
返回 drawingBuffer 值。

返回：
如果此对象将从 Buffer 绘制，则返回 true

setDebugOptions

public void setDebugOptions(int options)
启用/禁用有关每个图形操作的诊断信息。options 的值指示应该如何显示此信息。LOG_OPTION 导致打印一条文本消息。FLASH_OPTION 导致绘制被 flash 多次。BUFFERED_OPTION 创建一个新 Frame，该框架显示屏幕外缓冲区中的每个操作。当前值是 options 值的按位或。要禁用调试，请使用 NONE_OPTION。

getDebugOptions

public int getDebugOptions()
返回此 DebugGraphics 的当前调试选项。

另请参见：
setDebugOptions(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultBoundedRangeModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultBoundedRangeModel

java.lang.Object
    继承者  javax.swing.DefaultBoundedRangeModel
所有已实现的接口：
Serializable, BoundedRangeModel
public class DefaultBoundedRangeModel
extends Object
implements BoundedRangeModel, Serializable

BoundedRangeModel 的一般实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
BoundedRangeModel

字段摘要
protected ChangeEvent | changeEvent 由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
protected EventListenerList | listenerList 等待模型更改的侦听器。
构造方法摘要
DefaultBoundedRangeModel()
使用默认值初始化所有属性。
DefaultBoundedRangeModel(int value, int extent, int min, int max)
初始化 value、extent、minimum 和 maximum。
方法摘要
 void addChangeListener(ChangeListener l)
添加一个 ChangeListener。
protected  void fireStateChanged()
运行每个 ChangeListener 的 stateChanged 方法。
 ChangeListener[] getChangeListeners()
返回此 DefaultBoundedRangeModel 上所有已注册的更改侦听器组成的数组。
 int getExtent()
返回模型的 extent。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
 int getMaximum()
返回模型的 maximum。
 int getMinimum()
返回模型的 minimum。
 int getValue()
返回模型的当前值。
 boolean getValueIsAdjusting()
如果该值由于用户正执行操作而处于更改过程中，则返回 true。
 void removeChangeListener(ChangeListener l)
移除一个 ChangeListener。
 void setExtent(int n)
在确保 n 大于或等于零，且落在以下模型约束范围内之后，将 extent 设置为 n：
 void setMaximum(int n)
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 maximum 设置为 n：
 void setMinimum(int n)
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 minimum 设置为 n：
 void setRangeProperties(int newValue, int newExtent, int newMin, int newMax, boolean adjusting)
在强行使参数满足以下常规约束条件之后，设置所有的 BoundedRangeModel 属性： minimum <= value <= value+extent <= maximum 至多生成一个 ChangeEvent。
 void setValue(int n)
设置模型的当前值。
 void setValueIsAdjusting(boolean b)
设置 valueIsAdjusting 属性。
 String toString()
返回显示所有 BoundedRangeModel 属性的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

changeEvent

protected transient ChangeEvent changeEvent
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。这里生成的事件源总是“this”。

listenerList

protected EventListenerList listenerList
等待模型更改的侦听器。

构造方法详细信息

DefaultBoundedRangeModel

public DefaultBoundedRangeModel()
使用默认值初始化所有属性。这些值是：
  • value = 0
  • extent = 0
  • minimum = 0
  • maximum = 100
  • adjusting = false

DefaultBoundedRangeModel

public DefaultBoundedRangeModel(int value,
                                int extent,
                                int min,
                                int max)
初始化 value、extent、minimum 和 maximum。调整是错误的。如果不满足以下约束条件，则抛出 IllegalArgumentException：
 min <= value <= value+extent <= max

方法详细信息

getValue

public int getValue()
返回模型的当前值。

指定者：
接口 BoundedRangeModel 中的 getValue
返回：
模型的当前值
另请参见：
setValue(int), BoundedRangeModel.getValue()

getExtent

public int getExtent()
返回模型的 extent。

指定者：
接口 BoundedRangeModel 中的 getExtent
返回：
模型的 extent
另请参见：
setExtent(int), BoundedRangeModel.getExtent()

getMinimum

public int getMinimum()
返回模型的 minimum。

指定者：
接口 BoundedRangeModel 中的 getMinimum
返回：
模型的 minimum
另请参见：
setMinimum(int), BoundedRangeModel.getMinimum()

getMaximum

public int getMaximum()
返回模型的 maximum。

指定者：
接口 BoundedRangeModel 中的 getMaximum
返回：
模型的 maximum
另请参见：
setMaximum(int), BoundedRangeModel.getMaximum()

setValue

public void setValue(int n)
设置模型的当前值。对于滑块，该值确定调节器出现的位置。确保新值 n 落在以下模型约束范围内：
     minimum <= value <= value+extent <= maximum

指定者：
接口 BoundedRangeModel 中的 setValue
参数：
n - 模型的新值
另请参见：
BoundedRangeModel.setValue(int)

setExtent

public void setExtent(int n)
在确保 n 大于或等于零，且落在以下模型约束范围内之后，将 extent 设置为 n：
     minimum <= value <= value+extent <= maximum

指定者：
接口 BoundedRangeModel 中的 setExtent
参数：
n - 模型的新 extent
另请参见：
BoundedRangeModel.setExtent(int)

setMinimum

public void setMinimum(int n)
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 minimum 设置为 n：
     minimum <= value <= value+extent <= maximum

指定者：
接口 BoundedRangeModel 中的 setMinimum
参数：
n - 模型的新 minimum
另请参见：
getMinimum(), BoundedRangeModel.setMinimum(int)

setMaximum

public void setMaximum(int n)
在确保 n 以及其他三个属性满足以下模型约束条件之后，将 maximum 设置为 n：
     minimum <= value <= value+extent <= maximum

指定者：
接口 BoundedRangeModel 中的 setMaximum
参数：
n - 模型的新 maximum
另请参见：
BoundedRangeModel.setMaximum(int)

setValueIsAdjusting

public void setValueIsAdjusting(boolean b)
设置 valueIsAdjusting 属性。

指定者：
接口 BoundedRangeModel 中的 setValueIsAdjusting
参数：
b - 如果即将进行的 value 属性更改是一系列更改的一部分，则该参数为 true
另请参见：
getValueIsAdjusting(), setValue(int), BoundedRangeModel.setValueIsAdjusting(boolean)

getValueIsAdjusting

public boolean getValueIsAdjusting()
如果该值由于用户正执行操作而处于更改过程中，则返回 true。

指定者：
接口 BoundedRangeModel 中的 getValueIsAdjusting
返回：
valueIsAdjusting 属性的值
另请参见：
setValue(int), BoundedRangeModel.getValueIsAdjusting()

setRangeProperties

public void setRangeProperties(int newValue,
                               int newExtent,
                               int newMin,
                               int newMax,
                               boolean adjusting)
在强行使参数满足以下常规约束条件之后，设置所有的 BoundedRangeModel 属性：
     minimum <= value <= value+extent <= maximum

至多生成一个 ChangeEvent。

指定者：
接口 BoundedRangeModel 中的 setRangeProperties
参数：
newValue - 给出当前值的一个 int 值
newExtent - 给出 value 可以“跳跃”的量的 int 值
newMin - 给出 minimum 值的 int 值
newMax - 给出 maximum 值的 int 值
adjusting - 一个 boolean 值，如果正在进行一系列的更改，则该参数为 true
另请参见：
BoundedRangeModel.setRangeProperties(int, int, int, int, boolean), setValue(int), setExtent(int), setMinimum(int), setMaximum(int), setValueIsAdjusting(boolean)

addChangeListener

public void addChangeListener(ChangeListener l)
添加一个 ChangeListener。每当任何一个 Bounded Range 模型属性发生更改时，更改侦听器都会运行。

指定者：
接口 BoundedRangeModel 中的 addChangeListener
参数：
l - 要添加的 ChangeListener
另请参见：
removeChangeListener(javax.swing.event.ChangeListener), BoundedRangeModel.addChangeListener(javax.swing.event.ChangeListener)

removeChangeListener

public void removeChangeListener(ChangeListener l)
移除一个 ChangeListener。

指定者：
接口 BoundedRangeModel 中的 removeChangeListener
参数：
l - 要移除的 ChangeListener
另请参见：
addChangeListener(javax.swing.event.ChangeListener), BoundedRangeModel.removeChangeListener(javax.swing.event.ChangeListener)

getChangeListeners

public ChangeListener[] getChangeListeners()
返回此 DefaultBoundedRangeModel 上所有已注册的更改侦听器组成的数组。

返回：
此模型的所有 ChangeListener，如果当前没有已注册的更改侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

fireStateChanged

protected void fireStateChanged()
运行每个 ChangeListener 的 stateChanged 方法。

另请参见：
setRangeProperties(int, int, int, int, boolean), EventListenerList

toString

public String toString()
返回显示所有 BoundedRangeModel 属性的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用下面的代码查询 DefaultBoundedRangeModel 实例 m 的更改侦听器：

ChangeListener[] cls = (ChangeListener[])(m.getListeners(ChangeListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求侦听器的类型；此参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
在此模型上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getChangeListeners()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultButtonModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultButtonModel

java.lang.Object
    继承者  javax.swing.DefaultButtonModel
所有已实现的接口：
ItemSelectable, Serializable, ButtonModel
直接已知子类：
JToggleButton.ToggleButtonModel
public class DefaultButtonModel
extends Object
implements ButtonModel, Serializable

Button 组件的数据模型的默认实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected String | actionCommand 按钮所触发的动作命令字符串。
static int | ARMED 标识位掩码中“选中的”位，该位指示选择/触发按钮操作的部分委托事项。
protected ChangeEvent | changeEvent 每个按钮模型实例只需要一个 ChangeEvent，因为事件的唯一状态是源属性。
static int | ENABLED 标识位掩码中“启用的”位，该位指示可以通过输入设备（如鼠标指针）选择按钮。
protected ButtonGroup | group 按钮所属的按钮组。
protected EventListenerList | listenerList 在此模型中存储侦听器。
protected int | mnemonic 按钮的助记符。
static int | PRESSED 标识位掩码中“按下的”位，该位指示按钮已经被按下。
static int | ROLLOVER 标识位掩码中“翻转的”位，该位指示鼠标位于按钮上。
static int | SELECTED 标识位掩码中“选定的”位，该位指示按纽已被选定。
protected int | stateMask 用于存储按钮状态的位掩码。
构造方法摘要
DefaultButtonModel()
构造一个 DefaultButtonModel。
方法摘要
 void addActionListener(ActionListener l)
向模型添加一个 ActionListener。
 void addChangeListener(ChangeListener l)
向模型添加一个 ChangeListener。
 void addItemListener(ItemListener l)
向模型添加一个 ItemListener。
protected  void fireActionPerformed(ActionEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireItemStateChanged(ItemEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
 String getActionCommand()
返回该按钮的动作命令字符串。
 ActionListener[] getActionListeners()
返回此 DefaultButtonModel 上所有已注册的操作侦听器组成的数组。
 ChangeListener[] getChangeListeners()
返回此 DefaultButtonModel 上所有已注册的更改侦听器组成的数组。
 ButtonGroup getGroup()
返回该按钮所属的组。
 ItemListener[] getItemListeners()
返回此 DefaultButtonModel 上所有已注册的项侦听器组成的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。
 int getMnemonic()
获取该按钮的键盘助记符。
 Object[] getSelectedObjects()
重写以返回 null。
 boolean isArmed()
指示触发按钮操作的部分委托事项。
 boolean isEnabled()
指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。
 boolean isPressed()
指示按钮是否已被按下。
 boolean isRollover()
指示鼠标是否在按钮上。
 boolean isSelected()
指示按钮是否已经被选择。
 void removeActionListener(ActionListener l)
从模型中移除一个 ActionListener。
 void removeChangeListener(ChangeListener l)
从模型中移除一个 ChangeListener。
 void removeItemListener(ItemListener l)
从模型中移除一个 ItemListener。
 void setActionCommand(String actionCommand)
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。
 void setArmed(boolean b)
将此按钮标记为选中或未选中。
 void setEnabled(boolean b)
启用或禁用该按钮。
 void setGroup(ButtonGroup group)
标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。
 void setMnemonic(int key)
设置该按钮的键盘助记符（快捷键或加速键）。
 void setPressed(boolean b)
将按钮设置为按下或未被按下。
 void setRollover(boolean b)
设置或清除该按钮的翻转状态
 void setSelected(boolean b)
选择或取消选择该按钮。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

stateMask

protected int stateMask
用于存储按钮状态的位掩码。

actionCommand

protected String actionCommand
按钮所触发的动作命令字符串。

group

protected ButtonGroup group
按钮所属的按钮组。

mnemonic

protected int mnemonic
按钮的助记符。

changeEvent

protected transient ChangeEvent changeEvent
每个按钮模型实例只需要一个 ChangeEvent，因为事件的唯一状态是源属性。所生成事件的源总是 "this"。

listenerList

protected EventListenerList listenerList
在此模型中存储侦听器。

ARMED

public static final int ARMED
标识位掩码中“选中的”位，该位指示选择/触发按钮操作的部分委托事项。

另请参见：
常量字段值

SELECTED

public static final int SELECTED
标识位掩码中“选定的”位，该位指示按纽已被选定。只有某些类型的按钮需要该指示，比如单选钮或复选框。

另请参见：
常量字段值

PRESSED

public static final int PRESSED
标识位掩码中“按下的”位，该位指示按钮已经被按下。

另请参见：
常量字段值

ENABLED

public static final int ENABLED
标识位掩码中“启用的”位，该位指示可以通过输入设备（如鼠标指针）选择按钮。

另请参见：
常量字段值

ROLLOVER

public static final int ROLLOVER
标识位掩码中“翻转的”位，该位指示鼠标位于按钮上。

另请参见：
常量字段值
构造方法详细信息

DefaultButtonModel

public DefaultButtonModel()
构造一个 DefaultButtonModel。

方法详细信息

setActionCommand

public void setActionCommand(String actionCommand)
设置动作命令字符串，在触发按钮时，该字符串将作为 ActionEvent 的一部分被发送。

指定者：
接口 ButtonModel 中的 setActionCommand
参数：
actionCommand - 标识生成的事件的 String
另请参见：
ButtonModel.getActionCommand(), ActionEvent.getActionCommand()

getActionCommand

public String getActionCommand()
返回该按钮的动作命令字符串。

指定者：
接口 ButtonModel 中的 getActionCommand
返回：
标识生成的事件的 String
另请参见：
ButtonModel.setActionCommand(java.lang.String)

isArmed

public boolean isArmed()
指示触发按钮操作的部分委托事项。

指定者：
接口 ButtonModel 中的 isArmed
返回：
如果按钮被选中，并准备触发它，则返回 true
另请参见：
ButtonModel.setArmed(boolean)

isSelected

public boolean isSelected()
指示按钮是否已经被选择。只有某些类型的按钮需要此指示，比如单选钮和复选框。

指定者：
接口 ButtonModel 中的 isSelected
返回：
如果按钮已选择，则返回 true

isEnabled

public boolean isEnabled()
指示是否可通过输入设备（比如鼠标指针）选择或触发按钮。

指定者：
接口 ButtonModel 中的 isEnabled
返回：
如果启用按钮，则返回 true

isPressed

public boolean isPressed()
指示按钮是否已被按下。

指定者：
接口 ButtonModel 中的 isPressed
返回：
如果按钮已被按下，则返回 true

isRollover

public boolean isRollover()
指示鼠标是否在按钮上。

指定者：
接口 ButtonModel 中的 isRollover
返回：
如果鼠标在按钮上，则返回 true

setArmed

public void setArmed(boolean b)
将此按钮标记为选中或未选中。

指定者：
接口 ButtonModel 中的 setArmed
参数：
b - 是否应该选中该按钮

setEnabled

public void setEnabled(boolean b)
启用或禁用该按钮。

指定者：
接口 ButtonModel 中的 setEnabled
参数：
b - 是否应该启用该按钮
另请参见：
ButtonModel.isEnabled()

setSelected

public void setSelected(boolean b)
选择或取消选择该按钮。

指定者：
接口 ButtonModel 中的 setSelected
参数：
b - 为 true 表示选择该按钮，为 false 表示取消对该按钮的选择。

setPressed

public void setPressed(boolean b)
将按钮设置为按下或未被按下。

指定者：
接口 ButtonModel 中的 setPressed
参数：
b - 是否应该按下该按钮
另请参见：
ButtonModel.isPressed()

setRollover

public void setRollover(boolean b)
设置或清除该按钮的翻转状态

指定者：
接口 ButtonModel 中的 setRollover
参数：
b - 该按钮是否处于翻转状态
另请参见：
ButtonModel.isRollover()

setMnemonic

public void setMnemonic(int key)
设置该按钮的键盘助记符（快捷键或加速键）。

指定者：
接口 ButtonModel 中的 setMnemonic
参数：
key - 指示加速键的 int 值

getMnemonic

public int getMnemonic()
获取该按钮的键盘助记符。

指定者：
接口 ButtonModel 中的 getMnemonic
返回：
指示加速键的 int 值
另请参见：
ButtonModel.setMnemonic(int)

addChangeListener

public void addChangeListener(ChangeListener l)
向模型添加一个 ChangeListener。

指定者：
接口 ButtonModel 中的 addChangeListener
参数：
l - 要添加的侦听器

removeChangeListener

public void removeChangeListener(ChangeListener l)
从模型中移除一个 ChangeListener。

指定者：
接口 ButtonModel 中的 removeChangeListener
参数：
l - 要移除的侦听器

getChangeListeners

public ChangeListener[] getChangeListeners()
返回此 DefaultButtonModel 上所有已注册的更改侦听器组成的数组。

返回：
此模型的所有 ChangeListener，如果当前没有已注册的更改侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

fireStateChanged

protected void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

另请参见：
EventListenerList

addActionListener

public void addActionListener(ActionListener l)
向模型添加一个 ActionListener。

指定者：
接口 ButtonModel 中的 addActionListener
参数：
l - 要添加的侦听器

removeActionListener

public void removeActionListener(ActionListener l)
从模型中移除一个 ActionListener。

指定者：
接口 ButtonModel 中的 removeActionListener
参数：
l - 要移除的侦听器

getActionListeners

public ActionListener[] getActionListeners()
返回此 DefaultButtonModel 上所有已注册的操作侦听器组成的数组。

返回：
此模型的所有 ActionListener；如果当前没有注册任何操作侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener)

fireActionPerformed

protected void fireActionPerformed(ActionEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。

参数：
e - 要传递给侦听器的 ActionEvent
另请参见：
EventListenerList

addItemListener

public void addItemListener(ItemListener l)
向模型添加一个 ItemListener。

指定者：
接口 ItemSelectable 中的 addItemListener
指定者：
接口 ButtonModel 中的 addItemListener
参数：
l - 要添加的侦听器
另请参见：
ItemEvent

removeItemListener

public void removeItemListener(ItemListener l)
从模型中移除一个 ItemListener。

指定者：
接口 ItemSelectable 中的 removeItemListener
指定者：
接口 ButtonModel 中的 removeItemListener
参数：
l - 要移除的侦听器
另请参见：
ItemEvent

getItemListeners

public ItemListener[] getItemListeners()
返回此 DefaultButtonModel 上所有已注册的项侦听器组成的数组。

返回：
此模型的所有 ItemListener，如果没有当前已注册的项侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addItemListener(java.awt.event.ItemListener), removeItemListener(java.awt.event.ItemListener)

fireItemStateChanged

protected void fireItemStateChanged(ItemEvent e)
通知所有对此事件类型的通知感兴趣的已注册侦听器。

参数：
e - 要传递给侦听器的 ItemEvent
另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用下面的代码查询 DefaultButtonModel 实例 m 的操作侦听器：

ActionListener[] als = (ActionListener[])(m.getListeners(ActionListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 请求的侦听器类型；该参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此模型上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getActionListeners(),
getChangeListeners(),
getItemListeners()

getSelectedObjects

public Object[] getSelectedObjects()
重写以返回 null。

指定者：
接口 ItemSelectable 中的 getSelectedObjects

setGroup

public void setGroup(ButtonGroup group)
标识该按钮所属的组，这是单选钮所需要的，单选钮在它们的组内相互排斥。

指定者：
接口 ButtonModel 中的 setGroup
参数：
group - 该按钮所属的 ButtonGroup

getGroup

public ButtonGroup getGroup()
返回该按钮所属的组。通常用于单选钮，它们在其组中相互排斥。

返回：
该按钮所属的 ButtonGroup
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultCellEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultCellEditor

java.lang.Object
    继承者  javax.swing.AbstractCellEditor
        继承者  javax.swing.DefaultCellEditor
所有已实现的接口：
Serializable, CellEditor, TableCellEditor, TreeCellEditor
public class DefaultCellEditor
extends AbstractCellEditor
implements TableCellEditor, TreeCellEditor

表单元格和树单元格的默认编辑器。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class DefaultCellEditor.EditorDelegate
受保护的 (protected) EditorDelegate 类。
字段摘要
protected int | clickCountToStart 指定开始编辑所需单击次数的整数。
protected DefaultCellEditor.EditorDelegate | delegate 处理从 CellEditor 发送的所有方法的委托类。
protected JComponent | editorComponent 正被编辑的 Swing 组件。
从类 javax.swing.AbstractCellEditor 继承的字段
changeEvent, listenerList
构造方法摘要
DefaultCellEditor(JCheckBox checkBox)
构造一个使用复选框的 DefaultCellEditor 对象。
DefaultCellEditor(JComboBox comboBox)
构造一个使用组合框的 DefaultCellEditor 对象。
DefaultCellEditor(JTextField textField)
构造一个使用文本字段的 DefaultCellEditor。
方法摘要
void | cancelCellEditing() 将消息从 CellEditor 转发到 delegate。
Object | getCellEditorValue() 将消息从 CellEditor 转发到 delegate。
int | getClickCountToStart() 返回开始编辑所需的单击次数。
Component | getComponent() 返回对编辑器组件的引用。
Component | getTableCellEditorComponent(JTable table, Object value, boolean isSelected, int row, int column) 实现 TableCellEditor 接口。
Component | getTreeCellEditorComponent(JTree tree, Object value, boolean isSelected, boolean expanded, boolean leaf, int row) 实现 TreeCellEditor 接口。
boolean | isCellEditable(EventObject anEvent) 将消息从 CellEditor 转发到 delegate。
void | setClickCountToStart(int count) 指定开始编辑所需的单击次数。
boolean | shouldSelectCell(EventObject anEvent) 将消息从 CellEditor 转发到 delegate。
boolean | stopCellEditing() 将消息从 CellEditor 转发到 delegate。
从类 javax.swing.AbstractCellEditor 继承的方法
addCellEditorListener, fireEditingCanceled, fireEditingStopped, getCellEditorListeners, removeCellEditorListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.CellEditor 继承的方法
addCellEditorListener, removeCellEditorListener

字段详细信息

editorComponent

protected JComponent editorComponent
正被编辑的 Swing 组件。

delegate

protected DefaultCellEditor.EditorDelegate delegate
处理从 CellEditor 发送的所有方法的委托类。

clickCountToStart

protected int clickCountToStart
指定开始编辑所需单击次数的整数。即使将 clickCountToStart 定义为零，也只有在发生单击后才能启动它。

构造方法详细信息

DefaultCellEditor

public DefaultCellEditor(JTextField textField)
构造一个使用文本字段的 DefaultCellEditor。

参数：
textField - 一个 JTextField 对象

DefaultCellEditor

public DefaultCellEditor(JCheckBox checkBox)
构造一个使用复选框的 DefaultCellEditor 对象。

参数：
checkBox - 一个 JCheckBox 对象

DefaultCellEditor

public DefaultCellEditor(JComboBox comboBox)
构造一个使用组合框的 DefaultCellEditor 对象。

参数：
comboBox - 一个 JComboBox 对象
方法详细信息

getComponent

public Component getComponent()
返回对编辑器组件的引用。

返回：
编辑器 Component

setClickCountToStart

public void setClickCountToStart(int count)
指定开始编辑所需的单击次数。

参数：
count - 指定开始编辑所需的单击次数的 int 值
另请参见：
getClickCountToStart()

getClickCountToStart

public int getClickCountToStart()
返回开始编辑所需的单击次数。

返回：
开始编辑所需的单击次数

getCellEditorValue

public Object getCellEditorValue()
将消息从 CellEditor 转发到 delegate。

指定者：
接口 CellEditor 中的 getCellEditorValue
返回：
编辑器中包含的值
另请参见：
DefaultCellEditor.EditorDelegate.getCellEditorValue()

isCellEditable

public boolean isCellEditable(EventObject anEvent)
将消息从 CellEditor 转发到 delegate。

指定者：
接口 CellEditor 中的 isCellEditable
覆盖：
类 AbstractCellEditor 中的 isCellEditable
参数：
anEvent - 一个事件对象
返回：
true
另请参见：
DefaultCellEditor.EditorDelegate.isCellEditable(EventObject)

shouldSelectCell

public boolean shouldSelectCell(EventObject anEvent)
将消息从 CellEditor 转发到 delegate。

指定者：
接口 CellEditor 中的 shouldSelectCell
覆盖：
类 AbstractCellEditor 中的 shouldSelectCell
参数：
anEvent - 一个事件对象
返回：
true
另请参见：
DefaultCellEditor.EditorDelegate.shouldSelectCell(EventObject)

stopCellEditing

public boolean stopCellEditing()
将消息从 CellEditor 转发到 delegate。

指定者：
接口 CellEditor 中的 stopCellEditing
覆盖：
类 AbstractCellEditor 中的 stopCellEditing
返回：
true
另请参见：
DefaultCellEditor.EditorDelegate.stopCellEditing()

cancelCellEditing

public void cancelCellEditing()
将消息从 CellEditor 转发到 delegate。

指定者：
接口 CellEditor 中的 cancelCellEditing
覆盖：
类 AbstractCellEditor 中的 cancelCellEditing
另请参见：
DefaultCellEditor.EditorDelegate.cancelCellEditing()

getTreeCellEditorComponent

public Component getTreeCellEditorComponent(JTree tree,
                                            Object value,
                                            boolean isSelected,
                                            boolean expanded,
                                            boolean leaf,
                                            int row)
实现 TreeCellEditor 接口。

指定者：
接口 TreeCellEditor 中的 getTreeCellEditorComponent
参数：
tree - 要请求编辑器进行编辑的 JTree；此参数可以为 null
value - 要编辑的单元格的值
isSelected - 如果将呈现单元格并在选择时高亮显示，则为 true
expanded - 如果该节点被扩展，则为 true
leaf - 如果该节点是叶节点，则为 true
row - 正在编辑的节点的行索引
返回：
用于编辑的组件

getTableCellEditorComponent

public Component getTableCellEditorComponent(JTable table,
                                             Object value,
                                             boolean isSelected,
                                             int row,
                                             int column)
实现 TableCellEditor 接口。

指定者：
接口 TableCellEditor 中的 getTableCellEditorComponent
参数：
table - 要求编辑器进行编辑的 JTable；可以为 null
value - 要编辑的单元格的值；由具体的编辑器解释和绘制该值。例如，如果 value 是字符串 "true"，则它可呈现为字符串，或者也可作为已选中的复选框来呈现。null 是有效值
isSelected - 如果使用高亮显示来呈现该单元格，则为 true
row - 要编辑的单元格所在行
column - 要编辑的单元格所在列
返回：
要编辑的组件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultCellEditor.EditorDelegate (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultCellEditor.EditorDelegate

java.lang.Object
    继承者  javax.swing.DefaultCellEditor.EditorDelegate
所有已实现的接口：
ActionListener, ItemListener, Serializable, EventListener
正在封闭类：
DefaultCellEditor
protected class DefaultCellEditor.EditorDelegate
extends Object
implements ActionListener, ItemListener, Serializable

受保护的 (protected) EditorDelegate 类。

字段摘要
protected  Object value
此单元格的值。
构造方法摘要
protected DefaultCellEditor.EditorDelegate()
方法摘要
void | actionPerformed(ActionEvent e) 在执行操作时，编辑被终止。
void | cancelCellEditing() 取消编辑。
Object | getCellEditorValue() 返回此单元格的值。
boolean | isCellEditable(EventObject anEvent) 如果 anEvent 不是一个 MouseEvent，则返回 true。
void | itemStateChanged(ItemEvent e) 在项的状态发生更改时，编辑被终止。
void | setValue(Object value) 设置此单元格的值。
boolean | shouldSelectCell(EventObject anEvent) 返回 true 指示可能选定正编辑的单元格。
boolean | startCellEditing(EventObject anEvent) 返回 true 指示编辑已经开始。
boolean | stopCellEditing() 停止编辑并返回 true，指示编辑已经停止。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

value

protected Object value
此单元格的值。

构造方法详细信息

DefaultCellEditor.EditorDelegate

protected DefaultCellEditor.EditorDelegate()
方法详细信息

getCellEditorValue

public Object getCellEditorValue()
返回此单元格的值。

返回：
此单元格的值

setValue

public void setValue(Object value)
设置此单元格的值。

参数：
value - 此单元格的新值

isCellEditable

public boolean isCellEditable(EventObject anEvent)
如果 anEvent 不是一个 MouseEvent，则返回 true。如果已经发生必需的单击数，则返回 true，否则返回 false。

参数：
anEvent - 事件
返回：
如果单元格已为进行编辑做好准备，则返回 true；否则返回 false
另请参见：
DefaultCellEditor.setClickCountToStart(int), shouldSelectCell(java.util.EventObject)

shouldSelectCell

public boolean shouldSelectCell(EventObject anEvent)
返回 true 指示可能选定正编辑的单元格。

参数：
anEvent - 事件
返回：
true
另请参见：
isCellEditable(java.util.EventObject)

startCellEditing

public boolean startCellEditing(EventObject anEvent)
返回 true 指示编辑已经开始。

参数：
anEvent - 事件

stopCellEditing

public boolean stopCellEditing()
停止编辑并返回 true，指示编辑已经停止。此方法调用 fireEditingStopped。

返回：
true

cancelCellEditing

public void cancelCellEditing()
取消编辑。此方法调用 fireEditingCanceled。

actionPerformed

public void actionPerformed(ActionEvent e)
在执行操作时，编辑被终止。

指定者：
接口 ActionListener 中的 actionPerformed
参数：
e - 操作事件
另请参见：
stopCellEditing()

itemStateChanged

public void itemStateChanged(ItemEvent e)
在项的状态发生更改时，编辑被终止。

指定者：
接口 ItemListener 中的 itemStateChanged
参数：
e - 操作事件
另请参见：
stopCellEditing()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultComboBoxModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultComboBoxModel

java.lang.Object
    继承者  javax.swing.AbstractListModel
        继承者  javax.swing.DefaultComboBoxModel
所有已实现的接口：
Serializable, ComboBoxModel, ListModel, MutableComboBoxModel
public class DefaultComboBoxModel
extends AbstractListModel
implements MutableComboBoxModel, Serializable

组合框的默认模型。

字段摘要
从类 javax.swing.AbstractListModel 继承的字段
listenerList
构造方法摘要
DefaultComboBoxModel()
构造一个空的 DefaultComboBoxModel 对象。
DefaultComboBoxModel(Object[] items)
构造一个用对象数组初始化的 DefaultComboBoxModel 对象。
DefaultComboBoxModel(Vector<?> v)
构造一个用向量初始化的 DefaultComboBoxModel 对象。
方法摘要
void | addElement(Object anObject) 在模型的末尾添加项。
Object | getElementAt(int index) 返回指定索引处的值。
int | getIndexOf(Object anObject) 返回指定对象在列表中的索引位置。
Object | getSelectedItem() 返回选择的项
int | getSize() 返回列表的长度。
void | insertElementAt(Object anObject, int index) 在指定索引处添加项。
void | removeAllElements() 清空列表。
void | removeElement(Object anObject) 从模型中移除项。
void | removeElementAt(int index) 在指定索引处移除项。
void | setSelectedItem(Object anObject) 设置选择项的值。
从类 javax.swing.AbstractListModel 继承的方法
addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.swing.ListModel 继承的方法
addListDataListener, removeListDataListener

构造方法详细信息

DefaultComboBoxModel

public DefaultComboBoxModel()
构造一个空的 DefaultComboBoxModel 对象。

DefaultComboBoxModel

public DefaultComboBoxModel(Object[] items)
构造一个用对象数组初始化的 DefaultComboBoxModel 对象。

参数：
items - Object 对象数组

DefaultComboBoxModel

public DefaultComboBoxModel(Vector<?> v)
构造一个用向量初始化的 DefaultComboBoxModel 对象。

参数：
v - 一个 Vector 对象
方法详细信息

setSelectedItem

public void setSelectedItem(Object anObject)
设置选择项的值。选择项可以为 null。

指定者：
接口 ComboBoxModel 中的 setSelectedItem
参数：
anObject - 组合框值，如果没有选择任何对象，则该参数为 null。

getSelectedItem

public Object getSelectedItem()
从接口 ComboBoxModel 复制的描述
返回选择的项

指定者：
接口 ComboBoxModel 中的 getSelectedItem
返回：
选择的项，如果没有选择的项，则返回 null

getSize

public int getSize()
从接口 ListModel 复制的描述
返回列表的长度。

指定者：
接口 ListModel 中的 getSize
返回：
列表的长度

getElementAt

public Object getElementAt(int index)
从接口 ListModel 复制的描述
返回指定索引处的值。

指定者：
接口 ListModel 中的 getElementAt
参数：
index - 请求的索引
返回：
index 处的值

getIndexOf

public int getIndexOf(Object anObject)
返回指定对象在列表中的索引位置。

参数：
anObject -
返回：
表示索引位置的 int 值，其中 0 是第一个位置

addElement

public void addElement(Object anObject)
从接口 MutableComboBoxModel 复制的描述
在模型的末尾添加项。此方法的实现应该通知已添加项的所有已注册 ListDataListener。

指定者：
接口 MutableComboBoxModel 中的 addElement
参数：
anObject - 要添加的 Object

insertElementAt

public void insertElementAt(Object anObject,
                            int index)
从接口 MutableComboBoxModel 复制的描述
在指定索引处添加项。此方法的实现应该通知已添加项的所有已注册 ListDataListener。

指定者：
接口 MutableComboBoxModel 中的 insertElementAt
参数：
anObject - 要添加的 Object
index - 添加对象的位置

removeElementAt

public void removeElementAt(int index)
从接口 MutableComboBoxModel 复制的描述
在指定索引处移除项。此方法的实现应该通知已移除项的所有已注册 ListDataListener。

指定者：
接口 MutableComboBoxModel 中的 removeElementAt
参数：
index - 要移除对象的位置

removeElement

public void removeElement(Object anObject)
从接口 MutableComboBoxModel 复制的描述
从模型中移除项。此方法的实现应该通知已移除项的所有已注册 ListDataListener。

指定者：
接口 MutableComboBoxModel 中的 removeElement
参数：
anObject - 要移除的 Object

removeAllElements

public void removeAllElements()
清空列表。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultDesktopManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultDesktopManager

java.lang.Object
    继承者  javax.swing.DefaultDesktopManager
所有已实现的接口：
Serializable, DesktopManager
public class DefaultDesktopManager
extends Object
implements DesktopManager, Serializable

此类是 DesktopManager 的实现。它当前实现了在任意父级中管理 JInternalFrame 的基本行为。不是 JDesktop 的子级的 JInternalFrame 将使用此组件来处理其类似桌面的操作。

此类为各种 JInternalFrame 方法提供策略，不应该直接调用，而应该在 DesktopManager 中调用各种 JInternalFrame 方法。

另请参见：
JDesktopPane, JInternalFrame

构造方法摘要
DefaultDesktopManager()
方法摘要
void | activateFrame(JInternalFrame f) 此方法将激活 f，将它移动到前台。
void | beginDraggingFrame(JComponent f) 通常在用户已经指示他们将开始拖动某个组件时调用此方法。
void | beginResizingFrame(JComponent f, int direction) 通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。
void | closeFrame(JInternalFrame f) 从父窗体中移除窗体，如有必要，还要移除 desktopIcon。
void | deactivateFrame(JInternalFrame f) 通常指示此窗体失去焦点。
void | deiconifyFrame(JInternalFrame f) 从父窗体中移除 desktopIcon，并将其窗体添加到父窗体中。
void | dragFrame(JComponent f, int newX, int newY) 将正被拖动窗体的可见位置移动到指定位置。
void | endDraggingFrame(JComponent f) 此方法在拖动会话结束时发出信号。
void | endResizingFrame(JComponent f) 此方法在重新调整大小会话结束时发出信号。
protected Rectangle | getBoundsForIconOf(JInternalFrame f) iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。
protected Rectangle | getPreviousBounds(JInternalFrame f) 在将组件最大化之前，获得该组件的普通边界。
void | iconifyFrame(JInternalFrame f) 从父窗体中移除窗体，并将其 desktopIcon 添加到父窗体中。
void | maximizeFrame(JInternalFrame f) 重新调整窗体的大小，使其满足其父窗体的限制。
void | minimizeFrame(JInternalFrame f) 使窗体恢复回调用 maximizeFrame 之前的大小和位置。
void | openFrame(JInternalFrame f) 通常不调用此方法。
protected void | removeIconFor(JInternalFrame f) 在需要时移除 f 的 desktopIcon 的便捷方法。
void | resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight) 使用新值调用 setBoundsForFrame。
void | setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight) 此方法移动 JComponent 并重新绘制已毁坏的区域。
protected void | setPreviousBounds(JInternalFrame f, Rectangle r) 在进行 maximize 调用之前存储组件的边界。
protected void | setWasIcon(JInternalFrame f, Boolean value) 设定组件已被图标化并且 desktopIcon 的边界是有效的。
protected boolean | wasIcon(JInternalFrame f) 如果组件已被图标化并且 desktopIcon 的边界是有效的，则返回 true，否则返回 false。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultDesktopManager

public DefaultDesktopManager()
方法详细信息

openFrame

public void openFrame(JInternalFrame f)
通常不调用此方法。如果调用此方法，它会试着确定来自窗体的 desktopIcon 的适当父窗体。如果成功添加窗体，则要从其父级中移除 desktopIcon。

指定者：
接口 DesktopManager 中的 openFrame

closeFrame

public void closeFrame(JInternalFrame f)
从父窗体中移除窗体，如有必要，还要移除 desktopIcon。

指定者：
接口 DesktopManager 中的 closeFrame
参数：
f - 要移除的 JInternalFrame

maximizeFrame

public void maximizeFrame(JInternalFrame f)
重新调整窗体的大小，使其满足其父窗体的限制。

指定者：
接口 DesktopManager 中的 maximizeFrame
参数：
f - 要重新调整的窗体

minimizeFrame

public void minimizeFrame(JInternalFrame f)
使窗体恢复回调用 maximizeFrame 之前的大小和位置。

指定者：
接口 DesktopManager 中的 minimizeFrame
参数：
f - 要恢复的 JInternalFrame

iconifyFrame

public void iconifyFrame(JInternalFrame f)
从父窗体中移除窗体，并将其 desktopIcon 添加到父窗体中。

指定者：
接口 DesktopManager 中的 iconifyFrame
参数：
f - 要图标化的 JInternalFrame

deiconifyFrame

public void deiconifyFrame(JInternalFrame f)
从父窗体中移除 desktopIcon，并将其窗体添加到父窗体中。

指定者：
接口 DesktopManager 中的 deiconifyFrame
参数：
f - 要取消图标化的 JInternalFrame

activateFrame

public void activateFrame(JInternalFrame f)
此方法将激活 f，将它移动到前台。此方法将当前活动窗体（如果有）的 IS_SELECTED_PROPERTY 设置为 false。在所有层中，只能有一个活动窗体。

指定者：
接口 DesktopManager 中的 activateFrame
参数：
f - 要激活的 JInternalFrame

deactivateFrame

public void deactivateFrame(JInternalFrame f)
从接口 DesktopManager 复制的描述
通常指示此窗体失去焦点。此方法一般在已经将 JInternalFrame 的 IS_SELECTED_PROPERTY 设置为 false 后调用。

指定者：
接口 DesktopManager 中的 deactivateFrame

beginDraggingFrame

public void beginDraggingFrame(JComponent f)
从接口 DesktopManager 复制的描述
通常在用户已经指示他们将开始拖动某个组件时调用此方法。此方法应该在任何 dragFrame() 调用之前调用，以允许 DesktopManager 准备好所有的必需状态。通常 f 将是一个 JInternalFrame。

指定者：
接口 DesktopManager 中的 beginDraggingFrame

dragFrame

public void dragFrame(JComponent f,
                      int newX,
                      int newY)
将正被拖动窗体的可见位置移动到指定位置。发生此操作的方式随使用的拖动算法而不同。在调用 endDraggingFrame 之前，窗体的实际逻辑位置可能一直保持不变。

指定者：
接口 DesktopManager 中的 dragFrame

endDraggingFrame

public void endDraggingFrame(JComponent f)
从接口 DesktopManager 复制的描述
此方法在拖动会话结束时发出信号。在这里可以移除由 DesktopManager 维护的任何状态。通常 f 将是一个 JInternalFrame。

指定者：
接口 DesktopManager 中的 endDraggingFrame

beginResizingFrame

public void beginResizingFrame(JComponent f,
                               int direction)
从接口 DesktopManager 复制的描述
通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。此方法应该在任何 resizeFrame() 调用之前调用，以允许 DesktopManager 准备好所有的必需状态。通常 f 将是一个 JInternalFrame。

指定者：
接口 DesktopManager 中的 beginResizingFrame

resizeFrame

public void resizeFrame(JComponent f,
                        int newX,
                        int newY,
                        int newWidth,
                        int newHeight)
使用新值调用 setBoundsForFrame。

指定者：
接口 DesktopManager 中的 resizeFrame
参数：
f - 要重新调整大小的组件
newX - 新的 x 坐标
newY - 新的 y 坐标
newWidth - 新的宽度
newHeight - 新的高度

endResizingFrame

public void endResizingFrame(JComponent f)
从接口 DesktopManager 复制的描述
此方法在重新调整大小会话结束时发出信号。在这里可以移除由 DesktopManager 维护的任何状态。通常 f 将是一个 JInternalFrame。

指定者：
接口 DesktopManager 中的 endResizingFrame

setBoundsForFrame

public void setBoundsForFrame(JComponent f,
                              int newX,
                              int newY,
                              int newWidth,
                              int newHeight)
此方法移动 JComponent 并重新绘制已毁坏的区域。

指定者：
接口 DesktopManager 中的 setBoundsForFrame

removeIconFor

protected void removeIconFor(JInternalFrame f)
在需要时移除 f 的 desktopIcon 的便捷方法。

getBoundsForIconOf

protected Rectangle getBoundsForIconOf(JInternalFrame f)
iconifyFrame() 代码调用此方法来确定 desktopIcon 的适当边界。

setPreviousBounds

protected void setPreviousBounds(JInternalFrame f,
                                 Rectangle r)
在进行 maximize 调用之前存储组件的边界。

参数：
f - 要重新调整大小的组件
r - 要保存的普通边界

getPreviousBounds

protected Rectangle getPreviousBounds(JInternalFrame f)
在将组件最大化之前，获得该组件的普通边界。

参数：
f - 感兴趣的 JInternalFrame
返回：
组件的普通边界

setWasIcon

protected void setWasIcon(JInternalFrame f,
                          Boolean value)
设定组件已被图标化并且 desktopIcon 的边界是有效的。

wasIcon

protected boolean wasIcon(JInternalFrame f)
如果组件已被图标化并且 desktopIcon 的边界是有效的，则返回 true，否则返回 false。

参数：
f - 感兴趣的 JInternalFrame
返回：
如果组件已经被图标化，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultFocusManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultFocusManager

java.lang.Object
    继承者  java.awt.KeyboardFocusManager
        继承者  java.awt.DefaultKeyboardFocusManager
            继承者  javax.swing.FocusManager
                继承者  javax.swing.DefaultFocusManager
所有已实现的接口：
KeyEventDispatcher, KeyEventPostProcessor
public class DefaultFocusManager
extends FocusManager

此类已被废弃，用 1.4 focus API 取代。虽然客户端代码可能仍然使用此类，但强烈建议开发人员使用 java.awt.KeyboardFocusManager 和 java.awt.DefaultKeyboardFocusManager 替代。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节和 Focus Specification。

字段摘要
从类 javax.swing.FocusManager 继承的字段
FOCUS_MANAGER_CLASS_PROPERTY
从类 java.awt.KeyboardFocusManager 继承的字段
BACKWARD_TRAVERSAL_KEYS, DOWN_CYCLE_TRAVERSAL_KEYS, FORWARD_TRAVERSAL_KEYS, UP_CYCLE_TRAVERSAL_KEYS
构造方法摘要
DefaultFocusManager()
方法摘要
boolean | compareTabOrder(Component a, Component b)
Component | getComponentAfter(Container aContainer, Component aComponent)
Component | getComponentBefore(Container aContainer, Component aComponent)
Component | getFirstComponent(Container aContainer)
Component | getLastComponent(Container aContainer)
从类 javax.swing.FocusManager 继承的方法
disableSwingFocusManager, getCurrentManager, isFocusManagerEnabled, setCurrentManager
从类 java.awt.DefaultKeyboardFocusManager 继承的方法
dequeueKeyEvents, discardKeyEvents, dispatchEvent, dispatchKeyEvent, downFocusCycle, enqueueKeyEvents, focusNextComponent, focusPreviousComponent, postProcessKeyEvent, processKeyEvent, upFocusCycle
从类 java.awt.KeyboardFocusManager 继承的方法
addKeyEventDispatcher, addKeyEventPostProcessor, addPropertyChangeListener, addPropertyChangeListener, addVetoableChangeListener, addVetoableChangeListener, clearGlobalFocusOwner, downFocusCycle, firePropertyChange, fireVetoableChange, focusNextComponent, focusPreviousComponent, getActiveWindow, getCurrentFocusCycleRoot, getCurrentKeyboardFocusManager, getDefaultFocusTraversalKeys, getDefaultFocusTraversalPolicy, getFocusedWindow, getFocusOwner, getGlobalActiveWindow, getGlobalCurrentFocusCycleRoot, getGlobalFocusedWindow, getGlobalFocusOwner, getGlobalPermanentFocusOwner, getKeyEventDispatchers, getKeyEventPostProcessors, getPermanentFocusOwner, getPropertyChangeListeners, getPropertyChangeListeners, getVetoableChangeListeners, getVetoableChangeListeners, redispatchEvent, removeKeyEventDispatcher, removeKeyEventPostProcessor, removePropertyChangeListener, removePropertyChangeListener, removeVetoableChangeListener, removeVetoableChangeListener, setCurrentKeyboardFocusManager, setDefaultFocusTraversalKeys, setDefaultFocusTraversalPolicy, setGlobalActiveWindow, setGlobalCurrentFocusCycleRoot, setGlobalFocusedWindow, setGlobalFocusOwner, setGlobalPermanentFocusOwner, upFocusCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultFocusManager

public DefaultFocusManager()
方法详细信息

getComponentAfter

public Component getComponentAfter(Container aContainer,
                                   Component aComponent)

getComponentBefore

public Component getComponentBefore(Container aContainer,
                                    Component aComponent)

getFirstComponent

public Component getFirstComponent(Container aContainer)

getLastComponent

public Component getLastComponent(Container aContainer)

compareTabOrder

public boolean compareTabOrder(Component a,
                               Component b)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultListCellRenderer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultListCellRenderer

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.DefaultListCellRenderer
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, SwingConstants
直接已知子类：
DefaultListCellRenderer.UIResource, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer
public class DefaultListCellRenderer
extends JLabel
implements ListCellRenderer, Serializable

呈现列表中的一个项。

实现注意事项： 此类重写 invalidate、validate、revalidate、repaint、isOpaque 和 firePropertyChange 只是为了提高性能。如果不重写这些方法，这些经常调用的方法将执行那些对于默认列表单元格渲染器不必要的代码路径。如果编写自己的渲染器，则要小心权衡重写这些方法的利弊。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class DefaultListCellRenderer.UIResource
实现 UIResource 的 DefaultListCellRenderer 的子类。
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected static Border noFocusBorder
一个空 Border。
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
DefaultListCellRenderer()
为列表中的项构造默认渲染器对象。
方法摘要
void | firePropertyChange(String propertyName, boolean oldValue, boolean newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, byte oldValue, byte newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, char oldValue, char newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, double oldValue, double newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, float oldValue, float newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, int oldValue, int newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, long oldValue, long newValue) 因为性能原因而被重写。
protected void | firePropertyChange(String propertyName, Object oldValue, Object newValue) 因为性能原因而被重写。
void | firePropertyChange(String propertyName, short oldValue, short newValue) 因为性能原因而被重写。
Component | getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus) 返回已配置用于显示指定值的组件。
void | invalidate() 因为性能原因而被重写。
boolean | isOpaque() 因为性能原因而被重写。
void | repaint() 因为性能原因而被重写。
void | repaint(long tm, int x, int y, int width, int height) 因为性能原因而被重写。
void | repaint(Rectangle r) 因为性能原因而被重写。
void | revalidate() 因为性能原因而被重写。
void | validate() 因为性能原因而被重写。
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

noFocusBorder

protected static Border noFocusBorder
一个空 Border。可以不使用此字段。要更改此渲染器所使用的 Border，需要重写 getListCellRendererComponent 方法并直接设置返回组件的边框。

构造方法详细信息

DefaultListCellRenderer

public DefaultListCellRenderer()
为列表中的项构造默认渲染器对象。

方法详细信息

getListCellRendererComponent

public Component getListCellRendererComponent(JList list,
                                              Object value,
                                              int index,
                                              boolean isSelected,
                                              boolean cellHasFocus)
从接口 ListCellRenderer 复制的描述
返回已配置用于显示指定值的组件。然后调用该组件的 paint 方法来“呈现”单元格。如果由于列表单元格没有固定的大小而有必要计算该列表的尺寸，则调用此方法来生成一个可在其上调用 getPreferredSize 的组件。

指定者：
接口 ListCellRenderer 中的 getListCellRendererComponent
参数：
list - 正在绘制的 JList。
value - 由 list.getModel().getElementAt(index) 返回的值。
index - 单元格索引。
isSelected - 如果选择了指定的单元格，则为 true。
cellHasFocus - 如果指定的单元格拥有焦点，则为 true。
返回：
其 paint() 方法将呈现指定值的组件。
另请参见：
JList, ListSelectionModel, ListModel

isOpaque

public boolean isOpaque()
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 JComponent 中的 isOpaque
返回：
如果背景是完全不透明的并且不同于 JList 的背景，则返回 true，否则返回 false
从以下版本开始：
1.5
另请参见：
JComponent.setOpaque(boolean)

validate

public void validate()
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Container 中的 validate
另请参见：
Container.add(java.awt.Component),
Component.invalidate(),
JComponent.revalidate(),
Container.validateTree()

invalidate

public void invalidate()
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Container 中的 invalidate
从以下版本开始：
1.5
另请参见：
Container.validate(), Container.layout(), LayoutManager, LayoutManager2.invalidateLayout(Container)

repaint

public void repaint()
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Component 中的 repaint
从以下版本开始：
1.5
另请参见：
Component.update(Graphics)

revalidate

public void revalidate()
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 JComponent 中的 revalidate
另请参见：
Component.invalidate(),
Container.validate(),
JComponent.isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

repaint

public void repaint(long tm,
                    int x,
                    int y,
                    int width,
                    int height)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 JComponent 中的 repaint
参数：
tm - 不使用此参数
x - 脏区的 x 值
y - 脏区的 y 值
width - 脏区的宽度
height - 脏区的高度
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

repaint

public void repaint(Rectangle r)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 JComponent 中的 repaint
参数：
r - 包含脏区的 Rectangle
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 其值已改变的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

public void firePropertyChange(String propertyName,
                               byte oldValue,
                               byte newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（byte 类型）
newValue - 该属性的新值（byte 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               char oldValue,
                               char newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 JComponent 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（char 类型）
newValue - 该属性的新值（char 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               short oldValue,
                               short newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（short 类型）
newValue - 该属性的新值（short 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               int oldValue,
                               int newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 JComponent 中的 firePropertyChange
参数：
propertyName - 其值已更改的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

public void firePropertyChange(String propertyName,
                               long oldValue,
                               long newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（long 类型）
newValue - 该属性的新值（long 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               float oldValue,
                               float newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（float 类型）
newValue - 该属性的新值（float 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               double oldValue,
                               double newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（double 类型）
newValue - 该属性的新值（double 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

firePropertyChange

public void firePropertyChange(String propertyName,
                               boolean oldValue,
                               boolean newValue)
因为性能原因而被重写。有关更多详细信息，请参阅实现注意事项。

覆盖：
类 JComponent 中的 firePropertyChange
参数：
propertyName - 其值已更改的属性
oldValue - 该属性以前的值
newValue - 该属性的新值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultListCellRenderer.UIResource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultListCellRenderer.UIResource

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
                    继承者  javax.swing.DefaultListCellRenderer
                        继承者  javax.swing.DefaultListCellRenderer.UIResource
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, ListCellRenderer, UIResource, SwingConstants
正在封闭类：
DefaultListCellRenderer
public static class DefaultListCellRenderer.UIResource
extends DefaultListCellRenderer
implements UIResource

实现 UIResource 的 DefaultListCellRenderer 的子类。DefaultListCellRenderer 不直接实现 UIResource，因此应用程序可以安全地使用 DefaultListCellRenderer 子类重写 cellRenderer 属性。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.DefaultListCellRenderer 继承的嵌套类/接口
DefaultListCellRenderer.UIResource
从类 javax.swing.JLabel 继承的嵌套类/接口
JLabel.AccessibleJLabel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.DefaultListCellRenderer 继承的字段
noFocusBorder
从类 javax.swing.JLabel 继承的字段
labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
DefaultListCellRenderer.UIResource()
方法摘要
从类 javax.swing.DefaultListCellRenderer 继承的方法
firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getListCellRendererComponent, invalidate, isOpaque, repaint, repaint, repaint, revalidate, validate
从类 javax.swing.JLabel 继承的方法
checkHorizontalKey, checkVerticalKey, getAccessibleContext, getDisabledIcon, getDisplayedMnemonic, getDisplayedMnemonicIndex, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getLabelFor, getText, getUI, getUIClassID, getVerticalAlignment, getVerticalTextPosition, imageUpdate, paramString, setDisabledIcon, setDisplayedMnemonic, setDisplayedMnemonic, setDisplayedMnemonicIndex, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabelFor, setText, setUI, setVerticalAlignment, setVerticalTextPosition, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DefaultListCellRenderer.UIResource

public DefaultListCellRenderer.UIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultListModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultListModel

java.lang.Object
    继承者  javax.swing.AbstractListModel
        继承者  javax.swing.DefaultListModel
所有已实现的接口：
Serializable, ListModel
public class DefaultListModel
extends AbstractListModel

此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。目前，它委托给一个 Vector，在将来的版本中，它将是一个真正的 Collection 实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.AbstractListModel 继承的字段
listenerList
构造方法摘要
DefaultListModel()
方法摘要
void | add(int index, Object element) 在此列表的指定位置处插入指定元素。
void | addElement(Object obj) 将指定组件添加到此类表的末尾。
int | capacity() 返回此列表的当前容量。
void | clear() 从此列表中移除所有元素。
boolean | contains(Object elem) 测试指定对象是否为此类表中的组件。
void | copyInto(Object[] anArray) 将此列表的组件复制到指定数组中。
Object | elementAt(int index) 返回指定索引处的组件。
Enumeration<?> | elements() 返回此列表的组件枚举。
void | ensureCapacity(int minCapacity) 增加此列表的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。
Object | firstElement() 返回此列表中的第一个组件。
Object | get(int index) 返回列表中指定位置处的元素。
Object | getElementAt(int index) 返回指定索引处的组件。
int | getSize() 返回此列表中的组件数。
int | indexOf(Object elem) 搜索 elem 的第一次出现。
int | indexOf(Object elem, int index) 从 index 开始搜索 elem 的第一次出现。
void | insertElementAt(Object obj, int index) 将指定对象作为此列表中的组件插入到指定的 index 处。
boolean | isEmpty() 测试此列表中是否有组件。
Object | lastElement() 返回列表的最后一个组件。
int | lastIndexOf(Object elem) 返回 elem 最后一次出现处的索引。
int | lastIndexOf(Object elem, int index) 从指定的索引处开始反向搜索 elem，并返回该对象的索引。
Object | remove(int index) 移除此列表中指定位置处的元素。
void | removeAllElements() 从此列表中移除所有组件，并将它们的大小设置为零。
boolean | removeElement(Object obj) 从此列表中移除参数的第一个（索引最小的）匹配项。
void | removeElementAt(int index) 删除指定索引处的组件。
void | removeRange(int fromIndex, int toIndex) 删除指定索引范围中的组件。
Object | set(int index, Object element) 使用指定元素替换此列表中指定位置上的元素。
void | setElementAt(Object obj, int index) 将此列表指定 index 处的组件设置为指定的对象。
void | setSize(int newSize) 设置此列表的大小。
int | size() 返回此列表中的组件数。
Object[] | toArray() 以正确顺序返回包含此列表中所有元素的数组。
String | toString() 返回显示并标识此对象的属性的字符串。
void | trimToSize() 对此列表的容量进行裁剪，使其等于此列表的当前大小。
从类 javax.swing.AbstractListModel 继承的方法
addListDataListener, fireContentsChanged, fireIntervalAdded, fireIntervalRemoved, getListDataListeners, getListeners, removeListDataListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

DefaultListModel

public DefaultListModel()
方法详细信息

getSize

public int getSize()
返回此列表中的组件数。

此方法等同于 size，后者实现 1.2 Collections 框架中定义的 List 接口。此方法连同 setSize 一起存在，因此可以将 size 看作为一个 JavaBean 属性。

返回：
此列表中的组件数
另请参见：
size()

getElementAt

public Object getElementAt(int index)
返回指定索引处的组件。
注：尽管此方法未过时，但首选使用方法是 get(int)，该方法实现 1.2 Collections 框架中定义的 List 接口。

参数：
index - 此列表中的索引
返回：
指定索引处的组件
抛出：
ArrayIndexOutOfBoundsException - 如果 index 为负或大于此列表的当前大小
另请参见：
get(int)

copyInto

public void copyInto(Object[] anArray)
将此列表的组件复制到指定数组中。数组必须足够大，能够保存此列表中的所有对象，否则抛出 IndexOutOfBoundsException。

参数：
anArray - 要将组件复制到其中的数组
另请参见：
Vector.copyInto(Object[])

trimToSize

public void trimToSize()
对此列表的容量进行裁剪，使其等于此列表的当前大小。

另请参见：
Vector.trimToSize()

ensureCapacity

public void ensureCapacity(int minCapacity)
增加此列表的容量（如有必要），以确保其至少能够保存最小容量参数指定的组件数。

参数：
minCapacity - 所需的最小容量
另请参见：
Vector.ensureCapacity(int)

setSize

public void setSize(int newSize)
设置此列表的大小。

参数：
newSize - 此列表的新大小
另请参见：
Vector.setSize(int)

capacity

public int capacity()
返回此列表的当前容量。

返回：
当前容量
另请参见：
Vector.capacity()

size

public int size()
返回此列表中的组件数。

返回：
此列表中的组件数
另请参见：
Vector.size()

isEmpty

public boolean isEmpty()
测试此列表中是否有组件。

返回：
当且仅当此列表中没有组件（也就是说其大小为零）时返回 true；否则返回 false
另请参见：
Vector.isEmpty()

elements

public Enumeration<?> elements()
返回此列表的组件枚举。

返回：
此列表的组件枚举
另请参见：
Vector.elements()

contains

public boolean contains(Object elem)
测试指定对象是否为此类表中的组件。

参数：
elem - 对象
返回：
如果指定对象是此列表中的组件，则返回 true
另请参见：
Vector.contains(Object)

indexOf

public int indexOf(Object elem)
搜索 elem 的第一次出现。

参数：
elem - 一个对象
返回：
此列表中该参数第一次出现时所在位置上的索引；如果没有找到该对象，则返回 -1
另请参见：
Vector.indexOf(Object)

indexOf

public int indexOf(Object elem,
                   int index)
从 index 开始搜索 elem 的第一次出现。

参数：
elem - 所需的组件
index - 从其所在的位置开始进行搜索的索引
返回：
index 之后第一次出现 elem 处的索引；如果在列表中没有找到 elem，则返回 -1
另请参见：
Vector.indexOf(Object,int)

lastIndexOf

public int lastIndexOf(Object elem)
返回 elem 最后一次出现处的索引。

参数：
elem - 所需的组件
返回：
列表中 elem 最后一次出现处的索引；如果没有找到该对象，则返回 -1
另请参见：
Vector.lastIndexOf(Object)

lastIndexOf

public int lastIndexOf(Object elem,
                       int index)
从指定的索引处开始反向搜索 elem，并返回该对象的索引。

参数：
elem - 所需的组件
index - 从其所在的位置开始进行搜索的索引
返回：
列表中 index 之前最后一次出现 elem 处的索引；如果在列表中没有找到该对象，则返回 -1
另请参见：
Vector.lastIndexOf(Object,int)

elementAt

public Object elementAt(int index)
返回指定索引处的组件。如果索引为负或不小于列表的大小，则抛出 ArrayIndexOutOfBoundsException。
注：尽管此方法未过时，但首选使用方法是 get(int)，该方法实现 1.2 Collections 框架中定义的 List 接口。

参数：
index - 此列表中的一个索引
返回：
指定索引处的组件
另请参见：
get(int), Vector.elementAt(int)

firstElement

public Object firstElement()
返回此列表中的第一个组件。如果此向量没有组件，则抛出 NoSuchElementException。

返回：
此列表的第一个组件
另请参见：
Vector.firstElement()

lastElement

public Object lastElement()
返回列表的最后一个组件。如果此向量没有组件，则抛出 NoSuchElementException。

返回：
列表的最后一个组件
另请参见：
Vector.lastElement()

setElementAt

public void setElementAt(Object obj,
                         int index)
将此列表指定 index 处的组件设置为指定的对象。丢弃该位置以前的组件。

如果索引无效，则抛出 ArrayIndexOutOfBoundsException。

注：尽管此方法未过时，但首选使用方法是 set(int,Object)，该方法实现 1.2 Collections 框架中定义的 List 接口。

参数：
obj - 组件的设置目标
index - 指定的索引
另请参见：
set(int,Object), Vector.setElementAt(Object,int)

removeElementAt

public void removeElementAt(int index)
删除指定索引处的组件。

如果索引无效，则抛出 ArrayIndexOutOfBoundsException。

注：尽管此方法未过时，但首选使用方法是 remove(int)，该方法实现 1.2 Collections 框架中定义的 List 接口。

参数：
index - 要移除对象的索引
另请参见：
remove(int), Vector.removeElementAt(int)

insertElementAt

public void insertElementAt(Object obj,
                            int index)
将指定对象作为此列表中的组件插入到指定的 index 处。

如果索引无效，则抛出 ArrayIndexOutOfBoundsException。

注：尽管此方法未过时，但首选使用方法是 add(int,Object)，该方法实现 1.2 Collections 框架中定义的 List 接口。

参数：
obj - 要插入的组件
index - 插入新组件的位置
抛出：
ArrayIndexOutOfBoundsException - 如果索引无效
另请参见：
add(int,Object), Vector.insertElementAt(Object,int)

addElement

public void addElement(Object obj)
将指定组件添加到此类表的末尾。

参数：
obj - 要添加的组件
另请参见：
Vector.addElement(Object)

removeElement

public boolean removeElement(Object obj)
从此列表中移除参数的第一个（索引最小的）匹配项。

参数：
obj - 要移除的组件
返回：
如果该参数是此列表的一个组件，则返回 true；否则返回 false
另请参见：
Vector.removeElement(Object)

removeAllElements

public void removeAllElements()
从此列表中移除所有组件，并将它们的大小设置为零。
注：尽管此方法未过时，但首选使用方法是 clear，该方法实现 1.2 Collections 框架中定义的 List 接口。

另请参见：
clear(), Vector.removeAllElements()

toString

public String toString()
返回显示并标识此对象的属性的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的 String 表示形式

toArray

public Object[] toArray()
以正确顺序返回包含此列表中所有元素的数组。

返回：
包含列表元素的数组
另请参见：
Vector.toArray()

get

public Object get(int index)
返回列表中指定位置处的元素。

如果索引超出范围（index < 0 || index >= size()），则抛出 ArrayIndexOutOfBoundsException。

参数：
index - 要返回的元素的索引

set

public Object set(int index,
                  Object element)
使用指定元素替换此列表中指定位置上的元素。

如果索引超出范围（index < 0 || index >= size()），则抛出 ArrayIndexOutOfBoundsException。

参数：
index - 要替换的元素的索引
element - 要存储在指定位置上的元素
返回：
以前在指定位置上的元素

add

public void add(int index,
                Object element)
在此列表的指定位置处插入指定元素。

如果索引超出范围（index < 0 || index > size()），则抛出 ArrayIndexOutOfBoundsException。

参数：
index - 指定元素的插入位置的索引
element - 要插入的元素

remove

public Object remove(int index)
移除此列表中指定位置处的元素。返回从列表中移除的元素。

如果索引超出范围（index < 0 || index >= size()），则抛出 ArrayIndexOutOfBoundsException。

参数：
index - 要移除的元素的索引

clear

public void clear()
从此列表中移除所有元素。此调用返回后，列表将是空的（除非该调用抛出异常）。

removeRange

public void removeRange(int fromIndex,
                        int toIndex)
删除指定索引范围中的组件。移除组件包括指定范围两个端点处的组件，因此，如果指定范围 (1,5)，则移除索引 1 处的组件和索引 5 处的组件，以及它们之间的所有组件。

如果索引无效，则抛出 ArrayIndexOutOfBoundsException。如果 fromIndex > toIndex，则抛出 IllegalArgumentException。

参数：
fromIndex - 范围低端点的索引
toIndex - 范围高端点的索引
另请参见：
remove(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultListSelectionModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultListSelectionModel

java.lang.Object
    继承者  javax.swing.DefaultListSelectionModel
所有已实现的接口：
Serializable, Cloneable, ListSelectionModel
public class DefaultListSelectionModel
extends Object
implements ListSelectionModel, Cloneable, Serializable

列表选择的默认数据模型。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
ListSelectionModel

字段摘要
protected boolean | leadAnchorNotificationEnabled
protected EventListenerList | listenerList
从接口 javax.swing.ListSelectionModel 继承的字段
MULTIPLE_INTERVAL_SELECTION, SINGLE_INTERVAL_SELECTION, SINGLE_SELECTION
构造方法摘要
DefaultListSelectionModel()
方法摘要
 void addListSelectionListener(ListSelectionListener l)
将侦听器添加到每次在选择发生更改时都得到通知的列表。
 void addSelectionInterval(int index0, int index1)
将选择更改为当前选择与 index0 和 index1（包括）之间索引的并集。
 void clearSelection()
将该选择更改为空集。
 Object clone()
返回此选择模型的具有相同选择的副本。
protected  void fireValueChanged(boolean isAdjusting)
通知侦听器已经结束了一系列的调整。
protected  void fireValueChanged(int firstIndex, int lastIndex)
通知 ListSelectionListener 选择的值已发生更改，该值在 firstIndex 和 lastIndex 组成的闭区间内。
protected  void fireValueChanged(int firstIndex, int lastIndex, boolean isAdjusting)
 int getAnchorSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。
 int getLeadSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
 ListSelectionListener[] getListSelectionListeners()
返回已在此 DefaultListSelectionModel 上注册的所有列表选择侦听器组成的数组。
 int getMaxSelectionIndex()
返回最后选择的索引，如果选择为空，则返回 -1。
 int getMinSelectionIndex()
返回第一个选择的索引，如果选择为空，则返回 -1。
 int getSelectionMode()
返回当前选择模式。
 boolean getValueIsAdjusting()
如果选择在进行一系列更改，则返回 true。
 void insertIndexInterval(int index, int length, boolean before)
从 index 之前/之后开始插入 length 个索引。
 boolean isLeadAnchorNotificationEnabled()
返回 leadAnchorNotificationEnabled 标志的值。
 boolean isSelectedIndex(int index)
如果选择了指定的索引，则返回 true。
 boolean isSelectionEmpty()
如果没有选择索引，则返回 true。
 void moveLeadSelectionIndex(int leadIndex)
设置 lead 选择索引，并不作更改地保留所有选择值。
 void removeIndexInterval(int index0, int index1)
从选择模型中移除 index0,index1 区间中（包括两端点）的索引。
 void removeListSelectionListener(ListSelectionListener l)
将侦听器从每次在选择发生更改时都得到通知的列表中移除。
 void removeSelectionInterval(int index0, int index1)
将选择更改为当前选择与 index0 和 index1（包括）之间索引的差集。
 void setAnchorSelectionIndex(int anchorIndex)
设置 anchor 选择索引，并不作更改地保留所有选择值。
 void setLeadAnchorNotificationEnabled(boolean flag)
设置 leadAnchorNotificationEnabled 标志的值。
 void setLeadSelectionIndex(int leadIndex)
设置 lead 选择索引，确保 anchor 和新 lead 之间的值要么全部被选定，要么全部被取消选定。
 void setSelectionInterval(int index0, int index1)
将选择更改为 index0 和 index1（包括）的范围之间。
 void setSelectionMode(int selectionMode)
设置选择模式。
 void setValueIsAdjusting(boolean isAdjusting)
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。
 String toString()
返回显示并标识此对象的属性的字符串。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

listenerList

protected EventListenerList listenerList

leadAnchorNotificationEnabled

protected boolean leadAnchorNotificationEnabled
构造方法详细信息

DefaultListSelectionModel

public DefaultListSelectionModel()
方法详细信息

getMinSelectionIndex

public int getMinSelectionIndex()
返回第一个选择的索引，如果选择为空，则返回 -1。

指定者：
接口 ListSelectionModel 中的 getMinSelectionIndex

getMaxSelectionIndex

public int getMaxSelectionIndex()
返回最后选择的索引，如果选择为空，则返回 -1。

指定者：
接口 ListSelectionModel 中的 getMaxSelectionIndex

getValueIsAdjusting

public boolean getValueIsAdjusting()
如果选择在进行一系列更改，则返回 true。

指定者：
接口 ListSelectionModel 中的 getValueIsAdjusting
返回：
如果选择在进行一系列更改，则返回 true
另请参见：
ListSelectionModel.setValueIsAdjusting(boolean)

getSelectionMode

public int getSelectionMode()
返回当前选择模式。

指定者：
接口 ListSelectionModel 中的 getSelectionMode
返回：
当前选择模式
另请参见：
ListSelectionModel.setSelectionMode(int)

setSelectionMode

public void setSelectionMode(int selectionMode)
设置选择模式。以下列表描述了接受的选择模式：
  • ListSelectionModel.SINGLE_SELECTION - 一次只能选择一个列表索引。在此模式中，setSelectionInterval 和 addSelectionInterval 是等效的，两者都使用第二个参数（“lead”）所表示的索引来替换当前选择。
  • ListSelectionModel.SINGLE_INTERVAL_SELECTION - 一次只能选择一个连续索引区间。在此模式中，addSelectionInterval 行为类似于 setSelectionInterval（替换当前选择），除非给定区间紧接现有选择或与现有选择重叠从而可用于增大该选择。
  • ListSelectionModel.MULTIPLE_INTERVAL_SELECTION - 在此模式中，对选择内容无任何限制。

指定者：
接口 ListSelectionModel 中的 setSelectionMode
抛出：
IllegalArgumentException - 如果选择模式不是允许的模式之一
另请参见：
ListSelectionModel.getSelectionMode()

isSelectedIndex

public boolean isSelectedIndex(int index)
如果选择了指定的索引，则返回 true。

指定者：
接口 ListSelectionModel 中的 isSelectedIndex

isSelectionEmpty

public boolean isSelectionEmpty()
如果没有选择索引，则返回 true。

指定者：
接口 ListSelectionModel 中的 isSelectionEmpty

addListSelectionListener

public void addListSelectionListener(ListSelectionListener l)
将侦听器添加到每次在选择发生更改时都得到通知的列表。

指定者：
接口 ListSelectionModel 中的 addListSelectionListener
参数：
l - ListSelectionListener
另请参见：
ListSelectionModel.removeListSelectionListener(javax.swing.event.ListSelectionListener),
ListSelectionModel.setSelectionInterval(int, int),
ListSelectionModel.addSelectionInterval(int, int),
ListSelectionModel.removeSelectionInterval(int, int),
ListSelectionModel.clearSelection(),
ListSelectionModel.insertIndexInterval(int, int, boolean),
ListSelectionModel.removeIndexInterval(int, int)

removeListSelectionListener

public void removeListSelectionListener(ListSelectionListener l)
将侦听器从每次在选择发生更改时都得到通知的列表中移除。

指定者：
接口 ListSelectionModel 中的 removeListSelectionListener
参数：
l - ListSelectionListener
另请参见：
ListSelectionModel.addListSelectionListener(javax.swing.event.ListSelectionListener)

getListSelectionListeners

public ListSelectionListener[] getListSelectionListeners()
返回已在此 DefaultListSelectionModel 上注册的所有列表选择侦听器组成的数组。

返回：
此模型的所有 ListSelectionListener，如果当前没有已注册的列表选择侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener), removeListSelectionListener(javax.swing.event.ListSelectionListener)

fireValueChanged

protected void fireValueChanged(boolean isAdjusting)
通知侦听器已经结束了一系列的调整。

fireValueChanged

protected void fireValueChanged(int firstIndex,
                                int lastIndex)
通知 ListSelectionListener 选择的值已发生更改，该值在 firstIndex 和 lastIndex 组成的闭区间内。

fireValueChanged

protected void fireValueChanged(int firstIndex,
                                int lastIndex,
                                boolean isAdjusting)
参数：
firstIndex - 区间中的第一个索引
lastIndex - 区间中的最后一个索引
isAdjusting - 如果这是一系列调整中的最终更改，则该参数为 true
另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用下面的代码查询 DefaultListSelectionModel 实例 m 的列表选择侦听器：

ListSelectionListener[] lsls = (ListSelectionListener[])(m.getListeners(ListSelectionListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 请求的侦听器类型；该参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此模型上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getListSelectionListeners()

setLeadAnchorNotificationEnabled

public void setLeadAnchorNotificationEnabled(boolean flag)
设置 leadAnchorNotificationEnabled 标志的值。

另请参见：
isLeadAnchorNotificationEnabled()

isLeadAnchorNotificationEnabled

public boolean isLeadAnchorNotificationEnabled()
返回 leadAnchorNotificationEnabled 标志的值。当 leadAnchorNotificationEnabled 为 true 时，该模型生成具有限定范围的通知事件，该范围覆盖对选择所做的所有更改以及对 lead 和 anchor 索引所做的更改。将标志设置为 false 会导致事件的限定范围缩小，使其只包括那些已选择的或自上一次更改之后取消选择的元素。总之，该模型将继续内部维护 lead 和 anchor 变量。默认值为 true。

注：在不更改选择的情况下更改 lead 或 anchor 是有可能的。通知这些更改常常很重要，比如需要在视图中更新新的 lead 或 anchor 时。因此，在更改默认值时，一定要小心谨慎。

返回：
leadAnchorNotificationEnabled 标志的值
另请参见：
setLeadAnchorNotificationEnabled(boolean)

clearSelection

public void clearSelection()
将该选择更改为空集。如果这表示对当前选择的更改，则通知每个 ListSelectionListener。

指定者：
接口 ListSelectionModel 中的 clearSelection
另请参见：
ListSelectionModel.addListSelectionListener(javax.swing.event.ListSelectionListener)

setSelectionInterval

public void setSelectionInterval(int index0,
                                 int index1)
将选择更改为 index0 和 index1（包括）的范围之间。index0 不必小于等于 index1。

在 SINGLE_SELECTION 选择模式中，只使用第二个索引。

如果这表示对当前选择的更改，那么将向每个 ListSelectionListener 通知更改。

如果任一索引为 -1，则此方法不执行任何操作，并不带任何异常地返回。如果任一索引小于 -1，则抛出 IndexOutOfBoundsException。

指定者：
接口 ListSelectionModel 中的 setSelectionInterval
参数：
index0 - 区间的一端
index1 - 区间的另一端
抛出：
IndexOutOfBoundsException - 如果任一索引小于 -1（并且两个索引都不为 -1）
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener)

addSelectionInterval

public void addSelectionInterval(int index0,
                                 int index1)
将选择更改为当前选择与 index0 和 index1（包括）之间索引的并集。

在 SINGLE_SELECTION 选择模式中，此方法等效于调用 setSelectionInterval，并且只使用第二个索引。在 SINGLE_INTERVAL_SELECTION 选择模式中，此方法与 setSelectionInterval 的作用完全相同，除非给定区间紧接现有选择或与现有选择重叠从而可用于增大它。

如果这表示对当前选择的更改，那么将向每个 ListSelectionListener 通知更改。注意，index0 不必小于等于 index1。

如果任一索引为 -1，则此方法不执行任何操作，并不带任何异常地返回。如果任一索引小于 -1，则抛出 IndexOutOfBoundsException。

指定者：
接口 ListSelectionModel 中的 addSelectionInterval
参数：
index0 - 区间的一端
index1 - 区间的另一端
抛出：
IndexOutOfBoundsException - 如果任一索引小于 -1（并且两个索引都不为 -1）
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener), setSelectionInterval(int, int)

removeSelectionInterval

public void removeSelectionInterval(int index0,
                                    int index1)
将选择更改为当前选择与 index0 和 index1（包括）之间索引的差集。index0 不必小于等于 index1。

在 SINGLE_INTERVAL_SELECTION 选择模式中，如果移除操作将生成两个不相交的选择，则移除操作将通过该选择较大的一端延伸。例如，如果选择为 0-10，提供索引 5,6（按任意顺序），则所得选择为 0-4。

如果这表示对当前选择的更改，那么将向每个 ListSelectionListener 通知更改。

如果任一索引为 -1，则此方法不执行任何操作，并不带任何异常地返回。如果任一索引小于 -1，则抛出 IndexOutOfBoundsException。

指定者：
接口 ListSelectionModel 中的 removeSelectionInterval
参数：
index0 - 区间的一端
index1 - 区间的另一端
抛出：
IndexOutOfBoundsException - 如果任一索引小于 -1（并且两个索引都不为 -1）
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener)

insertIndexInterval

public void insertIndexInterval(int index,
                                int length,
                                boolean before)
从 index 之前/之后开始插入 length 个索引。如果 index 处的值本身处于已选状态，并且选择模式不是 SINGLE_SELECTION，则将新插入的所有项都设置为已选状态。否则将它们都设置为未选择状态。通常调用此方法来同步选择模型与数据模型中的相应更改。

指定者：
接口 ListSelectionModel 中的 insertIndexInterval

removeIndexInterval

public void removeIndexInterval(int index0,
                                int index1)
从选择模型中移除 index0,index1 区间中（包括两端点）的索引。通常调用此方法来同步选择模型与数据模型中的相应更改。注意，同往常一样，index0 不必 <= index1。

指定者：
接口 ListSelectionModel 中的 removeIndexInterval

setValueIsAdjusting

public void setValueIsAdjusting(boolean isAdjusting)
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。此属性的值用于初始化生成 ListSelectionEvent 的 valueIsAdjusting 属性。

例如，如果选择被更新以响应一个用户的拖动，那么在拖动开始时，此属性被设置为 true；在拖动结束时被设置为 false。在拖动期间，侦听器接收 valueIsAdjusting 属性设置为 true 的事件。在拖动的最后，当更改终止时，侦听器接收一个值设置为 false 的事件。如果只在更改已终止时希望更新，则侦听器可以使用此模式。

将此属性设置为 true 将开始一系列将被视为单个更改一部分的更改。当该属性更改回 false 时，发送一个表现整个选择更改特征的事件（如果有），该事件的 valueIsAdjusting 属性设置为 false。

指定者：
接口 ListSelectionModel 中的 setValueIsAdjusting
参数：
isAdjusting - 属性的新值
另请参见：
ListSelectionModel.getValueIsAdjusting(), ListSelectionEvent.getValueIsAdjusting()

toString

public String toString()
返回显示并标识此对象的属性的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的 String 表示形式

clone

public Object clone()
             throws CloneNotSupportedException
返回此选择模型的具有相同选择的副本。listenerList 没有被复制。

覆盖：
类 Object 中的 clone
返回：
此实例的一个副本。
抛出：
CloneNotSupportedException - 如果选择模型没有 (a) 实现 Cloneable 接口且 (b) 定义一个 clone 方法。
另请参见：
Cloneable

getAnchorSelectionIndex

public int getAnchorSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。最近的 index0 被认为是 "anchor"，最近的 index1 被认为是 "lead"。一些界面特别地显示这些索引，例如，Windows95 显示带有黄色点式轮廓的 lead 索引。

指定者：
接口 ListSelectionModel 中的 getAnchorSelectionIndex
另请参见：
ListSelectionModel.getLeadSelectionIndex(),
ListSelectionModel.setSelectionInterval(int, int),
ListSelectionModel.addSelectionInterval(int, int)

getLeadSelectionIndex

public int getLeadSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。

指定者：
接口 ListSelectionModel 中的 getLeadSelectionIndex
另请参见：
ListSelectionModel.getAnchorSelectionIndex(),
ListSelectionModel.setSelectionInterval(int, int),
ListSelectionModel.addSelectionInterval(int, int)

setAnchorSelectionIndex

public void setAnchorSelectionIndex(int anchorIndex)
设置 anchor 选择索引，并不作更改地保留所有选择值。如果 leadAnchorNotificationEnabled 为 true，则发送一个覆盖原有 anchor 单元格和新 anchor 单元格的通知。

指定者：
接口 ListSelectionModel 中的 setAnchorSelectionIndex
另请参见：
getAnchorSelectionIndex(), setLeadSelectionIndex(int)

moveLeadSelectionIndex

public void moveLeadSelectionIndex(int leadIndex)
设置 lead 选择索引，并不作更改地保留所有选择值。如果 leadAnchorNotificationEnabled 为 true，则发送一个覆盖原有 lead 单元格和新 lead 单元格的通知。

参数：
leadIndex - 新的 lead 选择索引
从以下版本开始：
1.5
另请参见：
setAnchorSelectionIndex(int), setLeadSelectionIndex(int), getLeadSelectionIndex()

setLeadSelectionIndex

public void setLeadSelectionIndex(int leadIndex)
设置 lead 选择索引，确保 anchor 和新 lead 之间的值要么全部被选定，要么全部被取消选定。如果 anchor 索引处的值被选定，则首先清除范围 [anchor, oldLeadIndex] 中的所有值，然后选择范围 [anchor, newLeadIndex] 中的所有值，其中 oldLeadIndex 是原有的 leadIndex，newLeadIndex 是新的 leadIndex。

如果 anchor 索引处的值未被选定，则反过来执行上述操作：选择原有范围中的值，并取消选择新范围中的值。

为此更改生成一个事件，并通知所有侦听器。为了在此事件中生成最小的限定范围，要一次完成该操作；那样广播的 ListSelectionEvent 中第一个和最后一个索引将指出由于此方法而实际更改了其值的单元格。如果分两步完成此操作，则选择状态上的效果将是相同的，但会生成两个事件，更改值的限定范围变得更宽，包括之前已清除但稍后又被设置的单元格。

可以在 UI 类的 mouseDragged 方法中使用此方法来扩展选择。

指定者：
接口 ListSelectionModel 中的 setLeadSelectionIndex
另请参见：
getLeadSelectionIndex(), setAnchorSelectionIndex(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultRowSorter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultRowSorter<M,I>

java.lang.Object
    继承者  javax.swing.RowSorter<M>
        继承者  javax.swing.DefaultRowSorter<M,I>
类型参数：
M - 模型的类型
I - 传递给 RowFilter 的标识符类型
直接已知子类：
TableRowSorter
public abstract class DefaultRowSorter<M,I>
extends RowSorter<M>

RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。除了创建和安装 RowSorter 之外，几乎不需要直接与它交互。有关 JTable 的 RowSorter 具体实现，请参阅 TableRowSorter。

排序操作依次根据当前的 SortKey 完成。如果两个对象相等（Comparator 对于列返回 0），则使用下一个 SortKey。如果没有剩余的 SortKey 或者顺序为 UNSORTED，则使用模型中行的顺序。

每一列的排序操作通过 Comparator 来完成，可以使用 setComparator 方法来指定 Comparator。如果尚未指定 Comparator，则先对底层对象调用 toString，再对其结果调用 Collator.getInstance()，使用所返回的 Comparator。Comparator 不传递 null。null 值被视为在非 null 值之前出现，两个 null 值被认为是相等的。

如果指定的 Comparator 将其参数强制转换为一个模型没有提供的类型，则对数据进行排序时将抛出 ClassCastException。

除了排序操作，DefaultRowSorter 还提供过滤行的能力。过滤操作通过用 setRowFilter 方法指定的 RowFilter 来完成。如果没有指定过滤器，则包含所有行。

默认情况下，行是未排序的（与模型相同），每一列都是可排序的。默认的 Comparator 记录在子类中（例如，TableRowSorter）。

如果底层模型结构更改（调用了 modelStructureChanged 方法），则以下内容被重置为默认值：按列的 Comparator、当前排序顺序、每一列是否都是可排序的。要找到默认的 Comparator，请参阅具体实现（例如，TableRowSorter）。默认的排序顺序是未排序的（与模型相同），默认情况下列是可排序的。

如果底层模型结构更改（调用了 modelStructureChanged 方法），则以下内容被重置为默认值：按列的 Comparator、当前排序顺序、某一列是否是可排序的。

DefaultRowSorter 是一个抽象类。通过调用 setModelWrapper，具体子类必须提供对底层数据的访问。调用构造方法之后必须立即调用 setModelWrapper 方法，最好是从子类的构造方法中进行调用。如果使用 DefaultRowSorter 时没有指定 ModelWrapper，则会导致不确定的行为。

DefaultRowSorter 有两种形式的类型参数。第一种类型参数对应于模型的类，例如 DefaultTableModel。第二种类型参数对应于传递给 RowFilter 的标识符的类。有关类型参数的详细信息，请参阅 TableRowSorter 和 RowFilter。

从以下版本开始：
1.6
另请参见：
TableRowSorter, DefaultTableModel, Collator

嵌套类摘要
protected static class DefaultRowSorter.ModelWrapper<M,I>
DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。
从类 javax.swing.RowSorter 继承的嵌套类/接口
RowSorter.SortKey
构造方法摘要
DefaultRowSorter()
创建一个空 DefaultRowSorter。
方法摘要
void | allRowsChanged() 当底层模型的内容完全更改时，调用此方法。
int | convertRowIndexToModel(int index) 返回基于底层模型的 index 的位置。
int | convertRowIndexToView(int index) 返回基于视图 index 的位置。
Comparator<?> | getComparator(int column) 返回指定列的 Comparator。
int | getMaxSortKeys() 返回排序键的最大数量。
M | getModel() 返回底层模型。
int | getModelRowCount() 返回底层模型中的行数。
protected DefaultRowSorter.ModelWrapper<M,I> | getModelWrapper() 返回模型包装器，它提供将要进行排序和过滤的数据。
RowFilter<? super M,? super I> | getRowFilter() 返回用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
List<? extends RowSorter.SortKey> | getSortKeys() 返回当前排序键。
boolean | getSortsOnUpdates() 如果底层模型更新时应该进行排序，则返回 true；否则返回 false。
int | getViewRowCount() 返回视图中的行数。
boolean | isSortable(int column) 如果指定的列可排序，则返回 true；否则返回 false。
void | modelStructureChanged() 当底层模型结构完全更改时，调用此方法。
void | rowsDeleted(int firstRow, int endRow) 当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。
void | rowsInserted(int firstRow, int endRow) 当行已经插入到指定范围（包括）内的底层模型时，调用此方法。
void | rowsUpdated(int firstRow, int endRow) 当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。
void | rowsUpdated(int firstRow, int endRow, int column) 当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。
void | setComparator(int column, Comparator<?> comparator) 设置对指定列进行排序时要使用的 Comparator。
void | setMaxSortKeys(int max) 设置排序键的最大数量。
protected void | setModelWrapper(DefaultRowSorter.ModelWrapper<M,I> modelWrapper) 设置模型包装器，它提供将要进行排序和过滤的数据。
void | setRowFilter(RowFilter<? super M,? super I> filter) 设置用于确定哪些行（如果有）应该在视图中隐藏的过滤器。
void | setSortable(int column, boolean sortable) 设置指定列是否可排序。
void | setSortKeys(List<? extends RowSorter.SortKey> sortKeys) 设置排序键。
void | setSortsOnUpdates(boolean sortsOnUpdates) 如果为 true，则指定应该在底层模型更新（调用了 rowsUpdated）时进行排序。
void | sort() 根据当前正在排序的列的排序键以及与此排序器关联的过滤器（如果有）对视图中的行进行排序和过滤。
void | toggleSortOrder(int column) 如果指定列已经是主要排序列，则反转排序顺序（将升序变为降序，或将降序变为升序）；否则，使指定列成为主要排序列，并使用升序排序顺序。
protected boolean | useToString(int column) 返回排序过程中进行比较之前是否要将值转换为字符串。
从类 javax.swing.RowSorter 继承的方法
addRowSorterListener, fireRowSorterChanged, fireSortOrderChanged, removeRowSorterListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultRowSorter

public DefaultRowSorter()
创建一个空 DefaultRowSorter。

方法详细信息

setModelWrapper

protected final void setModelWrapper(DefaultRowSorter.ModelWrapper<M,I> modelWrapper)
设置模型包装器，它提供将要进行排序和过滤的数据。

参数：
modelWrapper - 负责提供要进行排序和过滤的数据的模型包装器
抛出：
IllegalArgumentException - 如果 modelWrapper 为 null

getModelWrapper

protected final DefaultRowSorter.ModelWrapper<M,I> getModelWrapper()
返回模型包装器，它提供将要进行排序和过滤的数据。

返回：
负责提供要进行排序和过滤的数据的模型包装器

getModel

public final M getModel()
返回底层模型。

指定者：
类 RowSorter<M> 中的 getModel
返回：
底层模型

setSortable

public void setSortable(int column,
                        boolean sortable)
设置指定列是否可排序。只有调用 toggleSortOrder 时才检查指定的值。通过直接设置排序键，仍然可以对已标记为不可排序的列进行排序。默认值为 true。

参数：
column - 要启用排序或禁用排序的列，就底层模型而言
sortable - 指定的列是否可排序
抛出：
IndexOutOfBoundsException - 如果 column 超出模型的范围
另请参见：
toggleSortOrder(int), setSortKeys(java.util.List)

isSortable

public boolean isSortable(int column)
如果指定的列可排序，则返回 true；否则返回 false。

参数：
column - 要检查排序的列，就底层模型而言
返回：
如果该列可排序，则返回 true
抛出：
IndexOutOfBoundsException - 如果 column 超出底层模型的范围

setSortKeys

public void setSortKeys(List<? extends RowSorter.SortKey> sortKeys)
设置排序键。此方法创建所提供 List 的一个副本；对所提供 List 的后续更改不影响此 DefaultRowSorter。如果排序键已更改，则此方法触发一个排序。

指定者：
类 RowSorter<M> 中的 setSortKeys
参数：
sortKeys - 新的 SortKey；null 是指定一个空列表的简单表示方法，表示视图应该是未排序的。
抛出：
IllegalArgumentException - 如果 sortKey 中的任一值为 null，或者有超出模型范围的列索引

getSortKeys

public List<? extends RowSorter.SortKey> getSortKeys()
返回当前排序键。此方法返回一个无法修改的非 null List。如果需要更改排序键，可创建所返回 List 的一个副本，更改该副本并使用新列表调用 setSortKeys。

指定者：
类 RowSorter<M> 中的 getSortKeys
返回：
当前排序顺序

setMaxSortKeys

public void setMaxSortKeys(int max)
设置排序键的最大数量。排序键的数量决定了排序时如何解决相等的值。例如，假定创建了一个表格行排序器并对其调用 setMaxSortKeys(2)。用户单击列 1 表头，使表格行按照列 1 中的项进行排序。然后，用户单击列 2 的表头，使表格按照列 2 中的项进行排序；如果列 2 中的所有项都相等，则按照列 1 中的项对那些特定行进行排序。在这种情况下，我们说行首先在列 2 上进行排序，其次在列 1 上进行排序。如果用户单击列 3 的表头，则首先在列 3 上对项进行排序，其次在列 2 上进行排序。由于排序键的最大数量已经通过 setMaxSortKeys 被设置为 2，所以列 1 不再影响顺序。

排序键的最大数量由 toggleSortOrder 强制指定。可以通过直接调用 setSortKeys 指定更多的排序键，并且这些排序键都将被遵守。但是，如果之后调用了 toggleSortOrder，则将强制指定排序键的最大数量。默认值为 3。

参数：
max - 排序键的最大数量
抛出：
IllegalArgumentException - 如果 max < 1

getMaxSortKeys

public int getMaxSortKeys()
返回排序键的最大数量。

返回：
排序键的最大数量

setSortsOnUpdates

public void setSortsOnUpdates(boolean sortsOnUpdates)
如果为 true，则指定应该在底层模型更新（调用了 rowsUpdated）时进行排序。例如，如果为 true 并且用户编辑了一个条目，则该项在视图中的位置可能改变。默认值为 false。

参数：
sortsOnUpdates - 是否在发生更新事件时进行排序

getSortsOnUpdates

public boolean getSortsOnUpdates()
如果底层模型更新时应该进行排序，则返回 true；否则返回 false。

返回：
模型更新时是否进行排序

setRowFilter

public void setRowFilter(RowFilter<? super M,? super I> filter)
设置用于确定哪些行（如果有）应该在视图中隐藏的过滤器。过滤器在排序之前应用。null 值表示应该包括模型中的所有值。

将包装底层模型的 Entry 传递给 RowFilter 的 include 方法。Entry 的列数对应于 ModelWrapper 的列数。标识符也取自该 ModelWrapper。

此方法将触发排序。

参数：
filter - 用于确定应该包括哪些条目的过滤器

getRowFilter

public RowFilter<? super M,? super I> getRowFilter()
返回用于确定哪些行（如果有）应该在视图中隐藏的过滤器。

返回：
过滤器

toggleSortOrder

public void toggleSortOrder(int column)
如果指定列已经是主要排序列，则反转排序顺序（将升序变为降序，或将降序变为升序）；否则，使指定列成为主要排序列，并使用升序排序顺序。如果指定列不可排序，则此方法没有任何效果。

指定者：
类 RowSorter<M> 中的 toggleSortOrder
参数：
column - 要变为主要排序列的列索引，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果列超出底层模型的范围
另请参见：
setSortable(int,boolean), setMaxSortKeys(int)

convertRowIndexToView

public int convertRowIndexToView(int index)
返回基于视图 index 的位置。也就是说，对于底层模型坐标中的行 index，此方法返回基于视图的行索引。

指定者：
类 RowSorter<M> 中的 convertRowIndexToView
参数：
index - 基于底层模型的行索引
返回：
返回基于视图的行索引；如果索引已经被过滤出视图，则返回 -1
抛出：
IndexOutOfBoundsException - 如果 index 超出模型的范围

convertRowIndexToModel

public int convertRowIndexToModel(int index)
返回基于底层模型的 index 的位置。也就是说，对于视图坐标中的行 index，此方法返回基于底层模型的行索引。

指定者：
类 RowSorter<M> 中的 convertRowIndexToModel
参数：
index - 基于底层视图的行索引
返回：
基于视图的行索引
抛出：
IndexOutOfBoundsException - 如果 index 超出视图的范围

sort

public void sort()
根据当前正在排序的列的排序键以及与此排序器关联的过滤器（如果有）对视图中的行进行排序和过滤。空 sortKeys 列表表示视图应该未排序，与模型相同。

另请参见：
setRowFilter(javax.swing.RowFilter), setSortKeys(java.util.List)

useToString

protected boolean useToString(int column)
返回排序过程中进行比较之前是否要将值转换为字符串。如果为 true，则将使用 ModelWrapper.getStringValueAt；否则，将使用 ModelWrapper.getValueAt。由子类（比如 TableRowSorter）决定是否在其 ModelWrapper 实现中遵守此值。

参数：
column - 要测试的列的索引，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果 column 无效

setComparator

public void setComparator(int column,
                          Comparator<?> comparator)
设置对指定列进行排序时要使用的 Comparator。此方法不会触发排序。如果想要在设置比较器之后进行排序，则需要显式地调用 sort。

参数：
column - 要应用 Comparator 的列的索引，就底层模型而言
comparator - 要使用的 Comparator
抛出：
IndexOutOfBoundsException - 如果 column 超出底层模型的范围

getComparator

public Comparator<?> getComparator(int column)
返回指定列的 Comparator。如果没有为列指定 Comparator，则此方法将返回 null。

参数：
column - 要获取 Comparator 的列，就底层模型而言
返回：
指定列的 Comparator
抛出：
IndexOutOfBoundsException - 如果 column 超出底层模型的范围

getViewRowCount

public int getViewRowCount()
返回视图中的行数。如果该内容已被过滤，则此值可能不同于底层模型的行数。

指定者：
类 RowSorter<M> 中的 getViewRowCount
返回：
视图中的行数
另请参见：
RowSorter.getModelRowCount()

getModelRowCount

public int getModelRowCount()
返回底层模型中的行数。

指定者：
类 RowSorter<M> 中的 getModelRowCount
返回：
底层模型中的行数
另请参见：
RowSorter.getViewRowCount()

modelStructureChanged

public void modelStructureChanged()
当底层模型结构完全更改时，调用此方法。例如，如果 TableModel 中的列数发生了更改，则此方法将被调用。

通常不调用此方法。此方法是公共的，允许视图类调用它。

指定者：
类 RowSorter<M> 中的 modelStructureChanged

allRowsChanged

public void allRowsChanged()
当底层模型的内容完全更改时，调用此方法。表的结构相同，只有内容发生了更改。当对于其他方法来说标记此更改的代价太过昂贵时，通常使用此方法。

通常不调用此方法。此方法是公共的，允许视图类调用它。

指定者：
类 RowSorter<M> 中的 allRowsChanged

rowsInserted

public void rowsInserted(int firstRow,
                         int endRow)
当行已经插入到指定范围（包括）内的底层模型时，调用此方法。

参数指定有效范围的索引。第一个参数是基于更改之前的模型的，必须小于等于更改之前的模型的大小。第二个参数是基于更改之后的模型的，必须小于更改之后的模型的大小。例如，如果有一个 5 行的模型并在该模型的尾部添加 3 个项，则其索引为 5、7。

通常不调用此方法。此方法是公共的，允许视图类调用它。

指定者：
类 RowSorter<M> 中的 rowsInserted
参数：
firstRow - 第一行
endRow - 最后一行
抛出：
IndexOutOfBoundsException - 如果任一参数无效，或者 firstRow > endRow

rowsDeleted

public void rowsDeleted(int firstRow,
                        int endRow)
当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。

参数指定有效范围的索引，其基于更改之前的模型。例如，如果有一个 5 行的模型并从模型的尾部删除 3 个项，则其索引为 2、4。

通常不调用此方法。此方法是公共的，允许视图类调用它。

指定者：
类 RowSorter<M> 中的 rowsDeleted
参数：
firstRow - 第一行
endRow - 最后一行
抛出：
IndexOutOfBoundsException - 如果任一参数超出模型更改之前的范围，或者 firstRow > endRow

rowsUpdated

public void rowsUpdated(int firstRow,
                        int endRow)
当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。

通常不调用此方法。此方法是公共的，允许视图类调用它。

指定者：
类 RowSorter<M> 中的 rowsUpdated
参数：
firstRow - 第一行，就底层模型而言
endRow - 最后一行，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果任一参数超出模型更改之前的范围，或者 firstRow > endRow

rowsUpdated

public void rowsUpdated(int firstRow,
                        int endRow,
                        int column)
当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。

通常不调用此方法。此方法是公共的，允许视图类调用它。

指定者：
类 RowSorter<M> 中的 rowsUpdated
参数：
firstRow - 第一行，就底层模型而言
endRow - 最后一行，就底层模型而言
column - 已更改的列，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果任一参数超出底层模型更改之后的范围，firstRow > endRow 或者 column 超出底层模型的范围
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultRowSorter.ModelWrapper (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultRowSorter.ModelWrapper<M,I>

java.lang.Object
    继承者  javax.swing.DefaultRowSorter.ModelWrapper<M,I>
类型参数：
M - 底层模型的类型
I - 提供给过滤器的标识符
正在封闭类：
DefaultRowSorter<M,I>
protected abstract static class DefaultRowSorter.ModelWrapper<M,I>
extends Object

DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。通常不直接与 ModelWrapper 进行交互。DefaultRowSorter 的子类提供包装另一个模型的 ModelWrapper 实现。例如，TableRowSorter 提供包装 TableModel 的 ModelWrapper。

ModelWrapper 将值以 Object 和 String 形式加以区分。这允许实现提供要使用的自定义字符串转换器，而不是在对象上调用 toString。

从以下版本开始：
1.6
另请参见：
RowFilter, RowFilter.Entry

构造方法摘要
protected DefaultRowSorter.ModelWrapper()
创建一个新的 ModelWrapper。
方法摘要
abstract int | getColumnCount() 返回模型中的列数。
abstract I | getIdentifier(int row) 返回指定行的标识符。
abstract M | getModel() 返回此 Model 包装的底层模型。
abstract int | getRowCount() 返回模型中的行数。
String | getStringValueAt(int row, int column) 以 String 的形式返回指定索引处的值。
abstract Object | getValueAt(int row, int column) 返回指定索引处的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

DefaultRowSorter.ModelWrapper

protected DefaultRowSorter.ModelWrapper()
创建一个新的 ModelWrapper。

方法详细信息

getModel

public abstract M getModel()
返回此 Model 包装的底层模型。

返回：
底层模型

getColumnCount

public abstract int getColumnCount()
返回模型中的列数。

返回：
模型中的列数

getRowCount

public abstract int getRowCount()
返回模型中的行数。

返回：
模型中的行数

getValueAt

public abstract Object getValueAt(int row,
                                  int column)
返回指定索引处的值。

参数：
row - 行索引
column - 列索引
返回：
指定索引处的值
抛出：
IndexOutOfBoundsException - 如果索引超出模型的范围

getStringValueAt

public String getStringValueAt(int row,
                               int column)
以 String 的形式返回指定索引处的值。此实现在 getValueAt 的结果上使用 toString（确保对 null 值返回一个空字符串）。重写此方法的子类不应该返回 null。

参数：
row - 行索引
column - 列索引
返回：
指定索引处 String 形式的值
抛出：
IndexOutOfBoundsException - 如果索引超出模型的范围

getIdentifier

public abstract I getIdentifier(int row)
返回指定行的标识符。此方法的返回值用作传递给 RowFilter 的 RowFilter.Entry 的标识符。

参数：
row - 要为其返回标识符的行，就底层模型而言
返回：
标识符
另请参见：
RowFilter.Entry.getIdentifier()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultSingleSelectionModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 DefaultSingleSelectionModel

java.lang.Object
    继承者  javax.swing.DefaultSingleSelectionModel
所有已实现的接口：
Serializable, SingleSelectionModel
public class DefaultSingleSelectionModel
extends Object
implements SingleSelectionModel, Serializable

SingleSelectionModel 的一般实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected ChangeEvent | changeEvent
protected EventListenerList | listenerList 已注册侦听器的集合
构造方法摘要
DefaultSingleSelectionModel()
方法摘要
 void addChangeListener(ChangeListener l)
向按钮添加一个 ChangeListener。
 void clearSelection()
清除选项（返回 -1）。
protected  void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
 ChangeListener[] getChangeListeners()
返回此 DefaultSingleSelectionModel 上所有已注册的更改侦听器组成的数组。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。
 int getSelectedIndex()
返回模型的选项。
 boolean isSelected()
如果选项模型当前有一个选定的值，则返回 true。
 void removeChangeListener(ChangeListener l)
从按钮中移除一个 ChangeListener。
 void setSelectedIndex(int index)
将模型中选定的索引设置为 index。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

changeEvent

protected transient ChangeEvent changeEvent

listenerList

protected EventListenerList listenerList
已注册侦听器的集合

构造方法详细信息

DefaultSingleSelectionModel

public DefaultSingleSelectionModel()
方法详细信息

getSelectedIndex

public int getSelectedIndex()
从接口 SingleSelectionModel 复制的描述
返回模型的选项。

指定者：
接口 SingleSelectionModel 中的 getSelectedIndex
返回：
模型的选项，如果没有任何选项，则返回 -1
另请参见：
SingleSelectionModel.setSelectedIndex(int)

setSelectedIndex

public void setSelectedIndex(int index)
从接口 SingleSelectionModel 复制的描述
将模型中选定的索引设置为 index。如果模型更改则通知所有的侦听器。

指定者：
接口 SingleSelectionModel 中的 setSelectedIndex
参数：
index - 用于指定模型选项的整数
另请参见：
SingleSelectionModel.getSelectedIndex(), SingleSelectionModel.addChangeListener(javax.swing.event.ChangeListener)

clearSelection

public void clearSelection()
从接口 SingleSelectionModel 复制的描述
清除选项（返回 -1）。

指定者：
接口 SingleSelectionModel 中的 clearSelection

isSelected

public boolean isSelected()
从接口 SingleSelectionModel 复制的描述
如果选项模型当前有一个选定的值，则返回 true。

指定者：
接口 SingleSelectionModel 中的 isSelected
返回：
如果当前选定一个值，则返回 true

addChangeListener

public void addChangeListener(ChangeListener l)
向按钮添加一个 ChangeListener。

指定者：
接口 SingleSelectionModel 中的 addChangeListener
参数：
l - 要添加的 ChangeListener

removeChangeListener

public void removeChangeListener(ChangeListener l)
从按钮中移除一个 ChangeListener。

指定者：
接口 SingleSelectionModel 中的 removeChangeListener
参数：
l - 要移除的 ChangeListener

getChangeListeners

public ChangeListener[] getChangeListeners()
返回此 DefaultSingleSelectionModel 上所有已注册的更改侦听器组成的数组。

返回：
此模型的所有 ChangeListener，如果当前没有已注册的更改侦听器，则返回一个空数组。
从以下版本开始：
1.4
另请参见：
addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener)

fireStateChanged

protected void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前已在此模型上注册为 FooListener 的所有对象组成的数组。FooListener 是用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用下面的代码查询 DefaultSingleSelectionModel 实例 m 的更改侦听器：

ChangeListener[] cls = (ChangeListener[])(m.getListeners(ChangeListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求侦听器的类型；该参数应该指定一个从 java.util.EventListener 遗传下来的接口
返回：
在此模型上注册为 FooListener 的所有对象组成的数组，如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getChangeListeners()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DesktopManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 DesktopManager

所有已知实现类：
DefaultDesktopManager
public interface DesktopManager

DesktopManager 对象由 DesktopPane 对象所拥有。它们负责为 JDesktopPane 实现 L&F 特定行为。JInternalFrame 实现应该将特定行为委托给 DesktopManager。例如，如果 InternalFrame 请求图标化，则它应该试着：

    getDesktopPane().getDesktopManager().iconifyFrame(frame);
此委托允许每个 L&F 为特定于桌面的操作提供自定义行为。（例如，内部窗体图标的显示方法和位置。）

此类为各种 JInternalFrame 方法提供策略，不应该直接调用，而应该在 DesktopManager 中调用各种 JInternalFrame 方法。

另请参见：
JDesktopPane, JInternalFrame, JInternalFrame.JDesktopIcon

方法摘要
void | activateFrame(JInternalFrame f) 通常指示此窗体拥有焦点。
void | beginDraggingFrame(JComponent f) 通常在用户已经指示他们将开始拖动某个组件时调用此方法。
void | beginResizingFrame(JComponent f, int direction) 通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。
void | closeFrame(JInternalFrame f) 通常，此调用应该从其父窗体中移除窗体。
void | deactivateFrame(JInternalFrame f) 通常指示此窗体失去焦点。
void | deiconifyFrame(JInternalFrame f) 通常移除现有的任何图标表示形式，并将窗体恢复到其原始大小和位置。
void | dragFrame(JComponent f, int newX, int newY) 用户已经移动窗体。
void | endDraggingFrame(JComponent f) 此方法在拖动会话结束时发出信号。
void | endResizingFrame(JComponent f) 此方法在重新调整大小会话结束时发出信号。
void | iconifyFrame(JInternalFrame f) 通常从父窗体中移除此窗体，并添加一个图标表示形式。
void | maximizeFrame(JInternalFrame f) 通常，应该重新调整窗体的大小，使其满足其父窗体的限制。
void | minimizeFrame(JInternalFrame f) 通常，这指示应该将窗体恢复到调用 maximizeFrame() 前的大小和位置。
void | openFrame(JInternalFrame f) 如有可能，在适当的位置显示此窗体。
void | resizeFrame(JComponent f, int newX, int newY, int newWidth, int newHeight) 用户已经重新调整组件的大小。
void | setBoundsForFrame(JComponent f, int newX, int newY, int newWidth, int newHeight) 这是一个基本重塑方法。

方法详细信息

openFrame

void openFrame(JInternalFrame f)
如有可能，在适当的位置显示此窗体。通常不调用此方法，因为 JInternalFrame 的创建者会将该窗体添加到适当的父窗体中。

closeFrame

void closeFrame(JInternalFrame f)
通常，此调用应该从其父窗体中移除窗体。

maximizeFrame

void maximizeFrame(JInternalFrame f)
通常，应该重新调整窗体的大小，使其满足其父窗体的限制。

minimizeFrame

void minimizeFrame(JInternalFrame f)
通常，这指示应该将窗体恢复到调用 maximizeFrame() 前的大小和位置。

iconifyFrame

void iconifyFrame(JInternalFrame f)
通常从父窗体中移除此窗体，并添加一个图标表示形式。

deiconifyFrame

void deiconifyFrame(JInternalFrame f)
通常移除现有的任何图标表示形式，并将窗体恢复到其原始大小和位置。

activateFrame

void activateFrame(JInternalFrame f)
通常指示此窗体拥有焦点。此方法一般在已经将 JInternalFrame 的 IS_SELECTED_PROPERTY 设置为 true 后调用。

deactivateFrame

void deactivateFrame(JInternalFrame f)
通常指示此窗体失去焦点。此方法一般在已经将 JInternalFrame 的 IS_SELECTED_PROPERTY 设置为 false 后调用。

beginDraggingFrame

void beginDraggingFrame(JComponent f)
通常在用户已经指示他们将开始拖动某个组件时调用此方法。此方法应该在任何 dragFrame() 调用之前调用，以允许 DesktopManager 准备好所有的必需状态。通常 f 将是一个 JInternalFrame。

dragFrame

void dragFrame(JComponent f,
               int newX,
               int newY)
用户已经移动窗体。此方法将在调用 beginDraggingFrame() 之后调用。通常 f 将是一个 JInternalFrame。

endDraggingFrame

void endDraggingFrame(JComponent f)
此方法在拖动会话结束时发出信号。在这里可以移除由 DesktopManager 维护的任何状态。通常 f 将是一个 JInternalFrame。

beginResizingFrame

void beginResizingFrame(JComponent f,
                        int direction)
通常在用户已经指示他们将开始重新调整窗体的大小时调用此方法。此方法应该在任何 resizeFrame() 调用之前调用，以允许 DesktopManager 准备好所有的必需状态。通常 f 将是一个 JInternalFrame。

resizeFrame

void resizeFrame(JComponent f,
                 int newX,
                 int newY,
                 int newWidth,
                 int newHeight)
用户已经重新调整组件的大小。此方法将在调用 beginResizingFrame() 之后调用。通常 f 将是一个 JInternalFrame。

endResizingFrame

void endResizingFrame(JComponent f)
此方法在重新调整大小会话结束时发出信号。在这里可以移除由 DesktopManager 维护的任何状态。通常 f 将是一个 JInternalFrame。

setBoundsForFrame

void setBoundsForFrame(JComponent f,
                       int newX,
                       int newY,
                       int newWidth,
                       int newHeight)
这是一个基本重塑方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DropMode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing
枚举 DropMode

java.lang.Object
    继承者  java.lang.Enum<DropMode>
        继承者  javax.swing.DropMode
所有已实现的接口：
Serializable, Comparable<DropMode>
public enum DropMode
extends Enum<DropMode>

放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。

从以下版本开始：
1.6
另请参见：
JTable.setDropMode(javax.swing.DropMode),
JList.setDropMode(javax.swing.DropMode),
JTree.setDropMode(javax.swing.DropMode),
JTextComponent.setDropMode(javax.swing.DropMode)

枚举常量摘要
INSERT
应该根据要插入新数据的位置跟踪放置位置。
INSERT_COLS
应该根据要插入新列（以容纳要放置的数据）处的列索引来跟踪放置位置。
INSERT_ROWS
应该根据要插入新行（以容纳要放置的数据）处的行索引来跟踪放置位置。
ON
应该根据现有项的索引跟踪放置位置。
ON_OR_INSERT
此模式是 ON 和 INSERT 的组合，指定数据可以放置在现有项上或 INSERT 指定的插入位置中。
ON_OR_INSERT_COLS
此模式是 ON 和 INSERT_COLS 的组合，指定数据可以放置在现有项上或 INSERT_COLS 指定的插入列中。
ON_OR_INSERT_ROWS
此模式是 ON 和 INSERT_ROWS 的组合，指定数据可以放置在现有项上或 INSERT_ROWS 指定的插入行中。
USE_SELECTION
组件本身的内部选择机制（或插入符，对于文本组件而言）应该用于跟踪放置位置。
方法摘要
static DropMode | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static DropMode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

USE_SELECTION

public static final DropMode USE_SELECTION
组件本身的内部选择机制（或插入符，对于文本组件而言）应该用于跟踪放置位置。

ON

public static final DropMode ON
应该根据现有项的索引跟踪放置位置。对表格项、列表项和树项上的放置操作很有用。

INSERT

public static final DropMode INSERT
应该根据要插入新数据的位置跟踪放置位置。对于管理项列表的组件（例如，列表和树），放置位置应该指示要插入新数据的位置的索引。对于文本组件，该位置应该表示字符之间的位置。对于管理表格数据的组件（例如表格），放置位置应该指示在哪个位置插入新的行、列或者行与列，以容纳要放置的数据。

INSERT_ROWS

public static final DropMode INSERT_ROWS
应该根据要插入新行（以容纳要放置的数据）处的行索引来跟踪放置位置。此模式对管理表格数据的组件很有用。

INSERT_COLS

public static final DropMode INSERT_COLS
应该根据要插入新列（以容纳要放置的数据）处的列索引来跟踪放置位置。此模式对管理表格数据的组件很有用。

ON_OR_INSERT

public static final DropMode ON_OR_INSERT
此模式是 ON 和 INSERT 的组合，指定数据可以放置在现有项上或 INSERT 指定的插入位置中。

ON_OR_INSERT_ROWS

public static final DropMode ON_OR_INSERT_ROWS
此模式是 ON 和 INSERT_ROWS 的组合，指定数据可以放置在现有项上或 INSERT_ROWS 指定的插入行中。

ON_OR_INSERT_COLS

public static final DropMode ON_OR_INSERT_COLS
此模式是 ON 和 INSERT_COLS 的组合，指定数据可以放置在现有项上或 INSERT_COLS 指定的插入列中。

方法详细信息

values

public static final DropMode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(DropMode c : DropMode.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static DropMode valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


FocusManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 FocusManager

java.lang.Object
    继承者  java.awt.KeyboardFocusManager
        继承者  java.awt.DefaultKeyboardFocusManager
            继承者  javax.swing.FocusManager
所有已实现的接口：
KeyEventDispatcher, KeyEventPostProcessor
直接已知子类：
DefaultFocusManager
public abstract class FocusManager
extends DefaultKeyboardFocusManager

从 1.4 focus API 开始，此类已被废弃。虽然客户机代码可能仍然使用此类，但强烈建议开发人员使用 java.awt.KeyboardFocusManager 和 java.awt.DefaultKeyboardFocusManager 替代。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节和 Focus Specification。

另请参见：
Focus Specification

字段摘要
static String FOCUS_MANAGER_CLASS_PROPERTY
该字段已被废弃，不鼓励使用它，因为它的规范与 1.4 focus API 不兼容。
从类 java.awt.KeyboardFocusManager 继承的字段
BACKWARD_TRAVERSAL_KEYS, DOWN_CYCLE_TRAVERSAL_KEYS, FORWARD_TRAVERSAL_KEYS, UP_CYCLE_TRAVERSAL_KEYS
构造方法摘要
FocusManager()
方法摘要
static void disableSwingFocusManager()
已过时。 从 1.4 开始，由 KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy) 取代
static FocusManager getCurrentManager()
返回调用线程上下文的当前 KeyboardFocusManager 实例。
static boolean isFocusManagerEnabled()
已过时。 从 1.4 开始，由 KeyboardFocusManager.getDefaultFocusTraversalPolicy() 取代
static void setCurrentManager(FocusManager aFocusManager)
设置调用线程上下文的当前 KeyboardFocusManager 实例。
从类 java.awt.DefaultKeyboardFocusManager 继承的方法
dequeueKeyEvents, discardKeyEvents, dispatchEvent, dispatchKeyEvent, downFocusCycle, enqueueKeyEvents, focusNextComponent, focusPreviousComponent, postProcessKeyEvent, processKeyEvent, upFocusCycle
从类 java.awt.KeyboardFocusManager 继承的方法
addKeyEventDispatcher, addKeyEventPostProcessor, addPropertyChangeListener, addPropertyChangeListener, addVetoableChangeListener, addVetoableChangeListener, clearGlobalFocusOwner, downFocusCycle, firePropertyChange, fireVetoableChange, focusNextComponent, focusPreviousComponent, getActiveWindow, getCurrentFocusCycleRoot, getCurrentKeyboardFocusManager, getDefaultFocusTraversalKeys, getDefaultFocusTraversalPolicy, getFocusedWindow, getFocusOwner, getGlobalActiveWindow, getGlobalCurrentFocusCycleRoot, getGlobalFocusedWindow, getGlobalFocusOwner, getGlobalPermanentFocusOwner, getKeyEventDispatchers, getKeyEventPostProcessors, getPermanentFocusOwner, getPropertyChangeListeners, getPropertyChangeListeners, getVetoableChangeListeners, getVetoableChangeListeners, redispatchEvent, removeKeyEventDispatcher, removeKeyEventPostProcessor, removePropertyChangeListener, removePropertyChangeListener, removeVetoableChangeListener, removeVetoableChangeListener, setCurrentKeyboardFocusManager, setDefaultFocusTraversalKeys, setDefaultFocusTraversalPolicy, setGlobalActiveWindow, setGlobalCurrentFocusCycleRoot, setGlobalFocusedWindow, setGlobalFocusOwner, setGlobalPermanentFocusOwner, upFocusCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

FOCUS_MANAGER_CLASS_PROPERTY

public static final String FOCUS_MANAGER_CLASS_PROPERTY
该字段已被废弃，不鼓励使用它，因为它的规范与 1.4 focus API 不兼容。当前的 FocusManager 已经不再是 UI 的一个属性。客户端代码必须使用 KeyboardFocusManager.getCurrentKeyboardFocusManager() 来查询当前的 FocusManager。有关更多信息，请参阅 Focus Specification。

另请参见：
KeyboardFocusManager.getCurrentKeyboardFocusManager(), Focus Specification, 常量字段值
构造方法详细信息

FocusManager

public FocusManager()
方法详细信息

getCurrentManager

public static FocusManager getCurrentManager()
返回调用线程上下文的当前 KeyboardFocusManager 实例。

返回：
此线程上下文的 KeyboardFocusManager
另请参见：
setCurrentManager(javax.swing.FocusManager)

setCurrentManager

public static void setCurrentManager(FocusManager aFocusManager)
                              throws SecurityException
设置调用线程上下文的当前 KeyboardFocusManager 实例。如果指定了 null，则使用 DefaultKeyboardFocusManager 的新实例替换当前的 KeyboardFocusManager。

如果安装了 SecurityManager，则必须授予调用线程 AWTPermission "replaceKeyboardFocusManager" 权限才能替换当前的 KeyboardFocusManager。如果未授予该权限，则此方法将抛出 SecurityException，而当前的 KeyboardFocusManager 不会改变。

参数：
aFocusManager - 此线程上下文的新 KeyboardFocusManager
抛出：
SecurityException - 如果调用线程没有替换当前 KeyboardFocusManager 的权限
另请参见：
getCurrentManager(), DefaultKeyboardFocusManager

disableSwingFocusManager

@Deprecated
public static void disableSwingFocusManager()
已过时。 从 1.4 开始，由 KeyboardFocusManager.setDefaultFocusTraversalPolicy(FocusTraversalPolicy) 取代

将当前 KeyboardFocusManager 的默认 FocusTraversalPolicy 更改为 DefaultFocusTraversalPolicy。

另请参见：
DefaultFocusTraversalPolicy, KeyboardFocusManager.setDefaultFocusTraversalPolicy(java.awt.FocusTraversalPolicy)

isFocusManagerEnabled

@Deprecated
public static boolean isFocusManagerEnabled()
已过时。 从 1.4 开始，由 KeyboardFocusManager.getDefaultFocusTraversalPolicy() 取代

返回应用程序是否已调用 disableSwingFocusManager()。

另请参见：
disableSwingFocusManager()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GrayFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 GrayFilter

java.lang.Object
    继承者  java.awt.image.ImageFilter
        继承者  java.awt.image.RGBImageFilter
            继承者  javax.swing.GrayFilter
所有已实现的接口：
ImageConsumer, Cloneable
public class GrayFilter
extends RGBImageFilter

一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。按钮可使用该过滤器为禁用的按钮创建一个图像。

字段摘要
从类 java.awt.image.RGBImageFilter 继承的字段
canFilterIndexColorModel, newmodel, origmodel
从类 java.awt.image.ImageFilter 继承的字段
consumer
从接口 java.awt.image.ImageConsumer 继承的字段
COMPLETESCANLINES, IMAGEABORTED, IMAGEERROR, RANDOMPIXELORDER, SINGLEFRAME, SINGLEFRAMEDONE, SINGLEPASS, STATICIMAGEDONE, TOPDOWNLEFTRIGHT
构造方法摘要
GrayFilter(boolean b, int p)
构造一个 GrayFilter 对象，该对象将彩色图像过滤成灰度级图像。
方法摘要
static Image | createDisabledImage(Image i) 创建一个禁用图像
int | filterRGB(int x, int y, int rgb) 重写 RGBImageFilter.filterRGB。
从类 java.awt.image.RGBImageFilter 继承的方法
filterIndexColorModel, filterRGBPixels, setColorModel, setPixels, setPixels, substituteColorModel
从类 java.awt.image.ImageFilter 继承的方法
clone, getFilterInstance, imageComplete, resendTopDownLeftRight, setDimensions, setHints, setProperties
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

GrayFilter

public GrayFilter(boolean b,
                  int p)
构造一个 GrayFilter 对象，该对象将彩色图像过滤成灰度级图像。按钮用该对象来创建禁用 ("grayed out") 按钮图标。

参数：
b - 一个 boolean 值，如果应该增亮像素，则该参数为 true
p - 一个在 0 到 100 范围内的 int 值，用于确定灰色的百分比，其中 100 表示最深的灰色，0 表示最浅的灰色
方法详细信息

createDisabledImage

public static Image createDisabledImage(Image i)
创建一个禁用图像

filterRGB

public int filterRGB(int x,
                     int y,
                     int rgb)
重写 RGBImageFilter.filterRGB。

指定者：
类 RGBImageFilter 中的 filterRGB
参数：
x - 像素的 X 坐标
y - 像素的 Y 坐标
rgb - 使用默认 RGB 颜色模型的整数像素表示
返回：
使用默认 RGB 颜色模型的过滤后的像素。
另请参见：
ColorModel.getRGBdefault(), RGBImageFilter.filterRGBPixels(int, int, int, int, int[], int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 GroupLayout

java.lang.Object
    继承者  javax.swing.GroupLayout
所有已实现的接口：
LayoutManager, LayoutManager2
public class GroupLayout
extends Object
implements LayoutManager2

GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。GroupLayout 主要供生成器使用，但也可以手工编码。分组由 Group 类的实例来完成。GroupLayout 支持两种组。串行组 (sequential group) 按顺序一个接一个地放置其子元素。并行组 (parallel group) 能够以四种方式对齐其子元素。

每个组可以包含任意数量的元素，其中元素有 Group、Component 或间隙 (gap)。间隙可被视为一个具有最小大小、首选大小和最大大小的不可见组件。此外，GroupLayout 还支持其值取自 LayoutStyle 的首选间隙。

元素类似于一个弹簧。每个元素都有一个范围，由最小大小、首选大小和最大大小指定。间隙的范围由开发人员指定，或者由 LayoutStyle 确定。Component 的范围通过 Component 的 getMinimumSize、getPreferredSize 和 getMaximumSize 方法确定。此外，添加 Component 时，可以指定使用一个特定范围，而不使用该组件的范围。Group 的范围由组的类型确定。ParallelGroup 的范围是其元素范围的最大值。SequentialGroup 的范围是其元素范围的总和。

GroupLayout 将每个轴 (axis) 单独对待。也就是说，存在一个表示水平轴的组和一个表示垂直轴的组。水平组负责确定沿水平轴的最小大小、首选大小和最大大小，并设置所包含组件的 x 和宽度。垂直组负责确定沿垂直轴的最小大小、首选大小和最大大小，并设置所包含组件的 y 和高度。每个 Component 都必须同时存在于水平组和垂直组中，否则，在布局过程中或者在请求最小大小、首选大小或最大大小时，将抛出 IllegalStateException。

下图显示了一个沿水平轴的串行组。该串行组包含三个组件。沿垂直轴使用了一个并行组。

为了强调要单独对待每个轴，该图显示了沿每个轴的每个组和元素的范围。每个组件的范围已被投射到轴上，两个组分别呈现为蓝色（水平）和红色（垂直）。为了便于理解，串行组中的每个元素之间都有一个间隙。

沿水平轴的串行组呈现为蓝色实线。注意，串行组是它所包含的子元素的总和。

沿垂直轴，并行组是每个组件高度的最大值。由于三个组件的高度都相同，所以并行组具有相同的高度。

下图显示了与上图中相同的三个组件，但并行组沿水平轴，串行组沿垂直轴。

由于 c1 在三个组件中最大，所以并行组的大小被确定为 c1。由于 c2 和 c3 小于 c1，所以将根据为组件指定的对齐方式（如果已指定）或并行组的默认对齐方式将它们对齐。在该图中，c2 和 c3 是使用 LEADING 的对齐方式创建的。如果组件的方向是从右到左，那么 c2 和 c3 的位置将在相反的一侧对齐（沿右侧对齐）。

下图显示了沿水平和垂直两个轴的串行组。

GroupLayout 提供在 Component 之间插入间隙的能力。间隙的大小由 LayoutStyle 的实例确定。可以使用 setAutoCreateGaps 方法进行此操作。类似地，可以使用 setAutoCreateContainerGaps 方法在触到父容器边缘的组件和容器之间插入间隙。

以下代码构建了一个面板，该面板由两列构成，第一列中有两个标签，第二列中有两个文本字段：

JComponent panel = ...;
GroupLayout layout = new GroupLayout(panel);
panel.setLayout(layout);

// Turn on automatically adding gaps between components
layout.setAutoCreateGaps(true);

// Turn on automatically creating gaps between components that touch
// the edge of the container and the container.
layout.setAutoCreateContainerGaps(true);

// Create a sequential group for the horizontal axis.

GroupLayout.SequentialGroup hGroup = layout.createSequentialGroup();

// The sequential group in turn contains two parallel groups.
// One parallel group contains the labels, the other the text fields.
// Putting the labels in a parallel group along the horizontal axis
// positions them at the same x location.
   //
// Variable indentation is used to reinforce the level of grouping.
hGroup.addGroup(layout.createParallelGroup().
addComponent(label1).addComponent(label2));
hGroup.addGroup(layout.createParallelGroup().
addComponent(tf1).addComponent(tf2));
layout.setHorizontalGroup(hGroup);

// Create a sequential group for the vertical axis.
GroupLayout.SequentialGroup vGroup = layout.createSequentialGroup();

// The sequential group contains two parallel groups that align
// the contents along the baseline.The first parallel group contains
// the first label and text field, and the second parallel group contains
// the second label and text field.By using a sequential group
// the labels and text fields are positioned vertically after one another.
vGroup.addGroup(layout.createParallelGroup(Alignment.BASELINE).
addComponent(label1).addComponent(tf1));
vGroup.addGroup(layout.createParallelGroup(Alignment.BASELINE).
addComponent(label2).addComponent(tf2));
layout.setVerticalGroup(vGroup);

运行代码时，将出现下面的窗口。

此布局由以下部分组成。

  • 水平轴由一个包含两个并行组的串行组组成。第一个并行组包含标签，第二个并行组包含文本字段。
  • 垂直轴由一个包含两个并行组的串行组组成。并行组被配置为沿基线对齐其组件。第一个并行组包含第一个标签和第一个文本字段，第二个并行组包含第二个标签和第二个文本字段。
在这段代码中，要注意几个问题：
  • 不需要显式地将组件添加到容器；通过使用 Group 的一个 add 方法间接完成此操作。
  • 各种 add 方法返回调用者。这使得调用能很方便地进行链接。例如，group.addComponent(label1).addComponent(label2); 等效于 group.addComponent(label1); group.addComponent(label2);。
  • Group 没有公共构造方法；请使用 GroupLayout 的创建方法替代。

从以下版本开始：
1.6

嵌套类摘要
static class | GroupLayout.Alignment ParallelGroup 能够对齐其子元素的可能方式的枚举。
class | GroupLayout.Group Group 为 GroupLayout 所支持的以下两种操作提供基础：一个接一个地布置组件（SequentialGroup）或对齐组件（ParallelGroup）。
class | GroupLayout.ParallelGroup 一个 Group，它对齐其子元素并确定其大小。
class | GroupLayout.SequentialGroup 一个 Group，它按顺序一个接一个地确定其元素的位置和大小。
字段摘要
static int | DEFAULT_SIZE 指示组件或间隙的大小应该用于特定的范围值。
static int | PREFERRED_SIZE 指示组件或间隙的首选大小应该用于特定的范围值。
构造方法摘要
GroupLayout(Container host)
为指定的 Container 创建 GroupLayout。
方法摘要
void | addLayoutComponent(Component component, Object constraints) 已将 Component 添加到父容器的通知。
void | addLayoutComponent(String name, Component component) 已将 Component 添加到父容器的通知。
GroupLayout.ParallelGroup | createBaselineGroup(boolean resizable, boolean anchorBaselineToTop) 创建并返回一个沿基线对齐其元素的 ParallelGroup。
GroupLayout.ParallelGroup | createParallelGroup() 使用 Alignment.LEADING 的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | createParallelGroup(GroupLayout.Alignment alignment) 使用指定的对齐方式创建并返回一个 ParallelGroup。
GroupLayout.ParallelGroup | createParallelGroup(GroupLayout.Alignment alignment, boolean resizable) 使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。
GroupLayout.SequentialGroup | createSequentialGroup() 创建并返回一个 SequentialGroup。
boolean | getAutoCreateContainerGaps() 如果自动创建容器与触到容器边框的组件之间的间隙，则返回 true。
boolean | getAutoCreateGaps() 如果自动创建组件之间的间隙，则返回 true。
boolean | getHonorsVisibility() 返回确定组件的大小和位置时是否要考虑组件的可见性。
float | getLayoutAlignmentX(Container parent) 返回沿 x 轴的对齐方式。
float | getLayoutAlignmentY(Container parent) 返回沿 y 轴的对齐方式。
LayoutStyle | getLayoutStyle() 返回 LayoutStyle，用于计算组件之间的首选间隙。
void | invalidateLayout(Container parent) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | layoutContainer(Container parent) 布置指定的容器。
void | linkSize(Component... components) 将指定组件强制调整为具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
void | linkSize(int axis, Component... components) 将指定组件强制调整为沿指定轴具有相同的大小，而不管其首选大小、最小大小或最大大小如何。
Dimension | maximumLayoutSize(Container parent) 返回指定容器的最大大小。
Dimension | minimumLayoutSize(Container parent) 返回指定容器的最小大小。
Dimension | preferredLayoutSize(Container parent) 返回指定容器的首选大小。
void | removeLayoutComponent(Component component) 已从父容器中移除 Component 的通知。
void | replace(Component existingComponent, Component newComponent) 使用新的组件替代现有组件。
void | setAutoCreateContainerGaps(boolean autoCreateContainerPadding) 设置是否应该自动创建容器与触到容器边框的组件之间的间隙。
void | setAutoCreateGaps(boolean autoCreatePadding) 设置是否将自动创建组件之间的间隙。
void | setHonorsVisibility(boolean honorsVisibility) 设置确定组件的大小和位置时是否要考虑组件的可见性。
void | setHonorsVisibility(Component component, Boolean honorsVisibility) 设置确定组件的大小和位置时是否要考虑组件的可见性。
void | setHorizontalGroup(GroupLayout.Group group) 设置沿水平轴确定组件位置和大小的 Group。
void | setLayoutStyle(LayoutStyle layoutStyle) 设置用于计算组件之间首选间隙的 LayoutStyle。
void | setVerticalGroup(GroupLayout.Group group) 设置沿垂直轴确定组件位置和大小的 Group。
String | toString() 返回此 GroupLayout 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_SIZE

public static final int DEFAULT_SIZE
指示组件或间隙的大小应该用于特定的范围值。

另请参见：
GroupLayout.Group, 常量字段值

PREFERRED_SIZE

public static final int PREFERRED_SIZE
指示组件或间隙的首选大小应该用于特定的范围值。

另请参见：
GroupLayout.Group, 常量字段值
构造方法详细信息

GroupLayout

public GroupLayout(Container host)
为指定的 Container 创建 GroupLayout。

参数：
host - Container，创建的 GroupLayout 将作为其 LayoutManager
抛出：
IllegalArgumentException - 如果 host 为 null
方法详细信息

setHonorsVisibility

public void setHonorsVisibility(boolean honorsVisibility)
设置确定组件的大小和位置时是否要考虑组件的可见性。true 值指示非可见组件不应该被视为布局的一部分。false 值指示组件应该被确定位置和大小，而不管其可见性如何。

当组件的可见性是动态调整的并且不想更改周围的组件及其大小时，false 值很有用。

指定的值用于没有指定明确可见性的组件。

默认值为 true。

参数：
honorsVisibility - 确定组件的大小和位置时是否要考虑组件的可见性
另请参见：
setHonorsVisibility(Component,Boolean)

getHonorsVisibility

public boolean getHonorsVisibility()
返回确定组件的大小和位置时是否要考虑组件的可见性。

返回：
确定组件的大小和位置时是否要考虑组件的可见性

setHonorsVisibility

public void setHonorsVisibility(Component component,
                                Boolean honorsVisibility)
设置确定组件的大小和位置时是否要考虑组件的可见性。Boolean.TRUE 值指示如果 component 不可见，则它不应该被视为布局的一部分。false 值指示 component 应该被确定位置和大小，而不管其可见性如何。null 值指示应该使用由单参数方法 setHonorsVisibility 指定的值。

如果 component 不是此 GroupLayout 管理的 Container 的子组件，则它将被添加到 Container。

参数：
component - 组件
honorsVisibility - 确定大小和位置时是否要考虑 component 的可见性
抛出：
IllegalArgumentException - 如果 component 为 null
另请参见：
setHonorsVisibility(Component,Boolean)

setAutoCreateGaps

public void setAutoCreateGaps(boolean autoCreatePadding)
设置是否将自动创建组件之间的间隙。例如，如果设为 true 并且向 SequentialGroup 添加了两个组件，则将自动创建这两个组件之间的间隙。默认值为 false。

参数：
autoCreatePadding - 是否自动创建组件之间的间隙

getAutoCreateGaps

public boolean getAutoCreateGaps()
如果自动创建组件之间的间隙，则返回 true。

返回：
如果自动创建组件之间的间隙，则返回 true

setAutoCreateContainerGaps

public void setAutoCreateContainerGaps(boolean autoCreateContainerPadding)
设置是否应该自动创建容器与触到容器边框的组件之间的间隙。默认值为 false。

参数：
autoCreateContainerPadding - 是否应该自动创建容器与触到容器边框的组件之间的间隙

getAutoCreateContainerGaps

public boolean getAutoCreateContainerGaps()
如果自动创建容器与触到容器边框的组件之间的间隙，则返回 true。

返回：
如果自动创建容器与触到容器边框的组件之间的间隙，则返回 true

setHorizontalGroup

public void setHorizontalGroup(GroupLayout.Group group)
设置沿水平轴确定组件位置和大小的 Group。

参数：
group - 沿水平轴确定组件位置和大小的 Group
抛出：
IllegalArgumentException - 如果 group 为 null

setVerticalGroup

public void setVerticalGroup(GroupLayout.Group group)
设置沿垂直轴确定组件位置和大小的 Group。

参数：
group - 沿垂直轴确定组件位置和大小的 Group
抛出：
IllegalArgumentException - 如果 group 为 null

createSequentialGroup

public GroupLayout.SequentialGroup createSequentialGroup()
创建并返回一个 SequentialGroup。

返回：
一个新的 SequentialGroup

createParallelGroup

public GroupLayout.ParallelGroup createParallelGroup()
使用 Alignment.LEADING 的对齐方式创建并返回一个 ParallelGroup。此方法是更常用的 createParallelGroup(Alignment) 方法的覆盖方法。

返回：
一个新的 ParallelGroup
另请参见：
createParallelGroup(Alignment)

createParallelGroup

public GroupLayout.ParallelGroup createParallelGroup(GroupLayout.Alignment alignment)
使用指定的对齐方式创建并返回一个 ParallelGroup。此方法是更常用的 createParallelGroup(Alignment,boolean) 方法（其中第二个参数为 true）的覆盖方法。

参数：
alignment - 组元素的对齐方式
返回：
一个新的 ParallelGroup
抛出：
IllegalArgumentException - 如果 alignment 为 null
另请参见：
createBaselineGroup(boolean, boolean), GroupLayout.ParallelGroup

createParallelGroup

public GroupLayout.ParallelGroup createParallelGroup(GroupLayout.Alignment alignment,
                                                     boolean resizable)
使用指定的对齐方式和调整大小行为创建并返回一个 ParallelGroup。alignment 参数指定如何确定没有将组填满的子元素的位置。例如，如果对齐方式为 TRAILING 的 ParallelGroup 被给定为 100，而一个子元素只需要 50，则将该子元素放置在位置 50（组件方向从左到右）。

只有在沿垂直轴使用时基线对齐方式才有用。使用沿水平轴的基线对齐方式创建的 ParallelGroup 被视为 LEADING。

有关基线组行为的详细信息，请参阅 ParallelGroup。

参数：
alignment - 组元素的对齐方式
resizable - 如果组是可调整大小的，则返回 true；如果组是不可调整大小的，则首选大小用于组的最小大小和最大大小。
返回：
一个新的 ParallelGroup
抛出：
IllegalArgumentException - 如果 alignment 为 null
另请参见：
createBaselineGroup(boolean, boolean), GroupLayout.ParallelGroup

createBaselineGroup

public GroupLayout.ParallelGroup createBaselineGroup(boolean resizable,
                                                     boolean anchorBaselineToTop)
创建并返回一个沿基线对齐其元素的 ParallelGroup。

参数：
resizable - 组是否是可调整大小的
anchorBaselineToTop - 基线是固定在组的顶部还是底部
另请参见：
createBaselineGroup(boolean, boolean), GroupLayout.ParallelGroup

linkSize

public void linkSize(Component... components)
将指定组件强制调整为具有相同的大小，而不管其首选大小、最小大小或最大大小如何。将所有链接组件首选大小中的最大值赋予链接的组件。例如，如果将首选宽度分别为 10 和 20 的两个组件链接起来，则两个组件的宽度都将变为 20。

可以多次使用此方法来将任意数量的组件强制调整为具有相同的大小。

链接的 Component 是不可调整大小的。

参数：
components - 要具有相同大小的 Component
抛出：
IllegalArgumentException - 如果 components 为 null 或包含 null
另请参见：
linkSize(int,Component[])

linkSize

public void linkSize(int axis,
                     Component... components)
将指定组件强制调整为沿指定轴具有相同的大小，而不管其首选大小、最小大小或最大大小如何。将所有链接组件首选大小中的最大值赋予链接的组件。例如，如果沿水平轴将首选宽度分别为 10 和 20 的两个组件链接起来，则两个组件的宽度都将变为 20。

可以多次使用此方法来将任意数量的组件强制调整为具有相同的大小。

链接的 Component 是不可调整大小的。

参数：
components - 要具有相同大小的 Component
axis - 沿其链接大小的轴；SwingConstants.HORIZONTAL 或 SwingConstans.VERTICAL 之一
抛出：
IllegalArgumentException - 如果 components 为 null 或包含 null；或者 axis 不是 SwingConstants.HORIZONTAL 或 SwingConstants.VERTICAL

replace

public void replace(Component existingComponent,
                    Component newComponent)
使用新的组件替代现有组件。

参数：
existingComponent - 应该被移除并用 newComponent 来替代的组件
newComponent - 要放入 existingComponent 的位置的组件
抛出：
IllegalArgumentException - 如果任一组件为 null 或者 existingComponent 不受此布局管理器管理

setLayoutStyle

public void setLayoutStyle(LayoutStyle layoutStyle)
设置用于计算组件之间首选间隙的 LayoutStyle。null 值指示应该使用 LayoutStyle 的共享实例。

参数：
layoutStyle - 要使用的 LayoutStyle
另请参见：
LayoutStyle

getLayoutStyle

public LayoutStyle getLayoutStyle()
返回 LayoutStyle，用于计算组件之间的首选间隙。此方法返回指定给 setLayoutStyle 的值，可以为 null。

返回：
用于计算组件之间首选间隙的 LayoutStyle

addLayoutComponent

public void addLayoutComponent(String name,
                               Component component)
已将 Component 添加到父容器的通知。不应该直接调用此方法，而应该使用一个 Group 方法来添加 Component。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
component - 要添加的 Component

removeLayoutComponent

public void removeLayoutComponent(Component component)
已从父容器中移除 Component 的通知。不应该直接调用此方法，而应该调用父 Container 上的 remove。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
component - 要移除的组件
另请参见：
Component.remove(java.awt.MenuComponent)

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
返回指定容器的首选大小。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 要返回其首选大小的容器
返回：
parent 的首选大小
抛出：
IllegalArgumentException - 如果 parent 不是创建此 GroupLayout 的相同 Container
IllegalStateException - 如果添加到此布局的任意组件不同时位于水平组和垂直组中
另请参见：
Container.getPreferredSize()

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
返回指定容器的最小大小。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 要返回其大小的容器
返回：
parent 的最小大小
抛出：
IllegalArgumentException - 如果 parent 不是创建此 GroupLayout 的相同 Container
IllegalStateException - 如果添加到此布局的任意组件不同时位于水平组和垂直组中
另请参见：
Container.getMinimumSize()

layoutContainer

public void layoutContainer(Container parent)
布置指定的容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要布置的容器
抛出：
IllegalStateException - 如果添加到此布局的任意组件不同时位于水平组和垂直组中

addLayoutComponent

public void addLayoutComponent(Component component,
                               Object constraints)
已将 Component 添加到父容器的通知。不应该直接调用此方法，而应该使用一个 Group 方法来添加 Component。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
component - 要添加的组件
constraints - 组件放置位置的描述

maximumLayoutSize

public Dimension maximumLayoutSize(Container parent)
返回指定容器的最大大小。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
参数：
parent - 要返回其大小的容器
返回：
parent 的最大大小
抛出：
IllegalArgumentException - 如果 parent 不是创建此 GroupLayout 的相同 Container
IllegalStateException - 如果添加到此布局的任意组件不同时位于水平组和垂直组中
另请参见：
Container.getMaximumSize()

getLayoutAlignmentX

public float getLayoutAlignmentX(Container parent)
返回沿 x 轴的对齐方式。此方法指出如何相对于其他组件对齐该组件。该值应该是 0 到 1 之间的一个数，其中 0 表示沿原点对齐，1 表示在距原点最远的地方对齐，0.5 表示居中等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX
参数：
parent - 应用此 LayoutManager 的 Container
返回：
对齐方式；此实现返回 0.5
抛出：
IllegalArgumentException - 如果 parent 不是创建此 GroupLayout 的相同 Container

getLayoutAlignmentY

public float getLayoutAlignmentY(Container parent)
返回沿 y 轴的对齐方式。此方法指出如何相对于其他组件对齐该组件。该值应该是 0 到 1 之间的一个数，其中 0 表示沿原点对齐，1 表示在距原点最远的地方对齐，0.5 表示居中等等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY
参数：
parent - 应用此 LayoutManager 的 Container
返回：
对齐方式；此实现返回 0.5
抛出：
IllegalArgumentException - 如果 parent 不是创建此 GroupLayout 的相同 Container

invalidateLayout

public void invalidateLayout(Container parent)
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。

指定者：
接口 LayoutManager2 中的 invalidateLayout
参数：
parent - 应用此 LayoutManager 的 Container
抛出：
IllegalArgumentException - 如果 parent 不是创建此 GroupLayout 的相同 Container

toString

public String toString()
返回此 GroupLayout 的字符串表示形式。此方法仅用于调试，对于各个实现，所返回字符串的内容和格式可能有所不同。

覆盖：
类 Object 中的 toString
返回：
此 GroupLayout 的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Icon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 Icon

所有已知实现类：
IconUIResource, ImageIcon, MetalCheckBoxIcon, MetalComboBoxIcon, MetalIconFactory.FileIcon16, MetalIconFactory.FolderIcon16, MetalIconFactory.PaletteCloseIcon, MetalIconFactory.TreeControlIcon, MetalIconFactory.TreeFolderIcon, MetalIconFactory.TreeLeafIcon
public interface Icon

一个小的固定大小图片，通常用于装饰组件。

另请参见：
ImageIcon

方法摘要
int | getIconHeight() 返回图标的高度。
int | getIconWidth() 返回图标的宽度。
void | paintIcon(Component c, Graphics g, int x, int y) 在指定位置上绘制图标。

方法详细信息

paintIcon

void paintIcon(Component c,
               Graphics g,
               int x,
               int y)
在指定位置上绘制图标。图标实现可以使用 Component 参数来获得对绘制有用的属性，例如前景色和背景色。

getIconWidth

int getIconWidth()
返回图标的宽度。

返回：
一个指定图标的固定宽度的 int 值。

getIconHeight

int getIconHeight()
返回图标的高度。

返回：
一个指定图标的固定高度的 int 值。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupLayout.Alignment (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing
枚举 GroupLayout.Alignment

java.lang.Object
    继承者  java.lang.Enum<GroupLayout.Alignment>
        继承者  javax.swing.GroupLayout.Alignment
所有已实现的接口：
Serializable, Comparable<GroupLayout.Alignment>
正在封闭类：
GroupLayout
public static enum GroupLayout.Alignment
extends Enum<GroupLayout.Alignment>

ParallelGroup 能够对齐其子元素的可能方式的枚举。

从以下版本开始：
1.6
另请参见：
GroupLayout.createParallelGroup(Alignment)

枚举常量摘要
BASELINE
指示元素应该沿其基线对齐。
CENTER
指示元素应该在区域内居中。
LEADING
指示元素应该向原点对齐。
TRAILING
指示元素应该向区域底端对齐。
方法摘要
static GroupLayout.Alignment | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static GroupLayout.Alignment[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

LEADING

public static final GroupLayout.Alignment LEADING
指示元素应该向原点对齐。对于从左到右的水平轴，这表示向左端对齐。对于垂直轴，LEADING 表示向顶端对齐。

另请参见：
GroupLayout.createParallelGroup(Alignment)

TRAILING

public static final GroupLayout.Alignment TRAILING
指示元素应该向区域底端对齐。对于从左到右的水平轴，这表示向右端对齐。对于垂直轴，TRAILING 表示向底端对齐。

另请参见：
GroupLayout.createParallelGroup(Alignment)

CENTER

public static final GroupLayout.Alignment CENTER
指示元素应该在区域内居中。

另请参见：
GroupLayout.createParallelGroup(Alignment)

BASELINE

public static final GroupLayout.Alignment BASELINE
指示元素应该沿其基线对齐。

另请参见：
GroupLayout.createParallelGroup(Alignment), GroupLayout.createBaselineGroup(boolean,boolean)
方法详细信息

values

public static final GroupLayout.Alignment[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(GroupLayout.Alignment c : GroupLayout.Alignment.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static GroupLayout.Alignment valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


GroupLayout.Group (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 GroupLayout.Group

java.lang.Object
    继承者  javax.swing.GroupLayout.Group
直接已知子类：
GroupLayout.ParallelGroup, GroupLayout.SequentialGroup
正在封闭类：
GroupLayout
public abstract class GroupLayout.Group
extends Object

Group 为 GroupLayout 所支持的以下两种操作提供基础：一个接一个地布置组件（SequentialGroup）或对齐组件（ParallelGroup）。Group 及其子类没有公共的构造方法；要创建一个 Group，请使用 createSequentialGroup 或 createParallelGroup。此外，将从某个 GroupLayout 创建的 Group 与另一个 GroupLayout 一起使用将产生不确定的结果。

Group 及其子类中的各种方法允许显式地指定范围。这些方法的参数可以有两种形式：一个大于等于 0 的值，或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一。大于等于 0 的值指示一个特定大小。DEFAULT_SIZE 指示应该使用取自组件的相应大小。例如，如果 DEFAULT_SIZE 作为最小大小参数传递，则最小大小是在组件上调用 getMinimumSize 获得的。同样，PREFERRED_SIZE 指示应该使用 getPreferredSize 返回的值。下面的例子将 myComponent 添加到 group，并带有特定的范围值。也就是说，最小值被显式地指定为 100，首选值为 200，最大值为 300。

group.addComponent(myComponent, 100, 200, 300);
下面的例子将 myComponent 添加到 group，并使用了各种形式的组合。强制使最小大小与首选大小相同，首选大小通过使用 myComponent.getPreferredSize 确定，最大大小通过对组件调用 getMaximumSize 确定。
group.addComponent(myComponent, GroupLayout.PREFERRED_SIZE,
GroupLayout.PREFERRED_SIZE, GroupLayout.DEFAULT_SIZE);

除非另行指定，否则只要传递了无效的范围，Group 及其子类的所有允许指定范围的方法都将抛出 IllegalArgumentException。无效范围是指，此范围内的任何值都小于 0 且不是 PREFERRED_SIZE 或 DEFAULT_SIZE 之一，或是不满足以下条件的范围（对于特定值）：min <= pref <= max。

类似地，如果传递了 null，那么带有 Component 的所有方法都将抛出 NullPointerException，带有 Group 的所有方法都将抛出 IllegalArgumentException。

从以下版本开始：
1.6
另请参见：
GroupLayout.createSequentialGroup(), GroupLayout.createParallelGroup()

方法摘要
GroupLayout.Group | addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.Group | addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.Group | addGap(int size) 将固定间隙添加到此 Group。
GroupLayout.Group | addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.Group | addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

addGroup

public GroupLayout.Group addGroup(GroupLayout.Group group)
将 Group 添加到此 Group。

参数：
group - 要添加的 Group
返回：
此 Group

addComponent

public GroupLayout.Group addComponent(Component component)
将 Component 添加到此 Group。

参数：
component - 要添加的 Component
返回：
此 Group

addComponent

public GroupLayout.Group addComponent(Component component,
                                      int min,
                                      int pref,
                                      int max)
使用指定大小将 Component 添加到此 Group。

参数：
component - 要添加的 Component
min - 最小大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
pref - 首选大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
max - 最大大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
返回：
此 Group

addGap

public GroupLayout.Group addGap(int size)
将固定间隙添加到此 Group。

参数：
size - 间隙的大小
返回：
此 Group
抛出：
IllegalArgumentException - 如果 size 小于 0

addGap

public GroupLayout.Group addGap(int min,
                                int pref,
                                int max)
将指定大小的间隙添加到此 Group。

参数：
min - 间隙的最小大小
pref - 间隙的首选大小
max - 间隙的最大大小
返回：
此 Group
抛出：
IllegalArgumentException - 如果任一值小于 0
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupLayout.ParallelGroup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 GroupLayout.ParallelGroup

java.lang.Object
    继承者  javax.swing.GroupLayout.Group
        继承者  javax.swing.GroupLayout.ParallelGroup
正在封闭类：
GroupLayout
public class GroupLayout.ParallelGroup
extends GroupLayout.Group

一个 Group，它对齐其子元素并确定其大小。ParallelGroup 以四种可能的方式对齐其子元素：沿基线、居中、固定在前端、固定在尾端。

基线

使其子元素沿基线对齐的 ParallelGroup 必须首先确定基线固定的位置。基线可以固定在组的顶部或底部。也就是说，基线和组开始位置之间的距离可以是一个恒定距离，或者组结束位置和基线之间的距离可以是一个恒定距离。可能的选择对应于 BaselineResizeBehavior 常量 CONSTANT_ASCENT 和 CONSTANT_DESCENT。

基线锚点 (anchor) 可以由 createBaselineGroup 方法显式地指定，也可以根据元素来确定。如果没有显式地指定，那么如果所有带有基线以及向基线对齐的元素的基线调整大小行为都是 CONSTANT_DESCENT，则基线将固定在组的底部；否则，基线将固定在组的顶部。

如果向基线对齐的元素的基线调整大小行为是 CONSTANT_ASCENT 或 CONSTANT_DESCENT，则它们是可调整大小的。基线调整大小行为是 OTHER 或 CENTER_OFFSET 的元素是不可调整大小的。

基线是根据每个具有基线的元素的首选高度来计算的。使用以下算法来计算基线：max(maxNonBaselineHeight, maxAscent + maxDescent)，其中 maxNonBaselineHeight 是所有不具有基线或不沿基线对齐的元素中的最大高度。maxAscent 是所有具有基线并沿基线对齐的元素中的最大上升高度（基线）。maxDescent 是所有具有基线并沿基线对齐的元素中的最大下降高度（首选高度－基线）。

使其元素沿基线对齐的 ParallelGroup 仅用于垂直轴。如果创建了一个基线组并沿水平轴使用它，那么在向 GroupLayout 请求最小大小、首选大小或最大大小，或者试图布置组件时，将抛出 IllegalStateException。

没有向基线对齐并且大小小于 ParallelGroup 的元素以下面三种方式之一确定其位置：居中、固定在前端、固定在尾端。

无基线 ParallelGroup

用 BASELINE 以外的对齐方式创建的 ParallelGroup 将小于组大小的元素以下面三种方式之一进行对齐：居中、固定在前端、固定在尾端。

前端是基于轴和 ComponentOrientation 的。对于垂直轴，往往顶边缘是前端，底边缘是尾端。当 ComponentOrientation 为 LEFT_TO_RIGHT 时，前端是左边缘，尾端是右边缘。ComponentOrientation 为 RIGHT_TO_LEFT 时则前端是右边缘，尾端是左边缘。根据添加元素时所使用的指定对齐方式来对齐子元素。如果没有指定对齐方式，则使用为 ParallelGroup 指定的对齐方式。

要沿基线对齐元素，可以使用 BASELINE 对齐方式来 createBaselineGroup 或 createParallelGroup。如果组不是使用基线对齐方式创建的，那么在试图添加一个指定基线对齐方式的元素时将抛出 IllegalArgumentException。

从以下版本开始：
1.6
另请参见：
GroupLayout.createParallelGroup(), GroupLayout.createBaselineGroup(boolean,boolean)

方法摘要
GroupLayout.ParallelGroup | addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.ParallelGroup | addComponent(Component component, GroupLayout.Alignment alignment) 使用指定的对齐方式将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | addComponent(Component component, GroupLayout.Alignment alignment, int min, int pref, int max) 使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.ParallelGroup | addGap(int pref) 将固定间隙添加到此 Group。
GroupLayout.ParallelGroup | addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.ParallelGroup | addGroup(GroupLayout.Alignment alignment, GroupLayout.Group group) 使用指定的对齐方式将 Group 添加到此 ParallelGroup。
GroupLayout.ParallelGroup | addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

addGroup

public GroupLayout.ParallelGroup addGroup(GroupLayout.Group group)
将 Group 添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addGroup
参数：
group - 要添加的 Group
返回：
此 Group

addComponent

public GroupLayout.ParallelGroup addComponent(Component component)
将 Component 添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addComponent
参数：
component - 要添加的 Component
返回：
此 Group

addComponent

public GroupLayout.ParallelGroup addComponent(Component component,
                                              int min,
                                              int pref,
                                              int max)
使用指定大小将 Component 添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addComponent
参数：
component - 要添加的 Component
min - 最小大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
pref - 首选大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
max - 最大大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
返回：
此 Group

addGap

public GroupLayout.ParallelGroup addGap(int pref)
将固定间隙添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addGap
参数：
pref - 间隙的大小
返回：
此 Group

addGap

public GroupLayout.ParallelGroup addGap(int min,
                                        int pref,
                                        int max)
将指定大小的间隙添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addGap
参数：
min - 间隙的最小大小
pref - 间隙的首选大小
max - 间隙的最大大小
返回：
此 Group

addGroup

public GroupLayout.ParallelGroup addGroup(GroupLayout.Alignment alignment,
                                          GroupLayout.Group group)
使用指定的对齐方式将 Group 添加到此 ParallelGroup。如果子元素小于 Group，则根据指定的对齐方式来对齐它。

参数：
alignment - 对齐方式
group - 要添加的 Group
返回：
此 ParallelGroup
抛出：
IllegalArgumentException - 如果 alignment 为 null

addComponent

public GroupLayout.ParallelGroup addComponent(Component component,
                                              GroupLayout.Alignment alignment)
使用指定的对齐方式将 Component 添加到此 ParallelGroup。

参数：
alignment - 对齐方式
group - 要添加的 Component
返回：
此 Group
抛出：
IllegalArgumentException - 如果 alignment 为 null

addComponent

public GroupLayout.ParallelGroup addComponent(Component component,
                                              GroupLayout.Alignment alignment,
                                              int min,
                                              int pref,
                                              int max)
使用指定的对齐方式和大小将 Component 添加到此 ParallelGroup。

参数：
alignment - 对齐方式
component - 要添加的 Component
min - 最小大小
pref - 首选大小
max - 最大大小
返回：
此 Group
抛出：
IllegalArgumentException - 如果 alignment 为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


GroupLayout.SequentialGroup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 GroupLayout.SequentialGroup

java.lang.Object
    继承者  javax.swing.GroupLayout.Group
        继承者  javax.swing.GroupLayout.SequentialGroup
正在封闭类：
GroupLayout
public class GroupLayout.SequentialGroup
extends GroupLayout.Group

一个 Group，它按顺序一个接一个地确定其元素的位置和大小。此类没有公共构造方法，要创建 SequentialGroup，请使用 createSequentialGroup 方法。

要沿按基线对齐的 ParallelGroup 的基线对齐 SequentialGroup，您需要指定使用 SequentialGroup 的哪些元素来确定基线。使用一个带 boolean 的 add 方法来指定用于计算基线的元素。用 useAsBaseline 为 true 值的 add 方法添加的最后一个元素将用于计算基线。

从以下版本开始：
1.6
另请参见：
GroupLayout.createSequentialGroup()

方法摘要
GroupLayout.SequentialGroup | addComponent(boolean useAsBaseline, Component component) 将 Component 添加到此 Group。
GroupLayout.SequentialGroup | addComponent(boolean useAsBaseline, Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.SequentialGroup | addComponent(Component component) 将 Component 添加到此 Group。
GroupLayout.SequentialGroup | addComponent(Component component, int min, int pref, int max) 使用指定大小将 Component 添加到此 Group。
GroupLayout.SequentialGroup | addContainerGap() 添加一个表示容器边缘和触到容器边框的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | addContainerGap(int pref, int max) 使用指定大小添加一个元素，它表示容器的一个边缘和下一个或前一个 Component 之间的首选间隙。
GroupLayout.SequentialGroup | addGap(int size) 将固定间隙添加到此 Group。
GroupLayout.SequentialGroup | addGap(int min, int pref, int max) 将指定大小的间隙添加到此 Group。
GroupLayout.SequentialGroup | addGroup(boolean useAsBaseline, GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | addGroup(GroupLayout.Group group) 将 Group 添加到此 Group。
GroupLayout.SequentialGroup | addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | addPreferredGap(JComponent comp1, JComponent comp2, LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个组件之间首选间隙的元素。
GroupLayout.SequentialGroup | addPreferredGap(LayoutStyle.ComponentPlacement type) 添加一个表示两个距离最近的组件之间首选间隙的元素。
GroupLayout.SequentialGroup | addPreferredGap(LayoutStyle.ComponentPlacement type, int pref, int max) 添加一个表示两个距离最近的组件之间首选间隙的元素。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

addGroup

public GroupLayout.SequentialGroup addGroup(GroupLayout.Group group)
将 Group 添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addGroup
参数：
group - 要添加的 Group
返回：
此 Group

addGroup

public GroupLayout.SequentialGroup addGroup(boolean useAsBaseline,
                                            GroupLayout.Group group)
将 Group 添加到此 Group。

参数：
group - 要添加的 Group
useAsBaseline - 指定的 Group 是否应该用于计算此 Group 的基线
返回：
此 Group

addComponent

public GroupLayout.SequentialGroup addComponent(Component component)
将 Component 添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addComponent
参数：
component - 要添加的 Component
返回：
此 Group

addComponent

public GroupLayout.SequentialGroup addComponent(boolean useAsBaseline,
                                                Component component)
将 Component 添加到此 Group。

参数：
useAsBaseline - 指定的 Component 是否应该用于计算此 Group 的基线
component - 要添加的 Component
返回：
此 Group

addComponent

public GroupLayout.SequentialGroup addComponent(Component component,
                                                int min,
                                                int pref,
                                                int max)
使用指定大小将 Component 添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addComponent
参数：
component - 要添加的 Component
min - 最小大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
pref - 首选大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
max - 最大大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
返回：
此 Group

addComponent

public GroupLayout.SequentialGroup addComponent(boolean useAsBaseline,
                                                Component component,
                                                int min,
                                                int pref,
                                                int max)
使用指定大小将 Component 添加到此 Group。

参数：
useAsBaseline - 指定的 Component 是否应该用于计算此 Group 的基线
component - 要添加的 Component
min - 最小大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
pref - 首选大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
max - 最大大小或者 DEFAULT_SIZE 或 PREFERRED_SIZE 之一
返回：
此 Group

addGap

public GroupLayout.SequentialGroup addGap(int size)
将固定间隙添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addGap
参数：
size - 间隙的大小
返回：
此 Group

addGap

public GroupLayout.SequentialGroup addGap(int min,
                                          int pref,
                                          int max)
将指定大小的间隙添加到此 Group。

覆盖：
类 GroupLayout.Group 中的 addGap
参数：
min - 间隙的最小大小
pref - 间隙的首选大小
max - 间隙的最大大小
返回：
此 Group

addPreferredGap

public GroupLayout.SequentialGroup addPreferredGap(JComponent comp1,
                                                   JComponent comp2,
                                                   LayoutStyle.ComponentPlacement type)
添加一个表示两个组件之间首选间隙的元素。创建用来表示间隙的元素是不可调整大小的。

参数：
comp1 - 第一个组件
comp2 - 第二个组件
type - 间隙的类型；由 LayoutStyle 定义的常量之一
返回：
此 SequentialGroup
抛出：
IllegalArgumentException - 如果 type、comp1 或 comp2 为 null
另请参见：
LayoutStyle

addPreferredGap

public GroupLayout.SequentialGroup addPreferredGap(JComponent comp1,
                                                   JComponent comp2,
                                                   LayoutStyle.ComponentPlacement type,
                                                   int pref,
                                                   int max)
添加一个表示两个组件之间首选间隙的元素。

参数：
comp1 - 第一个组件
comp2 - 第二个组件
type - 间隙的类型
pref - 间隙的首选大小；DEFAULT_SIZE 或大于等于 0 的值
max - 间隙的最大大小；DEFAULT_SIZE、PREFERRED_SIZE 或大于等于 0 的值
返回：
此 SequentialGroup
抛出：
IllegalArgumentException - 如果 type、comp1 或 comp2 为 null
另请参见：
LayoutStyle

addPreferredGap

public GroupLayout.SequentialGroup addPreferredGap(LayoutStyle.ComponentPlacement type)
添加一个表示两个距离最近的组件之间首选间隙的元素。在布局过程中，找到相邻组件，并根据组件之间的首选间隙来设置添加间隙的大小。如果找不到相邻组件，则间隙的大小为 0。

创建用来表示间隙的元素是不可调整大小的。

参数：
type - 间隙的类型；LayoutStyle.ComponentPlacement.RELATED 或 LayoutStyle.ComponentPlacement.UNRELATED
返回：
此 SequentialGroup
抛出：
IllegalArgumentException - 如果 type 不是 LayoutStyle.ComponentPlacement.RELATED 或 LayoutStyle.ComponentPlacement.UNRELATED
另请参见：
LayoutStyle

addPreferredGap

public GroupLayout.SequentialGroup addPreferredGap(LayoutStyle.ComponentPlacement type,
                                                   int pref,
                                                   int max)
添加一个表示两个距离最近的组件之间首选间隙的元素。在布局过程中，找到相邻元素，并根据相邻组件之间的首选间隙大小来设置此间隙的最小大小。如果找不到相邻组件，则最小大小被设置为 0。

参数：
type - 间隙的类型；LayoutStyle.ComponentPlacement.RELATED 或 LayoutStyle.ComponentPlacement.UNRELATED
pref - 间隙的首选大小；DEFAULT_SIZE 或大于等于 0 的值
max - 间隙的最大大小；DEFAULT_SIZE、PREFERRED_SIZE 或大于等于 0 的值
返回：
此 SequentialGroup
抛出：
IllegalArgumentException - 如果 type 不是 LayoutStyle.ComponentPlacement.RELATED 或 LayoutStyle.ComponentPlacement.UNRELATED
另请参见：
LayoutStyle

addContainerGap

public GroupLayout.SequentialGroup addContainerGap()
添加一个表示容器边缘和触到容器边框的组件之间首选间隙的元素。如果添加的间隙没有触到父容器的边缘，则此方法没有任何效果。

创建用来表示间隙的元素是不可调整大小的。

返回：
此 SequentialGroup

addContainerGap

public GroupLayout.SequentialGroup addContainerGap(int pref,
                                                   int max)
使用指定大小添加一个元素，它表示容器的一个边缘和下一个或前一个 Component 之间的首选间隙。如果下一个或前一个元素不是 Component 并且没有触到父容器的一个边缘，则此方法没有任何效果。

参数：
pref - 首选大小；DEFAULT_SIZE 或大于等于 0 的值
max - 最大大小；DEFAULT_SIZE、PREFERRED_SIZE 或大于等于 0 的值
返回：
此 SequentialGroup
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageIcon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ImageIcon

java.lang.Object
    继承者  javax.swing.ImageIcon
所有已实现的接口：
Serializable, Accessible, Icon
public class ImageIcon
extends Object
implements Icon, Serializable, Accessible

一个 Icon 接口的实现，它根据 Image 绘制 Icon。可使用 MediaTracker 预载根据 URL、文件名或字节数组创建的图像，以监视该图像的加载状态。

有关使用图像图标的更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Icons 一节。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class ImageIcon.AccessibleImageIcon
此类实现 ImageIcon 类的可访问性支持。
字段摘要
protected static Component | component
protected static MediaTracker | tracker
构造方法摘要
ImageIcon()
创建一个未初始化的图像图标。
ImageIcon(byte[] imageData)
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。
ImageIcon(byte[] imageData, String description)
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。
ImageIcon(Image image)
根据图像对象创建一个 ImageIcon。
ImageIcon(Image image, String description)
根据图像创建一个 ImageIcon。
ImageIcon(String filename)
根据指定的文件创建一个 ImageIcon。
ImageIcon(String filename, String description)
根据指定的文件创建一个 ImageIcon。
ImageIcon(URL location)
根据指定的 URL 创建一个 ImageIcon。
ImageIcon(URL location, String description)
根据指定的 URL 创建一个 ImageIcon。
方法摘要
AccessibleContext | getAccessibleContext() 获得与此 ImageIcon 关联的 AccessibleContext。
String | getDescription() 获得图像的描述。
int | getIconHeight() 获得图标的高度。
int | getIconWidth() 获得图标的宽度。
Image | getImage() 返回此图标的 Image。
int | getImageLoadStatus() 返回图像加载操作的状态。
ImageObserver | getImageObserver() 返回图像的图像观察者。
protected void | loadImage(Image image) 加载图像，并且只在图像已加载时返回。
void | paintIcon(Component c, Graphics g, int x, int y) 绘制图标。
void | setDescription(String description) 设置图像的描述。
void | setImage(Image image) 设置由此图标显示的图像。
void | setImageObserver(ImageObserver observer) 设置图像的图像观察者。
String | toString() 返回此图像的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

component

protected static final Component component

tracker

protected static final MediaTracker tracker
构造方法详细信息

ImageIcon

public ImageIcon(String filename,
                 String description)
根据指定的文件创建一个 ImageIcon。使用 MediaTracker 预载图像以监视图像的加载状态。

参数：
filename - 包含图像的文件的名称
description - 图像的简明文本描述
另请参见：
ImageIcon(String)

ImageIcon

public ImageIcon(String filename)
根据指定的文件创建一个 ImageIcon。使用 MediaTracker 预载图像以监视图像的加载状态。指定 String 可以是一个文件名或是一条文件路径。在指定一条路径时，可使用 Internet 标准正斜杠 ("/") 作为分隔符。（该字符串被转换成一个 URL，而正斜杠适用于所有系统。）例如，指定：
    new ImageIcon("images/myImage.gif")
该描述被初始化为 filename 字符串。

参数：
filename - 指定文件名或路径的 String
另请参见：
getDescription()

ImageIcon

public ImageIcon(URL location,
                 String description)
根据指定的 URL 创建一个 ImageIcon。使用 MediaTracker 预载图像以监视图像的加载状态。

参数：
location - 图像的 URL
description - 图像的简明文本描述
另请参见：
ImageIcon(String)

ImageIcon

public ImageIcon(URL location)
根据指定的 URL 创建一个 ImageIcon。使用 MediaTracker 预载图像以监视图像的加载状态。图标的描述被初始化为 URL 的字符串表示形式。

参数：
location - 图像的 URL
另请参见：
getDescription()

ImageIcon

public ImageIcon(Image image,
                 String description)
根据图像创建一个 ImageIcon。

参数：
image - 图像
description - 图像的简明文本描述

ImageIcon

public ImageIcon(Image image)
根据图像对象创建一个 ImageIcon。如果图像有一个字符串形式的 "comment" 属性，则该字符串被用作此图标的描述。

参数：
image - 图像
另请参见：
getDescription(), Image.getProperty(java.lang.String, java.awt.image.ImageObserver)

ImageIcon

public ImageIcon(byte[] imageData,
                 String description)
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。通常，此数组是通过使用 Class.getResourceAsStream() 读取图像文件来创建的，但该字节数组也可以静态地存储在某个类中。

参数：
imageData - 一个像素数组，具有受 AWT Toolkit 支持的图像格式，比如 GIF、JPEG 或从 1.3 版本开始的 PNG
description - 图像的简明文本描述
另请参见：
Toolkit.createImage(java.lang.String)

ImageIcon

public ImageIcon(byte[] imageData)
根据字节数组创建一个 ImageIcon，这些字节读取自一个包含受支持图像格式（比如 GIF、JPEG 或从 1.3 版本开始的 PNG）的图像文件。通常，此数组是通过使用 Class.getResourceAsStream() 读取一幅图像来创建的，但该字节数组也可以静态地存储在某个类中。如果得到的图像有一个字符串形式的 "comment" 属性，则该字符串被用作此图标的描述。

参数：
imageData - 一个像素数组，具有受 AWT Toolkit 支持的图像格式，比如 GIF、JPEG 或从 1.3 版本开始的 PNG
另请参见：
Toolkit.createImage(java.lang.String),
getDescription(),
Image.getProperty(java.lang.String, java.awt.image.ImageObserver)

ImageIcon

public ImageIcon()
创建一个未初始化的图像图标。

方法详细信息

loadImage

protected void loadImage(Image image)
加载图像，并且只在图像已加载时返回。

参数：
image - 图像

getImageLoadStatus

public int getImageLoadStatus()
返回图像加载操作的状态。

返回：
由 java.awt.MediaTracker 定义的加载状态
另请参见：
MediaTracker.ABORTED, MediaTracker.ERRORED, MediaTracker.COMPLETE

getImage

public Image getImage()
返回此图标的 Image。

返回：
此 ImageIcon 的 Image 对象

setImage

public void setImage(Image image)
设置由此图标显示的图像。

参数：
image - 图像

getDescription

public String getDescription()
获得图像的描述。此描述应该是该对象的简明文本描述。例如，可以将它呈现给盲人用户，为他们提供该图像用途的指示。该描述可以为 null。

返回：
图像的简明文本描述。

setDescription

public void setDescription(String description)
设置图像的描述。此描述应该是该对象的简明文本描述。例如，可以将它呈现给盲人用户，为他们提供该图像用途的指示。

参数：
description - 图像的简明文本描述。

paintIcon

public void paintIcon(Component c,
                      Graphics g,
                      int x,
                      int y)
绘制图标。图标的左上角在图形上下文 g 的坐标空间中的点 (x, y) 处绘制。如果此图标没有图像观察者，则此方法使用 c 组件作为观察者。

指定者：
接口 Icon 中的 paintIcon
参数：
c - 用作观察者的组件，如果此图标没有图像观察者
g - 图形上下文
x - 图标左上角的 X 坐标
y - 图标左上角的 Y 坐标

getIconWidth

public int getIconWidth()
获得图标的宽度。

指定者：
接口 Icon 中的 getIconWidth
返回：
此图标的宽度，以像素为单位

getIconHeight

public int getIconHeight()
获得图标的高度。

指定者：
接口 Icon 中的 getIconHeight
返回：
此图标的高度，以像素为单位

setImageObserver

public void setImageObserver(ImageObserver observer)
设置图像的图像观察者。如果 ImageIcon 包含一个动画 GIF，则设置此属性，而观察者获得更新其显示的通知。例如：
     icon = new ImageIcon(...)
     button.setIcon(icon);
     icon.setImageObserver(button);

参数：
observer - 图像观察者

getImageObserver

public ImageObserver getImageObserver()
返回图像的图像观察者。

返回：
图像观察者，它可以为 null

toString

public String toString()
返回此图像的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
表示此图像的字符串

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得与此 ImageIcon 关联的 AccessibleContext。对于图像图标，AccessibleContext 采用 AccessibleImageIcon 的形式。如有必要，可创建一个新的 AccessibleImageIcon 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
一个 AccessibleImageIcon，它将充当此 ImageIcon 的 AccessibleContext
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ImageIcon.AccessibleImageIcon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ImageIcon.AccessibleImageIcon

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.ImageIcon.AccessibleImageIcon
所有已实现的接口：
Serializable, AccessibleIcon
正在封闭类：
ImageIcon
protected class ImageIcon.AccessibleImageIcon
extends AccessibleContext
implements AccessibleIcon, Serializable

此类实现 ImageIcon 类的可访问性支持。它提供适合图像图标用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.3

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected ImageIcon.AccessibleImageIcon()
方法摘要
Accessible | getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子对象。
int | getAccessibleChildrenCount() 返回对象中 accessible 子对象的数量。
String | getAccessibleIconDescription() 获得此图标的描述。
int | getAccessibleIconHeight() 获得图标的高度。
int | getAccessibleIconWidth() 获得图标的宽度。
int | getAccessibleIndexInParent() 获得此对象在其可访问的父对象中的索引。
Accessible | getAccessibleParent() 获得此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获得此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获得此对象的状态。
Locale | getLocale() 返回此对象的区域。
void | setAccessibleIconDescription(String description) 设置图标的描述。
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleComponent, getAccessibleDescription, getAccessibleEditableText, getAccessibleIcon, getAccessibleName, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ImageIcon.AccessibleImageIcon

protected ImageIcon.AccessibleImageIcon()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获得此对象的职责。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获得此对象的状态。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleParent

public Accessible getAccessibleParent()
获得此对象的 Accessible 父对象。如果此对象的父对象实现 Accessible，那么此方法应该只返回 getParent()。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
此对象的 Accessible 父对象；如果此对象没有 Accessible 父对象，则返回 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获得此对象在其可访问的父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象在其父对象中的索引；如果此对象没有 accessible 父对象，则返回 -1。
另请参见：
getAccessibleParent()

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中 accessible 子对象的数量。如果此对象的所有子对象都实现了 Accessible，则此方法应该返回此对象的子对象数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
对象的 accessible 子对象的数量。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个 Accessible 子对象。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
该对象的第 n 个 Accessible 子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
                 throws IllegalComponentStateException
返回此对象的区域。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此对象的区域
抛出：
IllegalComponentStateException - 如果该 Component 没有自己的语言环境，并且尚未被添加到可以从包含父级确定其语言环境的包含层次结构中。

getAccessibleIconDescription

public String getAccessibleIconDescription()
获得此图标的描述。此描述应该是该对象的简明文本描述。例如，可以将它呈现给盲人用户，为他们提供该图标用途的指示。

指定者：
接口 AccessibleIcon 中的 getAccessibleIconDescription
返回：
图标的描述

setAccessibleIconDescription

public void setAccessibleIconDescription(String description)
设置图标的描述。此描述应该是该对象的简明文本描述。例如，可以将它呈现给盲人用户，为他们提供该图标用途的指示。

指定者：
接口 AccessibleIcon 中的 setAccessibleIconDescription
参数：
description - 图标的描述

getAccessibleIconHeight

public int getAccessibleIconHeight()
获得图标的高度。

指定者：
接口 AccessibleIcon 中的 getAccessibleIconHeight
返回：
图标的高度

getAccessibleIconWidth

public int getAccessibleIconWidth()
获得图标的宽度。

指定者：
接口 AccessibleIcon 中的 getAccessibleIconWidth
返回：
图标的宽度
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 InputMap

java.lang.Object
    继承者  javax.swing.InputMap
所有已实现的接口：
Serializable
直接已知子类：
ComponentInputMap, InputMapUIResource
public class InputMap
extends Object
implements Serializable

InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。InputMap 通常与 ActionMap 一起使用，以确定按下键时执行一个 Action。InputMap 可以有一个父级，可搜索它来获得 InputMap 中未定义的绑定。

与 ActionMap 一同使用时，如果创建一个循环，例如：

   InputMap am = new InputMap();
   InputMap bm = new InputMap():
   am.setParent(bm);
   bm.setParent(am);
则某些方法将导致抛出 StackOverflowError。

从以下版本开始：
1.3

构造方法摘要
InputMap()
创建一个没有父级和映射关系的 InputMap。
方法摘要
KeyStroke[] | allKeys() 返回在此 InputMap 及其父级中定义的 KeyStroke 组成的数组。
void | clear() 从此 InputMap 中移除所有映射关系。
Object | get(KeyStroke keyStroke) 返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。
InputMap | getParent() 获得此 InputMap 的父级。
KeyStroke[] | keys() 返回绑定在此 InputMap 中的 KeyStroke。
void | put(KeyStroke keyStroke, Object actionMapKey) 将 keyStroke 的一个绑定添加到 actionMapKey。
void | remove(KeyStroke key) 从此 InputMap 中移除 key 的绑定。
void | setParent(InputMap map) 设置此 InputMap 的父级。
int | size() 返回 KeyStroke 绑定的数量。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputMap

public InputMap()
创建一个没有父级和映射关系的 InputMap。

方法详细信息

setParent

public void setParent(InputMap map)
设置此 InputMap 的父级。

参数：
map - 作为此 InputMap 的父级的 InputMap

getParent

public InputMap getParent()
获得此 InputMap 的父级。

返回：
map 作为此 InputMap 的父级的 InputMap，如果此 InputMap 没有父级，则返回 null

put

public void put(KeyStroke keyStroke,
                Object actionMapKey)
将 keyStroke 的一个绑定添加到 actionMapKey。如果 actionMapKey 为 null，则移除 keyStroke 的当前绑定。

get

public Object get(KeyStroke keyStroke)
返回 keyStroke 的绑定，如果该绑定不是本地定义的，则将此消息传递给父 InputMap。

remove

public void remove(KeyStroke key)
从此 InputMap 中移除 key 的绑定。

clear

public void clear()
从此 InputMap 中移除所有映射关系。

keys

public KeyStroke[] keys()
返回绑定在此 InputMap 中的 KeyStroke。

size

public int size()
返回 KeyStroke 绑定的数量。

allKeys

public KeyStroke[] allKeys()
返回在此 InputMap 及其父级中定义的 KeyStroke 组成的数组。此方法与 keys() 的不同之处在于：此方法包括父级中定义的键。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InputVerifier (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 InputVerifier

java.lang.Object
    继承者  javax.swing.InputVerifier

public abstract class InputVerifier
extends Object

此类的用途是通过带文本字段的 GUI 帮助客户端支持流畅的焦点导航。在允许用户导航到文本字段以外之前，这类 GUI 常常需要确保用户输入的文本是有效的（例如，文本具有正确的格式）。为做到这一点，客户端要使用 JComponent 的 setInputVerifier 方法创建 InputVerifier 的子类，并将其子类的实例附加到想要验证其输入的 JComponent 中。在将焦点转移到另一个请求它的 Swing 组件之前，要调用输入验证器的 shouldYieldFocus 方法。只在该方法返回 true 时才转移焦点。

以下示例有两个文本字段，其中第一个字段期望用户输入字符串 "pass"。如果在第一个文本字段中输入该字符串，那么用户可以通过在第二个文本字段上单击或按下 TAB 前进到第二个文本字段。不过，如果将其他字符串输入到第一个文本字段中，则用户无法将焦点转移到第二个文本字段。

 import java.awt.*;
 import java.util.*;
 import java.awt.event.*;
 import javax.swing.*;

 // This program demonstrates the use of the Swing InputVerifier class.
 // It creates two text fields; the first of the text fields expects the
 // string "pass" as input, and will allow focus to advance out of it
 // only after that string is typed in by the user.

 public class VerifierTest extends JFrame {
     public VerifierTest() {
         JTextField tf1 = new JTextField ("Type \"pass\" here");
           getContentPane().add (tf1, BorderLayout.NORTH);
           tf1.setInputVerifier(new PassVerifier());

           JTextField tf2 = new JTextField ("TextField2");
           getContentPane().add (tf2, BorderLayout.SOUTH);

           WindowListener l = new WindowAdapter() {
               public void windowClosing(WindowEvent e) {
                   System.exit(0);
               }
           };
           addWindowListener(l);
     }

     class PassVerifier extends InputVerifier {
         public boolean verify(JComponent input) {
               JTextField tf = (JTextField) input;
               return "pass".equals(tf.getText());
         }
     }

     public static void main(String[] args) {
         Frame f = new VerifierTest();
           f.pack();
           f.setVisible(true);
     }
 }

从以下版本开始：
1.3

构造方法摘要
InputVerifier()
方法摘要
boolean | shouldYieldFocus(JComponent input) 调用 verify(input) 来确保输入是有效的。
abstract boolean | verify(JComponent input) 检查 JComponent 的输入是否有效。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InputVerifier

public InputVerifier()
方法详细信息

verify

public abstract boolean verify(JComponent input)
检查 JComponent 的输入是否有效。此方法不应有副作用。该方法返回一个指示参数的输入状态的 boolean 值。

参数：
input - 要验证的 JComponent
返回：
在有效时返回 true，在无效时返回 false
另请参见：
JComponent.setInputVerifier(javax.swing.InputVerifier), JComponent.getInputVerifier()

shouldYieldFocus

public boolean shouldYieldFocus(JComponent input)
调用 verify(input) 来确保输入是有效的。此方法可以有副作用。需要特别指出的是，在用户试图将焦点移出参数组件进入此窗口中的另一个 Swing 组件时调用此方法。如果此方法返回 true，那么正常转移焦点；如果该方法返回 false，则焦点仍然留在参数组件中。

参数：
input - 要验证的 JComponent
返回：
在有效时返回 true，在无效时返回 false
另请参见：
JComponent.setInputVerifier(javax.swing.InputVerifier), JComponent.getInputVerifier()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InternalFrameFocusTraversalPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 InternalFrameFocusTraversalPolicy

java.lang.Object
    继承者  java.awt.FocusTraversalPolicy
        继承者  javax.swing.InternalFrameFocusTraversalPolicy
直接已知子类：
SortingFocusTraversalPolicy
public abstract class InternalFrameFocusTraversalPolicy
extends FocusTraversalPolicy

该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。初始 Component 是第一次选择 JInternalFrame 时接收焦点的第一个 Component。默认情况下，此组件是 InternalFrame 默认要聚焦的 Component。

从以下版本开始：
1.4

构造方法摘要
InternalFrameFocusTraversalPolicy()
方法摘要
 Component getInitialComponent(JInternalFrame frame)
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。
从类 java.awt.FocusTraversalPolicy 继承的方法
getComponentAfter, getComponentBefore, getDefaultComponent, getFirstComponent, getInitialComponent, getLastComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InternalFrameFocusTraversalPolicy

public InternalFrameFocusTraversalPolicy()
方法详细信息

getInitialComponent

public Component getInitialComponent(JInternalFrame frame)
返回第一次选择 JInternalFrame 时应该接收焦点的 Component。一旦通过调用 setSelected(true) 选择了 JInternalFrame，将不再使用初始 Component。相反，如果 JInternalFrame 被取消选择、随后又被选择，或者先被设置为不可见或不可显示、随后又设置为可见或可显示，则 JInternalFrame 最新聚焦的 Component 将成为焦点所有者。此方法的默认实现返回 JInternalFrame 默认要聚焦的 Component。

参数：
frame - 要返回其初始 Component 的 JInternalFrame
返回：
第一次选择窗体时应该接收焦点的 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 window 为 null
另请参见：
JInternalFrame.getMostRecentFocusOwner()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JApplet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JApplet

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Panel
                继承者  java.applet.Applet
                    继承者  javax.swing.JApplet
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer
public class JApplet
extends Applet
implements Accessible, RootPaneContainer

java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。有关使用 JApplet 的面向任务的文档，请参阅 The Java Tutorial 中的 How to Make Applets 一节。

JApplet 类与 java.applet.Applet 轻微不兼容。JApplet 包含一个 JRootPane 作为其唯一子类。contentPane 应该是 JApplet 任何子类的父类。作为一个便捷的 add 方法及其变体，remove 和 setLayout 被重写，其可以在必要时转发给 contentPane。这意味着您可以编写：

       applet.add(child);
并且可以将子类添加到 contentPane 中。contentPane 始终是非 null 的。试图将它设置为 null 会导致 JApplet 抛出异常。默认 contentPane 将在其上设置 BorderLayout 管理器。有关添加、移除和设置 JApplet 的 LayoutManager 的细节，请参阅 RootPaneContainer。

有关 contentPane、glassPane 和 layeredPane 属性的完整描述，请参阅 JRootPane 文档。

警告： Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
RootPaneContainer

嵌套类摘要
protected  class JApplet.AccessibleJApplet
此类实现对 JApplet 类的可访问性支持。
从类 java.applet.Applet 继承的嵌套类/接口
Applet.AccessibleApplet
从类 java.awt.Panel 继承的嵌套类/接口
Panel.AccessibleAWTPanel
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected AccessibleContext | accessibleContext
protected JRootPane | rootPane
protected boolean | rootPaneCheckingEnabled 如果为 true，则对 add 和 setLayout 的调用将转发给 contentPane。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JApplet()
创建一个 swing applet 实例。
方法摘要
protected void | addImpl(Component comp, Object constraints, int index) 添加指定的子 Component。
protected JRootPane | createRootPane() 构造方法调用此方法创建默认 rootPane。
AccessibleContext | getAccessibleContext() 获取与此 JApplet 关联的 AccessibleContext。
Container | getContentPane() 返回此 applet 的 contentPane 对象。
Component | getGlassPane() 返回此 applet 的 glassPane 对象。
Graphics | getGraphics() 为组件创建一个图形上下文。
JMenuBar | getJMenuBar() 返回此 applet 上的菜单栏设置。
JLayeredPane | getLayeredPane() 返回此 applet 的 layeredPane 对象。
JRootPane | getRootPane() 返回此 applet 的 rootPane 对象。
TransferHandler | getTransferHandler() 获取 transferHandler 属性。
protected boolean | isRootPaneCheckingEnabled() 返回是否将对 add 和 setLayout 的调用转发给 contentPane。
protected String | paramString() 返回此 JApplet 的字符串表示形式。
void | remove(Component comp) 从容器中移除指定的组件。
void | repaint(long time, int x, int y, int width, int height) 在 time 毫秒内重绘此组件的指定矩形区域。
void | setContentPane(Container contentPane) 设置 contentPane 属性。
void | setGlassPane(Component glassPane) 设置 glassPane 属性。
void | setJMenuBar(JMenuBar menuBar) 设置此 applet 的菜单栏。
void | setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | setLayout(LayoutManager manager) 设置 LayoutManager。
protected void | setRootPane(JRootPane root) 设置 rootPane 属性。
protected void | setRootPaneCheckingEnabled(boolean enabled) 设置是否将对 add 和 setLayout 的调用转发给 contentPane。
void | setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
void | update(Graphics g) 调用 paint(g)。
从类 java.applet.Applet 继承的方法
destroy, getAppletContext, getAppletInfo, getAudioClip, getAudioClip, getCodeBase, getDocumentBase, getImage, getImage, getLocale, getParameter, getParameterInfo, init, isActive, newAudioClip, play, play, resize, resize, setStub, showStatus, start, stop
从类 java.awt.Panel 继承的方法
addNotify
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getInsets, getLayout, getListeners, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, removeNotify, setComponentZOrder, setFocusCycleRoot, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getGraphicsConfiguration, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getToolkit, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, reshape, setBackground, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setMinimumSize, setName, setPreferredSize, setSize, setSize, setVisible, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

rootPane

protected JRootPane rootPane
另请参见：
getRootPane(), setRootPane(javax.swing.JRootPane)

rootPaneCheckingEnabled

protected boolean rootPaneCheckingEnabled
如果为 true，则对 add 和 setLayout 的调用将转发给 contentPane。该值最初为 false，但在构造 JApplet 时被设置为 true。

另请参见：
isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

accessibleContext

protected AccessibleContext accessibleContext
构造方法详细信息

JApplet

public JApplet()
        throws HeadlessException
创建一个 swing applet 实例。

此构造方法将组件的语言环境属性设置为 JComponent.getDefaultLocale 返回的值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()
方法详细信息

createRootPane

protected JRootPane createRootPane()
构造方法调用此方法创建默认 rootPane。

setTransferHandler

public void setTransferHandler(TransferHandler newHandler)
设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。如果该组件不支持数据传输操作，请使用 null。

如果系统属性 suppressSwingDropSupport 为 false（默认值），并且此组件上的当前放置目标为 null 或者不是用户设置的放置目标，那么此方法将按以下方式更改放置目标：如果 newHandler 为 null，它将清除放置目标。如果不为 null，则它将安装一个新的 DropTarget。

注：当用于 JApplet 时，TransferHandler 只提供数据导入功能，与数据导出有关的方法当前用于 JComponent。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

参数：
newHandler - 新的 TransferHandler
从以下版本开始：
1.6
另请参见：
TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

getTransferHandler

public TransferHandler getTransferHandler()
获取 transferHandler 属性。

返回：
transferHandler 属性的值
从以下版本开始：
1.6
另请参见：
TransferHandler, setTransferHandler(javax.swing.TransferHandler)

update

public void update(Graphics g)
调用 paint(g)。重写此方法以防止不必要地调用清除了背景。

覆盖：
类 Container 中的 update
参数：
g - 指定的 Graphics 窗口
另请参见：
Component.update(Graphics)

setJMenuBar

public void setJMenuBar(JMenuBar menuBar)
设置此 applet 的菜单栏。

参数：
menuBar - 将放置在 applet 中的菜单栏
另请参见：
getJMenuBar()

getJMenuBar

public JMenuBar getJMenuBar()
返回此 applet 上的菜单栏设置。

另请参见：
setJMenuBar(javax.swing.JMenuBar)

isRootPaneCheckingEnabled

protected boolean isRootPaneCheckingEnabled()
返回是否将对 add 和 setLayout 的调用转发给 contentPane。

返回：
如果转发 add 和 setLayout，则返回 true；否则返回 false
另请参见：
addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

setRootPaneCheckingEnabled

protected void setRootPaneCheckingEnabled(boolean enabled)
设置是否将对 add 和 setLayout 的调用转发给 contentPane。

参数：
enabled - 如果转发 add 和 setLayout，则该参数为 true；如果应该直接在 JApplet 上进行这两个操作，则该参数为 false。
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
添加指定的子 Component。重写此方法，以有条件地将调用转发给 contentPane。默认情况下，子组件被添加到 contentPane 而不是窗体中，有关细节，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要添加子组件的组件
constraints - 要遵从的约束条件
index - 索引
抛出：
IllegalArgumentException - 如果 index 无效
IllegalArgumentException - 如果将容器的父容器添加到该容器中
IllegalArgumentException - 如果将窗口添加到容器中
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

remove

public void remove(Component comp)
从容器中移除指定的组件。如果 comp 不是 rootPane，则此方法会将调用转发给 contentPane。如果 comp 不是 JFrame 或 contentPane 的子组件，则此方法不执行任何操作。

覆盖：
类 Container 中的 remove
参数：
comp - 要移除的组件
抛出：
NullPointerException - 如果 comp 为 null
另请参见：
Container.add(java.awt.Component), RootPaneContainer

setLayout

public void setLayout(LayoutManager manager)
设置 LayoutManager。重写此方法，以有条件地将调用转发给 contentPane。有关更多信息，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 setLayout
参数：
manager - LayoutManager
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

getRootPane

public JRootPane getRootPane()
返回此 applet 的 rootPane 对象。

指定者：
接口 RootPaneContainer 中的 getRootPane
返回：
此组件的单个 JRootPane 子组件。
另请参见：
setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

setRootPane

protected void setRootPane(JRootPane root)
设置 rootPane 属性。此方法由构造方法调用。

参数：
root - 此 applet 的 rootPane 对象
另请参见：
getRootPane()

getContentPane

public Container getContentPane()
返回此 applet 的 contentPane 对象。

指定者：
接口 RootPaneContainer 中的 getContentPane
返回：
contentPane 属性的值。
另请参见：
setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

setContentPane

public void setContentPane(Container contentPane)
设置 contentPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setContentPane
参数：
contentPane - 此 applet 的 contentPane 对象
抛出：
IllegalComponentStateException - （运行时异常）如果内容窗格参数为 null
另请参见：
getContentPane(), RootPaneContainer.setContentPane(java.awt.Container)

getLayeredPane

public JLayeredPane getLayeredPane()
返回此 applet 的 layeredPane 对象。

指定者：
接口 RootPaneContainer 中的 getLayeredPane
返回：
layeredPane 属性的值。
抛出：
IllegalComponentStateException - （运行时异常）如果分层窗格参数为 null
另请参见：
setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

setLayeredPane

public void setLayeredPane(JLayeredPane layeredPane)
设置 layeredPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setLayeredPane
参数：
layeredPane - 此 applet 的 layeredPane 对象
另请参见：
getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

getGlassPane

public Component getGlassPane()
返回此 applet 的 glassPane 对象。

指定者：
接口 RootPaneContainer 中的 getGlassPane
返回：
glassPane 属性的值。
另请参见：
setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

setGlassPane

public void setGlassPane(Component glassPane)
设置 glassPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setGlassPane
参数：
glassPane - 此 applet 的 glassPane 对象
另请参见：
getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

getGraphics

public Graphics getGraphics()
为组件创建一个图形上下文。如果组件当前是不可显示的，则此方法返回 null。

覆盖：
类 Component 中的 getGraphics
返回：
组件的图形上下文，如果其没有，则返回 null
从以下版本开始：
1.6
另请参见：
Component.paint(java.awt.Graphics)

repaint

public void repaint(long time,
                    int x,
                    int y,
                    int width,
                    int height)
在 time 毫秒内重绘此组件的指定矩形区域。有关如何处理重绘的详细信息，请参阅 RepaintManager。

覆盖：
类 Component 中的 repaint
参数：
time - 更新前等待的最长时间（以毫秒为单位）
x - x 坐标
y - y 坐标
width - 宽度
height - 高度
从以下版本开始：
1.6
另请参见：
RepaintManager

paramString

protected String paramString()
返回此 JApplet 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Container 中的 paramString
返回：
此 JApplet 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JApplet 关联的 AccessibleContext。对于 JApplet，AccessibleContext 采取 AccessibleJApplet 的形式。如有必要，可创建一个新的 AccessibleJApplet 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Applet 中的 getAccessibleContext
返回：
一个 AccessibleJApplet，它充当此 JApplet 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JApplet.AccessibleJApplet (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JApplet.AccessibleJApplet

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Panel.AccessibleAWTPanel
                    继承者  java.applet.Applet.AccessibleApplet
                        继承者  javax.swing.JApplet.AccessibleJApplet
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
JApplet
protected class JApplet.AccessibleJApplet
extends Applet.AccessibleApplet

此类实现对 JApplet 类的可访问性支持。

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JApplet.AccessibleJApplet()
方法摘要
从类 java.applet.Applet.AccessibleApplet 继承的方法
getAccessibleRole, getAccessibleStateSet
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JApplet.AccessibleJApplet

protected JApplet.AccessibleJApplet()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JButton

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JButton
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
直接已知子类：
BasicArrowButton, MetalComboBoxButton
public class JButton
extends AbstractButton
implements Accessible

"push" 按钮的实现。

通过 Action 可配置按钮，并进行一定程度的控制。将 Action 用于按钮具有许多直接配置按钮所不及的优点。有关更多详细信息，请参阅支持的 Action Swing 组件，可在 The Java Tutorial 中的 How to Use Actions 一节找到更到信息。

有关使用按钮的更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Buttons, Check Boxes, and Radio Buttons。

警告： Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JButton.AccessibleJButton
此类实现对 JButton 类的可访问性支持。
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JButton()
创建不带有设置文本或图标的按钮。
JButton(Action a)
创建一个按钮，其属性从所提供的 Action 中获取。
JButton(Icon icon)
创建一个带图标的按钮。
JButton(String text)
创建一个带文本的按钮。
JButton(String text, Icon icon)
创建一个带初始文本和图标的按钮。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JButton 关联的 AccessibleContext。
String | getUIClassID() 返回指定呈现此组件的 L&F 类名的字符串。
boolean | isDefaultButton() 获取 defaultButton 属性的值，如果为 true 则意味着此按钮是其 JRootPane 的当前默认按钮。
boolean | isDefaultCapable() 获取 defaultCapable 属性的值。
protected String | paramString() 返回此 JButton 的字符串表示形式。
void | removeNotify() 重写 JComponent.removeNotify 来检查此按钮当前是否被设置为 RootPane 上的默认按钮，如果是，则将 RootPane 的默认按钮设置为 null，以确保 RootPane 不继续停留在无效的按钮引用上。
void | setDefaultCapable(boolean defaultCapable) 设置 defaultCapable 属性，该属性确定此按钮是否可以是其根窗格的默认按钮。
void | updateUI() 根据当前外观的值重置 UI 属性。
从类 javax.swing.AbstractButton 继承的方法
actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JButton

public JButton()
创建不带有设置文本或图标的按钮。

JButton

public JButton(Icon icon)
创建一个带图标的按钮。

参数：
icon - 显示在按钮上的 Icon 图像

JButton

public JButton(String text)
创建一个带文本的按钮。

参数：
text - 按钮的文本

JButton

public JButton(Action a)
创建一个按钮，其属性从所提供的 Action 中获取。

参数：
a - 用于指定新按钮的 Action
从以下版本开始：
1.3

JButton

public JButton(String text,
               Icon icon)
创建一个带初始文本和图标的按钮。

参数：
text - 按钮的文本
icon - 显示在按钮上的 Icon 图像
方法详细信息

updateUI

public void updateUI()
根据当前外观的值重置 UI 属性。

覆盖：
类 AbstractButton 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "ButtonUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

isDefaultButton

public boolean isDefaultButton()
获取 defaultButton 属性的值，如果为 true 则意味着此按钮是其 JRootPane 的当前默认按钮。大多数外观呈现不同的默认按钮，并且可能提供对访问默认按钮的绑定。

返回：
defaultButton 属性的值
另请参见：
JRootPane.setDefaultButton(javax.swing.JButton), isDefaultCapable()

isDefaultCapable

public boolean isDefaultCapable()
获取 defaultCapable 属性的值。

返回：
defaultCapable 属性的值
另请参见：
setDefaultCapable(boolean), isDefaultButton(), JRootPane.setDefaultButton(javax.swing.JButton)

setDefaultCapable

public void setDefaultCapable(boolean defaultCapable)
设置 defaultCapable 属性，该属性确定此按钮是否可以是其根窗格的默认按钮。除非由外观另行指定，否则 defaultCapable 属性的默认值为 true。

参数：
defaultCapable - 如果此按钮可以是 RootPane 上的默认按钮，则该参数为 true；否则为 false
另请参见：
isDefaultCapable()

removeNotify

public void removeNotify()
重写 JComponent.removeNotify 来检查此按钮当前是否被设置为 RootPane 上的默认按钮，如果是，则将 RootPane 的默认按钮设置为 null，以确保 RootPane 不继续停留在无效的按钮引用上。

覆盖：
类 AbstractButton 中的 removeNotify
另请参见：
JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

paramString

protected String paramString()
返回此 JButton 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 AbstractButton 中的 paramString
返回：
此 JButton 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JButton 关联的 AccessibleContext。对于 JButton，AccessibleContext 采用 AccessibleJMenuItem 的形式。如有必要，可创建一个新的 AccessibleJButton 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJButton，它充当此 JButton 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JButton.AccessibleJButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JButton.AccessibleJButton

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JButton.AccessibleJButton
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
正在封闭类：
JButton
protected class JButton.AccessibleJButton
extends AbstractButton.AccessibleAbstractButton

此类实现对 JButton 类的可访问性支持。它提供适合于按钮用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JButton.AccessibleJButton()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JButton.AccessibleJButton

protected JButton.AccessibleJButton()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JCheckBox (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JCheckBox

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JToggleButton
                        继承者  javax.swing.JCheckBox
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
public class JCheckBox
extends JToggleButton
implements Accessible

复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。按照惯例，可以选定组中任意数量的复选框。有关使用复选框的示例和信息，请参阅 The Java Tutorial 中的 How to Use Buttons, Check Boxes, and Radio Buttons。

通过 Action 可配置按钮，并进行某种程度的控制。将 Action 用于按钮具有许多直接配置按钮所不及的优点。有关更多详细信息，请参阅支持 Action 的 Swing 组件，可在 The Java Tutorial 中的 How to Use Actions 一节找到更多信息。

警告： Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JRadioButton

嵌套类摘要
protected  class JCheckBox.AccessibleJCheckBox
此类实现对 JCheckBox 类的可访问性支持。
从类 javax.swing.JToggleButton 继承的嵌套类/接口
JToggleButton.AccessibleJToggleButton, JToggleButton.ToggleButtonModel
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static String BORDER_PAINTED_FLAT_CHANGED_PROPERTY
标识 flat 属性的更改。
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JCheckBox()
创建一个没有文本、没有图标并且最初未被选定的复选框。
JCheckBox(Action a)
创建一个复选框，其属性从所提供的 Action 获取。
JCheckBox(Icon icon)
创建有一个图标、最初未被选定的复选框。
JCheckBox(Icon icon, boolean selected)
创建一个带图标的复选框，并指定其最初是否处于选定状态。
JCheckBox(String text)
创建一个带文本的、最初未被选定的复选框。
JCheckBox(String text, boolean selected)
创建一个带文本的复选框，并指定其最初是否处于选定状态。
JCheckBox(String text, Icon icon)
创建带有指定文本和图标的、最初未选定的复选框。
JCheckBox(String text, Icon icon, boolean selected)
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JCheckBox 关联的 AccessibleContext。
String | getUIClassID() 返回指定呈现此组件的 L&F 类名的字符串。
boolean | isBorderPaintedFlat() 获取 borderPaintedFlat 属性的值。
protected String | paramString() 返回此 JCheckBox 的字符串表示形式。
void | setBorderPaintedFlat(boolean b) 设置 borderPaintedFlat 属性，该属性为外观提供了关于复选框边框外观的提示。
void | updateUI() 根据当前外观重置 UI 属性值。
从类 javax.swing.AbstractButton 继承的方法
actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

BORDER_PAINTED_FLAT_CHANGED_PROPERTY

public static final String BORDER_PAINTED_FLAT_CHANGED_PROPERTY
标识 flat 属性的更改。

另请参见：
常量字段值
构造方法详细信息

JCheckBox

public JCheckBox()
创建一个没有文本、没有图标并且最初未被选定的复选框。

JCheckBox

public JCheckBox(Icon icon)
创建有一个图标、最初未被选定的复选框。

参数：
icon - 要显示的 Icon 图像

JCheckBox

public JCheckBox(Icon icon,
                 boolean selected)
创建一个带图标的复选框，并指定其最初是否处于选定状态。

参数：
icon - 要显示的 Icon 图像
selected - 指示最初选择状态的 boolean 值。如果该参数为 true，则复选框被选定

JCheckBox

public JCheckBox(String text)
创建一个带文本的、最初未被选定的复选框。

参数：
text - 复选框的文本

JCheckBox

public JCheckBox(Action a)
创建一个复选框，其属性从所提供的 Action 获取。

从以下版本开始：
1.3

JCheckBox

public JCheckBox(String text,
                 boolean selected)
创建一个带文本的复选框，并指定其最初是否处于选定状态。

参数：
text - 复选框的文本
selected - 指示最初选择状态的 boolean 值。如果该参数为 true，则复选框被选定

JCheckBox

public JCheckBox(String text,
                 Icon icon)
创建带有指定文本和图标的、最初未选定的复选框。

参数：
text - 复选框的文本
icon - 要显示的 Icon 图像

JCheckBox

public JCheckBox(String text,
                 Icon icon,
                 boolean selected)
创建一个带文本和图标的复选框，并指定其最初是否处于选定状态。

参数：
text - 复选框的文本
icon - 要显示的 Icon 图像
selected - 指示最初选择状态的 boolean 值。如果该参数为 true，则复选框被选定
方法详细信息

setBorderPaintedFlat

public void setBorderPaintedFlat(boolean b)
设置 borderPaintedFlat 属性，该属性为外观提供了关于复选框边框外观的提示。在 JCheckBox 实例用作组件（如 JTable 或 JTree）中的渲染器时，该属性通常被设置为 true。borderPaintedFlat 属性的默认值为 false。此方法触发一个属性更改事件。一些外观也许不实现平面边框；它们将忽略此属性。

参数：
b - 为 true 则请求将边框绘制为平面的；为 false 则请求为普通边框
从以下版本开始：
1.3
另请参见：
isBorderPaintedFlat()

isBorderPaintedFlat

public boolean isBorderPaintedFlat()
获取 borderPaintedFlat 属性的值。

返回：
borderPaintedFlat 属性的值
从以下版本开始：
1.3
另请参见：
setBorderPaintedFlat(boolean)

updateUI

public void updateUI()
根据当前外观重置 UI 属性值。

覆盖：
类 JToggleButton 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

覆盖：
类 JToggleButton 中的 getUIClassID
返回：
字符串 "CheckBoxUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

paramString

protected String paramString()
返回此 JCheckBox 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。JFC 组件的一些特定的新的方面。

覆盖：
类 JToggleButton 中的 paramString
返回：
a 此 JCheckBox 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JCheckBox 关联的 AccessibleContext。对于 JCheckBoxes，AccessibleContext 采用 AccessibleJCheckBox 的形式。如有必要，可创建一个新的 AccessibleJCheckBox 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JToggleButton 中的 getAccessibleContext
返回：
一个 AccessibleJCheckBox，它将充当此 JCheckBox 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JCheckBoxMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JCheckBoxMenuItem

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JMenuItem
                        继承者  javax.swing.JCheckBoxMenuItem
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants
public class JCheckBoxMenuItem
extends JMenuItem
implements SwingConstants, Accessible

可以被选定或取消选定的菜单项。如果被选定，菜单项的旁边通常会出现一个复选标记。如果未被选定或被取消选定，菜单项的旁边就没有复选标记。像常规菜单项一样，复选框菜单项可以有与之关联的文本或图标，或者二者兼而有之。

isSelected/setSelected 或 getState/setState 都可以用来确定/指定菜单项的选择状态。首选方法是 isSelected 和 setSelected，它们可用于所有菜单和按钮。getState 和 setState 方法用于与其他组件集的兼容性。

通过 Action 可配置按钮，并进行某种程度的控制。将 Action 用于菜单项具有许多直接配置菜单项所不及的优点。有关更多详细信息，请参阅支持 Action 的 Swing 组件，可在 The Java Tutorial 中的 How to Use Actions 一节找到更多信息。

有关使用复选框菜单项的更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Menus 一节。

警告： Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
此类实现对 JCheckBoxMenuItem 类的可访问性支持。
从类 javax.swing.JMenuItem 继承的嵌套类/接口
JMenuItem.AccessibleJMenuItem
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JCheckBoxMenuItem()
创建一个没有设置文本或图标的、最初未选定的复选框菜单项。
JCheckBoxMenuItem(Action a)
创建一个从所提供的 Action 中获取其属性的菜单项。
JCheckBoxMenuItem(Icon icon)
创建有一个带图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String text)
创建一个带文本的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String text, boolean b)
创建带有指定文本和选择状态的复选框菜单项。
JCheckBoxMenuItem(String text, Icon icon)
创建带有指定文本和图标的、最初未被选定的复选框菜单项。
JCheckBoxMenuItem(String text, Icon icon, boolean b)
创建带有指定文本、图标和选择状态的复选框菜单项。
方法摘要
AccessibleContext | getAccessibleContext() 获得与此 JCheckBoxMenuItem 关联的 AccessibleContext。
Object[] | getSelectedObjects() 返回包含复选框菜单项标签的数组 (length 1)，如果没有选定复选框，则返回 null。
boolean | getState() 返回菜单项的选定状态。
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
protected String | paramString() 返回此 JCheckBoxMenuItem 的字符串表示形式。
void | setState(boolean b) 设置该项的选定状态。
从类 javax.swing.JMenuItem 继承的方法
actionPropertyChanged, addMenuDragMouseListener, addMenuKeyListener, configurePropertiesFromAction, fireMenuDragMouseDragged, fireMenuDragMouseEntered, fireMenuDragMouseExited, fireMenuDragMouseReleased, fireMenuKeyPressed, fireMenuKeyReleased, fireMenuKeyTyped, getAccelerator, getComponent, getMenuDragMouseListeners, getMenuKeyListeners, getSubElements, init, isArmed, menuSelectionChanged, processKeyEvent, processMenuDragMouseEvent, processMenuKeyEvent, processMouseEvent, removeMenuDragMouseListener, removeMenuKeyListener, setAccelerator, setArmed, setEnabled, setModel, setUI, updateUI
从类 javax.swing.AbstractButton 继承的方法
addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JCheckBoxMenuItem

public JCheckBoxMenuItem()
创建一个没有设置文本或图标的、最初未选定的复选框菜单项。

JCheckBoxMenuItem

public JCheckBoxMenuItem(Icon icon)
创建有一个带图标的、最初未被选定的复选框菜单项。

参数：
icon - CheckBoxMenuItem 的图标。

JCheckBoxMenuItem

public JCheckBoxMenuItem(String text)
创建一个带文本的、最初未被选定的复选框菜单项。

参数：
text - CheckBoxMenuItem 的文本

JCheckBoxMenuItem

public JCheckBoxMenuItem(Action a)
创建一个从所提供的 Action 中获取其属性的菜单项。

从以下版本开始：
1.3

JCheckBoxMenuItem

public JCheckBoxMenuItem(String text,
                         Icon icon)
创建带有指定文本和图标的、最初未被选定的复选框菜单项。

参数：
text - CheckBoxMenuItem 的文本
icon - CheckBoxMenuItem 的图标

JCheckBoxMenuItem

public JCheckBoxMenuItem(String text,
                         boolean b)
创建带有指定文本和选择状态的复选框菜单项。

参数：
text - 复选框菜单项的文本
b - 复选框菜单项的选定状态

JCheckBoxMenuItem

public JCheckBoxMenuItem(String text,
                         Icon icon,
                         boolean b)
创建带有指定文本、图标和选择状态的复选框菜单项。

参数：
text - 复选框菜单项的文本
icon - 复选框菜单项的图标
b - 复选框菜单项的选定状态
方法详细信息

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JMenuItem 中的 getUIClassID
返回：
"CheckBoxMenuItemUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getState

public boolean getState()
返回菜单项的选定状态。此方法仅用于 AWT 兼容性。新代码应该使用 isSelected() 。

返回：
如果该项被选定，则返回 true

setState

public void setState(boolean b)
设置该项的选定状态。此方法仅用于 AWT 兼容性。新代码应该使用 setSelected() 。

参数：
b - 指示该项选定状态的 boolean 值，其中 true = 选定

getSelectedObjects

public Object[] getSelectedObjects()
返回包含复选框菜单项标签的数组 (length 1)，如果没有选定复选框，则返回 null。

指定者：
接口 ItemSelectable 中的 getSelectedObjects
覆盖：
类 AbstractButton 中的 getSelectedObjects
返回：
如果该项被选定，则返回包含一个 Object（菜单项的文本）的数组，否则返回 null

paramString

protected String paramString()
返回此 JCheckBoxMenuItem 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JMenuItem 中的 paramString
返回：
此 JCheckBoxMenuItem 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得与此 JCheckBoxMenuItem 关联的 AccessibleContext。对于 JCheckBoxMenuItems，AccessibleContext 采用 AccessibleJCheckBoxMenuItem 的形式。如有必要，可创建一个新的 AccessibleJCheckBoxMenuItem 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JMenuItem 中的 getAccessibleContext
返回：
一个 AccessibleJCheckBoxMenuItem，它充当此 AccessibleJCheckBoxMenuItem 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JCheckBox.AccessibleJCheckBox (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JCheckBox.AccessibleJCheckBox

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JToggleButton.AccessibleJToggleButton
                            继承者  javax.swing.JCheckBox.AccessibleJCheckBox
所有已实现的接口：
ItemListener, Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
正在封闭类：
JCheckBox
protected class JCheckBox.AccessibleJCheckBox
extends JToggleButton.AccessibleJToggleButton

此类实现对 JCheckBox 类的可访问性支持。它提供适合复选框用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JCheckBox.AccessibleJCheckBox()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JToggleButton.AccessibleJToggleButton 继承的方法
itemStateChanged
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JCheckBox.AccessibleJCheckBox

protected JCheckBox.AccessibleJCheckBox()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JToggleButton.AccessibleJToggleButton 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JMenuItem.AccessibleJMenuItem
                            继承者  javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
正在封闭类：
JCheckBoxMenuItem
protected class JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
extends JMenuItem.AccessibleJMenuItem

此类实现对 JCheckBoxMenuItem 类的可访问性支持。它提供适合复选框菜单项用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JMenuItem.AccessibleJMenuItem 继承的方法
stateChanged
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem

protected JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JMenuItem.AccessibleJMenuItem 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JColorChooser (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JColorChooser

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JColorChooser
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JColorChooser
extends JComponent
implements Accessible

JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。有关使用颜色选取器的信息，请参阅 The Java Tutorial 中的 How to Use Color Choosers 一节。

此类提供三个级别的 API：

  1. 显示有模式颜色选取器对话框并返回用户所选颜色的静态便捷方法。
  2. 创建颜色选取器对话框的静态便捷方法，可以指定当用户按下其中一个对话框按钮时要调用的 ActionListener。
  3. 能直接创建 JColorChooser 窗格实例（在任何容器中）。可以添加 PropertyChange 侦听器以检测当前“颜色”属性何时更改。

警告： Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JColorChooser.AccessibleJColorChooser
此类实现对 JColorChooser 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected AccessibleContext | accessibleContext
static String | CHOOSER_PANELS_PROPERTY chooserPanel 数组属性名。
static String | PREVIEW_PANEL_PROPERTY 预览面板属性名。
static String | SELECTION_MODEL_PROPERTY 选择模型属性名。
从类 javax.swing.JComponent 继承的字段
listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JColorChooser()
创建初始颜色为白色的颜色选取器窗格。
JColorChooser(Color initialColor)
创建具有指定初始颜色的颜色选取器窗格。
JColorChooser(ColorSelectionModel model)
创建具有指定 ColorSelectionModel 颜色选取器窗格。
方法摘要
void | addChooserPanel(AbstractColorChooserPanel panel) 将颜色选取器面板添加到颜色选取器。
static JDialog | createDialog(Component c, String title, boolean modal, JColorChooser chooserPane, ActionListener okListener, ActionListener cancelListener) 创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。
AccessibleContext | getAccessibleContext() 获取与此 JColorChooser 关联的 AccessibleContext。
AbstractColorChooserPanel[] | getChooserPanels() 返回指定的颜色面板。
Color | getColor() 获取颜色选取器的当前颜色值。
boolean | getDragEnabled() 获取 dragEnabled 属性的值。
JComponent | getPreviewPanel() 返回显示选取颜色的预览面板。
ColorSelectionModel | getSelectionModel() 返回处理颜色选择的数据模型。
ColorChooserUI | getUI() 返回呈现此组件的 L&F 对象。
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
protected String | paramString() 返回此 JColorChooser 的字符串表示形式。
AbstractColorChooserPanel | removeChooserPanel(AbstractColorChooserPanel panel) 移除指定的 Color Panel。
void | setChooserPanels(AbstractColorChooserPanel[] panels) 指定用于选取颜色值的 Color Panel。
void | setColor(Color color) 将颜色选取器的当前颜色设置为指定颜色。
void | setColor(int c) 将颜色选取器的当前颜色设置为指定颜色。
void | setColor(int r, int g, int b) 将颜色选取器的当前颜色设置为指定的 RGB 颜色。
void | setDragEnabled(boolean b) 设置 dragEnabled 属性，该属性必须为 true 才能启用对此组件的自动拖动处理（拖放操作的第一部分）。
void | setPreviewPanel(JComponent preview) 设置当前预览面板。
void | setSelectionModel(ColorSelectionModel newModel) 设置包含所选颜色的模型。
void | setUI(ColorChooserUI ui) 设置呈现此组件的 L&F 对象。
static Color | showDialog(Component component, String title, Color initialColor) 显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。
void | updateUI() UIManager 发出的关于 L&F 已更改的通知。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

SELECTION_MODEL_PROPERTY

public static final String SELECTION_MODEL_PROPERTY
选择模型属性名。

另请参见：
常量字段值

PREVIEW_PANEL_PROPERTY

public static final String PREVIEW_PANEL_PROPERTY
预览面板属性名。

另请参见：
常量字段值

CHOOSER_PANELS_PROPERTY

public static final String CHOOSER_PANELS_PROPERTY
chooserPanel 数组属性名。

另请参见：
常量字段值

accessibleContext

protected AccessibleContext accessibleContext
构造方法详细信息

JColorChooser

public JColorChooser()
创建初始颜色为白色的颜色选取器窗格。

JColorChooser

public JColorChooser(Color initialColor)
创建具有指定初始颜色的颜色选取器窗格。

参数：
initialColor - 选取器中的初始颜色设置

JColorChooser

public JColorChooser(ColorSelectionModel model)
创建具有指定 ColorSelectionModel 颜色选取器窗格。

参数：
model - 要使用的 ColorSelectionModel
方法详细信息

showDialog

public static Color showDialog(Component component,
                               String title,
                               Color initialColor)
                        throws HeadlessException
显示有模式的颜色选取器，在隐藏对话框之前一直阻塞。如果用户按下 "OK" 按钮，则此方法隐藏/释放对话框并返回所选颜色。如果用户按下 "Cancel" 按钮或者在没有按 "OK" 的情况下关闭对话框，则此方法将隐藏/释放对话框并返回 null。

参数：
component - 对话框的父 Component
title - 包含对话框标题的 String
initialColor - 显示颜色选取器时的初始 Color 设置
返回：
所选颜色；如果用户退出，则返回 null
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

createDialog

public static JDialog createDialog(Component c,
                                   String title,
                                   boolean modal,
                                   JColorChooser chooserPane,
                                   ActionListener okListener,
                                   ActionListener cancelListener)
                            throws HeadlessException
创建并返回包含指定 ColorChooser 窗格及 "OK"、"Cancel" 和 "Reset" 按钮的新对话框。如果按下 "OK" 或 "Cancel" 按钮，则对话框自动隐藏（但未释放）。如果按下 "Reset" 按钮，则将颜色选取器的颜色重置为上一次在对话框上调用 show 时设置的颜色，并且对话框仍然显示。

参数：
c - 对话框的父组件
title - 对话框的标题
modal - 一个 boolean,为 true 时，在关闭对话框之前，程序的剩余部分将一直处于非激活状态。
chooserPane - 要置于对话框中的颜色选取器
okListener - 按下 "OK" 时调用的 ActionListener
cancelListener - 按下 "Cancel" 时调用的 ActionListener
返回：
包含颜色选取器窗格的新对话框
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

getUI

public ColorChooserUI getUI()
返回呈现此组件的 L&F 对象。

返回：
呈现此组件的 ColorChooserUI 对象

setUI

public void setUI(ColorChooserUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - ColorChooserUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
UIManager 发出的关于 L&F 已更改的通知。根据 UIManager 的最新通知替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "ColorChooserUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getColor

public Color getColor()
获取颜色选取器的当前颜色值。默认情况下，此操作委托给模型。

返回：
颜色选取器的当前颜色值

setColor

public void setColor(Color color)
将颜色选取器的当前颜色设置为指定颜色。ColorSelectionModel 将激发 ChangeEvent

参数：
color - 要在颜色选取器中设置的颜色
另请参见：
Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

setColor

public void setColor(int r,
                     int g,
                     int b)
将颜色选取器的当前颜色设置为指定的 RGB 颜色。注意，红色、绿色和蓝色的值应该介于数字 0 和 255 之间（包括两者）。

参数：
r - 指定 Red 量的 int
g - 指定 Green 量的 int
b - 指定 Blue 量的 int
抛出：
IllegalArgumentException - 如果 r,g,b 值超出范围
另请参见：
Color

setColor

public void setColor(int c)
将颜色选取器的当前颜色设置为指定颜色。

参数：
c - 在选取器中设置当前颜色的整数值，其中 8 个低位指定 Blue 值，接下来的 8 个位指定 Green 值，再往上的 8 个位指定 Red 值。

setDragEnabled

public void setDragEnabled(boolean b)
设置 dragEnabled 属性，该属性必须为 true 才能启用对此组件的自动拖动处理（拖放操作的第一部分）。必须将 transferHandler 属性设置为非 null 值，拖动才有效。dragEnabled 属性的默认值为 false。

启用自动拖动处理时，只要用户在预览面板上按下鼠标按钮，大多数外观就开始拖放操作了。有些外观可能不支持自动拖放；它们将忽略此属性。对于这些外观，可通过修改组件以直接调用 TransferHandler 的 exportAsDrag 方法来处理该问题。

参数：
b - 作为 dragEnabled 属性设置目标的值
抛出：
HeadlessException - 如果 b 为 true 并且 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDragEnabled

public boolean getDragEnabled()
获取 dragEnabled 属性的值。

返回：
dragEnabled 属性的值
从以下版本开始：
1.4
另请参见：
setDragEnabled(boolean)

setPreviewPanel

public void setPreviewPanel(JComponent preview)
设置当前预览面板。此操作将为名为 "previewPanel" 的属性激发 PropertyChangeEvent。

参数：
preview - 显示当前颜色的 JComponent
另请参见：
Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

getPreviewPanel

public JComponent getPreviewPanel()
返回显示选取颜色的预览面板。

返回：
JComponent 对象，即预览面板

addChooserPanel

public void addChooserPanel(AbstractColorChooserPanel panel)
将颜色选取器面板添加到颜色选取器。

参数：
panel - 要添加的 AbstractColorChooserPanel

removeChooserPanel

public AbstractColorChooserPanel removeChooserPanel(AbstractColorChooserPanel panel)
移除指定的 Color Panel。

参数：
panel - 要移除的指定面板的字符串
返回：
颜色面板
抛出：
IllegalArgumentException - 如果面板不在已知选取器面板的列表中

setChooserPanels

public void setChooserPanels(AbstractColorChooserPanel[] panels)
指定用于选取颜色值的 Color Panel。

参数：
panels - AbstractColorChooserPanel 对象的数组

getChooserPanels

public AbstractColorChooserPanel[] getChooserPanels()
返回指定的颜色面板。

返回：
AbstractColorChooserPanel 对象的数组

getSelectionModel

public ColorSelectionModel getSelectionModel()
返回处理颜色选择的数据模型。

返回：
ColorSelectionModel 对象

setSelectionModel

public void setSelectionModel(ColorSelectionModel newModel)
设置包含所选颜色的模型。

参数：
newModel - 新 ColorSelectionModel 对象

paramString

protected String paramString()
返回此 JColorChooser 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JColorChooser 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JColorChooser 关联的 AccessibleContext。对于颜色选取器，AccessibleContext 采用 AccessibleJColorChooser 的形式。如有必要，可创建一个新的 AccessibleJColorChooser 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
充当此 JColorChooser 的 AccessibleContext 的 AccessibleJColorChooser
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JColorChooser.AccessibleJColorChooser (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JColorChooser.AccessibleJColorChooser

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JColorChooser.AccessibleJColorChooser
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JColorChooser
protected class JColorChooser.AccessibleJColorChooser
extends JComponent.AccessibleJComponent

此类实现对 JColorChooser 类的可访问性支持。它提供适合颜色选取器用户界面元素的 Java Accessibility API 实现。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JColorChooser.AccessibleJColorChooser()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JColorChooser.AccessibleJColorChooser

protected JColorChooser.AccessibleJColorChooser()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComboBox (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComboBox

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JComboBox
所有已实现的接口：
ActionListener, ImageObserver, ItemSelectable, MenuContainer, Serializable, EventListener, Accessible, ListDataListener
public class JComboBox
extends JComponent
implements ItemSelectable, ListDataListener, ActionListener, Accessible

将按钮或可编辑字段与下拉列表组合的组件。用户可以从下拉列表中选择值，下拉列表在用户请求时显示。如果使组合框处于可编辑状态，则组合框将包括用户可在其中键入值的可编辑字段。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Combo Boxes 一节。

另请参见：
ComboBoxModel, DefaultComboBoxModel

嵌套类摘要
protected class | JComboBox.AccessibleJComboBox 此类实现 JComboBox 类的可访问性支持。
static interface | JComboBox.KeySelectionManager 定义 KeySelectionManager 的接口。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected String | actionCommand 此受保护字段是特定于实现的。
protected ComboBoxModel | dataModel 此受保护字段是特定于实现的。
protected ComboBoxEditor | editor 此受保护字段是特定于实现的。
protected boolean | isEditable 此受保护字段是特定于实现的。
protected JComboBox.KeySelectionManager | keySelectionManager 此受保护字段是特定于实现的。
protected boolean | lightWeightPopupEnabled 此受保护字段是特定于实现的。
protected int | maximumRowCount 此受保护字段是特定于实现的。
protected ListCellRenderer | renderer 此受保护字段是特定于实现的。
protected Object | selectedItemReminder 此受保护字段是特定于实现的。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JComboBox()
创建具有默认数据模型的 JComboBox。
JComboBox(ComboBoxModel aModel)
创建一个 JComboBox，其项取自现有的 ComboBoxModel。
JComboBox(Object[] items)
创建包含指定数组中的元素的 JComboBox。
JComboBox(Vector<?> items)
创建包含指定 Vector 中的元素的 JComboBox。
方法摘要
 void actionPerformed(ActionEvent e)
此方法由于实现的副作用而存在的公共方法。
protected  void actionPropertyChanged(Action action, String propertyName)
更新组合框的状态以响应关联动作中的属性更改。
 void addActionListener(ActionListener l)
添加 ActionListener。
 void addItem(Object anObject)
为项列表添加项。
 void addItemListener(ItemListener aListener)
添加 ItemListener。
 void addPopupMenuListener(PopupMenuListener l)
添加 PopupMenu 侦听器，该侦听器将侦听取自组合框弹出部分的通知消息。
 void configureEditor(ComboBoxEditor anEditor, Object anItem)
利用指定项初始化编辑器。
protected  void configurePropertiesFromAction(Action a)
在此组合框上设置属性以匹配指定 Action 中的属性。
 void contentsChanged(ListDataEvent e)
此方法作为实现的副作用存在的公共方法。
protected  PropertyChangeListener createActionPropertyChangeListener(Action a)
创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。
protected  JComboBox.KeySelectionManager createDefaultKeySelectionManager()
返回默认键选择管理器的实例。
protected  void fireActionEvent()
通知所有需要此事件类型的通知的已注册侦听器。
protected  void fireItemStateChanged(ItemEvent e)
通知所有需要此事件类型的通知的已注册侦听器。
 void firePopupMenuCanceled()
通知 PopupMenuListener 组合框的弹出部分已被取消。
 void firePopupMenuWillBecomeInvisible()
通知 PopupMenuListener 组合框的弹出部分已变得不可见。
 void firePopupMenuWillBecomeVisible()
通知 PopupMenuListener 组合框的弹出部分将变得可见。
 AccessibleContext getAccessibleContext()
获取与此 JComboBox 关联的 AccessibleContext。
 Action getAction()
返回此 ActionEvent 源当前设置的 Action，如果没有设置任何 Action，则返回 null。
 String getActionCommand()
返回发送到动作侦听器的事件中包括的动作命令。
 ActionListener[] getActionListeners()
返回使用 addActionListener() 添加到此 JComboBox 的所有 ActionListener 组成的数组。
 ComboBoxEditor getEditor()
返回用于绘制和编辑 JComboBox 字段中所选项的编辑器。
 Object getItemAt(int index)
返回指定索引处的列表项。
 int getItemCount()
返回列表中的项数。
 ItemListener[] getItemListeners()
返回使用 addItemListener() 添加到此 JComboBox 中的所有 ItemListener 组成的数组。
 JComboBox.KeySelectionManager getKeySelectionManager()
返回列表的键选择管理器。
 int getMaximumRowCount()
返回组合框不使用滚动条可以显示的最大项数
 ComboBoxModel getModel()
返回 JComboBox 当前使用的数据模型。
 PopupMenuListener[] getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JComboBox 的所有 PopupMenuListener 组成的数组。
 Object getPrototypeDisplayValue()
返回“原型显示”值，即用于计算显示高度和宽度的 Object。
 ListCellRenderer getRenderer()
返回用于显示 JComboBox 字段中所选项的渲染器。
 int getSelectedIndex()
返回列表中与给定项匹配的第一个选项。
 Object getSelectedItem()
返回当前所选项。
 Object[] getSelectedObjects()
返回包含所选项的数组。
 ComboBoxUI getUI()
返回呈现此组件的 L&F 对象。
 String getUIClassID()
返回呈现此组件的 L&F 类的名称。
 void hidePopup()
促使组合框关闭其弹出窗口。
 void insertItemAt(Object anObject, int index)
在项列表中的给定索引处插入项。
protected  void installAncestorListener()
 void intervalAdded(ListDataEvent e)
此方法作为实现的副作用存在的公共方法。
 void intervalRemoved(ListDataEvent e)
此方法作为实现的副作用存在的公共方法。
 boolean isEditable()
如果 JComboBox 可编辑，则返回 true。
 boolean isLightWeightPopupEnabled()
获取 lightWeightPopupEnabled 属性的值。
 boolean isPopupVisible()
确定弹出窗口的可见性。
protected  String paramString()
返回此 JComboBox 的字符串表示形式。
 void processKeyEvent(KeyEvent e)
处理 KeyEvent，查找 Tab 键。
 void removeActionListener(ActionListener l)
移除 ActionListener。
 void removeAllItems()
从项列表中移除所有项。
 void removeItem(Object anObject)
从项列表中移除项。
 void removeItemAt(int anIndex)
移除 anIndex 处的项。
 void removeItemListener(ItemListener aListener)
移除 ItemListener。
 void removePopupMenuListener(PopupMenuListener l)
移除 PopupMenuListener。
protected  void selectedItemChanged()
此受保护方法是特定于实现的。
 boolean selectWithKeyChar(char keyChar)
如果存在与指定键盘字符相对应的项，则选择该列表项并返回 true。
 void setAction(Action a)
设置 ActionEvent 源的 Action。
 void setActionCommand(String aCommand)
设置发送到动作侦听器的事件中应该包括的动作命令。
 void setEditable(boolean aFlag)
确定 JComboBox 字段是否可编辑。
 void setEditor(ComboBoxEditor anEditor)
设置用于绘制和编辑 JComboBox 字段中所选项的编辑器。
 void setEnabled(boolean b)
启用组合框以便可以选择项。
 void setKeySelectionManager(JComboBox.KeySelectionManager aManager)
设置将键盘字符转换为列表选择的对象。
 void setLightWeightPopupEnabled(boolean aFlag)
设置 lightWeightPopupEnabled 属性，该属性提供一个提示：是应该使用重量级 Component（如 Panel 或 Window）还是轻量级 Component 来包含 JComboBox。
 void setMaximumRowCount(int count)
设置 JComboBox 显示的最大行数。
 void setModel(ComboBoxModel aModel)
设置 JComboBox 用于获取项列表的数据模型。
 void setPopupVisible(boolean v)
设置弹出窗口的可见性。
 void setPrototypeDisplayValue(Object prototypeDisplayValue)
设置用于计算 UI 部分的显示大小的原型显示值。
 void setRenderer(ListCellRenderer aRenderer)
设置渲染器，该渲染器用于绘制列表项和从 JComboBox 字段的列表中选择的项。
 void setSelectedIndex(int anIndex)
选择索引 anIndex 处的项。
 void setSelectedItem(Object anObject)
将组合框显示区域中所选项设置为参数中的对象。
 void setUI(ComboBoxUI ui)
设置呈现此组件的 L&F 对象。
 void showPopup()
促使组合框显示其弹出窗口。
 void updateUI()
将 UI 属性重置为当前外观的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

dataModel

protected ComboBoxModel dataModel
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
getModel(), setModel(javax.swing.ComboBoxModel)

renderer

protected ListCellRenderer renderer
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
getRenderer(), setRenderer(javax.swing.ListCellRenderer)

editor

protected ComboBoxEditor editor
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
getEditor(), setEditor(javax.swing.ComboBoxEditor)

maximumRowCount

protected int maximumRowCount
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
getMaximumRowCount(), setMaximumRowCount(int)

isEditable

protected boolean isEditable
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
isEditable, setEditable(boolean)

keySelectionManager

protected JComboBox.KeySelectionManager keySelectionManager
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
setKeySelectionManager(javax.swing.JComboBox.KeySelectionManager), getKeySelectionManager()

actionCommand

protected String actionCommand
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
setActionCommand(java.lang.String), getActionCommand()

lightWeightPopupEnabled

protected boolean lightWeightPopupEnabled
此受保护字段是特定于实现的。不要直接访问或重写。要使用存取方法。

另请参见：
setLightWeightPopupEnabled(boolean), isLightWeightPopupEnabled()

selectedItemReminder

protected Object selectedItemReminder
此受保护字段是特定于实现的。不要直接访问或重写。

构造方法详细信息

JComboBox

public JComboBox(ComboBoxModel aModel)
创建一个 JComboBox，其项取自现有的 ComboBoxModel。由于提供了 ComboBoxModel，使用此构造方法创建的组合框不创建默认组合框模型，这可能影响插入、移除和添加方法的行为方式。

参数：
aModel - 提供显示的项列表的 ComboBoxModel
另请参见：
DefaultComboBoxModel

JComboBox

public JComboBox(Object[] items)
创建包含指定数组中的元素的 JComboBox。默认情况下，选择数组中的第一项（因而也选择了该项的数据模型）。

参数：
items - 要插入到组合框的对象数组
另请参见：
DefaultComboBoxModel

JComboBox

public JComboBox(Vector<?> items)
创建包含指定 Vector 中的元素的 JComboBox。默认情况下，选择数组中的第一项（因而也选择了该项的数据模型）。

参数：
items - 要插入到组合框的向量数组
另请参见：
DefaultComboBoxModel

JComboBox

public JComboBox()
创建具有默认数据模型的 JComboBox。默认的数据模型为空对象列表。使用 addItem 添加项。默认情况下，选择数据模型中的第一项。

另请参见：
DefaultComboBoxModel
方法详细信息

installAncestorListener

protected void installAncestorListener()

setUI

public void setUI(ComboBoxUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - ComboBoxUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
将 UI 属性重置为当前外观的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串“ComboBoxUI”
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getUI

public ComboBoxUI getUI()
返回呈现此组件的 L&F 对象。

返回：
呈现此组件的 ComboBoxUI 对象。

setModel

public void setModel(ComboBoxModel aModel)
设置 JComboBox 用于获取项列表的数据模型。

参数：
aModel - 提供显示的项列表的 ComboBoxModel

getModel

public ComboBoxModel getModel()
返回 JComboBox 当前使用的数据模型。

返回：
提供显示的项列表的 ComboBoxModel

setLightWeightPopupEnabled

public void setLightWeightPopupEnabled(boolean aFlag)
设置 lightWeightPopupEnabled 属性，该属性提供一个提示：是应该使用重量级 Component（如 Panel 或 Window）还是轻量级 Component 来包含 JComboBox。使用轻量级还是重量级组件，最终由 JComboBox 决定。轻量级窗口比重量级窗口更有效，但是轻量级和重量级组件在 GUI 中不能很好地混合使用。如果应用程序混合使用轻量级和重量级组件，则应该禁用轻量级弹出窗口。除非由外观另行指定，否则 lightWeightPopupEnabled 属性的默认值为 true。某些外观始终使用重量级弹出窗口，不管此属性的值如何。

请参阅 The Swing Connection 上的文章 Mixing Heavy and Light Components。此方法触发属性更改事件。

参数：
aFlag - 如果为 true，则需要轻量级弹出窗口

isLightWeightPopupEnabled

public boolean isLightWeightPopupEnabled()
获取 lightWeightPopupEnabled 属性的值。

返回：
lightWeightPopupEnabled 属性的值
另请参见：
setLightWeightPopupEnabled(boolean)

setEditable

public void setEditable(boolean aFlag)
确定 JComboBox 字段是否可编辑。可编辑的 JComboBox 允许用户在字段中键入内容或者从列表中选择项来初始化字段，执行此操作后，该字段就可编辑了。（编辑仅影响字段，列表项保持原样。）不可编辑的 JComboBox 在字段中显示所选项，但不能修改该选择。

参数：
aFlag - 一个 boolean 值，其中 true 指示字段可编辑。

isEditable

public boolean isEditable()
如果 JComboBox 可编辑，则返回 true。默认情况下，组合框不可编辑。

返回：
如果 JComboBox 可编辑，则返回 true；否则返回 false

setMaximumRowCount

public void setMaximumRowCount(int count)
设置 JComboBox 显示的最大行数。如果模型中的对象数大于 count，则组合框使用滚动条。

参数：
count - 一个整数，它指定使用滚动条前要在列表中显示的最大项数

getMaximumRowCount

public int getMaximumRowCount()
返回组合框不使用滚动条可以显示的最大项数

返回：
一个整数，它指定使用滚动条前列表中显示的最大项数

setRenderer

public void setRenderer(ListCellRenderer aRenderer)
设置渲染器，该渲染器用于绘制列表项和从 JComboBox 字段的列表中选择的项。该渲染器在 JComboBox 不可编辑时使用。如果其可编辑，则使用编辑器呈现和编辑所选项。

默认渲染器显示字符串或图标。其他渲染器可处理图形图像和复合选项。

要显示所选项，请调用 aRenderer.getListCellRendererComponent，其中传递列表对象和索引 -1。

参数：
aRenderer - 显示所选项的 ListCellRenderer
另请参见：
setEditor(javax.swing.ComboBoxEditor)

getRenderer

public ListCellRenderer getRenderer()
返回用于显示 JComboBox 字段中所选项的渲染器。

返回：
显示所选项的 ListCellRenderer。

setEditor

public void setEditor(ComboBoxEditor anEditor)
设置用于绘制和编辑 JComboBox 字段中所选项的编辑器。仅当接收的 JComboBox 可编辑时才使用编辑器。如果不可编辑，则组合框使用渲染器绘制所选项。

参数：
anEditor - 显示所选项的 ComboBoxEditor
另请参见：
setRenderer(javax.swing.ListCellRenderer)

getEditor

public ComboBoxEditor getEditor()
返回用于绘制和编辑 JComboBox 字段中所选项的编辑器。

返回：
显示所选项的 ComboBoxEditor。

setSelectedItem

public void setSelectedItem(Object anObject)
将组合框显示区域中所选项设置为参数中的对象。如果 anObject 在列表中，则显示区域显示所选的 anObject。

如果 anObject 不 在列表中，且组合框不可编辑，则不会更改显示区域中的当前选择。对于可编辑的组合框，选择将更改为 anObject。

如果此操作造成所选项发生更改，则添加到组合框的 ItemListener 将获得一个或两个 ItemEvent 通知。如果有当前所选项，则将触发 ItemEvent，而状态更改将为 ItemEvent.DESELECTED。如果 anObject 在列表中，但不是当前选择的项，则将触发 ItemEvent，而状态更改将为 ItemEvent.SELECTED。

调用此方法时，添加到组合框的 ActionListener 将获得 ActionEvent 通知。

参数：
anObject - 要选择的列表对象；使用 null 清除选择

getSelectedItem

public Object getSelectedItem()
返回当前所选项。

如果组合框可编辑，则可能尚未使用 addItem、insertItemAt 或数据构造方法将此值添加到组合框中。

返回：
当前选择的 Object
另请参见：
setSelectedItem(java.lang.Object)

setSelectedIndex

public void setSelectedIndex(int anIndex)
选择索引 anIndex 处的项。

参数：
anIndex - 指定要选择的列表项的整数，其中 0 指定列表中的第一项，-1 指示没有作出选择
抛出：
IllegalArgumentException - 如果 anIndex < -1 或者 anIndex 大于等于列表大小

getSelectedIndex

public int getSelectedIndex()
返回列表中与给定项匹配的第一个选项。如果 JComboBox 允许选择不在列表中的项，则结果并非不总是确定的。如果不存在所选项或者用户指定的项不在列表中，则返回 -1。

返回：
指定当前选择的列表项的整数，其中 0 指定列表中的第一项；如果没有选择任何项或者当前所选项不在列表中，则返回 -1

getPrototypeDisplayValue

public Object getPrototypeDisplayValue()
返回“原型显示”值，即用于计算显示高度和宽度的 Object。

返回：
prototypeDisplayValue 属性的值
从以下版本开始：
1.4
另请参见：
setPrototypeDisplayValue(java.lang.Object)

setPrototypeDisplayValue

public void setPrototypeDisplayValue(Object prototypeDisplayValue)
设置用于计算 UI 部分的显示大小的原型显示值。

如果指定了原型显示值，则组合框首选大小的计算方式是：利用原型显示值配置渲染器，然后获取其首选大小。指定首选显示值在组合框将显示大量数据时往往很有用。如果没有指定原型显示值，则必须为模型中的每个值及其获取的首选大小配置渲染器，其花费相对昂贵。

参数：
prototypeDisplayValue -
从以下版本开始：
1.4
另请参见：
getPrototypeDisplayValue()

addItem

public void addItem(Object anObject)
为项列表添加项。仅当 JComboBox 使用可变数据模型时此方法才有效。

警告：如果添加复制的 String 对象，可能会发生焦点和键盘导航问题。解决方法是，添加新对象而不是 String 对象，并且确保定义了 toString() 方法。例如：

   comboBox.addItem(makeObj("Item 1"));
   comboBox.addItem(makeObj("Item 1"));
   ...
   private Object makeObj(final String item)  {
     return new Object() { public String toString() { return item; } };
   }

参数：
anObject - 要添加到列表的 Object
另请参见：
MutableComboBoxModel

insertItemAt

public void insertItemAt(Object anObject,
                         int index)
在项列表中的给定索引处插入项。仅当 JComboBox 使用可变数据模型时此方法才有效。

参数：
anObject - 要添加到列表的 Object
index - 指定添加项的位置的整数
另请参见：
MutableComboBoxModel

removeItem

public void removeItem(Object anObject)
从项列表中移除项。仅当 JComboBox 使用可变数据模型时此方法才有效。

参数：
anObject - 要从项列表中移除的对象
另请参见：
MutableComboBoxModel

removeItemAt

public void removeItemAt(int anIndex)
移除 anIndex 处的项。仅当 JComboBox 使用可变数据模型时此方法才有效。

参数：
anIndex - 指定要移除的项索引的 int，其中 0 指示列表中的第一项
另请参见：
MutableComboBoxModel

removeAllItems

public void removeAllItems()
从项列表中移除所有项。

showPopup

public void showPopup()
促使组合框显示其弹出窗口。

另请参见：
setPopupVisible(boolean)

hidePopup

public void hidePopup()
促使组合框关闭其弹出窗口。

另请参见：
setPopupVisible(boolean)

setPopupVisible

public void setPopupVisible(boolean v)
设置弹出窗口的可见性。

isPopupVisible

public boolean isPopupVisible()
确定弹出窗口的可见性。

返回：
如果弹出窗口可见，则返回 true；否则返回 false

addItemListener

public void addItemListener(ItemListener aListener)
添加 ItemListener。

当所选项更改时，aListener 将接收一个或两个 ItemEvent。

指定者：
接口 ItemSelectable 中的 addItemListener
参数：
aListener - 要通知的 ItemListener
另请参见：
setSelectedItem(java.lang.Object)

removeItemListener

public void removeItemListener(ItemListener aListener)
移除 ItemListener。

指定者：
接口 ItemSelectable 中的 removeItemListener
参数：
aListener - 要移除的 ItemListener
另请参见：
ItemEvent

getItemListeners

public ItemListener[] getItemListeners()
返回使用 addItemListener() 添加到此 JComboBox 中的所有 ItemListener 组成的数组。

返回：
添加的所有 ItemListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

addActionListener

public void addActionListener(ActionListener l)
添加 ActionListener。

当作出选择时，ActionListener 将接收一个 ActionEvent。如果组合框可编辑，则在编辑停止时将触发 ActionEvent。

参数：
l - 要通知的 ActionListener
另请参见：
setSelectedItem(java.lang.Object)

removeActionListener

public void removeActionListener(ActionListener l)
移除 ActionListener。

参数：
l - 要移除的 ActionListener

getActionListeners

public ActionListener[] getActionListeners()
返回使用 addActionListener() 添加到此 JComboBox 的所有 ActionListener 组成的数组。

返回：
所有添加的 ActionListener；如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

addPopupMenuListener

public void addPopupMenuListener(PopupMenuListener l)
添加 PopupMenu 侦听器，该侦听器将侦听取自组合框弹出部分的通知消息。

对于 Java 附带的所有标准外观，组合框的弹出列表部分将被实现为 JPopupMenu。自定义外观可能不以这种方式实现组合框的弹出列表部分，因此不接收通知。

参数：
l - 要添加的 PopupMenuListener
从以下版本开始：
1.4

removePopupMenuListener

public void removePopupMenuListener(PopupMenuListener l)
移除 PopupMenuListener。

参数：
l - 要移除的 PopupMenuListener
从以下版本开始：
1.4
另请参见：
addPopupMenuListener(javax.swing.event.PopupMenuListener)

getPopupMenuListeners

public PopupMenuListener[] getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JComboBox 的所有 PopupMenuListener 组成的数组。

返回：
所有添加的 PopupMenuListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

firePopupMenuWillBecomeVisible

public void firePopupMenuWillBecomeVisible()
通知 PopupMenuListener 组合框的弹出部分将变得可见。

此方法是公共方法，但只能由 UI 委托调用。

从以下版本开始：
1.4
另请参见：
addPopupMenuListener(javax.swing.event.PopupMenuListener)

firePopupMenuWillBecomeInvisible

public void firePopupMenuWillBecomeInvisible()
通知 PopupMenuListener 组合框的弹出部分已变得不可见。

此方法是公共方法，但只能由 UI 委托调用。

从以下版本开始：
1.4
另请参见：
addPopupMenuListener(javax.swing.event.PopupMenuListener)

firePopupMenuCanceled

public void firePopupMenuCanceled()
通知 PopupMenuListener 组合框的弹出部分已被取消。

此方法是公共方法，但只能由 UI 委托调用。

从以下版本开始：
1.4
另请参见：
addPopupMenuListener(javax.swing.event.PopupMenuListener)

setActionCommand

public void setActionCommand(String aCommand)
设置发送到动作侦听器的事件中应该包括的动作命令。

参数：
aCommand - 包含发送到动作侦听器的“命令”的字符串；根据其所接受的命令，相同的侦听器可以做不同的事情

getActionCommand

public String getActionCommand()
返回发送到动作侦听器的事件中包括的动作命令。

返回：
包含发送到动作侦听器的“命令”的字符串。

setAction

public void setAction(Action a)
设置 ActionEvent 源的 Action。新的 Action 替换以前设置的所有 Action，而不影响通过 addActionListener 独立添加的 ActionListener。如果 Action 已经是一个注册到 ActionEvent 源的 ActionListener，则不对它进行重新注册。

设置 Action 将导致立即更改支持 Action 的 Swing 组件中所描述的所有属性。随后，组合框的属性将随 Action 属性的更改自动更新。

此方法使用三个其他方法来设置和帮助跟踪 Action 的属性值。它使用 configurePropertiesFromAction 方法立即更改组合框的属性。要跟踪 Action 属性值的更改，此方法应注册 createActionPropertyChangeListener 所返回的 PropertyChangeListener。当 Action 中的属性更改时，默认 PropertyChangeListener 调用 actionPropertyChanged 方法。

参数：
a - JComboBox 的 Action，或者 null。
从以下版本开始：
1.3
另请参见：
Action,
getAction(),
configurePropertiesFromAction(javax.swing.Action),
createActionPropertyChangeListener(javax.swing.Action),
actionPropertyChanged(javax.swing.Action, java.lang.String)

getAction

public Action getAction()
返回此 ActionEvent 源当前设置的 Action，如果没有设置任何 Action，则返回 null。

返回：
此 ActionEvent 源的 Action；或者 null
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

configurePropertiesFromAction

protected void configurePropertiesFromAction(Action a)
在此组合框上设置属性以匹配指定 Action 中的属性。有关设置何种属性的更多信息，请参阅支持 Action 的 Swing 组件。

参数：
a - 从其获取属性的 Action，或者 null
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

createActionPropertyChangeListener

protected PropertyChangeListener createActionPropertyChangeListener(Action a)
创建并返回一个 PropertyChangeListener，它负责侦听指定 Action 的更改并更新适当属性。

警告：如果子类化此方法，则不要创建匿名内部类。如果执行组合框的生存期，则它将被绑定到 Action 的生存期。

参数：
a - 组合框的动作
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

actionPropertyChanged

protected void actionPropertyChanged(Action action,
                                     String propertyName)
更新组合框的状态以响应关联动作中的属性更改。从 createActionPropertyChangeListener 所返回的 PropertyChangeListener 中调用此方法。子类通常不需要调用此方法。支持其他 Action 属性的子类应该重写此方法和 configurePropertiesFromAction。

有关此方法设置的属性列表，请参阅支持的 Action 的 Swing 组件下的表。

参数：
action - 与此组合框关联的 Action
propertyName - 更改的属性名称
从以下版本开始：
1.6
另请参见：
Action, configurePropertiesFromAction(javax.swing.Action)

fireItemStateChanged

protected void fireItemStateChanged(ItemEvent e)
通知所有需要此事件类型的通知的已注册侦听器。

参数：
e - 需要的事件
另请参见：
EventListenerList

fireActionEvent

protected void fireActionEvent()
通知所有需要此事件类型的通知的已注册侦听器。

另请参见：
EventListenerList

selectedItemChanged

protected void selectedItemChanged()
此受保护方法是特定于实现的。不要直接访问或重写。

getSelectedObjects

public Object[] getSelectedObjects()
返回包含所选项的数组。实现此方法是为了与 ItemSelectable 兼容。

指定者：
接口 ItemSelectable 中的 getSelectedObjects
返回：
包含一个元素（所选项）的 Object 数组

actionPerformed

public void actionPerformed(ActionEvent e)
此方法由于实现的副作用而存在的公共方法。不要调用或重写。

指定者：
接口 ActionListener 中的 actionPerformed

contentsChanged

public void contentsChanged(ListDataEvent e)
此方法作为实现的副作用存在的公共方法。不要调用或重写。

指定者：
接口 ListDataListener 中的 contentsChanged
参数：
e - 封装事件信息的 ListDataEvent

intervalAdded

public void intervalAdded(ListDataEvent e)
此方法作为实现的副作用存在的公共方法。不要调用或重写。

指定者：
接口 ListDataListener 中的 intervalAdded
参数：
e - 封装事件信息的 ListDataEvent

intervalRemoved

public void intervalRemoved(ListDataEvent e)
此方法作为实现的副作用存在的公共方法。不要调用或重写。

指定者：
接口 ListDataListener 中的 intervalRemoved
参数：
e - 封装事件信息的 ListDataEvent

selectWithKeyChar

public boolean selectWithKeyChar(char keyChar)
如果存在与指定键盘字符相对应的项，则选择该列表项并返回 true。否则，返回 false。

参数：
keyChar - 一个 char，它通常是用户键入的键盘键

setEnabled

public void setEnabled(boolean b)
启用组合框以便可以选择项。禁用组合框时，无法选择项并且无法在其字段中键入值（如果它是可编辑的）。

覆盖：
类 JComponent 中的 setEnabled
参数：
b - 一个 boolean 值，为 true 时，启用该组件，为 false 时，禁用该组件
另请参见：
Component.isEnabled(), Component.isLightweight()

configureEditor

public void configureEditor(ComboBoxEditor anEditor,
                            Object anItem)
利用指定项初始化编辑器。

参数：
anEditor - 显示组合框字段中的列表项，并可以对其进行编辑的 ComboBoxEditor
anItem - 要在字段中显示和编辑的对象

processKeyEvent

public void processKeyEvent(KeyEvent e)
处理 KeyEvent，查找 Tab 键。如果找不到 Tab 键，则关闭弹出窗口。

覆盖：
类 JComponent 中的 processKeyEvent
参数：
e - 包含按下的键盘键的 KeyEvent
另请参见：
KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

setKeySelectionManager

public void setKeySelectionManager(JComboBox.KeySelectionManager aManager)
设置将键盘字符转换为列表选择的对象。通常，第一个字符匹配的第一个选择将成为所选项。

getKeySelectionManager

public JComboBox.KeySelectionManager getKeySelectionManager()
返回列表的键选择管理器。

返回：
当前使用的 KeySelectionManager

getItemCount

public int getItemCount()
返回列表中的项数。

返回：
等于列表中项数的整数

getItemAt

public Object getItemAt(int index)
返回指定索引处的列表项。如果 index 超出范围（小于零或者大于等于列表大小），则返回 null。

参数：
index - 指示列表位置的整数，其中第一项从零开始
返回：
该列表位置上的 Object；如果超出范围，则返回 null

createDefaultKeySelectionManager

protected JComboBox.KeySelectionManager createDefaultKeySelectionManager()
返回默认键选择管理器的实例。

返回：
列表当前使用的 KeySelectionManager
另请参见：
setKeySelectionManager(javax.swing.JComboBox.KeySelectionManager)

paramString

protected String paramString()
返回此 JComboBox 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JComboBox 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JComboBox 关联的 AccessibleContext。对于组合框，AccessibleContext 采用 AccessibleJComboBox 的形式。如有必要，可创建一个新的 AccessibleJComboBox 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
充当此 JComboBox 的 AccessibleContext 的 AccessibleJComboBox
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComboBox.AccessibleJComboBox (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComboBox.AccessibleJComboBox

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JComboBox.AccessibleJComboBox
所有已实现的接口：
Serializable, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection
正在封闭类：
JComboBox
protected class JComboBox.AccessibleJComboBox
extends JComponent.AccessibleJComponent
implements AccessibleAction, AccessibleSelection

此类实现 JComboBox 类的可访问性支持。它提供适合组合框用户界面元素的 Java Accessibility API 实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
JComboBox.AccessibleJComboBox()
返回 AccessibleJComboBox 实例
方法摘要
void | addAccessibleSelection(int i) 将该对象的指定 Accessible 子对象添加到该对象的选择中。
void | clearAccessibleSelection() 清除对象中的选择，使对象中任何子对象都未被选中。
boolean | doAccessibleAction(int i) 对该对象执行指定的 Action
AccessibleAction | getAccessibleAction() 获取与此对象关联的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可用 Action 的数量。
String | getAccessibleActionDescription(int i) 返回该对象的指定操作的描述。
Accessible | getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
int | getAccessibleChildrenCount() 返回对象中可访问的子级数。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回表示弹出对象中指定选择子级的 Accessible。
int | getAccessibleSelectionCount() 返回当前选定的 Accessible 子对象数。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
boolean | isAccessibleChildSelected(int i) 确定是否选定此对象的当前子对象。
void | removeAccessibleSelection(int i) 从对象的选择中移除对象的指定子对象。
void | selectAllAccessibleSelection() 如果对象支持多个选择，则导致选定对象中的所有子对象。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JComboBox.AccessibleJComboBox

public JComboBox.AccessibleJComboBox()
返回 AccessibleJComboBox 实例

从以下版本开始：
1.4
方法详细信息

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中可访问的子级数。如果此对象的所有子级都实现 Accessible，则此方法应该返回此对象的子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子对象数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个可访问子级。索引零处的子级表示弹出对象。如果组合框可编辑，则索引 1 处的子级表示编辑器。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
对象的第 n 个可访问子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。对象的 AccessibleStateSet 由一组惟一的 AccessibleState 组成。对象的 AccessibleStateSet 中的更改将导致激发 ACCESSIBLE_STATE_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象的当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, JComponent.AccessibleJComponent.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的 AccessibleAction。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其自身实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回该对象的指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 该操作的从零开始的索引
返回：
动作的 String 描述
另请参见：
AccessibleAction.getAccessibleActionCount()

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可用 Action 的数量。组合框的默认行为是进行一次操作。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
1，此对象中的 Action 数

doAccessibleAction

public boolean doAccessibleAction(int i)
对该对象执行指定的 Action

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从零开始的索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象相关联的 AccessibleSelection。在此类的 Java Accessibility API 的实现中，返回的是此对象，它负责为其本身实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选定的 Accessible 子对象数。如果没有选定子对象，那么返回的值将为 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选定的项数。
从以下版本开始：
1.3

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回表示弹出对象中指定选择子级的 Accessible。如果没有选择，或者所选子级数少于传入的整数，则返回值为 null。

注意，该索引表示第 i 个选定的子对象，它不同于第 i 个子对象。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选子对象的从零开始的索引
返回：
第 i 个选定的子对象
从以下版本开始：
1.3
另请参见：
getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
确定是否选定此对象的当前子对象。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象中子对象的从零开始的索引。
返回：
如果选定此对象的当前子对象，则返回 true；否则，返回 false
从以下版本开始：
1.3
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将该对象的指定 Accessible 子对象添加到该对象的选择中。如果该对象支持多个选择，则将指定的子对象添加到任何现有选择中，否则，它会替换该对象中的任何现有选择。如果指定的子对象已被选定，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 子对象的从零开始的索引
从以下版本开始：
1.3
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从对象的选择中移除对象的指定子对象。如果当前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 子对象的从零开始的索引
从以下版本开始：
1.3
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，使对象中任何子对象都未被选中。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection
从以下版本开始：
1.3

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
如果对象支持多个选择，则导致选定对象中的所有子对象。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComboBox.KeySelectionManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 JComboBox.KeySelectionManager

正在封闭类：
JComboBox
public static interface JComboBox.KeySelectionManager

定义 KeySelectionManager 的接口。要取得 KeySelectionManager 的资格，类需要实现标识给定字符和组合数据模型的列表索引的方法。

方法摘要
 int selectionForKey(char aKey, ComboBoxModel aModel)
给定的 aKey 和模型返回应该被选择的行。

方法详细信息

selectionForKey

int selectionForKey(char aKey,
                    ComboBoxModel aModel)
给定的 aKey 和模型返回应该被选择的行。如果找不到匹配项，则返回 -1。

参数：
aKey - 一个 char 值，通常指示按下的键盘键
aModel - ComboBoxModel，即组件的数据模型，包含可选项的列表
返回：
等于选定行的 int，其中 0 是第一项，-1 表示什么也没有。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComponent

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
所有已实现的接口：
ImageObserver, MenuContainer, Serializable
直接已知子类：
AbstractButton, BasicInternalFrameTitlePane, Box, Box.Filler, JColorChooser, JComboBox, JFileChooser, JInternalFrame, JInternalFrame.JDesktopIcon, JLabel, JLayeredPane, JList, JMenuBar, JOptionPane, JPanel, JPopupMenu, JProgressBar, JRootPane, JScrollBar, JScrollPane, JSeparator, JSlider, JSpinner, JSplitPane, JTabbedPane, JTable, JTableHeader, JTextComponent, JToolBar, JToolTip, JTree, JViewport
public abstract class JComponent
extends Container
implements Serializable

该类是除顶层容器外所有 Swing 组件的基类。要使用继承自 JComponent 的组件，必须将该组件置于一个根为顶层 Swing 容器的包含层次结构（containment hierarchy）中。顶层 Swing 容器（如 JFrame、JDialog 和 JApplet）是专门为其他 Swing 组件提供绘制自身场所的组件。有关包含层次结构的解释，请参阅 The Java Tutorial 中的 Swing Components and the Containment Hierarchy 一节。

JComponent 类提供：

  • 使用 Swing 架构的标准组件和自定义组件的基类。
  • 可由程序员指定，或者由用户在运行时选择（可选）的“可插入外观”(L&F)。每个组件的外观都由 UI 委托 提供，UI 委托是一个继承自 ComponentUI 的对象。有关更多信息，请参阅 The Java Tutorial 中的 How to Set the Look and Feel。
  • 全面的键击处理。有关更多信息，请参阅 The Swing Connection 中的文档 Keyboard Bindings in Swing。
  • 对工具提示的支持：光标停留在组件时所弹出的简短描述。有关更多信息，请参阅 The Java Tutorial 中的 How to Use Tool Tips。
  • 可访问性支持。JComponent 包含 Accessible 接口中的所有方法，但是它实际上不实现该接口。由扩展 JComponent 的每个类负责实现该接口。
  • 对特定于组件属性的支持。通过 putClientProperty(java.lang.Object, java.lang.Object) 和 getClientProperty(java.lang.Object) 方法，可以将“名称-对象”对与继承自 JComponent 的任意对象进行关联。
  • 用于绘制的基础设施，包括双缓冲和对边框的支持。有关更多信息，请参阅 The Java Tutorial 中的 Painting 和 How to Use Borders 章节。
有关这些主题的更多信息，请参阅 Swing 包描述和 The Java Tutorial 中的 The JComponent Class 一节。

JComponent 及其子类记录了某些属性的默认值。例如，JTable 记录的默认行高为 16。每个具有 ComponentUI 的 JComponent 子类都将创建该 ComponentUI 作为其构造方法的一部分。为了提供特定的外观，每个 ComponentUI 都可以在创建它的 JComponent 上设置各种属性。例如，自定义的外观可能要求 JTable 的行高为 24。而所记录的默认值是安装 ComponentUI 前的属性值。如果需要为特定的属性使用具体值，则应该显式地设置它。

在版本 1.4 中，重新设计了焦点子系统。有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
KeyStroke, Action, setBorder(javax.swing.border.Border), registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int), JOptionPane, setDebugGraphicsOptions(int), setToolTipText(java.lang.String), setAutoscrolls(boolean)

嵌套类摘要
 class JComponent.AccessibleJComponent
用于为可访问性提供默认支持的 JComponent 内部类。
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected AccessibleContext | accessibleContext 与此 JComponent 关联的 AccessibleContext。
protected EventListenerList | listenerList 此组件的事件侦听器列表。
static String | TOOL_TIP_TEXT_KEY 光标位于组件上方时显示的注释，也称为“值提示”、“相交提示 (flyover help)”或“相交标签 (flyover label)”。
protected ComponentUI | ui 此组件的外观委托。
static int | UNDEFINED_CONDITION 某些 API 使用的常量，意味着没有定义任何条件。
static int | WHEN_ANCESTOR_OF_FOCUSED_COMPONENT 用于 registerKeyboardAction 的常量，意味着当接收组件是获得焦点的组件的祖先或者其本身就是获得焦点的组件时，应该调用命令。
static int | WHEN_FOCUSED 用于 registerKeyboardAction 的常量，意味着在组件获得焦点时应该调用命令。
static int | WHEN_IN_FOCUSED_WINDOW 用于 registerKeyboardAction 的常量，意味着当接收组件处于获得焦点的窗口内或者其本身就是获得焦点的组件时，应该调用命令。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JComponent()
默认的 JComponent 构造方法。
方法摘要
 void addAncestorListener(AncestorListener listener)
注册 listener，从而当组件或其任意祖先移动，或者变得可见或不可见时该侦听器将收到 AncestorEvent。
 void addNotify()
通知此组件它现在已有了一个父组件。
 void addVetoableChangeListener(VetoableChangeListener listener)
向侦听器列表添加一个 VetoableChangeListener。
 void computeVisibleRect(Rectangle visibleRect)
返回该 Component 的“可见 rect 矩形”，即此组件及其所有祖先的可见矩形的交集。
 boolean contains(int x, int y)
为了进行鼠标处理，让 UI 委托来定义此组件的精确形状。
 JToolTip createToolTip()
返回用于显示工具提示的 JToolTip 实例。
 void disable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
 void enable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。
 void firePropertyChange(String propertyName, boolean oldValue, boolean newValue)
支持报告 boolean 属性的绑定属性更改。
 void firePropertyChange(String propertyName, char oldValue, char newValue)
报告绑定属性的改变。
 void firePropertyChange(String propertyName, int oldValue, int newValue)
支持报告整数属性的绑定属性更改。
protected  void fireVetoableChange(String propertyName, Object oldValue, Object newValue)
支持报告约束 (constrained) 属性的更改。
 AccessibleContext getAccessibleContext()
返回与此 JComponent 关联的 AccessibleContext。
 ActionListener getActionForKeyStroke(KeyStroke aKeyStroke)
返回执行针对给定键击而注册的操作的对象。
 ActionMap getActionMap()
返回用于确定为特定 KeyStroke 绑定触发何种 Action 的 ActionMap。
 float getAlignmentX()
重写 Container.getAlignmentX 以返回垂直对齐方式。
 float getAlignmentY()
重写 Container.getAlignmentY 以返回水平对齐方式。
 AncestorListener[] getAncestorListeners()
返回在此组件上注册的所有祖先侦听器所组成的数组。
 boolean getAutoscrolls()
获取 autoscrolls 属性。
 int getBaseline(int width, int height)
返回基线。
 Component.BaselineResizeBehavior getBaselineResizeBehavior()
返回一个枚举，指示组件的基线如何随大小更改而发生更改。
 Border getBorder()
返回此组件的边框；如果当前未设置边框，则返回 null。
 Rectangle getBounds(Rectangle rv)
将此组件的边界存储到“返回值”rv 中并返回 rv。
 Object getClientProperty(Object key)
返回具有指定键的属性的值。
protected  Graphics getComponentGraphics(Graphics g)
返回用于绘制此组件的图形对象。
 JPopupMenu getComponentPopupMenu()
返回为此组件分配的 JPopupMenu。
 int getConditionForKeyStroke(KeyStroke aKeyStroke)
返回确定是否发生已注册动作以响应指定键击事件的条件。
 int getDebugGraphicsOptions()
返回图形调试的状态。
static Locale getDefaultLocale()
返回在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
 FontMetrics getFontMetrics(Font font)
获取指定 Font 的 FontMetrics。
 Graphics getGraphics()
返回此组件的图形上下文，该上下文允许您绘制组件。
 int getHeight()
返回此组件的当前高度。
 boolean getInheritsPopupMenu()
如果应该从父组件继承 JPopupMenu，则返回 true。
 InputMap getInputMap()
返回组件具有焦点时所使用的 InputMap。
 InputMap getInputMap(int condition)
返回 condition 中所使用的 InputMap。
 InputVerifier getInputVerifier()
返回此组件的输入校验器。
 Insets getInsets()
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。
 Insets getInsets(Insets insets)
返回包含此组件 inset 值的 Insets 对象。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。
 Point getLocation(Point rv)
将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。
 Dimension getMaximumSize()
如果已将最大大小设置为一个非 null 值，则返回该值。
 Dimension getMinimumSize()
如果已将最小大小设置为一个非 null 值，则返回该值。
 Component getNextFocusableComponent()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。
 Point getPopupLocation(MouseEvent event)
返回在此组件坐标系统中显示弹出式菜单的首选位置。
 Dimension getPreferredSize()
如果 preferredSize 已设置为一个非 null 值，则返回该值。
 KeyStroke[] getRegisteredKeyStrokes()
返回启动已注册动作的 KeyStrokes。
 JRootPane getRootPane()
返回此组件的 JRootPane 祖先。
 Dimension getSize(Dimension rv)
将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。
 Point getToolTipLocation(MouseEvent event)
返回工具提示在此组件坐标系统中的位置。
 String getToolTipText()
返回通过 setToolTipText 所设置的工具提示字符串。
 String getToolTipText(MouseEvent event)
返回用作 event 工具提示的字符串。
 Container getTopLevelAncestor()
返回此组件的顶层祖先（包含的 Window 或 Applet）；如果尚未将此组件添加到任意容器中，则返回 null。
 TransferHandler getTransferHandler()
获取 transferHandler 属性。
 String getUIClassID()
返回用于查找 wing.plaf.ComponentUI 类（定义了此组件的外观）名的 UIDefaults 键。
 boolean getVerifyInputWhenFocusTarget()
返回值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。
 VetoableChangeListener[] getVetoableChangeListeners()
返回在此组件上注册的所有可否决更改侦听器所组成的数组。
 Rectangle getVisibleRect()
返回该 Component 的“可见矩形”，即此组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight()) 及其所有祖先的可见矩形的交集。
 int getWidth()
返回此组件的当前宽度。
 int getX()
返回组件原点的当前 x 坐标。
 int getY()
返回组件原点的当前 y 坐标。
 void grabFocus()
请求此 Component 获取输入焦点，并请求此 Component 的顶层祖先成为获得焦点的 Window。
 boolean isDoubleBuffered()
返回此组件是否应该使用缓冲区进行绘制。
static boolean isLightweightComponent(Component c)
如果此组件是轻量的，也就是说，如果它没有本机窗口系统同位体，则返回 true。
 boolean isManagingFocus()
已过时。 从 1.4 版本开始，由 Component.setFocusTraversalKeys(int, Set) 和 Container.setFocusCycleRoot(boolean) 取代。
 boolean isOpaque()
如果此组件是完全不透明的，则返回 true。
 boolean isOptimizedDrawingEnabled()
如果此组件平铺显示其子组件（也就是说，它可以保证子组件不重叠），则返回 true。
 boolean isPaintingForPrint()
如果此组件上的当前绘制操作是 print 操作的一部分，则返回 true。
 boolean isPaintingTile()
如果组件当前正在绘制 tile，则返回 true。
 boolean isRequestFocusEnabled()
如果此 JComponent 应该获得焦点，则返回 true；否则返回 false。
 boolean isValidateRoot()
如果此方法返回 true，则此组件的子代调用 revalidate 将导致从此根开始对整棵树进行验证。
 void paint(Graphics g)
由 Swing 调用，以绘制组件。
protected  void paintBorder(Graphics g)
绘制组件的边框。
protected  void paintChildren(Graphics g)
绘制此组件的子组件。
protected  void paintComponent(Graphics g)
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。
 void paintImmediately(int x, int y, int w, int h)
立即绘制此组件及其与该区域重叠的子代中的指定区域。
 void paintImmediately(Rectangle r)
立即绘制指定的区域。
protected  String paramString()
返回此 JComponent 的字符串表示形式。
 void print(Graphics g)
调用此方法打印指定 Graphics 的组件。
 void printAll(Graphics g)
调用此方法打印组件。
protected  void printBorder(Graphics g)
打印组件的边框。
protected  void printChildren(Graphics g)
打印此组件的子组件。
protected  void printComponent(Graphics g)
在打印操作期间调用此方法。
protected  void processComponentKeyEvent(KeyEvent e)
处理该组件本身可识别的所有键事件。
protected  boolean processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed)
由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
protected  void processKeyEvent(KeyEvent e)
重写 processKeyEvent 以处理事件。
protected  void processMouseEvent(MouseEvent e)
处理此组件上发生的鼠标事件，通过将其指派到任意已注册的 MouseListener 对象来完成，有关此方法的完整描述，请参阅 Component.processMouseEvent(MouseEvent)。
protected  void processMouseMotionEvent(MouseEvent e)
处理鼠标移动事件，如 MouseEvent.MOUSE_DRAGGED。
 void putClientProperty(Object key, Object value)
向此组件添加任意的键/值“客户端属性”。
 void registerKeyboardAction(ActionListener anAction, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void registerKeyboardAction(ActionListener anAction, String aCommand, KeyStroke aKeyStroke, int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。
 void removeAncestorListener(AncestorListener listener)
注销 listener，使其不再接收 AncestorEvent。
 void removeNotify()
通知此组件它不再有父组件。
 void removeVetoableChangeListener(VetoableChangeListener listener)
从侦听器列表移除一个 VetoableChangeListener。
 void repaint(long tm, int x, int y, int width, int height)
如果要显示组件，则将指定的区域添加到脏区 (dirty region) 列表。
 void repaint(Rectangle r)
如果要显示该组件，则将指定的区域添加到脏区列表。
 boolean requestDefaultFocus()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy.getDefaultComponent(Container).requestFocus() 取代
 void requestFocus()
请求此 Component 获取输入焦点。
 boolean requestFocus(boolean temporary)
请求此 Component 获取输入焦点。
 boolean requestFocusInWindow()
请求此 Component 获取输入焦点。
protected  boolean requestFocusInWindow(boolean temporary)
请求此 Component 获取输入焦点。
 void resetKeyboardActions()
注销首层 InputMaps 和 ActionMap 中的所有绑定。
 void reshape(int x, int y, int w, int h)
已过时。 从 JDK 5 开始，由 Component.setBounds(int, int, int, int) 取代。

移动此组件并调整其大小。

 void revalidate()
支持推迟的自动布局。
 void scrollRectToVisible(Rectangle aRect)
将 scrollRectToVisible() 消息转发到 JComponent 的父组件。
 void setActionMap(ActionMap am)
将 ActionMap 设置为 am。
 void setAlignmentX(float alignmentX)
设置垂直对齐方式。
 void setAlignmentY(float alignmentY)
设置水平对齐方式。
 void setAutoscrolls(boolean autoscrolls)
设置 autoscrolls 属性。
 void setBackground(Color bg)
设置此组件的背景色。
 void setBorder(Border border)
设置此组件的边框。
 void setComponentPopupMenu(JPopupMenu popup)
设置此 JComponent 的 JPopupMenu。
 void setDebugGraphicsOptions(int debugOptions)
启用或禁用与组件或其某个子组件内执行的每个图形操作有关的诊断信息。
static void setDefaultLocale(Locale l)
设置在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。
 void setDoubleBuffered(boolean aFlag)
设置此组件是否应该使用缓冲区进行绘制。
 void setEnabled(boolean enabled)
设置是否启用此组件。
 void setFocusTraversalKeys(int id, Set<? extends AWTKeyStroke> keystrokes)
设置针对此 Component 的给定遍历操作的焦点遍历键。
 void setFont(Font font)
设置此组件的字体。
 void setForeground(Color fg)
设置此组件的前景色。
 void setInheritsPopupMenu(boolean value)
设置如果此组件没有分配给它的 JPopupMenu，那么 getComponentPopupMenu 是否应该委托给其父组件。
 void setInputMap(int condition, InputMap map)
设置在 map 的 condition 条件下要使用的 InputMap。
 void setInputVerifier(InputVerifier inputVerifier)
设置此组件的输入校验器。
 void setMaximumSize(Dimension maximumSize)
将此组件的最大大小设置为一个常量值。
 void setMinimumSize(Dimension minimumSize)
将此组件的最小大小设置为一个常量值。
 void setNextFocusableComponent(Component aComponent)
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代
 void setOpaque(boolean isOpaque)
如果为 true，则该组件绘制其边界内的所有像素。
 void setPreferredSize(Dimension preferredSize)
设置此组件的首选大小。
 void setRequestFocusEnabled(boolean requestFocusEnabled)
提供一个关于此 JComponent 是否应该获得焦点的提示。
 void setToolTipText(String text)
注册要在工具提示中显示的文本。
 void setTransferHandler(TransferHandler newHandler)
设置 transferHandler 属性；如果该组件不支持数据传输操作，则为 null。
protected  void setUI(ComponentUI newUI)
设置此组件的外观委托。
 void setVerifyInputWhenFocusTarget(boolean verifyInputWhenFocusTarget)
设置该值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。
 void setVisible(boolean aFlag)
使该组件可见或不可见。
 void unregisterKeyboardAction(KeyStroke aKeyStroke)
此方法现在已过时。
 void update(Graphics g)
调用 paint。
 void updateUI()
将 UI 属性重置为当前外观的值。
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ui

protected transient ComponentUI ui
此组件的外观委托。

listenerList

protected EventListenerList listenerList
此组件的事件侦听器列表。

WHEN_FOCUSED

public static final int WHEN_FOCUSED
用于 registerKeyboardAction 的常量，意味着在组件获得焦点时应该调用命令。

另请参见：
常量字段值

WHEN_ANCESTOR_OF_FOCUSED_COMPONENT

public static final int WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
用于 registerKeyboardAction 的常量，意味着当接收组件是获得焦点的组件的祖先或者其本身就是获得焦点的组件时，应该调用命令。

另请参见：
常量字段值

WHEN_IN_FOCUSED_WINDOW

public static final int WHEN_IN_FOCUSED_WINDOW
用于 registerKeyboardAction 的常量，意味着当接收组件处于获得焦点的窗口内或者其本身就是获得焦点的组件时，应该调用命令。

另请参见：
常量字段值

UNDEFINED_CONDITION

public static final int UNDEFINED_CONDITION
某些 API 使用的常量，意味着没有定义任何条件。

另请参见：
常量字段值

TOOL_TIP_TEXT_KEY

public static final String TOOL_TIP_TEXT_KEY
光标位于组件上方时显示的注释，也称为“值提示”、“相交提示 (flyover help)”或“相交标签 (flyover label)”。

另请参见：
常量字段值

accessibleContext

protected AccessibleContext accessibleContext
与此 JComponent 关联的 AccessibleContext。

构造方法详细信息

JComponent

public JComponent()
默认的 JComponent 构造方法。除调用 Container 构造方法外，此构造方法几乎不进行初始化工作。例如，初始布局管理器为 null。但是，它将组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

另请参见：
getDefaultLocale()
方法详细信息

setInheritsPopupMenu

public void setInheritsPopupMenu(boolean value)
设置如果此组件没有分配给它的 JPopupMenu，那么 getComponentPopupMenu 是否应该委托给其父组件。

此方法的默认值是 false，但是某些作为多个 JComponent 实现的 JComponent 子类可能将其设置为 true。

这是一个绑定 (bound) 属性。

参数：
value - JPopupMenu 是否是继承的
从以下版本开始：
1.5
另请参见：
setComponentPopupMenu(javax.swing.JPopupMenu)

getInheritsPopupMenu

public boolean getInheritsPopupMenu()
如果应该从父组件继承 JPopupMenu，则返回 true。

从以下版本开始：
1.5
另请参见：
setComponentPopupMenu(javax.swing.JPopupMenu)

setComponentPopupMenu

public void setComponentPopupMenu(JPopupMenu popup)
设置此 JComponent 的 JPopupMenu。UI 负责注册绑定并添加必要的侦听器，这样可在恰当的时间显示 JPopupMenu。何时显示 JPopupMenu 取决于外观：有些在鼠标事件中显示它，另一些则启用键绑定。

如果 popup 为 null，并且 getInheritsPopupMenu 返回 true，则将 getComponentPopupMenu 委托给父级。这将允许所有子组件继承父组件的 popupmenu。

这是一个绑定属性。

参数：
popup - - 分配给此组件的弹出菜单，可以为 null
从以下版本开始：
1.5
另请参见：
getComponentPopupMenu()

getComponentPopupMenu

public JPopupMenu getComponentPopupMenu()
返回为此组件分配的 JPopupMenu。如果尚未给此组件分配 JPopupMenu 并且 getInheritsPopupMenu 为 true，则此方法返回 getParent().getComponentPopupMenu()（假定父组件是有效的）。

返回：
分配给此组件的 JPopupMenu；如果未分配弹出菜单，则为 null
从以下版本开始：
1.5
另请参见：
setComponentPopupMenu(javax.swing.JPopupMenu)

updateUI

public void updateUI()
将 UI 属性重置为当前外观的值。JComponent 子类必须用以下方式重写此方法：
   public void updateUI() {
      setUI((SliderUI)UIManager.getUI(this);
   }

另请参见：
setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

setUI

protected void setUI(ComponentUI newUI)
设置此组件的外观委托。JComponent 子类通常重写此方法，以缩小参数类型。例如，在 JSlider 中：
 public void setUI(SliderUI newUI) {
     super.setUI(newUI);
 }

此外，JComponent 子类必须提供一个返回正确类型的 getUI 方法。例如：

 public SliderUI getUI() {
     return (SliderUI)ui;
 }

参数：
newUI - 新的 UI 委托
另请参见：
updateUI(),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

getUIClassID

public String getUIClassID()
返回用于查找 wing.plaf.ComponentUI 类（定义了此组件的外观）名的 UIDefaults 键。大多数应用程序无需调用此方法。支持可插入外观的 JComponent 子类应该重写此方法，以返回映射到定义其外观的 ComponentUI 子类的 UIDefaults 键。

返回：
用于 ComponentUI 子类的 UIDefaults 键
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getComponentGraphics

protected Graphics getComponentGraphics(Graphics g)
返回用于绘制此组件的图形对象。如果开启了 DebugGraphics，则根据需要创建一个新的 DebugGraphics 对象。否则只是配置指定图形对象的前景和字体。

参数：
g - 原 Graphics 对象
返回：
为此组件配置的 Graphics 对象

paintComponent

protected void paintComponent(Graphics g)
如果 UI 委托为非 null，则调用该 UI 委托的 paint 方法。向该委托传递 Graphics 对象的副本，以保护其余的 paint 代码免遭不可取消的更改（例如 Graphics.translate）。

如果在子类中重写此方法，则不应该对传入的 Graphics 进行永久更改。例如，不应更改剪贴区的 Rectangle 或修改转换。如果需要进行这些操作，您会发现根据传入的 Graphics 创建一个新 Graphics 并进行操作更加方便。另外，如果不调用超类的实现，则必须遵守不透明属性，也就是说，如果此组件是不透明的，则必须以透明的颜色完全填充背景。如果不遵守不透明属性，则很可能看到可视的人为内容。

传入的 Graphics 对象可能安装了恒等转换以外的转换。在这种情况下，如果多次应用其他转换，则可能得到不可预料的结果。

参数：
g - 要保护的 Graphics 对象
另请参见：
paint(java.awt.Graphics), ComponentUI

paintChildren

protected void paintChildren(Graphics g)
绘制此组件的子组件。如果 shouldUseBuffer 为 true，那么所有的组件祖先都没有缓冲区，且组件的子组件可以使用缓冲区（如果有）。否则，有一个祖先具有当前正在使用的缓冲区，且子组件不应该使用缓冲区进行绘制。

参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
paint(java.awt.Graphics), Container.paint(java.awt.Graphics)

paintBorder

protected void paintBorder(Graphics g)
绘制组件的边框。

如果在子类中重写此方法，则不应该对传入的 Graphics 进行永久更改。例如，不应更改剪贴区的 Rectangle 或修改转换。如果需要进行这些操作，您会发现根据传入的 Graphics 创建一个新 Graphics 并进行操作更加方便。

参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
paint(java.awt.Graphics), setBorder(javax.swing.border.Border)

update

public void update(Graphics g)
调用 paint。不清除背景，而是查看 ComponentUI.update，它由 paintComponent 调用。

覆盖：
类 Container 中的 update
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
paint(java.awt.Graphics), paintComponent(java.awt.Graphics), ComponentUI

paint

public void paint(Graphics g)
由 Swing 调用，以绘制组件。应用程序不应直接调用 paint，而是应该使用 repaint 方法来安排重绘组件。

此方法实际上将绘制工作委托给三个受保护的方法：paintComponent、paintBorder 和 paintChildren。按列出的顺序调用这些方法，以确保子组件出现在组件本身的顶部。一般来说，不应在分配给边框的 insets 区域绘制组件及其子组件。子类可以始终重写此方法。只想特殊化 UI（外观）委托的 paint 方法的子类只需重写 paintComponent。

覆盖：
类 Container 中的 paint
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
paintComponent(java.awt.Graphics),
paintBorder(java.awt.Graphics),
paintChildren(java.awt.Graphics),
getComponentGraphics(java.awt.Graphics),
repaint(long, int, int, int, int)

printAll

public void printAll(Graphics g)
调用此方法打印组件。此方法对组件调用 print。

覆盖：
类 Component 中的 printAll
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
print(java.awt.Graphics),
printComponent(java.awt.Graphics),
printBorder(java.awt.Graphics),
printChildren(java.awt.Graphics)

print

public void print(Graphics g)
调用此方法打印指定 Graphics 的组件。此方法将导致对 printComponent、printBorder 和 printChildren 的调用。如果目的是定制打印外观的方式，建议重写前面提及的方法之一，而不是此方法。但是，如果想在调用超类行为之前准备好状态，则重写此方法很有用。例如，如果想在打印前更改组件的背景颜色，则可以执行以下操作：
     public void print(Graphics g) {
         Color orig = getBackground();
         setBackground(Color.WHITE);

         // wrap in try/finally so that we always restore the state
         try {
             super.print(g);
         } finally {
             setBackground(orig);
         }
     }

另外，对于将打印委托给其他对象的组件，在绘制期间就可以查询组件是否在打印操作的中间。isPaintingForPrint 方法提供了这种功能并且此方法将改变其返回值：在即将呈现前改为 true，在呈现后立即改为 false。随着每一次更改，在此组件上都会触发一个名为 "paintingForPrint" 的属性更改事件。

此方法设置组件的状态，使得双缓冲无法使用：绘制将直接在传入的 Graphics 上完成。

覆盖：
类 Container 中的 print
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
printComponent(java.awt.Graphics),
printBorder(java.awt.Graphics),
printChildren(java.awt.Graphics),
isPaintingForPrint()

printComponent

protected void printComponent(Graphics g)
在打印操作期间调用此方法。实现此方法以对组件调用 paintComponent。如果要在打印时添加特殊的绘制行为，可重写此方法。

参数：
g - 在其中进行绘制的 Graphics 上下文
从以下版本开始：
1.3
另请参见：
print(java.awt.Graphics)

printChildren

protected void printChildren(Graphics g)
打印此组件的子组件。实现此方法以对组件调用 paintChildren。如果希望以不同于绘制的方式打印子组件，则重写此方法。

参数：
g - 在其中进行绘制的 Graphics 上下文
从以下版本开始：
1.3
另请参见：
print(java.awt.Graphics)

printBorder

protected void printBorder(Graphics g)
打印组件的边框。实现此方法以对组件调用 paintBorder。如果要以和绘制该边框所不同的方式来打印边框，则重写此方法。

参数：
g - 在其中进行绘制的 Graphics 上下文
从以下版本开始：
1.3
另请参见：
print(java.awt.Graphics)

isPaintingTile

public boolean isPaintingTile()
如果组件当前正在绘制 tile，则返回 true。如果此方法返回 true，则会为另一个 tile 再次调用 paint。如果没有绘制 tile，或者已绘制完最后一个 tile，则此方法返回 false。使用此方法可保持 tile 间可能需要的某个状态。

返回：
如果组件当前正在绘制 tile，则返回 true；否则返回 false

isPaintingForPrint

public final boolean isPaintingForPrint()
如果此组件上的当前绘制操作是 print 操作的一部分，则返回 true。当想要定制所打印的内容以及在屏幕上显示的内容时，此方法很有用。

通过侦听此组件上名为 "paintingForPrint" 的属性更改事件，可以检测此属性值中的更改。

注：此方法也提供其他高级别 Swing 打印 API 所提供的功能。但是，它严格处理绘制操作，不要因为高级别打印进程上提供的信息相混淆。例如，JTable.print() 操作不一定会连续呈现完整的组件，此方法的返回值在该操作中可多次更改。组件甚至有可能在打印进程正在进行时便绘制到屏幕。在这种情况下，当且仅当该表作为打印进程的一部分进行绘制时，此方法的返回值为 true。

返回：
如果此组件上的当前绘制操作是打印操作的一部分，则返回 true
从以下版本开始：
1.6
另请参见：
print(java.awt.Graphics)

isManagingFocus

@Deprecated
public boolean isManagingFocus()
已过时。 从 1.4 版本开始，由 Component.setFocusTraversalKeys(int, Set) 和 Container.setFocusCycleRoot(boolean) 取代。

在版本 1.4 中，重新设计了焦点子系统。有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

将此 JComponent 的焦点遍历键更改为 CTRL+TAB 和 CTRL+SHIFT+TAB。在计算焦点遍历循环时，SortingFocusTraversalPolicy 仍然没有将此 JComponent 的子代考虑在内。

另请参见：
Component.setFocusTraversalKeys(int, java.util.Set), SortingFocusTraversalPolicy

setNextFocusableComponent

@Deprecated
public void setNextFocusableComponent(Component aComponent)
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代

在版本 1.4 中，重新设计了焦点子系统。有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

为此 JComponent 的焦点遍历循环重写默认的 FocusTraversalPolicy：无条件地将指定的 Component 设置为循环中的下一个 Component，并将此 JComponent 设置为循环中指定 Component 的前一个 Component。

参数：
aComponent - 焦点遍历循环中应该跟在此 JComponent 后的 Component
另请参见：
getNextFocusableComponent(), FocusTraversalPolicy

getNextFocusableComponent

@Deprecated
public Component getNextFocusableComponent()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy 取代。

在版本 1.4 中，重新设计了焦点子系统。有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

返回之前对此 JComponent 调用 setNextFocusableComponent(Component) 所设置的 Component。

返回：
焦点遍历循环中应该跟在此 JComponent 后的 Component；如果尚未显式地指定，则为 null
另请参见：
setNextFocusableComponent(java.awt.Component)

setRequestFocusEnabled

public void setRequestFocusEnabled(boolean requestFocusEnabled)
提供一个关于此 JComponent 是否应该获得焦点的提示。这只是一个提示，由使用者决定请求焦点是否遵守此属性。鼠标操作通常遵守此属性，而键盘操作则并非如此。例如，在鼠标操作期间，外观可以在请求焦点前验证此属性是否为 true。如果不想在 JComponent 上按下鼠标以获得焦点，而是希望通过键盘遍历 JComponent，则要多次使用此方法。如果不希望此 JComponent 可聚焦，请使用 setFocusable 方法。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

参数：
requestFocusEnabled - 指示是否希望此 JComponent 可聚焦
另请参见：
Focus Specification, Component.setFocusable(boolean)

isRequestFocusEnabled

public boolean isRequestFocusEnabled()
如果此 JComponent 应该获得焦点，则返回 true；否则返回 false。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

返回：
如果此 component 应该获得焦点，则返回 true；否则返回 false
另请参见：
setRequestFocusEnabled(boolean), Focus Specification, Component.isFocusable()

requestFocus

public void requestFocus()
请求此 Component 获取输入焦点。有关此方法的完整描述，请参阅 Component.requestFocus()。

注意，不推荐使用此方法，因为其行为与平台有关。建议使用 requestFocusInWindow()。若要了解有关焦点的更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

覆盖：
类 Component 中的 requestFocus
从以下版本开始：
1.4
另请参见：
Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

requestFocus

public boolean requestFocus(boolean temporary)
请求此 Component 获取输入焦点。有关此方法的完整描述，请参阅 Component.requestFocus(boolean)。

注意，不推荐使用此方法，因为其行为与平台有关。建议使用 requestFocusInWindow(boolean)。若要了解有关焦点的更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

覆盖：
类 Component 中的 requestFocus
参数：
temporary - boolean 值，指示焦点更改是否为临时的
返回：
如果焦点更改请求一定会失败，则返回 false；如果有可能成功，则返回 true
从以下版本开始：
1.4
另请参见：
Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

requestFocusInWindow

public boolean requestFocusInWindow()
请求此 Component 获取输入焦点。有关此方法的完整描述，请参阅 Component.requestFocusInWindow()。

若要了解有关焦点的更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

覆盖：
类 Component 中的 requestFocusInWindow
返回：
如果焦点更改请求一定会失败，则返回 false；如果有可能成功，则返回 true
从以下版本开始：
1.4
另请参见：
Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

requestFocusInWindow

protected boolean requestFocusInWindow(boolean temporary)
请求此 Component 获取输入焦点。有关此方法的完整描述，请参阅 Component.requestFocusInWindow(boolean)。

若要了解有关焦点的更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

覆盖：
类 Component 中的 requestFocusInWindow
参数：
temporary - boolean 值，指示焦点更改是否为临时的
返回：
如果焦点更改请求一定会失败，则返回 false；如果有可能成功，则返回 true
从以下版本开始：
1.4
另请参见：
Component.requestFocusInWindow(), Component.requestFocusInWindow(boolean)

grabFocus

public void grabFocus()
请求此 Component 获取输入焦点，并请求此 Component 的顶层祖先成为获得焦点的 Window。此组件对于要准许的请求而言必须是可显示的、可见的、可聚焦的。

此方法用于焦点实现。客户端代码不应使用此方法；相反，它应该使用 requestFocusInWindow()。

另请参见：
requestFocusInWindow()

setVerifyInputWhenFocusTarget

public void setVerifyInputWhenFocusTarget(boolean verifyInputWhenFocusTarget)
设置该值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。默认值为 true。对于像 Cancel 按钮或滚动条等组件可将该值设置为 false，这些组件应该是激活的，即使当前焦点所有者的输入没有“通过”该组件的输入校验器的检验。

参数：
verifyInputWhenFocusTarget - verifyInputWhenFocusTarget 属性的值
从以下版本开始：
1.3
另请参见：
InputVerifier,
setInputVerifier(javax.swing.InputVerifier),
getInputVerifier(),
getVerifyInputWhenFocusTarget()

getVerifyInputWhenFocusTarget

public boolean getVerifyInputWhenFocusTarget()
返回值指示是否在此组件请求焦点前，为当前的焦点所有者调用输入校验器。

返回：
verifyInputWhenFocusTarget 属性的值
从以下版本开始：
1.3
另请参见：
InputVerifier,
setInputVerifier(javax.swing.InputVerifier),
getInputVerifier(),
setVerifyInputWhenFocusTarget(boolean)

getFontMetrics

public FontMetrics getFontMetrics(Font font)
获取指定 Font 的 FontMetrics。

覆盖：
类 Component 中的 getFontMetrics
参数：
font - 要获取其字体规格的字体
返回：
font 的字体规格
抛出：
NullPointerException - 如果 font 为 null
从以下版本开始：
1.5
另请参见：
Component.getFont(),
Component.getPeer(),
ComponentPeer.getFontMetrics(Font),
Toolkit.getFontMetrics(Font)

setPreferredSize

public void setPreferredSize(Dimension preferredSize)
设置此组件的首选大小。如果 preferredSize 为 null，则要求 UI 提供首选大小。

覆盖：
类 Component 中的 setPreferredSize
参数：
preferredSize - 新的首选大小，或者为 null
另请参见：
Component.getPreferredSize(), Component.isPreferredSizeSet()

getPreferredSize

public Dimension getPreferredSize()
如果 preferredSize 已设置为一个非 null 值，则返回该值。如果 UI 委托的 getPreferredSize 方法返回一个非 null 值，则返回该值；否则服从组件的布局管理器。

覆盖：
类 Container 中的 getPreferredSize
返回：
preferredSize 属性的值
另请参见：
setPreferredSize(java.awt.Dimension), ComponentUI

setMaximumSize

public void setMaximumSize(Dimension maximumSize)
将此组件的最大大小设置为一个常量值。对 getMaximumSize 的后续调用将始终返回此值；而不要求组件的 UI 计算它。将最大大小设置为 null 可恢复默认行为。

覆盖：
类 Component 中的 setMaximumSize
参数：
maximumSize - 一个包含所需最大允许大小的 Dimension
另请参见：
getMaximumSize()

getMaximumSize

public Dimension getMaximumSize()
如果已将最大大小设置为一个非 null 值，则返回该值。如果 UI 委托的 getMaximumSize 方法返回一个非 null 值，则返回该值；否则服从组件的布局管理器。

覆盖：
类 Container 中的 getMaximumSize
返回：
maximumSize 属性的值
另请参见：
setMaximumSize(java.awt.Dimension), ComponentUI

setMinimumSize

public void setMinimumSize(Dimension minimumSize)
将此组件的最小大小设置为一个常量值。对 getMinimumSize 的后续调用将始终返回此值；不会要求组件的 UI 计算它。将最小大小设置为 null 可恢复默认行为。

覆盖：
类 Component 中的 setMinimumSize
参数：
minimumSize - 此组件新的最小大小
另请参见：
getMinimumSize()

getMinimumSize

public Dimension getMinimumSize()
如果已将最小大小设置为一个非 null 值，则返回该值。如果 UI 委托的 getMinimumSize 方法返回一个非 null 值，则返回该值；否则服从组件的布局管理器。

覆盖：
类 Container 中的 getMinimumSize
返回：
minimumSize 属性的值
另请参见：
setMinimumSize(java.awt.Dimension), ComponentUI

contains

public boolean contains(int x,
                        int y)
为了进行鼠标处理，让 UI 委托来定义此组件的精确形状。

覆盖：
类 Component 中的 contains
参数：
x - 该点的 x 坐标
y - 该点的 y 坐标
返回：
如果此组件逻辑上包含 x,y，则返回 true
另请参见：
Component.contains(int, int), ComponentUI

setBorder

public void setBorder(Border border)
设置此组件的边框。Border 对象负责定义组件的 insets（直接对组件重写所有 insets 设置），并且可选地呈现这些 insets 范围内的边框装饰。要为 swing 组件创建有装饰的和无装饰的区域（例如边距和填充），应该使用边框（而不是 insets）。在单个组件中可使用复合边框来嵌套多个边框。

虽然从技术上讲可以在继承自 JComponent 的所有对象上设置边框，但是很多标准 Swing 组件的外观实现无法正常地使用用户设置的边框。通常，如果希望在标准的 Swing 组件而不是 JPanel 或 JLabel 上设置边框时，建议将组件放入 JPanel 中，并在 JPanel 上设置边框。

这是一个绑定属性。

参数：
border - 要为此组件呈现的边框
另请参见：
Border, CompoundBorder

getBorder

public Border getBorder()
返回此组件的边框；如果当前未设置边框，则返回 null。

返回：
此组件的边框对象
另请参见：
setBorder(javax.swing.border.Border)

getInsets

public Insets getInsets()
如果已在此组件上设置了边框，则返回该边框的 insets；否则调用 super.getInsets。

覆盖：
类 Container 中的 getInsets
返回：
insets 属性的值
另请参见：
setBorder(javax.swing.border.Border)

getInsets

public Insets getInsets(Insets insets)
返回包含此组件 inset 值的 Insets 对象。如有可能，将重用传入的 Insets 对象。但是不能假定调用这些方法将返回相同的对象。重写此对象内所有现有值。如果 insets 为 null，则此方法将分配一个新的 insets。

参数：
insets - Insets 对象，它可以被重用
返回：
Insets 对象
另请参见：
getInsets()

getAlignmentY

public float getAlignmentY()
重写 Container.getAlignmentY 以返回水平对齐方式。

覆盖：
类 Container 中的 getAlignmentY
返回：
alignmentY 属性的值
另请参见：
setAlignmentY(float), Component.getAlignmentY()

setAlignmentY

public void setAlignmentY(float alignmentY)
设置水平对齐方式。

参数：
alignmentY - 新的水平对齐方式
另请参见：
getAlignmentY()

getAlignmentX

public float getAlignmentX()
重写 Container.getAlignmentX 以返回垂直对齐方式。

覆盖：
类 Container 中的 getAlignmentX
返回：
alignmentX 属性的值
另请参见：
setAlignmentX(float), Component.getAlignmentX()

setAlignmentX

public void setAlignmentX(float alignmentX)
设置垂直对齐方式。

参数：
alignmentX - 新的垂直对齐方式
另请参见：
getAlignmentX()

setInputVerifier

public void setInputVerifier(InputVerifier inputVerifier)
设置此组件的输入校验器。

参数：
inputVerifier - 新的输入校验器
从以下版本开始：
1.3
另请参见：
InputVerifier

getInputVerifier

public InputVerifier getInputVerifier()
返回此组件的输入校验器。

返回：
inputVerifier 属性
从以下版本开始：
1.3
另请参见：
InputVerifier

getGraphics

public Graphics getGraphics()
返回此组件的图形上下文，该上下文允许您绘制组件。使用此方法可获取一个 Graphics 对象，然后在该对象上调用操作，以便绘制组件。

覆盖：
类 Component 中的 getGraphics
返回：
此组件的图形上下文
另请参见：
Component.paint(java.awt.Graphics)

setDebugGraphicsOptions

public void setDebugGraphicsOptions(int debugOptions)
启用或禁用与组件或其某个子组件内执行的每个图形操作有关的诊断信息。

参数：
debugOptions - 确定组件应该如何显示信息；为下列选项之一：
  • DebugGraphics.LOG_OPTION - 打印文本消息。
  • DebugGraphics.FLASH_OPTION - 绘制的内容闪烁几次。
  • DebugGraphics.BUFFERED_OPTION - 创建一个 ExternalWindow，显示在 View 的脱屏缓冲区上执行的操作。
  • DebugGraphics.NONE_OPTION 禁用调试。
  • 值 0 不会更改该调试选项。
当前值是 debugOptions 按位或运算的结果

getDebugGraphicsOptions

public int getDebugGraphicsOptions()
返回图形调试的状态。

返回：
0 标志或下列选项按位或运算的结果：
  • DebugGraphics.LOG_OPTION - 打印文本消息。
  • DebugGraphics.FLASH_OPTION - 绘制的内容闪烁几次。
  • DebugGraphics.BUFFERED_OPTION - 创建一个 ExternalWindow，显示在 View 的脱屏缓冲区上执行的操作。
  • DebugGraphics.NONE_OPTION 禁用调试。
  • 值 0 不会更改该调试选项。
另请参见：
setDebugGraphicsOptions(int)

registerKeyboardAction

public void registerKeyboardAction(ActionListener anAction,
                                   String aCommand,
                                   KeyStroke aKeyStroke,
                                   int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。例如，要将 KeyStroke aKeyStroke 绑定到 Action anAction，现在使用：
   component.getInputMap().put(aKeyStroke, aCommand);
   component.getActionMap().put(aCommmand, anAction);
以上假定您希望绑定适用于 WHEN_FOCUSED。要为其他焦点状态注册绑定，可使带有整数参数的 getInputMap 方法。

注册一个新的键盘动作。如果出现一个与 aKeyStroke 匹配的键事件并且 aCondition 经过了验证，则调用 anAction。KeyStroke 对象定义了键盘键和一个或多个修改键（alt、shift、ctrl、meta）的特定组合。

aCommand 将在传递的事件（如果指定）中进行设置。

aCondition 可以为：

WHEN_FOCUSED
仅在发生键击、同时组件具有焦点时才调用该动作。
WHEN_IN_FOCUSED_WINDOW
当发生键击、同时组件具有焦点时，或者组件处于具有焦点的窗口中时调用该动作。注意，该组件无需是该窗口的直接子级，它可以处于窗口包含层次结构中的任意位置。换句话说，只要窗口中的任意 组件具有焦点，就调用向此组件注册的动作。
WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
当发生键击、同时组件具有焦点时，或者该组件是具有焦点的组件的祖先时调用该动作。

这种键击和条件的组合允许您为指定的键击＋修改键组合定义高级别（语义）的动作事件（使用 KeyStroke 类），并导向具有焦点的组件的父组件或子组件，或者该组件本身。换句话说，在任意的组件层次结构中，可将任意的键组合导向层次结构中的适当组件，并调用具体的方法（通常通过适配器对象的方式）。

如果已经使用相同的 charCode 和修改键为接收容器注册了某个动作，则 anAction 将取代该动作。

参数：
anAction - 要注册的 Action
aCommand - 要在传递的事件中设置的命令
aKeyStroke - 与动作绑定的 KeyStroke
aCondition - 要符合的条件，见上文
另请参见：
KeyStroke

registerKeyboardAction

public void registerKeyboardAction(ActionListener anAction,
                                   KeyStroke aKeyStroke,
                                   int aCondition)
此方法现在已过时，对于类似的操作，请结合使用 getActionMap() 和 getInputMap()。

unregisterKeyboardAction

public void unregisterKeyboardAction(KeyStroke aKeyStroke)
此方法现在已过时。要注销现有绑定，可以从 ActionMap/InputMap 中移除该绑定，或者在 InputMap 中放置一个虚拟（dummy）绑定。从 InputMap 中移除绑定允许父 InputMap 中的绑定处于激活状态，而在 InputMap 中放置一个 dummy 绑定则可以有效地禁止绑定发生。

注销一个键盘动作。此动作将从 ActionMap（如果存在）和 InputMap 中移除绑定。

getRegisteredKeyStrokes

public KeyStroke[] getRegisteredKeyStrokes()
返回启动已注册动作的 KeyStrokes。

返回：
KeyStroke 对象数组
另请参见：
registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

getConditionForKeyStroke

public int getConditionForKeyStroke(KeyStroke aKeyStroke)
返回确定是否发生已注册动作以响应指定键击事件的条件。

对于 Java 2 平台 v1.3，一个 KeyStroke 可与多个条件关联。例如，'a' 可以和两个条件 WHEN_FOCUSED 和 WHEN_IN_FOCUSED_WINDOW 绑定。

返回：
动作-键击条件

getActionForKeyStroke

public ActionListener getActionForKeyStroke(KeyStroke aKeyStroke)
返回执行针对给定键击而注册的操作的对象。

返回：
发生键击时所调用的 ActionListener 对象

resetKeyboardActions

public void resetKeyboardActions()
注销首层 InputMaps 和 ActionMap 中的所有绑定。此操作可以移除所有的本地绑定，并允许保留父 InputMap/ActionMaps 中定义的绑定（通常在第二层定义 UI）。

setInputMap

public final void setInputMap(int condition,
                              InputMap map)
设置在 map 的 condition 条件下要使用的 InputMap。null 意味着不想使用任何绑定（包括来自 UI 的绑定）。这不会重新安装 UI InputMap（如果有）。condition 为以下值之一：
  • WHEN_IN_FOCUSED_WINDOW
  • WHEN_FOCUSED
  • WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
如果 condition 是 WHEN_IN_FOCUSED_WINDOW 且 map 不是 ComponentInputMap，则抛出 IllegalArgumentException。类似地，如果 condition 不是上述值之一，则抛出 IllegalArgumentException。

参数：
condition - 上述值之一
map - 用于给定条件的 InputMap
抛出：
IllegalArgumentException - 如果 condition 是 WHEN_IN_FOCUSED_WINDOW 且 map 不是 ComponentInputMap 的实例；或者 condition 不是上面指定的合法值之一
从以下版本开始：
1.3

getInputMap

public final InputMap getInputMap(int condition)
返回 condition 中所使用的 InputMap。

参数：
condition - WHEN_IN_FOCUSED_WINDOW、WHEN_FOCUSED、WHEN_ANCESTOR_OF_FOCUSED_COMPONENT 之一
返回：
指定 condition 的 InputMap
从以下版本开始：
1.3

getInputMap

public final InputMap getInputMap()
返回组件具有焦点时所使用的 InputMap。这是 getInputMap(WHEN_FOCUSED) 的一个便捷方法。

返回：
组件具有焦点时所使用的 InputMap
从以下版本开始：
1.3

setActionMap

public final void setActionMap(ActionMap am)
将 ActionMap 设置为 am。此方法不会将 am 的父级设置成 UI 的 ActionMap（如果有），由调用者决定是否这样做。

参数：
am - 新的 ActionMap
从以下版本开始：
1.3

getActionMap

public final ActionMap getActionMap()
返回用于确定为特定 KeyStroke 绑定触发何种 Action 的 ActionMap。除非另行设置，否则返回的 ActionMap 将 UI 的 ActionMap 设置为其父级。

返回：
包含键/动作绑定的 ActionMap
从以下版本开始：
1.3

getBaseline

public int getBaseline(int width,
                       int height)
返回基线。基线是从组件顶部开始测量的。此方法主要用于 LayoutManager，以便沿组件的基线对齐组件。返回值小于 0 表示此组件没有合理的基线，并且 LayoutManager 不应该根据该组件的基线来对齐此组件。

此方法调用相同名称的 ComponentUI 方法。如果此组件不具有 ComponentUI，则返回 -1。如果返回大于等于 0 的值，则该组件有一个对于任何大于等于最小大小的大小均有效的基线，并且可以使用 getBaselineResizeBehavior 确定基线如何随大小发生更改。

覆盖：
类 Component 中的 getBaseline
参数：
width - 适合基线的宽度
height - 适合基线的高度
返回：
基线，如果基线 < 0，则表示没有合理的基线
抛出：
IllegalArgumentException - 如果 width 或 height < 0
从以下版本开始：
1.6
另请参见：
getBaselineResizeBehavior(), FontMetrics

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior()
返回一个枚举，指示组件的基线如何随大小更改而发生更改。此方法主要用于布局管理器和 GUI 生成器。

此方法调用相同名称的 ComponentUI 方法。如果此组件不具有 ComponentUI，则返回 BaselineResizeBehavior.OTHER。子类不应该返回 null；如果无法计算基线，则返回 BaselineResizeBehavior.OTHER。调用者应该首先使用 getBaseline 询问基线，如果返回值大于等于 0，则使用此方法。此方法返回一个 BaselineResizeBehavior.OTHER 以外的值是可以接受的，即使 getBaseline 返回一个小于 0 的值。

覆盖：
类 Component 中的 getBaselineResizeBehavior
返回：
一个指示基线如何随组件大小的更改发生变化的枚举
从以下版本开始：
1.6
另请参见：
getBaseline(int, int)

requestDefaultFocus

@Deprecated
public boolean requestDefaultFocus()
已过时。 从 1.4 版本开始，由 FocusTraversalPolicy.getDefaultComponent(Container).requestFocus() 取代

在版本 1.4 中，重新设计了焦点子系统。有关更多信息，请参阅 The Java Tutorial 中的 How to Use the Focus Subsystem 一节。

请求此 JComponent FocusTraversalPolicy 的默认 Component 上的焦点。如果此 JComponent 是焦点循环根，则使用其 FocusTraversalPolicy。否则，使用此 JComponent 的焦点循环根祖先的 FocusTraversalPolicy。

另请参见：
FocusTraversalPolicy.getDefaultComponent(java.awt.Container)

setVisible

public void setVisible(boolean aFlag)
使该组件可见或不可见。重写 Component.setVisible。

覆盖：
类 Component 中的 setVisible
参数：
aFlag - true 使该组件可见；false 使其不可见
另请参见：
Component.isVisible()

setEnabled

public void setEnabled(boolean enabled)
设置是否启用此组件。已启用的组件可以响应用户输入，而未启用的组件则无法响应用户输入。可以在禁用某些组件时更改其可视化表现形式，以向用户提供反馈，说明其无法接受输入。

注：禁用某个组件不会禁用其子组件。

注：禁用轻量组件不会阻止其接收 MouseEvent。

覆盖：
类 Component 中的 setEnabled
参数：
enabled - 如果应该启用此组件，则为 true；否则为 false
另请参见：
Component.isEnabled(), Component.isLightweight()

setForeground

public void setForeground(Color fg)
设置此组件的前景色。由外观来决定是否遵守此属性，某些外观可以选择忽略它。

覆盖：
类 Component 中的 setForeground
参数：
fg - 所需的前景 Color
另请参见：
Component.getForeground()

setBackground

public void setBackground(Color bg)
设置此组件的背景色。背景色仅在组件是不透明时才使用，并且只能由 JComponent 或 ComponentUI 实现的子类使用。JComponent 的直接子类必须重写 paintComponent 以遵守此属性。

由外观决定是否遵守此属性，某些外观可以选择忽略它。

覆盖：
类 Component 中的 setBackground
参数：
bg - 所需的背景 Color
另请参见：
Component.getBackground(), setOpaque(boolean)

setFont

public void setFont(Font font)
设置此组件的字体。

覆盖：
类 Container 中的 setFont
参数：
font - 此组件所需的 Font
另请参见：
Component.getFont()

getDefaultLocale

public static Locale getDefaultLocale()
返回在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。 默认的语言环境具有 "AppContext" 范围，所以 applet（以及可能在单个 VM 中运行的多个轻量级应用程序）可以有它们自己的设置。applet 可以安全地更改其默认的语言环境，因为它不会影响其他 applet（或浏览器）。

返回：
默认的 Locale。
从以下版本开始：
1.4
另请参见：
setDefaultLocale(java.util.Locale),
Component.getLocale(),
Component.setLocale(java.util.Locale)

setDefaultLocale

public static void setDefaultLocale(Locale l)
设置在创建时，用于初始化每个 JComponent 的语言环境属性的默认语言环境。初始值是 VM 的默认语言环境。 默认的语言环境具有 "AppContext" 范围，所以 applet（以及可能在单个 VM 中运行的多个轻量级应用程序）可以有它们自己的设置。applet 可以安全地更改其默认的语言环境，因为它不会影响其他 applet（或浏览器）。

参数：
l - 所需的默认 Locale，用于新的组件。
从以下版本开始：
1.4
另请参见：
getDefaultLocale(),
Component.getLocale(),
Component.setLocale(java.util.Locale)

processComponentKeyEvent

protected void processComponentKeyEvent(KeyEvent e)
处理该组件本身可识别的所有键事件。在焦点管理器和所有相关侦听器可以侦听事件后调用此方法。仅在事件尚未被使用时才调用此方法。在键盘 UI 逻辑之前调用此方法。

实现此方法不执行任何操作。如果子类本身处理某些键事件，则这些子类通常重写此方法。如果事件已经处理，则使用该事件。

processKeyEvent

protected void processKeyEvent(KeyEvent e)
重写 processKeyEvent 以处理事件。

覆盖：
类 Component 中的 processKeyEvent
参数：
e - 按键事件
另请参见：
KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

processKeyBinding

protected boolean processKeyBinding(KeyStroke ks,
                                    KeyEvent e,
                                    int condition,
                                    boolean pressed)
由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。此方法将获取适当的 InputMap、获取绑定、从 ActionMap 获取动作，然后（如果找到该动作并且已启用该组件）调用 notifyAction 来通知该动作。

参数：
ks - 被查询的 KeyStroke
e - KeyEvent
condition - 为下列值之一：
  • JComponent.WHEN_FOCUSED
  • JComponent.WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
  • JComponent.WHEN_IN_FOCUSED_WINDOW
pressed - 如果键被按下，则为 true
返回：
如果有该动作的绑定并且已启用该动作，则返回 true
从以下版本开始：
1.3

setToolTipText

public void setToolTipText(String text)
注册要在工具提示中显示的文本。光标处于该组件上时显示该文本。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Tool Tips。

参数：
text - 要显示的字符串；如果 text 为 null，则关闭此组件的工具提示
另请参见：
TOOL_TIP_TEXT_KEY

getToolTipText

public String getToolTipText()
返回通过 setToolTipText 所设置的工具提示字符串。

返回：
工具提示文本
另请参见：
TOOL_TIP_TEXT_KEY

getToolTipText

public String getToolTipText(MouseEvent event)
返回用作 event 工具提示的字符串。默认情况下，此方法返回使用 setToolTipText 设置的任意字符串。如果组件提供了进一步扩展的 API，以支持不同位置的不同工具提示，则应重写此方法。

getToolTipLocation

public Point getToolTipLocation(MouseEvent event)
返回工具提示在此组件坐标系统中的位置。如果返回 null，则 Swing 将选择某个位置。默认实现返回 null。

参数：
event - 导致 ToolTipManager 显示工具提示的 MouseEvent
返回：
始终返回 null

getPopupLocation

public Point getPopupLocation(MouseEvent event)
返回在此组件坐标系统中显示弹出式菜单的首选位置。由外观来决定是否遵守此属性，某些外观可以选择忽略它。如果返回 null，则外观将选择一个合适的位置。

参数：
event - 触发显示弹出式菜单的 MouseEvent；如果不是因鼠标事件而显示弹出式菜单，则为 null
返回：
显示 JPopupMenu 的位置，或者返回 null
从以下版本开始：
1.5

createToolTip

public JToolTip createToolTip()
返回用于显示工具提示的 JToolTip 实例。组件通常不重写此方法，但是可将其用于以不同的方式显示不同的工具提示。

返回：
用于显示此工具提示的 JToolTip

scrollRectToVisible

public void scrollRectToVisible(Rectangle aRect)
将 scrollRectToVisible() 消息转发到 JComponent 的父组件。可执行该请求的组件（如 JViewport）会重写此方法并执行滚动。

参数：
aRect - 可见的 Rectangle
另请参见：
JViewport

setAutoscrolls

public void setAutoscrolls(boolean autoscrolls)
设置 autoscrolls 属性。如果为 true，则在将鼠标拖动到组件的边界外并且鼠标移动已暂停（但是继续按下鼠标按键）时，人为地生成鼠标拖动事件。该人为事件使得拖动动作似乎在跨越组件的边界时所建立的方向上得以恢复。支持自动滚动的组件必须处理 mouseDragged 事件，通过调用带有一个包含鼠标事件位置的矩形的 scrollRectToVisible 来完成。所有支持项选择以及通常在 JScrollPane（JTable、JList、JTree、JTextArea 和 JEditorPane）中显示的 Swing 组件都将以这种方式处理鼠标拖动事件。要在任何其他组件中启用自动滚动，可添加一个调用 scrollRectToVisible 的鼠标移动侦听器。例如，给定 JPanel、myPanel：
 MouseMotionListener doScrollRectToVisible = new MouseMotionAdapter() {
     public void mouseDragged(MouseEvent e) {
        Rectangle r = new Rectangle(e.getX(), e.getY(), 1, 1);
        ((JPanel)e.getSource()).scrollRectToVisible(r);
    }
 };
 myPanel.addMouseMotionListener(doScrollRectToVisible);
autoScrolls 属性的默认值是 false。

参数：
autoscrolls - 如果为 true，则在将鼠标拖动到组件的边界外并且继续按下鼠标按键时，生成人为鼠标拖动事件；否则为 false
另请参见：
getAutoscrolls(), JViewport, JScrollPane

getAutoscrolls

public boolean getAutoscrolls()
获取 autoscrolls 属性。

返回：
autoscrolls 属性的值
另请参见：
JViewport, setAutoscrolls(boolean)

setTransferHandler

public void setTransferHandler(TransferHandler newHandler)
设置 transferHandler 属性；如果该组件不支持数据传输操作，则为 null。

如果 newHandler 不为 null 并且系统属性 suppressSwingDropSupport 不为 true，则此方法将在 JComponent 上安装一个 DropTarget。该系统属性的默认值为 false，所以将添加一个 DropTarget。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

参数：
newHandler - 在组件之间传输数据的机制
从以下版本开始：
1.4
另请参见：
TransferHandler, getTransferHandler()

getTransferHandler

public TransferHandler getTransferHandler()
获取 transferHandler 属性。

返回：
transferHandler 属性的值
从以下版本开始：
1.4
另请参见：
TransferHandler, setTransferHandler(javax.swing.TransferHandler)

processMouseEvent

protected void processMouseEvent(MouseEvent e)
处理此组件上发生的鼠标事件，通过将其指派到任意已注册的 MouseListener 对象来完成，有关此方法的完整描述，请参阅 Component.processMouseEvent(MouseEvent)。

覆盖：
类 Component 中的 processMouseEvent
参数：
e - 鼠标事件
从以下版本开始：
1.5
另请参见：
Component.processMouseEvent(java.awt.event.MouseEvent)

processMouseMotionEvent

protected void processMouseMotionEvent(MouseEvent e)
处理鼠标移动事件，如 MouseEvent.MOUSE_DRAGGED。

覆盖：
类 Component 中的 processMouseMotionEvent
参数：
e - the MouseEvent
另请参见：
MouseEvent

enable

@Deprecated
public void enable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。

覆盖：
类 Component 中的 enable

disable

@Deprecated
public void disable()
已过时。 从 JDK version 1.1 开始，由 java.awt.Component.setEnabled(boolean) 取代。

覆盖：
类 Component 中的 disable

getAccessibleContext

public AccessibleContext getAccessibleContext()
返回与此 JComponent 关联的 AccessibleContext。此基类所实现的方法返回 null。扩展 JComponent 的类应该实现此方法，以返回与子类关联的 AccessibleContext。

覆盖：
类 Component 中的 getAccessibleContext
返回：
此 JComponent 的 AccessibleContext

getClientProperty

public final Object getClientProperty(Object key)
返回具有指定键的属性的值。只有通过 putClientProperty 添加的属性才返回非 null 值。

参数：
key - 查询的内容
返回：
此属性的值，或者返回 null
另请参见：
putClientProperty(java.lang.Object, java.lang.Object)

putClientProperty

public final void putClientProperty(Object key,
                                    Object value)
向此组件添加任意的键/值“客户端属性”。

get/putClientProperty 方法提供对每个实例小型哈希表的访问。调用者可以使用 get/putClientProperty 为另一个模块所创建的组件添加注释。例如，布局管理器可能以此方式来存储每个子组件的各种约束。例如：

 componentA.putClientProperty("to the left of", componentB);
如果值为 null，则此方法将移除该属性。通过 PropertyChange 事件报告客户端属性的更改。该属性的名称（为了 PropertyChange 事件）是 key.toString()。

clientProperty 字典不支持对 JComponent 的大范围扩展，也不适于在设计新组件时用做子类化的替代方法。

参数：
key - 新的客户端属性键
value - 新的客户端属性值，如果为 null，则此方法将移除该属性
另请参见：
getClientProperty(java.lang.Object), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

setFocusTraversalKeys

public void setFocusTraversalKeys(int id,
                                  Set<? extends AWTKeyStroke> keystrokes)
设置针对此 Component 的给定遍历操作的焦点遍历键。有关此方法的完整描述，请参阅 Component.setFocusTraversalKeys(int, java.util.Set)。

覆盖：
类 Container 中的 setFocusTraversalKeys
参数：
id - KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一
keystrokes - 指定操作的 AWTKeyStroke Set
抛出：
IllegalArgumentException - 如果 id 不是 KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS、KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS 或 KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS 之一、keystrokes 包含 null、keystroke 中的 Object 不是 AWTKeyStroke、任意 keystroke 表示一个 KEY_TYPED 事件，或者任意 keystroke 已经映射到此 Component 的另一个焦点遍历操作
从以下版本开始：
1.5
另请参见：
KeyboardFocusManager.FORWARD_TRAVERSAL_KEYS, KeyboardFocusManager.BACKWARD_TRAVERSAL_KEYS, KeyboardFocusManager.UP_CYCLE_TRAVERSAL_KEYS

isLightweightComponent

public static boolean isLightweightComponent(Component c)
如果此组件是轻量的，也就是说，如果它没有本机窗口系统同位体，则返回 true。

返回：
如果此组件是轻量的，则返回 true

reshape

@Deprecated
public void reshape(int x,
                               int y,
                               int w,
                               int h)
已过时。 从 JDK 5 开始，由 Component.setBounds(int, int, int, int) 取代。

移动此组件并调整其大小。

覆盖：
类 Component 中的 reshape
参数：
x - 新的水平位置
y - 新的垂直位置
w - 新的宽度
h - 新的高度
另请参见：
Component.setBounds(int, int, int, int)

getBounds

public Rectangle getBounds(Rectangle rv)
将此组件的边界存储到“返回值”rv 中并返回 rv。如果 rv 为 null，则分配一个新的 Rectangle。如果调用者不希望在堆上分配一个新的 Rectangle 对象，则这种 getBounds 是很有用的。

覆盖：
类 Component 中的 getBounds
参数：
rv - 返回值，被修改为该组件的边界
返回：
rv；如果 rv 为 null，则返回具有此组件边界的新建 Rectangle

getSize

public Dimension getSize(Dimension rv)
将此组件的宽度/高度存储到“返回值”rv 中并返回 rv。如果 rv 为 null，则分配一个新的 Dimension 对象。如果调用者不希望在堆上分配一个新的 Dimension 对象，则这种 getSize 是很有用的。

覆盖：
类 Component 中的 getSize
参数：
rv - 返回值，被修改为该组件的大小
返回：
rv

getLocation

public Point getLocation(Point rv)
将此组件的 x，y 原点存储到“返回值”rv 中并返回 rv。如果 rv 为 null，则分配一个新的 Point。如果调用者不希望在堆上分配一个新的 Point 对象，则这种 getLocation 是很有用的。

覆盖：
类 Component 中的 getLocation
参数：
rv - 返回值，被修改为该组件的位置
返回：
rv

getX

public int getX()
返回组件原点的当前 x 坐标。此方法优于 component.getBounds().x 或 component.getLocation().x，因为它不会导致任何堆分配。

覆盖：
类 Component 中的 getX
返回：
组件原点的当前 x 坐标

getY

public int getY()
返回组件原点的当前 y 坐标。此方法优于 component.getBounds().y 或 component.getLocation().y，因为它不会导致任何堆分配。

覆盖：
类 Component 中的 getY
返回：
组件原点的当前 y 坐标

getWidth

public int getWidth()
返回此组件的当前宽度。此方法优于 component.getBounds().width 或 component.getSize().width，因为它不会导致任何堆分配。

覆盖：
类 Component 中的 getWidth
返回：
此组件的当前宽度

getHeight

public int getHeight()
返回此组件的当前高度。此方法优于 component.getBounds().height 或 component.getSize().height，因为它不会导致任何堆分配。

覆盖：
类 Component 中的 getHeight
返回：
此组件的当前高度

isOpaque

public boolean isOpaque()
如果此组件是完全不透明的，则返回 true。

不透明组件将每个像素绘制在其矩形边界内。透明的组件则仅绘制部分像素或者不绘制任何像素，允许其底层像素“透视出来”。因此，没有完全绘制其像素的组件则提供了一定程度的透明度。

保证总是完全绘制其内容的子类应该重写此方法并返回 true。

覆盖：
类 Component 中的 isOpaque
返回：
如果此组件是完全不透明的，则返回 true
另请参见：
setOpaque(boolean)

setOpaque

public void setOpaque(boolean isOpaque)
如果为 true，则该组件绘制其边界内的所有像素。否则该组件可能不绘制部分或所有像素，从而允许其底层像素透视出来。

对于 JComponent 而言，此属性的默认值是 false。但是对于大多数标准的 JComponent 子类（如 JButton 和 JTree），此属性的默认值与外观有关。

参数：
isOpaque - 如果此组件应该是不透明的，则为 true
另请参见：
isOpaque()

computeVisibleRect

public void computeVisibleRect(Rectangle visibleRect)
返回该 Component 的“可见 rect 矩形”，即此组件及其所有祖先的可见矩形的交集。返回值存储在 visibleRect 中。

参数：
visibleRect - 根据此组件及其所有祖先的所有可见矩形交集而计算出的 Rectangle，这是此方法的返回值
另请参见：
getVisibleRect()

getVisibleRect

public Rectangle getVisibleRect()
返回该 Component 的“可见矩形”，即此组件的可见矩形 new Rectangle(0, 0, getWidth(), getHeight()) 及其所有祖先的可见矩形的交集。

返回：
可见矩形

firePropertyChange

public void firePropertyChange(String propertyName,
                               boolean oldValue,
                               boolean newValue)
支持报告 boolean 属性的绑定属性更改。当更改了绑定属性，并且向所有已注册的 PropertyChangeListener 发送相应的 PropertyChangeEvent 时可以调用此方法。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 其值已更改的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

public void firePropertyChange(String propertyName,
                               int oldValue,
                               int newValue)
支持报告整数属性的绑定属性更改。当更改了绑定属性，并且向所有已注册的 PropertyChangeListener 发送相应的 PropertyChangeEvent 时可以调用此方法。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 其值已更改的属性
oldValue - 该属性以前的值
newValue - 该属性的新值

firePropertyChange

public void firePropertyChange(String propertyName,
                               char oldValue,
                               char newValue)
从类 Component 复制的描述
报告绑定属性的改变。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 已改变的属性的编程名称
oldValue - 该属性的旧值（char 类型）
newValue - 该属性的新值（char 类型）
另请参见：
Component.firePropertyChange(java.lang.String, java.lang.Object, java.lang.Object)

fireVetoableChange

protected void fireVetoableChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
                           throws PropertyVetoException
支持报告约束 (constrained) 属性的更改。当更改了约束属性，并且向所有已注册的 VetoableChangeListener 发送相应的 PropertyChangeEvent 时可以调用此方法。

参数：
propertyName - 对其进行侦听的属性名称
oldValue - 该属性的旧值
newValue - 该属性的新值
抛出：
PropertyVetoException - 如果组件禁止设置该属性

addVetoableChangeListener

public void addVetoableChangeListener(VetoableChangeListener listener)
向侦听器列表添加一个 VetoableChangeListener。为所有属性注册该侦听器。

参数：
listener - 要添加的 VetoableChangeListener

removeVetoableChangeListener

public void removeVetoableChangeListener(VetoableChangeListener listener)
从侦听器列表移除一个 VetoableChangeListener。此方法移除了一个为所有属性注册的 VetoableChangeListener。

参数：
listener - 要移除的 VetoableChangeListener

getVetoableChangeListeners

public VetoableChangeListener[] getVetoableChangeListeners()
返回在此组件上注册的所有可否决更改侦听器所组成的数组。

返回：
组件的所有 VetoableChangeListener；如果当前没有注册任何可否决更改侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addVetoableChangeListener(java.beans.VetoableChangeListener), removeVetoableChangeListener(java.beans.VetoableChangeListener)

getTopLevelAncestor

public Container getTopLevelAncestor()
返回此组件的顶层祖先（包含的 Window 或 Applet）；如果尚未将此组件添加到任意容器中，则返回 null。

返回：
此组件所在的顶层 Container；如果不在任何容器中，则返回 null

addAncestorListener

public void addAncestorListener(AncestorListener listener)
注册 listener，从而当组件或其任意祖先移动，或者变得可见或不可见时该侦听器将收到 AncestorEvent。从包含层次结构中添加或移除组件或其祖先时，也发送这些事件。

参数：
listener - 要注册的 AncestorListener
另请参见：
AncestorEvent

removeAncestorListener

public void removeAncestorListener(AncestorListener listener)
注销 listener，使其不再接收 AncestorEvent。

参数：
listener - 要移除的 AncestorListener
另请参见：
addAncestorListener(javax.swing.event.AncestorListener)

getAncestorListeners

public AncestorListener[] getAncestorListeners()
返回在此组件上注册的所有祖先侦听器所组成的数组。

返回：
组件的所有 AncestorListener；如果当前没有注册任何祖先侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addAncestorListener(javax.swing.event.AncestorListener), removeAncestorListener(javax.swing.event.AncestorListener)

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回当前在此 JComponent 上注册为 FooListener 的所有对象所组成的数组。FooListener 是使用 addFooListener 方法注册的。

可以使用 class 字面值来指定 listenerType 参数，如 FooListener.class。例如，可以使用以下代码来查询 JComponent c 的鼠标侦听器：

MouseListener[] mls = (MouseListener[])(c.getListeners(MouseListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

覆盖：
类 Container 中的 getListeners
参数：
listenerType - 所请求的侦听器的类型；此参数应该指定一个从 java.util.EventListener 继承的接口
返回：
返回一个在此组件上注册为 FooListener 的所有对象所组成的数组；如果尚未添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 未指定一个实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getVetoableChangeListeners(), getAncestorListeners()

addNotify

public void addNotify()
通知此组件它现在已有了一个父组件。调用此方法时，通过 KeyboardAction 事件侦听器设置父组件链。

覆盖：
类 Container 中的 addNotify
另请参见：
registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

removeNotify

public void removeNotify()
通知此组件它不再有父组件。调用此方法时，移除父组件链中所有已设置的 KeyboardAction。

覆盖：
类 Container 中的 removeNotify
另请参见：
registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

repaint

public void repaint(long tm,
                    int x,
                    int y,
                    int width,
                    int height)
如果要显示组件，则将指定的区域添加到脏区 (dirty region) 列表。指派完当前所有未完成的事件后重新绘制该组件。

覆盖：
类 Component 中的 repaint
参数：
tm - 不使用此参数
x - 脏区的 x 值
y - 脏区的 y 值
width - 脏区的宽度
height - 脏区的高度
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

repaint

public void repaint(Rectangle r)
如果要显示该组件，则将指定的区域添加到脏区列表。指派完当前所有未完成的事件后重新绘制该组件。

参数：
r - 包含脏区的 Rectangle
另请参见：
Component.isShowing(), RepaintManager.addDirtyRegion(javax.swing.JComponent, int, int, int, int)

revalidate

public void revalidate()
支持推迟的自动布局。

调用 invalidate 并将此组件的 validateRoot 添加到需要验证的组件列表中。指派完当前所有未完成的事件后进行验证。换句话说，调用此方法后，将验证浏览此组件的包含层次结构时找到的第一个 validateRoot（如果有）。默认情况下，对 JRootPane、JScrollPane 和 JTextField 调用 isValidateRoot 返回 true。

当属性值更改，从而影响此组件的大小、位置或内部布局时，就对此组件自动调用此方法。这种自动更新不同于 AWT，因为通常来说，程序不再需要调用 validate 来获得要更新的 GUI 的内容。

另请参见：
Component.invalidate(),
Container.validate(),
isValidateRoot(),
RepaintManager.addInvalidComponent(javax.swing.JComponent)

isValidateRoot

public boolean isValidateRoot()
如果此方法返回 true，则此组件的子代调用 revalidate 将导致从此根开始对整棵树进行验证。默认情况下返回 false。JScrollPane 重写此方法并返回 true。

返回：
始终返回 false
另请参见：
revalidate(),
Component.invalidate(),
Container.validate()

isOptimizedDrawingEnabled

public boolean isOptimizedDrawingEnabled()
如果此组件平铺显示其子组件（也就是说，它可以保证子组件不重叠），则返回 true。通常，在此情况下重绘系统的效率非常高。无法作出此保证的 JComponent 子类（如 JLayeredPane）应该重写此方法以返回 false。

返回：
始终返回 true

paintImmediately

public void paintImmediately(int x,
                             int y,
                             int w,
                             int h)
立即绘制此组件及其与该区域重叠的子代中的指定区域。

极少需要调用此方法。在大多数情况下，调用 repaint 更为高效，repaint 会推迟实际的绘制并将多余的请求压缩为单个 paint 调用。如果需要在指派当前事件的同时更新显示，则此方法很有用。

参数：
x - 要绘制区域的 x 值
y - 要绘制区域的 y 值
w - 要绘制区域的宽度
h - 要绘制区域的高度
另请参见：
repaint(long, int, int, int, int)

paintImmediately

public void paintImmediately(Rectangle r)
立即绘制指定的区域。

参数：
r - 包含要绘制区域的 Rectangle

setDoubleBuffered

public void setDoubleBuffered(boolean aFlag)
设置此组件是否应该使用缓冲区进行绘制。如果设置为 true，则此组件的所有绘制将在一个离屏绘制缓冲区内完成。然后将该离屏绘制缓冲区复制到屏幕上。如果缓冲了某个 Component，并且还缓冲了它的某个祖先，则将使用该祖先缓冲区。

参数：
aFlag - 如果为 true，则设置此组件使用双缓冲区进行缓冲

isDoubleBuffered

public boolean isDoubleBuffered()
返回此组件是否应该使用缓冲区进行绘制。

覆盖：
类 Component 中的 isDoubleBuffered
返回：
如果此组件使用双缓冲区进行缓冲，则返回 true；否则返回 false

getRootPane

public JRootPane getRootPane()
返回此组件的 JRootPane 祖先。

返回：
包含此组件的 JRootPane；如果未找到 JRootPane，则为 null

paramString

protected String paramString()
返回此 JComponent 的字符串表示形式。此方法仅在调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Container 中的 paramString
返回：
此 JComponent 的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComponent.AccessibleJComponent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComponent.AccessibleJComponent

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
直接已知子类：
AbstractButton.AccessibleAbstractButton, JColorChooser.AccessibleJColorChooser, JComboBox.AccessibleJComboBox, JDesktopPane.AccessibleJDesktopPane, JFileChooser.AccessibleJFileChooser, JInternalFrame.AccessibleJInternalFrame, JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon, JLabel.AccessibleJLabel, JLayeredPane.AccessibleJLayeredPane, JList.AccessibleJList, JMenuBar.AccessibleJMenuBar, JOptionPane.AccessibleJOptionPane, JPanel.AccessibleJPanel, JPopupMenu.AccessibleJPopupMenu, JProgressBar.AccessibleJProgressBar, JRootPane.AccessibleJRootPane, JScrollBar.AccessibleJScrollBar, JScrollPane.AccessibleJScrollPane, JSeparator.AccessibleJSeparator, JSlider.AccessibleJSlider, JSpinner.AccessibleJSpinner, JSplitPane.AccessibleJSplitPane, JTabbedPane.AccessibleJTabbedPane, JTable.AccessibleJTable, JTableHeader.AccessibleJTableHeader, JTextComponent.AccessibleJTextComponent, JToolBar.AccessibleJToolBar, JToolTip.AccessibleJToolTip, JTree.AccessibleJTree, JViewport.AccessibleJViewport
正在封闭类：
JComponent
public abstract class JComponent.AccessibleJComponent
extends Container.AccessibleAWTContainer
implements AccessibleExtendedComponent

用于为可访问性提供默认支持的 JComponent 内部类。此类并非旨在由应用程序开发人员直接使用，而只能由容器开发人员为其创建子类。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected class | JComponent.AccessibleJComponent.AccessibleContainerHandler 添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
protected class | JComponent.AccessibleJComponent.AccessibleFocusHandler 发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
protected ContainerListener | accessibleContainerHandler
protected FocusListener | accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JComponent.AccessibleJComponent()
尽管该类是抽象的，但是应该通过所有子类调用它。
方法摘要
void | addPropertyChangeListener(PropertyChangeListener listener) 将一个 PropertyChangeListener 添加到侦听器列表中。
Accessible | getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
int | getAccessibleChildrenCount() 返回对象中可访问的子级数。
String | getAccessibleDescription() 获取此对象的可访问描述。
AccessibleKeyBinding | getAccessibleKeyBinding() 返回与此对象关联的键绑定
String | getAccessibleName() 获取此对象的可访问名称。
AccessibleRole | getAccessibleRole() 获取此对象的功能。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
protected String | getBorderTitle(Border b) 在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。
String | getTitledBorderText() 返回有标题边界的文本
String | getToolTipText() 返回工具提示文本
void | removePropertyChangeListener(PropertyChangeListener listener) 从侦听器列表移除一个 PropertyChangeListener。
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

字段详细信息

accessibleContainerHandler

protected ContainerListener accessibleContainerHandler

accessibleFocusHandler

protected FocusListener accessibleFocusHandler
构造方法详细信息

JComponent.AccessibleJComponent

protected JComponent.AccessibleJComponent()
尽管该类是抽象的，但是应该通过所有子类调用它。

方法详细信息

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到侦听器列表中。

覆盖：
类 Container.AccessibleAWTContainer 中的 addPropertyChangeListener
参数：
listener - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 Component.AccessibleAWTComponent 中的 removePropertyChangeListener
参数：
listener - 要移除的 PropertyChangeListener to be removed

getBorderTitle

protected String getBorderTitle(Border b)
在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。此方法首先在内部边界，然后在外部边界上执行深度优先搜索。在复合边界的情况中，假定标题实际上完全在边界内部，而不是完全在边界外部。这是相当随意的，但是希望可敬的 UI 程序员不会为相同的组件创建多个有标题的边界。

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。此方法几乎从不返回 java.awt.Component.getName() 获得的名称，因为该名称通常不是一个本地化名称，并且对用户没有任何意义。如果该对象从根本上说是一个文本对象（例如，菜单项），那么可访问的名称应是该对象的文本（例如，“保存”）。如果该对象有工具提示，则工具提示文本还可以是要返回的合适的 String。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleName
返回：
对象的本地化名称，如果此对象不具有名称，则可以为 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问描述。这应该是一个简明的本地化描述，描述此对象是什么，即对用户来说有何意义。如果该对象有一个工具提示，则该工具提示文本可以是要返回的合适的字符串，假设该字符串包含对该对象的简明描述（而不仅仅是该对象的名称。例如，将“保存”作为工具提示文本的工具栏上的“保存”图标不应返回工具提示文本作为描述，而应为“保存当前文本文档”）。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleDescription
返回：
返回该对象的本地化描述，如果此对象没有描述，则可能为 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的功能。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleRole
返回：
描述该对象功能的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 实例
另请参见：
AccessibleState

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中可访问的子级数。如果此对象的所有子级都实现 Accessible，则此方法应该返回该对象的子级数。

覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个可访问子级。

覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleChild
参数：
i - 从零开始的子级索引
返回：
该对象的第 n 个可访问子级
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getToolTipText

public String getToolTipText()
返回工具提示文本

指定者：
接口 AccessibleExtendedComponent 中的 getToolTipText
返回：
对象的工具提示文本（如果支持）；否则返回 null
从以下版本开始：
1.4

getTitledBorderText

public String getTitledBorderText()
返回有标题边界的文本

指定者：
接口 AccessibleExtendedComponent 中的 getTitledBorderText
返回：
对象的有标题边界文本（如果支持）；否则返回 null
从以下版本开始：
1.4

getAccessibleKeyBinding

public AccessibleKeyBinding getAccessibleKeyBinding()
返回与此对象关联的键绑定

指定者：
接口 AccessibleExtendedComponent 中的 getAccessibleKeyBinding
返回：
对象的键绑定（如果支持）；否则返回 null
从以下版本开始：
1.4
另请参见：
AccessibleKeyBinding
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComponent.AccessibleJComponent.AccessibleContainerHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComponent.AccessibleJComponent.AccessibleContainerHandler

java.lang.Object
    继承者  javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler
所有已实现的接口：
ContainerListener, EventListener
正在封闭类：
JComponent.AccessibleJComponent
protected class JComponent.AccessibleJComponent.AccessibleContainerHandler
extends Object
implements ContainerListener

添加或移除子容器时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

构造方法摘要
protected JComponent.AccessibleJComponent.AccessibleContainerHandler()
方法摘要
void | componentAdded(ContainerEvent e) 已将组件添加到容器中时调用。
void | componentRemoved(ContainerEvent e) 已从容器中移除组件时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JComponent.AccessibleJComponent.AccessibleContainerHandler

protected JComponent.AccessibleJComponent.AccessibleContainerHandler()
方法详细信息

componentAdded

public void componentAdded(ContainerEvent e)
从接口 ContainerListener 复制的描述
已将组件添加到容器中时调用。

指定者：
接口 ContainerListener 中的 componentAdded

componentRemoved

public void componentRemoved(ContainerEvent e)
从接口 ContainerListener 复制的描述
已从容器中移除组件时调用。

指定者：
接口 ContainerListener 中的 componentRemoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JComponent.AccessibleJComponent.AccessibleFocusHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JComponent.AccessibleJComponent.AccessibleFocusHandler

java.lang.Object
    继承者  javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler
所有已实现的接口：
FocusListener, EventListener
正在封闭类：
JComponent.AccessibleJComponent
protected class JComponent.AccessibleJComponent.AccessibleFocusHandler
extends Object
implements FocusListener

发生焦点事件时激发 PropertyChange 侦听器（如果已注册了此侦听器）。

从以下版本开始：
1.3

构造方法摘要
protected JComponent.AccessibleJComponent.AccessibleFocusHandler()
方法摘要
void | focusGained(FocusEvent event) 组件获得键盘焦点时调用。
void | focusLost(FocusEvent event) 组件失去键盘焦点时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JComponent.AccessibleJComponent.AccessibleFocusHandler

protected JComponent.AccessibleJComponent.AccessibleFocusHandler()
方法详细信息

focusGained

public void focusGained(FocusEvent event)
从接口 FocusListener 复制的描述
组件获得键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusGained

focusLost

public void focusLost(FocusEvent event)
从接口 FocusListener 复制的描述
组件失去键盘焦点时调用。

指定者：
接口 FocusListener 中的 focusLost
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JDesktopPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JDesktopPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLayeredPane
                    继承者  javax.swing.JDesktopPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JDesktopPane
extends JLayeredPane
implements Accessible

用于创建多文档界面或虚拟桌面的容器。用户可创建 JInternalFrame 对象并将其添加到 JDesktopPane。JDesktopPane 扩展了 JLayeredPane，以管理可能的重叠内部窗体。它还维护了对 DesktopManager 实例的引用，这是由 UI 类为当前的外观 (L&F) 所设置的。注意，JDesktopPane 不支持边界。

此类通常用作 JInternalFrames 的父类，为 JInternalFrames 提供一个可插入的 DesktopManager 对象。特定于 L&F 的实现 installUI 负责正确设置 desktopManager 变量。JInternalFrame 的父类是 JDesktopPane 时，它应该将其大部分行为（关闭、调整大小等）委托给 desktopManager。

有关此内容更多的文档和示例，请参阅 The Java Tutorial 的 How to Use Internal Frames 一节。

警告： Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JInternalFrame, JInternalFrame.JDesktopIcon, DesktopManager

嵌套类摘要
protected  class JDesktopPane.AccessibleJDesktopPane
此类实现对 JDesktopPane 类的可访问性支持。
从类 javax.swing.JLayeredPane 继承的嵌套类/接口
JLayeredPane.AccessibleJLayeredPane
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | LIVE_DRAG_MODE 指示正在被拖动项的所有内容是否应该出现在桌面窗格内部。
static int | OUTLINE_DRAG_MODE 指示桌面窗格是否只应该出现正在被拖动项的轮廓。
从类 javax.swing.JLayeredPane 继承的字段
DEFAULT_LAYER, DRAG_LAYER, FRAME_CONTENT_LAYER, LAYER_PROPERTY, MODAL_LAYER, PALETTE_LAYER, POPUP_LAYER
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JDesktopPane()
创建一个新的 JDesktopPane。
方法摘要
protected void | addImpl(Component comp, Object constraints, int index) 将指定组件添加到此容器的指定索引所在的位置上。
AccessibleContext | getAccessibleContext() 获取与此 JDesktopPane 关联的 AccessibleContext。
JInternalFrame[] | getAllFrames() 返回桌面中当前显示的所有 JInternalFrames。
JInternalFrame[] | getAllFramesInLayer(int layer) 返回桌面指定层中当前所显示的所有 JInternalFrames。
DesktopManager | getDesktopManager() 返回处理特定于桌面 UI 操作的 DesktopManger。
int | getDragMode() 获取桌面窗格当前使用的“拖动样式”。
JInternalFrame | getSelectedFrame() 返回此 JDesktopPane 中当前活动的 JInternalFrame，如果当前没有活动的 JInternalFrame，则返回 null。
DesktopPaneUI | getUI() 返回呈现此组件的 L&F 对象。
String | getUIClassID() 返回呈现此组件的 L&F 类名。
protected String | paramString() 返回此 JDesktopPane 的字符串表示形式。
void | remove(int index) 从此窗格中移除已索引的组件。
void | removeAll() 从此容器中移除所有组件。
JInternalFrame | selectFrame(boolean forward) 选择此桌面窗格中的下一个 JInternalFrame。
void | setComponentZOrder(Component comp, int index) 将指定组件移动到容器中指定的 z 顺序索引。
void | setDesktopManager(DesktopManager d) 设置处理特定于桌面 UI 操作的 DesktopManger。
void | setDragMode(int dragMode) 设置桌面窗格使用的“拖动样式”。
void | setSelectedFrame(JInternalFrame f) 设置此 JDesktopPane 中当前活动的 JInternalFrame。
void | setUI(DesktopPaneUI ui) 设置呈现此组件的 L&F 对象。
void | updateUI() UIManager 发出的关于 L&F 已更改的通知。
从类 javax.swing.JLayeredPane 继承的方法
getComponentCountInLayer, getComponentsInLayer, getComponentToLayer, getIndexOf, getLayer, getLayer, getLayeredPaneAbove, getObjectForLayer, getPosition, highestLayer, insertIndexForLayer, isOptimizedDrawingEnabled, lowestLayer, moveToBack, moveToFront, paint, putLayer, setLayer, setLayer, setPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeContainerListener, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

LIVE_DRAG_MODE

public static final int LIVE_DRAG_MODE
指示正在被拖动项的所有内容是否应该出现在桌面窗格内部。

另请参见：
OUTLINE_DRAG_MODE, setDragMode(int), 常量字段值

OUTLINE_DRAG_MODE

public static final int OUTLINE_DRAG_MODE
指示桌面窗格是否只应该出现正在被拖动项的轮廓。

另请参见：
LIVE_DRAG_MODE, setDragMode(int), 常量字段值
构造方法详细信息

JDesktopPane

public JDesktopPane()
创建一个新的 JDesktopPane。

方法详细信息

getUI

public DesktopPaneUI getUI()
返回呈现此组件的 L&F 对象。

返回：
呈现此组件的 DesktopPaneUI 对象

setUI

public void setUI(DesktopPaneUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - DesktopPaneUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

setDragMode

public void setDragMode(int dragMode)
设置桌面窗格使用的“拖动样式”。出于性能或审美的原因，可能要更改模式。

参数：
dragMode - 为 Desktop 中各项所用的拖动样式
从以下版本开始：
1.3
另请参见：
LIVE_DRAG_MODE, OUTLINE_DRAG_MODE

getDragMode

public int getDragMode()
获取桌面窗格当前使用的“拖动样式”。

返回：
Live_DRAG_MODE 或 OUTLINE_DRAG_MODE
从以下版本开始：
1.3
另请参见：
setDragMode(int)

getDesktopManager

public DesktopManager getDesktopManager()
返回处理特定于桌面 UI 操作的 DesktopManger。

setDesktopManager

public void setDesktopManager(DesktopManager d)
设置处理特定于桌面 UI 操作的 DesktopManger。

参数：
d - 所使用的 DesktopManager

updateUI

public void updateUI()
UIManager 发出的关于 L&F 已更改的通知。用来自 UIManager 的最新版本 UI 对象替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类名。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "DesktopPaneUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getAllFrames

public JInternalFrame[] getAllFrames()
返回桌面中当前显示的所有 JInternalFrames。返回图标化的窗体和扩展的窗体。

返回：
JInternalFrame 对象的数组

getSelectedFrame

public JInternalFrame getSelectedFrame()
返回此 JDesktopPane 中当前活动的 JInternalFrame，如果当前没有活动的 JInternalFrame，则返回 null。

返回：
当前活动的 JInternalFrame 或 null
从以下版本开始：
1.3

setSelectedFrame

public void setSelectedFrame(JInternalFrame f)
设置此 JDesktopPane 中当前活动的 JInternalFrame。此方法用于连接JDesktopPane 和平台实现代码，不应该直接调用。要可视化地选择窗体，客户端必须调用 JInternalFrame.setSelected(true) 激活窗体。

参数：
f - 当前选中的内部窗体
从以下版本开始：
1.3
另请参见：
JInternalFrame.setSelected(boolean)

getAllFramesInLayer

public JInternalFrame[] getAllFramesInLayer(int layer)
返回桌面指定层中当前所显示的所有 JInternalFrames。返回图标化的窗体和扩展的窗体。

参数：
layer - 指定桌面层的 int 值
返回：
JInternalFrame 对象的数组
另请参见：
JLayeredPane

selectFrame

public JInternalFrame selectFrame(boolean forward)
选择此桌面窗格中的下一个 JInternalFrame。

参数：
forward - 一个 boolean 值，指示选择的方向；true 表示向前，false 表示向后
返回：
选择的 JInternalFrame；如果未选择任何窗体，则返回 null
从以下版本开始：
1.6

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
将指定组件添加到此容器的指定索引所在的位置上。此方法还通知布局管理器，通过 addLayoutComponent 方法，使用指定的约束对象将组件添加到此容器的布局中。

这些约束是由正使用的特定布局管理器定义的。例如，BorderLayout 类定义了五个约束：BorderLayout.NORTH、BorderLayout.SOUTH、BorderLayout.EAST、BorderLayout.WEST 和 BorderLayout.CENTER。

GridBagLayout 类需要一个 GridBagConstraints 对象。如果传递正确的约束对象类型时失败，则会导致 IllegalArgumentException。

如果当前布局管理器实现了 LayoutManager2，则在其上调用 LayoutManager2.addLayoutComponent(Component,Object)。如果当前布局管理器没有实现 LayoutManager2，并且约束是一个 String，则在其上调用 LayoutManager.addLayoutComponent(String,Component)。

如果该组件不是此容器的祖先容器，并且有一个非 null 父组件，则在将该组件添加到此容器之前，从其当前父组件中移除它。

在其他所有添加方法引用此方法时，如果某个程序需要追踪每个添加到容器的请求，那么这就是要重写的方法。被重写的方法通常应该包括一个对该方法的超类版本的调用：

super.addImpl(comp, constraints, index)

覆盖：
类 JLayeredPane 中的 addImpl
参数：
comp - 要添加的组件
constraints - 表示此组件的布局约束的对象
从以下版本开始：
1.6
另请参见：
Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
LayoutManager,
LayoutManager2

remove

public void remove(int index)
从此窗格中移除已索引的组件。这是绝对索引，与层无关。

覆盖：
类 JLayeredPane 中的 remove
参数：
index - 指定要移除组件的 int 值
从以下版本开始：
1.6
另请参见：
JLayeredPane.getIndexOf(java.awt.Component)

removeAll

public void removeAll()
从此容器中移除所有组件。

覆盖：
类 JLayeredPane 中的 removeAll
从以下版本开始：
1.6
另请参见：
Container.add(java.awt.Component), Container.remove(int)

setComponentZOrder

public void setComponentZOrder(Component comp,
                               int index)
将指定组件移动到容器中指定的 z 顺序索引。z 顺序确定了绘制组件的顺序；具有最高 z 顺序的组件将第一个绘制，而具有最低 z 顺序的组件将最后一个绘制。在组件重叠的地方，具有较低 z 顺序的组件将覆盖具有较高 z 顺序的组件。

如果组件是其他某个 container 的子组件，则在将它添加到此容器之前，从该容器中移除它。此方法与 java.awt.Container.add(Component, int) 之间的重要不同是，在将组件从其以前的容器中移除时，此方法不对该组件调用 removeNotify，除非有此必要，并且基础本机窗口系统允许这样做。因此，如果组件拥有键盘焦点，那么在移动到新的位置上时，它会维持该焦点。

要保证此属性只应用于轻量级的非 Container 组件。

注：并不是所有的平台都支持在不调用 removeNotify 的情况下，将重量级组件的 z 顺序从一个容器更改到另一个容器中。无法检测某个平台是否支持这一点，因此开发人员不应该作出任何假设。

覆盖：
类 Container 中的 setComponentZOrder
参数：
comp - 要移动的组件
index - 在容器的列表中插入组件的位置，其中 getComponentCount() 指追加到尾部
从以下版本开始：
1.6
另请参见：
Container.getComponentZOrder(java.awt.Component)

paramString

protected String paramString()
返回此 JDesktopPane 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JLayeredPane 中的 paramString
返回：
此 JDesktopPane 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JDesktopPane 关联的 AccessibleContext。对于桌面窗格，AccessibleContext 采用 AccessibleJDesktopPane 的形式。如有必要，可以创建一个新的 AccessibleJDesktopPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JLayeredPane 中的 getAccessibleContext
返回：
充当此 JDesktopPane 的 AccessibleContext 的 AccessibleJDesktopPane
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JDesktopPane.AccessibleJDesktopPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JDesktopPane.AccessibleJDesktopPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JDesktopPane.AccessibleJDesktopPane
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JDesktopPane
protected class JDesktopPane.AccessibleJDesktopPane
extends JComponent.AccessibleJComponent

此类实现对 JDesktopPane 类的可访问性支持。它提供适合于桌面窗格用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JDesktopPane.AccessibleJDesktopPane()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的功能。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JDesktopPane.AccessibleJDesktopPane

protected JDesktopPane.AccessibleJDesktopPane()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的功能。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象功能的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JDialog (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JDialog

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
                继承者  java.awt.Dialog
                    继承者  javax.swing.JDialog
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer, WindowConstants
public class JDialog
extends Dialog
implements WindowConstants, Accessible, RootPaneContainer

创建对话框窗口的主要类。可以使用此类创建自定义的对话框，或者调用 JOptionPane 中的多个类方法来创建各种标准对话框。有关创建对话框的信息，请参阅 The Java Tutorial 中的 How to Make Dialogs 一节。

JDialog 组件包含一个 JRootPane 作为其唯一子组件。contentPane 应该是所有 JDialog 子组件的父级。为了方便使用 add 及其变体，已经重写了 remove 和 setLayout，以在必要时将其转发到 contentPane。这意味着可以编写：

       dialog.add(child);
将子级添加到 contentPane。contentPane 始终是非 null 的。试图将其设置为 null 会生成异常。默认的 contentPane 有一个 BorderLayout 管理器。有关添加、移除和设置 JDialog 的 LayoutManager 的更多信息，请参阅 RootPaneContainer。

有关 contentPane、glassPane 和 layeredPane 组件的完整描述，请参阅 JRootPane 文档。

在多屏幕环境中，可以在不同于其所有者的屏幕设备上创建一个 JDialog。有关更多信息，请参阅 Frame。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JOptionPane, JRootPane, RootPaneContainer

嵌套类摘要
protected  class JDialog.AccessibleJDialog
此类实现对 JDialog 类的可访问性支持。
从类 java.awt.Dialog 继承的嵌套类/接口
Dialog.AccessibleAWTDialog, Dialog.ModalExclusionType, Dialog.ModalityType
从类 java.awt.Window 继承的嵌套类/接口
Window.AccessibleAWTWindow
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected AccessibleContext | accessibleContext
protected JRootPane | rootPane
protected boolean | rootPaneCheckingEnabled 如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
从类 java.awt.Dialog 继承的字段
DEFAULT_MODALITY_TYPE
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.WindowConstants 继承的字段
DISPOSE_ON_CLOSE, DO_NOTHING_ON_CLOSE, EXIT_ON_CLOSE, HIDE_ON_CLOSE
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JDialog()
创建一个没有标题并且没有指定 Frame 所有者的无模式对话框。
JDialog(Dialog owner)
创建一个没有标题但将指定的 Dialog 作为其所有者的无模式对话框。
JDialog(Dialog owner, boolean modal)
创建一个具有指定所有者 Dialog 和模式的对话框。
JDialog(Dialog owner, String title)
创建一个具有指定标题和指定所有者对话框的无模式对话框。
JDialog(Dialog owner, String title, boolean modal)
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。
JDialog(Dialog owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。
JDialog(Frame owner)
创建一个没有标题但将指定的 Frame 作为其所有者的无模式对话框。
JDialog(Frame owner, boolean modal)
创建一个具有指定所有者 Frame、模式和空标题的对话框。
JDialog(Frame owner, String title)
创建一个具有指定标题和指定所有者窗体的无模式对话框。
JDialog(Frame owner, String title, boolean modal)
创建一个具有指定标题、所有者 Frame 和模式的对话框。
JDialog(Frame owner, String title, boolean modal, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。
JDialog(Window owner)
创建一个具有指定所有者 Window 和空标题的无模式对话框。
JDialog(Window owner, Dialog.ModalityType modalityType)
创建一个具有指定所有者 Window、模式和空标题的对话框。
JDialog(Window owner, String title)
创建一个具有指定标题和所有者 Window 的无模式对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。
JDialog(Window owner, String title, Dialog.ModalityType modalityType, GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。
方法摘要
protected void | addImpl(Component comp, Object constraints, int index) 添加指定的子 Component。
protected JRootPane | createRootPane() 构造方法调用此方法来创建默认的 rootPane。
protected void | dialogInit() 构造方法调用此方法来正确初始化 JDialog。
AccessibleContext | getAccessibleContext() 获取与此 JDialog 关联的 AccessibleContext。
Container | getContentPane() 返回此对话框的 contentPane 对象。
int | getDefaultCloseOperation() 返回用户在此对话框上启动 "close" 时所执行的操作。
Component | getGlassPane() 返回此对话框的 glassPane 对象。
Graphics | getGraphics() 为组件创建一个图形上下文。
JMenuBar | getJMenuBar() 返回此对话框上设置的菜单栏。
JLayeredPane | getLayeredPane() 返回此对话框的 layeredPane 对象。
JRootPane | getRootPane() 返回此对话框的 rootPane 对象。
TransferHandler | getTransferHandler() 获取 transferHandler 属性。
static boolean | isDefaultLookAndFeelDecorated() 如果应该通过当前外观为新创建的 JDialog 提供其 Window 装饰，则返回 true。
protected boolean | isRootPaneCheckingEnabled() 返回是否将对 add 和 setLayout 的调用转发到 contentPane。
protected String | paramString() 返回此 JDialog 的字符串表示形式。
protected void | processWindowEvent(WindowEvent e) 根据 defaultCloseOperation 属性的状态处理窗口事件。
void | remove(Component comp) 从该容器中移除指定组件。
void | repaint(long time, int x, int y, int width, int height) 在 time 毫秒内重绘此组件的指定矩形区域。
void | setContentPane(Container contentPane) 设置 contentPane 属性。
void | setDefaultCloseOperation(int operation) 设置当用户在此对话框上启动 "close" 时默认执行的操作。
static void | setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated) 提供一个关于是否应该通过当前外观为新创建的 JDialog 提供其 Window 装饰（如边界、关闭窗口的小部件、标题……）的提示。
void | setGlassPane(Component glassPane) 设置 glassPane 属性。
void | setJMenuBar(JMenuBar menu) 设置此对话框的菜单栏。
void | setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | setLayout(LayoutManager manager) 设置 LayoutManager。
protected void | setRootPane(JRootPane root) 设置 rootPane 属性。
protected void | setRootPaneCheckingEnabled(boolean enabled) 设置是否将对 add 和 setLayout 的调用转发到 contentPane。
void | setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
void | update(Graphics g) 调用 paint(g)。
从类 java.awt.Dialog 继承的方法
addNotify, getModalityType, getTitle, hide, isModal, isResizable, isUndecorated, setModal, setModalityType, setResizable, setTitle, setUndecorated, setVisible, show, toBack
从类 java.awt.Window 继承的方法
addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getGraphicsConfiguration, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOwnedWindows, getOwner, getOwnerlessWindows, getToolkit, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isShowing, pack, postEvent, processEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, toFront
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

rootPane

protected JRootPane rootPane
另请参见：
getRootPane(), setRootPane(javax.swing.JRootPane)

rootPaneCheckingEnabled

protected boolean rootPaneCheckingEnabled
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。此方法初始为 false，但在构造 JDialog 时将其设置为 true。

另请参见：
isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

accessibleContext

protected AccessibleContext accessibleContext
构造方法详细信息

JDialog

public JDialog()
创建一个没有标题并且没有指定 Frame 所有者的无模式对话框。一个共享的、隐藏的窗体将被设置为该对话框的所有者。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

注：此构造方法不允许创建没有所有者的 JDialog。要创建没有所有者的 JDialog，必须使用带有 null 参数的 JDialog(Window) 或 JDialog(Dialog) 构造方法。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Frame owner)
创建一个没有标题但将指定的 Frame 作为其所有者的无模式对话框。如果 owner 为 null，则一个共享的、隐藏的窗体将被设置为该对话框的所有者。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

注：此构造方法不允许创建没有所有者的 JDialog。要创建没有所有者的 JDialog，必须使用带有 null 参数的 JDialog(Window) 或 JDialog(Dialog) 构造方法。

参数：
owner - 显示该对话框的 Frame
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Frame owner,
               boolean modal)
创建一个具有指定所有者 Frame、模式和空标题的对话框。如果 owner 为 null，则一个共享的、隐藏的窗体将被设置为该对话框的所有者。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

注：此构造方法不允许创建没有所有者的 JDialog。要创建没有所有者的 JDialog，必须使用带有 null 参数的 JDialog(Window) 或 JDialog(Dialog) 构造方法。

参数：
owner - 显示该对话框的 Frame
modal - 指定对话框在显示时是否阻塞用户向其他顶层窗口输入。如果为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE；否则对话框是无模式
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Frame owner,
               String title)
创建一个具有指定标题和指定所有者窗体的无模式对话框。如果 owner 为 null，则一个共享的、隐藏的窗体将被设置为该对话框的所有者。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

注：此构造方法不允许创建没有所有者的 JDialog。要创建没有所有者的 JDialog，必须使用带有 null 参数的 JDialog(Window) 或 JDialog(Dialog) 构造方法。

参数：
owner - 显示该对话框的 Frame
title - 该对话框的标题栏中所显示的 String
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Frame owner,
               String title,
               boolean modal)
创建一个具有指定标题、所有者 Frame 和模式的对话框。如果 owner 为 null，则一个共享的、隐藏的窗体将被设置为该对话框的所有者。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

注：强制要求在有模式对话框中所创建的所有弹出式组件（JComboBox、JPopupMenu、JMenuBar）都是轻量级的。

注：此构造方法不允许创建没有所有者的 JDialog。要创建没有所有者的 JDialog，必须使用带有 null 参数的 JDialog(Window) 或 JDialog(Dialog) 构造方法。

参数：
owner - 显示该对话框的 Frame
title - 该对话框的标题栏中所显示的 String
modal - 指定对话框在显示时是否阻塞用户向其他顶层窗口输入。如果为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE；否则对话框是无模式的。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Frame owner,
               String title,
               boolean modal,
               GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Frame、模式和 GraphicsConfiguration 的对话框。如果 owner 为 null，则一个共享的、隐藏的窗体将被设置为该对话框的所有者。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 返回的值。

注：强制要求在有模式对话框中所创建的所有弹出式组件（JComboBox、JPopupMenu、JMenuBar）都是轻量级的。

注：此构造方法不允许创建没有所有者的 JDialog。要创建没有所有者的 JDialog，必须使用带有 null 参数的 JDialog(Window) 或 JDialog(Dialog) 构造方法。

参数：
owner - 显示该对话框的 Frame
title - 该对话框的标题栏中所显示的 String
modal - 指定对话框在显示时是否阻塞用户向其他顶层窗口输入。如果为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE；否则对话框是无模式的。
gc - 目标屏幕设备的 GraphicsConfiguration。如果 gc 为 null，则使用与 Frame 相同的 GraphicsConfiguration。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
1.4
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Dialog owner)
创建一个没有标题但将指定的 Dialog 作为其所有者的无模式对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的所有者 Dialog；如果此对话框没有所有者，则为 null
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Dialog owner,
               boolean modal)
创建一个具有指定所有者 Dialog 和模式的对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的所有者 Dialog；如果此对话框没有所有者，则为 null
modal - 指定对话框在显示时是否阻塞用户向其他顶层窗口输入。如果为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE；否则对话框是无模式的。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Dialog owner,
               String title)
创建一个具有指定标题和指定所有者对话框的无模式对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的所有者 Dialog；如果此对话框没有所有者，则为 null
title - 该对话框的标题栏中所显示的 String
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Dialog owner,
               String title,
               boolean modal)
创建一个具有指定标题、模式和指定所有者 Dialog 的对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的所有者 Dialog；如果此对话框没有所有者，则为 null
title - 该对话框的标题栏中所显示的 String
modal - 指定对话框在显示时是否阻塞用户向其他顶层窗口输入。如果为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE；否则对话框是无模式的。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Dialog owner,
               String title,
               boolean modal,
               GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Dialog、模式和 GraphicsConfiguration 的对话框。

注：强制要求在有模式对话框中所创建的所有弹出式组件（JComboBox、JPopupMenu、JMenuBar）都是轻量级的。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的所有者 Dialog；如果此对话框没有所有者，则为 null
title - 该对话框的标题栏中所显示的 String
modal - 指定对话框在显示时是否阻塞用户向其他顶层窗口输入。如果为 true，则模式类型属性被设置为 DEFAULT_MODALITY_TYPE；否则对话框是无模式的。
gc - 目标屏幕设备的 GraphicsConfiguration。如果 gc 为 null，则使用与 Dialog 相同的 GraphicsConfiguration。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
1.4
另请参见：
Dialog.ModalityType, Dialog.ModalityType.MODELESS, Dialog.DEFAULT_MODALITY_TYPE, Dialog.setModal(boolean), Dialog.setModalityType(java.awt.Dialog.ModalityType), GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Window owner)
创建一个具有指定所有者 Window 和空标题的无模式对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的 Window；如果此对话框没有所有者，则为 null
抛出：
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.6
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Window owner,
               Dialog.ModalityType modalityType)
创建一个具有指定所有者 Window、模式和空标题的对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的 Window；如果此对话框没有所有者，则为 null
modalityType - 指定对话框在显示时是否阻塞向其他窗口输入。null 值和不受支持的模式类型等效于 MODELESS
抛出：
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.6
另请参见：
Dialog.ModalityType,
Dialog.setModal(boolean),
Dialog.setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
JComponent.getDefaultLocale()

JDialog

public JDialog(Window owner,
               String title)
创建一个具有指定标题和所有者 Window 的无模式对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的 Window；如果此对话框没有所有者，则为 null
title - 该对话框的标题栏中所显示的 String；如果该对话框没有标题，则为 null
抛出：
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.6
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JDialog

public JDialog(Window owner,
               String title,
               Dialog.ModalityType modalityType)
创建一个具有指定标题、所有者 Window 和模式的对话框。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的 Window；如果此对话框没有所有者，则为 null
title - 该对话框的标题栏中所显示的 String；如果该对话框没有标题，则为 null
modalityType - 指定对话框在显示时是否阻塞向其他窗口输入。null 值和不受支持的模式类型等效于 MODELESS
抛出：
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.6
另请参见：
Dialog.ModalityType,
Dialog.setModal(boolean),
Dialog.setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
JComponent.getDefaultLocale()

JDialog

public JDialog(Window owner,
               String title,
               Dialog.ModalityType modalityType,
               GraphicsConfiguration gc)
创建一个具有指定标题、所有者 Window、模式和 GraphicsConfiguration 的对话框。

注：强制要求在有模式对话框中所创建的所有弹出式组件（JComboBox、JPopupMenu、JMenuBar）都是轻量级的。

此构造方法将该组件的语言环境属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
owner - 显示该对话框的 Window；如果此对话框没有所有者，则为 null
title - 该对话框的标题栏中所显示的 String；如果该对话框没有标题，则为 null
modalityType - 指定对话框在显示时是否阻塞向其他窗口输入。null 值和不受支持的模式类型等效于 MODELESS
gc - 目标屏幕设备的 GraphicsConfiguration；如果为 null，则使用拥有窗口的 GraphicsConfiguration；如果 owner 也为 null，则假定它为系统默认的 GraphicsConfiguration
抛出：
HeadlessException - 当 GraphicsEnvironment.isHeadless() 返回 true 时
从以下版本开始：
1.6
另请参见：
Dialog.ModalityType,
Dialog.setModal(boolean),
Dialog.setModalityType(java.awt.Dialog.ModalityType),
GraphicsEnvironment.isHeadless(),
JComponent.getDefaultLocale()
方法详细信息

dialogInit

protected void dialogInit()
构造方法调用此方法来正确初始化 JDialog。

createRootPane

protected JRootPane createRootPane()
构造方法调用此方法来创建默认的 rootPane。

processWindowEvent

protected void processWindowEvent(WindowEvent e)
根据 defaultCloseOperation 属性的状态处理窗口事件。

覆盖：
类 Window 中的 processWindowEvent
参数：
e - 窗口事件
另请参见：
setDefaultCloseOperation(int)

setDefaultCloseOperation

public void setDefaultCloseOperation(int operation)
设置当用户在此对话框上启动 "close" 时默认执行的操作。必须指定以下选项之一：

  • DO_NOTHING_ON_CLOSE（在 WindowConstants 中定义）：不执行任何操作；需要程序在已注册的 WindowListener 对象的 windowClosing 方法中处理该操作。
  • HIDE_ON_CLOSE（在 WindowConstants 中定义）：调用任意已注册的 WindowListener 对象后自动隐藏该对话框。
  • DISPOSE_ON_CLOSE（WindowConstants 中定义的）：调用任意已注册的 WindowListener 对象后自动隐藏并处置该对话框。

默认将该值设置为 HIDE_ON_CLOSE。对此属性的值的更改将导致触发属性更改事件，带有属性名称 "defaultCloseOperation"。

注：当 Java 虚拟机 (VM) 中最后的可显示窗口被移除后，虚拟机可能会终止。有关更多信息，请参阅 AWT Threading Issues。

参数：
operation - 当用户关闭该对话框时应该执行的操作
抛出：
IllegalArgumentException - 如果 defaultCloseOperation 值不是上述有效值之一
另请参见：
Window.addWindowListener(java.awt.event.WindowListener), getDefaultCloseOperation(), WindowConstants

getDefaultCloseOperation

public int getDefaultCloseOperation()
返回用户在此对话框上启动 "close" 时所执行的操作。

返回：
一个指示窗口关闭操作的整数
另请参见：
setDefaultCloseOperation(int)

setTransferHandler

public void setTransferHandler(TransferHandler newHandler)
设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。如果该组件不支持数据传输操作，那么请使用 null。

如果系统属性 suppressSwingDropSupport 为 false（默认值），并且此组件上的当前放置目标为 null 或者不是用户设置的放置目标，则此方法将按如下方式更改放置目标：如果 newHandler 为 null，则它将清除放置目标。如果不为 null，则它将安装一个新的 DropTarget。

注：当用于 JDialog 时，TransferHandler 只提供数据导入功能，与数据导出有关的方法当前用于 JComponent。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

参数：
newHandler - 新的 TransferHandler
从以下版本开始：
1.6
另请参见：
TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

getTransferHandler

public TransferHandler getTransferHandler()
获取 transferHandler 属性。

返回：
transferHandler 属性的值
从以下版本开始：
1.6
另请参见：
TransferHandler, setTransferHandler(javax.swing.TransferHandler)

update

public void update(Graphics g)
调用 paint(g)。重写此方法，以防止不必要的清除背景调用。

覆盖：
类 Container 中的 update
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
Component.update(Graphics)

setJMenuBar

public void setJMenuBar(JMenuBar menu)
设置此对话框的菜单栏。

参数：
menu - 该对话框中放置的菜单栏
另请参见：
getJMenuBar()

getJMenuBar

public JMenuBar getJMenuBar()
返回此对话框上设置的菜单栏。

另请参见：
setJMenuBar(javax.swing.JMenuBar)

isRootPaneCheckingEnabled

protected boolean isRootPaneCheckingEnabled()
返回是否将对 add 和 setLayout 的调用转发到 contentPane。

返回：
如果转发 add 和 setLayout，则返回 true；否则返回 false
另请参见：
addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

setRootPaneCheckingEnabled

protected void setRootPaneCheckingEnabled(boolean enabled)
设置是否将对 add 和 setLayout 的调用转发到 contentPane。

参数：
enabled - 如果转发 add 和 setLayout，则为 true；如果应该直接在 JDialog 上操作，则为 false。
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
添加指定的子 Component。重写此方法，以有条件地将调用转发到 contentPane。默认情况下将子组件添加到 contentPane，而不是窗体中，有关此内容的详情，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要增强的组件
constraints - 要遵守的约束条件
index - 索引
抛出：
IllegalArgumentException - 如果 index 无效
IllegalArgumentException - 如果将容器的父级添加到其本身
IllegalArgumentException - 如果向容器内添加窗口
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

remove

public void remove(Component comp)
从该容器中移除指定组件。如果 comp 不是 rootPane，则将该调用转发到 contentPane。如果 comp 不是 JDialog 或 contentPane 的子级，则不执行任何操作。

覆盖：
类 Container 中的 remove
参数：
comp - 要移除的组件
抛出：
NullPointerException - 如果 comp 为 null
另请参见：
Container.add(java.awt.Component), RootPaneContainer

setLayout

public void setLayout(LayoutManager manager)
设置 LayoutManager。重写此方法，以有条件地将调用转发到 contentPane。有关此内容的更多信息，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 setLayout
参数：
manager - the LayoutManager
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

getRootPane

public JRootPane getRootPane()
返回此对话框的 rootPane 对象。

指定者：
接口 RootPaneContainer 中的 getRootPane
返回：
此组件的单个 JRootPane 子组件。
另请参见：
setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

setRootPane

protected void setRootPane(JRootPane root)
设置 rootPane 属性。此方法由构造方法调用。

参数：
root - 此对话框的 rootPane 对象
另请参见：
getRootPane()

getContentPane

public Container getContentPane()
返回此对话框的 contentPane 对象。

指定者：
接口 RootPaneContainer 中的 getContentPane
返回：
contentPane 属性
另请参见：
setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

setContentPane

public void setContentPane(Container contentPane)
设置 contentPane 属性。此方法由构造方法调用。

Swing 的绘制架构要求在包含层次结构中有不透明的 JComponent。这通常由内容窗格提供。如果要替换内容窗格，建议用不透明的 JComponent 替换它。

指定者：
接口 RootPaneContainer 中的 setContentPane
参数：
contentPane - 此对话框的 contentPane 对象
抛出：
IllegalComponentStateException - （运行时异常）如果 contentPane 参数为 null
另请参见：
JRootPane, getContentPane(), RootPaneContainer.setContentPane(java.awt.Container)

getLayeredPane

public JLayeredPane getLayeredPane()
返回此对话框的 layeredPane 对象。

指定者：
接口 RootPaneContainer 中的 getLayeredPane
返回：
layeredPane 属性
另请参见：
setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

setLayeredPane

public void setLayeredPane(JLayeredPane layeredPane)
设置 layeredPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setLayeredPane
参数：
layeredPane - 新的 layeredPane 属性
抛出：
IllegalComponentStateException - （运行时异常）如果 layeredPane 参数为 null
另请参见：
getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

getGlassPane

public Component getGlassPane()
返回此对话框的 glassPane 对象。

指定者：
接口 RootPaneContainer 中的 getGlassPane
返回：
glassPane 属性
另请参见：
setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

setGlassPane

public void setGlassPane(Component glassPane)
设置 glassPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setGlassPane
参数：
glassPane - 此对话框的 glassPane 对象
另请参见：
getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

getGraphics

public Graphics getGraphics()
为组件创建一个图形上下文。如果组件当前是不可显示的，则此方法返回 null。

覆盖：
类 Component 中的 getGraphics
返回：
组件的图形上下文，如果其没有，则返回 null
从以下版本开始：
1.6
另请参见：
Component.paint(java.awt.Graphics)

repaint

public void repaint(long time,
                    int x,
                    int y,
                    int width,
                    int height)
在 time 毫秒内重绘此组件的指定矩形区域。有关如何处理重绘的详细信息，请参阅 RepaintManager。

覆盖：
类 Component 中的 repaint
参数：
time - 更新前等待的最长时间（以毫秒为单位）
x - x 坐标
y - y 坐标
width - 宽度
height - 高度
从以下版本开始：
1.6
另请参见：
RepaintManager

setDefaultLookAndFeelDecorated

public static void setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated)
提供一个关于是否应该通过当前外观为新创建的 JDialog 提供其 Window 装饰（如边界、关闭窗口的小部件、标题……）的提示。如果 defaultLookAndFeelDecorated 为 true、当前 LookAndFeel 支持提供 Window 装饰，并且当前窗口管理器支持未装饰的窗口，则通过当前 LookAndFeel 为新创建的 JDialog 提供其 Window 装饰。否则，通过当前窗口管理器为新创建的 JDialog 提供其 Window 装饰。

执行下列操作可在单个 JDialog 上获取相同的效果：

    JDialog dialog = new JDialog();
    dialog.setUndecorated(true);
    dialog.getRootPane().setWindowDecorationStyle(JRootPane.PLAIN_DIALOG);

参数：
defaultLookAndFeelDecorated - 关于当前外观是否应该提供 window 装饰的提示
从以下版本开始：
1.4
另请参见：
LookAndFeel.getSupportsWindowDecorations()

isDefaultLookAndFeelDecorated

public static boolean isDefaultLookAndFeelDecorated()
如果应该通过当前外观为新创建的 JDialog 提供其 Window 装饰，则返回 true。这只是一个提示，因为某些外观可能不支持此功能。

返回：
如果外观应该提供 Window 装饰，则返回 true。
从以下版本开始：
1.4

paramString

protected String paramString()
返回此 JDialog 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 Dialog 中的 paramString
返回：
此 JDialog 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JDialog 关联的 AccessibleContext。对于 JDialog 来说，AccessibleContext 采用 AccessibleJDialog 的形式。如有必要，可创建一个新的 AccessibleJDialog 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Dialog 中的 getAccessibleContext
返回：
一个 AccessibleJDialog，它充当此 JDialog 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JDialog.AccessibleJDialog (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JDialog.AccessibleJDialog

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Window.AccessibleAWTWindow
                    继承者  java.awt.Dialog.AccessibleAWTDialog
                        继承者  javax.swing.JDialog.AccessibleJDialog
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
JDialog
protected class JDialog.AccessibleJDialog
extends Dialog.AccessibleAWTDialog

此类实现对 JDialog 类的可访问性支持。它实现适合于 dialog 用户界面元素的 Java Accessibility API。

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JDialog.AccessibleJDialog()
方法摘要
String | getAccessibleName() 获取此对象的可访问名称。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
从类 java.awt.Dialog.AccessibleAWTDialog 继承的方法
getAccessibleRole
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JDialog.AccessibleJDialog

protected JDialog.AccessibleJDialog()
方法详细信息

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleName
返回：
返回该对象的本地化名称，如果此对象没有名称，则可以为 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

覆盖：
类 Dialog.AccessibleAWTDialog 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JEditorPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JEditorPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
                    继承者  javax.swing.JEditorPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
直接已知子类：
JTextPane
public class JEditorPane
extends JTextComponent

可编辑各种内容的文本组件。有关基础知识信息和使用编辑器窗格的示例，请参阅 The Java Tutorial 中的 Using Text Components 一节。

此组件使用 EditorKit 的实现来完成其操作。对于给予它的各种内容，它能有效地将其形态变换为适当的文本编辑器种类。该编辑器在任意给定时间的内容类型都由当前已安装的 EditorKit 确定。如果将内容设置为新的 URL，则使用其类型来确定加载该内容所应使用的 EditorKit。

默认情况下，已知下列内容类型：

text/plain
纯文本，即无法识别给定的类型时所使用的默认值。在此情况下使用的工具包是 DefaultEditorKit 的扩展，可生成有换行的纯文本视图。
text/html
HTML 文本。在此情况下使用的工具包是类 javax.swing.text.html.HTMLEditorKit，支持 HTML 3.2。
text/rtf
RTF 文本。在此情况下使用的工具包是类 javax.swing.text.rtf.RTFEditorKit，它提供了对多样化文本格式 (Rich Text Format) 的有限支持。

有多种方式可将内容加载到此组件中。

  1. 可使用 setText 方法来初始化字符串组件。在这种情况下，将使用当前的 EditorKit，且此类型为期望的内容类型。
  2. 可使用 read 方法来初始化 Reader 组件。注意，如果内容类型为 HTML，那么只有使用了 <base> 标记，或者设置了 HTMLDocument 上的 Base 属性时才能解析相关的引用（例如对于类似图像等内容）。在这种情况下，将使用当前的 EditorKit，且此类型为期望的内容类型。
  3. 可使用 setPage 方法来初始化 URL 组件。在这种情况下，将根据该 URL 来确定内容类型，并且设置为该内容类型所注册的 EditorKit。

某些内容类型可能通过生成超链接事件来提供对超链接的支持。如果 JEditorPane 是不可编辑的（已调用了 JEditorPane.setEditable(false);），则 HTML EditorKit 将生成超链接事件。如果文档中嵌入了 HTML frame，则典型的响应是更改当前文档的某一部分。以下代码片段是一种可能的超链接侦听器实现，它特殊对待 HTML frame 事件，并且简单地显示其他所有已激活的超链接。

     class Hyperactive implements HyperlinkListener {

         public void hyperlinkUpdate(HyperlinkEvent e) {
             if (e.getEventType() == HyperlinkEvent.EventType.ACTIVATED) {
                 JEditorPane pane = (JEditorPane) e.getSource();
                 if (e instanceof HTMLFrameHyperlinkEvent) {
                     HTMLFrameHyperlinkEvent  evt = (HTMLFrameHyperlinkEvent)e;
                     HTMLDocument doc = (HTMLDocument)pane.getDocument();
                     doc.processHTMLFrameHyperlinkEvent(evt);
                 } else {
                     try {
                         pane.setPage(e.getURL());
                     } catch (Throwable t) {
                         t.printStackTrace();
                     }
                 }
             }
         }
     }

有关自定义如何呈现 text/html 的信息，请参阅 W3C_LENGTH_UNITS 和 HONOR_DISPLAY_PROPERTIES

某些文档中与文化相关的信息是通过一种称为字符编码的机制来处理的。字符编码是字符集的成员（字母、象形文字、数字、符号或控制函数）和具体数字代码值的明确映射关系。它表示了文件的存储方式。字符编码有 ISO-8859-1、ISO-8859-5、Shift-jis、Euc-jp 和 UTF-8。将文件传递给用户代理 (JEditorPane) 时，该文件被转换为文档字符集 (ISO-10646 aka Unicode)。

有多种方式可获得使用 JEditorPane 时所用的字符集映射关系。

  1. 一种方式是将字符集指定为 MIME 类型的参数。通过调用 setContentType 方法来建立此方式。如果通过 setPage 方法加载内容，则其内容类型已根据 URL 的规范进行了设置。如果直接加载文件，则期望在加载前就已设置内容类型。
  2. 指定字符集的另一种方式是在该文档内指定。这需要在确定所需的字符集之前读取该文档。要处理此情况，需要 EditorKit.read 操作抛出将要被捕获的 ChangedCharSetException。然后使用新的 Reader 重新开始该 read 操作，该 Reader 使用 ChangedCharSetException（这是一个 IOException）中所指定的字符集。

换行
有关如何处理换行的讨论，请参阅 DefaultEditorKit。

警告： Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected class | JEditorPane.AccessibleJEditorPane 此类实现对 JEditorPane 类的可访问性支持。
protected class | JEditorPane.AccessibleJEditorPaneHTML 此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。
protected class | JEditorPane.JEditorPaneAccessibleHypertextSupport AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。
从类 javax.swing.text.JTextComponent 继承的嵌套类/接口
JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static String | HONOR_DISPLAY_PROPERTIES 用于客户机属性的关键字，指示如果在样式化文本中未指定字体或前景色，那么是否使用该组件的默认字体和前景色。
static String | W3C_LENGTH_UNITS 用于客户机属性的关键字，指示是否为 html 呈现使用 w3c 兼容的长度单位。
从类 javax.swing.text.JTextComponent 继承的字段
DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JEditorPane()
创建一个新的 JEditorPane。
JEditorPane(String url)
根据包含 URL 规范的字符串创建一个 JEditorPane。
JEditorPane(String type, String text)
创建一个已初始化为给定文件的 JEditorPane。
JEditorPane(URL initialPage)
根据用作输入的指定 URL 创建一个 JEditorPane。
方法摘要
 void addHyperlinkListener(HyperlinkListener listener)
为了通知所有的更改（例如选中和进入某个链接）而添加一个超链接侦听器。
protected  EditorKit createDefaultEditorKit()
首次创建组件时，创建默认的编辑器工具包 (PlainEditorKit)。
static EditorKit createEditorKitForContentType(String type)
根据默认的编辑器工具包注册表为给定的类型创建处理程序。
 void fireHyperlinkUpdate(HyperlinkEvent e)
通知因对此事件类型的通知感兴趣而已注册的所有侦听器。
 AccessibleContext getAccessibleContext()
获取与此 JEditorPane 关联的 AccessibleContext。
 String getContentType()
获得设置此编辑器当前要处理的内容类型。
 EditorKit getEditorKit()
获取用于处理内容的、当前已安装的工具包。
static String getEditorKitClassNameForContentType(String type)
返回当前向类型 type 所注册的 EditorKit 类名。
 EditorKit getEditorKitForContentType(String type)
获取用于给定内容类型的编辑器工具包。
 HyperlinkListener[] getHyperlinkListeners()
返回使用 addHyperlinkListener() 添加到此 JEditorPane 的所有 HyperLinkListener 的数组。
 URL getPage()
获得当前正在显示的 URL。
 Dimension getPreferredSize()
返回该 JEditorPane 的首选大小。
 boolean getScrollableTracksViewportHeight()
如果某个视口始终应该强迫此 Scrollable 的高度符合该视口的高度，则返回 true。
 boolean getScrollableTracksViewportWidth()
如果某个视口始终应该强迫此 Scrollable 的宽度符合该视口的宽度，则返回 true。
protected  InputStream getStream(URL page)
获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。
 String getText()
根据此编辑器的内容类型返回此 TextComponent 中所包含的文本。
 String getUIClassID()
获得该 UI 的类 ID。
protected  String paramString()
返回此 JEditorPane 的字符串表示形式。
 void read(InputStream in, Object desc)
此方法根据流进行初始化。
static void registerEditorKitForContentType(String type, String classname)
建立 type 到 classname 的默认绑定。
static void registerEditorKitForContentType(String type, String classname, ClassLoader loader)
建立 type 到 classname 的默认绑定。
 void removeHyperlinkListener(HyperlinkListener listener)
移除超链接侦听器。
 void replaceSelection(String content)
用由给定字符串表示的新内容替换当前选中的内容。
 void scrollToReference(String reference)
将视图滚动到给定的参考位置（也就是正在显示的 URL 的 UL.getRef 方法所返回的值）。
 void setContentType(String type)
设置此编辑器所处理的内容类型。
 void setEditorKit(EditorKit kit)
设置当前为处理内容而安装的工具包。
 void setEditorKitForContentType(String type, EditorKit k)
直接设置用于给定类型的编辑器工具包。
 void setPage(String url)
设置当前要显示的 URL。
 void setPage(URL page)
设置当前要显示的 URL。
 void setText(String t)
将此 TextComponent 的文本设置为指定内容，预期以此编辑器的内容类型格式提供该内容。
从类 javax.swing.text.JTextComponent 继承的方法
addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getActions, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDocument, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setUI, updateUI, viewToModel, write
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

W3C_LENGTH_UNITS

public static final String W3C_LENGTH_UNITS
用于客户机属性的关键字，指示是否为 html 呈现使用 w3c 兼容的长度单位。

默认不启用此属性；要启用它，可将带有此名称的客户机 property 设置为 Boolean.TRUE。

从以下版本开始：
1.5
另请参见：
常量字段值

HONOR_DISPLAY_PROPERTIES

public static final String HONOR_DISPLAY_PROPERTIES
用于客户机属性的关键字，指示如果在样式化文本中未指定字体或前景色，那么是否使用该组件的默认字体和前景色。

根据外观的不同，该默认值有所不同；要启用该属性，可将带有此名称的客户机 property 设置为 Boolean.TRUE。

从以下版本开始：
1.5
另请参见：
常量字段值
构造方法详细信息

JEditorPane

public JEditorPane()
创建一个新的 JEditorPane。文档模型被设置为 null。

JEditorPane

public JEditorPane(URL initialPage)
            throws IOException
根据用作输入的指定 URL 创建一个 JEditorPane。

参数：
initialPage - URL
抛出：
IOException - 如果该 URL 为 null 或者无法访问

JEditorPane

public JEditorPane(String url)
            throws IOException
根据包含 URL 规范的字符串创建一个 JEditorPane。

参数：
url - URL
抛出：
IOException - 如果该 URL 为 null 或者无法访问

JEditorPane

public JEditorPane(String type,
                   String text)
创建一个已初始化为给定文件的 JEditorPane。这是调用 setContentType 和 setText 方法的便捷构造方法。

参数：
type - 给定文本的 mime 类型
text - 初始化所使用的文本；可能为 null
抛出：
NullPointerException - 如果 type 参数为 null
方法详细信息

addHyperlinkListener

public void addHyperlinkListener(HyperlinkListener listener)
为了通知所有的更改（例如选中和进入某个链接）而添加一个超链接侦听器。

参数：
listener - 侦听器

removeHyperlinkListener

public void removeHyperlinkListener(HyperlinkListener listener)
移除超链接侦听器。

参数：
listener - 侦听器

getHyperlinkListeners

public HyperlinkListener[] getHyperlinkListeners()
返回使用 addHyperlinkListener() 添加到此 JEditorPane 的所有 HyperLinkListener 的数组。

返回：
已添加的所有 HyperLinkListener，如果尚未添加侦听器，则返回一个空数组
从以下版本开始：
1.4

fireHyperlinkUpdate

public void fireHyperlinkUpdate(HyperlinkEvent e)
通知因对此事件类型的通知感兴趣而已注册的所有侦听器。如果支持超链接的内容类型当前处于激活状态并且使用了某个链接，则通常由当前已安装的 EditorKit 调用此方法。从后向前处理侦听器列表。

参数：
e - 事件
另请参见：
EventListenerList

setPage

public void setPage(URL page)
             throws IOException
设置当前要显示的 URL。设置该窗格的内容类型，并且如果该窗格的编辑器工具包是非 null 的，则创建一个新的默认文档并将 URL 读入该文档。如果该 URL 包含并引用了位置，则通过调用 scrollToReference 方法滚动到该位置。如果所需的 URL 就是当前所显示的，则不会重新加载该文档。要强行重新加载某个文档，必须清除该文档的流描述属性。以下代码显示了如何完成该任务：
   Document doc = jEditorPane.getDocument();
   doc.putProperty(Document.StreamDescriptionProperty, null);
如果所需的 URL 不是当前所显示的，则调用 getStream 方法，让子类控制所提供的流。

这可能会同步或异步地加载，具体取决于 EditorKit 所返回的文档。如果该 Document 的类型是 AbstractDocument 并且具有由大于或等于零的 AbstractDocument.getAsynchronousLoadPriority 返回的值，则使用该优先级将该页面加载到单独的线程中。

如果同步加载文档，则先使用流填充文档，然后通过调用 setDocument 将其安装到编辑器中，而该调用将激发属性更改事件。如果抛出 IOException，则丢弃部分加载的文档，并且不激发文档和页面属性更改事件。如果成功加载并安装了该文档，则由 UI 为其建立一个视图，如有必要，接着滚动该 UI，之后激发页面属性更改事件。

如果异步加载该文档，则立即通过调用 setDocument （这会激发文档属性更改事件）将该文档安装到编辑器中，然后创建一个线程，而该线程将开始执行实际的加载工作。在这种情况下，直接调用此方法不会激发页面属性更改事件，而在线程加载结束时会激发该事件。在事件调度线程上也会激发该事件。因为调用线程无法在其他线程上出现失败事件的情况下抛出 IOException，所以在其他线程完成任务时（不管加载是否成功）将激发页面属性更改事件。

参数：
page - 页面的 URL
抛出：
IOException - 对于 null 或无效的页面规范，或者来自所读取的流的异常
另请参见：
getPage()

read

public void read(InputStream in,
                 Object desc)
          throws IOException
此方法根据流进行初始化。如果工具包被设置为 HTMLEditorKit 类型，并且 desc 参数是 HTMLDocument，则此方法调用 HTMLEditorKit 来初始化读取。否则它调用以纯文本的方式加载模型的超类方法。

参数：
in - 从中读取的流
desc - 描述流的对象
抛出：
IOException - 由用于初始化的流抛出
另请参见：
JTextComponent.read(java.io.Reader, java.lang.Object), JTextComponent.setDocument(javax.swing.text.Document)

getStream

protected InputStream getStream(URL page)
                         throws IOException
获取给定 URL 的流，该 URL 是将要由 setPage 方法加载的。默认情况下，这只是简单地打开该 URL 并返回流。可重新实现此方法以执行有用的任务，例如从缓存中获取流、监视该流的进程等等。

期望此方法具有的副作用是：建立该内容类型，从而设置加载流所要使用的合适的 EditorKit。

如果该流为 http 链接，那么接着会进行重定向，并将得到的 URL 设置为 Document.StreamDescriptionProperty，这样即可正确地解析相关的 URL。

参数：
page - 页面 URL
抛出：
IOException

scrollToReference

public void scrollToReference(String reference)
将视图滚动到给定的参考位置（也就是正在显示的 URL 的 UL.getRef 方法所返回的值）。默认情况下，此方法仅知道如何在 HTMLDocument 中定位一个参考位置。该实现调用 scrollRectToVisible 方法来完成实际的滚动。如果 HTML 之外的文档类型需要滚动到参考位置，则应该重新实现此方法。如果组件不可见，则此方法无效。

参数：
reference - 要滚动到的指定位置

getPage

public URL getPage()
获得当前正在显示的 URL。如果在文档创建中未指定 URL，则此方法返回 null，并且不解析相关的 URL。

返回：
URL，如果没有，则返回 null

setPage

public void setPage(String url)
             throws IOException
设置当前要显示的 URL。

参数：
url - 要显示的 URL
抛出：
IOException - 对于 null 或无效的 URL 规范

getUIClassID

public String getUIClassID()
获得该 UI 的类 ID。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "EditorPaneUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

createDefaultEditorKit

protected EditorKit createDefaultEditorKit()
首次创建组件时，创建默认的编辑器工具包 (PlainEditorKit)。

返回：
编辑器工具包

getEditorKit

public EditorKit getEditorKit()
获取用于处理内容的、当前已安装的工具包。如有必要，可调用 createDefaultEditorKit 来安装默认的工具包。

返回：
编辑器工具包

getContentType

public final String getContentType()
获得设置此编辑器当前要处理的内容类型。将其定义为与当前已安装的 EditorKit 相关联的类型。

返回：
内容类型，如果没有编辑器工具包集，则返回 null

setContentType

public final void setContentType(String type)
设置此编辑器所处理的内容类型。如果可以成功地找到编辑器工具包，则调用 getEditorKitForContentType，然后调用 setEditorKit。作为直接调用 setEditorKit 的一种替代方式，这是可用的最便捷的方法。

如果将字符集定义指定为内容类型规范的参数，则在使用关联的 EditorKit 加载输入流时使用它。例如，如果 type 指定为 text/html; charset=EUC-JP，则用注册为 text/html 的 EditorKit 加载内容，并且提供给该 EditorKit 以便将 unicode 加载到文档中的 Reader 将使用 EUC-JP 字符集转换到 unicode。如果无法识别该 type，则使用为纯文本 text/plain 注册的 EditorKit 加载内容。

参数：
type - 支持内容编辑的非 null mime 类型
抛出：
NullPointerException - 如果 type 参数为 null
另请参见：
getContentType()

setEditorKit

public void setEditorKit(EditorKit kit)
设置当前为处理内容而安装的工具包。这是建立编辑器内容类型的绑定 (bound) 属性。首先卸载所有旧的工具包，然后如果 kit 不为 null，则安装新的工具包并为其创建默认文档。调用 setEditorKit 时始终激发 PropertyChange 事件 ("editorKit")。

注：这具有更改模型的副作用，因为 EditorKit 是模拟特定内容类型的方式的根源。此方法将导致代表调用者来调用 setDocument，以确保内部状态的完整性。

参数：
kit - 所需的编辑器行为
另请参见：
getEditorKit()

getEditorKitForContentType

public EditorKit getEditorKitForContentType(String type)
获取用于给定内容类型的编辑器工具包。当请求的类型与当前已安装的类型不匹配时调用此方法。如果组件没有为给定类型注册的 EditorKit，则它会尝试根据默认的 EditorKit 注册表创建一个 EditorKit。如果创建失败，则在假定所有文本文档都可以表示为纯文本的基础上使用 PlainEditorKit。

可重新实现此方法，以使用某个其他的注册表类型。例如，可重新实现它以使用 Java Activation Framework。

参数：
type - 非 null 的内容类型
返回：
编辑器工具包

setEditorKitForContentType

public void setEditorKitForContentType(String type,
                                       EditorKit k)
直接设置用于给定类型的编辑器工具包。外观实现可能结合使用此方法和 createEditorKitForContentType 为具有某种外观偏好的内容类型安装处理程序。

参数：
type - 非 null 的内容类型
k - 要设置的编辑器工具包

replaceSelection

public void replaceSelection(String content)
用由给定字符串表示的新内容替换当前选中的内容。如果没有选中的内容，那么此操作就等效于插入给定文本。如果没有替换文本（也就是 content 字符串为空或为 null），那么就等效于移除当前的选择。替换文本具有当前为输入所定义的各种属性。如果该组件是不可编辑的，则发出蜂鸣声并返回。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参见 How to Use Threads。

覆盖：
类 JTextComponent 中的 replaceSelection
参数：
content - 要替换选择内容的内容。此值可以为 null

createEditorKitForContentType

public static EditorKit createEditorKitForContentType(String type)
根据默认的编辑器工具包注册表为给定的类型创建处理程序。如有必要，则创建注册表。如果尚未加载已注册的类，则尝试动态地加载针对给定类型的工具包原型。如果已向某个 ClassLoader 注册了该类型，则使用该 ClassLoader 加载该原型。如果没有已注册的 ClassLoader，则使用 Class.forName 加载该原型。

一旦成功地找到 EditorKit 实例，则复制它并返回该副本。

参数：
type - 内容类型
返回：
编辑器工具包，如果没有为给定类型注册的工具包，则返回 null

registerEditorKitForContentType

public static void registerEditorKitForContentType(String type,
                                                   String classname)
建立 type 到 classname 的默认绑定。实际需要该类时，将在稍后动态地加载该类，并且在使用前可安全地更改，以避免加载不需要的类。使用此方法注册后，将使用 Class.forName 加载 EditorKit 原型。

参数：
type - 非 null 的内容类型
classname - 稍后加载的类

registerEditorKitForContentType

public static void registerEditorKitForContentType(String type,
                                                   String classname,
                                                   ClassLoader loader)
建立 type 到 classname 的默认绑定。实际需要该类时，将在稍后使用给定的 ClassLoader 动态地加载该类，并且在使用前可安全地更改，以避免加载不需要的类。

参数：
type - 非 null 的内容类型
classname - 稍后加载的类
loader - 用于加载该名称的类的 ClassLoader

getEditorKitClassNameForContentType

public static String getEditorKitClassNameForContentType(String type)
返回当前向类型 type 所注册的 EditorKit 类名。

参数：
type - 非 null 的内容类型
从以下版本开始：
1.3

getPreferredSize

public Dimension getPreferredSize()
返回该 JEditorPane 的首选大小。JEditorPane 的首选大小与超类的首选大小稍微有所不同。如果视口 (viewport) 的大小已经小于组件的最低大小，则用于跟踪宽度或高度的可滚动定义将变为 false。默认的视口布局将给出首选大小，并且该大小在可滚动定义正在进行跟踪的情况下是不需要的。在这种情况下，将正常的 首选大小调整为最低大小。这就允许将 HTML 表缩小为其最低大小，然后以其最低大小进行布局，而不再做进一步的缩小。

覆盖：
类 JComponent 中的 getPreferredSize
返回：
包含首选大小的 Dimension
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

setText

public void setText(String t)
将此 TextComponent 的文本设置为指定内容，预期以此编辑器的内容类型格式提供该内容。例如，如果将类型设置为 text/html，则应按照 HTML 指定该字符串。

实现此方法可移除当前文档的内容，并通过使用当前的 EditorKit 分析给定字符串来替换该内容。这提供了超类的语义，方法是不更改模型，同时支持当前在此组件上所设置的内容类型。前提是以前的内容相对较少，并且以前的内容没有副作用。可以违反这两个前提，但这会导致不需要的结果。为了避免发生此情况，可用 getEditorKit().createDefaultDocument() 创建一个新文档，并用该新文档替换现有的 Document。然后就可以确保以前的 Document 没有任何遗留的状态。

  1. 保留现有的模型意味着去除旧的视图，并创建一个新视图，而替换文档则可避免去除旧的视图。
  2. 某些格式（如 HTML）可将各种内容放入文档，而这些内容可以影响以后的内容。HTML 可以具有嵌入的样式信息，这将意外地影响后面安装的内容。

加载带有字符串的此组件的另一种方式是创建一个 StringReader 并调用 read 方法。在这种情况下，使用字符串内容初始化模型后将替换该模型。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

覆盖：
类 JTextComponent 中的 setText
参数：
t - 要设置的新文本；如果为 null，则删除旧的文本
另请参见：
getText()

getText

public String getText()
根据此编辑器的内容类型返回此 TextComponent 中所包含的文本。如果试图检索文本的同时抛出异常，则返回 null。实现此方法以调用带有 StringWriter 的 JTextComponent.write 。

覆盖：
类 JTextComponent 中的 getText
返回：
文本
另请参见：
setText(java.lang.String)

getScrollableTracksViewportWidth

public boolean getScrollableTracksViewportWidth()
如果某个视口始终应该强迫此 Scrollable 的宽度符合该视口的宽度，则返回 true。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportWidth
覆盖：
类 JTextComponent 中的 getScrollableTracksViewportWidth
返回：
如果某个视口始终应该强迫 Scrollable 的宽度符合其宽度，则返回 true；否则返回 false

getScrollableTracksViewportHeight

public boolean getScrollableTracksViewportHeight()
如果某个视口始终应该强迫此 Scrollable 的高度符合该视口的高度，则返回 true。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportHeight
覆盖：
类 JTextComponent 中的 getScrollableTracksViewportHeight
返回：
如果某个视口始终应该强迫 Scrollable 的高度符合其高度，则返回 true；否则返回 false

paramString

protected String paramString()
返回此 JEditorPane 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JTextComponent 中的 paramString
返回：
此 JEditorPane 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JEditorPane 关联的 AccessibleContext。对于编辑器窗格，AccessibleContext 采用 AccessibleJEditorPane 的形式。必要时创建新的 AccessibleJEditorPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JTextComponent 中的 getAccessibleContext
返回：
AccessibleJEditorPane，充当此 JEditorPane 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JEditorPane.AccessibleJEditorPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JEditorPane.AccessibleJEditorPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.text.JTextComponent.AccessibleJTextComponent
                        继承者  javax.swing.JEditorPane.AccessibleJEditorPane
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
直接已知子类：
JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport
正在封闭类：
JEditorPane
protected class JEditorPane.AccessibleJEditorPane
extends JTextComponent.AccessibleJTextComponent

此类实现对 JEditorPane 类的可访问性支持。它提供适合于编辑器窗格用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
从接口 javax.accessibility.AccessibleExtendedText 继承的字段
ATTRIBUTE_RUN, LINE
构造方法摘要
protected JEditorPane.AccessibleJEditorPane()
方法摘要
String | getAccessibleDescription() 获得此对象的 accessibleDescription 属性。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集。
从类 javax.swing.text.JTextComponent.AccessibleJTextComponent 继承的方法
caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JEditorPane.AccessibleJEditorPane

protected JEditorPane.AccessibleJEditorPane()
方法详细信息

getAccessibleDescription

public String getAccessibleDescription()
获得此对象的 accessibleDescription 属性。如果未设置此属性，则返回此 JEditorPane 的内容类型（例如 "plain/text"、"html/text"）。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleDescription
返回：
该对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态集。

覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAccessibleStateSet
返回：
描述该对象状态的 AccessibleStateSet 实例
另请参见：
AccessibleStateSet
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JEditorPane.AccessibleJEditorPaneHTML (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JEditorPane.AccessibleJEditorPaneHTML

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.text.JTextComponent.AccessibleJTextComponent
                        继承者  javax.swing.JEditorPane.AccessibleJEditorPane
                            继承者  javax.swing.JEditorPane.AccessibleJEditorPaneHTML
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
正在封闭类：
JEditorPane
protected class JEditorPane.AccessibleJEditorPaneHTML
extends JEditorPane.AccessibleJEditorPane

此类提供了对 AccessibleHypertext 的支持，并且用于这类实例中：在此 JEditorPane 中安装的 EditorKit 是一个 HTMLEditorKit 实例。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
从接口 javax.accessibility.AccessibleExtendedText 继承的字段
ATTRIBUTE_RUN, LINE
构造方法摘要
protected JEditorPane.AccessibleJEditorPaneHTML()
方法摘要
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回对象的可访问子级数。
AccessibleText | getAccessibleText() 获取与此对象关联的 AccessibleText。
从类 javax.swing.JEditorPane.AccessibleJEditorPane 继承的方法
getAccessibleDescription, getAccessibleStateSet
从类 javax.swing.text.JTextComponent.AccessibleJTextComponent 继承的方法
caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JEditorPane.AccessibleJEditorPaneHTML

protected JEditorPane.AccessibleJEditorPaneHTML()
方法详细信息

getAccessibleText

public AccessibleText getAccessibleText()
从类 JTextComponent.AccessibleJTextComponent 复制的描述
获取与此对象关联的 AccessibleText。在此类的 Java Accessibility API 实现中，返回此对象，它负责以自己的方式实现 AccessibleText 接口。

覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAccessibleText
返回：
此对象
另请参见：
AccessibleText

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象的可访问子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从零开始索引的，因此 Accessible 第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 子级的从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
getAccessibleChildrenCount()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回本地坐标 Point 所包含的 Accessible 子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleAt
参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JEditorPane.JEditorPaneAccessibleHypertextSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JEditorPane.JEditorPaneAccessibleHypertextSupport

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.text.JTextComponent.AccessibleJTextComponent
                        继承者  javax.swing.JEditorPane.AccessibleJEditorPane
                            继承者  javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleHypertext, AccessibleText, CaretListener, DocumentListener
正在封闭类：
JEditorPane
protected class JEditorPane.JEditorPaneAccessibleHypertextSupport
extends JEditorPane.AccessibleJEditorPane
implements AccessibleHypertext

AccessibleJEditorPaneHTML.getAccessibleText 返回的内容。 在此 JEditorPane 中显示 HTML 文档的情况下，提供对 AccessibleHypertext 的支持。

嵌套类摘要
 class JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleExtendedText 继承的字段
ATTRIBUTE_RUN, LINE
构造方法摘要
JEditorPane.JEditorPaneAccessibleHypertextSupport()
提供某种支持
方法摘要
AccessibleHyperlink | getLink(int linkIndex) 返回超链接数组中该索引处的链接。
int | getLinkCount() 返回此超文本文档中的链接数。
int | getLinkIndex(int charIndex) 返回超链接数组中与此字符索引关联的超链接索引；如果没有与此索引关联的超链接，则返回 -1。
String | getLinkText(int linkIndex) 返回文档中与此超链接关联的连续文本。
从类 javax.swing.JEditorPane.AccessibleJEditorPane 继承的方法
getAccessibleDescription, getAccessibleStateSet
从类 javax.swing.text.JTextComponent.AccessibleJTextComponent 继承的方法
caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleText 继承的方法
getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JEditorPane.JEditorPaneAccessibleHypertextSupport

public JEditorPane.JEditorPaneAccessibleHypertextSupport()
提供某种支持

方法详细信息

getLinkCount

public int getLinkCount()
返回此超文本文档中的链接数。

指定者：
接口 AccessibleHypertext 中的 getLinkCount
返回：
此超文本文档中的链接数。

getLinkIndex

public int getLinkIndex(int charIndex)
返回超链接数组中与此字符索引关联的超链接索引；如果没有与此索引关联的超链接，则返回 -1。

指定者：
接口 AccessibleHypertext 中的 getLinkIndex
参数：
charIndex - 文本中的索引
返回：
超链接集合中针对此超文本文档的索引。

getLink

public AccessibleHyperlink getLink(int linkIndex)
返回超链接数组中该索引处的链接。如果在此索引处没有超链接，则返回 null。

指定者：
接口 AccessibleHypertext 中的 getLink
参数：
linkIndex - 超链接集合中针对此超文本文档的索引。
返回：
超链接的字符串表示形式

getLinkText

public String getLinkText(int linkIndex)
返回文档中与此超链接关联的连续文本。

参数：
linkIndex - 超链接集合中针对此超文本文档的索引。
返回：
共享此索引处的链接的连续文本
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

java.lang.Object
    继承者  javax.accessibility.AccessibleHyperlink
        继承者  javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
所有已实现的接口：
AccessibleAction
正在封闭类：
JEditorPane.JEditorPaneAccessibleHypertextSupport
public class JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
extends AccessibleHyperlink

字段摘要
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)
方法摘要
boolean | doAccessibleAction(int i) 对该对象执行指定的 Action
Object | getAccessibleActionAnchor(int i) 返回表示适合于该链接的链接锚点的对象。
int | getAccessibleActionCount() 返回此 Link 中的可访问操作数目（如果有多个），不认为首个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。
String | getAccessibleActionDescription(int i) 返回此特定链接操作的 String 描述。
Object | getAccessibleActionObject(int i) 返回表示该链接的 URL 对象。
int | getEndIndex() 获得此链接结束处该超文本文档的索引
int | getStartIndex() 获得此链接开始处该超文本文档的索引
boolean | isValid() 因为与某个链接相关联的文档可能已改变，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink

public JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink(Element e)
方法详细信息

isValid

public boolean isValid()
因为与某个链接相关联的文档可能已改变，所以此方法返回此 Link 是否仍然有效（关于它所引用的文档是否有效）。

指定者：
类 AccessibleHyperlink 中的 isValid
返回：
一个标志，指示此链接对于它所属的 AccessibleHypertext 而言是否仍然有效

getAccessibleActionCount

public int getAccessibleActionCount()
返回此 Link 中的可访问操作数目（如果有多个），不认为首个操作是此 LINK 对象的“默认”操作（例如，在 HTML imagemap 中）。通常，Link 中只有一个 AccessibleAction。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
指定者：
类 AccessibleHyperlink 中的 getAccessibleActionCount
返回：
此对象中从 0 开始的 Action 数

doAccessibleAction

public boolean doAccessibleAction(int i)
对该对象执行指定的 Action

指定者：
接口 AccessibleAction 中的 doAccessibleAction
指定者：
类 AccessibleHyperlink 中的 doAccessibleAction
参数：
i - 从 0 开始的操作索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
getAccessibleActionCount()

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回此特定链接操作的 String 描述。返回的字符串是文档内的文本，而该文档与包含此链接的元素相关联。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
指定者：
类 AccessibleHyperlink 中的 getAccessibleActionDescription
参数：
i - 从 0 开始的操作索引
返回：
该操作的 String 描述
另请参见：
getAccessibleActionCount()

getAccessibleActionObject

public Object getAccessibleActionObject(int i)
返回表示该链接的 URL 对象。

指定者：
类 AccessibleHyperlink 中的 getAccessibleActionObject
参数：
i - 从 0 开始的操作索引
返回：
表示该 HTML 链接本身的 URL
另请参见：
getAccessibleActionCount()

getAccessibleActionAnchor

public Object getAccessibleActionAnchor(int i)
返回表示适合于该链接的链接锚点的对象。例如，从 HTML：Accessibility 中，此方法会返回包含下列文本的 String：'Accessibility'。 类似地，从此 HTML：<a HREF="#top"><img src="top-hat.gif" alt="top hat"></a> 中，此方法返回对象 ImageIcon("top-hat.gif", "top hat")。

指定者：
类 AccessibleHyperlink 中的 getAccessibleActionAnchor
参数：
i - 从 0 开始的操作索引
返回：
表示该超文本锚点的 Object
另请参见：
getAccessibleActionCount()

getStartIndex

public int getStartIndex()
获得此链接开始处该超文本文档的索引

指定者：
类 AccessibleHyperlink 中的 getStartIndex
返回：
链接开始处的索引

getEndIndex

public int getEndIndex()
获得此链接结束处该超文本文档的索引

指定者：
类 AccessibleHyperlink 中的 getEndIndex
返回：
链接结束处的索引
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JFileChooser (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JFileChooser

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JFileChooser
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JFileChooser
extends JComponent
implements Accessible

JFileChooser 为用户选择文件提供了一种简单的机制。有关使用 JFileChooser 的更多信息，请参阅 The Java Tutorial 中的 How to Use File Choosers 一节。

以下代码弹出一个针对用户主目录的文件选择器，其中只显示 .jpg 和 .gif 图像：

    JFileChooser chooser = new JFileChooser();
    FileNameExtensionFilter filter = new FileNameExtensionFilter(
        "JPG & GIF Images", "jpg", "gif");
    chooser.setFileFilter(filter);
    int returnVal = chooser.showOpenDialog(parent);
    if(returnVal == JFileChooser.APPROVE_OPTION) {
       System.out.println("You chose to open this file: " +
            chooser.getSelectedFile().getName());
    }

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

嵌套类摘要
protected  class JFileChooser.AccessibleJFileChooser
此类实现对 JFileChooser 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static String | ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY 标识是否使用 AcceptAllFileFilter。
protected AccessibleContext | accessibleContext
static String | ACCESSORY_CHANGED_PROPERTY 声明正在使用不同的 accessory 组件（例如预览文件）。
static String | APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY 标识用于确认（yes、ok）按钮的助记符的更改。
static String | APPROVE_BUTTON_TEXT_CHANGED_PROPERTY 标识确认（yes、ok）按钮上的文本更改。
static String | APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY 标识用于确认（yes、ok）按钮的工具提示文本的更改。
static int | APPROVE_OPTION 选择确认（yes、ok）后返回该值。
static String | APPROVE_SELECTION 指示确认当前的选择（与按下 yes 或 ok 相同）。
static int | CANCEL_OPTION 选择 cancel 后的返回该值。
static String | CANCEL_SELECTION 指示取消当前的选择。
static String | CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY 标识预定义文件过滤器列表的更改，用户可从该列表中进行选择。
static String | CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY 指示显示控制按钮。
static int | CUSTOM_DIALOG 指示 JFileChooser 支持特定于开发人员文件操作的类型值。
static String | DIALOG_TITLE_CHANGED_PROPERTY 标识对话框标题的更改。
static String | DIALOG_TYPE_CHANGED_PROPERTY 标识显示文件类型的更改（仅显示文件、仅显示目录或显示文件和目录）。
static int | DIRECTORIES_ONLY 指示仅显示目录。
static String | DIRECTORY_CHANGED_PROPERTY 标识用户的目录更改。
static int | ERROR_OPTION 发生错误后返回该值。
static String | FILE_FILTER_CHANGED_PROPERTY 用户更改要显示的文件种类。
static String | FILE_HIDING_CHANGED_PROPERTY 标识在显示隐藏文件属性中的更改。
static String | FILE_SELECTION_MODE_CHANGED_PROPERTY 标识在选择种类（选择单个、多个等等）方面的更改。
static String | FILE_SYSTEM_VIEW_CHANGED_PROPERTY 声明使用其他对象在系统上查找可用的驱动器。
static String | FILE_VIEW_CHANGED_PROPERTY 声明使用其他对象检索文件信息。
static int | FILES_AND_DIRECTORIES 指示显示文件和目录。
static int | FILES_ONLY 指示仅显示文件。
static String | MULTI_SELECTION_ENABLED_CHANGED_PROPERTY 允许选择多个文件。
static int | OPEN_DIALOG 指示 JFileChooser 支持 "Open" 文件操作的类型值。
static int | SAVE_DIALOG 指示 JFileChooser 支持 "Save" 文件操作的类型值。
static String | SELECTED_FILE_CHANGED_PROPERTY 标识用户单个文件选择的更改。
static String | SELECTED_FILES_CHANGED_PROPERTY 标识用户多个文件选择的更改。
从类 javax.swing.JComponent 继承的字段
listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JFileChooser()
构造一个指向用户默认目录的 JFileChooser。
JFileChooser(File currentDirectory)
使用给定的 File 作为路径来构造一个 JFileChooser。
JFileChooser(File currentDirectory, FileSystemView fsv)
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。
JFileChooser(FileSystemView fsv)
使用给定的 FileSystemView 构造一个 JFileChooser。
JFileChooser(String currentDirectoryPath)
构造一个使用给定路径的 JFileChooser。
JFileChooser(String currentDirectoryPath, FileSystemView fsv)
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。
方法摘要
boolean | accept(File f) 如果应该显示该文件，则返回 true。
void | addActionListener(ActionListener l) 向文件选择器添加一个 ActionListener。
void | addChoosableFileFilter(FileFilter filter) 向用户可选择的文件过滤器列表添加一个过滤器。
void | approveSelection() 用户单击 Approve 按钮（默认情况下标有 "Open" 或 "Save"）时由 UI 调用此方法。
void | cancelSelection() 用户选择 Cancel 按钮时由 UI 调用此方法。
void | changeToParentDirectory() 将要设置的目录更改为当前目录的父级。
protected JDialog | createDialog(Component parent) 创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。
void | ensureFileIsVisible(File f) 确保指定的文件是可见的，不是隐藏的。
protected void | fireActionPerformed(String command) 通知对此事件类型感兴趣的所有侦听器。
FileFilter | getAcceptAllFileFilter() 返回 AcceptAll 文件过滤器。
AccessibleContext | getAccessibleContext() 获取与此 JFileChooser 关联的 AccessibleContext。
JComponent | getAccessory() 返回 accessory 组件。
ActionListener[] | getActionListeners() 返回在此文件选择器上注册的所有操作侦听器的数组。
int | getApproveButtonMnemonic() 返回确认按钮的助记符。
String | getApproveButtonText() 返回 ApproveButton 中的 FileChooserUI 内使用的文本。
String | getApproveButtonToolTipText() 返回 ApproveButton 中使用的工具提示文本。
FileFilter[] | getChoosableFileFilters() 获得用户可选择的文件过滤器列表。
boolean | getControlButtonsAreShown() 返回 controlButtonsAreShown 属性的值。
File | getCurrentDirectory() 返回当前目录。
String | getDescription(File f) 返回文件描述。
String | getDialogTitle() 获得 JFileChooser 的标题栏中所显示的字符串。
int | getDialogType() 返回此对话框的类型。
boolean | getDragEnabled() 获得 dragEnabled 属性的值。
FileFilter | getFileFilter() 返回当前选择的文件过滤器。
int | getFileSelectionMode() 返回当前的文件选择模式。
FileSystemView | getFileSystemView() 返回文件系统视图。
FileView | getFileView() 返回当前的文件视图。
Icon | getIcon(File f) 返回此文件或文件类型的图标，这取决于系统。
String | getName(File f) 返回文件名。
File | getSelectedFile() 返回选中的文件。
File[] | getSelectedFiles() 如果将文件选择器设置为允许选择多个文件，则返回选中文件的列表。
String | getTypeDescription(File f) 返回文件类型。
FileChooserUI | getUI() 获得实现此组件 L&F 的 UI 对象。
String | getUIClassID() 返回一个指示 L&F 类名的字符串，该类负责呈现此组件。
boolean | isAcceptAllFileFilterUsed() 返回是否使用 AcceptAll FileFilter。
boolean | isDirectorySelectionEnabled() 方便的调用，可根据当前的文件选择模式确定目录是否为可选择的。
boolean | isFileHidingEnabled() 如果在文件选择器中不显示隐藏文件，则返回 true；否则返回 false。
boolean | isFileSelectionEnabled() 方便的调用，可根据当前的文件选择模式确定文件是否为可选择的。
boolean | isMultiSelectionEnabled() 如果可以选择多个文件，则返回 true。
boolean | isTraversable(File f) 如果可以返回该文件（目录），则返回 true。
protected String | paramString() 返回此 JFileChooser 的字符串表示形式。
void | removeActionListener(ActionListener l) 从文件选择器中移除一个 ActionListener。
boolean | removeChoosableFileFilter(FileFilter f) 从用户可选择的文件过滤器列表中移除一个过滤器。
void | rescanCurrentDirectory() 通知 UI 重新扫描当前目录的文件列表。
void | resetChoosableFileFilters() 将可选择文件过滤器列表重置为其开始状态。
void | setAcceptAllFileFilterUsed(boolean b) 确定是否将 AcceptAll FileFilter 用作可选择过滤器列表中一个可用选项。
void | setAccessory(JComponent newAccessory) 设置 accessory 组件。
void | setApproveButtonMnemonic(char mnemonic) 使用字符设置确认按钮的助记符。
void | setApproveButtonMnemonic(int mnemonic) 使用数值键代码设置确认按钮的助记符。
void | setApproveButtonText(String approveButtonText) 设置 FileChooserUI 中的 ApproveButton 内使用的文本。
void | setApproveButtonToolTipText(String toolTipText) 设置 ApproveButton 中使用的工具提示文本。
void | setControlButtonsAreShown(boolean b) 设置属性，指示在文件选择器中是否显示 approve 和 cancel 按钮。
void | setCurrentDirectory(File dir) 设置当前目录。
void | setDialogTitle(String dialogTitle) 设置显示在 JFileChooser 窗口标题栏的字符串。
void | setDialogType(int dialogType) 设置此对话框的类型。
void | setDragEnabled(boolean b) 设置 dragEnabled 属性，要在此组件上启用自动拖动处理（drag 和 drop 的第一部分），此属性必须为 true。
void | setFileFilter(FileFilter filter) 设置当前文件过滤器。
void | setFileHidingEnabled(boolean b) 设置是否实现文件隐藏。
void | setFileSelectionMode(int mode) 设置 JFileChooser，以允许用户只选择文件、只选择目录，或者可选择文件和目录。
void | setFileSystemView(FileSystemView fsv) 设置为访问和创建文件系统资源（如查找软驱和获得根驱动器列表），JFileChooser 所使用的文件系统视图。
void | setFileView(FileView fileView) 设置用于检索 UI 信息的文件视图，如表示文件的图标或文件的类型描述。
void | setMultiSelectionEnabled(boolean b) 设置文件选择器，以允许选择多个文件。
void | setSelectedFile(File file) 设置选中的文件。
void | setSelectedFiles(File[] selectedFiles) 如果将文件选择器设置为允许选择多个文件，则设置选中文件的列表。
protected void | setup(FileSystemView view) 执行公共的构造方法初始化和设置。
int | showDialog(Component parent, String approveButtonText) 弹出具有自定义 approve 按钮的自定义文件选择器对话框。
int | showOpenDialog(Component parent) 弹出一个 "Open File" 文件选择器对话框。
int | showSaveDialog(Component parent) 弹出一个 "Save File" 文件选择器对话框。
void | updateUI() 将 UI 属性重置为当前的外观值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

OPEN_DIALOG

public static final int OPEN_DIALOG
指示 JFileChooser 支持 "Open" 文件操作的类型值。

另请参见：
常量字段值

SAVE_DIALOG

public static final int SAVE_DIALOG
指示 JFileChooser 支持 "Save" 文件操作的类型值。

另请参见：
常量字段值

CUSTOM_DIALOG

public static final int CUSTOM_DIALOG
指示 JFileChooser 支持特定于开发人员文件操作的类型值。

另请参见：
常量字段值

CANCEL_OPTION

public static final int CANCEL_OPTION
选择 cancel 后的返回该值。

另请参见：
常量字段值

APPROVE_OPTION

public static final int APPROVE_OPTION
选择确认（yes、ok）后返回该值。

另请参见：
常量字段值

ERROR_OPTION

public static final int ERROR_OPTION
发生错误后返回该值。

另请参见：
常量字段值

FILES_ONLY

public static final int FILES_ONLY
指示仅显示文件。

另请参见：
常量字段值

DIRECTORIES_ONLY

public static final int DIRECTORIES_ONLY
指示仅显示目录。

另请参见：
常量字段值

FILES_AND_DIRECTORIES

public static final int FILES_AND_DIRECTORIES
指示显示文件和目录。

另请参见：
常量字段值

CANCEL_SELECTION

public static final String CANCEL_SELECTION
指示取消当前的选择。

另请参见：
常量字段值

APPROVE_SELECTION

public static final String APPROVE_SELECTION
指示确认当前的选择（与按下 yes 或 ok 相同）。

另请参见：
常量字段值

APPROVE_BUTTON_TEXT_CHANGED_PROPERTY

public static final String APPROVE_BUTTON_TEXT_CHANGED_PROPERTY
标识确认（yes、ok）按钮上的文本更改。

另请参见：
常量字段值

APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY

public static final String APPROVE_BUTTON_TOOL_TIP_TEXT_CHANGED_PROPERTY
标识用于确认（yes、ok）按钮的工具提示文本的更改。

另请参见：
常量字段值

APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY

public static final String APPROVE_BUTTON_MNEMONIC_CHANGED_PROPERTY
标识用于确认（yes、ok）按钮的助记符的更改。

另请参见：
常量字段值

CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY

public static final String CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY
指示显示控制按钮。

另请参见：
常量字段值

DIRECTORY_CHANGED_PROPERTY

public static final String DIRECTORY_CHANGED_PROPERTY
标识用户的目录更改。

另请参见：
常量字段值

SELECTED_FILE_CHANGED_PROPERTY

public static final String SELECTED_FILE_CHANGED_PROPERTY
标识用户单个文件选择的更改。

另请参见：
常量字段值

SELECTED_FILES_CHANGED_PROPERTY

public static final String SELECTED_FILES_CHANGED_PROPERTY
标识用户多个文件选择的更改。

另请参见：
常量字段值

MULTI_SELECTION_ENABLED_CHANGED_PROPERTY

public static final String MULTI_SELECTION_ENABLED_CHANGED_PROPERTY
允许选择多个文件。

另请参见：
常量字段值

FILE_SYSTEM_VIEW_CHANGED_PROPERTY

public static final String FILE_SYSTEM_VIEW_CHANGED_PROPERTY
声明使用其他对象在系统上查找可用的驱动器。

另请参见：
常量字段值

FILE_VIEW_CHANGED_PROPERTY

public static final String FILE_VIEW_CHANGED_PROPERTY
声明使用其他对象检索文件信息。

另请参见：
常量字段值

FILE_HIDING_CHANGED_PROPERTY

public static final String FILE_HIDING_CHANGED_PROPERTY
标识在显示隐藏文件属性中的更改。

另请参见：
常量字段值

FILE_FILTER_CHANGED_PROPERTY

public static final String FILE_FILTER_CHANGED_PROPERTY
用户更改要显示的文件种类。

另请参见：
常量字段值

FILE_SELECTION_MODE_CHANGED_PROPERTY

public static final String FILE_SELECTION_MODE_CHANGED_PROPERTY
标识在选择种类（选择单个、多个等等）方面的更改。

另请参见：
常量字段值

ACCESSORY_CHANGED_PROPERTY

public static final String ACCESSORY_CHANGED_PROPERTY
声明正在使用不同的 accessory 组件（例如预览文件）。

另请参见：
常量字段值

ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY

public static final String ACCEPT_ALL_FILE_FILTER_USED_CHANGED_PROPERTY
标识是否使用 AcceptAllFileFilter。

另请参见：
常量字段值

DIALOG_TITLE_CHANGED_PROPERTY

public static final String DIALOG_TITLE_CHANGED_PROPERTY
标识对话框标题的更改。

另请参见：
常量字段值

DIALOG_TYPE_CHANGED_PROPERTY

public static final String DIALOG_TYPE_CHANGED_PROPERTY
标识显示文件类型的更改（仅显示文件、仅显示目录或显示文件和目录）。

另请参见：
常量字段值

CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY

public static final String CHOOSABLE_FILE_FILTER_CHANGED_PROPERTY
标识预定义文件过滤器列表的更改，用户可从该列表中进行选择。

另请参见：
常量字段值

accessibleContext

protected AccessibleContext accessibleContext
构造方法详细信息

JFileChooser

public JFileChooser()
构造一个指向用户默认目录的 JFileChooser。此默认目录取决于操作系统。在 Windows 上通常是“我的文档”，在 Unix 上是用户的主目录。

JFileChooser

public JFileChooser(String currentDirectoryPath)
构造一个使用给定路径的 JFileChooser。传入 null 字符串会导致文件选择器指向用户的默认目录。此默认目录取决于操作系统。在 Windows 上通常是“我的文档”，在 Unix 上是用户的主目录。

参数：
currentDirectoryPath - 给出文件或目录路径的 String

JFileChooser

public JFileChooser(File currentDirectory)
使用给定的 File 作为路径来构造一个 JFileChooser。传入 null 文件会导致文件选择器指向用户的默认目录。此默认目录取决于操作系统。在 Windows 上通常是“我的文档”，在 Unix 上是用户的主目录。

参数：
currentDirectory - 指出文件或目录路径的 File 对象

JFileChooser

public JFileChooser(FileSystemView fsv)
使用给定的 FileSystemView 构造一个 JFileChooser。

JFileChooser

public JFileChooser(File currentDirectory,
                    FileSystemView fsv)
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。

JFileChooser

public JFileChooser(String currentDirectoryPath,
                    FileSystemView fsv)
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。

方法详细信息

setup

protected void setup(FileSystemView view)
执行公共的构造方法初始化和设置。

setDragEnabled

public void setDragEnabled(boolean b)
设置 dragEnabled 属性，要在此组件上启用自动拖动处理（drag 和 drop 的第一部分），此属性必须为 true。为了让该拖动完成所需的任务，需要将 transferHandler 属性设置为非 null 的值。dragEnabled 属性的默认值为 false。

启用自动拖动处理后，每当用户在项上按下鼠标按键，然后将鼠标移动几个像素后，多数外观就开始拖放操作。因此将此属性设置为 true 对选择方式有一些影响。

某些外观可能不支持自动拖放；它们会忽略此属性。通过修改组件以直接调用 TransferHandler 的 exportAsDrag 方法，从而在此外观下工作。

参数：
b - 为 dragEnabled 属性设置的值
抛出：
HeadlessException - 如果 b 为 true 并且 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDragEnabled

public boolean getDragEnabled()
获得 dragEnabled 属性的值。

返回：
dragEnabled 属性的值
从以下版本开始：
1.4
另请参见：
setDragEnabled(boolean)

getSelectedFile

public File getSelectedFile()
返回选中的文件。可由程序员通过 setFile 或者通过用户操作（如在 UI 中键入文件名，或者从 UI 中的列表内选择文件）来进行此设置。

返回：
选中的文件
另请参见：
setSelectedFile(java.io.File)

setSelectedFile

public void setSelectedFile(File file)
设置选中的文件。如果该文件的父目录不是当前目录，则将当前目录更改为该文件的父目录。

参数：
file - 选中的文件
另请参见：
getSelectedFile()

getSelectedFiles

public File[] getSelectedFiles()
如果将文件选择器设置为允许选择多个文件，则返回选中文件的列表。

setSelectedFiles

public void setSelectedFiles(File[] selectedFiles)
如果将文件选择器设置为允许选择多个文件，则设置选中文件的列表。

getCurrentDirectory

public File getCurrentDirectory()
返回当前目录。

返回：
当前目录
另请参见：
setCurrentDirectory(java.io.File)

setCurrentDirectory

public void setCurrentDirectory(File dir)
设置当前目录。传入 null 会设置文件选择器指向用户的默认目录。此默认目录取决于操作系统。在 Windows 上通常是“我的文档”，在 Unix 上是用户的主目录。 如果作为 currentDirectory 所传入的文件不是一个目录，则使用该文件的父级作为 currentDirectory。如果该父级是不可遍历的，则会沿父级树向上查找，直到找到可遍历的目录，或者到达文件系统的根为止。

参数：
dir - 要指向的当前目录
另请参见：
getCurrentDirectory()

changeToParentDirectory

public void changeToParentDirectory()
将要设置的目录更改为当前目录的父级。

另请参见：
getCurrentDirectory()

rescanCurrentDirectory

public void rescanCurrentDirectory()
通知 UI 重新扫描当前目录的文件列表。

ensureFileIsVisible

public void ensureFileIsVisible(File f)
确保指定的文件是可见的，不是隐藏的。

参数：
f - 一个 File 对象

showOpenDialog

public int showOpenDialog(Component parent)
                   throws HeadlessException
弹出一个 "Open File" 文件选择器对话框。注意，approve 按钮上显示的文本由 L&F 决定。

参数：
parent - 该对话框的父组件，可以为 null；详情请参阅 showDialog
返回：
该文件选择器被弹下时的返回状态：
  • JFileChooser.CANCEL_OPTION
  • JFileChooser.APPROVE_OPTION
  • JFileChooser.ERROR_OPTION 如果发生错误或者该对话框已被解除
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), showDialog(java.awt.Component, java.lang.String)

showSaveDialog

public int showSaveDialog(Component parent)
                   throws HeadlessException
弹出一个 "Save File" 文件选择器对话框。注意，approve 按钮上显示的文本由 L&F 决定。

参数：
parent - 该对话框的父组件，可以为 null；详情请参阅 showDialog
返回：
该文件选择器被弹下时的返回状态：
  • JFileChooser.CANCEL_OPTION
  • JFileChooser.APPROVE_OPTION
  • JFileChooser.ERROR_OPTION 如果发生错误或者该对话框已被解除
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(), showDialog(java.awt.Component, java.lang.String)

showDialog

public int showDialog(Component parent,
                      String approveButtonText)
               throws HeadlessException
弹出具有自定义 approve 按钮的自定义文件选择器对话框。例如，以下代码弹出具有 "Run Application" 按钮（而不是普通的 "Save" 或 "Open" 按钮）的文件选择器：
 filechooser.showDialog(parentFrame, "Run Application");
或者，以下代码也可以执行相同的操作：
    JFileChooser chooser = new JFileChooser(null);
    chooser.setApproveButtonText("Run Application");
    chooser.showDialog(parentFrame, null);

parent 参数确定两件事情：打开的对话框所依赖的窗体，以及组件(放置对话框时外观应该考虑该组件的位置）。如果 parent 是一个 Frame 对象（例如 JFrame），则该对话框取决于该窗体，并且外观相对于窗体放置该对话框（例如在窗体上居中）。如果 parent 是一个组件，则该对话框取决于包含该组件的窗体，并且相对于该组件放置该对话框（例如在组件上居中）。如果 parent 为 null，则该对话框取决于不可见的窗口，并且将其放置到与外观相关的位置，如屏幕的中央。

参数：
parent - 该对话框的父组件，可以为 null
approveButtonText - ApproveButton 的文本
返回：
该文件选择器被弹下时的返回状态：
  • JFileChooser.CANCEL_OPTION
  • JFileChooser.APPROVE_OPTION
  • JFileChooser.ERROR_OPTION 如果发生错误或者该对话框已被解除
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless()

createDialog

protected JDialog createDialog(Component parent)
                        throws HeadlessException
创建并返回包含 this 的新 JDialog，在 parent 窗体中的 parent 上居中。可重写此方法以进一步地操作对话框、禁止调整大小、设置位置等等。例如：
     class MyFileChooser extends JFileChooser {
         protected JDialog createDialog(Component parent) throws HeadlessException {
             JDialog dialog = super.createDialog(parent);
             dialog.setLocation(300, 200);
             dialog.setResizable(false);
             return dialog;
         }
     }

参数：
parent - 该对话框的父组件，可以为 null
返回：
包含 this 实例的新 JDialog
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless()

getControlButtonsAreShown

public boolean getControlButtonsAreShown()
返回 controlButtonsAreShown 属性的值。

返回：
controlButtonsAreShown 属性的值
从以下版本开始：
1.3
另请参见：
setControlButtonsAreShown(boolean)

setControlButtonsAreShown

public void setControlButtonsAreShown(boolean b)
设置属性，指示在文件选择器中是否显示 approve 和 cancel 按钮。此属性默认为 true。始终显示这些按钮的外观将忽略此属性的值。此方法激发一个属性更改事件，使用 CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY 字符串值作为属性名。

参数：
b - 如果不应显示控制按钮，则为 false；否则为 true
从以下版本开始：
1.3
另请参见：
getControlButtonsAreShown(), CONTROL_BUTTONS_ARE_SHOWN_CHANGED_PROPERTY

getDialogType

public int getDialogType()
返回此对话框的类型。默认值是 JFileChooser.OPEN_DIALOG。

返回：
要显示的对话框的类型：
  • JFileChooser.OPEN_DIALOG
  • JFileChooser.SAVE_DIALOG
  • JFileChooser.CUSTOM_DIALOG
另请参见：
setDialogType(int)

setDialogType

public void setDialogType(int dialogType)
设置此对话框的类型。希望显示一个用户可用来打开文件的文件选择器时使用 OPEN_DIALOG。同样，使用 SAVE_DIALOG 可让用户选择用于保存的文件。想要在除 "Open" 或 "Save" 以外的上下文中使用文件选择器，则使用 CUSTOM_DIALOG。例如，您可能想要显示的文件选择器允许用户选择要执行的文件。注意，通常无需设置 JFileChooser 使用 CUSTOM_DIALOG，因为调用 setApproveButtonText 就已经这样作了。默认的对话框类型是 JFileChooser.OPEN_DIALOG。

参数：
dialogType - 要显示的对话框的类型：
  • JFileChooser.OPEN_DIALOG
  • JFileChooser.SAVE_DIALOG
  • JFileChooser.CUSTOM_DIALOG
抛出：
IllegalArgumentException - 如果 dialogType 非法
另请参见：
getDialogType(), setApproveButtonText(java.lang.String)

setDialogTitle

public void setDialogTitle(String dialogTitle)
设置显示在 JFileChooser 窗口标题栏的字符串。

参数：
dialogTitle - 标题栏的新 String
另请参见：
getDialogTitle()

getDialogTitle

public String getDialogTitle()
获得 JFileChooser 的标题栏中所显示的字符串。

另请参见：
setDialogTitle(java.lang.String)

setApproveButtonToolTipText

public void setApproveButtonToolTipText(String toolTipText)
设置 ApproveButton 中使用的工具提示文本。如果为 null，则由 UI 对象确定该按钮的文本。

参数：
toolTipText - 用于确认按钮的工具提示文本
另请参见：
setApproveButtonText(java.lang.String), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

getApproveButtonToolTipText

public String getApproveButtonToolTipText()
返回 ApproveButton 中使用的工具提示文本。如果为 null，则由 UI 对象确定该按钮的文本。

返回：
用于确认按钮的工具提示文本
另请参见：
setApproveButtonText(java.lang.String), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

getApproveButtonMnemonic

public int getApproveButtonMnemonic()
返回确认按钮的助记符。

返回：
用于助记符键的整数值
另请参见：
setApproveButtonMnemonic(int)

setApproveButtonMnemonic

public void setApproveButtonMnemonic(int mnemonic)
使用数值键代码设置确认按钮的助记符。

参数：
mnemonic - 用于助记符键的整数值
另请参见：
getApproveButtonMnemonic()

setApproveButtonMnemonic

public void setApproveButtonMnemonic(char mnemonic)
使用字符设置确认按钮的助记符。

参数：
mnemonic - 用于助记符键的 char 值
另请参见：
getApproveButtonMnemonic()

setApproveButtonText

public void setApproveButtonText(String approveButtonText)
设置 FileChooserUI 中的 ApproveButton 内使用的文本。

参数：
approveButtonText - ApproveButton 中使用的文本
另请参见：
getApproveButtonText(), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

getApproveButtonText

public String getApproveButtonText()
返回 ApproveButton 中的 FileChooserUI 内使用的文本。如果为 null，则由 UI 对象确定该按钮的文本。 通常该文本是 "Open" 或 "Save"。

返回：
ApproveButton 中使用的文本
另请参见：
setApproveButtonText(java.lang.String), setDialogType(int), showDialog(java.awt.Component, java.lang.String)

getChoosableFileFilters

public FileFilter[] getChoosableFileFilters()
获得用户可选择的文件过滤器列表。

返回：
包含所有可选择文件过滤器的 FileFilter 数组
另请参见：
addChoosableFileFilter(javax.swing.filechooser.FileFilter),
removeChoosableFileFilter(javax.swing.filechooser.FileFilter),
resetChoosableFileFilters()

addChoosableFileFilter

public void addChoosableFileFilter(FileFilter filter)
向用户可选择的文件过滤器列表添加一个过滤器。有关设置文件选择模式的信息，请参阅 setFileSelectionMode。

参数：
filter - 添加到可选择文件过滤器列表的 FileFilter
另请参见：
getChoosableFileFilters(),
removeChoosableFileFilter(javax.swing.filechooser.FileFilter),
resetChoosableFileFilters(),
setFileSelectionMode(int)

removeChoosableFileFilter

public boolean removeChoosableFileFilter(FileFilter f)
从用户可选择的文件过滤器列表中移除一个过滤器。如果移除了文件过滤器，则返回 true。

另请参见：
addChoosableFileFilter(javax.swing.filechooser.FileFilter),
getChoosableFileFilters(),
resetChoosableFileFilters()

resetChoosableFileFilters

public void resetChoosableFileFilters()
将可选择文件过滤器列表重置为其开始状态。通常这会移除所有已添加的文件过滤器并保留 AcceptAll 文件过滤器。

另请参见：
addChoosableFileFilter(javax.swing.filechooser.FileFilter),
getChoosableFileFilters(),
removeChoosableFileFilter(javax.swing.filechooser.FileFilter)

getAcceptAllFileFilter

public FileFilter getAcceptAllFileFilter()
返回 AcceptAll 文件过滤器。例如在 Microsoft Windows 上，这会是“所有文件” (*.*)。

isAcceptAllFileFilterUsed

public boolean isAcceptAllFileFilterUsed()
返回是否使用 AcceptAll FileFilter。

返回：
如果使用 AcceptAll FileFilter，则返回 true
从以下版本开始：
1.3
另请参见：
setAcceptAllFileFilterUsed(boolean)

setAcceptAllFileFilterUsed

public void setAcceptAllFileFilterUsed(boolean b)
确定是否将 AcceptAll FileFilter 用作可选择过滤器列表中一个可用选项。如果为 false，则从可用文件过滤器的列表中移除 AcceptAll 文件过滤器。如果为 true，则 AcceptAll 文件过滤器将成为可用的文件过滤器。

从以下版本开始：
1.3
另请参见：
isAcceptAllFileFilterUsed(),
getAcceptAllFileFilter(),
setFileFilter(javax.swing.filechooser.FileFilter)

getAccessory

public JComponent getAccessory()
返回 accessory 组件。

返回：
此 JFileChooser 的 accessory 组件，或者为 null
另请参见：
setAccessory(javax.swing.JComponent)

setAccessory

public void setAccessory(JComponent newAccessory)
设置 accessory 组件。accessory 通常用于显示已选中文件的预览图像；可按程序员的要求将其用来显示任何内容，如额外的自定义文件选择器控件。

注：如果有以前使用的 accessory，则应该取消注册该 accessory 已向文件选择器所注册的所有侦听器。

setFileSelectionMode

public void setFileSelectionMode(int mode)
设置 JFileChooser，以允许用户只选择文件、只选择目录，或者可选择文件和目录。默认值是 JFilesChooser.FILES_ONLY。

参数：
mode - 要显示的文件类型：
  • JFileChooser.FILES_ONLY
  • JFileChooser.DIRECTORIES_ONLY
  • JFileChooser.FILES_AND_DIRECTORIES
抛出：
IllegalArgumentException - 如果 mode 是非法的文件选择模式
另请参见：
getFileSelectionMode()

getFileSelectionMode

public int getFileSelectionMode()
返回当前的文件选择模式。默认值是 JFilesChooser.FILES_ONLY。

返回：
要显示的文件类型，为下列值之一：
  • JFileChooser.FILES_ONLY
  • JFileChooser.DIRECTORIES_ONLY
  • JFileChooser.FILES_AND_DIRECTORIES
另请参见：
setFileSelectionMode(int)

isFileSelectionEnabled

public boolean isFileSelectionEnabled()
方便的调用，可根据当前的文件选择模式确定文件是否为可选择的。

另请参见：
setFileSelectionMode(int), getFileSelectionMode()

isDirectorySelectionEnabled

public boolean isDirectorySelectionEnabled()
方便的调用，可根据当前的文件选择模式确定目录是否为可选择的。

另请参见：
setFileSelectionMode(int), getFileSelectionMode()

setMultiSelectionEnabled

public void setMultiSelectionEnabled(boolean b)
设置文件选择器，以允许选择多个文件。

参数：
b - 如果可以选择多个文件，则为 true
另请参见：
isMultiSelectionEnabled()

isMultiSelectionEnabled

public boolean isMultiSelectionEnabled()
如果可以选择多个文件，则返回 true。

返回：
如果可以选择多个文件，则返回 true
另请参见：
setMultiSelectionEnabled(boolean)

isFileHidingEnabled

public boolean isFileHidingEnabled()
如果在文件选择器中不显示隐藏文件，则返回 true；否则返回 false。

返回：
文件隐藏属性的状态
另请参见：
setFileHidingEnabled(boolean)

setFileHidingEnabled

public void setFileHidingEnabled(boolean b)
设置是否实现文件隐藏。如果为 true，则在文件选择器中不显示隐藏文件。确定显示哪些文件由 FileView 完成。

参数：
b - 确定是否开启文件隐藏的 boolean 值
另请参见：
isFileHidingEnabled()

setFileFilter

public void setFileFilter(FileFilter filter)
设置当前文件过滤器。文件选择器使用文件过滤器从用户的视图中过滤文件。

参数：
filter - 要使用的新的当前文件过滤器
另请参见：
getFileFilter()

getFileFilter

public FileFilter getFileFilter()
返回当前选择的文件过滤器。

返回：
当前的文件过滤器
另请参见：
setFileFilter(javax.swing.filechooser.FileFilter), addChoosableFileFilter(javax.swing.filechooser.FileFilter)

setFileView

public void setFileView(FileView fileView)
设置用于检索 UI 信息的文件视图，如表示文件的图标或文件的类型描述。

另请参见：
getFileView()

getFileView

public FileView getFileView()
返回当前的文件视图。

另请参见：
setFileView(javax.swing.filechooser.FileView)

getName

public String getName(File f)
返回文件名。

参数：
f - File
返回：
包含 f 文件名的 String
另请参见：
FileView.getName(java.io.File)

getDescription

public String getDescription(File f)
返回文件描述。

参数：
f - File
返回：
包含 f 文件描述的 String
另请参见：
FileView.getDescription(java.io.File)

getTypeDescription

public String getTypeDescription(File f)
返回文件类型。

参数：
f - File
返回：
包含 f 文件类型描述的 String
另请参见：
FileView.getTypeDescription(java.io.File)

getIcon

public Icon getIcon(File f)
返回此文件或文件类型的图标，这取决于系统。

参数：
f - File
返回：
此文件或文件类型的 Icon
另请参见：
FileView.getIcon(java.io.File)

isTraversable

public boolean isTraversable(File f)
如果可以返回该文件（目录），则返回 true。如果无法遍历目录，则返回 false。

参数：
f - File
返回：
如果可以遍历文件/目录，则返回 true；否则返回 false
另请参见：
FileView.isTraversable(java.io.File)

accept

public boolean accept(File f)
如果应该显示该文件，则返回 true。

参数：
f - File
返回：
如果应该显示该文件，则返回 true；否则返回 false
另请参见：
FileFilter.accept(java.io.File)

setFileSystemView

public void setFileSystemView(FileSystemView fsv)
设置为访问和创建文件系统资源（如查找软驱和获得根驱动器列表），JFileChooser 所使用的文件系统视图。

参数：
fsv - 新的 FileSystemView
另请参见：
FileSystemView

getFileSystemView

public FileSystemView getFileSystemView()
返回文件系统视图。

返回：
FileSystemView 对象
另请参见：
setFileSystemView(javax.swing.filechooser.FileSystemView)

approveSelection

public void approveSelection()
用户单击 Approve 按钮（默认情况下标有 "Open" 或 "Save"）时由 UI 调用此方法。程序员也可调用此方法。此方法导致使用等效于 APPROVE_SELECTION 的命令字符串激发一个操作事件。

另请参见：
APPROVE_SELECTION

cancelSelection

public void cancelSelection()
用户选择 Cancel 按钮时由 UI 调用此方法。程序员也可调用此方法。此方法导致使用等效于 CANCEL_SELECTION 的命令字符串激发一个操作事件。

另请参见：
CANCEL_SELECTION

addActionListener

public void addActionListener(ActionListener l)
向文件选择器添加一个 ActionListener。

参数：
l - 要添加的侦听器
另请参见：
approveSelection(), cancelSelection()

removeActionListener

public void removeActionListener(ActionListener l)
从文件选择器中移除一个 ActionListener。

参数：
l - 要移除的侦听器
另请参见：
addActionListener(java.awt.event.ActionListener)

getActionListeners

public ActionListener[] getActionListeners()
返回在此文件选择器上注册的所有操作侦听器的数组。

返回：
此文件选择器的所有 ActionListener；如果当前没有注册任何操作侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener)

fireActionPerformed

protected void fireActionPerformed(String command)
通知对此事件类型感兴趣的所有侦听器。使用 command 参数以延迟方式创建事件实例。

另请参见：
EventListenerList

updateUI

public void updateUI()
将 UI 属性重置为当前的外观值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回一个指示 L&F 类名的字符串，该类负责呈现此组件。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "FileChooserUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getUI

public FileChooserUI getUI()
获得实现此组件 L&F 的 UI 对象。

返回：
实现 FileChooserUI L&F 的 FileChooserUI 对象

paramString

protected String paramString()
返回此 JFileChooser 的字符串表示形式。此方法仅在进行调试时使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JFileChooser 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JFileChooser 关联的 AccessibleContext。对于文件选择器，AccessibleContext 采用 AccessibleJFileChooser 的形式。如有必要，可创建一个新的 AccessibleJFileChooser 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJFileChooser，它充当此 JFileChooser 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JFileChooser.AccessibleJFileChooser (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JFileChooser.AccessibleJFileChooser

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JFileChooser.AccessibleJFileChooser
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JFileChooser
protected class JFileChooser.AccessibleJFileChooser
extends JComponent.AccessibleJComponent

此类实现对 JFileChooser 类的可访问性支持。它提供适合文件选择器用户界面元素的 Java Accessibility API 的实现。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JFileChooser.AccessibleJFileChooser()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JFileChooser.AccessibleJFileChooser

protected JFileChooser.AccessibleJFileChooser()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JFrame (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JFrame

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
                继承者  java.awt.Frame
                    继承者  javax.swing.JFrame
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer, WindowConstants
public class JFrame
extends Frame
implements WindowConstants, Accessible, RootPaneContainer

java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。有关使用 JFrame 的面向任务的文档，请参阅 The Java Tutorial 中的 How to Make Frames 一节。

JFrame 类与 Frame 轻微不兼容。与其他所有 JFC/Swing 顶层容器一样，JFrame 包含一个 JRootPane 作为其唯一的子容器。根据规定，根窗格所提供的内容窗格应该包含 JFrame 所显示的所有非菜单组件。这不同于 AWT Frame。为了方便地使用 add 及其变体，已经重写了 remove 和 setLayout，以在必要时将其转发到 contentPane。这意味着可以编写：

       frame.add(child);
子级将被添加到 contentPane。内容窗格始终是非 null 的。试图将其设置为 null 会导致 JFrame 抛出异常。默认的内容窗格上会设置有 BorderLayout 管理器。有关添加、移除和设置 JFrame 的 LayoutManager 的详细信息，请参阅 RootPaneContainer。

与 Frame 不同，当用户试图关闭窗口时，JFrame 知道如何进行响应。用户关闭窗口时，默认的行为只是简单地隐藏 JFrame。要更改默认的行为，可调用方法 setDefaultCloseOperation(int)。要使 JFrame 的行为与 Frame 实例相同，请使用 setDefaultCloseOperation(WindowConstants.DO_NOTHING_ON_CLOSE)。

有关内容窗格和根窗格提供的其他功能的更多信息，请参阅 The Java Tutorial 中的 Using Top-Level Containers 一节。

在多屏幕环境中，可以在不同的屏幕设备上创建一个 JFrame。有关更多信息，请参阅 Frame。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

另请参见：
JRootPane, setDefaultCloseOperation(int), WindowListener.windowClosing(java.awt.event.WindowEvent), RootPaneContainer

嵌套类摘要
protected  class JFrame.AccessibleJFrame
此类实现对 JFrame 类的可访问性支持。
从类 java.awt.Frame 继承的嵌套类/接口
Frame.AccessibleAWTFrame
从类 java.awt.Window 继承的嵌套类/接口
Window.AccessibleAWTWindow
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected AccessibleContext | accessibleContext 可访问的上下文属性。
static int | EXIT_ON_CLOSE 退出应用程序后的默认窗口关闭操作。
protected JRootPane | rootPane JRootPane 实例管理此窗体的 contentPane 和可选的 menuBar，以及 glassPane。
protected boolean | rootPaneCheckingEnabled 如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
从类 java.awt.Frame 继承的字段
CROSSHAIR_CURSOR, DEFAULT_CURSOR, E_RESIZE_CURSOR, HAND_CURSOR, ICONIFIED, MAXIMIZED_BOTH, MAXIMIZED_HORIZ, MAXIMIZED_VERT, MOVE_CURSOR, N_RESIZE_CURSOR, NE_RESIZE_CURSOR, NORMAL, NW_RESIZE_CURSOR, S_RESIZE_CURSOR, SE_RESIZE_CURSOR, SW_RESIZE_CURSOR, TEXT_CURSOR, W_RESIZE_CURSOR, WAIT_CURSOR
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.WindowConstants 继承的字段
DISPOSE_ON_CLOSE, DO_NOTHING_ON_CLOSE, HIDE_ON_CLOSE
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JFrame()
构造一个初始时不可见的新窗体。
JFrame(GraphicsConfiguration gc)
以屏幕设备的指定 GraphicsConfiguration 和空白标题创建一个 Frame。
JFrame(String title)
创建一个新的、初始不可见的、具有指定标题的 Frame。
JFrame(String title, GraphicsConfiguration gc)
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。
方法摘要
protected void | addImpl(Component comp, Object constraints, int index) 添加指定的子 Component。
protected JRootPane | createRootPane() 由构造方法调用，以创建默认的 rootPane。
protected void | frameInit() 由构造方法调用，以适当地初始化 JFrame。
AccessibleContext | getAccessibleContext() 获得与此 JFrame 关联的 AccessibleContext。
Container | getContentPane() 返回此窗体的 contentPane 对象
int | getDefaultCloseOperation() 返回用户在此窗体上发起 "close" 时执行的操作。
Component | getGlassPane() 返回此窗体的 glassPane 对象。
Graphics | getGraphics() 为组件创建一个图形上下文。
JMenuBar | getJMenuBar() 返回此窗体上设置的菜单栏。
JLayeredPane | getLayeredPane() 返回此窗体的 layeredPane 对象。
JRootPane | getRootPane() 返回此窗体的 rootPane 对象。
TransferHandler | getTransferHandler() 获取 transferHandler 属性。
static boolean | isDefaultLookAndFeelDecorated() 如果新创建的 JFrame 应该由当前外观为其提供 Window 装饰，则返回 true。
protected boolean | isRootPaneCheckingEnabled() 返回是否将对 add 和 setLayout 的调用转发到 contentPane。
protected String | paramString() 返回此 JFrame 的字符串表示形式。
protected void | processWindowEvent(WindowEvent e) 处理此组件上发生的窗口事件。
void | remove(Component comp) 从该容器中移除指定组件。
void | repaint(long time, int x, int y, int width, int height) 在 time 毫秒内重绘此组件的指定矩形区域。
void | setContentPane(Container contentPane) 设置 contentPane 属性。
void | setDefaultCloseOperation(int operation) 设置用户在此窗体上发起 "close" 时默认执行的操作。
static void | setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated) 提供一个关于新创建的 JFrame 是否应该具有当前外观为其提供的 Window 装饰（如边框、关闭窗口的小部件、标题等等）的提示。
void | setGlassPane(Component glassPane) 设置 glassPane 属性。
void | setIconImage(Image image) 设置要作为此窗口图标显示的图像。
void | setJMenuBar(JMenuBar menubar) 设置此窗体的菜单栏。
void | setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | setLayout(LayoutManager manager) 设置 LayoutManager。
protected void | setRootPane(JRootPane root) 设置 rootPane 属性。
protected void | setRootPaneCheckingEnabled(boolean enabled) 设置是否将对 add 和 setLayout 的调用转发到 contentPane。
void | setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。
void | update(Graphics g) 只是调用 paint(g)。
从类 java.awt.Frame 继承的方法
addNotify, getCursorType, getExtendedState, getFrames, getIconImage, getMaximizedBounds, getMenuBar, getState, getTitle, isResizable, isUndecorated, remove, removeNotify, setCursor, setExtendedState, setMaximizedBounds, setMenuBar, setResizable, setState, setTitle, setUndecorated
从类 java.awt.Window 继承的方法
addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getGraphicsConfiguration, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOwnedWindows, getOwner, getOwnerlessWindows, getToolkit, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isShowing, pack, postEvent, processEvent, processWindowFocusEvent, processWindowStateEvent, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setVisible, show, toBack, toFront
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 java.awt.MenuContainer 继承的方法
getFont, postEvent

字段详细信息

EXIT_ON_CLOSE

public static final int EXIT_ON_CLOSE
退出应用程序后的默认窗口关闭操作。如果执行关闭操作时窗口具有此设置，并且是在 applet 中关闭窗口，则可能抛出 SecurityException。建议仅在应用程序中使用此设置。

从以下版本开始：
1.3
另请参见：
常量字段值

rootPane

protected JRootPane rootPane
JRootPane 实例管理此窗体的 contentPane 和可选的 menuBar，以及 glassPane。

另请参见：
JRootPane, RootPaneContainer

rootPaneCheckingEnabled

protected boolean rootPaneCheckingEnabled
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。此设置初始为 false，但在构建 JFrame 时将其设置为 true。

另请参见：
isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

accessibleContext

protected AccessibleContext accessibleContext
可访问的上下文属性。

构造方法详细信息

JFrame

public JFrame()
       throws HeadlessException
构造一个初始时不可见的新窗体。

此构造方法将组件的 locale 属性设置为 JComponent.getDefaultLocale 所返回的值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean),
JComponent.getDefaultLocale()

JFrame

public JFrame(GraphicsConfiguration gc)
以屏幕设备的指定 GraphicsConfiguration 和空白标题创建一个 Frame。

此构造方法将组件的 locale 属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
gc - 用于构造新 Frame 的 GraphicsConfiguration；如果 gc 为 null，则使用系统默认的 GraphicsConfiguration
抛出：
IllegalArgumentException - 如果 gc 不是来自屏幕设备。GraphicsEnvironment.isHeadless() 返回 true 时总是抛出此异常。
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()

JFrame

public JFrame(String title)
       throws HeadlessException
创建一个新的、初始不可见的、具有指定标题的 Frame。

此构造方法将组件的 locale 属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
title - 该窗体的标题
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(),
Component.setSize(int, int),
Component.setVisible(boolean),
JComponent.getDefaultLocale()

JFrame

public JFrame(String title,
              GraphicsConfiguration gc)
创建一个具有指定标题和指定屏幕设备的 GraphicsConfiguration 的 JFrame。

此构造方法将组件的 locale 属性设置为 JComponent.getDefaultLocale 所返回的值。

参数：
title - 要显示在窗体边框中的标题。将 null 值视为空字符串 ""。
gc - 用于构造新 JFrame 的 GraphicsConfiguration；如果 gc 为 null，则使用系统默认的 GraphicsConfiguration
抛出：
IllegalArgumentException - 如果 gc 不是来自屏幕设备。GraphicsEnvironment.isHeadless() 返回 true 时总是抛出此异常。
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless(), JComponent.getDefaultLocale()
方法详细信息

frameInit

protected void frameInit()
由构造方法调用，以适当地初始化 JFrame。

createRootPane

protected JRootPane createRootPane()
由构造方法调用，以创建默认的 rootPane。

processWindowEvent

protected void processWindowEvent(WindowEvent e)
处理此组件上发生的窗口事件。隐藏窗口或释放窗口，根据 defaultCloseOperation 属性的设置来指定。

覆盖：
类 Window 中的 processWindowEvent
参数：
e - 窗口事件
另请参见：
setDefaultCloseOperation(int), Window.processWindowEvent(java.awt.event.WindowEvent)

setDefaultCloseOperation

public void setDefaultCloseOperation(int operation)
设置用户在此窗体上发起 "close" 时默认执行的操作。必须指定以下选项之一：

  • DO_NOTHING_ON_CLOSE（在 WindowConstants 中定义）：不执行任何操作；要求程序在已注册的 WindowListener 对象的 windowClosing 方法中处理该操作。
  • HIDE_ON_CLOSE（在 WindowConstants 中定义）：调用任意已注册的 WindowListener 对象后自动隐藏该窗体。
  • DISPOSE_ON_CLOSE（在 WindowConstants 中定义）：调用任意已注册 WindowListener 的对象后自动隐藏并释放该窗体。
  • EXIT_ON_CLOSE（在 JFrame 中定义）：使用 System exit 方法退出应用程序。仅在应用程序中使用。

默认情况下，该值被设置为 HIDE_ON_CLOSE。更改此属性的值将导致激发属性更改事件，其属性名称为 "defaultCloseOperation"。

注：当 Java 虚拟机 (VM) 中最后一个可显示窗口被释放后，虚拟机可能会终止。有关更多信息，请参阅 AWT Threading Issues。

参数：
operation - 用户关闭该窗体时应该执行的操作
抛出：
IllegalArgumentException - 如果 defaultCloseOperation 值不是上述有效值之一
SecurityException - 如果已指定 EXIT_ON_CLOSE 并且 SecurityManager 不允许调用者调用 System.exit
另请参见：
Window.addWindowListener(java.awt.event.WindowListener), getDefaultCloseOperation(), WindowConstants, Runtime.exit(int)

getDefaultCloseOperation

public int getDefaultCloseOperation()
返回用户在此窗体上发起 "close" 时执行的操作。

返回：
一个指示窗口关闭操作的整数
另请参见：
setDefaultCloseOperation(int)

setTransferHandler

public void setTransferHandler(TransferHandler newHandler)
设置 transferHandler 属性，该属性是支持向此组件传输数据的机制。如果该组件不支持数据传输操作，那么请使用 null。

如果系统属性 suppressSwingDropSupport 为 false（默认值），并且此组件上的当前放置目标为 null 或者不是用户设置的放置目标，则此方法将按如下方式更改放置目标：如果 newHandler 为 null，则它将清除放置目标。如果不为 null，则它将安装一个新的 DropTarget。

注：当用于 JFrame 时，TransferHandler 只提供数据导入功能，与数据导出相关的方法当前用于 JComponent。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

参数：
newHandler - 新的 TransferHandler
从以下版本开始：
1.6
另请参见：
TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

getTransferHandler

public TransferHandler getTransferHandler()
获取 transferHandler 属性。

返回：
transferHandler 属性的值
从以下版本开始：
1.6
另请参见：
TransferHandler, setTransferHandler(javax.swing.TransferHandler)

update

public void update(Graphics g)
只是调用 paint(g)。重写此方法，以防止不必要的调用清除背景。

覆盖：
类 Container 中的 update
参数：
g - 要在其中进行绘制的 Graphics 上下文
另请参见：
Component.update(Graphics)

setJMenuBar

public void setJMenuBar(JMenuBar menubar)
设置此窗体的菜单栏。

参数：
menubar - 放置于该窗体中的菜单栏
另请参见：
getJMenuBar()

getJMenuBar

public JMenuBar getJMenuBar()
返回此窗体上设置的菜单栏。

返回：
此窗体的菜单栏
另请参见：
setJMenuBar(javax.swing.JMenuBar)

isRootPaneCheckingEnabled

protected boolean isRootPaneCheckingEnabled()
返回是否将对 add 和 setLayout 的调用转发到 contentPane。

返回：
如果转发 add 和 setLayout，则返回 true；否则返回 false
另请参见：
addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

setRootPaneCheckingEnabled

protected void setRootPaneCheckingEnabled(boolean enabled)
设置是否将对 add 和 setLayout 的调用转发到 contentPane。

参数：
enabled - 如果转发 add 和 setLayout，则为 true；如果应直接在 JFrame 上操作，则为 false。
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
添加指定的子 Component。重写此方法，从而有条件地将调用转发到 contentPane。默认情况下将子组件添加到 contentPane 而不是窗体中，有关详细信息，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要添加子组件的组件
constraints - 要遵守的约束条件
index - 索引
抛出：
IllegalArgumentException - 如果 index 无效
IllegalArgumentException - 如果将容器的父级添加到其本身
IllegalArgumentException - 如果向容器内添加窗口
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

remove

public void remove(Component comp)
从该容器中移除指定组件。如果 comp 不是 rootPane，则将调用转发到 contentPane。如果 comp 不是 JFrame 或 contentPane 的子级，则不执行任何操作。

覆盖：
类 Container 中的 remove
参数：
comp - 要移除的组件
抛出：
NullPointerException - 如果 comp 为 null
另请参见：
Container.add(java.awt.Component), RootPaneContainer

setLayout

public void setLayout(LayoutManager manager)
设置 LayoutManager。重写此方法，从而有条件地将调用转发到 contentPane。有关更多信息，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 setLayout
参数：
manager - LayoutManager
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

getRootPane

public JRootPane getRootPane()
返回此窗体的 rootPane 对象。

指定者：
接口 RootPaneContainer 中的 getRootPane
返回：
rootPane 属性
另请参见：
setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

setRootPane

protected void setRootPane(JRootPane root)
设置 rootPane 属性。此方法由构造方法调用。

参数：
root - 此窗体的 rootPane 对象
另请参见：
getRootPane()

setIconImage

public void setIconImage(Image image)
设置要作为此窗口图标显示的图像。

将单个图像指定为窗口的图标时，可以使用此方法代替 setIconImages()。

以下语句：

     setIconImage(image);
等价于：
     ArrayList   imageList = new ArrayList  ();
     imageList.add(image);
     setIconImages(imageList);

注：根据上下文的不同（例如，窗口装饰、窗口列表、任务栏等），本机窗口系统可以使用不同尺寸的不同图像表示一个窗口。也可以对所有上下文使用一个图像，或者根本不用图像。

覆盖：
类 Frame 中的 setIconImage
参数：
image - 要显示的图标图像。
另请参见：
Window.setIconImages(java.util.List), Window.getIconImages()

getContentPane

public Container getContentPane()
返回此窗体的 contentPane 对象

指定者：
接口 RootPaneContainer 中的 getContentPane
返回：
contentPane 属性
另请参见：
setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

setContentPane

public void setContentPane(Container contentPane)
设置 contentPane 属性。此方法由构造方法调用。

Swing 的绘制架构要求在包含层次结构中有不透明的 JComponent。这通常由内容窗格提供。如果要替换内容窗格，建议用不透明的 JComponent 替换它。

指定者：
接口 RootPaneContainer 中的 setContentPane
参数：
contentPane - 此窗体的 contentPane 对象
抛出：
IllegalComponentStateException - （运行时异常）如果 contentPane 参数为 null
另请参见：
getContentPane(), RootPaneContainer.setContentPane(java.awt.Container), JRootPane

getLayeredPane

public JLayeredPane getLayeredPane()
返回此窗体的 layeredPane 对象。

指定者：
接口 RootPaneContainer 中的 getLayeredPane
返回：
layeredPane 属性
另请参见：
setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

setLayeredPane

public void setLayeredPane(JLayeredPane layeredPane)
设置 layeredPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setLayeredPane
参数：
layeredPane - 此窗体的 layeredPane 对象
抛出：
IllegalComponentStateException - （运行时异常）如果 layeredPane 参数为 null
另请参见：
getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

getGlassPane

public Component getGlassPane()
返回此窗体的 glassPane 对象。

指定者：
接口 RootPaneContainer 中的 getGlassPane
返回：
glassPane 属性
另请参见：
setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

setGlassPane

public void setGlassPane(Component glassPane)
设置 glassPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setGlassPane
参数：
glassPane - 此窗体的 glassPane 对象
另请参见：
getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

getGraphics

public Graphics getGraphics()
为组件创建一个图形上下文。如果组件当前是不可显示的，则此方法返回 null。

覆盖：
类 Component 中的 getGraphics
返回：
组件的图形上下文，如果其没有，则返回 null
从以下版本开始：
1.6
另请参见：
Component.paint(java.awt.Graphics)

repaint

public void repaint(long time,
                    int x,
                    int y,
                    int width,
                    int height)
在 time 毫秒内重绘此组件的指定矩形区域。有关如何处理重绘的详细信息，请参阅 RepaintManager。

覆盖：
类 Component 中的 repaint
参数：
time - 更新前等待的最长时间（以毫秒为单位）
x - x 坐标
y - y 坐标
width - 宽度
height - 高度
从以下版本开始：
1.6
另请参见：
RepaintManager

setDefaultLookAndFeelDecorated

public static void setDefaultLookAndFeelDecorated(boolean defaultLookAndFeelDecorated)
提供一个关于新创建的 JFrame 是否应该具有当前外观为其提供的 Window 装饰（如边框、关闭窗口的小部件、标题等等）的提示。如果 defaultLookAndFeelDecorated 为 true，则当前的 LookAndFeel 支持提供窗口装饰，并且当前的窗口管理器支持未装饰的窗口，然后新创建的 JFrame 将具有当前 LookAndFeel 为其提供的 Window 装饰。否则，新创建的 JFrame 将具有当前窗口管理器为其提供的 Window 装饰。

执行以下操作可在单个 JFrame 上获得相同的效果：

    JFrame frame = new JFrame();
    frame.setUndecorated(true);
    frame.getRootPane().setWindowDecorationStyle(JRootPane.FRAME);

参数：
defaultLookAndFeelDecorated - 指示当前的外观是否应该提供窗口装饰的提示
从以下版本开始：
1.4
另请参见：
LookAndFeel.getSupportsWindowDecorations()

isDefaultLookAndFeelDecorated

public static boolean isDefaultLookAndFeelDecorated()
如果新创建的 JFrame 应该由当前外观为其提供 Window 装饰，则返回 true。这只是一个提示，因为某些外观可能不支持此功能。

返回：
如果外观应该提供 Window 装饰，则返回 true。
从以下版本开始：
1.4

paramString

protected String paramString()
返回此 JFrame 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Frame 中的 paramString
返回：
此 JFrame 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得与此 JFrame 关联的 AccessibleContext。对于 JFrame，AccessibleContext 采用 AccessibleJFrame 的形式。如有必要，可创建一个新的 AccessibleJFrame 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Frame 中的 getAccessibleContext
返回：
一个 AccessibleJFrame，它充当此 JFrame 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JFormattedTextField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JFormattedTextField

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
                    继承者  javax.swing.JTextField
                        继承者  javax.swing.JFormattedTextField
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants
public class JFormattedTextField
extends JTextField

JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。以下代码说明了如何配置 JFormattedTextField 来编辑日期：

   JFormattedTextField ftf = new JFormattedTextField();
   ftf.setValue(new Date());

一旦创建了 JFormattedTextField，就可以通过添加 PropertyChangeListener 的方式来侦听编辑更改，并且使用属性名 value 来侦听 PropertyChangeEvent。

JFormattedTextField 允许配置在失去焦点时应该采取的措施。可能的值为：

值 | 描述
JFormattedTextField.REVERT | 恢复显示以匹配 getValue，这可能丢失当前的编辑内容。
JFormattedTextField.COMMIT | 提交当前值。如果 AbstractFormatter 不认为所编辑的值是合法值，则抛出 ParseException，然后不更改该值并保留已编辑的值。
JFormattedTextField.COMMIT_OR_REVERT | 与 COMMIT 类似，但是如果该值不是合法的，则其行为类似于 REVERT。
JFormattedTextField.PERSIST | 不执行任何操作，不获取新的 AbstractFormatter 也不更新该值。
默认值为 JFormattedTextField.COMMIT_OR_REVERT，有关此内容的更多信息，请参阅 setFocusLostBehavior(int)。

JFormattedTextField 允许焦点离开，即使当前编辑的值是无效的也是如此。要在 JFormattedTextField 处于无效编辑状态时锁定焦点，可以附加一个 InputVerifier。以下代码片断显示了这种 InputVerifier 的可能实现：

 public class FormattedTextFieldVerifier extends InputVerifier {
     public boolean verify(JComponent input) {
         if (input instanceof JFormattedTextField) {
             JFormattedTextField ftf = (JFormattedTextField)input;
             AbstractFormatter formatter = ftf.getFormatter();
             if (formatter != null) {
                 String text = ftf.getText();
                 try {
                      formatter.stringToValue(text);
return true;
                  } catch (ParseException pe) {
                      return false;
                  }
              }
          }
return true;
      }
      public boolean shouldYieldFocus(JComponent input) {
          return verify(input);
      }
  }

或者，也可以调用 commitEdit，这也会提交该值。

JFormattedTextField 本身不执行格式化，而是通过从 JFormattedTextField.AbstractFormatterFactory 实例获得的 JFormattedTextField.AbstractFormatter 实例完成格式化。通过 install 方法的方式使 JFormattedTextField.AbstractFormatter 的实例处于激活状态时会通知它们，此时 JFormattedTextField.AbstractFormatter 可以安装其所需的任何内容，通常是 DocumentFilter。类似地，当 JFormattedTextField 不再需要 AbstractFormatter 时，它会调用 uninstall。

JFormattedTextField 通常在获得或丢失焦点时查询 AbstractFormatterFactory 以找到 AbstractFormat。但根据焦点丢失策略也可以更改此行为。如果焦点丢失策略是 JFormattedTextField.PERSIST 并且已编辑了 JFormattedTextField，则在值提交之前不会查询 AbstractFormatterFactory。类似地，如果焦点丢失策略是 JFormattedTextField.COMMIT 并且从 stringToValue 中抛出异常，则丢失或获得焦点时不查询 AbstractFormatterFactory。

JFormattedTextField.AbstractFormatter 还负责确定何时将值提交给 JFormattedTextField。某些 JFormattedTextField.AbstractFormatter 在每次编辑时都提供新值，而其他的则从不提交该值。可以强行从当前的 JFormattedTextField.AbstractFormatter 获得当前值，方法是调用 commitEdit。每当在 JFormattedTextField 中按下了 return 键，就调用 commitEdit。

如果尚未显式地设置 AbstractFormatterFactory，则在调用 setValue 后（假定 value 是非 null 的），根据 value 类型的 Class 设置该值。例如，在以下代码中将创建一个合适的 AbstractFormatterFactory 和 AbstractFormatter，以处理数字的格式化：

   JFormattedTextField tf = new JFormattedTextField();
   tf.setValue(new Number(100));

警告：由于 AbstractFormatter 通常在 Document 上安装一个 DocumentFilter，在 JFormattedTextField 上安装一个 NavigationFilter，所以您不应安装自己的过滤器。如果您安装了，则会看到奇怪的行为，因为将无法强制执行 AbstractFormatter 的编辑策略。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4

嵌套类摘要
static class | JFormattedTextField.AbstractFormatter JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
static class | JFormattedTextField.AbstractFormatterFactory JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。
从类 javax.swing.JTextField 继承的嵌套类/接口
JTextField.AccessibleJTextField
从类 javax.swing.text.JTextComponent 继承的嵌套类/接口
JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | COMMIT 标识丢失焦点时，应该调用 commitEdit 的常量。
static int | COMMIT_OR_REVERT 标识丢失焦点时，应该调用 commitEdit 的常量。
static int | PERSIST 标识丢失焦点时，应该保留编辑值的常量。
static int | REVERT 标识丢失焦点时，应该将编辑的值恢复为 JFormattedTextField 上所设当前值的常量。
从类 javax.swing.JTextField 继承的字段
notifyAction
从类 javax.swing.text.JTextComponent 继承的字段
DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JFormattedTextField()
创建一个没有 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(Format format)
创建一个 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatter formatter)
创建一个具有指定 AbstractFormatter 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory)
创建一个具有指定 AbstractFormatterFactory 的 JFormattedTextField。
JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory, Object currentValue)
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。
JFormattedTextField(Object value)
创建一个具有指定值的 JFormattedTextField。
方法摘要
void | commitEdit() 强制从 AbstractFormatter 获得当前值并将其设置为当前值。
Action[] | getActions() 获取编辑器的命令列表。
int | getFocusLostBehavior() 返回丢失焦点时的行为。
JFormattedTextField.AbstractFormatter | getFormatter() 返回用于格式化和分析当前值的 AbstractFormatter。
JFormattedTextField.AbstractFormatterFactory | getFormatterFactory() 返回当前的 AbstractFormatterFactory。
String | getUIClassID() 获得 UI 的类 ID。
Object | getValue() 返回最后一个有效值。
protected void | invalidEdit() 用户输入无效值时调用。
boolean | isEditValid() 如果所编辑的当前值有效，则返回 true。
protected void | processFocusEvent(FocusEvent e) 处理所有的焦点事件，如 FocusEvent.FOCUS_GAINED 或 FocusEvent.FOCUS_LOST。
protected void | processInputMethodEvent(InputMethodEvent e) 处理所有的输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED 或 InputMethodEvent.CARET_POSITION_CHANGED。
void | setDocument(Document doc) 将该编辑器与某个文本文档关联。
void | setFocusLostBehavior(int behavior) 设置丢失焦点时的行为。
protected void | setFormatter(JFormattedTextField.AbstractFormatter format) 设置当前的 AbstractFormatter。
void | setFormatterFactory(JFormattedTextField.AbstractFormatterFactory tf) 设置 AbstractFormatterFactory。
void | setValue(Object value) 设置值，该值由从当前 AbstractFormatterFactory 获得的 AbstractFormatter 进行格式化。
从类 javax.swing.JTextField 继承的方法
actionPropertyChanged, addActionListener, configurePropertiesFromAction, createActionPropertyChangeListener, createDefaultModel, fireActionPerformed, getAccessibleContext, getAction, getActionListeners, getColumns, getColumnWidth, getHorizontalAlignment, getHorizontalVisibility, getPreferredSize, getScrollOffset, isValidateRoot, paramString, postActionEvent, removeActionListener, scrollRectToVisible, setAction, setActionCommand, setColumns, setFont, setHorizontalAlignment, setScrollOffset
从类 javax.swing.text.JTextComponent 继承的方法
addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

COMMIT

public static final int COMMIT
标识丢失焦点时，应该调用 commitEdit 的常量。如果在提交新值的过程中抛出 ParseException，则将保留无效值。

另请参见：
setFocusLostBehavior(int), 常量字段值

COMMIT_OR_REVERT

public static final int COMMIT_OR_REVERT
标识丢失焦点时，应该调用 commitEdit 的常量。如果在提交新值的过程中抛出 ParseException，则将恢复原值。

另请参见：
setFocusLostBehavior(int), 常量字段值

REVERT

public static final int REVERT
标识丢失焦点时，应该将编辑的值恢复为 JFormattedTextField 上所设当前值的常量。

另请参见：
setFocusLostBehavior(int), 常量字段值

PERSIST

public static final int PERSIST
标识丢失焦点时，应该保留编辑值的常量。

另请参见：
setFocusLostBehavior(int), 常量字段值
构造方法详细信息

JFormattedTextField

public JFormattedTextField()
创建一个没有 AbstractFormatterFactory 的 JFormattedTextField。使用 setMask 或 setFormatterFactory 配置 JFormattedTextField 以编辑特定的值类型。

JFormattedTextField

public JFormattedTextField(Object value)
创建一个具有指定值的 JFormattedTextField。这将根据 value 的类型创建一个 AbstractFormatterFactory。

参数：
value - JFormattedTextField 的初始值

JFormattedTextField

public JFormattedTextField(Format format)
创建一个 JFormattedTextField。format 包装在一个适当的 AbstractFormatter 中，然后该 AbstractFormatter 包装在一个 AbstractFormatterFactory 中。

参数：
format - 用于查找 AbstractFormatter 的 Format

JFormattedTextField

public JFormattedTextField(JFormattedTextField.AbstractFormatter formatter)
创建一个具有指定 AbstractFormatter 的 JFormattedTextField。该 AbstractFormatter 被放置在 AbstractFormatterFactory 中。

参数：
formatter - 进行格式化所使用的 AbstractFormatter。

JFormattedTextField

public JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory)
创建一个具有指定 AbstractFormatterFactory 的 JFormattedTextField。

参数：
factory - 用于进行格式化的 AbstractFormatterFactory。

JFormattedTextField

public JFormattedTextField(JFormattedTextField.AbstractFormatterFactory factory,
                           Object currentValue)
创建一个具有指定 AbstractFormatterFactory 和初始值的 JFormattedTextField。

参数：
factory - 用于进行格式化的 AbstractFormatterFactory。
currentValue - 要使用的初始值
方法详细信息

setFocusLostBehavior

public void setFocusLostBehavior(int behavior)
设置丢失焦点时的行为。这是 JFormattedTextField.COMMIT_OR_REVERT、JFormattedTextField.REVERT、JFormattedTextField.COMMIT 或 JFormattedTextField.PERSIST 之一。注意，某些 AbstractFormatter 可能在出现更改时即进行下一步操作，所以该值无效。

如果传入的对象不是上述值之一，则将抛出 IllegalArgumentException。

此属性的默认值为 JFormattedTextField.COMMIT_OR_REVERT。

参数：
behavior - 标识丢失焦点时的行为
抛出：
IllegalArgumentException - 如果 behavior 不是某个已知值

getFocusLostBehavior

public int getFocusLostBehavior()
返回丢失焦点时的行为。这是 COMMIT_OR_REVERT、COMMIT、REVERT 或 PERSIST 之一。注意，某些 AbstractFormatter 可能在出现更改时即进行下一步操作，所以该值无效。

返回：
返回丢失焦点时的行为

setFormatterFactory

public void setFormatterFactory(JFormattedTextField.AbstractFormatterFactory tf)
设置 AbstractFormatterFactory。AbstractFormatterFactory 能够返回 AbstractFormatter 的实例，它可用于格式化要显示的某个值，以及强制执行编辑策略。

如果尚未通过此方法（或构造方法）显式地设置 AbstractFormatterFactory，则根据该值的 Class 使用 AbstractFormatterFactory，然后使用 AbstractFormatter。NumberFormatter 用于 Number，DateFormatter 用于 Dates，其他值将使用 DefaultFormatter。

这是一个 JavaBeans 绑定 (bound) 属性。

参数：
tf - 用于查找 AbstractFormatter 实例的 AbstractFormatterFactory

getFormatterFactory

public JFormattedTextField.AbstractFormatterFactory getFormatterFactory()
返回当前的 AbstractFormatterFactory。

返回：
用于确定 AbstractFormatter 的 AbstractFormatterFactory
另请参见：
setFormatterFactory(javax.swing.JFormattedTextField.AbstractFormatterFactory)

setFormatter

protected void setFormatter(JFormattedTextField.AbstractFormatter format)
设置当前的 AbstractFormatter。

通常不应调用此方法，而是设置 AbstractFormatterFactory 或设置值。当 JFormattedTextField 的状态更改并且需要重置该值时，JFormattedTextField 将调用此方法。JFormattedTextField 传入从 AbstractFormatterFactory 所获得的 AbstractFormatter。

这是一个 JavaBeans 绑定属性。

参数：
format - 进行格式化所使用的 AbstractFormatter
另请参见：
setFormatterFactory(javax.swing.JFormattedTextField.AbstractFormatterFactory)

getFormatter

public JFormattedTextField.AbstractFormatter getFormatter()
返回用于格式化和分析当前值的 AbstractFormatter。

返回：
用于进行格式化的 AbstractFormatter

setValue

public void setValue(Object value)
设置值，该值由从当前 AbstractFormatterFactory 获得的 AbstractFormatter 进行格式化。如果尚未指定任何 AbstractFormatterFactory，则此方法会试图根据 value 的类型创建它。

此属性的默认值为 null。

这是一个 JavaBeans 绑定属性。

参数：
value - 要显示的当前值

getValue

public Object getValue()
返回最后一个有效值。根据 AbstractFormatter 的编辑策略，此方法可能不会返回当前值。可通过调用 commitEdit 后调用 getValue 来获得当前编辑的值。

返回：
最后一个有效值

commitEdit

public void commitEdit()
                throws ParseException
强制从 AbstractFormatter 获得当前值并将其设置为当前值。 如果当前没有已安装的 AbstractFormatter，则此方法无效。

抛出：
ParseException - 如果 AbstractFormatter 无法格式化当前值

isEditValid

public boolean isEditValid()
如果所编辑的当前值有效，则返回 true。此值由当前的 AbstractFormatter 进行管理，并且没有针对它的公共 setter。

返回：
如果所编辑的当前值有效，则返回 true。

invalidEdit

protected void invalidEdit()
用户输入无效值时调用。这就使得组件可以提供反馈。默认的实现是发出蜂鸣声。

processInputMethodEvent

protected void processInputMethodEvent(InputMethodEvent e)
处理所有的输入法事件，如 InputMethodEvent.INPUT_METHOD_TEXT_CHANGED 或 InputMethodEvent.CARET_POSITION_CHANGED。

覆盖：
类 JTextComponent 中的 processInputMethodEvent
参数：
e - InputMethodEvent
另请参见：
InputMethodEvent

processFocusEvent

protected void processFocusEvent(FocusEvent e)
处理所有的焦点事件，如 FocusEvent.FOCUS_GAINED 或 FocusEvent.FOCUS_LOST。

覆盖：
类 Component 中的 processFocusEvent
参数：
e - FocusEvent
另请参见：
FocusEvent

getActions

public Action[] getActions()
获取编辑器的命令列表。这是嵌入的 UI 所支持的命令列表，该 UI 通过编辑器本身支持的命令集进行扩充。这些命令对于绑定到事件是很有用的，例如在 keymap 中。

覆盖：
类 JTextField 中的 getActions
返回：
命令列表

getUIClassID

public String getUIClassID()
获得 UI 的类 ID。

覆盖：
类 JTextField 中的 getUIClassID
返回：
字符串 "FormattedTextFieldUI"
另请参见：
JComponent.getUIClassID()

setDocument

public void setDocument(Document doc)
将该编辑器与某个文本文档关联。使用当前已注册的工厂构建一个文档视图，重新确认后由编辑器显示该文档。PropertyChange 事件 ("document") 被传播到每个侦听器。

覆盖：
类 JTextField 中的 setDocument
参数：
doc - 要显示/编辑的文档
另请参见：
JTextComponent.getDocument()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JFormattedTextField.AbstractFormatter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JFormattedTextField.AbstractFormatter

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatter
所有已实现的接口：
Serializable
直接已知子类：
DefaultFormatter
正在封闭类：
JFormattedTextField
public abstract static class JFormattedTextField.AbstractFormatter
extends Object
implements Serializable

JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。AbstractFormatter 还可强制执行编辑策略，或者指导策略的执行，或者以任何适合于强制执行所需策略的方式操作 JFormattedTextField。

AbstractFormatter 一次只能在一个 JFormattedTextField 中处于激活状态。JFormattedTextField 准备好使用 install 时即调用它，完成后调用 uninstall。希望安装其他状态的子类应该重写 install 并适当地通知超类。

子类必须重写转换方法 stringToValue 和 valueToString。或者，子类可以重写 getActions、getNavigationFilter 和 getDocumentFilter，以便以特定的方式限制 JFormattedTextField。

允许 JFormattedTextField 处于临时无效状态的子类应该在恰当的时间调用 setEditValid。

从以下版本开始：
1.4

构造方法摘要
JFormattedTextField.AbstractFormatter()
方法摘要
protected Object | clone() 复制 AbstractFormatter。
protected Action[] | getActions() 如果想提供自定义的 Action 集合，则应进行子类化和重写。
protected DocumentFilter | getDocumentFilter() 如果想要提供某个 DocumentFilter 以限制输入内容，则应进行子类化和重写。
protected JFormattedTextField | getFormattedTextField() 返回 AbstractFormatter 所安装到的当前 JFormattedTextField。
protected NavigationFilter | getNavigationFilter() 如果想要提供过滤器以限制用户可导航的位置，则应进行子类化和重写。
void | install(JFormattedTextField ftf) 将 AbstractFormatter 安装到特定的 JFormattedTextField。
protected void | invalidEdit() 用户键入无效字符时调用此方法。
protected void | setEditValid(boolean valid) 调用此方法以更新 JFormattedTextField 的 editValid 属性。
abstract Object | stringToValue(String text) 分析 text，返回任意 Object。
void | uninstall() 卸载 AbstractFormatter 可能已在 JFormattedTextField 上安装的所有状态。
abstract String | valueToString(Object value) 返回为 value 显示的 string 值。
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JFormattedTextField.AbstractFormatter

public JFormattedTextField.AbstractFormatter()
方法详细信息

install

public void install(JFormattedTextField ftf)
将 AbstractFormatter 安装到特定的 JFormattedTextField。这会调用 valueToString 将 JFormattedTextField 的当前值转换为 String。然后将从 getActions 返回的 Action、从 getDocumentFilter 返回的 DocumentFilter 和从 getNavigationFilter 返回的 NavigationFilter 安装到 JFormattedTextField。

如果子类希望在该 JFormattedTextField 上安装其他侦听器，通常只需重写此方法即可。

如果将当前值转换为 String 的过程中出现 ParseException，则会将文本设置为空 String，并标记 JFormattedTextField 为处于无效状态。

不过这是一个公共方法，通常它只对 JFormattedTextField 的子类有用。当值更改，或者 JFormattedTextField 的内部状态更改时，JFormattedTextField 才在适当的时间调用此方法。如果要创建 JFormattedTextField 的子类并且在不同于 JFormattedTextField 操作的时间安装/卸载 AbstractFormatter，则只需自己调用此方法。

参数：
ftf - 用于格式化的 JFormattedTextField，可以为 null，指示从当前 JFormattedTextField 进行卸载。

uninstall

public void uninstall()
卸载 AbstractFormatter 可能已在 JFormattedTextField 上安装的所有状态。这会重置在 JFormattedTextField 上安装的 DocumentFilter、NavigationFilter 和其他 Action。

stringToValue

public abstract Object stringToValue(String text)
                              throws ParseException
分析 text，返回任意 Object。某些 formatter 可能返回 null。

参数：
text - 要转换的 String
返回：
文本的 Object 表示形式
抛出：
ParseException - 如果转换过程中出现错误

valueToString

public abstract String valueToString(Object value)
                              throws ParseException
返回为 value 显示的 string 值。

参数：
value - 要转换的 Value
返回：
值的 String 表示形式
抛出：
ParseException - 如果转换过程中出现错误

getFormattedTextField

protected JFormattedTextField getFormattedTextField()
返回 AbstractFormatter 所安装到的当前 JFormattedTextField。

返回：
用于格式化的 JFormattedTextField。

invalidEdit

protected void invalidEdit()
用户键入无效字符时调用此方法。这会将调用转发到当前的 JFormattedTextField。

setEditValid

protected void setEditValid(boolean valid)
调用此方法以更新 JFormattedTextField 的 editValid 属性。如果强制实施某个策略而使 JFormattedTextField 始终处于有效状态，则不再需要调用此方法。

参数：
valid - JFormattedTextField 的有效状态

getActions

protected Action[] getActions()
如果想提供自定义的 Action 集合，则应进行子类化和重写。install 将在 JFormattedTextField 的 ActionMap 上安装这些 Action。

返回：
要在 JFormattedTextField 上安装的 Action 数组

getDocumentFilter

protected DocumentFilter getDocumentFilter()
如果想要提供某个 DocumentFilter 以限制输入内容，则应进行子类化和重写。install 会将返回值安装到 JFormattedTextField 上。

返回：
限制编辑的 DocumentFilter

getNavigationFilter

protected NavigationFilter getNavigationFilter()
如果想要提供过滤器以限制用户可导航的位置，则应进行子类化和重写。install 会将返回值安装到 JFormattedTextField 上。

返回：
限制导航的 NavigationFilter

clone

protected Object clone()
                throws CloneNotSupportedException
复制 AbstractFormatter。返回的实例与 JFormattedTextField 无关联。

覆盖：
类 Object 中的 clone
返回：
AbstractFormatter 的副本
抛出：
CloneNotSupportedException - 如果对象的类不支持 Cloneable 接口，则重写 clone 方法的子类也会抛出此异常，以指示无法复制某个实例。
另请参见：
Cloneable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JFormattedTextField.AbstractFormatterFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JFormattedTextField.AbstractFormatterFactory

java.lang.Object
    继承者  javax.swing.JFormattedTextField.AbstractFormatterFactory
直接已知子类：
DefaultFormatterFactory
正在封闭类：
JFormattedTextField
public abstract static class JFormattedTextField.AbstractFormatterFactory
extends Object

JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。AbstractFormatterFactory 可根据 JFormattedTextField 的状态返回不同的 AbstractFormatter，也许在 JFormattedTextField 具有焦点和不具有焦点时即返回不同的 AbstractFormatter。

从以下版本开始：
1.4

构造方法摘要
JFormattedTextField.AbstractFormatterFactory()
方法摘要
abstract  JFormattedTextField.AbstractFormatter getFormatter(JFormattedTextField tf)
返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JFormattedTextField.AbstractFormatterFactory

public JFormattedTextField.AbstractFormatterFactory()
方法详细信息

getFormatter

public abstract JFormattedTextField.AbstractFormatter getFormatter(JFormattedTextField tf)
返回一个 AbstractFormatter，它对传入的 JFormattedTextField 进行格式化。

参数：
tf - 请求 AbstractFormatter 的 JFormattedTextField
返回：
处理格式化任务的 AbstractFormatter，null 返回值意味着 JFormattedTextField 的行为应该类似于普通的 JTextField
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JFrame.AccessibleJFrame (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JFrame.AccessibleJFrame

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Window.AccessibleAWTWindow
                    继承者  java.awt.Frame.AccessibleAWTFrame
                        继承者  javax.swing.JFrame.AccessibleJFrame
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
JFrame
protected class JFrame.AccessibleJFrame
extends Frame.AccessibleAWTFrame

此类实现对 JFrame 类的可访问性支持。它提供了适合 frame 用户界面元素的 Java Accessibility API 的实现。

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JFrame.AccessibleJFrame()
方法摘要
String | getAccessibleName() 获得此对象的可访问名称。
AccessibleStateSet | getAccessibleStateSet() 获得此对象的状态。
从类 java.awt.Frame.AccessibleAWTFrame 继承的方法
getAccessibleRole
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JFrame.AccessibleJFrame

protected JFrame.AccessibleJFrame()
方法详细信息

getAccessibleName

public String getAccessibleName()
获得此对象的可访问名称。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleName
返回：
该对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获得此对象的状态。

覆盖：
类 Frame.AccessibleAWTFrame 中的 getAccessibleStateSet
返回：
包含此对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JInternalFrame (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JInternalFrame

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JInternalFrame
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer, WindowConstants
public class JInternalFrame
extends JComponent
implements Accessible, WindowConstants, RootPaneContainer

提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。有关使用内部窗体的面向任务的文档和示例，请参见 The Java Tutorial 中的 How to Use Internal Frames 一节。

通常，可将 JInternalFrame 添加到 JDesktopPane 中。UI 将特定于外观的操作委托给由 JDesktopPane 维护的 DesktopManager 对象。

JInternalFrame 内容窗格是添加子组件的地方。为了方便地使用 add 方法及其变体，已经重写了 remove 和 setLayout，以在必要时将其转发到 contentPane。这意味着可以编写：

       internalFrame.add(child);
子级将被添加到 contentPane。内容窗格实际上由 JRootPane 的实例管理，它还管理 layoutPane、glassPane 和内部窗体的可选菜单栏。有关这些组件的完整描述，请参见 JRootPane 文档。有关添加、移除和设置 JInternalFrame 的 LayoutManager 的详情，请参阅 RootPaneContainer。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
InternalFrameEvent, JDesktopPane, DesktopManager, JInternalFrame.JDesktopIcon, JRootPane, RootPaneContainer

嵌套类摘要
protected class | JInternalFrame.AccessibleJInternalFrame 此类实现对 JInternalFrame 类的可访问性支持。
static class | JInternalFrame.JDesktopIcon 此组件表示 JInternalFrame 的图标化版本。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected boolean | closable 窗体可关闭。
static String | CONTENT_PANE_PROPERTY 绑定属性名。
protected JInternalFrame.JDesktopIcon | desktopIcon 此内部窗体图标化时所显示的图标。
static String | FRAME_ICON_PROPERTY 绑定属性名。
protected Icon | frameIcon 此内部窗体左上角显示的图标。
static String | GLASS_PANE_PROPERTY 绑定属性名。
protected boolean | iconable 可以“图标化”窗体（缩小并显示为图标图像）。
static String | IS_CLOSED_PROPERTY 约束属性名，指示该内部窗体已关闭。
static String | IS_ICON_PROPERTY 约束属性名，指示该内部窗体已图标化。
static String | IS_MAXIMUM_PROPERTY 约束属性名，指示该内部窗体已最大化。
static String | IS_SELECTED_PROPERTY 约束属性名，指示此窗体具有选定状态。
protected boolean | isClosed 窗体已关闭。
protected boolean | isIcon 窗体已图标化。
protected boolean | isMaximum 已将窗体扩展到其最大大小。
protected boolean | isSelected 当前已选中窗体。
static String | LAYERED_PANE_PROPERTY 绑定属性名。
protected boolean | maximizable 可将窗体扩展到桌面窗格的大小。
static String | MENU_BAR_PROPERTY 绑定属性名。
protected boolean | resizable 可以更改窗体的大小。
static String | ROOT_PANE_PROPERTY 绑定属性名。
protected JRootPane | rootPane JRootPane 实例，它管理此内部窗体的内容窗格和可选菜单栏以及玻璃窗格（glass pane）。
protected boolean | rootPaneCheckingEnabled 如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。
protected String | title 此内部窗体标题栏中所显示的标题。
static String | TITLE_PROPERTY 绑定属性名。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.WindowConstants 继承的字段
DISPOSE_ON_CLOSE, DO_NOTHING_ON_CLOSE, EXIT_ON_CLOSE, HIDE_ON_CLOSE
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JInternalFrame()
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、没有标题的 JInternalFrame。
JInternalFrame(String title)
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、具有指定标题的 JInternalFrame。
JInternalFrame(String title, boolean resizable)
创建不可关闭的、不可最大化的、不可图标化的，以及具有指定标题和可调整大小的 JInternalFrame。
JInternalFrame(String title, boolean resizable, boolean closable)
创建不可最大化的、不可图标化的，以及具有指定标题、可调整大小和可关闭的 JInternalFrame。
JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable)
创建不可图标化的，但具有指定标题、可调整大小、可关闭和可最大化的 JInternalFrame。
JInternalFrame(String title, boolean resizable, boolean closable, boolean maximizable, boolean iconifiable)
创建具有指定标题、可调整、可关闭、可最大化和可图标化的 JInternalFrame。
方法摘要
protected  void addImpl(Component comp, Object constraints, int index)
添加指定的子 Component。
 void addInternalFrameListener(InternalFrameListener l)
添加指定的侦听器，以从此内部窗体接收内部窗体事件。
protected  JRootPane createRootPane()
构造方法调用此方法来设置 JRootPane。
 void dispose()
使此内部窗体不可见、取消选定并关闭它。
 void doDefaultCloseAction()
激发 INTERNAL_FRAME_CLOSING 事件，然后执行内部窗体的默认 close 操作所指定的操作。
protected  void fireInternalFrameEvent(int id)
激发内部窗体事件。
 AccessibleContext getAccessibleContext()
获得与此 JInternalFrame 关联的 AccessibleContext。
 Container getContentPane()
返回此内部窗体的内容窗格。
 int getDefaultCloseOperation()
返回用户在此内部窗体上发起 "close" 时默认执行的操作。
 JInternalFrame.JDesktopIcon getDesktopIcon()
返回图标化此 JInternalFrame 时使用的 JDesktopIcon。
 JDesktopPane getDesktopPane()
在祖先层次结构中搜索 JDesktop 实例的便捷方法。
 Container getFocusCycleRootAncestor()
始终返回 null，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
 Component getFocusOwner()
如果此 JInternalFrame 处于激活状态，则返回具有焦点的子组件。
 Icon getFrameIcon()
返回要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
 Component getGlassPane()
返回此内部窗体的玻璃窗格。
 InternalFrameListener[] getInternalFrameListeners()
返回使用 addInternalFrameListener 添加到此 JInternalFrame 的所有 InternalFrameListener 的数组。
 JMenuBar getJMenuBar()
返回此 JInternalFrame 的当前 JMenuBar；如果尚未设置菜单栏，则返回 null。
 Cursor getLastCursor()
返回通过 setCursor 方法设置的最后一个 Cursor，它是不可调整大小的 Cursor。
 int getLayer()
获得此组件 layer 属性的便捷方法。
 JLayeredPane getLayeredPane()
返回此内部窗体的分层窗格。
 JMenuBar getMenuBar()
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。
 Component getMostRecentFocusOwner()
返回选定此 JInternalFrame 时，将接收焦点的 JInternalFrame 子组件。
 Rectangle getNormalBounds()
如果 JInternalFrame 未处于最大化状态，则返回 getBounds()；否则返回还原 JInternalFrame 后的边界。
 JRootPane getRootPane()
返回此内部窗体的 rootPane 对象。
 String getTitle()
返回 JInternalFrame 的标题。
 InternalFrameUI getUI()
返回呈现此组件的外观对象。
 String getUIClassID()
返回呈现此组件的外观类名。
 String getWarningString()
获取此内部窗体中显示的警告字符串。
 void hide()
 boolean isClosable()
返回是否可以通过某个用户操作关闭此 JInternalFrame。
 boolean isClosed()
返回此 JInternalFrame 当前是否已关闭。
 boolean isFocusCycleRoot()
始终返回 true，原因是所有 JInternalFrame 必须为焦点遍历循环的根。
 boolean isIcon()
返回 JInternalFrame 当前是否已图标化。
 boolean isIconifiable()
获取该 iconable 属性（默认情况下为 false）。
 boolean isMaximizable()
获取该 maximizable 属性的值。
 boolean isMaximum()
返回 JInternalFrame 当前是否已最大化。
 boolean isResizable()
返回是否可以通过某个用户操作调整 JInternalFrame 的大小。
protected  boolean isRootPaneCheckingEnabled()
返回是否将对 add 和 setLayout 的调用转发到 contentPane。
 boolean isSelected()
返回 JInternalFrame 当前是否为“选定的”或处于激活状态的窗体。
 void moveToBack()
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 -1 的便捷方法。
 void moveToFront()
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 0 的便捷方法。
 void pack()
使此 JInternalFrame 的子组件按其首选大小进行布局。
protected  void paintComponent(Graphics g)
重写此方法，以便在拖动内部窗体时允许进行优化的绘制。
protected  String paramString()
返回此 JInternalFrame 的字符串表示形式。
 void remove(Component comp)
从此容器中移除指定组件。
 void removeInternalFrameListener(InternalFrameListener l)
移除指定的内部窗体侦听器，不再接收此内部窗体发出的内部窗体事件。
 void reshape(int x, int y, int width, int height)
移动此组件并调整其大小。
 void restoreSubcomponentFocus()
请求内部窗体将焦点还原到具有焦点的最后一个子组件。
 void setClosable(boolean b)
设置是否可以通过某个用户操作关闭此 JInternalFrame。
 void setClosed(boolean b)
如果参数为 true，则关闭此内部窗体。
 void setContentPane(Container c)
设置此 JInternalFrame 的 contentPane 属性。
 void setCursor(Cursor cursor)
为指定的光标设置光标图像。
 void setDefaultCloseOperation(int operation)
设置用户在此内部窗体上发起 "close" 时默认执行的操作。
 void setDesktopIcon(JInternalFrame.JDesktopIcon d)
设置与此 JInternalFrame 关联的 JDesktopIcon。
 void setFocusCycleRoot(boolean focusCycleRoot)
不执行任何操作，原因是 JInternalFrame 必须始终为焦点遍历循环的根。
 void setFrameIcon(Icon icon)
设置要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。
 void setGlassPane(Component glass)
设置此 JInternalFrame 的 glassPane 属性。
 void setIcon(boolean b)
如果外观支持图标化，则对此内部窗体执行图标化或取消图标化。
 void setIconifiable(boolean b)
设置 iconable 属性，对于能够使 JInternalFrame 变成一个图标的用户而言，该属性必须为 true。
 void setJMenuBar(JMenuBar m)
设置此 JInternalFrame 的 menuBar 属性。
 void setLayer(int layer)
设置此组件 layer 属性的便捷方法。
 void setLayer(Integer layer)
设置此组件 layer 属性的便捷方法。
 void setLayeredPane(JLayeredPane layered)
设置此 JInternalFrame 的 layeredPane 属性。
 void setLayout(LayoutManager manager)
确保默认情况下无法设置此组件的布局。
 void setMaximizable(boolean b)
设置 maximizable 属性，该属性确定是否可以通过某个用户操作最大化此 JInternalFrame。
 void setMaximum(boolean b)
最大化并还原此内部窗体。
 void setMenuBar(JMenuBar m)
已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。
 void setNormalBounds(Rectangle r)
设置此内部窗体的正常边界，即此内部窗体从其最大化状态还原后的边界。
 void setResizable(boolean b)
设置是否可以通过某个用户操作调整 JInternalFrame 的大小。
protected  void setRootPane(JRootPane root)
设置此 JInternalFrame 的 rootPane 属性。
protected  void setRootPaneCheckingEnabled(boolean enabled)
设置是否将对 add 和 setLayout 的调用转发到 contentPane。
 void setSelected(boolean selected)
如果要显示内部窗体，则选定或取消选定该窗体。
 void setTitle(String title)
设置 JInternalFrame 的标题。
 void setUI(InternalFrameUI ui)
设置此 JInternalFrame 的 UI 委托。
 void show()
如果内部窗体不可见，则将该内部窗体置于前端，使其可见并尝试选定它。
 void toBack()
将此内部窗体发送至后台。
 void toFront()
将此内部窗体置于前端。
 void updateUI()
来自 UIManager 的通知，告知外观已更改。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

rootPane

protected JRootPane rootPane
JRootPane 实例，它管理此内部窗体的内容窗格和可选菜单栏以及玻璃窗格（glass pane）。

另请参见：
JRootPane, RootPaneContainer

rootPaneCheckingEnabled

protected boolean rootPaneCheckingEnabled
如果为 true，则将对 add 和 setLayout 的调用转发到 contentPane。初始设置为 false，但在构造 JInternalFrame 时将其设置为 true。

另请参见：
isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

closable

protected boolean closable
窗体可关闭。

isClosed

protected boolean isClosed
窗体已关闭。

maximizable

protected boolean maximizable
可将窗体扩展到桌面窗格的大小。

isMaximum

protected boolean isMaximum
已将窗体扩展到其最大大小。

另请参见：
maximizable

iconable

protected boolean iconable
可以“图标化”窗体（缩小并显示为图标图像）。

另请参见：
JInternalFrame.JDesktopIcon, setIconifiable(boolean)

isIcon

protected boolean isIcon
窗体已图标化。

另请参见：
isIcon()

resizable

protected boolean resizable
可以更改窗体的大小。

isSelected

protected boolean isSelected
当前已选中窗体。

frameIcon

protected Icon frameIcon
此内部窗体左上角显示的图标。

title

protected String title
此内部窗体标题栏中所显示的标题。

desktopIcon

protected JInternalFrame.JDesktopIcon desktopIcon
此内部窗体图标化时所显示的图标。

另请参见：
iconable

CONTENT_PANE_PROPERTY

public static final String CONTENT_PANE_PROPERTY
绑定属性名。

另请参见：
常量字段值

MENU_BAR_PROPERTY

public static final String MENU_BAR_PROPERTY
绑定属性名。

另请参见：
常量字段值

TITLE_PROPERTY

public static final String TITLE_PROPERTY
绑定属性名。

另请参见：
常量字段值

LAYERED_PANE_PROPERTY

public static final String LAYERED_PANE_PROPERTY
绑定属性名。

另请参见：
常量字段值

ROOT_PANE_PROPERTY

public static final String ROOT_PANE_PROPERTY
绑定属性名。

另请参见：
常量字段值

GLASS_PANE_PROPERTY

public static final String GLASS_PANE_PROPERTY
绑定属性名。

另请参见：
常量字段值

FRAME_ICON_PROPERTY

public static final String FRAME_ICON_PROPERTY
绑定属性名。

另请参见：
常量字段值

IS_SELECTED_PROPERTY

public static final String IS_SELECTED_PROPERTY
约束属性名，指示此窗体具有选定状态。

另请参见：
常量字段值

IS_CLOSED_PROPERTY

public static final String IS_CLOSED_PROPERTY
约束属性名，指示该内部窗体已关闭。

另请参见：
常量字段值

IS_MAXIMUM_PROPERTY

public static final String IS_MAXIMUM_PROPERTY
约束属性名，指示该内部窗体已最大化。

另请参见：
常量字段值

IS_ICON_PROPERTY

public static final String IS_ICON_PROPERTY
约束属性名，指示该内部窗体已图标化。

另请参见：
常量字段值
构造方法详细信息

JInternalFrame

public JInternalFrame()
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、没有标题的 JInternalFrame。

JInternalFrame

public JInternalFrame(String title)
创建不可调整大小的、不可关闭的、不可最大化的、不可图标化的、具有指定标题的 JInternalFrame。注意，传入 null title 会导致不确定的行为，并且可能导致异常。

参数：
title - 要在标题栏中显示的非 null String

JInternalFrame

public JInternalFrame(String title,
                      boolean resizable)
创建不可关闭的、不可最大化的、不可图标化的，以及具有指定标题和可调整大小的 JInternalFrame。

参数：
title - 标题栏中要显示的 String
resizable - 如果为 true，则可以调整内部窗体的大小

JInternalFrame

public JInternalFrame(String title,
                      boolean resizable,
                      boolean closable)
创建不可最大化的、不可图标化的，以及具有指定标题、可调整大小和可关闭的 JInternalFrame。

参数：
title - 标题栏中要显示的 String
resizable - 如果为 true，则可以调整内部窗体的大小
closable - 如果为 true，则可以关闭内部窗体

JInternalFrame

public JInternalFrame(String title,
                      boolean resizable,
                      boolean closable,
                      boolean maximizable)
创建不可图标化的，但具有指定标题、可调整大小、可关闭和可最大化的 JInternalFrame。

参数：
title - 标题栏中要显示的 String
resizable - 如果为 true，则可以调整内部窗体的大小
closable - 如果为 true，则可以关闭内部窗体
maximizable - 如果为 true，则可以最大化内部窗体

JInternalFrame

public JInternalFrame(String title,
                      boolean resizable,
                      boolean closable,
                      boolean maximizable,
                      boolean iconifiable)
创建具有指定标题、可调整、可关闭、可最大化和可图标化的 JInternalFrame。所有 JInternalFrame 构造方法都使用此构造方法。

参数：
title - 标题栏中要显示的 String
resizable - 如果为 true，则可以调整内部窗体的大小
closable - 如果为 true，则可以关闭内部窗体
maximizable - 如果为 true，则可以最大化内部窗体
iconifiable - 如果为 true，则可以图标化内部窗体
方法详细信息

createRootPane

protected JRootPane createRootPane()
构造方法调用此方法来设置 JRootPane。

返回：
新的 JRootPane
另请参见：
JRootPane

getUI

public InternalFrameUI getUI()
返回呈现此组件的外观对象。

返回：
呈现此组件的 InternalFrameUI 对象

setUI

public void setUI(InternalFrameUI ui)
设置此 JInternalFrame 的 UI 委托。

参数：
ui - UI 委托

updateUI

public void updateUI()
来自 UIManager 的通知，告知外观已更改。用 UIManager 的最新版本替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的外观类名。

覆盖：
类 JComponent 中的 getUIClassID
返回：
"InternalFrameUI" 字符串
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

isRootPaneCheckingEnabled

protected boolean isRootPaneCheckingEnabled()
返回是否将对 add 和 setLayout 的调用转发到 contentPane。

返回：
如果转发 add 和 setLayout，则返回 true；否则返回 false
另请参见：
addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

setRootPaneCheckingEnabled

protected void setRootPaneCheckingEnabled(boolean enabled)
设置是否将对 add 和 setLayout 的调用转发到 contentPane。

参数：
enabled - 如果转发 add 和 setLayout，则为 true；如果应直接在 JInternalFrame 上操作，则为 false。
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
添加指定的子 Component。重写此方法，从而有条件地将调用转发到 contentPane。默认情况下将子组件添加到 contentPane 而不是窗体中，有关详情，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要添加子组件的组件
constraints - 要遵守的约束条件
index - 索引
抛出：
IllegalArgumentException - 如果 index 无效
IllegalArgumentException - 如果将容器的父级添加到其本身
IllegalArgumentException - 如果向容器内添加窗口
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

remove

public void remove(Component comp)
从此容器中移除指定组件。如果 comp 不是 JInternalFrame 的子级，则将调用转发到 contentPane。

覆盖：
类 Container 中的 remove
参数：
comp - 要移除的组件
抛出：
NullPointerException - 如果 comp 为 null
另请参见：
Container.add(java.awt.Component), RootPaneContainer

setLayout

public void setLayout(LayoutManager manager)
确保默认情况下无法设置此组件的布局。重写此方法，从而有条件地将调用转发到 contentPane。有关更多信息，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 setLayout
参数：
manager - LayoutManager
另请参见：
setRootPaneCheckingEnabled(boolean)

getMenuBar

@Deprecated
public JMenuBar getMenuBar()
已过时。 从 Swing version 1.0.3 开始，由 getJMenuBar() 取代。

返回此 JInternalFrame 的当前 JMenuBar；如果尚未设置菜单栏，则返回 null。

返回：
当前的菜单栏；如果尚未设置菜单栏，则返回 null

getJMenuBar

public JMenuBar getJMenuBar()
返回此 JInternalFrame 的当前 JMenuBar；如果尚未设置菜单栏，则返回 null。

返回：
此内部窗体使用的 JMenuBar
另请参见：
setJMenuBar(javax.swing.JMenuBar)

setMenuBar

@Deprecated
public void setMenuBar(JMenuBar m)
已过时。 从 Swing version 1.0.3 开始，由 setJMenuBar(JMenuBar m) 取代。

设置此 JInternalFrame 的 menuBar 属性。

参数：
m - 此内部窗体中使用的 JMenuBar
另请参见：
getJMenuBar()

setJMenuBar

public void setJMenuBar(JMenuBar m)
设置此 JInternalFrame 的 menuBar 属性。

参数：
m - 此内部窗体中使用的 JMenuBar
另请参见：
getJMenuBar()

getContentPane

public Container getContentPane()
返回此内部窗体的内容窗格。

指定者：
接口 RootPaneContainer 中的 getContentPane
返回：
内容窗格
另请参见：
RootPaneContainer.setContentPane(java.awt.Container)

setContentPane

public void setContentPane(Container c)
设置此 JInternalFrame 的 contentPane 属性。

指定者：
接口 RootPaneContainer 中的 setContentPane
参数：
c - 此内部窗体的内容窗格
抛出：
IllegalComponentStateException - （运行时异常）如果 contentPane 参数为 null
另请参见：
RootPaneContainer.getContentPane()

getLayeredPane

public JLayeredPane getLayeredPane()
返回此内部窗体的分层窗格。

指定者：
接口 RootPaneContainer 中的 getLayeredPane
返回：
JLayeredPane 对象
另请参见：
RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

setLayeredPane

public void setLayeredPane(JLayeredPane layered)
设置此 JInternalFrame 的 layeredPane 属性。

指定者：
接口 RootPaneContainer 中的 setLayeredPane
参数：
layered - 此内部窗体的 JLayeredPane
抛出：
IllegalComponentStateException - （运行时异常）如果 layeredPane 参数为 null
另请参见：
RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

getGlassPane

public Component getGlassPane()
返回此内部窗体的玻璃窗格。

指定者：
接口 RootPaneContainer 中的 getGlassPane
返回：
glassPane
另请参见：
RootPaneContainer.setGlassPane(java.awt.Component)

setGlassPane

public void setGlassPane(Component glass)
设置此 JInternalFrame 的 glassPane 属性。

指定者：
接口 RootPaneContainer 中的 setGlassPane
参数：
glass - 此内部窗体的 glassPane
另请参见：
RootPaneContainer.getGlassPane()

getRootPane

public JRootPane getRootPane()
返回此内部窗体的 rootPane 对象。

指定者：
接口 RootPaneContainer 中的 getRootPane
覆盖：
类 JComponent 中的 getRootPane
返回：
rootPane 属性
另请参见：
RootPaneContainer.getRootPane()

setRootPane

protected void setRootPane(JRootPane root)
设置此 JInternalFrame 的 rootPane 属性。此方法由构造方法调用。

参数：
root - 新的 JRootPane 对象

setClosable

public void setClosable(boolean b)
设置是否可以通过某个用户操作关闭此 JInternalFrame。

参数：
b - boolean 值，其中 true 意味着可以关闭此内部窗体

isClosable

public boolean isClosable()
返回是否可以通过某个用户操作关闭此 JInternalFrame。

返回：
如果可以关闭此内部窗体，则返回 true

isClosed

public boolean isClosed()
返回此 JInternalFrame 当前是否已关闭。

返回：
如果此内部窗体已关闭，则返回 true；否则返回 false

setClosed

public void setClosed(boolean b)
               throws PropertyVetoException
如果参数为 true，则关闭此内部窗体。不要调用带有 false 参数的此方法；调用 setClosed(false) 的结果是不确定的。

如果已关闭内部窗体，则此方法不执行任何操作并立即返回。否则此方法通过激发 INTERNAL_FRAME_CLOSING 事件来开始执行。然后此方法将 closed 属性设置为 true，除非侦听器禁止属性更改。最后此方法通过使内部窗体不可见和不可选择，然后激发 INTERNAL_FRAME_CLOSED 事件来结束操作。

注：要想重用已关闭的内部窗体，您必须将其添加到容器中（即使从未将其从以前的容器中移除也是如此）。通常，此容器是以前包含该内部窗体的 JDesktopPane。

参数：
b - 必须为 true
抛出：
PropertyVetoException - 如果 JInternalFrame 禁止设置该属性
另请参见：
isClosed(), setDefaultCloseOperation(int), dispose(), InternalFrameEvent.INTERNAL_FRAME_CLOSING

setResizable

public void setResizable(boolean b)
设置是否可以通过某个用户操作调整 JInternalFrame 的大小。

参数：
b - boolean 值，其中 true 意味着可以调整此内部窗体的大小

isResizable

public boolean isResizable()
返回是否可以通过某个用户操作调整 JInternalFrame 的大小。

返回：
如果可以调整此内部窗体的大小，则返回 true；否则返回 false

setIconifiable

public void setIconifiable(boolean b)
设置 iconable 属性，对于能够使 JInternalFrame 变成一个图标的用户而言，该属性必须为 true。某些外观可能不实现图标化；它们将忽略此属性。

参数：
b - boolean 值，其中 true 意味着可以图标化此内部窗体

isIconifiable

public boolean isIconifiable()
获取该 iconable 属性（默认情况下为 false）。

返回：
iconable 属性的值。
另请参见：
setIconifiable(boolean)

isIcon

public boolean isIcon()
返回 JInternalFrame 当前是否已图标化。

返回：
如果此内部窗体已图标化，则返回 true

setIcon

public void setIcon(boolean b)
             throws PropertyVetoException
如果外观支持图标化，则对此内部窗体执行图标化或取消图标化。如果内部窗体的状态更改为图标化，则此方法激发 INTERNAL_FRAME_ICONIFIED 事件。如果该状态更改为取消图标化，则激发 INTERNAL_FRAME_DEICONIFIED 事件。

参数：
b - boolean 值，其中 true 意味着图标化此内部窗体，而 false 意味着取消其图标化
抛出：
PropertyVetoException - 如果 JInternalFrame 禁止设置该属性
另请参见：
InternalFrameEvent.INTERNAL_FRAME_ICONIFIED, InternalFrameEvent.INTERNAL_FRAME_DEICONIFIED

setMaximizable

public void setMaximizable(boolean b)
设置 maximizable 属性，该属性确定是否可以通过某个用户操作最大化此 JInternalFrame。某些外观可能不支持最大化内部窗体；它们会忽略此属性。

参数：
b - true 指示此窗体应该是可最大化的；false 指示其不应该是可最大化的

isMaximizable

public boolean isMaximizable()
获取该 maximizable 属性的值。

返回：
maximizable 属性的值
另请参见：
setMaximizable(boolean)

isMaximum

public boolean isMaximum()
返回 JInternalFrame 当前是否已最大化。

返回：
如果此内部窗体已最大化，则返回 true；否则返回 false

setMaximum

public void setMaximum(boolean b)
                throws PropertyVetoException
最大化并还原此内部窗体。将已最大化的窗体的大小调整为完全适合与 JInternalFrame 关联的 JDesktopPane 区域。将已还原的窗体的大小设置为 JInternalFrame 的实际大小。

参数：
b - boolean 值，其中 true 意味着最大化此内部窗体；false 意味着还原它
抛出：
PropertyVetoException - JInternalFrame 如果禁止设置该属性

getTitle

public String getTitle()
返回 JInternalFrame 的标题。

返回：
包含此内部窗体标题的 String
另请参见：
setTitle(java.lang.String)

setTitle

public void setTitle(String title)
设置 JInternalFrame 的标题。title 可能为 null 值。

参数：
title - 标题栏中要显示的 String
另请参见：
getTitle()

setSelected

public void setSelected(boolean selected)
                 throws PropertyVetoException
如果要显示内部窗体，则选定或取消选定该窗体。如果内部窗体是已选定的窗体，则 JInternalFrame 以不同的方式绘制其标题栏，向用户指示此内部窗体具有焦点。当此方法将内部窗体的状态从取消选定更改为选定时，它会激发 InternalFrameEvent.INTERNAL_FRAME_ACTIVATED 事件。如果将状态从选定更改为取消选定，则激发 InternalFrameEvent.INTERNAL_FRAME_DEACTIVATED 事件。

参数：
selected - boolean 值，其中 true 意味着此内部窗体应该成为选定的窗体（当前处于激活状态）；false 意味着此内部窗体应该成为取消选定的窗体
抛出：
PropertyVetoException - JInternalFrame 如果设置该属性
另请参见：
Component.isShowing(), InternalFrameEvent.INTERNAL_FRAME_ACTIVATED, InternalFrameEvent.INTERNAL_FRAME_DEACTIVATED

isSelected

public boolean isSelected()
返回 JInternalFrame 当前是否为“选定的”或处于激活状态的窗体。

返回：
如果此内部窗体当前为选定的（处于激活状态），则返回 true
另请参见：
setSelected(boolean)

setFrameIcon

public void setFrameIcon(Icon icon)
设置要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。此图像不是 desktopIcon 对象，desktopIcon 对象是图标化此内部窗体时在 JDesktop 中所显示的图像。 向此函数传入 null 是有效的，但在此情况下外观可选择适当的行为，如不显示图标，或者显示该外观的默认图标。

参数：
icon - 标题栏中要显示的 Icon
另请参见：
getFrameIcon()

getFrameIcon

public Icon getFrameIcon()
返回要在此内部窗体的标题栏中显示的图像（通常显示在左上角）。

返回：
标题栏中显示的 Icon
另请参见：
setFrameIcon(javax.swing.Icon)

moveToFront

public void moveToFront()
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 0 的便捷方法。

moveToBack

public void moveToBack()
如果此组件的父组件是 JLayeredPane，则将此组件移至位置 -1 的便捷方法。

getLastCursor

public Cursor getLastCursor()
返回通过 setCursor 方法设置的最后一个 Cursor，它是不可调整大小的 Cursor。

返回：
最后一个不可调整大小的 Cursor
从以下版本开始：
1.6

setCursor

public void setCursor(Cursor cursor)
为指定的光标设置光标图像。当此组件的 contains 方法为当前的光标位置返回 ture，并且此组件是可见的、可显示的并且已启用的，则显示此光标图像。设置 Container 的光标会导致在该容器的所有子组件内显示该光标，那些具有非 null 的光标除外。

如果 Java 平台实现和/或本机系统不支持更改鼠标光标形状，则该方法可能不会产生任何视觉效果。

覆盖：
类 Component 中的 setCursor
参数：
cursor - Cursor 类定义的常量之一；如果此参数为 null，则此组件继承其父级的光标
从以下版本开始：
1.6
另请参见：
Component.isEnabled(),
Component.isShowing(),
Component.getCursor(),
Component.contains(int, int),
Toolkit.createCustomCursor(java.awt.Image, java.awt.Point, java.lang.String),
Cursor

setLayer

public void setLayer(Integer layer)
设置此组件 layer 属性的便捷方法。

参数：
layer - 指定此窗体的桌面层的 Integer 对象
另请参见：
JLayeredPane

setLayer

public void setLayer(int layer)
设置此组件 layer 属性的便捷方法。对于 JLayeredPane 中预定义的 layer 值，应该使用 setLayer(Integer) 方法。使用 setLayer(int) 时，必须注意不要意外地与这些值冲突。

参数：
layer - 指定此内部窗体的桌面层的整数
从以下版本开始：
1.3
另请参见：
setLayer(Integer), JLayeredPane

getLayer

public int getLayer()
获得此组件 layer 属性的便捷方法。

返回：
指定此窗体的桌面层的 Integer 对象
另请参见：
JLayeredPane

getDesktopPane

public JDesktopPane getDesktopPane()
在祖先层次结构中搜索 JDesktop 实例的便捷方法。如果 JInternalFrame 未找到 JDesktop 实例，则搜索 desktopIcon 树。

返回：
此内部窗体所属于的 JDesktopPane；如果找不到，则为 null

setDesktopIcon

public void setDesktopIcon(JInternalFrame.JDesktopIcon d)
设置与此 JInternalFrame 关联的 JDesktopIcon。

参数：
d - 要在桌面上显示的 JDesktopIcon
另请参见：
getDesktopIcon()

getDesktopIcon

public JInternalFrame.JDesktopIcon getDesktopIcon()
返回图标化此 JInternalFrame 时使用的 JDesktopIcon。

返回：
在桌面上显示的 JDesktopIcon
另请参见：
setDesktopIcon(javax.swing.JInternalFrame.JDesktopIcon)

getNormalBounds

public Rectangle getNormalBounds()
如果 JInternalFrame 未处于最大化状态，则返回 getBounds()；否则返回还原 JInternalFrame 后的边界。

返回：
返回此窗体处于正常状态时，包含此窗体边界的 Rectangle
从以下版本开始：
1.3

setNormalBounds

public void setNormalBounds(Rectangle r)
设置此内部窗体的正常边界，即此内部窗体从其最大化状态还原后的边界。此方法仅由桌面管理器使用。

参数：
r - 此内部窗体应该还原为的边界
从以下版本开始：
1.3

getFocusOwner

public Component getFocusOwner()
如果此 JInternalFrame 处于激活状态，则返回具有焦点的子组件。否则返回 null。

返回：
具有焦点的组件，如果子组件都不具有焦点，则返回 null
从以下版本开始：
1.3

getMostRecentFocusOwner

public Component getMostRecentFocusOwner()
返回选定此 JInternalFrame 时，将接收焦点的 JInternalFrame 子组件。如果当前已选定此 JInternalFrame，则此方法返回与 getFocusOwner 方法相同的组件。如果尚未选定此 JInternalFrame ，则返回最近请求焦点的子组件。如果没有子组件请求过焦点，则返回此 JInternalFrame 的初始 focusable 组件。如果不存在这种子组件，则返回此 JInternalFrame 接收焦点的默认组件。

返回：
选定此 JInternalFrame 时将接收焦点的子组件
从以下版本开始：
1.4
另请参见：
getFocusOwner(), isSelected

restoreSubcomponentFocus

public void restoreSubcomponentFocus()
请求内部窗体将焦点还原到具有焦点的最后一个子组件。用户选定此内部窗体时（例如通过单击标题栏）由 UI 使用此方法。

从以下版本开始：
1.3

reshape

public void reshape(int x,
                    int y,
                    int width,
                    int height)
移动此组件并调整其大小。与其他组件不同，此实现还会强制进行重新布局，因此总是重新显示窗体装饰，例如标题栏。

覆盖：
类 JComponent 中的 reshape
参数：
x - 给出该组件新水平位置的整数，该位置从其容器的左边开始，以像素为单位
y - 给出该组件新垂直位置的整数，该位置从其容器的底边开始，以像素为单位
width - 给出该组件新宽度的整数，以像素为单位
height - 给出该组件新高度的整数，以像素为单位
另请参见：
Component.setBounds(int, int, int, int)

addInternalFrameListener

public void addInternalFrameListener(InternalFrameListener l)
添加指定的侦听器，以从此内部窗体接收内部窗体事件。

参数：
l - 内部窗体侦听器

removeInternalFrameListener

public void removeInternalFrameListener(InternalFrameListener l)
移除指定的内部窗体侦听器，不再接收此内部窗体发出的内部窗体事件。

参数：
l - 内部窗体侦听器

getInternalFrameListeners

public InternalFrameListener[] getInternalFrameListeners()
返回使用 addInternalFrameListener 添加到此 JInternalFrame 的所有 InternalFrameListener 的数组。

返回：
已添加的所有 InternalFrameListener，如果尚未添加侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addInternalFrameListener(javax.swing.event.InternalFrameListener)

fireInternalFrameEvent

protected void fireInternalFrameEvent(int id)
激发内部窗体事件。

参数：
id - 要激发的事件类型；为以下值之一：
  • InternalFrameEvent.INTERNAL_FRAME_OPENED
  • InternalFrameEvent.INTERNAL_FRAME_CLOSING
  • InternalFrameEvent.INTERNAL_FRAME_CLOSED
  • InternalFrameEvent.INTERNAL_FRAME_ICONIFIED
  • InternalFrameEvent.INTERNAL_FRAME_DEICONIFIED
  • InternalFrameEvent.INTERNAL_FRAME_ACTIVATED
  • InternalFrameEvent.INTERNAL_FRAME_DEACTIVATED
如果事件类型不是上述某个值，则不执行任何操作。

doDefaultCloseAction

public void doDefaultCloseAction()
激发 INTERNAL_FRAME_CLOSING 事件，然后执行内部窗体的默认 close 操作所指定的操作。此方法通常由外观实现的操作处理程序为该内部窗体的 close 按钮所调用。

从以下版本开始：
1.3
另请参见：
setDefaultCloseOperation(int), InternalFrameEvent.INTERNAL_FRAME_CLOSING

setDefaultCloseOperation

public void setDefaultCloseOperation(int operation)
设置用户在此内部窗体上发起 "close" 时默认执行的操作。可能的选项为：

DO_NOTHING_ON_CLOSE
不执行任何操作。这要求程序在已注册 InternalFrameListener 对象的 windowClosing 方法中处理该操作。
HIDE_ON_CLOSE
自动使该内部窗体不可见。
DISPOSE_ON_CLOSE
自动释放该内部窗体。

默认值是 DISPOSE_ON_CLOSE。执行指定的 close 操作前，该内部窗体激发 INTERNAL_FRAME_CLOSING 事件。

参数：
operation - 在 javax.swing.WindowConstants（由 JInternalFrame 所实现的接口）中定义的以下常量之一：DO_NOTHING_ON_CLOSE、HIDE_ON_CLOSE 或 DISPOSE_ON_CLOSE
另请参见：
addInternalFrameListener(javax.swing.event.InternalFrameListener),
getDefaultCloseOperation(),
JComponent.setVisible(boolean),
dispose(),
InternalFrameEvent.INTERNAL_FRAME_CLOSING

getDefaultCloseOperation

public int getDefaultCloseOperation()
返回用户在此内部窗体上发起 "close" 时默认执行的操作。

返回：
用户关闭内部窗体时所执行的操作
另请参见：
setDefaultCloseOperation(int)

pack

public void pack()
使此 JInternalFrame 的子组件按其首选大小进行布局。首先还原然后打包已图标化或最大化的内部窗体。如果无法还原内部窗体，则不更改其状态并且不对其进行打包。

另请参见：
Window.pack()

show

public void show()
如果内部窗体不可见，则将该内部窗体置于前端，使其可见并尝试选定它。首次使该内部窗体可见时，此方法还激发 INTERNAL_FRAME_OPENED 事件。如果内部窗体已经可见，则此方法不执行任何操作。调用此方法与调用 setVisible(true) 具有相同的效果。

覆盖：
类 Component 中的 show
另请参见：
moveToFront(), setSelected(boolean), InternalFrameEvent.INTERNAL_FRAME_OPENED, JComponent.setVisible(boolean)

hide

public void hide()
覆盖：
类 Component 中的 hide

dispose

public void dispose()
使此内部窗体不可见、取消选定并关闭它。如果还未关闭该窗体，则此方法激发 INTERNAL_FRAME_CLOSED 事件。调用此方法的结果与调用 setClosed(true) 类似，但是 dispose 总是成功地关闭内部窗体，并且不激发 INTERNAL_FRAME_CLOSING 事件。

另请参见：
InternalFrameEvent.INTERNAL_FRAME_CLOSED, JComponent.setVisible(boolean), setSelected(boolean), setClosed(boolean)

toFront

public void toFront()
将此内部窗体置于前端。将此内部窗体置于堆栈顺序的顶部，并且对其他可见的内部窗体进行相应的调整。

另请参见：
Window.toFront(), moveToFront()

toBack

public void toBack()
将此内部窗体发送至后台。将此内部窗体置于堆栈顺序的底部，并且对其他可见的内部窗体进行相应的调整。

另请参见：
Window.toBack(), moveToBack()

setFocusCycleRoot

public final void setFocusCycleRoot(boolean focusCycleRoot)
不执行任何操作，原因是 JInternalFrame 必须始终为焦点遍历循环的根。

覆盖：
类 Container 中的 setFocusCycleRoot
参数：
focusCycleRoot - 忽略此值
从以下版本开始：
1.4
另请参见：
isFocusCycleRoot(),
Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy),
Container.getFocusTraversalPolicy()

isFocusCycleRoot

public final boolean isFocusCycleRoot()
始终返回 true，原因是所有 JInternalFrame 必须为焦点遍历循环的根。

覆盖：
类 Container 中的 isFocusCycleRoot
返回：
true
从以下版本开始：
1.4
另请参见：
setFocusCycleRoot(boolean), Container.setFocusTraversalPolicy(java.awt.FocusTraversalPolicy), Container.getFocusTraversalPolicy()

getFocusCycleRootAncestor

public final Container getFocusCycleRootAncestor()
始终返回 null，原因是 JInternalFrame 必须始终为焦点遍历循环的根。

覆盖：
类 Component 中的 getFocusCycleRootAncestor
返回：
null
从以下版本开始：
1.4
另请参见：
Container.isFocusCycleRoot()

getWarningString

public final String getWarningString()
获取此内部窗体中显示的警告字符串。因为内部窗体始终是安全的（由于它完全包含在窗口中，而该窗口可能需要警告字符串），所以此方法始终返回 null。

返回：
null
另请参见：
Window.getWarningString()

paramString

protected String paramString()
返回此 JInternalFrame 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JInternalFrame 的字符串表示形式

paintComponent

protected void paintComponent(Graphics g)
重写此方法，以便在拖动内部窗体时允许进行优化的绘制。

覆盖：
类 JComponent 中的 paintComponent
参数：
g - 要保护的 Graphics 对象
另请参见：
JComponent.paint(java.awt.Graphics), ComponentUI

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得与此 JInternalFrame 关联的 AccessibleContext。对于内部窗体，AccessibleContext 采用 AccessibleJInternalFrame 对象的形式。如果有必要，创建一个新的 AccessibleJInternalFrame 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
AccessibleJInternalFrame，它用作此 JInternalFrame 的 AccessibleContext
另请参见：
JInternalFrame.AccessibleJInternalFrame
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JInternalFrame.AccessibleJInternalFrame (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JInternalFrame.AccessibleJInternalFrame

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JInternalFrame.AccessibleJInternalFrame
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
正在封闭类：
JInternalFrame
protected class JInternalFrame.AccessibleJInternalFrame
extends JComponent.AccessibleJComponent
implements AccessibleValue

此类实现对 JInternalFrame 类的可访问性支持。它提供了适合内部 frame 用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JInternalFrame.AccessibleJInternalFrame()
方法摘要
String | getAccessibleName() 获取此对象的可访问名称。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JInternalFrame.AccessibleJInternalFrame

protected JInternalFrame.AccessibleJInternalFrame()
方法详细信息

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleName
返回：
如果此对象没有名称，则返回该对象的本地化名称，可以为 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在实现此类的 Java Accessibility API 时，返回此对象，它负责代表它自己实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
以 Number 形式获取此对象的值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
该对象的值，如果此对象没有值，则可以为 null
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 true
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
以 Number 形式获取此对象的最小值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
对象的最小值；如果此对象没有最小值，则返回 null
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
以 Number 形式获取此对象的最大值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
对象的最大值；如果此对象没有最大值，则返回 null
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JInternalFrame.JDesktopIcon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JInternalFrame.JDesktopIcon

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JInternalFrame.JDesktopIcon
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
正在封闭类：
JInternalFrame
public static class JInternalFrame.JDesktopIcon
extends JComponent
implements Accessible

此组件表示 JInternalFrame 的图标化版本。Swing 应用程序不应使用此 API，因为随着其功能被移入 JInternalFrame，在以后的 Swing 版本中不会再出现此 API。此类只是公共的，所以 UI 对象可以显示桌面图标。如果应用程序要显示桌面图标，那么它应该创建一个 JInternalFrame 实例并将其图标化。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JInternalFrame.JDesktopIcon(JInternalFrame f)
为内部 frame 创建一个图标。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JDesktopIcon 关联的 AccessibleContext。
JDesktopPane | getDesktopPane() 询问该图标所属的 Desktop 对象的便捷方法。
JInternalFrame | getInternalFrame() 返回与此 DesktopIcon 关联的 JInternalFrame。
DesktopIconUI | getUI() 返回呈现此组件的外观对象。
String | getUIClassID() 返回呈现此组件的外观类名。
void | setInternalFrame(JInternalFrame f) 设置与此 DesktopIcon 关联的 JInternalFrame。
void | setUI(DesktopIconUI ui) 设置呈现此组件的外观对象。
void | updateUI() 来自 UIManager 的通知，告知外观已更改。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JInternalFrame.JDesktopIcon

public JInternalFrame.JDesktopIcon(JInternalFrame f)
为内部 frame 创建一个图标。

参数：
f - 为其创建图标的 JInternalFrame
方法详细信息

getUI

public DesktopIconUI getUI()
返回呈现此组件的外观对象。

返回：
呈现此组件的 DesktopIconUI 对象

setUI

public void setUI(DesktopIconUI ui)
设置呈现此组件的外观对象。

参数：
ui - DesktopIconUI 外观对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getInternalFrame

public JInternalFrame getInternalFrame()
返回与此 DesktopIcon 关联的 JInternalFrame。

返回：
与此图标关联的 JInternalFrame

setInternalFrame

public void setInternalFrame(JInternalFrame f)
设置与此 DesktopIcon 关联的 JInternalFrame。

参数：
f - 与此图标关联的 JInternalFrame

getDesktopPane

public JDesktopPane getDesktopPane()
询问该图标所属的 Desktop 对象的便捷方法。

返回：
包含此图标的内部 frame 的 JDesktopPane；如果未找到，则为 null

updateUI

public void updateUI()
来自 UIManager 的通知，告知外观已更改。使用来自 UIManager 的最新 UI 对象版本替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的外观类名。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "DesktopIconUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JDesktopIcon 关联的 AccessibleContext。对于桌面图标，AccessibleContext 采用 AccessibleJDesktopIcon 的形式。如有必要，可创建一个新的 AccessibleJDesktopIcon 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJDesktopIcon，它充当此 JDesktopIcon 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
正在封闭类：
JInternalFrame.JDesktopIcon
protected class JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon
extends JComponent.AccessibleJComponent
implements AccessibleValue

此类实现对 JInternalFrame.JDesktopIcon 类的可访问性支持。它提供适合桌面图标用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 以 Number 形式获取此对象的值。
Number | getMaximumAccessibleValue() 以 Number 形式获取此对象的最大值。
Number | getMinimumAccessibleValue() 以 Number 形式获取此对象的最小值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon

protected JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在实现此类的 Java Accessibility API 时，返回此对象，它负责代表它自己实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
以 Number 形式获取此对象的值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
该对象的值，如果此对象没有值，则可以为 null
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 true
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
以 Number 形式获取此对象的最小值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
对象的最小值；如果此对象没有最小值，则返回 null
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
以 Number 形式获取此对象的最大值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
对象的最大值；如果此对象没有最大值，则返回 null
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JLabel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JLabel

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLabel
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
直接已知子类：
BasicComboBoxRenderer, DefaultListCellRenderer, DefaultTableCellRenderer, DefaultTreeCellRenderer
public class JLabel
extends JComponent
implements SwingConstants, Accessible

用于短文本字符串或图像或二者的显示区。标签不对输入事件作出反应。因此，它无法获得键盘焦点。但是，标签可以为具有键盘替换功能却无法显示的邻近组件方便地显示其键盘替换功能。

JLabel 对象可以显示文本、图像或同时显示二者。可以通过设置垂直和水平对齐方式，指定标签显示区中标签内容在何处对齐。默认情况下，标签在其显示区内垂直居中对齐。默认情况下，只显示文本的标签是开始边对齐；而只显示图像的标签则水平居中对齐。

还可以指定文本相对于图像的位置。默认情况下，文本位于图像的结尾边上，文本和图像都垂直对齐。

根据标签的 ComponentOrientation 属性值确定其开始边和结尾边。目前，默认的 ComponentOrientation 设置将开始边映射到左边，将结尾边映射到右边。

最后，还可以使用 setIconTextGap 方法指定文本和图像之间应该出现多少像素。默认情况下为 4 个像素。

有关进一步的文档，请参阅 The Java Tutorial 中的 How to Use Labels 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JLabel.AccessibleJLabel
该类用于获得此对象的可访问性职责。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected  Component labelFor
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JLabel()
创建无图像并且其标题为空字符串的 JLabel。
JLabel(Icon image)
创建具有指定图像的 JLabel 实例。
JLabel(Icon image, int horizontalAlignment)
创建具有指定图像和水平对齐方式的 JLabel 实例。
JLabel(String text)
创建具有指定文本的 JLabel 实例。
JLabel(String text, Icon icon, int horizontalAlignment)
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。
JLabel(String text, int horizontalAlignment)
创建具有指定文本和水平对齐方式的 JLabel 实例。
方法摘要
protected int | checkHorizontalKey(int key, String message) 验证该键是否为 horizontalAlignment 属性的合法值。
protected int | checkVerticalKey(int key, String message) 验证该键是否为 verticalAlignment 或 verticalTextPosition 属性的合法值。
AccessibleContext | getAccessibleContext() 获得此对象的 AccessibleContext。
Icon | getDisabledIcon() 返回该标签被禁用时所使用的图标。
int | getDisplayedMnemonic() 返回指示助记符键的键代码。
int | getDisplayedMnemonicIndex() 以索引的形式返回字符，外观应提供该字符的装饰以表示助记符。
int | getHorizontalAlignment() 返回标签内容沿 X 轴的对齐方式。
int | getHorizontalTextPosition() 返回标签的文本相对其图像的水平位置。
Icon | getIcon() 返回该标签显示的图形图像（字形、图标）。
int | getIconTextGap() 返回此标签中显示的文本和图标之间的间隔量。
Component | getLabelFor() 获取要添加标签的组件。
String | getText() 返回该标签所显示的文本字符串。
LabelUI | getUI() 返回呈现此组件的 L&F 对象。
String | getUIClassID() 返回一个指定 L&F 类名称的字符串，该类呈现此组件。
int | getVerticalAlignment() 返回标签内容沿 Y 轴的对齐方式。
int | getVerticalTextPosition() 返回标签的文本相对其图像的垂直位置。
boolean | imageUpdate(Image img, int infoflags, int x, int y, int w, int h) 如果当前图标的图像不等于传入的图像 img，则重写此方法以返回 false。
protected String | paramString() 返回此 JLabel 的字符串表示形式。
void | setDisabledIcon(Icon disabledIcon) 设置如果此 JLabel 是“禁用的”(JLabel.setEnabled(false))，则要显示的图标。
void | setDisplayedMnemonic(char aChar) 指定 displayedMnemonic 为一个 char 值。
void | setDisplayedMnemonic(int key) 指定一个指示助记符键的键代码。
void | setDisplayedMnemonicIndex(int index) 关于应该装饰文本中的哪个字符以表示助记符，为外观提供一个提示。
void | setHorizontalAlignment(int alignment) 设置标签内容沿 X 轴的对齐方式。
void | setHorizontalTextPosition(int textPosition) 设置标签的文本相对其图像的水平位置。
void | setIcon(Icon icon) 定义此组件将要显示的图标。
void | setIconTextGap(int iconTextGap) 如果同时设置了图标和文本属性，则此属性定义它们之间的间隔。
void | setLabelFor(Component c) 设置要添加标签的组件。
void | setText(String text) 定义此组件将要显示的单行文本。
void | setUI(LabelUI ui) 设置呈现此组件的 L&F 对象。
void | setVerticalAlignment(int alignment) 设置标签内容沿 Y 轴的对齐方式。
void | setVerticalTextPosition(int textPosition) 设置标签的文本相对其图像的垂直位置。
void | updateUI() 将 UI 属性重置为当前外观的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

labelFor

protected Component labelFor
构造方法详细信息

JLabel

public JLabel(String text,
              Icon icon,
              int horizontalAlignment)
创建具有指定文本、图像和水平对齐方式的 JLabel 实例。该标签在其显示区内垂直居中对齐。文本位于图像的结尾边上。

参数：
text - 由标签显示的文本。
icon - 由标签显示的图像。
horizontalAlignment - SwingConstants 中定义的以下常量之一：LEFT、CENTER、RIGHT、LEADING 或 TRAILING。

JLabel

public JLabel(String text,
              int horizontalAlignment)
创建具有指定文本和水平对齐方式的 JLabel 实例。该标签在其显示区内垂直居中对齐。

参数：
text - 由标签显示的文本。
horizontalAlignment - 在 SwingConstants 中定义的以下常量之一：LEFT、CENTER、RIGHT、LEADING 或 TRAILING。

JLabel

public JLabel(String text)
创建具有指定文本的 JLabel 实例。该标签与其显示区的开始边对齐，并垂直居中。

参数：
text - 由标签显示的文本。

JLabel

public JLabel(Icon image,
              int horizontalAlignment)
创建具有指定图像和水平对齐方式的 JLabel 实例。该标签在其显示区内垂直居中对齐。

参数：
image - 由标签显示的图像。
horizontalAlignment - 在 SwingConstants 中定义的以下常量之一：LEFT、CENTER、RIGHT、LEADING 或 TRAILING。

JLabel

public JLabel(Icon image)
创建具有指定图像的 JLabel 实例。该标签在其显示区内垂直和水平居中对齐。

参数：
image - 由标签显示的图像。

JLabel

public JLabel()
创建无图像并且其标题为空字符串的 JLabel。该标签在其显示区内垂直居中对齐。一旦设置了标签的内容，该内容就会显示在标签显示区的开始边上。

方法详细信息

getUI

public LabelUI getUI()
返回呈现此组件的 L&F 对象。

返回：
LabelUI 对象

setUI

public void setUI(LabelUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - LabelUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
将 UI 属性重置为当前外观的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回一个指定 L&F 类名称的字符串，该类呈现此组件。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "LabelUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getText

public String getText()
返回该标签所显示的文本字符串。

返回：
一个 String
另请参见：
setText(java.lang.String)

setText

public void setText(String text)
定义此组件将要显示的单行文本。如果 text 值为 null 或空字符串，则什么也不显示。

此属性的默认值为 null。

这是一个 JavaBeans 绑定属性。

另请参见：
setVerticalTextPosition(int), setHorizontalTextPosition(int), setIcon(javax.swing.Icon)

getIcon

public Icon getIcon()
返回该标签显示的图形图像（字形、图标）。

返回：
一个 Icon
另请参见：
setIcon(javax.swing.Icon)

setIcon

public void setIcon(Icon icon)
定义此组件将要显示的图标。如果 icon 值为 null，则什么也不显示。

此属性的默认值为 null。

这是一个 JavaBeans 绑定属性。

另请参见：
setVerticalTextPosition(int), setHorizontalTextPosition(int), getIcon()

getDisabledIcon

public Icon getDisabledIcon()
返回该标签被禁用时所使用的图标。如果尚未设置禁用图标，则此方法将转发对外观的调用，以构造一个合适的禁用图标。

某些外观可能无法呈现禁用图标，在此情况下，外观将忽略此图标。

返回：
disabledIcon 属性
另请参见：
setDisabledIcon(javax.swing.Icon), LookAndFeel.getDisabledIcon(javax.swing.JComponent, javax.swing.Icon), ImageIcon

setDisabledIcon

public void setDisabledIcon(Icon disabledIcon)
设置如果此 JLabel 是“禁用的”(JLabel.setEnabled(false))，则要显示的图标。

此属性的默认值为 null。

参数：
disabledIcon - 组件禁用时要显示的图标
另请参见：
getDisabledIcon(), JComponent.setEnabled(boolean)

setDisplayedMnemonic

public void setDisplayedMnemonic(int key)
指定一个指示助记符键的键代码。当标签是一个较大组件的一部分时使用此属性。如果标签的 labelFor 属性不为 null，则助记符被激活时，标签将调用 labelFor 属性所指定组件的 requestFocus 方法。

另请参见：
getLabelFor(), setLabelFor(java.awt.Component)

setDisplayedMnemonic

public void setDisplayedMnemonic(char aChar)
指定 displayedMnemonic 为一个 char 值。

参数：
aChar - 指定要显示的助记符的 char
另请参见：
setDisplayedMnemonic(int)

getDisplayedMnemonic

public int getDisplayedMnemonic()
返回指示助记符键的键代码。当标签是一个较大组件的一部分时使用此属性。如果标签的 labelFor 属性不为 null，则助记符被激活时，标签将调用 labelFor 属性所指定组件的 requestFocus 方法。

返回：
用于助记符键的 int 值
另请参见：
getLabelFor(), setLabelFor(java.awt.Component)

setDisplayedMnemonicIndex

public void setDisplayedMnemonicIndex(int index)
                               throws IllegalArgumentException
关于应该装饰文本中的哪个字符以表示助记符，为外观提供一个提示。并非所有的外观都支持此功能。值 -1 指示没有助记符（字符串中不包含该助记符），或者开发人员不希望显示该助记符。

此值随着与助记符相关属性的变化（如助记符本身、文本……）而得到更新。只有不希望对默认字符加下划线时，才必须调用此方法。例如，如果文本为 'Save As'，助记符为 'a'，而您希望装饰 'A'，使文本显示为 'Save As'，那么您必须在调用 setDisplayedMnemonic(KeyEvent.VK_A) 之后调用 setDisplayedMnemonicIndex(5)。

参数：
index - 要加下划线的 String 中的索引
抛出：
IllegalArgumentException - 在 index >= 文本长度或< -1 时抛出
从以下版本开始：
1.4

getDisplayedMnemonicIndex

public int getDisplayedMnemonicIndex()
以索引的形式返回字符，外观应提供该字符的装饰以表示助记符。

返回：
表示助记符的索引
从以下版本开始：
1.4
另请参见：
setDisplayedMnemonicIndex(int)

checkHorizontalKey

protected int checkHorizontalKey(int key,
                                 String message)
验证该键是否为 horizontalAlignment 属性的合法值。

参数：
key - 要检查的属性值
message - IllegalArgumentException 详细消息
抛出：
IllegalArgumentException - 如果 key 不是 LEFT、CENTER、RIGHT、LEADING 或 TRAILING。
另请参见：
setHorizontalTextPosition(int), setHorizontalAlignment(int)

checkVerticalKey

protected int checkVerticalKey(int key,
                               String message)
验证该键是否为 verticalAlignment 或 verticalTextPosition 属性的合法值。

参数：
key - 要检查的属性值
message - IllegalArgumentException 详细消息
抛出：
IllegalArgumentException - 如果 key 不是 TOP、CENTER 或 BOTTOM。
另请参见：
setVerticalAlignment(int), setVerticalTextPosition(int)

getIconTextGap

public int getIconTextGap()
返回此标签中显示的文本和图标之间的间隔量。

返回：
等于文本和图标之间像素数的 int 值。
另请参见：
setIconTextGap(int)

setIconTextGap

public void setIconTextGap(int iconTextGap)
如果同时设置了图标和文本属性，则此属性定义它们之间的间隔。

此属性的默认值为 4 个像素。

这是一个 JavaBeans 绑定属性。

另请参见：
getIconTextGap()

getVerticalAlignment

public int getVerticalAlignment()
返回标签内容沿 Y 轴的对齐方式。

返回：
verticalAlignment 属性的值，为 SwingConstants 中定义的以下常量之一：TOP、CENTER 或 BOTTOM。
另请参见：
SwingConstants, setVerticalAlignment(int)

setVerticalAlignment

public void setVerticalAlignment(int alignment)
设置标签内容沿 Y 轴的对齐方式。

此属性的默认值为 CENTER。

参数：
alignment - SwingConstants 中定义的以下常量之一：TOP、CENTER（默认）或 BOTTOM。
另请参见：
SwingConstants, getVerticalAlignment()

getHorizontalAlignment

public int getHorizontalAlignment()
返回标签内容沿 X 轴的对齐方式。

返回：
horizontalAlignment 属性的值，为 SwingConstants 中定义的以下常量之一：LEFT、CENTER、RIGHT、LEADING 或 TRAILING。
另请参见：
setHorizontalAlignment(int), SwingConstants

setHorizontalAlignment

public void setHorizontalAlignment(int alignment)
设置标签内容沿 X 轴的对齐方式。

这是一个 JavaBeans 绑定属性。

参数：
alignment - SwingConstants 中定义的以下常量之一：LEFT、CENTER（只显示图像的标签的默认值）、RIGHT、LEADING（只显示文本的标签的默认值）或 TRAILING。
另请参见：
SwingConstants, getHorizontalAlignment()

getVerticalTextPosition

public int getVerticalTextPosition()
返回标签的文本相对其图像的垂直位置。

返回：
SwingConstants 中定义的以下常量之一：TOP、CENTER 或 BOTTOM。
另请参见：
setVerticalTextPosition(int), SwingConstants

setVerticalTextPosition

public void setVerticalTextPosition(int textPosition)
设置标签的文本相对其图像的垂直位置。

此属性的默认值为 CENTER。

这是一个 JavaBeans 绑定属性。

参数：
textPosition - SwingConstants 中定义的以下常量之一：TOP、CENTER（默认）或 BOTTOM。
另请参见：
SwingConstants, getVerticalTextPosition()

getHorizontalTextPosition

public int getHorizontalTextPosition()
返回标签的文本相对其图像的水平位置。

返回：
SwingConstants 中定义的以下常量之一：LEFT、CENTER、RIGHT、LEADING 或 TRAILING。
另请参见：
SwingConstants

setHorizontalTextPosition

public void setHorizontalTextPosition(int textPosition)
设置标签的文本相对其图像的水平位置。

参数：
textPosition - SwingConstants 中定义的以下常量之一：LEFT、CENTER、RIGHT、LEADING 或 TRAILING（默认）。
抛出：
IllegalArgumentException
另请参见：
SwingConstants

imageUpdate

public boolean imageUpdate(Image img,
                           int infoflags,
                           int x,
                           int y,
                           int w,
                           int h)
如果当前图标的图像不等于传入的图像 img，则重写此方法以返回 false。

指定者：
接口 ImageObserver 中的 imageUpdate
覆盖：
类 Component 中的 imageUpdate
参数：
img - 正观察的图像
infoflags - 有关更多信息，请参阅 imageUpdate
x - x 坐标
y - y 坐标
w - 宽度
h - 高度
返回：
如果 infoflags 表明已完全加载了图像，则返回 false；否则返回 true。
另请参见：
ImageObserver, Component.imageUpdate(java.awt.Image, int, int, int, int, int)

paramString

protected String paramString()
返回此 JLabel 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JLabel 的字符串表示形式。

getLabelFor

public Component getLabelFor()
获取要添加标签的组件。

返回：
要添加标签的 Component。如果无法为 Component 添加标签，则返回值可以为 null。如果设置了 displayedMnemonic 和 labelFor 属性，则助记符被激活时，标签将调用 labelFor 属性所指定组件的 requestFocus 方法。
另请参见：
getDisplayedMnemonic(), setDisplayedMnemonic(int)

setLabelFor

public void setLabelFor(Component c)
设置要添加标签的组件。如果无法为 Component 添加标签，则返回值可以为 null。如果设置了 displayedMnemonic 和 labelFor 属性，则助记符被激活时，标签将调用 labelFor 属性所指定组件的 requestFocus 方法。

参数：
c - 要添加此标签的 Component，如果该标签不是组件的标签，则为 null
另请参见：
getDisplayedMnemonic(), setDisplayedMnemonic(int)

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得此对象的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
此对象的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JLabel.AccessibleJLabel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JLabel.AccessibleJLabel

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JLabel.AccessibleJLabel
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleText
正在封闭类：
JLabel
protected class JLabel.AccessibleJLabel
extends JComponent.AccessibleJComponent
implements AccessibleText, AccessibleExtendedComponent

该类用于获得此对象的可访问性职责。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JLabel.AccessibleJLabel()
方法摘要
AccessibleIcon[] | getAccessibleIcon() 获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。
AccessibleKeyBinding | getAccessibleKeyBinding() 返回与此对象关联的键绑定
String | getAccessibleName() 获取此对象的可访问名称。
AccessibleRelationSet | getAccessibleRelationSet() 获取与此对象关联的 AccessibleRelationSet（如果存在）。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
String | getAfterIndex(int part, int index) 返回给定索引后的 String。
String | getAtIndex(int part, int index) 返回给定索引处的 String。
String | getBeforeIndex(int part, int index) 返回给定索引前的 String。
int | getCaretPosition() 返回从 0 开始的插入符号偏移量。
AttributeSet | getCharacterAttribute(int i) 返回给定索引处给定字符的 AttributeSet
Rectangle | getCharacterBounds(int i) 确定给定字符串索引处字符的边界框。
int | getCharCount() 返回字符（有效索引）数。
int | getIndexAtPoint(Point p) 以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
String | getSelectedText() 返回选定的部分文本。
int | getSelectionEnd() 返回选定文本中的结尾偏移量。
int | getSelectionStart() 返回选定文本中的开始偏移量。
String | getTitledBorderText() 返回有标题边框的文本
String | getToolTipText() 返回工具提示文本
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleStateSet, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JLabel.AccessibleJLabel

protected JLabel.AccessibleJLabel()
方法详细信息

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleName
返回：
对象的本地化名称，如果此对象没有名称，则可以为 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleIcon

public AccessibleIcon[] getAccessibleIcon()
获取与此对象关联的 AccessibleIcon（如果存在一个或多个）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleIcon
返回：
如果受对象支持，则返回一个 AccessibleIcon 数组；否则返回 null
从以下版本开始：
1.3
另请参见：
AccessibleIcon

getAccessibleRelationSet

public AccessibleRelationSet getAccessibleRelationSet()
获取与此对象关联的 AccessibleRelationSet（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleRelationSet
返回：
如果受对象支持，则返回 AccessibleRelationSet；否则返回 null
从以下版本开始：
1.3
另请参见：
AccessibleRelation

getAccessibleText

public AccessibleText getAccessibleText()
从类 AccessibleContext 复制的描述
获取与在显示器上显示文本的此对象关联的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getIndexAtPoint

public int getIndexAtPoint(Point p)
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。如果 point 无效，则此方法返回 -1。

指定者：
接口 AccessibleText 中的 getIndexAtPoint
参数：
p - 本地坐标中的
返回：
点 p 处字符从 0 开始的索引；如果 Point 无效，则返回 -1。
从以下版本开始：
1.3

getCharacterBounds

public Rectangle getCharacterBounds(int i)
确定给定字符串索引处字符的边界框。以本地坐标形式返回边界框。如果索引无效，则返回一个空的矩形。

指定者：
接口 AccessibleText 中的 getCharacterBounds
参数：
i - String 中的索引
返回：
返回字符边界框的屏幕坐标，如果索引无效，则返回一个空矩形。
从以下版本开始：
1.3

getCharCount

public int getCharCount()
返回字符（有效索引）数。

指定者：
接口 AccessibleText 中的 getCharCount
返回：
字符数
从以下版本开始：
1.3

getCaretPosition

public int getCaretPosition()
返回从 0 开始的插入符号偏移量。 注：这表示插入符号的右边与偏移量（插入符号在两个字符之间）有相同的索引值。

指定者：
接口 AccessibleText 中的 getCaretPosition
返回：
从 0 开始的插入符号偏移量。
从以下版本开始：
1.3

getAtIndex

public String getAtIndex(int part,
                         int index)
返回给定索引处的 String。

指定者：
接口 AccessibleText 中的 getAtIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该 index >= 0
返回：
字母、单词或句子，对于无效索引或无效 part，则返回 null
从以下版本开始：
1.3

getAfterIndex

public String getAfterIndex(int part,
                            int index)
返回给定索引后的 String。

指定者：
接口 AccessibleText 中的 getAfterIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该 index >= 0
返回：
字母、单词或句子，对于无效索引或无效 part，则返回 null
从以下版本开始：
1.3

getBeforeIndex

public String getBeforeIndex(int part,
                             int index)
返回给定索引前的 String。

指定者：
接口 AccessibleText 中的 getBeforeIndex
参数：
part - 要检索的 AccessibleText.CHARACTER、AccessibleText.WORD 或 AccessibleText.SENTENCE
index - 文本中的索引，该 index >= 0
返回：
字母、单词或句子，对于无效索引或无效 part，则返回 null
从以下版本开始：
1.3

getCharacterAttribute

public AttributeSet getCharacterAttribute(int i)
返回给定索引处给定字符的 AttributeSet

指定者：
接口 AccessibleText 中的 getCharacterAttribute
参数：
i - 从 0 开始的文本索引
返回：
字符的 AttributeSet
从以下版本开始：
1.3

getSelectionStart

public int getSelectionStart()
返回选定文本中的开始偏移量。如果没有选定，但有一个插入符号，则开始和结尾偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionStart
返回：
所选定文本开始处的索引
从以下版本开始：
1.3

getSelectionEnd

public int getSelectionEnd()
返回选定文本中的结尾偏移量。如果没有选定，但有一个插入符号，则开始和结尾偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionEnd
返回：
所选定文本结尾的索引
从以下版本开始：
1.3

getSelectedText

public String getSelectedText()
返回选定的部分文本。

指定者：
接口 AccessibleText 中的 getSelectedText
返回：
选定文本的 String 部分
从以下版本开始：
1.3

getToolTipText

public String getToolTipText()
返回工具提示文本

指定者：
接口 AccessibleExtendedComponent 中的 getToolTipText
覆盖：
类 JComponent.AccessibleJComponent 中的 getToolTipText
返回：
对象的工具提示文本（如果支持）；否则返回 null
从以下版本开始：
1.4

getTitledBorderText

public String getTitledBorderText()
返回有标题边框的文本

指定者：
接口 AccessibleExtendedComponent 中的 getTitledBorderText
覆盖：
类 JComponent.AccessibleJComponent 中的 getTitledBorderText
返回：
对象的有标题边框文本（如果支持）；否则返回 null
从以下版本开始：
1.4

getAccessibleKeyBinding

public AccessibleKeyBinding getAccessibleKeyBinding()
返回与此对象关联的键绑定

指定者：
接口 AccessibleExtendedComponent 中的 getAccessibleKeyBinding
覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleKeyBinding
返回：
对象的键绑定（如果支持）；否则返回 null
从以下版本开始：
1.4
另请参见：
AccessibleKeyBinding
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JLayeredPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JLayeredPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JLayeredPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
JDesktopPane
public class JLayeredPane
extends JComponent
implements Accessible

JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。Integer 对象指定容器中每个组件的深度，其中编号较高的组件位于其他组件之上。有关面向任务的文档和使用分层窗格的示例，请参阅 The Java Tutorial 中的 How to Use a Layered Pane 一节。

以下文本是对此图像的描述。

为方便起见，JLayeredPane 将该深度范围分成几个不同的层。将组件放入相应的层，这样更容易确保组件正确地重叠，而不必担心为具体的深度指定编号：
DEFAULT_LAYER
大多数组件位于的标准层。这是最底层。
PALETTE_LAYER
调色板层位于默认层之上。它们对于浮动工具栏和调色板很有用，因此可以位于其他组件之上。
MODAL_LAYER
该层用于模式对话框。它们将出现在容器中所有工具栏、调色板或标准组件的上面。
POPUP_LAYER
弹出层显示在对话框的上面。这样，与组合框、工具提示和其他帮助文本关联的弹出式窗口将出现在组件、调色板或生成它们的对话框之上。
DRAG_LAYER
拖动一个组件时，将该组件重分配到拖动层可确保将其定位在容器中的其他所有组件之上。完成拖动后，可将该组件重分配到其正常层。
可以使用 JLayeredPane 的方法 moveToFront(Component)、moveToBack(Component) 和 setPosition 在组件所在层中对其进行重定位。还可以使用 setLayer 方法更改该组件的当前层。

详细信息

JLayeredPane 以类似 Container 的方式管理其子级列表，但允许在其内部定义多个层。对同一层中子级的管理就像普通的 Container 对象一样，但添加的功能是，当子组件重叠时，高层中的子组件显示在低层中的子组件之上。

每一层都是一个不同的整数。可以在调用 add 的过程中通过传递 Integer 对象，从而在 Component 上设置 layer 属性。
例如：

     layeredPane.add(child, JLayeredPane.DEFAULT_LAYER);
或者
layeredPane.add(child, new Integer(10));
还可以通过在 JLayeredPane 上进行如下调用在 Component 上设置 layer 属性:
     layeredPaneParent.setLayer(child, 10)
JLayeredPane 是该 Component 的父组件。应该将子组件添加到父组件之前 设置 layer 属性。

编号较高的层显示在编号较低的层之上。因此，对于每个组件，使用其层编号和字母即可，有代表性的列表顺序如下所示：

       5a, 5b, 5c, 2a, 2b, 2c, 1a
其中最左边的组件最接近显示区的顶部。

可以通过调用 moveToFront 或 moveToBack 将组件移入到其所在层的顶部或底部位置。

还可以直接指定某层中组件的位置。有效的位置范围是从 0 到该层中组件数减一所得的值。值 -1 指示最底层位置。值 0 指示最顶层位置。与层的编号不同，较高的位置值显示在较低 处。

注： 此序列（通过 java.awt.Container 定义）与层的编号序列相反。可是通常使用的是 moveToFront、moveToBack 和 setLayer 方法。
以下是使用方法 add(Component, layer, position) 的一些示例：调用 add(5x, 5, -1) 得到：
       5a, 5b, 5c, 5x, 2a, 2b, 2c, 1a
调用 add(5z, 5, 2) 得到：
       5a, 5b, 5z, 5c, 5x, 2a, 2b, 2c, 1a
调用 add(3a, 3, 7) 得到：
       5a, 5b, 5z, 5c, 5x, 3a, 2a, 2b, 2c, 1a
使用正常的 paint/event 机制会使 1a 出现在底部，5a 出现在所有其他组件之上。

注： 这些层只是一个逻辑构造，LayoutManager 将影响此容器的所有子组件，而不管其层设置如何。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JLayeredPane.AccessibleJLayeredPane
此类实现对 JLayeredPane 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static Integer | DEFAULT_LAYER 定义 Default 层的便捷对象。
static Integer | DRAG_LAYER 定义 Drag 层的便捷对象。
static Integer | FRAME_CONTENT_LAYER 定义 Frame Content 层的便捷对象。
static String | LAYER_PROPERTY 绑定属性
static Integer | MODAL_LAYER 定义 Modal 层的便捷对象。
static Integer | PALETTE_LAYER 定义 Palette 层的便捷对象。
static Integer | POPUP_LAYER 定义 Popup 层的便捷对象。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JLayeredPane()
创建新的 JLayeredPane
方法摘要
protected void | addImpl(Component comp, Object constraints, int index) 将指定组件添加到此容器的指定索引所在的位置上。
AccessibleContext | getAccessibleContext() 获得与此 JLayeredPane 关联的 AccessibleContext。
int | getComponentCountInLayer(int layer) 返回指定层中当前的子组件数。
Component[] | getComponentsInLayer(int layer) 返回指定层中组件的数组。
protected Hashtable<Component,Integer> | getComponentToLayer() 返回将组件映射到层的哈希表。
int | getIndexOf(Component c) 返回指定 Component 的索引。
int | getLayer(Component c) 返回指定 Component 的 layer 属性。
static int | getLayer(JComponent c) 获得 JComponent 的 layer 属性，此方法不会产生与 setLayer() 类似的副作用（绘制、添加/移除等）。
static JLayeredPane | getLayeredPaneAbove(Component c) 一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。
protected Integer | getObjectForLayer(int layer) 返回与指定层关联的 Integer 对象。
int | getPosition(Component c) 获得该组件在其所在层中的相对位置。
int | highestLayer() 返回所有当前子组件的最高层值。
protected int | insertIndexForLayer(int layer, int position) 一个根据层和位置要求确定插入新子组件的正确位置的基本方法。
boolean | isOptimizedDrawingEnabled() 如果窗格中的组件可以重叠，则返回 false（因为这会导致最优绘制无法进行）。
int | lowestLayer() 返回所有当前子组件的最低层值。
void | moveToBack(Component c) 将该组件移到当前层中所有组件的底层（位置 -1）。
void | moveToFront(Component c) 将该组件移到当前层中所有组件的顶层（位置 0）。
void | paint(Graphics g) 在指定的图形上下文中绘制此 JLayeredPane。
protected String | paramString() 返回此 JLayeredPane 的字符串表示形式。
static void | putLayer(JComponent c, int layer) 设置 JComponent 上的 layer 属性。
void | remove(int index) 从此窗格中移除已索引的组件。
void | removeAll() 从此容器中移除所有组件。
void | setLayer(Component c, int layer) 设置指定组件的 layer 属性，使之成为该层中最底部的组件。
void | setLayer(Component c, int layer, int position) 为指定组件设置 layer 属性，并设置它在该层中的位置。
void | setPosition(Component c, int position) 将该组件移到当前层中的 position 处，其中 0 表示该层中的最顶层位置，-1 表示最底层位置。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getUIClassID, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update, updateUI
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

DEFAULT_LAYER

public static final Integer DEFAULT_LAYER
定义 Default 层的便捷对象。等同于新的 Integer(0)。

PALETTE_LAYER

public static final Integer PALETTE_LAYER
定义 Palette 层的便捷对象。等同于新的 Integer(100)。

MODAL_LAYER

public static final Integer MODAL_LAYER
定义 Modal 层的便捷对象。等同于新的 Integer(200)。

POPUP_LAYER

public static final Integer POPUP_LAYER
定义 Popup 层的便捷对象。等同于新的 Integer(300)。

DRAG_LAYER

public static final Integer DRAG_LAYER
定义 Drag 层的便捷对象。等同于新的 Integer(400)。

FRAME_CONTENT_LAYER

public static final Integer FRAME_CONTENT_LAYER
定义 Frame Content 层的便捷对象。此层通常只用于定位 JFrame 的 contentPane 和 menuBar 组件。等同于新的 Integer(-30000)。

另请参见：
JFrame

LAYER_PROPERTY

public static final String LAYER_PROPERTY
绑定属性

另请参见：
常量字段值
构造方法详细信息

JLayeredPane

public JLayeredPane()
创建新的 JLayeredPane

方法详细信息

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
从类 Container 复制的描述
将指定组件添加到此容器的指定索引所在的位置上。此方法还通知布局管理器，通过 addLayoutComponent 方法，使用指定的约束对象将组件添加到此容器的布局中。

这些约束是由正使用的特定布局管理器定义的。例如，BorderLayout 类定义了五个约束：BorderLayout.NORTH、BorderLayout.SOUTH、BorderLayout.EAST、BorderLayout.WEST 和 BorderLayout.CENTER。

GridBagLayout 类需要一个 GridBagConstraints 对象。如果传递正确的约束对象类型时失败，则会导致 IllegalArgumentException。

如果当前布局管理器实现了 LayoutManager2，则在其上调用 LayoutManager2.addLayoutComponent(Component,Object)。如果当前布局管理器没有实现 LayoutManager2，并且约束是一个 String，则在其上调用 LayoutManager.addLayoutComponent(String,Component)。

如果该组件不是此容器的祖先容器，并且有一个非 null 父组件，则在将该组件添加到此容器之前，从其当前父组件中移除它。

在其他所有添加方法引用此方法时，如果某个程序需要追踪每个添加到容器的请求，那么这就是要重写的方法。被重写的方法通常应该包括一个对该方法的超类版本的调用：

super.addImpl(comp, constraints, index)

覆盖：
类 Container 中的 addImpl
参数：
comp - 要添加的组件
constraints - 表示此组件的布局约束的对象
另请参见：
Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
LayoutManager,
LayoutManager2

remove

public void remove(int index)
从此窗格中移除已索引的组件。这是绝对索引，与层无关。

覆盖：
类 Container 中的 remove
参数：
index - 指定要移除组件的 int 值
另请参见：
getIndexOf(java.awt.Component)

removeAll

public void removeAll()
从此容器中移除所有组件。

覆盖：
类 Container 中的 removeAll
从以下版本开始：
1.5
另请参见：
Container.add(java.awt.Component), Container.remove(int)

isOptimizedDrawingEnabled

public boolean isOptimizedDrawingEnabled()
如果窗格中的组件可以重叠，则返回 false（因为这会导致最优绘制无法进行）。否则返回 true。

覆盖：
类 JComponent 中的 isOptimizedDrawingEnabled
返回：
如果组件可以重叠，则返回 false；否则返回 true
另请参见：
JComponent.isOptimizedDrawingEnabled()

putLayer

public static void putLayer(JComponent c,
                            int layer)
设置 JComponent 上的 layer 属性。此方法不会产生与 setLayer() 类似的副作用（绘制、添加/移除等）。通常，为了获得所需的副作用（如重绘），应该使用实例方法 setLayer()。

参数：
c - 要移动的 JComponent
layer - 一个 int 值，指定要移入的层
另请参见：
setLayer(java.awt.Component, int)

getLayer

public static int getLayer(JComponent c)
获得 JComponent 的 layer 属性，此方法不会产生与 setLayer() 类似的副作用（绘制、添加/移除等）。要获得绘制、添加/移除等功能，通常应该使用实例方法 getLayer()。

参数：
c - 要检查的 JComponent
返回：
指定组件层的 int 值

getLayeredPaneAbove

public static JLayeredPane getLayeredPaneAbove(Component c)
一个便捷方法，它返回包含指定组件的第一个 JLayeredPane。注意，所有 JFrame 在其根部都有一个 JLayeredPane，因此 JFrame 中的任何组件都具有 JLayeredPane 父级。

参数：
c - 要检查的 Component
返回：
包含该组件的 JLayeredPane，如果在组件层次结构中未找到 JLayeredPane，则返回 null
另请参见：
JFrame, JRootPane

setLayer

public void setLayer(Component c,
                     int layer)
设置指定组件的 layer 属性，使之成为该层中最底部的组件。应该在将组件添加到其父组件之前调用该方法。

参数：
c - 要为其设置层的 Component
layer - 一个 int 值，指定要设置的层，其中较低编号更接近底部

setLayer

public void setLayer(Component c,
                     int layer,
                     int position)
为指定组件设置 layer 属性，并设置它在该层中的位置。

参数：
c - 要为其设置层的 Component
layer - 一个 int 值，指定要设置的层，其中较低编号更接近底部
position - 指定层中位置的 int 值，其中 0 表示最顶层位置，-1 表示最底层位置

getLayer

public int getLayer(Component c)
返回指定 Component 的 layer 属性。

参数：
c - 要检查的 Component
返回：
指定组件当前层的 int 值

getIndexOf

public int getIndexOf(Component c)
返回指定 Component 的索引。这是绝对索引，与层无关。索引编号与位置编号一样，索引零表示最顶层组件。较大编号更接近底部。

参数：
c - 要检查的 Component
返回：
指定组件索引的 int 值

moveToFront

public void moveToFront(Component c)
将该组件移到当前层中所有组件的顶层（位置 0）。

参数：
c - 要移动的 Component
另请参见：
setPosition(Component, int)

moveToBack

public void moveToBack(Component c)
将该组件移到当前层中所有组件的底层（位置 -1）。

参数：
c - 要移动的 Component
另请参见：
setPosition(Component, int)

setPosition

public void setPosition(Component c,
                        int position)
将该组件移到当前层中的 position 处，其中 0 表示该层中的最顶层位置，-1 表示最底层位置。

注：位置编号由 java.awt.Container 定义，且与层的编号相反。较低的位置编号更接近顶层（0 为最顶层），较高的位置编号更接近底层。

参数：
c - 要移动的 Component
position - 范围在 -1 到 N-1 之间的 int 值，其中 N 是该组件当前层中的组件数

getPosition

public int getPosition(Component c)
获得该组件在其所在层中的相对位置。

参数：
c - 要检查的 Component
返回：
给出组件位置的一个 int 值，其中 0 表示最顶层位置，且最高索引值等于该层中的组件数减一
另请参见：
getComponentCountInLayer(int)

highestLayer

public int highestLayer()
返回所有当前子组件的最高层值。如果没有子组件，则返回 0。

返回：
一个 int 值，指示窗格中最顶层组件的层，如果没有子组件，则返回 0

lowestLayer

public int lowestLayer()
返回所有当前子组件的最低层值。如果没有子组件，则返回 0。

返回：
一个 int 值，指示窗格中最底层组件的层；如果没有子组件，则返回 0

getComponentCountInLayer

public int getComponentCountInLayer(int layer)
返回指定层中当前的子组件数。

参数：
layer - 一个 int 值，指定要检查的层
返回：
一个 int 值，指定该层中的组件数

getComponentsInLayer

public Component[] getComponentsInLayer(int layer)
返回指定层中组件的数组。

参数：
layer - 一个 int 值，指定要检查的层
返回：
该层中包含的 Component 数组

paint

public void paint(Graphics g)
在指定的图形上下文中绘制此 JLayeredPane。

覆盖：
类 JComponent 中的 paint
参数：
g - 要在其中进行绘制的 Graphics 上下文
另请参见：
JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

getComponentToLayer

protected Hashtable<Component,Integer> getComponentToLayer()
返回将组件映射到层的哈希表。

返回：
用于将组件映射到对应层的 Hashtable

getObjectForLayer

protected Integer getObjectForLayer(int layer)
返回与指定层关联的 Integer 对象。

参数：
layer - 指定该层的 int 值
返回：
该层的 Integer 对象

insertIndexForLayer

protected int insertIndexForLayer(int layer,
                                  int position)
一个根据层和位置要求确定插入新子组件的正确位置的基本方法。

参数：
layer - 指定该层的 int 值
position - 指定层中位置的 int 值
返回：
给出（绝对的）插入索引的 int 值
另请参见：
getIndexOf(java.awt.Component)

paramString

protected String paramString()
返回此 JLayeredPane 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JLayeredPane 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得与此 JLayeredPane 关联的 AccessibleContext。对于分层窗格，AccessibleContext 采用 AccessibleJLayeredPane 的形式。如有必要，将创建一个新的 AccessibleJLayeredPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJLayeredPane，它充当此 JLayeredPane 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JList

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JList
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
public class JList
extends JComponent
implements Scrollable, Accessible

显示对象列表并且允许用户选择一个或多个项的组件。单独的模型 ListModel 维护列表的内容。

使用能自动构建只读 ListModel 实例的 JList 构造方法，可以方便地显示对象数组或对象 Vector：

 // Create a JList that displays strings from an array

 String[] data = {"one", "two", "three", "four"};
 JList myList = new JList(data);

 // Create a JList that displays the superclasses of JList.class, by
 // creating it with a Vector populated with this data

 Vector superClasses = new Vector();
 Class rootClass = javax.swing.JList.class;
 for(Class cls = rootClass; cls != null; cls = cls.getSuperclass()) {
     superClasses.addElement(cls);
 }
 JList myList = new JList(superClasses);

 // The automatically created model is stored in JList's "model"
 // property, which you can retrieve

 ListModel model = myList.getModel();
 for(int i = 0; i < model.getSize(); i++) {
     System.out.println(model.getElementAt(i));
 }

可通过构造方法或 setModel 方法向 JList 直接提供 ListModel。内容不需要是静态的，即项数和项值可以随时间而更改。正确的 ListModel 实现在每次发生更改时通知已添加到其中的 javax.swing.event.ListDataListener 集合。这些更改的特性由标识已修改、已添加或已移除的列表索引范围的 javax.swing.event.ListDataEvent 来描述。通过侦听该模型，JList 的 ListUI 负责保持可视化表示形式与更改一致。

简单的、动态内容的 JList 应用程序可以使用 DefaultListModel 类维护列表元素。此类实现 ListModel 接口，它还提供类似于 java.util.Vector 的 API。而需要自定义 ListModel 实现的应用程序可能希望子类化 AbstractListModel，它提供对管理和通知侦听器的基本支持。例如，AbstractListModel 的一个只读实现：

 // This list model has about 2^16 elements.  Enjoy scrolling.

 ListModel bigData = new AbstractListModel() {
     public int getSize() { return Short.MAX_VALUE; }
     public Object getElementAt(int index) { return "Index " + index; }
 };

JList 的选择状态由另一个独立模型（ListSelectionModel 的一个实例）进行管理。JList 在构造时使用选择模型初始化，它还包含要查询或设置此选择模型的方法。此外，JList 提供了便捷的方法，可以很容易地管理选择。这些方法（如 setSelectedIndex 和 getSelectedValue）是维护与选择模型交互细节的覆盖方法。默认情况下，JList 的选择模型配置为允许一次选择项的任何组合；选择模式为 MULTIPLE_INTERVAL_SELECTION。选择模式可以在选择模型上进行直接更改，或者通过 JList 的覆盖方法更改。更新选择模型以响应用户动作的责任取决于列表的 ListUI。

正确的 ListSelectionModel 实现在每次选择发生更改时通知向其添加的 javax.swing.event.ListSelectionListener 集合。这些更改的特征由标识选择更改范围的 javax.swing.event.ListSelectionEvent 来描述。

侦听列表选择中更改的首选方法是向 JList 中直接添加 ListSelectionListener。然后，JList 负责侦听选择模型并向侦听器通知更改。

侦听选择更改以便使列表可视化表示形式保持最新的责任取决于列表的 ListUI。

绘制 JList 中的单元由称为单元渲染器（以 cellRenderer 属性的形式安装在列表上）的委托进行处理。渲染器提供一个其用法类似 "rubber stamp" 的 java.awt.Component 来绘制单元。每当需要绘制单元时，列表的 ListUI 就请求组件的单元渲染器，将其移动到位，然后通过其 paint 方法绘制单元的内容。默认单元渲染器（它使用 JLabel 组件呈现）由列表的 ListUI 安装。用户还可以使用如下代码替换自己的渲染器：

  // Display an icon and a string for each object in the list.

 class MyCellRenderer extends JLabel implements ListCellRenderer {
     final static ImageIcon longIcon = new ImageIcon("long.gif");
     final static ImageIcon shortIcon = new ImageIcon("short.gif");

     // This is the only method defined by ListCellRenderer.
     // We just reconfigure the JLabel each time we're called.

     public Component getListCellRendererComponent(
       JList list,              // the list
       Object value,            // value to display
       int index,               // cell index
       boolean isSelected,      // is the cell selected
       boolean cellHasFocus)    // does the cell have focus
     {
         String s = value.toString();
         setText(s);
         setIcon((s.length() > 10) ? longIcon : shortIcon);
         if (isSelected) {
             setBackground(list.getSelectionBackground());
             setForeground(list.getSelectionForeground());
         } else {
             setBackground(list.getBackground());
             setForeground(list.getForeground());
         }
         setEnabled(list.isEnabled());
         setFont(list.getFont());
         setOpaque(true);
         return this;
     }
 }

 myList.setCellRenderer(new MyCellRenderer());

单元渲染器的另一项工作是帮助确定列表的大小信息。默认情况下，列表的 ListUI 通过请求单元渲染器提供每个列表项的首选大小来确定单元的大小。对于大的项列表，这可能开销很大。为了避免这些计算，可以在列表上设置 fixedCellWidth 和 fixedCellHeight，或者根据单个原型值自动计算这些值：

 JList bigDataList = new JList(bigData);

 // We don't want the JList implementation to compute the width
 // or height of all of the list cells, so we give it a string
 // that's as big as we'll need for any cell.  It uses this to
 // compute values for the fixedCellWidth and fixedCellHeight
// properties.

 bigDataList.setPrototypeCellValue("Index 1234567890");

JList 不实现直接滚动。要创建一个滚动的列表，请将它作为 JScrollPane 的视口视图。例如：

 JScrollPane scrollPane = new JScrollPane(myList);

 // Or in two steps:
 JScrollPane scrollPane = new JScrollPane();
 scrollPane.getViewport().setView(myList);

JList 没有提供两次或三次（或 N 次）鼠标单击的任何特殊处理，但是，如果希望对这些事件采取操作，则可以很方便地添加一个 MouseListener。使用 locationToIndex 方法确定单击的是哪一个单元。例如：

 MouseListener mouseListener = new MouseAdapter() {
     public void mouseClicked(MouseEvent e) {
         if (e.getClickCount() == 2) {
             int index = list.locationToIndex(e.getPoint());
             System.out.println("Double clicked on Item " + index);
          }
     }
 };
 list.addMouseListener(mouseListener);

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

有关更多文档，请参阅 The Java Tutorial 中的 How to Use Lists。另请参见 The Swing Connection 中的文章 Advanced JList Programming。

另请参见：
ListModel, AbstractListModel, DefaultListModel, ListSelectionModel, DefaultListSelectionModel, ListCellRenderer, DefaultListCellRenderer

嵌套类摘要
protected class | JList.AccessibleJList 此类实现 JList 类的可访问性支持。
static class | JList.DropLocation TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | HORIZONTAL_WRAP 指示“报纸样式”布局，单元按先水平后垂直排列。
static int | VERTICAL 指示单个列中单元的垂直布局；默认布局。
static int | VERTICAL_WRAP 指示“报纸样式”布局，单元按先垂直后水平排列。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JList()
构造一个具有空的、只读模型的 JList。
JList(ListModel dataModel)
根据指定的非 null 模型构造一个显示元素的 JList。
JList(Object[] listData)
构造一个 JList，使其显示指定数组中的元素。
JList(Vector<?> listData)
构造一个 JList，使其显示指定 Vector 中的元素。
方法摘要
void | addListSelectionListener(ListSelectionListener listener) 将侦听器添加到列表，每次选择发生更改时将获得通知；这是侦听选择状态更改的首选方式。
void | addSelectionInterval(int anchor, int lead) 将选择设置为指定间隔与当前选择的并集。
void | clearSelection() 清除选择；调用此方法后，isSelectionEmpty 将返回 true。
protected ListSelectionModel | createSelectionModel() 返回一个 DefaultListSelectionModel 实例；在构造期间调用此方法初始化列表的选择模型属性。
void | ensureIndexIsVisible(int index) 滚动封闭视口中的列表，使指定单元完全可见。
protected void | fireSelectionValueChanged(int firstIndex, int lastIndex, boolean isAdjusting) 通知直接添加到列表的 ListSelectionListener 对列表模型做出了选择更改。
AccessibleContext | getAccessibleContext() 获取与此 JList 关联的 AccessibleContext。
int | getAnchorSelectionIndex() 返回定位选择索引。
Rectangle | getCellBounds(int index0, int index1) 返回列表的坐标系统中两个索引所指定单元范围内的边界矩形。
ListCellRenderer | getCellRenderer() 返回负责绘制列表项的对象。
boolean | getDragEnabled() 返回是否启用自动拖动处理。
JList.DropLocation | getDropLocation() 返回在该组件上执行 DnD 操作期间此组件应该视觉上指示为放置位置的位置；如果当前没有任何显示的位置，则返回 null。
DropMode | getDropMode() 返回此组件的放置模式。
int | getFirstVisibleIndex() 返回当前可见的最小的列表索引。
int | getFixedCellHeight() 返回 fixedCellHeight 属性的值。
int | getFixedCellWidth() 返回 fixedCellWidth 属性的值。
int | getLastVisibleIndex() 返回当前可见的最大列表索引。
int | getLayoutOrientation() 返回列表的布局方向属性：如果布局是单列单元，则返回 VERTICAL；如果布局是“报纸样式”并且内容按先垂直后水平排列， 则返回 VERTICAL_WRAP；如果布局是“报纸样式”并且内容按先水平后垂直排列，则返回 HORIZONTAL_WRAP。
int | getLeadSelectionIndex() 返回前导选择索引。
ListSelectionListener[] | getListSelectionListeners() 返回通过 addListSelectionListener 添加到此 JList 中的所有 ListSelectionListener 所组成的数组。
int | getMaxSelectionIndex() 返回选择的最大单元索引；如果选择为空，则返回 -1。
int | getMinSelectionIndex() 返回选择的最小单元索引；如果选择为空，则返回 -1。
ListModel | getModel() 返回保存由 JList 组件显示的项列表的数据模型。
int | getNextMatch(String prefix, int startIndex, Position.Bias bias) 返回其 toString 值以给定前缀开头的下一个列表元素。
Dimension | getPreferredScrollableViewportSize() 计算显示 visibleRowCount 行所需的视口的大小。
Object | getPrototypeCellValue() 返回“原型的”单元值，即用于计算单元的固定宽度和高度的值。
int | getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction) 返回为显露上一个或下一个块而滚动的距离。
boolean | getScrollableTracksViewportHeight() 如果此 JList 在 JViewport 中显示并且视口的高度大于列表的首选高度，或者布局方向为 VERTICAL_WRAP 或 visibleRowCount <= 0，则返回 true；否则返回 false。
boolean | getScrollableTracksViewportWidth() 如果此 JList 在 JViewport 中显示并且视口的宽度大于列表的首选宽度，或者布局方向为 HORIZONTAL_WRAP 和 visibleRowCount <= 0，则返回 true；否则返回 false。
int | getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction) 返回为显露上一个或下一个行（垂直滚动）或列（水平滚动）而滚动的距离。
int | getSelectedIndex() 返回最小的选择单元索引；只选择了列表中单个项时，返回该选择。
int[] | getSelectedIndices() 返回所选的全部索引的数组（按升序排列）。
Object | getSelectedValue() 返回最小的选择单元索引的值；只选择了列表中单个项时，返回所选值。
Object[] | getSelectedValues() 返回所有选择值的数组，根据其列表中的索引顺序按升序排序。
Color | getSelectionBackground() 返回用于绘制选定项的背景的颜色。
Color | getSelectionForeground() 返回用于绘制选定项的前景的颜色。
int | getSelectionMode() 返回列表的当前选择模式。
ListSelectionModel | getSelectionModel() 返回当前选择模型。
String | getToolTipText(MouseEvent event) 返回用于给定事件的工具提示文本。
ListUI | getUI() 返回呈现此组件的外观对象 ListUI。
String | getUIClassID() 返回 "ListUI"，它是用于查找定义此组件外观的 javax.swing.plaf.ListUI 类名称的 UIDefaults 键。
boolean | getValueIsAdjusting() 返回选择模型的 isAdjusting 属性的值。
int | getVisibleRowCount() 返回 visibleRowCount 属性的值。
Point | indexToLocation(int index) 返回列表的坐标系统中指定项的原点。
boolean | isSelectedIndex(int index) 如果选择了指定的索引，则返回 true；否则返回 false。
boolean | isSelectionEmpty() 如果什么也没有选择，则返回 true；否则返回 false。
int | locationToIndex(Point location) 返回最接近列表的坐标系统中给定位置的单元索引。
protected String | paramString() 返回此 JList 的 String 表示形式。
void | removeListSelectionListener(ListSelectionListener listener) 从列表中移除一个选择侦听器。
void | removeSelectionInterval(int index0, int index1) 将选择设置为指定间隔和当前选择的差集。
void | setCellRenderer(ListCellRenderer cellRenderer) 设置用于绘制列表中每个单元的委托。
void | setDragEnabled(boolean b) 打开或关闭自动拖动处理。
void | setDropMode(DropMode dropMode) 设置此组件的放置模式。
void | setFixedCellHeight(int height) 设置一个固定值，将用于列表中每个单元的高度。
void | setFixedCellWidth(int width) 设置一个固定值，将用于列表中每个单元的宽度。
void | setLayoutOrientation(int layoutOrientation) 定义布置列表单元的方式。
void | setListData(Object[] listData) 根据一个对象数组构造只读 ListModel，然后对此模型调用 setModel。
void | setListData(Vector<?> listData) 根据一个 Vector 构造只读 ListModel，然后对此模型调用 setModel。
void | setModel(ListModel model) 设置表示列表内容或列表“值”的模型，通知属性更改侦听器，然后清除列表选择。
void | setPrototypeCellValue(Object prototypeCellValue) 设置 prototypeCellValue 属性，然后（如果新值为非 null）计算 fixedCellWidth 和 fixedCellHeight 属性：请求单元渲染器组件提供单元渲染器的给定值（及索引 0），并使用该组件的首选大小。
void | setSelectedIndex(int index) 选择单个单元。
void | setSelectedIndices(int[] indices) 将选择更改为给定数组所指定的索引的集合。
void | setSelectedValue(Object anObject, boolean shouldScroll) 从列表中选择指定的对象。
void | setSelectionBackground(Color selectionBackground) 设置用于绘制选定项的背景的颜色，单元渲染器可以使用此颜色填充所选单元。
void | setSelectionForeground(Color selectionForeground) 设置用于绘制选定项的前景的颜色，单元渲染器可以使用此颜色呈现文本和图形。
void | setSelectionInterval(int anchor, int lead) 选择指定的间隔。
void | setSelectionMode(int selectionMode) 设置列表的选择模式。
void | setSelectionModel(ListSelectionModel selectionModel) 将列表的 selectionModel 设置为非 null 的 ListSelectionModel 实现。
void | setUI(ListUI ui) 设置呈现此组件的外观对象 ListUI。
void | setValueIsAdjusting(boolean b) 设置选择模型的 valueIsAdjusting 属性。
void | setVisibleRowCount(int visibleRowCount) 设置 visibleRowCount 属性，对于不同的布局方向，此方法有不同的含义：对于 VERTICAL 布局方向，此方法设置要显示的首选行数（不要求滚动）；对于其他方向，它影响单元的包装。
void | updateUI() 重置 ListUI 属性，将其设置为当前外观所提供的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

VERTICAL

public static final int VERTICAL
指示单个列中单元的垂直布局；默认布局。

从以下版本开始：
1.4
另请参见：
setLayoutOrientation(int), 常量字段值

VERTICAL_WRAP

public static final int VERTICAL_WRAP
指示“报纸样式”布局，单元按先垂直后水平排列。

从以下版本开始：
1.4
另请参见：
setLayoutOrientation(int), 常量字段值

HORIZONTAL_WRAP

public static final int HORIZONTAL_WRAP
指示“报纸样式”布局，单元按先水平后垂直排列。

从以下版本开始：
1.4
另请参见：
setLayoutOrientation(int), 常量字段值
构造方法详细信息

JList

public JList(ListModel dataModel)
根据指定的非 null 模型构造一个显示元素的 JList。所有 JList 构造方法都委托给此方法。

此构造方法向 ToolTipManager 注册列表，允许工具提示由单元渲染器提供。

参数：
dataModel - 该列表的模型
抛出：
IllegalArgumentException - 如果模型为 null

JList

public JList(Object[] listData)
构造一个 JList，使其显示指定数组中的元素。此构造方法为给定数组创建一个只读模型，然后委托给带有 ListModel　的构造方法。

如果试图将一个 null 值传递给此方法，则会导致不确定的行为，最有可能导致异常。创建的模型直接引用给定的数组。如果试图在构造列表之后修改该数组，则会导致不确定的行为。

参数：
listData - 要加载到数据模型中的 Object 的数组（为非 null）

JList

public JList(Vector<?> listData)
构造一个 JList，使其显示指定 Vector 中的元素。此构造方法为给定 Vector 创建一个只读模型，然后委托给带有 ListModel 的构造方法。

如果试图将一个 null 值传递给此方法，则会导致不确定的行为，最有可能导致异常。创建的模型直接引用给定的 Vector。如果试图在构造列表之后修改该 Vector，则会导致不确定的行为。

参数：
listData - 要加载到数据模型中的 Vector（为非 null）

JList

public JList()
构造一个具有空的、只读模型的 JList。

方法详细信息

getUI

public ListUI getUI()
返回呈现此组件的外观对象 ListUI。

返回：
呈现此组件的 ListUI 对象

setUI

public void setUI(ListUI ui)
设置呈现此组件的外观对象 ListUI。

参数：
ui - ListUI 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
重置 ListUI 属性，将其设置为当前外观所提供的值。如果当前单元渲染器由开发人员（而不是外观本身）安装，则这还会导致单元渲染器及其子单元渲染器被更新（通过在其上调用 SwingUtilities.updateComponentTreeUI）。

覆盖：
类 JComponent 中的 updateUI
另请参见：
UIManager.getUI(javax.swing.JComponent), SwingUtilities.updateComponentTreeUI(java.awt.Component)

getUIClassID

public String getUIClassID()
返回 "ListUI"，它是用于查找定义此组件外观的 javax.swing.plaf.ListUI 类名称的 UIDefaults 键。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "ListUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getPrototypeCellValue

public Object getPrototypeCellValue()
返回“原型的”单元值，即用于计算单元的固定宽度和高度的值。如果没有这样的值，则可以返回 null。

返回：
prototypeCellValue 属性的值
另请参见：
setPrototypeCellValue(java.lang.Object)

setPrototypeCellValue

public void setPrototypeCellValue(Object prototypeCellValue)
设置 prototypeCellValue 属性，然后（如果新值为非 null）计算 fixedCellWidth 和 fixedCellHeight 属性：请求单元渲染器组件提供单元渲染器的给定值（及索引 0），并使用该组件的首选大小。

当由于列表过长而不允许 ListUI 计算每个单元的宽度/高度，并且已知某个单元值（所谓的原型）所占用的空间与任何其他单元一样多时，此方法很有用。

尽管 prototypeCellValue、fixedCellHeight 和 fixedCellWidth 三个属性都可以由此方法进行修改时，但只有 prototypeCellValue 属性更改时才发送 PropertyChangeEvent 通知。

要查看设置此属性的示例，请参见上述类描述。

此属性的默认值为 null。

这是一个 JavaBeans 绑定属性。

参数：
prototypeCellValue - 作为 fixedCellWidth 和 fixedCellHeight 的基础的值
另请参见：
getPrototypeCellValue(), setFixedCellWidth(int), setFixedCellHeight(int), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

getFixedCellWidth

public int getFixedCellWidth()
返回 fixedCellWidth 属性的值。

返回：
固定单元宽度
另请参见：
setFixedCellWidth(int)

setFixedCellWidth

public void setFixedCellWidth(int width)
设置一个固定值，将用于列表中每个单元的宽度。如果 width 为 -1，则可以通过将 getPreferredSize 应用到每个列表元素的单元渲染器组件来计算 ListUI 的单元宽度。

此属性的默认值为 -1。

这是一个 JavaBeans 绑定属性。

参数：
width - 将用于该列表中所有单元的宽度
另请参见：
setPrototypeCellValue(java.lang.Object), setFixedCellWidth(int), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

getFixedCellHeight

public int getFixedCellHeight()
返回 fixedCellHeight 属性的值。

返回：
固定单元高度
另请参见：
setFixedCellHeight(int)

setFixedCellHeight

public void setFixedCellHeight(int height)
设置一个固定值，将用于列表中每个单元的高度。如果 height 为 -1，则可以通过将 getPreferredSize 应用到每个列表元素的单元渲染器组件来计算 ListUI 的单元高度。

此属性的默认值为 -1。

这是一个 JavaBeans 绑定属性。

参数：
height - 将用于该列表中所有单元的高度
另请参见：
setPrototypeCellValue(java.lang.Object), setFixedCellWidth(int), Container.addPropertyChangeListener(java.beans.PropertyChangeListener)

getCellRenderer

public ListCellRenderer getCellRenderer()
返回负责绘制列表项的对象。

返回：
cellRenderer 属性的值
另请参见：
setCellRenderer(javax.swing.ListCellRenderer)

setCellRenderer

public void setCellRenderer(ListCellRenderer cellRenderer)
设置用于绘制列表中每个单元的委托。类级别文档中更加详细地讨论了单元渲染器的工作。

如果 prototypeCellValue 属性为非 null，则设置单元渲染器还导致重新计算 fixedCellWidth 和 fixedCellHeight 属性。但是只对 cellRenderer 属性生成一个 PropertyChangeEvent。

此属性的默认值由 ListUI 委托（即外观实现）提供。

这是一个 JavaBeans 绑定属性。

参数：
cellRenderer - 绘制列表单元的 ListCellRenderer
另请参见：
getCellRenderer()

getSelectionForeground

public Color getSelectionForeground()
返回用于绘制选定项的前景的颜色。DefaultListCellRenderer 使用此颜色来绘制选定状态中的项的前景，就像大多数 ListUI 实现安装的渲染器所做的一样。

返回：
用于绘制选定项的前景的颜色
另请参见：
setSelectionForeground(java.awt.Color), DefaultListCellRenderer

setSelectionForeground

public void setSelectionForeground(Color selectionForeground)
设置用于绘制选定项的前景的颜色，单元渲染器可以使用此颜色呈现文本和图形。DefaultListCellRenderer 使用此颜色来绘制选定状态中的项的前景，就像大多数 ListUI 实现安装的渲染器所做的一样。

此属性的默认值由外观实现定义。

这是一个 JavaBeans 绑定属性。

参数：
selectionForeground - 在所选列表项的前景中使用的 Color
另请参见：
getSelectionForeground(),
setSelectionBackground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font),
DefaultListCellRenderer

getSelectionBackground

public Color getSelectionBackground()
返回用于绘制选定项的背景的颜色。DefaultListCellRenderer 使用此颜色来绘制选定状态中的项的背景，就像大多数 ListUI 实现安装的渲染器所做的一样。

返回：
用于绘制选定项的背景的颜色
另请参见：
setSelectionBackground(java.awt.Color), DefaultListCellRenderer

setSelectionBackground

public void setSelectionBackground(Color selectionBackground)
设置用于绘制选定项的背景的颜色，单元渲染器可以使用此颜色填充所选单元。DefaultListCellRenderer 使用此颜色来填充选定状态中的项的背景，就像大多数 ListUI 实现安装的渲染器所做的一样。

此属性的默认值由外观实现定义。

这是一个 JavaBeans 绑定属性。

参数：
selectionBackground - 用于所选单元的背景的 Color
另请参见：
getSelectionBackground(),
setSelectionForeground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font),
DefaultListCellRenderer

getVisibleRowCount

public int getVisibleRowCount()
返回 visibleRowCount 属性的值。有关如何解释此值的详细信息，请参阅 setVisibleRowCount(int) 的文档。

返回：
visibleRowCount 属性的值。
另请参见：
setVisibleRowCount(int)

setVisibleRowCount

public void setVisibleRowCount(int visibleRowCount)
设置 visibleRowCount 属性，对于不同的布局方向，此方法有不同的含义：对于 VERTICAL 布局方向，此方法设置要显示的首选行数（不要求滚动）；对于其他方向，它影响单元的包装。

在 VERTICAL 方向上：
设置此属性将影响 getPreferredScrollableViewportSize() 方法（它用于计算封闭视口的首选大小）的返回值。有关更多信息，请参阅该方法的文档。

在 HORIZONTAL_WRAP 和 VERTICAL_WRAP 方向上：
这将影响如何包装单元。有关更多信息，请参阅 setLayoutOrientation(int) 的文档。

此属性的默认值为 8。

使用负值调用此方法将导致该属性被设置为 0。

这是一个 JavaBeans 绑定属性。

参数：
visibleRowCount - 一个整数值，指示要显示的首选行数（不要求滚动）
另请参见：
getVisibleRowCount(), getPreferredScrollableViewportSize(), setLayoutOrientation(int), JComponent.getVisibleRect(), JViewport

getLayoutOrientation

public int getLayoutOrientation()
返回列表的布局方向属性：如果布局是单列单元，则返回 VERTICAL；如果布局是“报纸样式”并且内容按先垂直后水平排列， 则返回 VERTICAL_WRAP；如果布局是“报纸样式”并且内容按先水平后垂直排列，则返回 HORIZONTAL_WRAP。

返回：
layoutOrientation 属性的值
从以下版本开始：
1.4
另请参见：
setLayoutOrientation(int)

setLayoutOrientation

public void setLayoutOrientation(int layoutOrientation)
定义布置列表单元的方式。考虑一个具有五个单元的 JList。单元的布局可以采用以下方式之一：

 VERTICAL:          0
                    1
                    2
                    3
                    4

 HORIZONTAL_WRAP:   0  1  2
                    3  4

 VERTICAL_WRAP:     0  3
                    1  4
                    2

这些布局的描述遵循如下内容：

值

描述

VERTICAL | 在单个列中垂直布置单元。
HORIZONTAL_WRAP | 水平布置单元，根据需要将单元包装到新行中。如果 visibleRowCount 属性小于等于 0，则包装由该列表的宽度确定；否则，以确保列表中 visibleRowCount 行的方式进行包装。
VERTICAL_WRAP | 垂直布置单元，根据需要将单元包装到新列中。如果 visibleRowCount 属性小于等于 0，则包装由该列表的宽度确定；否则，在 visibleRowCount 行进行包装。

此属性的默认值为 VERTICAL。

参数：
layoutOrientation - 新的布局方向，VERTICAL、HORIZONTAL_WRAP 或 VERTICAL_WRAP 之一
抛出：
IllegalArgumentException - 如果 layoutOrientation 不是所允许的值之一
从以下版本开始：
1.4
另请参见：
getLayoutOrientation(), setVisibleRowCount(int), getScrollableTracksViewportHeight(), getScrollableTracksViewportWidth()

getFirstVisibleIndex

public int getFirstVisibleIndex()
返回当前可见的最小的列表索引。在从左到右的 componentOrientation 中，第一个可见单元最接近列表的左上角。在从右到左方向上，它最接近右上角。如果任何单元都不可见或者列表为空，则返回 -1。注意，返回的单元可能只有部分可见。

返回：
第一个可见单元的索引
另请参见：
getLastVisibleIndex(), JComponent.getVisibleRect()

getLastVisibleIndex

public int getLastVisibleIndex()
返回当前可见的最大列表索引。如果任何单元都不可见或者列表为空，则返回 -1。注意，返回的单元可能只有部分可见。

返回：
最后一个可见单元的索引
另请参见：
getFirstVisibleIndex(), JComponent.getVisibleRect()

ensureIndexIsVisible

public void ensureIndexIsVisible(int index)
滚动封闭视口中的列表，使指定单元完全可见。此方法使用指定单元的边界调用 scrollRectToVisible。要让此方法生效，JList 必须在 JViewport 中。

如果给定索引超出列表中单元的范围，则此方法不起任何作用。

参数：
index - 要变得可见的单元的索引
另请参见：
JComponent.scrollRectToVisible(java.awt.Rectangle), JComponent.getVisibleRect()

setDragEnabled

public void setDragEnabled(boolean b)
打开或关闭自动拖动处理。要启用自动拖动处理，此属性应该设置为 true，列表的 TransferHandler 需要为非 null。dragEnabled 属性的默认值为 false。

遵守此属性的作业以及识别用户拖动动作取决于外观实现，尤其是列表的 ListUI。启用自动拖动处理时，只要用户在项上按下鼠标按键，然后将鼠标移动几个像素，大多数外观（包括子类化 BasicLookAndFeel 的外观）就开始拖放操作了。因此，将此属性设置为 true 可以对选择的行为方式产生微妙的影响。

如果使用忽略此属性的外观，则仍然可以通过在列表的 TransferHandler 上调用 exportAsDrag 开始一个拖动操作。

参数：
b - 是否启用自动拖动处理
抛出：
HeadlessException - 如果 b 为 true 并且 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDragEnabled

public boolean getDragEnabled()
返回是否启用自动拖动处理。

返回：
dragEnabled 属性的值
从以下版本开始：
1.4
另请参见：
setDragEnabled(boolean)

setDropMode

public final void setDropMode(DropMode dropMode)
设置此组件的放置模式。为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。但是，为了方便用户使用，建议使用其他模式。例如，DropMode.ON 提供与选择相似的显示项的行为，但执行此操作不会影响列表中的实际选择。

JList 支持下列放置模式：

  • DropMode.USE_SELECTION
  • DropMode.ON
  • DropMode.INSERT
  • DropMode.ON_OR_INSERT
只有此组件具有接受放置的 TransferHandler 时，放置模式才有意义。

参数：
dropMode - 要使用的放置模式
抛出：
IllegalArgumentException - 如果放置模式不受支持或为 null
从以下版本开始：
1.6
另请参见：
getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDropMode

public final DropMode getDropMode()
返回此组件的放置模式。

返回：
此组件的放置模式
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode)

getDropLocation

public final JList.DropLocation getDropLocation()
返回在该组件上执行 DnD 操作期间此组件应该视觉上指示为放置位置的位置；如果当前没有任何显示的位置，则返回 null。

此方法不用于查询 TransferHandler 的放置位置，因为只有在 TransferHandler 的 canImport 已返回并允许显示放置位置之后才设置了放置位置。

此属性更改时，带有 "dropLocation" 名称的属性更改事件由该组件触发。

默认情况下，负责侦听对此属性的更改以及视觉上指示放置位置的是列表的 ListUI，它可以直接绘制该位置和/或安装一个用来执行此操作的渲染器。希望实现自定义放置操作绘制和/或替换默认单元渲染器的开发人员可能需要遵守此属性。

返回：
放置操作
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

getNextMatch

public int getNextMatch(String prefix,
                        int startIndex,
                        Position.Bias bias)
返回其 toString 值以给定前缀开头的下一个列表元素。

参数：
prefix - 要测试是否匹配的字符串
startIndex - 开始搜索的索引
bias - 搜索方向，Position.Bias.Forward 或 Position.Bias.Backward。
返回：
以 prefix 开头的下一个列表元素的索引；否则返回 -1
抛出：
IllegalArgumentException - 如果 prefix 为 null 或者 startIndex 超出范围
从以下版本开始：
1.4

getToolTipText

public String getToolTipText(MouseEvent event)
返回用于给定事件的工具提示文本。此方法重写 JComponent 的 getToolTipText，首先检查其上发生事件的单元的单元渲染器组件，并返回其工具提示文本（如果有）。此实现允许使用单元渲染器组件上的 setToolTipText 在单元层上指定工具提示文本。

注：要让 JList 以此方式正确地显示其渲染器的工具提示，JList 必须是已向 ToolTipManager 注册的组件。此注册可以在构造方法中自动完成。但是，如果之后通过调用 setToolTipText(null) 注销了 JList，则渲染器的提示将不再显示。

覆盖：
类 JComponent 中的 getToolTipText
参数：
event - 用于获取工具提示文本的 MouseEvent
另请参见：
JComponent.setToolTipText(java.lang.String), JComponent.getToolTipText()

locationToIndex

public int locationToIndex(Point location)
返回最接近列表的坐标系统中给定位置的单元索引。要确定单元是否实际包含指定的位置，需要将该点与单元的边界进行比较，边界由 getCellBounds 提供。如果模型为空，则此方法返回 -1

此方法是委托给列表的 ListUI 中同名方法的覆盖方法。如果列表没有 ListUI，则它返回 -1。

参数：
location - 点的坐标
返回：
接近给定位置的单元索引或 -1

indexToLocation

public Point indexToLocation(int index)
返回列表的坐标系统中指定项的原点。如果索引无效，则此方法返回 null。

此方法是委托给列表的 ListUI 中同名方法的覆盖方法。如果列表没有 ListUI，则它返回 null。

参数：
index - 单元索引
返回：
单元的原点或 null

getCellBounds

public Rectangle getCellBounds(int index0,
                               int index1)
返回列表的坐标系统中两个索引所指定单元范围内的边界矩形。索引可以按任意顺序提供。

如果较小索引超出单元的列表范围，则此方法返回 null。如果较小索引有效，但较大索引超出列表范围，则只返回第一个索引的边界。否则，返回有效范围的边界。

此方法是委托给列表的 ListUI 中同名方法的覆盖方法。如果列表没有 ListUI，则它返回 null。

参数：
index0 - 范围中的第一个索引
index1 - 范围中的第二个索引
返回：
单元范围的边界矩形或 null

getModel

public ListModel getModel()
返回保存由 JList 组件显示的项列表的数据模型。

返回：
提供显示的项列表的 ListModel
另请参见：
setModel(javax.swing.ListModel)

setModel

public void setModel(ListModel model)
设置表示列表内容或列表“值”的模型，通知属性更改侦听器，然后清除列表选择。

这是一个 JavaBeans 绑定属性。

参数：
model - 提供要显示的项列表的 ListModel
抛出：
IllegalArgumentException - 如果 model 为 null
另请参见：
getModel(), clearSelection()

setListData

public void setListData(Object[] listData)
根据一个对象数组构造只读 ListModel，然后对此模型调用 setModel。

试图将 null 值传递给此方法将导致不确定的行为，很有可能是异常。创建的模型直接引用给定数组。试图在调用此方法之后修改该数组将导致不确定的行为。

参数：
listData - 包含要在列表中显示的项的 Object 数组
另请参见：
setModel(javax.swing.ListModel)

setListData

public void setListData(Vector<?> listData)
根据一个 Vector 构造只读 ListModel，然后对此模型调用 setModel。

试图将 null 值传递给此方法将导致不确定的行为，很有可能是异常。创建的模型直接引用给定 Vector。试图在调用此方法之后修改该 Vector 将导致不确定的行为。

参数：
listData - 包含要在列表中显示的项的 Vector
另请参见：
setModel(javax.swing.ListModel)

createSelectionModel

protected ListSelectionModel createSelectionModel()
返回一个 DefaultListSelectionModel 实例；在构造期间调用此方法初始化列表的选择模型属性。

返回：
一个 DefaultListSelecitonModel，用于在构造期间初始化列表的选择模型属性
另请参见：
setSelectionModel(javax.swing.ListSelectionModel), DefaultListSelectionModel

getSelectionModel

public ListSelectionModel getSelectionModel()
返回当前选择模型。选择模型维护列表的选择状态。有关更多信息，请参阅类级别文档。

返回：
维护列表的选择的 ListSelectionModel
另请参见：
setSelectionModel(javax.swing.ListSelectionModel), ListSelectionModel

fireSelectionValueChanged

protected void fireSelectionValueChanged(int firstIndex,
                                         int lastIndex,
                                         boolean isAdjusting)
通知直接添加到列表的 ListSelectionListener 对列表模型做出了选择更改。JList 侦听选择模型中对选择所做的更改，并通过调用此方法将通知转发到直接添加到列表的侦听器。

此方法以此列表作为源，使用指定的参数构造 ListSelectionEvent，并将其发送到已注册的 ListSelectionListener。

参数：
firstIndex - 范围内的第一个索引（<= lastIndex）
lastIndex - 范围内的最后一个索引（>= firstIndex）
isAdjusting - 此事件是否是多个连续事件之一，其中更改仍然在进行
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener), removeListSelectionListener(javax.swing.event.ListSelectionListener), ListSelectionEvent, EventListenerList

addListSelectionListener

public void addListSelectionListener(ListSelectionListener listener)
将侦听器添加到列表，每次选择发生更改时将获得通知；这是侦听选择状态更改的首选方式。JList 负责侦听选择模型中选择状态更改，并通知每个更改的给定侦听器。发送到侦听器的 ListSelectionEvent 具有设置为此列表的 source 属性。

参数：
listener - 要添加的 ListSelectionListener
另请参见：
getSelectionModel(), getListSelectionListeners()

removeListSelectionListener

public void removeListSelectionListener(ListSelectionListener listener)
从列表中移除一个选择侦听器。

参数：
listener - 要移除的 ListSelectionListener
另请参见：
getSelectionModel(), getListSelectionListeners()

getListSelectionListeners

public ListSelectionListener[] getListSelectionListeners()
返回通过 addListSelectionListener 添加到此 JList 中的所有 ListSelectionListener 所组成的数组。

返回：
此列表上的所有 ListSelectionListener；如果没有添加任何侦听器，则返回空数组
从以下版本开始：
1.4
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener)

setSelectionModel

public void setSelectionModel(ListSelectionModel selectionModel)
将列表的 selectionModel 设置为非 null 的 ListSelectionModel 实现。选择模型可以完成单个选择、连续范围选择和非连续范围选择等任务。

这是一个 JavaBeans 绑定属性。

参数：
selectionModel - 实现选择的 ListSelectionModel
抛出：
IllegalArgumentException - 如果 selectionModel 为 null
另请参见：
getSelectionModel()

setSelectionMode

public void setSelectionMode(int selectionMode)
设置列表的选择模式。此方法是在选择模型上直接设置选择模式的覆盖方法。

以下列表描述了可接受的选择模式：

  • ListSelectionModel.SINGLE_SELECTION - 一次只能选择一个列表索引。在此模式中，setSelectionInterval 和 addSelectionInterval 是等效的，两者都使用第二个参数（“lead”）所表示的索引来替换当前选择。
  • ListSelectionModel.SINGLE_INTERVAL_SELECTION - 一次只能选择一个连续间隔。在此模式中，如果给定间隔没有紧邻着现有选择或与现有选择重叠，则 addSelectionInterval 与 setSelectionInterval 完全相同（替换当前选择），并可用于生成选择。
  • ListSelectionModel.MULTIPLE_INTERVAL_SELECTION - 在此模式中，不存在对选择的限制。此模式是默认设置。

参数：
selectionMode - 选择模式
抛出：
IllegalArgumentException - 如果选择模式不是那些允许的模式之一
另请参见：
getSelectionMode()

getSelectionMode

public int getSelectionMode()
返回列表的当前选择模式。此方法是委托给列表的选择模型上同名方法的覆盖方法。

返回：
当前选择模式
另请参见：
setSelectionMode(int)

getAnchorSelectionIndex

public int getAnchorSelectionIndex()
返回定位选择索引。此方法是委托给列表的选择模型上同名方法的覆盖方法。

返回：
定位选择索引
另请参见：
ListSelectionModel.getAnchorSelectionIndex()

getLeadSelectionIndex

public int getLeadSelectionIndex()
返回前导选择索引。此方法是委托给列表的选择模型上同名方法的覆盖方法。

返回：
前导选择索引
另请参见：
ListSelectionModel.getLeadSelectionIndex()

getMinSelectionIndex

public int getMinSelectionIndex()
返回选择的最小单元索引；如果选择为空，则返回 -1。此方法是委托给列表的选择模型上同名方法的覆盖方法。

返回：
选择的最小单元索引或 -1
另请参见：
ListSelectionModel.getMinSelectionIndex()

getMaxSelectionIndex

public int getMaxSelectionIndex()
返回选择的最大单元索引；如果选择为空，则返回 -1。此方法是委托给列表的选择模型上同名方法的覆盖方法。

返回：
选择的最大单元索引
另请参见：
ListSelectionModel.getMaxSelectionIndex()

isSelectedIndex

public boolean isSelectedIndex(int index)
如果选择了指定的索引，则返回 true；否则返回 false。此方法是委托给列表的选择模型上同名方法的覆盖方法。

参数：
index - 要查询其选择状态的索引
返回：
如果选择了指定的索引，则返回 true；否则返回 false
另请参见：
ListSelectionModel.isSelectedIndex(int), setSelectedIndex(int)

isSelectionEmpty

public boolean isSelectionEmpty()
如果什么也没有选择，则返回 true；否则返回 false。此方法是委托给列表的选择模型上同名方法的覆盖方法。

返回：
如果什么也没有选择，则返回 true；否则返回 false
另请参见：
ListSelectionModel.isSelectionEmpty(), clearSelection()

clearSelection

public void clearSelection()
清除选择；调用此方法后，isSelectionEmpty 将返回 true。此方法是委托给列表的选择模型上同名方法的覆盖方法。

另请参见：
ListSelectionModel.clearSelection(), isSelectionEmpty()

setSelectionInterval

public void setSelectionInterval(int anchor,
                                 int lead)
选择指定的间隔。包括 anchor 和 lead 两个索引。anchor 不必小于等于 lead。此方法是委托给列表的选择模型上同名方法的覆盖方法。

有关如何处理小于 0 的值的详细信息，请参阅所用选择模型类的文档。

参数：
anchor - 要选择的第一个索引
lead - 要选择的最后一个索引
另请参见：
ListSelectionModel.setSelectionInterval(int, int),
DefaultListSelectionModel.setSelectionInterval(int, int),
createSelectionModel(),
addSelectionInterval(int, int),
removeSelectionInterval(int, int)

addSelectionInterval

public void addSelectionInterval(int anchor,
                                 int lead)
将选择设置为指定间隔与当前选择的并集。包括 anchor 和 lead 两个索引。anchor 不必小于等于 lead。此方法是委托给列表的选择模型上同名方法的覆盖方法。

有关如何处理小于 0 的值的详细信息，请参阅所用选择模型类的文档。

参数：
anchor - 要添加到选择的第一个索引
lead - 要添加到选择的最后一个索引
另请参见：
ListSelectionModel.addSelectionInterval(int, int),
DefaultListSelectionModel.addSelectionInterval(int, int),
createSelectionModel(),
setSelectionInterval(int, int),
removeSelectionInterval(int, int)

removeSelectionInterval

public void removeSelectionInterval(int index0,
                                    int index1)
将选择设置为指定间隔和当前选择的差集。两个索引 index0 和 index1 都要移除。index0 不必小于等于 index1。此方法是委托给列表的选择模型上同名方法的覆盖方法。

有关如何处理小于 0 的值的详细信息，请参阅所用选择模型类的文档。

参数：
index0 - 要从选择移除的第一个索引
index1 - 要从选择移除的最后一个索引
另请参见：
ListSelectionModel.removeSelectionInterval(int, int),
DefaultListSelectionModel.removeSelectionInterval(int, int),
createSelectionModel(),
setSelectionInterval(int, int),
addSelectionInterval(int, int)

setValueIsAdjusting

public void setValueIsAdjusting(boolean b)
设置选择模型的 valueIsAdjusting 属性。当为 true 时，即将进行的选择更改应该被视为单个更改的一部分。此属性供内部使用，开发人员通常不要调用此方法。例如，模型正被更新以响应用户拖动时，如果拖动已经开始，那么该属性值被设置为 true；如果拖动已经结束，则被设置为 false。此属性允许侦听器只在更改结束时进行更新，而不是处理所有的中间值。

如果所做的一系列更改都应该被视为单个更改的一部分，则可能需要直接使用此方法。

此方法是委托给列表的选择模型上同名方法的覆盖方法。有关更多信息，请参阅 ListSelectionModel.setValueIsAdjusting(boolean) 的文档。

参数：
b - 属性的新值
另请参见：
ListSelectionModel.setValueIsAdjusting(boolean),
ListSelectionEvent.getValueIsAdjusting(),
getValueIsAdjusting()

getValueIsAdjusting

public boolean getValueIsAdjusting()
返回选择模型的 isAdjusting 属性的值。

此方法是委托给列表的选择模型上同名方法的覆盖方法。

返回：
选择模型的 isAdjusting 属性的值。
另请参见：
setValueIsAdjusting(boolean), ListSelectionModel.getValueIsAdjusting()

getSelectedIndices

public int[] getSelectedIndices()
返回所选的全部索引的数组（按升序排列）。

返回：
所选的全部索引（按升序排列）；如果什么也没有选择，则返回一个空数组
另请参见：
removeSelectionInterval(int, int), addListSelectionListener(javax.swing.event.ListSelectionListener)

setSelectedIndex

public void setSelectedIndex(int index)
选择单个单元。如果给定索引大于等于模型大小，则不执行任何操作。此方法是在选择模型上使用 setSelectionInterval 的便捷方法。有关如何处理小于 0 的值的详细信息，请参阅所用选择模型类的文档。

参数：
index - 要选择的单元的索引
另请参见：
ListSelectionModel.setSelectionInterval(int, int), isSelectedIndex(int), addListSelectionListener(javax.swing.event.ListSelectionListener)

setSelectedIndices

public void setSelectedIndices(int[] indices)
将选择更改为给定数组所指定的索引的集合。忽略大于等于模型大小的索引。此方法是清除选择、然后在选择模型上使用 addSelectionInterval 添加索引的便捷方法。有关如何处理小于 0 的值的详细信息，请参阅所用选择模型类的文档。

参数：
indices - 要选择的单元的索引数组（为非 null）
抛出：
NullPointerException - 如果给定数组为 null
另请参见：
ListSelectionModel.addSelectionInterval(int, int), isSelectedIndex(int), addListSelectionListener(javax.swing.event.ListSelectionListener)

getSelectedValues

public Object[] getSelectedValues()
返回所有选择值的数组，根据其列表中的索引顺序按升序排序。

返回：
所选值；如果什么也没有选择，则返回一个空数组
另请参见：
isSelectedIndex(int), getModel(), addListSelectionListener(javax.swing.event.ListSelectionListener)

getSelectedIndex

public int getSelectedIndex()
返回最小的选择单元索引；只选择了列表中单个项时，返回该选择。选择了多项时，则只返回最小的选择索引。如果什么也没有选择，则返回 -1。

此方法是委托给 getMinSelectionIndex 的覆盖方法。

返回：
最小的选择的单元索引
另请参见：
getMinSelectionIndex(), addListSelectionListener(javax.swing.event.ListSelectionListener)

getSelectedValue

public Object getSelectedValue()
返回最小的选择单元索引的值；只选择了列表中单个项时，返回所选值。选择了多项时，返回最小的选择索引的值。如果什么也没有选择，则返回 null。

此方法是返回 getMinSelectionIndex 的模型值的便捷方法。

返回：
所选的第一个值
另请参见：
getMinSelectionIndex(),
getModel(),
addListSelectionListener(javax.swing.event.ListSelectionListener)

setSelectedValue

public void setSelectedValue(Object anObject,
                             boolean shouldScroll)
从列表中选择指定的对象。

参数：
anObject - 要选择的对象
shouldScroll - 如果所选对象存在，但列表需要滚动才能显示，则为 true；否则为 false

getPreferredScrollableViewportSize

public Dimension getPreferredScrollableViewportSize()
计算显示 visibleRowCount 行所需的视口的大小。此方法所返回的值取决于布局方向：

VERTICAL:
如果已（显式地或通过指定一个原型单元值）设置了 fixedCellWidth 和 fixedCellHeight，则此操作无足轻重。宽度是 fixedCellWidth 加上列表的水平 insets。高度是 fixedCellHeight 乘以 visibleRowCount 再加上列表的垂直 insets。

如果尚未指定 fixedCellWidth 或 fixedCellHeight，则使用直观推断。模型为空时，如果 fixedCellWidth 大于 0，则宽度为 fixedCellWidth，否则为 256 的固定编码 (hard coded) 值。如果 fixedCellHeight 大于 0，则高度为 fixedCellHeight 乘以 visibleRowCount；否则它是固定编码 (hard coded) 值 16 乘以 visibleRowCount。

如果模型不为空，则宽度为首选大小的宽度，通常是最宽的列表元素的宽度。高度是 fixedCellHeight 乘以 visibleRowCount 再加上列表的垂直 insets。

VERTICAL_WRAP 或 HORIZONTAL_WRAP：
此方法只返回 getPreferredSize 的返回值。期望列表的 ListUI 重写 getPreferredSize 以返回适当的值。

指定者：
接口 Scrollable 中的 getPreferredScrollableViewportSize
返回：
包含显示 visibleRowCount 行所需视口大小的 dimension
另请参见：
getPreferredScrollableViewportSize(), setPrototypeCellValue(java.lang.Object)

getScrollableUnitIncrement

public int getScrollableUnitIncrement(Rectangle visibleRect,
                                      int orientation,
                                      int direction)
返回为显露上一个或下一个行（垂直滚动）或列（水平滚动）而滚动的距离。

对于水平滚动，如果布局方向为 VERTICAL，则返回列表的字体大小（如果字体为 null，则返回 1）。

指定者：
接口 Scrollable 中的 getScrollableUnitIncrement
参数：
visibleRect - 视口中可见的视图区域
orientation - SwingConstants.HORIZONTAL 或 SwingConstants.VERTICAL
direction - 小于等于 0 表示向上滚动/后退，大于 0 表示向下滚动/前进
返回：
沿指定方向滚动的“单位”增量；永远为正数
抛出：
IllegalArgumentException - 如果 visibleRect 为 null，或者 orientation 不为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
另请参见：
getScrollableBlockIncrement(java.awt.Rectangle, int, int), Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

getScrollableBlockIncrement

public int getScrollableBlockIncrement(Rectangle visibleRect,
                                       int orientation,
                                       int direction)
返回为显露上一个或下一个块而滚动的距离。

对于垂直滚动，使用以下规则：

  • 如果向下滚动，则返回使最后一个可见元素就成为第一个完全可见元素的滚动距离
  • 如果向上滚动，则返回使第一个可见元素就成为最后一个完全可见元素的滚动距离
  • 如果列表为空，则返回 visibleRect.height

对于水平滚动，当布局方向为 VERTICAL_WRAP 或 HORIZONTAL_WRAP 时：

  • 如果向右滚动，则返回使最后一个可见元素就成为第一个完全可见元素的滚动距离
  • 如果向左滚动，则返回使第一个可见元素就成为最后一个完全可见元素的滚动距离
  • 如果列表为空，则返回 visibleRect.width

对于水平滚动和 VERTICAL 方向，则返回 visibleRect.width。

注意，visibleRect 的值必须等于 this.getVisibleRect()。

指定者：
接口 Scrollable 中的 getScrollableBlockIncrement
参数：
visibleRect - 视口中可见的视图区域
orientation - SwingConstants.HORIZONTAL 或 SwingConstants.VERTICAL
direction - 小于等于 0 表示向上滚动/后退，大于 0 表示向下滚动/前进
返回：
沿指定方向滚动的“块”增量；永远为负数
抛出：
IllegalArgumentException - 如果 visibleRect 为 null，或者 orientation 不为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
另请参见：
getScrollableUnitIncrement(java.awt.Rectangle, int, int), Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

getScrollableTracksViewportWidth

public boolean getScrollableTracksViewportWidth()
如果此 JList 在 JViewport 中显示并且视口的宽度大于列表的首选宽度，或者布局方向为 HORIZONTAL_WRAP 和 visibleRowCount <= 0，则返回 true；否则返回 false。

如果返回 false，则不跟踪视口宽度。如果 JViewport 本身嵌入在 JScrollPane 中，则此操作允许水平滚动。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportWidth
返回：
封闭视口是否强制列表的宽度与其自身宽度匹配
另请参见：
Scrollable.getScrollableTracksViewportWidth()

getScrollableTracksViewportHeight

public boolean getScrollableTracksViewportHeight()
如果此 JList 在 JViewport 中显示并且视口的高度大于列表的首选高度，或者布局方向为 VERTICAL_WRAP 或 visibleRowCount <= 0，则返回 true；否则返回 false。

如果返回 false，则不跟踪视口高度。如果 JViewport 本身嵌入在 JScrollPane 中，则此操作允许垂直滚动。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportHeight
返回：
封闭视口是否强制列表的高度与其自身高度匹配
另请参见：
Scrollable.getScrollableTracksViewportHeight()

paramString

protected String paramString()
返回此 JList 的 String 表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回 String 的内容和格式可能有所不同。返回的 String 可以为空，但不可以为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JList 的 String 表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JList 关联的 AccessibleContext。对于 JList，AccessibleContext 采取 AccessibleJList 的形式。

如有必要，可以创建一个新的 AccessibleJList 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJList，它充当此 JList 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMenu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JMenu

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JMenuItem
                        继承者  javax.swing.JMenu
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants
public class JMenu
extends JMenuItem
implements Accessible, MenuElement

菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。除 JMenuItem 之外，JMenu 还可以包含 JSeparator。

菜单本质上是带有关联 JPopupMenu 的按钮。当按下“按钮”时，就会显示 JPopupMenu。如果“按钮”位于 JMenuBar 上，则该菜单为顶层窗口。如果“按钮”是另一个菜单项，则 JPopupMenu 就是“右拉”菜单。

通过 Action 可以配置菜单，并进行一定程度的控制。对菜单使用 Action 有许多直接配置菜单所不及的优点。有关更多信息，请参阅支持 Action 的 Swing 组件，可以在 The Java Tutorial 中的 How to Use Actions 一节找到更多信息。

有关使用菜单的示例和信息，请参阅 The Java Tutorial 中的 How to Use Menus 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

另请参见：
JMenuItem, JSeparator, JMenuBar, JPopupMenu

嵌套类摘要
protected class | JMenu.AccessibleJMenu 此类实现 JMenu 类的可访问性支持。
protected class | JMenu.WinListener 观察弹出窗口关闭的侦听器类。
从类 javax.swing.JMenuItem 继承的嵌套类/接口
JMenuItem.AccessibleJMenuItem
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected  JMenu.WinListener popupListener
弹出菜单的窗口关闭侦听器。
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JMenu()
构造没有文本的新 JMenu。
JMenu(Action a)
构造一个从提供的 Action 获取其属性的菜单。
JMenu(String s)
构造一个新 JMenu，用提供的字符串作为其文本。
JMenu(String s, boolean b)
构造一个新 JMenu，用提供的字符串作为其文本并指定其是否为分离式 (tear-off) 菜单。
方法摘要
 JMenuItem add(Action a)
创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。
 Component add(Component c)
将某个组件追加到此菜单的末尾。
 Component add(Component c, int index)
将指定组件添加到此容器的给定位置上。
 JMenuItem add(JMenuItem menuItem)
将某个菜单项追加到此菜单的末尾。
 JMenuItem add(String s)
创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。
 void addMenuListener(MenuListener l)
添加菜单事件的侦听器。
 void addSeparator()
将新分隔符追加到菜单的末尾。
 void applyComponentOrientation(ComponentOrientation o)
设置此菜单及其中包含的所有组件的 ComponentOrientation 属性。
protected  PropertyChangeListener createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected  JMenuItem createActionComponent(Action a)
该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。
protected  JMenu.WinListener createWinListener(JPopupMenu p)
创建弹出菜单的窗口关闭侦听器。
 void doClick(int pressTime)
以编程方式执行“单击”。
protected  void fireMenuCanceled()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireMenuDeselected()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
protected  void fireMenuSelected()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
 AccessibleContext getAccessibleContext()
获取与此 JMenu 关联的 AccessibleContext。
 Component getComponent()
返回用于绘制此 MenuElement 的 java.awt.Component。
 int getDelay()
返回子菜单向上或向下弹出前建议的延迟（以毫秒为单位）。
 JMenuItem getItem(int pos)
返回指定位置的 JMenuItem。
 int getItemCount()
返回菜单上的项数，包括分隔符。
 Component getMenuComponent(int n)
返回位于位置 n 的组件。
 int getMenuComponentCount()
返回菜单上的组件数。
 Component[] getMenuComponents()
返回菜单子组件的 Component 数组。
 MenuListener[] getMenuListeners()
返回利用 addMenuListener() 添加到此 JMenu 的所有 MenuListener 组成的数组。
 JPopupMenu getPopupMenu()
返回与此菜单关联的弹出菜单。
protected  Point getPopupMenuOrigin()
计算 JMenu 的弹出菜单的原点。
 MenuElement[] getSubElements()
返回由 MenuElement 组成的数组，其中包含此菜单组件的子菜单。
 String getUIClassID()
返回呈现此组件的 L&F 类的名称。
 JMenuItem insert(Action a, int pos)
在给定位置插入连接到指定 Action 对象的新菜单项。
 JMenuItem insert(JMenuItem mi, int pos)
在给定位置插入指定的 JMenuitem。
 void insert(String s, int pos)
在给定位置插入具有指定文本的新菜单项。
 void insertSeparator(int index)
在指定的位置插入分隔符。
 boolean isMenuComponent(Component c)
如果在子菜单层次结构中存在指定的组件，则返回 true。
 boolean isPopupMenuVisible()
如果菜单的弹出窗口可见，则返回 true。
 boolean isSelected()
如果菜单是当前选择的（即高亮显示的）菜单，则返回 true。
 boolean isTearOff()
如果此菜单是分离式的，则返回 true。
 boolean isTopLevelMenu()
如果菜单是“顶层菜单”（即菜单栏的直接子级），则返回 true。
 void menuSelectionChanged(boolean isIncluded)
当菜单栏选择更改为激活或取消激活此菜单时传递消息。
protected  String paramString()
返回此 JMenu 的字符串表示形式。
protected  void processKeyEvent(KeyEvent evt)
处理键击事件，如助记符和加速器。
 void remove(Component c)
从此菜单移除组件 c。
 void remove(int pos)
从此菜单移除指定索引处的菜单项。
 void remove(JMenuItem item)
从此菜单移除指定的菜单项。
 void removeAll()
从此菜单移除所有菜单项。
 void removeMenuListener(MenuListener l)
移除菜单事件的侦听器。
 void setAccelerator(KeyStroke keyStroke)
没有为 JMenu 定义 setAccelerator。
 void setComponentOrientation(ComponentOrientation o)
设置语言敏感的方向，用于排序此组件内的元素或文本。
 void setDelay(int d)
设置菜单的 PopupMenu 向上或向下弹出前建议的延迟。
 void setMenuLocation(int x, int y)
设置弹出组件的位置。
 void setModel(ButtonModel newModel)
设置“菜单按钮”的数据模型，即用户单击可以打开或关闭菜单的标签。
 void setPopupMenuVisible(boolean b)
设置菜单弹出的可见性。
 void setSelected(boolean b)
设置菜单的选择状态。
 void updateUI()
利用当前外观的值重置 UI 属性。
从类 javax.swing.JMenuItem 继承的方法
actionPropertyChanged, addMenuDragMouseListener, addMenuKeyListener, configurePropertiesFromAction, fireMenuDragMouseDragged, fireMenuDragMouseEntered, fireMenuDragMouseExited, fireMenuDragMouseReleased, fireMenuKeyPressed, fireMenuKeyReleased, fireMenuKeyTyped, getAccelerator, getMenuDragMouseListeners, getMenuKeyListeners, init, isArmed, processKeyEvent, processMenuDragMouseEvent, processMenuKeyEvent, processMouseEvent, removeMenuDragMouseListener, removeMenuKeyListener, setArmed, setEnabled, setUI
从类 javax.swing.AbstractButton 继承的方法
addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait
从接口 javax.swing.MenuElement 继承的方法
processKeyEvent, processMouseEvent

字段详细信息

popupListener

protected JMenu.WinListener popupListener
弹出菜单的窗口关闭侦听器。

另请参见：
JMenu.WinListener
构造方法详细信息

JMenu

public JMenu()
构造没有文本的新 JMenu。

JMenu

public JMenu(String s)
构造一个新 JMenu，用提供的字符串作为其文本。

参数：
s - 菜单标签的文本

JMenu

public JMenu(Action a)
构造一个从提供的 Action 获取其属性的菜单。

参数：
a - Action
从以下版本开始：
1.3

JMenu

public JMenu(String s,
             boolean b)
构造一个新 JMenu，用提供的字符串作为其文本并指定其是否为分离式 (tear-off) 菜单。

参数：
s - 菜单标签的文本
b - 菜单是否是分离式的（尚未实现）
方法详细信息

updateUI

public void updateUI()
利用当前外观的值重置 UI 属性。

覆盖：
类 JMenuItem 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JMenuItem 中的 getUIClassID
返回：
字符串 "MenuUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setModel

public void setModel(ButtonModel newModel)
设置“菜单按钮”的数据模型，即用户单击可以打开或关闭菜单的标签。

覆盖：
类 JMenuItem 中的 setModel
参数：
newModel - ButtonModel
另请参见：
AbstractButton.getModel()

isSelected

public boolean isSelected()
如果菜单是当前选择的（即高亮显示的）菜单，则返回 true。

覆盖：
类 AbstractButton 中的 isSelected
返回：
如果选择了菜单，则返回 true；否则返回 false

setSelected

public void setSelected(boolean b)
设置菜单的选择状态。

覆盖：
类 AbstractButton 中的 setSelected
参数：
b - true 表示选择（高亮显示）菜单，false 表示取消选择菜单

isPopupMenuVisible

public boolean isPopupMenuVisible()
如果菜单的弹出窗口可见，则返回 true。

返回：
如果菜单可见，则返回 true；否则返回 false

setPopupMenuVisible

public void setPopupMenuVisible(boolean b)
设置菜单弹出的可见性。如果未启用菜单，则此方法无效。

参数：
b - 一个 boolean 值，true 表示菜单可见，false 表示隐藏

getPopupMenuOrigin

protected Point getPopupMenuOrigin()
计算 JMenu 的弹出菜单的原点。此方法使用名为 Menu.menuPopupOffsetX、Menu.menuPopupOffsetY、Menu.submenuPopupOffsetX 和 Menu.submenuPopupOffsetY 的外观属性调整弹出的确切位置。

返回：
菜单的坐标空间中的一个 Point，该点应该用作 JMenu 的弹出菜单的原点
从以下版本开始：
1.3

getDelay

public int getDelay()
返回子菜单向上或向下弹出前建议的延迟（以毫秒为单位）。每个外观 (L&F) 都可以确定它自己查看 delay 属性的策略。在大多数情况下，对于顶层菜单或正在拖动的菜单，不查看延迟。delay 的默认值为 0。此方法是外观代码的属性，用于管理各种 UI 实现的特质。

返回：
delay 属性

setDelay

public void setDelay(int d)
设置菜单的 PopupMenu 向上或向下弹出前建议的延迟。每个外观 (L&F) 都可以确定它自己查看 delay 属性的策略。在大多数情况下，对于顶层菜单或正在拖动的菜单，不查看延迟。此方法是外观代码的属性，用于管理各种 UI 实现的特质。

参数：
d - 要延迟的毫秒数
抛出：
IllegalArgumentException - 如果 d 小于 0

setMenuLocation

public void setMenuLocation(int x,
                            int y)
设置弹出组件的位置。

参数：
x - 弹出菜单的新位置的 x 坐标
y - 弹出菜单的新位置的 y 坐标

add

public JMenuItem add(JMenuItem menuItem)
将某个菜单项追加到此菜单的末尾。返回添加的菜单项。

参数：
menuItem - 要添加的 JMenuitem
返回：
已添加的 JMenuItem

add

public Component add(Component c)
将某个组件追加到此菜单的末尾。返回添加的组件。

覆盖：
类 Container 中的 add
参数：
c - 要添加的 Component
返回：
已添加的 Component
另请参见：
Container.addImpl(java.awt.Component, java.lang.Object, int),
Container.validate(),
JComponent.revalidate()

add

public Component add(Component c,
                     int index)
将指定组件添加到此容器的给定位置上。如果 index 等于 -1，则将组件追加到末尾。

覆盖：
类 Container 中的 add
参数：
c - 要添加的 Component
index - 要插入组件的位置
返回：
已添加的 Component
另请参见：
remove(javax.swing.JMenuItem), Container.add(Component, int)

add

public JMenuItem add(String s)
创建具有指定文本的新菜单项，并将其追加到此菜单的末尾。

参数：
s - 要添加的菜单项的字符串

add

public JMenuItem add(Action a)
创建连接到指定 Action 对象的新菜单项，并将其追加到此菜单的末尾。

参数：
a - 要添加的菜单项的 Action
另请参见：
Action

createActionComponent

protected JMenuItem createActionComponent(Action a)
该工厂方法创建添加到 JMenu 的 Action 的 JMenuItem。

参数：
a - 要添加的菜单项的 Action
返回：
新菜单项
从以下版本开始：
1.3
另请参见：
Action

createActionChangeListener

protected PropertyChangeListener createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。

addSeparator

public void addSeparator()
将新分隔符追加到菜单的末尾。

insert

public void insert(String s,
                   int pos)
在给定位置插入具有指定文本的新菜单项。

参数：
s - 要添加的菜单项的文本
pos - 指定要添加新菜单项的位置的整数
抛出：
IllegalArgumentException - 当 pos 的值 < 0 时

insert

public JMenuItem insert(JMenuItem mi,
                        int pos)
在给定位置插入指定的 JMenuitem。

参数：
mi - 要添加的 JMenuitem
pos - 指定要添加新 JMenuitem 的位置的整数
返回：
新菜单项
抛出：
IllegalArgumentException - 如果 pos 的值 < 0

insert

public JMenuItem insert(Action a,
                        int pos)
在给定位置插入连接到指定 Action 对象的新菜单项。

参数：
a - 要添加的菜单项的 Action 对象
pos - 指定要添加新菜单项的位置的整数
抛出：
IllegalArgumentException - 如果 pos 的值 < 0

insertSeparator

public void insertSeparator(int index)
在指定的位置插入分隔符。

参数：
index - 指定要插入菜单分隔符的位置的整数
抛出：
IllegalArgumentException - 如果 index 的值 < 0

getItem

public JMenuItem getItem(int pos)
返回指定位置的 JMenuItem。如果位于 pos 的组件不是菜单项，则返回 null。包含此方法是为了 AWT 兼容性。

参数：
pos - 指定位置的整数
返回：
指定位置的菜单项；如果指定位置的项不是菜单项，则返回 null
抛出：
IllegalArgumentException - 如果 pos 的值 < 0

getItemCount

public int getItemCount()
返回菜单上的项数，包括分隔符。包含此方法是为了与 AWT 的兼容性。

返回：
等于菜单上的项数的整数
另请参见：
getMenuComponentCount()

isTearOff

public boolean isTearOff()
如果此菜单是分离式的，则返回 true。此方法尚未实现。

返回：
如果菜单是分离式的，则返回 true；否则返回 false
抛出：
Error - 如果调用（此方法尚未实现）

remove

public void remove(JMenuItem item)
从此菜单移除指定的菜单项。如果不存在弹出菜单，则此方法无效。

参数：
item - 要从该菜单移除的 JMenuItem

remove

public void remove(int pos)
从此菜单移除指定索引处的菜单项。

覆盖：
类 Container 中的 remove
参数：
pos - 要移除的项的位置
抛出：
IllegalArgumentException - 如果 pos 的值 < 0 或者 pos 大于菜单项数
另请参见：
Container.add(java.awt.Component),
Container.validate(),
Container.getComponentCount()

remove

public void remove(Component c)
从此菜单移除组件 c。

覆盖：
类 Container 中的 remove
参数：
c - 要移除的组件
另请参见：
Container.add(java.awt.Component),
Container.validate(),
Container.remove(int)

removeAll

public void removeAll()
从此菜单移除所有菜单项。

覆盖：
类 Container 中的 removeAll
另请参见：
Container.add(java.awt.Component), Container.remove(int)

getMenuComponentCount

public int getMenuComponentCount()
返回菜单上的组件数。

返回：
包含菜单上的组件数的整数

getMenuComponent

public Component getMenuComponent(int n)
返回位于位置 n 的组件。

参数：
n - 要返回的组件的位置
返回：
请求的组件；如果不存在弹出菜单，则返回 null

getMenuComponents

public Component[] getMenuComponents()
返回菜单子组件的 Component 数组。注意，此操作返回弹出菜单中的所有 Component，包括分隔符。

返回：
Component 数组；如果不存在弹出菜单，则返回空数组

isTopLevelMenu

public boolean isTopLevelMenu()
如果菜单是“顶层菜单”（即菜单栏的直接子级），则返回 true。

返回：
如果从菜单栏激活菜单，则返回 true；如果从另一个菜单的菜单项激活菜单，则返回 false

isMenuComponent

public boolean isMenuComponent(Component c)
如果在子菜单层次结构中存在指定的组件，则返回 true。

参数：
c - 要测试的 Component
返回：
如果 Component 存在，则返回 true；否则返回 false

getPopupMenu

public JPopupMenu getPopupMenu()
返回与此菜单关联的弹出菜单。如果不存在弹出菜单，则将创建一个。

addMenuListener

public void addMenuListener(MenuListener l)
添加菜单事件的侦听器。

参数：
l - 要添加的侦听器

removeMenuListener

public void removeMenuListener(MenuListener l)
移除菜单事件的侦听器。

参数：
l - 要移除的侦听器

getMenuListeners

public MenuListener[] getMenuListeners()
返回利用 addMenuListener() 添加到此 JMenu 的所有 MenuListener 组成的数组。

返回：
添加的所有 MenuListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

fireMenuSelected

protected void fireMenuSelected()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

抛出：
Error - 如果存在 null 侦听器
另请参见：
EventListenerList

fireMenuDeselected

protected void fireMenuDeselected()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

抛出：
Error - 如果存在 null 侦听器
另请参见：
EventListenerList

fireMenuCanceled

protected void fireMenuCanceled()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

抛出：
Error - 如果存在 null 侦听器
另请参见：
EventListenerList

createWinListener

protected JMenu.WinListener createWinListener(JPopupMenu p)
创建弹出菜单的窗口关闭侦听器。

参数：
p - JPopupMenu
返回：
新窗口关闭侦听器
另请参见：
JMenu.WinListener

menuSelectionChanged

public void menuSelectionChanged(boolean isIncluded)
当菜单栏选择更改为激活或取消激活此菜单时传递消息。重写 JMenuItem.menuSelectionChanged。

指定者：
接口 MenuElement 中的 menuSelectionChanged
覆盖：
类 JMenuItem 中的 menuSelectionChanged
参数：
isIncluded - 如果此菜单处于激活状态，则返回 true；如果不是，则返回 false
另请参见：
MenuSelectionManager.setSelectedPath(MenuElement[])

getSubElements

public MenuElement[] getSubElements()
返回由 MenuElement 组成的数组，其中包含此菜单组件的子菜单。如果弹出菜单为 null，则返回空数组。要求此方法遵守 MenuElement 接口。注意，由于 JSeparator 不遵守 MenuElement 接口，因此此数组只包含 JMenuItem。

指定者：
接口 MenuElement 中的 getSubElements
覆盖：
类 JMenuItem 中的 getSubElements
返回：
MenuElement 对象的数组。

getComponent

public Component getComponent()
返回用于绘制此 MenuElement 的 java.awt.Component。返回的组件用于转换事件并检测某个事件是否位于菜单组件中。

指定者：
接口 MenuElement 中的 getComponent
覆盖：
类 JMenuItem 中的 getComponent
返回：
绘制此菜单项的 Component

applyComponentOrientation

public void applyComponentOrientation(ComponentOrientation o)
设置此菜单及其中包含的所有组件的 ComponentOrientation 属性。这包括由 getMenuComponents 返回的所有组件。

覆盖：
类 Container 中的 applyComponentOrientation
参数：
o - 此菜单的新组件的方向性和其中包含组件的方向性。
抛出：
NullPointerException - 如果 orientation 为 null。
从以下版本开始：
1.4
另请参见：
Component.setComponentOrientation(java.awt.ComponentOrientation), Component.getComponentOrientation()

setComponentOrientation

public void setComponentOrientation(ComponentOrientation o)
从类 Component 复制的描述
设置语言敏感的方向，用于排序此组件内的元素或文本。语言敏感的 LayoutManager 和 Component 子类使用此属性来确定如何布局并绘制组件。

在构造时，组件的方向设置为 ComponentOrientation.UNKNOWN，表示尚未显式地指定它。UNKNOWN 方向的行为与 ComponentOrientation.LEFT_TO_RIGHT 相同。

要设置单个组件的方向，请使用此方法。要设置整个组件层次结构的方向，请使用 applyComponentOrientation。

覆盖：
类 Component 中的 setComponentOrientation
另请参见：
ComponentOrientation

setAccelerator

public void setAccelerator(KeyStroke keyStroke)
没有为 JMenu 定义 setAccelerator。而使用 setMnemonic 来代替。

覆盖：
类 JMenuItem 中的 setAccelerator
参数：
keyStroke - 键击组合，它调用 JMenuItem 的 actionlistener 而不必导航菜单的层次结构
抛出：
Error - 如果调用（没有为 JMenu 定义此方法。使用 setMnemonic 来代替）

processKeyEvent

protected void processKeyEvent(KeyEvent evt)
处理键击事件，如助记符和加速器。

覆盖：
类 JComponent 中的 processKeyEvent
参数：
evt - 要处理的键事件
另请参见：
KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

doClick

public void doClick(int pressTime)
以编程方式执行“单击”。为使菜单弹出，此方法重写 AbstractButton.doClick 方法。

覆盖：
类 AbstractButton 中的 doClick
参数：
pressTime - 指示按下按钮的毫秒数

paramString

protected String paramString()
返回此 JMenu 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JMenuItem 中的 paramString
返回：
此 JMenu 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JMenu 关联的 AccessibleContext。对于 JMenu，AccessibleContext 采用 AccessibleJMenu 的形式。必要时创建一个新的 AccessibleJMenu 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JMenuItem 中的 getAccessibleContext
返回：
一个 AccessibleJMenu，它充当此 JMenu 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JLayeredPane.AccessibleJLayeredPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JLayeredPane.AccessibleJLayeredPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JLayeredPane.AccessibleJLayeredPane
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JLayeredPane
protected class JLayeredPane.AccessibleJLayeredPane
extends JComponent.AccessibleJComponent

此类实现对 JLayeredPane 类的可访问性支持。它提供适合于分层窗格用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JLayeredPane.AccessibleJLayeredPane()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JLayeredPane.AccessibleJLayeredPane

protected JLayeredPane.AccessibleJLayeredPane()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JList.AccessibleJList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JList.AccessibleJList

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JList.AccessibleJList
所有已实现的接口：
PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, ListDataListener, ListSelectionListener
正在封闭类：
JList
protected class JList.AccessibleJList
extends JComponent.AccessibleJComponent
implements AccessibleSelection, PropertyChangeListener, ListSelectionListener, ListDataListener

此类实现 JList 类的可访问性支持。它提供适合列表用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JList.AccessibleJList.AccessibleJListChild
此类实现供 List 子级使用的可访问性支持。
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JList.AccessibleJList()
方法摘要
void | addAccessibleSelection(int i) 将对象中的指定选项添加到对象选择中。
void | clearAccessibleSelection() 清除对象中的选择，从而对象中没有选择任何项。
void | contentsChanged(ListDataEvent e) List Data Listener 内容更改方法。
Accessible | getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | getAccessibleChild(int i) 返回对象的第 n 个可访问子级。
int | getAccessibleChildrenCount() 返回对象中可访问的子级数。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回表示对象中指定选项的 Accessible。
int | getAccessibleSelectionCount() 返回当前选择的项数。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
void | intervalAdded(ListDataEvent e) List Data Listener 间隔添加方法。
void | intervalRemoved(ListDataEvent e) List Data Listener 间隔移除方法。
boolean | isAccessibleChildSelected(int i) 如果选择了此对象的当前子级，则返回 true。
void | propertyChange(PropertyChangeEvent e) Property Change Listener 更改方法。
void | removeAccessibleSelection(int i) 从对象选择中移除对象中的指定选项。
void | selectAllAccessibleSelection() 如果对象支持多种选择，则导致选择对象中的所有选择项。
void | valueChanged(ListSelectionEvent e) List Selection Listener 值更改方法。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JList.AccessibleJList

public JList.AccessibleJList()
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
Property Change Listener 更改方法。用于跟踪对 DataModel 和 ListSelectionModel 的更改，以便重新设置对它们的侦听器，以通过 Accessibility PropertyChange 机制报告对它们进行的更改。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - PropertyChangeEvent

valueChanged

public void valueChanged(ListSelectionEvent e)
List Selection Listener 值更改方法。用于激发属性更改。

指定者：
接口 ListSelectionListener 中的 valueChanged
参数：
e - ListSelectionEvent

intervalAdded

public void intervalAdded(ListDataEvent e)
List Data Listener 间隔添加方法。用于激发可见数据属性更改。

指定者：
接口 ListDataListener 中的 intervalAdded
参数：
e - ListDataEvent

intervalRemoved

public void intervalRemoved(ListDataEvent e)
List Data Listener 间隔移除方法。用于激发可见数据属性更改。

指定者：
接口 ListDataListener 中的 intervalRemoved
参数：
e - ListDataEvent

contentsChanged

public void contentsChanged(ListDataEvent e)
List Data Listener 内容更改方法。用于激发可见数据属性更改。

指定者：
接口 ListDataListener 中的 contentsChanged
参数：
e - ListDataEvent

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。否则返回 null。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleAt
参数：
p - 定义 Accessible 左上角的点，在对象父代的坐标空间中给出
返回：
指定位置的 Accessible（如果存在）

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中可访问的子级数。如果此对象的所有子级都实现 Accessible，则此方法应该返回此对象的子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个可访问子级。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
该对象的第 n 个可访问子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象相关联的 AccessibleSelection。在此类的 Java Accessibility API 的实现中，返回的是此对象，它负责为其本身实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选择的项数。如果未选择项，则返回值 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选择的项数。

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回表示对象中指定选项的 Accessible。如果没有选择，或选择的项数小于传入的整数，则返回的值将为 null。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选项的从零开始的索引
返回：
包含所选项的 Accessible
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
如果选择了此对象的当前子级，则返回 true。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象子级的从零开始的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将对象中的指定选项添加到对象选择中。如果对象支持多种选择，则将指定项添加到所有现有选择中，否则它将替换对象中的所有现有选择。如果已经选择了指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从对象选择中移除对象中的指定选项。如果当前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，从而对象中没有选择任何项。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
如果对象支持多种选择，则导致选择对象中的所有选择项。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JList.AccessibleJList.AccessibleJListChild (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JList.AccessibleJList.AccessibleJListChild

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.JList.AccessibleJList.AccessibleJListChild
所有已实现的接口：
Accessible, AccessibleComponent
正在封闭类：
JList.AccessibleJList
protected class JList.AccessibleJList.AccessibleJListChild
extends AccessibleContext
implements Accessible, AccessibleComponent

此类实现供 List 子级使用的可访问性支持。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JList.AccessibleJList.AccessibleJListChild(JList parent, int indexInParent)
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
boolean | contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
AccessibleAction | getAccessibleAction() 获取与此对象关联的可支持一个或多个动作的 AccessibleAction。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回该对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回该对象的可访问子级数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleContext | getAccessibleContext() 获取此对象的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的 accessibleDescription 属性。
AccessibleIcon[] | getAccessibleIcon() 返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。
int | getAccessibleIndexInParent() 获取此对象在其可访问父级中的基于零的索引。
String | getAccessibleName() 获取此对象的 accessibleName 属性。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集合。
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的支持 Numerical 值的 AccessibleValue。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取该组件的语言环境。
Point | getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否已启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定此对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | setAccessibleDescription(String s) 设置此对象的可访问描述。
void | setAccessibleName(String s) 设置此对象的可访问的本地化名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleParent, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JList.AccessibleJList.AccessibleJListChild

public JList.AccessibleJList.AccessibleJListChild(JList parent,
                                                  int indexInParent)
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取此对象的 AccessibleContext。在针对此类的 Java Accessibility API 的实现中，返回的是此对象，它是其本身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleName

public String getAccessibleName()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleName 属性。对象的 accessibleName 属性是指定该对象功能的本地化 String。例如，标签和按钮的 accessibleName 属性可以是标签或按钮本身的文本。对于不显示其名称的对象，仍应设置 accessibleName。例如，对于用于输入城市名称的文本字段，在 en_US 语言环境下，accessibleName 可以为 "city"。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问的本地化名称。更改名称将导致激发 ACCESSIBLE_NAME_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 对象的新本地化名称。
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
从类 AccessibleContext 复制的描述
获取此对象的 accessibleDescription 属性。此对象的 accessibleDescription 属性是描述该对象功能的本地化短语。例如，对于 "Cancel" 按钮，accessibleDescription 可以是 "Ignore changes and close dialog box"（忽略更改并关闭对话框）。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
该对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
从类 AccessibleContext 复制的描述
设置此对象的可访问描述。更改名称将导致激发 ACCESSIBLE_DESCRIPTION_PROPERTY 属性的 PropertyChangeEvent。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
从类 AccessibleContext 复制的描述
获取此对象的职责。对象的职责是此对象的类的一般功能或用途。例如，push 按钮的职责是 AccessibleRole.PUSH_BUTTON。AccessibleRole 中提供了一些职责，组件开发人员可以从一组预定义职责中进行选择。这就使辅助技术能为各种交互的组件子类（例如，对所有充当按钮的组件使用 AccessibleRole.PUSH_BUTTON）以及区分行为各异的子类（例如，复选框 AccessibleRole.CHECK_BOX 和单选框 AccessibleRole.RADIO_BUTTON）提供一致的接口。

注意，AccessibleRole 类也是可扩展的，因此如果预定义的职责集合不充分，则自定义组件的开发人员可以定义他们自己的 AccessibleRole。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
从类 AccessibleContext 复制的描述
获取此对象的状态集合。对象的 AccessibleStateSet 由一组唯一的 AccessibleState 组成。对象的 AccessibleStateSet 中的更改将导致激发 ACCESSIBLE_STATE_PROPERTY 属性的 PropertyChangeEvent。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象的当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
从类 AccessibleContext 复制的描述
获取此对象在其可访问父级中的基于零的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象在父级中从零开始的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
AccessibleContext.getAccessibleParent(),
AccessibleContext.getAccessibleChildrenCount(),
AccessibleContext.getAccessibleChild(int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
从类 AccessibleContext 复制的描述
返回该对象的可访问子级数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
该对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
从类 AccessibleContext 复制的描述
返回该对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从零开始的，因此 Accessible 对象的第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 子级从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
从类 AccessibleContext 复制的描述
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此组件的语言环境。如果此组件没有语言环境，则返回其父级的语言环境。

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
将 PropertyChangeListener 添加到侦听器列表。此侦听器为所有 Accessible 属性注册，并且将在这些属性发生更改时调用。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从类 AccessibleContext 复制的描述
从侦听器列表移除 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
从类 AccessibleContext 复制的描述
获取与此对象关联的可支持一个或多个动作的 AccessibleAction。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
如果受对象支持，则返回 AccessibleAction；否则返回 null
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleComponent 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
此对象
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
从类 AccessibleContext 复制的描述
获取与此对象关联的 AccessibleSelection，该对象允许选择其 Accessible 子级。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
如果受对象支持，则返回 AccessibleSelection；否则返回 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
从类 AccessibleContext 复制的描述
获取与在显示器上显示文本的此对象关联的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
从类 AccessibleContext 复制的描述
获取与此对象关联的支持 Numerical 值的 AccessibleValue。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
如果受对象支持，则返回 AccessibleValue；否则返回 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
从接口 AccessibleComponent 复制的描述
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
如果支持的话，返回对象的背景色；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 新的背景 Color
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
从接口 AccessibleComponent 复制的描述
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
如果支持的话，返回对象的前景色；否则返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 新的前景 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
从接口 AccessibleComponent 复制的描述
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
如果支持的话，返回对象的 Cursor；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
从接口 AccessibleComponent 复制的描述
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
从接口 AccessibleComponent 复制的描述
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
如果支持的话，返回对象的 Font；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
从接口 AccessibleComponent 复制的描述
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
从接口 AccessibleComponent 复制的描述
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
如果支持的话，返回对象的 FontMetrics；否则返回 null
另请参见：
AccessibleComponent.getFont()

isEnabled

public boolean isEnabled()
从接口 AccessibleComponent 复制的描述
确定是否已启用该对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
从接口 AccessibleComponent 复制的描述
确定此对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
从接口 AccessibleComponent 复制的描述
确定是否正显示对象。通过检查该对象和祖先的可见性可确定这一点。注：即使该对象被另一对象屏蔽（例如，它是下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果正在显示对象，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
从接口 AccessibleComponent 复制的描述
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 相对于对象的坐标系统的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
从接口 AccessibleComponent 复制的描述
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
从接口 AccessibleComponent 复制的描述
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
Point 的实例，该点表示屏幕坐标空间中对象边界的左上角 ；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
从接口 AccessibleComponent 复制的描述
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
从接口 AccessibleComponent 复制的描述
返回本地坐标 Point 包含的可访问子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

getAccessibleIcon

public AccessibleIcon[] getAccessibleIcon()
返回元素渲染器的图标，作为 AccessibleIcon 数组的唯一项；如果渲染器组件不包含任何图标，则返回一个 null 数组。

覆盖：
类 AccessibleContext 中的 getAccessibleIcon
返回：
包含可访问图标的数组；如果不包含任何图标，则返回一个 null 数组
从以下版本开始：
1.3
另请参见：
AccessibleIcon
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JList.DropLocation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JList.DropLocation

java.lang.Object
    继承者  javax.swing.TransferHandler.DropLocation
        继承者  javax.swing.JList.DropLocation
正在封闭类：
JList
public static final class JList.DropLocation
extends TransferHandler.DropLocation

TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。

从以下版本开始：
1.6
另请参见：
JList.getDropLocation()

方法摘要
int | getIndex() 返回列表中应该用来放入放置数据的索引。
boolean | isInsert() 返回此位置是否表示一个插入位置。
String | toString() 返回此放置位置的字符串表示形式。
从类 javax.swing.TransferHandler.DropLocation 继承的方法
getDropPoint
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getIndex

public int getIndex()
返回列表中应该用来放入放置数据的索引。对该值的解释取决于在关联组件上设置的放置模式。如果放置模式是 DropMode.USE_SELECTION 或 DropMode.ON，则返回值为列表中行的索引。如果放置模式是 DropMode.INSERT，则返回值是应该插入数据的位置的索引。如果放置模式是 DropMode.ON_OR_INSERT，则 isInsert() 的值将指示该索引是行的索引还是插入索引。

-1 指示放置操作发生在空格上，无法计算索引。

返回：
放置索引

isInsert

public boolean isInsert()
返回此位置是否表示一个插入位置。

返回：
此位置是否是一个插入位置

toString

public String toString()
返回此放置位置的字符串表示形式。此方法仅用于调试，对于各个实现，所返回字符串的内容和格式可能有所不同。

覆盖：
类 TransferHandler.DropLocation 中的 toString
返回：
此放置位置的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMenu.AccessibleJMenu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JMenu.AccessibleJMenu

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JMenuItem.AccessibleJMenuItem
                            继承者  javax.swing.JMenu.AccessibleJMenu
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, AccessibleText, AccessibleValue, ChangeListener
正在封闭类：
JMenu
protected class JMenu.AccessibleJMenu
extends JMenuItem.AccessibleJMenuItem
implements AccessibleSelection

此类实现 JMenu 类的可访问性支持。它提供适合菜单用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JMenu.AccessibleJMenu()
方法摘要
void | addAccessibleSelection(int i) 选择菜单中的第 i 个菜单。
void | clearAccessibleSelection() 清除对象中的选择，从而对象中没有选择任何项。
Accessible | getAccessibleChild(int i) 返回对象的第 n 个 Accessible 子对象。
int | getAccessibleChildrenCount() 返回该对象中可访问的子对象数。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回当前选择的子菜单（如果选择了），否则返回 null（只能选择一项并且只能选择子菜单，除非菜单项没有保持选中状态）。
int | getAccessibleSelectionCount() 如果当前在此菜单中选择了子菜单，则返回 1。
boolean | isAccessibleChildSelected(int i) 如果选择了此对象的当前子对象（即此子对象为弹出子菜单），则返回 true。
void | removeAccessibleSelection(int i) 从选择中移除第 n 个项。
void | selectAllAccessibleSelection() 如果对象支持多种选择，则通常导致选择对象中的所有选择项。
从类 javax.swing.JMenuItem.AccessibleJMenuItem 继承的方法
stateChanged
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JMenu.AccessibleJMenu

protected JMenu.AccessibleJMenu()
方法详细信息

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回该对象中可访问的子对象数。如果此对象的所有子级都实现 Accessible，则此方法应该返回此对象的子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个 Accessible 子对象。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
该对象的第 n 个 Accessible 子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JMenuItem.AccessibleJMenuItem 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象相关联的 AccessibleSelection。在此类的 Java Accessibility API 的实现中，返回的是此对象，它负责为其本身实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
如果当前在此菜单中选择了子菜单，则返回 1。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
如果当前选择了菜单，则返回 1；否则返回 0

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回当前选择的子菜单（如果选择了），否则返回 null（只能选择一项并且只能选择子菜单，除非菜单项没有保持选中状态）。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选子对象的从零开始的索引
返回：
第 i 个选定的子对象
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
如果选择了此对象的当前子对象（即此子对象为弹出子菜单），则返回 true。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子对象基于零的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
选择菜单中的第 i 个菜单。如果该项为子菜单，则它将弹出以响应此方法。如果已经弹出了不同的项，则此操作将强制其关闭。如果此为已经弹出（已选择）的子菜单，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 要选择的项的索引
另请参见：
AbstractButton.AccessibleAbstractButton.getAccessibleStateSet()

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从选择中移除第 n 个项。一般情况下，一次只能选择一个菜单中的项（如，打开一个弹出子菜单）。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 所选项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，从而对象中没有选择任何项。此操作将关闭任何打开的子菜单。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
如果对象支持多种选择，则通常导致选择对象中的所有选择项。此方法在菜单栏中没有意义，因此不执行任何操作。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMenu.WinListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JMenu.WinListener

java.lang.Object
    继承者  java.awt.event.WindowAdapter
        继承者  javax.swing.JMenu.WinListener
所有已实现的接口：
WindowFocusListener, WindowListener, WindowStateListener, Serializable, EventListener
正在封闭类：
JMenu
protected class JMenu.WinListener
extends WindowAdapter
implements Serializable

观察弹出窗口关闭的侦听器类。当弹出菜单关闭时，侦听器取消选择该菜单。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
JMenu.WinListener(JPopupMenu p)
创建指定弹出菜单的窗口侦听器。
方法摘要
 void windowClosing(WindowEvent e)
从外部关闭弹出菜单时取消选择该菜单。
从类 java.awt.event.WindowAdapter 继承的方法
windowActivated, windowClosed, windowDeactivated, windowDeiconified, windowGainedFocus, windowIconified, windowLostFocus, windowOpened, windowStateChanged
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JMenu.WinListener

public JMenu.WinListener(JPopupMenu p)
创建指定弹出菜单的窗口侦听器。

从以下版本开始：
1.4
方法详细信息

windowClosing

public void windowClosing(WindowEvent e)
从外部关闭弹出菜单时取消选择该菜单。

指定者：
接口 WindowListener 中的 windowClosing
覆盖：
类 WindowAdapter 中的 windowClosing
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMenuBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JMenuBar

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JMenuBar
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, MenuElement
直接已知子类：
BasicInternalFrameTitlePane.SystemMenuBar
public class JMenuBar
extends JComponent
implements Accessible, MenuElement

菜单栏的实现。将 JMenu 对象添加到菜单栏以构造菜单。当用户选择 JMenu 对象时，就会显示其关联的 JPopupMenu，允许用户选择其上的某一个 JMenuItem。

有关使用菜单栏的信息和示例，请参阅 The Java Tutorial 中的 How to Use Menus 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JMenu, JPopupMenu, JMenuItem

嵌套类摘要
protected  class JMenuBar.AccessibleJMenuBar
此类实现 JMenuBar 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JMenuBar()
创建新的菜单栏。
方法摘要
JMenu | add(JMenu c) 将指定的菜单追加到菜单栏的末尾。
void | addNotify() 重写 JComponent.addNotify 以向当前键盘管理器注册此菜单栏。
AccessibleContext | getAccessibleContext() 获取与此 JMenuBar 相关联的 AccessibleContext。
Component | getComponent() 实现为 MenuElement。
Component | getComponentAtIndex(int i) 已过时。 由 getComponent(int i) 取代
int | getComponentIndex(Component c) 返回指定组件的索引。
JMenu | getHelpMenu() 获取菜单栏的帮助菜单。
Insets | getMargin() 返回菜单栏的边框与其菜单之间的空白。
JMenu | getMenu(int index) 返回菜单栏中指定位置的菜单。
int | getMenuCount() 返回菜单栏上的菜单数。
SingleSelectionModel | getSelectionModel() 返回处理单个选择的模型对象。
MenuElement[] | getSubElements() 实现为 MenuElement（返回此菜单栏中的菜单）。
MenuBarUI | getUI() 返回菜单栏的当前 UI。
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
boolean | isBorderPainted() 如果应该绘制菜单栏的边框，则返回 true。
boolean | isSelected() 如果当前已选择了菜单栏的组件，则返回 true。
void | menuSelectionChanged(boolean isIncluded) 实现为 MenuElement（不执行任何操作）。
protected void | paintBorder(Graphics g) 如果 BorderPainted 属性为 true，则绘制菜单栏的边框。
protected String | paramString() 返回此 JMenuBar 的字符串表示形式。
protected boolean | processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed) 子类化以检查所有子菜单。
void | processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 实现为 MenuElement（不执行任何操作）。
void | removeNotify() 重写 JComponent.removeNotify 以在当前键盘管理器中注销此菜单栏。
void | setBorderPainted(boolean b) 设置是否应该绘制边框。
void | setHelpMenu(JMenu menu) 设置用户选择菜单栏中的“帮助”选项时显示的帮助菜单。
void | setMargin(Insets m) 设置菜单栏的边框与其菜单之间的空白。
void | setSelected(Component sel) 设置当前选择的组件，更改选择模型。
void | setSelectionModel(SingleSelectionModel model) 设置处理单个选择的模型对象。
void | setUI(MenuBarUI ui) 设置呈现此组件的 L&F 对象。
void | updateUI() 利用当前外观的值重置 UI 属性。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMenuBar

public JMenuBar()
创建新的菜单栏。

方法详细信息

getUI

public MenuBarUI getUI()
返回菜单栏的当前 UI。

另请参见：
setUI(javax.swing.plaf.MenuBarUI)

setUI

public void setUI(MenuBarUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - 新的 MenuBarUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
利用当前外观的值重置 UI 属性。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "MenuBarUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getSelectionModel

public SingleSelectionModel getSelectionModel()
返回处理单个选择的模型对象。

返回：
SingleSelectionModel 属性
另请参见：
SingleSelectionModel

setSelectionModel

public void setSelectionModel(SingleSelectionModel model)
设置处理单个选择的模型对象。

参数：
model - 要使用的 SingleSelectionModel
另请参见：
SingleSelectionModel

add

public JMenu add(JMenu c)
将指定的菜单追加到菜单栏的末尾。

参数：
c - 要添加的 JMenu 组件
返回：
菜单组件

getMenu

public JMenu getMenu(int index)
返回菜单栏中指定位置的菜单。

参数：
index - 给出菜单栏中位置的整数，其中 0 是第一个位置
返回：
该位置上的 JMenu；如果在该位置上没有 JMenu（即它是一个 JMenuItem），则返回 null

getMenuCount

public int getMenuCount()
返回菜单栏上的菜单数。

返回：
菜单栏中的项数

setHelpMenu

public void setHelpMenu(JMenu menu)
设置用户选择菜单栏中的“帮助”选项时显示的帮助菜单。此方法尚未实现，将抛出异常。

参数：
menu - 向用户提供帮助的 JMenu

getHelpMenu

public JMenu getHelpMenu()
获取菜单栏的帮助菜单。此方法尚未实现，将抛出异常。

返回：
向用户提供帮助的 JMenu

getComponentAtIndex

@Deprecated
public Component getComponentAtIndex(int i)
已过时。 由 getComponent(int i) 取代

返回指定索引处的组件。

参数：
i - 指定位置的整数，其中 0 为第一个
返回：
该位置上的 Component；返回 null 表示索引无效

getComponentIndex

public int getComponentIndex(Component c)
返回指定组件的索引。

参数：
c - 要查找的 Component
返回：
给出组件位置的整数，其中 0 为第一个；如果找不到则为 -1

setSelected

public void setSelected(Component sel)
设置当前选择的组件，更改选择模型。

参数：
sel - 要选择的 Component

isSelected

public boolean isSelected()
如果当前已选择了菜单栏的组件，则返回 true。

返回：
如果已做出选择，则返回 true；否则返回 false

isBorderPainted

public boolean isBorderPainted()
如果应该绘制菜单栏的边框，则返回 true。

返回：
如果应该绘制边框，则返回 true；否则返回 false

setBorderPainted

public void setBorderPainted(boolean b)
设置是否应该绘制边框。

参数：
b - 如果为 true 且边框属性不为 null，则绘制边框。
另请参见：
isBorderPainted()

paintBorder

protected void paintBorder(Graphics g)
如果 BorderPainted 属性为 true，则绘制菜单栏的边框。

覆盖：
类 JComponent 中的 paintBorder
参数：
g - 用于进行绘制的 Graphics 上下文
另请参见：
JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

setMargin

public void setMargin(Insets m)
设置菜单栏的边框与其菜单之间的空白。设置为 null 将导致菜单栏使用默认空白。

参数：
m - 包含空白值的 Insets 对象
另请参见：
Insets

getMargin

public Insets getMargin()
返回菜单栏的边框与其菜单之间的空白。如果以前不存在空白，它将创建一个大小为 0 的默认空白。

返回：
包含空白值的 Insets 对象
另请参见：
Insets

processMouseEvent

public void processMouseEvent(MouseEvent event,
                              MenuElement[] path,
                              MenuSelectionManager manager)
实现为 MenuElement（不执行任何操作）。

指定者：
接口 MenuElement 中的 processMouseEvent
另请参见：
getSubElements()

processKeyEvent

public void processKeyEvent(KeyEvent e,
                            MenuElement[] path,
                            MenuSelectionManager manager)
实现为 MenuElement（不执行任何操作）。

指定者：
接口 MenuElement 中的 processKeyEvent
另请参见：
getSubElements()

menuSelectionChanged

public void menuSelectionChanged(boolean isIncluded)
实现为 MenuElement（不执行任何操作）。

指定者：
接口 MenuElement 中的 menuSelectionChanged
另请参见：
getSubElements()

getSubElements

public MenuElement[] getSubElements()
实现为 MenuElement（返回此菜单栏中的菜单）。这就是实现 MenuElement 接口的原因：以便菜单栏可视为与其他菜单元素相同。

指定者：
接口 MenuElement 中的 getSubElements
返回：
菜单栏中的菜单项所组成的数组。

getComponent

public Component getComponent()
实现为 MenuElement。返回此对象。

指定者：
接口 MenuElement 中的 getComponent
返回：
当前 Component (this)
另请参见：
getSubElements()

paramString

protected String paramString()
返回此 JMenuBar 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JMenuBar 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JMenuBar 相关联的 AccessibleContext。对于 JMenuBar，AccessibleContext 采取 AccessibleJMenuBar 的形式。必要时要创建新的 AccessibleJMenuBar 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
用作此 JMenuBar 的 AccessibleContext 的 AccessibleJMenuBar

processKeyBinding

protected boolean processKeyBinding(KeyStroke ks,
                                    KeyEvent e,
                                    int condition,
                                    boolean pressed)
子类化以检查所有子菜单。

覆盖：
类 JComponent 中的 processKeyBinding
参数：
ks - 被查询的 KeyStroke
e - KeyEvent
condition - 为下列值之一：
  • JComponent.WHEN_FOCUSED
  • JComponent.WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
  • JComponent.WHEN_IN_FOCUSED_WINDOW
pressed - 如果键被按下，则为 true
返回：
如果有该动作的绑定并且已启用该动作，则返回 true
从以下版本开始：
1.3

addNotify

public void addNotify()
重写 JComponent.addNotify 以向当前键盘管理器注册此菜单栏。

覆盖：
类 JComponent 中的 addNotify
另请参见：
JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

removeNotify

public void removeNotify()
重写 JComponent.removeNotify 以在当前键盘管理器中注销此菜单栏。

覆盖：
类 JComponent 中的 removeNotify
另请参见：
JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMenuBar.AccessibleJMenuBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JMenuBar.AccessibleJMenuBar

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JMenuBar.AccessibleJMenuBar
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection
正在封闭类：
JMenuBar
protected class JMenuBar.AccessibleJMenuBar
extends JComponent.AccessibleJComponent
implements AccessibleSelection

此类实现 JMenuBar 类的可访问性支持。它提供适合菜单用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JMenuBar.AccessibleJMenuBar()
方法摘要
void | addAccessibleSelection(int i) 在菜单栏中选择第 n 个菜单，并强制其弹出。
void | clearAccessibleSelection() 清除对象中的选择，从而对象中没有选择任何项。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回当前选择的菜单（如果选择了一个）；否则返回 null。
int | getAccessibleSelectionCount() 如果当前在此菜单栏中选择了菜单，则返回 1。
AccessibleStateSet | getAccessibleStateSet() 获得此对象的可访问性状态设置。
boolean | isAccessibleChildSelected(int i) 如果选择了此对象的当前子级，则返回 true。
void | removeAccessibleSelection(int i) 从对象选择中移除对象中的第 n 个选项。
void | selectAllAccessibleSelection() 如果对象支持多种选择，则通常导致选择对象中的所有选择项。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JMenuBar.AccessibleJMenuBar

protected JMenuBar.AccessibleJMenuBar()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获得此对象的可访问性状态设置。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象相关联的 AccessibleSelection。在此类的 Java Accessibility API 的实现中，返回的是此对象，它负责为其本身实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
如果当前在此菜单栏中选择了菜单，则返回 1。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
如果当前选择了菜单，则返回 1；否则返回 0

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回当前选择的菜单（如果选择了一个）；否则返回 null。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选子对象的从零开始的索引
返回：
第 i 个选定的子对象
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
如果选择了此对象的当前子级，则返回 true。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子级从零开始的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
在菜单栏中选择第 n 个菜单，并强制其弹出。如果另一个菜单已弹出，则此操作将强制其关闭。如果第 n 个菜单已被选择，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
getAccessibleStateSet()

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从对象选择中移除对象中的第 n 个选项。如果当前没有选择第 n 项，则此方法无效。否则，它将关闭弹出菜单。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，从而对象中没有选择任何项。此操作将关闭任何打开的菜单。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
如果对象支持多种选择，则通常导致选择对象中的所有选择项。此方法在菜单栏中没有意义，因此不执行任何操作。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JMenuItem

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JMenuItem
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants
直接已知子类：
JCheckBoxMenuItem, JMenu, JRadioButtonMenuItem
public class JMenuItem
extends AbstractButton
implements Accessible, MenuElement

菜单中的项的实现。菜单项本质上是位于列表中的按钮。当用户选择“按钮”时，则执行与菜单项关联的操作。JPopupMenu 中包含的 JMenuItem 正好执行该功能。

通过 Action 可以配置菜单，并进行一定程度的控制。对菜单项使用 Action 有许多直接配置菜单项所不及的优点。有关更多信息，请参阅支持 Action 的 Swing 组件，可以在 The Java Tutorial 中的 How to Use Actions 一节找到更多信息。

有关更多文档和示例，请参见 The Java Tutorial 中的 How to Use Menus 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JPopupMenu, JMenu, JCheckBoxMenuItem, JRadioButtonMenuItem

嵌套类摘要
protected  class JMenuItem.AccessibleJMenuItem
此类实现 JMenuItem 类的可访问性支持。
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JMenuItem()
创建不带有设置文本或图标的 JMenuItem。
JMenuItem(Action a)
创建从指定的 Action 获取其属性的菜单项。
JMenuItem(Icon icon)
创建带有指定图标的 JMenuItem。
JMenuItem(String text)
创建带有指定文本的 JMenuItem。
JMenuItem(String text, Icon icon)
创建带有指定文本和图标的 JMenuItem。
JMenuItem(String text, int mnemonic)
创建带有指定文本和键盘助记符的 JMenuItem。
方法摘要
protected  void actionPropertyChanged(Action action, String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。
 void addMenuDragMouseListener(MenuDragMouseListener l)
将 MenuDragMouseListener 添加到菜单项。
 void addMenuKeyListener(MenuKeyListener l)
将 MenuKeyListener 添加到菜单项。
protected  void configurePropertiesFromAction(Action a)
在此按钮上设置属性以匹配指定 Action 中的属性。
protected  void fireMenuDragMouseDragged(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected  void fireMenuDragMouseEntered(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected  void fireMenuDragMouseExited(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected  void fireMenuDragMouseReleased(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected  void fireMenuKeyPressed(MenuKeyEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected  void fireMenuKeyReleased(MenuKeyEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected  void fireMenuKeyTyped(MenuKeyEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。
 KeyStroke getAccelerator()
返回作为菜单项的加速器的 KeyStroke。
 AccessibleContext getAccessibleContext()
返回与此 JMenuItem 关联的 AccessibleContext。
 Component getComponent()
返回用于绘制此对象的 java.awt.Component。
 MenuDragMouseListener[] getMenuDragMouseListeners()
返回利用 addMenuDragMouseListener() 添加到此 JMenuItem 的所有 MenuDragMouseListener 组成的数组。
 MenuKeyListener[] getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JMenuItem 的所有 MenuKeyListener 的数组。
 MenuElement[] getSubElements()
此方法返回包含此菜单组件的子菜单组件的数组。
 String getUIClassID()
返回用于构造呈现此组件时使用的 L&F 类名称的后缀。
protected  void init(String text, Icon icon)
利用指定文本和图标初始化菜单项。
 boolean isArmed()
返回菜单项是否被“调出”。
 void menuSelectionChanged(boolean isIncluded)
当选择或取消选择 MenuElement 时由 MenuSelectionManager 调用。
protected  String paramString()
返回此 JMenuItem 的字符串表示形式。
 void processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
 void processMenuDragMouseEvent(MenuDragMouseEvent e)
处理菜单中的鼠标拖动。
 void processMenuKeyEvent(MenuKeyEvent e)
处理菜单中的快捷键。
 void processMouseEvent(MouseEvent e, MenuElement[] path, MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。
 void removeMenuDragMouseListener(MenuDragMouseListener l)
从菜单项中移除 MenuDragMouseListener。
 void removeMenuKeyListener(MenuKeyListener l)
从菜单项中移除 MenuKeyListener。
 void setAccelerator(KeyStroke keyStroke)
设置修改键，它能直接调用菜单项的操作侦听器而不必显示菜单的层次结构。
 void setArmed(boolean b)
将菜单项标识为“调出”。
 void setEnabled(boolean b)
启用或禁用菜单项。
 void setModel(ButtonModel newModel)
设置此按钮表示的模型。
 void setUI(MenuItemUI ui)
设置呈现此组件的外观对象。
 void updateUI()
利用当前外观的值重置 UI 属性。
从类 javax.swing.AbstractButton 继承的方法
addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JMenuItem

public JMenuItem()
创建不带有设置文本或图标的 JMenuItem。

JMenuItem

public JMenuItem(Icon icon)
创建带有指定图标的 JMenuItem。

参数：
icon - JMenuItem 的图标

JMenuItem

public JMenuItem(String text)
创建带有指定文本的 JMenuItem。

参数：
text - JMenuItem 的文本

JMenuItem

public JMenuItem(Action a)
创建从指定的 Action 获取其属性的菜单项。

参数：
a - JMenuItem 的操作
从以下版本开始：
1.3

JMenuItem

public JMenuItem(String text,
                 Icon icon)
创建带有指定文本和图标的 JMenuItem。

参数：
text - JMenuItem 的文本
icon - JMenuItem 的图标

JMenuItem

public JMenuItem(String text,
                 int mnemonic)
创建带有指定文本和键盘助记符的 JMenuItem。

参数：
text - JMenuItem 的文本
mnemonic - JMenuItem 的键盘助记符
方法详细信息

setModel

public void setModel(ButtonModel newModel)
设置此按钮表示的模型。

覆盖：
类 AbstractButton 中的 setModel
参数：
newModel - 新的 ButtonModel
另请参见：
AbstractButton.getModel()

init

protected void init(String text,
                    Icon icon)
利用指定文本和图标初始化菜单项。

覆盖：
类 AbstractButton 中的 init
参数：
text - JMenuItem 的文本
icon - JMenuItem 的图标

setUI

public void setUI(MenuItemUI ui)
设置呈现此组件的外观对象。

参数：
ui - JMenuItemUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
利用当前外观的值重置 UI 属性。

覆盖：
类 AbstractButton 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回用于构造呈现此组件时使用的 L&F 类名称的后缀。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "MenuItemUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setArmed

public void setArmed(boolean b)
将菜单项标识为“调出”。如果鼠标指针在此项上时释放鼠标按钮，则激发菜单的操作事件。如果在其他地方释放鼠标按钮，则不激发事件，而菜单项将缩回。

参数：
b - true 表示调出菜单项以供选择

isArmed

public boolean isArmed()
返回菜单项是否被“调出”。

返回：
如果菜单项为调出状态，可供选择，则返回 true
另请参见：
setArmed(boolean)

setEnabled

public void setEnabled(boolean b)
启用或禁用菜单项。

覆盖：
类 AbstractButton 中的 setEnabled
参数：
b - true 表示启用项
另请参见：
Component.isEnabled(), Component.isLightweight()

setAccelerator

public void setAccelerator(KeyStroke keyStroke)
设置修改键，它能直接调用菜单项的操作侦听器而不必显示菜单的层次结构。UI 负责安装正确的操作。注意，当键入键盘加速器时，不管目前是否显示菜单，它都会运行。

参数：
keyStroke - 将作为加速器的 KeyStroke

getAccelerator

public KeyStroke getAccelerator()
返回作为菜单项的加速器的 KeyStroke。

返回：
标识加速键的 KeyStroke 对象

configurePropertiesFromAction

protected void configurePropertiesFromAction(Action a)
在此按钮上设置属性以匹配指定 Action 中的属性。有关关于设置了哪些属性的更多信息，请参阅支持 Action 的 Swing 组件。

覆盖：
类 AbstractButton 中的 configurePropertiesFromAction
参数：
a - 从中获取属性的 Action，或为 null
从以下版本开始：
1.3
另请参见：
Action, AbstractButton.setAction(javax.swing.Action)

actionPropertyChanged

protected void actionPropertyChanged(Action action,
                                     String propertyName)
更新按钮的状态以响应相关的操作中的属性更改。从 createActionPropertyChangeListener 返回的 PropertyChangeListener 中调用此方法。子类通常不需要调用此方法。支持其他 Action 属性的子类应该重写此方法以及 configurePropertiesFromAction。

有关此方法设置的属性的列表，请参阅支持 Action 的 Swing 组件处的表。

覆盖：
类 AbstractButton 中的 actionPropertyChanged
参数：
action - 与此按钮关联的 Action
propertyName - 已更改属性的名称
从以下版本开始：
1.6
另请参见：
Action, AbstractButton.configurePropertiesFromAction(javax.swing.Action)

processMouseEvent

public void processMouseEvent(MouseEvent e,
                              MenuElement[] path,
                              MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的鼠标事件并更改菜单选择。

注：不必将事件转发到子组件。此操作可以通过 MenuSelectionManager 自动完成。

指定者：
接口 MenuElement 中的 processMouseEvent
参数：
e - MouseEvent
path - MenuElement 路径数组
manager - MenuSelectionManager

processKeyEvent

public void processKeyEvent(KeyEvent e,
                            MenuElement[] path,
                            MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。

注：不必将事件转发到子组件。此操作可以通过 MenuSelectionManager 自动完成。

指定者：
接口 MenuElement 中的 processKeyEvent
参数：
e - KeyEvent
path - MenuElement 路径数组
manager - MenuSelectionManager

processMenuDragMouseEvent

public void processMenuDragMouseEvent(MenuDragMouseEvent e)
处理菜单中的鼠标拖动。

参数：
e - MenuDragMouseEvent 对象

processMenuKeyEvent

public void processMenuKeyEvent(MenuKeyEvent e)
处理菜单中的快捷键。

参数：
e - MenuKeyEvent 对象

fireMenuDragMouseEntered

protected void fireMenuDragMouseEntered(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。

参数：
event - MenuMouseDragEvent
另请参见：
EventListenerList

fireMenuDragMouseExited

protected void fireMenuDragMouseExited(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。

参数：
event - MenuDragMouseEvent
另请参见：
EventListenerList

fireMenuDragMouseDragged

protected void fireMenuDragMouseDragged(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。

参数：
event - MenuDragMouseEvent
另请参见：
EventListenerList

fireMenuDragMouseReleased

protected void fireMenuDragMouseReleased(MenuDragMouseEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。

参数：
event - MenuDragMouseEvent
另请参见：
EventListenerList

fireMenuKeyPressed

protected void fireMenuKeyPressed(MenuKeyEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。

参数：
event - MenuKeyEvent
另请参见：
EventListenerList

fireMenuKeyReleased

protected void fireMenuKeyReleased(MenuKeyEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。

参数：
event - MenuKeyEvent
另请参见：
EventListenerList

fireMenuKeyTyped

protected void fireMenuKeyTyped(MenuKeyEvent event)
通知所有对此事件类型上的通知感兴趣的已注册侦听器。

参数：
event - MenuKeyEvent
另请参见：
EventListenerList

menuSelectionChanged

public void menuSelectionChanged(boolean isIncluded)
当选择或取消选择 MenuElement 时由 MenuSelectionManager 调用。

指定者：
接口 MenuElement 中的 menuSelectionChanged
参数：
isIncluded - 如果此菜单项位于发生更改的菜单路径部分，则为 true；如果此菜单项位于发生更改的菜单路径部分，但该路径的这一特殊部分与更改前相同，则为 false
另请参见：
MenuSelectionManager.setSelectedPath(MenuElement[])

getSubElements

public MenuElement[] getSubElements()
此方法返回包含此菜单组件的子菜单组件的数组。

指定者：
接口 MenuElement 中的 getSubElements
返回：
MenuElement 的数组

getComponent

public Component getComponent()
返回用于绘制此对象的 java.awt.Component。返回的组件用于转换事件并检测事件是否位于菜单组件中。

指定者：
接口 MenuElement 中的 getComponent
返回：
绘制此菜单项的 Component

addMenuDragMouseListener

public void addMenuDragMouseListener(MenuDragMouseListener l)
将 MenuDragMouseListener 添加到菜单项。

参数：
l - 要添加的 MenuDragMouseListener

removeMenuDragMouseListener

public void removeMenuDragMouseListener(MenuDragMouseListener l)
从菜单项中移除 MenuDragMouseListener。

参数：
l - 要移除的 MenuDragMouseListener

getMenuDragMouseListeners

public MenuDragMouseListener[] getMenuDragMouseListeners()
返回利用 addMenuDragMouseListener() 添加到此 JMenuItem 的所有 MenuDragMouseListener 组成的数组。

返回：
添加的所有 MenuDragMouseListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

addMenuKeyListener

public void addMenuKeyListener(MenuKeyListener l)
将 MenuKeyListener 添加到菜单项。

参数：
l - 要添加的 MenuKeyListener

removeMenuKeyListener

public void removeMenuKeyListener(MenuKeyListener l)
从菜单项中移除 MenuKeyListener。

参数：
l - 要移除的 MenuKeyListener

getMenuKeyListeners

public MenuKeyListener[] getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JMenuItem 的所有 MenuKeyListener 的数组。

返回：
添加的所有 MenuKeyListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

paramString

protected String paramString()
返回此 JMenuItem 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 AbstractButton 中的 paramString
返回：
此 JMenuItem 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
返回与此 JMenuItem 关联的 AccessibleContext。对于 JMenuItem，AccessibleContext 采用的是 AccessibleJMenuItem 的形式。必要时创建一个新的 AccessibleJMenuItme 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
充当此 JMenuItem 的 AccessibleContext 的 AccessibleJMenuItem
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JMenuItem.AccessibleJMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JMenuItem.AccessibleJMenuItem

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JMenuItem.AccessibleJMenuItem
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
直接已知子类：
JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JMenu.AccessibleJMenu, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
正在封闭类：
JMenuItem
protected class JMenuItem.AccessibleJMenuItem
extends AbstractButton.AccessibleAbstractButton
implements ChangeListener

此类实现 JMenuItem 类的可访问性支持。它提供适合菜单项用户界面元素的 Java Accessibility API 实现。

警告：此类已序列化的对象将不再与以后的 Swing 版本兼容。当前的序列化支持适合于在运行相同 Swing 版本的应用程序之间短期存储或 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
void | stateChanged(ChangeEvent e) 支持更改侦听器接口并激发属性更改。
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

stateChanged

public void stateChanged(ChangeEvent e)
支持更改侦听器接口并激发属性更改。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JOptionPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JOptionPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JOptionPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JOptionPane
extends JComponent
implements Accessible

JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。有关使用 JOptionPane 的信息，请参见 The Java Tutorial 中的 How to Make Dialogs 一节。

虽然由于方法数多使 JOptionPane 类可能显得复杂，但几乎所有此类的使用都是对下列静态 showXxxDialog 方法之一的单行调用：

方法名 | 描述
showConfirmDialog | 询问一个确认问题，如 yes/no/cancel。
showInputDialog | 提示要求某些输入。
showMessageDialog | 告知用户某事已发生。
showOptionDialog | 上述三项的大统一 (Grand Unification)。
所有这些方法还可能以 showInternalXXX 风格出现，该风格使用内部窗体来保存对话框（请参见 JInternalFrame）。此外还定义了多种便捷方法，这些方法重载那些基本方法，使用不同的参数列表。

所有对话框都是有模式的。在用户交互完成之前，每个 showXxxDialog 方法都一直阻塞调用者。

图标 消息
输入值
选项按钮
这些对话框的基本外形通常与右图类似，尽管各种外观从根本上决定着最后结果。尤其是，外观可以调整布局以适应选项窗格的 ComponentOrientation 属性。

参数：
这些方法的参数遵守一致的模式：

parentComponent
定义作为此对话框的父对话框的 Component。通过两种方式使用此参数：包含它的 Frame 可以用作对话框的父 Frame，在对话框的位置使用其屏幕坐标。一般情况下，将对话框紧靠组件置于其之下。此参数可以为 null，在这种情况下，默认的 Frame 用作父级，并且对话框将居中位于屏幕上（取决于 L&F）。
message
要置于对话框中的描述消息。在最常见的应用中，message 就是一个 String 或 String 常量。不过，此参数的类型实际上是 Object。其解释依赖于其类型：
Object[]
对象数组被解释为在纵向堆栈中排列的一系列 message（每个对象一个）。解释是递归式的，即根据其类型解释数组中的每个对象。
Component
该 Component 在对话框中显示。
Icon
该 Icon 被包装在 JLabel 中并在对话框中显示。
其他
该对象通过调用其 toString 方法被转换为 String。结果被包装在 JLabel 中显示。
messageType
定义 message 的样式。外观管理器根据此值对对话框进行不同地布置，并且通常提供默认图标。可能的值为：
  • ERROR_MESSAGE
  • INFORMATION_MESSAGE
  • WARNING_MESSAGE
  • QUESTION_MESSAGE
  • PLAIN_MESSAGE
optionType
定义在对话框的底部显示的选项按钮的集合：
  • DEFAULT_OPTION
  • YES_NO_OPTION
  • YES_NO_CANCEL_OPTION
  • OK_CANCEL_OPTION
用户并非仅限于使用此选项按钮集合。使用 options 参数可以提供想使用的任何按钮。
options
将在对话框底部显示的选项按钮集合的更详细描述。options 参数的常规值是 String 数组，但是参数类型是 Object 数组。根据对象的以下类型为每个对象创建一个按钮：
Component
该组件被直接添加到按钮行中。
Icon
创建的 JButton 以此图标作为其标签。
其他
该 Object 通过使用其 toString 方法转换为字符串，并使用该结果作为 JButton 的标签。
icon
要置于对话框中的装饰性图标。图标的默认值由 messageType 参数确定。
title
对话框的标题。
initialValue
默认选择（输入值）。

当选择更改时，调用生成 PropertyChangeEvent 的 setValue 方法。

如果已为所有输入 setWantsInput 配置了 JOptionPane，则还可以侦听绑定属性 JOptionPane.INPUT_VALUE_PROPERTY，以确定何时用户输入或选择了值。

当其中一个 showXxxDialog 方法返回整数时，可能的值为：

  • YES_OPTION
  • NO_OPTION
  • CANCEL_OPTION
  • OK_OPTION
  • CLOSED_OPTION
示例：
显示一个错误对话框，该对话框显示的 message 为 'alert'：
JOptionPane.showMessageDialog(null, "alert", "alert", JOptionPane.ERROR_MESSAGE);

显示一个内部信息对话框，其 message 为 'information'：
JOptionPane.showInternalMessageDialog(frame, "information",
      "information", JOptionPane.INFORMATION_MESSAGE);

显示一个信息面板，其 options 为 "yes/no"，message 为 'choose one'：
JOptionPane.showConfirmDialog(null,
      "choose one", "choose one", JOptionPane.YES_NO_OPTION);

显示一个内部信息对话框，其 options 为 "yes/no/cancel"，message 为 'please choose one'，并具有 title 信息：
JOptionPane.showInternalConfirmDialog(frame,
      "please choose one", "information",
      JOptionPane.YES_NO_CANCEL_OPTION, JOptionPane.INFORMATION_MESSAGE);

显示一个警告对话框，其 options 为 OK、CANCEL，title 为 'Warning'，message 为 'Click OK to continue'：
Object[] options = { "OK", "CANCEL" };
JOptionPane.showOptionDialog(null, "Click OK to continue", "Warning",
      JOptionPane.DEFAULT_OPTION, JOptionPane.WARNING_MESSAGE,
      null, options, options[0]);

显示一个要求用户键入 String 的对话框：
String inputValue = JOptionPane.showInputDialog("Please input a value");

显示一个要求用户选择 String 的对话框：
Object[] possibleValues = { "First", "Second", "Third" };
Object selectedValue = JOptionPane.showInputDialog(null,
      "Choose one", "Input",
      JOptionPane.INFORMATION_MESSAGE, null,
      possibleValues, possibleValues[0]);

直接使用：
要直接创建和使用 JOptionPane，标准模式大致如下：
     JOptionPane pane = new JOptionPane(arguments);
     pane.set.Xxxx(...); // Configure
     JDialog dialog = pane.createDialog(parentComponent, title);
     dialog.show();
     Object selectedValue = pane.getValue();
     if(selectedValue == null)
       return CLOSED_OPTION;
     //If there is not an array of option buttons:
     if(options == null) {
       if(selectedValue instanceof Integer)
          return ((Integer)selectedValue).intValue();
       return CLOSED_OPTION;
     }
     //If there is an array of option buttons:
     for(int counter = 0, maxCounter = options.length;
        counter < maxCounter; counter++) {
        if(options[counter].equals(selectedValue))
        return counter;
     }
     return CLOSED_OPTION;

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JInternalFrame

嵌套类摘要
protected  class JOptionPane.AccessibleJOptionPane
此类实现对 JOptionPane 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | CANCEL_OPTION 选择 CANCEL 时从类方法返回的值。
static int | CLOSED_OPTION 用户没有做出任何选择而关闭了窗口时从类方法返回的值，很可能将此值视为 CANCEL_OPTION 或 NO_OPTION。
static int | DEFAULT_OPTION 意味着外观不应该提供任何选项的类型，即仅使用取自 JOptionPane 的选项。
static int | ERROR_MESSAGE 用于错误消息。
protected Icon | icon 在窗格中使用的图标。
static String | ICON_PROPERTY icon 的绑定属性名。
static int | INFORMATION_MESSAGE 用于信息消息。
static String | INITIAL_SELECTION_VALUE_PROPERTY initialSelectionValue 的绑定属性名。
static String | INITIAL_VALUE_PROPERTY initialValue 的绑定属性名。
protected Object | initialSelectionValue 要在 selectionValues 中选择的初始值。
protected Object | initialValue 应该在 options 中最初选择的值。
static String | INPUT_VALUE_PROPERTY inputValue 的绑定属性名。
protected Object | inputValue 用户已输入的值。
protected Object | message 要显示的消息。
static String | MESSAGE_PROPERTY message 的绑定属性名。
static String | MESSAGE_TYPE_PROPERTY type 的绑定属性名。
protected int | messageType 消息类型。
static int | NO_OPTION 选择 NO 时从类方法返回的值。
static int | OK_CANCEL_OPTION 用于 showConfirmDialog 的类型。
static int | OK_OPTION 选择 OK 时从类方法返回的值。
static String | OPTION_TYPE_PROPERTY optionType 的绑定属性名。
protected Object[] | options 要向用户显示的选项。
static String | OPTIONS_PROPERTY option 的绑定属性名。
protected int | optionType 选项类型，DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION 之一。
static int | PLAIN_MESSAGE 未使用图标。
static int | QUESTION_MESSAGE 用于问题。
static String | SELECTION_VALUES_PROPERTY selectionValues 的绑定属性名。
protected Object[] | selectionValues 用户可以从中选择值的数组。
static Object | UNINITIALIZED_VALUE 指示用户尚未选择值。
protected Object | value 当前选择的值，该值将为有效选项或者 UNINITIALIZED_VALUE 或 null。
static String | VALUE_PROPERTY value 的绑定属性名。
static String | WANTS_INPUT_PROPERTY wantsInput 的绑定属性名。
protected boolean | wantsInput 如果为 true，则向用户提供 UI 窗口小部件以获取输入。
static int | WARNING_MESSAGE 用于警告消息。
static int | YES_NO_CANCEL_OPTION 用于 showConfirmDialog 的类型。
static int | YES_NO_OPTION 用于 showConfirmDialog 的类型。
static int | YES_OPTION 选择 YES 时从类方法返回的值。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JOptionPane()
创建一个带有测试消息的 JOptionPane。
JOptionPane(Object message)
创建一个显示消息的 JOptionPane 的实例，使其使用 UI 提供的普通消息消息类型和默认选项。
JOptionPane(Object message, int messageType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和默认选项。
JOptionPane(Object message, int messageType, int optionType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和选项。
JOptionPane(Object message, int messageType, int optionType, Icon icon)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。
JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
JOptionPane(Object message, int messageType, int optionType, Icon icon, Object[] options, Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。
方法摘要
JDialog | createDialog(Component parentComponent, String title) 创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。
JDialog | createDialog(String title) 创建并返回一个新的带有指定标题的无父 JDialog。
JInternalFrame | createInternalFrame(Component parentComponent, String title) 创建并返回 JInternalFrame 的实例。
AccessibleContext | getAccessibleContext() 返回与此 JOptionPane 相关联的 AccessibleContext。
static JDesktopPane | getDesktopPaneForComponent(Component parentComponent) 返回指定组件的桌面窗格。
static Frame | getFrameForComponent(Component parentComponent) 返回指定组件的 Frame。
Icon | getIcon() 返回此窗格显示的图标。
Object | getInitialSelectionValue() 返回（根据最初选择）向用户显示的输入值。
Object | getInitialValue() 返回初始值。
Object | getInputValue() 如果 wantsInput 为 true，则返回用户已输入的值。
int | getMaxCharactersPerLineCount() 返回要置于消息的行中的最大字符数。
Object | getMessage() 返回此窗格显示的消息对象。
int | getMessageType() 返回消息类型。
Object[] | getOptions() 返回用户可以作出的选择。
int | getOptionType() 返回显示的选项类型。
static Frame | getRootFrame() 返回用于不提供窗体的类方法中的 Frame。
Object[] | getSelectionValues() 返回输入选择值。
OptionPaneUI | getUI() 返回实现此组件 L&F 的 UI 对象。
String | getUIClassID() 返回实现此组件 L&F 的 UI 类的名称。
Object | getValue() 返回用户所选值。
boolean | getWantsInput() 返回 wantsInput 属性的值。
protected String | paramString() 返回此 JOptionPane 的字符串表示形式。
void | selectInitialValue() 请求选择初始值，该请求将焦点设置为初始值。
void | setIcon(Icon newIcon) 设置要显示的图标。
void | setInitialSelectionValue(Object newValue) 设置（根据选择）最初向用户显示的输入值。
void | setInitialValue(Object newInitialValue) 设置要启用的初始值，即最初显示窗格时处于焦点状态的 Component。
void | setInputValue(Object newValue) 设置由用户选择或输入的输入值。
void | setMessage(Object newMessage) 设置选项窗格的消息对象。
void | setMessageType(int newType) 设置选项窗格的消息类型。
void | setOptions(Object[] newOptions) 设置此窗格显示的选项。
void | setOptionType(int newType) 设置要显示的选项。
static void | setRootFrame(Frame newRootFrame) 设置窗体，以用于不提供窗体的类方法。
void | setSelectionValues(Object[] newValues) 设置窗格的输入选择值，该窗格向用户提供可以从中进行选择的项列表。
void | setUI(OptionPaneUI ui) 设置实现此组件 L&F 的 UI 对象。
void | setValue(Object newValue) 设置用户所选值。
void | setWantsInput(boolean newValue) 设置 wantsInput 属性。
static int | showConfirmDialog(Component parentComponent, Object message) 调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。
static int | showConfirmDialog(Component parentComponent, Object message, String title, int optionType) 调出一个由 optionType 参数确定其中选项数的对话框。
static int | showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType) 调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。
static int | showConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon) 调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。
static String | showInputDialog(Component parentComponent, Object message) 显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String | showInputDialog(Component parentComponent, Object message, Object initialSelectionValue) 显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。
static String | showInputDialog(Component parentComponent, Object message, String title, int messageType) 显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。
static Object | showInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue) 提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。
static String | showInputDialog(Object message) 显示请求用户输入的问题消息对话框。
static String | showInputDialog(Object message, Object initialSelectionValue) 显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。
static int | showInternalConfirmDialog(Component parentComponent, Object message) 调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。
static int | showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType) 调出一个由 optionType 参数确定其中选项数的内部对话框面板。
static int | showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType) 调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。
static int | showInternalConfirmDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon) 调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。
static String | showInternalInputDialog(Component parentComponent, Object message) 显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。
static String | showInternalInputDialog(Component parentComponent, Object message, String title, int messageType) 显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。
static Object | showInternalInputDialog(Component parentComponent, Object message, String title, int messageType, Icon icon, Object[] selectionValues, Object initialSelectionValue) 提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。
static void | showInternalMessageDialog(Component parentComponent, Object message) 调出内部确认对话框面板。
static void | showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType) 调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。
static void | showInternalMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon) 调出一个显示消息的内部对话框面板，为其指定了所有参数。
static int | showInternalOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue) 调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
static void | showMessageDialog(Component parentComponent, Object message) 调出标题为 "Message" 的信息消息对话框。
static void | showMessageDialog(Component parentComponent, Object message, String title, int messageType) 调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。
static void | showMessageDialog(Component parentComponent, Object message, String title, int messageType, Icon icon) 调出一个显示信息的对话框，为其指定了所有参数。
static int | showOptionDialog(Component parentComponent, Object message, String title, int optionType, int messageType, Icon icon, Object[] options, Object initialValue) 调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。
void | updateUI() UIManager 发出的关于 L&F 已改变的通知。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

UNINITIALIZED_VALUE

public static final Object UNINITIALIZED_VALUE
指示用户尚未选择值。

DEFAULT_OPTION

public static final int DEFAULT_OPTION
意味着外观不应该提供任何选项的类型，即仅使用取自 JOptionPane 的选项。

另请参见：
常量字段值

YES_NO_OPTION

public static final int YES_NO_OPTION
用于 showConfirmDialog 的类型。

另请参见：
常量字段值

YES_NO_CANCEL_OPTION

public static final int YES_NO_CANCEL_OPTION
用于 showConfirmDialog 的类型。

另请参见：
常量字段值

OK_CANCEL_OPTION

public static final int OK_CANCEL_OPTION
用于 showConfirmDialog 的类型。

另请参见：
常量字段值

YES_OPTION

public static final int YES_OPTION
选择 YES 时从类方法返回的值。

另请参见：
常量字段值

NO_OPTION

public static final int NO_OPTION
选择 NO 时从类方法返回的值。

另请参见：
常量字段值

CANCEL_OPTION

public static final int CANCEL_OPTION
选择 CANCEL 时从类方法返回的值。

另请参见：
常量字段值

OK_OPTION

public static final int OK_OPTION
选择 OK 时从类方法返回的值。

另请参见：
常量字段值

CLOSED_OPTION

public static final int CLOSED_OPTION
用户没有做出任何选择而关闭了窗口时从类方法返回的值，很可能将此值视为 CANCEL_OPTION 或 NO_OPTION。

另请参见：
常量字段值

ERROR_MESSAGE

public static final int ERROR_MESSAGE
用于错误消息。

另请参见：
常量字段值

INFORMATION_MESSAGE

public static final int INFORMATION_MESSAGE
用于信息消息。

另请参见：
常量字段值

WARNING_MESSAGE

public static final int WARNING_MESSAGE
用于警告消息。

另请参见：
常量字段值

QUESTION_MESSAGE

public static final int QUESTION_MESSAGE
用于问题。

另请参见：
常量字段值

PLAIN_MESSAGE

public static final int PLAIN_MESSAGE
未使用图标。

另请参见：
常量字段值

ICON_PROPERTY

public static final String ICON_PROPERTY
icon 的绑定属性名。

另请参见：
常量字段值

MESSAGE_PROPERTY

public static final String MESSAGE_PROPERTY
message 的绑定属性名。

另请参见：
常量字段值

VALUE_PROPERTY

public static final String VALUE_PROPERTY
value 的绑定属性名。

另请参见：
常量字段值

OPTIONS_PROPERTY

public static final String OPTIONS_PROPERTY
option 的绑定属性名。

另请参见：
常量字段值

INITIAL_VALUE_PROPERTY

public static final String INITIAL_VALUE_PROPERTY
initialValue 的绑定属性名。

另请参见：
常量字段值

MESSAGE_TYPE_PROPERTY

public static final String MESSAGE_TYPE_PROPERTY
type 的绑定属性名。

另请参见：
常量字段值

OPTION_TYPE_PROPERTY

public static final String OPTION_TYPE_PROPERTY
optionType 的绑定属性名。

另请参见：
常量字段值

SELECTION_VALUES_PROPERTY

public static final String SELECTION_VALUES_PROPERTY
selectionValues 的绑定属性名。

另请参见：
常量字段值

INITIAL_SELECTION_VALUE_PROPERTY

public static final String INITIAL_SELECTION_VALUE_PROPERTY
initialSelectionValue 的绑定属性名。

另请参见：
常量字段值

INPUT_VALUE_PROPERTY

public static final String INPUT_VALUE_PROPERTY
inputValue 的绑定属性名。

另请参见：
常量字段值

WANTS_INPUT_PROPERTY

public static final String WANTS_INPUT_PROPERTY
wantsInput 的绑定属性名。

另请参见：
常量字段值

icon

protected transient Icon icon
在窗格中使用的图标。

message

protected transient Object message
要显示的消息。

options

protected transient Object[] options
要向用户显示的选项。

initialValue

protected transient Object initialValue
应该在 options 中最初选择的值。

messageType

protected int messageType
消息类型。

optionType

protected int optionType
选项类型，DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION 之一。

value

protected transient Object value
当前选择的值，该值将为有效选项或者 UNINITIALIZED_VALUE 或 null。

selectionValues

protected transient Object[] selectionValues
用户可以从中选择值的数组。外观将提供从中做出选择的 UI 组件。

inputValue

protected transient Object inputValue
用户已输入的值。

initialSelectionValue

protected transient Object initialSelectionValue
要在 selectionValues 中选择的初始值。

wantsInput

protected boolean wantsInput
如果为 true，则向用户提供 UI 窗口小部件以获取输入。

构造方法详细信息

JOptionPane

public JOptionPane()
创建一个带有测试消息的 JOptionPane。

JOptionPane

public JOptionPane(Object message)
创建一个显示消息的 JOptionPane 的实例，使其使用 UI 提供的普通消息消息类型和默认选项。

参数：
message - 要显示的 Object

JOptionPane

public JOptionPane(Object message,
                   int messageType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和默认选项。

参数：
message - 要显示的 Object
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE

JOptionPane

public JOptionPane(Object message,
                   int messageType,
                   int optionType)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型和选项。

参数：
message - 要显示的 Object
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
optionType - 要在窗格中显示的选项：DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION、OK_CANCEL_OPTION

JOptionPane

public JOptionPane(Object message,
                   int messageType,
                   int optionType,
                   Icon icon)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、选项和图标。

参数：
message - 要显示的 Object
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
optionType - 要在窗格中显示的选项：DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION、OK_CANCEL_OPTION
icon - 要显示的 Icon 图像

JOptionPane

public JOptionPane(Object message,
                   int messageType,
                   int optionType,
                   Icon icon,
                   Object[] options)
创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。最初没有选择任何选项。

options 对象应该包含 Component（直接添加的）或 String（包装在 JButton 中）的实例。如果提供 Component，则必须确保单击 Component 时，它向创建的 JOptionPane 传递消息 setValue。

参数：
message - 要显示的 Object
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
optionType - 要在窗格中显示的选项：DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION、OK_CANCEL_OPTION
icon - 要显示的 Icon 图像
options - 用户可以选择的选项

JOptionPane

public JOptionPane(Object message,
                   int messageType,
                   int optionType,
                   Icon icon,
                   Object[] options,
                   Object initialValue)
在指定最初选择的选项的前提下，创建一个显示消息的 JOptionPane 的实例，使其具有指定的消息类型、图标和选项。

参数：
message - 要显示的 Object
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
optionType - 要在窗格中显示的选项：DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION、OK_CANCEL_OPTION
icon - 要显示的图标图像
options - 用户可以选择的选项
initialValue - 最初选择的选项；如果为 null，则不做最初选择；只有在使用 options 时才有意义
方法详细信息

showInputDialog

public static String showInputDialog(Object message)
                              throws HeadlessException
显示请求用户输入的问题消息对话框。该对话框使用默认的边框，通常意味着在屏幕上居中显示。

参数：
message - 要显示的 Object
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showInputDialog

public static String showInputDialog(Object message,
                                     Object initialSelectionValue)
显示请求用户输入的问题消息对话框，它带有已初始化为 initialSelectionValue 的输入值。该对话框使用默认的窗体，通常意味着在屏幕上居中显示。

参数：
message - 要显示的 Object
initialSelectionValue - 用于初始化输入字段的值
从以下版本开始：
1.4

showInputDialog

public static String showInputDialog(Component parentComponent,
                                     Object message)
                              throws HeadlessException
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。该对话框显示于 Component 的窗体的上部，通常位于 Component 之下。

参数：
parentComponent - 对话框的父 Component
message - 要显示的 Object
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showInputDialog

public static String showInputDialog(Component parentComponent,
                                     Object message,
                                     Object initialSelectionValue)
显示请求用户输入内容的问题消息对话框，它以 parentComponent 为父级。输入值将被初始化为 initialSelectionValue。该对话框显示于 Component 的窗体的上部，通常位于 Component 之下。

参数：
parentComponent - 对话框的父 Component
message - 要显示的 Object
initialSelectionValue - 用于初始化输入字段的值
从以下版本开始：
1.4

showInputDialog

public static String showInputDialog(Component parentComponent,
                                     Object message,
                                     String title,
                                     int messageType)
                              throws HeadlessException
显示请求用户输入内容的对话框，它以 parentComponent 为父级，该对话框的标题为 title，消息类型为 messageType。

参数：
parentComponent - 对话框的父 Component
message - 要显示的 Object
title - 要在对话框的标题栏中显示的 String
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showInputDialog

public static Object showInputDialog(Component parentComponent,
                                     Object message,
                                     String title,
                                     int messageType,
                                     Icon icon,
                                     Object[] selectionValues,
                                     Object initialSelectionValue)
                              throws HeadlessException
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的对话框中输入内容。用户可以从 selectionValues 中进行选择，其中 null 表示用户可以输入想输入的任何内容，通常依靠 JTextField 来实现。initialSelectionValue 是用于提示用户的初始值。由 UI 决定如何最好的表示 selectionValues，但通常情况下将使用 JComboBox、JList 或 JTextField。

参数：
parentComponent - 对话框的父 Component
message - 要显示的 Object
title - 要在对话框的标题栏中显示的 String
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 要显示的 Icon 图像
selectionValues - 给出可能选择的 Object 数组
initialSelectionValue - 用于初始化输入字段的值
返回：
用户输入；返回 null 意味着用户取消了输入
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showMessageDialog

public static void showMessageDialog(Component parentComponent,
                                     Object message)
                              throws HeadlessException
调出标题为 "Message" 的信息消息对话框。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showMessageDialog

public static void showMessageDialog(Component parentComponent,
                                     Object message,
                                     String title,
                                     int messageType)
                              throws HeadlessException
调出对话框，它显示使用由 messageType 参数确定的默认图标的 message。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
title - 对话框的标题字符串
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showMessageDialog

public static void showMessageDialog(Component parentComponent,
                                     Object message,
                                     String title,
                                     int messageType,
                                     Icon icon)
                              throws HeadlessException
调出一个显示信息的对话框，为其指定了所有参数。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
title - 对话框的标题字符串
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 要在对话框中显示的图标，该图标可以帮助用户识别要显示的消息种类
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showConfirmDialog

public static int showConfirmDialog(Component parentComponent,
                                    Object message)
                             throws HeadlessException
调出带有选项 Yes、No 和 Cancel 的对话框；标题为 Select an Option。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
返回：
指示用户所选选项的整数
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showConfirmDialog

public static int showConfirmDialog(Component parentComponent,
                                    Object message,
                                    String title,
                                    int optionType)
                             throws HeadlessException
调出一个由 optionType 参数确定其中选项数的对话框。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的 int：YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION
返回：
指示用户所选选项的 int
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showConfirmDialog

public static int showConfirmDialog(Component parentComponent,
                                    Object message,
                                    String title,
                                    int optionType,
                                    int messageType)
                             throws HeadlessException
调用一个由 optionType 参数确定其中选项数的对话框，messageType 参数确定要显示的图标。messageType 参数主要用于提供来自外观的默认图标。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame。
message - 要显示的 Object
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的整数：YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION
messageType - 指定此消息种类的整数；主要用于确定来自可插入外观的图标：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
返回：
指示用户所选选项的整数
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showConfirmDialog

public static int showConfirmDialog(Component parentComponent,
                                    Object message,
                                    String title,
                                    int optionType,
                                    int messageType,
                                    Icon icon)
                             throws HeadlessException
调出一个带有指定图标的对话框，其中的选项数由 optionType 参数确定。messageType 参数主要用于提供来自外观的默认图标。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的 int：YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION
messageType - 指定此消息种类的 int，主要用于确定来自可插入外观的图标：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 要在对话框中显示的图标
返回：
指示用户所选选项的 int
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

showOptionDialog

public static int showOptionDialog(Component parentComponent,
                                   Object message,
                                   String title,
                                   int optionType,
                                   int messageType,
                                   Icon icon,
                                   Object[] options,
                                   Object initialValue)
                            throws HeadlessException
调出一个带有指定图标的对话框，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

如果 optionType 为 YES_NO_OPTION 或者 YES_NO_CANCEL_OPTION，并且 options 参数为 null，则由外观提供选项。

messageType 参数主要用于提供来自外观的默认图标。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的整数：DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION
messageType - 指定消息种类的整数，主要用于确定来自可插入外观的图标：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 在对话框中显示的图标
options - 指示用户可能选择的对象组成的数组；如果对象是组件，则可以正确呈现；非 String 对象使用其 toString 方法呈现；如果此参数为 null，则由外观确定选项
initialValue - 表示对话框的默认选择的对象；只有在使用 options 时才有意义；可以为 null
返回：
指示用户所选选项的整数；如果用户关闭了对话框，则返回 CLOSED_OPTION
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

createDialog

public JDialog createDialog(Component parentComponent,
                            String title)
                     throws HeadlessException
创建并返回一个新 JDialog，它在 parentComponent 窗体中的 parentComponent 中央包装 this。title 是返回对话框的标题。用户不能调整返回的 JDialog，但是程序可以通过调用 JDialog 实例上的 setResizable 来更改此属性。返回的 JDialog 将被设置为：一旦将其关闭或者用户单击其中一个按钮，就会相应地设置选项窗格的值属性并关闭对话框。每次对话框变得可见时，它会将选项窗格的值属性重置为 JOptionPane.UNINITIALIZED_VALUE，从而确保用户的后续操作能够正确地关闭对话框。

参数：
parentComponent - 确定在其中显示对话框的窗体；如果 parentComponent 不具有 Frame，则使用默认的 Frame
title - 对话框的标题字符串
返回：
包含此实例的新 JDialog
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
GraphicsEnvironment.isHeadless()

createDialog

public JDialog createDialog(String title)
                     throws HeadlessException
创建并返回一个新的带有指定标题的无父 JDialog。用户不能调整返回的 JDialog，但是程序可以通过调用 JDialog 实例上的 setResizable 来更改此属性。返回的 JDialog 将被设置为：一旦将其关闭或者用户单击其中一个按钮，就会相应地设置选项窗格的值属性并关闭对话框。每次对话框变得可见时，它会将选项窗格的值属性重置为 JOptionPane.UNINITIALIZED_VALUE，从而确保用户的后续动作能够正确地关闭对话框。

参数：
title - 对话框的标题字符串
返回：
包含此实例的新 JDialog
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
从以下版本开始：
1.6
另请参见：
GraphicsEnvironment.isHeadless()

showInternalMessageDialog

public static void showInternalMessageDialog(Component parentComponent,
                                             Object message)
调出内部确认对话框面板。该对话框是一个信息消息对话框，标题为 "Message"。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的对象

showInternalMessageDialog

public static void showInternalMessageDialog(Component parentComponent,
                                             Object message,
                                             String title,
                                             int messageType)
调出一个显示消息的内部对话框面板，它使用由 messageType 参数确定的默认图标。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
title - 对话框的标题字符串
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE

showInternalMessageDialog

public static void showInternalMessageDialog(Component parentComponent,
                                             Object message,
                                             String title,
                                             int messageType,
                                             Icon icon)
调出一个显示消息的内部对话框面板，为其指定了所有参数。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
title - 对话框的标题字符串
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 要在对话框中显示的图标，该图标可以帮助用户识别要显示的消息种类

showInternalConfirmDialog

public static int showInternalConfirmDialog(Component parentComponent,
                                            Object message)
调出带有选项 Yes、No 和 Cancel 的内部对话框面板；标题为 Select an Option。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要显示的 Object
返回：
指示用户所选选项的整数

showInternalConfirmDialog

public static int showInternalConfirmDialog(Component parentComponent,
                                            Object message,
                                            String title,
                                            int optionType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要在对话框中显示的对象；Component 对象呈现为 Component；String 对象呈现为字符串；其他对象将通过 toString 方法被转换为 String
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的整数：YES_NO_OPTION 或 YES_NO_CANCEL_OPTION
返回：
指示用户所选选项的整数

showInternalConfirmDialog

public static int showInternalConfirmDialog(Component parentComponent,
                                            Object message,
                                            String title,
                                            int optionType,
                                            int messageType)
调出一个由 optionType 参数确定其中选项数的内部对话框面板，messageType 参数确定要显示的图标。messageType 参数主要用于提供来自外观的默认图标。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要在对话框中显示的对象；Component 对象呈现为 Component；String 对象呈现为字符串；其他对象将通过 toString 方法被转换为 String
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的整数：YES_NO_OPTION 或 YES_NO_CANCEL_OPTION
messageType - 指定消息种类的整数，主要用于确定来自可插入外观的图标：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
返回：
指示用户所选选项的整数

showInternalConfirmDialog

public static int showInternalConfirmDialog(Component parentComponent,
                                            Object message,
                                            String title,
                                            int optionType,
                                            int messageType,
                                            Icon icon)
调出一个带有指定图标的内部对话框面板，其中的选项数由 optionType 参数确定。messageType 参数主要用于提供来自外观的默认图标。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要在对话框中显示的对象；Component 对象呈现为 Component；String 对象呈现为字符串；其他对象将通过 toString 方法被转换为 String
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的整数：YES_NO_OPTION 或 YES_NO_CANCEL_OPTION。
messageType - 指定消息种类的整数，主要用于确定来自可插入外观的图标：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 要在对话框中显示的图标
返回：
指示用户所选选项的整数

showInternalOptionDialog

public static int showInternalOptionDialog(Component parentComponent,
                                           Object message,
                                           String title,
                                           int optionType,
                                           int messageType,
                                           Icon icon,
                                           Object[] options,
                                           Object initialValue)
调出一个带有指定图标的内部对话框面板，其中的初始选择由 initialValue 参数确定，选项数由 optionType 参数确定。

如果 optionType 为 YES_NO_OPTION，或者 YES_NO_CANCEL_OPTION 且 options 参数为 null，则由外观提供选项。

messageType 参数主要用于提供来自外观的默认图标。

参数：
parentComponent - 确定在其中显示对话框的 Frame；如果为 null 或者 parentComponent 不具有 Frame，则使用默认的 Frame
message - 要在对话框中显示的对象；Component 对象呈现为 Component；String 对象呈现为字符串。其他对象通过 toString 方法被转换为 String
title - 对话框的标题字符串
optionType - 指定可用于对话框的选项的整数：YES_NO_OPTION 或 YES_NO_CANCEL_OPTION
messageType - 指定消息种类的整数；主要用于确定来自可插入外观的图标：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 在对话框中显示的图标
options - 指示用户可能选择的对象组成的数组；如果对象是组件，则可以正确呈现；非 String 对象使用其 toString 方法呈现；如果此参数为 null，则由外观确定选项
initialValue - 表示对话框的默认选择的对象；只有在使用 options 时才有意义；可以为 null
返回：
指示用户所选选项的整数；如果用户关闭了对话框，则返回 CLOSED_OPTION

showInternalInputDialog

public static String showInternalInputDialog(Component parentComponent,
                                             Object message)
显示请求用户输入内容的内部问题消息对话框，它以 parentComponent 为父级。该对话框显示于 Component 的窗体中，通常位于 Component 之下。

参数：
parentComponent - 对话框的父 Component
message - 要显示的 Object

showInternalInputDialog

public static String showInternalInputDialog(Component parentComponent,
                                             Object message,
                                             String title,
                                             int messageType)
显示请求用户输入内容的内部对话框，它以 parentComponent 为父级。该对话框的标题为 title，消息类型为 messageType。

参数：
parentComponent - 对话框的父 Component
message - 要显示的 Object
title - 要在对话框的标题栏中显示的 String
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE

showInternalInputDialog

public static Object showInternalInputDialog(Component parentComponent,
                                             Object message,
                                             String title,
                                             int messageType,
                                             Icon icon,
                                             Object[] selectionValues,
                                             Object initialSelectionValue)
提示用户在可以指定初始选择、可能选择及其他所有选项的模块化的内部对话框中输入内容。用户可以从 selectionValues 中进行选择，其中 null 表示用户可以输入想输入的任何内容，通常依靠 JTextField 来实现。initialSelectionValue 是用于提示用户的初始值。由 UI 决定如何最好的表示 selectionValues，但通常情况下将使用 JComboBox、JList 或 JTextField。

参数：
parentComponent - 对话框的父 Component
message - 要显示的 Object
title - 要在对话框的标题栏中显示的 String
messageType - 要显示的消息类型：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
icon - 要显示的 Icon 图像
selectionValues - 给出可能选择的 Object 数组
initialSelectionValue - 用于初始化输入字段的值
返回：
用户输入；返回 null 意味着用户取消了输入

createInternalFrame

public JInternalFrame createInternalFrame(Component parentComponent,
                                          String title)
创建并返回 JInternalFrame 的实例。内部窗体是利用指定标题创建的，同时包装了 JOptionPane。返回的 JInternalFrame 将被添加到 parentComponent 的 JDesktopPane 祖先中；如果其祖先之一不是 JDesktopPane，则添加到其父组件中；如果 parentComponent 不具有父级，则抛出 RuntimeException。

参数：
parentComponent - 内部窗体的父 Component
title - 要在窗体的标题栏中显示的 String
返回：
包含 JOptionPane 的 JInternalFrame
抛出：
RuntimeException - 如果 parentComponent 不具有有效的父级

getFrameForComponent

public static Frame getFrameForComponent(Component parentComponent)
                                  throws HeadlessException
返回指定组件的 Frame。

参数：
parentComponent - 要检查 Frame 的 Component
返回：
包含组件的 Frame；如果组件为 null 或者不具有有效的 Frame 父级，则返回 getRootFrame
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
getRootFrame(), GraphicsEnvironment.isHeadless()

getDesktopPaneForComponent

public static JDesktopPane getDesktopPaneForComponent(Component parentComponent)
返回指定组件的桌面窗格。

参数：
parentComponent - 要检查桌面的 Component
返回：
包含组件的 JDesktopPane；如果组件为 null 或者不具有作为 JInternalFrame 的祖先，则返回 null

setRootFrame

public static void setRootFrame(Frame newRootFrame)
设置窗体，以用于不提供窗体的类方法。

注： 建议提供有效的父级而不是使用此方法。

参数：
newRootFrame - 要使用的默认 Frame

getRootFrame

public static Frame getRootFrame()
                          throws HeadlessException
返回用于不提供窗体的类方法中的 Frame。

返回：
要使用的默认 Frame
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless 返回 true
另请参见：
setRootFrame(java.awt.Frame), GraphicsEnvironment.isHeadless()

setUI

public void setUI(OptionPaneUI ui)
设置实现此组件 L&F 的 UI 对象。

参数：
ui - OptionPaneUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getUI

public OptionPaneUI getUI()
返回实现此组件 L&F 的 UI 对象。

返回：
OptionPaneUI 对象

updateUI

public void updateUI()
UIManager 发出的关于 L&F 已改变的通知。根据 UIManager 的最新通知替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回实现此组件 L&F 的 UI 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "OptionPaneUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setMessage

public void setMessage(Object newMessage)
设置选项窗格的消息对象。

参数：
newMessage - 要显示的 Object
另请参见：
getMessage()

getMessage

public Object getMessage()
返回此窗格显示的消息对象。

返回：
显示的 Object
另请参见：
setMessage(java.lang.Object)

setIcon

public void setIcon(Icon newIcon)
设置要显示的图标。如果非 null，则外观不提供图标。

参数：
newIcon - 要显示的 Icon
另请参见：
getIcon()

getIcon

public Icon getIcon()
返回此窗格显示的图标。

返回：
显示的 Icon
另请参见：
setIcon(javax.swing.Icon)

setValue

public void setValue(Object newValue)
设置用户所选值。

参数：
newValue - 所选值
另请参见：
getValue()

getValue

public Object getValue()
返回用户所选值。UNINITIALIZED_VALUE 表示用户尚未作出选择，而 null 则表示用户没有选取任何项便关闭了窗口。否则，返回值将为在此对象中所定义的选项之一。

返回：
用户所选 Object；如果用户尚未作出选择，则返回 UNINITIALIZED_VALUE；如果用户没有作出选择而关闭了窗口，则返回 null
另请参见：
setValue(java.lang.Object)

setOptions

public void setOptions(Object[] newOptions)
设置此窗格显示的选项。如果 newOptions 中的元素为 Component，则直接将其添加到窗格；否则为元素创建一个按钮。

参数：
newOptions - 用于创建用户可单击按钮的 Object 数组，或者要添加到窗格的任意 Component
另请参见：
getOptions()

getOptions

public Object[] getOptions()
返回用户可以作出的选择。

返回：
给出用户选择的 Object 数组
另请参见：
setOptions(java.lang.Object[])

setInitialValue

public void setInitialValue(Object newInitialValue)
设置要启用的初始值，即最初显示窗格时处于焦点状态的 Component。

参数：
newInitialValue - 获得初始键盘焦点的 Object
另请参见：
getInitialValue()

getInitialValue

public Object getInitialValue()
返回初始值。

返回：
获得初始键盘焦点的 Object
另请参见：
setInitialValue(java.lang.Object)

setMessageType

public void setMessageType(int newType)
设置选项窗格的消息类型。消息类型供外观确定要显示的图标（如果未提供）及 parentComponent 的可能布局时使用。

参数：
newType - 指定要显示的消息种类的整数：ERROR_MESSAGE、INFORMATION_MESSAGE、WARNING_MESSAGE、QUESTION_MESSAGE 或 PLAIN_MESSAGE
抛出：
RuntimeException - 如果 newType 不是上面列出的合法值之一
另请参见：
getMessageType()

getMessageType

public int getMessageType()
返回消息类型。

返回：
指定消息类型的整数
另请参见：
setMessageType(int)

setOptionType

public void setOptionType(int newType)
设置要显示的选项。选项类型供外观确定要显示的按钮时使用（除非已提供选项）。

参数：
newType - 指定 L&F 要显示的选项的整数：DEFAULT_OPTION、YES_NO_OPTION、YES_NO_CANCEL_OPTION 或 OK_CANCEL_OPTION
抛出：
RuntimeException - 如果 newType 不是上面列出的合法值之一
另请参见：
getOptionType(), setOptions(java.lang.Object[])

getOptionType

public int getOptionType()
返回显示的选项类型。

返回：
指定用户可选择选项的整数
另请参见：
setOptionType(int)

setSelectionValues

public void setSelectionValues(Object[] newValues)
设置窗格的输入选择值，该窗格向用户提供可以从中进行选择的项列表。（UI 提供窗口小部件，以便用户从中选取其中一个值。）null 值表示用户可以输入想输入的任何值，通常依靠 JTextField 来实现。

将 wantsInput 设置为 true。使用 setInitialSelectionValue 指定最初选择的值。启用了窗格后，inputValue 将被设置为用户所选的值。

参数：
newValues - 用户要显示的 Object 数组（通常使用列表或组合框的形式），用户可以从中作出选择
另请参见：
setWantsInput(boolean), setInitialSelectionValue(java.lang.Object), getSelectionValues()

getSelectionValues

public Object[] getSelectionValues()
返回输入选择值。

返回：
用户可以选择的 Object 数组
另请参见：
setSelectionValues(java.lang.Object[])

setInitialSelectionValue

public void setInitialSelectionValue(Object newValue)
设置（根据选择）最初向用户显示的输入值。仅当 wantsInput 为 true 时使用。

参数：
newValue - 最初选择的值
另请参见：
setSelectionValues(java.lang.Object[]), getInitialSelectionValue()

getInitialSelectionValue

public Object getInitialSelectionValue()
返回（根据最初选择）向用户显示的输入值。

返回：
最初选择值
另请参见：
setInitialSelectionValue(java.lang.Object), setSelectionValues(java.lang.Object[])

setInputValue

public void setInputValue(Object newValue)
设置由用户选择或输入的输入值。仅当 wantsInput 为 true 时才使用。注意，此方法由选项窗格内部调用（响应用户操作），客户端程序一般不能调用。要设置（根据选择）最初向用户显示的输入值，请使用 setInitialSelectionValue。

参数：
newValue - 用于设置用户指定值的 Object（通常使用文本字段的形式）
另请参见：
setSelectionValues(java.lang.Object[]), setInitialSelectionValue(java.lang.Object), setWantsInput(boolean), getInputValue()

getInputValue

public Object getInputValue()
如果 wantsInput 为 true，则返回用户已输入的值。

返回：
用户指定的 Object，如果它是这些对象之一；如果为键入字段中的值，则返回 String
另请参见：
setSelectionValues(java.lang.Object[]), setWantsInput(boolean), setInputValue(java.lang.Object)

getMaxCharactersPerLineCount

public int getMaxCharactersPerLineCount()
返回要置于消息的行中的最大字符数。默认情况下返回 Integer.MAX_VALUE。在子类中重写此方法可更改该值。

返回：
给出行中最大字符数的整数

setWantsInput

public void setWantsInput(boolean newValue)
设置 wantsInput 属性。如果 newValue 为 true，则提供其父级为 parentComponent 的输入组件（比如文本字段或组合框），以允许用户输入值。如果 getSelectionValues 返回非 null 数组，则输入值为该数组中的对象之一。否则，输入值就是用户输入的内容。

这是一个绑定属性。

另请参见：
setSelectionValues(java.lang.Object[]), setInputValue(java.lang.Object)

getWantsInput

public boolean getWantsInput()
返回 wantsInput 属性的值。

返回：
如果将提供输入组件，则返回 true
另请参见：
setWantsInput(boolean)

selectInitialValue

public void selectInitialValue()
请求选择初始值，该请求将焦点设置为初始值。应该在包含选项窗格的窗口变得可见后调用此方法。

paramString

protected String paramString()
返回此 JOptionPane 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JOptionPane 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
返回与此 JOptionPane 相关联的 AccessibleContext。对于选项窗格，AccessibleContext 采用 AccessibleJOptionPane 的形式。必要时创建一个新的 AccessibleJOptionPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJOptionPane，它充当此 AccessibleJOptionPane 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JOptionPane.AccessibleJOptionPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JOptionPane.AccessibleJOptionPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JOptionPane.AccessibleJOptionPane
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JOptionPane
protected class JOptionPane.AccessibleJOptionPane
extends JComponent.AccessibleJComponent

此类实现对 JOptionPane 类的可访问性支持。它提供适合于选项窗格用户界面元素的 Java Accessibility API 的实现。

警告：此类已序列化的对象将不再与以后的 Swing 版本兼容。当前的序列化支持适合于在运行相同 Swing 版本的应用程序之间短期存储或 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JOptionPane.AccessibleJOptionPane()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JOptionPane.AccessibleJOptionPane

protected JOptionPane.AccessibleJOptionPane()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPanel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JPanel

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPanel
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
AbstractColorChooserPanel, JSpinner.DefaultEditor
public class JPanel
extends JComponent
implements Accessible

JPanel 是一般轻量级容器。有关 JPanel 的示例和面向任务的文档，请参阅 The Java Tutorial 的 How to Use Panels 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JPanel.AccessibleJPanel
此类实现对 JPanel 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JPanel()
创建具有双缓冲和流布局的新 JPanel。
JPanel(boolean isDoubleBuffered)
创建具有 FlowLayout 和指定缓冲策略的新 JPanel。
JPanel(LayoutManager layout)
创建具有指定布局管理器的新缓冲 JPanel。
JPanel(LayoutManager layout, boolean isDoubleBuffered)
创建具有指定布局管理器和缓冲策略的新 JPanel。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JPanel 关联的 AccessibleContext。
PanelUI | getUI() 返回呈现此组件的外观 (L&F) 对象。
String | getUIClassID() 返回指定呈现此组件的 L&F 类名的字符串。
protected String | paramString() 返回此 JPanel 的字符串表示形式。
void | setUI(PanelUI ui) 设置呈现此组件的外观 (L&F) 对象。
void | updateUI() 利用当前外观的值重置 UI 属性。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JPanel

public JPanel(LayoutManager layout,
              boolean isDoubleBuffered)
创建具有指定布局管理器和缓冲策略的新 JPanel。

参数：
layout - 要使用的 LayoutManager
isDoubleBuffered - boolean 值，true 表示双缓冲，双缓冲使用更多内存空间实现快速、无闪烁的更新

JPanel

public JPanel(LayoutManager layout)
创建具有指定布局管理器的新缓冲 JPanel。

参数：
layout - 要使用的 LayoutManager

JPanel

public JPanel(boolean isDoubleBuffered)
创建具有 FlowLayout 和指定缓冲策略的新 JPanel。如果 isDoubleBuffered 为 true，则 JPanel 将使用双缓冲。

参数：
isDoubleBuffered - boolean 值，true 表示双缓冲，双缓冲使用更多内存空间实现快速、无闪烁的更新

JPanel

public JPanel()
创建具有双缓冲和流布局的新 JPanel。

方法详细信息

updateUI

public void updateUI()
利用当前外观的值重置 UI 属性。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUI

public PanelUI getUI()
返回呈现此组件的外观 (L&F) 对象。

返回：
呈现此组件的 PanelUI 对象
从以下版本开始：
1.4

setUI

public void setUI(PanelUI ui)
设置呈现此组件的外观 (L&F) 对象。

参数：
ui - PanelUI L&F 对象
从以下版本开始：
1.4
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getUIClassID

public String getUIClassID()
返回指定呈现此组件的 L&F 类名的字符串。

覆盖：
类 JComponent 中的 getUIClassID
返回：
"PanelUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

paramString

protected String paramString()
返回此 JPanel 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JPanel 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JPanel 关联的 AccessibleContext。对于 JPanel，AccessibleContext 采取 AccessibleJPanel 的形式。必要时要创建新的 AccessibleJPanel 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJPanel，它充当此 JPanel 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPasswordField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JPasswordField

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
                    继承者  javax.swing.JTextField
                        继承者  javax.swing.JPasswordField
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants
public class JPasswordField
extends JTextField

JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。有关更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Text Fields 一节。

JPasswordField 与使用 echoChar 设置的 java.awt.TextField 是根本一致的。单独提供它可以较方便地安全更改 JTextField 的 UI 而不影响密码输入。

注： 默认情况下，JPasswordField 禁用输入法；否则，当使用输入法组合时，输入字符应该是可见的。如果应用程序需要输入法支持，请使用继承方法 enableInputMethods(true)。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JPasswordField.AccessibleJPasswordField
此类实现对 JPasswordField 类的可访问性支持。
从类 javax.swing.JTextField 继承的嵌套类/接口
JTextField.AccessibleJTextField
从类 javax.swing.text.JTextComponent 继承的嵌套类/接口
JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JTextField 继承的字段
notifyAction
从类 javax.swing.text.JTextComponent 继承的字段
DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JPasswordField()
构造一个新 JPasswordField，使其具有默认文档、为 null 的开始文本字符串和为 0 的列宽度。
JPasswordField(Document doc, String txt, int columns)
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。
JPasswordField(int columns)
构造一个具有指定列数的新的空 JPasswordField。
JPasswordField(String text)
构造一个利用指定文本初始化的新 JPasswordField。
JPasswordField(String text, int columns)
构造一个利用指定文本和列初始化的新 JPasswordField。
方法摘要
void | copy() 对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。
void | cut() 对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。
boolean | echoCharIsSet() 如果此 JPasswordField 具有为回显设置的字符，则返回 true。
AccessibleContext | getAccessibleContext() 返回与此 JPasswordField 关联的 AccessibleContext。
char | getEchoChar() 返回要用于回显的字符。
char[] | getPassword() 返回此 TextComponent 中所包含的文本。
String | getText() 已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
String | getText(int offs, int len) 已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。
String | getUIClassID() 返回呈现此组件的 L&F 类名。
protected String | paramString() 返回此 JPasswordField 的字符串表示形式。
void | setEchoChar(char c) 设置此 JPasswordField 的回显字符。
void | updateUI() 重新加载可插入的 UI。
从类 javax.swing.JTextField 继承的方法
actionPropertyChanged, addActionListener, configurePropertiesFromAction, createActionPropertyChangeListener, createDefaultModel, fireActionPerformed, getAction, getActionListeners, getActions, getColumns, getColumnWidth, getHorizontalAlignment, getHorizontalVisibility, getPreferredSize, getScrollOffset, isValidateRoot, postActionEvent, removeActionListener, scrollRectToVisible, setAction, setActionCommand, setColumns, setDocument, setFont, setHorizontalAlignment, setScrollOffset
从类 javax.swing.text.JTextComponent 继承的方法
addCaretListener, addInputMethodListener, addKeymap, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, viewToModel, write
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JPasswordField

public JPasswordField()
构造一个新 JPasswordField，使其具有默认文档、为 null 的开始文本字符串和为 0 的列宽度。

JPasswordField

public JPasswordField(String text)
构造一个利用指定文本初始化的新 JPasswordField。将文档模型设置为默认值，列数为 0。

参数：
text - 要显示的文本；如果没有文本，则为 null

JPasswordField

public JPasswordField(int columns)
构造一个具有指定列数的新的空 JPasswordField。创建一个默认模型，并将其初始字符串设置为 null。

参数：
columns - 列数，它 >= 0

JPasswordField

public JPasswordField(String text,
                      int columns)
构造一个利用指定文本和列初始化的新 JPasswordField。将文档模型设置为默认值。

参数：
text - 要显示的文本；如果不存在文本，则为 null
columns - 列数，它 >= 0

JPasswordField

public JPasswordField(Document doc,
                      String txt,
                      int columns)
构造一个使用给定文本存储模型和给定列数的新 JPasswordField。其他构造方法馈通此构造方法。将回显字符设置为 '*'，但可以通过当前外观更改。如果文档模型为 null，则创建默认文档。

参数：
doc - 要使用的文本存储
txt - 要显示的文本；如果不存在文本，则为 null
columns - 用于计算首选宽度的列数，它 >= 0；如果将列数设置为 0，则首选宽度将从组件实现自然产生
方法详细信息

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类名。

覆盖：
类 JTextField 中的 getUIClassID
返回：
字符串 "PasswordFieldUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
重新加载可插入的 UI。用于获取新界面的键是 getUIClassID()。该 UI 的类型是 TextUI。设置该 UI 之后调用 invalidate。

覆盖：
类 JTextComponent 中的 updateUI
从以下版本开始：
1.6
另请参见：
JComponent.setUI(javax.swing.plaf.ComponentUI),
UIManager.getLookAndFeel(),
UIManager.getUI(javax.swing.JComponent)

getEchoChar

public char getEchoChar()
返回要用于回显的字符。默认值为 '*'。默认值根据当前运行的外观可以有所不同。例如，Metal/Ocean 的默认值为 bullet 字符。

返回：
回显字符；如果未设置，则返回 0
另请参见：
setEchoChar(char), echoCharIsSet()

setEchoChar

public void setEchoChar(char c)
设置此 JPasswordField 的回显字符。注意，这仅仅是一个建议，因为安装的视图可以使用它所需要的任何图形技术来表示字段。将值设置为 0 指示希望按照键入查看文本，类似于标准 JTextField 的行为。

参数：
c - 要显示的回显字符
另请参见：
echoCharIsSet(), getEchoChar()

echoCharIsSet

public boolean echoCharIsSet()
如果此 JPasswordField 具有为回显设置的字符，则返回 true。如果回显字符不为 0，则考虑设置字符。

返回：
如果为回显设置了字符，则返回 true
另请参见：
setEchoChar(char), getEchoChar()

cut

public void cut()
对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。将关联模型中的当前选定范围传输到系统剪贴板并从模型中移除内容，这种普通行为对于密码字段而言，是不可接受的。

覆盖：
类 JTextComponent 中的 cut
另请参见：
Toolkit.getSystemClipboard(), Clipboard

copy

public void copy()
对当前外观调用 provideErrorFeedback，这通常启动错误蜂鸣。将关联模型中的当前选定范围传输到系统剪贴板并在模型中保留内容，这种普通行为对于密码字段而言，是不可接受的。

覆盖：
类 JTextComponent 中的 copy
另请参见：
Toolkit.getSystemClipboard(), Clipboard

getText

@Deprecated
public String getText()
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

返回此 TextComponent 中所包含的文本。如果基础文档为 null，则将给出 NullPointerException。

出于安全考虑，此方法已废弃。使用 getPassword 方法来代替。

覆盖：
类 JTextComponent 中的 getText
返回：
文本
另请参见：
JTextComponent.setText(java.lang.String)

getText

@Deprecated
public String getText(int offs,
                                 int len)
               throws BadLocationException
已过时。 从 Java 2 platform v1.2 开始，由 getPassword 来代替。

获取由组件表示的文本部分。如果长度为 0，则返回空字符串。

出于安全考虑，此方法已废弃。使用 getPassword 方法来代替。

覆盖：
类 JTextComponent 中的 getText
参数：
offs - 偏移量，它 >= 0
len - 长度，它 >= 0
返回：
文本
抛出：
BadLocationException - 如果偏移量或长度无效

getPassword

public char[] getPassword()
返回此 TextComponent 中所包含的文本。如果基础文档为 null，则将给出 NullPointerException。为了取得较高的安全性，建议将每个字符设置为 0 以便在使用后清除返回的字符数组。

返回：
文本

paramString

protected String paramString()
返回此 JPasswordField 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JTextField 中的 paramString
返回：
此 JPasswordField 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
返回与此 JPasswordField 关联的 AccessibleContext。对于密码字段，AccessibleContext 采用 AccessibleJPasswordField 的形式。必要时要创建新的 AccessibleJPasswordField 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JTextField 中的 getAccessibleContext
返回：
一个 AccessibleJPasswordField，它充当此 JPasswordField 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPanel.AccessibleJPanel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JPanel.AccessibleJPanel

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JPanel.AccessibleJPanel
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JPanel
protected class JPanel.AccessibleJPanel
extends JComponent.AccessibleJComponent

此类实现对 JPanel 类的可访问性支持。它提供适合面板用户界面元素的 Java Accessibility API 实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JPanel.AccessibleJPanel()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JPanel.AccessibleJPanel

protected JPanel.AccessibleJPanel()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPasswordField.AccessibleJPasswordField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JPasswordField.AccessibleJPasswordField

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.text.JTextComponent.AccessibleJTextComponent
                        继承者  javax.swing.JTextField.AccessibleJTextField
                            继承者  javax.swing.JPasswordField.AccessibleJPasswordField
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
正在封闭类：
JPasswordField
protected class JPasswordField.AccessibleJPasswordField
extends JTextField.AccessibleJTextField

此类实现对 JPasswordField 类的可访问性支持。它提供适合密码字段用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
从接口 javax.accessibility.AccessibleExtendedText 继承的字段
ATTRIBUTE_RUN, LINE
构造方法摘要
protected JPasswordField.AccessibleJPasswordField()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleText | getAccessibleText() 获取 JPasswordField 的 AccessibleText。
String | getAfterIndex(int part, int index) 返回给定 index 之后的 String。
String | getAtIndex(int part, int index) 返回给定 index 处的 String。
String | getBeforeIndex(int part, int index) 返回给定 index 之前的 String。
String | getTextRange(int startIndex, int endIndex) 返回两个索引之间的文本。
AccessibleTextSequence | getTextSequenceAfter(int part, int index) 返回给定 index 之后的 AccessibleTextSequence。
AccessibleTextSequence | getTextSequenceAt(int part, int index) 返回给定 index 处的 AccessibleTextSequence。
AccessibleTextSequence | getTextSequenceBefore(int part, int index) 返回给定 index 之前的 AccessibleTextSequence。
从类 javax.swing.JTextField.AccessibleJTextField 继承的方法
getAccessibleStateSet
从类 javax.swing.text.JTextComponent.AccessibleJTextComponent 继承的方法
caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JPasswordField.AccessibleJPasswordField

protected JPasswordField.AccessibleJPasswordField()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAccessibleRole
返回：
描述对象 (AccessibleRole.PASSWORD_TEXT) 的职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleText

public AccessibleText getAccessibleText()
获取 JPasswordField 的 AccessibleText。返回的对象也实现 AccessibleExtendedText 接口。

覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAccessibleText
返回：
JPasswordField 的 AccessibleText
从以下版本开始：
1.6
另请参见：
AccessibleContext, AccessibleContext.getAccessibleText(), AccessibleText, AccessibleExtendedText

getAtIndex

public String getAtIndex(int part,
                         int index)
返回给定 index 处的 String。

指定者：
接口 AccessibleText 中的 getAtIndex
覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAtIndex
参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回一个 String。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

getAfterIndex

public String getAfterIndex(int part,
                            int index)
返回给定 index 之后的 String。

指定者：
接口 AccessibleText 中的 getAfterIndex
覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAfterIndex
参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回一个 String。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

getBeforeIndex

public String getBeforeIndex(int part,
                             int index)
返回给定 index 之前的 String。

指定者：
接口 AccessibleText 中的 getBeforeIndex
覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getBeforeIndex
参数：
part - 要获取的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回一个 String。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE

getTextRange

public String getTextRange(int startIndex,
                           int endIndex)
返回两个索引之间的文本。

指定者：
接口 AccessibleEditableText 中的 getTextRange
指定者：
接口 AccessibleExtendedText 中的 getTextRange
覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getTextRange
参数：
startIndex - 文本中的起始索引
endIndex - 文本中的结尾索引
返回：
如果索引有效，则返回文本字符串。否则，返回 null
从以下版本开始：
1.6

getTextSequenceAt

public AccessibleTextSequence getTextSequenceAt(int part,
                                                int index)
返回给定 index 处的 AccessibleTextSequence。

指定者：
接口 AccessibleExtendedText 中的 getTextSequenceAt
覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getTextSequenceAt
参数：
part - 要获取的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回指定文本的 AccessibleTextSequence。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

getTextSequenceAfter

public AccessibleTextSequence getTextSequenceAfter(int part,
                                                   int index)
返回给定 index 之后的 AccessibleTextSequence。

指定者：
接口 AccessibleExtendedText 中的 getTextSequenceAfter
覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getTextSequenceAfter
参数：
part - 要获取的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回指定文本的 AccessibleTextSequence。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN

getTextSequenceBefore

public AccessibleTextSequence getTextSequenceBefore(int part,
                                                    int index)
返回给定 index 之前的 AccessibleTextSequence。

指定者：
接口 AccessibleExtendedText 中的 getTextSequenceBefore
覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getTextSequenceBefore
参数：
part - 要获取的 CHARACTER、WORD、SENTENCE、LINE 或 ATTRIBUTE_RUN
index - 文本中的索引
返回：
如果 part 和 index 有效，则返回指定文本的 AccessibleTextSequence。否则，返回 null
从以下版本开始：
1.6
另请参见：
AccessibleText.CHARACTER, AccessibleText.WORD, AccessibleText.SENTENCE, AccessibleExtendedText.LINE, AccessibleExtendedText.ATTRIBUTE_RUN
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPopupMenu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JPopupMenu

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPopupMenu
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, MenuElement
直接已知子类：
BasicComboPopup
public class JPopupMenu
extends JComponent
implements Accessible, MenuElement

弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。JPopupMenu 用于用户在菜单栏上选择项时显示的菜单。它还用于当用户选择菜单项并激活它时显示的“右拉式 (pull-right)”菜单。最后，JPopupMenu 还可以在想让菜单显示的任何其他位置使用。例如，当用户在指定区域中右击时。

有关使用弹出菜单的示例和信息，请参阅 The Java Tutorial 中的 How to Use Menus。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected class | JPopupMenu.AccessibleJPopupMenu 此类实现 JPopupMenu 类的可访问性支持。
static class | JPopupMenu.Separator 弹出与菜单有关的分隔符。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JPopupMenu()
构造一个不带“调用者”的 JPopupMenu。
JPopupMenu(String label)
构造一个具有指定标题的 JPopupMenu。
方法摘要
 JMenuItem add(Action a)
将指派指定 Action 对象的新菜单项添加到菜单的末尾。
 JMenuItem add(JMenuItem menuItem)
将指定菜单项添加到此菜单的末尾。
 JMenuItem add(String s)
创建具有指定文本的菜单项，并将其添加到此菜单的末尾。
 void addMenuKeyListener(MenuKeyListener l)
将 MenuKeyListener 添加到弹出菜单。
 void addPopupMenuListener(PopupMenuListener l)
添加 PopupMenu 侦听器。
 void addSeparator()
将新分隔符添加到菜单的末尾。
protected  PropertyChangeListener createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。
protected  JMenuItem createActionComponent(Action a)
该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。
protected  void firePopupMenuCanceled()
通知 PopupMenuListener 此弹出菜单将被取消。
protected  void firePopupMenuWillBecomeInvisible()
通知 PopupMenuListener 此弹出菜单将变得不可见。
protected  void firePopupMenuWillBecomeVisible()
通知 PopupMenuListener 此弹出菜单将变得可见。
 AccessibleContext getAccessibleContext()
获取与此 JPopupMenu 关联的 AccessibleContext。
 Component getComponent()
返回此 JPopupMenu 组件。
 Component getComponentAtIndex(int i)
已过时。 由 Container.getComponent(int) 取代
 int getComponentIndex(Component c)
返回指定组件的索引。
static boolean getDefaultLightWeightPopupEnabled()
获取 defaultLightWeightPopupEnabled 属性，默认情况下，该属性为 true。
 Component getInvoker()
返回作为此弹出菜单的“调用者”的组件。
 String getLabel()
返回弹出菜单的标签。
 Insets getMargin()
返回弹出菜单的边框与其包含内容之间的空白（以像素表示）。
 MenuKeyListener[] getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JPopupMenu 的所有 MenuKeyListener 组成的数组。
 PopupMenuListener[] getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JMenuItem 的所有 PopupMenuListener 组成的数组。
 SingleSelectionModel getSelectionModel()
返回处理单个选择的模型对象。
 MenuElement[] getSubElements()
返回 MenuElement 组成的数组，包含此菜单组件的子菜单。
 PopupMenuUI getUI()
返回用于呈现此组件的外观 (L&F) 对象。
 String getUIClassID()
返回用于呈现此组件的 L&F 类名。
 void insert(Action a, int index)
在给定位置插入指定 Action 对象的菜单项。
 void insert(Component component, int index)
将指定组件插入到菜单的给定位置。
 boolean isBorderPainted()
检查是否应该绘制边框。
 boolean isLightWeightPopupEnabled()
获取 lightWeightPopupEnabled 属性。
 boolean isPopupTrigger(MouseEvent e)
如果 JPopupMenu 的当前安装 UI 将 MouseEvent 视为弹出菜单触发器，则返回 true。
 boolean isVisible()
如果弹出菜单可见（当前显示的），则返回 true。
 void menuSelectionChanged(boolean isIncluded)
当菜单栏选择发生更改以激活或取消激活此菜单时传递消息。
 void pack()
布置容器，让它使用显示其内容所需的最小空间。
protected  void paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制弹出菜单的边框。
protected  String paramString()
返回此 JPopupMenu 的字符串表示形式。
protected  void processFocusEvent(FocusEvent evt)
处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。
protected  void processKeyEvent(KeyEvent evt)
处理快捷键事件，如助记符和加速器。
 void processKeyEvent(KeyEvent e, MenuElement[] path, MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。
 void processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager)
要求此方法遵守 MenuElement 接口，但它没有被实现。
 void remove(int pos)
从此弹出菜单移除指定索引处的组件。
 void removeMenuKeyListener(MenuKeyListener l)
从弹出菜单移除 MenuKeyListener。
 void removePopupMenuListener(PopupMenuListener l)
移除 PopupMenu 侦听器。
 void setBorderPainted(boolean b)
设置是否应该绘制边框。
static void setDefaultLightWeightPopupEnabled(boolean aFlag)
设置 lightWeightPopupEnabled 属性的默认值。
 void setInvoker(Component invoker)
设置此弹出菜单的调用者，即弹出菜单在其中显示的组件。
 void setLabel(String label)
设置弹出菜单的标签。
 void setLightWeightPopupEnabled(boolean aFlag)
设置 lightWeightPopupEnabled 属性的值，默认情况下该值为 true。
 void setLocation(int x, int y)
使用 X、Y 坐标设置弹出菜单的左上角的位置。
 void setPopupSize(Dimension d)
使用 Dimension 对象设置弹出窗口的大小。
 void setPopupSize(int width, int height)
将弹出窗口的大小设置为指定的宽度和高度。
 void setSelected(Component sel)
设置当前选择的组件，此方法将更改选择模型。
 void setSelectionModel(SingleSelectionModel model)
设置处理单个选择的模型对象。
 void setUI(PopupMenuUI ui)
设置呈现此组件的 L&F 对象。
 void setVisible(boolean b)
设置弹出菜单的可见性。
 void show(Component invoker, int x, int y)
在组件调用者的坐标空间中的位置 X、Y 显示弹出菜单。
 void updateUI()
将 UI 属性重置为一个来自当前外观的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JPopupMenu

public JPopupMenu()
构造一个不带“调用者”的 JPopupMenu。

JPopupMenu

public JPopupMenu(String label)
构造一个具有指定标题的 JPopupMenu。

参数：
label - 可以被 UI 用作弹出菜单的标题显示的字符串。
方法详细信息

setDefaultLightWeightPopupEnabled

public static void setDefaultLightWeightPopupEnabled(boolean aFlag)
设置 lightWeightPopupEnabled 属性的默认值。

参数：
aFlag - 如果弹出菜单为轻量级，则为 true；否则为 false
另请参见：
getDefaultLightWeightPopupEnabled(), setLightWeightPopupEnabled(boolean)

getDefaultLightWeightPopupEnabled

public static boolean getDefaultLightWeightPopupEnabled()
获取 defaultLightWeightPopupEnabled 属性，默认情况下，该属性为 true。

返回：
defaultLightWeightPopupEnabled 属性的值
另请参见：
setDefaultLightWeightPopupEnabled(boolean)

getUI

public PopupMenuUI getUI()
返回用于呈现此组件的外观 (L&F) 对象。

返回：
呈现此组件的 PopupMenuUI 对象

setUI

public void setUI(PopupMenuUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - 新 PopupMenuUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
将 UI 属性重置为一个来自当前外观的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回用于呈现此组件的 L&F 类名。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "PopupMenuUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

processFocusEvent

protected void processFocusEvent(FocusEvent evt)
从类 Component 复制的描述
处理组件上发生的焦点事件，方法是将其指派到任意已注册的 FocusListener 对象。

如果组件上没有启用焦点事件，则不调用此方法。发生下列之一时启用焦点事件：

  • 通过 addFocusListener 注册了一个 FocusListener 对象。
  • 通过 enableEvents 启用了焦点事件。

如果为某个 Component 启用了焦点事件，则当前的 KeyboardFocusManager 确定是否应该将焦点事件指派到已注册的 FocusListener 对象。如果未指派事件，则 KeyboardFocusManager 调用 Component 的 dispatchEvent 方法，此方法又调用 Component 的 processFocusEvent 方法。

如果为 Component 启用了焦点事件，则用 FocusEvent 作为参数来调用 Component 的 dispatchEvent 方法将导致调用 Component 的 processFocusEvent 方法，而不管当前的 KeyboardFocusManager 如何。

注意，如果事件参数为 null，则未指定行为并且可能导致异常。

覆盖：
类 Component 中的 processFocusEvent
参数：
evt - 焦点事件
另请参见：
FocusEvent, FocusListener, KeyboardFocusManager, Component.addFocusListener(java.awt.event.FocusListener), Component.enableEvents(long), Component.dispatchEvent(java.awt.AWTEvent)

processKeyEvent

protected void processKeyEvent(KeyEvent evt)
处理快捷键事件，如助记符和加速器。

覆盖：
类 JComponent 中的 processKeyEvent
参数：
evt - 要处理的键事件
另请参见：
KeyEvent, KeyListener, KeyboardFocusManager, DefaultKeyboardFocusManager, Component.processEvent(java.awt.AWTEvent), Component.dispatchEvent(java.awt.AWTEvent), Component.addKeyListener(java.awt.event.KeyListener), Component.enableEvents(long), Component.isShowing()

getSelectionModel

public SingleSelectionModel getSelectionModel()
返回处理单个选择的模型对象。

返回：
selectionModel 属性
另请参见：
SingleSelectionModel

setSelectionModel

public void setSelectionModel(SingleSelectionModel model)
设置处理单个选择的模型对象。

参数：
model - 新 SingleSelectionModel
另请参见：
SingleSelectionModel

add

public JMenuItem add(JMenuItem menuItem)
将指定菜单项添加到此菜单的末尾。

参数：
menuItem - 要添加的 JMenuItem
返回：
已添加的 JMenuItem

add

public JMenuItem add(String s)
创建具有指定文本的菜单项，并将其添加到此菜单的末尾。

参数：
s - 要添加的菜单项的字符串

add

public JMenuItem add(Action a)
将指派指定 Action 对象的新菜单项添加到菜单的末尾。

参数：
a - 要添加到菜单的 Action
返回：
新菜单项
另请参见：
Action

createActionComponent

protected JMenuItem createActionComponent(Action a)
该工厂方法为添加到 JPopupMenu 的 Action 创建对应的 JMenuItem。

参数：
a - 要添加的菜单项的 Action
返回：
新菜单项
从以下版本开始：
1.3
另请参见：
Action

createActionChangeListener

protected PropertyChangeListener createActionChangeListener(JMenuItem b)
返回一个正确配置的 PropertyChangeListener，它在 Action 发生更改时更新控件。

remove

public void remove(int pos)
从此弹出菜单移除指定索引处的组件。

覆盖：
类 Container 中的 remove
参数：
pos - 要移除的项的位置
抛出：
IllegalArgumentException - 如果 pos 的值 < 0 或者 pos 的值大于项数
另请参见：
Container.add(java.awt.Component),
Container.validate(),
Container.getComponentCount()

setLightWeightPopupEnabled

public void setLightWeightPopupEnabled(boolean aFlag)
设置 lightWeightPopupEnabled 属性的值，默认情况下该值为 true。默认情况下，当外观显示弹出菜单时，它选择使用轻量级（纯 Java 的）弹出菜单。轻量级弹出窗口比重量级（本机同位体）窗口效果更好，但是轻量级和重量级组件在 GUI 中不能很好地混合使用。如果应用程序混合使用轻量级和重量级组件，则应该禁用轻量级弹出窗口。某些外观可能始终使用重量级弹出菜单，不管此属性的值如何。

参数：
aFlag - 为 false 表示禁用轻量级弹出菜单
另请参见：
isLightWeightPopupEnabled()

isLightWeightPopupEnabled

public boolean isLightWeightPopupEnabled()
获取 lightWeightPopupEnabled 属性。

返回：
lightWeightPopupEnabled 属性的值
另请参见：
setLightWeightPopupEnabled(boolean)

getLabel

public String getLabel()
返回弹出菜单的标签。

返回：
包含弹出菜单标签的字符串
另请参见：
setLabel(java.lang.String)

setLabel

public void setLabel(String label)
设置弹出菜单的标签。不同的外观可以选择显示，也可以选择不显示这一项。

参数：
label - 指定弹出菜单标签的字符串
另请参见：
setLabel(java.lang.String)

addSeparator

public void addSeparator()
将新分隔符添加到菜单的末尾。

insert

public void insert(Action a,
                   int index)
在给定位置插入指定 Action 对象的菜单项。

参数：
a - 要插入的 Action 对象
index - 指定插入 Action 的位置，其中 0 为第一个
抛出：
IllegalArgumentException - 如果 index < 0
另请参见：
Action

insert

public void insert(Component component,
                   int index)
将指定组件插入到菜单的给定位置。

参数：
component - 要插入的 Component
index - 指定插入组件的位置，其中 0 为第一个
抛出：
IllegalArgumentException - 如果 index < 0

addPopupMenuListener

public void addPopupMenuListener(PopupMenuListener l)
添加 PopupMenu 侦听器。

参数：
l - 要添加的 PopupMenuListener

removePopupMenuListener

public void removePopupMenuListener(PopupMenuListener l)
移除 PopupMenu 侦听器。

参数：
l - 要移除的 PopupMenuListener

getPopupMenuListeners

public PopupMenuListener[] getPopupMenuListeners()
返回利用 addPopupMenuListener() 添加到此 JMenuItem 的所有 PopupMenuListener 组成的数组。

返回：
所有添加的 PopupMenuListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

addMenuKeyListener

public void addMenuKeyListener(MenuKeyListener l)
将 MenuKeyListener 添加到弹出菜单。

参数：
l - 要添加的 MenuKeyListener
从以下版本开始：
1.5

removeMenuKeyListener

public void removeMenuKeyListener(MenuKeyListener l)
从弹出菜单移除 MenuKeyListener。

参数：
l - 要移除的 MenuKeyListener
从以下版本开始：
1.5

getMenuKeyListeners

public MenuKeyListener[] getMenuKeyListeners()
返回利用 addMenuKeyListener() 添加到此 JPopupMenu 的所有 MenuKeyListener 组成的数组。

返回：
添加的所有 MenuKeyListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.5

firePopupMenuWillBecomeVisible

protected void firePopupMenuWillBecomeVisible()
通知 PopupMenuListener 此弹出菜单将变得可见。

firePopupMenuWillBecomeInvisible

protected void firePopupMenuWillBecomeInvisible()
通知 PopupMenuListener 此弹出菜单将变得不可见。

firePopupMenuCanceled

protected void firePopupMenuCanceled()
通知 PopupMenuListener 此弹出菜单将被取消。

pack

public void pack()
布置容器，让它使用显示其内容所需的最小空间。

setVisible

public void setVisible(boolean b)
设置弹出菜单的可见性。

覆盖：
类 JComponent 中的 setVisible
参数：
b - 为 true 表示使弹出菜单可见，为 false 表示隐藏它
另请参见：
Component.isVisible()

isVisible

public boolean isVisible()
如果弹出菜单可见（当前显示的），则返回 true。

覆盖：
类 Component 中的 isVisible
返回：
如果组件是可见的，则返回 true；否则返回 false
另请参见：
Component.setVisible(boolean)

setLocation

public void setLocation(int x,
                        int y)
使用 X、Y 坐标设置弹出菜单的左上角的位置。

覆盖：
类 Component 中的 setLocation
参数：
x - 屏幕坐标空间中弹出菜单的新位置的 X 坐标
y - 屏幕坐标空间中弹出菜单的新位置的 Y 坐标
另请参见：
Component.getLocation(), Component.setBounds(int, int, int, int)

getInvoker

public Component getInvoker()
返回作为此弹出菜单的“调用者”的组件。

返回：
弹出菜单在其中显示的 Component

setInvoker

public void setInvoker(Component invoker)
设置此弹出菜单的调用者，即弹出菜单在其中显示的组件。

参数：
invoker - 弹出菜单在其中显示的 Component

show

public void show(Component invoker,
                 int x,
                 int y)
在组件调用者的坐标空间中的位置 X、Y 显示弹出菜单。

参数：
invoker - 弹出菜单在其空间中显示的组件
x - 用于显示弹出菜单的调用者的坐标空间中的 X 坐标
y - 用于显示弹出菜单的调用者的坐标空间中的 Y 坐标

getComponentAtIndex

@Deprecated
public Component getComponentAtIndex(int i)
已过时。 由 Container.getComponent(int) 取代

返回指定索引处的组件。

参数：
i - 组件的索引，其中 0 为第一个
返回：
该索引处的 Component

getComponentIndex

public int getComponentIndex(Component c)
返回指定组件的索引。

参数：
c - 要查找的 Component
返回：
组件的索引，其中 0 为第一个；如果未找到该组件，则返回 -1

setPopupSize

public void setPopupSize(Dimension d)
使用 Dimension 对象设置弹出窗口的大小。此操作等效于 setPreferredSize(d)。

参数：
d - 指定此组件新的大小的 Dimension。

setPopupSize

public void setPopupSize(int width,
                         int height)
将弹出窗口的大小设置为指定的宽度和高度。此操作等效于 setPreferredSize(new Dimension(width, height))。

参数：
width - 弹出窗口的新宽度（以像素为单位）
height - 弹出窗口的新高度（以像素为单位）

setSelected

public void setSelected(Component sel)
设置当前选择的组件，此方法将更改选择模型。

参数：
sel - 要选择的 Component

isBorderPainted

public boolean isBorderPainted()
检查是否应该绘制边框。

返回：
如果绘制边框，则返回 true；否则返回 false
另请参见：
setBorderPainted(boolean)

setBorderPainted

public void setBorderPainted(boolean b)
设置是否应该绘制边框。

参数：
b - 如果为 true，则绘制边框。
另请参见：
isBorderPainted()

paintBorder

protected void paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制弹出菜单的边框。

覆盖：
类 JComponent 中的 paintBorder
参数：
g - Graphics 对象
另请参见：
JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

getMargin

public Insets getMargin()
返回弹出菜单的边框与其包含内容之间的空白（以像素表示）。

返回：
包含空白值的 Insets 对象。

paramString

protected String paramString()
返回此 JPopupMenu 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JPopupMenu 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JPopupMenu 关联的 AccessibleContext。对于 JPopupMenus，AccessibleContext 采用 AccessibleJPopupMenu 的形式。必要时创建一个新的 AccessibleJPopupMenu 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJPopupMenu，它充当此 JPopupMenu 的 AccessibleContext

processMouseEvent

public void processMouseEvent(MouseEvent event,
                              MenuElement[] path,
                              MenuSelectionManager manager)
要求此方法遵守 MenuElement 接口，但它没有被实现。

指定者：
接口 MenuElement 中的 processMouseEvent
另请参见：
MenuElement.processMouseEvent(MouseEvent, MenuElement[], MenuSelectionManager)

processKeyEvent

public void processKeyEvent(KeyEvent e,
                            MenuElement[] path,
                            MenuSelectionManager manager)
如有必要，通过使用 MenuSelectionManager 的 API 处理从 MenuSelectionManager 转发的键事件并更改菜单选择。

注：不必将事件转发到子组件。此操作可以通过 MenuSelectionManager 自动完成。

指定者：
接口 MenuElement 中的 processKeyEvent
参数：
e - KeyEvent
path - MenuElement 路径数组
manager - MenuSelectionManager

menuSelectionChanged

public void menuSelectionChanged(boolean isIncluded)
当菜单栏选择发生更改以激活或取消激活此菜单时传递消息。此操作实现 javax.swing.MenuElement 接口。重写 MenuElement.menuSelectionChanged。

指定者：
接口 MenuElement 中的 menuSelectionChanged
参数：
isIncluded - 如果此菜单处于激活状态，则为 true；如果不是，则为 false
另请参见：
MenuElement.menuSelectionChanged(boolean)

getSubElements

public MenuElement[] getSubElements()
返回 MenuElement 组成的数组，包含此菜单组件的子菜单。它将只返回遵守 JMenuElement 接口的项。如果弹出菜单为 null，则返回空数组。要求此方法遵守 MenuElement 接口。

指定者：
接口 MenuElement 中的 getSubElements
返回：
MenuElement 对象的数组
另请参见：
MenuElement.getSubElements()

getComponent

public Component getComponent()
返回此 JPopupMenu 组件。

指定者：
接口 MenuElement 中的 getComponent
返回：
此 JPopupMenu 对象
另请参见：
MenuElement.getComponent()

isPopupTrigger

public boolean isPopupTrigger(MouseEvent e)
如果 JPopupMenu 的当前安装 UI 将 MouseEvent 视为弹出菜单触发器，则返回 true。

返回：
如果鼠标事件为弹出菜单触发器，则返回 true
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPopupMenu.AccessibleJPopupMenu (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JPopupMenu.AccessibleJPopupMenu

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JPopupMenu.AccessibleJPopupMenu
所有已实现的接口：
PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JPopupMenu
protected class JPopupMenu.AccessibleJPopupMenu
extends JComponent.AccessibleJComponent
implements PropertyChangeListener

此类实现 JPopupMenu 类的可访问性支持。它提供适合弹出菜单用户界面元素的 Java Accessibility API 的实现。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JPopupMenu.AccessibleJPopupMenu()
AccessibleJPopupMenu 构造方法
方法摘要
AccessibleRole | getAccessibleRole() 获得此对象的职责。
void | propertyChange(PropertyChangeEvent e) 更改绑定 (bound) 属性时调用此方法。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JPopupMenu.AccessibleJPopupMenu

protected JPopupMenu.AccessibleJPopupMenu()
AccessibleJPopupMenu 构造方法

从以下版本开始：
1.5
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获得此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

propertyChange

public void propertyChange(PropertyChangeEvent e)
更改绑定 (bound) 属性时调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。一定不能为 null。
抛出：
NullPointerException - 如果参数为 null。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JPopupMenu.Separator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JPopupMenu.Separator

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JSeparator
                    继承者  javax.swing.JPopupMenu.Separator
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
正在封闭类：
JPopupMenu
public static class JPopupMenu.Separator
extends JSeparator

弹出与菜单有关的分隔符。

嵌套类摘要
从类 javax.swing.JSeparator 继承的嵌套类/接口
JSeparator.AccessibleJSeparator
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JPopupMenu.Separator()
方法摘要
 String getUIClassID()
返回呈现此组件的 L&F 类名。
从类 javax.swing.JSeparator 继承的方法
getAccessibleContext, getOrientation, getUI, paramString, setOrientation, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JPopupMenu.Separator

public JPopupMenu.Separator()
方法详细信息

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类名。

覆盖：
类 JSeparator 中的 getUIClassID
返回：
字符串 "PopupMenuSeparatorUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JProgressBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JProgressBar

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JProgressBar
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
public class JProgressBar
extends JComponent
implements SwingConstants, Accessible

以可视化形式显示某些任务进度的组件。在任务的完成进度中，进度条显示该任务完成的百分比。此百分比通常由一个矩形以可视化形式表示，该矩形开始是空的，随着任务的完成逐渐被填充。此外，进度条可显示此百分比的文本表示形式。

JProgressBar 使用 BoundedRangeModel 作为其数据模型，以 value 属性表示该任务的“当前”状态，minimum 和 maximum 属性分别表示开始点和结束点。

要指示正在执行一个未知长度的任务，可以将进度条设置为不确定模式。不确定模式的进度条持续地显示动画来表示正进行的操作。一旦可以确定任务长度和进度量，则应该更新进度条的值，将其切换回确定模式。

下面是一个创建进度条的示例，其中 task 为返回关于该任务进度信息的对象（表示某部分操作）：

progressBar = new JProgressBar(0, task.getLengthOfTask());
progressBar.setValue(0);
progressBar.setStringPainted(true);
下面是查询该任务的当前状态以及使用返回值更新进度条值的示例：
progressBar.setValue(task.getCurrent());
下面的示例将进度条设置为不确定模式，然后在知道任务长度后切换回确定模式：
progressBar = new JProgressBar();
...//when the task of (initially) unknown length begins:
progressBar.setIndeterminate(true);
...//do some work; get length of task...
progressBar.setMaximum(newLength);
progressBar.setValue(newValue);
progressBar.setIndeterminate(false);

有关进一步的文档和完整的示例，请参阅 The Java Tutorial 中的 How to Monitor Progress 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
BasicProgressBarUI, BoundedRangeModel, SwingWorker

嵌套类摘要
protected  class JProgressBar.AccessibleJProgressBar
此类实现 JProgressBar 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected ChangeEvent | changeEvent 每个实例只需要一个 ChangeEvent，因为事件的唯一感兴趣属性是不可变源，即进度条。
protected ChangeListener | changeListener 侦听由进度条的模型发送的更改事件，并将其再次指派到在此进度条上注册的更改事件侦听器。
protected BoundedRangeModel | model 保存进度条数据的对象。
protected int | orientation 进度条是水平的还是垂直的。
protected boolean | paintBorder 是否显示围绕进度条的边框。
protected boolean | paintString 是否在进度条上显示文本的字符串。
protected String | progressString 可以在进度条上显示的可选字符串。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JProgressBar()
创建一个显示边框但不带进度字符串的水平进度条。
JProgressBar(BoundedRangeModel newModel)
创建使用指定的保存进度条数据模型的水平进度条。
JProgressBar(int orient)
创建具有指定方向（SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）的进度条。
JProgressBar(int min, int max)
创建具有指定最小值和最大值的水平进度条。
JProgressBar(int orient, int min, int max)
创建使用指定方向、最小值和最大值的进度条。
方法摘要
void | addChangeListener(ChangeListener l) 将指定的 ChangeListener 添加到进度条。
protected ChangeListener | createChangeListener() 要以不同方式处理来自模型的更改事件的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
protected void | fireStateChanged() 将一个 ChangeEvent（其源是此 JProgressBar）发送给针对 ChangeEvent 的所有已注册 ChangeListener。
AccessibleContext | getAccessibleContext() 获得与此 JProgressBar 关联的 AccessibleContext。
ChangeListener[] | getChangeListeners() 返回通过 addChangeListener 添加到此进度条的所有 ChangeListener 组成的数组。
int | getMaximum() 从 BoundedRangeModel 返回进度条的 maximum 值。
int | getMinimum() 从 BoundedRangeModel 返回进度条的 minimum 值。
BoundedRangeModel | getModel() 返回此进度条使用的数据模型。
int | getOrientation() 根据进度条的方向返回 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
double | getPercentComplete() 返回进度条的完成百分比。
String | getString() 返回当前进度的 String 表示形式。
ProgressBarUI | getUI() 返回呈现此组件的外观对象。
String | getUIClassID() 返回呈现此组件的外观类的名称。
int | getValue() 从 BoundedRangeModel 返回进度条的当前 value。
boolean | isBorderPainted() 返回 borderPainted 属性。
boolean | isIndeterminate() 返回 indeterminate 属性的值。
boolean | isStringPainted() 返回 stringPainted 属性的值。
protected void | paintBorder(Graphics g) 如果 borderPainted 属性为 true，则绘制进度条的边框。
protected String | paramString() 返回此 JProgressBar 的字符串表示形式。
void | removeChangeListener(ChangeListener l) 从进度条移除 ChangeListener。
void | setBorderPainted(boolean b) 设置 borderPainted 属性，如果进度条应该绘制其边框，则此属性为 true。
void | setIndeterminate(boolean newValue) 设置进度条的 indeterminate 属性，该属性确定进度条处于确定模式中还是处于不确定模式中。
void | setMaximum(int n) 将进度条的最大值（存储在进度条的数据模型中）设置为 n。
void | setMinimum(int n) 将进度条的最小值（存储在进度条的数据模型中）设置为 n。
void | setModel(BoundedRangeModel newModel) 设置 JProgressBar 使用的数据模型。
void | setOrientation(int newOrientation) 将进度条的方向设置为 newOrientation（必须为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）。
void | setString(String s) 设置进度字符串的值。
void | setStringPainted(boolean b) 设置 stringPainted 属性的值，该属性确定进度条是否应该呈现进度字符串。
void | setUI(ProgressBarUI ui) 设置呈现此组件的外观对象。
void | setValue(int n) 将进度条的当前值设置为 n。
void | updateUI() 将 UI 属性重置为当前外观对应的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

orientation

protected int orientation
进度条是水平的还是垂直的。默认值为 HORIZONTAL。

另请参见：
setOrientation(int)

paintBorder

protected boolean paintBorder
是否显示围绕进度条的边框。默认值为 true。

另请参见：
setBorderPainted(boolean)

model

protected BoundedRangeModel model
保存进度条数据的对象。

另请参见：
setModel(javax.swing.BoundedRangeModel)

progressString

protected String progressString
可以在进度条上显示的可选字符串。默认值为 null。将此值设置为非 null 值并不表示将显示该字符串。要显示该字符串，paintString 必须为 true。

另请参见：
setString(java.lang.String), setStringPainted(boolean)

paintString

protected boolean paintString
是否在进度条上显示文本的字符串。默认值为 false。将此值设置为 true 可在进度条上呈现进度的文本显示。如果 progressString 为 null，则在进度条上显示完成的百分比。否则，在进度条上呈现 progressString。

另请参见：
setStringPainted(boolean), setString(java.lang.String)

changeEvent

protected transient ChangeEvent changeEvent
每个实例只需要一个 ChangeEvent，因为事件的唯一感兴趣属性是不可变源，即进度条。首次触发该事件通知以延迟方式创建该事件。

另请参见：
fireStateChanged()

changeListener

protected ChangeListener changeListener
侦听由进度条的模型发送的更改事件，并将其再次指派到在此进度条上注册的更改事件侦听器。

另请参见：
createChangeListener()
构造方法详细信息

JProgressBar

public JProgressBar()
创建一个显示边框但不带进度字符串的水平进度条。初始值和最小值都为 0，最大值为 100。

另请参见：
setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

JProgressBar

public JProgressBar(int orient)
创建具有指定方向（SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）的进度条。默认情况下，绘制边框但不绘制进度字符串。初始值和最小值都为 0，最大值为 100。

参数：
orient - 所需进度条方向
抛出：
IllegalArgumentException - 如果 orient 为非法值
另请参见：
setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

JProgressBar

public JProgressBar(int min,
                    int max)
创建具有指定最小值和最大值的水平进度条。将进度条的初始值设置为指定最小值。默认情况下，绘制边框但不绘制进度字符串。

保存进度条数据的 BoundedRangeModel 可处理由于在进度条上不正确地设置了最小值、初始值和最大值而引起的任何问题。有关详细信息，请参阅 BoundedRangeModel 文档。

参数：
min - 进度条的最小值
max - 进度条的最大值
另请参见：
BoundedRangeModel, setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

JProgressBar

public JProgressBar(int orient,
                    int min,
                    int max)
创建使用指定方向、最小值和最大值的进度条。默认情况下，绘制边框但不绘制进度字符串。将进度条的初始值设置为指定最小值。

保存进度条数据的 BoundedRangeModel 可处理由于在进度条上不正确地设置了最小值、初始值和最大值而引起的任何问题。有关详细信息，请参阅 BoundedRangeModel 文档。

参数：
orient - 所需的进度条方向
min - 进度条的最小值
max - 进度条的最大值
抛出：
IllegalArgumentException - 如果 orient 为非法值
另请参见：
BoundedRangeModel, setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)

JProgressBar

public JProgressBar(BoundedRangeModel newModel)
创建使用指定的保存进度条数据模型的水平进度条。默认情况下，绘制边框但不绘制进度字符串。

参数：
newModel - 进度条的数据模型。
另请参见：
setOrientation(int), setBorderPainted(boolean), setStringPainted(boolean), setString(java.lang.String), setIndeterminate(boolean)
方法详细信息

getOrientation

public int getOrientation()
根据进度条的方向返回 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。默认方向为 SwingConstants.HORIZONTAL。

返回：
HORIZONTAL 或 VERTICAL
另请参见：
setOrientation(int)

setOrientation

public void setOrientation(int newOrientation)
将进度条的方向设置为 newOrientation（必须为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL）。默认方向为 SwingConstants.HORIZONTAL。

参数：
newOrientation - HORIZONTAL 或 VERTICAL
抛出：
IllegalArgumentException - 如果 newOrientation 为非法值
另请参见：
getOrientation()

isStringPainted

public boolean isStringPainted()
返回 stringPainted 属性的值。

返回：
stringPainted 属性的值
另请参见：
setStringPainted(boolean), setString(java.lang.String)

setStringPainted

public void setStringPainted(boolean b)
设置 stringPainted 属性的值，该属性确定进度条是否应该呈现进度字符串。默认值为 false，意味着不绘制任何字符串。有些外观可能不支持进度字符串，或者只有在进度条处于确定模式时才支持它们。

参数：
b - 如果进度条应该呈现字符串，则该参数为 true
另请参见：
isStringPainted(), setString(java.lang.String)

getString

public String getString()
返回当前进度的 String 表示形式。默认情况下，此方法根据从 getPercentComplete 返回的值返回一个简单的百分比 String。比如说 "42%"。可通过调用 setString 更改该字符串。

返回：
进度字符串的值；如果进度字符串为 null，则返回一个简单的百分比字符串
另请参见：
setString(java.lang.String)

setString

public void setString(String s)
设置进度字符串的值。默认情况下，此字符串为 null，隐含使用简单百分比字符串的内置行为。如果已提供自定义进度字符串并要转换回内置状态，将字符串设置回 null 即可。

仅当 isStringPainted 方法返回 true 时绘制进度字符串。

参数：
s - 进度字符串的值
另请参见：
getString(), setStringPainted(boolean), isStringPainted()

getPercentComplete

public double getPercentComplete()
返回进度条的完成百分比。注意，此数介于 0.0 和 1.0 之间。

返回：
此进度条的完成百分比

isBorderPainted

public boolean isBorderPainted()
返回 borderPainted 属性。

返回：
borderPainted 属性的值
另请参见：
setBorderPainted(boolean)

setBorderPainted

public void setBorderPainted(boolean b)
设置 borderPainted 属性，如果进度条应该绘制其边框，则此属性为 true。此属性的默认值为 true。一些外观也许不实现绘制的边框；它们将忽略此属性。

参数：
b - 如果进度条应该绘制边框，则为 true；否则为 false
另请参见：
isBorderPainted()

paintBorder

protected void paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制进度条的边框。

覆盖：
类 JComponent 中的 paintBorder
参数：
g - 用于绘制边框的 Graphics 上下文
另请参见：
JComponent.paint(java.awt.Graphics),
JComponent.setBorder(javax.swing.border.Border),
isBorderPainted(),
setBorderPainted(boolean)

getUI

public ProgressBarUI getUI()
返回呈现此组件的外观对象。

返回：
呈现此组件的 ProgressBarUI 对象

setUI

public void setUI(ProgressBarUI ui)
设置呈现此组件的外观对象。

参数：
ui - ProgressBarUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
将 UI 属性重置为当前外观对应的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的外观类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "ProgressBarUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

createChangeListener

protected ChangeListener createChangeListener()
要以不同方式处理来自模型的更改事件的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。默认 ChangeListener 调用 fireStateChanged 方法将 ChangeEvent 转发给直接添加到进度条的 ChangeListener。

另请参见：
changeListener, fireStateChanged(), ChangeListener, BoundedRangeModel

addChangeListener

public void addChangeListener(ChangeListener l)
将指定的 ChangeListener 添加到进度条。

参数：
l - 要添加的 ChangeListener

removeChangeListener

public void removeChangeListener(ChangeListener l)
从进度条移除 ChangeListener。

参数：
l - 要移除的 ChangeListener

getChangeListeners

public ChangeListener[] getChangeListeners()
返回通过 addChangeListener 添加到此进度条的所有 ChangeListener 组成的数组。

返回：
所有添加的 ChangeListener；如果没有添加任何侦听器，则返回一个空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
将一个 ChangeEvent（其源是此 JProgressBar）发送给针对 ChangeEvent 的所有已注册 ChangeListener。每次从该模型接收 ChangeEvent 时调用此方法。

如果需要，将创建事件实例并存储在 changeEvent 中。

另请参见：
addChangeListener(javax.swing.event.ChangeListener), EventListenerList

getModel

public BoundedRangeModel getModel()
返回此进度条使用的数据模型。

返回：
当前使用的 BoundedRangeModel
另请参见：
setModel(javax.swing.BoundedRangeModel), BoundedRangeModel

setModel

public void setModel(BoundedRangeModel newModel)
设置 JProgressBar 使用的数据模型。注意，BoundedRangeModel 的 extent 未被使用，并设置为 0。

参数：
newModel - 要使用的 BoundedRangeModel

getValue

public int getValue()
从 BoundedRangeModel 返回进度条的当前 value。该值始终介于最小值和最大值之间（包括两者）。

返回：
进度条的当前值
另请参见：
setValue(int), BoundedRangeModel.getValue()

getMinimum

public int getMinimum()
从 BoundedRangeModel 返回进度条的 minimum 值。

返回：
进度条的最小值
另请参见：
setMinimum(int), BoundedRangeModel.getMinimum()

getMaximum

public int getMaximum()
从 BoundedRangeModel 返回进度条的 maximum 值。

返回：
进度条的最大值
另请参见：
setMaximum(int), BoundedRangeModel.getMaximum()

setValue

public void setValue(int n)
将进度条的当前值设置为 n。此方法将新值转发到该模型。

数据模型（BoundedRangeModel 实例）处理因赋值不当而引起的所有数学问题。有关详细信息，请参阅 BoundedRangeModel 文档。

如果新值不同于以前的值，则通知所有的更改侦听器。

参数：
n - 新值
另请参见：
getValue(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setValue(int)

setMinimum

public void setMinimum(int n)
将进度条的最小值（存储在进度条的数据模型中）设置为 n。

数据模型（BoundedRangeModel 实例）处理因赋值不当而引起的所有数学问题。有关详细信息，请参阅 BoundedRangeModel 文档。

如果该最小值不同于以前的最小值，则通知所有的更改侦听器。

参数：
n - 新值
另请参见：
getMinimum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMinimum(int)

setMaximum

public void setMaximum(int n)
将进度条的最大值（存储在进度条的数据模型中）设置为 n。

底层 BoundedRangeModel 处理因赋值不当而引起的所有数学问题。有关详细信息，请参阅 BoundedRangeModel 文档。

如果该最大值不同于以前的最大值，则通知所有的更改侦听器。

参数：
n - 新最大值
另请参见：
getMaximum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMaximum(int)

setIndeterminate

public void setIndeterminate(boolean newValue)
设置进度条的 indeterminate 属性，该属性确定进度条处于确定模式中还是处于不确定模式中。不确定进度条连续地显示动画，指示发生未知长度的操作。默认情况下，此属性为 false。有些外观可能不支持不确定进度条；它们将忽略此属性。

请参阅 How to Monitor Progress 以获取使用不确定进度条的示例。

参数：
newValue - 如果进度条应该更改为不确定模式，则为 true；如果应该转换回常规模式，则为 false。
从以下版本开始：
1.4
另请参见：
isIndeterminate(), BasicProgressBarUI

isIndeterminate

public boolean isIndeterminate()
返回 indeterminate 属性的值。

返回：
indeterminate 属性的值
从以下版本开始：
1.4
另请参见：
setIndeterminate(boolean)

paramString

protected String paramString()
返回此 JProgressBar 的字符串表示形式。此方法仅用于调试目的。返回的字符串内容和格式在各种实现间可能各不相同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JProgressBar 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得与此 JProgressBar 关联的 AccessibleContext。对于进度条，AccessibleContext 采用 AccessibleJProgressBar 的形式。必要时要创建新的 AccessibleJProgressBar 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJProgressBar，它将充当此 JProgressBar 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JProgressBar.AccessibleJProgressBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JProgressBar.AccessibleJProgressBar

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JProgressBar.AccessibleJProgressBar
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
正在封闭类：
JProgressBar
protected class JProgressBar.AccessibleJProgressBar
extends JComponent.AccessibleJComponent
implements AccessibleValue

此类实现 JProgressBar 类的可访问性支持。它提供适合进度条用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JProgressBar.AccessibleJProgressBar()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleValue | getAccessibleValue() 获得与此对象相关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的可访问值。
Number | getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | getMinimumAccessibleValue() 获取此对象的最小可访问值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JProgressBar.AccessibleJProgressBar

protected JProgressBar.AccessibleJProgressBar()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

getAccessibleValue

public AccessibleValue getAccessibleValue()
获得与此对象相关联的 AccessibleValue。在实现此对象的 Java Accessibility API 时，返回此对象，它负责代表它自己实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的可访问值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
此对象的当前值。
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 true
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小可访问值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
此对象的最小值。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大可访问值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
此对象的最大值。
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JRadioButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JRadioButton

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JToggleButton
                        继承者  javax.swing.JRadioButton
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
public class JRadioButton
extends JToggleButton
implements Accessible

实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。与 ButtonGroup 对象配合使用可创建一组按钮，一次只能选择其中的一个按钮。（创建一个 ButtonGroup 对象并用其 add 方法将 JRadioButton 对象包含在此组中。）

注：ButtonGroup 对象为逻辑分组，不是物理分组。要创建按钮面板，仍需要创建一个 JPanel 或类似的容器对象并将 Border 添加到其中以便将面板与周围的组件分开。

通过 Action 可以配置按钮，并进行一定程度的控制。对按钮使用 Action 有许多直接配置按钮所不及的优点。有关更多信息，请参阅支持 Action 的 Swing 组件，可以在 The Java Tutorial 中的 How to Use Actions 一节找到更多信息。

有关更多内容，请参阅 The Java Tutorial 中的 How to Use Buttons, Check Boxes, and Radio Buttons。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
ButtonGroup, JCheckBox

嵌套类摘要
protected  class JRadioButton.AccessibleJRadioButton
此类实现对 JRadioButton 类的可访问性支持。
从类 javax.swing.JToggleButton 继承的嵌套类/接口
JToggleButton.AccessibleJToggleButton, JToggleButton.ToggleButtonModel
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JRadioButton()
创建一个初始化为未选择的单选按钮，其文本未设定。
JRadioButton(Action a)
创建一个单选按钮，其属性来自提供的 Action。
JRadioButton(Icon icon)
创建一个初始化为未选择的单选按钮，其具有指定的图像但无文本。
JRadioButton(Icon icon, boolean selected)
创建一个具有指定图像和选择状态的单选按钮，但无文本。
JRadioButton(String text)
创建一个具有指定文本的状态为未选择的单选按钮。
JRadioButton(String text, boolean selected)
创建一个具有指定文本和选择状态的单选按钮。
JRadioButton(String text, Icon icon)
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。
JRadioButton(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JRadioButton 相关联的 AccessibleContext。
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
protected String | paramString() 返回此 JRadioButton 的字符串表示形式。
void | updateUI() 将 UI 属性重置为当前外观对应的值。
从类 javax.swing.AbstractButton 继承的方法
actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JRadioButton

public JRadioButton()
创建一个初始化为未选择的单选按钮，其文本未设定。

JRadioButton

public JRadioButton(Icon icon)
创建一个初始化为未选择的单选按钮，其具有指定的图像但无文本。

参数：
icon - 此按钮应显示的图像

JRadioButton

public JRadioButton(Action a)
创建一个单选按钮，其属性来自提供的 Action。

从以下版本开始：
1.3

JRadioButton

public JRadioButton(Icon icon,
                    boolean selected)
创建一个具有指定图像和选择状态的单选按钮，但无文本。

参数：
icon - 此按钮应显示的图像
selected - 如果为 true，按钮被初始化为选择；否则，按钮被初始化为未选择

JRadioButton

public JRadioButton(String text)
创建一个具有指定文本的状态为未选择的单选按钮。

参数：
text - 单选按钮上显示的字符串

JRadioButton

public JRadioButton(String text,
                    boolean selected)
创建一个具有指定文本和选择状态的单选按钮。

参数：
text - 单选按钮上显示的字符串
selected - 如果为 true，按钮被初始化为选择；否则，按钮被初始化为未选择

JRadioButton

public JRadioButton(String text,
                    Icon icon)
创建一个具有指定的文本和图像并初始化为未选择的单选按钮。

参数：
text - 此单选按钮上显示的字符串
icon - 此按钮应显示的图像

JRadioButton

public JRadioButton(String text,
                    Icon icon,
                    boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮。

参数：
text - 此单选按钮上显示的字符串
icon - 此按钮应显示的图像
方法详细信息

updateUI

public void updateUI()
将 UI 属性重置为当前外观对应的值。

覆盖：
类 JToggleButton 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JToggleButton 中的 getUIClassID
返回：
"RadioButtonUI" 字符串
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

paramString

protected String paramString()
返回此 JRadioButton 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JToggleButton 中的 paramString
返回：
此 JRadioButton 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JRadioButton 相关联的 AccessibleContext。对于 JRadioButton，AccessibleContext 采用 AccessibleJRadioButton 的形式。必要时创建新的 AccessibleJRadioButton 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JToggleButton 中的 getAccessibleContext
返回：
一个 AccessibleJRadioButton，它将充当此 JRadioButton 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JRadioButton.AccessibleJRadioButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JRadioButton.AccessibleJRadioButton

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JToggleButton.AccessibleJToggleButton
                            继承者  javax.swing.JRadioButton.AccessibleJRadioButton
所有已实现的接口：
ItemListener, Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
正在封闭类：
JRadioButton
protected class JRadioButton.AccessibleJRadioButton
extends JToggleButton.AccessibleJToggleButton

此类实现对 JRadioButton 类的可访问性支持。它提供适合于单选按钮用户界面元素的 Java Accessibility API 的一个实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JRadioButton.AccessibleJRadioButton()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JToggleButton.AccessibleJToggleButton 继承的方法
itemStateChanged
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JRadioButton.AccessibleJRadioButton

protected JRadioButton.AccessibleJRadioButton()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JToggleButton.AccessibleJToggleButton 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JRadioButtonMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JRadioButtonMenuItem

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JMenuItem
                        继承者  javax.swing.JRadioButtonMenuItem
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, MenuElement, SwingConstants
public class JRadioButtonMenuItem
extends JMenuItem
implements Accessible

一个单选按钮菜单项的实现。JRadioButtonMenuItem 是属于一组菜单项中的一个菜单项，该组中只能选择一个项。被选择的项显示其选择状态。选择此项的同时，其他任何以前被选择的项都切换到未选择状态。要控制一组单选按钮菜单项的选择状态，请使用 ButtonGroup 对象。

通过 Action 可以配置菜单项，并进行一定程度的控制。对菜单项使用 Action 有许多直接配置菜单项所不及的优点。有关更多信息，请参阅支持 Action 的 Swing 组件，可以在 The Java Tutorial 中的 How to Use Actions 一节找到更多信息。

有关更多内容和示例，请参阅 The Java Tutorial 中的 How to Use Menus 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
ButtonGroup

嵌套类摘要
protected  class JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
此类实现对 JRadioButtonMenuItem 类的可访问性支持。
从类 javax.swing.JMenuItem 继承的嵌套类/接口
JMenuItem.AccessibleJMenuItem
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JRadioButtonMenuItem()
创建一个未设置文本或图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Action a)
创建一个单选按钮菜单项，其属性来自提供的 Action。
JRadioButtonMenuItem(Icon icon)
创建一个带图标的 JRadioButtonMenuItem。
JRadioButtonMenuItem(Icon icon, boolean selected)
创建一个具有指定图像和选择状态的单选按钮菜单项，但无文本。
JRadioButtonMenuItem(String text)
创建一个带文本的 JRadioButtonMenuItem。
JRadioButtonMenuItem(String text, boolean selected)
创建一个具有指定文本和选择状态的单选按钮菜单项。
JRadioButtonMenuItem(String text, Icon icon)
创建一个具有指定文本和 Icon 的单选按钮菜单项。
JRadioButtonMenuItem(String text, Icon icon, boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JRadioButtonMenuItem 相关联的 AccessibleContext。
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
protected String | paramString() 返回此 JRadioButtonMenuItem 的字符串表示形式。
从类 javax.swing.JMenuItem 继承的方法
actionPropertyChanged, addMenuDragMouseListener, addMenuKeyListener, configurePropertiesFromAction, fireMenuDragMouseDragged, fireMenuDragMouseEntered, fireMenuDragMouseExited, fireMenuDragMouseReleased, fireMenuKeyPressed, fireMenuKeyReleased, fireMenuKeyTyped, getAccelerator, getComponent, getMenuDragMouseListeners, getMenuKeyListeners, getSubElements, init, isArmed, menuSelectionChanged, processKeyEvent, processMenuDragMouseEvent, processMenuKeyEvent, processMouseEvent, removeMenuDragMouseListener, removeMenuKeyListener, setAccelerator, setArmed, setEnabled, setModel, setUI, updateUI
从类 javax.swing.AbstractButton 继承的方法
addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JRadioButtonMenuItem

public JRadioButtonMenuItem()
创建一个未设置文本或图标的 JRadioButtonMenuItem。

JRadioButtonMenuItem

public JRadioButtonMenuItem(Icon icon)
创建一个带图标的 JRadioButtonMenuItem。

参数：
icon - 将在 JRadioButtonMenuItem 上显示的 Icon。

JRadioButtonMenuItem

public JRadioButtonMenuItem(String text)
创建一个带文本的 JRadioButtonMenuItem。

参数：
text - JRadioButtonMenuItem 的文本

JRadioButtonMenuItem

public JRadioButtonMenuItem(Action a)
创建一个单选按钮菜单项，其属性来自提供的 Action。

参数：
a - 将基于其建立单选按钮菜单项的 Action
从以下版本开始：
1.3

JRadioButtonMenuItem

public JRadioButtonMenuItem(String text,
                            Icon icon)
创建一个具有指定文本和 Icon 的单选按钮菜单项。

参数：
text - JRadioButtonMenuItem 的文本
icon - 将在 JRadioButtonMenuItem 上显示的图标

JRadioButtonMenuItem

public JRadioButtonMenuItem(String text,
                            boolean selected)
创建一个具有指定文本和选择状态的单选按钮菜单项。

参数：
text - CheckBoxMenuItem 的文本
selected - CheckBoxMenuItem 的选择状态

JRadioButtonMenuItem

public JRadioButtonMenuItem(Icon icon,
                            boolean selected)
创建一个具有指定图像和选择状态的单选按钮菜单项，但无文本。

参数：
icon - 此按钮应显示的图像
selected - 如果为 true，按钮被初始化为选择；否则，按钮被初始化为未选择

JRadioButtonMenuItem

public JRadioButtonMenuItem(String text,
                            Icon icon,
                            boolean selected)
创建一个具有指定的文本、图像和选择状态的单选按钮菜单项。所有其他构造方法都隶属于此方法。

参数：
text - 此单选按钮上显示的字符串
icon - 此按钮应显示的图像
方法详细信息

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JMenuItem 中的 getUIClassID
返回：
"RadioButtonMenuItemUI" 字符串
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

paramString

protected String paramString()
返回此 JRadioButtonMenuItem 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JMenuItem 中的 paramString
返回：
此 JRadioButtonMenuItem 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JRadioButtonMenuItem 相关联的 AccessibleContext。对于 JRadioButtonMenuItem，AccessibleContext 采用 AccessibleJRadioButtonMenuItem 的形式。必要时创建新的 AccessibleJRadioButtonMenuItem 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JMenuItem 中的 getAccessibleContext
返回：
一个 AccessibleJRadioButtonMenuItem，它充当此 JRadioButtonMenuItem 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JMenuItem.AccessibleJMenuItem
                            继承者  javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
正在封闭类：
JRadioButtonMenuItem
protected class JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
extends JMenuItem.AccessibleJMenuItem

此类实现对 JRadioButtonMenuItem 类的可访问性支持。它提供适合 JRadioButtonMenuItem 用户界面元素的 Java Accessibility API 实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JMenuItem.AccessibleJMenuItem 继承的方法
stateChanged
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem

protected JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JMenuItem.AccessibleJMenuItem 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JRootPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JRootPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JRootPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JRootPane
extends JComponent
implements Accessible

该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。有关根窗格所提供功能的面向任务的信息，请参阅 The Java Tutorial 中的 How to Use Root Panes 一节。

下面的图像显示了使用根窗格的各个类之间的关系。

“重量级”组件（指委托给主机系统上的同位体或本地组件的组件）用较暗的、更重的框来显示。四个重量级 JFC/Swing 容器（JFrame、JDialog、JWindow 和 JApplet）的显示与它们扩展的 AWT 类有关。这四个组件是 Swing 库中仅有的重量级容器。这里还显示了轻量级容器 JInternalFrame。所有这五个 JFC/Swing 容器都实现 RootPaneContainer 接口，并且它们都将其操作委托给 JRootPane（顶端显示有一个小 "handle"）。
注：使用 JComponent 的 getRootPane 方法可获取包含给定组件的 JRootPane。
以下文本是对此图像的描述。
右图显示了 JRootPane 的结构。JRootpane 由一个 glassPane 和一个可选的 menuBar 以及一个 contentPane 组成。（JLayeredPane 负责管理 menuBar 和 contentPane。）glassPane 位于所有窗格之上，以便能够截取鼠标移动。由于 glassPane（与 contentPane 类似）可以是一个任意的组件，也可以设置 glassPane 来进行绘制。这样 glassPane 上的线条和图像可涵盖其下的窗体，不受其边界的限制。

尽管 menuBar 组件为可选，但 layeredPane、contentPane 和 glassPane 总是存在的。试图将它们设置为 null 将生成异常。

要将组件添加到 JRootPane（可选的菜单栏除外），您可以将对象添加到 JRootPane 的 contentPane，如下所示：

       rootPane.getContentPane().add(child);
可用同样的方法设置布局管理器、移除组件以及列出子级等。所有这些方法都是在 contentPane 上而不是 JRootPane 上调用的。
注：contentPane 的默认布局管理器是 BorderLayout 管理器。但是，JRootPane 使用一个自定义的 LayoutManager。所以，如果您希望更改已添加到 JRootPane 中的组件的布局管理器，一定要确保使用如下代码：
    rootPane.getContentPane().setLayout(new BoxLayout());
如果已在 JRootPane 上设置了 JMenuBar 组件，它将沿窗体的上边缘放置。contentPane 的位置和大小将进行调整以填充剩余的区域。（JMenuBar 和 contentPane 被添加到位于 JLayeredPane.FRAME_CONTENT_LAYER 层的 layeredPane 组件中。)

layeredPane 是 JRootPane 中所有子级的父级，既是菜单的直接父级，又是添加到 contentPane 中的所有组件的祖父级。它是 JLayeredPane 的实例，提供在若干层上添加组件的能力。在处理弹出菜单、对话框以及拖动时，即要求将组件置于窗格中所有其它组件之上的情况下，此功能非常有用。

glassPane 位于 JRootPane 中所有其它组件之上。这为在所有其它组件上绘图和截取鼠标事件提供了方便，这对拖动和绘图都非常有用。开发人员可在 glassPane 上使用 setVisible 控制 glassPane 在所有其它子级上面显示的时间。默认情况下，glassPane 为不可见。

JRootPane 所使用的自定义 LayoutManager 可确保：

  1. glassPane 填充了 JRootPane 的整个可查看区域（边界 - insets）。
  2. layeredPane 填充了 JRootPane 的整个可查看区域。（边界 - insets）
  3. menuBar 位于 layeredPane 的上边缘。
  4. contentPane 填充了整个可查看区域，减去 menuBar（如果有）。
JRootPane 视图层次结构中的任何其它视图均忽略。

如果您替换 JRootPane 的 LayoutManager，您将负责管理所有这些视图。所以通常情况下，应该确保更改的是 contentPane 的布局管理器，而不是 JRootPane 自身的布局管理器。

Swing 的绘制架构要求在所有其它组件之上的包含层次结构中有一个不透明的 JComponent。这通常通过使用内容窗格来实现。如果要替换内容窗格，建议使用 setOpaque(true) 将内容窗格设置为不透明。另外，如果内容窗格重写 paintComponent，还需要在 paintComponent 中用不透明颜色将背景完全填充。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JLayeredPane, JMenuBar, JWindow, JFrame, JDialog, JApplet, JInternalFrame, JComponent, BoxLayout, Mixing Heavy and Light Components

嵌套类摘要
protected class | JRootPane.AccessibleJRootPane 此类实现对 JRootPane 类的可访问性支持。
protected class | JRootPane.RootLayout 该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | COLOR_CHOOSER_DIALOG 供 windowDecorationStyle 属性使用的常量。
protected Container | contentPane 内容窗格。
protected JButton | defaultButton 当窗格成为焦点并有类似按下 Enter 键的特定于 UI 的操作发生时被激活的按钮。
protected javax.swing.JRootPane.DefaultAction | defaultPressAction 已过时。 从 Java 2 platform v1.3 开始
protected javax.swing.JRootPane.DefaultAction | defaultReleaseAction 已过时。 从 Java 2 platform v1.3 开始
static int | ERROR_DIALOG 供 windowDecorationStyle 属性使用的常量。
static int | FILE_CHOOSER_DIALOG 供 windowDecorationStyle 属性使用的常量。
static int | FRAME 供 windowDecorationStyle 属性使用的常量。
protected Component | glassPane 覆盖菜单栏和内容窗格的玻璃窗格，便于截取鼠标移动等操作。
static int | INFORMATION_DIALOG 供 windowDecorationStyle 属性使用的常量。
protected JLayeredPane | layeredPane 管理菜单栏和内容窗格的分层窗格。
protected JMenuBar | menuBar 菜单栏。
static int | NONE 供 windowDecorationStyle 属性使用的常量。
static int | PLAIN_DIALOG 供 windowDecorationStyle 属性使用的常量。
static int | QUESTION_DIALOG 供 windowDecorationStyle 属性使用的常量。
static int | WARNING_DIALOG 供 windowDecorationStyle 属性使用的常量。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JRootPane()
创建 JRootPane，设置其 glassPane、layeredPane 以及 contentPane。
方法摘要
protected  void addImpl(Component comp, Object constraints, int index)
重写以便将玻璃组件的位置强行设置成零位子级。
 void addNotify()
将本身注册为 SystemEventQueueUtils 的新的根窗格。
protected  Container createContentPane()
由构造方法调用以便创建默认的 contentPane。
protected  Component createGlassPane()
由构造方法调用以便创建默认的 glassPane。
protected  JLayeredPane createLayeredPane()
由构造方法调用以便创建默认的 layeredPane。
protected  LayoutManager createRootLayout()
由构造方法调用以便创建默认的 layoutManager。
 AccessibleContext getAccessibleContext()
获取与此 JRootPane 相关联的 AccessibleContext。
 Container getContentPane()
返回内容窗格，它是保存以根窗格为父级的组件的容器。
 JButton getDefaultButton()
返回 defaultButton 属性的值。
 Component getGlassPane()
返回此 JRootPane 的当前玻璃窗格。
 JMenuBar getJMenuBar()
返回窗格层的菜单栏。
 JLayeredPane getLayeredPane()
获取供根窗格使用的分层窗格。
 JMenuBar getMenuBar()
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。
 RootPaneUI getUI()
返回呈现此组件的 L&F 对象。
 String getUIClassID()
返回一个指定呈现此组件的 L&F 类名称的字符串。
 int getWindowDecorationStyle()
返回一个常量，它标识 JRootPane 提供的 Window 装饰类型。
 boolean isOptimizedDrawingEnabled()
glassPane 和 contentPane 具有相同的边界，这意味着 JRootPane 并不对其子级平铺，应返回 false。
 boolean isValidateRoot()
如果此 JRootPane 的一个后代调用 revalidate，将从此位置开始进行验证。
protected  String paramString()
返回此 JRootPane 的字符串表示形式。
 void removeNotify()
将本身从 SystemEventQueueUtils 注销。
 void setContentPane(Container content)
设置内容窗格，它是保存以根窗格为父级的组件的容器。
 void setDefaultButton(JButton defaultButton)
设置 defaultButton 属性，它确定此 JRootPane 的当前默认按钮。
 void setDoubleBuffered(boolean aFlag)
设置此组件是否应该使用缓冲区进行绘制。
 void setGlassPane(Component glass)
将指定的 Component 设置为此根窗格的玻璃窗格。
 void setJMenuBar(JMenuBar menu)
添加或更改在分层窗格中使用的菜单栏。
 void setLayeredPane(JLayeredPane layered)
设置供根窗格使用的分层窗格。
 void setMenuBar(JMenuBar menu)
已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。
 void setUI(RootPaneUI ui)
设置呈现此组件的 L&F 对象。
 void setWindowDecorationStyle(int windowDecorationStyle)
设置 JRootPane 应提供的 Window 装饰类型（例如，边界、关闭 Window 的小部件、标题等）。
 void updateUI()
将 UI 属性重置为当前外观对应的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

NONE

public static final int NONE
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 不应提供任何类型的 Window 装饰。

从以下版本开始：
1.4
另请参见：
常量字段值

FRAME

public static final int FRAME
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Frame 的装饰。

从以下版本开始：
1.4
另请参见：
常量字段值

PLAIN_DIALOG

public static final int PLAIN_DIALOG
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Dialog 的装饰。

从以下版本开始：
1.4
另请参见：
常量字段值

INFORMATION_DIALOG

public static final int INFORMATION_DIALOG
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Dialog 的装饰以便显示一条报告消息。

从以下版本开始：
1.4
另请参见：
常量字段值

ERROR_DIALOG

public static final int ERROR_DIALOG
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Dialog 的装饰以便显示一条错误消息。

从以下版本开始：
1.4
另请参见：
常量字段值

COLOR_CHOOSER_DIALOG

public static final int COLOR_CHOOSER_DIALOG
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Dialog 的装饰以便显示 JColorChooser。

从以下版本开始：
1.4
另请参见：
常量字段值

FILE_CHOOSER_DIALOG

public static final int FILE_CHOOSER_DIALOG
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Dialog 的装饰以便显示 JFileChooser。

从以下版本开始：
1.4
另请参见：
常量字段值

QUESTION_DIALOG

public static final int QUESTION_DIALOG
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Dialog 的装饰以便向用户显示一个问题。

从以下版本开始：
1.4
另请参见：
常量字段值

WARNING_DIALOG

public static final int WARNING_DIALOG
供 windowDecorationStyle 属性使用的常量。指示 JRootPane 应提供适合 Dialog 的装饰以便显示一条警告消息。

从以下版本开始：
1.4
另请参见：
常量字段值

menuBar

protected JMenuBar menuBar
菜单栏。

contentPane

protected Container contentPane
内容窗格。

layeredPane

protected JLayeredPane layeredPane
管理菜单栏和内容窗格的分层窗格。

glassPane

protected Component glassPane
覆盖菜单栏和内容窗格的玻璃窗格，便于截取鼠标移动等操作。

defaultButton

protected JButton defaultButton
当窗格成为焦点并有类似按下 Enter 键的特定于 UI 的操作发生时被激活的按钮。

defaultPressAction

@Deprecated
protected javax.swing.JRootPane.DefaultAction defaultPressAction
已过时。 从 Java 2 platform v1.3 开始
从 Java 2 platform v1.3 开始，此无用字段已不再使用。要重写默认的按钮，应在 JRootPane 的 ActionMap 中替换 Action。有关更多详细信息，请参阅键绑定规范。

另请参见：
defaultButton

defaultReleaseAction

@Deprecated
protected javax.swing.JRootPane.DefaultAction defaultReleaseAction
已过时。 从 Java 2 platform v1.3 开始
从 Java 2 platform v1.3 开始，此无用字段已不再使用。要重写默认的按钮，应在 JRootPane 的 ActionMap 中替换 Action。有关更多详细信息，请参阅键绑定规范。

另请参见：
defaultButton
构造方法详细信息

JRootPane

public JRootPane()
创建 JRootPane，设置其 glassPane、layeredPane 以及 contentPane。

方法详细信息

setDoubleBuffered

public void setDoubleBuffered(boolean aFlag)
设置此组件是否应该使用缓冲区进行绘制。如果设置为 true，则此组件的所有绘制将在一个离屏绘制缓冲区内完成。然后将该离屏绘制缓冲区复制到屏幕上。如果缓冲了某个 Component，并且还缓冲了它的某个祖先，则将使用该祖先缓冲区。

覆盖：
类 JComponent 中的 setDoubleBuffered
参数：
aFlag - 如果为 true，则设置此组件使用双缓冲区进行缓冲
从以下版本开始：
1.6

getWindowDecorationStyle

public int getWindowDecorationStyle()
返回一个常量，它标识 JRootPane 提供的 Window 装饰类型。

返回：
NONE、FRAME、PLAIN_DIALOG、INFORMATION_DIALOG、ERROR_DIALOG、COLOR_CHOOSER_DIALOG、FILE_CHOOSER_DIALOG、QUESTION_DIALOG 或 WARNING_DIALOG 之一。
从以下版本开始：
1.4
另请参见：
setWindowDecorationStyle(int)

setWindowDecorationStyle

public void setWindowDecorationStyle(int windowDecorationStyle)
设置 JRootPane 应提供的 Window 装饰类型（例如，边界、关闭 Window 的小部件、标题等）。默认不提供任何 Window 装饰 (NONE)。

这只是一个提示，有些外观可能不支持。这是一个绑定属性。

参数：
windowDecorationStyle - 标识要提供的 Window 装饰的常量。
抛出：
IllegalArgumentException - 如果 style 不是下列常量之一：NONE、FRAME、PLAIN_DIALOG、INFORMATION_DIALOG、ERROR_DIALOG、COLOR_CHOOSER_DIALOG、FILE_CHOOSER_DIALOG、QUESTION_DIALOG 或 WARNING_DIALOG。
从以下版本开始：
1.4
另请参见：
JDialog.setDefaultLookAndFeelDecorated(boolean),
JFrame.setDefaultLookAndFeelDecorated(boolean),
LookAndFeel.getSupportsWindowDecorations()

getUI

public RootPaneUI getUI()
返回呈现此组件的 L&F 对象。

返回：
LabelUI 对象
从以下版本开始：
1.3

setUI

public void setUI(RootPaneUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - LabelUI L&F 对象
从以下版本开始：
1.3
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
将 UI 属性重置为当前外观对应的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回一个指定呈现此组件的 L&F 类名称的字符串。

覆盖：
类 JComponent 中的 getUIClassID
返回：
"RootPaneUI" 字符串
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

createLayeredPane

protected JLayeredPane createLayeredPane()
由构造方法调用以便创建默认的 layeredPane。默认情况下创建一个新的 JLayeredPane。

返回：
默认的 layeredPane

createContentPane

protected Container createContentPane()
由构造方法调用以便创建默认的 contentPane。默认情况下，此方法创建新的 JComponent 并将 BorderLayout 设置为它的 LayoutManager。

返回：
默认的 contentPane

createGlassPane

protected Component createGlassPane()
由构造方法调用以便创建默认的 glassPane。默认情况下，此方法创建新的 JComponent，其可见性设置为 false。

返回：
默认的 glassPane

createRootLayout

protected LayoutManager createRootLayout()
由构造方法调用以便创建默认的 layoutManager。

返回：
默认的 layoutManager.

setJMenuBar

public void setJMenuBar(JMenuBar menu)
添加或更改在分层窗格中使用的菜单栏。

参数：
menu - 要添加的 JMenuBar

setMenuBar

@Deprecated
public void setMenuBar(JMenuBar menu)
已过时。 从 Swing 版本 1.0.3 开始，由 setJMenuBar(JMenuBar menu) 取代。

指定菜单栏的值。

参数：
menu - 要添加的 JMenuBar。

getJMenuBar

public JMenuBar getJMenuBar()
返回窗格层的菜单栏。

返回：
该窗格中使用的 JMenuBar

getMenuBar

@Deprecated
public JMenuBar getMenuBar()
已过时。 从 Swing 版本 1.0.3 开始，由 getJMenuBar() 取代。

返回菜单栏的值。

返回：
窗格中使用的 JMenuBar

setContentPane

public void setContentPane(Container content)
设置内容窗格，它是保存以根窗格为父级的组件的容器。

Swing 的绘制架构要求在包含层次结构中有一个不透明的 JComponent。这通常由内容窗格提供。如果要替换内容窗格，则建议用一个不透明的 JComponent 来替代。

参数：
content - 供组件内容使用的 Container
抛出：
IllegalComponentStateException - （运行时异常）如果内容窗格参数为 null

getContentPane

public Container getContentPane()
返回内容窗格，它是保存以根窗格为父级的组件的容器。

返回：
保存组件内容的 Container

setLayeredPane

public void setLayeredPane(JLayeredPane layered)
设置供根窗格使用的分层窗格。分层窗格通常容纳一个内容窗格和一个可选的 JMenuBar。

参数：
layered - 要使用的 JLayeredPane
抛出：
IllegalComponentStateException - （运行时异常）如果分层窗格参数为 null

getLayeredPane

public JLayeredPane getLayeredPane()
获取供根窗格使用的分层窗格。分层窗格通常保存一个内容窗格和一个可选的 JMenuBar。

返回：
当前使用的 JLayeredPane

setGlassPane

public void setGlassPane(Component glass)
将指定的 Component 设置为此根窗格的玻璃窗格。玻璃窗格通常应该是一个轻量级的、透明的组件，因为每当根窗格需要抓取输入事件时会将它设置为可见。

更改新玻璃窗格的可见性，以匹配当前玻璃窗格的可见性。其含义是，当想要替换玻璃窗格并使其可见时必须要小心。以下代码之一将起作用：

   root.setGlassPane(newGlassPane);
   newGlassPane.setVisible(true);
或者：
   root.getGlassPane().setVisible(true);
   root.setGlassPane(newGlassPane);

参数：
glass - 要用作此 JRootPane 的玻璃窗格的 Component
抛出：
NullPointerException - 如果 glass 参数为 null

getGlassPane

public Component getGlassPane()
返回此 JRootPane 的当前玻璃窗格。

返回：
当前的玻璃窗格
另请参见：
setGlassPane(java.awt.Component)

isValidateRoot

public boolean isValidateRoot()
如果此 JRootPane 的一个后代调用 revalidate，将从此位置开始进行验证。

推迟对一个组件及其后代再次布局的请求。例如，对 revalidate 的调用被上推至 JRootPane 或 JScrollPane，因为两个类都重写 isValidateRoot 以返回 true。

覆盖：
类 JComponent 中的 isValidateRoot
返回：
true
另请参见：
JComponent.isValidateRoot()

isOptimizedDrawingEnabled

public boolean isOptimizedDrawingEnabled()
glassPane 和 contentPane 具有相同的边界，这意味着 JRootPane 并不对其子级平铺，应返回 false。另一方面，glassPane 通常为不可见，所以如果 glassPane 为不可见时，它会返回 true。因此，这里的返回值取决于 glassPane 的可见性。

覆盖：
类 JComponent 中的 isOptimizedDrawingEnabled
返回：
如果此组件的子级不重叠，则返回 true

addNotify

public void addNotify()
将本身注册为 SystemEventQueueUtils 的新的根窗格。

覆盖：
类 JComponent 中的 addNotify
另请参见：
JComponent.registerKeyboardAction(java.awt.event.ActionListener, java.lang.String, javax.swing.KeyStroke, int)

removeNotify

public void removeNotify()
将本身从 SystemEventQueueUtils 注销。

覆盖：
类 JComponent 中的 removeNotify
另请参见：
addNotify()

setDefaultButton

public void setDefaultButton(JButton defaultButton)
设置 defaultButton 属性，它确定此 JRootPane 的当前默认按钮。默认的按钮是根窗格中发生 UI 定义的激活事件（通常是 Enter 键）时将被激活的按钮，无论按钮是否成为键盘焦点（除非根窗格中另有一个组件使用此激活事件，例如一个 JTextPane）。为使默认的激活正常工作，在激活发生时该按钮必须是根窗格的一个已启用的后代。要从此根窗格移除一个默认的按钮，设置此属性为 null。

参数：
defaultButton - 将成为默认按钮的 JButton
另请参见：
JButton.isDefaultButton()

getDefaultButton

public JButton getDefaultButton()
返回 defaultButton 属性的值。

返回：
当前为默认按钮的 JButton
另请参见：
setDefaultButton(javax.swing.JButton)

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
重写以便将玻璃组件的位置强行设置成零位子级。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要增强的组件
constraints - 要遵守的约束条件
index - 索引
另请参见：
Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
LayoutManager,
LayoutManager2

paramString

protected String paramString()
返回此 JRootPane 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JRootPane 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JRootPane 相关联的 AccessibleContext。对于根窗格，AccessibleContext 采用 AccessibleJRootPane 的形式。必要时创建新的 AccessibleJRootPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJRootPane，它充当此 JRootPane 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTable

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JTable
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, EventListener, Accessible, CellEditorListener, ListSelectionListener, RowSorterListener, TableColumnModelListener, TableModelListener, Scrollable
public class JTable
extends JComponent
implements TableModelListener, Scrollable, TableColumnModelListener, ListSelectionListener, CellEditorListener, Accessible, RowSorterListener

JTable 用来显示和编辑常规二维单元表。有关面向任务的文档和使用 JTable 的示例，请参阅 The Java Tutorial 中的 How to Use Tables 一节。

JTable 有很多用来自定义其呈现和编辑的工具，同时提供了这些功能的默认设置，从而可以轻松地设置简单表。例如，要设置一个 10 行 10 列的表：

      TableModel dataModel = new AbstractTableModel() {
          public int getColumnCount() { return 10; }
          public int getRowCount() { return 10;}
          public Object getValueAt(int row, int col) { return new Integer(row*col); }
      };
      JTable table = new JTable(dataModel);
      JScrollPane scrollpane = new JScrollPane(table);

注意，如果要在单独的视图中（在 JScrollPane 外）使用 JTable 并显示表标题，则可以使用 getTableHeader() 获取并单独显示它。

要启用行的排序和过滤，请使用 RowSorter。可以通过以下两种方式之一设置一个行排序器。

  • 直接设置 RowSorter。例如：table.setRowSorter(new TableRowSorter(model))。
  • 将 autoCreateRowSorter 属性设置为 true，从而 JTable 可用于创建 RowSorter。例如：setAutoCreateRowSorter(true)。

设计使用 JTable 的应用程序时，务必要注意用来表示表数据的数据结构。DefaultTableModel 是一个模型实现，它使用一个 Vector 来存储所有单元格的值，该 Vector 由包含多个 Object 的 Vector 组成。除了将数据从应用程序复制到 DefaultTableModel 中之外，还可以用 TableModel 接口的方法来包装数据，这样可将数据直接传递到 JTable，如上例所示。这通常可以提高应用程序的效率，因为模型可以自由选择最适合数据的内部表示形式。在决定使用 AbstractTableModel 还是使用 DefaultTableModel 方面有一个好的实践经验，即在创建子类时使用 AbstractTableModel 作为基类，在不需要创建子类时则使用 DefaultTableModel。

源分布演示部分中的 "TableExample" 目录给出了许多 JTable 用法的完整示例，包括如何使用 JTable 来提供一个可编辑的数据视图（数据取自数据库），以及如何修改显示的列以使用指定的渲染器和编辑器。

JTable 使用专有的整数来引用它所显示的模型的行和列。JTable 采用表格的单元格范围，并在绘制时使用 getValueAt(int, int) 从模型中获取值。务必记住各种 JTable 方法所返回的列和行索引是就 JTable（视图）而言的，不一定是模型所使用的那些索引。

默认情况下，在 JTable 中对列进行重新安排，这样在视图中列的出现顺序与模型中列的顺序不同。但这根本不影响模型的实现：当列重新排列时，JTable 在内部保持列的新顺序，并在查询模型前转换其列索引。

因此编写 TableModel 时，不必侦听列的重排事件，因为不管视图怎样，模型都将在其自己的坐标系统被查询。在示例部分中有一个排序算法的演示，此演示正是使用了此技术在另一个坐标系统中进行排序，其中更改了行顺序，没有更改列顺序。

类似地，使用 RowSorter 提供的排序和过滤功能时，底层 TableModel 不需要知道怎样进行排序，RowSorter 将处理它。对底层 TableModel 使用 JTable 的基于行的方法时，必须进行坐标转换。所有基于 JTable 行的方法都是就 RowSorter 而言的，不一定与底层 TableModel 的方法相同。例如，选择始终是就 JTable 而言的，因此使用 RowSorter 时，需要使用 convertRowIndexToView 或 convertRowIndexToModel 进行转换。以下代码显示了如何将 JTable 的坐标转换为底层模型的坐标：

   int[] selection = table.getSelectedRows();
   for (int i = 0; i < selection.length; i++) {
     selection[i] = table.convertRowIndexToModel(selection[i]);
   }
   // selection is now in terms of the underlying TableModel

默认情况下，如果启用排序，那么排序时 JTable 将保留基于模型的选择和可变行高度。例如，如果当前选择行 0（就底层模型而言），那么排序之后将选择行 0（就底层模型而言）。选择有可能看起来被更改了，但就底层模型而言它仍然保持不变。模型索引不再可见或者被移除时除外。例如，如果行 0 被过滤掉了，那么选择在排序后将为空。

J2SE 5 在 JTable 中添加了一些方法，为某些普通打印需求提供方便的访问。print() 是一个简单的新方法，它允许快速简单地向应用程序添加打印支持。此外，新的 getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat) 方法可用于更高级的打印需求。

对于所有的 JComponent 类，可以使用 InputMap 和 ActionMap 将 Action 对象与 KeyStroke 进行关联，并在指定的条件下执行动作。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
DefaultTableModel, TableRowSorter

嵌套类摘要
protected class | JTable.AccessibleJTable 此类实现对 JTable 类的可访问性支持。
static class | JTable.DropLocation TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。
static class | JTable.PrintMode 用于打印 JTable 的打印模式。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static int | AUTO_RESIZE_ALL_COLUMNS 在所有的调整大小操作中，按比例调整所有的列。
static int | AUTO_RESIZE_LAST_COLUMN 在所有的调整大小操作中，只对最后一列进行调整。
static int | AUTO_RESIZE_NEXT_COLUMN 在 UI 中调整了一个列时，对其下一列进行相反方向的调整。
static int | AUTO_RESIZE_OFF 不自动调整列的宽度；使用滚动条。
static int | AUTO_RESIZE_SUBSEQUENT_COLUMNS 在 UI 调整中，更改后续列以保持总宽度不变；此为默认行为。
protected boolean | autoCreateColumnsFromModel 如果为 true，则表对 TableModel 进行查询以构建默认列集。
protected int | autoResizeMode 确定表是否自动调整列的宽度以占用表的整个宽度，以及如何进行调整。
protected TableCellEditor | cellEditor 活动单元格编辑器对象，它重写当前单元格占用的屏幕空间，并允许用户更改其内容。
protected boolean | cellSelectionEnabled 从 Java 2 平台 v1.3 开始已过时。
protected TableColumnModel | columnModel 表的 TableColumnModel。
protected TableModel | dataModel 表的 TableModel。
protected Hashtable | defaultEditorsByColumnClass 一个由对象组成的表，它显示并编辑单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
protected Hashtable | defaultRenderersByColumnClass 一个由对象组成的表，它显示单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。
protected int | editingColumn 标识所编辑的单元格的列。
protected int | editingRow 标识所编辑的单元格的行。
protected Component | editorComp 在编辑时处理编辑的 Component。
protected Color | gridColor 网格的颜色。
protected Dimension | preferredViewportSize Scrollable 接口使用它来确定初始的可见区域。
protected int | rowHeight 表中每一行的高度，以像素为单位。
protected int | rowMargin 每行中单元格之间间距的高度，以像素为单位。
protected boolean | rowSelectionAllowed 如果行选择在此表中是允许的，则返回 true。
protected Color | selectionBackground 已选定单元格的背景色。
protected Color | selectionForeground 已选定单元格的前景色。
protected ListSelectionModel | selectionModel 表的 ListSelectionModel，用来追踪行选择。
protected boolean | showHorizontalLines 如果 showHorizontalLines 为 true，则表在单元格之间绘制水平行。
protected boolean | showVerticalLines 如果 showVerticalLines 为 true，则表在单元格之间绘制垂直行。
protected JTableHeader | tableHeader 表所使用的 TableHeader。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTable()
构造一个默认的 JTable，使用默认的数据模型、默认的列模型和默认的选择模型对其进行初始化。
JTable(int numRows, int numColumns)
使用 DefaultTableModel 构造具有 numRows 行和 numColumns 列个空单元格的 JTable。
JTable(Object[][] rowData, Object[] columnNames)
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。
JTable(TableModel dm)
构造一个 JTable，使用数据模型 dm、默认的列模型和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。
JTable(TableModel dm, TableColumnModel cm, ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。
JTable(Vector rowData, Vector columnNames)
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。
方法摘要
void | addColumn(TableColumn aColumn) 将 aColumn 追加到此 JTable 的列模型所保持的列数组的尾部。
void | addColumnSelectionInterval(int index0, int index1) 将从 index0 到 index1 之间（包含两端）的列添加到当前选择中。
void | addNotify() 调用 configureEnclosingScrollPane 方法。
void | addRowSelectionInterval(int index0, int index1) 将从 index0 到 index1 之间（包含两端）的行添加到当前选择中。
void | changeSelection(int rowIndex, int columnIndex, boolean toggle, boolean extend) 根据 toggle 和 extend 这两个标志的状态，更新表的选择模型。
void | clearSelection() 取消选中所有已选定的行和列。
void | columnAdded(TableColumnModelEvent e) 将列添加到表的列模型时调用。
int | columnAtPoint(Point point) 返回 point 所在的列索引；如果结果不在 [0, getColumnCount()-1] 范围内，则返回 -1。
void | columnMarginChanged(ChangeEvent e) 当列由于间距的更改而被移动时调用。
void | columnMoved(TableColumnModelEvent e) 重新定位列时调用。
void | columnRemoved(TableColumnModelEvent e) 从表的列模型中移除列时调用。
void | columnSelectionChanged(ListSelectionEvent e) TableColumnModel 的选择模型更改时调用。
protected void | configureEnclosingScrollPane() 如果此 JTable 是一个封闭 JScrollPane 的 viewportView（通常情况如此），那么可通过安装表的 tableHeader 作为滚动窗格的 columnHeaderView 来配置此 ScrollPane。
int | convertColumnIndexToModel(int viewColumnIndex) 将视图中位于 viewColumnIndex 的列索引映射到表模型中的列索引。
int | convertColumnIndexToView(int modelColumnIndex) 将表模型中位于 modelColumnIndex 的列索引映射到视图中的列索引。
int | convertRowIndexToModel(int viewRowIndex) 将基于视图的行索引映射到底层 TableModel。
int | convertRowIndexToView(int modelRowIndex) 将基于 TableModel 的行索引映射到该视图。
protected TableColumnModel | createDefaultColumnModel() 返回默认的列模型对象，它是一个 DefaultTableColumnModel。
void | createDefaultColumnsFromModel() 使用 TableModel 接口中定义的 getColumnCount 方法根据数据模型创建默认的表列。
protected TableModel | createDefaultDataModel() 返回默认的表模型对象，它是一个 DefaultTableModel。
protected void | createDefaultEditors() 为 object、number 和 boolean 值创建默认的单元格编辑器。
protected void | createDefaultRenderers() 为 object、number、double、date、boolean 和 icon 创建默认的单元格渲染器。
protected ListSelectionModel | createDefaultSelectionModel() 返回默认的选择模型对象，它是一个 DefaultListSelectionModel。
protected JTableHeader | createDefaultTableHeader() 返回默认的表标题对象，它是一个 JTableHeader。
static JScrollPane | createScrollPaneForTable(JTable aTable) 已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。
void | doLayout() 使此表布局其行和列。
boolean | editCellAt(int row, int column) 如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
boolean | editCellAt(int row, int column, EventObject e) 如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。
void | editingCanceled(ChangeEvent e) 编辑取消时调用。
void | editingStopped(ChangeEvent e) 编辑结束时调用。
AccessibleContext | getAccessibleContext() 获取与此 JTable 关联的 AccessibleContext。
boolean | getAutoCreateColumnsFromModel() 确定表是否要根据模型创建默认的列。
boolean | getAutoCreateRowSorter() 如果每当模型更改时，都应该创建一个新 RowSorter 并作为该表的排序器安装，则返回 true；否则，返回 false。
int | getAutoResizeMode() 返回表的自动调整模式。
TableCellEditor | getCellEditor() 返回活动单元格编辑器；如果该表当前没有被编辑，则返回 null。
TableCellEditor | getCellEditor(int row, int column) 返回适用于由 row 和 column 所指定单元格的编辑器。
Rectangle | getCellRect(int row, int column, boolean includeSpacing) 返回位于 row 和 column 相交位置的单元格矩形。
TableCellRenderer | getCellRenderer(int row, int column) 返回适于由此行和列所指定单元格的渲染器。
boolean | getCellSelectionEnabled() 如果同时启用了行选择模型和列选择模型，则返回 true。
TableColumn | getColumn(Object identifier) 返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。
Class<?> | getColumnClass(int column) 返回出现在视图中 column 列位置处的列类型。
int | getColumnCount() 返回列模型中的列数。
TableColumnModel | getColumnModel() 返回包含此表所有列信息的 TableColumnModel。
String | getColumnName(int column) 返回出现在视图中 column 列位置处的列名称。
boolean | getColumnSelectionAllowed() 如果可以选择列，则返回 true。
TableCellEditor | getDefaultEditor(Class<?> columnClass) 尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。
TableCellRenderer | getDefaultRenderer(Class<?> columnClass) 尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。
boolean | getDragEnabled() 返回是否启用自动拖动处理。
JTable.DropLocation | getDropLocation() 返回对组件的 DnD 操作期间此组件应该可见地指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。
DropMode | getDropMode() 返回此组件的放置模式。
int | getEditingColumn() 返回包含当前被编辑的单元格的列索引。
int | getEditingRow() 返回包含当前被编辑的单元格的行索引。
Component | getEditorComponent() 返回处理编辑会话的组件。
boolean | getFillsViewportHeight() 返回此表是否始终大到足以填充封闭视口的高度。
Color | getGridColor() 返回用来绘制网格线的颜色。
Dimension | getIntercellSpacing() 返回单元格之间的水平间距和垂直间距。
TableModel | getModel() 返回提供此 JTable 所显示数据的 TableModel。
Dimension | getPreferredScrollableViewportSize() 返回此表视口的首选大小。
Printable | getPrintable(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 返回打印此 JTable 中所使用的 Printable。
int | getRowCount() 返回 JTable 中可以显示的行数（给定无限空间）。
int | getRowHeight() 返回表的行高，以像素为单位。
int | getRowHeight(int row) 返回 row 中单元格的高度，以像素为单位。
int | getRowMargin() 获取单元格之间的间距，以像素为单位。
boolean | getRowSelectionAllowed() 如果可以选择行，则返回 true。
RowSorter<? extends TableModel> | getRowSorter() 返回负责排序的对象。
int | getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction) 返回 visibleRect.height 或 visibleRect.width，这取决于此表的方向。
boolean | getScrollableTracksViewportHeight() 返回 false 指示表的高度不是由视口的高度决定的，除非 getFillsViewportHeight 为 true 并且该表的首选高度小于视口的高度。
boolean | getScrollableTracksViewportWidth() 如果 autoResizeMode 设置为 AUTO_RESIZE_OFF，则返回 false，这指示表的宽度不是由视口的宽度决定的。
int | getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction) 返回完全呈现出一个新行或新列（取决于方向）的滚动增量（以像素为单位）。
int | getSelectedColumn() 返回第一个选定列的索引；如果没有选定的列，则返回 -1。
int | getSelectedColumnCount() 返回选定列数。
int[] | getSelectedColumns() 返回所有选定列的索引。
int | getSelectedRow() 返回第一个选定行的索引；如果没有选定的行，则返回 -1。
int | getSelectedRowCount() 返回选定行数。
int[] | getSelectedRows() 返回所有选定行的索引。
Color | getSelectionBackground() 返回选定单元格的背景色。
Color | getSelectionForeground() 返回选定单元格的前景色。
ListSelectionModel | getSelectionModel() 返回用来维持行选择状态的 ListSelectionModel。
boolean | getShowHorizontalLines() 如果表绘制单元格之间的水平线，则返回 true，否则返回 false。
boolean | getShowVerticalLines() 如果表绘制单元格之间的垂直线，则返回 true，否则返回 false。
boolean | getSurrendersFocusOnKeystroke() 如果在键击导致编辑器被激活时编辑器应该获得焦点，则返回 true
JTableHeader | getTableHeader() 返回此 JTable 所使用的 tableHeader。
String | getToolTipText(MouseEvent event) 重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。
TableUI | getUI() 返回呈现此组件的 L&F 对象。
String | getUIClassID() 返回用于构造呈现此组件时所用 L&F 类名称的后缀。
boolean | getUpdateSelectionOnSort() 如果排序后应该更新选择，则返回 true。
Object | getValueAt(int row, int column) 返回 row 和 column 位置的单元格值。
protected void | initializeLocalVars() 将表的属性初始化为其默认值。
boolean | isCellEditable(int row, int column) 如果 row 和 column 位置的单元格是可编辑的，则返回 true。
boolean | isCellSelected(int row, int column) 如果指定的索引位于行和列的有效范围内，并且位于该指定位置的单元格被选定，则返回 true。
boolean | isColumnSelected(int column) 如果指定的索引位于列的有效范围内，并且位于该索引的列被选定，则返回 true。
boolean | isEditing() 如果正在编辑单元格，则返回 true。
boolean | isRowSelected(int row) 如果指定的索引位于行的有效范围内，并且位于该索引的行被选定，则返回 true。
void | moveColumn(int column, int targetColumn) 将视图中的 column 列移动到当前被 targetColumn 列所占用的位置。
protected String | paramString() 返回此表的字符串表示形式。
Component | prepareEditor(TableCellEditor editor, int row, int column) 通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。
Component | prepareRenderer(TableCellRenderer renderer, int row, int column) 通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。
boolean | print() 一个便捷的方法，它显示一个打印对话框，然后以 PrintMode.FIT_WIDTH 模式打印此 JTable，不打印标题或脚注文本。
boolean | print(JTable.PrintMode printMode) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。
boolean | print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat) 一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。
boolean | print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive) 根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。
boolean | print(JTable.PrintMode printMode, MessageFormat headerFormat, MessageFormat footerFormat, boolean showPrintDialog, PrintRequestAttributeSet attr, boolean interactive, PrintService service) 打印此 JTable。
protected boolean | processKeyBinding(KeyStroke ks, KeyEvent e, int condition, boolean pressed) 由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。
void | removeColumn(TableColumn aColumn) 从此 JTable 的列数组中移除 aColumn。
void | removeColumnSelectionInterval(int index0, int index1) 取消选中从 index0 到 index1 之间（包含两端）的列。
void | removeEditor() 丢弃编辑器对象并释放它用于单元格呈现的资源。
void | removeNotify() 调用 unconfigureEnclosingScrollPane 方法。
void | removeRowSelectionInterval(int index0, int index1) 取消选中从 index0 到 index1 之间（包含两端）的行。
protected void | resizeAndRepaint() 等效于先调用 revalidate 再调用 repaint。
int | rowAtPoint(Point point) 返回 point 所在的行索引；如果结果不在 [0, getRowCount()-1] 范围内，则返回 -1。
void | selectAll() 选择表中的所有行、列和单元格。
void | setAutoCreateColumnsFromModel(boolean autoCreateColumnsFromModel) 设置此表的 autoCreateColumnsFromModel 标志。
void | setAutoCreateRowSorter(boolean autoCreateRowSorter) 指定其模型更改时是否应该为表创建一个 RowSorter。
void | setAutoResizeMode(int mode) 当调整表的大小时，设置表的自动调整模式。
void | setCellEditor(TableCellEditor anEditor) 设置活动单元格编辑器。
void | setCellSelectionEnabled(boolean cellSelectionEnabled) 设置此表是否允许同时存在行选择和列选择。
void | setColumnModel(TableColumnModel columnModel) 将此表的列模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
void | setColumnSelectionAllowed(boolean columnSelectionAllowed) 设置是否可以选择此模型中的列。
void | setColumnSelectionInterval(int index0, int index1) 选择从 index0 到 index1 之间（包含两端）的列。
void | setDefaultEditor(Class<?> columnClass, TableCellEditor editor) 如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。
void | setDefaultRenderer(Class<?> columnClass, TableCellRenderer renderer) 如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。
void | setDragEnabled(boolean b) 打开或关闭自动拖动处理。
void | setDropMode(DropMode dropMode) 设置此组件的放置模式。
void | setEditingColumn(int aColumn) 设置 editingColumn 变量。
void | setEditingRow(int aRow) 设置 editingRow 变量。
void | setFillsViewportHeight(boolean fillsViewportHeight) 设置此表是否始终大到足以填充封闭视口的高度。
void | setGridColor(Color gridColor) 将用来绘制网格线的颜色设置为 gridColor 并重新显示它。
void | setIntercellSpacing(Dimension intercellSpacing) 将 rowMargin 和 columnMargin（单元格之间间距的高度和宽度）设置为 intercellSpacing。
void | setModel(TableModel dataModel) 将此表的数据模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
void | setPreferredScrollableViewportSize(Dimension size) 设置此表视口的首选大小。
void | setRowHeight(int rowHeight) 将所有单元格的高度设置为 rowHeight（以像素为单位），重新验证并重新绘制它。
void | setRowHeight(int row, int rowHeight) 将 row 的高度设置为 rowHeight，重新验证并重新绘制它。
void | setRowMargin(int rowMargin) 设置相临行中单元格之间的间距。
void | setRowSelectionAllowed(boolean rowSelectionAllowed) 设置是否可以选择此模型中的行。
void | setRowSelectionInterval(int index0, int index1) 选择从 index0 到 index1 之间（包含两端）的行。
void | setRowSorter(RowSorter<? extends TableModel> sorter) 设置 RowSorter。
void | setSelectionBackground(Color selectionBackground) 设置选定单元格的背景色。
void | setSelectionForeground(Color selectionForeground) 设置选定单元格的前景色。
void | setSelectionMode(int selectionMode) 将表的选择模式设置为只允许单个选择、单个连续间隔选择或多间隔选择。
void | setSelectionModel(ListSelectionModel newModel) 将此表的行选择模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。
void | setShowGrid(boolean showGrid) 设置表是否绘制单元格周围的网格线。
void | setShowHorizontalLines(boolean showHorizontalLines) 设置表是否绘制单元格之间的水平线。
void | setShowVerticalLines(boolean showVerticalLines) 设置表是否绘制单元格之间的垂直线。
void | setSurrendersFocusOnKeystroke(boolean surrendersFocusOnKeystroke) 设置由于 JTable 为某个单元格转发键盘事件而导致编辑器被激活时，此 JTable 中的编辑器是否获得键盘焦点。
void | setTableHeader(JTableHeader tableHeader) 将此 JTable 所使用的 tableHeader 设置为 newHeader。
void | setUI(TableUI ui) 设置呈现此组件并进行重新绘制的 L&F 对象。
void | setUpdateSelectionOnSort(boolean update) 指定排序后是否应该更新选择。
void | setValueAt(Object aValue, int row, int column) 设置表模型中 row 和 column 位置的单元格值。
void | sizeColumnsToFit(boolean lastColumnOnly) 已过时。 从 Swing version 1.0.3 开始，由 doLayout() 取代。
void | sizeColumnsToFit(int resizingColumn) 从 Java 2 平台 v1.4 开始已过时。
void | sorterChanged(RowSorterEvent e) RowSorter 以某种方式发生了更改的 RowSorterListener 通知。
void | tableChanged(TableModelEvent e) 当此表的 TableModel 生成 TableModelEvent 时调用。
protected void | unconfigureEnclosingScrollPane() 通过将封闭滚动窗格的 columnHeaderView 替换为 null，可以起到 configureEnclosingScrollPane 的相反作用。
void | updateUI() UIManager 发出的表明 L&F 已经更改的通知。
void | valueChanged(ListSelectionEvent e) 行选择更改时调用，重新绘制来显示新的选择。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

AUTO_RESIZE_OFF

public static final int AUTO_RESIZE_OFF
不自动调整列的宽度；使用滚动条。

另请参见：
常量字段值

AUTO_RESIZE_NEXT_COLUMN

public static final int AUTO_RESIZE_NEXT_COLUMN
在 UI 中调整了一个列时，对其下一列进行相反方向的调整。

另请参见：
常量字段值

AUTO_RESIZE_SUBSEQUENT_COLUMNS

public static final int AUTO_RESIZE_SUBSEQUENT_COLUMNS
在 UI 调整中，更改后续列以保持总宽度不变；此为默认行为。

另请参见：
常量字段值

AUTO_RESIZE_LAST_COLUMN

public static final int AUTO_RESIZE_LAST_COLUMN
在所有的调整大小操作中，只对最后一列进行调整。

另请参见：
常量字段值

AUTO_RESIZE_ALL_COLUMNS

public static final int AUTO_RESIZE_ALL_COLUMNS
在所有的调整大小操作中，按比例调整所有的列。

另请参见：
常量字段值

dataModel

protected TableModel dataModel
表的 TableModel。

columnModel

protected TableColumnModel columnModel
表的 TableColumnModel。

selectionModel

protected ListSelectionModel selectionModel
表的 ListSelectionModel，用来追踪行选择。

tableHeader

protected JTableHeader tableHeader
表所使用的 TableHeader。

rowHeight

protected int rowHeight
表中每一行的高度，以像素为单位。

rowMargin

protected int rowMargin
每行中单元格之间间距的高度，以像素为单位。

gridColor

protected Color gridColor
网格的颜色。

showHorizontalLines

protected boolean showHorizontalLines
如果 showHorizontalLines 为 true，则表在单元格之间绘制水平行。

showVerticalLines

protected boolean showVerticalLines
如果 showVerticalLines 为 true，则表在单元格之间绘制垂直行。

autoResizeMode

protected int autoResizeMode
确定表是否自动调整列的宽度以占用表的整个宽度，以及如何进行调整。

autoCreateColumnsFromModel

protected boolean autoCreateColumnsFromModel
如果为 true，则表对 TableModel 进行查询以构建默认列集。

preferredViewportSize

protected Dimension preferredViewportSize
Scrollable 接口使用它来确定初始的可见区域。

rowSelectionAllowed

protected boolean rowSelectionAllowed
如果行选择在此表中是允许的，则返回 true。

cellSelectionEnabled

protected boolean cellSelectionEnabled
从 Java 2 平台 v1.3 开始已过时。请使用 rowSelectionAllowed 属性和 columnModel 的 columnSelectionAllowed 属性，或者使用方法 getCellSelectionEnabled。

editorComp

protected transient Component editorComp
在编辑时处理编辑的 Component。

cellEditor

protected transient TableCellEditor cellEditor
活动单元格编辑器对象，它重写当前单元格占用的屏幕空间，并允许用户更改其内容。如果当前没有编辑该表，则为 null。

editingColumn

protected transient int editingColumn
标识所编辑的单元格的列。

editingRow

protected transient int editingRow
标识所编辑的单元格的行。

defaultRenderersByColumnClass

protected transient Hashtable defaultRenderersByColumnClass
一个由对象组成的表，它显示单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。

defaultEditorsByColumnClass

protected transient Hashtable defaultEditorsByColumnClass
一个由对象组成的表，它显示并编辑单元格的内容，通过在 TableModel 接口的 getColumnClass 中所声明的类建立索引。

selectionForeground

protected Color selectionForeground
已选定单元格的前景色。

selectionBackground

protected Color selectionBackground
已选定单元格的背景色。

构造方法详细信息

JTable

public JTable()
构造一个默认的 JTable，使用默认的数据模型、默认的列模型和默认的选择模型对其进行初始化。

另请参见：
createDefaultDataModel(),
createDefaultColumnModel(),
createDefaultSelectionModel()

JTable

public JTable(TableModel dm)
构造一个 JTable，使用数据模型 dm、默认的列模型和默认的选择模型对其进行初始化。

参数：
dm - 表的数据模型
另请参见：
createDefaultColumnModel(), createDefaultSelectionModel()

JTable

public JTable(TableModel dm,
              TableColumnModel cm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和默认的选择模型对其进行初始化。

参数：
dm - 表的数据模型
cm - 表的列模型
另请参见：
createDefaultSelectionModel()

JTable

public JTable(TableModel dm,
              TableColumnModel cm,
              ListSelectionModel sm)
构造一个 JTable，使用数据模型 dm、列模型 cm 和选择模型 sm 对其进行初始化。如果任何参数为 null，则此方法将使用相应的默认模型初始化表。如果 cm 为非 null，则 autoCreateColumnsFromModel 标志被设置为 false，否则设置为 true，并使用 dm 中各列的合适 TableColumn 来填充列模型。

参数：
dm - 表的数据模型
cm - 表的列模型
sm - 表的行选择模型
另请参见：
createDefaultDataModel(),
createDefaultColumnModel(),
createDefaultSelectionModel()

JTable

public JTable(int numRows,
              int numColumns)
使用 DefaultTableModel 构造具有 numRows 行和 numColumns 列个空单元格的 JTable。列名称采用 "A"、"B"、"C" 等形式。

参数：
numRows - 表所拥有的行数
numColumns - 表所拥有的列数
另请参见：
DefaultTableModel

JTable

public JTable(Vector rowData,
              Vector columnNames)
构造一个 JTable 来显示 Vector 所组成的 Vector rowData 中的值，其列名称为 columnNames。rowData 中包含的 Vector 应该包含该行的值。换句话说，可以通过以下代码获取第 1 行，第 5 列单元格的值：

((Vector)rowData.elementAt(1)).elementAt(5);

参数：
rowData - 新表的数据
columnNames - 每列的名称

JTable

public JTable(Object[][] rowData,
              Object[] columnNames)
构造一个 JTable 来显示二维数组 rowData 中的值，其列名称为 columnNames。rowData 是一个行数组，因此可以通过以下代码获取第 1 行，第 5 列单元格的值：

 rowData[1][5];

所有行的长度必须与 columnNames 的长度相同。

参数：
rowData - 新表的数据
columnNames - 每列的名称
方法详细信息

addNotify

public void addNotify()
调用 configureEnclosingScrollPane 方法。

覆盖：
类 JComponent 中的 addNotify
另请参见：
configureEnclosingScrollPane()

configureEnclosingScrollPane

protected void configureEnclosingScrollPane()
如果此 JTable 是一个封闭 JScrollPane 的 viewportView（通常情况如此），那么可通过安装表的 tableHeader 作为滚动窗格的 columnHeaderView 来配置此 ScrollPane。以正常方式向 JScrollPane 添加 JTable 时，请使用 new JScrollPane(myTable)，addNotify 是在 JTable 中调用的（表被添加到视口中时）。JTable 的 addNotify 方法将调用此方法，此方法是受保护的，以便子类可以重写此默认的安装过程。

另请参见：
addNotify()

removeNotify

public void removeNotify()
调用 unconfigureEnclosingScrollPane 方法。

覆盖：
类 JComponent 中的 removeNotify
另请参见：
unconfigureEnclosingScrollPane()

unconfigureEnclosingScrollPane

protected void unconfigureEnclosingScrollPane()
通过将封闭滚动窗格的 columnHeaderView 替换为 null，可以起到 configureEnclosingScrollPane 的相反作用。JTable 的 removeNotify 方法调用此方法，此方法是受保护的，以便子类可以重写此默认的卸载过程。

从以下版本开始：
1.3
另请参见：
removeNotify(), configureEnclosingScrollPane()

createScrollPaneForTable

@Deprecated
public static JScrollPane createScrollPaneForTable(JTable aTable)
已过时。 从 Swing version 1.0.2 开始，由 new JScrollPane(aTable) 取代。

等效于 new JScrollPane(aTable)。

setTableHeader

public void setTableHeader(JTableHeader tableHeader)
将此 JTable 所使用的 tableHeader 设置为 newHeader。tableHeader 为 null 是合法的。

参数：
tableHeader - 新的 tableHeader
另请参见：
getTableHeader()

getTableHeader

public JTableHeader getTableHeader()
返回此 JTable 所使用的 tableHeader。

返回：
此表所使用的 tableHeader
另请参见：
setTableHeader(javax.swing.table.JTableHeader)

setRowHeight

public void setRowHeight(int rowHeight)
将所有单元格的高度设置为 rowHeight（以像素为单位），重新验证并重新绘制它。单元格的高度等于行高减去行间距。

参数：
rowHeight - 新的行高
抛出：
IllegalArgumentException - 如果 rowHeight 小于 1
另请参见：
getRowHeight()

getRowHeight

public int getRowHeight()
返回表的行高，以像素为单位。默认的行高为 16.0。

返回：
表的行高，以像素为单位
另请参见：
setRowHeight(int)

setRowHeight

public void setRowHeight(int row,
                         int rowHeight)
将 row 的高度设置为 rowHeight，重新验证并重新绘制它。此行中单元格的高度等于行高减去行间距。

参数：
row - 更改高度的行
rowHeight - 新的行高，以像素为单位
抛出：
IllegalArgumentException - 如果 rowHeight 小于 1
从以下版本开始：
1.3

getRowHeight

public int getRowHeight(int row)
返回 row 中单元格的高度，以像素为单位。

参数：
row - 要返回其高度的行
返回：
行中单元格的高度，以像素为单位
从以下版本开始：
1.3

setRowMargin

public void setRowMargin(int rowMargin)
设置相临行中单元格之间的间距。

参数：
rowMargin - 一行中单元格之间的像素数
另请参见：
getRowMargin()

getRowMargin

public int getRowMargin()
获取单元格之间的间距，以像素为单位。等效于：getIntercellSpacing().height。

返回：
一行中单元格之间的像素数
另请参见：
setRowMargin(int)

setIntercellSpacing

public void setIntercellSpacing(Dimension intercellSpacing)
将 rowMargin 和 columnMargin（单元格之间间距的高度和宽度）设置为 intercellSpacing。

参数：
intercellSpacing - 指定单元格之间新高度和宽度的 Dimension
另请参见：
getIntercellSpacing()

getIntercellSpacing

public Dimension getIntercellSpacing()
返回单元格之间的水平间距和垂直间距。默认的间距为 (1, 1)，它为绘制网格提供了空间。

返回：
单元格之间的水平间距和垂直间距
另请参见：
setIntercellSpacing(java.awt.Dimension)

setGridColor

public void setGridColor(Color gridColor)
将用来绘制网格线的颜色设置为 gridColor 并重新显示它。默认的颜色取决于外观。

参数：
gridColor - 网格线的新颜色
抛出：
IllegalArgumentException - 如果 gridColor 为 null
另请参见：
getGridColor()

getGridColor

public Color getGridColor()
返回用来绘制网格线的颜色。默认的颜色取决于外观。

返回：
用来绘制网格线的颜色
另请参见：
setGridColor(java.awt.Color)

setShowGrid

public void setShowGrid(boolean showGrid)
设置表是否绘制单元格周围的网格线。如果 showGrid 为 true，则绘制网格线；如果为 false，则不绘制。没有 getShowGrid 方法，因为此状态保存在两个变量中，即 showHorizontalLines 和 showVerticalLines，可以对其中任何一个变量单独进行查询。

参数：
showGrid - 如果表视图应该绘制网格线，则为 true
另请参见：
setShowVerticalLines(boolean), setShowHorizontalLines(boolean)

setShowHorizontalLines

public void setShowHorizontalLines(boolean showHorizontalLines)
设置表是否绘制单元格之间的水平线。如果 showHorizontalLines 为 true，则绘制水平线；如果为 false，则不绘制。

参数：
showHorizontalLines - 如果表视图应该绘制水平线，则为 true
另请参见：
getShowHorizontalLines(), setShowGrid(boolean), setShowVerticalLines(boolean)

setShowVerticalLines

public void setShowVerticalLines(boolean showVerticalLines)
设置表是否绘制单元格之间的垂直线。如果 showVerticalLines 为 true，则绘制垂直线；如果为 false，则不绘制。

参数：
showVerticalLines - 如果表视图应该绘制垂直线，则为 true
另请参见：
getShowVerticalLines(), setShowGrid(boolean), setShowHorizontalLines(boolean)

getShowHorizontalLines

public boolean getShowHorizontalLines()
如果表绘制单元格之间的水平线，则返回 true，否则返回 false。默认值为 true。

返回：
如果表绘制单元格之间的水平线，则返回 true；否则返回 false
另请参见：
setShowHorizontalLines(boolean)

getShowVerticalLines

public boolean getShowVerticalLines()
如果表绘制单元格之间的垂直线，则返回 true，否则返回 false。默认值为 true。

返回：
如果表绘制单元格之间的垂直线，则返回 true；否则返回 false
另请参见：
setShowVerticalLines(boolean)

setAutoResizeMode

public void setAutoResizeMode(int mode)
当调整表的大小时，设置表的自动调整模式。

参数：
mode - 5 个合法值之一：AUTO_RESIZE_OFF、AUTO_RESIZE_NEXT_COLUMN、AUTO_RESIZE_SUBSEQUENT_COLUMNS、AUTO_RESIZE_LAST_COLUMN、AUTO_RESIZE_ALL_COLUMNS
另请参见：
getAutoResizeMode(), doLayout()

getAutoResizeMode

public int getAutoResizeMode()
返回表的自动调整模式。默认的模式为 AUTO_RESIZE_SUBSEQUENT_COLUMNS。

返回：
表的 autoResizeMode
另请参见：
setAutoResizeMode(int), doLayout()

setAutoCreateColumnsFromModel

public void setAutoCreateColumnsFromModel(boolean autoCreateColumnsFromModel)
设置此表的 autoCreateColumnsFromModel 标志。如果 autoCreateColumnsFromModel 由 false 更改为 true，则此方法调用 createDefaultColumnsFromModel。

参数：
autoCreateColumnsFromModel - 如果 JTable 应该自动创建列，则为 true
另请参见：
getAutoCreateColumnsFromModel(), createDefaultColumnsFromModel()

getAutoCreateColumnsFromModel

public boolean getAutoCreateColumnsFromModel()
确定表是否要根据模型创建默认的列。如果为 true，则 setModel 将清除所有现有列并根据新模型创建新的列。同样，如果 tableChanged 通知中的事件指定整个表已更改，则将重新构建各列。默认值为 true。

返回：
表的 autoCreateColumnsFromModel
另请参见：
setAutoCreateColumnsFromModel(boolean), createDefaultColumnsFromModel()

createDefaultColumnsFromModel

public void createDefaultColumnsFromModel()
使用 TableModel 接口中定义的 getColumnCount 方法根据数据模型创建默认的表列。

在根据模型的信息创建新的列之前，清除所有现有列。

另请参见：
getAutoCreateColumnsFromModel()

setDefaultRenderer

public void setDefaultRenderer(Class<?> columnClass,
                               TableCellRenderer renderer)
如果没有在 TableColumn 中设置渲染器，则设置要使用的默认单元格渲染器。如果 renderer 为 null，则移除此 columnClass 的默认渲染器。

参数：
columnClass - 设置此 columnClass 的默认单元格渲染器
renderer - 此 columnClass 要使用的默认单元格渲染器
另请参见：
getDefaultRenderer(java.lang.Class), setDefaultEditor(java.lang.Class, javax.swing.table.TableCellEditor)

getDefaultRenderer

public TableCellRenderer getDefaultRenderer(Class<?> columnClass)
尚未在 TableColumn 中设置渲染器时，返回要使用的单元格渲染器。呈现单元格时，渲染器是根据列中各单元格的类从各个项的 Hashtable 中获取的。如果没有对应于此 columnClass 的项，则此方法返回最相关超类的项。JTable 安装了对应于 Object、Number 和 Boolean 的项，它们都可以修改和替换。

参数：
columnClass - 返回此 columnClass 的默认单元格渲染器
返回：
此 columnClass 的渲染器
另请参见：
setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer), getColumnClass(int)

setDefaultEditor

public void setDefaultEditor(Class<?> columnClass,
                             TableCellEditor editor)
如果尚未在 TableColumn 中设置编辑器，则设置要使用的默认单元格编辑器。如果表不需要进行编辑，或者表中的特定列不需要编辑，则使用 TableModel 接口中的 isCellEditable 方法来确保此 JTable 在这些列中不启动编辑器。如果 editor 为 null，则移除此 columnClass 的默认编辑器。

参数：
columnClass - 设置此 columnClass 的默认单元格编辑器
editor - 此 columnClass 要使用的默认单元格编辑器
另请参见：
TableModel.isCellEditable(int, int),
getDefaultEditor(java.lang.Class),
setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer)

getDefaultEditor

public TableCellEditor getDefaultEditor(Class<?> columnClass)
尚未在 TableColumn 中设置编辑器时，返回要使用的编辑器。编辑单元格时，编辑器是根据列中各单元格的类从各项的 Hashtable 中获取的。如果没有对应于此 columnClass 的项，则此方法返回最相关超类的项。JTable 安装了对应于 Object、Number 和 Boolean 的项，它们都可以修改和替换。

参数：
columnClass - 返回此 columnClass 的默认单元格编辑器
返回：
此 columnClass 要使用的默认单元格编辑器
另请参见：
setDefaultEditor(java.lang.Class, javax.swing.table.TableCellEditor), getColumnClass(int)

setDragEnabled

public void setDragEnabled(boolean b)
打开或关闭自动拖动处理。要启用自动拖动处理，应该将此属性设置为 true，并且该表的 TransferHandler 需要为非 null。dragEnabled 属性的默认值为 false。

遵守此属性并识别用户拖动动作的作业取决于外观实现，尤其是表的 TableUI。当启用自动拖动处理时，只要用户在项（单个选择模式中）或选择（其他选择模式中）上按下鼠标按键，并将鼠标移动几个像素，多数外观（包括子类化 BasicLookAndFeel 的外观）就会开始拖放操作。因此，将此属性设置为 true 可以对选择行为产生微妙的影响。

如果使用一个忽略此属性的外观，仍然可以通过在表的 TransferHandler 上调用 exportAsDrag 开始拖放操作。

参数：
b - 是否启用自动拖动处理
抛出：
HeadlessException - 如果 b 为 true，并且 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDragEnabled

public boolean getDragEnabled()
返回是否启用自动拖动处理。

返回：
dragEnabled 属性的值
从以下版本开始：
1.4
另请参见：
setDragEnabled(boolean)

setDropMode

public final void setDropMode(DropMode dropMode)
设置此组件的放置模式。为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。 但是，为了用户使用更加方便，建议使用其他某个模式。例如，DropMode.ON 提供与选择类似的显示项的行为，但执行此操作不会影响表中的实际选择。

JTable 支持以下放置模式：

  • DropMode.USE_SELECTION
  • DropMode.ON
  • DropMode.INSERT
  • DropMode.INSERT_ROWS
  • DropMode.INSERT_COLS
  • DropMode.ON_OR_INSERT
  • DropMode.ON_OR_INSERT_ROWS
  • DropMode.ON_OR_INSERT_COLS

只有此组件具有接受放置操作的 TransferHandler 时，放置模式才有意义。

参数：
dropMode - 要使用的放置模式
抛出：
IllegalArgumentException - 如果放置模式不受支持或为 null
从以下版本开始：
1.6
另请参见：
getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDropMode

public final DropMode getDropMode()
返回此组件的放置模式。

返回：
此组件的放置模式
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode)

getDropLocation

public final JTable.DropLocation getDropLocation()
返回对组件的 DnD 操作期间此组件应该可见地指示为放置位置的位置；如果当前没有显示任何位置，则返回 null。

此方法不用于从 TransferHandler 查询放置操作，因为放置操作只在 TransferHandler 的 canImport 已经返回并允许显示该位置之后才会被设置。

当此属性更改时，组件将触发名为 "dropLocation" 的属性更改事件。

返回：
放置位置
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

setAutoCreateRowSorter

public void setAutoCreateRowSorter(boolean autoCreateRowSorter)
指定其模型更改时是否应该为表创建一个 RowSorter。

当调用 setAutoCreateRowSorter(true) 时，立即创建一个 TableRowSorter 并安装在表上。autoCreateRowSorter 属性保持为 true 时，每次模型更改都会创建一个新的 TableRowSorter 并将其设置为表的行排序器。

参数：
autoCreateRowSorter - 是否应该自动创建 RowSorter
从以下版本开始：
1.6
另请参见：
TableRowSorter

getAutoCreateRowSorter

public boolean getAutoCreateRowSorter()
如果每当模型更改时，都应该创建一个新 RowSorter 并作为该表的排序器安装，则返回 true；否则，返回 false。

返回：
如果模型更改时应该创建一个 RowSorter，则返回 true
从以下版本开始：
1.6

setUpdateSelectionOnSort

public void setUpdateSelectionOnSort(boolean update)
指定排序后是否应该更新选择。如果为 true，排序时选择将被重置，从而仍然选择相同的行（就模型而言）。默认值为 true。

参数：
update - 在排序时是否应该更新选择
从以下版本开始：
1.6

getUpdateSelectionOnSort

public boolean getUpdateSelectionOnSort()
如果排序后应该更新选择，则返回 true。

返回：
是否应该更新排序的选择
从以下版本开始：
1.6

setRowSorter

public void setRowSorter(RowSorter<? extends TableModel> sorter)
设置 RowSorter。RowSorter 用于提供对 JTable 的排序和过滤。

此方法清除该选择并重置所有可变行高度。

如果 RowSorter 的底层模型不同于此 JTable 的底层模型，则将导致不确定的行为。

参数：
sorter - RowSorter；null 表示关闭排序
从以下版本开始：
1.6
另请参见：
TableRowSorter

getRowSorter

public RowSorter<? extends TableModel> getRowSorter()
返回负责排序的对象。

返回：
负责排序的对象
从以下版本开始：
1.6

setSelectionMode

public void setSelectionMode(int selectionMode)
将表的选择模式设置为只允许单个选择、单个连续间隔选择或多间隔选择。

注：JTable 提供用于处理行选择和列选择的所有方法。设置状态时（例如 setSelectionMode），它不仅更新行选择模型的模式，而且还将设置 columnModel 选择模型中的类似值。如果希望在不同的模式中操作行选择模型和列选择模型，请直接设置这二者。

JTable 的行选择模型和列选择模型都默认使用 DefaultListSelectionModel，以便 JTable 与 JList 的工作方式一致。有关各种模式的详细信息，请参阅 JList 中的 setSelectionMode 方法。

另请参见：
JList.setSelectionMode(int)

setRowSelectionAllowed

public void setRowSelectionAllowed(boolean rowSelectionAllowed)
设置是否可以选择此模型中的行。

参数：
rowSelectionAllowed - 如果此模型允许行选择，则为 true
另请参见：
getRowSelectionAllowed()

getRowSelectionAllowed

public boolean getRowSelectionAllowed()
如果可以选择行，则返回 true。

返回：
如果可以选择行，则返回 true；否则返回 false
另请参见：
setRowSelectionAllowed(boolean)

setColumnSelectionAllowed

public void setColumnSelectionAllowed(boolean columnSelectionAllowed)
设置是否可以选择此模型中的列。

参数：
columnSelectionAllowed - 如果此模型允许列选择，则为 true
另请参见：
getColumnSelectionAllowed()

getColumnSelectionAllowed

public boolean getColumnSelectionAllowed()
如果可以选择列，则返回 true。

返回：
如果可以选择列，则返回 true；否则返回 false
另请参见：
setColumnSelectionAllowed(boolean)

setCellSelectionEnabled

public void setCellSelectionEnabled(boolean cellSelectionEnabled)
设置此表是否允许同时存在行选择和列选择。当允许时，表将行选择模型和列选择模型的相交部分作为选定的单元格。重写 isCellSelected 以更改此默认行为。此方法等效于将 columnModel 的 rowSelectionAllowed 属性和 columnSelectionAllowed 属性均设置为所提供的值。

参数：
cellSelectionEnabled - 如果允许同时存在行选择和列选择，则为 true
另请参见：
getCellSelectionEnabled(), isCellSelected(int, int)

getCellSelectionEnabled

public boolean getCellSelectionEnabled()
如果同时启用了行选择模型和列选择模型，则返回 true。等效于 getRowSelectionAllowed() && getColumnSelectionAllowed()。

返回：
如果同时启用了行选择模型和列选择模型，则返回 true
另请参见：
setCellSelectionEnabled(boolean)

selectAll

public void selectAll()
选择表中的所有行、列和单元格。

clearSelection

public void clearSelection()
取消选中所有已选定的行和列。

setRowSelectionInterval

public void setRowSelectionInterval(int index0,
                                    int index1)
选择从 index0 到 index1 之间（包含两端）的行。

参数：
index0 - 间隔的一端
index1 - 间隔的另一端
抛出：
IllegalArgumentException - 如果 index0 或 index1 位于 [0,getRowCount()-1] 范围外

setColumnSelectionInterval

public void setColumnSelectionInterval(int index0,
                                       int index1)
选择从 index0 到 index1 之间（包含两端）的列。

参数：
index0 - 间隔的一端
index1 - 间隔的另一端
抛出：
IllegalArgumentException - 如果 index0 或 index1 位于 [0, getColumnCount()-1] 范围外

addRowSelectionInterval

public void addRowSelectionInterval(int index0,
                                    int index1)
将从 index0 到 index1 之间（包含两端）的行添加到当前选择中。

参数：
index0 - 间隔的一端
index1 - 间隔的另一端
抛出：
IllegalArgumentException - 如果 index0 或 index1 位于 [0, getRowCount()-1] 范围外

addColumnSelectionInterval

public void addColumnSelectionInterval(int index0,
                                       int index1)
将从 index0 到 index1 之间（包含两端）的列添加到当前选择中。

参数：
index0 - 间隔的一端
index1 - 间隔的另一端
抛出：
IllegalArgumentException - 如果 index0 或 index1 位于 [0, getColumnCount()-1] 范围外

removeRowSelectionInterval

public void removeRowSelectionInterval(int index0,
                                       int index1)
取消选中从 index0 到 index1 之间（包含两端）的行。

参数：
index0 - 间隔的一端
index1 - 间隔的另一端
抛出：
IllegalArgumentException - 如果 index0 或 index1 位于 [0, getRowCount()-1] 范围外

removeColumnSelectionInterval

public void removeColumnSelectionInterval(int index0,
                                          int index1)
取消选中从 index0 到 index1 之间（包含两端）的列。

参数：
index0 - 间隔的一端
index1 - 间隔的另一端
抛出：
IllegalArgumentException - 如果 index0 或 index1 位于 [0, getColumnCount()-1] 范围外

getSelectedRow

public int getSelectedRow()
返回第一个选定行的索引；如果没有选定的行，则返回 -1。

返回：
第一个选定行的索引

getSelectedColumn

public int getSelectedColumn()
返回第一个选定列的索引；如果没有选定的列，则返回 -1。

返回：
第一个选定列的索引。

getSelectedRows

public int[] getSelectedRows()
返回所有选定行的索引。

返回：
包含所有选定行索引的整数数组；如果没有选定的行，则返回一个空数组
另请参见：
getSelectedRow()

getSelectedColumns

public int[] getSelectedColumns()
返回所有选定列的索引。

返回：
包含所有选定列索引的整数数组；如果没有选定的列，则返回一个空数组
另请参见：
getSelectedColumn()

getSelectedRowCount

public int getSelectedRowCount()
返回选定行数。

返回：
选定行数；如果没有选定的行，则返回 0

getSelectedColumnCount

public int getSelectedColumnCount()
返回选定列数。

返回：
选定列数；如果没有选定的列，则返回 0

isRowSelected

public boolean isRowSelected(int row)
如果指定的索引位于行的有效范围内，并且位于该索引的行被选定，则返回 true。

返回：
如果 row 是有效的索引，并且位于该索引的行被选定（其中 0 表示第一行），则返回 true

isColumnSelected

public boolean isColumnSelected(int column)
如果指定的索引位于列的有效范围内，并且位于该索引的列被选定，则返回 true。

参数：
column - 列模型中的列
返回：
如果 column 是有效的索引，并且位于该索引的列被选定（其中 0 表示第一列），则返回 true

isCellSelected

public boolean isCellSelected(int row,
                              int column)
如果指定的索引位于行和列的有效范围内，并且位于该指定位置的单元格被选定，则返回 true。

参数：
row - 被查询的行
column - 被查询的列
返回：
如果 row 和 column 是有效的索引，并且位于索引 (row, column) 的单元格被选定（其中第一行和第一列位于索引 0），则返回 true

changeSelection

public void changeSelection(int rowIndex,
                            int columnIndex,
                            boolean toggle,
                            boolean extend)
根据 toggle 和 extend 这两个标志的状态，更新表的选择模型。UI 所接收的键盘事件或鼠标事件所引起的大多数选择更改都是通过此方法来传递的，以便子类可以重写此行为。某些 UI 需要的功能可能多于此方法所提供的功能（例如在操作非连续选择的前端时），而且对某些选择更改可能不会调用到此方法中。

此实现使用以下约定：

  • toggle：false，extend：false。清除以前的选择并确保选定新的单元格。
  • toggle：false，extend：true。将以前的选择从定位点扩展到指定的单元格，清除所有其他选择。
  • toggle：true，extend：false。如果指定的单元格是选定的，则取消选定它。如果它不是选定的，则选定它。
  • toggle：true，extend：true。将定位点的选择状态应用于它与指定单元间的所有单元。

参数：
rowIndex - 影响 row 的选择
columnIndex - 影响 column 的选择
toggle - 参见上面的描述
extend - 如果为 true，则扩展当前的选择
从以下版本开始：
1.3

getSelectionForeground

public Color getSelectionForeground()
返回选定单元格的前景色。

返回：
前景属性的 Color 对象
另请参见：
setSelectionForeground(java.awt.Color), setSelectionBackground(java.awt.Color)

setSelectionForeground

public void setSelectionForeground(Color selectionForeground)
设置选定单元格的前景色。单元格渲染器可以使用此颜色来呈现选定单元格的文本和图形。

此属性的默认值由外观实现定义。

这是一个 JavaBeans 绑定 (bound) 属性。

参数：
selectionForeground - 用于选定列表项前景中的 Color
另请参见：
getSelectionForeground(),
setSelectionBackground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font)

getSelectionBackground

public Color getSelectionBackground()
返回选定单元格的背景色。

返回：
用于选定列表项背景中的 Color
另请参见：
setSelectionBackground(java.awt.Color), setSelectionForeground(java.awt.Color)

setSelectionBackground

public void setSelectionBackground(Color selectionBackground)
设置选定单元格的背景色。单元格渲染器可以使用此颜色填充选定单元格。

此属性的默认值由外观实现定义。

这是一个 JavaBeans 绑定属性。

参数：
selectionBackground - 用于选定单元格背景的 Color
另请参见：
getSelectionBackground(),
setSelectionForeground(java.awt.Color),
JComponent.setForeground(java.awt.Color),
JComponent.setBackground(java.awt.Color),
JComponent.setFont(java.awt.Font)

getColumn

public TableColumn getColumn(Object identifier)
返回表中列的 TableColumn 对象，当使用 equals 进行比较时，表的标识符等于 identifier。

参数：
identifier - 标识符对象
返回：
与标识符相匹配的 TableColumn 对象
抛出：
IllegalArgumentException - 如果 identifier 为 null 或者没有 TableColumn 具有此标识符

convertColumnIndexToModel

public int convertColumnIndexToModel(int viewColumnIndex)
将视图中位于 viewColumnIndex 的列索引映射到表模型中的列索引。返回模型中的对应列索引。如果 viewColumnIndex 小于 0，则返回 viewColumnIndex。

参数：
viewColumnIndex - 视图中的列索引
返回：
模型中的对应列索引
另请参见：
convertColumnIndexToView(int)

convertColumnIndexToView

public int convertColumnIndexToView(int modelColumnIndex)
将表模型中位于 modelColumnIndex 的列索引映射到视图中的列索引。返回视图中的对应列索引；如果此列不是被显示的列，则返回 -1。如果 modelColumnIndex 小于 0，则返回 modelColumnIndex。

参数：
modelColumnIndex - 模型中的列索引
返回：
视图中的对应列索引
另请参见：
convertColumnIndexToModel(int)

convertRowIndexToView

public int convertRowIndexToView(int modelRowIndex)
将基于 TableModel 的行索引映射到该视图。如果模型的内容没有进行排序，则模型和视图的索引相同。

参数：
modelRowIndex - 基于模型的行索引
返回：
视图中对应行的索引；如果该行不可见，则返回 -1
抛出：
IndexOutOfBoundsException - 如果启用排序并传递 TableModel 的行数范围之外的索引
从以下版本开始：
1.6
另请参见：
TableRowSorter

convertRowIndexToModel

public int convertRowIndexToModel(int viewRowIndex)
将基于视图的行索引映射到底层 TableModel。如果模型的内容没有进行排序，则模型和视图的索引相同。

参数：
viewRowIndex - 视图中行的索引
返回：
模型中对应行的索引
抛出：
IndexOutOfBoundsException - 如果启用排序并传递 JTable 范围（由 getRowCount 方法确定）之外的索引
从以下版本开始：
1.6
另请参见：
TableRowSorter, getRowCount()

getRowCount

public int getRowCount()
返回 JTable 中可以显示的行数（给定无限空间）。如果已指定一个带有过滤器的 RowSorter，则返回的行数可能与底层 TableModel 的行数不同。

返回：
JTable 中显示的行数
另请参见：
getColumnCount()

getColumnCount

public int getColumnCount()
返回列模型中的列数。注意，这可能与表模型中的列数不同。

返回：
表中的列数
另请参见：
getRowCount(), removeColumn(javax.swing.table.TableColumn)

getColumnName

public String getColumnName(int column)
返回出现在视图中 column 列位置处的列名称。

参数：
column - 在视图中查询的列
返回：
视图中 column 位置的列名称，其中第一列为列 0

getColumnClass

public Class<?> getColumnClass(int column)
返回出现在视图中 column 列位置处的列类型。

参数：
column - 在视图中查询的列
返回：
视图中 column 位置的列类型，其中第一列为列 0

getValueAt

public Object getValueAt(int row,
                         int column)
返回 row 和 column 位置的单元格值。

注：列是以表视图的显示顺序，而不是以 TableModel 的列顺序指定的。这是一项重要的区别，因为在用户重新安排表中的列时，视图中给定索引处的列将更改。同时用户的操作不会影响模型的列顺序。

参数：
row - 其值要被查询的行
column - 其值要被查询的列
返回：
指定单元格处的 Object

setValueAt

public void setValueAt(Object aValue,
                       int row,
                       int column)
设置表模型中 row 和 column 位置的单元格值。

注：列是以表视图的显示顺序，而不是以 TableModel 的列顺序指定的。这是一项重要的区别，因为在用户重新安排表中的列时，视图中给定索引处的列将更改。同时用户的操作不会影响模型的列顺序。 aValue 是一个新值。

参数：
aValue - 新值
row - 要更改的单元格所在的行
column - 要更改的单元格所在的列
另请参见：
getValueAt(int, int)

isCellEditable

public boolean isCellEditable(int row,
                              int column)
如果 row 和 column 位置的单元格是可编辑的，则返回 true。否则，在单元格上调用 setValueAt 没有任何效果。

注：列是以表视图的显示顺序，而不是以 TableModel 的列顺序指定的。这是一项重要的区别，因为在用户重新安排表中的列时，视图中给定索引处的列将更改。同时用户的操作不会影响模型的列顺序。

参数：
row - 其值要被查询的行
column - 其值要被查询的列
返回：
如果单元格是可编辑的，则返回 true
另请参见：
setValueAt(java.lang.Object, int, int)

addColumn

public void addColumn(TableColumn aColumn)
将 aColumn 追加到此 JTable 的列模型所保持的列数组的尾部。如果 aColumn 的列名称为 null，则将 aColumn 的列名称设置为 getModel().getColumnName() 所返回的名称。

要向此 JTable 添加一列，以用给定的 width、cellRenderer 和 cellEditor 来显示模型中第 modelColumn 列的数据，可以使用以下方法：

      addColumn(new TableColumn(modelColumn, width, cellRenderer, cellEditor));
[TableColumn 构造方法中的任何一个方法都可以用来替代此方法。]模型的列号存储在 TableColumn 中，在呈现和编辑过程中使用该列号来定位模型中合适的数据值。当列在视图中重新排序时，不更改模型的列号。

参数：
aColumn - 要添加的 TableColumn
另请参见：
removeColumn(javax.swing.table.TableColumn)

removeColumn

public void removeColumn(TableColumn aColumn)
从此 JTable 的列数组中移除 aColumn。注：此方法不从模型中移除数据列；它只移除负责显示它的 TableColumn。

参数：
aColumn - 要移除的 TableColumn
另请参见：
addColumn(javax.swing.table.TableColumn)

moveColumn

public void moveColumn(int column,
                       int targetColumn)
将视图中的 column 列移动到当前被 targetColumn 列所占用的位置。targetColumn 位置上的原有列向左或右移动以腾出空间。

参数：
column - 要移动的列的索引
targetColumn - 列的新索引

columnAtPoint

public int columnAtPoint(Point point)
返回 point 所在的列索引；如果结果不在 [0, getColumnCount()-1] 范围内，则返回 -1。

参数：
point - 要查询的位置
返回：
point 所在的列索引；如果结果不在 [0, getColumnCount()-1] 范围内，则返回 -1
另请参见：
rowAtPoint(java.awt.Point)

rowAtPoint

public int rowAtPoint(Point point)
返回 point 所在的行索引；如果结果不在 [0, getRowCount()-1] 范围内，则返回 -1。

参数：
point - 要查询的位置
返回：
point 所在的行索引；如果结果不在 [0, getRowCount()-1] 范围内，则返回 -1
另请参见：
columnAtPoint(java.awt.Point)

getCellRect

public Rectangle getCellRect(int row,
                             int column,
                             boolean includeSpacing)
返回位于 row 和 column 相交位置的单元格矩形。如果 includeSpacing 为 true，则返回的值具有指定行和列的完整高度和宽度。如果为 false，则返回的矩形为单元格空间减去单元格间的间隙，以便在呈现期间设置该属性后，返回呈现和编辑的组件的真实边界。

如果列索引有效但是行索引小于 0，则此方法返回一个矩形，此矩形的 y 和 height 设置为合适的值，其 x 和 width 值都设置为 0。通常，行索引或列索引指示适当区域外的单元格时，此方法都返回一个矩形，它描绘了表范围内最近单元格的最近边。当行索引和列索引都超出范围时，返回的矩形覆盖了最近单元格的最近点。

在所有的情形中，使用此方法沿一个轴的计算结果不会因为沿另一个轴的计算出现异常而失败。当单元格无效时，忽略 includeSpacing 参数。

参数：
row - 所需单元格所在的行索引
column - 所需单元格所在的列索引；不一定与表中数据模型的列索引相同；convertColumnIndexToView(int) 方法可以用来将数据模型的列索引转换为显示的列索引
includeSpacing - 如果为 false，则返回实际的单元格边界，计算方法是从列模型和行模型的高度和宽度中减去单元格间距
返回：
包含 row、column 处单元格的矩形
另请参见：
getIntercellSpacing()

doLayout

public void doLayout()
使此表布局其行和列。重写的此方法可调整列的大小，以适应包含的父级的大小更改。调整表中一列或多列的大小，以便所有此 JTable 列的总宽度等于表的宽度。

开始布局之前，此方法获取 tableHeader 的 resizingColumn。当由于要调整封闭窗口的大小而调用此方法时，resizingColumn 为 null。这意味着调整大小发生在 JTable 的“外部”，并且更改（或 "delta" ）应该分布到所有列，无论此 JTable 的自动调整大小模式如何。

如果 resizingColumn 不为 null，则它是发生大小更改的表中的一列，而不是表本身。在这种情况下，自动调整大小模式控制额外（或不足）空间在可用列之间的分布方式。

该模式有：

  • AUTO_RESIZE_OFF：不自动调整列的宽度。当列的总宽度超过 Viewport 的宽度时，使用水平滚动条来适应列的宽度。如果 JTable 没有封闭在 JScrollPane 中，则可能导致该表的一部分不可见。
  • AUTO_RESIZE_NEXT_COLUMN：使用被调整列的下一列。这导致相邻单元格之间的“边界”或分隔栏是可独立调整的。
  • AUTO_RESIZE_SUBSEQUENT_COLUMNS：使用被调整列后面的所有列来吸收所作的更改。这是默认行为。
  • AUTO_RESIZE_LAST_COLUMN：只自动调整最后一列的大小。如果最后一列的边界导致无法分配所需的大小，则将最后一列的宽度设置为适当的界限并且不再做进一步的调整。
  • AUTO_RESIZE_ALL_COLUMNS：将 delta 分散在 JTable 中的所有列之间，包括正在被调整的列。

注：当 JTable 调整列宽时，它绝对遵守其最小值和最大值。但是即使在调用此方法后，列的总宽度仍然可能不等于表的宽度。发生这种情况时，JTable 不会进入 AUTO_RESIZE_OFF 模式来生成一个滚动条，或者中断其当前自动调整模式的其他提交，相反，它允许其边界设置为大于（或小于）最大总宽度（或最小总宽度），这意味着要么没有足够的空间来显示所有的列，要么就是列不能填满 JTable 的边界。这将分别导致在绘制期间，某些列将被剪切掉，或者某个区域将被绘制为 JTable 的背景色。

用于在可用列之间分布 delta 的机制是由 JTable 类中的一个私有方法提供的：

   adjustSizes(long targetSize, final Resizable3 r, boolean inverse)
以下部分是对它的解释。Resizable3 是一个私有接口，它允许包含元素（具有大小、首选大小、最大大小和最小大小）集合的任何数据结构可以通过该算法来操作其元素。

分布 delta

概述

将 r 中各元素的目标大小与首选大小总和之间的差值称为 "DELTA"。单独的大小通过将原始首选大小加上 DELTA 的共享部分来计算，该共享部分基于每个首选大小到其限定边界的距离（最小值或最大值）。

定义

单独的约束称为 min[i]、max[i] 和 pref[i]。

它们相应的和称为：MIN、MAX 和 PREF。

用以下公式计算每个新大小：

          size[i] = pref[i] + delta[i]
其中每个单独的 delta[i] 根据以下条件计算：

如果 (DELTA < 0)，则处于收缩模式，其中：

                        DELTA
          delta[i] = ------------ * (pref[i] - min[i])
                     (PREF - MIN)
如果 (DELTA > 0)，则处于扩展模式，其中：

                        DELTA
          delta[i] = ------------ * (max[i] - pref[i])
                      (MAX - PREF)

总体效果是总大小向总的最小值或最大值移动相同的百分比 k，此百分比确保适应所需的间距，即 DELTA。

详细信息

估计此处给出的公式计算易受累积舍入误差的影响，该误差是由此操作的有限精度（使用 int）引起的。为了处理此问题，要经常重新计算上述乘数，这可将以前迭代中的舍入误差考虑在内。结果是一个生成一组整数的算法，这组整数值的和恰好等于提供的 targetSize，这是通过将舍入误差均匀分散到给定元素上来实现的。

何时选中 MAX 和 MIN 边界

当 targetSize 处于 [MIN, MAX] 范围外时，算法将所有大小设置为其适合的限定值（最大值或最小值）。

覆盖：
类 Container 中的 doLayout
另请参见：
LayoutManager.layoutContainer(java.awt.Container),
Container.setLayout(java.awt.LayoutManager),
Container.validate()

sizeColumnsToFit

@Deprecated
public void sizeColumnsToFit(boolean lastColumnOnly)
已过时。 从 Swing version 1.0.3 开始，由 doLayout() 取代。

调整表列的大小以适合可用的空间。

另请参见：
doLayout()

sizeColumnsToFit

public void sizeColumnsToFit(int resizingColumn)
从 Java 2 平台 v1.4 开始已过时。请使用 doLayout() 方法。

参数：
resizingColumn - 由于大小的改变导致需要进行此调整的列；如果没有这样的列，则为 -1
另请参见：
doLayout()

getToolTipText

public String getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，从而允许使用渲染器的提示（如果设置了文本）。

注：要让 JTable 正确显示其渲染器的工具提示，JTable 必须是 ToolTipManager 中的注册组件。此操作可在 initializeLocalVars 中自动完成，但是如果之后在 JTable 上调用了 setToolTipText(null)，则这是一个注销的表组件，渲染器的提示将不再显示。

覆盖：
类 JComponent 中的 getToolTipText
另请参见：
JComponent.getToolTipText()

setSurrendersFocusOnKeystroke

public void setSurrendersFocusOnKeystroke(boolean surrendersFocusOnKeystroke)
设置由于 JTable 为某个单元格转发键盘事件而导致编辑器被激活时，此 JTable 中的编辑器是否获得键盘焦点。默认情况下，此属性为 false，且 JTable 保留焦点，除非单击了单元格。

参数：
surrendersFocusOnKeystroke - 如果在键击导致编辑器被激活时编辑器应该获得焦点，则为 true
从以下版本开始：
1.4
另请参见：
getSurrendersFocusOnKeystroke()

getSurrendersFocusOnKeystroke

public boolean getSurrendersFocusOnKeystroke()
如果在键击导致编辑器被激活时编辑器应该获得焦点，则返回 true

返回：
如果在键击导致编辑器被激活时编辑器应该获得焦点，则返回 true
从以下版本开始：
1.4
另请参见：
setSurrendersFocusOnKeystroke(boolean)

editCellAt

public boolean editCellAt(int row,
                          int column)
如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。注意，这是 editCellAt(int, int, null) 的一种便捷方法。

参数：
row - 要编辑的行
column - 要编辑的列
返回：
如果由于任何原因而无法编辑该单元格，或者索引无效，则返回 false

editCellAt

public boolean editCellAt(int row,
                          int column,
                          EventObject e)
如果 row 和 column 位置的索引在有效范围内，并且这些索引处的单元格是可编辑的，则以编程方式启动该位置单元格的编辑。要防止 JTable 编辑特定的表、列或单元格的值，TableModel 接口中的 isCellEditable 方法应返回 false。

参数：
row - 要编辑的行
column - 要编辑的列
e - 要传递到 shouldSelectCell 中的事件；注意，从 Java 2 平台 v1.2 开始，不再调用 shouldSelectCell
返回：
如果由于任何原因而无法编辑该单元格，或者索引无效，则返回 false

isEditing

public boolean isEditing()
如果正在编辑单元格，则返回 true。

返回：
如果表正在编辑一个单元格，则返回 true
另请参见：
editingColumn, editingRow

getEditorComponent

public Component getEditorComponent()
返回处理编辑会话的组件。如果没有编辑任何内容，则返回 null。

返回：
处理编辑会话的 Component

getEditingColumn

public int getEditingColumn()
返回包含当前被编辑的单元格的列索引。如果没有编辑任何内容，则返回 -1。

返回：
包含当前被编辑的单元格的列索引；如果没有编辑任何内容，则返回 -1
另请参见：
editingRow

getEditingRow

public int getEditingRow()
返回包含当前被编辑的单元格的行索引。如果没有编辑任何内容，则返回 -1。

返回：
包含当前被编辑的单元格的行索引；如果没有编辑任何内容，则返回 -1
另请参见：
editingColumn

getUI

public TableUI getUI()
返回呈现此组件的 L&F 对象。

返回：
呈现此组件的 TableUI 对象

setUI

public void setUI(TableUI ui)
设置呈现此组件并进行重新绘制的 L&F 对象。

参数：
ui - TableUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
UIManager 发出的表明 L&F 已经更改的通知。用 UIManager 的最新版本替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回用于构造呈现此组件时所用 L&F 类名称的后缀。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "TableUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setModel

public void setModel(TableModel dataModel)
将此表的数据模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。

参数：
dataModel - 此表的新数据源
抛出：
IllegalArgumentException - 如果 newModel 为 null
另请参见：
getModel()

getModel

public TableModel getModel()
返回提供此 JTable 所显示数据的 TableModel。

返回：
提供此 JTable 所显示数据的 TableModel
另请参见：
setModel(javax.swing.table.TableModel)

setColumnModel

public void setColumnModel(TableColumnModel columnModel)
将此表的列模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。还要将 JTableHeader 的列模型设置为 columnModel。

参数：
columnModel - 此表的新数据源
抛出：
IllegalArgumentException - 如果 columnModel 为 null
另请参见：
getColumnModel()

getColumnModel

public TableColumnModel getColumnModel()
返回包含此表所有列信息的 TableColumnModel。

返回：
提供该表列状态的对象
另请参见：
setColumnModel(javax.swing.table.TableColumnModel)

setSelectionModel

public void setSelectionModel(ListSelectionModel newModel)
将此表的行选择模型设置为 newModel，并向其注册以获取来自新数据模型的侦听器通知。

参数：
newModel - 新的选择模型
抛出：
IllegalArgumentException - 如果 newModel 为 null
另请参见：
getSelectionModel()

getSelectionModel

public ListSelectionModel getSelectionModel()
返回用来维持行选择状态的 ListSelectionModel。

返回：
提供行选择状态的对象；如果不允许行选择，则返回 null
另请参见：
setSelectionModel(javax.swing.ListSelectionModel)

sorterChanged

public void sorterChanged(RowSorterEvent e)
RowSorter 以某种方式发生了更改的 RowSorterListener 通知。

指定者：
接口 RowSorterListener 中的 sorterChanged
参数：
e - 描述更改的 RowSorterEvent
抛出：
NullPointerException - 如果 e 为 null
从以下版本开始：
1.6

tableChanged

public void tableChanged(TableModelEvent e)
当此表的 TableModel 生成 TableModelEvent 时调用。应在该模型的坐标系统中构造 TableModelEvent；当此 JTable 接收事件时，它执行到视图坐标系统的适当映射。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

注意，从 1.3 版本开始，此方法清除选择（如果有）。

指定者：
接口 TableModelListener 中的 tableChanged

columnAdded

public void columnAdded(TableColumnModelEvent e)
将列添加到表的列模型时调用。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnAdded
另请参见：
TableColumnModelListener

columnRemoved

public void columnRemoved(TableColumnModelEvent e)
从表的列模型中移除列时调用。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnRemoved
另请参见：
TableColumnModelListener

columnMoved

public void columnMoved(TableColumnModelEvent e)
重新定位列时调用。如果正在编辑某个单元格，则停止编辑并重新绘制该单元格。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnMoved
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

columnMarginChanged

public void columnMarginChanged(ChangeEvent e)
当列由于间距的更改而被移动时调用。如果正在编辑某个单元格，则停止编辑并重新绘制该单元格。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnMarginChanged
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

columnSelectionChanged

public void columnSelectionChanged(ListSelectionEvent e)
TableColumnModel 的选择模型更改时调用。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 TableColumnModelListener 中的 columnSelectionChanged
参数：
e - 接收到的事件
另请参见：
TableColumnModelListener

valueChanged

public void valueChanged(ListSelectionEvent e)
行选择更改时调用，重新绘制来显示新的选择。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 ListSelectionListener 中的 valueChanged
参数：
e - 接收到的事件
另请参见：
ListSelectionListener

editingStopped

public void editingStopped(ChangeEvent e)
编辑结束时调用。保存更改并丢弃编辑器。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 CellEditorListener 中的 editingStopped
参数：
e - 接收到的事件
另请参见：
CellEditorListener

editingCanceled

public void editingCanceled(ChangeEvent e)
编辑取消时调用。丢弃编辑器对象，并再次呈现单元格。

应用程序代码不显式地使用这些方法，它们由 JTable 在内部使用。

指定者：
接口 CellEditorListener 中的 editingCanceled
参数：
e - 接收到的事件
另请参见：
CellEditorListener

setPreferredScrollableViewportSize

public void setPreferredScrollableViewportSize(Dimension size)
设置此表视口的首选大小。

参数：
size - 指定 JViewport（其视图为此表）的 preferredSize 的 Dimension 对象
另请参见：
Scrollable.getPreferredScrollableViewportSize()

getPreferredScrollableViewportSize

public Dimension getPreferredScrollableViewportSize()
返回此表视口的首选大小。

指定者：
接口 Scrollable 中的 getPreferredScrollableViewportSize
返回：
包含 JViewport（它显示此表）的 preferredSize 的 Dimension 对象
另请参见：
Scrollable.getPreferredScrollableViewportSize()

getScrollableUnitIncrement

public int getScrollableUnitIncrement(Rectangle visibleRect,
                                      int orientation,
                                      int direction)
返回完全呈现出一个新行或新列（取决于方向）的滚动增量（以像素为单位）。

用户每次请求一个单位的滚动时，就调用此方法。

指定者：
接口 Scrollable 中的 getScrollableUnitIncrement
参数：
visibleRect - 视口中可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
direction - 小于 0 向上/左滚动，大于 0 向下/右滚动
返回：
在指定方向滚动的“单位”增量
另请参见：
Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

getScrollableBlockIncrement

public int getScrollableBlockIncrement(Rectangle visibleRect,
                                       int orientation,
                                       int direction)
返回 visibleRect.height 或 visibleRect.width，这取决于此表的方向。注意，从 Swing 1.1.1 (Java 2 v 1.2.2) 开始，返回的值将确保视口在行边界上完全对齐。

指定者：
接口 Scrollable 中的 getScrollableBlockIncrement
参数：
visibleRect - 视口内可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
direction - 小于 0 为向上/左滚动，大于 0 为向下/右滚动。
返回：
每个方向上的 visibleRect.height 或 visibleRect.width
另请参见：
Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

getScrollableTracksViewportWidth

public boolean getScrollableTracksViewportWidth()
如果 autoResizeMode 设置为 AUTO_RESIZE_OFF，则返回 false，这指示表的宽度不是由视口的宽度决定的。否则返回 true。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportWidth
返回：
如果 autoResizeMode 设置为 AUTO_RESIZE_OFF，则返回 false；否则返回 true
另请参见：
Scrollable.getScrollableTracksViewportWidth()

getScrollableTracksViewportHeight

public boolean getScrollableTracksViewportHeight()
返回 false 指示表的高度不是由视口的高度决定的，除非 getFillsViewportHeight 为 true 并且该表的首选高度小于视口的高度。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportHeight
返回：
false，除非 getFillsViewportHeight 为 true 并且需要延伸该表以填充视口
另请参见：
Scrollable.getScrollableTracksViewportHeight(), setFillsViewportHeight(boolean), getFillsViewportHeight()

setFillsViewportHeight

public void setFillsViewportHeight(boolean fillsViewportHeight)
设置此表是否始终大到足以填充封闭视口的高度。如果该表的首选高度小于视口，则将会延伸该表以填充视口。换句话说，此方法确保该表永远不会小于该视口。此属性的默认值为 false。

参数：
fillsViewportHeight - 此表是否始终大到足以填充封闭视口的高度
从以下版本开始：
1.6
另请参见：
getFillsViewportHeight(), getScrollableTracksViewportHeight()

getFillsViewportHeight

public boolean getFillsViewportHeight()
返回此表是否始终大到足以填充封闭视口的高度。

返回：
此表是否始终大到足以填充封闭视口的高度
从以下版本开始：
1.6
另请参见：
setFillsViewportHeight(boolean)

processKeyBinding

protected boolean processKeyBinding(KeyStroke ks,
                                    KeyEvent e,
                                    int condition,
                                    boolean pressed)
从类 JComponent 复制的描述
由于发生 KeyEvent e 而调用此方法处理 ks 的键绑定。此方法将获取适当的 InputMap、获取绑定、从 ActionMap 获取动作，然后（如果找到该动作并且已启用该组件）调用 notifyAction 来通知该动作。

覆盖：
类 JComponent 中的 processKeyBinding
参数：
ks - 被查询的 KeyStroke
e - KeyEvent
condition - 为下列值之一：
  • JComponent.WHEN_FOCUSED
  • JComponent.WHEN_ANCESTOR_OF_FOCUSED_COMPONENT
  • JComponent.WHEN_IN_FOCUSED_WINDOW
pressed - 如果键被按下，则为 true
返回：
如果有该动作的绑定并且已启用该动作，则返回 true

createDefaultRenderers

protected void createDefaultRenderers()
为 object、number、double、date、boolean 和 icon 创建默认的单元格渲染器。

另请参见：
DefaultTableCellRenderer

createDefaultEditors

protected void createDefaultEditors()
为 object、number 和 boolean 值创建默认的单元格编辑器。

另请参见：
DefaultCellEditor

initializeLocalVars

protected void initializeLocalVars()
将表的属性初始化为其默认值。

createDefaultDataModel

protected TableModel createDefaultDataModel()
返回默认的表模型对象，它是一个 DefaultTableModel。子类可以重写此方法以返回不同的表模型对象。

返回：
默认的表模型对象
另请参见：
DefaultTableModel

createDefaultColumnModel

protected TableColumnModel createDefaultColumnModel()
返回默认的列模型对象，它是一个 DefaultTableColumnModel。子类可以重写此方法以返回不同的列模型对象。

返回：
默认的列模型对象
另请参见：
DefaultTableColumnModel

createDefaultSelectionModel

protected ListSelectionModel createDefaultSelectionModel()
返回默认的选择模型对象，它是一个 DefaultListSelectionModel。子类可以重写此方法以返回不同的选择模型对象。

返回：
默认的选择模型对象
另请参见：
DefaultListSelectionModel

createDefaultTableHeader

protected JTableHeader createDefaultTableHeader()
返回默认的表标题对象，它是一个 JTableHeader。子类可以重写此方法以返回不同的表标题对象。

返回：
默认的表标题对象
另请参见：
JTableHeader

resizeAndRepaint

protected void resizeAndRepaint()
等效于先调用 revalidate 再调用 repaint。

getCellEditor

public TableCellEditor getCellEditor()
返回活动单元格编辑器；如果该表当前没有被编辑，则返回 null。

返回：
执行编辑操作的 TableCellEditor；如果该表当前没有被编辑，则返回 null。
另请参见：
cellEditor, getCellEditor(int, int)

setCellEditor

public void setCellEditor(TableCellEditor anEditor)
设置活动单元格编辑器。

参数：
anEditor - 活动单元格编辑器
另请参见：
cellEditor

setEditingColumn

public void setEditingColumn(int aColumn)
设置 editingColumn 变量。

参数：
aColumn - 要编辑的单元格所在的列
另请参见：
editingColumn

setEditingRow

public void setEditingRow(int aRow)
设置 editingRow 变量。

参数：
aRow - 要编辑的单元格所在的行
另请参见：
editingRow

getCellRenderer

public TableCellRenderer getCellRenderer(int row,
                                         int column)
返回适于由此行和列所指定单元格的渲染器。如果此列的 TableColumn 有一个非 null 的渲染器，则返回它。如果没有，则查找此列中的数据类（使用 getColumnClass），并返回此数据类型的默认渲染器。

注：在整个表的包中，内部实现始终使用此方法来提供渲染器，以便子类能够安全地重写此默认行为。

参数：
row - 要呈现的单元格所在的行，其中第一行为 0
column - 要呈现的单元格所在的列，其中第一列为 0
返回：
已分配的渲染器；如果为 null，则返回此类型对象的默认渲染器
另请参见：
DefaultTableCellRenderer, TableColumn.setCellRenderer(javax.swing.table.TableCellRenderer), setDefaultRenderer(java.lang.Class, javax.swing.table.TableCellRenderer)

prepareRenderer

public Component prepareRenderer(TableCellRenderer renderer,
                                 int row,
                                 int column)
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备渲染器。返回事件所在的组件（可能是 Component 或 JComponent）。

打印操作期间，此方法将配置不指示选择和焦点的渲染器，以防止它们出现在打印输出中。要执行基于该表是否打印的其他定制，可以检查 JComponent.isPaintingForPrint() 的值（在此处或者在自定义渲染器中）。

注：在整个表的包中，内部实现始终使用此方法来准备渲染器，以便子类能够安全地重写此默认行为。

参数：
renderer - 要准备的 TableCellRenderer
row - 要呈现的单元格所在的行，其中第一行为 0
column - 要呈现的单元格所在的列，其中第一列为 0
返回：
事件所在的 Component

getCellEditor

public TableCellEditor getCellEditor(int row,
                                     int column)
返回适用于由 row 和 column 所指定单元格的编辑器。如果此列的 TableColumn 有一个非 null 的编辑器，则返回它。如果没有，则查找此列中的数据类（使用 getColumnClass），并返回此类型数据的默认编辑器。

注：在整个表的包中，内部实现始终使用此方法来提供编辑器，以便子类能够安全地重写此默认行为。

参数：
row - 要编辑的单元格所在的行，其中第一行为 0
column - 要编辑的单元格所在的列，其中第一列为 0
返回：
此单元格的编辑器；如果为 null，则返回此类型单元格的默认编辑器
另请参见：
DefaultCellEditor

prepareEditor

public Component prepareEditor(TableCellEditor editor,
                               int row,
                               int column)
通过查询 row、column 处单元格值的数据模型和单元格选择状态来准备编辑器。

注：在整个表的包中，内部实现始终使用此方法来准备编辑器，以便子类能够安全地重写此默认行为。

参数：
editor - 要设置的 TableCellEditor
row - 要编辑的单元格所在的行，其中第一行为 0
column - 要编辑的单元格所在的列，其中第一列为 0
返回：
被编辑的 Component

removeEditor

public void removeEditor()
丢弃编辑器对象并释放它用于单元格呈现的资源。

paramString

protected String paramString()
返回此表的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此表的字符串表示形式

print

public boolean print()
              throws PrinterException
一个便捷的方法，它显示一个打印对话框，然后以 PrintMode.FIT_WIDTH 模式打印此 JTable，不打印标题或脚注文本。打印期间将显示一个有模式的进度对话框（带有中止选项）。

注：在 headless 模式中，不显示对话框并且打印在默认打印机上进行。

返回：
除非用户取消了打印，否则返回 true
抛出：
SecurityException - 如果不允许此线程启动打印作业请求
PrinterException - 如果打印系统的错误导致打印作业中止
从以下版本开始：
1.5
另请参见：
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

print

public boolean print(JTable.PrintMode printMode)
              throws PrinterException
一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，不打印标题或脚注文本。打印期间将显示一个有模式的进度对话框（带有中止选项）。

注：在 headless 模式中，不显示对话框并且打印在默认打印机上进行。

参数：
printMode - printable 应使用的打印模式
返回：
除非用户取消了打印，否则返回 true
抛出：
SecurityException - 如果不允许此线程启动打印作业请求
PrinterException - 如果打印系统的错误导致打印作业中止
从以下版本开始：
1.5
另请参见：
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

print

public boolean print(JTable.PrintMode printMode,
                     MessageFormat headerFormat,
                     MessageFormat footerFormat)
              throws PrinterException
一个便捷的方法，它显示一个打印对话框，然后以给定的打印模式打印此 JTable，打印指定的标题和脚注文本。打印期间将显示一个有模式的进度对话框（带有中止选项）。

注：在 headless 模式中，不显示对话框并且打印在默认打印机上进行。

参数：
printMode - printable 应使用的打印模式
headerFormat - 指定在打印标题中所用文本的 MessageFormat，如果没有则为 null
footerFormat - 指定在打印脚注中所用文本的 MessageFormat，如果没有则为 null
返回：
除非用户取消了打印，否则返回 true
抛出：
SecurityException - 如果不允许此线程启动打印作业请求
PrinterException - 如果打印系统的错误导致打印作业中止
从以下版本开始：
1.5
另请参见：
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

print

public boolean print(JTable.PrintMode printMode,
                     MessageFormat headerFormat,
                     MessageFormat footerFormat,
                     boolean showPrintDialog,
                     PrintRequestAttributeSet attr,
                     boolean interactive)
              throws PrinterException,
                     HeadlessException
根据完全功能 print 方法的指定打印此表，将默认打印机指定为打印服务。

参数：
printMode - printable 应该使用的打印模式
headerFormat - 指定在打印标题中所用文本的 MessageFormat，如果没有则为 null
footerFormat - 指定在打印脚注中所用文本的 MessageFormat，如果没有则为 null
showPrintDialog - 是否显示打印对话框
attr - 指定所有打印属性的 PrintRequestAttributeSet，如果没有则为 null
interactive - 是否以交互模式打印
返回：
true，除非用户取消了打印
抛出：
HeadlessException - 如果要求方法显示打印对话框或交互运行，并且 GraphicsEnvironment.isHeadless 返回 true
SecurityException - 如果不允许此线程启动打印作业请求
PrinterException - 如果打印系统的错误导致打印作业中止
从以下版本开始：
1.5
另请参见：
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean, PrintService), getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

print

public boolean print(JTable.PrintMode printMode,
                     MessageFormat headerFormat,
                     MessageFormat footerFormat,
                     boolean showPrintDialog,
                     PrintRequestAttributeSet attr,
                     boolean interactive,
                     PrintService service)
              throws PrinterException,
                     HeadlessException
打印此 JTable。按照大多数开发人员所采取的步骤来打印 JTable。简单地说，它准备表，调用 getPrintable 来获取合适的 Printable，然后将其发送到打印机。

boolean 参数允许指定是否向用户显示打印对话框。显示打印对话框时，用户可以使用该对话框更改目标打印机或打印属性，甚至可以取消打印。另外两个参数允许指定 PrintService 和打印属性。这些参数可以用来提供打印对话框的初始值，或者在未显示对话框时指定值。

第二个 boolean 参数允许指定是否以交互模式执行打印。如果为 true，则在打印期间将显示一个有模式的进度对话框（带有中止选项）。此对话框还可防止任何可能影响表的用户动作。但是，它不能防止代码对表的修改（例如，另一个线程使用 SwingUtilities.invokeLater 发送更新）。因此，开发人员要负责确保在打印期间没有任何其他代码会以任何方式修改表（无效的修改包括在大小、渲染器或底层数据方面的修改）。如果在打印期间更改了表，则会产生不确定的打印行为。

如果将此参数指定为 false，则不显示对话框，打印将立即在事件指派进程上开始。在打印完成前，这将阻塞任何其他事件的处理（包括重新绘制）。尽管这有效地防止了对表的更改，但用户使用起来不是很方便。出于这个原因，建议只在从一个没有可视 GUI 的应用程序打印时才指定 false。

注：在 headless 模式下，试图显示打印对话框或交互运行将导致 HeadlessException。

获取 printable 前，此方法将会正常地终止编辑（如有必要），以防止编辑器在打印结果中显示。此外，JTable 在未指示选择和焦点的打印期间将准备好其渲染器。至于定制打印输出中表的外观的更多信息，开发人员可以提供自定义渲染器或者条件化 JComponent.isPaintingForPrint() 值的绘制模式。

有关如何打印表的更多描述，请参见 getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)。

参数：
printMode - printable 应使用的打印模式
headerFormat - 指定在打印标题中所用文本的 MessageFormat，如果没有则为 null
footerFormat - 指定在打印脚注中所用文本的 MessageFormat，如果没有则为 null
showPrintDialog - 是否显示打印对话框
attr - 指定任何打印属性的 PrintRequestAttributeSet，如果没有则为 null
interactive - 是否以交互模式打印
service - 目标 PrintService，或者为 null，表示使用默认打印机
返回：
除非用户取消了打印，否则返回 true
抛出：
HeadlessException - 如果要求方法显示打印对话框或交互运行，并且 GraphicsEnvironment.isHeadless 返回 true
SecurityException - 如果安全管理器存在并且其 SecurityManager.checkPrintJobAccess() 方法不允许此线程创建打印作业请求
PrinterException - 如果打印系统的错误导致打印作业中止
从以下版本开始：
1.6
另请参见：
getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat), GraphicsEnvironment.isHeadless()

getPrintable

public Printable getPrintable(JTable.PrintMode printMode,
                              MessageFormat headerFormat,
                              MessageFormat footerFormat)
返回打印此 JTable 中所使用的 Printable。

此方法用于希望定制 JTable 的 print 方法所使用的默认 Printable 实现的开发人员。只想打印该表的开发人员应该直接使用其中一个打印方法。

可以在两种打印模式的任意一个内请求 Printable。在这两种模式中，它按顺序自然地将表的各行分散到多个页中，每页放入尽可能多的行。PrintMode.NORMAL 指定表以当前大小打印。在此模式中，可能需要以类似于行的方式将列分散到多页中。需要这样分散时，列以与表的 ComponentOrientation 一致的顺序进行分布。PrintMode.FIT_WIDTH 指定按比例缩小输出（如有必要），以在每页上放入表的整个宽度（凭此放入所有列）。宽度和高度等比例进行缩放，以保持输出的高宽比。

Printable 将该表 JTableHeader（如果有）的合适部分作为每页上表部分的标题。

可以通过提供 MessageFormat 参数将标题和脚注文本添加到输出中。打印代码根据格式请求 String，提供可以包括在已格式化字符串中的单个项：表示当前页码的 Integer。

当某些字符（例如单引号）是特殊字符并需要转义处理时，鼓励阅读 MessageFormat 的文档。

以下示例创建一个可用来打印 "Duke's Table Page - " 和当前页码的 MessageFormat：

     // notice the escaping of the single quote
     // notice how the page number is included with "{0}"
     MessageFormat format = new MessageFormat("Duke''s Table: Page - {0}");

Printable 限制向它打印的每一页的可打印区域所绘制的内容。在某些情况下，可能看到该区域不可能放入所有页的内容。在这种情况下，可以截取输出，但实现将采取一些合理的行为。以下是几种已知会发生的情况，以及如何通过此特定实现来处理它们：

  • 在任何模式中，当标题或脚注文本太宽而无法完全放入可打印区域时，从表的起始处（由 ComponentOrientation 确定）开始打印尽可能多的文本。
  • 在任何模式中，当行太高而无法放入可打印区域时，打印行的最上面部分并且不绘制表的下边框。
  • 在 PrintMode.NORMAL 中，当列太宽而无法放入可打印区域时，打印该列的中央部分，不打印表的左右边框。

将此 Printable 包装到另一个 Printable 中是完全有效的，这可以用来创建复杂的报告和文档。甚至可以请求将不同的页呈现到不同大小的可打印区域中。必须准备好让实现处理此问题（可能通过其布局计算动态完成）。但是，当必须跨页分散列时，为每页提供不同的高度可能无法与 PrintMode.NORMAL 正常工作。

至于定制打印结果中表的外观的信息，JTable 自身将在打印期间负责隐藏选择和焦点。对于其他定制，用户的渲染器或绘制模式可以定制基于 JComponent.isPaintingForPrint() 值的外观。

此外，调用此方法之前，可以首先 修改该表的状态，例如取消单元编辑或者让用户恰当地调整表的大小。但是，在获取此 Printable 之后，不得再修改该表的状态（无效的修改包括在大小或底层数据方面的修改）。如果更改了该表，返回 Printable 的行为将是不确定的。

参数：
printMode - printable 应使用的打印模式
headerFormat - 指定在打印标题中所用文本的 MessageFormat，如果没有则为 null
footerFormat - 指定在打印脚注中所用文本的 MessageFormat，如果没有则为 null
返回：
用于打印此 JTable 的 Printable
从以下版本开始：
1.5
另请参见：
print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean), Printable, PrinterJob

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JTable 关联的 AccessibleContext。对于表，AccessibleContext 采用 AccessibleJTable 的形式。必要时创建新的 AccessibleJTable 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJTable，它充当此 JTable 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JRootPane.AccessibleJRootPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JRootPane.AccessibleJRootPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JRootPane.AccessibleJRootPane
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JRootPane
protected class JRootPane.AccessibleJRootPane
extends JComponent.AccessibleJComponent

此类实现对 JRootPane 类的可访问性支持。它提供适合于根窗格用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JRootPane.AccessibleJRootPane()
方法摘要
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回对象的可访问子级数。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JRootPane.AccessibleJRootPane

protected JRootPane.AccessibleJRootPane()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象的可访问子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从零开始的，因此 Accessible 第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 子级从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
getAccessibleChildrenCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JRootPane.RootLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JRootPane.RootLayout

java.lang.Object
    继承者  javax.swing.JRootPane.RootLayout
所有已实现的接口：
LayoutManager, LayoutManager2, Serializable
正在封闭类：
JRootPane
protected class JRootPane.RootLayout
extends Object
implements LayoutManager2, Serializable

该自定义布局管理器负责 layeredPane、glassPane 和 menuBar 的布局。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

构造方法摘要
protected JRootPane.RootLayout()
方法摘要
void | addLayoutComponent(Component comp, Object constraints) 使用指定约束对象，将指定组件添加到布局。
void | addLayoutComponent(String name, Component comp) 如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。
float | getLayoutAlignmentX(Container target) 返回沿 X 轴的对齐方式。
float | getLayoutAlignmentY(Container target) 返回沿 Y 轴的对齐方式。
void | invalidateLayout(Container target) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | layoutContainer(Container parent) 指示布局管理器为指定的容器执行布局。
Dimension | maximumLayoutSize(Container target) 返回布局能够使用的最大空间量。
Dimension | minimumLayoutSize(Container parent) 返回布局需要的最小空间量。
Dimension | preferredLayoutSize(Container parent) 返回布局要使用的空间量。
void | removeLayoutComponent(Component comp) 从布局移除指定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JRootPane.RootLayout

protected JRootPane.RootLayout()
方法详细信息

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
返回布局要使用的空间量。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 为其使用此布局管理器的 Container
返回：
包含此布局首选大小的 Dimension 对象
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
返回布局需要的最小空间量。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 为其使用此布局管理器的 Container
返回：
包含此布局最小大小的 Dimension 对象

maximumLayoutSize

public Dimension maximumLayoutSize(Container target)
返回布局能够使用的最大空间量。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
参数：
target - 为其使用此布局管理器的 Container
返回：
包含此布局最大大小的 Dimension 对象
另请参见：
Component.getMaximumSize(), LayoutManager

layoutContainer

public void layoutContainer(Container parent)
指示布局管理器为指定的容器执行布局。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 为其使用此布局管理器的 Container

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
从接口 LayoutManager 复制的描述
如果布局管理器使用每组件字符串，则将组件 comp 添加到布局，并将它与 name 指定的字符串关联。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从接口 LayoutManager 复制的描述
从布局移除指定组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件

addLayoutComponent

public void addLayoutComponent(Component comp,
                               Object constraints)
从接口 LayoutManager2 复制的描述
使用指定约束对象，将指定组件添加到布局。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
comp - 要添加的组件
constraints - 如何以及在何处将组件添加到布局。

getLayoutAlignmentX

public float getLayoutAlignmentX(Container target)
从接口 LayoutManager2 复制的描述
返回沿 X 轴的对齐方式。它指定如何相对于其他组件对齐该组件。值应该是一个介于 0 和 1 之间的数，其中 0 表示顶部对齐，1 表示底部对齐，0.5 表示居中对齐等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX

getLayoutAlignmentY

public float getLayoutAlignmentY(Container target)
从接口 LayoutManager2 复制的描述
返回沿 Y 轴的对齐方式。它指定如何相对于其他组件对齐该组件。值应该是一个介于 0 和 1 之间的数，其中 0 表示顶部对齐，1 表示底部对齐，0.5 表示居中对齐等。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY

invalidateLayout

public void invalidateLayout(Container target)
从接口 LayoutManager2 复制的描述
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。

指定者：
接口 LayoutManager2 中的 invalidateLayout
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JScrollBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JScrollBar

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JScrollBar
所有已实现的接口：
Adjustable, ImageObserver, MenuContainer, Serializable, Accessible
直接已知子类：
JScrollPane.ScrollBar
public class JScrollBar
extends JComponent
implements Adjustable, Accessible

滚动条的实现。用户在滚动条内移动滑块可确定显示区域中的内容。该程序通常将显示调整为滚动条的结束代表可显示内容的结束，或内容的 100%。滚动条的开始为可显示内容的开始，或 0%。然后滑块在其边界中的位置转换为可显示内容对应的百分比。

通常，随着滑块的位置在滚动条中的变化，将在基础视图上对 JViewport 的位置进行相应的更改，这样 JViewport 的内容也随之改变。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JScrollPane

嵌套类摘要
protected  class JScrollBar.AccessibleJScrollBar
此类实现 JScrollBar 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected int | blockIncrement
protected BoundedRangeModel | model 表示滚动条的最小、最大、跨度（也叫 "visibleAmount"）和当前值的模型。
protected int | orientation
protected int | unitIncrement
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.Adjustable 继承的字段
HORIZONTAL, NO_ORIENTATION, VERTICAL
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JScrollBar()
创建具有下列初始值的垂直滚动条：
JScrollBar(int orientation)
创建具有指定方向和下列初始值的滚动条：
JScrollBar(int orientation, int value, int extent, int min, int max)
创建具有指定方向、值、跨度、最小值和最大值的一个滚动条。
方法摘要
 void addAdjustmentListener(AdjustmentListener l)
添加一个 AdjustmentListener。
protected  void fireAdjustmentValueChanged(int id, int type, int value)
通知侦听器该滚动条的模型已更改。
 AccessibleContext getAccessibleContext()
获取与此 JScrollBar 相关联的 AccessibleContext。
 AdjustmentListener[] getAdjustmentListeners()
返回使用 addAdjustmentListener() 添加到此 JScrollBar 中的 AdjustmentListener 组成的数组。
 int getBlockIncrement()
供与 java.awt.Scrollbar 向后兼容。
 int getBlockIncrement(int direction)
针对一个向上/向下滚动一个块（通常为 "page"）的请求，返回滚动条值的更改量。
 int getMaximum()
滚动条的最大值为最大跨度。
 Dimension getMaximumSize()
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
 int getMinimum()
返回滚动条支持的最小值（通常为 0）。
 Dimension getMinimumSize()
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。
 BoundedRangeModel getModel()
返回处理滚动条的四个基本属性的数据模型：minimum、maximum、value 和 extent。
 int getOrientation()
返回组件的方向（横向或纵向）。
 ScrollBarUI getUI()
返回实现此组件的外观的委托。
 String getUIClassID()
返回此组件的 LookAndFeel 类的名称。
 int getUnitIncrement()
供与 java.awt.Scrollbar 向后兼容。
 int getUnitIncrement(int direction)
针对一个向上/向下滚动一个单位的请求，返回滚动条值的更改量。
 int getValue()
返回滚动条的值。
 boolean getValueIsAdjusting()
如果滚动条滑块被拖动，则返回 True。
 int getVisibleAmount()
返回滚动条的跨度，即它的 "visibleAmount"。
protected  String paramString()
返回此 JScrollBar 的字符串表示形式。
 void removeAdjustmentListener(AdjustmentListener l)
移除一个 AdjustmentEvent 侦听器。
 void setBlockIncrement(int blockIncrement)
设置 blockIncrement 属性。
 void setEnabled(boolean x)
启用该组件以便滑块位置能够改变。
 void setMaximum(int maximum)
设置模型的 maximum 属性。
 void setMinimum(int minimum)
设置模型的 minimum 属性。
 void setModel(BoundedRangeModel newModel)
设置处理滚动条的以下四个基本属性的模型：minimum、maximum、value 和 extent。
 void setOrientation(int orientation)
将滚动条的方向设置为 VERTICAL 或 HORIZONTAL。
 void setUI(ScrollBarUI ui)
设置呈现此组件的 L&F 对象。
 void setUnitIncrement(int unitIncrement)
设置 unitIncrement 属性。
 void setValue(int value)
设置滚动条的值。
 void setValueIsAdjusting(boolean b)
设置模型的 valueIsAdjusting 属性。
 void setValues(int newValue, int newExtent, int newMin, int newMax)
强制参数满足以下常规约束后设置四个 BoundedRangeModel 属性：
 void setVisibleAmount(int extent)
设置模型的 extent 属性。
 void updateUI()
重写 JComponent.updateUI。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

model

protected BoundedRangeModel model
表示滚动条的最小、最大、跨度（也叫 "visibleAmount"）和当前值的模型。

另请参见：
setModel(javax.swing.BoundedRangeModel)

orientation

protected int orientation
另请参见：
setOrientation(int)

unitIncrement

protected int unitIncrement
另请参见：
setUnitIncrement(int)

blockIncrement

protected int blockIncrement
另请参见：
setBlockIncrement(int)
构造方法详细信息

JScrollBar

public JScrollBar(int orientation,
                  int value,
                  int extent,
                  int min,
                  int max)
创建具有指定方向、值、跨度、最小值和最大值的一个滚动条。“跨度”是指可见区域的大小。它又被称为“可见量”。

注：使用 setBlockIncrement 将块增量设置为一个比视图的跨度稍小的大小。这样，当用户使滑块跳到一个相邻位置时，原有内容的一行或两行仍位于视图中。

抛出：
IllegalArgumentException - 如果 orientation 不属于 VERTICAL 或 HORIZONTAL 中的任何一个
另请参见：
setOrientation(int), setValue(int), setVisibleAmount(int), setMinimum(int), setMaximum(int)

JScrollBar

public JScrollBar(int orientation)
创建具有指定方向和下列初始值的滚动条：
 minimum = 0
 maximum = 100
 value = 0
 extent = 10

JScrollBar

public JScrollBar()
创建具有下列初始值的垂直滚动条：
 minimum = 0
 maximum = 100
 value = 0
 extent = 10

方法详细信息

setUI

public void setUI(ScrollBarUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - ScrollBarUI L&F 对象
从以下版本开始：
1.4
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getUI

public ScrollBarUI getUI()
返回实现此组件的外观的委托。

另请参见：
JComponent.setUI(javax.swing.plaf.ComponentUI)

updateUI

public void updateUI()
重写 JComponent.updateUI。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回此组件的 LookAndFeel 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
"ScrollBarUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getOrientation

public int getOrientation()
返回组件的方向（横向或纵向）。

指定者：
接口 Adjustable 中的 getOrientation
返回：
VERTICAL 或 HORIZONTAL
另请参见：
setOrientation(int), Adjustable.getOrientation()

setOrientation

public void setOrientation(int orientation)
将滚动条的方向设置为 VERTICAL 或 HORIZONTAL。

抛出：
IllegalArgumentException - 如果方向不属于 VERTICAL、HORIZONTAL 中的任何一个
另请参见：
getOrientation()

getModel

public BoundedRangeModel getModel()
返回处理滚动条的四个基本属性的数据模型：minimum、maximum、value 和 extent。

另请参见：
setModel(javax.swing.BoundedRangeModel)

setModel

public void setModel(BoundedRangeModel newModel)
设置处理滚动条的以下四个基本属性的模型：minimum、maximum、value 和 extent。

另请参见：
getModel()

getUnitIncrement

public int getUnitIncrement(int direction)
针对一个向上/向下滚动一个单位的请求，返回滚动条值的更改量。当用户单击滚动条向上/向下箭头时，ScrollBarUI 实现通常调用此方法，并用此方法的结果来更新滚动条的值。子类可重写此方法以便计算某个值，例如，向上或向下滚动一行文本（变量 height）或在表格中滚动一行时所需的改变值。

JScrollPane 组件创建的滚动条（默认）会重写此方法，还会将它委托给视口的 Scrollable 视图（如果有）。Scrollable 接口提供了此方法的一个更为特殊的版本。

参数：
direction - 为 -1 或 1，分别对应向上/向下
返回：
unitIncrement 属性的值
另请参见：
setUnitIncrement(int), setValue(int), Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

setUnitIncrement

public void setUnitIncrement(int unitIncrement)
设置 unitIncrement 属性。

注意，如果参数等于值 Integer.MIN_VALUE，大多数外观显示将不提供向右/向下滚动。

指定者：
接口 Adjustable 中的 setUnitIncrement
参数：
unitIncrement - 单位增量
另请参见：
getUnitIncrement(int)

getBlockIncrement

public int getBlockIncrement(int direction)
针对一个向上/向下滚动一个块（通常为 "page"）的请求，返回滚动条值的更改量。当用户通过在滚动条“滑块”的上面或下面单击从而将值大幅度增大或减小时，ScrollBarUI 实现通常调用此方法。子类可重写此方法以便计算某个值，例如，在一个文本文档中向上或向下滚动一个段落时所需的改变值。

JScrollPane 组件创建的滚动条（默认）会重写此方法，还会将它委托给视口的 Scrollable 视图（如果有）。Scrollable 接口提供了此方法的一个更为特殊的版本。

参数：
direction - 为 -1 或 1，分别对应向上/向下
返回：
blockIncrement 属性的值
另请参见：
setBlockIncrement(int), setValue(int), Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)

setBlockIncrement

public void setBlockIncrement(int blockIncrement)
设置 blockIncrement 属性。

注意，如果参数等于值 Integer.MIN_VALUE，大多数外观显示将不提供向右/向下滚动。

指定者：
接口 Adjustable 中的 setBlockIncrement
参数：
blockIncrement - 块值增量
另请参见：
getBlockIncrement()

getUnitIncrement

public int getUnitIncrement()
供与 java.awt.Scrollbar 向后兼容。

指定者：
接口 Adjustable 中的 getUnitIncrement
返回：
可调整对象的单位值增量
另请参见：
Adjustable.getUnitIncrement(), getUnitIncrement(int)

getBlockIncrement

public int getBlockIncrement()
供与 java.awt.Scrollbar 向后兼容。

指定者：
接口 Adjustable 中的 getBlockIncrement
返回：
可调整对象的块值增量
另请参见：
Adjustable.getBlockIncrement(), getBlockIncrement(int)

getValue

public int getValue()
返回滚动条的值。

指定者：
接口 Adjustable 中的 getValue
返回：
模型的 value 属性
另请参见：
setValue(int)

setValue

public void setValue(int value)
设置滚动条的值。此方法只将值转发给模型。

指定者：
接口 Adjustable 中的 setValue
参数：
value - 当前值，它位于 minimum 和 maximum - visibleAmount 之间
另请参见：
getValue(), BoundedRangeModel.setValue(int)

getVisibleAmount

public int getVisibleAmount()
返回滚动条的跨度，即它的 "visibleAmount"。在许多滚动条的外观实现中，滚动条“滑块”或 "thumb" 的大小与此跨度成正比。

指定者：
接口 Adjustable 中的 getVisibleAmount
返回：
模型的 extent 属性的值
另请参见：
setVisibleAmount(int)

setVisibleAmount

public void setVisibleAmount(int extent)
设置模型的 extent 属性。

指定者：
接口 Adjustable 中的 setVisibleAmount
参数：
extent - 指示器的长度
另请参见：
getVisibleAmount(), BoundedRangeModel.setExtent(int)

getMinimum

public int getMinimum()
返回滚动条支持的最小值（通常为 0）。

指定者：
接口 Adjustable 中的 getMinimum
返回：
模型的 minimum 属性的值
另请参见：
setMinimum(int)

setMinimum

public void setMinimum(int minimum)
设置模型的 minimum 属性。

指定者：
接口 Adjustable 中的 setMinimum
参数：
minimum - 最小值
另请参见：
getMinimum(), BoundedRangeModel.setMinimum(int)

getMaximum

public int getMaximum()
滚动条的最大值为最大跨度。

指定者：
接口 Adjustable 中的 getMaximum
返回：
模型的 maximum 属性值
另请参见：
setMaximum(int)

setMaximum

public void setMaximum(int maximum)
设置模型的 maximum 属性。注意，滚动条的值只能设置为最大跨度。

指定者：
接口 Adjustable 中的 setMaximum
参数：
maximum - 最大值
另请参见：
getMaximum(), BoundedRangeModel.setMaximum(int)

getValueIsAdjusting

public boolean getValueIsAdjusting()
如果滚动条滑块被拖动，则返回 True。

返回：
模型的 valueIsAdjusting 属性
另请参见：
setValueIsAdjusting(boolean)

setValueIsAdjusting

public void setValueIsAdjusting(boolean b)
设置模型的 valueIsAdjusting 属性。当开始拖动滑块时，滚动条外观实现应将此属性设置为 true，拖动停止时，将此属性设置为 false。在 valueIsAdjusting 为 true 时，滚动条模型不生成 ChangeEvent。

另请参见：
getValueIsAdjusting(), BoundedRangeModel.setValueIsAdjusting(boolean)

setValues

public void setValues(int newValue,
                      int newExtent,
                      int newMin,
                      int newMax)
强制参数满足以下常规约束后设置四个 BoundedRangeModel 属性：
 minimum <= value <= value+extent <= maximum

另请参见：
BoundedRangeModel.setRangeProperties(int, int, int, int, boolean), setValue(int), setVisibleAmount(int), setMinimum(int), setMaximum(int)

addAdjustmentListener

public void addAdjustmentListener(AdjustmentListener l)
添加一个 AdjustmentListener。每当滚动条模型发生更改时，都会通知调整侦听器。为与 java.awt.Scrollbar 向后兼容而提供调整事件。

注意，AdjustmentEvent 类型属性将一直有一个占位值 AdjustmentEvent.TRACK，因为对 BoundedRangeModels 值的所有更改都被认为是等价的。要更改 BoundedRangeModel 的值，只需要设置它的 value 属性，即 model.setValue(123)。未提供任何关于更改起源的信息，如它是一个块减小的更改之类。这里对更改的起源将不赘述。

指定者：
接口 Adjustable 中的 addAdjustmentListener
参数：
l - 要添加的 AdjustmentLister
另请参见：
removeAdjustmentListener(java.awt.event.AdjustmentListener), BoundedRangeModel.addChangeListener(javax.swing.event.ChangeListener)

removeAdjustmentListener

public void removeAdjustmentListener(AdjustmentListener l)
移除一个 AdjustmentEvent 侦听器。

指定者：
接口 Adjustable 中的 removeAdjustmentListener
参数：
l - 要移除的 AdjustmentLister
另请参见：
addAdjustmentListener(java.awt.event.AdjustmentListener)

getAdjustmentListeners

public AdjustmentListener[] getAdjustmentListeners()
返回使用 addAdjustmentListener() 添加到此 JScrollBar 中的 AdjustmentListener 组成的数组。

返回：
如果有侦听器，则返回所有已添加的 AdjustmentListener；如果未添加任何侦听器，则返回一个空数组
从以下版本开始：
1.4

fireAdjustmentValueChanged

protected void fireAdjustmentValueChanged(int id,
                                          int type,
                                          int value)
通知侦听器该滚动条的模型已更改。

另请参见：
addAdjustmentListener(java.awt.event.AdjustmentListener), EventListenerList

getMinimumSize

public Dimension getMinimumSize()
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。

覆盖：
类 JComponent 中的 getMinimumSize
返回：
minimumSize 属性的值
另请参见：
JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

getMaximumSize

public Dimension getMaximumSize()
滚动条沿其滚动轴具有弹性，沿另一个轴具有刚性。

覆盖：
类 JComponent 中的 getMaximumSize
返回：
maximumSize 属性的值
另请参见：
JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

setEnabled

public void setEnabled(boolean x)
启用该组件以便滑块位置能够改变。如果被禁用，滑块位置将不能改变。

覆盖：
类 JComponent 中的 setEnabled
参数：
x - boolean 值，它为 true 时，启用该组件，它为 false 时，禁用该组件
另请参见：
Component.isEnabled(), Component.isLightweight()

paramString

protected String paramString()
返回此 JScrollBar 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JScrollBar 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JScrollBar 相关联的 AccessibleContext。对于 JScrollBar，AccessibleContext 采取 AccessibleJScrollBar 的形式。必要时创建新的 AccessibleJScrollBar 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJScrollBar，它充当此 JScrollBar 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JScrollBar.AccessibleJScrollBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JScrollBar.AccessibleJScrollBar

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JScrollBar.AccessibleJScrollBar
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
正在封闭类：
JScrollBar
protected class JScrollBar.AccessibleJScrollBar
extends JComponent.AccessibleJComponent
implements AccessibleValue

此类实现 JScrollBar 类的可访问性支持。它提供适合于滚动条用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JScrollBar.AccessibleJScrollBar()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的可访问值。
Number | getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | getMinimumAccessibleValue() 获取此对象的最小可访问值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JScrollBar.AccessibleJScrollBar

protected JScrollBar.AccessibleJScrollBar()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的可访问值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
此对象的当前值。
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置了该值，则返回 True。
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小可访问值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
此对象的最小值。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大可访问值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
此对象的最大值。
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JScrollPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JScrollPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JScrollPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, ScrollPaneConstants
public class JScrollPane
extends JComponent
implements ScrollPaneConstants, Accessible

提供轻量级组件的 scrollable 视图。JScrollPane 管理视口、可选的垂直和水平滚动条以及可选的行和列标题视口。有关 JScrollPane 的面向任务的文档，请参阅 The Java Tutorial 中的 How to Use Scroll Panes 一节。注意，JScrollPane 不支持重量级组件。

以下文本是对此图像的描述。

JViewport 为数据源提供一个窗口或“视口”，例如，一个文本文件。该数据源为由 JViewport 视图显示的“scrollable 客户端”（即数据模型）。JScrollPane 基本上由 JScrollBar、一个 JViewport 以及它们之间的连线组成，如右图所示。

除了滚动条和视口之外，JScrollPane 也可以有一个列标题和一个行标题。这二者都是 JViewport 对象，可用 setRowHeaderView 和 setColumnHeaderView 指定。列标题视口自动左右滚动，跟踪主视口的左右滚动。（但是它不会垂直滚动。）行标题的滚动方式与此类似。

在两个滚动条的交汇处、行标题与列标题的交汇处，或者滚动条与其中一个标题的交汇处，两个组件在很接近角的地方停止，留下一个默认情况下为空的矩形空间。四个角都有可能存在这些空间。在上图中，右上角存在该空间，由标签“角组件”标识。

可使用 setCorner 方法替换许多的这些空白空间，以便将组件添加到一个特定角。（注：相同的组件不能添加到多个角。）如果想要为滚动窗格增加一些额外的装饰或功能，那么此方法很有用。每个角组件的大小都完全由标题和/或包围它的滚动条的大小确定。

只有角组件存在于其中的角中有空白空间时该角组件才是可见的。例如，设想一个设置在滚动窗格（带有列标题）右上角的组件。如果滚动窗格的垂直滚动条不存在（可能因为视图组件尚未大到需要它的地步），那么该角组件将不会显示（因为标题和垂直滚动条的交汇点所创建的角中没有空白空间）。要强制使滚动条始终显示，可使用 setVerticalScrollBarPolicy(VERTICAL_SCROLLBAR_ALWAYS) 确保该角组件的空间始终存在。

要围绕主视口添加一个边界，可使用 setViewportBorder。（当然，也可以使用 setBorder 围绕整个滚动窗格添加一个边界。）

应该执行的一个常见操作是设置背景颜色，此颜色可在主视口小于视口或透明时使用。使用 scrollPane.getViewport().setBackground() 设置视口的背景色可实现此目的。设置视口而不是滚动窗格的颜色的原因是，默认情况下，JViewport 为不透明，还有一些其他属性，这意味着它将用其背景色完全填充背景。因此当 JScrollPane 绘制其背景时，视口通常将在它上面绘制。

默认情况下，JScrollPane 使用 ScrollPaneLayout 处理其子组件的布局。ScrollPaneLayout 使用以下两个方法之一确定视口视图的大小：

  1. 如果视图实现了 Scrollable，将使用 getPreferredScrollableViewportSize、getScrollableTracksViewportWidth 和 getScrollableTracksViewportHeight 的组合，否则使用
  2. getPreferredSize。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JScrollBar,
JViewport,
ScrollPaneLayout,
Scrollable,
Component.getPreferredSize(),
setViewportView(java.awt.Component),
setRowHeaderView(java.awt.Component),
setColumnHeaderView(java.awt.Component),
setCorner(java.lang.String, java.awt.Component),
setViewportBorder(javax.swing.border.Border)

嵌套类摘要
protected class | JScrollPane.AccessibleJScrollPane 此类实现 JScrollPane 类的可访问性支持。
protected class | JScrollPane.ScrollBar 默认情况下，JScrollPane 创建的滚动条为此类的实例。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected JViewport | columnHeader 列标题子级。
protected JScrollBar | horizontalScrollBar 滚动窗格的水平滚动条子级。
protected int | horizontalScrollBarPolicy 用于水平滚动条的显示策略。
protected Component | lowerLeft 在左下角显示的组件。
protected Component | lowerRight 在右下角显示的组件。
protected JViewport | rowHeader 行标题子级。
protected Component | upperLeft 在左上角显示的组件。
protected Component | upperRight 在右上角显示的组件。
protected JScrollBar | verticalScrollBar 滚动窗格的垂直滚动条子级。
protected int | verticalScrollBarPolicy 用于垂直滚动条的显示策略。
protected JViewport | viewport 滚动窗格的视口子级。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.ScrollPaneConstants 继承的字段
COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JScrollPane()
创建一个空的（无视口的视图）JScrollPane，需要时水平和垂直滚动条都可显示。
JScrollPane(Component view)
创建一个显示指定组件内容的 JScrollPane，只要组件的内容超过视图大小就会显示水平和垂直滚动条。
JScrollPane(Component view, int vsbPolicy, int hsbPolicy)
创建一个 JScrollPane，它将视图组件显示在一个视口中，视图位置可使用一对滚动条控制。
JScrollPane(int vsbPolicy, int hsbPolicy)
创建一个具有指定滚动条策略的空（无视口的视图）JScrollPane。
方法摘要
JScrollBar | createHorizontalScrollBar() 默认返回 JScrollPane.ScrollBar。
JScrollBar | createVerticalScrollBar() 默认返回 JScrollPane.ScrollBar。
protected JViewport | createViewport() 默认返回新的 JViewport。
AccessibleContext | getAccessibleContext() 获取与此 JScrollPane 相关联的 AccessibleContext。
JViewport | getColumnHeader() 返回列标题。
Component | getCorner(String key) 返回位于指定角的组件。
JScrollBar | getHorizontalScrollBar() 返回控制视口的水平视图位置的水平滚动条。
int | getHorizontalScrollBarPolicy() 返回水平滚动条策略值。
JViewport | getRowHeader() 返回行标题。
ScrollPaneUI | getUI() 返回呈现此组件的外观 (L&F) 对象。
String | getUIClassID() 返回用于构造呈现此组件时所用 L&F 类的名称的后缀。
JScrollBar | getVerticalScrollBar() 返回控制视口垂直视图位置的垂直滚动条。
int | getVerticalScrollBarPolicy() 返回垂直滚动条策略值。
JViewport | getViewport() 返回当前的 JViewport。
Border | getViewportBorder() 返回围绕该视口的 Border 对象。
Rectangle | getViewportBorderBounds() 返回视口边界的范围。
boolean | isValidateRoot() 重写以返回 true，这样任何在此 JScrollPane 的任何后代上对 revalidate 的调用将使从此 JScrollPane 开始的整个树接受验证。
boolean | isWheelScrollingEnabled() 指示是否进行滚动以响应鼠标滚轮。
protected String | paramString() 返回此 JScrollPane 的字符串表示形式。
void | setColumnHeader(JViewport columnHeader) 移除旧的 columnHeader，如果有的话；如果新的 columnHeader 不为 null，将其 viewPosition 的 x 坐标与视口（如果有）同步然后将其添加到滚动窗格。
void | setColumnHeaderView(Component view) 创建一个列标题视口（如果有必要），设置其视图然后将此列标题视口添加到滚动窗格。
void | setComponentOrientation(ComponentOrientation co) 设置由 ComponentOrientation 参数确定的垂直和水平滚动条方向。
void | setCorner(String key, Component corner) 添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。
void | setHorizontalScrollBar(JScrollBar horizontalScrollBar) 将控制视口水平视图位置的水平滚动条添加到滚动窗格中。
void | setHorizontalScrollBarPolicy(int policy) 确定水平滚动条何时显示在滚动窗格上。
void | setLayout(LayoutManager layout) 设置此 JScrollPane 的布局管理器。
void | setRowHeader(JViewport rowHeader) 移除旧的 rowHeader，如果存在；如果新的 rowHeader 不为 null，将其 viewPosition 的 y 坐标与视口（如果有）同步然后将其添加到滚动窗格。
void | setRowHeaderView(Component view) 创建一个行标题视口（如果有必要），设置其视图然后将此行标题视口添加到滚动窗格。
void | setUI(ScrollPaneUI ui) 设置 ScrollPaneUI 对象，它为此组件提供外观 (L&F)。
void | setVerticalScrollBar(JScrollBar verticalScrollBar) 将控制视口垂直视图位置的滚动条添加到滚动窗格中。
void | setVerticalScrollBarPolicy(int policy) 确定垂直滚动条何时显示在滚动窗格上。
void | setViewport(JViewport viewport) 移除旧视口（如果有）；强制新视口的 viewPosition 位于 +x,+y 象限中；将行和列标题（如果有）与新视口同步；最后将滚动条和标题与新视口同步。
void | setViewportBorder(Border viewportBorder) 围绕视口添加一个边界。
void | setViewportView(Component view) 创建一个视口（如果有必要）并设置其视图。
void | setWheelScrollingEnabled(boolean handleWheel) 启用/禁用对鼠标滚轮滚动的移动响应。
void | updateUI() 用一个来自当前默认外观的 ScrollPaneUI 替换当前的 ScrollPaneUI 对象。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

verticalScrollBarPolicy

protected int verticalScrollBarPolicy
用于垂直滚动条的显示策略。默认为 ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED。

另请参见：
setVerticalScrollBarPolicy(int)

horizontalScrollBarPolicy

protected int horizontalScrollBarPolicy
用于水平滚动条的显示策略。默认为 ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED。

另请参见：
setHorizontalScrollBarPolicy(int)

viewport

protected JViewport viewport
滚动窗格的视口子级。默认为一个空的 JViewport。

另请参见：
setViewport(javax.swing.JViewport)

verticalScrollBar

protected JScrollBar verticalScrollBar
滚动窗格的垂直滚动条子级。默认为 JScrollBar。

另请参见：
setVerticalScrollBar(javax.swing.JScrollBar)

horizontalScrollBar

protected JScrollBar horizontalScrollBar
滚动窗格的水平滚动条子级。默认为 JScrollBar。

另请参见：
setHorizontalScrollBar(javax.swing.JScrollBar)

rowHeader

protected JViewport rowHeader
行标题子级。默认为 null。

另请参见：
setRowHeader(javax.swing.JViewport)

columnHeader

protected JViewport columnHeader
列标题子级。默认为 null。

另请参见：
setColumnHeader(javax.swing.JViewport)

lowerLeft

protected Component lowerLeft
在左下角显示的组件。默认为 null。

另请参见：
setCorner(java.lang.String, java.awt.Component)

lowerRight

protected Component lowerRight
在右下角显示的组件。默认为 null。

另请参见：
setCorner(java.lang.String, java.awt.Component)

upperLeft

protected Component upperLeft
在左上角显示的组件。默认为 null。

另请参见：
setCorner(java.lang.String, java.awt.Component)

upperRight

protected Component upperRight
在右上角显示的组件。默认为 null。

另请参见：
setCorner(java.lang.String, java.awt.Component)
构造方法详细信息

JScrollPane

public JScrollPane(Component view,
                   int vsbPolicy,
                   int hsbPolicy)
创建一个 JScrollPane，它将视图组件显示在一个视口中，视图位置可使用一对滚动条控制。滚动条策略指定滚动条在何时显示，例如，如果 vsbPolicy 为 VERTICAL_SCROLLBAR_AS_NEEDED，则只有在垂直查看无法完全显示时，垂直滚动条才显示。可用的策略设定在 setVerticalScrollBarPolicy(int) 和 setHorizontalScrollBarPolicy(int) 中列出。

参数：
view - 将显示在滚动窗格视口中的组件
vsbPolicy - 指定垂直滚动条策略的一个整数
hsbPolicy - 指定水平滚动条策略的一个整数
另请参见：
setViewportView(java.awt.Component)

JScrollPane

public JScrollPane(Component view)
创建一个显示指定组件内容的 JScrollPane，只要组件的内容超过视图大小就会显示水平和垂直滚动条。

参数：
view - 将显示在滚动窗格视口中的组件
另请参见：
setViewportView(java.awt.Component)

JScrollPane

public JScrollPane(int vsbPolicy,
                   int hsbPolicy)
创建一个具有指定滚动条策略的空（无视口的视图）JScrollPane。可用的策略设定在 setVerticalScrollBarPolicy(int) 和 setHorizontalScrollBarPolicy(int) 中列出。

参数：
vsbPolicy - 指定垂直滚动条策略的一个整数
hsbPolicy - 指定水平滚动条策略的一个整数
另请参见：
setViewportView(java.awt.Component)

JScrollPane

public JScrollPane()
创建一个空的（无视口的视图）JScrollPane，需要时水平和垂直滚动条都可显示。

方法详细信息

getUI

public ScrollPaneUI getUI()
返回呈现此组件的外观 (L&F) 对象。

返回：
呈现此组件的 ScrollPaneUI 对象
另请参见：
setUI(javax.swing.plaf.ScrollPaneUI)

setUI

public void setUI(ScrollPaneUI ui)
设置 ScrollPaneUI 对象，它为此组件提供外观 (L&F)。

参数：
ui - ScrollPaneUI L&F 对象
另请参见：
getUI()

updateUI

public void updateUI()
用一个来自当前默认外观的 ScrollPaneUI 替换当前的 ScrollPaneUI 对象。在默认的外观更改时将被调用。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI(), UIManager.getUI(javax.swing.JComponent)

getUIClassID

public String getUIClassID()
返回用于构造呈现此组件时所用 L&F 类的名称的后缀。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "ScrollPaneUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setLayout

public void setLayout(LayoutManager layout)
设置此 JScrollPane 的布局管理器。此方法重写 java.awt.Container 中的 setLayout，这样可确保只有属于 ScrollPaneLayout 的子类的 LayoutManager 才能在 JScrollPane 中使用。如果 layout 为非 null，将在其上调用 syncWithScrollPane。

覆盖：
类 Container 中的 setLayout
参数：
layout - 指定的布局管理器
抛出：
ClassCastException - 如果布局不是 ScrollPaneLayout
另请参见：
Container.getLayout(), Container.setLayout(java.awt.LayoutManager)

isValidateRoot

public boolean isValidateRoot()
重写以返回 true，这样任何在此 JScrollPane 的任何后代上对 revalidate 的调用将使从此 JScrollPane 开始的整个树接受验证。

覆盖：
类 JComponent 中的 isValidateRoot
返回：
true
另请参见：
Container.validate(),
JComponent.revalidate(),
JComponent.isValidateRoot()

getVerticalScrollBarPolicy

public int getVerticalScrollBarPolicy()
返回垂直滚动条策略值。

返回：
verticalScrollBarPolicy 属性
另请参见：
setVerticalScrollBarPolicy(int)

setVerticalScrollBarPolicy

public void setVerticalScrollBarPolicy(int policy)
确定垂直滚动条何时显示在滚动窗格上。合法值是：
  • ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED
  • ScrollPaneConstants.VERTICAL_SCROLLBAR_NEVER
  • ScrollPaneConstants.VERTICAL_SCROLLBAR_ALWAYS

参数：
policy - 以上列出的三个值之一
抛出：
IllegalArgumentException - 如果 policy 不是以上列出的合法值之一
另请参见：
getVerticalScrollBarPolicy()

getHorizontalScrollBarPolicy

public int getHorizontalScrollBarPolicy()
返回水平滚动条策略值。

返回：
horizontalScrollBarPolicy 属性
另请参见：
setHorizontalScrollBarPolicy(int)

setHorizontalScrollBarPolicy

public void setHorizontalScrollBarPolicy(int policy)
确定水平滚动条何时显示在滚动窗格上。选项有：
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_NEVER
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_ALWAYS

参数：
policy - 以上列出的三个值之一
抛出：
IllegalArgumentException - 如果 policy 不是以上列出的合法值之一
另请参见：
getHorizontalScrollBarPolicy()

getViewportBorder

public Border getViewportBorder()
返回围绕该视口的 Border 对象。

返回：
viewportBorder 属性
另请参见：
setViewportBorder(javax.swing.border.Border)

setViewportBorder

public void setViewportBorder(Border viewportBorder)
围绕视口添加一个边界。注意，边界并不是直接设置在视口上，JViewport 不支持 JComponent 边界属性。同样，设置 JScrollPane 的视口并不影响 viewportBorder 属性。

此属性的默认值由外观实现计算。

参数：
viewportBorder - 要添加的边界
另请参见：
getViewportBorder(), setViewport(javax.swing.JViewport)

getViewportBorderBounds

public Rectangle getViewportBorderBounds()
返回视口边界的范围。

返回：
一个指定该视口边界的 Rectangle 对象

createHorizontalScrollBar

public JScrollBar createHorizontalScrollBar()
默认返回 JScrollPane.ScrollBar。子类可以重写此方法来强制 ScrollPaneUI 实现使用 JScrollBar 子类。ScrollPaneUI 实现用它来创建水平滚动条。

返回：
水平方向的 JScrollBar
另请参见：
JScrollBar

getHorizontalScrollBar

public JScrollBar getHorizontalScrollBar()
返回控制视口的水平视图位置的水平滚动条。

返回：
horizontalScrollBar 属性
另请参见：
setHorizontalScrollBar(javax.swing.JScrollBar)

setHorizontalScrollBar

public void setHorizontalScrollBar(JScrollBar horizontalScrollBar)
将控制视口水平视图位置的水平滚动条添加到滚动窗格中。这通常是不必要的，因为 JScrollPane 默认创建水平和垂直滚动条。

参数：
horizontalScrollBar - 要添加的水平滚动条
另请参见：
createHorizontalScrollBar(), getHorizontalScrollBar()

createVerticalScrollBar

public JScrollBar createVerticalScrollBar()
默认返回 JScrollPane.ScrollBar。子类可以重写此方法来强制 ScrollPaneUI 实现使用 JScrollBar 子类。ScrollPaneUI 实现用它来创建垂直滚动条。

返回：
垂直方向的 JScrollBar
另请参见：
JScrollBar

getVerticalScrollBar

public JScrollBar getVerticalScrollBar()
返回控制视口垂直视图位置的垂直滚动条。

返回：
verticalScrollBar 属性
另请参见：
setVerticalScrollBar(javax.swing.JScrollBar)

setVerticalScrollBar

public void setVerticalScrollBar(JScrollBar verticalScrollBar)
将控制视口垂直视图位置的滚动条添加到滚动窗格中。这通常是不必要的，因为 JScrollPane 默认创建垂直和水平滚动条。

参数：
verticalScrollBar - 要添加的新垂直滚动条
另请参见：
createVerticalScrollBar(), getVerticalScrollBar()

createViewport

protected JViewport createViewport()
默认返回新的 JViewport。在 setViewportView、setRowHeaderView 和 setColumnHeaderView 中使用它来创建视口（需要时）。子类可重写此方法来返回 JViewport 的一个子类。

返回：
新的 JViewport

getViewport

public JViewport getViewport()
返回当前的 JViewport。

返回：
viewport 属性
另请参见：
setViewport(javax.swing.JViewport)

setViewport

public void setViewport(JViewport viewport)
移除旧视口（如果有）；强制新视口的 viewPosition 位于 +x,+y 象限中；将行和列标题（如果有）与新视口同步；最后将滚动条和标题与新视口同步。

在大多数应用程序中，使用 setViewportView 将视口和视图添加到滚动窗格更为方便。

参数：
viewport - 要使用的新视口；如果视口为 null，将依旧移除旧视口并将新视口设置为 null
另请参见：
createViewport(),
getViewport(),
setViewportView(java.awt.Component)

setViewportView

public void setViewportView(Component view)
创建一个视口（如果有必要）并设置其视图。不直接为 JScrollPane 构造方法提供视图的应用程序应使用此方法指定将显示在滚动窗格中的滚动组件子级。例如：
 JScrollPane scrollpane = new JScrollPane();
 scrollpane.setViewportView(myBigComponentToScroll);
应用程序不应将子级直接添加到滚动窗格。

参数：
view - 要添加到视口的组件
另请参见：
setViewport(javax.swing.JViewport), JViewport.setView(java.awt.Component)

getRowHeader

public JViewport getRowHeader()
返回行标题。

返回：
rowHeader 属性
另请参见：
setRowHeader(javax.swing.JViewport)

setRowHeader

public void setRowHeader(JViewport rowHeader)
移除旧的 rowHeader，如果存在；如果新的 rowHeader 不为 null，将其 viewPosition 的 y 坐标与视口（如果有）同步然后将其添加到滚动窗格。

在大多数应用程序中，使用 setRowHeaderView 将行标题组件及其视口添加到滚动窗格更为方便。

参数：
rowHeader - 要使用的新行标题；如果为 null 将依旧移除旧行标题并将新行标题设置为 null
另请参见：
getRowHeader(), setRowHeaderView(java.awt.Component)

setRowHeaderView

public void setRowHeaderView(Component view)
创建一个行标题视口（如果有必要），设置其视图然后将此行标题视口添加到滚动窗格。例如：
 JScrollPane scrollpane = new JScrollPane();
 scrollpane.setViewportView(myBigComponentToScroll);
 scrollpane.setRowHeaderView(myBigComponentsRowHeader);

参数：
view - 将作为行标题显示的组件
另请参见：
setRowHeader(javax.swing.JViewport), JViewport.setView(java.awt.Component)

getColumnHeader

public JViewport getColumnHeader()
返回列标题。

返回：
columnHeader 属性
另请参见：
setColumnHeader(javax.swing.JViewport)

setColumnHeader

public void setColumnHeader(JViewport columnHeader)
移除旧的 columnHeader，如果有的话；如果新的 columnHeader 不为 null，将其 viewPosition 的 x 坐标与视口（如果有）同步然后将其添加到滚动窗格。

在大多数应用程序中，使用 setColumnHeaderView 将列标题组件及其视口添加到滚动窗格更为方便。

另请参见：
getColumnHeader(), setColumnHeaderView(java.awt.Component)

setColumnHeaderView

public void setColumnHeaderView(Component view)
创建一个列标题视口（如果有必要），设置其视图然后将此列标题视口添加到滚动窗格。例如：
 JScrollPane scrollpane = new JScrollPane();
 scrollpane.setViewportView(myBigComponentToScroll);
 scrollpane.setColumnHeaderView(myBigComponentsColumnHeader);

参数：
view - 将作为列标题显示的组件
另请参见：
setColumnHeader(javax.swing.JViewport), JViewport.setView(java.awt.Component)

getCorner

public Component getCorner(String key)
返回位于指定角的组件。指定角的 key 值为下列之一：
  • ScrollPaneConstants.LOWER_LEFT_CORNER
  • ScrollPaneConstants.LOWER_RIGHT_CORNER
  • ScrollPaneConstants.UPPER_LEFT_CORNER
  • ScrollPaneConstants.UPPER_RIGHT_CORNER
  • ScrollPaneConstants.LOWER_LEADING_CORNER
  • ScrollPaneConstants.LOWER_TRAILING_CORNER
  • ScrollPaneConstants.UPPER_LEADING_CORNER
  • ScrollPaneConstants.UPPER_TRAILING_CORNER

参数：
key - 如上所示的值之一
返回：
给定键所标识的角组件（可以为 null）；如果该键无效，则返回 null
另请参见：
setCorner(java.lang.String, java.awt.Component)

setCorner

public void setCorner(String key,
                      Component corner)
添加一个将显示在一个滚动窗格角中的子级，如果有空间的话。例如，两个滚动条的显示中（在滚动窗格的右边缘和下边缘），左下角组件将显示在两个滚动条两头之间的空间中。key 的合法值有：
  • ScrollPaneConstants.LOWER_LEFT_CORNER
  • ScrollPaneConstants.LOWER_RIGHT_CORNER
  • ScrollPaneConstants.UPPER_LEFT_CORNER
  • ScrollPaneConstants.UPPER_RIGHT_CORNER
  • ScrollPaneConstants.LOWER_LEADING_CORNER
  • ScrollPaneConstants.LOWER_TRAILING_CORNER
  • ScrollPaneConstants.UPPER_LEADING_CORNER
  • ScrollPaneConstants.UPPER_TRAILING_CORNER

尽管 "corner" 不与任何 beans 属性签名匹配，生成的 PropertyChange 事件还是将此属性名设置为 corner key。

参数：
key - 标识组件将显示的角
corner - 下列组件之一：
  • lowerLeft
  • lowerRight
  • upperLeft
  • upperRight
抛出：
IllegalArgumentException - 如果 corner key 无效

setComponentOrientation

public void setComponentOrientation(ComponentOrientation co)
设置由 ComponentOrientation 参数确定的垂直和水平滚动条方向。

覆盖：
类 Component 中的 setComponentOrientation
参数：
co - 以下值之一：
  • java.awt.ComponentOrientation.LEFT_TO_RIGHT
  • java.awt.ComponentOrientation.RIGHT_TO_LEFT
  • java.awt.ComponentOrientation.UNKNOWN
另请参见：
ComponentOrientation

isWheelScrollingEnabled

public boolean isWheelScrollingEnabled()
指示是否进行滚动以响应鼠标滚轮。默认情况下启用滚轮滚动。

从以下版本开始：
1.4
另请参见：
setWheelScrollingEnabled(boolean)

setWheelScrollingEnabled

public void setWheelScrollingEnabled(boolean handleWheel)
启用/禁用对鼠标滚轮滚动的移动响应。默认情况下启用滚轮滚动。

参数：
handleWheel - 如果为 MouseWheelEvent 自动完成滚动，则为 true；否则为 false。
从以下版本开始：
1.4
另请参见：
isWheelScrollingEnabled(), MouseWheelEvent, MouseWheelListener

paramString

protected String paramString()
返回此 JScrollPane 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JScrollPane 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JScrollPane 相关联的 AccessibleContext。对于滚动窗格，AccessibleContext 采用的是 AccessibleJScrollPane 的形式。必要时创建一个新的 AccessibleJScrollPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJScrollPane，它充当此 JScrollPane 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JScrollPane.AccessibleJScrollPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JScrollPane.AccessibleJScrollPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JScrollPane.AccessibleJScrollPane
所有已实现的接口：
PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, ChangeListener
正在封闭类：
JScrollPane
protected class JScrollPane.AccessibleJScrollPane
extends JComponent.AccessibleJComponent
implements ChangeListener, PropertyChangeListener

此类实现 JScrollPane 类的可访问性支持。它提供适合于滚动窗格用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
protected  JViewport viewPort
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JScrollPane.AccessibleJScrollPane()
AccessibleJScrollPane 构造方法
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
void | propertyChange(PropertyChangeEvent e) 当有一个绑定 (bound) 属性改变时，此方法被调用。
void | resetViewPort()
void | stateChanged(ChangeEvent e) 当侦听器目标的状态改变时，此方法被调用。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

字段详细信息

viewPort

protected JViewport viewPort
构造方法详细信息

JScrollPane.AccessibleJScrollPane

public JScrollPane.AccessibleJScrollPane()
AccessibleJScrollPane 构造方法

方法详细信息

resetViewPort

public void resetViewPort()

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

stateChanged

public void stateChanged(ChangeEvent e)
当侦听器目标的状态改变时，此方法被调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象。不能为 null。
抛出：
NullPointerException - 如果参数为 null。

propertyChange

public void propertyChange(PropertyChangeEvent e)
当有一个绑定 (bound) 属性改变时，此方法被调用。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。不能为 null。
抛出：
NullPointerException - 如果参数为 null。
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JScrollPane.ScrollBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JScrollPane.ScrollBar

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JScrollBar
                    继承者  javax.swing.JScrollPane.ScrollBar
所有已实现的接口：
Adjustable, ImageObserver, MenuContainer, Serializable, Accessible, UIResource
正在封闭类：
JScrollPane
protected class JScrollPane.ScrollBar
extends JScrollBar
implements UIResource

默认情况下，JScrollPane 创建的滚动条为此类的实例。Scrollbar 重写 getUnitIncrement 和 getBlockIncrement 方法，所以如果视口的视图为 Scrollable，会要求该视图计算这些值。除非显式设置了单位/块增量。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

另请参见：
Scrollable, JScrollPane.createVerticalScrollBar(), JScrollPane.createHorizontalScrollBar()

嵌套类摘要
从类 javax.swing.JScrollBar 继承的嵌套类/接口
JScrollBar.AccessibleJScrollBar
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JScrollBar 继承的字段
blockIncrement, model, orientation, unitIncrement
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.Adjustable 继承的字段
HORIZONTAL, NO_ORIENTATION, VERTICAL
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JScrollPane.ScrollBar(int orientation)
创建具有指定方向的滚动条。
方法摘要
int | getBlockIncrement(int direction) 如果视口中的视图为 Scrollable 对象，将计算滚动的块增量值。
int | getUnitIncrement(int direction) 如果视口中的视图为 Scrollable 对象，将计算滚动的单位增量值。
void | setBlockIncrement(int blockIncrement) 通知超类来设定该值，并将 blockIncrementSet 实例变量重置为 true。
void | setUnitIncrement(int unitIncrement) 通知超类来设定该值，并将 unitIncrementSet 实例变量重置为 true。
从类 javax.swing.JScrollBar 继承的方法
addAdjustmentListener, fireAdjustmentValueChanged, getAccessibleContext, getAdjustmentListeners, getBlockIncrement, getMaximum, getMaximumSize, getMinimum, getMinimumSize, getModel, getOrientation, getUI, getUIClassID, getUnitIncrement, getValue, getValueIsAdjusting, getVisibleAmount, paramString, removeAdjustmentListener, setEnabled, setMaximum, setMinimum, setModel, setOrientation, setUI, setValue, setValueIsAdjusting, setValues, setVisibleAmount, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JScrollPane.ScrollBar

public JScrollPane.ScrollBar(int orientation)
创建具有指定方向的滚动条。方向包括：
  • ScrollPaneConstants.VERTICAL
  • ScrollPaneConstants.HORIZONTAL

参数：
orientation - 指定上面两个合法方向值之一的整数
方法详细信息

setUnitIncrement

public void setUnitIncrement(int unitIncrement)
通知超类来设定该值，并将 unitIncrementSet 实例变量重置为 true。

指定者：
接口 Adjustable 中的 setUnitIncrement
覆盖：
类 JScrollBar 中的 setUnitIncrement
参数：
unitIncrement - 新单位增量值，以像素为单位
从以下版本开始：
1.4
另请参见：
JScrollBar.getUnitIncrement(int)

getUnitIncrement

public int getUnitIncrement(int direction)
如果视口中的视图为 Scrollable 对象，将计算滚动的单位增量值。否则返回 super.getUnitIncrement。

覆盖：
类 JScrollBar 中的 getUnitIncrement
参数：
direction - 小于零表示向上/左滚动，大于零表示向下/右滚动
返回：
包含单位增量的整数，以像素为单位
另请参见：
Scrollable.getScrollableUnitIncrement(java.awt.Rectangle, int, int)

setBlockIncrement

public void setBlockIncrement(int blockIncrement)
通知超类来设定该值，并将 blockIncrementSet 实例变量重置为 true。

指定者：
接口 Adjustable 中的 setBlockIncrement
覆盖：
类 JScrollBar 中的 setBlockIncrement
参数：
blockIncrement - 新的块增量值，以像素为单位
另请参见：
JScrollBar.getBlockIncrement()

getBlockIncrement

public int getBlockIncrement(int direction)
如果视口中的视图为 Scrollable 对象，将计算滚动的块增量值。否则 blockIncrement 与视口的宽度或高度相等。如果无任何视口，则返回 super.getBlockIncrement。

覆盖：
类 JScrollBar 中的 getBlockIncrement
参数：
direction - 小于零表示向上/向左滚动，大于零表示向下/向右滚动
返回：
包含块增量的整数，以像素为单位
另请参见：
Scrollable.getScrollableBlockIncrement(java.awt.Rectangle, int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSeparator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSeparator

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JSeparator
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
直接已知子类：
JPopupMenu.Separator, JToolBar.Separator
public class JSeparator
extends JComponent
implements SwingConstants, Accessible

JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。可以使用 JMenu 或者 JPopupMenu 的 addSeparator 方法来创建和添加一个分隔符，而不是直接使用 JSeparator。JSeparator 还可能用于 GUI 中任何一个需要可视化分隔符的地方。

有关更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Menus 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JSeparator.AccessibleJSeparator
此类实现 JSeparator 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSeparator()
创建一个新的水平分隔符。
JSeparator(int orientation)
创建一个具有指定水平或者垂直方向的分隔符。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JSeparator 相关的 AccessibleContext。
int | getOrientation() 返回此分隔符的方向。
SeparatorUI | getUI() 返回呈现此组件的 L&F 对象。
String | getUIClassID() 返回呈现此组件的 L&F 的类名。
protected String | paramString() 返回表示此 JSeparator 的一个字符串。
void | setOrientation(int orientation) 设置此分隔符的方向。
void | setUI(SeparatorUI ui) 设置呈现此组件的 L&F 对象。
void | updateUI() 根据当前外观将 UI 属性重设成某个值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JSeparator

public JSeparator()
创建一个新的水平分隔符。

JSeparator

public JSeparator(int orientation)
创建一个具有指定水平或者垂直方向的分隔符。

参数：
orientation - 指定 SwingConstants.HORIZONTAL 或 SwingConstants.VERTICAL 的一个整数
抛出：
IllegalArgumentException - 如果 orientation 既不是 SwingConstants.HORIZONTAL 也不是 SwingConstants.VERTICAL
方法详细信息

getUI

public SeparatorUI getUI()
返回呈现此组件的 L&F 对象。

返回：
呈现此组件的 SeparatorUI 对象

setUI

public void setUI(SeparatorUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - SeparatorUI 的 L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
根据当前外观将 UI 属性重设成某个值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 的类名。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串“SeparatorUI”
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getOrientation

public int getOrientation()
返回此分隔符的方向。

返回：
方向属性值，它是 SwingConstants 中定义的如下常量之一：VERTICAL 或 HORIZONTAL。
另请参见：
SwingConstants, setOrientation(int)

setOrientation

public void setOrientation(int orientation)
设置此分隔符的方向。此属性的默认值是 HORIZONTAL。

参数：
orientation - 是 SwingConstants.HORIZONTAL 或 SwingConstants.VERTICAL
抛出：
IllegalArgumentException - 如果 orientation 既不是 SwingConstants.HORIZONTAL 也不是 SwingConstants.VERTICAL
另请参见：
SwingConstants, getOrientation()

paramString

protected String paramString()
返回表示此 JSeparator 的一个字符串。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JSeparator 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JSeparator 相关的 AccessibleContext。对于分隔符，AccessibleContext 采用 AccessibleJSeparator 的形式。必要时创建新的 AccessibleJSeparator 的实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJSeparator，它充当此 JSeparator 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSeparator.AccessibleJSeparator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSeparator.AccessibleJSeparator

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JSeparator.AccessibleJSeparator
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JSeparator
protected class JSeparator.AccessibleJSeparator
extends JComponent.AccessibleJComponent

此类实现 JSeparator 类的可访问性支持。它提供适合分隔符用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JSeparator.AccessibleJSeparator()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JSeparator.AccessibleJSeparator

protected JSeparator.AccessibleJSeparator()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSlider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSlider

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JSlider
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
public class JSlider
extends JComponent
implements SwingConstants, Accessible

一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。

滑块可以显示主刻度标记以及主刻度之间的次刻度标记。刻度标记之间的值的个数由 setMajorTickSpacing 和 setMinorTickSpacing 来控制。刻度标记的绘制由 setPaintTicks 控制。

滑块也可以在固定时间间隔（或在任意位置）沿滑块刻度打印文本标签。标签的绘制由 setLabelTable 和 setPaintLabels 控制。

有关更多信息和示例，请参阅 The Java Tutorial 中的 How to Use Sliders 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JSlider.AccessibleJSlider
此类实现 JSlider 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected ChangeEvent | changeEvent 一个滑块实例仅需要一个 ChangeEvent，因为该事件唯一（只读）的状态是源属性。
protected ChangeListener | changeListener changeListener（无前缀）是添加到滑块模型的侦听器。
protected int | majorTickSpacing 主刻度标记（分解次刻度标记的较大标记）之间的值的个数。
protected int | minorTickSpacing 次刻度标记（出现在主刻度标记之间的较小标记）之间的值的个数。
protected int | orientation 滑块方向是水平还是垂直的。
protected BoundedRangeModel | sliderModel 处理滑块的数字最大值、最小值和当前位置值的数据模型。
protected boolean | snapToTicks 如果为 true，滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSlider()
创建一个范围在 0 到 100 之间并且初始值为 50 的水平滑块。
JSlider(BoundedRangeModel brm)
使用指定的 BoundedRangeModel 创建一个水平滑块。
JSlider(int orientation)
使用指定的方向创建一个滑块，范围在 0 到 100 之间并且初始值为 50。
JSlider(int min, int max)
使用指定的最小值和最大值创建一个水平滑块，初始值等于最小值加上最大值的平均值。
JSlider(int min, int max, int value)
用指定的最小值、最大值和初始值创建一个水平滑块。
JSlider(int orientation, int min, int max, int value)
用指定的方向和指定的最小值、最大值以及初始值创建一个滑块。
方法摘要
 void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到滑块。
protected  ChangeListener createChangeListener()
想要以不同方式处理模型的 ChangeEvent 的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。
 Hashtable createStandardLabels(int increment)
创建一个数字文本标签的 Hashtable，从滑块最小值处开始并使用指定的增量。
 Hashtable createStandardLabels(int increment, int start)
创建一个数字文本标签的 Hashtable，从指定起始点处开始并使用指定的增量。
protected  void fireStateChanged()
将一个其源为此 JSlider 的 ChangeEvent 发送到所有需要 ChangeEvent 的已注册 ChangeListener。
 AccessibleContext getAccessibleContext()
获取与此 JSlider 关联的 AccessibleContext。
 ChangeListener[] getChangeListeners()
返回一个通过 addChangeListener() 方法添加此 JSlider 的所有 ChangeListener 的数组。
 int getExtent()
从 BoundedRangeModel 返回“范围”。
 boolean getInverted()
如果滑块显示的值范围反转，则返回 true。
 Dictionary getLabelTable()
返回哪些标签在哪些值处绘制的字典。
 int getMajorTickSpacing()
此方法返回主刻度标记的间隔。
 int getMaximum()
从 BoundedRangeModel 返回滑块所支持的最大值。
 int getMinimum()
从 BoundedRangeModel 返回滑块所支持的最小值。
 int getMinorTickSpacing()
此方法返回次刻度标记的间隔。
 BoundedRangeModel getModel()
返回处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
 int getOrientation()
返回此滑块的垂直或者水平方向。
 boolean getPaintLabels()
告知是否绘制标签。
 boolean getPaintTicks()
告知是否绘制刻度标记。
 boolean getPaintTrack()
告知是否绘制滑道（滑块滑动的区域）。
 boolean getSnapToTicks()
如果滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值，则返回为 true。
 SliderUI getUI()
获取实现此组件 L&F 的 UI 对象。
 String getUIClassID()
返回呈现此组件的 L&F 的类名。
 int getValue()
从 BoundedRangeModel 返回滑块的当前值。
 boolean getValueIsAdjusting()
从模型返回 valueIsAdjusting 属性。
protected  String paramString()
返回此 JSlider 的字符串表示形式。
 void removeChangeListener(ChangeListener l)
从滑块中移除一个 ChangeListener。
 void setExtent(int extent)
设置滑块所“覆盖”的范围的大小。
 void setFont(Font font)
设置此组件的字体。
 void setInverted(boolean b)
指定为 true，则反转滑块显示的值范围，指定为 false 则将值范围置为正常顺序。
 void setLabelTable(Dictionary labels)
用于指定将在给定值处绘制哪个标签。
 void setMajorTickSpacing(int n)
此方法设置主刻度标记的间隔。
 void setMaximum(int maximum)
将滑块的最大值设置为 maximum。
 void setMinimum(int minimum)
将滑块的最小值设置为 minimum。
 void setMinorTickSpacing(int n)
此方法设置次刻度标记的间隔。
 void setModel(BoundedRangeModel newModel)
设置处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。
 void setOrientation(int orientation)
将滑块的方向设置为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
 void setPaintLabels(boolean b)
确定是否在滑块上绘制标签。
 void setPaintTicks(boolean b)
确定是否在滑块上绘制刻度标记。
 void setPaintTrack(boolean b)
确定是否在滑块上绘制滑道。
 void setSnapToTicks(boolean b)
指定为 true，则滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。
 void setUI(SliderUI ui)
设置实现此组件 L&F 的 UI 对象。
 void setValue(int n)
将滑块的当前值设置为 n。
 void setValueIsAdjusting(boolean b)
设置模型的 valueIsAdjusting 属性。
protected  void updateLabelUIs()
通过在每个标签上调用 updateUI 更新标签表中标签的 UI。
 void updateUI()
根据当前外观将 UI 属性重设为某个值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

sliderModel

protected BoundedRangeModel sliderModel
处理滑块的数字最大值、最小值和当前位置值的数据模型。

majorTickSpacing

protected int majorTickSpacing
主刻度标记（分解次刻度标记的较大标记）之间的值的个数。

minorTickSpacing

protected int minorTickSpacing
次刻度标记（出现在主刻度标记之间的较小标记）之间的值的个数。

另请参见：
setMinorTickSpacing(int)

snapToTicks

protected boolean snapToTicks
如果为 true，滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。默认情况下为 false。

另请参见：
setSnapToTicks(boolean)

orientation

protected int orientation
滑块方向是水平还是垂直的。默认情况下是水平的。

另请参见：
setOrientation(int)

changeListener

protected ChangeListener changeListener
changeListener（无前缀）是添加到滑块模型的侦听器。此侦听器被初始化为从 createChangeListener 返回的 ChangeListener，默认情况下，ChangeListener 仅将事件转发给直接添加到该滑块的 ChangeListener（如果有）。

另请参见：
addChangeListener(javax.swing.event.ChangeListener), createChangeListener()

changeEvent

protected transient ChangeEvent changeEvent
一个滑块实例仅需要一个 ChangeEvent，因为该事件唯一（只读）的状态是源属性。这里生成的事件源总是 "this"。该事件是在第一次触发某个事件通知时以延迟方式创建的。

另请参见：
fireStateChanged()
构造方法详细信息

JSlider

public JSlider()
创建一个范围在 0 到 100 之间并且初始值为 50 的水平滑块。

JSlider

public JSlider(int orientation)
使用指定的方向创建一个滑块，范围在 0 到 100 之间并且初始值为 50。方向可以是 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。

参数：
orientation - 滑块的方向
抛出：
IllegalArgumentException - 如果方向不是 VERTICAL、HORIZONTAL 之一
另请参见：
setOrientation(int)

JSlider

public JSlider(int min,
               int max)
使用指定的最小值和最大值创建一个水平滑块，初始值等于最小值加上最大值的平均值。

保存滑块数据的 BoundedRangeModel 可处理由于在滑块上错误地设置了最小值和最大值而引起的任何问题。有关详细信息，请参阅 BoundedRangeModel 文档。

参数：
min - 滑块的最小值
max - 滑块的最大值
另请参见：
BoundedRangeModel, setMinimum(int), setMaximum(int)

JSlider

public JSlider(int min,
               int max,
               int value)
用指定的最小值、最大值和初始值创建一个水平滑块。

保存滑块数据的 BoundedRangeModel 可处理由于在滑块上错误地设置了最小值、初始值和最大值而引起的任何问题。有关详细信息，请参阅 BoundedRangeModel 文档。

参数：
min - 滑块的最小值
max - 滑块的最大值
value - 滑块的初始值
另请参见：
BoundedRangeModel, setMinimum(int), setMaximum(int), setValue(int)

JSlider

public JSlider(int orientation,
               int min,
               int max,
               int value)
用指定的方向和指定的最小值、最大值以及初始值创建一个滑块。方向可以是 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。

保存滑块数据的 BoundedRangeModel 可处理由于在滑块上错误地设置了最小值、初始值和最大值而引起的任何问题。有关详细信息，请参阅 BoundedRangeModel 文档。

参数：
orientation - 滑块的方向
min - 滑块的最小值
max - 滑块的最大值
value - 滑块的初始值
抛出：
IllegalArgumentException - 如果方向不是 VERTICAL、HORIZONTAL 之一
另请参见：
BoundedRangeModel, setOrientation(int), setMinimum(int), setMaximum(int), setValue(int)

JSlider

public JSlider(BoundedRangeModel brm)
使用指定的 BoundedRangeModel 创建一个水平滑块。

方法详细信息

getUI

public SliderUI getUI()
获取实现此组件 L&F 的 UI 对象。

返回：
实现 Slider L&F 的 SliderUI 对象

setUI

public void setUI(SliderUI ui)
设置实现此组件 L&F 的 UI 对象。

参数：
ui - SliderUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
根据当前外观将 UI 属性重设为某个值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 的类名。

覆盖：
类 JComponent 中的 getUIClassID
返回：
"SliderUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

createChangeListener

protected ChangeListener createChangeListener()
想要以不同方式处理模型的 ChangeEvent 的子类可以重写此方法，以返回自定义 ChangeListener 实现的实例。默认 ChangeListener 调用 fireStateChanged 方法将 ChangeEvent 转发给已直接添加到滑块的 ChangeListener。

另请参见：
changeListener, fireStateChanged(), ChangeListener, BoundedRangeModel

addChangeListener

public void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到滑块。

参数：
l - 要添加的 ChangeListener
另请参见：
fireStateChanged(), removeChangeListener(javax.swing.event.ChangeListener)

removeChangeListener

public void removeChangeListener(ChangeListener l)
从滑块中移除一个 ChangeListener。

参数：
l - 要移除的 ChangeListener
另请参见：
fireStateChanged(), addChangeListener(javax.swing.event.ChangeListener)

getChangeListeners

public ChangeListener[] getChangeListeners()
返回一个通过 addChangeListener() 方法添加此 JSlider 的所有 ChangeListener 的数组。

返回：
所有被添加的 ChangeListener；如果没有添加任何侦听器，则返回空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
将一个其源为此 JSlider 的 ChangeEvent 发送到所有需要 ChangeEvent 的已注册 ChangeListener。每次从模型中收到 ChangeEvent 时都要调用此方法。

必要时创建事件实例，并存储在 changeEvent 中。

另请参见：
addChangeListener(javax.swing.event.ChangeListener), EventListenerList

getModel

public BoundedRangeModel getModel()
返回处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。

返回：
此组件的数据模型
另请参见：
setModel(javax.swing.BoundedRangeModel), BoundedRangeModel

setModel

public void setModel(BoundedRangeModel newModel)
设置处理滑块三个基本属性（minimum、maximum、value）的 BoundedRangeModel。

试图将 null 模型传递给此方法将导致不确定的行为，很有可能是异常。

参数：
newModel - 要使用的新的非 null BoundedRangeModel
另请参见：
getModel(), BoundedRangeModel

getValue

public int getValue()
从 BoundedRangeModel 返回滑块的当前值。

返回：
滑块的当前值
另请参见：
setValue(int), BoundedRangeModel.getValue()

setValue

public void setValue(int n)
将滑块的当前值设置为 n。此方法将新值转发给模型。

数据模型（BoundedRangeModel 实例）处理因赋值不当而引起的所有数学问题。有关详细信息，请参阅 BoundedRangeModel 文档。

如果新值不同于以前的值，则通知所有的更改侦听器。

参数：
n - 新值
另请参见：
getValue(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setValue(int)

getMinimum

public int getMinimum()
从 BoundedRangeModel 返回滑块所支持的最小值。

返回：
模型最小属性的值
另请参见：
setMinimum(int), BoundedRangeModel.getMinimum()

setMinimum

public void setMinimum(int minimum)
将滑块的最小值设置为 minimum。此方法将新的最小值转发给模型。

数据模型（BoundedRangeModel 实例）处理因赋值不当而引起的所有数学问题。有关详细信息，请参阅 BoundedRangeModel 文档。

如果新的最小值不同于以前的最小值，则通知所有的更改侦听器。

参数：
n - 新的最小值
另请参见：
getMinimum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMinimum(int)

getMaximum

public int getMaximum()
从 BoundedRangeModel 返回滑块所支持的最大值。

返回：
模型最大属性的值
另请参见：
setMaximum(int), BoundedRangeModel.getMaximum()

setMaximum

public void setMaximum(int maximum)
将滑块的最大值设置为 maximum。此方法将新的最大值转发给模型。

数据模型（BoundedRangeModel 实例）处理因赋值不当而引起的所有数学问题。有关详细信息，请参阅 BoundedRangeModel 文档。

如果新的最大值不同于以前的最大值，则通知所有的更改侦听器。

参数：
n - 新的最大值
另请参见：
getMaximum(),
addChangeListener(javax.swing.event.ChangeListener),
BoundedRangeModel.setMaximum(int)

getValueIsAdjusting

public boolean getValueIsAdjusting()
从模型返回 valueIsAdjusting 属性。有关如何使用此方法的详细信息，请参阅 setValueIsAdjusting 文档。

返回：
模型的 valueIsAdjusting 属性的值
另请参见：
setValueIsAdjusting(boolean)

setValueIsAdjusting

public void setValueIsAdjusting(boolean b)
设置模型的 valueIsAdjusting 属性。滑块的外观实现应该在开始拖动滑块时将此属性设置为 true，并在拖动结束时设为 false。当 valueIsAdjusting 为 true 时，滑块模型不会产生 ChangeEvent。

参数：
b - valueIsAdjusting 属性的新值
另请参见：
getValueIsAdjusting(), BoundedRangeModel.setValueIsAdjusting(boolean)

getExtent

public int getExtent()
从 BoundedRangeModel 返回“范围”。此范围表示滑块所“覆盖”的范围。

返回：
表示范围的一个整数
另请参见：
setExtent(int), BoundedRangeModel.getExtent()

setExtent

public void setExtent(int extent)
设置滑块所“覆盖”的范围的大小。如果用户单击滑块的任何一侧，大多数的外观实现将根据此数量而更改值。此方法仅将新的范围值转发给模型。

数据模型（BoundedRangeModel 实例）处理因赋值不当而引起的所有数学问题。有关详细信息，请参阅 BoundedRangeModel 文档。

如果新的范围值不同于以前的范围值，则通知所有的更改侦听器。

参数：
extent - 新的范围值
另请参见：
getExtent(), BoundedRangeModel.setExtent(int)

getOrientation

public int getOrientation()
返回此滑块的垂直或者水平方向。

返回：
SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
另请参见：
setOrientation(int)

setOrientation

public void setOrientation(int orientation)
将滑块的方向设置为 SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。

参数：
orientation - HORIZONTAL 或 VERTICAL
抛出：
IllegalArgumentException - 如果方向不是 VERTICAL、HORIZONTAL 之一
另请参见：
getOrientation()

setFont

public void setFont(Font font)
设置此组件的字体。

覆盖：
类 JComponent 中的 setFont
参数：
font - 此组件所需的 Font
从以下版本开始：
1.6
另请参见：
Component.getFont()

getLabelTable

public Dictionary getLabelTable()
返回哪些标签在哪些值处绘制的字典。

返回：
包含标签及其绘制位置的 Dictionary

setLabelTable

public void setLabelTable(Dictionary labels)
用于指定将在给定值处绘制哪个标签。键-值对有如下格式：{ Integer value, java.swing.JComponent label }。

生成值标签标准表的一个便捷方式是通过使用 createStandardLabels 方法。

只要已经设置了该标签，此方法就调用 updateLabelUIs()。注意，只有 paintLabels 属性为 true 时才绘制该标签。

参数：
labels - 标签的新 Dictionary，为 null 表示移除所有标签
另请参见：
createStandardLabels(int), getLabelTable(), setPaintLabels(boolean)

updateLabelUIs

protected void updateLabelUIs()
通过在每个标签上调用 updateUI 更新标签表中标签的 UI。根据当前外观更新 UI。标签也将设置为其首选大小。

另请参见：
setLabelTable(java.util.Dictionary), JComponent.updateUI()

createStandardLabels

public Hashtable createStandardLabels(int increment)
创建一个数字文本标签的 Hashtable，从滑块最小值处开始并使用指定的增量。例如，如果调用 createStandardLabels( 10 ) 并且滑块的最小值为 0，那么创建的标签值将为 0、10、20、30，依此类推。

对于要在滑块上绘制的标签，返回的 Hashtable 必须传递到 setLabelTable 并且 setPaintLabels 必须被设置为 true。

有关返回的 Hashtable 组成的更多信息，请参阅 setLabelTable 文档。

参数：
increment - 生成的哈希表中标签之间的距离
返回：
标签的新 Hashtable
抛出：
IllegalArgumentException - 如果 increment 小于等于 0
另请参见：
setLabelTable(java.util.Dictionary), setPaintLabels(boolean)

createStandardLabels

public Hashtable createStandardLabels(int increment,
                                      int start)
创建一个数字文本标签的 Hashtable，从指定起始点处开始并使用指定的增量。例如，如果调用 createStandardLabels( 10, 2 )，那么创建的标签值将为 2、12、22、32，依此类推。

对于要在滑块上绘制的标签，返回的 Hashtable 必须传递到 setLabelTable 并且 setPaintLabels 必须设置为 true。

有关返回的 Hashtable 组成的更多信息，请参阅 setLabelTable 文档。

参数：
increment - 生成的哈希表中标签之间的距离
start - 标签的开始值
返回：
标签的新 Hashtable
抛出：
IllegalArgumentException - 如果 start 超出范围，或者 increment 小于等于 0
另请参见：
setLabelTable(java.util.Dictionary), setPaintLabels(boolean)

getInverted

public boolean getInverted()
如果滑块显示的值范围反转，则返回 true。

返回：
如果滑块值相对其正常顺序是反转的，则返回 true
另请参见：
setInverted(boolean)

setInverted

public void setInverted(boolean b)
指定为 true，则反转滑块显示的值范围，指定为 false 则将值范围置为正常顺序。此顺序取决于滑块的 ComponentOrientation 属性。ComponentOrientation 值为 LEFT_TO_RIGHT 的正常（非反转）水平滑块最大值位于右边。ComponentOrientation 值为 RIGHT_TO_LEFT 的正常水平滑块最大值位于左边。正常的垂直滑块其最大值位于顶部。当滑块颠倒时，这些标签也反转。

默认情况下，此属性的值为 false。

参数：
b - 为 true 时从滑块正常顺序反转滑块值

getMajorTickSpacing

public int getMajorTickSpacing()
此方法返回主刻度标记的间隔。返回的数字表示在每个主刻度标记之间以值衡量的距离。如果您有一个范围从 0 到 50 的滑块并且主刻度标记间隔为 10，则您会发现主刻度标记在如下值旁边：0、10、20、30、40、50。

返回：
主刻度标记之间的值的个数
另请参见：
setMajorTickSpacing(int)

setMajorTickSpacing

public void setMajorTickSpacing(int n)
此方法设置主刻度标记的间隔。传入的数字表示在每个主刻度标记之间以值衡量的距离。如果您有一个范围从 0 到 50 的滑块并且主刻度标记间隔为 10，则您会发现主刻度标记在如下值旁边：0、10、20、30、40、50。

要绘制主刻度，setPaintTicks 必须设置为 true。

此方法也将为您设置一个标签表。如果还没有标签表，并且主刻度间隔为 > 0，并且 getPaintLabels 返回 true，则会生成一个在主刻度标记处带有标签的标准标签表（通过调用 createStandardLabels）。对于上述示例，将获取文本标签："0"、"10"、"20"、"30"、"40"、"50"。然后通过调用 setLabelTable 在滑块上设置标签表。

参数：
n - majorTickSpacing 属性的新值
另请参见：
getMajorTickSpacing(), setPaintTicks(boolean), setLabelTable(java.util.Dictionary), createStandardLabels(int)

getMinorTickSpacing

public int getMinorTickSpacing()
此方法返回次刻度标记的间隔。返回的数字表示在每个次刻度标记之间以值衡量的距离。如果您有一个范围从 0 到 50 的滑块并且次刻度标记间隔为 10，则您会发现次刻度标记在如下值旁边：0、10、20、30、40、50。

返回：
次刻度标记之间的值的个数
另请参见：
getMinorTickSpacing()

setMinorTickSpacing

public void setMinorTickSpacing(int n)
此方法设置次刻度标记的间隔。传入的数字表示在每个次刻度标记之间以值衡量的距离。如果您有一个范围从 0 到 50 的滑块并且次刻度标记间隔为 10，则您会发现次刻度标记在如下值旁边：0、10、20、30、40、50。

要绘制次刻度，setPaintTicks 必须设置为 true。

参数：
n - minorTickSpacing 属性的新值
另请参见：
getMinorTickSpacing(), setPaintTicks(boolean)

getSnapToTicks

public boolean getSnapToTicks()
如果滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值，则返回为 true。

返回：
如果值对齐最近的刻度标记，则返回 true；否则返回 false
另请参见：
setSnapToTicks(boolean)

setSnapToTicks

public void setSnapToTicks(boolean b)
指定为 true，则滑块（及其所表示的值）解析为最靠近用户放置滑块处的刻度标记的值。默认情况下，此属性为 false。

参数：
b - 为 true 则对齐滑块到最近的刻度标记
另请参见：
getSnapToTicks()

getPaintTicks

public boolean getPaintTicks()
告知是否绘制刻度标记。

返回：
如果绘制刻度标记，则返回 true；否则返回 false
另请参见：
setPaintTicks(boolean)

setPaintTicks

public void setPaintTicks(boolean b)
确定是否在滑块上绘制刻度标记。默认情况下，此属性为 false。

参数：
b - 是否应该绘制标记刻度
另请参见：
getPaintTicks()

getPaintTrack

public boolean getPaintTrack()
告知是否绘制滑道（滑块滑动的区域）。

返回：
如果绘制滑道，则返回 true；否则返回 false
另请参见：
setPaintTrack(boolean)

setPaintTrack

public void setPaintTrack(boolean b)
确定是否在滑块上绘制滑道。默认情况下，此属性为 true。

参数：
b - 是否绘制滑道
另请参见：
getPaintTrack()

getPaintLabels

public boolean getPaintLabels()
告知是否绘制标签。

返回：
如果绘制标签，则返回 true；否则返回 false
另请参见：
setPaintLabels(boolean)

setPaintLabels

public void setPaintLabels(boolean b)
确定是否在滑块上绘制标签。

此方法也将为您设置一个标签表。如果还没有标签表，并且主刻度间隔为 > 0，则会生成一个在主刻度标记处带有标签的标准标签表（通过调用 createStandardLabels）。然后通过调用 setLabelTable 在滑块上设置标签表。

默认情况下，此属性为 false。

参数：
b - 是否绘制标签
另请参见：
getPaintLabels(),
getLabelTable(),
createStandardLabels(int)

paramString

protected String paramString()
返回此 JSlider 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回字符串可以为空，但不可以为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JSlider 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JSlider 关联的 AccessibleContext。对于滑块，AccessibleContext 采取 AccessibleJSlider 的形式。必要时创建新的 AccessibleJSlider 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJSlider，它充当此 JSlider 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSlider.AccessibleJSlider (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSlider.AccessibleJSlider

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JSlider.AccessibleJSlider
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
正在封闭类：
JSlider
protected class JSlider.AccessibleJSlider
extends JComponent.AccessibleJComponent
implements AccessibleValue

此类实现 JSlider 类的可访问性支持。它提供适合滑块用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行同一版本 Swing 的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JSlider.AccessibleJSlider()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的可访问值。
Number | getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | getMinimumAccessibleValue() 获取此对象的最小可访问值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为数字。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JSlider.AccessibleJSlider

protected JSlider.AccessibleJSlider()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态集。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其本身实现 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的可访问值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
此对象的当前值。
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为数字。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 True。
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小可访问值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
此对象的最小值。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大可访问值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
此对象的最大值。
另请参见：
AccessibleValue.getMinimumAccessibleValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSpinner (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSpinner

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JSpinner
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JSpinner
extends JComponent
implements Accessible

让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。Spinner 通常提供一对带小箭头的按钮以便逐步遍历序列元素。键盘的向上/向下方向键也可循环遍历元素。也允许用户在 spinner 中直接输入合法值。尽管组合框提供了相似的功能，但因为 spinner 不要求可隐藏重要数据的下拉列表，所以有时它也成为首要选择。

JSpinner 序列的值由其 SpinnerModel 定义。此 model 可指定为构造方法的参数，并且可通过 model 属性进行更改。提供了针对某些常见类型的 SpinnerModel 类：SpinnerListModel、SpinnerNumberModel 和 SpinnerDateModel。

JSpinner 具有一个负责显示和潜在地更改当前元素或者模型 value 的惟一子组件，被称为 editor。此编辑器由 JSpinner 的构造方法创建，并且可通过 editor 属性进行更改。JSpinner 的编辑器通过侦听 ChangeEvent 而与模型保持同步。如果用户更改了 editor 所显示的值，则有可能 model 的值与 editor 的值不一样。为保证 model 与编辑器具有相同的值，请使用 commitEdit 方法，例如：

   try {
       spinner.commitEdit();
   }
   catch (ParseException pe) {{
       // Edited value is invalid, spinner.getValue() will return
       // the last valid value, you could revert the spinner to show that:
       JComponent editor = spinner.getEditor()
       if (editor instanceof DefaultEditor) {
           ((DefaultEditor)editor).getTextField().setValue(spinner.getValue();
       }
       // reset the value to some known value:
       spinner.setValue(fallbackValue);
       // or treat the last valid value as the current, in which
       // case you don't need to do anything.
   }
   return spinner.getValue();

有关使用微调器的信息和示例，请参阅 The Java Tutorial 中的 How to Use Spinners 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4
另请参见：
SpinnerModel, AbstractSpinnerModel, SpinnerListModel, SpinnerNumberModel, SpinnerDateModel, JFormattedTextField

嵌套类摘要
protected class | JSpinner.AccessibleJSpinner AccessibleJSpinner 实现 JSpinner 类的可访问性支持。
static class | JSpinner.DateEditor 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
static class | JSpinner.DefaultEditor 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
static class | JSpinner.ListEditor 其模型为 SpinnerListModel 的 JSpinner 编辑器。
static class | JSpinner.NumberEditor 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSpinner()
构造一个 spinner，使其具有初始值为 0 并且无任何最小值或者最大值限制的 Integer SpinnerNumberModel。
JSpinner(SpinnerModel model)
构造具有一对 next/previous 按钮和 SpinnerModel 编辑器的完整 spinner。
方法摘要
 void addChangeListener(ChangeListener listener)
为每次发生模型更改时要通知的列表添加侦听器。
 void commitEdit()
将当前编辑的值提交给 SpinnerModel。
protected  JComponent createEditor(SpinnerModel model)
此方法由构造方法调用，以创建显示序列当前值的 JComponent。
protected  void fireStateChanged()
将一个其源为此 JSpinner 的 ChangeEvent 发送到每个 ChangeListener。
 AccessibleContext getAccessibleContext()
获取此 JSpinner 的 AccessibleContext
 ChangeListener[] getChangeListeners()
返回一个通过 addChangeListener() 方法添加到此 JSpinner 的所有 ChangeListener 的数组。
 JComponent getEditor()
返回显示和潜在更改模型值的组件。
 SpinnerModel getModel()
返回定义此 spinner 值序列的 SpinnerModel。
 Object getNextValue()
返回序列中由 getValue() 所返回的对象之后的对象。
 Object getPreviousValue()
返回序列中由 getValue() 所返回对象之前的对象。
 SpinnerUI getUI()
返回呈现此组件的外观 (L&F) 对象。
 String getUIClassID()
返回用于构造呈现此组件外观 (L&F) 类的名称的后缀。
 Object getValue()
返回模型的当前值，通常此值是 editor 所显示的值。
 void removeChangeListener(ChangeListener listener)
从此 spinne 中移除 ChangeListener。
 void setEditor(JComponent editor)
更改显示 SpinnerModel 当前值的 JComponent。
 void setModel(SpinnerModel model)
更改表示此 spinner 值的模型。
 void setUI(SpinnerUI ui)
设置呈现此组件的外观 (L&F) 对象。
 void setValue(Object value)
更改模型的当前值，通常此值是 editor 所显示的值。
 void updateUI()
用取自当前外观的值重设 UI 属性。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, paramString, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JSpinner

public JSpinner(SpinnerModel model)
构造具有一对 next/previous 按钮和 SpinnerModel 编辑器的完整 spinner。

JSpinner

public JSpinner()
构造一个 spinner，使其具有初始值为 0 并且无任何最小值或者最大值限制的 Integer SpinnerNumberModel。

方法详细信息

getUI

public SpinnerUI getUI()
返回呈现此组件的外观 (L&F) 对象。

返回：
呈现此组件的 SpinnerUI 对象

setUI

public void setUI(SpinnerUI ui)
设置呈现此组件的外观 (L&F) 对象。

参数：
ui - SpinnerUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getUIClassID

public String getUIClassID()
返回用于构造呈现此组件外观 (L&F) 类的名称的后缀。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "SpinnerUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
用取自当前外观的值重设 UI 属性。

覆盖：
类 JComponent 中的 updateUI
另请参见：
UIManager.getUI(javax.swing.JComponent)

createEditor

protected JComponent createEditor(SpinnerModel model)
此方法由构造方法调用，以创建显示序列当前值的 JComponent。编辑器也可能允许用户直接输入序列中的元素。编辑器必须侦听 model 上的 ChangeEvents，并且让显示的值与模型的值保持同步。

子类可能重写此方法以便添加对新 SpinnerModel 类的支持。作为一种选择，用户可只替换此处使用 setEditor 方法创建的编辑器。从模型类型到编辑器的默认映射是：

  • SpinnerNumberModel => JSpinner.NumberEditor
  • SpinnerDateModel => JSpinner.DateEditor
  • SpinnerListModel => JSpinner.ListEditor
  • all others => JSpinner.DefaultEditor

参数：
model - getModel 的值
返回：
显示序列当前值的组件
另请参见：
getModel(), setEditor(javax.swing.JComponent)

setModel

public void setModel(SpinnerModel model)
更改表示此 spinner 值的模型。如果没有显式地设置编辑器属性，将在调用 "model" 的 PropertyChangeEvent 后（隐式地）设置编辑器属性。编辑器属性设置为 createEditor 所返回的值，如：
 setEditor(createEditor(model));

参数：
model - 新的 SpinnerModel
抛出：
IllegalArgumentException - 如果 model 为 null
另请参见：
getModel(),
getEditor(),
setEditor(javax.swing.JComponent)

getModel

public SpinnerModel getModel()
返回定义此 spinner 值序列的 SpinnerModel。

返回：
模型属性的值
另请参见：
setModel(javax.swing.SpinnerModel)

getValue

public Object getValue()
返回模型的当前值，通常此值是 editor 所显示的值。如果用户已更改 editor 所显示的值，则 model 的值可能与 editor 的值不一样，关于如何处理这种情况的示例，请参阅类级别 javadoc。

此方法只委托给 model。它等效于：

 getModel().getValue()

另请参见：
setValue(java.lang.Object), SpinnerModel.getValue()

setValue

public void setValue(Object value)
更改模型的当前值，通常此值是 editor 所显示的值。如果 SpinnerModel 的实现不支持指定的值，则抛出 IllegalArgumentException。

此方法只委托给 model。它等效于：

 getModel().setValue(value)

抛出：
IllegalArgumentException - 如果不允许为 value
另请参见：
getValue(), SpinnerModel.setValue(java.lang.Object)

getNextValue

public Object getNextValue()
返回序列中由 getValue() 所返回的对象之后的对象。如果已达到序列结尾，则返回 null。调用此方法不影响 value。

此方法只委托给 model。它等效于：

 getModel().getNextValue()

返回：
下一个有效值，如果不存在，则返回 null
另请参见：
getValue(),
getPreviousValue(),
SpinnerModel.getNextValue()

addChangeListener

public void addChangeListener(ChangeListener listener)
为每次发生模型更改时要通知的列表添加侦听器。传递到 ChangeListeners 的 ChangeEvents 源将是此 JSpinner。还要注意到替换模型将不会影响直接添加到 JSpinner 的侦听器。应用程序可以直接向模型添加侦听器。在这种情况下，事件源将是 SpinnerModel。

参数：
listener - 要添加的 ChangeListener
另请参见：
removeChangeListener(javax.swing.event.ChangeListener), getModel()

removeChangeListener

public void removeChangeListener(ChangeListener listener)
从此 spinne 中移除 ChangeListener。

参数：
listener - 要移除的 ChangeListener
另请参见：
fireStateChanged(), addChangeListener(javax.swing.event.ChangeListener)

getChangeListeners

public ChangeListener[] getChangeListeners()
返回一个通过 addChangeListener() 方法添加到此 JSpinner 的所有 ChangeListener 的数组。

返回：
所有被添加的 ChangeListener，如果没有添加任何侦听器，则返回空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
将一个其源为此 JSpinner 的 ChangeEvent 发送到每个 ChangeListener。当向此 spinner 添加一个 ChangeListener 时，则每一次从模型接收到 ChangeEvent 都会调用此方法。

另请参见：
addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener), EventListenerList

getPreviousValue

public Object getPreviousValue()
返回序列中由 getValue() 所返回对象之前的对象。如果已达到序列末尾，则返回 null。调用此方法不影响 value。

此方法只委托给 model。它等效于：

 getModel().getPreviousValue()

返回：
前一个有效值；如果不存在有效值，则返回 null
另请参见：
getValue(),
getNextValue(),
SpinnerModel.getPreviousValue()

setEditor

public void setEditor(JComponent editor)
更改显示 SpinnerModel 当前值的 JComponent。此方法负责将原编辑器从模型断开 并连接新的编辑器。这可能意味着将从模型中或者 spinner 本身移除原编辑器的 ChangeListener，并为新编辑器添加一个侦听器。

参数：
editor - 新编辑器
抛出：
IllegalArgumentException - 如果编辑器为 null
另请参见：
getEditor(),
createEditor(javax.swing.SpinnerModel),
getModel()

getEditor

public JComponent getEditor()
返回显示和潜在更改模型值的组件。

返回：
显示和潜在更改模型值的组件
另请参见：
setEditor(javax.swing.JComponent), createEditor(javax.swing.SpinnerModel)

commitEdit

public void commitEdit()
                throws ParseException
将当前编辑的值提交给 SpinnerModel。

如果此编辑器是 DefaultEditor 的一个实例，调用会转发给编辑器；否则不执行任何操作。

抛出：
ParseException - 如果当前编辑的值不能提交。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取此 JSpinner 的 AccessibleContext

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
此 JSpinner 的 AccessibleContext
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSpinner.AccessibleJSpinner (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSpinner.AccessibleJSpinner

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JSpinner.AccessibleJSpinner
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleText, AccessibleValue, ChangeListener
正在封闭类：
JSpinner
protected class JSpinner.AccessibleJSpinner
extends JComponent.AccessibleJComponent
implements AccessibleValue, AccessibleAction, AccessibleText, AccessibleEditableText, ChangeListener

AccessibleJSpinner 实现 JSpinner 类的可访问性支持。

从以下版本开始：
1.5

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected JSpinner.AccessibleJSpinner()
AccessibleJSpinner 构造方法
方法摘要
void | cut(int startIndex, int endIndex) 将两个索引之间的文本剪切到系统剪贴板中。
void | delete(int startIndex, int endIndex) 删除两个索引之间的文本
boolean | doAccessibleAction(int i) 对该对象执行指定的操作
AccessibleAction | getAccessibleAction() 获取与此对象关联的可支持一个或多个操作的 AccessibleAction。
int | getAccessibleActionCount() 返回此对象中可访问的操作数，如果多于一个，则第一个就被认为是此对象的“默认”操作。
String | getAccessibleActionDescription(int i) 返回此对象指定操作的描述。
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回对象的可访问子级数。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleText | getAccessibleText() 获取与此对象相关联的可在显示器上表示的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
String | getAfterIndex(int part, int index) 返回给定索引后的 String。
String | getAtIndex(int part, int index) 返回给定索引处的 String。
String | getBeforeIndex(int part, int index) 返回给定索引前的 String。
int | getCaretPosition() 返回从 0 开始的插入符号偏移量。
AttributeSet | getCharacterAttribute(int i) 返回给定索引处给定字符的 AttributeSet
Rectangle | getCharacterBounds(int i) 确定给定字符串索引处字符的边界。
int | getCharCount() 返回字符（有效索引）数。
Number | getCurrentAccessibleValue() 获取此对象数字形式的值。
int | getIndexAtPoint(Point p) 以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。
Number | getMaximumAccessibleValue() 获取此对象数字形式的最大值。
Number | getMinimumAccessibleValue() 获取此对象数字形式的最小值。
String | getSelectedText() 返回选中的部分文本。
int | getSelectionEnd() 返回选定文本中的结尾偏移量。
int | getSelectionStart() 返回选定文本中的开始偏移量。
String | getTextRange(int startIndex, int endIndex) 返回两个索引之间的文本字符串。
void | insertTextAtIndex(int index, String s) 在给定索引处插入指定的字符串。
void | paste(int startIndex) 将系统剪贴板中的文本粘贴到指定文本的文件开始处。
void | replaceText(int startIndex, int endIndex, String s) 用指定的字符串替换两个索引之间的文本。
void | selectText(int startIndex, int endIndex) 选中两个索引之间的文本
void | setAttributes(int startIndex, int endIndex, AttributeSet as) 设置两个索引之间文本的属性。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为数字。
void | setTextContents(String s) 将文本内容设置为指定字符串。
void | stateChanged(ChangeEvent e) 侦听器的目标已更改其状态时调用。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JSpinner.AccessibleJSpinner

protected JSpinner.AccessibleJSpinner()
AccessibleJSpinner 构造方法

方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - 一个 ChangeEvent 对象。不能为 null。
抛出：
NullPointerException - 如果参数为 null。

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。对象的职责是此对象的类的一般用途或用法。例如，按钮的职责是 AccessibleRole.PUSH_BUTTON。AccessibleRole 中提供了一些职责，组件开发人员可以在一组预定义职责中选择。这就使辅助技术能为各种交互的组件子类（例如，对所有充当按钮的组件使用 AccessibleRole.PUSH_BUTTON）以及区分行为各异的子类（例如，复选框 AccessibleRole.CHECK_BOX 和单选框 AccessibleRole.RADIO_BUTTON）提供一致的接口。

注意 AccessibleRole 类也是可扩展的，因此如果预定义的职责集合不充分时，自定义组件的开发人员可以定义其自己的 AccessibleRole。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象的可访问子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子级。Accessible 对象的 Accessible 子级是从 0 开始的，因此 Accessible 第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 子级从 0 开始的索引
返回：
对象的 Accessible 子级
另请参见：
getAccessibleChildrenCount()

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的可支持一个或多个操作的 AccessibleAction。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
如果受对象支持，则返回 AccessibleAction；否则返回 null
另请参见：
AccessibleAction

getAccessibleText

public AccessibleText getAccessibleText()
获取与此对象相关联的可在显示器上表示的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
如果受对象支持，则返回 AccessibleValue；否则返回 null
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象数字形式的值。如果没有设置值，则返回值为 null。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
对象的值
另请参见：
setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为数字。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
参数：
n - 要设置此对象的值
返回：
如果设置了值，则返回 true；否则返回 False
另请参见：
getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象数字形式的最小值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
对象的最小值，如果此对象没有最小值，则返回 null
另请参见：
getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象数字形式的最大值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
对象的最大值，如果此对象没有最大值，则返回 null
另请参见：
getMinimumAccessibleValue()

getAccessibleActionCount

public int getAccessibleActionCount()
返回此对象中可访问的操作数，如果多于一个，则第一个就被认为是此对象的“默认”操作。 支持两个操作：增加 spinner 值的 AccessibleAction.INCREMENT 和减少 spinner 值的 AccessibleAction.DECREMENT。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中从 0 开始的 Action 数

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回此对象指定操作的描述。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 从 0 开始的操作索引
返回：
操作的字符串描述
另请参见：
getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
对该对象执行指定的操作

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 从 0 开始的操作索引。第一个操作（索引为 0）是 AccessibleAction.INCREMENT 并且第二个操作（索引为 1）是 AccessibleAction.DECREMENT。
返回：
如果执行操作则返回 true；否则返回 false。
另请参见：
getAccessibleActionCount()

getIndexAtPoint

public int getIndexAtPoint(Point p)
以本地坐标给定一个点，返回在该点处字符从 0 开始的索引。如果该点无效，则此方法返回 -1。

指定者：
接口 AccessibleText 中的 getIndexAtPoint
参数：
p - 本地坐标中的点
返回：
点 p 处字符从 0 开始的索引，如果该点无效则返回 -1。

getCharacterBounds

public Rectangle getCharacterBounds(int i)
确定给定字符串索引处字符的边界。以本地坐标形式返回边界框。如果索引无效，则返回一个空的矩形。

指定者：
接口 AccessibleText 中的 getCharacterBounds
参数：
i - 对 String 的索引
返回：
字符边界框的屏幕坐标，如果索引无效，则返回一个空矩形。

getCharCount

public int getCharCount()
返回字符（有效索引）数。

指定者：
接口 AccessibleText 中的 getCharCount
返回：
字符数

getCaretPosition

public int getCaretPosition()
返回从 0 开始的插入符号偏移量。 注：这表示插入符号的右边与偏移量（插入符号在两个字符之间）有相同的索引值。

指定者：
接口 AccessibleText 中的 getCaretPosition
返回：
从 0 开始的插入符号偏移量。

getAtIndex

public String getAtIndex(int part,
                         int index)
返回给定索引处的 String。

指定者：
接口 AccessibleText 中的 getAtIndex
参数：
part - 要检索的 CHARACTER、WORD 或 SENTENCE
index - 文本中的一个索引
返回：
字母、单词或句子

getAfterIndex

public String getAfterIndex(int part,
                            int index)
返回给定索引后的 String。

指定者：
接口 AccessibleText 中的 getAfterIndex
参数：
part - 要检索的 CHARACTER、WORD 或 SENTENCE
index - 文本中的一个索引
返回：
字母、单词或句子

getBeforeIndex

public String getBeforeIndex(int part,
                             int index)
返回给定索引前的 String。

指定者：
接口 AccessibleText 中的 getBeforeIndex
参数：
part - 要检索的 CHARACTER、WORD 或 SENTENCE
index - 文本中的一个索引
返回：
字母、单词或句子

getCharacterAttribute

public AttributeSet getCharacterAttribute(int i)
返回给定索引处给定字符的 AttributeSet

指定者：
接口 AccessibleText 中的 getCharacterAttribute
参数：
i - 从 0 开始的文本索引
返回：
字符的 AttributeSet

getSelectionStart

public int getSelectionStart()
返回选定文本中的开始偏移量。如果没有选项，但有一个插入符号，则开始和结尾偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionStart
返回：
选择开始处对文本的索引

getSelectionEnd

public int getSelectionEnd()
返回选定文本中的结尾偏移量。如果没有选项，但有一个插入符号，则开始和结尾偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionEnd
返回：
选择结尾处对文本的索引

getSelectedText

public String getSelectedText()
返回选中的部分文本。

指定者：
接口 AccessibleText 中的 getSelectedText
返回：
选中文本的 String 部分。

setTextContents

public void setTextContents(String s)
将文本内容设置为指定字符串。

指定者：
接口 AccessibleEditableText 中的 setTextContents
参数：
s - 要设置文本内容的字符串

insertTextAtIndex

public void insertTextAtIndex(int index,
                              String s)
在给定索引处插入指定的字符串。

指定者：
接口 AccessibleEditableText 中的 insertTextAtIndex
参数：
index - 将要插入字符串处的文本索引
s - 要插入文本中的字符串

getTextRange

public String getTextRange(int startIndex,
                           int endIndex)
返回两个索引之间的文本字符串。

指定者：
接口 AccessibleEditableText 中的 getTextRange
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
返回：
两个索引之间的文本字符串

delete

public void delete(int startIndex,
                   int endIndex)
删除两个索引之间的文本

指定者：
接口 AccessibleEditableText 中的 delete
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引

cut

public void cut(int startIndex,
                int endIndex)
将两个索引之间的文本剪切到系统剪贴板中。

指定者：
接口 AccessibleEditableText 中的 cut
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引

paste

public void paste(int startIndex)
将系统剪贴板中的文本粘贴到指定文本的文件开始处。

指定者：
接口 AccessibleEditableText 中的 paste
参数：
startIndex - 文本中的开始索引

replaceText

public void replaceText(int startIndex,
                        int endIndex,
                        String s)
用指定的字符串替换两个索引之间的文本。

指定者：
接口 AccessibleEditableText 中的 replaceText
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引

selectText

public void selectText(int startIndex,
                       int endIndex)
选中两个索引之间的文本

指定者：
接口 AccessibleEditableText 中的 selectText
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引

setAttributes

public void setAttributes(int startIndex,
                          int endIndex,
                          AttributeSet as)
设置两个索引之间文本的属性。

指定者：
接口 AccessibleEditableText 中的 setAttributes
参数：
startIndex - 文本中的开始索引
endIndex - 文本中的结尾索引
as - 属性集
另请参见：
AttributeSet
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSpinner.DateEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSpinner.DateEditor

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPanel
                    继承者  javax.swing.JSpinner.DefaultEditor
                        继承者  javax.swing.JSpinner.DateEditor
所有已实现的接口：
ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
正在封闭类：
JSpinner
public static class JSpinner.DateEditor
extends JSpinner.DefaultEditor

其模型为 SpinnerDateModel 的 JSpinner 编辑器。该编辑器的值由一个 JFormattedTextField 显示，后者的格式由 minimum 和 maximum 属性映射到 SpinnerDateModel 的 DateFormatter 实例定义。

从以下版本开始：
1.4

嵌套类摘要
从类 javax.swing.JPanel 继承的嵌套类/接口
JPanel.AccessibleJPanel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSpinner.DateEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
JSpinner.DateEditor(JSpinner spinner, String dateFormatPattern)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。
方法摘要
SimpleDateFormat | getFormat() 返回 JFormattedTextField 用于分析和格式化数字的 java.text.SimpleDateFormat 对象。
SpinnerDateModel | getModel() 返回微调器祖先的 SpinnerDateModel。
从类 javax.swing.JSpinner.DefaultEditor 继承的方法
addLayoutComponent, commitEdit, dismiss, getBaseline, getBaselineResizeBehavior, getSpinner, getTextField, layoutContainer, minimumLayoutSize, preferredLayoutSize, propertyChange, removeLayoutComponent, stateChanged
从类 javax.swing.JPanel 继承的方法
getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JSpinner.DateEditor

public JSpinner.DateEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。此 DateEditor 既可以成为微调器模型的 ChangeListener，又可以成为新的 JF\ormattedTextField 的 PropertyChangeListener。

参数：
spinner - 此编辑器将要监视其模型的微调器
抛出：
IllegalArgumentException - 如果微调器模型不是 SpinnerDateModel 的实例
另请参见：
getModel(), getFormat(), SpinnerDateModel

JSpinner.DateEditor

public JSpinner.DateEditor(JSpinner spinner,
                           String dateFormatPattern)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerDateModel 值的显示和编辑。此 DateEditor 既可以成为微调器的 ChangeListener，又可以成为新的 JFormattedTextField 的 PropertyChangeListener。

参数：
spinner - 此编辑器将要监视其模型的微调器
dateFormatPattern - 用于显示和分析文本字段值的 SimpleDateFormat 对象的初始模式。
抛出：
IllegalArgumentException - 如果微调器模型不是 SpinnerDateModel 的实例
另请参见：
getModel(), getFormat(), SpinnerDateModel, SimpleDateFormat
方法详细信息

getFormat

public SimpleDateFormat getFormat()
返回 JFormattedTextField 用于分析和格式化数字的 java.text.SimpleDateFormat 对象。

返回：
getTextField().getFormatter().getFormat() 的值。
另请参见：
JSpinner.DefaultEditor.getTextField(), SimpleDateFormat

getModel

public SpinnerDateModel getModel()
返回微调器祖先的 SpinnerDateModel。

返回：
getSpinner().getModel()
另请参见：
JSpinner.DefaultEditor.getSpinner(), JSpinner.DefaultEditor.getTextField()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSpinner.DefaultEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSpinner.DefaultEditor

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPanel
                    继承者  javax.swing.JSpinner.DefaultEditor
所有已实现的接口：
ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
直接已知子类：
JSpinner.DateEditor, JSpinner.ListEditor, JSpinner.NumberEditor
正在封闭类：
JSpinner
public static class JSpinner.DefaultEditor
extends JPanel
implements ChangeListener, PropertyChangeListener, LayoutManager

一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。子类可以配置 JFormattedTextField 以创建适合其支持的模型类型的编辑器，并且子类可能需要重写保持模型和文本字段同步的 stateChanged 和 propertyChanged 方法。

此类定义了一个 dismiss 方法，可从 JSpinner 移除作为其一部分的编辑器 ChangeListener。setEditor 方法知道 DefaultEditor.dismiss，因此如果开发人员替换了一个从 JSpinner.DefaultEditor 派生的编辑器，将会移除返回 JSpinner 的 ChangeListener 连接。尽管如此，也会等到开发者管理其编辑器侦听器才移除。类似地，如果一个子类重写了 createEditor，子类也会等到处理了后续替换掉（通过 setEditor）的编辑器之后才移除。我们期望在大多数情况下不以任何形式替换，包括通过 setEditor 安装或者通过重写 createEditor 创建编辑器。

此类是针对其单一 JFormattedTextField 子类的 LayoutManager。默认情况下，子级正好处于父 insets 的中间。

从以下版本开始：
1.4

嵌套类摘要
从类 javax.swing.JPanel 继承的嵌套类/接口
JPanel.AccessibleJPanel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSpinner.DefaultEditor(JSpinner spinner)
构造一个针对指定 JSpinner 的编辑器组件。
方法摘要
void | addLayoutComponent(String name, Component child) 此 LayoutManager 方法不执行任何操作。
void | commitEdit() 将当前编辑值赋给 SpinnerModel。
void | dismiss(JSpinner spinner) 将此编辑器从指定的 JSpinner 断开连接。
int | getBaseline(int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior() 返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。
JSpinner | getSpinner() 如果此编辑器的 JSpinner 祖先，如果祖先都不为 JSpinner，则返回 null。
JFormattedTextField | getTextField() 返回此编辑器的子 JFormattedTextField。
void | layoutContainer(Container parent) 调整一个（并且是唯一）子级的大小，以完全填充父 insets 中的区域。
Dimension | minimumLayoutSize(Container parent) 返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。
Dimension | preferredLayoutSize(Container parent) 返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。
void | propertyChange(PropertyChangeEvent e) 由 JFormattedTextField 的 PropertyChangeListener 调用。
void | removeLayoutComponent(Component child) 此 LayoutManager 方法不执行任何操作。
void | stateChanged(ChangeEvent e) 当 spinner 的模型状态更改时调用此方法。
从类 javax.swing.JPanel 继承的方法
getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JSpinner.DefaultEditor

public JSpinner.DefaultEditor(JSpinner spinner)
构造一个针对指定 JSpinner 的编辑器组件。此 DefaultEditor 是其自身的布局管理器，并且它已被添加到 spinner 的 ChangeListener 列表中。此构造方法创建了单一的子 JFormattedTextField，其值被初始化为 spinner 模型的当前值，并且将其添加到了此 DefaultEditor 中。

参数：
spinner - 此编辑器将要监视其模型的 spinner
另请参见：
getTextField(), JSpinner.addChangeListener(javax.swing.event.ChangeListener)
方法详细信息

dismiss

public void dismiss(JSpinner spinner)
将此编辑器从指定的 JSpinner 断开连接。默认情况下，此方法将从 spinner 的 ChangeListener 列表中移除其自身。

参数：
spinner - 要从其断开编辑器连接的 JSpinner；与构造方法传入的是同一个 spinner。

getSpinner

public JSpinner getSpinner()
如果此编辑器的 JSpinner 祖先，如果祖先都不为 JSpinner，则返回 null。 通常编辑器的父级是一个 JSpinner，尽管 JSpinner 的子类可能重写 createEditor 方法和在 JSpinner 及其编辑器之间插入一个到多个容器。

返回：
JSpinner 祖先；如果祖先都不为 JSpinner，则返回 null
另请参见：
JSpinner.createEditor(javax.swing.SpinnerModel)

getTextField

public JFormattedTextField getTextField()
返回此编辑器的子 JFormattedTextField。默认情况下，文本字段是编辑器的第一个也是唯一的一个子级。

返回：
供用户访问 SpinnerDateModel 值的 JFormattedTextField。
另请参见：
getSpinner(), JSpinner.getModel()

stateChanged

public void stateChanged(ChangeEvent e)
当 spinner 的模型状态更改时调用此方法。它将文本字段的 value 设置成 spinner 模型的当前值。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - 其源为模型已更改的 JSpinner 的 ChangeEvent。
另请参见：
getTextField(), JSpinner.getValue()

propertyChange

public void propertyChange(PropertyChangeEvent e)
由 JFormattedTextField 的 PropertyChangeListener 调用。当 "value" 属性更改时，这就意味着用户键入了一个新的数字，我们就设置 spinner 模型的值。

此类忽略其源不是 JFormattedTextField 的 PropertyChangeEvents，因此子类能安全地使此 DefaultEditor 成为其他对象的 PropertyChangeListener。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 此类创建的其源为 JFormattedTextField 的 PropertyChangeEvent。
另请参见：
getTextField()

addLayoutComponent

public void addLayoutComponent(String name,
                               Component child)
此 LayoutManager 方法不执行任何操作。我们仅管理单个子级并且不支持布局约束。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 忽略
child - 忽略

removeLayoutComponent

public void removeLayoutComponent(Component child)
此 LayoutManager 方法不执行任何操作。没有任何每子级的状态。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
child - 忽略

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
返回第一个（并且是唯一）子级的首选大小与其父 insets 的大小和。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 管理布局的容器
返回：
布局指定容器子组件的首选维度。
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
返回第一个（并且是唯一）的子级最小大小与其父 insets 的大小和。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 管理布局的 Container
返回：
布局指定容器子组件所需的最小维度。

layoutContainer

public void layoutContainer(Container parent)
调整一个（并且是唯一）子级的大小，以完全填充父 insets 中的区域。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要布置的容器

commitEdit

public void commitEdit()
                throws ParseException
将当前编辑值赋给 SpinnerModel。

默认的实现调用 JFormattedTextField 上的 commitEdit 方法。

抛出：
ParseException - 如果编辑值不合法

getBaseline

public int getBaseline(int width,
                       int height)
返回基线。

覆盖：
类 JComponent 中的 getBaseline
参数：
width - 适合基线的宽度
height - 适合基线的高度
返回：
基线，如果基线 < 0，则表示没有合理的基线
抛出：
IllegalArgumentException - 如果 width 或 height < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int,int), JComponent.getBaselineResizeBehavior()

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior()
返回一个枚举，它指示组件的基线如何随大小的改变而发生更改。

覆盖：
类 JComponent 中的 getBaselineResizeBehavior
返回：
一个指示基线如何随组件大小的更改发生变化的枚举
抛出：
NullPointerException
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSpinner.ListEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSpinner.ListEditor

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPanel
                    继承者  javax.swing.JSpinner.DefaultEditor
                        继承者  javax.swing.JSpinner.ListEditor
所有已实现的接口：
ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
正在封闭类：
JSpinner
public static class JSpinner.ListEditor
extends JSpinner.DefaultEditor

其模型为 SpinnerListModel 的 JSpinner 编辑器。

从以下版本开始：
1.4

嵌套类摘要
从类 javax.swing.JPanel 继承的嵌套类/接口
JPanel.AccessibleJPanel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSpinner.ListEditor(JSpinner spinner)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerListModel 的值的显示和编辑。
方法摘要
 SpinnerListModel getModel()
返回 spinner 祖先的 SpinnerNumberModel。
从类 javax.swing.JSpinner.DefaultEditor 继承的方法
addLayoutComponent, commitEdit, dismiss, getBaseline, getBaselineResizeBehavior, getSpinner, getTextField, layoutContainer, minimumLayoutSize, preferredLayoutSize, propertyChange, removeLayoutComponent, stateChanged
从类 javax.swing.JPanel 继承的方法
getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JSpinner.ListEditor

public JSpinner.ListEditor(JSpinner spinner)
构造一个 JSpinner，使其支持具有 JFormattedTextField 的 SpinnerListModel 的值的显示和编辑。此 ListEditor 既可以成为 spinner 的 ChangeListener，又可以成为新的 JFormattedTextField 的 PropertyChangeListener。

参数：
spinner - this 编辑器将要监视其模型的 spinner
抛出：
IllegalArgumentException - 如果 spinner 模型不是 SpinnerListModel 的实例
另请参见：
getModel(), SpinnerListModel
方法详细信息

getModel

public SpinnerListModel getModel()
返回 spinner 祖先的 SpinnerNumberModel。

返回：
getSpinner().getModel()
另请参见：
JSpinner.DefaultEditor.getSpinner(), JSpinner.DefaultEditor.getTextField()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSpinner.NumberEditor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSpinner.NumberEditor

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPanel
                    继承者  javax.swing.JSpinner.DefaultEditor
                        继承者  javax.swing.JSpinner.NumberEditor
所有已实现的接口：
ImageObserver, LayoutManager, MenuContainer, PropertyChangeListener, Serializable, EventListener, Accessible, ChangeListener
正在封闭类：
JSpinner
public static class JSpinner.NumberEditor
extends JSpinner.DefaultEditor

其模型为 SpinnerNumberModel 的 JSpinner 编辑器。该编辑器的值由一个 JFormattedTextField 显示，后者的格式由 minimum 和 maximum 属性映射到 SpinnerNumberMode 的 NumberFormatter 实例定义。

从以下版本开始：
1.4

嵌套类摘要
从类 javax.swing.JPanel 继承的嵌套类/接口
JPanel.AccessibleJPanel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSpinner.NumberEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerNumberModel 值的显示和编辑。
JSpinner.NumberEditor(JSpinner spinner, String decimalFormatPattern)
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。
方法摘要
DecimalFormat | getFormat() 返回 JFormattedTextField 用于分析和格式化数字的 java.text.DecimalFormat 对象。
SpinnerNumberModel | getModel() 返回 spinner 祖先的 SpinnerNumberModel。
从类 javax.swing.JSpinner.DefaultEditor 继承的方法
addLayoutComponent, commitEdit, dismiss, getBaseline, getBaselineResizeBehavior, getSpinner, getTextField, layoutContainer, minimumLayoutSize, preferredLayoutSize, propertyChange, removeLayoutComponent, stateChanged
从类 javax.swing.JPanel 继承的方法
getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JSpinner.NumberEditor

public JSpinner.NumberEditor(JSpinner spinner)
构造一个 JSpinner 编辑器，使其支持具有 JFormattedTextField 的 SpinnerNumberModel 值的显示和编辑。此 NumberEditor 既可以成为 spinner 的 ChangeListener，又可以成为新的 JFormattedTextField 的 PropertyChangeListener。

参数：
spinner - 此编辑器将要监视其模型的 spinner
抛出：
IllegalArgumentException - 如果 spinner 模型不是 SpinnerLNumberModel 的实例
另请参见：
getModel(), getFormat(), SpinnerNumberModel

JSpinner.NumberEditor

public JSpinner.NumberEditor(JSpinner spinner,
                             String decimalFormatPattern)
构造一个 JSpinner，使其支持具有一个 JFormattedTextField 的 SpinnerNumberModel 的值。此 NumberEditor 既可以成为 spinner 的 ChangeListener，又可以成为新的 JFormattedTextField 的 PropertyChangeListener。

参数：
此 - 编辑器将要监视其模型的 spinner
decimalFormatPattern - 用于显示和分析文本字段值的 DecimalFormat 对象的初始模式。
抛出：
IllegalArgumentException - 如果 spinner 模型不是 SpinnerNumberModel 的实例，或者 decimalFormatPattern 对于 DecimalFormat 不是一个有效的参数
另请参见：
JSpinner.DefaultEditor.getTextField(), SpinnerNumberModel, DecimalFormat
方法详细信息

getFormat

public DecimalFormat getFormat()
返回 JFormattedTextField 用于分析和格式化数字的 java.text.DecimalFormat 对象。

返回：
getTextField().getFormatter().getFormat() 的值。
另请参见：
JSpinner.DefaultEditor.getTextField(), DecimalFormat

getModel

public SpinnerNumberModel getModel()
返回 spinner 祖先的 SpinnerNumberModel。

返回：
getSpinner().getModel()
另请参见：
JSpinner.DefaultEditor.getSpinner(), JSpinner.DefaultEditor.getTextField()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSplitPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSplitPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JSplitPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JSplitPane
extends JComponent
implements Accessible

JSplitPane 用于分隔两个（只能两个）Component。两个 Component 图形化分隔以外观实现为基础，并且这两个 Component 可以由用户交互式调整大小。有关如何使用 JSplitPane 的信息，请参阅 The Java Tutorial 中的 How to Use Split Panes 一节。

使用 JSplitPane.HORIZONTAL_SPLIT 可让分隔窗格中的两个 Component 从左到右排列，或者使用 JSplitPane.VERTICAL_SPLIT 使其从上到下排列。改变 Component 大小的首选方式是调用 setDividerLocation，其中 location 是新的 x 或 y 位置，具体取决于 JSplitPane 的方向。

要将 Component 调整到其首选大小，可调用 resetToPreferredSizes。

当用户调整 Component 的大小时，Component 的最小大小用于确定 Component 能够设置的最大/最小位置。如果两个组件的最小大小大于分隔窗格的大小，则分隔条将不允许您调整其大小。改变 JComponent 最小大小，请参阅 JComponent.setMinimumSize(java.awt.Dimension)。

当用户调整分隔窗格大小时，新的空间以 resizeWeight 为基础在两个组件之间分配。默认情况下，值为 0 表示右边/底部的组件获得所有空间，而值为 1 表示左边/顶部的组件获得所有空间。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
setDividerLocation(double), resetToPreferredSizes()

嵌套类摘要
protected  class JSplitPane.AccessibleJSplitPane
此类实现 JSplitPane 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static String | BOTTOM 用于添加一个 Component 到另一个 Component 的下面。
static String | CONTINUOUS_LAYOUT_PROPERTY 绑定 continuousLayout 属性名称。
protected boolean | continuousLayout 当调整大小时视图是否连续重新显示。
static String | DIVIDER 用于添加一个表示分隔条的 Component。
static String | DIVIDER_LOCATION_PROPERTY 绑定 dividerLocation 属性。
static String | DIVIDER_SIZE_PROPERTY 绑定 border 属性名称。
protected int | dividerSize 分隔条大小。
static int | HORIZONTAL_SPLIT 水平分割表示 Component 沿 x 轴分割。
static String | LAST_DIVIDER_LOCATION_PROPERTY 绑定 lastLocation 属性。
protected int | lastDividerLocation 分隔窗格的上一个位置。
static String | LEFT 用于添加一个 Component 到另一个 Component 的左边。
protected Component | leftComponent 左边或者顶部的组件。
static String | ONE_TOUCH_EXPANDABLE_PROPERTY 绑定 oneTouchExpandable 属性。
protected boolean | oneTouchExpandable 是否要提供一个小部件来快速展开/折叠分隔窗格。
protected int | orientation 如何分割视图。
static String | ORIENTATION_PROPERTY 绑定 orientation（水平或者垂直）属性名称。
static String | RESIZE_WEIGHT_PROPERTY 绑定 weight 属性。
static String | RIGHT 用于添加一个 Component 到另一个 Component 的右边。
protected Component | rightComponent 右边或者底部的组件。
static String | TOP 用于添加一个 Component 到另一个 Component 的上面。
static int | VERTICAL_SPLIT 垂直分割表示 Component 沿 y 轴分割。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JSplitPane()
创建一个配置为将其子组件水平排列、无连续布局、为组件使用两个按钮的新 JSplitPane。
JSplitPane(int newOrientation)
创建一个配置为指定方向且无连续布局的新 JSplitPane。
JSplitPane(int newOrientation, boolean newContinuousLayout)
创建一个具有指定方向和重绘方式的新 JSplitPane。
JSplitPane(int newOrientation, boolean newContinuousLayout, Component newLeftComponent, Component newRightComponent)
创建一个具有指定方向、重绘方式和指定组件的新 JSplitPane。
JSplitPane(int newOrientation, Component newLeftComponent, Component newRightComponent)
创建一个具有指定方向和不连续重绘的指定组件的新 JSplitPane。
方法摘要
protected void | addImpl(Component comp, Object constraints, int index) 将指定组件添加到此分隔窗格。
AccessibleContext | getAccessibleContext() 获取与 JSplitPane 关联的 AccessibleContext。
Component | getBottomComponent() 返回分隔条下面或者右边的组件。
int | getDividerLocation() 返回最后传递给 setDividerLocation 的值。
int | getDividerSize() 返回分隔条的大小。
int | getLastDividerLocation() 返回分隔条所处的最后位置。
Component | getLeftComponent() 返回分隔条左边（或者上面）的组件。
int | getMaximumDividerLocation() 返回外观实现中分隔条的最大位置。
int | getMinimumDividerLocation() 返回外观实现中分隔条的最小位置。
int | getOrientation() 返回方向。
double | getResizeWeight() 返回确定额外空间如何分配的数。
Component | getRightComponent() 返回分隔条右边（或者下面）的组件。
Component | getTopComponent() 返回分隔条上面或者左边的组件。
SplitPaneUI | getUI() 返回提供当前外观的 SplitPaneUI。
String | getUIClassID() 返回呈现此组件的 L&F 类名。
boolean | isContinuousLayout() 获取 continuousLayout 属性。
boolean | isOneTouchExpandable() 获取 oneTouchExpandable 属性。
boolean | isValidateRoot() 如果返回 true，则在此 JSplitPane 的任何后代上调用 revalidate，将导致在队列中加入一个验证 JSplitPane 及其所有后代的一个请求。
protected void | paintChildren(Graphics g) 通知超类后，UI 通过 finishedPaintingChildren 通知子类，同时绘制边框。
protected String | paramString() 返回此 JSplitPane 的字符串表示形式。
void | remove(Component component) 移除窗格中的子组件 component。
void | remove(int index) 移除指定索引处的 Component。
void | removeAll() 从分隔窗格中移除所有子组件。
void | resetToPreferredSizes() 以子组件的首选大小为基础调整 JSplitPane 的布局。
void | setBottomComponent(Component comp) 将组件设置到分隔条的下面或者右边。
void | setContinuousLayout(boolean newContinuousLayout) 设置 continuousLayout 属性的值，在用户干预期要使子组件连续地重新显示和布局子组件，此值必须为 true。
void | setDividerLocation(double proportionalLocation) 设置分隔条的位置为 JSplitPane 大小的一个百分比。
void | setDividerLocation(int location) 设置分隔条的位置。
void | setDividerSize(int newSize) 设置分隔条的大小。
void | setLastDividerLocation(int newLastLocation) 将分隔条所处的最后位置设置为 newLastLocation。
void | setLeftComponent(Component comp) 将组件设置到分隔条的左边（或上面）。
void | setOneTouchExpandable(boolean newValue) 设置 oneTouchExpandable 属性的值，要使 JSplitPane 在分隔条上提供一个 UI 小部件来快速展开/折叠分隔条，此属性必须为 true。
void | setOrientation(int orientation) 设置方向，或者分隔窗格的方式。
void | setResizeWeight(double value) 指定当分隔窗格的大小改变时如何分配额外空间。
void | setRightComponent(Component comp) 将组件设置到分隔条的右边（或者下面）。
void | setTopComponent(Component comp) 将组件设置到分隔条的上面或者左边。
void | setUI(SplitPaneUI ui) 设置呈现此组件的 L&F 对象。
void | updateUI() UIManager 发出的关于 L&F 已改变的通知。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

VERTICAL_SPLIT

public static final int VERTICAL_SPLIT
垂直分割表示 Component 沿 y 轴分割。例如，两个 Component 将被分割成一个在另一个顶上。

另请参见：
常量字段值

HORIZONTAL_SPLIT

public static final int HORIZONTAL_SPLIT
水平分割表示 Component 沿 x 轴分割。例如，两个 Component 将被分割成一个在另一个左边。

另请参见：
常量字段值

LEFT

public static final String LEFT
用于添加一个 Component 到另一个 Component 的左边。

另请参见：
常量字段值

RIGHT

public static final String RIGHT
用于添加一个 Component 到另一个 Component 的右边。

另请参见：
常量字段值

TOP

public static final String TOP
用于添加一个 Component 到另一个 Component 的上面。

另请参见：
常量字段值

BOTTOM

public static final String BOTTOM
用于添加一个 Component 到另一个 Component 的下面。

另请参见：
常量字段值

DIVIDER

public static final String DIVIDER
用于添加一个表示分隔条的 Component。

另请参见：
常量字段值

ORIENTATION_PROPERTY

public static final String ORIENTATION_PROPERTY
绑定 orientation（水平或者垂直）属性名称。

另请参见：
常量字段值

CONTINUOUS_LAYOUT_PROPERTY

public static final String CONTINUOUS_LAYOUT_PROPERTY
绑定 continuousLayout 属性名称。

另请参见：
常量字段值

DIVIDER_SIZE_PROPERTY

public static final String DIVIDER_SIZE_PROPERTY
绑定 border 属性名称。

另请参见：
常量字段值

ONE_TOUCH_EXPANDABLE_PROPERTY

public static final String ONE_TOUCH_EXPANDABLE_PROPERTY
绑定 oneTouchExpandable 属性。

另请参见：
常量字段值

LAST_DIVIDER_LOCATION_PROPERTY

public static final String LAST_DIVIDER_LOCATION_PROPERTY
绑定 lastLocation 属性。

另请参见：
常量字段值

DIVIDER_LOCATION_PROPERTY

public static final String DIVIDER_LOCATION_PROPERTY
绑定 dividerLocation 属性。

从以下版本开始：
1.3
另请参见：
常量字段值

RESIZE_WEIGHT_PROPERTY

public static final String RESIZE_WEIGHT_PROPERTY
绑定 weight 属性。

从以下版本开始：
1.3
另请参见：
常量字段值

orientation

protected int orientation
如何分割视图。

continuousLayout

protected boolean continuousLayout
当调整大小时视图是否连续重新显示。

leftComponent

protected Component leftComponent
左边或者顶部的组件。

rightComponent

protected Component rightComponent
右边或者底部的组件。

dividerSize

protected int dividerSize
分隔条大小。

oneTouchExpandable

protected boolean oneTouchExpandable
是否要提供一个小部件来快速展开/折叠分隔窗格。

lastDividerLocation

protected int lastDividerLocation
分隔窗格的上一个位置。

构造方法详细信息

JSplitPane

public JSplitPane()
创建一个配置为将其子组件水平排列、无连续布局、为组件使用两个按钮的新 JSplitPane。

JSplitPane

public JSplitPane(int newOrientation)
创建一个配置为指定方向且无连续布局的新 JSplitPane。

参数：
newOrientation - JSplitPane.HORIZONTAL_SPLIT 或 JSplitPane.VERTICAL_SPLIT
抛出：
IllegalArgumentException - 如果 orientation 不是 HORIZONTAL_SPLIT 或 VERTICAL_SPLIT 之一。

JSplitPane

public JSplitPane(int newOrientation,
                  boolean newContinuousLayout)
创建一个具有指定方向和重绘方式的新 JSplitPane。

参数：
newOrientation - JSplitPane.HORIZONTAL_SPLIT 或 JSplitPane.VERTICAL_SPLIT
newContinuousLayout - 一个 boolean 值，当分隔条改变位置时组件连续重绘则为 true；当分隔条位置停止改变时才重绘则为 false
抛出：
IllegalArgumentException - 如果 orientation 不是 HORIZONTAL_SPLIT 或 VERTICAL_SPLIT 之一

JSplitPane

public JSplitPane(int newOrientation,
                  Component newLeftComponent,
                  Component newRightComponent)
创建一个具有指定方向和不连续重绘的指定组件的新 JSplitPane。

参数：
newOrientation - JSplitPane.HORIZONTAL_SPLIT 或 JSplitPane.VERTICAL_SPLIT
newLeftComponent - 将出现在水平分隔窗格的左边或者垂直分隔窗格的顶部的 Component
newRightComponent - 将出现在水平分隔窗格的右边或者垂直分隔窗格的底部的 Component
抛出：
IllegalArgumentException - 如果 orientation 不是 HORIZONTAL_SPLIT 或 VERTICAL_SPLIT 之一

JSplitPane

public JSplitPane(int newOrientation,
                  boolean newContinuousLayout,
                  Component newLeftComponent,
                  Component newRightComponent)
创建一个具有指定方向、重绘方式和指定组件的新 JSplitPane。

参数：
newOrientation - JSplitPane.HORIZONTAL_SPLIT 或 JSplitPane.VERTICAL_SPLIT
newContinuousLayout - 一个 boolean 值，当分隔条改变位置时组件连续重绘则为 true；当分隔条位置停止改变时才重绘则为 false
newLeftComponent - 将出现在水平分隔窗格的左边或者垂直分隔窗格的顶部的 Component
newRightComponent - 将出现在水平分隔窗格的右边或者垂直分隔窗格的底部的 Component
抛出：
IllegalArgumentException - 如果 orientation 不是 HORIZONTAL_SPLIT 或 VERTICAL_SPLIT 之一
方法详细信息

setUI

public void setUI(SplitPaneUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - SplitPaneUI 的 L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getUI

public SplitPaneUI getUI()
返回提供当前外观的 SplitPaneUI。

返回：
呈现此组件的 SplitPaneUI 对象

updateUI

public void updateUI()
UIManager 发出的关于 L&F 已改变的通知。用来自 UIManager 的最新版本 UI 对象替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类名。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "SplitPaneUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setDividerSize

public void setDividerSize(int newSize)
设置分隔条的大小。

参数：
newSize - 给定分隔条大小的一个整数，以像素为单位

getDividerSize

public int getDividerSize()
返回分隔条的大小。

返回：
给定分隔条大小的一个整数，以像素为单位

setLeftComponent

public void setLeftComponent(Component comp)
将组件设置到分隔条的左边（或上面）。

参数：
comp - 在该位置中显示的 Component

getLeftComponent

public Component getLeftComponent()
返回分隔条左边（或者上面）的组件。

返回：
在该位置中显示的 Component

setTopComponent

public void setTopComponent(Component comp)
将组件设置到分隔条的上面或者左边。

参数：
comp - 在该位置中显示的 Component

getTopComponent

public Component getTopComponent()
返回分隔条上面或者左边的组件。

返回：
在该位置中显示的 Component

setRightComponent

public void setRightComponent(Component comp)
将组件设置到分隔条的右边（或者下面）。

参数：
comp - 在该位置中显示的 Component

getRightComponent

public Component getRightComponent()
返回分隔条右边（或者下面）的组件。

返回：
在该位置中显示的 Component

setBottomComponent

public void setBottomComponent(Component comp)
将组件设置到分隔条的下面或者右边。

参数：
comp - 在该位置中显示的 Component

getBottomComponent

public Component getBottomComponent()
返回分隔条下面或者右边的组件。

返回：
在该位置中显示的 Component

setOneTouchExpandable

public void setOneTouchExpandable(boolean newValue)
设置 oneTouchExpandable 属性的值，要使 JSplitPane 在分隔条上提供一个 UI 小部件来快速展开/折叠分隔条，此属性必须为 true。此属性的默认值为 false。有些外观可能不支持一键展开；它们将忽略此属性。

参数：
newValue - 指定为 true，则分隔窗格应该提供一个折叠/展开的小部件
另请参见：
isOneTouchExpandable()

isOneTouchExpandable

public boolean isOneTouchExpandable()
获取 oneTouchExpandable 属性。

返回：
oneTouchExpandable 的值
另请参见：
setOneTouchExpandable(boolean)

setLastDividerLocation

public void setLastDividerLocation(int newLastLocation)
将分隔条所处的最后位置设置为 newLastLocation。

参数：
newLastLocation - 指定分隔条最后位置从窗格的左边（或者上边）到分隔条的左边（或者上边）的一个整数，以像素为单位

getLastDividerLocation

public int getLastDividerLocation()
返回分隔条所处的最后位置。

返回：
指定分隔条最后位置从窗格的左边（或者上边）到分隔条的左边（或者上边）的一个整数，以像素为单位

setOrientation

public void setOrientation(int orientation)
设置方向，或者分隔窗格的方式。选项有：
  • JSplitPane.VERTICAL_SPLIT（组件的上/下方向）
  • JSplitPane.HORIZONTAL_SPLIT（组件的左/右方向）

参数：
orientation - 指定方向的一个整数
抛出：
IllegalArgumentException - 如果方向不是如下之一：HORIZONTAL_SPLIT 或 VERTICAL_SPLIT。

getOrientation

public int getOrientation()
返回方向。

返回：
给定方向的一个整数
另请参见：
setOrientation(int)

setContinuousLayout

public void setContinuousLayout(boolean newContinuousLayout)
设置 continuousLayout 属性的值，在用户干预期要使子组件连续地重新显示和布局子组件，此值必须为 true。此属性的默认值为 false。一些外观可能不支持连续布局；它们将忽略此属性。

参数：
newContinuousLayout - 如果分隔条改变位置时组件连续重绘，则为 true
另请参见：
isContinuousLayout()

isContinuousLayout

public boolean isContinuousLayout()
获取 continuousLayout 属性。

返回：
continuousLayout 属性的值
另请参见：
setContinuousLayout(boolean)

setResizeWeight

public void setResizeWeight(double value)
指定当分隔窗格的大小改变时如何分配额外空间。在默认情况下，值为 0 表示右边/底部的组件获得所有额外空间（左边/顶部的组件固定），而值为 1 表示左边/顶部的组件获得所有额外空间（右边/底部的组件固定）。特别地，左边/顶部的组件获得 (weight * diff) 额外空间，并且右边/底部的组件获得 (1 - weight) * diff 额外空间。

参数：
value - 如上所述
抛出：
IllegalArgumentException - 如果 value 小于 0 或者大于 1
从以下版本开始：
1.3

getResizeWeight

public double getResizeWeight()
返回确定额外空间如何分配的数。

返回：
在分隔窗格的一次大小调整中如何分配额外空间
从以下版本开始：
1.3

resetToPreferredSizes

public void resetToPreferredSizes()
以子组件的首选大小为基础调整 JSplitPane 的布局。这将可能导致分隔条位置的改变。

setDividerLocation

public void setDividerLocation(double proportionalLocation)
设置分隔条的位置为 JSplitPane 大小的一个百分比。

根据 setDividerLocation(int) 来实现此方法。此方法以分隔窗格的当前大小为基础迅速改变窗格的大小。如果分隔窗格没有正确地实现并且不显示在屏幕上，此方法将不产生任何影响（新的分隔条位置将成为 0（当前的 size * proportionalLocation ））。

参数：
proportionalLocation - 指示百分比的双精度浮点值，从 0 (top/left) 到 1.0 (bottom/right)
抛出：
IllegalArgumentException - 如果指定的位置为 < 0 or > 1.0

setDividerLocation

public void setDividerLocation(int location)
设置分隔条的位置。这将传递给外观实现，然后通知侦听器。一个值小于 0 意味着分隔条应该重设为试图遵守左边/顶部组件首选大小的一个值。通知侦听器之后，最后的分隔条位置通过 setLastDividerLocation 更新。

参数：
location - 指定特定于 UI 值的一个整数（通常以像素为单位）

getDividerLocation

public int getDividerLocation()
返回最后传递给 setDividerLocation 的值。此方法返回的值可能与实际的分隔条位置不同（如果传递给 setDividerLocation 的值大于当前大小）。

返回：
指定分隔条位置的一个整数

getMinimumDividerLocation

public int getMinimumDividerLocation()
返回外观实现中分隔条的最小位置。

返回：
一个整数，它指定最小位置的特定于 UI 的值（通常以像素为单位）；如果 UI 为 null，则返回 -1

getMaximumDividerLocation

public int getMaximumDividerLocation()
返回外观实现中分隔条的最大位置。

返回：
指定最大位置的特定于 UI 值的一个整数（通常以像素为单位）；如果 UI 为 null，则返回 -1

remove

public void remove(Component component)
移除窗格中的子组件 component。如果必要，可重设 leftComponent 或 rightComponent 实例变量。

覆盖：
类 Container 中的 remove
参数：
component - 要移除的 Component
另请参见：
Container.add(java.awt.Component),
Container.validate(),
Container.remove(int)

remove

public void remove(int index)
移除指定索引处的 Component。如果必要，可更新 leftComponent 和 rightComponent 实例变量，然后通知超类。

覆盖：
类 Container 中的 remove
参数：
index - 指定要移除的组件的一个整数，为 1 时指定左边/顶部的组件，为 2 指定底部/右边的组件
另请参见：
Container.add(java.awt.Component),
Container.validate(),
Container.getComponentCount()

removeAll

public void removeAll()
从分隔窗格中移除所有子组件。重设 leftComponent 和 rightComponent 实例变量。

覆盖：
类 Container 中的 removeAll
另请参见：
Container.add(java.awt.Component), Container.remove(int)

isValidateRoot

public boolean isValidateRoot()
如果返回 true，则在此 JSplitPane 的任何后代上调用 revalidate，将导致在队列中加入一个验证 JSplitPane 及其所有后代的一个请求。

覆盖：
类 JComponent 中的 isValidateRoot
返回：
true
另请参见：
JComponent.revalidate()

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
将指定组件添加到此分隔窗格。如果 constraints 标识左边/顶部或者右边/底部的子组件，并且之前已添加了一个具有该标识符的组件，则该组件将被移除，然后 comp 将被添加到该位置。如果 constraints 不是已知的标识符之一，则布局管理器可能抛出一个 IllegalArgumentException。

可能的约束对象（字符串）是：

  • JSplitPane.TOP
  • JSplitPane.LEFT
  • JSplitPane.BOTTOM
  • JSplitPane.RIGHT
如果 constraints 对象为 null，则组件将被添加到第一个可用位置（如果展开，则为左边/顶部；否则为右边/底部）。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要添加的组件
constraints - 指定此组件布局约束（位置）的一个 Object
index - 指定容器列表中索引的一个整数。
抛出：
IllegalArgumentException - 如果 constraints 对象不匹配现有的组件
另请参见：
Container.addImpl(Component, Object, int)

paintChildren

protected void paintChildren(Graphics g)
通知超类后，UI 通过 finishedPaintingChildren 通知子类，同时绘制边框。

覆盖：
类 JComponent 中的 paintChildren
参数：
g - 在其中进行绘制的 Graphics 上下文
另请参见：
JComponent.paint(java.awt.Graphics), Container.paint(java.awt.Graphics)

paramString

protected String paramString()
返回此 JSplitPane 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JSplitPane 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与 JSplitPane 关联的 AccessibleContext。对于分隔窗格，AccessibleContext 采用 AccessibleJSplitPane 的形式。必要时创建新的 AccessibleJSplitPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJSplitPane，它充当此 JSplitPane 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JSplitPane.AccessibleJSplitPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JSplitPane.AccessibleJSplitPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JSplitPane.AccessibleJSplitPane
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent, AccessibleValue
正在封闭类：
JSplitPane
protected class JSplitPane.AccessibleJSplitPane
extends JComponent.AccessibleJComponent
implements AccessibleValue

此类实现 JSplitPane 类的可访问性支持。它提供适合于分隔窗格用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JSplitPane.AccessibleJSplitPane()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue。
Number | getCurrentAccessibleValue() 获取此对象的可访问值。
Number | getMaximumAccessibleValue() 获取此对象的最大可访问值。
Number | getMinimumAccessibleValue() 获取此对象的最小可访问值。
boolean | setCurrentAccessibleValue(Number n) 将此对象的值设置为一个 Number。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JSplitPane.AccessibleJSplitPane

protected JSplitPane.AccessibleJSplitPane()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态集。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态的 AccessibleState 的实例
另请参见：
AccessibleState

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue。在此类的 Java Accessibility API 实现中，返回此对象，它负责实现其本身行为的 AccessibleValue 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
此对象
另请参见：
AccessibleValue

getCurrentAccessibleValue

public Number getCurrentAccessibleValue()
获取此对象的可访问值。

指定者：
接口 AccessibleValue 中的 getCurrentAccessibleValue
返回：
描述此对象值的本地 String。
另请参见：
AccessibleValue.setCurrentAccessibleValue(java.lang.Number)

setCurrentAccessibleValue

public boolean setCurrentAccessibleValue(Number n)
将此对象的值设置为一个 Number。

指定者：
接口 AccessibleValue 中的 setCurrentAccessibleValue
返回：
如果设置该值，则返回 True。
另请参见：
AccessibleValue.getCurrentAccessibleValue()

getMinimumAccessibleValue

public Number getMinimumAccessibleValue()
获取此对象的最小可访问值。

指定者：
接口 AccessibleValue 中的 getMinimumAccessibleValue
返回：
此对象的最小值。
另请参见：
AccessibleValue.getMaximumAccessibleValue()

getMaximumAccessibleValue

public Number getMaximumAccessibleValue()
获取此对象的最大可访问值。

指定者：
接口 AccessibleValue 中的 getMaximumAccessibleValue
返回：
此对象的最大值。
另请参见：
AccessibleValue.getMinimumAccessibleValue()

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTabbedPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTabbedPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JTabbedPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
public class JTabbedPane
extends JComponent
implements Serializable, Accessible, SwingConstants

一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。有关使用选项卡窗格的例子和信息，请参阅 The Java Tutorial 中的 How to Use Tabbed Panes 一节。

通过使用 addTab 和 insertTab 方法将选项卡/组件添加到 TabbedPane 对象中。选项卡通过对应于添加位置的索引来表示，其中第一个选项卡的索引为 0，最后一个选项卡的索引为选项卡数减 1。

TabbedPane 使用 SingleSelectionModel 来表示选项卡索引集和当前所选择的索引。如果选项卡数大于 0，则总会有一个被选定的索引，此索引默认被初始化为第一个选项卡。如果选项卡数为 0，则所选择的索引为 -1。

制表符标题可由 Component 呈现。例如，以下代码将产生类似的结果：

 // In this case the look and feel renders the title for the tab.
 tabbedPane.addTab("Tab", myComponent);
 // In this case the custom component is responsible for rendering the
 // title of the tab.
 tabbedPane.addTab(null, myComponent);
 tabbedPane.setTabComponentAt(0, new JLabel("Tab"));
当想要一个更复杂的用户交互（需要制表符上的自定义组件）时，通常使用后者。例如，可提供一个显示动画的自定义组件或者具有关闭制表符的小部件的组件。

如果为制表符指定一个组件，则 JTabbedPane 将不会呈现为该制表符指定的任何文本或图标。

注： 不要在制表符组件上直接使用 setVisible 以使其可见，使用 setSelectedComponent 或 setSelectedIndex 方法来替代。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
SingleSelectionModel

嵌套类摘要
protected class | JTabbedPane.AccessibleJTabbedPane 此类实现对 JTabbedPane 类的可访问性支持。
protected class | JTabbedPane.ModelListener 将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected ChangeEvent | changeEvent 由于事件仅有的（只读）状态是源属性，因此每个 TabPane 实例只需要一个 ChangeEvent。
protected ChangeListener | changeListener changeListener 是添加到模型中的侦听器。
protected SingleSelectionModel | model 默认的选择模型。
static int | SCROLL_TAB_LAYOUT 当在一次运行中不能放入所有的选项卡时，用于提供可用选项卡子集的选项卡布局策略。
protected int | tabPlacement 选项卡的放置位置。
static int | WRAP_TAB_LAYOUT 当在一次运行中不能放入所有的选项卡时，在多次运行中包装选项卡的选项卡布局策略。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTabbedPane()
创建一个具有默认的 JTabbedPane.TOP 选项卡布局的空 TabbedPane。
JTabbedPane(int tabPlacement)
创建一个空的 TabbedPane，使其具有以下指定选项卡布局中的一种：JTabbedPane.TOP、JTabbedPane.BOTTOM、JTabbedPane.LEFT 或 JTabbedPane.RIGHT。
JTabbedPane(int tabPlacement, int tabLayoutPolicy)
创建一个空的 TabbedPane，使其具有指定的选项卡布局和选项卡布局策略。
方法摘要
Component | add(Component component) 添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。
Component | add(Component component, int index) 在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。
void | add(Component component, Object constraints) 将一个 component 添加到选项卡窗格中。
void | add(Component component, Object constraints, int index) 在指定的选项卡索引位置添加一个 component。
Component | add(String title, Component component) 添加具有指定选项卡标题的 component。
void | addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到此选项卡窗格中。
void | addTab(String title, Component component) 添加一个由 title 表示，且没有图标的 component。
void | addTab(String title, Icon icon, Component component) 添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。
void | addTab(String title, Icon icon, Component component, String tip) 添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。
protected ChangeListener | createChangeListener() 要对 ChangeEvents 进行不同处理的子类可以重写它，从而返回 ModelListener 的一个子类，或者返回另一个 ChangeListener 实现。
protected void | fireStateChanged() 将一个 ChangeEvent（以此 JTabbedPane 作为源）发送到每个已注册的侦听器。
AccessibleContext | getAccessibleContext() 获取与此 JTabbedPane 关联的 AccessibleContext。
Color | getBackgroundAt(int index) 返回 index 位置的选项卡背景色。
Rectangle | getBoundsAt(int index) 返回 index 位置的选项卡边界。
ChangeListener[] | getChangeListeners() 返回通过 addChangeListener 方法添加到此 JTabbedPane 中的所有 ChangeListener 的数组。
Component | getComponentAt(int index) 返回 index 位置的组件。
Icon | getDisabledIconAt(int index) 返回 index 位置的选项卡禁用图标。
int | getDisplayedMnemonicIndexAt(int tabIndex) 返回作为索引的字符，外观必须提供它来表示助记符字符。
Color | getForegroundAt(int index) 返回 index 位置的选项卡背景色。
Icon | getIconAt(int index) 返回 index 位置的选项卡图标。
int | getMnemonicAt(int tabIndex) 返回用于访问指定选项卡的键盘助记符。
SingleSelectionModel | getModel() 返回与此选项卡窗格关联的模型。
Component | getSelectedComponent() 返回此选项卡窗格当前选择的组件。
int | getSelectedIndex() 返回当前选择的此选项卡窗格的索引。
Component | getTabComponentAt(int index) 返回 index 位置上的选项卡组件。
int | getTabCount() 返回此 tabbedpane 的选项卡数。
int | getTabLayoutPolicy() 返回在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。
int | getTabPlacement() 返回此选项卡窗格的选项卡布局。
int | getTabRunCount() 返回当前运行的用于显示选项卡的选项卡数。
String | getTitleAt(int index) 返回 index 位置的选项卡标题。
String | getToolTipText(MouseEvent event) 返回由鼠标事件位置确定的组件的工具提示文本。
String | getToolTipTextAt(int index) 返回 index 位置的选项卡工具提示文本。
TabbedPaneUI | getUI() 返回实现此组件的 L&F 的 UI 对象。
String | getUIClassID() 返回实现此组件的 L&F 的 UI 类的名称。
int | indexAtLocation(int x, int y) 返回选项卡边界与指定区域相交的选项卡索引。
int | indexOfComponent(Component component) 返回指定组件的选项卡索引。
int | indexOfTab(Icon icon) 返回具有给定的 icon 的第一个选项卡索引，如果没有具有此图标的选项卡，则返回 -1。
int | indexOfTab(String title) 返回具有给定 title 的第一个选项卡索引，如果没有具有此标题的选项卡，则返回 -1。
int | indexOfTabComponent(Component tabComponent) 返回指定选项卡组件的选项卡索引。
void | insertTab(String title, Icon icon, Component component, String tip, int index) 在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。
boolean | isEnabledAt(int index) 返回当前是否启用了 index 位置的选项卡。
protected String | paramString() 返回此 JTabbedPane 的字符串表示。
void | remove(Component component) 从 JTabbedPane 中移除指定 Component。
void | remove(int index) 移除对应于指定索引的选项卡和组件。
void | removeAll() 从 tabbedpane 中移除所有选项卡及其相应组件。
void | removeChangeListener(ChangeListener l) 从此选项卡窗格中移除一个 ChangeListener。
void | removeTabAt(int index) 移除 index 位置的选项卡。
void | setBackgroundAt(int index, Color background) 将 index 位置的背景色设置为 background，它可以为 null，在这种情况下选项卡的背景色默认为 tabbedpane 的背景色。
void | setComponentAt(int index, Component component) 将 index 位置的组件设置为 component。
void | setDisabledIconAt(int index, Icon disabledIcon) 将 index 位置的禁用图标设置为 icon，它可以为 null。
void | setDisplayedMnemonicIndexAt(int tabIndex, int mnemonicIndex) 提供一个外观的提示，此提示是关于文本中哪此字符必须被装饰用来表示助记符。
void | setEnabledAt(int index, boolean enabled) 设置是否启用 index 位置的选项卡。
void | setForegroundAt(int index, Color foreground) 将 index 位置的前景色设置为 foreground，它可以为 null，在这种情况下选项卡的前景色默认为此 tabbedpane 的前景色。
void | setIconAt(int index, Icon icon) 将 index 位置的图标设置为 icon，它可以为 null。
void | setMnemonicAt(int tabIndex, int mnemonic) 设置用于访问指定选项卡的键盘助记符。
void | setModel(SingleSelectionModel model) 设置要用于此选项卡窗格的模型。
void | setSelectedComponent(Component c) 设置此选项卡窗格的已选组件。
void | setSelectedIndex(int index) 设置所选择的此选项卡窗格的索引。
void | setTabComponentAt(int index, Component component) 设置负责呈现指定选项卡标题的组件。
void | setTabLayoutPolicy(int tabLayoutPolicy) 设置在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。
void | setTabPlacement(int tabPlacement) 设置此选项卡窗格的选项卡布局。
void | setTitleAt(int index, String title) 将 index 位置的标题设置为 title，它可以为 null。
void | setToolTipTextAt(int index, String toolTipText) 将 index 位置的工具提示文本设置为 toolTipText，它可以为 null。
void | setUI(TabbedPaneUI ui) 设置实现此组件的 L&F 的 UI 对象。
void | updateUI() 从当前外观更新 UI 属性的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

WRAP_TAB_LAYOUT

public static final int WRAP_TAB_LAYOUT
当在一次运行中不能放入所有的选项卡时，在多次运行中包装选项卡的选项卡布局策略。

另请参见：
常量字段值

SCROLL_TAB_LAYOUT

public static final int SCROLL_TAB_LAYOUT
当在一次运行中不能放入所有的选项卡时，用于提供可用选项卡子集的选项卡布局策略。如果在一次运行中不能放入所有的选项卡，则外观（look and feel）将提供一种导航到隐藏的选项卡的方法。

另请参见：
常量字段值

tabPlacement

protected int tabPlacement
选项卡的放置位置。

另请参见：
setTabPlacement(int)

model

protected SingleSelectionModel model
默认的选择模型。

changeListener

protected ChangeListener changeListener
changeListener 是添加到模型中的侦听器。

changeEvent

protected transient ChangeEvent changeEvent
由于事件仅有的（只读）状态是源属性，因此每个 TabPane 实例只需要一个 ChangeEvent。此处生成的事件源总是 "this"。

构造方法详细信息

JTabbedPane

public JTabbedPane()
创建一个具有默认的 JTabbedPane.TOP 选项卡布局的空 TabbedPane。

另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String)

JTabbedPane

public JTabbedPane(int tabPlacement)
创建一个空的 TabbedPane，使其具有以下指定选项卡布局中的一种：JTabbedPane.TOP、JTabbedPane.BOTTOM、JTabbedPane.LEFT 或 JTabbedPane.RIGHT。

参数：
tabPlacement - 关于内容的选项卡布局
另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String)

JTabbedPane

public JTabbedPane(int tabPlacement,
                   int tabLayoutPolicy)
创建一个空的 TabbedPane，使其具有指定的选项卡布局和选项卡布局策略。布局可以是以下几种之一：JTabbedPane.TOP、JTabbedPane.BOTTOM、JTabbedPane.LEFT 或 JTabbedPane.RIGHT。布局策略可以是以下两种之一：JTabbedPane.WRAP_TAB_LAYOUT 或 JTabbedPane.SCROLL_TAB_LAYOUT。

参数：
tabPlacement - 关于内容的选项卡布局
tabLayoutPolicy - 当在一次运行中不能放入所有的选项卡时，放置选项卡的策略
抛出：
IllegalArgumentException - 如果选项卡布局或选项卡布局策略不是以上受支持的值中的一个
从以下版本开始：
1.4
另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String)
方法详细信息

getUI

public TabbedPaneUI getUI()
返回实现此组件的 L&F 的 UI 对象。

返回：
TabbedPaneUI 对象
另请参见：
setUI(javax.swing.plaf.TabbedPaneUI)

setUI

public void setUI(TabbedPaneUI ui)
设置实现此组件的 L&F 的 UI 对象。

参数：
ui - 新的 UI 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
从当前外观更新 UI 属性的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回实现此组件的 L&F 的 UI 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "TabbedPaneUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

createChangeListener

protected ChangeListener createChangeListener()
要对 ChangeEvents 进行不同处理的子类可以重写它，从而返回 ModelListener 的一个子类，或者返回另一个 ChangeListener 实现。

另请参见：
fireStateChanged()

addChangeListener

public void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到此选项卡窗格中。

参数：
l - 要添加的 ChangeListener
另请参见：
fireStateChanged(), removeChangeListener(javax.swing.event.ChangeListener)

removeChangeListener

public void removeChangeListener(ChangeListener l)
从此选项卡窗格中移除一个 ChangeListener。

参数：
l - 要移除的 ChangeListener
另请参见：
fireStateChanged(), addChangeListener(javax.swing.event.ChangeListener)

getChangeListeners

public ChangeListener[] getChangeListeners()
返回通过 addChangeListener 方法添加到此 JTabbedPane 中的所有 ChangeListener 的数组。

返回：
所有添加的 ChangeListener，或者在没有添加侦听器时返回一个空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
将一个 ChangeEvent（以此 JTabbedPane 作为源）发送到每个已注册的侦听器。每次选定的索引或 JTabbedPane 中选定的制表符发生了更改时调用此方法。通常，选定的索引和选定的制表符同时更改。但是，在某些情况下（如选项卡增加），选定的索引发生了更改而选定的选项卡却保持不变。还有一些情况下（如删除选定的选项卡），索引保持不变，但一个新的选项卡移动到该索引。对于所有这些情况都将触发事件。

另请参见：
addChangeListener(javax.swing.event.ChangeListener), EventListenerList

getModel

public SingleSelectionModel getModel()
返回与此选项卡窗格关联的模型。

另请参见：
setModel(javax.swing.SingleSelectionModel)

setModel

public void setModel(SingleSelectionModel model)
设置要用于此选项卡窗格的模型。

参数：
model - 要使用的模型
另请参见：
getModel()

getTabPlacement

public int getTabPlacement()
返回此选项卡窗格的选项卡布局。

另请参见：
setTabPlacement(int)

setTabPlacement

public void setTabPlacement(int tabPlacement)
设置此选项卡窗格的选项卡布局。可能的值为：
  • JTabbedPane.TOP
  • JTabbedPane.BOTTOM
  • JTabbedPane.LEFT
  • JTabbedPane.RIGHT
如果未设置，则默认值为 SwingConstants.TOP。

参数：
tabPlacement - 关于内容的选项卡布局
抛出：
IllegalArgumentException - 如果选项卡布局的值不是以上的有效值之一

getTabLayoutPolicy

public int getTabLayoutPolicy()
返回在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。

从以下版本开始：
1.4
另请参见：
setTabLayoutPolicy(int)

setTabLayoutPolicy

public void setTabLayoutPolicy(int tabLayoutPolicy)
设置在一次运行中不能放入所有的选项卡时，选项卡窗格使用的对选项卡进行布局安排的策略。可能的值为：
  • JTabbedPane.WRAP_TAB_LAYOUT
  • JTabbedPane.SCROLL_TAB_LAYOUT
如果未通过 UI 进行设置，则默认值为 JTabbedPane.WRAP_TAB_LAYOUT。

一些外观可能只支持可能的布局策略的一个子集，在这种情况下可以忽略此属性的值。

参数：
tabLayoutPolicy - 用于安排选项卡的策略
抛出：
IllegalArgumentException - 如果 layoutPolicy 的值不是以上有效值之一
从以下版本开始：
1.4
另请参见：
getTabLayoutPolicy()

getSelectedIndex

public int getSelectedIndex()
返回当前选择的此选项卡窗格的索引。如果当前没有选择选项卡，则返回 -1。

返回：
所选择的选项卡的索引
另请参见：
setSelectedIndex(int)

setSelectedIndex

public void setSelectedIndex(int index)
设置所选择的此选项卡窗格的索引。索引必须为有效的选项卡索引或为 -1，-1 指示不应该选择选项卡（也可以用于选项卡窗格中没有选项卡的情况）。如果在选项卡窗格中包含一个或多个选项卡时指定了 -1，则结果将是已定义的实现。

参数：
index - 要选择的索引
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < -1 || index >= tab count）
另请参见：
getSelectedIndex(), SingleSelectionModel.setSelectedIndex(int)

getSelectedComponent

public Component getSelectedComponent()
返回此选项卡窗格当前选择的组件。如果当前没有选择选项卡，则返回 null。

返回：
与选择的选项卡对应的组件
另请参见：
setSelectedComponent(java.awt.Component)

setSelectedComponent

public void setSelectedComponent(Component c)
设置此选项卡窗格的已选组件。这将自动将 selectedIndex 设置为对应于指定组件的索引。

抛出：
IllegalArgumentException - 如果选项卡窗格中没有组件
另请参见：
getSelectedComponent()

insertTab

public void insertTab(String title,
                      Icon icon,
                      Component component,
                      String tip,
                      int index)
在 index 位置插入一个 component，该组件通过 title 和/或 icon（任意一个都可以为 null）来表示。在内部使用 java.util.Vector，有关插入约定的详细信息请参阅 insertElementAt。

参数：
title - 要在此选项卡中显示的标题
icon - 要在此选项卡中显示的图标
component - 单击此选项卡时要显示的组件。
tip - 此选项卡要显示的工具提示
index - 要插入此新选项卡的位置
另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

addTab

public void addTab(String title,
                   Icon icon,
                   Component component,
                   String tip)
添加由 title 和/或 icon 表示的 component 和 tip，其中任意一个都可以为 null。insertTab 的覆盖方法。

参数：
title - 此选项卡中要显示的标题
icon - 此选项卡中要显示的图标
component - 单击此选项卡时要显示的组件
tip - 此选项卡要显示的工具提示
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

addTab

public void addTab(String title,
                   Icon icon,
                   Component component)
添加一个由 title 和/或 icon 表示的 component，其任意一个都可以为 null。insertTab 的覆盖方法。

参数：
title - 此选项卡中要显示的标题
icon - 此选项卡中要显示的图标
component - 单击此选项卡时要显示的组件
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

addTab

public void addTab(String title,
                   Component component)
添加一个由 title 表示，且没有图标的 component。insertTab 的覆盖方法。

参数：
title - 此选项卡要显示的标题
component - 单击此选项卡时要显示的组件
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

add

public Component add(Component component)
添加一个 component，其选项卡的默认值为调用 component.getName 返回的组件的名称。insertTab 的覆盖方法。

覆盖：
类 Container 中的 add
参数：
component - 单击此选项卡时要显示的组件
返回：
此组件
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

add

public Component add(String title,
                     Component component)
添加具有指定选项卡标题的 component。insertTab 的覆盖方法。

覆盖：
类 Container 中的 add
参数：
title - 此选项卡要显示的标题
component - 单击此选项卡时要显示的组件
返回：
此组件
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

add

public Component add(Component component,
                     int index)
在指定的选项卡索引位置添加一个 component，默认的选项卡标题为组件名称。insertTab 的覆盖方法。

覆盖：
类 Container 中的 add
参数：
component - 单击此选项卡时要显示的组件
index - 新选项卡的插入位置
返回：
此组件
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

add

public void add(Component component,
                Object constraints)
将一个 component 添加到选项卡窗格中。如果 constraints 为 String 或 Icon，则它将用于选项卡标题，否则组件名称将用作选项卡标题。insertTab 的覆盖方法。

覆盖：
类 Container 中的 add
参数：
component - 单击此选项卡时要显示的组件
constraints - 选项卡中要显示的对象
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

add

public void add(Component component,
                Object constraints,
                int index)
在指定的选项卡索引位置添加一个 component。如果 constraints 为 String 或 Icon，则它将用于选项卡标题，否则组件名称将用作选项卡标题。insertTab 的覆盖方法。

覆盖：
类 Container 中的 add
参数：
component - 单击此选项卡时要显示的组件
constraints - 选项卡中要显示的对象
index - 插入新选项卡的位置
另请参见：
insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int), removeTabAt(int)

removeTabAt

public void removeTabAt(int index)
移除 index 位置的选项卡。移除与 index 关联的组件后，将其可见性重置为 true，以确保加入到其他容器时是可见的。

参数：
index - 要移除的选项卡的索引
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), insertTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String, int)

remove

public void remove(Component component)
从 JTabbedPane 中移除指定 Component。如果 component 为 null，则此方法不执行任何操作。

覆盖：
类 Container 中的 remove
参数：
component - 要从选项卡窗格中移除的组件
另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

remove

public void remove(int index)
移除对应于指定索引的选项卡和组件。

覆盖：
类 Container 中的 remove
参数：
index - 要从 tabbedpane 中移除的组件的索引
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

removeAll

public void removeAll()
从 tabbedpane 中移除所有选项卡及其相应组件。

覆盖：
类 Container 中的 removeAll
另请参见：
addTab(java.lang.String, javax.swing.Icon, java.awt.Component, java.lang.String), removeTabAt(int)

getTabCount

public int getTabCount()
返回此 tabbedpane 的选项卡数。

返回：
指定了选项卡页数的整数

getTabRunCount

public int getTabRunCount()
返回当前运行的用于显示选项卡的选项卡数。

返回：
一个整数，如果 tabPlacement 为 TOP 或 BOTTOM，则此数给出了行数，如果 tabPlacement 为 LEFT 或 RIGHT，则此数给出了列数，如果此 tabbedpane 没有设置 UI，则此数为 0

getTitleAt

public String getTitleAt(int index)
返回 index 位置的选项卡标题。

参数：
index - 正在被查询的项的索引
返回：
index 位置的标题
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count)
另请参见：
setTitleAt(int, java.lang.String)

getIconAt

public Icon getIconAt(int index)
返回 index 位置的选项卡图标。

参数：
index - 正在被查询的项的索引
返回：
index 位置的图标
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
setIconAt(int, javax.swing.Icon)

getDisabledIconAt

public Icon getDisabledIconAt(int index)
返回 index 位置的选项卡禁用图标。如果在 index 位置不存在选项卡禁用图标，则将该调用转发到外观，以从对应的启用的 Icon 构造合适的禁用 Icon。一些外观可能不呈现禁用的 Icon，在这种情况下将不创建禁用的 Icon。

参数：
index - 正在被查询的项的索引
返回：
index 位置的图标
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
setDisabledIconAt(int, javax.swing.Icon)

getToolTipTextAt

public String getToolTipTextAt(int index)
返回 index 位置的选项卡工具提示文本。

参数：
index - 正在被查询的项的索引
返回：
包含 index 位置的工具提示文本的字符串
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
从以下版本开始：
1.3
另请参见：
setToolTipTextAt(int, java.lang.String)

getBackgroundAt

public Color getBackgroundAt(int index)
返回 index 位置的选项卡背景色。

参数：
index - 正在被查询的项的索引
返回：
index 位置的选项卡背景色的 Color
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
setBackgroundAt(int, java.awt.Color)

getForegroundAt

public Color getForegroundAt(int index)
返回 index 位置的选项卡背景色。

参数：
index - 正在被查询的项的索引
返回：
index 位置的选项卡的前景 Color
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
setForegroundAt(int, java.awt.Color)

isEnabledAt

public boolean isEnabledAt(int index)
返回当前是否启用了 index 位置的选项卡。

参数：
index - 正在被查询的项的索引
返回：
如果启用了 index 位置的选项卡，则返回 true；否则返回 false
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
setEnabledAt(int, boolean)

getComponentAt

public Component getComponentAt(int index)
返回 index 位置的组件。

参数：
index - 正在被查询的项的索引
返回：
index 位置的 Component
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
setComponentAt(int, java.awt.Component)

getMnemonicAt

public int getMnemonicAt(int tabIndex)
返回用于访问指定选项卡的键盘助记符。助记符是一个键，在与外观的无鼠标修改键（通常为 Alt）一起使用时，它将激活指定的选项卡。

参数：
tabIndex - 助记符引用的选项卡的索引
返回：
表示助记符的键代码；如果选项卡没有指定助记符，则返回 -1
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（tabIndex < 0 || tabIndex >= tab count）
从以下版本开始：
1.4
另请参见：
setDisplayedMnemonicIndexAt(int,int), setMnemonicAt(int,int)

getDisplayedMnemonicIndexAt

public int getDisplayedMnemonicIndexAt(int tabIndex)
返回作为索引的字符，外观必须提供它来表示助记符字符。

参数：
tabIndex - 助记符要引用的选项卡索引
返回：
表示助记符字符（如果存在）的索引；否则返回 -1
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（tabIndex < 0 || tabIndex >= tab count）
从以下版本开始：
1.4
另请参见：
setDisplayedMnemonicIndexAt(int,int), setMnemonicAt(int,int)

getBoundsAt

public Rectangle getBoundsAt(int index)
返回 index 位置的选项卡边界。如果当前此索引位置的选项卡在 UI 中不可见，则返回 null。如果在此 tabbedpane 上没有设置 UI，则返回 null。

参数：
index - 要查询的索引
返回：
包含 index 位置的选项卡边界的 Rectangle，如果当前 index 位置的选项卡在 UI 中不可见，则返回 null，如果在此 tabbedpane 上没有设置 UI，也将返回 null
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）

setTitleAt

public void setTitleAt(int index,
                       String title)
将 index 位置的标题设置为 title，它可以为 null。如果未指定此选项卡的选项卡组件，则不显示该标题。如果在该索引位置没有选项卡，则将引发一个内部异常。

参数：
index - 标题要被设置的位置的选项卡索引
title - 选项卡上要显示的标题
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
getTitleAt(int), setTabComponentAt(int, java.awt.Component)

setIconAt

public void setIconAt(int index,
                      Icon icon)
将 index 位置的图标设置为 icon，它可以为 null。此方法不能设置 icon 位置的禁用图标。如果新的 Icon 不同于当前的 Icon，且禁用的图标不是显式设置的，那么 LookAndFeel 会被要求生成一个禁用的 Icon。要显式设置禁用的图标，请使用 setDisableIconAt()。如果指定了此选项卡的选项卡组件，则不显示该图标。如果在该索引位置没有选项卡，则会引发一个内部异常。

参数：
index - 图标要被设置的位置的选项卡索引
icon - 要在选项卡中显示的图标
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
setDisabledIconAt(int, javax.swing.Icon), getIconAt(int), getDisabledIconAt(int), setTabComponentAt(int, java.awt.Component)

setDisabledIconAt

public void setDisabledIconAt(int index,
                              Icon disabledIcon)
将 index 位置的禁用图标设置为 icon，它可以为 null。如果在该索引位置没有选项卡，则会引发一个内部异常。

参数：
index - 图标要被设置的位置的选项卡索引
disabledIcon - 当禁用时要在选项卡中显示的图标
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
getDisabledIconAt(int)

setToolTipTextAt

public void setToolTipTextAt(int index,
                             String toolTipText)
将 index 位置的工具提示文本设置为 toolTipText，它可以为 null。如果在该索引位置没有选项卡，则会引发一个内部异常。

参数：
index - 工具提示文本要被设置的位置选项卡索引
toolTipText - 选项卡中要显示的工具提示文本
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
从以下版本开始：
1.3
另请参见：
getToolTipTextAt(int)

setBackgroundAt

public void setBackgroundAt(int index,
                            Color background)
将 index 位置的背景色设置为 background，它可以为 null，在这种情况下选项卡的背景色默认为 tabbedpane 的背景色。如果在该索引位置没有选项卡，则会引发一个内部异常。

参数：
index - 要设置背景色的位置的选项卡索引
background - 要在选项卡背景中显示的颜色
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
getBackgroundAt(int)

setForegroundAt

public void setForegroundAt(int index,
                            Color foreground)
将 index 位置的前景色设置为 foreground，它可以为 null，在这种情况下选项卡的前景色默认为此 tabbedpane 的前景色。如果在该索引位置没有选项卡，则会引发一个内部异常。

参数：
index - 要设置前景色的位置的选项卡索引
foreground - 要作为选项卡前景色显示的颜色
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
getForegroundAt(int)

setEnabledAt

public void setEnabledAt(int index,
                         boolean enabled)
设置是否启用 index 位置的选项卡。如果在该索引位置没有选项卡，则会引发一个内部异常。

参数：
index - 要启用/禁用的选项卡索引
enabled - 选项卡是否启用
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
isEnabledAt(int)

setComponentAt

public void setComponentAt(int index,
                           Component component)
将 index 位置的组件设置为 component。如果在该索引位置没有选项卡，则会引发一个内部异常。

参数：
index - 此组件放置位置的选项卡索引
component - 选项卡的组件
抛出：
IndexOutOfBoundsException - 如果索引超出了范围（index < 0 || index >= tab count）
另请参见：
getComponentAt(int)

setDisplayedMnemonicIndexAt

public void setDisplayedMnemonicIndexAt(int tabIndex,
                                        int mnemonicIndex)
提供一个外观的提示，此提示是关于文本中哪此字符必须被装饰用来表示助记符。不是所有的外观都支持此功能。-1 指示两种情况，或者此选项卡没有助记符，或者用户不希望此选项卡显示助记符。

此值随着助记符相关属性的改变（例如助记符本身、文本等等）而更新。如果不需要默认字符带有下划线，则不必调用此方法。例如，如果索引为 3 的选项卡的文本为 'Apple Price'，助记符为 'p'，并且要将其装饰为 'Apple Price'，那么必须在调用 setMnemonicAt(3, KeyEvent.VK_P) 之后调用 setDisplayedMnemonicIndex(3, 6)。

注意，程序员要负责确保每个选项卡具有惟一的助记符，否则将发生不可预计的结果。

参数：
tabIndex - 助记符引用的选项卡索引
mnemonicIndex - 要加下划线的 String 的索引
抛出：
IndexOutOfBoundsException - 如果 tabIndex 超出了范围（tabIndex < 0 || tabIndex >= tab count)
IllegalArgumentException - 将被抛出，如果 mnemonicIndex >= 选项卡标题的长度或 < -1
从以下版本开始：
1.4
另请参见：
setMnemonicAt(int,int), getDisplayedMnemonicIndexAt(int)

setMnemonicAt

public void setMnemonicAt(int tabIndex,
                          int mnemonic)
设置用于访问指定选项卡的键盘助记符。助记符是一个键，在与外观的无鼠标修改键（通常为 Alt）一起使用时，它将激活指定的选项卡。

助记符必须对应于键盘上的单个键，且必须使用 java.awt.event.KeyEvent 中定义的 VK_XXX 键代码之一来指定。助记符是不区分大小写的，因此具有对应键代码的键事件将导致铵钮被激活，而不管 Shift 键是否按下。

这将更新指定选项卡所显示的助记符属性。

参数：
tabIndex - 助记符引用的选项卡的索引
mnemonic - 表示助记符的键代码
抛出：
IndexOutOfBoundsException - 如果 tabIndex 超出了范围（tabIndex < 0 || tabIndex >= tab count）
从以下版本开始：
1.4
另请参见：
getMnemonicAt(int), setDisplayedMnemonicIndexAt(int,int)

indexOfTab

public int indexOfTab(String title)
返回具有给定 title 的第一个选项卡索引，如果没有具有此标题的选项卡，则返回 -1。

参数：
title - 选项卡的标题
返回：
与 title 匹配的第一个选项卡索引，如果没有具有此标题的选项卡，则返回 -1

indexOfTab

public int indexOfTab(Icon icon)
返回具有给定的 icon 的第一个选项卡索引，如果没有具有此图标的选项卡，则返回 -1。

参数：
icon - 选项卡的图标
返回：
与 icon 匹配的第一个选项卡索引，如果没有具有此图标的选项卡，则返回 -1

indexOfComponent

public int indexOfComponent(Component component)
返回指定组件的选项卡索引。如果此组件没有选项卡，则返回 -1。

参数：
component - 选项卡的组件
返回：
与此组件匹配的第一个选项卡，如果此组件没有选项卡，则返回 -1

indexAtLocation

public int indexAtLocation(int x,
                           int y)
返回选项卡边界与指定区域相交的选项卡索引。如果没有与此区域相交的选项卡，则返回 -1。

参数：
x - 相对于此选项卡窗格的 x 位置
y - 相对于此选项卡窗格的 y 位置
返回：
与此位置相交的选项卡索引，如果没有与此位置相交的选项卡，则返回 -1
从以下版本开始：
1.4

getToolTipText

public String getToolTipText(MouseEvent event)
返回由鼠标事件位置确定的组件的工具提示文本。

覆盖：
类 JComponent 中的 getToolTipText
参数：
event - MouseEvent，它告知光标的当前位置
返回：
包含工具提示文本的 String

paramString

protected String paramString()
返回此 JTabbedPane 的字符串表示。此方法仅用于调试目的，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JTabbedPane 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JTabbedPane 关联的 AccessibleContext。对于选项卡窗格，AccessibleContext 采用 AccessibleJTabbedPane 的形式。必要时创建新的 AccessibleJTabbedPane 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJTabbedPane，它充当此 JTabbedPane 的 AccessibleContext

setTabComponentAt

public void setTabComponentAt(int index,
                              Component component)
设置负责呈现指定选项卡标题的组件。null 值意味着 JTabbedPane 将呈现指定选项卡的标题和/或图标。非 null 值意味着该组件将呈现标题，并且 JTabbedPane 将不呈现标题和/或图标。

注：该组件不得是开发人员已添加到选项卡面板中的组件之一。

参数：
index - 应该在其中设置组件的选项卡索引
component - 要呈现指定选项卡标题的组件
抛出：
IndexOutOfBoundsException - 如果索引超出了范围 (index < 0 || index >= tab count)
IllegalArgumentException - 如果组件已添加到此 JTabbedPane 中
从以下版本开始：
1.6
另请参见：
getTabComponentAt(int)

getTabComponentAt

public Component getTabComponentAt(int index)
返回 index 位置上的选项卡组件。

参数：
index - 被查询的项的索引
返回：
index 位置上的选项卡组件
抛出：
IndexOutOfBoundsException - 如果索引超出了范围 (index < 0 || index >= tab count)
从以下版本开始：
1.6
另请参见：
setTabComponentAt(int, java.awt.Component)

indexOfTabComponent

public int indexOfTabComponent(Component tabComponent)
返回指定选项卡组件的选项卡索引。如果此选项卡组件没有选项卡，则返回 -1。

参数：
tabComponent - 该选项卡的选项卡组件
返回：
匹配此选项卡组件的第一个选项卡；如果此选项卡组件没有选项卡，则返回 -1
从以下版本开始：
1.6
另请参见：
setTabComponentAt(int, java.awt.Component), getTabComponentAt(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTabbedPane.AccessibleJTabbedPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTabbedPane.AccessibleJTabbedPane

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JTabbedPane.AccessibleJTabbedPane
所有已实现的接口：
Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, ChangeListener
正在封闭类：
JTabbedPane
protected class JTabbedPane.AccessibleJTabbedPane
extends JComponent.AccessibleJComponent
implements AccessibleSelection, ChangeListener

此类实现对 JTabbedPane 类的可访问性支持。它提供适合于选项卡窗格用户界面的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JTabbedPane.AccessibleJTabbedPane()
构造 AccessibleJTabbedPane。
方法摘要
void | addAccessibleSelection(int i) 将对象的指定 Accessible 子级添加到该对象的选项中。
void | clearAccessibleSelection() 清除对象中的选项，使该对象中没有选中的子对象。
Accessible | getAccessibleAt(Point p) 返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子级。
int | getAccessibleChildrenCount() 返回对象中可访问的子级数。
String | getAccessibleName() 返回此对象的可访问名称；如果没有可访问名称，则返回 null。
AccessibleRole | getAccessibleRole() 获取此对象的功能。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回表示指定的所选对象子级的 Accessible。
int | getAccessibleSelectionCount() 返回当前选中的 Accessible 子级数。
boolean | isAccessibleChildSelected(int i) 确定此对象的当前子级是否已选中。
void | removeAccessibleSelection(int i) 从对象的选项中移除该对象的指定子对象。
void | selectAllAccessibleSelection() 如果该对象支持多项选择，则会导致该对象的每个子对象都被选中。
void | stateChanged(ChangeEvent e) 当侦听器的目标已更改其状态时调用。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JTabbedPane.AccessibleJTabbedPane

public JTabbedPane.AccessibleJTabbedPane()
构造 AccessibleJTabbedPane。

方法详细信息

getAccessibleName

public String getAccessibleName()
返回此对象的可访问名称；如果没有可访问名称，则返回 null。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleName
返回：
此对象的可访问名称或 null。
从以下版本开始：
1.6
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的功能。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象功能的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中可访问的子级数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子级。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 子级基于零的索引
返回：
对象的 Accessible 子级
抛出：
IllegalArgumentException - 如果索引超出了范围
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection。在实现此类的 Java Accessibility API 时，返回此对象，它负责代表它自己实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回包含在本地坐标 Point 中的 Accessible 子容器（如果存在）。否则返回当前选择的选项卡。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleAt
参数：
p - 定义 Accessible 左上角的点，在对象父代的坐标空间中给出
返回：
指定位置的 Accessible（如果存在）

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
从接口 AccessibleSelection 复制的描述
返回当前选中的 Accessible 子级数。如果没有选定子对象，那么返回的值将为 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选定的项数。

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
从接口 AccessibleSelection 复制的描述
返回表示指定的所选对象子级的 Accessible。如果没有选择，或者所选子级数少于传入的整数，则返回值为 null。

注意，该索引表示第 i 个选定的子对象，它不同于第 i 个子对象。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选子对象的从零开始的索引
返回：
第 i 个选定的子对象
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
从接口 AccessibleSelection 复制的描述
确定此对象的当前子级是否已选中。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子对象的从零开始的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
从接口 AccessibleSelection 复制的描述
将对象的指定 Accessible 子级添加到该对象的选项中。如果该对象支持多项选择，则将指定的子对象添加到任何现有选项中，否则，它会替换该对象中的任何现有选项。如果指定的子对象已被选定，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 子对象的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从接口 AccessibleSelection 复制的描述
从对象的选项中移除该对象的指定子对象。如果当前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 子对象的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
从接口 AccessibleSelection 复制的描述
清除对象中的选项，使该对象中没有选中的子对象。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
从接口 AccessibleSelection 复制的描述
如果该对象支持多项选择，则会导致该对象的每个子对象都被选中。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTabbedPane.ModelListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTabbedPane.ModelListener

java.lang.Object
    继承者  javax.swing.JTabbedPane.ModelListener
所有已实现的接口：
Serializable, EventListener, ChangeListener
正在封闭类：
JTabbedPane
protected class JTabbedPane.ModelListener
extends Object
implements ChangeListener, Serializable

将 ModelChanged 事件传递给侦听器，其中选项卡窗格（而不是模型本身）作为侦听器的事件源。

构造方法摘要
protected JTabbedPane.ModelListener()
方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTabbedPane.ModelListener

protected JTabbedPane.ModelListener()
方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
从接口 ChangeListener 复制的描述
当侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable.AccessibleJTable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTable.AccessibleJTable

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JTable.AccessibleJTable
所有已实现的接口：
PropertyChangeListener, Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleExtendedTable, AccessibleSelection, AccessibleTable, CellEditorListener, ListSelectionListener, TableColumnModelListener, TableModelListener
正在封闭类：
JTable
protected class JTable.AccessibleJTable
extends JComponent.AccessibleJComponent
implements AccessibleSelection, ListSelectionListener, TableModelListener, TableColumnModelListener, CellEditorListener, PropertyChangeListener, AccessibleExtendedTable

此类实现对 JTable 类的可访问性支持。它提供适合于表用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected class | JTable.AccessibleJTable.AccessibleJTableCell 此类提供了适用于表单元格的 Java Accessibility API 实现。
protected class | JTable.AccessibleJTable.AccessibleJTableModelChange
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JTable.AccessibleJTable()
AccessibleJTable 构造方法
方法摘要
void | addAccessibleSelection(int i) 将该对象的指定 Accessible 子对象添加到该对象的选择中。
void | clearAccessibleSelection() 清除该对象中的选择，使该对象中不存在选择的子对象。
void | columnAdded(TableColumnModelEvent e) 跟踪表内容的变更（列插入）
void | columnMarginChanged(ChangeEvent e) 跟踪由于空白变更而引起的列移动的变更。
void | columnMoved(TableColumnModelEvent e) 跟踪列重新定位的变更。
void | columnRemoved(TableColumnModelEvent e) 跟踪表内容的变更（列删除）
void | columnSelectionChanged(ListSelectionEvent e) 对变更的 TableColumnModel 的选择模型进行跟踪。
void | editingCanceled(ChangeEvent e) 编辑取消时调用。
void | editingStopped(ChangeEvent e) 跟踪单元格内容的变更。
Accessible | getAccessibleAt(int r, int c) 返回表中指定行和列处的 Accessible。
Accessible | getAccessibleAt(Point p) 如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。
Accessible | getAccessibleCaption() 返回此表的标题。
Accessible | getAccessibleChild(int i) 返回该对象的第 n 个 Accessible 子对象。
int | getAccessibleChildrenCount() 返回该对象中可访问的子对象数。
int | getAccessibleColumn(int index) 返回表中一个索引的列数。
int | getAccessibleColumnAtIndex(int i) 返回在表中给定的索引位置的列。
int | getAccessibleColumnCount() 返回表中的列数。
Accessible | getAccessibleColumnDescription(int c) 返回对表中指定列的描述。
int | getAccessibleColumnExtentAt(int r, int c) 返回 Accessible 在给定的 (row, column) 占用的列数。
AccessibleTable | getAccessibleColumnHeader() 返回以 AccessibleTable 表示的列标题。
int | getAccessibleIndex(int r, int c) 返回表中在某一行和某一列的索引。
int | getAccessibleIndexAt(int r, int c) 返回表中在给定的 (row, column) 位置的索引。
AccessibleRole | getAccessibleRole() 获取此对象的功能。
int | getAccessibleRow(int index) 返回表中一个索引的行数。
int | getAccessibleRowAtIndex(int i) 返回表中在一个给定的索引位置的行。
int | getAccessibleRowCount() 返回表中的行数。
Accessible | getAccessibleRowDescription(int r) 返回对表中指定行的描述。
int | getAccessibleRowExtentAt(int r, int c) 返回 Accessible 在表中指定行和列占用的行数。
AccessibleTable | getAccessibleRowHeader() 返回以 AccessibleTable 表示的行标题。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回 Accessible，它表示该对象中指定的已选择的子对象。
int | getAccessibleSelectionCount() 返回当前选择的 Accessible 子对象数。
Accessible | getAccessibleSummary() 返回表的摘要描述。
AccessibleTable | getAccessibleTable() 获取与此对象关联的 AccessibleTable。
int[] | getSelectedAccessibleColumns() 返回表中选择的列。
int[] | getSelectedAccessibleRows() 返回表中选择的行。
boolean | isAccessibleChildSelected(int i) 确定是否选择此对象的当前子对象。
boolean | isAccessibleColumnSelected(int c) 返回一个布尔值，它指示是否选择了指定的列。
boolean | isAccessibleRowSelected(int r) 返回一个布尔值，它表示是否选择了指定的行。
boolean | isAccessibleSelected(int r, int c) 返回一个布尔值，它表明在给定的 (row, column) 是否选择为可访问的。
void | propertyChange(PropertyChangeEvent e) 跟踪选择模型、列模型等的变更，从而能够重新将侦听器放置这些模型上，以便把信息传递给 Accessibility PropertyChange 机制
void | removeAccessibleSelection(int i) 从对象的选择中移除该对象的指定子对象。
void | selectAllAccessibleSelection() 只有 JTable 支持多个选择，并且单个单元格选择为启用状态时，才会导致该对象的每个子对象都被选择。
void | setAccessibleCaption(Accessible a) 设置表的标题。
void | setAccessibleColumnDescription(int c, Accessible a) 设置表中指定列的描述文本。
void | setAccessibleColumnHeader(AccessibleTable a) 设置以 AccessibleTable 表示的列标题。
void | setAccessibleRowDescription(int r, Accessible a) 设置表中指定行的描述文本。
void | setAccessibleRowHeader(AccessibleTable a) 设置以 AccessibleTable 表示的列标题。
void | setAccessibleSummary(Accessible a) 设置表的摘要描述。
void | tableChanged(TableModelEvent e) 跟踪表内容的变更
void | tableRowsDeleted(TableModelEvent e) 跟踪表内容的变更（行删除）
void | tableRowsInserted(TableModelEvent e) 跟踪表内容的变更（行插入）
void | valueChanged(ListSelectionEvent e) 跟踪表单元格选择的变更
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JTable.AccessibleJTable

protected JTable.AccessibleJTable()
AccessibleJTable 构造方法

从以下版本开始：
1.5
方法详细信息

propertyChange

public void propertyChange(PropertyChangeEvent e)
跟踪选择模型、列模型等的变更，从而能够重新将侦听器放置这些模型上，以便把信息传递给 Accessibility PropertyChange 机制

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和已更改属性的 PropertyChangeEvent 对象。

tableChanged

public void tableChanged(TableModelEvent e)
跟踪表内容的变更

指定者：
接口 TableModelListener 中的 tableChanged

tableRowsInserted

public void tableRowsInserted(TableModelEvent e)
跟踪表内容的变更（行插入）

tableRowsDeleted

public void tableRowsDeleted(TableModelEvent e)
跟踪表内容的变更（行删除）

columnAdded

public void columnAdded(TableColumnModelEvent e)
跟踪表内容的变更（列插入）

指定者：
接口 TableColumnModelListener 中的 columnAdded

columnRemoved

public void columnRemoved(TableColumnModelEvent e)
跟踪表内容的变更（列删除）

指定者：
接口 TableColumnModelListener 中的 columnRemoved

columnMoved

public void columnMoved(TableColumnModelEvent e)
跟踪列重新定位的变更。

指定者：
接口 TableColumnModelListener 中的 columnMoved
另请参见：
TableColumnModelListener

columnMarginChanged

public void columnMarginChanged(ChangeEvent e)
跟踪由于空白变更而引起的列移动的变更。

指定者：
接口 TableColumnModelListener 中的 columnMarginChanged
另请参见：
TableColumnModelListener

columnSelectionChanged

public void columnSelectionChanged(ListSelectionEvent e)
对变更的 TableColumnModel 的选择模型进行跟踪。

指定者：
接口 TableColumnModelListener 中的 columnSelectionChanged
另请参见：
TableColumnModelListener

editingStopped

public void editingStopped(ChangeEvent e)
跟踪单元格内容的变更。 当编辑结束时调用。保存变更，丢弃编辑器对象，并再次呈现单元格。

指定者：
接口 CellEditorListener 中的 editingStopped
另请参见：
CellEditorListener

editingCanceled

public void editingCanceled(ChangeEvent e)
编辑取消时调用。丢弃编辑器对象，并再次呈现单元格。

指定者：
接口 CellEditorListener 中的 editingCanceled
另请参见：
CellEditorListener

valueChanged

public void valueChanged(ListSelectionEvent e)
跟踪表单元格选择的变更

指定者：
接口 ListSelectionListener 中的 valueChanged
参数：
e - 表现更改的特征的事件。

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection。在此类的 Java Accessibility API 的实现中，返回的是此对象，它负责代表它自己实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的功能。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述该对象功能的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleAt

public Accessible getAccessibleAt(Point p)
如果存在 Accessible 子级，并且包含在本地坐标 Point 位置，则返回 Accessible 子级。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleAt
参数：
p - 该点定义该对象的父对象的坐标空间中给出的 Accessible 的左上角
返回：
如果在指定的位置存在 Accessible，则返回它；否则，返回 null

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回该对象中可访问的子对象数。如果此对象的所有子对象都实现 Accessible，那么此方法应返回此对象的子对象数。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
该对象中可访问的子对象数

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回该对象的第 n 个 Accessible 子对象。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 基于零的子对象索引
返回：
该对象的第 n 个可访问子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选择的 Accessible 子对象数。如果没有选择子对象，那么返回的值将为 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选择的项数

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回 Accessible，它表示该对象中指定的已选择的子对象。如果没有选择，或选择的子对象数小于传入的整数，那么返回的值将为 null。

注意，该索引表示第 i 个已选择的子对象，它不同于第 i 个子对象。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选子对象的基于零的索引
返回：
第 i 个已选择的子对象
另请参见：
getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
确定是否选择此对象的当前子对象。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子对象基于 0 的索引
返回：
true 如果选择此对象的当前子对象
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将该对象的指定 Accessible 子对象添加到该对象的选择中。如果该对象支持多个选择，则将指定的子对象添加到任何现有选择中，否则，它会替换该对象中的任何现有选择。如果指定的子对象已被选择，则此方法无效。

此方法只对 JTable 有效，它的单个单元格选择是启用的。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 子对象的基于零的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
从对象的选择中移除该对象的指定子对象。如果当前没有选择指定的项，则此方法无效。

此方法只对 JTables 有效，它的单个单元格选择是启用的。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 子对象的基于零的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除该对象中的选择，使该对象中不存在选择的子对象。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
只有 JTable 支持多个选择，并且单个单元格选择为启用状态时，才会导致该对象的每个子对象都被选择。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection

getAccessibleRow

public int getAccessibleRow(int index)
返回表中一个索引的行数。

指定者：
接口 AccessibleExtendedTable 中的 getAccessibleRow
参数：
index - 此表中基于 0 的索引
返回：
表中基于 0 的行（如果存在）；否则返回 -1
从以下版本开始：
1.4

getAccessibleColumn

public int getAccessibleColumn(int index)
返回表中一个索引的列数。

指定者：
接口 AccessibleExtendedTable 中的 getAccessibleColumn
参数：
index - 此表中基于 0 的索引
返回：
表中基于 0 的列（如果存在）；否则返回 -1
从以下版本开始：
1.4

getAccessibleIndex

public int getAccessibleIndex(int r,
                              int c)
返回表中在某一行和某一列的索引。

指定者：
接口 AccessibleExtendedTable 中的 getAccessibleIndex
参数：
r - 表中基于 0 的行
c - 表中基于 0 的列
返回：
表中基于 0 的索引（如果存在）；否则返回 -1。
从以下版本开始：
1.4

getAccessibleTable

public AccessibleTable getAccessibleTable()
获取与此对象关联的 AccessibleTable。在实现此类的 Java Accessibility API 时，返回此对象，它负责代表它自己实现 AccessibleTables 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleTable
返回：
此对象
从以下版本开始：
1.3
另请参见：
AccessibleTable

getAccessibleCaption

public Accessible getAccessibleCaption()
返回此表的标题。

指定者：
接口 AccessibleTable 中的 getAccessibleCaption
返回：
表的标题
从以下版本开始：
1.3

setAccessibleCaption

public void setAccessibleCaption(Accessible a)
设置表的标题。

指定者：
接口 AccessibleTable 中的 setAccessibleCaption
参数：
a - 表的标题
从以下版本开始：
1.3

getAccessibleSummary

public Accessible getAccessibleSummary()
返回表的摘要描述。

指定者：
接口 AccessibleTable 中的 getAccessibleSummary
返回：
表的摘要描述
从以下版本开始：
1.3

setAccessibleSummary

public void setAccessibleSummary(Accessible a)
设置表的摘要描述。

指定者：
接口 AccessibleTable 中的 setAccessibleSummary
参数：
a - 表的摘要描述
从以下版本开始：
1.3

getAccessibleRowCount

public int getAccessibleRowCount()
从接口 AccessibleTable 复制的描述
返回表中的行数。

指定者：
接口 AccessibleTable 中的 getAccessibleRowCount
返回：
该表中的行数

getAccessibleColumnCount

public int getAccessibleColumnCount()
从接口 AccessibleTable 复制的描述
返回表中的列数。

指定者：
接口 AccessibleTable 中的 getAccessibleColumnCount
返回：
该表中的列数

getAccessibleAt

public Accessible getAccessibleAt(int r,
                                  int c)
从接口 AccessibleTable 复制的描述
返回表中指定行和列处的 Accessible。

指定者：
接口 AccessibleTable 中的 getAccessibleAt
参数：
r - 表中基于零的行
c - 表中基于零的列
返回：
在指定行和列处的 Accessible

getAccessibleRowExtentAt

public int getAccessibleRowExtentAt(int r,
                                    int c)
返回 Accessible 在表中指定行和列占用的行数。

指定者：
接口 AccessibleTable 中的 getAccessibleRowExtentAt
返回：
Accessible 在表中指定行和列占用的行数
从以下版本开始：
1.3

getAccessibleColumnExtentAt

public int getAccessibleColumnExtentAt(int r,
                                       int c)
返回 Accessible 在给定的 (row, column) 占用的列数。

指定者：
接口 AccessibleTable 中的 getAccessibleColumnExtentAt
返回：
Accessible 在表中指定行和列占用的列数
从以下版本开始：
1.3

getAccessibleRowHeader

public AccessibleTable getAccessibleRowHeader()
返回以 AccessibleTable 表示的行标题。

指定者：
接口 AccessibleTable 中的 getAccessibleRowHeader
返回：
表示行标题的 AccessibleTable
从以下版本开始：
1.3

setAccessibleRowHeader

public void setAccessibleRowHeader(AccessibleTable a)
设置以 AccessibleTable 表示的列标题。

指定者：
接口 AccessibleTable 中的 setAccessibleRowHeader
参数：
a - 表示行标题的 AccessibleTable
从以下版本开始：
1.3

getAccessibleColumnHeader

public AccessibleTable getAccessibleColumnHeader()
返回以 AccessibleTable 表示的列标题。

指定者：
接口 AccessibleTable 中的 getAccessibleColumnHeader
返回：
表示列标题的 AccessibleTable，如果表头为 null，则返回 null
从以下版本开始：
1.3

setAccessibleColumnHeader

public void setAccessibleColumnHeader(AccessibleTable a)
设置以 AccessibleTable 表示的列标题。

指定者：
接口 AccessibleTable 中的 setAccessibleColumnHeader
参数：
a - 表示列标题的 AccessibleTable
从以下版本开始：
1.3

getAccessibleRowDescription

public Accessible getAccessibleRowDescription(int r)
返回对表中指定行的描述。

指定者：
接口 AccessibleTable 中的 getAccessibleRowDescription
参数：
r - 表的基于 0 的索引
返回：
行的描述
从以下版本开始：
1.3

setAccessibleRowDescription

public void setAccessibleRowDescription(int r,
                                        Accessible a)
设置表中指定行的描述文本。

指定者：
接口 AccessibleTable 中的 setAccessibleRowDescription
参数：
r - 表中基于 0 的索引
a - 行的描述
从以下版本开始：
1.3

getAccessibleColumnDescription

public Accessible getAccessibleColumnDescription(int c)
返回对表中指定列的描述。

指定者：
接口 AccessibleTable 中的 getAccessibleColumnDescription
参数：
r - 表的基于 0 的列
返回：
列的描述
从以下版本开始：
1.3

setAccessibleColumnDescription

public void setAccessibleColumnDescription(int c,
                                           Accessible a)
设置表中指定列的描述文本。

指定者：
接口 AccessibleTable 中的 setAccessibleColumnDescription
参数：
c - 表中基于 0 的列
a - 列的描述
从以下版本开始：
1.3

isAccessibleSelected

public boolean isAccessibleSelected(int r,
                                    int c)
返回一个布尔值，它表明在给定的 (row, column) 是否选择为可访问的。

指定者：
接口 AccessibleTable 中的 isAccessibleSelected
参数：
r - 表的基于 0 的行
c - 表的基于 0 的列
返回：
如果在 (row, column) 选择了可访问性，则返回布尔值 true；否则返回布尔值 false
从以下版本开始：
1.3

isAccessibleRowSelected

public boolean isAccessibleRowSelected(int r)
返回一个布尔值，它表示是否选择了指定的行。

指定者：
接口 AccessibleTable 中的 isAccessibleRowSelected
参数：
r - 表的基于 0 的行
返回：
如果选择了指定的行，则返回布尔值 true；否则返回 false
从以下版本开始：
1.3

isAccessibleColumnSelected

public boolean isAccessibleColumnSelected(int c)
返回一个布尔值，它指示是否选择了指定的列。

指定者：
接口 AccessibleTable 中的 isAccessibleColumnSelected
参数：
c - 表的基于 0 的列
返回：
如果选择了指定的列，则返回布尔值 true；否则返回 false
从以下版本开始：
1.3

getSelectedAccessibleRows

public int[] getSelectedAccessibleRows()
返回表中选择的行。

指定者：
接口 AccessibleTable 中的 getSelectedAccessibleRows
返回：
选择的行的数组，其中每个元素都是表中一个基于 0 的行
从以下版本开始：
1.3

getSelectedAccessibleColumns

public int[] getSelectedAccessibleColumns()
返回表中选择的列。

指定者：
接口 AccessibleTable 中的 getSelectedAccessibleColumns
返回：
选择的列的数组，其中每个元素都是表中一个基于 0 的列
从以下版本开始：
1.3

getAccessibleRowAtIndex

public int getAccessibleRowAtIndex(int i)
返回表中在一个给定的索引位置的行。

参数：
i - 表的基于 0 的索引
返回：
在给定的索引位置的行
从以下版本开始：
1.3

getAccessibleColumnAtIndex

public int getAccessibleColumnAtIndex(int i)
返回在表中给定的索引位置的列。

参数：
i - 表的基于 0 的索引
返回：
在给定的索引位置的列
从以下版本开始：
1.3

getAccessibleIndexAt

public int getAccessibleIndexAt(int r,
                                int c)
返回表中在给定的 (row, column) 位置的索引。

参数：
r - 表中基于 0 的行
c - 表中基于 0 的列
返回：
表的索引
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable.AccessibleJTable.AccessibleJTableCell (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTable.AccessibleJTable.AccessibleJTableCell

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.JTable.AccessibleJTable.AccessibleJTableCell
所有已实现的接口：
Accessible, AccessibleComponent
正在封闭类：
JTable.AccessibleJTable
protected class JTable.AccessibleJTable.AccessibleJTableCell
extends AccessibleContext
implements Accessible, AccessibleComponent

此类提供了适用于表单元格的 Java Accessibility API 实现。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JTable.AccessibleJTable.AccessibleJTableCell(JTable t, int r, int c, int i)
构造一个 AccessibleJTableHeaderEntry。
方法摘要
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将一个 PropertyChangeListener 添加到侦听器列表中。
boolean | contains(Point p) 检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。
AccessibleAction | getAccessibleAction() 获取与此对象关联的 AccessibleAction（如果存在）。
Accessible | getAccessibleAt(Point p) 返回本地坐标 Point 包含的可访问子级（如果存在）。
Accessible | getAccessibleChild(int i) 返回此对象的指定的 Accessible 子对象。
int | getAccessibleChildrenCount() 返回此对象中可访问的子对象数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent（如果存在）。
AccessibleContext | getAccessibleContext() 获取与此组件关联的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的可访问的描述。
int | getAccessibleIndexInParent() 获取此对象在其可访问的父对象中的索引。
String | getAccessibleName() 获取此对象的可访问的名称。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获取此对象的功能。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleText | getAccessibleText() 获取与此对象关联的 AccessibleText （如果存在）。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
protected AccessibleContext | getCurrentAccessibleContext() 获取表单元格渲染器的 AccessibleContext。
protected Component | getCurrentComponent() 获取表单元格渲染器组件。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取该组件的语言环境。
Point | getLocation() 以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isEnabled() 确定是否启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定该对象是否正在显示。
boolean | isVisible() 确定该对象是否可见。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表移除一个 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | setAccessibleDescription(String s) 设置此对象的可访问的描述。
void | setAccessibleName(String s) 获取此对象的可访问的本地化名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置该对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置该对象相对于父对象的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置该对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTable.AccessibleJTable.AccessibleJTableCell

public JTable.AccessibleJTable.AccessibleJTableCell(JTable t,
                                                    int r,
                                                    int c,
                                                    int i)
构造一个 AccessibleJTableHeaderEntry。

从以下版本开始：
1.4
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此组件关联的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它是其本身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getCurrentAccessibleContext

protected AccessibleContext getCurrentAccessibleContext()
获取表单元格渲染器的 AccessibleContext。

返回：
表单元格渲染器的 AccessibleContext（如果存在）；否则返回 null。
从以下版本开始：
1.6

getCurrentComponent

protected Component getCurrentComponent()
获取表单元格渲染器组件。

返回：
表单元格渲染器组件（如果存在）；否则返回 null
从以下版本开始：
1.6

getAccessibleName

public String getAccessibleName()
获取此对象的可访问的名称。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
此对象的本地化名称，如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
获取此对象的可访问的本地化名称。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 此对象新的本地化名称
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问的描述。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
此对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
设置此对象的可访问的描述。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的功能。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述此对象功能的 AccessibleRole 的实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含该对象当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
此对象的可访问的父对象；如果此对象没有 Accessible 父对象，则返回 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问的父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
此对象在其父对象中的索引；如果此对象没有可访问的父对象，则返回 -1
另请参见：
getAccessibleParent()

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回此对象中可访问的子对象数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
此对象中可访问的子对象数

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回此对象的指定的 Accessible 子对象。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 基于 0 的子容器索引
返回：
对象的 Accessible 子容器
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

指定者：
类 AccessibleContext 中的 getLocale
返回：
组件的语言环境；如果此组件没有语言环境，则返回其父级的语言环境
抛出：
IllegalComponentStateException - 如果 Component 没有其自己的语言环境，并且尚未添加到包含层次结构中（如果添加到包含层次结构中就可以从其父级确定语言环境）
另请参见：
Component.setLocale(java.util.Locale)

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
将一个 PropertyChangeListener 添加到侦听器列表中。侦听器为所有的属性注册。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从侦听器列表移除一个 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的 AccessibleAction（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
AccessibleAction 或 null
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
AccessibleComponent 或 null
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
AccessibleSelection 或 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
获取与此对象关联的 AccessibleText （如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
AccessibleText 或 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue（如果存在）。否则返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
AccessibleValue 或 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
该对象的背景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 该背景的新 Color
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
该对象的前景色（如果受支持）；否则，返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 该前景的新的 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
对象的 Cursor（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 此对象的新的 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
该对象的 Font（如果受支持）；否则，返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 该对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
FontMetrics 对象（如果受支持）；否则返回 null
另请参见：
getFont()

isEnabled

public boolean isEnabled()
确定是否启用该对象。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果启用了该对象，则返回 true；否则，返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
设置该对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则，禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
确定该对象是否可见。注：这意味着该对象是可见的；但是，它实际上不显示在屏幕上，因为包含此对象的对象中的一个对象不可见。要确定某一对象是否在屏幕上显示，请使用 isShowing。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则，返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
设置该对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则，隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
确定该对象是否正在显示。通过检查该对象的可见性和祖先可确定这一点。注：这将返回 true，即使该对象被另一个对象遮掩（例如，该对象碰巧在下拉菜单的下面）。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果对象正在显示，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
检查指定的点是否在此对象的边界内，其中点的 x 和 y 坐标被定义成与该对象的坐标系统相关。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 与该对象的坐标系统相关的 Point
返回：
如果对象包含 Point，则返回 true；否则，返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
屏幕上对象的位置（如果此对象不在屏幕上，则可以为 null）
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocation

public Point getLocation()
以点（指定屏幕坐标空间中对象的左上角）的形式获取该对象相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
表示该屏幕坐标空间中对象边界的左上角的 Point的实例；如果此对象或其父对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
设置该对象相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
从接口 AccessibleComponent 复制的描述
返回本地坐标 Point 包含的可访问子级（如果存在）。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 相对于此对象坐标系统的 point。
返回：
如果存在，则返回指定位置处的 Accessible；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable.AccessibleJTable.AccessibleJTableModelChange (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTable.AccessibleJTable.AccessibleJTableModelChange

java.lang.Object
    继承者  javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange
所有已实现的接口：
AccessibleTableModelChange
正在封闭类：
JTable.AccessibleJTable
protected class JTable.AccessibleJTable.AccessibleJTableModelChange
extends Object
implements AccessibleTableModelChange

字段摘要
protected int | firstColumn
protected int | firstRow
protected int | lastColumn
protected int | lastRow
protected int | type
从接口 javax.accessibility.AccessibleTableModelChange 继承的字段
DELETE, INSERT, UPDATE
构造方法摘要
protected JTable.AccessibleJTable.AccessibleJTableModelChange(int type, int firstRow, int lastRow, int firstColumn, int lastColumn)
方法摘要
int | getFirstColumn() 返回已更改的第一列。
int | getFirstRow() 返回已更改的第一行。
int | getLastColumn() 返回已更改的最后一列。
int | getLastRow() 返回已更改的最后一行。
int | getType() 返回事件的类型
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

type

protected int type

firstRow

protected int firstRow

lastRow

protected int lastRow

firstColumn

protected int firstColumn

lastColumn

protected int lastColumn
构造方法详细信息

JTable.AccessibleJTable.AccessibleJTableModelChange

protected JTable.AccessibleJTable.AccessibleJTableModelChange(int type,
                                                              int firstRow,
                                                              int lastRow,
                                                              int firstColumn,
                                                              int lastColumn)
方法详细信息

getType

public int getType()
从接口 AccessibleTableModelChange 复制的描述
返回事件的类型

指定者：
接口 AccessibleTableModelChange 中的 getType
另请参见：
AccessibleTableModelChange.INSERT, AccessibleTableModelChange.UPDATE, AccessibleTableModelChange.DELETE

getFirstRow

public int getFirstRow()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的第一行。

指定者：
接口 AccessibleTableModelChange 中的 getFirstRow

getLastRow

public int getLastRow()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的最后一行。

指定者：
接口 AccessibleTableModelChange 中的 getLastRow

getFirstColumn

public int getFirstColumn()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的第一列。

指定者：
接口 AccessibleTableModelChange 中的 getFirstColumn

getLastColumn

public int getLastColumn()
从接口 AccessibleTableModelChange 复制的描述
返回已更改的最后一列。

指定者：
接口 AccessibleTableModelChange 中的 getLastColumn
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable.DropLocation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTable.DropLocation

java.lang.Object
    继承者  javax.swing.TransferHandler.DropLocation
        继承者  javax.swing.JTable.DropLocation
正在封闭类：
JTable
public static final class JTable.DropLocation
extends TransferHandler.DropLocation

TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。

从以下版本开始：
1.6
另请参见：
JTable.getDropLocation()

方法摘要
int | getColumn() 返回表中应该用来放入放置项的列索引。
int | getRow() 返回表中应该用来放入放置项的行索引。
boolean | isInsertColumn() 返回此位置是否表示一个列的插入位置。
boolean | isInsertRow() 返回此位置是否表示一个行的插入位置。
String | toString() 返回此放置位置的字符串表示形式。
从类 javax.swing.TransferHandler.DropLocation 继承的方法
getDropPoint
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getRow

public int getRow()
返回表中应该用来放入放置项的行索引。对该值的解释取决于 isInsertRow() 的返回值。如果该方法返回 true，则此值指示新行应该插入的位置的索引。否则，它表示将放置数据的现有行的值。此索引是基于视图的。

-1 指示放置操作发生在空格上，无法计算行。

返回：
放置行

getColumn

public int getColumn()
返回表中应该用来放入放置项的列索引。对该值的解释取决于 isInsertColumn() 的返回值。如果该方法返回 true，则此值指示新列应该插入的位置的索引。否则，它表示将放置数据的现有列的值。此索引是基于视图的。

-1 指示放置操作发生在空格上，无法计算列。

返回：
放置列

isInsertRow

public boolean isInsertRow()
返回此位置是否表示一个行的插入位置。

返回：
此位置是否是一个插入行

isInsertColumn

public boolean isInsertColumn()
返回此位置是否表示一个列的插入位置。

返回：
此位置是否是一个插入列

toString

public String toString()
返回此放置位置的字符串表示形式。此方法仅用于调试，对于各个实现，所返回字符串的内容和格式可能有所不同。

覆盖：
类 TransferHandler.DropLocation 中的 toString
返回：
此放置位置的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTable.PrintMode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing
枚举 JTable.PrintMode

java.lang.Object
    继承者  java.lang.Enum<JTable.PrintMode>
        继承者  javax.swing.JTable.PrintMode
所有已实现的接口：
Serializable, Comparable<JTable.PrintMode>
正在封闭类：
JTable
public static enum JTable.PrintMode
extends Enum<JTable.PrintMode>

用于打印 JTable 的打印模式。

从以下版本开始：
1.5
另请参见：
JTable.print(JTable.PrintMode, MessageFormat, MessageFormat, boolean, PrintRequestAttributeSet, boolean), JTable.getPrintable(javax.swing.JTable.PrintMode, java.text.MessageFormat, java.text.MessageFormat)

枚举常量摘要
FIT_WIDTH
按比例将输出缩小的打印模式（如果必要），以便每页可以放入表的整个宽度（这样就能够放入所有的列）；如果必要，行可以分散到多页。
NORMAL
以表的当前尺寸进行打印的打印模式，如果必要，把行和列分散到多页。
方法摘要
static JTable.PrintMode | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static JTable.PrintMode[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

NORMAL

public static final JTable.PrintMode NORMAL
以表的当前尺寸进行打印的打印模式，如果必要，把行和列分散到多页。

FIT_WIDTH

public static final JTable.PrintMode FIT_WIDTH
按比例将输出缩小的打印模式（如果必要），以便每页可以放入表的整个宽度（这样就能够放入所有的列）；如果必要，行可以分散到多页。

方法详细信息

values

public static final JTable.PrintMode[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(JTable.PrintMode c : JTable.PrintMode.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static JTable.PrintMode valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


JTextArea (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTextArea

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
                    继承者  javax.swing.JTextArea
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
public class JTextArea
extends JTextComponent

JTextArea 是一个显示纯文本的多行区域。它作为一个轻量级组件，提供与 java.awt.TextArea 类的源兼容性，理应如此。有关使用所有文本组件的信息和示例，请参阅 The Java Tutorial 中 Using Text Components 一节。

此组件具有 java.awt.TextArea 类中没有的功能。有关其他功能，请参考超类。还有 JTextPane 和 JEditorPane 也是具有更多功能的多行文本类。

java.awt.TextArea 在内部处理滚动。JTextArea 的不同之处在于，它不管理滚动，但实现了 swing Scrollable 接口。这允许把它放置在 JScrollPane 的内部（如果需要滚动行为），或者直接使用（如果不需要滚动）。

java.awt.TextArea 具有换行能力。这由水平滚动策略来控制。由于滚动不是由 JTextArea 直接完成的，因此必须通过另一种方式来提供向后兼容性。JTextArea 具有用于换行的绑定 (bound) 属性，该属性控制其是否换行。在默认情况下，换行属性设置为 false（不换行）。

java.awt.TextArea 具有两个属性 rows 和 columns，这两个属性用来确定首选大小。JTextArea 用这些属性来指示 viewport 的首选大小，此 viewport 被放置到 JScrollPane 中以匹配由 java.awt.TextArea 提供的功能。JTextArea 具有显示所有文本所需的首选大小，以便在 JScrollPane 内部正常工作。如果 rows 或 columns 的值等于 0，则沿该轴的首选大小将用于沿相同轴上 viewport 的首选大小。

可以通过添加一个 TextEvent 的 TextListener 来对 java.awt.TextArea 的更改进行监视。在基于 JTextComponent 的组件中，更改通过 DocumentEvent 从模型传播到 DocumentListeners。DocumentEvent 给出了更改的位置和更改种类（如果需要）。代码片段如下所示：

    DocumentListener myListener = ??;
    JTextArea myArea = ??;
    myArea.getDocument().addDocumentListener(myListener);

换行
有关如何处理换行的讨论，请参阅 DefaultEditorKit。

警告：Swing 不是线程安全的。有关更多信息，请参阅　Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JTextPane, JEditorPane

嵌套类摘要
protected  class JTextArea.AccessibleJTextArea
此类实现对 JTextArea 类的可访问性支持。
从类 javax.swing.text.JTextComponent 继承的嵌套类/接口
JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.text.JTextComponent 继承的字段
DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTextArea()
构造新的 TextArea。
JTextArea(Document doc)
构造新的 JTextArea，使其具有给定的文档模型，所有其他参数均默认为 (null, 0, 0)。
JTextArea(Document doc, String text, int rows, int columns)
构造具有指定行数和列数以及给定模型的新的 JTextArea。
JTextArea(int rows, int columns)
构造具有指定行数和列数的新的空 TextArea。
JTextArea(String text)
构造显示指定文本的新的 TextArea。
JTextArea(String text, int rows, int columns)
构造具有指定文本、行数和列数的新的 TextArea。
方法摘要
void | append(String str) 将给定文本追加到文档结尾。
protected Document | createDefaultModel() 如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
AccessibleContext | getAccessibleContext() 获取与此 JTextArea 关联的 AccessibleContext。
int | getColumns() 返回 TextArea 中的列数。
protected int | getColumnWidth() 获取列的宽度。
int | getLineCount() 确定文本区中所包含的行数。
int | getLineEndOffset(int line) 确定给定行结尾处的偏移量。
int | getLineOfOffset(int offset) 将组件文本中的偏移量转换为行号。
int | getLineStartOffset(int line) 确定给定行起始处的偏移量。
boolean | getLineWrap() 获取文本区的换行策略。
Dimension | getPreferredScrollableViewportSize() 如果此组件被嵌入 JScrollPane 中，则返回 viewport 的首选大小。
Dimension | getPreferredSize() 返回 TextArea 的首选大小。
protected int | getRowHeight() 定义行高的意义。
int | getRows() 返回 TextArea 中的行数。
boolean | getScrollableTracksViewportWidth() 如果 viewport 总是强制要求此 Scrollable 的宽度与 viewport 的宽度相匹配，则返回 true。
int | getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应根据方向的值计算滚动增量，此滚动增量将完全显示一个新行或新列。
int | getTabSize() 获取用于扩展选项卡的字符数。
String | getUIClassID() 返回 UI 的类 ID。
boolean | getWrapStyleWord() 获取换行方式（如果文本区要换行）。
void | insert(String str, int pos) 将指定文本插入指定位置。
protected String | paramString() 返回此 JTextArea 的字符串表示形式。
void | replaceRange(String str, int start, int end) 用给定的新文本替换从指示的起始位置到结尾位置的文本。
void | setColumns(int columns) 设置此 TextArea 中的列数。
void | setFont(Font f) 设置当前字体。
void | setLineWrap(boolean wrap) 设置文本区的换行策略。
void | setRows(int rows) 设置此 TextArea 的行数。
void | setTabSize(int size) 设置选项卡要扩大到的字符数。
void | setWrapStyleWord(boolean word) 设置换行方式（如果文本区要换行）。
从类 javax.swing.text.JTextComponent 继承的方法
addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getActions, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDocument, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JTextArea

public JTextArea()
构造新的 TextArea。设置默认的模型，初始字符串为 null，行/列设置为 0。

JTextArea

public JTextArea(String text)
构造显示指定文本的新的 TextArea。创建默认模型，行/列设置为 0。

参数：
text - 要显示的文本，或者为 null

JTextArea

public JTextArea(int rows,
                 int columns)
构造具有指定行数和列数的新的空 TextArea。创建默认模型，初始字符串为 null。

参数：
rows - 行数 >= 0
columns - 列数 >= 0
抛出：
IllegalArgumentException - 如果行或列参数为负数。

JTextArea

public JTextArea(String text,
                 int rows,
                 int columns)
构造具有指定文本、行数和列数的新的 TextArea。创建默认模型。

参数：
text - 要显示的文本，或者为 null
rows - 行数 >= 0
columns - 列数 >= 0
抛出：
IllegalArgumentException - 如果行或列参数为负数。

JTextArea

public JTextArea(Document doc)
构造新的 JTextArea，使其具有给定的文档模型，所有其他参数均默认为 (null, 0, 0)。

参数：
doc - 要使用的模型

JTextArea

public JTextArea(Document doc,
                 String text,
                 int rows,
                 int columns)
构造具有指定行数和列数以及给定模型的新的 JTextArea。所有构造方法均调用此构造方法。

参数：
doc - 要使用的模型，如果为 null，则创建一个默认的模型
text - 要显示的文本，如果没有文本，则为 null
rows - 行数 >= 0
columns - 列数 >= 0
抛出：
IllegalArgumentException - 如果行或列参数为负数。
方法详细信息

getUIClassID

public String getUIClassID()
返回 UI 的类 ID。

覆盖：
类 JComponent 中的 getUIClassID
返回：
ID ("TextAreaUI")
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

createDefaultModel

protected Document createDefaultModel()
如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。返回 PlainDocument 的一个新的实例。

返回：
默认的文档模型

setTabSize

public void setTabSize(int size)
设置选项卡要扩大到的字符数。此数将与可变宽度字体的最大 advance 相乘。当选项卡大小变化时将激发 PropertyChange 事件（"tabSize"）。

参数：
size - 要扩大到的字符数
另请参见：
getTabSize()

getTabSize

public int getTabSize()
获取用于扩展选项卡的字符数。如果文档为 null 或者没有选项卡设置，则返回默认值 8。

返回：
字符数

setLineWrap

public void setLineWrap(boolean wrap)
设置文本区的换行策略。如果设置为 true，则当行的长度大于所分配的宽度时，将换行。如果设置为 false，则始终不换行。当策略更改时，将激发 PropertyChange 事件（"lineWrap"）。此属性默认为 false。

参数：
wrap - 指示是否应该换行
另请参见：
getLineWrap()

getLineWrap

public boolean getLineWrap()
获取文本区的换行策略。如果设置为 true，则当行的长度大于所分配的宽度时，将换行。如果设置为 false，则始终不换行。

返回：
是否换行

setWrapStyleWord

public void setWrapStyleWord(boolean word)
设置换行方式（如果文本区要换行）。如果设置为 true，则当行的长度大于所分配的宽度时，将在单词边界（空白）处换行。如果设置为 false，则将在字符边界处换行。此属性默认为 false。

参数：
word - 指示是否应该使用单词边界来换行
另请参见：
getWrapStyleWord()

getWrapStyleWord

public boolean getWrapStyleWord()
获取换行方式（如果文本区要换行）。如果设置为 true，则当行的长度大于所分配的宽度时，将在单词边界（即空白）处换行。如果设置为 false，则将在字符边界处换行。

返回：
换行方式是否应该为单词边界，而不是字符边界
另请参见：
setWrapStyleWord(boolean)

getLineOfOffset

public int getLineOfOffset(int offset)
                    throws BadLocationException
将组件文本中的偏移量转换为行号。

参数：
offset - 偏移量 >= 0
返回：
行号 >= 0
抛出：
BadLocationException - 如果偏移量小于 0 或大于文档长度。

getLineCount

public int getLineCount()
确定文本区中所包含的行数。

返回：
行数 > 0

getLineStartOffset

public int getLineStartOffset(int line)
                       throws BadLocationException
确定给定行起始处的偏移量。

参数：
line - 要转换的行号 >= 0
返回：
偏移量 >= 0
抛出：
BadLocationException - 如果 line 小于 0 或大于等于文档中所包含的行数（由 getLineCount 进行报告）。

getLineEndOffset

public int getLineEndOffset(int line)
                     throws BadLocationException
确定给定行结尾处的偏移量。

参数：
line - 行 >= 0
返回：
偏移量 >= 0
抛出：
BadLocationException - 如果 line 小于 0 或大于等于文档所包含的行数（由 getLineCount 报告）。

insert

public void insert(String str,
                   int pos)
将指定文本插入指定位置。如果模型为 null 或者文本为 null 或空，则不执行任何操作。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
str - 要插入的文本
pos - 插入的位置 >= 0
抛出：
IllegalArgumentException - 如果 pos 在模型中是一个无效的位置
另请参见：
replaceRange(java.lang.String, int, int)

append

public void append(String str)
将给定文本追加到文档结尾。如果模型为 null 或者字符串为 null 或空，则不执行任何操作。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
str - 要插入的文本
另请参见：
insert(java.lang.String, int)

replaceRange

public void replaceRange(String str,
                         int start,
                         int end)
用给定的新文本替换从指示的起始位置到结尾位置的文本。如果模型为 null，则不执行任何操作。如果新字符串为 null 或为空，则只执行简单的删除操作。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
str - 要用来替换的文本
start - 起始位置 >= 0
end - 结尾位置 >= start
抛出：
IllegalArgumentException - 如果模型中的部分范围是无效的位置
另请参见：
insert(java.lang.String, int), replaceRange(java.lang.String, int, int)

getRows

public int getRows()
返回 TextArea 中的行数。

返回：
行数 > 0

setRows

public void setRows(int rows)
设置此 TextArea 的行数。设置新值之后调用 invalidate()。

参数：
rows - 行数 >= 0
抛出：
IllegalArgumentException - 如果 rows 小于 0
另请参见：
getRows()

getRowHeight

protected int getRowHeight()
定义行高的意义。默认为字体的高度。

返回：
高度 >= 1

getColumns

public int getColumns()
返回 TextArea 中的列数。

返回：
列数 >= 0

setColumns

public void setColumns(int columns)
设置此 TextArea 中的列数。设置新值之后执行 invalidate()。

参数：
columns - 列数 >= 0
抛出：
IllegalArgumentException - 如果列小于 0
另请参见：
getColumns()

getColumnWidth

protected int getColumnWidth()
获取列的宽度。对某些字体而言列的概念不是很有意义。此方法用来定义列的宽度。对于所使用的字体，默认情况下这将被定义为字符 m 的宽度。此方法可以被重新定义为一些其他替代量。

返回：
列的宽度 >= 1

getPreferredSize

public Dimension getPreferredSize()
返回 TextArea 的首选大小。这是显示文本所需的大小和 viewport 所要求大小的最大值。

覆盖：
类 JComponent 中的 getPreferredSize
返回：
大小
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

setFont

public void setFont(Font f)
设置当前字体。这将移除缓存的行高和列宽，以便新的字体能够反映出来，并且调用 revalidate()。

覆盖：
类 JComponent 中的 setFont
参数：
f - 要使用的当前字体
另请参见：
Component.getFont()

paramString

protected String paramString()
返回此 JTextArea 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JTextComponent 中的 paramString
返回：
此 JTextArea 的字符串表示形式。

getScrollableTracksViewportWidth

public boolean getScrollableTracksViewportWidth()
如果 viewport 总是强制要求此 Scrollable 的宽度与 viewport 的宽度相匹配，则返回 true。如果换行策略为 true，则此实现返回 true，如果不换行，则返回 false。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportWidth
覆盖：
类 JTextComponent 中的 getScrollableTracksViewportWidth
返回：
如果 viewport 应强制要求 Scrollables 宽度与其自己的宽度相匹配，则返回 true。

getPreferredScrollableViewportSize

public Dimension getPreferredScrollableViewportSize()
如果此组件被嵌入 JScrollPane 中，则返回 viewport 的首选大小。这将使用预期的列和行设置（如果已经设置），否则使用超类行为。

指定者：
接口 Scrollable 中的 getPreferredScrollableViewportSize
覆盖：
类 JTextComponent 中的 getPreferredScrollableViewportSize
返回：
JViewport 的 preferredSize，其中 JViewport 的视图为此 Scrollable。
另请参见：
JComponent.getPreferredSize()

getScrollableUnitIncrement

public int getScrollableUnitIncrement(Rectangle visibleRect,
                                      int orientation,
                                      int direction)
显示逻辑行或列的组件应根据方向的值计算滚动增量，此滚动增量将完全显示一个新行或新列。此实现使用 getRowHeight 和 getColumnWidth 方法返回的值。

用户每次请求一个单元滚动时，滚动容器（例如 JScrollPane）都将使用此方法。

指定者：
接口 Scrollable 中的 getScrollableUnitIncrement
覆盖：
类 JTextComponent 中的 getScrollableUnitIncrement
参数：
visibleRect - viewport 中可见的视图区域
orientation - 或者是 SwingConstants.VERTICAL 或者是 SwingConstants.HORIZONTAL.
direction - 小于 0 时为向左/上滚动，大于 0 时为向右/下滚动。
返回：
在指定方向滚动的 "单位" 增量
抛出：
IllegalArgumentException - 如果方向无效
另请参见：
JScrollBar.setUnitIncrement(int),
getRowHeight(),
getColumnWidth()

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JTextArea 关联的 AccessibleContext。对于 JTextAreas，AccessibleContext 采取 AccessibleJTextArea 的形式。必要时创建新的 AccessibleJTextArea 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JTextComponent 中的 getAccessibleContext
返回：
一个 AccessibleJTextArea，它充当此 JTextArea 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextArea.AccessibleJTextArea (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTextArea.AccessibleJTextArea

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.text.JTextComponent.AccessibleJTextComponent
                        继承者  javax.swing.JTextArea.AccessibleJTextArea
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
正在封闭类：
JTextArea
protected class JTextArea.AccessibleJTextArea
extends JTextComponent.AccessibleJTextComponent

此类实现对 JTextArea 类的可访问性支持。它提供适合文本区域用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
从接口 javax.accessibility.AccessibleExtendedText 继承的字段
ATTRIBUTE_RUN, LINE
构造方法摘要
protected JTextArea.AccessibleJTextArea()
方法摘要
 AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。
从类 javax.swing.text.JTextComponent.AccessibleJTextComponent 继承的方法
caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JTextArea.AccessibleJTextArea

protected JTextArea.AccessibleJTextArea()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAccessibleStateSet
返回：
描述该对象状态的 AccessibleStateSet 实例
另请参见：
AccessibleStateSet
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTextField

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
                    继承者  javax.swing.JTextField
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable, SwingConstants
直接已知子类：
DefaultTreeCellEditor.DefaultTextField, JFormattedTextField, JPasswordField
public class JTextField
extends JTextComponent
implements SwingConstants

JTextField 是一个轻量级组件，它允许编辑单行文本。有关使用文本字段的信息和示例，请参阅 The Java Tutorial 中的 How to Use Text Fields 一节。

JTextField 应与 java.awt.TextField 具有源代码兼容性，理应如此。此组件具有 java.awt.TextField 类中没有的功能。有关其他功能，请参考超类。

JTextField 具有建立字符串的方法，此字符串用作针对被激发的操作事件的命令字符串。java.awt.TextField 把字段文本用作针对 ActionEvent 的命令字符串。如果通过 setActionCommand 方法设置的命令字符串不为 null，则 JTextField 将使用该字符串来保持与 java.awt.TextField 的兼容性，否则将使用字段文本来保持兼容性。

setEchoChar 和 getEchoChar 方法不是直接提供的，以避免可插入的外观的新实现意外公开密码字符。为了提供类似密码的服务，单独的类 JPasswordField 扩展了 JTextField，从而通过可插入外观独立地提供此服务。

通过添加 TextEvent 的 TextListener，可以监视 java.awt.TextField 的更改。在基于 JTextComponent 的组件中，通过 DocumentEvent 将更改从模型传播到 DocumentListeners。DocumentEvent 给出了更改的位置和更改种类（如果需要）。代码片段可能看起来如下所示：

     DocumentListener myListener = ??;
     JTextField myArea = ??;
     myArea.getDocument().addDocumentListener(myListener);

JTextField 的水平对齐方式可以设置为左对齐、前端对齐、居中对齐、右对齐或尾部对齐。右对齐/尾部对齐在所需的字段文本尺寸小于为它分配的尺寸时使用。这是由 setHorizontalAlignment 和 getHorizontalAlignment 方法确定的。默认情况下为前端对齐。

文本字段如何使用 VK_ENTER 事件取决于文本字段是否具有任何操作侦听器。如果具有操作侦听器，则 VK_ENTER 导致侦听器获取一个 ActionEvent，并使用 VK_ENTER 事件。这与 AWT 文本字段处理 VK_ENTER 事件的方式是兼容的。如果文本字段没有操作侦听器，则从 1.3 版本开始不使用 VK_ENTER 事件。而是处理祖先组件的绑定，这将启用 JFC/Swing 的默认按钮特性。

通过对模型进行扩展和改变所提供的默认模型，可以很容易创建自定义字段。例如，以下代码片段将创建一个仅保存大写字符的字段。即使文本从剪贴板中粘贴过来或者通过编程方式而更改，此代码片段也是有效的。

 public class UpperCaseField extends JTextField {

     public UpperCaseField(int cols) {
         super(cols);
     }

     protected Document createDefaultModel() {
         return new UpperCaseDocument();
     }

     static class UpperCaseDocument extends PlainDocument {

         public void insertString(int offs, String str, AttributeSet a)
             throws BadLocationException {

             if (str == null) {
                 return;
             }
             char[] upper = str.toCharArray();
             for (int i = 0; i < upper.length; i++) {
                 upper[i] = Character.toUpperCase(upper[i]);
             }
             super.insertString(offs, new String(upper), a);
         }
     }
 }

警告：Swing 不是线程安全的。有关更多信息，请参阅　Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
setActionCommand(java.lang.String), JPasswordField, addActionListener(java.awt.event.ActionListener)

嵌套类摘要
protected  class JTextField.AccessibleJTextField
此类实现对 JTextField 类的可访问性支持。
从类 javax.swing.text.JTextComponent 继承的嵌套类/接口
JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static String notifyAction
发送通知（已接收字段内容）的动作名称。
从类 javax.swing.text.JTextComponent 继承的字段
DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTextField()
构造一个新的 TextField。
JTextField(Document doc, String text, int columns)
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。
JTextField(int columns)
构造一个具有指定列数的新的空 TextField。
JTextField(String text)
构造一个用指定文本初始化的新 TextField。
JTextField(String text, int columns)
构造一个用指定文本和列初始化的新 TextField。
方法摘要
protected  void actionPropertyChanged(Action action, String propertyName)
更新文本字段的状态以响应关联动作中的属性更改。
 void addActionListener(ActionListener l)
添加指定的操作侦听器以从此文本字段接收操作事件。
protected  void configurePropertiesFromAction(Action a)
在此文本字段上设置属性，以匹配指定 Action 中的值。
protected  PropertyChangeListener createActionPropertyChangeListener(Action a)
创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。
protected  Document createDefaultModel()
如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。
protected  void fireActionPerformed()
通知对此事件类型需要的所有侦听器。
 AccessibleContext getAccessibleContext()
获取与此 JTextField 关联的 AccessibleContext。
 Action getAction()
返回此 ActionEvent 源当前设置的 Action，如果没有设置 Action 则返回 null。
 ActionListener[] getActionListeners()
返回通过 addActionListener() 添加到此 JTextField 中的所有 ActionListener 的数组。
 Action[] getActions()
获取编辑器的命令列表。
 int getColumns()
返回此 TextField 中的列数。
protected  int getColumnWidth()
返回列宽度。
 int getHorizontalAlignment()
返回文本的水平对齐方式。
 BoundedRangeModel getHorizontalVisibility()
获取文本字段的可见性。
 Dimension getPreferredSize()
返回此 TextField 所需的首选大小 Dimensions。
 int getScrollOffset()
获取滚动偏移量（以像素为单位）。
 String getUIClassID()
获取 UI 的类 ID。
 boolean isValidateRoot()
调用来自文本字段本身的 revalidate，将通过验证文本字段来处理，如果文本字段不包含在 JViewport 中，则在这种情况下将返回 false。
protected  String paramString()
返回此 JTextField 的字符串表示形式。
 void postActionEvent()
通过将其指派给所有已注册的 ActionListener 对象来处理发生在此文本字段上的操作事件。
 void removeActionListener(ActionListener l)
移除指定的操作侦听器，以便不再从此文本字段接收操作事件。
 void scrollRectToVisible(Rectangle r)
将字段向左或向右滚动。
 void setAction(Action a)
设置 ActionEvent 源的 Action。
 void setActionCommand(String command)
设置用于操作事件的命令字符串。
 void setColumns(int columns)
设置此 TextField 中的列数，然后验证布局。
 void setDocument(Document doc)
将编辑器与一个文本文档关联。
 void setFont(Font f)
设置当前字体。
 void setHorizontalAlignment(int alignment)
设置文本的水平对齐方式。
 void setScrollOffset(int scrollOffset)
获取滚动偏移量（以像素为单位）。
从类 javax.swing.text.JTextComponent 继承的方法
addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, replaceSelection, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setText, setUI, updateUI, viewToModel, write
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

notifyAction

public static final String notifyAction
发送通知（已接收字段内容）的动作名称。通常它必须绑定到回车操作。

另请参见：
常量字段值
构造方法详细信息

JTextField

public JTextField()
构造一个新的 TextField。创建一个默认的模型，初始字符串为 null，列数设置为 0。

JTextField

public JTextField(String text)
构造一个用指定文本初始化的新 TextField。创建列数为 0 的默认模型。

参数：
text - 要显示的文本，或者为 null

JTextField

public JTextField(int columns)
构造一个具有指定列数的新的空 TextField。创建默认的模型，初始字符串设置为 null。

参数：
columns - 用来计算首选宽度的列数；如果列设置为 0，则首选宽度将是组件实现的自然结果

JTextField

public JTextField(String text,
                  int columns)
构造一个用指定文本和列初始化的新 TextField。创建默认的模型。

参数：
text - 要显示的文本，或者为 null
columns - 用来计算首选宽度的列数；如果列被设置为 0，则首选宽度将是组件实现的自然结果

JTextField

public JTextField(Document doc,
                  String text,
                  int columns)
构造一个新的 JTextField，它使用给定文本存储模型和给定的列数。其他构造方法均调用此方法。如果文档为 null，则创建默认的模型。

参数：
doc - 要使用的文本存储；如果为 null，则通过调用 createDefaultModel 方法提供一个默认的存储
text - 要显示的初始文本，或者为 null
columns - 要用来计算首选宽度 >= 0 的列数；如果 columns 被设置为 0，则首选宽度将为组件实现的自然结果
抛出：
IllegalArgumentException - 如果 columns < 0
方法详细信息

getUIClassID

public String getUIClassID()
获取 UI 的类 ID。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "TextFieldUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setDocument

public void setDocument(Document doc)
将编辑器与一个文本文档关联。当前注册的工厂用来生成文档的一个视图，此视图经过重新验证之后由编辑器来显示。将 PropertyChange 事件 ("document") 传播到每个侦听器。

覆盖：
类 JTextComponent 中的 setDocument
参数：
doc - 要显示/编辑的文档
另请参见：
JTextComponent.getDocument()

isValidateRoot

public boolean isValidateRoot()
调用来自文本字段本身的 revalidate，将通过验证文本字段来处理，如果文本字段不包含在 JViewport 中，则在这种情况下将返回 false。

覆盖：
类 JComponent 中的 isValidateRoot
返回：
如果此文本字段的父字段为 JViewPort，则返回 false；否则返回 true
另请参见：
JComponent.revalidate(), JComponent.isValidateRoot()

getHorizontalAlignment

public int getHorizontalAlignment()
返回文本的水平对齐方式。有效值包括：
  • JTextField.LEFT
  • JTextField.CENTER
  • JTextField.RIGHT
  • JTextField.LEADING
  • JTextField.TRAILING

返回：
水平对齐方式

setHorizontalAlignment

public void setHorizontalAlignment(int alignment)
设置文本的水平对齐方式。有效值包括：
  • JTextField.LEFT
  • JTextField.CENTER
  • JTextField.RIGHT
  • JTextField.LEADING
  • JTextField.TRAILING
当设置对齐方式时，调用 invalidate 和 repaint，并且激发 PropertyChange 事件（"horizontalAlignment"）。

参数：
alignment - 对齐方式
抛出：
IllegalArgumentException - 如果 alignment 不是一个有效键

createDefaultModel

protected Document createDefaultModel()
如果没有显式给出构造时要使用的模型，则创建该模型的默认实现。返回 PlainDocument 的一个实例。

返回：
默认的模型实现

getColumns

public int getColumns()
返回此 TextField 中的列数。

返回：
列数 >= 0

setColumns

public void setColumns(int columns)
设置此 TextField 中的列数，然后验证布局。

参数：
columns - 列数 >= 0
抛出：
IllegalArgumentException - 如果 columns 小于 0

getColumnWidth

protected int getColumnWidth()
返回列宽度。列的意义可以看作是一些字体的非常弱的概念。此方法用来定义列的宽度。对于所使用的字体，默认情况下这将被定义为字符 m 的宽度。此方法可以被重新定义为一些其他替代量。

返回：
列的宽度 >= 1

getPreferredSize

public Dimension getPreferredSize()
返回此 TextField 所需的首选大小 Dimensions。如果设置的列数为非 0 ，则将宽度设置为此数与列的宽度的乘积。

覆盖：
类 JComponent 中的 getPreferredSize
返回：
此文本字段的尺寸
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI

setFont

public void setFont(Font f)
设置当前字体。这将移除缓存的行高和列宽，以便新的字体能够反映出来，设置字体后将调用 revalidate。

覆盖：
类 JComponent 中的 setFont
参数：
f - 新字体
另请参见：
Component.getFont()

addActionListener

public void addActionListener(ActionListener l)
添加指定的操作侦听器以从此文本字段接收操作事件。

参数：
l - 要添加的动作侦听器

removeActionListener

public void removeActionListener(ActionListener l)
移除指定的操作侦听器，以便不再从此文本字段接收操作事件。

参数：
l - 要移除的操作侦听器

getActionListeners

public ActionListener[] getActionListeners()
返回通过 addActionListener() 添加到此 JTextField 中的所有 ActionListener 的数组。

返回：
所有添加的 ActionListener，或者不具有添加的侦听器时返回一个空数组
从以下版本开始：
1.4

fireActionPerformed

protected void fireActionPerformed()
通知对此事件类型需要的所有侦听器。以延迟方式创建的事件实例。侦听器列表按从后到前的顺序处理。

另请参见：
EventListenerList

setActionCommand

public void setActionCommand(String command)
设置用于操作事件的命令字符串。

参数：
command - 命令字符串

setAction

public void setAction(Action a)
设置 ActionEvent 源的 Action。新的 Action 替换任何以前设置的 Action，而不影响通过 addActionListener 独立添加的 ActionListeners。如果 Action 已经是一个注册到 ActionEvent 源的 ActionListener，则不对它进行重新注册。

设置 Action 将导致立即更改支持 Action 的 Swing 组件中描述的所有属性。随后，文本字段的属性将随着 Action 属性的变化而自动更新。

此方法使用三个其他方法设置并帮助跟踪 Action 的属性值。它使用 configurePropertiesFromAction 方法立即更改文本字段的属性。要跟踪 Action 属性值中的更改，此方法应注册 createActionPropertyChangeListener 所返回的 PropertyChangeListener。当 Action 中的属性更改时，默认 PropertyChangeListener 调用 actionPropertyChanged 方法。

参数：
a - JTextField 的 Action，或者为 null
从以下版本开始：
1.3
另请参见：
Action,
getAction(),
configurePropertiesFromAction(javax.swing.Action),
createActionPropertyChangeListener(javax.swing.Action),
actionPropertyChanged(javax.swing.Action, java.lang.String)

getAction

public Action getAction()
返回此 ActionEvent 源当前设置的 Action，如果没有设置 Action 则返回 null。

返回：
此 ActionEvent 源的 Action，或者 null
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

configurePropertiesFromAction

protected void configurePropertiesFromAction(Action a)
在此文本字段上设置属性，以匹配指定 Action 中的值。有关此方法设置的是哪些属性的更多信息，请参阅支持 Action 的 Swing 组件。

参数：
a - 从其获取属性的 Action，或者为 null
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

actionPropertyChanged

protected void actionPropertyChanged(Action action,
                                     String propertyName)
更新文本字段的状态以响应关联动作中的属性更改。从 createActionPropertyChangeListener 所返回的 PropertyChangeListener 中调用此方法。子类通常不调用此方法。支持其他 Action 属性的子类应该重写此方法和 configurePropertiesFromAction。

有关此方法设置的属性列表，请参阅支持 Action 的 Swing 组件中的表。

参数：
action - 与此文本字段关联的 Action
propertyName - 已更改属性的名称
从以下版本开始：
1.6
另请参见：
Action, configurePropertiesFromAction(javax.swing.Action)

createActionPropertyChangeListener

protected PropertyChangeListener createActionPropertyChangeListener(Action a)
创建并返回一个负责侦听指定 Action 的更改以及更新适当属性的 PropertyChangeListener。

警告：如果子类化此方法，则不要创建匿名的内部类。如果执行文本字段的生命周期，则它将被绑定到 Action 的值。

参数：
a - 文本字段的动作
从以下版本开始：
1.3
另请参见：
Action, setAction(javax.swing.Action)

getActions

public Action[] getActions()
获取编辑器的命令列表。此命令列表受可插入的 UI 支持，此 UI 是通过编辑器本身支持的命令集进行扩展的。这些命令可以用于事件绑定，例如在 keymap 中。

覆盖：
类 JTextComponent 中的 getActions
返回：
命令列表

postActionEvent

public void postActionEvent()
通过将其指派给所有已注册的 ActionListener 对象来处理发生在此文本字段上的操作事件。通常，这通过以文本字段注册的控制器来调用。

getHorizontalVisibility

public BoundedRangeModel getHorizontalVisibility()
获取文本字段的可见性。如果字段大小大于分配给它的区域，则可以对它进行调整，从而改变可见区域的位置。

字段的外观实现管理最小值、最大值，以及 BoundedRangeModel 的范围属性。

返回：
可见性
另请参见：
BoundedRangeModel

getScrollOffset

public int getScrollOffset()
获取滚动偏移量（以像素为单位）。

返回：
偏移 >= 0

setScrollOffset

public void setScrollOffset(int scrollOffset)
获取滚动偏移量（以像素为单位）。

参数：
scrollOffset - 偏移量 >= 0

scrollRectToVisible

public void scrollRectToVisible(Rectangle r)
将字段向左或向右滚动。

覆盖：
类 JComponent 中的 scrollRectToVisible
参数：
r - 要滚动的区域
另请参见：
JViewport

paramString

protected String paramString()
返回此 JTextField 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JTextComponent 中的 paramString
返回：
此 JTextField 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JTextField 关联的 AccessibleContext。对于 JTextFields 组件，AccessibleContext 采用 AccessibleJTextField 的形式。必要时创建新的 AccessibleJTextField 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JTextComponent 中的 getAccessibleContext
返回：
一个 AccessibleJTextField，它充当此 JTextField 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextField.AccessibleJTextField (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTextField.AccessibleJTextField

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.text.JTextComponent.AccessibleJTextComponent
                        继承者  javax.swing.JTextField.AccessibleJTextField
所有已实现的接口：
Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleEditableText, AccessibleExtendedComponent, AccessibleExtendedText, AccessibleText, CaretListener, DocumentListener
直接已知子类：
JPasswordField.AccessibleJPasswordField
正在封闭类：
JTextField
protected class JTextField.AccessibleJTextField
extends JTextComponent.AccessibleJTextComponent

此类实现对 JTextField 类的可访问性支持。它提供适合文本字段用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
从接口 javax.accessibility.AccessibleExtendedText 继承的字段
ATTRIBUTE_RUN, LINE
构造方法摘要
protected JTextField.AccessibleJTextField()
方法摘要
 AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。
从类 javax.swing.text.JTextComponent.AccessibleJTextComponent 继承的方法
caretUpdate, changedUpdate, cut, delete, doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleEditableText, getAccessibleRole, getAccessibleText, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getIndexAtPoint, getSelectedText, getSelectionEnd, getSelectionStart, getTextBounds, getTextRange, getTextSequenceAfter, getTextSequenceAt, getTextSequenceBefore, insertTextAtIndex, insertUpdate, paste, removeUpdate, replaceText, selectText, setAttributes, setTextContents
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JTextField.AccessibleJTextField

protected JTextField.AccessibleJTextField()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

覆盖：
类 JTextComponent.AccessibleJTextComponent 中的 getAccessibleStateSet
返回：
描述该对象状态的 AccessibleStateSet 实例
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTextPane (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTextPane

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.text.JTextComponent
                    继承者  javax.swing.JEditorPane
                        继承者  javax.swing.JTextPane
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
public class JTextPane
extends JEditorPane

可以用以图形方式表示的属性来标记的文本组件。有关使用文本窗格的 how-to 信息和示例，请参阅 The Java Tutorial 中的 Using Text Components 一节。

此组件模仿了由一串字符级属性组成的段落。每个段落都可能有一个附加的逻辑样式，如果默认属性没有通过段落上的属性集或一串字符重写，则此样式包含要使用的默认属性。组件和图像可以嵌入在文本流中。

换行
有关如果处理换行的讨论，请参阅 DefaultEditorKit。

警告：Swing 不是线程安全的。有关更多信息，请参阅　Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
StyledEditorKit

嵌套类摘要
从类 javax.swing.JEditorPane 继承的嵌套类/接口
JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport
从类 javax.swing.text.JTextComponent 继承的嵌套类/接口
JTextComponent.AccessibleJTextComponent, JTextComponent.DropLocation, JTextComponent.KeyBinding
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JEditorPane 继承的字段
HONOR_DISPLAY_PROPERTIES, W3C_LENGTH_UNITS
从类 javax.swing.text.JTextComponent 继承的字段
DEFAULT_KEYMAP, FOCUS_ACCELERATOR_KEY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTextPane()
创建一个新的 JTextPane。
JTextPane(StyledDocument doc)
创建具有指定文档模型的新 JTextPane。
方法摘要
Style | addStyle(String nm, Style parent) 将一个新样式添加到逻辑样式层次结构中。
protected EditorKit | createDefaultEditorKit() 创建默认使用的 EditorKit。
AttributeSet | getCharacterAttributes() 获取在当前插入符号位置的有效字符属性，或者 null。
MutableAttributeSet | getInputAttributes() 获取窗格的输入属性。
Style | getLogicalStyle() 获取分配给由当前插入符号位置表示的段落的逻辑样式，或者 null。
AttributeSet | getParagraphAttributes() 获取插入符号位置的当前有效段落属性，如果没有，则返回 null。
Style | getStyle(String nm) 获取以前添加的已命名的非 null 样式。
StyledDocument | getStyledDocument() 获取与编辑器关联的模型。
protected StyledEditorKit | getStyledEditorKit() 获取编辑器工具包。
String | getUIClassID() 返回 UI 的类 ID。
void | insertComponent(Component c) 将一个组件插入到文档中，以替换当前选择的内容。
void | insertIcon(Icon g) 将一个图标插入文档中，以替换当前选择的内容。
protected String | paramString() 返回此 JTextPane 的字符串表示形式。
void | removeStyle(String nm) 移除以前添加到文档中的已命名的非 null 样式。
void | replaceSelection(String content) 用给定字符串所表示的新内容替换当前选择的内容。
void | setCharacterAttributes(AttributeSet attr, boolean replace) 将给定属性应用于字符内容。
void | setDocument(Document doc) 将编辑器与一个文本文档关联。
void | setEditorKit(EditorKit kit) 设置当前安装的用于内容处理的工具包。
void | setLogicalStyle(Style s) 设置在当前插入符号位置用于段落的逻辑样式。
void | setParagraphAttributes(AttributeSet attr, boolean replace) 将给定属性应用于段落。
void | setStyledDocument(StyledDocument doc) 将编辑器与一个文本文档关联。
从类 javax.swing.JEditorPane 继承的方法
addHyperlinkListener, createEditorKitForContentType, fireHyperlinkUpdate, getAccessibleContext, getContentType, getEditorKit, getEditorKitClassNameForContentType, getEditorKitForContentType, getHyperlinkListeners, getPage, getPreferredSize, getScrollableTracksViewportHeight, getScrollableTracksViewportWidth, getStream, getText, read, registerEditorKitForContentType, registerEditorKitForContentType, removeHyperlinkListener, scrollToReference, setContentType, setEditorKitForContentType, setPage, setPage, setText
从类 javax.swing.text.JTextComponent 继承的方法
addCaretListener, addInputMethodListener, addKeymap, copy, cut, fireCaretUpdate, getActions, getCaret, getCaretColor, getCaretListeners, getCaretPosition, getDisabledTextColor, getDocument, getDragEnabled, getDropLocation, getDropMode, getFocusAccelerator, getHighlighter, getInputMethodRequests, getKeymap, getKeymap, getMargin, getNavigationFilter, getPreferredScrollableViewportSize, getPrintable, getScrollableBlockIncrement, getScrollableUnitIncrement, getSelectedText, getSelectedTextColor, getSelectionColor, getSelectionEnd, getSelectionStart, getText, getToolTipText, getUI, isEditable, loadKeymap, modelToView, moveCaretPosition, paste, print, print, print, processInputMethodEvent, read, removeCaretListener, removeKeymap, removeNotify, select, selectAll, setCaret, setCaretColor, setCaretPosition, setComponentOrientation, setDisabledTextColor, setDragEnabled, setDropMode, setEditable, setFocusAccelerator, setHighlighter, setKeymap, setMargin, setNavigationFilter, setSelectedTextColor, setSelectionColor, setSelectionEnd, setSelectionStart, setUI, updateUI, viewToModel, write
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JTextPane

public JTextPane()
创建一个新的 JTextPane。创建并设置 StyledEditorKit 的一个新实例，并将文档模型设置为 null。

JTextPane

public JTextPane(StyledDocument doc)
创建具有指定文档模型的新 JTextPane。创建并设置 javax.swing.text.StyledEditorKit 的一个新实例。

参数：
doc - 文档模型
方法详细信息

getUIClassID

public String getUIClassID()
返回 UI 的类 ID。

覆盖：
类 JEditorPane 中的 getUIClassID
返回：
字符串 "TextPaneUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setDocument

public void setDocument(Document doc)
将编辑器与一个文本文档关联。这必须是一个 StyledDocument。

覆盖：
类 JTextComponent 中的 setDocument
参数：
doc - 要显示/编辑的文档
抛出：
IllegalArgumentException - 如果 doc 不能收缩为一个 StyledDocument，它是此文本组件所要求的模型类型
另请参见：
JTextComponent.getDocument()

setStyledDocument

public void setStyledDocument(StyledDocument doc)
将编辑器与一个文本文档关联。当前注册的工厂用来生成文档的一个视图，此视图由编辑器来显示。

参数：
doc - 要显示/编辑的文档

getStyledDocument

public StyledDocument getStyledDocument()
获取与编辑器关联的模型。

返回：
模型

replaceSelection

public void replaceSelection(String content)
用给定字符串所表示的新内容替换当前选择的内容。如果没有选择的内容，则该操作插入给定的文本。如果没有替换文本，则该操作移除当前选择的内容。替换文本将具有针对插入点的输入当前定义的属性。如果文档不是可编辑的，则发出蜂鸣并返回。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

覆盖：
类 JEditorPane 中的 replaceSelection
参数：
content - 替换选定内容的内容

insertComponent

public void insertComponent(Component c)
将一个组件插入到文档中，以替换当前选择的内容。如果当前没有选择的内容，则将组件插入到插入符号的当前位置。在相关文档中这表示为内容字符的一个属性。

给定组件是 JTextPane 所使用的实际组件。由于组件不能是多个容器的子级，因此此方法不能在多个文本组件共享模型的情形下使用。

根据 Component.getAlignmentY 返回的值，组件相对于文本基线放置。对于 Swing 组件，可以方便地使用 JComponent.setAlignmentY 方法来设置此值。例如，设置值 0.75 将导致组件的 75% 位于基线之上，组件的 25% 位于基线之下。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
c - 要插入的组件

insertIcon

public void insertIcon(Icon g)
将一个图标插入文档中，以替换当前选择的内容。如果当前没有选择的内容，则将图标插入到插入符号的当前位置。在相关文档中这被表示为内容字符的一个属性。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
g - 要插入的图标
另请参见：
Icon

addStyle

public Style addStyle(String nm,
                      Style parent)
将一个新样式添加到逻辑样式层次结构中。样式属性自底向上进行解析，这样在子级中指定的属性重写在父级中指定的属性。

参数：
nm - 样式的名称（在命名样式集合中必须是惟一的）。如果样式未命名，则其名称可以为 null，但是调用者要负责管理返回的引用，因为未命名的样式不能通过其名称获取。未命名的样式可以用于诸如字符属性重写这类情况，比如，在样式运行中。
parent - 父样式。如果未指定的属性不需要以其他样式解析，则此值可以为 null。
返回：
新的 Style

removeStyle

public void removeStyle(String nm)
移除以前添加到文档中的已命名的非 null 样式。

参数：
nm - 要移除的样式名称

getStyle

public Style getStyle(String nm)
获取以前添加的已命名的非 null 样式。

参数：
nm - 样式名称
返回：
Style

setLogicalStyle

public void setLogicalStyle(Style s)
设置在当前插入符号位置用于段落的逻辑样式。如果没有为字符和段落属性显式设置属性，则它们将通过分配给段落的逻辑样式进行解析，也就是通过某个层次结构来解析，该层次结构完全独立于文档中元素的层次结构。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
s - 要分配给段落的逻辑样式，如果没有样式，则为 null

getLogicalStyle

public Style getLogicalStyle()
获取分配给由当前插入符号位置表示的段落的逻辑样式，或者 null。

返回：
Style

getCharacterAttributes

public AttributeSet getCharacterAttributes()
获取在当前插入符号位置的有效字符属性，或者 null。

返回：
属性，或者 null

setCharacterAttributes

public void setCharacterAttributes(AttributeSet attr,
                                   boolean replace)
将给定属性应用于字符内容。如果有选择内容，则属性将应用于所选择的范围。如果没有选择内容，则属性将应用于输入属性集合，此集合定义了所有新插入文本的属性。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
attr - 属性
replace - 如果为 true，则首先替换现有属性

getParagraphAttributes

public AttributeSet getParagraphAttributes()
获取插入符号位置的当前有效段落属性，如果没有，则返回 null。

返回：
属性

setParagraphAttributes

public void setParagraphAttributes(AttributeSet attr,
                                   boolean replace)
将给定属性应用于段落。如果有选择内容，则将属性应用于与选择内容相交的段落。如果没有选择内容，则将属性应用于当前插入符号位置的段落。

虽然大多数 Swing 方法不是线程安全的，但此方法是线程安全的。有关更多信息，请参阅 How to Use Threads。

参数：
attr - 非 null 属性
replace - 如果为 true，则首先替换现有属性

getInputAttributes

public MutableAttributeSet getInputAttributes()
获取窗格的输入属性。

返回：
属性

getStyledEditorKit

protected final StyledEditorKit getStyledEditorKit()
获取编辑器工具包。

返回：
编辑器工具包

createDefaultEditorKit

protected EditorKit createDefaultEditorKit()
创建默认使用的 EditorKit。此实现返回 javax.swing.text.StyledEditorKit。

覆盖：
类 JEditorPane 中的 createDefaultEditorKit
返回：
编辑器工具包

setEditorKit

public final void setEditorKit(EditorKit kit)
设置当前安装的用于内容处理的工具包。这是建立编辑器内容类型的绑定属性。

覆盖：
类 JEditorPane 中的 setEditorKit
参数：
kit - 所需的编辑器行为
抛出：
IllegalArgumentException - 如果 kit 不是一个 StyledEditorKit
另请参见：
JEditorPane.getEditorKit()

paramString

protected String paramString()
返回此 JTextPane 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JEditorPane 中的 paramString
返回：
此 JTextPane 的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToggleButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToggleButton

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.AbstractButton
                    继承者  javax.swing.JToggleButton
所有已实现的接口：
ImageObserver, ItemSelectable, MenuContainer, Serializable, Accessible, SwingConstants
直接已知子类：
JCheckBox, JRadioButton
public class JToggleButton
extends AbstractButton
implements Accessible

具有两个状态的（two-state）按钮的实现。JRadioButton 和 JCheckBox 类是此类的子类。有关如何使用按钮，请参阅 The Java Tutorial 中的 How to Use Buttons, Check Boxes, and Radio Buttons 一节。

通过 Action 可以配置按钮，并进行一定程度的控制。对按钮使用 Action 有许多直接配置按钮所不及的优点。有关更多信息，请参阅支持 Action 的 Swing 组件，可以在 The Java Tutorial 中的 How to Use Actions 一节找到更多信息。

警告：Swing 不是线程安全的。有关更多信息，请参阅　Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JRadioButton, JCheckBox

嵌套类摘要
protected class | JToggleButton.AccessibleJToggleButton 此类实现对 JToggleButton 类的可访问性支持。
static class | JToggleButton.ToggleButtonModel ToggleButton 模型。
从类 javax.swing.AbstractButton 继承的嵌套类/接口
AbstractButton.AccessibleAbstractButton, AbstractButton.ButtonChangeListener
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.AbstractButton 继承的字段
actionListener, BORDER_PAINTED_CHANGED_PROPERTY, changeEvent, changeListener, CONTENT_AREA_FILLED_CHANGED_PROPERTY, DISABLED_ICON_CHANGED_PROPERTY, DISABLED_SELECTED_ICON_CHANGED_PROPERTY, FOCUS_PAINTED_CHANGED_PROPERTY, HORIZONTAL_ALIGNMENT_CHANGED_PROPERTY, HORIZONTAL_TEXT_POSITION_CHANGED_PROPERTY, ICON_CHANGED_PROPERTY, itemListener, MARGIN_CHANGED_PROPERTY, MNEMONIC_CHANGED_PROPERTY, model, MODEL_CHANGED_PROPERTY, PRESSED_ICON_CHANGED_PROPERTY, ROLLOVER_ENABLED_CHANGED_PROPERTY, ROLLOVER_ICON_CHANGED_PROPERTY, ROLLOVER_SELECTED_ICON_CHANGED_PROPERTY, SELECTED_ICON_CHANGED_PROPERTY, TEXT_CHANGED_PROPERTY, VERTICAL_ALIGNMENT_CHANGED_PROPERTY, VERTICAL_TEXT_POSITION_CHANGED_PROPERTY
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JToggleButton()
创建最初未选定的切换按钮，不设置文本或图像。
JToggleButton(Action a)
创建一个切换按钮，其属性从所提供的 Action 获取。
JToggleButton(Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的图像但是没有文本。
JToggleButton(Icon icon, boolean selected)
创建具有指定图像和选择状态但没有文本的切换按钮。
JToggleButton(String text)
创建具有指定文本的未选定的切换按钮。
JToggleButton(String text, boolean selected)
创建具有指定文本和选择状态的切换按钮。
JToggleButton(String text, Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。
JToggleButton(String text, Icon icon, boolean selected)
创建具有指定文本、图像和选择状态的切换按钮。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JToggleButton 关联的 AccessibleContext。
String | getUIClassID() 返回指定了 l&f 类名称的字符串，其中 l&f 类呈现此组件。
protected String | paramString() 返回此 JToggleButton 的字符串表示形式。
void | updateUI() 将 UI 属性重置为当前外观的值。
从类 javax.swing.AbstractButton 继承的方法
actionPropertyChanged, addActionListener, addChangeListener, addImpl, addItemListener, checkHorizontalKey, checkVerticalKey, configurePropertiesFromAction, createActionListener, createActionPropertyChangeListener, createChangeListener, createItemListener, doClick, doClick, fireActionPerformed, fireItemStateChanged, fireStateChanged, getAction, getActionCommand, getActionListeners, getChangeListeners, getDisabledIcon, getDisabledSelectedIcon, getDisplayedMnemonicIndex, getHideActionText, getHorizontalAlignment, getHorizontalTextPosition, getIcon, getIconTextGap, getItemListeners, getLabel, getMargin, getMnemonic, getModel, getMultiClickThreshhold, getPressedIcon, getRolloverIcon, getRolloverSelectedIcon, getSelectedIcon, getSelectedObjects, getText, getUI, getVerticalAlignment, getVerticalTextPosition, imageUpdate, init, isBorderPainted, isContentAreaFilled, isFocusPainted, isRolloverEnabled, isSelected, paintBorder, removeActionListener, removeChangeListener, removeItemListener, removeNotify, setAction, setActionCommand, setBorderPainted, setContentAreaFilled, setDisabledIcon, setDisabledSelectedIcon, setDisplayedMnemonicIndex, setEnabled, setFocusPainted, setHideActionText, setHorizontalAlignment, setHorizontalTextPosition, setIcon, setIconTextGap, setLabel, setLayout, setMargin, setMnemonic, setMnemonic, setModel, setMultiClickThreshhold, setPressedIcon, setRolloverEnabled, setRolloverIcon, setRolloverSelectedIcon, setSelected, setSelectedIcon, setText, setUI, setVerticalAlignment, setVerticalTextPosition
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JToggleButton

public JToggleButton()
创建最初未选定的切换按钮，不设置文本或图像。

JToggleButton

public JToggleButton(Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的图像但是没有文本。

参数：
icon - 按钮应显示的图像

JToggleButton

public JToggleButton(Icon icon,
                     boolean selected)
创建具有指定图像和选择状态但没有文本的切换按钮。

参数：
icon - 按钮应显示的图像
selected - 如果为 true，则按钮最初是选定的；否则，按钮最初未选定

JToggleButton

public JToggleButton(String text)
创建具有指定文本的未选定的切换按钮。

参数：
text - 要在切换按钮上显示的字符串

JToggleButton

public JToggleButton(String text,
                     boolean selected)
创建具有指定文本和选择状态的切换按钮。

参数：
text - 在切换按钮上显示的字符串
selected - 如果为 true，则按钮最初是选定的；否则按钮最初未选定

JToggleButton

public JToggleButton(Action a)
创建一个切换按钮，其属性从所提供的 Action 获取。

从以下版本开始：
1.3

JToggleButton

public JToggleButton(String text,
                     Icon icon)
创建一个最初未选定的切换按钮，该按钮具有指定的文本和图像。

参数：
text - 在按钮上显示的字符串
icon - 按钮应显示的图像

JToggleButton

public JToggleButton(String text,
                     Icon icon,
                     boolean selected)
创建具有指定文本、图像和选择状态的切换按钮。

参数：
text - 切换按钮的文本
icon - 按钮应显示的图像
selected - 如果为 true，则按钮最初是选定的；否则按钮最初未选定
方法详细信息

updateUI

public void updateUI()
将 UI 属性重置为当前外观的值。

覆盖：
类 AbstractButton 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回指定了 l&f 类名称的字符串，其中 l&f 类呈现此组件。

覆盖：
类 JComponent 中的 getUIClassID
返回：
String "ToggleButtonUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

paramString

protected String paramString()
返回此 JToggleButton 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 AbstractButton 中的 paramString
返回：
此 JToggleButton 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JToggleButton 关联的 AccessibleContext。对于切换按钮，AccessibleContext 采用 AccessibleJToggleButton 的形式。必要时创建新的 AccessibleJToggleButton 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJToggleButton，它将充当此 JToggleButton 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToggleButton.AccessibleJToggleButton (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToggleButton.AccessibleJToggleButton

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.AbstractButton.AccessibleAbstractButton
                        继承者  javax.swing.JToggleButton.AccessibleJToggleButton
所有已实现的接口：
ItemListener, Serializable, EventListener, AccessibleAction, AccessibleComponent, AccessibleExtendedComponent, AccessibleText, AccessibleValue
直接已知子类：
JCheckBox.AccessibleJCheckBox, JRadioButton.AccessibleJRadioButton
正在封闭类：
JToggleButton
protected class JToggleButton.AccessibleJToggleButton
extends AbstractButton.AccessibleAbstractButton
implements ItemListener

此类实现对 JToggleButton 类的可访问性支持。它提供适合于切换按钮用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
JToggleButton.AccessibleJToggleButton()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
void | itemStateChanged(ItemEvent e) 当切换按钮的状态变化时，激发可访问的属性变更事件。
从类 javax.swing.AbstractButton.AccessibleAbstractButton 继承的方法
doAccessibleAction, getAccessibleAction, getAccessibleActionCount, getAccessibleActionDescription, getAccessibleIcon, getAccessibleKeyBinding, getAccessibleName, getAccessibleRelationSet, getAccessibleStateSet, getAccessibleText, getAccessibleValue, getAfterIndex, getAtIndex, getBeforeIndex, getCaretPosition, getCharacterAttribute, getCharacterBounds, getCharCount, getCurrentAccessibleValue, getIndexAtPoint, getMaximumAccessibleValue, getMinimumAccessibleValue, getSelectedText, getSelectionEnd, getSelectionStart, getTitledBorderText, getToolTipText, setCurrentAccessibleValue
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getBorderTitle, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleSelection, getAccessibleTable, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JToggleButton.AccessibleJToggleButton

public JToggleButton.AccessibleJToggleButton()
方法详细信息

itemStateChanged

public void itemStateChanged(ItemEvent e)
当切换按钮的状态变化时，激发可访问的属性变更事件。

指定者：
接口 ItemListener 中的 itemStateChanged

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToggleButton.ToggleButtonModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToggleButton.ToggleButtonModel

java.lang.Object
    继承者  javax.swing.DefaultButtonModel
        继承者  javax.swing.JToggleButton.ToggleButtonModel
所有已实现的接口：
ItemSelectable, Serializable, ButtonModel
正在封闭类：
JToggleButton
public static class JToggleButton.ToggleButtonModel
extends DefaultButtonModel

ToggleButton 模型。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.DefaultButtonModel 继承的字段
actionCommand, ARMED, changeEvent, ENABLED, group, listenerList, mnemonic, PRESSED, ROLLOVER, SELECTED, stateMask
构造方法摘要
JToggleButton.ToggleButtonModel()
创建一个新的 ToggleButton Model
方法摘要
boolean | isSelected() 检查按钮是否是选定的。
void | setPressed(boolean b) 设置切换按钮按下时的状态。
void | setSelected(boolean b) 设置按钮的选定状态。
从类 javax.swing.DefaultButtonModel 继承的方法
addActionListener, addChangeListener, addItemListener, fireActionPerformed, fireItemStateChanged, fireStateChanged, getActionCommand, getActionListeners, getChangeListeners, getGroup, getItemListeners, getListeners, getMnemonic, getSelectedObjects, isArmed, isEnabled, isPressed, isRollover, removeActionListener, removeChangeListener, removeItemListener, setActionCommand, setArmed, setEnabled, setGroup, setMnemonic, setRollover
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JToggleButton.ToggleButtonModel

public JToggleButton.ToggleButtonModel()
创建一个新的 ToggleButton Model

方法详细信息

isSelected

public boolean isSelected()
检查按钮是否是选定的。

指定者：
接口 ButtonModel 中的 isSelected
覆盖：
类 DefaultButtonModel 中的 isSelected
返回：
如果按钮已选择，则返回 true

setSelected

public void setSelected(boolean b)
设置按钮的选定状态。

指定者：
接口 ButtonModel 中的 setSelected
覆盖：
类 DefaultButtonModel 中的 setSelected
参数：
b - 如果选定了切换按钮，则为 true，如果未选定切换按钮，则为 false。

setPressed

public void setPressed(boolean b)
设置切换按钮按下时的状态。

指定者：
接口 ButtonModel 中的 setPressed
覆盖：
类 DefaultButtonModel 中的 setPressed
参数：
b - 是否应该按下该按钮
另请参见：
ButtonModel.isPressed()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToolBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToolBar

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JToolBar
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
public class JToolBar
extends JComponent
implements SwingConstants, Accessible

JToolBar 提供了一个用来显示常用的 Action 或控件的组件。有关使用工具栏的示例和信息，请参阅 The Java Tutorial 中的 How to Use Tool Bars 一节。

对于大多数的外观，用户可以将工具栏拖到单独的窗口中（除非 floatable 属性被设置为 false）。为了正确执行拖动，建议将 JToolBar 实例添加到容器的四“边”中的一边（其中容器的布局管理器为 BorderLayout），并且不在其他四“边”中添加任何子级。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Action

嵌套类摘要
protected class | JToolBar.AccessibleJToolBar 此类实现对 JToolBar 类的可访问性支持。
static class | JToolBar.Separator 一个特定于工具栏的分隔符。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JToolBar()
创建新的工具栏；默认的方向为 HORIZONTAL。
JToolBar(int orientation)
创建具有指定 orientation 的新工具栏。
JToolBar(String name)
创建一个具有指定 name 的新工具栏。
JToolBar(String name, int orientation)
创建一个具有指定 name 和 orientation 的新工具栏。
方法摘要
JButton | add(Action a) 添加一个指派动作的新的 JButton。
protected void | addImpl(Component comp, Object constraints, int index) 在添加 JButton 时，它最初被设置为 disabled。
void | addSeparator() 将默认大小的分隔符添加到工具栏的末尾。
void | addSeparator(Dimension size) 将指定大小的分隔符添加到工具栏的末尾。
protected PropertyChangeListener | createActionChangeListener(JButton b) 返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。
protected JButton | createActionComponent(Action a) 将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。
AccessibleContext | getAccessibleContext() 获取与此 JToolBar 关联的 AccessibleContext。
Component | getComponentAtIndex(int i) 返回指定索引位置的组件。
int | getComponentIndex(Component c) 返回指定组件的索引。
Insets | getMargin() 返回工具栏边框和它的按钮之间的空白。
int | getOrientation() 返回工具栏的当前方向。
ToolBarUI | getUI() 返回工具栏的当前 UI。
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
boolean | isBorderPainted() 获取 borderPainted 属性。
boolean | isFloatable() 获取 floatable 属性。
boolean | isRollover() 返回 rollover 状态。
protected void | paintBorder(Graphics g) 如果 borderPainted 属性为 true，则绘制工具栏边框。
protected String | paramString() 返回此 JToolBar 的字符串表示形式。
void | setBorderPainted(boolean b) 设置 borderPainted 属性，如果需要绘制边框，则此属性为 true。
void | setFloatable(boolean b) 设置 floatable 属性，如果要移动工具栏，此属性必须设置为 true。
void | setLayout(LayoutManager mgr) 设置此容器的布局管理器。
void | setMargin(Insets m) 设置工具栏边框和它的按钮之间的空白。
void | setOrientation(int o) 设置工具栏的方向。
void | setRollover(boolean rollover) 设置此工具栏的 rollover 状态。
void | setUI(ToolBarUI ui) 设置呈现此组件的 L&F 对象。
void | updateUI() UIFactory 发出的关于 L&F 已更改的通知。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JToolBar

public JToolBar()
创建新的工具栏；默认的方向为 HORIZONTAL。

JToolBar

public JToolBar(int orientation)
创建具有指定 orientation 的新工具栏。orientation 不是 HORIZONTAL 就是 VERTICAL。

参数：
orientation - 预期的方向

JToolBar

public JToolBar(String name)
创建一个具有指定 name 的新工具栏。名称用作浮动式 (undocked) 工具栏的标题。默认的方向为 HORIZONTAL。

参数：
name - 工具栏的名称
从以下版本开始：
1.3

JToolBar

public JToolBar(String name,
                int orientation)
创建一个具有指定 name 和 orientation 的新工具栏。所有其他构造方法均调用此构造方法。如果 orientation 是一个无效值，则将抛出异常。

参数：
name - 工具栏的名称
orientation - 初始方向，它不是 HORIZONTAL 就是 VERTICAL
抛出：
IllegalArgumentException - 如果方向既不是 HORIZONTAL 也不是 VERTICAL
从以下版本开始：
1.3
方法详细信息

getUI

public ToolBarUI getUI()
返回工具栏的当前 UI。

另请参见：
setUI(javax.swing.plaf.ToolBarUI)

setUI

public void setUI(ToolBarUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - ToolBarUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
UIFactory 发出的关于 L&F 已更改的通知。调用该方法，从而用 UIFactory 的最新版本来替换 UI。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "ToolBarUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getComponentIndex

public int getComponentIndex(Component c)
返回指定组件的索引。（注：分隔符占用索引位置）。

参数：
c - 要查找的 Component
返回：
指示组件位置的整数，此数从 0 开始

getComponentAtIndex

public Component getComponentAtIndex(int i)
返回指定索引位置的组件。

参数：
i - 组件的位置，从 0 开始
返回：
在该位置的 Component，如果索引无效则返回 null

setMargin

public void setMargin(Insets m)
设置工具栏边框和它的按钮之间的空白。设置为 null 将导致工具栏使用默认的空白。工具栏的默认 Border 对象使用此值来创建正确的空白。不过，如果在工具栏上设置了非默认边框，则由 Border 对象负责创建适当的空白（否则此属性将被忽略）。

参数：
m - Insets 对象，它定义了边框和按钮之间的空间
另请参见：
Insets

getMargin

public Insets getMargin()
返回工具栏边框和它的按钮之间的空白。

返回：
包含空白值的 Insets 对象
另请参见：
Insets

isBorderPainted

public boolean isBorderPainted()
获取 borderPainted 属性。

返回：
borderPainted 属性的值
另请参见：
setBorderPainted(boolean)

setBorderPainted

public void setBorderPainted(boolean b)
设置 borderPainted 属性，如果需要绘制边框，则此属性为 true。此属性的默认值为 true。某些外观可能不绘制边框，它们将忽略此属性。

参数：
b - 如果为 true，则绘制边框
另请参见：
isBorderPainted()

paintBorder

protected void paintBorder(Graphics g)
如果 borderPainted 属性为 true，则绘制工具栏边框。

覆盖：
类 JComponent 中的 paintBorder
参数：
g - Graphics 上下文，绘制在此上下文中完成
另请参见：
JComponent.paint(java.awt.Graphics), JComponent.setBorder(javax.swing.border.Border)

isFloatable

public boolean isFloatable()
获取 floatable 属性。

返回：
floatable 属性的值
另请参见：
setFloatable(boolean)

setFloatable

public void setFloatable(boolean b)
设置 floatable 属性，如果要移动工具栏，此属性必须设置为 true。通常，可以将浮动工具栏拖动到同一个容器中的不同位置，或者拖动到自己的窗口中。此属性的默认值为 true。某些外观可能不实现浮动工具栏，它们将忽略此属性。

参数：
b - 如果为 true，则工具栏可以移动；如果为 false，则工具栏不能移动
另请参见：
isFloatable()

getOrientation

public int getOrientation()
返回工具栏的当前方向。值不是 HORIZONTAL 就是 VERTICAL。

返回：
表示当前方向的整数 -- 不是 HORIZONTAL 就是 VERTICAL
另请参见：
setOrientation(int)

setOrientation

public void setOrientation(int o)
设置工具栏的方向。方向不是 HORIZONTAL 就是 VERTICAL。如果 orientation 是一个无效值，则将抛出异常。

参数：
o - 新的方向，不是 HORIZONTAL 就是 VERTICAL
抛出：
IllegalArgumentException - 如果方向既不是 HORIZONTAL 也不是 VERTICAL
另请参见：
getOrientation()

setRollover

public void setRollover(boolean rollover)
设置此工具栏的 rollover 状态。如果 rollover 状态为 true，则仅当鼠标指针悬停在工具栏按钮上时，才绘制该工具栏按钮的边框。此属性的默认值为 false。

外观的实现可以选择忽略此属性。

参数：
rollover - 如果翻转工具栏按钮，则为 true；否则为 false
从以下版本开始：
1.4

isRollover

public boolean isRollover()
返回 rollover 状态。

返回：
如果绘制 rollover 工具栏按钮，则返回 true；否则返回 false
从以下版本开始：
1.4
另请参见：
setRollover(boolean)

addSeparator

public void addSeparator()
将默认大小的分隔符添加到工具栏的末尾。默认大小由当前外观确定。

addSeparator

public void addSeparator(Dimension size)
将指定大小的分隔符添加到工具栏的末尾。

参数：
size - 分隔符的 Dimension

add

public JButton add(Action a)
添加一个指派动作的新的 JButton。

参数：
a - 要作为一个新的菜单项添加的 Action 对象
返回：
用来指派动作的新按钮

createActionComponent

protected JButton createActionComponent(Action a)
将为 Action 创建 JButton 的工厂方法添加到 JToolBar 中。如果传递了一个 null 操作，则默认名称为空。

参数：
a - 要添加的按钮的 Action
返回：
新创建的按钮
从以下版本开始：
1.3
另请参见：
Action

createActionChangeListener

protected PropertyChangeListener createActionChangeListener(JButton b)
返回正确配置的 PropertyChangeListener，它根据 Action 的更改对控件进行更新，如果需要使用默认的属性更改侦听器，则为 null。

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
在添加 JButton 时，它最初被设置为 disabled。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要增强的组件
constraints - 组件上强制要求的约束
index - 组件的索引
另请参见：
Container.add(Component),
Container.add(Component, int),
Container.add(Component, java.lang.Object),
LayoutManager,
LayoutManager2

paramString

protected String paramString()
返回此 JToolBar 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可以为空，但不可以为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JToolBar 的字符串表示形式。

setLayout

public void setLayout(LayoutManager mgr)
从类 Container 复制的描述
设置此容器的布局管理器。

覆盖：
类 Container 中的 setLayout
参数：
mgr - 指定的布局管理器
另请参见：
Container.doLayout(), Container.getLayout()

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JToolBar 关联的 AccessibleContext。对于工具栏，AccessibleContext 采用 AccessibleJToolBar 的形式。必要时创建新的 AccessibleJToolBar 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJToolBar，它充当此 JToolBar 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToolBar.AccessibleJToolBar (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToolBar.AccessibleJToolBar

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JToolBar.AccessibleJToolBar
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JToolBar
protected class JToolBar.AccessibleJToolBar
extends JComponent.AccessibleJComponent

此类实现对 JToolBar 类的可访问性支持。它提供了适合工具栏用户界面元素的 Java Accessibility API 的实现。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JToolBar.AccessibleJToolBar()
方法摘要
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JToolBar.AccessibleJToolBar

protected JToolBar.AccessibleJToolBar()
方法详细信息

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToolBar.Separator (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToolBar.Separator

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JSeparator
                    继承者  javax.swing.JToolBar.Separator
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, SwingConstants
正在封闭类：
JToolBar
public static class JToolBar.Separator
extends JSeparator

一个特定于工具栏的分隔符。一个具有维度但没有内容的对象用于对工具栏上的按钮进行分组。

嵌套类摘要
从类 javax.swing.JSeparator 继承的嵌套类/接口
JSeparator.AccessibleJSeparator
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JToolBar.Separator()
创建一个新的工具栏分隔符，使其具有当前外观定义的默认大小。
JToolBar.Separator(Dimension size)
创建具有指定大小的新的工具栏分隔符。
方法摘要
Dimension | getMaximumSize() 返回分隔符的最小大小。
Dimension | getMinimumSize() 返回分隔符的最小大小。
Dimension | getPreferredSize() 返回分隔符的首选大小。
Dimension | getSeparatorSize() 返回分隔符的大小
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
void | setSeparatorSize(Dimension size) 设置分隔符的大小。
从类 javax.swing.JSeparator 继承的方法
getAccessibleContext, getOrientation, getUI, paramString, setOrientation, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getNextFocusableComponent, getPopupLocation, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JToolBar.Separator

public JToolBar.Separator()
创建一个新的工具栏分隔符，使其具有当前外观定义的默认大小。

JToolBar.Separator

public JToolBar.Separator(Dimension size)
创建具有指定大小的新的工具栏分隔符。

参数：
size - 分隔符的 Dimension
方法详细信息

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JSeparator 中的 getUIClassID
返回：
字符串 "ToolBarSeparatorUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setSeparatorSize

public void setSeparatorSize(Dimension size)
设置分隔符的大小。

参数：
size - 分隔符的新的 Dimension

getSeparatorSize

public Dimension getSeparatorSize()
返回分隔符的大小

返回：
包含分隔符大小的 Dimension 对象（这是一个引用，不是副本！）

getMinimumSize

public Dimension getMinimumSize()
返回分隔符的最小大小。

覆盖：
类 JComponent 中的 getMinimumSize
返回：
Dimension 对象，它包含分隔符的最小大小。
另请参见：
JComponent.setMinimumSize(java.awt.Dimension), ComponentUI

getMaximumSize

public Dimension getMaximumSize()
返回分隔符的最小大小。

覆盖：
类 JComponent 中的 getMaximumSize
返回：
Dimension 对象，它包含分隔符的最大大小
另请参见：
JComponent.setMaximumSize(java.awt.Dimension), ComponentUI

getPreferredSize

public Dimension getPreferredSize()
返回分隔符的首选大小。

覆盖：
类 JComponent 中的 getPreferredSize
返回：
Dimension 对象，它包含分隔符的首选大小。
另请参见：
JComponent.setPreferredSize(java.awt.Dimension), ComponentUI
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToolTip (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToolTip

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JToolTip
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JToolTip
extends JComponent
implements Accessible

用来显示 Component 的“提示”。通常，组件提供 api，从而将使用 ToolTip 的过程自动化。例如，任何 Swing 组件都可以使用 JComponent setToolTipText 方法来指定一个标准的工具提示文本。需要创建自定义 ToolTip 显示的组件可以重写 JComponent 的 createToolTip 方法，并使用此类的一个子类。

有关更多文档，请参阅 The Java Tutorial 中的 How to Use Tool Tips 一节。

警告：Swing 不是线程安全的。有关更多信息，请参阅　Swing's Threading Policy。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JComponent.setToolTipText(java.lang.String), JComponent.createToolTip()

嵌套类摘要
protected  class JToolTip.AccessibleJToolTip
此类实现对 JToolTip 类的可访问性支持。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JToolTip()
创建一个工具提示。
方法摘要
AccessibleContext | getAccessibleContext() 获取与此 JToolTip 关联的 AccessibleContext。
JComponent | getComponent() 返回工具提示所描述的组件。
String | getTipText() 返回显示工具提示时所显示的文本。
ToolTipUI | getUI() 返回呈现此组件的 L&F 对象。
String | getUIClassID() 返回呈现此组件的 L&F 类的名称。
protected String | paramString() 返回此 JToolTip 的字符串表示形式。
void | setComponent(JComponent c) 指定工具提示所描述的组件。
void | setTipText(String tipText) 设置显示工具提示时要显示的文本。
void | updateUI() 将 UI 属性重置为当前外观的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

JToolTip

public JToolTip()
创建一个工具提示。

方法详细信息

getUI

public ToolTipUI getUI()
返回呈现此组件的 L&F 对象。

返回：
呈现此组件的 ToolTipUI 对象

updateUI

public void updateUI()
将 UI 属性重置为当前外观的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串 "ToolTipUI"
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

setTipText

public void setTipText(String tipText)
设置显示工具提示时要显示的文本。字符串 tipText 可以为 null。

参数：
tipText - 要显示的 String

getTipText

public String getTipText()
返回显示工具提示时所显示的文本。返回值可以为 null。

返回：
显示的 String

setComponent

public void setComponent(JComponent c)
指定工具提示所描述的组件。组件 c 可以为 null，这时它将是无效的。

这是一个绑定属性。

参数：
c - 正在描述的 JComponent
另请参见：
JComponent.createToolTip()

getComponent

public JComponent getComponent()
返回工具提示所描述的组件。返回值可以为 null。

返回：
工具提示所描述的组件
另请参见：
JComponent.createToolTip()

paramString

protected String paramString()
返回此 JToolTip 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JToolTip 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JToolTip 关联的 AccessibleContext。对于工具提示，AccessibleContext 采用 AccessibleJToolTip 的形式。必要时创建新的 AccessibleJToolTip 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJToolTip，它充当此 JToolTip 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JToolTip.AccessibleJToolTip (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JToolTip.AccessibleJToolTip

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JToolTip.AccessibleJToolTip
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JToolTip
protected class JToolTip.AccessibleJToolTip
extends JComponent.AccessibleJComponent

此类实现对 JToolTip 类的可访问性支持。它提供适合工具提示用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JToolTip.AccessibleJToolTip()
方法摘要
String | getAccessibleDescription() 获取此对象的可访问的描述。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JToolTip.AccessibleJToolTip

protected JToolTip.AccessibleJToolTip()
方法详细信息

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问的描述。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleDescription
返回：
描述此对象的本地化 String。
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JTree
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, Scrollable
public class JTree
extends JComponent
implements Scrollable, Accessible

将分层数据集显示为轮廓的控件。有关面向任务的文档和使用树的示例，请参阅 The Java Tutorial 中的 How to Use Trees 一节。

树中特定的节点可以由 TreePath（封装节点及其所有祖先的对象）标识，或由其显示行（其中显示区域中的每一行都显示一个节点）标识。展开 节点是一个非叶节点（由返回 false 的 TreeModel.isLeaf(node) 标识），当展开 其所有祖先时，该节点将显示其子节点。折叠 节点是隐藏它们的节点。隐藏 节点是位于折叠祖先下面的节点。所有可查看 节点的父节点都是可以展开的，但是可以显示它们，也可以不显示它们。显示 节点是可查看的并且位于可以看到它的显示区域。

以下 JTree 方法使用 "visible" 来表示 "displayed"：

  • isRootVisible()
  • setRootVisible()
  • scrollPathToVisible()
  • scrollRowToVisible()
  • getVisibleRowCount()
  • setVisibleRowCount()

下一组 JTree 方法使用 "visible" 表示 "viewable"（在展开的父节点下面）：

  • isVisible()
  • makeVisible()

如果您有兴趣了解选择何时更改，请实现 TreeSelectionListener 接口，并使用方法 addTreeSelectionListener 添加实例。当选择更改时，将调用 valueChanged，即如果用户在同一节点上单击两次，则仅调用 valueChanged 一次。

如果有兴趣检测双击事件或用户何时单击节点（不管是否选中它），建议您执行以下操作：

 final JTree tree = ...;

 MouseListener ml = new MouseAdapter() {
     public void mousePressed(MouseEvent e) {
         int selRow = tree.getRowForLocation(e.getX(), e.getY());
         TreePath selPath = tree.getPathForLocation(e.getX(), e.getY());
         if(selRow != -1) {
             if(e.getClickCount() == 1) {
                 mySingleClick(selRow, selPath);
             }
             else if(e.getClickCount() == 2) {
                 myDoubleClick(selRow, selPath);
             }
         }
     }
 };
 tree.addMouseListener(ml);
注：上述示例同时获取路径和行，但是您只需要获取感兴趣的内容。

要使用 JTree 显示复合节点（例如，同时包含图形图标和文本的节点），请为 TreeCellRenderer 创建子类，并使用 setCellRenderer(javax.swing.tree.TreeCellRenderer) 通知树使用它。要编辑此类节点，请为 TreeCellEditor 创建子类，并使用 setCellEditor(javax.swing.tree.TreeCellEditor)。

与所有 JComponent 类一样，可以使用 InputMap 和 ActionMap 将 Action 对象与 KeyStroke 关联，并在指定条件下执行操作。

警告：Swing 不是线程安全的。有关更多信息，请参阅　Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected class | JTree.AccessibleJTree 此类实现 JTree 类的可访问性支持。
static class | JTree.DropLocation TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。
static class | JTree.DynamicUtilTreeNode DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
protected static class | JTree.EmptySelectionModel EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
protected class | JTree.TreeModelHandler 在移除或更改节点时，监听模型并相应地更新 expandedState。
protected class | JTree.TreeSelectionRedirector 使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
static String | ANCHOR_SELECTION_PATH_PROPERTY 定位选择路径的绑定属性名称。
static String | CELL_EDITOR_PROPERTY cellEditor 的绑定属性名称。
static String | CELL_RENDERER_PROPERTY cellRenderer 的绑定属性名称。
protected TreeCellEditor | cellEditor 条目编辑器。
protected TreeCellRenderer | cellRenderer 用于绘制节点的单元格。
protected boolean | editable 树是否可以编辑？默认值为 false。
static String | EDITABLE_PROPERTY editable 的绑定属性名称。
static String | EXPANDS_SELECTED_PATHS_PROPERTY 展开选择路径属性的绑定属性名称
static String | INVOKES_STOP_CELL_EDITING_PROPERTY messagesStopCellEditing 的绑定属性名称。
protected boolean | invokesStopCellEditing 如果为 true，则在通过更改选择、更改树中的数据或通过其他方法停止编辑时，会调用 stopCellEditing，并保存更改。
static String | LARGE_MODEL_PROPERTY largeModel 的绑定属性名称。
protected boolean | largeModel 此树是否为大模型？这是一种代码优化设置。
static String | LEAD_SELECTION_PATH_PROPERTY leadSelectionPath 的绑定属性名称。
static String | ROOT_VISIBLE_PROPERTY rootVisible 的绑定属性名称。
protected boolean | rootVisible 如果显示根节点，则为 true；如果其子节点为最高可见节点，则为 false。
static String | ROW_HEIGHT_PROPERTY rowHeight 的绑定属性名称。
protected int | rowHeight 用于每个显示行的高度。
static String | SCROLLS_ON_EXPAND_PROPERTY scrollsOnExpand 的绑定属性名称。
protected boolean | scrollsOnExpand 如果为 true，则当展开节点时，将滚动尽可能多的子节点，以便看到它们。
static String | SELECTION_MODEL_PROPERTY selectionModel 的绑定属性名称。
protected TreeSelectionModel | selectionModel 对此树中选择的节点集建模。
protected JTree.TreeSelectionRedirector | selectionRedirector 创建一个新事件，并将它传递给 selectionListeners。
static String | SHOWS_ROOT_HANDLES_PROPERTY showsRootHandles 的绑定属性名称。
protected boolean | showsRootHandles 如果在树的最高层显示句柄，则为 True。
static String | TOGGLE_CLICK_COUNT_PROPERTY toggleClickCount 的绑定属性名称。
protected int | toggleClickCount 展开节点之前的鼠标单击数。
static String | TREE_MODEL_PROPERTY treeModel 的绑定属性名称。
protected TreeModel | treeModel 定义此对象显示的树的模型。
protected TreeModelListener | treeModelListener 更新 expandedState。
static String | VISIBLE_ROW_COUNT_PROPERTY visibleRowCount 的绑定属性名称。
protected int | visibleRowCount 一次可见的行数。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JTree()
返回带有示例模型的 JTree。
JTree(Hashtable<?,?> value)
返回从 Hashtable 创建的 JTree，它不显示根。
JTree(Object[] value)
返回 JTree，指定数组的每个元素作为不被显示的新根节点的子节点。
JTree(TreeModel newModel)
返回 JTree 的一个实例，它显示根节点 - 使用指定的数据模型创建树。
JTree(TreeNode root)
返回 JTree，指定的 TreeNode 作为其根，它显示根节点。
JTree(TreeNode root, boolean asksAllowsChildren)
返回 JTree，指定的 TreeNode 作为其根，它用指定的方式显示根节点，并确定节点是否为叶节点。
JTree(Vector<?> value)
返回 JTree，指定 Vector 的每个元素作为不被显示的新根节点的子节点。
方法摘要
 void addSelectionInterval(int index0, int index1)
将 index0 和 index1（包含）之间的路径添加到该选择。
 void addSelectionPath(TreePath path)
将由指定的 TreePath 标识的节点添加到当前选择。
 void addSelectionPaths(TreePath[] paths)
将路径数组中的每个路径添加到当前选择。
 void addSelectionRow(int row)
将指定行处的路径添加到当前选择。
 void addSelectionRows(int[] rows)
将每个指定行处的路径添加到当前选择。
 void addTreeExpansionListener(TreeExpansionListener tel)
为 TreeExpansion 事件添加侦听器。
 void addTreeSelectionListener(TreeSelectionListener tsl)
为 TreeSelection 事件添加侦听器。
 void addTreeWillExpandListener(TreeWillExpandListener tel)
为 TreeWillExpand 事件添加侦听器。
 void cancelEditing()
取消当前编辑会话。
 void clearSelection()
清除该选择。
protected  void clearToggledPaths()
清除切换的树路径的缓存。
 void collapsePath(TreePath path)
确保指定路径标识的节点是折叠的，并且可查看。
 void collapseRow(int row)
确保指定行中的节点是折叠的。
 String convertValueToText(Object value, boolean selected, boolean expanded, boolean leaf, int row, boolean hasFocus)
通过渲染器调用以将指定值转换为文本。
protected static TreeModel createTreeModel(Object value)
返回一个 TreeModel，它包装指定的对象。
protected  TreeModelListener createTreeModelListener()
创建并返回 TreeModelHandler 的一个实例。
 void expandPath(TreePath path)
确保指定路径标识的节点展开，并且可查看。
 void expandRow(int row)
确保指定行中的节点展开，并且可查看。
 void fireTreeCollapsed(TreePath path)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
 void fireTreeExpanded(TreePath path)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
 void fireTreeWillCollapse(TreePath path)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
 void fireTreeWillExpand(TreePath path)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
protected  void fireValueChanged(TreeSelectionEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。
 AccessibleContext getAccessibleContext()
获取与此 JTree 关联的 AccessibleContext。
 TreePath getAnchorSelectionPath()
返回标识为定位的路径。
 TreeCellEditor getCellEditor()
返回用于编辑树中条目的编辑器。
 TreeCellRenderer getCellRenderer()
返回正在呈现每个单元格的当前 TreeCellRenderer。
 TreePath getClosestPathForLocation(int x, int y)
返回离 x,y 最近的节点的路径。
 int getClosestRowForLocation(int x, int y)
返回离 x,y 最近的节点的行。
protected static TreeModel getDefaultTreeModel()
创建并返回一个示例 TreeModel。
protected  Enumeration<TreePath> getDescendantToggledPaths(TreePath parent)
返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。
 boolean getDragEnabled()
返回是否启用自动拖动处理。
 JTree.DropLocation getDropLocation()
返回该组件上 DnD 操作期间此组件应该视觉上指示为放置操作的位置；如果当前未显示任何位置，则返回 null。
 DropMode getDropMode()
返回此组件的放置模式。
 TreePath getEditingPath()
返回当前正在编辑的元素的路径。
 Enumeration<TreePath> getExpandedDescendants(TreePath parent)
返回当前展开的 parent 路径的子路径的 Enumeration。
 boolean getExpandsSelectedPaths()
返回 expandsSelectedPaths 属性。
 boolean getInvokesStopCellEditing()
返回告知编辑中断时发生了什么情况的指示符。
 Object getLastSelectedPathComponent()
返回当前选择的第一个节点中的最后一个路径组件。
 TreePath getLeadSelectionPath()
返回标识为前导的路径。
 int getLeadSelectionRow()
返回与前导路径对应的行索引。
 int getMaxSelectionRow()
返回选择的最后一行。
 int getMinSelectionRow()
获取选择的第一行。
 TreeModel getModel()
返回正在提供数据的 TreeModel。
 TreePath getNextMatch(String prefix, int startingRow, Position.Bias bias)
将 TreePath 返回到以一个前缀开头的下一个树元素。
protected  TreePath[] getPathBetweenRows(int index0, int index1)
返回 JTreePath 实例，它表示 index0 和 index1（包括 index1）之间的路径。
 Rectangle getPathBounds(TreePath path)
返回将指定节点绘入的 Rectangle。
 TreePath getPathForLocation(int x, int y)
返回指定位置处的节点路径。
 TreePath getPathForRow(int row)
返回指定行的路径。
 Dimension getPreferredScrollableViewportSize()
返回 JTree 的首选显示大小。
 Rectangle getRowBounds(int row)
返回将指定行处的节点绘入的 Rectangle。
 int getRowCount()
返回当前正在显示的行数。
 int getRowForLocation(int x, int y)
返回指定位置的行。
 int getRowForPath(TreePath path)
返回显示由指定路径标识的节点的行。
 int getRowHeight()
返回每个行的高度。
 int getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction)
返回块增量的数量，它是基于 orientation 的 visibleRect 高度或宽度。
 boolean getScrollableTracksViewportHeight()
返回 false 指示视口的高度不能确定表的高度，除非树的首选高度小于视口高度。
 boolean getScrollableTracksViewportWidth()
返回 false 指示视口的宽度不能确定表的宽度，除非树的首选宽度小于视口宽度。
 int getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction)
返回滚动时增加的数量。
 boolean getScrollsOnExpand()
返回 scrollsOnExpand 属性的值。
 int getSelectionCount()
返回选择的节点数。
 TreeSelectionModel getSelectionModel()
返回选择的模型。
 TreePath getSelectionPath()
返回首选节点的路径。
 TreePath[] getSelectionPaths()
返回所有选择值的路径。
 int[] getSelectionRows()
返回所有当前选择的行。
 boolean getShowsRootHandles()
返回 showsRootHandles 属性的值。
 int getToggleClickCount()
返回展开或关闭节点所需的鼠标单击数。
 String getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。
 TreeExpansionListener[] getTreeExpansionListeners()
返回使用 addTreeExpansionListener() 添加到此 JTree 的所有 TreeExpansionListener 的数组。
 TreeSelectionListener[] getTreeSelectionListeners()
返回使用 addTreeSelectionListener() 添加到此 JTree 的所有 TreeSelectionListener 的数组。
 TreeWillExpandListener[] getTreeWillExpandListeners()
返回使用 addTreeWillExpandListener() 添加到此 JTree 的所有 TreeWillExpandListener 的数组。
 TreeUI getUI()
返回呈现此组件的 L&F 对象。
 String getUIClassID()
返回呈现此组件的 L&F 类的名称。
 int getVisibleRowCount()
返回显示区域中显示的行数。
 boolean hasBeenExpanded(TreePath path)
如果已经展开路径标识的节点，则返回 true。
 boolean isCollapsed(int row)
如果折叠了指定显示行处的节点，则返回 true。
 boolean isCollapsed(TreePath path)
如果当前折叠了路径标识的值，则返回 true，如果当前未显示路径中的任何值，则返回 false。
 boolean isEditable()
如果树可编辑，则返回 true。
 boolean isEditing()
如果正在编辑树，则返回 true。
 boolean isExpanded(int row)
如果当前展开了指定显示行处的节点，则返回 true。
 boolean isExpanded(TreePath path)
如果当前展开了路径标识的节点，则返回 true。
 boolean isFixedRowHeight()
如果每个显示行的高度为固定大小，则返回 true。
 boolean isLargeModel()
如果将树配置为大模型，则返回 true。
 boolean isPathEditable(TreePath path)
返回 isEditable。
 boolean isPathSelected(TreePath path)
如果当前选择了路径标识的条目，则返回 true。
 boolean isRootVisible()
如果显示树的根节点，则返回 true。
 boolean isRowSelected(int row)
如果选择了行标识的节点，则返回 true。
 boolean isSelectionEmpty()
如果该选择当前为空，则返回 true。
 boolean isVisible(TreePath path)
如果当前可查看路径标识的值，则返回 true，这意味着该路径或者是根路径，或者它的所有父路径均被展开。
 void makeVisible(TreePath path)
确保路径标识的节点当前可查看。
protected  String paramString()
返回此 JTree 的字符串表示形式。
protected  boolean removeDescendantSelectedPaths(TreePath path, boolean includePath)
移除选择中的任何路径（path 的子路径）。
protected  void removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
移除已展开的 toRemove 中 TreePath 的所有子路径。
 void removeSelectionInterval(int index0, int index1)
从该选择中移除 index0 和 index1（包含）之间的节点。
 void removeSelectionPath(TreePath path)
从当前选择中移除指定路径标识的节点。
 void removeSelectionPaths(TreePath[] paths)
从当前选择移除指定路径标识的节点。
 void removeSelectionRow(int row)
从当前选择移除索引 row 处的行。
 void removeSelectionRows(int[] rows)
移除在每个指定行处选择的行。
 void removeTreeExpansionListener(TreeExpansionListener tel)
移除 TreeExpansion 事件的侦听器。
 void removeTreeSelectionListener(TreeSelectionListener tsl)
移除 TreeSelection 侦听器。
 void removeTreeWillExpandListener(TreeWillExpandListener tel)
移除 TreeWillExpand 事件的侦听器。
 void scrollPathToVisible(TreePath path)
确保路径中所有的路径组件均展开（最后一个路径组件除外）并滚动，以便显示该路径标识的节点。
 void scrollRowToVisible(int row)
滚动行标识的条目，直到显示出来。
 void setAnchorSelectionPath(TreePath newPath)
将标识的路径设置为定位路径。
 void setCellEditor(TreeCellEditor cellEditor)
设置单元格编辑器。
 void setCellRenderer(TreeCellRenderer x)
设置将用于绘制每个单元格的 TreeCellRenderer。
 void setDragEnabled(boolean b)
打开或关闭自动拖动处理。
 void setDropMode(DropMode dropMode)
设置此组件的放置模式。
 void setEditable(boolean flag)
确定树是否可编辑。
protected  void setExpandedState(TreePath path, boolean state)
设置此 JTree 的展开状态。
 void setExpandsSelectedPaths(boolean newValue)
配置 expandsSelectedPaths 属性。
 void setInvokesStopCellEditing(boolean newValue)
通过选择树中的另一个节点、树的数据中的更改或通过其他方法来确定编辑被中断时发生了什么情况。
 void setLargeModel(boolean newValue)
指定 UI 是否使用大模型。
 void setLeadSelectionPath(TreePath newPath)
将标识的路径设置为前导路径。
 void setModel(TreeModel newModel)
设置将提供数据的 TreeModel。
 void setRootVisible(boolean rootVisible)
确定 TreeModel 的根节点是否可见。
 void setRowHeight(int rowHeight)
设置每个单元格的高度（以像素为单位）。
 void setScrollsOnExpand(boolean newValue)
设置 scrollsOnExpand 属性，它确定树是否可以滚动显示以前隐藏的子节点。
 void setSelectionInterval(int index0, int index1)
选择 index0 和 index1（包含）之间的节点。
 void setSelectionModel(TreeSelectionModel selectionModel)
设置树的选择模型。
 void setSelectionPath(TreePath path)
选择指定路径标识的节点。
 void setSelectionPaths(TreePath[] paths)
选择由指定的路径数组标识的节点。
 void setSelectionRow(int row)
选择显示的指定行的节点。
 void setSelectionRows(int[] rows)
选择与显示的每个指定行对应的节点。
 void setShowsRootHandles(boolean newValue)
设置 showsRootHandles 属性的值，它指定是否应显示节点句柄。
 void setToggleClickCount(int clickCount)
设置节点展开或关闭之前鼠标的单击数。
 void setUI(TreeUI ui)
设置呈现此组件的 L&F 对象。
 void setVisibleRowCount(int newCount)
设置要显示的行数。
 void startEditingAtPath(TreePath path)
选择指定路径标识的节点，并开始编辑。
 boolean stopEditing()
结束当前编辑会话。
 void treeDidChange()
当树被更改得足以需要调整边界大小，但还不足以需要移除展开的节点集（例如，展开或折叠节点，或者将节点插入到树）时发送。
 void updateUI()
UIManager 发出的关于 L&F 已经更改的通知。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paint, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

treeModel

protected transient TreeModel treeModel
定义此对象显示的树的模型。

selectionModel

protected transient TreeSelectionModel selectionModel
对此树中选择的节点集建模。

rootVisible

protected boolean rootVisible
如果显示根节点，则为 true；如果其子节点为最高可见节点，则为 false。

cellRenderer

protected transient TreeCellRenderer cellRenderer
用于绘制节点的单元格。如果为 null，则 UI 使用默认 cellRenderer。

rowHeight

protected int rowHeight
用于每个显示行的高度。如果此高度 <= 0，则渲染器为每个行确定高度。

showsRootHandles

protected boolean showsRootHandles
如果在树的最高层显示句柄，则为 True。

句柄是一个小图标，它显示在节点旁边，用户可以单击一次此图标来展开或折叠该节点。公共接口为可以展开的节点显示加号 (+)，为可以折叠的节点显示减号 (-)。节点的句柄始终显示在最高层下面。

如果 rootVisible 设置指定将显示根节点，那么该根节点是位于最高层的惟一节点。如果不显示根节点，那么其所有的子节点都位于树的最高层。始终显示节点的句柄，但最高层节点除外。

如果根节点不可见，那么通常最好的方法是将此值设为 true。否则，树看起来很像一个列表，用户可能不知道“列表条目”实际上就是树节点。

另请参见：
rootVisible

selectionRedirector

protected transient JTree.TreeSelectionRedirector selectionRedirector
创建一个新事件，并将它传递给 selectionListeners。

cellEditor

protected transient TreeCellEditor cellEditor
条目编辑器。默认值为 null（树不可编辑）。

editable

protected boolean editable
树是否可以编辑？默认值为 false。

largeModel

protected boolean largeModel
此树是否为大模型？这是一种代码优化设置。当单元格高度对于所有节点都相同时，可以使用大模型。然后，UI 将缓存非常少的信息，并改为继续向模型发送消息。在没有大模型的情况下，UI 缓存大部分信息，从而使该模型的方法调用更少。

此值仅为 UI 的一个建议值。并不是所有的 UI 都将利用它。默认值为 false。

visibleRowCount

protected int visibleRowCount
一次可见的行数。此值用于 Scrollable 接口。它可以确定显示区域的首选大小。

invokesStopCellEditing

protected boolean invokesStopCellEditing
如果为 true，则在通过更改选择、更改树中的数据或通过其他方法停止编辑时，会调用 stopCellEditing，并保存更改。如果为 false，则调用 cancelCellEditing，并丢弃更改。默认值为 false。

scrollsOnExpand

protected boolean scrollsOnExpand
如果为 true，则当展开节点时，将滚动尽可能多的子节点，以便看到它们。

toggleClickCount

protected int toggleClickCount
展开节点之前的鼠标单击数。

treeModelListener

protected transient TreeModelListener treeModelListener
更新 expandedState。

CELL_RENDERER_PROPERTY

public static final String CELL_RENDERER_PROPERTY
cellRenderer 的绑定属性名称。

另请参见：
常量字段值

TREE_MODEL_PROPERTY

public static final String TREE_MODEL_PROPERTY
treeModel 的绑定属性名称。

另请参见：
常量字段值

ROOT_VISIBLE_PROPERTY

public static final String ROOT_VISIBLE_PROPERTY
rootVisible 的绑定属性名称。

另请参见：
常量字段值

SHOWS_ROOT_HANDLES_PROPERTY

public static final String SHOWS_ROOT_HANDLES_PROPERTY
showsRootHandles 的绑定属性名称。

另请参见：
常量字段值

ROW_HEIGHT_PROPERTY

public static final String ROW_HEIGHT_PROPERTY
rowHeight 的绑定属性名称。

另请参见：
常量字段值

CELL_EDITOR_PROPERTY

public static final String CELL_EDITOR_PROPERTY
cellEditor 的绑定属性名称。

另请参见：
常量字段值

EDITABLE_PROPERTY

public static final String EDITABLE_PROPERTY
editable 的绑定属性名称。

另请参见：
常量字段值

LARGE_MODEL_PROPERTY

public static final String LARGE_MODEL_PROPERTY
largeModel 的绑定属性名称。

另请参见：
常量字段值

SELECTION_MODEL_PROPERTY

public static final String SELECTION_MODEL_PROPERTY
selectionModel 的绑定属性名称。

另请参见：
常量字段值

VISIBLE_ROW_COUNT_PROPERTY

public static final String VISIBLE_ROW_COUNT_PROPERTY
visibleRowCount 的绑定属性名称。

另请参见：
常量字段值

INVOKES_STOP_CELL_EDITING_PROPERTY

public static final String INVOKES_STOP_CELL_EDITING_PROPERTY
messagesStopCellEditing 的绑定属性名称。

另请参见：
常量字段值

SCROLLS_ON_EXPAND_PROPERTY

public static final String SCROLLS_ON_EXPAND_PROPERTY
scrollsOnExpand 的绑定属性名称。

另请参见：
常量字段值

TOGGLE_CLICK_COUNT_PROPERTY

public static final String TOGGLE_CLICK_COUNT_PROPERTY
toggleClickCount 的绑定属性名称。

另请参见：
常量字段值

LEAD_SELECTION_PATH_PROPERTY

public static final String LEAD_SELECTION_PATH_PROPERTY
leadSelectionPath 的绑定属性名称。

从以下版本开始：
1.3
另请参见：
常量字段值

ANCHOR_SELECTION_PATH_PROPERTY

public static final String ANCHOR_SELECTION_PATH_PROPERTY
定位选择路径的绑定属性名称。

从以下版本开始：
1.3
另请参见：
常量字段值

EXPANDS_SELECTED_PATHS_PROPERTY

public static final String EXPANDS_SELECTED_PATHS_PROPERTY
展开选择路径属性的绑定属性名称

从以下版本开始：
1.3
另请参见：
常量字段值
构造方法详细信息

JTree

public JTree()
返回带有示例模型的 JTree。树使用的默认模型可以将叶节点定义为不带子节点的任何节点。

另请参见：
DefaultTreeModel.asksAllowsChildren

JTree

public JTree(Object[] value)
返回 JTree，指定数组的每个元素作为不被显示的新根节点的子节点。默认情况下，树可以将叶节点定义为不带子节点的任何节点。

参数：
value - Object 的数组
另请参见：
DefaultTreeModel.asksAllowsChildren

JTree

public JTree(Vector<?> value)
返回 JTree，指定 Vector 的每个元素作为不被显示的新根节点的子节点。默认情况下，树可以将叶节点定义为不带子节点的任何节点。

参数：
value - 一个 Vector
另请参见：
DefaultTreeModel.asksAllowsChildren

JTree

public JTree(Hashtable<?,?> value)
返回从 Hashtable 创建的 JTree，它不显示根。HashTable 中每个键/值对的半值都成为新根节点的子节点。默认情况下，树可以将叶节点定义为不带子节点的任何节点。

参数：
value - 一个 Hashtable
另请参见：
DefaultTreeModel.asksAllowsChildren

JTree

public JTree(TreeNode root)
返回 JTree，指定的 TreeNode 作为其根，它显示根节点。默认情况下，树可以将叶节点定义为不带子节点的任何节点。

参数：
root - 一个 TreeNode 对象
另请参见：
DefaultTreeModel.asksAllowsChildren

JTree

public JTree(TreeNode root,
             boolean asksAllowsChildren)
返回 JTree，指定的 TreeNode 作为其根，它用指定的方式显示根节点，并确定节点是否为叶节点。

参数：
root - 一个 TreeNode 对象
asksAllowsChildren - 如果为 false，则不带子节点的任何节点都是叶节点；如果为 true，则只有不允许带子节点的节点是叶节点
另请参见：
DefaultTreeModel.asksAllowsChildren

JTree

public JTree(TreeModel newModel)
返回 JTree 的一个实例，它显示根节点 - 使用指定的数据模型创建树。

参数：
newModel - 用作数据模型的 TreeModel
方法详细信息

getDefaultTreeModel

protected static TreeModel getDefaultTreeModel()
创建并返回一个示例 TreeModel。主要用于 bean 生成器，来显示一些有趣的东西。

返回：
默认 TreeModel

createTreeModel

protected static TreeModel createTreeModel(Object value)
返回一个 TreeModel，它包装指定的对象。如果该对象为：
  • 一个 Object 数组
  • 一个 Hashtable 或
  • 一个 Vector
则创建新的根节点，将传入的每个对象作为子节点。否则，创建新的根，将指定的对象作为其值。

参数：
value - 用作 TreeModel 的基础的 Object
返回：
包装指定对象的 TreeModel

getUI

public TreeUI getUI()
返回呈现此组件的 L&F 对象。

返回：
呈现此组件的 TreeUI 对象

setUI

public void setUI(TreeUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - TreeUI L&F 对象
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
UIManager 发出的关于 L&F 已经更改的通知。用 UIManager 的最新版本替换当前的 UI 对象。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回呈现此组件的 L&F 类的名称。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串“TreeUI”
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

getCellRenderer

public TreeCellRenderer getCellRenderer()
返回正在呈现每个单元格的当前 TreeCellRenderer。

返回：
正在呈现每个单元格的 TreeCellRenderer

setCellRenderer

public void setCellRenderer(TreeCellRenderer x)
设置将用于绘制每个单元格的 TreeCellRenderer。

参数：
x - 将呈现每个单元格的 TreeCellRenderer

setEditable

public void setEditable(boolean flag)
确定树是否可编辑。如果新设置与现有设置不同，则激发属性更改事件。

参数：
flag - boolean 值，如果树可编辑，则为 true

isEditable

public boolean isEditable()
如果树可编辑，则返回 true。

返回：
如果树可编辑，则返回 true

setCellEditor

public void setCellEditor(TreeCellEditor cellEditor)
设置单元格编辑器。null 值表示树无法编辑。如果这表示 cellEditor 中的一个更改，则在所有侦听器上调用 propertyChange 方法。

参数：
cellEditor - 要使用的 TreeCellEditor

getCellEditor

public TreeCellEditor getCellEditor()
返回用于编辑树中条目的编辑器。

返回：
使用中的 TreeCellEditor，如果树无法编辑，则返回 null

getModel

public TreeModel getModel()
返回正在提供数据的 TreeModel。

返回：
正在提供数据的 TreeModel

setModel

public void setModel(TreeModel newModel)
设置将提供数据的 TreeModel。

参数：
newModel - 将提供数据的 TreeModel

isRootVisible

public boolean isRootVisible()
如果显示树的根节点，则返回 true。

返回：
如果显示树的根节点，则返回 true
另请参见：
rootVisible

setRootVisible

public void setRootVisible(boolean rootVisible)
确定 TreeModel 的根节点是否可见。

参数：
rootVisible - 如果将显示树的根节点，则为 true
另请参见：
rootVisible

setShowsRootHandles

public void setShowsRootHandles(boolean newValue)
设置 showsRootHandles 属性的值，它指定是否应显示节点句柄。此属性的默认值取决于用于创建 JTree 的构造方法。某些外观可能不支持句柄；它们将忽略此属性。

参数：
newValue - 如果显示根句柄，则为 true；否则为 false
另请参见：
showsRootHandles, getShowsRootHandles()

getShowsRootHandles

public boolean getShowsRootHandles()
返回 showsRootHandles 属性的值。

返回：
showsRootHandles 属性的值
另请参见：
showsRootHandles

setRowHeight

public void setRowHeight(int rowHeight)
设置每个单元格的高度（以像素为单位）。如果指定的值小于或等于 0，则会查询当前单元格渲染器以获取每个行的高度。

参数：
rowHeight - 每个单元格的高度（以像素为单位）

getRowHeight

public int getRowHeight()
返回每个行的高度。如果返回的值小于或等于 0，则每个行的高度由渲染器确定。

isFixedRowHeight

public boolean isFixedRowHeight()
如果每个显示行的高度为固定大小，则返回 true。

返回：
如果每行的高度为固定大小，则返回 true

setLargeModel

public void setLargeModel(boolean newValue)
指定 UI 是否使用大模型。（并不是所有的 UI 都可以实现这一点。）激发 LARGE_MODEL_PROPERTY 的属性更改。

参数：
newValue - 如果 UI 使用大模型，则为 true
另请参见：
largeModel

isLargeModel

public boolean isLargeModel()
如果将树配置为大模型，则返回 true。

返回：
如果建议使用大模型，则返回 true
另请参见：
largeModel

setInvokesStopCellEditing

public void setInvokesStopCellEditing(boolean newValue)
通过选择树中的另一个节点、树的数据中的更改或通过其他方法来确定编辑被中断时发生了什么情况。将此属性设置为 true 可导致在编辑被中断时自动保存更改。

激发 INVOKES_STOP_CELL_EDITING_PROPERTY 的属性更改。

参数：
newValue - true 意味着当编辑中断时，调用 stopCellEditing，并保存数据；false 意味着调用 cancelCellEditing，并丢失更改

getInvokesStopCellEditing

public boolean getInvokesStopCellEditing()
返回告知编辑中断时发生了什么情况的指示符。

返回：
告知编辑中断时发生了什么情况的指示符
另请参见：
setInvokesStopCellEditing(boolean)

setScrollsOnExpand

public void setScrollsOnExpand(boolean newValue)
设置 scrollsOnExpand 属性，它确定树是否可以滚动显示以前隐藏的子节点。如果此属性为 true（默认值），则当节点展开时，树可以使用滚动来显示该节点的尽可能多的子节点。某些外观中，树在展开时可能不需要滚动；这些外观会忽略此属性。

参数：
newValue - false 表示展开时禁用滚动；true 表示启用滚动
另请参见：
getScrollsOnExpand()

getScrollsOnExpand

public boolean getScrollsOnExpand()
返回 scrollsOnExpand 属性的值。

返回：
scrollsOnExpand 属性的值

setToggleClickCount

public void setToggleClickCount(int clickCount)
设置节点展开或关闭之前鼠标的单击数。默认值为两次。

从以下版本开始：
1.3

getToggleClickCount

public int getToggleClickCount()
返回展开或关闭节点所需的鼠标单击数。

返回：
节点展开之前的鼠标单击数
从以下版本开始：
1.3

setExpandsSelectedPaths

public void setExpandsSelectedPaths(boolean newValue)
配置 expandsSelectedPaths 属性。如果为 true，则在任何时候通过 TreeSelectionModel 或 JTree 提供的覆盖方法更改选择时，将展开 TreePath 的父路径，使它们可见（可见是指父路径不一定在 JTree 的可见矩形内展开）。如果为 false，当选择更改时，节点的父节点不可见（展开的所有父节点）。如果希望使您的选择模型维持并不总是可见的路径（展开的所有父路径），那么这一点非常有用。

参数：
newValue - expandsSelectedPaths 的新值
从以下版本开始：
1.3

getExpandsSelectedPaths

public boolean getExpandsSelectedPaths()
返回 expandsSelectedPaths 属性。

返回：
如果选择更改导致父路径展开，则返回 true
从以下版本开始：
1.3
另请参见：
setExpandsSelectedPaths(boolean)

setDragEnabled

public void setDragEnabled(boolean b)
打开或关闭自动拖动处理。要启用自动拖动处理，应将此属性设置为 true，并且树的 TransferHandler 必须为非 null。dragEnabled 属性的默认值为 false。

遵守此属性以及识别用户拖动动作的工作取决于外观实现，尤其是树的 TreeUI。启用自动拖动处理时，只要用户在项上按下鼠标按钮，并将鼠标移动几个像素，大多数外观（包括为 BasicLookAndFeel 创建子类的外观）就会开始拖放操作。因此，将此属性设置为 true 可以对选择行为产生微妙的影响。

如果使用忽略此属性的外观，仍然可以通过在树的 TransferHandler 上调用 exportAsDrag 来开始拖放操作。

参数：
b - 是否启用自动拖动处理
抛出：
HeadlessException - 如果 b 为 true，并且 GraphicsEnvironment.isHeadless() 返回 true
从以下版本开始：
1.4
另请参见：
GraphicsEnvironment.isHeadless(),
getDragEnabled(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDragEnabled

public boolean getDragEnabled()
返回是否启用自动拖动处理。

返回：
dragEnabled 属性的值
从以下版本开始：
1.4
另请参见：
setDragEnabled(boolean)

setDropMode

public final void setDropMode(DropMode dropMode)
设置此组件的放置模式。为了向后兼容性，此属性的默认值为 DropMode.USE_SELECTION。但是，为了用户使用更方便，建议使用其他模式中的某个模式。例如，DropMode.ON 提供与选择类似的显示项的行为，但执行此操作不会影响树中的实际选择。

JTree 支持以下放置模式：

  • DropMode.USE_SELECTION
  • DropMode.ON
  • DropMode.INSERT
  • DropMode.ON_OR_INSERT

只有此组件具有接受放置操作的 TransferHandler 时，该放置模式才是有意义的。

参数：
dropMode - 要使用的放置模式
抛出：
IllegalArgumentException - 如果放置模式不受支持或为 null
从以下版本开始：
1.6
另请参见：
getDropMode(),
getDropLocation(),
JComponent.setTransferHandler(javax.swing.TransferHandler),
TransferHandler

getDropMode

public final DropMode getDropMode()
返回此组件的放置模式。

返回：
此组件的放置模式
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode)

getDropLocation

public final JTree.DropLocation getDropLocation()
返回该组件上 DnD 操作期间此组件应该视觉上指示为放置操作的位置；如果当前未显示任何位置，则返回 null。

此方法不用于从 TransferHandler 查询放置操作，因为放置操作只有在 TransferHandler 的 canImport 已返回并允许显示该位置之后才被设置。

当此属性更改时，该组件将触发名为 "dropLocation" 的属性更改事件。

返回：
放置位置
从以下版本开始：
1.6
另请参见：
setDropMode(javax.swing.DropMode), TransferHandler.canImport(TransferHandler.TransferSupport)

isPathEditable

public boolean isPathEditable(TreePath path)
返回 isEditable。在编辑开始确保给定的路径可以编辑之前，这可以从 UI 调用。这作为子类的入口点提供，以添加经过过滤的编辑，而无需借助于创建新编辑器。

返回：
如果每个父节点和节点本身可编辑，则返回 true
另请参见：
isEditable()

getToolTipText

public String getToolTipText(MouseEvent event)
重写 JComponent 的 getToolTipText 方法，以允许使用渲染器的提示（如果渲染器设置了文本）。

注：对于要正确显示其渲染器工具提示的 JTree，JTree 必须是向 ToolTipManager 注册的组件。这可以通过调用 ToolTipManager.sharedInstance().registerComponent(tree) 来完成。它不能自动完成！

覆盖：
类 JComponent 中的 getToolTipText
参数：
event - 启动 ToolTip 显示的 MouseEvent
返回：
包含工具提示的字符串，如果 event 为 null，则返回 null

convertValueToText

public String convertValueToText(Object value,
                                 boolean selected,
                                 boolean expanded,
                                 boolean leaf,
                                 int row,
                                 boolean hasFocus)
通过渲染器调用以将指定值转换为文本。此实现返回 value.toString，忽略所有其他参数。要控制该转换，则为此方法创建子类，并使用需要的任何参数。

参数：
value - 要转换成文本的 Object
selected - 如果选中节点，则为 true
expanded - 如果展开节点，则为 true
leaf - 如果节点是叶节点，则为 true
row - 指定节点的显示行的整数，其中 0 表示显示的第一行
hasFocus - 如果节点有焦点，则为 true
返回：
节点值的 String 表示形式

getRowCount

public int getRowCount()
返回当前正在显示的行数。

返回：
正在显示的行数

setSelectionPath

public void setSelectionPath(TreePath path)
选择指定路径标识的节点。如果隐藏该路径的任何组件（在折叠节点之下），并且 getExpandsSelectedPaths 为 true，则公开它（可查看）。

参数：
path - 指定要选择的节点的 TreePath

setSelectionPaths

public void setSelectionPaths(TreePath[] paths)
选择由指定的路径数组标识的节点。如果隐藏任何路径中的任何组件（在折叠节点之下），并且 getExpandsSelectedPaths 为 true，则公开它（可查看）。

参数：
paths - 指定要选择的节点的 TreePath 对象数组

setLeadSelectionPath

public void setLeadSelectionPath(TreePath newPath)
将标识的路径设置为前导路径。不能选择前导路径。JTree 不维持前导路径，UI 将更新它。

参数：
newPath - 新的前导路径
从以下版本开始：
1.3

setAnchorSelectionPath

public void setAnchorSelectionPath(TreePath newPath)
将标识的路径设置为定位路径。JTree 不维持定位路径，UI 将更新它。

参数：
newPath - 新的定位路径
从以下版本开始：
1.3

setSelectionRow

public void setSelectionRow(int row)
选择显示的指定行的节点。

参数：
row - 要选择的行，其中 0 是显示的第一行

setSelectionRows

public void setSelectionRows(int[] rows)
选择与显示的每个指定行对应的节点。如果 rows 的特定元素 < 0 或 >= getRowCount，则它会被忽略。如果 rows 中的元素都不是有效的行，则会清除该选择。这就好像调用 clearSelection 一样。

参数：
rows - 指定要选择的行的 int 数组，其中 0 指示显示的第一行

addSelectionPath

public void addSelectionPath(TreePath path)
将由指定的 TreePath 标识的节点添加到当前选择。如果路径的所有组件都不可查看，并且 getExpandsSelectedPaths 为 true，则使得其可以查看。

注意，JTree 不允许完全相同的节点作为子节点存在于同一父节点之下 - 每个兄弟节点必须是惟一的对象。

参数：
path - 要添加的 TreePath

addSelectionPaths

public void addSelectionPaths(TreePath[] paths)
将路径数组中的每个路径添加到当前选择。如果任何路径的所有组件都不可查看，并且 getExpandsSelectedPaths 为 true，则其可以查看。

注意，JTree 不允许完全相同的节点作为子节点存在于同一父节点之下 - 每个兄弟节点必须是惟一的对象。

参数：
paths - 指定要添加的节点的 TreePath 对象数组

addSelectionRow

public void addSelectionRow(int row)
将指定行处的路径添加到当前选择。

参数：
row - 指定要添加的节点行的整数，其中 0 表示显示的第一行

addSelectionRows

public void addSelectionRows(int[] rows)
将每个指定行处的路径添加到当前选择。

参数：
rows - 指定要添加的行的 int 数组，其中 0 指示显示的第一行

getLastSelectedPathComponent

public Object getLastSelectedPathComponent()
返回当前选择的第一个节点中的最后一个路径组件。

返回：
首选节点的 TreePath 中的最后一个 Object，若未选择任何内容，则返回 null
另请参见：
TreePath.getLastPathComponent()

getLeadSelectionPath

public TreePath getLeadSelectionPath()
返回标识为前导的路径。

返回：
标识为前导的路径

getAnchorSelectionPath

public TreePath getAnchorSelectionPath()
返回标识为定位的路径。

返回：
标识为定位的路径
从以下版本开始：
1.3

getSelectionPath

public TreePath getSelectionPath()
返回首选节点的路径。

返回：
首选节点的 TreePath，如果当前未选择任何内容，则返回 null

getSelectionPaths

public TreePath[] getSelectionPaths()
返回所有选择值的路径。

返回：
指示所选节点的 TreePath 对象的数组，如果当前未选择任何内容，则返回 null

getSelectionRows

public int[] getSelectionRows()
返回所有当前选择的行。此方法仅转发到 TreeSelectionModel。若未选择任何内容，则返回 null 或一个空数组，具体取决于 TreeSelectionModel 的实现。

返回：
标识所有当前选择的行的整数数组，其中 0 表示显示的第一行

getSelectionCount

public int getSelectionCount()
返回选择的节点数。

返回：
选择的节点数

getMinSelectionRow

public int getMinSelectionRow()
获取选择的第一行。

返回：
指定选择的第一行的整数，其中 0 表示显示的第一行

getMaxSelectionRow

public int getMaxSelectionRow()
返回选择的最后一行。

返回：
指定选择的最后一行的整数，其中 0 表示显示的第一行

getLeadSelectionRow

public int getLeadSelectionRow()
返回与前导路径对应的行索引。

返回：
提供前导路径的行索引的整数，其中 0 表示显示的第一行；如果 leadPath 为 null，则返回 -1

isPathSelected

public boolean isPathSelected(TreePath path)
如果当前选择了路径标识的条目，则返回 true。

参数：
path - 标识节点的 TreePath
返回：
如果选择该节点，则返回 true

isRowSelected

public boolean isRowSelected(int row)
如果选择了行标识的节点，则返回 true。

参数：
row - 指定一个显示行的整数，其中 0 表示显示的第一行
返回：
如果选择该节点，则返回 true

getExpandedDescendants

public Enumeration<TreePath> getExpandedDescendants(TreePath parent)
返回当前展开的 parent 路径的子路径的 Enumeration。如果当前没有展开 parent，将返回 null。如果在返回的 Enumeration 上迭代时展开/折叠节点，则不能返回所有展开的路径，或者可能返回不再展开的路径。

参数：
parent - 要检查的路径
返回：
parent 的子路径的 Enumeration，如果当前没有展开 parent，则返回 null

hasBeenExpanded

public boolean hasBeenExpanded(TreePath path)
如果已经展开路径标识的节点，则返回 true。

返回：
如果已经展开 path，则返回 true

isExpanded

public boolean isExpanded(TreePath path)
如果当前展开了路径标识的节点，则返回 true。

参数：
path - 指定要检查的节点的 TreePath
返回：
如果折叠了节点的路径中的任何节点，则返回 false，如果展开了路径中的所有节点，则返回 true

isExpanded

public boolean isExpanded(int row)
如果当前展开了指定显示行处的节点，则返回 true。

参数：
row - 要检查的行，其中 0 表示显示的第一行
返回：
如果当前展开了节点，则返回 true，否则返回 false

isCollapsed

public boolean isCollapsed(TreePath path)
如果当前折叠了路径标识的值，则返回 true，如果当前未显示路径中的任何值，则返回 false。

参数：
path - 要检查的 TreePath
返回：
如果折叠了节点路径中的任何节点，则返回 true，如果展开了路径中的所有节点，则返回 false

isCollapsed

public boolean isCollapsed(int row)
如果折叠了指定显示行处的节点，则返回 true。

参数：
row - 要检查的行，其中 0 表示显示的第一行
返回：
如果当前折叠节点，则返回 true，否则返回 false

makeVisible

public void makeVisible(TreePath path)
确保路径标识的节点当前可查看。

参数：
path - 使之可查看的 TreePath

isVisible

public boolean isVisible(TreePath path)
如果当前可查看路径标识的值，则返回 true，这意味着该路径或者是根路径，或者它的所有父路径均被展开。否则，此方法返回 false。

返回：
如果该节点可查看，则返回 true，否则返回 false

getPathBounds

public Rectangle getPathBounds(TreePath path)
返回将指定节点绘入的 Rectangle。如果隐藏了路径中的任何组件（在折叠的父路径下），则返回 null。

注：
此方法返回一个有效的矩形，即使当前不显示指定的节点。

参数：
path - 标识节点的 TreePath
返回：
将节点绘入的 Rectangle，或者返回 null

getRowBounds

public Rectangle getRowBounds(int row)
返回将指定行处的节点绘入的 Rectangle。

参数：
row - 要绘制的行，其中 0 表示显示的第一行
返回：
将节点绘入的 Rectangle

scrollPathToVisible

public void scrollPathToVisible(TreePath path)
确保路径中所有的路径组件均展开（最后一个路径组件除外）并滚动，以便显示该路径标识的节点。仅当此 JTree 包含在 JScrollPane 中时才工作。

参数：
path - 标识引入视图的节点的 TreePath

scrollRowToVisible

public void scrollRowToVisible(int row)
滚动行标识的条目，直到显示出来。执行将行引入视图必需的最小滚动数量。仅当此 JTree 包含在 JScrollPane 中时才工作。

参数：
row - 指定要滚动的行的整数，其中 0 表示显示的第一行

getPathForRow

public TreePath getPathForRow(int row)
返回指定行的路径。如果 row 不可见，则返回 null。

参数：
row - 指定行的整数
返回：
指定节点的 TreePath，如果 row < 0 或 row > getRowCount()，则返回 null

getRowForPath

public int getRowForPath(TreePath path)
返回显示由指定路径标识的节点的行。

参数：
path - 标识节点的 TreePath
返回：
指定显示行的整数，其中 0 表示显示的第一行，如果路径中任何元素隐藏在折叠的父路径之下，则返回 -1。

expandPath

public void expandPath(TreePath path)
确保指定路径标识的节点展开，并且可查看。如果路径中的最后一项是叶节点，则此方法无效。

参数：
path - 标识节点的 TreePath

expandRow

public void expandRow(int row)
确保指定行中的节点展开，并且可查看。

如果 row < 0 或 >= getRowCount，则此方法无效。

参数：
row - 指定一个显示行的整数，其中 0 表示显示的第一行

collapsePath

public void collapsePath(TreePath path)
确保指定路径标识的节点是折叠的，并且可查看。

参数：
path - 标识节点的 TreePath

collapseRow

public void collapseRow(int row)
确保指定行中的节点是折叠的。

如果 row < 0 或 >= getRowCount，则此方法无效。

参数：
row - 指定一个显示行的整数，其中 0 表示显示的第一行

getPathForLocation

public TreePath getPathForLocation(int x,
                                   int y)
返回指定位置处的节点路径。

参数：
x - 提供水平像素数的整数，从显示区域左边开始减去左边距
y - 提供垂直像素数的整数，从显示区域顶部开始减去顶边距
返回：
该位置处节点的 TreePath

getRowForLocation

public int getRowForLocation(int x,
                             int y)
返回指定位置的行。

参数：
x - 提供水平像素数的整数，从显示区域左边开始减去左边距
y - 提供垂直像素数的整数，从显示区域顶部开始减去顶边距
返回：
与该位置对应的行，如果该位置不在显示的单元格的边界内，则返回 -1
另请参见：
getClosestRowForLocation(int, int)

getClosestPathForLocation

public TreePath getClosestPathForLocation(int x,
                                          int y)
返回离 x,y 最近的节点的路径。如果当前查看不到任何节点，或不存在模型，则返回 null，否则始终返回有效路径。要测试该节点是否正好位于 x, y，请获取该节点的边界，并根据该边界测试 x, y。

参数：
x - 提供水平像素数的整数，从显示区域左边开始减去左边距
y - 提供垂直像素数的整数，从显示区域顶部开始减去顶边距
返回：
最靠近该位置的节点的 TreePath，如果没有可查看内容，或不存在模型，则返回 null
另请参见：
getPathForLocation(int, int), getPathBounds(javax.swing.tree.TreePath)

getClosestRowForLocation

public int getClosestRowForLocation(int x,
                                    int y)
返回离 x,y 最近的节点的行。如果查看不到任何节点，或者不存在模型，则返回 -1。否则始终返回有效的行。要测试返回的对象是否正好位于 x, y，请获取返回行处的节点的边界，并根据该边界测试 x,y。

参数：
x - 提供水平像素数的整数，从显示区域左边开始减去左边距
y - 提供垂直像素数的整数，从显示区域顶部开始减去顶边距
返回：
最靠近该位置的行，如果没有可查看内容或不存在模型，则返回 -1
另请参见：
getRowForLocation(int, int), getRowBounds(int)

isEditing

public boolean isEditing()
如果正在编辑树，则返回 true。使用 getSelectionPath 可以获取正在编辑的项。

返回：
如果用户当前正在编辑节点，则返回 true
另请参见：
getSelectionPath()

stopEditing

public boolean stopEditing()
结束当前编辑会话。（DefaultTreeCellEditor 对象可以保存当前在单元格上进行的任何编辑。其他实现可以进行不同方式的操作。）如果不编辑树，则没有任何影响。
注：
当用户在树中更改它们的位置时，要使编辑-保存自动化，请使用 setInvokesStopCellEditing(boolean)。

返回：
如果编辑正在进行中，并且目前已停止，则返回 true，如果编辑不在进行中，则返回 false

cancelEditing

public void cancelEditing()
取消当前编辑会话。如果不编辑树，则没有任何影响。

startEditingAtPath

public void startEditingAtPath(TreePath path)
选择指定路径标识的节点，并开始编辑。如果 CellEditor 不允许编辑指定的项，则编辑尝试失败。

参数：
path - 标识节点的 TreePath

getEditingPath

public TreePath getEditingPath()
返回当前正在编辑的元素的路径。

返回：
正在编辑的节点的 TreePath

setSelectionModel

public void setSelectionModel(TreeSelectionModel selectionModel)
设置树的选择模型。若指定 null 值，则使用空 selectionModel，不允许选择。

参数：
selectionModel - 要使用的 TreeSelectionModel，null 表示禁用选择
另请参见：
TreeSelectionModel

getSelectionModel

public TreeSelectionModel getSelectionModel()
返回选择的模型。应该始终返回非 null 值。如果您不希望允许选择任何内容，则将选择模型设置为 null，它会强制使用空选择模型。

另请参见：
setSelectionModel(javax.swing.tree.TreeSelectionModel)

getPathBetweenRows

protected TreePath[] getPathBetweenRows(int index0,
                                        int index1)
返回 JTreePath 实例，它表示 index0 和 index1（包括 index1）之间的路径。如果不存在树，则返回 null。

参数：
index0 - 指定一个显示行的整数，其中 0 表示显示的第一行
index1 - 指定第二个显示行的整数
返回：
TreePath 对象的数组（index0 和 index1 之间的每个节点包含一个该对象）；如果不存在树，则返回 null

setSelectionInterval

public void setSelectionInterval(int index0,
                                 int index1)
选择 index0 和 index1（包含）之间的节点。

参数：
index0 - 指定一个显示行的整数，其中 0 是显示的第一行
index1 - 指定第二个显示行的整数

addSelectionInterval

public void addSelectionInterval(int index0,
                                 int index1)
将 index0 和 index1（包含）之间的路径添加到该选择。

参数：
index0 - 指定一个显示行的整数，其中 0 是显示的第一行
index1 - 指定第二个显示行的整数

removeSelectionInterval

public void removeSelectionInterval(int index0,
                                    int index1)
从该选择中移除 index0 和 index1（包含）之间的节点。

参数：
index0 - 指定一个显示行的整数，其中 0 是显示的第一行
index1 - 指定第二个显示行的整数

removeSelectionPath

public void removeSelectionPath(TreePath path)
从当前选择中移除指定路径标识的节点。

参数：
path - 标识节点的 TreePath

removeSelectionPaths

public void removeSelectionPaths(TreePath[] paths)
从当前选择移除指定路径标识的节点。

参数：
paths - 指定要移除的节点的 TreePath 对象数组

removeSelectionRow

public void removeSelectionRow(int row)
从当前选择移除索引 row 处的行。

参数：
row - 要移除的行

removeSelectionRows

public void removeSelectionRows(int[] rows)
移除在每个指定行处选择的行。

参数：
rows - 指定显示行的 int 数组，其中 0 表示显示的第一行

clearSelection

public void clearSelection()
清除该选择。

isSelectionEmpty

public boolean isSelectionEmpty()
如果该选择当前为空，则返回 true。

返回：
如果该选择当前为空，则返回 true

addTreeExpansionListener

public void addTreeExpansionListener(TreeExpansionListener tel)
为 TreeExpansion 事件添加侦听器。

参数：
tel - 当展开或折叠（“负展开”）树节点时，将要通知的 TreeExpansionListener

removeTreeExpansionListener

public void removeTreeExpansionListener(TreeExpansionListener tel)
移除 TreeExpansion 事件的侦听器。

参数：
tel - 要移除的 TreeExpansionListener

getTreeExpansionListeners

public TreeExpansionListener[] getTreeExpansionListeners()
返回使用 addTreeExpansionListener() 添加到此 JTree 的所有 TreeExpansionListener 的数组。

返回：
添加的所有 TreeExpansionListener，若未添加任何侦听器，则返回空数组
从以下版本开始：
1.4

addTreeWillExpandListener

public void addTreeWillExpandListener(TreeWillExpandListener tel)
为 TreeWillExpand 事件添加侦听器。

参数：
tel - 当展开或折叠（“负展开”）树节点时，将要通知的 TreeWillExpandListener

removeTreeWillExpandListener

public void removeTreeWillExpandListener(TreeWillExpandListener tel)
移除 TreeWillExpand 事件的侦听器。

参数：
tel - 要移除的 TreeWillExpandListener

getTreeWillExpandListeners

public TreeWillExpandListener[] getTreeWillExpandListeners()
返回使用 addTreeWillExpandListener() 添加到此 JTree 的所有 TreeWillExpandListener 的数组。

返回：
添加的所有 TreeWillExpandListener，若未添加任何侦听器，则返回空数组
从以下版本开始：
1.4

fireTreeExpanded

public void fireTreeExpanded(TreePath path)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用 path 参数以延迟方式创建事件实例。

参数：
path - 指示展开的节点的 TreePath
另请参见：
EventListenerList

fireTreeCollapsed

public void fireTreeCollapsed(TreePath path)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用 path 参数以延迟方式创建事件实例。

参数：
path - 指示折叠的节点的 TreePath
另请参见：
EventListenerList

fireTreeWillExpand

public void fireTreeWillExpand(TreePath path)
                        throws ExpandVetoException
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用 path 参数以延迟方式创建事件实例。

参数：
path - 指示展开的节点的 TreePath
抛出：
ExpandVetoException
另请参见：
EventListenerList

fireTreeWillCollapse

public void fireTreeWillCollapse(TreePath path)
                          throws ExpandVetoException
通知已注册对获得此事件类型通知感兴趣的所有侦听器。使用 path 参数以延迟方式创建事件实例。

参数：
path - 指示展开的节点的 TreePath
抛出：
ExpandVetoException
另请参见：
EventListenerList

addTreeSelectionListener

public void addTreeSelectionListener(TreeSelectionListener tsl)
为 TreeSelection 事件添加侦听器。

参数：
tsl - 当选中或取消选中（“负选择”）节点时，将要通知的 TreeSelectionListener

removeTreeSelectionListener

public void removeTreeSelectionListener(TreeSelectionListener tsl)
移除 TreeSelection 侦听器。

参数：
tsl - 要移除的 TreeSelectionListener

getTreeSelectionListeners

public TreeSelectionListener[] getTreeSelectionListeners()
返回使用 addTreeSelectionListener() 添加到此 JTree 的所有 TreeSelectionListener 的数组。

返回：
添加的所有 TreeSelectionListener，若未添加任何侦听器，则返回空数组
从以下版本开始：
1.4

fireValueChanged

protected void fireValueChanged(TreeSelectionEvent e)
通知已注册对获得此事件类型通知感兴趣的所有侦听器。

参数：
e - 要激发的 TreeSelectionEvent；当选中或取消选中节点时，由 TreeSelectionModel 生成
另请参见：
EventListenerList

treeDidChange

public void treeDidChange()
当树被更改得足以需要调整边界大小，但还不足以需要移除展开的节点集（例如，展开或折叠节点，或者将节点插入到树）时发送。您从不需要调用它，当需要时，UI 会调用它。

setVisibleRowCount

public void setVisibleRowCount(int newCount)
设置要显示的行数。仅当树包含在 JScrollPane 中时才工作，并将调整首选大小和该滚动窗格的大小。

参数：
newCount - 要显示的行数

getVisibleRowCount

public int getVisibleRowCount()
返回显示区域中显示的行数。

返回：
显示的行数

getNextMatch

public TreePath getNextMatch(String prefix,
                             int startingRow,
                             Position.Bias bias)
将 TreePath 返回到以一个前缀开头的下一个树元素。要处理 TreePath 到字符串的转换，将用到 convertValueToText。

参数：
prefix - 要测试是否匹配的字符串
startingRow - 用于启动搜索的行
bias - 搜索方向，Position.Bias.Forward 或 Position.Bias.Backward。
返回：
以该前缀开始的下一个树元素的 TreePath；否则返回 null
抛出：
IllegalArgumentException - 如果前缀为 null，或 startingRow 在边界之外
从以下版本开始：
1.4

getPreferredScrollableViewportSize

public Dimension getPreferredScrollableViewportSize()
返回 JTree 的首选显示大小。高度根据 getVisibleRowCount 确定，宽度是当前的首选宽度。

指定者：
接口 Scrollable 中的 getPreferredScrollableViewportSize
返回：
包含首选大小的 Dimension 对象
另请参见：
JComponent.getPreferredSize()

getScrollableUnitIncrement

public int getScrollableUnitIncrement(Rectangle visibleRect,
                                      int orientation,
                                      int direction)
返回滚动时增加的数量。该数量是第一个显示行（不完全在视图中）的高度，如果该行完全显示，那么该数量是滚动方向中下一个行的高度。

指定者：
接口 Scrollable 中的 getScrollableUnitIncrement
参数：
visibleRect - 视口中可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
direction - 小于 0 向上/左滚动，大于 0 向下/右滚动
返回：
按指定方向滚动的“单位”增量
另请参见：
JScrollBar.setUnitIncrement(int)

getScrollableBlockIncrement

public int getScrollableBlockIncrement(Rectangle visibleRect,
                                       int orientation,
                                       int direction)
返回块增量的数量，它是基于 orientation 的 visibleRect 高度或宽度。

指定者：
接口 Scrollable 中的 getScrollableBlockIncrement
参数：
visibleRect - 视口中可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL
direction - 小于 0 向上/左滚动，大于 0 向下/右滚动。
返回：
按指定方向滚动的“块”增量
另请参见：
JScrollBar.setBlockIncrement(int)

getScrollableTracksViewportWidth

public boolean getScrollableTracksViewportWidth()
返回 false 指示视口的宽度不能确定表的宽度，除非树的首选宽度小于视口宽度。换句话说：确保树从不小于其视口。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportWidth
返回：
false
另请参见：
Scrollable.getScrollableTracksViewportWidth()

getScrollableTracksViewportHeight

public boolean getScrollableTracksViewportHeight()
返回 false 指示视口的高度不能确定表的高度，除非树的首选高度小于视口高度。换句话说：确保树从不小于其视口。

指定者：
接口 Scrollable 中的 getScrollableTracksViewportHeight
返回：
false
另请参见：
Scrollable.getScrollableTracksViewportHeight()

setExpandedState

protected void setExpandedState(TreePath path,
                                boolean state)
设置此 JTree 的展开状态。如果 state 为 true，则 path 的所有父路径和路径都被标记为展开。如果 state 为 false，则 path 的所有父路径被标记为展开，但是 path 本身被标记为折叠。

如果 TreeWillExpandListener 禁止它，则会失败。

getDescendantToggledPaths

protected Enumeration<TreePath> getDescendantToggledPaths(TreePath parent)
返回已展开且为 parent 的子路径的 TreePath 的 Enumeration。

removeDescendantToggledPaths

protected void removeDescendantToggledPaths(Enumeration<TreePath> toRemove)
移除已展开的 toRemove 中 TreePath 的所有子路径。

clearToggledPaths

protected void clearToggledPaths()
清除切换的树路径的缓存。这不会发送任何 TreeExpansionListener 事件。

createTreeModelListener

protected TreeModelListener createTreeModelListener()
创建并返回 TreeModelHandler 的一个实例。返回的对象负责 TreeModel 更改时更新展开的状态。

有关展开状态的含义的更多信息，请参阅上述 JTree 描述。

removeDescendantSelectedPaths

protected boolean removeDescendantSelectedPaths(TreePath path,
                                                boolean includePath)
移除选择中的任何路径（path 的子路径）。如果 includePath 为 true，并且选中 path，则从该选择中移除它。

返回：
如果选择子路径，则返回 true
从以下版本开始：
1.3

paramString

protected String paramString()
返回此 JTree 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JTree 的字符串表示形式。

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JTree 关联的 AccessibleContext。对于 JTrees，AccessibleContext 采用 AccessibleJTree 的形式。必要时创建一个新的 AccessibleJTree 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJTree，它充当此 JTree 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.AccessibleJTree (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.AccessibleJTree

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JTree.AccessibleJTree
所有已实现的接口：
Serializable, EventListener, AccessibleComponent, AccessibleExtendedComponent, AccessibleSelection, TreeExpansionListener, TreeModelListener, TreeSelectionListener
正在封闭类：
JTree
protected class JTree.AccessibleJTree
extends JComponent.AccessibleJComponent
implements AccessibleSelection, TreeSelectionListener, TreeModelListener, TreeExpansionListener

此类实现 JTree 类的可访问性支持。它提供适合树用户界面元素的 Java Accessibility API 的实现。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
protected  class JTree.AccessibleJTree.AccessibleJTreeNode
此类实现 JTree 子类的可访问性支持。
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
JTree.AccessibleJTree()
方法摘要
void | addAccessibleSelection(int i) 将对象中指定选择的项添加到对象的选择中。
void | clearAccessibleSelection() 清除对象中的选择，这样此对象中什么也没有选择。
void | fireVisibleDataPropertyChange() 激发可见数据属性更改通知。
Accessible | getAccessibleAt(Point p) 返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
Accessible | getAccessibleChild(int i) 返回对象的第 n 个可访问子对象。
int | getAccessibleChildrenCount() 返回此 JTree 的顶层子节点数。
int | getAccessibleIndexInParent() 获取此对象在其可访问父对象中的索引。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象相关联的 AccessibleSelection。
Accessible | getAccessibleSelection(int i) 返回表示对象中指定选择项的 Accessible。
int | getAccessibleSelectionCount() 返回当前选中的项数。
boolean | isAccessibleChildSelected(int i) 如果选择了此对象的当前子对象，则返回 true。
void | removeAccessibleSelection(int i) 将对象中指定选择项从对象的选择中移除。
void | selectAllAccessibleSelection() 导致对象中的所有选择项都被选中，前提是对象支持多个选择。
void | treeCollapsed(TreeExpansionEvent e) 树折叠通知。
void | treeExpanded(TreeExpansionEvent e) 树模型展开通知。
void | treeNodesChanged(TreeModelEvent e) 树模型节点更改通知。
void | treeNodesInserted(TreeModelEvent e) 树模型节点更改通知。
void | treeNodesRemoved(TreeModelEvent e) 树模型节点更改通知。
void | treeStructureChanged(TreeModelEvent e) 树模型结构更改通知。
void | valueChanged(TreeSelectionEvent e) 树选择侦听器值更改方法。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JTree.AccessibleJTree

public JTree.AccessibleJTree()
方法详细信息

valueChanged

public void valueChanged(TreeSelectionEvent e)
树选择侦听器值更改方法。用于激发属性更改

指定者：
接口 TreeSelectionListener 中的 valueChanged
参数：
e - ListSelectionEvent

fireVisibleDataPropertyChange

public void fireVisibleDataPropertyChange()
激发可见数据属性更改通知。“可见”数据属性表示组件在显示器上的显示方式，其外观不受限于任何其他属性。它通知屏幕 reader 组件的可见外观已发生更改，因此它们可以通知用户。

treeNodesChanged

public void treeNodesChanged(TreeModelEvent e)
树模型节点更改通知。

指定者：
接口 TreeModelListener 中的 treeNodesChanged
参数：
e - 树模型事件

treeNodesInserted

public void treeNodesInserted(TreeModelEvent e)
树模型节点更改通知。

指定者：
接口 TreeModelListener 中的 treeNodesInserted
参数：
e - 树节点插入事件

treeNodesRemoved

public void treeNodesRemoved(TreeModelEvent e)
树模型节点更改通知。

指定者：
接口 TreeModelListener 中的 treeNodesRemoved
参数：
e - 树节点移除事件

treeStructureChanged

public void treeStructureChanged(TreeModelEvent e)
树模型结构更改通知。

指定者：
接口 TreeModelListener 中的 treeStructureChanged
参数：
e - 树模型事件

treeCollapsed

public void treeCollapsed(TreeExpansionEvent e)
树折叠通知。

指定者：
接口 TreeExpansionListener 中的 treeCollapsed
参数：
e - 一个 TreeExpansionEvent

treeExpanded

public void treeExpanded(TreeExpansionEvent e)
树模型展开通知。

指定者：
接口 TreeExpansionListener 中的 treeExpanded
参数：
e - 树节点插入事件

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。否则返回 null。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
覆盖：
类 Container.AccessibleAWTContainer 中的 getAccessibleAt
参数：
p - 此 Accessible 的本地坐标中的点
返回：
在指定位置的 Accessible（如果存在）；否则返回 null

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回此 JTree 的顶层子节点数。每个这样的节点都可以依次拥有子节点。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChildrenCount
返回：
树中的可访问子节点数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的第 n 个可访问子对象。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
对象的第 n 个可访问子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问父对象中的索引。

覆盖：
类 Component.AccessibleAWTComponent 中的 getAccessibleIndexInParent
返回：
此对象在其父对象中的索引。因为 JTree 顶层对象没有可访问父对象。
另请参见：
Component.AccessibleAWTComponent.getAccessibleParent()

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象相关联的 AccessibleSelection。在此类的 Java Accessibility API 的实现中，返回的是此对象，它负责为其本身实现 AccessibleSelection 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
此对象
另请参见：
AccessibleSelection

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选中的项数。如果未选择项，则返回值 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选择的项数。

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回表示对象中指定选择项的 Accessible。如果没有作出选择，或者所选项数少于传入的整数，则返回值为 null。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选项的从零开始的索引
返回：
包含所选项的 Accessible
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
如果选择了此对象的当前子对象，则返回 true。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子级的从零开始的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将对象中指定选择的项添加到对象的选择中。如果对象支持多种选择，则将指定项添加到所有现有选择中，否则它将替换对象中的所有现有选择。如果已经选择了指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
将对象中指定选择项从对象的选择中移除。如果当前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，这样此对象中什么也没有选择。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
导致对象中的所有选择项都被选中，前提是对象支持多个选择。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.AccessibleJTree.AccessibleJTreeNode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.AccessibleJTree.AccessibleJTreeNode

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode
所有已实现的接口：
Accessible, AccessibleAction, AccessibleComponent, AccessibleSelection
正在封闭类：
JTree.AccessibleJTree
protected class JTree.AccessibleJTree.AccessibleJTreeNode
extends AccessibleContext
implements Accessible, AccessibleComponent, AccessibleSelection, AccessibleAction

此类实现 JTree 子类的可访问性支持。它提供适合树节点的 Java Accessibility API 实现。

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName
从接口 javax.accessibility.AccessibleAction 继承的字段
CLICK, DECREMENT, INCREMENT, TOGGLE_EXPAND, TOGGLE_POPUP
构造方法摘要
JTree.AccessibleJTree.AccessibleJTreeNode(JTree t, TreePath p, Accessible ap)
构造一个 AccessibleJTreeNode
方法摘要
void | addAccessibleSelection(int i) 将对象中指定选择的项添加到对象的选择中。
void | addFocusListener(FocusListener l) 添加指定的焦点侦听器，以接收来自此组件的焦点事件。
void | addPropertyChangeListener(PropertyChangeListener l) 将 PropertyChangeListener 添加到侦听器列表。
void | clearAccessibleSelection() 清除对象中的选择，这样此对象中什么也没有选择。
boolean | contains(Point p) 检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。
boolean | doAccessibleAction(int i) 执行树节点上的指定操作。
AccessibleAction | getAccessibleAction() 获取与此对象关联的 AccessibleAction。
int | getAccessibleActionCount() 返回此树节点中可用的可访问操作数。
String | getAccessibleActionDescription(int i) 返回该树节点的指定操作的描述。
Accessible | getAccessibleAt(Point p) 返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。
Accessible | getAccessibleChild(int i) 返回对象的指定 Accessible 子对象。
int | getAccessibleChildrenCount() 返回对象中的可访问子对象数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent。
AccessibleContext | getAccessibleContext() 获取与此树节点关联的 AccessibleContext。
String | getAccessibleDescription() 获取此对象的可访问的描述。
int | getAccessibleIndexInParent() 获取此对象在其可访问父对象中的索引。
String | getAccessibleName() 获取此对象的可访问名称。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleSelection | getAccessibleSelection() 获取与此对象关联的 AccessibleSelection（如果存在）。
Accessible | getAccessibleSelection(int i) 返回表示对象中指定选择项的 Accessible。
int | getAccessibleSelectionCount() 返回当前选中的项数。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态设置。
AccessibleText | getAccessibleText() 获取与此对象关联的 AccessibleText（如果存在）。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue（如果存在）。
Color | getBackground() 获取此对象的背景色。
Rectangle | getBounds() 获取 Rectangle 对象形式的此对象的边界。
Cursor | getCursor() 获取此对象的 Cursor。
Font | getFont() 获取此对象的 Font。
FontMetrics | getFontMetrics(Font f) 获取此对象的 FontMetrics。
Color | getForeground() 获取此对象的前景色。
Locale | getLocale() 获取组件的区域。
Point | getLocation() 获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。
protected Point | getLocationInJTree()
Point | getLocationOnScreen() 返回对象在屏幕上的位置。
Dimension | getSize() 以 Dimension 对象的形式返回此对象的大小。
boolean | isAccessibleChildSelected(int i) 如果选择了此对象的当前子对象，则返回 true。
boolean | isEnabled() 确定是否已启用该对象。
boolean | isFocusTraversable() 返回此对象是否可以接受焦点。
boolean | isShowing() 确定是否正显示对象。
boolean | isVisible() 确定此对象是否可见。
void | removeAccessibleSelection(int i) 将该对象中指定选择的项从该对象的选择中移除。
void | removeFocusListener(FocusListener l) 移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。
void | removePropertyChangeListener(PropertyChangeListener l) 从侦听器列表中移除 PropertyChangeListener。
void | requestFocus() 请求此对象的焦点。
void | selectAllAccessibleSelection() 导致该对象中的所有选择项都被选中，前提是该对象支持多个选择。
void | setAccessibleDescription(String s) 设置此对象的可访问描述。
void | setAccessibleName(String s) 设置此对象的本地化可访问名称。
void | setBackground(Color c) 设置此对象的背景色。
void | setBounds(Rectangle r) 设置 Rectangle 对象形式的此对象的边界。
void | setCursor(Cursor c) 设置此对象的 Cursor。
void | setEnabled(boolean b) 设置对象的启用状态。
void | setFont(Font f) 设置此对象的 Font。
void | setForeground(Color c) 设置此对象的前景色。
void | setLocation(Point p) 设置对象相对于父级的位置。
void | setSize(Dimension d) 调整此对象，使其具有高度和宽度。
void | setVisible(boolean b) 设置对象的可见状态。
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleTable, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTree.AccessibleJTree.AccessibleJTreeNode

public JTree.AccessibleJTree.AccessibleJTreeNode(JTree t,
                                                 TreePath p,
                                                 Accessible ap)
构造一个 AccessibleJTreeNode

从以下版本开始：
1.4
方法详细信息

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此树节点关联的 AccessibleContext。在此类的 Java Accessibility API 的实现中，返回的是此对象，它是其自身的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
此对象

getAccessibleName

public String getAccessibleName()
获取此对象的可访问名称。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

setAccessibleName

public void setAccessibleName(String s)
设置此对象的本地化可访问名称。

覆盖：
类 AccessibleContext 中的 setAccessibleName
参数：
s - 对象的新本地化名称。
另请参见：
AccessibleContext.getAccessibleName(), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleDescription

public String getAccessibleDescription()
获取此对象的可访问的描述。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

setAccessibleDescription

public void setAccessibleDescription(String s)
设置此对象的可访问描述。

覆盖：
类 AccessibleContext 中的 setAccessibleDescription
参数：
s - 此对象的新的本地化描述
另请参见：
AccessibleContext.setAccessibleName(java.lang.String), AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态设置。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
此对象的 Accessible 父对象；如果此对象没有 Accessible 父对象，则返回 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象的父对象中的索引；如果此对象没有可访问父对象，则返回 -1。
另请参见：
getAccessibleParent()

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中的可访问子对象数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
对象的可访问子对象数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回对象的指定 Accessible 子对象。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 从零开始的子对象索引
返回：
对象的 Accessible 子对象
另请参见：
AccessibleContext.getAccessibleChildrenCount()

getLocale

public Locale getLocale()
获取组件的区域。如果该组件没有区域，则返回其父级的区域。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此组件的区域。如果此组件没有区域，则返回其父级的区域。
抛出：
IllegalComponentStateException - 如果该 Component 没有自己的区域，并且尚未被添加到包含层次结构（那样可以从包含父级确定其区域）。
另请参见：
Component.setLocale(java.util.Locale)

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener l)
将 PropertyChangeListener 添加到侦听器列表。此侦听器为所有属性注册。

覆盖：
类 AccessibleContext 中的 addPropertyChangeListener
参数：
l - 要添加的 PropertyChangeListener
另请参见：
AccessibleContext.ACCESSIBLE_NAME_PROPERTY, AccessibleContext.ACCESSIBLE_DESCRIPTION_PROPERTY, AccessibleContext.ACCESSIBLE_STATE_PROPERTY, AccessibleContext.ACCESSIBLE_VALUE_PROPERTY, AccessibleContext.ACCESSIBLE_SELECTION_PROPERTY, AccessibleContext.ACCESSIBLE_TEXT_PROPERTY, AccessibleContext.ACCESSIBLE_VISIBLE_DATA_PROPERTY

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener l)
从侦听器列表中移除 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

覆盖：
类 AccessibleContext 中的 removePropertyChangeListener
参数：
l - 要移除的 PropertyChangeListener

getAccessibleAction

public AccessibleAction getAccessibleAction()
获取与此对象关联的 AccessibleAction。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其自身实现 AccessibleAction 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleAction
返回：
此对象
另请参见：
AccessibleAction

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent。在针对此类的 Java Accessibility API 的实现中，返回此对象，它负责代表其自身实现 AccessibleComponent 接口。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
此对象
另请参见：
AccessibleComponent

getAccessibleSelection

public AccessibleSelection getAccessibleSelection()
获取与此对象关联的 AccessibleSelection（如果存在）。否则，返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleSelection
返回：
AccessibleSelection 或 null
另请参见：
AccessibleSelection

getAccessibleText

public AccessibleText getAccessibleText()
获取与此对象关联的 AccessibleText（如果存在）。否则，返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
AccessibleText 或 null
另请参见：
AccessibleText

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue（如果存在）。否则，返回 null。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
AccessibleValue 或 null
另请参见：
AccessibleValue

getBackground

public Color getBackground()
获取此对象的背景色。

指定者：
接口 AccessibleComponent 中的 getBackground
返回：
对象的背景色（如果受支持）；否则返回 null
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

setBackground

public void setBackground(Color c)
设置此对象的背景色。

指定者：
接口 AccessibleComponent 中的 setBackground
参数：
c - 背景的新颜色
另请参见：
AccessibleComponent.setBackground(java.awt.Color)

getForeground

public Color getForeground()
获取此对象的前景色。

指定者：
接口 AccessibleComponent 中的 getForeground
返回：
对象的前景色（如果受支持）；否则，返回 null
另请参见：
AccessibleComponent.setForeground(java.awt.Color)

setForeground

public void setForeground(Color c)
从接口 AccessibleComponent 复制的描述
设置此对象的前景色。

指定者：
接口 AccessibleComponent 中的 setForeground
参数：
c - 新的前景 Color
另请参见：
AccessibleComponent.getForeground()

getCursor

public Cursor getCursor()
从接口 AccessibleComponent 复制的描述
获取此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 getCursor
返回：
如果支持的话，返回对象的 Cursor；否则返回 null
另请参见：
AccessibleComponent.setCursor(java.awt.Cursor)

setCursor

public void setCursor(Cursor c)
从接口 AccessibleComponent 复制的描述
设置此对象的 Cursor。

指定者：
接口 AccessibleComponent 中的 setCursor
参数：
c - 对象的新 Cursor
另请参见：
AccessibleComponent.getCursor()

getFont

public Font getFont()
从接口 AccessibleComponent 复制的描述
获取此对象的 Font。

指定者：
接口 AccessibleComponent 中的 getFont
返回：
如果支持的话，返回对象的 Font；否则返回 null
另请参见：
AccessibleComponent.setFont(java.awt.Font)

setFont

public void setFont(Font f)
从接口 AccessibleComponent 复制的描述
设置此对象的 Font。

指定者：
接口 AccessibleComponent 中的 setFont
参数：
f - 对象的新 Font
另请参见：
AccessibleComponent.getFont()

getFontMetrics

public FontMetrics getFontMetrics(Font f)
从接口 AccessibleComponent 复制的描述
获取此对象的 FontMetrics。

指定者：
接口 AccessibleComponent 中的 getFontMetrics
参数：
f - Font
返回：
如果支持的话，返回对象的 FontMetrics；否则返回 null
另请参见：
AccessibleComponent.getFont()

isEnabled

public boolean isEnabled()
从接口 AccessibleComponent 复制的描述
确定是否已启用该对象。启用的对象在其 AccessibleStateSet 中也将具有 AccessibleState.ENABLED 状态设置。

指定者：
接口 AccessibleComponent 中的 isEnabled
返回：
如果已启用对象，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setEnabled(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.ENABLED, AccessibleStateSet

setEnabled

public void setEnabled(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的启用状态。

指定者：
接口 AccessibleComponent 中的 setEnabled
参数：
b - 如果为 true，则启用此对象；否则禁用它
另请参见：
AccessibleComponent.isEnabled()

isVisible

public boolean isVisible()
从接口 AccessibleComponent 复制的描述
确定此对象是否可见。注：这意味着该对象多半是可见的；但是因为包含此对象的对象之一目前不可见，所以可能在屏幕上不显示它。要确定对象是否在屏幕上显示，需要使用 isShowing()。

可见的对象在其 AccessibleStateSet 中也将具有 AccessibleState.VISIBLE 状态设置。

指定者：
接口 AccessibleComponent 中的 isVisible
返回：
如果对象可见，则返回 true；否则返回 false
另请参见：
AccessibleComponent.setVisible(boolean), AccessibleContext.getAccessibleStateSet(), AccessibleState.VISIBLE, AccessibleStateSet

setVisible

public void setVisible(boolean b)
从接口 AccessibleComponent 复制的描述
设置对象的可见状态。

指定者：
接口 AccessibleComponent 中的 setVisible
参数：
b - 如果为 true，则显示此对象；否则隐藏它
另请参见：
AccessibleComponent.isVisible()

isShowing

public boolean isShowing()
从接口 AccessibleComponent 复制的描述
确定是否正显示对象。通过检查该对象和祖先的可见性可确定这一点。注：即使该对象被另一对象屏蔽（例如，它是下拉菜单的下级），仍然返回 true。

指定者：
接口 AccessibleComponent 中的 isShowing
返回：
如果正在显示对象，则返回 true；否则，返回 false

contains

public boolean contains(Point p)
从接口 AccessibleComponent 复制的描述
检查指定点是否位于此对象的边界内，其中该点的 X 坐标和 Y 坐标是相对于对象的坐标系统定义的。

指定者：
接口 AccessibleComponent 中的 contains
参数：
p - 相对于对象的坐标系统的 Point
返回：
如果对象包含 Point，则返回 true；否则返回 false
另请参见：
AccessibleComponent.getBounds()

getLocationOnScreen

public Point getLocationOnScreen()
从接口 AccessibleComponent 复制的描述
返回对象在屏幕上的位置。

指定者：
接口 AccessibleComponent 中的 getLocationOnScreen
返回：
返回对象在屏幕上的位置；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocation()

getLocationInJTree

protected Point getLocationInJTree()

getLocation

public Point getLocation()
从接口 AccessibleComponent 复制的描述
获得此对象相对于父对象的位置，返回值是一个点对象，它指定对象左上角在屏幕坐标空间内的位置。

指定者：
接口 AccessibleComponent 中的 getLocation
返回：
Point 的实例，该点表示屏幕坐标空间中对象边界的左上角 ；如果此对象或其父级不在屏幕上，则返回 null
另请参见：
AccessibleComponent.getBounds(), AccessibleComponent.getLocationOnScreen()

setLocation

public void setLocation(Point p)
从接口 AccessibleComponent 复制的描述
设置对象相对于父级的位置。

指定者：
接口 AccessibleComponent 中的 setLocation
参数：
p - 左上角的新位置
另请参见：
AccessibleComponent.getLocation()

getBounds

public Rectangle getBounds()
从接口 AccessibleComponent 复制的描述
获取 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 getBounds
返回：
返回指示此组件的边界的矩形；如果此对象不在屏幕上，则返回 null。
另请参见：
AccessibleComponent.contains(java.awt.Point)

setBounds

public void setBounds(Rectangle r)
从接口 AccessibleComponent 复制的描述
设置 Rectangle 对象形式的此对象的边界。该边界指定此对象的宽、高，以及相对于父对象的位置。

指定者：
接口 AccessibleComponent 中的 setBounds
参数：
r - 指示此组件边界的矩形
另请参见：
AccessibleComponent.getBounds()

getSize

public Dimension getSize()
从接口 AccessibleComponent 复制的描述
以 Dimension 对象的形式返回此对象的大小。Dimension 对象的 height 字段包含此对象的高度，Dimension 对象的 width 字段包含此对象的宽度。

指定者：
接口 AccessibleComponent 中的 getSize
返回：
返回指示此组件大小的 Dimension 对象；如果此对象不在屏幕上，则返回 null
另请参见：
AccessibleComponent.setSize(java.awt.Dimension)

setSize

public void setSize(Dimension d)
从接口 AccessibleComponent 复制的描述
调整此对象，使其具有高度和宽度。

指定者：
接口 AccessibleComponent 中的 setSize
参数：
d - 指定对象新大小的维数。
另请参见：
AccessibleComponent.getSize()

getAccessibleAt

public Accessible getAccessibleAt(Point p)
返回 Accessible 子对象（如果存在），它包含在本地坐标 Point 中。否则返回 null。

指定者：
接口 AccessibleComponent 中的 getAccessibleAt
参数：
p - 此 Accessible 的本地坐标中的点
返回：
在指定位置的 Accessible（如果存在）；否则返回 null

isFocusTraversable

public boolean isFocusTraversable()
从接口 AccessibleComponent 复制的描述
返回此对象是否可以接受焦点。可以接受焦点的对象也将具有在其 AccessibleStateSet 中设置的 AccessibleState.FOCUSABLE 状态。

指定者：
接口 AccessibleComponent 中的 isFocusTraversable
返回：
如果对象可以接受焦点，则返回 true；否则返回 false
另请参见：
AccessibleContext.getAccessibleStateSet(), AccessibleState.FOCUSABLE, AccessibleState.FOCUSED, AccessibleStateSet

requestFocus

public void requestFocus()
从接口 AccessibleComponent 复制的描述
请求此对象的焦点。如果此对象不能接受焦点，则不执行任何操作。否则，对象将尝试接受焦点。

指定者：
接口 AccessibleComponent 中的 requestFocus
另请参见：
AccessibleComponent.isFocusTraversable()

addFocusListener

public void addFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
添加指定的焦点侦听器，以接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 addFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.removeFocusListener(java.awt.event.FocusListener)

removeFocusListener

public void removeFocusListener(FocusListener l)
从接口 AccessibleComponent 复制的描述
移除指定的焦点侦听器，使其不再接收来自此组件的焦点事件。

指定者：
接口 AccessibleComponent 中的 removeFocusListener
参数：
l - 焦点侦听器
另请参见：
AccessibleComponent.addFocusListener(java.awt.event.FocusListener)

getAccessibleSelectionCount

public int getAccessibleSelectionCount()
返回当前选中的项数。如果未选择项，则返回值 0。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelectionCount
返回：
当前选择的项数。

getAccessibleSelection

public Accessible getAccessibleSelection(int i)
返回表示对象中指定选择项的 Accessible。如果没有作出选择，或者所选项数少于传入的整数，则返回值为 null。

指定者：
接口 AccessibleSelection 中的 getAccessibleSelection
参数：
i - 所选项的从零开始的索引
返回：
包含所选项的 Accessible
另请参见：
AccessibleSelection.getAccessibleSelectionCount()

isAccessibleChildSelected

public boolean isAccessibleChildSelected(int i)
如果选择了此对象的当前子对象，则返回 true。

指定者：
接口 AccessibleSelection 中的 isAccessibleChildSelected
参数：
i - 此 Accessible 对象的子对象的从零开始的索引。
返回：
如果此对象的当前子级已选中，则返回 true；否则返回 false。
另请参见：
AccessibleContext.getAccessibleChild(int)

addAccessibleSelection

public void addAccessibleSelection(int i)
将对象中指定选择的项添加到对象的选择中。如果对象支持多种选择，则将指定项添加到所有现有选择中，否则它将替换对象中的所有现有选择。如果已经选择了指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 addAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

removeAccessibleSelection

public void removeAccessibleSelection(int i)
将该对象中指定选择的项从该对象的选择中移除。如果当前没有选择指定的项，则此方法无效。

指定者：
接口 AccessibleSelection 中的 removeAccessibleSelection
参数：
i - 可选择项的从零开始的索引
另请参见：
AccessibleContext.getAccessibleChild(int)

clearAccessibleSelection

public void clearAccessibleSelection()
清除对象中的选择，这样此对象中什么也没有选择。

指定者：
接口 AccessibleSelection 中的 clearAccessibleSelection

selectAllAccessibleSelection

public void selectAllAccessibleSelection()
导致该对象中的所有选择项都被选中，前提是该对象支持多个选择。

指定者：
接口 AccessibleSelection 中的 selectAllAccessibleSelection

getAccessibleActionCount

public int getAccessibleActionCount()
返回此树节点中可用的可访问操作数。如果此节点不是叶节点，则除 TreeCellRenderer 后面对象上所有可用操作外，至少还存在一个操作（切换展开）。

指定者：
接口 AccessibleAction 中的 getAccessibleActionCount
返回：
此对象中的操作数

getAccessibleActionDescription

public String getAccessibleActionDescription(int i)
返回该树节点的指定操作的描述。如果此节点不是叶节点，则除 TreeCellRenderer 后面对象上所有可用操作外，至少还存在一个操作描述（切换展开）。

指定者：
接口 AccessibleAction 中的 getAccessibleActionDescription
参数：
i - 该操作的从零开始的索引
返回：
该操作的描述
另请参见：
AccessibleAction.getAccessibleActionCount()

doAccessibleAction

public boolean doAccessibleAction(int i)
执行树节点上的指定操作。如果此节点不是叶节点，则除 TreeCellRenderer 后面对象上所有可用操作外，至少还存在一个可以完成的操作（切换展开）。

指定者：
接口 AccessibleAction 中的 doAccessibleAction
参数：
i - 操作的从零开始的索引
返回：
如果执行了该操作，则返回 true；否则返回 false。
另请参见：
AccessibleAction.getAccessibleActionCount()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.DropLocation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.DropLocation

java.lang.Object
    继承者  javax.swing.TransferHandler.DropLocation
        继承者  javax.swing.JTree.DropLocation
正在封闭类：
JTree
public static final class JTree.DropLocation
extends TransferHandler.DropLocation

TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。

从以下版本开始：
1.6
另请参见：
JTree.getDropLocation()

方法摘要
 int getChildIndex()
对于 getPath() 返回的路径，返回应该插入放置数据的位置的索引。
 TreePath getPath()
返回树中应该用来放入放置数据的路径。
 String toString()
返回此放置位置的字符串表示形式。
从类 javax.swing.TransferHandler.DropLocation 继承的方法
getDropPoint
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

方法详细信息

getChildIndex

public int getChildIndex()
对于 getPath() 返回的路径，返回应该插入放置数据的位置的索引。

对于放置模式 DropMode.USE_SELECTION 和 DropMode.ON，此索引并不重要（它将始终为 -1），因为所需的数据只是放置操作发生的路径。

对于放置模式 DropMode.INSERT，此索引指示 getPath() 所表示的父路径中应该插入数据的位置的索引。-1 指示放置操作发生在父路径上，在大多数情况下，应该被视为插入到子路径的父路径列表开始或结束的位置。

对于 DropMode.ON_OR_INSERT，此值将是一个插入索引，如上所述，如果放置操作发生在路径本身上，则此值为 -1。

返回：
子索引
另请参见：
getPath()

getPath

public TreePath getPath()
返回树中应该用来放入放置数据的路径。

对此值的解释取决于在关联组件上设置的放置模式。如果放置模式为 DropMode.USE_SELECTION 或 DropMode.ON，则返回值是树中放置了（或将放置）数据的路径。null 指示该放置操作发生在空格上，与特定路径没有关联。

如果放置模式为 DropMode.INSERT，则返回值是应该成为新数据父级的路径，在这种情况下，getChildIndex() 指示应该将新的项插入到此父路径的哪个位置。null 路径指示没有确定父路径，发生这种情况有很多原因：

  • 树没有模型
  • 树中没有根
  • 根是折叠的
  • 根是一个叶节点
由开发人员决定他们是否希望处理 null 的情况以及如何处理这种情况。

如果放置模式为 DropMode.ON_OR_INSERT，则可以使用 getChildIndex 来确定放置操作是否发生在路径本身的顶部（-1），或者路径中应该插入它的位置的索引（-1 以外的值）。

返回：
放置路径
另请参见：
getChildIndex()

toString

public String toString()
返回此放置位置的字符串表示形式。此方法仅用于调试，对于各个实现，所返回字符串的内容和格式可能有所不同。

覆盖：
类 TransferHandler.DropLocation 中的 toString
返回：
此放置位置的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.DynamicUtilTreeNode (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.DynamicUtilTreeNode

java.lang.Object
    继承者  javax.swing.tree.DefaultMutableTreeNode
        继承者  javax.swing.JTree.DynamicUtilTreeNode
所有已实现的接口：
Serializable, Cloneable, MutableTreeNode, TreeNode
正在封闭类：
JTree
public static class JTree.DynamicUtilTreeNode
extends DefaultMutableTreeNode

DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。它是动态的，因为它在需要时才创建子节点。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected Object | childValue 用于创建子节点的值。
protected boolean | hasChildren 此 JTree 是否具有子节点？目前未实现此属性。
protected boolean | loadedChildren 是否已加载此子节点？
从类 javax.swing.tree.DefaultMutableTreeNode 继承的字段
allowsChildren, children, EMPTY_ENUMERATION, parent, userObject
构造方法摘要
JTree.DynamicUtilTreeNode(Object value, Object children)
使用指定的对象作为其值并使用指定的子节点创建一个节点。
方法摘要
Enumeration | children() 必要时创建子类以加载此子节点。
static void | createChildren(DefaultMutableTreeNode parent, Object children) 将 children 中的所有子节点添加到父节点。
TreeNode | getChildAt(int index) 必要时创建子类以加载此子节点。
int | getChildCount() 返回子节点数。
boolean | isLeaf() 如果此节点允许子节点，则返回 true。
protected void | loadChildren() 根据 childValue 加载子节点。
从类 javax.swing.tree.DefaultMutableTreeNode 继承的方法
add, breadthFirstEnumeration, clone, depthFirstEnumeration, getAllowsChildren, getChildAfter, getChildBefore, getDepth, getFirstChild, getFirstLeaf, getIndex, getLastChild, getLastLeaf, getLeafCount, getLevel, getNextLeaf, getNextNode, getNextSibling, getParent, getPath, getPathToRoot, getPreviousLeaf, getPreviousNode, getPreviousSibling, getRoot, getSharedAncestor, getSiblingCount, getUserObject, getUserObjectPath, insert, isNodeAncestor, isNodeChild, isNodeDescendant, isNodeRelated, isNodeSibling, isRoot, pathFromAncestorEnumeration, postorderEnumeration, preorderEnumeration, remove, remove, removeAllChildren, removeFromParent, setAllowsChildren, setParent, setUserObject, toString
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

hasChildren

protected boolean hasChildren
此 JTree 是否具有子节点？目前未实现此属性。

childValue

protected Object childValue
用于创建子节点的值。

loadedChildren

protected boolean loadedChildren
是否已加载此子节点？

构造方法详细信息

JTree.DynamicUtilTreeNode

public JTree.DynamicUtilTreeNode(Object value,
                                 Object children)
使用指定的对象作为其值并使用指定的子节点创建一个节点。对于允许子节点的节点，该子节点对象必须为对象数组、Vector 或 Hashtable（即使为空）。否则，该节点不允许有子节点。

参数：
value - 作为新节点值的 Object
children - 用于创建子节点的一组 Object、一个 Vector 或一个 Hashtable；如果指定了任何其他对象，或者该值为 null，则不允许此节点有子节点
方法详细信息

createChildren

public static void createChildren(DefaultMutableTreeNode parent,
                                  Object children)
将 children 中的所有子节点添加到父节点。如果 children 是一个数组或向量，则其添加的所有元素都是子级；否则，如果 children 是一个哈希表，则按照 Enumeration 返回它们的顺序添加所有键/值对。

isLeaf

public boolean isLeaf()
如果此节点允许子节点，则返回 true。节点是否允许子节点取决于其创建方式。

指定者：
接口 TreeNode 中的 isLeaf
覆盖：
类 DefaultMutableTreeNode 中的 isLeaf
返回：
如果此节点允许子节点，则返回 true；否则返回 false
另请参见：
JTree.DynamicUtilTreeNode(java.lang.Object, java.lang.Object)

getChildCount

public int getChildCount()
返回子节点数。

指定者：
接口 TreeNode 中的 getChildCount
覆盖：
类 DefaultMutableTreeNode 中的 getChildCount
返回：
子节点数

loadChildren

protected void loadChildren()
根据 childValue 加载子节点。如果 childValue 是一个 Vector 或数组，则每个元素都作为子节点添加；否则，如果 childValue 是一个 Hashtable，则按照 Enumeration 返回这些键的顺序添加每个键/值对。

getChildAt

public TreeNode getChildAt(int index)
必要时创建子类以加载此子节点。

指定者：
接口 TreeNode 中的 getChildAt
覆盖：
类 DefaultMutableTreeNode 中的 getChildAt
参数：
index - 此节点的子节点数组中的一个索引
返回：
此节点的子节点数组中指定索引处的 TreeNode

children

public Enumeration children()
必要时创建子类以加载此子节点。

指定者：
接口 TreeNode 中的 children
覆盖：
类 DefaultMutableTreeNode 中的 children
返回：
此节点的子节点 Enumeration
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.EmptySelectionModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.EmptySelectionModel

java.lang.Object
    继承者  javax.swing.tree.DefaultTreeSelectionModel
        继承者  javax.swing.JTree.EmptySelectionModel
所有已实现的接口：
Serializable, Cloneable, TreeSelectionModel
正在封闭类：
JTree
protected static class JTree.EmptySelectionModel
extends DefaultTreeSelectionModel

EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected static JTree.EmptySelectionModel sharedInstance
独有的共享实例。
从类 javax.swing.tree.DefaultTreeSelectionModel 继承的字段
changeSupport, leadIndex, leadPath, leadRow, listenerList, listSelectionModel, rowMapper, selection, SELECTION_MODE_PROPERTY, selectionMode
从接口 javax.swing.tree.TreeSelectionModel 继承的字段
CONTIGUOUS_TREE_SELECTION, DISCONTIGUOUS_TREE_SELECTION, SINGLE_TREE_SELECTION
构造方法摘要
protected JTree.EmptySelectionModel()
方法摘要
void | addSelectionPaths(TreePath[] paths) 一个未添加任何内容的 null 实现。
void | removeSelectionPaths(TreePath[] paths) 一个未移除任何内容的 null 实现。
void | setSelectionPaths(TreePath[] pPaths) 一个未选择任何内容的 null 实现。
static JTree.EmptySelectionModel | sharedInstance() 返回空选择模型的共享实例。
从类 javax.swing.tree.DefaultTreeSelectionModel 继承的方法
addPropertyChangeListener, addSelectionPath, addTreeSelectionListener, arePathsContiguous, canPathsBeAdded, canPathsBeRemoved, clearSelection, clone, fireValueChanged, getLeadSelectionPath, getLeadSelectionRow, getListeners, getMaxSelectionRow, getMinSelectionRow, getPropertyChangeListeners, getRowMapper, getSelectionCount, getSelectionMode, getSelectionPath, getSelectionPaths, getSelectionRows, getTreeSelectionListeners, insureRowContinuity, insureUniqueness, isPathSelected, isRowSelected, isSelectionEmpty, notifyPathChange, removePropertyChangeListener, removeSelectionPath, removeTreeSelectionListener, resetRowSelection, setRowMapper, setSelectionMode, setSelectionPath, toString, updateLeadIndex
从类 java.lang.Object 继承的方法
equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

sharedInstance

protected static final JTree.EmptySelectionModel sharedInstance
独有的共享实例。

构造方法详细信息

JTree.EmptySelectionModel

protected JTree.EmptySelectionModel()
方法详细信息

sharedInstance

public static JTree.EmptySelectionModel sharedInstance()
返回空选择模型的共享实例。

setSelectionPaths

public void setSelectionPaths(TreePath[] pPaths)
一个未选择任何内容的 null 实现。

指定者：
接口 TreeSelectionModel 中的 setSelectionPaths
覆盖：
类 DefaultTreeSelectionModel 中的 setSelectionPaths
参数：
pPaths - 新的选择

addSelectionPaths

public void addSelectionPaths(TreePath[] paths)
一个未添加任何内容的 null 实现。

指定者：
接口 TreeSelectionModel 中的 addSelectionPaths
覆盖：
类 DefaultTreeSelectionModel 中的 addSelectionPaths
参数：
paths - 添加到当前 selection 的新路径

removeSelectionPaths

public void removeSelectionPaths(TreePath[] paths)
一个未移除任何内容的 null 实现。

指定者：
接口 TreeSelectionModel 中的 removeSelectionPaths
覆盖：
类 DefaultTreeSelectionModel 中的 removeSelectionPaths
参数：
paths - 从 selection 中移除的路径
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.TreeModelHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.TreeModelHandler

java.lang.Object
    继承者  javax.swing.JTree.TreeModelHandler
所有已实现的接口：
EventListener, TreeModelListener
正在封闭类：
JTree
protected class JTree.TreeModelHandler
extends Object
implements TreeModelListener

在移除或更改节点时，监听模型并相应地更新 expandedState。

构造方法摘要
protected JTree.TreeModelHandler()
方法摘要
void | treeNodesChanged(TreeModelEvent e) 在已经以某种方式更改节点（或同级节点集）后调用。
void | treeNodesInserted(TreeModelEvent e) 在已将节点插入树中以后调用。
void | treeNodesRemoved(TreeModelEvent e) 在已从树中移除节点后调用。
void | treeStructureChanged(TreeModelEvent e) 在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTree.TreeModelHandler

protected JTree.TreeModelHandler()
方法详细信息

treeNodesChanged

public void treeNodesChanged(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在已经以某种方式更改节点（或同级节点集）后调用。这些节点在树中的位置没有改变，或者说没有更改其子数组，但其他一些属性已发生更改，并且可能影响表示形式。示例：文件的名称已更改，但它仍然在文件系统中的同一位置上。

要指示根已更改，则 childIndices 和 children 将为 null。

可使用 e.getPath() 获得已更改节点的父节点。e.getChildIndices() 返回已更改节点的索引。

指定者：
接口 TreeModelListener 中的 treeNodesChanged

treeNodesInserted

public void treeNodesInserted(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在已将节点插入树中以后调用。

可使用 e.getPath() 获得新节点的父节点。e.getChildIndices() 按升序返回新节点的索引。

指定者：
接口 TreeModelListener 中的 treeNodesInserted

treeStructureChanged

public void treeStructureChanged(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。如果由 e.getPath() 返回的路径长度为 1，并且第一个元素并没有标识当前根节点，则第一个元素应该成为树的新根。

可使用 e.getPath() 获得到该节点的路径。e.getChildIndices() 返回 null。

指定者：
接口 TreeModelListener 中的 treeStructureChanged

treeNodesRemoved

public void treeNodesRemoved(TreeModelEvent e)
从接口 TreeModelListener 复制的描述

在已从树中移除节点后调用。注意，如果从树中移除一个子树，则可能仅对已移除子树的根调用此方法一次，而不是对每个已移除的同级子树集调用一次。

可使用 e.getPath() 获得已删除节点的前父节点。e.getChildIndices() 按升序返回删除此节点前该节点所拥有的索引。

指定者：
接口 TreeModelListener 中的 treeNodesRemoved
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JTree.TreeSelectionRedirector (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JTree.TreeSelectionRedirector

java.lang.Object
    继承者  javax.swing.JTree.TreeSelectionRedirector
所有已实现的接口：
Serializable, EventListener, TreeSelectionListener
正在封闭类：
JTree
protected class JTree.TreeSelectionRedirector
extends Object
implements Serializable, TreeSelectionListener

使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
protected JTree.TreeSelectionRedirector()
方法摘要
 void valueChanged(TreeSelectionEvent e)
在选择更改时由 TreeSelectionModel 调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JTree.TreeSelectionRedirector

protected JTree.TreeSelectionRedirector()
方法详细信息

valueChanged

public void valueChanged(TreeSelectionEvent e)
在选择更改时由 TreeSelectionModel 调用。

指定者：
接口 TreeSelectionListener 中的 valueChanged
参数：
e - 由 TreeSelectionModel 生成的 TreeSelectionEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JViewport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JViewport

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JViewport
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public class JViewport
extends JComponent
implements Accessible

用于查看底层信息的“视口”或“观察孔”。在滚动时，移动部分称为视口。这好像通过照相机的取景器进行查看。将取景器向上移动会将图片顶部的内部移入视野，而底部的内容将消失。

默认情况下，JViewport 是不透明的。要进行更改，请使用 setOpaque 方法。

注：我们已实现了更快的滚动算法，不需要引入缓存。该算法的工作方式如下：

  1. 检查视图和父视图，了解它们是否为 JComponents，如果不是，则停止，然后重绘整个视口。
  2. 如果视口由祖先遮掩，则停止，然后重绘整个视口。
  3. 计算将变为可见的区域，如果可见区域的大小与视口一样，则停止，然后重绘整个视图区域。
  4. 获取祖先 Window 的图形，并在滚动区域上执行 copyArea。
  5. 传递视图消息以重绘新的可见区域。
  6. 下次绘制将在视口上调用，如果剪贴区域小于视口大小，将开始使用计时器重绘整个区域。
一般情况下，此方法相当快。与后备存储方法相比，这避免了维护屏幕外缓冲区和必须执行两个 copyArea 的开销。与非后备存储情况相比，此方法将大大减少绘制的区域。

当视口被另一窗口遮掩或者部分在屏幕外时，此方法比后备存储方法更慢。当另一窗口遮掩该视口时，copyArea 将复制垃圾，并且系统将生成一个绘制事件，通知我们绘制新露出的区域。处理这一情况的惟一方法是重绘整个视口，这可能比后备存储情形的速度要慢。在多数应用程序中，在视口被另一窗口遮掩或在屏幕外时，用户很少滚动它，因此，在被遮掩时，通常值得使用这一优化来提高性能。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JScrollPane

嵌套类摘要
protected class | JViewport.AccessibleJViewport 此类实现对 JViewport 类的可访问性支持。
protected class | JViewport.ViewListener 视图的侦听器。
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected boolean | backingStore 已过时。 从 Java 2 平台 v1.3 开始
static int | BACKINGSTORE_SCROLL_MODE 将视口内容拉入屏幕外图像。
protected Image | backingStoreImage 用于后备存储的视图图像。
static int | BLIT_SCROLL_MODE 使用 graphics.copyArea 来实现滚动。
protected boolean | isViewSizeSet 在确定视口的维数后为 true。
protected Point | lastPaintPosition 我们绘制的最后一个 viewPosition，因此我们知道有多少有效的后备存储图像。
protected boolean | scrollUnderway scrollUnderway 标志用于 JList 之类的组件。
static int | SIMPLE_SCROLL_MODE 此模式使用非常简单的方法，在 scrollpane 每次滚动时重绘它的整个内容。
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JViewport()
创建一个 JViewport。
方法摘要
 void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表。
protected  void addImpl(Component child, Object constraints, int index)
设置 JViewport 的轻量子对象，可以为 null。
protected  boolean computeBlit(int dx, int dy, Point blitFrom, Point blitTo, Dimension blitSize, Rectangle blitPaint)
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。
protected  LayoutManager createLayoutManager()
子类可以重写此方法以在该构造方法中安装一个不同布局的管理器（或者为 null）。
protected  JViewport.ViewListener createViewListener()
为该视图创建侦听器。
protected  void firePropertyChange(String propertyName, Object oldValue, Object newValue)
通知侦听器发生的属性更改。
protected  void fireStateChanged()
在视图的大小、位置或视口的扩展大小更改时通知所有 ChangeListeners。
 AccessibleContext getAccessibleContext()
获取与此 JViewport 关联的 AccessibleContext。
 ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 JViewport 的所有 ChangeListener 的数组。
 Dimension getExtentSize()
返回视图坐标中视图的可见部分的大小。
 Insets getInsets()
返回 inset（边框）维数 (0,0,0,0)，因为在 JViewport 上不支持边框。
 Insets getInsets(Insets insets)
返回包含此 JViewport 的 inset 值的 inset 对象。
 int getScrollMode()
返回当前的滚动模式。
 ViewportUI getUI()
返回呈现此组件的 L&F 对象。
 String getUIClassID()
返回指定呈现此组件的 L&F 类名称的字符串。
 Component getView()
返回 JViewport 的一个子对象或 null。
 Point getViewPosition()
返回显示在视口左上角的视图坐标，如果不存在视图，则返回（0,0）。
 Rectangle getViewRect()
返回一个矩形，其原位置在 getViewPosition，大小为 getExtentSize。
 Dimension getViewSize()
如果未显式设置视图的大小，则返回首选大小，否则返回该视图的当前大小。
 boolean isBackingStoreEnabled()
已过时。 从 Java 2 平台 1.3 版开始，由 getScrollMode() 取代。
 boolean isOptimizedDrawingEnabled()
JViewport 重写此方法（在 JComponent 中返回 false）的默认实现。
 void paint(Graphics g)
通过后备存储绘制图像，或者使用后备存储“位图传送”剩余图像来仅绘制最新暴露的部分，这具体取决于是否启用 backingStore。
protected  String paramString()
返回此 JViewport 的字符串表示形式。
 void remove(Component child)
移除 Viewport 的一个轻量子对象。
 void removeChangeListener(ChangeListener l)
从每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表中移除 ChangeListener。
 void repaint(long tm, int x, int y, int w, int h)
始终在父坐标系统中重绘，以确保 RepaintManager 仅执行一种绘制方法。
 void reshape(int x, int y, int w, int h)
设置此视口的边界。
 void scrollRectToVisible(Rectangle contentRect)
滚动该视图，使该视图中的 Rectangle 变得可见。
 void setBackingStoreEnabled(boolean enabled)
已过时。 从 Java 2 平台 1.3 版开始，由 setScrollMode() 取代。
 void setBorder(Border border)
视口通过常规父/子剪贴（一般该视图向滚动的相反方向移动）“滚动”其子视口（称为“视图”）。
 void setExtentSize(Dimension newExtent)
使用视图坐标设置该视图可见部分的大小。
 void setScrollMode(int mode)
用于控制滚动视口内容的方法。
 void setUI(ViewportUI ui)
设置呈现此组件的 L&F 对象。
 void setView(Component view)
设置 JViewport 的一个轻量子对象 (view)，可以为 null。
 void setViewPosition(Point p)
设置显示在视口左上角的视图坐标，如果不存在视图，则不执行任何操作。
 void setViewSize(Dimension newSize)
设置视图的大小。
 Dimension toViewCoordinates(Dimension size)
将一个大小的像素坐标转换为视图坐标。
 Point toViewCoordinates(Point p)
将一个点的像素坐标转换为视图坐标。
 void updateUI()
将 UI 属性重置为当前外观的值。
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, revalidate, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

isViewSizeSet

protected boolean isViewSizeSet
在确定视口的维数后为 true。默认值为 false。

lastPaintPosition

protected Point lastPaintPosition
我们绘制的最后一个 viewPosition，因此我们知道有多少有效的后备存储图像。

backingStore

@Deprecated
protected boolean backingStore
已过时。 从 Java 2 平台 v1.3 开始
当此视口正在维护其内容的一个屏幕外图像时，将为 true，这样可以使用快速的“位图传送”操作执行一些滚动，而不用通过视图对象来构造此显示。默认值为 false。

另请参见：
setScrollMode(int)

backingStoreImage

protected transient Image backingStoreImage
用于后备存储的视图图像。

scrollUnderway

protected boolean scrollUnderway
scrollUnderway 标志用于 JList 之类的组件。当在 JList 上按下向下箭头且所选单元格是列表中的最后一个单元格时，scrollpane 将自动滚动。这里，以前选中的单元格需要进行重绘，因此我们需要一个标志让该视口仅在存在对 setViewPosition(Point) 的显式调用时执行优化的绘制。当通过其他途径调用 setBounds 时，该标志关闭并且该视图按常规方法重绘。另一种方法是从 JViewport 类中移除此标志，并让 JList 通过使用 setBackingStoreEnabled 管理此情形。默认值为 false。

BLIT_SCROLL_MODE

public static final int BLIT_SCROLL_MODE
使用 graphics.copyArea 来实现滚动。对多数应用程序而言，这是最快的方法。

从以下版本开始：
1.3
另请参见：
setScrollMode(int), 常量字段值

BACKINGSTORE_SCROLL_MODE

public static final int BACKINGSTORE_SCROLL_MODE
将视口内容拉入屏幕外图像。这以前是 JTable 的默认模式。在某些情况下，此模式优于“位图传送模式”，但它需要大量的额外内存。

从以下版本开始：
1.3
另请参见：
setScrollMode(int), 常量字段值

SIMPLE_SCROLL_MODE

public static final int SIMPLE_SCROLL_MODE
此模式使用非常简单的方法，在 scrollpane 每次滚动时重绘它的整个内容。这是 Swing 1.0 和 Swing 1.1 中的默认行为。在多数情况下，其他两个选项都将提供更好的性能。

从以下版本开始：
1.3
另请参见：
setScrollMode(int), 常量字段值
构造方法详细信息

JViewport

public JViewport()
创建一个 JViewport。

方法详细信息

getUI

public ViewportUI getUI()
返回呈现此组件的 L&F 对象。

返回：
ViewportUI 对象
从以下版本开始：
1.3

setUI

public void setUI(ViewportUI ui)
设置呈现此组件的 L&F 对象。

参数：
ui - ViewportUI L&F 对象
从以下版本开始：
1.3
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

updateUI

public void updateUI()
将 UI 属性重置为当前外观的值。

覆盖：
类 JComponent 中的 updateUI
另请参见：
JComponent.updateUI()

getUIClassID

public String getUIClassID()
返回指定呈现此组件的 L&F 类名称的字符串。

覆盖：
类 JComponent 中的 getUIClassID
返回：
字符串“ViewportUI”
另请参见：
JComponent.getUIClassID(), UIDefaults.getUI(javax.swing.JComponent)

addImpl

protected void addImpl(Component child,
                       Object constraints,
                       int index)
设置 JViewport 的轻量子对象，可以为 null。（由于只存在一个占用整个视口的子对象，因此忽略 constraints 和 index 参数。）

覆盖：
类 Container 中的 addImpl
参数：
child - 视口的轻量 child
constraints - 要考虑的 constraint
index - 索引
另请参见：
setView(java.awt.Component)

remove

public void remove(Component child)
移除 Viewport 的一个轻量子对象。

覆盖：
类 Container 中的 remove
参数：
child - 要移除的组件
另请参见：
setView(java.awt.Component)

scrollRectToVisible

public void scrollRectToVisible(Rectangle contentRect)
滚动该视图，使该视图中的 Rectangle 变得可见。

如果视图当前无效，则此操作将尝试在滚动前验证该视图 - isValid 返回 false。为避免在创建包含层次结构时验证时间过长，如果祖先之一没有同位体，或者不存在有效的根祖先，或者祖先之一不是 Window 或 Applet，则不进行验证。

注意，此方法不会滚动到有效视口之外；例如，如果 contentRect 大于视口，滚动操作将限制在视口的边界之内。

覆盖：
类 JComponent 中的 scrollRectToVisible
参数：
contentRect - 要显示的 Rectangle
另请参见：
JComponent.isValidateRoot(),
Component.isValid(),
Component.getPeer()

setBorder

public final void setBorder(Border border)
视口通过常规父/子剪贴（一般该视图向滚动的相反方向移动）“滚动”其子视口（称为“视图”）。不支持非 null 边框或非零 inset，以防止此组件的几何结构复杂得无法禁止创建子类。要创建带边框的 JViewport，请将其添加到具有边框的 JPanel。

注：如果 border 为非 null，此方法将抛出一个异常，原因是在 JViewPort 上不支持边框。

覆盖：
类 JComponent 中的 setBorder
参数：
border - 要设置的 Border
抛出：
IllegalArgumentException - 未实现此方法
另请参见：
Border, CompoundBorder

getInsets

public final Insets getInsets()
返回 inset（边框）维数 (0,0,0,0)，因为在 JViewport 上不支持边框。

覆盖：
类 JComponent 中的 getInsets
返回：
零维数和零区域的 Rectange
另请参见：
setBorder(javax.swing.border.Border)

getInsets

public final Insets getInsets(Insets insets)
返回包含此 JViewport 的 inset 值的 inset 对象。重新初始化传入的 inset 对象，此对象中所有现有值都将被重写。

覆盖：
类 JComponent 中的 getInsets
参数：
insets - 可以重用的 inset 对象
返回：
此视口的 inset 值
另请参见：
getInsets()

isOptimizedDrawingEnabled

public boolean isOptimizedDrawingEnabled()
JViewport 重写此方法（在 JComponent 中返回 false）的默认实现。这确保了绘制机制将调用 Viewport 的 paint 实现，而不是直接通知 JViewport 的子对象。

覆盖：
类 JComponent 中的 isOptimizedDrawingEnabled
返回：
false

paint

public void paint(Graphics g)
通过后备存储绘制图像，或者使用后备存储“位图传送”剩余图像来仅绘制最新暴露的部分，这具体取决于是否启用 backingStore。
术语“位图传送”是 PDP-10 BLT (BLock Transfer) 指令的 pronounced 版，该指令复制位块。（在您感到好奇时。）

覆盖：
类 JComponent 中的 paint
参数：
g - 要在其中进行绘制的 Graphics 上下文
另请参见：
JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)

reshape

public void reshape(int x,
                    int y,
                    int w,
                    int h)
设置此视口的边界。如果视口的宽度或高度已更改，则激发 StateChanged 事件。

覆盖：
类 JComponent 中的 reshape
参数：
x - 原视口的左边缘
y - 原视口的上边缘
w - 以像素为单位的宽度
h - 以像素为单位的高度
另请参见：
JComponent.reshape(int, int, int, int)

setScrollMode

public void setScrollMode(int mode)
用于控制滚动视口内容的方法。您可能需要更改此模式，以便在您的使用情形中获得最大性能。

参数：
mode - 下列值之一：
  • JViewport.BLIT_SCROLL_MODE
  • JViewport.BACKINGSTORE_SCROLL_MODE
  • JViewport.SIMPLE_SCROLL_MODE
从以下版本开始：
1.3
另请参见：
BLIT_SCROLL_MODE, BACKINGSTORE_SCROLL_MODE, SIMPLE_SCROLL_MODE

getScrollMode

public int getScrollMode()
返回当前的滚动模式。

返回：
scrollMode 属性
从以下版本开始：
1.3
另请参见：
setScrollMode(int)

isBackingStoreEnabled

@Deprecated
public boolean isBackingStoreEnabled()
已过时。 从 Java 2 平台 1.3 版开始，由 getScrollMode() 取代。

如果此视口维护其内容的一个屏幕外图像，则返回 true。

返回：
如果 scrollMode 为 BACKINGSTORE_SCROLL_MODE，则返回 true

setBackingStoreEnabled

@Deprecated
public void setBackingStoreEnabled(boolean enabled)
已过时。 从 Java 2 平台 1.3 版开始，由 setScrollMode() 取代。

如果此视口维护其内容的一个屏幕外图像，则返回 true。此图像用于减少对 viewPosition 的较小一维更改的成本。我们使用 Graphics.copyArea 实现某些滚动，而不是重绘整个视口。

参数：
enabled - 如果为 true，则维持一个屏幕外后备存储

getView

public Component getView()
返回 JViewport 的一个子对象或 null。

返回：
返回视口的子对象，如果不存在，则返回 null
另请参见：
setView(java.awt.Component)

setView

public void setView(Component view)
设置 JViewport 的一个轻量子对象 (view)，可以为 null。

参数：
view - 该视口的新轻量子对象
另请参见：
getView()

getViewSize

public Dimension getViewSize()
如果未显式设置视图的大小，则返回首选大小，否则返回该视图的当前大小。如果不存在视图，则返回（0,0）。

返回：
指定视图大小的 Dimension 对象

setViewSize

public void setViewSize(Dimension newSize)
设置视图的大小。将引发状态更改的事件。

参数：
newSize - 指定视图新大小的 Dimension 对象

getViewPosition

public Point getViewPosition()
返回显示在视口左上角的视图坐标，如果不存在视图，则返回（0,0）。

返回：
给出左上角坐标的 Point 对象

setViewPosition

public void setViewPosition(Point p)
设置显示在视口左上角的视图坐标，如果不存在视图，则不执行任何操作。

参数：
p - 给出左上角坐标的 Point 对象

getViewRect

public Rectangle getViewRect()
返回一个矩形，其原位置在 getViewPosition，大小为 getExtentSize。这是视图在视图坐标中的可见部分。

返回：
使用视图坐标给出视图可见部分的 Rectangle。

computeBlit

protected boolean computeBlit(int dx,
                              int dy,
                              Point blitFrom,
                              Point blitTo,
                              Dimension blitSize,
                              Rectangle blitPaint)
计算 blit 的参数，其中后备存储图像当前在左上角包含 oldLoc，并且我们滚动到 newLoc。已修改该参数以返回 blit 所需的值。

参数：
dx - 水平 delta
dy - 垂直 delta
blitFrom - 我们从中传送的 Point
blitTo - 我们传送的 Point
blitSize - 要传送的区域的 Dimension
blitPaint - 要传送的区域
返回：
如果已修改参数并且我们已经准备好传送，则返回 true；否则返回 false

getExtentSize

public Dimension getExtentSize()
返回视图坐标中视图的可见部分的大小。

返回：
给出视图大小的 Dimension 对象

toViewCoordinates

public Dimension toViewCoordinates(Dimension size)
将一个大小的像素坐标转换为视图坐标。支持“逻辑坐标”的视口的子类将重写此方法。

参数：
size - 使用像素坐标的 Dimension 对象
返回：
转换为视图坐标的 Dimension 对象

toViewCoordinates

public Point toViewCoordinates(Point p)
将一个点的像素坐标转换为视图坐标。支持“逻辑坐标”的视口的子类将重写此方法。

参数：
p - 使用像素坐标的 Point 对象
返回：
转换为视图坐标的 Point 对象

setExtentSize

public void setExtentSize(Dimension newExtent)
使用视图坐标设置该视图可见部分的大小。

参数：
newExtent - 指定视图大小的 Dimension 对象

createViewListener

protected JViewport.ViewListener createViewListener()
为该视图创建侦听器。

返回：
ViewListener

createLayoutManager

protected LayoutManager createLayoutManager()
子类可以重写此方法以在该构造方法中安装一个不同布局的管理器（或者为 null）。返回要在 JViewport 上安装的 LayoutManager。

返回：
LayoutManager

addChangeListener

public void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表。

参数：
l - 要添加的 ChangeListener
另请参见：
removeChangeListener(javax.swing.event.ChangeListener),
setViewPosition(java.awt.Point),
setViewSize(java.awt.Dimension),
setExtentSize(java.awt.Dimension)

removeChangeListener

public void removeChangeListener(ChangeListener l)
从每次在视图的大小、位置或视口的扩展大小更改时都会得到通知的列表中移除 ChangeListener。

参数：
l - 要移除的 ChangeListener
另请参见：
addChangeListener(javax.swing.event.ChangeListener)

getChangeListeners

public ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 JViewport 的所有 ChangeListener 的数组。

返回：
返回添加的所有 ChangeListener，如果未添加侦听器，则返回一个空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
在视图的大小、位置或视口的扩展大小更改时通知所有 ChangeListeners。

另请参见：
addChangeListener(javax.swing.event.ChangeListener), removeChangeListener(javax.swing.event.ChangeListener), EventListenerList

repaint

public void repaint(long tm,
                    int x,
                    int y,
                    int w,
                    int h)
始终在父坐标系统中重绘，以确保 RepaintManager 仅执行一种绘制方法。

覆盖：
类 JComponent 中的 repaint
参数：
tm - 更新前等待的最长时间（以毫秒为单位）
x - x 坐标（像素从左端向上）
y - y 坐标（像素从顶部向下）
w - 宽度
h - 高度
另请参见：
Component.update(java.awt.Graphics)

paramString

protected String paramString()
返回此 JViewport 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 JComponent 中的 paramString
返回：
此 JViewport 的字符串表示形式

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
通知侦听器发生的属性更改。已创建其子类以更新 windowBlit 属性。（putClientProperty 属性为最后属性）。

覆盖：
类 Component 中的 firePropertyChange
参数：
propertyName - 包含属性名的字符串
oldValue - 属性的旧值
newValue - 属性的新值

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JViewport 关联的 AccessibleContext。对于视口来说，AccessibleContext 采用 AccessibleJViewport 的某种形式。必要时创建新的 AccessibleJViewport 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 JComponent 中的 getAccessibleContext
返回：
一个 AccessibleJViewport，它充当此 JViewport 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JViewport.AccessibleJViewport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JViewport.AccessibleJViewport

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  javax.swing.JComponent.AccessibleJComponent
                    继承者  javax.swing.JViewport.AccessibleJViewport
所有已实现的接口：
Serializable, AccessibleComponent, AccessibleExtendedComponent
正在封闭类：
JViewport
protected class JViewport.AccessibleJViewport
extends JComponent.AccessibleJComponent

此类实现对 JViewport 类的可访问性支持。它提供适合视口用户界面元素的 Java Accessibility API 的实现。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent.AccessibleContainerHandler, JComponent.AccessibleJComponent.AccessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 javax.swing.JComponent.AccessibleJComponent 继承的字段
accessibleContainerHandler, accessibleFocusHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JViewport.AccessibleJViewport()
方法摘要
 AccessibleRole getAccessibleRole()
获取此对象的职责。
从类 javax.swing.JComponent.AccessibleJComponent 继承的方法
addPropertyChangeListener, getAccessibleChild, getAccessibleChildrenCount, getAccessibleDescription, getAccessibleKeyBinding, getAccessibleName, getAccessibleStateSet, getBorderTitle, getTitledBorderText, getToolTipText, removePropertyChangeListener
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
getAccessibleAt
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleIndexInParent, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 javax.accessibility.AccessibleComponent 继承的方法
addFocusListener, contains, getAccessibleAt, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible

构造方法详细信息

JViewport.AccessibleJViewport

protected JViewport.AccessibleJViewport()
方法详细信息

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。

覆盖：
类 JComponent.AccessibleJComponent 中的 getAccessibleRole
返回：
描述对象职责的 AccessibleRole 的实例。
另请参见：
AccessibleRole
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JViewport.ViewListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JViewport.ViewListener

java.lang.Object
    继承者  java.awt.event.ComponentAdapter
        继承者  javax.swing.JViewport.ViewListener
所有已实现的接口：
ComponentListener, Serializable, EventListener
正在封闭类：
JViewport
protected class JViewport.ViewListener
extends ComponentAdapter
implements Serializable

视图的侦听器。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
protected JViewport.ViewListener()
方法摘要
 void componentResized(ComponentEvent e)
组件大小更改时调用。
从类 java.awt.event.ComponentAdapter 继承的方法
componentHidden, componentMoved, componentShown
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JViewport.ViewListener

protected JViewport.ViewListener()
方法详细信息

componentResized

public void componentResized(ComponentEvent e)
从类 ComponentAdapter 复制的描述
组件大小更改时调用。

指定者：
接口 ComponentListener 中的 componentResized
覆盖：
类 ComponentAdapter 中的 componentResized
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JWindow (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JWindow

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  java.awt.Window
                继承者  javax.swing.JWindow
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible, RootPaneContainer
public class JWindow
extends Window
implements Accessible, RootPaneContainer

JWindow 是一个容器，可以显示在用户桌面上的任何位置。它没有标题栏、窗口管理按钮或者其他与 JFrame 关联的修饰，但它仍然是用户桌面的“一类居民”，可以存在于桌面上的任何位置。

JWindow 组件包含一个 JRootPane 作为其仅有的子组件。contentPane 应为 JWindow 的所有子窗口的父窗口。作为一个便捷的 add 及其变体，remove 和 setLayout 已被重写并根据需要转发到 contentPane。这意味着您可以写入：

       window.add(child);
该子窗口也被添加到 contentPane。contentPane 将始终为非 null。尝试将其设置为 null 将导致 JWindow 抛出异常。默认的 contentPane 将在其上设置 BorderLayout 管理器。有关添加、删除和设置 JWindow 的 LayoutManager 的详细信息，请参阅 RootPaneContainer。

有关 contentPane、glassPane 和 layeredPane 组件的完整描述，请参阅 JRootPane 文档。

在多屏幕环境中，可以在不同的屏幕设备上创建 JWindow。请参阅 Window 以获取更多信息。

警告：Swing 不是线程安全的。有关更多信息，请参阅 Swing's Threading Policy。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JRootPane

嵌套类摘要
protected  class JWindow.AccessibleJWindow
此类实现对 JWindow 类的可访问性支持。
从类 java.awt.Window 继承的嵌套类/接口
Window.AccessibleAWTWindow
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
protected AccessibleContext | accessibleContext 可访问的上下文属性。
protected JRootPane | rootPane 管理此框架的 contentPane 和可选 menuBar 以及 glassPane 的 JRootPane 实例。
protected boolean | rootPaneCheckingEnabled 如果为 true，则对 add 和 setLayout 的调用将转发到 contentPane。
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
JWindow()
创建未指定所有者的窗口。
JWindow(Frame owner)
使用指定的所有者框架创建窗口。
JWindow(GraphicsConfiguration gc)
使用屏幕设备的指定 GraphicsConfiguration 创建窗口。
JWindow(Window owner)
使用指定的所有者窗口创建窗口。
JWindow(Window owner, GraphicsConfiguration gc)
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。
方法摘要
protected void | addImpl(Component comp, Object constraints, int index) 添加指定的子 Component。
protected JRootPane | createRootPane() 由该构造方法调用以创建默认的 rootPane。
AccessibleContext | getAccessibleContext() 获取与此 JWindow 关联的 AccessibleContext。
Container | getContentPane() 返回作为此窗口的 contentPane 的 Container。
Component | getGlassPane() 返回此窗口的 glassPane Component。
Graphics | getGraphics() 为组件创建一个图形上下文。
JLayeredPane | getLayeredPane() 返回此窗口的 layeredPane 对象。
JRootPane | getRootPane() 返回此窗口的 rootPane 对象。
TransferHandler | getTransferHandler() 获取 transferHandler 属性。
protected boolean | isRootPaneCheckingEnabled() 返回对 add 和 setLayout 的调用是否转发到 contentPane。
protected String | paramString() 返回此 JWindow 的字符串表示形式。
void | remove(Component comp) 从该容器中移除指定组件。
void | repaint(long time, int x, int y, int width, int height) 在 time 毫秒内重绘此组件的指定矩形区域。
void | setContentPane(Container contentPane) 设置此窗口的 contentPane 属性。
void | setGlassPane(Component glassPane) 设置 glassPane 属性。
void | setLayeredPane(JLayeredPane layeredPane) 设置 layeredPane 属性。
void | setLayout(LayoutManager manager) 设置 LayoutManager。
protected void | setRootPane(JRootPane root) 设置此窗口的新 rootPane 对象。
protected void | setRootPaneCheckingEnabled(boolean enabled) 设置对 add 和 setLayout 的调用是否转发到 contentPane。
void | setTransferHandler(TransferHandler newHandler) 设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。
void | update(Graphics g) 调用 paint(g)。
protected void | windowInit() 由该构造方法调用以正确初始化 JWindow。
从类 java.awt.Window 继承的方法
addNotify, addPropertyChangeListener, addPropertyChangeListener, addWindowFocusListener, addWindowListener, addWindowStateListener, applyResourceBundle, applyResourceBundle, createBufferStrategy, createBufferStrategy, dispose, getBufferStrategy, getFocusableWindowState, getFocusCycleRootAncestor, getFocusOwner, getFocusTraversalKeys, getGraphicsConfiguration, getIconImages, getInputContext, getListeners, getLocale, getModalExclusionType, getMostRecentFocusOwner, getOwnedWindows, getOwner, getOwnerlessWindows, getToolkit, getWarningString, getWindowFocusListeners, getWindowListeners, getWindows, getWindowStateListeners, hide, isActive, isAlwaysOnTop, isAlwaysOnTopSupported, isFocusableWindow, isFocusCycleRoot, isFocused, isLocationByPlatform, isShowing, pack, postEvent, processEvent, processWindowEvent, processWindowFocusEvent, processWindowStateEvent, removeNotify, removeWindowFocusListener, removeWindowListener, removeWindowStateListener, reshape, setAlwaysOnTop, setBounds, setBounds, setCursor, setFocusableWindowState, setFocusCycleRoot, setIconImage, setIconImages, setLocationByPlatform, setLocationRelativeTo, setMinimumSize, setModalExclusionType, setSize, setSize, setVisible, show, toBack, toFront
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getAlignmentX, getAlignmentY, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalPolicy, getInsets, getLayout, getMaximumSize, getMinimumSize, getMousePosition, getPreferredSize, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paint, paintComponents, preferredSize, print, printComponents, processContainerEvent, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusTraversalKeys, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setFont, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, contains, createImage, createImage, createVolatileImage, createVolatileImage, disable, disableEvents, dispatchEvent, enable, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBaseline, getBaselineResizeBehavior, getBounds, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getFontMetrics, getForeground, getHeight, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocation, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getSize, getTreeLock, getWidth, getX, getY, gotFocus, handleEvent, hasFocus, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isDoubleBuffered, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isOpaque, isPreferredSizeSet, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, prepareImage, prepareImage, printAll, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processKeyEvent, processMouseEvent, processMouseMotionEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resize, resize, setBackground, setComponentOrientation, setDropTarget, setEnabled, setFocusable, setFocusTraversalKeysEnabled, setForeground, setIgnoreRepaint, setLocale, setLocation, setLocation, setMaximumSize, setName, setPreferredSize, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

rootPane

protected JRootPane rootPane
管理此框架的 contentPane 和可选 menuBar 以及 glassPane 的 JRootPane 实例。

另请参见：
getRootPane(), setRootPane(javax.swing.JRootPane)

rootPaneCheckingEnabled

protected boolean rootPaneCheckingEnabled
如果为 true，则对 add 和 setLayout 的调用将转发到 contentPane。其最初设置为 false，但在构造 JWindow 时将被设置为 true。

另请参见：
isRootPaneCheckingEnabled(), setRootPaneCheckingEnabled(boolean), RootPaneContainer

accessibleContext

protected AccessibleContext accessibleContext
可访问的上下文属性。

构造方法详细信息

JWindow

public JWindow()
创建未指定所有者的窗口。此窗口不可获得焦点。

此构造方法将组件的区域属性设置为 JComponent.getDefaultLocale 返回的值。

抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

JWindow

public JWindow(GraphicsConfiguration gc)
使用屏幕设备的指定 GraphicsConfiguration 创建窗口。此窗口不可获得焦点。

此构造方法将组件的区域属性设置为 JComponent.getDefaultLocale 返回的值。

参数：
gc - 用以构造新窗口的 GraphicsConfiguration；如果 gc 为 null，则假定系统默认的 GraphicsConfiguration
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
IllegalArgumentException - 如果 gc 不是来自屏幕设备。
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

JWindow

public JWindow(Frame owner)
使用指定的所有者框架创建窗口。如果 owner 为 null，则使用共享所有者，而且此窗口不可获得焦点。而且，只有其所有者正显示在屏幕上时此窗口才可获得焦点。

此构造方法将组件的 locale 属性设置为 JComponent.getDefaultLocale 返回的值。

参数：
owner - 从中显示该窗口的框架
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

JWindow

public JWindow(Window owner)
使用指定的所有者窗口创建窗口。只有在其所有者正显示在屏幕上时此窗口才可获得焦点。如果 owner 为 null，则使用共享所有者，而且此窗口不可获得焦点。

此构造方法将组件的 locale 属性设置为 JComponent.getDefaultLocale 返回的值。

参数：
owner - 从中显示该窗口的窗口
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
另请参见：
GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()

JWindow

public JWindow(Window owner,
               GraphicsConfiguration gc)
使用屏幕设备的指定所有者窗口和 GraphicsConfiguration 创建窗口。如果 owner 为 null，则使用共享所有者，而且此窗口不可获得焦点。

此构造方法将组件的 locale 属性设置为 JComponent.getDefaultLocale 返回的值。

参数：
owner - 从中显示该窗口的窗口
gc - 用以构造新窗口的 GraphicsConfiguration；如果 gc 为 null，则假定系统默认的 GraphicsConfiguration，除非 owner 也为 null，在此情况下将使用来自共享所有者框架的 GraphicsConfiguration。
抛出：
HeadlessException - 如果 GraphicsEnvironment.isHeadless() 返回 true。
IllegalArgumentException - 如果 gc 不是来自屏幕设备。
从以下版本开始：
1.3
另请参见：
GraphicsEnvironment.isHeadless(),
Window.isFocusableWindow(),
JComponent.getDefaultLocale()
方法详细信息

windowInit

protected void windowInit()
由该构造方法调用以正确初始化 JWindow。

createRootPane

protected JRootPane createRootPane()
由该构造方法调用以创建默认的 rootPane。

isRootPaneCheckingEnabled

protected boolean isRootPaneCheckingEnabled()
返回对 add 和 setLayout 的调用是否转发到 contentPane。

返回：
如果 add 和 setLayout 被转发，则返回 true；否则返回 false
另请参见：
addImpl(java.awt.Component, java.lang.Object, int), setLayout(java.awt.LayoutManager), setRootPaneCheckingEnabled(boolean), RootPaneContainer

setTransferHandler

public void setTransferHandler(TransferHandler newHandler)
设置 transferHandler 属性，该属性是支持将数据传输到此组件的机制。如果该组件不支持数据传输操作，则使用 null。

如果系统属性 suppressSwingDropSupport 为 false（默认值），并且此组件上的当前放置目标为 null 或者不是用户设置的放置目标，那么此方法将按以下方式更改放置目标：如果 newHandler 为 null，则它将清除放置目标。如果不为 null，则它将安装一个新 DropTarget。

注：当用于 JWindow 时，TransferHandler 只提供数据导入功能，与数据导出有关的方法当前用于 JComponent。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

参数：
newHandler - 新 TransferHandler
从以下版本开始：
1.6
另请参见：
TransferHandler, getTransferHandler(), Component.setDropTarget(java.awt.dnd.DropTarget)

getTransferHandler

public TransferHandler getTransferHandler()
获取 transferHandler 属性。

返回：
transferHandler 属性的值
从以下版本开始：
1.6
另请参见：
TransferHandler, setTransferHandler(javax.swing.TransferHandler)

update

public void update(Graphics g)
调用 paint(g)。此方法已被重写以防止因不必要的调用而清除背景。

覆盖：
类 Container 中的 update
参数：
g - 要在其中进行绘制的 Graphics 上下文
另请参见：
Component.update(Graphics)

setRootPaneCheckingEnabled

protected void setRootPaneCheckingEnabled(boolean enabled)
设置对 add 和 setLayout 的调用是否转发到 contentPane。

参数：
enabled - 如果 add 和 setLayout 被转发，则为 true；如果应直接在 JWindow 上操作，则为 false。
另请参见：
addImpl(java.awt.Component, java.lang.Object, int),
setLayout(java.awt.LayoutManager),
isRootPaneCheckingEnabled(),
RootPaneContainer

addImpl

protected void addImpl(Component comp,
                       Object constraints,
                       int index)
添加指定的子 Component。重写此方法以有条件地转发对 contentPane 的调用。默认情况下，子组件被添加到 contentPane 而非框架，请参阅 RootPaneContainer 以获取详细信息。

覆盖：
类 Container 中的 addImpl
参数：
comp - 要增强的组件
constraints - 要考虑的限制
index - 索引
抛出：
IllegalArgumentException - 如果 index 无效
IllegalArgumentException - 如果将容器的父级添加到自身
IllegalArgumentException - 如果将一个窗口添加到窗口
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

remove

public void remove(Component comp)
从该容器中移除指定组件。如果 comp 不是 rootPane，这将把该调用转发到 contentPane。如果 comp 不是 JWindow 或 contentPane 的子对象，将不会执行任何操作。

覆盖：
类 Container 中的 remove
参数：
comp - 要移除的组件
抛出：
NullPointerException - 如果 comp 为 null
另请参见：
Container.add(java.awt.Component), RootPaneContainer

setLayout

public void setLayout(LayoutManager manager)
设置 LayoutManager。重写以有条件地将调用转发到 contentPane。有关更多信息，请参阅 RootPaneContainer。

覆盖：
类 Container 中的 setLayout
参数：
manager - LayoutManager
另请参见：
setRootPaneCheckingEnabled(boolean), RootPaneContainer

getRootPane

public JRootPane getRootPane()
返回此窗口的 rootPane 对象。

指定者：
接口 RootPaneContainer 中的 getRootPane
返回：
此窗口的 rootPane 属性
另请参见：
setRootPane(javax.swing.JRootPane), RootPaneContainer.getRootPane()

setRootPane

protected void setRootPane(JRootPane root)
设置此窗口的新 rootPane 对象。此方法由构造方法调用。

参数：
root - 新的 rootPane 属性
另请参见：
getRootPane()

getContentPane

public Container getContentPane()
返回作为此窗口的 contentPane 的 Container。

指定者：
接口 RootPaneContainer 中的 getContentPane
返回：
contentPane 属性
另请参见：
setContentPane(java.awt.Container), RootPaneContainer.getContentPane()

setContentPane

public void setContentPane(Container contentPane)
设置此窗口的 contentPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setContentPane
参数：
contentPane - 新的 contentPane
抛出：
IllegalComponentStateException - （运行时异常）如果内容窗格参数为 null
另请参见：
getContentPane(), RootPaneContainer.setContentPane(java.awt.Container)

getLayeredPane

public JLayeredPane getLayeredPane()
返回此窗口的 layeredPane 对象。

指定者：
接口 RootPaneContainer 中的 getLayeredPane
返回：
layeredPane 属性
另请参见：
setLayeredPane(javax.swing.JLayeredPane), RootPaneContainer.getLayeredPane()

setLayeredPane

public void setLayeredPane(JLayeredPane layeredPane)
设置 layeredPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setLayeredPane
参数：
layeredPane - 新的 layeredPane 对象
抛出：
IllegalComponentStateException - （运行时异常）如果内容窗格参数为 null
另请参见：
getLayeredPane(), RootPaneContainer.setLayeredPane(javax.swing.JLayeredPane)

getGlassPane

public Component getGlassPane()
返回此窗口的 glassPane Component。

指定者：
接口 RootPaneContainer 中的 getGlassPane
返回：
glassPane 属性
另请参见：
setGlassPane(java.awt.Component), RootPaneContainer.getGlassPane()

setGlassPane

public void setGlassPane(Component glassPane)
设置 glassPane 属性。此方法由构造方法调用。

指定者：
接口 RootPaneContainer 中的 setGlassPane
参数：
glassPane - 此窗口的 glassPane 对象
另请参见：
getGlassPane(), RootPaneContainer.setGlassPane(java.awt.Component)

getGraphics

public Graphics getGraphics()
为组件创建一个图形上下文。如果组件当前是不可显示的，则此方法返回 null。

覆盖：
类 Component 中的 getGraphics
返回：
组件的图形上下文，如果其没有，则返回 null
从以下版本开始：
1.6
另请参见：
Component.paint(java.awt.Graphics)

repaint

public void repaint(long time,
                    int x,
                    int y,
                    int width,
                    int height)
在 time 毫秒内重绘此组件的指定矩形区域。有关如何处理重绘的细节，请参阅 RepaintManager。

覆盖：
类 Component 中的 repaint
参数：
time - 更新前等待的最长时间（以毫秒为单位）
x - x 坐标
y - y 坐标
width - 宽度
height - 高度
从以下版本开始：
1.6
另请参见：
RepaintManager

paramString

protected String paramString()
返回此 JWindow 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 Container 中的 paramString
返回：
此 JWindow 的字符串表示形式

getAccessibleContext

public AccessibleContext getAccessibleContext()
获取与此 JWindow 关联的 AccessibleContext。对于 JWindows，AccessibleContext 采取 AccessibleJWindow 的形式。必要时创建新的 AccessibleJWindow 实例。

指定者：
接口 Accessible 中的 getAccessibleContext
覆盖：
类 Window 中的 getAccessibleContext
返回：
一个 AccessibleJWindow，它充当此 JWindow 的 AccessibleContext
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


JWindow.AccessibleJWindow (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 JWindow.AccessibleJWindow

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  java.awt.Component.AccessibleAWTComponent
            继承者  java.awt.Container.AccessibleAWTContainer
                继承者  java.awt.Window.AccessibleAWTWindow
                    继承者  javax.swing.JWindow.AccessibleJWindow
所有已实现的接口：
Serializable, AccessibleComponent
正在封闭类：
JWindow
protected class JWindow.AccessibleJWindow
extends Window.AccessibleAWTWindow

此类实现对 JWindow 类的可访问性支持。它提供适合窗口用户界面元素的 Java Accessibility API 实现。

嵌套类摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的嵌套类/接口
Container.AccessibleAWTContainer.AccessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的嵌套类/接口
Component.AccessibleAWTComponent.AccessibleAWTComponentHandler, Component.AccessibleAWTComponent.AccessibleAWTFocusHandler
字段摘要
从类 java.awt.Container.AccessibleAWTContainer 继承的字段
accessibleContainerHandler
从类 java.awt.Component.AccessibleAWTComponent 继承的字段
accessibleAWTComponentHandler, accessibleAWTFocusHandler
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
构造方法摘要
protected JWindow.AccessibleJWindow()
方法摘要
从类 java.awt.Window.AccessibleAWTWindow 继承的方法
getAccessibleRole, getAccessibleStateSet
从类 java.awt.Container.AccessibleAWTContainer 继承的方法
addPropertyChangeListener, getAccessibleAt, getAccessibleChild, getAccessibleChildrenCount
从类 java.awt.Component.AccessibleAWTComponent 继承的方法
addFocusListener, contains, getAccessibleComponent, getAccessibleDescription, getAccessibleIndexInParent, getAccessibleName, getAccessibleParent, getBackground, getBounds, getCursor, getFont, getFontMetrics, getForeground, getLocale, getLocation, getLocationOnScreen, getSize, isEnabled, isFocusTraversable, isShowing, isVisible, removeFocusListener, removePropertyChangeListener, requestFocus, setBackground, setBounds, setCursor, setEnabled, setFont, setForeground, setLocation, setSize, setVisible
从类 javax.accessibility.AccessibleContext 继承的方法
firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, getAccessibleText, getAccessibleValue, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

JWindow.AccessibleJWindow

protected JWindow.AccessibleJWindow()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


KeyStroke (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 KeyStroke

java.lang.Object
    继承者  java.awt.AWTKeyStroke
        继承者  javax.swing.KeyStroke
所有已实现的接口：
Serializable
public class KeyStroke
extends AWTKeyStroke

表示键盘或等效输入设置上的键操作的 KeyStroke。KeyStroke 仅能对应于按下或释放某个特定的键，正如 KEY_PRESSED 和 KEY_RELEASED KeyEvents 执行的操作；或者，它们可能对应于键入特定的 Java 字符，正如 KEY_TYPED KeyEvents 执行的操作。在所有情况下，KeyStroke 都可以指定修饰符（alt、shift、control、meta、altGraph 或其组合），在针对精确匹配的操作中，这些修饰符必须存在。

KeyStroke 用于定义高级（语义)操作事件。不用捕获每个 keystroke 并抛弃不感兴趣的 keystroke，这些重要的 keystroke 会自动在其注册的 Components 上启动操作。

KeyStroke 是不可变的，而且是唯一的。客户端代码无法创建 KeyStroke；必须使用 getKeyStroke 的变体。这些工厂方法使得 KeyStroke 实现能够高效缓存和共享实例。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Keymap, getKeyStroke(char)

方法摘要
static KeyStroke | getKeyStroke(char keyChar) 返回 KeyStroke 的共享实例，前者表示指定字符的 KEY_TYPED 事件。
static KeyStroke | getKeyStroke(Character keyChar, int modifiers) 返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。
static KeyStroke | getKeyStroke(char keyChar, boolean onKeyRelease) 已过时。 使用 getKeyStroke(char)
static KeyStroke | getKeyStroke(int keyCode, int modifiers) 在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例。
static KeyStroke | getKeyStroke(int keyCode, int modifiers, boolean onKeyRelease) 在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例，指定该键在按下或释放时是否为已激活。
static KeyStroke | getKeyStroke(String s) 分析字符串并返回 KeyStroke。
static KeyStroke | getKeyStrokeForEvent(KeyEvent anEvent) 返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。
从类 java.awt.AWTKeyStroke 继承的方法
equals, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStroke, getAWTKeyStrokeForEvent, getKeyChar, getKeyCode, getKeyEventType, getModifiers, hashCode, isOnKeyRelease, readResolve, registerSubclass, toString
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, wait, wait, wait

方法详细信息

getKeyStroke

public static KeyStroke getKeyStroke(char keyChar)
返回 KeyStroke 的共享实例，前者表示指定字符的 KEY_TYPED 事件。

参数：
keyChar - 键盘上某个键的字符值
返回：
该键的 KeyStroke 对象

getKeyStroke

@Deprecated
public static KeyStroke getKeyStroke(char keyChar,
                                                boolean onKeyRelease)
已过时。 使用 getKeyStroke(char)

返回 KeyStroke 的实例，指定该键在按下或释放时是否视为已激活。与此类中的所有其他工厂方法不同，此方法返回的实例不一定被缓存或共享。

参数：
keyChar - 键盘上某个键的字符值
onKeyRelease - 如果此 KeyStroke 对应于某个键的释放，则为 true；否则为 false。
返回：
键的 KeyStroke 对象

getKeyStroke

public static KeyStroke getKeyStroke(Character keyChar,
                                     int modifiers)
返回 KeyStroke 的一个共享实例，它表示指定 Character 对象和一组修饰符的 KEY_TYPED 事件。注意，第一个参数是 Character 类型而不是 char 类型。这是为了避免在调用 getKeyStroke(int keyCode, int modifiers) 时发生无意的冲突。 修饰符由以下任意组合组成：
  • java.awt.event.InputEvent.SHIFT_DOWN_MASK
  • java.awt.event.InputEvent.CTRL_DOWN_MASK
  • java.awt.event.InputEvent.META_DOWN_MASK
  • java.awt.event.InputEvent.ALT_DOWN_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
也可以使用下面列出的旧的修饰符，但它们被映射到 _DOWN_ 修饰符。
  • java.awt.event.InputEvent.SHIFT_MASK
  • java.awt.event.InputEvent.CTRL_MASK
  • java.awt.event.InputEvent.META_MASK
  • java.awt.event.InputEvent.ALT_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_MASK
也可以使用，但它们被映射到 _DOWN_ 修饰符。 因为这些数字都是 2 的不同次幂，所以它们的任意组合是一个整数，该整数的每个位都表示一个不同的修饰符键。可以使用 0 指定无修饰符。

参数：
keyChar - 键盘字符的 Character 对象
modifiers - 任意修饰符的按位或组合
返回：
该键的 KeyStroke 对象
抛出：
IllegalArgumentException - 如果 keyChar 为 null
从以下版本开始：
1.3
另请参见：
InputEvent

getKeyStroke

public static KeyStroke getKeyStroke(int keyCode,
                                     int modifiers,
                                     boolean onKeyRelease)
在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例，指定该键在按下或释放时是否为已激活。

可以使用在 java.awt.event.KeyEvent 中定义的“虚拟键”常量来指定键代码。例如：

  • java.awt.event.KeyEvent.VK_ENTER
  • java.awt.event.KeyEvent.VK_TAB
  • java.awt.event.KeyEvent.VK_SPACE
修饰符由以下任意组合组成：
  • java.awt.event.InputEvent.SHIFT_DOWN_MASK
  • java.awt.event.InputEvent.CTRL_DOWN_MASK
  • java.awt.event.InputEvent.META_DOWN_MASK
  • java.awt.event.InputEvent.ALT_DOWN_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
旧的修饰符
  • java.awt.event.InputEvent.SHIFT_MASK
  • java.awt.event.InputEvent.CTRL_MASK
  • java.awt.event.InputEvent.META_MASK
  • java.awt.event.InputEvent.ALT_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_MASK
也可以使用，但它们被映射到 _DOWN_ 修饰符。 因为这些数字都是 2 的不同次幂，所以它们的任意组合是一个整数，该整数的每个位都表示一个不同的修饰符键。可以使用 0 指定无修饰符。

参数：
keyCode - 一个 int，指定键盘上某个键的数字代码
modifiers - 任意修饰符的按位或组合
onKeyRelease - 如果 KeyStroke 应该表示一个键释放，则为 true；否则为 false。
返回：
该键的 KeyStroke 对象
另请参见：
KeyEvent, InputEvent

getKeyStroke

public static KeyStroke getKeyStroke(int keyCode,
                                     int modifiers)
在给出一个数字键代码和一组修饰符的情况下，返回 KeyStroke 的一个共享实例。返回的 KeyStroke 将对应于一个按键操作。

可以使用在 java.awt.event.KeyEvent 中定义的“虚拟键”常量来指定键代码。例如：

  • java.awt.event.KeyEvent.VK_ENTER
  • java.awt.event.KeyEvent.VK_TAB
  • java.awt.event.KeyEvent.VK_SPACE
修饰符由以下任意组合组成：
  • java.awt.event.InputEvent.SHIFT_DOWN_MASK
  • java.awt.event.InputEvent.CTRL_DOWN_MASK
  • java.awt.event.InputEvent.META_DOWN_MASK
  • java.awt.event.InputEvent.ALT_DOWN_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_DOWN_MASK
旧的修饰符
  • java.awt.event.InputEvent.SHIFT_MASK
  • java.awt.event.InputEvent.CTRL_MASK
  • java.awt.event.InputEvent.META_MASK
  • java.awt.event.InputEvent.ALT_MASK
  • java.awt.event.InputEvent.ALT_GRAPH_MASK
也可以使用，但它们被映射到 _DOWN_ 修饰符。 因为这些数字都是 2 的不同次幂，所以它们的任意组合是一个整数，该整数的每个位都表示一个不同的修饰符键。可以使用 0 指定无修饰符。

参数：
keyCode - 一个 int，指定键盘上某个键的数字代码
modifiers - 任意修饰符的按位或组合
返回：
该键的 KeyStroke 对象
另请参见：
KeyEvent, InputEvent

getKeyStrokeForEvent

public static KeyStroke getKeyStrokeForEvent(KeyEvent anEvent)
返回一个 KeyStroke，它表示生成给定 KeyEvent 的快捷键事件。

此方法获得来自 KeyTyped 事件的 keyChar，以及来自 KeyPressed 或 KeyReleased 事件的 keyCode。为所有三种类型的 KeyEvent 获取 KeyEvent 修饰符。

参数：
anEvent - 从中获取 KeyStroke 的 KeyEvent
返回：
促成事件的 KeyStroke
抛出：
NullPointerException - 如果 anEvent 为 null

getKeyStroke

public static KeyStroke getKeyStroke(String s)
分析字符串并返回 KeyStroke。字符串必须具有以下语法：
    <modifiers>* (<typedID> | <pressedReleasedID>)

    modifiers := shift | control | ctrl | meta | alt | altGraph
    typedID := typed <typedKey>
    typedKey := string of length 1 giving Unicode character.
    pressedReleasedID := (pressed | released) key
    key := KeyEvent key code name, i.e. the name following "VK_".
如果没有指定是键入、按下还是释放，则假定为按下。以下是一些示例：
     "INSERT" => getKeyStroke(KeyEvent.VK_INSERT, 0);
     "control DELETE" => getKeyStroke(KeyEvent.VK_DELETE, InputEvent.CTRL_MASK);
     "alt shift X" => getKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK);
     "alt shift released X" => getKeyStroke(KeyEvent.VK_X, InputEvent.ALT_MASK | InputEvent.SHIFT_MASK, true);
     "typed a" => getKeyStroke('a');
为了维持向后兼容性，指定 null String 或格式不正确的 String 将返回 null。

参数：
s - 用上述方法格式化的 String
返回：
该 String 的 KeyStroke 对象，如果指定的 String 为 null 或格式不正确，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutStyle (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 LayoutStyle

java.lang.Object
    继承者  javax.swing.LayoutStyle

public abstract class LayoutStyle
extends Object

LayoutStyle 提供有关如何确定组件位置的信息。此类主要用于可视化工具和布局管理器。大多数开发人员不需要使用此类。

通常不设置或创建 LayoutStyle。而是使用静态方法 getInstance 获取当前实例。

从以下版本开始：
1.6

嵌套类摘要
static class LayoutStyle.ComponentPlacement
ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
构造方法摘要
LayoutStyle()
创建一个新的 LayoutStyle。
方法摘要
abstract int | getContainerGap(JComponent component, int position, Container parent) 返回组件与其父容器的指定边缘之间放置的空格数量。
static LayoutStyle | getInstance() 返回 LayoutStyle 的共享实例。
abstract int | getPreferredGap(JComponent component1, JComponent component2, LayoutStyle.ComponentPlacement type, int position, Container parent) 返回两个组件之间使用的空格的数量。
static void | setInstance(LayoutStyle style) 设置 LayoutStyle 的共享实例。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LayoutStyle

public LayoutStyle()
创建一个新的 LayoutStyle。通常不创建 LayoutStyle。而是使用 getInstance 方法获取当前 LayoutStyle。

方法详细信息

setInstance

public static void setInstance(LayoutStyle style)
设置 LayoutStyle 的共享实例。指定 null 将导致使用当前 LookAndFeel 的 LayoutStyle。

参数：
style - LayoutStyle，或 null
另请参见：
getInstance()

getInstance

public static LayoutStyle getInstance()
返回 LayoutStyle 的共享实例。如果没有在 setInstance 中指定实例，则此方法将返回当前 LookAndFeel 的 LayoutStyle。

返回：
LayoutStyle 的共享实例
另请参见：
LookAndFeel.getLayoutStyle()

getPreferredGap

public abstract int getPreferredGap(JComponent component1,
                                    JComponent component2,
                                    LayoutStyle.ComponentPlacement type,
                                    int position,
                                    Container parent)
返回两个组件之间使用的空格的数量。返回值表示相对于 component1 放置 component2 的距离。例如，当 component2 被放置在 component1 的正上方时，以下代码返回 component2 和 component1 之间放置的空格数：
int gap = getPreferredGap(component1, component2,
ComponentPlacement.RELATED,
SwingConstants.NORTH, parent);
type 参数指示两个组件之间的关系。如果这两个组件将被包含在同一个父容器中并显示相似的逻辑相关项，则使用 RELATED。如果这两个组件将被包含在同一个父容器中但显示逻辑不相关项，则使用 UNRELATED。某些外观不区分 RELATED 和 UNRELATED 类型。

返回值不考虑 component2 或 component1 的当前大小和位置。返回值可能考虑组件的各种属性。例如，空格可能随字体大小或组件首选大小的不同而不同。

参数：
component1 - JComponent，component2 将相对于该 JComponent 被放置
component2 - 将被放置的 JComponent
position - component2 将相对于 component1 进行放置的位置；SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一
type - 这两个组件将如何放置
parent - component2 的父容器；它可能不同于实际的父容器，可能为 null
返回：
两个组件之间放置的空格数量
抛出：
NullPointerException - 如果 component1、component2 或 type 为 null
IllegalArgumentException - 如果 position 不是 SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一
从以下版本开始：
1.6
另请参见：
LookAndFeel.getLayoutStyle()

getContainerGap

public abstract int getContainerGap(JComponent component,
                                    int position,
                                    Container parent)
返回组件与其父容器的指定边缘之间放置的空格数量。

参数：
component - 要放置的 JComponent
position - component 将相对于其父容器被放置的位置；SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一
parent - component 的父容器；它可能不同于实际的父容器，可能为 null
返回：
组件与指定边缘之间放置的空格数
抛出：
IllegalArgumentException - 如果 position 不是 SwingConstants.NORTH、SwingConstants.SOUTH、SwingConstants.EAST 或 SwingConstants.WEST 之一
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutFocusTraversalPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 LayoutFocusTraversalPolicy

java.lang.Object
    继承者  java.awt.FocusTraversalPolicy
        继承者  javax.swing.InternalFrameFocusTraversalPolicy
            继承者  javax.swing.SortingFocusTraversalPolicy
                继承者  javax.swing.LayoutFocusTraversalPolicy
所有已实现的接口：
Serializable
public class LayoutFocusTraversalPolicy
extends SortingFocusTraversalPolicy
implements Serializable

根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。根据 Component 的大小和位置，可以将其大致归类为行和列。对于水平方向的 Container，列的排列顺序是从左到右或从右到左，行的排列顺序是从顶端到底部。对于垂直方向的 Container，列的排列顺序是从顶端到底部，行的排列顺序是从左到右或从右到左。有关更多信息，请参见 ComponentOrientation。在完全遍历一行中的所有列之后才继续到下一行。

从以下版本开始：
1.4
另请参见：
ComponentOrientation

构造方法摘要
LayoutFocusTraversalPolicy()
构造一个 LayoutFocusTraversalPolicy。
方法摘要
protected boolean | accept(Component aComponent) 确定是否可以接受选择指定的 Component 作为新的焦点所有者。
Component | getComponentAfter(Container aContainer, Component aComponent) 返回应在 aComponent 之后接收焦点的 Component。
Component | getComponentBefore(Container aContainer, Component aComponent) 返回应在 aComponent 之前接收焦点的 Component。
Component | getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
Component | getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
从类 javax.swing.SortingFocusTraversalPolicy 继承的方法
getComparator, getDefaultComponent, getImplicitDownCycleTraversal, setComparator, setImplicitDownCycleTraversal
从类 javax.swing.InternalFrameFocusTraversalPolicy 继承的方法
getInitialComponent
从类 java.awt.FocusTraversalPolicy 继承的方法
getInitialComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

LayoutFocusTraversalPolicy

public LayoutFocusTraversalPolicy()
构造一个 LayoutFocusTraversalPolicy。

方法详细信息

getComponentAfter

public Component getComponentAfter(Container aContainer,
                                   Component aComponent)
返回应在 aComponent 之后接收焦点的 Component。aContainer 必须是 aComponent 的焦点循环根。

默认情况下，LayoutFocusTraversalPolicy 会隐式将焦点传输给下一个循环。也就是说，在进行正常焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。可以使用 setImplicitDownCycleTraversal 方法禁用此行为。

如果 aContainer 是焦点遍历策略提供者，则总是将焦点传输到下一个循环。

覆盖：
类 SortingFocusTraversalPolicy 中的 getComponentAfter
参数：
aContainer - aComponent 的焦点循环根，或焦点遍历策略提供者
aComponent - aContainer 的子组件（可能是间接的），或 aContainer 自身
返回：
应该接收 aComponent 之后的焦点的 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getComponentBefore

public Component getComponentBefore(Container aContainer,
                                    Component aComponent)
返回应在 aComponent 之前接收焦点的 Component。aContainer 必须是 aComponent 的焦点循环根。

默认情况下，LayoutFocusTraversalPolicy 会隐式将焦点传输给下一个循环。也就是说，在进行正常焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。可以使用 setImplicitDownCycleTraversal 方法禁用此行为。

如果 aContainer 是焦点遍历策略提供者，则总是将焦点传输到下一个循环。

覆盖：
类 SortingFocusTraversalPolicy 中的 getComponentBefore
参数：
aContainer - aComponent 的焦点循环根，或焦点遍历策略提供者
aComponent - aContainer 的子组件（可能是间接的），或 aContainer 自身
返回：
应该接收 aComponent 之前的焦点的 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getFirstComponent

public Component getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。在进行正向遍历时，可用此方法确定拥有焦点的下一个 Component。

覆盖：
类 SortingFocusTraversalPolicy 中的 getFirstComponent
参数：
aContainer - 要返回其第一个 Component 的 aComponent 的焦点循环根，或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的第一个 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getLastComponent

public Component getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。在进行反向遍历时，可用此方法确定拥有焦点的下一个 Component。

覆盖：
类 SortingFocusTraversalPolicy 中的 getLastComponent
参数：
aContainer - 要返回其最后一个 Component 的 aComponent 的焦点循环根，或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的最后一个 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

accept

protected boolean accept(Component aComponent)
确定是否可以接受选择指定的 Component 作为新的焦点所有者。此方法执行下列顺序的操作：
  1. 检查 aComponent 是否可见、可显示、已启用以及是否可获得焦点。如果这些属性中任何一个为 false，则此方法返回 false。
  2. 如果 aComponent 是 JTable 的一个实例，则返回 true。
  3. 如果 aComponent 是 JComboBox 的一个实例，则返回 aComponent.getUI().isFocusTraversable(aComponent) 的值。
  4. 如果 aComponent 是一个 JComponent，且具有一个既不为 null 也不为空的 JComponent.WHEN_FOCUSED InputMap，则返回 true。
  5. 返回 DefaultFocusTraversalPolicy.accept(aComponent) 的值。

覆盖：
类 SortingFocusTraversalPolicy 中的 accept
参数：
aComponent - 将测试其是否适合作为焦点所有者的 Component
返回：
如果 aComponent 是作为焦点所有者的有效选择，则返回 true；否则返回 false
另请参见：
Component.isVisible(),
Component.isDisplayable(),
Component.isEnabled(),
Component.isFocusable(),
ComboBoxUI.isFocusTraversable(javax.swing.JComboBox),
JComponent.getInputMap(int),
DefaultFocusTraversalPolicy.accept(java.awt.Component)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LayoutStyle.ComponentPlacement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing
枚举 LayoutStyle.ComponentPlacement

java.lang.Object
    继承者  java.lang.Enum<LayoutStyle.ComponentPlacement>
        继承者  javax.swing.LayoutStyle.ComponentPlacement
所有已实现的接口：
Serializable, Comparable<LayoutStyle.ComponentPlacement>
正在封闭类：
LayoutStyle
public static enum LayoutStyle.ComponentPlacement
extends Enum<LayoutStyle.ComponentPlacement>

ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。ComponentPlacement 由 LayoutStyle 方法 getPreferredGap 使用。有关更多信息，请参阅 LayoutStyle。

从以下版本开始：
1.6
另请参见：
LayoutStyle.getPreferredGap(JComponent,JComponent, ComponentPlacement,int,Container)

枚举常量摘要
INDENT
一个枚举值，指示被请求组件要缩排的距离。
RELATED
一个枚举值，指示两个组件在视觉上相关，并且将被放置在同一个父容器中。
UNRELATED
一个枚举值，指示两个组件在视觉上不相关，并且将被放置在同一个的父容器中。
方法摘要
static LayoutStyle.ComponentPlacement | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static LayoutStyle.ComponentPlacement[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

RELATED

public static final LayoutStyle.ComponentPlacement RELATED
一个枚举值，指示两个组件在视觉上相关，并且将被放置在同一个父容器中。例如，为 JTextField 提供标签的 JLabel 通常在视觉上与该 JTextField 关联；常量 RELATED 用于这种情况。

UNRELATED

public static final LayoutStyle.ComponentPlacement UNRELATED
一个枚举值，指示两个组件在视觉上不相关，并且将被放置在同一个的父容器中。例如，组件的分组通常在视觉上是分开的；常量 UNRELATED 用于此种情况。

INDENT

public static final LayoutStyle.ComponentPlacement INDENT
一个枚举值，指示被请求组件要缩排的距离。例如，经常从标签中水平缩排该标签的子元素。要确定此类间隙的首选距离，使用 INDENT 类型。

此值通常只与 EAST 或 WEST 方向一起使用。

方法详细信息

values

public static final LayoutStyle.ComponentPlacement[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(LayoutStyle.ComponentPlacement c : LayoutStyle.ComponentPlacement.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static LayoutStyle.ComponentPlacement valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


ListCellRenderer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 ListCellRenderer

所有已知实现类：
BasicComboBoxRenderer, BasicComboBoxRenderer.UIResource, DefaultListCellRenderer, DefaultListCellRenderer.UIResource, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer
public interface ListCellRenderer

标识可用作“橡皮图章”以绘制 JList 中单元格的组件。例如，要将 JLabel 用作 ListCellRenderer，则需要编写：

 class MyCellRenderer extends JLabel implements ListCellRenderer {
     public MyCellRenderer() {
         setOpaque(true);
     }

     public Component getListCellRendererComponent(JList list,
                                                   Object value,
                                                   int index,
                                                   boolean isSelected,
                                                   boolean cellHasFocus) {

         setText(value.toString());

         Color background;
         Color foreground;

         // check if this cell represents the current DnD drop location
         JList.DropLocation dropLocation = list.getDropLocation();
         if (dropLocation != null
                 && !dropLocation.isInsert()
                 && dropLocation.getIndex() == index) {

             background = Color.BLUE;
             foreground = Color.WHITE;

         // check if this cell is selected
         } else if (isSelected) {
             background = Color.RED;
             foreground = Color.WHITE;

         // unselected, and not the DnD drop location
         } else {
             background = Color.WHITE;
             foreground = Color.BLACK;
         };

         setBackground(background);
         setForeground(foreground);

         return this;
     }
 }

另请参见：
JList, DefaultListCellRenderer

方法摘要
 Component getListCellRendererComponent(JList list, Object value, int index, boolean isSelected, boolean cellHasFocus)
返回已配置用于显示指定值的组件。

方法详细信息

getListCellRendererComponent

Component getListCellRendererComponent(JList list,
                                       Object value,
                                       int index,
                                       boolean isSelected,
                                       boolean cellHasFocus)
返回已配置用于显示指定值的组件。然后调用该组件的 paint 方法来“呈现”单元格。如果由于列表单元格没有固定的大小而有必要计算该列表的尺寸，则调用此方法来生成一个可在其上调用 getPreferredSize 的组件。

参数：
list - 正在绘制的 JList。
value - 由 list.getModel().getElementAt(index) 返回的值。
index - 单元格索引。
isSelected - 如果选择了指定的单元格，则为 true。
cellHasFocus - 如果指定的单元格拥有焦点，则为 true。
返回：
其 paint() 方法将呈现指定值的组件。
另请参见：
JList, ListSelectionModel, ListModel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 ListModel

所有已知子接口：
ComboBoxModel, MutableComboBoxModel
所有已知实现类：
AbstractListModel, BasicDirectoryModel, DefaultComboBoxModel, DefaultListModel, MetalFileChooserUI.DirectoryComboBoxModel, MetalFileChooserUI.FilterComboBoxModel
public interface ListModel

此接口定义方法组件（如 JList），这些组件用于获取列表中每个单元格的值以及列表的长度。在逻辑上，模型是一个向量，索引范围从 0 到 ListDataModel.getSize() - 1。对数据模型的内容和长度的任何更改必须报告给所有 ListDataListener。

另请参见：
JList

方法摘要
void | addListDataListener(ListDataListener l) 将一个侦听器添加到每次在数据模型发生更改时都得到通知的列表。
Object | getElementAt(int index) 返回指定索引处的值。
int | getSize() 返回列表的长度。
void | removeListDataListener(ListDataListener l) 从每次在数据模型发生更改时都得到通知的列表中移除侦听器。

方法详细信息

getSize

int getSize()
返回列表的长度。

返回：
列表的长度

getElementAt

Object getElementAt(int index)
返回指定索引处的值。

参数：
index - 请求的索引
返回：
index 处的值

addListDataListener

void addListDataListener(ListDataListener l)
将一个侦听器添加到每次在数据模型发生更改时都得到通知的列表。

参数：
l - 要添加的 ListDataListener

removeListDataListener

void removeListDataListener(ListDataListener l)
从每次在数据模型发生更改时都得到通知的列表中移除侦听器。

参数：
l - 要移除的 ListDataListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListSelectionModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 ListSelectionModel

所有已知实现类：
DefaultListSelectionModel
public interface ListSelectionModel

此接口表示任何组件的当前选择状态，该组件显示一个具有稳定索引的值列表。该选择被建模为一组区间，每个区间表示一个选定列表元素的连续范围。修改该组选定区间的方法都采用一对索引：index0 和 index1，这对索引表示一个闭区间，即该区间同时包括 index0 和 index1。

另请参见：
DefaultListSelectionModel

字段摘要
static int | MULTIPLE_INTERVAL_SELECTION selectionMode 属性的值：一次选择一个或多个连续的索引范围。
static int | SINGLE_INTERVAL_SELECTION selectionMode 属性的值：一次选择一个连续的索引范围。
static int | SINGLE_SELECTION selectionMode 属性的值：一次选择一个列表索引。
方法摘要
 void addListSelectionListener(ListSelectionListener x)
将侦听器添加到每次在选择发生更改时都得到通知的列表。
 void addSelectionInterval(int index0, int index1)
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的并集。
 void clearSelection()
将该选择更改为空集。
 int getAnchorSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。
 int getLeadSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。
 int getMaxSelectionIndex()
返回最后选择的索引，如果选择为空，则返回 -1。
 int getMinSelectionIndex()
返回第一个选择的索引，如果选择为空，则返回 -1。
 int getSelectionMode()
返回当前选择模式。
 boolean getValueIsAdjusting()
如果选择在进行一系列更改，则返回 true。
 void insertIndexInterval(int index, int length, boolean before)
在 index 之前/之后开始插入 length 个索引。
 boolean isSelectedIndex(int index)
如果选择了指定的索引，则返回 true。
 boolean isSelectionEmpty()
如果没有选择索引，则返回 true。
 void removeIndexInterval(int index0, int index1)
从选择模型中移除区间 index0、index1（包括）中的索引。
 void removeListSelectionListener(ListSelectionListener x)
将侦听器从每次在选择发生更改时都得到通知的列表中移除。
 void removeSelectionInterval(int index0, int index1)
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的差集。
 void setAnchorSelectionIndex(int index)
设置 anchor 选择索引。
 void setLeadSelectionIndex(int index)
设置 lead 选择索引。
 void setSelectionInterval(int index0, int index1)
将选择更改为在 index0 和 index1 之间（包括两者）。
 void setSelectionMode(int selectionMode)
设置选择模式。
 void setValueIsAdjusting(boolean valueIsAdjusting)
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。

字段详细信息

SINGLE_SELECTION

static final int SINGLE_SELECTION
selectionMode 属性的值：一次选择一个列表索引。

另请参见：
setSelectionMode(int), 常量字段值

SINGLE_INTERVAL_SELECTION

static final int SINGLE_INTERVAL_SELECTION
selectionMode 属性的值：一次选择一个连续的索引范围。

另请参见：
setSelectionMode(int), 常量字段值

MULTIPLE_INTERVAL_SELECTION

static final int MULTIPLE_INTERVAL_SELECTION
selectionMode 属性的值：一次选择一个或多个连续的索引范围。

另请参见：
setSelectionMode(int), 常量字段值
方法详细信息

setSelectionInterval

void setSelectionInterval(int index0,
                          int index1)
将选择更改为在 index0 和 index1 之间（包括两者）。index0 不必小于等于 index1。

在 SINGLE_SELECTION 选择模式中，只使用第二个索引。

如果这表示对当前选择的更改，则通知每个 ListSelectionListener 该更改。

参数：
index0 - 区间的一端。
index1 - 区间的另一端
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener)

addSelectionInterval

void addSelectionInterval(int index0,
                          int index1)
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的并集。index0 不必小于等于 index1。

在 SINGLE_SELECTION 选择模式中，这等效于调用 setSelectionInterval，并且只使用第二个索引。在 SINGLE_INTERVAL_SELECTION 选择模式中，此方法行为类似于 setSelectionInterval，除非给定区间紧接现有选择或与现有选择重叠从而可用于增大该选择。

如果这表示对当前选择的更改，则通知每个 ListSelectionListener 该更改。

参数：
index0 - 区间的一端。
index1 - 区间的另一端
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener), setSelectionInterval(int, int)

removeSelectionInterval

void removeSelectionInterval(int index0,
                             int index1)
将选择更改为当前选择与 index0 和 index1 之间（包括两者）索引的差集。index0 不必小于等于 index1。

在 SINGLE_INTERVAL_SELECTION 选择模式中，如果移除操作会生成两个不相交的选择，那么移除操作将延伸到选择的较大端。例如，如果选择是 0-10，提供的索引是 5,6（按任意顺序），则所得选择是 0-4。

如果这表示对当前选择的更改，则通知每个 ListSelectionListener 该更改。

参数：
index0 - 区间的一端。
index1 - 区间的另一端
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener)

getMinSelectionIndex

int getMinSelectionIndex()
返回第一个选择的索引，如果选择为空，则返回 -1。

getMaxSelectionIndex

int getMaxSelectionIndex()
返回最后选择的索引，如果选择为空，则返回 -1。

isSelectedIndex

boolean isSelectedIndex(int index)
如果选择了指定的索引，则返回 true。

getAnchorSelectionIndex

int getAnchorSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第一个索引参数。最近的 index0 被认为是 "anchor"，最近的 index1 被认为是 "lead"。一些界面特别地显示这些索引，例如，Windows95 显示带有黄色点式轮廓的 lead 索引。

另请参见：
getLeadSelectionIndex(),
setSelectionInterval(int, int),
addSelectionInterval(int, int)

setAnchorSelectionIndex

void setAnchorSelectionIndex(int index)
设置 anchor 选择索引。

另请参见：
getAnchorSelectionIndex()

getLeadSelectionIndex

int getLeadSelectionIndex()
从对 setSelectionInterval()、addSelectionInterval() 或 removeSelectionInterval() 的最近调用中返回第二个索引参数。

另请参见：
getAnchorSelectionIndex(),
setSelectionInterval(int, int),
addSelectionInterval(int, int)

setLeadSelectionIndex

void setLeadSelectionIndex(int index)
设置 lead 选择索引。

另请参见：
getLeadSelectionIndex()

clearSelection

void clearSelection()
将该选择更改为空集。如果这表示对当前选择的更改，则通知每个 ListSelectionListener。

另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener)

isSelectionEmpty

boolean isSelectionEmpty()
如果没有选择索引，则返回 true。

insertIndexInterval

void insertIndexInterval(int index,
                         int length,
                         boolean before)
在 index 之前/之后开始插入 length 个索引。通常调用此方法来同步选择模型与数据模型中的相应更改。

removeIndexInterval

void removeIndexInterval(int index0,
                         int index1)
从选择模型中移除区间 index0、index1（包括）中的索引。通常调用此方法来同步选择模型与数据模型中的相应更改。

setValueIsAdjusting

void setValueIsAdjusting(boolean valueIsAdjusting)
设置 valueIsAdjusting 属性，指示即将进行的选择更改是否应该被视为单个更改的一部分。此属性的值用于初始化生成 ListSelectionEvent 的 valueIsAdjusting 属性。

例如，如果选择被更新以响应一个用户的拖动，那么在拖动开始时，此属性被设置为 true；在拖动结束时被设置为 false。在拖动期间，侦听器接收 valueIsAdjusting 属性设置为 true 的事件。在拖动的最后，当更改终止时，侦听器接收一个值设置为 false 的事件。如果只在更改已终止时希望更新，则侦听器可以使用此模式。

将此属性设置为 true 将开始一系列将被视为单个更改一部分的更改。当该属性更改回 false 时，发送一个表现整个选择更改特征的事件（如果有），该事件的 valueIsAdjusting 属性设置为 false。

参数：
valueIsAdjusting - 属性的新值
另请参见：
getValueIsAdjusting(), ListSelectionEvent.getValueIsAdjusting()

getValueIsAdjusting

boolean getValueIsAdjusting()
如果选择在进行一系列更改，则返回 true。

返回：
如果选择在进行一系列更改，则返回 true
另请参见：
setValueIsAdjusting(boolean)

setSelectionMode

void setSelectionMode(int selectionMode)
设置选择模式。以下列表描述了接受的选择模式：
  • ListSelectionModel.SINGLE_SELECTION - 一次只能选择一个列表索引。在此模式中，setSelectionInterval 和 addSelectionInterval 是等效的，两者都使用第二个参数（“lead”）所表示的索引来替换当前选择。
  • ListSelectionModel.SINGLE_INTERVAL_SELECTION - 一次只能选择一个连续索引区间。在此模式中，addSelectionInterval 行为类似于 setSelectionInterval（替换当前选择），除非给定区间紧接现有选择或与现有选择重叠从而可用于增大该选择。
  • ListSelectionModel.MULTIPLE_INTERVAL_SELECTION - 在此模式中，对选择内容无任何限制。

抛出：
IllegalArgumentException - 如果选择模式不是允许的模式之一
另请参见：
getSelectionMode()

getSelectionMode

int getSelectionMode()
返回当前选择模式。

返回：
当前选择模式
另请参见：
setSelectionMode(int)

addListSelectionListener

void addListSelectionListener(ListSelectionListener x)
将侦听器添加到每次在选择发生更改时都得到通知的列表。

参数：
x - ListSelectionListener
另请参见：
removeListSelectionListener(javax.swing.event.ListSelectionListener),
setSelectionInterval(int, int),
addSelectionInterval(int, int),
removeSelectionInterval(int, int),
clearSelection(),
insertIndexInterval(int, int, boolean),
removeIndexInterval(int, int)

removeListSelectionListener

void removeListSelectionListener(ListSelectionListener x)
将侦听器从每次在选择发生更改时都得到通知的列表中移除。

参数：
x - ListSelectionListener
另请参见：
addListSelectionListener(javax.swing.event.ListSelectionListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LookAndFeel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 LookAndFeel

java.lang.Object
    继承者  javax.swing.LookAndFeel
直接已知子类：
BasicLookAndFeel, MultiLookAndFeel
public abstract class LookAndFeel
extends Object

顾名思义，LookAndFeel 封装了一个外观。除了安装外观之外，大多数开发人员无需直接与 LookAndFeel 进行交互。通常，只有创建自定义外观的开发人员才需要涉及此类。

Swing 构建的基础是每个 JComponent 子类都具有特定 ComponentUI 子类的实现。ComponentUI 通常被称为“ui”、“组件 ui”或“外观委托”。ComponentUI 子类负责提供组件特定于外观的功能。例如，JTree 需要 ComponentUI 子类 TreeUI 的实现。特定 ComponentUI 子类的实现由 LookAndFeel 提供。通过 JComponent 方法 getUIClassID，每个 JComponent 子类可标识所需的 ComponentUI 子类。

每个 LookAndFeel 实现必须提供适当 ComponentUI 子类的实现，方法是为 getDefaults 所返回的 UIDefaults 对象中每个 Swing 的 ui 类 id 指定一个值。例如，BasicLookAndFeel 将 BasicTreeUI 用作 TreeUI 的具体实现。这是通过提供键-值对 "TreeUI"-"javax.swing.plaf.basic.BasicTreeUI" 的 BasicLookAndFeel 完成的，该键-值对在 getDefaults 所返回的 UIDefaults 中。有关如何获得 ComponentUI 子类实现的详细信息，请参阅 UIDefaults.getUI(JComponent)。

当安装了一个 LookAndFeel 时，UIManager 不会检查是否存在所有 ui 类 id 的项。因此，如果当前外观尚未为特定 ui 类 id 提供一个值，并且创建了 JComponent 子类的实例，则会发生随机异常。

对外观的建议

正如 UIManager 中说明的，每个 LookAndFeel 都有机会提供一个默认值（该值按开发人员和系统默认值分层）的集合。Swing 的某些组件要求外观提供默认值的特定集合。这些在要求特定默认值的类中有记录。

ComponentUI 和默认值

所有 ComponentUI 通常都需要在 JComponent 上设置各种属性，ComponentUI 为其提供外观。这通常在 JComponent 上安装了 ComponentUI 时执行。只有在开发人员尚未设置属性时，才应该设置该属性。对于非基本值，只有当前值为 null 或实现 UIResource 时，才建议 ComponentUI 更改 JComponent 上的属性。如果当前值为 null 或实现 UIResource，则它指示开发人员尚未设置该属性，ui 可以随意更改它。例如，只有从 button.getFont() 返回的值为 null 或实现 UIResource 时，BasicButtonUI.installDefaults 才更改 JButton 的字体。另一方面，如果 button.getFont() 返回一个未实现 UIResource 的非 null 值，则 BasicButtonUI.installDefaults 将不会更改 JButton 的字体。

对于基本值（如 opaque），应该调用 installProperty 方法。只有在开发人员尚未更改该值时，installProperty 才更改对应属性。

在 ComponentUI 实现使用推荐指南处理必需的检查和安装属性时，它们应该使用此类提供的各种安装方法。

异常

如果要更改的属性值为 null 或 UIResource，则 LookAndFeel 提供的所有安装方法都需要访问默认值。例如，安装字体执行以下操作：
   JComponent c;
   Font font = c.getFont();
   if (font == null || (font instanceof UIResource)) {
       c.setFont(UIManager.getFont("fontKey"));
   }
如果字体为 null 或 UIResource，则使用 fontKey 键查询默认表。如果传入 null，则所有 UIDefaults 的获取方法都将抛出 NullPointerException。因此，如果当前值为 null 或 UIResource，并且提供的默认键为 null，那么除非另行说明，否则 LookAndFeel 的每个安装方法都将抛出 NullPointerException。此外，如果传入一个 null 组件，那么除非另行指定，否则所有 install 方法都将抛出 NullPointerException。

构造方法摘要
LookAndFeel()
方法摘要
 UIDefaults getDefaults()
返回外观的默认值。
abstract  String getDescription()
返回对此外观实现的单行描述，例如，"The CDE/Motif Look and Feel"。
static Object getDesktopPropertyValue(String systemPropertyName, Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。
 Icon getDisabledIcon(JComponent component, Icon icon)
返回具有禁用外观的 Icon。
 Icon getDisabledSelectedIcon(JComponent component, Icon icon)
返回由选定的禁用组件使用的 Icon。
abstract  String getID()
返回标识此外观的字符串。
 LayoutStyle getLayoutStyle()
返回此外观的 LayoutStyle。
abstract  String getName()
返回标识此外观的短字符串，例如 "CDE/Motif"。
 boolean getSupportsWindowDecorations()
如果 LookAndFeel 返回的 RootPaneUI 实例支持 JRootPane 中提供 Window 装饰，则返回 true。
 void initialize()
初始化外观。
static void installBorder(JComponent c, String defaultBorderName)
使用默认的值设置组件边框属性的便捷方法。
static void installColors(JComponent c, String defaultBgName, String defaultFgName)
使用默认的值设置组件的前景和背景颜色属性的便捷方法。
static void installColorsAndFont(JComponent c, String defaultBgName, String defaultFgName, String defaultFontName)
使用默认的值设置组件的前景、背景和字体属性的便捷方法。
static void installProperty(JComponent c, String propertyName, Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。
abstract  boolean isNativeLookAndFeel()
如果底层平台具有“本机”外观，而且这是对它的一个实现，则返回 true。
abstract  boolean isSupportedLookAndFeel()
如果底层平台支持和/或允许此外观，则返回 true。
static void loadKeyBindings(InputMap retMap, Object[] keys)
使用指定绑定填充 InputMap。
static ComponentInputMap makeComponentInputMap(JComponent c, Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。
static Object makeIcon(Class<?> baseClass, String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。
static InputMap makeInputMap(Object[] keys)
根据 keys 创建一个 InputMapUIResource。
static JTextComponent.KeyBinding[] makeKeyBindings(Object[] keyBindingList)
构建一个 KeyBinding 数组的便捷方法。
 void provideErrorFeedback(Component component)
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。
 String toString()
返回显示和标识此对象属性的字符串。
 void uninitialize()
取消初始化外观。
static void uninstallBorder(JComponent c)
卸载边框的便捷方法。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

LookAndFeel

public LookAndFeel()
方法详细信息

installColors

public static void installColors(JComponent c,
                                 String defaultBgName,
                                 String defaultFgName)
使用默认的值设置组件的前景和背景颜色属性的便捷方法。只有在当前值为 null 或 UIResource 时才设置这些属性。

参数：
c - 要设置颜色的组件
defaultBgName - 背景的键
defaultFgName - 前景的键
抛出：
NullPointerException - 如异常中所述
另请参见：
installColorsAndFont(javax.swing.JComponent, java.lang.String, java.lang.String, java.lang.String), UIManager.getColor(java.lang.Object)

installColorsAndFont

public static void installColorsAndFont(JComponent c,
                                        String defaultBgName,
                                        String defaultFgName,
                                        String defaultFontName)
使用默认的值设置组件的前景、背景和字体属性的便捷方法。只有在当前值为 null 或 UIResource 时才设置这些属性。

参数：
c - 要设置颜色和字体的组件
defaultBgName - 背景的键
defaultFgName - 前景的键
defaultFontName - 字体的键
抛出：
NullPointerException - 如异常中所述
另请参见：
installColors(javax.swing.JComponent, java.lang.String, java.lang.String),
UIManager.getColor(java.lang.Object),
UIManager.getFont(java.lang.Object)

installBorder

public static void installBorder(JComponent c,
                                 String defaultBorderName)
使用默认的值设置组件边框属性的便捷方法。只有在边框为 null 或 UIResource 的实例时才设置该边框。

参数：
c - 要设置边框的组件
defaultBorderName - 指定该边框的键
抛出：
NullPointerException - 如异常中所述

uninstallBorder

public static void uninstallBorder(JComponent c)
卸载边框的便捷方法。如果该组件的边框是一个 UIResource，则将它设置为 null。

参数：
c - 要卸载边框的组件
抛出：
NullPointerException - 如果 c 为 null

installProperty

public static void installProperty(JComponent c,
                                   String propertyName,
                                   Object propertyValue)
在组件上安装具有指定名称和值的属性的便捷方法，条件是该属性尚未由开发人员设置。此方法供 ui 委托实例使用，该实例需要为基本类型 (boolean, int, ..) 的属性指定一个默认值，但不希望重写由客户端设置的值。由于基本属性值无法使用 UIResource 标记来包装，此方法使用私有状态来确定属性是否已由客户端设置。

参数：
c - 要设置属性的目标组件
propertyName - 要设置的属性的名称
propertyValue - 属性的值
抛出：
IllegalArgumentException - 如果指定的属性不是可以使用此方法设置的属性
ClassCastException - 如果属性值尚未由开发人员设置并且类型与属性的类型不匹配
NullPointerException - 如果 c 为 null，或者指定属性尚未由开发人员设置并且 propertyValue 为 null
从以下版本开始：
1.5

makeKeyBindings

public static JTextComponent.KeyBinding[] makeKeyBindings(Object[] keyBindingList)
构建一个 KeyBinding 数组的便捷方法。尽管此方法没有过时，但开发人员应该使用 ActionMap 和 InputMap 来提供键绑定。

此方法返回一个 KeyBinding 数组，其中的每个元素都是 keyBindingList 中一个交替 key-action 对。key 可以是由 KeyStroke.getKeyStroke 方法指定格式的 String，或者是一个 KeyStroke。该对的 action 部分是对应于 Action 名称的 String。

以下示例演示了如何根据六个交替 key-action 对创建一个 KeyBinding 数组：

        JTextComponent.KeyBinding[] multilineBindings = makeKeyBindings( new Object[] {
          "UP", DefaultEditorKit.upAction,
        "DOWN", DefaultEditorKit.downAction,
     "PAGE_UP", DefaultEditorKit.pageUpAction,
   "PAGE_DOWN", DefaultEditorKit.pageDownAction,
       "ENTER", DefaultEditorKit.insertBreakAction,
         "TAB", DefaultEditorKit.insertTabAction
  });
如果 keyBindingList 的长度为奇数，则忽略最后一个元素。

为 key-action 对的 key 或 action 部分提供一个 null 值将导致创建一个 KeyBinding，其对应值为 null。作为 KeyBinding 中 Swing 的期望非 null 值的其他部分，应该避免将 null 作为 key-action 对的 key 或 action 部分提供。

参数：
keyBindingList - key-action 对数组
返回：
KeyBinding 数组
抛出：
NullPointerException - 如果 keyBindingList 为 null
ClassCastException - 如果该对的 key 部分不是 KeyStroke 或 String，或者该对的 action 部分不是 String
另请参见：
ActionMap, InputMap, KeyStroke.getKeyStroke(char)

makeInputMap

public static InputMap makeInputMap(Object[] keys)
根据 keys 创建一个 InputMapUIResource。这是创建新 InputMapUIResource、调用 loadKeyBindings(map, keys) 并返回 InputMapUIResource 的一个便捷方法。

参数：
keys - loadKeyBindings(javax.swing.InputMap, java.lang.Object[]) 中所述的 keystroke-action key 对的交替对
返回：
新创建并填充的 InputMapUIResource
从以下版本开始：
1.3
另请参见：
loadKeyBindings(javax.swing.InputMap, java.lang.Object[])

makeComponentInputMap

public static ComponentInputMap makeComponentInputMap(JComponent c,
                                                      Object[] keys)
根据 keys 创建一个 ComponentInputMapUIResource。这是创建新 ComponentInputMapUIResource、调用 loadKeyBindings(map, keys) 并返回 ComponentInputMapUIResource 的一个便捷方法。

参数：
c - 要用来创建 ComponentInputMapUIResource 的组件
keys - loadKeyBindings(javax.swing.InputMap, java.lang.Object[]) 中所述的 keystroke-action key 对的交替对
返回：
新创建并填充的 InputMapUIResource
抛出：
IllegalArgumentException - 如果 c 为 null
从以下版本开始：
1.3
另请参见：
loadKeyBindings(javax.swing.InputMap, java.lang.Object[]), ComponentInputMapUIResource

loadKeyBindings

public static void loadKeyBindings(InputMap retMap,
                                   Object[] keys)
使用指定绑定填充 InputMap。该绑定作为一个交替 keystroke-action key 对的列表提供。keystroke 是 KeyStroke 的实例，或者是标识该绑定的 KeyStroke 的 String。有关特定格式，请参阅 KeyStroke.getKeyStroke(String)。该对的 action key 部分是为 KeyStroke 在 InputMap 中注册的键。

以下代码演示了如何使用两个 key-action 对来加载 InputMap：

   LookAndFeel.loadKeyBindings(inputMap, new Object[] {
     "control X", "cut",
     "control V", "paste"
   });

提供一个绑定 keys 的 null 列表不会以任何方式更改 retMap。

指定一个为 null 的 action key 将导致从 InputMap 中移除 keystroke 的项。忽略为 null 的 keystroke。

参数：
retMap - 要添加 key-action 对的 InputMap
keys - 要添加到 retMap 的绑定
抛出：
NullPointerException - 如果 keys 为非 null，不为空，并且 retMap 为 null
从以下版本开始：
1.3
另请参见：
KeyStroke.getKeyStroke(String), InputMap

makeIcon

public static Object makeIcon(Class<?> baseClass,
                              String gifFile)
创建并返回一个加载图像的 UIDefault.LazyValue。返回值是 UIDefaults.LazyValue 的实现。当在返回对象上调用 createValue 时加载图像。如果图像为非 null，则它包装在一个实现 UIResource 的 Icon 中。使用 Class.getResourceAsStream(gifFile) 加载图像。

此方法不会以任何方式检查参数。建议最好提供非 null 值，否则在返回对象上调用 createValue 时可能发生异常。

参数：
baseClass - 用于加载资源的 Class
gifFile - 要加载的图像的路径
返回：
一个 UIDefaults.LazyValue；该值被解析时 LazyValue 加载指定的图像
另请参见：
UIDefaults.LazyValue, Icon, Class.getResourceAsStream(String)

getLayoutStyle

public LayoutStyle getLayoutStyle()
返回此外观的 LayoutStyle。此方法永远不会返回 null。

通常不使用外观的 LayoutStyle，而使用 LayoutStyle 方法 getInstance。

返回：
此外观的 LayoutStyle
从以下版本开始：
1.6
另请参见：
LayoutStyle.getInstance()

provideErrorFeedback

public void provideErrorFeedback(Component component)
在用户尝试一个无效操作时调用，例如，在具有焦点的不可编辑的 JTextField 中进行粘贴。默认实现蜂鸣。期待不同行为的子类应重写它，并提供其他的反馈。

参数：
component - 其中发生错误的 Component，可以为 null，指示错误条件与某个 Component 并无直接关联
从以下版本开始：
1.4

getDesktopPropertyValue

public static Object getDesktopPropertyValue(String systemPropertyName,
                                             Object fallbackValue)
通过调用 Toolkit.getDefaultToolkit().getDesktopProperty() 返回指定系统桌面属性的值。如果指定属性的值为 null，则返回 fallbackValue。

参数：
systemPropertyName - 正被查询的系统桌面属性的名称
fallbackValue - 在系统值为 null 时，要作为值返回的对象
返回：
桌面属性的当前值
从以下版本开始：
1.4
另请参见：
Toolkit.getDesktopProperty(java.lang.String)

getDisabledIcon

public Icon getDisabledIcon(JComponent component,
                            Icon icon)
返回具有禁用外观的 Icon。此方法用于在未指定图标时生成被禁用的 Icon。例如，如果创建了一个 JButton，并通过 setIcon 仅指定了一个 Icon，则会调用此方法来生成被禁用的 Icon。如果 null 作为 icon 传递，则此方法将返回 null。

有些外观可能不呈现被禁用的 Icon，在此情况下这些外观将忽略它。

参数：
component - 将显示 Icon 的 JComponent，可以为 null
icon - 从其生成禁用图标的 Icon
返回：
禁用 Icon；如果无法生成合适的 Icon，则返回 null
从以下版本开始：
1.5

getDisabledSelectedIcon

public Icon getDisabledSelectedIcon(JComponent component,
                                    Icon icon)
返回由选定的禁用组件使用的 Icon。此方法用于为以下情况的组件生成一个 Icon：这些组件均为禁用和选中状态，但没有此状态的指定 Icon。例如，如果创建了一个 JButton，并通过 setIcon 仅指定了一个 Icon，则会调用此方法来生成禁用和选中的 Icon。如果 null 作为 icon 传递，则此方法将返回 null。

有些外观可能不呈现禁用和选中的 Icon，在此情况下这些外观将忽略它。

参数：
component - 将显示 Icon 的 JComponent，可以为 null
icon - 从其生成禁用和选中图标的 Icon
返回：
禁用和选中的图标，如果无法生成合适的 Icon，则返回 null
从以下版本开始：
1.5

getName

public abstract String getName()
返回标识此外观的短字符串，例如 "CDE/Motif"。此字符串应适合于菜单项。不同的外观应具有不同的名称，例如，更改某些组件呈现方式的 MotifLookAndFeel 的子类应称为 "CDE/Motif My Way"；这对从名称列表中选择 L&F 的用户非常有用。

返回：
该外观的短标识符

getID

public abstract String getID()
返回标识此外观的字符串。此字符串将由希望识别熟知的外观实现的应用程序/服务使用。目前熟知的的名称有“Motif”、“Windows”、“Mac”和“Metal”。注意，由未对外观进行任何基本更改的熟知的超类派生的 LookAndFeel 不应重写此方法。

返回：
该外观的标识符

getDescription

public abstract String getDescription()
返回对此外观实现的单行描述，例如，"The CDE/Motif Look and Feel"。此字符串供用户使用，例如，在窗口的标题中或在 ToolTip 消息中使用。

返回：
该外观的简短描述

getSupportsWindowDecorations

public boolean getSupportsWindowDecorations()
如果 LookAndFeel 返回的 RootPaneUI 实例支持 JRootPane 中提供 Window 装饰，则返回 true。

默认实现返回 false，支持 Window 装饰的子类应重写它并返回 true。

返回：
如果此外观创建的 RootPaneUI 实例支持客户端装饰，则返回 true
从以下版本开始：
1.4
另请参见：
JDialog.setDefaultLookAndFeelDecorated(boolean),
JFrame.setDefaultLookAndFeelDecorated(boolean),
JRootPane.setWindowDecorationStyle(int)

isNativeLookAndFeel

public abstract boolean isNativeLookAndFeel()
如果底层平台具有“本机”外观，而且这是对它的一个实现，则返回 true。例如，在底层平台为运行 CDE 的 Solaris 时，CDE/Motif 的外观实现将返回 true。

返回：
如果此外观表示底层平台的外观，则返回 true

isSupportedLookAndFeel

public abstract boolean isSupportedLookAndFeel()
如果底层平台支持和/或允许此外观，则返回 true。如果外观取决于特定资源或未为当前平台定义合法协议，则此方法返回 false。

返回：
如果这是一个受支持的外观，则返回 true
另请参见：
UIManager.setLookAndFeel(javax.swing.LookAndFeel)

initialize

public void initialize()
初始化外观。尽管此方法是公共的，但只有在外观作为当前外观安装时才能由 UIManager 调用。在 UIManager 调用 getDefaults 之前调用此方法。此方法用于执行外观的任何初始化。子类应该用此方法而不是静态初始化程序来执行它们需要的任何一次设置，因为也可能只是为了发现 isSupportedLookAndFeel() 返回 false 而加载外观类对象。

另请参见：
uninitialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

uninitialize

public void uninitialize()
取消初始化外观。尽管此方法是公共的，但只有在卸载外观时才能由 UIManager 调用。例如，外观更改时 UIManager.setLookAndFeel 调用此方法。

子类在此处可以选择释放一些资源。

另请参见：
initialize(), UIManager.setLookAndFeel(javax.swing.LookAndFeel)

getDefaults

public UIDefaults getDefaults()
返回外观的默认值。尽管此方法是公共的，但只有在调用 initialize 后，外观作为当前外观设置时才能由 UIManager 调用。

返回：
外观默认值
另请参见：
initialize(),
uninitialize(),
UIManager.setLookAndFeel(javax.swing.LookAndFeel)

toString

public String toString()
返回显示和标识此对象属性的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuElement (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 MenuElement

所有已知实现类：
BasicComboPopup, BasicInternalFrameTitlePane.SystemMenuBar, JCheckBoxMenuItem, JMenu, JMenuBar, JMenuItem, JPopupMenu, JRadioButtonMenuItem, MetalComboBoxUI.MetalComboPopup
public interface MenuElement

可以放入菜单中的所有组件都应该实现此接口。此接口由 MenuSelectionManager 用来处理菜单层次结构中的选择和导航。

方法摘要
Component | getComponent() 此方法应返回用于绘制接收元素的 java.awt.Component。
MenuElement[] | getSubElements() 此方法应返回一个包含接收菜单元素的子元素的数组
void | menuSelectionChanged(boolean isIncluded) 在向菜单选择中添加或从中删除 MenuElement 时，由 MenuSelectionManager 调用。
void | processKeyEvent(KeyEvent event, MenuElement[] path, MenuSelectionManager manager) 处理键事件。
void | processMouseEvent(MouseEvent event, MenuElement[] path, MenuSelectionManager manager) 处理鼠标事件。

方法详细信息

processMouseEvent

void processMouseEvent(MouseEvent event,
                       MenuElement[] path,
                       MenuSelectionManager manager)
处理鼠标事件。event 是 MouseEvent，其源为接收元素的组件。path 是包括接收元素本身的菜单层次结构中接收元素的路径。manager 是菜单层次结构的 MenuSelectionManager。此方法应处理 MouseEvent 并根据需要通过使用 MenuSelectionManager 的 API 更改菜单选择。注：不必将事件转发到子组件。此操作可以通过 MenuSelectionManager 自动完成。

processKeyEvent

void processKeyEvent(KeyEvent event,
                     MenuElement[] path,
                     MenuSelectionManager manager)
处理键事件。

menuSelectionChanged

void menuSelectionChanged(boolean isIncluded)
在向菜单选择中添加或从中删除 MenuElement 时，由 MenuSelectionManager 调用。

getSubElements

MenuElement[] getSubElements()
此方法应返回一个包含接收菜单元素的子元素的数组

返回：
MenuElements 的数组

getComponent

Component getComponent()
此方法应返回用于绘制接收元素的 java.awt.Component。返回的组件用于转换事件并检测事件是否位于 MenuElement 的组件中。

返回：
Component 值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuSelectionManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 MenuSelectionManager

java.lang.Object
    继承者  javax.swing.MenuSelectionManager

public class MenuSelectionManager
extends Object

MenuSelectionManager 拥有菜单层次结构中的选项。

字段摘要
protected ChangeEvent | changeEvent 每个按钮模型实例只需要一个 ChangeEvent，因为事件的惟一状态是 source 属性。
protected EventListenerList | listenerList
构造方法摘要
MenuSelectionManager()
方法摘要
 void addChangeListener(ChangeListener l)
向按钮添加 ChangeListener。
 void clearSelectedPath()
告知菜单选项，以关闭和取消选择所有菜单组件。
 Component componentForPoint(Component source, Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。
static MenuSelectionManager defaultManager()
返回默认菜单选项管理器。
protected  void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。
 ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 MenuSelectionManager 的所有 ChangeListener 的数组。
 MenuElement[] getSelectedPath()
返回当前选择菜单项的路径
 boolean isComponentPartOfCurrentMenu(Component c)
如果 c 是当前使用菜单的一部分，则返回 true
 void processKeyEvent(KeyEvent e)
当 MenuElement 从 KeyListener 接收事件时，它决不应直接处理该事件。
 void processMouseEvent(MouseEvent event)
当 MenuElement 从 MouseListener 接收事件时，它决不应直接处理该事件。
 void removeChangeListener(ChangeListener l)
从按钮中移除 ChangeListener。
 void setSelectedPath(MenuElement[] path)
更改菜单层次结构中的选项。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

changeEvent

protected transient ChangeEvent changeEvent
每个按钮模型实例只需要一个 ChangeEvent，因为事件的惟一状态是 source 属性。所生成事件的 source 总是 "this"。

listenerList

protected EventListenerList listenerList
构造方法详细信息

MenuSelectionManager

public MenuSelectionManager()
方法详细信息

defaultManager

public static MenuSelectionManager defaultManager()
返回默认菜单选项管理器。

返回：
MenuSelectionManager 对象

setSelectedPath

public void setSelectedPath(MenuElement[] path)
更改菜单层次结构中的选项。数组中的元素按从根菜单元素到当前选定菜单元素的顺序排列。

注意，此方法为公共方法，但供外观引擎使用，不应由客户端应用程序调用。

参数：
path - 指定选择路径的 MenuElement 对象的数组

getSelectedPath

public MenuElement[] getSelectedPath()
返回当前选择菜单项的路径

返回：
表示所选路径的 MenuElement 对象的数组

clearSelectedPath

public void clearSelectedPath()
告知菜单选项，以关闭和取消选择所有菜单组件。在做出选择时调用此方法。

addChangeListener

public void addChangeListener(ChangeListener l)
向按钮添加 ChangeListener。

参数：
l - 要添加的侦听器

removeChangeListener

public void removeChangeListener(ChangeListener l)
从按钮中移除 ChangeListener。

参数：
l - 要移除的侦听器

getChangeListeners

public ChangeListener[] getChangeListeners()
返回使用 addChangeListener() 添加到此 MenuSelectionManager 的所有 ChangeListener 的数组。

返回：
所有添加的 ChangeListener，如果没有添加侦听器，则返回空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
通知所有对此事件类型的通知感兴趣的已注册侦听器。以延迟方式创建事件实例。

另请参见：
EventListenerList

processMouseEvent

public void processMouseEvent(MouseEvent event)
当 MenuElement 从 MouseListener 接收事件时，它决不应直接处理该事件。相反，所有 MenuElements 应使用该事件调用此方法。

参数：
event - MouseEvent 对象

componentForPoint

public Component componentForPoint(Component source,
                                   Point sourcePoint)
返回包含 sourcePoint 的当前选择路径的组件。

参数：
source - 已给定坐标空间 sourcePoint 的组件
sourcePoint - 正在被测试的点
返回：
包含 sourcePoint（相对于源组件的坐标空间）的当前选择路径的组件。如果 sourcePoint 不在当前选择路径上的组件中，则返回 null。

processKeyEvent

public void processKeyEvent(KeyEvent e)
当 MenuElement 从 KeyListener 接收事件时，它决不应直接处理该事件。相反，所有 MenuElements 应使用该事件调用此方法。

参数：
e - KeyEvent 对象

isComponentPartOfCurrentMenu

public boolean isComponentPartOfCurrentMenu(Component c)
如果 c 是当前使用菜单的一部分，则返回 true

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MutableComboBoxModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 MutableComboBoxModel

所有超级接口：
ComboBoxModel, ListModel
所有已知实现类：
DefaultComboBoxModel
public interface MutableComboBoxModel
extends ComboBoxModel

ComboBoxModel 的可变版本。

方法摘要
void | addElement(Object obj) 在模型的末尾添加项。
void | insertElementAt(Object obj, int index) 在指定索引处添加项。
void | removeElement(Object obj) 从模型中移除项。
void | removeElementAt(int index) 在指定索引处移除项。
从接口 javax.swing.ComboBoxModel 继承的方法
getSelectedItem, setSelectedItem
从接口 javax.swing.ListModel 继承的方法
addListDataListener, getElementAt, getSize, removeListDataListener

方法详细信息

addElement

void addElement(Object obj)
在模型的末尾添加项。此方法的实现应该通知已添加项的所有已注册 ListDataListener。

参数：
obj - 要添加的 Object

removeElement

void removeElement(Object obj)
从模型中移除项。此方法的实现应该通知已移除项的所有已注册 ListDataListener。

参数：
obj - 要移除的 Object

insertElementAt

void insertElementAt(Object obj,
                     int index)
在指定索引处添加项。此方法的实现应该通知已添加项的所有已注册 ListDataListener。

参数：
obj - 要添加的 Object
index - 添加对象的位置

removeElementAt

void removeElementAt(int index)
在指定索引处移除项。此方法的实现应该通知已移除项的所有已注册 ListDataListener。

参数：
index - 要移除对象的位置
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


OverlayLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 OverlayLayout

java.lang.Object
    继承者  javax.swing.OverlayLayout
所有已实现的接口：
LayoutManager, LayoutManager2, Serializable
public class OverlayLayout
extends Object
implements LayoutManager2, Serializable

要在彼此顶部安排组件的布局管理器。请求的容器大小将是请求的子容器的最大大小，同时要考虑对齐方式的需求。 对齐方式以满足分配区域中子容器的需求为基础。放置子容器，使他们的对齐点都在彼此的顶部。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
OverlayLayout(Container target)
构造执行子容器的覆盖安排的布局管理器。
方法摘要
void | addLayoutComponent(Component comp, Object constraints) 使用指定的约束对象将指定组件添加到布局中。
void | addLayoutComponent(String name, Component comp) 将指定的组件添加到布局中。
float | getLayoutAlignmentX(Container target) 返回容器沿 X 轴的对齐方式。
float | getLayoutAlignmentY(Container target) 返回容器沿 Y 轴的对齐方式。
Container | getTarget() 返回使用此布局管理器的容器。
void | invalidateLayout(Container target) 指示子容器已更改其布局相关信息，这会导致刷新所有缓存计算。
void | layoutContainer(Container target) 当需要布置指定的容器时，由 AWT 调用。
Dimension | maximumLayoutSize(Container target) 返回需要布置组件的最大维数，该组件包含在指定的目标容器中。
Dimension | minimumLayoutSize(Container target) 返回需要布置组件的最小维数，该组件包含在指定的目标容器中。
Dimension | preferredLayoutSize(Container target) 在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
void | removeLayoutComponent(Component comp) 从布局移除指定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

OverlayLayout

public OverlayLayout(Container target)
构造执行子容器的覆盖安排的布局管理器。创建的布局管理器专门用于给定的容器。

参数：
target - 用于执行布局的容器
方法详细信息

getTarget

public final Container getTarget()
返回使用此布局管理器的容器。

返回：
使用此布局管理器的容器
从以下版本开始：
1.6

invalidateLayout

public void invalidateLayout(Container target)
指示子容器已更改其布局相关信息，这会导致刷新所有缓存计算。

指定者：
接口 LayoutManager2 中的 invalidateLayout
参数：
target - 容器

addLayoutComponent

public void addLayoutComponent(String name,
                               Component comp)
将指定的组件添加到布局中。由此类使用，以了解何时使布局无效。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 组件的名称
comp - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component comp)
从布局移除指定组件。由此类使用，以了解何时使布局无效。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
comp - 要移除的组件

addLayoutComponent

public void addLayoutComponent(Component comp,
                               Object constraints)
使用指定的约束对象将指定组件添加到布局中。由此类使用，以了解何时使布局无效。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
comp - 要添加的组件
constraints - 如何将组件添加到布局以及添加到何处。

preferredLayoutSize

public Dimension preferredLayoutSize(Container target)
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。重新计算布局（如果已经无效）。getInsets() 返回的当前 inset 设置中的因子。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
target - 需要布置的组件
返回：
包含首选维数的 Dimension 对象
另请参见：
minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container target)
返回需要布置组件的最小维数，该组件包含在指定的目标容器中。重新计算布局（如果已经无效）和当前 inset 设置中的因子。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
target - 需要布置的组件
返回：
包含最小维数的 Dimension 对象
另请参见：
preferredLayoutSize(java.awt.Container)

maximumLayoutSize

public Dimension maximumLayoutSize(Container target)
返回需要布置组件的最大维数，该组件包含在指定的目标容器中。重新计算布局（如果已经无效）和 getInset 返回的 inset 设置中的因子。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
参数：
target - 需要布置的组件
返回：
包含最大维数的 Dimension 对象
另请参见：
preferredLayoutSize(java.awt.Container)

getLayoutAlignmentX

public float getLayoutAlignmentX(Container target)
返回容器沿 X 轴的对齐方式。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX
参数：
target - 容器
返回：
>= 0.0f && <= 1.0f 的对齐方式

getLayoutAlignmentY

public float getLayoutAlignmentY(Container target)
返回容器沿 Y 轴的对齐方式。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY
参数：
target - 容器
返回：
>= 0.0f && <= 1.0f 的对齐方式

layoutContainer

public void layoutContainer(Container target)
当需要布置指定的容器时，由 AWT 调用。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
target - 要布置的容器
抛出：
AWTError - 如果目标不是指定给构造方法的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Popup (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Popup

java.lang.Object
    继承者  javax.swing.Popup

public class Popup
extends Object

Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。Popup 的生命周期很短。获取 Popup 并将它隐藏（调用 hide 方法）后，不应再对它调用任何方法。这允许 PopupFactory 缓存 Popup，以便将来使用。

常规协定是如果需要更改 Component 的大小或 Popup 的位置，应获取新的 Popup。

Popup 不是从 Component 继承的，Popup 的实现负责创建并维护其本身的 Component，以便向用户呈现请求的 Component。

一般不显式创建 Popup 的实例，而是改为从 PopupFactory 获取。

从以下版本开始：
1.4
另请参见：
PopupFactory

构造方法摘要
protected | Popup() 创建 Popup。
protected | Popup(Component owner, Component contents, int x, int y) 为包含 Component content 的 Component owner 创建 Popup。
方法摘要
void | hide() 隐藏和移除 Popup。
void | show() 使 Popup 可见。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

Popup

protected Popup(Component owner,
                Component contents,
                int x,
                int y)
为包含 Component content 的 Component owner 创建 Popup。owner 用于确定对于哪一个 Window 新 Popup 是 Component（Popup 创建的）的父级。null owner 暗示不存在有效的父级。x 和 y 指定放置 Popup 的首选初始位置。基于屏幕大小或其他参数，Popup 不能显示在 x 和 y 处。

参数：
owner - 组件鼠标坐标与其相关，它可以为 null
contents - Popup 的内容
x - 初始 x 屏幕坐标
y - 初始的 y 屏幕坐标
抛出：
IllegalArgumentException - 如果内容为 null

Popup

protected Popup()
创建 Popup。这是为子类提供的。

方法详细信息

show

public void show()
使 Popup 可见。如果 Popup 当前可见，则无效。

hide

public void hide()
隐藏和移除 Popup。移除 Popup 之后，不应再对它调用方法。可以回收 disposed Popup，然后再基于 PopupFactory 使用。同样，如果对 disposed Popup 调用方法，则会产生不确定的行为。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PopupFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 PopupFactory

java.lang.Object
    继承者  javax.swing.PopupFactory

public class PopupFactory
extends Object

顾名思义，PopupFactory 用于获取 Popup 的实例。Popup 用于显示特定包含层次结构中所有其他 Component 之上的 Component。常规协定是从 PopupFactory 获取 Popup 之后，必须调用 Popup 上的 hide。一般用法为：

   PopupFactory factory = PopupFactory.getSharedInstance();
   Popup popup = factory.getPopup(owner, contents, x, y);
   popup.show();
   ...
   popup.hide();

从以下版本开始：
1.4
另请参见：
Popup

构造方法摘要
PopupFactory()
方法摘要
Popup | getPopup(Component owner, Component contents, int x, int y) 为包含 Component contents 的 Component owner 创建 Popup。
static PopupFactory | getSharedInstance() 返回共享 PopupFactory，它可用于获取 Popup。
static void | setSharedInstance(PopupFactory factory) 设置用于获取 Popup 的 PopupFactory。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

PopupFactory

public PopupFactory()
方法详细信息

setSharedInstance

public static void setSharedInstance(PopupFactory factory)
设置用于获取 Popup 的 PopupFactory。如果 factory 为 null，这将抛出 IllegalArgumentException。

参数：
factory - Shared PopupFactory
抛出：
IllegalArgumentException - 如果 factory 为 null
另请参见：
getPopup(java.awt.Component, java.awt.Component, int, int)

getSharedInstance

public static PopupFactory getSharedInstance()
返回共享 PopupFactory，它可用于获取 Popup。

返回：
共享的 PopupFactory

getPopup

public Popup getPopup(Component owner,
                      Component contents,
                      int x,
                      int y)
               throws IllegalArgumentException
为包含 Component contents 的 Component owner 创建 Popup。owner 用于确定 Window，新 Popup 将其作为创建 Popup 的 Component 的父级。null owner 暗示不存在有效的父级。x 和 y 指定放置 Popup 的首选初始位置。基于屏幕大小或其他参数，Popup 不能显示在 x 和 y 处。

参数：
owner - 组件鼠标坐标与其相关，它可以为 null
contents - Popup 的内容
x - 初始的 x 屏幕坐标
y - 初始的 y 屏幕坐标
返回：
包含 Contents 的 Popup
抛出：
IllegalArgumentException - 如果内容为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProgressMonitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ProgressMonitor

java.lang.Object
    继承者  javax.swing.ProgressMonitor
所有已实现的接口：
Accessible
public class ProgressMonitor
extends Object
implements Accessible

监视某个操作的进度的类。如果表现为操作需要一段时间，则会弹出进度对话框。创建 ProgressMonitor 时，向它提供数字范围和描述字符串。在操作进行时，调用 setProgress 方法，以指示操作的 [min,max] 范围有多大。最初，不存在 ProgressDialog。第一个 millisToDecideToPopup 毫秒（默认值为 500）以后，进度监视器会预测该操作将花费多长时间。如果大于 millisToPopup（默认值为 2000，即 2 秒），则弹出 ProgressDialog。

当可以看到 Dialog 框时，调用 setProgress 可以更新进度条。setProgress 并不总是更新该进度条，仅当进度量明显增多时才进行更新。

有关此内容的更多文档和示例，请参阅 The Java Tutorial 中的 How to Monitor Progress 一节。

另请参见：
ProgressMonitorInputStream

嵌套类摘要
protected  class ProgressMonitor.AccessibleProgressMonitor
AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。
字段摘要
protected  AccessibleContext accessibleContext
ProgressMonitor 的 AccessibleContext
构造方法摘要
ProgressMonitor(Component parentComponent, Object message, String note, int min, int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。
方法摘要
void | close() 指示操作已完成。
AccessibleContext | getAccessibleContext() 获得 ProgressMonitor 的 AccessibleContext。
int | getMaximum() 返回最大值 - 进度值的较高端。
int | getMillisToDecideToPopup() 返回在确定是否弹出进度监视器之前此对象等待的时间量。
int | getMillisToPopup() 返回显示弹出监视器花费的时间量。
int | getMinimum() 返回最小值 - 进度值的较低端。
String | getNote() 指定随进度消息一起显示的其他注释。
boolean | isCanceled() 如果用户单击进度对话框中的 Cancel 按钮，则返回 true。
void | setMaximum(int m) 指定最大值。
void | setMillisToDecideToPopup(int millisToDecideToPopup) 指定在确定是否弹出进度监视器之前要等待的时间量。
void | setMillisToPopup(int millisToPopup) 指定显示弹出监视器花费的时间量。
void | setMinimum(int m) 指定最小值。
void | setNote(String note) 指定与进度消息一起显示的其他注释。
void | setProgress(int nv) 指示正被监视操作的进度。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

accessibleContext

protected AccessibleContext accessibleContext
ProgressMonitor 的 AccessibleContext

从以下版本开始：
1.5
构造方法详细信息

ProgressMonitor

public ProgressMonitor(Component parentComponent,
                       Object message,
                       String note,
                       int min,
                       int max)
构造一个图形对象，它一般会根据进程的完成情况通过填充矩形条来显示进度。

参数：
parentComponent - 对话框的父组件
message - 要显示给用户的描述消息，以指示在监视什么操作。这不随操作进度而更改。请参阅 JOptionPane.message 中方法的 message 参数，了解值的范围。
note - 描述操作状态的简短注释。随着操作的进行，可以调用 setNote 来更改显示的注释。例如，这可用于迭代文件列表以显示正在处理的文件名称的操作中。如果注释最初为 null，则对话框中将不存在注释行，并且 setNote 无效
min - 范围的下边界
max - 范围的上边界
另请参见：
JDialog, JOptionPane
方法详细信息

setProgress

public void setProgress(int nv)
指示正被监视操作的进度。如果指定值 >= 最大值，则关闭进度监视器。

参数：
nv - 指定当前值的 int，位于为此组件指定的最大值和最小值之间
另请参见：
setMinimum(int), setMaximum(int), close()

close

public void close()
指示操作已完成。当 setProgress 设置的值 >= 最大值时，此过程自动发生，但是如果提前结束该操作，则可以提前调用它。

getMinimum

public int getMinimum()
返回最小值 - 进度值的较低端。

返回：
表示最小值的 int
另请参见：
setMinimum(int)

setMinimum

public void setMinimum(int m)
指定最小值。

参数：
m - 指定最小值的 int
另请参见：
getMinimum()

getMaximum

public int getMaximum()
返回最大值 - 进度值的较高端。

返回：
表示最大值的 int
另请参见：
setMaximum(int)

setMaximum

public void setMaximum(int m)
指定最大值。

参数：
m - 指定最大值的 int
另请参见：
getMaximum()

isCanceled

public boolean isCanceled()
如果用户单击进度对话框中的 Cancel 按钮，则返回 true。

setMillisToDecideToPopup

public void setMillisToDecideToPopup(int millisToDecideToPopup)
指定在确定是否弹出进度监视器之前要等待的时间量。

参数：
millisToDecideToPopup - 指定要等待的时间（以毫秒为单位）的 int
另请参见：
getMillisToDecideToPopup()

getMillisToDecideToPopup

public int getMillisToDecideToPopup()
返回在确定是否弹出进度监视器之前此对象等待的时间量。

另请参见：
setMillisToDecideToPopup(int)

setMillisToPopup

public void setMillisToPopup(int millisToPopup)
指定显示弹出监视器花费的时间量。（如果剩余的预计时间小于此时间，则不显示弹出监视器。）

参数：
millisToPopup - 指定时间（以毫秒为单位）的 int
另请参见：
getMillisToPopup()

getMillisToPopup

public int getMillisToPopup()
返回显示弹出监视器花费的时间量。

另请参见：
setMillisToPopup(int)

setNote

public void setNote(String note)
指定与进度消息一起显示的其他注释。例如，在复制多个文件的过程中，用于显示当前正在复制哪一个文件。

参数：
note - 指定要显示的注释的 String
另请参见：
getNote()

getNote

public String getNote()
指定随进度消息一起显示的其他注释。

返回：
指定要显示的注释的 String
另请参见：
setNote(java.lang.String)

getAccessibleContext

public AccessibleContext getAccessibleContext()
获得 ProgressMonitor 的 AccessibleContext。

指定者：
接口 Accessible 中的 getAccessibleContext
返回：
ProgressMonitor 的 AccessibleContext
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProgressMonitor.AccessibleProgressMonitor (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ProgressMonitor.AccessibleProgressMonitor

java.lang.Object
    继承者  javax.accessibility.AccessibleContext
        继承者  javax.swing.ProgressMonitor.AccessibleProgressMonitor
所有已实现的接口：
PropertyChangeListener, EventListener, AccessibleText, ChangeListener
正在封闭类：
ProgressMonitor
protected class ProgressMonitor.AccessibleProgressMonitor
extends AccessibleContext
implements AccessibleText, ChangeListener, PropertyChangeListener

AccessibleProgressMonitor 实现 ProgressMonitor 类的可访问性支持。

从以下版本开始：
1.5

字段摘要
从类 javax.accessibility.AccessibleContext 继承的字段
ACCESSIBLE_ACTION_PROPERTY, ACCESSIBLE_ACTIVE_DESCENDANT_PROPERTY, ACCESSIBLE_CARET_PROPERTY, ACCESSIBLE_CHILD_PROPERTY, ACCESSIBLE_COMPONENT_BOUNDS_CHANGED, ACCESSIBLE_DESCRIPTION_PROPERTY, ACCESSIBLE_HYPERTEXT_OFFSET, ACCESSIBLE_INVALIDATE_CHILDREN, ACCESSIBLE_NAME_PROPERTY, ACCESSIBLE_SELECTION_PROPERTY, ACCESSIBLE_STATE_PROPERTY, ACCESSIBLE_TABLE_CAPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_COLUMN_HEADER_CHANGED, ACCESSIBLE_TABLE_MODEL_CHANGED, ACCESSIBLE_TABLE_ROW_DESCRIPTION_CHANGED, ACCESSIBLE_TABLE_ROW_HEADER_CHANGED, ACCESSIBLE_TABLE_SUMMARY_CHANGED, ACCESSIBLE_TEXT_ATTRIBUTES_CHANGED, ACCESSIBLE_TEXT_PROPERTY, ACCESSIBLE_VALUE_PROPERTY, ACCESSIBLE_VISIBLE_DATA_PROPERTY, accessibleDescription, accessibleName, accessibleParent
从接口 javax.accessibility.AccessibleText 继承的字段
CHARACTER, SENTENCE, WORD
构造方法摘要
protected ProgressMonitor.AccessibleProgressMonitor()
AccessibleProgressMonitor 构造方法
方法摘要
Accessible | getAccessibleChild(int i) 返回该对象指定的 Accessible 子对象。
int | getAccessibleChildrenCount() 返回对象中可访问的子级数。
AccessibleComponent | getAccessibleComponent() 获取与此对象关联的 AccessibleComponent，它具有图形表示形式。
String | getAccessibleDescription() 获取对象的 accessibleDescription 属性。
int | getAccessibleIndexInParent() 获取此对象在其可访问的父对象中的索引。
String | getAccessibleName() 获取此对象的 accessibleName 属性。
Accessible | getAccessibleParent() 获取此对象的 Accessible 父对象。
AccessibleRole | getAccessibleRole() 获取此对象的职责。
AccessibleStateSet | getAccessibleStateSet() 获取此对象的状态集。
AccessibleText | getAccessibleText() 获取与在显示器上显示文本的此对象关联的 AccessibleText。
AccessibleValue | getAccessibleValue() 获取与此对象关联的 AccessibleValue，该对象支持数值。
String | getAfterIndex(int part, int index) 返回给定索引后面的 String。
String | getAtIndex(int part, int index) 返回给定索引处的 String。
String | getBeforeIndex(int part, int index) 返回给定索引前面的 String。
int | getCaretPosition() 返回插入符号的从零开始的偏移量。
AttributeSet | getCharacterAttribute(int i) 返回位于给定索引处的给定字符的 AttributeSet
Rectangle | getCharacterBounds(int i) 确定字符串中给定索引处的字符的边界框。
int | getCharCount() 返回字符（有效索引）的数量
int | getIndexAtPoint(Point p) 在本地坐标中给定一个点，返回该 Point 下字符的从零开始的索引。
Locale | getLocale() 获取该组件的语言环境。
String | getSelectedText() 返回选择的一部分文本。
int | getSelectionEnd() 返回选择文本中的结束偏移量。
int | getSelectionStart() 返回选择的文本中的初始偏移量。
void | propertyChange(PropertyChangeEvent e) 更改绑定 (bound) 属性时，调用此方法。
void | stateChanged(ChangeEvent e) 在侦听器的目标已更改其状态时调用。
从类 javax.accessibility.AccessibleContext 继承的方法
addPropertyChangeListener, firePropertyChange, getAccessibleAction, getAccessibleEditableText, getAccessibleIcon, getAccessibleRelationSet, getAccessibleSelection, getAccessibleTable, removePropertyChangeListener, setAccessibleDescription, setAccessibleName, setAccessibleParent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProgressMonitor.AccessibleProgressMonitor

protected ProgressMonitor.AccessibleProgressMonitor()
AccessibleProgressMonitor 构造方法

方法详细信息

stateChanged

public void stateChanged(ChangeEvent e)
在侦听器的目标已更改其状态时调用。

指定者：
接口 ChangeListener 中的 stateChanged
参数：
e - ChangeEvent 对象。不能为 null。
抛出：
NullPointerException - 如果参数为 null。

propertyChange

public void propertyChange(PropertyChangeEvent e)
更改绑定 (bound) 属性时，调用此方法。

指定者：
接口 PropertyChangeListener 中的 propertyChange
参数：
e - 描述事件源和更改的属性的 PropertyChangeEvent 对象。不能为 null。
抛出：
NullPointerException - 如果参数为 null。

getAccessibleName

public String getAccessibleName()
获取此对象的 accessibleName 属性。对象的 accessibleName 属性是指定该对象目的的本地化 String。例如，标签和按钮的 accessibleName 属性可以是标签或按钮本身的文本。对于不显示其名称的对象，仍应设置 accessibleName。例如，对于用于输入城市名称的文本字段，en_US 语言环境的 accessibleName 可以为 "city"。

覆盖：
类 AccessibleContext 中的 getAccessibleName
返回：
对象的本地化名称；如果此对象没有名称，则返回 null
另请参见：
AccessibleContext.setAccessibleName(java.lang.String)

getAccessibleDescription

public String getAccessibleDescription()
获取对象的 accessibleDescription 属性。此对象的 accessibleDescription 属性是描述该对象目的的本地化短语。例如，对于 "Cancel" 按钮，accessibleDescription 可以是 "Ignore changes and close dialog box"（忽略更改并关闭对话框）。

覆盖：
类 AccessibleContext 中的 getAccessibleDescription
返回：
该对象的本地化描述；如果此对象没有描述，则返回 null
另请参见：
AccessibleContext.setAccessibleDescription(java.lang.String)

getAccessibleRole

public AccessibleRole getAccessibleRole()
获取此对象的职责。对象的职责是此对象的类的一般用途或用法。例如，按钮的职责是 AccessibleRole.PUSH_BUTTON。AccessibleRole 中提供了一些职责，组件开发人员可以在一组预定义职责中选择。这就使辅助技术能为各种交互的组件子类（例如，对所有充当按钮的组件使用 AccessibleRole.PUSH_BUTTON）以及区分行为各异的子类（例如，复选框 AccessibleRole.CHECK_BOX 和单选框 AccessibleRole.RADIO_BUTTON）提供一致的接口。

注意，AccessibleRole 类也是可扩展的，因此如果预定义的职责集合不充分时，自定义组件的开发人员可以定义其自己的 AccessibleRole。

指定者：
类 AccessibleContext 中的 getAccessibleRole
返回：
描述该对象职责的 AccessibleRole 实例
另请参见：
AccessibleRole

getAccessibleStateSet

public AccessibleStateSet getAccessibleStateSet()
获取此对象的状态集。对象的 AccessibleStateSet 由一组惟一的 AccessibleStates 组成。对象的 AccessibleStateSet 中的更改将导致激发 ACCESSIBLE_STATE_PROPERTY 属性的 PropertyChangeEvent。

指定者：
类 AccessibleContext 中的 getAccessibleStateSet
返回：
包含对象的当前状态设置的 AccessibleStateSet 的实例
另请参见：
AccessibleStateSet, AccessibleState, AccessibleContext.addPropertyChangeListener(java.beans.PropertyChangeListener)

getAccessibleParent

public Accessible getAccessibleParent()
获取此对象的 Accessible 父对象。

覆盖：
类 AccessibleContext 中的 getAccessibleParent
返回：
此对象的 Accessible 父对象；如果此对象没有 Accessible 父对象，则返回 null

getAccessibleIndexInParent

public int getAccessibleIndexInParent()
获取此对象在其可访问的父对象中的索引。

指定者：
类 AccessibleContext 中的 getAccessibleIndexInParent
返回：
返回此对象父级中从零开始的索引；如果此对象没有可访问父级，则返回 -1。
另请参见：
getAccessibleParent(),
getAccessibleChildrenCount(),
getAccessibleChild(int)

getAccessibleChildrenCount

public int getAccessibleChildrenCount()
返回对象中可访问的子级数。

指定者：
类 AccessibleContext 中的 getAccessibleChildrenCount
返回：
对象的可访问子级数。

getAccessibleChild

public Accessible getAccessibleChild(int i)
返回该对象指定的 Accessible 子对象。Accessible 对象的 Accessible 子级是从零开始的，因此 Accessible 第一个子对象的索引为 0，第二个子对象的索引为 1，依此类推。

指定者：
类 AccessibleContext 中的 getAccessibleChild
参数：
i - 子级从零开始的索引
返回：
对象的 Accessible 子级
另请参见：
getAccessibleChildrenCount()

getLocale

public Locale getLocale()
                 throws IllegalComponentStateException
获取该组件的语言环境。如果该组件没有语言环境，则返回其父级的语言环境。

指定者：
类 AccessibleContext 中的 getLocale
返回：
此组件的语言环境。如果此组件没有语言环境，则返回其父级的语言环境。
抛出：
IllegalComponentStateException - 如果该 Component 没有自己的语言环境，并且尚未被添加到包含层次结构（那样可以从包含父级确定其语言环境）。

getAccessibleComponent

public AccessibleComponent getAccessibleComponent()
获取与此对象关联的 AccessibleComponent，它具有图形表示形式。

覆盖：
类 AccessibleContext 中的 getAccessibleComponent
返回：
如果受对象支持，则返回 AccessibleComponent；否则返回 null
另请参见：
AccessibleComponent

getAccessibleValue

public AccessibleValue getAccessibleValue()
获取与此对象关联的 AccessibleValue，该对象支持数值。

覆盖：
类 AccessibleContext 中的 getAccessibleValue
返回：
如果受对象支持，则返回 AccessibleValue；否则返回 null
另请参见：
AccessibleValue

getAccessibleText

public AccessibleText getAccessibleText()
获取与在显示器上显示文本的此对象关联的 AccessibleText。

覆盖：
类 AccessibleContext 中的 getAccessibleText
返回：
如果受对象支持，则返回 AccessibleText；否则返回 null
另请参见：
AccessibleText

getIndexAtPoint

public int getIndexAtPoint(Point p)
在本地坐标中给定一个点，返回该 Point 下字符的从零开始的索引。如果该点无效，则此方法返回 -1。

指定者：
接口 AccessibleText 中的 getIndexAtPoint
参数：
p - 本地坐标中的点
返回：
点 p 处字符从零开始的索引，如果该点无效则返回 -1。

getCharacterBounds

public Rectangle getCharacterBounds(int i)
确定字符串中给定索引处的字符的边界框。以本地坐标形式返回边界框。如果索引无效，则返回一个空的矩形。

指定者：
接口 AccessibleText 中的 getCharacterBounds
参数：
i - 对 String 的索引
返回：
字符边界框的屏幕坐标，如果索引无效，则返回一个空矩形。

getCharCount

public int getCharCount()
返回字符（有效索引）的数量

指定者：
接口 AccessibleText 中的 getCharCount
返回：
字符数

getCaretPosition

public int getCaretPosition()
返回插入符号的从零开始的偏移量。 注：这表示插入符号的右边与偏移量（插入符号在两个字符之间）有相同的索引值。

指定者：
接口 AccessibleText 中的 getCaretPosition
返回：
从零开始的插入符号偏移量。

getAtIndex

public String getAtIndex(int part,
                         int index)
返回给定索引处的 String。

指定者：
接口 AccessibleText 中的 getAtIndex
参数：
part - 要检索的 CHARACTER、WORD 或 SENTENCE
index - 文本中的一个索引
返回：
字母、单词或句子

getAfterIndex

public String getAfterIndex(int part,
                            int index)
返回给定索引后面的 String。

指定者：
接口 AccessibleText 中的 getAfterIndex
参数：
part - 要检索的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getBeforeIndex

public String getBeforeIndex(int part,
                             int index)
返回给定索引前面的 String。

指定者：
接口 AccessibleText 中的 getBeforeIndex
参数：
part - 要检索的 CHARACTER、WORD 或 SENTENCE
index - 文本中的索引
返回：
字母、单词或句子

getCharacterAttribute

public AttributeSet getCharacterAttribute(int i)
返回位于给定索引处的给定字符的 AttributeSet

指定者：
接口 AccessibleText 中的 getCharacterAttribute
参数：
i - 从零开始的文本索引
返回：
字符的 AttributeSet

getSelectionStart

public int getSelectionStart()
返回选择的文本中的初始偏移量。如果没有选项，但有一个插入符号，则开始和结尾偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionStart
返回：
选择开始处对文本的索引

getSelectionEnd

public int getSelectionEnd()
返回选择文本中的结束偏移量。如果没有选项，但有一个插入符号，则开始和结尾偏移量是相同的。

指定者：
接口 AccessibleText 中的 getSelectionEnd
返回：
选择结尾处对文本的索引

getSelectedText

public String getSelectedText()
返回选择的一部分文本。

指定者：
接口 AccessibleText 中的 getSelectedText
返回：
返回选定文本的 String 部分
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ProgressMonitorInputStream (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ProgressMonitorInputStream

java.lang.Object
    继承者  java.io.InputStream
        继承者  java.io.FilterInputStream
            继承者  javax.swing.ProgressMonitorInputStream
所有已实现的接口：
Closeable
public class ProgressMonitorInputStream
extends FilterInputStream

监视读取某些 InputStream 的进度。大致用以下形式调用此 ProgressMonitor：

 InputStream in = new BufferedInputStream(
                          new ProgressMonitorInputStream(
                                  parentComponent,
                                  "Reading " + fileName,
                                  new FileInputStream(fileName)));

这可以创建一个进度监视器，以监视读取输入流的进度。如果需要一段时间，将会弹出 ProgressDialog，以通知用户。如果用户单击 Cancel 按钮，则在进行下一次读取操作时会抛出 InterruptedIOException。当关闭流时，会执行所有的正确清除。

有关此内容的更多文档和示例，请参阅 The Java Tutorial 中的 How to Monitor Progress 一节。

另请参见：
ProgressMonitor, JOptionPane

字段摘要
从类 java.io.FilterInputStream 继承的字段
in
构造方法摘要
ProgressMonitorInputStream(Component parentComponent, Object message, InputStream in)
构造一个对象，以监视输入流的进度。
方法摘要
void | close() 重写 FilterInputStream.close，以便关闭进度监视器以及流。
ProgressMonitor | getProgressMonitor() 获取此流使用的 ProgressMonitor 对象。
int | read() 重写 FilterInputStream.read，以便在读取之后更新进度监视器。
int | read(byte[] b) 重写 FilterInputStream.read，以读取之后更新进度监视器。
int | read(byte[] b, int off, int len) 重写 FilterInputStream.read，以便在读取之后更新进度监视器。
void | reset() 重写 FilterInputStream.reset，以重置进度监视器以及流。
long | skip(long n) 重写 FilterInputStream.skip，以便在跳过之后更新进度监视器。
从类 java.io.FilterInputStream 继承的方法
available, mark, markSupported
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ProgressMonitorInputStream

public ProgressMonitorInputStream(Component parentComponent,
                                  Object message,
                                  InputStream in)
构造一个对象，以监视输入流的进度。

参数：
message - 要在对话框（如果弹出）中放置的描述性文本。
parentComponent - 触发被监视操作的组件。
in - 要监视的输入流。
方法详细信息

getProgressMonitor

public ProgressMonitor getProgressMonitor()
获取此流使用的 ProgressMonitor 对象。通常不需要上述操作，除非您要通过读取文件执行一些中途更改描述性文本的操作。

返回：
此对象使用的 ProgressMonitor 对象

read

public int read()
         throws IOException
重写 FilterInputStream.read，以便在读取之后更新进度监视器。

覆盖：
类 FilterInputStream 中的 read
返回：
下一个数据字节；如果已到达流末尾，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in

read

public int read(byte[] b)
         throws IOException
重写 FilterInputStream.read，以读取之后更新进度监视器。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
返回：
读入缓冲区的字节总数，如果因为已经到达流末尾而没有更多的数据，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.read(byte[], int, int)

read

public int read(byte[] b,
                int off,
                int len)
         throws IOException
重写 FilterInputStream.read，以便在读取之后更新进度监视器。

覆盖：
类 FilterInputStream 中的 read
参数：
b - 存储读取数据的缓冲区。
off - 目标数组 b 中的起始偏移量。
len - 读取的最大字节数。
返回：
读入缓冲区的字节总数，如果因为已经到达流末尾而没有更多的数据，则返回 -1。
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in

skip

public long skip(long n)
          throws IOException
重写 FilterInputStream.skip，以便在跳过之后更新进度监视器。

覆盖：
类 FilterInputStream 中的 skip
参数：
n - 要跳过的字节数。
返回：
跳过的实际字节数。
抛出：
IOException - 如果流不支持搜索，或者发生其他 I/O 错误。

close

public void close()
           throws IOException
重写 FilterInputStream.close，以便关闭进度监视器以及流。

指定者：
接口 Closeable 中的 close
覆盖：
类 FilterInputStream 中的 close
抛出：
IOException - 如果发生 I/O 错误。
另请参见：
FilterInputStream.in

reset

public void reset()
           throws IOException
重写 FilterInputStream.reset，以重置进度监视器以及流。

覆盖：
类 FilterInputStream 中的 reset
抛出：
IOException - 如果已经标记了该流，或者标记已经无效。
另请参见：
FilterInputStream.in, FilterInputStream.mark(int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Renderer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 Renderer

public interface Renderer

为负责“呈现”（显示）值的对象定义需求。

方法摘要
Component | getComponent() 返回用于呈现该值的组件。
void | setValue(Object aValue, boolean isSelected) 指定要显示的值和是否应将该值描绘为“当前选定”。

方法详细信息

setValue

void setValue(Object aValue,
              boolean isSelected)
指定要显示的值和是否应将该值描绘为“当前选定”。

参数：
aValue - Object 对象
isSelected - 布尔值

getComponent

Component getComponent()
返回用于呈现该值的组件。

返回：
负责显示该值的组件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RepaintManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 RepaintManager

java.lang.Object
    继承者  javax.swing.RepaintManager

public class RepaintManager
extends Object

此类管理重绘请求，以最大限度地降低重绘次数。例如，通过将多个请求折叠到对组件树成员的单个重绘中。

从 1.6 开始，RepaintManager 处理对 Swing 的顶层组件（JApplet、JWindow、JFrame 和 JDialog）的重绘请求。在这些组件之一上对 repaint 的任何调用将生成适当的 addDirtyRegion 方法。

构造方法摘要
RepaintManager()
创建新的 RepaintManager 实例。
方法摘要
void | addDirtyRegion(Applet applet, int x, int y, int w, int h) 将 applet 添加到需要重绘的 Component 列表。
void | addDirtyRegion(JComponent c, int x, int y, int w, int h) 在应刷新的组件列表中添加组件。
void | addDirtyRegion(Window window, int x, int y, int w, int h) 将 window 添加到需要重绘的 Component 列表。
void | addInvalidComponent(JComponent invalidComponent) 按照布局需要标记组件，并将事件指派线程的 runnable 排入队列，该线程将验证组件的第一个 isValidateRoot() 祖先。
static RepaintManager | currentManager(Component c) 在给定 Component 的情况下，返回调用线程的 RepaintManager。
static RepaintManager | currentManager(JComponent c) 在给定 JComponent 的情况下，返回调用线程的 RepaintManager。
Rectangle | getDirtyRegion(JComponent aComponent) 返回组件的当前脏区。
Dimension | getDoubleBufferMaximumSize() 返回最大双缓冲区大小。
Image | getOffscreenBuffer(Component c, int proposedWidth, int proposedHeight) 返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。
Image | getVolatileOffscreenBuffer(Component c, int proposedWidth, int proposedHeight) 返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。
boolean | isCompletelyDirty(JComponent aComponent) 在下一个 paintDirtyRegions() 中全部绘制 aComponent 时返回 true 的便捷方法。
boolean | isDoubleBufferingEnabled() 如果此 RepaintManager 被双缓冲，则返回 true。
void | markCompletelyClean(JComponent aComponent) 标记完全干净的组件。
void | markCompletelyDirty(JComponent aComponent) 标记完全弄脏的组件。
void | paintDirtyRegions() 绘制被标记为脏的所有组件。
void | removeInvalidComponent(JComponent component) 从无效组件的列表移除组件。
static void | setCurrentManager(RepaintManager aRepaintManager) 设置用于调用线程的 RepaintManager。
void | setDoubleBufferingEnabled(boolean aFlag) 在此 RepaintManager 中，启用或禁用双缓冲。
void | setDoubleBufferMaximumSize(Dimension d) 设置最大双缓冲区大小。
String | toString() 返回一个显示并标记此对象属性的字符串。
void | validateInvalidComponents() 验证被标记为无效的所有组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RepaintManager

public RepaintManager()
创建新的 RepaintManager 实例。很少直接调用此构造方法。要获取默认 RepaintManager，请使用 RepaintManager.currentManager(JComponent)（通常为 "this"）。

方法详细信息

currentManager

public static RepaintManager currentManager(Component c)
在给定 Component 的情况下，返回调用线程的 RepaintManager。

参数：
c - 在默认实现中未使用的 Component，但是重写版本可以使用它，以根据 Component 返回不同的 RepaintManager
返回：
RepaintManager 对象

currentManager

public static RepaintManager currentManager(JComponent c)
在给定 JComponent 的情况下，返回调用线程的 RepaintManager。

注：此方法用于与 Swing 库早期版本的向后二进制兼容性。它只返回 currentManager(Component) 返回的结果。

参数：
c - 未使用的 JComponent
返回：
RepaintManager 对象

setCurrentManager

public static void setCurrentManager(RepaintManager aRepaintManager)
设置用于调用线程的 RepaintManager。aRepaintManager 将成为调用线程的线程组的当前 RepaintManager。

参数：
aRepaintManager - 要使用的 RepaintManager 对象

addInvalidComponent

public void addInvalidComponent(JComponent invalidComponent)
按照布局需要标记组件，并将事件指派线程的 runnable 排入队列，该线程将验证组件的第一个 isValidateRoot() 祖先。

另请参见：
JComponent.isValidateRoot(), removeInvalidComponent(javax.swing.JComponent)

removeInvalidComponent

public void removeInvalidComponent(JComponent component)
从无效组件的列表移除组件。

另请参见：
addInvalidComponent(javax.swing.JComponent)

addDirtyRegion

public void addDirtyRegion(JComponent c,
                           int x,
                           int y,
                           int w,
                           int h)
在应刷新的组件列表中添加组件。如果 c 已有脏区 (dirty region)，则矩形 (x,y,w,h) 将与应重绘的区域合并。

参数：
c - 要重绘的组件，null 不执行任何操作。
x - 要重绘区域的 X 坐标
y - 要重绘区域的 Y 坐标
w - 要重绘区域的宽度
h - 要重绘区域的高度
另请参见：
JComponent.repaint(long, int, int, int, int)

addDirtyRegion

public void addDirtyRegion(Window window,
                           int x,
                           int y,
                           int w,
                           int h)
将 window 添加到需要重绘的 Component 列表。

参数：
window - 要重绘的窗口，null 不执行任何操作。
x - 要重绘区域的 X 坐标
y - 要重绘区域的 Y 坐标
w - 要重绘区域的宽度
h - 要重绘区域的高度
从以下版本开始：
1.6
另请参见：
JFrame.repaint(long, int, int, int, int),
JWindow.repaint(long, int, int, int, int),
JDialog.repaint(long, int, int, int, int)

addDirtyRegion

public void addDirtyRegion(Applet applet,
                           int x,
                           int y,
                           int w,
                           int h)
将 applet 添加到需要重绘的 Component 列表。

参数：
applet - 要重绘的 Applet，null 不执行任何操作。
x - 要重绘区域的 X 坐标
y - 要重绘区域的 Y 坐标
w - 要重绘区域的宽度
h - 要重绘区域的高度
从以下版本开始：
1.6
另请参见：
JApplet.repaint(long, int, int, int, int)

getDirtyRegion

public Rectangle getDirtyRegion(JComponent aComponent)
返回组件的当前脏区。如果组件不脏，则返回空矩形。

markCompletelyDirty

public void markCompletelyDirty(JComponent aComponent)
标记完全弄脏的组件。在下一个 paintDirtyRegions() 调用中，将全部绘制 aComponent。

markCompletelyClean

public void markCompletelyClean(JComponent aComponent)
标记完全干净的组件。在下一个 paintDirtyRegions() 调用中，将不绘制 aComponent。

isCompletelyDirty

public boolean isCompletelyDirty(JComponent aComponent)
在下一个 paintDirtyRegions() 中全部绘制 aComponent 时返回 true 的便捷方法。如果计算脏区对组件开销很大，请使用此方法，避免在其返回 true 时计算脏区。

validateInvalidComponents

public void validateInvalidComponents()
验证被标记为无效的所有组件。

另请参见：
addInvalidComponent(javax.swing.JComponent)

paintDirtyRegions

public void paintDirtyRegions()
绘制被标记为脏的所有组件。

另请参见：
addDirtyRegion(javax.swing.JComponent, int, int, int, int)

toString

public String toString()
返回一个显示并标记此对象属性的字符串。

覆盖：
类 Object 中的 toString
返回：
此对象的字符串表示形式

getOffscreenBuffer

public Image getOffscreenBuffer(Component c,
                                int proposedWidth,
                                int proposedHeight)
返回屏幕外缓冲区，它应用作带有组件 c 的双缓冲区。默认情况下，每个 RepaintManager 都有一个双缓冲。该缓冲可能比 (proposedWidth,proposedHeight) 小，当最大双缓冲区的大小已设置为用于接收重绘管理器时，会发生这种情况。

getVolatileOffscreenBuffer

public Image getVolatileOffscreenBuffer(Component c,
                                        int proposedWidth,
                                        int proposedHeight)
返回可变屏幕外缓冲区，它应用作带有指定组件 c 的双缓冲区。返回的图像将是 VolatileImage 的实例，如果 VolatileImage 对象无法实例化，则为 null。此缓冲区可能小于 (proposedWidth,proposedHeight)。当最大双缓冲区的大小已设置为用于接收重绘管理器时，会发生这种情况。

从以下版本开始：
1.4
另请参见：
VolatileImage

setDoubleBufferMaximumSize

public void setDoubleBufferMaximumSize(Dimension d)
设置最大双缓冲区大小。

getDoubleBufferMaximumSize

public Dimension getDoubleBufferMaximumSize()
返回最大双缓冲区大小。

返回：
表示最大大小的 Dimension 对象

setDoubleBufferingEnabled

public void setDoubleBufferingEnabled(boolean aFlag)
在此 RepaintManager 中，启用或禁用双缓冲。小心：设置此属性的默认值可获得给定平台上的最佳绘制性能，不建议程序直接修改此属性。

参数：
aFlag - 如果激活双缓冲，则为 true
另请参见：
isDoubleBufferingEnabled()

isDoubleBufferingEnabled

public boolean isDoubleBufferingEnabled()
如果此 RepaintManager 被双缓冲，则返回 true。此属性的默认值可以随平台的改变而改变。在 AWT 中支持本机双缓冲的平台上，默认值为 false，以避免 Swing 中不必要的缓冲。在不支持本机双缓冲的平台上，默认值为 true。

返回：
如果此对象被双缓冲，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RootPaneContainer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 RootPaneContainer

所有已知实现类：
JApplet, JDialog, JFrame, JInternalFrame, JWindow
public interface RootPaneContainer

此接口由具有单个 JRootPane 子组件的组件来实现，这些子组件包括：JDialog、JFrame、JWindow、JApplet、JInternalFrame。此接口中的方法仅为 JRootPane 属性的封面 (covers)，例如，getContentPane() 通常按以下方法实现：

     public Container getContentPane() {
         return getRootPane().getContentPane();
     }
此接口用作 Swing GUI 生成器的标记 (marker)，这些生成器需要处理 JFrame 之类的组件，特别是包含单个 JRootPane 的组件。例如，在 GUI 生成器中，删除 RootPaneContainer 上的组件将被解释为 frame.getContentPane().add(child)。

为了便于使用 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame，默认情况下，将 add、remove 和 setLayout 方法的所有调用转发到 contentPane。这意味着您可以调用：

 rootPaneContainer.add(component);
而不是：
 rootPaneContainer.getContentPane().add(component);

rootPaneCheckingEnabled 属性控制 JFrame、JDialog、 JWindow、JApplet 和 JInternalFrame 的 add 和 setLayout 方法的行为。如果此属性为 true（默认值），则将这些方法的调用转发到 contentPane；如果为 false，则这些方法直接在 RootPaneContainer 上操作。此属性仅用于子类，因此是受保护的。

另请参见：
JRootPane, JFrame, JDialog, JWindow, JApplet, JInternalFrame

方法摘要
Container | getContentPane() 返回 contentPane。
Component | getGlassPane() 返回 glassPane。
JLayeredPane | getLayeredPane() 返回 layeredPane。
JRootPane | getRootPane() 返回此组件的单个 JRootPane 子组件。
void | setContentPane(Container contentPane) "contentPane" 是应用程序特定组件的主要容器。
void | setGlassPane(Component glassPane) glassPane 始终为 rootPane 的第一个子组件，rootPanes 布局管理器确保它始终与 rootPane 一样大。
void | setLayeredPane(JLayeredPane layeredPane) 管理 contentPane 的 Container，在某些情况下为菜单栏。

方法详细信息

getRootPane

JRootPane getRootPane()
返回此组件的单个 JRootPane 子组件。此接口的传统实现间接通过此接口获得所有其他方法。rootPane 有两个子组件：glassPane 和 layeredPane。

返回：
此组件的单个 JRootPane 子组件。
另请参见：
JRootPane

setContentPane

void setContentPane(Container contentPane)
"contentPane" 是应用程序特定组件的主要容器。应用程序应将子组件添加到 contentPane，设置它的布局管理器，等等。

contentPane 不能为 null。

通常使用 getRootPane().setContentPane(contentPane); 实现

参数：
contentPane - 用于此 JRootPane 内容的 Container
抛出：
IllegalComponentStateException - （运行时异常）如果内容窗格参数为 null
另请参见：
JRootPane.getContentPane(), getContentPane()

getContentPane

Container getContentPane()
返回 contentPane。

返回：
contentPane 属性的值。
另请参见：
setContentPane(java.awt.Container)

setLayeredPane

void setLayeredPane(JLayeredPane layeredPane)
管理 contentPane 的 Container，在某些情况下为菜单栏。希望将子组件添加到不归布局管理的 RootPaneContainer 的后代可以使用 layeredPane。例如，内部对话框或拖放效果组件。

layeredPane 不能为 null。

通常使用以下方法实现

    getRootPane().setLayeredPane(layeredPane);

抛出：
IllegalComponentStateException - （一个运行时异常）如果分层窗格参数为 null
另请参见：
getLayeredPane(), JRootPane.getLayeredPane()

getLayeredPane

JLayeredPane getLayeredPane()
返回 layeredPane。

返回：
layeredPane 属性的值。
另请参见：
setLayeredPane(javax.swing.JLayeredPane)

setGlassPane

void setGlassPane(Component glassPane)
glassPane 始终为 rootPane 的第一个子组件，rootPanes 布局管理器确保它始终与 rootPane 一样大。默认情况下，它是透明的，不可见。通过添加侦听器并使它变得可见，可以将它用于临时捕获所有的键盘和鼠标输入。默认情况下，它不可见。

glassPane 不能为 null。

通常使用以下方法实现 getRootPane().setGlassPane(glassPane);

另请参见：
getGlassPane(), JRootPane.setGlassPane(java.awt.Component)

getGlassPane

Component getGlassPane()
返回 glassPane。

返回：
glassPane 属性的值。
另请参见：
setGlassPane(java.awt.Component)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 RowFilter<M,I>

java.lang.Object
    继承者  javax.swing.RowFilter<M,I>
类型参数：
M - 模型的类型；例如 PersonModel
I - 标识符的类型；使用 TableRowSorter 时，此类型将是 Integer
public abstract class RowFilter<M,I>
extends Object

RowFilter 用于从模型中过滤条目，使得这些条目不会在视图中显示。例如，一个与 JTable 关联的 RowFilter 可能只允许包含带指定字符串的列的那些行。条目 的含义取决于组件类型。例如，当过滤器与 JTable 关联时，一个条目对应于一行；当过滤器与 JTree 关联时，一个条目对应于一个节点。

子类必须重写 include 方法指示是否应该在视图中显示该条目。Entry 参数可用于获取该条目中每一列的值。下例显示了一个 include 方法，该方法只允许包含以字符串“a”开头的一个或多个值的条目。

RowFilter<Object,Object> startsWithAFilter = new RowFilter<Object,Object>() {
public boolean include(Entry<? extends Object, ? extends Object> entry) {
for (int i = entry.getValueCount() - 1; i >= 0; i--) {
if (entry.getStringValue(i).startsWith("a")) {
// The value starts with "a", include it
return true;
       }
     }
// None of the columns start with "a"; return false so that this
// entry is not shown
return false;
   }
 };
RowFilter 有两个形式类型参数，可用来为特定模型创建 RowFilter。例如，以下代码假定一个包装 Person 类型对象的特定模型。只显示年龄大于 20 的 Person：
RowFilter<PersonModel,Integer> ageFilter = new RowFilter<PersonModel,Integer>() {
public boolean include(Entry<? extends PersonModel, ? extends Integer> entry) {
PersonModel personModel = entry.getModel();
Person person = personModel.getPerson(entry.getIdentifier());
if (person.getAge() > 20) {
// Returning true indicates this row should be shown.
return true;
     }
// Age is <= 20, don't show it.
return false;
   }
 };
PersonModel model = createPersonModel();
TableRowSorter<PersonModel> sorter = new TableRowSorter<PersonModel>(model);
sorter.setRowFilter(ageFilter);

从以下版本开始：
1.6
另请参见：
TableRowSorter

嵌套类摘要
static class | RowFilter.ComparisonType 由某些默认 RowFilter 支持的可能比较值的枚举。
static class | RowFilter.Entry<M,I> 一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。
构造方法摘要
RowFilter()
方法摘要
static
<M,I> RowFilter<M,I>
andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
dateFilter(RowFilter.ComparisonType type, Date date, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。
abstract  boolean include(RowFilter.Entry<? extends M,? extends I> entry)
如果应该显示指定的条目，则返回 true；如果应该隐藏该条目，则返回 false。
static
<M,I> RowFilter<M,I>
notFilter(RowFilter<M,I> filter)
返回一个 RowFilter，它包含提供的过滤器不包含的条目。
static
<M,I> RowFilter<M,I>
numberFilter(RowFilter.ComparisonType type, Number number, int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。
static
<M,I> RowFilter<M,I>
orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。
static
<M,I> RowFilter<M,I>
regexFilter(String regex, int... indices)
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RowFilter

public RowFilter()
方法详细信息

regexFilter

public static <M,I> RowFilter<M,I> regexFilter(String regex,
                                               int... indices)
返回一个 RowFilter，它使用正则表达式确定要包含哪些条目。只包含至少有一个匹配值的条目。例如，以下代码创建了一个 RowFilter，它包含其值至少有一个以“a”开头的条目。
RowFilter.regexFilter("^a");

返回的过滤器使用 Matcher.find() 对包含进行测试。若要测试完全匹配，可分别使用字符 '^' 和 '$' 来匹配该字符串的开头和结尾。例如，“^foo$”只包含其字符串完全为“foo”的行，而不是“food”之类。有关受支持的正则表达式结构的完整描述，请参阅 Pattern。

参数：
regex - 在其上进行过滤的正则表达式
indices - 要检查的值的索引如果没有提供，则计算所有的值
返回：
一个实现指定标准的 RowFilter
抛出：
NullPointerException - 如果 regex 为 null
IllegalArgumentException - 如果任一 indices 值小于 0
PatternSyntaxException - 如果 regex 不是有效的正则表达式
另请参见：
Pattern

dateFilter

public static <M,I> RowFilter<M,I> dateFilter(RowFilter.ComparisonType type,
                                              Date date,
                                              int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Date 值的条目。例如，下面的 RowFilter 只包含至少具有一个当前日期之后的日期值的条目：
RowFilter.dateFilter(ComparisonType.AFTER, new Date());

参数：
type - 要执行的比较类型
date - 要比较的日期
indices - 要检查的值的索引。如果没有提供，则计算所有的值
返回：
一个实现指定标准的 RowFilter
抛出：
NullPointerException - 如果 date 为 null
IllegalArgumentException - 如果任一 indices 值小于 0 或 type 为 null
另请参见：
Calendar, Date

numberFilter

public static <M,I> RowFilter<M,I> numberFilter(RowFilter.ComparisonType type,
                                                Number number,
                                                int... indices)
返回一个 RowFilter，它包含至少具有一个符合指定标准的 Number 值的条目。例如，下面的过滤器将只包含至少具有一个等于 10 的数值的条目：
RowFilter.numberFilter(ComparisonType.EQUAL, 10);

参数：
type - 要执行的比较类型
indices - 要检查的值的索引。如果没有提供，则计算所有值
返回：
一个实现指定标准的 RowFilter
抛出：
IllegalArgumentException - 如果任一 indices 值小于 0，type 为 null 或者 number 为 null

orFilter

public static <M,I> RowFilter<M,I> orFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。

下例创建了一个 RowFilter，它将包括所有包含字符串“foo”或字符串“bar”的条目：

List<RowFilter<Object,Object>> filters = new ArrayList<RowFilter<Object,Object>>(2);
filters.add(RowFilter.regexFilter("foo"));
filters.add(RowFilter.regexFilter("bar"));
RowFilter<Object,Object> fooBarFilter = RowFilter.orFilter(filters);

参数：
filters - 要测试的 RowFilter
返回：
一个实现指定标准的 RowFilter
抛出：
IllegalArgumentException - 如果任一过滤器为 null
NullPointerException - 如果 filters 为 null
另请参见：
Arrays.asList(T...)

andFilter

public static <M,I> RowFilter<M,I> andFilter(Iterable<? extends RowFilter<? super M,? super I>> filters)
返回一个 RowFilter，它包含所有提供的过滤器所包含的条目。

下例创建了一个 RowFilter，它将包括所有包含字符串“foo”和字符串“bar”的条目：

List<RowFilter<Object,Object>> filters = new ArrayList<RowFilter<Object,Object>>(2);
filters.add(RowFilter.regexFilter("foo"));
filters.add(RowFilter.regexFilter("bar"));
RowFilter<Object,Object> fooBarFilter = RowFilter.andFilter(filters);

参数：
filters - 要测试的 RowFilter
返回：
一个实现指定标准的 RowFilter
抛出：
IllegalArgumentException - 如果任一过滤器为 null
NullPointerException - 如果 filters 为 null
另请参见：
Arrays.asList(T...)

notFilter

public static <M,I> RowFilter<M,I> notFilter(RowFilter<M,I> filter)
返回一个 RowFilter，它包含提供的过滤器不包含的条目。

参数：
filter - 要求反 (negate) 的 RowFilter
返回：
一个实现指定标准的 RowFilter
抛出：
IllegalArgumentException - 如果 filter 为 null

include

public abstract boolean include(RowFilter.Entry<? extends M,? extends I> entry)
如果应该显示指定的条目，则返回 true；如果应该隐藏该条目，则返回 false。

entry 参数只在调用期间有效。在调用返回之后使用 entry 将导致不确定的行为。

参数：
entry - 一个非 null 对象，它包装取自模型的底层对象
返回：
如果应该显示该条目，则返回 true
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowFilter.ComparisonType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing
枚举 RowFilter.ComparisonType

java.lang.Object
    继承者  java.lang.Enum<RowFilter.ComparisonType>
        继承者  javax.swing.RowFilter.ComparisonType
所有已实现的接口：
Serializable, Comparable<RowFilter.ComparisonType>
正在封闭类：
RowFilter<M,I>
public static enum RowFilter.ComparisonType
extends Enum<RowFilter.ComparisonType>

由某些默认 RowFilter 支持的可能比较值的枚举。

从以下版本开始：
1.6
另请参见：
RowFilter

枚举常量摘要
AFTER
指示应该包含带有所提供值之后的值的条目。
BEFORE
指示应该包含带有所提供值之前的值的条目。
EQUAL
指示应该包含带有与所提供值相等的值的条目。
NOT_EQUAL
指示应该包含带有与所提供值不相等的值的条目。
方法摘要
static RowFilter.ComparisonType | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowFilter.ComparisonType[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

BEFORE

public static final RowFilter.ComparisonType BEFORE
指示应该包含带有所提供值之前的值的条目。

AFTER

public static final RowFilter.ComparisonType AFTER
指示应该包含带有所提供值之后的值的条目。

EQUAL

public static final RowFilter.ComparisonType EQUAL
指示应该包含带有与所提供值相等的值的条目。

NOT_EQUAL

public static final RowFilter.ComparisonType NOT_EQUAL
指示应该包含带有与所提供值不相等的值的条目。

方法详细信息

values

public static final RowFilter.ComparisonType[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(RowFilter.ComparisonType c : RowFilter.ComparisonType.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static RowFilter.ComparisonType valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


RowFilter.Entry (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 RowFilter.Entry<M,I>

java.lang.Object
    继承者  javax.swing.RowFilter.Entry<M,I>
类型参数：
M - 模型的类型；例如 PersonModel
I - 标识符的类型；使用 TableRowSorter 时，此类型为 Integer
正在封闭类：
RowFilter<M,I>
public abstract static class RowFilter.Entry<M,I>
extends Object

一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。Entry 对象包含有关模型的信息以及从模型中获取底层值的方法。

从以下版本开始：
1.6
另请参见：
RowFilter, DefaultRowSorter.setRowFilter(javax.swing.RowFilter)

构造方法摘要
RowFilter.Entry()
创建一个 Entry。
方法摘要
abstract I | getIdentifier() 返回条目的标识符（在模型中）。
abstract M | getModel() 返回底层模型。
String | getStringValue(int index) 返回指定索引处的字符串值。
abstract Object | getValue(int index) 返回指定索引处的值。
abstract int | getValueCount() 返回条目中值的数量。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RowFilter.Entry

public RowFilter.Entry()
创建一个 Entry。

方法详细信息

getModel

public abstract M getModel()
返回底层模型。

返回：
包含此条目所表示数据的模型

getValueCount

public abstract int getValueCount()
返回条目中值的数量。例如，当用于表时，此值对应于列的数量。

返回：
要过滤的对象中值的数量

getValue

public abstract Object getValue(int index)
返回指定索引处的值。此方法可以返回 null。当用于表时，索引对应于模型中的列号。

参数：
index - 要获取的值的索引
返回：
指定索引处的值
抛出：
IndexOutOfBoundsException - 如果索引小于 0 或大于等于 getValueCount

getStringValue

public String getStringValue(int index)
返回指定索引处的字符串值。如果基于 String 值进行过滤操作，则首选此方法而不是使用 getValue，因为 getValue(index).toString() 返回的结果可能与 getStringValue(index) 不同。

此实现检查有无 null 值后调用 getValue(index).toString()。如有必要，提供不同字符串转换的子类应该重写此方法。

参数：
index - 要获取的值的索引
返回：
指定索引处的非 null 字符串
抛出：
IndexOutOfBoundsException - 如果索引小于 0 或大于等于 getValueCount

getIdentifier

public abstract I getIdentifier()
返回条目的标识符（在模型中）。对于表，此值对应于模式中的行索引，以 Integer 形式表示。

返回：
此条目基于模型的（而非基于视图）标识符
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSorter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 RowSorter<M>

java.lang.Object
    继承者  javax.swing.RowSorter<M>
类型参数：
M - 底层模型的类型
直接已知子类：
DefaultRowSorter
public abstract class RowSorter<M>
extends Object

RowSorter 提供排序和过滤的基础。创建和安装了 RowSorter 之后，您几乎不需要直接与它交互。有关 JTable 的 RowSorter 具体实现，请参阅 TableRowSorter。

RowSorter 的主要功能在于，提供两个坐标系统之间的映射关系：视图的映射关系（例如 JTable）和底层数据源（通常是模型）的映射关系。

视图调用 RowSorter 的以下方法：

  • toggleSortOrder — 当发生了触发排序操作的恰当用户行为时，视图调用此方法。例如，用户在表中单击列标题时。
  • 其中一个模型更改方法 — 当底层模型发生了更改时，视图调用一个模型更改方法。由于在如何交付事件方面可能存在顺序依赖关系，因此在调用这些方法之一之前 RowSorter 不应该更新其映射关系。
因为视图大量使用了 convertRowIndexToModel、convertRowIndexToView 和 getViewRowCount 方法，所以这些方法需要很快的运行快速。

RowSorter 通过 RowSorterListener 提供更改的通知。它发送两种类型的通知：

  • RowSorterEvent.Type.SORT_ORDER_CHANGED — 通知侦听器排序顺序发生了更改。此通知通常后跟一个通知，表示排序发生了更改。
  • RowSorterEvent.Type.SORTED — 通知侦听器由 RowSorter 维护的映射关系已经以某种方式发生了更改。
RowSorter 实现与底层模型通常没有一对一的映射关系，但它们也可以这样做。例如，如果数据库进行排序操作，则可以通过数据库调用 toggleSortOrder （在后台线程上），并重写映射方法以返回传入的参数。

RowSorter 的具体实现需要引用一个模型，比如 TableModel 或 ListModel。JTable 和 JList 之类的视图类也将引用该模型。要避免排序依赖关系，RowSorter 实现不应该在模型上安装侦听器。而是在模型更改时，视图类调用 RowSorter。例如，如果在 TableModel 中更新了一行，则 JTable 调用 rowsUpdated。模型更改时，视图可以调用任意以下方法：modelStructureChanged、allRowsChanged、rowsInserted、rowsDeleted 和 rowsUpdated。

从以下版本开始：
1.6
另请参见：
TableRowSorter

嵌套类摘要
static class RowSorter.SortKey
SortKey 描述特定列的排序顺序。
构造方法摘要
RowSorter()
创建一个RowSorter。
方法摘要
void | addRowSorterListener(RowSorterListener l) 添加一个 RowSorterListener 来接收有关此 RowSorter 的通知。
abstract void | allRowsChanged() 当底层模型的内容完全更改时，调用此方法。
abstract int | convertRowIndexToModel(int index) 返回基于底层模型的 index 的位置。
abstract int | convertRowIndexToView(int index) 返回基于视图 index 的位置。
protected void | fireRowSorterChanged(int[] lastRowIndexToModel) 通知侦听器映射关系发生了更改。
protected void | fireSortOrderChanged() 通知侦听器排序顺序发生了更改。
abstract M | getModel() 返回底层模型。
abstract int | getModelRowCount() 返回底层模型中的行数。
abstract List<? extends RowSorter.SortKey> | getSortKeys() 返回当前排序键。
abstract int | getViewRowCount() 返回视图中的行数。
abstract void | modelStructureChanged() 当底层模型结构完全更改时，调用此方法。
void | removeRowSorterListener(RowSorterListener l) 移除一个 RowSorterListener。
abstract void | rowsDeleted(int firstRow, int endRow) 当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。
abstract void | rowsInserted(int firstRow, int endRow) 当行已经插入到指定范围（包括）内的底层模型时，调用此方法。
abstract void | rowsUpdated(int firstRow, int endRow) 当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。
abstract void | rowsUpdated(int firstRow, int endRow, int column) 当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。
abstract void | setSortKeys(List<? extends RowSorter.SortKey> keys) 设置当前排序键。
abstract void | toggleSortOrder(int column) 颠倒指定列的排序顺序。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RowSorter

public RowSorter()
创建一个RowSorter。

方法详细信息

getModel

public abstract M getModel()
返回底层模型。

返回：
底层模型

toggleSortOrder

public abstract void toggleSortOrder(int column)
颠倒指定列的排序顺序。调用此方法时，由子类提供具体行为。通常，如果指定列已经是主要排序列，则此方法将升序变为降序（或将降序变为升序）；否则，使指定列成为主要排序列，并使用升序排序顺序。如果指定列不可排序，则此方法没有任何效果。

如果此方法导致更改排序顺序和排序操作，则它将发送适当的 RowSorterListener 通知。

参数：
column - 要切换排序顺序的列，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果列超出底层模型的范围

convertRowIndexToModel

public abstract int convertRowIndexToModel(int index)
返回基于底层模型的 index 的位置。也就是说，对于视图坐标中的行 index，此方法返回基于底层模型的行索引。

参数：
index - 基于底层视图的行索引
返回：
基于视图的行索引
抛出：
IndexOutOfBoundsException - 如果 index 超出视图的范围

convertRowIndexToView

public abstract int convertRowIndexToView(int index)
返回基于视图 index 的位置。也就是说，对于底层模型坐标中的行 index，此方法返回基于视图的行索引。

参数：
index - 基于底层模型的行索引
返回：
返回基于视图的行索引；如果索引已经被过滤出视图，则返回 -1
抛出：
IndexOutOfBoundsException - 如果 index 超出模型的范围

setSortKeys

public abstract void setSortKeys(List<? extends RowSorter.SortKey> keys)
设置当前排序键。

参数：
keys - 新的 SortKeys；null 是指定一个空列表的简写，表示视图应该是未排序的。

getSortKeys

public abstract List<? extends RowSorter.SortKey> getSortKeys()
返回当前排序键。此方法必须返回一个非 null List，可以返回一个无法修改的 List。如果需要更改排序键，可创建所返回 List 的一个副本，更改该副本并使用新列表调用 setSortKeys。

返回：
当前排序顺序

getViewRowCount

public abstract int getViewRowCount()
返回视图中的行数。如果该内容已被过滤，则此值可能不同于底层模型的行数。

返回：
视图中的行数
另请参见：
getModelRowCount()

getModelRowCount

public abstract int getModelRowCount()
返回底层模型中的行数。

返回：
底层模型中的行数
另请参见：
getViewRowCount()

modelStructureChanged

public abstract void modelStructureChanged()
当底层模型结构完全更改时，调用此方法。例如，如果 TableModel 中的列数发生了更改，则此方法将被调用。

通常不调用此方法。此方法是公共的，允许视图类调用它。

allRowsChanged

public abstract void allRowsChanged()
当底层模型的内容完全更改时，调用此方法。表的结构相同，只有内容发生了更改。当对于其他方法来说标记此更改的代价太过昂贵时，通常使用此方法。

通常不调用此方法。此方法是公共的，允许视图类调用它。

rowsInserted

public abstract void rowsInserted(int firstRow,
                                  int endRow)
当行已经插入到指定范围（包括）内的底层模型时，调用此方法。

参数指定有效范围的索引。第一个参数是基于更改之前的模型的，必须小于等于更改之前的模型的大小。第二个参数是基于更改之后的模型的，必须小于更改之后的模型的大小。例如，如果有一个 5 行的模型并在该模型的尾部添加 3 个项，则其索引为 5、7。

通常不调用此方法。此方法是公共的，允许视图类调用它。

参数：
firstRow - 第一行
endRow - 最后一行
抛出：
IndexOutOfBoundsException - 如果任一参数无效，或者 firstRow > endRow

rowsDeleted

public abstract void rowsDeleted(int firstRow,
                                 int endRow)
当行已经从指定范围（包括）内的底层模型中被删除时，调用此方法。

参数指定有效范围的索引，其基于更改之前的模型。例如，如果有一个 5 行的模型并从模型的尾部删除 3 个项，则其索引为 2、4。

通常不调用此方法。此方法是公共的，允许视图类调用它。

参数：
firstRow - 第一行
endRow - 最后一行
抛出：
IndexOutOfBoundsException - 如果任一参数超出模型更改之前的范围，或者 firstRow > endRow

rowsUpdated

public abstract void rowsUpdated(int firstRow,
                                 int endRow)
当行已经在指定范围（包括）内的底层模型中被更改时，调用此方法。

通常不调用此方法。此方法是公共的，允许视图类调用它。

参数：
firstRow - 第一行，就底层模型而言
endRow - 最后一行，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果任一参数超出模型更改之前的范围，或者 firstRow > endRow

rowsUpdated

public abstract void rowsUpdated(int firstRow,
                                 int endRow,
                                 int column)
当行中的列已经在指定范围内的底层模型中被更新时，调用此方法。

通常不调用此方法。此方法是公共的，允许视图类调用它。

参数：
firstRow - 第一行，就底层模型而言
endRow - 最后一行，就底层模型而言
column - 已更改的列，就底层模型而言
抛出：
IndexOutOfBoundsException - 如果任一参数超出底层模型更改之后的范围，firstRow > endRow 或者 column 超出底层模型的范围

addRowSorterListener

public void addRowSorterListener(RowSorterListener l)
添加一个 RowSorterListener 来接收有关此 RowSorter 的通知。如果多次添加相同的侦听器，则它将接收多个通知。如果 l 为 null，则不执行任何操作。

参数：
l - RowSorterListener

removeRowSorterListener

public void removeRowSorterListener(RowSorterListener l)
移除一个 RowSorterListener。如果 l 为 null，则不执行任何操作。

参数：
l - RowSorterListener

fireSortOrderChanged

protected void fireSortOrderChanged()
通知侦听器排序顺序发生了更改。

fireRowSorterChanged

protected void fireRowSorterChanged(int[] lastRowIndexToModel)
通知侦听器映射关系发生了更改。

参数：
lastRowIndexToModel - 模型索引到排序之前视图索引的映射关系，可以为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSorter.SortKey (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 RowSorter.SortKey

java.lang.Object
    继承者  javax.swing.RowSorter.SortKey
正在封闭类：
RowSorter<M>
public static class RowSorter.SortKey
extends Object

SortKey 描述特定列的排序顺序。列索引是基于底层模型的，它可能不同于视图的列索引。

从以下版本开始：
1.6

构造方法摘要
RowSorter.SortKey(int column, SortOrder sortOrder)
使用指定的排序顺序创建指定列的 SortKey。
方法摘要
boolean | equals(Object o) 如果此对象与指定对象相等，则返回 true。
int | getColumn() 返回列的索引。
SortOrder | getSortOrder() 返回列的排序顺序。
int | hashCode() 返回此 SortKey 的哈希码。
从类 java.lang.Object 继承的方法
clone, finalize, getClass, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

RowSorter.SortKey

public RowSorter.SortKey(int column,
                         SortOrder sortOrder)
使用指定的排序顺序创建指定列的 SortKey。

参数：
column - 列索引，就模型而言
sortOrder - 排序顺序
抛出：
IllegalArgumentException - 如果 sortOrder 为 null
方法详细信息

getColumn

public final int getColumn()
返回列的索引。

返回：
列的索引

getSortOrder

public final SortOrder getSortOrder()
返回列的排序顺序。

返回：
列的排序顺序

hashCode

public int hashCode()
返回此 SortKey 的哈希码。

覆盖：
类 Object 中的 hashCode
返回：
哈希码
另请参见：
Object.equals(java.lang.Object), Hashtable

equals

public boolean equals(Object o)
如果此对象与指定对象相等，则返回 true。如果指定的对象是一个 SortKey 并且引用相同的列和排序顺序，则这两个对象相等。

覆盖：
类 Object 中的 equals
参数：
o - 要比较的对象
返回：
如果 o 等于此 SortKey，则返回 true
另请参见：
Object.hashCode(), Hashtable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Scrollable (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 Scrollable

所有已知实现类：
DefaultTreeCellEditor.DefaultTextField, JEditorPane, JFormattedTextField, JList, JPasswordField, JTable, JTextArea, JTextComponent, JTextField, JTextPane, JTree
public interface Scrollable

为类似 JScrollPane 的滚动容器提供信息的接口。用于查看 JScrollPane （或其他滚动容器）的视口的复杂组件应实现此接口。

另请参见：
JViewport, JScrollPane, JScrollBar

方法摘要
Dimension | getPreferredScrollableViewportSize() 返回视图组件视口的首选大小。
int | getScrollableBlockIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。
boolean | getScrollableTracksViewportHeight() 如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。
boolean | getScrollableTracksViewportWidth() 如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。
int | getScrollableUnitIncrement(Rectangle visibleRect, int orientation, int direction) 显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。

方法详细信息

getPreferredScrollableViewportSize

Dimension getPreferredScrollableViewportSize()
返回视图组件视口的首选大小。例如，JList 组件的首选大小为容纳其列表中所有单元所需的大小。但是，preferredScrollableViewportSize 的值为 JList.getVisibleRowCount 行所需的大小。此处不带任何影响视口大小的属性的组件应只返回 getPreferredSize。

返回：
视图为此 Scrollable 的 JViewport 的首选大小
另请参见：
JComponent.getPreferredSize()

getScrollableUnitIncrement

int getScrollableUnitIncrement(Rectangle visibleRect,
                               int orientation,
                               int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个新的行或列。理想情况下，组件应通过返回需要的距离来处理一个部分公开的行或列，以便完全公开此项。

每当用户请求一个单位的滚动时，类似 JScrollPane 的滚动容器将使用此方法。

参数：
visibleRect - 视口内可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
direction - 小于 0 为向上/左滚动，大于 0 为向下/右滚动。
返回：
沿指定方向滚动的“单位”增量。此值应该永远为正数。
另请参见：
JScrollBar.setUnitIncrement(int)

getScrollableBlockIncrement

int getScrollableBlockIncrement(Rectangle visibleRect,
                                int orientation,
                                int direction)
显示逻辑行或列的组件应计算滚动增量，它将根据方向的值完全公开一个行块或列块。

每当用户请求一个块的滚动时，类似 JScrollPane 的滚动容器将使用此方法。

参数：
visibleRect - 视口内可见的视图区域
orientation - SwingConstants.VERTICAL 或 SwingConstants.HORIZONTAL。
direction - 小于 0 为向上/左滚动，大于 0 为向下/右滚动。
返回：
沿指定方向滚动的“块”增量。此值应该永远为正数。
另请参见：
JScrollBar.setBlockIncrement(int)

getScrollableTracksViewportWidth

boolean getScrollableTracksViewportWidth()
如果视口总是强制此 Scrollable 的宽度与视口宽度匹配，则返回 true。例如，支持换行的正常文本显示在这里将返回 true，因为不希望让换行内容超出视口右边界而无法显示。注意，祖先为 JScrollPane 的 Scrollable 返回 true 可有效地禁用水平滚动。

类似 JViewport 的滚动容器在每次进行验证时都使用此方法。

返回：
如果视口强制 Scrollable 宽度与其自身宽度匹配，则返回 True。

getScrollableTracksViewportHeight

boolean getScrollableTracksViewportHeight()
如果视口总是强制此 Scrollable 的高度与视口高度匹配，则返回 true。例如，纵行文本视图（按列从左向右流入文本）通过在此处返回 true 可有效地禁用垂直滚动。

类似 JViewport 的滚动容器在每次进行验证时都使用此方法。

返回：
如果视口强制 Scrollable 高度与其自身高度匹配，则返回 True。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollPaneConstants (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 ScrollPaneConstants

所有已知实现类：
BasicScrollPaneUI, JScrollPane, MetalScrollPaneUI, ScrollPaneLayout, ScrollPaneLayout.UIResource
public interface ScrollPaneConstants

与 JScrollPane 组件一起使用的常数。

字段摘要
static String | COLUMN_HEADER 标识视口顶部左上角和右上角之间的区域。
static String | HORIZONTAL_SCROLLBAR 标识水平滚动条。
static int | HORIZONTAL_SCROLLBAR_ALWAYS 用于设置水平滚动条策略以使水平滚动条一直显示。
static int | HORIZONTAL_SCROLLBAR_AS_NEEDED 用于设置水平滚动条策略以使水平滚动条只在需要时显示。
static int | HORIZONTAL_SCROLLBAR_NEVER 用于设置水平滚动条策略以使水平滚动条从不显示。
static String | HORIZONTAL_SCROLLBAR_POLICY 标识水平滚动条策略属性。
static String | LOWER_LEADING_CORNER 标识视口的底端开始边角。
static String | LOWER_LEFT_CORNER 标识视口的左下角。
static String | LOWER_RIGHT_CORNER 标识视口的右下角。
static String | LOWER_TRAILING_CORNER 标识视口的底端结束边角。
static String | ROW_HEADER 标识沿视口左边左上角和左下角之间的区域。
static String | UPPER_LEADING_CORNER 标识视口的顶端开始边角。
static String | UPPER_LEFT_CORNER 标识视口的左上角。
static String | UPPER_RIGHT_CORNER 标识视口的右上角。
static String | UPPER_TRAILING_CORNER 标识视口的顶端结束边角。
static String | VERTICAL_SCROLLBAR 标识垂直滚动条。
static int | VERTICAL_SCROLLBAR_ALWAYS 用于设置垂直滚动条策略以使垂直滚动条一直显示。
static int | VERTICAL_SCROLLBAR_AS_NEEDED 用于设置垂直滚动条策略以使垂直滚动条只在需要时显示。
static int | VERTICAL_SCROLLBAR_NEVER 用于设置垂直滚动条策略以使垂直滚动条从不显示。
static String | VERTICAL_SCROLLBAR_POLICY 标识垂直滚动条策略属性。
static String | VIEWPORT 标识一个“视口”或显示区域，在这个范围内能看到滚动的内容。

字段详细信息

VIEWPORT

static final String VIEWPORT
标识一个“视口”或显示区域，在这个范围内能看到滚动的内容。

另请参见：
常量字段值

VERTICAL_SCROLLBAR

static final String VERTICAL_SCROLLBAR
标识垂直滚动条。

另请参见：
常量字段值

HORIZONTAL_SCROLLBAR

static final String HORIZONTAL_SCROLLBAR
标识水平滚动条。

另请参见：
常量字段值

ROW_HEADER

static final String ROW_HEADER
标识沿视口左边左上角和左下角之间的区域。

另请参见：
常量字段值

COLUMN_HEADER

static final String COLUMN_HEADER
标识视口顶部左上角和右上角之间的区域。

另请参见：
常量字段值

LOWER_LEFT_CORNER

static final String LOWER_LEFT_CORNER
标识视口的左下角。

另请参见：
常量字段值

LOWER_RIGHT_CORNER

static final String LOWER_RIGHT_CORNER
标识视口的右下角。

另请参见：
常量字段值

UPPER_LEFT_CORNER

static final String UPPER_LEFT_CORNER
标识视口的左上角。

另请参见：
常量字段值

UPPER_RIGHT_CORNER

static final String UPPER_RIGHT_CORNER
标识视口的右上角。

另请参见：
常量字段值

LOWER_LEADING_CORNER

static final String LOWER_LEADING_CORNER
标识视口的底端开始边角。开始边相对于滚动窗格的 ComponentOrientation 属性而确定。

另请参见：
常量字段值

LOWER_TRAILING_CORNER

static final String LOWER_TRAILING_CORNER
标识视口的底端结束边角。结束边相对于滚动窗格的 ComponentOrientation 属性而确定。

另请参见：
常量字段值

UPPER_LEADING_CORNER

static final String UPPER_LEADING_CORNER
标识视口的顶端开始边角。开始边相对于滚动窗格的 ComponentOrientation 属性而确定。

另请参见：
常量字段值

UPPER_TRAILING_CORNER

static final String UPPER_TRAILING_CORNER
标识视口的顶端结束边角。结束边相对于滚动窗格的 ComponentOrientation 属性而确定。

另请参见：
常量字段值

VERTICAL_SCROLLBAR_POLICY

static final String VERTICAL_SCROLLBAR_POLICY
标识垂直滚动条策略属性。

另请参见：
常量字段值

HORIZONTAL_SCROLLBAR_POLICY

static final String HORIZONTAL_SCROLLBAR_POLICY
标识水平滚动条策略属性。

另请参见：
常量字段值

VERTICAL_SCROLLBAR_AS_NEEDED

static final int VERTICAL_SCROLLBAR_AS_NEEDED
用于设置垂直滚动条策略以使垂直滚动条只在需要时显示。

另请参见：
常量字段值

VERTICAL_SCROLLBAR_NEVER

static final int VERTICAL_SCROLLBAR_NEVER
用于设置垂直滚动条策略以使垂直滚动条从不显示。

另请参见：
常量字段值

VERTICAL_SCROLLBAR_ALWAYS

static final int VERTICAL_SCROLLBAR_ALWAYS
用于设置垂直滚动条策略以使垂直滚动条一直显示。

另请参见：
常量字段值

HORIZONTAL_SCROLLBAR_AS_NEEDED

static final int HORIZONTAL_SCROLLBAR_AS_NEEDED
用于设置水平滚动条策略以使水平滚动条只在需要时显示。

另请参见：
常量字段值

HORIZONTAL_SCROLLBAR_NEVER

static final int HORIZONTAL_SCROLLBAR_NEVER
用于设置水平滚动条策略以使水平滚动条从不显示。

另请参见：
常量字段值

HORIZONTAL_SCROLLBAR_ALWAYS

static final int HORIZONTAL_SCROLLBAR_ALWAYS
用于设置水平滚动条策略以使水平滚动条一直显示。

另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollPaneLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ScrollPaneLayout

java.lang.Object
    继承者  javax.swing.ScrollPaneLayout
所有已实现的接口：
LayoutManager, Serializable, ScrollPaneConstants
直接已知子类：
ScrollPaneLayout.UIResource
public class ScrollPaneLayout
extends Object
implements LayoutManager, ScrollPaneConstants, Serializable

JScrollPane 使用的布局管理器。JScrollPaneLayout 负责管理九个组件：一个视口、两个滚动条、一个行标题、一个列标题和四个“角”组件。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
JScrollPane, JViewport

嵌套类摘要
static class ScrollPaneLayout.UIResource
ScrollPaneLayout 的 UI 资源版本。
字段摘要
protected JViewport | colHead 子级列标题。
protected JScrollBar | hsb 滚动窗格的子级水平滚动条。
protected int | hsbPolicy 水平滚动条的显示策略。
protected Component | lowerLeft 左下角显示的组件。
protected Component | lowerRight 右下角显示的组件。
protected JViewport | rowHead 子级行标题。
protected Component | upperLeft 左上角显示的组件。
protected Component | upperRight 右上角显示的组件。
protected JViewport | viewport 滚动窗格的子级视口。
protected JScrollBar | vsb 滚动窗格的子级垂直滚动条。
protected int | vsbPolicy 垂直滚动条的显示策略。
从接口 javax.swing.ScrollPaneConstants 继承的字段
COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT
构造方法摘要
ScrollPaneLayout()
方法摘要
void | addLayoutComponent(String s, Component c) 将指定的组件添加到布局中。
protected Component | addSingletonComponent(Component oldC, Component newC) 移除现有组件。
JViewport | getColumnHeader() 返回列标题对应的 JViewport 对象。
Component | getCorner(String key) 返回位于指定角的 Component。
JScrollBar | getHorizontalScrollBar() 返回处理水平滚动的 JScrollBar 对象。
int | getHorizontalScrollBarPolicy() 返回水平滚动条的显示策略。
JViewport | getRowHeader() 返回行标题对应的 JViewport 对象。
JScrollBar | getVerticalScrollBar() 返回处理垂直滚动的 JScrollBar 对象。
int | getVerticalScrollBarPolicy() 返回垂直滚动条的显示策略。
JViewport | getViewport() 返回显示滚动组件内容的 JViewport 对象。
Rectangle | getViewportBorderBounds(JScrollPane scrollpane) 已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。
void | layoutContainer(Container parent) 布置滚动窗格。
Dimension | minimumLayoutSize(Container parent) ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。
Dimension | preferredLayoutSize(Container parent) ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。
void | removeLayoutComponent(Component c) 从布局中移除指定的组件。
void | setHorizontalScrollBarPolicy(int x) 设置水平滚动条显示策略。
void | setVerticalScrollBarPolicy(int x) 设置垂直滚动条的显示策略。
void | syncWithScrollPane(JScrollPane sp) 在 ScrollPaneLayout 被设置为 JScrollPane 的 LayoutManager 后，此方法被调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

viewport

protected JViewport viewport
滚动窗格的子级视口。默认情况下为空 JViewport。

另请参见：
JScrollPane.setViewport(javax.swing.JViewport)

vsb

protected JScrollBar vsb
滚动窗格的子级垂直滚动条。默认情况下为 JScrollBar。

另请参见：
JScrollPane.setVerticalScrollBar(javax.swing.JScrollBar)

hsb

protected JScrollBar hsb
滚动窗格的子级水平滚动条。默认情况下为 JScrollBar。

另请参见：
JScrollPane.setHorizontalScrollBar(javax.swing.JScrollBar)

rowHead

protected JViewport rowHead
子级行标题。默认情况下为 null。

另请参见：
JScrollPane.setRowHeader(javax.swing.JViewport)

colHead

protected JViewport colHead
子级列标题。默认情况下为 null。

另请参见：
JScrollPane.setColumnHeader(javax.swing.JViewport)

lowerLeft

protected Component lowerLeft
左下角显示的组件。默认情况下为 null。

另请参见：
JScrollPane.setCorner(java.lang.String, java.awt.Component)

lowerRight

protected Component lowerRight
右下角显示的组件。默认情况下为 null。

另请参见：
JScrollPane.setCorner(java.lang.String, java.awt.Component)

upperLeft

protected Component upperLeft
左上角显示的组件。默认情况下为 null。

另请参见：
JScrollPane.setCorner(java.lang.String, java.awt.Component)

upperRight

protected Component upperRight
右上角显示的组件。默认情况下为 null。

另请参见：
JScrollPane.setCorner(java.lang.String, java.awt.Component)

vsbPolicy

protected int vsbPolicy
垂直滚动条的显示策略。默认情况下为 ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED。

该字段已废弃，请用 JScrollPane 字段代替。

另请参见：
JScrollPane.setVerticalScrollBarPolicy(int)

hsbPolicy

protected int hsbPolicy
水平滚动条的显示策略。默认情况下为 ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED。

该字段已废弃，请用 JScrollPane 字段代替。

另请参见：
JScrollPane.setHorizontalScrollBarPolicy(int)
构造方法详细信息

ScrollPaneLayout

public ScrollPaneLayout()
方法详细信息

syncWithScrollPane

public void syncWithScrollPane(JScrollPane sp)
在 ScrollPaneLayout 被设置为 JScrollPane 的 LayoutManager 后，此方法被调用。它将初始化通常由 addLayoutComponent 设置的所有内部字段。例如：
 ScrollPaneLayout mySPLayout = new ScrollPanelLayout() {
     public void layoutContainer(Container p) {
         super.layoutContainer(p);
         // do some extra work here ...
     }
 };
 scrollpane.setLayout(mySPLayout):

addSingletonComponent

protected Component addSingletonComponent(Component oldC,
                                          Component newC)
移除现有组件。当添加新的组件（如左角或垂直滚动条）时，对应的旧组件（如果有）必须移除。

该方法返回 newC。如果 oldC 不等于 newC 并且不为 null，它将从其父级移除。

参数：
oldC - 要替换的 Component
newC - 要添加的 Component
返回：
newC

addLayoutComponent

public void addLayoutComponent(String s,
                               Component c)
将指定的组件添加到布局中。布局通过以下内容之一标识：
  • ScrollPaneConstants.VIEWPORT
  • ScrollPaneConstants.VERTICAL_SCROLLBAR
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR
  • ScrollPaneConstants.ROW_HEADER
  • ScrollPaneConstants.COLUMN_HEADER
  • ScrollPaneConstants.LOWER_LEFT_CORNER
  • ScrollPaneConstants.LOWER_RIGHT_CORNER
  • ScrollPaneConstants.UPPER_LEFT_CORNER
  • ScrollPaneConstants.UPPER_RIGHT_CORNER

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
s - 组件标识符
c - 要添加的组件
抛出：
IllegalArgumentException - 如果 s 为无效关键字

removeLayoutComponent

public void removeLayoutComponent(Component c)
从布局中移除指定的组件。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
c - 要移除的组件

getVerticalScrollBarPolicy

public int getVerticalScrollBarPolicy()
返回垂直滚动条的显示策略。

返回：
一个提供显示策略的整数
另请参见：
setVerticalScrollBarPolicy(int)

setVerticalScrollBarPolicy

public void setVerticalScrollBarPolicy(int x)
设置垂直滚动条的显示策略。选项有：
  • ScrollPaneConstants.VERTICAL_SCROLLBAR_AS_NEEDED
  • ScrollPaneConstants.VERTICAL_SCROLLBAR_NEVER
  • ScrollPaneConstants.VERTICAL_SCROLLBAR_ALWAYS
注：应用程序应使用该方法的 JScrollPane 版本。它仅用于此类的 Swing 1.0.2（及更早）版本向后兼容。

参数：
x - 一个提供显示策略的整数
抛出：
IllegalArgumentException - 如果 x 为上面列出的无效垂直滚动条策略

getHorizontalScrollBarPolicy

public int getHorizontalScrollBarPolicy()
返回水平滚动条的显示策略。

返回：
一个提供显示策略的整数
另请参见：
setHorizontalScrollBarPolicy(int)

setHorizontalScrollBarPolicy

public void setHorizontalScrollBarPolicy(int x)
设置水平滚动条显示策略。选项有：
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_AS_NEEDED
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_NEVER
  • ScrollPaneConstants.HORIZONTAL_SCROLLBAR_ALWAYS
注：应用程序应使用该方法的 JScrollPane 版本。它仅用于此类的 Swing 1.0.2（及更早）版本向后兼容。

参数：
x - 一个提供显示策略的整数
抛出：
IllegalArgumentException - 如果 x 为上面列出的无效水平滚动条策略

getViewport

public JViewport getViewport()
返回显示滚动组件内容的 JViewport 对象。

返回：
显示滚动组件内容的 JViewport 对象
另请参见：
JScrollPane.getViewport()

getHorizontalScrollBar

public JScrollBar getHorizontalScrollBar()
返回处理水平滚动的 JScrollBar 对象。

返回：
处理水平滚动的 JScrollBar 对象
另请参见：
JScrollPane.getHorizontalScrollBar()

getVerticalScrollBar

public JScrollBar getVerticalScrollBar()
返回处理垂直滚动的 JScrollBar 对象。

返回：
处理垂直滚动的 JScrollBar 对象
另请参见：
JScrollPane.getVerticalScrollBar()

getRowHeader

public JViewport getRowHeader()
返回行标题对应的 JViewport 对象。

返回：
行标题对应的 JViewport 对象
另请参见：
JScrollPane.getRowHeader()

getColumnHeader

public JViewport getColumnHeader()
返回列标题对应的 JViewport 对象。

返回：
列标题对应的 JViewport 对象
另请参见：
JScrollPane.getColumnHeader()

getCorner

public Component getCorner(String key)
返回位于指定角的 Component。

参数：
key - 用于指定角的 String
返回：
位于指定角的 Component，在 ScrollPaneConstants 中的定义；如果 key 不是四个角之一，则返回 null
另请参见：
JScrollPane.getCorner(java.lang.String)

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
ScrollPane 的首选大小是 insets 的大小加上视口的首选大小、可见标题首选大小以及滚动条的首选大小，它按照给定的当前视图和当前滚动条策略显示。

注意，rowHeader 是作为 width 首选大小的一部分计算的，colHeader 是作为首选大小的一部分计算的。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 将被布置的 Container
返回：
指定视口和任何滚动条的首选大小的 Dimension 对象
另请参见：
ViewportLayout, LayoutManager

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
ScrollPane 的最小大小是 insets 加上视口最小大小，加上可见标题的最小大小，加上 displayPolicy 不为 NEVER 的滚动条的最小大小。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 将被布置的 Container
返回：
指定最小大小的 Dimension 对象

layoutContainer

public void layoutContainer(Container parent)
布置滚动窗格。组件的放置取决于以下约束：
  • 行标题，如果存在且可见的话，获取它的首选宽度大小以及视口的高度。
  • 列标题，如果存在且可见的话，获取它的首选高度大小以及视口的宽度。
  • 如果需要垂直滚动条，即如果视口的延伸高度小于它的视图高度，或者 displayPolicy 为 ALWAYS，在维度方面它将被视作行标题并且可见。
  • 如果需要水平滚动条，它将被视作列标题（请参阅上段中有关垂直滚动条的内容）。
  • 如果滚动窗格为非 null viewportBorder，将为其分配空间。
  • 视口在满足前面的约束后获取可用的空间。
  • 如果提供了角组件，它将与滚动条和标题的末尾对齐。如果有垂直滚动条，将显示右角；如果有水平滚动条，将显示底角；有行标题将显示左角，有列标题将显示上角。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要布置的 Container

getViewportBorderBounds

@Deprecated
public Rectangle getViewportBorderBounds(JScrollPane scrollpane)
已过时。 从 JDK version Swing1.1 开始，由 JScrollPane.getViewportBorderBounds() 取代。

返回围绕指定滚动窗格视口的边框。

返回：
视口边框的大小和位置
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ScrollPaneLayout.UIResource (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ScrollPaneLayout.UIResource

java.lang.Object
    继承者  javax.swing.ScrollPaneLayout
        继承者  javax.swing.ScrollPaneLayout.UIResource
所有已实现的接口：
LayoutManager, Serializable, UIResource, ScrollPaneConstants
正在封闭类：
ScrollPaneLayout
public static class ScrollPaneLayout.UIResource
extends ScrollPaneLayout
implements UIResource

ScrollPaneLayout 的 UI 资源版本。

嵌套类摘要
从类 javax.swing.ScrollPaneLayout 继承的嵌套类/接口
ScrollPaneLayout.UIResource
字段摘要
从类 javax.swing.ScrollPaneLayout 继承的字段
colHead, hsb, hsbPolicy, lowerLeft, lowerRight, rowHead, upperLeft, upperRight, viewport, vsb, vsbPolicy
从接口 javax.swing.ScrollPaneConstants 继承的字段
COLUMN_HEADER, HORIZONTAL_SCROLLBAR, HORIZONTAL_SCROLLBAR_ALWAYS, HORIZONTAL_SCROLLBAR_AS_NEEDED, HORIZONTAL_SCROLLBAR_NEVER, HORIZONTAL_SCROLLBAR_POLICY, LOWER_LEADING_CORNER, LOWER_LEFT_CORNER, LOWER_RIGHT_CORNER, LOWER_TRAILING_CORNER, ROW_HEADER, UPPER_LEADING_CORNER, UPPER_LEFT_CORNER, UPPER_RIGHT_CORNER, UPPER_TRAILING_CORNER, VERTICAL_SCROLLBAR, VERTICAL_SCROLLBAR_ALWAYS, VERTICAL_SCROLLBAR_AS_NEEDED, VERTICAL_SCROLLBAR_NEVER, VERTICAL_SCROLLBAR_POLICY, VIEWPORT
构造方法摘要
ScrollPaneLayout.UIResource()
方法摘要
从类 javax.swing.ScrollPaneLayout 继承的方法
addLayoutComponent, addSingletonComponent, getColumnHeader, getCorner, getHorizontalScrollBar, getHorizontalScrollBarPolicy, getRowHeader, getVerticalScrollBar, getVerticalScrollBarPolicy, getViewport, getViewportBorderBounds, layoutContainer, minimumLayoutSize, preferredLayoutSize, removeLayoutComponent, setHorizontalScrollBarPolicy, setVerticalScrollBarPolicy, syncWithScrollPane
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ScrollPaneLayout.UIResource

public ScrollPaneLayout.UIResource()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SingleSelectionModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 SingleSelectionModel

所有已知实现类：
DefaultSingleSelectionModel
public interface SingleSelectionModel

最多支持一个索引选项的模型。

方法摘要
void | addChangeListener(ChangeListener listener) 在模型中添加作为更改侦听侦听器的 listener。
void | clearSelection() 清除选项（返回 -1）。
int | getSelectedIndex() 返回模型的选项。
boolean | isSelected() 如果选项模型当前有一个选定的值，则返回 true。
void | removeChangeListener(ChangeListener listener) 从模型中移除作为更改侦听器的 listener。
void | setSelectedIndex(int index) 将模型中选定的索引设置为 index。

方法详细信息

getSelectedIndex

int getSelectedIndex()
返回模型的选项。

返回：
模型的选项，如果没有任何选项，则返回 -1
另请参见：
setSelectedIndex(int)

setSelectedIndex

void setSelectedIndex(int index)
将模型中选定的索引设置为 index。如果模型更改则通知所有的侦听器。

参数：
index - 用于指定模型选项的整数
另请参见：
getSelectedIndex(), addChangeListener(javax.swing.event.ChangeListener)

clearSelection

void clearSelection()
清除选项（返回 -1）。

isSelected

boolean isSelected()
如果选项模型当前有一个选定的值，则返回 true。

返回：
如果当前选定一个值，则返回 true

addChangeListener

void addChangeListener(ChangeListener listener)
在模型中添加作为更改侦听侦听器的 listener。

参数：
listener - 要添加的 ChangeListener

removeChangeListener

void removeChangeListener(ChangeListener listener)
从模型中移除作为更改侦听器的 listener。

参数：
listener - 要移除的 ChangeListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SizeRequirements (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SizeRequirements

java.lang.Object
    继承者  javax.swing.SizeRequirements
所有已实现的接口：
Serializable
public class SizeRequirements
extends Object
implements Serializable

为方便布局管理器，计算组件的有关大小和位置信息。大小和位置的所有计算方法都是将 SizeRequirements 数组作为参数的类方法。SizeRequirements 类支持两种布局类型：

平铺
组件按端到端方式放置，起点可以为坐标 0 （最左或最顶端位置）或所分配区域的末尾对应的坐标（最右或最底端位置）。
对齐
组件按每个组件的 X 或 Y 对齐值指定的方式对齐。

每个 SizeRequirements 对象包含了有关单个组件或一组组件的宽度（和 X 对齐方式）或高度（和 Y 对齐方式）的信息：

minimum
组件或组件组的最小合理宽度/高度，以像素为单位。
preferred
组件或组件组的自然宽度/高度，以像素为单位。
maximum
组件或组件组的最大合理宽度/高度，以像素为单位。
alignment
组件或组件组的 X/Y 对齐方式。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
Component.getMinimumSize(),
Component.getPreferredSize(),
Component.getMaximumSize(),
Component.getAlignmentX(),
Component.getAlignmentY()

字段摘要
float | alignment 对齐方式，指定为介于 0.0 和 1.0 之间的值，包含这两个边界值。
int | maximum 允许的最大大小。
int | minimum 要求的最小大小。
int | preferred 首选（自然）大小。
构造方法摘要
SizeRequirements()
创建 SizeRequirements 对象，其最小、首选和最大大小设置为零，对齐方式值为 0.5（居中）。
SizeRequirements(int min, int pref, int max, float a)
用指定的最小、首选和最大大小以及指定的对齐方式创建 SizeRequirements 对象。
方法摘要
static int[] | adjustSizes(int delta, SizeRequirements[] children) 按给定总量调整指定的大小数组。
static void | calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。
static void | calculateAlignedPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean normal) 创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。
static void | calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static void | calculateTiledPositions(int allocated, SizeRequirements total, SizeRequirements[] children, int[] offsets, int[] spans, boolean forward) 创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。
static SizeRequirements | getAlignedSizeRequirements(SizeRequirements[] children) 确定对齐一组组件所需的总空间。
static SizeRequirements | getTiledSizeRequirements(SizeRequirements[] children) 确定端到端放置一组组件需要占用的总空间。
String | toString() 返回一个描述最小、首选和最大大小以及对齐方式要求的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

minimum

public int minimum
要求的最小大小。对于组件 comp，该大小应该等于 comp.getMinimumSize().width 或 comp.getMinimumSize().height。

preferred

public int preferred
首选（自然）大小。对于组件 comp，该大小应该等于 comp.getPreferredSize().width 或 comp.getPreferredSize().height。

maximum

public int maximum
允许的最大大小。对于组件 comp，该大小应该等于 comp.getMaximumSize().width 或 comp.getMaximumSize().height。

alignment

public float alignment
对齐方式，指定为介于 0.0 和 1.0 之间的值，包含这两个边界值。要指定居中，对齐方式应为 0.5。

构造方法详细信息

SizeRequirements

public SizeRequirements()
创建 SizeRequirements 对象，其最小、首选和最大大小设置为零，对齐方式值为 0.5（居中）。

SizeRequirements

public SizeRequirements(int min,
                        int pref,
                        int max,
                        float a)
用指定的最小、首选和最大大小以及指定的对齐方式创建 SizeRequirements 对象。

参数：
min - 最小大小 >= 0
pref - 首选大小 >= 0
max - 最大大小 >= 0
a - 对齐方式 >= 0.0f && <= 1.0f
方法详细信息

toString

public String toString()
返回一个描述最小、首选和最大大小以及对齐方式要求的字符串。

覆盖：
类 Object 中的 toString
返回：
字符串

getTiledSizeRequirements

public static SizeRequirements getTiledSizeRequirements(SizeRequirements[] children)
确定端到端放置一组组件需要占用的总空间。集合中每个组件的要求通过传入的 SizeRequirements 数组中的一个条目表示。返回的 SizeRequirements 对象的对齐方式为 0.5 （居中）。所需空间永远不会大于 Integer.MAX_VALUE。

参数：
children - 一组组件的空间要求。该向量可以是零长度，它将导致传回一个默认的 SizeRequirements 对象实例。
返回：
总空间要求。

getAlignedSizeRequirements

public static SizeRequirements getAlignedSizeRequirements(SizeRequirements[] children)
确定对齐一组组件所需的总空间。集合中每个组件的要求通过传入的 SizeRequirements 数组中的一个条目表示。所需总空间永远不会大于 Integer.MAX_VALUE。

参数：
children - 所需的子级集合。如果长度为零，返回的结果将是一个默认的 SizeRequirements 实例。
返回：
总空间要求。

calculateTiledPositions

public static void calculateTiledPositions(int allocated,
                                           SizeRequirements total,
                                           SizeRequirements[] children,
                                           int[] offsets,
                                           int[] spans)
创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。此方法需要您指定要分配的总空间量、要放置的每个组件的大小要求（指定为 SizeRequirements 数组）以及组件集合的总大小要求。通过调用 getTiledSizeRequirements 方法可获得总大小要求。组件将按正向平铺，偏移量从 0 递增。

参数：
allocated - 要分配的总区域 >= 0。
total - 请求的子级总数。该参数是可选的，可以为 null。
children - 每个组件的大小要求。
offsets - 每个子级相对于 0 的偏移量，用于分配区域（确定区域的放置）。
spans - 为每个子级分配的区域，它们构成了总目标区域。

calculateTiledPositions

public static void calculateTiledPositions(int allocated,
                                           SizeRequirements total,
                                           SizeRequirements[] children,
                                           int[] offsets,
                                           int[] spans,
                                           boolean forward)
创建一组表示如何对一组组件进行端到端布局的偏移量/区域对。此方法需要您指定要分配的总空间量、要放置的每个组件的大小要求（指定为一组 SizeRequirements）以及组件集合的总大小要求。通过调用 getTiledSizeRequirements 方法可获得总大小要求。 该方法还需要使用一个标志，用来指示组件应该以正向（偏移量从 0 递增）还是反向（偏移量从已分配空间末尾递减）平铺。正向表示组件从左到右或从顶部到底部平铺。反向表示组件从右到左或从底部到顶部平铺。

参数：
allocated - 要分配的总区域 >= 0。
total - 请求的子级总数。该参数是可选的，可以为 null。
children - 每个组件的大小要求。
offsets - 每个子级相对于 0 的偏移量，用于分配区域（确定区域的放置）。
spans - 为每个子级分配的区域，它们构成了总目标区域。
forward - 如果为 true，按从 0 递增的偏移量平铺；如果为 false，按从已分配空间末尾递减的偏移量平铺。

calculateAlignedPositions

public static void calculateAlignedPositions(int allocated,
                                             SizeRequirements total,
                                             SizeRequirements[] children,
                                             int[] offsets,
                                             int[] spans)
创建一组偏移量/区域对，指定如何按照指定对齐方式对一组组件进行布局。得到的区域分配将互相重叠，每个组件尽可能地放到给定的总分配中。此方法需要您指定要分配的总空间量、要放置的每个组件的大小要求（指定为一组 SizeRequirements）以及组件集合的总大小要求（实际上只使用其中的对齐字段）。通过调用 getAlignedSizeRequirements 可获得总大小要求。 将执行正常对齐方式，对齐方式值为 0.0f（表示组件的左/上边界）。

参数：
allocated - 要分配的总区域 >= 0。
total - 请求的子级总数。
children - 每个组件的大小要求。
offsets - 每个子级相对于 0 的偏移量，用于分配区域（确定区域的放置）。
spans - 为每个子级分配的区域，它们构成了总目标区域。
从以下版本开始：
1.4

calculateAlignedPositions

public static void calculateAlignedPositions(int allocated,
                                             SizeRequirements total,
                                             SizeRequirements[] children,
                                             int[] offsets,
                                             int[] spans,
                                             boolean normal)
创建一组偏移量/区域对，指定如何按指定对齐方式对一组组件进行布局。得到的区域分配将互相重叠，每个组件尽可能地放到给定的总分配中。此方法需要您指定要分配的总空间量、要放置的每个组件的大小要求（指定为一组 SizeRequirements）以及组件集合的总大小要求（实际上只使用其中的对齐字段）。调用 getAlignedSizeRequirements 可获得总大小要求。 此方法还需要使用一个标志，用来指示应该执行正常或反向对齐。正常对齐方式下，值 0.0f 表示要对齐的组件的左/顶端边界。反向对齐方式下，0.0f 表示右/底端边界。

参数：
allocated - 要分配的总区域 >= 0。
total - 请求的子级总数。
children - 每个组件的大小要求。
offsets - 区域分配位置每个子级相对于 0 的偏移（确定区域的放置）。
spans - 为每个子级分配的区域，它们构成了总目标区域。
normal - 值为 true 时，对齐方式值 0.0f 表示左/顶端；值为 false 时，它表示右/底端。
从以下版本开始：
1.4

adjustSizes

public static int[] adjustSizes(int delta,
                                SizeRequirements[] children)
按给定总量调整指定的大小数组。

参数：
delta - 指定大小差异的 int
children - SizeRequirements 对象的数组
返回：
包含每一项的最终大小的 int 数组
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SizeSequence (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SizeSequence

java.lang.Object
    继承者  javax.swing.SizeSequence

public class SizeSequence
extends Object

一个 SizeSequence 对象，它有效地维护一个包含大小和相应位置的顺序列表。有一种情况需要用到 SizeSequence，即显示具有不同大小的多个行的组件。在这种情况下，用一个单独的 SizeSequence 对象可跟踪所有行的高度和 Y 位置。

另一个例子是包含多列的组件，比如 JTable，它的各列大小不尽相同。JTable 可使用一个单独的 SizeSequence 对象来存储所有列的宽度和 X 位置。然后，JTable 可以使用 SizeSequence 对象来查找与特定位置对应的列。只要有一列或多列大小发生更改，JTable 就会更新该 SizeSequence 对象。

下图显示了多列组件中大小和位置数据之间的关系。

第一项起始位置为 0，第二项起始位置等于 前一项的大小，依此类推。

在上图中，第一个索引 (0) 对应第一列，第二个索引 (1) 对应第二列，依此类推。第一列位置从 0 开始，该列占据 size0 个像素，其中 size0 是 getSize(0) 返回的值。因此，第一列在 size0 - 1 位置结束。然后第二列从 size0 位置开始并占据 size1 (getSize(1)) 个像素。

注意，SizeSequence 对象只代表轴上的间隔。在我们的示例中，间隔代表以像素为单位的高度或宽度。但是，任何其他测量单位（例如，时间单位为天）也同样有效。

实现注意事项

通常，存储条目的大小和位置时，我们会选择是存储条目的大小还是位置。呈现时需要两个公共操作：getIndex(position) 和 setSize(index, size)。无论选择哪种内部格式，当条目数变大时，这两个操作中每一个开销都很大。如果存储的是大小，查找位于特定位置的条目索引与条目数呈线性关系。反过来，如果存储的是位置，对位于特定索引的条目设置大小需要更新相关条目的位置，这又是一个线性计算。

与以上技巧相似，此类内部保存一个包含 N 个整数的数组，但它使用混合编码，这是介于基于大小和基于位置的方法之间一种折中方法。结果为一个数据结构，它存储信息需要相同大小的空间，但是执行大多数操作只需要 Log(N) 次，而不是 O(N) 次，N 是列表中的条目数。

有两个操作还需要执行 O(N) 条目数次，它们就是 insertEntries 和 removeEntries 方法，两者的实现方法都是将内部数组转换为一组整数大小，将它复制到新数组，然后将混合表示形式重新正确归位。

从以下版本开始：
1.3

构造方法摘要
SizeSequence()
创建一个新的 SizeSequence 对象，它不包含任何条目。
SizeSequence(int numEntries)
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 0。
SizeSequence(int[] sizes)
创建一个新的 SizeSequence 对象，它包含指定的大小。
SizeSequence(int numEntries, int value)
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 value。
方法摘要
int | getIndex(int position) 返回与指定位置对应的条目的索引。
int | getPosition(int index) 返回指定条目的起始位置。
int | getSize(int index) 返回指定条目的大小。
int[] | getSizes() 返回所有条目的大小。
void | insertEntries(int start, int length, int value) 将一组相邻的条目添加到此 SizeSequence 中。
void | removeEntries(int start, int length) 从此 SizeSequence 中移除一组相邻的条目。
void | setSize(int index, int size) 设置指定条目的大小。
void | setSizes(int[] sizes) 用 sizes 参数中的数据重置此 SizeSequence 对象。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SizeSequence

public SizeSequence()
创建一个新的 SizeSequence 对象，它不包含任何条目。要添加条目，可使用 insertEntries 或 setSizes。

另请参见：
insertEntries(int, int, int), setSizes(int, int)

SizeSequence

public SizeSequence(int numEntries)
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 0。

参数：
numEntries - 要跟踪的大小数
抛出：
NegativeArraySizeException - 如果 numEntries < 0

SizeSequence

public SizeSequence(int numEntries,
                    int value)
创建一个新的 SizeSequence 对象，它包含指定的条目数，每个大小都已初始化为 value。

参数：
numEntries - 要跟踪的大小数
value - 每个大小的初始值

SizeSequence

public SizeSequence(int[] sizes)
创建一个新的 SizeSequence 对象，它包含指定的大小。

参数：
sizes - 要包含在 SizeSequence 中的大小的数组
方法详细信息

setSizes

public void setSizes(int[] sizes)
用 sizes 参数中的数据重置此 SizeSequence 对象。该方法将此对象重新初始化，这样它可以包含与 sizes 数组一样多的条目。每个条目的大小都初始化为 sizes 中对应项的值。

参数：
sizes - 要包含在此 SizeSequence 中的大小的数组

getSizes

public int[] getSizes()
返回所有条目的大小。

返回：
一个包含此对象中的大小的新数组

getPosition

public int getPosition(int index)
返回指定条目的起始位置。例如，getPosition(0) 返回 0，getPosition(1) 与 getSize(0)相等，getPosition(2) 等于 getSize(0) + getSize(1)，依此类推。

注意，如果 index 大于 length，返回的值可能无意义。

参数：
index - 位于期望位置的条目的索引
返回：
指定条目的起始位置

getIndex

public int getIndex(int position)
返回与指定位置对应的条目的索引。例如，由于第一个条目通常从位置 0 开始，getIndex(0) 为 0。

参数：
position - 条目的位置
返回：
占用指定位置的条目的索引

getSize

public int getSize(int index)
返回指定条目的大小。如果 index 超出范围 (0 <= index < getSizes().length)，则行为是未指定的。

参数：
index - 与条目对应的索引
返回：
条目的大小

setSize

public void setSize(int index,
                    int size)
设置指定条目的大小。注意，如果 index 值未落在如下范围：(0 <= index < getSizes().length)，则行为是未指定的。

参数：
index - 与条目对应的索引
size - 条目的大小

insertEntries

public void insertEntries(int start,
                          int length,
                          int value)
将一组相邻的条目添加到此 SizeSequence 中。注意，start 和 length 的值必须满足如下条件：(0 <= start < getSizes().length) AND (length >= 0)。如果未满足这些条件，则行为未指定并且可能抛出异常。

参数：
start - 将分配给组中第一个条目的索引
length - 组中的条目数
value - 将分配给每个条目的大小
抛出：
ArrayIndexOutOfBoundsException - 如果参数超出如下范围：(0 <= start < (getSizes().length)) AND (length >= 0)

removeEntries

public void removeEntries(int start,
                          int length)
从此 SizeSequence 中移除一组相邻的条目。注意，start 和 length 的值必须满足如下条件：(0 <= start < getSizes().length) AND (length >= 0)。如果未满足这些条件，则行为未指定并且可能抛出异常。

参数：
start - 要移除的第一个条目的索引
length - 要移除的条目数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SortingFocusTraversalPolicy (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SortingFocusTraversalPolicy

java.lang.Object
    继承者  java.awt.FocusTraversalPolicy
        继承者  javax.swing.InternalFrameFocusTraversalPolicy
            继承者  javax.swing.SortingFocusTraversalPolicy
直接已知子类：
LayoutFocusTraversalPolicy
public class SortingFocusTraversalPolicy
extends InternalFrameFocusTraversalPolicy

通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。不可视和不可显示的 Component 层次结构部分将不被包含。

默认情况下，SortingFocusTraversalPolicy 会隐式将焦点传输给下一个循环。也就是说，在进行正常焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。可以使用 setImplicitDownCycleTraversal 方法禁用此行为。

默认情况下，只有 Component 是可视的、可显示的、被启用的和可聚焦的时候，此类的方法才返回此 Component。子类可以通过重写 accept 方法修改此行为。

此策略需要考虑焦点遍历策略提供者。当搜索第一个/最后一个/下一个/上一个 Component 时，如果遇到焦点遍历策略提供者，则使用该焦点遍历策略来执行搜索操作。

从以下版本开始：
1.4
另请参见：
Comparator

构造方法摘要
protected | SortingFocusTraversalPolicy() 构造一个不带 Comparator 的 SortingFocusTraversalPolicy。
 | SortingFocusTraversalPolicy(Comparator<? super Component> comparator) 构造具有指定 Comparator 的 SortingFocusTraversalPolicy。
方法摘要
protected boolean | accept(Component aComponent) 确定是否可以接受选择某个 Component 作为新的焦点拥有者。
protected Comparator<? super Component> | getComparator() 返回将用于对焦点遍历循环中的 Components 排序的 Comparator。
Component | getComponentAfter(Container aContainer, Component aComponent) 返回应该接收 aComponent 后面的焦点的 Component。
Component | getComponentBefore(Container aContainer, Component aComponent) 返回应该接收 aComponent 前面的焦点的 Component。
Component | getDefaultComponent(Container aContainer) 返回默认拥有焦点的 Component。
Component | getFirstComponent(Container aContainer) 返回遍历循环中的第一个 Component。
boolean | getImplicitDownCycleTraversal() 返回对此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环的判断。
Component | getLastComponent(Container aContainer) 返回遍历循环中的最后一个 Component。
protected void | setComparator(Comparator<? super Component> comparator) 设置将用于对焦点遍历循环中的 Components 排序的 Comparator。
void | setImplicitDownCycleTraversal(boolean implicitDownCycleTraversal) 设置此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环。
从类 javax.swing.InternalFrameFocusTraversalPolicy 继承的方法
getInitialComponent
从类 java.awt.FocusTraversalPolicy 继承的方法
getInitialComponent
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SortingFocusTraversalPolicy

protected SortingFocusTraversalPolicy()
构造一个不带 Comparator 的 SortingFocusTraversalPolicy。在焦点循环根或 KeyboardFocusManager 上安装此 FocusTraversalPolicy 之前，子类必须用 setComparator 设置 Comparator。

SortingFocusTraversalPolicy

public SortingFocusTraversalPolicy(Comparator<? super Component> comparator)
构造具有指定 Comparator 的 SortingFocusTraversalPolicy。

方法详细信息

getComponentAfter

public Component getComponentAfter(Container aContainer,
                                   Component aComponent)
返回应该接收 aComponent 后面的焦点的 Component。aContainer 必须是 aComponent 的焦点循环根，或者是一个焦点遍历策略提供者。

默认情况下，SortingFocusTraversalPolicy 会隐式将焦点传输给下一个循环。也就是说，在进行正常焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。可以使用 setImplicitDownCycleTraversal 方法禁用此行为。

如果 aContainer 是焦点遍历策略提供者，则总是将焦点传输到下一个循环。

指定者：
类 FocusTraversalPolicy 中的 getComponentAfter
参数：
aContainer - aComponent 的焦点循环根，或焦点遍历策略提供者
aComponent - aContainer 的子组件（可能是间接的），或 aContainer 自身
返回：
应该接收 aComponent 之后的焦点的 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getComponentBefore

public Component getComponentBefore(Container aContainer,
                                    Component aComponent)
返回应该接收 aComponent 前面的焦点的 Component。aContainer 必须是 aComponent 的焦点循环根，或者是一个焦点遍历策略提供者。

默认情况下，SortingFocusTraversalPolicy 会隐式将焦点传输给下一个循环。也就是说，在进行正常焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。可以使用 setImplicitDownCycleTraversal 方法禁用此行为。

如果 aContainer 是焦点遍历策略提供者，则总是将焦点传输到下一个循环。

指定者：
类 FocusTraversalPolicy 中的 getComponentBefore
参数：
aContainer - aComponent 的焦点循环根，或焦点遍历策略提供者
aComponent - aContainer 的子组件（可能是间接的），或 aContainer 自身
返回：
应该接收 aComponent 之前的焦点的 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 不是 aComponent 的焦点循环根或焦点遍历策略提供者，或者 aContainer 或 aComponent 为 null

getFirstComponent

public Component getFirstComponent(Container aContainer)
返回遍历循环中的第一个 Component。在进行正向遍历时，可用此方法确定拥有焦点的下一个 Component。

指定者：
类 FocusTraversalPolicy 中的 getFirstComponent
参数：
aContainer - 要返回其第一个 Component 的 aComponent 的焦点循环根，或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的第一个 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getLastComponent

public Component getLastComponent(Container aContainer)
返回遍历循环中的最后一个 Component。在进行反向遍历时，可用此方法确定拥有焦点的下一个 Component。

指定者：
类 FocusTraversalPolicy 中的 getLastComponent
参数：
aContainer - 要返回其最后一个 Component 的 aComponent 的焦点循环根，或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的最后一个 Component，如果无法找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null

getDefaultComponent

public Component getDefaultComponent(Container aContainer)
返回默认拥有焦点的 Component。在向下遍历到以 aContainer 为根的新焦点遍历循环时，此 Component 将是第一个接受焦点的 Component。此方法的默认实现将返回与 getFirstComponent 相同的 Component。

指定者：
类 FocusTraversalPolicy 中的 getDefaultComponent
参数：
aContainer - 将返回其默认 Component 的 aComponent 的焦点循环根或焦点遍历策略提供者
返回：
aContainer 的遍历循环中的默认 Component，如果没有找到合适的 Component，则返回 null
抛出：
IllegalArgumentException - 如果 aContainer 为 null
另请参见：
getFirstComponent(java.awt.Container)

setImplicitDownCycleTraversal

public void setImplicitDownCycleTraversal(boolean implicitDownCycleTraversal)
设置此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环。如果返回 true，则在进行正常焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。如果返回 false，则将遍历根植在指定焦点循环上的焦点遍历循环中的下一个 Component。此属性的默认值为 true。

参数：
implicitDownCycleTraversal - 此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环
另请参见：
getImplicitDownCycleTraversal(), getFirstComponent(java.awt.Container)

getImplicitDownCycleTraversal

public boolean getImplicitDownCycleTraversal()
返回对此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环的判断。如果返回 true，则在进行正常焦点遍历期间，在焦点循环根后面遍历的 Component 将成为焦点循环根默认拥有焦点的 Component。如果返回 false，则将遍历根植在指定焦点循环上的焦点遍历循环中的下一个 Component。

返回：
此 SortingFocusTraversalPolicy 是否隐式将焦点传输给下一个循环
另请参见：
setImplicitDownCycleTraversal(boolean), getFirstComponent(java.awt.Container)

setComparator

protected void setComparator(Comparator<? super Component> comparator)
设置将用于对焦点遍历循环中的 Components 排序的 Comparator。

参数：
comparator - 将用于排序的 Comparator

getComparator

protected Comparator<? super Component> getComparator()
返回将用于对焦点遍历循环中的 Components 排序的 Comparator。

返回：
将用于排序的 Comparator

accept

protected boolean accept(Component aComponent)
确定是否可以接受选择某个 Component 作为新的焦点拥有者。默认情况下，当且仅当 Component 是可视的、可显示的、被启用的和可聚焦的时候，此方法才接受此 Component。

参数：
aComponent - 将测试其是否适合作为焦点拥有者的 Component
返回：
如果 aComponent 是可视的、可显示的、被启用的和可聚焦的，则返回 true；否则返回 false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SortOrder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing
枚举 SortOrder

java.lang.Object
    继承者  java.lang.Enum<SortOrder>
        继承者  javax.swing.SortOrder
所有已实现的接口：
Serializable, Comparable<SortOrder>
public enum SortOrder
extends Enum<SortOrder>

SortOrder 是可能排序顺序的枚举。

从以下版本开始：
1.6
另请参见：
RowSorter

枚举常量摘要
ASCENDING
指示项以递增顺序排序的枚举值。
DESCENDING
指示项以递减顺序排序的枚举值。
UNSORTED
指示项为无序的枚举值。
方法摘要
static SortOrder | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SortOrder[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

ASCENDING

public static final SortOrder ASCENDING
指示项以递增顺序排序的枚举值。例如，以 ASCENDING 顺序排序的集合 1, 4, 0 为 0, 1, 4。

DESCENDING

public static final SortOrder DESCENDING
指示项以递减顺序排序的枚举值。例如，以 DESCENDING 顺序排序的集合 1, 4, 0 为 4, 1, 0。

UNSORTED

public static final SortOrder UNSORTED
指示项为无序的枚举值。例如，以 UNSORTED 顺序排序的集合 1, 4, 0 为 1, 4, 0。

方法详细信息

values

public static final SortOrder[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SortOrder c : SortOrder.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SortOrder valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


SpinnerDateModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SpinnerDateModel

java.lang.Object
    继承者  javax.swing.AbstractSpinnerModel
        继承者  javax.swing.SpinnerDateModel
所有已实现的接口：
Serializable, SpinnerModel
public class SpinnerDateModel
extends AbstractSpinnerModel
implements Serializable

Date 序列的一个 SpinnerModel。序列的上下边界由称为 start 和 end 的属性定义，而通过 nextValue 和 previousValue 方法计算的增加和减少的大小由称作 calendarField 的属性定义。start 和 end 属性可以为 null，以指示序列没有下限和上限。

calendarField 属性的值必须是在 Calendar 内指定某个字段的其中一个 java.util.Calendar 常量。getNextValue 和 getPreviousValue 方法将日期向前或向后更改这些量。例如，如果 calendarField 为 Calendar.DAY_OF_WEEK，则 nextValue 生成一个比当前 value 延后 24 小时的 Date，而 previousValue 则生成一个提前 24 小时的 Date。

calendarField 的合法值为：

  • Calendar.ERA
  • Calendar.YEAR
  • Calendar.MONTH
  • Calendar.WEEK_OF_YEAR
  • Calendar.WEEK_OF_MONTH
  • Calendar.DAY_OF_MONTH
  • Calendar.DAY_OF_YEAR
  • Calendar.DAY_OF_WEEK
  • Calendar.DAY_OF_WEEK_IN_MONTH
  • Calendar.AM_PM
  • Calendar.HOUR
  • Calendar.HOUR_OF_DAY
  • Calendar.MINUTE
  • Calendar.SECOND
  • Calendar.MILLISECOND
但是有些 UI 可能在向光标下旋转字段提交编辑之前设置 calendarField。如果只希望旋转一个字段，则可以为 setCalendarField 调用创建子类并忽略 setCalendarField 调用。

此模型继承一个 ChangeListener。每当模型 value、calendarField、start 或 end 属性发生变化时，该 ChangeListeners 就会收到通知。

从以下版本开始：
1.4
另请参见：
JSpinner, SpinnerModel, AbstractSpinnerModel, SpinnerListModel, SpinnerNumberModel, Calendar.add(int, int)

字段摘要
从类 javax.swing.AbstractSpinnerModel 继承的字段
listenerList
构造方法摘要
SpinnerDateModel()
构造一个 SpinnerDateModel，其初始 value 为当前日期，calendarField 等于 Calendar.DAY_OF_MONTH，且没有 start/end 限制。
SpinnerDateModel(Date value, Comparable start, Comparable end, int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。
方法摘要
int | getCalendarField() 返回由 nextValue 和 previousValue 方法添加或去掉的 Calendar 字段。
Date | getDate() 返回此 Date 序列中的当前元素。
Comparable | getEnd() 返回序列中的最后一个 Date。
Object | getNextValue() 返回序列中的下一个 Date，如果下一个日期在 end 之后，则返回 null。
Object | getPreviousValue() 返回序列中上一个 Date，如果上一个日期是在 start 之前，则返回 null。
Comparable | getStart() 返回序列中的第一个 Date。
Object | getValue() 返回此 Date 序列中的当前元素。
void | setCalendarField(int calendarField) 更改由 nextValue 和 previousValue 方法计算的日期值更改的大小。
void | setEnd(Comparable end) 更改此序列中 Date 的上限。
void | setStart(Comparable start) 更改此序列中的日期下限。
void | setValue(Object value) 设置此序列的当前 Date。
从类 javax.swing.AbstractSpinnerModel 继承的方法
addChangeListener, fireStateChanged, getChangeListeners, getListeners, removeChangeListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SpinnerDateModel

public SpinnerDateModel(Date value,
                        Comparable start,
                        Comparable end,
                        int calendarField)
创建一个表示 start 和 end 之间的日期序列的 SpinnerDateModel。nextValue 和 previousValue 方法通过向前或向后调整由 calendarField 时间单位表示的当前日期 value 计算该序列的元素。有关增加或减少 Calendar field 的含义的精确描述，请参阅 java.util.Calendar 中的 add 方法。

start 和 end 参数可以为 null，以指示该范围没有上下边界。如果 value 或 calendarField 为 null，或者指定了 start 和 end 且其值为 mininum > maximum，则抛出一个 IllegalArgumentException。同样，如果 (minimum <= value <= maximum) 为 false，则抛出一个 IllegalArgumentException。

参数：
value - 该模型的当前（非 null）值
start - 该序列中的第一个日期，或 null
end - 该序列中的最后一个日期，或 null
calendarField - 该参数为下列值之一
  • Calendar.ERA
  • Calendar.YEAR
  • Calendar.MONTH
  • Calendar.WEEK_OF_YEAR
  • Calendar.WEEK_OF_MONTH
  • Calendar.DAY_OF_MONTH
  • Calendar.DAY_OF_YEAR
  • Calendar.DAY_OF_WEEK
  • Calendar.DAY_OF_WEEK_IN_MONTH
  • Calendar.AM_PM
  • Calendar.HOUR
  • Calendar.HOUR_OF_DAY
  • Calendar.MINUTE
  • Calendar.SECOND
  • Calendar.MILLISECOND
抛出：
IllegalArgumentException - 如果 value 或 calendarField 为 null，如果 calendarField 无效，或者下面的表达式为 false：(start <= value <= end)。
另请参见：
Calendar.add(int, int),
setValue(java.lang.Object),
setStart(java.lang.Comparable),
setEnd(java.lang.Comparable),
setCalendarField(int)

SpinnerDateModel

public SpinnerDateModel()
构造一个 SpinnerDateModel，其初始 value 为当前日期，calendarField 等于 Calendar.DAY_OF_MONTH，且没有 start/end 限制。

方法详细信息

setStart

public void setStart(Comparable start)
更改此序列中的日期下限。如果 start 为 null，则不存在下限。此处不进行边界检查：新起始值可能会使该构造方法强制执行的 (start <= value <= end) 不变式失效。这是为了简化对该模型的更新。很自然，调用 nextValue、previousValue 或 setValue 方法之前应该确保该不变式为 true。

该属性通常是一个 Date，但是它可以使用一个具有用于 Date 的 compareTo 方法的 Comparable。例如，start 可以是一个下列形式的类的实例：

 MyStartDate implements Comparable {
     long t = 12345;
     public int compareTo(Date d) {
            return (t < d.getTime() ? -1 : (t == d.getTime() ? 0 : 1));
     }
     public int compareTo(Object o) {
            return compareTo((Date)o);
     }
 }
注意，如果传递给 compareTo(Object) 的 Object 不是 Date，则上面的示例将抛出一个 ClassCastException。

如果 start 已经更改，则此方法会触发一个 ChangeEvent。

参数：
start - 定义序列中的第一个日期
另请参见：
getStart(),
setEnd(java.lang.Comparable),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

getStart

public Comparable getStart()
返回序列中的第一个 Date。

返回：
start 属性的值
另请参见：
setStart(java.lang.Comparable)

setEnd

public void setEnd(Comparable end)
更改此序列中 Date 的上限。如果 start 为 null，则不存在上限。此处不进行边界检查：新起始值可能会使该构造方法强制执行的 (start <= value <= end) 不变式失效。这是为了简化对该模型的更新。很自然，调用 nextValue、previousValue 或 setValue 方法之前应该确保该不变式为 true。

该属性通常是一个 Date，但是它可以使用一个具有用于 Date 的 compareTo 方法的 Comparable。请参见 setStart 以获得一个示例。

如果 end 已经更改，则此方法会触发一个 ChangeEvent。

参数：
end - 定义序列中的最后一个日期
另请参见：
getEnd(),
setStart(java.lang.Comparable),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

getEnd

public Comparable getEnd()
返回序列中的最后一个 Date。

返回：
end 属性的值
另请参见：
setEnd(java.lang.Comparable)

setCalendarField

public void setCalendarField(int calendarField)
更改由 nextValue 和 previousValue 方法计算的日期值更改的大小。calendarField 参数必须是其中一个 Calendar 字段常量，如 Calendar.MONTH 或 Calendar.MINUTE。nextValue 和 previousValue 方法使用 Calendar.add 方法将指定 Calendar 字段只向前或向后移动一个单位。要慎重使用此方法，因为有些 UI 可能在向光标下旋转字段提交编辑之前设置 calendarField。如果只希望旋转一个字段，则可以为 setCalendarField 调用创建子类并忽略 setCalendarField 调用。

参数：
calendarField - 该参数为下列值之一
  • Calendar.ERA
  • Calendar.YEAR
  • Calendar.MONTH
  • Calendar.WEEK_OF_YEAR
  • Calendar.WEEK_OF_MONTH
  • Calendar.DAY_OF_MONTH
  • Calendar.DAY_OF_YEAR
  • Calendar.DAY_OF_WEEK
  • Calendar.DAY_OF_WEEK_IN_MONTH
  • Calendar.AM_PM
  • Calendar.HOUR
  • Calendar.HOUR_OF_DAY
  • Calendar.MINUTE
  • Calendar.SECOND
  • Calendar.MILLISECOND

如果 calendarField 已经更改，则此方法会触发一个 ChangeEvent。

另请参见：
getCalendarField(),
getNextValue(),
getPreviousValue(),
Calendar.add(int, int),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

getCalendarField

public int getCalendarField()
返回由 nextValue 和 previousValue 方法添加或去掉的 Calendar 字段。

返回：
calendarField 属性的值
另请参见：
setCalendarField(int)

getNextValue

public Object getNextValue()
返回序列中的下一个 Date，如果下一个日期在 end 之后，则返回 null。

指定者：
接口 SpinnerModel 中的 getNextValue
返回：
序列中的下一个 Date，如果下一个日期是在 end 之后，则返回 null。
另请参见：
SpinnerModel.getNextValue(),
getPreviousValue(),
setCalendarField(int)

getPreviousValue

public Object getPreviousValue()
返回序列中上一个 Date，如果上一个日期是在 start 之前，则返回 null。

指定者：
接口 SpinnerModel 中的 getPreviousValue
返回：
序列中上一个 Date，如果上一个日期在 start 之前，则返回 null
另请参见：
SpinnerModel.getPreviousValue(),
getNextValue(),
setCalendarField(int)

getDate

public Date getDate()
返回此 Date 序列中的当前元素。此方法等效于 (Date)getValue。

返回：
value 属性
另请参见：
setValue(java.lang.Object)

getValue

public Object getValue()
返回此 Date 序列中的当前元素。

指定者：
接口 SpinnerModel 中的 getValue
返回：
value 属性
另请参见：
setValue(java.lang.Object), getDate()

setValue

public void setValue(Object value)
设置此序列的当前 Date。如果 value 为 null，则抛出一个 IllegalArgumentException。此处不进行边界检查：新值可能会使该构造方法强制执行的 (start <= value < end) 不变式失效。很自然，调用 nextValue、previousValue 或 setValue 方法之前应该确保 (start <= value <= maximum) 不变式为 true。

如果 value 已经更改，则此方法会触发一个 ChangeEvent。

指定者：
接口 SpinnerModel 中的 setValue
参数：
value - 此序列的当前（非 null）Date
抛出：
IllegalArgumentException - 如果值为 null 或不是一个 Date
另请参见：
getDate(),
getValue(),
AbstractSpinnerModel.addChangeListener(javax.swing.event.ChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpinnerListModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SpinnerListModel

java.lang.Object
    继承者  javax.swing.AbstractSpinnerModel
        继承者  javax.swing.SpinnerListModel
所有已实现的接口：
Serializable, SpinnerModel
public class SpinnerListModel
extends AbstractSpinnerModel
implements Serializable

其值由数组或 List 定义的 SpinnerModel 的简单实现。例如，创建一个由一周几天的名称数组定义的模型：

 String[] days = new DateFormatSymbols().getWeekdays();
 SpinnerModel model = new SpinnerListModel(Arrays.asList(days).subList(1, 8));
此类只存储对该数组或 List 的引用，所以，如果基础序列的元素发生变化，则应用程序有责任通过调用 fireStateChanged 通知 ChangeListeners。

此模型继承的是一个 ChangeListener。每当该模型的 value 或 list 属性发生变化时，就会通知 ChangeListener。

从以下版本开始：
1.4
另请参见：
JSpinner, SpinnerModel, AbstractSpinnerModel, SpinnerNumberModel, SpinnerDateModel

字段摘要
从类 javax.swing.AbstractSpinnerModel 继承的字段
listenerList
构造方法摘要
SpinnerListModel()
创建一个实际为空的 SpinnerListModel。
SpinnerListModel(List<?> values)
构造一个由指定 List 定义其值序列的 SpinnerModel。
SpinnerListModel(Object[] values)
构造一个由指定数组定义其值序列的 SpinnerModel。
方法摘要
List<?> | getList() 返回定义此模型的序列的 List。
Object | getNextValue() 返回基础序列的下一个合法值，如果值已经是最后一个元素，则返回 null。
Object | getPreviousValue() 返回该基础序列的前一个元素，如果值已经是第一个元素，则返回 null。
Object | getValue() 返回该序列的当前元素。
void | setList(List<?> list) 更改定义此序列的列表，并将该模型 value 的索引重新设置为零。
void | setValue(Object elt) 改变该序列的当前元素并通知 ChangeListeners。
从类 javax.swing.AbstractSpinnerModel 继承的方法
addChangeListener, fireStateChanged, getChangeListeners, getListeners, removeChangeListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SpinnerListModel

public SpinnerListModel(List<?> values)
构造一个由指定 List 定义其值序列的 SpinnerModel。该模型的初始值（当前元素）将为 values.get(0)。如果 values 为 null 或具有零大小，则抛出一个 IllegalArugmentException。

参数：
values - 此模型表示的序列
抛出：
IllegalArugmentException - 如果 values 为 null 或零大小

SpinnerListModel

public SpinnerListModel(Object[] values)
构造一个由指定数组定义其值序列的 SpinnerModel。该模型的初始值将为 values[0]。如果 values 为 null 或具有零长度，则抛出一个 IllegalArugmentException。

参数：
values - 此模型表示的序列
抛出：
IllegalArugmentException - 如果 values 为 null 或零长度

SpinnerListModel

public SpinnerListModel()
创建一个实际为空的 SpinnerListModel。该模型的列表将包含单个的 "empty" 字符串元素。

方法详细信息

getList

public List<?> getList()
返回定义此模型的序列的 List。

返回：
该 list 属性的值
另请参见：
setList(java.util.List)

setList

public void setList(List<?> list)
更改定义此序列的列表，并将该模型 value 的索引重新设置为零。注意，不复制 list，该模型只存储对它的引用。

如果 list 不等于当前列表，则此方法激发一个 ChangeEvent。

参数：
list - 此模型表示的序列
抛出：
IllegalArgumentException - 如果 list 为 null 或零长度
另请参见：
getList()

getValue

public Object getValue()
返回该序列的当前元素。

指定者：
接口 SpinnerModel 中的 getValue
返回：
该 value 属性
另请参见：
SpinnerModel.getValue(), setValue(java.lang.Object)

setValue

public void setValue(Object elt)
改变该序列的当前元素并通知 ChangeListeners。如果指定值不等于基础序列的元素，则抛出一个 IllegalArgumentException。在以下示例中，该 setValue 调用会抛出一个异常：
 String[] values = {"one", "two", "free", "four"};
 SpinnerModel model = new SpinnerListModel(values);
 model.setValue("TWO");

指定者：
接口 SpinnerModel 中的 setValue
参数：
elt - 将作为模型当前值的序列元素
抛出：
IllegalArgumentException - 如果不允许指定值
另请参见：
SpinnerModel.setValue(java.lang.Object), getValue()

getNextValue

public Object getNextValue()
返回基础序列的下一个合法值，如果值已经是最后一个元素，则返回 null。

指定者：
接口 SpinnerModel 中的 getNextValue
返回：
该基础序列的下一个合法值，或返回 null 如果值已经是最后一个元素
另请参见：
SpinnerModel.getNextValue(), getPreviousValue()

getPreviousValue

public Object getPreviousValue()
返回该基础序列的前一个元素，如果值已经是第一个元素，则返回 null。

指定者：
接口 SpinnerModel 中的 getPreviousValue
返回：
该基础序列的前一个元素，如果值已经是第一个元素，则返回 null
另请参见：
SpinnerModel.getPreviousValue(), getNextValue()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpinnerModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 SpinnerModel

所有已知实现类：
AbstractSpinnerModel, SpinnerDateModel, SpinnerListModel, SpinnerNumberModel
public interface SpinnerModel

对象值的潜在无界序列的模型。此模型类似于 ListModel，但是有以下一些重要区别：

  • 序列元素数不一定是有界的。
  • 该模型不支持对序列元素的索引随机存取。一次只有以下三个序列值可以存取：当前值、下一个值和前一个值。
  • 可以设置当前序列元素。

SpinnerModel 有三个属性，只有第一个是读/写属性。

value
该序列的当前元素。
nextValue
下一个元素，如果 value 是该序列的最后一个元素，则为 null。
previousValue
前一个元素，如果 value 是该序列的第一个元素，则为 null。
当 value 属性更改时，将通知 ChangeListeners。在其他情况下，SpinnerModel 可以选择通知 ChangeListeners。

从以下版本开始：
1.4
另请参见：
JSpinner, AbstractSpinnerModel, SpinnerListModel, SpinnerNumberModel, SpinnerDateModel

方法摘要
 void addChangeListener(ChangeListener l)
向该模型的侦听器列表添加一个 ChangeListener。
 Object getNextValue()
返回该序列中出现在 getValue() 返回的对象之后的对象。
 Object getPreviousValue()
返回该序列中出现在 getValue() 返回的对象之前的对象。
 Object getValue()
该序列的当前元素。
 void removeChangeListener(ChangeListener l)
从该模型的侦听器列表移除一个 ChangeListener。
 void setValue(Object value)
改变该模型的当前值，通常此值由 JSpinner 的 editor 部分显示。

方法详细信息

getValue

Object getValue()
该序列的当前元素。此元素通常由 JSpinner 的 editor 部分显示。

返回：
当前的 spinner 值。
另请参见：
setValue(java.lang.Object)

setValue

void setValue(Object value)
改变该模型的当前值，通常此值由 JSpinner 的 editor 部分显示。如果 SpinnerModel 实现不支持指定值，则抛出一个 IllegalArgumentException。例如，数字的 SpinnerModel 可能只支持 10 的整数倍的值。在这种情况下，model.setValue(new Number(11)) 将抛出一个异常。

抛出：
IllegalArgumentException - 如果不允许 value
另请参见：
getValue()

getNextValue

Object getNextValue()
返回该序列中出现在 getValue() 返回的对象之后的对象。如果已到达该序列的结尾，则返回 null。调用此方法不会影响 value。

返回：
下一个合法值，如果一个也不存在，则返回 null
另请参见：
getValue(), getPreviousValue()

getPreviousValue

Object getPreviousValue()
返回该序列中出现在 getValue() 返回的对象之前的对象。如果已到达该序列的结尾，则返回 null。调用此方法不会影响 value。

返回：
前一个合法值，如果一个也不存在，则返回 null
另请参见：
getValue(), getNextValue()

addChangeListener

void addChangeListener(ChangeListener l)
向该模型的侦听器列表添加一个 ChangeListener。模型 value 变化时，必须通知该 ChangeListeners。

参数：
l - 要添加的 ChangeListener
另请参见：
removeChangeListener(javax.swing.event.ChangeListener)

removeChangeListener

void removeChangeListener(ChangeListener l)
从该模型的侦听器列表移除一个 ChangeListener。

参数：
l - 要移除的 ChangeListener
另请参见：
addChangeListener(javax.swing.event.ChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpinnerNumberModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SpinnerNumberModel

java.lang.Object
    继承者  javax.swing.AbstractSpinnerModel
        继承者  javax.swing.SpinnerNumberModel
所有已实现的接口：
Serializable, SpinnerModel
public class SpinnerNumberModel
extends AbstractSpinnerModel
implements Serializable

用于数字序列的 SpinnerModel。该序列的上下边界由名为 minimum 和 maximum 的属性定义。nextValue 和 previousValue 方法计算的增加或减少的大小由名为 stepSize 的属性定义。该 minimum 和 maximum 属性可以为 null，指示该序列没有下限和上限。此类中的所有属性都根据以下两个一般类型定义：Number 和 Comparable，以便适应所有 Java 数字类型。在内部，仅支持其类型为以下某个基本 Number 类型的值：Double、Float、Long、Integer、Short 或 Byte。

要创建从 0 到 100 整数范围（初始值为 50）的 SpinnerNumberModel，可以写入：

 Integer value = new Integer(50);
Integer min = new Integer(0);
 Integer max = new Integer(100);
 Integer step = new Integer(1);
 SpinnerNumberModel model = new SpinnerNumberModel(value, min, max, step);
 int fifty = model.getNumber().intValue();

Integer 和 double 的 spinner 是很常见的，因此提供了针对这些情况的特殊构造方法。例如，要创建前一示例中的模式，也可以写入：

 SpinnerNumberModel model = new SpinnerNumberModel(50, 0, 100, 1);

此模式继承的是一个 ChangeListener。每当该模式的 value、stepSize、minimum 或 maximum 属性发生变化时，就会通知该 ChangeListeners。

从以下版本开始：
1.4
另请参见：
JSpinner, SpinnerModel, AbstractSpinnerModel, SpinnerListModel, SpinnerDateModel

字段摘要
从类 javax.swing.AbstractSpinnerModel 继承的字段
listenerList
构造方法摘要
SpinnerNumberModel()
构造一个没有 minimum 或 maximum 值、stepSize 等于 1 且初始值为零的 SpinnerNumberModel。
SpinnerNumberModel(double value, double minimum, double maximum, double stepSize)
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。
SpinnerNumberModel(int value, int minimum, int maximum, int stepSize)
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。
SpinnerNumberModel(Number value, Comparable minimum, Comparable maximum, Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。
方法摘要
Comparable | getMaximum() 返回该序列中的最后一个数字。
Comparable | getMinimum() 返回此序列中的第一个数字。
Object | getNextValue() 返回该序列中的下一个数字。
Number | getNumber() 返回该序列的当前元素的值。
Object | getPreviousValue() 返回该序列中的上一个数字。
Number | getStepSize() 返回由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。
Object | getValue() 返回该序列的当前元素的值。
void | setMaximum(Comparable maximum) 更改此序列中数字的上边界。
void | setMinimum(Comparable minimum) 更改此序列中数字的下边界。
void | setStepSize(Number stepSize) 更改由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。
void | setValue(Object value) 设置此序列的当前元素。
从类 javax.swing.AbstractSpinnerModel 继承的方法
addChangeListener, fireStateChanged, getChangeListeners, getListeners, removeChangeListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SpinnerNumberModel

public SpinnerNumberModel(Number value,
                          Comparable minimum,
                          Comparable maximum,
                          Number stepSize)
构造一个表示从 minimum 到 maximum 的闭区间数字序列的 SpinnerModel。nextValue 和 previousValue 方法通过分别添加或减去 stepSize 计算该序列的元素。所有参数必须是相互 Comparable 的，value 和 stepSize 必须是 Integer Long、Float 或 Double 的实例。

该 minimum 和 maximum 参数可以为 null，指示该范围没有上下边界。如果 value 或 stepSize 为 null，或者 minimum 和 maximum 两者都是指定值，且 mininum > maximum，则抛出一个 IllegalArgumentException。同样，如果 (minimum <= value <= maximum) 为 false，则抛出一个 IllegalArgumentException。

参数：
value - 该模式的当前（非 null）值
minimum - 该序列中第一个数或 null
maximum - 该序列中的最后一个数或 null
stepSize - 该序列中元素之间的区别
抛出：
IllegalArgumentException - 如果 stepSize 或值为 null，或者以下表达式为 false：minimum <= value <= maximum

SpinnerNumberModel

public SpinnerNumberModel(int value,
                          int minimum,
                          int maximum,
                          int stepSize)
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。

参数：
value - 该模式的当前值
minimum - 该序列中的第一个数
maximum - 该序列中的最后一个数
stepSize - 该序列中元素之间的区别
抛出：
IllegalArgumentException - 如果以下表达式为 false：minimum <= value <= maximum

SpinnerNumberModel

public SpinnerNumberModel(double value,
                          double minimum,
                          double maximum,
                          double stepSize)
构造一个具有指定 value、minimum/maximum 边界和 stepSize 的 SpinnerNumberModel。

参数：
value - 该模式的当前值
minimum - 该序列中的第一个数
maximum - 该序列中的最后一个数
stepSize - 该序列中元素之间的区别
抛出：
IllegalArgumentException - 如果以下表达式为 false：minimum <= value <= maximum

SpinnerNumberModel

public SpinnerNumberModel()
构造一个没有 minimum 或 maximum 值、stepSize 等于 1 且初始值为零的 SpinnerNumberModel。

方法详细信息

setMinimum

public void setMinimum(Comparable minimum)
更改此序列中数字的下边界。如果 minimum 为 null，则不存在下边界。此处不进行边界检查；新 minimum 值可能会使该构造方法强制执行的 (minimum <= value <= maximum) 等式失效。这样可以简化更新该模式，调用 getNextValue、getPreviousValue 或 setValue 方法之前自然应该确保该等式为 true。

通常，此属性是一个与 value 同一类型的 Number，但是，与该值同一类型 Number 可以使用具有 compareTo 方法的任何 Comparable。例如，如果值为 Long，则 minimum 可能是一个这样定义的 Date 子类：

 MyDate extends Date {  // Date already implements Comparable
     public int compareTo(Long o) {
         long t = getTime();
         return (t < o.longValue() ? -1 : (t == o.longValue() ? 0 : 1));
     }
 }

如果 minimum 已经更改，则此方法会激发一个 ChangeEvent。

参数：
minimum - 一个 Comparable，它具有与 value 同一类型的 Number 的 compareTo 方法
另请参见：
getMinimum(),
setMaximum(java.lang.Comparable),
SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

getMinimum

public Comparable getMinimum()
返回此序列中的第一个数字。

返回：
该 minimum 属性的值
另请参见：
setMinimum(java.lang.Comparable)

setMaximum

public void setMaximum(Comparable maximum)
更改此序列中数字的上边界。如果 maximum 为 null，则不存在上边界。此处不进行边界检查；新 maximum 值可能会使该构造方法强制执行的 (minimum <= value < maximum) 等式失效。这样可以简化更新该模式，调用 next、previous 或 setValue 方法之前自然应该确保该等式为 true。

通常，此属性是一个与 value 同一类型的 Number，但是，与该值同一类型 Number 可以使用具有 compareTo 方法的任何 Comparable。有关示例，请参阅 setMinimum。

如果 maximum 已经更改，则此方法会激发一个 ChangeEvent。

参数：
maximum - 一个 Comparable，它具有与 value 同一类型的 Number 的 compareTo 方法
另请参见：
setMinimum(java.lang.Comparable), SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

getMaximum

public Comparable getMaximum()
返回该序列中的最后一个数字。

返回：
该 maximum 属性的值
另请参见：
setMaximum(java.lang.Comparable)

setStepSize

public void setStepSize(Number stepSize)
更改由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。如果 stepSize 为 null，则抛出一个 IllegalArgumentException。

如果 stepSize 已经更改，则此方法会激发一个 ChangeEvent。

参数：
stepSize - 由 getNextValue 和 getPreviousValue 方法计算的值更改的大小
另请参见：
getNextValue(),
getPreviousValue(),
getStepSize(),
SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)

getStepSize

public Number getStepSize()
返回由 getNextValue 和 getPreviousValue 方法计算的值更改的大小。

返回：
该 stepSize 属性的值
另请参见：
setStepSize(java.lang.Number)

getNextValue

public Object getNextValue()
返回该序列中的下一个数字。

指定者：
接口 SpinnerModel 中的 getNextValue
返回：
value + stepSize，如果和超过 maximum，则返回 null。
另请参见：
SpinnerModel.getNextValue(),
getPreviousValue(),
setStepSize(java.lang.Number)

getPreviousValue

public Object getPreviousValue()
返回该序列中的上一个数字。

指定者：
接口 SpinnerModel 中的 getPreviousValue
返回：
value - stepSize，如果和小于 minimum，则返回 null。
另请参见：
SpinnerModel.getPreviousValue(),
getNextValue(),
setStepSize(java.lang.Number)

getNumber

public Number getNumber()
返回该序列的当前元素的值。

返回：
值属性
另请参见：
setValue(java.lang.Object)

getValue

public Object getValue()
返回该序列的当前元素的值。

指定者：
接口 SpinnerModel 中的 getValue
返回：
值属性
另请参见：
setValue(java.lang.Object), getNumber()

setValue

public void setValue(Object value)
设置此序列的当前元素。如果 value 为 null，或不为 Number，则抛出一个 IllegalArgumentException。此处不进行边界检查；新值可能会使该构造方法强制执行的 (minimum <= value <= maximum) 等式失效。还可以将该值设置为不会在该序列中自然出现的值，即一个不以 stepSize 为模的值。这样做是为了简化更新该模式，也是为了适应不希望限制由用户直接输入的值的 spinner。很自然，调用 next、previous 或 setValue 方法之前应该确保 (minimum <= value <= maximum) 等式为 true。

如果该值已更改，则此方法会激发一个 ChangeEvent。

指定者：
接口 SpinnerModel 中的 setValue
参数：
value - 此序列的当前（非 null）Number
抛出：
IllegalArgumentException - 如果 value 为 null 或不为 Number
另请参见：
getNumber(),
getValue(),
SpinnerModel.addChangeListener(javax.swing.event.ChangeListener)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Spring (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Spring

java.lang.Object
    继承者  javax.swing.Spring

public abstract class Spring
extends Object

该 Spring 类的实例将存储以下三个表示其行为特征的属性：minimum、preferred 和 maximum 值。根据一系列规则定义其第四个 value 属性时可能涉及其中每一个属性。

该 Spring 类的实例就像从其首选值进行压缩或伸展的 spring 一样，显示为一个提供回复力的机械弹簧。此回复力被建模为从首选值开始的距离的线性函数，但有两个不同的常量 - 一个是压缩力常量，一个是张力常量。这些常量由 spring 的最小值和最大值指定，这样处于最小值的 spring 产生一个与其处于最大值时创建的力相等且相对的力。因此，preferred 和 minimum 值之间的区别表示使用该值压缩 spring 的容易性，其 maximum 和 preferred 值之间的区别指示使用该值扩展 Spring 的容易性。有关详细信息，请参阅 sum(javax.swing.Spring, javax.swing.Spring) 方法。

通过在 Spring 上定义简单的算术运算，可以将 Spring 集合的行为减少到普通（非复合）Spring 的行为。我们在 Spring 上定义 "+"、"-"、max 和 min 运算符，以便每种情况下的结果都是一个 Spring，其特征是将一个有用的数学关系用于其组成的 spring。

一个 Spring 可以视为一对具有以下单个公共点的区间：首选值。以下规则定义一些可以应用于区间（[a, b] 指从 a 到 b 的区间，其中 a <= b）的算术运算符。

          [a1, b1] + [a2, b2] = [a1 + a2, b1 + b2]

                      -[a, b] = [-b, -a]

      max([a1, b1], [a2, b2]) = [max(a1, a2), max(b1, b2)]

如果我们将 Spring 表示为 [a, b, c]（其中 a <= b <= c），则我们可以在 Spring 上定义以下相同的算术运算符：

          [a1, b1, c1] + [a2, b2, c2] = [a1 + a2, b1 + b2, c1 + c2]

                           -[a, b, c] = [-c, -b, -a]

      max([a1, b1, c1], [a2, b2, c2]) = [max(a1, a2), max(b1, b2), max(c1, c2)]

通过这些区间和 Spring，我们可以根据以下相反数定义 "-" 和 min：

      X - Y = X + (-Y)

      min(X, Y) = -max(-X, -Y)

对于此类中包含算术运算符的静态方法，我们不会像在调用此静态方法时对该方法参数的属性值进行快照一样实际执行相关的操作。相反，该静态方法创建一个新 Spring 实例，该实例包含对该方法参数的引用，以便新 spring 的特征跟踪原来生成它的 spring 的潜在不断变化的特征。这有点类似于函数性语言中 lazy value 的概念。

如果您正在实现一个 SpringLayout，则可以在 The Java Tutorial 中的 How to Use SpringLayout 一节找到更详细的信息和示例。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4
另请参见：
SpringLayout, SpringLayout.Constraints

字段摘要
static int UNSET
一个表示属性值尚未计算的整数值。
构造方法摘要
protected Spring()
由工厂方法创建 Spring 时使用。
方法摘要
static Spring constant(int pref)
返回一个 strut -- 一个其 minimum、preferred 和 maximum 值每个都有值 pref 的 spring。
static Spring constant(int min, int pref, int max)
返回一个其 minimum、preferred 和 maximum 值具有以下值的 spring：分别是 min、pref 和 max。
abstract  int getMaximumValue()
返回此 Spring 的 maximum 值。
abstract  int getMinimumValue()
返回此 Spring 的 minimum 值。
abstract  int getPreferredValue()
返回此 Spring 的 preferred 值。
abstract  int getValue()
返回此 Spring 的当前 value。
static Spring height(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。
static Spring max(Spring s1, Spring s2)
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。
static Spring minus(Spring s)
返回 -s：一个以与 s 相反方向运行的 spring。
static Spring scale(Spring s, float factor)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。
abstract  void setValue(int value)
将此 Spring 的当前 value 设置为 value。
static Spring sum(Spring s1, Spring s2)
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。
static Spring width(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

UNSET

public static final int UNSET
一个表示属性值尚未计算的整数值。

另请参见：
常量字段值
构造方法详细信息

Spring

protected Spring()
由工厂方法创建 Spring 时使用。

另请参见：
constant(int),
constant(int, int, int),
max(javax.swing.Spring, javax.swing.Spring),
minus(javax.swing.Spring),
sum(javax.swing.Spring, javax.swing.Spring),
SpringLayout.Constraints
方法详细信息

getMinimumValue

public abstract int getMinimumValue()
返回此 Spring 的 minimum 值。

返回：
此 Spring 的 minimumValue 属性

getPreferredValue

public abstract int getPreferredValue()
返回此 Spring 的 preferred 值。

返回：
此 Spring 的 preferredValue

getMaximumValue

public abstract int getMaximumValue()
返回此 Spring 的 maximum 值。

返回：
此 Spring 的 maximumValue 属性

getValue

public abstract int getValue()
返回此 Spring 的当前 value。

返回：
此 Spring 的 value 属性
另请参见：
setValue(int)

setValue

public abstract void setValue(int value)
将此 Spring 的当前 value 设置为 value。

参数：
value - 该 value 属性的新设置值
另请参见：
getValue()

constant

public static Spring constant(int pref)
返回一个 strut -- 一个其 minimum、preferred 和 maximum 值每个都有值 pref 的 spring。

参数：
pref - 该新 spring 的 minimum、preferred 和 maximum 值
返回：
一个其 minimum、preferred 和 maximum 值每个都有值 pref 的 spring
另请参见：
Spring

constant

public static Spring constant(int min,
                              int pref,
                              int max)
返回一个其 minimum、preferred 和 maximum 值具有以下值的 spring：分别是 min、pref 和 max。

参数：
min - 新 spring 的 minimum 值
pref - 新 spring 的 preferred 值
max - 新 spring 的 maximum 值
返回：
一个其 minimum、preferred 和 maximum 值具有以下值的 spring：分别是 min、pref 和 max
另请参见：
Spring

minus

public static Spring minus(Spring s)
返回 -s：一个以与 s 相反方向运行的 spring。

返回：
-s：一个以与 s 相反方向运行的 spring
另请参见：
Spring

sum

public static Spring sum(Spring s1,
                         Spring s2)
返回 s1+s2：一个连续表示 s1 和 s2 的 spring。从总数上说，s3 等于两个 spring s1 和 s2，s1、s2 和 s3 的 strains 在同一个级别（它们的整数 value 暗示的精度内）上进行维护。压缩形式下的 spring 的 strain 为：
         value - pref
         ------------
          pref - min
伸展形式下的 spring 的 strain 为：
         value - pref
         ------------
          max - pref
在对总共 spring（也即 s3）调用 setValue 时，使用上述某个公式计算 s3 中的 strain。一旦知道了总共的 strain，就能设置 s1 和 s2 的 value，以使它们的 strain 与总共的 strain 相等。对这些公式进行评诂，以便将舍入错误考虑在内并确保 s1 和 s2 的 value 值的总和正好与 s3 的 value 相等。

返回：
s1+s2：一个连续表示 s1 和 s2 的 spring
另请参见：
Spring

max

public static Spring max(Spring s1,
                         Spring s2)
返回 max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring。

返回：
max(s1, s2)：一个其值始终大于（或等于）s1 加 s2 的值的 spring
另请参见：
Spring

scale

public static Spring scale(Spring s,
                           float factor)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性都是参数 spring s 的属性的倍数。当 factor 为负（根据间隔算法规则）时，Minimum 和 maximum 属性可以交换。

例如，当因子为 0.5f 时，该结果表示此输入的“中点” - 一种对居中容器中组件很有用的操作。

参数：
s - 要缩放的 spring
factor - 要缩放的量。
返回：
一个 spring，其属性为输入 spring s 乘以 factor 得到的值
抛出：
NullPointerException - 如果 s 为 null
从以下版本开始：
1.5

width

public static Spring width(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的宽度定义。返回的 spring 是一个“包装器”实现，其方法调用所提供组件的适当大小方法。因此，返回的 spring 的最小、首选、最大和值属性将报告组件中适当属性的当前状态，并在它们发生更改时进行跟踪。

参数：
c - 用于计算大小的组件
返回：
一个 spring，其属性由该组件大小方法的水平组件定义。
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.5

height

public static Spring height(Component c)
返回一个 spring，其 minimum、preferred、maximum 和 value 属性由所提供组件的 minimumSize、preferredSize、maximumSize 和 size 属性的高度定义。返回的 spring 是一个“包装器”实现，其方法调用所提供组件的适当大小方法。因此，返回的 spring 的最小、首选、最大和值属性将报告组件中适当属性的当前状态，并在它们发生更改时进行跟踪。

参数：
c - 用于计算大小的组件
返回：
一个 spring，其属性由该组件大小方法的垂直组件定义。
抛出：
NullPointerException - 如果 c 为 null
从以下版本开始：
1.5
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpringLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SpringLayout

java.lang.Object
    继承者  javax.swing.SpringLayout
所有已实现的接口：
LayoutManager, LayoutManager2
public class SpringLayout
extends Object
implements LayoutManager2

SpringLayout 根据一组约束布置其相关容器的子组件。有关使用 SpringLayout 的示例，请参阅 The Java Tutorial 中的 How to Use SpringLayout 一节。

每个由 Spring 对象表示的约束控制着两个组件边之间的垂直距离或水平距离。这两个边属于容器的任一子级，或属于该容器本身。例如，可以使用控制某组件东（右）和西（左）边之间距离的约束表示该组件允许的宽度。某个组件所允许的 y 坐标可以通过约束该组件北（上）边和其容器的北边之间的距离表示。

SpringLayout 控制的容器的每个子级及其容器本身都有一组与其相关的约束。这些约束由一个 SpringLayout.Constraints 对象表示。默认情况下，SpringLayout 创建使其相关组件具有最小、首选和最大大小的约束，这几项大小都由该组件的 Component.getMinimumSize()、Component.getPreferredSize() 和 Component.getMaximumSize() 方法返回。x 和 y 的位置最初不受约束，以便在约束它们之前将该 Component 定位在对应于父 Container 的 Insets 的（0,0）位置。

有好几种可以更改组件约束的方式。可以使用某个 putConstraint 方法建立一个连接同一个容器内两个组件边的 spring。或者使用 getConstraints 获取适当 SpringLayout.Constraints，然后修改其中一个或多个 spring。或者使用 getConstraint 获取某个组件特定边的 spring，并修改它。还可以在将某个组件添加到其容器（使用 Container.add(Component, Object)）时，通过指定自己的 SpringLayout.Constraints 对象，将该约束对象与该组件相关联。

表示每项约束的 Spring 对象都有最小、首选、最大和当前值。按照 Spring.sum(javax.swing.Spring, javax.swing.Spring) 方法描述中给定的公式，该 spring 的当前值介于最小值和最大值之间的某个位置。当最小、首选和最大值相同时，当前值始终与它们相等；此不灵活的 spring 被称作 strut。可以使用工厂方法 Spring.constant(int) 创建 strut。该 Spring 类还提供工厂方法，用于创建其他种类的 spring，包括依赖其他 spring 的 spring。

在 SpringLayout 中，每个边的位置只与其他一个边的位置有关。如果随后添加一个约束来创建某个边的新绑定，则以前的绑定会被丢弃，且该边保持与某单个边相关。Spring 只应在容器的两个边及其直接子级之间连接；当出现连接到不同容器（内部或外部）中组件边缘的约束时，该 SpringLayout 的行为是不确定的。

SpringLayout 与其他布局管理器的比较

注：与多数布局管理器不同，SpringLayout 不自动设置它管理的组件的位置。如果手工编写一个使用 SpringLayout 的 GUI，则要记住通过约束东/西和南/北的位置初始化组件的位置。

可能还需要明确设置容器的大小，具体取决于您使用的约束。

尽管 SpringLayout 简单易用，但它还要仿效其他多数布局管理器的行为。对于某些功能（如 FlowLayout 提供的行断开），需要创建一个 Spring 类的专用子类。

SpringLayout 还提供解决许多困难布局问题的方法，这些问题都不能通过嵌套 Box 的组合来解决。也就是说，SpringLayout 完全遵守 LayoutManager2 协定，因此可以使用其他布局管理器进行嵌套（一种创建其他布局管理器使用的约束的更好技术）。

SpringLayout 布局操作的渐进复杂性与约束（和/或组件）的数量呈线关系。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

从以下版本开始：
1.4
另请参见：
Spring, SpringLayout.Constraints

嵌套类摘要
static class SpringLayout.Constraints
Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。
字段摘要
static String | BASELINE 指定组件的基线。
static String | EAST 指定组件的边界矩形的右边。
static String | HEIGHT 指定组件边界矩形的高度。
static String | HORIZONTAL_CENTER 指定组件边界矩形的水平中央位置。
static String | NORTH 指定组件的边界矩形的顶边。
static String | SOUTH 指定组件的边界矩形的底边。
static String | VERTICAL_CENTER 指定组件的边界矩形的垂直中央位置。
static String | WEST 指定组件的边界矩形的左边。
static String | WIDTH 指定组件边界矩形的宽度。
构造方法摘要
SpringLayout()
构造一个新 SpringLayout。
方法摘要
void | addLayoutComponent(Component component, Object constraints) 如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。
void | addLayoutComponent(String name, Component c) 无效，因为此布局管理器不使用每组件字符串。
Spring | getConstraint(String edgeName, Component c) 返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。
SpringLayout.Constraints | getConstraints(Component c) 返回指定组件的约束。
float | getLayoutAlignmentX(Container p) 返回 0.5f（居中）。
float | getLayoutAlignmentY(Container p) 返回 0.5f（居中）。
void | invalidateLayout(Container p) 使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。
void | layoutContainer(Container parent) 布置指定容器。
Dimension | maximumLayoutSize(Container parent) 给定指定容器的组件，计算该容器的最大大小维数。
Dimension | minimumLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的最小大小维数。
Dimension | preferredLayoutSize(Container parent) 给定指定容器所包含的组件，计算该容器的首选大小维数。
void | putConstraint(String e1, Component c1, int pad, String e2, Component c2) 将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。
void | putConstraint(String e1, Component c1, Spring s, String e2, Component c2) 将组件 c1 的边 e1 连接到组件 c2 的边 e2。
void | removeLayoutComponent(Component c) 移除与指定组件相关的约束。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NORTH

public static final String NORTH
指定组件的边界矩形的顶边。

另请参见：
常量字段值

SOUTH

public static final String SOUTH
指定组件的边界矩形的底边。

另请参见：
常量字段值

EAST

public static final String EAST
指定组件的边界矩形的右边。

另请参见：
常量字段值

WEST

public static final String WEST
指定组件的边界矩形的左边。

另请参见：
常量字段值

HORIZONTAL_CENTER

public static final String HORIZONTAL_CENTER
指定组件边界矩形的水平中央位置。

从以下版本开始：
1.6
另请参见：
常量字段值

VERTICAL_CENTER

public static final String VERTICAL_CENTER
指定组件的边界矩形的垂直中央位置。

从以下版本开始：
1.6
另请参见：
常量字段值

BASELINE

public static final String BASELINE
指定组件的基线。

从以下版本开始：
1.6
另请参见：
常量字段值

WIDTH

public static final String WIDTH
指定组件边界矩形的宽度。

从以下版本开始：
1.6
另请参见：
常量字段值

HEIGHT

public static final String HEIGHT
指定组件边界矩形的高度。

从以下版本开始：
1.6
另请参见：
常量字段值
构造方法详细信息

SpringLayout

public SpringLayout()
构造一个新 SpringLayout。

方法详细信息

addLayoutComponent

public void addLayoutComponent(String name,
                               Component c)
无效，因为此布局管理器不使用每组件字符串。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 要与组件关联的字符串
c - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component c)
移除与指定组件相关的约束。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
c - 将从容器中移除的组件

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的最小大小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 要布置的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
从接口 LayoutManager 复制的描述
给定指定容器所包含的组件，计算该容器的首选大小维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 要布置的容器
另请参见：
LayoutManager.minimumLayoutSize(java.awt.Container)

maximumLayoutSize

public Dimension maximumLayoutSize(Container parent)
从接口 LayoutManager2 复制的描述
给定指定容器的组件，计算该容器的最大大小维数。

指定者：
接口 LayoutManager2 中的 maximumLayoutSize
另请参见：
Component.getMaximumSize(), LayoutManager

addLayoutComponent

public void addLayoutComponent(Component component,
                               Object constraints)
如果 constraints 是 SpringLayout.Constraints 的一个实例，则将该约束与指定组件相关联。

指定者：
接口 LayoutManager2 中的 addLayoutComponent
参数：
component - 正添加的组件
constraints - 该组件的约束
另请参见：
SpringLayout.Constraints

getLayoutAlignmentX

public float getLayoutAlignmentX(Container p)
返回 0.5f（居中）。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentX

getLayoutAlignmentY

public float getLayoutAlignmentY(Container p)
返回 0.5f（居中）。

指定者：
接口 LayoutManager2 中的 getLayoutAlignmentY

invalidateLayout

public void invalidateLayout(Container p)
从接口 LayoutManager2 复制的描述
使布局失效，指示如果布局管理器缓存了信息，则应该将其丢弃。

指定者：
接口 LayoutManager2 中的 invalidateLayout

putConstraint

public void putConstraint(String e1,
                          Component c1,
                          int pad,
                          String e2,
                          Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2，边与边之间的距离固定。此约束将导致赋值
     value(e1, c1) = value(e2, c2) + pad
在以后的所有布局操作期间发生。

参数：
e1 - 该 dependent 的边
c1 - 该 dependent 的组件
pad - dependent 和 anchor 之间的固定距离
e2 - 该 anchor 的边
c2 - 该 anchor 的组件
另请参见：
putConstraint(String, Component, Spring, String, Component)

putConstraint

public void putConstraint(String e1,
                          Component c1,
                          Spring s,
                          String e2,
                          Component c2)
将组件 c1 的边 e1 连接到组件 c2 的边 e2。因为边 (e2, c2) 会使值发生变化，所以边 (e1, c1) 将使用 (e2, c2) 加 s 的 (spring) 总和计算。每个边必须具有以下某个值：SpringLayout.NORTH、SpringLayout.SOUTH、SpringLayout.EAST、SpringLayout.WEST、SpringLayout.VERTICAL_CENTER、SpringLayout.HORIZONTAL_CENTER 或 SpringLayout.BASELINE。

参数：
e1 - 该 dependent 的边
c1 - 该 dependent 的组件
s - 连接 dependent 和 anchor 的 spring
e2 - 该 anchor 的边
c2 - 该 anchor 的组件
另请参见：
putConstraint(String, Component, int, String, Component), NORTH, SOUTH, EAST, WEST, VERTICAL_CENTER, HORIZONTAL_CENTER, BASELINE

getConstraints

public SpringLayout.Constraints getConstraints(Component c)
返回指定组件的约束。注意，与 GridBagLayout getConstraints 方法不同，此方法不复制约束。如果没有与此组件相关的约束，则此方法返回一个位置在 0,0 的默认约束对象，此位置相对于父级的 Insets 及其受该组件的最小、最大和首选大小约束的宽度/高度。该大小特征不会在调用此方法时冻结；相反，此方法会返回一个约束对象，其特征会随着该组件特征的更改而进行跟踪。

参数：
c - 将返回其约束的组件
返回：
指定组件的约束

getConstraint

public Spring getConstraint(String edgeName,
                            Component c)
返回控制该组件指定边及其父级的顶边或左边之间距离的 spring。此方法返回一个跟踪该边特征的代理，而不是返回该边当前绑定，即使该边随后反弹也一样。代理特别适用于生成器环境，在此环境中能够使用户以任意顺序定义布局约束。不过，代理确实会提供在布局约束之间创建周期依赖关系的方法。SpringLayout 将对此类周期进行内部检测，以使布局操作始终终止。

参数：
edgeName - 必须是以下值之一：SpringLayout.NORTH、SpringLayout.SOUTH、SpringLayout.EAST、SpringLayout.WEST、SpringLayout.VERTICAL_CENTER、SpringLayout.HORIZONTAL_CENTER 或 SpringLayout.BASELINE
c - 需要其边缘 spring 的组件
返回：
一个控制指定边及其父级的顶边或左边之间距离的 spring 代理
另请参见：
NORTH, SOUTH, EAST, WEST, VERTICAL_CENTER, HORIZONTAL_CENTER, BASELINE

layoutContainer

public void layoutContainer(Container parent)
从接口 LayoutManager 复制的描述
布置指定容器。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要布置的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SpringLayout.Constraints (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SpringLayout.Constraints

java.lang.Object
    继承者  javax.swing.SpringLayout.Constraints
正在封闭类：
SpringLayout
public static class SpringLayout.Constraints
extends Object

Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。由于 Constraints 对象具有 x、y、width 和 height 属性，因而它类似于一个 Rectangle。但是，在 Constraints 对象中，这些属性具有的是 Spring 值，而不是整数。此外，可以使用 constraint 属性按四个边（东、南、西、北）操作一个 Constraints 对象。

对于 Constraints 对象，以下公式始终为 true（这里 WEST 和 x 同义，同样地 NORTH 和 y 同义）：

               EAST = WEST + WIDTH
              SOUTH = NORTH + HEIGHT
  HORIZONTAL_CENTER = WEST + WIDTH/2
    VERTICAL_CENTER = NORTH + HEIGHT/2
  ABSOLUTE_BASELINE = NORTH + RELATIVE_BASELINE*

例如，如果指定 WIDTH 和 WEST (X) 位置，则 EAST 按 WEST + WIDTH 计算。如果指定 WIDTH 和 EAST 位置，则 WEST (X) 位置按 EAST - WIDTH 计算。

[RELATIVE_BASELINE 是调用 SpringLayout.Constraints(Component) 时或向 SpringLayout 对象注册约束对象时自动设置的专有约束]。

注：在本文档中，操作符表示该 Spring 类中的方法。例如，"a + b" 等于 Spring.sum(a, b)，"a - b" 等于 Spring.sum(a, Spring.minus(b))。有关 spring 算法的更多详细信息，请参阅 Spring API documentation。

因为 Constraints 对象的属性（表示其边、大小和位置）都可以单独设置，并且互相关联，所以 Constraints 对象可以成为过分约束。例如，如果设置了 WEST、WIDTH 和 EAST 边，则必须采取措施以确保上述公式中的第一个有效。要做到这一点，Constraints 对象抛出最近设置的 约束以使公式有效。

从以下版本开始：
1.4

构造方法摘要
SpringLayout.Constraints()
创建一个空 Constraints 对象。
SpringLayout.Constraints(Component c)
创建组件 c 的合适 x、y、width 和 height spring 的 Constraints 对象。
SpringLayout.Constraints(Spring x, Spring y)
创建一个指定了 x 和 y 属性值的 Constraints 对象。
SpringLayout.Constraints(Spring x, Spring y, Spring width, Spring height)
创建一个指定了 x、y、width 和 height 属性值的 Constraints 对象。
方法摘要
Spring | getConstraint(String edgeName) 返回指定边的值，它可以为一个派生值，甚至可以为 null。
Spring | getHeight() 返回 height 属性的值。
Spring | getWidth() 返回 width 属性的值。
Spring | getX() 返回 x 属性的值。
Spring | getY() 返回 y 属性的值。
void | setConstraint(String edgeName, Spring s) 设置控制指定边的 spring。
void | setHeight(Spring height) 设置 height 属性，该属性控制组件的高度。
void | setWidth(Spring width) 设置 width 属性，该属性控制组件的宽度。
void | setX(Spring x) 设置 x 属性，该属性控制组件位置的 x 值。
void | setY(Spring y) 设置 y 属性，该属性控制组件位置的 y 值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SpringLayout.Constraints

public SpringLayout.Constraints()
创建一个空 Constraints 对象。

SpringLayout.Constraints

public SpringLayout.Constraints(Spring x,
                                Spring y)
创建一个指定了 x 和 y 属性值的 Constraints 对象。height 和 width spring 具有 null 值。

参数：
x - 控制组件的 x 值的 spring
y - 控制组件的 y 值的 spring

SpringLayout.Constraints

public SpringLayout.Constraints(Spring x,
                                Spring y,
                                Spring width,
                                Spring height)
创建一个指定了 x、y、width 和 height 属性值的 Constraints 对象。注：如果 SpringLayout 类在给定组件的 Constraints 对象中遇到 null 值，则它将使用合适的默认值取代这些值。

参数：
x - x 属性的 spring 值
y - y 属性的 spring 值
width - width 属性的 spring 值
height - height 属性的 spring 值

SpringLayout.Constraints

public SpringLayout.Constraints(Component c)
创建组件 c 的合适 x、y、width 和 height spring 的 Constraints 对象。x 和 y spring 是使用调用此方法时该组件的位置初始化的常量 spring。width 和 height spring 是由 Spring.width() 和 Spring.height() 方法创建的特殊 spring，这些方法可在组件的大小特征发生变化时进行跟踪。

参数：
c - 此约束对象反映其特征的组件
抛出：
NullPointerException - 如果 c 为 null。
从以下版本开始：
1.5
方法详细信息

setX

public void setX(Spring x)
设置 x 属性，该属性控制组件位置的 x 值。

参数：
x - 控制组件位置的 x 值的 spring
另请参见：
getX(), SpringLayout.Constraints

getX

public Spring getX()
返回 x 属性的值。

返回：
控制组件位置的 x 值的 spring
另请参见：
setX(javax.swing.Spring), SpringLayout.Constraints

setY

public void setY(Spring y)
设置 y 属性，该属性控制组件位置的 y 值。

参数：
y - 控制组件位置的 y 值的 spring
另请参见：
getY(), SpringLayout.Constraints

getY

public Spring getY()
返回 y 属性的值。

返回：
控制组件位置的 y 值的 spring
另请参见：
setY(javax.swing.Spring), SpringLayout.Constraints

setWidth

public void setWidth(Spring width)
设置 width 属性，该属性控制组件的宽度。

参数：
width - 控制此 Constraints 对象的宽度的 spring
另请参见：
getWidth(), SpringLayout.Constraints

getWidth

public Spring getWidth()
返回 width 属性的值。

返回：
控制组件宽度的 spring
另请参见：
setWidth(javax.swing.Spring), SpringLayout.Constraints

setHeight

public void setHeight(Spring height)
设置 height 属性，该属性控制组件的高度。

参数：
height - 控制此 Constraints 对象高度的 spring
另请参见：
getHeight(), SpringLayout.Constraints

getHeight

public Spring getHeight()
返回 height 属性的值。

返回：
控制组件高度的 spring
另请参见：
setHeight(javax.swing.Spring), SpringLayout.Constraints

setConstraint

public void setConstraint(String edgeName,
                          Spring s)
设置控制指定边的 spring。该边必须是以下某个值：SpringLayout.NORTH、SpringLayout.SOUTH、SpringLayout.EAST、SpringLayout.WEST、SpringLayout.HORIZONTAL_CENTER、SpringLayout.VERTICAL_CENTER、SpringLayout.BASELINE、SpringLayout.WIDTH 或 SpringLayout.HEIGHT。 对于作为边传递的任何其他 String 值，则不执行任何操作。对于 null 边，则抛出 NullPointerException。

参数：
edgeName - 要设置的边
s - 控制指定边的 spring
抛出：
NullPointerException - 如果 edgeName 为 null
另请参见：
getConstraint(java.lang.String), SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.HORIZONTAL_CENTER, SpringLayout.VERTICAL_CENTER, SpringLayout.BASELINE, SpringLayout.WIDTH, SpringLayout.HEIGHT, SpringLayout.Constraints

getConstraint

public Spring getConstraint(String edgeName)
返回指定边的值，它可以为一个派生值，甚至可以为 null。该边必须是以下某个值：SpringLayout.NORTH、SpringLayout.SOUTH、SpringLayout.EAST、SpringLayout.WEST、SpringLayout.HORIZONTAL_CENTER、SpringLayout.VERTICAL_CENTER、SpringLayout.BASELINE、SpringLayout.WIDTH 或 SpringLayout.HEIGHT。 对于作为边传递的任何其他 String 值，则会返回 null。对于 null 边，则抛出 NullPointerException。

参数：
edgeName - 要返回其值的边
返回：
控制指定边的 spring，可以为 null
抛出：
NullPointerException - 如果 edgeName 为 null
另请参见：
setConstraint(java.lang.String, javax.swing.Spring), SpringLayout.NORTH, SpringLayout.SOUTH, SpringLayout.EAST, SpringLayout.WEST, SpringLayout.HORIZONTAL_CENTER, SpringLayout.VERTICAL_CENTER, SpringLayout.BASELINE, SpringLayout.WIDTH, SpringLayout.HEIGHT, SpringLayout.Constraints
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SwingConstants (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 SwingConstants

所有已知实现类：
AbstractButton, AsyncBoxView, BasicArrowButton, BasicComboBoxRenderer, BasicComboBoxRenderer.UIResource, BasicInternalFrameUI.BorderListener, BasicScrollBarUI, BasicTabbedPaneUI, BasicToolBarUI, BlockView, BoxView, ComponentView, CompositeView, DefaultListCellRenderer, DefaultListCellRenderer.UIResource, DefaultTableCellRenderer, DefaultTableCellRenderer.UIResource, DefaultTreeCellEditor.DefaultTextField, DefaultTreeCellRenderer, FieldView, FlowView, FormView, GlyphView, IconView, ImageView, InlineView, JButton, JCheckBox, JCheckBoxMenuItem, JFormattedTextField, JLabel, JMenu, JMenuItem, JPasswordField, JPopupMenu.Separator, JProgressBar, JRadioButton, JRadioButtonMenuItem, JSeparator, JSlider, JTabbedPane, JTextField, JToggleButton, JToolBar, JToolBar.Separator, LabelView, ListView, MetalBorders.ToolBarBorder, MetalComboBoxButton, MetalFileChooserUI.FileRenderer, MetalFileChooserUI.FilterComboBoxRenderer, MetalScrollBarUI, MetalScrollButton, MetalTabbedPaneUI, MetalToolBarUI, ObjectView, ParagraphView, ParagraphView, PasswordView, PlainView, SwingUtilities, TableView, TableView.TableCell, TableView.TableRow, View, WrappedPlainView, ZoneView
public interface SwingConstants

通常用于在屏幕上定位或定向组件的常量的集合。

字段摘要
static int | BOTTOM 用于指定框底部位置的框方向常量。
static int | CENTER 某区域的中心位置。
static int | EAST 罗盘方向东（右）。
static int | HORIZONTAL 水平方向。
static int | LEADING 标识使用从左到右和从右到左的语言的文本开始边。
static int | LEFT 用于指定框左侧位置的框方向常量。
static int | NEXT 标识序列中的下一个方向。
static int | NORTH 罗盘方向北（上）。
static int | NORTH_EAST 罗盘方向东北（右上）。
static int | NORTH_WEST 罗盘方向西北（左上）。
static int | PREVIOUS 标识序列中前一个方向。
static int | RIGHT 用于指定框右侧位置的框方向常量。
static int | SOUTH 罗盘方向南（下）。
static int | SOUTH_EAST 罗盘方向东南（右下）。
static int | SOUTH_WEST 罗盘方向西南（左下）。
static int | TOP 用于指定框顶部位置的框方向常量。
static int | TRAILING 标识使用从左到右和从右到左的语言的文本结束边。
static int | VERTICAL 垂直方向。
static int | WEST 罗盘方向西（左）。

字段详细信息

CENTER

static final int CENTER
某区域的中心位置。用于罗盘方向常量（NORTH 等）和框方向常量（TOP 等）。

另请参见：
常量字段值

TOP

static final int TOP
用于指定框顶部位置的框方向常量。

另请参见：
常量字段值

LEFT

static final int LEFT
用于指定框左侧位置的框方向常量。

另请参见：
常量字段值

BOTTOM

static final int BOTTOM
用于指定框底部位置的框方向常量。

另请参见：
常量字段值

RIGHT

static final int RIGHT
用于指定框右侧位置的框方向常量。

另请参见：
常量字段值

NORTH

static final int NORTH
罗盘方向北（上）。

另请参见：
常量字段值

NORTH_EAST

static final int NORTH_EAST
罗盘方向东北（右上）。

另请参见：
常量字段值

EAST

static final int EAST
罗盘方向东（右）。

另请参见：
常量字段值

SOUTH_EAST

static final int SOUTH_EAST
罗盘方向东南（右下）。

另请参见：
常量字段值

SOUTH

static final int SOUTH
罗盘方向南（下）。

另请参见：
常量字段值

SOUTH_WEST

static final int SOUTH_WEST
罗盘方向西南（左下）。

另请参见：
常量字段值

WEST

static final int WEST
罗盘方向西（左）。

另请参见：
常量字段值

NORTH_WEST

static final int NORTH_WEST
罗盘方向西北（左上）。

另请参见：
常量字段值

HORIZONTAL

static final int HORIZONTAL
水平方向。用于滚动条和滑块。

另请参见：
常量字段值

VERTICAL

static final int VERTICAL
垂直方向。用于滚动条和滑块。

另请参见：
常量字段值

LEADING

static final int LEADING
标识使用从左到右和从右到左的语言的文本开始边。由按钮和标签使用。

另请参见：
常量字段值

TRAILING

static final int TRAILING
标识使用从左到右和从右到左的语言的文本结束边。由按钮和标签使用。

另请参见：
常量字段值

NEXT

static final int NEXT
标识序列中的下一个方向。

从以下版本开始：
1.4
另请参见：
常量字段值

PREVIOUS

static final int PREVIOUS
标识序列中前一个方向。

从以下版本开始：
1.4
另请参见：
常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SwingUtilities (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SwingUtilities

java.lang.Object
    继承者  javax.swing.SwingUtilities
所有已实现的接口：
SwingConstants
public class SwingUtilities
extends Object
implements SwingConstants

Swing 实用方法的集合。

字段摘要
从接口 javax.swing.SwingConstants 继承的字段
BOTTOM, CENTER, EAST, HORIZONTAL, LEADING, LEFT, NEXT, NORTH, NORTH_EAST, NORTH_WEST, PREVIOUS, RIGHT, SOUTH, SOUTH_EAST, SOUTH_WEST, TOP, TRAILING, VERTICAL, WEST
方法摘要
static Rectangle | calculateInnerArea(JComponent c, Rectangle r) 将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。
static Rectangle[] | computeDifference(Rectangle rectA, Rectangle rectB) 返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。
static Rectangle | computeIntersection(int x, int y, int width, int height, Rectangle dest) 在未分配新矩形的情况下计算两个矩形的交集的便捷方法。
static int | computeStringWidth(FontMetrics fm, String str) 使用具有指定“规格”（大小）的字体计算字符串的宽度。
static Rectangle | computeUnion(int x, int y, int width, int height, Rectangle dest) 在未分配新矩形的情况下计算两个矩形的并集的便捷方法。
static MouseEvent | convertMouseEvent(Component source, MouseEvent sourceEvent, Component destination) 返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。
static Point | convertPoint(Component source, int x, int y, Component destination) 将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。
static Point | convertPoint(Component source, Point aPoint, Component destination) 将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。
static void | convertPointFromScreen(Point p, Component c) 将一个点从屏幕坐标转换到组件的坐标系统
static void | convertPointToScreen(Point p, Component c) 将一个点从组件的坐标系统转换到屏幕坐标。
static Rectangle | convertRectangle(Component source, Rectangle aRectangle, Component destination) 将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。
static Component | findFocusOwner(Component c) 已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。
static Accessible | getAccessibleAt(Component c, Point p) 如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。
static Accessible | getAccessibleChild(Component c, int i) 返回对象的第 n 个可访问子对象。
static int | getAccessibleChildrenCount(Component c) 返回对象中可访问的子对象数。
static int | getAccessibleIndexInParent(Component c) 获取此对象在其可访问的父对象中的索引。
static AccessibleStateSet | getAccessibleStateSet(Component c) 获取此对象的状态。
static Container | getAncestorNamed(String name, Component comp) 在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。
static Container | getAncestorOfClass(Class<?> c, Component comp) 在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。
static Component | getDeepestComponentAt(Component parent, int x, int y) 返回包含位置 x、y 的 parent 的最深可见后代组件。
static Rectangle | getLocalBounds(Component aComponent) 返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。
static Component | getRoot(Component c) 返回当前组件树结构的根组件。
static JRootPane | getRootPane(Component c) 如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。
static ActionMap | getUIActionMap(JComponent component) 返回该 UI 在组件 component 中提供的 ActionMap。
static InputMap | getUIInputMap(JComponent component, int condition) 返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。
static Window | getWindowAncestor(Component c) 返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
static void | invokeAndWait(Runnable doRun) 导致 doRun.run() 在 AWT 事件指派线程上同步执行。
static void | invokeLater(Runnable doRun) 导致 doRun.run() 在 AWT 事件指派线程上异步执行。
static boolean | isDescendingFrom(Component a, Component b) 如果组件 a 从组件 b 继承，则返回 true。
static boolean | isEventDispatchThread() 如果当前线程是 AWT 事件指派线程，则返回 true。
static boolean | isLeftMouseButton(MouseEvent anEvent) 如果鼠标事件指定左边鼠标按键，则返回 true。
static boolean | isMiddleMouseButton(MouseEvent anEvent) 如果鼠标事件指定中间鼠标按键，则返回 true。
static boolean | isRectangleContainingRectangle(Rectangle a, Rectangle b) 如果 a 包含 b，则返回 true。
static boolean | isRightMouseButton(MouseEvent anEvent) 如果鼠标事件指定右边鼠标按键，则返回 true。
static String | layoutCompoundLabel(FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap) 计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static String | layoutCompoundLabel(JComponent c, FontMetrics fm, String text, Icon icon, int verticalAlignment, int horizontalAlignment, int verticalTextPosition, int horizontalTextPosition, Rectangle viewR, Rectangle iconR, Rectangle textR, int textIconGap) 计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。
static boolean | notifyAction(Action action, KeyStroke ks, KeyEvent event, Object sender, int modifiers) 如果启用 action（且为非 null），则调用 action 上的 actionPerformed。
static void | paintComponent(Graphics g, Component c, Container p, int x, int y, int w, int h) 在指定的 Graphics 上绘制组件。
static void | paintComponent(Graphics g, Component c, Container p, Rectangle r) 在指定的 Graphics 上绘制组件。
static boolean | processKeyBindings(KeyEvent event) 处理与 event 关联的 Component 的键绑定。
static void | replaceUIActionMap(JComponent component, ActionMap uiActionMap) 将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。
static void | replaceUIInputMap(JComponent component, int type, InputMap uiInputMap) 将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。
static void | updateComponentTreeUI(Component c) 简单的外观更改：将树结构中的每个节点转到 updateUI() -- 也就是说，通过当前外观初始化其 UI 属性。
static Window | windowForComponent(Component c) 返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

isRectangleContainingRectangle

public static final boolean isRectangleContainingRectangle(Rectangle a,
                                                           Rectangle b)
如果 a 包含 b，则返回 true。

getLocalBounds

public static Rectangle getLocalBounds(Component aComponent)
返回组件 aComponent 的矩形 (0,0,bounds.width,bounds.height)。

getWindowAncestor

public static Window getWindowAncestor(Component c)
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。

参数：
c - 要获取其 Window 祖先的 Component。
返回：
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。
从以下版本开始：
1.3

convertPoint

public static Point convertPoint(Component source,
                                 Point aPoint,
                                 Component destination)
将 source 坐标系统中的 aPoint 转换到 destination 坐标系统。如果 source 为 null，则假定 aPoint 位于 destination 的根组件坐标系统中。如果 destination 为 null，则将 aPoint 转换到 source 的根组件坐标系统。如果 source 和 destination 都为 null，则返回 aPoint，无需进行任何转换。

convertPoint

public static Point convertPoint(Component source,
                                 int x,
                                 int y,
                                 Component destination)
将 source 坐标系统中的点 (x,y) 转换到 destination 坐标系统。如果 source 为 null，则假定 (x,y) 位于 destination 的根组件坐标系统中。如果 destination 为 null，则将 (x,y) 转换到 source 的根组件坐标系统。如果 source 和 destination 都为 null，则返回 (x,y)，无需进行任何转换。

convertRectangle

public static Rectangle convertRectangle(Component source,
                                         Rectangle aRectangle,
                                         Component destination)
将 source 坐标系统中的矩形 aRectangle 转换到 destination 坐标系统。如果 source 为 null，则假定 aRectangle 位于 destination 的根组件坐标系统中。如果 destination 为 null，则将 aRectangle 转换到 source 的根组件坐标系统。如果 source 和 destination 都为 null，则返回 aRectangle，无需进行任何转换。

getAncestorOfClass

public static Container getAncestorOfClass(Class<?> c,
                                           Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的类 c 的第一个对象。如果无法找到类 c，可以返回 null。

getAncestorNamed

public static Container getAncestorNamed(String name,
                                         Component comp)
在组件层次结构中搜索上面的 comp 的便捷方法，返回它找到的 name 第一个对象。如果无法找到 name，可以返回 null。

getDeepestComponentAt

public static Component getDeepestComponentAt(Component parent,
                                              int x,
                                              int y)
返回包含位置 x、y 的 parent 的最深可见后代组件。如果 parent 未包含指定位置，则返回 null。如果 parent 不是容器，或者没有一个 parent 的可见后代包含指定位置，则返回 parent。

参数：
parent - 开始该搜索的根组件
x - 该 x 目标位置
y - 该 y 目标位置

convertMouseEvent

public static MouseEvent convertMouseEvent(Component source,
                                           MouseEvent sourceEvent,
                                           Component destination)
返回类似于 sourceEvent 的 MouseEvent，除了其 x 和 y 成员已转换到 destination 的坐标系统。如果 source 为 null，则假定已将 sourceEvent x 和 y 成员转换到 destination 的根组件坐标系统。如果 destination 为 null，则返回的 MouseEvent 将位于 source 的坐标系统中。sourceEvent 不会更改。返回一个新事件。返回事件的 source 字段将被设置为 destination。如果目标为非 null，则在不更改源的情况下使用 translateMouseEvent() 方法将鼠标事件从一个组件转换到另一个组件。

convertPointToScreen

public static void convertPointToScreen(Point p,
                                        Component c)
将一个点从组件的坐标系统转换到屏幕坐标。

参数：
p - 一个 Point 对象（已转换到新坐标系统）
c - 一个 Component 对象

convertPointFromScreen

public static void convertPointFromScreen(Point p,
                                          Component c)
将一个点从屏幕坐标转换到组件的坐标系统

参数：
p - 一个 Point 对象（已转换到新坐标系统）
c - 一个 Component 对象

windowForComponent

public static Window windowForComponent(Component c)
返回 c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。

注：此方法与 getWindowAncestor 提供的功能相同。

参数：
c - 要获取其 Window 祖先的 Component。
返回：
c 的第一个 Window 祖先；如果 c 未包含在 Window 内，则返回 null。

isDescendingFrom

public static boolean isDescendingFrom(Component a,
                                       Component b)
如果组件 a 从组件 b 继承，则返回 true。

computeIntersection

public static Rectangle computeIntersection(int x,
                                            int y,
                                            int width,
                                            int height,
                                            Rectangle dest)
在未分配新矩形的情况下计算两个矩形的交集的便捷方法。如果这两个矩形不相交，则返回的矩形从 (0,0) 开始，宽度和高度都是 0。

参数：
x - 第一个矩形的左上顶点的 X 坐标
y - 第一个矩形的左上顶点的 Y 坐标
width - 第一个矩形的宽度
height - 第一个矩形的高度
dest - 第二个矩形
返回：
dest，已改为指定交集

computeUnion

public static Rectangle computeUnion(int x,
                                     int y,
                                     int width,
                                     int height,
                                     Rectangle dest)
在未分配新矩形的情况下计算两个矩形的并集的便捷方法。

参数：
x - 第一个矩形的 x 坐标
y - 第一个矩形的 y 坐标
width - 第一个矩形的宽度
height - 第一个矩形的高度
dest - 第二个矩形的坐标；在此矩形中返回两个矩形的并集
返回：
该 dest Rectangle

computeDifference

public static Rectangle[] computeDifference(Rectangle rectA,
                                            Rectangle rectB)
返回矩形数组的便捷方法，该矩形表示不与 rectB 重叠的 rectA 内的区域。如果两个矩形不重叠，则返回一个空数组。

isLeftMouseButton

public static boolean isLeftMouseButton(MouseEvent anEvent)
如果鼠标事件指定左边鼠标按键，则返回 true。

参数：
anEvent - 一个 MouseEvent 对象
返回：
如果左边鼠标按键处于活动状态，则返回 true

isMiddleMouseButton

public static boolean isMiddleMouseButton(MouseEvent anEvent)
如果鼠标事件指定中间鼠标按键，则返回 true。

参数：
anEvent - 一个 MouseEvent 对象
返回：
如果中间鼠标按键处于活动状态，则返回 true

isRightMouseButton

public static boolean isRightMouseButton(MouseEvent anEvent)
如果鼠标事件指定右边鼠标按键，则返回 true。

参数：
anEvent - 一个 MouseEvent 对象
返回：
如果右边鼠标按键处于活动状态，则返回 true

computeStringWidth

public static int computeStringWidth(FontMetrics fm,
                                     String str)
使用具有指定“规格”（大小）的字体计算字符串的宽度。

参数：
fm - 用来计算的 FontMetrics 对象
str - 要计算的字符串
返回：
一个包含该字符串宽度的 int 值

layoutCompoundLabel

public static String layoutCompoundLabel(JComponent c,
                                         FontMetrics fm,
                                         String text,
                                         Icon icon,
                                         int verticalAlignment,
                                         int horizontalAlignment,
                                         int verticalTextPosition,
                                         int horizontalTextPosition,
                                         Rectangle viewR,
                                         Rectangle iconR,
                                         Rectangle textR,
                                         int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。相对于 viewR 矩形计算位置。还要考虑该 JComponents 方向 (LEADING/TRAILING)，并相应地将其转换为 LEFT/RIGHT 值。

layoutCompoundLabel

public static String layoutCompoundLabel(FontMetrics fm,
                                         String text,
                                         Icon icon,
                                         int verticalAlignment,
                                         int horizontalAlignment,
                                         int verticalTextPosition,
                                         int horizontalTextPosition,
                                         Rectangle viewR,
                                         Rectangle iconR,
                                         Rectangle textR,
                                         int textIconGap)
计算并返回图标原点的位置，文本基线的原点的位置，以及复合标签字符串的可能进行了修剪的版本。相对于 viewR 矩形计算位置。此 layoutCompoundLabel() 不知道如何处理 horizontalTextPosition（默认为 RIGHT）和 horizontalAlignment（默认为 CENTER）中的 LEADING/TRAILING 值。可以使用其他版本的 layoutCompoundLabel() 替代。

paintComponent

public static void paintComponent(Graphics g,
                                  Component c,
                                  Container p,
                                  int x,
                                  int y,
                                  int w,
                                  int h)
在指定的 Graphics 上绘制组件。此方法主要用于呈现不作为可见包含层次结构的一部分而存在，但用于呈现的 Component。例如，如果执行自己的呈现并想呈现某些文本（甚至 HTML），则可以利用 JLabel 的文本呈现支持并通过此方法直接绘制它，而不会将标签添加到可见包含层次结构中。

此方法利用 CellRendererPane 处理实际的绘制，只有使用了用于呈现的组件时才建议使用此方法。如果利用多个组件处理呈现，则就像 JTable 所做的一样，那么可直接使用 CellRendererPane。否则，如下所述，每个 Component 可以以 CellRendererPane 结尾。

如果 c 的父组件不是 CellRendererPane，则创建一个新的 CellRendererPane，将 c 添加到其中，并将 CellRendererPane 添加到 p。如果 c 的父组件是 CellRendererPane，并且 CellRendererPane 的父级不是 p，则将它添加到 p。

该组件应该从 JComponent 继承或者是另一种轻量级组件。轻量级组件是一个其 "lightweight" 属性（由该 Component isLightweight 方法返回）为 true 的组件。如果该 Component 不是轻量级的，则可能发生以下糟糕的事情：崩溃、异常、绘制问题……

参数：
g - 要在其上绘制的 Graphics 对象
c - 要绘制的 Component
p - 该中间 Container
x - 指定要在其中绘制的区域左侧的 int 值，以像素为单位，通过图形环境的左边缘测量
y - 指定要在其中绘制的区域顶部的 int 值，以像素为单位，通过图形环境的顶部边缘测量
w - 指定要在其中绘制的区域宽度的 int 值，以像素为单位
h - 指定要在其中绘制的区域高度的 int 值，以像素为单位
另请参见：
CellRendererPane, Component.isLightweight()

paintComponent

public static void paintComponent(Graphics g,
                                  Component c,
                                  Container p,
                                  Rectangle r)
在指定的 Graphics 上绘制组件。这是 paintComponent(Graphics,Component,Container,int,int,int,int) 的一个覆盖方法。有关更多信息，请参阅它。

参数：
g - 要在其上绘制的 Graphics 对象
c - 要绘制的 Component
p - 该中间 Container
r - 要在其中绘制的 Rectangle
另请参见：
paintComponent(Graphics,Component,Container,int,int,int,int), CellRendererPane

updateComponentTreeUI

public static void updateComponentTreeUI(Component c)
简单的外观更改：将树结构中的每个节点转到 updateUI() -- 也就是说，通过当前外观初始化其 UI 属性。

invokeLater

public static void invokeLater(Runnable doRun)
导致 doRun.run() 在 AWT 事件指派线程上异步执行。在所有挂起的 AWT 事件被处理后才发生。此方法应该在应用程序线程需要更新该 GUI 时使用。在下面的示例中，invokeLater 调用将事件指派线程上的 Runnable 对象 doHelloWorld 加入队列，然后输出一条信息。
 Runnable doHelloWorld = new Runnable() {
     public void run() {
         System.out.println("Hello World on " + Thread.currentThread());
     }
 };

 SwingUtilities.invokeLater(doHelloWorld);
 System.out.println("This might well be displayed before the other message.");
如果从事件指派线程调用 invokeLater（例如，从 JButton 的 ActionListener）则仍要将 doRun.run() 推迟，直到处理了所有挂起的事件。注意，如果 doRun.run() 抛出一个未捕获的异常，则该事件指派线程将不会缠绕（不是该当前线程）。

有关此方法的其他文档和示例，请参阅 The Java Tutorial 中的 How to Use Threads 一节。

从 1.3 版本开始，此方法只覆盖了 java.awt.EventQueue.invokeLater()。

与 Swing 的其余部分不同，可从任一线程中调用此方法。

另请参见：
invokeAndWait(java.lang.Runnable)

invokeAndWait

public static void invokeAndWait(Runnable doRun)
                          throws InterruptedException,
                                 InvocationTargetException
导致 doRun.run() 在 AWT 事件指派线程上同步执行。在所有挂起的 AWT 事件被处理完（然后）返回 doRun.run() 之前，此调用将处于阻塞状态。此方法应该在应用程序线程需要更新该 GUI 时使用。而不应该从 EventDispatchThread 中调用此方法。下面是一个创建新应用程序线程的示例，该应用线程使用 invokeAndWait 从事件指派线程输出一个字符串，完成后再从应用程序线程输出一个字符串。
 final Runnable doHelloWorld = new Runnable() {
     public void run() {
         System.out.println("Hello World on " + Thread.currentThread());
     }
 };

 Thread appThread = new Thread() {
     public void run() {
         try {
             SwingUtilities.invokeAndWait(doHelloWorld);
         }
         catch (Exception e) {
             e.printStackTrace();
         }
         System.out.println("Finished on " + Thread.currentThread());
     }
 };
 appThread.start();
注意，如果 Runnable.run 方法抛出一个未捕获的异常（在事件指派线程上），则它将被作为一个 InvocationTargetException（在调用者的线程上）捕获并重新抛出。

有关此方法的更多文档和示例，请参阅 The Java Tutorial 中的 How to Use Threads 一节。

从 1.3 版本开始，此方法只覆盖了 java.awt.EventQueue.invokeAndWait()。

抛出：
InterruptedException - 如果等待事件指派线程执完成执行 doRun.run() 时被中断
InvocationTargetException - 如果在运行 doRun 时抛出异常
另请参见：
invokeLater(java.lang.Runnable)

isEventDispatchThread

public static boolean isEventDispatchThread()
如果当前线程是 AWT 事件指派线程，则返回 true。

从 1.3 版本开始，此方法只覆盖了 java.awt.EventQueue.isDispatchThread()。

返回：
true 如果当前线程是一个 AWT 事件指派线程

getAccessibleIndexInParent

public static int getAccessibleIndexInParent(Component c)
获取此对象在其可访问的父对象中的索引。

注：从 Java 2 平台 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleIndexInParent()，而不是使用此方法。

返回：
如果此对象没有可访问的父对象，则返回 -1。否则，返回子对象在其可访问的父对象中的索引。

getAccessibleAt

public static Accessible getAccessibleAt(Component c,
                                         Point p)
如果存在，则返回本地坐标 Point 处包含的 Accessible 子对象。否则返回 null。

返回：
指定位置的 Accessible（如果存在）；否则返回 null

getAccessibleStateSet

public static AccessibleStateSet getAccessibleStateSet(Component c)
获取此对象的状态。

注：从 Java 2 平台 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleIndexInParent()，而不是使用此方法。

返回：
包含对象当前状态集合的 AccessibleStateSet 的实例
另请参见：
AccessibleState

getAccessibleChildrenCount

public static int getAccessibleChildrenCount(Component c)
返回对象中可访问的子对象数。如果此对象的所有子级都实现 Accessible，则此方法应该返回该对象的子级数。

注：从 Java 2 平台 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleIndexInParent()，而不是使用此方法。

返回：
对象的可访问子对象数

getAccessibleChild

public static Accessible getAccessibleChild(Component c,
                                            int i)
返回对象的第 n 个可访问子对象。

注：从 Java 2 平台 v1.3 开始，建议开发人员调用 Component.AccessibleAWTComponent.getAccessibleIndexInParent()，而不是使用此方法。

参数：
i - 从零开始的子对象索引
返回：
该对象的第 n 个可访问子对象

findFocusOwner

@Deprecated
public static Component findFocusOwner(Component c)
已过时。 从 1.4 开始，由 KeyboardFocusManager.getFocusOwner() 取代。

返回指定为焦点所有者的 Component 的子 Component（如果有）。

参数：
c - 要搜索焦点所有者的 Component 层次结构的根
返回：
焦点所有者；如果不存在焦点所有者，如果焦点所有者不是 comp 或 comp 的后代，则返回 null
另请参见：
KeyboardFocusManager.getFocusOwner()

getRootPane

public static JRootPane getRootPane(Component c)
如果 c 是一个 JRootPane 后代，则返回其 JRootPane 祖先。如果 c 是一个 RootPaneContainer，则返回其 JRootPane。

返回：
组件 c 的 JRootPane，或者 null。

getRoot

public static Component getRoot(Component c)
返回当前组件树结构的根组件。

返回：
c（一个 Window）的第一个祖先，或者最后一个 Applet 祖先

processKeyBindings

public static boolean processKeyBindings(KeyEvent event)
处理与 event 关联的 Component 的键绑定。此方法仅当 event.getComponent() 不是从 JComponent 继承的，或不从 JComponent 子类中调用 super.processKeyEvent 时才有用。JComponent 自动处理其 processKeyEvent 方法中的绑定，因此一般情况下不需要直接调用此方法。

参数：
event - 用于标识哪些绑定要处理以及哪个组件有焦点的 KeyEvent。
返回：
如果找到并处理一个绑定，则返回 true
从以下版本开始：
1.4

notifyAction

public static boolean notifyAction(Action action,
                                   KeyStroke ks,
                                   KeyEvent event,
                                   Object sender,
                                   int modifiers)
如果启用 action（且为非 null），则调用 action 上的 actionPerformed。ActionEvent 的命令由以下情况确定：
  1. 如果该动作是通过 registerKeyboardAction 注册的，则传入命令字符串（如果传入 null，则使用 null）。
  2. 动作值的名称是 Action.ACTION_COMMAND_KEY，除非为 null。
  3. 该 KeyEvent 的字符串值，除非 getKeyChar 返回 KeyEvent.CHAR_UNDEFINED。
如果 action 为非 null 且 actionPerformed 是在其上调用的，则将返回 true。

从以下版本开始：
1.3

replaceUIInputMap

public static void replaceUIInputMap(JComponent component,
                                     int type,
                                     InputMap uiInputMap)
将 component 的 UI InputMap 更改为 uiInputMap 的便捷方法。如果 uiInputMap 为 null，则将移除以前安装的任何 UI InputMap。

从以下版本开始：
1.3

replaceUIActionMap

public static void replaceUIActionMap(JComponent component,
                                      ActionMap uiActionMap)
将 component 的 UI ActionMap 更改为 uiActionMap 的便捷方法。如果 uiActionMap 为 null，则将移除以前安装的任何 UI ActionMap。

从以下版本开始：
1.3

getUIInputMap

public static InputMap getUIInputMap(JComponent component,
                                     int condition)
返回由组件 component 中的条件 condition 的 UI 提供的 InputMap。

如果该 UI 未安装指定类型的 InputMap，则将返回 null。

从以下版本开始：
1.3

getUIActionMap

public static ActionMap getUIActionMap(JComponent component)
返回该 UI 在组件 component 中提供的 ActionMap。

如果该 UI 未安装 ActionMap，则将返回 null。

从以下版本开始：
1.3

calculateInnerArea

public static Rectangle calculateInnerArea(JComponent c,
                                           Rectangle r)
将指定组件的内部绘制区域的位置和大小存储在 r 中，然后返回 r。该位置和大小指定组件的边界，进行调整以使其不包括边框区域（即 insets）。此方法对实现绘制代码的类很有用。

参数：
c - 相关的 JComponent；如果为 null，则此方法返回 null
r - 要修改的 Rectangle 实例；可以为 null
返回：
如果该组件为 null，则返回 null；否则返回传入的矩形（如果为非 null），或一个指定位置和大小信息的新矩形
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SwingWorker (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 SwingWorker<T,V>

java.lang.Object
    继承者  javax.swing.SwingWorker<T,V>
类型参数：
T - 此 SwingWorker 的 doInBackground 和 get 方法返回的结果类型
V - 用于保存此 SwingWorker 的 publish 和 process 方法的中间结果的类型
所有已实现的接口：
Runnable, Future<T>, RunnableFuture<T>
public abstract class SwingWorker<T,V>
extends Object
implements RunnableFuture<T>

在专用线程中执行长时间 GUI 交互任务的抽象类。

使用 Swing 编写多线程应用程序时，要记住两个约束条件：（有关详细信息，请参阅 How to Use Threads）：

  • 不应该在事件指派线程 上运行耗时任务。否则应用程序将无响应。
  • 只能在事件指派线程 上访问 Swing 组件。

这些约束意味着需要时间密集计算操作的 GUI 应用程序至少需要以下两个线程：1) 执行长时间任务的线程； 2) 所有 GUI 相关活动的事件指派线程 （EDT）这涉及到难以实现的线程间通信。

SwingWorker 设计用于需要在后台线程中运行长时间运行任务的情况，并可在完成后或者在处理过程中向 UI 提供更新。SwingWorker 的子类必须实现 doInBackground() 方法，以执行后台计算。

工作流

SwingWorker 的生命周期中包含三个线程：

  • 当前 线程：在此线程上调用 execute() 方法。它调度 SwingWorker 以在 worker 线程上执行并立即返回。可以使用 get 方法等待 SwingWorker 完成。

  • Worker 线程：在此线程上调用 doInBackground() 方法。所有后台活动都应该在此线程上发生。要通知 PropertyChangeListeners 有关绑定 (bound) 属性的更改，请使用 firePropertyChange 和 getPropertyChangeSupport() 方法。默认情况下，有两个可用的绑定属性：state 和 progress。

  • 事件指派线程：所有与 Swing 有关的活动都在此线程上发生。SwingWorker 调用 process 和 done() 方法，并通知此线程的所有 PropertyChangeListener。

通常，当前 线程就是事件指派线程。

在 worker 线程上调用 doInBackground 方法之前，SwingWorker 通知所有 PropertyChangeListener 有关对 StateValue.STARTED 的 state 属性更改。doInBackground 方法完成后，执行 done 方法。然后 SwingWorker 通知所有 PropertyChangeListener 有关对 StateValue.DONE 的 state 属性更改。

SwingWorker 被设计为只执行一次。多次执行 SwingWorker 将不会调用两次 doInBackground 方法。

示例用法

下例说明了最简单的使用范例：在后台完成某些处理，并在处理完成后更新 Swing 组件。

假定想找到“Meaning of Life”并在 JLabel 中显示结果。

final JLabel label;
class MeaningOfLifeFinder extends SwingWorker<String, Object> {
@Override
public String doInBackground() {
return findTheMeaningOfLife();
       }

@Override
protected void done() {
try {
label.setText(get());
} catch (Exception ignore) {
           }
       }
   }

(new MeaningOfLifeFinder()).execute();

在希望处理已经在事件指派线程 上准备好的数据时，下一个例子很有用。

现在想要查找第一个 N 素数值并在 JTextArea 中显示结果。在计算过程中，想在 JProgressBar 中更新进度。最后，还要将该素数值打印到 System.out。

class PrimeNumbersTask extends
SwingWorker<List<Integer>, Integer> {
PrimeNumbersTask(JTextArea textArea, int numbersToFind) {
//initialize
     }

@Override
public List<Integer> doInBackground() {
while (! enough && ! isCancelled()) {
number = nextPrimeNumber();
publish(number);
setProgress(100 * numbers.size() / numbersToFind);
             }
         }
return numbers;
     }

@Override
protected void process(List<Integer> chunks) {
for (int number :chunks) {
textArea.append(number + "\n");
         }
     }
 }

JTextArea textArea = new JTextArea();
final JProgressBar progressBar = new JProgressBar(0, 100);
PrimeNumbersTask task = new PrimeNumbersTask(textArea, N);
task.addPropertyChangeListener(
new PropertyChangeListener() {
public  void propertyChange(PropertyChangeEvent evt) {
if ("progress".equals(evt.getPropertyName())) {
progressBar.setValue((Integer)evt.getNewValue());
             }
         }
     });

task.execute();
System.out.println(task.get()); //prints all prime numbers we have got

因为 SwingWorker 实现了 Runnable，所以可以将 SwingWorker 提交给 Executor 执行。

从以下版本开始：
1.6

嵌套类摘要
static class SwingWorker.StateValue
state 绑定 (bound) 属性的值。
构造方法摘要
SwingWorker()
构造此 SwingWorker。
方法摘要
 void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。
 boolean cancel(boolean mayInterruptIfRunning)
试图取消对此任务的执行。
protected abstract  T doInBackground()
计算结果；如果无法计算结果，则抛出异常。
protected  void done()
doInBackground 方法完成后，在事件指派线程 上执行此方法。
 void execute()
调度此 SwingWorker 以便在 worker 线程上执行。
 void firePropertyChange(String propertyName, Object oldValue, Object newValue)
向所有已注册的侦听器报告绑定属性更新。
 T get()
如有必要，等待计算完成，然后获取其结果。
 T get(long timeout, TimeUnit unit)
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。
 int getProgress()
返回 progress 绑定属性。
 PropertyChangeSupport getPropertyChangeSupport()
返回此 SwingWorker 的 PropertyChangeSupport。
 SwingWorker.StateValue getState()
返回 SwingWorker 状态绑定属性。
 boolean isCancelled()
如果在任务正常完成前将其取消，则返回 true。
 boolean isDone()
如果任务已完成，则返回 true。
protected  void process(List<V> chunks)
在事件指派线程 上异步地从 publish 方法接收数据块。
protected  void publish(V... chunks)
将数据块发送给 process(java.util.List) 方法。
 void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表中移除一个 PropertyChangeListener。
 void run()
将此 Future 设置为计算的结果，除非它已经被取消。
protected  void setProgress(int progress)
设置 progress 绑定属性。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SwingWorker

public SwingWorker()
构造此 SwingWorker。

方法详细信息

doInBackground

protected abstract T doInBackground()
                             throws Exception
计算结果；如果无法计算结果，则抛出异常。

注意，此方法只执行一次。

注：此方法在后台线程中执行。

返回：
计算的结果
抛出：
Exception - 如果无法计算结果

run

public final void run()
将此 Future 设置为计算的结果，除非它已经被取消。

指定者：
接口 Runnable 中的 run
指定者：
接口 RunnableFuture<T> 中的 run
另请参见：
Thread.run()

publish

protected final void publish(V... chunks)
将数据块发送给 process(java.util.List) 方法。将从 doInBackground 方法内部使用此方法传送中间结果，以便在 process 方法内部对事件指派线程 进行处理。

由于在事件指派进程 上异步地调用 process 方法，所以在执行 process 方法之前可以对 publish 方法进行多次调用。为了改进性能，所有这些调用都合并为一个带连接参数的调用。

例如：

publish("1");
publish("2", "3");
publish("4", "5", "6");
结果可能为：
process("1", "2", "3", "4", "5", "6")

示例用法。以下代码片断加载某一表格数据，并用它来更新 DefaultTableModel。注意，从 process 方法内部更换 tableModel 是安全的，因为该方法是在事件指派线程 上调用的。

class TableSwingWorker extends
SwingWorker<DefaultTableModel, Object[]> {
private final DefaultTableModel tableModel;

public TableSwingWorker(DefaultTableModel tableModel) {
this.tableModel = tableModel;
     }

@Override
protected DefaultTableModel doInBackground() throws Exception {
for (Object[] row = loadData();
! isCancelled() && row != null;
row = loadData()) {
publish((Object[]) row);
         }
return tableModel;
     }

@Override
protected void process(List<Object[]> chunks) {
for (Object[] row :chunks) {
tableModel.addRow(row);
         }
     }
 }

参数：
chunks - 要处理的中间结果
另请参见：
process(java.util.List)

process

protected void process(List<V> chunks)
在事件指派线程 上异步地从 publish 方法接收数据块。

有关详细信息，请参阅 publish(V...) 方法。

参数：
chunks - 要处理的中间结果
另请参见：
publish(V...)

done

protected void done()
doInBackground 方法完成后，在事件指派线程 上执行此方法。默认实现不执行任何操作。子类可以重写此方法，以在事件指派线程 上执行完成操作。注意，可以查询此方法实现内部的状态，以确定此任务的结果或者是否已经取消了此任务。

另请参见：
doInBackground(),
isCancelled(),
get()

setProgress

protected final void setProgress(int progress)
设置 progress 绑定属性。该值应该在 0 到 100 之间。

由于在事件指派线程 上异步地通知 PropertyChangeListener，所以可以在调用任意 PropertyChangeListener 之前对 setProgress 方法进行多次调用。为了改进性能，所有这些调用都合并为一个只带最后一个调用参数的调用。

例如，以下调用：

setProgress(1);
setProgress(2);
setProgress(3);
结果可能为带有值 3 的单个 PropertyChangeListener 通知。

参数：
progress - 要设置的进度值
抛出：
IllegalArgumentException - 如果值不是从 0 到 100

getProgress

public final int getProgress()
返回 progress 绑定属性。

返回：
progress 绑定属性。

execute

public final void execute()
调度此 SwingWorker 以便在 worker 线程上执行。存在许多可用的 worker 线程。如果所有 worker 线程都忙于处理其他 SwingWorker，则此 SwingWorker 将被放入等待队列。

注：SwingWorker 被设计为只执行一次。多次执行 SwingWorker 将不会调用两次 doInBackground 方法。

cancel

public final boolean cancel(boolean mayInterruptIfRunning)
试图取消对此任务的执行。如果任务已完成、或已取消，或者由于某些其他原因而无法取消，则此尝试将失败。当调用 cancel 时，如果调用成功，而此任务尚未启动，则此任务将永不运行。如果任务已经启动，则 mayInterruptIfRunning 参数确定是否应该以试图停止任务的方式来中断执行此任务的线程。

此方法返回后，对 Future.isDone() 的后续调用将始终返回 true。如果此方法返回 true，则对 Future.isCancelled() 的后续调用将始终返回 true。

指定者：
接口 Future<T> 中的 cancel
参数：
mayInterruptIfRunning - 如果应该中断执行此任务的线程，则为 true；否则允许正在运行的任务运行完成
返回：
如果无法取消任务，则返回 false，这通常是由于它已经正常完成；否则返回 true

isCancelled

public final boolean isCancelled()
如果在任务正常完成前将其取消，则返回 true。

指定者：
接口 Future<T> 中的 isCancelled
返回：
如果任务完成前将其取消，则返回 true

isDone

public final boolean isDone()
如果任务已完成，则返回 true。 可能由于正常终止、异常或取消而完成，在所有这些情况中，此方法都将返回 true。

指定者：
接口 Future<T> 中的 isDone
返回：
如果任务已完成，则返回 true

get

public final T get()
            throws InterruptedException,
                   ExecutionException
如有必要，等待计算完成，然后获取其结果。

注：在此 SwingWorker 完成之前，在事件指派线程 上调用 get 将阻塞所有 事件（包括 repaint）的处理。

想在事件指派线程 上阻塞 SwingWorker 时，建议使用 模式对话框（modal dialog）。

例如：

class SwingWorkerCompletionWaiter extends PropertyChangeListener {
private JDialog dialog;

public SwingWorkerCompletionWaiter(JDialog dialog) {
this.dialog = dialog;
     }

public void propertyChange(PropertyChangeEvent event) {
if ("state".equals(event.getPropertyName())
&& SwingWorker.StateValue.DONE == event.getNewValue()) {
dialog.setVisible(false);
dialog.dispose();
         }
     }
 }
JDialog dialog = new JDialog(owner, true);
swingWorker.addPropertyChangeListener(
new SwingWorkerCompletionWaiter(dialog));
swingWorker.execute();
//the dialog will be visible until the SwingWorker is done
dialog.setVisible(true);

指定者：
接口 Future<T> 中的 get
返回：
计算的结果
抛出：
InterruptedException - 如果当前的线程在等待时被中断
ExecutionException - 如果计算抛出异常

get

public final T get(long timeout,
                   TimeUnit unit)
            throws InterruptedException,
                   ExecutionException,
                   TimeoutException
如有必要，最多等待为使计算完成所给定的时间之后，获取其结果（如果结果可用）。

有关更多信息，请参阅 get()。

指定者：
接口 Future<T> 中的 get
参数：
timeout - 等待的最大时间
unit - timeout 参数的时间单位
返回：
计算的结果
抛出：
InterruptedException - 如果当前的线程在等待时被中断
ExecutionException - 如果计算抛出异常
TimeoutException - 如果等待超时

addPropertyChangeListener

public final void addPropertyChangeListener(PropertyChangeListener listener)
将 PropertyChangeListener 添加到侦听器列表。该侦听器是为所有属性注册的。同一侦听器对象可以被添加多次，并且它们被调用的次数将与添加它们的次数相同。如果 listener 为 null，则不抛出任何异常并且不执行任何操作。

注：此方法只是一个便捷包装器。所有工作都委托给 getPropertyChangeSupport() 返回的 PropertyChangeSupport。

参数：
listener - 要添加的 PropertyChangeListener

removePropertyChangeListener

public final void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表中移除一个 PropertyChangeListener。此方法移除一个为所有属性注册的 PropertyChangeListener。如果将 listener 多次添加到同一事件源，则在被移除之后，它获得的通知将减少一次。如果 listener 为 null，或者没有添加过，则不抛出任何异常并且不执行任何操作。

注：此方法只是一个便捷包装器。所有工作都委托给 getPropertyChangeSupport() 返回的 PropertyChangeSupport。

参数：
listener - 要移除的 PropertyChangeListener

firePropertyChange

public final void firePropertyChange(String propertyName,
                                     Object oldValue,
                                     Object newValue)
向所有已注册的侦听器报告绑定属性更新。如果 old 和 new 相等并且为非 null，则不触发任何事件。

此 SwingWorker 将成为所有已生成事件的源。

在事件指派线程 之外调用此方法时，则在事件指派线程 上异步地通知 PropertyChangeListener。

注：此方法只是一个便捷包装器。所有工作都委托给 getPropertyChangeSupport() 返回的 PropertyChangeSupport。

参数：
propertyName - 已更改属性的编程名称
oldValue - 属性的旧值
newValue - 属性的新值

getPropertyChangeSupport

public final PropertyChangeSupport getPropertyChangeSupport()
返回此 SwingWorker 的 PropertyChangeSupport。当需要灵活地访问绑定属性支持时，使用此方法。

此 SwingWorker 将成为所有已生成事件的源。

注：如果在事件指派线程 之外调用 firePropertyChange 或 fireIndexedPropertyChange，则返回的 PropertyChangeSupport 在事件指派线程 上异步地通知所有 PropertyChangeListener。

返回：
此 SwingWorker 的 PropertyChangeSupport

getState

public final SwingWorker.StateValue getState()
返回 SwingWorker 状态绑定属性。

返回：
当前状态
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SwingWorker.StateValue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing
枚举 SwingWorker.StateValue

java.lang.Object
    继承者  java.lang.Enum<SwingWorker.StateValue>
        继承者  javax.swing.SwingWorker.StateValue
所有已实现的接口：
Serializable, Comparable<SwingWorker.StateValue>
正在封闭类：
SwingWorker<T,V>
public static enum SwingWorker.StateValue
extends Enum<SwingWorker.StateValue>

state 绑定 (bound) 属性的值。

从以下版本开始：
1.6

枚举常量摘要
DONE
doInBackground 方法完成之后 DONE（执行）SwingWorker。
PENDING
初始 SwingWorker 状态。
STARTED
在调用 doInBackground 之前 STARTED（启动）SwingWorker。
方法摘要
static SwingWorker.StateValue | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static SwingWorker.StateValue[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

PENDING

public static final SwingWorker.StateValue PENDING
初始 SwingWorker 状态。

STARTED

public static final SwingWorker.StateValue STARTED
在调用 doInBackground 之前 STARTED（启动）SwingWorker。

DONE

public static final SwingWorker.StateValue DONE
doInBackground 方法完成之后 DONE（执行）SwingWorker。

方法详细信息

values

public static final SwingWorker.StateValue[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(SwingWorker.StateValue c : SwingWorker.StateValue.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static SwingWorker.StateValue valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


Timer (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 Timer

java.lang.Object
    继承者  javax.swing.Timer
所有已实现的接口：
Serializable
public class Timer
extends Object
implements Serializable

在指定时间间隔触发一个或多个 ActionEvent。一个示例用法是动画对象，它将 Timer 用作绘制其帧的触发器。

设置计时器的过程包括创建一个 Timer 对象，在该对象上注册一个或多个动作侦听器，以及使用 start 方法启动该计时器。例如，以下代码创建并启动一个每秒（该时间由 Timer 构造方法的第一个参数指定）触发一次动作事件的计时器。Timer 构造方法的第二个参数指定接收计时器动作事件的侦听器。

int delay = 1000; //milliseconds
  ActionListener taskPerformer = new ActionListener() {
      public void actionPerformed(ActionEvent evt) {
          //...Perform a task...
      }
  };
  new Timer(delay, taskPerformer).start();

构造 Timer 时要指定一个延迟参数和一个 ActionListener。延迟参数用于设置初始延迟和事件触发之间的延迟（以毫秒为单位）。启动了计时器后，它将在向已注册侦听器触发第一个 ActionEvent 之前等待初始延迟。第一个事件之后，每次超过事件间延迟时它都继续触发事件，直到被停止。

构造之后，可以单独更改初始延迟和事件间延迟，并且可以添加其他 ActionListener。

如果希望计时器只在第一次时触发然后停止，可以对计时器调用 setRepeats(false)。

尽管所有 Timer 都使用一个共享线程（由第一个执行操作的 Timer 对象创建）执行等待，但是 Timer 的动作事件处理程序还会在其他线程（事件指派线程上）执行。这意味着 Timer 的操作处理程序可以安全地在 Swing 组件上执行操作。但是，它也意味着处理程序必须快速执行以保证 GUI 作出响应。

在 1.3 版本中，向 Java 平台添加了另一个 Timer 类：java.util.Timer。该类和 javax.swing.Timer 的基本功能相同，但是 java.util.Timer 更常用，功能更多。javax.swing.Timer 有两个特征，它们可以让使用 GUI 更方便。首先，其事件处理程序都是 GUI 程序员所熟悉的，并且可以更简单地处理事件指派线程。第二，其自动线程共享意味着不必采取特殊步骤来避免生成过多线程。相反，计时器使用同一个线程让光标闪烁、使工具提示显示等等。

通过查看 The Java Tutorial 中的 How to Use Timers 一节，可以找到使用计时器的更详细的文档和几个示例。有关在此 Timer 类和 java.util.Timer 之间进行选择的更多示例和帮助信息，请参阅 The Swing Connection 中的 Using Timers in Swing Applications 一文。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参阅 XMLEncoder。

另请参见：
java.util.Timer

字段摘要
protected  EventListenerList listenerList
构造方法摘要
Timer(int delay, ActionListener listener)
创建一个 Timer 并将初始延迟和事件间延迟初始化为 delay 毫秒。
方法摘要
 void addActionListener(ActionListener listener)
将一个动作侦听器添加到 Timer。
protected  void fireActionPerformed(ActionEvent e)
通知为此事件类型的通知而注册的所有侦听器。
 String getActionCommand()
返回将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。
 ActionListener[] getActionListeners()
返回已在此计时器上注册的所有动作侦听器所组成的数组。
 int getDelay()
返回两次触发动作事件间延迟，以毫秒为单位。
 int getInitialDelay()
返回 Timer 的初始延迟。
<T extends EventListener>
T[]
getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。
static boolean getLogTimers()
如果启用了日志记录，则返回 true。
 boolean isCoalesce()
如果 Timer 组合多个挂起的动作事件，则返回 true。
 boolean isRepeats()
如果 Timer 多次将一个动作事件发送到其侦听器，则返回 true（默认）。
 boolean isRunning()
如果 Timer 正在运行，则返回 true。
 void removeActionListener(ActionListener listener)
从 Timer 移除指定的动作侦听器。
 void restart()
重新启动 Timer，取消所有挂起的触发并使它按初始延迟触发。
 void setActionCommand(String command)
设置将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。
 void setCoalesce(boolean flag)
设置 Timer 是否组合多个挂起的 ActionEvent 触发。
 void setDelay(int delay)
设置 Timer 的事件间延迟，两次连续的动作事件之间的毫秒数。
 void setInitialDelay(int initialDelay)
设置 Timer 的初始延迟，即启动计时器后触发第一个事件之前要等待的时间（以毫秒为单位）。
static void setLogTimers(boolean flag)
启用／禁用计时器日志。
 void setRepeats(boolean flag)
如果 flag 为 false，则指示 Timer 只向其侦听器发送一次动作事件。
 void start()
启动 Timer，使它开始向其侦听器发送动作事件。
 void stop()
停止 Timer，使它停止向其侦听器发送动作事件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

listenerList

protected EventListenerList listenerList
构造方法详细信息

Timer

public Timer(int delay,
             ActionListener listener)
创建一个 Timer 并将初始延迟和事件间延迟初始化为 delay 毫秒。如果 delay 小于等于 0，则该计时器一启动就触发事件。如果 listener 不为 null，则它会在计时器上注册为动作侦听器。

参数：
delay - 初始延迟和动作事件间延迟的毫秒数
listener - 初始侦听器；可以为 null
另请参见：
addActionListener(java.awt.event.ActionListener), setInitialDelay(int), setRepeats(boolean)
方法详细信息

addActionListener

public void addActionListener(ActionListener listener)
将一个动作侦听器添加到 Timer。

参数：
listener - 要添加的侦听器
另请参见：
Timer(int, java.awt.event.ActionListener)

removeActionListener

public void removeActionListener(ActionListener listener)
从 Timer 移除指定的动作侦听器。

参数：
listener - 要移除的侦听器

getActionListeners

public ActionListener[] getActionListeners()
返回已在此计时器上注册的所有动作侦听器所组成的数组。

返回：
此计时器的所有 ActionListener；如果当前没有注册任何动作侦听器，则返回一个空数组
从以下版本开始：
1.4
另请参见：
addActionListener(java.awt.event.ActionListener), removeActionListener(java.awt.event.ActionListener)

fireActionPerformed

protected void fireActionPerformed(ActionEvent e)
通知为此事件类型的通知而注册的所有侦听器。

参数：
e - 要触发的动作事件
另请参见：
EventListenerList

getListeners

public <T extends EventListener> T[] getListeners(Class<T> listenerType)
返回目前已在此 Timer 上注册为 FooListener 的所有对象所组成的数组。FooListener 是使用 addFooListener 方法注册的。

可以用一个类字面值（比如 FooListener.class）指定 listenerType 参数。例如，可以使用下面的代码查询 Timer 实例 t 的动作侦听器：

ActionListener[] als = (ActionListener[])(t.getListeners(ActionListener.class));
如果不存在这样的侦听器，则此方法将返回一个空数组。

参数：
listenerType - 所请求的侦听器的类型；该参数应该指定一个从 java.util.EventListener 继承的接口
返回：
在此计时器上注册为 FooListener 的所有对象所组成的数组；如果没有添加这样的侦听器，则返回一个空数组
抛出：
ClassCastException - 如果 listenerType 没有指定实现 java.util.EventListener 的类或接口
从以下版本开始：
1.3
另请参见：
getActionListeners(),
addActionListener(java.awt.event.ActionListener),
removeActionListener(java.awt.event.ActionListener)

setLogTimers

public static void setLogTimers(boolean flag)
启用／禁用计时器日志。启用时，每次计时器退出时都会向 System.out 发送一条信息。

参数：
flag - true 表示要启用日志记录
另请参见：
getLogTimers()

getLogTimers

public static boolean getLogTimers()
如果启用了日志记录，则返回 true。

返回：
如果启用了日志记录，则返回 true；否则，返回 false
另请参见：
setLogTimers(boolean)

setDelay

public void setDelay(int delay)
设置 Timer 的事件间延迟，两次连续的动作事件之间的毫秒数。这不会影响初始延迟属性，该属性可由 setInitialDelay 方法设置。

参数：
delay - 以毫秒为单位的延迟
另请参见：
setInitialDelay(int)

getDelay

public int getDelay()
返回两次触发动作事件间延迟，以毫秒为单位。

另请参见：
setDelay(int), getInitialDelay()

setInitialDelay

public void setInitialDelay(int initialDelay)
设置 Timer 的初始延迟，即启动计时器后触发第一个事件之前要等待的时间（以毫秒为单位）。构造时，此延迟设置为与事件间延迟相同，但是其值是独立的，并且不受事件间延迟更改的影响。

参数：
initialDelay - 初始延迟（以毫秒为单位）
另请参见：
setDelay(int)

getInitialDelay

public int getInitialDelay()
返回 Timer 的初始延迟。

另请参见：
setInitialDelay(int), setDelay(int)

setRepeats

public void setRepeats(boolean flag)
如果 flag 为 false，则指示 Timer 只向其侦听器发送一次动作事件。

参数：
flag - 指定 false 将使计时器在发送第一个动作事件之后停止

isRepeats

public boolean isRepeats()
如果 Timer 多次将一个动作事件发送到其侦听器，则返回 true（默认）。

另请参见：
setRepeats(boolean)

setCoalesce

public void setCoalesce(boolean flag)
设置 Timer 是否组合多个挂起的 ActionEvent 触发。忙碌的应用程序可能跟不上 Timer 的事件生成速度，导致多个动作事件排队。当处理这些事件时，应用程序会一个接一个地进行发送，导致 Timer 的侦听器收到一个没有事件间延迟的事件序列。组合操作可以将多个挂起的事件减少为一个事件，从而避免了这种情况的发生。默认情况下 Timer 将组合事件。

参数：
flag - 指定 false 将关闭组合

isCoalesce

public boolean isCoalesce()
如果 Timer 组合多个挂起的动作事件，则返回 true。

另请参见：
setCoalesce(boolean)

setActionCommand

public void setActionCommand(String command)
设置将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。null 是可接受的值。

参数：
command - 动作命令
从以下版本开始：
1.6

getActionCommand

public String getActionCommand()
返回将作为此计时器所触发的 ActionEvent 中的动作命令传递的字符串。可以为 null， null 也是默认值。

返回：
在触发事件中使用的动作命令
从以下版本开始：
1.6

start

public void start()
启动 Timer，使它开始向其侦听器发送动作事件。

另请参见：
stop()

isRunning

public boolean isRunning()
如果 Timer 正在运行，则返回 true。

另请参见：
start()

stop

public void stop()
停止 Timer，使它停止向其侦听器发送动作事件。

另请参见：
start()

restart

public void restart()
重新启动 Timer，取消所有挂起的触发并使它按初始延迟触发。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToolTipManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ToolTipManager

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.ToolTipManager
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener
public class ToolTipManager
extends MouseAdapter
implements MouseMotionListener

管理系统中的所有 ToolTips。

ToolTipManager 包含众多属性，用于配置该工具提示需要多长时间显示出来，需要多长时间隐藏。考虑一个在不同的鼠标位置（如 JTree）有不同工具提示的组件。在鼠标移动到 JTree 中和具有有效工具提示的区域上时，该工具提示将在 initialDelay 毫秒后显示出来。在 dismissDelay 毫秒后，将隐藏该工具提示。如果鼠标在具有有效工具提示的区域上，并且当前能看到该工具提示，则在鼠标移动到没有有效工具提示的区域时，将隐藏该工具提示。如果鼠标接下来在 reshowDelay 毫秒内移回具有有效工具提示的区域，则将立即显示该工具提示，否则在 initialDelay 毫秒后将再次显示该工具提示。

另请参见：
JComponent.createToolTip()

嵌套类摘要
protected class | ToolTipManager.insideTimerAction
protected class | ToolTipManager.outsideTimerAction
protected class | ToolTipManager.stillInsideTimerAction
字段摘要
protected boolean | heavyWeightPopupEnabled
protected boolean | lightWeightPopupEnabled
方法摘要
int | getDismissDelay() 返回取消工具提示的延迟值。
int | getInitialDelay() 返回初始延迟值。
int | getReshowDelay() 返回重新显示延迟属性。
boolean | isEnabled() 如果启用该对象，则返回 true。
boolean | isLightWeightPopupEnabled() 如果使用轻量级（所有 Java）Tooltips，则返回 true；如果使用重量级（本机同位体）Tooltips，则返回 false。
void | mouseDragged(MouseEvent event) 按下和拖动鼠标时调用。
void | mouseEntered(MouseEvent event) 鼠标进入组件区域时调用。
void | mouseExited(MouseEvent event) 鼠标退出组件区域时调用。
void | mouseMoved(MouseEvent event) 移动鼠标时调用。
void | mousePressed(MouseEvent event) 当按下鼠标时调用。
void | registerComponent(JComponent component) 注册一个工具提示管理组件。
void | setDismissDelay(int milliseconds) 指定取消工具提示的延迟值。
void | setEnabled(boolean flag) 启用或禁用工具提示。
void | setInitialDelay(int milliseconds) 指定初始延迟值。
void | setLightWeightPopupEnabled(boolean aFlag) 显示 JToolTip 时，该 ToolTipManager 会选择使用一个轻量级 JPanel（如果合适）。
void | setReshowDelay(int milliseconds) 在显示工具提示之前，用于指定用户必须等待 initialDelay 毫秒之前的时间。
static ToolTipManager | sharedInstance() 返回共享的 ToolTipManager 实例。
void | unregisterComponent(JComponent component) 从工具提示控件中移除一个组件。
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseReleased, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

lightWeightPopupEnabled

protected boolean lightWeightPopupEnabled

heavyWeightPopupEnabled

protected boolean heavyWeightPopupEnabled
方法详细信息

setEnabled

public void setEnabled(boolean flag)
启用或禁用工具提示。

参数：
flag - 要启用提示则为 true，否则为 false

isEnabled

public boolean isEnabled()
如果启用该对象，则返回 true。

返回：
如果启用该对象，则返回 true，否则，返回 false

setLightWeightPopupEnabled

public void setLightWeightPopupEnabled(boolean aFlag)
显示 JToolTip 时，该 ToolTipManager 会选择使用一个轻量级 JPanel（如果合适）。此方法允许您禁用该功能。如果应用程序混合轻量级组件和重量级组件，则必须真正禁用此功能。

参数：
aFlag - 如果需要轻量级面板，则为 true，否则为 false

isLightWeightPopupEnabled

public boolean isLightWeightPopupEnabled()
如果使用轻量级（所有 Java）Tooltips，则返回 true；如果使用重量级（本机同位体）Tooltips，则返回 false。

返回：
true 如果使用轻量级 ToolTips

setInitialDelay

public void setInitialDelay(int milliseconds)
指定初始延迟值。

参数：
milliseconds - （光标暂停之后）显示工具提示之前要延迟的毫秒数
另请参见：
getInitialDelay()

getInitialDelay

public int getInitialDelay()
返回初始延迟值。

返回：
一个表示该初始延迟值的整数，以毫秒为单位
另请参见：
setInitialDelay(int)

setDismissDelay

public void setDismissDelay(int milliseconds)
指定取消工具提示的延迟值。

参数：
milliseconds - 取消工具提示之前要延迟的毫秒数
另请参见：
getDismissDelay()

getDismissDelay

public int getDismissDelay()
返回取消工具提示的延迟值。

返回：
一个表示取消工具提示的延迟值的整数，以毫秒为单位
另请参见：
setDismissDelay(int)

setReshowDelay

public void setReshowDelay(int milliseconds)
在显示工具提示之前，用于指定用户必须等待 initialDelay 毫秒之前的时间。也就是说，如果隐藏工具提示，且用户在 milliseconds 毫秒内移动到同一个具有有效工具提示的组件，则立即显示该工具提示。否则，如果用户在 milliseconds 毫秒之后移动到具有有效工具提示的区域，则用户必须在再次显示该工具提示之前再等待 initialDelay 毫秒。

参数：
milliseconds - 以毫秒为单位的时间
另请参见：
getReshowDelay()

getReshowDelay

public int getReshowDelay()
返回重新显示延迟属性。

返回：
重新显示的延迟属性
另请参见：
setReshowDelay(int)

sharedInstance

public static ToolTipManager sharedInstance()
返回共享的 ToolTipManager 实例。

返回：
共享的 ToolTipManager 对象

registerComponent

public void registerComponent(JComponent component)
注册一个工具提示管理组件。

这将注册键绑定，以在仅当 component 具有焦点绑定时显示和隐藏工具提示文本。执行此操作，以使通常不是焦点遍历的组件（如 JLabel）不会因为调用此方法而进行焦点遍历。

参数：
component - 要添加的 JComponent 对象
另请参见：
Component.isFocusTraversable()

unregisterComponent

public void unregisterComponent(JComponent component)
从工具提示控件中移除一个组件。

参数：
component - 要移除的 JComponent 对象

mouseEntered

public void mouseEntered(MouseEvent event)
鼠标进入组件区域时调用。这确定是否应该显示该工具提示。

指定者：
接口 MouseListener 中的 mouseEntered
覆盖：
类 MouseAdapter 中的 mouseEntered
参数：
event - 相关事件

mouseExited

public void mouseExited(MouseEvent event)
鼠标退出组件区域时调用。任何显示的工具提示都应该隐藏。

指定者：
接口 MouseListener 中的 mouseExited
覆盖：
类 MouseAdapter 中的 mouseExited
参数：
event - 相关事件

mousePressed

public void mousePressed(MouseEvent event)
当按下鼠标时调用。任何工具提示显示都应该隐藏。

指定者：
接口 MouseListener 中的 mousePressed
覆盖：
类 MouseAdapter 中的 mousePressed
参数：
event - 相关事件

mouseDragged

public void mouseDragged(MouseEvent event)
按下和拖动鼠标时调用。不执行任何操作。

指定者：
接口 MouseMotionListener 中的 mouseDragged
覆盖：
类 MouseAdapter 中的 mouseDragged
参数：
event - 相关事件

mouseMoved

public void mouseMoved(MouseEvent event)
移动鼠标时调用。确定是否应该显示工具提示。

指定者：
接口 MouseMotionListener 中的 mouseMoved
覆盖：
类 MouseAdapter 中的 mouseMoved
参数：
event - 相关事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToolTipManager.insideTimerAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ToolTipManager.insideTimerAction

java.lang.Object
    继承者  javax.swing.ToolTipManager.insideTimerAction
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
ToolTipManager
protected class ToolTipManager.insideTimerAction
extends Object
implements ActionListener

构造方法摘要
protected ToolTipManager.insideTimerAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ToolTipManager.insideTimerAction

protected ToolTipManager.insideTimerAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToolTipManager.outsideTimerAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ToolTipManager.outsideTimerAction

java.lang.Object
    继承者  javax.swing.ToolTipManager.outsideTimerAction
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
ToolTipManager
protected class ToolTipManager.outsideTimerAction
extends Object
implements ActionListener

构造方法摘要
protected ToolTipManager.outsideTimerAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ToolTipManager.outsideTimerAction

protected ToolTipManager.outsideTimerAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ToolTipManager.stillInsideTimerAction (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ToolTipManager.stillInsideTimerAction

java.lang.Object
    继承者  javax.swing.ToolTipManager.stillInsideTimerAction
所有已实现的接口：
ActionListener, EventListener
正在封闭类：
ToolTipManager
protected class ToolTipManager.stillInsideTimerAction
extends Object
implements ActionListener

构造方法摘要
protected ToolTipManager.stillInsideTimerAction()
方法摘要
 void actionPerformed(ActionEvent e)
发生操作时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ToolTipManager.stillInsideTimerAction

protected ToolTipManager.stillInsideTimerAction()
方法详细信息

actionPerformed

public void actionPerformed(ActionEvent e)
从接口 ActionListener 复制的描述
发生操作时调用。

指定者：
接口 ActionListener 中的 actionPerformed
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransferHandler (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 TransferHandler

java.lang.Object
    继承者  javax.swing.TransferHandler
所有已实现的接口：
Serializable
public class TransferHandler
extends Object
implements Serializable

此类用于处理往返于 Swing 组件的 Transferable 的传输。该 Transferable 用于表示通过往/返于剪贴板的剪切、复制或粘贴操作进行交换的数据。它还在拖放操作中使用，以表示对组件进行拖动和放置组件。Swing 提供自动支持剪切、复制和粘贴的键盘绑定的功能，该键盘绑定使用由此类的实现提供的功能。Swing 还提供自动支持拖放操作的功能，该拖放操作使用由此类的实现提供的功能。Swing 开发人员可以主要通过在 Swing 组件上设置 transferHandler 属性专门指定传输语义。

只通过指定构造方法中的属性名称即可实现此类，以提供传输某个组件属性的默认行为。例如，要通过剪贴板或拖放操作将前景色从一个组件传输到另一个组件，可以使用字符串 "foreground" 构造一个 TransferHandler。内置支持将把由 getForeground 返回的颜色用作该传输的源，把由 setForeground 返回的颜色用作传输的目标。

有关更多信息，请参阅 The Java Tutorial 中的 How to Use Drag and Drop and Data Transfer 一节。

从以下版本开始：
1.4

嵌套类摘要
static class | TransferHandler.DropLocation 表示放置的数据 (dropped data) 应该插入的位置。
static class | TransferHandler.TransferSupport 此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。
字段摘要
static int | COPY 表示“复制”传输动作的 int 值。
static int | COPY_OR_MOVE 表示“复制”或“移动”的源操作功能的 int 值。
static int | LINK 表示“链接”传输动作的 int 值。
static int | MOVE 表示“移动”传输动作的 int 值。
static int | NONE 表示无传输动作的 int 值。
构造方法摘要
protected | TransferHandler() 子类的便捷构造方法。
 | TransferHandler(String property) 构造一个通过剪贴板或拖放操作可以将 Java Bean 属性从一个组件传输到另一个组件的传输处理程序。
方法摘要
boolean | canImport(JComponent comp, DataFlavor[] transferFlavors) 指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。
boolean | canImport(TransferHandler.TransferSupport support) 在拖放操作期间重复调用此方法，以允许开发人员配置传输的可接受性属性，并返回传输的可接受性；返回 true 值指示给定 TransferSupport（它包含该传输的所有细节）所表示的传输在当前是可以接受的，false 值指示拒绝该传输。
protected Transferable | createTransferable(JComponent c) 创建一个要用作数据传输源的 Transferable。
void | exportAsDrag(JComponent comp, InputEvent e, int action) 导致 Swing 拖动支持的启用。
protected void | exportDone(JComponent source, Transferable data, int action) 在导出数据之后调用。
void | exportToClipboard(JComponent comp, Clipboard clip, int action) 导致从给定组件到给定剪贴板的传输。
static Action | getCopyAction() 返回一个执行复制到剪贴板操作的 Action。
static Action | getCutAction() 返回一个执行剪切到剪贴板操作的 Action。
static Action | getPasteAction() 返回一个从剪贴板执行粘贴操作的 Action。
int | getSourceActions(JComponent c) 返回源支持的传输动作的类型；COPY、MOVE 和 LINK 的任意按位或组合。
Icon | getVisualRepresentation(Transferable t) 返回一个建立传输外观的对象。
boolean | importData(JComponent comp, Transferable t) 导致从剪贴板或 DND 放置操作向组件的传输。
boolean | importData(TransferHandler.TransferSupport support) 导致从剪贴板或拖放操作的传输。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

NONE

public static final int NONE
表示无传输动作的 int 值。

另请参见：
常量字段值

COPY

public static final int COPY
表示“复制”传输动作的 int 值。将数据复制到剪贴板或复制到拖放操作中其他位置时使用此值。

另请参见：
常量字段值

MOVE

public static final int MOVE
表示“移动”传输动作的 int 值。将数据移动到剪贴板（即剪切）或移动到拖放操作中的其他位置时使用此值。

另请参见：
常量字段值

COPY_OR_MOVE

public static final int COPY_OR_MOVE
表示“复制”或“移动”的源操作功能的 int 值。

另请参见：
常量字段值

LINK

public static final int LINK
表示“链接”传输动作的 int 值。此值用于指定应该以拖放操作链接数据。

从以下版本开始：
1.6
另请参见：
DnDConstants.ACTION_LINK, 常量字段值
构造方法详细信息

TransferHandler

public TransferHandler(String property)
构造一个通过剪贴板或拖放操作可以将 Java Bean 属性从一个组件传输到另一个组件的传输处理程序。

参数：
property - 要传输的属性的名称；如果没有与该传输处理程序相关的属性（例如，执行其他某种传输的子类），则可以为 null

TransferHandler

protected TransferHandler()
子类的便捷构造方法。

方法详细信息

getCutAction

public static Action getCutAction()
返回一个执行剪切到剪贴板操作的 Action。在执行时，此动作通过对组件的 TransferHandler 调用带 MOVE 动作的 exportToClipboard，在 ActionEvent 的 JComponent 源上进行操作。

返回：
一个执行剪切到剪贴板的 Action

getCopyAction

public static Action getCopyAction()
返回一个执行复制到剪贴板操作的 Action。在执行时，此动作通过对组件的 TransferHandler 调用带 COPY 动作的 exportToClipboard，在 ActionEvent 的 JComponent 源上进行操作。

返回：
一个执行复制到剪贴板的 Action

getPasteAction

public static Action getPasteAction()
返回一个从剪贴板执行粘贴操作的 Action。在执行时，此动作通过对组件的 TransferHandler 调用带有剪贴板内容的 importData，在 ActionEvent 的 JComponent 源上进行操作。

返回：
一个从剪贴板执行粘贴的 Action

exportAsDrag

public void exportAsDrag(JComponent comp,
                         InputEvent e,
                         int action)
导致 Swing 拖动支持的启用。如果在组件上设置 dragEnabled 属性，则由 javax.swing.plaf.basic 包中的各种 UI 实现调用此方法。可由使用 Swing 拖动支持的自定义 UI 实现调用此方法。也可由作为 JComponent 的子类写入的 Swing 扩展调用此方法，以利用 Swing 拖动支持。

传输不必 在返回此调用时完成（即该调用不会在等待放置时阻塞）。该传输将通过 java.awt.dnd 机制的 Swing 实现进行，无需开发人员投入更大精力。完成该传输时将调用 exportDone 方法。

参数：
comp - 存储要传输的数据的组件；提供此参数以启用 TransferHandler 的共享
e - 触发该传输的事件
action - 最初请求的传输动作；为 COPY、MOVE 或 LINK；DnD 系统可以在执行拖动操作的过程中更改所使用的动作

exportToClipboard

public void exportToClipboard(JComponent comp,
                              Clipboard clip,
                              int action)
                       throws IllegalStateException
导致从给定组件到给定剪贴板的传输。可以由在组件的操作映射中注册的默认剪切和复制操作调用该方法。

该传输将使用 java.awt.datatransfer 机制进行，无需开发人员投入更大精力。任何数据传输都将 在此 exportDone 方法返回之前完成，并使用发生的操作调用该方法。如果尝试在其上放置数据时剪贴板不可用，则由 Clipboard.setContents(Transferable, ClipboardOwner) 抛出的 IllegalStateException 将通过此方法传播。但是，出于一致性考虑，首先要使用 NONE 操作调用 exportDone。

参数：
comp - 存储要传输的数据的组件；提供此参数以启用 TransferHandler 的共享
clip - 要向其传输数据的剪贴板
action - 请求的传输动作；这应该是 COPY 或 MOVE 二者的其中一个值；执行的操作是由 getSourceActions 和请求的操作给定的传输功能的交集；如果不支持请求的操作，则该交集可能会导致 NONE 操作
抛出：
IllegalStateException - 如果该剪贴板当前不可用
另请参见：
Clipboard.setContents(Transferable, ClipboardOwner)

importData

public boolean importData(TransferHandler.TransferSupport support)
导致从剪贴板或拖放操作的传输。要导入的 Transferable 和要传输到的组件包含在 TransferSupport 中。

拖放实现在调用此方法前调用 canImport 确定是否适合传输，但粘贴的实现不会这样做。因此，调用此方法进行粘贴时不能假定传输一定是可接受的。这种情况下，建议显式调用 canImport。

注：传递给此方法的 TransferSupport 对象只在该方法的调用期间才有效。此方法返回后它可以包含的值是不确定的。

参数：
support - 包含该传输细节的对象，不为 null。
返回：
如果数据被插入该组件，则返回 true；否则返回 false
抛出：
NullPointerException - 如果 support 为 null
从以下版本开始：
1.6
另请参见：
canImport(TransferHandler.TransferSupport)

importData

public boolean importData(JComponent comp,
                          Transferable t)
导致从剪贴板或 DND 放置操作向组件的传输。Transferable 表示要导入组件的数据。

注：Swing 现在调用新的 importData，它带有 TransferSupport，而 TransferSupport 调用此方法（如果 TransferSupport 中的组件是 JComponent）。鼓励开发人员调用并重写新的版本，因为它提供了更多信息（它也是唯一支持与直接在 JFrame 或其他非 JComponent 上设置的 TransferHandler 一起使用的版本）。

参数：
comp - 要接收传输的组件；提供此参数以启用 TransferHandler 的共享
t - 要导入的数据
返回：
如果该数据已插入到组件，则返回 true，否则返回 false
另请参见：
importData(TransferHandler.TransferSupport)

canImport

public boolean canImport(TransferHandler.TransferSupport support)
在拖放操作期间重复调用此方法，以允许开发人员配置传输的可接受性属性，并返回传输的可接受性；返回 true 值指示给定 TransferSupport（它包含该传输的所有细节）所表示的传输在当前是可以接受的，false 值指示拒绝该传输。

对于在拖放期间自动显示放置位置的那些组件（接受传输），默认情况下，告知它们显示放置位置。这可通过在 TransferSupport 上调用 setShowDropLocation 更改。

默认情况下，当接受传输时，选择的放置动作是用户通过其拖动动作挑出的动作。通过在 TransferSupport 上调用 setDropAction，开发人员可以重写此方法并从受支持的源动作中选择一个不同的动作。

每次调用 canImport 时，TransferSupport 都包含新状态。因此，每次调用时都必须设置在其上设置的所有属性。对于放置操作，调用 importData 之前最后再调用一次 canImport。最后一次调用期间在 TransferSupport 上设置的任何状态在 importData 中都是可用的。

不会内部调用此方法来响应粘贴操作。因此，对于这种情况，建议 importData 的实现显式调用此方法，并建议此方法还要准备好返回是否适合粘贴操作。

注：传递给此方法的 TransferSupport 对象只在该方法的调用期间才有效。此方法返回后可以包含的值是不确定的。

参数：
support - 包含该传输的细节的对象，不为 null。
返回：
如果导入可能发生，则返回 true；否则返回 false
抛出：
NullPointerException - 如果 support 为 null
从以下版本开始：
1.6
另请参见：
importData(TransferHandler.TransferSupport),
TransferHandler.TransferSupport.setShowDropLocation(boolean),
TransferHandler.TransferSupport.setDropAction(int)

canImport

public boolean canImport(JComponent comp,
                         DataFlavor[] transferFlavors)
指示一个组件在实际尝试导入给定数据 flavor 的集合之前是否接受其导入。

注：Swing 现在调用新的 importData，它带有 TransferSupport，而 TransferSupport 调用此方法（当且仅当 TransferSupport 中的组件是 JComponent 时）。鼓励开发人员调用并重写新的版本，因为它提供了更多信息（它也是唯一支持与直接在 JFrame 或其他非 JComponent 上设置的 TransferHandler 一起使用的版本）。

参数：
comp - 要接收传输的组件；提供此参数以启用 TransferHandlers 的共享
transferFlavors - 可用的数据格式
返回：
如果可以将该数据插入到组件，则返回 true，否则返回 false
另请参见：
canImport(TransferHandler.TransferSupport)

getSourceActions

public int getSourceActions(JComponent c)
返回源支持的传输动作的类型；COPY、MOVE 和 LINK 的任意按位或组合。

有些模型是不可变的，因此 MOVE 的传输动作不应该在这种情况下公开。返回 NONE 禁用该组件的传输。

参数：
c - 存储要传输的数据的组件；提供此参数以启用 TransferHandler 的共享
返回：
如果可以找到该传输属性，则返回 COPY；否则返回 NONE

getVisualRepresentation

public Icon getVisualRepresentation(Transferable t)
返回一个建立传输外观的对象。此方法适用于在执行拖动操作时提供反馈和在具有可视化外观的剪贴板实现中表示传输。该 Icon 接口的实现不应更改图形剪贴或 alpha 级别。该图标实现不必是矩形，也不必绘制所有边界矩形，并且调用该图标绘制方法的逻辑不应假定绘制了所有位。null 是此方法的一个有效返回值，指示没有提供任何可视化表示形式。在这种情况下，该调用逻辑完全可以随意表示该 transferable。

如果返回值为 null，则该默认 Swing 逻辑将不执行 alpha 混合拖动动画。

参数：
t - 要传输的数据；此值希望已由 createTransferable 方法创建
返回：
null，指示没有任何默认可视化表示形式

createTransferable

protected Transferable createTransferable(JComponent c)
创建一个要用作数据传输源的 Transferable。返回要传输的数据表示形式，或者返回 null 如果组件的属性为 null

参数：
c - 存储要传输的数据的组件；提供此参数以启用 TransferHandler 的共享
返回：
要传输的数据表示形式，或返回 null 如果与 c 相关的属性为 null

exportDone

protected void exportDone(JComponent source,
                          Transferable data,
                          int action)
在导出数据之后调用。如果该操作为 MOVE，则此方法应该移除已传输的数据。

因为 MOVE 不是此实现支持的操作，所以实现此方法不执行任何操作（getSourceActions 不包括 MOVE）。

参数：
source - 以前作为数据源的组件
data - 已传输的数据，如果该操作为 NONE，则可能为 null。
action - 已执行的实际操作
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransferHandler.DropLocation (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 TransferHandler.DropLocation

java.lang.Object
    继承者  javax.swing.TransferHandler.DropLocation
直接已知子类：
JList.DropLocation, JTable.DropLocation, JTextComponent.DropLocation, JTree.DropLocation
正在封闭类：
TransferHandler
public static class TransferHandler.DropLocation
extends Object

表示放置的数据 (dropped data) 应该插入的位置。这是一个基类，它仅封装一个点。支持放置操作的组件可以提供包含更多信息的此方法的子类。

开发人员通常不应该创建此类的实例或扩展此类。它们是由 DnD 实现通过 TransferSupport 实例和带 getDropLocation() 方法的组件提供的。

从以下版本开始：
1.6
另请参见：
TransferHandler.TransferSupport.getDropLocation()

构造方法摘要
protected TransferHandler.DropLocation(Point dropPoint)
构造给定点的放置位置。
方法摘要
Point | getDropPoint() 返回放置点，表示组件内鼠标的当前位置。
String | toString() 返回此放置位置的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

TransferHandler.DropLocation

protected TransferHandler.DropLocation(Point dropPoint)
构造给定点的放置位置。

参数：
dropPoint - 放置点，表示组件内鼠标的当前位置。
抛出：
IllegalArgumentException - 如果点为 null
方法详细信息

getDropPoint

public final Point getDropPoint()
返回放置点，表示组件内鼠标的当前位置。

返回：
放置点。

toString

public String toString()
返回此放置位置的字符串表示形式。此方法仅用于调试，对于各个实现，所返回字符串的内容和格式可能有所不同。

覆盖：
类 Object 中的 toString
返回：
此放置位置的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TransferHandler.TransferSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 TransferHandler.TransferSupport

java.lang.Object
    继承者  javax.swing.TransferHandler.TransferSupport
正在封闭类：
TransferHandler
public static final class TransferHandler.TransferSupport
extends Object

此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。

此类的主要目的是提供开发人员需要的信息，以便确定传输的适合性或者导入传输中包含的数据。但它同时又是一个控制器，可自定义拖放过程中的属性，比如是否显示放置位置，使用哪种放置动作等。

开发人员通常不需要创建此类的实例。它们是 DnD 实现向 TransferHandler 中的某些方法提供的。

从以下版本开始：
1.6
另请参见：
TransferHandler.canImport(TransferHandler.TransferSupport), TransferHandler.importData(TransferHandler.TransferSupport)

构造方法摘要
TransferHandler.TransferSupport(Component component, Transferable transferable)
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。
方法摘要
Component | getComponent() 返回此传输的目标组件。
DataFlavor[] | getDataFlavors() 返回此传输的数据 flavor。
int | getDropAction() 当此 TransferSupport 表示放置操作时，返回为其选择的动作。
TransferHandler.DropLocation | getDropLocation() 此 TransferSupport 表示一个放置操作时，返回组件的当前放置位置（非 null）。
int | getSourceDropActions() 当此 TransferSupport 表示放置操作时，返回拖动源受支持的放置动作。
Transferable | getTransferable() 返回与此传输关联的 Transferable。
int | getUserDropAction() 当此 TransferSupport 表示一个放置操作时，返回其用户放置动作。
boolean | isDataFlavorSupported(DataFlavor df) 返回是否支持给定的数据 flavor。
boolean | isDrop() 返回此 TransferSupport 是否表示一个放置操作。
void | setDropAction(int dropAction) 将传输（必须表示一个放置操作）的放置动作设置为给定动作，而不是默认的用户放置动作。
void | setShowDropLocation(boolean showDropLocation) 设置是否应该为传输（必须表示一个放置操作）可视地指出放置位置。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

TransferHandler.TransferSupport

public TransferHandler.TransferSupport(Component component,
                                       Transferable transferable)
使用给定组件和 Transferable 创建一个 TransferSupport，对于该 TransferSupport isDrop() 返回 false。

参数：
component - 目标组件
transferable - transferable
抛出：
NullPointerException - 如果任一参数为 null
方法详细信息

isDrop

public boolean isDrop()
返回此 TransferSupport 是否表示一个放置操作。

返回：
如果这是一个放置操作，则返回 true；否则返回 false。

getComponent

public Component getComponent()
返回此传输的目标组件。

返回：
目标组件

getDropLocation

public TransferHandler.DropLocation getDropLocation()
此 TransferSupport 表示一个放置操作时，返回组件的当前放置位置（非 null）。

注：对于带内置放置操作支持的组件，此位置将是一个 DropLocation 的子类，该 DropLocation 的类型与该组件的 getDropLocation 方法返回的相同。

此方法只用于拖放传输。isDrop() 为 false 时调用此方法将导致 IllegalStateException。

返回：
放置位置
抛出：
IllegalStateException - 如果此 TransferSupport 不是一个放置操作
另请参见：
isDrop

setShowDropLocation

public void setShowDropLocation(boolean showDropLocation)
设置是否应该为传输（必须表示一个放置操作）可视地指出放置位置。此方法用于那些在拖放操作过程的适当时候能够自动显示放置位置的组件。默认情况下，只有在 TransferHandler 已声明它能够接受此 TransferSupport 表示的导入时才显示放置位置。使用此方法，可以将放置位置强制改为总是显示，或总是不显示。

此方法只用于拖放传输。isDrop() 为 false 时调用此方法将导致 IllegalStateException。

参数：
showDropLocation - 是否指示放置位置
抛出：
IllegalStateException - 如果此 TransferSupport 不是一个放置操作
另请参见：
isDrop

setDropAction

public void setDropAction(int dropAction)
将传输（必须表示一个放置操作）的放置动作设置为给定动作，而不是默认的用户放置动作。此动作必须受源放置动作的支持，并且必须为 COPY、MOVE 或 LINK 之一。

此方法只用于拖放传输。isDrop() 为 false 时调用此方法将导致 IllegalStateException。

参数：
dropAction - 放置动作
抛出：
IllegalStateException - 如果此 TransferSupport 不是一个放置操作
IllegalArgumentException - 如果指定了无效的动作
另请参见：
getDropAction(),
getUserDropAction(),
getSourceDropActions(),
isDrop

getDropAction

public int getDropAction()
当此 TransferSupport 表示放置操作时，返回为其选择的动作。

除非通过 setDropAction 显式地选择，否则此方法返回 getUserDropAction 提供的用户放置动作。

可以使用 TransferHandler 的 importData 方法查询此动作，以便根据该动作自定义处理方法。

此方法只用于拖放传输。isDrop() 为 false 时调用此方法将导致 IllegalStateException。

返回：
为放置操作选择的动作 throws IllegalStateException 如果此 TransferSupport 不是一个放置操作
另请参见：
setDropAction(int), getUserDropAction(), isDrop

getUserDropAction

public int getUserDropAction()
当此 TransferSupport 表示一个放置操作时，返回其用户放置动作。

根据 DropTargetDragEvent 和 DropTargetDropEvent 文档中的描述，为放置操作选择用户放置动作。通过 setDropAction 方法，可以选择不同的动作作为放置动作。

当要确定放置操作的适合性或者对显式地选择放置动作作决定的时候，可以使用 TransferHandler 的 canImport 方法查询此动作。

此方法只用于拖放传输。isDrop() 为 false 时调用此方法将导致 IllegalStateException。

返回：
用户放置动作
抛出：
IllegalStateException - 如果此 TransferSupport 不是一个放置操作
另请参见：
setDropAction(int), getDropAction(), isDrop

getSourceDropActions

public int getSourceDropActions()
当此 TransferSupport 表示放置操作时，返回拖动源受支持的放置动作。

源动作表示此传输的源所支持的动作集合，并表示为 COPY、MOVE 和 LINK 的某个按位或组合。当要确定放置操作的适合性或者对显式地选择放置动作作决定的时候，可以使用 TransferHandler 的 canImport 方法查询此动作。要确定源是否支持指定动作，可以将该动作与源放置动作进行按位加，然后将结果与初始动作进行比较。例如：

boolean copySupported = (COPY & getSourceDropActions()) == COPY;

此方法只用于拖放传输。isDrop() 为 false 时调用此方法将导致 IllegalStateException。

返回：
拖动源受支持的放置动作
抛出：
IllegalStateException - 如果此 TransferSupport 不是一个放置操作
另请参见：
isDrop

getDataFlavors

public DataFlavor[] getDataFlavors()
返回此传输的数据 flavor。

返回：
此传输的数据 flavor

isDataFlavorSupported

public boolean isDataFlavorSupported(DataFlavor df)
返回是否支持给定的数据 flavor。

参数：
df - 要测试的 DataFlavor
返回：
是否支持给定的 flavor。

getTransferable

public Transferable getTransferable()
返回与此传输关联的 Transferable。

注：除非有必要直接获取 Transferable，否则使用此类的其他方法之一查询传输。这可能比直接获取 Transferable 并询问它执行得更好。

返回：
与此传输关联的 Transferable
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIDefaults (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 UIDefaults

java.lang.Object
    继承者  java.util.Dictionary<K,V>
        继承者  java.util.Hashtable<Object,Object>
            继承者  javax.swing.UIDefaults
所有已实现的接口：
Serializable, Cloneable, Map<Object,Object>
public class UIDefaults
extends Hashtable<Object,Object>

Swing 组件的默认值表。应用程序可以通过 UIManager 设置/获取默认值。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
UIManager

嵌套类摘要
static interface | UIDefaults.ActiveValue 此类使用户能够在默认表中存储项，该默认表在每次使用某个 getXXX(key) 方法进行查找时创建。
static class | UIDefaults.LazyInputMap LazyInputMap 将在其 createValue 方法中创建一个 InputMap。
static interface | UIDefaults.LazyValue 此类使用户能够在默认表中存储项，该默认表只有在第一次使用某个 getXXX(key) 方法进行查找时才创建。
static class | UIDefaults.ProxyLazyValue 此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。
构造方法摘要
UIDefaults()
创建一个空默认值表。
UIDefaults(int initialCapacity, float loadFactor)
创建一个带有指定初始容量和加载因子的空默认值表。
UIDefaults(Object[] keyValueList)
创建一个使用指定键/值对初始化的默认值表。
方法摘要
 void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。
 void addResourceBundle(String bundleName)
将一个资源包添加到从中搜索本地化值的资源包的列表中。
protected  void firePropertyChange(String propertyName, Object oldValue, Object newValue)
支持报告绑定属性更改。
 Object get(Object key)
返回键的值。
 Object get(Object key, Locale l)
返回与给定语言环境相关的那些键的值。
 boolean getBoolean(Object key)
如果 key 是 boolean 值，则返回该 boolean 值，否则返回 false。
 boolean getBoolean(Object key, Locale l)
如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。
 Border getBorder(Object key)
如果 key 值为一个 Border，则返回该 Border，否则返回 null。
 Border getBorder(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。
 Color getColor(Object key)
如果 key 值为一个 Color，则返回它，否则返回 null。
 Color getColor(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。
 Locale getDefaultLocale()
返回该默认语言环境。
 Dimension getDimension(Object key)
如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
 Dimension getDimension(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。
 Font getFont(Object key)
如果 key 值为一个 Font，则返回该 Font，否则返回 null。
 Font getFont(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。
 Icon getIcon(Object key)
如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。
 Icon getIcon(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。
 Insets getInsets(Object key)
如果 key 值为一个 Insets，则返回它，否则返回 null。
 Insets getInsets(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。
 int getInt(Object key)
如果 key 值为一个 Integer，则返回该整数值，否则返回 0。
 int getInt(Object key, Locale l)
如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。
 PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 UIDefaults 的所有 PropertyChangeListener 组成的数组。
 String getString(Object key)
如果 key 值为一个 String，则返回该 String，否则返回 null。
 String getString(Object key, Locale l)
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。
 ComponentUI getUI(JComponent target)
创建一个指定组件的 ComponentUI 实现。
 Class<? extends ComponentUI> getUIClass(String uiClassID)
返回呈现此组件的 L&F 类。
 Class<? extends ComponentUI> getUIClass(String uiClassID, ClassLoader uiClassLoader)
get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。
protected  void getUIError(String msg)
如果由于某种原因导致 getUI() 失败，则它会在返回 null 之前调用此方法。
 Object put(Object key, Object value)
将 key 值设置为所有语言环境的 value。
 void putDefaults(Object[] keyValueList)
将所有键/值对放入数据库中，并无条件地生成一个 PropertyChangeEvent。
 void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。
 void removeResourceBundle(String bundleName)
从在其中搜索本地化默认的资源包列表中移除一个资源包。
 void setDefaultLocale(Locale l)
设置默认语言环境。
从类 java.util.Hashtable 继承的方法
clear, clone, contains, containsKey, containsValue, elements, entrySet, equals, hashCode, isEmpty, keys, keySet, putAll, rehash, remove, size, toString, values
从类 java.lang.Object 继承的方法
finalize, getClass, notify, notifyAll, wait, wait, wait

构造方法详细信息

UIDefaults

public UIDefaults()
创建一个空默认值表。

UIDefaults

public UIDefaults(int initialCapacity,
                  float loadFactor)
创建一个带有指定初始容量和加载因子的空默认值表。

参数：
initialCapacity - 默认值表的初始容量
loadFactor - 默认值表的加载因子
从以下版本开始：
1.6
另请参见：
Hashtable

UIDefaults

public UIDefaults(Object[] keyValueList)
创建一个使用指定键/值对初始化的默认值表。例如：
        Object[] uiDefaults = {
             "Font", new Font("Dialog", Font.BOLD, 12),
            "Color", Color.red,
"five", new Integer(5)
        }
        UIDefaults myDefaults = new UIDefaults(uiDefaults);

参数：
keyValueList - 包含键/值对的对象数组
方法详细信息

get

public Object get(Object key)
返回键的值。如果该值为 UIDefaults.LazyValue，则使用 LazyValue.createValue() 计算其实际值，替换表项并返回实际值。如果该值为 UIDefaults.ActiveValue，则不替换表项，而是使用每个 get() 调用的 ActiveValue.createValue() 来计算该值。如果未在表中找到该键，则在此对象维护的资源包中搜索它。使用由 getDefaultLocale 返回的语言环境首先搜索最近添加的资源包。LazyValues 和 ActiveValues 在资源包中不受支持。

指定者：
接口 Map<Object,Object> 中的 get
覆盖：
类 Hashtable<Object,Object> 中的 get
参数：
key - 所需的键
返回：
key 的值
从以下版本开始：
1.4
另请参见：
UIDefaults.LazyValue,
UIDefaults.ActiveValue,
Hashtable.get(java.lang.Object),
getDefaultLocale(),
addResourceBundle(java.lang.String)

get

public Object get(Object key,
                  Locale l)
返回与给定语言环境相关的那些键的值。如果该值为 UIDefaults.LazyValue，则使用 LazyValue.createValue() 计算其实际值、替换表项并返回实际值。如果该值为 UIDefaults.ActiveValue，则不替换表项，而是使用每个 get() 调用的 ActiveValue.createValue() 来计算该值。如果未在表中找到该键，则在由此对象维护的资源包中搜索它。使用给定的语言环境首先搜索最近添加的资源包。LazyValues 和 ActiveValues 在资源包中不受支持。

参数：
key - 所需的键
l - 所需的 locale
返回：
key 的值
从以下版本开始：
1.4
另请参见：
UIDefaults.LazyValue, UIDefaults.ActiveValue, Hashtable.get(java.lang.Object), addResourceBundle(java.lang.String)

put

public Object put(Object key,
                  Object value)
将 key 值设置为所有语言环境的 value。如果 key 为一个字符串且新值不等于旧值，则触发一个 PropertyChangeEvent。如果值为 null，则从表中移除该键。

指定者：
接口 Map<Object,Object> 中的 put
覆盖：
类 Hashtable<Object,Object> 中的 put
参数：
key - 使用其值检索与之相关的数据值的惟一 Object
value - 要以数据形式在该键下存储的新 Object
返回：
以前的 Object 值，或 null
另请参见：
putDefaults(java.lang.Object[]), Hashtable.put(K, V)

putDefaults

public void putDefaults(Object[] keyValueList)
将所有键/值对放入数据库中，并无条件地生成一个 PropertyChangeEvent。事件 oldValue 和 newValue 将为 null，而其 propertyName 将为“UIDefaults”。为所有语言环境添加键/值对。

参数：
keyValueList - 键/值对数组
另请参见：
put(java.lang.Object, java.lang.Object), Hashtable.put(K, V)

getFont

public Font getFont(Object key)
如果 key 值为一个 Font，则返回该 Font，否则返回 null。

参数：
key - 所需的键
返回：
如果 key 的值为一个 Font，则返回该 Font 对象；否则返回 null

getFont

public Font getFont(Object key,
                    Locale l)
如果给定 Locale 的 key 值为一个 Font，则返回它，否则返回 null。

参数：
key - 所需的键
l - 所需语言环境
返回：
如果 key 和 Locale 的值为一个 Font，则返回该 Font 对象；否则返回 null
从以下版本开始：
1.4

getColor

public Color getColor(Object key)
如果 key 值为一个 Color，则返回它，否则返回 null。

参数：
key - 所需的键
返回：
如果 key 的值为一个 Color，则返回该 Color 对象；否则返回 null

getColor

public Color getColor(Object key,
                      Locale l)
如果给定 Locale 的 key 值为一个 Color，则返回它，否则返回 null。

参数：
key - 所需的键
l - 所需的语言环境
返回：
如果 key 和 Locale 的值为一个 Color，则返回该 Color 对象；否则返回 null
从以下版本开始：
1.4

getIcon

public Icon getIcon(Object key)
如果 key 值为一个 Icon，则返回该 Icon，否则返回 null。

参数：
key - 所需的键
返回：
如果 key 的值为一个 Icon，则返回该 Icon 对象；否则返回 null

getIcon

public Icon getIcon(Object key,
                    Locale l)
如果给定 Locale 的 key 值为一个 Icon，则返回该 Icon，否则返回 null。

参数：
key - 所需的键
l - 所需的语言环境
返回：
如果 key 和 Locale 的值为一个 Icon，则返回该 Icon 对象；否则返回 null
从以下版本开始：
1.4

getBorder

public Border getBorder(Object key)
如果 key 值为一个 Border，则返回该 Border，否则返回 null。

参数：
key - 所需的键
返回：
如果 key 的值为一个 Border，则返回该 Border 对象；否则返回 null

getBorder

public Border getBorder(Object key,
                        Locale l)
如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。

参数：
key - 所需的键
l - 所需的语言环境
返回：
如果 key 和 Locale 的值为一个 Border，则返回该 Border 对象；否则返回 null
从以下版本开始：
1.4

getString

public String getString(Object key)
如果 key 值为一个 String，则返回该 String，否则返回 null。

参数：
key - 所需的键
返回：
如果 key 的值为一个 String，则返回该 String 对象；否则返回 null

getString

public String getString(Object key,
                        Locale l)
如果给定 Locale 的 key 值为一个 String，则返回该 String，否则返回 null。

参数：
key - 所需的键
l - 所需的 Locale
返回：
如果给定 Locale 的 key 的值为一个 String，则返回该 String 对象；否则返回 null
从以下版本开始：
1.4

getInt

public int getInt(Object key)
如果 key 值为一个 Integer，则返回该整数值，否则返回 0。

参数：
key - 所需的键
返回：
如果 key 的值为一个 Integer，则返回其值，否则返回 0

getInt

public int getInt(Object key,
                  Locale l)
如果给定 Locale 的 key 值为一个 Integer，则返回其整数值，否则返回 0。

参数：
key - 所需的键
l - 所需的语言环境
返回：
如果 key 和 Locale 的值为一个 Integer，则返回其值，否则返回 0
从以下版本开始：
1.4

getBoolean

public boolean getBoolean(Object key)
如果 key 是 boolean 值，则返回该 boolean 值，否则返回 false。

参数：
key - 指定所需 boolean 值的键的 Object
返回：
如果 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。
从以下版本开始：
1.4

getBoolean

public boolean getBoolean(Object key,
                          Locale l)
如果给定 Locale 的 key 值是 boolean 值，则返回该 boolean 值，否则返回 false。

参数：
key - 一个指定所需 boolean 值的键的 Object
l - 所需的语言环境
返回：
如果 key 和 Locale 的值是 boolean 值，则返回该 boolean 值，否则返回 false。
从以下版本开始：
1.4

getInsets

public Insets getInsets(Object key)
如果 key 值为一个 Insets，则返回它，否则返回 null。

参数：
key - 所需的键
返回：
如果 key 的值为一个 Insets，则返回该 Insets 对象；否则返回 null

getInsets

public Insets getInsets(Object key,
                        Locale l)
如果给定 Locale 的 key 值为一个 Insets，则返回该 Insets，否则返回 null。

参数：
key - 所需的键
l - 所需的语言环境
返回：
如果 key 和 Locale 的值为一个 Insets，则返回该 Insets 对象；否则返回 null
从以下版本开始：
1.4

getDimension

public Dimension getDimension(Object key)
如果 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。

参数：
key - 所需的键
返回：
如果 key 的值为一个 Dimension，则返回该 Dimension 对象；否则返回 null

getDimension

public Dimension getDimension(Object key,
                              Locale l)
如果给定 Locale 的 key 值为一个 Dimension，则返回该 Dimension，否则返回 null。

参数：
key - 所需的键
l - 所需的语言环境
返回：
如果 key 和 Locale 的值为一个 Dimension，则返回该 Dimension 对象；否则返回 null
从以下版本开始：
1.4

getUIClass

public Class<? extends ComponentUI> getUIClass(String uiClassID,
                                               ClassLoader uiClassLoader)
get(uidClassID) 的值必须为一个类的 String 名称，该类实现相应的 ComponentUI 类。如果以前未加载该类，若提供非 null 类加载器，则此方法会使用 uiClassLoader.loadClass() 查找该类，否则使用 classForName() 查找。

如果 uiClassID 的映射关系存在，或者无法找到指定类，则返回 null。

此方法由 getUI 使用，通常不必直接调用该方法。

参数：
uiClassID - 一个包含类 ID 的字符串
uiClassLoader - 将加载该类的对象
返回：
Class.forName(get(uidClassID)) 的值
另请参见：
getUI(javax.swing.JComponent)

getUIClass

public Class<? extends ComponentUI> getUIClass(String uiClassID)
返回呈现此组件的 L&F 类。

参数：
uiClassID - 一个包含类 ID 的字符串
返回：
由 getUIClass(uiClassID, null) 返回的类对象

getUIError

protected void getUIError(String msg)
如果由于某种原因导致 getUI() 失败，则它会在返回 null 之前调用此方法。子类在这里也可以选择执行差不多的操作。

参数：
msg - 要打印的消息字符串
另请参见：
getUI(javax.swing.JComponent)

getUI

public ComponentUI getUI(JComponent target)
创建一个指定组件的 ComponentUI 实现。换句话说，创建 target 的特定于外观的委托对象。此操作分以下两步进行：
  • 查找由 target.getUIClassID() 返回的值下的 ComponentUI 实现类的名称。
  • 使用该实现类的静态 createUI() 方法构造一个外观代理。

参数：
target - 需要 UI 的 JComponent
返回：
该 ComponentUI 对象

addPropertyChangeListener

public void addPropertyChangeListener(PropertyChangeListener listener)
向侦听器列表添加一个 PropertyChangeListener。该侦听器是为所有属性注册的。

每更改一个默认值时，都将触发一个 PropertyChangeEvent。

参数：
listener - 要添加的 PropertyChangeListener
另请参见：
PropertyChangeSupport

removePropertyChangeListener

public void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除一个 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

参数：
listener - 要移除的 PropertyChangeListener
另请参见：
PropertyChangeSupport

getPropertyChangeListeners

public PropertyChangeListener[] getPropertyChangeListeners()
返回使用 addPropertyChangeListener() 添加到此 UIDefaults 的所有 PropertyChangeListener 组成的数组。

返回：
添加的所有 PropertyChangeListener，如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4

firePropertyChange

protected void firePropertyChange(String propertyName,
                                  Object oldValue,
                                  Object newValue)
支持报告绑定属性更改。如果 oldValue 和 newValue 不相等，且 PropertyChangeEventx 侦听器列表不为空，则对每个侦听器触发一个 PropertyChange。

参数：
propertyName - 已更改的属性的编程名称
oldValue - 属性的旧值
newValue - 属性的新值
另请参见：
PropertyChangeSupport

addResourceBundle

public void addResourceBundle(String bundleName)
将一个资源包添加到从中搜索本地化值的资源包的列表中。按添加时的反向顺序搜索资源包。换句话说，就是搜索最近刚添加的包。

参数：
bundleName - 要添加的资源包的基本名称
从以下版本开始：
1.4
另请参见：
ResourceBundle, removeResourceBundle(java.lang.String)

removeResourceBundle

public void removeResourceBundle(String bundleName)
从在其中搜索本地化默认的资源包列表中移除一个资源包。

参数：
bundleName - 要移除的资源包的基本名称
从以下版本开始：
1.4
另请参见：
ResourceBundle, addResourceBundle(java.lang.String)

setDefaultLocale

public void setDefaultLocale(Locale l)
设置默认语言环境。通过不带 locale 参数的 get 方法，使用默认语言环境检索本地化值。从版本 1.4 开始，Swing UI 对象应该使用其组件的语言环境而不是使用默认语言环境检索本地化值。默认的语言环境可以与 1.4 以前的行为兼容。

参数：
l - 新的默认语言环境
从以下版本开始：
1.4
另请参见：
getDefaultLocale(), get(Object), get(Object,Locale)

getDefaultLocale

public Locale getDefaultLocale()
返回该默认语言环境。通过不带 locale 参数的 get 方法，使用默认语言环境检索本地化值。从版本 1.4 开始，Swing UI 对象应该使用其组件的语言环境而不是使用默认语言环境检索本地化值。默认的语言环境可以与 1.4 以前的行为兼容。

返回：
该默认语言环境
从以下版本开始：
1.4
另请参见：
setDefaultLocale(java.util.Locale), get(Object), get(Object,Locale)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIDefaults.ActiveValue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 UIDefaults.ActiveValue

正在封闭类：
UIDefaults
public static interface UIDefaults.ActiveValue

此类使用户能够在默认表中存储项，该默认表在每次使用某个 getXXX(key) 方法进行查找时创建。下面是一个构造 DefaultListCellRenderer 的 ActiveValue 的示例：

  Object cellRendererActiveValue = new UIDefaults.ActiveValue() {
      public Object createValue(UIDefaults table) {
          return new DefaultListCellRenderer();
      }
  };

  uiDefaultsTable.put("MyRenderer", cellRendererActiveValue);

另请参见：
UIDefaults.get(java.lang.Object)

方法摘要
 Object createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。

方法详细信息

createValue

Object createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。该对象在每次被访问时创建。

参数：
table - 一个 UIDefaults 表
返回：
已创建的 Object
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIDefaults.LazyInputMap (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 UIDefaults.LazyInputMap

java.lang.Object
    继承者  javax.swing.UIDefaults.LazyInputMap
所有已实现的接口：
UIDefaults.LazyValue
正在封闭类：
UIDefaults
public static class UIDefaults.LazyInputMap
extends Object
implements UIDefaults.LazyValue

LazyInputMap 将在其 createValue 方法中创建一个 InputMap。将绑定传入该构造方法。该绑定是一个有偶数个项为字符串 KeyStrokes（如 "alt SPACE"）和奇数个项为在 InputMap 中使用的值（和 ActionMap 中的键）的数组。

从以下版本开始：
1.3

构造方法摘要
UIDefaults.LazyInputMap(Object[] bindings)
方法摘要
 Object createValue(UIDefaults table)
使用传入的绑定创建一个 InputMap。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UIDefaults.LazyInputMap

public UIDefaults.LazyInputMap(Object[] bindings)
方法详细信息

createValue

public Object createValue(UIDefaults table)
使用传入的绑定创建一个 InputMap。

指定者：
接口 UIDefaults.LazyValue 中的 createValue
参数：
table - 一个 UIDefaults 表
返回：
该 InputMap
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIDefaults.LazyValue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 UIDefaults.LazyValue

所有已知实现类：
UIDefaults.LazyInputMap, UIDefaults.ProxyLazyValue
正在封闭类：
UIDefaults
public static interface UIDefaults.LazyValue

此类使用户能够在默认表中存储项，该默认表只有在第一次使用某个 getXXX(key) 方法进行查找时才创建。Lazy 值适用于构造代价高或不常检索的默认情况。第一次检索 LazyValue 时，通过调用 LazyValue.createValue() 计算其“实际值”，并使用该实际值取代 UIDefaults 表中的 LazyValue。对同一键的后续查找会返回该实际值。下面是一个构造 Border 的 LazyValue 的示例：

  Object borderLazyValue = new UIDefaults.LazyValue() {
      public Object createValue(UIDefaults table) {
          return new BorderFactory.createLoweredBevelBorder();
      }
  };

  uiDefaultsTable.put("MyBorder", borderLazyValue);

另请参见：
UIDefaults.get(java.lang.Object)

方法摘要
 Object createValue(UIDefaults table)
创建从 UIDefaults 表中检索的实际值。

方法详细信息

createValue

Object createValue(UIDefaults table)
创建从 UIDefaults 表中检索的实际值。当从该表检索实现此接口的对象时，此方法用于创建该实际值，然后将此值存储在该表中，并将其返回给该调用方法。

参数：
table - 一个 UIDefaults 表
返回：
已创建的 Object
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIDefaults.ProxyLazyValue (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 UIDefaults.ProxyLazyValue

java.lang.Object
    继承者  javax.swing.UIDefaults.ProxyLazyValue
所有已实现的接口：
UIDefaults.LazyValue
正在封闭类：
UIDefaults
public static class UIDefaults.ProxyLazyValue
extends Object
implements UIDefaults.LazyValue

此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。还可以避免创建 LazyValue 子类的匿名内部类。对于第一次调用 createValue 时导致的轻微性能缩减（因为使用了 Reflection API），这两项都可在加载外观 (Look and Feel) 时提高性能。

从以下版本开始：
1.3

构造方法摘要
UIDefaults.ProxyLazyValue(String c)
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String c, Object[] o)
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String c, String m)
创建一个将在请求时构造实例的 LazyValue。
UIDefaults.ProxyLazyValue(String c, String m, Object[] o)
创建一个将在请求时构造实例的 LazyValue。
方法摘要
 Object createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UIDefaults.ProxyLazyValue

public UIDefaults.ProxyLazyValue(String c)
创建一个将在请求时构造实例的 LazyValue。

参数：
c - 一个 String，指定根据需要要创建的实例的类名称

UIDefaults.ProxyLazyValue

public UIDefaults.ProxyLazyValue(String c,
                                 String m)
创建一个将在请求时构造实例的 LazyValue。

参数：
c - 一个指定该类的类名称的 String，该类包含为实例创建要调用的静态方法
m - 一个指定在类 c 上要调用该静态方法的 String

UIDefaults.ProxyLazyValue

public UIDefaults.ProxyLazyValue(String c,
                                 Object[] o)
创建一个将在请求时构造实例的 LazyValue。

参数：
c - 一个 String，指定根据需要要创建的实例的类名称
o - 要作为参数传递到类 c 中构造方法的 Objects 数组

UIDefaults.ProxyLazyValue

public UIDefaults.ProxyLazyValue(String c,
                                 String m,
                                 Object[] o)
创建一个将在请求时构造实例的 LazyValue。

参数：
c - 一个指定该类的类名称的 String，该类包含为实例创建要调用的静态方法。
m - 一个指定在类 c 上要调用该静态方法的 String
o - 要作为参数传递到类 c 中静态方法的 Objects 数组
方法详细信息

createValue

public Object createValue(UIDefaults table)
创建从 UIDefaults 表中检索的值。该对象在每次被访问时创建。

指定者：
接口 UIDefaults.LazyValue 中的 createValue
参数：
table - 一个 UIDefaults 表
返回：
已创建的 Object
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIManager (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 UIManager

java.lang.Object
    继承者  javax.swing.UIManager
所有已实现的接口：
Serializable
public class UIManager
extends Object
implements Serializable

UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。

指定外观

可以通过两种不同的方式指定外观：指定外观类的完全限定名称，或者创建 LookAndFeel 的实例并将它传递给 setLookAndFeel。以下示例说明了如何将外观设置为系统外观：
   UIManager.setLookAndFeel(UIManager.getSystemLookAndFeelClassName());
以下示例说明了如何根据类名称设置外观：
   UIManager.setLookAndFeel("javax.swing.plaf.metal.MetalLookAndFeel");
一旦更改了外观，则强制在所有 JComponent 上调用 updateUI。SwingUtilities.updateComponentTreeUI(java.awt.Component) 方法有助于方便地对包含层次结构应用 updateUI。有关详细信息，请参阅它。没有指定更改外观后不调用 updateUI 的确切行为。很有可能接收到无法预料的异常、绘制问题或更坏的情况。

默认外观

按以下方式选择用于默认外观的类：
  1. 如果系统属性 swing.defaultlaf 为非 null，则将其值用作默认外观类名称。
  2. 如果 Properties 文件 swing.properties 存在且包含键 swing.defaultlaf，则将其值用作默认外观类名称。用来检查 swing.properties 的位置可能随 Java 平台的实现而不同。在 Sun 的实现中，该位置位于 ${java.home}/lib/swing.properties 中。有关更多信息，请参阅所用实现的发行说明。
  3. 否则，请使用跨平台外观。

默认值

UIManager 管理 UIDefault 的三个集合。它们分别是：
  1. 开发人员默认值。由于几乎没有异常，所以 Swing 不会更改开发人员默认值；这些适合修改并由开发人员使用。
  2. 外观默认值。外观默认值在外观作为当前外观安装（调用 setLookAndFeel()）时由该外观提供。使用 getLookAndFeelDefaults() 方法可以获得外观默认值。
  3. 系统默认值。系统默认值由 Swing 提供。
调用任何一个 get 方法都将导致检查每个默认值，按顺序返回第一个非 null 值。例如，调用 UIManager.getString("Table.foreground") 导致首先检查开发人员默认值。如果开发人员默认值包含 "Table.foreground" 的值，则返回该值，否则检查外观默认值，接着检查系统默认值。

要重点注意的是，getDefaults 返回 UIDefault 的一个自定义实例，此解析逻辑内置于其中。例如，UIManager.getDefaults().getString("Table.foreground") 等效于 UIManager.getString("Table.foreground")。两者都使用刚才所描述的算法进行解析。在许多地方，该文档使用字默认值查阅 UIDefaults 的自定义实例，解析逻辑如前所述。

更改外观时，UIManager 只更改外观默认值；UIManager 不以任何方式更改开发人员和系统默认值。

该外观定义并记录特定外观支持的默认值集合。此外，每个外观或者外观所提供的 ComponentUI 在它们生命周期中的不同时间可以访问该默认值。某些外观可以强制查找默认值，这样在安装该外观后更改默认值可能无效。其他外观可以延迟访问默认值，这样对该默认值的更改可能对现有外观产生影响。最后，其他外观可能不会以任何方式根据默认表自我配置。虽然如此，但通常是外观期望特定默认值这种情况，这样在一般情况下，某个外观提供的 ComponentUI 不会对另一个外观起作用。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class UIManager.LookAndFeelInfo
为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。
构造方法摘要
UIManager()
方法摘要
static void addAuxiliaryLookAndFeel(LookAndFeel laf)
将 LookAndFeel 添加到辅助外观的列表中。
static void addPropertyChangeListener(PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到侦听器列表。
static Object get(Object key)
从默认值中返回一个对象。
static Object get(Object key, Locale l)
从适合给定语言环境的默认值中返回一个对象。
static LookAndFeel[] getAuxiliaryLookAndFeels()
返回辅助外观的列表（可以为 null）。
static boolean getBoolean(Object key)
从与键值相关的默认值中返回一个布尔变量。
static boolean getBoolean(Object key, Locale l)
从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。
static Border getBorder(Object key)
从默认值中返回一个边框。
static Border getBorder(Object key, Locale l)
从适合给定语言环境的默认值中返回一个边框。
static Color getColor(Object key)
从默认值返回一种颜色。
static Color getColor(Object key, Locale l)
从适合给定语言环境的默认值中返回一种颜色。
static String getCrossPlatformLookAndFeelClassName()
返回实现默认的跨平台外观 -- Java Look and Feel (JLF) -- 的 LookAndFeel 类的名称。
static UIDefaults getDefaults()
返回该默认值。
static Dimension getDimension(Object key)
从默认值中返回一个维数。
static Dimension getDimension(Object key, Locale l)
从适合给定语言环境的默认值中返回一个维数。
static Font getFont(Object key)
从默认值返回一种字体。
static Font getFont(Object key, Locale l)
从适合给定语言环境的默认值中返回一种字体。
static Icon getIcon(Object key)
从默认值中返回一个 Icon。
static Icon getIcon(Object key, Locale l)
从适合给定语言环境的默认值中返回一个 Icon。
static Insets getInsets(Object key)
从默认值中返回一个 Insets 对象。
static Insets getInsets(Object key, Locale l)
从适合给定语言环境的默认值中返回一个 Insets 对象。
static UIManager.LookAndFeelInfo[] getInstalledLookAndFeels()
返回表示当前可用的 LookAndFeel 实现的 LookAndFeelInfo 数组。
static int getInt(Object key)
从默认值中返回一个整数。
static int getInt(Object key, Locale l)
从适合给定语言环境的默认值中返回一个整数。
static LookAndFeel getLookAndFeel()
返回当前外观或 null。
static UIDefaults getLookAndFeelDefaults()
从当前外观返回 UIDefaults，UIDefaults 在安装该外观时获得。
static PropertyChangeListener[] getPropertyChangeListeners()
返回添加到此 UIManager（具有 addPropertyChangeListener()）的所有 PropertyChangeListener 的数组。
static String getString(Object key)
从默认值中返回一个字符串。
static String getString(Object key, Locale l)
从适合给定语言环境的默认值中返回一个字符串。
static String getSystemLookAndFeelClassName()
如果有实现本机系统外观的 LookAndFeel 类的名称，则返回该名称；否则返回默认的跨平台 LookAndFeel 类的名称。
static ComponentUI getUI(JComponent target)
返回 target 的适当 ComponentUI 实现。
static void installLookAndFeel(String name, String className)
将指定的外观添加到可用外观的集合中。
static void installLookAndFeel(UIManager.LookAndFeelInfo info)
将指定的外观添加到可用外观的集合中。
static Object put(Object key, Object value)
在开发人员默认值中存储一个对象。
static boolean removeAuxiliaryLookAndFeel(LookAndFeel laf)
从辅助外观列表移除一个 LookAndFeel。
static void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除 PropertyChangeListener。
static void setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos)
设置可用外观的集合。
static void setLookAndFeel(LookAndFeel newLookAndFeel)
将当前外观设置为 newLookAndFeel。
static void setLookAndFeel(String className)
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

UIManager

public UIManager()
方法详细信息

getInstalledLookAndFeels

public static UIManager.LookAndFeelInfo[] getInstalledLookAndFeels()
返回表示当前可用的 LookAndFeel 实现的 LookAndFeelInfo 数组。应用程序可以使用 LookAndFeelInfo 对象为用户构造外观选项的菜单，或确定在启动时要设置哪个外观。要避免创建众多 LookAndFeel 对象的影响，LookAndFeelInfo 维护 LookAndFeel 类的类名称，而不是实际的 LookAndFeel 实例。

以下示例演示了如何根据 LookAndFeelInfo 的实例设置外观：

   UIManager.setLookAndFeel(info.getClassName());

返回：
LookAndFeelInfo 对象的数组
另请参见：
setLookAndFeel(javax.swing.LookAndFeel)

setInstalledLookAndFeels

public static void setInstalledLookAndFeels(UIManager.LookAndFeelInfo[] infos)
                                     throws SecurityException
设置可用外观的集合。此方法不进行检查以确保所有 LookAndFeelInfos 为非 null，因此建议最好在 infos 数组中只提供非 null 值。

参数：
infos - 指定可用外观的 LookAndFeelInfo 对象的集合
抛出：
NullPointerException - 如果 infos 为 null
SecurityException
另请参见：
getInstalledLookAndFeels()

installLookAndFeel

public static void installLookAndFeel(UIManager.LookAndFeelInfo info)
将指定的外观添加到可用外观的集合中。尽管此方法允许 null info，但建议最好使用非 null 值。

参数：
info - 命名外观并标识实现它的类的 LookAndFeelInfo 对象
另请参见：
setInstalledLookAndFeels(javax.swing.UIManager.LookAndFeelInfo[])

installLookAndFeel

public static void installLookAndFeel(String name,
                                      String className)
将指定的外观添加到可用外观的集合中。此方法不以任何方式检查参数，因此建议最好提供非 null 值。

参数：
name - 该外观的描述性名称
className - 实现该外观的类的名称
另请参见：
setInstalledLookAndFeels(javax.swing.UIManager.LookAndFeelInfo[])

getLookAndFeel

public static LookAndFeel getLookAndFeel()
返回当前外观或 null。

返回：
当前外观或 null
另请参见：
setLookAndFeel(javax.swing.LookAndFeel)

setLookAndFeel

public static void setLookAndFeel(LookAndFeel newLookAndFeel)
                           throws UnsupportedLookAndFeelException
将当前外观设置为 newLookAndFeel。如果当前外观为非 null，则在其上调用 uninitialize。如果 newLookAndFeel 为非 null，则在其上调用 initialize，接着调用 getDefaults。从 newLookAndFeel.getDefaults() 返回的默认值将替换以前外观的默认值。如果 newLookAndFeel 为 null，则该外观默认值被设置为 null。

null 值可用于将该外观设置为 null。由于大多数 Swing 的运行都要求 LookAndFeel，所以不建议将 LookAndFeel 设置为 null。

这是一个 JavaBeans 绑定属性。

参数：
newLookAndFeel - 要安装的 LookAndFeel
抛出：
UnsupportedLookAndFeelException - 如果 newLookAndFeel 为非 null 并且 newLookAndFeel.isSupportedLookAndFeel() 返回 false
另请参见：
getLookAndFeel()

setLookAndFeel

public static void setLookAndFeel(String className)
                           throws ClassNotFoundException,
                                  InstantiationException,
                                  IllegalAccessException,
                                  UnsupportedLookAndFeelException
使用当前线程的上下文类加载器加载给定类名称所指定的 LookAndFeel，并将它传递给 setLookAndFeel(LookAndFeel)。

参数：
className - 指定实现外观的类名称的字符串
抛出：
ClassNotFoundException - 如果无法找到 LookAndFeel 类
InstantiationException - 如果无法创建一个该类的新实例
IllegalAccessException - 如果该类或初始化程序不可访问
UnsupportedLookAndFeelException - 如果 lnf.isSupportedLookAndFeel() 为 false
ClassCastException - 如果 className 没有标识扩展 LookAndFeel 的类

getSystemLookAndFeelClassName

public static String getSystemLookAndFeelClassName()
如果有实现本机系统外观的 LookAndFeel 类的名称，则返回该名称；否则返回默认的跨平台 LookAndFeel 类的名称。可通过设置 swing.systemlaf 系统属性重写此值。

返回：
该 LookAndFeel 类的 String
另请参见：
setLookAndFeel(javax.swing.LookAndFeel), getCrossPlatformLookAndFeelClassName()

getCrossPlatformLookAndFeelClassName

public static String getCrossPlatformLookAndFeelClassName()
返回实现默认的跨平台外观 -- Java Look and Feel (JLF) -- 的 LookAndFeel 类的名称。可通过设置 swing.crossplatformlaf 系统属性重写此值。

返回：
带有 JLF 实现类的字符串
另请参见：
setLookAndFeel(javax.swing.LookAndFeel), getSystemLookAndFeelClassName()

getDefaults

public static UIDefaults getDefaults()
返回该默认值。使用类文档中指定的逻辑解析返回的默认值。

返回：
包含该默认值的 UIDefaults 对象

getFont

public static Font getFont(Object key)
从默认值返回一种字体。如果 key 的值不为 Font，则返回 null。

参数：
key - 指定该字体的 Object
返回：
Font 对象
抛出：
NullPointerException - 如果 key 为 null

getFont

public static Font getFont(Object key,
                           Locale l)
从适合给定语言环境的默认值中返回一种字体。如果 key 的值不为 Font，则返回 null。

参数：
key - 指定该字体的 Object
l - 需要该字体的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults。
返回：
Font 对象
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getColor

public static Color getColor(Object key)
从默认值返回一种颜色。如果 key 的值不为 Color，则返回 null。

参数：
key - 指定该颜色的 Object
返回：
该 Color 对象
抛出：
NullPointerException - 如果 key 为 null

getColor

public static Color getColor(Object key,
                             Locale l)
从适合给定语言环境的默认值中返回一种颜色。如果 key 的值不为 Color，则返回 null。

参数：
key - 指定该颜色的 Object
l - 需要该颜色的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 Color 对象
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getIcon

public static Icon getIcon(Object key)
从默认值中返回一个 Icon。如果 key 的值不为 Icon，则返回 null。

参数：
key - 指定该图标的 Object
返回：
该 Icon 对象
抛出：
NullPointerException - 如果 key 为 null

getIcon

public static Icon getIcon(Object key,
                           Locale l)
从适合给定语言环境的默认值中返回一个 Icon。如果 key 的值不为 Icon，则返回 null。

参数：
key - 指定该图标的 Object
l - 需要该图标的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 Icon 对象
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getBorder

public static Border getBorder(Object key)
从默认值中返回一个边框。如果 key 的值不为 Border，则返回 null。

参数：
key - 指定该边框的 Object
返回：
该 Border 对象
抛出：
NullPointerException - 如果 key 为 null

getBorder

public static Border getBorder(Object key,
                               Locale l)
从适合给定语言环境的默认值中返回一个边框。如果 key 的值不为 Border，则返回 null。

参数：
key - 指定该边框的 Object
l - 需要该边框的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 Border 对象
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getString

public static String getString(Object key)
从默认值中返回一个字符串。如果 key 的值不为 String，则返回 null。

参数：
key - 指定该字符串的 Object
返回：
该 String
抛出：
NullPointerException - 如果 key 为 null

getString

public static String getString(Object key,
                               Locale l)
从适合给定语言环境的默认值中返回一个字符串。如果 key 的值不为 String，则返回 null。

参数：
key - 指定该字符串的 Object
l - 需要该字符串的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 String
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getInt

public static int getInt(Object key)
从默认值中返回一个整数。如果 key 的值不为 Integer 或者不存在，则返回 0。

参数：
key - 指定该 int 值的 Object
返回：
该 int 值
抛出：
NullPointerException - 如果 key 为 null

getInt

public static int getInt(Object key,
                         Locale l)
从适合给定语言环境的默认值中返回一个整数。如果 key 的值不为 Integer 或者不存在，则返回 0。

参数：
key - 指定该 int 值的 Object
l - 需要该 int 值的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 int 值
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getBoolean

public static boolean getBoolean(Object key)
从与键值相关的默认值中返回一个布尔变量。如果找不到键或该键不表示布尔值，则返回 false。

参数：
key - 指定所需布尔值的键的 Object
返回：
对应于该键的布尔值
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getBoolean

public static boolean getBoolean(Object key,
                                 Locale l)
从与键值和给定的 Locale 相关的默认值中返回一个布尔变量。如果找不到键或该键不表示布尔值，则返回 false。

参数：
key - 指定所需布尔值的键的 Object
l - 需要该布尔变量的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
对应于该键的布尔值
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getInsets

public static Insets getInsets(Object key)
从默认值中返回一个 Insets 对象。如果 key 的值不为 Insets，则返回 null。

参数：
key - 指定该 Insets 对象的 Object
返回：
该 Insets 对象
抛出：
NullPointerException - 如果 key 为 null

getInsets

public static Insets getInsets(Object key,
                               Locale l)
从适合给定语言环境的默认值中返回一个 Insets 对象。如果 key 的值不为 Insets，则返回 null。

参数：
key - 指定该 Insets 对象的 Object
l - 需要该对象的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 Insets 对象
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

getDimension

public static Dimension getDimension(Object key)
从默认值中返回一个维数。如果 key 的值不为 Dimension，则返回 null。

参数：
key - 指定维数对象的 Object
返回：
该 Dimension 对象
抛出：
NullPointerException - 如果 key 为 null

getDimension

public static Dimension getDimension(Object key,
                                     Locale l)
从适合给定语言环境的默认值中返回一个维数。如果 key 的值不为 Dimension，则返回 null。

参数：
key - 指定该维数对象的 Object
l - 需要该对象的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 Dimension 对象
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

get

public static Object get(Object key)
从默认值中返回一个对象。

参数：
key - 指定所需对象的 Object
返回：
该 Object
抛出：
NullPointerException - 如果 key 为 null

get

public static Object get(Object key,
                         Locale l)
从适合给定语言环境的默认值中返回一个对象。

参数：
key - 指定所需对象的 Object
l - 需要该对象的 Locale；有关如何处理 null Locale 的详细信息，请参阅 UIDefaults
返回：
该 Object
抛出：
NullPointerException - 如果 key 为 null
从以下版本开始：
1.4

put

public static Object put(Object key,
                         Object value)
在开发人员默认值中存储一个对象。此方法是 getDefaults().put(key, value) 的一个覆盖方法。此方法仅对开发人员默认值有效，对系统默认值和外观默认值无效。

参数：
key - 一个指定检索键的 Object
value - 要存储的 Object；有关如何处理 null 的详细信息，请参阅 UIDefaults
返回：
由 UIDefaults.put(java.lang.Object, java.lang.Object) 返回的 Object
抛出：
NullPointerException - 如果 key 为 null
另请参见：
UIDefaults.put(java.lang.Object, java.lang.Object)

getUI

public static ComponentUI getUI(JComponent target)
返回 target 的适当 ComponentUI 实现。通常，此方法覆盖 getDefaults().getUI(target)。但是，如果安装了辅助外观，则此方法首先在多路外观的默认值上调用 getUI(target)，如果返回值为非 null，则返回该值。

参数：
target - 要返回 ComponentUI 的 JComponent
返回：
target 的 ComponentUI 对象
抛出：
NullPointerException - 如果 target 为 null
另请参见：
UIDefaults.getUI(javax.swing.JComponent)

getLookAndFeelDefaults

public static UIDefaults getLookAndFeelDefaults()
从当前外观返回 UIDefaults，UIDefaults 在安装该外观时获得。

通常，开发人员应该使用从 getDefaults() 返回的 UIDefaults。因为当前外观可能期望存在特定值，所以替换从此方法返回的 UIDefaults 可能发生不可预料的结果。

返回：
当前外观的 UIDefaults
另请参见：
getDefaults(), setLookAndFeel(LookAndFeel), LookAndFeel.getDefaults()

addAuxiliaryLookAndFeel

public static void addAuxiliaryLookAndFeel(LookAndFeel laf)
将 LookAndFeel 添加到辅助外观的列表中。这些辅助外观会告知多路外观，在创建多路 UI 时除默认的 LookAndFeel 类外还使用其他哪些 LookAndFeel 类。该项更改只有在创建新的 UI 类或在组件实例上更改默认外观时生效。

注意，这些类不同于已安装的外观。

参数：
laf - 该 LookAndFeel 对象
另请参见：
removeAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
setLookAndFeel(javax.swing.LookAndFeel),
getAuxiliaryLookAndFeels(),
getInstalledLookAndFeels()

removeAuxiliaryLookAndFeel

public static boolean removeAuxiliaryLookAndFeel(LookAndFeel laf)
从辅助外观列表移除一个 LookAndFeel。这些辅助外观会告知多路外观，在创建多路 UI 时除默认的 LookAndFeel 类外还使用其他哪些 LookAndFeel 类。该项更改只有在创建新的 UI 类或在组件实例上更改默认外观时生效。

注意，这些类不同于已安装的外观。

返回：
如果该 LookAndFeel 已从列表移除，则返回 true
另请参见：
removeAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
getAuxiliaryLookAndFeels(),
setLookAndFeel(javax.swing.LookAndFeel),
getInstalledLookAndFeels()

getAuxiliaryLookAndFeels

public static LookAndFeel[] getAuxiliaryLookAndFeels()
返回辅助外观的列表（可以为 null）。这些辅助的外观告知多路外观，在创建多路 UI 时除默认的 LookAndFeel 类外还使用其他哪些 LookAndFeel 类。

注意，这些类不同于已安装的外观。

返回：
辅助 LookAndFeel 的列表，或返回 null
另请参见：
addAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
removeAuxiliaryLookAndFeel(javax.swing.LookAndFeel),
setLookAndFeel(javax.swing.LookAndFeel),
getInstalledLookAndFeels()

addPropertyChangeListener

public static void addPropertyChangeListener(PropertyChangeListener listener)
将一个 PropertyChangeListener 添加到侦听器列表。该侦听器为所有属性进行注册。

参数：
listener - 要添加的 PropertyChangeListener
另请参见：
PropertyChangeSupport

removePropertyChangeListener

public static void removePropertyChangeListener(PropertyChangeListener listener)
从侦听器列表移除 PropertyChangeListener。此方法移除了一个为所有属性注册的 PropertyChangeListener。

参数：
listener - 要移除的 PropertyChangeListener
另请参见：
PropertyChangeSupport

getPropertyChangeListeners

public static PropertyChangeListener[] getPropertyChangeListeners()
返回添加到此 UIManager（具有 addPropertyChangeListener()）的所有 PropertyChangeListener 的数组。

返回：
添加的所有 PropertyChangeListener；如果没有添加侦听器，则返回一个空数组
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UIManager.LookAndFeelInfo (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 UIManager.LookAndFeelInfo

java.lang.Object
    继承者  javax.swing.UIManager.LookAndFeelInfo
正在封闭类：
UIManager
public static class UIManager.LookAndFeelInfo
extends Object

为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。

另请参见：
UIManager.getInstalledLookAndFeels(), LookAndFeel

构造方法摘要
UIManager.LookAndFeelInfo(String name, String className)
构造一个 UIManager LookAndFeelInfo 对象。
方法摘要
String | getClassName() 返回实现此外观的类名称。
String | getName() 以适合菜单或其他展示的形式返回外观的名称
String | toString() 返回一个显示并标识此对象属性的字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UIManager.LookAndFeelInfo

public UIManager.LookAndFeelInfo(String name,
                                 String className)
构造一个 UIManager LookAndFeelInfo 对象。

参数：
name - 一个指定外观的名称的 String
className - 一个指定实现外观的类名称的 String
方法详细信息

getName

public String getName()
以适合菜单或其他展示的形式返回外观的名称

返回：
包含该名称的 String
另请参见：
LookAndFeel.getName()

getClassName

public String getClassName()
返回实现此外观的类名称。

返回：
实现此 LookAndFeel 的类名称
另请参见：
LookAndFeel

toString

public String toString()
返回一个显示并标识此对象属性的字符串。

覆盖：
类 Object 中的 toString
返回：
该对象的 String 表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UnsupportedLookAndFeelException (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 UnsupportedLookAndFeelException

java.lang.Object
    继承者  java.lang.Throwable
        继承者  java.lang.Exception
            继承者  javax.swing.UnsupportedLookAndFeelException
所有已实现的接口：
Serializable
public class UnsupportedLookAndFeelException
extends Exception

指示在用户系统上不存在请求的外观管理类的异常。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
UnsupportedLookAndFeelException(String s)
构造一个 UnsupportedLookAndFeelException 对象。
方法摘要
从类 java.lang.Throwable 继承的方法
fillInStackTrace, getCause, getLocalizedMessage, getMessage, getStackTrace, initCause, printStackTrace, printStackTrace, printStackTrace, setStackTrace, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UnsupportedLookAndFeelException

public UnsupportedLookAndFeelException(String s)
构造一个 UnsupportedLookAndFeelException 对象。

参数：
s - 消息字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ViewportLayout (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing
类 ViewportLayout

java.lang.Object
    继承者  javax.swing.ViewportLayout
所有已实现的接口：
LayoutManager, Serializable
public class ViewportLayout
extends Object
implements LayoutManager, Serializable

JViewport 的默认布局管理器。ViewportLayout 定义应该对大多数应用程序都有用的布局策略。视口使其视图与视口的大小相同，但它不会使视图小于其最小大小。随着视口增大，视图先是在可以看到整个视图之前保持底部对齐，之后是顶部对齐。

警告：此类的序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
ViewportLayout()
方法摘要
void | addLayoutComponent(String name, Component c) 将指定的组件添加到布局中。
void | layoutContainer(Container parent) 在需要布置指定容器时由 AWT 调用。
Dimension | minimumLayoutSize(Container parent) 返回需要布置指定目标容器中包含的组件的最小维数。
Dimension | preferredLayoutSize(Container parent) 在给出指定目标容器中的组件的前提下，返回此布局的首选维数。
void | removeLayoutComponent(Component c) 从布局中移除指定组件。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

ViewportLayout

public ViewportLayout()
方法详细信息

addLayoutComponent

public void addLayoutComponent(String name,
                               Component c)
将指定的组件添加到布局中。不能被此类使用。

指定者：
接口 LayoutManager 中的 addLayoutComponent
参数：
name - 组件的名称
c - 要添加的组件

removeLayoutComponent

public void removeLayoutComponent(Component c)
从布局中移除指定组件。不能被此类使用。

指定者：
接口 LayoutManager 中的 removeLayoutComponent
参数：
c - 要移除的组件

preferredLayoutSize

public Dimension preferredLayoutSize(Container parent)
在给出指定目标容器中的组件的前提下，返回此布局的首选维数。

指定者：
接口 LayoutManager 中的 preferredLayoutSize
参数：
parent - 需要布置的组件
返回：
包含首选维数的 Dimension 对象
另请参见：
minimumLayoutSize(java.awt.Container)

minimumLayoutSize

public Dimension minimumLayoutSize(Container parent)
返回需要布置指定目标容器中包含的组件的最小维数。

指定者：
接口 LayoutManager 中的 minimumLayoutSize
参数：
parent - 需要布置的组件
返回：
包含最小维数的 Dimension 对象
另请参见：
preferredLayoutSize(java.awt.Container)

layoutContainer

public void layoutContainer(Container parent)
在需要布置指定容器时由 AWT 调用。

指定者：
接口 LayoutManager 中的 layoutContainer
参数：
parent - 要布置的容器
抛出：
AWTError - 如果目标不是指定给 BoxLayout 构造方法的容器
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


WindowConstants (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing
接口 WindowConstants

所有已知实现类：
JDialog, JFrame, JInternalFrame
public interface WindowConstants

用于控制窗口关闭操作的常量。由 JFrame、JInternalFrame 和 JDialog 提供的 setDefaultCloseOperation 和 getDefaultCloseOperation 方法使用这些常量。有关设置默认窗口操作的示例，请参阅 The Java Tutorial 中的 Responding to Window-Closing Events 一节。

另请参见：
JFrame.setDefaultCloseOperation(int),
JDialog.setDefaultCloseOperation(int),
JInternalFrame.setDefaultCloseOperation(int)

字段摘要
static int | DISPOSE_ON_CLOSE 移除窗口的默认窗口关闭操作。
static int | DO_NOTHING_ON_CLOSE 无操作默认窗口关闭操作。
static int | EXIT_ON_CLOSE 退出应用程序默认窗口关闭操作。
static int | HIDE_ON_CLOSE 隐藏窗口的默认窗口关闭操作

字段详细信息

DO_NOTHING_ON_CLOSE

static final int DO_NOTHING_ON_CLOSE
无操作默认窗口关闭操作。

另请参见：
常量字段值

HIDE_ON_CLOSE

static final int HIDE_ON_CLOSE
隐藏窗口的默认窗口关闭操作

另请参见：
常量字段值

DISPOSE_ON_CLOSE

static final int DISPOSE_ON_CLOSE
移除窗口的默认窗口关闭操作。

注：当 Java 虚拟机 (VM) 中最后的可显示窗口被移除后，虚拟机可能会终止。有关更多信息，请参阅 AWT Threading Issues。

另请参见：
Window.dispose(), JInternalFrame.dispose(), 常量字段值

EXIT_ON_CLOSE

static final int EXIT_ON_CLOSE
退出应用程序默认窗口关闭操作。尝试在支持此操作的 Windows 上执行此项设置（如 JFrame）可能会根据 SecurityManager 抛出一个 SecurityException。建议您只在应用程序中使用此项操作。

从以下版本开始：
1.4
另请参见：
JFrame.setDefaultCloseOperation(int), 常量字段值
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing (Java 2 Platform SE 6)

 javax.swing
接口
Action
BoundedRangeModel
ButtonModel
CellEditor
ComboBoxEditor
ComboBoxModel
DesktopManager
Icon
JComboBox.KeySelectionManager
ListCellRenderer
ListModel
ListSelectionModel
MenuElement
MutableComboBoxModel
Renderer
RootPaneContainer
Scrollable
ScrollPaneConstants
SingleSelectionModel
SpinnerModel
SwingConstants
UIDefaults.ActiveValue
UIDefaults.LazyValue
WindowConstants
类
AbstractAction
AbstractButton
AbstractCellEditor
AbstractListModel
AbstractSpinnerModel
ActionMap
BorderFactory
Box
Box.Filler
BoxLayout
ButtonGroup
CellRendererPane
ComponentInputMap
DebugGraphics
DefaultBoundedRangeModel
DefaultButtonModel
DefaultCellEditor
DefaultComboBoxModel
DefaultDesktopManager
DefaultFocusManager
DefaultListCellRenderer
DefaultListCellRenderer.UIResource
DefaultListModel
DefaultListSelectionModel
DefaultRowSorter
DefaultRowSorter.ModelWrapper
DefaultSingleSelectionModel
FocusManager
GrayFilter
GroupLayout
ImageIcon
InputMap
InputVerifier
InternalFrameFocusTraversalPolicy
JApplet
JButton
JCheckBox
JCheckBoxMenuItem
JColorChooser
JComboBox
JComponent
JDesktopPane
JDialog
JEditorPane
JFileChooser
JFormattedTextField
JFormattedTextField.AbstractFormatter
JFormattedTextField.AbstractFormatterFactory
JFrame
JInternalFrame
JInternalFrame.JDesktopIcon
JLabel
JLayeredPane
JList
JList.DropLocation
JMenu
JMenuBar
JMenuItem
JOptionPane
JPanel
JPasswordField
JPopupMenu
JPopupMenu.Separator
JProgressBar
JRadioButton
JRadioButtonMenuItem
JRootPane
JScrollBar
JScrollPane
JSeparator
JSlider
JSpinner
JSpinner.DateEditor
JSpinner.DefaultEditor
JSpinner.ListEditor
JSpinner.NumberEditor
JSplitPane
JTabbedPane
JTable
JTable.DropLocation
JTextArea
JTextField
JTextPane
JToggleButton
JToggleButton.ToggleButtonModel
JToolBar
JToolBar.Separator
JToolTip
JTree
JTree.DropLocation
JTree.DynamicUtilTreeNode
JTree.EmptySelectionModel
JViewport
JWindow
KeyStroke
LayoutFocusTraversalPolicy
LayoutStyle
LookAndFeel
MenuSelectionManager
OverlayLayout
Popup
PopupFactory
ProgressMonitor
ProgressMonitorInputStream
RepaintManager
RowFilter
RowFilter.Entry
RowSorter
RowSorter.SortKey
ScrollPaneLayout
ScrollPaneLayout.UIResource
SizeRequirements
SizeSequence
SortingFocusTraversalPolicy
SpinnerDateModel
SpinnerListModel
SpinnerNumberModel
Spring
SpringLayout
SpringLayout.Constraints
SwingUtilities
SwingWorker
Timer
ToolTipManager
TransferHandler
TransferHandler.DropLocation
TransferHandler.TransferSupport
UIDefaults
UIDefaults.LazyInputMap
UIDefaults.ProxyLazyValue
UIManager
UIManager.LookAndFeelInfo
ViewportLayout
枚举
DropMode
GroupLayout.Alignment
JTable.PrintMode
LayoutStyle.ComponentPlacement
RowFilter.ComparisonType
SortOrder
SwingWorker.StateValue
异常
UnsupportedLookAndFeelException


javax.swing (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing

提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

请参见：
描述

接口摘要
Action | Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
BoundedRangeModel | 定义由 Slider 和 ProgressBar 这类组件使用的数据模型。
ButtonModel | 按钮的状态模型。
CellEditor | 此接口定义任何通用编辑器应该能够实现的方法。
ComboBoxEditor | 用于 JComboBox 组件的编辑器组件。
ComboBoxModel | 用于组合框的数据模型。
DesktopManager | DesktopManager 对象由 DesktopPane 对象所拥有。
Icon | 一个小的固定大小图片，通常用于装饰组件。
JComboBox.KeySelectionManager | 定义 KeySelectionManager 的接口。
ListCellRenderer | 标识可用作“橡皮图章”以绘制 JList 中单元格的组件。
ListModel | 此接口定义方法组件（如 JList），这些组件用于获取列表中每个单元格的值以及列表的长度。
ListSelectionModel | 此接口表示任何组件的当前选择状态，该组件显示一个具有稳定索引的值列表。
MenuElement | 可以放入菜单中的所有组件都应该实现此接口。
MutableComboBoxModel | ComboBoxModel 的可变版本。
Renderer | 为负责“呈现”（显示）值的对象定义需求。
RootPaneContainer | 此接口由具有单个 JRootPane 子组件的组件来实现，这些子组件包括：JDialog、JFrame、JWindow、JApplet、JInternalFrame。
Scrollable | 为类似 JScrollPane 的滚动容器提供信息的接口。
ScrollPaneConstants | 与 JScrollPane 组件一起使用的常数。
SingleSelectionModel | 最多支持一个索引选项的模型。
SpinnerModel | 对象值的潜在无界序列的模型。
SwingConstants | 通常用于在屏幕上定位或定向组件的常量的集合。
UIDefaults.ActiveValue | 此类使用户能够在默认表中存储项，该默认表在每次使用某个 getXXX(key) 方法进行查找时创建。
UIDefaults.LazyValue | 此类使用户能够在默认表中存储项，该默认表只有在第一次使用某个 getXXX(key) 方法进行查找时才创建。
WindowConstants | 用于控制窗口关闭操作的常量。

类摘要
AbstractAction | 此类提供 JFC Action 接口的默认实现。
AbstractButton | 定义按钮和菜单项的一般行为。
AbstractCellEditor |
AbstractListModel | 该数据模型的抽象定义提供一个带内容的 List。
AbstractSpinnerModel | 此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。
ActionMap | ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
BorderFactory | 提供标准 Border 对象的工厂类。
Box | 使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
Box.Filler | 参与布局但没有视图的轻量级组件的实现。
BoxLayout | 允许垂直或水平布置多个组件的布局管理器。
ButtonGroup | 此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。
CellRendererPane | 此类被插入在单元格渲染器与使用它们的组件之间。
ComponentInputMap | ComponentInputMap 是与特定 JComponent 相关联的 InputMap。
DebugGraphics | 支持图形调试的图形子类。
DefaultBoundedRangeModel | BoundedRangeModel 的一般实现。
DefaultButtonModel | Button 组件的数据模型的默认实现。
DefaultCellEditor | 表单元格和树单元格的默认编辑器。
DefaultComboBoxModel | 组合框的默认模型。
DefaultDesktopManager | 此类是 DesktopManager 的实现。
DefaultFocusManager | 此类已被废弃，用 1.4 focus API 取代。
DefaultListCellRenderer | 呈现列表中的一个项。
DefaultListCellRenderer.UIResource | 实现 UIResource 的 DefaultListCellRenderer 的子类。
DefaultListModel | 此类以松散方式实现 java.util.Vector API，它实现 1.1.x 版本的 java.util.Vector，没有 collection 类支持，并且在发生更改时通知 ListDataListener。
DefaultListSelectionModel | 列表选择的默认数据模型。
DefaultRowSorter<M,I> | RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。
DefaultRowSorter.ModelWrapper<M,I> | DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。
DefaultSingleSelectionModel | SingleSelectionModel 的一般实现。
FocusManager | 从 1.4 focus API 开始，此类已被废弃。
GrayFilter | 一个图像过滤器，它通过将图像转换成灰度级图像并增亮图像中的像素来“禁用”图像。
GroupLayout | GroupLayout 是一个 LayoutManager，它将组件按层次分组，以决定它们在 Container 中的位置。
ImageIcon | 一个 Icon 接口的实现，它根据 Image 绘制 Icon。
InputMap | InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。
InputVerifier | 此类的用途是通过带文本字段的 GUI 帮助客户端支持流畅的焦点导航。
InternalFrameFocusTraversalPolicy | 该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。
JApplet | java.applet.Applet 的扩展版，它添加了对 JFC/Swing 组件架构的支持。
JButton | "push" 按钮的实现。
JCheckBox | 复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
JCheckBoxMenuItem | 可以被选定或取消选定的菜单项。
JColorChooser | JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
JComboBox | 将按钮或可编辑字段与下拉列表组合的组件。
JComponent | 该类是除顶层容器外所有 Swing 组件的基类。
JDesktopPane | 用于创建多文档界面或虚拟桌面的容器。
JDialog | 创建对话框窗口的主要类。
JEditorPane | 可编辑各种内容的文本组件。
JFileChooser | JFileChooser 为用户选择文件提供了一种简单的机制。
JFormattedTextField | JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
JFormattedTextField.AbstractFormatter | JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
JFormattedTextField.AbstractFormatterFactory | JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。
JFrame | java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
JInternalFrame | 提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
JInternalFrame.JDesktopIcon | 此组件表示 JInternalFrame 的图标化版本。
JLabel | 用于短文本字符串或图像或二者的显示区。
JLayeredPane | JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
JList | 显示对象列表并且允许用户选择一个或多个项的组件。
JList.DropLocation | TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。
JMenu | 菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
JMenuBar | 菜单栏的实现。
JMenuItem | 菜单中的项的实现。
JOptionPane | JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
JPanel | JPanel 是一般轻量级容器。
JPasswordField | JPasswordField 是一个轻量级组件，允许编辑单行文本，其视图指示键入内容，但不显示原始字符。
JPopupMenu | 弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JPopupMenu.Separator | 弹出与菜单有关的分隔符。
JProgressBar | 以可视化形式显示某些任务进度的组件。
JRadioButton | 实现一个单选按钮，此按钮项可被选择或取消选择，并可为用户显示其状态。
JRadioButtonMenuItem | 一个单选按钮菜单项的实现。
JRootPane | 该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
JScrollBar | 滚动条的实现。
JScrollPane | 提供轻量级组件的 scrollable 视图。
JSeparator | JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
JSlider | 一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
JSpinner | 让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
JSpinner.DateEditor | 其模型为 SpinnerDateModel 的 JSpinner 编辑器。
JSpinner.DefaultEditor | 一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
JSpinner.ListEditor | 其模型为 SpinnerListModel 的 JSpinner 编辑器。
JSpinner.NumberEditor | 其模型为 SpinnerNumberModel 的 JSpinner 编辑器。
JSplitPane | JSplitPane 用于分隔两个（只能两个）Component。
JTabbedPane | 一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
JTable | JTable 用来显示和编辑常规二维单元表。
JTable.DropLocation | TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。
JTextArea | JTextArea 是一个显示纯文本的多行区域。
JTextField | JTextField 是一个轻量级组件，它允许编辑单行文本。
JTextPane | 可以用以图形方式表示的属性来标记的文本组件。
JToggleButton | 具有两个状态的（two-state）按钮的实现。
JToggleButton.ToggleButtonModel | ToggleButton 模型。
JToolBar | JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
JToolBar.Separator | 一个特定于工具栏的分隔符。
JToolTip | 用来显示 Component 的“提示”。
JTree | 将分层数据集显示为轮廓的控件。
JTree.DropLocation | TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。
JTree.DynamicUtilTreeNode | DynamicUtilTreeNode 可以包装 vectors/hashtables/arrays/strings 并根据需要创建适当的子树节点。
JTree.EmptySelectionModel | EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
JViewport | 用于查看底层信息的“视口”或“观察孔”。
JWindow | JWindow 是一个容器，可以显示在用户桌面上的任何位置。
KeyStroke | 表示键盘或等效输入设置上的键操作的 KeyStroke。
LayoutFocusTraversalPolicy | 根据 Component 的大小、位置和方向对其排序的 SortingFocusTraversalPolicy。
LayoutStyle | LayoutStyle 提供有关如何确定组件位置的信息。
LookAndFeel | 顾名思义，LookAndFeel 封装了一个外观。
MenuSelectionManager | MenuSelectionManager 拥有菜单层次结构中的选项。
OverlayLayout | 要在彼此顶部安排组件的布局管理器。
Popup | Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。
PopupFactory | 顾名思义，PopupFactory 用于获取 Popup 的实例。
ProgressMonitor | 监视某个操作的进度的类。
ProgressMonitorInputStream | 监视读取某些 InputStream 的进度。
RepaintManager | 此类管理重绘请求，以最大限度地降低重绘次数。
RowFilter<M,I> | RowFilter 用于从模型中过滤条目，使得这些条目不会在视图中显示。
RowFilter.Entry<M,I> | 一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。
RowSorter<M> | RowSorter 提供排序和过滤的基础。
RowSorter.SortKey | SortKey 描述特定列的排序顺序。
ScrollPaneLayout | JScrollPane 使用的布局管理器。
ScrollPaneLayout.UIResource | ScrollPaneLayout 的 UI 资源版本。
SizeRequirements | 为方便布局管理器，计算组件的有关大小和位置信息。
SizeSequence | 一个 SizeSequence 对象，它有效地维护一个包含大小和相应位置的顺序列表。
SortingFocusTraversalPolicy | 通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。
SpinnerDateModel | Date 序列的一个 SpinnerModel。
SpinnerListModel | 其值由数组或 List 定义的 SpinnerModel 的简单实现。
SpinnerNumberModel | 用于数字序列的 SpinnerModel。
Spring | 该 Spring 类的实例将存储以下三个表示其行为特征的属性：minimum、preferred 和 maximum 值。
SpringLayout | SpringLayout 根据一组约束布置其相关容器的子组件。
SpringLayout.Constraints | Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。
SwingUtilities | Swing 实用方法的集合。
SwingWorker<T,V> | 在专用线程中执行长时间 GUI 交互任务的抽象类。
Timer | 在指定时间间隔触发一个或多个 ActionEvent。
ToolTipManager | 管理系统中的所有 ToolTips。
TransferHandler | 此类用于处理往返于 Swing 组件的 Transferable 的传输。
TransferHandler.DropLocation | 表示放置的数据 (dropped data) 应该插入的位置。
TransferHandler.TransferSupport | 此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。
UIDefaults | Swing 组件的默认值表。
UIDefaults.LazyInputMap | LazyInputMap 将在其 createValue 方法中创建一个 InputMap。
UIDefaults.ProxyLazyValue | 此类提供一个可用于延迟加载要创建实例类的 LazyValue 的实现。
UIManager | UIManager 管理当前外观、可用外观集合、外观更改时被通知的 PropertyChangeListeners、外观默认值以及获取各种默认值的便捷方法。
UIManager.LookAndFeelInfo | 为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。
ViewportLayout | JViewport 的默认布局管理器。

枚举摘要
DropMode | 放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
GroupLayout.Alignment | ParallelGroup 能够对齐其子元素的可能方式的枚举。
JTable.PrintMode | 用于打印 JTable 的打印模式。
LayoutStyle.ComponentPlacement | ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
RowFilter.ComparisonType | 由某些默认 RowFilter 支持的可能比较值的枚举。
SortOrder | SortOrder 是可能排序顺序的枚举。
SwingWorker.StateValue | state 绑定 (bound) 属性的值。

异常摘要
UnsupportedLookAndFeelException 指示在用户系统上不存在请求的外观管理类的异常。

软件包 javax.swing 的描述

提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。有关使用这些组件的程序员指南，请参阅 Creating a GUI with JFC/Swing，该内容在 The Java Tutorial 的结尾处。有关其他参考资料，请参阅相关文档。

Swing 的线程策略

通常 Swing 不是线程安全的。除非另行说明，否则所有 Swing 组件及相关类都必须在事件调度线程上访问。

典型的 Swing 应用程序执行处理以响应用户动作所生成的事件。例如，单击 JButton 通知所有添加到 JButton 的 ActionListener。由于用户动作所生成的所有事件都在调度线程上指派，所以大部分开发人员不受该限制的影响。

但是，影响存在于构造以及显示 Swing 的应用程序中。对应用程序的 main 方法或 Applet 中方法的调用不在事件调度线程上调用。因此，构造和显示应用程序或 applet 时，必须注意要将控件转移到事件调度线程。转移控件和开始处理 Swing 的首选方法是使用 invokeLater。invokeLater 方法安排 Runnable 在事件调度线程上处理。以下两个示例都同样很好地用于转移控件和启动 Swing 应用程序：

public class MyApp implements Runnable {
    public void run() {
        // Invoked on the event dispatching thread.
        // Construct and show GUI.
    }

    public static void main(String[] args) {
        SwingUtilities.invokeLater(new MyApp(args));
    }
}
或：
public class MyApp {
    MyApp(String[] args) {
        // Invoked on the event dispatching thread. Do any initialization
        // here.
    }

    public void show() {
        // Show the UI.
    }

    public static void main(final String[] args) {
        // Schedule a job for the event-dispatching thread:
        // creating and showing this application's GUI.
        SwingUtilities.invokeLater(new Runnable() {
            public void run() {
                new MyApp(args).show();
            }
        });
    }
}
此限制也适用于连接到 Swing 组件的模型。例如，如果将 TableModel 连接到 JTable，则 TableModel 应该只在事件调度线程上进行修改。如果修改单独线程上的模型，就有遭遇异常和可能的显示损坏的风险。

由于所有事件都是在事件调度线程上传递的，所以必须注意事件处理。尤其是，在事件调度线程上执行的长运行时间任务（如网络 io 或计算密集处理）将阻塞事件调度线程调度任何其他线程。事件调度线程受阻塞时，应用程序对用户输入完全没有反应。有关处理 Swing 时执行这种处理的首选方式，请参阅 SwingWorker。

可以在 Swing tutorial 中，尤其是 How to Use Threads 一节找到关于此主题的更多信息。

相关文档

有关概述、教程、示例、指南和其他文档的信息，请参阅：

  • The Swing Connection
  • The Java Tutorial
  • Online Training Java Developer ConnectionSM
  • Java Foundation Classes (JFC) 主页

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.AbstractAction (implements javax.swing.Action, java.lang.Cloneable, java.io.Serializable)
    • javax.swing.AbstractButton.ButtonChangeListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.AbstractCellEditor (implements javax.swing.CellEditor, java.io.Serializable)
      • javax.swing.DefaultCellEditor (implements javax.swing.table.TableCellEditor, javax.swing.tree.TreeCellEditor)
    • javax.swing.AbstractListModel (implements javax.swing.ListModel, java.io.Serializable)
      • javax.swing.DefaultComboBoxModel (implements javax.swing.MutableComboBoxModel, java.io.Serializable)
      • javax.swing.DefaultListModel
    • javax.swing.AbstractSpinnerModel (implements javax.swing.SpinnerModel)
      • javax.swing.SpinnerDateModel (implements java.io.Serializable)
      • javax.swing.SpinnerListModel (implements java.io.Serializable)
      • javax.swing.SpinnerNumberModel (implements java.io.Serializable)
    • javax.accessibility.AccessibleContext
      • java.awt.Component.AccessibleAWTComponent (implements javax.accessibility.AccessibleComponent, java.io.Serializable)
        • javax.swing.Box.Filler.AccessibleBoxFiller
        • java.awt.Container.AccessibleAWTContainer
          • javax.swing.Box.AccessibleBox
          • javax.swing.CellRendererPane.AccessibleCellRendererPane
          • javax.swing.JComponent.AccessibleJComponent (implements javax.accessibility.AccessibleExtendedComponent)
            • javax.swing.AbstractButton.AccessibleAbstractButton (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue)
              • javax.swing.JButton.AccessibleJButton
              • javax.swing.JMenuItem.AccessibleJMenuItem (implements javax.swing.event.ChangeListener)
                • javax.swing.JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem
                • javax.swing.JMenu.AccessibleJMenu (implements javax.accessibility.AccessibleSelection)
                • javax.swing.JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem
              • javax.swing.JToggleButton.AccessibleJToggleButton (implements java.awt.event.ItemListener)
                • javax.swing.JCheckBox.AccessibleJCheckBox
                • javax.swing.JRadioButton.AccessibleJRadioButton
            • javax.swing.JColorChooser.AccessibleJColorChooser
            • javax.swing.JComboBox.AccessibleJComboBox (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleSelection)
            • javax.swing.JDesktopPane.AccessibleJDesktopPane
            • javax.swing.JFileChooser.AccessibleJFileChooser
            • javax.swing.JInternalFrame.AccessibleJInternalFrame (implements javax.accessibility.AccessibleValue)
            • javax.swing.JInternalFrame.JDesktopIcon.AccessibleJDesktopIcon (implements javax.accessibility.AccessibleValue)
            • javax.swing.JLabel.AccessibleJLabel (implements javax.accessibility.AccessibleExtendedComponent, javax.accessibility.AccessibleText)
            • javax.swing.JLayeredPane.AccessibleJLayeredPane
            • javax.swing.JList.AccessibleJList (implements javax.accessibility.AccessibleSelection, javax.swing.event.ListDataListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener)
            • javax.swing.JMenuBar.AccessibleJMenuBar (implements javax.accessibility.AccessibleSelection)
            • javax.swing.JOptionPane.AccessibleJOptionPane
            • javax.swing.JPanel.AccessibleJPanel
            • javax.swing.JPopupMenu.AccessibleJPopupMenu (implements java.beans.PropertyChangeListener)
            • javax.swing.JProgressBar.AccessibleJProgressBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JRootPane.AccessibleJRootPane
            • javax.swing.JScrollBar.AccessibleJScrollBar (implements javax.accessibility.AccessibleValue)
            • javax.swing.JScrollPane.AccessibleJScrollPane (implements javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
            • javax.swing.JSeparator.AccessibleJSeparator
            • javax.swing.JSlider.AccessibleJSlider (implements javax.accessibility.AccessibleValue)
            • javax.swing.JSpinner.AccessibleJSpinner (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleText, javax.accessibility.AccessibleValue, javax.swing.event.ChangeListener)
            • javax.swing.JSplitPane.AccessibleJSplitPane (implements javax.accessibility.AccessibleValue)
            • javax.swing.JTabbedPane.AccessibleJTabbedPane (implements javax.accessibility.AccessibleSelection, javax.swing.event.ChangeListener)
            • javax.swing.JTable.AccessibleJTable (implements javax.accessibility.AccessibleExtendedTable, javax.accessibility.AccessibleSelection, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, java.beans.PropertyChangeListener, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
            • javax.swing.text.JTextComponent.AccessibleJTextComponent (implements javax.accessibility.AccessibleAction, javax.accessibility.AccessibleEditableText, javax.accessibility.AccessibleExtendedText, javax.accessibility.AccessibleText, javax.swing.event.CaretListener, javax.swing.event.DocumentListener)
              • javax.swing.JEditorPane.AccessibleJEditorPane
                • javax.swing.JEditorPane.AccessibleJEditorPaneHTML
                • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport (implements javax.accessibility.AccessibleHypertext)
              • javax.swing.JTextArea.AccessibleJTextArea
              • javax.swing.JTextField.AccessibleJTextField
                • javax.swing.JPasswordField.AccessibleJPasswordField
            • javax.swing.JToolBar.AccessibleJToolBar
            • javax.swing.JToolTip.AccessibleJToolTip
            • javax.swing.JTree.AccessibleJTree (implements javax.accessibility.AccessibleSelection, javax.swing.event.TreeExpansionListener, javax.swing.event.TreeModelListener, javax.swing.event.TreeSelectionListener)
            • javax.swing.JViewport.AccessibleJViewport
          • java.awt.Panel.AccessibleAWTPanel
            • java.applet.Applet.AccessibleApplet
              • javax.swing.JApplet.AccessibleJApplet
          • java.awt.Window.AccessibleAWTWindow
            • java.awt.Dialog.AccessibleAWTDialog
              • javax.swing.JDialog.AccessibleJDialog
            • java.awt.Frame.AccessibleAWTFrame
              • javax.swing.JFrame.AccessibleJFrame
            • javax.swing.JWindow.AccessibleJWindow
      • javax.swing.ImageIcon.AccessibleImageIcon (implements javax.accessibility.AccessibleIcon, java.io.Serializable)
      • javax.swing.JList.AccessibleJList.AccessibleJListChild (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTable.AccessibleJTable.AccessibleJTableCell (implements javax.accessibility.Accessible, javax.accessibility.AccessibleComponent)
      • javax.swing.JTree.AccessibleJTree.AccessibleJTreeNode (implements javax.accessibility.Accessible, javax.accessibility.AccessibleAction, javax.accessibility.AccessibleComponent, javax.accessibility.AccessibleSelection)
      • javax.swing.ProgressMonitor.AccessibleProgressMonitor (implements javax.accessibility.AccessibleText, javax.swing.event.ChangeListener, java.beans.PropertyChangeListener)
    • javax.accessibility.AccessibleHyperlink (implements javax.accessibility.AccessibleAction)
      • javax.swing.JEditorPane.JEditorPaneAccessibleHypertextSupport.HTMLLink
    • javax.swing.ActionMap (implements java.io.Serializable)
    • java.awt.AWTKeyStroke (implements java.io.Serializable)
      • javax.swing.KeyStroke
    • javax.swing.BorderFactory
    • javax.swing.BoxLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.ButtonGroup (implements java.io.Serializable)
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.CellRendererPane (implements javax.accessibility.Accessible)
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.AbstractButton (implements java.awt.ItemSelectable, javax.swing.SwingConstants)
            • javax.swing.JButton (implements javax.accessibility.Accessible)
            • javax.swing.JMenuItem (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JCheckBoxMenuItem (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
              • javax.swing.JMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
              • javax.swing.JRadioButtonMenuItem (implements javax.accessibility.Accessible)
            • javax.swing.JToggleButton (implements javax.accessibility.Accessible)
              • javax.swing.JCheckBox (implements javax.accessibility.Accessible)
              • javax.swing.JRadioButton (implements javax.accessibility.Accessible)
          • javax.swing.Box (implements javax.accessibility.Accessible)
          • javax.swing.Box.Filler (implements javax.accessibility.Accessible)
          • javax.swing.JColorChooser (implements javax.accessibility.Accessible)
          • javax.swing.JComboBox (implements javax.accessibility.Accessible, java.awt.event.ActionListener, java.awt.ItemSelectable, javax.swing.event.ListDataListener)
          • javax.swing.JFileChooser (implements javax.accessibility.Accessible)
          • javax.swing.JInternalFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JInternalFrame.JDesktopIcon (implements javax.accessibility.Accessible)
          • javax.swing.JLabel (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.DefaultListCellRenderer (implements javax.swing.ListCellRenderer, java.io.Serializable)
              • javax.swing.DefaultListCellRenderer.UIResource (implements javax.swing.plaf.UIResource)
          • javax.swing.JLayeredPane (implements javax.accessibility.Accessible)
            • javax.swing.JDesktopPane (implements javax.accessibility.Accessible)
          • javax.swing.JList (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JMenuBar (implements javax.accessibility.Accessible, javax.swing.MenuElement)
          • javax.swing.JOptionPane (implements javax.accessibility.Accessible)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • javax.swing.JSpinner.DefaultEditor (implements javax.swing.event.ChangeListener, java.awt.LayoutManager, java.beans.PropertyChangeListener)
              • javax.swing.JSpinner.DateEditor
              • javax.swing.JSpinner.ListEditor
              • javax.swing.JSpinner.NumberEditor
          • javax.swing.JPopupMenu (implements javax.accessibility.Accessible, javax.swing.MenuElement)
          • javax.swing.JProgressBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JRootPane (implements javax.accessibility.Accessible)
          • javax.swing.JScrollBar (implements javax.accessibility.Accessible, java.awt.Adjustable)
            • javax.swing.JScrollPane.ScrollBar (implements javax.swing.plaf.UIResource)
          • javax.swing.JScrollPane (implements javax.accessibility.Accessible, javax.swing.ScrollPaneConstants)
          • javax.swing.JSeparator (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
            • javax.swing.JPopupMenu.Separator
            • javax.swing.JToolBar.Separator
          • javax.swing.JSlider (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JSpinner (implements javax.accessibility.Accessible)
          • javax.swing.JSplitPane (implements javax.accessibility.Accessible)
          • javax.swing.JTabbedPane (implements javax.accessibility.Accessible, java.io.Serializable, javax.swing.SwingConstants)
          • javax.swing.JTable (implements javax.accessibility.Accessible, javax.swing.event.CellEditorListener, javax.swing.event.ListSelectionListener, javax.swing.event.RowSorterListener, javax.swing.Scrollable, javax.swing.event.TableColumnModelListener, javax.swing.event.TableModelListener)
          • javax.swing.text.JTextComponent (implements javax.accessibility.Accessible, javax.swing.Scrollable)
            • javax.swing.JEditorPane
              • javax.swing.JTextPane
            • javax.swing.JTextArea
            • javax.swing.JTextField (implements javax.swing.SwingConstants)
              • javax.swing.JFormattedTextField
              • javax.swing.JPasswordField
          • javax.swing.JToolBar (implements javax.accessibility.Accessible, javax.swing.SwingConstants)
          • javax.swing.JToolTip (implements javax.accessibility.Accessible)
          • javax.swing.JTree (implements javax.accessibility.Accessible, javax.swing.Scrollable)
          • javax.swing.JViewport (implements javax.accessibility.Accessible)
        • java.awt.Panel (implements javax.accessibility.Accessible)
          • java.applet.Applet
            • javax.swing.JApplet (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
        • java.awt.Window (implements javax.accessibility.Accessible)
          • java.awt.Dialog
            • javax.swing.JDialog (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • java.awt.Frame (implements java.awt.MenuContainer)
            • javax.swing.JFrame (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer, javax.swing.WindowConstants)
          • javax.swing.JWindow (implements javax.accessibility.Accessible, javax.swing.RootPaneContainer)
    • java.awt.event.ComponentAdapter (implements java.awt.event.ComponentListener)
      • javax.swing.JViewport.ViewListener (implements java.io.Serializable)
    • javax.swing.DefaultBoundedRangeModel (implements javax.swing.BoundedRangeModel, java.io.Serializable)
    • javax.swing.DefaultButtonModel (implements javax.swing.ButtonModel, java.io.Serializable)
      • javax.swing.JToggleButton.ToggleButtonModel
    • javax.swing.DefaultCellEditor.EditorDelegate (implements java.awt.event.ActionListener, java.awt.event.ItemListener, java.io.Serializable)
    • javax.swing.DefaultDesktopManager (implements javax.swing.DesktopManager, java.io.Serializable)
    • javax.swing.DefaultListSelectionModel (implements java.lang.Cloneable, javax.swing.ListSelectionModel, java.io.Serializable)
    • javax.swing.tree.DefaultMutableTreeNode (implements java.lang.Cloneable, javax.swing.tree.MutableTreeNode, java.io.Serializable)
      • javax.swing.JTree.DynamicUtilTreeNode
    • javax.swing.DefaultRowSorter.ModelWrapper<M,I>
    • javax.swing.DefaultSingleSelectionModel (implements java.io.Serializable, javax.swing.SingleSelectionModel)
    • javax.swing.tree.DefaultTreeSelectionModel (implements java.lang.Cloneable, java.io.Serializable, javax.swing.tree.TreeSelectionModel)
      • javax.swing.JTree.EmptySelectionModel
    • java.util.Dictionary<K,V>
      • java.util.Hashtable<K,V> (implements java.lang.Cloneable, java.util.Map<K,V>, java.io.Serializable)
        • javax.swing.UIDefaults
    • java.awt.FocusTraversalPolicy
      • javax.swing.InternalFrameFocusTraversalPolicy
        • javax.swing.SortingFocusTraversalPolicy
          • javax.swing.LayoutFocusTraversalPolicy (implements java.io.Serializable)
    • java.awt.Graphics
      • javax.swing.DebugGraphics
    • javax.swing.GroupLayout (implements java.awt.LayoutManager2)
    • javax.swing.GroupLayout.Group
      • javax.swing.GroupLayout.ParallelGroup
      • javax.swing.GroupLayout.SequentialGroup
    • java.awt.image.ImageFilter (implements java.lang.Cloneable, java.awt.image.ImageConsumer)
      • java.awt.image.RGBImageFilter
        • javax.swing.GrayFilter
    • javax.swing.ImageIcon (implements javax.accessibility.Accessible, javax.swing.Icon, java.io.Serializable)
    • javax.swing.InputMap (implements java.io.Serializable)
      • javax.swing.ComponentInputMap
    • java.io.InputStream (implements java.io.Closeable)
      • java.io.FilterInputStream
        • javax.swing.ProgressMonitorInputStream
    • javax.swing.InputVerifier
    • javax.swing.JComponent.AccessibleJComponent.AccessibleContainerHandler (implements java.awt.event.ContainerListener)
    • javax.swing.JComponent.AccessibleJComponent.AccessibleFocusHandler (implements java.awt.event.FocusListener)
    • javax.swing.JFormattedTextField.AbstractFormatter (implements java.io.Serializable)
    • javax.swing.JFormattedTextField.AbstractFormatterFactory
    • javax.swing.JRootPane.RootLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.JTabbedPane.ModelListener (implements javax.swing.event.ChangeListener, java.io.Serializable)
    • javax.swing.JTable.AccessibleJTable.AccessibleJTableModelChange (implements javax.accessibility.AccessibleTableModelChange)
    • javax.swing.JTree.TreeModelHandler (implements javax.swing.event.TreeModelListener)
    • javax.swing.JTree.TreeSelectionRedirector (implements java.io.Serializable, javax.swing.event.TreeSelectionListener)
    • java.awt.KeyboardFocusManager (implements java.awt.KeyEventDispatcher, java.awt.KeyEventPostProcessor)
      • java.awt.DefaultKeyboardFocusManager
        • javax.swing.FocusManager
          • javax.swing.DefaultFocusManager
    • javax.swing.LayoutStyle
    • javax.swing.LookAndFeel
    • javax.swing.MenuSelectionManager
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.ToolTipManager (implements java.awt.event.MouseMotionListener)
    • javax.swing.OverlayLayout (implements java.awt.LayoutManager2, java.io.Serializable)
    • javax.swing.Popup
    • javax.swing.PopupFactory
    • javax.swing.ProgressMonitor (implements javax.accessibility.Accessible)
    • javax.swing.RepaintManager
    • javax.swing.RowFilter<M,I>
    • javax.swing.RowFilter.Entry<M,I>
    • javax.swing.RowSorter<M>
      • javax.swing.DefaultRowSorter<M,I>
    • javax.swing.RowSorter.SortKey
    • javax.swing.ScrollPaneLayout (implements java.awt.LayoutManager, javax.swing.ScrollPaneConstants, java.io.Serializable)
      • javax.swing.ScrollPaneLayout.UIResource (implements javax.swing.plaf.UIResource)
    • javax.swing.SizeRequirements (implements java.io.Serializable)
    • javax.swing.SizeSequence
    • javax.swing.Spring
    • javax.swing.SpringLayout (implements java.awt.LayoutManager2)
    • javax.swing.SpringLayout.Constraints
    • javax.swing.SwingUtilities (implements javax.swing.SwingConstants)
    • javax.swing.SwingWorker<T,V> (implements java.util.concurrent.RunnableFuture<V>)
    • java.lang.Throwable (implements java.io.Serializable)
      • java.lang.Exception
        • javax.swing.UnsupportedLookAndFeelException
    • javax.swing.Timer (implements java.io.Serializable)
    • javax.swing.ToolTipManager.insideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.outsideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.ToolTipManager.stillInsideTimerAction (implements java.awt.event.ActionListener)
    • javax.swing.TransferHandler (implements java.io.Serializable)
    • javax.swing.TransferHandler.DropLocation
      • javax.swing.JList.DropLocation
      • javax.swing.JTable.DropLocation
      • javax.swing.JTree.DropLocation
    • javax.swing.TransferHandler.TransferSupport
    • javax.swing.UIDefaults.LazyInputMap (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIDefaults.ProxyLazyValue (implements javax.swing.UIDefaults.LazyValue)
    • javax.swing.UIManager (implements java.io.Serializable)
    • javax.swing.UIManager.LookAndFeelInfo
    • javax.swing.ViewportLayout (implements java.awt.LayoutManager, java.io.Serializable)
    • java.awt.event.WindowAdapter (implements java.awt.event.WindowFocusListener, java.awt.event.WindowListener, java.awt.event.WindowStateListener)
      • javax.swing.JMenu.WinListener (implements java.io.Serializable)

接口分层结构

  • javax.swing.BoundedRangeModel
  • javax.swing.CellEditor
  • javax.swing.ComboBoxEditor
  • javax.swing.DesktopManager
  • java.util.EventListener
    • java.awt.event.ActionListener
      • javax.swing.Action
  • javax.swing.Icon
  • java.awt.ItemSelectable
    • javax.swing.ButtonModel
  • javax.swing.JComboBox.KeySelectionManager
  • javax.swing.ListCellRenderer
  • javax.swing.ListModel
    • javax.swing.ComboBoxModel
      • javax.swing.MutableComboBoxModel
  • javax.swing.ListSelectionModel
  • javax.swing.MenuElement
  • javax.swing.Renderer
  • javax.swing.RootPaneContainer
  • javax.swing.Scrollable
  • javax.swing.ScrollPaneConstants
  • javax.swing.SingleSelectionModel
  • javax.swing.SpinnerModel
  • javax.swing.SwingConstants
  • javax.swing.UIDefaults.ActiveValue
  • javax.swing.UIDefaults.LazyValue
  • javax.swing.WindowConstants

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.GroupLayout.Alignment
      • javax.swing.LayoutStyle.ComponentPlacement
      • javax.swing.RowFilter.ComparisonType
      • javax.swing.SortOrder
      • javax.swing.SwingWorker.StateValue
      • javax.swing.JTable.PrintMode
      • javax.swing.DropMode
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.swing 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing
的使用

使用 javax.swing 的软件包
java.awt.im.spi | 提供启用可以与 Java 运行时环境一起使用的输入方法开发的接口。
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。
javax.swing.plaf.synth | Synth 是一个可更换皮肤 (skinnable) 的外观，在其中可委托所有绘制。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

java.awt.im.spi 使用的 javax.swing 中的类
JFrame
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。

javax.swing 使用的 javax.swing 中的类
AbstractButton
定义按钮和菜单项的一般行为。
AbstractButton.AccessibleAbstractButton
此类实现对 AbstractButton 类的可访问性支持。
AbstractCellEditor
AbstractListModel
该数据模型的抽象定义提供一个带内容的 List。
AbstractSpinnerModel
此类提供 SpinnerModel 接口的 ChangeListener 部分，该接口应该适用于最具体的 SpinnerModel 实现。
Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
ActionMap
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
BoundedRangeModel
定义由 Slider 和 ProgressBar 这类组件使用的数据模型。
Box
使用 BoxLayout 对象作为其布局管理器的一个轻量级容器。
ButtonGroup
此类用于为一组按钮创建一个多斥（multiple-exclusion）作用域。
ButtonModel
按钮的状态模型。
CellEditor
此接口定义任何通用编辑器应该能够实现的方法。
ComboBoxEditor
用于 JComboBox 组件的编辑器组件。
ComboBoxModel
用于组合框的数据模型。
ComponentInputMap
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。
DefaultButtonModel
Button 组件的数据模型的默认实现。
DefaultCellEditor.EditorDelegate
受保护的 (protected) EditorDelegate 类。
DefaultListCellRenderer
呈现列表中的一个项。
DefaultRowSorter.ModelWrapper
DefaultRowSorter.ModelWrapper 负责提供由 DefaultRowSorter 进行排序的数据。
DesktopManager
DesktopManager 对象由 DesktopPane 对象所拥有。
DropMode
放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
FocusManager
从 1.4 focus API 开始，此类已被废弃。
GroupLayout.Alignment
ParallelGroup 能够对齐其子元素的可能方式的枚举。
GroupLayout.Group
Group 为 GroupLayout 所支持的以下两种操作提供基础：一个接一个地布置组件（SequentialGroup）或对齐组件（ParallelGroup）。
GroupLayout.ParallelGroup
一个 Group，它对齐其子元素并确定其大小。
GroupLayout.SequentialGroup
一个 Group，它按顺序一个接一个地确定其元素的位置和大小。
Icon
一个小的固定大小图片，通常用于装饰组件。
InputMap
InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。
InputVerifier
此类的用途是通过带文本字段的 GUI 帮助客户端支持流畅的焦点导航。
InternalFrameFocusTraversalPolicy
该 FocusTraversalPolicy 可以有选择地提供确定 JInternalFrame 初始 Component 的算法。
JButton
"push" 按钮的实现。
JCheckBox
复选框的实现，复选框是一个可以被选定和取消选定的项，它将其状态显示给用户。
JColorChooser
JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
JComboBox
将按钮或可编辑字段与下拉列表组合的组件。
JComboBox.KeySelectionManager
定义 KeySelectionManager 的接口。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JComponent.AccessibleJComponent
用于为可访问性提供默认支持的 JComponent 内部类。
JDesktopPane
用于创建多文档界面或虚拟桌面的容器。
JDialog
创建对话框窗口的主要类。
JEditorPane
可编辑各种内容的文本组件。
JEditorPane.AccessibleJEditorPane
此类实现对 JEditorPane 类的可访问性支持。
JFormattedTextField
JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
JFormattedTextField.AbstractFormatter
JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
JFormattedTextField.AbstractFormatterFactory
JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。
JInternalFrame
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
JInternalFrame.JDesktopIcon
此组件表示 JInternalFrame 的图标化版本。
JLabel
用于短文本字符串或图像或二者的显示区。
JLayeredPane
JLayeredPane 为 JFC/Swing 容器添加了深度，允许组件在需要时互相重叠。
JList
显示对象列表并且允许用户选择一个或多个项的组件。
JList.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JList 的放置位置 (drop location)。
JMenu
菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
JMenu.WinListener
观察弹出窗口关闭的侦听器类。
JMenuBar
菜单栏的实现。
JMenuItem
菜单中的项的实现。
JMenuItem.AccessibleJMenuItem
此类实现 JMenuItem 类的可访问性支持。
JPanel
JPanel 是一般轻量级容器。
JPopupMenu
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JRootPane
该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
JScrollBar
滚动条的实现。
JScrollPane
提供轻量级组件的 scrollable 视图。
JSeparator
JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
JSpinner
让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
JSpinner.DefaultEditor
一个针对非常特殊编辑器的简单基类，该类在 JFormattedTextField 中显示模型的当前值的只读视图。
JTable
JTable 用来显示和编辑常规二维单元表。
JTable.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JTable 的放置位置 (drop location)。
JTable.PrintMode
用于打印 JTable 的打印模式。
JTextField
JTextField 是一个轻量级组件，它允许编辑单行文本。
JTextField.AccessibleJTextField
此类实现对 JTextField 类的可访问性支持。
JToggleButton
具有两个状态的（two-state）按钮的实现。
JToggleButton.AccessibleJToggleButton
此类实现对 JToggleButton 类的可访问性支持。
JToolTip
用来显示 Component 的“提示”。
JTree
将分层数据集显示为轮廓的控件。
JTree.DropLocation
TransferHandler.DropLocation 的一个子类，表示 JTree 的放置位置 (drop location)。
JTree.EmptySelectionModel
EmptySelectionModel 是一个不允许选择任何内容的 TreeSelectionModel。
JTree.TreeSelectionRedirector
使用 JTree 创建一个作为源的新 TreeSelectionEvent 并将其传递到所有侦听器的句柄。
JViewport
用于查看底层信息的“视口”或“观察孔”。
JViewport.ViewListener
视图的侦听器。
KeyStroke
表示键盘或等效输入设置上的键操作的 KeyStroke。
LayoutStyle
LayoutStyle 提供有关如何确定组件位置的信息。
LayoutStyle.ComponentPlacement
ComponentPlacement 是两个组件相对于彼此的可能放置方式的枚举。
ListCellRenderer
标识可用作“橡皮图章”以绘制 JList 中单元格的组件。
ListModel
此接口定义方法组件（如 JList），这些组件用于获取列表中每个单元格的值以及列表的长度。
ListSelectionModel
此接口表示任何组件的当前选择状态，该组件显示一个具有稳定索引的值列表。
LookAndFeel
顾名思义，LookAndFeel 封装了一个外观。
MenuElement
可以放入菜单中的所有组件都应该实现此接口。
MenuSelectionManager
MenuSelectionManager 拥有菜单层次结构中的选项。
MutableComboBoxModel
ComboBoxModel 的可变版本。
Popup
Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。
PopupFactory
顾名思义，PopupFactory 用于获取 Popup 的实例。
ProgressMonitor
监视某个操作的进度的类。
RepaintManager
此类管理重绘请求，以最大限度地降低重绘次数。
RootPaneContainer
此接口由具有单个 JRootPane 子组件的组件来实现，这些子组件包括：JDialog、JFrame、JWindow、JApplet、JInternalFrame。
RowFilter
RowFilter 用于从模型中过滤条目，使得这些条目不会在视图中显示。
RowFilter.ComparisonType
由某些默认 RowFilter 支持的可能比较值的枚举。
RowFilter.Entry
一个传递给 RowFilter 实例的 Entry 对象，允许过滤器获取该条目的数据的值，以确定是否应该显示该条目。
RowSorter
RowSorter 提供排序和过滤的基础。
RowSorter.SortKey
SortKey 描述特定列的排序顺序。
Scrollable
为类似 JScrollPane 的滚动容器提供信息的接口。
ScrollPaneConstants
与 JScrollPane 组件一起使用的常数。
ScrollPaneLayout
JScrollPane 使用的布局管理器。
SingleSelectionModel
最多支持一个索引选项的模型。
SizeRequirements
为方便布局管理器，计算组件的有关大小和位置信息。
SortingFocusTraversalPolicy
通过对焦点遍历循环的 Components 按给定 Comparator 排序确定遍历顺序的 FocusTraversalPolicy。
SortOrder
SortOrder 是可能排序顺序的枚举。
SpinnerDateModel
Date 序列的一个 SpinnerModel。
SpinnerListModel
其值由数组或 List 定义的 SpinnerModel 的简单实现。
SpinnerModel
对象值的潜在无界序列的模型。
SpinnerNumberModel
用于数字序列的 SpinnerModel。
Spring
该 Spring 类的实例将存储以下三个表示其行为特征的属性：minimum、preferred 和 maximum 值。
SpringLayout.Constraints
Constraints 对象将管理组件大小和位置更改方式的约束存储在 SpringLayout 控制的容器中。
SwingConstants
通常用于在屏幕上定位或定向组件的常量的集合。
SwingWorker.StateValue
state 绑定 (bound) 属性的值。
ToolTipManager
管理系统中的所有 ToolTips。
TransferHandler
此类用于处理往返于 Swing 组件的 Transferable 的传输。
TransferHandler.DropLocation
表示放置的数据 (dropped data) 应该插入的位置。
TransferHandler.TransferSupport
此类封装剪贴板或拖放传输的所有相关详细信息，并且还允许自定义拖放过程的各方面。
UIDefaults
Swing 组件的默认值表。
UIDefaults.LazyValue
此类使用户能够在默认表中存储项，该默认表只有在第一次使用某个 getXXX(key) 方法进行查找时才创建。
UIManager.LookAndFeelInfo
为了配置菜单或为了初始应用程序设置而提供关于已安装的 LookAndFeel 的少量信息。
UnsupportedLookAndFeelException
指示在用户系统上不存在请求的外观管理类的异常。
WindowConstants
用于控制窗口关闭操作的常量。

javax.swing.border 使用的 javax.swing 中的类
Icon
一个小的固定大小图片，通常用于装饰组件。

javax.swing.colorchooser 使用的 javax.swing 中的类
Icon
一个小的固定大小图片，通常用于装饰组件。
JColorChooser
JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JPanel
JPanel 是一般轻量级容器。

javax.swing.event 使用的 javax.swing 中的类
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JInternalFrame
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
MenuElement
可以放入菜单中的所有组件都应该实现此接口。
MenuSelectionManager
MenuSelectionManager 拥有菜单层次结构中的选项。
RowSorter
RowSorter 提供排序和过滤的基础。

javax.swing.filechooser 使用的 javax.swing 中的类
Icon
一个小的固定大小图片，通常用于装饰组件。

javax.swing.plaf 使用的 javax.swing 中的类
ActionMap
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
ComponentInputMap
ComponentInputMap 是与特定 JComponent 相关联的 InputMap。
Icon
一个小的固定大小图片，通常用于装饰组件。
InputMap
InputMap 提供输入事件（目前只使用 KeyStroke）和 Object 之间的绑定。
JComboBox
将按钮或可编辑字段与下拉列表组合的组件。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JFileChooser
JFileChooser 为用户选择文件提供了一种简单的机制。
JList
显示对象列表并且允许用户选择一个或多个项的组件。
JOptionPane
JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
JPopupMenu
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JSplitPane
JSplitPane 用于分隔两个（只能两个）Component。
JTabbedPane
一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
JTree
将分层数据集显示为轮廓的控件。
Popup
Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。

javax.swing.plaf.basic 使用的 javax.swing 中的类
AbstractAction
此类提供 JFC Action 接口的默认实现。
AbstractButton
定义按钮和菜单项的一般行为。
AbstractListModel
该数据模型的抽象定义提供一个带内容的 List。
Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
ActionMap
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
BoxLayout
允许垂直或水平布置多个组件的布局管理器。
CellRendererPane
此类被插入在单元格渲染器与使用它们的组件之间。
ComboBoxEditor
用于 JComboBox 组件的编辑器组件。
ComboBoxModel
用于组合框的数据模型。
DesktopManager
DesktopManager 对象由 DesktopPane 对象所拥有。
Icon
一个小的固定大小图片，通常用于装饰组件。
JButton
"push" 按钮的实现。
JColorChooser
JColorChooser 提供一个用于允许用户操作和选择颜色的控制器窗格。
JComboBox
将按钮或可编辑字段与下拉列表组合的组件。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JDesktopPane
用于创建多文档界面或虚拟桌面的容器。
JFileChooser
JFileChooser 为用户选择文件提供了一种简单的机制。
JFrame
java.awt.Frame 的扩展版本，该版本添加了对 JFC/Swing 组件架构的支持。
JInternalFrame
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
JInternalFrame.JDesktopIcon
此组件表示 JInternalFrame 的图标化版本。
JLabel
用于短文本字符串或图像或二者的显示区。
JList
显示对象列表并且允许用户选择一个或多个项的组件。
JMenu
菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
JMenuBar
菜单栏的实现。
JMenuItem
菜单中的项的实现。
JOptionPane
JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
JPanel
JPanel 是一般轻量级容器。
JPopupMenu
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JProgressBar
以可视化形式显示某些任务进度的组件。
JRootPane
该轻量级容器由 JFrame、JDialog、JWindow、JApplet 和 JInternalFrame 在后台使用。
JScrollBar
滚动条的实现。
JScrollPane
提供轻量级组件的 scrollable 视图。
JSeparator
JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
JSlider
一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
JSpinner
让用户从一个有序序列中选择一个数字或者一个对象值的单行输入字段。
JSplitPane
JSplitPane 用于分隔两个（只能两个）Component。
JTabbedPane
一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
JTable
JTable 用来显示和编辑常规二维单元表。
JTextField
JTextField 是一个轻量级组件，它允许编辑单行文本。
JToolBar
JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
JTree
将分层数据集显示为轮廓的控件。
KeyStroke
表示键盘或等效输入设置上的键操作的 KeyStroke。
ListCellRenderer
标识可用作“橡皮图章”以绘制 JList 中单元格的组件。
ListModel
此接口定义方法组件（如 JList），这些组件用于获取列表中每个单元格的值以及列表的长度。
ListSelectionModel
此接口表示任何组件的当前选择状态，该组件显示一个具有稳定索引的值列表。
LookAndFeel
顾名思义，LookAndFeel 封装了一个外观。
MenuElement
可以放入菜单中的所有组件都应该实现此接口。
MenuSelectionManager
MenuSelectionManager 拥有菜单层次结构中的选项。
RootPaneContainer
此接口由具有单个 JRootPane 子组件的组件来实现，这些子组件包括：JDialog、JFrame、JWindow、JApplet、JInternalFrame。
ScrollPaneConstants
与 JScrollPane 组件一起使用的常数。
SwingConstants
通常用于在屏幕上定位或定向组件的常量的集合。
Timer
在指定时间间隔触发一个或多个 ActionEvent。
UIDefaults
Swing 组件的默认值表。

javax.swing.plaf.metal 使用的 javax.swing 中的类
AbstractAction
此类提供 JFC Action 接口的默认实现。
AbstractButton
定义按钮和菜单项的一般行为。
AbstractListModel
该数据模型的抽象定义提供一个带内容的 List。
Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
ActionMap
ActionMap 提供从 Object（称为键 或 Action 名）到 Action 的映射。
CellRendererPane
此类被插入在单元格渲染器与使用它们的组件之间。
ComboBoxEditor
用于 JComboBox 组件的编辑器组件。
ComboBoxModel
用于组合框的数据模型。
DefaultListCellRenderer
呈现列表中的一个项。
Icon
一个小的固定大小图片，通常用于装饰组件。
JButton
"push" 按钮的实现。
JComboBox
将按钮或可编辑字段与下拉列表组合的组件。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JFileChooser
JFileChooser 为用户选择文件提供了一种简单的机制。
JInternalFrame
提供很多本机窗体功能的轻量级对象，这些功能包括拖动、关闭、变成图标、调整大小、标题显示和支持菜单栏。
JLabel
用于短文本字符串或图像或二者的显示区。
JList
显示对象列表并且允许用户选择一个或多个项的组件。
JMenu
菜单的该实现是一个包含 JMenuItem 的弹出窗口，用户选择 JMenuBar 上的项时会显示该 JMenuItem。
JPanel
JPanel 是一般轻量级容器。
JPopupMenu
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JScrollPane
提供轻量级组件的 scrollable 视图。
JSeparator
JSeparator 为实现分隔线提供了一个通用组件 - 通常用作菜单项之间的分隔符，以便将菜单项分成几个逻辑组。
JSlider
一个让用户以图形方式在有界区间内通过移动滑块来选择值的组件。
JToolBar
JToolBar 提供了一个用来显示常用的 Action 或控件的组件。
LayoutStyle
LayoutStyle 提供有关如何确定组件位置的信息。
ListCellRenderer
标识可用作“橡皮图章”以绘制 JList 中单元格的组件。
ListModel
此接口定义方法组件（如 JList），这些组件用于获取列表中每个单元格的值以及列表的长度。
LookAndFeel
顾名思义，LookAndFeel 封装了一个外观。
MenuElement
可以放入菜单中的所有组件都应该实现此接口。
ScrollPaneConstants
与 JScrollPane 组件一起使用的常数。
SwingConstants
通常用于在屏幕上定位或定向组件的常量的集合。
UIDefaults
Swing 组件的默认值表。

javax.swing.plaf.multi 使用的 javax.swing 中的类
JComboBox
将按钮或可编辑字段与下拉列表组合的组件。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JFileChooser
JFileChooser 为用户选择文件提供了一种简单的机制。
JList
显示对象列表并且允许用户选择一个或多个项的组件。
JOptionPane
JOptionPane 有助于方便地弹出要求用户提供值或向其发出通知的标准对话框。
JPopupMenu
弹出菜单的实现，弹出菜单是一个可弹出并显示一系列选项的小窗口。
JSplitPane
JSplitPane 用于分隔两个（只能两个）Component。
JTabbedPane
一个组件，它允许用户通过单击具有给定标题和/或图标的选项卡，在一组组件之间进行切换。
JTree
将分层数据集显示为轮廓的控件。
LookAndFeel
顾名思义，LookAndFeel 封装了一个外观。
Popup
Popup 用于向用户显示 Component，它通常位于特定包含层次结构中所有其他 Component 的顶部。
UIDefaults
Swing 组件的默认值表。

javax.swing.plaf.synth 使用的 javax.swing 中的类
Icon
一个小的固定大小图片，通常用于装饰组件。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
LookAndFeel
顾名思义，LookAndFeel 封装了一个外观。
UIDefaults
Swing 组件的默认值表。

javax.swing.table 使用的 javax.swing 中的类
CellEditor
此接口定义任何通用编辑器应该能够实现的方法。
DefaultRowSorter
RowSorter 的一个实现，它围绕基于网格的数据模型提供排序和过滤操作。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JComponent.AccessibleJComponent
用于为可访问性提供默认支持的 JComponent 内部类。
JLabel
用于短文本字符串或图像或二者的显示区。
JTable
JTable 用来显示和编辑常规二维单元表。
ListSelectionModel
此接口表示任何组件的当前选择状态，该组件显示一个具有稳定索引的值列表。
RowSorter
RowSorter 提供排序和过滤的基础。
SwingConstants
通常用于在屏幕上定位或定向组件的常量的集合。

javax.swing.text 使用的 javax.swing 中的类
AbstractAction
此类提供 JFC Action 接口的默认实现。
Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
DropMode
放置模式，用于确定组件在拖放过程中跟踪和指示放置位置 (drop location) 的方法。
Icon
一个小的固定大小图片，通常用于装饰组件。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JComponent.AccessibleJComponent
用于为可访问性提供默认支持的 JComponent 内部类。
JEditorPane
可编辑各种内容的文本组件。
JFormattedTextField
JFormattedTextField 扩展了 JTextField，添加了对格式化任意值的支持，以及一旦用户编辑了文本就检索特定对象的支持。
JFormattedTextField.AbstractFormatter
JFormattedTextField 所使用的 AbstractFormatter 实例，用于处理从 Object 到 String 和从 String 到 Object 的转换。
JFormattedTextField.AbstractFormatterFactory
JFormattedTextField 使用的 AbstractFormatterFactory 实例，用来获得 AbstractFormatter 实例，依次使用该实例格式化各个值。
KeyStroke
表示键盘或等效输入设置上的键操作的 KeyStroke。
Scrollable
为类似 JScrollPane 的滚动容器提供信息的接口。
SizeRequirements
为方便布局管理器，计算组件的有关大小和位置信息。
SwingConstants
通常用于在屏幕上定位或定向组件的常量的集合。
TransferHandler.DropLocation
表示放置的数据 (dropped data) 应该插入的位置。

javax.swing.text.html 使用的 javax.swing 中的类
AbstractAction
此类提供 JFC Action 接口的默认实现。
Action
Action 接口提供 ActionListener 接口的一个有用扩展，以便若干控件访问相同的功能。
Icon
一个小的固定大小图片，通常用于装饰组件。
JEditorPane
可编辑各种内容的文本组件。
SizeRequirements
为方便布局管理器，计算组件的有关大小和位置信息。
SwingConstants
通常用于在屏幕上定位或定向组件的常量的集合。

javax.swing.tree 使用的 javax.swing 中的类
CellEditor
此接口定义任何通用编辑器应该能够实现的方法。
DefaultListSelectionModel
列表选择的默认数据模型。
Icon
一个小的固定大小图片，通常用于装饰组件。
JComponent
该类是除顶层容器外所有 Swing 组件的基类。
JLabel
用于短文本字符串或图像或二者的显示区。
JTextField
JTextField 是一个轻量级组件，它允许编辑单行文本。
JTree
将分层数据集显示为轮廓的控件。
Scrollable
为类似 JScrollPane 的滚动容器提供信息的接口。
SwingConstants
通常用于在屏幕上定位或定向组件的常量的集合。
Timer
在指定时间间隔触发一个或多个 ActionEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractBorder (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 AbstractBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BasicBorders.ButtonBorder, BasicBorders.FieldBorder, BasicBorders.MarginBorder, BasicBorders.MenuBarBorder, BevelBorder, CompoundBorder, EmptyBorder, EtchedBorder, LineBorder, MetalBorders.ButtonBorder, MetalBorders.Flush3DBorder, MetalBorders.InternalFrameBorder, MetalBorders.MenuBarBorder, MetalBorders.MenuItemBorder, MetalBorders.OptionDialogBorder, MetalBorders.PaletteBorder, MetalBorders.PopupMenuBorder, MetalBorders.ScrollPaneBorder, MetalBorders.TableHeaderBorder, MetalBorders.ToolBarBorder, TitledBorder
public abstract class AbstractBorder
extends Object
implements Border, Serializable

实现无大小限制的空边框类。它提供了一个便捷的基类，其他边框类可方便地从其派生。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

构造方法摘要
AbstractBorder()
方法摘要
int | getBaseline(Component c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(Component c) 返回一个枚举，指示组件的基线如何随大小的改变而发生更改。
Insets | getBorderInsets(Component c) 此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
static Rectangle | getInteriorRectangle(Component c, Border b, int x, int y, int width, int height) 返回一个用所给的参数减去边框 insets 得到的矩形。
Rectangle | getInteriorRectangle(Component c, int x, int y, int width, int height) 此便捷方法调用静态方法。
boolean | isBorderOpaque() 此默认实现返回 false。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 此默认实现不执行绘制操作。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

AbstractBorder

public AbstractBorder()
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
此默认实现不执行绘制操作。

指定者：
接口 Border 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
此默认实现返回一个新的 Insets 实例，其中 top、left、bottom 和 right 字段都设置成了 0。

指定者：
接口 Border 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数。

参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

isBorderOpaque

public boolean isBorderOpaque()
此默认实现返回 false。

指定者：
接口 Border 中的 isBorderOpaque
返回：
false

getInteriorRectangle

public Rectangle getInteriorRectangle(Component c,
                                      int x,
                                      int y,
                                      int width,
                                      int height)
此便捷方法调用静态方法。

参数：
c - 要为其计算此边框的组件
x - 边框的 x 坐标位置
y - 边框的 y 坐标位置
width - 边框的宽度
height - 边框的高度
返回：
包含内部坐标的 Rectangle

getInteriorRectangle

public static Rectangle getInteriorRectangle(Component c,
                                             Border b,
                                             int x,
                                             int y,
                                             int width,
                                             int height)
返回一个用所给的参数减去边框 insets 得到的矩形。这有助于确定绘制组件所在的区域，保证不会与边框相交。

参数：
c - 为其计算边框的组件
b - Border 对象
x - 边框的 x 坐标位置
y - 边框的 y 坐标位置
width - 边框的宽度
height - 边框的高度
返回：
包含内部坐标的 Rectangle

getBaseline

public int getBaseline(Component c,
                       int width,
                       int height)
返回基线。小于 0 的返回值指示边框不具有合理的基线。

默认实现返回 －1。支持基线的子类应该进行适当地重写。如果返回 >= 0 的值，则任何大小 >= 最小大小的组件都具有有效基线并且 getBaselineResizeBehavior 可用于确定基线如何随大小的改变而发生更改。

参数：
c - 将为其请求基线的 Component
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果 <0，则指示没有合理的基线
抛出：
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
Component.getBaseline(int,int), Component.getBaselineResizeBehavior()

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(Component c)
返回一个枚举，指示组件的基线如何随大小的改变而发生更改。此方法主要用于布局管理器和 GUI 生成器。

默认实现返回 BaselineResizeBehavior.OTHER，支持基线的子类应该进行适当地重写。子类从不返回 null；如果不能计算基线，则返回 BaselineResizeBehavior.OTHER。调用者应该首先使用 getBaseline 请求基线，如果返回 >= 0 的值，则使用此方法。此方法返回 BaselineResizeBehavior.OTHER 以外的值也是可以接受的，即使 getBaseline 返回小于 0 的值。

参数：
c - 为其返回基线调整大小行为的 Component
返回：
一个枚举，指示调整边框大小时基线如何改变
从以下版本开始：
1.6
另请参见：
Component.getBaseline(int,int), Component.getBaselineResizeBehavior()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


BevelBorder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 BevelBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.BevelBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BorderUIResource.BevelBorderUIResource, SoftBevelBorder
public class BevelBorder
extends AbstractBorder

该类实现简单的双线斜面边框。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected int | bevelType
protected Color | highlightInner
protected Color | highlightOuter
static int | LOWERED 凹入斜面类型。
static int | RAISED 凸出斜面类型。
protected Color | shadowInner
protected Color | shadowOuter
构造方法摘要
BevelBorder(int bevelType)
创建具有指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。
BevelBorder(int bevelType, Color highlight, Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
BevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
方法摘要
int | getBevelType() 返回斜面边框的类型。
Insets | getBorderInsets(Component c) 返回边框的 insets。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Color | getHighlightInnerColor() 返回斜面边框内部的高亮显示颜色。
Color | getHighlightInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部高亮显示颜色。
Color | getHighlightOuterColor() 返回斜面边框外部的高亮显示颜色。
Color | getHighlightOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部高亮显示颜色。
Color | getShadowInnerColor() 返回斜面边框内部的阴影颜色。
Color | getShadowInnerColor(Component c) 返回斜面边框在指定组件上呈现的内部阴影颜色。
Color | getShadowOuterColor() 返回斜面边框的外部阴影颜色。
Color | getShadowOuterColor(Component c) 返回斜面边框在指定组件上呈现的外部阴影颜色。
boolean | isBorderOpaque() 返回边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。
protected void | paintLoweredBevel(Component c, Graphics g, int x, int y, int width, int height)
protected void | paintRaisedBevel(Component c, Graphics g, int x, int y, int width, int height)
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RAISED

public static final int RAISED
凸出斜面类型。

另请参见：
常量字段值

LOWERED

public static final int LOWERED
凹入斜面类型。

另请参见：
常量字段值

bevelType

protected int bevelType

highlightOuter

protected Color highlightOuter

highlightInner

protected Color highlightInner

shadowInner

protected Color shadowInner

shadowOuter

protected Color shadowOuter
构造方法详细信息

BevelBorder

public BevelBorder(int bevelType)
创建具有指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。

参数：
bevelType - 边框斜面类型

BevelBorder

public BevelBorder(int bevelType,
                   Color highlight,
                   Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。

参数：
bevelType - 边框的斜面类型
highlight - 斜面高亮显示所用颜色
shadow - 斜面阴影所用颜色

BevelBorder

public BevelBorder(int bevelType,
                   Color highlightOuterColor,
                   Color highlightInnerColor,
                   Color shadowOuterColor,
                   Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。

注：可与凹入斜面边框交换阴影内部和外部的颜色。

参数：
bevelType - 边框的斜面类型
highlightOuterColor - 斜面外部高亮显示所用颜色
highlightInnerColor - 斜面内部高亮显示所用颜色
shadowOuterColor - 斜面外部阴影所用颜色
shadowInnerColor - 斜面内部阴影所用颜色
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
按指定的位置和尺寸绘制指定组件的边框。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
返回边框的 insets。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

getHighlightOuterColor

public Color getHighlightOuterColor(Component c)
返回斜面边框在指定组件上呈现的外部高亮显示颜色。如果实例化时未指定任何高亮显示颜色，高亮显示颜色将从指定组件的背景色派生。

参数：
c - 从其派生高亮显示颜色的组件
从以下版本开始：
1.3

getHighlightInnerColor

public Color getHighlightInnerColor(Component c)
返回斜面边框在指定组件上呈现的内部高亮显示颜色。如果实例化时未指定任何高亮显示颜色，高亮显示颜色将从指定组件的背景色派生。

参数：
c - 从其派生高亮显示颜色的组件
从以下版本开始：
1.3

getShadowInnerColor

public Color getShadowInnerColor(Component c)
返回斜面边框在指定组件上呈现的内部阴影颜色。如果实例化时未指定任何阴影颜色，阴影颜色将从指定组件的背景色派生。

参数：
c - 从其派生阴影颜色的组件
从以下版本开始：
1.3

getShadowOuterColor

public Color getShadowOuterColor(Component c)
返回斜面边框在指定组件上呈现的外部阴影颜色。如果实例化时未指定任何阴影颜色，阴影颜色将从指定组件的背景色派生。

参数：
c - 从其派生阴影颜色的组件
从以下版本开始：
1.3

getHighlightOuterColor

public Color getHighlightOuterColor()
返回斜面边框外部的高亮显示颜色。如果实例化时未指定任何高亮显示颜色，则返回 null。

从以下版本开始：
1.3

getHighlightInnerColor

public Color getHighlightInnerColor()
返回斜面边框内部的高亮显示颜色。如果实例化时未指定任何高亮显示颜色，则返回 null。

从以下版本开始：
1.3

getShadowInnerColor

public Color getShadowInnerColor()
返回斜面边框内部的阴影颜色。如果实例化时未指定任何阴影颜色，则返回 null。

从以下版本开始：
1.3

getShadowOuterColor

public Color getShadowOuterColor()
返回斜面边框的外部阴影颜色。如果实例化时未指定任何阴影颜色，则返回 null。

从以下版本开始：
1.3

getBevelType

public int getBevelType()
返回斜面边框的类型。

isBorderOpaque

public boolean isBorderOpaque()
返回边框是否透明。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 AbstractBorder 中的 isBorderOpaque
返回：
false

paintRaisedBevel

protected void paintRaisedBevel(Component c,
                                Graphics g,
                                int x,
                                int y,
                                int width,
                                int height)

paintLoweredBevel

protected void paintLoweredBevel(Component c,
                                 Graphics g,
                                 int x,
                                 int y,
                                 int width,
                                 int height)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


Border (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
接口 Border

所有已知实现类：
AbstractBorder, BasicBorders.ButtonBorder, BasicBorders.FieldBorder, BasicBorders.MarginBorder, BasicBorders.MenuBarBorder, BasicBorders.RadioButtonBorder, BasicBorders.RolloverButtonBorder, BasicBorders.SplitPaneBorder, BasicBorders.ToggleButtonBorder, BevelBorder, BorderUIResource, BorderUIResource.BevelBorderUIResource, BorderUIResource.CompoundBorderUIResource, BorderUIResource.EmptyBorderUIResource, BorderUIResource.EtchedBorderUIResource, BorderUIResource.LineBorderUIResource, BorderUIResource.MatteBorderUIResource, BorderUIResource.TitledBorderUIResource, CompoundBorder, EmptyBorder, EtchedBorder, LineBorder, MatteBorder, MetalBorders.ButtonBorder, MetalBorders.Flush3DBorder, MetalBorders.InternalFrameBorder, MetalBorders.MenuBarBorder, MetalBorders.MenuItemBorder, MetalBorders.OptionDialogBorder, MetalBorders.PaletteBorder, MetalBorders.PopupMenuBorder, MetalBorders.RolloverButtonBorder, MetalBorders.ScrollPaneBorder, MetalBorders.TableHeaderBorder, MetalBorders.TextFieldBorder, MetalBorders.ToggleButtonBorder, MetalBorders.ToolBarBorder, SoftBevelBorder, TitledBorder
public interface Border

该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。有关使用 border 的示例，请参阅 The Java Tutorial 中的 How to Use Borders 一节。

在 Swing 组件集中，作为一种创建组件边缘四周的装饰或普通区域的机制，border 取代了 Insets。

用法说明：

  • 使用 EmptyBorder 创建普通边框（该机制取代了原先的 setInsets）。
  • 使用嵌套多个 border 对象的 CompoundBorder 来创建单个组合边框。
  • border 实例设计为可共享。不使用某个 border 类来创建新的 border 对象，而是使用 BorderFactory 方法生成常见 border 类型的共享实例。
  • 其他边框样式包括 BevelBorder、SoftBevelBorder、EtchedBorder、LineBorder、TitledBorder 和 MatteBorder。
  • 要创建新的 border 类，请用 AbstractBorder 创建子类。

另请参见：
BorderFactory, EmptyBorder, CompoundBorder

方法摘要
Insets | getBorderInsets(Component c) 返回该边框的 insets。
boolean | isBorderOpaque() 返回此边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按指定的位置和尺寸绘制指定组件的边框。

方法详细信息

paintBorder

void paintBorder(Component c,
                 Graphics g,
                 int x,
                 int y,
                 int width,
                 int height)
按指定的位置和尺寸绘制指定组件的边框。

参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

Insets getBorderInsets(Component c)
返回该边框的 insets。

参数：
c - 要应用此边框 insets 值的组件

isBorderOpaque

boolean isBorderOpaque()
返回此边框是否透明。如果边框为不透明，则在绘制它时将用自身的背景来填充。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CompoundBorder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 CompoundBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.CompoundBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BorderUIResource.CompoundBorderUIResource
public class CompoundBorder
extends AbstractBorder

一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。例如，此类可使用现有的装饰边框向组件添加空白边缘区域：

    Border border = comp.getBorder();
    Border margin = new EmptyBorder(10,10,10,10);
    comp.setBorder(new CompoundBorder(border, margin));

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected Border | insideBorder
protected Border | outsideBorder
构造方法摘要
CompoundBorder()
创建一个组合边框，其内部边框和外部边框均为 null。
CompoundBorder(Border outsideBorder, Border insideBorder)
按照指定的内部边框和外部边框创建组合边框。
方法摘要
Insets | getBorderInsets(Component c) 返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Border | getInsideBorder() 返回内部边框对象。
Border | getOutsideBorder() 返回外部边框对象。
boolean | isBorderOpaque() 返回此组合边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

outsideBorder

protected Border outsideBorder

insideBorder

protected Border insideBorder
构造方法详细信息

CompoundBorder

public CompoundBorder()
创建一个组合边框，其内部边框和外部边框均为 null。

CompoundBorder

public CompoundBorder(Border outsideBorder,
                      Border insideBorder)
按照指定的内部边框和外部边框创建组合边框。其内部边框和外部边框都可以为 null。

参数：
outsideBorder - 外部边框
insideBorder - 要嵌套的内部边框
方法详细信息

isBorderOpaque

public boolean isBorderOpaque()
返回此组合边框是否透明。如果内部边框和外部边框均不为 null 且均不透明，则返回 true；否则返回 false。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 AbstractBorder 中的 isBorderOpaque
返回：
false

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
绘制组合边框，方法是先按指定的位置和尺寸绘制外部边框，然后按照外部边框 insets 指定的位置和尺寸偏移量绘制内部边框。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

getBorderInsets

public Insets getBorderInsets(Component c)
返回复合边框的 insets，它是外部边框的 insets 与内部边框的 insets 相加所得的结果。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getOutsideBorder

public Border getOutsideBorder()
返回外部边框对象。

getInsideBorder

public Border getInsideBorder()
返回内部边框对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EmptyBorder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 EmptyBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.EmptyBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BorderUIResource.EmptyBorderUIResource, MatteBorder
public class EmptyBorder
extends AbstractBorder
implements Serializable

该类提供了一个占用空间但不执行绘制的空透明边框。

警告：此类已序列化的对象将不再与以后的 Swing 版本兼容。当前的序列化支持适合于在运行相同 Swing 版本的应用程序之间短期存储或 RMI。从 1.4 版开始，已在 java.beans 包中加入对所有 JavaBeansTM 的长期存储支持。请参见 XMLEncoder。

字段摘要
protected int | bottom
protected int | left
protected int | right
protected int | top
构造方法摘要
EmptyBorder(Insets borderInsets)
创建具有指定 insets 的空边框
EmptyBorder(int top, int left, int bottom, int right)
创建具有指定 insets 的空边框
方法摘要
Insets | getBorderInsets() 返回此边框的 insets。
Insets | getBorderInsets(Component c) 返回此边框的 insets
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
boolean | isBorderOpaque() 返回此边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 默认情况下不执行绘制。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

left

protected int left

right

protected int right

top

protected int top

bottom

protected int bottom
构造方法详细信息

EmptyBorder

public EmptyBorder(int top,
                   int left,
                   int bottom,
                   int right)
创建具有指定 insets 的空边框

参数：
top - 边框顶部 inset
left - 边框左部 inset
bottom - 边框底部 inset
right - 边框右部 inset

EmptyBorder

public EmptyBorder(Insets borderInsets)
创建具有指定 insets 的空边框

参数：
borderInsets - 边框的 insets
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
默认情况下不执行绘制。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
返回此边框的 insets

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象
从以下版本开始：
1.3

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

getBorderInsets

public Insets getBorderInsets()
返回此边框的 insets。

从以下版本开始：
1.3

isBorderOpaque

public boolean isBorderOpaque()
返回此边框是否透明。默认情况下返回 false。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 AbstractBorder 中的 isBorderOpaque
返回：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EtchedBorder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 EtchedBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.EtchedBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BorderUIResource.EtchedBorderUIResource
public class EtchedBorder
extends AbstractBorder

该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。如果创建边框时未初始化任何高亮显示/阴影颜色，则这些颜色将从传递给 paintBorder() 方法的组件参数的背景色动态派生。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected int | etchType
protected Color | highlight
static int | LOWERED 阴刻浮雕化类型。
static int | RAISED 阳刻浮雕化类型。
protected Color | shadow
构造方法摘要
EtchedBorder()
创建一个阴刻浮雕化类型的边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。
EtchedBorder(Color highlight, Color shadow)
创建具有指定高亮显示和阴影颜色的阴刻浮雕化边框
EtchedBorder(int etchType)
创建具有指定蚀刻类型的浮雕化边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生
EtchedBorder(int etchType, Color highlight, Color shadow)
创建具有指定蚀刻类型、高亮显示和阴影颜色的浮雕化边框
方法摘要
Insets | getBorderInsets(Component c) 返回边框的 insets
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数
int | getEtchType() 返回浮雕化边框设置的蚀刻类型。
Color | getHighlightColor() 返回浮雕化边框的高亮显示颜色。
Color | getHighlightColor(Component c) 返回浮雕化边框在指定组件上呈现的高亮显示颜色。
Color | getShadowColor() 返回浮雕化边框的阴影颜色。
Color | getShadowColor(Component c) 返回浮雕化边框在指定组件上呈现的阴影颜色。
boolean | isBorderOpaque() 返回边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

RAISED

public static final int RAISED
阳刻浮雕化类型。

另请参见：
常量字段值

LOWERED

public static final int LOWERED
阴刻浮雕化类型。

另请参见：
常量字段值

etchType

protected int etchType

highlight

protected Color highlight

shadow

protected Color shadow
构造方法详细信息

EtchedBorder

public EtchedBorder()
创建一个阴刻浮雕化类型的边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生。

EtchedBorder

public EtchedBorder(int etchType)
创建具有指定蚀刻类型的浮雕化边框，其颜色将从传递给 paintBorder 方法的组件的背景色派生

参数：
etchType - 边框要绘制的蚀刻类型

EtchedBorder

public EtchedBorder(Color highlight,
                    Color shadow)
创建具有指定高亮显示和阴影颜色的阴刻浮雕化边框

参数：
highlight - 用于浮雕化高亮显示的颜色
shadow - 用于浮雕化阴影的颜色

EtchedBorder

public EtchedBorder(int etchType,
                    Color highlight,
                    Color shadow)
创建具有指定蚀刻类型、高亮显示和阴影颜色的浮雕化边框

参数：
etchType - 边框要绘制的蚀刻类型
highlight - 用于浮雕化高亮显示的颜色
shadow - 用于浮雕化阴影的颜色
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
按照指定的位置和尺寸为指定的组件绘制边框

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
返回边框的 insets

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

isBorderOpaque

public boolean isBorderOpaque()
返回边框是否透明。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 AbstractBorder 中的 isBorderOpaque
返回：
false

getEtchType

public int getEtchType()
返回浮雕化边框设置的蚀刻类型。

getHighlightColor

public Color getHighlightColor(Component c)
返回浮雕化边框在指定组件上呈现的高亮显示颜色。如果实例化时未指定任何高亮显示颜色，高亮显示颜色将从指定组件的背景色派生

参数：
c - 从其派生高亮显示颜色的组件
从以下版本开始：
1.3

getHighlightColor

public Color getHighlightColor()
返回浮雕化边框的高亮显示颜色。如果实例化时未指定任何高亮显示颜色，则返回 null。

从以下版本开始：
1.3

getShadowColor

public Color getShadowColor(Component c)
返回浮雕化边框在指定组件上呈现的阴影颜色。如果实例化时未指定任何阴影颜色，阴影颜色将从指定组件的背景色派生

参数：
c - 从其派生阴影颜色的组件
从以下版本开始：
1.3

getShadowColor

public Color getShadowColor()
返回浮雕化边框的阴影颜色。如果实例化时未指定任何阴影颜色，则返回 null。

从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


LineBorder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 LineBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.LineBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BorderUIResource.LineBorderUIResource
public class LineBorder
extends AbstractBorder

实现单色、任意厚度线边框的类。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected Color | lineColor
protected boolean | roundedCorners
protected int | thickness
构造方法摘要
LineBorder(Color color)
创建具有指定颜色、厚度为 1（thickness = 1）的线边框。
LineBorder(Color color, int thickness)
创建具有指定颜色和厚度的线边框。
LineBorder(Color color, int thickness, boolean roundedCorners)
创建具有指定颜色、厚度和拐角形状的线条边框。
方法摘要
static Border | createBlackLineBorder() 获取一个颜色为黑色、厚度为 1 的线边框的便捷方法。
static Border | createGrayLineBorder() 获取一个颜色为灰色、厚度为 1 的线条边框的便捷方法。
Insets | getBorderInsets(Component c) 返回边框的 insets。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Color | getLineColor() 返回边框的颜色。
boolean | getRoundedCorners() 返回是否将此边框绘制为圆弧拐角边框。
int | getThickness() 返回边框的厚度。
boolean | isBorderOpaque() 返回此边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸为指定的组件绘制边框。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

thickness

protected int thickness

lineColor

protected Color lineColor

roundedCorners

protected boolean roundedCorners
构造方法详细信息

LineBorder

public LineBorder(Color color)
创建具有指定颜色、厚度为 1（thickness = 1）的线边框。

参数：
color - 边框的颜色。

LineBorder

public LineBorder(Color color,
                  int thickness)
创建具有指定颜色和厚度的线边框。

参数：
color - 边框的颜色
thickness - 边框的厚度

LineBorder

public LineBorder(Color color,
                  int thickness,
                  boolean roundedCorners)
创建具有指定颜色、厚度和拐角形状的线条边框。

参数：
color - 边框的颜色
thickness - 边框的厚度
roundedCorners - 边框拐角是否应为弧形
从以下版本开始：
1.3
方法详细信息

createBlackLineBorder

public static Border createBlackLineBorder()
获取一个颜色为黑色、厚度为 1 的线边框的便捷方法。

createGrayLineBorder

public static Border createGrayLineBorder()
获取一个颜色为灰色、厚度为 1 的线条边框的便捷方法。

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
按照指定的位置和尺寸为指定的组件绘制边框。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
返回边框的 insets。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

getLineColor

public Color getLineColor()
返回边框的颜色。

getThickness

public int getThickness()
返回边框的厚度。

getRoundedCorners

public boolean getRoundedCorners()
返回是否将此边框绘制为圆弧拐角边框。

从以下版本开始：
1.3

isBorderOpaque

public boolean isBorderOpaque()
返回此边框是否透明。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 AbstractBorder 中的 isBorderOpaque
返回：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MatteBorder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 MatteBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.EmptyBorder
            继承者  javax.swing.border.MatteBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BorderUIResource.MatteBorderUIResource
public class MatteBorder
extends EmptyBorder

该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected Color | color
protected Icon | tileIcon
从类 javax.swing.border.EmptyBorder 继承的字段
bottom, left, right, top
构造方法摘要
MatteBorder(Icon tileIcon)
创建具有指定平铺图标的衬边边框。
MatteBorder(Insets borderInsets, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(Insets borderInsets, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。
MatteBorder(int top, int left, int bottom, int right, Color matteColor)
创建具有指定 insets 和颜色的衬边边框。
MatteBorder(int top, int left, int bottom, int right, Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。
方法摘要
Insets | getBorderInsets() 返回此边框的 insets。
Insets | getBorderInsets(Component c) 返回边框的 insets。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
Color | getMatteColor() 返回平铺边框的颜色，如果使用了平铺图标，则返回 null。
Icon | getTileIcon() 返回平铺边框的图标，如果使用了纯色，则返回 null。
boolean | isBorderOpaque() 返回边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 绘制衬边边框。
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

color

protected Color color

tileIcon

protected Icon tileIcon
构造方法详细信息

MatteBorder

public MatteBorder(int top,
                   int left,
                   int bottom,
                   int right,
                   Color matteColor)
创建具有指定 insets 和颜色的衬边边框。

参数：
top - 边框顶部 inset
left - 边框左部 inset
bottom - 边框底部 inset
right - 边框右部 inset
matteColor - 边框呈现的颜色

MatteBorder

public MatteBorder(Insets borderInsets,
                   Color matteColor)
创建具有指定 insets 和颜色的衬边边框。

参数：
borderInsets - 边框的 insets
matteColor - 边框呈现的颜色
从以下版本开始：
1.3

MatteBorder

public MatteBorder(int top,
                   int left,
                   int bottom,
                   int right,
                   Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。

参数：
top - 边框顶部 inset
left - 边框左部 inset
bottom - 边框底部 insetr
边框右部 - inset
tileIcon - 用于平铺边框的图标

MatteBorder

public MatteBorder(Insets borderInsets,
                   Icon tileIcon)
创建具有指定 insets 和平铺图标的衬边边框。

参数：
borderInsets - 边框的 insets
tileIcon - 用于平铺边框的图标
从以下版本开始：
1.3

MatteBorder

public MatteBorder(Icon tileIcon)
创建具有指定平铺图标的衬边边框。将会根据平铺图标的大小动态计算 insets，其中顶部和底部 insets 将等于平铺图标的高度，而左部和右部 insets 将等于平铺图标的宽度。

参数：
tileIcon - 用于平铺边框的图标
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
绘制衬边边框。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 EmptyBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
返回边框的 insets。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 EmptyBorder 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象
从以下版本开始：
1.3

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 EmptyBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象
从以下版本开始：
1.3

getBorderInsets

public Insets getBorderInsets()
返回此边框的 insets。

覆盖：
类 EmptyBorder 中的 getBorderInsets
从以下版本开始：
1.3

getMatteColor

public Color getMatteColor()
返回平铺边框的颜色，如果使用了平铺图标，则返回 null。

从以下版本开始：
1.3

getTileIcon

public Icon getTileIcon()
返回平铺边框的图标，如果使用了纯色，则返回 null。

从以下版本开始：
1.3

isBorderOpaque

public boolean isBorderOpaque()
返回边框是否透明。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 EmptyBorder 中的 isBorderOpaque
返回：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SoftBevelBorder (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 SoftBevelBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.BevelBorder
            继承者  javax.swing.border.SoftBevelBorder
所有已实现的接口：
Serializable, Border
public class SoftBevelBorder
extends BevelBorder

实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 javax.swing.border.BevelBorder 继承的字段
bevelType, highlightInner, highlightOuter, LOWERED, RAISED, shadowInner, shadowOuter
构造方法摘要
SoftBevelBorder(int bevelType)
创建具有用指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件背景色派生。
SoftBevelBorder(int bevelType, Color highlight, Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
SoftBevelBorder(int bevelType, Color highlightOuterColor, Color highlightInnerColor, Color shadowOuterColor, Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。
方法摘要
Insets | getBorderInsets(Component c) 返回边框的 insets。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
boolean | isBorderOpaque() 返回边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和尺寸绘制指定组件的边框。
从类 javax.swing.border.BevelBorder 继承的方法
getBevelType, getHighlightInnerColor, getHighlightInnerColor, getHighlightOuterColor, getHighlightOuterColor, getShadowInnerColor, getShadowInnerColor, getShadowOuterColor, getShadowOuterColor, paintLoweredBevel, paintRaisedBevel
从类 javax.swing.border.AbstractBorder 继承的方法
getBaseline, getBaselineResizeBehavior, getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SoftBevelBorder

public SoftBevelBorder(int bevelType)
创建具有用指定类型的斜面边框，其颜色将从传递给 paintBorder 方法的组件背景色派生。

参数：
bevelType - 边框斜面类型

SoftBevelBorder

public SoftBevelBorder(int bevelType,
                       Color highlight,
                       Color shadow)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。

参数：
bevelType - 边框的斜面类型
highlight - 斜面高亮显示所用颜色
shadow - 斜面阴影所用颜色

SoftBevelBorder

public SoftBevelBorder(int bevelType,
                       Color highlightOuterColor,
                       Color highlightInnerColor,
                       Color shadowOuterColor,
                       Color shadowInnerColor)
创建具有指定类型、高亮显示和阴影颜色的斜面边框。

参数：
bevelType - 边框的斜面类型
highlightOuterColor - 斜面外部高亮显示所用颜色
highlightInnerColor - 斜面内部高亮显示所用颜色
shadowOuterColor - 斜面外部阴影所用颜色
shadowInnerColor - 斜面内部阴影所用颜色
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
按照指定的位置和尺寸绘制指定组件的边框。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 BevelBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
返回边框的 insets。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 BevelBorder 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 BevelBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

isBorderOpaque

public boolean isBorderOpaque()
返回边框是否透明。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 BevelBorder 中的 isBorderOpaque
返回：
false
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TitledBorder (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.border
类 TitledBorder

java.lang.Object
    继承者  javax.swing.border.AbstractBorder
        继承者  javax.swing.border.TitledBorder
所有已实现的接口：
Serializable, Border
直接已知子类：
BorderUIResource.TitledBorderUIResource
public class TitledBorder
extends AbstractBorder

该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

如果构造方法中未指定边框、字体或颜色属性，也没有调用相应的设置方法来设置这些属性值，则当前外观将按照“默认表”中的如下属性名称定义属性值：

  • "TitledBorder.border"
  • "TitledBorder.font"
  • "TitledBorder.titleColor"

警告：此类的已序列化对象与以后的 Swing 版本不兼容。当前序列化支持适用于短期存储，或适用于在运行相同 Swing 版本的应用程序之间进行 RMI（Remote Method Invocation，远程方法调用）。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
static int | ABOVE_BOTTOM 将标题置于边框底端线的顶部。
static int | ABOVE_TOP 将标题置于边框顶端线的上部。
static int | BELOW_BOTTOM 将标题置于边框底端线的底部。
static int | BELOW_TOP 将标题置于边框顶端线的底部。
protected Border | border
static int | BOTTOM 将标题置于边框底端线的中部。
static int | CENTER 将标题文本置于边框线的中心。
static int | DEFAULT_JUSTIFICATION 标题文本使用默认的对齐方式。
static int | DEFAULT_POSITION 标题文本使用默认的垂直方向。
protected static int | EDGE_SPACING
static int | LEADING 从左到右排列时将标题文本置于边框线的左边，从右到左排列时将标题文本置于边框线的右边。
static int | LEFT 将标题文本置于边框线的左边。
static int | RIGHT 将标题文本置于边框线的右边。
protected static int | TEXT_INSET_H
protected static int | TEXT_SPACING
protected String | title
protected Color | titleColor
protected Font | titleFont
protected int | titleJustification
protected int | titlePosition
static int | TOP 将标题置于边框顶端线的中部。
static int | TRAILING 从左到右排列时将标题文本置于边框线的右边，从右到左排列时将标题文本置于边框线的左边。
构造方法摘要
TitledBorder(Border border)
创建具有指定边框和空标题的 TitledBorder 实例。
TitledBorder(Border border, String title)
创建具有指定边框和标题的 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition)
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。
TitledBorder(String title)
创建 TitledBorder 实例。
方法摘要
int | getBaseline(Component c, int width, int height) 返回基线。
Component.BaselineResizeBehavior | getBaselineResizeBehavior(Component c) 返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。
Border | getBorder() 返回带标题边框的边框。
Insets | getBorderInsets(Component c) 返回边框的 insets。
Insets | getBorderInsets(Component c, Insets insets) 用此边框的当前 Insets 重新初始化 insets 参数。
protected Font | getFont(Component c)
Dimension | getMinimumSize(Component c) 返回此边框完全显示边框和标题所需的最小大小。
String | getTitle() 返回带标题边框的标题。
Color | getTitleColor() 返回带标题边框的标题颜色。
Font | getTitleFont() 返回带标题边框的标题字体。
int | getTitleJustification() 返回带标题边框的标题对齐方式。
int | getTitlePosition() 返回带标题边框的标题位置。
boolean | isBorderOpaque() 返回边框是否透明。
void | paintBorder(Component c, Graphics g, int x, int y, int width, int height) 按照指定的位置和大小为指定的组件绘制边框。
void | setBorder(Border border) 设置带标题边框的边框。
void | setTitle(String title) 设置带标题边框的标题。
void | setTitleColor(Color titleColor) 设置带标题边框的标题颜色。
void | setTitleFont(Font titleFont) 设置带标题边框的标题字体。
void | setTitleJustification(int titleJustification) 设置带标题边框的标题对齐方式。
void | setTitlePosition(int titlePosition) 设置带标题边框的标题位置。
从类 javax.swing.border.AbstractBorder 继承的方法
getInteriorRectangle, getInteriorRectangle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

title

protected String title

border

protected Border border

titlePosition

protected int titlePosition

titleJustification

protected int titleJustification

titleFont

protected Font titleFont

titleColor

protected Color titleColor

DEFAULT_POSITION

public static final int DEFAULT_POSITION
标题文本使用默认的垂直方向。

另请参见：
常量字段值

ABOVE_TOP

public static final int ABOVE_TOP
将标题置于边框顶端线的上部。

另请参见：
常量字段值

TOP

public static final int TOP
将标题置于边框顶端线的中部。

另请参见：
常量字段值

BELOW_TOP

public static final int BELOW_TOP
将标题置于边框顶端线的底部。

另请参见：
常量字段值

ABOVE_BOTTOM

public static final int ABOVE_BOTTOM
将标题置于边框底端线的顶部。

另请参见：
常量字段值

BOTTOM

public static final int BOTTOM
将标题置于边框底端线的中部。

另请参见：
常量字段值

BELOW_BOTTOM

public static final int BELOW_BOTTOM
将标题置于边框底端线的底部。

另请参见：
常量字段值

DEFAULT_JUSTIFICATION

public static final int DEFAULT_JUSTIFICATION
标题文本使用默认的对齐方式。

另请参见：
常量字段值

LEFT

public static final int LEFT
将标题文本置于边框线的左边。

另请参见：
常量字段值

CENTER

public static final int CENTER
将标题文本置于边框线的中心。

另请参见：
常量字段值

RIGHT

public static final int RIGHT
将标题文本置于边框线的右边。

另请参见：
常量字段值

LEADING

public static final int LEADING
从左到右排列时将标题文本置于边框线的左边，从右到左排列时将标题文本置于边框线的右边。

另请参见：
常量字段值

TRAILING

public static final int TRAILING
从左到右排列时将标题文本置于边框线的右边，从右到左排列时将标题文本置于边框线的左边。

另请参见：
常量字段值

EDGE_SPACING

protected static final int EDGE_SPACING
另请参见：
常量字段值

TEXT_SPACING

protected static final int TEXT_SPACING
另请参见：
常量字段值

TEXT_INSET_H

protected static final int TEXT_INSET_H
另请参见：
常量字段值
构造方法详细信息

TitledBorder

public TitledBorder(String title)
创建 TitledBorder 实例。

参数：
title - 边框应显示的标题

TitledBorder

public TitledBorder(Border border)
创建具有指定边框和空标题的 TitledBorder 实例。

参数：
border - 边框

TitledBorder

public TitledBorder(Border border,
                    String title)
创建具有指定边框和标题的 TitledBorder 实例。

参数：
border - 边框
title - 边框应显示的标题

TitledBorder

public TitledBorder(Border border,
                    String title,
                    int titleJustification,
                    int titlePosition)
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。

参数：
border - 边框
title - 边框应显示的标题
titleJustification - 标题的对齐方式
titlePosition - 标题的位置

TitledBorder

public TitledBorder(Border border,
                    String title,
                    int titleJustification,
                    int titlePosition,
                    Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。

参数：
border - 边框
title - 边框应显示的标题
titleJustification - 标题的对齐方式
titlePosition - 标题的位置
titleFont - 显示标题的字体

TitledBorder

public TitledBorder(Border border,
                    String title,
                    int titleJustification,
                    int titlePosition,
                    Font titleFont,
                    Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

参数：
border - 边框
title - 边框应显示的标题
titleJustification - 标题的对齐方式
titlePosition - 标题的位置
titleFont - 标题的字体
titleColor - 标题的颜色
方法详细信息

paintBorder

public void paintBorder(Component c,
                        Graphics g,
                        int x,
                        int y,
                        int width,
                        int height)
按照指定的位置和大小为指定的组件绘制边框。

指定者：
接口 Border 中的 paintBorder
覆盖：
类 AbstractBorder 中的 paintBorder
参数：
c - 要为其绘制边框的组件
g - 绘制的图形
x - 所绘制边框的 x 坐标位置
y - 所绘制边框的 y 坐标位置
width - 所绘制边框的宽度
height - 所绘制边框的高度

getBorderInsets

public Insets getBorderInsets(Component c)
返回边框的 insets。

指定者：
接口 Border 中的 getBorderInsets
覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 要应用此边框 insets 值的组件
返回：
已初始化为 0 的新 Insets 对象

getBorderInsets

public Insets getBorderInsets(Component c,
                              Insets insets)
用此边框的当前 Insets 重新初始化 insets 参数。

覆盖：
类 AbstractBorder 中的 getBorderInsets
参数：
c - 应用此边框 insets 值的组件
insets - 要重新初始化的对象
返回：
insets 对象

isBorderOpaque

public boolean isBorderOpaque()
返回边框是否透明。

指定者：
接口 Border 中的 isBorderOpaque
覆盖：
类 AbstractBorder 中的 isBorderOpaque
返回：
false

getTitle

public String getTitle()
返回带标题边框的标题。

getBorder

public Border getBorder()
返回带标题边框的边框。

getTitlePosition

public int getTitlePosition()
返回带标题边框的标题位置。

getTitleJustification

public int getTitleJustification()
返回带标题边框的标题对齐方式。

getTitleFont

public Font getTitleFont()
返回带标题边框的标题字体。

getTitleColor

public Color getTitleColor()
返回带标题边框的标题颜色。

setTitle

public void setTitle(String title)
设置带标题边框的标题。参数 title 为边框的 title（标题）

setBorder

public void setBorder(Border border)
设置带标题边框的边框。

参数：
border - 边框

setTitlePosition

public void setTitlePosition(int titlePosition)
设置带标题边框的标题位置。

参数：
titlePosition - 边框的位置

setTitleJustification

public void setTitleJustification(int titleJustification)
设置带标题边框的标题对齐方式。

参数：
titleJustification - 边框标题的对齐方式

setTitleFont

public void setTitleFont(Font titleFont)
设置带标题边框的标题字体。

参数：
titleFont - 边框标题的字体

setTitleColor

public void setTitleColor(Color titleColor)
设置带标题边框的标题颜色。

参数：
titleColor - 边框标题的颜色

getMinimumSize

public Dimension getMinimumSize(Component c)
返回此边框完全显示边框和标题所需的最小大小。

参数：
c - 将在其上绘制此边框的组件

getBaseline

public int getBaseline(Component c,
                       int width,
                       int height)
返回基线。

覆盖：
类 AbstractBorder 中的 getBaseline
参数：
c - 将为其请求基线的 Component
width - 为其获取基线的宽度
height - 为其获取基线的高度
返回：
基线；如果 <0，则指示没有合理的基线
抛出：
NullPointerException
IllegalArgumentException - 如果宽度或高度 < 0
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getBaselineResizeBehavior

public Component.BaselineResizeBehavior getBaselineResizeBehavior(Component c)
返回一个枚举，指示该边框的基线如何随大小的改变而发生更改。

覆盖：
类 AbstractBorder 中的 getBaselineResizeBehavior
参数：
c - 为其返回基线调整大小行为的 Component
返回：
一个枚举，指示调整边框大小时基线如何改变
抛出：
NullPointerException
从以下版本开始：
1.6
另请参见：
JComponent.getBaseline(int, int)

getFont

protected Font getFont(Component c)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.border (Java 2 Platform SE 6)

 javax.swing.border
接口
Border
类
AbstractBorder
BevelBorder
CompoundBorder
EmptyBorder
EtchedBorder
LineBorder
MatteBorder
SoftBevelBorder
TitledBorder


javax.swing.border (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.border

提供围绕 Swing 组件绘制特殊边框的类和接口。

请参见：
描述

接口摘要
Border 该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。

类摘要
AbstractBorder | 实现无大小限制的空边框类。
BevelBorder | 该类实现简单的双线斜面边框。
CompoundBorder | 一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
EmptyBorder | 该类提供了一个占用空间但不执行绘制的空透明边框。
EtchedBorder | 该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
LineBorder | 实现单色、任意厚度线边框的类。
MatteBorder | 该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
SoftBevelBorder | 实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
TitledBorder | 该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

软件包 javax.swing.border 的描述

提供围绕 Swing 组件绘制特殊边框的类和接口。您可以通过为这些类创建子类来创建组件的自定义边框，不需要使用外观所提供的默认边框。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • The Java Tutorial 中的 How to Use Borders 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.border 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.border 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.border.AbstractBorder (implements javax.swing.border.Border, java.io.Serializable)
      • javax.swing.border.BevelBorder
        • javax.swing.border.SoftBevelBorder
      • javax.swing.border.CompoundBorder
      • javax.swing.border.EmptyBorder (implements java.io.Serializable)
        • javax.swing.border.MatteBorder
      • javax.swing.border.EtchedBorder
      • javax.swing.border.LineBorder
      • javax.swing.border.TitledBorder

接口分层结构

  • javax.swing.border.Border
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.swing.border 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.border
的使用

使用 javax.swing.border 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 使用的 javax.swing.border 中的类
Border
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。
CompoundBorder
一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
MatteBorder
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
TitledBorder
该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.border 使用的 javax.swing.border 中的类
AbstractBorder
实现无大小限制的空边框类。
BevelBorder
该类实现简单的双线斜面边框。
Border
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。
EmptyBorder
该类提供了一个占用空间但不执行绘制的空透明边框。

javax.swing.plaf 使用的 javax.swing.border 中的类
AbstractBorder
实现无大小限制的空边框类。
BevelBorder
该类实现简单的双线斜面边框。
Border
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。
CompoundBorder
一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
EmptyBorder
该类提供了一个占用空间但不执行绘制的空透明边框。
EtchedBorder
该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
LineBorder
实现单色、任意厚度线边框的类。
MatteBorder
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
TitledBorder
该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.plaf.basic 使用的 javax.swing.border 中的类
AbstractBorder
实现无大小限制的空边框类。
Border
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。

javax.swing.plaf.metal 使用的 javax.swing.border 中的类
AbstractBorder
实现无大小限制的空边框类。
Border
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。

javax.swing.table 使用的 javax.swing.border 中的类
Border
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。

javax.swing.tree 使用的 javax.swing.border 中的类
Border
该接口描述一个能够呈现围绕 swing 组件边缘边框的对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.SoftBevelBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.SoftBevelBorder
的使用

没有 javax.swing.border.SoftBevelBorder 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.TitledBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.TitledBorder
的使用

使用 TitledBorder 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 TitledBorder 的使用

返回 TitledBorder 的 javax.swing 中的方法
static TitledBorder | BorderFactory.createTitledBorder(Border border) 创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title) 向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition) 向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont) 向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
static TitledBorder | BorderFactory.createTitledBorder(String title) 创建一个新标题边框，使其具有指定的标题、默认的边框类型（由当前外观确定）、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。

javax.swing.plaf 中 TitledBorder 的使用

javax.swing.plaf 中 TitledBorder 的子类
static class BorderUIResource.TitledBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.BevelBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.BevelBorder
的使用

使用 BevelBorder 的软件包
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.border 中 BevelBorder 的使用

javax.swing.border 中 BevelBorder 的子类
 class SoftBevelBorder
实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。

javax.swing.plaf 中 BevelBorder 的使用

javax.swing.plaf 中 BevelBorder 的子类
static class BorderUIResource.BevelBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.EtchedBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.EtchedBorder
的使用

使用 EtchedBorder 的软件包
javax.swing.plaf 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf 中 EtchedBorder 的使用

javax.swing.plaf 中 EtchedBorder 的子类
static class BorderUIResource.EtchedBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.LineBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.LineBorder
的使用

使用 LineBorder 的软件包
javax.swing.plaf 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.plaf 中 LineBorder 的使用

javax.swing.plaf 中 LineBorder 的子类
static class BorderUIResource.LineBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.MatteBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.MatteBorder
的使用

使用 MatteBorder 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 MatteBorder 的使用

返回 MatteBorder 的 javax.swing 中的方法
static MatteBorder | BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Color color) 使用纯色创建一个类似衬边的边框。
static MatteBorder | BorderFactory.createMatteBorder(int top, int left, int bottom, int right, Icon tileIcon) 创建一个由多层指定图标组成的、类似衬边的边框。

javax.swing.plaf 中 MatteBorder 的使用

javax.swing.plaf 中 MatteBorder 的子类
static class BorderUIResource.MatteBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.CompoundBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.CompoundBorder
的使用

使用 CompoundBorder 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing 中 CompoundBorder 的使用

返回 CompoundBorder 的 javax.swing 中的方法
static CompoundBorder | BorderFactory.createCompoundBorder() 创建一个具有 null 内部边缘和 null 外部边缘的合成边框。
static CompoundBorder | BorderFactory.createCompoundBorder(Border outsideBorder, Border insideBorder) 创建一个合成边框，指定了用于外部和内部边缘的 border 对象。

javax.swing.plaf 中 CompoundBorder 的使用

javax.swing.plaf 中 CompoundBorder 的子类
static class BorderUIResource.CompoundBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.EmptyBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.EmptyBorder
的使用

使用 EmptyBorder 的软件包
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。

javax.swing.border 中 EmptyBorder 的使用

javax.swing.border 中 EmptyBorder 的子类
 class MatteBorder
该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。

javax.swing.plaf 中 EmptyBorder 的使用

javax.swing.plaf 中 EmptyBorder 的子类
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.MatteBorderUIResource

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.border.AbstractBorder 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.border.AbstractBorder
的使用

使用 AbstractBorder 的软件包
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。

javax.swing.border 中 AbstractBorder 的使用

javax.swing.border 中 AbstractBorder 的子类
class | BevelBorder 该类实现简单的双线斜面边框。
class | CompoundBorder 一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
class | EmptyBorder 该类提供了一个占用空间但不执行绘制的空透明边框。
class | EtchedBorder 该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
class | LineBorder 实现单色、任意厚度线边框的类。
class | MatteBorder 该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
class | SoftBevelBorder 实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
class | TitledBorder 该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

javax.swing.plaf 中 AbstractBorder 的使用

javax.swing.plaf 中 AbstractBorder 的子类
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource

javax.swing.plaf.basic 中 AbstractBorder 的使用

javax.swing.plaf.basic 中 AbstractBorder 的子类
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.ToggleButtonBorder

javax.swing.plaf.metal 中 AbstractBorder 的使用

javax.swing.plaf.metal 中 AbstractBorder 的子类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TableHeaderBorder Table Header 的边框
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.swing.border.Border 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.border.Border
的使用

使用 Border 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.border | 提供围绕 Swing 组件绘制特殊边框的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 Border 的使用

声明为 Border 的 javax.swing 中的字段
protected static Border DefaultListCellRenderer.noFocusBorder
一个空 Border。

返回 Border 的 javax.swing 中的方法
static Border | BorderFactory.createBevelBorder(int type) 创建一个指定类型的斜面边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
static Border | BorderFactory.createBevelBorder(int type, Color highlight, Color shadow) 使用指定高亮显示和阴影显示方式来创建一个指定类型的斜面边框。
static Border | BorderFactory.createBevelBorder(int type, Color highlightOuter, Color highlightInner, Color shadowOuter, Color shadowInner) 创建一个指定类型的斜面边框，使用内部和外部高亮显示区域及阴影区域的指定颜色。
static Border | BorderFactory.createEmptyBorder() 创建一个不占用空间的空边框。
static Border | BorderFactory.createEmptyBorder(int top, int left, int bottom, int right) 创建一个占用空间但没有绘制的空边框，指定了顶线、底线、左边框线和右边框线的宽度。
static Border | BorderFactory.createEtchedBorder() 创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
static Border | BorderFactory.createEtchedBorder(Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createEtchedBorder(int type) 创建一个具有“浮雕化”外观效果的边框，将组件的当前背景色用于高亮显示和阴影显示。
static Border | BorderFactory.createEtchedBorder(int type, Color highlight, Color shadow) 使用指定的高亮显示颜色和阴影颜色创建一个具有“浮雕化”外观效果的边框。
static Border | BorderFactory.createLineBorder(Color color) 创建一个具有指定颜色的线边框。
static Border | BorderFactory.createLineBorder(Color color, int thickness) 创建一个具有指定颜色和宽度的线边框。
static Border | BorderFactory.createLoweredBevelBorder() 创建一个具有凹入斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
static Border | BorderFactory.createRaisedBevelBorder() 创建一个具有凸出斜面边缘的边框，将组件当前背景色的较亮的色度用于高亮显示，较暗的色度用于阴影。
Border | JComponent.getBorder() 返回此组件的边框；如果当前未设置边框，则返回 null。
Border | UIDefaults.getBorder(Object key) 如果 key 值为一个 Border，则返回该 Border，否则返回 null。
static Border | UIManager.getBorder(Object key) 从默认值中返回一个边框。
Border | UIDefaults.getBorder(Object key, Locale l) 如果给定 Locale 的 key 值为一个 Border，则返回该 Border，否则返回 null。
static Border | UIManager.getBorder(Object key, Locale l) 从适合给定语言环境的默认值中返回一个边框。
Border | JScrollPane.getViewportBorder() 返回围绕该视口的 Border 对象。

参数类型为 Border 的 javax.swing 中的方法
static CompoundBorder | BorderFactory.createCompoundBorder(Border outsideBorder, Border insideBorder) 创建一个合成边框，指定了用于外部和内部边缘的 border 对象。
static TitledBorder | BorderFactory.createTitledBorder(Border border) 创建一个空标题的新标题边框，使其具有指定的边框对象、默认的文本位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title) 向现有边框添加一个标题，使其具有默认的位置（位于顶线上）、默认的调整 (leading)，以及默认的字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition) 向现有边框添加一个标题，使其具有指定的位置和默认字体和文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont) 向现有边框添加一个标题，使其具有指定的位置和默认的文本颜色（由当前外观确定）。
static TitledBorder | BorderFactory.createTitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor) 向现有边框添加一个标题，使其具有指定的位置、字体和颜色。
protected String | JComponent.AccessibleJComponent.getBorderTitle(Border b) 在边界层次结构（如果存在）中递归地搜索带有非 null 标题的 TitledBorder。
void | JViewport.setBorder(Border border) 视口通过常规父/子剪贴（一般该视图向滚动的相反方向移动）“滚动”其子视口（称为“视图”）。
void | JComponent.setBorder(Border border) 设置此组件的边框。
void | JScrollPane.setViewportBorder(Border viewportBorder) 围绕视口添加一个边界。

javax.swing.border 中 Border 的使用

实现 Border 的 javax.swing.border 中的类
class | AbstractBorder 实现无大小限制的空边框类。
class | BevelBorder 该类实现简单的双线斜面边框。
class | CompoundBorder 一个复合 Border 类，通过将内部 Border 对象嵌套到外部 Border 对象的 insets 中实现将两个 Border 对象合并为一个单个边框。
class | EmptyBorder 该类提供了一个占用空间但不执行绘制的空透明边框。
class | EtchedBorder 该类实现简单的浮雕化边框，它既可以是阴刻浮雕化边框，也可以是阳刻浮雕化边框。
class | LineBorder 实现单色、任意厚度线边框的类。
class | MatteBorder 该类提供类似衬边的边框，衬边图案既可以是纯色也可以是平铺的图标。
class | SoftBevelBorder 实现某种斜面的类，这种斜面要么凸出要么凹入且拐角圆滑。
class | TitledBorder 该类实现在指定位置以指定对齐方式显示字符串标题的任意边框。

声明为 Border 的 javax.swing.border 中的字段
protected Border | TitledBorder.border
protected Border | CompoundBorder.insideBorder
protected Border | CompoundBorder.outsideBorder

返回 Border 的 javax.swing.border 中的方法
static Border | LineBorder.createBlackLineBorder() 获取一个颜色为黑色、厚度为 1 的线边框的便捷方法。
static Border | LineBorder.createGrayLineBorder() 获取一个颜色为灰色、厚度为 1 的线条边框的便捷方法。
Border | TitledBorder.getBorder() 返回带标题边框的边框。
Border | CompoundBorder.getInsideBorder() 返回内部边框对象。
Border | CompoundBorder.getOutsideBorder() 返回外部边框对象。

参数类型为 Border 的 javax.swing.border 中的方法
static Rectangle | AbstractBorder.getInteriorRectangle(Component c, Border b, int x, int y, int width, int height) 返回一个用所给的参数减去边框 insets 得到的矩形。
void | TitledBorder.setBorder(Border border) 设置带标题边框的边框。

参数类型为 Border 的 javax.swing.border 中的构造方法
CompoundBorder(Border outsideBorder, Border insideBorder)
按照指定的内部边框和外部边框创建组合边框。
TitledBorder(Border border)
创建具有指定边框和空标题的 TitledBorder 实例。
TitledBorder(Border border, String title)
创建具有指定边框和标题的 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition)
用指定的边框、标题、标题对齐方式和标题位置创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
用指定的边框、标题、标题对齐方式、标题位置和标题字体创建 TitledBorder 实例。
TitledBorder(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
用指定的边框、标题、标题对齐方式、标题位置、标题字体和标题颜色创建 TitledBorder 实例。

javax.swing.plaf 中 Border 的使用

实现 Border 的 javax.swing.plaf 中的类
class | BorderUIResource
static class | BorderUIResource.BevelBorderUIResource
static class | BorderUIResource.CompoundBorderUIResource
static class | BorderUIResource.EmptyBorderUIResource
static class | BorderUIResource.EtchedBorderUIResource
static class | BorderUIResource.LineBorderUIResource
static class | BorderUIResource.MatteBorderUIResource
static class | BorderUIResource.TitledBorderUIResource

返回 Border 的 javax.swing.plaf 中的方法
static Border | BorderUIResource.getBlackLineBorderUIResource()
static Border | BorderUIResource.getEtchedBorderUIResource()
static Border | BorderUIResource.getLoweredBevelBorderUIResource()
static Border | BorderUIResource.getRaisedBevelBorderUIResource()

参数类型为 Border 的 javax.swing.plaf 中的构造方法
BorderUIResource.CompoundBorderUIResource(Border outsideBorder, Border insideBorder)
BorderUIResource.TitledBorderUIResource(Border border)
BorderUIResource.TitledBorderUIResource(Border border, String title)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont)
BorderUIResource.TitledBorderUIResource(Border border, String title, int titleJustification, int titlePosition, Font titleFont, Color titleColor)
BorderUIResource(Border delegate)
创建一个 UIResource 边框对象，该对象包装了一个现有 Border 实例。

javax.swing.plaf.basic 中 Border 的使用

实现 Border 的 javax.swing.plaf.basic 中的类
static class | BasicBorders.ButtonBorder
static class | BasicBorders.FieldBorder
static class | BasicBorders.MarginBorder
static class | BasicBorders.MenuBarBorder
static class | BasicBorders.RadioButtonBorder
static class | BasicBorders.RolloverButtonBorder 用于翻转工具栏按钮的特殊细边框。
static class | BasicBorders.SplitPaneBorder 绘制围绕拆分窗格的边框。
static class | BasicBorders.ToggleButtonBorder

声明为 Border 的 javax.swing.plaf.basic 中的字段
protected static Border BasicComboBoxRenderer.noFocusBorder
空 Border。

返回 Border 的 javax.swing.plaf.basic 中的方法
protected Border | BasicToolBarUI.createNonRolloverBorder() 创建工具栏组件的非翻转边框。
protected Border | BasicToolBarUI.createRolloverBorder() 创建工具栏组件的翻转边框。
Border | BasicSplitPaneDivider.getBorder() 返回此组件的边框，如果当前没有设置边框，则返回 null。
static Border | BasicBorders.getButtonBorder()
static Border | BasicBorders.getInternalFrameBorder()
static Border | BasicBorders.getMenuBarBorder()
protected Border | BasicToolBarUI.getNonRolloverBorder(AbstractButton b) 返回按钮的非翻转边框。
static Border | BasicBorders.getProgressBarBorder()
static Border | BasicBorders.getRadioButtonBorder()
protected Border | BasicToolBarUI.getRolloverBorder(AbstractButton b) 返回按钮的翻转边框。
static Border | BasicBorders.getSplitPaneBorder()
static Border | BasicBorders.getSplitPaneDividerBorder() 返回 JSplitPane 分隔符的边框实例
static Border | BasicBorders.getTextFieldBorder()
static Border | BasicBorders.getToggleButtonBorder()

参数类型为 Border 的 javax.swing.plaf.basic 中的方法
 void BasicSplitPaneDivider.setBorder(Border border)
设置此组件的边框。

javax.swing.plaf.metal 中 Border 的使用

实现 Border 的 javax.swing.plaf.metal 中的类
static class | MetalBorders.ButtonBorder
static class | MetalBorders.Flush3DBorder
static class | MetalBorders.InternalFrameBorder
static class | MetalBorders.MenuBarBorder
static class | MetalBorders.MenuItemBorder
static class | MetalBorders.OptionDialogBorder
static class | MetalBorders.PaletteBorder Palette 的边框。
static class | MetalBorders.PopupMenuBorder
static class | MetalBorders.RolloverButtonBorder
static class | MetalBorders.ScrollPaneBorder
static class | MetalBorders.TableHeaderBorder Table Header 的边框
static class | MetalBorders.TextFieldBorder
static class | MetalBorders.ToggleButtonBorder
static class | MetalBorders.ToolBarBorder

返回 Border 的 javax.swing.plaf.metal 中的方法
protected Border | MetalToolBarUI.createNonRolloverBorder()
protected Border | MetalToolBarUI.createRolloverBorder()
static Border | MetalBorders.getButtonBorder() 返回一个用于 JButton 的 border 实例
static Border | MetalBorders.getDesktopIconBorder() 返回一个用于 Desktop Icon 的 border 实例
static Border | MetalBorders.getTextBorder() 返回一个用于文本组件的 border 实例
static Border | MetalBorders.getTextFieldBorder() 返回一个用于 JTextField 的 border 实例
static Border | MetalBorders.getToggleButtonBorder() 返回一个用于 JToggleButton 的 border 实例

javax.swing.table 中 Border 的使用

声明为 Border 的 javax.swing.table 中的字段
protected static Border DefaultTableCellRenderer.noFocusBorder
一个空 Border。

javax.swing.tree 中 Border 的使用

声明为 Border 的 javax.swing.tree 中的字段
protected  Border DefaultTreeCellEditor.DefaultTextField.border
要使用的边框。

返回 Border 的 javax.swing.tree 中的方法
 Border DefaultTreeCellEditor.DefaultTextField.getBorder()
重写 JComponent.getBorder，以返回当前边框。

参数类型为 Border 的 javax.swing.tree 中的方法
 void DefaultTreeCellEditor.DefaultTextField.setBorder(Border border)
设置此组件的边框。

参数类型为 Border 的 javax.swing.tree 中的构造方法
DefaultTreeCellEditor.DefaultTextField(Border border)
构造一个 DefaultTreeCellEditor.DefaultTextField 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AbstractColorChooserPanel (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.colorchooser
类 AbstractColorChooserPanel

java.lang.Object
    继承者  java.awt.Component
        继承者  java.awt.Container
            继承者  javax.swing.JComponent
                继承者  javax.swing.JPanel
                    继承者  javax.swing.colorchooser.AbstractColorChooserPanel
所有已实现的接口：
ImageObserver, MenuContainer, Serializable, Accessible
public abstract class AbstractColorChooserPanel
extends JPanel

这是用于颜色选取器的抽象超类。如果希望在 JColorChooser 中添加一个新的颜色选取器面板，请创建该类的子类。

警告：此类已序列化的对象将不再与以后的 Swing 版本兼容。当前的序列化支持适合在运行相同 Swing 版本的应用程序之间短期存储或 RMI。从 1.4 版开始，已在 java.beans 包中加入对所有 JavaBeansTM 的长期存储支持。请参见 XMLEncoder。

嵌套类摘要
从类 javax.swing.JPanel 继承的嵌套类/接口
JPanel.AccessibleJPanel
从类 javax.swing.JComponent 继承的嵌套类/接口
JComponent.AccessibleJComponent
从类 java.awt.Container 继承的嵌套类/接口
Container.AccessibleAWTContainer
从类 java.awt.Component 继承的嵌套类/接口
Component.AccessibleAWTComponent, Component.BaselineResizeBehavior, Component.BltBufferStrategy, Component.FlipBufferStrategy
字段摘要
从类 javax.swing.JComponent 继承的字段
accessibleContext, listenerList, TOOL_TIP_TEXT_KEY, ui, UNDEFINED_CONDITION, WHEN_ANCESTOR_OF_FOCUSED_COMPONENT, WHEN_FOCUSED, WHEN_IN_FOCUSED_WINDOW
从类 java.awt.Component 继承的字段
BOTTOM_ALIGNMENT, CENTER_ALIGNMENT, LEFT_ALIGNMENT, RIGHT_ALIGNMENT, TOP_ALIGNMENT
从接口 java.awt.image.ImageObserver 继承的字段
ABORT, ALLBITS, ERROR, FRAMEBITS, HEIGHT, PROPERTIES, SOMEBITS, WIDTH
构造方法摘要
AbstractColorChooserPanel()
方法摘要
protected abstract void | buildChooser() 建立一个新的选取器面板。
protected Color | getColorFromModel() 返回当前所选取的颜色。
ColorSelectionModel | getColorSelectionModel() 返回选取器面板正在编辑的模型。
int | getDisplayedMnemonicIndex() 提供关于 getDisplayName 中字符的索引在外观方面的提示，字符索引应以可视化的方式标识为助记符。
abstract String | getDisplayName() 返回一个包含面板显示名称的字符串。
abstract Icon | getLargeDisplayIcon() 返回此面板的大显示图标。
int | getMnemonic() 提供关于 KeyEvent.VK 常量的外观方面的提示，此常量可用作访问面板的助记符。
abstract Icon | getSmallDisplayIcon() 返回此面板的小图标。
void | installChooserPanel(JColorChooser enclosingChooser) 将面板添加到选取器时被调用。
void | paint(Graphics g) 绘制面板。
void | uninstallChooserPanel(JColorChooser enclosingChooser) 从选取器中移除面板时被调用。
abstract void | updateChooser() 在模型状态更改时自动调用。
从类 javax.swing.JPanel 继承的方法
getAccessibleContext, getUI, getUIClassID, paramString, setUI, updateUI
从类 javax.swing.JComponent 继承的方法
addAncestorListener, addNotify, addVetoableChangeListener, computeVisibleRect, contains, createToolTip, disable, enable, firePropertyChange, firePropertyChange, firePropertyChange, fireVetoableChange, getActionForKeyStroke, getActionMap, getAlignmentX, getAlignmentY, getAncestorListeners, getAutoscrolls, getBaseline, getBaselineResizeBehavior, getBorder, getBounds, getClientProperty, getComponentGraphics, getComponentPopupMenu, getConditionForKeyStroke, getDebugGraphicsOptions, getDefaultLocale, getFontMetrics, getGraphics, getHeight, getInheritsPopupMenu, getInputMap, getInputMap, getInputVerifier, getInsets, getInsets, getListeners, getLocation, getMaximumSize, getMinimumSize, getNextFocusableComponent, getPopupLocation, getPreferredSize, getRegisteredKeyStrokes, getRootPane, getSize, getToolTipLocation, getToolTipText, getToolTipText, getTopLevelAncestor, getTransferHandler, getVerifyInputWhenFocusTarget, getVetoableChangeListeners, getVisibleRect, getWidth, getX, getY, grabFocus, isDoubleBuffered, isLightweightComponent, isManagingFocus, isOpaque, isOptimizedDrawingEnabled, isPaintingForPrint, isPaintingTile, isRequestFocusEnabled, isValidateRoot, paintBorder, paintChildren, paintComponent, paintImmediately, paintImmediately, print, printAll, printBorder, printChildren, printComponent, processComponentKeyEvent, processKeyBinding, processKeyEvent, processMouseEvent, processMouseMotionEvent, putClientProperty, registerKeyboardAction, registerKeyboardAction, removeAncestorListener, removeNotify, removeVetoableChangeListener, repaint, repaint, requestDefaultFocus, requestFocus, requestFocus, requestFocusInWindow, requestFocusInWindow, resetKeyboardActions, reshape, revalidate, scrollRectToVisible, setActionMap, setAlignmentX, setAlignmentY, setAutoscrolls, setBackground, setBorder, setComponentPopupMenu, setDebugGraphicsOptions, setDefaultLocale, setDoubleBuffered, setEnabled, setFocusTraversalKeys, setFont, setForeground, setInheritsPopupMenu, setInputMap, setInputVerifier, setMaximumSize, setMinimumSize, setNextFocusableComponent, setOpaque, setPreferredSize, setRequestFocusEnabled, setToolTipText, setTransferHandler, setUI, setVerifyInputWhenFocusTarget, setVisible, unregisterKeyboardAction, update
从类 java.awt.Container 继承的方法
add, add, add, add, add, addContainerListener, addImpl, addPropertyChangeListener, addPropertyChangeListener, applyComponentOrientation, areFocusTraversalKeysSet, countComponents, deliverEvent, doLayout, findComponentAt, findComponentAt, getComponent, getComponentAt, getComponentAt, getComponentCount, getComponents, getComponentZOrder, getContainerListeners, getFocusTraversalKeys, getFocusTraversalPolicy, getLayout, getMousePosition, insets, invalidate, isAncestorOf, isFocusCycleRoot, isFocusCycleRoot, isFocusTraversalPolicyProvider, isFocusTraversalPolicySet, layout, list, list, locate, minimumSize, paintComponents, preferredSize, printComponents, processContainerEvent, processEvent, remove, remove, removeAll, removeContainerListener, setComponentZOrder, setFocusCycleRoot, setFocusTraversalPolicy, setFocusTraversalPolicyProvider, setLayout, transferFocusBackward, transferFocusDownCycle, validate, validateTree
从类 java.awt.Component 继承的方法
action, add, addComponentListener, addFocusListener, addHierarchyBoundsListener, addHierarchyListener, addInputMethodListener, addKeyListener, addMouseListener, addMouseMotionListener, addMouseWheelListener, bounds, checkImage, checkImage, coalesceEvents, contains, createImage, createImage, createVolatileImage, createVolatileImage, disableEvents, dispatchEvent, enable, enableEvents, enableInputMethods, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getBackground, getBounds, getColorModel, getComponentListeners, getComponentOrientation, getCursor, getDropTarget, getFocusCycleRootAncestor, getFocusListeners, getFocusTraversalKeysEnabled, getFont, getForeground, getGraphicsConfiguration, getHierarchyBoundsListeners, getHierarchyListeners, getIgnoreRepaint, getInputContext, getInputMethodListeners, getInputMethodRequests, getKeyListeners, getLocale, getLocation, getLocationOnScreen, getMouseListeners, getMouseMotionListeners, getMousePosition, getMouseWheelListeners, getName, getParent, getPeer, getPropertyChangeListeners, getPropertyChangeListeners, getSize, getToolkit, getTreeLock, gotFocus, handleEvent, hasFocus, hide, imageUpdate, inside, isBackgroundSet, isCursorSet, isDisplayable, isEnabled, isFocusable, isFocusOwner, isFocusTraversable, isFontSet, isForegroundSet, isLightweight, isMaximumSizeSet, isMinimumSizeSet, isPreferredSizeSet, isShowing, isValid, isVisible, keyDown, keyUp, list, list, list, location, lostFocus, mouseDown, mouseDrag, mouseEnter, mouseExit, mouseMove, mouseUp, move, nextFocus, paintAll, postEvent, prepareImage, prepareImage, processComponentEvent, processFocusEvent, processHierarchyBoundsEvent, processHierarchyEvent, processInputMethodEvent, processMouseWheelEvent, remove, removeComponentListener, removeFocusListener, removeHierarchyBoundsListener, removeHierarchyListener, removeInputMethodListener, removeKeyListener, removeMouseListener, removeMouseMotionListener, removeMouseWheelListener, removePropertyChangeListener, removePropertyChangeListener, repaint, repaint, repaint, resize, resize, setBounds, setBounds, setComponentOrientation, setCursor, setDropTarget, setFocusable, setFocusTraversalKeysEnabled, setIgnoreRepaint, setLocale, setLocation, setLocation, setName, setSize, setSize, show, show, size, toString, transferFocus, transferFocusUpCycle
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

AbstractColorChooserPanel

public AbstractColorChooserPanel()
方法详细信息

updateChooser

public abstract void updateChooser()
在模型状态更改时自动调用。也可以由 installChooserPanel 来调用它，以便允许您设置选取器的初始状态。重写此方法以更新 ChooserPanel。

buildChooser

protected abstract void buildChooser()
建立一个新的选取器面板。

getDisplayName

public abstract String getDisplayName()
返回一个包含面板显示名称的字符串。

返回：
显示面板的名称

getMnemonic

public int getMnemonic()
提供关于 KeyEvent.VK 常量的外观方面的提示，此常量可用作访问面板的助记符。返回值 <= 0 表明无助记符。

这里的返回值是一个提示，最终由外观来为此返回值赋予真实的含义。

此实现返回 0，表明 AbstractColorChooserPanel 不支持助记符，希望使用助记符的子类需要重写此方法。

返回：
标识助记符的 KeyEvent.VK 常量；返回值 <= 0 表示无助记符
从以下版本开始：
1.4
另请参见：
getDisplayedMnemonicIndex()

getDisplayedMnemonicIndex

public int getDisplayedMnemonicIndex()
提供关于 getDisplayName 中字符的索引在外观方面的提示，字符索引应以可视化的方式标识为助记符。如果 getMnemonic 返回值 > 0，外观应当只用助记符。

这里的返回值是一个提示，最终由外观来为此返回值赋予真实的含义。例如，外观希望在 JTabbedPane 中呈现每个 AbstractColorChooserPanel，然后进一步使用该返回值来为 getDisplayName 中的某个字符加下划线。

此实现返回 -1，表明 AbstractColorChooserPanel 不支持助记符，希望使用助记符的子类需要重写此方法。

返回：
呈现助记符的字符索引；-1 表示不为该面板提供任何可视化标识符。
从以下版本开始：
1.4
另请参见：
getMnemonic()

getSmallDisplayIcon

public abstract Icon getSmallDisplayIcon()
返回此面板的小图标。

返回：
小显示图标

getLargeDisplayIcon

public abstract Icon getLargeDisplayIcon()
返回此面板的大显示图标。

返回：
大显示图标

installChooserPanel

public void installChooserPanel(JColorChooser enclosingChooser)
将面板添加到选取器时被调用。如果要重写此方法，一定要确保调用 super。

参数：
enclosingChooser - 要添加的面板
抛出：
RuntimeException - 如果已安装了选取器面板

uninstallChooserPanel

public void uninstallChooserPanel(JColorChooser enclosingChooser)
从选取器中移除面板时被调用。如果要重写此方法，一定要确保调用 super。

getColorSelectionModel

public ColorSelectionModel getColorSelectionModel()
返回选取器面板正在编辑的模型。

返回：
此面板正在编辑的 ColorSelectionModel 模型

getColorFromModel

protected Color getColorFromModel()
返回当前所选取的颜色。

返回：
所选取的 Color

paint

public void paint(Graphics g)
绘制面板。

覆盖：
类 JComponent 中的 paint
参数：
g - Graphics 对象
另请参见：
JComponent.paintComponent(java.awt.Graphics),
JComponent.paintBorder(java.awt.Graphics),
JComponent.paintChildren(java.awt.Graphics),
JComponent.getComponentGraphics(java.awt.Graphics),
JComponent.repaint(long, int, int, int, int)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


ColorChooserComponentFactory (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.colorchooser
类 ColorChooserComponentFactory

java.lang.Object
    继承者  javax.swing.colorchooser.ColorChooserComponentFactory

public class ColorChooserComponentFactory
extends Object

旨在生成要插入到颜色选取器中的预先配置的“访问器”对象的类。

警告：此类已序列化的对象将不再与以后的 Swing 版本兼容。当前的序列化支持适合于在运行相同 Swing 版本的应用程序之间短期存储或 RMI。从 1.4 版本开始，已在 java.beans 包中加入对所有 JavaBeansTM 的长期存储支持。请参见 XMLEncoder。

方法摘要
static AbstractColorChooserPanel[] | getDefaultChooserPanels()
static JComponent | getPreviewPanel()
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

方法详细信息

getDefaultChooserPanels

public static AbstractColorChooserPanel[] getDefaultChooserPanels()

getPreviewPanel

public static JComponent getPreviewPanel()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ColorSelectionModel (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.colorchooser
接口 ColorSelectionModel

所有已知实现类：
DefaultColorSelectionModel
public interface ColorSelectionModel

支持选取 Color 的模型。

另请参见：
Color

方法摘要
void | addChangeListener(ChangeListener listener) 在模型中添加作为更改侦听器的 listener。
Color | getSelectedColor() 返回所选取的 Color，它不应为 null。
void | removeChangeListener(ChangeListener listener) 从模型中移除作为更改侦听器的 listener。
void | setSelectedColor(Color color) 将选取的颜色设置为 color。

方法详细信息

getSelectedColor

Color getSelectedColor()
返回所选取的 Color，它不应为 null。

返回：
所选取的 Color
另请参见：
setSelectedColor(java.awt.Color)

setSelectedColor

void setSelectedColor(Color color)
将选取的颜色设置为 color。注意，将颜色设置为 null 是不确定的，这样做可能会带来不可预知的后果。如果此方法将当前颜色设置为一个新的非 null 颜色，它将激发状态更改事件。

参数：
color - 新的 Color
另请参见：
getSelectedColor(), addChangeListener(javax.swing.event.ChangeListener)

addChangeListener

void addChangeListener(ChangeListener listener)
在模型中添加作为更改侦听器的 listener。

参数：
listener - 要添加的 ChangeListener

removeChangeListener

void removeChangeListener(ChangeListener listener)
从模型中移除作为更改侦听器的 listener。

参数：
listener - 要移除的 ChangeListener
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DefaultColorSelectionModel (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.colorchooser
类 DefaultColorSelectionModel

java.lang.Object
    继承者  javax.swing.colorchooser.DefaultColorSelectionModel
所有已实现的接口：
Serializable, ColorSelectionModel
public class DefaultColorSelectionModel
extends Object
implements ColorSelectionModel, Serializable

ColorSelectionModel 的一般实现。

另请参见：
Color

字段摘要
protected ChangeEvent | changeEvent 由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。
protected EventListenerList | listenerList
构造方法摘要
DefaultColorSelectionModel()
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 Color.white。
DefaultColorSelectionModel(Color color)
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 color，该颜色不应为 null。
方法摘要
void | addChangeListener(ChangeListener l) 将一个 ChangeListener 添加到模型中。
protected void | fireStateChanged() 运行每个 ChangeListener 的 stateChanged 方法。
ChangeListener[] | getChangeListeners() 返回一个使用 addChangeListener 添加到此 DefaultColorSelectionModel 中的所有 ChangeListener 的数组。
Color | getSelectedColor() 返回所选取的 Color，它不应为 null。
void | removeChangeListener(ChangeListener l) 从模型中移除一个 ChangeListener。
void | setSelectedColor(Color color) 将选取的颜色设置为 color。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

字段详细信息

changeEvent

protected transient ChangeEvent changeEvent
由于事件的惟一状态（只读）为源属性，所以每个模型实例只需要一个 ChangeEvent。这里生成的事件源总是“this”。

listenerList

protected EventListenerList listenerList
构造方法详细信息

DefaultColorSelectionModel

public DefaultColorSelectionModel()
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 Color.white。这是默认的构造方法。

DefaultColorSelectionModel

public DefaultColorSelectionModel(Color color)
创建一个 DefaultColorSelectionModel，其当前颜色被设置为 color，该颜色不应为 null。注意，将颜色设置为 null 是不确定的，这样做可能会带来不可预知的后果。

参数：
color - 新的 Color
方法详细信息

getSelectedColor

public Color getSelectedColor()
返回所选取的 Color，它不应为 null。

指定者：
接口 ColorSelectionModel 中的 getSelectedColor
返回：
选取的 Color
另请参见：
ColorSelectionModel.setSelectedColor(java.awt.Color)

setSelectedColor

public void setSelectedColor(Color color)
将选取的颜色设置为 color。注意，将颜色设置为 null 是不确定的，这样做可能会带来不可预知的后果。如果此方法将当前颜色设置为一个新的非 null 颜色，则它会激发状态更改事件；如果新颜色与当前颜色相同，则不会激发任何事件。

指定者：
接口 ColorSelectionModel 中的 setSelectedColor
参数：
color - 新的 Color
另请参见：
ColorSelectionModel.getSelectedColor(), ColorSelectionModel.addChangeListener(javax.swing.event.ChangeListener)

addChangeListener

public void addChangeListener(ChangeListener l)
将一个 ChangeListener 添加到模型中。

指定者：
接口 ColorSelectionModel 中的 addChangeListener
参数：
l - 要添加的 ChangeListener

removeChangeListener

public void removeChangeListener(ChangeListener l)
从模型中移除一个 ChangeListener。

指定者：
接口 ColorSelectionModel 中的 removeChangeListener
参数：
l - 要移除的 ChangeListener

getChangeListeners

public ChangeListener[] getChangeListeners()
返回一个使用 addChangeListener 添加到此 DefaultColorSelectionModel 中的所有 ChangeListener 的数组。

返回：
已添加的所有 ChangeListener，如果未添加任何侦听器，则返回一个空数组
从以下版本开始：
1.4

fireStateChanged

protected void fireStateChanged()
运行每个 ChangeListener 的 stateChanged 方法。

另请参见：
EventListenerList
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.colorchooser (Java 2 Platform SE 6)

 javax.swing.colorchooser
接口
ColorSelectionModel
类
AbstractColorChooserPanel
ColorChooserComponentFactory
DefaultColorSelectionModel


javax.swing.colorchooser (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.colorchooser

包含供 JColorChooser 组件使用的类和接口。

请参见：
描述

接口摘要
ColorSelectionModel 支持选取 Color 的模型。

类摘要
AbstractColorChooserPanel | 这是用于颜色选取器的抽象超类。
ColorChooserComponentFactory | 旨在生成要插入到颜色选取器中的预先配置的“访问器”对象的类。
DefaultColorSelectionModel | ColorSelectionModel 的一般实现。

软件包 javax.swing.colorchooser 的描述

包含供 JColorChooser 组件使用的类和接口。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

相关文档

本文档构成了完整的 API 规范。有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • The Java Tutorial 中的 How to Use Color Choosers 一节。
  • Internationalization Documentation
  • Input Method Framework Documentation

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.colorchooser 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.colorchooser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.colorchooser.ColorChooserComponentFactory
    • java.awt.Component (implements java.awt.image.ImageObserver, java.awt.MenuContainer, java.io.Serializable)
      • java.awt.Container
        • javax.swing.JComponent (implements java.io.Serializable)
          • javax.swing.JPanel (implements javax.accessibility.Accessible)
            • javax.swing.colorchooser.AbstractColorChooserPanel
    • javax.swing.colorchooser.DefaultColorSelectionModel (implements javax.swing.colorchooser.ColorSelectionModel, java.io.Serializable)

接口分层结构

  • javax.swing.colorchooser.ColorSelectionModel
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.swing.colorchooser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.colorchooser
的使用

使用 javax.swing.colorchooser 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 使用的 javax.swing.colorchooser 中的类
AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。
ColorSelectionModel
支持选取 Color 的模型。

javax.swing.colorchooser 使用的 javax.swing.colorchooser 中的类
AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。
ColorSelectionModel
支持选取 Color 的模型。

javax.swing.plaf.basic 使用的 javax.swing.colorchooser 中的类
AbstractColorChooserPanel
这是用于颜色选取器的抽象超类。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.colorchooser.AbstractColorChooserPanel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.colorchooser.AbstractColorChooserPanel
的使用

使用 AbstractColorChooserPanel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 AbstractColorChooserPanel 的使用

返回 AbstractColorChooserPanel 的 javax.swing 中的方法
AbstractColorChooserPanel[] | JColorChooser.getChooserPanels() 返回指定的颜色面板。
AbstractColorChooserPanel | JColorChooser.removeChooserPanel(AbstractColorChooserPanel panel) 移除指定的 Color Panel。

参数类型为 AbstractColorChooserPanel 的 javax.swing 中的方法
void | JColorChooser.addChooserPanel(AbstractColorChooserPanel panel) 将颜色选取器面板添加到颜色选取器。
AbstractColorChooserPanel | JColorChooser.removeChooserPanel(AbstractColorChooserPanel panel) 移除指定的 Color Panel。
void | JColorChooser.setChooserPanels(AbstractColorChooserPanel[] panels) 指定用于选取颜色值的 Color Panel。

javax.swing.colorchooser 中 AbstractColorChooserPanel 的使用

返回 AbstractColorChooserPanel 的 javax.swing.colorchooser 中的方法
static AbstractColorChooserPanel[] ColorChooserComponentFactory.getDefaultChooserPanels()

javax.swing.plaf.basic 中 AbstractColorChooserPanel 的使用

声明为 AbstractColorChooserPanel 的 javax.swing.plaf.basic 中的字段
protected  AbstractColorChooserPanel[] BasicColorChooserUI.defaultChoosers

返回 AbstractColorChooserPanel 的 javax.swing.plaf.basic 中的方法
protected  AbstractColorChooserPanel[] BasicColorChooserUI.createDefaultChoosers()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.colorchooser.ColorChooserComponentFactory 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.colorchooser.ColorChooserComponentFactory
的使用

没有 javax.swing.colorchooser.ColorChooserComponentFactory 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.swing.colorchooser.ColorSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.colorchooser.ColorSelectionModel
的使用

使用 ColorSelectionModel 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。

javax.swing 中 ColorSelectionModel 的使用

返回 ColorSelectionModel 的 javax.swing 中的方法
 ColorSelectionModel JColorChooser.getSelectionModel()
返回处理颜色选择的数据模型。

参数类型为 ColorSelectionModel 的 javax.swing 中的方法
 void JColorChooser.setSelectionModel(ColorSelectionModel newModel)
设置包含所选颜色的模型。

参数类型为 ColorSelectionModel 的 javax.swing 中的构造方法
JColorChooser(ColorSelectionModel model)
创建具有指定 ColorSelectionModel 颜色选取器窗格。

javax.swing.colorchooser 中 ColorSelectionModel 的使用

实现 ColorSelectionModel 的 javax.swing.colorchooser 中的类
 class DefaultColorSelectionModel
ColorSelectionModel 的一般实现。

返回 ColorSelectionModel 的 javax.swing.colorchooser 中的方法
 ColorSelectionModel AbstractColorChooserPanel.getColorSelectionModel()
返回选取器面板正在编辑的模型。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.colorchooser.DefaultColorSelectionModel 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.colorchooser.DefaultColorSelectionModel
的使用

没有 javax.swing.colorchooser.DefaultColorSelectionModel 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


FileFilter (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.filechooser
类 FileFilter

java.lang.Object
    继承者  javax.swing.filechooser.FileFilter
直接已知子类：
BasicFileChooserUI.AcceptAllFileFilter, FileNameExtensionFilter
public abstract class FileFilter
extends Object

FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。有关使用文件扩展名进行过滤的实现，请参阅 FileNameExtensionFilter。

FileFilter 可以设置在 JFileChooser 上，以阻止不需要的文件出现在目录清单中。有关简单文件过滤器的示例实现，请参阅 yourJDK/demo/jfc/FileChooserDemo/ExampleFileFilter.java。有关更多的信息和示例，请参阅 The Java Tutorial 中的 How to Use Borders 一节。

另请参见：
FileNameExtensionFilter, JFileChooser.setFileFilter(javax.swing.filechooser.FileFilter), JFileChooser.addChoosableFileFilter(javax.swing.filechooser.FileFilter)

构造方法摘要
FileFilter()
方法摘要
abstract boolean | accept(File f) 此过滤器是否接受给定的文件。
abstract String | getDescription() 此过滤器的描述。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileFilter

public FileFilter()
方法详细信息

accept

public abstract boolean accept(File f)
此过滤器是否接受给定的文件。

getDescription

public abstract String getDescription()
此过滤器的描述。例如："JPG and GIF Images"

另请参见：
FileView.getName(java.io.File)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


FileNameExtensionFilter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.filechooser
类 FileNameExtensionFilter

java.lang.Object
    继承者  javax.swing.filechooser.FileFilter
        继承者  javax.swing.filechooser.FileNameExtensionFilter

public final class FileNameExtensionFilter
extends FileFilter

FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。文件的扩展名是指文件名最后一个“.”后面的部分。名称不包含“.”的文件没有文件扩展名。文件扩展名的比较不区分大小写。

下例创建了一个 FileNameExtensionFilter，它将显示 jpg 文件：

FileFilter filter = new FileNameExtensionFilter("JPEG file", "jpg", "jpeg");
JFileChooser fileChooser = ...;
fileChooser.addChoosableFileFilter(filter);

从以下版本开始：
1.6
另请参见：
FileFilter,
JFileChooser.setFileFilter(javax.swing.filechooser.FileFilter),
JFileChooser.addChoosableFileFilter(javax.swing.filechooser.FileFilter),
JFileChooser.getFileFilter()

构造方法摘要
FileNameExtensionFilter(String description, String... extensions)
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。
方法摘要
boolean | accept(File f) 测试指定的文件，如果该文件被接受，则返回 true，否则返回 false。
String | getDescription() 此过滤器的描述。
String[] | getExtensions() 返回要测试文件的文件扩展名集合。
String | toString() 返回 FileNameExtensionFilter 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

FileNameExtensionFilter

public FileNameExtensionFilter(String description,
                               String... extensions)
使用指定的描述和文件扩展名创建一个 FileNameExtensionFilter。返回的 FileNameExtensionFilter 将接受所有的目录和所有带有 extensions 中所包含的文件扩展名的文件。

参数：
description - 过滤器的文本描述，可以为 null
extensions - 接受的文件扩展名
抛出：
IllegalArgumentException - 如果 extensions 为 null、为空、包含 null 或者包含空字符串
另请参见：
accept(java.io.File)
方法详细信息

accept

public boolean accept(File f)
测试指定的文件，如果该文件被接受，则返回 true，否则返回 false。如果扩展名与此 FileFilter 中的一个文件扩展名匹配，或者该文件是一个目录，则返回 true。

指定者：
类 FileFilter 中的 accept
参数：
f - 要测试的 File
返回：
如果文件将被接受，则返回 true；否则返回false。

getDescription

public String getDescription()
此过滤器的描述。例如："JPG and GIF Images."

指定者：
类 FileFilter 中的 getDescription
返回：
此过滤器的描述
另请参见：
FileView.getName(java.io.File)

getExtensions

public String[] getExtensions()
返回要测试文件的文件扩展名集合。

返回：
要测试文件的文件扩展名集合

toString

public String toString()
返回 FileNameExtensionFilter 的字符串表示形式。此方法仅用于调试，对于各个实现，所返回字符串的内容和格式可能有所不同。

覆盖：
类 Object 中的 toString
返回：
此 FileNameExtensionFilter 的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileSystemView (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.filechooser
类 FileSystemView

java.lang.Object
    继承者  javax.swing.filechooser.FileSystemView

public abstract class FileSystemView
extends Object

FileSystemView 是 JFileChooser 的文件系统网关。由于 JDK1.1 File API 不允许对诸如根分区、文件类型信息或隐藏文件位之类的信息进行访问，此类被设计成能够直接获得尽可能多的特定于 OS 的文件系统信息。

Java Licensees 可能想要提供 FileSystemView 的不同实现来更好地处理给定操作系统。

构造方法摘要
FileSystemView()
方法摘要
File | createFileObject(File dir, String filename) 返回根据给定的 filename 在 dir 中构造的 File 对象。
File | createFileObject(String path) 返回根据给定路径字符串构造的 File 对象。
protected File | createFileSystemRoot(File f) 创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。
abstract File | createNewFolder(File containingDir) 创建具有默认文件夹名称的新文件夹。
File | getChild(File parent, String fileName)
File | getDefaultDirectory() 返回文件选择器的用户默认起始目录。
File[] | getFiles(File dir, boolean useFileHiding) 获取显示的（即未隐藏）文件的列表。
static FileSystemView | getFileSystemView()
File | getHomeDirectory()
File | getParentDirectory(File dir) 返回 dir 的父目录。
File[] | getRoots() 返回此系统的所有根分区。
String | getSystemDisplayName(File f) 在系统文件浏览器中显示的文件、目录或文件夹名。
Icon | getSystemIcon(File f) 在系统文件浏览器中显示的文件、目录或文件夹的图标。
String | getSystemTypeDescription(File f) 在系统文件浏览器中显示的文件、目录或文件夹类型描述。
boolean | isComputerNode(File dir) UI 类使用此方法来决定是否为计算机节点显示特殊图标，例如，“我的电脑”或网络服务器。
boolean | isDrive(File dir) UI 类使用此方法来决定是否为驱动器或分区显示特殊图标，例如，“硬盘”图标。
boolean | isFileSystem(File f) 检查 f 是否表示一个相对于特殊文件夹（如 "Desktop"）的实际目录或文件。
boolean | isFileSystemRoot(File dir) 判断 dir 是否是文件系统（如驱动器或分区）中的树的根。
boolean | isFloppyDrive(File dir) UI 类使用此方法来决定是否为软盘显示特殊图标。
boolean | isHiddenFile(File f) 返回某个文件是否被隐藏。
boolean | isParent(File folder, File file) 在 Windows 中，一个文件可以出现在多个文件夹，但在文件系统中的父目录中除外。
boolean | isRoot(File f) 确定给定文件是否是导航树中的根。
Boolean | isTraversable(File f) 如果可以访问文件（目录），则返回 true。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileSystemView

public FileSystemView()
方法详细信息

getFileSystemView

public static FileSystemView getFileSystemView()

isRoot

public boolean isRoot(File f)
确定给定文件是否是导航树中的根。示例：Windows 98 有一个根，即 Desktop 文件夹。DOS 中的每个驱动器名都有一个根：C:\、D:\ 等等。Unix 有一个根，即 "/" 目录。 默认实现从 ShellFolder 类中获取信息。

参数：
f - 表示目录的 File 对象
返回：
如果 f 是导航树中的根，则返回 true。
另请参见：
isFileSystemRoot(java.io.File)

isTraversable

public Boolean isTraversable(File f)
如果可以访问文件（目录），则返回 true。如果无法遍历目录，则返回 false。

参数：
f - File
返回：
如果可以遍历文件/目录，则返回 true，否则返回 false
从以下版本开始：
1.4
另请参见：
JFileChooser.isTraversable(java.io.File), FileView.isTraversable(java.io.File)

getSystemDisplayName

public String getSystemDisplayName(File f)
在系统文件浏览器中显示的文件、目录或文件夹名。以 Windows 为例："M:\" 目录显示为 "CD-ROM (M:)"。 默认实现从 ShellFolder 类获取信息。

参数：
f - File 对象
返回：
本机文件选择器显示的文件名
从以下版本开始：
1.4
另请参见：
JFileChooser.getName(java.io.File)

getSystemTypeDescription

public String getSystemTypeDescription(File f)
在系统文件浏览器中显示的文件、目录或文件夹类型描述。以 Windows 为例："Desktop" 文件夹被描述为 "Desktop"。 为本机 ShellFolder 实现中的平台重写此方法。

参数：
f - File 对象
返回：
本机文件选择器显示的文件类型描述；如果没有可用的本机信息，则返回 null。
从以下版本开始：
1.4
另请参见：
JFileChooser.getTypeDescription(java.io.File)

getSystemIcon

public Icon getSystemIcon(File f)
在系统文件浏览器中显示的文件、目录或文件夹的图标。以 Windows 为例："M:\" 目录显示 CD-ROM 图标。 默认实现从 ShellFolder 类获取信息。

参数：
f - File 对象
返回：
本机文件选择器显示的图标
从以下版本开始：
1.4
另请参见：
JFileChooser.getIcon(java.io.File)

isParent

public boolean isParent(File folder,
                        File file)
在 Windows 中，一个文件可以出现在多个文件夹，但在文件系统中的父目录中除外。例如，该文件夹可以是不同于 file.getParentFile() 的 "Desktop" 文件夹。

参数：
folder - 表示一个目录或特殊文件夹的 File 对象
file - File 对象
返回：
如果 folder 是一个目录或特殊文件夹，并且包括 file，则返回 true。
从以下版本开始：
1.4

getChild

public File getChild(File parent,
                     String fileName)
参数：
parent - 表示一个目录或特殊文件夹的 File 对象
fileName - 存在于 parent 中的文件或文件夹的名称
返回：
File 对象。它通常使用 new File(parent, fileName) 构造，父级和子级都是特殊文件夹时除外，在这种情况下，File 是包含 ShellFolder 对象的包装器。
从以下版本开始：
1.4

isFileSystem

public boolean isFileSystem(File f)
检查 f 是否表示一个相对于特殊文件夹（如 "Desktop"）的实际目录或文件。UI 类使用此方法来决定在选择目录时某个文件夹是否可选择。

参数：
f - File 对象
返回：
如果 f 是实际文件或目录，则返回 true。
从以下版本开始：
1.4

createNewFolder

public abstract File createNewFolder(File containingDir)
                              throws IOException
创建具有默认文件夹名称的新文件夹。

抛出：
IOException

isHiddenFile

public boolean isHiddenFile(File f)
返回某个文件是否被隐藏。

isFileSystemRoot

public boolean isFileSystemRoot(File dir)
判断 dir 是否是文件系统（如驱动器或分区）中的树的根。示例：在 Windows 98 中，对于 "C:\" 返回 true。

参数：
dir - 表示目录的 File 对象
返回：
如果 f 是文件系统的根，则返回 true
从以下版本开始：
1.4
另请参见：
isRoot(java.io.File)

isDrive

public boolean isDrive(File dir)
UI 类使用此方法来决定是否为驱动器或分区显示特殊图标，例如，“硬盘”图标。 默认实现无法知道，因此总是返回 false。

参数：
dir - 目录
返回：
总是返回 false
从以下版本开始：
1.4

isFloppyDrive

public boolean isFloppyDrive(File dir)
UI 类使用此方法来决定是否为软盘显示特殊图标。隐含了 isDrive(dir)。 默认实现无法知道，因此总是返回 false。

参数：
dir - 目录
返回：
总是返回 false
从以下版本开始：
1.4

isComputerNode

public boolean isComputerNode(File dir)
UI 类使用此方法来决定是否为计算机节点显示特殊图标，例如，“我的电脑”或网络服务器。 默认实现无法知道，因此总是返回 false。

参数：
dir - 目录
返回：
总是返回 false
从以下版本开始：
1.4

getRoots

public File[] getRoots()
返回此系统的所有根分区。例如，在 Windows 中，这将是“桌面”文件夹，而在 DOS 中将是从 A：到 Z：的驱动器。

getHomeDirectory

public File getHomeDirectory()

getDefaultDirectory

public File getDefaultDirectory()
返回文件选择器的用户默认起始目录。

返回：
表示默认起始文件夹的 File 对象
从以下版本开始：
1.4

createFileObject

public File createFileObject(File dir,
                             String filename)
返回根据给定的 filename 在 dir 中构造的 File 对象。

createFileObject

public File createFileObject(String path)
返回根据给定路径字符串构造的 File 对象。

getFiles

public File[] getFiles(File dir,
                       boolean useFileHiding)
获取显示的（即未隐藏）文件的列表。

getParentDirectory

public File getParentDirectory(File dir)
返回 dir 的父目录。

参数：
dir - 要查询的 File
返回：
dir 的父目录；如果 dir 为 null，则返回 null

createFileSystemRoot

protected File createFileSystemRoot(File f)
创建针对 f 的新 File 对象，使其对于文件系统根目录而言具有正确的行为。

参数：
f - 表示文件系统根目录的 File 对象，例如 Unix 上的 "/" 或 Windows 上的 "C:\"。
返回：
新的 File 对象
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


FileView (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.filechooser
类 FileView

java.lang.Object
    继承者  javax.swing.filechooser.FileView
直接已知子类：
BasicFileChooserUI.BasicFileView
public abstract class FileView
extends Object

FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。每个 L&F JFileChooserUI 对象都实现此类来传递回特定于该 L&F 的图标和类型描述。例如，Microsoft Windows L&F 为目录和一般文件返回一般 Window 图标。此外，可以通过使用 JFileChooser.setFileView(javax.swing.filechooser.FileView) 为 JFileChooser 提供自己的 FileView，以返回不同的图标或附加信息。

JFileChooser 首先注意查看是否有用户定义的 FileView，如果有的话，它先根据该 FileView 获取类型信息。如果对于任何方法，FileView 都返回 null，则 JFileChooser 使用特定于 L&F 的视图来获取信息。因此，举例来说，如果提供了 FileView 类，该类对 JPG 文件返回一个 Icon，并对其他所有文件返回 null，则 UI 的 FileView 将对其他所有文件提供默认图标。

有关简单文件视图的示例实现，请参阅 yourJDK/demo/jfc/FileChooserDemo/ExampleFileView.java。有关更多的信息和示例，请参阅 The Java Tutorial 中的 How to Use Choosers 一节。

另请参见：
JFileChooser

构造方法摘要
FileView()
方法摘要
String | getDescription(File f) 文件的可读描述。
Icon | getIcon(File f) 表示 JFileChooser 中此文件的图标。
String | getName(File f) 文件名称。
String | getTypeDescription(File f) 文件类型的可读描述。
Boolean | isTraversable(File f) 目录是否是可遍历的。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

FileView

public FileView()
方法详细信息

getName

public String getName(File f)
文件名称。通常此名称就是 f.getName()。

getDescription

public String getDescription(File f)
文件的可读描述。例如，名为 jag.jpg 的文件可能有这样一个描述："A JPEG image file of James Gosling's face"。

getTypeDescription

public String getTypeDescription(File f)
文件类型的可读描述。例如，jpg 文件可能有这样一个类型描述："A JPEG Compressed Image File"

getIcon

public Icon getIcon(File f)
表示 JFileChooser 中此文件的图标。

isTraversable

public Boolean isTraversable(File f)
目录是否是可遍历的。此方法可能很有用，例如在需要一个目录来表示复合文档并且不希望用户访问其内部的情况下。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.filechooser (Java 2 Platform SE 6)

 javax.swing.filechooser
类
FileFilter
FileNameExtensionFilter
FileSystemView
FileView


javax.swing.filechooser (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.filechooser

包含 JFileChooser 组件使用的类和接口。

请参见：
描述

类摘要
FileFilter | FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileNameExtensionFilter | FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。
FileSystemView | FileSystemView 是 JFileChooser 的文件系统网关。
FileView | FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。

软件包 javax.swing.filechooser 的描述

包含 JFileChooser 组件使用的类和接口。

注：大多数 Swing API 都不是 线程安全的。有关细节，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

相关文档

本文档构成了完整的 API 规范。有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • The Java Tutorial 中的 How to Use File Choosers 一节。
  • Internationalization Documentation
  • Input Method Framework Documentation

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.filechooser 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.filechooser 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.filechooser.FileFilter
      • javax.swing.filechooser.FileNameExtensionFilter
    • javax.swing.filechooser.FileSystemView
    • javax.swing.filechooser.FileView
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.swing.filechooser 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.filechooser
的使用

使用 javax.swing.filechooser 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 使用的 javax.swing.filechooser 中的类
FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileSystemView
FileSystemView 是 JFileChooser 的文件系统网关。
FileView
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。

javax.swing.filechooser 使用的 javax.swing.filechooser 中的类
FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileSystemView
FileSystemView 是 JFileChooser 的文件系统网关。

javax.swing.plaf 使用的 javax.swing.filechooser 中的类
FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileView
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。

javax.swing.plaf.basic 使用的 javax.swing.filechooser 中的类
FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileView
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。

javax.swing.plaf.metal 使用的 javax.swing.filechooser 中的类
FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。

javax.swing.plaf.multi 使用的 javax.swing.filechooser 中的类
FileFilter
FileFilter 是一个抽象类，JFileChooser 使用它过滤显示给用户的文件集合。
FileView
FileView 定义一个抽象类，可以实现该抽象类来为 File 提供带 UI 信息的文件选择器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.filechooser.FileNameExtensionFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileNameExtensionFilter
的使用

没有 javax.swing.filechooser.FileNameExtensionFilter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.filechooser.FileSystemView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileSystemView
的使用

使用 FileSystemView 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。

javax.swing 中 FileSystemView 的使用

返回 FileSystemView 的 javax.swing 中的方法
 FileSystemView JFileChooser.getFileSystemView()
返回文件系统视图。

参数类型为 FileSystemView 的 javax.swing 中的方法
void | JFileChooser.setFileSystemView(FileSystemView fsv) 设置为访问和创建文件系统资源（如查找软驱和获得根驱动器列表），JFileChooser 所使用的文件系统视图。
protected void | JFileChooser.setup(FileSystemView view) 执行公共的构造方法初始化和设置。

参数类型为 FileSystemView 的 javax.swing 中的构造方法
JFileChooser(File currentDirectory, FileSystemView fsv)
使用给定的当前目录和 FileSystemView 构造一个 JFileChooser。
JFileChooser(FileSystemView fsv)
使用给定的 FileSystemView 构造一个 JFileChooser。
JFileChooser(String currentDirectoryPath, FileSystemView fsv)
使用给定的当前目录路径和 FileSystemView 构造一个 JFileChooser。

javax.swing.filechooser 中 FileSystemView 的使用

返回 FileSystemView 的 javax.swing.filechooser 中的方法
static FileSystemView FileSystemView.getFileSystemView()

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.filechooser.FileView 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileView
的使用

使用 FileView 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 FileView 的使用

返回 FileView 的 javax.swing 中的方法
 FileView JFileChooser.getFileView()
返回当前的文件视图。

参数类型为 FileView 的 javax.swing 中的方法
 void JFileChooser.setFileView(FileView fileView)
设置用于检索 UI 信息的文件视图，如表示文件的图标或文件的类型描述。

javax.swing.plaf 中 FileView 的使用

返回 FileView 的 javax.swing.plaf 中的方法
abstract  FileView FileChooserUI.getFileView(JFileChooser fc)

javax.swing.plaf.basic 中 FileView 的使用

javax.swing.plaf.basic 中 FileView 的子类
protected  class BasicFileChooserUI.BasicFileView

返回 FileView 的 javax.swing.plaf.basic 中的方法
 FileView BasicFileChooserUI.getFileView(JFileChooser fc)

javax.swing.plaf.multi 中 FileView 的使用

返回 FileView 的 javax.swing.plaf.multi 中的方法
 FileView MultiFileChooserUI.getFileView(JFileChooser a)
在由此对象处理的每个 UI 上调用 getFileView 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.filechooser.FileFilter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.filechooser.FileFilter
的使用

使用 FileFilter 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.filechooser | 包含 JFileChooser 组件使用的类和接口。
javax.swing.plaf | 提供一个接口和许多抽象类，Swing 用它们来提供自己的可插入外观功能。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.plaf.multi | 提供了组合两个或多个外观的用户界面对象。

javax.swing 中 FileFilter 的使用

返回 FileFilter 的 javax.swing 中的方法
FileFilter | JFileChooser.getAcceptAllFileFilter() 返回 AcceptAll 文件过滤器。
FileFilter[] | JFileChooser.getChoosableFileFilters() 获得用户可选择的文件过滤器列表。
FileFilter | JFileChooser.getFileFilter() 返回当前选择的文件过滤器。

参数类型为 FileFilter 的 javax.swing 中的方法
void | JFileChooser.addChoosableFileFilter(FileFilter filter) 向用户可选择的文件过滤器列表添加一个过滤器。
boolean | JFileChooser.removeChoosableFileFilter(FileFilter f) 从用户可选择的文件过滤器列表中移除一个过滤器。
void | JFileChooser.setFileFilter(FileFilter filter) 设置当前文件过滤器。

javax.swing.filechooser 中 FileFilter 的使用

javax.swing.filechooser 中 FileFilter 的子类
 class FileNameExtensionFilter
FileFilter 的一个实现，它使用指定的扩展名集合进行过滤。

javax.swing.plaf 中 FileFilter 的使用

返回 FileFilter 的 javax.swing.plaf 中的方法
abstract  FileFilter FileChooserUI.getAcceptAllFileFilter(JFileChooser fc)

javax.swing.plaf.basic 中 FileFilter 的使用

javax.swing.plaf.basic 中 FileFilter 的子类
protected  class BasicFileChooserUI.AcceptAllFileFilter

返回 FileFilter 的 javax.swing.plaf.basic 中的方法
 FileFilter BasicFileChooserUI.getAcceptAllFileFilter(JFileChooser fc)
返回默认接受所有文件过滤器

javax.swing.plaf.metal 中 FileFilter 的使用

声明为 FileFilter 的 javax.swing.plaf.metal 中的字段
protected  FileFilter[] MetalFileChooserUI.FilterComboBoxModel.filters

javax.swing.plaf.multi 中 FileFilter 的使用

返回 FileFilter 的 javax.swing.plaf.multi 中的方法
 FileFilter MultiFileChooserUI.getAcceptAllFileFilter(JFileChooser a)
在由此对象处理的每个 UI 上调用 getAcceptAllFileFilter 方法。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


AncestorEvent (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 AncestorEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  javax.swing.event.AncestorEvent
所有已实现的接口：
Serializable
public class AncestorEvent
extends AWTEvent

报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
static int | ANCESTOR_ADDED 某个祖先组件被添加到可见对象的层次结构中（使其可见），并且目前正显示该组件。
static int | ANCESTOR_MOVED 某个祖先组件更改了其屏幕位置。
static int | ANCESTOR_REMOVED 某个祖先组件从可见对象的层次结构中被移除（隐藏它），并且不再显示该组件。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
AncestorEvent(JComponent source, int id, Container ancestor, Container ancestorParent)
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。
方法摘要
Container | getAncestor() 返回实际发生事件的祖先组件。
Container | getAncestorParent() 返回实际发生事件的祖先组件的父组件。
JComponent | getComponent() 返回添加了侦听器的组件。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, paramString, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ANCESTOR_ADDED

public static final int ANCESTOR_ADDED
某个祖先组件被添加到可见对象的层次结构中（使其可见），并且目前正显示该组件。

另请参见：
常量字段值

ANCESTOR_REMOVED

public static final int ANCESTOR_REMOVED
某个祖先组件从可见对象的层次结构中被移除（隐藏它），并且不再显示该组件。

另请参见：
常量字段值

ANCESTOR_MOVED

public static final int ANCESTOR_MOVED
某个祖先组件更改了其屏幕位置。

另请参见：
常量字段值
构造方法详细信息

AncestorEvent

public AncestorEvent(JComponent source,
                     int id,
                     Container ancestor,
                     Container ancestorParent)
构造一个 AncestorEvent 对象，以标识祖先组件显示状态的更改。

参数：
source - 发起事件的 JComponent（通常为 this）
id - 指定 ANCESTOR_ADDED、ANCESTOR_REMOVED 或 ANCESTOR_MOVED 的 int 值
ancestor - 指定显示状态已发生更改的祖先容器的 Container 对象
ancestorParent - 指定祖先容器的父容器的 Container 对象
方法详细信息

getAncestor

public Container getAncestor()
返回实际发生事件的祖先组件。

getAncestorParent

public Container getAncestorParent()
返回实际发生事件的祖先组件的父组件。此方法在 ANCESTOR_REMOVED 事件中最为有趣，因为祖先组件可能不再位于组件层次结构中。

getComponent

public JComponent getComponent()
返回添加了侦听器的组件。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


AncestorListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 AncestorListener

所有超级接口：
EventListener
public interface AncestorListener
extends EventListener

AncestorListener 接口支持 JComponent 或其祖先之一发生更改时进行通知。 这些更改包括移动和组件变得可见或不可见时（通过 setVisible() 方法，或者将组件添加到组件层次结构中或从中移除）。

方法摘要
void | ancestorAdded(AncestorEvent event) 当通过调用 setVisible(true) 或将其添加到组件层次结构中而使源组件或其祖先之一变得可见时调用。
void | ancestorMoved(AncestorEvent event) 在源组件或其祖先之一被移动时调用。
void | ancestorRemoved(AncestorEvent event) 当通过调用 setVisible(false) 或将其从组件层次结构中移除而使源组件或其祖先之一变得不可见时调用。

方法详细信息

ancestorAdded

void ancestorAdded(AncestorEvent event)
当通过调用 setVisible(true) 或将其添加到组件层次结构中而使源组件或其祖先之一变得可见时调用。此方法只在源组件变得实际可见时调用。要源组件实际可见，其所有父组件都必须是可见的，并且它必须在以某个窗口为根的层次结构中。

ancestorRemoved

void ancestorRemoved(AncestorEvent event)
当通过调用 setVisible(false) 或将其从组件层次结构中移除而使源组件或其祖先之一变得不可见时调用。此方法只在源组件变得实际不可见时调用。要源组件实际不可见，至少有一个父组件必须是不可见的，或者它不在以某个窗口为根的层次结构中。

ancestorMoved

void ancestorMoved(AncestorEvent event)
在源组件或其祖先之一被移动时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CaretEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 CaretEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.CaretEvent
所有已实现的接口：
Serializable
public abstract class CaretEvent
extends EventObject

CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
CaretEvent(Object source)
创建一个新的 CaretEvent 对象。
方法摘要
abstract int | getDot() 获得插入符的位置。
abstract int | getMark() 获得逻辑选择的另一端的位置。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

CaretEvent

public CaretEvent(Object source)
创建一个新的 CaretEvent 对象。

参数：
source - 对事件负责的对象
方法详细信息

getDot

public abstract int getDot()
获得插入符的位置。

返回：
大于或等于 0 的点

getMark

public abstract int getMark()
获得逻辑选择的另一端的位置。如果没有进行选择，则此位置将与 dot 相同。

返回：
大于或等于 0 的标记
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CaretListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 CaretListener

所有超级接口：
EventListener
所有已知实现类：
JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JPasswordField.AccessibleJPasswordField, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField
public interface CaretListener
extends EventListener

用于侦听文本组件插入符的位置更改的侦听器。

方法摘要
 void caretUpdate(CaretEvent e)
当插入符的位置被更新时调用。

方法详细信息

caretUpdate

void caretUpdate(CaretEvent e)
当插入符的位置被更新时调用。

参数：
e - 插入符事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


CellEditorListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 CellEditorListener

所有超级接口：
EventListener
所有已知实现类：
BasicTreeUI.CellEditorHandler, JTable, JTable.AccessibleJTable
public interface CellEditorListener
extends EventListener

CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口

方法摘要
void | editingCanceled(ChangeEvent e) 此方法告知侦听器编辑器已经取消编辑
void | editingStopped(ChangeEvent e) 此方法告知侦听器编辑器已经结束编辑

方法详细信息

editingStopped

void editingStopped(ChangeEvent e)
此方法告知侦听器编辑器已经结束编辑

editingCanceled

void editingCanceled(ChangeEvent e)
此方法告知侦听器编辑器已经取消编辑

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChangeEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 ChangeEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.ChangeEvent
所有已实现的接口：
Serializable
public class ChangeEvent
extends EventObject

ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ChangeEvent(Object source)
构造一个 ChangeEvent 对象。
方法摘要
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ChangeEvent

public ChangeEvent(Object source)
构造一个 ChangeEvent 对象。

参数：
source - 作为事件源的 Object（通常为 this）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ChangeListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 ChangeListener

所有超级接口：
EventListener
所有已知实现类：
AbstractButton.ButtonChangeListener, BasicButtonListener, BasicMenuUI.ChangeHandler, BasicProgressBarUI.ChangeHandler, BasicScrollBarUI.ModelListener, BasicScrollPaneUI.HSBChangeListener, BasicScrollPaneUI.ViewportChangeHandler, BasicScrollPaneUI.VSBChangeListener, BasicSliderUI.ChangeHandler, BasicTabbedPaneUI.TabSelectionHandler, JCheckBoxMenuItem.AccessibleJCheckBoxMenuItem, JMenu.AccessibleJMenu, JMenuItem.AccessibleJMenuItem, JRadioButtonMenuItem.AccessibleJRadioButtonMenuItem, JScrollPane.AccessibleJScrollPane, JSpinner.AccessibleJSpinner, JSpinner.DateEditor, JSpinner.DefaultEditor, JSpinner.ListEditor, JSpinner.NumberEditor, JTabbedPane.AccessibleJTabbedPane, JTabbedPane.ModelListener, ProgressMonitor.AccessibleProgressMonitor
public interface ChangeListener
extends EventListener

定义一个侦听 ChangeEvent 的对象。

方法摘要
 void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。

方法详细信息

stateChanged

void stateChanged(ChangeEvent e)
当侦听器的目标已更改其状态时调用。

参数：
e - ChangeEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 DocumentEvent

所有已知实现类：
AbstractDocument.DefaultDocumentEvent
public interface DocumentEvent

用于文档更改通知的接口。此接口为 Document 观察者提供了有关 Document 更改方式的细节信息。它提供一些高级信息，比如更改类型、在哪儿发生更改，以及更多具体的结构性更改（插入和移除哪些 Element）。

另请参见：
Document, DocumentListener

嵌套类摘要
static interface | DocumentEvent.ElementChange 描述对特定元素所做的更改。
static class | DocumentEvent.EventType 文档事件类型的枚举
方法摘要
DocumentEvent.ElementChange | getChange(Element elem) 获得给定元素的更改信息。
Document | getDocument() 获得发起更改事件的文档。
int | getLength() 返回更改的长度。
int | getOffset() 返回文档中更改开始的偏移量。
DocumentEvent.EventType | getType() 获得事件类型。

方法详细信息

getOffset

int getOffset()
返回文档中更改开始的偏移量。

返回：
偏移量，该偏移量 >= 0

getLength

int getLength()
返回更改的长度。

返回：
长度，该长度 >= 0

getDocument

Document getDocument()
获得发起更改事件的文档。

返回：
文档

getType

DocumentEvent.EventType getType()
获得事件类型。

返回：
类型

getChange

DocumentEvent.ElementChange getChange(Element elem)
获得给定元素的更改信息。更改信息描述了哪些元素被添加和移处，以及添加和移处的位置。如果没有更改，则返回 null。

此方法适用于观察者发现已完成的结构性更改。这意味着只有发生变化之前存在的元素（以及发生变化之后仍然存在的元素）需要有 ElementChange 记录。变得可用的更改不必是递归的。

例如，如果从父元素中移除某个元素，则此方法应该报告该父元素已更改，并提供描述父元素的更改的 ElementChange 实现。如果已移除的子元素有子级，则在移除时不需要报告这些元素。

如果子元素被插入到父元素中，则父元素应该报告此更改。如果子元素中还有一些已插入其中的元素（父元素的孙级），则这些元素无需报告发生的更改。

参数：
elem - 元素
返回：
更改信息，如果元素未被修改，则返回 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentEvent.ElementChange (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 DocumentEvent.ElementChange

所有已知实现类：
AbstractDocument.ElementEdit
正在封闭接口：
DocumentEvent
public static interface DocumentEvent.ElementChange

描述对特定元素所做的更改。

方法摘要
Element[] | getChildrenAdded() 获得添加到给定父元素中的子元素。
Element[] | getChildrenRemoved() 获得从给定父元素中移除的子元素。
Element | getElement() 返回所表示的元素。
int | getIndex() 获得所表示元素中的索引。

方法详细信息

getElement

Element getElement()
返回所表示的元素。此元素是已被更改的元素。

返回：
元素

getIndex

int getIndex()
获得所表示元素中的索引。此索引是子元素被添加和/或移除的位置。

返回：
大于或等于 0 的索引

getChildrenRemoved

Element[] getChildrenRemoved()
获得从给定父元素中移除的子元素。所返回的元素数组是按照元素在文档中的放置顺序存储的，并且必须彼此相邻。

返回：
子元素

getChildrenAdded

Element[] getChildrenAdded()
获得添加到给定父元素中的子元素。所返回的元素数组按元素在文档中的放置顺序，并且必须彼此相邻。

返回：
子元素
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentEvent.EventType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 DocumentEvent.EventType

java.lang.Object
    继承者  javax.swing.event.DocumentEvent.EventType
正在封闭接口：
DocumentEvent
public static final class DocumentEvent.EventType
extends Object

文档事件类型的枚举

字段摘要
static DocumentEvent.EventType | CHANGE 更改类型。
static DocumentEvent.EventType | INSERT 插入类型。
static DocumentEvent.EventType | REMOVE 移除类型。
方法摘要
 String toString()
将类型转换成一个字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

INSERT

public static final DocumentEvent.EventType INSERT
插入类型。

REMOVE

public static final DocumentEvent.EventType REMOVE
移除类型。

CHANGE

public static final DocumentEvent.EventType CHANGE
更改类型。

方法详细信息

toString

public String toString()
将类型转换成一个字符串。

覆盖：
类 Object 中的 toString
返回：
字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


DocumentListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 DocumentListener

所有超级接口：
EventListener
所有已知实现类：
JEditorPane.AccessibleJEditorPane, JEditorPane.AccessibleJEditorPaneHTML, JEditorPane.JEditorPaneAccessibleHypertextSupport, JPasswordField.AccessibleJPasswordField, JTextArea.AccessibleJTextArea, JTextComponent.AccessibleJTextComponent, JTextField.AccessibleJTextField
public interface DocumentListener
extends EventListener

观察者使用该接口注册以接收文本文档的更改通知。

Document 接口的默认实现 (AbstractDocument) 支持异步更改。如果使用此功能（即变化是来自 Swing 事件线程之外的线程），则通过正发生变化的线程通知侦听器。这意味着如果进行异步更新，则此接口的实现必须是线程安全的！

DocumentEvent 通知以 JavaBeans 事件模型为基础。传递给侦听器的传递顺序是没有保证的，并且在对 Document 做进一步的更改之前，必须通知所有侦听器。这意味着 DocumentListener 的实现不能更改事件源（即相关的 Document）。

另请参见：
Document, StyledDocument, DocumentEvent

方法摘要
void | changedUpdate(DocumentEvent e) 给出属性或属性集发生了更改的通知。
void | insertUpdate(DocumentEvent e) 给出对文档执行了插入操作的通知。
void | removeUpdate(DocumentEvent e) 给出移除了一部分文档的通知。

方法详细信息

insertUpdate

void insertUpdate(DocumentEvent e)
给出对文档执行了插入操作的通知。DocumentEvent 给出的范围限制了新的插入区域。

参数：
e - 文档事件

removeUpdate

void removeUpdate(DocumentEvent e)
给出移除了一部分文档的通知。根据最后看见的视图（即更新固定位置之前的视图）来给出范围。

参数：
e - 文档事件

changedUpdate

void changedUpdate(DocumentEvent e)
给出属性或属性集发生了更改的通知。

参数：
e - 文档事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


EventListenerList (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 EventListenerList

java.lang.Object
    继承者  javax.swing.event.EventListenerList
所有已实现的接口：
Serializable
public class EventListenerList
extends Object
implements Serializable

保存 EventListener 列表的类。单个实例可用来保存使用列表的实例的所有侦听器（所有类型）。该类的责任是使用 EventListenerList 提供类型安全的 API（最好遵守 JavaBeans 规范）和方法，这些方法将事件通知方法指派给列表上适当的 Event Listener。 此类的主要优点是，在没有侦听器的情况下，它相对廉价一些，它在单个地方为事件侦听器提供序列化，同时还提供某种程度的 MT 安全（在正确使用时）。 用例：假定正在定义发送 FooEvent 的类，并希望允许该类的用户注册 FooListener 并在发生 FooEvent 时接收通知。则应该将以下代码添加到类定义中：

 EventListenerList listenerList = new EventListenerList();
 FooEvent fooEvent = null;

 public void addFooListener(FooListener l) {
     listenerList.add(FooListener.class, l);
 }

 public void removeFooListener(FooListener l) {
     listenerList.remove(FooListener.class, l);
 }

 // Notify all listeners that have registered interest for
 // notification on this event type.  The event instance
 // is lazily created using the parameters passed into
 // the fire method.

 protected void fireFooXXX() {
     // Guaranteed to return a non-null array
     Object[] listeners = listenerList.getListenerList();
     // Process the listeners last to first, notifying
     // those that are interested in this event
     for (int i = listeners.length-2; i>=0; i-=2) {
         if (listeners[i]==FooListener.class) {
             // Lazily create the event:
             if (fooEvent == null)
                 fooEvent = new FooEvent(this);
             ((FooListener)listeners[i+1]).fooXXX(fooEvent);
         }
     }
 }
应该将 foo 更改为适当的名称，并将 fireFooXxx 也更改为适当的方法名称。FooListener 接口中的每个通知方法都应该有一个 fire 方法。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected  Object[] listenerList
构造方法摘要
EventListenerList()
方法摘要
<T extends EventListener>
void
add(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行添加。
 int getListenerCount()
返回此侦听器列表中侦听器的总数。
 int getListenerCount(Class<?> t)
返回此侦听器列表中所提供类型的侦听器的总数。
 Object[] getListenerList()
将事件侦听器列表以 ListenerType 侦听器对数组的形式传回。
<T extends EventListener>
T[]
getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。
<T extends EventListener>
void
remove(Class<T> t, T l)
将侦听器作为指定类型的侦听器进行移除。
 String toString()
返回此 EventListenerList 的字符串表示形式。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

listenerList

protected transient Object[] listenerList
构造方法详细信息

EventListenerList

public EventListenerList()
方法详细信息

getListenerList

public Object[] getListenerList()
将事件侦听器列表以 ListenerType 侦听器对数组的形式传回。注意，出于性能方面的原因，此实现传回实际数据结构，侦听器数据就内部存储在该结构中！此方法可保证传回的是一个非 null 数组，因此不需要在 fire 方法中进行 null 检验。如果当前没有侦听器，则应返回零长度的 Object 数组。 警告!!!绝对“不”能对包含在此数组中的数据进行修改，如果必须进行这类操作，则应在返回数组的副本而非数组本身上进行操作。

getListeners

public <T extends EventListener> T[] getListeners(Class<T> t)
返回给定类型的所有侦听器组成的数组。

返回：
指定类型的所有侦听器。
抛出：
ClassCastException - 如果所提供的类不能分配给 EventListener
从以下版本开始：
1.3

getListenerCount

public int getListenerCount()
返回此侦听器列表中侦听器的总数。

getListenerCount

public int getListenerCount(Class<?> t)
返回此侦听器列表中所提供类型的侦听器的总数。

add

public <T extends EventListener> void add(Class<T> t,
                                          T l)
将侦听器作为指定类型的侦听器进行添加。

参数：
t - 要添加的侦听器的类型
l - 要添加的侦听器

remove

public <T extends EventListener> void remove(Class<T> t,
                                             T l)
将侦听器作为指定类型的侦听器进行移除。

参数：
t - 要移除的侦听器的类型
l - 要移除的侦听器

toString

public String toString()
返回此 EventListenerList 的字符串表示形式。

覆盖：
类 Object 中的 toString
返回：
该对象的字符串表示形式。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HyperlinkEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 HyperlinkEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.HyperlinkEvent
所有已实现的接口：
Serializable
直接已知子类：
HTMLFrameHyperlinkEvent
public class HyperlinkEvent
extends EventObject

HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

嵌套类摘要
static class HyperlinkEvent.EventType
定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。
字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。
方法摘要
String | getDescription() 获得链接描述的字符串表示形式。
HyperlinkEvent.EventType | getEventType() 获得事件类型。
Element | getSourceElement() 返回对应于事件源的 Element。
URL | getURL() 获得链接引用的 URL。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

HyperlinkEvent

public HyperlinkEvent(Object source,
                      HyperlinkEvent.EventType type,
                      URL u)
创建一个表示超文本链接事件的新对象。另一个构造方法是首选，因为如果无法形成 URL，则该构造方法可以提供更多的信息。此构造方法主要用于后向兼容。

参数：
source - 对事件负责的对象
type - 事件类型
u - 受影响的 URL

HyperlinkEvent

public HyperlinkEvent(Object source,
                      HyperlinkEvent.EventType type,
                      URL u,
                      String desc)
创建一个表示超文本链接事件的新对象。

参数：
source - 对事件负责的对象
type - 事件类型
u - 受影响的 URL。如果无法创建有效的 URL，则该参数为 null。
desc - 链接的描述。在试图形成一个 URL 却导致 MalformedURLException 时，此描述可能很有用。此描述提供试图形成 URL 时使用的文本。

HyperlinkEvent

public HyperlinkEvent(Object source,
                      HyperlinkEvent.EventType type,
                      URL u,
                      String desc,
                      Element sourceElement)
创建一个表示超文本链接事件的新对象。

参数：
source - 对事件负责的对象
type - 事件类型
u - 受影响的 URL。如果无法创建有效的 URL，则该参数为 null。
desc - 链接的描述。在试图构造一个 URL 却导致 MalformedURLException 时，此描述可能很有用。此描述提供试图形成 URL 时使用的文本。
sourceElement - 表示锚的 Document 中的 Element
从以下版本开始：
1.4
方法详细信息

getEventType

public HyperlinkEvent.EventType getEventType()
获得事件类型。

返回：
类型

getDescription

public String getDescription()
获得链接描述的字符串表示形式。如果无法根据描述形成 URL，则此方法很有用，在无法根据描述形成 URL 的情况下，相关 URL 将为 null。

getURL

public URL getURL()
获得链接引用的 URL。

返回：
URL

getSourceElement

public Element getSourceElement()
返回对应于事件源的 Element。此元素通常是表示某个锚的一个 Element。如果所使用的构造方法没有指定源 Element，或者将 null 指定为源 Element，则此方法将返回 null。

返回：
指示事件源的 Element，或者返回 null
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HyperlinkEvent.EventType (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 HyperlinkEvent.EventType

java.lang.Object
    继承者  javax.swing.event.HyperlinkEvent.EventType
正在封闭类：
HyperlinkEvent
public static final class HyperlinkEvent.EventType
extends Object

定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。

字段摘要
static HyperlinkEvent.EventType | ACTIVATED 激活类型。
static HyperlinkEvent.EventType | ENTERED 进入类型。
static HyperlinkEvent.EventType | EXITED 退出类型。
方法摘要
 String toString()
将类型转换成一个字符串。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

ENTERED

public static final HyperlinkEvent.EventType ENTERED
进入类型。

EXITED

public static final HyperlinkEvent.EventType EXITED
退出类型。

ACTIVATED

public static final HyperlinkEvent.EventType ACTIVATED
激活类型。

方法详细信息

toString

public String toString()
将类型转换成一个字符串。

覆盖：
类 Object 中的 toString
返回：
字符串
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


HyperlinkListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 HyperlinkListener

所有超级接口：
EventListener
public interface HyperlinkListener
extends EventListener

HyperlinkListener

方法摘要
 void hyperlinkUpdate(HyperlinkEvent e)
在更新超文本链接时调用。

方法详细信息

hyperlinkUpdate

void hyperlinkUpdate(HyperlinkEvent e)
在更新超文本链接时调用。

参数：
e - 负责更新的事件
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InternalFrameAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 InternalFrameAdapter

java.lang.Object
    继承者  javax.swing.event.InternalFrameAdapter
所有已实现的接口：
EventListener, InternalFrameListener
public abstract class InternalFrameAdapter
extends Object
implements InternalFrameListener

用于接收内部窗体事件的抽象适配器类。此类中的方法为空。此类的存在只是为了便于创建侦听器对象，它在功能上等同于 AWT 中的 WindowAdapter 类。

请参阅 The Java Tutorial 中的 How to Write an Internal Frame Listener 一节以及 The Java Class Libraries (update)。

另请参见：
InternalFrameEvent, InternalFrameListener, WindowListener

构造方法摘要
InternalFrameAdapter()
方法摘要
void | internalFrameActivated(InternalFrameEvent e) 当内部窗体被激活时调用。
void | internalFrameClosed(InternalFrameEvent e) 当内部窗体已关闭时调用。
void | internalFrameClosing(InternalFrameEvent e) 当内部窗体正被关闭时调用。
void | internalFrameDeactivated(InternalFrameEvent e) 当内部窗体被取消激活时调用。
void | internalFrameDeiconified(InternalFrameEvent e) 当内部窗体被取消图标化时调用。
void | internalFrameIconified(InternalFrameEvent e) 当内部窗体被图标化时调用。
void | internalFrameOpened(InternalFrameEvent e) 当内部窗体已打开时调用。
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

InternalFrameAdapter

public InternalFrameAdapter()
方法详细信息

internalFrameOpened

public void internalFrameOpened(InternalFrameEvent e)
当内部窗体已打开时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameOpened
另请参见：
JInternalFrame.show()

internalFrameClosing

public void internalFrameClosing(InternalFrameEvent e)
当内部窗体正被关闭时调用。此时可重写关闭操作。

指定者：
接口 InternalFrameListener 中的 internalFrameClosing
另请参见：
JInternalFrame.setDefaultCloseOperation(int)

internalFrameClosed

public void internalFrameClosed(InternalFrameEvent e)
当内部窗体已关闭时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameClosed
另请参见：
JInternalFrame.setClosed(boolean)

internalFrameIconified

public void internalFrameIconified(InternalFrameEvent e)
当内部窗体被图标化时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameIconified
另请参见：
JInternalFrame.setIcon(boolean)

internalFrameDeiconified

public void internalFrameDeiconified(InternalFrameEvent e)
当内部窗体被取消图标化时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameDeiconified
另请参见：
JInternalFrame.setIcon(boolean)

internalFrameActivated

public void internalFrameActivated(InternalFrameEvent e)
当内部窗体被激活时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameActivated
另请参见：
JInternalFrame.setSelected(boolean)

internalFrameDeactivated

public void internalFrameDeactivated(InternalFrameEvent e)
当内部窗体被取消激活时调用。

指定者：
接口 InternalFrameListener 中的 internalFrameDeactivated
另请参见：
JInternalFrame.setSelected(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InternalFrameEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 InternalFrameEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  javax.swing.event.InternalFrameEvent
所有已实现的接口：
Serializable
public class InternalFrameEvent
extends AWTEvent

以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。此类的事件类型与 WindowEvent 相同，尽管它们使用不同的 ID。有关处理内部窗体事件的帮助，请参阅 The Java Tutorial 中的 How to Write an Internal Frame Listener 一节。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
WindowEvent, WindowListener, JInternalFrame, InternalFrameListener

字段摘要
static int | INTERNAL_FRAME_ACTIVATED “窗口激活”事件类型。
static int | INTERNAL_FRAME_CLOSED “窗口关闭”事件。
static int | INTERNAL_FRAME_CLOSING “窗口正在关闭”事件。
static int | INTERNAL_FRAME_DEACTIVATED “窗口取消激活”事件类型。
static int | INTERNAL_FRAME_DEICONIFIED “窗口取消图标化”事件类型。
static int | INTERNAL_FRAME_FIRST 用于内部窗体事件的 ID 范围的起始编号。
static int | INTERNAL_FRAME_ICONIFIED “窗口图标化”事件。
static int | INTERNAL_FRAME_LAST 用于内部窗体事件的 ID 范围的结束编号。
static int | INTERNAL_FRAME_OPENED “窗口打开”事件。
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
InternalFrameEvent(JInternalFrame source, int id)
构造一个 InternalFrameEvent 对象。
方法摘要
JInternalFrame | getInternalFrame() 返回事件的发起者。
String | paramString() 返回标识此事件的参数字符串。
从类 java.awt.AWTEvent 继承的方法
consume, getID, isConsumed, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

INTERNAL_FRAME_FIRST

public static final int INTERNAL_FRAME_FIRST
用于内部窗体事件的 ID 范围的起始编号。

另请参见：
常量字段值

INTERNAL_FRAME_LAST

public static final int INTERNAL_FRAME_LAST
用于内部窗体事件的 ID 范围的结束编号。

另请参见：
常量字段值

INTERNAL_FRAME_OPENED

public static final int INTERNAL_FRAME_OPENED
“窗口打开”事件。仅在第一次使内部窗体可见时传递此事件。

另请参见：
JInternalFrame.show(), 常量字段值

INTERNAL_FRAME_CLOSING

public static final int INTERNAL_FRAME_CLOSING
“窗口正在关闭”事件。当用户试图关闭内部窗体时传递此事件，比如单击内部窗体的 close 按钮时，或者程序试图通过调用 setClosed 方法关闭内部窗体时。

另请参见：
JInternalFrame.setDefaultCloseOperation(int),
JInternalFrame.doDefaultCloseAction(),
JInternalFrame.setClosed(boolean),
常量字段值

INTERNAL_FRAME_CLOSED

public static final int INTERNAL_FRAME_CLOSED
“窗口关闭”事件。在由于调用 setClosed 或 dispose 方法而使内部窗体被关闭之后，传递此事件。

另请参见：
JInternalFrame.setClosed(boolean), JInternalFrame.dispose(), 常量字段值

INTERNAL_FRAME_ICONIFIED

public static final int INTERNAL_FRAME_ICONIFIED
“窗口图标化”事件。此事件指示内部窗体被缩小为一个小图标。

另请参见：
JInternalFrame.setIcon(boolean), 常量字段值

INTERNAL_FRAME_DEICONIFIED

public static final int INTERNAL_FRAME_DEICONIFIED
“窗口取消图标化”事件类型。此事件指示内部窗体已恢复其正常大小。

另请参见：
JInternalFrame.setIcon(boolean), 常量字段值

INTERNAL_FRAME_ACTIVATED

public static final int INTERNAL_FRAME_ACTIVATED
“窗口激活”事件类型。此事件指示直接对此内部窗体进行键击和鼠标单击。

另请参见：
JInternalFrame.show(), JInternalFrame.setSelected(boolean), 常量字段值

INTERNAL_FRAME_DEACTIVATED

public static final int INTERNAL_FRAME_DEACTIVATED
“窗口取消激活”事件类型。此事件指示不再直接对此内部窗体进行键击和鼠标单击。

另请参见：
JInternalFrame.setSelected(boolean), 常量字段值
构造方法详细信息

InternalFrameEvent

public InternalFrameEvent(JInternalFrame source,
                          int id)
构造一个 InternalFrameEvent 对象。

参数：
source - 发起事件的 JInternalFrame 对象
id - 指示事件类型的整数
方法详细信息

paramString

public String paramString()
返回标识此事件的参数字符串。此方法对于事件记录和调试很有用。

覆盖：
类 AWTEvent 中的 paramString
返回：
标识事件及其属性的字符串

getInternalFrame

public JInternalFrame getInternalFrame()
返回事件的发起者。

返回：
发起事件的 JInternalFrame 对象
从以下版本开始：
1.3
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


InternalFrameListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 InternalFrameListener

所有超级接口：
EventListener
所有已知实现类：
BasicInternalFrameUI.BasicInternalFrameListener, InternalFrameAdapter
public interface InternalFrameListener
extends EventListener

用于接收内部窗体事件的侦听器接口。此类在功能上等同于 AWT 中的 WindowListener 类。

有关更多的文档信息，请参阅 The Java Tutorial 中的 How to Write an Internal Frame Listener 一节以及 The Java Class Libraries (update)。

另请参见：
WindowListener

方法摘要
void | internalFrameActivated(InternalFrameEvent e) 当内部窗体被激活时调用。
void | internalFrameClosed(InternalFrameEvent e) 当内部窗体已关闭时调用。
void | internalFrameClosing(InternalFrameEvent e) 当内部窗体正被关闭时调用。
void | internalFrameDeactivated(InternalFrameEvent e) 当内部窗体被取消激活时调用。
void | internalFrameDeiconified(InternalFrameEvent e) 当内部窗体被取消图标化时调用。
void | internalFrameIconified(InternalFrameEvent e) 当内部窗体被图标化时调用。
void | internalFrameOpened(InternalFrameEvent e) 当内部窗体已打开时调用。

方法详细信息

internalFrameOpened

void internalFrameOpened(InternalFrameEvent e)
当内部窗体已打开时调用。

另请参见：
JInternalFrame.show()

internalFrameClosing

void internalFrameClosing(InternalFrameEvent e)
当内部窗体正被关闭时调用。此时可重写关闭操作。

另请参见：
JInternalFrame.setDefaultCloseOperation(int)

internalFrameClosed

void internalFrameClosed(InternalFrameEvent e)
当内部窗体已关闭时调用。

另请参见：
JInternalFrame.setClosed(boolean)

internalFrameIconified

void internalFrameIconified(InternalFrameEvent e)
当内部窗体被图标化时调用。

另请参见：
JInternalFrame.setIcon(boolean)

internalFrameDeiconified

void internalFrameDeiconified(InternalFrameEvent e)
当内部窗体被取消图标化时调用。

另请参见：
JInternalFrame.setIcon(boolean)

internalFrameActivated

void internalFrameActivated(InternalFrameEvent e)
当内部窗体被激活时调用。

另请参见：
JInternalFrame.setSelected(boolean)

internalFrameDeactivated

void internalFrameDeactivated(InternalFrameEvent e)
当内部窗体被取消激活时调用。

另请参见：
JInternalFrame.setSelected(boolean)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListDataEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 ListDataEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.ListDataEvent
所有已实现的接口：
Serializable
public class ListDataEvent
extends EventObject

定义一个封装列表更改的事件。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
static int | CONTENTS_CHANGED 标识列表内容中的一处或多处更改。
static int | INTERVAL_ADDED 标识添加到列表中的一个或多个相邻项
static int | INTERVAL_REMOVED 标识从列表中移除的一个或多个相邻项
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ListDataEvent(Object source, int type, int index0, int index1)
构造一个 ListDataEvent 对象。
方法摘要
int | getIndex0() 返回该范围的较小的索引。
int | getIndex1() 返回该范围的较大的索引。
int | getType() 返回事件类型。
String | toString() 返回此 ListDataEvent 的字符串表示形式。
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

CONTENTS_CHANGED

public static final int CONTENTS_CHANGED
标识列表内容中的一处或多处更改。

另请参见：
常量字段值

INTERVAL_ADDED

public static final int INTERVAL_ADDED
标识添加到列表中的一个或多个相邻项

另请参见：
常量字段值

INTERVAL_REMOVED

public static final int INTERVAL_REMOVED
标识从列表中移除的一个或多个相邻项

另请参见：
常量字段值
构造方法详细信息

ListDataEvent

public ListDataEvent(Object source,
                     int type,
                     int index0,
                     int index1)
构造一个 ListDataEvent 对象。如果 index0 > index1，则对 index0 和 index1 进行调换，使 index0 总是 <= index1。

参数：
source - 源 Object（通常为 this）
type - 指定 CONTENTS_CHANGED、INTERVAL_ADDED 或 INTERVAL_REMOVED 的一个 int 值
index0 - 新区间的一个端点
index1 - 新区间的另一个端点
方法详细信息

getType

public int getType()
返回事件类型。可能的值为：
  • CONTENTS_CHANGED
  • INTERVAL_ADDED
  • INTERVAL_REMOVED

返回：
一个表示类型值的 int 值

getIndex0

public int getIndex0()
返回该范围的较小的索引。对于单个元素，此值与 getIndex1() 返回的值相同。

返回：
一个表示较小的索引值的 int 值

getIndex1

public int getIndex1()
返回该范围的较大的索引。对于单个元素，此值与 getIndex0() 返回的值相同。

返回：
一个表示较大的索引值的 int 值

toString

public String toString()
返回此 ListDataEvent 的字符串表示形式。此方法仅在进行调试的时候使用，对于各个实现，所返回字符串的内容和格式可能有所不同。返回的字符串可能为空，但不可能为 null。

覆盖：
类 EventObject 中的 toString
返回：
此 ListDataEvent 的字符串表示形式。
从以下版本开始：
1.4
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListDataListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 ListDataListener

所有超级接口：
EventListener
所有已知实现类：
BasicComboBoxUI.ListDataHandler, BasicComboPopup.ListDataHandler, BasicListUI.ListDataHandler, JComboBox, JList.AccessibleJList
public interface ListDataListener
extends EventListener

ListDataListener

方法摘要
void | contentsChanged(ListDataEvent e) 在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
void | intervalAdded(ListDataEvent e) 在已将 index0,index1 区间中的索引插入数据模型中之后发送。
void | intervalRemoved(ListDataEvent e) 在已将 index0,index1 区间中的索引从数据模型中移除后发送。

方法详细信息

intervalAdded

void intervalAdded(ListDataEvent e)
在已将 index0,index1 区间中的索引插入数据模型中之后发送。新区间既包括 index0 也包括 index1。

参数：
e - 封装事件信息的 ListDataEvent

intervalRemoved

void intervalRemoved(ListDataEvent e)
在已将 index0,index1 区间中的索引从数据模型中移除后发送。该区间既包括 index0 也包括 index1。

参数：
e - 封装事件信息的 ListDataEvent

contentsChanged

void contentsChanged(ListDataEvent e)
在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。例如，在已经替换某个项时发送此方法。Index0 和 index1 括出了该范围。

参数：
e - 封装事件信息的 ListDataEvent
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListSelectionEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 ListSelectionEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.ListSelectionEvent
所有已实现的接口：
Serializable
public class ListSelectionEvent
extends EventObject

表现选择中更改的特征的事件。该更改被限定于单个闭区间。该范围中至少一个索引的选择将要更改。合适的 ListSelectionModel 实现将使该范围尽可能的小。ListSelectionListeners 通常将查询事件源，以获得每个可能更改行的新选定状态。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
ListSelectionModel

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
ListSelectionEvent(Object source, int firstIndex, int lastIndex, boolean isAdjusting)
表示 firstIndex 与 lastIndex（包括两者）范围内的选择状态的更改。
方法摘要
int | getFirstIndex() 返回第一个选择状态可能发生更改的行的索引。
int | getLastIndex() 返回最后一个选择状态可能已发生更改的行的索引。
boolean | getValueIsAdjusting() 返回此事件是否是仍然在更改的多个不同事件之一。
String | toString() 返回显示并标识此对象的属性的 String。
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

ListSelectionEvent

public ListSelectionEvent(Object source,
                          int firstIndex,
                          int lastIndex,
                          boolean isAdjusting)
表示 firstIndex 与 lastIndex（包括两者）范围内的选择状态的更改。firstIndex 小于等于 lastIndex。该范围中至少有一个索引处的选择将被更改。

参数：
firstIndex - 该范围中第一个索引，<= lastIndex
lastIndex - 该范围中最后一个索引，>= firstIndex
isAdjusting - 此事件是否是仍然在更改的多个不同事件之一
方法详细信息

getFirstIndex

public int getFirstIndex()
返回第一个选择状态可能发生更改的行的索引。getFirstIndex() &lt;= getLastIndex()

返回：
第一个选择值可能已发生更改的行，其中 0 表示第一行

getLastIndex

public int getLastIndex()
返回最后一个选择状态可能已发生更改的行的索引。 getLastIndex() &gt;= getFirstIndex()

返回：
最后一个选择值可能已发生更改的行，其中 0 表示第一行

getValueIsAdjusting

public boolean getValueIsAdjusting()
返回此事件是否是仍然在更改的多个不同事件之一。有关如何使用此方法的详细信息，请参阅 ListSelectionModel.setValueIsAdjusting(boolean) 文档。

返回：
如果此事件是仍然在更改的多个不同事件之一，则返回 true

toString

public String toString()
返回显示并标识此对象的属性的 String。

覆盖：
类 EventObject 中的 toString
返回：
此对象的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


ListSelectionListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 ListSelectionListener

所有超级接口：
EventListener
所有已知实现类：
BasicComboPopup.ListSelectionHandler, BasicFileChooserUI.SelectionListener, BasicListUI.ListSelectionHandler, DefaultTableColumnModel, JList.AccessibleJList, JTable, JTable.AccessibleJTable
public interface ListSelectionListener
extends EventListener

列表选择值发生更改时收到通知的侦听器。

另请参见：
ListSelectionModel

方法摘要
 void valueChanged(ListSelectionEvent e)
每当选择值发生更改时调用。

方法详细信息

valueChanged

void valueChanged(ListSelectionEvent e)
每当选择值发生更改时调用。

参数：
e - 表现更改的特征的事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuDragMouseEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 MenuDragMouseEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.InputEvent
                    继承者  java.awt.event.MouseEvent
                        继承者  javax.swing.event.MenuDragMouseEvent
所有已实现的接口：
Serializable
public class MenuDragMouseEvent
extends MouseEvent

MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 java.awt.event.MouseEvent 继承的字段
BUTTON1, BUTTON2, BUTTON3, MOUSE_CLICKED, MOUSE_DRAGGED, MOUSE_ENTERED, MOUSE_EXITED, MOUSE_FIRST, MOUSE_LAST, MOUSE_MOVED, MOUSE_PRESSED, MOUSE_RELEASED, MOUSE_WHEEL, NOBUTTON
从类 java.awt.event.InputEvent 继承的字段
ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
MenuDragMouseEvent(Component source, int id, long when, int modifiers, int x, int y, int xAbs, int yAbs, int clickCount, boolean popupTrigger, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。
方法摘要
MenuSelectionManager | getMenuSelectionManager() 返回当前菜单选项管理器。
MenuElement[] | getPath() 返回选定菜单项所在的路径。
从类 java.awt.event.MouseEvent 继承的方法
getButton, getClickCount, getLocationOnScreen, getMouseModifiersText, getPoint, getX, getXOnScreen, getY, getYOnScreen, isPopupTrigger, paramString, translatePoint
从类 java.awt.event.InputEvent 继承的方法
consume, getModifiers, getModifiersEx, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
getID, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuDragMouseEvent

public MenuDragMouseEvent(Component source,
                          int id,
                          long when,
                          int modifiers,
                          int x,
                          int y,
                          int clickCount,
                          boolean popupTrigger,
                          MenuElement[] p,
                          MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。

绝对坐标 xAbs 和 yAbs 被设置为：屏幕上源的位置加上相对坐标 x 和 y。如果源没有显示，则将 xAbs 和 yAbs 设置为 0。

参数：
source - 发起事件的 Component（通常为 this）
id - 指定事件类型的 int 值，在 MouseEvent 中进行了定义
when - 标识事件发生时间的 long 值
modifiers - 指定按下的所有修改键的 int 值，在 InputEvent 中进行了指定
x - 指定发生事件的水平位置（以像素为单位）的 int 值
y - 指定发生事件的垂直位置（以像素为单位）的 int 值
clickCount - 指定鼠标单击次数的 int 值
popupTrigger - 一个 boolean 值，如果该事件{应该？/已经？}触发一个弹出菜单，则该参数为 true
p - 指定受拖动影响的菜单项所在路径的 MenuElement 对象所组成的数组
m - 处理选择的 MenuSelectionManager 对象
另请参见：
MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)

MenuDragMouseEvent

public MenuDragMouseEvent(Component source,
                          int id,
                          long when,
                          int modifiers,
                          int x,
                          int y,
                          int xAbs,
                          int yAbs,
                          int clickCount,
                          boolean popupTrigger,
                          MenuElement[] p,
                          MenuSelectionManager m)
构造一个 MenuDragMouseEvent 对象。

即使传递给构造方法的相对坐标和绝对坐标的值不一致，MenuDragMouseEvent 实例仍然会被创建。

参数：
source - 发起事件的 Component（通常为 this）
id - 指定事件类型的 int 值，在 MouseEvent 中进行了定义
when - 标识事件发生时间的 long 值
modifiers - 指定按下的所有修改键的 int 值，在 InputEvent 中进行了指定
x - 指定发生事件的水平位置（以像素为单位）的 int 值
y - 指定发生事件的垂直位置（以像素为单位）的 int 值
xAbs - 指定发生事件的水平绝对位置（以像素为单位）的 int 值
yAbs - 指定发生事件的垂直绝对位置（以像素为单位）的 int 值
clickCount - 指定鼠标单击次数的 int 值
popupTrigger - 一个 boolean 值，如果该事件{应该？/已经？}触发一个弹出菜单，则该参数为 true
p - 指定受拖动影响的菜单项所在路径的 MenuElement 对象所组成的数组
m - 处理选择的 MenuSelectionManager 对象
从以下版本开始：
1.6
另请参见：
MouseEvent.MouseEvent(java.awt.Component, int, long, int, int, int, int, int, int, boolean, int)
方法详细信息

getPath

public MenuElement[] getPath()
返回选定菜单项所在的路径。

返回：
表示路径值的 MenuElement 对象所组成的数组

getMenuSelectionManager

public MenuSelectionManager getMenuSelectionManager()
返回当前菜单选项管理器。

返回：
MenuSelectionManager 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuDragMouseListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 MenuDragMouseListener

所有超级接口：
EventListener
public interface MenuDragMouseListener
extends EventListener

定义一个菜单鼠标拖动侦听器。

方法摘要
void | menuDragMouseDragged(MenuDragMouseEvent e) 当鼠标被拖动到某一菜单组件的显示区域中时调用。
void | menuDragMouseEntered(MenuDragMouseEvent e) 当拖动的鼠标进入某一菜单组件的显示区域时调用。
void | menuDragMouseExited(MenuDragMouseEvent e) 当拖动的鼠标离开某一菜单组件的显示区域时调用。
void | menuDragMouseReleased(MenuDragMouseEvent e) 当在菜单组件的显示区域中释放拖动鼠标时调用。

方法详细信息

menuDragMouseEntered

void menuDragMouseEntered(MenuDragMouseEvent e)
当拖动的鼠标进入某一菜单组件的显示区域时调用。

参数：
e - MenuDragMouseEvent 对象

menuDragMouseExited

void menuDragMouseExited(MenuDragMouseEvent e)
当拖动的鼠标离开某一菜单组件的显示区域时调用。

参数：
e - MenuDragMouseEvent 对象

menuDragMouseDragged

void menuDragMouseDragged(MenuDragMouseEvent e)
当鼠标被拖动到某一菜单组件的显示区域中时调用。

参数：
e - MenuDragMouseEvent 对象

menuDragMouseReleased

void menuDragMouseReleased(MenuDragMouseEvent e)
当在菜单组件的显示区域中释放拖动鼠标时调用。

参数：
e - MenuDragMouseEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 MenuEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.MenuEvent
所有已实现的接口：
Serializable
public class MenuEvent
extends EventObject

MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
MenuEvent(Object source)
构造一个 MenuEvent 对象。
方法摘要
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuEvent

public MenuEvent(Object source)
构造一个 MenuEvent 对象。

参数：
source - 发起事件的 Object（通常为 this）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuKeyEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 MenuKeyEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  java.awt.AWTEvent
            继承者  java.awt.event.ComponentEvent
                继承者  java.awt.event.InputEvent
                    继承者  java.awt.event.KeyEvent
                        继承者  javax.swing.event.MenuKeyEvent
所有已实现的接口：
Serializable
public class MenuKeyEvent
extends KeyEvent

MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 java.awt.event.KeyEvent 继承的字段
CHAR_UNDEFINED, KEY_FIRST, KEY_LAST, KEY_LOCATION_LEFT, KEY_LOCATION_NUMPAD, KEY_LOCATION_RIGHT, KEY_LOCATION_STANDARD, KEY_LOCATION_UNKNOWN, KEY_PRESSED, KEY_RELEASED, KEY_TYPED, VK_0, VK_1, VK_2, VK_3, VK_4, VK_5, VK_6, VK_7, VK_8, VK_9, VK_A, VK_ACCEPT, VK_ADD, VK_AGAIN, VK_ALL_CANDIDATES, VK_ALPHANUMERIC, VK_ALT, VK_ALT_GRAPH, VK_AMPERSAND, VK_ASTERISK, VK_AT, VK_B, VK_BACK_QUOTE, VK_BACK_SLASH, VK_BACK_SPACE, VK_BEGIN, VK_BRACELEFT, VK_BRACERIGHT, VK_C, VK_CANCEL, VK_CAPS_LOCK, VK_CIRCUMFLEX, VK_CLEAR, VK_CLOSE_BRACKET, VK_CODE_INPUT, VK_COLON, VK_COMMA, VK_COMPOSE, VK_CONTEXT_MENU, VK_CONTROL, VK_CONVERT, VK_COPY, VK_CUT, VK_D, VK_DEAD_ABOVEDOT, VK_DEAD_ABOVERING, VK_DEAD_ACUTE, VK_DEAD_BREVE, VK_DEAD_CARON, VK_DEAD_CEDILLA, VK_DEAD_CIRCUMFLEX, VK_DEAD_DIAERESIS, VK_DEAD_DOUBLEACUTE, VK_DEAD_GRAVE, VK_DEAD_IOTA, VK_DEAD_MACRON, VK_DEAD_OGONEK, VK_DEAD_SEMIVOICED_SOUND, VK_DEAD_TILDE, VK_DEAD_VOICED_SOUND, VK_DECIMAL, VK_DELETE, VK_DIVIDE, VK_DOLLAR, VK_DOWN, VK_E, VK_END, VK_ENTER, VK_EQUALS, VK_ESCAPE, VK_EURO_SIGN, VK_EXCLAMATION_MARK, VK_F, VK_F1, VK_F10, VK_F11, VK_F12, VK_F13, VK_F14, VK_F15, VK_F16, VK_F17, VK_F18, VK_F19, VK_F2, VK_F20, VK_F21, VK_F22, VK_F23, VK_F24, VK_F3, VK_F4, VK_F5, VK_F6, VK_F7, VK_F8, VK_F9, VK_FINAL, VK_FIND, VK_FULL_WIDTH, VK_G, VK_GREATER, VK_H, VK_HALF_WIDTH, VK_HELP, VK_HIRAGANA, VK_HOME, VK_I, VK_INPUT_METHOD_ON_OFF, VK_INSERT, VK_INVERTED_EXCLAMATION_MARK, VK_J, VK_JAPANESE_HIRAGANA, VK_JAPANESE_KATAKANA, VK_JAPANESE_ROMAN, VK_K, VK_KANA, VK_KANA_LOCK, VK_KANJI, VK_KATAKANA, VK_KP_DOWN, VK_KP_LEFT, VK_KP_RIGHT, VK_KP_UP, VK_L, VK_LEFT, VK_LEFT_PARENTHESIS, VK_LESS, VK_M, VK_META, VK_MINUS, VK_MODECHANGE, VK_MULTIPLY, VK_N, VK_NONCONVERT, VK_NUM_LOCK, VK_NUMBER_SIGN, VK_NUMPAD0, VK_NUMPAD1, VK_NUMPAD2, VK_NUMPAD3, VK_NUMPAD4, VK_NUMPAD5, VK_NUMPAD6, VK_NUMPAD7, VK_NUMPAD8, VK_NUMPAD9, VK_O, VK_OPEN_BRACKET, VK_P, VK_PAGE_DOWN, VK_PAGE_UP, VK_PASTE, VK_PAUSE, VK_PERIOD, VK_PLUS, VK_PREVIOUS_CANDIDATE, VK_PRINTSCREEN, VK_PROPS, VK_Q, VK_QUOTE, VK_QUOTEDBL, VK_R, VK_RIGHT, VK_RIGHT_PARENTHESIS, VK_ROMAN_CHARACTERS, VK_S, VK_SCROLL_LOCK, VK_SEMICOLON, VK_SEPARATER, VK_SEPARATOR, VK_SHIFT, VK_SLASH, VK_SPACE, VK_STOP, VK_SUBTRACT, VK_T, VK_TAB, VK_U, VK_UNDEFINED, VK_UNDERSCORE, VK_UNDO, VK_UP, VK_V, VK_W, VK_WINDOWS, VK_X, VK_Y, VK_Z
从类 java.awt.event.InputEvent 继承的字段
ALT_DOWN_MASK, ALT_GRAPH_DOWN_MASK, ALT_GRAPH_MASK, ALT_MASK, BUTTON1_DOWN_MASK, BUTTON1_MASK, BUTTON2_DOWN_MASK, BUTTON2_MASK, BUTTON3_DOWN_MASK, BUTTON3_MASK, CTRL_DOWN_MASK, CTRL_MASK, META_DOWN_MASK, META_MASK, SHIFT_DOWN_MASK, SHIFT_MASK
从类 java.awt.event.ComponentEvent 继承的字段
COMPONENT_FIRST, COMPONENT_HIDDEN, COMPONENT_LAST, COMPONENT_MOVED, COMPONENT_RESIZED, COMPONENT_SHOWN
从类 java.awt.AWTEvent 继承的字段
ACTION_EVENT_MASK, ADJUSTMENT_EVENT_MASK, COMPONENT_EVENT_MASK, consumed, CONTAINER_EVENT_MASK, FOCUS_EVENT_MASK, HIERARCHY_BOUNDS_EVENT_MASK, HIERARCHY_EVENT_MASK, id, INPUT_METHOD_EVENT_MASK, INVOCATION_EVENT_MASK, ITEM_EVENT_MASK, KEY_EVENT_MASK, MOUSE_EVENT_MASK, MOUSE_MOTION_EVENT_MASK, MOUSE_WHEEL_EVENT_MASK, PAINT_EVENT_MASK, RESERVED_ID_MAX, TEXT_EVENT_MASK, WINDOW_EVENT_MASK, WINDOW_FOCUS_EVENT_MASK, WINDOW_STATE_EVENT_MASK
从类 java.util.EventObject 继承的字段
source
构造方法摘要
MenuKeyEvent(Component source, int id, long when, int modifiers, int keyCode, char keyChar, MenuElement[] p, MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。
方法摘要
MenuSelectionManager | getMenuSelectionManager() 返回当前菜单选项管理器。
MenuElement[] | getPath() 返回到达此事件引用的菜单项的路径。
从类 java.awt.event.KeyEvent 继承的方法
getKeyChar, getKeyCode, getKeyLocation, getKeyModifiersText, getKeyText, isActionKey, paramString, setKeyChar, setKeyCode, setModifiers
从类 java.awt.event.InputEvent 继承的方法
consume, getModifiers, getModifiersEx, getModifiersExText, getWhen, isAltDown, isAltGraphDown, isConsumed, isControlDown, isMetaDown, isShiftDown
从类 java.awt.event.ComponentEvent 继承的方法
getComponent
从类 java.awt.AWTEvent 继承的方法
getID, setSource, toString
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

MenuKeyEvent

public MenuKeyEvent(Component source,
                    int id,
                    long when,
                    int modifiers,
                    int keyCode,
                    char keyChar,
                    MenuElement[] p,
                    MenuSelectionManager m)
构造一个 MenuKeyEvent 对象。

参数：
source - 发起事件的 Component（通常为 this）
id - 指定事件类型的 int 值，KeyEvent 中定义了这些事件类型
when - 标识事件发生时间的 long 值
modifiers - 指定按下的所有修改键的 int 值，InputEvent 中指定了这些修改键
keyCode - 指定按下的特定键的 int 值
keyChar - 指定键的字符值（如果有）的 char 值，如果该键没有字符值，则该参数为 null
p - 为受拖动影响的菜单项指定一条路径的 MenuElement 对象所组成的数组
m - 处理选择的 MenuSelectionManager 对象
方法详细信息

getPath

public MenuElement[] getPath()
返回到达此事件引用的菜单项的路径。

返回：
表示路径值的 MenuElement 对象组成的数组

getMenuSelectionManager

public MenuSelectionManager getMenuSelectionManager()
返回当前菜单选项管理器。

返回：
MenuSelectionManager 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuKeyListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 MenuKeyListener

所有超级接口：
EventListener
public interface MenuKeyListener
extends EventListener

MenuKeyListener

方法摘要
void | menuKeyPressed(MenuKeyEvent e) 已按下某个键时调用。
void | menuKeyReleased(MenuKeyEvent e) 已释放某个键时调用。
void | menuKeyTyped(MenuKeyEvent e) 已键入某个键时调用。

方法详细信息

menuKeyTyped

void menuKeyTyped(MenuKeyEvent e)
已键入某个键时调用。此事件发生在释放一个键后紧跟着按下一个键时。

menuKeyPressed

void menuKeyPressed(MenuKeyEvent e)
已按下某个键时调用。

menuKeyReleased

void menuKeyReleased(MenuKeyEvent e)
已释放某个键时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MenuListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 MenuListener

所有超级接口：
EventListener
public interface MenuListener
extends EventListener

定义一个菜单事件侦听器。

方法摘要
void | menuCanceled(MenuEvent e) 取消菜单时调用。
void | menuDeselected(MenuEvent e) 取消选择某个菜单时调用。
void | menuSelected(MenuEvent e) 选择某个菜单时调用。

方法详细信息

menuSelected

void menuSelected(MenuEvent e)
选择某个菜单时调用。

参数：
e - 一个 MenuEvent 对象

menuDeselected

void menuDeselected(MenuEvent e)
取消选择某个菜单时调用。

参数：
e - 一个 MenuEvent 对象

menuCanceled

void menuCanceled(MenuEvent e)
取消菜单时调用。

参数：
e - 一个 MenuEvent 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseInputAdapter (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 MouseInputAdapter

java.lang.Object
    继承者  java.awt.event.MouseAdapter
        继承者  javax.swing.event.MouseInputAdapter
所有已实现的接口：
MouseListener, MouseMotionListener, MouseWheelListener, EventListener, MouseInputListener
直接已知子类：
BasicDesktopIconUI.MouseInputHandler, BasicInternalFrameUI.BorderListener, BasicSliderUI.TrackListener
public abstract class MouseInputAdapter
extends MouseAdapter
implements MouseInputListener

MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。通过从 AWT 的 MouseAdapter 扩展此类，它还可以提供 MouseWheelListener 接口的一个空实现。

构造方法摘要
MouseInputAdapter()
方法摘要
从类 java.awt.event.MouseAdapter 继承的方法
mouseClicked, mouseDragged, mouseEntered, mouseExited, mouseMoved, mousePressed, mouseReleased, mouseWheelMoved
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait
从接口 java.awt.event.MouseListener 继承的方法
mouseClicked, mouseEntered, mouseExited, mousePressed, mouseReleased
从接口 java.awt.event.MouseMotionListener 继承的方法
mouseDragged, mouseMoved

构造方法详细信息

MouseInputAdapter

public MouseInputAdapter()
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


MouseInputListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 MouseInputListener

所有超级接口：
EventListener, MouseListener, MouseMotionListener
所有已知实现类：
BasicDesktopIconUI.MouseInputHandler, BasicInternalFrameUI.BorderListener, BasicInternalFrameUI.GlassPaneDispatcher, BasicListUI.MouseInputHandler, BasicMenuItemUI.MouseInputHandler, BasicMenuUI.MouseInputHandler, BasicSliderUI.TrackListener, BasicTableHeaderUI.MouseInputHandler, BasicTableUI.MouseInputHandler, BasicToolBarUI.DockingListener, BasicTreeUI.MouseInputHandler, MetalToolBarUI.MetalDockingListener, MouseInputAdapter
public interface MouseInputListener
extends MouseListener, MouseMotionListener

实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。

另请参见：
MouseInputAdapter

方法摘要
从接口 java.awt.event.MouseListener 继承的方法
mouseClicked, mouseEntered, mouseExited, mousePressed, mouseReleased
从接口 java.awt.event.MouseMotionListener 继承的方法
mouseDragged, mouseMoved

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PopupMenuEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 PopupMenuEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.PopupMenuEvent
所有已实现的接口：
Serializable
public class PopupMenuEvent
extends EventObject

PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
PopupMenuEvent(Object source)
构造一个 PopupMenuEvent 对象。
方法摘要
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

PopupMenuEvent

public PopupMenuEvent(Object source)
构造一个 PopupMenuEvent 对象。

参数：
source - 发起事件的 Object（通常为 this）
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


PopupMenuListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 PopupMenuListener

所有超级接口：
EventListener
public interface PopupMenuListener
extends EventListener

弹出菜单侦听器

方法摘要
void | popupMenuCanceled(PopupMenuEvent e) 此方法在弹出菜单被取消时调用。
void | popupMenuWillBecomeInvisible(PopupMenuEvent e) 此方法在弹出菜单变得不可见之前调用。
void | popupMenuWillBecomeVisible(PopupMenuEvent e) 此方法在弹出菜单变得可见之前调用

方法详细信息

popupMenuWillBecomeVisible

void popupMenuWillBecomeVisible(PopupMenuEvent e)
此方法在弹出菜单变得可见之前调用

popupMenuWillBecomeInvisible

void popupMenuWillBecomeInvisible(PopupMenuEvent e)
此方法在弹出菜单变得不可见之前调用。注意，JPopupMenu 可在任意时间变得不可见。

popupMenuCanceled

void popupMenuCanceled(PopupMenuEvent e)
此方法在弹出菜单被取消时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSorterEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 RowSorterEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.RowSorterEvent
所有已实现的接口：
Serializable
public class RowSorterEvent
extends EventObject

RowSorterEvent 提供 RowSorter 的更改通知。可能有两种类型的通知：

  • Type.SORT_ORDER_CHANGED：表示排序顺序发生了更改。此通知通常跟有以下通知：
  • Type.SORTED：表示已经以某种方式转换了模型的内容。例如，可能对内容进行了排序或过滤。

从以下版本开始：
1.6
另请参见：
RowSorter

嵌套类摘要
static class RowSorterEvent.Type
RowSorterEvent 类型的枚举。
字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
RowSorterEvent(RowSorter source)
创建类型为 SORT_ORDER_CHANGED 的 RowSorterEvent。
RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
创建一个 RowSorterEvent。
方法摘要
int | convertPreviousRowIndexToModel(int index) 返回基于模型排序之前的 index 的位置。
int | getPreviousRowCount() 返回排序之前行的数量。
RowSorter | getSource() 返回以 RowSorter 形式表示的事件源。
RowSorterEvent.Type | getType() 返回事件的类型。
从类 java.util.EventObject 继承的方法
toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

RowSorterEvent

public RowSorterEvent(RowSorter source)
创建类型为 SORT_ORDER_CHANGED 的 RowSorterEvent。

参数：
source - 更改的源
抛出：
IllegalArgumentException - 如果 source 为 null

RowSorterEvent

public RowSorterEvent(RowSorter source,
                      RowSorterEvent.Type type,
                      int[] previousRowIndexToModel)
创建一个 RowSorterEvent。

参数：
source - 更改的源
type - 事件的类型
previousRowIndexToModel - 从模型索引到排序之前的视图索引的映射关系，可以为 null
抛出：
IllegalArgumentException - 如果 source 或 type 为 null
方法详细信息

getSource

public RowSorter getSource()
返回以 RowSorter 形式表示的事件源。

覆盖：
类 EventObject 中的 getSource
返回：
以 RowSorter 形式表示的事件源

getType

public RowSorterEvent.Type getType()
返回事件的类型。

返回：
事件的类型

convertPreviousRowIndexToModel

public int convertPreviousRowIndexToModel(int index)
返回基于模型排序之前的 index 的位置。此方法只用于类型为 SORTED 的事件。如果索引无效或者尚未提供排序之前的位置，则此方法将返回 -1。

参数：
index - 基于视图的索引
返回：
基于排序之前的模型的索引；如果该位置无效或没有提供该映射关系，则返回 -1。

getPreviousRowCount

public int getPreviousRowCount()
返回排序之前行的数量。此方法只用于类型为 SORTED 的事件；如果尚未提供最后的位置，此方法将返回 0。

返回：
基于排序之前的视图的行数
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


RowSorterEvent.Type (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法

javax.swing.event
枚举 RowSorterEvent.Type

java.lang.Object
    继承者  java.lang.Enum<RowSorterEvent.Type>
        继承者  javax.swing.event.RowSorterEvent.Type
所有已实现的接口：
Serializable, Comparable<RowSorterEvent.Type>
正在封闭类：
RowSorterEvent
public static enum RowSorterEvent.Type
extends Enum<RowSorterEvent.Type>

RowSorterEvent 类型的枚举。

从以下版本开始：
1.6

枚举常量摘要
SORT_ORDER_CHANGED
指示排序顺序发生了更改。
SORTED
指示最近以某种方式对内容进行了排序和转换。
方法摘要
static RowSorterEvent.Type | valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowSorterEvent.Type[] | values() Returns an array containing the constants of this enum type, in the order they are declared.
从类 java.lang.Enum 继承的方法
clone, compareTo, equals, finalize, getDeclaringClass, hashCode, name, ordinal, toString, valueOf
从类 java.lang.Object 继承的方法
getClass, notify, notifyAll, wait, wait, wait

枚举常量详细信息

SORT_ORDER_CHANGED

public static final RowSorterEvent.Type SORT_ORDER_CHANGED
指示排序顺序发生了更改。

SORTED

public static final RowSorterEvent.Type SORTED
指示最近以某种方式对内容进行了排序和转换。

方法详细信息

values

public static final RowSorterEvent.Type[] values()
Returns an array containing the constants of this enum type, in the order they are declared. This method may be used to iterate over the constants as follows:
for(RowSorterEvent.Type c : RowSorterEvent.Type.values())
        System.out.println(c);

返回：
an array containing the constants of this enum type, in the order they are declared

valueOf

public static RowSorterEvent.Type valueOf(String name)
返回带有指定名称的该类型的枚举常量。 字符串必须与用于声明该类型的枚举常量的 标识符完全匹配。（不允许有多余 的空格。）

参数：
指定要返回的枚举常量的名称。 -
返回：
返回带有指定名称的枚举常量
抛出：
如果该枚举类型没有带有指定名称的常量， - 则抛出 IllegalArgumentException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 枚举常量 | 字段 | 方法 详细信息： 枚举常量 | 字段 | 方法


RowSorterListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 RowSorterListener

所有超级接口：
EventListener
所有已知实现类：
JTable
public interface RowSorterListener
extends EventListener

通知 RowSorterListener 对 RowSorter 的更改。

从以下版本开始：
1.6
另请参见：
RowSorter

方法摘要
 void sorterChanged(RowSorterEvent e)
RowSorter 发生了更改的通知。

方法详细信息

sorterChanged

void sorterChanged(RowSorterEvent e)
RowSorter 发生了更改的通知。事件描述了更改的范围。

参数：
e - 事件，不能为 null
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


SwingPropertyChangeSupport (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 SwingPropertyChangeSupport

java.lang.Object
    继承者  java.beans.PropertyChangeSupport
        继承者  javax.swing.event.SwingPropertyChangeSupport
所有已实现的接口：
Serializable
public final class SwingPropertyChangeSupport
extends PropertyChangeSupport

java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。唯一的不同在于，如果用 SwingPropertyChangeSupport(sourceBean, true) 构造此类，它确保只在事件指派线程 上通知侦听器。

构造方法摘要
SwingPropertyChangeSupport(Object sourceBean)
构造一个 SwingPropertyChangeSupport 对象。
SwingPropertyChangeSupport(Object sourceBean, boolean notifyOnEDT)
构造一个 SwingPropertyChangeSupport 对象。
方法摘要
void | firePropertyChange(PropertyChangeEvent evt) 对所有已注册侦听器激发一个现有 PropertyChangeEvent。
boolean | isNotifyOnEDT() 返回 notifyOnEDT 属性。
从类 java.beans.PropertyChangeSupport 继承的方法
addPropertyChangeListener, addPropertyChangeListener, fireIndexedPropertyChange, fireIndexedPropertyChange, fireIndexedPropertyChange, firePropertyChange, firePropertyChange, firePropertyChange, getPropertyChangeListeners, getPropertyChangeListeners, hasListeners, removePropertyChangeListener, removePropertyChangeListener
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, toString, wait, wait, wait

构造方法详细信息

SwingPropertyChangeSupport

public SwingPropertyChangeSupport(Object sourceBean)
构造一个 SwingPropertyChangeSupport 对象。

参数：
sourceBean - 作为所有事件的源提供的 bean。
抛出：
NullPointerException - 如果 sourceBean 为 null

SwingPropertyChangeSupport

public SwingPropertyChangeSupport(Object sourceBean,
                                  boolean notifyOnEDT)
构造一个 SwingPropertyChangeSupport 对象。

参数：
sourceBean - 作为所有事件的源提供的 bean
notifyOnEDT - 是否只在事件指派线程 上通知侦听器
抛出：
NullPointerException - 如果 sourceBean 为 null
从以下版本开始：
1.6
方法详细信息

firePropertyChange

public void firePropertyChange(PropertyChangeEvent evt)
对所有已注册侦听器激发一个现有 PropertyChangeEvent。如果给定事件的旧值和新值相等并且都是非 null 的，则不会激发事件。

如果 isNotifyOnEDT() 为 true 并且取消了事件指派线程，则此实现使用 SwingUtilities.invokeLater 在事件指派线程 上发送通知。这确保只在事件指派线程 上通知侦听器。

覆盖：
类 PropertyChangeSupport 中的 firePropertyChange
参数：
evt - PropertyChangeEvent 对象。
抛出：
NullPointerException - 如果 evt 为 null
从以下版本开始：
1.6

isNotifyOnEDT

public final boolean isNotifyOnEDT()
返回 notifyOnEDT 属性。

返回：
notifyOnEDT 属性
从以下版本开始：
1.6
另请参见：
SwingPropertyChangeSupport(Object sourceBean, boolean notifyOnEDT)
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableColumnModelEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 TableColumnModelEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.TableColumnModelEvent
所有已实现的接口：
Serializable
public class TableColumnModelEvent
extends EventObject

TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
TableColumnModelListener

字段摘要
protected int | fromIndex 列的索引，从该索引处移动或移除列
protected int | toIndex 列的索引，该索引处是移动或添加操作的目标位置
从类 java.util.EventObject 继承的字段
source
构造方法摘要
TableColumnModelEvent(TableColumnModel source, int from, int to)
构造一个 TableColumnModelEvent 对象。
方法摘要
int | getFromIndex() 返回 fromIndex。
int | getToIndex() 返回 toIndex。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

fromIndex

protected int fromIndex
列的索引，从该索引处移动或移除列

toIndex

protected int toIndex
列的索引，该索引处是移动或添加操作的目标位置

构造方法详细信息

TableColumnModelEvent

public TableColumnModelEvent(TableColumnModel source,
                             int from,
                             int to)
构造一个 TableColumnModelEvent 对象。

参数：
source - 发起事件的 TableColumnModel
from - 指定移动或移除列的原位置处索引的 int 值
to - 指定移动或添加列的目标位置处索引的 int 值
另请参见：
getFromIndex(), getToIndex()
方法详细信息

getFromIndex

public int getFromIndex()
返回 fromIndex。对已移除或移动的事件有效

getToIndex

public int getToIndex()
返回 toIndex。对添加和移动的事件有效

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableColumnModelListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 TableColumnModelListener

所有超级接口：
EventListener
所有已知实现类：
JTable, JTable.AccessibleJTable, JTableHeader
public interface TableColumnModelListener
extends EventListener

TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。

另请参见：
TableColumnModelEvent

方法摘要
void | columnAdded(TableColumnModelEvent e) 告知侦听器有一列被添加到模型中。
void | columnMarginChanged(ChangeEvent e) 告知侦听器因为页边空白更改，有一列被移除。
void | columnMoved(TableColumnModelEvent e) 告知侦听器有一列被重新调整位置。
void | columnRemoved(TableColumnModelEvent e) 告知侦听器有一列从模型中移除。
void | columnSelectionChanged(ListSelectionEvent e) 告知侦听器 TableColumnModel 的选择模型发生更改。

方法详细信息

columnAdded

void columnAdded(TableColumnModelEvent e)
告知侦听器有一列被添加到模型中。

columnRemoved

void columnRemoved(TableColumnModelEvent e)
告知侦听器有一列从模型中移除。

columnMoved

void columnMoved(TableColumnModelEvent e)
告知侦听器有一列被重新调整位置。

columnMarginChanged

void columnMarginChanged(ChangeEvent e)
告知侦听器因为页边空白更改，有一列被移除。

columnSelectionChanged

void columnSelectionChanged(ListSelectionEvent e)
告知侦听器 TableColumnModel 的选择模型发生更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableModelEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 TableModelEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.TableModelEvent
所有已实现的接口：
Serializable
public class TableModelEvent
extends EventObject

TableModelEvent 用于通知侦听器某一表模型已发生更改。模型事件描述 TableModel 的更改，并且对行和列的所有引用都在该模型的坐标系统中。可以根据构造方法中使用的参数，用 TableModelevent 指定以下更改类型：

 TableModelEvent(source);              //  The data, ie. all rows changed
 TableModelEvent(source, HEADER_ROW);  //  Structure change, reallocate TableColumns
 TableModelEvent(source, 1);           //  Row 1 changed
 TableModelEvent(source, 3, 6);        //  Rows 3 to 6 inclusive changed
 TableModelEvent(source, 2, 2, 6);     //  Cell at (2, 6) changed
 TableModelEvent(source, 3, 6, ALL_COLUMNS, INSERT); // Rows (3, 6) were inserted
 TableModelEvent(source, 3, 6, ALL_COLUMNS, DELETE); // Rows (3, 6) were deleted
可以使用其他参数组合，但并不是所有的参数都有意义。通过创建子类，可以添加其他任何信息，例如：事件“将要”发生，还是“确实已经”发生。这使得 DELETE 事件中的行的指定更有用，但这并没有包含在 swing 包中，因为 JTable 只需要发送事件的通知。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
TableModel

字段摘要
static int | ALL_COLUMNS 指定一行或一些行中的所有列。
protected int | column
static int | DELETE 标识行或列的移除。
protected int | firstRow
static int | HEADER_ROW 标识标题行。
static int | INSERT 标识新行或新列的添加。
protected int | lastRow
protected int | type
static int | UPDATE 标识现有数据的更改。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
TableModelEvent(TableModel source)
如果表中的所有行数据都发生更改，那么侦听器应该丢弃基于这些行的所有状态，并重新查询 TableModel 来获得新的行计数和所有恰当值。
TableModelEvent(TableModel source, int row)
此数据行已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow)
行 [firstRow, lastRow] 中的数据已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow, int column)
列 column 的 [firstRow, lastRow] 范围内的单元格已被更新。
TableModelEvent(TableModel source, int firstRow, int lastRow, int column, int type)
从 (firstRow, column) 到 (lastRow, column) 的单元格已被更改。
方法摘要
int | getColumn() 返回事件的列。
int | getFirstRow() 返回第一个被更改的行。
int | getLastRow() 返回最后一个被更改的行。
int | getType() 返回事件类型，该类型为以下类型之一：INSERT、UPDATE 和 DELETE。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

INSERT

public static final int INSERT
标识新行或新列的添加。

另请参见：
常量字段值

UPDATE

public static final int UPDATE
标识现有数据的更改。

另请参见：
常量字段值

DELETE

public static final int DELETE
标识行或列的移除。

另请参见：
常量字段值

HEADER_ROW

public static final int HEADER_ROW
标识标题行。

另请参见：
常量字段值

ALL_COLUMNS

public static final int ALL_COLUMNS
指定一行或一些行中的所有列。

另请参见：
常量字段值

type

protected int type

firstRow

protected int firstRow

lastRow

protected int lastRow

column

protected int column
构造方法详细信息

TableModelEvent

public TableModelEvent(TableModel source)
如果表中的所有行数据都发生更改，那么侦听器应该丢弃基于这些行的所有状态，并重新查询 TableModel 来获得新的行计数和所有恰当值。JTable 将重新绘制接收此事件有关的整个可见区域，并查询模型来获得可见的单元格值。表的结构（即列的名称、类型和顺序）未发生更改。

TableModelEvent

public TableModelEvent(TableModel source,
                       int row)
此数据行已被更新。为了表示具有不同结构的整个新表都已到达，可使用 HEADER_ROW 作为 row 的值。当 JTable 接收此事件，并且其 autoCreateColumnsFromModel 标志被设置，它将丢弃它所拥有的所有 TableColumn，并按照这些列在模型中出现的顺序重新分配默认列。此方法等效于在 JTable 上调用 setModel(TableModel)。

TableModelEvent

public TableModelEvent(TableModel source,
                       int firstRow,
                       int lastRow)
行 [firstRow, lastRow] 中的数据已被更新。

TableModelEvent

public TableModelEvent(TableModel source,
                       int firstRow,
                       int lastRow,
                       int column)
列 column 的 [firstRow, lastRow] 范围内的单元格已被更新。

TableModelEvent

public TableModelEvent(TableModel source,
                       int firstRow,
                       int lastRow,
                       int column,
                       int type)
从 (firstRow, column) 到 (lastRow, column) 的单元格已被更改。column 引用模型坐标系统中的单元格的列索引。当 column 为 ALL_COLUMNS 时，指定行范围中的所有单元格都被认为是已更改的。

type 应该是以下类型之一：INSERT、UPDATE 和 DELETE。

方法详细信息

getFirstRow

public int getFirstRow()
返回第一个被更改的行。HEADER_ROW 表示元数据，即列的名称、类型和顺序。

getLastRow

public int getLastRow()
返回最后一个被更改的行。

getColumn

public int getColumn()
返回事件的列。如果返回值为 ALL_COLUMNS，则意味着指定行中的所有列都被更改。

getType

public int getType()
返回事件类型，该类型为以下类型之一：INSERT、UPDATE 和 DELETE。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TableModelListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 TableModelListener

所有超级接口：
EventListener
所有已知实现类：
JTable, JTable.AccessibleJTable
public interface TableModelListener
extends EventListener

TableModelListener 定义侦听 TableModel 中更改的对象的接口。

另请参见：
TableModel

方法摘要
 void tableChanged(TableModelEvent e)
此细粒度通知告知侦听器单元格、行或列的哪些具体范围发生了更改。

方法详细信息

tableChanged

void tableChanged(TableModelEvent e)
此细粒度通知告知侦听器单元格、行或列的哪些具体范围发生了更改。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeExpansionEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 TreeExpansionEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.TreeExpansionEvent
所有已实现的接口：
Serializable
public class TreeExpansionEvent
extends EventObject

用于标识树中的单个路径的事件。由 getSource 返回的源将是一个 JTree 实例。

有关进一步文档和示例，请参阅 The Java Tutorial 中的以下章节：How to Write a Tree Expansion Listener 和 How to Write a Tree-Will-Expand Listener。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected  TreePath path
到达此事件表示的值的路径。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
TreeExpansionEvent(Object source, TreePath path)
构造一个 TreeExpansionEvent 对象。
方法摘要
 TreePath getPath()
返回到达已被扩展/折叠的值的路径。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

path

protected TreePath path
到达此事件表示的值的路径。

构造方法详细信息

TreeExpansionEvent

public TreeExpansionEvent(Object source,
                          TreePath path)
构造一个 TreeExpansionEvent 对象。

参数：
source - 发起事件的 Object（通常为 this）
path - 标识新扩展的节点的 TreePath 对象
方法详细信息

getPath

public TreePath getPath()
返回到达已被扩展/折叠的值的路径。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeExpansionListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 TreeExpansionListener

所有超级接口：
EventListener
所有已知实现类：
BasicTreeUI.TreeExpansionHandler, JTree.AccessibleJTree
public interface TreeExpansionListener
extends EventListener

当树扩展或折叠某一节点时获得通知的侦听器。有关进一步的文档和示例，请参阅 The Java Tutorial 中的 How to Write a Tree Expansion Listener 一节。

方法摘要
void | treeCollapsed(TreeExpansionEvent event) 每当树中的一个项被折叠时调用。
void | treeExpanded(TreeExpansionEvent event) 每当树中的一个项被扩展时调用。

方法详细信息

treeExpanded

void treeExpanded(TreeExpansionEvent event)
每当树中的一个项被扩展时调用。

treeCollapsed

void treeCollapsed(TreeExpansionEvent event)
每当树中的一个项被折叠时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeModelEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 TreeModelEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.TreeModelEvent
所有已实现的接口：
Serializable
public class TreeModelEvent
extends EventObject

封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。有关更多的信息和示例，请参阅 The Java Tutorial 中的 How to Write a Tree Model Listener 一节。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
protected int[] | childIndices 标识子节点所在位置的索引。
protected Object[] | children 已被移除的子节点。
protected TreePath | path 到达已更改节点的父节点的路径。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
TreeModelEvent(Object source, Object[] path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。
TreeModelEvent(Object source, Object[] path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。
TreeModelEvent(Object source, TreePath path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。
TreeModelEvent(Object source, TreePath path, int[] childIndices, Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。
方法摘要
int[] | getChildIndices() 返回子索引的值。
Object[] | getChildren() 返回位于 getChildIndices 指定位置处的、作为 getPath 所标识节点的子节点的对象。
Object[] | getPath() 从此事件包装的 TreePath 实例中获得对象数组的便捷方法。
TreePath | getTreePath() 对于除 treeStructureChanged 以外的所有事件，返回已更改节点的父节点。
String | toString() 返回显示和标识此对象属性的字符串。
从类 java.util.EventObject 继承的方法
getSource
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

path

protected TreePath path
到达已更改节点的父节点的路径。

childIndices

protected int[] childIndices
标识子节点所在位置的索引。

children

protected Object[] children
已被移除的子节点。

构造方法详细信息

TreeModelEvent

public TreeModelEvent(Object source,
                      Object[] path,
                      int[] childIndices,
                      Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 Object 数组。所有修改的对象都是同级的，它们是指定父对象的直接后代（不是孙级）。发生插入、删除或更改操作的位置由一个 int 数组指定。该数组中的索引必须是有序的，从最低到最高。

对于更改操作，模型中的索引完全对应于当前显示在 UI 中的项的索引。因此，如果索引没有按其正确的顺序排列实际上也没有多大关系。但在多次执行插入或删除操作以后，UI 中当前存在的项不再对应于模型中的项。因此，为插入和删除操作正确地指定索引很关键。

对于插入操作，在执行插入操作之后，索引表示树的最终 状态。因为必须按顺序指定索引，所以最自然的处理方法是从最低索引处开始执行插入操作，向最高索引处移动。在此过程中累计指定插入位置的 Integer 对象的 Vector，然后将该 Vector 转换成一个 int 数组，以创建事件。当位置索引等于零时，在列表的开始处插入节点。当位置索引等于列表的大小时，在列表的结尾处“插入”（追加）节点。

对于删除操作，在执行删除操作之前，索引表示树的最初 状态。因为必须按顺序指定索引，所以最自然的处理方法是使用一个删除计数器 (delete-counter)。先将计数器初始化为零，然后从最低索引到最高索引对列表进行初始化。每执行一次删除操作，就将删除计数器的当前值添加到执行删除的索引位置，然后使用 addElement() 将所得的结果追加到删除位置的 Vector 中。然后将删除计数器加 1。所以存储在 Vector 中的索引位置可以反映所有以前的删除操作的效果，因此它们表示初始树中每个对象的位置。（还可以从最高索引开始，反向运行到最低索引，并在此过程中使用 insertElementAt(Integer, 0) 累计删除位置的 Vector。）不过，先要生成初始位置的 Vector，然后将 Integer 对象的 Vector 转换成一个 int 数组，以创建事件。

注：

  • 与 DefaultTreeModel类中的 insertNodeInto 方法类似，insertElementAt 在索引与向量的大小匹配时追加 Vector。所以即使在向量为空时也可以使用 insertElementAt(Integer, 0)。
      要为根节点创建一个节点更改事件，则需要将父索引和子索引都指定为 null。

    参数：
    source - 对生成该事件负责的 Object（事件对象的创建者通常传递 this 作为其值）
    path - 指定到达已修改项父级的路径的 Object 数组，该数组的第一个元素是存储在根节点上的 Object，最后一个元素是存储在父节点上的 Object
    childIndices - 指定已移除项的索引值的 int 数组。索引必须按存储顺序排列，从最低索引到最高索引
    children - 包含已插入、移除或更改对象的 Object 数组
    另请参见：
    TreePath

TreeModelEvent

public TreeModelEvent(Object source,
                      TreePath path,
                      int[] childIndices,
                      Object[] children)
用来在节点已更改、插入或移除时创建一个事件，将到达已修改项的父级的路径标识为一个 TreePath 对象。有关如何指定索引和对象的更多信息，请参见 TreeModelEvent(Object,Object[],int[],Object[])。

参数：
source - 对生成该事件负责的 Object（事件对象的创建者通常传递 this 作为其值）
path - 标识到达已修改项父级的路径的 TreePath 对象
childIndices - 指定已修改项的索引值的 int 数组
children - 包含已插入、移除或更改对象的 Object 数组
另请参见：
TreeModelEvent(Object,Object[],int[],Object[])

TreeModelEvent

public TreeModelEvent(Object source,
                      Object[] path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 Object 数组。例如，结构更改事件可能涉及节点交换位置，或者它可以在源于该节点的子树中封装多个插入和删除操作，在该子树中，更改可以发生在子树的不同级别上。
注：
JTree 折叠指定节点下的所有节点，因此只有该节点的直接子节点可见。

参数：
source - 对生成该事件负责的 Object（事件对象的创建者通常传递 this 作为其值）
path - 指定到达已修改子树的根的路径的 Object 数组，该数组的第一个元素是存储在根节点上的对象，最后一个元素是存储在已更改节点上的对象
另请参见：
TreePath

TreeModelEvent

public TreeModelEvent(Object source,
                      TreePath path)
用来在节点结构以某种方法发生更改时创建一个事件，将到达已修改子树的根的路径标识为一个 TreePath 对象。有关此事件规范的更多信息，请参见 TreeModelEvent(Object,Object[])。

参数：
source - 对生成该事件负责的 Object（事件对象的创建者通常传递 this 作为其值）
path - 标识到达更改的路径的 TreePath 对象。在 DefaultTreeModel 中，此对象包含一个用户数据对象数组，但 TreePath 的子类可以使用完全不同的一些机制，例如，一个节点 ID 编号
另请参见：
TreeModelEvent(Object,Object[])
方法详细信息

getTreePath

public TreePath getTreePath()
对于除 treeStructureChanged 以外的所有事件，返回已更改节点的父节点。对于 treeStructureChanged 事件，返回已更改结构的祖先。可使用此方法和 getChildIndices 来获得受影响节点的列表。

惟一的例外是一个将标识根的 treeNodesChanged 事件，在这种情况下，此方法将返回此根，而 getChildIndices 将返回 null。

返回：
用于标识已更改节点的 TreePath。
另请参见：
TreePath.getLastPathComponent()

getPath

public Object[] getPath()
从此事件包装的 TreePath 实例中获得对象数组的便捷方法。

返回：
Object 数组，其中第一个 Object 是存储在根节点上的对象，最后一个对象是存储在由该路径标识的节点上的对象

getChildren

public Object[] getChildren()
返回位于 getChildIndices 指定位置处的、作为 getPath 所标识节点的子节点的对象。如果这是一个移除事件，则返回的对象不再是父节点的子节点。

返回：
包含由事件指定的子节点的 Object 数组
另请参见：
getPath(), getChildIndices()

getChildIndices

public int[] getChildIndices()
返回子索引的值。如果这是一个移除事件，则索引指向已移除项所在的初始列表中的位置。如果这是一个插入事件，则索引指向添加项所在的初始列表中的位置。对于节点更改，索引指向已修改节点的位置。

返回：
包含该事件指定的子索引位置的 int 数组

toString

public String toString()
返回显示和标识此对象属性的字符串。

覆盖：
类 EventObject 中的 toString
返回：
此对象的字符串表示形式
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeModelListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 TreeModelListener

所有超级接口：
EventListener
所有已知实现类：
BasicTreeUI.TreeModelHandler, JTree.AccessibleJTree, JTree.TreeModelHandler
public interface TreeModelListener
extends EventListener

定义侦听 TreeModel 中更改的对象的接口。有关更多信息和示例，请参阅 The Java Tutorial 中的How to Write a Tree Model Listener 一节。

方法摘要
void | treeNodesChanged(TreeModelEvent e) 在已经以某种方式更改节点（或同级节点集）后调用。
void | treeNodesInserted(TreeModelEvent e) 在已将节点插入树中以后调用。
void | treeNodesRemoved(TreeModelEvent e) 在已从树中移除节点后调用。
void | treeStructureChanged(TreeModelEvent e) 在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。

方法详细信息

treeNodesChanged

void treeNodesChanged(TreeModelEvent e)

在已经以某种方式更改节点（或同级节点集）后调用。这些节点在树中的位置没有改变，或者说没有更改其子数组，但其他一些属性已发生更改，并且可能影响表示形式。示例：文件的名称已更改，但它仍然在文件系统中的同一位置上。

要指示根已更改，则 childIndices 和 children 将为 null。

可使用 e.getPath() 获得已更改节点的父节点。e.getChildIndices() 返回已更改节点的索引。

treeNodesInserted

void treeNodesInserted(TreeModelEvent e)

在已将节点插入树中以后调用。

可使用 e.getPath() 获得新节点的父节点。e.getChildIndices() 按升序返回新节点的索引。

treeNodesRemoved

void treeNodesRemoved(TreeModelEvent e)

在已从树中移除节点后调用。注意，如果从树中移除一个子树，则可能仅对已移除子树的根调用此方法一次，而不是对每个已移除的同级子树集调用一次。

可使用 e.getPath() 获得已删除节点的前父节点。e.getChildIndices() 按升序返回删除此节点前该节点所拥有的索引。

treeStructureChanged

void treeStructureChanged(TreeModelEvent e)

在树结构中从某个给定节点开始向下的地方发生彻底更改之后调用。如果由 e.getPath() 返回的路径长度为 1，并且第一个元素并没有标识当前根节点，则第一个元素应该成为树的新根。

可使用 e.getPath() 获得到该节点的路径。e.getChildIndices() 返回 null。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeSelectionEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 TreeSelectionEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.TreeSelectionEvent
所有已实现的接口：
Serializable
public class TreeSelectionEvent
extends EventObject

描述当前选择中的更改的事件。该更改以任意数量的路径为基础。TreeSelectionListener 通常将查询事件源，以获得每个可能更改行的新选定状态。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

另请参见：
TreeSelectionListener, TreeSelectionModel

字段摘要
protected boolean[] | areNew 对于每条路径，标识该路径实际上是否为一条新路径。
protected TreePath | newLeadSelectionPath 在路径被更改之后的 leadSelectionPath，可能为 null。
protected TreePath | oldLeadSelectionPath 在路径被更改之前的 leadSelectionPath，可能为 null。
protected TreePath[] | paths 此事件表示的路径。
从类 java.util.EventObject 继承的字段
source
构造方法摘要
TreeSelectionEvent(Object source, TreePath[] paths, boolean[] areNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。
TreeSelectionEvent(Object source, TreePath path, boolean isNew, TreePath oldLeadSelectionPath, TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。
方法摘要
Object | cloneWithSource(Object newSource) 返回接收方的副本，但带有将成为 newSource 的源。
TreePath | getNewLeadSelectionPath() 返回当前前导路径。
TreePath | getOldLeadSelectionPath() 返回以前是前导路径的路径。
TreePath | getPath() 返回第一个路径元素。
TreePath[] | getPaths() 返回已经添加到该选择中或已从中移除的路径。
boolean | isAddedPath() 如果已经将第一个路径元素添加到选择中，则返回 true。
boolean | isAddedPath(int index) 如果由 index 标识的路径被添加到选择中，则返回 true。
boolean | isAddedPath(TreePath path) 如果 path 标识的路径被添加到选择中，则返回 true。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

字段详细信息

paths

protected TreePath[] paths
此事件表示的路径。

areNew

protected boolean[] areNew
对于每条路径，标识该路径实际上是否为一条新路径。

oldLeadSelectionPath

protected TreePath oldLeadSelectionPath
在路径被更改之前的 leadSelectionPath，可能为 null。

newLeadSelectionPath

protected TreePath newLeadSelectionPath
在路径被更改之后的 leadSelectionPath，可能为 null。

构造方法详细信息

TreeSelectionEvent

public TreeSelectionEvent(Object source,
                          TreePath[] paths,
                          boolean[] areNew,
                          TreePath oldLeadSelectionPath,
                          TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。paths 标识已经添加到该选择中或已从中移除的路径。

参数：
source - 事件源
paths - 在该选择中发生更改的路径

TreeSelectionEvent

public TreeSelectionEvent(Object source,
                          TreePath path,
                          boolean isNew,
                          TreePath oldLeadSelectionPath,
                          TreePath newLeadSelectionPath)
表示 TreeSelectionModel 选择中的更改。path 标识已经添加到该选择中或已从中移除的路径。

参数：
source - 事件源
path - 在该选择中发生更改的路径
isNew - 某条路径对于该选择而言是否为新路径，false 表示路径从该选择中被移除。
方法详细信息

getPaths

public TreePath[] getPaths()
返回已经添加到该选择中或已从中移除的路径。

getPath

public TreePath getPath()
返回第一个路径元素。

isAddedPath

public boolean isAddedPath()
如果已经将第一个路径元素添加到选择中，则返回 true。返回 false 值意味着第一条路径已从选择中移除。

isAddedPath

public boolean isAddedPath(TreePath path)
如果 path 标识的路径被添加到选择中，则返回 true。返回 false 值意味着该路径过去在该选择中，但现在不再在该选择中。如果 path 是此事件标识的路径之一，则此方法将被激活。

isAddedPath

public boolean isAddedPath(int index)
如果由 index 标识的路径被添加到选择中，则返回 true。返回 false 值意味着该路径过去在该选择中，但现在不再在该选择中。如果 index < 0 || >= getPaths.length，则此方法将被激活。

从以下版本开始：
1.3

getOldLeadSelectionPath

public TreePath getOldLeadSelectionPath()
返回以前是前导路径的路径。

getNewLeadSelectionPath

public TreePath getNewLeadSelectionPath()
返回当前前导路径。

cloneWithSource

public Object cloneWithSource(Object newSource)
返回接收方的副本，但带有将成为 newSource 的源。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeSelectionListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 TreeSelectionListener

所有超级接口：
EventListener
所有已知实现类：
BasicTreeUI.TreeSelectionHandler, DefaultTreeCellEditor, JTree.AccessibleJTree, JTree.TreeSelectionRedirector
public interface TreeSelectionListener
extends EventListener

当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。有关更多的信息和示例，请参阅 The Java Tutorial 中的 How to Write a Tree Selection Listener 一节。

另请参见：
TreeSelectionModel, JTree

方法摘要
 void valueChanged(TreeSelectionEvent e)
每当选择值发生更改时调用。

方法详细信息

valueChanged

void valueChanged(TreeSelectionEvent e)
每当选择值发生更改时调用。

参数：
e - 表现更改的特征的事件。
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


TreeWillExpandListener (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 TreeWillExpandListener

所有超级接口：
EventListener
public interface TreeWillExpandListener
extends EventListener

当树扩展或折叠某一节点时获得通知的侦听器。有关更多信息和示例，请参阅 The Java Tutorial 中的 How to Write a Tree-Will-Expand Listener 一节。

方法摘要
void | treeWillCollapse(TreeExpansionEvent event) 每当树中的一个节点将被折叠时调用。
void | treeWillExpand(TreeExpansionEvent event) 每当树中的一个节点将被扩展时调用。

方法详细信息

treeWillExpand

void treeWillExpand(TreeExpansionEvent event)
                    throws ExpandVetoException
每当树中的一个节点将被扩展时调用。

抛出：
ExpandVetoException

treeWillCollapse

void treeWillCollapse(TreeExpansionEvent event)
                      throws ExpandVetoException
每当树中的一个节点将被折叠时调用。

抛出：
ExpandVetoException
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UndoableEditEvent (Java 2 Platform SE 6)

上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
类 UndoableEditEvent

java.lang.Object
    继承者  java.util.EventObject
        继承者  javax.swing.event.UndoableEditEvent
所有已实现的接口：
Serializable
public class UndoableEditEvent
extends EventObject

指示发生了可撤消操作的事件。

警告：此类的序列化对象将与以后的 Swing 版本不兼容。当前的序列化支持适用于短期存储或运行相同 Swing 版本的应用程序之间的 RMI。从 1.4 版本开始，已在 java.beans 包中添加了支持所有 JavaBeansTM 长期存储的功能。请参见 XMLEncoder。

字段摘要
从类 java.util.EventObject 继承的字段
source
构造方法摘要
UndoableEditEvent(Object source, UndoableEdit edit)
构造一个 UndoableEditEvent 对象。
方法摘要
 UndoableEdit getEdit()
返回 edit 值。
从类 java.util.EventObject 继承的方法
getSource, toString
从类 java.lang.Object 继承的方法
clone, equals, finalize, getClass, hashCode, notify, notifyAll, wait, wait, wait

构造方法详细信息

UndoableEditEvent

public UndoableEditEvent(Object source,
                         UndoableEdit edit)
构造一个 UndoableEditEvent 对象。

参数：
source - 发起事件的 Object（通常为 this）
edit - 一个 UndoableEdit 对象
方法详细信息

getEdit

public UndoableEdit getEdit()
返回 edit 值。

返回：
封装 edit 的 UndoableEdit 对象
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 详细信息： 字段 | 构造方法 | 方法


UndoableEditListener (Java 2 Platform SE 6)

上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法

javax.swing.event
接口 UndoableEditListener

所有超级接口：
EventListener
所有已知实现类：
UndoManager
public interface UndoableEditListener
extends EventListener

该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。

方法摘要
 void undoableEditHappened(UndoableEditEvent e)
发生了可撤消的编辑操作

方法详细信息

undoableEditHappened

void undoableEditHappened(UndoableEditEvent e)
发生了可撤消的编辑操作

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个类 下一个类 | 框架 无框架
摘要： 嵌套 | 字段 | 构造方法 | 方法 | 详细信息： 字段 | 构造方法 | 方法


javax.swing.event (Java 2 Platform SE 6)

 javax.swing.event
接口
AncestorListener
CaretListener
CellEditorListener
ChangeListener
DocumentEvent
DocumentEvent.ElementChange
DocumentListener
HyperlinkListener
InternalFrameListener
ListDataListener
ListSelectionListener
MenuDragMouseListener
MenuKeyListener
MenuListener
MouseInputListener
PopupMenuListener
RowSorterListener
TableColumnModelListener
TableModelListener
TreeExpansionListener
TreeModelListener
TreeSelectionListener
TreeWillExpandListener
UndoableEditListener
类
AncestorEvent
CaretEvent
ChangeEvent
DocumentEvent.EventType
EventListenerList
HyperlinkEvent
HyperlinkEvent.EventType
InternalFrameAdapter
InternalFrameEvent
ListDataEvent
ListSelectionEvent
MenuDragMouseEvent
MenuEvent
MenuKeyEvent
MouseInputAdapter
PopupMenuEvent
RowSorterEvent
SwingPropertyChangeSupport
TableColumnModelEvent
TableModelEvent
TreeExpansionEvent
TreeModelEvent
TreeSelectionEvent
UndoableEditEvent
枚举
RowSorterEvent.Type


javax.swing.event (Java 2 Platform SE 6)

上一个软件包 下一个软件包 框架 无框架

软件包 javax.swing.event

供 Swing 组件触发的事件使用。

请参见：
描述

接口摘要
AncestorListener | AncestorListener 接口支持 JComponent 或其祖先之一发生更改时进行通知。
CaretListener | 用于侦听文本组件插入符的位置更改的侦听器。
CellEditorListener | CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
ChangeListener | 定义一个侦听 ChangeEvent 的对象。
DocumentEvent | 用于文档更改通知的接口。
DocumentEvent.ElementChange | 描述对特定元素所做的更改。
DocumentListener | 观察者使用该接口注册以接收文本文档的更改通知。
HyperlinkListener | HyperlinkListener
InternalFrameListener | 用于接收内部窗体事件的侦听器接口。
ListDataListener | ListDataListener
ListSelectionListener | 列表选择值发生更改时收到通知的侦听器。
MenuDragMouseListener | 定义一个菜单鼠标拖动侦听器。
MenuKeyListener | MenuKeyListener
MenuListener | 定义一个菜单事件侦听器。
MouseInputListener | 实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。
PopupMenuListener | 弹出菜单侦听器
RowSorterListener | 通知 RowSorterListener 对 RowSorter 的更改。
TableColumnModelListener | TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。
TableModelListener | TableModelListener 定义侦听 TableModel 中更改的对象的接口。
TreeExpansionListener | 当树扩展或折叠某一节点时获得通知的侦听器。
TreeModelListener | 定义侦听 TreeModel 中更改的对象的接口。
TreeSelectionListener | 当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。
TreeWillExpandListener | 当树扩展或折叠某一节点时获得通知的侦听器。
UndoableEditListener | 该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。

类摘要
AncestorEvent | 报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
CaretEvent | CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
ChangeEvent | ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
DocumentEvent.EventType | 文档事件类型的枚举
EventListenerList | 保存 EventListener 列表的类。
HyperlinkEvent | HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
HyperlinkEvent.EventType | 定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。
InternalFrameAdapter | 用于接收内部窗体事件的抽象适配器类。
InternalFrameEvent | 以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
ListDataEvent | 定义一个封装列表更改的事件。
ListSelectionEvent | 表现选择中更改的特征的事件。
MenuDragMouseEvent | MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
MenuEvent | MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
MenuKeyEvent | MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
MouseInputAdapter | MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。
PopupMenuEvent | PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
RowSorterEvent | RowSorterEvent 提供 RowSorter 的更改通知。
SwingPropertyChangeSupport | java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。
TableColumnModelEvent | TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
TableModelEvent | TableModelEvent 用于通知侦听器某一表模型已发生更改。
TreeExpansionEvent | 用于标识树中的单个路径的事件。
TreeModelEvent | 封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
TreeSelectionEvent | 描述当前选择中的更改的事件。
UndoableEditEvent | 指示发生了可撤消操作的事件。

枚举摘要
RowSorterEvent.Type RowSorterEvent 类型的枚举。

软件包 javax.swing.event 的描述

供 Swing 组件触发的事件使用。除了 java.awt.event 包中的事件之外，还包括 Swing 组件触发的事件的事件类和相应事件侦听器接口。

注： 大多数 Swing API 都不是 线程安全的。有关详细信息，请参阅 The Java Tutorial 中的 Threads and Swing 一节。

相关文档

有关概述、教程、示例、指南和工具文档的信息，请参阅：
  • The Java Tutorial 中的 Writing Event Listeners 一节。

从以下版本开始：
1.2
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个软件包 下一个软件包 框架 无框架


javax.swing.event 类分层结构 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.event 的分层结构

软件包分层结构：
所有软件包

类分层结构

  • java.lang.Object
    • javax.swing.event.DocumentEvent.EventType
    • javax.swing.event.EventListenerList (implements java.io.Serializable)
    • java.util.EventObject (implements java.io.Serializable)
      • java.awt.AWTEvent
        • javax.swing.event.AncestorEvent
        • java.awt.event.ComponentEvent
          • java.awt.event.InputEvent
            • java.awt.event.KeyEvent
              • javax.swing.event.MenuKeyEvent
            • java.awt.event.MouseEvent
              • javax.swing.event.MenuDragMouseEvent
        • javax.swing.event.InternalFrameEvent
      • javax.swing.event.CaretEvent
      • javax.swing.event.ChangeEvent
      • javax.swing.event.HyperlinkEvent
      • javax.swing.event.ListDataEvent
      • javax.swing.event.ListSelectionEvent
      • javax.swing.event.MenuEvent
      • javax.swing.event.PopupMenuEvent
      • javax.swing.event.RowSorterEvent
      • javax.swing.event.TableColumnModelEvent
      • javax.swing.event.TableModelEvent
      • javax.swing.event.TreeExpansionEvent
      • javax.swing.event.TreeModelEvent
      • javax.swing.event.TreeSelectionEvent
      • javax.swing.event.UndoableEditEvent
    • javax.swing.event.HyperlinkEvent.EventType
    • javax.swing.event.InternalFrameAdapter (implements javax.swing.event.InternalFrameListener)
    • java.awt.event.MouseAdapter (implements java.awt.event.MouseListener, java.awt.event.MouseMotionListener, java.awt.event.MouseWheelListener)
      • javax.swing.event.MouseInputAdapter (implements javax.swing.event.MouseInputListener)
    • java.beans.PropertyChangeSupport (implements java.io.Serializable)
      • javax.swing.event.SwingPropertyChangeSupport

接口分层结构

  • javax.swing.event.DocumentEvent
  • javax.swing.event.DocumentEvent.ElementChange
  • java.util.EventListener
    • javax.swing.event.AncestorListener
    • javax.swing.event.CaretListener
    • javax.swing.event.CellEditorListener
    • javax.swing.event.ChangeListener
    • javax.swing.event.DocumentListener
    • javax.swing.event.HyperlinkListener
    • javax.swing.event.InternalFrameListener
    • javax.swing.event.ListDataListener
    • javax.swing.event.ListSelectionListener
    • javax.swing.event.MenuDragMouseListener
    • javax.swing.event.MenuKeyListener
    • javax.swing.event.MenuListener
    • java.awt.event.MouseListener
      • javax.swing.event.MouseInputListener (并 extends java.awt.event.MouseMotionListener)
    • java.awt.event.MouseMotionListener
      • javax.swing.event.MouseInputListener (并 extends java.awt.event.MouseListener)
    • javax.swing.event.PopupMenuListener
    • javax.swing.event.RowSorterListener
    • javax.swing.event.TableColumnModelListener
    • javax.swing.event.TableModelListener
    • javax.swing.event.TreeExpansionListener
    • javax.swing.event.TreeModelListener
    • javax.swing.event.TreeSelectionListener
    • javax.swing.event.TreeWillExpandListener
    • javax.swing.event.UndoableEditListener

枚举分层结构

  • java.lang.Object
    • java.lang.Enum<E> (implements java.lang.Comparable<T>, java.io.Serializable)
      • javax.swing.event.RowSorterEvent.Type
概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


软件包 javax.swing.event 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

软件包 javax.swing.event
的使用

使用 javax.swing.event 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.colorchooser | 包含供 JColorChooser 组件使用的类和接口。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.plaf.metal | 提供根据 Java 外观（曾经代称为 Metal）构建的用户界面对象，Java 外观是默认外观。
javax.swing.table | 提供用于处理 javax.swing.JTable 的类和接口。
javax.swing.text | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。
javax.swing.undo | 允许开发人员为应用程序（例如文本编辑器）中的撤消/恢复提供支持。

javax.swing 使用的 javax.swing.event 中的类
AncestorListener
AncestorListener 接口支持 JComponent 或其祖先之一发生更改时进行通知。
CaretListener
用于侦听文本组件插入符的位置更改的侦听器。
CellEditorListener
CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
ChangeListener
定义一个侦听 ChangeEvent 的对象。
DocumentListener
观察者使用该接口注册以接收文本文档的更改通知。
EventListenerList
保存 EventListener 列表的类。
HyperlinkEvent
HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
HyperlinkListener
HyperlinkListener
InternalFrameListener
用于接收内部窗体事件的侦听器接口。
ListDataEvent
定义一个封装列表更改的事件。
ListDataListener
ListDataListener
ListSelectionEvent
表现选择中更改的特征的事件。
ListSelectionListener
列表选择值发生更改时收到通知的侦听器。
MenuDragMouseEvent
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
MenuDragMouseListener
定义一个菜单鼠标拖动侦听器。
MenuKeyEvent
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
MenuKeyListener
MenuKeyListener
MenuListener
定义一个菜单事件侦听器。
PopupMenuListener
弹出菜单侦听器
RowSorterEvent
RowSorterEvent 提供 RowSorter 的更改通知。
RowSorterListener
通知 RowSorterListener 对 RowSorter 的更改。
SwingPropertyChangeSupport
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。
TableColumnModelEvent
TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
TableColumnModelListener
TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。
TableModelEvent
TableModelEvent 用于通知侦听器某一表模型已发生更改。
TableModelListener
TableModelListener 定义侦听 TableModel 中更改的对象的接口。
TreeExpansionEvent
用于标识树中的单个路径的事件。
TreeExpansionListener
当树扩展或折叠某一节点时获得通知的侦听器。
TreeModelEvent
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
TreeModelListener
定义侦听 TreeModel 中更改的对象的接口。
TreeSelectionEvent
描述当前选择中的更改的事件。
TreeSelectionListener
当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。
TreeWillExpandListener
当树扩展或折叠某一节点时获得通知的侦听器。

javax.swing.colorchooser 使用的 javax.swing.event 中的类
ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
ChangeListener
定义一个侦听 ChangeEvent 的对象。
EventListenerList
保存 EventListener 列表的类。

javax.swing.event 使用的 javax.swing.event 中的类
AncestorEvent
报告给子组件的事件，该子组件源自组件层次结构中的某个祖先。
CaretEvent
CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
DocumentEvent
用于文档更改通知的接口。
DocumentEvent.ElementChange
描述对特定元素所做的更改。
DocumentEvent.EventType
文档事件类型的枚举
HyperlinkEvent
HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
HyperlinkEvent.EventType
定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。
InternalFrameEvent
以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
InternalFrameListener
用于接收内部窗体事件的侦听器接口。
ListDataEvent
定义一个封装列表更改的事件。
ListSelectionEvent
表现选择中更改的特征的事件。
MenuDragMouseEvent
MenuDragMouseEvent 用于通知对此进行侦听的参与者在拖动情况下菜单元素已经收到转发给它的 MouseEvent。
MenuEvent
MenuEvent 用于通知感兴趣的参与者作为事件源的菜单已经被发送、选定或取消。
MenuKeyEvent
MenuKeyEvent 用于通知感兴趣的参与者菜单元素已在菜单树中接收转发给它的 KeyEvent。
MouseInputListener
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。
PopupMenuEvent
PopupMenuEvent 只包含事件源，该事件源是发送事件的 JPoupMenu 警告：此类的序列化对象将与以后的 Swing 版本不兼容。
RowSorterEvent
RowSorterEvent 提供 RowSorter 的更改通知。
RowSorterEvent.Type
RowSorterEvent 类型的枚举。
TableColumnModelEvent
TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
TableModelEvent
TableModelEvent 用于通知侦听器某一表模型已发生更改。
TreeExpansionEvent
用于标识树中的单个路径的事件。
TreeModelEvent
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
TreeSelectionEvent
描述当前选择中的更改的事件。
UndoableEditEvent
指示发生了可撤消操作的事件。

javax.swing.plaf.basic 使用的 javax.swing.event 中的类
CellEditorListener
CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
ChangeListener
定义一个侦听 ChangeEvent 的对象。
InternalFrameEvent
以事件源的形式添加对 JInternalFrame 对象的支持的 AWTEvent。
InternalFrameListener
用于接收内部窗体事件的侦听器接口。
ListDataEvent
定义一个封装列表更改的事件。
ListDataListener
ListDataListener
ListSelectionEvent
表现选择中更改的特征的事件。
ListSelectionListener
列表选择值发生更改时收到通知的侦听器。
MenuDragMouseListener
定义一个菜单鼠标拖动侦听器。
MenuKeyListener
MenuKeyListener
MenuListener
定义一个菜单事件侦听器。
MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。
MouseInputListener
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。
TreeExpansionEvent
用于标识树中的单个路径的事件。
TreeExpansionListener
当树扩展或折叠某一节点时获得通知的侦听器。
TreeModelEvent
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
TreeModelListener
定义侦听 TreeModel 中更改的对象的接口。
TreeSelectionEvent
描述当前选择中的更改的事件。
TreeSelectionListener
当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。

javax.swing.plaf.metal 使用的 javax.swing.event 中的类
ListSelectionEvent
表现选择中更改的特征的事件。
ListSelectionListener
列表选择值发生更改时收到通知的侦听器。
MouseInputAdapter
MouseInputListener 接口的一个空实现，提供此类作为简化创建侦听器任务的一种便捷方式，它只扩展和实现需要的方法。
MouseInputListener
实现 MouseListener 和 MouseMotionListener 接口中的所有方法的侦听器。

javax.swing.table 使用的 javax.swing.event 中的类
ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
EventListenerList
保存 EventListener 列表的类。
ListSelectionEvent
表现选择中更改的特征的事件。
ListSelectionListener
列表选择值发生更改时收到通知的侦听器。
TableColumnModelEvent
TableColumnModelEvent 用于通知侦听器某一个表的列模型已发生更改，比如添加、移除或移动列。
TableColumnModelListener
TableColumnModelListener 定义侦听 TableColumnModel 中更改的对象的接口。
TableModelEvent
TableModelEvent 用于通知侦听器某一表模型已发生更改。
TableModelListener
TableModelListener 定义侦听 TableModel 中更改的对象的接口。

javax.swing.text 使用的 javax.swing.event 中的类
CaretEvent
CaretEvent 用于通知感兴趣的参与者事件源中的文本插入符已发生更改。
CaretListener
用于侦听文本组件插入符的位置更改的侦听器。
ChangeEvent
ChangeEvent 用于通知感兴趣的参与者事件源中的状态已发生更改。
ChangeListener
定义一个侦听 ChangeEvent 的对象。
DocumentEvent
用于文档更改通知的接口。
DocumentEvent.ElementChange
描述对特定元素所做的更改。
DocumentEvent.EventType
文档事件类型的枚举
DocumentListener
观察者使用该接口注册以接收文本文档的更改通知。
EventListenerList
保存 EventListener 列表的类。
UndoableEditEvent
指示发生了可撤消操作的事件。
UndoableEditListener
该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。

javax.swing.text.html 使用的 javax.swing.event 中的类
DocumentEvent
用于文档更改通知的接口。
HyperlinkEvent
HyperlinkEvent 用于通知感兴趣的参与者发生了与超文本链接有关的事情。
HyperlinkEvent.EventType
定义 ENTERED、EXITED 和 ACTIVATED 事件类型，以及由 toString() 返回的这些事件类型的字符串表示形式。
UndoableEditEvent
指示发生了可撤消操作的事件。

javax.swing.tree 使用的 javax.swing.event 中的类
CellEditorListener
CellEditorListener 定义用于侦听 CellEditor 中更改的对象的接口
EventListenerList
保存 EventListener 列表的类。
SwingPropertyChangeSupport
java.beans.PropertyChangeSupport 的这一子类在功能上几乎是等效的。
TreeExpansionEvent
用于标识树中的单个路径的事件。
TreeModelEvent
封装描述树模型更改的信息，并用于通知侦听更改的树模型侦听器。
TreeModelListener
定义侦听 TreeModel 中更改的对象的接口。
TreeSelectionEvent
描述当前选择中的更改的事件。
TreeSelectionListener
当 TreeSelectionModel 中的选择发生更改时收到通知的侦听器。

javax.swing.undo 使用的 javax.swing.event 中的类
UndoableEditEvent
指示发生了可撤消操作的事件。
UndoableEditListener
该接口由某个对接收有关可撤消操作的消息感兴趣的类实现。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.HyperlinkEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.HyperlinkEvent
的使用

使用 HyperlinkEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing 中 HyperlinkEvent 的使用

参数类型为 HyperlinkEvent 的 javax.swing 中的方法
 void JEditorPane.fireHyperlinkUpdate(HyperlinkEvent e)
通知因对此事件类型的通知感兴趣而已注册的所有侦听器。

javax.swing.event 中 HyperlinkEvent 的使用

参数类型为 HyperlinkEvent 的 javax.swing.event 中的方法
 void HyperlinkListener.hyperlinkUpdate(HyperlinkEvent e)
在更新超文本链接时调用。

javax.swing.text.html 中 HyperlinkEvent 的使用

javax.swing.text.html 中 HyperlinkEvent 的子类
class | FormSubmitEvent FormSubmitEvent 用于通知提交表单所需的参与者。
class | HTMLFrameHyperlinkEvent HTMLFrameHyperlinkEvent 用于通知感兴趣的参与者框架中的链接已被激活。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.HyperlinkEvent.EventType 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.HyperlinkEvent.EventType
的使用

使用 HyperlinkEvent.EventType 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.text.html | 提供类 HTMLEditorKit 和创建 HTML 文本编辑器的支持类。

javax.swing.event 中 HyperlinkEvent.EventType 的使用

声明为 HyperlinkEvent.EventType 的 javax.swing.event 中的字段
static HyperlinkEvent.EventType | HyperlinkEvent.EventType.ACTIVATED 激活类型。
static HyperlinkEvent.EventType | HyperlinkEvent.EventType.ENTERED 进入类型。
static HyperlinkEvent.EventType | HyperlinkEvent.EventType.EXITED 退出类型。

返回 HyperlinkEvent.EventType 的 javax.swing.event 中的方法
 HyperlinkEvent.EventType HyperlinkEvent.getEventType()
获得事件类型。

参数类型为 HyperlinkEvent.EventType 的 javax.swing.event 中的构造方法
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc)
创建一个表示超文本链接事件的新对象。
HyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL u, String desc, Element sourceElement)
创建一个表示超文本链接事件的新对象。

javax.swing.text.html 中 HyperlinkEvent.EventType 的使用

参数类型为 HyperlinkEvent.EventType 的 javax.swing.text.html 中的构造方法
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String targetFrame)
创建一个表示 html 框架超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, Element sourceElement, String targetFrame)
创建一个表示超文本链接事件的新对象。
HTMLFrameHyperlinkEvent(Object source, HyperlinkEvent.EventType type, URL targetURL, String desc, String targetFrame)
创建一个表示超文本链接事件的新对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.swing.event.HyperlinkListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.HyperlinkListener
的使用

使用 HyperlinkListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 HyperlinkListener 的使用

返回 HyperlinkListener 的 javax.swing 中的方法
 HyperlinkListener[] JEditorPane.getHyperlinkListeners()
返回使用 addHyperlinkListener() 添加到此 JEditorPane 的所有 HyperLinkListener 的数组。

参数类型为 HyperlinkListener 的 javax.swing 中的方法
void | JEditorPane.addHyperlinkListener(HyperlinkListener listener) 为了通知所有的更改（例如选中和进入某个链接）而添加一个超链接侦听器。
void | JEditorPane.removeHyperlinkListener(HyperlinkListener listener) 移除超链接侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.InternalFrameAdapter 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.InternalFrameAdapter
的使用

没有 javax.swing.event.InternalFrameAdapter 的用法

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.InternalFrameEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.InternalFrameEvent
的使用

使用 InternalFrameEvent 的软件包
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing.event 中 InternalFrameEvent 的使用

参数类型为 InternalFrameEvent 的 javax.swing.event 中的方法
void | InternalFrameAdapter.internalFrameActivated(InternalFrameEvent e) 当内部窗体被激活时调用。
void | InternalFrameListener.internalFrameActivated(InternalFrameEvent e) 当内部窗体被激活时调用。
void | InternalFrameAdapter.internalFrameClosed(InternalFrameEvent e) 当内部窗体已关闭时调用。
void | InternalFrameListener.internalFrameClosed(InternalFrameEvent e) 当内部窗体已关闭时调用。
void | InternalFrameAdapter.internalFrameClosing(InternalFrameEvent e) 当内部窗体正被关闭时调用。
void | InternalFrameListener.internalFrameClosing(InternalFrameEvent e) 当内部窗体正被关闭时调用。
void | InternalFrameAdapter.internalFrameDeactivated(InternalFrameEvent e) 当内部窗体被取消激活时调用。
void | InternalFrameListener.internalFrameDeactivated(InternalFrameEvent e) 当内部窗体被取消激活时调用。
void | InternalFrameAdapter.internalFrameDeiconified(InternalFrameEvent e) 当内部窗体被取消图标化时调用。
void | InternalFrameListener.internalFrameDeiconified(InternalFrameEvent e) 当内部窗体被取消图标化时调用。
void | InternalFrameAdapter.internalFrameIconified(InternalFrameEvent e) 当内部窗体被图标化时调用。
void | InternalFrameListener.internalFrameIconified(InternalFrameEvent e) 当内部窗体被图标化时调用。
void | InternalFrameAdapter.internalFrameOpened(InternalFrameEvent e) 当内部窗体已打开时调用。
void | InternalFrameListener.internalFrameOpened(InternalFrameEvent e) 当内部窗体已打开时调用。

javax.swing.plaf.basic 中 InternalFrameEvent 的使用

参数类型为 InternalFrameEvent 的 javax.swing.plaf.basic 中的方法
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameActivated(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameClosed(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameClosing(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameDeactivated(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameDeiconified(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameIconified(InternalFrameEvent e)
void | BasicInternalFrameUI.BasicInternalFrameListener.internalFrameOpened(InternalFrameEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.swing.event.InternalFrameListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.InternalFrameListener
的使用

使用 InternalFrameListener 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 InternalFrameListener 的使用

返回 InternalFrameListener 的 javax.swing 中的方法
 InternalFrameListener[] JInternalFrame.getInternalFrameListeners()
返回使用 addInternalFrameListener 添加到此 JInternalFrame 的所有 InternalFrameListener 的数组。

参数类型为 InternalFrameListener 的 javax.swing 中的方法
void | JInternalFrame.addInternalFrameListener(InternalFrameListener l) 添加指定的侦听器，以从此内部窗体接收内部窗体事件。
void | JInternalFrame.removeInternalFrameListener(InternalFrameListener l) 移除指定的内部窗体侦听器，不再接收此内部窗体发出的内部窗体事件。

javax.swing.event 中 InternalFrameListener 的使用

实现 InternalFrameListener 的 javax.swing.event 中的类
 class InternalFrameAdapter
用于接收内部窗体事件的抽象适配器类。

javax.swing.plaf.basic 中 InternalFrameListener 的使用

实现 InternalFrameListener 的 javax.swing.plaf.basic 中的类
protected  class BasicInternalFrameUI.BasicInternalFrameListener

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.MenuDragMouseEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.MenuDragMouseEvent
的使用

使用 MenuDragMouseEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 MenuDragMouseEvent 的使用

参数类型为 MenuDragMouseEvent 的 javax.swing 中的方法
protected void | JMenuItem.fireMenuDragMouseDragged(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuDragMouseEntered(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuDragMouseExited(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuDragMouseReleased(MenuDragMouseEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
void | JMenuItem.processMenuDragMouseEvent(MenuDragMouseEvent e) 处理菜单中的鼠标拖动。

javax.swing.event 中 MenuDragMouseEvent 的使用

参数类型为 MenuDragMouseEvent 的 javax.swing.event 中的方法
void | MenuDragMouseListener.menuDragMouseDragged(MenuDragMouseEvent e) 当鼠标被拖动到某一菜单组件的显示区域中时调用。
void | MenuDragMouseListener.menuDragMouseEntered(MenuDragMouseEvent e) 当拖动的鼠标进入某一菜单组件的显示区域时调用。
void | MenuDragMouseListener.menuDragMouseExited(MenuDragMouseEvent e) 当拖动的鼠标离开某一菜单组件的显示区域时调用。
void | MenuDragMouseListener.menuDragMouseReleased(MenuDragMouseEvent e) 当在菜单组件的显示区域中释放拖动鼠标时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.MenuKeyEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.MenuKeyEvent
的使用

使用 MenuKeyEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 MenuKeyEvent 的使用

参数类型为 MenuKeyEvent 的 javax.swing 中的方法
protected void | JMenuItem.fireMenuKeyPressed(MenuKeyEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuKeyReleased(MenuKeyEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
protected void | JMenuItem.fireMenuKeyTyped(MenuKeyEvent event) 通知所有对此事件类型上的通知感兴趣的已注册侦听器。
void | JMenuItem.processMenuKeyEvent(MenuKeyEvent e) 处理菜单中的快捷键。

javax.swing.event 中 MenuKeyEvent 的使用

参数类型为 MenuKeyEvent 的 javax.swing.event 中的方法
void | MenuKeyListener.menuKeyPressed(MenuKeyEvent e) 已按下某个键时调用。
void | MenuKeyListener.menuKeyReleased(MenuKeyEvent e) 已释放某个键时调用。
void | MenuKeyListener.menuKeyTyped(MenuKeyEvent e) 已键入某个键时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.PopupMenuEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.PopupMenuEvent
的使用

使用 PopupMenuEvent 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 PopupMenuEvent 的使用

参数类型为 PopupMenuEvent 的 javax.swing.event 中的方法
void | PopupMenuListener.popupMenuCanceled(PopupMenuEvent e) 此方法在弹出菜单被取消时调用。
void | PopupMenuListener.popupMenuWillBecomeInvisible(PopupMenuEvent e) 此方法在弹出菜单变得不可见之前调用。
void | PopupMenuListener.popupMenuWillBecomeVisible(PopupMenuEvent e) 此方法在弹出菜单变得可见之前调用

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.RowSorterEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.RowSorterEvent
的使用

使用 RowSorterEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。

javax.swing 中 RowSorterEvent 的使用

参数类型为 RowSorterEvent 的 javax.swing 中的方法
 void JTable.sorterChanged(RowSorterEvent e)
RowSorter 以某种方式发生了更改的 RowSorterListener 通知。

javax.swing.event 中 RowSorterEvent 的使用

参数类型为 RowSorterEvent 的 javax.swing.event 中的方法
 void RowSorterListener.sorterChanged(RowSorterEvent e)
RowSorter 发生了更改的通知。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.RowSorterEvent.Type 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.RowSorterEvent.Type
的使用

使用 RowSorterEvent.Type 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 RowSorterEvent.Type 的使用

返回 RowSorterEvent.Type 的 javax.swing.event 中的方法
RowSorterEvent.Type | RowSorterEvent.getType() 返回事件的类型。
static RowSorterEvent.Type | RowSorterEvent.Type.valueOf(String name) 返回带有指定名称的该类型的枚举常量。
static RowSorterEvent.Type[] | RowSorterEvent.Type.values() Returns an array containing the constants of this enum type, in the order they are declared.

参数类型为 RowSorterEvent.Type 的 javax.swing.event 中的构造方法
RowSorterEvent(RowSorter source, RowSorterEvent.Type type, int[] previousRowIndexToModel)
创建一个 RowSorterEvent。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.TreeExpansionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.TreeExpansionEvent
的使用

使用 TreeExpansionEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeExpansionEvent 的使用

参数类型为 TreeExpansionEvent 的 javax.swing 中的方法
void | JTree.AccessibleJTree.treeCollapsed(TreeExpansionEvent e) 树折叠通知。
void | JTree.AccessibleJTree.treeExpanded(TreeExpansionEvent e) 树模型展开通知。

javax.swing.event 中 TreeExpansionEvent 的使用

参数类型为 TreeExpansionEvent 的 javax.swing.event 中的方法
void | TreeExpansionListener.treeCollapsed(TreeExpansionEvent event) 每当树中的一个项被折叠时调用。
void | TreeExpansionListener.treeExpanded(TreeExpansionEvent event) 每当树中的一个项被扩展时调用。
void | TreeWillExpandListener.treeWillCollapse(TreeExpansionEvent event) 每当树中的一个节点将被折叠时调用。
void | TreeWillExpandListener.treeWillExpand(TreeExpansionEvent event) 每当树中的一个节点将被扩展时调用。

javax.swing.plaf.basic 中 TreeExpansionEvent 的使用

参数类型为 TreeExpansionEvent 的 javax.swing.plaf.basic 中的方法
void | BasicTreeUI.TreeExpansionHandler.treeCollapsed(TreeExpansionEvent event) 每当树中的项被折叠时调用。
void | BasicTreeUI.TreeExpansionHandler.treeExpanded(TreeExpansionEvent event) 每当树中的项被展开时调用。

javax.swing.tree 中 TreeExpansionEvent 的使用

声明为 TreeExpansionEvent 的 javax.swing.tree 中的字段
protected  TreeExpansionEvent ExpandVetoException.event
为其创建异常的事件。

参数类型为 TreeExpansionEvent 的 javax.swing.tree 中的构造方法
ExpandVetoException(TreeExpansionEvent event)
构造不带任何消息的 ExpandVetoException 对象。
ExpandVetoException(TreeExpansionEvent event, String message)
构造带指定消息的 ExpandVetoException 对象。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


接口 javax.swing.event.TreeWillExpandListener 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

接口 javax.swing.event.TreeWillExpandListener
的使用

使用 TreeWillExpandListener 的软件包
javax.swing 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。

javax.swing 中 TreeWillExpandListener 的使用

返回 TreeWillExpandListener 的 javax.swing 中的方法
 TreeWillExpandListener[] JTree.getTreeWillExpandListeners()
返回使用 addTreeWillExpandListener() 添加到此 JTree 的所有 TreeWillExpandListener 的数组。

参数类型为 TreeWillExpandListener 的 javax.swing 中的方法
void | JTree.addTreeWillExpandListener(TreeWillExpandListener tel) 为 TreeWillExpand 事件添加侦听器。
void | JTree.removeTreeWillExpandListener(TreeWillExpandListener tel) 移除 TreeWillExpand 事件的侦听器。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.AncestorEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.AncestorEvent
的使用

使用 AncestorEvent 的软件包
javax.swing.event 供 Swing 组件触发的事件使用。

javax.swing.event 中 AncestorEvent 的使用

参数类型为 AncestorEvent 的 javax.swing.event 中的方法
void | AncestorListener.ancestorAdded(AncestorEvent event) 当通过调用 setVisible(true) 或将其添加到组件层次结构中而使源组件或其祖先之一变得可见时调用。
void | AncestorListener.ancestorMoved(AncestorEvent event) 在源组件或其祖先之一被移动时调用。
void | AncestorListener.ancestorRemoved(AncestorEvent event) 当通过调用 setVisible(false) 或将其从组件层次结构中移除而使源组件或其祖先之一变得不可见时调用。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.ListDataEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.ListDataEvent
的使用

使用 ListDataEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。

javax.swing 中 ListDataEvent 的使用

参数类型为 ListDataEvent 的 javax.swing 中的方法
void | JList.AccessibleJList.contentsChanged(ListDataEvent e) List Data Listener 内容更改方法。
void | JComboBox.contentsChanged(ListDataEvent e) 此方法作为实现的副作用存在的公共方法。
void | JList.AccessibleJList.intervalAdded(ListDataEvent e) List Data Listener 间隔添加方法。
void | JComboBox.intervalAdded(ListDataEvent e) 此方法作为实现的副作用存在的公共方法。
void | JList.AccessibleJList.intervalRemoved(ListDataEvent e) List Data Listener 间隔移除方法。
void | JComboBox.intervalRemoved(ListDataEvent e) 此方法作为实现的副作用存在的公共方法。

javax.swing.event 中 ListDataEvent 的使用

参数类型为 ListDataEvent 的 javax.swing.event 中的方法
void | ListDataListener.contentsChanged(ListDataEvent e) 在列表的内容以某种太过复杂以至用以前的方法难以描述的方式发生更改时发送。
void | ListDataListener.intervalAdded(ListDataEvent e) 在已将 index0,index1 区间中的索引插入数据模型中之后发送。
void | ListDataListener.intervalRemoved(ListDataEvent e) 在已将 index0,index1 区间中的索引从数据模型中移除后发送。

javax.swing.plaf.basic 中 ListDataEvent 的使用

参数类型为 ListDataEvent 的 javax.swing.plaf.basic 中的方法
void | BasicListUI.ListDataHandler.contentsChanged(ListDataEvent e)
void | BasicComboPopup.ListDataHandler.contentsChanged(ListDataEvent e)
void | BasicComboBoxUI.ListDataHandler.contentsChanged(ListDataEvent e)
void | BasicDirectoryModel.intervalAdded(ListDataEvent e) 废弃，不使用。
void | BasicListUI.ListDataHandler.intervalAdded(ListDataEvent e)
void | BasicComboPopup.ListDataHandler.intervalAdded(ListDataEvent e)
void | BasicComboBoxUI.ListDataHandler.intervalAdded(ListDataEvent e)
void | BasicDirectoryModel.intervalRemoved(ListDataEvent e) 废弃，不使用。
void | BasicListUI.ListDataHandler.intervalRemoved(ListDataEvent e)
void | BasicComboPopup.ListDataHandler.intervalRemoved(ListDataEvent e)
void | BasicComboBoxUI.ListDataHandler.intervalRemoved(ListDataEvent e)

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架


类 javax.swing.event.TreeSelectionEvent 的使用 (Java 2 Platform SE 6)

上一个 下一个 框架 无框架

类 javax.swing.event.TreeSelectionEvent
的使用

使用 TreeSelectionEvent 的软件包
javax.swing | 提供一组“轻量级”（全部是 Java 语言）组件，尽量让这些组件在所有平台上的工作方式都相同。
javax.swing.event | 供 Swing 组件触发的事件使用。
javax.swing.plaf.basic | 提供了根据基本外观构建的用户界面对象。
javax.swing.tree | 提供处理 javax.swing.JTree 的类和接口。

javax.swing 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing 中的方法
protected void | JTree.fireValueChanged(TreeSelectionEvent e) 通知已注册对获得此事件类型通知感兴趣的所有侦听器。
void | JTree.TreeSelectionRedirector.valueChanged(TreeSelectionEvent e) 在选择更改时由 TreeSelectionModel 调用。
void | JTree.AccessibleJTree.valueChanged(TreeSelectionEvent e) 树选择侦听器值更改方法。

javax.swing.event 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing.event 中的方法
 void TreeSelectionListener.valueChanged(TreeSelectionEvent e)
每当选择值发生更改时调用。

javax.swing.plaf.basic 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing.plaf.basic 中的方法
 void BasicTreeUI.TreeSelectionHandler.valueChanged(TreeSelectionEvent event)
当显示的树中发生选择更改时传递消息。

javax.swing.tree 中 TreeSelectionEvent 的使用

参数类型为 TreeSelectionEvent 的 javax.swing.tree 中的方法
protected void | DefaultTreeSelectionModel.fireValueChanged(TreeSelectionEvent e) 通知已注册此对象上的树选择事件的所有侦听器。
void | DefaultTreeCellEditor.valueChanged(TreeSelectionEvent e) 重置 lastPath。

概述 软件包 类 使用 树 已过时 索引 帮助
JavaTM 2 Platform
Standard Ed. 6
上一个 下一个 框架 无框架